Manual de PHP

por:
Mehdi Achour
Friedhelm Betz
Antony Dovgal
Nuno Lopes
Hannes Magnusson
Georg Richter
Damien Seguy
Jakub Vrana
Y muchos otros
2021-03-15
Editado por: Peter Cowburn
por:
¿Quieres ayudarnos a traducir? Ponte en contacto con: seros[arroba]php.net
Traduciendo desde Dic-2009. Estado: 80% completo y al día.
Lista de encargados del mantenimiento y traducción por número de ficheros:
1. Pedro Antonio Gil Rodríguez 2. Andrés García 3. Yago Ferrer 4. Jesús Ruiz-Ayúcar Vázquez 5. Juan Pablo Berdejo 6. Alexander Garzon 7. Jesús Ruiz García 8. Marta Regina Cano Jiménez 9. Leonardo Boshell 10. Francisco José Naranjo Abad 11. Jesús Rafael Cova Huerta 12. Jorge Eduardo Olaya P. 13. Edwin Cartagena Hdez. 14. Jesús Díez 15. Diego Agulló Falcó 16. Ernesto Mediavilla del Río 17. Carlos Hernández Afan de Ribera 18. Waldo Malqui Silva 19. Braian Iván Monnier 20. José Mercedes Venegas Acevedo
y muchos más...
© 1997-2021 the PHP Documentation Group
  • Copyright
  • Manual de PHP
    • Prefacio
  • Conceptos básicos
    • Introducción
    • Un tutorial sencillo
  • Instalación y configuración
    • Consideraciones generales de instalación
    • Instalación sobre sistemas Unix
    • Instalación en Mac OS X
    • Instalación en sistemas Windows
    • Instalación en las plataformas de Nube Informática
    • Manejador de Procesos FastCGI (FPM)
    • Instalación de extensiones PECL
    • Resolución de problemas
    • Configuración en tiempo de ejecución
  • Referencia del lenguaje
    • Sintaxis básica
    • Tipos
    • Variables
    • Constantes
    • Expresiones
    • Operadores
    • Estructuras de Control
    • Funciones
    • Clases y objetos
    • Espacios de nombres
    • Errores
    • Excepciones
    • Generadores
    • Attributes
    • Explicación de las Referencias
    • Variables predefinidas
    • Excepciones predefinidas
    • Interfaces y clases predefinidas
    • Opciones y parámetros de contexto
    • Protocolos y Envolturas soportados
  • Seguridad
    • Introducción
    • Consideraciones generales
    • Instalado como CGI binario
    • Instalado como módulo de Apache
    • Seguridad de una Sesión
    • Seguridad del Sistema de Archivos
    • Seguridad en bases de datos
    • Reportando errores
    • Datos Enviados por el Usuario
    • Ocultar PHP
    • Mantenerse al día
  • Características
    • Autenticación HTTP con PHP
    • 'Cookies'
    • Sesiones
    • Manejo de XForms
    • Subida de ficheros
    • Empleo de ficheros remotos
    • Manejo de conexiones
    • Conexiones persistentes a bases de datos
    • Uso de la línea de comandos — PHP desde la línea de comandos
    • Recolección de basura
    • Rastreo Dinámico con DTrace
  • Referencia de funciones
    • Afecta el comportamiento de PHP
    • Manipulación de formatos de audio
    • Servicios de autenticación
    • Extensiones específicas de la línea de comandos
    • Extensiones de compresión y archivos
    • Extensiones criptográficas
    • Extensiones de bases de datos
    • Extensiones relacionadas con fecha y hora
    • Extensiones relacionadas con el sistema de ficheros
    • Soporte para lenguaje humano y codificación de caracteres
    • Procesamiento y generación de imágenes
    • Extensiones relacionadas con Email
    • Extensiones matemáticas
    • Salida MIME que no es texto
    • Extensiones de control de procesos
    • Otras extensiones básicas
    • Otros servicios
    • Extensiones para motores de búsqueda
    • Extensiones específicas para Servidores
    • Extensiones de sesiones
    • Procesamiento de texto
    • Extensiones relacionadas con variable y tipo
    • Servicios web
    • Extensiones específicas de Windows
    • Manipulación de XML
    • Extensiones de GUI
  • FAQ — FAQ: Preguntas frequentes
    • Información general
    • Listas de correos
    • Consiguiendo PHP
    • Problemas con bases de datos
    • Instalación
    • Problemas de Compilación
    • Utilizar PHP
    • Hash de Contraseñas — Hash de contraseñas seguro
    • PHP y HTML
    • PHP y COM
    • Preguntas Varias
  • Apéndices
    • Historia de PHP y Proyectos Relacionados
    • Migración de PHP 7.4.x a PHP 8.0.x
    • Migración de PHP 7.3.x a PHP 7.4.x
    • Migración de PHP 7.2.x a PHP 7.3.x
    • Migración de PHP 7.1.x a PHP 7.2.x
    • Migración de PHP 7.0.x a PHP 7.1.x
    • Migración de PHP 5.6.x a PHP 7.0.x
    • Migración de PHP 5.5.x a PHP 5.6.x
    • Depuración en PHP
    • Opciones de configuración
    • Directivas de php.ini
    • Categorización de Extensiones
    • Listado de funciones alias
    • Lista de palabras reservadas
    • Lista de Tipos de Recurso
    • Lista de filtros disponibles
    • Lista de Transportes de Sockets Soportados
    • Tablas de comparación de tipos de PHP
    • Lista de componentes léxicos del analizador
    • Guía de entorno de usuario para nombres
    • Acerca del manual
    • Creative Commons Attribution 3.0
    • Listado de índices
    • Registro de cambios
  • HTML edición de ayuda
    • Sobre Esta Edición
    • Uso de la Edición CHM del Manual de PHP
    • La Búsqueda de Texto Completo
    • Integración del manual de PHP


Copyright

Copyright © 1997 - 2021 por el PHP Documentation Group. Este material puede ser distribuido solamente sujeto a los términos y condiciones establecidos por la licencia de Creative Commons Attribution 3.0 o superior. Una copia de la Licencia de Commons Attribution 3.0 está distribuida con este manual. La versión más reciente está disponible en » http://creativecommons.org/licenses/by/3.0/.

Si está interesado en la redistribución o republicación de este documento completa o parcialmente, con o sin modificaciones, y si tiene alguna pregunta, por favor contacte con los propietarios del Copyright en » doc-license@lists.php.net. Observe que esta dirección está ligada a una lista de correo pública.


  • « Copyright
  • Prefacio »
  • PHP Manual
  • Manual de PHP

Manual de PHP

  • Prefacio


Prefacio

PHP, acrónimo de "PHP: Hypertext Preprocessor", es un lenguaje de 'scripting' de propósito general y de código abierto que está especialmente pensado para el desarrollo web y que puede ser embebido en páginas HTML. Su sintaxis recurre a C, Java y Perl, siendo así sencillo de aprender. El objetivo principal de este lenguaje es permitir a los desarrolladores web escribir dinámica y rápidamente páginas web generadas; aunque se puede hacer mucho más con PHP.

Este manual consiste principalmente en una referencia de funciones, aunque también contiene una referencia del lenguaje, explicaciones de algunas de las características importantes de PHP, y otra información suplementaria.

Este manual se puede descargar en diferentes formatos en » https://www.php.net/download-docs.php. Puede encontrarse más información sobre cómo se desarrolla este manual en el apéndice "Acerca de este manual". Si está interesado en la Historia de PHP, visite el apéndice correspondiente.

Autores y Contribuyentes

Destacamos a las personas actualmente más activas al frente del manual, pero hay muchos más contribuyentes que nos ayudan en nuestro trabajo o han brindado una gran cantidad de ayuda al proyecto en el pasado. Hay muchísima gente anónima que ayudó con notas de usuario en las páginas del manual, que continuamente son incluidas en las referencias, labor de la que también estamos muy agradecidos. Todas las listas siguientes están en orden alfabético.

Autores y Editores

Los siguientes contribuyentes deberían ser reconocidos por el impacto de lo que han hecho y/o continúan haciendo añadiendo contenido al manual: Bill Abt, Jouni Ahto, Alexander Aulbach, Stig Bakken, George Peter Banyard, Christoph M. Becker, Daniel Beckham, Nilgün Belma Bugüner, Jesus M. Castagnetto, Ron Chmara, Sean Coates, John Coggeshall, Simone Cortesi, Peter Cowburn, Daniel Egeberg, Markus Fischer, Wez Furlong, Sara Golemon, Rui Hirokawa, Brad House, Pierre-Alain Joye, Etienne Kneuss, Moriyoshi Koizumi, Rasmus Lerdorf, Andrew Lindeman, Stanislav Malyshev, Justin Martin, Rafael Martinez, Rick McGuire, Moacir de Oliveira Miranda Júnior, Kalle Sommer Nielsen, Yasuo Ohgaki, Philip Olson, Richard Quadling, Derick Rethans, Rob Richards, Sander Roobol, Egon Schmid, Thomas Schoefbeck, Sascha Schumann, Dan Scott, Masahiro Takagi, Yoshinari Takaoka, Yannick Torres, Michael Wallner, Lars Torben Wilson, Jim Winstead, Jeroen van Wolffelaar y Andrei Zmievski.

Los siguientes contribuyentes han hecho un importante trabajo editando el manual: Stig Bakken, Gabor Hojtsy, Hartmut Holzgraefe, Philip Olson y Egon Schmid.

Mantenedores de las Notas de Usuario

Los mantenedores actualmente más activos son: Daniel Brown, Nuno Lopes, Felipe Pena, Thiago Pojda y Maciek Sokolewicz.

Estas personas también pusieron mucho esfuerzo en la administración de las notas de usuario: Mehdi Achour, Daniel Beckham, Friedhelm Betz, Victor Boivie, Jesus M. Castagnetto, Nicolas Chaillan, Ron Chmara, Sean Coates, James Cox, Vincent Gevers, Sara Golemon, Zak Greant, Szabolcs Heilig, Oliver Hinckel, Hartmut Holzgraefe, Etienne Kneuss, Rasmus Lerdorf, Matthew Li, Andrew Lindeman, Aidan Lister, Hannes Magnusson, Maxim Maletsky, Bobby Matthis, James Moore, Philip Olson, Sebastian Picklum, Derick Rethans, Sander Roobol, Damien Seguy, Jason Sheets, Tom Sommer, Jani Taskinen, Yasuo Ohgaki, Jakub Vrana, Lars Torben Wilson, Jim Winstead, Jared Wyles y Jeroen van Wolffelaar.


Conceptos básicos

  • Introducción
    • ¿Qué es PHP?
    • ¿Qué puede hacer PHP?
  • Un tutorial sencillo
    • ¿Qué necesito?
    • Su primera página con PHP
    • Algo útil
    • Tratar con formularios
    • Utilizar código antiguo en nuevas versiones de PHP
    • ¿Y ahora qué?


  • « Conceptos básicos
  • ¿Qué es PHP? »
  • PHP Manual
  • Conceptos básicos
  • Introducción

Introducción

Tabla de contenidos

  • ¿Qué es PHP?
  • ¿Qué puede hacer PHP?


¿Qué es PHP?

PHP (acrónimo recursivo de PHP: Hypertext Preprocessor) es un lenguaje de código abierto muy popular especialmente adecuado para el desarrollo web y que puede ser incrustado en HTML.

Bien, pero ¿qué significa realmente? Un ejemplo nos aclarará las cosas:

Ejemplo #1 Un ejemplo introductorio

<!DOCTYPE html>
<html>
    <head>
        <title>Ejemplo</title>
    </head>
    <body>

        <?php
            echo "¡Hola, soy un script de PHP!";
        ?>

    </body>
</html>

En lugar de usar muchos comandos para mostrar HTML (como en C o en Perl), las páginas de PHP contienen HTML con código incrustado que hace "algo" (en este caso, mostrar "¡Hola, soy un script de PHP!). El código de PHP está encerrado entre las etiquetas especiales de comienzo y final <?php y ?> que permiten entrar y salir del "modo PHP".

Lo que distingue a PHP de algo del lado del cliente como Javascript es que el código es ejecutado en el servidor, generando HTML y enviándolo al cliente. El cliente recibirá el resultado de ejecutar el script, aunque no se sabrá el código subyacente que era. El servidor web puede ser configurado incluso para que procese todos los ficheros HTML con PHP, por lo que no hay manera de que los usuarios puedan saber qué se tiene debajo de la manga.

Lo mejor de utilizar PHP es su extrema simplicidad para el principiante, pero a su vez ofrece muchas características avanzadas para los programadores profesionales. No sienta miedo de leer la larga lista de características de PHP. En unas pocas horas podrá empezar a escribir sus primeros scripts.

Aunque el desarrollo de PHP está centrado en la programación de scripts del lado del servidor, se puede utilizar para muchas otras cosas. Siga leyendo y descubra más en la sección ¿Qué puede hacer PHP?, o vaya directo al tutorial introductorio si solamente está interesado en programación web.


¿Qué puede hacer PHP?

Cualquier cosa. PHP está enfocado principalmente a la programación de scripts del lado del servidor, por lo que se puede hacer cualquier cosa que pueda hacer otro programa CGI, como recopilar datos de formularios, generar páginas con contenidos dinámicos, o enviar y recibir cookies. Aunque PHP puede hacer mucho más.

Existen principalmente tres campos principales donde se usan scripts de PHP.

  • Scripts del lado del servidor. Este es el campo más tradicional y el foco principal. Son necesarias tres cosas para que esto funcione: el analizador de PHP (módulo CGI o servidor), un servidor web y un navegador web. Es necesario ejecutar el servidor con una instalación de PHP conectada. Se puede acceder al resultado del programa de PHP con un navegador, viendo la página de PHP a través del servidor. Todo esto se puede ejecutar en su máquina si está experimentado con la programación de PHP. Véase la sección sobre las instrucciones de instalación para más información.
  • Scripts desde la línea de comandos. Se puede crear un script de PHP y ejecutarlo sin necesidad de un servidor o navegador. Solamente es necesario el analizador de PHP para utilizarlo de esta manera. Este tipo de uso es ideal para scripts que se ejecuten con regularidad empleando cron (en *nix o Linux) o el Planificador de tareas (en Windows). Estos scripts también pueden usarse para tareas simples de procesamiento de texto. Véase la sección Uso de PHP en la línea de comandos para más información.
  • Escribir aplicaciones de escritorio. Probablemente PHP no sea el lenguaje más apropiado para crear aplicaciones de escritorio con una interfaz gráfica de usuario, pero si se conoce bien PHP, y se quisiera utilizar algunas características avanzadas de PHP en aplicaciones del lado del cliente, se puede utilizar PHP-GTK para escribir dichos programas. También es posible de esta manera escribir aplicaciones independientes de una plataforma. PHP-GTK es una extensión de PHP, no disponible en la distribución principal. Si está interesado en PHP-GTK, puede visitar su propio » sitio web.

PHP puede emplearse en todos los sistemas operativos principales, incluyendo Linux, muchas variantes de Unix (incluyendo HP-UX, Solaris y OpenBSD), Microsoft Windows, macOS, RISC OS y probablemente otros más. PHP admite la mayoría de servidores web de hoy en día, incluyendo Apache, IIS, y muchos otros. Esto incluye cualquier servidor web que pueda utilizar el binario de PHP FastCGI, como lighttpd y nginx. PHP funciona tanto como módulo como procesador de CGI.

De modo que con PHP, se tiene la libertad de elegir el sistema operativo y el servidor web. Además, se tiene la posibilidad de utilizar programación por procedimientos o programación orientada a objetos (POO), o una mezcla de ambas.

Con PHP no se está limitado a generar HTML. Entre las capacidades de PHP se incluyen la creación de imágenes, ficheros PDF e incluso películas Flash (usando libswf y Ming) generadas sobre la marcha. También se puede generar fácilmente cualquier tipo de texto, como XHTML y cualquier otro tipo de fichero XML. PHP puede autogenerar estos ficheros y guardarlos en el sistema de ficheros en vez de imprimirlos en pantalla, creando una caché en el lado del servidor para contenido dinámico.

Una de las características más potentes y destacables de PHP es su soporte para un amplio abanico de bases de datos. Escribir una página web con acceso a una base de datos es increíblemente simple utilizando una de las extensiones específicas de bases de datos (p.ej., para mysql), o utilizar una capa de abstracción como PDO, o conectarse a cualquier base de datos que admita el estándar de Conexión Abierta a Bases de Datos por medio de la extensión ODBC. Otras bases de datos podrían utilizar cURL o sockets, como lo hace CouchDB.

PHP también cuenta con soporte para comunicarse con otros servicios usando protocolos tales como LDAP, IMAP, SNMP, NNTP, POP3, HTTP, COM (en Windows) y muchos otros. También se pueden crear sockets de red puros e interactuar usando cualquier otro protocolo. PHP tiene soporte para el intercambio de datos complejos de WDDX entre virtualmente todos los lenguajes de programación web. Y hablando de interconexión, PHP tiene soporte para la instalación de objetos de Java y emplearlos de forma transparente como objetos de PHP.

PHP tiene útiles características de procesamiento de texto, las cuales incluyen las expresiones regulares compatibles con Perl (PCRE), y muchas extensiones y herramientas para el acceso y análisis de documentos XML. PHP estandariza todas las extensiones XML sobre el fundamento sólido de libxml2, y amplía este conjunto de características añadiendo soporte para SimpleXML, XMLReader y XMLWriter.

Existen otras extensiones interesantes, las cuales están categorizadas alfabéticamente y por categoría. También hay extensiones adicionales de PECL que podrían estar documentadas o no dentro del manual de PHP, tal como » XDebug.

Como se puede apreciar, esta página no es suficiente para enumerar todas las características y beneficios que ofrece PHP. Consulte las secciones Instalación de PHP y Referencia de las funciones para una explicación de las extensiones mencionadas aquí.


Un tutorial sencillo

Tabla de contenidos

  • ¿Qué necesito?
  • Su primera página con PHP
  • Algo útil
  • Tratar con formularios
  • Utilizar código antiguo en nuevas versiones de PHP
  • ¿Y ahora qué?

A continuación, nos gustaría mostrarle lo esencial de PHP en un corto y sencillo tutorial. Este documento solamente trata de la creación de páginas web dinámicas con PHP, aunque PHP no solamente es capaz de crear páginas web. Consulte la sección titulada ¿Qué puede hacer PHP? para más información.

Las páginas web que usan PHP se tratan igual que páginas HTML comunes y corrientes, y se pueden crear y editar de la misma manera que normalmente se crean páginas HTML.


¿Qué necesito?

En este manual se asume que se cuenta con un servidor que tiene soporte activado para PHP y que todos los ficheros con la extensión .php son tratados por PHP. En la mayoría de servidores, esta es la extensión predeterminada para los ficheros de PHP, aunque puede preguntar al administrador de su servidor para estar seguro. Si el servidor tiene soporte para PHP, entonces no es necesario hacer nada. Simplemente cree sus ficheros .php, guárdelos en su directorio web y el servidor los analizará por usted. No hay necesidad de compilar nada o instalar otras herramientas. Piense en estos ficheros habilitados para PHP como simples ficheros HTML con el añadido de una nueva familia de etiquetas mágicas que permiten todo tipo de cosas.

Digamos que quiere ahorrar el preciado ancho de banda y trabajar localmente. En este caso, querrá instalar un servidor web, como » Apache, y por supuesto » PHP. Lo más seguro es que también quiera instalar una base de datos como » MySQL.

Puede instalarlos de forma independiente o bien puede elegir una manera más sencilla. Este manual contiene Instrucciones de instalación de PHP (asumiendo que tiene algún tipo de servidor web ya configurado). Si tuviera problemas con la instalación, sugerimos que formule sus preguntas en nuestra » lista de correo de instalación. Si elige la manera más sencilla, » localice un paquete preconfigurado para su sistema operativo, el cual instala automáticamente todo esto con únicamente unos pocos clics de ratón. Es sencillo configurar un servidor web con soporte para PHP en cualquier sistema operativo, incluyendo MacOSX, Linux y Windows. En Linux, podría encontrar útil » rpmfind y » PBone para localizar los RPM. También puede visitar » apt-get para buscar paquetes para Debian..


Su primera página con PHP

Comience por crear un fichero llamado hola.php y póngalo en el directorio raíz de su servidor web (DOCUMENT_ROOT) con el siguiente contenido:

Ejemplo #1 Nuestro primer script de PHP: hola.php

<html>
 <head>
  <title>Prueba de PHP</title>
 </head>
 <body>
 <?php echo '<p>Hola Mundo</p>'; ?>
 </body>
</html>

Utilice su navegador web para acceder al fichero con el URL de su servidor, finalizado con la referencia al fichero /hola.php. Si está programando localmente, este URL será algo parecido a http://localhost/hola.php o http://127.0.0.1/hola.php, pero esto depende de la configuración de su servidor web. Si todo está configurado correctamente, el fichero será analizado por PHP y se enviará el siguiente contenido a su navegador:

<html>
 <head>
  <title>Prueba de PHP</title>
 </head>
 <body>
 <p>Hola mundo</p>
 </body>
</html>

Este programa es extremadamente simple y realmente no es necesario utilizar PHP para crear una página como esta. Lo único que muestra es: Hola mundo empleando la sentencia echo de PHP. Observe que el fichero no necesita ser ejecutable o especial de ninguna forma. El servidor reconoce que este fichero necesita ser interpretado por PHP debido al empleo de la extensión ".php", ya que el servidor está configurado para enviarlo a PHP. Piense como si fuera un fichero HTML normal que tiene una serie de etiquetas especiales disponibles con las que puede hacer muchas cosas interesantes.

Si intentó usar este ejemplo y no produjo ningún resultado, se le preguntó si deseaba descargar el fichero, o se mostró todo el fichero como texto, lo más seguro es que PHP no se encuentre habilitado en su servidor o no esté configurado adecuadamente. Pídale a su administrador que lo habilite utilizando el capítulo Instalación del manual. Si está trabajando localmente, lea también el capítulo dedicado a la instalación para asegurarse de que todo esté configurado adecuadamente. Asegúrese de que está accediendo al fichero mediante http y que el servidor muestre el resultado. Si está abriendo el fichero desde el sistema de ficheros, probablemente no será analizado por PHP. Si el problema persiste, no dude en usar alguna de las múltiples opciones del » Soporte para PHP.

El objetivo de este ejemplo es el formato de las etiquetas especiales de PHP. En este ejemplo utilizamos <?php para indicar el inicio de una etiqueta de PHP. Después ponemos la sentencia y abandonamos el modo PHP añadiendo la etiqueta de cierre ?>. De esta manera, se puede entrar y salir del modo PHP en un fichero HTML cada vez que se quiera. Para más información, lea la sección del manual titulada Sintaxis básica de PHP.

Nota: Una observación sobre los avances de línea

Los avances de línea tienen poco sentido en HTML, aunque sigue siendo buena idea hacer que el código HTML se vea limpio y claro poniendo avances de línea. PHP automáticamente eliminará los avances de línea que estén después de una etiqueta de cierre ?>. Esto puede ser muy útil al poner muchos bloques de PHP o incluir ficheros que contienen PHP y que se supone que no deben mostrar nada. Al mismo tiempo, puede resultar un poco confuso. Se puede poner un espacio después de la etiqueta de cierre ?> para mostrar forzosamente un espacio y un avance de línea, o se puede poner un avance de línea explícito en el último echo/print dentro del bloque de PHP.

Nota: Una observación sobre los editores de texto

Hay muchos editores de texto y Entornos de Desarrollo Integrados (IDE por sus siglas en Inglés) que se pueden emplear para crear, editar, y gestionar ficheros de PHP. Se puede encontrar una lista parcial de estos en » Lista de editores de PHP. Si desea recomendar un editor, por favor visite la página mencionada anteriormente y pregunte al mantenedor de la página para que lo incluya en la lista. Contar con un editor que resalte la sintaxis puede ser de mucha ayuda.

Nota: Una observación sobre los procesadores de texto

Los procesadores de texto como StarOffice Writer, Microsoft Word y Abiword no son buenas opciones para editar ficheros de PHP. Si desea utilizar uno de estos programas para probar este script, asegúrese de guardar el documento como texto sin formato, o de lo contrario, PHP no será capaz de leerlo y ejecutarlo.

Nota: Una observación sobre el Bloc de Notas de Windows

Si escribe sus scripts de PHP usando el Bloc de Notas de Windows, debe asegurarse de que sus ficheros sean guardados con la extensión .php. (El Bloc de Notas automáticamente añade la extensión .txt a los ficheros a menos que siga los siguientes pasos para prevenirlo). Cuando guarde el fichero y el programa le pregunte qué nombre desea dar al fichero, entrecomille el nombre (es decir, "hola.php"). Una alternativa es hacer clic en el menú desplegable "Documentos de Texto (*.txt)" del cuadro de diálogo "Guardar como", y cambiar a la opción "Todos los archivos (*.*)". Aquí puede escribir el nombre del fichero sin las comillas.

Ahora que ha creado un pequeño script de PHP que funciona correctamente, es hora de crear el script de PHP más famoso: hacer una llamada a la función phpinfo() para obtener mucha información útil acerca de su sistema y configuración, como las variables predefinidas disponibles, los módulos de PHP cargados, y los ajustes de configuración. Tómese algo de tiempo para revisar esta importante información.

Ejemplo #2 Obtener la información del sistema desde PHP

<?php phpinfo(); ?>


Algo útil

Hagamos ahora algo que puede ser más útil. Vamos a comprobar qué tipo de navegador está utilizando el usuario visitante. Para hacerlo, vamos a comprobar el string del agente de usuario que el navegador envía como parte de la petición HTTP. Esta información es almacenada en una variable. En PHP, las variables siempre comienzan con un signo de dólar. La variable que nos interesa ahora es $_SERVER['HTTP_USER_AGENT'].

Nota:

$_SERVER es una variable especial reservada por PHP que contiene toda la información del servidor web. Es conocida como una superglobal. Consulte la página del manual sobre Superglobales para más información. Estas variables especiales fueron introducidas en la versión » 4.1.0 de PHP. Antes se podían usar en su lugar los antiguos arrays $HTTP_*_VARS, tales como $HTTP_SERVER_VARS. A partir de PHP 5.4.0, estos antiguos arrays han sido eliminados. (Véase también la nota sobre código antiguo).

Para mostrar esta variable, se puede hacer simplemente:

Ejemplo #1 Imprimir una variable (elemento de array)

<?php
echo $_SERVER['HTTP_USER_AGENT'];
?>

Un ejemplo del resultado de este script podría ser:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Hay muchos tipos de variables en PHP. En el ejemplo anterior se muestra un elemento de un Array. Los arrays pueden ser muy útiles.

$_SERVER es simplemente una variable que se encuentra disponible automáticamente en PHP. Se puede encontrar una lista en la sección Variables reservadas del manual, o se puede obtener una lista completa observando la salida de la función phpinfo() usada en el ejemplo de la sección anterior.

Puede usar múltiples sentencias de PHP dentro de una etiqueta de PHP y crear pequeños bloques de código que realicen más que un simple 'echo'. Por ejemplo, si se quisiera detectar el uso de Internet Explorer, se podría hacer algo así:

Ejemplo #2 Ejemplo usando estructuras de control y funciones

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
    echo 'Está usando Internet Explorer.<br />';
}
?>

Un ejemplo del resultado de este script sería:

Está usando Internet Explorer.<br />

Aquí hemos introducido un par de conceptos nuevos. Tenemos una sentencia if. Si está familiarizado con la sintaxis básica del lenguaje C, debería parecerle lógico. De lo contrario, probablemente debería conseguir un libro que le introduzca a PHP, y leer el primer par de capítulos, o leer la parte del manual titulada Referencia del lenguaje.

El segundo concepto que introducimos fue la función llamada a strpos(). strpos() es una función integrada en PHP que busca un string dentro de otro. En este caso estamos buscando 'MSIE' (también llamado aguja) dentro de $_SERVER['HTTP_USER_AGENT'] (también llamado pajar). Si el string se encuentra dentro del pajar, la función devuelve la posición de la aguja relativa al inicio del pajar. De lo contrario, devuelve false. Si no devuelve false, la expresión if se evalúa como true y se ejecuta el código entre llaves {}. De lo contrario, el código no será ejecutado. Tómese la libertad de crear ejemplos similares, con if, else, y otras funciones como strtoupper() y strlen(). Cada página del manual relacionada también contiene ejemplos. Si no está seguro de cómo usar estas funciones, es recomendable que lea las páginas del manual sobre Cómo interpretar una definición de función y la sección sobre Funciones de PHP.

Podemos dar un paso más y mostrar cómo se puede entrar y salir del modo PHP incluso en medio de un bloque de código de PHP:

Ejemplo #3 Mezcla de los modos HTML y PHP

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
?>
<h3>strpos() debe haber devuelto no falso</h3>
<p>Está usando Internet Explorer</p>
<?php
} else {
?>
<h3>strpos() debe haber devuelto falso</h3>
<p>No está usando Internet Explorer</p>
<?php
}
?>

Un ejemplo del resultado del script podría ser:

<h3>strpos() debe haber devuelto no falso</h3>
<p>Está usando Internet Explorer</p>

En vez de usar una sentencia echo de PHP para mostrar algo, salimos del modo PHP y enviamos solamente HTML. Este es un punto muy importante y potente que se ha de observar aquí, y es que la fluidez lógica del script permanece intacta. Solamente uno de los bloques HTML terminará siendo enviado al navegador dependiendo del resultado de strpos(). En otras palabras, depende de si el string MSIE fue encontrada o no.


Tratar con formularios

Otra de las características más potentes de PHP es la forma de gestionar formularios HTML. El concepto básico que es importante entender es que cualquier elemento de un formulario estará disponible automáticamente en sus scripts de PHP. Por favor, lea la sección del manual sobre Variables desde fuentes externas para obtener más información y ejemplos sobre cómo usar formularios con PHP. Observemos un ejemplo:

Ejemplo #1 Un formulario HTML sencillo

<form action="accion.php" method="post">
 <p>Su nombre: <input type="text" name="nombre" /></p>
 <p>Su edad: <input type="text" name="edad" /></p>
 <p><input type="submit" /></p>
</form>

No hay nada especial en este formulario. Es solamente un formulario HTML sin ninguna clase de etiqueta especial. Cuando el usuario rellena este formulario y oprime el botón de envío, se llama a la página accion.php. En este fichero se podría escribir algo así:

Ejemplo #2 Mostrar información de nuestro formulario

Hola <?php echo htmlspecialchars($_POST['nombre']); ?>.
Usted tiene <?php echo (int)$_POST['edad']; ?> años.

Un ejemplo del resultado de este script podría ser:

Hola José. Usted tiene 22 años.

Excepto las partes de htmlspecialchars() y de (int), debería ser obvio qué es lo que hace el código. htmlspecialchars() garantiza que cualquier carácter que sea especial en html se codifique adecuadamente, de manera que nadie pueda inyectar etiquetas HTML o Javascript en la página. El campo edad, ya que sabemos que es un número, podemos convertirlo a un valor de tipo integer que automáticamente se deshará de cualquier carácter no numérico. También se puede hacer lo mismo con PHP con la extensión filter. Las variables $_POST['nombre'] y $_POST['edad'] son establecidas automáticamente por PHP. Anteriormente hemos usado la superglobal $_SERVER; arriba introdujimos la superglobal $_POST, la cual contiene todos los datos de POST. Observe que el método de nuestro formulario es POST. Si hubiésemos usado el método GET, nuestra información estaría en su lugar en la superglobal $_GET. También se podría usar la superglobal $_REQUEST, si no le preocupa la fuente de los datos solicitados. Contiene toda la información de los datos de GET, POST y COOKIE mezclada.

En PHP, también puede tratar con entradas de XForms; aunque probablemente al principio se sienta cómodo con los formularios de HTML, los cuales están ampliamente respaldados. A pesar de que trabajar con XForms no es para principiantes, podrían interesarle. Si es así, en la sección de características hay una pequeña introducción a la manipulación de datos recibidos desde XForms.


Utilizar código antiguo en nuevas versiones de PHP

Ahora que PHP ha crecido y se ha convertido en un lenguaje popular, hay muchos más repositorios y bibliotecas que contienen código que puede reutilizar. Los desarrolladores de PHP han intentado preservar la retrocompatibilidad, es decir, si un script fue escrito para una versión antigua, funcionará (idealmente) sin ningún cambio en una versión reciente de PHP. En la práctica, normalmente son necesarios algunos cambios.

Dos de los cambios más importantes que afectan el código antiguo son:

  • Los antiguos arrays $HTTP_*_VARS ya no están disponibles a partir de PHP 5.4.0. Los siguientes arrays superglobales fueron introducidos en PHP » 4.1.0. Son: $_GET, $_POST, $_COOKIE, $_SERVER, $_FILES, $_ENV, $_REQUEST, y $_SESSION.
  • Las variables externas ya no son registradas en el ámbito global de forma predeterminada. En otras palabras, a partir de PHP » 4.2.0, la directiva de PHP register_globals está desactivada (off) por defecto en php.ini. El mejor método para acceder a estos valores es por medio de las variables superglobales mencionadas anteriormente. Los scripts, libros y tutoriales antiguos podrían contar con que esta directiva esté activada (on). Si fuera on, por ejemplo, se podría usar $id desde el URL http://www.example.com/foo.php?id=42. Ya esté activada o desactivada, $_GET['id'] está siempre disponible.
Para más información relacionada con estos cambios, véase la sección sobre variables predefinidas y los enlaces que incluye.


¿Y ahora qué?

Con sus nuevos conocimientos debería ser capaz de entender la mayoría del manual y los diversos scripts de ejemplo disponibles en los archivos de ejemplos.

Para ver varias presentaciones que muestran más acerca de lo que puede hacer PHP, véase el Sitio de Material de Conferencias de PHP: » http://talks.php.net/


Instalación y configuración

  • Consideraciones generales de instalación
  • Instalación sobre sistemas Unix
    • Apache 1.3.x sobre sistemas Unix
    • Apache 2.x sobre sistemas Unix
    • Nginx 1.4.x en sistemas Unix
    • Lighttpd 1.4 en sistemas Unix
    • Servior web LiteSpeed/OpenLiteSpeed en sistemas Unix
    • CGI y configuraciones de línea de comandos
    • Notas de instalación específicas para HP-UX
    • Notas de instalación para OpenBSD
    • Solaris sugerencias específicas de instalación
    • Notas de instalación en Debian GNU/Linux
  • Instalación en Mac OS X
    • Empleo de paquetes
    • Usando el paquete PHP
    • Compilar PHP en Mac OS X
  • Instalación en sistemas Windows
    • Herramientas de instalación de PHP en Windows
    • Configuración recomendada en sistemas Windows
    • Instalación manual de PHP en Windows
    • Resolución de problemas de PHP en Windows
    • Instalación en sistemas Windows
  • Instalación en las plataformas de Nube Informática
    • Microsoft Azure
    • Amazon EC2
  • Manejador de Procesos FastCGI (FPM)
    • Instalación
    • Configuración
  • Instalación de extensiones PECL
    • Introducción a las Instalaciones en PECL
    • Descarga de extensiones PECL
    • Instalación una extensión de PHP en Windows
    • Compilando extensiones PECL compartidas con el comando pecl
    • Compilando extensiones PEC compartidas con phpize
    • php-config
    • Compilando extensiones PECL estáticamente en PHP
  • Resolución de problemas
    • Lea las Preguntas frecuentes
    • Otros problemas
    • Informar sobre errores (bugs)
  • Configuración en tiempo de ejecución
    • El fichero de configuración
    • Ficheros .user.ini
    • Dónde se puede realizar un ajuste de configuración
    • Cómo cambiar los ajustes de configuración


Consideraciones generales de instalación

Antes de empezar con la instalación, primero necesita saber para qué quiere utilizar PHP. Existen tres campos principales donde se puede utilizar PHP tal y como se describe en la sección: ¿Qué se puede hacer con PHP?

  • Aplicaciones web y sitios web (scripting del lado del servidor)
  • Scripting en la línea de comandos
  • Aplicaciones de escritorio (GUI)

Para la primera forma mencionada, que es la más común, se necesitan tres cosas: PHP, un servidor web y un navegador web. Seguramente ya disponga del navegador web y, dependiendo de la configuración del sistema operativo, quizá ya tenga un servidor web (p.ej. Apache en Linux y macOS; IIS en Windows). También puede alquilar espacio web en una empresa. De esta forma, no se necesita instalar nada, solo tiene que escribir los scripts de PHP, subirlos al servidor que alquile y ver los resultados en su navegador.

En caso de configurar el servidor y PHP por su cuenta, existen dos opciones para el modo de conectar PHP con el servidor. Para muchos servidores, PHP tiene un módulo de interfaz directo (también llamado SAPI). Entre estos servidores se incluyen Apache, Microsoft Internet Information Server, Netscape y iPlanet. Muchos otros servidores tienen soporte para ISAPI, el módulo de interfaz de Microsoft (OmniHTTPd por ejemplo). Si PHP no tiene soporte para el módulo de su servidor web, siempre puede usarlo como procesador CGI o FastCGI. Esto significa configurar el servidor para usar el CGI ejecutable de PHP para procesar cada una de las peticiones a ficheros PHP en el servidor.

Si también está interesado en usar PHP bajo la línea de comandos (p.ej. escribir scripts que autogeneran imágenes de forma offline, o procesar ficheros de texto dependiendo de los argumentos que se les pasen), siempre necesitará el ejecutable de línea de comandos. Para más información, lea la sección sobre escribir aplicaciones PHP desde la línea de comandos. En este caso, no se necesita ningún servidor o navegador.

Con PHP también se pueden escribir aplicaciones GUI de escritorio usando la extensión PHP-GTK. Este enfoque no tiene nada que ver con escribir páginas web, ya que no se muestra nada de HTML, pero gestiona ventanas y objetos dentro de ellas. Para más información acerca de PHP-GTK, por favor » visite el sitio dedicado a esta extensión. PHP-GTK no está incluido en la distribución oficial de PHP.

De aquí en adelante, esta sección trata de la configuración de PHP para servidores web sobre Unix y Windows con interfaces de módulo de servidor y ejecutables CGI. También se puede encontrar información sobre ejecutables de línea de comandos en las siguientes secciones.

El código fuente de PHP y las distribuciones binarias para Windows pueden encontrarse en » https://www.php.net/downloads.php. Recomendamos elegir un » sitio alternativo cercano para descargar las distribuciones.


Instalación sobre sistemas Unix

Tabla de contenidos

  • Apache 1.3.x sobre sistemas Unix
  • Apache 2.x sobre sistemas Unix
  • Nginx 1.4.x en sistemas Unix
  • Lighttpd 1.4 en sistemas Unix
  • Servior web LiteSpeed/OpenLiteSpeed en sistemas Unix
  • CGI y configuraciones de línea de comandos
  • Notas de instalación específicas para HP-UX
  • Notas de instalación para OpenBSD
  • Solaris sugerencias específicas de instalación
  • Notas de instalación en Debian GNU/Linux

Esta sección le guiará a través de la configuración general e instalación de PHP sobre sistemas Unix. Asegúrese de investigar cualquier sección específica a su plataforma o servidor web antes de comenzar el proceso.

Tal como el manual lo esboza en la sección Consideraciones generales de instalación, se está tratando principalmente con configuraciones de PHP centradas en web en esta sección, aunque también se cubrirá el preparar PHP para usarse en línea de comando.

Existen varias maneras de instalar PHP para la plataforma Unix, ya sea con un proceso de compilar y configurar, o a través de varios métodos pre-empaquetados. Esta documentación está enfocada principalmente alrededor del proceso de compilar y configurar PHP. Muchos sistemas estilo Unix tienen algún tipo de sistema de instalación de paquetes. Esto puede ayudar en preparar una configuración standard, pero si se requiere tener un conjunto diferente de características (tales como un servidor seguro, o un manejador diferente de base de datos), podría ser necesario construir PHP y/o el servidor web. Si no se está familiarizado con la construcción y el compilado de su propio software, vale la pena revisar para ver si alguien ya ha construido una versión empaquetada de PHP con las características que se necesitan.

Conocimientos y software necesarios para compilar:

  • Habilidades básicas en Unix (ser capaz de operar "make" y un compilador de C)
  • Un compilador ANSI C
  • Un servidor web
  • Cualquier componente específico para módulos (tales como GD, PDF libs, etc.)

Cuando compile directamente de una fuente Git o después de realizar modificaciones usted necesita también:

  • autoconf: 2.13+ (for PHP < 5.4.0), 2.59+ (for PHP >= 5.4.0)
  • automake: 1.4+
  • libtool: 1.4.x+ (except 1.4.2)
  • re2c: Version 0.13.4 or newer
  • flex: Versión 2.5.4 (para PHP <= 5.2)
  • bison:
    • PHP 5.4: 1.28, 1.35, 1.75, 1.875, 2.0, 2.1, 2.2, 2.3, 2.4, 2.4.1, 2.4.2, 2.4.3, 2.5, 2.5.1, 2.6, 2.6.1, 2.6.2, 2.6.4
    • PHP 5.5: 2.4, 2.4.1, 2.4.2, 2.4.3, 2.5, 2.5.1, 2.6, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.7
    • PHP 5.6: 2.4 o superior, excluyendo 3.0 únicamente (3.0.1 y superior están bien)
    • PHP 7.0: 2.4 o superior

El proceso inicial de preparación y configuración de PHP es controlado por el uso de las opciones de línea de comando del script configure. Es posible obtener una lista de todas las opciones disponibles junto con una descripción corta ejecutando ./configure --help. El manual documenta las diferentes opciones por separado. Se encontrarán las opciones principales en el apéndice, mientras que las diferentes opciones específicas de las extensiones se describen en las páginas de referencia.

Cuando PHP está configurado, se está listo para compilar el módulo y/o ejecutables. El comando make debería hacerse cargo de esto. Si falla y no se puede encontrar el porque, véase la sección de problemas.

Nota:

Algunos sistemas UNIX (como OpenBSD y SELinux) pueden deshabilitar el mapeo de páginas tanto en escritura como lectura por razones de seguridad, Lo que se llama PaX MPROTECT o W^X protección contra violaciones. Este tipo de mapeado de memoria es, sin embargo, necesario para el soporte JIT PCRE, por lo que bien PHP debe ser compilado sin soporte PCRE's JIT , o el binario ha de ser cargado en lista blanca por cualquier medio proporcionado por el sistema.

Nota: La compilación cruzada para ARM con toolchain de Android no es compatible actualmente.


Apache 1.3.x sobre sistemas Unix

Esta sección contiene notas y consejos específicos a instalaciones Apache de PHP sobre plataformas Unix. También se tienen instrucciones y notas para Apache 2 en una página por separado.

Se pueden seleccionar argumentos para agregar a configure en la línea 10 debajo de la lista de opciones principales de configure y de opciones específicas a extensiones descritas en sus respectivos lugares en el manual. Los números de versión han sido omitidos aquí, para asegurar que las instrucciones no sean incorrectas. Se necesita reemplazar las 'xxx' aquí con los valores correctos de los ficheros.

Ejemplo #1 Instrucciones de instalación (Versión de módulo compartido de Apache) para PHP

1.  gunzip apache_xxx.tar.gz
2.  tar -xvf apache_xxx.tar
3.  gunzip php-xxx.tar.gz
4.  tar -xvf php-xxx.tar
5.  cd apache_xxx
6.  ./configure --prefix=/www --enable-module=so
7.  make
8.  make install
9.  cd ../php-xxx

10. Ahora, se configura PHP.  Aquí es donde se personaliza PHP
    con varias opciones, como cuales extensiones se habilitarán.  Realizar un
    ./configure --help para obtener una lista de opciones disponibles.  En el ejemplo
    se realiza un configure simple con soporte para Apache 1 y MySQL.  La
    ruta de acceso a apxs puede diferir del ejemplo.

      ./configure --with-mysql --with-apxs=/www/bin/apxs

11. make
12. make install

    Si se decide cambiar las opciones de configure después de la instalación,
    solamente se necesita repetir los últimos tres pasos. Sólo hace falta
    reiniciar apache para que el nuevo módulo tenga efecto. Una recompilación de
    Apache no es necesaria.

    Nótese que a menos que se mencione lo contrario, 'make install' también instalará PEAR,
    varias herramientas de PHP tales como phpize, instalará la línea de comando (CLI) de PHP, y más.

13. Preparar el fichero php.ini:

      cp php.ini-development /usr/local/lib/php.ini

    Se puede editar el fichero .ini para fijar las opciones de PHP.  Si se prefiere
    php.ini en otra ubicación, utilice --with-config-file-path=/some/path en
    el paso 10.

    Si en vez de ello se elige php.ini-production, asegurarse de leer la lista
    de cambios en el interior, ya que éstos afectan como se comporta PHP.

14. Editar httpd.conf para cargar el módulo de PHP.  La ruta de acceso al lado derecho
    de el enunciado LoadModule debe apuntar a la ruta del módulo de PHP
    en su sistema.  El make install anterior podría haber agregado esto ya
    por usted, pero asegúrese de revisarlo.

      LoadModule php5_module libexec/libphp5.so

15. Y en la sección AddModule de httpd.conf, en algún lugar por debajo de
    ClearModuleList, agregar esto:

      AddModule mod_php5.c

16. Indicar a Apache que procese ciertas extensiones como PHP.  Por ejemplo,
    hacer que Apache procese la extensión .php como PHP.  Se podría
    hacer que cualquier extensión o extensiones sean procesadas como PHP simplemente añadiendo más, con
    cada una separada por un espacio.  Se agregará .phtml para demostrarlo.

      AddType application/x-httpd-php .php .phtml

    También es común configurar la extensión .phps para mostrar fuentes resaltadas de PHP,
    ésto puede hacerse con:

      AddType application/x-httpd-php-source .phps

17. Utilice el procedimiento normal para iniciar el servidor Apache. (Se debe
    detener y reiniciar el servidor, no sólo causar que el servidor recargue utilizando
    una señal HUP o USR1.)

Alternativamente, para instalar PHP como un objeto estático:

Ejemplo #2 Instrucciones de instalación (Instalación de módulo estático para Apache) para PHP

1.  gunzip -c apache_1.3.x.tar.gz | tar xf -
2.  cd apache_1.3.x
3.  ./configure
4.  cd ..

5.  gunzip -c php-5.x.y.tar.gz | tar xf -
6.  cd php-5.x.y
7.  ./configure --with-mysql --with-apache=../apache_1.3.x
8.  make
9.  make install

10. cd ../apache_1.3.x

11. ./configure --prefix=/www --activate-module=src/modules/php5/libphp5.a
    (¡La línea anterior es correcta! Sí, ya se sabe que libphp5.a aún no existe en esta
    etapa. No se supone que deba. Será creado.)

12. make
    (ahora se debe tener un binario httpd que puede ser copiado al directorio bin de Apache si
    esta es la primera instalación entonces se necesita dar "make install" también)

13. cd ../php-5.x.y
14. cp php.ini-development /usr/local/lib/php.ini

15. Se puede editar el fichero /usr/local/lib/php.ini para fijar las opciones de PHP.
    Editar el fichero httpd.conf o srm.conf y añadir:
    AddType application/x-httpd-php .php

Dependiendo de la instalación de Apache y la variante de Unix, hay muchas maneras posibles de detener y reiniciar el servidor. Abajo hay algunas líneas típicas utilizadas para reiniciar el servidor, para diferentes instalaciones apache/unix. Se debe reemplazar /path/to/ con la trayectoria a estas aplicaciones en el sistema.

Ejemplo #3 Comandos de ejemplo para reiniciar Apache

1. Diferentes variantes de Linux y SysV:
/etc/rc.d/init.d/httpd restart

2. Utilizando scripts apachectl:
/path/to/apachectl stop
/path/to/apachectl start

3. httpdctl y httpsdctl (Utilizando OpenSSL), similar a apachectl:
/path/to/httpsdctl stop
/path/to/httpsdctl start

4. Usando mod_ssl, u otro servidor SSL, que se quiera detener e iniciar
manualmente:
/path/to/apachectl stop
/path/to/apachectl startssl

Las ubicaciones de los binarios apachectl y http(s)dctl varían frecuentemente. Si el sistema tiene los comandos locate o whereis o which, éstos pueden ayudar en encontrar los programas de control del servidor.

Distintos ejemplos de compilaciones de PHP para apache son como sigue:

./configure --with-apxs --with-pgsql

Esto creará una librería compartida libphp5.so que se carga en Apache utilizando una línea LoadModule en el fichero de Apache httpd.conf. El soporte para PostgreSQL está incluido dentro de esta librería.

./configure --with-apxs --with-pgsql=shared

Esto creará una librería compartida libphp5.so para Apache, pero también creará una librería compartida pgsql.so que se carga en PHP ya sea usando la directiva de extensión en el fichero php.ini o cargándola explícitamente en un script utilizando la función dl().

./configure --with-apache=/path/to/apache_source --with-pgsql

Esto creará una librería libmodphp5.a, un mod_php5.c y algunos ficheros acompañantes y cópiese estos dentro del directorio src/modules/php5 en el árbol de fuentes de Apache. Entonces se compila Apache utilizando --activate-module=src/modules/php5/libphp5.a y el sistema de compilación de Apache creará libphp5.a y lo enlazará estáticamente dentro del binario httpd. El soporte para PostgreSQL se incluye directamente dentro de este binario httpd, así que el resultado final aquí es un binario httpd sencillo que incluye todo Apache y todo PHP.

./configure --with-apache=/path/to/apache_source --with-pgsql=shared

Igual que en el anterior, excepto que en vez de incluir soporte para PostgreSQL directamente en el httpd final se obtiene una librería compartida pgsql.so que puede cargarse dentro de PHP desde ya sea el fichero php.ini o directamente utilizando dl().

Cuando se elige compilar PHP de diferentes maneras, se deben considerar las ventajas y desventajas de cada método. Compilar como objeto compartido significará que se puede compilar apache por separado, y no se tiene que recompilar todo cuando se agrega o se cambia algo en PHP. Compilar PHP dentro de apache (método estático) significa que PHP cargará y ejecutará más rápido. Para más información, ver la » página web de Apache sobre soporte DSO.

Nota:

El httpd.conf por omisión de Apache actualmente se distribuye con una sección que se parece a esto:

User nobody
Group "#-1"
A menos que se cambie esto a "Group nogroup" o algo como esto ("Group daemon" es también muy común) PHP no será capaz de abrir ficheros.

Nota:

Asegúrese de que se especifica la versión instalada de apxs cuando se utiliza --with-apxs=/path/to/apxs. NO se debe utilizar la versión de apxs que está en las fuentes de apache, si no la que en realidad está instalada en el sistema.


Apache 2.x sobre sistemas Unix

Esta sección contiene notas y consejos específicos a las instalaciones de Apache 2.x de PHP sobre sistemas Unix.

Advertencia

No se recomienda utilizar un MPM threaded en producción con Apache 2. Use MPM prefork, que es el MPM por defecto en Apache 2.0 y 2.2. Para información sobre cómo, lea la correspondiente entrada de la FAQ sobre utilizar Apache2 con un MPM threaded

La » Documentación de Apache es la fuente de información más autorizada acerca del servidor Apache 2.x. Ahí se puede encontrar más información acerca de las opciones de instalación.

La versión más reciente de Apache HTTP Server puede obtenerse del » Sitio de descargas de Apache, y una versión apropiada de PHP de los lugares anteriormente mencionados. Esta guía rápida solamente cubre lo básico para comenzar con Apache 2.x y PHP. Para obtener más información lea la » Documentación de Apache. Los números de versión han sido omitidos aquí, para asegurar que las instrucciones no sean incorrectas. En los ejemplos siguientes, 'NN' deberá ser reemplazado con la versión específica de Apache que se está utilizando.

Existen actualmente dos versiones de Apache 2.x - está la 2.0 y la 2.2. Mientras que existen varias razones para elegir cada una, la 2.2 es actualmente la versión más reciente, y la que se recomienda, si es que esa opción está disponible. Sin embargo, las instrucciones aquí funcionarán ya sea para 2.0 ó 2.2.

  1. Obténgase el servidor HTTP Apache de la ubicación listada con anterioridad, y desempáquese:

    gzip -d httpd-2_x_NN.tar.gz
tar -xf httpd-2_x_NN.tar

  2. De la misma manera, obtener y desempacar las fuentes de PHP:

    gunzip php-NN.tar.gz
tar -xf php-NN.tar

  3. Compilar e instalar Apache. Consúltese la documentación de instalación de Apache para mayores detalles sobre la compilación de Apache.

    cd httpd-2_x_NN
./configure --enable-so
make
make install

  4. Ahora se tiene Apache 2.x.NN disponible debajo de /usr/local/apache2, configurado con soporte para módulos cargables y con el MPM (Módulo de multiproceso) prefork estándar. Para probar la instalación úsese el procedimiento para iniciar el servidor Apache, por ej.:

    /usr/local/apache2/bin/apachectl start
    y deténgase el servidor para proceder con la configuración para PHP:
    /usr/local/apache2/bin/apachectl stop

  5. Ahora, configure y compile PHP. Aquí es donde se personaliza PHP con varias opciones, como qué extensiones se han de habilitar. Ejecute ./configure --help para obtener una lista de opciones disponibles. En el ejemplo se realiza un simple configure con soporte para Apache 2 y MySQL.

    Si se compila Apache a partir de los fuentes, tal como se describe anteriormente, el siguiente ejemplo coincidirá con la trayectoria para apxs, pero si se ha instalado Apache de alguna otra manera, será necesario ajustar la trayectoria a apxs apropiadamente. Nótese que algunas distribuciones pueden renombrar apxs cómo apxs2.

    cd ../php-NN
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
make
make install

    Si se decide a cambiar las opciones de configuración después de la instalación, se deben volver a ejecutar los pasos configure, make, y make install. Solamente se necesita reiniciar apache para que el nuevo módulo tenga efecto. Una recompilación de Apache no es necesaria.

    Nótese que a menos que se indique lo contrario, 'make install' también instalará PEAR, varias herramientas de PHP tales como phpize, instalará la interfaz de línea de comando (CLI) de PHP, y más.

  6. Configurar php.ini

    cp php.ini-development /usr/local/lib/php.ini

    Se puede editar el fichero .ini para fijar las opciones de PHP. Si se prefiere tener php.ini en otra ubicación, utilice --with-config-file-path=/alguna/trayectoria en el paso 5.

    Si en vez de eso se elige php.ini-production, asegúrese de leer la lista de cambios al interior, ya que afectan como se comporta PHP.

  7. Edítese httpd.conf para cargar el módulo PHP. La trayectoria a la derecha de la sentencia LoadModule debe apuntar a la trayectoria del módulo PHP en el sistema. El make install anterior podría ya haber agregado esto automáticamente, pero asegúrese de revisar.

    Para PHP 7:

    LoadModule php7_module modules/libphp7.so

    Para PHP 5:

    LoadModule php5_module modules/libphp5.so

  8. Indicar a Apache que procese ciertas extensiones como PHP. Por ejemplo, hágase que Apache procese ficheros .php como PHP. En vez de solamente utilizar la directiva de Apache AddType, se desea evitar subidas de ficheros potencialmente peligrosas y que ficheros creados tal como exploit.php.jpg sean ejecutados como PHP. Utilizando este ejemplo, se puede hacer que cualquier extensión o extensiones sean procesadas como PHP simplemente añadiéndolas. Se agregará .php para demostrarlo.

    <FilesMatch \.php$>
    SetHandler application/x-httpd-php
</FilesMatch>

    O, si se deseara permitir que ficheros .php, .php2, .php3, .php4, .php5, .php6, y .phtml fuesen ejecutados como PHP, pero nada más, se utilizaría esto:

    <FilesMatch "\.ph(p[2-1]?|tml)$">
    SetHandler application/x-httpd-php
</FilesMatch>

    Y para permitir que ficheros .phps sean manejados por el filtro de fuentes de php, y desplegado como código fuente con sintaxis resaltada, se utiliza esto:

    <FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

    mod_rewrite puede ser utilizado para permitir que cualquier fichero .php arbitrario sea desplegado como código fuente con sintaxis resaltada, sin tener que renombrarlo o copiarlo a un fichero .phps:

    RewriteEngine On
RewriteRule (.*\.php)s$ $1 [H=application/x-httpd-php-source]

    El filtro de código fuente php no debe habilitarse en sistemas de producción, donde podría exponer información confidencial o de alguna otra manera sensible incluida en código fuente.

  9. Utilícese el procedimiento normal para iniciar el servidor Apache, por ej.:

    /usr/local/apache2/bin/apachectl start

    O

    service httpd restart

Siguiendo los pasos anteriores se tendrá corriendo un servidor web Apache2 con soporte para PHP como un módulo SAPI. Por supuesto existen muchas opciones más de configuración disponibles para Apache y PHP. Para más información teclee ./configure --help en el árbol de fuentes correspondiente.

Apache se puede compilar con soporte multihilos seleccionando el worker MPM, en vez del prefork MPM standard, cuando Apache se compila. Esto se realiza agregando la siguiente opción al argumento pasado a ./configure, en el paso 3 anterior:

--with-mpm=worker

Esto no debe llevarse a cabo sin ser consciente de las consecuencias de esta decisión, y tener al menos un ligero entendimiento acerca de las implicaciones. La documentación de Apache al respecto de » MPM-Modules discute los MPM en forma mucho más detallada.

Nota:

Las Preguntas frecuentes de Apache MultiViews discute acerca del uso de multiviews con PHP.

Nota:

Para compilar una versión multihilo de Apache, el sistema destino debe soportar hilos. En este caso, PHP también debe compilarse con la opción Zend Thread Safety (ZTS) experimental. Bajo esta configuración, no todas las extensiones se encontrarán disponibles. La configuración recomendada es compilar Apache con el MPM-module prefork por omisión.


Nginx 1.4.x en sistemas Unix

Esta documentación cubre la instalación y configuración de PHP con PHP-FPM para un servidor HTTP de Nginx 1.4.x.

En esta guía se asume que se ha construido Nginx desde el código fuente, por lo que todos los ficheros binarios y de configuración están ubicados en /usr/local/nginx. Si este no es el caso y se ha obtenido Nginx a través de otros medios, consúltese la » Wiki de Nginx para traducir este manual a una configuración propia.

Esta guía cubre la configuración básica de un servidor Nginx para procesar aplicaciones de PHP y servirlas en el puerto 80. Se recomienda estudiar la documentación de Nginx y de PHP-FPM para poder optimizar la configuración más allá del ámbito de esta documentación.

Obsérvese que en esta documentación se han reemplazado los números de versión con una 'x' para asegurarse de que sea correcta en el futuro; se han de reemplazar estos con los números de versión correspondiente cuando sea necesario.

  1. Se recomienda visitar la página de » instalación de la Wiki de Nginx para obtener e instalar Nginx en un sistema propio.

  2. Obtener y desempaquetar el código fuente de PHP:

    tar zxf php-x.x.x

  3. Configurar y construir PHP. Aquí es donde se personaliza PHP con varias opciones, como qué extensiones se habilitarán. Ejecutar ./configure --help para enumerar las opciones disponibles. En este ejemplo se realiza una configuración sencilla con soporte para PHP-FPM y MySQL.

    cd ../php-x.x.x
./configure --enable-fpm --with-mysql
make
sudo make install

  4. Obtener y mover los ficheros de configuración a sus ubicaciones correctas

    cp php.ini-development /usr/local/php/php.ini
cp /usr/local/etc/php-fpm.conf.default /usr/local/etc/php-fpm.conf
cp sapi/fpm/php-fpm /usr/local/bin

  5. Es importante prevenir que Nginx pase peticiones al «backend» de PHP-FPM si el fichero no existe, evitando así la inyección arbitraria de scripts.

    Esto se puede corregir estableciendo la directiva cgi.fix_pathinfo a 0 dentro del fichero php.ini.

    Cargar el php.ini:

    vim /usr/local/php/php.ini

    Localizar cgi.fix_pathinfo= y modificarla como sigue:

    cgi.fix_pathinfo=0

  6. Se debe modificar php-fpm.conf para especificar que php-fpm debe ejecutarse como el usuario www-data y el grupo www-data antes de poder iniciar el servicio:

    vim /usr/local/etc/php-fpm.conf

    Buscar y modificar lo siguiente:

    ; Usuario/grupo de procesos de Unix
; Nota: El usuario es obligatorio. Si el grupo no se establece, se utilizará
;       el grupo predeterminado del usuario.
user = www-data
group = www-data

    Ahora se puede iniciar el servicio de php-fpm:

    /usr/local/bin/php-fpm

    Esta guía no continua configurando php-fpm; si se tiene interés en una configuración mayor de php-fpm, consulte la documentación.

  7. Ahora Nginx debe configurarse para que pueda procesar aplicaciones de PHP:

    vim /usr/local/nginx/conf/nginx.conf

    Modificar el bloque de ubicaciones predeterminado para que intente servir ficheros .php:

    location / {
    root   html;
    index  index.php index.html index.htm;
}

    El siguiente paso es asegurarse de que los ficheros .php se pasan al «backend» de PHP-FPM. Bajo el bloque de ubicaciones predeterminado de PHP comentado, añadir lo siguiente:

    location ~* \.php$ {
    fastcgi_index   index.php;
    fastcgi_pass    127.0.0.1:9000;
    include         fastcgi_params;
    fastcgi_param   SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param   SCRIPT_NAME        $fastcgi_script_name;
}

    Reiniciar Nginx.

    sudo /usr/local/nginx/sbin/nginx -s stop
sudo /usr/local/nginx/sbin/nginx

  8. Crear un fichero de prueba

    rm /usr/local/nginx/html/index.html
echo "<?php phpinfo(); ?>" >> /usr/local/nginx/html/index.php

    Ahora, navegar a http://localhost. phpinfo() debería mostrarse.

Siguiendo los pasos anteriores se tendrá un servidor web Nginx funcionando con soporte para PHP como módulo SAPI. Por supuesto, existen muchas más opciones de configuración disponibles para Nginx y PHP. Para más información, teclear ./configure --help en el árbol de código fuente correspondiente.


Lighttpd 1.4 en sistemas Unix

Esta sección contiene anotaciones y consejos específicos para la instalación de PHP en Lighttpd 1.4 para sistemas Unix.

Por favor, antes de continuar consulte el » sistema de seguimiento de Lighttpd para saber cómo instalar Lighttpd apropiadamente.

La SAPI recomendada para conectar PHP a Lighttpd es Fastcig. Esta SAPI viene habilitada por omisión en php-cgi PHP 5.3. En versiones anteriores debe configurarse PHP con --enable-fastcgi. Para verificar que PHP tiene fastcgi habilitado, php -v debe contener PHP 5.2.5 (cgi-fcgi) En versiones anteriores a PHP 5.2.3, fastcgi estaba habilitado en el binario de php (no había php-cgi).

Permitiendo que Lighttpd lance procesos de php

Para configurar Lighttpd para que se conecte a php y lance procesos fastcgi, debe editar lighttpd.conf. Se recomienda utilizar sockets para conectar fastcgi a los procesos del sistema local.

Ejemplo #1 Extracto de lighttpd.conf

server.modules += ( "mod_fastcgi" )

fastcgi.server = ( ".php" =>
  ((
    "socket" => "/tmp/php.socket",
    "bin-path" => "/usr/local/bin/php-cgi",
    "bin-environment" => (
      "PHP_FCGI_CHILDREN" => "16",
      "PHP_FCGI_MAX_REQUESTS" => "10000"
    ),
    "min-procs" => 1,
    "max-procs" => 1,
    "idle-timeout" => 20
  ))
)

La directiva bin-path permite a lighttpd lanzar procesos fastcgi dinámicamente. PHP creará nuevos procesos hijos según se especifique en la variable de entorno PHP_FCGI_CHILDREN. La directiva "bin-environment" establece el entorno de los nuevos procesos. Cada vez que se alcance un determinado número de peticiones, determinado por PHP_FCGI_MAX_REQUEST, se matará un proceso. Las directivas "min-procs" y "max-procs" deben, por norma general, evitarse con PHP. PHP gestiona sus propios hijos, de forma que cachés como APC sólo estarán disponibles para los procesos gestionados por PHP. Si se establece "min-procs" a un número superior a 1, el número total de procesos oyentes en php se multiplicará por PHP_FCGI_CHILDREN (2 min-procs * 16 hijos produce 32 oyentes).

Lanzando procesos con spawn-fcgi

Lighttpd contiene el programa spawn-fcgi que facilita lanzar procesos fastcgi.

Lanzando procesos php-cgi

Pese a que es más laborioso, es posible lanzar procesos sin spawn-fcgi. La variable de entorno PHP_FCGI_CHILDREN controla cuántos procesos hijo de PHP se lanzarán para manejar las peticiones entrantes. PHP_FCGI_MAX_REQUESTS determinará el tiempo de vida (en peticiones) de cada proceso hijo. Aquí se muestra un script en bash que asiste en la creación de procesos php.

Ejemplo #2 Lanzando oyentes FastCGI

#!/bin/sh

# Ubicación del binario php-cgi
PHP=/usr/local/bin/php-cgi

# Ubicación del fichero PID
PHP_PID=/tmp/php.pid

# Enlazando a una dirección
#FCGI_BIND_ADDRESS=10.0.1.1:10000
# Enlazando a un socket de dominio
FCGI_BIND_ADDRESS=/tmp/php.sock

PHP_FCGI_CHILDREN=16
PHP_FCGI_MAX_REQUESTS=10000

env -i PHP_FCGI_CHILDREN=$PHP_FCGI_CHILDREN \
       PHP_FCGI_MAX_REQUESTS=$PHP_FCGI_MAX_REQUESTS \
       $PHP -b $FCGI_BIND_ADDRESS &

echo $! > "$PHP_PID"

Conexión a instancias FCGI remotas

Para poder tener aplicaciones escalables, pueden lanzarse instancias de fastcgi en múltiples equipos remotos.

Ejemplo #3 Conexión a instancias de php-fastcgi remotas

fastcgi.server = ( ".php" =>
   (( "host" => "10.0.0.2", "port" => 1030 ),
    ( "host" => "10.0.0.3", "port" => 1030 ))
)


Servior web LiteSpeed/OpenLiteSpeed en sistemas Unix

LiteSpeed ??PHP (LSPHP) es una compilación optimizada de PHP creada para funcionar con los productos de LiteSpeed a través de LiteSpeed ??SAPI. LSPHP se ejecuta como su propio proceso y tiene su propio binario independiente, el cual puede usarse como un simple binario de línea de comandos para ejecutar scripts PHP desde la terminal.

LSAPI es una API altamente optimizada que permite la comunicación entre LiteSpeed y motores web de terceros. Su protocolo es similar al FCGI, pero más eficiente.

Esta documentación abarcará la instalación y configuración de PHP con LSAPI tanto para un servidor web LiteSpeed como para un servidor web OpenLiteSpeed.

Esta guía asumirá que LSWS u OLS están instalados con sus rutas y banderas predeterminadas. El directorio de instalación predeterminado para ambos servidores será /usr/local/lsws y ambos se podrán ejecutar desde el subdirectorio bin.

Tenga en cuenta que a lo largo de esta documentación, los números de versión han sido reemplazados con una x para garantizar que esta se mantenga correcta en el futuro. Por favor, reemplácelos, según sea necesario, con los números de versión correspondientes.

  1. Para obtener e instalar el servidor web LiteSpeed o OpenLiteSpeed, visite la » página de instalación de la wiki de LiteSpeed, o la » página de instalación de la wiki de OpenLiteSpeed.

  2. Obtenga y descomprima el código fuente de PHP:

    mkdir /home/php
cd /home/php
wget http://us1.php.net/get/php-x.x.x.tar.gz/from/this/mirror
tar -zxvf php-x.x.x.tar.gz
cd php-x.x.x

  3. Configure y compile PHP. Aquí es donde PHP se puede personalizar con varias opciones, como pudieran ser las extensiones que se habilitarán. Ejecute ./configure --help para obtener una lista de opciones. En el ejemplo, utilizaremos las opciones de configuración recomendadas predeterminadas para el servidor web LiteSpeed:

    ./configure ... '--with-litespeed'
make
sudo make install

  4. Compruebe la instalación de LSPHP

    Una de las formas más simples de verificar si la instalación de PHP fue exitosa es ejecutar el siguiente código:

    cd /usr/local/lsws/fcgi-bin/
./lsphp5 -v

    Dicho código debería devolver información sobre la nueva compilación de PHP:

    PHP 5.6.17 (litespeed) (built: Mar 22 2016 11:34:19)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

    Observe el texto litespeed entre paréntesis. Esto significa que el binario de PHP ha sido construido con soporte para LSAPI.

Siguiendo los pasos anteriores, el servidor web LiteSpeed / OpenLiteSpeed debería encontrarse ejecutándose con soporte para PHP como extensión SAPI. Hay muchos más opciones de configuración disponibles para LSWS / OLS y PHP. Para más información, eche un vistazo a la wiki de LiteSpeed sobre » PHP.

Usando LSPHP desde la línea de comando:

El modo de línea de comandos LSPHP (LSAPI + PHP) se utiliza para procesar scripts PHP que se ejecutan en un servidor remoto que no necesariamente tiene un servidor web en ejecución. Se utiliza para procesar scripts PHP que residen en un servidor web local (separado). Esta configuración es adecuada para la escalabilidad del servicio, ya que el procesamiento de PHP se descarga a un servidor remoto.

Inicie lsphp desde la línea de comandos en un servidor remoto: LSPHP es un ejecutable y puede iniciarse manualmente y vincularse a IPv4, IPv6 o direcciones de socket de dominio Unix con la opción de línea de comandos -b socket_address

Ejemplos:

Haga que LSPHP utilice el puerto 3000 en todas las direcciones IPv4 e IPv6:

/path/to/lsphp -b [::]:3000

Haga que LSPHP utilice el puerto 3000 en todas las direcciones IPv4:

/path/to/lsphp -b *:3000

Haga que LSPHP utilice la dirección 192.168.0.2:3000:

/path/to/lsphp -b 192.168.0.2:3000

Haga que LSPHP acepte solicitudes en el socket de dominio Unix /tmp/lsphp_manual.sock :

/path/to/lsphp -b /tmp/lsphp_manual.sock

Las variables de entorno se pueden agregar antes del ejecutable LSPHP:

PHP_LSAPI_MAX_REQUESTS=500 PHP_LSAPI_CHILDREN=35 /path/to/lsphp -b IP_address:port

Actualmente, LiteSpeed PHP se puede usar con el servidor web LiteSpeed, OpenLiteSpeed y Apache mod_lsapi. Para pasos sobre configuración del lado del servidor, visite las páginas wiki de » LiteSpeed y » OpenLiteSpeed.

LSPHP también se puede instalar de otras formas:

CentOS: En CentOS, LSPHP puede ser instalado tanto desde el repositorio de LiteSpeed como desde el de Remi utilizando » RPM.

Debian: En Debian, LSPHP puede ser instalado desde el repositorio de LiteSpeed Repository utilizando » apt.

cPanel: Visite la respectiva » página de la wiki sobre cómo instalar LSPHP en cPanel y LSWS/OLS usando EasyApache 4.

Plesk: Plesk puede ser usado con LSPHP en CentOS, CloudLinux, Debian, y Ubuntu. Para más detalles en este tema, visite la correspondiente » página de la wiki


CGI y configuraciones de línea de comandos

Por defecto, PHP se construye como un programa CLI y CGI, que puede ser utilizado para el procesamiento de CGI. Si está ejecutando un servidor web PHP tiene soporte para los módulos, por lo general debe irse por esta solución por razones de rendimiento. Sin embargo, la versión CGI permite a los usuarios ejecutar diferentes páginas con PHP bajo diferentes identificadores de usuarios.

Advertencia

Al usar el modo CGI, su servidor esta expuesto a diferentes ataques. Por favor, leer la sección Seguridad con CGI para aprender cómo defenderse de estos ataques.

Pruebas

Si has construido PHP como un programa CGI, puede probar su construcción escribiendo make test. Siempre es una buena idea probar su construcción. De esta manera usted puede encontrar un problema al principio con PHP en la plataforma, en lugar de tener que luchar con él más adelante.

Utilización de variables

Algunos servidores suministrando variables de entorno no se definen en las actuales » CGI/1.1 specification. Sólo las siguientes variables no se definen: AUTH_TYPE, CONTENT_LENGTH, CONTENT_TYPE, GATEWAY_INTERFACE, PATH_INFO, PATH_TRANSLATED, QUERY_STRING, REMOTE_ADDR, REMOTE_HOST, REMOTE_IDENT, REMOTE_USER, REQUEST_METHOD, SCRIPT_NAME, SERVER_NAME, SERVER_PORT, SERVER_PROTOCOL, and SERVER_SOFTWARE. Todo lo demás debe ser tratado como "extensiones de proveedor".


Notas de instalación específicas para HP-UX

Esta sección contiene notas y consejos específicos para instalar PHP sobre sistemas HP-UX.

Existen dos opciones principales para instalar PHP sobre sistemas HP-UX. Ya sea compilarlo, o instalar un binario precompilado.

Los paquetes oficiales precompilados se localizan aquí: » http://software.hp.com/

Hasta que esta sección del manual sea reescrita, la documentación acerca de compilar PHP (y las extensiones relacionadas) sobre sistemas HP-UX ha sido removida. Por ahora, favor de considerar la lectura de los siguientes recursos externos: » Building Apache and PHP on HP-UX 11.11


Notas de instalación para OpenBSD

Esta sección contiene notas y consejos específicos a la instalación de PHP sobre » OpenBSD 3.6.

Utilizando paquetes binarios

Utilizar paquetes binarios para instalar PHP sobre OpenBSD es el método más simple y recomendado. El paquete principal ha sido separado de los distintos módulos, y cada uno puede ser instalado removido independientemente de los otros. Los ficheros que se necesitan pueden ser encontrados en el CD de OpenBSD o en el sitio FTP.

El paquete principal que se necesita instalar es php4-core-4.3.8.tgz, que contiene el motor básico (además de gettext e iconv). Seguido, tómese un vistazo a los paquetes de módulos, tales como php4-mysql-4.3.8.tgz o php4-imap-4.3.8.tgz. Se necesita emplear el comando phpxs para activar y desactivar estos módulos en el fichero php.ini.

Ejemplo #1 Ejemplo de instalación de paquete de OpenBSD

# pkg_add php4-core-4.3.8.tgz
# /usr/local/sbin/phpxs -s
# cp /usr/local/share/doc/php4/php.ini-recommended /var/www/conf/php.ini
  (agregar mysql)
# pkg_add php4-mysql-4.3.8.tgz
# /usr/local/sbin/phpxs -a mysql
  (agregar imap)
# pkg_add php4-imap-4.3.8.tgz
# /usr/local/sbin/phpxs -a imap
  (quitar mysql a manera de prueba)
# pkg_delete php4-mysql-4.3.8
# /usr/local/sbin/phpxs -r mysql
  (instalar las librerías de PEAR)
# pkg_add php4-pear-4.3.8.tgz

Leer la página del manual » packages(7) para mas información sobre paquetes binarios en OpenBSD.

Utilizando portes

También se puede compilar PHP a partir de fuentes utilizando el » árbol de portes. Sin embargo, esto sólo se recomienda para usuarios familiarizados con OpenBSD. El porte de PHP 4 está dividido en dos subdirectorios: core y extensions. El directorio extensions genera subpaquetes para todos los módulos soportados de PHP. Si se encuentra que no se desea crear alguno de estos módulos, utilice el sabor o FLAVOR no_*. Por ejemplo, para evitar compilar el módulo imap, fijar el sabor o FLAVOR a no_imap.

Problemas comunes

  • La instalación por omisión de Apache se ejecuta dentro de una » jaula chroot(2), que habrá de restringir a los script PHP el acceso a ficheros debajo de /var/www. Por lo tanto se requiere crear un directorio /var/www/tmp para que los ficheros de sesión de PHP sean almacenados, o utilizar un medio alternativo de almacenamiento de sesiones. Además, los sockets de base de datos necesitan colocarse dentro de la jaula o escuchar en la interfaz de localhost. Se se hace uso de funciones de red, algunos ficheros de /etc tales como /etc/resolv.conf y /etc/services tendrán que ser movidos a /var/www/etc. El paquete PEAR de OpenBSD automáticamente se instala dentro de los directorios correctos del chroot, así que no hace falta ninguna modificación especial ahí. Más información sobre el Apache de OpenBSD está disponible en las preguntas frecuentes OpenBSD.
  • El paquete de OpenBSD 3.6 para la extensión » gd requiere que XFree86 sea instalado. Si no se desea utilizar algunas de las características de fuentes tipográficas que requieren de X11, es mejor instalar el paquete php4-gd-4.3.8-no_x11.tgz.

Ediciones antiguas

Ediciones antiguas de OpenBSD utilizaban el sistema FLAVORS para compilar un PHP enlazado estáticamente. Dado que es difícil generar paquetes binarios utilizando este método, ahora es depreciado. Aún es posible utilizar los viejos árboles estables de ports si así se desea, pero carecen de soporte por parte del equipo de OpenBSD. Si se tiene algún comentario al respecto, el responsable actual del port es Anil Madhavapeddy (avsm arroba openbsd punto org).


Solaris sugerencias específicas de instalación

Esta sección contiene notas y sugerencias específicas para la instalación de PHP en sistemas Solaris.

Software necesario

La instalacion Solaris carece con frecuencia de los compiladores de C y sus herramientas relacionadas. Lea las preguntas frecuentes para obtener información sobre porqué usar versiones GNU de algunas de estas herramientas.

Para descomprimir la distribución PHP se necesita

  • tar
  • gzip ó
  • bzip2

Para compilar PHP se necesita

  • gcc (recomendado, aunque puede que sirvan otros compiladores de C)
  • make
  • GNU sed

Para compilar extensiones adicionales o hackear el código PHP puede que se necesite también

  • flex (versión PHP 5.2 o posterior)
  • re2c
  • bison
  • m4
  • autoconf
  • automake
Además, usted tendrá que instalar (y posiblemente compilar) cualquier software adicional específico para la configuración, tales como Oracle o MySQL.

Empleo de paquetes

Se puede simplificar el procesao de intalación de Solaris mediante el uso de pkgadd para instalar la mayoría de sus componentes necesarios. El Sistema de Empaquetado de Imagen (IPS) para Solaris 11 Express contiene también la mayoría de los componentes requeridos para la instalación usando el comando pkg.


Notas de instalación en Debian GNU/Linux

Esta sección contiene notas y consejos específicos para instalar PHP sobre » Debian GNU/Linux.

Advertencia

No se ofrece soporte de builds no oficiales de terceros. Cualquier bug debe ser informado al equipo de Debian a no ser que puedan reproducirse usando los últimos builds de nuestra » zona de descargas.

Mientras que las instrucciones para construir PHP sobre Unix se aplican a Debian también, esta página del manual contiene información específica para otras opciones, tales como utilizar ya sea los comandos apt-get o aptitude. En esta página del manual estos dos comandos se pueden utilizar indistintamente.

Utilizando APT

Primero, nótese que otros paquetes relacionados podrían ser deseables como libapache2-mod-php5 para integración con Apache 2, y php-pear para PEAR.

Segundo, antes de instalar un paquete, es sensato asegurarse de que la lista de paquetes está al día. Típicamente, esto se realiza ejecutando el comando apt-get update.

Ejemplo #1 Ejemplo de Instalación en Debian con Apache 2

# apt-get install php5-common libapache2-mod-php5 php5-cli

APT instalará automáticamente el módulo PHP 5 para Apache 2 junto con todas sus dependencias, y luego lo activará. Apache debería reiniciarse para que los cambios tengan efecto. Por ejemplo:

Ejemplo #2 Deteniendo e iniciando Apache una vez que PHP está instalado

# /etc/init.d/apache2 stop
# /etc/init.d/apache2 start

Un mejor control de la configuración

En la sección anterior, PHP se instaló únicamente con los módulos principales. Es muy probable que se deseen módulos adicionales, tales como MySQL, cURL, GD, etc. Estos también pueden ser instalados vía el comando apt-get.

Ejemplo #3 Métodos para listar paquetes relacionados con PHP 5

# apt-cache search php5
# aptitude search php5
# aptitude search php5 |grep -i mysql

Los ejemplos mostrarán una gran cantidad de paquetes incluyendo varios específicos a PHP como php5-cgi, php5-cli y php5-dev. Determine cuales son necesarios e instálelos como cualquier otro ya sea con apt-get o aptitude. Y ya que Debian realiza revisión de dependencias, preguntará por ellos, así que por ejemplo para instalar MySQL y cURL:

Ejemplo #4 Instalar PHP con MySQL, cURL

# apt-get install php5-mysql php5-curl

APT agregará automáticamente las líneas apropiadas a los diferentes ficheros relacionados con php.ini como /etc/php5/apache2/php.ini, /etc/php5/conf.d/pdo.ini, etc. y dependiendo de la extensión, le agregará registros similares a extension=foo.so. De cualquier manera, reiniciar el servidor web (como es Apache) es requerido antes de que estos cambios tengan efecto.

Problemas Frecuentes

  • Si los scripts de PHP no se están interpretando por el servidor web, entonces es probable que PHP no haya sido agregado al fichero de configuración del servidor web, que en Debian puede ser /etc/apache2/apache2.conf o algo semejante. Véase el manual de Debian para mayores detalles.
  • Si una extensión fue aparentemente instalada y aún así las funciones no aparecen definidas, asegurar de que el fichero ini apropiado está siendo cargado y/o que el servidor web fue reiniciado después de la instalación.
  • Hay dos comandos básicos para instalar paquetes en Debian (y otras variantes de linux): apt-get y aptitude. Pero, explicar las sutiles diferencias entre estos comandos va más allá del alcance de este manual.


Instalación en Mac OS X

Tabla de contenidos

  • Empleo de paquetes
  • Usando el paquete PHP
  • Compilar PHP en Mac OS X

Esta sección contiene notas y sugerencias específicas para la instalación de PHP en Mac OS X. PHP se incluye con Mac, y la compilación es similar a la guía de instalación Unix .


Empleo de paquetes

Hay algunas versiones preempaquetadas y precompiladas de PHP para Mac OS X. Esto puede ayudar en la creación de una configuración estándar, pero si fuera necesario tener un conjunto diferente de características (como un servidor seguro, o un controlador de base de datos diferente), es posible que sea necesario construir PHP y/o un servidor web. Si no está familiarizado con la construcción y compilación de su propio software, vale la pena revisar si alguien ya ha construido una versión empaquetada de PHP con las características que necesita.

Los siguientes recursos ofrecen paquetes fáciles de instalar y binarios precompilados para PHP en Mac OS:

  • MacPorts: » http://www.macports.org/
  • Liip: » http://php-osx.liip.ch/
  • Fink: » http://www.finkproject.org/
  • Homebrew: » https://github.com/Homebrew/brew


Usando el paquete PHP

PHP está incluido en los Macs desde la versión OS X 10.0.0. Habilitar PHP con el servidor web por defecto requiere descomentar unas cuantas líneas en el fichero de configuración de Apache httpd.conf donde CGI y/o CLI están activados por defecto (son fácilmente accesibles a través del programa Terminal).

Siguiendo las instrucciones que se ofrecen a continuación se podrá habilitar PHP de una forma rápida para un entorno de desarrollo local. Es muy recomendable tener siempre actualizado PHP a la última versión. Como casi todo el software vivo, y PHP no es una excepción, se crean nuevas versiones para resolver errores y añadir nuevas funcionalidades. Consulte la documentación de instalación de Mac OS X adecuada para más detalles. Las siguientes instrucciones para obtener una configuración están orientadas a los principiantes que deseen obtener una configuración totalmente operativa. Se anima a todos los usuarios a compilar o instalar una nueva versión ya empaquetada.

La instalación típica es mediante mod_php. Para habilitar el paquete mod_php que viene en el Mac OS X para el servidor web Apache (el servidor web por defecto, al que se puede acceder mediante las Preferencias del Sistema) se requiere efectuar los siguientes pasos:

  1. Localizar y abrir el archivo de configuración de Apache. Por defecto, la localización de dicho fichero es: /private/etc/apache2/httpd.conf Mediante el Finder o el Spotlight puede ser algo complicado encontrar dicho fichero ya que por defecto es privado y pertenece al usuario root.

    Nota: Una forma de abrir el fichero es usando un editor de texto basado en UNIX en el Terminal, como por ejemplo nano. Debido a que el fichero pertenece al usuario root se debe emplear el comando sudo para abrirlo (como si fueramos el usuario root). Por ejemplo, teclée lo siguiente en el Terminal (tras lo cual le preguntará por la contraseña): sudo nano /private/etc/apache2/httpd.conf Comandos de nano a tener en cuenta: ^w (buscar), ^o (guardar), and ^x (salir) donde ^ representa la tecla Ctrl.

    Nota: Las versiones de Mac OS X anteriores a 10.5 tienen incorporadas versiones antiguas de PHP y Apache. Por ello, es posible que el fichero de configuracion de Apache se encuentre en dichos equipos en /etc/httpd/httpd.conf.

  2. En el editor de texto, descomente las líneas (eliminando el símbolo #) que sean similares a las que se muestran a continuación (a menudo estas líneas se encuentran separadas, asi que tendrá que localizar ambas en el fichero):

    # LoadModule php5_module libexec/httpd/libphp5.so

# AddModule mod_php5.c
    Fíjese en la localización/ruta de acceso. Cuando compile PHP en el futuro, las lineas arriba indicadas deberán ser reemplazadas o comentadas.

  3. Asegúrese que las extensiones que desee puedan ser interpretadas como PHP (por ejemplo: .php .html y .inc)

    Como las siguientes sentencias ya existían en el httpd.conf (desde el Max Panther), una vez se habilite PHP los ficheros .php automáticamente seran interpretados como PHP.

    <IfModule mod_php5.c>
    # If php is turned on, we respect .php and .phps files.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    # Since most users will want index.php to work we
    # also automatically enable index.php
    <IfModule mod_dir.c>
        DirectoryIndex index.html index.php
    </IfModule>
</IfModule>

    Nota:

    Con anterioridad a OS X 10.5 (Leopard) se empaquetaba PHP 4 en lugar de PHP 5, en cuyo caso las instrucciones anteriores pueden ser ligeramente diferentes cambiando los 5 por los 4.

  4. Asegúrese que DirectoryIndex carga el fichero por defecto index deseado Esto tambien se configura en httpd.conf. Normalmente se usan index.php y index.html. Por defecto index.php está habilitado porque está incluido en la comprobación de PHP mostrada arriba. Ajuste a conveniencia.
  5. Configure la localizacion de php.ini o use el valor por defecto. Por defecto se localiza en los Mac OS X en /usr/local/php/php.ini y empleando phpinfo() se puede obtener esta información. Si no se está usando php.ini, PHP usará los valores por defecto. Véase también las preguntas frecuentes relacionadas en finding php.ini.
  6. Localize o configure el DocumentRoot Éste es el directorio raíz de todos los ficheros web. Los ficheros en este directorio son obtenidos del servidor web a fin de que los ficheros PHP sean ejecutados como PHP antes de ser enviados al navegador. Una ruta de acceso típica es /Library/WebServer/Documents pero puede ser configurada en httpd.conf. Como alternativa, el DocumentRoot por defecto para usuarios individuales es /Users/yourusername/Sites
  7. Cree un fichero phpinfo()

    La función phpinfo() muestra información sobre PHP. Considere la creación de un fichero en el DocumentRoot que contenga el siguiente código PHP:

    <?php phpinfo(); ?>

  8. Reinicie Apache, y cargue el fichero PHP creado arriba

    Para reiniciar, ejecute sudo apachectl graceful en el shell o desactive/active la opción "Compartir Web" en las Preferencias del Sistema. Por defecto, cargar ficheros locales en el navegador tiene una URL parecida a: http://localhost/info.php. Usar DocumentRoot en el directorio del usuario es otra opción, y la URL sería parecida a: http://localhost/~yourusername/info.php

CLI (o CGI en versiones antiguas) también es llamado de forma correcta php y posiblemente existe como /usr/bin/php. Abra el Terminal, lea la sección de línea de comando del manual de PHP, y ejecute php -v para comprobar la versión de PHP del binario PHP. Una llamada a phpinfo() también le mostrará esta información.


  • « Usando el paquete PHP
  • Instalación en sistemas Windows »
  • PHP Manual
  • Instalación en Mac OS X
  • Compilar PHP en Mac OS X

Compilar PHP en Mac OS X

Utilice la guía de instalación en Unix para compilar PHP en OS X.


Instalación en sistemas Windows

Tabla de contenidos

  • Herramientas de instalación de PHP en Windows
  • Configuración recomendada en sistemas Windows
  • Instalación manual de PHP en Windows
  • Resolución de problemas de PHP en Windows
  • Instalación en sistemas Windows

Installing PHP on modern Microsoft Windows systems and recommended configuration with common web servers.

Nota:

If you are looking for information about older systems, such as Windows XP, 2003, 98 or Apache 1.x, see the Legacy Info section.

The Official releases of PHP on Windows are recommended for production use. However, you are welcome to build PHP from Source. You will need a Visual Studio environment. See » Step by Step Build Instructions.

Using PHP on Windows Command line Installing PHP on Azure App Services (aka Microsoft Azure, Windows Azure, or (Windows) Azure Web Apps).


Herramientas de instalación de PHP en Windows

Herramientas de instalación de PHP

Si quiere configurar PHP y está usando IIS, la forma más fácil es usar » El instalador de la plataforma web de Microsoft (WebPI).

» XAMPP, WampServer y BitNami configurarán las aplicaciones PHP para su uso con Apache en Windows.

La configuración de Nginx en Windows requiere un poco más de configuración. Vea la » documentación de Nginx para obtener ayuda adicional con la configuración.


Configuración recomendada en sistemas Windows

OpCache

Se recomienda habilitar OpCache. Esta extensión está incluida en PHP para Windows. Compila y optimiza scripts de PHP y los almancena en memoria caché para así no tener que compilarlos cada vez que se cargue la página.

En el php.ini, establezca

Ejemplo #1 Configuración recomendada de WinCache

zend_extension=php_opcache.dll
opcache.enable=On
opcache.cli_enable=On
Y reinice el servidor web. Para más información, vea: Configuración de OpCache

WinCache

Se recomineda que se use WinCache si se utiliza IIS, especialmente en un entorno de alojamiento web compartido o si se utuliza el almacenamiento de ficheros en red (NAS). Todas las aplicaciones de PHP se benefician automáticamente de la funcionalidad de almancenamiento en caché de WinCache. Las operaciones en el sistema de ficheros se almacenan en memoria caché. WinCache también puede almacenar en memoria caché objetos de usuario y compartirlos entre procesos de php.exe o php-cgi.exe (objetos compartidos entre peticiones). Muchas de las grandes aplicaciones web tienen un complemento, extensión u opción de configuración para hacer uso de la caché de objetos de usuario de WinCache. Si lo que necesita es un alto rendimiento, debería utilizar la caché de objetos en sus aplicaciones. Vea: » http://pecl.php.net/package/WinCache para descargar una DLL (o tgz) de WinCache a su directorio de extensiones de PHP (extensions_dir en el php.ini). En el php.ini, establezca

Ejemplo #2 Configuración recomendada de WinCache

extension=php_wincache.dll
wincache.fcenabled=1
wincache.ocenabled=1
Para más información, vea: » http://php.net/manual/en/wincache.configuration.php

Configuración de IIS

En el Administrador de IIS, Instalar módulo FastCGI y añadir un manejador para `.php` a la ruta de PHP-CGI.exe (no de PHP.exe)

Se puede también utilizar la herramienta de línea de comandos APPCMD para configurar IIS.

Base de datos

Probablemente necesitará un servidor de bases de datos. Las bases de datos populares proporcionan extensiones de PHP para utillzarlas. Si su sitio web no tiene mucho tráfico, puede ejecutar el servidor de bases de datos en su mismo servidor web. Muchos servidores de bases de datos se ejecutan en Windows.

PHP incluye las extensiones mysqli y pdo_mysql. PHP 5.5 y 5.6 incluyen la extensión mysql (obsoleta en 7.0).

Véase » https://dev.mysql.com/downloads/windows/


Instalación manual de PHP en Windows

Elección del servidor web

  • IIS está integrado en Windows. En Windows Server, use Server Manager para añadir el rol de IIS. Asegúrese de incluir CGI Role Feature. En Windows Desktop, use Añadir/Eliminar Programas del Panel de Control para añadir IIS. Véase: » https://msdn.microsoft.com/en-us/library/ms181052%28v=vs.80%29.aspx?f=255&MSPPError=-2147217396 Para aplicaciones web de escritorio y desarrollo web también se puede usar IIS/Express o PHP Desktop

    Ejemplo #1 Linea de órdenes para configurar IIS y PHP

    @echo off

    REM Descargar el fichero .ZIP o la compilación de PHP desde http://windows.php.net/downloads/
    REM
    REM Ruta al directorio donde se ha descomprimido el fichero .ZIP de PHP
set phpdir=c:\php
set phppath=php-5.6.19-nts-Win32-VC11-x86

REM Limpiar los manejadores actuales de PHP
%windir%\system32\inetsrv\appcmd clear config /section:system.webServer/fastCGI
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /-[name='PHP_via_FastCGI']

REM Instalar el manejador de PHP
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI /+[fullPath='%phpdir%\%phppath%\php-cgi.exe']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /+[name='PHP_via_FastCGI',path='*.php',verb='*',modules='FastCgiModule',scriptProcessor='%phpdir%\%phppath%\php-cgi.exe',resourceType='Unspecified']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /accessPolicy:Read,Script

REM Configurar las variables de FastCGI
%windir%\system32\inetsrv\appcmd set config -section:system.webServer/fastCgi /[fullPath='%phpdir%\%phppath%\php-cgi.exe'].instanceMaxRequests:10000
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phpdir%\%phppath%\php-cgi.exe'].environmentVariables.[name='PHP_FCGI_MAX_REQUESTS',value='10000']"
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phpdir%\%phppath%\php-cgi.exe'].environmentVariables.[name='PHPRC',value='%phpdir%\%phppath%\php.ini']"
    Cómo configurar manualmente IIS

  • Existen varias compilaciones de Apache2 para Windows. Aquí se da soporte a ApacheLounge, aunque otras opciones pueden ser XAMPP, WampServer y BitNami, las cuales proporcionan herramientas de instalación automática. Se puede utilizar mod_php o mod_fastcgi para cargar PHP en Apache. Si se emplea mod_php, se DEBE utlizar como una compilación TS de Apache construida con la misma versión de Visual C y la misma CPU (x86 o x64). Cómo configurar manualmente Apache2

Elegir una compilación

Descargue las versiones de producción de PHP desde » http://windows.php.net/download/. Ya se han realizado muchas pruebas y optimizaciones en las versiones imagen y de aseguramiento de la calidad, aunque cualquier es bienvenido para ayudar a realizar más. Existen cuantro tipos de compilación de PHP:

  • Thread-Safe(TS) - usada para servidores web monoproceso, como Apache con mod_php

  • Non-Thread-Safe(NTS) - usada para IIS y otros servidores web FastCGI (Apache con mod_fastcgi) y la recomendad para scripts de línea de órdenes

  • x86 - producción usada por PHP 5.5 o 5.6 o 7.0.

  • x64 - producción usada por PHP 7.0+ a menos que sea una versión de Windows de 32 bits solamente. 5.5 y 5.6 x64 son experimentales.


Resolución de problemas de PHP en Windows

Comprobar los permisos del directorio temporal

  1. Clic derecho en el directorio temporal con el Explorador de archivos para mostrar los permisos.

  2. Para IIS, compruebe que el usuario IIS_User posee el permiso MODIFY. Se puede saber cuál es el directorio temporal a través de la configuración o información de php.


Instalación en sistemas Windows

Esta sección se aplica a Windows 98/Me y Windows NT/2000/XP/2003. PHP no funcionará en plataformas de 16 bits, como Windows 3.1. A veces se referirá a las plataformas de Windows admitidas como Win32.

Nota:

Ya no se da soporte a Windows XP/2003 a partir de PHP 5.5.0.

Nota:

Ya no se da soporte a Windows 98/Me/NT4 a partir de PHP 5.3.0.

Nota:

Ya no se da soporte a Windows 95 a partir de PHP 4.3.0.

Si posee un entorno de desarrollo como Microsoft Visual Studio, también puede PHP desde el código fuente original.

Una vez que haya instalado PHP en su sistema Windows, también podrá cargar varias extensiones para aumentar la funcionalidad.

Pasos para una instalación manual

Esta sección contiene instrucciones para instalar y configurar manualmente PHP en Windows de Microsoft.

Selección y descarga de el paquete de distribución PHP

Descarga la distribución binaria desde » PHP para Windows: Binarios y Fuentes . Hay varias versiones diferentes del paquete zip. Para seleccionar la versión adecuada, siga la guía detallada en la » página de descargas.

La estructura del paquete PHP y el contenido

Descomprimir el contenido del archivo zip en un directorio de su elección, por ejemplo C:\PHP\. La estructura de directorios y archivos extraídos de del zip se verá de la siguiente manera:

Ejemplo #1 PHP 5 paquete de estructura

c:\php
   |
   +--dev
   |  |
   |  |-php5ts.lib                 -- php5.lib in non thread safe version
   |
   +--ext                          -- extension DLLs for PHP
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-...
   |
   +--extras                       -- empty
   |
   +--pear                         -- initial copy of PEAR
   |
   |
   |-go-pear.bat                   -- PEAR setup script
   |
   |-...
   |
   |-php-cgi.exe                   -- CGI executable
   |
   |-php-win.exe                   -- executes scripts without an opened command prompt
   |
   |-php.exe                       -- Command line PHP executable (CLI)
   |
   |-...
   |
   |-php.ini-development           -- default php.ini settings
   |
   |-php.ini-production            -- recommended php.ini settings
   |
   |-php5apache2_2.dll             -- does not exist in non thread safe version
   |
   |-php5apache2_2_filter.dll      -- does not exist in non thread safe version
   |
   |-...
   |
   |-php5ts.dll                    -- core PHP DLL ( php5.dll in non thread safe version)
   |
   |-...

A continuación se muestra la lista de los módulos y archivos ejecutables incluidos en la distribución del archivo zip de PHP:

  • go-pear.bat - el script de configuración de PEAR. Consulte » Instalación (PEAR) para más detalles.

  • php-cgi.exe - ejecutable CGI que se puede utilizar cuando se ejecuta PHP en IIS a través de CGI o FastCGI.

  • php-win.exe - el ejecutable para la ejecución de scripts en PHP sin necesidad de utilizar una ventana de línea de comandos de PHP (Por ejemplo, las aplicaciones PHP que utilizan Windows GUI).

  • php.exe - el ejecutable para la ejecución de scripts PHP dentro de una interfaz de línea de comandos (CLI) de PHP.

  • php5apache2_2.dll - Apache 2.2.X module.

  • php5apache2_2_filter.dll - Apache 2.2.X filter.

Cambio el fichero php.ini

Después de que el contenido del paquete de PHP se ha extraído, copie el php.ini-production en php.ini en la misma carpeta. Si es necesario, también es posible colocar el php.ini en cualquier otro lugar. Pero se requieren pasos adicionales de configuración como se describe en Configuración de PHP.

El fichero php.ini le dice a PHP cómo se configura, y cómo trabajar con el ambiente que se ejecuta. Aquí hay una serie de ajustes para el fichero php.ini PHP que ayudan a trabajar mejor con Windows. Algunos de estos son opcionales. Hay muchas otras directivas que puedan ser relevantes para su ambiente - dirijase lista de directivas php.ini para más información.

Las directivas:

  • extension_dir = <path to extension directory> - La extension_dir necesidades para indicar el directorio donde las extensiones de PHP se almacenan los ficheros. La ruta puede ser absoluta (i.e. "C:\PHP\ext") o (i.e. ".\ext"). Extensiones que se enumeran más baja en el php.ini ficheros que se encuentra en el extension_dir .

  • extension = xxxxx.dll - Para cada extensión que desee habilitar, necesita un correspondiente "extension=" directiva que le dice a PHP que las extensiones en el extension_dir para cargar en tiempo de inicio.

  • log_errors = On - PHP tiene un error de registro de instalación que se puede utilizar para enviar los errores a un fichero, o de un servicio (i.e. syslog) y trabaja en conjunto con el error_log Directiva a continuación. Cuando se ejecuta bajo IIS, la log_errors debe estar habilitado, con una validez error_log .

  • error_log = <path to the error log file> - El error_log tiene que especificar la ruta de acceso absoluta, o en relación con el archivo donde los errores de PHP debe estar registrado. Este archivo debe tener permisos de escritura para el servidor web. Los lugares más comunes para este archivo en varios directorios TEMP, por ejemplo "C:\inetpub\temp\php-errors.log".

  • cgi.force_redirect = 0 - La presente Directiva se requiere para ejecutar en IIS. Se trata de una protección de la instalación de la guía necesaria por muchos otros servidores web. Sin embargo, lo que permite que en IIS hacer que el motor de PHP a un error en Windows.

  • cgi.fix_pathinfo = 1 - Esto le permite acceder a PHP al real path después de la especificación CGI. IIS FastCGI implementa las necesidades de este conjunto.

  • fastcgi.impersonate = 1 - FastCGI bajo IIS admite la posibilidad de hacerse pasar por tokens de seguridad del cliente que llama. Esto permite que IIS defina el contexto de seguridad que solicita ejecutar.

  • fastcgi.logging = 0 - FastCGI debe estar deshabilitado en IIS. Si se deja habilitada, los mensajes de cualquier clase son tratados por FastCGI como las condiciones de error que hará que IIS genere una excepción HTTP 500.

Directivas opcionales

  • max_execution_time = ## - Esta directiva le dice a PHP, el importe máximo de tiempo que puede ejecutar cualquier script determinado. El defecto es 30 segundos. Aumentar el valor de esta directiva, si la aplicación PHP tomar mucho tiempo para ejecutarse.

  • memory_limit = ###M - La cantidad de memoria disponible para el proceso de PHP, en Megabytes. El valor por defecto es 128, lo cual está bien para la mayoría de las aplicaciones PHP. Algunos de los más complejos puede ser que necesite más.

  • display_errors = Off - Esta directiva le dice a PHP si se incluyen los mensajes de error en el corriente que devuelve al servidor web. Si se establece en "On", entonces PHP enviará lo que las clases de errores que se define con la error_reporting directiva de nuevo al servidor web como parte de la secuencia de error. Por razones de seguridad, se recomienda "Off" en los servidores de producción con el fin de no revelar ninguna información sensible de la seguridad que a menudo se incluyen en los mensajes de error.

  • open_basedir = <paths a directorios, separados por semicolon>, por ejemplo, openbasedir="C:\inetpub\wwwroot;C:\inetpub\temp". Esta directiva especifica las rutas de directorio en donde PHP se le permite realizar las operaciones del sistema de archivos. Cualquier operación de fichero fuera de las rutas especificadas se producirá un error. Esta directiva es especialmente útil para bloquear la instalación de PHP en entornos de alojamiento compartido para evitar que scripts PHP de acceso a los archivos fuera del directorio raíz del sitio web.

  • upload_max_filesize = ###M and post_max_size = ###M - El tamaño máximo permitido de un archivo subido y los datos posteriores, respectivamente. Los valores de estas directivas serán aumenta si las aplicaciones PHP necesita realizar grandes cargas, como por ejemplo fotos o archivos de vídeo.

PHP esta ahora configurado en el sistema. El siguiente paso es elegir un servidor web, a fin de que pueda ejecutar PHP. Elegir un servidor web de la tabla de contenido.

Además de ejecutar PHP a través de un servidor web, PHP puede ejecutar desde la línea de comandos como un script .BAT. Ver

Microsoft IIS

Esta sección contiene instrucciones específicas de la instalación de PHP en Microsoft Internet Information Services (IIS).

  • Instalación manual de PHP en Microsoft IIS 5.1 y IIS 6.0
  • Instalación manual de PHP en Microsoft IIS 7.0 y posteriores

Microsoft IIS 5.1 y IIS 6.0

Esta sección contiene instrucciones para configurar en forma manual Internet Information Services (IIS) 5.1 y IIS 6.0 para trabajar con PHP en Microsoft Windows XP y Windows Server 2003. Para obtener instrucciones sobre la configuración de IIS 7.0 y versiones posteriores de Windows Vista , Windows Server 2008, Windows 7 y Windows Server 2008 R2 referirse a Microsoft IIS 7.0 y posteriores.

Configurar IIS para procesar solicitudes de PHP

Descarga e instala PHP de acuerdo a las instrucciones descritas en manual detallado de instalación

Nota:

Non-thread-safe build de PHP se recomienda cuando se utiliza IIS. Non-thread-safe builds están disponibles en » PHP para Windows: Binarios y Fuentes.

Configure el CGI- y configure FastCGI-specific en el archivo php.ini como se muestra a continuación:

Ejemplo #2 Configuración CGI y FastCGI en php.ini

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0

Descargue e instale » Microsoft FastCGI extensión para IIS 5.1 y 6.0. La extensión está disponible para 32-bit y plataformas de 64-bit - seleccionar el paquete de descarga adecuada para la plataforma.

Configure la extensión FastCGI para manejar las solicitudes específicas de PHP ejecutando el comando que se muestra a continuación. Vuelva a colocar el valor de el parámetro "-path" con la ruta absoluta del fichero en el fichero php-cgi.exe.

Ejemplo #3 Configuración de la extensión FastCGI para manejar las solicitudes de PHP

cscript %windir%\system32\inetsrv\fcgiconfig.js -add -section:"PHP" ^
-extension:php -path:"C:\PHP\php-cgi.exe"

Este comando creará un script de mapeo IIS para el fichero de extensión *.php , lo que resultará en todas las URLs que terminan con .php siendo manejado por la extensión FastCGI. Asimismo, se configurará la extensión FastCGI a usar en el ejecutable php-cgi.exe para procesar las solicitudes de PHP.

Nota:

En este punto la necesidad de instalación y configuración de los pasos se han completado. El resto de instrucciones a continuación son opcionales, pero altamente recomendable para lograr una funcionalidad óptima y el rendimiento de PHP en IIS.

Suplantación y acceso a ficheros del sistema

Se recomienda habilitar la suplantación FastCGI en PHP cuando este utilizando IIS. Esto es controlado por la directiva fastcgi.impersonate en el fichero php.ini. Cuando suplantación está activado, PHP realizará todas las operaciones de ficheros de sistema en favor de la cuenta de usuario que se ha determinado por la autentificación de IIS. Esta asegura que, incluso si el mismo proceso PHP se comparte entre diferentes sitios web IIS, los scripts PHP en estos sitios web no podrá acceder a los otros fichero ' siempre y cuando use cuentas de usuario diferentes utilizado para la autenticación IIS en cada sitio web.

Por ejemplo IIS 5.1 and IIS 6.0, en su configuración predeterminada, se ha habilitado la autenticación anónima con una función de cuenta de usuario IUSR_<MACHINE_NAME> utilizado como una identidad por defecto. Esto significa que para que IIS puede ejecutar scripts PHP, es necesario concedera la cuenta IIUSR_<MACHINE_NAME> permiso de lectura en estos scripts. Si las aplicaciones PHP necesitan realizar operaciones de escritura sobre determinados ficheros o escribir ficheros en algunas carpetas a continuación la cuenta IUSR_<MACHINE_NAME> debe tener permiso para escribir en ellos.

Para determinar qué cuenta de usuario es utilizado por IIS autenticación anónima, siga estos pasos:

  1. En el menú Inicio de Windows seleccione "Run:", type "inetmgr" y haga clic en "Ok";

  2. Expanda la lista de sitios web en el nodo "Web Sites" en la vista de árbol, haga clic derecho en el sitio web que se está utilizando y seleccionar "Properties";

  3. Haga clic en "Directory Security" tab;

  4. Tome nota de un "User name:" campo en el cuadro de dialogo "Authentication Methods"

Autenticación anonima para IIS 5.1 y IIS 6.0

Para modificar la configuración de permisos en ficheros y carpetas, utilice la interfaz de usuario de el Explorador de Windows o el comando icacls.

Ejemplo #4 Configuración del fichero de los permisos de acceso

icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

Establecerindex.php como un documento predeterminado en IIS

Los documentos por defecto de IIS se utilizan para las solicitudes HTTP que no especifican un nombre de documento. Con las aplicaciones PHP, index.php suele actuar como un documento predeterminado. Para añadir index.php a la lista de documentos predeterminados IIS, siga estos pasos:

  1. En el menú Inicio de Windows seleccione "Run:", teclee "inetmgr" y haga clic en "Ok";

  2. Haga clic derecho en el nodo ""Web Sites" de la vista de árbol y seleccione "Properties";

  3. Haga clic en "Documents" tab;

  4. Haga clic en el botón "Add..." y enter en "index.php" para el " Contenido de la página por defecto :".

Configuración index.php como documento predeterminado para IIS

FastCGI y Reciclaje de configuración de PHP

Configurar la extensión IIS FastCGI para el reciclaje de procesos PHP utilizando los comandos de abajo. Los controles de configuración de FastCGI instanceMaxRequests número de solicitudes que serán procesadas por un solo proceso php-cgi.exe antes de el cierre de la extensión FastCGI. La variable PHP de entorno PHP_FCGI_MAX_REQUESTS controla cuántas peticiones de un único proceso php-cgi.exe se encargará antes de que se recicle así mismo. Asegúrese de que el valor especificado por la configuración FastCGI InstanceMaxRequests es menor o igual al valor especificado para PHP_FCGI_MAX_REQUESTS.

Ejemplo #5 Configuración FastCGI y reciclaje PHP

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-InstanceMaxRequests:10000

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHP_FCGI_MAX_REQUESTS:10000

Configuración de los ajustes de tiempo de espera FastCGI

Aumentar la configuración de tiempo de espera para la extensión FastCGI si hay aplicaciones que llevan mucho tiempo ejecutar scripts PHP. Los dos valores a ajsutar de los controles de tiempos de espera son ActivityTimeout y RequestTimeout. Véase » Configuración de Extensión FastCGI para IIS 6.0 para más información sobre los ajustes.

Ejemplo #6 Configuración de los ajustes de tiempo de espera FastCGI

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-ActivityTimeout:90

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-RequestTimeout:90

Cambiar la ubicación del fichero php.ini

PHP busca para el fichero php.ini en varios lugares y es posible cambiar las ubicaciones predeterminadas de el fichero php.ini utilizando la variable de entorno PHPRC. Las instrucciones PHP para cargar el fichero de configuración desde una ubicación personalizada, ejecute el comando que se muestra a continuación. La ruta de acceso absoluta al directorio con el fichero php.ini debe ser especifica con un valor de variable de entorno PHPRC.

Ejemplo #7 Cambiar la ubicación del fichero php.ini

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHPRC:"C:\Some\Directory\"

Microsoft IIS 7.0 y posteriores

Esta sección contiene instrucciones para configurar en forma manual Internet Information Services (IIS) 7.0 y posteriores para trabajar con PHP en Microsoft Windows Vista SP1, Windows 7, Windows Server 2008 and Windows Server 2008 R2. Para obtener instrucciones sobre la configuración de IIS 5.1 and IIS 6.0 on Windows XP and Windows Server 2003 refiérase a Microsoft IIS 5.1 and IIS 6.0.

Habilitación de apoyo FastCGI en IIS

Módulo FastCGI está deshabilitado en la instalación por defecto de IIS. Los pasos para que pueda variar según la versión de Windows se está utilizando.

Para activar el soporte FastCGI en Windows Vista SP1 y Windows 7:

  1. En el menu de inicio de Windows seleccione "Run:", teclee "optionalfeatures.exe" y click "Ok";

  2. En el "Windows Features" cuadro de diálogo "Internet Information Services", "World Wide Web Services", " Caracteristicas Desarrollo de aplicaciones " y luego permitir que el "CGI" checkbox;

  3. Haga clic en Aceptar y espere hasta que se complete la instalación

Habilitar soporte para FastCGI IIS7 en Windows Vista SP1 y Windows 7

Para activar el soporte FastCGI en Windows Server 2008 y Windows Server 2008 R2:

  1. En el menú Inicio de Windows elegir "Run:", teclee "CompMgmtLauncher" y click "Ok";

  2. En el "Web Server (IIS)" El rol no está presente en el marco del "Roles" nodo, a continuación, añadir haciendo clic en "Adicionar Roles";

  3. Si la "Web Server (IIS)" role esta presente, entonces haga click "Add Role Services" y luego permitir que el "CGI" casilla de verificación en grupo "Desarrollo de Aplicaciones" ;

  4. Click "Next" y luego "Install" ay espere a que la instalación se complete.

Habilitación FastCGI apoyo en Windows Server 2008 y Windows Server 2008 R2

Configurar IIS para procesar las solicitudes de PHP

Descargue e instale PHP de acuerdo a las instrucciones descritas en manual installation steps

Nota:

No construir thread-safe de PHP se recomienda cuando IIS utilizando. El no-thread-safe crea están disponibles en » PHP para Windows: binarios y fuentes.

Configure el CGI y la configuración específica de FastCGI php.ini fichero como se muestra a continuación:

Ejemplo #8 CGI y FastCGI en la configuración php.ini

fastcgi.impersonate = 1
    fastcgi.logging = 0
    cgi.fix_pathinfo=1
    cgi.force_redirect = 0

Configurar la asignación de IIS controlador para PHP utilizando la interfaz de usuario Administrador de IIS o una herramienta de línea de comandos.

El uso de IIS interfaz de usuario de Manager para crear una asignación de controlador para PHP

Siga estos pasos para crear una asignación de controlador de IIS para PHP en la interfaz de usuario Administrador de IIS:

  1. En el menú Inicio de Windows elegir "Run:", escriba "inetmgr" y click "Ok";

  2. En la interfaz de usuario de IIS Manager, seleccione el nodo de servidor en el "Connections" vista de árbol;

  3. En el "Características" Página de abrir el "Handler Mappings" feature;

    Crear la asignación de IIS controlador para PHP: Localizar Handler Mappings

  4. En el "Actions" haga click en panel "Add Module Mapping...";

  5. En el "Add Module Mapping" diálogo entre lo siguiente:

    • Solicitud de ruta: *.php
    • Modulo: FastCgiModule
    • Ejecutable: C:\[Path to PHP installation]\php-cgi.exe
    • Nombre: PHP_via_FastCGI

  6. Haga Click en "Solicitar Restricciones" botón y luego configurar la asignación de invocar controlador sólo si la solicitud se asigna a un archivo o una carpeta;

  7. Haga clic en Aceptar en todos los cuadros de diálogo para guardar la configuración.

Crear mapas controlador de IIS para PHP: Agregar controlador de Cartografía

Utilizando la herramienta de línea de comandos para crear una asignación de controlador para PHP

Utilice el comando mostrado a continuación para crear un grupo de IIS FastCGI proceso que utilizará php-cgi.exe ejecutable para la tramitación de solicitudes de PHP. Vuelva a colocar el valor del parámetro fullPath con la ruta absoluta al fichero php-cgi.exe.

Ejemplo #9 >Creación del proceso del grupo IIS FastCGI

     %windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI ^
     /+[fullPath='c:\PHP\php-cgi.exe']

Configurar IIS PHP para manejar las peticiones concretas de la ejecución del comando que se muestra a continuación. Vuelva a colocar el valor del parámetro scriptProcessor con la ruta de acceso absoluta al fichero php-cgi.exe.

Ejemplo #10 Creación de mapas manejador de peticiones PHP

     %windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers ^
     /+[name='PHP_via_FastCGI', path='*.php',verb='*',modules='FastCgiModule',^
     scriptProcessor='c:\PHP\php-cgi.exe',resourceType='Either']

Este comando crea una asignación de controlador de IIS para la extensión de archivo *.php, lo que resultará en todas las direcciones URL que terminan con. Php siendo manejado por el módulo FastCGI.

Nota:

En este punto la necesidad de instalación y configuración de los pasos se han completado. Las instrucciones a continuación son opcionales, pero altamente recomendable para lograr una funcionalidad óptima y el rendimiento de PHP en IIS.

Suplantación de identidad y acceso a archivos del sistema

Se recomienda habilitar la suplantación en PHP FastCGI cuando IIS utilizando. Esta está controlado por la directiva fastcgi.impersonate en el fichero php.ini. Cuando está habilitada la suplantación, PHP realizará todas las operaciones del sistema de ficheros en nombre de la cuenta de usuario que ha sido determinado por la autentificación de IIS. Esto asegura que, aunque el proceso mismo PHP es compartido a través de diferentes sitios web IIS, los scripts PHP en los sitios web no será capaz de acceder a los demás ficheros, siempre y cuando las cuentas de usuario se utilizan para la autenticación de IIS en cada sitio web.

Por ejemplo IIS 7, en su configuración por defecto, se ha habilitado la autenticación anónima con incorporada IUSR cuenta de usuario utilizada como una identidad por defecto. Esto significa que para que IIS ejecutar scripts PHP, es necesario conceder a la cuenta IUSR permiso de lectura en estos scripts. Si las aplicaciones PHP necesidad de realizar operaciones de escritura de ciertos ficheros o escribir ficheros en una carpetas entonces cuenta IUSR debe tener permiso para escribir en ellos.

Para determinar qué cuenta de usuario se utiliza como una identidad anónima en IIS 7 utilice el siguiente comando. Vuelva a colocar el "Sitio Web predeterminado" con el nombre del sitio Web de IIS que utiliza. En la producción configuración XML aspecto de elemento para el atributo userName.

Ejemplo #11 La determinación de la cuenta utilizada como IIS identidad anónima

    %windir%\system32\inetsrv\appcmd.exe list config "Default Web Site" ^
    /section:anonymousAuthentication
    <system.webServer>
    <security>
    <authentication>
    <anonymousAuthentication enabled="true" userName="IUSR" />
    </authentication>
    </security>
    </system.webServer>

Nota:

Si el atributo userName no está presente en el elemento anonymousAuthentication, o si se establece una cadena vacía, entonces significa que la identidad del grupo de aplicaciones se utiliza como un identidad anónima para ese sitio web.

Para modificar la configuración de permisos de archivos y carpetas, utilice la interfaz de usuario del Explorador de Windows o comando icacls.

Ejemplo #12 Configuración de archivo de los permisos de acceso

    icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

Establecer index.php como un documento predeterminado en IIS

Los documentos por defecto de IIS se utilizan para las solicitudes HTTP que no se especifica un nombre de documento. Con las aplicaciones PHP,index.php por lo general actúa como un documento predeterminado. Para añadir index.php a la lista de los documentos por defecto de IIS, utilice este comando:

Ejemplo #13 Establecer index.php como un documento predeterminado en IIS

    %windir%\system32\inetsrv\appcmd.exe set config ^
    -section:system.webServer/defaultDocument /+"files.[value='index.php']" ^
    /commit:apphost

FastCGI y configuración de PHP Reciclaje

Configurar la configuración de IIS FastCGI PHP para el reciclaje de los procesos mediante los comandos de abajo. La configuración FastCGI instanceMaxRequests controla cuántas peticiones se procesado por un solo peoceso php-cgi.exe antes de IIS se cierra. La variable de entorno PHP PHP_FCGI_MAX_REQUESTS controla el número pide una sola proceso php-cgi.exe se encargará antes de que se recicla sí misma. Asegúrese de que el valor especificado para la configuración FastCGI InstanceMaxRequests es menor o igual al valor especificado para PHP_FCGI_MAX_REQUESTS.

Ejemplo #14 Configuración de PHP FastCGI y el reciclaje

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
    /[fullPath='c:\php\php-cgi.exe'].instanceMaxRequests:10000
    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
    /+"[fullPath='C:\{php_folder}\php-cgi.exe'].environmentVariables.^
    [name='PHP_FCGI_MAX_REQUESTS',value='10000']"

FastCGI ajustes de tiempo de espera

Aumentar el tiempo de espera para la configuración de FastCGI si se espera tener a largo ejecutar scripts PHP. Los dos valores que los tiempos de espera de control activityTimeout y requestTimeout. Utilice los comandos siguientes para cambiar la configuración de tiempo de espera. Asegúrese de sustituir el valor en el parámetro a fullPath contendrá la ruta absoluta a el fichero php-cgi.exe.

Ejemplo #15 Configuración de los ajustes de tiempo de espera FastCGI

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
    /[fullPath='C:\php\php-cgi.exe',arguments=''].activityTimeout:"90"  /commit:apphost
    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
    /[fullPath='C:\php\php-cgi.exe',arguments=''].requestTimeout:"90"  /commit:apphost

Cambiar la ubicación del fichero php.ini

PHP busca el fichero php.ini en varios lugares y es posible cambiar las ubicaciones predeterminadas del fichero php.ini utilizando variable de entorno PHPRC. Encomendar a PHP para cargar el archivo de configuración desde una ubicación personalizada, ejecute el comando se muestra a continuación. La ruta de acceso absoluta al directorio con el fichero php.ini debe ser especifica como un valor de variable de entorno PHPRC.

Ejemplo #16 Cambiar la ubicación del fichero php.ini

    appcmd.exe set config  -section:system.webServer/fastCgi ^
    /+"[fullPath='C:\php\php.exe',arguments=''].environmentVariables.^
    [name='PHPRC',value='C:\Some\Directory\']" /commit:apphost

Apache 1.3.x en Microsoft Windows

Esta sección contiene notas y sugerencias específicas para Apache 1.3.x instaladas con PHP en sistemas Microsoft Windows. También hay

Nota:

Por favor lea primero el manual de instalación

Hay dos formas de configurar PHP para trabajar con Apache 1.3.x en Windows. La primera es usar CGI binary (php.exe para PHP 4 y php-cgi.exe para PHP 5), la otra es utilizar el módulo DLL de Apache. En ambos casos se necesita editar httpd.conf para configurar Apache para trabajar con PHP, y después reiniciar el servidor.

Vale la pena resaltar, que el módulo SAPI ha sido desarrollado mas estable bajo Windows. Se recomienda su uso más que el binario CGI, ya que es más trasparente y seguro.

Aunque pueden haber algunas variaciones en la configuración de PHP bajo Apache, estas son sencillas para ser utilizados por el principiante. Por favor consulte la documentación de Apache para seguir directivas de configuración.

Después de modificar el archivo de configuración, recuerde que debe reiniciar el servidor, por ejemplo NET STOP APACHE seguido de NET START APACHE, si ejecuta Apache como un servicio de Windows, o si usa los atajos

Nota: Recuerde que cuando agrega rutas como valores en los archivos de configuración de Apache en Windows, todas las barras invertidas tal como c:\directory\file.ext deberían ser convertidas en barras comunes: c:/directory/file.ext. Una barra común al final será necesaria para directorios.

Instalación como módulo de Apache

Se deben agregar las siguientes líneas a su archivo de configuración Apache httpd.conf

Ejemplo #17 PHP como módulo de Apache 1.3.x

Se asume que PHP está instalado en c:\php. Ajuste la ruta de acceso si este no es el caso.

Para PHP 4:

# Adicionar al final de la sección LoadModule
# No olvidar copiar este ficrero desde el directorio sapi!
LoadModule php4_module "C:/php/php4apache.dll"

# Adicionar al final de la sección AddModule
AddModule mod_php4.c

Para PHP 5:

# Adicionar al final de la sección LoadModule
LoadModule php5_module "C:/php/php5apache.dll"

# Adicionar al final de la sección AddModule
AddModule mod_php5.c

Para ambos :

# Adicionar esta línea dentro de la <IfModule Mod_mime.c> condicional brace
AddType application/x-httpd-php .php

# Para la sintaxis highlighted .phps files, tambien adicionar
AddType application/x-httpd-php-source .phps

Instalación como un binario CGI

Si se ha descomprimido el paquete PHP C:\php\ como se describe en la sección Manual de instalación paso a paso, es necesario insertar estas líneas a su archivo de configuración de Apache para configurar el binario CGI:

Ejemplo #18 PHP y Apache 1.3.x como CGI

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# Para PHP 4
Action application/x-httpd-php "/php/php.exe"

# Para PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

# Especifica el directorio donde php.ini esta
SetEnv PHPRC C:/php
Tenga en cuenta que la segunda línea en la lista anterior se puede encontrar en las versiones actuales de httpd.conf, pero se comenta. Recordar también sustituir el c:\php\ para su ruta de acceso real a PHP.

Advertencia

Al usar el modo CGI, su servidor esta expuesto a diferentes ataques. Por favor, leer la sección Seguridad con CGI para aprender cómo defenderse de estos ataques.

Si desea presentar archivos de código fuente PHP sintaxis highlighted, no existe la opción más conveniente con la versión de PHP como módulo. Si ha elegido configurar Apache para usar PHP como un binario CGI, tendrá que usar la función highlight_file(). Para ello se necesita crear un script PHP y agregarle el código <?php highlight_file('some_php_script.php'); ?>.

Apache 2.x en Microsoft Windows

Esta sección contiene notas y sugerencias específicas de Apache 2.x instaladas con PHP en sistemas Microsoft Windows. También hay

Nota:

Por favor lea primero el manual de instalación

Nota: Soporte para Apache 2.2

Los usuarios de Apache 2.2 deben tener en cuenta que el archivo DLL para Apache 2.2 es llamado php5apache2_2.dll a cambio de php5apache2.dll y sólo está disponible para PHP 5.2.0 y posteriores.

Se le recomienda consultar la » Documentación de Apache Para obtener un conocimiento básico del servidor Apache 2.x. Tambien considere leer las » notas especificas de Windows para Apache 2.x antes de seguir leyendo aquí.

Apache 2.x está diseñado para ejecutarse en las versiones de Windows designado como servidor de plataforma, tales como Windows NT 4.0, Windows 2000, Windows XP o Windows 7. Aunque Apache 2.x funciona bastante bien en Windows 9x, el soporte en estas plataformas es incompleta, y algunas cosas no funcionan correctamente. No existe un plan para remediar esta situación.

Descargue la versión más reciente de » Apache 2.x y un accesorio de la versión de PHP. Siga los pasos del Manual de Instalación y regrese a continuar con la integración de PHP y Apache.

Hay tres formas de configurar PHP para trabajar con Apache 2.x en Windows. Puede ejecutar PHP como un controlador, como CGI o bajo FastCGI.

Nota: Recuerde que cuando agrega rutas como valores en los archivos de configuración de Apache en Windows, todas las barras invertidas tal como c:\directory\file.ext deberían ser convertidas en barras comunes: c:/directory/file.ext. Una barra común al final será necesaria para directorios.

Instalación como un controlador de Apache

Es necesario insertar las siguientes líneas en Apache httpd.conf archivo de configuración para cargar el módulo PHP para Apache 2.x:

Ejemplo #19 PHP and Apache 2.x como controlador

#
LoadModule php5_module "c:/php/php5apache2.dll"
AddHandler application/x-httpd-php .php

# Configurar la ruta de php.ini
PHPIniDir "C:/php"

Nota: Recuerda sustituir la ruta de acceso actual a PHP para el C:/php/ en los ejemplos anteriores. Tenga cuidado en utilizar ya sea php5apache2.dll o php5apache2_2.dll en la directiva LoadModule y verificar que el fichero de referencia se encuentra localizado en la ruta de fichero que se señala en la presente directiva.

La configuración anterior permite habilitar PHP como controlador de cualquier fichero que tiene una extensión .php, aunque existen otras extensiones de fichero. Por ejemplo, un fichero llamadoexample.php.txt será ejecutado por el controlador de PHP. Para garantizar que sólo los ficheros queterminen en .php son ejecutados, se utiliza la siguiente configuración en su lugar:

<FilesMatch \.php$>
      SetHandler application/x-httpd-php
 </FilesMatch>

Ejecutar PHP como CGI

Se debe consultar la» Documentación de Apache CGI para una comprensión más completa de ejecutar CGI en Apache

Para ejecutar PHP como CGI, tendrás que colocar los ficheros php-cgi en un directorio designado como directorio CGI usando la directiva ScriptAlias.

A continuación, se nesesita insertar una #! línea en los ficheros PHP, apuntando a la ubicación del binario de PHP:

Ejemplo #20 PHP y Apache 2.x como CGI

#!C:/php/php.exe
<?php
  phpinfo();
?>

Advertencia

Al usar el modo CGI, su servidor esta expuesto a diferentes ataques. Por favor, leer la sección Seguridad con CGI para aprender cómo defenderse de estos ataques.

Ejecutar PHP bajo FastCGI

Ejecutar PHP bajo FastCGI tiene una serie de ventajas con respecto a ejecutarlo como un CGI. Si lo establece de esta manera es bastante sencillo:

Obtener mod_fcgid de » http://httpd.apache.org/mod_fcgid/. Los binarios de Win32 están disponibles para la descargar en ese sitio. Instalar el módulo de acuerdo con las instrucciones que vienen con él.

Configurar el servidor web como se muestra abajo, teniendo cuidado de ajustar cualquier ruta que refleje como se tiene instalado las cosas en el sistema:

Ejemplo #21 Configurar Apache para ejecutar PHP como FastCGI

LoadModule fcgid_module modules/mod_fcgid.so

# Donde está el fichero php.ini?
FcgidInitialEnv PHPRC        "c:/php"

AddHandler fcgid-script .php
FcgidWrapper "c:/php/php-cgi.exe" .php
Los ficheros con extensión .php ahora serán ejecutados por PHP FastCGI

Sambar Server en Microsoft Windows

Esta sección contiene notas y consejos específicos a el » Servidor Sambar para Windows.

Nota:

Debe leer primero los pasos del manual de instalación.

Esta lista describe cómo configurar el módulo ISAPI para trabajar con el servidor Sambar en Windows.

  • Busque el archivo llamado mappings.ini (en el directorio de configuración) en el directorio de instalación de Sambar.

  • Abra mappings.ini y adicione la siguiente línea de abajo [ISAPI]:

    Ejemplo #22 Configuracion de Sambar ISAPI

        #for PHP 4
    *.php = c:\php\php4isapi.dll

    #for PHP 5
    *.php = c:\php\php5isapi.dll
    (Esta línea asume que PHP se instaló en c:\php.)

  • Ahora reinicie el servidor Sambar para que los cambios surtan efecto.

Nota:

Si va a usar PHP para comunicarse con los recursos que se celebran en un equipo diferente en la red, entonces usted tendrá que modificar la cuenta utilizada por los servicios de el servidor Sambar. La cuenta por defecto utilizado por el Servicio del servidor Sambar es LocalSystem que no tendrán acceso a recursos remotos. La cuenta puede ser modificada mediante el uso de la opción de servicios de Windows en el Panel de control de las herramientas de administración.

Xitami en Microsoft Windows

Esta sección contiene notas y sugerencias específicas para » Xitami en Windows.

Nota:

Debe leer primero los pasos del Manual de instalación.

Esta lista describe cómo configurar el PHP CGI binary para trabajar con Xitami en Windows.

Nota: Importante para los usuarios de CGI

Leer las preguntas frecuentes en cgi.force_redirect para más detalles importantes. Esta directiva se debe establecer a0. Si desea utilizar $_SERVER['PHP_SELF'] tienes que habilitar la directiva cgi.fix_pathinfo.

Advertencia

Al usar el modo CGI, su servidor esta expuesto a diferentes ataques. Por favor, leer la sección Seguridad con CGI para aprender cómo defenderse de estos ataques.

  • Asegúrese de que el servidor web está funcionando, y apunte el navegador a la consola de administración xitamis (por lo general http://127.0.0.1/admin), Y haga clic en Configuración.

  • Navegue a los filtros, y ponga la extensión PHP que debe analizar (es decir, .php) en el campo de las extensiones del fichero(.xxx).

  • En el comando del filtro o script coloque la ruta y el nombre de el ejecutable PHP CGI es decir, C:\php\php.exe para PHP 4, o C:\php\php-cgi.exe para PHP 5.

  • Pulse el icono "Guardar".

  • Reinicie el servidor para reflejar los cambios.

Construcción de la fuente

En este capítulo se enseña a compilar PHP a partir de fuentes en Windows, usando Microsoft's tools. Para compilar PHP con cygwin, por favor vaya a Instalación sobre sistemas Unix.

Consulte la documentación del Wiki en: » https://wiki.php.net/internals/windows/stepbystepbuild

Instalación de extensiones en Windows

Después de instalar PHP y un servidor web en Windows, es probable que desee instalar algunas extensiones para mayor funcionalidad. Puede elegir cuales extensiones desea cargar cuando PHP inicia modificando php.ini. También puede cargar un módulo dinámicamente en el script con dll().

Las DLL para las extensiones de PHP tienen el prefijo php_.

Algunas extensiones son construidas dentro de la versión de Windows de PHP. Esto significa que los ficheros DLL adicionales, y la extensión directiva, no se utiliza para cargar estas extensiones. En la tabla de Windows las extensiones PHP son enumeradas las extensiones que se requieren, se utilizan, ficheros PHP DLL adicionales. Aquí hay una lista de extensiones integradas (actualizada PHP 5.0.4): BCMath, Caledar, COM, Ctype, DOM, FTP, LibXML, Iconv, ODBC, PCRE, Session, SimpleXML, SPL, WDDX, XML y Zlib.

La ubicación predeterminada de las búsquedas PHP para las extensiones es C:\php5. Para cambiar estos parámetros reflejando la configuración de PHP, edite el fichero php.ini:

  • Tendrá que cambiar los parámetros de la extension_dir para apuntar al directorio donde está la extensión, o donde tenga localizado el fichero php_*.dll. Por ejemplo:

    extension_dir = C:\php\extensions

  • Habilite la extensión(s) en php.ini que desea utilizar descomentando las siguientes líneas extension=php_*.dll en php.ini. Esto se hace mediante el borrado de la cabecera, desde la extensión que desea cargar.

    Ejemplo #23 Habilitar la extensión Bzip2 para PHP-Windows

    // cambiar la siguiente línea de ...
;extension=php_bz2.dll

// ... to
extension=php_bz2.dll

  • Algunas de las extensiones de archivos necesita DLL extras para trabajar. Un par de ellos se puede encontrar en el paquete de distribución, en la carpeta principal, pero algunos, por ejemplo Oracle, (php_oci8.dll) requieren ficheros DLL que no se incluyen con el paquete de distribución. No se olvide de incluir C:\php en el PATH del sistema (Este proceso se explica por separado en Preguntas Frecuentes de entrada).

  • Algunos de estos DLLs no se incluye con la distribución de PHP. Consulta cada página de documentación de las extensiones para más detalles. Además, lea el manual sección titulada Instalación de extensiones PECL para más detalles sobre PECL. Un gran número de extensiones de PHP se encuentran en PECL, y estas extensiones requieren una descarga independiente .

Nota: Si está ejecutando un servidor de la versión de PHP como módulo recuerde reiniciar su servidor web para reflejar los cambios a php.ini.

En la tabla siguiente se describen algunas de las extensiones disponibles y las dlls adicionales.

Extensiones de PHP
Extensión | Descripción | Notas
php_bz2.dll | Funciones de compresión bzip2 | Ninguna
php_calendar.dll | Funciones de conversión Calendario | Ninguna
php_ctype.dll | Funciones familiares ctype | Ninguna
php_curl.dll | Funciones de la libreria cliente URL CURL | Requiere: libeay32.dll, ssleay32.dll(incluido)
php_dba.dll | DBA: Funciones de Capa de abstracción de la Base de datos (dbm-style) | Ninguna
php_dbase.dll | Funciones dBase | Ninguna
php_exif.dll | FuncionesEXIF | php_mbstring.dll. y, php_exif.dll se debe cargar después de php_mbstring.dll en php.ini.
php_fbsql.dll | Funciones FrontBase | Ninguna
php_fdf.dll | FDF: Formato de datos de formularios de funciones. | Requiere: fdftk.dll (incluido)
php_filepro.dll | Funciones filePro | Acceso de sólo lectura
php_ftp.dll | Funciones FTP | Ninguna
php_gd2.dll | Funciones de libreria de imagen GD | GD2
php_gettext.dll | Funciones Gettext | PHP <= 4.2.0 requiere gnu_gettext.dll (incluido), PHP >= 4.2.3 requiere libintl-1.dll, iconv.dll (incluido).
php_hyperwave.dll | Funciones HyperWave | Ninguna
php_iconv.dll | Conversión de caracteres ICONV | Requiere: iconv-1.3.dll (incluido), iconv.dll
php_iisfunc.dll | Funciones de administracion IIS | Ninguna
php_imap.dll | POP3 y Funciones NNTP IMAP | Ninguna
php_ingres.dll | Funciones Ingres | Requiere: Librerias Ingres
php_interbase.dll | Funciones de InterBase | Requiere: gds32.dll (incluido)
php_ldap.dll | Funciones LDAP | Requiere libeay32.dll, ssleay32.dll (incluido)
php_mbstring.dll | Funciones Multi-Byte String | Ninguna
php_mcrypt.dll | Funciones Mcrypt Encryption | Requiere: libmcrypt.dll
php_mhash.dll | Funciones Mhash | Requiere: libmhash.dll (incluido)
php_mysql.dll | Funciones MySQL | Requiere libmysql.dll (incluido)
php_mysqli.dll | Funciones MySQLi | Requiere libmysql.dll (libmysqli.dll en PHP <= 5.0.2) (incluido)
php_oci8.dll | Funciones Oracle 8 | Requiere: Librerias cliente Oracle 8.1+
php_openssl.dll | Funciones OpenSSL | Requiere: libeay32.dll (incluido)
php_pgsql.dll | Funciones PostgreSQL | Ninguna
php_shmop.dll | Funciones Shared Memory | Ninguna
php_snmp.dll | Funciones SNMP | ¡Solamente NT!
php_soap.dll | Funciones SOAP | Ninguna
php_sockets.dll | Funciones Socket | Ninguna
php_tidy.dll | Funciones Tidy | Ninguna
php_tokenizer.dll | Funciones Tokenizer | Ninguna
php_w32api.dll | Funciones W32api | Ninguna
php_xmlrpc.dll | Funciones XML-RPC | Requiere: iconv.dll (incluido)
php_xslt.dll | Funciones de XSLT | Requiere sablot.dll, expat.dll, iconv.dll (incluido).
php_yaz.dll | Funciones YAZ | Requiere: yaz.dll (incluido)
php_zip.dll | Ficheros Zip incluido | Acceso de sólo lectura
php_zlib.dll | Funciones de compresión ZLib | Ninguna

Linea de Comandos PHP en Microsoft Windows

Esta sección contiene notas y sugerencias específicas para conseguir ejecutar PHP en la línea de comandos para Windows.

Nota:

Usted debe leer primero el manual de instalación

Cómo ejecutar PHP desde la línea de comandos sin hacer ningún cambio a Windows.

C:\PHP5\php.exe -f "C:\PHP Scripts\script.php" -- -arg1 -arg2 -arg3

Pero hay algunos pasos sencillos que puede seguir para hacer esto simple. Algunas de estas medidas ya se deberían haber tomado, pero se repiten aquí para ser capaz de proporcionar una completa secuencia paso a paso.

    Nota:

    Tanto PATH como PATHEXT son variables de sistema preexistentes importantes en Windows, por lo que se ha de asegurarse de no sobrescribir dichas variables, solamente agregarle algo.

  • Añada la ubicación del ejecutable de PHP (php.exe, php-win.exe o php-cli.exe dependiendo de su versión de PHP y las preferencias de presentación) a la variable de entorno PATH. Lea más acerca de cómo añadir el directorio de PHP PATH en la entrada correspondiente de preguntas frecuentes.

  • Añada la extensión .PHP de la variable de entorno PATHEXT. Esto se puede hacer al mismo tiempo, con la modificación de la variable de entorno PATH. Siga los mismos pasos como se describe en las Preguntas frecuentes pero habría que modificar la variable de entorno PATHEXTen lugar de la variable de entorno PATH.

    Nota:

    La posición en que se coloca el .PHP determina qué secuencia de comandos o programa se ejecuta cuando hay nombre de archivos coincidentes. Por ejemplo, colocar .PHP antes de .BAT hará que el script se ejecute, en lugar de el archivo por lotes, si hay un fichero por lotes con el mismo nombre.

  • Asociar la extensión .PHP con un tipo de fichero. Esta se hace ejecutando el siguiente comando:

    assoc .php=phpfile

  • Asociar el tipo de fichero phpfile con el adecuado ejecutable PHP. Esto se hace ejecutando el siguiente comando:

    ftype phpfile="C:\PHP5\php.exe" -f "%1" -- %~2

Si sigue estos pasos permitirá ejecutar scripts PHP desde cualquier directorio sin necesidad de escribir el ejecutable PHP o la extensión .PHP y todos los parámetros, será enviada a el script para el procesamiento.

En el ejemplo a continuación se detallan algunos de los cambios de registro que se puede hacer manualmente.

Ejemplo #24 Registro de cambios

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.php]
@="phpfile"
"Content Type"="application/php"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile]
@="PHP Script"
"EditFlags"=dword:00000000
"BrowserFlags"=dword:00000008
"AlwaysShowExt"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\DefaultIcon]
@="C:\\PHP5\\php-win.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell]
@="Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open]
@="&Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open\command]
@="\"C:\\PHP5\\php.exe\" -f \"%1\" -- %~2"

Con estos cambios el mismo comando se puede escribir como:

"C:\PHP Scripts\script" -arg1 -arg2 -arg3
O, si la ruta de acceso "C:\PHP Scripts" está en el variable de entorno PATH:
script -arg1 -arg2 -arg3

Nota:

Hay un pequeño problema si tiene intención de utilizar esta técnica y usar scripts PHP como filtro de línea de comandos, como el ejemplo a continuación:

dir | "C:\PHP Scripts\script" -arg1 -arg2 -arg3
o
dir | script -arg1 -arg2 -arg3
Es posible que el script simplemente se cuelga y no salga nada. Para hacer esto operacional, es necesario hacer otro cambio en el registro.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"InheritConsoleHandles"=dword:00000001
Información adicional sobre este tema se pueden encontrar en el » Artículo de la base de conocimientos de Microsoft: 321788. A partir de Windows 10, este ajuste parece haber sido invertido, haciendo que la instalación predeterminada de Windows 10 admita manejadores de consola heredados automáticamente. Esta » entrada del foro de Microsoft proporciona la explicación.


  • « Instalación en sistemas Windows
  • Microsoft Azure »
  • PHP Manual
  • Instalación y configuración
  • Instalación en las plataformas de Nube Informática

Instalación en las plataformas de Nube Informática

Tabla de contenidos

  • Microsoft Azure
  • Amazon EC2

PHP instalará en la nube. A la nube de PHP!


  • « Instalación en las plataformas de Nube Informática
  • Amazon EC2 »
  • PHP Manual
  • Instalación en las plataformas de Nube Informática
  • Microsoft Azure

Microsoft Azure

PHP instalará el Azure cloud platform.

Ver acerca de Azure SDK para PHP.


  • « Microsoft Azure
  • Manejador de Procesos FastCGI (FPM) »
  • PHP Manual
  • Instalación en las plataformas de Nube Informática
  • Amazon EC2

Amazon EC2

PHP instalará el » EC2 cloud platform.

Ver acerca de » AWS SDK for PHP.


Manejador de Procesos FastCGI (FPM)

Tabla de contenidos

  • Instalación
  • Configuración

FPM (FastCGI Process Manager) es una implementación alternativa al PHP FastCGI con algunas características adicionales (la mayoría) útiles para sitios web con mucho tráfico.

Estas características incluyen:

  • Manejo avanzado para detener/arrancar procesos de forma fácil;

  • Posibilidad de iniciar hilos de procesos con diferentes uid/gid/chroot/environment, escuchar en diferentes puertos y usar distintos php.ini (remplazando); safe_mode

  • Registro stdout y stderr;

  • Reinicio de emergencia en caso de destrucción accidental del caché opcode;

  • Soporte acelerado de subidas;

  • "slowlog" - scripts de registro de procesos (no sólo sus nombres, sin sus backtraces también, usando ptrace y similares para leer procesos execute_data remotos) que son inusualmente lentos;

  • fastcgi_finish_request() - Función especial para detener y descargar todos los datos mientras continua haciendo algún proceso más largo (conversión de vídeos, procesamiento de estadísticas, etc.);

  • Creación dinámico/estático de hilos;

  • Información básica del status SAPI (similar al mod_status de Apache);

  • Basado en archivos de configuración php.ini


Instalación

Compilación desde el código fuente

Para habilitar FPM en la construcción de PHP, debe añadirse --enable-fpm a la línea de configuración.

Hay otras opciones de configuración específicas de FPM (todas ellas optativas):

  • --with-fpm-user - Establecer el usuario de FPM (por omisión: nobody).

  • --with-fpm-group - Establecer el grupo de FPM (por omisión: nobody).

  • --with-fpm-systemd - Activar la integración del sistema (por omisión: no).

  • --with-fpm-acl - Utilizar las listas de control de acceso de POSIX (por omisión: no). Desde 5.6.5


Configuración

FPM usa la sintaxis de php.ini para su fichero de configuración - php-fpm.conf, y agrupa ficheros de configuración.

Lista de directivas globales de php-fpm.conf

pid string

Ruta al fichero PID. Valor por defecto: none.

error_log string

Ruta al fichero de registro de errores. Valor por defecto: #INSTALL_PREFIX#/log/php-fpm.log. Si se establece a "syslog", los registros son enviados a syslogd en lugar de escribir en un archivo local.

log_level string

Nivel de registro de errores. Posibles valores: alert, error, warning, notice, debug. Valor por defecto: notice.

syslog.facility string

Usado para especificar qué tipo de programa está recibiendo los mensajes de registro. Valor por defecto: daemon.

syslog.ident string

Anteponer a cada mensaje. Si hay varias instancias FPM ejecutándose en el mismo servidor, puede cambiar el valor por defecto que debe adaptarse a sus necesidades. Valor por defecto: php-fpm.

emergency_restart_threshold int

Si este número de procesos termina con SIGSEGV o SIGBUS dentro del intervalo de tiempo establecido por emergency_restart_interval entonces FPM se reiniciará. Un valor de 0 corresponde a 'Off'. Valor por defecto: 0 (Off).

emergency_restart_interval mixed

Intervalo de tiempo usado por emergency_restart_interval para determinar cuando un reinicio agraciado será realizado. Esto puede ser útil trabajar sobre corrupciones accidentales in en acelerador de memoria compartida. Unidades disponibles:: s(segundos), m(inutos), h(oras), o d(ías). Unidad por defecto: segundos. Valor por defecto: 0 (Off).

process_control_timeout mixed

Límite de tiempo que un hilo de proceso espera por una señal maestra. Unidades disponibles: s(egundos), m(inutos), h(oras), o d(ías) Unidad por defecto: segundos. Valor por defecto: 0.

process.max int

El número máximo de procesos FPM creará. Esto ha sido diseñado para controlar el número global de procesos cuando se utiliza PM dinámico dentro de muchos pools. Utilícelo con precaución. Valor por defecto: 0.

process.priority int

Especifique la prioridad nice(2) que se aplicará al proceso maestro (sólo si se establece). El valor puede variar entre -19 (prioridad más alta) hasta 20 (prioridad más baja). Valor por defecto: no establecido.

daemonize boolean

Envía a FPM al background. Establezca a 'no' para mantener FPM en foreground para depuración. Valor por defecto: yes.

rlimit_files int

Establece el descriptor rlimit de archivos abiertos para el proceso maestro. Valor predeterminado: Establece el descriptor rlimit de archivos abiertos para el proceso maestro.

rlimit_core int

Establece el tamaño máximo del núcleo rlimit para el proceso maestro. Valor por defecto: 0.

events.mechanism string

Especifica el mecanismo de eventos que FPM utilizará. Los siguientes están disponibles: select, pool, epoll, kqueue (*BSD), port (Solaris). Valor por defecto: no establecido (auto-detección).

systemd_interval int

Cuando FPM es compilado con integración con systemd, especifique el intervalo, en segundos, entre notificaciones de reporte de salud a systemd. Coloque a 0 para deshabilitar. Valor por defecto: 10.

Lista de directivas de grupo

Con FPM usted puede correr varios grupos de procesos con diferentes ajustes. Estos son los parámetros que pueden ser ajustados por grupo.

listen string

La dirección sobre la cual desea aceptar peticiones FastCGI. Las sintaxis válidas son: 'ip.add.re.ss:port', 'port', '/path/to/unix/socket'. Esta opción es obligatoria por cada grupo.

listen.backlog int

Establece listen(2) backlog. Un valor de '-1' significa ilimitado. Valor por defecto: -1.

listen.allowed_clients string

Lista de direcciones ipv4 de clientes FastCGI que tienen permiso para conectarse. El equivalente a la variable de entorno FCGI_WEB_SERVER_ADDRS en el PHP FastCGI (5.2.2+) original. Tiene sentido solamente con un socket tcp escuchando. Cada dirección debe ser separada por coma. Si este valor es dejado en blanco, las conexiones serán aceptas desde cualquier dirección ip. Valor por defecto: any.

listen.owner string

Establece permisos para sockets unix, si uno es usado. En Linux, los permisos de lectura/escritura deben ser puestos a fin de permitir conexiones desde un servidor web. Muchos sistemas derivados de BSD permiten conexiones sin considerar los permisos. Valor por defecto: usuario y grupo son establecidos según el usuario ejecutor, permisos puestos a 0660.

listen.group string

Ver listen.owner.

listen.mode string

Ver listen.owner.

listen.acl_users string

Cuando las lsitas de control de acceso POSIX están soportadas, usted puede configurarlas usando esta opción. Cuando se establece, listen.owner y listen.group son ignoradas. El valor es una lista de nombres de usuario separado por comas. Desde PHP 5.6.5.

listen.acl_groups string

Ver listen.acl_users. El valor es una lista de nombres de grupo separado por comas. Desde PHP 5.6.5.

user string

Usuario Unix de procesos FPM. Esta opción es obligatoria.

group string

Grupo Unix group of FPM processes. Si no es establecido, el grupo del usuario por defecto será usado.

pm string

Seleccione cómo el manejador de procesos controlará el número de hilos de procesos. Valores posibles: static, ondemand, dynamic. Esta opción es obligatoria.

static - el número de hilos de proceso es fijo (pm.max_children).

ondemand - el proceso se lanza en demanda (cuando se solicita, al contrario que dynamic, donde pm.start_servers son iniciados cuando el servicio está iniciado.

dynamic - el número de hilos de proceso será basado dinámicamente basado en las siguientes directivas: pm.max_children, pm.start_servers, pm.min_spare_servers, pm.max_spare_servers.

pm.max_children int

El número de hilos de procesos a ser creados cuando pm es puesto a static y el máximo número de hilos de proceso a ser creados cuando pm es puesto a dynamic. Esta opción es obligatoria.

Esta opción establece el límite sobre el número de peticiones simultaneas que serán servidas. Equivale a la directiva ApacheMaxClients con mpm_prefork y a la variable de entorno PHP_FCGI_CHILDREN del PHP FastCGI original.

pm.start_servers int

Número de hilos de procesos creados al inicio. Usado solamente cuando pm es puesto a dynamic. Valor por defecto: min_spare_servers + (max_spare_servers - min_spare_servers) / 2.

pm.min_spare_servers int

El número mínimo deseado de procesos libres en el servidor. Usado sólo cuando pm es puesto a dynamic. También obligatorio en este caso.

pm.max_spare_servers int

El número máximo deseado de procesos libres en el servidor. usado sólo cuando pm es puesto a dynamic. También obligatorio en este caso.

pm.process_idle_timeout mixed

El número de segundos después de los cuales se matará un proceso inactivo. Usado sólo cuando pm está establecido como ondemand. Unidades disponibles: s(segundos)(predeterminado), m(inutos), h(horas), o d(ías). Valor por defecto: 10s.

pm.max_requests int

El número de pedidos que cada hilo de proceso debe ejecutar antes de reaparecer. Esto puede ser útil para evitar las fugas de memoria en librerías de terceros. para el procesamiento de solicitudes sin límites especifique '0'. Equivale a PHP_FCGI_MAX_REQUESTS. Valor por defecto: 0.

pm.status_path string

La dirección URI para ver la página de status FPM. Si este valor no es establecido, ninguna dirección URI será reconocida como una página de status. Valor por defecto: none.

ping.path string

La dirección URI del ping para llamar a la página de monitor del FPM. Si este valor no es establecido, ninguna dirección URI será reconocida como página del ping. Esto debería ser usado para probar desde el exterior que el FPM está funcionando y respondiendo. Por favor, note que este valor debe empezar con un slash (/).

ping.response string

Esta directiva puede ser usada para personalizar las peticiones de respuestas a ping. La respuesta es formateada como text/plain con un código de respuesta 200. Valor por defecto: pong.

process.priority int

Especifique la prioridad nice(2) que se aplicará al proceso maestro (sólo si se establece). El valor puede variar entre -19 (prioridad más alta) hasta 20 (prioridad más baja). Valor por defecto: no establecido.

prefix string

Establece un prefijo para la ruta de evaluación

request_terminate_timeout mixed

El tiempo de espera para servir una simple petición luego que el proceso worker sea eliminado. Esta opción debe ser usada cuando la opción 'max_execution_time' no detenga la ejecuciuón del script por cualquier razón. Un valor de '0' corresponde a 'Off'. Unidades disponibles: s(egundos)(por defecto), m(inutos), h(horas), or d(ías). Default value: 0.

request_slowlog_timeout mixed

El tiempo de espera para servir una simple petición después de que un backtrace PHP sea volcado al fichero 'slowlog'. Un valor de '0' corresponde a 'Off'. Unidades disponibles: s(egundos)(por defecto), m(inutos), h(oras), or d(ías). Valor por defecto: 0.

slowlog string

El fichero de registro para peticiones lentas. Valor por defecto: #INSTALL_PREFIX#/log/php-fpm.log.slow.

rlimit_files int

Establece el fichero descriptor rlimit. Valor por defecto: definido por el sistema.

rlimit_core int

Establece el tamaño máximo del rlimit. Valores posibles: 'unlimited' o un entero mayor o igualo a 0. Valor por defecto: definido por el sistema.

chroot string

Establece el Chroot (enjaulado) a este directorio al inicio. Este valor debe ser definido como una ruta absoluta. Cuando este valor no es establecido, el chroot no es usado.

chdir string

Establece el Chdir a este directorio al inicio. Este valor debe ser establecido como una ruta absoluta. Valor por defecto: directorio actual o / cuando está en chroot (enjaulado).

catch_workers_output boolean

Redirige los worker stdout y stderr en el fichero de registro principal. Sí no es establecido, stdout y stderr serán redirigidos a /dev/null de acuerdo a las especificaciones FastCGI. Valor por defecto: no.

clear_env boolean

Entorno limpio in workers FPM. Evita que variables de entorno arbitrarias lleguen a los procesos FPM mediante la limpieza del entorno en los workers antes de que se añadan las variables env a las pools correspondientes a esta configuración. Desde PHP 5.4.27, 5.5.11, y 5.6.0. Valor por defecto: Yes.

security.limit_extensions string

Limita las extensiones del script principal que FPM procesará. Esto puede evitar errores de configuración del lado del servidor. Usted debería limitar su FPM a procesar unicamente extensiones .php para evitar que usuarios malintencionados usen diferentes extensiones para ejecutar código PHP. Valor por defecto: .php .phar

access.log string

Archivo de registro de acceso. Valor por defecto: no establecido

access.format string

Formato del archivo de registro de acceso. Valor por defecto: "%R - %u %t \"%m %r\" %s"

Es posible pasar las variables de entorno adicionales y actualizar los ajustes PHP de ciertos grupos. Para ello, se necesita agregar las siguientes opciones al fichero de configuración.

Ejemplo #1 Pasando variables de entorno y ajustando las configuraciones de PHP por grupos

env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp

php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
php_flag[display_errors] = off
php_admin_value[error_log] = /var/log/fpm-php.www.log
php_admin_flag[log_errors] = on
php_admin_value[memory_limit] = 32M
Los ajustes PHP pasados con php_value o php_flag serán sobre-escritos a sus valores previos. Por favor note que definiendo disable_functions o disable_classes no sobre-escribirá los valores de definiciones anteriores php.ini, pero añadirán nuevos en cambio.

Ajustes definidos con php_admin_value and php_admin_flag cannot be anulados con ini_set().

Como 5.3.3, establecer los ajustes PHP es también posible como servidor web.

Ejemplo #2 Establecer ajustes PHP en nginx.conf

set $php_value "pcre.backtrack_limit=424242";
set $php_value "$php_value \n pcre.recursion_limit=99999";
fastcgi_param  PHP_VALUE $php_value;

fastcgi_param  PHP_ADMIN_VALUE "open_basedir=/var/www/htdocs";
Precaución

Dado a que estos valores se pasan a php-fpm como cabeceras fastcgi, php-fpm no debe estar vinculado a una dirección accesible para todo el mundo. De lo contrario, cualquiera podría alterar las opciones de configuración de PHP. Ver también listen.allowed_clients.


Instalación de extensiones PECL

Tabla de contenidos

  • Introducción a las Instalaciones en PECL
  • Descarga de extensiones PECL
  • Instalación una extensión de PHP en Windows
  • Compilando extensiones PECL compartidas con el comando pecl
  • Compilando extensiones PEC compartidas con phpize
  • php-config
  • Compilando extensiones PECL estáticamente en PHP


Introducción a las Instalaciones en PECL

» PECL es un repositorio de extensiones de PHP disponible mediante el sistema de paquetes » PEAR. Esta sección del manual tiene por objetivo ilustrar cómo obtener e instalar extensiones PECL.

Estas instrucciones asumen que la ruta al fuente de su distribución de PHP es /your/phpsrcdir/, y que extname es el nombre de la extensión PECL. Ajuste a sus valores. Estas instrucciones, además, asumen conocimientos del » comando pear. La información del manual de PEAR para el comando pear también es aplicable al comando pecl.

Para poder usarse, una extensión compartida se debe construir, instalar, y cargar. Los métodos descritos abajo le proporcionan varias instrucciones para construir e instalar extensiones, pero no se cargarán automáticamente. Éstas se pueden cargar añadiendo una directiva extension. al fichero php.ini, o bien mediante el uso de la función dl().

Al construir un módulo PHP, es importante contar con las versiones correctas de las herramientas requeridas (autoconf, automake, libtool, etc.). Para conocer los detalles de las herramientas requeridas y sus versiones, revise las » Instrucciones de Git Anónimo.


Descarga de extensiones PECL

Existen varias opciones para descargar extensiones PECL, a saber:

  • El comando pecl install extname descarga el código de la extensión automáticamente, de modo que en este caso no se hace necesario realizar una descarga por separado.
  • » https://pecl.php.net/ La página web de PECL contiene información sobre las diferentes extensiones que ofrece el Equipo de Desarrollo de PHP. La información disponible aquí incluye: ChangeLog, notas de la versión, requisitos, y otros detalles similares.
  • pecl download extname Puede descargar e instalar las extensiones PECL listadas en el sitio web de PECL usando el » comando pecl. También se podrán especificar versiones concretas.
  • SVN La mayor parte de las extensiones PECL también están alojadas en SVN. Puede consultar la interfaz web en » https://svn.php.net/viewvc/pecl/. Para descargar directamente del SVN, debe usar la siguiente secuencia de comandos:

    $ svn checkout http://svn.php.net/repository/pecl/extname/trunk extname

  • Descargas para Windows El proyecto PHP compila y ofrece DLL de Windows para la mayoría de extensiones PECL en la página del paquete respectivo.


Instalación una extensión de PHP en Windows

Dispone de dos formas para cargar extensiones PHP en Windows: o bien compilándolas en PHP, o bien cargando su DLL. El método recomendado y más sencillo es cargar una extensión pre-compilada.

Para cargar una extensión, debe estar disponible como fichero ".dll" en su sistema. Todas las extensiones son compiladas por el Grupo PHP automática y periódicamente (revise la siguiente sección para realizar descargas).

Para compilar una extensión en PHP, por favor, acceda a la documentación de construcción de la fuente.

Para compilar una extensión independiente (o lo que es lo mismo, un fichero DLL), por favor, revise la documentación de construcción de la fuente. Si el fichero DLL no está disponible ni en su distribución de PHP ni en PECL, deberá compilarla antes de poder comenzar a usarla.

¿Dónde encontrar una extensión?

Las extensiones de PHP generalmente se llaman "php_*.dll" (donde el asterisco representa el nombre de la extensión) y se localizan bajo la carpeta "PHP\ext".

PHP se distribuye con las extensiones más útiles para la mayoría de desarrolladores. Se les llama extensiones del "núcleo".

En cualquier caso, si necesita una funcionalidad que no proporciona ninguna de las extensiones del núcleo, podrá buscarla en PECL. La Biblioteca de la Comunidad de Extensiones de PHP (PECL) es un repositorio de extensiones PHP, que proporciona un directorio de todas las extensiones conocidas, y aloja utilidades para descargar y desarrollar extensiones de PHP.

Si usted ha desarrollado una extensión para su propio uso, quizá quiera considerar alojarla en PECL, de forma que otros desarrolladores con las mismas necesidades puedan verse beneficiados de su tiempo. Una de las ventajas es que tendrá la oportunidad de recibir colaboración, (ojalá) agradecimientos, informes de errores, e incluso parches/correcciones. Antes de enviar su extensión para ser alojada en PECL, por favor, lea » el envío a PECL.

¿Qué extensión descargar?

A menudo, encontrará varias versiones de cada DLL:

  • Números de versión diferentes (al menos los dos primeros números deben coincidir)
  • Diferentes ajustes de seguridad en hilos
  • Diferentes arquitecturas de procesadores (x86, x64, ...)
  • Diferentes ajustes de depuración
  • etc.

Debe tener en cuenta que los ajustes de su extensión deben coincidir con la configuración del ejecutable de PHP que está utilizando. El siguiente script de PHP le dirá todo sobre sus ajustes de PHP:

Ejemplo #1 llamada a phpinfo()

<?php
phpinfo();
?>

O ejecute desde la línea de comandos:

drive:\\path\to\php\executable\php.exe -i

Cargando una extensión

La forma más común de cargar una extensión PHP consiste en incluirla en el fichero de configuración php.ini. Por favor, tenga en cuenta que ya hay muchas extensiones presentes en el fichero php.ini y que sólo es necesario eliminar el punto y coma para activarlas.

Observe que en versiones de PHP 7.2.0 y superiores, se podría utilizar el nombre de extensión en lugar del nombre de fichero de la extensión. Ya que esto es independiente del SO y más sencillo, especialmente para recién llegados, se convierte en la forma recomendada de especificar estensiones a cargar. El soporte para nombres de ficheros permanece por compatibilidad con versiones anteriores.

;extension=php_extname.dll

extension=php_extname.dll

; On PHP version 7.2 and up, prefer :
extension=extname
zend_extension=another_extension

Sin embargo, algunos servidores web puede resultar confusos, dado que no utilizan el php.ini ubicado junto al ejecutable de PHP. Para averiguar dónde se localiza el php.ini en uso, consulte su ruta usando phpinfo():

Configuration File (php.ini) Path  C:\WINDOWS

Loaded Configuration File   C:\Program Files\PHP\5.2\php.ini

Tras activar una extensión, guarde el fichero php.ini, reinicie el servidor web y vuelva a comprobar phpinfo(). La nueva extensión debe ahora tener su propia sección.

Resolviendo problemas

Si la extensión no aparece en phpinfo(), compruebe los registro de errores para conocer qué provoca el problema.

Si está utilizando PHP desde la línea de comandos (CLI), podrá leer directamente en pantalla el error en la carga de la extensión.

Si está usando PHP en un servidor web, la localización y formato de los registros vería en función de su software. Por favor, lea la documentación de su servidor web para localizar los registros, dado que esto no lo gestiona el propio ejecutable de PHP.

Los problemas más comunes son la ubicación del fichero DLL, el valor de " extension_dir" en php.ini, y desajustes de configuración en tiempo de compilación.

Si el problema reside en desajustes de configuración en tiempo de compilación, seguramente se deba a que no se ha descargado el fichero DLL correcto. Pruebe a descargar de nuevo la extensión con los ajustes correctos. De nuevo, phpinfo() puede resultar de gran ayuda.


Compilando extensiones PECL compartidas con el comando pecl

PECL facilita la creación de extensiones PHP compartidas. Usando el » comando pecl, haga lo siguiente:

$ pecl install extname

Esto descargará el código fuente de extname, lo compilará, e instalará extname.so en su extension_dir. Ahora se puede cargar extname.so mediante php.ini

Por omisión, el comando pecl no instalará paquetes marcados en los estados alpha o beta. Si no hay paquetes disponibles en estado stable, podrá instalar un paquete en estado beta utilizando el siguiente comando:

$ pecl install extname-beta

Del mismo modo, podrá también instalar una versión en concreto usando esta variante:

$ pecl install extname-0.1

Nota:

Tras activar la extensión en php.ini, será necesario reiniciar el servidor web para hacer efectivos los cambios.


Compilando extensiones PEC compartidas con phpize

A menudo no es posible utilizar el instalador pecl. Esto se puede deber a que se encuentra tras un cortafuegos, o a que la extensión que trata de instalar no está disponible como paquete compatible con PECL, como por ejemplo extensiones no liberadas desde el SVN. Si necesita construir una extensión de este tipo, puede llevar a cabo esta tarea manualmente utilizando las herramientas de construcción de bajo nivel.

El comando phpize se utiliza para preparar el entorno de compilación de la extensión de PHP. En el siguiente ejemplo, el fuente de una extensión se ubica en un directorio llamado extname:

$ cd extname
$ phpize
$ ./configure
$ make
# make install

En caso de que la instalación sea correcta, se creará extname.so y se salvará en el directorio de extensiones de PHP. Quizá necesite ajustar el fichero php.ini y añadir una línea extension=extname.so antes de poder usar la extensión.

Si el sistema no contiene el comando phpize, y se están utilizando paquetes pre-compilados (como RPM), asegúrese de instalar también la versión de desarrollo apropiada del paquete PHP, dado que a menudo incluyen el comando phpize con los ficheros de cabeceras necesarios para construir PHP y sus extensiones.

Ejecute phpize --help para mostrar información de uso adicional.


php-config

php-config es una utilidad de consola que permite obtener información sobre la configuración de la instalación de PHP.

A la hora de compilar extensiones, si se tuvieran varias versiones de PHP instaladas, se podrá especificar sobre cuál se va a construir usando el modificador --with-php-config durante la configuración, donde especificaremos la ruta a su respecto script php-config.

En cualquier momento podrá consutlarse la lista de opciones de la utilidad php-config ejecutando php-config con el modificador -h:

Usage: /usr/local/bin/php-config [OPTION]
Options:
  --prefix            [...]
  --includes          [...]
  --ldflags           [...]
  --libs              [...]
  --extension-dir     [...]
  --include-dir       [...]
  --php-binary        [...]
  --php-sapis         [...]
  --configure-options [...]
  --version           [...]
  --vernum            [...]

Opciones de línea de comandos
Opción | Descripción
--prefix | Prefijo del directorio donde PHP está instalado, p.ej. /usr/local
--includes | Lista de opciones -I con todos los ficheros incluídos
--ldflags | Banderas LD con las que se ha compilado PHP
--libs | Bibliotecas extras con las que se ha compilado PHP
--extension-dir | Directorio en el que se buscan por omisión las extensiones
--include-dir | Prefijo de directorio donde se buscan por omisión los ficheros de cabeceras
--php-binary | Ruta completa al binario de php CLI o CGI
--php-sapis | Muestra todos los módulos SAPI disponibles
--configure-options | Opciones de configuración para recrear la configuración de la instalación actual de PHP
--version | Versión de PHP
--vernum | Versión de PHP en forma de entero


Compilando extensiones PECL estáticamente en PHP

Quizá necesite construir una extensión PECL estáticamente en su binario de PHP. Para hacer esto, necesitará ubicar el fuente de la extensión bajo el directorio /su/directorio_fuentes_php/ext/ e indicarle al sistema de construcción de PHP que regenere su script de configuración.

$ cd /your/phpsrcdir/ext
$ pecl download extname
$ gzip -d < extname.tgz | tar -xvf -
$ mv extname-x.x.x extname

Esto generará el siguiente directorio:

/your/phpsrcdir/ext/extname

Desde aquí, fuerce a PHP a regenerar el script de configuración, y entonces construya PHP con normalidad:

$ cd /your/phpsrcdir
$ rm configure
$ ./buildconf --force
$ ./configure --help
$ ./configure --with-extname --enable-someotherext --with-foobar
$ make
$ make install

Nota: Necesitará autoconf 2.13 y automake 1.4+ para ejecutar el script 'buildconf' (es posible que funcionen versiones más recientes de autoconf, pero no están oficialmente soportadas).

Dependiendo de la extensión, utilizará --enable-extname o --with-extname. Las extensiones que no requieren de bibliotecas externas generalmente utilizan --enable. Para asegurarse, ejecute el siguiente comando después de buildconf:

$ ./configure --help | grep extname


  • « Compilando extensiones PECL estáticamente en PHP
  • Lea las Preguntas frecuentes »
  • PHP Manual
  • Instalación y configuración
  • Resolución de problemas

Resolución de problemas

Tabla de contenidos

  • Lea las Preguntas frecuentes
  • Otros problemas
  • Informar sobre errores (bugs)


Lea las Preguntas frecuentes

Algunos problemas son más comunes que otros. Los más comunes se enumeran en las Preguntas frecuentes de PHP de este manual.


Otros problemas

Si sigue bloqueado, seguramente alguien de la lista de correo de la instalación de PHP podrá ayudarle. Primero, debería consultar el archivo para comprobar si alguien ya ha contestado a otra persona que haya tenido el mismo problema. Los archivos están disponibles desde la página de soporte en » https://www.php.net/support.php. Para subscribirse a la lista de correo de la instalación de PHP (en inglés), envíe un correo vacío a » php-install-subscribe@lists.php.net. La dirección de la lista de correo es » php-install@lists.php.net.

Si quiere obtener ayuda de la lista de correo, por favor trate de ser preciso y dar toda la información necesaria a cerca de su entorno (sistema operativo, versión de PHP, servidor web, si está usando PHP como GCI o como módulo de servidor, etc.), y preferiblemente suficiente código para que otras personas sean capaces de reproducir y probar su problema.


Informar sobre errores (bugs)

Si cree que ha encontrado un error en PHP, por favor informe sobre él. Los desarrolladores de PHP probablemente no estén informados del problema y, a no ser que lo mencione, es muy probable que no sea solucionado. Puede informar sobre errores empleando el sistema de seguimiento de errores en » https://bugs.php.net/. Por favor, no envíe informes de errores a listas de correos o cartas personales. El sistema de errores también está capacitado para enviar sugerencias y peticiones.

Lea el documento » Cómo informar sobre errores antes de enviar cualquier informe de errores.


Configuración en tiempo de ejecución

Tabla de contenidos

  • El fichero de configuración
  • Ficheros .user.ini
  • Dónde se puede realizar un ajuste de configuración
  • Cómo cambiar los ajustes de configuración


El fichero de configuración

El fichero de configuración (php.ini) es leído al arrancar PHP. En las versiones en que PHP funciona como módulo de servidor, esto sucede únicamente cuando se inicia el servidor. En las versiones CGI y CLI, esto ocurre en cada ejecución.

El fichero php.ini se busca en las siguientes ubicaciones (en orden):

  • La ubicación específica de módulo SAPI (directiva PHPIniDir en Apache 2, opción de línea de comandos -c en CGI y CLI, parámetro php_ini en NSAPI, variable de entorno PHP_INI_PATH en THTTPD)
  • La variable de entorno PHPRC. Antes de PHP 5.2.0, esta ubicación se comprobaba después de la clave de registro mencionada más abajo.
  • A partir de PHP 5.2.0, se puede establecer la ubicación del fichero php.ini para diferentes versiones de PHP. Se examinan en orden las siguientes claves de registro: [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y.z], [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y] y [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x], donde 'x', 'y' y 'z' significan la versión mayor, menor, y de edición de PHP. Si existiera un valor para IniFilePath en cualquiera de estas claves, la primera en ser encontrada se utilizaría como ubicación del fichero php.ini (solo en Windows).
  • [HKEY_LOCAL_MACHINE\SOFTWARE\PHP], valor de IniFilePath (solo en Windows).
  • El directorio actual de trabajo (excepto CLI)
  • El directorio del servidor web (para módulos SAPI), o el directorio de PHP (excepto en Windows)
  • El directorio de Windows (C:\windows o C:\winnt) (para Windows), o la opción en tiempo de compilación --with-config-file-path.

Si existiera el fichero php-SAPI.ini (donde SAPI es la SAPI en uso, por ejemplo, php-cli.ini o php-apache.ini), se usaría éste en lugar de php.ini. Se puede determinar el nombre de la SAPI usando php_sapi_name().

Nota:

El servidor web Apache cambia el directorio al raíz al arrancar, haciendo que PHP intente leer php.ini desde el sistema de ficheros raíz si existiera.

Las variables de entorno se pueden usar en php.ini como se muestra abajo.

Ejemplo #1 Variables de entorno de php.ini

; PHP_MEMORY_LIMIT se toma del entorno
memory_limit = ${PHP_MEMORY_LIMIT}

Las directivas de php.ini manejadas por extensiones están documentadas en la propia página de cada extensión. Hay una lista de directivas del núcleo disponible en el apéndice. Es posible que no todas las directivas de PHP estén documentadas en el manual: para consultar una lista completa de las directivas disponibles en su versión de PHP, por favor, lea los comentarios del fichero php.ini. Adicionalmente, puede encontrar útil » el último php.ini desde Git.

Ejemplo #2 Ejemplo de php.ini

; todo texto en una línea tras un punto y coma sin comillas (;) será ignorado
[php] ; los marcadores de sección (textos entre corchetes) también se ignoran
; Los valores de tipo boolean puede establecerse a:
;    true, on, yes
; o  false, off, no, none
register_globals = off
track_errors = yes

; se pueden encerrar los strings entre comillas dobles
include_path = ".:/usr/local/lib/php"

; las barras invertidas reciben el mismo tratamiento que el resto de caracteres
include_path = ".;c:\php\lib"

A partir de PHP 5.1.0, es posible hacer referencia a variables .ini ya existentes desde el propio fichero .ini. Ejemplo: open_basedir = ${open_basedir} ":/new/dir".

Directorios de búsqueda

Es posible configurar PHP para que busque ficheros .ini en un directorio después de leer php.ini. Esto se puede realizar durante la compilación estableciento la opción --with-config-file-scan-dir. En PHP 5.2.0 y posteriores, el directorio de búsqueda puede ser sobrescrito durante la ejecución estableciendo la vairable de entorno PHP_INI_SCAN_DIR.

Es posible buscar en varios directorios separándolos con el separador de rutas específico de cada plataforma (; en Windows, NetWare y RISC OS; : en las demás plataformas; el valor que PHP emplea está disponible como la constante PATH_SEPARATOR). Si se proporciona a PHP_INI_SCAN_DIR un directorio en blanco, PHP también buscará en el directorio dado durante la compilación mediante --with-config-file-scan-dir.

PHP buscará dentro de cada directorio todos los ficheros que finalicen en .ini en orden alfabético. Se puede obtener una lista de los ficheros cargados, y en qué orden, llamando a php_ini_scanned_files(), o ejecutando PHP con la opción --ini.

Se asumen que PHP está configurado con --with-config-file-scan-dir=/etc/php.d,
y que el separador de rutas es :...

$ php
  PHP cargará todos los ficheros de /etc/php.d/*.ini como ficheros de configuración.

$ PHP_INI_SCAN_DIR=/usr/local/etc/php.d php
  PHP cargará todos los ficheros de /usr/local/etc/php.d/*.ini como
  ficheros de configuración.

$ PHP_INI_SCAN_DIR=:/usr/local/etc/php.d php
  PHP cargará todos los ficheros de /etc/php.d/*.ini, y luego de
  /usr/local/etc/php.d/*.ini como ficheros de configuración.

$ PHP_INI_SCAN_DIR=/usr/local/etc/php.d: php
  PHP cargará todos los ficheros de /usr/local/etc/php.d/*.ini, y luego de
  /etc/php.d/*.ini como ficheros de configuración.

Historial de cambios

Versión | Descripción
7.0.0 | Las almohadillas (#) ya no se reconocen como comentarios.
5.3.0 | Las almohadillas (#) ya no deberían utilizarse como comentarios, ya que lanzarán una advertencia de obsolescencia si se emplean.
5.2.0 | La variable de entorno PHP_INI_SCAN_DIR se puede establecer para sobrescribir el directorio de búsqueda mediante el script de configuración.
5.1.0 | Es posible referirse a variables .ini existentes dentrode ficheros .ini.


Ficheros .user.ini

A partir de PHP 5.3.0 se incluye soporte para ficheros de configuración INI a nivel de directorios. Estos ficheros solo los procesa la SAPI CGI/FastCGI. Esta funcionalidad deja obsoleta la extensión PECL htscanner. Si está usando Apache, use los ficheros .htaccess para lograr el mismo efecto.

Además del fichero php.ini principal, PHP explora cada directorio en busca de ficheros INI, empezando por el directorio del fichero PHP solicitado, y continuando hasta el directorio raíz de documentos (tal y como esté establecido en $_SERVER['DOCUMENT_ROOT']). En el caso de que el fichero PHP se encuentre fuera del directorio raíz de documentos, sólo se explorará su directorio.

En los ficheros INI estilo .user.ini sólo se reconocerán las configuraciones INI que tengan los modos PHP_INI_PERDIR y PHP_INI_USER.

Las dos nuevas directivas INI, user_ini.filename y user_ini.cache_ttl controlan el uso de los ficheros INI de usuarios.

user_ini.filename establece el nombre del fichero que PHP buscará en cada directorio; si se establece un string vacío, PHP no realizará ninguna búsqueda. El nombre por omisión es .user.ini.

user_ini.cache_ttl controla con qué frecuencia se releen los ficheros INI de usuario. El valor por omisión es 300 segundos (5 minutos).


Dónde se puede realizar un ajuste de configuración

Estos modos determinan cuándo y dónde se debe o no asignar una directiva de PHP, y cada directiva del manual hace referencia a uno de estos modos. Por ejemplo, algunos ajustes pueden establecerse en scripts de PHP usando ini_set(), mientras que otros requieren hacerlo en php.ini o en httpd.conf.

Por ejemplo, el ajuste output_buffering es PHP_INI_PERDIR por tanto no puede establecerse usando ini_set(). Sin embargo, la directiva display_errors es PHP_INI_ALL por tanto se puede establecer en cualquier lugar, incluso con ini_set().

Definición de los modos PHP_INI_*
Modo | Significado
PHP_INI_USER | La entrada se puede establecer en scripts de usuario (como con ini_set()) o en el registro de Windows. Desde PHP 5.3, la entrada puede ser establecida en .user.ini
PHP_INI_PERDIR | La entrada se puede establecer en php.ini, .htaccess, httpd.conf o .user.ini (desde PHP 5.3)
PHP_INI_SYSTEM | La entrada se puede establecer en php.ini o en httpd.conf
PHP_INI_ALL | La entrada se puede establecer en cualquier lugar


Cómo cambiar los ajustes de configuración

Ejecutar PHP como un módulo de Apache

Cuando se usa PHP como un módulo de Apache, se pueden cambiar los ajustes de configuración usando directivas en los ficheros de configuración de Apache (p.ej. httpd.conf) y en los ficheros .htaccess. Se necesitarán los privilegios "AllowOverride Options" o "AllowOverride All" para poder hacerlo.

Existen varias directivas de Apache que permiten cambiar la configuración de PHP desde los propios ficheros de configuración de Apache. Para un listado las directivas que son PHP_INI_ALL, PHP_INI_PERDIR, o PHP_INI_SYSTEM, consulte el apéndice de la Lista de directivas de php.ini.

php_value nombre valor

Establece el valor de la directiva especificada. Sólo puede usarse con las directivas de tipo PHP_INI_ALL y PHP_INI_PERDIR. Para borrar un valor previamente establecido, use none como valor.

Nota: No use php_value para establecer valores boolean. Debe usarse en su lugar php_flag (ver más abajo).

php_flag nombre on|off

Usado para establecer una directiva de configuración de tipo boolean. Sólo puede usarse con las directivas de tipo PHP_INI_ALL y PHP_INI_PERDIR.

php_admin_value nombre valor

Establece el valor de la directiva especificada. Esto no se puede usar en ficheros .htaccess. Ninguna directiva establecida con php_admin_value podrá ser sobrescrita por .htaccess o por ini_set(). Para borrar un valor establecido previamente use none como valor.

php_admin_flag nombre on|off

Usado para establecer una directiva de configuración de tipo boolean. Esto no se puede usar en ficheros .htaccess. Ninguna directiva establecida con php_admin_flag podrá ser sobrescrita por .htaccess o por ini_set().

Ejemplo #1 Ejemplo de configuración de Apache

<IfModule mod_php5.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>
<IfModule mod_php4.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>

Precaución

Las constantes de PHP no existen fuera de PHP. Por ejemplo, en httpd.conf no se pueden usar constantes de PHP tales como E_ALL o E_NOTICE para establecer la directiva error_reporting puesto que no tendrán ningún significado y se evaluarán como 0. Use en su lugar la máscara de bits asociada. Estas constantes sí pueden ser usadas en php.ini

Cambiar la configuración de PHP a través del registro de Windows

Cuando se ejecuta PHP en Windows, se pueden modificar los valores de configuración a nivel de directorio usando el registro de Windows. Los valores de configuración se almacenan en la clave de registro HKLM\SOFTWARE\PHP\Per Directory Values, en las subclaves correspondientes a los nombres de ruta. Por ejemplo, los valores de configuración para el directorio c:\inetpub\wwwroot se almacenarían en la clave HKLM\SOFTWARE\PHP\Per Directory Values\c\inetpub\wwwroot. Los ajustes para el directorio estarán activos para cualquier script dentro de este directorio o en cualquiera de sus subdirectorios. Los valores bajo esta clave deberían tener el nombre de la directiva de configuración de PHP y el valor como string. Las constantes de PHP usadas como valor no serán procesadas. En cualquier caso, únicamente los valores de configuración modificables de PHP_INI_USER podrán establecerse con este método, mientras que los valores de PHP_INI_PERDIR no.

Otras interfaces a PHP

Independientemente de cómo ejecute PHP, se pueden cambiar determinados valores de los scripts en tiempo de ejecución mediante ini_set(). Consulte la documentación de la página ini_set() para más información.

Si está interesado en una lista completa de los ajustes de configuración en su sistema con sus valores actuales, puede ejecutar la función phpinfo(), y consultar la página mostrada. Puede también acceder a los valores de directivas de configuración concretas usando ini_get() o get_cfg_var().


Referencia del lenguaje

  • Sintaxis básica
    • Etiquetas de PHP
    • Salir de HTML
    • Separación de instrucciones
    • Comentarios
  • Tipos
    • Introducción
    • Booleanos
    • Números enteros (Integers)
    • Números de punto flotante
    • Cadenas de caracteres (Strings)
    • Numeric strings
    • Arrays
    • Iterables
    • Objetos
    • Recursos
    • NULO
    • Llamadas de retorno (Callbacks / Callables)
    • Type declarations
    • Manipulación de tipos
  • Variables
    • Conceptos básicos
    • Variables Predefinidas
    • Ámbito de las variables
    • Variables variables
    • Variables desde fuentes externas
  • Constantes
    • Sintaxis
    • Constantes predefinidas
  • Expresiones
  • Operadores
    • Precedencia de operadores
    • Operadores aritméticos
    • Operadores de asignación
    • Operadores bit a bit
    • Operadores de comparación
    • Operadores de control de errores
    • Operadores de ejecución
    • Operadores de incremento/decremento
    • Operadores lógicos
    • Operadores para strings
    • Operadores para arrays
    • Operadores de tipo
  • Estructuras de Control
    • Introducción
    • if
    • else
    • elseif/else if
    • Sintaxis alternativa de estructuras de control
    • while
    • do-while
    • for
    • foreach
    • break
    • continue
    • switch
    • match
    • declare
    • return
    • require
    • include
    • require_once
    • include_once
    • goto
  • Funciones
    • Funciones definidas por el usuario
    • Argumentos de funciones
    • Devolver valores
    • Funciones variables
    • Funciones internas (incluidas)
    • Funciones anónimas
    • Funciones de flecha
  • Clases y objetos
    • Introducción
    • Lo básico
    • Propiedades
    • Constantes de clases
    • Autocarga de clases
    • Constructores y destructores
    • Visibilidad
    • Herencia de Objetos
    • Operador de Resolución de Ámbito (::)
    • La palabra reservada 'static'
    • Abstracción de clases
    • Interfaces de objetos
    • Rasgos (Traits)
    • Clases anónimas
    • Sobrecarga
    • Iteración de objetos
    • Métodos mágicos
    • Palabra clave Final
    • Clonación de Objetos
    • Comparación de Objetos
    • Enlaces estáticos en tiempo de ejecución
    • Objetos y referencias
    • Serialización de objetos
    • Covarianza y Contravarianza
    • Registro de cambios de la POO
  • Espacios de nombres
    • Resumen de los espacios de nombres
    • Definir espacios de nombres
    • Declarar subespacios de nombres
    • Definir varios espacios de nombres en un mismo fichero
    • Uso de los espacios de nombres: lo básico
    • Espacios de nombres y características dinámicas del lenguaje
    • La palabra reservada namespace y la constante __NAMESPACE__
    • Uso de los espacios de nombres: apodar/importar
    • Espacio global
    • Utilizar espacios de nombres: una alternativa a funciones/constantes globales
    • Reglas de resolución de nombres
    • P+F: cosas que es necesario saber sobre los espacios de nombres
  • Errores
    • Lo básico
    • Errores en PHP 7
  • Excepciones
    • Ampliar las Excepciones
  • Generadores
    • Información general de los generadores
    • Generator syntax
    • Comparación entre generadores y objetos Iterator
  • Attributes
    • Attributes overview
    • Attribute syntax
    • Reading Attributes with the Reflection API
    • Declaring Attribute Classes
  • Explicación de las Referencias
    • ¿Qué son las Referencias?
    • ¿Qué hacen las referencias?
    • ¿Qué NO son las Referencias?
    • Pasar por Referencia
    • Devolver Referencias
    • Destruir Referencias
    • Ubicar las Referencias
  • Variables predefinidas
    • Superglobals — Superglobals son variables internas que están disponibles siempre en todos los ámbitos
    • $GLOBALS — Hace referencia a todas las variables disponibles en el ámbito global
    • $_SERVER — Información del entorno del servidor y de ejecución
    • $_GET — Variables HTTP GET
    • $_POST — Variables POST de HTTP
    • $_FILES — Variables de subida de ficheros HTTP
    • $_REQUEST — Variables HTTP Request
    • $_SESSION — Variables de sesión
    • $_ENV — Variables de entorno
    • $_COOKIE — Cookies HTTP
    • $php_errormsg — El mensaje de error anterior
    • $http_response_header — Encabezados de respuesta HTTP
    • $argc — El número de argumentos pasados a un script
    • $argv — Array de argumentos pasados a un script
  • Excepciones predefinidas
    • Exception
    • ErrorException
    • Error
    • ArgumentCountError
    • ArithmeticError
    • AssertionError
    • DivisionByZeroError
    • CompileError
    • ParseError
    • TypeError
  • Interfaces y clases predefinidas
    • Traversable — La interfaz Traversable
    • Iterator — La interfaz Iterator
    • IteratorAggregate — La interfaz IteratorAggregate
    • Throwable
    • ArrayAccess — La interfaz ArrayAccess
    • Serializable — La interfaz Serializable
    • Closure — La clase Closure
    • Generator — La clase Generator
    • WeakReference — La clase WeakReference
  • Opciones y parámetros de contexto
    • Opciones de contexto de sockets — Listado de opciones de contexto de sockets
    • Opciones de contexto de HTTP — Listado de opciones de contexto de HTTP
    • Opciones de contexto para FTP — Listado de opciones de contexto para FTP
    • Opciones de contexto para SSL — Listado de opciones de contexto para SSL
    • Opciones de contexto para CURL — Listado de opciones de contexto para CURL
    • Opciones de contexto Phar — Listado de opciones de contexto Phar
    • Opciones de contexto de MongoDB — Listado de opciones de contexto de MongoDB
    • Contexto parámetros — Listado de parámetros de contexto
    • Opciones del contexto zip — Listado de opciones del contexto zip
  • Protocolos y Envolturas soportados
    • file:// — Acceso al sistema de ficheros local
    • http:// — Acceso a URLS en HTTP(s)
    • ftp:// — Acceso a URLs por FTP(s)
    • php:// — Acceso a distintos flujos de E/S
    • zlib:// — Flujos de compresión
    • data:// — Data (RFC 2397)
    • glob:// — Encuentra las rutas que coincidan con el patrón
    • phar:// — Archivo PHP
    • ssh2:// — Secure Shell 2
    • rar:// — RAR
    • ogg:// — Flujos de audio
    • expect:// — Flujos de Interacción de Procesos


Sintaxis básica

Tabla de contenidos

  • Etiquetas de PHP
  • Salir de HTML
  • Separación de instrucciones
  • Comentarios


Etiquetas de PHP

Cuando PHP analiza un fichero, busca las etiquetas de apertura y cierre, que son <?php y ?>, y que indican a PHP dónde empezar y finalizar la interpretación del código. Este mecanismo permite embeber a PHP en todo tipo de documentos, ya que todo lo que esté fuera de las etiquetas de apertura y cierre de PHP será ignorado por el analizador.

PHP también permite la etiqueta de apertura abreviada <? (la cual está desaconsejada debido a que sólo está disponible si se habilita con la directiva short_open_tag del fichero de configuración php.ini, o si PHP se configuró con la opción --enable-short-tags).

Si un fichero contiene solamente código de PHP, es preferible omitir la etiqueta de cierre de PHP al final del mismo. Así se previene la adición de espacios en blanco o nuevas líneas accidentales después de la etiqueta de cierre, lo cual causaría efectos no deseados debido a que PHP comenzará la salida del búfer cuando no había intención por parte del programador de enviar ninguna salida en ese punto del script.

<?php
echo "Hola mundo";

// ... más código

echo "Última sentencia";

// el script finaliza aquí sin etiqueta de cierre de PHP

Historial de cambios
Versión | Descripción
7.0.0 | Se eliminaron de PHP las etiquetas de ASP <%, %>, <%=, y la etiqueta de script <script language="php">.
5.4.0 | La etiqueta <?= siempre está disponible independientemente del ajuste ini short_open_tag.


Salir de HTML

Cualquier cosa fuera de un par de etiquetas de apertura y cierre es ignorado por el intérprete de PHP, lo que permite que los ficheros de PHP tengan contenido mixto. Esto hace que PHP pueda ser embebido en documentos HTML para, por ejemplo, crear plantillas.

<p>Esto va a ser ignorado por PHP y mostrado por el navegador.</p>
<?php echo 'Mientras que esto va a ser interpretado.'; ?>
<p>Esto también será ignorado por PHP y mostrado por el navegador.</p>
Este ejemplo funciona como estaba previsto, porque cuando PHP intercepta las etiquetas de cierre ?>, simplemente comienza a imprimir cualquier cosa que encuentre (a excepción de una nueva línea inmediatamente después; véase la separación de instrucciones) hasta que dé con otra etiqueta de apertura a menos que se encuentre en mitad de una sentencia condicional, en cuyo caso el intérprete determinará el resultado de la condición antes de tomar una decisión de qué es lo que tiene que saltar. Vea el siguiente ejemplo.

Empleo de estructuras con condiciones

Ejemplo #1 Salida avanzada usando condiciones

<?php if ($expresión == true): ?>
  Esto se mostrará si la expresión es verdadera.
<?php else: ?>
  En caso contrario se mostrará esto.
<?php endif; ?>
En este ejemplo, PHP saltará los bloques donde la condición no se cumpla, incluso si están fuera de las etiquetas de apertura/cierre de PHP, los saltará según la condición debido a que el intérprete salta los bloques contenidos dentro de una condición que no se cumpla.

Para imprimir bloques de texto grandes, es más eficiente abandonar el modo intérprete de PHP que enviar todo el texto a través de echo o print.

En PHP 5 existen hasta cinco pares de etiquetas de apertura y cierre diferentes, dependiendo de la configuración de PHP. Dos de estas, <?php ?> y <script language="php"> </script>, siempre están disponibles. También existe una etiqueta echo abreviada, <?= ?>, que siempre está disponible en PHP 5.4.0 y posteriores.

Las otras dos son las etiquetas abreviadas y las etiquetas al estilo de ASP. De por sí, aunque algunos encuentran prácticas, las etiquetas abreviadas y las etiquetas al estilo ASP son menos portables, no recomendándose por lo general.

Nota:

Observe también que si se está embebiendo PHP dentro de XML o XHTML será necesario usar las etiquetas <?php ?> para seguir los estándares.

PHP 7 elimina el soprte para las etiquetas ASP y <script language="php">. Por tanto, para maximizar la compatibilidad, se recomienda solamente el empleo de <?php ?> y <?= ?> al escribir código de PHP.

Ejemplo #2 Etiquetas de apertura y de cierre de PHP

1.  <?php echo 'si quiere proveer código de PHP a documentos XHTML o XML,
                emplee estas etiquetas'; ?>

2.  Puede emplear la etiqueta echo abreviada para <?= 'imprimir esta cadena' ?>.
    Siempre está habilitada en PHP 5.4.0 y posterior, y es equivalente a
    <?php echo 'imprimir esta cadena' ?>.

3.  <? echo 'este código está dentro de etiquetas abreviadas, aunque sólo '.
            'funcionará si short_open_tag está habilitada'; ?>

4.  <script language="php">
        echo 'a algunos editores (como FrontPage) no les gustan
              las instruciones de procesamiento dentro de estas etiquetas';
    </script>
    Esta sintaxis ha sido eliminada en PHP 7.0.0.

5.  <% echo 'Opcionalmente, se pueden emplear las etiquetas al estilo de ASP'; %>
    El código dentro de estas etiquetas <%= $variable; %> es una abreviatura para este código <% echo $variable; %>
    Ambas sintaxis han sido eliminadas en PHP 7.0.0.

Las etiquetas abreviadas (ejemplo tres) solamente están disponibles cuando se activan mediante la directiva short_open_tag del fichero de configuración php.ini o si PHP se configuró con la opción --enable-short-tags.

Las etiquetas de estilo de ASP (ejemplo cinco) solamente están disponibles cuando se activan mediante la directiva asp_tags del fichero de configuración php.ini. Han sido eliminadas en PHP 7.0.0.

Nota:

Debe evitarse el uso de etiquetas abreviadas cuando se desarrollen aplicaciones o bibliotecas que estén pensadas para su redistribución o despliegue en servidores de PHP que no estén bajo su control, porque puede que las etiquetas abreviadas no estén admitidas en un servidor determinado. Por portabilidad y código redistribuible, asegúrese de no usar etiquetas abreviadas.

Nota:

En PHP 5.2 y anteriores, el analizador no permite que un fichero contenga únicamente la etiqueta de apertura <?php. A partir de PHP 5.3 sí se permite, siempre que existan uno o más caracteres espacio en blanco después de la etiqueta de apertura.

Nota:

Desde PHP 5.4, la etiqueta de echo abreviada <?= siempre es aceptada y válida, independientemente de la configuración de short_open_tag.


Separación de instrucciones

Como en C o en Perl, PHP requiere que las instrucciones terminen en punto y coma al final de cada sentencia. La etiqueta de cierre de un bloque de código de PHP automáticamente implica un punto y coma; no es necesario usar un punto y coma para cerrar la última línea de un bloque de PHP. La etiqueta de cierre del bloque incluirá la nueva línea final inmediata si está presente.

<?php
    echo 'Esto es una prueba';
?>

<?php echo 'Esto es una prueba' ?>

<?php echo 'Hemos omitido la última etiqueta de cierre';

Nota:

La etiqueta de cierre de un bloque de PHP es opcional al final de un fichero, y en algunos casos es útil omitirla cuando se usa include o require, para que no se produzcan espacios en blanco al final de los ficheros, pudiéndose aún añadir así cabeceras para la respuesta posterior. También es práctico si se utiliza la salida del buffer y no se desean espacios en blanco no deseados al final de las partes generadas por ficheros incluídos.


Comentarios

PHP admite comentarios al estilo de 'C', 'C++' y de consola de Unix (estilo de Perl). Por ejemplo:

<?php
    echo 'Esto es una prueba'; // Esto es un comentario al estilo de c++ de una sola línea
    /* Esto es un comentario multilínea
       y otra lína de comentarios */
    echo 'Esto es otra prueba';
    echo 'Una prueba final'; # Esto es un comentario al estilo de consola de una sola línea
?>

Los comentarios al estilo de "una sola línea" solo comentan hasta el final de la línea o del bloque actual de código de PHP, lo primero que suceda. Esto implica que el código HTML después de // ... ?> o # ... ?> SERÁ impreso: ?> sale del modo PHP y vuelve al modo HTML, por lo que // o # no pueden influir en eso. Si la directiva de configuración asp_tags está activada, actúa igual que // %> y # %>. Sin embargo, la etiqueta </script> no sale del modo PHP en un comentario de una sola línea.

<h1>Esto es un <?php # echo 'simple';?> ejemplo</h1>
<p>El encabezado anterior dirá 'Esto es un  ejemplo'.</p>

Los comentarios al estilo de 'C' finalizan con el primer */ que se encuentre. Asegúrese de no anidar comentarios al estilo de 'C'. Es muy fácil cometer este error cuando se intenta comentar un bloque grande de código.

<?php
 /*
    echo 'Esto es una prueba'; /* Este comentario causará un problema*/
 */
?>


Tipos

Tabla de contenidos

  • Introducción
  • Booleanos
  • Números enteros (Integers)
  • Números de punto flotante
  • Cadenas de caracteres (Strings)
  • Numeric strings
  • Arrays
  • Iterables
  • Objetos
  • Recursos
  • NULO
  • Llamadas de retorno (Callbacks / Callables)
  • Type declarations
  • Manipulación de tipos


Introducción

PHP admite diez tipos primitivos.

Cuatro tipos escalares:

  • boolean
  • integer
  • float (número de punto flotante, también conocido como double)
  • string

Cuatro tipos compuestos:

  • array
  • object
  • callable
  • iterable

Y finalmente dos tipos especiales:

  • resource
  • NULL

Puede que existan aún algunas referencias al tipo "double" en el manual. Considere al tipo double como float; los dos nombres existen sólo por razones históricas.

El tipo de una variable usualmente no lo declara el programador; al contrario, es decidido en tiempo de ejecución por PHP dependiendo del contexto en el que se emplea dicha variable.

Nota: Para comprobar el tipo y el valor de una expresión, utilice la función var_dump().

Para obtener una representación legible por humanos de un tipo con propósitos de depuración, use la función gettype(). Para comprobar un cierto tipo, no emplee gettype(), si no las funciones is_tipo. Algunos ejemplos:

<?php
$un_bool = TRUE;   // un valor booleano
$un_str  = "foo";  // una cadena de caracteres
$un_str2 = 'foo';  // una cadena de caracteres
$un_int  = 12;     // un número entero

echo gettype($un_bool); // imprime: boolean
echo gettype($un_str);  // imprime: string

// Si este valor es un entero, incrementarlo en cuatro
if (is_int($un_int)) {
    $un_int += 4;
}

// Si $un_bool es una cadena, imprimirla
// (no imprime nada)
if (is_string($un_bool)) {
    echo "Cadena: $un_bool";
}
?>

Para forzar la conversión de una variable a un cierto tipo, puede amoldar la variable o usar la función settype() con ella.

Observe que una variable puede ser evaluada con valores diferentes en ciertas situaciones, dependiendo del tipo que posea en cada momento. Para más información, lea la sección sobre Manipulación de tipos. Las tablas de comparación de tipos pueden resultar útiles también, ya que muestran ejemplos de varias comparaciones relacionadas con tipos.


Booleanos

Este es el tipo más simple. Un boolean expresa un valor que indica verdad. Puede ser true (verdadero) o false (falso).

Sintaxis

Para especificar un literal de tipo boolean se emplean las constantes true o false. Ambas no son susceptibles a mayúsculas y minúsculas.

<?php
$foo = True; // asigna el valor TRUE a $foo
?>

Usualmente, el resultado de un operador que devuelve un valor de tipo boolean es pasado a una estructura de control.

<?php
// == es un operador que comprueba la
// igualdad y devuelve un booleano
if ($accion == "mostrar_version") {
    echo "La versión es 1.23";
}

// esto no es necesario...
if ($mostrar_separadores == TRUE) {
    echo "<hr>\n";
}

// ...porque se puede escribir simplemente:
if ($mostrar_separadores) {
    echo "<hr>\n";
}
?>

Conversión a booleano

Para convertir explícitamente un valor al tipo boolean, use los amoldamientos (bool) o (boolean). Sin embargo, en la mayoría de casos es innecesario el amoldamiento, ya que un valor será convertido automáticamente si un operador, función o estructura de control requiere un argumento de tipo boolean.

Véase también la Manipulación de tipos.

Cuando se realizan conversiones a boolean, los siguientes valores se consideran false:

  • el boolean false mismo
  • el integer 0 y -0 (cero)
  • el float 0.0 y -0.0 (cero)
  • el valor string vacío, y el string "0"
  • un array con cero elementos
  • el tipo especial NULL (incluidas variables no establecidas)
  • objetos SimpleXML creados desde etiquetas vacías

Cualquier otro valor se considera como true (incluido cualquier resource y NAN).

Advertencia

-1 se considera true, como cualquier otro número distinto de cero (ya sea negativo o positivo).

<?php
var_dump((bool) "");        // bool(false)
var_dump((bool) 1);         // bool(true)
var_dump((bool) -2);        // bool(true)
var_dump((bool) "foo");     // bool(true)
var_dump((bool) 2.3e5);     // bool(true)
var_dump((bool) array(12)); // bool(true)
var_dump((bool) array());   // bool(false)
var_dump((bool) "false");   // bool(true)
?>


Números enteros (Integers)

Un número entero (o integer) es un número del conjunto Z = {..., -2, -1, 0, 1, 2, ...}.

Véase también:

  • Enteros de longitud arbitraria / GMP
  • Números de punto flotante
  • Precisión arbitraria / BCMath

Sintaxis

Los integer pueden especificarse mediante notación decimal (base 10), hexadecimal (base 16), octal (base 8) o binaria (base 2), opcionalmente precedidos por un signo (- o +).

Los literales de tipo integer binarios están disponibles desde PHP 5.4.0.

Para utilizar la notación octal, se antepone al número un 0 (cero). Para utilizar la notación hexadecimal, se antepone al número 0x. Para utilizar la notación binaria, se antepone al número 0b.

Ejemplo #1 Literales de números enteros

<?php
$a = 1234; // número decimal
$a = -123; // un número negativo
$a = 0123; // número octal (equivale a 83 decimal)
$a = 0x1A; // número hexadecimal (equivale a 26 decimal)
$a = 0b11111111; // número binario (equivale al 255 decimal)
?>

Formalmente, la estructura de los literales de tipo integer es:

decimal     : [1-9][0-9]*
            | 0

hexadecimal : 0[xX][0-9a-fA-F]+

octal       : 0[0-7]+

binario     : 0b[01]+

entero      : [+-]?decimal
            | [+-]?hexadecimal
            | [+-]?octal
            | [+-]?binario

El tamaño de un integer depende de la plataforma, aunque el valor usual es un valor máximo de aproximadamente dos mil millones (esto es, 32 bits con signo). Las plataformas de 64 bits normalmente tienen un valor máximo de aproximadamente 9E18, excepto en Windows antes de PHP 7, que siempre es de 32 bits. PHP no tiene soporte para el tipo integer sin signo. El tamaño de un integer se puede determinar mediante la constante PHP_INT_SIZE, y el valor máximo mediante la constante PHP_INT_MAX desde PHP 4.4.0 y PHP 5.0.5, y el valor mínimo mediante la constante PHP_INT_MIN desde PHP 7.0.0.

Advertencia

Antes de PHP 7, si a un integer octal se le proporcionaba un dígito no válido (esto es, 8 o 9), se ignoraba el resto del número. Desde PHP 7, se emite un error de análisis.

Desbordamiento de enteros

Si PHP encuentra un número fuera de los límites de un integer, se interpretará en su lugar como un valor de tipo float. También, una operación cuyo resultado sea un número fuera de los límites de un integer devolverá en su lugar un valor de tipo float.

Ejemplo #2 Desbordamiento de enteros en sistemas de 32 bit

<?php
$número_grande = 2147483647;
var_dump($número_grande);                    // int(2147483647)

$número_grande = 2147483648;
var_dump($número_grande);                    // float(2147483648)

$millón = 1000000;
$número_grande =  50000 * $millón;
var_dump($número_grande);                    // float(50000000000)
?>

Ejemplo #3 Desbordamiento de enteros en sistemas de 64 bit

<?php
$número_grande = 9223372036854775807;
var_dump($número_grande);                    // int(9223372036854775807)

$número_grande = 9223372036854775808;
var_dump($número_grande);                    // float(9.2233720368548E+18)

$millón = 1000000;
$número_grande =  50000000000000 * $millón;
var_dump($número_grande);                    // float(5.0E+19)
?>

No existe el operador de división de integer en PHP. 1/2 produce el float 0.5. El valor puede ser convertido a un integer redondeándolo a cero, o mediante la función round() que permite un mayor control sobre el redondeo.

<?php
var_dump(25/7);         // float(3.5714285714286)
var_dump((int) (25/7)); // int(3)
var_dump(round(25/7));  // float(4)
?>

Conversión a números enteros

Para convertir explícitamente un valor al tipo integer se puede emplear tanto (int) como (integer). Sin embargo, la mayoría de las veces la conversión no es necesaria, ya que un valor es convertido de forma automática cuando un operador, función o estructura de control requiera un argumento de tipo integer. Un valor también puede ser convertido al tipo integer mediante la función intval().

Si un resource es convertido a un integer, el resultado será el número de recurso único asignado al resource por PHP durante la ejecución.

Consulte también la Manipulación de tipos.

Desde booleanos

false producirá 0 (cero), y true producirá 1 (uno).

Desde números de punto flotante

Cuando se convierte un float a un integer, el número será redondeado hacia cero.

Si el valor de tipo float esta por debajo de los límites de un integer (normalmente +/- 2.15e+9 = 2^31 en plataformas de 32 bits y +/- 9.22e+18 = 2^63 en plataformas de 64 bits distintas de Windows), el resultado es indefinido, debido a que float no tiene la precisión suficiente para ofrecer el resultado como un integer exacto. No se mostrará ninguna advertencia, ni siquiera un aviso, cuando esto ocurra.

Nota:

A partir de PHP 7.0.0,0, en lugar de ser indefinidos y dependientes de la plataforma, NaN e Infinity siempre serán cero al amoldarlos a integer.

Advertencia

Nunca se debe convertir una fracción desconocida a un integer, ya que a veces puede conducir a resultados inesperados.

<?php
echo (int) ( (0.1+0.7) * 10 ); // ¡muestra 7!
?>

Consulte también la advertencia sobre la precisión de float

Desde cadenas de caracteres

Consulte Conversión de string a números

Desde otros tipos

Precaución

El comportamiento de la conversión de integer a otros tipos es indefinido. No confíe en ningún comportamiento observado, ya que puede cambiar sin previo aviso.


Números de punto flotante

Los números de punto flotante (también conocidos como "de coma flotante" en español, y "floats" en inglés) pueden ser especificados usando cualquiera de las siguientes sintaxis:

<?php
$a = 1.234;
$b = 1.2e3;
$c = 7E-10;
$d = 1_234.567; // a partir de PHP 7.4.0
?>

Formalmente a partir de PHP 7.4.0 (anteriormente, no se permitían los guiones bajos):

LNUM          [0-9]+(_[0-9]+)*
DNUM          ([0-9]*(_[0-9]+)*[\.]{LNUM}) | ({LNUM}[\.][0-9]*(_[0-9]+)*)
EXPONENT_DNUM (({LNUM} | {DNUM}) [eE][+-]? {LNUM})

El tamaño de un 'float' depende de la plataforma, aunque un valor común consiste en un máximo de aproximadamente 1.8e308 con una precisión cercana a los 14 dígitos decimales (el formato de 64 bit del IEEE).

Advertencia

Precisión del punto flotante

Los números de punto flotante tienen una precisión limitada. Aunque depende del sistema, PHP típicamente utiliza el formato de doble precisión IEEE 754, el cual dará un error relativo máximo por aproximación del orden de 1.11e-16. Las operaciones aritméticas elementales no podrán generar grandes errores y, por supuesto, se han de considrar los errores por propagación al componer varias operaciones.

Adicionalmente, los numeros racionales que son representables exactamente como números de punto flotante en base 10, como 0.1 o 0.7, no tienen una representación exacta como números de punto flotante en base 2, que es la base empleada internamente, sin importar el tamaño de la mantisa. Por lo tanto, no se pueden convertir en sus equivalentes binarios internos sin una pequeña pérdida de precisión. Esto puede conducir a resultados confusos: Por ejemplo, floor((0.1+0.7)*10) usualmente devolverá 7 en lugar del 8 previsto, ya que la representación interna será algo así como 7.9999999999999991118....

Por tanto, nunca se ha de confiar en resultados de números flotantes hasta el último dígito, y no comparar la igualdad de números de punto flotante directamente. Si fuera necesaria una mayor precisión, están disponibles las funciones matemáticas de precisión arbitraria y las funciones de gmp.

Para una explicación "simple", véase la » guía del punto flotante que también se titula "¿Por qué no sale la cuenta?"

Conversión al tipo float

Para más información sobre las conversiones de string a float, véase la Conversión de cadenas a números. Para valores de otros tipos, la conversión es la misma que si el valor hubiese sido convertido primero a integer y luego a float. Véase la Conversión a al tipo integer para más información. A partir de PHP 5, se genera un aviso si se intenta convertir un object a float.

Comparación del tipo float

Como se indica en la advertencia anterior, comprobar la igualdad de valores de punto flotante es problemático debido a la forma en que se representan internamente. Sin embargo, hay maneras de hacer comparaciones de los valores de punto flotante que evitan estas limitaciones.

Para comprobar la igualdad de valores de punto flotante, se utiliza un límite superior en el error relativo debido al redondeo. Este valor se conoce como el épsilon de la máquina o unidad de redondeo, y es la menor diferencia aceptable en los cálculos.

$a y $b son iguales en 5 dígitos de precisión.

<?php
$a = 1.23456789;
$b = 1.23456780;
$épsilon = 0.00001;

if(abs($a-$b) < $épsilon) {
    echo "true";
}
?>

NaN

Algunas operaciones numéricas pueden resultar en un valor representado por la constante NAN. Este resultado representa un valor no definido o no representable mediante cálculos de punto flotante. Cualquier comparación, ya sea estricta o no, de este valor con cualquier otro valor, incluido él mismo, pero excepto true, tendrá un resultado de false.

Ya que NAN representa cualquier número de diferentes valores, NAN no debería compararse con otros valores, incluido él mismo; en su lugar debería comprobarse usando la función is_nan().


Cadenas de caracteres (Strings)

Un string, o cadena, es una serie de caracteres donde cada carácter es lo mismo que un byte. Esto significa que PHP solo admite un conjunto de 256 caracteres, y de ahí que no ofrezca soporte nativo para Unicode. Véanse los detalles del tipo string.

Nota: Un string puede llegar a alcanzar hasta 2 GB de tamaño (2147483647 bytes máximo).

Sintaxis

Un literal de tipo string se puede especificar de cuatro formas diferentes:

  • entrecomillado simple
  • entrecomillado doble
  • sintaxis heredoc
  • sintaxis nowdoc (desde PHP 5.3.0)

Entrecomillado simple

La manera más sencilla de especificar un string es delimitarlo con comillas simples (el carácter ').

Para especificar una comilla simple literal, se ha de escapar con una barra invertida (\). Para especificar una barra invertida literal, se duplica (\\). Todas las demás instancias de barras invertidas serán tratadas como una barra invertida literal: esto significa que otras secuencias de escape que podrían utilizarse, tales como \r o \n, serán mostradas literalmente tal y como se especifican, en lugar de tener cualquier otro significado especial.

Nota: A diferencia de las sintaxis de entrecomillado doble y heredoc, las variables y las sentencias de escape para caracteres especiales no se expandirán cuando estén incluidas dentro de un string entre comillas simples.

<?php
echo 'Esto es una cadena sencilla';

echo 'También se pueden incluir nuevas líneas en
un string de esta forma, ya que es
correcto hacerlo así';

// Resultado: Arnold una vez dijo: "I'll be back"
echo 'Arnold una vez dijo: "I\'ll be back"';

// Resultado: Ha borrado C:\*.*?
echo 'Ha borrado C:\\*.*?';

// Resultado: Ha borrado C:\*.*?
echo 'Ha borrado C:\*.*?';

// Resultado: Esto no se expandirá: \n una nueva línea
echo 'Esto no se expandirá: \n una nueva línea';

// Resultado: Las variables $tampoco se $expandirán
echo 'Las variables $tampoco se $expandirán';
?>

Entrecomillado doble

Si un string está delimitado con comillas dobles ("), PHP interpretará las siguientes secuencias de escape como caracteres especiales:

Caracteres escapados
Secuencia | Significado
\n | avance de línea (LF o 0x0A (10) en ASCII)
\r | retorno de carro (CR o 0x0D (13) en ASCII)
\t | tabulador horizontal (HT o 0x09 (9) en ASCII)
\v | tabulador vertical (VT o 0x0B (11) en ASCII) (desde PHP 5.2.5)
\e | escape (ESC o 0x1B (27) en ASCII) (desde PHP 5.4.4)
\f | avance de página (FF o 0x0C (12) en ASCII) (desde PHP 5.2.5)
\\ | barra invertida
\$ | signo de dólar
\" | comillas dobles
\[0-7]{1,3} | la secuencia de caracteres que coincida con la expresión regular es un carácter en notación octal, que silenciosamente desborda para encajar en un byte (p.ej. "\400" === "\000")
\x[0-9A-Fa-f]{1,2} | la secuencia de caracteres que coincida con la expresión regular es un carácter en notación hexadecimal
\u{[0-9A-Fa-f]+} | la secuencia de caracteres que coincida con la expresión regular es un punto de código de Unicode, la cual será imprimida al string como dicha representación UTF-8 del punto de código (añadido en PHP 7.0.0)

Al igual que en el entrecomillado simple de un string, escapar cualquier otro carácter puede dar lugar a que se muestre también la barra invertida. Antes de PHP 5.1.1, no se mostraba la barra invertida de \{$var}.

La característica más importante del entrecomillado doble de un string es el hecho de que se expanden los nombres de las variables. Consulte el análisis de string para más detalles.

Heredoc

Una tercera forma de delimitar un string es mediante la sintaxis heredoc: <<<. Después de este operador, se deberá proporcionar un identificador y justo después una nueva línea. A continuación va el propio string, y para cerrar la notación se pone el mismo identificador.

El identificador de cierre debe empezar en la primera columna de la nueva línea. Asimismo, el identificador debe seguir las mismas reglas de nomenclatura de las etiquetas en PHP: debe contener solo caracteres alfanuméricos y guiones bajos, y debe empezar con un carácter alfabético o un guión bajo.

Advertencia

Es muy importante señalar que la línea con el identificador de cierre no debe contener ningún otro carácter, excepto un punto y coma (;). Esto, en especial, significa que el identificador no debe estar sangrado, y que no debe existir ningún espacio ni tabulación antes o después del punto y coma. Es muy importante observar que el primer carácter antes del identificador de cierre debe ser un salto de línea definido por el sistema operativo local. Este es \n en los sistemas UNIX, incluyendo Mac OS X. Al delimitador de cierre le ha de seguir tambíen una nueva línea.

Si se rompe esta regla y el identificador de cierre no está "limpio", no será considerado como un identificador de cierre, por lo que PHP continuará buscando uno. Si no se encuentra ningún identificador de cierre apropiado antes del final del fichero, se producirá un error de análisis en la última línea.

No se puede emplear Heredoc para inicializar las propiedades de una clase. Desde PHP 5.3, esta limitación es válida solamente para un heredoc que contengan variables.

Ejemplo #1 Ejemplo no válido

<?php
class foo {
    public $bar = <<<EOT
bar
    EOT;
}
?>

El texto heredoc se comporta como un string entre comillas dobles, pero sin tener comillas dobles. Esto significa que no es necesario escapar las comillas en un heredoc, aunque se puede seguir empleando los códigos de escape indicados arriba. Pese a que las variables son expandidas, se debe tener el mismo cuidado al expresar variables complejas en un heredoc que en un string.

Ejemplo #2 Ejemplo de entrecomillado de string en Heredoc

<?php
$str = <<<EOD
Ejemplo de una cadena
expandida en varias líneas
empleando la sintaxis heredoc.
EOD;

/* Un ejemplo más complejo con variables. */
class foo
{
    var $foo;
    var $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$nombre = 'MiNombre';

echo <<<EOT
Mi nombre es "$nombre". Estoy escribiendo un poco de $foo->foo.
Ahora, estoy escribiendo un poco de {$foo->bar[1]}.
Esto debería mostrar una 'A' mayúscula: \x41
EOT;
?>

El resultado del ejemplo sería:

Mi nombre es "MiNombre". Estoy escribiendo un poco de Foo.
Ahora, estoy escribiendo un poco de Bar2.
Esto debería mostrar una 'A' mayúscula: A

También se puede emplear la sintaxis Heredoc para pasar datos como argumentos de una función:

Ejemplo #3 Ejemplo de Heredoc en argumentos

<?php
var_dump(array(<<<EOD
foobar!
EOD
));
?>

Desde PHP 5.3.0, es posible inicializar variables estáticas y propiedades/constantes de clase mediante la sintaxis Heredoc:

Ejemplo #4 Usar Heredoc para inicializar valores estáticos

<?php
// Variables estáticas
function foo()
{
    static $bar = <<<LABEL
Nada aquí...
LABEL;
}

// Propiedades/constantes de clase
class foo
{
    const BAR = <<<FOOBAR
Ejemplo de constante
FOOBAR;

    public $baz = <<<FOOBAR
Ejemplo de propiedad
FOOBAR;
}
?>

PHP 5.3.0 también introdujo la posibilidad de entrecomillar el identificador de apertura en Heredoc:

Ejemplo #5 Emplear comillas dobles en Heredoc

<?php
echo <<<"FOOBAR"
¡Hola Mundo!
FOOBAR;
?>

Nowdoc

Nowdoc es a los string con comillas simples lo mismo que Heredoc lo es a los string con comillas dobles. Un nowdoc se especifica de forma análoga a un heredoc, pero no se realiza ningún análisis dentro del nowdoc. La construcción es ideal para embeber código de PHP o grandes fragmentos de texto sin necesidad de escaparlos. Comparte algunas características comunes con la construcción <![CDATA[ ]]> de SGML, donde se declara un bloque de texto que no se analiza.

Un nowdoc se identifica con la misma secuencia empleada para heredoc, <<<, pero el identificador que le sigue está delimitado con comillas simples, p.ej., <<<'EOT'. Todas las reglas para los identificadores de heredoc también son aplicables a los identificadores de nowdoc, especialmente aquellas que se refieren al empleo del identificador de cierre.

Ejemplo #6 Ejemplo de entrecomillado de string de Nowdoc

<?php
$str = <<<'EOD'
Ejemplo de un string
expandido en varias líneas
empleando la sintaxis nowdoc.
EOD;

/* Un ejemplo más complejo con variables. */
class foo
{
    public $foo;
    public $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$nombre = 'MiNombre';

echo <<<'EOT'
Mi nombre es "$nombre". Estoy escribiendo un poco de $foo->foo.
Ahora, estoy escribiendo un poco de {$foo->bar[1]}.
Esto debería mostrar una 'A' mayúscula: \x41
EOT;
?>

El resultado del ejemplo sería:

Mi nombre es "$nombre". Estoy escribiendo un poco de $foo->foo.
Ahora, estoy escribiendo un poco de {$foo->bar[1]}.
Esto debería mostrar una 'A' mayúscula: \x41

Ejemplo #7 Ejemplo de datos estáticos

<?php
class foo {
    public $bar = <<<'EOT'
bar
EOT;
}
?>

Nota:

El soporte para Nowdoc se añadió en PHP 5.3.0.

Análisis de variables

Cuando un string es especificado mediante comillas dobles o mediante heredoc, las variables que haya dentro de dicho string se analizarán.

Existen dos tipos de sintaxis: una simple y otra compleja. La sintaxis simple es la más empleada y práctica. Proporciona una forma de embeber una variable, un valor de un array o una propiedad de un object dentro de un string con el mínimo esfuerzo.

La sintaxis compleja puede ser reconocida por las llaves que delimitan la expresión.

Sintaxis simple

Si se encuentra un signo de dólar ($), el analizador tomará el mayor número de símbolos para formar un nombre de variable válido. Delimitar el nombre de la variable con llaves permite especificar explícitamente el final del nombre.

<?php
$jugo = "manzana";

echo "Él tomó algo de jugo de $jugo.".PHP_EOL;
// Inválido. "s" es un carácter válido para un nombre de variable, pero la variable es $jugo.
echo "Él tomó algo de jugo hecho de $jugos.";
// Válido. Explícitamente especifica el final del nombre de la variable encerrándolo entre llaves:
echo "Él tomó algo de jugo hecho de ${jugo}s."
?>

El resultado del ejemplo sería:

Él tomó algo de jugo de manzana.
Él tomó algo de jugo hecho de .
Él tomó algo de jugo hecho de manzanas.

De forma parecida, se puede analizar el índice de un array o la propiedad de un object. Con los índices de los arrays, el corchete de cierre (]) marca el final del índice. La misma regla se puede aplicar a las propiedades de los objetos y a las variables simples.

Ejemplo #8 Ejemplo de sintaxis simple

<?php
$jugos = array("manzana", "naranja", "koolaid1" => "púrpura");

echo "Él tomó algo de jugo de $jugos[0].".PHP_EOL;
echo "Él tomó algo de jugo de $jugos[1].".PHP_EOL;
echo "Él tomó algo de jugo $jugos[koolaid1].".PHP_EOL;

class persona {
    public $john = "John Smith";
    public $jane = "Jane Smith";
    public $robert = "Robert Paulsen";

    public $smith = "Smith";
}

$persona = new persona();

echo "$persona->john tomó algo de jugo de $jugos[0].".PHP_EOL;
echo "$persona->john entonces dijo hola a $persona->jane.".PHP_EOL;
echo "La esposa de $persona->john saludó a $persona->robert.".PHP_EOL;
echo "$persona->robert saludó a los dos $persona->smiths."; // No funcionará
?>

El resultado del ejemplo sería:

Él tomó algo de jugo de manzana.
Él tomó algo de jugo de naranja.
Él tomó algo de jugo púrpura.
John Smith tomó algo de jugo de manzana.
John Smith entonces dijo hola a Jane Smith.
La esposa de John Smith saludó a Robert Paulsen.
Robert Paulsen saludó a los dos .

Para casos más complejos se debe emplear la sintaxis compleja.

Sintaxis compleja (llaves)

Esta sintaxis no se llama compleja porque sea compleja, sino porque permite el empleo de expresiones complejas.

Cualquier variable escalar, elemento de array o propiedad de objeto con una representación de tipo string puede ser incluido a través de esta sintaxis. Simplemente se escribe la expresión del mismo modo en que aparecería por fuera del string, y delimitándola con { y }. Dado que { no puede ser escapado, esta sintaxis será reconocida únicamente cuando el $ siga inmediatamente al {. Utilice {\$ para obtener un {$ literal. Algunos ejemplos para que quede más claro:

<?php
// Mostrar todos los errores
error_reporting(E_ALL);

$genial = 'fantástico';

// No funciona, muestra: Esto es { fantástico}
echo "Esto es { $genial}";

// Funciona, muestra: Esto es fantástico
echo "Esto es {$genial}";

// Funciona
echo "Este cuadrado tiene {$cuadrado->width}00 centímetros de lado.";

// Funciona, las claves entre comillas sólo funcionan usando la sintaxis de llaves
echo "Esto funciona: {$arr['clave']}";

// Funciona
echo "Esto funciona: {$arr[4][3]}";

// Esto no funciona por la misma razón que $foo[bar] es incorrecto fuera de un string.
// En otras palabras, aún funcionaría, pero solamente porque PHP primero busca una
// constante llamada foo; se emitirá un error de nivel E_NOTICE
// (constante no definida).
echo "Esto está mal: {$arr[foo][3]}";

// Funciona. Cuando se usan arrays multidimensionales, emplee siempre llaves que delimiten
// a los arrays cuando se encuentre dentro de un string
echo "Esto funciona: {$arr['foo'][3]}";

// Funciona.
echo "Esto funciona: " . $arr['foo'][3];

echo "Esto también funciona: {$obj->valores[3]->nombre}";

echo "Este es el valor de la variable llamada $nombre: {${$nombre}}";

echo "Este es el valor de la variable llamada por el valor devuelto por getNombre(): {${getNombre()}}";

echo "Este es el valor de la variable llamada por el valor devuelto por \$objeto->getNombre(): {${$objeto->getNombre()}}";

//No funciona, muestra: Esto es el valor devuelto por getNombre(): {getNombre()}
echo "Esto es el valor devuelto por getNombre(): {getNombre()}";
?>

Con esta sintaxis, también es posible acceder a las propiedades de una clase empleando variables dentro de un string.

<?php
class foo {
    var $bar = 'Soy bar.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo "{$foo->$bar}\n";
echo "{$foo->{$baz[1]}}\n";
?>

El resultado del ejemplo sería:

Soy bar.
Soy bar.

Nota:

Las funciones, llamadas a métodos, variables de clase estáticas y constantes de clases dentro de {$} funcionan desde PHP 5. Sin embargo, el valor accedido puede ser interpretado como el nombre de la variable en el ámbito en el que está definido el string. El empleo de simples llaves ({}) no servirá para acceder al valor devuelto por las funciones o métodos, o los valores de las constantes de clase o variables de clase estáticas.

<?php
// Mostrar todos los errores.
error_reporting(E_ALL);

class cervezas {
    const refresco = 'zarzaparrilla';
    public static $ale = 'ipa';
}

$zarzaparrilla = 'A & W';
$ipa = 'Alexander Keith\'s';

// Funciona; muestra: Me gusta una A & W
echo "Me gusta una {${cervezas::refresco}}\n";

// También funciona; muestra: Me gusta una Alexander Keith's
echo "Me gusta una {${cervezas::$ale}}\n";
?>

Acceso a string y modificacion por caracteres

Se puede acceder y modificar los caracteres dentro de un string especificando el índice de base cero del carácter deseado después del string empleando los corchetes de array, como en $str[42]. Piense en un string como un array de caracteres, en este caso. Las funciones substr() y substr_replace() pueden ser empleadas para extraer o reemplazar más de un carácter.

Nota: También se puede acceder a un string utilizando llaves, como en $str{42}, con el mismo propósito.

Advertencia

Escribir en un índice fuera del rango rellenará el string con espacios. Los tipos que no sean integer son convertidos a integer. Los índices ilegales emiten un error de nivel E_NOTICE. Los índices negativos emiten un error de nivel E_NOTICE en la escritura, aunque se lea un string vacío. Sólo se emplea el primer carácter de un string asignado. La asignación de un string vacío asigna un byte NULL.

Advertencia

Internamente, los string de PHP son arrays de bytes. Por tanto, acceder o modificar un string utilizando los corchetes de array no es seguro con caracteres multibyte, dado que sólo se realiza con los string de codificaciones monobyte, como ISO-8859-1.

Ejemplo #9 Algunos ejemplos de string

<?php
// Obtener el primer carácter de un string
$str = 'Esto es una prueba.';
$primero = $str[0];

// Obtener el tercer carácter de un string
$tercero = $str[2];

// Obtener el último carácter de un string
$str = 'Esto sigue siendo una prueba.';
$último = $str[strlen($str)-1];

// Modificar el último carácter de un string
$str = 'Mira el mar';
$str[strlen($str)-1] = 'l';

?>

A partir de PHP 5.4, los índices de string tienen que ser de tipo integer o integer en forma de string, si no, se emitirá una advertencia. Anteriormente, un índice como "foo" era convertido de manera silenciosa a 0.

Ejemplo #10 Diferencias entre PHP 5.3 y PHP 5.4

<?php
$str = 'abc';

var_dump($str['1']);
var_dump(isset($str['1']));

var_dump($str['1.0']);
var_dump(isset($str['1.0']));

var_dump($str['x']);
var_dump(isset($str['x']));

var_dump($str['1x']);
var_dump(isset($str['1x']));
?>

Salida del ejemplo anterior en PHP 5.3:

string(1) "b"
bool(true)
string(1) "b"
bool(true)
string(1) "a"
bool(true)
string(1) "b"
bool(true)

Salida del ejemplo anterior en PHP 5.4:

string(1) "b"
bool(true)

Warning: Illegal string offset '1.0' in /tmp/t.php on line 7
string(1) "b"
bool(false)

Warning: Illegal string offset 'x' in /tmp/t.php on line 9
string(1) "a"
bool(false)
string(1) "b"
bool(false)

Nota:

El acceso a variables de otros tipos (sin incluir arrays u objetos que implementen las interfaces apropiadas) utilizando [] o {}, silenciosamente retorna null.

Nota:

PHP 5.5 añadió soporte para acceder a caracteres dentro de literales de tipo string utilizando [] o {}.

Funciones y operadores útiles

Los string pueden ser concatenados empleando el operador '.' (punto). Fíjese que el operador '+' (suma) no servirá para concatenar. Consulte los operadores de string para más información.

Hay una serie de funciones útiles para la manipulación de string.

Consulte la sección de funciones de string para funciones generales, y las funciones de expresiones regulares o las funciones de expresiones regulares compatibles con Perl para características avanzadas de búsqueda y sustitución.

También existen funciones para string de URL, y funciones para encriptar/desencriptar string (mcrypt y mhash).

Finalmente, también existen las funciones para el tipo carácter.

Conversión a string

Un valor puede convertirse a un string empleando el molde (string) o mediante la función strval(). La conversión automática a string tiene lugar en el ámbito de una expresión donde sea necesario un string. Esto ocurre cuando se utilizan las funciones echo o print, o cuando se compara una variable con un string. Las secciones sobre Tipos y Manipulación de tipos lo aclararán. Consulte también la función settype().

El valor true del tipo boolean es convertido al string "1". El valor false del tipo boolean es convertido al string "" (el string vacío). Esto permite la conversión en ambos sentidos entre los valores de los tipos boolean y string.

Un integer o float es convertido a un string que representa textualmente el número (incluyendo la parte exponencial para los float. Los números de punto flotante pueden ser convertidos mediante la notación exponencial (4.1E+6).

Nota:

El carácter para el punto decimal se define en el localismo del script (categoría LC_NUMERIC). Consulte la función setlocale().

Los arrays siempre son convertidos al string "Array". Debido a esto, echo y print no pueden por sí mismos mostrar el contenido de un array. Para ver un único elemento individualmente, utilice una construcción como echo $arr['foo']. Vea los consejos de más abajo para mostrar el contenido completo.

Los object en PHP 4 siempre son convertidos al string "Object". Para mostrar los valores de las propiedades de un objeto para su depuración, lea los párrafos siguientes. Para obtener el nombre de la clase de un objeto, emplee la función get_class(). A partir de PHP 5, se puede emplear el método __toString cuando sea relevante.

Un resource siempre es convertido a string con la estructura "Resource id #1", donde 1 es el número de recurso asignado al resource por PHP durante la ejecución. A pesar de que no se debe depender de la estructura exacta, debido a que está sujeta a cambios, siempre será única para un recurso dado dentro del tiempo de vida de un script en ejecución (es decir, una petición web o proceso CLI), por lo que no será reutilizada. Para obtener el tipo de un resource, emplee la función get_resource_type().

null siempre es convertido a un string vacío.

Como se indicó anteriormente, la conversión directa de un array, object o resource a un string no proporciona información útil acerca del valor más allá de su tipo. Consulte las funciones print_r() y var_dump() para ver medios más efectivos de inspeccionar el contenido de estos tipos.

La mayoría de los valores de PHP pueden ser convertidos a un string para su almacenamiento permanente. Este método se denomina serialización, y es realizado mediante la función serialize(). Si el motor de PHP se construyó con soporte para WDDX, los valores de PHP también pueden ser serializacos como texto XML bien formado.

Conversión de string a números

Cuando un string es evaluado en un contexto numérico, el valor resultante y el tipo se determina como se explica a continuación.

Si el string no contiene ninguno de los caracteres '.', 'e', o 'E', y el valor numérico está entre los límites del tipo integer (tal como está definido por PHP_INT_MAX), el string será evaluado como un integer. En todos los demás casos será evaluado como un float.

El valor es dado por la parte inicial del string. Si el string empieza con un dato numérico válido, éste será el valor empleado. De lo contrario, el valor será 0 (cero). Un dato numérico válido es un signo opcional, seguido de uno o más dígitos (opcionalmente puede contener un punto decimal), seguido de un exponente opcional. El exponente es una 'e' o 'E' seguida de uno o más dígitos.

<?php
$foo = 1 + "10.5";                   // $foo es float (11.5)
$foo = 1 + "-1.3e3";                 // $foo es float (-1299)
$foo = 1 + "bob-1.3e3";              // $foo es integer (1)
$foo = 1 + "bob3";                   // $foo es integer (1)
$foo = 1 + "10 pequeños cerdos";     // $foo es integer (11)
$foo = 4 + "10.2 pequeños cerditos"; // $foo es float (14.2)
$foo = "10.0 cerdos " + 1;           // $foo es float (11)
$foo = "10.0 cerdos " + 1.0;         // $foo es float (11)
?>

Para más información sobre esta conversión, consulte la página del manual de Unix para a strtod(3).

Para probar cualesquiera de los ejemplos de esta sección, copie y péguelos e incluya la siguiente línea para ver lo que está sucediendo:

<?php
echo "\$foo==$foo; tipo : " . gettype ($foo) . "<br />\n";
?>

No espere obtener el código de un carácter convirtiéndolo a un integer, como ocurre en C. Emplee las funciones ord() y chr() para convertir entre código códigos ASCII y caracteres.

Detalles del tipo string

En PHP, los string se implementan como un array de bytes y con un número entero que indica la longitud del búfer. No posee ninguna información sobre cómo traducir esos bytes a caracteres, relegando esa tarea al programador. No existe ninguna limitación sobre los valores que pueden componer un string; en concreto, está permitido colocar bytes con valor 0 (“bytes NUL”) en cualquier posición del string (aunque existen algunas funciones, citadas en este manual como “no seguras a nivel binario”, que podrían rechazar estos string para aquellas bibliotecas que ignoren los datos que siguen a un byte NUL.)

Este comportamiento del tipo string justifica que no exista un tipo de dato "byte" en PHP – los string se encargan de esto. Las funciones que no devuelven datos de texto – por ejemplo, cualquier dato leído a partir de un socket de red – devolverán valores de tipo string.

Dado que PHP no obliga a utilizar ninguna condificación en particular, uno podría preguntarse cómo se codifican los literales de tipo string. Por ejemplo, ¿es el string "á" equivalente a "\xE1" (ISO-8859-1), "\xC3\xA1" (UTF-8, forma C), "\x61\xCC\x81" (UTF-8, forma D) o cualquier otra representación posible? La respuesta es que un string será codificado en cualquiera forma en que estuviera codificado el fichero del script. Por tanto, si un script estuviera escrito en ISO-8859-1, el string se codificará en ISO-8859-1, etc. Sin embargo, esto no es aplicable si está habilitado Zend Multibyte; en ese caso, el script podría estar escrito en cualquier codificación (la cual es declarada explícitamente o es detectada) para después convertirse a una determinada codificación interna, que será entonces la codificación usada para los literales de tipo string. Tenga presente que existen algunas limitaciones sobre la codificación del script (o en la codificación interna, si Zend Multibyte estuviera habilitado); esto suele significar que dicha codificación debería ser compatible con un superconjunto de ASCII, tal como UTF-8 o ISO-8859-1. Por contra, las codificaciones dependientes del estado donde se pueden utilizar los mismos valores de byte en estados de desplazamiento iniciales y no iniciales, podrían generar problemas.

Por supuesto, para poder ser útiles, las funciones que operen con texto podrían partir de unos supuestos sobre cómo está codificado el string. Desafortunadamente, respecto a esto existen muchas variaciones en las funciones de PHP:

  • Algunas funciones asumen que el string está codificado con una codificación de un único byte, por lo que no es necesario interpretar estos bytes como caracteres específicos. Este es el caso de, por ejemplo, substr(), strpos(), strlen() o strcmp(). Otra forma de entender estas funciones es pensando que operan sobre búferes de memoria, es decir, trabajan con bytes y con índices de bytes.
  • A otras funciones se les proporciona la codificación del string, si bien es posible que asuman una codificación predeterminada si no se proporciona ninguna. Este es el caso de htmlentities() y la mayoría de funciones de la extensión mbstring.
  • Otras utilizan el localismo en uso (véase setlocale()), pero operan byte a byte. Este es el caso de strcasecmp(), strtoupper() y ucfirst(). Esto significa que sólo se pueden usar con codificaciones de un byte, siempre y cuando la codificación coincida con la del localismo. Por ejemplo, strtoupper("á") podría devolver "Á" si el localismo está correctamente establecido y á está codificado con un único byte. Si está codificado en UTF-8, no se devolverá un resultado correcto, y el string resultante podría devolverse corrupto, en función del localismo en uso.
  • Por último, las funciones podrán también asumir que se utiliza una codificación en particular, usualmente UTF-8. Este es el caso de la mayoría de las funciones de la extensión intl y de la extensión PCRE (en este último caso, sólo cuando se utiliza el modificador u). Debido a su propósito especial, la función utf8_decode() asume una codificación UTF-8, mientras que la función utf8_encode() asume una codificación ISO-8859-1.

En resumen, para escribir programas de forma correcta usando Unicode hay que evitar cuidadosamente las funciones que puedan fallar y que muy probablemente corrompan los datos, y utilizar en su lugar las funciones que se comporten de forma correcta, generalmente las de las extensiones intl y mbstring. Sin embargo, el uso de funciones que pueden manejar codificaciones Unicode es sólo el principio. No importa qué funciones incorpore el lenguaje; es primordial conocer la especificación Unicode. Por ejemplo, un programa que asuma que sólo hay mayúsculas y minúsculas estará haciendo una suposición errónea.


Numeric strings

A PHP string is considered numeric if it can be interpreted as an int or a float.

Formally as of PHP 8.0.0:

WHITESPACES      \s*
LNUM             [0-9]+
DNUM             ([0-9]*)[\.]{LNUM}) | ({LNUM}[\.][0-9]*)
EXPONENT_DNUM    (({LNUM} | {DNUM}) [eE][+-]? {LNUM})
INT_NUM_STRING   {WHITESPACES} [+-]? {LNUM} {WHITESPACES}
FLOAT_NUM_STRING {WHITESPACES} [+-]? ({DNUM} | {EXPONENT_DNUM}) {WHITESPACES}
NUM_STRING       ({INT_NUM_STRING} | {FLOAT_NUM_STRING})

PHP also has a concept of leading numeric strings. This is simply a string which starts like a numeric string followed by any characters.

Strings used in numeric contexts

When a string needs to be evaluated as number (e.g. arithmetic operations, int type declaration, etc.) the following steps are taken to determine the outcome:

  1. If the string is numeric, resolve to an int if the string is an integer numeric string and fits into the limits of the int type limits (as defined by PHP_INT_MAX), otherwise resolve to a float.
  2. If the context allows leading numeric strings and the string is one, resolve to an int if the leading part of the string is an integer numeric string and fits into the limits of the int type limits (as defined by PHP_INT_MAX), otherwise resolve to a float. Additionally an error of level E_WARNING is raised.
  3. The string is not numeric, throw a TypeError.

Behavior prior to PHP 8.0.0

Prior to PHP 8.0.0, a string was considered numeric only if it had leading whitespaces, if it had trailing whitespaces then the string was considered to be leading numeric.

Prior to PHP 8.0.0, when a string was used in a numeric context it would perform the same steps as above with the following differences:

  • The usage of a leading numeric string would raise an E_NOTICE instead of an E_WARNING.
  • If the string is not numeric, an E_WARNING was raised and the value 0 would be returned.

<?php
$foo = 1 + "10.5";                // $foo is float (11.5)
$foo = 1 + "-1.3e3";              // $foo is float (-1299)
$foo = 1 + "bob-1.3e3";           // TypeError as of PHP 8.0.0, $foo is integer (1) previously
$foo = 1 + "bob3";                // TypeError as of PHP 8.0.0, $foo is integer (1) previously
$foo = 1 + "10 Small Pigs";       // $foo is integer (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = 4 + "10.2 Little Piggies"; // $foo is float (14.2) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = "10.0 pigs " + 1;          // $foo is float (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = "10.0 pigs " + 1.0;        // $foo is float (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
?>


Arrays

Un array en PHP es en realidad un mapa ordenado. Un mapa es un tipo de datos que asocia valores con claves. Este tipo se optimiza para varios usos diferentes; se puede emplear como un array, lista (vector), tabla asociativa (tabla hash - una implementación de un mapa), diccionario, colección, pila, cola, y posiblemente más. Ya que los valores de un array pueden ser otros arrays, también son posibles árboles y arrays multidimensionales.

Una explicación sobre tales estructuras de datos está fuera del alcance de este manual, aunque se proporciona al menos un ejemplo de cada uno de ellos. Para más información, consulte la extensa literatura que existe sobre este amplio tema.

Sintaxis

Especificación con array()

Un array puede ser creado con el constructor del lenguaje array(). Éste toma cualquier número de parejas clave => valor como argumentos.

    array(
    clave  => valor,
    clave2 => valor2,
    clave3 => valor3,
    ...
    )

La coma después del último elemento del array es opcional, pudiéndose omitir. Esto normalmente se hace para arrays de una única línea, es decir, es preferible array(1, 2) que array(1, 2, ). Por otra parte, para arrays multilínea, la coma final se usa frecuentemente, ya que permite una adición más sencilla de nuevos elementos al final.

A partir de PHP 5.4 también se puede usar la sintaxis de array corta, la cual reemplaza array() con [].

Ejemplo #1 Un array simple

<?php
$array = array(
    "foo" => "bar",
    "bar" => "foo",
);

// a partir de PHP 5.4
$array = [
    "foo" => "bar",
    "bar" => "foo",
];
?>

La clave puede ser un integer o un string. El valor puede ser de cualquier tipo.

Además, se darán los siguientes amoldamientos de clave:

  • Strings que contiene un decimal válido integer, a menos que el número esté precedido por un signo +, será amoldado al tipo integer. Por ejemplo, la llave "8" será en realidad almacenado como 8. Por otro lado "08" no será moldeado, ya que no es un entero decimal válido.
  • Un floats también será amoldado a integer, lo que significa que la parte fraccionaria se elimina. P.ej., la clave 8.7 en realidad será almacenada como 8.
  • Un booleano son amoldados a integers también, es decir, la clave true en realidad será almacenada como 1 y la clave false como 0.
  • Un null será amoldado a un string vacío, es decir, la clave null en realidad será almacenada como "".
  • Los arrays y los objects no pueden utilizarse como claves. Si se hace, dará lugar a una advertencia: Illegal offset type.

Si varios elementos en la declaración del array usan la misma clave, sólo se utilizará la última, siendo los demás sobrescritos.

Ejemplo #2 Ejemplo de amoldamiento de tipo y sobrescritura

<?php
$array = array(
    1    => "a",
    "1"  => "b",
    1.5  => "c",
    true => "d",
);
var_dump($array);
?>

El resultado del ejemplo sería:

array(1) {
  [1]=>
  string(1) "d"
}

Como todas las claves en el ejemplo anterior se convierten en 1, los valores serán sobrescritos en cada nuevo elemento, por lo que el último valor asignado "d" es el único que queda.

Los arrays de PHP pueden contener claves integer y string al mismo tiempo ya que PHP no distingue entre arrays indexados y asociativos.

Ejemplo #3 Claves mixtas integer y string

<?php
$array = array(
    "foo" => "bar",
    "bar" => "foo",
    100   => -100,
    -100  => 100,
);
var_dump($array);
?>

El resultado del ejemplo sería:

array(4) {
  ["foo"]=>
  string(3) "bar"
  ["bar"]=>
  string(3) "foo"
  [100]=>
  int(-100)
  [-100]=>
  int(100)
}

La clave es opcional. Si no se especifica, PHP usará el incremento de la clave de tipo integer mayor utilizada anteriormente.

Ejemplo #4 Arrays indexados sin clave

<?php
$array = array("foo", "bar", "hello", "world");
var_dump($array);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(3) "foo"
  [1]=>
  string(3) "bar"
  [2]=>
  string(5) "hello"
  [3]=>
  string(5) "world"
}

Es posible especificar la clave sólo para algunos elementos y excluir a los demás:

Ejemplo #5 Claves no en todos los elementos

<?php
$array = array(
         "a",
         "b",
    6 => "c",
         "d",
);
var_dump($array);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [6]=>
  string(1) "c"
  [7]=>
  string(1) "d"
}

Como se puede ver, al último valor "d" se le asignó la clave 7. Esto es debido a que la mayor clave integer anterior era 6.

Acceso a elementos de array con la sintaxis de corchete

Los elementos de array se pueden acceder utilizando la sintaxis array[key].

Ejemplo #6 Acceso a elementos de un array

<?php
$array = array(
    "foo" => "bar",
    42    => 24,
    "multi" => array(
         "dimensional" => array(
             "array" => "foo"
         )
    )
);

var_dump($array["foo"]);
var_dump($array[42]);
var_dump($array["multi"]["dimensional"]["array"]);
?>

El resultado del ejemplo sería:

string(3) "bar"
int(24)
string(3) "foo"

Nota:

Tanto los corchetes como las llaves pueden ser utilizados de forma intercambiable para acceder a los elementos de un array (p.ej.: $array[42] y $array{42} tendrán el mismo resultado en el ejemplo anterior).

A partir de PHP 5.4 es posible hacer referencia al array del resultado de una llamada a una función o método directamente. Antes sólo era posible utilizando una variable temporal.

Desde PHP 5.5 es posible hacer referencia directa un elemento de un array literal.

Ejemplo #7 Hacer referencia al resultado array de funciones

<?php
function getArray() {
    return array(1, 2, 3);
}

// en PHP 5.4
$secondElement = getArray()[1];

// anteriormente
$tmp = getArray();
$secondElement = $tmp[1];

// o
list(, $secondElement) = getArray();
?>

Nota:

Intentar acceder a una clave de un array que no se ha definido es lo mismo que el acceder a cualquier otra variable no definida: se emitirá un mensaje de error de nivel E_NOTICE, y el resultado será null.

Nota:

Array que dereferencia un valor escalar que no es un string silenciosamente arroja null, es decir, sin emitir un mensaje de error.

Creación/modificación con la sintaxis de corchete

Un array existente puede ser modificado estableciendo explícitamente valores en él.

Esto se realiza asignando valores al array, especificando la clave entre corchetes. Esta también se puede omitir, resultando en un par de corchetes vacíos ([]).

    $arr[clave] = valor;
    $arr[] = valor;
    // clave puede ser un integer o un string
    // valor puede ser cualquier valor de cualquier tipo

Si $arr aún no existe, se creará, siendo también esta forma una alternativa de crear un array. Sin embargo, se desaconsejada esta práctica porque que si $arr ya contiene algún valor (p.ej. un string de una variable de petición), este estará en su lugar y [] puede significar realmente el operador de acceso a strings. Siempre es mejor inicializar variables mediante una asignación directa.

Nota: A partir de PHP 7.1.0, la aplicación del operador de índice vacío en un string lanza un fatal error. Antes, el string se convertía silenciosamente en un array.

Para cambiar un valor determinado se debe asignar un nuevo valor a ese elemento empleando su clave. Para quitar una pareja clave/valor, se debe llamar a la función unset() con éste.

<?php
$arr = array(5 => 1, 12 => 2);

$arr[] = 56;    // Esto es lo mismo que $arr[13] = 56;
                // en este punto de el script

$arr["x"] = 42; // Esto agrega un nuevo elemento a
                // el array con la clave "x"

unset($arr[5]); // Esto elimina el elemento del array

unset($arr);    // Esto elimina el array completo
?>

Nota:

Como se mencionó anteriormente, si no se especifica una clave, se toma el máximo de los índices integer existentes, y la nueva clave será ese valor máximo más 1 (aunque al menos 0). Si todavía no existen índices integer, la clave será 0 (cero).

Tenga en cuenta que la clave integer máxima utilizada para éste no es necesario que actualmente exista en el array. Ésta sólo debe haber existido en el array en algún momento desde la última vez que el array fué re-indexado. El siguiente ejemplo ilustra este comportamiento:

<?php
// Crear un array simple.
$array = array(1, 2, 3, 4, 5);
print_r($array);

// Ahora elimina cada elemento, pero deja el mismo array intacto:
foreach ($array as $i => $value) {
    unset($array[$i]);
}
print_r($array);

// Agregar un elemento (note que la nueva clave es 5, en lugar de 0).
$array[] = 6;
print_r($array);

// Re-indexar:
$array = array_values($array);
$array[] = 7;
print_r($array);
?>

El resultado del ejemplo sería:

Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)
Array
(
)
Array
(
    [5] => 6
)
Array
(
    [0] => 6
    [1] => 7
)

Funciones útiles

Hay un buen número de funciones útiles para trabajar con arrays. Véase la sección funciones de array.

Nota:

La función unset() permite remover claves de un array. Tenga en cuenta que el array no es re-indexado. Si se desea un verdadero comportamiento "eliminar y desplazar", el array puede ser re-indexado usando la función array_values().

<?php
$a = array(1 => 'uno', 2 => 'dos', 3 => 'tres');
unset($a[2]);
/* producirá un array que se ha definido como
   $a = array(1 => 'uno', 3 => 'tres');
   y NO
   $a = array(1 => 'uno', 2 =>'tres');
*/

$b = array_values($a);
// Ahora $b es array(0 => 'uno', 1 =>'tres')
?>

La estructura de control foreach existe específicamente para arrays. Ésta provee una manera fácil de recorrer un array.

Recomendaciones sobre arrays y cosas a evitar

¿Por qué es incorrecto $foo[bar]?

Siempre deben usarse comillas alrededor de un índice de array tipo string literal. Por ejemplo, $foo['bar'] es correcto, mientras que $foo[bar] no lo es. ¿Pero por qué? Es común encontrar este tipo de sintaxis en scripts viejos:

<?php
$foo[bar] = 'enemy';
echo $foo[bar];
// etc
?>

Esto está mal, pero funciona. La razón es que este código tiene una constante indefinida (bar) en lugar de un string ('bar' - observe las comillas). Funciona porque PHP automáticamente convierte un string puro (un string sin comillas que no corresponde con ningún símbolo conocido) en un string que contiene el string puro. Por ejemplo, si no se ha definido una constante llamada bar, entonces PHP reemplazará su valor por el string 'bar' y usará éste último.

Advertencia

La alternativa de tratar una constante indefinida como string vacío está obsoleto a partir de PHP 7.2.0, y emite un error de nivel E_WARNING. Anteriormente, un error de nivel E_NOTICE era emitido.

Nota: Esto no quiere decir que siempre haya que usar comillas en la clave. No use comillas con claves que sean constantes o variables, ya que en tal caso PHP no podrá interpretar sus valores.

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
ini_set('html_errors', false);
// Array simple:
$array = array(1, 2);
$count = count($array);
for ($i = 0; $i < $count; $i++) {
    echo "\nRevisando $i: \n";
    echo "Mal: " . $array['$i'] . "\n";
    echo "Bien: " . $array[$i] . "\n";
    echo "Mal: {$array['$i']}\n";
    echo "Bien: {$array[$i]}\n";
}
?>

El resultado del ejemplo sería:

Revisando 0:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Mal:
Bien: 1
Notice: Undefined index:  $i in /path/to/script.html on line 11
Mal:
Bien: 1

Revisando 1:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Mal:
Bien: 2
Notice: Undefined index:  $i in /path/to/script.html on line 11
Mal:
Bien: 2

Más ejemplos para demostrar este comportamiento:

<?php
// Mostrar todos los errores
error_reporting(E_ALL);

$arr = array('fruit' => 'apple', 'veggie' => 'carrot');

// Correcto
print $arr['fruit'];  // apple
print $arr['veggie']; // carrot

// Incorrecto. Esto funciona pero también genera un error de PHP de
// nivel E_NOTICE ya que no hay definida una constante llamada fruit
//
// Notice: Use of undefined constant fruit - assumed 'fruit' in...
print $arr[fruit];    // apple

// Esto define una constante para demostrar lo que pasa. El valor 'veggie'
// es asignado a una constante llamada fruit.
define('fruit', 'veggie');

// Note la diferencia ahora
print $arr['fruit'];  // apple
print $arr[fruit];    // carrot

// Lo siguiente está bien ya que se encuentra al interior de una cadena. Las constantes no son procesadas al
// interior de cadenas, así que no se produce un error E_NOTICE aquí
print "Hello $arr[fruit]";      // Hello apple

// Con una excepción, los corchetes que rodean las matrices al
// interior de cadenas permiten el uso de constantes
print "Hello {$arr[fruit]}";    // Hello carrot
print "Hello {$arr['fruit']}";  // Hello apple

// Esto no funciona, resulta en un error de intérprete como:
// Parse error: parse error, expecting T_STRING' or T_VARIABLE' or T_NUM_STRING'
// Esto por supuesto se aplica también al uso de superglobales en cadenas
print "Hello $arr['fruit']";
print "Hello $_GET['foo']";

// La concatenación es otra opción
print "Hello " . $arr['fruit']; // Hello apple
?>

Cuando se habilita error_reporting para mostrar errores de nivel E_NOTICE (como por ejemplo definiendo el valor E_ALL), este tipo de usos serán inmediatamente visibles. Por omisión, error_reporting se encuentra configurado para no mostrarlos.

Tal y como se indica en la sección de sintaxis, lo que existe entre los corchetes cuadrados ('[' y ']') debe ser una expresión. Esto quiere decir que código como el siguiente funciona:

<?php
echo $arr[somefunc($bar)];
?>

Este es un ejemplo del uso de un valor devuelto por una función como índice del array. PHP también conoce las constantes:

<?php
$error_descriptions[E_ERROR]   = "Un error fatal ha ocurrido";
$error_descriptions[E_WARNING] = "PHP produjo una advertencia";
$error_descriptions[E_NOTICE]  = "Esta es una noticia informal";
?>

Note que E_ERROR es también un identificador válido, asi como bar en el primer ejemplo. Pero el último ejemplo es equivalente a escribir:

<?php
$error_descriptions[1] = "Un error fatal ha ocurrido";
$error_descriptions[2] = "PHP produjo una advertencia";
$error_descriptions[8] = "Esta es una noticia informal";
?>

ya que E_ERROR es igual a 1, etc.

¿Entonces porqué está mal?

En algún momento en el futuro, puede que el equipo de PHP quiera usar otra constante o palabra clave, o una constante proveniente de otro código puede interferir. Por ejemplo, en este momento no puede usar las palabras empty y default de esta forma, ya que son palabras clave reservadas.

Nota: Reiterando, al interior de un valor string entre comillas dobles, es válido no rodear los índices de array con comillas, así que "$foo[bar]" es válido. Consulte los ejemplos anteriores para más detalles sobre el porqué, así como la sección sobre procesamiento de variables en cadenas.

Conversión a array

Para cualquiera de los tipos integer, float, string, boolean y resource, convertir un valor a un array resulta en un array con un solo elemento, con índice 0, y el valor del escalar que fue convertido. En otras palabras, (array)$scalarValue es exactamente lo mismo que array($scalarValue).

Si convierte un object a un array, el resultado es un array cuyos elementos son las propiedades del object. Las claves son los nombres de las variables miembro, con algunas excepciones notables: las variables privadas tienen el nombre de la clase al comienzo del nombre de la variable; las variables protegidas tienen un caracter '*' al comienzo del nombre de la variable. Estos valores adicionados al inicio tienen bytes nulos a los lados. Esto puede resultar en algunos comportamientos inesperados:

<?php

class A {
    private $A; //  Este campo se convertirá en '\0A\0A'
}

class B extends A {
    private $A; // Este campo se convertirá en '\0B\0A'
    public $AA; // Este campo se convertirá en 'AA'
}

var_dump((array) new B());
?>

En el ejemplo anterior parecerá que se tienen dos claves llamadas 'AA', aunque en realidad una de ellas se llama '\0A\0A'.

Si convierte un valor null a array, obtiene un array vacío.

Comparación

Es posible comparar arrays con la función array_diff() y mediante operadores de arrays.

Ejemplos

El tipo array en PHP es bastante versátil. Aquí hay algunos ejempos:

<?php
// Esto:
$a = array( 'color' => 'red',
            'taste' => 'sweet',
            'shape' => 'round',
            'name'  => 'apple',
            4        // la clave será 0
          );

$b = array('a', 'b', 'c');

// . . .es completamente equivalente a
$a = array();
$a['color'] = 'red';
$a['taste'] = 'sweet';
$a['shape'] = 'round';
$a['name']  = 'apple';
$a[]        = 4;        // la clave será 0

$b = array();
$b[] = 'a';
$b[] = 'b';
$b[] = 'c';

// Después de que se ejecute el código, $a será el array
// array('color' => 'red', 'taste' => 'sweet', 'shape' => 'round',
// 'name' => 'apple', 0 => 4), y $b será el array
// array(0 => 'a', 1 => 'b', 2 => 'c'), o simplemente array('a', 'b', 'c').
?>

Ejemplo #8 Uso de array()

<?php
// Array como mapa de propiedades
$map = array( 'version'    => 4,
              'OS'         => 'Linux',
              'lang'       => 'english',
              'short_tags' => true
            );

// Keys estrictamente numéricas
$array = array( 7,
                8,
                0,
                156,
                -10
              );
// esto es lo mismo que array(0 => 7, 1 => 8, ...)

$switching = array(         10, // key = 0
                    5    =>  6,
                    3    =>  7,
                    'a'  =>  4,
                            11, // key = 6 (el índice entero máximo era 5)
                    '8'  =>  2, // key = 8 (integer!)
                    '02' => 77, // key = '02'
                    0    => 12  // el valor 10 será reemplazado por 12
                  );

// array vacío
$empty = array();
?>

Ejemplo #9 Colección

<?php
$colors = array('rojo', 'azul', 'verde', 'amarillo');

foreach ($colors as $color) {
    echo "¿Le gusta el $color?\n";
}

?>

El resultado del ejemplo sería:

¿Le gusta el rojo?
¿Le gusta el azul?
¿Le gusta el verde?
¿Le gusta el amarillo?

Modificar los valores del array directamente es posible pasándolos por referencia.

Ejemplo #10 Cambiando elemento en el bucle

<?php
foreach ($colors as &$color) {
    $color = strtoupper($color);
}
unset($color); /* se asegura de que escrituras subsiguientes a $color
no modifiquen el último elemento del arrays */

print_r($colors);
?>

El resultado del ejemplo sería:

Array
(
    [0] => ROJO
    [1] => AZUL
    [2] => VERDE
    [3] => AMARILLO
)

Este ejemplo crea un array con base uno.

Ejemplo #11 Índice con base 1

<?php
$firstquarter  = array(1 => 'Enero', 'Febrero', 'Marzo');
print_r($firstquarter);
?>

El resultado del ejemplo sería:

Array
(
    [1] => 'Enero'
    [2] => 'Febrero'
    [3] => 'Marzo'
)

Ejemplo #12 Llenado de un array

<?php
// llenar un array con todos los ítems de un directorio
$handle = opendir('.');
while (false !== ($file = readdir($handle))) {
    $files[] = $file;
}
closedir($handle);
?>

Los Arrays son ordenados. El orden puede ser modificado usando varias funciones de ordenado. Vea la sección sobre funciones de arrays para más información. La función count() puede ser usada para contar el número de elementos en un array.

Ejemplo #13 Ordenado de un array

<?php
sort($files);
print_r($files);
?>

Dado que el valor de un array puede ser cualquier cosa, también puede ser otro array. De esta forma es posible crear arrays recursivas y multi-dimensionales.

Ejemplo #14 Arrays recursivos y multi-dimensionales

<?php
$fruits = array ( "fruits"  => array ( "a" => "orange",
                                       "b" => "banana",
                                       "c" => "apple"
                                     ),
                  "numbers" => array ( 1,
                                       2,
                                       3,
                                       4,
                                       5,
                                       6
                                     ),
                  "holes"   => array (      "first",
                                       5 => "second",
                                            "third"
                                     )
                );

// Algunos ejemplos que hacen referencia a los valores del array anterior
echo $fruits["holes"][5];    // prints "second"
echo $fruits["fruits"]["a"]; // prints "orange"
unset($fruits["holes"][0]);  // remove "first"

// Crear una nueva array multi-dimensional
$juices["apple"]["green"] = "good";
?>

La asignación de arrays siempre involucra la copia de valores. Use el operador de referencia para copiar un array por referencia.

<?php
$arr1 = array(2, 3);
$arr2 = $arr1;
$arr2[] = 4; // $arr2 ha cambiado,
             // $arr1 sigue siendo array(2, 3)

$arr3 = &$arr1;
$arr3[] = 4; // ahora $arr1 y $arr3 son iguales
?>


Iterables

Iterable es un seudotipo introducido en PHP 7.1. Acepta cualquier array u objeto que implemente la interfaz Traversable. Estos dos tipos se recorren con foreach y se pueden emplear con yield from dentro de un generador.

Empleo de iterables

Iterable se puede usar como tipo de parámetro para indicar que una función requiere un conjunto de valores, pero que no importa la forma del dicho conjunto ya que se utiizará con foreach. Si un valor no es un array o una instancia de Traversable, se lanzará un TypeError.

Ejemplo #1 Ejemplo de de tipo de parámetro iterable

<?php

function foo(iterable $iterable) {
    foreach ($iterable as $valor) {
        // ...
    }
}

?>

Los parámetros declarados como iterable pueden usar null o un array como valor predeterminado.

Ejemplo #2 Ejemplo de valor predeterminado de un parámetro iterable

<?php

function foo(iterable $iterable = []) {
    // ...
}

?>

Iterable se puede usar como tipo de retorno para indicar que una función devolverá un valor iterable. Si el valor devuelto no es un array o una instancia de Traversable, se lanzará un TypeError.

Ejemplo #3 Ejemplo de tipo de retorno iterable

<?php

function bar(): iterable {
    return [1, 2, 3];
}

?>

Las funciones que declaren su tipo de retorno como también pueden ser generadores.

Ejemplo #4 Ejemplo de tipo de retorno de generadro iterable

<?php

function gen(): iterable {
    yield 1;
    yield 2;
    yield 3;
}

?>

Varianza del tipo iterable

Las clases que extiendan/implementen podrían ampliar los métodos usando array o Traversable como tipos de parámetro a iterable o reducir los tipos de retorno de iterable a array o Traversable.

Ejemplo #5 Ejemplo de varianza del tipo iterable

<?php

interface Ejemplo {
    public function method(array $array): iterable;
}

class ImplementaciónDeEjemplo implements Ejemplo {
    public function method(iterable $iterable): array {
        // Parámetro ampliado y tipo de retorno reducido.
    }
}

?>


Objetos

Inicialización de objetos

Para crear un nuevo object, utilice la sentencia new para instanciar una clase:

<?php
class foo
{
    function hacer_algo()
    {
        echo "Haciendo algo.";
    }
}

$bar = new foo;
$bar->hacer_algo();
?>

Para una descripción completa, véase el capítulo Clases y objetos.

Conversión a un objeto

Si un object se convierte en un object, éste no se modifica. Si un valor de cualquier otro tipo se convierte en un object, se crea una nueva instancia de la clase stdClass incorporada. Si el valor es null, la nueva instancia estará vacía. Un array se convierte en un object con las propiedades nombradas como claves y los valores correspondientes, con la excepción de las claves numéricas, las cuales serán inaccesibles a menos que sean recorridas.

<?php
$obj = (object) array('1' => 'foo');
var_dump(isset($obj->{'1'})); // muestra 'bool(false)'
var_dump(key($obj)); // muestra 'int(1)'
?>

Para cualquier otro valor, una variable miembro llamada scalar contendrá el valor.

<?php
$obj = (object) 'ciao';
echo $obj->scalar;  // muestra 'ciao'
?>


Recursos

Un valor tipo resource es una variable especial, que contiene una referencia a un recurso externo. Los recursos son creados y usados por funciones especiales. Vea el apéndice para un listado de todas estas funciones y los tipos resource correspondientes.

Vea también la función get_resource_type().

Conversión a recurso

Dado que las variables resource contienen gestores especiales a archivos abiertos, conexiones con bases de datos, áreas de pintura de imágenes y cosas por el estilo, la conversión a tipo resource carece de sentido.

Liberación de recursos

Gracias al sistema de conteo de referencias introducido con el Motor Zend, un recurso que ya no es referenciado es detectado automáticamente, y es liberado por el recolector de basura. Por esta razón, rara vez se necesita liberar la memoria manualmente.

Nota: Los enlaces persistentes con bases de datos son una excepción a esta regla. Ellos no son destruidos por el recolector de basura. Vea también la sección sobre conexiones persistentes para más información.


NULO

El valor especial null representa una variable sin valor. null es el único valor posible del tipo null.

Una variable es considerada null si:

  • se le ha asignado la constante null.

  • no se le ha asignado un valor todavía.

  • se ha destruido con unset().

Sintaxis

No hay más que un valor de tipo null, y es la constante null insensible a mayúsculas/minúsculas.

<?php
$var = NULL;
?>

Véase también las funciones is_null() y unset().

La conversión a null

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Convertir una variable a null usando (unset) $var no eliminará la variable ni destruirá su valor. Sólo retornará un valor null.


Llamadas de retorno (Callbacks / Callables)

Las llamadas de retorno, o retrollamadas, se pueden indicar con la declaración de tipo callable a partir de PHP 5.4. Esta documentación utilizó la información del tipo callback con el mismo propósito.

Algunas funciones como call_user_func() o usort() aceptan como parámetro funciones de llamada de retorno definidas por el usuario. Las funciones de llamadas de retorno no sólo pueden ser funciones simples, sino también métodos de un object, incluyendo métodos de clase estáticos.

Pasar una función de llamada de retorno

Una función de PHP se pasa por su nombre como un string. Se puede utilizar
cualquier función nativa o definida por el usuario, exceptuando contrucciones del lenguaje, tales como:
array(), echo,
empty(), eval(),
exit(), isset(),
list(), print o
unset().

Un método de un object instanciado se pasa como un array que contiene un object en el índice 0 y el nombre del método en el índice 1. Está permitido el acceso a métodos protegidos y privados desde dentro de una clase.

Los métodos de clase estáticos también se pueden pasar sin instanciar un object de dicha clase, pasando el nombre de la clase en lugar de un object en el índice 0. A partir de PHP 5.2.3, también es posible pasar 'NombreDeClase::nombreDeMetodo'.

A parte de las funciones comunes definidas por el usuario, las funciones anónimas también se pueden pasar a un parámetro de llamada de retorno.

Ejemplo #1 Ejemplos de funciones de llamadas de retorno

<?php

// Un ejemplo de función de llamada de retorno
function mi_función_de_llamada_de_retorno() {
    echo '¡hola mundo!';
}

// Un ejemplo de método de llamada de retorno
class MiClase {
    static function miMétodoDeLlamadaDeRetorno() {
        echo '¡Hola Mundo!';
    }
}

// Tipo 1: Llamada de retorno simple
call_user_func('mi_función_de_llamada_de_retorno');

// Tipo 2: Llamada a un método de clase estático
call_user_func(array('MiClase', 'miMétodoDeLlamadaDeRetorno'));

// Tipo 3: Llamada al método de un objeto
$obj = new MiClase();
call_user_func(array($obj, 'miMétodoDeLlamadaDeRetorno'));

// Tipo 4: Llamada a un método de clase estático (A partir de PHP 5.2.3)
call_user_func('MiClase::miMétodoDeLlamadaDeRetorno');

// Tipo 5: Llamada a un método de clase estático relativo (A partir de PHP 5.3.0)
class A {
    public static function quién() {
        echo "A\n";
    }
}

class B extends A {
    public static function quién() {
        echo "B\n";
    }
}

call_user_func(array('B', 'parent::quién')); // A

// Tipe 6: Los objetos que implementan __invoke se pueden emplear como retrollamadas (desde PHP 5.3)
class C {
    public function __invoke($nombre) {
        echo 'Hola ', $nombre, "\n";
    }
}

$c = new C();
call_user_func($c, 'PHP!');
?>

Ejemplo #2 Ejemplo de retrollamada utilizando un cierre

<?php
// Nuestro cierre
$doble = function($a) {
    return $a * 2;
};

// Este es nuestro rango de números
$números = range(1, 5);

// Usar el cierre como llamada de retorno para
// doblar el valor de cada elemento de nuestro
// rango
$números_nuevos = array_map($doble, $números);

print implode(' ', $números_nuevos);
?>

El resultado del ejemplo sería:

2 4 6 8 10

Nota:

Las funciones de retorno de llamada que se registran con funciones como call_user_func() y call_user_func_array() no se llamarán si se produce una excepción en la función de retorno previa.


Type declarations

Type declarations can be added to function arguments, return values, and, as of PHP 7.4.0, class properties. They ensure that the value is of the specified type at call time, otherwise a TypeError is thrown.

Nota:

When overriding a parent method, the child's method must match any return type declaration on the parent. If the parent doesn't define a return type, then the child method may do so.

Single types

Tipo | Descripción | Versión
Class/interface name | The value must be an instanceof the given class or interface. |
self | The value must be an instanceof the same class as the one in which the type declaration is used. Can only be used in classes. |
parent | The value must be an instanceof the parent of the class in which the type declaration is used. Can only be used in classes. |
array | The value must be an array. |
callable | The value must be a valid callable. Cannot be used as a class property type declaration. |
bool | The value must be a boolean value. |
float | The value must be a floating point number. |
int | The value must be an integer. |
string | The value must be a string. |
iterable | The value must be either an array or an instanceof Traversable. | PHP 7.1.0
object | The value must be an object. | PHP 7.2.0
mixed | The value can be any value. | PHP 8.0.0
Advertencia

Aliases for the above scalar types are not supported. Instead, they are treated as class or interface names. For example, using boolean as a type declaration will require the value to be an instanceof the class or interface boolean, rather than of type bool:

<?php
    function test(boolean $param) {}
    test(true);
?>

Output of the above example in PHP 8:

Warning: "boolean" will be interpreted as a class name. Did you mean "bool"? Write "\boolean" to suppress this warning in /in/9YrUX on line 2

Fatal error: Uncaught TypeError: test(): Argument #1 ($param) must be of type boolean, bool given, called in - on line 3 and defined in -:2
Stack trace:
#0 -(3): test(true)
#1 {main}
  thrown in - on line 2

mixed

mixed is equivalent to the union type array|bool|callable|int|float |object|resource|string|null . Available as of PHP 8.0.0.

Ejemplos

Ejemplo #1 Basic class type declaration

<?php
class C {}
class D extends C {}

// This doesn't extend C.
class E {}

function f(C $c) {
    echo get_class($c)."\n";
}

f(new C);
f(new D);
f(new E);
?>

Output of the above example in PHP 8:

C
D

Fatal error: Uncaught TypeError: f(): Argument #1 ($c) must be of type C, E given, called in /in/gLonb on line 14 and defined in /in/gLonb:8
Stack trace:
#0 -(14): f(Object(E))
#1 {main}
  thrown in - on line 8

Ejemplo #2 Basic interface type declaration

<?php
interface I { public function f(); }
class C implements I { public function f() {} }

// This doesn't implement I.
class E {}

function f(I $i) {
    echo get_class($i)."\n";
}

f(new C);
f(new E);
?>

Output of the above example in PHP 8:

C

Fatal error: Uncaught TypeError: f(): Argument #1 ($i) must be of type I, E given, called in - on line 13 and defined in -:8
Stack trace:
#0 -(13): f(Object(E))
#1 {main}
  thrown in - on line 8

Ejemplo #3 Basic return type declaration

<?php
function sum($a, $b): float {
    return $a + $b;
}

// Note that a float will be returned.
var_dump(sum(1, 2));
?>

El resultado del ejemplo sería:

float(3)

Ejemplo #4 Returning an object

<?php
class C {}

function getC(): C {
    return new C;
}

var_dump(getC());
?>

El resultado del ejemplo sería:

object(C)#1 (0) {
}

Nullable type

As of PHP 7.1.0, type declarations can be marked nullable by prefixing the type name with a question mark (?). This signifies that the value can be of the specified type or null.

Ejemplo #5 Nullable argument type declaration

<?php
class C {}

function f(?C $c) {
    var_dump($c);
}

f(new C);
f(null);
?>

El resultado del ejemplo sería:

object(C)#1 (0) {
}
NULL

Ejemplo #6 Nullable return type declaration

<?php
function get_item(): ?string {
    if (isset($_GET['item'])) {
        return $_GET['item'];
    } else {
        return null;
    }
}
?>

Nota:

Prior to PHP 7.1.0, it was possible to achieve nullable arguments by making null the default value. This is not recommended as this breaks during inheritance.

Ejemplo #7 Old way to make arguments nullable

<?php
class C {}

function f(C $c = null) {
    var_dump($c);
}

f(new C);
f(null);
?>

El resultado del ejemplo sería:

object(C)#1 (0) {
}
NULL

Union types

A union type declaration accepts values of multiple different types, rather than a single one. Union types are specified using the syntax T1|T2|.... Union types are available as of PHP 8.0.0.

Nullable union types

The null type is supported as part of unions, such that T1|T2|null can be used to create a nullable union. The existing ?T notation is considered a shorthand for the common case of T|null.

Precaución

null cannot be used as a standalone type.

false pseudo-type

The false literal type is supported as part of unions, and is included as for historical reasons many internal functions return false instead of null for failures. A classic example of such a function is strpos().

Precaución

false cannot be used as a standalone type (including nullable standalone type). As such, all of false, false|null and ?false are not permitted.

Precaución

The true literal type does not exist.

Duplicate and redundant types

To catch simple bugs in union type declarations, redundant types that can be detected without performing class loading will result in a compile-time error. This includes:

  • Each name-resolved type may only occur once. Types such as int|string|INT result in an error.
  • If bool is used, false cannot be used additionally.
  • If object is used, class types cannot be used additionally.
  • If iterable is used, array and Traversable cannot be used additionally.

Nota: This does not guarantee that the type is “minimal”, because doing so would require loading all used class types.

For example, if A and B are class aliases, then A|B remains a legal union type, even though it could be reduced to either A or B. Similarly, if class B extends A {}, then A|B is also a legal union type, even though it could be reduced to just A.

<?php
function foo(): int|INT {} // Disallowed
function foo(): bool|false {} // Disallowed

use A as B;
function foo(): A|B {} // Disallowed ("use" is part of name resolution)

class_alias('X', 'Y');
function foo(): X|Y {} // Allowed (redundancy is only known at runtime)
?>

Return only types

void

void is a return type indicating the function does not return a value. Therefore it cannot be part of a union type declaration. Available as of PHP 7.1.0.

static

The value must be an instanceof the same class as the one the method is called in. Available as of PHP 8.0.0.

Strict typing

By default, PHP will coerce values of the wrong type into the expected scalar type declaration if possible. For example, a function that is given an int for a parameter that expects a string will get a variable of type string.

It is possible to enable strict mode on a per-file basis. In strict mode, only a value corresponding exactly to the type declaration will be accepted, otherwise a TypeError will be thrown. The only exception to this rule is that an int value will pass a float type declaration.

Advertencia

Function calls from within internal functions will not be affected by the strict_types declaration.

To enable strict mode, the declare statement is used with the strict_types declaration:

Nota:

Strict typing applies to function calls made from within the file with strict typing enabled, not to the functions declared within that file. If a file without strict typing enabled makes a call to a function that was defined in a file with strict typing, the caller's preference (coercive typing) will be respected, and the value will be coerced.

Nota:

Strict typing is only defined for scalar type declarations.

Ejemplo #8 Strict typing for arguments values

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1.5, 2.5));
?>

Output of the above example in PHP 8:

int(3)

Fatal error: Uncaught TypeError: sum(): Argument #1 ($a) must be of type int, float given, called in - on line 9 and defined in -:4
Stack trace:
#0 -(9): sum(1.5, 2.5)
#1 {main}
  thrown in - on line 4

Ejemplo #9 Coercive typing for argument values

<?php
function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));

// These will be coerced to integers: note the output below!
var_dump(sum(1.5, 2.5));
?>

El resultado del ejemplo sería:

int(3)
int(3)

Ejemplo #10 Strict typing for return values

<?php
declare(strict_types=1);

function sum($a, $b): int {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1, 2.5));
?>

El resultado del ejemplo sería:

int(3)

Fatal error: Uncaught TypeError: sum(): Return value must be of type int, float returned in -:5
Stack trace:
#0 -(9): sum(1, 2.5)
#1 {main}
  thrown in - on line 5

Coercive typing with union types

When strict_types is not enabled, scalar type declarations are subject to limited implicit type coercions. If the exact type of the value is not part of the union, then the target type is chosen in the following order of preference:

  1. int
  2. float
  3. string
  4. bool
If the type both exists in the union, and the value can be coerced to the type under PHPs existing type checking semantics, then the type is chosen. Otherwise the next type is tried.

Precaución

As an exception, if the value is a string and both int and float are part of the union, the preferred type is determined by the existing “numeric string” semantics. For example, for "42" int is chosen, while for "42.0" float is chosen.

Nota:

Types that are not part of the above preference list are not eligible targets for implicit coercion. In particular no implicit coercions to the null and false types occur.

Ejemplo #11 Example of types being coerced into a type part of the union

<?php
// int|string
42    --> 42          // exact type
"42"  --> "42"        // exact type
new ObjectWithToString --> "Result of __toString()"
                      // object never compatible with int, fall back to string
42.0  --> 42          // float compatible with int
42.1  --> 42          // float compatible with int
1e100 --> "1.0E+100"  // float too large for int type, fall back to string
INF   --> "INF"       // float too large for int type, fall back to string
true  --> 1           // bool compatible with int
[]    --> TypeError   // array not compatible with int or string

// int|float|bool
"45"    --> 45        // int numeric string
"45.0"  --> 45.0      // float numeric string

"45X"   --> true      // not numeric string, fall back to bool
""      --> false     // not numeric string, fall back to bool
"X"     --> true      // not numeric string, fall back to bool
[]      --> TypeError // array not compatible with int, float or bool
?>

Misc

Ejemplo #12 Typed pass-by-reference Parameters

Declared types of reference parameters are checked on function entry, but not when the function returns, so after the function had returned, the argument's type may have changed.

<?php
function array_baz(array &$param)
{
    $param = 1;
}
$var = [];
array_baz($var);
var_dump($var);
array_baz($var);
?>

Output of the above example in PHP 8:

int(1)

Fatal error: Uncaught TypeError: array_baz(): Argument #1 ($param) must be of type array, int given, called in - on line 9 and defined in -:2
Stack trace:
#0 -(9): array_baz(1)
#1 {main}
  thrown in - on line 2

Ejemplo #13 Catching TypeError

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

try {
    var_dump(sum(1, 2));
    var_dump(sum(1.5, 2.5));
} catch (TypeError $e) {
    echo 'Error: ', $e->getMessage();
}
?>

Output of the above example in PHP 8:

int(3)
Error: sum(): Argument #1 ($a) must be of type int, float given, called in - on line 10


Manipulación de tipos

PHP no requiere (ni soporta) la definición explicita de tipos en la declaración de variables; el tipo de la variable se determina por el contexto en el cual se emplea la variable. Es decir, si se asigna un valor string a una variable $var, entonces $var se convierte en un string. Si un valor integer es entonces asignado a la misma variable $var, ésta se convierte en integer.

Un ejemplo de la conversión de tipos automática de PHP es el operador suma '+'. Si al menos uno de los operandos es float, entonces ambos operandos son evaluados como floats y el resultado será un float. De otra manera, los operandos seran interpretados como integers, y el resultado será entonces integer. Tenga en cuenta que esto no implica que se cambien los tipos de los propios operandos; el único cambio es en como se evalúan los operandos y en el tipo de expresión en sí mismo.

<?php
$foo = "0";  // $foo es string (ASCII 48)
$foo += 2;   // $foo es ahora un integer (2)
$foo = $foo + 1.3;  // $foo es ahora un float (3.3)
$foo = 5 + "10 Cerditos pequeñitos"; // $foo es integer (15)
$foo = 5 + "10 Cerdos pequeños";     // $foo es integer (15)
?>

Si considera confusos los últimos dos ejemplos anteriores, consulte Conversión de cadenas a números.

Para forzar a que una variable sea evaluada como un determinado tipo, consulte la sección Forzado de tipos. Para cambiar el tipo de variable, consulte la función settype().

Para probar cualquiera de los ejemplos de esta sección, utilice la función var_dump().

Nota:

El comportamiento de la conversión automática en array está actualmente sin definir.

Tambien, debido a que PHP soporta el indexado de string mediante compensaciones mediante la misma sintaxis empleada en el indexado de arrays, los siguientes ejemplos son válidos para todas las versiones de PHP:

<?php
$a    = 'car'; // $a es un string
$a[0] = 'b';   // $a sigue siendo un string
echo $a;       // bar
?>

Consulte la sección Acceso a cadenas mediante caracteres para más información.

Forzado de tipos

El forzado de tipos en PHP funciona de la misma manera que en C:, donde el nombre del tipo deseado se escribe entre paréntesis antes de la variable que se quiera forzar.

<?php
$foo = 10;   // $foo es un integer
$bar = (boolean) $foo;   // $bar es un boolean
?>

Los siguientes forzados de tipos están permitidos:

  • (int), (integer) - forzado a integer
  • (bool), (boolean) - forzado a boolean
  • (float), (double), (real) - forzado a float
  • (string) - forzado a string
  • (array) - forzado a array
  • (object) - forzado a object
  • (unset) - forzado a NULL (PHP 5)

El forzado (binary) y el soporte del prefijo b fueron añadidos en PHP 5.2.1

Fíjese que se permiten las tabulaciones y espacios dentro de los paréntesis, por lo que los siguientes ejemplos son funcionalmente equivalentes:

<?php
$foo = (int) $bar;
$foo = ( int ) $bar;
?>

Forzado literal de strings y variables a strings binarios:

<?php
$binary = (binary) $string;
$binary = b"binary string";
?>

Nota:

El lugar de forzar una variable a string, tambien se puede encerrar la variable entre comillas dobles.

<?php
$foo = 10;            // $foo es un integer
$str = "$foo";        // $str es un string
$fst = (string) $foo; // $fst es tambien un string

// Esto muestra que "son lo mismo"
if ($fst === $str) {
    echo "son lo mismo";
}
?>

Puede que no sea obvio que sucede exactamente cuando se fuerzan ciertos tipos. Para más información, consulte estas secciones:

  • Conversión a booleano
  • Conversión a entero
  • Conversión a número de punto flotante
  • Conversión a cadena
  • Conversión a array
  • Conversión a objecto
  • Conversión a recurso
  • Conversión a NULL
  • Tablas de comparación de tipos


Variables

Tabla de contenidos

  • Conceptos básicos
  • Variables Predefinidas
  • Ámbito de las variables
  • Variables variables
  • Variables desde fuentes externas


Conceptos básicos

En PHP las variables se representan con un signo de dólar seguido por el nombre de la variable. El nombre de la variable es sensible a minúsculas y mayúsculas.

Los nombres de variables siguen las mismas reglas que otras etiquetas en PHP. Un nombre de variable válido tiene que empezar con una letra o un carácter de subrayado (underscore), seguido de cualquier número de letras, números y caracteres de subrayado. Como expresión regular se podría expresar como: '[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*'

Nota: Para los propósitos de este manual, una letra es a-z, A-Z, y los bytes del 127 al 255 (0x7f-0xff).

Nota: $this es una variable especial que no puede ser asignada.

Sugerencia

Vea también Guía de entorno de usuario para nombres.

Para más información sobre funciones relacionadas con variables, vea la Referencia de Funciones de Variables.

<?php
$var = 'Roberto';
$Var = 'Juan';
echo "$var, $Var";      // imprime "Roberto, Juan"

$4site = 'aun no';      // inválido; comienza con un número
$_4site = 'aun no';     // válido; comienza con un carácter de subrayado
$täyte = 'mansikka';    // válido; 'ä' es ASCII (Extendido) 228
?>

De forma predeterminada, las variables siempre se asignan por valor. Esto significa que cuando se asigna una expresión a una variable, el valor completo de la expresión original se copia en la variable de destino. Esto quiere decir que, por ejemplo, después de asignar el valor de una variable a otra, los cambios que se efectúen a una de esas variables no afectará a la otra. Para más información sobre este tipo de asignación, vea Expresiones.

PHP también ofrece otra forma de asignar valores a las variables: asignar por referencia. Esto significa que la nueva variable simplemente referencia (en otras palabras, "se convierte en un alias de" ó "apunta a") la variable original. Los cambios a la nueva variable afectan a la original, y viceversa.

Para asignar por referencia, simplemente se antepone un signo ampersand (&) al comienzo de la variable cuyo valor se está asignando (la variable fuente). Por ejemplo, el siguiente segmento de código produce la salida 'Mi nombre es Bob' dos veces:

<?php
$foo = 'Bob';                // Asigna el valor 'Bob' a $foo
$bar = &$foo;                // Referenciar $foo vía $bar.
$bar = "Mi nombre es $bar";  // Modifica $bar...
echo $bar;
echo $foo;                   // $foo también se modifica.
?>

Algo importante a tener en cuenta es que sólo las variables con nombre pueden ser asignadas por referencia.

<?php
$foo = 25;
$bar = &$foo;      // Esta es una asignación válida.
$bar = &(24 * 7);  // Inválida; referencia una expresión sin nombre.

function test()
{
   return 25;
}

$bar = &test();    // Inválido.
?>

No es necesario inicializar variables en PHP, sin embargo, es una muy buena práctica. Las variables no inicializadas tienen un valor predeterminado de acuerdo a su tipo dependiendo del contexto en el que son usadas - las booleanas se asumen como false, los enteros y flotantes como cero, las cadenas (p.ej. usadas en echo) se establecen como una cadena vacía y los arrays se convierten en un array vacío.

Ejemplo #1 Valores predeterminados en variables sin inicializar

<?php
// Una variable no definida Y no referenciada (sin contexto de uso); imprime NULL
var_dump($variable_indefinida);

// Uso booleano; imprime 'false' (Vea operadores ternarios para más información sobre esta sintaxis)
echo($booleano_indefinido ? "true\n" : "false\n");

// Uso de una cadena; imprime 'string(3) "abc"'
$cadena_indefinida .= 'abc';
var_dump($cadena_indefinida);

// Uso de un entero; imprime 'int(25)'
$int_indefinido += 25; // 0 + 25 => 25
var_dump($int_indefinido);

// Uso de flotante/doble; imprime 'float(1.25)'
$flotante_indefinido += 1.25;
var_dump($flotante_indefinido);

// Uso de array; imprime array(1) {  [3]=>  string(3) "def" }
$array_indefinida[3] = "def"; // array() + array(3 => "def") => array(3 => "def")
var_dump($array_indefinida);

// Uso de objetos; crea un nuevo objeto stdClass (vea http://www.php.net/manual/en/reserved.classes.php)
// Imprime: object(stdClass)#1 (1) {  ["foo"]=>  string(3) "bar" }
$objeto_indefinido->foo = 'bar';
var_dump($objeto_indefinido);
?>

Depender del valor predeterminado de una variable sin inicializar es problemático al incluir un archivo en otro que use el mismo nombre de variable. Un error de nivel E_NOTICE es emitido cuendo se trabaja con variables sin inicializar, con la excepción del caso en el que se anexan elementos a un array no inicializado. La construcción del lenguaje isset() puede ser usada para detectar si una variable ya ha sido inicializada.


Variables Predefinidas

PHP proporciona una gran cantidad de variables predefinidas a cualquier script que se ejecute. Muchas de éstas, sin embargo, no pueden ser completamente documentadas ya que dependen del servidor que esté corriendo, la versión y configuración de dicho servidor, y otros factores. Algunas de estas variables no estarán disponibles cuando se ejecute PHP desde la línea de comandos. Para obtener una lista de estas variables, por favor vea la sección sobre Variables Predefinidas Reservadas.

PHP ofrece un conjunto adicional de arrays predefinidas que contienen variables del servidor web, el entorno y entradas del usuario. Estos nuevos arrays son un poco especiales porque son automáticamente globales. Por esta razón, son conocidas a menudo como "superglobales". Las superglobales se mencionan más abajo; sin embargo para una lista de sus contenidos y más información sobre variables predefinidas en PHP, por favor consulte la sección Variables predefinidas reservadas. Asimismo, podrá notar cómo las antiguas variables predefinidas ($HTTP_*_VARS) todavía existen. A partir de PHP 5.0.0, los arrays de variables predefinidas de tipo long de PHP se pueden desactivar con la directiva register_long_arrays .

Nota: Variables variables

Las superglobales no pueden ser usadas como variables variables al interior de funciones o métodos de clase.

Nota:

Aún cuando las superglobales y HTTP_*_VARS pueden existir al mismo tiempo; estas variables no son idénticas, así que modificar una no cambia la otra.

Si ciertas variables no son definidas en variables_order, los arrays de PHP predefinidos asociados a estas, estarán vacíos.


Ámbito de las variables

El ámbito de una variable es el contexto dentro del que la variable está definida. La mayor parte de las variables PHP sólo tienen un ámbito simple. Este ámbito simple también abarca los ficheros incluídos y los requeridos. Por ejemplo:

<?php
$a = 1;
include 'b.inc';
?>

Aquí, la variable $a estará disponible al interior del script incluido b.inc. Sin embargo, al interior de las funciones definidas por el usuario se introduce un ámbito local a la función. Cualquier variable usada dentro de una función está, por omisión, limitada al ámbito local de la función. Por ejemplo:

<?php
$a = 1; /* ámbito global */

function test()
{
    echo $a; /* referencia a una variable del ámbito local */
}

test();
?>

Este script no producirá salida, ya que la sentencia echo utiliza una versión local de la variable $a, a la que no se ha asignado ningún valor en su ámbito. Puede que usted note que hay una pequeña diferencia con el lenguaje C, en el que las variables globales están disponibles automáticamente dentro de la función a menos que sean expresamente sobreescritas por una definición local. Esto puede causar algunos problemas, ya que la gente puede cambiar variables globales inadvertidamente. En PHP, las variables globales deben ser declaradas globales dentro de la función si van a ser utilizadas dentro de dicha función.

La palabra clave global

En primer lugar, un ejemplo de uso de global:

Ejemplo #1 Uso de global

<?php
$a = 1;
$b = 2;

function Suma()
{
    global $a, $b;

    $b = $a + $b;
}

Suma();
echo $b;
?>

El script anterior producirá la salida 3. Al declarar $a y $b globales dentro de la función, todas las referencias a tales variables se referirán a la versión global. No hay límite al número de variables globales que se pueden manipular dentro de una función.

Un segundo método para acceder a las variables desde un ámbito global es usando el array $GLOBALS. El ejemplo anterior se puede reescribir así:

Ejemplo #2 Uso de $GLOBALS en lugar de global

<?php
$a = 1;
$b = 2;

function Suma()
{
    $GLOBALS['b'] = $GLOBALS['a'] + $GLOBALS['b'];
}

Suma();
echo $b;
?>

El array $GLOBALS es un array asociativo con el nombre de la variable global como clave y los contenidos de dicha variable como el valor del elemento del array. $GLOBALS existe en cualquier ámbito, esto ocurre ya que $GLOBALS es una superglobal. Aquí hay un ejemplo que demuestra el poder de las superglobales:

Ejemplo #3 Ejemplo que demuestra las superglobales y el ámbito

<?php
function test_global()
{
    // La mayoría de variables predefinidas no son "super" y requieren
    // 'global' para estar disponibles al ámbito local de las funciones.
    global $HTTP_POST_VARS;

    echo $HTTP_POST_VARS['name'];

    // Las superglobales están disponibles en cualquier ámbito y no
    // requieren 'global'. Las superglobales están disponibles desde
    // PHP 4.1.0, y ahora HTTP_POST_VARS se considera obsoleta.
    echo $_POST['name'];
}
?>

Nota:

Utilizar una clave global fuera de una función no es un error. Esta puede ser utilizada aún si el fichero está incluido desde el interior de una función.

Uso de variables static

Otra característica importante del ámbito de las variables es la variable estática. Una variable estática existe sólo en el ámbito local de la función, pero no pierde su valor cuando la ejecución del programa abandona este ámbito. Consideremos el siguiente ejemplo:

Ejemplo #4 Ejemplo que demuestra la necesidad de variables estáticas

<?php
function test()
{
    $a = 0;
    echo $a;
    $a++;
}
?>

Esta función tiene poca utilidad ya que cada vez que es llamada asigna a $a el valor 0 e imprime un 0. La sentencia $a++, que incrementa la variable, no sirve para nada, ya que en cuanto la función finaliza, la variable $a desaparece. Para hacer una función útil para contar, que no pierda la pista del valor actual del conteo, la variable $a debe declararse como estática:

Ejemplo #5 Ejemplo del uso de variables estáticas

<?php
function test()
{
    static $a = 0;
    echo $a;
    $a++;
}
?>

Ahora, $a se inicializa únicamente en la primera llamada a la función, y cada vez que la función test() es llamada, imprimirá el valor de $a y lo incrementa.

Las variables estáticas también proporcionan una forma de manejar funciones recursivas. Una función recursiva es la que se llama a sí misma. Se debe tener cuidado al escribir una función recursiva, ya que puede ocurrir que se llame a sí misma indefinidamente. Hay que asegurarse de implementar una forma adecuada de terminar la recursión. La siguiente función cuenta recursivamente hasta 10, usando la variable estática $count para saber cuándo parar:

Ejemplo #6 Variables estáticas con funciones recursivas

<?php
function test()
{
    static $count = 0;

    $count++;
    echo $count;
    if ($count < 10) {
        test();
    }
    $count--;
}
?>

Nota:

Las variables estáticas pueden ser declaradas como se ha visto en los ejemplos anteriores. Desde PHP 5.6 se pueden asignar valores a estas variables que sean el resultado de expresiones, aunque no se pueden usar funciones aquí, lo cual causaría un eror de análisis.

Ejemplo #7 Declaración de variables estáticas

<?php
function foo(){
    static $int = 0;          // correcto
    static $int = 1+2;        // correcto (a partir de PHP 5.6)
    static $int = sqrt(121);  // incorrecto (ya que es una función)

    $int++;
    echo $int;
}
?>

Nota:

Las declaraciones estáticas son resueltas en tiempo de compilación.

Referencias con variables global y static

El motor Zend 1, utilizado por PHP 4, implementa los modificadores static y global para variables en términos de referencias. Por ejemplo, una variable global verdadera importada dentro del ámbito de una función con global crea una referencia a la variable global. Esto puede ser causa de un comportamiento inesperado, tal y como podemos comprobar en el siguiente ejemplo:

<?php
function prueba_referencia_global() {
    global $obj;
    $obj = &new stdclass;
}

function prueba_no_referencia_global() {
    global $obj;
    $obj = new stdclass;
}

prueba_referencia_global();
var_dump($obj);
prueba_no_referencia_global();
var_dump($obj);
?>

El resultado del ejemplo sería:

NULL
object(stdClass)(0) {
}

Un comportamiento similar se aplica a static. Las referencias no son almacenadas estáticamente.

<?php
function &obtener_instancia_ref() {
    static $obj;

    echo 'Objeto estático: ';
    var_dump($obj);
    if (!isset($obj)) {
        // Asignar una referencia a la variable estática
        $obj = &new stdclass;
    }
    $obj->property++;
    return $obj;
}

function &obtener_instancia_no_ref() {
    static $obj;

    echo 'Objeto estático: ';
    var_dump($obj);
    if (!isset($obj)) {
        // Asignar el objeto a la variable estática
        $obj = new stdclass;
    }
    $obj->property++;
    return $obj;
}

$obj1 = obtener_instancia_ref();
$aun_obj1 = obtener_instancia_ref();
echo "\n";
$obj2 = obtener_instancia_no_ref();
$aun_obj2 = obtener_instancia_no_ref();
?>

El resultado del ejemplo sería:

Objeto estático: NULL
Objeto estático: NULL

Objeto estático: NULL
Objeto estático: object(stdClass)(1) {
["property"]=>
int(1)
}

Este ejemplo demuestra que al asignar una referencia a una variable estática, esta no es recordada cuando se invoca la funcion &obtener_instancia_ref() por segunda vez.


Variables variables

A veces es conveniente tener nombres de variables variables. Dicho de otro modo, son nombres de variables que se pueden definir y usar dinámicamente. Una variable normal se establece con una sentencia como:

<?php
$a = 'hola';
?>

Una variable variable toma el valor de una variable y lo trata como el nombre de una variable. En el ejemplo anterior, hola, se puede usar como el nombre de una variable utilizando dos signos de dólar. Es decir:

<?php
$$a = 'mundo';
?>

En este momento se han definido y almacenado dos variables en el árbol de símbolos de PHP: $a, que contiene "hola", y $hola, que contiene "mundo". Es más, esta sentencia:

<?php
echo "$a ${$a}";
?>

produce el mismo resultado que:

<?php
echo "$a $hola";
?>

esto quiere decir que ambas producen el resultado: hola mundo.

Para usar variables variables con arrays hay que resolver un problema de ambigüedad. Si se escribe $$a[1], el intérprete necesita saber si nos referimos a utilizar $a[1] como una variable, o si se pretendía utilizar $$a como variable y el índice [1] como índice de dicha variable. La sintaxis para resolver esta ambigüedad es: ${$a[1]} para el primer caso y ${$a}[1] para el segundo.

También se puede acceder a las propiedades de una clase usando el nombre de propiedad variable. Este será resuelto dentro del ámbito del cual se hizo la llamada. Por ejemplo, en la expresión $foo->$bar, se buscará $bar en el ámibto local y se empleará su valor será como el nombre de la propiedad de $foo. Esto también es cierto si $bar es un acceso a un array.

Precaución

Además, derreferenciar una propiedad variable que es un array tiene diferente semántica entre PHP 5 y PHP 7. La guías de migración de PHP 7.0 incluye más detalles sobre los tipos de expresiones que han cambiado, y cómo colocar llaves para evitar ambigüedades.

También se pueden usar llaves para delimitar de forma clara el nombre de la propiedad. Son muy útila al acceder a valores dentro una propiedad que contiene un array, cuando el nombre de la propiedad está compuesto de múltiples partes, o cuando el nombre de la propiedad contiene caracteres que de otro modo no son válidos (p.ej. desde json_decode() o SimpleXML).

Ejemplo #1 Ejemplo de propiedad variable

<?php
class foo {
    var $bar = 'Soy bar.';
    var $arr = array('Soy A.', 'Soy B.', 'Soy C.');
    var $r   = 'Soy r.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo $foo->$bar . "\n";
echo $foo->{$baz[1]} . "\n";

$start = 'b';
$end   = 'ar';
echo $foo->{$start . $end} . "\n";

$arr = 'arr';
echo $foo->$arr[1] . "\n";
echo $foo->{$arr[1]} . "\n";

?>

El resultado del ejemplo sería:

Soy bar.
Soy bar.
Soy bar.
Soy r.

Advertencia

Por favor tenga en cuenta que las variables variables no pueden usarse con los Arrays superglobales de PHP al interior de funciones o métodos de clase. La variable $this es también una variable especial que no puede ser referenciada dinámicamente.


Variables desde fuentes externas

Formularios HTML (GET y POST)

Cuando se envía un formulario a un script de PHP, la información de dicho formulario pasa a estar automáticamente disponible en el script. Existen algunas formas de acceder a esta información, por ejemplo:

Ejemplo #1 Un formulario HTML sencillo

<form action="foo.php" method="post">
    Nombre usuario: <input type="text" name="username" /><br />
    Email:  <input type="text" name="email" /><br />
    <input type="submit" name="submit" value="¡Enviarme!" />
</form>

A partir de PHP 5.4.0, solamente existen dos maneras de acceder a datos desde formularios HTML. Los métodos disponibles actualmente se enumeran a continuación:

Ejemplo #2 Acceso a datos de un formulario HTML sencillo con POST

<?php
echo $_POST['username'];
echo $_REQUEST['username'];
?>

Habían otras formas de acceder a la entrada del usuario en versiones antiguas de PHP. Están enumeradas abajo. Véase el historial de cambios al final para más detalles.

Ejemplo #3 Old methods of accessing user input

<?php
// OJO: estos métodos ya NO ESTÁN soportados.
// Los válidos están descritos arriba.

// Usar import_request_variables() - esta función ha sido eliminada en PHP 5.4.0
   import_request_variables('p', 'p_');
   echo $p_username;

// Estas variables predefinidas fueron eliminadas en PHP 5.4.0
   echo $HTTP_POST_VARS['username'];

// Usar register_globals. Esta característica fue eliminada en PHP 5.4.0
   echo $username;
?>

Usar un formulario con GET es similar excepto en el uso de variables predefinidas, que en este caso serán del tipo GET. GET también se usa con QUERY_STRING (la información despues del símbolo '?' en una URL). Por ejemplo http://www.example.com/test.php?id=3 contiene datos GET que son accesibles con $_GET['id']. Véase también $_REQUEST.

Nota:

Puntos y espacios en nombres de variables son convertidos a guiones bajos. Por ejemplo <input name="a.b" /> se convierte en $_REQUEST["a_b"].

PHP también entiende arrays en el contexto de variables de formularios (vea la faq relacionada). Se puede, por ejemplo, agrupar juntas variables relacionadas o usar esta característica para obtener valores de una entrada "select" múltiple. Por ejemplo, vamos a mandar un formulario a sí mismo y a presentar los datos cuando se reciban:

Ejemplo #4 Variables de formulario más complejas

<?php
if ($_POST) {
    echo '<pre>';
    echo htmlspecialchars(print_r($_POST, true));
    echo '</pre>';
}
?>
<form action="" method="post">
    Nombre:  <input type="text" name="personal[nombre]" /><br />
    Email:   <input type="text" name="personal[email]" /><br />
    Cerveza: <br />
    <select multiple name="cerveza[]">
        <option value="warthog">Warthog</option>
        <option value="guinness">Guinness</option>
        <option value="stuttgarter">Stuttgarter Schwabenbräu</option>
    </select><br />
    <input type="submit" value="¡enviarme!" />
</form>

Nombres de variables tipo IMAGE SUBMIT

Cuando se envía un formulario, es posible usar una imagen en vez del botón estándar "submit":

<input type="image" src="image.gif" name="sub" />

Cuando el usuario hace click en cualquier parte de la imagen, el formulario que la acompaña se transmitirá al servidor con dos variables adicionales, sub_x y sub_y. Éstas contienen las coordenadas del clic del usuario dentro de la imagen. Los más experimentados puede notar que los nombres de variable enviados por el navegador contienen un guión en vez de un subrayado (guión bajo), pero PHP convierte el guión en subrayado automáticamente.

Cookies HTTP

PHP soporta cookies de HTTP de forma transparente tal y como están definidas en » RFC 6265. Las cookies son un mecanismo para almacenar datos en el navegador y así rastrear o identificar a usuarios que vuelven. Se pueden crear cookies usando la función setcookie(). Las cookies son parte de la cabecera HTTP, así que se debe llamar a la función SetCookie antes de que se envíe cualquier salida al navegador. Es la misma restricción que para la función header(). Los datos de una cookie están disponibles en el array de datos de la cookies apropiada, tal como $_COOKIE y $_REQUEST. Véase la página de setcookie() del manual para más detalles y ejemplos.

Si se quieren asignar múltiples valores a una sola cookie, basta con asignarlo como un array. Por ejemplo:

<?php
  setcookie("MiCookie[foo]", 'Prueba 1', time()+3600);
  setcookie("MiCookie[bar]", 'Prueba 2', time()+3600);
?>

Esto creará dos cookies separadas aunque MiCookie será un array simple en el script. Si se quiere definir una sola cookie con valores múltiples, considere el uso de la función serialize() o explode() primero en el valor.

Nótese que una cookie reemplazará a una cookie anterior que tuviese el mismo nombre en el navegador a menos que la ruta o el dominio fuesen diferentes. Así, para una aplicación de carrito de compras se podría querer mantener un contador e ir pasándolo. Es decir:

Ejemplo #5 Un ejemplo de setcookie()

<?php
if (isset($_COOKIE['conteo'])) {
    $conteo = $_COOKIE['conteo'] + 1;
} else {
    $conteo = 1;
}
setcookie('conteo', $conteo, time()+3600);
setcookie("Carrito[$conteo]", $item, time()+3600);
?>

Puntos en los nombres de variables de entrada

Típicamente, PHP no altera los nombres de las variables cuando se pasan a un script. Sin embargo, hay que notar que el punto no es un carácter válido en el nombre de una variable PHP. Para conocer la razón, considere el siguiente ejemplo:

<?php
$varname.ext;  /* nombre de variable inválido */
?>
Lo que el intérprete vé es el nombre de una variable $varname, seguido por el operador de concatenación, y seguido por la cadena pura (es decir, una cadena sin entrecomillar que no coincide con ninguna palabra clave o reservada conocida) 'ext'. Obviamente, no se pretendía que fuese éste el resultado.

Por esta razón, es importante hacer notar que PHP reemplazará automáticamente cualquier punto en los nombres de variables de entrada por guiones bajos (subrayados).

Determinación de los tipos de variables

Dado que PHP determina los tipos de las variables y los convierte (generalmente) según lo que necesita, no siempre resulta obvio de qué tipo es una variable dada en un momento concreto. PHP incluye varias funciones que descubren de qué tipo es una variable: gettype(), is_array(), is_float(), is_int(), is_object(), y is_string(). Vea también el capítulo sobre Tipos.

Historial de cambios

Versión | Descripción
7.2.34, 7.3.23, 7.4.11 | Los nombres de las cookies entrantes ya no son con url-decoded por razones de seguridad.


Constantes

Tabla de contenidos

  • Sintaxis
  • Constantes predefinidas

Una constante es un identificador (nombre) para un valor simple. Como el nombre sugiere, este valor no puede variar durante la ejecución del script (a excepción de las constantes mágicas, que en realidad no son constantes). Por defecto, una constante distingue mayúsculas y minúsculas. Por convención, los identificadores de constantes siempre se declaran en mayúsculas.

El nombre de una constante sigue las mismas reglas que cualquier otra etiqueta de PHP. Un nombre de constante válido empieza por una letra o guion bajo, seguido por cualquier número de letras, números o guiones bajos. Usando una expresión regular, se representaría de la siguiente manera: [a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*

Sugerencia

Vea también Guía de entorno de usuario para nombres.

Ejemplo #1 Nombres de constantes correctos e incorrectos

<?php

// Nombres de constantes correctos
define("FOO",     "something");
define("FOO2",    "something else");
define("FOO_BAR", "something more");

// Nombres de constantes incorrectos
define("2FOO",    "something");

// Esto es válido, pero debe evitarse:
// PHP podría cualquier día proporcionar una constante mágica
// que rompiera el script
define("__FOO__", "something");

?>

Nota: Para nuestros propósitos, una letra está entre los carácteres a-z, A-Z, y los caracteres ASCII del 127 hasta el 255 (0x7f-0xff).

Igual que las superglobals, el acceso a una constante es global. Se puede acceder a constantes desde cualquier sitio del script sin importar desde donde. Para más información en el acceso, lea el manual en la sección acceso a variables.


Sintaxis

Se puede definir una constante usando la función define() o con la palabra reservada const fuera de la definición de una clase a partir PHP 5.3.0. Mientras que define() permite definir una constante con una expresión arbitraria, la palabra reservada const tiene retricciones que se resumen en el siguiente párrafo. Una vez que la constante está definida, no puede ser cambiada o redifinida.

Antes de PHP 5.6, al emplear la palabra reservada const, solamente los datos escalares (boolean, integer, float y string) pueder estar contenidos en constante. Desde PHP 5.6 en adelante, es posible definir una constante como una expresión escalar, y también es posible definir un array constante. Es posible definir constantes como un resource, pero debería evitarse, ya que podría ocasionar resultados inesperados.

Para obtener el valor de una constante solo es necesario especificar su nombre. A diferencia de las variables, no se debe prefijar una constante con el signo $. También se puede usar la función constant() para leer el valor de una constante si se desea obtener el valor de una constante de forma dinámica. Use get_defined_constants() para obtener una lista de todas las constantes definidas.

Nota: Las contantes y las variables (globales) se encuentran en un espacio de nombres distinto. Esto implica que por ejemplo true y $TRUE son diferentes.

Si se usa una constante que todavía no está definida, PHP asume que se está refiriendo al nombre de la constante en si, igual que si fuera una string (CONSTANT vs "CONSTANT"). Cuando esto suceda, se mostrará un error de nivel E_NOTICE. Ver también la sección en el manual de porqué $foo[bar] es incorrecto (a no ser que primero define() bar como constante). Esto no se aplica a las constantes (completamente) cualificadas, lo cual emitirá un error fatal si no está definida. Si simplemente quiere comprobar si una constante está definida, use la función defined().

Estas son las diferencias entre constantes y variables:

  • Las constantes no llevan el signo dólar ($), como prefijo.
  • Antes de PHP 5.3, las constantes solo podían ser definidas usando la función define(), y no por simple asignación.
  • Las constantes pueden ser definidas y accedidas desde cualquier sitio sin importar las reglas de acceso de variables.
  • Las constantes no pueden ser redefinidas o eliminadas una vez se han definido; y
  • Las constantes podrían evaluarse como valores escalares. A partir de PHP 5.6 es posible definir una constante de array con la palabra reservada const, y, a partir de PHP 7, las constantes de array también se pueden definir con define(). Se pueden utilizar arrays en expresiones escalares constantes (por ejemplo, const FOO = array(1,2,3)[0];), aunque el resultado final debe ser un valor de un tipo permitido.

Ejemplo #1 Definición de constantes

<?php
define("CONSTANTE", "Hola mundo.");
echo CONSTANTE; // muestra "Hola mundo."
echo Constante; // muestra "Constant" y se emite un aviso.
?>

Ejemplo #2 Definición de constantes usando el la palabra reservada const

<?php
// Funciona a partir de PHP 5.3.0
const CONSTANTE = 'Hola Mundo';

echo CONSTANTE;

// Funciona a partir de PHP 5.6.0
const OTRA_CONSTANTE = CONSTANTE.'; Adiós Mundo';
echo OTRA_CONSTANTE;

const ANIMALES = array('perro', 'gato', 'pájaro');
echo ANIMALES[1]; // muestra "gato"

// Funciona a partir de PHP 7
define('ANIMALES', array(
    'perro',
    'gato',
    'pájaro'
));
echo ANIMALES[1]; // muestra "gato"
?>

Nota:

A diferencia de definir constantes usando define(), las constantes definidas con la palabra clave const deben declararse en el nivel superior del entorno de la aplicación porque se definen en tiempo de ejecución. Esto significa que no pueden declararse dentro de funciones, bucles, sentencias if o bloques try/ catch.

Vea también Constantes de clase.


Constantes predefinidas

PHP ofrece un gran número de constantes predefinidas a cualquier script en ejecucción. Muchas de estas constantes, sin embargo, son creadas por diferentes extensiones, y sólo estarán presentes si dichas extensiones están disponibles, bien por carga dinámica o porque han sido compiladas.

Hay nueve constantes mágicas que cambian dependiendo de dónde se emplean. Por ejemplo, el valor de __LINE__ depende de la línea en que se use en el script. Todas estas constantes «mágicas» se resuelven durante la compilación, a diferencia de las constantes normales que lo hacen durante la ejecución. Estas constantes especiales son sensibles a mayúsculas Estas constantes especiales distinguen mayúsculas y minúsculas, y son las siguientes:

Varias constantes "mágicas" de PHP
Nombre | Descripción
__LINE__ | El número de línea actual en el fichero.
__FILE__ | Ruta completa y nombre del fichero con enlaces simbólicos resueltos. Si se usa dentro de un include, devolverá el nombre del fichero incluido.
__DIR__ | Directorio del fichero. Si se utiliza dentro de un include, devolverá el directorio del fichero incluído. Esta constante es igual que dirname(__FILE__). El nombre del directorio no lleva la barra final a no ser que esté en el directorio root.
__FUNCTION__ | Nombre de la función.
__CLASS__ | Nombre de la clase. El nombre de la clase incluye el namespace declarado en (p.e.j. Foo\Bar). Tenga en cuenta que a partir de PHP 5.4 __CLASS__ también funciona con traits. Cuando es usado en un método trait, __CLASS__ es el nombre de la clase del trait que está siendo utilizado.
__TRAIT__ | El nombre del trait. El nombre del trait incluye el espacio de nombres en el que fue declarado (p.e.j. Foo\Bar).
__METHOD__ | Nombre del método de la clase.
__NAMESPACE__ | Nombre del espacio de nombres actual.
ClassName::class | El nombre de clase completamente cualificado. Véase también ::class.

Véase también
get_class(),
get_object_vars(),
file_exists() y
function_exists().

Historial de cambios

Versión | Descripción
5.5.0 | Se añadió la constante mágica ::class
5.4.0 | Se añadió la constante __TRAIT__
5.3.0 | Se añadieron las constantes __DIR__ y __NAMESPACE__
5.0.0 | Se añadió la constante __METHOD__
5.0.0 | Antes de esta versión, los valores de algunas constantes mágicas estaban siempre en minúsculas. Ahora todas ellas están en mayúsculas (contienen nombres mientras eran declaradas).
4.3.0 | Se añadieron las constantes __FUNCTION__ y __CLASS__
4.0.2 | __FILE__ siempre contiene una ruta absoluta con enlaces simbólicos resueltos, mientras que en versiones antiguas contenía una ruta relativa bajo algunas circunstancias


Expresiones

La expresiones son los bloques de construcción más importantes de PHP. En PHP casi todo lo que se escribe es una expresión. La manera más simple y acertada de definir lo que es una expresión es «cualquier cosa que tiene un valor».

Las formas más básicas de expresiones son las constantes y las variables. Cuando se escribe "$a = 5", se está asignando '5' a $a. '5', obviamente, tiene el valor 5, o en otras palabras, '5' es una expresión con el valor de 5 (en este caso, '5' es una constante entera).

Después de esta asignación, se espera que el valor de $a sea 5 también, por lo que si se escribe $b = $a, se espera que esto se comporte tal como si se escribiera $b = 5. En otras palabras, $a es también una expresión con el valor 5. Si todo funciona bien, esto es exactamente lo que sucederá.

Un ejemplo de expresiones algo más complejo son las funciones. Por ejemplo, considere la siguiente función:

<?php
function foo ()
{
    return 5;
}
?>

Asumiendo que está familiarizado con el concepto de función (si no lo está, échele una ojeada al capítulo sobre funciones), asumirá que escribir $c = foo() es esencialmente igual que escribir $c = 5. Y está en lo cierto. Las funciones son expresiones con el valor de sus valores devueltos. Ya que foo() devuelve 5, el valor de la expresión 'foo()' es 5. Normalmente las funciones no sólo devuelven un valor estático, sino que computan algo.

Por supuesto, los valores en PHP no tienen que ser enteros, y con frecuencia no lo son. PHP soporta cuatro tipos de valores escalares: valores enteros (integer), valores de coma (punto) flotante (float), valores de cadena (string) y valores booleanos (boolean) - (valores escalares son aquellos que no se pueden descomponer en piezas más pequeñas, a diferencia de las matrices, por ejemplo). PHP también soporta dos tipos compuestos (no escalares): matrices (arrays) y objetos. Cada uno de estos tipos de valores pueden ser asignados a variables o devueltos desde funciones.

PHP lleva las expresiones mucho más allá, de la misma manera que lo hacen otros lenguajes. PHP es un lenguaje orientado a expresiones, en el sentido de que casi todo es una expresión. Considere el ejemplo que ya hemos tratado, '$a = 5'. Es fácil de ver que aquí hay dos valores involucrados, el valor de la constante entera '5', y el valor de $a que ha sido actualizado a 5 también. Aunque la verdad es que existe aquí un valor adicional involucrado, que es el valor de la asignación misma. La asignación evalúa al valor asignado, en este caso 5. En la práctica, esto significa que '$a = 5', sin importar lo que haga, es una expresión con el valor 5. De este modo, escribir algo como '$b = ($a = 5)' es igual que escribir '$a = 5; $b = 5;' (el punto y coma marca el final de una sentencia). Ya que las asignaciones se analizan de derecha a izquierda, también se puede escribir '$b = $a = 5'.

Otro buen ejemplo de orientación a expresiones es el pre- y post-incremento y decremento. Los usuarios de PHP y de otros muchos lenguajes pueden estar familiarizados con la notación variable++ y variable--. Éstos son los operadores de incremento y decremento. En PHP, al igual que en C, hay dos tipos de incrementos - pre-incremento y post-incremento. Ambos esencialmente incrementan la variable, y el efecto sobre la variable es idéntico. La diferencia está con el valor de la expresión de incremento. Pre-incremento, que se escribre '++$variable', evalúa al valor incrementado (PHP incrementa la variable antes de leer su valor, de ahí el nombre de 'pre-incremento'). Post-incremento, que se escribe '$variable++' evalúa el valor original de $variable, antes de que sea incrementado (PHP incrementa la variable después de leer su valor, de ahí el nombre de 'post-incremento').

Un tipo de expresiones muy comunes son las expresiones de comparación. Estas expresiones evalúan si algo es false (falso) o true (verdadero). PHP soporta > (mayor que), >= (mayor o igual que), == (igual), != (distinto), < (menor que) y <= (menor o igual que). El lenguaje también soporta un conjunto de operadores de equivalencia estricta: === (igual y del mismo tipo) y !== (diferente o de distinto tipo). Estas expresiones se usan mayormente dentro de ejecuciones condicionales, tales como la sentencia if.

El último ejemplo de expresiones que trataremos aquí es una combinación de expresiones operador-asignación. Ya sabe que si quiere incrementar $a en 1, puede simplemente escribir '$a++' o '++$a'. Pero si lo que quiere es añadirle más de uno, por ejemplo 3, podría escribir '$a++' varias veces, pero esto, obviamente, no es una manera muy eficiente o cómoda. Una práctica mucho más común es escribir '$a = $a + 3'. '$a + 3' evalúa al valor de $a más 3, y se vuelve a asignar a $a, lo que resulta en incrementar $a en 3. En PHP, como en otros lenguajes como C, se puede escribir esto de una manera más abreviada, lo que con el tiempo se podría convertir en una forma más clara y rápida de entenderlo. Añadir 3 al valor actual de $a puede ser escrito '$a += 3'. Esto significa exactamente "toma el valor de $a, añádele 3 y asígnalo de nuevo a $a". Además de ser más corto y claro, también resulta en una ejecución más rápida. El valor de '$a += 3', al igual que el valor de una asignación normal, es el valor asignado. Observe que NO es 3, sino el valor combinado de $a más 3 (éste es el valor que es asignado a $a). Se puede usar cualquier operador compuesto de dos partes en este modo de operador-asignación, por ejemplo '$a -= 5' (restar 5 del valor de $a), '$b *= 7' (multiplicar el valor de $b por 7), etc.

Existe una expresión más que le puede parecer rara si no la ha visto en otros lenguajes, el operador condicional ternario:

<?php
$primero ? $segundo : $tercero
?>

Si el valor de la primera subexpresión es true (no es cero), se evalúa la segunda subexpresión, y ése será el resultado de la expresión condicional. Si no, se evalúa la tercera subexpresión, y ése será el valor.

El siguiente ejemplo debería ayudarle a comprender un poco mejor el pre- y post-incremento y las expresiones en general:

<?php
function doble($i)
{
    return $i*2;
}
$b = $a = 5;        /* asignar el valor cinco a la variable $a y $b */
$c = $a++;          /* post-incremento, asignar el valor original de $a
                       (5) a $c */
$e = $d = ++$b;     /* pre-incremento, asignar el valor incrementado de
                       $b (6) a $d y $e */

/* en este punto, $d y $e son iguales a 6 */

$f = doble($d++);  /* asignar el doble del valor de $d antes
                       del incremento, 2*6 = 12, a $f */
$g = doble(++$e);  /* asignar el doble del valor de $e después
                       del incremento, 2*7 = 14, a $g */
$h = $g += 10;      /* primero, $g es incrementado en 10 y finaliza con el
                       valor 24. El valor de la asignación (24) es
                       asignado después a $h, y $h finaliza también con el
                       valor 24. */
?>

Algunas expresiones pueden considerarse como sentencias. En este caso, una sentencia tiene la forma 'expr ;', es decir, una expresión seguida de un punto y coma. En '$b = $a = 5;', '$a = 5' es una expresión válida, pero no es una sentencia en sí. Sin embargo, '$b = $a = 5;' es una sentencia válida.

Lo último que vale la pena mencionar es el valor verdadero de las expresiones. En muchos casos, principalmente en ejecuciones condicionales y bucles, no interesa saber el valor específico de la expresión, sino sólo si el valor significa true o false. Las constantes true y false (insensible a mayúsculas-minúsculas) son los dos valores booleanos posibles. Cuando es necesario, una expresión es convertida automáticamente al tipo boolean. Véase la sección sobre conversión de tipos para más detalles.

PHP proporciona una implementación completa y potente de expresiones, y documentarla por completo va más allá del ámbito de este manual. Los ejemplos de arriba deberían darle una buena idea de lo que son las expresiones y cómo construir expresiones útiles. Durante el resto de este manual se escribirá expr para indicar cualquier expresión de PHP válida.


Operadores

Tabla de contenidos

  • Precedencia de operadores
  • Operadores aritméticos
  • Operadores de asignación
  • Operadores bit a bit
  • Operadores de comparación
  • Operadores de control de errores
  • Operadores de ejecución
  • Operadores de incremento/decremento
  • Operadores lógicos
  • Operadores para strings
  • Operadores para arrays
  • Operadores de tipo

Un operador es algo que toma uno más valores (o expresiones, en la jerga de programación) y produce otro valor (de modo que la construcción en si misma se convierte en una expresión).

Los operadores se pueden agrupar de acuerdo con el número de valores que toman. Los operadores unarios toman sólo un valor, por ejemplo ! (el operador lógico de negación) o ++ (el operador de incremento). Los operadores binarios toman dos valores, como los familiares operadores aritméticos + (suma) y - (resta), y la mayoría de los operadores de PHP entran en esta categoría. Finalmente, hay sólo un operador ternario, ? :, el cual toma tres valores; usualmente a este se le refiere simplemente como "el operador ternario" (aunque podría tal vez llamarse más correctamente como el operador condicional).

Una lista completa de operadores de PHP sigue en la sección Precedencia de Operadores. La sección también explica la precedencia y asociatividad de los operadores, las cuales gobiernan exactamente cómo son evaluadas expresiones que contienen varios diferentes operadores.


Precedencia de operadores

La precedencia de un operador indica qué tan "estrechamente" se unen dos expresiones juntas. Por ejemplo, en la expresión 1 + 5 * 3 , la respuesta es 16 y no 18 porque el operador de multiplicación ("*") tiene una precedencia mayor que el operador de adición ("+"). Los paréntesis pueden ser usados para forzar la precedencia, si es necesario. Por ejemplo: (1 + 5) * 3 se evalúa como 18.

Cuando los operadores tienen igual precedencia su asociatividad decide cómo se agrupan. Por ejemplo "-" tiene asociatividad a izquierda, así 1 - 2 - 3 se agrupa como (1 - 2) - 3 y se evalúa a -4. "=", por otra parte, tiene asociatividad a derecha, así $a = $b = $c se agrupa como $a = ($b = $c).

Los operadores de igual precedencia que no son asociativos no pueden usarse unos junto a otros, por ejemplo, 1 < 2 > 1 es ilegal en PHP. La expresión 1 <= 1 == 1, por otro lado, es legal, ya que el operador == tiene menos precedencia que el operador <=.

El uso de paréntesis, incluso cuando no es estrictamente necesario, a menudo puede aumentar la legibilidad del código haciendo grupos explícitamente en lugar de confiar en la precedencia y asociatividad implícitas del operador.

La siguiente tabla enumera los operadores en orden de precedencia, con los de más alta precedencia al inicio. Los operadores en la misma línea tienen igual precedencia, en cuyo caso la asociatividad decide el agrupamiento.

Precedencia de operadores
Asociatividad | Operadores | Información adicional
no asociativo | clone new | clone and new
izquierda | [ | array()
derecha | ** | aritmética
derecha | ++ -- ~ (int) (float) (string) (array) (object) (bool) @ | tipos e incremento/decremento
no asociativo | instanceof | tipos
derecha | ! | lógico
izquierda | * / % | aritmética
izquierda | + - . | aritmética y string
izquierda | << >> | bit a bit
no asociativo | < <= > >= | comparación
no asociativo | == != === !== <> <=> | comparación
izquierda | & | bit a bit y referencias
izquierda | ^ | bit a bit
izquierda | | | bit a bit
izquierda | && | lógico
izquierda | || | lógico
derecha | ?? | comparación
izquierda | ? : | ternario
derecha | = += -= *= **= /= .= %= &= |= ^= <<= >>= | asignación
izquierda | and | lógico
izquierda | xor | lógico
izquierda | or | lógico

Ejemplo #1 Asociatividad

<?php
$a = 3 * 3 % 5; // (3 * 3) % 5 = 4
// la asociatividad del operador ternario difiere de C/C++
$a = true ? 0 : true ? 1 : 2; // (true ? 0 : true) ? 1 : 2 = 2

$a = 1;
$b = 2;
$a = $b += 3; // $a = ($b += 3) -> $a = 5, $b = 5
?>

La precedencia y asociatividad de los operadores solamente determinan cómo se agrupan las expresiones, no especifican un orden de evaluación. PHP no especifica (en general) el orden en que se evalúa una expresión y se debería evitar el código que se asume un orden específico de evaluación, ya que el comportamiento puede cambiar entre versiones de PHP o dependiendo de código circundante.

Ejemplo #2 Orden de evaluación no definido

<?php
$a = 1;
echo $a + $a++; // podría mostrar 2 o 3

$i = 1;
$array[$i] = $i++; // podría establecer el índice a 1 o 2
?>

Ejemplo #3 +, - y . tienen la misma precedencia

<?php
$x = 4;
// esta línea podría resultar en una salida inesperada:
echo "x menos uno igual a " . $x-1 . ", o eso espero\n";
// ya que se evalúa como esta línea:
echo (("x menos uno igual a " . $x) - 1) . ", o eso espero\n";
// la precedencia deseada se puede forzar con paréntesis:
echo "x menos uno igual a " . ($x-1) . ", o eso espero\n";
?>

El resultado del ejemplo sería:

-1, o eso espero
-1, o eso espero
x menos uno igual a 3, o eso espero

Nota:

Aunque = tiene una precedencia menor que la mayoría de los demás operadores, PHP aun permitirá expresiones similares a lo siguiente: if (!$a = foo()), en cuyo caso el valor devuelto de foo() es puesto en $a.


Operadores aritméticos

¿Recuerda la aritmética básica de la escuela? Estos funcionan igual que aquellos.

Operadores aritméticos
Ejemplo | Nombre | Resultado
+$a | Identidad | Conversión de $a a int o float según el caso.
-$a | Negación | Opuesto de $a.
$a + $b | Adición | Suma de $a y $b.
$a - $b | Sustracción | Diferencia de $a y $b.
$a * $b | Multiplicación | Producto de $a y $b.
$a / $b | División | Cociente de $a y $b.
$a % $b | Módulo | Resto de $a dividido por $b.
$a ** $b | Exponenciación | Resultado de elevar $a a la potencia $bésima. Introducido en PHP 5.6.

El operador de división ("/") devuelve un valor flotante a menos que los dos operandos sean integers (o strings que se conviertan a integers) y los números sean divisibles, en cuyo caso será devuelto un valor integer.

Los operandos del módulo se convierten en integers (por extracción de la parte decimal) antes del procesamiento.

El resultado del operador módulo % tiene el mismo signo que el dividendo — es decir, el resultado de $a % $b tendrá el mismo signo que $a. Por ejemplo:

<?php

echo (5 % 3)."\n";           // muestra 2
echo (5 % -3)."\n";          // muestra 2
echo (-5 % 3)."\n";          // muestra -2
echo (-5 % -3)."\n";         // muestra -2

?>

Véase también la página del manual sobre funciones matemáticas.


Operadores de asignación

El operador básico de asignación es "=". Se podría inclinar a pensar primero que es como un "igual a". No lo es. Realmente significa que el operando de la izquierda se establece con el valor de la expresión de la derecha (es decir, "se define como").

El valor de una expresión de asignación es el valor asignado. Es decir, el valor de "$a = 3" es de 3. Esto permite hacer algunas cosas intrincadas:

<?php

$a = ($b = 4) + 5; // ahora $a es igual a 9 y $b se ha establecido en 4.

?>

Además del operador básico de asignación, existen «operadores combinados» para todos los de aritmética binaria, unión de arrays y operadores de strings que permiten usar un valor en una expresión y entonces establecer su valor como el resultado de esa expresión. Por ejemplo:

<?php

$a = 3;
$a += 5; // establece $a en 8, como si se hubiera dicho: $a = $a + 5;
$b = "Hola ";
$b .= "ahí!"; // establece $b en "Hola ahí!", al igual que $b = $b . "ahí!";

?>

Observe que la asignación copia la variable original en la nueva (asignación por valor), por lo que los cambios en una no afectarán a la otra. Esto también puede tener relevancia si se necesita copiar algo como un gran array dentro de un bucle estrecho.

Una excepción al comportamiento usual de la asignación por valor en PHP ocurre con objects los cuales son asignados por referencia en PHP 5. Los objetos pueden ser explícitamente copiados por medio de la palabra clave clone.

Asignación por referencia

La asignación por referencia también está soportada, utilizando la sintaxis "$var = &$othervar;". Asignación por referencia significa que ambas variables terminan apuntando a los mismos datos y nada es copiado en ninguna parte.

Ejemplo #1 Asignación por referencia

<?php
$a = 3;
$b = &$a; // $b es una referencia para $a

print "$a\n"; // muestra 3
print "$b\n"; // muestra 3

$a = 4; // cambia $a

print "$a\n"; // muestra 4
print "$b\n"; // muestra 4 también, dado que $b es una referencia para $a, la cual ha
              // sido cambiada
?>

Desde PHP 5, el operador new retorna una referencia automáticamente, así que asignar el resultado de new por referencia, resulta en un mensaje E_DEPRECATED en PHP 5.3 y posteriores y un mensaje E_STRICT en versiones anteriores.

Por ejemplo, éste código resultará en una advertencia:

<?php
class C {}

/* La siguiente línea genera el siguiente mensaje de error:
 * Deprecated: Assigning the return value of new by reference is deprecated in...
 */
$o = &new C;
?>

Más información sobre referencias y sus usos potenciales se puede encontrar en la sección del manual Referencias Explicadas


Operadores bit a bit

Los operadores bit a bit permiten la evaluación y la manipulación de bits específicos dentro de un integer.

Operadores bit a bit
Ejemplo | Nombre | Resultado
$a & $b | And (y) | Los bits que están activos en ambos $a y $b son activados.
$a | $b | Or (o inclusivo) | Los bits que están activos ya sea en $a o en $b son activados.
$a ^ $b | Xor (o exclusivo) | Los bits que están activos en $a o en $b, pero no en ambos, son activados.
~ $a | Not (no) | Los bits que están activos en $a son desactivados, y viceversa.
$a << $b | Shift left(desplazamiento a izquierda) | Desplaza los bits de $a, $b pasos a la izquierda (cada paso quiere decir "multiplicar por dos").
$a >> $b | Shift right (desplazamiento a derecha) | Desplaza los bits de $a, $b pasos a la derecha (cada paso quiere decir "dividir por dos").

El desplazamiento de bits en PHP es aritmético. Los bits desplazados por fuera de cualquiera de los extremos son descartados. Desplazamientos de izquierda tienen ceros desplazados a la derecha mientras que el bit de signo es desplazado fuera a la izquierda, es decir que no se conserva el signo de un operando. Desplazamientos a la derecha tienen copias del bit de signo desplazado a la izquierda, es decir que se conserva el signo de un operando.

Utilice paréntesis para garantizar la precedencia deseada. Por ejemplo, $a & $b == true evalúa la equivalencia y luego el bit a bit, mientras que ($a & $b) == true evalúa el bit a bit y luego la equivalencia.

Si los operandos para los operadores &, | y ^ son string, la operación se realizará con los valores ASCII de los caracteres que componen dichos string, y el resultado será también un string. En todos los demás casos, ambos operandos serán convertidos a valores de tipo integer y el resultado será también un integer.

Si el operando del operados ~ es un string, la operación se realizará con valores los ASCII de los caracteres que componen dicho string, y el resultado también será un string; en caso contrario, el operando y el resultado serán tratados como valores de tipo integer.

Ambos operandos y el resultado de lo operadores << y >> siempre son tratados como valores de tipo integer.

      El ajuste ini error_reporting utiliza valores a nivel de bit,
      lo que ofrece una demostración del mundo real de desactivar
      bits. Para mostrar todos los errores, a excepción de los avisos,
      las instrucciones del archivo php.ini dicen utilizar:
      E_ALL & ~E_NOTICE

      Esto funciona iniciando con E_ALL:
      00000000000000000111011111111111
      Luego se toma el valor de E_NOTICE ...
      00000000000000000000000000001000
      ... y se invierte por medio de ~:
      11111111111111111111111111110111
      Finalmente, se utiliza AND (&) para encontrar los bits que se
      activaron en ambos valores:
      00000000000000000111011111110111

      Otra forma de lograrlo es mediante XOR (^)
      para encontrar los bits que están activados en sólo el primer valor o en el otro:
      E_ALL ^ E_NOTICE

      error_reporting también se puede utilizar para demostrar la activación de bits.
      La forma para mostrar sólo los errores y los errores recuperables es:
      E_ERROR | E_RECOVERABLE_ERROR

      Este proceso combina E_ERROR
      00000000000000000000000000000001
      y
      00000000000000000001000000000000
      usando el operador OR (|)
      para obtener los bits activados en cualquiera de estos valores:
      00000000000000000001000000000001

Ejemplo #1 Operaciones AND, OR y XOR bit a bit sobre integers

<?php
/*
 * Ignore la sección superior,
 * es sólo el formateado para hacer la salida más clara.
 */

$format = '(%1$2d = %1$04b) = (%2$2d = %2$04b)'
        . ' %3$s (%4$2d = %4$04b)' . "\n";

echo <<<EOH
 ---------     ---------  -- ---------
 resultado     valor      op prueba
 ---------     ---------  -- ---------
EOH;

/*
 * Aquí están los ejemplos.
 */

$values = array(0, 1, 2, 4, 8);
$test = 1 + 4;

echo "\n AND bit a bit \n";
foreach ($values as $value) {
    $result = $value & $test;
    printf($format, $result, $value, '&', $test);
}

echo "\n OR inclusivo bit a bit \n";
foreach ($values as $value) {
    $result = $value | $test;
    printf($format, $result, $value, '|', $test);
}

echo "\n OR exclusivo (XOR) bit a bit \n";
foreach ($values as $value) {
    $result = $value ^ $test;
    printf($format, $result, $value, '^', $test);
}
?>

El resultado del ejemplo sería:

 ---------     ---------  -- ---------
 resultado     valor      op prueba
 ---------     ---------  -- ---------
 AND bit a bit
( 0 = 0000) = ( 0 = 0000) & ( 5 = 0101)
( 1 = 0001) = ( 1 = 0001) & ( 5 = 0101)
( 0 = 0000) = ( 2 = 0010) & ( 5 = 0101)
( 4 = 0100) = ( 4 = 0100) & ( 5 = 0101)
( 0 = 0000) = ( 8 = 1000) & ( 5 = 0101)

 OR inclusivo bit a bit
( 5 = 0101) = ( 0 = 0000) | ( 5 = 0101)
( 5 = 0101) = ( 1 = 0001) | ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) | ( 5 = 0101)
( 5 = 0101) = ( 4 = 0100) | ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) | ( 5 = 0101)

 OR exclusivo (XOR) bit a bit
( 5 = 0101) = ( 0 = 0000) ^ ( 5 = 0101)
( 4 = 0100) = ( 1 = 0001) ^ ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) ^ ( 5 = 0101)
( 1 = 0001) = ( 4 = 0100) ^ ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) ^ ( 5 = 0101)

Ejemplo #2 Operaciones XOR bit a bit sobre strings

<?php
echo 12 ^ 9; // Sale '5'

echo "12" ^ "9"; // Sale el caracter de retroceso (ascii 8)
                 // ('1' (ascii 49)) ^ ('9' (ascii 57)) = #8

echo "hallo" ^ "hello"; // Salen los valores ascii #0 #4 #0 #0 #0
                        // 'a' ^ 'e' = #4

echo 2 ^ "3"; // Sale 1
              // 2 ^ ((int)"3") == 1

echo "2" ^ 3; // Sale 1
              // ((int)"2") ^ 3 == 1
?>

Ejemplo #3 Desplazamiento de bits sobre integers

<?php
/*
 * Aquí están los ejemplos.
 */

echo "\n--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS POSITIVOS ---\n";

$val = 4;
$places = 1;
$res = $val >> $places;
p($res, $val, '>>', $places, 'copia del bit de signo desplazado hacia el lado izquierdo');

$val = 4;
$places = 2;
$res = $val >> $places;
p($res, $val, '>>', $places);

$val = 4;
$places = 3;
$res = $val >> $places;
p($res, $val, '>>', $places, 'bits desplazados fuera del lado derecho');

$val = 4;
$places = 4;
$res = $val >> $places;
p($res, $val, '>>', $places, 'mismo resultado que arriba; no se puede desplazar más allá del 0');

echo "\n--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS NEGATIVOS ---\n";

$val = -4;
$places = 1;
$res = $val >> $places;
p($res, $val, '>>', $places, 'copia del bit de signo desplazado al lado izquierdo');

$val = -4;
$places = 2;
$res = $val >> $places;
p($res, $val, '>>', $places, 'bits desplazados fuera del lado derecho');

$val = -4;
$places = 3;
$res = $val >> $places;
p($res, $val, '>>', $places, 'mismo resultado que arriba; no se puede desplazar más allá del -1');

echo "\n--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS POSITIVOS ---\n";

$val = 4;
$places = 1;
$res = $val << $places;
p($res, $val, '<<', $places, 'ceros rellenan en el lado derecho');

$val = 4;
$places = (PHP_INT_SIZE * 8) - 4;
$res = $val << $places;
p($res, $val, '<<', $places);

$val = 4;
$places = (PHP_INT_SIZE * 8) - 3;
$res = $val << $places;
p($res, $val, '<<', $places, 'bit de signo resulta desplazado fuera');

$val = 4;
$places = (PHP_INT_SIZE * 8) - 2;
$res = $val << $places;
p($res, $val, '<<', $places, 'bit de signo desplazado fuera del lado izquierdo');

echo "\n--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS NEGATIVOS ---\n";

$val = -4;
$places = 1;
$res = $val << $places;
p($res, $val, '<<', $places, 'ceros rellenan en el lado derecho');

$val = -4;
$places = (PHP_INT_SIZE * 8) - 3;
$res = $val << $places;
p($res, $val, '<<', $places);

$val = -4;
$places = (PHP_INT_SIZE * 8) - 2;
$res = $val << $places;
p($res, $val, '<<', $places, 'bits desplazados fuera del lado izquierdo, incluyendo el bit de signo');

/*
 * Ignore this bottom section,
 * it is just formatting to make output clearer.
 */

function p($res, $val, $op, $places, $note = '') {
    $format = '%0' . (PHP_INT_SIZE * 8) . "b\n";

    printf("Expression: %d = %d %s %d\n", $res, $val, $op, $places);

    echo " Decimal:\n";
    printf("  val=%d\n", $val);
    printf("  res=%d\n", $res);

    echo " Binary:\n";
    printf('  val=' . $format, $val);
    printf('  res=' . $format, $res);

    if ($note) {
        echo " NOTE: $note\n";
    }

    echo "\n";
}
?>

El resultado del ejemplo en equipos de 32 bit sería:

--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS POSITIVOS ---
Expression: 2 = 4 >> 1
 Decimal:
  val=4
  res=2
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000010
 NOTE: copia del bit de signo desplazado hacia el lado izquierdo

Expression: 1 = 4 >> 2
 Decimal:
  val=4
  res=1
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000001

Expression: 0 = 4 >> 3
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: bits desplazados fuera del lado derecho

Expression: 0 = 4 >> 4
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: mismo resultado que arriba; no se puede desplazar más allá del 0

--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS NEGATIVOS ---
Expression: -2 = -4 >> 1
 Decimal:
  val=-4
  res=-2
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111110
 NOTE: copia del bit de signo desplazado al lado izquierdo

Expression: -1 = -4 >> 2
 Decimal:
  val=-4
  res=-1
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111111
 NOTE: bits desplazados fuera del lado derecho

Expression: -1 = -4 >> 3
 Decimal:
  val=-4
  res=-1
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111111
 NOTE: mismo resultado que arriba; no se puede desplazar más allá del -1

--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS POSITIVOS ---
Expression: 8 = 4 << 1
 Decimal:
  val=4
  res=8
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000001000
 NOTE: ceros rellenan en el lado derecho

Expression: 1073741824 = 4 << 28
 Decimal:
  val=4
  res=1073741824
 Binary:
  val=00000000000000000000000000000100
  res=01000000000000000000000000000000

Expression: -2147483648 = 4 << 29
 Decimal:
  val=4
  res=-2147483648
 Binary:
  val=00000000000000000000000000000100
  res=10000000000000000000000000000000
 NOTE: bit de signo resulta desplazado fuera

Expression: 0 = 4 << 30
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: bit de signo desplazado fuera del lado izquierdo

--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS NEGATIVOS ---
Expression: -8 = -4 << 1
 Decimal:
  val=-4
  res=-8
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111000
 NOTE: ceros rellenan en el lado derecho

Expression: -2147483648 = -4 << 29
 Decimal:
  val=-4
  res=-2147483648
 Binary:
  val=11111111111111111111111111111100
  res=10000000000000000000000000000000

Expression: 0 = -4 << 30
 Decimal:
  val=-4
  res=0
 Binary:
  val=11111111111111111111111111111100
  res=00000000000000000000000000000000
 NOTE: bits desplazados fuera del lado izquierdo, incluyendo el bit de signo

El resultado del ejemplo en equipos de 64 bit sería:

--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS POSITIVOS ---
Expression: 2 = 4 >> 1
 Decimal:
  val=4
  res=2
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000010
 NOTE: copia del bit de signo desplazado hacia el lado izquierdo

Expression: 1 = 4 >> 2
 Decimal:
  val=4
  res=1
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000001

Expression: 0 = 4 >> 3
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bits desplazados fuera del lado derecho

Expression: 0 = 4 >> 4
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: mismo resultado que arriba; no se puede desplazar más allá del 0

--- DESPLAZAMIENTO DE BITS A LA DERECHA SOBRE ENTEROS NEGATIVOS ---
Expression: -2 = -4 >> 1
 Decimal:
  val=-4
  res=-2
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111110
 NOTE: copia del bit de signo desplazado al lado izquierdo

Expression: -1 = -4 >> 2
 Decimal:
  val=-4
  res=-1
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111111
 NOTE: bits desplazados fuera del lado derecho

Expression: -1 = -4 >> 3
 Decimal:
  val=-4
  res=-1
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111111
 NOTE: mismo resultado que arriba; no se puede desplazar más allá del -1

--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS POSITIVOS ---
Expression: 8 = 4 << 1
 Decimal:
  val=4
  res=8
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000001000
 NOTE: ceros rellenan en el lado derecho

Expression: 4611686018427387904 = 4 << 60
 Decimal:
  val=4
  res=4611686018427387904
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0100000000000000000000000000000000000000000000000000000000000000

Expression: -9223372036854775808 = 4 << 61
 Decimal:
  val=4
  res=-9223372036854775808
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=1000000000000000000000000000000000000000000000000000000000000000
 NOTE: bit de signo resulta desplazado fuera

Expression: 0 = 4 << 62
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bit de signo desplazado fuera del lado izquierdo

--- DESPLAZAMIENTO DE BITS A LA IZQUIERDA SOBRE ENTEROS NEGATIVOS ---
Expression: -8 = -4 << 1
 Decimal:
  val=-4
  res=-8
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111000
 NOTE: ceros rellenan en el lado derecho

Expression: -9223372036854775808 = -4 << 61
 Decimal:
  val=-4
  res=-9223372036854775808
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1000000000000000000000000000000000000000000000000000000000000000

Expression: 0 = -4 << 62
 Decimal:
  val=-4
  res=0
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bits desplazados fuera del lado izquierdo, incluyendo el bit de signo

Advertencia

Desplazar un integer por valores mayores o iguales al ancho del tipo long integer del sistema resultará en un comportamiento indefinido. En otras palabras, no desplace más de 31 bit en sistemas de 32 bit, y no desplace más de 63 bit en sistemas de 64 bit.

Use funciones de la extensión gmp para manipular a nivel de bit números mayores que PHP_INT_MAX.

Ver también
pack(),
unpack(),
gmp_and(),
gmp_or(),
gmp_xor(),
gmp_testbit(),
gmp_clrbit()


Operadores de comparación

Los operadores de comparación, como su nombre lo indica, permiten comparar dos valores. Puede también estar interesado en ver las tablas de comparación de tipos, ya que muestran ejemplos de las varias comparaciones relacionadas con tipos.

Operadores de comparación
Ejemplo | Nombre | Resultado
$a == $b | Igual | true si $a es igual a $b después de la manipulación de tipos.
$a === $b | Idéntico | true si $a es igual a $b, y son del mismo tipo.
$a != $b | Diferente | true si $a no es igual a $b después de la manipulación de tipos.
$a <> $b | Diferente | true si $a no es igual a $b después de la manipulación de tipos.
$a !== $b | No idéntico | true si $a no es igual a $b, o si no son del mismo tipo.
$a < $b | Menor que | true si $a es estrictamente menor que $b.
$a > $b | Mayor que | true si $a es estrictamente mayor que $b.
$a <= $b | Menor o igual que | true si $a es menor o igual que $b.
$a >= $b | Mayor o igual que | true si $a es mayor o igual que $b.
$a <=> $b | Nave espacial | Un integer menor que, igual a, o mayor que cero cuando $a es respectivamente menor que, igual a, o mayor que $b. Disponible a partir de PHP 7.
$a ?? $b ?? $c | Fusión de null | El primer operando de izquierda a derecha que exista y no sea null. null si no hay valores definidos y no son null. Disponible a partir de PHP 7.

Si se compara un número con un string o la comparación implica strings numéricos, entonces cada string es convertido en un número y la comparación realizada numéricamente. Estas reglas también se aplican a la sentencia switch. La conversión de tipo no tiene lugar cuando la comparación es === o !== ya que esto involucra comparar el tipo así como el valor.

<?php
var_dump(0 == "a"); // 0 == 0 -> true
var_dump("1" == "01"); // 1 == 1 -> true
var_dump("10" == "1e1"); // 10 == 10 -> true
var_dump(100 == "1e2"); // 100 == 100 -> true

switch ("a") {
case 0:
    echo "0";
    break;
case "a": // nunca alcanzado debido a que "a" ya ha coincidido con 0
    echo "a";
    break;
}
?>
<?php
// Integers
echo 1 <=> 1; // 0
echo 1 <=> 2; // -1
echo 2 <=> 1; // 1

// Floats
echo 1.5 <=> 1.5; // 0
echo 1.5 <=> 2.5; // -1
echo 2.5 <=> 1.5; // 1

// Strings
echo "a" <=> "a"; // 0
echo "a" <=> "b"; // -1
echo "b" <=> "a"; // 1

echo "a" <=> "aa"; // -1
echo "zz" <=> "aa"; // 1

// Arrays
echo [] <=> []; // 0
echo [1, 2, 3] <=> [1, 2, 3]; // 0
echo [1, 2, 3] <=> []; // 1
echo [1, 2, 3] <=> [1, 2, 1]; // 1
echo [1, 2, 3] <=> [1, 2, 4]; // -1

// Objects
$a = (object) ["a" => "b"];
$b = (object) ["a" => "b"];
echo $a <=> $b; // 0

$a = (object) ["a" => "b"];
$b = (object) ["a" => "c"];
echo $a <=> $b; // -1

$a = (object) ["a" => "c"];
$b = (object) ["a" => "b"];
echo $a <=> $b; // 1

// only values are compared
$a = (object) ["a" => "b"];
$b = (object) ["b" => "b"];
echo $a <=> $b; // 1

?>

Para varios tipos, la comparación se realiza de acuerdo a la siguiente tabla (en orden).

La comparación con varios tipos
Tipo de operando 1 | Tipo de operando 2 | Resultado
null o string | string | Convierte null en "", comparación numérica o léxica
bool o null | cualquiera | Convierte ambos lados a bool, false < true
object | object | Las clases internas pueden definir su propia comparación, diferentes clases son incomparables, la misma clase - comparan propiedades en la misma forma que los arrays (PHP 4), PHP 5 tiene su propia explicación
string, resource o number | string, resource o number | Traducir las cadenas y recursos a números, matemática usual
array | array | Un array con menos elementos es menor, si una clave del operando 1 no se encuentra en el operando 2 entonces los arrays son incomparables, de otra forma - compara valor por valor (ver el siguiente ejemplo)
object | cualquiera | object es siempre mayor
array | cualquiera | array es siempre mayor

Ejemplo #1 Comparación boolean/null

<?php
// Booleanos y null son comparados siempre coomo bool
var_dump(1 == TRUE);  // TRUE - same as (bool)1 == TRUE
var_dump(0 == FALSE); // TRUE - same as (bool)0 == FALSE
var_dump(100 < TRUE); // FALSE - same as (bool)100 < TRUE
var_dump(-10 < FALSE);// FALSE - same as (bool)-10 < FALSE
var_dump(min(-100, -10, NULL, 10, 100)); // NULL - (bool)NULL < (bool)-100 is FALSE < TRUE
?>

Ejemplo #2 Transcripción de la comparación estándar de arrays

<?php
// Arrays son comparados de esta forma con los operadores de comparación estándar
function standard_array_compare($op1, $op2)
{
    if (count($op1) < count($op2)) {
        return -1; // $op1 < $op2
    } elseif (count($op1) > count($op2)) {
        return 1; // $op1 > $op2
    }
    foreach ($op1 as $key => $val) {
        if (!array_key_exists($key, $op2)) {
            return null; // uncomparable
        } elseif ($val < $op2[$key]) {
            return -1;
        } elseif ($val > $op2[$key]) {
            return 1;
        }
    }
    return 0; // $op1 == $op2
}
?>

Ver también strcasecmp(), strcmp(), operadores de array, y la sección del manual sobre tipos.

Advertencia

Comparación de números de punto flotante

Debido a la forma en que son representados internamente los floats, no se deben probar por igualdad dos floats.

Ver la documentación de float para más información.

Operador ternario

Otro operador condicional es el operador "?:" (o ternario).

Ejemplo #3 Asignación de un valor predeterminado

<?php
// Ejemplo de uso para: Operador Ternario
$action = (empty($_POST['action'])) ? 'default' : $_POST['action'];

// Lo anterior es idéntico a esta sentencia if/else
if (empty($_POST['action'])) {
    $action = 'default';
} else {
    $action = $_POST['action'];
}

?>
La expresión (expr1) ? (expr2) : (expr3) evalúa a expr2 si expr1 se evalúa como true y a expr3 si expr1 se evalúa como false.

A partir de PHP 5.3, es posible dejar de lado la parte media del operador ternario. La expresión expr1 ?: expr3 retorna expr1 si expr1 se evalúa como true y expr3 si es de otra manera.

Nota: Por favor note que el operador ternario es una expresión, y que no evalúa a una variable, sino al resultado de una expresión. Esto es importante saberlo si se desea retornar una variable por referencia. La sentencia return $var == 42 ? $a : $b; en una función con retorno-por-referencia no funcionará por lo que se ha mencionado y una advertencia es generada en versiones posteriores de PHP.

Nota:

Es recomendable evitar el "apilamiento" expresiones ternarias. El comportamiento de PHP al utilizar más de un operador ternario en una única sentencia no es evidente:

Ejemplo #4 Comportamiento Ternario poco obvio

<?php
// a primera vista, lo siguiente parece tener la salida de 'true'
echo (true?'true':false?'t':'f');

// sin embargo, la salida real de lo anterior es 't'
// esto se debe a que las expresiones ternarias se evalúan de izquierda a derecha

// la siguiente es una versión más obvia del mismo código anterior
echo ((true ? 'true' : false) ? 't' : 'f');

// aquí, se puede ver que la primera expresión es evaluada como 'true', que
// a su vez se evalúa como (bool)true, retornando así la rama verdadera de la
// segunda expresión ternaria.
?>


Operadores de control de errores

PHP soporta un operador de control de errores: el signo de arroba (@). Cuando se antepone a una expresión en PHP, cualquier mensaje de error que pueden ser generado por esa expresión será ignorado.

Si se ha establecido una función controladora de errores personalizada con set_error_handler() entonces todavía será llamada, pero este controlador de errores personalizado puede (y debe) llamar a error_reporting() el cual devolverá 0 cuando la llamada que provocó el error fue precedida por el signo @.

Si la propiedad track_errors está activada, cualquier mensaje de error generado por la expresión será guardada en la variable $php_errormsg. Esta variable se sobrescribe en cada error, así que se debe comprobar antes si se desea utilizar.

<?php
/* Error intencional de archivo */
$my_file = @file ('non_existent_file') or
    die ("La apertura de archivo ha fallado: el error fue '$php_errormsg'");

// esto funciona con cualquier expresión, no solo con funciones:
$value = @$cache[$key];
// no producirá una anotación si el índice $key no existe.

?>

Nota: El operador @ trabaja sólo sobre expresiones. Una simple regla de oro es: si se puede tomar el valor de algo, entonces se le puede anteponer el operador @. Por ejemplo, puede anteponerse a variables, a llamadas a funciones e includes, constantes y así sucesivamente. No puede anteponerse a definiciones de función o clase, ni a estructuras condicionales como if y foreach, y así sucesivamente.

Ver también error_reporting() y la sección del manual sobre funciones de Manejo de Errores y Registros.

Advertencia

En la actualidad, el operador de prefijo "@" para control de errores deshabilitará incluso el reporte de errores en casos de fallos críticos que terminarán la ejecución del script. Entre otras cosas, esto quiere decir que si se usa "@" para eliminar los errores de una cierta función y ésta no se encuentra disponible o ha sido escrita de forma incorrecta, el script se detendrá en ese punto sin indicación de por qué.


Operadores de ejecución

PHP soporta un operador de ejecución: las comillas invertidas (``). ¡Note que estas no son las comillas sencillas! PHP intentará ejecutar el contenido entre las comillas invertidas como si se tratara de un comando del shell; la salida será retornada (es decir, no será simplemente volcada como salida; puede ser asignada a una variable). El uso del operador de comillas invertidas es idéntico al de shell_exec().

<?php
$output = `ls -al`;
echo "<pre>$output</pre>";
?>

Nota:

El operador de comillas invertidas se deshabilita cuando shell_exec() esta desactivado.

Nota:

A diferencia de otros lenguajes, las comillas invertidas no tienen un significa especial dentro de string entre comillas dobles.

Vea también la sección del manual sobre funciones de ejecución de programas, popen() proc_open() y Usando PHP desde la línea de comandos.


Operadores de incremento/decremento

PHP soporta operadores estilo C de pre- y post-incremento y decremento.

Nota: Los operadores de incremento/decremento solamente afectan a números y strings. Los arrays, objects y resources no se ven afectados. Decrementar valores null tampoco tiene efecto, pero incrementarlos entonces resulta en 1.

Operadores de incremento/decremento
Ejemplo | Nombre | Efecto
++$a | Pre-incremento | Incrementa $a en uno, y luego retorna $a.
$a++ | Post-incremento | Retorna $a, y luego incrementa $a en uno.
--$a | Pre-decremento | Decrementa $a en uno, luego retorna $a.
$a-- | Post-decremento | Retorna $a, luego decrementa $a en uno.

Aquí hay un script simple de ejemplo:

<?php
echo "<h3>Postincremento</h3>";
$a = 5;
echo "Debe ser 5: " . $a++ . "<br />\n";
echo "Debe ser 6: " . $a . "<br />\n";

echo "<h3>Preincremento</h3>";
$a = 5;
echo "Debe ser 6: " . ++$a . "<br />\n";
echo "Debe ser 6: " . $a . "<br />\n";

echo "<h3>Postdecremento</h3>";
$a = 5;
echo "Debe ser 5: " . $a-- . "<br />\n";
echo "Debe ser 4: " . $a . "<br />\n";

echo "<h3>Predecremento</h3>";
$a = 5;
echo "Debe ser 4: " . --$a . "<br />\n";
echo "Debe ser 4: " . $a . "<br />\n";
?>

PHP sigue la convención de Perl cuando trabaja con operaciones aritméticas sobre variables de caracteres y no la de C. Por ejemplo, en PHP y Perl $a = 'Z'; $a++; convierte $a en 'AA', mientras que en C a = 'Z'; a++; convierte a en '[' (el valor ASCII de 'Z' es 90, el valor ASCII de '[' es 91). Nótese que las variables de caracteres pueden ser incrementadas pero no decrementadas y aun así sólo caracteres y dígitos de ASCII puro (a-z, A-Z y 0-9) están soportados. Incrementar o decrementar otras variables de caracteres no tiene efecto, el string original no se modifica.

Ejemplo #1 Operaciones aritméticas sobre variables de caracteres

<?php
echo '== Letras ==' . PHP_EOL;
$s = 'W';
for ($n=0; $n<6; $n++) {
    echo ++$s . PHP_EOL;
}
// Los caracteres de dígitos tienen un comportamiento diferente
echo '== Dígitos ==' . PHP_EOL;
$d = 'A8';
for ($n=0; $n<6; $n++) {
    echo ++$d . PHP_EOL;
}
$d = 'A08';
for ($n=0; $n<6; $n++) {
    echo ++$d . PHP_EOL;
}
?>

El resultado del ejemplo sería:

== Letras ==
X
Y
Z
AA
AB
AC
== Dígitos ==
A9
B0
B1
B2
B3
B4
A09
A10
A11
A12
A13
A14

Incrementar o decrementar booleanos no tiene efecto.


Operadores lógicos

Operadores lógicos
Ejemplo | Nombre | Resultado
$a and $b | And (y) | true si tanto $a como $b son true.
$a or $b | Or (o inclusivo) | true si cualquiera de $a o $b es true.
$a xor $b | Xor (o exclusivo) | true si $a o $b es true, pero no ambos.
! $a | Not (no) | true si $a no es true.
$a && $b | And (y) | true si tanto $a como $b son true.
$a || $b | Or (o inclusivo) | true si cualquiera de $a o $b es true.

La razón para tener las dos variaciones diferentes de los operadores "and" y "or" es que ellos operan con precedencias diferentes. (Ver Precedencia de operadores.)

Ejemplo #1 Los operadores lógicos ilustrados

<?php

// --------------------
// foo() nunca será llamado ya que los operadores están en cortocircuito

$a = (false && foo());
$b = (true  || foo());
$c = (false and foo());
$d = (true  or  foo());

// --------------------
// "||" tiene una precedencia mayor que "or"

// El resultado de la expresión (false || true) es asignado a $e
// Actúa como: ($e = (false || true))
$e = false || true;

// La constante false es asignada a $f antes de que suceda la operación "or"
// Actúa como: (($f = false) or true)
$f = false or true;

var_dump($e, $f);

// --------------------
// "&&" tiene una precedencia mayor que "and"

// El resultado de la expresión (true && false) es asignado a $g
// Actúa como: ($g = (true && false))
$g = true && false;

// La constante true es asignada a $h antes de que suceda la operación "and"
// Actúa como: (($h = true) and false)
$h = true and false;

var_dump($g, $h);
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)
bool(false)
bool(true)


Operadores para strings

Existen dos operadores para datos tipo string. El primero es el operador de concatenación ('.'), el cual retorna el resultado de concatenar sus argumentos derecho e izquierdo. El segundo es el operador de asignación sobre concatenación ('.='), el cual añade el argumento del lado derecho al argumento en el lado izquierdo. Por favor consulte Operadores de asignación para más información.

<?php
$a = "Hello ";
$b = $a . "World!"; // ahora $b contiene "Hello World!"

$a = "Hello ";
$a .= "World!";     // ahora $a contiene "Hello World!"
?>

Ver también las secciones del manual sobre el tipo string y las funciones de strings.


Operadores para arrays

Operadores para arrays
Ejemplo | Nombre | Resultado
$a + $b | Unión | Unión de $a y $b.
$a == $b | Igualdad | true si $a i $b tienen las mismas parejas clave/valor.
$a === $b | Identidad | true si $a y $b tienen las mismas parejas clave/valor en el mismo orden y de los mismos tipos.
$a != $b | Desigualdad | true si $a no es igual a $b.
$a <> $b | Desigualdad | true si $a no es igual a $b.
$a !== $b | No-identidad | true si $a no es idéntica a $b.

El operador + devuelve el array del lado derecho añadido al array del lado izquierdo; para las claves que existan en ambos arrays, serán utilizados los elementos del array de la izquierda y serán ignorados los elementos correspondientes del array de la derecha.

<?php
$a = array("a" => "apple", "b" => "banana");
$b = array("a" => "pear", "b" => "strawberry", "c" => "cherry");

$c = $a + $b; // Unión de $a y $b
echo "Unión de \$a y \$b: \n";
var_dump($c);

$c = $b + $a; // Unión de $b y $a
echo "Unión de \$b y \$a: \n";
var_dump($c);

$a += $b; // Unión de $a += $b es $a y $b
echo "Unión de \$a += \$b: \n";
var_dump($a);
?>
Cuando sea ejecutado, este script producirá la siguiente salida:
Unión de $a y $b:
array(3) {
  ["a"]=>
  string(5) "apple"
  ["b"]=>
  string(6) "banana"
  ["c"]=>
  string(6) "cherry"
}
Unión de $b y $a:
array(3) {
  ["a"]=>
  string(4) "pear"
  ["b"]=>
  string(10) "strawberry"
  ["c"]=>
  string(6) "cherry"
}
Unión de $a += $b:
array(3) {
  'a' =>
  string(5) "apple"
  'b' =>
  string(6) "banana"
  'c' =>
  string(6) "cherry"
}

Los elementos de los arrays son iguales para la comparación si éstos tienen la misma clave y valor.

Ejemplo #1 Comparando arrays

<?php
$a = array("apple", "banana");
$b = array(1 => "banana", "0" => "apple");

var_dump($a == $b); // bool(true)
var_dump($a === $b); // bool(false)
?>

Ver también las secciones del manual sobre el tipo array y funciones de arrays.


Operadores de tipo

instanceof se utiliza para determinar si una variable de PHP es un objeto instanciado de una cierta clase:

Ejemplo #1 Utilizando instanceof con clases

<?php
class MyClass
{
}

class NotMyClass
{
}
$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof NotMyClass);
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

instanceof también se puede utilizar para determinar si una variable es un objeto instanciado de una clase que hereda de una clase padre:

Ejemplo #2 Utilizando instanceof con clases heredadas

<?php
class ParentClass
{
}

class MyClass extends ParentClass
{
}

$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof ParentClass);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)

Para comprobar si un objeto no es una instancia de una clase, se puede usar el operador lógico not.

Ejemplo #3 Utilizando instanceof para verificar si un objeto no es una instancia de una clase

<?php
class MyClass
{
}

$a = new MyClass;
var_dump(!($a instanceof stdClass));
?>

El resultado del ejemplo sería:

bool(true)

Finalmente, instanceof también se puede utilizar para determinar si una variable es un objeto instanciado de una clase que implementa una interface:

Ejemplo #4 Utilizando instanceof para la clase

<?php
interface MyInterface
{
}

class MyClass implements MyInterface
{
}

$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof MyInterface);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)

Aunque instanceof se utiliza generalmente con un nombre de clase literal, también puede ser utilizado con otro objeto o una variable string:

Ejemplo #5 Utilizando instanceof con otras variables

<?php
interface MyInterface
{
}

class MyClass implements MyInterface
{
}

$a = new MyClass;
$b = new MyClass;
$c = 'MyClass';
$d = 'NotMyClass';

var_dump($a instanceof $b); // $b is an object of class MyClass
var_dump($a instanceof $c); // $c is a string 'MyClass'
var_dump($a instanceof $d); // $d is a string 'NotMyClass'
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)

instanceof no lanza ningún error si la variable que está siendo comprobada no es un objeto, simplemente devuelve false. Las constantes, sin embargo, no está permitidas.

Ejemplo #6 Usar instanceof para comprobar otras variables

<?php
$a = 1;
$b = NULL;
$c = imagecreate(5, 5);
var_dump($a instanceof stdClass); // $a es un entero
var_dump($b instanceof stdClass); // $b es NULL
var_dump($c instanceof stdClass); // $c es un recurso
var_dump(FALSE instanceof stdClass);
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(false)
PHP Fatal error:  instanceof expects an object instance, constant given

Hay algunas trampas a tener en cuenta. Antes de versión de PHP 5.1.0, instanceof llamaría a __autoload() si el nombre de clase no existía. Además, si la clase no estaba cargada, un error fatal ocurriría. Esto se puede solucionar mediante una referencia de clase dinámica o una variable string que contenga el nombre de la clase:

Ejemplo #7 Evitando búsquedas del nombre de clase y errores fatales con instanceof en PHP 5.0

<?php
$d = 'NotMyClass';
var_dump($a instanceof $d); // aquí no hay error fatal
?>

El resultado del ejemplo sería:

bool(false)

El operador instanceof fue introducido en PHP 5. Antes de esta época se utilizaba is_a(), pero desde entonces is_a() se ha quedado obsoleto en favor de instanceof. Tenga en cuenta que a partir de PHP 5.3.0, is_a() ya no está obsoleto.

Ver también get_class() y is_a().


Estructuras de Control

Tabla de contenidos

  • Introducción
  • if
  • else
  • elseif/else if
  • Sintaxis alternativa de estructuras de control
  • while
  • do-while
  • for
  • foreach
  • break
  • continue
  • switch
  • match
  • declare
  • return
  • require
  • include
  • require_once
  • include_once
  • goto


Introducción

Todo script PHP está construido según una serie de sentencias. Una sentencia puede ser una asignación, una llamada de función, un ciclo, una sentencia condicional o incluso una sentencia que no hace nada (una sentencia vacía). Las sentencias generalmente finalizan con un punto y coma. Adicionalmente, las sentencias pueden agruparse en un conjunto de sentencias, encapsulándolas entre corchetes. Un grupo de sentencias es una sentencia por sí misma también. Los diferentes tipos de sentencias son descritos en este capítulo.


if

(PHP 4, PHP 5, PHP 7, PHP 8)

El constructor if es una de las características más importantes de muchos lenguajes, incluido PHP. Permite la ejecución condicional de fragmentos de código. PHP dispone de una estructura if que es similar a la de C:

if (expr)
  sentencia

Como se describe en la sección sobre expresiones , la expresión es evaluada a su valor booleano. Si la expresión se evalúa como true, PHP ejecutará la sentencia y si se evalúa como false la ignorará. Más información sobre qué valores evalúan como false se puede encontrar en la sección 'Convirtiendo a booleano'.

El siguiente ejemplo mostraría a es mayor que b si $a es mayor que $b:

<?php
if ($a > $b) {
  echo "a es mayor que b";
}
?>

A menudo se desea tener más de una sentencia para ser ejecutada condicionalmente. Por supuesto, no hay necesidad de envolver cada sentencia con una cláusula if. En cambio, se pueden agrupar varias sentencias en un grupo de sentencias. Por ejemplo, este código mostraría a es mayor que b si $a es mayor que $b y entonces asignaría el valor de $a a $b:

<?php
if ($a > $b) {
  echo "a es mayor que b";
  $b = $a;
}
?>

Las sentencias if pueden anidarse dentro de otra sentencias if infinitamente, lo cual provee completa flexibilidad para la ejecución condicional de diferentes partes del programa.


else

(PHP 4, PHP 5, PHP 7, PHP 8)

Con frecuencia se desea ejecutar una sentencia si una determinada condición se cumple y una sentencia diferente si la condición no se cumple. Esto es para lo que sirve else. El else extiende una sentencia if para ejecutar una sentencia en caso que la expresión en la sentencia if se evalúe como false. Por ejemplo, el siguiente código deberá mostrar a es mayor que b si $a es mayor que $b y a NO es mayor que b en el caso contrario:

<?php
if ($a > $b) {
  echo "a es mayor que b";
} else {
  echo "a NO es mayor que b";
}
?>
La sentencia else sólo es ejecutada si la expresión if es evaluada como false y si hay algunas expresiones elseif - sólo se ejecuta si también todas son evaluadas como false (ver elseif).


elseif/else if

(PHP 4, PHP 5, PHP 7, PHP 8)

elseif, como su nombre lo sugiere, es una combinación de if y else. Del mismo modo que else, extiende una sentencia if para ejecutar una sentencia diferente en caso que la expresión if original se evalúe como false. Sin embargo, a diferencia de else, esa expresión alternativa sólo se ejecutará si la expresión condicional del elseif se evalúa como true. Por ejemplo, el siguiente código debe mostrar a es mayor que b, a es igual que b o a es menor que b:

<?php
if ($a > $b) {
    echo "a es mayor que b";
} elseif ($a == $b) {
    echo "a es igual que b";
} else {
    echo "a es menor que b";
}
?>

Puede haber varios elseif dentro de la misma sentencia if. La primera expresión elseif (si hay alguna) que se evalúe como true sería ejecutada. En PHP también se puede escribir 'else if' (en dos palabras) y el comportamiento sería idéntico al de 'elseif' (en una sola palabra). El significado sintáctico es ligeramente diferente (si se está familiarizado con C, este es el mismo comportamiento) pero la conclusión es que ambos resultarían tener exactamente el mismo comportamiento.

La sentencia elseif es ejecutada solamente si la expresión if precedente y cualquiera de las expresiones elseif precedentes son evaluadas como false, y la expresión elseif actual se evalúa como true.

Nota: Tenga en cuenta que elseif y else if serán considerados exactamente iguales sólamente cuando se utilizan llaves como en el ejemplo anterior. Al utilizar los dos puntos para definir las condiciones if/elseif, no debe separarse else if en dos palabras o PHP fallará con un error del interprete.

<?php

/* Método incorrecto: */
if ($a > $b):
    echo $a." es mayor que ".$b;
else if ($a == $b): // No compilará
    echo "La línea anterior provoca un error del interprete.";
endif;

/* Método correcto: */
if ($a > $b):
    echo $a." es mayor que ".$b;
elseif ($a == $b): // Tenga en cuenta la combinación de las palabras.
    echo $a." igual ".$b;
else:
    echo $a." no es ni mayor ni igual a ".$b;
endif;

?>


Sintaxis alternativa de estructuras de control

(PHP 4, PHP 5, PHP 7, PHP 8)

PHP ofrece una sintaxis alternativa para algunas de sus estructuras de control, a saber: if, while, for, foreach, y switch. En cada caso, la forma básica de la sintaxis alternativa es cambiar la llave de apertura por dos puntos (:) y la llave de cierre por endif;, endwhile;, endfor;, endforeach;, o endswitch;, respectivamente.

<?php if ($a == 5): ?>
A es igual a 5
<?php endif; ?>

En el ejemplo anterior, el bloque HTML "A es igual a 5" está anidado dentro de una sentencia if escrita en la sintaxis alternativa. El bloque HTML se mostraría solamente si $a es igual a 5.

La sintaxis alternativa también se aplica a else y elseif. La siguiente es una estructura if con elseif y else en el formato alternativo:

<?php
if ($a == 5):
    echo "a igual 5";
    echo "...";
elseif ($a == 6):
    echo "a igual 6";
    echo "!!!";
else:
    echo "a no es 5 ni 6";
endif;
?>

Nota:

No se admite la mezcla de sintaxis en el mismo bloque de control.

Advertencia

Cualquier salida (incluyendo espacios en blanco) entre una sentencia switch y el primer case resultará en un error de sintaxis. Por ejemplo, esto no es válido:

<?php switch ($foo): ?>
    <?php case 1: ?>
    ...
<?php endswitch ?>

Mientras que lo siguinte es válido, ya que la nueva línea al final después de la sentencia switch es considerada como parte del ?> de cierre, no generando nada entre el switch y el case:

<?php switch ($foo): ?>
<?php case 1: ?>
    ...
<?php endswitch ?>

Véase también while, for e if para más ejemplos.


while

(PHP 4, PHP 5, PHP 7, PHP 8)

Los bucles while son el tipo más sencillo de bucle en PHP. Se comportan igual que su contrapartida en C. La forma básica de una sentencia while es:

while (expr)
    sentencia

El significado de una sentencia while es simple. Le dice a PHP que ejecute las sentencias anidadas, tanto como la expresión while se evalúe como true. El valor de la expresión es verificado cada vez al inicio del bucle, por lo que incluso si este valor cambia durante la ejecución de las sentencias anidadas, la ejecución no se detendrá hasta el final de la iteración (cada vez que PHP ejecuta las sentencias contenidas en el bucle es una iteración). A veces, si la expresión while se evalúa como false desde el principio, las sentencias anidadas no se ejecutarán ni siquiera una vez.

Al igual que con la sentencia if, se pueden agrupar varias instrucciones dentro del mismo bucle while rodeando un grupo de sentencias con corchetes, o utilizando la sintaxis alternativa:

while (expr):
    sentencias
    ...
endwhile;

Los siguientes ejemplos son idénticos y ambos presentan los números del 1 al 10:

<?php
/* ejemplo 1 */

$i = 1;
while ($i <= 10) {
    echo $i++;  /* el valor presentado sería
                   $i antes del incremento
                   (post-incremento) */
}

/* ejemplo 2 */

$i = 1;
while ($i <= 10):
    echo $i;
    $i++;
endwhile;
?>


do-while

(PHP 4, PHP 5, PHP 7, PHP 8)

Los bucles do-while son muy similares a los bucles while, excepto que la expresión verdadera es verificada al final de cada iteración en lugar que al principio. La diferencia principal con los bucles while es que está garantizado que corra la primera iteración de un bucle do-while (la expresión verdadera sólo es verificada al final de la iteración), mientras que no necesariamente va a correr con un bucle while regular (la expresión verdadera es verificada al principio de cada iteración, si se evalúa como false justo desde el comienzo, la ejecución del bucle terminaría inmediatamente).

Hay una sola sintaxis para bucles do-while:

<?php
$i = 0;
do {
    echo $i;
} while ($i > 0);
?>

El bucle de arriba se ejecutaría exactamente una sola vez, ya que después de la primera iteración, cuando la expresión verdadera es verificada, se evalúa como false ($i no es mayor que 0) y termina la ejecución del bucle.

Los usuarios avanzados de C pueden estar familiarizados con un uso distinto del bucle do-while, para permitir parar la ejecución en medio de los bloques de código, mediante el encapsulado con do-while (0), y utilizando la sentencia break. El siguiente fragmento de código demuestra esto:

<?php
do {
    if ($i < 5) {
        echo "i no es lo suficientemente grande";
        break;
    }
    $i *= $factor;
    if ($i < $minimum_limit) {
        break;
    }
   echo "i está bien";

    /* procesar i */

} while (0);
?>

No se preocupe si no se entiende esto completamente o en absoluto. Se pueden codificar scripts e incluso scripts potentes sin usar esta 'característica'. Desde PHP 5.3.0, es posible utilizar el operador goto en lugar de este hack.


for

(PHP 4, PHP 5, PHP 7, PHP 8)

Los bucles for son los más complejos en PHP. Se comportan como sus homólogos en C. La sintaxis de un bucle for es:

for (expr1; expr2; expr3)
    sentencia

La primera expresión (expr1) es evaluada (ejecutada) una vez incondicionalmente al comienzo del bucle.

En el comienzo de cada iteración, se evalúa expr2. Si se evalúa como true, el bucle continúa y se ejecutan la/sy sentencia/s anidada/s. Si se evalúa como false, finaliza la ejecución del bucle.

Al final de cada iteración, se evalúa (ejecuta) expr3.

Cada una de las expresiones puede estar vacía o contener múltiples expresiones separadas por comas. En expr2, todas las expresiones separadas por una coma son evaluadas, pero el resultado se toma de la última parte. Que expr2 esté vacía significa que el bucle debería ser corrido indefinidamente (PHP implícitamente lo considera como true, como en C). Esto puede no ser tan inútil como se pudiera pensar, ya que muchas veces se debe terminar el bucle usando una sentencia condicional break en lugar de utilizar la expresión verdadera del for.

Considere los siguientes ejemplos. Todos ellos muestran los números del 1 al 10:

<?php
/* ejemplo 1 */

for ($i = 1; $i <= 10; $i++) {
    echo $i;
}

/* ejemplo 2 */

for ($i = 1; ; $i++) {
    if ($i > 10) {
        break;
    }
    echo $i;
}

/* ejemplo 3 */

$i = 1;
for (; ; ) {
    if ($i > 10) {
        break;
    }
    echo $i;
    $i++;
}

/* ejemplo 4 */

for ($i = 1, $j = 0; $i <= 10; $j += $i, print $i, $i++);
?>

Por supuesto, el primer ejemplo parece ser el mejor (o quizás el cuarto), pero se puede observar que la posibilidad de usar expresiones vacías en los bucles for resulta útil en muchas ocasiones.

PHP también admite la sintaxis alternativa de los dos puntos para bucles for.

for (expr1; expr2; expr3):
    sentencia
    ...
endfor;

Es una cosa común a muchos usuarios iterar por medio de arrays como en el siguiente ejemplo.

<?php
/*
* Este es un array con algunos datos que se quieren modificar
* cuando se recorra el bucle for.
*/
$people = array(
    array('name' => 'Kalle', 'salt' => 856412),
    array('name' => 'Pierre', 'salt' => 215863)
);

for($i = 0; $i < count($people); ++$i) {
    $people[$i]['salt'] = mt_rand(000000, 999999);
}
?>

El código anterior puede ser lento, debido a que el tamaño del array se capta en cada iteración. Dado que el tamaño nunca cambia, el bucle puede ser fácilmente optimizado mediante el uso de una variable intermedia para almacenar el tamaño en lugar de llamar repetidamente a count():

<?php
$people = array(
    array('name' => 'Kalle', 'salt' => 856412),
    array('name' => 'Pierre', 'salt' => 215863)
);

for($i = 0, $size = count($people); $i < $size; ++$i) {
    $people[$i]['salt'] = mt_rand(000000, 999999);
}
?>


foreach

(PHP 4, PHP 5, PHP 7, PHP 8)

El constructor foreach proporciona un modo sencillo de iterar sobre arrays. foreach funciona sólo sobre arrays y objetos, y emitirá un error al intentar usarlo con una variable de un tipo diferente de datos o una variable no inicializada. Existen dos sintaxis:

foreach (expresión_array as $valor)
    sentencias
foreach (expresión_array as $clave => $valor)
    sentencias

La primera forma recorre el array dado por expresión_array. En cada iteración, el valor del elemento actual se asigna a $valor y el puntero interno del array avanza una posición (así en la próxima iteración se estará observando el siguiente elemento).

La segunda forma además asigna la clave del elemento actual a la variable $clave en cada iteración.

También es posible personalizar la iteración de objetos.

Nota:

En PHP 5, cuando foreach inicia su ejecución, el puntero interno del array se pone automáticamente en el primer elemento del array. Esto significa que no es necesario llamar la función reset() antes de un bucle foreach.

Ya que foreach depende el puntero de array interno en PHP 5, cambiar éste dentro del bucle puede conducir a un comportamiento inesperado.

En PHP 7, foreach no utiliza el puntero interno del array.

Para poder modificar directamente los elementos del array dentro de bucle, se ha de anteponer & a $valor. En este caso el valor será asignado por referencia.

<?php
$array = array(1, 2, 3, 4);
foreach ($array as &$valor) {
    $valor = $valor * 2;
}
// $array ahora es array(2, 4, 6, 8)
unset($valor); // rompe la referencia con el último elemento
?>

Advertencia

La referencia del $valor y el último elemento del array permanecen aún después del bucle foreach. Se recomienda destruirlos con unset(). De lo contrario, se experimentará el siguiente funcionamiento:

<?php
$array = array(1, 2, 3, 4);
foreach ($array as &$valor) {
    $valor = $valor * 2;
}
// $array ahora es array(2, 4, 6, 8)

// sin unset($valor), $valor aún es una referencia al último elemento: $array[3]

foreach ($array as $clave => $valor) {
    // $array[3] se actualizará con cada valor de $array...
    echo "{$clave} => {$valor} ";
    print_r($array);
}
// ...hasta que finalmente el penúltimo valor se copia al último valor

// salida:
// 0 => 2 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 2 )
// 1 => 4 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 4 )
// 2 => 6 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 6 )
// 3 => 6 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 6 )
?>

Antes de PHP 5.5.0, referenciar $valor sólo es posible si el array iterado puede ser referenciado (es decir, si es una variable). El siguiente código solamente funciona a partir de PHP 5.5.0:

<?php
foreach (array(1, 2, 3, 4) as &$valor) {
    $valor = $valor * 2;
}
?>

Nota:

foreach no soporta la capacidad de suprimir mensajes de error usando '@'.

Algunos ejemplos más para demostrar su uso:

<?php
/* Ejemplo 1 de foreach: sólo el valor */

$a = array(1, 2, 3, 17);

foreach ($a as $v) {
    echo "Valor actual de \$a: $v.\n";
}

/* Ejemplo 2 de foreach: valor (con su notación de acceso manual impreso con fines ilustrativos) */

$a = array(1, 2, 3, 17);

$i = 0; /* sólo para efectos ilustrativos */

foreach ($a as $v) {
    echo "\$a[$i] => $v.\n";
    $i++;
}

/* Ejemplo 3 de foreach: clave y valor */

$a = array(
    "uno" => 1,
    "dos" => 2,
    "tres" => 3,
    "diecisiete" => 17
);

foreach ($a as $k => $v) {
    echo "\$a[$k] => $v.\n";
}

/* Ejemplo 4 de foreach: arrays multidimensionales */
$a = array();
$a[0][0] = "a";
$a[0][1] = "b";
$a[1][0] = "y";
$a[1][1] = "z";

foreach ($a as $v1) {
    foreach ($v1 as $v2) {
        echo "$v2\n";
    }
}

/* Ejemplo 5 de foreach: arrays dinámicos */

foreach (array(1, 2, 3, 4, 5) as $v) {
    echo "$v\n";
}
?>

Utilizando arrays anidados con list()

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

PHP 5.5 añade la posibilidad de recorrer un array de arrays y utilizar el array interior en las variables del bucle proporcionando list() como el valor.

Por ejemplo:

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a, $b)) {
    // $a contiene el primer elemento del array interior,
    // y $b contiene el segundo elemento.
    echo "A: $a; B: $b\n";
}
?>

El resultado del ejemplo sería:

A: 1; B: 2
A: 3; B: 4

Puedes proporcionar menos elementos a list() de los que hay en el array interior, en cuyo caso los elementos sobrantes del array serán descartados:

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a)) {
    // Observa que no hay $b en este caso.
    echo "$a\n";
}
?>

El resultado del ejemplo sería:

1
3

Se generará un notice si no hay suficientes elementos en el array para completar el list():

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a, $b, $c)) {
    echo "A: $a; B: $b; C: $c\n";
}
?>

El resultado del ejemplo sería:

Notice: Undefined offset: 2 in example.php on line 7
A: 1; B: 2; C:

Notice: Undefined offset: 2 in example.php on line 7
A: 3; B: 4; C:

Historial de cambios

Versión | Descripción
7.0.0 | foreach ya no utiliza el puntero interno al array.
5.5.0 | Hacer referencia a $valor está admitido para expresiones. Anteriormente, solamente estaban admitidas las variables.
5.5.0 | El desempaquetamiento de arrays anidados con list() está admitido.


break

(PHP 4, PHP 5, PHP 7, PHP 8)

break finaliza la ejecución de la estructura for, foreach, while, do-while o switch en curso.

break acepta un argumento numérico opcional que indica de cuántas estructuras anidadas circundantes se debe salir. El valor predeterminado es 1, es decir, solamente se sale de la estructura circundante inmediata.

<?php
$arr = array('uno', 'dos', 'tres', 'cuatro', 'pare', 'cinco');
while (list(, $val) = each($arr)) {
    if ($val == 'pare') {
        break;    /* Se puede también escribir 'break 1;' aquí. */
    }
    echo "$val<br />\n";
}

/* Utilizar el argumento opcional. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "En 5<br />\n";
        break 1;  /* Sólo sale del switch. */
    case 10:
        echo "En 10; saliendo<br />\n";
        break 2;  /* Sale del switch y del while. */
    default:
        break;
    }
}
?>

Registro de cambios para break
Versión | Descripción
5.4.0 | break 0; ya no es válido. En versiones anteriores se interpretaba igual que break 1;.
5.4.0 | Eliminada la posibilidad de pasar variables (por ejemplo, $num = 2; break $num;) como argumento numérico.


continue

(PHP 4, PHP 5, PHP 7, PHP 8)

continue se utiliza dentro de las estructuras iterativas para saltar el resto de la iteración actual del bucle y continuar la ejecución en la evaluación de la condición, para luego comenzar la siguiente iteración.

Nota: En PHP, la sentencia switch se considera una estructura iterativa para los propósitos de continue. continue se comporta igual que break (cuando no se proporcionan argumentos). Si un switch está dentro de un bucle, continue 2 continurá con la siguiente iteración del bucle externo.

continue acepta un argumento numérico opcional, que indica a cuántos niveles de bucles encerrados se ha de saltar al final. El valor por omisión es 1, por lo que salta al final del bucle actual.

<?php
while (list($clave, $valor) = each($arr)) {
    if (!($clave % 2)) { // saltar los miembros pares
        continue;
    }
    hacer_algo($valor);
}

$i = 0;
while ($i++ < 5) {
    echo "Exterior<br />\n";
    while (1) {
        echo "Medio<br />\n";
        while (1) {
            echo "Interior<br />\n";
            continue 3;
        }
        echo "Esto nunca se imprimirá.<br />\n";
    }
    echo "Ni esto tampoco.<br />\n";
}
?>

Omitir el punto y coma después del continue puede llevar a confusión. He aquí un ejemplo de lo que no se debe hacer.

<?php
for ($i = 0; $i < 5; ++$i) {
    if ($i == 2)
        continue
    print "$i\n";
}
?>

Se esperaría que el resultado fuera:

0
1
3
4

pero, en versiones de PHP anteriores a la 5.4.0, la salida de este script será:

2

debido a que continue print "$i\n"; se evalúa completo como una sola expresión, y así print se llama solamente cuando $i == 2 es verdadero. (El valor de retorno de print es pasado a continue como el argumento numérico.)

Nota:

A partir de PHP 5.4.0, el ejemplo anterior emitirá un error E_COMPILE_ERROR.

Registro de cambios para continue
Versión | Descripción
5.4.0 | continue 0; ya no es válido. En versiones anteriores era interpretado de la misma manera que continue 1;.
5.4.0 | Se eliminó la posibilidad de pasar variables (por ejemplo, $num = 2; continue $num;) como el argumento numérico.


switch

(PHP 4, PHP 5, PHP 7, PHP 8)

La sentencia switch es similar a una serie de sentencias IF en la misma expresión. En muchas ocasiones, es posible que se quiera comparar la misma variable (o expresión) con muchos valores diferentes, y ejecutar una parte de código distinta dependiendo de a que valor es igual. Para esto es exactamente la expresión switch.

Nota: Cabe señalar que a diferencia de algunos otros lenguajes, la sentencia continue se aplica a switch y actúa de manera similar a break. Si se tiene un switch dentro de un bucle y se desea continuar a la siguiente iteración de del ciclo exterior, se utiliza continue 2.

Nota:

Tener en cuenta que switch/case hace comparaciones flexibles.

Historial de cambios
Versión | Descripción
7.0.0 | Múltiples casos predeterminados (default) emitirán un error de tipo E_COMPILE_ERROR.

Los dos ejemplos siguientes son dos formas diferentes de escribir lo mismo, uno con una serie de sentencias if y elseif, y el otro usando la sentencia switch:

Ejemplo #1 Estructura switch

<?php
if ($i == 0) {
    echo "i es igual a 0";
} elseif ($i == 1) {
    echo "i es igual a 1";
} elseif ($i == 2) {
    echo "i es igual a 2";
}

switch ($i) {
    case 0:
        echo "i es igual a 0";
        break;
    case 1:
        echo "i es igual a 1";
        break;
    case 2:
        echo "i es igual a 2";
        break;
}
?>

Ejemplo #2 Estrutura switch permite el uso de strings

<?php
switch ($i) {
    case "manzana":
        echo "i es una manzana";
        break;
    case "barra":
        echo "i es una barra";
        break;
    case "pastel":
        echo "i es un pastel";
        break;
}
?>

Es importante entender cómo la sentencia switch es ejecutada con el fin de evitar errores. La sentencia switch ejecuta línea por línea (en realidad, sentencia por sentencia). Al principio, ningún código es ejecutado. Solo cuando se encuentra una sentencia case cuya expresión se evalúa a un valor que coincida con el valor de la con un valor que coincide con el valor de la expresión switch, PHP comienza a ejecutar la sentencias. PHP continúa ejecutando las sentencias hasta el final del bloque switch, o hasta la primera vez que vea una sentencia break. Si no se escribe una sentencia break al final de la lista de sentencias de un caso, PHP seguirá ejecutando las sentencias del caso siguiente. Por ejemplo:

<?php
switch ($i) {
    case 0:
        echo "i es igual a 0";
    case 1:
        echo "i es igual a 1";
    case 2:
        echo "i es igual a 2";
}
?>

Aquí, si $i es igual a 0, PHP ejecutaría todas las sentencias echo! Si $i es igual a 1, PHP ejecutaría las últimas dos sentencias echo. Se obtendría el comportamiento esperado (se mostraría 'i es igual a 2') sólo si $i es igual a 2. Por lo tanto, es importante no olvidar las sentencias break (aunque es posible que se desee evitar proporcionarlas a propósito bajo determinadas circunstancias).

En una sentencia switch, la condición es evaluada sólo una vez y el resultado es comparado con cada una de las sentencias case. En una sentencia elseif, la condición es evaluada otra vez. Si la condición es más complicada que una simple comparación y/o está en un bucle estrecho, un switch puede ser más rápido.

La lista de sentencias para un caso también puede estar vacía, lo cual simplemente pasa el control a la lista de sentencias para el siguiente caso.

<?php
switch ($i) {
    case 0:
    case 1:
    case 2:
        echo "i es menor que 3 pero no negativo";
        break;
    case 3:
        echo "i es 3";
}
?>

Un caso especial es el default. Este caso coincide con cualquier cosa que no se haya correspondido por los otros casos. Por ejemplo:

<?php
switch ($i) {
    case 0:
        echo "i es igual a 0";
        break;
    case 1:
        echo "i es igual a 1";
        break;
    case 2:
        echo "i es igual a 2";
        break;
    default:
       echo "i no es igual a 0, 1 ni 2";
}
?>

La sintaxis alternativa para las estructuras de control es compatible con los switch. Para obtener más información, consulte Sintaxis alternativa de estructuras de control.

<?php
switch ($i):
    case 0:
        echo "i es igual a 0";
        break;
    case 1:
        echo "i es igual a 1";
        break;
    case 2:
        echo "i es igual a 2";
        break;
    default:
        echo "i no es igual a 0, 1 ni 2";
endswitch;
?>

Es posible utilizar un punto y coma en lugar de dos puntos después de un caso como:

<?php
switch($beer)
{
    case 'tuborg';
    case 'carlsberg';
    case 'heineken';
        echo 'Buena elección';
    break;
    default;
        echo 'Por favor haga una nueva selección...';
    break;
}
?>


match

(PHP 8)

The match expression branches evaluation based on an identity check of a value. Similarly to a switch statement, a match expression has a subject expression that is compared against multiple alternatives. Unlike switch, it will evaluate to a value much like ternary expressions. Unlike switch, the comparison is an identity check (===) rather than a weak equality check (==). Match expressions are available as of PHP 8.0.0.

Ejemplo #1 Structure of a match expression

<?php
$return_value = match (subject_expression) {
    single_conditional_expression => return_expression,
    conditional_expression1, conditional_expression2 => return_expression,
};
?>

Nota: The result of a match expression does not need to be used.

Nota: A match expression must be terminated by a semicolon ;.

The match expression is similar to a switch statement but has some key differences:

  • A match arm compares values strictly (===) instead of loosely as the switch statement does.
  • A match expression returns a value.
  • Match arms do not fall-through to later cases the way switch statements do.
  • A match expression must be exhaustive.

As switch statements, match expressions are executed match arm by match arm. In the beginning, no code is executed. The conditional expressions are only evaluated if all previous conditional expressions failed to match the subject expression. Only the return expression corresponding to the matching conditional expression will be evaluated. For example:

<?php
$result = match ($x) {
    foo() => ...,
    $this->bar() => ..., // bar() isn't called if foo() === $x
    $this->baz => beep(), // beep() isn't called unless $x === $this->baz
    // etc.
};
?>

match expression arms may contain multiple expressions separated by a comma. That is a logical OR, and is a short-hand for multiple match arms with the same right-hand side.

<?php
$result = match ($x) {
    // This match arm:
    $a, $b, $c => 5,
    // Is equivalent to these three match arms:
    $a => 5,
    $b => 5,
    $c => 5,
};
?>

A special case is the default pattern. This pattern matches anything that wasn't previously matched. For example:

<?php
$expressionResult = match ($condition) {
    1, 2 => foo(),
    3, 4 => bar(),
    default => baz(),
};
?>

Nota: Multiple default patterns will raise a E_FATAL_ERROR error.

A match expression must be exhaustive. If the subject expression is not handled by any match arm an UnhandledMatchError is thrown.

Ejemplo #2 Example of an unhandled match expression

<?php
$condition = 5;

try {
    match ($condition) {
        1, 2 => foo(),
        3, 4 => bar(),
    };
} catch (\UnhandledMatchError $e) {
    var_dump($e);
}
?>

El resultado del ejemplo sería:

object(UnhandledMatchError)#1 (7) {
  ["message":protected]=>
  string(33) "Unhandled match value of type int"
  ["string":"Error":private]=>
  string(0) ""
  ["code":protected]=>
  int(0)
  ["file":protected]=>
  string(9) "/in/ICgGK"
  ["line":protected]=>
  int(6)
  ["trace":"Error":private]=>
  array(0) {
  }
  ["previous":"Error":private]=>
  NULL
}

Using match expressions to handle non identity checks

It is possible to use a match expression to handle non-identity conditional cases by using true as the subject expression.

Ejemplo #3 Using a generalized match expressions to branch on integer ranges

<?php

$age = 23;

$result = match (true) {
    $age >= 65 => 'senior',
    $age >= 25 => 'adult',
    $age >= 18 => 'young adult',
    default => 'kid',
};

var_dump($result);
?>

El resultado del ejemplo sería:

string(11) "young adult"

Ejemplo #4 Using a generalized match expressions to branch on string content

<?php

$text = 'Bienvenue chez nous';

$result = match (true) {
    str_contains($text, 'Welcome') || str_contains($text, 'Hello') => 'en',
    str_contains($text, 'Bienvenue') || str_contains($text, 'Bonjour') => 'fr',
    // ...
};

var_dump($result);
?>

El resultado del ejemplo sería:

string(2) "fr"


declare

(PHP 4, PHP 5, PHP 7, PHP 8)

El constructor declare es usado para fijar directivas de ejecución para un bloque de código. La sintaxis de declare es similar a la sintaxis de otros constructores de control de flujo:

declare (directive)
    statement

La sección directive permite que el comportamiento de declare sea configurado. Actualmente, solamente están reconocidas tres directivas: ticks (véase abajo para más información sobre la directiva ticks), encoding (véase abajo para más información sobre la directiva encoding) y strict_types (para más infomación, véase la sección strict de la página de Argumentos de funciones)

Versión | Descripción
7.0.0 | Se añadió la directiva strict_types
5.3.0 | Se añadió la directiva encoding

Ya que las directivas se manejan mientras el fichero está siendo compilado, solamente se pueden proporcionar literales como valores de directivas. No se pueden emplear variables ni constantes. Como ejemplo:

<?php
// Esto es válido:
declare(ticks=1);

// Esto no es válido:
const TICK_VALUE = 1;
declare(ticks=TICK_VALUE);
?>

La parte statement del bloque declare será ejecutada - como se ejecuta y que efectos secundarios ocurran durante la ejecución puede depender de la directiva fijada en el bloque directive.

El constructor declare también se puede utilizar en el alcance global, afectando a todo el código que le sigue (sin embargo, si el archivo con el declare fue incluido entonces no afectará al archivo padre).

<?php
// estos son lo mismo:

// se puede usar ésto:
declare(ticks=1) {
    // script entero aquí
}

// o se puede usar ésto:
declare(ticks=1);
// script entero aquí
?>

Ticks

Un tick es un evento que ocurre para cada sentencia tickable N de bajo nivel ejecutada por el intérprete dentro del bloque declare. El valor para N se especifica usando ticks=N dentro del bloque de declare de la sección directive.

No todas las sentencias son tickable. Por lo general, expresiones de condición y expresiones de argumento no son tickables.

Los eventos que ocurren en cada tick se especifican mediante la register_tick_function(). Ver el ejemplo abajo para más detalles. Tener en cuenta que más de un evento puede ocurrir por cada tick.

Ejemplo #1 Ejemplo de uso del tick

<?php

declare(ticks=1);

// Una función llamada en cada evento tick
function tick_handler()
{
    echo "tick_handler() llamado\n";
}

register_tick_function('tick_handler');

$a = 1;

if ($a > 0) {
    $a += 2;
    print($a);
}

?>

Ejemplo #2 Ejemplo de uso de ticks

<?php

function tick_handler()
{
  echo "tick_handler() llamado\n";
}

$a = 1;
tick_handler();

if ($a > 0) {
    $a += 2;
    tick_handler();
    print($a);
    tick_handler();
}
tick_handler();

?>

Véase también register_tick_function() y unregister_tick_function().

Encoding

Una codificación de script puede ser especificada para cada script usando la directiva encoding.

Ejemplo #3 Declarando un encoding para el script

<?php
declare(encoding='ISO-8859-1');
// código aquí
?>

Precaución

Cuando se combina con espacios de nombres, la única sintaxis legal para declarar es declare(encoding='...'); donde ... es el valor del encoding. declare(encoding='...') {} resultará en un error de análisis cuando se combina con espacios de nombres.

El valor declarado de encoding es ignorado en PHP 5.3 a menos que php esté compilado con --enable-zend-multibyte.

Tener en cuenta que PHP no expone si --enable-zend-multibyte fue utilizado para compilar PHP que no sea por phpinfo().

Ver también zend.script_encoding.


return

(PHP 4, PHP 5, PHP 7, PHP 8)

return devuelve el control del programa al módulo que lo invoca. La ejecución vuelve a la siguiente expresión después del módulo que lo invoca.

Si se llama desde una función, la sentencia return inmediatamente termina la ejecución de la función actual, y devuelve su argumento como el valor de la llamada a la función. return también termina la ejecución de una sentencia eval() o un archivo de script.

Si se llama desde el ámbito global, entonces la ejecución del script actual se termina. Si el archivo script actual fue incluido o requerido con include o require, entonces el control es pasado de regreso al archivo que hizo el llamado. Además, si el archivo script actual fue incluido con include, entonces el valor dado a return será retornado como el valor de la llamada include. Si return es llamado desde dentro del fichero del script principal, entonces termina la ejecución del script. Si el archivo script actual fue nombrado por las opciones de configuración auto_prepend_file o auto_append_file en php.ini, entonces se termina la ejecución de ese archivo script.

Para más información, ver Retornando valores.

Nota: Cabe señalar que dado que return es un constructor del lenguaje y no una función, los paréntesis que rodean su argumento no son obligatorios y se desaconseja su uso.

Nota: Si no se suministra un parámetro, entonces el paréntesis debe omitirse y null será retornado. Llamadas a return con paréntesis pero sin argumentos resultarán en un error del intérprete.


require

(PHP 4, PHP 5, PHP 7, PHP 8)

require es idéntico a include excepto que en caso de fallo producirá un error fatal de nivel E_COMPILE_ERROR. En otras palabras, éste detiene el script mientras que include sólo emitirá una advertencia (E_WARNING) lo cual permite continuar el script.

Véase la documentación de include para más información.


include

(PHP 4, PHP 5, PHP 7, PHP 8)

La sentencia include incluye y evalúa el archivo especificado.

La siguiente documentación también se aplica a require.

Los archivos son incluidos con base en la ruta de acceso dada o, si ninguna es dada, el include_path especificado. Si el archivo no se encuentra en el include_path, include finalmente verificará en el propio directorio del script que hace el llamado y en el directorio de trabajo actual, antes de fallar. El constructor include emitirá una advertencia si no puede encontrar un archivo, éste es un comportamiento diferente al de require, el cual emitirá un error fatal..

Si una ruta es definida — ya sea absoluta (comenzando con una letra de unidad o \ en Windows o / en sistemas Unix/Linux) o relativa al directorio actual (comenzando con . o ..) — el include_path será ignorado por completo. Por ejemplo, si un nombre de archivo comienza con ../, el interprete buscará en el directorio padre para encontrar el archivo solicitado.

Para más información sobre como PHP maneja la inclusión de archivos y la ruta de accesos para incluir, ver la documentación de include_path.

Cuando se incluye un archivo, el código que contiene hereda el ámbito de las variables de la línea en la cual ocurre la inclusión. Cualquier variable disponible en esa línea del archivo que hace el llamado, estará disponible en el archivo llamado, desde ese punto en adelante. Sin embargo, todas las funciones y clases definidas en el archivo incluido tienen el ámbito global.

Ejemplo #1 Ejemplo básico de include

vars.php
<?php

$color = 'verde';
$fruta = 'manzana';

?>

test.php
<?php

echo "Una $fruta $color"; // Una

include 'vars.php';

echo "Una $fruta $color"; // Una manzana verde

?>

Si la inclusión ocurre al interior de una función dentro del archivo que hace el llamado, entonces todo el código contenido en el archivo llamado se comportará como si hubiera sido definida dentro de esa función. Por lo tanto, seguirá el ámbito de las variables de esa función. Una excepción a esta regla son las constantes mágicas las cuales son evaluadas por el intérprete antes que ocurra la inclusión.

Ejemplo #2 Incluyendo dentro de funciones

<?php

function foo()
{
    global $color;

    include 'vars.php';

    echo "Una $fruta $color";
}

/* vars.php está en el ámbito de foo() así que *
* $fruta NO está disponible por fuera de éste  *
* ámbito. $color sí está porque fue declarado *
* como global.                                 */

foo();                      // Una manzana verde
echo "Una $fruta $color";   // Una verde

?>

Cuando un archivo es incluido, el intérprete abandona el modo PHP e ingresa al modo HTML al comienzo del archivo objetivo y se reanuda de nuevo al final. Por esta razón, cualquier código al interior del archivo objetivo que deba ser ejecutado como código PHP, tendrá que ser encerrado dentro de etiquetas válidas de comienzo y terminación de PHP.

Si las "envolturas URL include" están activadas en PHP, se puede especificar el archivo a ser incluido usando una URL (vía HTTP u otra envoltura soportada - ver Protocolos y Envolturas soportados para una lista de protocolos) en lugar de una ruta de acceso local. Si el servidor objetivo interpreta el archivo objetivo como código PHP, las variables se pueden pasar al archivo incluido usando una string de petición como la usada con HTTP GET. Esto no es, en estricto rigor, lo mismo que haber incluido el archivo y que haya heredado el ámbito de variables del archivo padre; el script realmente está siendo ejecutado en el servidor remoto y el resultado entonces se incluye dentro del script local.

Ejemplo #3 include por medio de HTTP

<?php

/* Este ejemplo asume que www.example.com está configurado para interpretar archivos
* .php y no archivos .txt. Además, aquí 'Funciona' quiere decir que las variables
* $foo y $bar están disponibles dentro del archivo incluido. */

// No funciona; file.txt no puede ser manejado por www.example.com como PHP
include 'http://www.example.com/file.txt?foo=1&bar=2';

// No funciona; busca por un archivo llamado 'file.php?foo=1&bar=2' en el
// sistema de archivos local.
include 'file.php?foo=1&bar=2';

// Si funciona.
include 'http://www.example.com/file.php?foo=1&bar=2';

$foo = 1;
$bar = 2;
include 'file.txt';  // Funciona.
include 'file.php';  // Funciona.

?>

Advertencia

Advertencia de seguridad

El archivo remoto puede ser procesado en el servidor remoto (dependiendo de la extensión del archivo y del hecho de si el servidor remoto corre PHP o no) pero aun así tiene que producir un script PHP válido, porque será procesado en el servidor local. Si el archivo desde el servidor remoto debe ser procesado allá y entregar la salida solamente, readfile() es la mejor función para usar. De lo contrario, debe tenerse especial cuidado para asegurar que el script remoto produce un código válido y deseado.

Ver también Archivos remotos, fopen() y file() para información relacionada.

Manejando retornos: include devuelve FALSE en caso de falla y eleva una advertencia. Inclusiones exitosas, a menos que sea reemplazado por el archivo incluido, devolverá 1. Es posible ejecutar una sentencia return dentro de un archivo incluido con el fin de terminar el procesamiento en ese archivo y volver al script que lo llamó. Además, es posible retornar valores desde los archivos incluidos. Se puede tomar el valor de la llamada "include" de la misma forma como se haría con una función normal. Esto no es, sin embargo, posible si se incluyen archivos remotos, a menos que la salida del archivo remoto tenga unas etiquetas válidas de inicio y terminación de PHP (igual que con cualquier archivo local). Se pueden declarar las variables necesarias dentro de esas etiquetas y serán introducidas en cualquiera sea el punto del archivo en el cual fue incluido.

Debido a que include es un constructor especial del lenguaje, los paréntesis no son necesarios en torno a su argumento. Se debe tener cuidado cuando se compara el valor de retorno.

Ejemplo #4 Comparando el valor de retorno de include

<?php
// no funcionará, se evalúa como include(('vars.php') == TRUE), es decir, include('')
if (include('vars.php') == TRUE) {
    echo 'OK';
}

// sí funciona
if ((include 'vars.php') == TRUE) {
    echo 'OK';
}
?>

Ejemplo #5 include y la sentencia return

return.php
<?php

$var = 'PHP';

return $var;

?>

noreturn.php
<?php

$var = 'PHP';

?>

testreturns.php
<?php

$foo = include 'return.php';

echo $foo; // muestra 'PHP'

$bar = include 'noreturn.php';

echo $bar; // muestra 1

?>

$bar tiene el valor 1 debido a que el include fue exitoso. Nótese la diferencia entre los ejemplos anteriores. El primero usa return dentro del archivo incluido, mientras que el otro no. Si el archivo no se pueden incluir, se retorna false y se emite un E_WARNING.

Si hay funciones definidas en el archivo incluido, se pueden utilizar en el archivo principal independientemente que hayan return antes o después. Si el archivo se incluye dos veces, PHP 5 arrojará un error fatal ya que las funciones ya han sido declaradas, mientras que PHP 4 no se queja acerca de las funciones definidas después de un return. Se recomienda el uso de include_once en lugar de comprobar si el archivo ya estaba incluido y hacer el retorno de forma condicionada dentro del archivo incluido.

Otra forma de "incluir" un archivo PHP en una variable es capturar la salida mediante el uso de Funciones de control de salida con include. Por ejemplo:

Ejemplo #6 Usando buffering de salida para incluir un archivo PHP dentro de una cadena

<?php
$string = get_include_contents('somefile.php');

function get_include_contents($filename) {
    if (is_file($filename)) {
        ob_start();
        include $filename;
        return ob_get_clean();
    }
    return false;
}

?>

Con el fin de incluir archivos de forma automática dentro de scripts, véase también las opciones de configuración auto_prepend_file and auto_append_file en php.ini.

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Ver también require, require_once, include_once, get_included_files(), readfile(), virtual() y include_path.


require_once

(PHP 4, PHP 5, PHP 7, PHP 8)

La sentencia require_once es idéntica a require excepto que PHP verificará si el archivo ya ha sido incluido y si es así, no se incluye (require) de nuevo.

Ver la documentación de include_once para información sobre el comportamiento de _once, y como difiere de sus hermanos no _once.


include_once

(PHP 4, PHP 5, PHP 7, PHP 8)

La sentencia include_once incluye y evalúa el fichero especificado durante la ejecución del script. Tiene un comportamiento similar al de la sentencia include, siendo la única diferencia de que si el código del fichero ya ha sido incluido, no se volverá a incluir, e include_once devolverá true. Como su nombre indica, el fichero será incluido solamente una vez.

include_once se puede utilizar en casos donde el mismo fichero podría ser incluido y evaluado más de una vez durante una ejecución particular de un script, así que en este caso, puede ser de ayuda para evitar problemas como la redefinición de funciones, reasignación de valores de variables, etc.

Véase la documentación de include para más información sobre cómo funciona esta función.


goto

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

¿Qué es lo peor que podría suceder si utiliza goto?
Imagen cortesía de » xkcd

El operador goto puede ser usado para saltar a otra sección en el programa. El punto de destino es especificado mediante una etiqueta seguida de dos puntos y la instrucción es dada como goto seguida de la etiqueta del destino deseado. Este goto no es completamente sin restricciones. La etiqueta de destino debe estar dentro del mismo fichero y contexto, lo que significa que no se puede saltar fuera de una función o método, ni se puede saltar dentro de uno. Tampoco se puede saltar dentro de cualquier clase de estructura de bucle o switch. Se puede saltar fuera de estos y un uso común es utilizar un goto en lugar de un break multi-nivel.

Ejemplo #1 Ejemplo de goto

<?php
goto a;
echo 'Foo';

a:
echo 'Bar';
?>

El resultado del ejemplo sería:

Bar

Ejemplo #2 Ejemplo de goto en un bucle

<?php
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    if($j==17) goto end;
  }
}
echo "i = $i";
end:
echo 'j alcanzó 17';
?>

El resultado del ejemplo sería:

j alcanzó 17

Ejemplo #3 Esto no funcionará

<?php
goto loop;
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    loop:
  }
}
echo "$i = $i";
?>

El resultado del ejemplo sería:

Fatal error: 'goto' into loop or switch statement is disallowed in script on line 2
(Error fatal: 'goto' hacia el interior de un bucle o sentencia switch no esta permitido en el script en la línea 2)

Nota:

El operador goto está disponible a partir de PHP 5.3.


Funciones

Tabla de contenidos

  • Funciones definidas por el usuario
  • Argumentos de funciones
  • Devolver valores
  • Funciones variables
  • Funciones internas (incluidas)
  • Funciones anónimas
  • Funciones de flecha


Funciones definidas por el usuario

Una función puede ser definida empleando una sintaxis como la siguiente:

Ejemplo #1 Seudocódigo para demostrar el uso de funciones

<?php
function foo($arg_1, $arg_2, /* ..., */ $arg_n)
{
    echo "Función de ejemplo.\n";
    return $valor_devuelto;
}
?>

Cualquier código PHP válido puede aparecer dentro de una función, incluso otras funciones y definiciones de clases.

Los nombres de las funciones siguen las mismas reglas que las demás etiquetas de PHP. Un nombre de función válido comienza con una letra o guión bajo, seguido de cualquier número de letras, números o guiones bajos. Como expresión regular se expresaría así: ^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$.

Sugerencia

Vea también Guía de entorno de usuario para nombres.

No es necesario definir una función antes de que sea referenciada, excepto cuando esta esté condicionalmente definida como se muestra en los dos ejemplos de abajo.

Cuando una función está definida de una forma condicional como en los dos ejemplos siguientes, sus definiciones deben ser procesadas antes de ser llamadas.

Ejemplo #2 Funciones condicionales

<?php

$hacer_algo = true;

/* No podemos llamar a foo() desde aquí
   ya que no existe aún,
   pero podemos llamar a bar() */

bar();

if ($hacer_algo) {
  function foo()
  {
    echo "No existo hasta que la ejecución del programa llegue hasta mí.\n";
  }
}

/* Ahora podemos llamar de forma segura a foo()
   ya que $hacer_algo se evaluó como verdadero */

if ($hacer_algo) foo();

function bar()
{
  echo "Existo desde el momento inmediato que comenzó el programa.\n";
}

?>

Ejemplo #3 Funciones dentro de funciones

<?php
function foo()
{
  function bar()
  {
    echo "No existo hasta que se llame a foo().\n";
  }
}

/* No podemos llamar aún a bar()
   ya que no existe. */

foo();

/* Ahora podemos llamar a bar(),
   el procesamiento de foo()
   la ha hecho accesible. */

bar();

?>

Todas las funciones y clases de PHP tienen ámbito global. Se pueden llamar desde fuera de una función incluso si fueron definidas dentro, y viceversa.

PHP no admite la sobrecarga de funciones, ni es posible 'desdefinir' ni redefinir funciones previamente declaradas.

Nota: Los nombres de las fuciones son insensibles a mayúsculas-minúsculas, aunque es una buena idea llamar a las funciones tal y como aparecen en sus declaraciones.

Las funciones admiten un número variable de argumentos y argumentos predeterminados. Véanse también las referencias de funciones para func_num_args(), func_get_arg(), y func_get_args() para más información.

En PHP es posible llamar a funciones recursivas.

Ejemplo #4 Funciones recursivas

<?php
function recursividad($a)
{
    if ($a < 20) {
        echo "$a\n";
        recursividad($a + 1);
    }
}
?>

Nota: Las llamadas a funciones/métodos recursivos con más de 100-200 niveles de recursividad pueden agotar la pila y ocasionar la finalización del script en curso. Especialmente, las recurisvidades infinitas están consideradas un error de programación.


Argumentos de funciones

Cualquier información puede ser pasada a las funciones mediante la lista de argumentos, la cual es una lista de expresiones delimitadas por comas. Los argumentos son evaluados de izquierda a derecha.

PHP admite el paso de argumentos por valor (lo predeterminado), el paso por referencia, y valores de argumentos predeterminados. Las Listas de argumentos de longitud variable también están soportadas.

Ejemplo #1 Pasar arrays a funciones

<?php
function tomar_array($entrada)
{
    echo "$entrada[0] + $entrada[1] = ".$entrada[0]+$entrada[1];
}
?>

Paso de argumentos por referencia

Por defecto, los argumentos de las funciones son pasados por valor (así, si el valor del argumento dentro de la función cambia, este no cambia fuera de la función). Para permitir a una función modificar sus argumentos, éstos deben pasarse por referencia.

Para hacer que un argumento a una función sea siempre pasado por referencia hay que anteponer al nombre del argumento el signo 'et' (&) en la definición de la función:

Ejemplo #2 Paso de parámetros de una función por referencia

<?php
function añadir_algo(&$cadena)
{
    $cadena .= 'y algo más.';
}
$cad = 'Esto es una cadena, ';
añadir_algo($cad);
echo $cad;    // imprime 'Esto es una cadena, y algo más.'
?>

Valores de argumentos predeterminados

Una función puede definir valores predeterminados al estilo de C++ para argumentos escalares como sigue:

Ejemplo #3 Uso de parámetros predeterminados en funciones

<?php
function hacer_café($tipo = "capuchino")
{
    return "Hacer una taza de $tipo.\n";
}
echo hacer_café();
echo hacer_café(null);
echo hacer_café("espresso");
?>

El resultado del ejemplo sería:

Hacer una taza de capuchino.
Hacer una taza de .
Hacer una taza de espresso.

PHP también permite el uso de arrays y del tipo especial null como valores predeterminados, por ejemplo:

Ejemplo #4 Usar tipos no escalares como valores predeterminados

<?php
function hacer_café($tipos = array("capuchino"), $fabricanteCafé = NULL)
{
    $aparato = is_null($fabricanteCafé) ? "las manos" : $fabricanteCafé;
    return "Hacer una taza de ".join(", ", $tipos)." con $aparato.\n";
}
echo hacer_café();
echo hacer_café(array("capuchino", "lavazza"), "una tetera");
?>

El valor predeterminado debe ser una expresión constante, no (por ejemplo) una variable, un miembro de una clase o una llamada a una función.

Obsérvese que cuando se emplean argumentos predeterminados, cualquiera de ellos debería estar a la derecha de los argumentos no predeterminados; si no, las cosas no funcionarán como se esperaba. Considérese el siguiente trozo de código:

Ejemplo #5 Uso incorrecto de argumentos predeterminados en una función

<?php
function hacer_yogur($tipo = "acidófilo", $sabor)
{
    return "Hacer un tazón de yogur $tipo de $sabor.\n";
}

echo hacer_yogur("frambuesa");   // no funcionará como se esperaba
?>

El resultado del ejemplo sería:

Warning: Missing argument 2 in call to hacer_yogur() in
/usr/local/etc/httpd/htdocs/phptest/functest.html on line 41
Hacer un tazón de yogur frambuesa de .

Ahora, compare el ejemplo de arriba con este:

Ejemplo #6 Uso correcto de argumentos predeterminados en una función

<?php
function hacer_yogur($sabor, $tipo = "acidófilo")
{
    return "Hacer un tazón de yogur $tipo de $sabor.\n";
}

echo hacer_yogur("frambuesa");   // funciona como se esperaba
?>

El resultado del ejemplo sería:

Hacer un tazón de yogur acidófilo de frambuensa.

Nota: A partir de PHP 5, los argumentos pasados por referencia pueden tener un valor predeterminado.

Declaraciones de tipo

Nota:

La declaración de tipos también se conoce como 'Determinación de tipos' en PHP 5.

Las declaraciones de tipo permiten a las funciones requerir que los parámetros sean de cierto tipo durante una llamada. Si el valor dado es de un tipo incorrecto, se generará un error: en PHP 5, este error es un error fatal recuperable, mientras que PHP 7 lanzará una excepción TypeError.

Para especificar una declaración de tipo, debe anteponerse el nombre del tipo al nombre del parámetro. Se puede hacer que una declaración acepte valores null si el valor predeterminado del parámetro se establece a null.

Tipos válidos

Tipo | Descripción | Versión de PHP mínima
nombre de clase/interfaz | El parámetro debe ser una instanceof del nombre de la clase o interfaz dada. | PHP 5.0.0
self | El parámetro debe ser una instanceof de la misma clase donde está definido el método. Esto solamente se puede utilizar en clases y métodos de instancia. | PHP 5.0.0
array | El parámetro debe ser un array. | PHP 5.1.0
callable | El parámetro debe ser un callable válido. | PHP 5.4.0
bool | El parámetro debe ser un valor de tipo boolean. | PHP 7.0.0
float | El parámetro debe ser un número de tipo float. | PHP 7.0.0
int | El parámetro debe ser un valor de tipo integer. | PHP 7.0.0
string | El parámetro debe ser un string. | PHP 7.0.0
iterable | El parámetro debe ser un array o una instanceof Traversable. | PHP 7.1.0
object | El parámetro debe ser un object. | PHP 7.2.0
Advertencia

Los alias de los tipos escalares anteriores no están admitidos. En su lugar, son tratados como nombres de clases o de interfaces. Por ejemplo, el empleo de boolean como parámetro o como tipo devuelto requerirá un argumento o un valor devuelto que sea unaan instanceof de la clase o interfaz boolean, más que el tipo bool:

<?php
 function prueba(boolean $param) {}
 prueba(true);
 ?>

El resultado del ejemplo sería:

 Fatal error: Uncaught TypeError: Argument 1 passed to test() must be an instance of boolean, boolean given, called in - on line 1 and defined in -:1

Ejemplos

Ejemplo #7 Declaración básica de tipo clase

<?php
class C {}
class D extends C {}

// Esta no extiende a C.
class E {}

function f(C $c) {
    echo get_class($c)."\n";
}

f(new C);
f(new D);
f(new E);
?>

El resultado del ejemplo sería:

C
D

Fatal error: Uncaught TypeError: Argument 1 passed to f() must be an instance of C, instance of E given, called in - on line 14 and defined in -:8
Stack trace:
#0 -(14): f(Object(E))
#1 {main}
  thrown in - on line 8

Ejemplo #8 Declaración básica de tipo interfaz

<?php
interface I { public function f(); }
class C implements I { public function f() {} }

// Esta no implementa I.
class E {}

function f(I $i) {
    echo get_class($i)."\n";
}

f(new C);
f(new E);
?>

El resultado del ejemplo sería:

C

Fatal error: Uncaught TypeError: Argument 1 passed to f() must implement interface I, instance of E given, called in - on line 13 and defined in -:8
Stack trace:
#0 -(13): f(Object(E))
#1 {main}
  thrown in - on line 8

Ejemplo #9 Tipos de parámetros pasados por referencia

Los tipos declarados de parámetros de referencia se comprueban en la entrada de la función, pero no cuando la función vuelve, así que después de que la función haya vuelto, el el tipo de argumento puede haber cambiado.

<?php
function array_baz(array &$param)
{
    $param = 1;
}
$var = [];
array_baz($var);
var_dump($var);
array_baz($var);
?>

El resultado del ejemplo sería algo similar a:

int(1)

Fatal error: Uncaught TypeError: Argument 1 passed to array_baz() must be of the type array, int given, called in %s on line %d

Ejemplo #10 Declaración de tipo nulo

<?php
class C {}

function f(C $c = null) {
    var_dump($c);
}

f(new C);
f(null);
?>

El resultado del ejemplo sería:

object(C)#1 (0) {
}
NULL

Tipificación estricta

Por defecto, PHP fuerza a los valores de un tipo erróneo a ser del tipo escalar esperado si es posible. Por ejemplo, una función a la que se le pasa un integer para un parámetro que se prevé sea un string obtendrá una variable de tipo string.

Es posible habilitar el modo estricto en función de cada fichero. El el modo estricto solamente será aceptada una variable del tipo exacto de la declaración de tipo, o será lanzada una TypeError. La única excepción a esta regla es que se podría proporcionar un integer a una función que espere un float. Las llamadas a funciones desde dentro de funciones internas no se verán afectadas por la declaración strict_types.

Para habilitar el modo escricto se emplea la sentencia declare con la declaración strict_types:

Precaución

Habilitar el modo esctricto también afectará a las declaraciones de tipo de devolución.

Nota:

La tipificación estricta se aplica a las llamadas a funciones hechas desde dentro del fichero con la tipificación estricta habilitada, no a las funciones declaradas dentro del fichero. Si un fichero sin la tipificación estricta habilitada realiza una llamada a una función definida en un fichero con tipificación estricta, será respetada la preferencia del llamador (tipificación débil), y se forzará el valor.

Nota:

La tipificación estricta solamente se define para declaraciones de tipos escalares, y como tal, requiere PHP 7.0.0 o posterior, ya que las declaraciones de tipo escalar fueron añadidas en esta versión.

Ejemplo #11 Tipificación estricta

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1.5, 2.5));
?>

El resultado del ejemplo sería:

int(3)

Fatal error: Uncaught TypeError: Argument 1 passed to sum() must be of the type integer, float given, called in - on line 9 and defined in -:4
Stack trace:
#0 -(9): sum(1.5, 2.5)
#1 {main}
  thrown in - on line 4

Ejemplo #12 Tipificación débil

<?php
function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));

// Estos números serán forzados a ser enteros: ¡observe la salida de abajo!
var_dump(sum(1.5, 2.5));
?>

El resultado del ejemplo sería:

int(3)
int(3)

Ejemplo #13 Capturar la excepción TypeError

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

try {
    var_dump(sum(1, 2));
    var_dump(sum(1.5, 2.5));
} catch (TypeError $e) {
    echo 'Error: '.$e->getMessage();
}
?>

El resultado del ejemplo sería:

int(3)
Error: Argument 1 passed to sum() must be of the type integer, float given, called in - on line 10

Listas de argumentos de longitud variable

PHP tiene soporte para listas de argumentos de longitud variable en funciones definidas por el usuario. Esto se implementa utilizando el token ... en PHP 5.6 y posteriores, y utilizando las funciones func_num_args(), func_get_arg(), y func_get_args() en PHP 5.5 y anteriores.

... en PHP 5.6+

En PHP 5.6 y posteriores, las listas de argumentos pueden incluir el token ... para denotar que la función acepta un número variable de argumentos. Los argumentos serán pasados a la variable dada como un aryay, por ejemplo:

Ejemplo #14 Usando ... para acceder a argumentos variables

<?php
function sum(...$números) {
    $acc = 0;
    foreach ($números as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

El resultado del ejemplo sería:

10

También se puede emplear ... al llamar a funciones para convertir un array o variable Traversable o literal en una lista de argumentos:

Ejemplo #15 Usar ... para proporcionar argumentos

<?php
function add($a, $b) {
    return $a + $b;
}

echo add(...[1, 2])."\n";

$a = [1, 2];
echo add(...$a);
?>

El resultado del ejemplo sería:

3
3

Se puede especifcar argumentos posicionales normales antes del token .... En este caso, solamente los argumentos al final que no coincidan con un argumento posicional serán añadidos al array generado por ....

También es posible añadir una declaración de tipo antes del símbolo .... Si está presente, todos los argumentos capturados por ... deben ser objetos de la clase implicada.

Ejemplo #16 Argumentos variables de declaración de tipo

<?php
function total_intervals($unit, DateInterval ...$intervals) {
    $time = 0;
    foreach ($intervals as $interval) {
        $time += $interval->$unit;
    }
    return $time;
}

$a = new DateInterval('P1D');
$b = new DateInterval('P2D');
echo total_intervals('d', $a, $b).' days';

// Esto fallará, debido a que  null no es un objeto de DateInterval.
echo total_intervals('d', null);
?>

El resultado del ejemplo sería:

3 days
Catchable fatal error: Argument 2 passed to total_intervals() must be an instance of DateInterval, null given, called in - on line 14 and defined in - on line 2

Por último, también es pueden pasar argumentos variables por referencia prefijando ... con el signo (&).

Versiones antiguas de PHP

No se requiere una sintaxis especial para señalar que una función es varíadica; sin embargo, para acceder a los argumentos de la función se debe usar func_num_args(), func_get_arg() y func_get_args().

El primer ejemplo de antes se implementaría en PHP 5.5 y anteriores como sigue:

Ejemplo #17 Acceder a argumentos variables en PHP 5.5 y anteriores

<?php
function sum() {
    $acc = 0;
    foreach (func_get_args() as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

El resultado del ejemplo sería:

10

Named Arguments

PHP 8.0.0 introduced named arguments as an extension of the existing positional parameters. Named arguments allow passing arguments to a function based on the parameter name, rather than the parameter position. This makes the meaning of the argument self-documenting, makes the arguments order-independent and allows skipping default values arbitrarily.

Named arguments are passed by prefixing the value with the parameter name followed by a colon. Using reserved keywords as parameter names is allowed. The parameter name must be an identifier, specifying dynamically is not allowed.

Ejemplo #18 Named argument syntax

<?php
myFunction(paramName: $value);
array_foobar(array: $value);

// NOT supported.
function_name($variableStoringParamName: $value);
?>

Ejemplo #19 Positional arguments versus named arguments

<?php
// Using positional arguments:
array_fill(0, 100, 50);

// Using named arguments:
array_fill(start_index: 0, count: 100, value: 50);
?>

The order in which the named arguments are passed does not matter.

Ejemplo #20 Same example as above with a different order of parameters

<?php
array_fill(value: 50, num: 100, start_index: 0);
?>

Named arguments can be combined with positional arguments. In this case, the named arguments must come after the positional arguments. It is also possible to specify only some of the optional arguments of a function, regardless of their order.

Ejemplo #21 Combining named arguments with positional arguments

<?php
htmlspecialchars($string, double_encode: false);
// Same as
htmlspecialchars($string, ENT_COMPAT | ENT_HTML401, 'UTF-8', false);
?>

Passing the same parameter multiple times results in an Error exception.

Ejemplo #22 Error exception when passing the same parameter multiple times

<?php
function foo($param) { ... }

foo(param: 1, param: 2);
// Error: Named parameter $param overwrites previous argument
foo(1, param: 2);
// Error: Named parameter $param overwrites previous argument
?>


Devolver valores

Los valores son devueltos usando la sentencia opcional return. Se puede devolver cualquier tipo, incluidos arrays y objetos. Esto causa que la función finalice su ejecución inmediatamente y pase el control de nuevo a la línea desde la que fue llamada. Véase return para más información.

Nota:

Si se omite return, el valor devuelto será null.

Empleo de return

Ejemplo #1 Empleo de return

<?php
function cuadrado($núm)
{
    return $núm * $núm;
}
echo cuadrado(4);   // imprime '16'.
?>

Una función no puede devolver múltiples valores, pero se pueden obtener resultados similares devolviendo un array.

Ejemplo #2 Devolver un array para obtener múltiples valores

<?php
function números_pequeños()
{
    return array (0, 1, 2);
}
list ($cero, $uno, $dos) = números_pequeños();
?>

Para devolver una referencia desde una función use el operador de referencia &, en la declaración de la función y cuando se asigne el valor devuelto a una variable:

Ejemplo #3 Devolver una referencia desde una función

<?php
function &devolver_referencia()
{
    return $algunaref;
}

$nuevaref =& devolver_referencia();
?>

Para más información sobre referencias, por favor, lea las Referencias explicadas.

Declaraciones de tipo de devolución

PHP 7 añade soporte para las declaraciones de tipo de devolución. De forma similar a las declaraciones de tipo de argumento, las declaraciones de tipo de devolución especifican el tipo del valor que serán devuelto desde una función. Están disponibles los mismos tipos para las declaraciones de tipo de devolución que para las declaraciones de tipo de argumento.

La tipificación estricta también tiene efecto sobre las declaraciones de tipo de devolución. En el modo predeterminado de tipificacón débil, los valores devueltos serán forzados al tipo correcto si no son ya de ese tipo. En el modo fuerte, el valor devuelto debe ser del tipo correcto, o de lo contrario se lanzará una excepción TypeError.

A partir de PHP 7.1.0, los valores de retorno pueden ser marcados como anulables anteponiendo el prefijo nombre de tipo con un signo de interrogación (?). Esto significa que la función devuelve el tipo especificado o null.

Nota:

Al sobrescribir un método padre, el método hijo debe hacer coincidir cualquier declaración de tipo de devolución del padre. Si el padre no define un tipo de devolución, el método hijo puede hacerlo.

Ejemplos

Ejemplo #4 Declaración básica de tipo de devolución

<?php
function sum($a, $b): float {
    return $a + $b;
}

// Observe que será devuelto un float.
var_dump(sum(1, 2));
?>

El resultado del ejemplo sería:

float(3)

Ejemplo #5 El modo estricto en acción

<?php
declare(strict_types=1);

function sum($a, $b): int {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1, 2.5));
?>

El resultado del ejemplo sería:

int(3)

Fatal error: Uncaught TypeError: Return value of sum() must be of the type integer, float returned in - on line 5 in -:5
Stack trace:
#0 -(9): sum(1, 2.5)
#1 {main}
  thrown in - on line 5

Ejemplo #6 Devolver un objeto

<?php
class C {}

function getC(): C {
    return new C;
}

var_dump(getC());
?>

El resultado del ejemplo sería:

object(C)#1 (0) {
}

Ejemplo #7 Declaración de tipo de retorno anulable (a partir de PHP 7.1.0)

<?php
function get_item(): ?string {
    if (isset($_GET['item'])) {
        return $_GET['item'];
    } else {
        return null;
    }
}
?>


Funciones variables

PHP admite el concepto de funciones variables. Esto significa que si un nombre de variable tiene paréntesis anexos a él, PHP buscará una función con el mismo nombre que lo evaluado por la variable, e intentará ejecutarla. Entre otras cosas, esto se puede usar para implementar llamadas de retorno, tablas de funciones, y así sucesivamente.

Las funciones variables no funcionarán con constructores de lenguaje como echo, print, unset(), isset(), empty(), include, require y similares. Utilice funciones de envoltura para hacer uso de cualquiera de estos constructores como funciones variables.

Ejemplo #1 Ejemplo de función variable

<?php
function foo() {
    echo "En foo()<br />\n";
}

function bar($arg = '')
{
    echo "En bar(); el argumento era '$arg'.<br />\n";
}

// Esta es una función de envoltura alrededor de echo
function hacerecho($cadena)
{
    echo $cadena;
}

$func = 'foo';
$func();        // Esto llama a foo()

$func = 'bar';
$func('prueba');  // Esto llama a bar()

$func = 'hacerecho';
$func('prueba');  // Esto llama a hacerecho()
?>

Los métodos de objetos también puede ser llamados con la sintaxis de funciones variables.

Ejemplo #2 Ejemplo de método variable

<?php
class Foo
{
    function Variable()
    {
        $nombre = 'Bar';
        $this->$nombre(); // Esto llama al método Bar()
    }

    function Bar()
    {
        echo "Esto es Bar";
    }
}

$foo = new Foo();
$nombrefunc = "Variable";
$foo->$nombrefunc();  // Esto llama a $foo->Variable()

?>

Cuando se llaman a métodos estáticos, la llamada a la función es más fuerte que el operador de propiedad estática:

Ejemplo #3 Ejemplo de método variable con propiedades estáticas

<?php
class Foo
{
    static $variable = 'propiedad estática';
    static function Variable()
    {
        echo 'Método Variable llamado';
    }
}

echo Foo::$variable; // Esto imprime 'propiedad estática'. No necesita una $variable en este ámbito.
$variable = "Variable";
Foo::$variable();  // Esto llama a $foo->Variable() leyendo $variable en este ámbito.

?>

A partir de PHP 5.4.0, se puede llamar a cualquier callable almacenado en una variable.

Ejemplo #4 Llamables complejos

<?php
class Foo
{
    static function bar()
    {
        echo "bar\n";
    }
    function baz()
    {
        echo "baz\n";
    }
}

$func = array("Foo", "bar");
$func(); // imprime "bar"
$func = array(new Foo, "baz");
$func(); // imprime "baz"
$func = "Foo::bar";
$func(); // imprime "bar" a partrid de PHP 7.0.0; antes, emitía un error fatal
?>

Véase también is_callable(), call_user_func(), variables variables y function_exists().

Historial de cambios

Versión | Descripción
7.0.0 | 'NombreDeClase::NombreDeMétodo' se permite como función variable.
5.4.0 | Los arrays, que son llamables válidos, están permitidos como funciones variables.


Funciones internas (incluidas)

PHP se estandariza con muchas funciones y construcciones. También existen funciones que necesitan extensiones específicas de PHP compiladas, si no, aparecerán errores fatales "undefined function" ("función no definida"). Por ejemplo, para usar las funciones de image tales como imagecreatetruecolor(), PHP debe ser compilado con soporte para GD. O para usar mysql_connect(), PHP debe ser compilado con soporte para MySQLi. Hay muchas funciones de núcleo que está incluidas en cada versión de PHP, tales como las funciones de string y de variable. Una llamada a phpinfo() o get_loaded_extensions() mostrará las extensiones que están cargadas en PHP. Observe también que muchas extensiones están habilitadas por defecto y que el manual de PHP está dividido por extensiones. Véase configuración, instalación, y capítulos individuales de extensiones para más información sobre cómo configurar PHP.

Interpretar y comprender un prototipo de una función está explicado dentro de la sección del manual titulada cómo interpretar la definición de una función. Es importante comprender lo que devuelve una función o si una función funciona directamente con un valor pasado. Por ejemplo, str_replace() devolverá la cadena modificada mientras que usort() funciona con la variable actual pasada. Cada página del manual también tiene información específica para cada función, como información sobre parámetros de funciones, cambios de comportamiento, valores devueltos en caso de éxito o fallo, e información de disponibilidad. Conocer estas importantes diferencias (a menudo imperceptibles) es crucial para escribir código de PHP correcto.

Nota: Si los parámetros dados a una función no son los que se esperaban, como pasar un array donde se esperaba un string, el valor devuelto de la función será indefinido. En este caso lo más probable es que devuelva null pero esto es sólo una convención, y no se puede confiar en ello.

Véase también function_exists(), la referencia de funciones, get_extension_funcs(), y dl().


Funciones anónimas

Las funciones anónimas, también conocidas como cierres (closures), permiten la creación de funciones que no tienen un nombre especificado. Son más útiles como valor de los parámetros de llamadas de retorno, pero tienen muchos otros usos.

Las funciones anónimas están implementadas utilizando la clase Closure.

Ejemplo #1 Ejemplo de función anónima

<?php
echo preg_replace_callback('~-([a-z])~', function ($coincidencia) {
    return strtoupper($coincidencia[1]);
}, 'hola-mundo');
// imprime holaMundo
?>

Los cierres también se pueden usar como valores de variables; PHP automáticamente convierte tales expresiones en instancias de la clase interna Closure. La asignación de un cierre a una variable emplea la misma sintaxis que cualquier otra asignación, incluido el punto y coma final:

Ejemplo #2 Ejemplo de asignación de variable de una función anónima

<?php
$saludo = function($nombre)
{
    printf("Hola %s\r\n", $nombre);
};

$saludo('Mundo');
$saludo('PHP');
?>

Los cierres también pueden heredar variables del ámbito padre. Cualquier variable debe ser pasada al constructor de lenguaje use. Desde PHP 7.1, estas variables no deben incluir superglobals, $this, o variables con el mismo nombre que un parámetro.

Ejemplo #3 Heredar variables de un ámbito padre

<?php
$mensaje = 'hola';

// Sin "use"
$ejemplo = function () {
    var_dump($mensaje);
};
$ejemplo();

// Heredar $mensaje
$ejemplo = function () use ($mensaje) {
    var_dump($mensaje);
};
$ejemplo();

// El valor de la variable heredada está cuando la función
// está definida, no cuando se le invoca
$mensaje = 'mundo';
$ejemplo();

// Reiniciar el mensaje
$mensaje = 'hola';

// Heredar por referencia
$ejemplo = function () use (&$mensaje) {
    var_dump($mensaje);
};
$ejemplo();

// El valor cambiado en el ámbito padre
// se refleja dentro de la llamada a la función
$mensaje = 'mundo';
$ejemplo();

// Los cierres también aceptan argumentos normales
$ejemplo = function ($arg) use ($mensaje) {
    var_dump($arg . ' ' . $mensaje);
};
$ejemplo("hola");
?>

El resultado del ejemplo sería algo similar a:

Notice: Undefined variable: message in /example.php on line 6
NULL
string(4) "hola"
string(4) "hola"
string(4) "hola"
string(5) "mundo"
string(10) "hola mundo"

Heredar variables del ámbito padre no es lo mismo que usar variables globales. Las variables globales existen en el ámbito global, lo que implica que no importa qué función se esté ejecutando. El ámbito padre de un cierre es la función en la que dicho cierre fue declarado (no necesariamente la función desde la que se llamó). Vea el siguiente ejemplo:

Ejemplo #4 Cierres y ámbito

<?php
// Un carro de compras básico que contiene una lista de productos añadidos
// y la cantidad de cada producto. Incluye un método que
// calcula el precio total de los artículos del carro usando un
// cierre como llamada de retorno.
class Carro
{
    const PRECIO_MANTEQUILLA = 1.00;
    const PRECIO_LECHE       = 3.00;
    const PRECIO_HUEVOS      = 6.95;

    protected $productos = array();

    public function añadir($producto, $cantidad)
    {
        $this->productos[$producto] = $cantidad;
    }

    public function obtenerCantidad($producto)
    {
        return isset($this->productos[$producto]) ? $this->productos[$producto] :
               FALSE;
    }

    public function obtenerTotal($impuesto)
    {
        $total = 0.00;

        $llamadaDeRetorno =
            function ($cantidad, $producto) use ($impuesto, &$total)
            {
                $precioUnidad = constant(__CLASS__ . "::PRECIO_" .
                    strtoupper($producto));
                $total += ($precioUnidad * $cantidad) * ($impuesto + 1.0);
            };

        array_walk($this->productos, $llamadaDeRetorno);
        return round($total, 2);
    }
}

$mi_carro = new Carro;

// Añadir algunos artículos al carro
$mi_carro->añadir('mantequilla', 1);
$mi_carro->añadir('leche', 3);
$mi_carro->añadir('huevos', 6);

// Imprimir el total con un impuesto de venta del 5%.
print $mi_carro->obtenerTotal(0.05) . "\n";
// El resultado es 54.29
?>

Ejemplo #5 Vinculación automática de $this

<?php

class Test
{
    public function testing()
    {
        return function() {
            var_dump($this);
        };
    }
}

$object = new Test;
$function = $object->testing();
$function();

?>

El resultado del ejemplo sería:

object(Test)#1 (0) {
}

Salida del ejemplo anterior en PHP 5.3:

Notice: Undefined variable: this in script.php on line 8
NULL

A partir de PHP 5.4.0, cuando se declara en el contexto de una clase, la clase actual está vinculada a ella automáticamente, haciendo que $this esté disponible dentro del ámbito de la función. Si no se desea esta vinculación automática de la clase actual, se deberían usar funcions anónimas estáticas en su lugar.

Static anonymous functions

A partir de PHP 5.4, las funciones anónimas pueden ser declaradas estáticamente. Esto evita tener la clase actual vinculada automáticamente a ellas. Los objetos tampoco podrían vincularse a ellas durante la ejecución.

Ejemplo #6 Intentar usar $this dentro de una función anónima estática

<?php

class Foo
{
    function __construct()
    {
        $func = static function() {
            var_dump($this);
        };
        $func();
    }
};
new Foo();

?>

El resultado del ejemplo sería:

Notice: Undefined variable: this in %s on line %d
NULL

Ejemplo #7 Intentar vincular un objeto a una función anónima estática

<?php

$func = static function() {
    // cuerpo de la función
};
$func = $func->bindTo(new StdClass);
$func();

?>

El resultado del ejemplo sería:

Warning: Cannot bind an instance to a static closure in %s on line %d

Historial de cambios

Versión | Descripción
7.1.0 | Las funciones anónimas no pueden tener un cierre sobre superglobals, $this, o cualquier variable con el mismo nombre que un parámetro.
5.4.0 | Las funciones anónimas pueden usar $this, así como ser declaradas státicamente.
5.3.0 | Las funciones anónimas se encuentran disponibles.

Notas

Nota: Es posible utilizar func_num_args(), func_get_arg(), y func_get_args() desde dentro de un cierre.


Funciones de flecha

Las funciones de flecha fueron introducidas en PHP 7.4 como una sintaxis más concisa para las funciones anónimas.

Tanto las funciones anónimas como las funciones de flecha se implementan utilizando la clase Closure.

Las funciones de las flechas tienen la forma básica fn (argument_list) => expr.

Las funciones de las flechas soportan las mismas características que las funciones anónimas, excepto que el uso de variables del ámbito padre siempre es automático.

Cuando una variable utilizada en la expresión se define en el ámbito padre será implícitamente capturada por valor. En el siguiente ejemplo, las funciones $fn1 y $fn2 se comportan de la misma manera.

Ejemplo #1 Las funciones de flecha capturan las variables por valor automáticamente

<?php

$y = 1;

$fn1 = fn($x) => $x + $y;
// equivalent to using $y by value:
$fn2 = function ($x) use ($y) {
    return $x + $y;
};

var_export($fn1(3));
?>

El resultado del ejemplo sería:

4

Esto también funciona si las funciones de la flecha están anidadas:

Ejemplo #2 Las funciones de flecha capturan variables por valor automáticamente, incluso cuando están anidadas

<?php

$z = 1;
$fn = fn($x) => fn($y) => $x * $y + $z;
// Outputs 51
var_export($fn(5)(10));
?>

De manera similar a las funciones anónimas, la sintaxis de la función de la flecha permite firmas de funciones arbitrarias, incluyendo los tipos de parámetros y de retorno, valores por defecto, variadades, así como por referencia al pasar y al regresar. Todos los siguientes son ejemplos válidos de las funciones de las flechas:

Ejemplo #3 Ejemplos de funciones de flecha

<?php

fn(array $x) => $x;
static fn(): int => $x;
fn($x = 42) => $x;
fn(&$x) => $x;
fn&($x) => $x;
fn($x, ...$rest) => $rest;

?>

Las funciones de flecha utilizan la unión variable por valor. Esto es aproximadamente equivalente a realizar un use($x) para cada variable $x usada dentro de la función de la flecha. Una unión por valores significa que no es posible modificar ningún valor desde el ámbito exterior. Funciones anónimas se pueden utilizar en su lugar para las asignaciones por referencia.

Ejemplo #4 Los valores del alcance exterior no pueden ser modificados por las funciones de flecha

<?php

$x = 1;
$fn = fn() => $x++; // No tiene ningún efecto
$fn();
var_export($x);  // Salida 1

?>

Historial de cambios

Versión | Descripción
7.4.0 | Las funciones de flecha se hicieron disponibles.

Notas

Nota: Es posible utilizar func_num_args(), func_get_arg(), y func_get_args() desde dentro de una función de flecha.


Clases y objetos

Tabla de contenidos

  • Introducción
  • Lo básico
  • Propiedades
  • Constantes de clases
  • Autocarga de clases
  • Constructores y destructores
  • Visibilidad
  • Herencia de Objetos
  • Operador de Resolución de Ámbito (::)
  • La palabra reservada 'static'
  • Abstracción de clases
  • Interfaces de objetos
  • Rasgos (Traits)
  • Clases anónimas
  • Sobrecarga
  • Iteración de objetos
  • Métodos mágicos
  • Palabra clave Final
  • Clonación de Objetos
  • Comparación de Objetos
  • Enlaces estáticos en tiempo de ejecución
  • Objetos y referencias
  • Serialización de objetos
  • Covarianza y Contravarianza
  • Registro de cambios de la POO


Introducción

PHP incluye un modelo de objetos completo. Algunas de sus características son: visibilidad, clases y métodos abstractos y finales, métodos mágicos adicionales, interfaces, clonación.

PHP trata los objetos de la misma manera que las referencias o manejadores, lo que significa que cada variable contiene una referencia a un objeto en lugar de una copia de todo el objeto. Véanse los Objetos y referencias

Sugerencia

Vea también Guía de entorno de usuario para nombres.


Lo básico

class

La definición básica de una clase comienza con la palabra reservada class, seguida de un nombre de clase, y continuando con un par de llaves que encierran las definiciones de las propiedades y métodos pertenecientes a dicha clase.

El nombre de clase puede ser cualquier etiqueta válida, siempre que no sea una palabra reservada de PHP. Un nombre válido de clase comienza con una letra o un guión bajo, seguido de una cantidad arbitraria de letras, números o guiones bajos. Como expresión regular, se expresaría de la siguiente forma: ^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$.

Una clase puede tener sus propias constantes, variables (llamadas "propiedades"), y funciones (llamados "métodos").

Ejemplo #1 Definición de una clase sencilla

<?php
class ClaseSencilla
{
    // Declaración de una propiedad
    public $var = 'un valor predeterminado';

    // Declaración de un método
    public function mostrarVar() {
        echo $this->var;
    }
}
?>

La pseudovariable $this está disponible cuando un método es invocado dentro del contexto de un objeto. $this es una referencia al objeto invocador.

Advertencia

Llamar a un método no estático arroja estáticamente un Error. Antes de PHP 8.0.0, esto generaría un aviso de desaprobación obsoleta, y $this esto no estaría definido.

Ejemplo #2 Algunos ejemplos de la pseudovariable $this

<?php
class A
{
    function foo()
    {
        if (isset($this)) {
            echo '$this está definida (';
            echo get_class($this);
            echo ")\n";
        } else {
            echo "\$this no está definida.\n";
        }
    }
}

class B
{
    function bar()
    {
        A::foo();
    }
}

$a = new A();
$a->foo();

A::foo();

$b = new B();
$b->bar();

B::bar();
?>

Salida del ejemplo anterior en PHP 7:

$this está definida (A)

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 27
$this is not defined.

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 20
$this is not defined.

Deprecated: Non-static method B::bar() should not be called statically in %s  on line 32

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 20
$this is not defined.

Output of the above example in PHP 8:

$this está definida (A)

Fatal error: Uncaught Error: Non-static method A::foo() cannot be called statically in %s :27
Stack trace:
#0 {main}
  thrown in %s  on line 27

new

Para crear una instancia de una clase, se debe emplear la palabra reservada new. Un objeto se creará siempre a menos que el objeto tenga un constructor que arroje una excepción en caso de error. Las clases deberían ser definidas antes de la instanciación (y en algunos casos esto es un requerimiento).

Si se emplea un string que contenga el nombre de una clase con new, se creará una nueva instancia de esa clase. Si la clase estuviera en un espacio de nombres, se debe utilizar su nombre completo al realizar esto.

Nota:

Si no hay argumentos para pasar al constructor de la clase, se pueden omitir los paréntesis después del nombre de la clase.

Ejemplo #3 Creación de una instancia

<?php
$instancia = new ClaseSencilla();

// Esto también se puede hacer con una variable:
$nombreClase = 'ClaseSencilla';
$instancia = new $nombreClase(); // new ClaseSencilla()
?>

En el contexto de una clase, es posible crear un nuevo objeto con new self y new parent.

Cuando se asigna una instancia ya creada de una clase a una nueva variable, ésta última accederá a la misma instancia que el objeto que le fue asignado. Esta conducta es la misma que cuando se pasan instancias a una función. Se puede realizar una copia de un objeto ya creado a través de la clonación del mismo.

Ejemplo #4 Asignación de objetos

<?php

$instancia = new ClaseSencilla();

$asignada   =  $instancia;
$referencia =& $instancia;

$instancia->var = '$asignada tendrá este valor';

$instancia = null; // $instancia y $referencia son null

var_dump($instancia);
var_dump($referencia);
var_dump($asignada);
?>

El resultado del ejemplo sería:

NULL
NULL
object(ClaseSencilla)#1 (1) {
   ["var"]=>
     string(27) "$asignada tendrá este valor"
}

Existe un par de formas de crear instancias de un objecto:

Ejemplo #5 Creación de nuevos objetos

<?php
class Prueba
{
    static public function getNew()
    {
        return new static;
    }
}

class Hija extends Prueba
{}

$obj1 = new Prueba();
$obj2 = new $obj1;
var_dump($obj1 !== $obj2);

$obj3 = Prueba::getNew();
var_dump($obj3 instanceof Prueba);

$obj4 = Hija::getNew();
var_dump($obj4 instanceof Hija);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)

Es posible acceder a un miembro de un objeto recién creado en una única expresión:

Ejemplo #6 Acceder a un mimebro de un objeto recién creado

<?php
echo (new DateTime())->format('Y');
?>

El resultado del ejemplo sería algo similar a:

2016

Nota: Antes de PHP 7.1, los argumentos no se evalúan si no hay una función constructora definida.

Propiedades y métodos

Las propiedades y métodos de una clase viven en «espacios de nombres» diferentes, por tanto, es posible tener una propiedad y un método con el mismo nombre. Al hacer referencia tanto a una propiedad como a un método se utiliza la misma notación, y si se accederá a la propiedad o se llamará al método, solamente depende del contexto, es decir, si el empleo es el acceso a una variable o la llamada a una función.

Ejemplo #7 Acceso a propiedad contra llamada a método

<?php
class Foo
{
    public $bar = 'property';

    public function bar() {
        return 'method';
    }
}

$obj = new Foo();
echo $obj->bar, PHP_EOL, $obj->bar(), PHP_EOL;

El resultado del ejemplo sería:

propiedad
método

Esto significa que llamar a una función anónima que ha sido asignada a una propiedad no es posible directamte. En su lugar, la propiedad ha de ser asignada primero a una variable, por ejemplo. A partir de PHP 7.0.0, es posible llamar a dicha propiedad directamente encerrándola entre paréntesis.

Ejemplo #8 Llamar a una función anónima almacenada en una propiedad

<?php
class Foo
{
    public $bar;

    public function __construct() {
        $this->bar = function() {
            return 42;
        };
    }
}

$obj = new Foo();

echo ($obj->bar)(), PHP_EOL;

El resultado del ejemplo sería:

42

extends

Una clase puede heredar los métodos y propiedades de otra clase empleando la palabra reservada extends en la declaración de la clase. No es posible la extensión de múltiples clases; una clase sólo puede heredar de una clase base.

Los métodos y propiedades heredados pueden ser sobrescritos con la redeclaración de éstos utilizando el mismo nombre que en la clase madre. Sin embargo, si la clase madre definió un método como final, éste no podrá ser sobrescrito. Es posible acceder a los métodos sobrescritos o a las propiedades estáticas haciendo referencia a ellos con parent::.

Ejemplo #9 Herencia de clases sencilla

<?php
class ClaseExtendida extends ClaseSencilla
{
    // Redefinición del método padre
    function mostrarVar()
    {
        echo "Clase extendida\n";
        parent::mostrarVar();
    }
}

$extendida = new ClaseExtendida();
$extendida->mostrarVar();
?>

El resultado del ejemplo sería:

Clase extendida
un valor predeterminado

Signature compatibility rules

When overriding a method, its signature must be compatible with the parent method. Otherwise, a fatal error is emitted, or, prior to PHP 8.0.0, an E_WARNING level error is generated. A signature is compatible if it respects the variance rules, makes a mandatory parameter optional, and if any new parameters are optional. This is known as the Liskov Substitution Principle, or LSP for short. The constructor, and private methods are exempt from these signature compatibility rules, and thus won't emit a fatal error in case of a signature mismatch.

Ejemplo #10 Compatible child methods

<?php

class Base
{
    public function foo(int $a) {
        echo "Valid\n";
    }
}

class Extend1 extends Base
{
    function foo(int $a = 5)
    {
        parent::foo($a);
    }
}

class Extend2 extends Base
{
    function foo(int $a, $b = 5)
    {
        parent::foo($a);
    }
}

$extended1 = new Extend1();
$extended1->foo();
$extended2 = new Extend2();
$extended2->foo(1);

El resultado del ejemplo sería:

Valid
Valid

The following examples demonstrate that a child method which removes a parameter, or makes an optional parameter mandatory, is not compatible with the parent method.

Ejemplo #11 Fatal error when a child method removes a parameter

<?php

class Base
{
    public function foo(int $a = 5) {
        echo "Valid\n";
    }
}

class Extend extends Base
{
    function foo()
    {
        parent::foo(1);
    }
}

Output of the above example in PHP 8 is similar to:

Fatal error: Declaration of Extend::foo() must be compatible with Base::foo(int $a = 5) in /in/evtlq on line 13

Ejemplo #12 Fatal error when a child method makes an optional parameter mandatory

<?php

class Base
{
    public function foo(int $a = 5) {
        echo "Valid\n";
    }
}

class Extend extends Base
{
    function foo(int $a)
    {
        parent::foo($a);
    }
}

Output of the above example in PHP 8 is similar to:

Fatal error: Declaration of Extend::foo(int $a) must be compatible with Base::foo(int $a = 5) in /in/qJXVC on line 13
Advertencia

Renaming a method's parameter in a child class is not a signature incompatibility. However, this is discouraged as it will result in a runtime Error if named arguments are used.

Ejemplo #13 Error when using named arguments and parameters were renamed in a child class

<?php

class A {
    public function test($foo, $bar) {}
}

class B extends A {
    public function test($a, $b) {}
}

$obj = new B;

// Pass parameters according to A::test() contract
$obj->test(foo: "foo", bar: "bar"); // ERROR!

El resultado del ejemplo sería algo similar a:

Fatal error: Uncaught Error: Unknown named parameter $foo in /in/XaaeN:14
Stack trace:
#0 {main}
  thrown in /in/XaaeN on line 14

::class

La palabra reservada class es usada para la resolución de nombres de clases. Se puede obtener un string con el nombre completamente cualificado de la clase ClassName utilizando ClassName::class. Esto es particularmete útil con clases en espacios de nombres.

Ejemplo #14 Resolución de nombres de clases

<?php
namespace NS {
    class ClassName {
    }

    echo ClassName::class;
}
?>

El resultado del ejemplo sería:

NS\ClassName

Nota:

La resolución de nombres de clases con ::class es una transformación durante la compilación. Esto significa que, en el instante de crear el string del nombre de la clase, aún no se ha realizado ninguna autocarga. Como consecuencia, los nombres de clases se expanden incluso si la clase no existe. No se emite ningún error en tal caso.

Ejemplo #15 Missing class name resolution

<?php
print Does\Not\Exist::class;
?>

El resultado del ejemplo sería:

Does\Not\Exist

As of PHP 8.0.0, the ::class constant may also be used on objects. This resolution happens at runtime, not compile time. Its effect is the same as calling get_class() on the object.

Ejemplo #16 Object name resolution

<?php
namespace NS {
    class ClassName {
    }
}
$c = new ClassName();
print $c::class;
?>

El resultado del ejemplo sería:

NS\ClassName

Nullsafe methods and properties

As of PHP 8.0.0, properties and methods may also be accessed with the "nullsafe" operator instead: ?->. The nullsafe operator works the same as property or method access as above, except that if the object being dereferenced is null then null will be returned rather than an exception thrown. If the dereference is part of a chain, the rest of the chain is skipped.

The effect is similar to wrapping each access in an is_null() check first, but more compact.

Ejemplo #17 Nullsafe Operator

<?php

// As of PHP 8.0.0, this line:
$result = $repository?->getUser(5)?->name;

// Is equivalent to the following code block:
if (is_null($repository)) {
    $result = null;
} else {
    $user = $repository->getUser(5);
    if (is_null($user)) {
        $result = null;
    } else {
        $result = $user->name;
    }
}
?>

Nota:

The nullsafe operator is best used when null is considered a valid and expected possible value for a property or method return. For indicating an error, a thrown exception is preferable.


Propiedades

Las variables pertenecientes a una clase se llaman "propiedades". También se les puede llamar usando otros términos como "atributos" o "campos", pero para los propósitos de esta referencia se va a utilizar "propiedades". Éstas se definen usando una de las palabras reservadas public, protected, o private, seguido de una declaración normal de variable. Esta declaración puede incluir una inicialización, pero esta inicialización debe ser un valor constante, es decir, debe poder ser evaluada durante la compilación y no depender de información generada durante la ejecución.

Véase la Visibilidad para más información sobre el significado de public, protected, y private.

Nota:

Con el fin de mantener la compatibilidad con PHP 4, PHP 5 continuará aceptando el uso de la palabra reservada var en la declaración de propiedades en lugar de (o además de) public, protected, o private. Sin embargo, var ya no es necesaria. Entre las versiones 5.0 y 5.1.3 de PHP, el uso de var fue considerado obsoleto y emitía una advertencia de nivel E_STRICT; pero a partir de PHP 5.1.3 ya no está obsoleta y no se emite la advertencia.

Si se declara una propiedad utilizando var en lugar de public, protected, o private, PHP tratará dicha propiedad como si hubiera sido definida como public.

Dentro de los métodos de una clase, se puede acceder a las propiedades no estáticas utilizando -> (el operador de objeto): $this->propiedad (donde propiedad es el nombre de la propiedad). A las propiedades estáticas se puede acceder utilizando :: (doble dos puntos): self::$propiedad. Véase la palabra reservada 'static' para más información sobre la diferencia entre propiedades estáticas y no estáticas.

La pseudovariable $this está disponible dentro de cualquier método de clase cuando éste es invocado dentro del contexto de un objeto. $this es una referencia al objeto invocador (usualmente el objeto al cual pertenece el método, aunque puede que sea otro objeto si el método es llamado estáticamente desde el contexto de un objeto secundario).

Ejemplo #1 Declaración de propiedades

<?php
class ClaseSencilla
{
   // Válido a partir de PHP 5.6.0:
   public $var1 = 'hola ' . 'mundo';
   // Válido a partir de PHP 5.3.0:
   public $var2 = <<<EOD
hola mundo
EOD;
   // Válido a partir de PHP 5.6.0:
   public $var3 = 1+2;
   // Declaraciones de propiedades inválidas:
   public $var4 = self::miMétodoEstático();
   public $var5 = $myVar;

   // Declaraciones de propiedades válidas:
   public $var6 = miConstante;
   public $var7 = array(true, false);

   // Válido a partir de PHP 5.3.0:
   public $var8 = <<<'EOD'
hola mundo
EOD;
}
?>

Nota:

Existen varias funciones interesantes para manipular clases y objetos. Puede ser interesante echarle un vistazo a las Funciones de clases/objetos.

A partir de PHP 5.3.0, se puede utilizar heredocs y nowdocs en cualquier contexto de datos estáticos, incluyendo la declaración de propiedades.

Ejemplo #2 Ejemplo del uso de nowdoc para inicializar una propiedad

<?php
class foo {
   // A paritr de PHP 5.3.0
   public $bar = <<<'EOT'
bar
EOT;
   public $baz = <<<EOT
baz
EOT;
}
?>

Nota:

Se añadio soporte para Nowdoc y Heredoc en PHP 5.3.0.


Constantes de clases

Es posible definir valores constantes en función de cada clase manteniéndola invariable. Las constantes se diferencian de las variables comunes en que no utilizan el símbolo $ al declararlas o emplearlas. La visibilidad predeterminada de las constantes de clase es public.

El valor debe ser una expresión constante, no (por ejemplo) una variable, una propiedad o una llamada a una función.

También es posible que las interfaces tengan constantes. Consulte los ejemplos de la documentación de interfaces.

A partir de PHP 5.3.0, es posible referirse a una clase utilizando una variable. El valor de la variable no puede ser una palabra reservada (p.ej., self, parent o static).

Observe que las constantes de clase están asignadas una vez por clase, y no por cada instancia de la clase.

Ejemplo #1 Definición y uso de una constante

<?php
class MiClase
{
    const CONSTANTE = 'valor constante';

    function mostrarConstante() {
        echo  self::CONSTANTE . "\n";
    }
}

echo MiClase::CONSTANTE . "\n";

$nombreclase = "MiClase";
echo $nombreclase::CONSTANTE . "\n"; // A partir de PHP 5.3.0

$clase = new MiClase();
$clase->mostrarConstante();

echo $clase::CONSTANTE."\n"; // A partir de PHP 5.3.0
?>

Ejemplo #2 Ejemplo de datos estáticos

<?php
class foo {
    // A partir de PHP 5.3.0
    const BAR = <<<'EOT'
bar
EOT;
    // A partir de PHP 5.3.0
    const BAZ = <<<EOT
baz
EOT;
}
?>

Nota:

El soporte para la inicialización de constantes con la sintaxis de Heredoc y Nowdoc fue agregado en PHP 5.3.0.

La constante especial ::class está disponible a partir de PHP 5.5.0, y permite la resolución de nombres de clase completamente cualificados en la compilación. Esto es útil para clases en espacios de nombres:

Ejemplo #3 Ejemplo de ::class en espacio de nombres

<?php
namespace foo {
    class bar {
    }

    echo bar::class; // foo\bar
}
?>

Ejemplo #4 Ejemplo de expresión constante

<?php
const UNO = 1;

class foo {
    // A partir de PHP 5.6.0
    const DOS = UNO * 2;
    const TRES = UNO + self::DOS;
    const SENTENCIA = 'El valor de TRES es '.self::TRES;
}
?>

Es posible proporcionar una expresión escalar que implique literales numéricos y de string y/o constantes en el contexto de una constante de clase.

Nota:

El soporte para expresiones constantes se añadió en PHP 5.6.0.

Ejemplo #5 Modificadores de visibilidad de constantes de clase

<?php
class Foo {
    // A partir de PHP 7.1.0
    public const BAR = 'bar';
    private const BAZ = 'baz';
}
echo Foo::BAR, PHP_EOL;
echo Foo::BAZ, PHP_EOL;
?>

Salida del ejemplo anterior en PHP 7.1:

bar

Fatal error: Uncaught Error: Cannot access private const Foo::BAZ in …

Nota:

A partir de PHP 7.1.0, están permitidos los modificadores de visibilidad para constantes de clase.


Autocarga de clases

Muchos desarrolladores que escriben aplicaciones orientadas a objetos crean un fichero fuente de PHP para cada definición de clase. Una de las mayores molestias es tener que hacer una larga lista de inclusiones al comienzo de cada script (uno por cada clase).

En PHP 5 esto ya no es necesario. La función spl_autoload_register() registra cualquier número de autocargadores, posibilitando que las clases e interfaces sean cargadas automáticamente si no están definidas actualmente. Al registrar autocargadores, a PHP se le da una última oportunidad de cargar las clases o interfaces antes de que falle por un error.

Sugerencia

Aunque la función __autoload() también puede ser empleada para autocargar clases e interfaces, es preferible utilizar la función spl_autoload_register(). Esto es debido a que es una alternativa más flexible (posibilitando que se pueda especificar cualquier número de autocargadores en la aplicación, tales como los de las bibliotecas de terceros). Por esta razón, se desaconseja el uso de __autoload() y es obsoleto a partir de PHP 7.2.0.

Nota:

Antes de 5.3.0, las excepciones lanzadas en la función __autoload() no podían ser capturadas en el bloque catch, resultando en un error fatal. Desde 5.3 en adelante, esto es posible simpre que, si se lanza una excepción personalizada, esté disponible la clase de la excepción personalizada. La función __autoload() podría utilizarse recursivamente para cargar la clase de excepción personalizada.

Nota:

La autocarga no está disponible si se utiliza PHP en el modo interactivo CLI.

Nota:

Si el nombre de la clase se utiliza, por ejemplo, en call_user_func(), este puede contener algunos caracteres peligrosos tales como ../. Se recomienda no utilizar la entrada del usuario en tales funciones, o al menos verificar dicha entrada en __autoload().

Ejemplo #1 Ejemplo de autocarga

Este ejemplo intenta cargar las clases MiClase1 y MiClase2 desde los ficheros MiClase1.php y MiClase2.php, respectivamente.

<?php
spl_autoload_register(function ($nombre_clase) {
    include $nombre_clase . '.php';
});

$obj  = new MiClase1();
$obj2 = new MiClase2();
?>

Ejemplo #2 Otro ejemplo de autocarga

Este ejemplo intenta cargar la interfaz IPrueba.

<?php

spl_autoload_register(function ($nombre) {
    var_dump($nombre);
});

class Foo implements IPrueba {
}

/*
string(7) "IPrueba"

Fatal error: Interface 'IPrueba' not found in ...
*/
?>

Ejemplo #3 Autocarga con manejo de excepciones para 5.3.0+

Este ejemplo lanza una excepción y demuestra los bloques try/catch.

<?php
spl_autoload_register(function ($nombre) {
    echo "Intentando cargar $nombre.\n";
    throw new Exception("Imposible cargar $nombre.");
});

try {
    $obj = new ClaseNoCargable();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

El resultado del ejemplo sería:

Intentando cargar ClaseNoCargable.
Imposible cargar ClaseNoCargable.

Ejemplo #4 Autocarga con manejo de excepciones para 5.3.0+: Excepción personalizada ausente

Este ejemplo lanza una excepción para una excepción personalizada no cargable.

<?php
spl_autoload_register(function ($nombre) {
    echo "Intentando cargar $nombre.\n";
    throw new ExcepciónAusente("Imposible cargar $nombre.");
});

try {
    $obj = new ClaseNoCargable();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

El resultado del ejemplo sería:

Intentando cargar ClaseNoCargable.
Intentando cargar ExcepciónAusente.

Fatal error: Class 'ExcepciónAusente' not found in testExcepcionAusente.php on line 4

Ver también

  • unserialize()
  • unserialize_callback_func
  • spl_autoload_register()
  • spl_autoload()
  • __autoload()


Constructores y destructores

Constructor

__construct ( mixed ...$values = "" ) : void

PHP permite a los desarrolladores declarar métodos constructores para las clases. Aquellas que tengan un método constructor lo invocarán en cada nuevo objeto creado, lo que lo hace idóneo para cualquier inicialización que el objeto pueda necesitar antes de ser usado.

Nota: Los constructores padres no son llamados implícitamente si la clase hija define un constructor. Para ejecutar un constructor padre, se requiere invocar a parent::__construct() desde el constructor hijo. Si el hijo no define un constructor, entonces se puede heredar de la clase madre como un método de clase normal (si no fue declarada como privada).

Ejemplo #1 Utilización de nuevos constructores unificados

<?php
class BaseClass {
   function __construct() {
       print "En el constructor BaseClass\n";
   }
}

class SubClass extends BaseClass {
   function __construct() {
       parent::__construct();
       print "En el constructor SubClass\n";
   }
}

class OtherSubClass extends BaseClass {
    // heredando el constructor BaseClass
}

// En el constructor BaseClass
$obj = new BaseClass();

// En el constructor BaseClass
// En el constructor SubClass
$obj = new SubClass();

// En el constructor BaseClass
$obj = new OtherSubClass();
?>

A diferencia de otros métodos, __construct() is exempt from the usual signature compatibility rules when being extended.

Constructors are ordinary methods which are called during the instantiation of their corresponding object. As such, they may define an arbitrary number of arguments, which may be required, may have a type, and may have a default value. Constructor arguments are called by placing the arguments in parentheses after the class name.

Ejemplo #2 Using constructor arguments

<?php
class Point {
    protected int $x;
    protected int $y;

    public function __construct(int $x, int $y = 0) {
        $this->x = $x;
        $this->y = $y;
    }
}

// Pass both parameters.
$p1 = new Point(4, 5);
// Pass only the required parameter. $y will take its default value of 0.
$p2 = new Point(4);
// With named parameters (as of PHP 8.0):
$p3 = new Point(y: 5, x: 4);
?>

If a class has no constructor, or the constructor has no required arguments, the parentheses may be omitted.

Old-style constructors

Prior to PHP 8.0.0, classes in the global namespace will interpret a method named the same as the class as an old-style constructor. That syntax is deprecated, and will result in an E_DEPRECATED error but still call that function as a constructor. If both __construct() and a same-name method are defined, __construct() will be called.

In namespaced classes, or any class as of PHP 8.0.0, a method named the same as the class never has any special meaning.

Always use __construct() in new code.

Constructor Promotion

As of PHP 8.0.0, constructor parameters may also be promoted to correspond to an object property. It is very common for constructor parameters to be assigned to a property in the constructor but otherwise not operated upon. Constructor promotion provides a short-hand for that use case. The example above could be rewritten as the following.

Ejemplo #3 Using constructor property promotion

<?php
class Point {
    public function __construct(protected int $x, protected int $y = 0) {
    }
}

When a constructor argument includes a visibility modifier, PHP will interpret it as both an object property and a constructor argument, and assign the argument value to the property. The constructor body may then be empty or may contain other statements. Any additional statements will be executed after the argument values have been assigned to the corresponding properties.

Not all arguments need to be promoted. It is possible to mix and match promoted and not-promoted arguments, in any order. Promoted arguments have no impact on code calling the constructor.

Nota:

Object properties may not be typed callable due to engine ambiguity that would introduce. Promoted arguments, therefore, may not be typed callable either. Any other type declaration is permitted, however.

Nota:

Attributes placed on a promoted constructor argument will be replicated to both the property and argument.

Static creation methods

PHP only supports a single constructor per class. In some cases, however, it may be desirable to allow an object to be constructed in different ways with different inputs. The recommended way to do so is by using static methods as constructor wrappers.

Ejemplo #4 Using static creation methods

<?php
class Product {

    private ?int $id;
    private ?string $name;

    private function __construct(?int $id = null, ?string $name = null) {
        $this->id = $id;
        $this->name = $name;
    }

    public static function fromBasicData(int $id, string $name): static {
        $new = new static($id, $name);
        return $new;
    }

    public static function fromJson(string $json): static {
        $data = json_decode($json);
        return new static($data['id'], $data['name']);
    }

    public static function fromXml(string $xml): static {
        // Put your own logic here.
        $data = convert_xml_to_array($xml);
        $new = new static();
        $new->id = $data['id'];
        $new->name = $data['name'];
        return $new;
    }
}

$p1 = Product::fromBasicData(5, 'Widget');
$p2 = Product::fromJson($some_json_string);
$p3 = Product::fromXml($some_xml_string);

The constructor may be made private or protected to prevent it from being called externally. If so, only a static method will be able to instantiate the class. Because they are in the same class definition they have access to private methods, even if not of the same object instance. The private constructor is optional and may or may not make sense depending on the use case.

The three public static methods then demonstrate different ways of instantiating the object.

  • fromBasicData() takes the exact parameters that are needed, then creates the object by calling the constructor and returning the result.
  • fromJson() accepts a JSON string and does some pre-processing on it itself to convert it into the format desired by the constructor. It then returns the new object.
  • fromXml() accepts an XML string, preprocesses it, and then creates a bare object. The constructor is still called, but as all of the parameters are optional the method skips them. It then assigns values to the object properties directly before returning the result.

In all three cases, the static keyword is translated into the name of the class the code is in. In this case, Product.

Destructor

__destruct ( ) : void

PHP posee un concepto de destructor similar al de otros lenguajes orientados a objetos, tal como C++. El método destructor será llamado tan pronto como no hayan otras referencias a un objeto determinado, o en cualquier otra circunstancia de finalización.

Ejemplo #5 Ejemplo de Destructor

<?php

class MyDestructableClass
{
    function __construct() {
        print "En el constructor\n";
    }

    function __destruct() {
        print "Destruyendo " . __CLASS__ . "\n";
    }
}

$obj = new MyDestructableClass();

Como los constructores, los destructores padre no serán llamados implícitamente por el motor. Para ejecutar un destructor padre, se deberá llamar explícitamente a parent::__destruct() en el interior del destructor. También como los constructores, una clase child puede heredar el destructor de los padres si no implementa uno propio.

El destructor será invocado aún si la ejecución del script es detenida usando exit(). Llamar a exit() en un destructor evitará que se ejecuten las rutinas restantes de finalización.

Nota:

Los destructores invocados durante la finalización del script tienen los headers HTTP ya enviados. El directorio de trabajo en la fase de finalización del script puede ser diferente con algunos SAPIs (por ej., Apache).

Nota:

Intentar lanzar una excepción desde un destructor (invocado en la finalización del script) causa un error fatal.


Visibilidad

La visibilidad de una propiedad, un método o (a partir de PHP 7.1.0) una constante se puede definir anteponiendo a su declaración una de las palabras reservadas public, protected o private. A los miembros de clase declarados como 'public' se puede acceder desde donde sea; a los miembros declarados como 'protected', solo desde la misma clase, mediante clases heredadas o desde la clase padre. A los miembros declarados como 'private' únicamente se puede acceder desde la clase que los definió.

Visibilidad de propiedades

Las propiedades de clases deben ser definidas como 'public', 'private' o 'protected'. Si se declaran usando var, serán definidas como 'public'.

Ejemplo #1 Declaración de propiedades

<?php
/**
 * Definición de MyClass
 */
class MyClass
{
    public $public = 'Public';
    protected $protected = 'Protected';
    private $private = 'Private';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj = new MyClass();
echo $obj->public;    // Funciona bien
echo $obj->protected; // Error Fatal
echo $obj->private;   // Error Fatal
$obj->printHello();   // Muestra Public, Protected y Private

/**
 * Definición de MyClass2
 */
class MyClass2 extends MyClass
{
    // Se pueden redeclarar las propiedades pública y protegida, pero no la privada
    public $public = 'Public2';
    protected $protected = 'Protected2';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj2 = new MyClass2();
echo $obj2->public;    // Funciona bien
echo $obj2->protected; // Error Fatal
echo $obj2->private;   // Undefined
$obj2->printHello();   // Muestra Public2, Protected2, Undefined

?>

Nota: La forma de declaración de una variable de PHP 4 con la palabra clave var todavía es soportado (como un sinónimo de public) por razones de compatibilidad. En PHP 5 antes de 5.1.3, su uso genera un Warning E_STRICT.

Visibilidad de Métodos

Los métodos de clases pueden ser definidos como public, private, o protected. Aquellos declarados sin ninguna palabra clave de visibilidad explícita serán definidos como public.

Ejemplo #2 Declaración de métodos

<?php
/**
 * Definición de MyClass
 */
class MyClass
{
    // Declaración de un constructor public
    public function __construct() { }

    // Declaración de un método public
    public function MyPublic() { }

    // Declaración de un método protected
    protected function MyProtected() { }

    // Declaración de un método private
    private function MyPrivate() { }

    // Esto es public
    function Foo()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate();
    }
}

$myclass = new MyClass;
$myclass->MyPublic(); // Funciona
$myclass->MyProtected(); // Error Fatal
$myclass->MyPrivate(); // Error Fatal
$myclass->Foo(); // Public, Protected y Private funcionan

/**
 * Definición de MyClass2
 */
class MyClass2 extends MyClass
{
    // Esto es public
    function Foo2()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate(); // Error Fatal
    }
}

$myclass2 = new MyClass2;
$myclass2->MyPublic(); // Funciona
$myclass2->Foo2(); // Public y Protected funcionan, pero Private no

class Bar
{
    public function test() {
        $this->testPrivate();
        $this->testPublic();
    }

    public function testPublic() {
        echo "Bar::testPublic\n";
    }

    private function testPrivate() {
        echo "Bar::testPrivate\n";
    }
}

class Foo extends Bar
{
    public function testPublic() {
        echo "Foo::testPublic\n";
    }

    private function testPrivate() {
        echo "Foo::testPrivate\n";
    }
}

$myFoo = new Foo();
$myFoo->test(); // Bar::testPrivate
                // Foo::testPublic
?>

Visibilidad de las constantes

A partir de PHP 7.1.0, las constantes de clase se pueden definir como públicas, privadas o protegidas. Las constantes declaradas sin una visibilidad explítica serán definidas como públicas.

Ejemplo #3 Declaración de constantes a partir de PHP 7.1.0

<?php
/**
 * Definir MiClase
 */
class MiClase
{
    // Declarar una constante pública
    public const MY_PUBLIC = 'public';

    // Declarar una constante protegida
    protected const MY_PROTECTED = 'protected';

    // Declarar una constante privada
    private const MY_PRIVATE = 'private';

    public function foo()
    {
        echo self::MY_PUBLIC;
        echo self::MY_PROTECTED;
        echo self::MY_PRIVATE;
    }
}

$myclass = new MiClase();
MiClase::MY_PUBLIC; // Funciona
MiClase::MY_PROTECTED; // Error fatal
MiClase::MY_PRIVATE; // Error fatal
$myclass->foo(); // Funcionan Public, Protected y Private

/**
 * Definir MiClase2
 */
class MiClase2 extends MiClase
{
    // Esta es pública
    function foo2()
    {
        echo self::MY_PUBLIC;
        echo self::MY_PROTECTED;
        echo self::MY_PRIVATE; // Error fatal
    }
}

$myclass2 = new MiClase2;
echo MiClase2::MY_PUBLIC; // Funciona
$myclass2->foo2(); // Funcionan Public y Protected, pero no Private
?>

Visibilidad desde otros objetos

Los objetos del mismo tipo tendrán acceso a los miembros private y protected entre ellos aunque no sean de la misma instancia. Esto es porque los detalles específicos de implementación ya se conocen cuando se encuentra dentro de estos objetos.

Ejemplo #4 Accediendo a miembros private del mismo tipo de objeto

<?php
class Test
{
    private $foo;

    public function __construct($foo)
    {
        $this->foo = $foo;
    }

    private function bar()
    {
        echo 'Método private accedido.';
    }

    public function baz(Test $other)
    {
        // Se puede cambiar la propiedad private:
        $other->foo = 'hola';
        var_dump($other->foo);

        // También se puede invocar al método private:
        $other->bar();
    }
}

$test = new Test('test');

$test->baz(new Test('other'));
?>

El resultado del ejemplo sería:

string(5) "hola"
Método private accedido.


Herencia de Objetos

La herencia es un principio de programación bien establecido y PHP hace uso de él en su modelado de objetos. Este principio afectará la manera en que muchas clases y objetos se relacionan unas con otras.

Por ejemplo, cuando se extiende una clase, la subclase hereda todos los métodos públicos y protegidos de la clase padre. A menos que una clase sobrescriba esos métodos, mantendrán su funcionalidad original.

Esto es útil para la definición y abstracción de la funcionalidad y permite la implementación de funcionalidad adicional en objetos similares sin la necesidad de reimplementar toda la funcionalidad compartida.

Nota:

A menos que la carga automática sea utilizada, entonces las clases deben ser definidas antes de ser usadas. Si una clase se extiende a otra, entonces la clase padre debe ser declarada antes de la estructura de clase hija. Esta regla se aplica a las clases que heredan de otras clases e interfaces.

Ejemplo #1 Ejemplo de herencia

<?php

class Foo
{
    public function printItem($string)
    {
        echo 'Foo: ' . $string . PHP_EOL;
    }

    public function printPHP()
    {
        echo 'PHP is great.' . PHP_EOL;
    }
}

class bar extends Foo
{
    public function printItem($string)
    {
        echo 'Bar: ' . $string . PHP_EOL;
    }
}

$foo = new Foo();
$bar = new Bar();
$foo->printItem('baz'); // Salida: 'Foo: baz'
$foo->printPHP();       // Salida: 'PHP is great'
$bar->printItem('baz'); // Salida: 'Bar: baz'
$bar->printPHP();       // Salida: 'PHP is great'

?>


Operador de Resolución de Ámbito (::)

El Operador de Resolución de Ámbito (también denominado Paamayim Nekudotayim) o en términos simples, el doble dos-puntos, es un token que permite acceder a elementos estáticos, constantes, y sobrescribir propiedades o métodos de una clase.

Cuando se hace referencia a estos items desde el exterior de la definición de la clase, se utiliza el nombre de la clase.

A partir de PHP 5.3.0, es posible hacer referencia a una clase usando una variable. El valor de la variable no puede ser una palabra clave (por ej., self, parent y static).

Paamayim Nekudotayim podría, en un principio, parecer una extraña elección para bautizar a un doble dos-puntos. Sin embargo, mientras se escribía el Zend Engine 0.5 (que utilizó PHP 3), asi es como el equipo Zend decidió bautizarlo. En realidad, significa doble dos-puntos - en Hebreo!

Ejemplo #1 :: desde el exterior de la definición de la clase

<?php
class MyClass {
    const CONST_VALUE = 'Un valor constante';
}

$classname = 'MyClass';
echo $classname::CONST_VALUE; // A partir de PHP 5.3.0

echo MyClass::CONST_VALUE;
?>

Las tres palabras claves especiales self, parent y static son utilizadas para acceder a propiedades y métodos desde el interior de la definición de la clase.

Ejemplo #2 :: desde el interior de la definición de la clase

<?php
class OtherClass extends MyClass
{
    public static $my_static = 'variable estática';

    public static function doubleColon() {
        echo parent::CONST_VALUE . "\n";
        echo self::$my_static . "\n";
    }
}

$classname = 'OtherClass';
$classname::doubleColon(); // A partir de PHP 5.3.0

OtherClass::doubleColon();
?>

Cuando una clase extendida sobrescribe la definición parent de un método, PHP no invocará al método parent. Depende de la clase extendida el hecho de llamar o no al método parent. Esto también se aplica a definiciones de métodos Constructores y Destructores, Sobrecarga, y Mágicos.

Ejemplo #3 Invocando a un método parent

<?php
class MyClass
{
    protected function myFunc() {
        echo "MyClass::myFunc()\n";
    }
}

class OtherClass extends MyClass
{
    // Sobrescritura de definición parent
    public function myFunc()
    {
        // Pero todavía se puede llamar a la función parent
        parent::myFunc();
        echo "OtherClass::myFunc()\n";
    }
}

$class = new OtherClass();
$class->myFunc();
?>

Véase también algunos ejemplos de trucos de llamadas estáticas .


La palabra reservada 'static'

Sugerencia

Esta página describe el uso de la palabra reservada static para definir métodos y propiedades estáticos. static también se puede usar para definir variables estáticas y para enlaces estáticos en tiempo de ejecución. Por favor, consulte estas páginas para más información sobre estos significados de static.

Declarar propiedades o métodos de clases como estáticos los hacen accesibles sin la necesidad de instanciar la clase. Una propiedad declarada como static no puede ser accedida con un objeto de clase instanciado (aunque un método estático sí lo puede hacer).

Por motivos de compatibilidad con PHP 4, si no se utiliza ninguna declaración de visibilidad, se tratará a las propiedades o métodos como si hubiesen sido definidos como public.

Métodos estáticos

Debido a que los métodos estáticos se pueden invocar sin tener creada una instancia del objeto, la seudovariable $this no está disponible dentro de los métodos declarados como estáticos.

Precaución

En PHP 5, llamar a métodos no estáticos de forma estática genera una advertencia de nivel E_STRICT.

Advertencia

En PHP 7, llamar a métodos no estáticos de forma estática está obsoleto y generará una advertencia E_DEPRECATED. El soporte para las llamadas a métodos no estáticos de forma estática podría ser eliminado en el futuro.

Ejemplo #1 Ejemplo de método estático

<?php
class Foo {
    public static function unMetodoEstatico() {
        // ...
    }
}

Foo::unMetodoEstatico();
$nombre_clase = 'Foo';
$nombre_clase::unMetodoEstatico(); // A partir de PHP 5.3.0
?>

Propiedades estáticas

No se puede acceder a las propiedades estáticas a través del objeto utilizando el operador flecha (->).

Como cualquier otra variable estática de PHP, las propiedades estáticas sólo pueden ser inicializadas utilizando un string literal o una constante; las expresiones no están permitidas. Por tanto, se puede inicializar una propiedad estática con enteros o arrays (por ejemplo), pero no se puede hacer con otra variable, con el valor de devolución de una función, o con un objeto.

A partir de PHP 5.3.0, es posible hacer referencia a una clase usando una variable. El valor de la variable no puede ser una palabra reservada (p.ej., self, parent y static).

Ejemplo #2 Ejemplo de propiedad estática

<?php
class Foo
{
    public static $mi_static = 'foo';

    public function valorStatic() {
        return self::$mi_static;
    }
}

class Bar extends Foo
{
    public function fooStatic() {
        return parent::$mi_static;
    }
}

print Foo::$mi_static . "\n";

$foo = new Foo();
print $foo->valorStatic() . "\n";
print $foo->mi_static . "\n";      // "Propiedad" mi_static no definida

print $foo::$mi_static . "\n";
$nombreClase = 'Foo';
print $nombreClase::$mi_static . "\n"; // A partir de PHP 5.3.0

print Bar::$mi_static . "\n";
$bar = new Bar();
print $bar->fooStatic() . "\n";
?>


Abstracción de clases

PHP 5 introduce clases y métodos abstractos. Las clases definidas como abstractas no se pueden instanciar y cualquier clase que contiene al menos un método abstracto debe ser definida como tal. Los métodos definidos como abstractos simplemente declaran la firma del método, pero no pueden definir la implementación.

Cuando se hereda de una clase abstracta, todos los métodos definidos como abstractos en la declaración de la clase madre deben ser definidos en la clase hija; además, estos métodos deben ser definidos con la misma (o con una menos restrictiva) visibilidad. Por ejemplo, si el método abstracto está definido como protegido, la implementación de la función debe ser definida como protegida o pública, pero nunca como privada. Por otra parte, las firmas de los métodos tienen que coincidir, es decir, la declaración de tipos y el número de argumentos requeridos deben ser los mismos. Por ejemplo, si la clase derivada define un argumento opcional y la firma del método abstracto no lo hace, no habría conflicto con la firma. Esto también se aplica a los constructores a partir de PHP 5.4. Antes de PHP 5.4, las firmas del constructor podían ser diferentes.

Ejemplo #1 Ejemplo de clase abstracta

<?php
abstract class ClaseAbstracta
{
    // Forzar la extensión de clase para definir este método
    abstract protected function getValor();
    abstract protected function valorPrefijo($prefijo);

    // Método común
    public function imprimir() {
        print $this->getValor() . "\n";
    }
}

class ClaseConcreta1 extends ClaseAbstracta
{
    protected function getValor() {
        return "ClaseConcreta1";
    }

    public function valorPrefijo($prefijo) {
        return "{$prefijo}ClaseConcreta1";
    }
}

class ClaseConcreta2 extends ClaseAbstracta
{
    public function getValor() {
        return "ClaseConcreta2";
    }

    public function valorPrefijo($prefijo) {
        return "{$prefijo}ClaseConcreta2";
    }
}

$clase1 = new ClaseConcreta1;
$clase1->imprimir();
echo $clase1->valorPrefijo('FOO_') ."\n";

$clase2 = new ClaseConcreta2;
$clase2->imprimir();
echo $clase2->valorPrefijo('FOO_') ."\n";
?>

El resultado del ejemplo sería:

ClaseConcreta1
FOO_ClaseConcreta1
ClaseConcreta2
FOO_ClaseConcreta2

Ejemplo #2 Ejemplo de clase abstracta

<?php
abstract class ClaseAbstracta
{
    // El método abstracto sólo necesita definir los argumentos requeridos
    abstract protected function nombrePrefijo($nombre);

}

class ClaseConcreta extends ClaseAbstracta
{

    // La clase derivada puede definir parámetros opcionales que no estén en la estructura del prototipo
    public function nombrePrefijo($nombre, $separador = ".") {
        if ($nombre == "Pacman") {
            $prefijo = "Mr";
        } elseif ($nombre == "Pacwoman") {
            $prefijo = "Mrs";
        } else {
            $prefijo = "";
        }
        return "{$prefijo}{$separador} {$nombre}";
    }
}

$clase = new ClaseConcreta;
echo $clase->nombrePrefijo("Pacman"), "\n";
echo $clase->nombrePrefijo("Pacwoman"), "\n";
?>

El resultado del ejemplo sería:

Mr. Pacman
Mrs. Pacwoman

El código antiguo que no tenga clases o funciones definidas por el usuario llamadas 'abstract' deberían ejecutarse sin modificaciones.


Interfaces de objetos

Las interfaces de objetos permiten crear código con el cual especificar qué métodos deben ser implementados por una clase, sin tener que definir cómo estos métodos son manipulados.

Las interfaces se definen de la misma manera que una clase, aunque reemplazando la palabra reservada class por la palabra reservada interface y sin que ninguno de sus métodos tenga su contenido definido.

Todos los métodos declarados en una interfaz deben ser públicos, ya que ésta es la naturaleza de una interfaz.

implements

Para implementar una interfaz, se utiliza el operador implements. Todos los métodos en una interfaz deben ser implementados dentro de la clase; el no cumplir con esta regla resultará en un error fatal. Las clases pueden implementar más de una interfaz si se deseara, separándolas cada una por una coma.

Nota:

Antes de PHP 5.3.9, una clase no puede implementar dos interfaces que especifiquen un método con el mismo nombre, ya que podría causar ambigüedad. Las versiones más recientes de PHP permiten esto siempre y cuando los métodos duplicados tengan la misma firma.

Nota:

Las interfaces se pueden extender al igual que las clases utilizando el operador extends.

Nota:

La clase que implemente una interfaz debe utilizar exactamente las mismas estructuras de métodos que fueron definidos en la interfaz. De no cumplir con esta regla, se generará un error fatal.

Constantes

Es posible tener constantes dentro de las interfaces. Las constantes de interfaces funcionan como las constantes de clases excepto porque no pueden ser sobrescritas por una clase/interfaz que las herede.

Ejemplos

Ejemplo #1 Ejemplo de interfaz

<?php

// Declarar la interfaz 'iTemplate'
interface iTemplate
{
    public function setVariable($name, $var);
    public function getHtml($template);
}

// Implementar la interfaz
// Ésto funcionará
class Template implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }

    public function getHtml($template)
    {
        foreach($this->vars as $name => $value) {
            $template = str_replace('{' . $name . '}', $value, $template);
        }

        return $template;
    }
}
// Ésto no funcionará
// Error fatal: La Clase BadTemplate contiene un método abstracto
// y por lo tanto debe declararse como abstracta (iTemplate::getHtml)
class BadTemplate implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }
}
?>

Ejemplo #2 Interfaces extensibles

<?php
interface a
{
    public function foo();
}

interface b extends a
{
    public function baz(Baz $baz);
}

// Ésto sí funcionará
class c implements b
{
    public function foo()
    {
    }

    public function baz(Baz $baz)
    {
    }
}

// Ésto no funcionará y resultará en un error fatal
class d implements b
{
    public function foo()
    {
    }

    public function baz(Foo $foo)
    {
    }
}
?>

Ejemplo #3 Herencia múltiple de interfaces

<?php
interface a
{
    public function foo();
}

interface b
{
    public function bar();
}

interface c extends a, b
{
    public function baz();
}

class d implements c
{
    public function foo()
    {
    }

    public function bar()
    {
    }

    public function baz()
    {
    }
}
?>

Ejemplo #4 Interfaces con constantes

<?php
interface a
{
    const b = 'Interface constant';
}

// Imprime: Interface constant
echo a::b;

// Sin embargo ésto no funcionará ya que no está permitido
// sobrescribir constantes
class b implements a
{
    const b = 'Class constant';
}
?>

Una interfaz, junto con la determinación de tipos, proveen una buena forma de asegurarse que determinado objeto contiene métodos particulares. Vea el operador instanceof y la declaración de tipos.


Rasgos (Traits)

Desde su versión 5.4.0, PHP implementa una metodología de reutilización de código llamada Traits.

Los rasgos («traits» en inglés) son un mecanismo de reutilización de código en lenguajes de herencia simple, como PHP. El objetivo de un rasgo es el de reducir las limitaciones propias de la herencia simple permitiendo que los desarrolladores reutilicen a voluntad conjuntos de métodos sobre varias clases independientes y pertenecientes a clases jerárquicas distintas. La semántica a la hora combinar Traits y clases se define de tal manera que reduzca su complejidad y se eviten los problemas típicos asociados a la herencia múltiple y a los Mixins.

Un Trait es similar a una clase, pero con el único objetivo de agrupar funcionalidades muy específicas y de una manera coherente. No se puede instanciar directamente un Trait. Es por tanto un añadido a la herencia tradicional, y habilita la composición horizontal de comportamientos; es decir, permite combinar miembros de clases sin tener que usar herencia.

Ejemplo #1 Ejemplo de rasgo

<?php
trait ezcReflectionReturnInfo {
    function getReturnType() { /*1*/ }
    function getReturnDescription() { /*2*/ }
}

class ezcReflectionMethod extends ReflectionMethod {
    use ezcReflectionReturnInfo;
    /* ... */
}

class ezcReflectionFunction extends ReflectionFunction {
    use ezcReflectionReturnInfo;
    /* ... */
}
?>

Precedencia

Los miembros heredados de una clase base se sobrescriben cuando se inserta otro miembro homónimo desde un Trait. De acuerdo con el orden de precedencia, los miembros de la clase actual sobrescriben los métodos del Trait, que a su vez sobrescribe los métodos heredados.

Ejemplo #2 Ejemplo de Orden de Precedencia

Se sobrescribe un miembro de la clase base con el método insertado en MiHolaMundo a partir del Trait DecirMundo. El comportamiento es el mismo para los métodos definidos en la clase MiHolaMundo. Según el orden de precedencia los métodos de la clase actual sobrescriben los métodos del Trait, a la vez que el Trait sobrescribe los métodos de la clase base.

<?php
class Base {
    public function decirHola() {
        echo '¡Hola ';
    }
}

trait DecirMundo {
    public function decirHola() {
        parent::decirHola();
        echo 'Mundo!';
    }
}

class MiHolaMundo extends Base {
    use DecirMundo;
}

$o = new MiHolaMundo();
$o->decirHola();
?>

El resultado del ejemplo sería:

¡Hola Mundo!

Ejemplo #3 Ejemplo de Orden de Precedencia #2

<?php
trait HolaMundo {
    public function decirHola() {
        echo '¡Hola Mundo!';
    }
}

class ElMundoNoEsSuficiente {
    use HolaMundo;
    public function decirHola() {
        echo '¡Hola Universo!';
    }
}

$o = new ElMundoNoEsSuficiente();
$o->decirHola();
?>

El resultado del ejemplo sería:

¡Hola Universo!

Multiples Traits

Se pueden insertar múltiples Traits en una clase, mediante una lista separada por comas en la sentencia use.

Ejemplo #4 Uso de varios rasgos

<?php
trait Hola {
    public function decirHola() {
        echo 'Hola ';
    }
}

trait Mundo {
    public function decirMundo() {
        echo 'Mundo';
    }
}

class MiHolaMundo {
    use Hola, Mundo;
    public function decirAdmiración() {
        echo '!';
    }
}

$o = new MiHolaMundo();
$o->decirHola();
$o->decirMundo();
$o->decirAdmiración();
?>

El resultado del ejemplo sería:

Hola Mundo!

Resolución de Conflictos

Si dos Traits insertan un método con el mismo nombre, se produce un error fatal, siempre y cuando no se haya resuelto explicitamente el conflicto.

Para resolver los conflictos de nombres entre Traits en una misma clase, se debe usar el operador insteadof para elegir unívocamente uno de los métodos conflictivos.

Como esto solamente permite excluir métodos, se puede utilizar el operador as para añadir un alias a uno de los métodos. Observe que el operador as no renombra el método ni afecta a cualquier otro método.

Ejemplo #5 Resolución de Conflictos

En este ejemplo, Talker utiliza los traits A y B. Como A y B tienen métodos conflictos, se define el uso de la variante de smallTalk del trait B, y la variante de bigTalk del trait A.

Aliased_Talker hace uso del operador as para poder usar la implementación de bigTalk de B, bajo el alias adicional talk.

<?php
trait A {
    public function smallTalk() {
        echo 'a';
    }
    public function bigTalk() {
        echo 'A';
    }
}

trait B {
    public function smallTalk() {
        echo 'b';
    }
    public function bigTalk() {
        echo 'B';
    }
}

class Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
    }
}

class Aliased_Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
        B::bigTalk as talk;
    }
}
?>

Nota:

Antes de PHP 7.0, definir una propiedad en una clase con el mismo nombre que en un rasgo lanzaba un E_STRICT si la definición de la clase era compatible (misma visivilidad y mismo valor inicial).

Modificando la Visibilidad de los Métodos

Al usar el operador as, se puede también ajustar la visibilidad del método en la clase exhibida.

Ejemplo #6 Modificar la Visibilidad de un Método

<?php
trait HolaMundo {
    public function decirHola() {
        echo 'Hola Mundo!';
    }
}

// Cambiamos visibilidad de decirHola
class MiClase1 {
    use HolaMundo { decirHola as protected; }
}

// Método alias con visibilidad cambiada
// La visibilidad de decirHola no cambia
class MiClase2 {
  use HolaMundo { decirHola as private miPrivadoHola; }
}
?>

Traits Compuestos de Traits

Al igual que las clases, los Traits también pueden hacer uso de otros Traits. Al usar uno o más traits en la definición de un trait, éste puede componerse parcial o completamente de miembros definidos en esos otros traits.

Ejemplo #7 Traits compuestos de traits

<?php
trait Hola {
    public function decirHola() {
        echo 'Hola ';
    }
}

trait Mundo {
    public function decirMundo() {
        echo 'Mundo!';
    }
}

trait HolaMundo {
    use Hola, Mundo;
}

class MiHolaMundo {
    use HolaMundo;
}

$o = new MiHolaMundo();
$o->decirHola();
$o->decirMundo();
?>

El resultado del ejemplo sería:

Hola Mundo!

Miembros Abstractos de Traits

Los traits soportan el uso de métodos abstractos para imponer requisitos a la clase a la que se exhiban.

Precaución

Una clase concreta cumple este requisito definiendo un método concreto con el mismo nombre; su firma puede ser diferente.

Ejemplo #8 Expresar Resquisitos con Métodos Abstractos

<?php
trait Hola {
    public function decirHolaMundo() {
        echo 'Hola'.$this->obtenerMundo();
    }
    abstract public function obtenerMundo();
}

class MiHolaMundo {
    private $mundo;
    use Hola;
    public function obtenerMundo() {
        return $this->mundo;
    }
    public function asignarMundo($val) {
        $this->mundo = $val;
    }
}
?>

Miembros Estáticos en Traits

Los trait pueden definir miembros y métodos estáticos.

Ejemplo #9 Variables estáticas

<?php
trait Contador {
    public function inc() {
        static $c = 0;
        $c = $c + 1;
        echo "$c\n";
    }
}

class C1 {
    use Contador;
}

class C2 {
    use Contador;
}

$o = new C1(); $o->inc(); // echo 1
$p = new C2(); $p->inc(); // echo 1
?>

Ejemplo #10 Métodos Estáticos

<?php
trait EjemploEstatico {
    public static function hacerAlgo() {
        return 'Hacer algo';
    }
}

class Ejemplo {
    use EjemploEstatico;
}

Ejemplo::hacerAlgo();
?>

Propiedades

Los traits también pueden definir propiedades.

Ejemplo #11 Definir Propiedades

<?php
trait PropiedadesTrait {
    public $x = 1;
}

class EjemploPropiedades {
    use PropiedadesTrait;
}

$ejemplo = new EjemploPropiedades;
$ejemplo->x;
?>

Si un trait define una propiedad, una clase no puede definir una propiedad con el mismo nombre, a menos que sea compatible (misma visibilidad y mismo valor inicial), si no, se emitirá un error fatal. Antes de PHP 7.0, definir una propiedad en una clase con la misma visibilidad y el mismo valor inicial que en el rasgo, emitía un aviso E_STRICT.

Ejemplo #12 Resolución de Conflictos

<?php
trait PropiedadesTrait {
    public $misma = true;
    public $diferente = false;
}

class EjemploPropiedades {
    use PropiedadesTrait;
    public $misma = true; // Permitido a partir de PHP 7.0.0; aviso E_STRICT anteriormente
    public $diferente = true; // Error fatal
}
?>


Clases anónimas

En PHP 7 se ha añadido soporte para clases anónimas. Las clases anónimas son útiles cuando es necesario crear objetos sencillos y únicos.

<?php

// Código anterior a PHP 7
class Logger
{
    public function log($msg)
    {
        echo $msg;
    }
}

$util->setLogger(new Logger());

// Código de PHP 7+
$util->setLogger(new class {
    public function log($msg)
    {
        echo $msg;
    }
});

Pueden pasar argumentos a través de sus constructores, extender otras clases, implementar interfaces, y utilizar rasgos al igual que una clase normal:

<?php

class SomeClass {}
interface SomeInterface {}
trait SomeTrait {}

var_dump(new class(10) extends SomeClass implements SomeInterface {
    private $num;

    public function __construct($num)
    {
        $this->num = $num;
    }

    use SomeTrait;
});

El resultado del ejemplo sería:

object(class@anonymous)#1 (1) {
  ["Command line code0x104c5b612":"class@anonymous":private]=>
  int(10)
}

El anidamiento de una clase anónima dentro de otra clase no le proporciona acceso a ningún método o propiedad privados o protegidos de la clase externa. Para utilizar las propiedades o métodos protegidos de la clase externa, la clase anónima puede extender la clase externa. Para utilizar las propiedades privadas de la clase externa en la clase anónima, estos deben pasarse a su constructor:

<?php

class Externa
{
    private $prop = 1;
    protected $prop2 = 2;

    protected function func1()
    {
        return 3;
    }

    public function func2()
    {
        return new class($this->prop) extends Externa {
            private $prop3;

            public function __construct($prop)
            {
                $this->prop3 = $prop;
            }

            public function func3()
            {
                return $this->prop2 + $this->prop3 + $this->func1();
            }
        };
    }
}

echo (new Externa)->func2()->func3();

El resultado del ejemplo sería:

6

Todos los objetos creados por la misma declaración de clase anónima son instancias de esa misma clase.

<?php
function clase_anónima()
{
    return new class {};
}

if (get_class(clase_anónima()) === get_class(clase_anónima())) {
    echo 'misma clase';
} else {
    echo 'clase diferente';
}

El resultado del ejemplo sería:

misma clase

Nota:

Observe que el motor le asigna un nombre a las clases anónimas, como se demuestra en el siguiente ejemplo. Este nombre name ha de considerarse un detalle de implementación del cual no se debería depender.

<?php
echo get_class(new class {});

El resultado del ejemplo sería algo similar a:

class@anonymous/in/oNi1A0x7f8636ad2021


Sobrecarga

La sobrecarga en PHP ofrece los medios para crear dinámicamente propiedades y métodos. Estas entidades dinámicas se procesan por los métodos mágicos que se pueden establecer en una clase para diversas acciones.

Se invoca a los métodos de sobrecarga cuando se interactúa con propiedades o métodos que no se han declarado o que no son visibles en el ámbito activo. A lo largo de esta sección usaremos los términos propiedades inaccesibles y métodos inaccesibles para referirnos a esta combinación de declaración y visibilidad.

Todos los métodos sobrecargados deben definirse como public.

Nota:

No se puede pasar ninguno de los parámetros de estos métodos mágicos por referencia.

Nota:

La interpretación de PHP de overloading es distinta de la mayoría de los lenguajes orientados a objetos. La sobrecarga tradicionalmente ofrece la capacidad de tener múltiples métodos con el mismo nombre, pero con un tipo o un número distinto de parámetros.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió __callStatic. Se añadieron advertencias para hacer cumplir la visibilidad pública e impedir la declaración static.
5.1.0 | Se añadieron __isset() y __unset(). Se añadió el soporte para __get() para la sobrecarga de propiedades privadas.
5.0.0 | Se añadió __get().

Sobrecarga de propiedades

public __set ( string $name , mixed $value ) : void
public __get ( string $name ) : mixed
public __isset ( string $name ) : bool
public __unset ( string $name ) : void

__set() se ejecuta al escribir datos sobre propiedades inaccesibles (protegidas o privadas) o inexistentes.

__get() se utiliza para consultar datos a partir de propiedades inaccesibles (protegidas o privadas) o inexistentes.

__isset() se lanza al llamar a isset() o a empty() sobre propiedades inaccesibles (protegidas o privadas) o inexistentes.

__unset() se invoca cuando se usa unset() sobre propiedades inaccesibles (protegidas o privadas) o inexistentes.

El parámetro $name es el nombre de la propiedad con la que se está interactuando. En el método __set() el parámetro $value especifica el valor que se debe asignar a la propiedad $name.

La sobrecarga de propiedades sólo funciona en contextos de objetos. Estos métodos mágicos no se lanzarán en contextos estáticos. Por esa razón, no se deben declarar como estáticos. Desde PHP 5.3.0, se emite un aviso si alguno de los métodos de sobrecarga es declarado como static.

Nota:

Debido a la forma en que PHP procesa el operador de asignación, el valor que devuelve __set() se ignora. Del mismo modo, nunca se llama a __get() al encadenar asignaciones como esta:

 $a = $obj->b = 8;

Ejemplo #1 Sobrecarga de propiedades mediante los métodos __get(), __set(), __isset() y __unset()

<?php
class PropertyTest
{
    /**  Localización de los datos sobrecargados.  */
    private $data = array();

    /**  La sobrecarga no se usa en propiedades declaradas.  */
    public $declared = 1;

    /**  La sobre carga sólo funciona aquí al acceder desde fuera de la clase.  */
    private $hidden = 2;

    public function __set($name, $value)
    {
        echo "Estableciendo '$name' a '$value'\n";
        $this->data[$name] = $value;
    }

    public function __get($name)
    {
        echo "Consultando '$name'\n";
        if (array_key_exists($name, $this->data)) {
            return $this->data[$name];
        }

        $trace = debug_backtrace();
        trigger_error(
            'Propiedad indefinida mediante __get(): ' . $name .
            ' en ' . $trace[0]['file'] .
            ' en la línea ' . $trace[0]['line'],
            E_USER_NOTICE);
        return null;
    }

    /**  Desde PHP 5.1.0  */
    public function __isset($name)
    {
        echo "¿Está definido '$name'?\n";
        return isset($this->data[$name]);
    }

    /**  Desde PHP 5.1.0  */
    public function __unset($name)
    {
        echo "Eliminando '$name'\n";
        unset($this->data[$name]);
    }

    /**  No es un método mágico, esta aquí para completar el ejemplo.  */
    public function getHidden()
    {
        return $this->hidden;
    }
}

echo "<pre>\n";

$obj = new PropertyTest;

$obj->a = 1;
echo $obj->a . "\n\n";

var_dump(isset($obj->a));
unset($obj->a);
var_dump(isset($obj->a));
echo "\n";

echo $obj->declared . "\n\n";

echo "Vamos a probar con la propiedad privada que se llama 'hidden':\n";
echo "Las propiedades privadas pueden consultarse en la clase, por lo que no se usa __get()...\n";
echo $obj->getHidden() . "\n";
echo "Las propiedades privadas no son visibles fuera de la clase, por lo que se usa __get()...\n";
echo $obj->hidden . "\n";
?>

El resultado del ejemplo sería:

Estableciendo 'a' a '1'
Consultando 'a'
1

¿Está definido 'a'?
bool(true)
Eliminando 'a'
¿Está definido 'a'?
bool(false)

1

Vamos a probar con la propiedad privada que se llama 'hidden':
Las propiedades privadas pueden consultarse en la clase, por lo que no se usa __get()...
2
Las propiedades privadas no son visibles fuera de la clase, por lo que se usa __get()...
Consultando 'hidden'

Notice:  Propiedad indefinida mediante __get(): hidden en <file> en la línea 69 in <file>en la línea 28

Sobrecarga de métodos

public __call ( string $name , array $arguments ) : mixed
public static __callStatic ( string $name , array $arguments ) : mixed

__call() es lanzado al invocar un método inaccesible en un contexto de objeto.

__callStatic() es lanzado al invocar un método inaccesible en un contexto estático.

El parámetro $name corresponde al nombre del método al que se está llamando. El parámetro $arguments es un array enumerado que contiene los parámetros que se han pasado al método $name.

Ejemplo #2 Sobrecarga de métodos mediante los métodos __call() and __callStatic()

<?php
class MethodTest
{
    public function __call($name, $arguments)
    {
        // Nota: el valor $name es sensible a mayúsculas.
        echo "Llamando al método de objeto '$name' "
             . implode(', ', $arguments). "\n";
    }

    /**  Desde PHP 5.3.0  */
    public static function __callStatic($name, $arguments)
    {
        // Nota: el valor $name es sensible a mayúsculas.
        echo "Llamando al método estático '$name' "
             . implode(', ', $arguments). "\n";
    }
}

$obj = new MethodTest;
$obj->runTest('en contexto de objeto');

MethodTest::runTest('en contexto estático');  // Desde PHP 5.3.0
?>

El resultado del ejemplo sería:

Llamando al método de objeto 'runTest' en contexto de objeto
Llamando al método estático 'runTest' en contexto estático


Iteración de objetos

PHP 5 ofrece una manera para definir objetos, por lo que es posible recorrer una lista de elementos con, por ejemplo, una sentencia foreach. Por defecto, se utilizarán todas las propiedades visibles para la iteración.

Ejemplo #1 Iteración simple de un objeto

<?php
class MiClase
{
    public $var1 = 'valor 1';
    public $var2 = 'valor 2';
    public $var3 = 'valor 3';

    protected $protected = 'variable protegida';
    private   $private   = 'variable privada';

    function iterateVisible() {
       echo "MiClase::iterateVisible:\n";
       foreach ($this as $clave => $valor) {
           print "$clave => $valor\n";
       }
    }
}

$clase = new MiClase();

foreach($clase as $clave => $valor) {
    print "$clave => $valor\n";
}
echo "\n";

$clase->iterateVisible();

?>

El resultado del ejemplo sería:

var1 => valor 1
var2 => valor 2
var3 => valor 3

MiClase::iterateVisible:
var1 => valor 1
var2 => valor 2
var3 => valor 3
protected => variable protegida
private => variable privada

Como se muestra en la salida, foreach recorre todas las propiedades visibles a las que se pueden acceder.

Para dar un paso más, se puede implementar la interfaz Iterator. Esto permite al objeto decidir cómo será iterado y qué valores estarán disponibles en cada iteración.

Ejemplo #2 Iteración de un objeto implementando Iterator

<?php
class MiIterador implements Iterator
{
    private $var = array();

    public function __construct($array)
    {
        if (is_array($array)) {
            $this->var = $array;
        }
    }

    public function rewind()
    {
        echo "rebobinando\n";
        reset($this->var);
    }

    public function current()
    {
        $var = current($this->var);
        echo "actual: $var\n";
        return $var;
    }

    public function key()
    {
        $var = key($this->var);
        echo "clave: $var\n";
        return $var;
    }

    public function next()
    {
        $var = next($this->var);
        echo "siguiente: $var\n";
        return $var;
    }

    public function valid()
    {
        $clave = key($this->var);
        $var = ($clave !== NULL && $clave !== FALSE);
        echo "válido: $var\n";
        return $var;
    }

}

$valores = array(1,2,3);
$it = new MiIterador($valores);

foreach ($it as $a => $b) {
    print "$a: $b\n";
}
?>

El resultado del ejemplo sería:

rebobinando
válido: 1
actual: 1
clave: 0
0: 1
siguiente: 2
válido: 1
actual: 2
clave: 1
1: 2
siguiente: 3
válido: 1
actual: 3
clave: 2
2: 3
siguiente:
válido:

La interfaz IteratorAggregate se puede usar como alternativa para implementar todos los métodos de Iterator. IteratorAggregate solamente requiere la implementación de un único método, IteratorAggregate::getIterator(), el cual debería devolver una instancia de una clase que implemente Iterator.

Ejemplo #3 Iteración de un objeto implementando IteratorAggregate

<?php
class MiColección implements IteratorAggregate
{
    private $items = array();
    private $cuenta = 0;

    // Se requiere la definición de la interfaz IteratorAggregate
    public function getIterator() {
        return new MiIterador($this->items);
    }

    public function add($valor) {
        $this->items[$this->cuenta++] = $valor;
    }
}

$colección = new MiColección();
$colección->add('valor 1');
$colección->add('valor 2');
$colección->add('valor 3');

foreach ($colección as $clave => $val) {
    echo "clave/valor: [$clave -> $val]\n\n";
}
?>

El resultado del ejemplo sería:

rebobinando
actual: valor 1
válido: 1
actual: valor 1
clave: 0
clave/valor: [0 -> valor 1]

siguiente: valor 2
actual: valor 2
válido: 1
actual: valor 2
clave: 1
clave/valor: [1 -> valor 2]

siguiente: valor 3
actual: valor 3
válido: 1
actual: valor 3
clave: 2
clave/valor: [2 -> valor 3]

siguiente:
actual:
válido:

Nota:

Para más ejemplos de iteradores, véase la extensión SPL.

Nota:

Los usuarios de PHP 5.5 y posteriores pueden investigar los generadores, los cuales posibilitan una forma alternativa de definir iteradores.


Métodos mágicos

Los nombres de los métodos
__construct(),
__destruct(),
__call(),
__callStatic(),
__get(),
__set(),
__isset(),
__unset(),
__sleep(),
__wakeup(),
__toString(),
__invoke(),
__set_state(),
__clone() y
__debugInfo()
son mágicos en las clases PHP. No se
puede tener métodos con estos nombres en ninguna
clase a menos que se desee la funcionalidad mágica asociada
a estos.

Precaución

PHP se reserva todos los nombres de los métodos que comienzan con __ como mágicos. Se recomienda que no utilice los nombres de métodos con __ en PHP a menos que desee alguna funcionalidad mágica documentada.

__sleep() y __wakeup()

public __sleep ( ) : array
__wakeup ( ) : void

serialize() comprueba si la clase tiene un método con el nombre mágico __sleep(). Si es así, el método se ejecuta antes de cualquier serialización. Se puede limpiar el objeto y se supone que devuelve un array con los nombres de todas las variables de el objeto que se va a serializar. Si el método no devuelve nada, entonces null es serializado y un error E_NOTICE es emitido.

Nota:

No es posible para __sleep() devolver nombres de propiedades privadas en las clases padres. Hacer esto resultaría un nivel de error E_NOTICE. En su lugar, puede utilizar la interfaz Serializable.

El uso para el que está destinado __sleep() consiste en confirmar datos pendientes o realizar tareas similares de limpieza. Además, el método es útil si tiene objetos muy grandes que no necesitan guardarse por completo.

Por el contrario, unserialize() comprueba la presencia de un método con el nombre mágico __wakeup(). Si está presente, este método puede reconstruir cualquier recurso que el objeto pueda tener.

El uso para el que está destinado __wakeup() es restablecer las conexiones de base de datos que se puedan haber perdido durante la serialización y realizar otras tareas de reinicialización.

Ejemplo #1 Sleep y wakeup

<?php
class Connection
{
    protected $link;
    private $dsn, $username, $password;

    public function __construct($dsn, $username, $password)
    {
        $this->dsn = $dsn;
        $this->username = $username;
        $this->password = $password;
        $this->connect();
    }

    private function connect()
    {
        $this->link = new PDO($this->dsn, $this->username, $this->password);
    }

    public function __sleep()
    {
        return array('dsn', 'username', 'password');
    }

    public function __wakeup()
    {
        $this->connect();
    }
}?>

__toString()

public __toString ( ) : string

El método __toString() permite a una clase decidir cómo comportarse cuando se le trata como un string. Por ejemplo, lo que echo $obj; mostraría. Este método debe devolver un string, si no se emitirá un nivel de error fatal E_RECOVERABLE_ERROR.

Advertencia

No se puede lanzar una excepción desde dentro un método __toString(). Hacerlo resultará en un error fatal.

Ejemplo #2 Ejemplo simple

<?php
// Declarar una clase simple
class TestClass
{
    public $foo;

    public function __construct($foo)
    {
        $this->foo = $foo;
    }

    public function __toString()
    {
        return $this->foo;
    }
}

$class = new TestClass('Hola Mundo');
echo $class;
?>

El resultado del ejemplo sería:

Hola Mundo

Antes de PHP 5.2.0 el método __toString() se llama sólo cuando se combina directamente con echo o print. Desde PHP 5.2.0, se le llama en cualquier contexto de string (e.j. en printf() con el modificador %s) pero no en el contexto de otros tipos (e.j. con el modificador %d). Desde PHP 5.2.0, la conversión de los objetos sin el método __toString() a string podría causar E_RECOVERABLE_ERROR.

__invoke()

__invoke ( $... = ? ) : mixed

El método __invoke() es llamado cuando un script intenta llamar a un objeto como si fuera una función.

Nota:

Esta característica está disponible desde PHP 5.3.0.

Ejemplo #3 Uso de __invoke()

<?php
class CallableClass
{
    public function __invoke($x)
    {
        var_dump($x);
    }
}
$obj = new CallableClass;
$obj(5);
var_dump(is_callable($obj));
?>

El resultado del ejemplo sería:

int(5)
bool(true)

__set_state()

static __set_state ( array $properties ) : object

Este método static es llamado para las clases exportadas por var_export(), desde PHP 5.1.0.

El único parámetro de este método es un array que contiene las propiedades exportadas en la forma array('property' => value, ...).

Ejemplo #4 Uso de __set_state() (desde PHP 5.1.0)

<?php

class A
{
    public $var1;
    public $var2;

    public static function __set_state($an_array) // A partir de PHP 5.1.0
    {
        $obj = new A;
        $obj->var1 = $an_array['var1'];
        $obj->var2 = $an_array['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);

?>

El resultado del ejemplo sería:

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

Nota: Al exportar un objeto, var_export() no comprueba si __set_state() está implementado por la clase del objeto, por lo que la reimportación de tales objetos fallará si __set_state() no está implementado. Esto, en particular, afecta a algunas clases internas. Es responsabilidad del programador verificar que solamente se vayan a reimportar los objetos cuya clase implemente __set_state().

__debugInfo()

__debugInfo ( ) : array

Este método es invocado por var_dump() al volcar un objeto para obtener las propiedades que deberían mostrarse. Si el método no está definido sobre un objeto, se mostrarán todas las propiedades públicas protegidas y privadas.

Esta característica se añadió en PHP 5.6.0.

Ejemplo #5 Utilizar __debugInfo()

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

El resultado del ejemplo sería:

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}


Palabra clave Final

PHP 5 introduce la nueva palabra clave final, que impide que las clases hijas sobrescriban un método, antecediendo su definición con final. Si la propia clase se define como final, entonces no se podrá heredar de ella.

Ejemplo #1 Ejemplo de métodos Final

<?php
class BaseClass {
   public function test() {
       echo "llamada a BaseClass::test()\n";
   }

   final public function moreTesting() {
       echo "llamada a BaseClass::moreTesting()\n";
   }
}

class ChildClass extends BaseClass {
   public function moreTesting() {
       echo "llamada a ChildClass::moreTesting()\n";
   }
}
// Devuelve un error Fatal: Cannot override final method BaseClass::moreTesting()
?>

Ejemplo #2 Ejemplo de clase Final

<?php
final class BaseClass {
   public function test() {
       echo "llamada a BaseClass::test()\n";
   }

   // Aquí no importa si definimos una función como final o no
   final public function moreTesting() {
       echo "llamada a BaseClass::moreTesting()\n";
   }
}

class ChildClass extends BaseClass {
}
// Devuelve un error Fatal: Class ChildClass may not inherit from final class (BaseClass)
?>

Nota: Las propiedades y las constantes no pueden declararse como final. Sólo pueden las clases y los métodos.


Clonación de Objetos

No siempre se desea crear una copia de un objeto replicando todas sus propiedades completamente. Un buen ejemplo que ilustra la necesidad de contar con un constructor de copias, sería si tuviéramos un objeto que represente una ventana en GTK y el objeto almacene los recursos de esta ventana GTK, de forma que cuando creas un duplicado el comportamiento esperado sería una nueva ventana con las mismas propiedades, y que el nuevo objeto referencie a los recursos de la nueva ventana. Otro ejemplo es si un objeto hace referencia a otro objeto necesario, de forma que cuando se realiza una réplica del objeto principal, se espera que se cree una nueva instancia de este otro objeto, de forma que la réplica tenga su propia copia.

Para crear una copia de un objeto se utiliza la palabra clave clone (que invoca, si fuera posible, al método __clone() del objeto). No se puede llamar al método __clone() de un objeto directamente.

$copia_de_objeto = clone $objeto;

Cuando se clona un objeto, PHP llevará a cabo una copia superficial de las propiedades del objeto. Las propiedades que sean referencias a otras variables, mantendrán las referencias.

__clone ( ) : void

Una vez que la clonación ha finalizado, se llamará al método __clone() del nuevo objeto (si el método __clone() estuviera definido), para permitirle realizar los cambios necesarios sobre sus propiedades.

Ejemplo #1 Clonación de un objeto

<?php
class SubObject
{
    static $instances = 0;
    public $instance;

    public function __construct() {
        $this->instance = ++self::$instances;
    }

    public function __clone() {
        $this->instance = ++self::$instances;
    }
}

class MyCloneable
{
    public $object1;
    public $object2;

    function __clone()
    {
        // Forzamos la copia de this->object, si no
        // hará referencia al mismo objeto.
        $this->object1 = clone $this->object1;
    }
}

$obj = new MyCloneable();

$obj->object1 = new SubObject();
$obj->object2 = new SubObject();

$obj2 = clone $obj;

print("Objeto Original:\n");
print_r($obj);

print("Objeto Clonado:\n");
print_r($obj2);

?>

El resultado del ejemplo sería:

Objeto Original:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 1
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)
Objeto Clonado:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 3
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)

PHP 7.0.0 introdujo la posibilidad de acceder a un miembro del objeto recién clonado en una única expresión:

Ejemplo #2 Acceder a un miembre del objeto recién clonado

<?php
$dateTime = new DateTime();
echo (clone $dateTime)->format('Y');
?>

El resultado del ejemplo sería algo similar a:

2016


Comparación de Objetos

Al utilizar el operador de comparación (==), se comparan de una forma sencilla las variables de cada objeto, es decir: dos instancias de un objeto son iguales si tienen los mismos atributos y valores (los valores se comparan con ==), y son instancias de la misma clase.

Cuando se utiliza el operador identidad (===), las variables de un objeto son idénticas sí y sólo sí hacen referencia a la misma instancia de la misma clase.

Un ejemplo aclarará estas reglas.

Ejemplo #1 Ejemplo de comparación de objetos en PHP 5

<?php
function bool2str($bool)
{
    if ($bool === false) {
        return 'FALSO';
    } else {
        return 'VERDADERO';
    }
}

function compararObjetos(&$o1, &$o2)
{
    echo 'o1 == o2 : ' . bool2str($o1 == $o2) . "\n";
    echo 'o1 != o2 : ' . bool2str($o1 != $o2) . "\n";
    echo 'o1 === o2 : ' . bool2str($o1 === $o2) . "\n";
    echo 'o1 !== o2 : ' . bool2str($o1 !== $o2) . "\n";
}

class Bandera
{
    public $bandera;

    function __construct($bandera = true) {
        $this->bandera = $bandera;
    }
}

class OtraBandera
{
    public $bandera;

    function __construct($bandera = true) {
        $this->bandera = $bandera;
    }
}

$o = new Bandera();
$p = new Bandera();
$q = $o;
$r = new OtraBandera();

echo "Dos instancias de la misma clase\n";
compararObjetos($o, $p);

echo "\nDos referencias a la misma instancia\n";
compararObjetos($o, $q);

echo "\nInstancias de dos clases diferentes\n";
compararObjetos($o, $r);
?>

El resultado del ejemplo sería:

Dos instancias de la misma clase
o1 == o2 : VERDADERO
o1 != o2 : FALSO
o1 === o2 : FALSO
o1 !== o2 : VERDADERO

Dos referencias a la misma instancia
o1 == o2 : VERDADERO
o1 != o2 : FALSO
o1 === o2 : VERDADERO
o1 !== o2 : FALSO

Instancias de dos clases diferentes
o1 == o2 : FALSO
o1 != o2 : VERDADERO
o1 === o2 : FALSO
o1 !== o2 : VERDADERO

Nota:

Las extensiones pueden definir sus propias reglas para la comparación de sus objetos (==).


Enlaces estáticos en tiempo de ejecución

Desde su versión 5.3.0, PHP incorpora una nueva funcionalidad llamada enlace estático en tiempo de ejecución ("late static bindings" en inglés) que permite referirse referencias a la clase invocada en un contexto de herencia estática.

De forma más precisa, un enlace estático en tiempo de ejecución funciona almacenando el nombre de clase de la última llamada que no tenga «propagación». En el caso de llamadas a métodos estáticos, se trata de la clase nombrada explícitamente (normalmente la que precede al operador ::); en los casos de llamadas a métodos no estáticos, es clase del objeto. Una «llamada con propagación» es una llamada estática que precedida por self::, parent::, static::, o, siguiendo la jerarquía de clases, forward_static_call(). La función get_called_class() puede utilizarse para obtener una cadena con el nombre de la clase invocada, y static:: revela cuál es su alcance.

A esta funcionalidad se le ha llamado «enlace estático en tiempo de ejecución» teniendo en cuenta un punto de vista interno. «Enlace en tiempo de ejecución» viene del hecho de que static:: no será resuelto usando la clase donde el método está definido, sino que en su lugar se calculará utilizando información en tiempo de ejecución. También se le llamó «enlace estático» debido a que se puede utilizar (entre otras cosas) para llamadas a métodos estáticos.

Limitaciones de self::

Las referencias estáticas a la clase en uso, como self:: o __CLASS__, se resuelven empleando la clase a la que pertenece la función:

Ejemplo #1 Uso de self::

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        self::who();
    }
}

class B extends A {
    public static function who() {
        echo __CLASS__;
    }
}

B::test();
?>

El resultado del ejemplo sería:

A

Uso de enlaces estático en tiempo de ejecución

Los enlaces estáticos en tiempo de ejecución tratan de resolver esta limitación empleando una palabra reservada que se refiera a la clase invocada inicialmente en tiempo de ejecución; básicamente, una palabra reservada que permita referirse a a B desde test(), según el ejemplo anterior. Se decidió no crear una nueva palabra reservada, si no utilizar en su lugar static, que ya era reservada.

Ejemplo #2 Uso básico de static::

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        static::who(); // He aquí el enlace estático en tiempo de ejecución
    }
}

class B extends A {
    public static function who() {
        echo __CLASS__;
    }
}

B::test();
?>

El resultado del ejemplo sería:

B

Nota:

En contextos no estáticos, la clase invocada será la clase de la instancia del objeto. Dado que $this-> trata de invocar métodos privados desde su mismo ámbito, el uso de static:: puede dar diferentes resultados. Otra diferencia es que static:: sólo puede referirse a propiedades estáticas.

Ejemplo #3 Uso de static:: en un contexto no estático

<?php
class A {
    private function foo() {
        echo "¡Éxito!\n";
    }
    public function test() {
        $this->foo();
        static::foo();
    }
}

class B extends A {
   /* foo() se copiará en B, por lo tanto su ámbito seguirá siendo A
    * y la llamada tendrá éxito */
}

class C extends A {
    private function foo() {
        /* se reemplaza el método original; el ámbito del nuevo es ahora C */
    }
}

$b = new B();
$b->test();
$c = new C();
$c->test();   //falla
?>

El resultado del ejemplo sería:

¡Éxito!
¡Éxito!
¡Éxito!

Fatal error:  Call to private method C::foo() from context 'A' in /tmp/test.php on line 9

Nota:

En una llamada que se resuelva como estática, la resolución de enlaces estáticos en tiempo de ejecución se detendrá sin propagarse. Por otra parte, las llamadas estáticas que utilicen palabras reservadas como parent:: o self:: sí propagarán la información de llamada.

Ejemplo #4 Llamadas que propagan y que no propagan la información de llamada

<?php
class A {
    public static function foo() {
        static::who();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}

class B extends A {
    public static function test() {
        A::foo();
        parent::foo();
        self::foo();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}
class C extends B {
    public static function who() {
        echo __CLASS__."\n";
    }
}

C::test();
?>

El resultado del ejemplo sería:

A
C
C


Objetos y referencias

Uno de los puntos clave de la POO de PHP 5 que a menudo se menciona es que "por omisión los objetos se pasan por referencia". Esto no es completamente cierto. Esta sección rectifica esa creencia general, usando algunos ejemplos.

Una referencia en PHP es un alias, que permite a dos variables diferentes escribir sobre un mismo valor. Desde PHP 5, una variable de tipo objeto ya no contiene el objeto en sí como valor. Únicamente contiene un identificador del objeto que le permite localizar al objeto real. Cuando se pasa un objeto como parámetro, o se devuelve como retorno, o se asigna a otra variable, las distintas variables no son alias: guardan una copia del identificador, que apunta al mismo objeto.

Ejemplo #1 Referencias y Objetos

<?php
class A {
    public $foo = 1;
}

$a = new A;
$b = $a;     // $a y $b son copias del mismo identificador
             // ($a) = ($b) = <id>
$b->foo = 2;
echo $a->foo."\n";

$c = new A;
$d = &$c;    // $c y $d son referencias
             // ($c,$d) = <id>

$d->foo = 2;
echo $c->foo."\n";

$e = new A;

function foo($obj) {
    // ($obj) = ($e) = <id>
    $obj->foo = 2;
}

foo($e);
echo $e->foo."\n";

?>

El resultado del ejemplo sería:

2
2
2


Serialización de objetos

serialización de objetos - objetos en sesiones

La función serialize() devuelve un string que contiene un flujo de bytes que representa cualquier valor que se pueda almacenar en PHP. Por otra parte, unserialize() puede restaurar los valores originales a partir de dicho string. Al utilizar serialize para guardar un objeto, almacenará todas las variables de dicho objeto. En cambio los métodos no se guardarán, sólo el nombre de la clase.

Para poder deserializar (unserialize()) un objeto, debe estar definida la clase de ese objeto. Es decir, si se tiene un objeto de la clase A, y lo serializamos, se obtendrá un string que haga referencia a la clase A y contenga todas las variables que haya en esta clase. Si se desea deserializar en otro fichero, antes debe estar presente la definición de la clase A. Esto se puede hacer, por ejemplo, escribiendo la definición de la clase A en un fichero, para después o bien incluirlo, o bien hacer uso de la función spl_autoload_register().

<?php
// classa.inc:

  class A {
      public $one = 1;

      public function show_one() {
          echo $this->one;
      }
  }

// page1.php:

  include("classa.inc");

  $a = new A;
  $s = serialize($a);
  // almacenamos $s en algún lugar en el que page2.php puede encontrarlo.
  file_put_contents('store', $s);

// page2.php:

  // se necesita para que unserialize funcione correctamente.
  include("classa.inc");

  $s = file_get_contents('store');
  $a = unserialize($s);

  // now use the function show_one() of the $a object.
  $a->show_one();
?>

Si una aplicación está usando sesiones, y utiliza session_register() para registrar objetos, estos objetos se serializarán automáticamente al final de cada página PHP, y se deserializan también automáticamente en cada una de las siguientes peticiones. Esto significa que, una vez que formen parte de la sesión, estos objetos se podrán utilizar en cualquier página de la aplicación. Sin embargo, la función session_register(): ha sido borrada a partir de PHP 5.4.0

Si una aplicación serializa objetos para su uso posterior, se recomienda encarecidamente que se incluya la definición de la clase en toda la aplicación. Si no se hiciera, se deserializaría el objeto sin una definición de clase, lo cual daría como resultado que PHP definiera al objeto con la clase __PHP_Incomplete_Class_Name, que no tiene métodos, haciendo que el objeto no fuera útil.

Por tanto, si en el ejemplo anterior $a se guardara en una sesión mediante session_register("a"), sería necesario incluir el fichero classa.inc en todas las páginas, no sólo en page1.php y page2.php.

Más allá del consejo de arriba, observe que también se puede conectar con eventos de serialización y deserialización sobre un objeto usando los métodos __sleep() y __wakeup(). El uso de __sleep() también permite serializar únicamente un subconjunto de propiedades de objetos.


Covarianza y Contravarianza

En PHP 7.2.0, se introdujo la contravarianza parcial mediante la eliminación de las restricciones de tipo en los parámetros de un método hijo. A partir de PHP 7.4.0, se añadió soporte completo de covarianza y contravarianza.

La covarianza permite que el método hijo devuelva un tipo más específico que el tipo de devolución del método de su padre. Mientras que la contravarianza permite que un tipo de parámetro sea menos específico en un método hijo, que el de su padre.

Covarianza

Para ilustrar cómo funciona la covarianza, una simple clase de padre abstracta, Animal es creada. Animal se extenderá a las clases hijo, Cat, y Dog.

<?php

abstract class Animal
{
    protected string $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    abstract public function speak();
}

class Dog extends Animal
{
    public function speak()
    {
        echo $this->name . " barks";
    }
}

class Cat extends Animal
{
    public function speak()
    {
        echo $this->name . " meows";
    }
}

Observe que no hay ningún método que devuelva valores en este ejemplo. Unas pocas fábricas que devuelven un nuevo objeto de tipo clase Animal, Cat, o Dog.

<?php

interface AnimalShelter
{
    public function adopt(string $name): Animal;
}

class CatShelter implements AnimalShelter
{
    public function adopt(string $name): Cat // instead of returning class type Animal, it can return class type Cat
    {
        return new Cat($name);
    }
}

class DogShelter implements AnimalShelter
{
    public function adopt(string $name): Dog // instead of returning class type Animal, it can return class type Dog
    {
        return new Dog($name);
    }
}

$kitty = (new CatShelter)->adopt("Ricky");
$kitty->speak();
echo "\n";

$doggy = (new DogShelter)->adopt("Mavrick");
$doggy->speak();

El resultado del ejemplo sería:

Ricky meows
Mavrick barks

Contravarianza

Continuando con el ejemplo anterior con las clases Animal, Cat, y Dog, una clase llamada Food y AnimalFood serán incluidas, y un método eat(AnimalFood $food) es añadido a la clase abstracta Animal.

<?php

class Food {}

class AnimalFood extends Food {}

abstract class Animal
{
    protected string $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    public function eat(Food $food)
    {
        echo $this->name . " eats " . get_class($food);
    }
}

Para ver el comportamiento de la contravención, el método eat se sobrescribe en la clase Dog para permitir cualquier tipo de objeto Food. La clase Cat permanece sin cambios.

<?php

class Dog extends Animal
{
    public function eat(Food $food) {
        echo $this->name . " eats " . get_class($food);
    }
}

El siguiente ejemplo mostrará el comportamiento de la contravarianza.

<?php

$kitty = (new CatShelter)->adopt("Ricky");
$catFood = new AnimalFood();
$kitty->eat($catFood);
echo "\n";

$doggy = (new DogShelter)->adopt("Mavrick");
$banana = new Food();
$doggy->eat($banana);

El resultado del ejemplo sería:

Ricky eats AnimalFood
Mavrick eats Food

¿Pero qué pasa si el (gatito) $kitty trata de (comer) eat la $banana?

$kitty->eat($banana);

El resultado del ejemplo sería:

Fatal error: Uncaught TypeError: Argument 1 passed to Animal::eat() must be an instance of AnimalFood, instance of Food given


Registro de cambios de la POO

Aquí se registran los cambios del modelo de POO de PHP 5. Las descripciones y otras notas respecto a estas nuevas funcionalidades están documentadas dentro de la documentación de POO 5.

Versión | Descripción
7.0.0 | Definir propiedades (compatibles) en dos rasgos («traits») ya no lanza un error.
5.6.0 | Añadido: El método __debugInfo().
5.5.0 | Añadido: La constante mágica ::class.
5.5.0 | Añadido: finally para manejar excepciones.
5.4.0 | Añadido: traits.
5.4.0 | Cambiado: Si una clase abstracta define una firma para el constructor, ahora se hará cumplir.
5.3.3 | Cambiado: Los métodos con el mismo nombre que el último elemento de un nombre de clase perteneciente a un espacio de nombres ya no serán tratados como un constructor. Este cambio no afecta a las clases que no pertenecen a un espacio de nombres.
5.3.0 | Cambiado: Ya no es necesario que los valores predeterminados de los métodos de una clase que implemente un interfaz coincidan con los valores predeterminados de los prototipos de la interfaz.
5.3.0 | Cambiado: Ahora es posible hacer referencia a la clase utilizando una variable (p.ej., echo $nombreclase::constante;). La variable no puede contener como valor una palabra reservada (p.ej., self, parent o static).
5.3.0 | Cambiado: Se emite un error de nivel E_WARNING si al sobrecargar un método mágico se le declara como estático. Además, hace necesario que tenga visibilidad pública.
5.3.0 | Cambiado: Antes de 5.3.0, las excepciones lanzadas en la función __autoload() no podían capturarse en el bloque catch, y provocaban un error fatal. Ahora, las excepciones lanzadas dentro de la función __autoload pueden capturarse en el bloque catch, con una única salvedad: Si se lanza una excepción definida por el usuario, esta excepción debería estar disponible. Se puede utilizar recursivamente la función __autoload para cargar automáticamente la clase de la excepción definida por el usuario.
5.3.0 | Añadido: El método __callStatic.
5.3.0 | Añadido: El soporte para heredoc y nowdoc para constantes de clase y definición de propiedades. Nota: los valores heredoc deben seguir las mismas reglas que los string de comillas dobles (p.ej., no contener variables).
5.3.0 | Añadido: Enlaces estáticos en tiempo de ejecución.
5.3.0 | Añadido: El método __invoke().
5.2.0 | Cambiado: Al método __toString() sólo se le invocaba cuando se le combinaba con echo o con print. Pero ahora, se le invoca en cualquier contexto de string (p.ej, en printf() con el modificador %s) pero no en contextos de otro tipo (p.ej. con el modificador %d). Desde PHP 5.2.0, convertir objetos a string sin el método __toString emitirá un error de nivel E_RECOVERABLE_ERROR.
5.1.3 | Cambiado: En versiones anteriores de PHP 5, se consideraba obsoleto el uso de var y emitía un error de nivel E_STRICT. Ya no está obsoleto, y por tanto no emite el error.
5.1.0 | Cambiado: Ahora se invoca al método estático __set_state() en las clases exportadas por var_export().
5.1.0 | Añadido: Los métodos __isset() y __unset().


Espacios de nombres

Tabla de contenidos

  • Resumen de los espacios de nombres
  • Definir espacios de nombres
  • Declarar subespacios de nombres
  • Definir varios espacios de nombres en un mismo fichero
  • Uso de los espacios de nombres: lo básico
  • Espacios de nombres y características dinámicas del lenguaje
  • La palabra reservada namespace y la constante __NAMESPACE__
  • Uso de los espacios de nombres: apodar/importar
  • Espacio global
  • Utilizar espacios de nombres: una alternativa a funciones/constantes globales
  • Reglas de resolución de nombres
  • P+F: cosas que es necesario saber sobre los espacios de nombres


Resumen de los espacios de nombres

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

¿Qué son los espacios de nombres? En su definición más aceptada, los espacios de nombres son una manera de encapsular elementos. Se pueden ver como un concepto abstracto en muchos aspectos. Por ejemplo, en cualquier sistema operativo, los directorios sirven para agrupar ficheros relacionados, actuando así como espacios de nombres para los ficheros que contienen. Como ejemplo, el fichero foo.txt puede existir en los directorios /home/greg y /home/otro, pero no pueden coexistir dos copias de foo.txt en el mismo directorio. Además, para acceder al fichero foo.txt fuera del directorio /home/greg, se debe anteponer el nombre del directorio al nombre del fichero, empleando el separador de directorios para así obtener /home/greg/foo.txt. Este mismo principio se extiende a los espacios de nombres en el mundo de la programación.

Versión | Descripción
7.0.0 | Añadidas las Declaraciones de use en grupo.

En el mundo de PHP, los espacios de nombres están diseñados para solucionar dos problemas con los que se encuentran los autores de bibliotecas y de aplicaciones al crear elementos de código reusable, tales como clases o funciones:

  1. El conflicto de nombres entre el código que se crea y las clases/funciones/constantes internas de PHP o las clases/funciones/constantes de terceros.
  2. La capacidad de apodar (o abreviar) Nombres_Extra_Largos diseñada para aliviar el primer problema, mejorando la legibilidad del código fuente.

Los espacios de nombres de PHP proporcionan una manera para agrupar clases, interfaces, funciones y constantes relacionadas. Un ejemplo de la sintaxis de los espacios de nombres de PHP:

Ejemplo #1 Ejemplo de sintaxis de espacios de nombres

<?php
namespace mi\nombre; // véase la sección "Definir espacios de nombres"

class MiClase {}
function mifunción() {}
const MICONSTANTE = 1;

$a = new MiClase;
$c = new \mi\nombre\MiClase; // véase la sección "Espacio global"

$a = strlen('hola'); // véase la sección "Utilizar espacios de nombres: una
                     // alternativa a funciones/constantes globales"

$d = namespace\MICONSTANTE; // véase la sección "El operador namespace y
                            // la constante __NAMESPACE__"
$d = __NAMESPACE__ . '\MICONSTANTE';
echo constant($d); // véase la sección "Espacios de nombres y características dinámicas del lenguaje"
?>

Nota:

Los nombres de los espacios de nombres PHP y php, y los nombres compuestos a partir de estos (como PHP\Classes) están reservados para el uso interno del lenguaje y no deben utilizarse en el código del espacio del usuario.


Definir espacios de nombres

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Aunque cualquier código de PHP válido puede estar contenido dentro de un espacio de nombres, solamente se ven afectados por espacios de nombres los siguientes tipos de código: clases (incluyendo abstractas y traits), interfaces, funciones y constantes.

Los espacios de nombres se declaran utilizando la palabra reservada namespace. Un fichero que contenga un espacio de nombres debe declararlo al inicio del mismo, antes que cualquier otro código, con una excepción: la palabra reservada declare.

Ejemplo #1 Declarar un único espacio de nombres

<?php
namespace MiProyecto;

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */ }

?>
La única construcción de código permitida antes de la declaración de un espacio de nombres es la sentencia declare para declarar la codificación de un fichero fuente. Además, todo lo que no sea código de PHP no puede preceder a la declaración del espacio de nombres, incluyendo espacios en blanco extra:

Ejemplo #2 Declarar un único espacio de nombres

<html>
<?php
namespace MiProyecto; // error fatal - el espacio de nombres debe ser la primera sentencia del script
?>

También, a diferencia de otras construcciones de PHP, se puede definir el mismo espacio de nombres en varios ficheros, permitiendo la separación del contenido de un espacio de nombres a través del sistema de ficheros.


Declarar subespacios de nombres

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Al igual que los directorios y ficheros, los espacios de nombres de PHP también tienen la capacidad de especificar una jerarquía de nombres de espacios de nombres. Así, un nombre de un espacio de nombres se puede definir con subniveles:

Ejemplo #1 Declarar un único espacio de nombres con jerarquía

<?php
namespace MiProyecto\Sub\Nivel;

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }

?>
El ejemplo de arriba crea la constante MiProyecto\Sub\Nivel\CONECTAR_OK, la clase MiProyecto\Sub\Nivel\Conexión y la función MiProyecto\Sub\Nivel\conectar.


Definir varios espacios de nombres en un mismo fichero

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

También se pueden declarar varios espacios de nombres en un mismo fichero. Se permiten dos tipos de sintaxis.

Ejemplo #1 Declarar varios espacios de nombres, sintaxis de combinación simple

<?php
namespace MiProyecto;

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }

namespace OtroProyecto;

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }
?>

No se recomienda esta sintaxis para combinar espacios de nombres en un único fichero. En su lugar, se recomienda emplear la sintaxis de llaves alternativa.

Ejemplo #2 Declarar varios espacios de nombres, sintaxis de llaves

<?php
namespace MiProyecto {

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }
}

namespace OtroProyecto {

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }
}
?>

Se desaconseja completamente, como práctica de código, la combinación de varios espacios de nombres en un mismo fichero. El caso de uso principal es combinar varios scripts de PHP en el mismo fichero.

Combinar código global que no es de espacio de nombres con código que sí lo es, sólo está soportado mediante la sintaxis de llaves. El código global debería estar encerrado en una declaración de espacio de nombres sin nombre de espacio de nombres:

Ejemplo #3 Declarar múltiples espacios de nombres y código que no es de espacio de nombres

<?php
namespace MiProyecto {

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }
}

namespace { // código global
session_start();
$a = MiProyecto\conectar();
echo MiProyecto\Conexión::iniciar();
}
?>

No puede existir código de PHP fuera de las llaves del espacio de nombres, excepto para una sentencia de apertura 'declare'.

Ejemplo #4 Declarar varios espacios de nombres y código que no es de espacio de nombres

<?php
declare(encoding='UTF-8');
namespace MiProyecto {

const CONECTAR_OK = 1;
class Conexión { /* ... */ }
function conectar() { /* ... */  }
}

namespace { // código global
session_start();
$a = MiProyecto\conectar();
echo MiProyecto\Conexión::iniciar();
}
?>


Uso de los espacios de nombres: lo básico

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Antes de hablar del uso de los espacios de nombres es importante entender cómo sabe PHP qué elemento del código del espacio de nombres se requiere. Se puede hacer una simple analogía entre los espacios de nombres de PHP y el sistema de ficheros. Existen tres maneras de acceder a un fichero en el sistema de ficheros:

  1. Nombre de fichero relativo como foo.txt. Se resuelve con directorio_actual/foo.txt donde directorio_actual es el directorio actualmente ocupado. Así, si el directorio actual es /home/foo, el nombre se resuelve con /home/foo/foo.txt.
  2. Nombre de ruta relativa como subdirectorio/foo.txt. Se resuelve con directorioactual/subdirectorio/foo.txt.
  3. Nombre de ruta absoluta como /main/foo.txt. Se resuelve con /main/foo.txt.
Se puede aplicar el mismo principio a los elementos del espacio de nombres de PHP. Por ejemplo, se puede hacer referencia a un nombre de una clase de tres maneras:
  1. Nombre no cualificado, o nombre de clase sin prefijo como $a = new foo(); o foo::método_estático();. Si el espacio de nombres actual es espacio_de_nombres_actual, esto se resuelve con espacio_de_nombres_actual\foo. Si el código es global, es decir, no es de espacio de nombres, esto se resuelve con foo. Una advertencia: los nombres no cualificados para funciones y constantes se resolverán con funciones y constantes globales si la función o la constante del espacio de nombres no está definida. Véase Utilizar espacios de nombres: una alternativa a funciones/constantes globales para más detalles.
  2. Nombre cualificado, o un nombre de clase con prefijo como $a = new subespacio_de_nombres\foo(); o subespacio_de_nombres\foo::método_estático();. Si el espacio de nombres actual es espacio_de_nombres_actual, esto se resuelve con espacio_de_nombres_actual\subespacio_de_nombres\foo. Si el código es global, es decir, no es de espacio de nombres, esto se resuelve con subespacio_de_nombres\foo.
  3. Nombre completamente cualificado, o un nombre con prefijo con el operador de prefijo global como $a = new \espacio_de_nombres_actual\foo(); o \espacio_de_nombres_actual\foo::método_estático();. Esto siempre se resuelve con nombre literal especificado en el código, espacio_de_nombres_actual\foo.

Un ejemplo de los tres tipos de sintaxis en código real:

fichero1.php

<?php
namespace Foo\Bar\subespacio_de_nombres;

const FOO = 1;
function foo() {}
class foo
{
    static function método_estático() {}
}
?>

fichero2.php

<?php
namespace Foo\Bar;
include 'fichero1.php';

const FOO = 2;
function foo() {}
class foo
{
    static function método_estático() {}
}

/* Nombre no cualificado */
foo(); // se resuelve con la función Foo\Bar\foo
foo::método_estático(); // se resuelve con la clase Foo\Bar\foo, método método_estático
echo FOO; // se resuelve con la constante Foo\Bar\FOO

/* Nombre cualificado */
subespacio_de_nombres\foo(); // se resuelve con la función Foo\Bar\subespacio_de_nombres\foo
subespacio_de_nombres\foo::método_estático(); // se resuelve con la clase Foo\Bar\subespacio_de_nombres\foo,
                                              // método método_estático
echo subespacio_de_nombres\FOO; // se resuelve con la constante Foo\Bar\subespacio_de_nombres\FOO

/* Nombre conmpletamente cualificado */
\Foo\Bar\foo(); // se resuelve con la función Foo\Bar\foo
\Foo\Bar\foo::método_estático(); // se resuelve con la clase Foo\Bar\foo, método método_estático
echo \Foo\Bar\FOO; // se resuelve con la constante Foo\Bar\FOO
?>

Observe que para acceder a cualquier clase, función o constante globales, se puede utilizar un nombre completamente cualificado, como \strlen() o \Exception o \INI_ALL.

Ejemplo #1 Acceder a clases, funciones y constantes globales desde un espacio de nombres

<?php
namespace Foo;

function strlen() {}
const INI_ALL = 3;
class Exception {}

$a = \strlen('hola'); // llama a la función global strlen
$b = \INI_ALL; // accede a la constante global INI_ALL
$c = new \Exception('error'); // instancia a la clase global Exception
?>


Espacios de nombres y características dinámicas del lenguaje

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

La implementación de PHP de los espacios de nombres está influenciada por su naturaleza dinámica como lenguaje de programación. Así, para convertir código como el del siguiente ejemplo en código de espacios de nombres:

Ejemplo #1 Acceder dinámicamente a elementos

ejemplo1.php:

<?php
class nombre_clase
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function nombre_func()
{
    echo __FUNCTION__,"\n";
}
const nombre_const = "global";

$a = 'nombre_clase';
$obj = new $a; // imprime nombre_clase::__construct
$b = 'nombre_func';
$b(); // imprime nombre_func
echo constant('nombre_const'), "\n"; // imprime global
?>
se debe emplear el nombre completamente cualificado (nombre de clase con prefijo de espacio de nombres). Observe que, debido a que no hay diferencia entre un nombre cualificado y uno completamente cualificado dentro de un nombre de clase, función, o constante dinámicas, no es necesario la barra invertida inicial.

Ejemplo #2 Acceder dinámicamente a elementos de un espacio de nombres

<?php
namespace nombre_espacio_de_nombres;
class nombre_clase
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function nombre_func()
{
    echo __FUNCTION__,"\n";
}
const nombre_const = "de espacio de nombres";

/* observe que si se emplean comillas dobles, se debe usar "\\nombre_espacio_de_nombres\\nombre_clase" */
$a = '\nombre_espacio_de_nombres\nombre_clase';
$obj = new $a; // imprime nombre_espacio_de_nombres\nombre_clase::__construct
$a = 'nombre_espacio_de_nombres\nombre_clase';
$obj = new $a; // también imprime nombre_espacio_de_nombres\nombre_clase::__construct
$b = 'nombre_espacio_de_nombres\nombre_func';
$b(); // imprime nombre_espacio_de_nombres\nombre_func
$b = '\nombre_espacio_de_nombres\nombre_func';
$b(); // también imprime nombre_espacio_de_nombres\nombre_func
echo constant('\nombre_espacio_de_nombres\nombre_const'), "\n"; // imprime de espacio de nombres
echo constant('nombre_espacio_de_nombres\nombre_const'), "\n"; // también imprime de espacio de nombres
?>

Asegúrese de leer la nota sobre escapar nombres de espacios de nombres en cadenas.


La palabra reservada namespace y la constante __NAMESPACE__

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

PHP admite dos formas de acceder de manera abstracta a elementos dentro del espacio de nombres actual: la constante mágica __NAMESPACE__, y la palabra reservada namespace.

El valor de __NAMESPACE__ es una cadena que contiene el nombre del espacio de nombres actual. En código global, que no es de espacio de nombres, contiene una cadena vacía.

Ejemplo #1 Ejemplo de __NAMESPACE__, código de espacio de nombres

<?php
namespace MiProyecto;

echo '"', __NAMESPACE__, '"'; // imprime "MiProyecto"
?>

Ejemplo #2 Ejemplo de __NAMESPACE__, código global

<?php

echo '"', __NAMESPACE__, '"'; // imprime ""
?>
La constante __NAMESPACE__ es útil para construir nombres dinámicamente, por ejemplo:

Ejemplo #3 Empleo de __NAMESPACE__ para la construcción dinámica de nombres

<?php
namespace MiProyecto;

function obtener($nombre_clase)
{
    $a = __NAMESPACE__ . '\\' . $nombre_clase;
    return new $a;
}
?>

La palabra reservada namespace se puede utilizar para solicitar explícitamente un elemento del espacio de nombres o subespacio de nombres actual. Es el equivalente del espacio de nombres para el operador self de las clases.

Ejemplo #4 El operador namespace, dentro de un espacio de nombres

<?php
namespace MiProyecto;

use blah\blah as mío; // véase "Uso de los espacios de nombres: Apodar/Importar"

blah\mío(); // llama a la función MiProyecto\blah\mío()
namespace\blah\mío(); // llama a la función MiProyecto\blah\mío()

namespace\func(); // llama a la función MiProyecto\func()
namespace\sub\func(); // llama a la función MiProyecto\sub\func()
namespace\nombrec::método(); // llama al método estático "método" de la clase MiProyecto\nombrec
$a = new namespace\sub\nombrec(); // instancia un objeto de la clase MiProyecto\sub\nombrec
$b = namespace\CONSTANTE; // asigna el valor de la constante MiProyecto\CONSTANTE a $b
?>

Ejemplo #5 El operador namespace, en código global

<?php

namespace\func(); // llama a la función func()
namespace\sub\func(); // llama a la función sub\func()
namespace\nombrec::método(); // llama al método estático "método" de la clase nombrec
$a = new namespace\sub\nombrec(); // instancia un objeto de la clase sub\nombrec
$b = namespace\CONSTANTE; // asigna el valor de la constante CONSTANTE a $b
?>


Uso de los espacios de nombres: apodar/importar

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

La capacidad de referirse a un nombre completamente cualificado externo con un alias, o importar, es una característca importante de los espacios de nombres. Esto es similar a la capacidad de los sistemas de ficheros basados en Unix de crear enlaces simbólicos a un fichero o directorio.

Todas las versiones de PHP que tienen soporte para espacios de nombres admiten tres tipos de alias o importación: apodar un nombre de clase, apodar un nombre de interfaz, y apodar un nombre de espacio de nombres. PHP 5.6+ también permite apodar o importar nombres de funciones y constantes.

En PHP, la acción de apodar se lleva a cabo con el operador use. Aquí hay un ejemplo que muestra los cinco tipos de importación:

Ejemplo #1 Importar/apodar con el operador use

<?php
namespace foo;
use Mi\Completo\NombreDeClase as Otra;

// esto es lo mismo que utilizar Mi\Completo\NombreEN as NombreEN
use Mi\Completo\NombreEN;

// importar una clase global
use ArrayObject;

// importar una función (PHP 5.6+)
use function Mi\Completo\nombreDeFunción;

// apodar una función (PHP 5.6+)
use function Mi\Completo\nombreDeFunción as func;

// importar una constante (PHP 5.6+)
use const Mi\Completa\CONSTANTE;

$obj = new namespace\Otra; // instancia un objeto de la clase foo\Otra
$obj = new Otra; // instancia un objeto de la clase class Mi\Completo\NombreDeClase
NombreEN\suben\func(); // llama a la función Mi\Completo\NombreEN\subes\func
$a = new ArrayObject(array(1)); // instancia un objeto de la clase ArrayObject
// sin el "use ArrayObject" instanciaríamos un objeto de la clase foo\ArrayObject
func(); // llama a la función Mi\Completo\nombreDeFunción
echo CONSTANT; // imprime el valor de Mi\Completa\CONSTANTE;
?>
Observe que para los nombres de espacios de nombres (nombres de espacios de nombres completamente cualificados que contienen el separador de espacios de nombres, como Foo\Bar, en oposición a los nombres globales que no lo contienen, como FooBar), no es necesaria y no está recomendada la barra invertida inicial, ya que los nombres importados deben ser completamente cualificados, por lo que no son procesados en relación al espacio de nombres actual.

PHP admite además un atajo para poner varias sentencias use en la misma línea

Ejemplo #2 Importar/apodar con el operador use, varias sentencias use combinadas

<?php
use Mi\Completo\NombreDeClase as Otra, Mi\Completo\NombreEN;

$obj = new Otra; // instancia un objeto de la clase Mi\Completo\NombreDeClase
NombreEN\suben\func(); // llama a la función Mi\Completo\NombreEN\suben\func
?>

La importación se realiza durante la compilación, por lo que no afecta a los nombres de clases, funciones o constantes.

Ejemplo #3 La importación y los nombres dinámicos

<?php
use Mi\Completo\NombreDeClase as Otra, Mi\Completo\NombreEN;

$obj = new Otra; // instancia un objeto de la clase Mi\Completo\NombreDeClase
$a = 'Otra';
$obj = new $a;   // instancia un objeto de la clase Otra
?>

Además, la importación sólo afecta a los nombres cualificados y no cualificados. Los nombres completamente cualificados son absolutos, por lo que no se ven afectados por la importación.

Ejemplo #4 La importación y los nombres completamente cualificados

<?php
use Mi\Completo\NombreDeClase as Otra, Mi\Completo\NombreEN;

$obj = new Otra; // instancia un objeto de la clase Mi\Completo\NombreDeClase
$obj = new \Otra; // instancia un objeto de la clase Otra
$obj = new Otra\cosa; // instancia un objeto de la clase Mi\Completo\NombreDeClase\cosa
$obj = new \Otra\cosa; // instancia un objeto de la clase Otra\cosa
?>

Reglas de ámbito para la importación

La palabra reservada use debe ser declarada en el ámbito exterior de un fichero (el ámbito global) o dentro de declaraciones de espacios de nombres. Esto es así debido a que la importación se realiza durante la compilación y no durante la ejecución, por lo que no puede ser utilizada en un ámbito de bloque. El siguiente ejemplo muestra un uso ilegal de la palabra reservada use:

Ejemplo #5 Regla de importación ilegal

<?php
namespace Idiomas;

function aGroenlandés
{
    use Idiomas\Danés;

    // ...
}
?>

Nota:

Las reglas de importación tiene una base por fichero, lo que significa que los ficheros incluidos NO heredarán las reglas de importación del padre.

Declaraciones de use en grupo

Desde PHP 7.0 en adelante, las clases, funciones y constantes importadas desde el mismo namespace pueden ser agrupadas en una única sentencia use.

<?php

// Código anterir a PHP 7
use un\espacioDeNombres\ClaseA;
use un\espacioDeNombres\ClaseB;
use un\espacioDeNombres\ClaseC as C;

use function un\espacioDeNombres\fn_a;
use function un\espacioDeNombres\fn_b;
use function un\espacioDeNombres\fn_c;

use const un\espacioDeNombres\ConstA;
use const un\espacioDeNombres\ConstB;
use const un\espacioDeNombres\ConstC;

// Código de PHP 7+
use un\espacioDeNombres\{ClaseA, ClaseB, ClaseC as C};
use function un\espacioDeNombres\{fn_a, fn_b, fn_c};
use const un\espacioDeNombres\{ConstA, ConstB, ConstC};


Espacio global

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Sin ninguna definición de espacios de nombres, todas las definiciones de clases y funciones son colocadas en el espacio global, como si lo estuvieran antes de que PHP soportara los espacios de nombres. Prefijar un nombre con \ especificará que el nombre es requerido desde el espacio global incluso en el contexto del espacio de nombres.

Ejemplo #1 Usar la especificación de espacio global

<?php
namespace A\B\C;

/* Esta función es A\B\C\fopen */
function fopen() {
     /* ... */
     $f = \fopen(...); // llamar a fopen global
     return $f;
}
?>


Utilizar espacios de nombres: una alternativa a funciones/constantes globales

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Dentro de un espacio de nombres, cuando PHP se encuentra con nombre no cualificado en un contexto de nombre de clase, función o constante, lo resuelve con diferentes prioridades. Los nombres de clases siempre se resuelven con el nombre de espacio de nombres actual. Así, para acceder a clases de usuario internas o que no son de espacio de nombres, se debe referir a ellas con su nombre completamente cualificado:

Ejemplo #1 Acceder a clases globales dentro de un espacio de nombres

<?php
namespace A\B\C;
class Exception extends \Exception {}

$a = new Exception('hola'); // $a es un objeto de la clase A\B\C\Exception
$b = new \Exception('hola'); // $b es un objeto de la clase Exception

$c = new ArrayObject; // error fatal, no se encontró la clase A\B\C\ArrayObject
?>

Para funciones y constantes, PHP recurrirá a funciones y constantes globales si no existe una función o constante en el espacio de nombres.

Ejemplo #2 Recurrir a funciones/constantes globales dentro de un espacio de nombres

<?php
namespace A\B\C;

const E_ERROR = 45;
function strlen($str)
{
    return \strlen($str) - 1;
}

echo E_ERROR, "\n"; // imprime "45"
echo INI_ALL, "\n"; // imprime "7" - recurre a INI_ALL global

echo strlen('hola'), "\n"; // imprime "3"
if (is_array('hola')) { // imprime "no es un array"
    echo "es una array\n";
} else {
    echo "no es un array\n";
}
?>


Reglas de resolución de nombres

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

A continuación se exponen unas definiciones importantes para estas reglas de resolución:

Definiciones de nombres de espacios de nombres
Nombre no cualificado

Es un identificador sin un separador de espacios de nombres, como Foo

Nombre cualificado

Es un identificador con un separador de espacios de nombres, como Foo\Bar

Nombre completamente cualificado

Es un identificador con un separador de espacios de nombres que comienza con un separador de espacios de nombres, como \Foo\Bar. namespace\Foo también es un nombre completamente cualificado.

Los nombres se resuelven siguiendo estas reglas de resolución:

  1. Las llamadas a clases, funciones o constantes completamente cualificadas se resuelven durante la compilación. Por ejemplo new \A\B se resuelve con la clase A\B.
  2. Todos los nombres no cualificados y cualificados (no los completamente cualificados) se traducen durante la compilación según las reglas de importación actuales. Por ejemplo, si el espacio de nombres A\B\C se importa como C, una llamada a C\D\e() se traduce como A\B\C\D\e().
  3. Dentro de un espacio de nombres, todos los nombres cualificados no traducidos según la reglas de importación llevan antepuesto el espacio de nombres actual. Por ejemplo, si una llamada a C\D\e() se lleva a cabo dentro del espacio de nombres A\B, se traduce como A\B\C\D\e().
  4. Los nombres de clases no cualificados se traducen durante la compilación según las reglas de importación actuales (el nombre completo sustituido por el nombre abreviado importado). Por ejemplo, si el espacio de nombres A\B\C se importa como C, new C() se traduce como new A\B\C().
  5. Dentro de un espacio de nombres (digamos A\B), las llamadas a funciones no cualificadas se resuelven durante la ejecución. Así se resuelve una llamada a la función foo():
    1. Se busca una función del espacio de nombres actual: A\B\foo().
    2. Se intenta encontrar y llamar a la función global foo().
  6. Dentro de un espacio de nombres (digamos A\B), las llamadas a nombres de clases no cualificados o cualificados (no los completamente cualificados) se resuelven durante la ejecución. Así se resuelve una llamada a new C() o a new D\E(). Para new C():
    1. Se busca una clase del espacio de nombres actual: A\B\C.
    2. Se intenta autocargar A\B\C.
    Para new D\E():
    1. Se busca una clase anteponiendo el espacio de nombres actual: A\B\D\E.
    2. Se intenta autocargar A\B\D\E.
    Para referirse a cualquier clase global en el espacio de nombres global, se debe emplear su nombre completamente cualificado new \C().

Ejemplo #1 Las resoluciones de nombres ilustradas

<?php
namespace A;
use B\D, C\E as F;

// llamadas a funciones

foo();      // primero se intenta llamar a "foo" definida en el espacio de nombres "A"
            // después se llama a la función global "foo"

\foo();     // se llama a la función "foo" definidia en el ámbito global

mi\foo();   // se llama a la función "foo" definida en el espacio de nombres "A\mi"

F();        // primero se intenta llamar a "F" definida en el espacio de nombres "A"
            // después se llama a la función global "F"

// referecias a clases

new B();    // crea un objeto de la clase "B" definida en el espacio de nombres "A"
            // si no se encuentra, se intenta autocargar la clase "A\B"

new D();    // usando las reglas de importación, se crea un objeto de la clase "D" definida en el espacio de nombres "B"
            // si no se encuentra, se intenta autocargar la clase "B\D"

new F();    // usando las reglas de importación, se crea un objeto de la clase "E" definida en el espacio de nombres "C"
            // si no se encuentra, se intenta autocargar la clase "C\E"

new \B();   // crea un objeto de la clase "B" definida en el ámbito global
            // si no se encuentra, se intenta autocargar la clase "B"

new \D();   // crea un objeto de la clase "D" definida en el ámbito global
            // si no se encuentra, se intenta autocargar la clase "D"

new \F();   // crea un objeto de la clase "F" definida en el ámbito global
            // si no se encuentra, se intenta autocargar la clase "F"

// métodos estáticos y funciones de un espacio de nombres desde otro espacio de nombres

B\foo();    // se llama a la función "foo" desde el espacio de nombres "A\B"

B::foo();   // se llama al método "foo" de la clase "B" definidia en el espacio de nombres "A"
            // si no se encuentra la clase "A\B", se intenta autocargar la clase "A\B"

D::foo();   // usando las reglas de importación, se llama al método "foo" de la clase "D" definida en el espacio de nombres "B"
            // si no se encuentra la clase "B\D", se intenta autocargar la clase "B\D"

\B\foo();   // se llama a la función "foo" desde el espacio de nombres "B"

\B::foo();  // se llama al método "foo" de la clase "B" desde el ámbito global
            // si no es encuentra la clase "B", se intenta autocargar la clase "B"

// métodos estáticos yfunciones de un espacio de nombres del espacio de nombres actual

A\B::foo();   // se llama al método "foo" de la clase "B" desde el espacio de nombres "A\A"
              // si no se encuentra la clase "A\A\B", se intenta autocargar la clase "A\A\B"

\A\B::foo();  // se llama al método "foo" de la clase "B" desde el espacio de nombres "A"
              // si no se encuentra la clase "A\B", se intenta autocargar la clase "A\B"
?>


P+F: cosas que es necesario saber sobre los espacios de nombres

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Esta sección está dividida en dos subsecciones: preguntas comunes, y algunas especificaciones de implementación que son útiles para comprender completamente los espacios de nombres.

Primero, las preguntas comunes.

  1. Si no utilizo espacios de nombres, ¿debería preocuparme por algo de esto?
  2. ¿Cómo uso clases internas o globales en un espacio de nombres?
  3. ¿Cómo uso clases, funciones o constantes de espacios de nombres en su propio espacio de nombres?
  4. ¿Cómo se resuelve un nombre como \mi\nombre o \nombre?
  5. ¿Cómo se resuelve un nombre como mi\nombre?
  6. ¿Cómo se resuelve un nombre de clase no cualificado como nombre?
  7. ¿Cómo se resuelve un nombre de función o de constante no cualifcado como nombre?

Existen unos pocos detalles de las implementaciones de espacios de nombres que son útiles para enterderlos.

  1. Importar nombres no entra en conflicto con las clases definidas en el mismo fichero.
  2. Los espacios de nombres anidados no están permitidos.
  3. Antes de PHP 5.6, ni las funciones ni las constantes se pueden importar mediante la sentencia use.
  4. Los nombres de espacios de nombres dinámicos (identificadores entre comillas) deberían escaparse con una barra invertida.
  5. Las constantes no definidas aludidas usando cualquier barra invertida terminan en un error fatal
  6. No se pueden sobrescribir las constantes especiales NULL, TRUE, FALSE, ZEND_THREAD_SAFE o ZEND_DEBUG_BUILD

Si no utilizo espacios de nombres, ¿debería preocuparme por algo de esto?

No. Los espacios de nombres no afectan a ningún código existente de ninguna manera, o a ningún código todavía por escribir que no contenga espacios de nombres. Se puede escribir este código si se desea:

Ejemplo #1 Acceder a clases globales fuera de un espacio de nombres

<?php
$a = new \stdClass;
?>

Esto es funcionalmente equivalente a:

Ejemplo #2 Acceder a clases globales fuera de un espacio de nombres

<?php
$a = new stdClass;
?>

¿Cómo uso clases internas o globales en un espacio de nombres?

Ejemplo #3 Acceder a clases internas en espacios de nombres

<?php
namespace foo;
$a = new \stdClass;

function probar(\ArrayObject $ejemploalusiónatipo = null) {}

$a = \DirectoryIterator::CURRENT_AS_FILEINFO;

// extender una clase interna o global
class MiExcepción extends \Exception {}
?>

¿Cómo uso clases, funciones o constantes de espacios de nombres en su propio espacio de nombres?

Ejemplo #4 Acceder a clases, funciones o constantes internas en un espacio de nombres

<?php
namespace foo;

class MiClase {}

// usar una clase desde el espacio de nombres actual como una declaración de tipo
function probar(MiClase $ejemploalusiónatipo = null) {}
// otra manera de usar una clase desde el espacio de nombres actual una declaración de tipo
function probar(\foo\MiClase $ejemploalusiónatipo = null) {}

// extender una clase desde el espacio de nombres actual
class Extendida extends MiClase {}

// acceder a una función global
$a = \funcglobal();

// acceder a una constante global
$b = \INI_ALL;
?>

¿Cómo se resuelve un nombre como \mi\nombre o \nombre?

Los nombres que comienzan con una \ siempre se resuelven a aquello a lo que se asemejan, así \mi\nombre de hecho es mi\nombre, y \Exception es Exception.

Ejemplo #5 Nombres completamente cualificados

<?php
namespace foo;
$a = new \mi\nombre(); // instancia a la clase "mi\nombre"
echo \strlen('hola'); // llama a la función "strlen"
$a = \INI_ALL; // $a está establecida al valor de la constante "INI_ALL"
?>

¿Cómo se resuelve un nombre como mi\nombre?

Los nombres que contienen una barra invertida pero no comienzan con una barra invertida como mi\nombre pueden resolverse de dos formas diferentes.

Si hay una sentencia de importación que apode a otro nombre como mi, el alias de importación se aplica a mi en mi\nombre.

De lo contrario, al nombre del espacio de nombres actual se le antepone mi\nombre.

Ejemplo #6 Nombres cualificados

<?php
namespace foo;
use blah\blah as foo;

$a = new mi\nombre(); // instancia a la clase "foo\mi\nombre"
foo\bar::nombre(); // llama a método estático "nombre" de la clase "blah\blah\bar"
mi\bar(); // llama a la función "foo\mi\bar"
$a = mi\BAR; // establece $a al valor de la constante "foo\mi\BAR"
?>

¿Cómo se resuelve un nombre de clase no cualificado como nombre?

Los nombres de clases que no contienen una barra invertida como nombre se pueden resolver de dos formas diferentes.

Si hay una sentencia de importación que apode a otro nombre como nombre, se aplica el alias de importación.

De lo contrario, al nombre del espacio de nombres actual se le antepone nombre.

Ejemplo #7 Nombres de clases no cualificados

<?php
namespace foo;
use blah\blah as foo;

$a = new nombre(); // instancia a la clase "foo\nombre"
foo::nombre(); // llama al método estático "nombre" de la clase "blah\blah"
?>

¿Cómo se resuelve un nombre de función o de constante no cualifcado como nombre?

Los nombres de funciones o de constantes que no contienen una barra invertida como nombre se pueden resolver de dos formas diferentes.

Primero, al nombre del espacio de nombres actual se le antepone nombre.

Finalmente, si el nombre de la constante o de la función no existe en el espacio de nombres actual, se emplea un nombre de constante o función global, si es que existe.

Ejemplo #8 Nombres de funciones o constantes no cualificados

<?php
namespace foo;
use blah\blah as foo;

const FOO = 1;

function mi() {}
function foo() {}
function sort(&$a)
{
    \sort($a); // invoca a la función global "sort"
    $a = array_flip($a);
    return $a;
}

mi(); // calls "foo\mi"
$a = strlen('hola'); // llama a la función global "strlen" ya que "foo\strlen" no existe
$array = array(1,3,2);
$b = sort($array); // llama a la función "foo\sort"
$c = foo(); // llama a la función "foo\foo" - la importación no se aplica

$a = FOO; // establece $a al valor de la constante "foo\FOO"; la importación no se aplica
$b = INI_ALL; // establece $b al valor de la constante "INI_ALL"
?>

Importar nombres no entra en conflicto con las clases definidas en el mismo fichero.

Están permitidas las siguientes combinaciones de scripts:

fichero1.php

<?php
namespace mis\cosas;
class MiClase {}
?>

otro.php

<?php
namespace otro;
class cosa {}
?>

fichero2.php

<?php
namespace mis\cosas;
include 'fichero1.php';
include 'otro.php';

use otro\cosa as MiClase;
$a = new MiClase; // instancia a la clase "cosa" del espacio de nombres otro
?>

No existe conflicto entre nombres, aunque la clase MiClase exista dentro del espacio de nombres mis\cosas, porque la definición de MiClase está en otro fichero. Sin embargo, el siguiente ejemplo causa un error fatal por el conflicto entre nombres, debido a que MiClase está definida en el mismo fichero que el de la sentencia use.

<?php
namespace mis\cosas;
use otro\cosa as MiClase;
class MiClase {} // error fatal: MiClase entra en conflicto con la sentencia de importación
$a = new MiClase;
?>

Los espacios de nombres anidados no están permitidos.

PHP no permite los espacios de nombres anidados

<?php
namespace mis\cosas {
    namespace anidado {
        class foo {}
    }
}
?>
Sin embargo, es fácil simular los espacios de nombres anidados de la siguiente manera:
<?php
namespace mis\cosas\anidado {
    class foo {}
}
?>

Antes de PHP 5.6, ni las funciones ni las constantes se pueden importar mediante la sentencia use.

Ants de PHP 5.6, los únicos elementos que se ven afectados por la sentencia use son los espacios de nombres y los nombres de clases. Para abreviar una constante o una función larga, se ha de importar el espacio de nombres que la contiene:

<?php
namespace mío;
use nombre\en\ultra\largo;

$a = largo\CONSTANT;
largo\func();
?>
A partir de PHP 5.6, está permitido apodar o imortar nombres de funciones y de constantes.

Los nombres de espacios de nombres dinámicos (identificadores entre comillas) deberían escaparse con una barra invertida.

Es muy importante darse cuenta de que, debeido a que la barra invertida se usa como carácter de escape dentro de cadenas, se deberían emplear dos barras inverticas cuando se utilicen dentro de cadenas. De lo contrario, existe el riesgo de obtener consecuencias inesperadas:

Ejemplo #9 Peligros de usar nombres de espacios de nombres dentro de una cadena entre comillas dobles

<?php
$a = "peligroso\nombre"; // ¡\n es una nueva línea dentro de las cadenas entre comillas dobles!
$obj = new $a;

$a = 'sin\peligro\alguno'; // aquí sin problemas.
$obj = new $a;
?>
Dentro de una cadena entre comillas dobles, es más seguro usar la secuencia de escape de la barra invertida, pero aún se recomienda como práctica escapar las barras invertidas en todas las cadenas.

Las constantes no definidas a las que se hace referencia usando una barra invertida terminan con un error fatal

Cualquier constante no definida que no sea cualificada, como FOO, generará una aviso explicando que PHP asume que FOO es el valor de la constante. Cualquier constante, cualificada o completamente cualificada, que contenga una barra invertida producirá un error fatal si no se encuentra.

Ejemplo #10 Constantes no definidas

<?php
namespace bar;
$a = FOO; // produce un aviso - constante no definida "FOO" se asume que es "FOO";
$a = \FOO; // error fatal, constante FOO del espacio de nombres no definida
$a = Bar\FOO; // error fatal, constante bar\Bar\FOO del espacio de nombres no definida
$a = \Bar\FOO; // error fatal, constante Bar\FOO del espacio de nombres no definida
?>

No se pueden sobrescribir las constantes especiales NULL, TRUE, FALSE, ZEND_THREAD_SAFE o ZEND_DEBUG_BUILD

Cualquier intento de definir una constante de espacio de nombres que sea una constante especial interna, resultará en un error fatal:

Ejemplo #11 Constantes no definidas

<?php
namespace bar;
const NULL = 0; // error fatal;
const true = 'estúpido'; // también error fatal;
// etc.
?>


Errores

Tabla de contenidos

  • Lo básico
  • Errores en PHP 7

Introducción

Desarfortunadamente, no importa lo cuidadoso que uno sea escribiendo código; los errores son un hecho de la vida. PHP notificará errores, advertencias y avisos para muchos problemas comunes de codificación y de tiempo de ejecución, por lo que saber cómo detectar y manejar estos errores hará la depuración mucho más sencilla.


Lo básico

PHP notifica errores en respuesta a varias condiciones de error internas. Estas se pueden utilizar para señalar varias condiciones diferentes, mostrándose y/o registrándose si fuera necesario.

Cada error que genera PHP incluye un tipo. Existe una lista de dichos tipos, junto con una breve descripción de su comportamiento y sus posibles causas.

Manejo de errores con PHP

Si no se establece un manejador de errores, PHP manejará cada error que ocurra según su configuración. Los errores que se notifican y los que se ignoran se controla mediante la directiva error_reporting de php.ini, o durante la ejecución llamando a error_reporting(). Sin embargo, se recomienda encarecidamente establecer la directiva de configuración, ya que algunos errores pueden ocurrir antes de comenzar la ejecución de un script.

En un entorno de desarrollo debería establecerse siempre error_reporting a E_ALL, debido a que es necesario reconocer y corregir los problemas generados por PHP. En producción, se podría establecer esta directiva a un nivel de menor verbosidad como E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED, aunque en muchos casos E_ALL también es apropiado, ya que puede proporcionar advertencias precoces de problemas potenciales.

Lo que PHP hace con estos errores depende de dos directivas más de php.ini. display_errors controla si el error es mostrado como parte de la salida del script. Esta debería estar siempre deshabilitada en un entorno de producción, ya que puede incluir información confidencial tal como contraseñas de bases de datos, aunque a menudo es útil habilitarla en desarrollo debido a que asegura la notificación inmediata de problemas.

Además de mostrar errores, PHP puede registrarlos cuando la directiva log_errors está habilitada. Esta registrará cualquier error en el fichero o registro del sistema definido por error_log. Esta directiva puede ser extremadamente útil en un entorno de producción debido a que se pueden registrar los errores que ocurran y generar informes basados en ellos.

Manejadores de errores de usuario

Si el manejo de errores predeterminado de PHP es inadecuado, también se pueden manejar muchos tipos de error con un manejador de errores propio mediante set_error_handler(). Mientras que algunos tipos de error no se pueden manejar de esta forma, aquellos que sí se pueden lo hacen de la manera en que su script vea apropiada: por ejemplo, se puede emplear para mostrar al usuario una página de error personalizada y luego notificar más directamente mediante un registro, tal como el envío de un correo electrónico.


Errores en PHP 7

PHP 7 cambia la mayoría de los errores notificados por PHP. En lugar de notificar errores a través del mecanismo de notificación de errores tradicional de PHP 5, la mayoría de los errores ahora son notificados lanzando excepciones Error.

Al igual que las excepciones normales, las excepciones Error se propagarán hasta alcanzar el primer bloque catch coincidente. Si no hay bloques coincidentes, será invocado cualquier manejador de excepciones predeterminado instalado con set_exception_handler(), y si no hubiera ningún manejador de excepciones predeterminado, la excepción será convertida en un error fatal y será manejada como un error tradicional.

Debido a que la jerarquía de Error no hereda de Exception, el código que emplee bloques catch (Exception $e) { ... } para manejar excepciones no capturadas en PHP 5 encontrará que estos Errores no son capturados por dichos bloques. Se requiere, por tanto, un bloque catch (Error $e) { ... } o un manejador set_exception_handler().

Jerarquía de Error

  • Throwable
    • Error
      • ArithmeticError
        • DivisionByZeroError
      • AssertionError
      • CompileError
        • ParseError
      • TypeError
        • ArgumentCountError
    • Exception
      • ...


Excepciones

Tabla de contenidos

  • Ampliar las Excepciones

PHP 5 tiene un modelo de excepciones similar al de otros lenguajes de programación. Una excepción puede ser lanzada ("thrown"), y atrapada ("catched") dentro de PHP. El código puede estar dentro de un bloque try para facilitar la captura de excepciones potenciales. Cada bloque try debe tener al menos un bloque catch o finally correspondiente.

El objeto lanzado debe ser una instancia de la clase Exception o una subclase de Exception. Intentar lanzar un objeto que no lo sea resultará en un Error Fatal de PHP.

catch

Se pueden usar múltiples bloques catch para atrapar diferentes clases de excepciones. La ejecución normal (cuando no es lanzada ninguna excepción dentro del bloque try) continuará después del último bloque catch definido en la sencuencia. Las excepciones pueden ser lanzadas ("thrown") (o relanzadas) dentro de un bloque catch.

Cuando una excepción es lanzada, el código siguiente a la declaración no será ejecutado, y PHP intentará encontrar el primer bloque catch coincidente. Si una excepción no es capturada, se emitirá un Error Fatal de PHP con un mensaje "Uncaught Exception ..." ("Excepción No Capturada"), a menos que se haya definido un manejador con set_exception_handler().

finally

En PHP 5.5 y posterior, se puede utilizar un bloque finally después o en lugar de los bloques catch. El código de dentro del bloque finally siempre se ejecutará después de los bloques try y catch, independientemente de que se haya lanzado una excepción o no, y antes de que la ejecución normal continúe.

Notas

Nota:

Las funciones internas de PHP utilizan principalmente la Información de Errores, sólo las extensiones Orientadas a objetos modernas utilizan excepciones. Sin embargo, los errores se pueden traducir a excepciones simplemente con ErrorException.

Sugerencia

La Biblioteca Estádar de PHP (SPL) proporciona un buen número de excepciones internas.

Ejemplos

Ejemplo #3 Lanzar una Excepción

<?php
function inverso($x) {
    if (!$x) {
        throw new Exception('División por cero.');
    }
    return 1/$x;
}

try {
    echo inverso(5) . "\n";
    echo inverso(0) . "\n";
} catch (Exception $e) {
    echo 'Excepción capturada: ',  $e->getMessage(), "\n";
}

// Continuar la ejecución
echo 'Hola Mundo\n';
?>

El resultado del ejemplo sería:

0.2
Excepción capturada: División por cero.
Hola Mundo

Ejemplo #4 Manejo de excepciones con un bloque finally

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('División por cero.');
    }
    return 1/$x;
}

try {
    echo inverse(5) . "\n";
} catch (Exception $e) {
    echo 'Excepción capturada: ',  $e->getMessage(), "\n";
} finally {
    echo "Primer finally.\n";
}

try {
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'Excepción capturada: ',  $e->getMessage(), "\n";
} finally {
    echo "Segundo finally.\n";
}

// Continuar ejecución
echo 'Hola Mundo\n';
?>

El resultado del ejemplo sería:

0.2
Primer finally.
Excepción capturada: División por cero.
Segundo finally.
Hola Mundo

Ejemplo #5 Excepciones anidadas

<?php

class MiExcepción extends Exception { }

class Prueba {
    public function probar() {
        try {
            try {
                throw new MiExcepción('foo!');
            } catch (MiExcepción $e) {
                // relanzarla
                throw $e;
            }
        } catch (Exception $e) {
            var_dump($e->getMessage());
        }
    }
}

$foo = new Prueba;
$foo->probar();

?>

El resultado del ejemplo sería:

string(4) "foo!"


Ampliar las Excepciones

Una clase de Excepción definida por el usuario puede ser definida ampliando la clase Exception interna. Los miembros y las propiedades de abajo muestran lo que es accesible dentro de la clase hija que deriva de la clase Exception interna.

Ejemplo #1 La clase Exception Interna

<?php
class Exception
{
    protected $message = 'Unknown exception';   // mensaje de excepción
    private   $string;                          // caché de __toString
    protected $code = 0;                        // código de excepción definido por el usuario
    protected $file;                            // nombre de archivo fuente de la excepción
    protected $line;                            // línea fuente de la excepción
    private   $trace;                           // determinación del origen
    private   $previous;                        // excepción previa si la excepción está anidada

    public function __construct($message = null, $code = 0, Exception $previous = null);

    final private function __clone();           // Inhibe la clonación de excepciones.

    final public  function getMessage();        // mensaje de excepción
    final public  function getCode();           // código de excepción
    final public  function getFile();           // nombre de archivo fuente
    final public  function getLine();           // línea fuente
    final public  function getTrace();          // un array de backtrace()
    final public  function getPrevious();       // excepción anterior
    final public  function getTraceAsString();  // string formateado del seguimiento del origen

    // Sobrescribible
    public function __toString();               // string formateado para mostrar
}
?>

Si una clase extiende la clase Exception interna y redefine el constructor, se recomienda encarecidamente que también llame a parent::__construct() para asegurarse que toda la información disponible haya sido asignada apropiadamente. El método __toString() puede ser sobrescrito para proporcionar una salida personalizada cuando el objeto es presentado como un string.

Nota:

Las excepciones no se pueden clonar. Intentar clonar una Excepción resultará en un error E_ERROR fatal.

Ejemplo #2 Extender la clase Exception (PHP 5.3.0+)

<?php
/**
 * Definir una clase de excepción personalizada
 */
class MiExcepción extends Exception
{
    // Redefinir la excepción, por lo que el mensaje no es opcional
    public function __construct($message, $code = 0, Exception $previous = null) {
        // algo de código

        // asegúrese de que todo está asignado apropiadamente
        parent::__construct($message, $code, $previous);
    }

    // representación de cadena personalizada del objeto
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function funciónPersonalizada() {
        echo "Una función personalizada para este tipo de excepción\n";
    }
}

/**
 * Crear una clase para probar la excepción
 */
class ProbarExcepción
{
    public $var;

    const THROW_NONE    = 0;
    const THROW_CUSTOM  = 1;
    const THROW_DEFAULT = 2;

    function __construct($avalue = self::THROW_NONE) {

        switch ($avalue) {
            case self::THROW_CUSTOM:
                // lanzar la excepción personalizada
                throw new MiExcepción('1 no es un parámetro válido', 5);
                break;

            case self::THROW_DEFAULT:
                // lanzar la predeterminada.
                throw new Exception('2 no está permitido como parámetro', 6);
                break;

            default:
                // No hay excepción, el objeto se creará.
                $this->var = $avalue;
                break;
        }
    }
}

// Ejemplo 1
try {
    $o = new ProbarExcepción(ProbarExcepción::THROW_CUSTOM);
} catch (MiExcepción $e) {      // Será atrapada
    echo "Atrapada mi excepción\n", $e;
    $e->funciónPersonalizada();
} catch (Exception $e) {        // Skipped
    echo "Atrapada la Excepción Predeterminada\n", $e;
}

// Continuar la ejecución
var_dump($o); // Null
echo "\n\n";

// Ejemplo 2
try {
    $o = new ProbarExcepción(ProbarExcepción::THROW_DEFAULT);
} catch (MiExcepción $e) {      // Este tipo no coincide
    echo "Atrapada mi excepción\n", $e;
    $e->funciónPersonalizada();
} catch (Exception $e) {        // Will be caught
    echo "Atrapada la Excepción Predeterminada\n", $e;
}

// Continuar la ejecución
var_dump($o); // Null
echo "\n\n";

// Ejemplo 3
try {
    $o = new ProbarExcepción(ProbarExcepción::THROW_CUSTOM);
} catch (Exception $e) {        // Será atrapada
    echo "Atrapada la Excepción Predeterminada\n", $e;
}

// Continuar la ejecución
var_dump($o); // Null
echo "\n\n";

// Ejemplo 4
try {
    $o = new ProbarExcepción();
} catch (Exception $e) {        // Saltado, sin excepción
    echo "Atrapada la Excepción Predeterminada\n", $e;
}

// Continuar la ejecución
var_dump($o); // ProbarExcepción
echo "\n\n";
?>

Nota:

Las versiones de PHP 5, anteriores a PHP 5.3.0, no soportan excepciones anidadas. El siguiente fragmento de código se puede usar para reemplazar la clase MiExcepción si se desea ejecutar este ejemplo.

<?php
/**
 * Definir una clase de excepción personalizada
 */
class MiExcepción extends Exception
{
    // Redefinir la excepción, por lo que el mensaje no es opcional
    public function __construct($message, $code = 0) {
        // algo de código

        // asegúrese de que todo está asignador apropiadamente
        parent::__construct($message, $code);
    }

    // representación de cadena personalizada del objeto
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function funciónPersonalizada() {
        echo "Una función personalizada para este tipo de excepción\n";
    }
}
?>


Generadores

Tabla de contenidos

  • Información general de los generadores
  • Generator syntax
  • Comparación entre generadores y objetos Iterator


Información general de los generadores

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Los generadores proporcionan un modo fácil de implementar iteradores simples sin la sobrecarga o complejidad de implementar una clase que implemente la interfaz Iterator.

Un generador permite escribir código que utilice foreach para iterar sobre un conjunto de datos sin que sea necesario cargar el array en memoria, lo que puede ocasionar que se exceda el límite de memoria, o requiera una cantidad considerable de tiempo de procesado para generarse. En su lugar, se puede escribir una función generadora, que es igual que una función normal, con la salvedad de que en vez de hacer un solo return, un generador puede invocar yield tantas veces como necesite para proporcionar valores por los que iterar.

Un ejemplo simple de esto es reimplementar la función range() como un generador. La función estándar range() tiene que generar un array con cada uno de los valores y devolverlo, lo que puede resultar en arrays grandes: por ejemplo, llamar range(0, 1000000) resultará en más de 100 MB de memoria utilizada.

Como alternativa, se puede implementar un generador xrange(), que sólo necesitará memoria para crear un objeto Iterator y controlar el estado actual del generador de manera interna, lo que no ocupa más de 1 kilobyte.

Ejemplo #1 Implementando range() como generador

<?php
function xrange($start, $limit, $step = 1) {
    if ($start < $limit) {
        if ($step <= 0) {
            throw new LogicException('Step tiene que ser +ve');
        }

        for ($i = $start; $i <= $limit; $i += $step) {
            yield $i;
        }
    } else {
        if ($step >= 0) {
            throw new LogicException('Step tiene que ser -ve');
        }

        for ($i = $start; $i >= $limit; $i += $step) {
            yield $i;
        }
    }
}

/*
 * Obsereve que tanto range() como xrange() producen la misma
 * salida a continuación.
 */

echo 'Números impares de una cifra de range():  ';
foreach (range(1, 9, 2) as $number) {
    echo "$number ";
}
echo "\n";

echo 'Números impares de una cifra de xrange():  ';
foreach (xrange(1, 9, 2) as $number) {
    echo "$number ";
}
?>

El resultado del ejemplo sería:

Números impares de una cifra de range():  1 3 5 7 9
Números impares de una cifra de xrange(): 1 3 5 7 9

Objetos Generator

Cuando una función generadora es invocada por primera vez, se devuelve un objeto de la clase interna Generator. Este objeto implementa la interfaz Iterator de la misma forma que lo haría un objeto iterador de solo avance, y proporciona métodos que pueden ser invocados para manipular el estado del generador, incluyendo el envío de valores hacia y la devolución de valores desde él.


Generator syntax

Una función generadora es igual que una función normal, con la diferencia de que en vez de devolver un valor, un generador invoca yield tantas veces como necesita.

Cuando se llama a una función generadora, devuelve un objeto que puede ser iterado. Cuando se itera sobre ese objeto (por ejemplo, con un bucle foreach), PHP llamará a la función generadora cada vez que necesite un valor, y guardará el estado del generador cuando este provea un valor con yield para que ese estado pueda ser recuperado cuando el próximo valor sea requerido.

Cuando no hay más valores que se puedan proporcionar, la función generadora puede simplemente terminar, y el código desde el que se la llama continuará como si un array se hubiera quedado sin valores.

Nota:

Un generador no puede retornar un valor: hacerlo resultaría en un error de compilación. Un return vacío es válido en cuanto a sintaxis dentro de un generador y terminará el generador.

yield keyword

La clave de una función generadora es la palabra reservada yield. En su forma más simple, la sentencia yield es parecida a la sentencia return, excepto en que en vez de detener la ejecución de la función y devolver un valor, yield facilita el valor al bucle que itera sobre el generador y pausa la ejecución de la función generadora.

Ejemplo #1 Ejemplo sencillo de facilitar valores con yield

<?php
function gen_one_to_three() {
    for ($i = 1; $i <= 3; $i++) {
        // Observe que $i es preservado entre yields
        yield $i;
    }
}

$generator = gen_one_to_three();
foreach ($generator as $value) {
    echo "$value\n";
}
?>

El resultado del ejemplo sería:

1
2
3

Nota:

Internamente, las claves enteras secuenciales serán asociadas con los valores sobre los que se usa yield, como un array no asociativo.

Precaución

Si se utiliza yield en el contexto de una expresión (por ejemplo, en el lado derecho de una asignación), se debe poner la sentencia yield entre paréntesis en PHP 5. Por ejemplo, esto es válido:

$data = (yield $value);

Pero esto no lo es, y resultará en un error de análisis en PHP 5:

$data = yield $value;

Las restricciones parentéticas no se aplican en PHP 7.

Esta sintaxis podría usarse junto con el método Generator::send().

Utilizar yield para facilitar valores con claves

PHP soporta arrays asociativos, y los generadores no son menos. Además de facilitar valores simples, como se muestra arriba, también se puede facilitar una clave al mismo tiempo.

La sintaxis para facilitar un par clave-valor es muy similar a la utilizada para definir un array asociativo, como se muestra a continuación.

Ejemplo #2 Facilitar un par clave-valor

<?php
/*
 * La entrada son campos separados por punto y coma, con el primer
 * campo siendo la ID utilizada como clave.
 */

$input = <<<'EOF'
1;PHP;Likes dollar signs
2;Python;Likes whitespace
3;Ruby;Likes blocks
EOF;

function input_parser($input) {
    foreach (explode("\n", $input) as $line) {
        $fields = explode(';', $line);
        $id = array_shift($fields);

        yield $id => $fields;
    }
}

foreach (input_parser($input) as $id => $fields) {
    echo "$id:\n";
    echo "    $fields[0]\n";
    echo "    $fields[1]\n";
}
?>

El resultado del ejemplo sería:

1:
    PHP
    Likes dollar signs
2:
    Python
    Likes whitespace
3:
    Ruby
    Likes blocks
Precaución

Como en el ejemplo anterior, facilitar un par clave-valor en contexto de expresión requiere que la sentencia yield sea puesta entre paréntesis:

$data = (yield $key => $value);

Facilitar valores nulos

Yield puede ser invocado sin argumentos para facilitar un valor null con una clave automática.

Ejemplo #3 Yielding nulls

<?php
function gen_three_nulls() {
    foreach (range(1, 3) as $i) {
        yield;
    }
}

var_dump(iterator_to_array(gen_three_nulls()));
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  NULL
  [1]=>
  NULL
  [2]=>
  NULL
}

Facilitar por referencia

Las funciones generadoras son capaces de facilitar valores por referencia igual que lo hacen por valor. Esto se hace de la misma forma que devolviendo referencias desde funciones: poniendo un ampersand (signo &) delante del nombre de la función.

Ejemplo #4 Facilitar valores por referencia

<?php
function &gen_reference() {
    $value = 3;

    while ($value > 0) {
        yield $value;
    }
}

/*
 * Observe que es posible cambiar $number desde dentro del bucle, y
 * dado que el generador está facilitando referencias, $value
 * dentro de gen_reference() cambia.
 */
foreach (gen_reference() as &$number) {
    echo (--$number).'... ';
}
?>

El resultado del ejemplo sería:

2... 1... 0...

Delegación de generadores mediante yield from

En PHP 7, la delegación de generadores permite producir valores desde otro generador, objeto Traversable, o array mediante la palabra reservada yield from. El generador externo producirá entonces todos los valores desde el generador interno, object, o array hasta que este ya no sea válido, después de lo cual la ejecuión continuará en el generador externo.

Si un generador se emplea con yield from, la expresión yield from también devolverá cualquier valor devuelto por el generador interno.

Precaución

Almacenamiento en un array (p.ej. con iterator_to_array())

yield from no reinicia las claves. Preserva las claves devueltas por el objeto Traversable o array. Por tanto, algunos valores podrían compartir una clave en común con otro yield o yield from, los cuales, en el momento de la inserción en el array, sobrescribirán los valores antiguos con esa clave.

Un caso común donde esto importa es cuando iterator_to_array() devuelve un array con claves por defecto, conduciendo a posibles resultados inesperados. iterator_to_array() tiene un segundo parámetro, use_keys, que puede ser establecido a false para recoger todos los valores mientras ignora las claves devueltas por el Generator.

Ejemplo #5 yield from con iterator_to_array()

<?php
function from() {
    yield 1; // clave 0
    yield 2; // clave 1
    yield 3; // clave 2
}
function gen() {
    yield 0; // clave 0
    yield from from(); // claves 0-2
    yield 4; // clave 1
}
// pasar false como segundo parámetro para obtener un array [0, 1, 2, 3, 4]
var_dump(iterator_to_array(gen()));
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(4)
  [2]=>
  int(3)
}

Ejemplo #6 Uso básico de yield from

<?php
function contar_hasta_diez() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from siete_ocho();
    yield 9;
    yield 10;
}

function siete_ocho() {
    yield 7;
    yield from ocho();
}

function ocho() {
    yield 8;
}

foreach (contar_hasta_diez() as $num) {
    echo "$num ";
}
?>

El resultado del ejemplo sería:

1 2 3 4 5 6 7 8 9 10

Ejemplo #7 yield from y valores devueltos

<?php
function contar_hasta_diez() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from siete_ocho();
    return yield from nueve_diez();
}

function siete_ocho() {
    yield 7;
    yield from ocho();
}

function ocho() {
    yield 8;
}

function nueve_diez() {
    yield 9;
    return 10;
}

$gen = contar_hasta_diez();
foreach ($gen as $num) {
    echo "$num ";
}
echo $gen->getReturn();
?>

El resultado del ejemplo sería:

1 2 3 4 5 6 7 8 9 10


Comparación entre generadores y objetos Iterator

La principal ventaja de los generadores es su simplicadad. Se ha de escribir mucho menos código repetitivo en comparación con el necesario para implementar una clase Iterator, y el código es generalmente mucho más legible. Por ejemplo, la siguiente función y clase son equivalentes:

<?php
function getLinesFromFile($fileName) {
    if (!$fileHandle = fopen($fileName, 'r')) {
        return;
    }

    while (false !== $line = fgets($fileHandle)) {
        yield $line;
    }

    fclose($fileHandle);
}

// Contra...

class LineIterator implements Iterator {
    protected $fileHandle;

    protected $line;
    protected $i;

    public function __construct($fileName) {
        if (!$this->fileHandle = fopen($fileName, 'r')) {
            throw new RuntimeException('Couldn\'t open file "' . $fileName . '"');
        }
    }

    public function rewind() {
        fseek($this->fileHandle, 0);
        $this->line = fgets($this->fileHandle);
        $this->i = 0;
    }

    public function valid() {
        return false !== $this->line;
    }

    public function current() {
        return $this->line;
    }

    public function key() {
        return $this->i;
    }

    public function next() {
        if (false !== $this->line) {
            $this->line = fgets($this->fileHandle);
            $this->i++;
        }
    }

    public function __destruct() {
        fclose($this->fileHandle);
    }
}
?>

La flexibilidad, sin embargo, tiene un coste: los generadores son iteradores unidireccionales, ya que no pueden ser rebobinados una vez la iteración ha empezado. Esto también significa que se puede iterar sobre el mismo generador varias veces: el generador necesitará ser reconstruido llamando a la función generadora de nuevo.


Attributes

Tabla de contenidos

  • Attributes overview
  • Attribute syntax
  • Reading Attributes with the Reflection API
  • Declaring Attribute Classes


Attributes overview

(PHP 8)

Attributes offer the ability to add structured, machine-readable metadata information on declarations in code: Classes, methods, functions, parameters, properties and class constants can be the target of an attribute. The metadata defined by attributes can then be inspected at runtime using the Reflection APIs. Attributes could therefore be thought of as a configuration language embedded directly into code.

With attributes the generic implementation of a feature and its concrete use in an application can be decoupled. In a way it is comparable to interfaces and their implementations. But where interfaces and implementations are about code, attributes are about annotating extra information and configuration. Interfaces can be implemented by classes, yet attributes can also be declared on methods, functions, parameters, properties and class constants. As such they are more flexible than interfaces.

A simple example of attribute usage is to convert an interface that has optional methods to use attributes. Lets assume an ActionHandler interface representing an operation in an application, where some implementations of an action handler require setup and others do not. Instead of requiring all classes that implement ActionHandler to implement a method setUp(), an attribute can be used. One benefit of this approach is that we can use the attribute several times.

Ejemplo #1 Implementing optional methods of an interface with Attributes

<?php
interface ActionHandler
{
    public function execute();
}

#[Attribute]
class SetUp {}

class CopyFile implements ActionHandler
{
    public string $fileName;
    public string $targetDirectory;

    #[SetUp]
    public function fileExists()
    {
        if (!file_exists($this->fileName)) {
            throw new RuntimeException("File does not exist");
        }
    }

    #[SetUp]
    public function targetDirectoryExists()
    {
        mkdir($this->targetDirectory);
    }

    public function execute()
    {
        copy($this->fileName, $this->targetDirectory . '/' . basename($this->fileName));
    }
}

function executeAction(ActionHandler $actionHandler)
{
    $reflection = new ReflectionObject($actionHandler);

    foreach ($reflection->getMethods() as $method) {
        $attributes = $method->getAttributes(SetUp::class);

        if (count($attributes) > 0) {
            $methodName = $method->getName();

            $actionHandler->$methodName();
        }
    }

    $actionHandler->execute();
}

$copyAction = new CopyFile();
$copyAction->fileName = "/tmp/foo.jpg";
$copyAction->targetDirectory = "/home/user";

executeAction($copyAction);


Attribute syntax

There are several parts to the attributes syntax. First, an attribute declaration is always enclosed with a starting #[ and a corresponding ending ]. Inside, one or many attributes are listed, separated by comma. The attribute name is an unqualified, qualified or fully-qualified name as described in Using Namespaces Basics. Arguments to the attribute are optional, but are enclosed in the usual parenthesis (). Arguments to attributes can only be literal values or constant expressions. Both positional and named arguments syntax can be used.

Attribute names and their arguments are resolved to a class and the arguments are passed to its constructor, when an instance of the attribute is requested through the Reflection API. As such a class should be introduced for each attribute.

Ejemplo #1 Attribute Syntax

<?php
// a.php
namespace MyExample;

use Attribute;

#[Attribute]
class MyAttribute
{
    const VALUE = 'value';

    private $value;

    public function __construct($value = null)
    {
        $this->value = $value;
    }
}

// b.php

namespace Another;

use MyExample\MyAttribute;

#[MyAttribute]
#[\MyExample\MyAttribute]
#[MyAttribute(1234)]
#[MyAttribute(value: 1234)]
#[MyAttribute(MyAttribute::VALUE)]
#[MyAttribute(array("key" => "value"))]
#[MyAttribute(100 + 200)]
class Thing
{
}

#[MyAttribute(1234), MyAttribute(5678)]
class AnotherThing
{
}


Reading Attributes with the Reflection API

To access attributes from classes, methods, functions, parameters, properties and class constants, the Reflection API provides the method getAttributes() on each of the corresponding Reflection objects. This method returns an array of ReflectionAttribute instances that can be queried for attribute name, arguments and to instantiate an instance of the represented attribute.

This separation of reflected attribute representation from actual instance increases control of the programmer to handle errors regarding missing attribute classes, mistyped or missing arguments. Only after calling newInstance(), objects of the attribute class are instantiated and the correct matching of arguments is validated, not earlier.

Ejemplo #1 Reading Attributes using Reflection API

<?php

#[Attribute]
class MyAttribute
{
    public $value;

    public function __construct($value)
    {
        $this->value = $value;
    }
}

#[MyAttribute(value: 1234)]
class Thing
{
}

function dumpAttributeData($reflection) {
    $attributes = $reflection->getAttributes();

    foreach ($attributes as $attribute) {
       var_dump($attribute->getName());
       var_dump($attribute->getArguments());
       var_dump($attribute->newInstance());
    }
}

dumpAttributeData(new ReflectionClass(Thing::class));
/*
string(11) "MyAttribute"
array(1) {
  ["value"]=>
  int(1234)
}
object(MyAttribute)#3 (1) {
  ["value"]=>
  int(1234)
}
*/

Instead of iterating all attributes on the reflection instance, only those of a particular attribute class can be retrieved by passing the searched attribute class name as argument.

Ejemplo #2 Reading Specific Attributes using Reflection API

<?php

function dumpMyAttributeData($reflection) {
    $attributes = $reflection->getAttributes(MyAttribute::class);

    foreach ($attributes as $attribute) {
       var_dump($attribute->getName());
       var_dump($attribute->getArguments());
       var_dump($attribute->newInstance());
    }
}

dumpAttributeData(new ReflectionClass(Thing::class));


Declaring Attribute Classes

While not strictly required it is recommended to create an actual class for every attribute. In the most simple case only an empty class is needed with the #[Attribute] attribute declared that can be imported from the global namespace with a use statement.

Ejemplo #1 Using target specification to restrict where attributes can be used

<?php

namespace Example;

use Attribute;

#[Attribute]
class MyAttribute
{
}

To restrict the type of declaration an attribute can be assigned to, a bitmask can be passed as the first argument to the #[Attribute] declaration.

Ejemplo #2 Simple Attribute Class

<?php

namespace Example;

use Attribute;

#[Attribute(Attribute::TARGET_METHOD | Attribute::TARGET_FUNCTION)]
class MyAttribute
{
}

Declaring MyAttribute on another type will now throw an exception during the call to ReflectionAttribute::newInstance()

By default an attribute can only be used once per declaration. If the attribute should be repeatable on declarations it must be specified as part of the bitmask to the #[Attribute] declaration.

Ejemplo #3 Using IS_REPEATABLE to allow attribute on a declaration multiple times

<?php

namespace Example;

use Attribute;

#[Attribute(Attribute::TARGET_METHOD | Attribute::TARGET_FUNCTION | Attribute::IS_REPEATABLE)]
class MyAttribute
{
}


Explicación de las Referencias

Tabla de contenidos

  • ¿Qué son las Referencias?
  • ¿Qué hacen las referencias?
  • ¿Qué NO son las Referencias?
  • Pasar por Referencia
  • Devolver Referencias
  • Destruir Referencias
  • Ubicar las Referencias


¿Qué son las Referencias?

Las Referencias en PHP son medios de acceder al mismo contenido de una variable mediante diferentes nombres. No son como los punteros de C; por ejemplo, no se puede realizar aritmética de punteros con ellas, realmente no son direcciones de memoria, etc. Véase ¿Qué NO son las Referencias? para más información. Las referencias son alias de la tabla de símbolos. Observe que en PHP el nombre de la variable y el contenido de la variable son cosas diferentes, por lo que el mismo contenido puede tener diferentes nombres. La analogía más próxima es con los archivos y los nombres de archivos de Unix - los nombres de variables son entradas de directorio, mientras que el contenido de las variables es el archivo en sí. Las referencias se pueden vincular a enlaces duros en sistemas de archivos Unix.


¿Qué hacen las referencias?

Hay tres operaciones básicas que se realizan usando referencias: asignar por referencia, pasar por referencia, y devolver por referencia. En esta sección se dará una introducción a estas operaciones, con enlaces para una lectura complementaria.

Asignar por Referencia

En la primera de estas operaciones, las referencias de PHP permiten hacer que dos variables hagan referencia al mismo contenido. Es decir, cuando se hace:

<?php
$a =& $b;
?>
significa que $a y $b apuntan al mismo contenido.

Nota:

$a y $b aquí son completamente iguales. $a no está apuntando a $b o viceversa. $a y $b están apuntando al mismo lugar.

Nota:

Si se asigna, pasa, o devuelve una variable no definida por referencia, la variable se creará.

Ejemplo #1 Usar referencias con variables no definidas

<?php
function foo(&$var) { }

foo($a); // $a es "creada" y asignada a null

$b = array();
foo($b['b']);
var_dump(array_key_exists('b', $b)); // bool(true)

$c = new StdClass;
foo($c->d);
var_dump(property_exists($c, 'd')); // bool(true)
?>

Se puede usar la misma sintaxis con funciones que devuelven referencias:

<?php
$foo =& find_var($bar);
?>
Desde PHP 5, new devuelve una referencia automáticamente, por lo que usar =& en este contexto es obsoleto y produce un mensaje E_DEPRECATED en PHP 5.3 y posteriores, y un mensaje E_STRICT en versiones anteriores. A partir de PHP 7.0 es sintácticamente inválido. (Técnicamente, la diferencia es que, en PHP 5, las variables de objetos, como los recursos, son meros punteros a la información del objeto actual, por lo que estas referencias a objetos no son "referencias" en el mismo sentido usado antes (alias). Para más información, véase Objetos y referencias.)

Advertencia

Si se asigna una referencia a una varible declarada global dentro de una función, la referencia será visible sólo dentro de la función. Se puede evitar esto usando la matriz $GLOBALS.

Ejemplo #2 Refenciar variables globales dentro de funciones

<?php
$var1 = "Variable de ejemplo";
$var2 = "";

function referencias_globales($usar_globals)
{
    global $var1, $var2;
    if (!$usar_globals) {
        $var2 =& $var1; // visible sólo dentro de la función
    } else {
        $GLOBALS["var2"] =& $var1; // visible también en el contexto global
    }
}

referencias_globales(false);
echo "var2 está establecida a '$var2'\n"; // var2 está establecida a ''
referencias_globales(true);
echo "var2 está establecida a '$var2'\n"; // var2 está establecida a 'Variable de ejemplo'
?>
Piense en global $var; como simplificación de $var =& $GLOBALS['var'];. De este modo, al asignar otra referencia a $var sólo cambia la referencia de la variable local.

Nota:

Si se asigna un valor a una variable con referencias en una sentencia foreach, también se modifican las referencias.

Ejemplo #3 Referencias y la sentencia foreach

<?php
$ref = 0;
$fila =& $ref;
foreach (array(1, 2, 3) as $fila) {
    // hacer algo
}
echo $ref; // 3 - último elemento de la matriz iterada
?>

Mientras que no sea estrictamente una asignación por referencia, las expresiones creadas con el constructor de lenguaje array() también pueden comportarse como tales prefijando & al elemento del array a añadir. Ejemplo:

<?php
$a = 1;
$b = array(2, 3);
$arr = array(&$a, &$b[0], &$b[1]);
$arr[0]++; $arr[1]++; $arr[2]++;
/* $a == 2, $b == array(3, 4); */
?>

Observe, sin embargo, que las referencias dentro de arrays son potencialmente peligrosas. Realizar una asignación normal (no por referencia) con una referencia en el lado derecho no convierte el lado izquierdo en una referencia, pero las referencias dentro de arrays son conservadas en estas asignaciones normales. Esto también se aplica a las llamadas a funciones donde el array es pasado por valor. Ejemplo:

<?php
/* Asignación de variables escalares */
$a = 1;
$b =& $a;
$c = $b;
$c = 7; //$c no es una referencia; no cambia $a o $b

/* Asignación de variables de array */
$arr = array(1);
$a =& $arr[0]; // $a y $arr[0] son el mismo conjunto de referencias
$arr2 = $arr; // ¡no es una asignación por referencia!
$arr2[0]++;
/* $a == 2, $arr == array(2) */
/* ¡El contenido de $arr se cambia incluso si no es una referencia! */
?>
En otras palabras, el comportamiento de las referencias de arrays está definido en una base elemento-por-elemento; el comportamiento de las referencias de elementos individuales está desasociado del estado de la referencia del array contenedor.

Pasar por Referencia

Lo segundo que hacen las referencias es pasar variables por referencia. Esto se lleva a cabo haciendo que una variable local en una función y una variable en el ámbito de la llamada referencien al mismo contenido. Ejemplo:

<?php
function foo(&$var)
{
    $var++;
}

$a=5;
foo($a);
?>
hará que $a sea 6. Esto sucede porque en la función foo la variable $var hace referencia al mismo contenido que $a. Para más información sobre esto, lea la sección pasar por referencia.

Devolver por Referencia

Lo tercero que hacen las referncias es devolver por referencia.


¿Qué NO son las Referencias?

Como se dijo antes, las referencias no son punteros. Es decir, la siguiente construcción no hará lo que se esperaba:

<?php
function foo(&$var)
{
    $var =& $GLOBALS["baz"];
}
foo($bar);
?>

Lo que sucede es que $var en foo será ligada con $bar en la llamada, pero entonces será religada con $GLOBALS["baz"]. No hay forma de ligar $bar en el ámbito de la llamada a otra cosa usando el mecanismo de referencia, ya que $bar no está disponible en la función foo (está representada por $var, pero $var sólo tiene el contenido de la variable y no la vinculación nombre-a-valor en la tabla de símbolos de llamada). Se puede usar devolver referencias para referencias variables seleccionadas por la función.


Pasar por Referencia

Se puede pasar una variable por referencia a una función y así hacer que la función pueda modificar la variable. La sintaxis es la siguiente:

<?php
function foo(&$var)
{
    $var++;
}

$a=5;
foo($a);
// $a es 6 aquí
?>

Nota: No existe ningún signo de referencia en una llamada a una función - sólo en la definición de la función. Las definiciones de funciones por sí solas son suficientes para pasar correctamente el argumento por referencia. A partir de PHP 5.3.0, se obtendrá una advertencia diciendo que "call-time pass-by-reference" (pasar por referencia en tiempo de llamada) está obsoleto cuando se use & en foo(&$a);. A partir de PHP 5.4.0, el paso por referencia en tiempo de llamada ha sido eliminado, por lo que su uso emitirá un error fatal.

Se puede pasar por referencia lo siguiente:

  • Variables, esto es, foo($a)

  • Referencias devueltas desde funciones, esto es:

    <?php
    function foo(&$var)
    {
            $var++;
    }
    function &    bar()
    {
            $a = 5;
        return     $a;
    }
    foo(bar());
    ?>
    Vea más sobre devolver por referencia.

Ninguna otra expresión debería pasarse por referencia, ya que el resultado no está definido. Por ejemplo, los siguientes ejemplos de pasar por referencia no son válidos:

<?php
function foo(&$var)
{
    $var++;
}
function bar() // Observe que falta el &
{
    $a = 5;
    return $a;
}
foo(bar()); // Produce un error fatal a partir de PHP 5.0.5,un aviso de estándar estricto
            // a partir de PHP 5.1.1, y un aviso a partir de PHP 7.0.0

foo($a = 5); // Expresión, no una variable
foo(5); // Produce un error fatal

class Foobar
{
}

foo(new Foobar()) // Produce un aviso a partir de PHP 7.0.7
                  // Observación: Solo las variables deben pasarse por referencia
?>


Devolver Referencias

Devolver por referencia es útil cuando se quiere usar una función para encontrar a qué variable debería estar vinculada una referencia. No use devolver por referencia para aumentar el rendimiento. El motor optimizará automáticamente esto por sí mismo. Hay que devolver referencias sólo cuando se tenga una razón técnicamente válida para hacerlo. Para devolver referencias use esta sintaxis:

<?php
class foo {
    public $valor = 42;

    public function &obtenerValor() {
        return $this->valor;
    }
}

$obj = new foo;
$miValor = &$obj->obtenerValor(); // $miValor es una referencia a $obj->valor, que es 42.
$obj->valor = 2;
echo $miValor;                // imprime el nuevo valor de $obj->valor, esto es, 2.
?>
En este ejemplo, la propiedad del objeto devuelto por la función obtenerValor debería estar establecida, no la copia, como si estuviera sin usar la sintaxis de referencia.

Nota: A diferencia de pasar un parámetro, aquí se tiene que usar & en ambos lugares - para indicar que se quiere devolver por referencia, no una copia, y para indicar que la vinculación por referencia, en vez de la asignación normal, debería ser hecha para $miValor.

Nota: Si se intenta devolver una referencia desde una función con la sintaxis: return ($this->valor);, no funcionará ya que se está intentando devolver el resultado de una expresión, y no de una variable, por referencia. Sólo se puede devolver variables por referencia desde una función - nada más. Desde PHP 5.1.0, se emite un error E_NOTICE si el código intenta devolver una expresión dinámica o un resultado del operador new.

Para usar la referencia retornada, se debe usar la asignación por referencia:

<?php
function &collector() {
  static $collection = array();
  return $collection;
}
$collection = &collector();
$collection[] = 'foo';
?>
Para pasar la referencia retornada a otra función que espera una referencia se puede usar la siguiente sintaxis:
<?php
function &collector() {
  static $collection = array();
  return $collection;
}
array_push(collector(), 'foo');
?>

Nota: Observe que array_push(&collector(), 'foo'); no funcionará, resultará en un error fatal.


Destruir Referencias

Cuando se destruye una referencia, se rompe el vínculo entre el nombre de la variable y el contenido de la variable. Esto no significa que el contenido de la variable sea destruida. Por ejemplo:

<?php
$a = 1;
$b =& $a;
unset($a);
?>
no destruirá $b, sólo $a.

De nuevo, podría ser útil pensar en esto como análogo a una llamada a unlink de Unix.


Ubicar las Referencias

Muchas construcciones sintácticas de PHP están implementadas mediante el mecanismo de referencia, por lo que todo lo mencionado aquí sobre la vinculación de referencias también se aplica a estas construcciones. Algunas construcciones, como pasar y devolver por referencia, han sido mencionadas antes. Otras construcciones que usan referencias son:

Referencias globales

Cuando se declara una variable como global $var, de hecho se está creando una referencia a una variable global. Es decir, esto es lo mismo que:

<?php
$var =& $GLOBALS["var"];
?>

Esto también significa que al destruir $var no se destruirá la variable global.

$this

En un método de un objeto, $this es siempre una referencia al objeto llamado.


Variables predefinidas

PHP proporciona una gran cantidad de variables predefinidas para todos los scripts. Las variables representan de todo, desde variables externas hasta variables de entorno incorporadas, desde los últimos mensajes de error hasta los últimos encabezados recuperados.

Tabla de contenidos

  • Superglobals — Superglobals son variables internas que están disponibles siempre en todos los ámbitos
  • $GLOBALS — Hace referencia a todas las variables disponibles en el ámbito global
  • $_SERVER — Información del entorno del servidor y de ejecución
  • $_GET — Variables HTTP GET
  • $_POST — Variables POST de HTTP
  • $_FILES — Variables de subida de ficheros HTTP
  • $_REQUEST — Variables HTTP Request
  • $_SESSION — Variables de sesión
  • $_ENV — Variables de entorno
  • $_COOKIE — Cookies HTTP
  • $php_errormsg — El mensaje de error anterior
  • $http_response_header — Encabezados de respuesta HTTP
  • $argc — El número de argumentos pasados a un script
  • $argv — Array de argumentos pasados a un script


Superglobals son variables internas que están disponibles siempre en todos los ámbitos

  • « Variables predefinidas
  • $GLOBALS »
  • PHP Manual
  • Variables predefinidas
  • Superglobals son variables internas que están disponibles siempre en todos los ámbitos

Superglobals

Superglobals — Superglobals son variables internas que están disponibles siempre en todos los ámbitos

Descripción

Algunas variables predefinidas en PHP son "superglobales", lo que significa que están disponibles en todos los ámbitos a lo largo del script. No es necesario emplear global $variable; para acceder a ellas dentro de las funciones o métodos.

Las variables superglobals son:

  • $GLOBALS
  • $_SERVER
  • $_GET
  • $_POST
  • $_FILES
  • $_COOKIE
  • $_SESSION
  • $_REQUEST
  • $_ENV

Notas

Nota: Disponibilidad de variables

Por defecto, todas las superglobals están disponibles pero hay directivas que afectan a su disponibilidad. Para más información, véase la documentacion de variables_order.

Nota: Variables variables

Las variables superglobals no pueden ser usadas como variables variables dentro de funciones o métodos de clase.

Ver también

  • ámbito de las variables
  • La directiva variables_order
  • La extensión filter


Hace referencia a todas las variables disponibles en el ámbito global

  • « Superglobals
  • $_SERVER »
  • PHP Manual
  • Variables predefinidas
  • Hace referencia a todas las variables disponibles en el ámbito global

$GLOBALS

(PHP 4, PHP 5, PHP 7, PHP 8)

$GLOBALS — Hace referencia a todas las variables disponibles en el ámbito global

Descripción

Es un array asociativo que contiene las referencias a todas la variables que están definidas en el ámbito global del script. Los nombres de las variables son las claves del array.

Ejemplos

Ejemplo #1 Ejemplo de $GLOBALS

<?php
function test() {
    $foo = "variable local";

    echo '$foo en el ámbito global: ' . $GLOBALS["foo"] . "\n";
    echo '$foo en el ámbito simple: ' . $foo . "\n";
}

$foo = "Contenido de ejemplo";
test();
?>

El resultado del ejemplo sería algo similar a:

$foo en el ámbito global: Contenido de ejemplo
$foo en el ámbito simple: variable local

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Nota: Disponibilidad de las variables

A diferencia de todas las otras superglobals, $GLOBALS ha estado esencialmente siempre disponible en PHP.


Información del entorno del servidor y de ejecución

  • « $GLOBALS
  • $_GET »
  • PHP Manual
  • Variables predefinidas
  • Información del entorno del servidor y de ejecución

$_SERVER

$HTTP_SERVER_VARS [eliminado]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_SERVER -- $HTTP_SERVER_VARS [eliminado] — Información del entorno del servidor y de ejecución

Descripción

$_SERVER es un array que contiene información, tales como cabeceras, rutas y ubicaciones de script. Las entradas de este array son creadas por el servidor web. No hay garantía que cada servidor web proporcione alguna de estas entradas, existen servidores que pueden omitir algunas o proporcionar otras no recogidas aquí. Un gran número de estas variables se encuentran recogidas en » especificación CGI 1.1, así que al menos debe esperar encontrar estas entradas.

Nota: Antes de PHP 5.4.0, $HTTP_SERVER_VARS contenía la misma información inicial, aunque no era una superglobal. (Observe que $HTTP_SERVER_VARS y $_SERVER eran variables diferentes, por lo que PHP las trata de forma distinta).

Índices

Puede encontrar o no los siguientes elementos en $_SERVER. Tenga en cuenta que si ejecuta PHP desde línea de comando pocos o ninguno de los siguientes elementos estarán disponibles (o tendrán algún significado).

'PHP_SELF'
El nombre del archivo de script ejecutándose actualmente, relativa al directorio raíz de documentos del servidor. Por ejemplo, el valor de $_SERVER['PHP_SELF'] en un script ejecutado en la dirección http://example.com/foo/bar.php será /foo/bar.php. La constante __FILE__ contiene la ruta completa del fichero actual, incluyendo el nombre del archivo. Si PHP se está ejecutando como un proceso de línea de comando, esta variable es el nombre del script desde PHP 4.3.0. En anteriores versiones no estaba disponible.
'argv'
Array de los argumentos enviados al script. Cuando se ejecuta el script en línea de comando se obtiene acceso a los parámetros de línea de comando con un estilo parecido a como sería en C. Cuando se ejecuta el script mediante el método GET, contendrá la cadena de la consulta.
'argc'
Contiene el número de parámetros de línea de comando enviados al script (si se ejecuta en línea de comando).
'GATEWAY_INTERFACE'
Número de revisión de la especificación CGI que está empleando el servidor, por ejemplo 'CGI/1.1'.
'SERVER_ADDR'
La dirección IP del servidor donde se está ejecutando actualmente el script.
'SERVER_NAME'
El nombre del host del servidor donde se está ejecutando actualmente el script. Si el script se ejecuta en un host virtual se obtendrá el valor del nombre definido para dicho host virtual.

Nota: Bajo Apache 2, se debe establecer UseCanonicalName = On y ServerName. De lo contrario, este valor refleja el nombre del host proporcionado por el cliente, el cual se puede burlar. No es seguro depender de este valor en contextos que necesiten seguridad.

'SERVER_SOFTWARE'
Cadena de identificación del servidor dada en las cabeceras de respuesta a las peticiones.
'SERVER_PROTOCOL'
Nombre y número de revisión del protocolo de información a través del cual la página es solicitada, por ejemplo 'HTTP/1.0'.
'REQUEST_METHOD'
Método de petición empleado para acceder a la página, por ejemplo 'GET', 'HEAD', 'POST', 'PUT'.

Nota:

El script de PHP se considera terminado después de enviar las cabeceras (es decir después de producir cualquier resultado sin emplear buffers para el resultado) si el método de la petición empleado era HEAD.

'REQUEST_TIME'
Fecha Unix de inicio de la petición. Disponible desde PHP 5.1.0.
'REQUEST_TIME_FLOAT'
El timestamp del inicio de la solicitud, con precisión microsegundo. Disponible desde PHP 5.4.0.
'QUERY_STRING'
Si existe, la cadena de la consulta de la petición de la página.
'DOCUMENT_ROOT'
El directorio raíz de documentos del servidor en el cual se está ejecutando el script actual, según está definida en el archivo de configuración del servidor.
'HTTP_ACCEPT'
Contenido de la cabecera Accept: de la petición actual, si existe.
'HTTP_ACCEPT_CHARSET'
Contenido de la cabecera Accept-Charset: de la petición actual, si existe. Por ejemplo: 'iso-8859-1,*,utf-8'.
'HTTP_ACCEPT_ENCODING'
Contenido de la cabecera Accept-Encoding: de la petición actual, si existe. Por ejemplo: 'gzip'.
'HTTP_ACCEPT_LANGUAGE'
Contenido de la cabecera Accept-Language: de la petición actual, si existe. Por ejemplo: 'en'.
'HTTP_CONNECTION'
Contenido de la cabecera Connection: de la petición actual, si existe. Por ejemplo: 'Keep-Alive'.
'HTTP_HOST'
Contenido de la cabecera Host: de la petición actual, si existe.
'HTTP_REFERER'
Dirección de la pagina (si la hay) que emplea el agente de usuario para la pagina actual. Es definido por el agente de usuario. No todos los agentes de usuarios lo definen y algunos permiten modificar HTTP_REFERER como parte de su funcionalidad. En resumen, es un valor del que no se puede confiar realmente.
'HTTP_USER_AGENT'
Contenido de la cabecera User-Agent: de la petición actual, si existe. Consiste en una cadena que indica el agente de usuario empleado para acceder a la pagina. Un ejemplo típico es: Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586). Entre otras opciones, puede emplear dicho valor con get_browser() para personalizar el resultado de la salida de la página en función de las capacidades del agente de usuario empleado.
'HTTPS'
Ofrece un valor no vacío si el script es pedido mediante el protocolo HTTPS.

Nota: Tenga en cuenta que si se emplea ISAPI con IIS el valor será off si la petición no se ha realizado a través del protocolo HTTPS.

'REMOTE_ADDR'
La dirección IP desde la cual está viendo la página actual el usuario.
'REMOTE_HOST'
El nombre del host desde el cual está viendo la página actual el usuario. La obtención inversa del dns está basada en la REMOTE_ADDR del usuario.

Nota: Su servidor web debe estar configurado para crear esta variable. Por ejemplo en Apache necesita que exista HostnameLookups On dentro de httpd.conf. Consulte tambien gethostbyaddr().

'REMOTE_PORT'
El puerto empleado por la máquina del usuario para comunicarse con el servidor web.
'REMOTE_USER'
El usuario autenticado.
'REDIRECT_REMOTE_USER'
El usuario autenticado si la petición es redirigida internamente.
'SCRIPT_FILENAME'

La ruta del script ejecutándose actualmente en forma absoluta.

Nota:

Si un script se ejecuta mediante CLI como ruta relativa, como por ejemplo file.php o ../file.php, entonces $_SERVER['SCRIPT_FILENAME'] contendrá la ruta relativa especificada por el usuario.

'SERVER_ADMIN'
El valor dado a la directiva SERVER_ADMIN (de Apache) en el archivo de configuración del servidor web. Si el script se está ejecutando en un host virtual, el valor dado será el definido para dicho host virtual.
'SERVER_PORT'
El puerto de la máquina del servidor usado por el servidor web para la comunicación. Para las configuraciones por omisión, el valor será '80'; el empleo de SSL, por ejemplo, cambiará dicho valor al valor definido para el puerto HTTP seguro.

Nota: Bajo Apache 2, se debe establecer UseCanonicalName = On, así como UseCanonicalPhysicalPort = On para poder obtener el puerto físico (real), de otro modo, este valor podría ser burlado y podría o no devolver el valor del puerto físico. No es seguro confiar en este valor en contextos que requieran seguridad.

'SERVER_SIGNATURE'
Cadena que contiene la versión del servidor y el nombre del host virtual que son añadidas a las páginas generadas por el servidor, si esta habilitada esta funcionalidad.
'PATH_TRANSLATED'
Ruta de acceso basada en el sistema (no en el directorio raíz de documentos del servidor) del script actual, después de cualquier mapeo de virtual a real realizada por el servidor.

Nota: A partir de PHP 4.3.2, PATH_TRANSLATED no está definida de forma implícita en el SAPI de Apache 2, en comparación a la situación de Apache 1, donde era necesario establecer el mismo valor que la variable del servidor SCRIPT_FILENAME cuando no era proporcionada por Apache. Este cambio ha sido realizado para cumplir la especificación CGI donde PATH_TRANSLATED sólo debe existir si PATH_INFO esta definida. Los usuarios de Apache 2 pueden emplear AcceptPathInfo = On dentro de httpd.conf para definir PATH_INFO.

'SCRIPT_NAME'
Contiene la ruta del script actual. Esto es de utilidad para las páginas que necesiten apuntarse a si mismas. La constante __FILE__ contiene la ruta absoluta y el nombre del archivo actual incluido.
'REQUEST_URI'
La URI que se empleó para acceder a la página. Por ejemplo: '/index.html'.
'PHP_AUTH_DIGEST'
Cuando se hace autenticación Digest HTTP, esta variable se establece para el encabezado 'Authorization' enviado por el cliente (el cual se debe entonces usar para hacer la validación apropiada).
'PHP_AUTH_USER'
Cuando se hace autenticación HTTP, esta variable se establece para el nombre de usuario provisto por el usuario.
'PHP_AUTH_PW'
Cuando se hace autenticación HTTP, esta variable se establece para la clave provista por el usuario.
'AUTH_TYPE'
Cuando se realiza la autenticación HTTP, está variable se establece para el tipo de autenticación.
'PATH_INFO'
Contiene cualquier información sobre la ruta proporcionada por el cliente a continuación del nombre del fichero del script actual pero antecediendo a la cadena de la petición, si existe. Por ejemplo, si el script actual se accede a través de la URL http://www.example.com/php/path_info.php/some/stuff?foo=bar, entonces $_SERVER['PATH_INFO'] contendrá /some/stuff.
'ORIG_PATH_INFO'
Versión original de 'PATH_INFO' antes de ser procesado por PHP.

Historial de cambios

Versión | Descripción
5.4.0 | $HTTP_SERVER_VARS ya no está disponible debido a la eliminación de arrays grandes de registro.
5.3.0 | La directiva register_long_arrays, la cual hacía que estuviera disponible $HTTP_SERVER_VARS está obsoleta.

Ejemplos

Ejemplo #1 Ejemplo de $_SERVER

<?php
echo $_SERVER['SERVER_NAME'];
?>

El resultado del ejemplo sería algo similar a:

www.example.com

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • Filtrado de datos


Variables HTTP GET

  • « $_SERVER
  • $_POST »
  • PHP Manual
  • Variables predefinidas
  • Variables HTTP GET

$_GET

$HTTP_GET_VARS [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_GET -- $HTTP_GET_VARS [obsoleta] — Variables HTTP GET

Descripción

Un array asociativo de variables pasado al script actual vía parámetros URL (también conocida como cadena de consulta). Tenga en cuenta que el array no solo se rellena para las solicitudes GET, sino para todas las solicitudes con una cadena de consulta.

$HTTP_GET_VARS contiene la misma información, pero no es una superglobal. (Note que $HTTP_GET_VARS y $_GET son diferentes variables y que PHP los usa de forma diferente)

Ejemplos

Ejemplo #1 Ejemplo de $_GET

<?php
echo '¡Hola ' . htmlspecialchars($_GET["nombre"]) . '!';
?>

Asumiendo que el usuario introdujo http://example.com/?nombre=Hannes

El resultado del ejemplo sería algo similar a:

¡Hola Hannes!

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Nota:

Las variables GET son pasadas vía urldecode().

Ver también

  • Manejo de variables externas
  • La extensión filter


Variables POST de HTTP

  • « $_GET
  • $_FILES »
  • PHP Manual
  • Variables predefinidas
  • Variables POST de HTTP

$_POST

$HTTP_POST_VARS [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_POST -- $HTTP_POST_VARS [obsoleta] — Variables POST de HTTP

Descripción

Un array asociativo de variables pasadas al script actual a través del método POST de HTTP cuando se emplea application/x-www-form-urlencoded o multipart/form-data como Content-Type de HTTP en la petición.

$HTTP_POST_VARS contiene la misma información inicial, aunque no es una superglobal. (Observe que $HTTP_POST_VARS y $_POST son variables diferentes, por lo que PHP las trata de forma distinta).

Ejemplos

Ejemplo #1 Ejemplo de $_POST

<?php
echo '¡Hola ' . htmlspecialchars($_POST["nombre"]) . '!';
?>

Asumiendo que el usuario envió por el método POST nombre=Juan

El resultado del ejemplo sería algo similar a:

¡Hola Juan!

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • Manejo de variables externas
  • La extensión filter


Variables de subida de ficheros HTTP

  • « $_POST
  • $_REQUEST »
  • PHP Manual
  • Variables predefinidas
  • Variables de subida de ficheros HTTP

$_FILES

$HTTP_POST_FILES [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_FILES -- $HTTP_POST_FILES [obsoleta] — Variables de subida de ficheros HTTP

Descripción

Un array asociativo de elementos subidos al script en curso a través del método POST. La estructura de este array se resume en la sección Subidas con el método POST.

$HTTP_POST_FILES contiene la misma información inicial, pero no es superglobal. (Observe que $HTTP_POST_FILES y $_FILES son variables diferentes y que PHP las trata como tal).

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • move_uploaded_file() - Mueve un archivo subido a una nueva ubicación
  • Manejo de subida de ficheros


Variables HTTP Request

  • « $_FILES
  • $_SESSION »
  • PHP Manual
  • Variables predefinidas
  • Variables HTTP Request

$_REQUEST

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_REQUEST — Variables HTTP Request

Descripción

Un array asociativo que por defecto contiene el contenido de $_GET, $_POST y $_COOKIE.

Historial de cambios

Versión | Descripción
5.3.0 | Se introdujo request_order. Esta directiva afecta al contenido de $_REQUEST.

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Nota:

Cuando se ejecuta en la línea de comandos , no se incluirán las entradas argv y argc; ya que están presentes en el array $_SERVER

Nota:

Las variables en $_REQUEST se proporcionan al script a través de los mecanismos de entrada GET, POST, y COOKIE y por lo tanto pueden ser manipulados por el usuario remoto y no debe confiar en el contenido. La presencia y el orden de las variables listadas en este array se definen según la directiva de configuración PHP variables_order.

Ver también

  • import_request_variables()
  • Tratando con variables externas
  • La extensión filter


Variables de sesión

  • « $_REQUEST
  • $_ENV »
  • PHP Manual
  • Variables predefinidas
  • Variables de sesión

$_SESSION

$HTTP_SESSION_VARS [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_SESSION -- $HTTP_SESSION_VARS [obsoleta] — Variables de sesión

Descripción

Es un array asociativo que contiene variables de sesión disponibles para el script actual. Ver la documentación de Funciones de sesión para más información sobre su uso.

$HTTP_SESSION_VARS contiene la misma información inicial pero no es una superglobal. (Nótese que $HTTP_SESSION_VARS y $_SESSION son diferentes variables y PHP las trata de forma distinta)

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • session_start() - Iniciar una nueva sesión o reanudar la existente


Variables de entorno

  • « $_SESSION
  • $_COOKIE »
  • PHP Manual
  • Variables predefinidas
  • Variables de entorno

$_ENV

$HTTP_ENV_VARS [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_ENV -- $HTTP_ENV_VARS [obsoleta] — Variables de entorno

Descripción

Una variable tipo array asociativo de variables pasadas al script actual a través del método del entorno.

Estas variables son importadas en el espacio de nombres global de PHP desde el entorno bajo el que está siendo ejecutado el intérprete PHP. Muchas son entregadas por el intérprete de comandos bajo el que PHP está corriendo y diferentes sistemas suelen tener diferentes tipos de intérpretes de comandos, una lista definitiva es imposible. Por favor consulte la documentación de su intérprete de comandos para una lista de las variables de entorno que se definen.

Otras variables de entorno incluyen las variables CGI, colocadas allí independientemente de que PHP esté siendo ejecutado como módulo del servidor o procesador CGI.

$HTTP_ENV_VARS contiene la misma información inicial, pero no es una superglobal. (Note que $HTTP_ENV_VARS y $_ENV son variables diferentes y que PHP las trata como tal)

Ejemplos

Ejemplo #1 Ejemplo de $_ENV

<?php
echo '¡Mi nombre de usuario es ' . $_ENV["USER"] . '!';
?>

Asumiendo que "bjori" ejecuta este script

El resultado del ejemplo sería algo similar a:

¡Mi nombre de usuario es bjori!

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • getenv() - Obtiene el valor de una variable de entorno
  • La extensión filter


Cookies HTTP

  • « $_ENV
  • $php_errormsg »
  • PHP Manual
  • Variables predefinidas
  • Cookies HTTP

$_COOKIE

$HTTP_COOKIE_VARS [obsoleta]

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

$_COOKIE -- $HTTP_COOKIE_VARS [obsoleta] — Cookies HTTP

Descripción

Una variable tipo array asociativo de variables pasadas al script actual a través de Cookies HTTP.

$HTTP_COOKIE_VARS contiene la misma información inicial, pero no es una superglobal. (Note que $HTTP_COOKIE_VARS y $_COOKIE son variables diferentes y que PHP las trata como tal)

Ejemplos

Ejemplo #1 Ejemplo de $_COOKIE

<?php
echo '¡Hola ' . htmlspecialchars($_COOKIE["nombre"]) . '!';
?>

Asumiendo que la cookie "nombre" ha sido definida anteriormente

El resultado del ejemplo sería algo similar a:

¡Hola Juan!

Notas

Nota:

Esta es una 'superglobal' o una variable automatic global. Significa simplemente que es una variable que está disponible en cualquier parte del script. No hace falta hacer global $variable; para acceder a la misma desde funciones o métodos.

Ver también

  • setcookie() - Enviar una cookie
  • Gestión de variables externas
  • La extensión filter


El mensaje de error anterior

  • « $_COOKIE
  • $http_response_header »
  • PHP Manual
  • Variables predefinidas
  • El mensaje de error anterior

$php_errormsg

(PHP 4, PHP 5, PHP 7)

$php_errormsg — El mensaje de error anterior

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Utilice error_get_last() en su lugar.

Descripción

$php_errormsg es una variable que contiene el texto del último mensaje de error generado por PHP. Esta variable solo estará disponible dentro del ámbito donde ocurrió el error, y solamente funcionará si la opción de configuración track_errors está activada (por defecto está desactivada).

Advertencia

Si está definido un manejador de errores (set_error_handler()), $php_errormsg estará establecido solamente si el manejador de errores devuelve false

Ejemplos

Ejemplo #1 Ejemplo de $php_errormsg

<?php
@strpos();
echo $php_errormsg;
?>

El resultado del ejemplo sería algo similar a:

Wrong parameter count for strpos()

Ver también

  • error_get_last() - Obtener el último error que ocurrió


Encabezados de respuesta HTTP

  • « $php_errormsg
  • $argc »
  • PHP Manual
  • Variables predefinidas
  • Encabezados de respuesta HTTP

$http_response_header

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

$http_response_header — Encabezados de respuesta HTTP

Descripción

El array $http_response_header es similar a la functión get_headers(). Cuando se hace uso de HTTP wrapper, $http_response_header será poblado con los encabezados de respuesta HTTP. $http_response_header será creada en el ámbito local.

Ejemplos

Ejemplo #1 Ejemplo de $http_response_header

<?php
function get_contents() {
  file_get_contents("http://example.com");
  var_dump($http_response_header);
}
get_contents();
var_dump($http_response_header);
?>

El resultado del ejemplo sería algo similar a:

array(9) {
  [0]=>
  string(15) "HTTP/1.1 200 OK"
  [1]=>
  string(35) "Date: Sat, 12 Apr 2008 17:30:38 GMT"
  [2]=>
  string(29) "Server: Apache/2.2.3 (CentOS)"
  [3]=>
  string(44) "Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT"
  [4]=>
  string(27) "ETag: "280100-1b6-80bfd280""
  [5]=>
  string(20) "Accept-Ranges: bytes"
  [6]=>
  string(19) "Content-Length: 438"
  [7]=>
  string(17) "Connection: close"
  [8]=>
  string(38) "Content-Type: text/html; CHARSET=Windows-1252"
}
NULL


El número de argumentos pasados a un script

  • « $http_response_header
  • $argv »
  • PHP Manual
  • Variables predefinidas
  • El número de argumentos pasados a un script

$argc

(PHP 4, PHP 5, PHP 7, PHP 8)

$argc — El número de argumentos pasados a un script

Descripción

Contiene el número de argumentos pasados al script actual cuando se ejecuta desde la línea de comandos.

Nota: El nombre del script es pasado siempre como argumento del script, por lo tanto, el valor mínimo de $argc es 1.

Nota: Esta variable sólo está disponible cuando register_argc_argv está activado.

Ejemplos

Ejemplo #1 Ejemplo de $argc

<?php
var_dump($argc);
?>

Cuando se ejecuta el ejemplo con: php script.php arg1 arg2 arg3

El resultado del ejemplo sería algo similar a:

int(4)

Notas

Nota:

Esto también está disponible como $_SERVER['argc'].

Ver también

  • getopt() - Obtiene las opciones de la lista de argumentos de la línea de comandos


Array de argumentos pasados a un script

  • « $argc
  • Excepciones predefinidas »
  • PHP Manual
  • Variables predefinidas
  • Array de argumentos pasados a un script

$argv

(PHP 4, PHP 5, PHP 7, PHP 8)

$argv — Array de argumentos pasados a un script

Descripción

Contiene un array de todos los argumentos pasados a un script cuando se ejecuta desde la línea de comandos.

Nota: El primer argumento $argv[0] siempre es el nombre del fichero que fue usado para ejecutar el script.

Nota: Esta variable no está disponible si register_argc_argv está deshabilitado.

Ejemplos

Ejemplo #1 Ejemplo de $argv

<?php
var_dump($argv);
?>

Cuando se ejecuta el ejemplo con: php script.php arg1 arg2 arg3

El resultado del ejemplo sería algo similar a:

array(4) {
  [0]=>
  string(10) "script.php"
  [1]=>
  string(4) "arg1"
  [2]=>
  string(4) "arg2"
  [3]=>
  string(4) "arg3"
}

Notas

Nota:

Esto también está disponible como $_SERVER['argv'].

Ver también

  • getopt() - Obtiene las opciones de la lista de argumentos de la línea de comandos


Excepciones predefinidas

Tabla de contenidos

  • Exception
  • ErrorException
  • Error
  • ArgumentCountError
  • ArithmeticError
  • AssertionError
  • DivisionByZeroError
  • CompileError
  • ParseError
  • TypeError

Véanse también las Excepciones de la SPL


Exception

(PHP 5, PHP 7, PHP 8)

Introducción

Exception es la clase base para todas las excepciones en PHP 5, y la clase base para todas las excepciones de usuario en PHP 7.

Antes de PHP 7, Exception no implementa la interfaz Throwable.

Sinopsis de la Clase

Exception implements Throwable {
/* Propiedades */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public __construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public getMessage ( ) : string
final public getPrevious ( ) : Throwable
final public getCode ( ) : mixed
final public getFile ( ) : string
final public getLine ( ) : int
final public getTrace ( ) : array
final public getTraceAsString ( ) : string
public __toString ( ) : string
final private __clone ( ) : void
}

Propiedades

message

El mensaje de la excepción

code

El código de la excepción

file

El nombre del fichero donde se originó la excepción

line

La línea donde se originó la excepción

Tabla de contenidos

  • Exception::__construct — Constructor de la excepción
  • Exception::getMessage — Obtiene el mensaje de Excepción
  • Exception::getPrevious — Devuelve la excepción anterior
  • Exception::getCode — Obtiene el código de una excepción
  • Exception::getFile — Obtiene el fichero en el que se creó la excepción
  • Exception::getLine — Obtiene la línea en el que se creó la excepción
  • Exception::getTrace — Obtiene la traza de la pila
  • Exception::getTraceAsString — Obtiene la traza de la pila como una cadena de caracteres
  • Exception::__toString — Representación de la excepción en formato cadena
  • Exception::__clone — Clona la excepción


Constructor de la excepción

  • « Exception
  • Exception::getMessage »
  • PHP Manual
  • Exception
  • Constructor de la excepción

Exception::__construct

(PHP 5, PHP 7, PHP 8)

Exception::__construct — Constructor de la excepción

Descripción

public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )

Construye el objeto Exception.

Parámetros

message

Mensaje de la excepción a lanzar.

code

El código de la excepción.

previous

La excepción previa utilizada por la serie de excepciones.

Nota: Llamar al constructor de la clase Exception de una subclase ignora los argumentos por omisión, si las propiedades $code y $message ya están establecidas.

Historial de cambios

Versión | Descripción
7.0.0 | El parámetro previous ahora es del tipo Throwable.
5.3.0 | Se añadió el parámetro previous.

Notas

Nota:

message NO es seguro binariamente.


Obtiene el mensaje de Excepción

  • « Exception::__construct
  • Exception::getPrevious »
  • PHP Manual
  • Exception
  • Obtiene el mensaje de Excepción

Exception::getMessage

(PHP 5, PHP 7, PHP 8)

Exception::getMessage — Obtiene el mensaje de Excepción

Descripción

final public Exception::getMessage ( ) : string

Devuelve el mensaje de Excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el mensaje de Excepción en formato cadena.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getMessage()

<?php
try {
    throw new Exception("Algún mensaje de error");
} catch(Exception $e) {
    echo $e->getMessage();
}
?>

El resultado del ejemplo sería algo similar a:

Algún mensaje de error

Ver también

  • Throwable::getMessage() - Obtiene el mensaje


Devuelve la excepción anterior

  • « Exception::getMessage
  • Exception::getCode »
  • PHP Manual
  • Exception
  • Devuelve la excepción anterior

Exception::getPrevious

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Exception::getPrevious — Devuelve la excepción anterior

Descripción

final public Exception::getPrevious ( ) : Throwable

Devuelve la excepción anterior (el tercer parámetro de Exception::__construct()).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la Throwable anterior si está disponible o null si no.

Historial de cambios

Versión | Descripción
7.0.0 | La declaración de tipo de retorno cambió a Throwable.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getPrevious()

Recorrer, e imprimir la traza de una excepción.

<?php
class MiPropiaExcepción extends Exception {}

function hacerCosas() {
    try {
        throw new InvalidArgumentException("¡Lo está haciendo mal!", 112);
    } catch(Exception $e) {
        throw new MiPropiaExcepción("Ocurrió algo", 911, $e);
    }
}

try {
    hacerCosas();
} catch(Exception $e) {
    do {
        printf("%s:%d %s (%d) [%s]\n", $e->getFile(), $e->getLine(), $e->getMessage(), $e->getCode(), get_class($e));
    } while($e = $e->getPrevious());
}
?>

El resultado del ejemplo sería algo similar a:

/home/bjori/ex.php:8 Ocurrió algo (911) [MiPropiaExcepción]
/home/bjori/ex.php:6 ¡Lo está haciendo mal! (112) [InvalidArgumentException]

Ver también

  • Throwable::getPrevious() - Devuelve el objeto Throwable previo


Obtiene el código de una excepción

  • « Exception::getPrevious
  • Exception::getFile »
  • PHP Manual
  • Exception
  • Obtiene el código de una excepción

Exception::getCode

(PHP 5, PHP 7, PHP 8)

Exception::getCode — Obtiene el código de una excepción

Descripción

final public Exception::getCode ( ) : mixed

Devuelve el código de una excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el código de Excepción en forma de integer en Exception pero posiblemente en forma de otros tipos en Exception descendientes (por ejemplo como string en PDOException).

Ejemplos

Ejemplo #1 Ejemplo de Exception::getCode()

<?php
try {
    throw new Exception("Un mensaje de error", 30);
} catch(Exception $e) {
    echo "El código de excepción es: " . $e->getCode();
}
?>

El resultado del ejemplo sería algo similar a:

El código de excepción es: 30

Ver también

  • Throwable::getCode() - Obtener el código de la excepción


Obtiene el fichero en el que se creó la excepción

  • « Exception::getCode
  • Exception::getLine »
  • PHP Manual
  • Exception
  • Obtiene el fichero en el que se creó la excepción

Exception::getFile

(PHP 5, PHP 7, PHP 8)

Exception::getFile — Obtiene el fichero en el que se creó la excepción

Descripción

final public Exception::getFile ( ) : string

Obtiene el nombre del fichero en el que fue creada la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero en donde fue creada la excepción.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getFile()

<?php
try {
    throw new Exception;
} catch(Exception $e) {
    echo $e->getFile();
}
?>

El resultado del ejemplo sería algo similar a:

/home/bjori/tmp/ex.php

Ver también

  • Throwable::getFile() - Obtiene el fichero en el que se creó el objeto


Obtiene la línea en el que se creó la excepción

  • « Exception::getFile
  • Exception::getTrace »
  • PHP Manual
  • Exception
  • Obtiene la línea en el que se creó la excepción

Exception::getLine

(PHP 5, PHP 7, PHP 8)

Exception::getLine — Obtiene la línea en el que se creó la excepción

Descripción

final public Exception::getLine ( ) : int

Devuelve el número de la línea donde se creó la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de la línea donde se creó la excepción.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getLine()

<?php
try {
    throw new Exception("Algún mensaje de error");
} catch(Exception $e) {
    echo "La excepción se creó en la línea: " . $e->getLine();
}
?>

El resultado del ejemplo sería algo similar a:

La excepción se creó en la línea: 3

Ver también

  • Throwable::getLine() - Obtiene la línea en la que el objeto fue instanciado


Obtiene la traza de la pila

  • « Exception::getLine
  • Exception::getTraceAsString »
  • PHP Manual
  • Exception
  • Obtiene la traza de la pila

Exception::getTrace

(PHP 5, PHP 7, PHP 8)

Exception::getTrace — Obtiene la traza de la pila

Descripción

final public Exception::getTrace ( ) : array

Devuelve la traza de pila de una excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el seguimiento de pila de una excepción como un array.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getTrace()

<?php
function test() {
 throw new Exception;
}

try {
 test();
} catch(Exception $e) {
 var_dump($e->getTrace());
}
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  array(4) {
    ["file"]=>
    string(22) "/home/bjori/tmp/ex.php"
    ["line"]=>
    int(7)
    ["function"]=>
    string(4) "test"
    ["args"]=>
    array(0) {
    }
  }
}

Ver también

  • Throwable::getTrace() - Obtener la traza de la pila


Obtiene la traza de la pila como una cadena de caracteres

  • « Exception::getTrace
  • Exception::__toString »
  • PHP Manual
  • Exception
  • Obtiene la traza de la pila como una cadena de caracteres

Exception::getTraceAsString

(PHP 5, PHP 7, PHP 8)

Exception::getTraceAsString — Obtiene la traza de la pila como una cadena de caracteres

Descripción

final public Exception::getTraceAsString ( ) : string

Devuelve la traza de la pila de una excepción como una cadena de caracteres.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Exception stack trace as a string.

Ejemplos

Ejemplo #1 Ejemplo de Exception::getTraceAsString()

<?php
function test() {
    throw new Exception;
}

try {
    test();
} catch(Exception $e) {
    echo $e->getTraceAsString();
}
?>

El resultado del ejemplo sería algo similar a:

#0 /home/bjori/tmp/ex.php(7): test()
#1 {main}

Ver también

  • Throwable::getTraceAsString() - Obtener la traza de la pila como un string


Representación de la excepción en formato cadena

  • « Exception::getTraceAsString
  • Exception::__clone »
  • PHP Manual
  • Exception
  • Representación de la excepción en formato cadena

Exception::__toString

(PHP 5, PHP 7, PHP 8)

Exception::__toString — Representación de la excepción en formato cadena

Descripción

public Exception::__toString ( ) : string

Devuelve la representación de la excepción en formato string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación de la excepción en formato string.

Ejemplos

Ejemplo #1 Ejemplo de Exception::__toString()

<?php
try {
    throw new Exception("Some error message");
} catch(Exception $e) {
    echo $e;
}
?>

El resultado del ejemplo sería algo similar a:

exception 'Exception' with message 'Some error message' in /home/bjori/tmp/ex.php:3
Stack trace:
#0 {main}

Ver también

  • Throwable::__toString() - Obtiene un representación de string del objeto lanzado


Clona la excepción

  • « Exception::__toString
  • ErrorException »
  • PHP Manual
  • Exception
  • Clona la excepción

Exception::__clone

(PHP 5, PHP 7, PHP 8)

Exception::__clone — Clona la excepción

Descripción

final private Exception::__clone ( ) : void

Intenta clonar la Excepción, lo que resultará en un error Fatal.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Las Excepciones no se pueden clonar.


ErrorException

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Introducción

Una excepción de error.

Sinopsis de la Clase

ErrorException extends Exception {
/* Propiedades */
protected int $severity ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public __construct ( string $message = "" , int $code = 0 , int $severity = E_ERROR , string $filename = __FILE__ , int $lineno = __LINE__ , Exception $previous = null )
final public getSeverity ( ) : int
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

severity

La gravedad de la excepción

Ejemplos

Ejemplo #1 Utilizar set_error_handler() para convertir mensajes de error en objetos ErrorException.

<?php
function exception_error_handler($severidad, $mensaje, $fichero, $línea) {
    if (!(error_reporting() & $severidad)) {
        // Este código de error no está incluido en error_reporting
        return;
    }
    throw new ErrorException($mensaje, 0, $severidad, $fichero, $línea);
}
set_error_handler("exception_error_handler");

/* Desencadenar la excepción */
strpos();
?>

El resultado del ejemplo sería algo similar a:

Fatal error: Uncaught exception 'ErrorException' with message 'strpos() expects at least 2 parameters, 0 given' in /home/bjori/tmp/ex.php:12
Stack trace:
#0 [internal function]: exception_error_handler(2, 'strpos() expect...', '/home/bjori/php...', 12, Array)
#1 /home/bjori/php/cleandocs/test.php(12): strpos()
#2 {main}
  thrown in /home/bjori/tmp/ex.php on line 12

Tabla de contenidos

  • ErrorException::__construct — Constructor de la excepción
  • ErrorException::getSeverity — Obtiene la severidad de la excepción


Constructor de la excepción

  • « ErrorException
  • ErrorException::getSeverity »
  • PHP Manual
  • ErrorException
  • Constructor de la excepción

ErrorException::__construct

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

ErrorException::__construct — Constructor de la excepción

Descripción

public ErrorException::__construct ( string $message = "" , int $code = 0 , int $severity = E_ERROR , string $filename = __FILE__ , int $lineno = __LINE__ , Exception $previous = null )

Construye el objeto Exception.

Parámetros

message

Mensaje de la excepción a lanzar.

code

El código de la excepción.

severity

Nivel de la severidad de la excepción.

Nota:

Aunque la severidad puede ser cuaquier valor de tipo integer, se pretende que se empleen las constantes de error.

filename

Nombre del fichero donde se lanzó la excepción.

lineno

Número de la línea donde se produjo la excepción.

previous

La anterior excepción utilizada para la excepción de encadenamiento.

Historial de cambios

Versión | Descripción
5.3.0 | El parámetro previous fue añadido.


Obtiene la severidad de la excepción

  • « ErrorException::__construct
  • Error »
  • PHP Manual
  • ErrorException
  • Obtiene la severidad de la excepción

ErrorException::getSeverity

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

ErrorException::getSeverity — Obtiene la severidad de la excepción

Descripción

final public ErrorException::getSeverity ( ) : int

Devuelve la severidad de la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nivel de la severidad de la excepción.

Ejemplos

Ejemplo #1 Ejemplo de ErrorException::getSeverity()

<?php
try {
    throw new ErrorException("Mensaje de la excepción", 0, E_USER_ERROR);
} catch(ErrorException $e) {
    echo "La severidad de la excepción es: " . $e->getSeverity();
    var_dump($e->getSeverity() === E_USER_ERROR);
}
?>

El resultado del ejemplo sería algo similar a:

La severidad de la excepción es: 256
bool(true)


Error

(PHP 7, PHP 8)

Introducción

Error es la clase base para todos los errores de PHP internos.

Sinopsis de la Clase

Error implements Throwable {
/* Propiedades */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public __construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public getMessage ( ) : string
final public getPrevious ( ) : Throwable
final public getCode ( ) : mixed
final public getFile ( ) : string
final public getLine ( ) : int
final public getTrace ( ) : array
final public getTraceAsString ( ) : string
public __toString ( ) : string
final private __clone ( ) : void
}

Propiedades

message

El mensaje de error

code

El código de error

file

El nombre del fichero donde ocurrió el error

line

La línea donde ocurrió el error

Tabla de contenidos

  • Error::__construct — Construir el objeto error
  • Error::getMessage — Obtener el mensaje de error
  • Error::getPrevious — Devuelve el objeto Throwable anterior
  • Error::getCode — Obtener el código de error
  • Error::getFile — Obtener el fichero en el que ocurrío el error
  • Error::getLine — Obtener la línea en la que ocurrió el error
  • Error::getTrace — Obtener la traza de la pila
  • Error::getTraceAsString — Obtener la traza de la pila como un string
  • Error::__toString — Representación de string del error
  • Error::__clone — Clonar el error


Construir el objeto error

  • « Error
  • Error::getMessage »
  • PHP Manual
  • Error
  • Construir el objeto error

Error::__construct

(PHP 7, PHP 8)

Error::__construct — Construir el objeto error

Descripción

public Error::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )

Construye el Error.

Parámetros

message

El mensaje de error.

code

El código de error.

previous

El objeto Throwable anterior empleado para la cadena de excepciones.

Notas

Nota:

El parámetro message NO es seguro a nivel binario.


Obtener el mensaje de error

  • « Error::__construct
  • Error::getPrevious »
  • PHP Manual
  • Error
  • Obtener el mensaje de error

Error::getMessage

(PHP 7, PHP 8)

Error::getMessage — Obtener el mensaje de error

Descripción

final public Error::getMessage ( ) : string

Devuelve el mensaje de error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el mensaje de error como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de Error::getMessage()

<?php
try {
    throw new Error("Un mensaje de error");
} catch(Error $e) {
    echo $e->getMessage();
}
?>

El resultado del ejemplo sería algo similar a:

Un mensaje de error

Ver también

  • Throwable::getMessage() - Obtiene el mensaje


Devuelve el objeto Throwable anterior

  • « Error::getMessage
  • Error::getCode »
  • PHP Manual
  • Error
  • Devuelve el objeto Throwable anterior

Error::getPrevious

(PHP 7, PHP 8)

Error::getPrevious — Devuelve el objeto Throwable anterior

Descripción

final public Error::getPrevious ( ) : Throwable

Devuelve el objeto Throwable anterior (el tercer parámetro de Error::__construct()).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el objeto Throwable anterior si está disponible, o null en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de Error::getPrevious()

Recorrer e imprimir la traza de errores.

<?php
class MiErrorPersonalizado extends Error {}

function hacerCosas() {
    try {
        throw new InvalidArgumentError("¡Lo está haciendo mal!", 112);
    } catch(Error $e) {
        throw new MiErrorPersonalizado("Ocurrió algo", 911, $e);
    }
}

try {
    hacerCosas();
} catch(Error $e) {
    do {
        printf("%s:%d %s (%d) [%s]\n", $e->getFile(), $e->getLine(), $e->getMessage(), $e->getCode(), get_class($e));
    } while($e = $e->getPrevious());
}
?>

El resultado del ejemplo sería algo similar a:

/home/bjori/ex.php:8 Ocurrió algo (911) [MiErrorPersonalizado]
/home/bjori/ex.php:6 ¡Lo está haciendo mal! (112) [InvalidArgumentError]

Ver también

  • Throwable::getPrevious() - Devuelve el objeto Throwable previo


Obtener el código de error

  • « Error::getPrevious
  • Error::getFile »
  • PHP Manual
  • Error
  • Obtener el código de error

Error::getCode

(PHP 7, PHP 8)

Error::getCode — Obtener el código de error

Descripción

final public Error::getCode ( ) : mixed

Devuelve el código de error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el código de error como un integer

Ejemplos

Ejemplo #1 Ejemplo de Error::getCode()

<?php
try {
    throw new Error("Un mensaje de error", 30);
} catch(Error $e) {
    echo "El código del Error es: " . $e->getCode();
}
?>

El resultado del ejemplo sería algo similar a:

El código del Error es: 30

Ver también

  • Throwable::getCode() - Obtener el código de la excepción


Obtener el fichero en el que ocurrío el error

  • « Error::getCode
  • Error::getLine »
  • PHP Manual
  • Error
  • Obtener el fichero en el que ocurrío el error

Error::getFile

(PHP 7, PHP 8)

Error::getFile — Obtener el fichero en el que ocurrío el error

Descripción

final public Error::getFile ( ) : string

Obtiene el nombre del fichero donde ocurrió el error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero el en cual ocurrió el error.

Ejemplos

Ejemplo #1 Ejemplo de Error::getFile()

<?php
try {
    throw new Error;
} catch(Error $e) {
    echo $e->getFile();
}
?>

El resultado del ejemplo sería algo similar a:

/home/bjori/tmp/ex.php

Ver también

  • Throwable::getFile() - Obtiene el fichero en el que se creó el objeto


Obtener la línea en la que ocurrió el error

  • « Error::getFile
  • Error::getTrace »
  • PHP Manual
  • Error
  • Obtener la línea en la que ocurrió el error

Error::getLine

(PHP 7, PHP 8)

Error::getLine — Obtener la línea en la que ocurrió el error

Descripción

final public Error::getLine ( ) : int

Obtiene el número de línea donde ocurrió el error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de línea en la que ocurrió el error.

Ejemplos

Ejemplo #1 Ejemplo de Error::getLine()

<?php
try {
    throw new Error("Un mensaje de error");
} catch(Error $e) {
    echo "El error se ocasionó en la línea: " . $e->getLine();
}
?>

El resultado del ejemplo sería algo similar a:

El error se ocasionó en la línea: 3

Ver también

  • Throwable::getLine() - Obtiene la línea en la que el objeto fue instanciado


Obtener la traza de la pila

  • « Error::getLine
  • Error::getTraceAsString »
  • PHP Manual
  • Error
  • Obtener la traza de la pila

Error::getTrace

(PHP 7, PHP 8)

Error::getTrace — Obtener la traza de la pila

Descripción

final public Error::getTrace ( ) : array

Devuelve la traza de la pila.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la traza de la pila como un array.

Ejemplos

Ejemplo #1 Ejemplo de Error::getTrace()

<?php
function prueba() {
 throw new Error;
}

try {
 prueba();
} catch(Error $e) {
 var_dump($e->getTrace());
}
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  array(4) {
    ["file"]=>
    string(22) "/home/bjori/tmp/ex.php"
    ["line"]=>
    int(7)
    ["function"]=>
    string(6) "prueba"
    ["args"]=>
    array(0) {
    }
  }
}

Ver también

  • Throwable::getTrace() - Obtener la traza de la pila


Obtener la traza de la pila como un string

  • « Error::getTrace
  • Error::__toString »
  • PHP Manual
  • Error
  • Obtener la traza de la pila como un string

Error::getTraceAsString

(PHP 7, PHP 8)

Error::getTraceAsString — Obtener la traza de la pila como un string

Descripción

final public Error::getTraceAsString ( ) : string

Devuelve la traza de la pila como un string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la traza de la pila como un string.

Ejemplos

Ejemplo #1 Ejemplo de Error::getTraceAsString()

<?php
function prueba() {
    throw new Error;
}

try {
    prueba();
} catch(Error $e) {
    echo $e->getTraceAsString();
}
?>

El resultado del ejemplo sería algo similar a:

#0 /home/bjori/tmp/ex.php(7): prueba()
#1 {main}

Ver también

  • Throwable::getTraceAsString() - Obtener la traza de la pila como un string


Representación de string del error

  • « Error::getTraceAsString
  • Error::__clone »
  • PHP Manual
  • Error
  • Representación de string del error

Error::__toString

(PHP 7, PHP 8)

Error::__toString — Representación de string del error

Descripción

public Error::__toString ( ) : string

Devuelve la representación de string del error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación de string del error.

Ejemplos

Ejemplo #1 Ejemplo de Error::__toString()

<?php
try {
    throw new Error("Un mensaje de error");
} catch(Error $e) {
    echo $e;
}
?>

El resultado del ejemplo sería algo similar a:

Error: Un mensaje de error in /home/bjori/tmp/ex.php:3
Stack trace:
#0 {main}

Ver también

  • Throwable::__toString() - Obtiene un representación de string del objeto lanzado


Clonar el error

  • « Error::__toString
  • ArgumentCountError »
  • PHP Manual
  • Error
  • Clonar el error

Error::__clone

(PHP 7, PHP 8)

Error::__clone — Clonar el error

Descripción

final private Error::__clone ( ) : void

Un error no se pueden clonar, por lo que este método resulta en un error fatal.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Los errores no son clonabes.


ArgumentCountError

(PHP 7 >= PHP 7.1.0, PHP 8)

Introducción

ArgumentCountError es lanzado cuando muy pocos argumentos son pasados a una funcion o método definido por el usuario.

Sinopsis de la Clase

ArgumentCountError extends TypeError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


ArithmeticError

(PHP 7, PHP 8)

Introducción

Un ArithmeticError es lanzado cuando ocurre un error durante la realización de operaciones matemáticas. En PHP 7.0, estos errores incluyen el intento de realizar un desplazamiento de bit mediante una cantidad negativa, y cualquier llamada a intdiv() que resulte en un valor fuera de los límites posibles de un integer.

Sinopsis de la Clase

ArithmeticError extends Error {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


AssertionError

(PHP 7, PHP 8)

Introducción

Un AssertionError se lanza cuando falla una afirmación realizada mediante assert().

Sinopsis de la Clase

AssertionError extends Error {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


DivisionByZeroError

(PHP 7, PHP 8)

Introducción

Un DivisionByZeroError se lanza al intentar dividir un número por cero.

Sinopsis de la Clase

DivisionByZeroError extends ArithmeticError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


CompileError

(PHP 7 > 7.3.0, PHP 8)

Introducción

CompileError es lanzado por algunos errores de compilación, que anteriormente emitió un error fatal.

Sinopsis de la Clase

CompileError extends Error {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


ParseError

(PHP 7, PHP 8)

Introducción

Un ParseError se lanza cuando ocurre un error al analizar código de PHP, tal como cuando se llama a eval().

Nota: ParseError extiende CompileError a partir de PHP 7.3.0. Anteriormente, extendía Error.

Sinopsis de la Clase

ParseError extends CompileError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


TypeError

(PHP 7, PHP 8)

Introducción

Existen tres escenarios donde de podría lanzar un TypeError. El primero es donde el tipo de argumento pasado a una función no coincide con su correspondiente tipo de parámetro declarado. El segundo es donde un valor devuelto desde una función no coincide con el tipo de devolución declarado en la función. El tercero es donde se proporciona un número inválido de argumentos a una función interna de PHP (solamente en modo estricto).

Sinopsis de la Clase

TypeError extends Error {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


Interfaces y clases predefinidas

Tabla de contenidos

  • Traversable
  • Iterator
  • IteratorAggregate
  • Throwable
  • ArrayAccess
  • Serializable
  • Closure
  • Generator
  • WeakReference

Véanse también las interfaces de la SPL y las clases reservadas.


La interfaz Traversable

(PHP 5, PHP 7, PHP 8)

Introducción

Interfaz para detectar si una clase puede recorrerse mediante foreach.

Una interfaz abstracta base no puede ser implementada sola. En su lugar, debe ser implementada con IteratorAggregate o con Iterator.

Nota:

Las clases internas que implementan esta interfaz pueden ser usadas en una construcción foreach y no necesitan implementar IteratorAggregate o Iterator.

Nota:

Esta es una interfaz del motor interno que no puede ser implementada en scripts de PHP. Se debe emplear en su lugar o IteratorAggregate, o bien Iterator. Cuando se implementa una interfaz que extiende a Traversable, asegúrese de enumerar IteratorAggregate o Iterator antes de su nombre en la cláusula de implementación.

Sinopsis de la Interfaz

Traversable {
}

Esta interfaz no tiene métodos; su único propósito es servir de interfaz base para todas las clases que se pueden recorrer.


La interfaz Iterator

(PHP 5, PHP 7, PHP 8)

Introducción

Interfaz para iteradores externos u objetos que pueden ser iterados internamente por sí mismos.

Sinopsis de la Interfaz

Iterator extends Traversable {
/* Métodos */
abstract public current ( ) : mixed
abstract public key ( ) : scalar
abstract public next ( ) : void
abstract public rewind ( ) : void
abstract public valid ( ) : bool
}

Iteradores Predefinidos

PHP ya ofrece un número de iteradores para muchas de las tareas del día a día. Véase la lista de iteradores SPL.

Ejemplos

Ejemplo #1 Uso básico

Este ejemplo muestra el orden en el que se llaman a los métodos cuando se emplea un foreach con un iterator.

<?php
class myIterator implements Iterator {
    private $position = 0;
    private $array = array(
        "firstelement",
        "secondelement",
        "lastelement",
    );

    public function __construct() {
        $this->position = 0;
    }

     public function rewind() {
        var_dump(__METHOD__);
        $this->position = 0;
    }

    public function current() {
        var_dump(__METHOD__);
        return $this->array[$this->position];
    }

    public function key() {
        var_dump(__METHOD__);
        return $this->position;
    }

    public function next() {
        var_dump(__METHOD__);
        ++$this->position;
    }

    public function valid() {
        var_dump(__METHOD__);
        return isset($this->array[$this->position]);
    }
}

$it = new myIterator;

foreach($it as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

El resultado del ejemplo sería algo similar a:

string(18) "myIterator::rewind"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(0)
string(12) "firstelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(1)
string(13) "secondelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(2)
string(11) "lastelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"

Tabla de contenidos

  • Iterator::current — Devuelve el elemento actual
  • Iterator::key — Devuelve la clave del elemento actual
  • Iterator::next — Avanza al siguiente elemento
  • Iterator::rewind — Rebobine la Iterator al primer elemento
  • Iterator::valid — Comprueba si la posición actual es válido


Devuelve el elemento actual

  • « Iterator
  • Iterator::key »
  • PHP Manual
  • Iterator
  • Devuelve el elemento actual

Iterator::current

(PHP 5, PHP 7, PHP 8)

Iterator::current — Devuelve el elemento actual

Descripción

abstract public Iterator::current ( ) : mixed

Devuelve el elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Puede devolver cualquier tipo.


Devuelve la clave del elemento actual

  • « Iterator::current
  • Iterator::next »
  • PHP Manual
  • Iterator
  • Devuelve la clave del elemento actual

Iterator::key

(PHP 5, PHP 7, PHP 8)

Iterator::key — Devuelve la clave del elemento actual

Descripción

abstract public Iterator::key ( ) : scalar

Devuelve la clave del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve scalar en caso de éxito, o null en caso de error.

Errores/Excepciones

Muestra un E_NOTICE en caso de error.


Avanza al siguiente elemento

  • « Iterator::key
  • Iterator::rewind »
  • PHP Manual
  • Iterator
  • Avanza al siguiente elemento

Iterator::next

(PHP 5, PHP 7, PHP 8)

Iterator::next — Avanza al siguiente elemento

Descripción

abstract public Iterator::next ( ) : void

Avanza la posición actual al siguiente elemento.

Nota:

El método es llamado después de cada foreach loop.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor devuelto es ignorado.


Rebobine la Iterator al primer elemento

  • « Iterator::next
  • Iterator::valid »
  • PHP Manual
  • Iterator
  • Rebobine la Iterator al primer elemento

Iterator::rewind

(PHP 5, PHP 7, PHP 8)

Iterator::rewind — Rebobine la Iterator al primer elemento

Descripción

abstract public Iterator::rewind ( ) : void

Rebobina de nuevo al primer elemento de la Iterator.

Nota:

Este es el primer método llamado cuando se inicia un foreach bucle. No va a ser ejecutado despues foreach bucle.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Cualquier valor devuelto se pasa por alto.


Comprueba si la posición actual es válido

  • « Iterator::rewind
  • IteratorAggregate »
  • PHP Manual
  • Iterator
  • Comprueba si la posición actual es válido

Iterator::valid

(PHP 5, PHP 7, PHP 8)

Iterator::valid — Comprueba si la posición actual es válido

Descripción

abstract public Iterator::valid ( ) : bool

Este método se llama después de Iterator::rewind() y Iterator::next() para comprobar si la posición actual es válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de retorno se debe fundir a boolean y luego evaluar. Devuelve true en caso de éxito o false en caso de error.


La interfaz IteratorAggregate

(PHP 5, PHP 7, PHP 8)

Introducción

Para crear una interfaz externa Iterator.

Sinopsis de la Interfaz

IteratorAggregate extends Traversable {
/* Métodos */
abstract public getIterator ( ) : Traversable
}

Ejemplo #1 Uso básico

<?php
class myData implements IteratorAggregate {
    public $property1 = "Public property one";
    public $property2 = "Public property two";
    public $property3 = "Public property three";

    public function __construct() {
        $this->property4 = "last property";
    }

    public function getIterator() {
        return new ArrayIterator($this);
    }
}

$obj = new myData;

foreach($obj as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

El resultado del ejemplo sería algo similar a:

string(9) "property1"
string(19) "Public property one"

string(9) "property2"
string(19) "Public property two"

string(9) "property3"
string(21) "Public property three"

string(9) "property4"
string(13) "last property"

Tabla de contenidos

  • IteratorAggregate::getIterator — Recuperar un Iterator externo


Recuperar un Iterator externo

  • « IteratorAggregate
  • Throwable »
  • PHP Manual
  • IteratorAggregate
  • Recuperar un Iterator externo

IteratorAggregate::getIterator

(PHP 5, PHP 7, PHP 8)

IteratorAggregate::getIterator — Recuperar un Iterator externo

Descripción

abstract public IteratorAggregate::getIterator ( ) : Traversable

Devuelve un iterador externo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de un objeto que implementa Iterator o Traversable

Errores/Excepciones

Lanza una Exception en caso de fallo.


Throwable

(PHP 7, PHP 8)

Introducción

Throwable es la interfaz base para cualquier objeto que pueda ser lanzado mediante una sentencia throw en PHP 7, incluyendo Error y Exception.

Nota:

Las clases de PHP no pueden implementar la interfaz Throwable directamente, por lo que deben extender en su lugar Exception.

Sinopsis de la Interfaz

Throwable {
/* Métodos */
abstract public getMessage ( ) : string
abstract public getCode ( ) : int
abstract public getFile ( ) : string
abstract public getLine ( ) : int
abstract public getTrace ( ) : array
abstract public getTraceAsString ( ) : string
abstract public getPrevious ( ) : Throwable
abstract public __toString ( ) : string
}

Tabla de contenidos

  • Throwable::getMessage — Obtiene el mensaje
  • Throwable::getCode — Obtener el código de la excepción
  • Throwable::getFile — Obtiene el fichero en el que se creó el objeto
  • Throwable::getLine — Obtiene la línea en la que el objeto fue instanciado
  • Throwable::getTrace — Obtener la traza de la pila
  • Throwable::getTraceAsString — Obtener la traza de la pila como un string
  • Throwable::getPrevious — Devuelve el objeto Throwable previo
  • Throwable::__toString — Obtiene un representación de string del objeto lanzado


Obtiene el mensaje

  • « Throwable
  • Throwable::getCode »
  • PHP Manual
  • Throwable
  • Obtiene el mensaje

Throwable::getMessage

(PHP 7, PHP 8)

Throwable::getMessage — Obtiene el mensaje

Descripción

abstract public Throwable::getMessage ( ) : string

Devuelve el mensaje asociado al objeto lanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el mensaje asociado al objeto lanzado.

Ver también

  • Exception::getMessage() - Obtiene el mensaje de Excepción


Obtener el código de la excepción

  • « Throwable::getMessage
  • Throwable::getFile »
  • PHP Manual
  • Throwable
  • Obtener el código de la excepción

Throwable::getCode

(PHP 7, PHP 8)

Throwable::getCode — Obtener el código de la excepción

Descripción

abstract public Throwable::getCode ( ) : int

Devuelve el código de error asociado al objeto lanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el código de la excepción como un integer en Exception, aunque posiblemente como otro tipo en los descendientes de Exception (por ejemplo, como string en PDOException).

Ver también

  • Exception::getCode() - Obtiene el código de una excepción


Obtiene el fichero en el que se creó el objeto

  • « Throwable::getCode
  • Throwable::getLine »
  • PHP Manual
  • Throwable
  • Obtiene el fichero en el que se creó el objeto

Throwable::getFile

(PHP 7, PHP 8)

Throwable::getFile — Obtiene el fichero en el que se creó el objeto

Descripción

abstract public Throwable::getFile ( ) : string

Obtiene el nombre del fichero en el que se creó el objeto lanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero en el que se creó la el objeto lanzado.

Ver también

  • Exception::getFile() - Obtiene el fichero en el que se creó la excepción


Obtiene la línea en la que el objeto fue instanciado

  • « Throwable::getFile
  • Throwable::getTrace »
  • PHP Manual
  • Throwable
  • Obtiene la línea en la que el objeto fue instanciado

Throwable::getLine

(PHP 7, PHP 8)

Throwable::getLine — Obtiene la línea en la que el objeto fue instanciado

Descripción

abstract public Throwable::getLine ( ) : int

Devuelve el número de línea en la que el objeto fue instanciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de línea en la que el objeto fue instanciado.

Ver también

  • Exception::getLine() - Obtiene la línea en el que se creó la excepción


Obtener la traza de la pila

  • « Throwable::getLine
  • Throwable::getTraceAsString »
  • PHP Manual
  • Throwable
  • Obtener la traza de la pila

Throwable::getTrace

(PHP 7, PHP 8)

Throwable::getTrace — Obtener la traza de la pila

Descripción

abstract public Throwable::getTrace ( ) : array

Devuelve la traza de la pila como un array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la traza de la pila como un array con el mismo formato que en debug_backtrace().

Ver también

  • Exception::getTrace() - Obtiene la traza de la pila


Obtener la traza de la pila como un string

  • « Throwable::getTrace
  • Throwable::getPrevious »
  • PHP Manual
  • Throwable
  • Obtener la traza de la pila como un string

Throwable::getTraceAsString

(PHP 7, PHP 8)

Throwable::getTraceAsString — Obtener la traza de la pila como un string

Descripción

abstract public Throwable::getTraceAsString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la traza de la pila como un string.

Ver también

  • Exception::getTraceAsString() - Obtiene la traza de la pila como una cadena de caracteres


Devuelve el objeto Throwable previo

  • « Throwable::getTraceAsString
  • Throwable::__toString »
  • PHP Manual
  • Throwable
  • Devuelve el objeto Throwable previo

Throwable::getPrevious

(PHP 7, PHP 8)

Throwable::getPrevious — Devuelve el objeto Throwable previo

Descripción

abstract public Throwable::getPrevious ( ) : Throwable

Devuelve el objeto Throwable previo (por ejemplo, uno proporcionado como tercer parámetro de Exception::__construct()).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el objeto Throwable anterior si está disponible, o null si no lo está.

Ver también

  • Exception::getPrevious() - Devuelve la excepción anterior


Obtiene un representación de string del objeto lanzado

  • « Throwable::getPrevious
  • ArrayAccess »
  • PHP Manual
  • Throwable
  • Obtiene un representación de string del objeto lanzado

Throwable::__toString

(PHP 7, PHP 8)

Throwable::__toString — Obtiene un representación de string del objeto lanzado

Descripción

abstract public Throwable::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación de string del objeto lanzado.

Ver también

  • Exception::__toString() - Representación de la excepción en formato cadena


La interfaz ArrayAccess

(PHP 5, PHP 7, PHP 8)

Introducción

Interfaz para proporcionar acceso a objetos como arrays.

Sinopsis de la Interfaz

ArrayAccess {
/* Métodos */
abstract public offsetExists ( mixed $offset ) : bool
abstract public offsetGet ( mixed $offset ) : mixed
abstract public offsetSet ( mixed $offset , mixed $value ) : void
abstract public offsetUnset ( mixed $offset ) : void
}

Ejemplo #1 Uso básico

<?php
class Obj implements ArrayAccess {
    private $contenedor = array();

    public function __construct() {
        $this->contenedor = array(
            "uno"   => 1,
            "dos"   => 2,
            "tres" => 3,
        );
    }

    public function offsetSet($offset, $valor) {
        if (is_null($offset)) {
            $this->contenedor[] = $valor;
        } else {
            $this->contenedor[$offset] = $valor;
        }
    }

    public function offsetExists($offset) {
        return isset($this->contenedor[$offset]);
    }

    public function offsetUnset($offset) {
        unset($this->contenedor[$offset]);
    }

    public function offsetGet($offset) {
        return isset($this->contenedor[$offset]) ? $this->contenedor[$offset] : null;
    }
}

$obj = new Obj;

var_dump(isset($obj["dos"]));
var_dump($obj["dos"]);
unset($obj["dos"]);
var_dump(isset($obj["dos"]));
$obj["dos"] = "Un valor";
var_dump($obj["dos"]);
$obj[] = 'Añadido 1';
$obj[] = 'Añadido 2';
$obj[] = 'Añadido 3';
print_r($obj);
?>

El resultado del ejemplo sería algo similar a:

bool(true)
int(2)
bool(false)
string(8) "Un valor"
obj Object
(
    [contenedor:obj:private] => Array
        (
            [uno] => 1
            [tres] => 3
            [dos] => Un valor
            [0] => Añadido 1
            [1] => Añadido 2
            [2] => Añadido 3
        )

)

Tabla de contenidos

  • ArrayAccess::offsetExists — Comprobar si existe un índice
  • ArrayAccess::offsetGet — Offset para recuperar
  • ArrayAccess::offsetSet — Asignar un valor al índice esepecificado
  • ArrayAccess::offsetUnset — Destruye un offset


Comprobar si existe un índice

  • « ArrayAccess
  • ArrayAccess::offsetGet »
  • PHP Manual
  • ArrayAccess
  • Comprobar si existe un índice

ArrayAccess::offsetExists

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetExists — Comprobar si existe un índice

Descripción

abstract public ArrayAccess::offsetExists ( mixed $offset ) : bool

Comprueba si existe o no un índice.

Este método se ejecuta cuando se utilizan las funciones isset() o empty() sobre los objetos que implementan ArrayAccess.

Nota:

Cuando se utiliza empty(), ArrayAccess::offsetGet() será invocada para comprobar si está vacío solamente si ArrayAccess::offsetExists() devuelve true.

Parámetros

offset

El índice a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Nota:

El valor de retorno se debe convertir a boolean si no devuelve un valor boleano.

Ejemplos

Ejemplo #1 Ejemplo de ArrayAccess::offsetExists()

<?php
class obj implements arrayaccess {
    public function offsetSet($offset, $value) {
        var_dump(__METHOD__);
    }
    public function offsetExists($var) {
        var_dump(__METHOD__);
        if ($var == "foobar") {
            return true;
        }
        return false;
    }
    public function offsetUnset($var) {
        var_dump(__METHOD__);
    }
    public function offsetGet($var) {
        var_dump(__METHOD__);
        return "value";
    }
}

$obj = new obj;

echo "Runs obj::offsetExists()\n";
var_dump(isset($obj["foobar"]));

echo "\nRuns obj::offsetExists() and obj::offsetGet()\n";
var_dump(empty($obj["foobar"]));

echo "\nRuns obj::offsetExists(), *not* obj:offsetGet() as there is nothing to get\n";
var_dump(empty($obj["foobaz"]));
?>

El resultado del ejemplo sería algo similar a:

Runs obj::offsetExists()
string(17) "obj::offsetExists"
bool(true)

Runs obj::offsetExists() and obj::offsetGet()
string(17) "obj::offsetExists"
string(14) "obj::offsetGet"
bool(false)

Runs obj::offsetExists(), *not* obj:offsetGet() as there is nothing to get
string(17) "obj::offsetExists"
bool(true)


Offset para recuperar

  • « ArrayAccess::offsetExists
  • ArrayAccess::offsetSet »
  • PHP Manual
  • ArrayAccess
  • Offset para recuperar

ArrayAccess::offsetGet

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetGet — Offset para recuperar

Descripción

abstract public ArrayAccess::offsetGet ( mixed $offset ) : mixed

Devuelve el valor correspondiente a desplazamiento especificado.

Este método se ejecuta para comprobar si el desplazamiento es empty().

Parámetros

offset

El desplazamiento va a recuperar.

Notas

Nota:

A partir de PHP 5.3.4, el prototipo de los controles se relajaron y es posible para las implementaciones de este método para devolver por referencia. Esto hace que las modificaciones indirectas a las dimensiones de los arreglos sobrecargados de objetos ArrayAccess posibles.

Una modificación directa es aquella que reemplaza completamente el valor de la dimensión de el arreglo, como en $obj[6] = 7. Una modificación indirecta, por el contrario, sólo una parte los cambios de la dimensión, o los intentos de asignar la dimensión en función de otra variable, como en $obj[6][7] = 7 o $var =& $obj[6]. Con incrementos ++ y disminye con -- también se aplican de una manera que requiere la modificación indirecta.

Si bien la modificación directa desencadena una llamada a ArrayAccess::offsetSet(), modificación indirecta provoca una llamada a ArrayAccess::offsetGet(). En ese caso, la aplicación de ArrayAccess::offsetGet() debe ser capaz de volver por la referencia, de lo contrario un E_NOTICE mensaje es elevado..

Valores devueltos

Puede devolver todos los tipos de valor.

Ver también

  • ArrayAccess::offsetExists() - Comprobar si existe un índice


Asignar un valor al índice esepecificado

  • « ArrayAccess::offsetGet
  • ArrayAccess::offsetUnset »
  • PHP Manual
  • ArrayAccess
  • Asignar un valor al índice esepecificado

ArrayAccess::offsetSet

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetSet — Asignar un valor al índice esepecificado

Descripción

abstract public ArrayAccess::offsetSet ( mixed $offset , mixed $value ) : void

Asigna un valor a un offset determinado.

Parámetros

offset

El offset al que se asigna el valor.

value

El valor a asignar.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

El parámetro offset será inicializado a null si otro valor no está disponible, como en el siguiente ejemplo.

<?php
$arrayaccess[] = "primer valor";
$arrayaccess[] = "segundo valor";
print_r($arrayaccess);
?>

El resultado del ejemplo sería:

Array
(
    [0] => primer valor
    [1] => segundo valor
)

Nota:

Esta función no es invocada al realizar asignaciones por referencias y por tanto en los cambios de dimensiones en arrays sobrecargados con ArrayAccess (indirecto en el sentido de que no se hace cambiando la dimensión directamente, sino cambiando una sub-dimensión o sub-propiedad o asignando la dimensión del array por referencia en otra variable). En su lugar, se llama a ArrayAccess::offsetGet(). La operación tendrá éxito si devuelve el valor por referencia, lo cuál sólo es posible desde PHP 5.3.4.


Destruye un offset

  • « ArrayAccess::offsetSet
  • Serializable »
  • PHP Manual
  • ArrayAccess
  • Destruye un offset

ArrayAccess::offsetUnset

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetUnset — Destruye un offset

Descripción

abstract public ArrayAccess::offsetUnset ( mixed $offset ) : void

Destruye un offset.

Nota:

Este método no será llamado cuando se fuerza un tipo mediante (unset)

Parámetros

offset

El offset a destruir.

Valores devueltos

No devuelve ningún valor.


La interfaz Serializable

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Introducción

Interfaz para personalizar la serialización.

Las clases que implementan esta interfaz ya no admiten __sleep() ni __wakeup(). El método serialize se llama cuando una instancia requiere ser serializada. Esto no invoca a __destruct() ni tiene ningún efecto adicional a menos que se programe dentro del método. Cuando los datos son deserializados, la clase es conocida y se llama al correspondiente método unserialize() como constructor en lugar de llamar al método __construct(). Se puede ejecutar el constructor estándar en el método si fuera necesario.

Sinopsis de la Interfaz

Serializable {
/* Métodos */
abstract public serialize ( ) : string
abstract public unserialize ( string $serialized ) : void
}

Ejemplo #1 Uso básico

<?php
class obj implements Serializable {
    private $datos;
    public function __construct() {
        $this->datos = "Mis datos privados";
    }
    public function serialize() {
        return serialize($this->datos);
    }
    public function unserialize($datos) {
        $this->datos = unserialize($datos);
    }
    public function getDatos() {
        return $this->datos;
    }
}

$obj = new obj;
$ser = serialize($obj);

var_dump($ser);

$obj_nuevo = unserialize($ser);

var_dump($obj_nuevo->getDatos());
?>

El resultado del ejemplo sería algo similar a:

string(38) "C:3:"obj":23:{s:15:"Mis datos privados";}"
string(15) "Mis datos privados"

Tabla de contenidos

  • Serializable::serialize — Representación en formato cadena de un objeto
  • Serializable::unserialize — Construye el objeto


Representación en formato cadena de un objeto

  • « Serializable
  • Serializable::unserialize »
  • PHP Manual
  • Serializable
  • Representación en formato cadena de un objeto

Serializable::serialize

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Serializable::serialize — Representación en formato cadena de un objeto

Descripción

abstract public Serializable::serialize ( ) : string

Devuelve la representación de un objeto en formato string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación de un objeto o null

Errores/Excepciones

Lanza una Exception cuando de devuelen otros tipos aparte de string y null

Ver también

  • __sleep()


Construye el objeto

  • « Serializable::serialize
  • Closure »
  • PHP Manual
  • Serializable
  • Construye el objeto

Serializable::unserialize

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Serializable::unserialize — Construye el objeto

Descripción

abstract public Serializable::unserialize ( string $serialized ) : void

Es llamado durante la unserialización del objeto.

Nota:

Este método actua como el constructor del objeto. El método __construct() no será llamado después de este método.

Parámetros

serialized

La representación en formato string de un objeto.

Valores devueltos

El valor devuelto por este método es ignorado.

Ver también

  • __wakeup()


La clase Closure

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

Clase empleada para representar funciones anónimas.

Las funciones anónimas, implementadas en PHP 5.3, producían objetos de este tipo. Este hecho solía ser considerado como un detalle de implementación, pero ahora puede confiarse en él. Desde PHP 5.4, esta clase tiene métodos que permiten más control sobre las funciones anónimas después de haber sido creadas.

Además de los métodos listados aquí, esta clase también posse un método __invoke. Está por consistencia con otras clases que implementan la llamada mágica, ya que este método no se usa para llamar a la función.

Sinopsis de la Clase

Closure {
/* Métodos */
private __construct ( )
public static bind ( Closure $closure , object $newthis , mixed $newscope = "static" ) : Closure
public bindTo ( object $newthis , mixed $newscope = "static" ) : Closure
public call ( object $newthis , mixed $... = ? ) : mixed
public static fromCallable ( callable $callable ) : Closure
}

Tabla de contenidos

  • Closure::__construct — Constructor que anula la instanciación
  • Closure::bind — Duplicar un cierre con un objeto vinculado y ámbito de clase especificados
  • Closure::bindTo — Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos
  • Closure::call — Vincula y llama al cierre
  • Closure::fromCallable — Convierte un 'callable' en un cierre


Constructor que anula la instanciación

  • « Closure
  • Closure::bind »
  • PHP Manual
  • Closure
  • Constructor que anula la instanciación

Closure::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Closure::__construct — Constructor que anula la instanciación

Descripción

private Closure::__construct ( )

Este método sólo existe para anular la instanciación de la clase Closure. Los objetos de esta clase se crean del modo descrito en la página funciones anónimas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este método no tiene un valor de retorno; simplemente emite un error (de tipo E_RECOVERABLE_ERROR).

Ver también

  • Funciones anónimas


Duplicar un cierre con un objeto vinculado y ámbito de clase especificados

  • « Closure::__construct
  • Closure::bindTo »
  • PHP Manual
  • Closure
  • Duplicar un cierre con un objeto vinculado y ámbito de clase especificados

Closure::bind

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Closure::bind — Duplicar un cierre con un objeto vinculado y ámbito de clase especificados

Descripción

public static Closure::bind ( Closure $closure , object $newthis , mixed $newscope = "static" ) : Closure

Este método es una versión estática de Closure::bindTo(). Véase la documentación de ese método para más información.

Parámetros

closure

La función anónima a vincular.

newthis

El objeto al que la función anónima dada debería ser vinculado, o null para que el cierre sea desvinculado.

newscope

El ámbito de clase a la que asociar el cierre, o 'static' para mantener el actual. Si se proporciona un objeto, el tipo del mismo se usará en su lugar. Esto determina la visibilidad de métodos protegidos y privados del objeto vinculado. No se permite pasar (un objeto de) una clase interna a este parámetro.

Valores devueltos

Devuelve un nuevo objeto Closure o false en caso de error

Historial de cambios

Versión | Descripción
7.0.0 | newscope ya no puede ser (un objeto de) una clase interna, lo que era posible antes de esta versión.

Ejemplos

Ejemplo #1 Ejemplo de Closure::bind()

<?php
class A {
    private static $sfoo = 1;
    private $ifoo = 2;
}
$cl1 = static function() {
    return A::$sfoo;
};
$cl2 = function() {
    return $this->ifoo;
};

$bcl1 = Closure::bind($cl1, null, 'A');
$bcl2 = Closure::bind($cl2, new A(), 'A');
echo $bcl1(), "\n";
echo $bcl2(), "\n";
?>

El resultado del ejemplo sería algo similar a:

1
2

Ver también

  • Funciones anónimas
  • Closure::bindTo() - Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos


Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos

  • « Closure::bind
  • Closure::call »
  • PHP Manual
  • Closure
  • Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos

Closure::bindTo

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Closure::bindTo — Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos

Descripción

public Closure::bindTo ( object $newthis , mixed $newscope = "static" ) : Closure

Crea y devuelve una nueva función anónima con el cuerpo y variables vinculadas como ésta, pero posiblemente con un objeto vinculado diferente y un nuevo ámbito de clase.

El "objeto vinculado" determina el valor que $this tendrá en el cuerpo de la función, y el "ámbito de clase" representa una clase que determina los miembros privados y protegidos a los que será capaz de acceder la función anónima. Concretamente, los miembros que serán visibles son los mismos que si la función anónima fuese un método de la clase dada como valor del parámetro newscope.

Los cierres estáticos no pueden tener ningún objeto vinculado (el valor del parámetro newthis debería ser null), pero esta función puede, no obstante, usarse para cambiar su ámbito de clase.

Esta función se asegurará de que a un cierre no estático que tenga una instancia vinculada se le aplique un ámbito y viceversa. En este punto, los cierres no estáticos que le son dados un ámbito, excepto una instancia null, son hechos estáticos, y los cierres no estáticos y sin ámbito que le son dados una instancia no nula se les aplica un ámbito de clase no especificado.

Nota:

Si solamente se quieren duplicar las funciones anónimas, se puede usar cloning en su lugar.

Parámetros

newthis

El objeto al que la función anónima dada debería ser vinculado, o null para que el cierre sea desvinculado.

newscope

El ámbito de la clase a la que se va a asociar el cierre, o 'static' para mantener el actual. Si se proporciona un objeto, el tipo del mismo se usará en su lugar. Esto determina la visibilidad de métodos protegidos y privados del objeto vinculado. No se permite pasar (un objeto de) una clase interna a este parémtro.

Valores devueltos

Devuelve el objeto Closure recién creado o false en caso de error

Historial de cambios

Versión | Descripción
7.0.0 | newscope ya no puede ser (un objeto de) una clase interna, lo cual era posible antes de esta versión.

Ejemplos

Ejemplo #1 Ejemplo de Closure::bindTo()

<?php

class A {
    function __construct($val) {
        $this->val = $val;
    }
    function getClosure() {
        //devuelve el cierre vinculado a este objeto y el ámbito
        return function() { return $this->val; };
    }
}

$ob1 = new A(1);
$ob2 = new A(2);

$cl = $ob1->getClosure();
echo $cl(), "\n";
$cl = $cl->bindTo($ob2);
echo $cl(), "\n";
?>

El resultado del ejemplo sería algo similar a:

1
2

Ver también

  • Funciones anónimas
  • Closure::bind() - Duplicar un cierre con un objeto vinculado y ámbito de clase especificados


Vincula y llama al cierre

  • « Closure::bindTo
  • Closure::fromCallable »
  • PHP Manual
  • Closure
  • Vincula y llama al cierre

Closure::call

(PHP 7, PHP 8)

Closure::call — Vincula y llama al cierre

Descripción

public Closure::call ( object $newthis , mixed $... = ? ) : mixed

Vincula temporalmente el cierre a newthis, y lo llama con cualquier parámetro dado.

Parámetros

newthis

El object a vincular al cierre mientras dure la llamada.

...

Cero o más parámetros, que serán dados como parámetros al cierre.

Valores devueltos

Devuelve el valor devuelto por el cierre.

Ejemplos

Ejemplo #1 Ejemplo de Closure::call()

<?php
class Valor {
    protected $valor;

    public function __construct($valor) {
        $this->valor = $valor;
    }

    public function getValor() {
        return $this->valor;
    }
}

$tres = new Valor(3);
$cuatro = new Valor(4);

$cierre = function ($delta) { var_dump($this->getValor() + $delta); };
$cierre->call($tres, 4);
$cierre->call($cuatro, 4);
?>

El resultado del ejemplo sería:

int(7)
int(8)


Convierte un 'callable' en un cierre

  • « Closure::call
  • Generator »
  • PHP Manual
  • Closure
  • Convierte un 'callable' en un cierre

Closure::fromCallable

(PHP 7 >= 7.1.0)

Closure::fromCallable — Convierte un 'callable' en un cierre

Descripción

public static Closure::fromCallable ( callable $callable ) : Closure

Crea y devuelve una nueva función anónima desde el callable dado empleando el ámbito actual. Este método comprueba si callable es llamable en el ámbito actual, lanzando un TypeError si no lo es.

Parámetros

callable

El «callable» a convertir.

Valores devueltos

Devuelve el recién creado Closure o lanza un TypeError si callable no es llamable en el ámbito actual.


La clase Generator

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Introducción

Los objetos Generator son devueltos desde generadores.

Precaución

Los objetos Generator no pueden ser instanciados mediante new.

Sinopsis de la Clase

Generator implements Iterator {
/* Métodos */
public current ( ) : mixed
public getReturn ( ) : mixed
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public send ( mixed $value ) : mixed
public throw ( Throwable $exception ) : mixed
public valid ( ) : bool
public __wakeup ( ) : void
}

Tabla de contenidos

  • Generator::current — Obtener el valor producido
  • Generator::getReturn — Obtener el valor devuelto de un generador
  • Generator::key — Obtener la clave generada
  • Generator::next — Continua la ejecución del generador
  • Generator::rewind — Rebobina el iterador
  • Generator::send — Enviar un valor al generador
  • Generator::throw — Lanzar una excepción dentro generador
  • Generator::valid — Verificar si el iterador ha sido cerrado
  • Generator::__wakeup — Serialize callback


Obtener el valor producido

  • « Generator
  • Generator::getReturn »
  • PHP Manual
  • Generator
  • Obtener el valor producido

Generator::current

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::current — Obtener el valor producido

Descripción

public Generator::current ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor producido.


Obtener el valor devuelto de un generador

  • « Generator::current
  • Generator::key »
  • PHP Manual
  • Generator
  • Obtener el valor devuelto de un generador

Generator::getReturn

(PHP 7, PHP 8)

Generator::getReturn — Obtener el valor devuelto de un generador

Descripción

public Generator::getReturn ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor devuelto del generador una vez ha finalizado su ejecución.

Ejemplos

Ejemplo #1 Ejemplo de Generator::getReturn()

<?php

$gen = (function() {
    yield 1;
    yield 2;

    return 3;
})();

foreach ($gen as $val) {
    echo $val, PHP_EOL;
}

echo $gen->getReturn(), PHP_EOL;

El resultado del ejemplo sería:

1
2
3


Obtener la clave generada

  • « Generator::getReturn
  • Generator::next »
  • PHP Manual
  • Generator
  • Obtener la clave generada

Generator::key

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::key — Obtener la clave generada

Descripción

public Generator::key ( ) : mixed

Obtiene la clave del valor generado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clave generada.

Ejemplos

Ejemplo #1 Ejemplo de Generator::key()

<?php

function Gen()
{
    yield 'key' => 'value';
}

$gen = Gen();

echo "{$gen->key()} => {$gen->current()}";

El resultado del ejemplo sería:

key => value


Continua la ejecución del generador

  • « Generator::key
  • Generator::rewind »
  • PHP Manual
  • Generator
  • Continua la ejecución del generador

Generator::next

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::next — Continua la ejecución del generador

Descripción

public Generator::next ( ) : void

Llamar a Generator::next() tiene el mismo efecto que llamar a Generator::send() con null como argumento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador

  • « Generator::next
  • Generator::send »
  • PHP Manual
  • Generator
  • Rebobina el iterador

Generator::rewind

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::rewind — Rebobina el iterador

Descripción

public Generator::rewind ( ) : void

Si la iteración ya ha comenzado, lanzará una excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Enviar un valor al generador

  • « Generator::rewind
  • Generator::throw »
  • PHP Manual
  • Generator
  • Enviar un valor al generador

Generator::send

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::send — Enviar un valor al generador

Descripción

public Generator::send ( mixed $value ) : mixed

Envía el valor dado al generador como resultado de la expresión yield actual y reanuda la ejecución del generador.

Si el generador no es una expresión yield en el momento de invocar a este método, se permitirá avanzar a la primera expresión yield antes de enviar el valor. Por tanto, no es necesario «preparar» generadores de PHP con una llamada a Generator::next() (como se hace en Python).

Parámetros

value

El valor a enviar al generador. Este valor será el valor devuelto de la expresión yield en la que está actualmente el generador.

Valores devueltos

Devuelve el valor producido.

Ejemplos

Ejemplo #1 Empleo de Generator::send() para inyectar valores

<?php
function printer() {
    echo "¡Soy una impresora!".PHP_EOL;
    while (true) {
        $string = yield;
        echo $string;
    }
}

$printer = printer();
$printer->send('¡Hola mundo!');
$printer->send('¡Adiós mundo!');
?>

El resultado del ejemplo sería:

¡Soy una impresora!
¡Hola mundo!
¡Adiós mundo!


Lanzar una excepción dentro generador

  • « Generator::send
  • Generator::valid »
  • PHP Manual
  • Generator
  • Lanzar una excepción dentro generador

Generator::throw

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::throw — Lanzar una excepción dentro generador

Descripción

public Generator::throw ( Throwable $exception ) : mixed

Lanza una excepción dentro del generador y reanuda su ejecución. El comportamiento será el mismo que si la expresión yield actual fuera reemplazada con una sentencia throw $exception.

Si el generador ya está cerrado al invocar a este método, la excepción será lanzada en su lugar en el contexto del invocador.

Parámetros

exception

La excepción a lanzar dentro del generador.

Valores devueltos

Devuelve el valor generado.

Historial de cambios

Versión | Descripción
7.0.0 | Ahora el parámetro exception también acepta Throwable.

Ejemplos

Ejemplo #1 Lanzar una ecepión dentro de un generador

<?php
function gen() {
    echo "Foo\n";
    try {
        yield;
    } catch (Exception $e) {
        echo "Excepción: {$e->getMessage()}\n";
    }
    echo "Bar\n";
}

$gen = gen();
$gen->rewind();
$gen->throw(new Exception('Prueba'));
?>

El resultado del ejemplo sería:

Foo
Excepción: Prueba
Bar


Verificar si el iterador ha sido cerrado

  • « Generator::throw
  • Generator::__wakeup »
  • PHP Manual
  • Generator
  • Verificar si el iterador ha sido cerrado

Generator::valid

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::valid — Verificar si el iterador ha sido cerrado

Descripción

public Generator::valid ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve false si el iterador ha sido cerrado. De lo contrario devuelve true.


Serialize callback

  • « Generator::valid
  • WeakReference »
  • PHP Manual
  • Generator
  • Serialize callback

Generator::__wakeup

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::__wakeup — Serialize callback

Descripción

public Generator::__wakeup ( ) : void

Lanza una excepción indicando que el generador no puede ser presentado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


La clase WeakReference

(PHP 7 >= 7.4.0)

Introducción

Las referencias débiles permiten al programador retener una referencia a un objeto que no impide que el objeto sea destruido. Son útiles para implementar estructuras de tipo cache.

Nota:

La clase WeakReference no debe confundirse con la clase WeakRef de la extensión Weakref.

WeakReference no puede ser serializado.

Sinopsis de la Clase

WeakReference {
/* Métodos */
public __construct ( )
public static create ( object $referent ) : WeakReference
public get ( ) : ?object
}

Ejemplos de WeakReference

Ejemplo #1 Uso básico de WeakReference

<?php
$obj = new stdClass;
$weakref = WeakReference::create($obj);
var_dump($weakref->get());
unset($obj);
var_dump($weakref->get());
?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#1 (0) {
}
NULL

Tabla de contenidos

  • WeakReference::__construct — Constructor que no permite la instanciación
  • WeakReference::create — Crea una nueva referencia débil
  • WeakReference::get — Obtiene un objeto débilmente referenciado


Constructor que no permite la instanciación

  • « WeakReference
  • WeakReference::create »
  • PHP Manual
  • WeakReference
  • Constructor que no permite la instanciación

WeakReference::__construct

(PHP 7 >= 7.4.0)

WeakReference::__construct — Constructor que no permite la instanciación

Descripción

public WeakReference::__construct ( )

Este método existe sólo para no permitir la instanciación de la clase WeakReference. Las referencias débiles deben ser instanciadas con el método factory WeakReference::create().

Parámetros

Esta función no tiene parámetros.

Ver también

  • WeakReference::create() - Crea una nueva referencia débil


Crea una nueva referencia débil

  • « WeakReference::__construct
  • WeakReference::get »
  • PHP Manual
  • WeakReference
  • Crea una nueva referencia débil

WeakReference::create

(PHP 7 >= 7.4.0)

WeakReference::create — Crea una nueva referencia débil

Descripción

public static WeakReference::create ( object $referent ) : WeakReference

Crea una nueva WeakReference.

Parámetros

referent

El objeto a ser referenciado débilmente.

Valores devueltos

Devuelve el objeto recién instanciado.


Obtiene un objeto débilmente referenciado

  • « WeakReference::create
  • Opciones y parámetros de contexto »
  • PHP Manual
  • WeakReference
  • Obtiene un objeto débilmente referenciado

WeakReference::get

(PHP 7 >= 7.4.0)

WeakReference::get — Obtiene un objeto débilmente referenciado

Descripción

public WeakReference::get ( ) : ?object

Se obtiene un objeto débilmente referenciado. Si el objeto ya ha sido destruido, devuelve null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el referenciado object, o null si el objeto ha sido destruido.


Opciones y parámetros de contexto

PHP ofrece varias opciones y parámetros de contexto que pueden utilizarse
con todos los sistemas de ficheros y envolturas de flujos. Un contexto se crea con
stream_context_create(). Las opciones se establecen con
stream_context_set_option(), y los parámetros con
stream_context_set_params().

Tabla de contenidos

  • Opciones de contexto de sockets — Listado de opciones de contexto de sockets
  • Opciones de contexto de HTTP — Listado de opciones de contexto de HTTP
  • Opciones de contexto para FTP — Listado de opciones de contexto para FTP
  • Opciones de contexto para SSL — Listado de opciones de contexto para SSL
  • Opciones de contexto para CURL — Listado de opciones de contexto para CURL
  • Opciones de contexto Phar — Listado de opciones de contexto Phar
  • Opciones de contexto de MongoDB — Listado de opciones de contexto de MongoDB
  • Contexto parámetros — Listado de parámetros de contexto
  • Opciones del contexto zip — Listado de opciones del contexto zip


Listado de opciones de contexto de sockets

  • « Opciones y parámetros de contexto
  • Opciones de contexto de HTTP »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto de sockets

Opciones de contexto de sockets

Opciones de contexto de sockets — Listado de opciones de contexto de sockets

Descripción

Las opciones de contexto de sockets están disponibles para todas las envolturas que trabajan sobre sockets, como tcp, http y ftp.

Opciones

bindto

Usada para especificar la dirección IP (ya sea IPv4 o IPv6) y/o el número de puerto que PHP usará para acceder a la red. La sintaxis es ip:puerto para direcciones IPv4, y [ip]:puerto para direcciones IPv6. Establecer el número IP o de puerto como 0 producirá que el sistema lo elija por usted.

Nota:

Dado que FTP crea dos conexiones de socket durante la operación normal, no es posible especificar el número de puerto con esta opción.

backlog

Usado para limitar el número de conexiones pendientes en la cola de escucha del socket.

Nota:

Solamente se aplica a stream_socket_server().

Historial de cambios

Versión | Descripción
5.3.3 | Se agregó bindto.
5.1.0 | Se agregó backlog.

Ejemplos

Ejemplo #1 Ejemplo de uso básico de bindto

<?php
// conectarse a internet usando la IP '192.168.0.100'
$opciones = array(
    'socket' => array(
        'bindto' => '192.168.0.100:0',
    ),
);

// conectarse a internet usando la IP '192.168.0.100' y el puerto '7000'
$opciones = array(
    'socket' => array(
        'bindto' => '192.168.0.100:7000',
    ),
);

// conectarse a internet usando la dirección IPv6  '2001:db8::1'
// y el puerto '7000'
$opciones = array(
    'socket' => array(
        'bindto' => '[2001:db8::1]:7000',
    ),
);

// conectarse a internet usando el puerto '7000'
$opciones = array(
    'socket' => array(
        'bindto' => '0:7000',
    ),
);

// crear el contexto...
$contexto = stream_context_create($opciones);

// ...y usarlo para recuperar los datos
echo file_get_contents('http://www.example.com', false, $contexto);

?>


Listado de opciones de contexto de HTTP

  • « Opciones de contexto de sockets
  • Opciones de contexto para FTP »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto de HTTP

Opciones de contexto de HTTP

Opciones de contexto de HTTP — Listado de opciones de contexto de HTTP

Descripción

Opciones de contexto para los transportes http:// y https://.

Opciones

method string

GET, POST, o cualquier otro método HTTP que admita el servidor remoto.

Por omisión, GET.

header string

Las cabeceras adicionales que se envían en la petición. Los valores de esta opción sobrescribirán los existentes (tales como User-agent:, Host:, o Authentication:).

user_agent string

Valor de la cabecera User-Agent:. Solo se utilizará si el agente no se ha especificado en la opción de contexto header vista arriba.

Por omisión, se utiliza el valor del ajuste user_agent de php.ini.

content string

Datos adicionales a enviar tras las cabeceras. Típicamente se utiliza con peticiones POST o PUT.

proxy string

El URI que define la dirección de un servidor proxy (p.ej. tcp://proxy.example.com:5100).

request_fulluri boolean

Cuando se establece a true, se utilizará todo el URI para construir la petición, (es decir, GET http://www.example.com/path/to/file.html HTTP/1.0). A pesar de que es un formato de petición no estándar, algunos servidores proxy requieren que sea así.

Por omisión es false.

follow_location integer

Seguir las redirecciones de las cabeceras Location. Establecer a 0 para deshabilitarlo.

Por omisión es 1.

max_redirects integer

El número máximo de redirecciones a seguir. Un valor igual o menor a 1 indica que no se siga ninguna redirección.

Por omisión es 20.

protocol_version float

La versión del protocolo HTTP.

Por omisión es 1.0.

Nota:

Las versiónes de PHP anteriores a la 5.3.0 no implementan la decodificación de transferencias fragmentadas. Si este valor es 1.1, es responsabilidad del programador cumplir con la versión 1.1.

timeout float

El tiempo de espera de lectura en segundos, especificado por un float (p.ej. 10.5).

Por omisión, se utiliza el valor del ajuste default_socket_timeout de php.ini.

ignore_errors boolean

Obtener el contenido incluso con códigos de estado de error.

Por omisión es false.

Historial de cambios

Versión | Descripción
5.3.4 | Se añadió follow_location.
5.3.0 | La opción protocol_version admite la decodificación de transferencias fragmentadas en caso de valer 1.1.
5.2.10 | Se añadió ignore_errors.
5.2.10 | El parámetro header ahora puede ser un array de índices numéricos.
5.2.1 | Se añadió timeout.
5.1.0 | Se añadió el soporte de HTTPS mediante proxies HTTP.
5.1.0 | Se añadió max_redirects.
5.1.0 | Se añadió protocol_version.

Ejemplos

Ejemplo #1 Obtener una página y enviar datos POST

<?php

$datos_post = http_build_query(
    array(
        'var1' => 'contenido',
        'var2' => 'doh'
    )
);

$opciones = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $datos_post
    )
);

$contexto = stream_context_create($opciones);

$resultado = file_get_contents('http://example.com/submit.php', false, $contexto);

?>

Ejemplo #2 Ignorar las redirecciones, aunque obtener las cabeceras y el contenido

<?php

$url = "http://www.example.org/header.php";

$opciones = array('http' =>
    array(
        'method' => 'GET',
        'max_redirects' => '0',
        'ignore_errors' => '1'
    )
);

$contexto = stream_context_create($opciones);
$flujo = fopen($url, 'r', false, $contexto);

// información de cabeceras y meta datos
// sobre el flujo
var_dump(stream_get_meta_data($flujo));

// datos reales en $url
var_dump(stream_get_contents($flujo));
fclose($flujo);
?>

Notas

Nota: Opciones de contexto del flujo de socket subyacente
Se pueden admitir opciones de contexto adicionales mediante el transporte subyacente. Para flujos http://, deben consultarse las opciones de contexto del transporte tcp://. Para flujos https://, deben consultarse las opciones de contexto del transporte ssl://.

Nota: Línea de estado HTTP
Cuando esta envultura de flujo sigue una redirección, los datos en wrapper_data devueltos por stream_get_meta_data() podrían no contener necesariamente la línea de estado HTTP que realmente se aplica a los datos del contenido del índice 0.

array (
  'wrapper_data' =>
  array (
    0 => 'HTTP/1.0 301 Moved Permantenly',
    1 => 'Cache-Control: no-cache',
    2 => 'Connection: close',
    3 => 'Location: http://example.com/foo.jpg',
    4 => 'HTTP/1.1 200 OK',
    ...
La primera petición devolvió un 301 (redirección permanente), de manera que la envoltura del flujo sigue automáticamente la redirección para obtener una respuesta de código 200 (índice = 4).

Ver también

  • http://
  • Opciones de contexto de sockets
  • Opciones de contexto para SSL


Listado de opciones de contexto para FTP

  • « Opciones de contexto de HTTP
  • Opciones de contexto para SSL »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto para FTP

Opciones de contexto para FTP

Opciones de contexto para FTP — Listado de opciones de contexto para FTP

Descripción

Opciones de contexto para transportes ftp:// y ftps://

Opciones

overwrite boolean

Permite sobrescribir archivos ya existentes en el servidor remoto. Se aplica sólo al modo de escritura (subida).

Defaults to false.

resume_pos integer

Desplazamiento de archivo en donde iniciar la transferencia. Se aplica sólo al modo de lectura (descarga).

Por defecto es 0 (inicio del archivo).

proxy string

Petición FTP al proxy por medio de un servidor proxy http. Se aplica sólo a operaciones de lectura de archivos. Ejemplo: tcp://squid.example.com:8000.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió proxy.

Notas

Nota: Opciones subyacentes del contexto del flujo del socket
Opciones adicionales de contexto pueden se soportadas por el transporte subyacente Para flujos ftp://, remitirse a las opciones de contexto para el transporte tcp://. Para flujos ftps://, remitirse a las opciones de contexto para el transporte ssl://.

Ver también

  • ftp://
  • Opciones de contexto de sockets
  • Opciones de contexto para SSL


Listado de opciones de contexto para SSL

  • « Opciones de contexto para FTP
  • Opciones de contexto para CURL »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto para SSL

Opciones de contexto para SSL

Opciones de contexto para SSL — Listado de opciones de contexto para SSL

Descripción

Opciones de contexto para transportes ssl:// y tls://

Opciones

peer_name string

Nombre del par a utilizar. Si no se establece este valor, se averigua basándose en el nombre del host empleado al abrir el flujo.

verify_peer boolean

Requerir verificación del certificado SSL utilizado.

Por defecto es true.

verify_peer_name boolean

Requerir verificación de nombre del par.

Por defecto es true.

allow_self_signed boolean

Permite certificados auto-firmados. Requiere verify_peer.

Por defecto es false

cafile string

Ubicación del archivo de la entidad emisora de certificados en el sistema de archivos local, la cual debe ser utilizada con la opción de contexto verify_peer para autenticar la identidad del par remoto.

capath string

Si no se específica cafile o si no se encuentra el certificado, el directorio al que apunta capath sera explorado en busca de un certificado apropiado. capath debe ser un directorio con el hash correcto.

local_cert string

Ruta hacia el archivo del certificado local en el sistema de archivos. Debe ser un archivo codificado con PEM el cual contenga el certificado y la llave privada. Puede, opcionalmente, contener la cadena de los emisores del certificado. La clave privada también podría estar contenida en un fichero aparte especificado por local_pk.

local_pk string

Ruta a fichero de clave privada local del sistema de ficheros en caso ficheros separados para el certificado (local_cert) y la clave privada.

passphrase string

La frase de contraseña con la cual el archivo local_cert fue codificado.

CN_match string

El nombre común que se está esperando. PHP realizará comparaciones limitadas de comodines. Si el nombre común no coincide con esto, el intento de conexión fallará.

Nota: Esta opción está obsoleta a favor de peer_name, a partir de PHP 5.6.0.

verify_depth integer

Abortar si la cadena de certificados es demasiado profunda.

Por defecto es no verificarlo.

ciphers string

Establece la lista de sistemas de cifrado disponibles. El formato de la cadena se describe en » ciphers(1).

Por defecto es DEFAULT.

capture_peer_cert boolean

Si se establece en true, una opción de contexto peer_certificate será creada, conteniendo el certificado par.

capture_peer_cert_chain boolean

Si se establece en true, una opción de contexto peer_certificate_chain será creada, conteniendo la cadena del certificado.

SNI_enabled boolean

Si se establece en true, la indicación del nombre del servidor se activará. Activando SNI se permiten múltiples certificados en la misma dirección IP.

SNI_server_name string

Si se establece, entonces este valor se utilizará como nombre del servidor para la indicación de nombre de servidor. Si este valor no está establecido, entonces el nombre del servidor se supone basado en el nombre de host utilizado cuando se abre el flujo.

Nota: Esta opción está obsoleta a favor de peer_name, a partir de PHP 5.6.0.

disable_compression boolean

Si está establecido, deshabilita la comprensión TLS. Esto puede ayudar a mitigar el vector de ataque CRIME.

peer_fingerprint string | array

Aborta cuando el resumen del certificado remoto no coincide con el has especificado.

Cuando se emplea un string, la longitud determinará qué algoritmo hash se aplica, si "md5" (32) o "sha1" (40).

Cuando se emplea un array, las claves indican el nombre del algoritmo hash y cada valor correspondiente es el resumen previsto.

Historial de cambios

Versión | Descripción
5.6.0 | Se añadieron peer_fingerprint and verify_peer_name. El valor predeterminado de verify_peer se cambió a true.
5.4.13 | Se añadió disable_compression. Requiere OpenSSL >= 1.0.0.
5.3.2 | Se añadió SNI_enabled y SNI_server_name.

Notas

Nota: Debido a que ssl:// el es transporte subyacente para las envolturas https:// y ftps://, cualquier opción de contexto que aplique para ssl:// también aplica para https:// y ftps://.

Nota: Para que SNI (Server Name Indication) esté disponible, entonces PHP se debe compilar con OpenSSL 0.9.8j o superior. Se utiliza OPENSSL_TLSEXT_SERVER_NAME para determinar si SNI está soportado.

Ver también

  • Opciones de contexto de sockets


Listado de opciones de contexto para CURL

  • « Opciones de contexto para SSL
  • Opciones de contexto Phar »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto para CURL

Opciones de contexto para CURL

Opciones de contexto para CURL — Listado de opciones de contexto para CURL

Descripción

Las opciones de contexto para CURL están disponibles cuando la extensión CURL fue compilada usando la opción de configuración --with-curlwrappers.

Opciones

method string

GET, POST, o cualquier otro método HTTP soportado por el servidor remoto.

Por defecto es GET.

header string

Cabeceras adicionales a ser enviadas durante la petición. Los valores de esta opción sobrescribirán otros valores (como por ejemplo User-agent:, Host:, y Authentication:).

user_agent string

Valor a ser enviado con la cabecera User-Agent:.

Por defecto se usa la configuración user_agent de php.ini.

content string

Datos adicionales para ser enviados después de las cabeceras. Esta opción no se utiliza para peticiones GET o HEAD.

proxy string

URI que especifica la dirección del servidor proxy. (Por ejemplo tcp://proxy.example.com:5100).

max_redirects integer

El número máximo de redirecciones a seguir. Un valor de 1 o menos significa que no se siguen la redirecciones.

Por defecto es 20.

curl_verify_ssl_host boolean

Verifica el host.

Por defecto es false

Nota:

Esta opción está disponible tanto para envolturas del protocolo http como del ftp.

curl_verify_ssl_peer boolean

Requiere verificación del certificado SSL utilizado.

Por defecto es false

Nota:

Esta opción está disponible tanto para envolturas del protocolo http como del ftp.

Ejemplos

Ejemplo #1 Obtener una página y enviar datos POST

<?php

$postdata = http_build_query(
    array(
        'var1' => 'some content',
        'var2' => 'doh'
    )
);

$opts = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postdata
    )
);

$context = stream_context_create($opts);

$result = file_get_contents('http://example.com/submit.php', false, $context);

?>

Ver también

  • Opciones de contexto de sockets


Listado de opciones de contexto Phar

  • « Opciones de contexto para CURL
  • Opciones de contexto de MongoDB »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto Phar

Opciones de contexto Phar

Opciones de contexto Phar — Listado de opciones de contexto Phar

Descripción

Opciones de contexto para phar:// envoltura.

Opciones

comprimir int

Uno de Constantes de compresión Phar.

metadata mixed

Metadatos Phar. Ver Phar::setMetadata().

Ver también

  • phar://
  • Envoltura de secuencias Phar


Listado de opciones de contexto de MongoDB

  • « Opciones de contexto Phar
  • Contexto parámetros »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones de contexto de MongoDB

Opciones de contexto de MongoDB

Opciones de contexto de MongoDB — Listado de opciones de contexto de MongoDB

Descripción

Opciones de contexto para transportes mongodb://.

Opciones

log_cmd_insert callable

Una función de retrollamada invocada al insertar un documento, véase log_cmd_insert().

log_cmd_delete callable

Una función de retrollamada invocada al borrar un documento, véase log_cmd_delete().

log_cmd_update callable

Una función de retrollamada invocada al actualizar un documento, véase log_cmd_update().

log_write_batch callable

Una función de retrollamada invocada al ejecutar un Lote de Escrituras, véase log_write_batch().

log_reply callable

Una función de retrollamada invocada al leer una réplica de MongoDB, véase log_reply().

log_getmore callable

Una función de retrollamada invocada al recuperar más resultados de un cursor MongoDB, véase log_getmore().

log_killcursor callable

Una función de retrollamada invocada al ejecutar un código de operación 'killcursor', véase log_killcursor().

Historial de cambios

Versión | Descripción
pecl/mongo 1.5.0 | Se añadieron las opciones de Contexto de la API de escritura

Ver también

  • Opciones de contexto de sockets
  • Opciones de contexto para SSL


Listado de parámetros de contexto

  • « Opciones de contexto de MongoDB
  • Opciones del contexto zip »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de parámetros de contexto

Contexto parámetros

Contexto parámetros — Listado de parámetros de contexto

Descripción

Estos parametros se pueden establecer en un contexto usando el la función stream_context_set_params().

Parámetros

notification callable

Un valor de tipo callable que se llamará cuando se produce un evento en un flujo.

Véase stream_notification_callback para más detalles.


Listado de opciones del contexto zip

  • « Contexto parámetros
  • Protocolos y Envolturas soportados »
  • PHP Manual
  • Opciones y parámetros de contexto
  • Listado de opciones del contexto zip

Opciones del contexto zip

Opciones del contexto zip — Listado de opciones del contexto zip

Descripción

Las opciones del contexto zip están disponibles para envolturas zip.

Opciones

password

Empleado para especificar la contraseña utilizada para el archivo encriptado.

Historial de cambios

Versión | Descripción
PHP 7.2.0, PECL zip 1.14.0 | Se añadió password.

Ejemplos

Ejemplo #1 Ejemplo de uso básico password

<?php
// Leer el fichero encriptado
$opciones = array(
    'zip' => array(
        'password' => 'secret',
    ),
);
// Crear el contexto...
$contexto = stream_context_create($opciones);

// ...y emplearlo para recuperar los datos
echo file_get_contents('zip://test.zip#test.txt", false, $ctx);

?>


Protocolos y Envolturas soportados

PHP incorpora de serie envolturas para distintos protocolos tipo URL para trabajar junto con funciones del sistema de ficheros, como fopen(), copy(), file_exists() y filesize(). Además de estas envolturas, se pueden definir por el usuario utilizando la función stream_wrapper_register().

Nota: La sintaxis de URL que se utiliza para describir una envoltura solo puede ser scheme://.... Las sintaxis scheme:/ y scheme: no están soportadas.

Tabla de contenidos

  • file:// — Acceso al sistema de ficheros local
  • http:// — Acceso a URLS en HTTP(s)
  • ftp:// — Acceso a URLs por FTP(s)
  • php:// — Acceso a distintos flujos de E/S
  • zlib:// — Flujos de compresión
  • data:// — Data (RFC 2397)
  • glob:// — Encuentra las rutas que coincidan con el patrón
  • phar:// — Archivo PHP
  • ssh2:// — Secure Shell 2
  • rar:// — RAR
  • ogg:// — Flujos de audio
  • expect:// — Flujos de Interacción de Procesos


Acceso al sistema de ficheros local

  • « Protocolos y Envolturas soportados
  • http:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Acceso al sistema de ficheros local

file://

file:// — Acceso al sistema de ficheros local

Descripción

El Sistema de Ficheros es la envoltura por omisión de PHP y representa al sistema de ficheros local. Cuando se proporciona una ruta relativa (esto es, no comienza con /, \, \\, ni con la letra de un dispositivo Windows) ésta se hará usando el directorio de trabajo actual. En muchos casos, se trata del directorio en el que se aloja el script, a no ser que se haya cambiado explicitamente. Si se utiliza la sapi CLI, apuntará al directorio desde el que se ejecutó el script.

En algunas funciones, como por ejemplo fopen() o file_get_contents(), puede usarse también include_path para localizar ficheros con rutas relativas.

Uso

  • /ruta/al/fichero.ext
  • ruta/relativa/al/fichero.ext
  • ficheroEnDta.ext
  • C:/ruta/a/ficherowindows.ext
  • C:\ruta\a\ficherowindows.ext
  • \\servidorsmb\ruta\compartida\a\ficherowindows.ext
  • file:///ruta/al/fichero.ext

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Permite Lecturas | Sí
Permite Escrituras | Sí
Permite Añadir contenidos | Sí
Permite Lecturas y Escrituras Simultáneas | Sí
Permite usar la función stat() | Sí
Permite usar la función unlink() | Sí
Permite usar la función rename() | Sí
Permite usar la función mkdir() | Sí
Permite usar la función rmdir() | Sí


Acceso a URLS en HTTP(s)

  • « file://
  • ftp:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Acceso a URLS en HTTP(s)

http://

https://

http:// -- https:// — Acceso a URLS en HTTP(s)

Descripción

Permite acceso de lectura a ficheros/recursos mediante HTTP 1.0, utilizando el método GET de HTTP. Junto con la petición, se envía una cabecera Host: para así poder usar hosts virtuales basados en nombres. Si se ha definido un user_agent en el fichero php.ini o en el contexto del flujo, éste se incluirá también en la petición.

El flujo proporciona acceso al cuerpo del recurso; las cabeceras se guardan en la variable $http_response_header.

Si fuera importante conocer la URL del recurso del que procede el documento (tras procesar todas las redirecciones), se deberán procesar todas las cabeceras de respuesta devueltas por el flujo.

Se usará la directiva from en la cabecera From: siempre que esté asignado y no se sobrescriba por Opciones y parámetros de contexto.

Uso

  • http://ejemplo.com
  • http://ejemplo.com/fichero.php?var1=val1&var2=val2
  • http://usuario:contraseña@ejemplo.com
  • https://ejemplo.com
  • https://ejemplo.com/fichero.php?var1=val1&var2=val2
  • https://usuario:contraseña@ejemplo.com

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | Sí
Permite Lecturas | Sí
Permite Escrituras | No
Permite Añadir contenidos | No
Permite Lecturas y Escrituras Simultáneas | N/A
Permite usar la función stat() | No
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Ejemplos

Ejemplo #1 Detectar la URL en la que se finaliza tras las redirecciones

<?php
$url = 'http://www.example.com/redirecting_page.php';

$fp = fopen($url, 'r');

$meta_data = stream_get_meta_data($fp);
foreach ($meta_data['wrapper_data'] as $response) {

    /* Were we redirected? */
    if (strtolower(substr($response, 0, 10)) == 'location: ') {

        /* update $url with where we were redirected to */
        $url = substr($response, 10);
    }

}

?>

Notas

Nota: Sólo habrá soporte para HTTPS cuando la extensión openssl esté habilitada.

Las conexiones HTTP son de sólo lectura; no hay soporte para escribir o copiar datos a un recurso HTTP.

Se pueden enviar peticiones POST y PUT, por ejemplo, con ayuda de los Contextos HTTP.

Ver también

  • Opciones de contexto de HTTP
  • $http_response_header
  • stream_get_meta_data() - Recuperar meta-información o de cabecera de punteros a flujos/archivo


Acceso a URLs por FTP(s)

  • « http://
  • php:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Acceso a URLs por FTP(s)

ftp://

ftps://

ftp:// -- ftps:// — Acceso a URLs por FTP(s)

Descripción

Permite tanto lectura de ficheros existentes como la creación de nuevos ficheros vía FTP. La conexión fallará si el servidor no soporta FTP en modo pasivo.

Se puede tanto leer como escribir ficheros, pero no las dos cosas simultáneamente. Si el fichero remoto ya existiera en el servidor ftp, y se quisiera abrir en modo escritura sin especificar la opción de contexto overwrite, también fallará la conexión. Si fuera necesario sobrescribir un fichero ya existente en ftp, se tendrá que especificar la opción de contexto overwrite antes de abrir el fichero para su escritura. Alternativamente, puede usarse la extensión FTP.

Si se ha establecido la directiva from en php.ini, se enviará como contraseña para conexiones de FTP anónimo.

Uso

  • ftp://ejemplo.com/pub/fichero.txt
  • ftp://usuario:contraseña@example.com/pub/fichero.txt
  • ftps://ejemplo.com/pub/fichero.txt
  • ftps://usuario:contraseña@ejemplo.com/pub/fichero.txt

Opciones

Resumen de la Envoltura
Atributos | Permitido
Restringido por allow_url_fopen | Sí
Permite Lecturas | Sí
Permite Escrituras | Sí (ficheros nuevos. En los existentes con overwrite)
Permite Añadir contenidos | Sí
Permite Lecturas y Escrituras Simultáneas | No
Permite usar la función stat() | Sólo los elementos filesize(), filetype(), file_exists(), is_file(), y is_dir(). Desde PHP 5.1.0: filemtime().
Permite usar la función unlink() | Sí
Permite usar la función rename() | Sí
Permite usar la función mkdir() | Sí
Permite usar la función rmdir() | Sí

Notas

Nota:

Hay soporte para FTPS desde PHP 4.3.0, siempre y cuando se haya compilado con soporte para openssl.

Si el servidor no soporta SSL, entonces la conexión se restablece a una conexión ftp regular sin encriptación.

Nota: Añadiendo contenido
Se puede añadir contenido a los ficheros mediante la envoltura de URL ftp://.

Ver también

  • Opciones de contexto para FTP


Acceso a distintos flujos de E/S

  • « ftp://
  • zlib:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Acceso a distintos flujos de E/S

php://

php:// — Acceso a distintos flujos de E/S

Descripción

PHP ofrece una serie de flujos de E/S generales que permiten acceder tanto a los flujos de entrada y salida de PHP, a la entrada estándar, a descriptores de ficheros de salida y de errores, a flujos de ficheros temporales en memoria y en disco, y a filtros para poder manipular otros recursos de ficheros según se lee desde o se escribe en ellos.

php://stdin, php://stdout y php://stderr

php://stdin, php://stdout y php://stderr permiten acceder directamente al correspondiente flujo de entrada o salida del proceso de PHP. El flujo hace referencia a un descriptor de fichero duplicado, de modo que si se abre php://stdin y más tarde se cierra, sólo se cerraría la copia del descriptor; el flujo real al que se refiere STDIN no se vería afectado. Tenga en cuenta que PHP mostraba un comportamiento irregular en este aspecto hasta PHP 5.2.1. Se recomienda utilizar simplemente las constantes STDIN, STDOUT y STDERR en lugar de abrir flujos manualmente usando estas envolturas.

php://stdin es de sólo lectura, mientras que php://stdout y php://stderr son de sólo escritura.

php://input

php://input es un flujo de sólo lectura que permite leer datos del cuerpo solicitado. En el caso de peticiones POST, es preferible usar php://input en vez de $HTTP_RAW_POST_DATA ya que no depende de directivas php.ini especiales. Sin embargo, cuando no se genera automáticamente $HTTP_RAW_POST_DATA, se trata de una alternativa que hace un uso menos intensivo de memoria que activando always_populate_raw_post_data. php://input no está disponible con enctype="multipart/form-data".

Nota: Antes de PHP 5.6, un flujo abierto con php://input solamente podía leerse una vez; el flujo no admite operaciones de búsqueda. Sin embargo, dependiendo de la implementación de la SAPI, podría ser posible abrir otro flujo php://input y reiniciar la lectura. Esto solamente es posible si los datos del cuerpo de la petición se han guardado. Este caso es típico en peticiones POST, pero no en otros métodos de petición, como PUT o PROPFIND.

php://output

php://output es un flujo de sólo escritura que permite escribir en el buffer de salida tal como lo hacen print y echo.

php://fd

php://fd permite el acceso directo al descriptor de archivo dado. Por ejemplo, php://fd/3 refiere al descriptor de archivo 3.

php://memory y php://temp

php://memory y php://temp son flujos de lectura-escritura que permiten almacenar datos temporales en una envoltura similar a un fichero. La única diferencia entre las dos es que php://memory siempre almacenará sus datos en memoria, mientras que php://temp utilizará un fichero temporal cuando la cantidad de datos almacenados superen el límite predefinido (por omisión, 2 MB). La ubicación de este fichero temporal está determinada de la misma manera que la funciónsys_get_temp_dir(),

El límite de memoria de php://temp se puede controlar añadiendo /maxmemory:NN, donde NN es la cantidad en bytes máxima de datos a almacenar en memoria antes de recurrir a un fichero temporal.

php://filter

php://filter es una especie de meta-envoltura diseñada para permitir aplicar filtros a los flujos en las aperturas. Esto es muy útil en las funciones todo en uno, como readfile(), file(), y file_get_contents() donde, por otra parte, no se pueden aplicar filtros a los flujos antes de que se lea su contenido.

php://filter acepta los siguientes parámetros como parte de su ruta. Se pueden especifcar múltiples filtros en una ruta. Por favor, consulte los ejemplos para los usos concretors de estos parámetros.

parámetros de php://filter
Nombre | Descripción
resource=<flujo a filtrar> | Este parámetro es obligatorio. Especifica el flujo que se desea filtrar.
read=<listra de filtros a aplicar a la cadena de lectura> | Este parámetro es opcional. Se pueden enumerar uno o más filtros, separados por el carácter |.
write=<lista de filtros a aplicar a la cadena de escritura> | Este parámetro es opcional. Se puedene enumerar uno o más filtros, separados por el carácter |.
<lista de filtros a aplicar a las dos cadenas> | Cualquier listra de filtros que no esté precedida ni por read= ni por write= se aplicará tanto a las cadenas de lectura como de escritura según proceda.

Opciones

Resumen de la Envoltura (Para php://filter, consúltese el resumen de la envoltura que se filtra)
Atributo | Permitido
Restringido por allow_url_fopen | No
Restringido por allow_url_include | php://input, php://stdin, php://memory y php://temp solamente.
Permite Lecturas | php://stdin, php://input, php://fd, php://memory y php://temp solamente.
Permite Escrituras | php://stdout, php://stderr, php://output, php://fd, php://memory y php://temp solamente.
Permite Añadir contenidos | php://stdout, php://stderr, php://output, php://fd, php://memory y php://temp solamente. (Equivalente a escrituras)
Permite Lecturas y Escrituras Simultáneas | php://fd, php://memory y php://temp solamente.
Permite usar la función stat() | php://memory y php://temp solamente.
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No
Permite usar la función stream_select() | php://stdin, php://stdout, php://stderr, php://fd y php://temp solamente.

Historial de cambios

Versión | Descripción
5.6.0 | php://input se puede reutilzar.
5.3.6 | Se añadió php://fd.
5.1.0 | Se añadieron php://memory y php://temp.

Ejemplos

Ejemplo #1 php://temp/maxmemory

Este parámetro opcional permite establecer el límite de memoria a partir del cual php://temp comienza a usar un fichero temporal.

<?php
// Establecer el límite a 5 MB.
$fiveMBs = 5 * 1024 * 1024;
$fp = fopen("php://temp/maxmemory:$fiveMBs", 'r+');

fputs($fp, "hello\n");

// Leer lo que hemos escrito.
rewind($fp);
echo stream_get_contents($fp);
?>

Ejemplo #2 php://filter/resource=<flujo a filtrar>

Este parámetro tiene que ubicarse al final de la especificación de php://filter y tiene que apuntar al flujo que se desea filtrar.

<?php
/* Esto es equivalente a:
  readfile("http://www.example.com");
  dado que no se especifica ningún filtro */

readfile("php://filter/resource=http://www.example.com");
?>

Ejemplo #3 php://filter/read=<lista de filtros a aplicar a la cadena de lectura>

Este parámetro contiene uno o más nombres de filtros separados por el caracter |.

<?php
/* Devolverá el contenido de
  www.example.com en mayúsculas */
readfile("php://filter/read=string.toupper/resource=http://www.example.com");

/* Hará lo mismo que el ejemplo de arriba
  pero además lo codificará en ROT13 */
readfile("php://filter/read=string.toupper|string.rot13/resource=http://www.example.com");
?>

Ejemplo #4 php://filter/write=<lista de filtros a aplicar a la cadena de escritura>

Este parámetro contiene uno o más nombres de filtros separados por el caracter |.

<?php
/* Filtrará el string "Hello World" con
  el filtro rot13, y después lo escribirá en
  example.txt dentro del directorio actual */
file_put_contents("php://filter/write=string.rot13/resource=example.txt","Hello World");
?>

Ejemplo #5 php://memory y php://temp no son reutilizables

php://memory y php://temp no son reutilizabes, esto es, debepués de que los flujos hayan sido cerrados, no hay forma de hacer referencia a ellos de nuevo.

file_put_contents('php://memory', 'PHP');
echo file_get_contents('php://memory'); // no imprime nada


Flujos de compresión

  • « php://
  • data:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Flujos de compresión

zlib://

bzip2://

zip://

zlib:// -- bzip2:// -- zip:// — Flujos de compresión

Descripción

zlib: PHP 4.0.4 - PHP 4.2.3 (sólo en sistemas con fopencookie)

compress.zlib:// and compress.bzip2:// PHP 4.3.0 y superior

zlib: funciona como gzopen(), solo que usando el flujo, se puede utilizar con fread() al igual que con otras funciones del sistema de ficheros. Esto quedó obsoleto en PHP 4.3.0 debido a la ambigüedad que surge con los nombres de fichero que contienen el caracter ':'; en su lugar, debe usarse compress.zlib://.

compress.zlib:// y compress.bzip2:// son equivalentes a gzopen() y a bzopen() respectivamente, y funcionan incluso en sistemas que no tienen soporte para fopencookie.

La extensión ZIP registra la envoltura zip:.

Uso

  • compress.zlib://file.gz
  • compress.bzip2://file.bz2
  • zip://archive.zip#dir/file.txt

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Permite Lecturas | Sí
Permite Escrituras | Sí (excepto zip://)
Permite Añadir contenidos | Sí (excepto zip://)
Permite Lecturas y Escrituras Simultaneas | No
Permite usar la función stat() | No, utilice la envoltura file:// para consultar la información de un fichero.
Permite usar la función unlink() | No, utilice la envoltura file:// para eliminar ficheros comprimidos.
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No


Data (RFC 2397)

  • « zlib://
  • glob:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Data (RFC 2397)

data://

data:// — Data (RFC 2397)

Descripción

La envoltura del flujo data: (» RFC 2397) está disponible desde PHP 5.2.0.

Uso

  • data://text/plain;base64,

Opciones

Resumen de la envolutra
Atributo | Permitido
Restringido por allow_url_fopen | No
Restringido por allow_url_include | Sí
Permite Lecturas | Sí
Permite Escrituras | No
Permite Añadir contenido | No
Permite Lectura y Escritura Simultanea | No
Permite usar la función stat() | No
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Ejemplos

Ejemplo #1 Mostrar contenidos de data://

<?php
// muestra "I love PHP"
echo file_get_contents('data://text/plain;base64,SSBsb3ZlIFBIUAo=');
?>

Ejemplo #2 Obtener el Tipo de Medio

<?php
$fp   = fopen('data://text/plain;base64,', 'r');
$meta = stream_get_meta_data($fp);

// muestra "text/plain"
echo $meta['mediatype'];
?>


Encuentra las rutas que coincidan con el patrón

  • « data://
  • phar:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Encuentra las rutas que coincidan con el patrón

glob://

glob:// — Encuentra las rutas que coincidan con el patrón

Descripción

La envoltura del flujo glob: está disponible desde PHP 5.3.0.

Uso

  • glob://

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Restringido por allow_url_include | No
Permite Lecturas | No
Permite Escrituras | No
Permite Añadir Contenidos | No
Permite Lecturas y Escrituras Simultáneas | No
Permite usar la función stat() | No
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Ejemplos

Ejemplo #1 Uso básico

<?php
// Recorrer todos los ficheros *.php del directorio ext/spl/examples/
// y mostrar sus nombres y tamaños
$it = new DirectoryIterator("glob://ext/spl/examples/*.php");
foreach($it as $f) {
    printf("%s: %.1FK\n", $f->getFilename(), $f->getSize()/1024);
}
?>
tree.php: 1.0K
findregex.php: 0.6K
findfile.php: 0.7K
dba_dump.php: 0.9K
nocvsdir.php: 1.1K
phar_from_dir.php: 1.0K
ini_groups.php: 0.9K
directorytree.php: 0.9K
dba_array.php: 1.1K
class_tree.php: 1.8K


Archivo PHP

  • « glob://
  • ssh2:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Archivo PHP

phar://

phar:// — Archivo PHP

Descripción

La envoltura de flujo phar:// está disponible desde PHP 5.3.0. Para consultar una descripción detallada, revise envoltura del flujo Phar.

Uso

  • phar://

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Restringido por allow_url_include | No
Permite Lecturas | Sí
Permite Escrituras | Sí
Permite Añadir contenidos | No
Permite Lectura y Escritura Simultanea | Sí
Permite usar la función stat() | Sí
Permite usar la función unlink() | Sí
Permite usar la función rename() | Sí
Permite usar la función mkdir() | Sí
Permite usar la función rmdir() | Sí

Ver también

  • Opciones de contexto Phar


Secure Shell 2

  • « phar://
  • rar:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Secure Shell 2

ssh2://

ssh2:// — Secure Shell 2

Descripción

ssh2.shell:// ssh2.exec:// ssh2.tunnel:// ssh2.sftp:// ssh2.scp:// (PECL)

Nota: Esta envoltura no está habilitada por omisión
Para poder usarse la envoltura ssh2.*:// debe instalarase la extensión » SSH2 disponible en » PECL.

Además de permitir hacer un login tradicional en la URI, la envoltura ssh2 también puede reutilizar las conexiones ya abiertas, proporcionando el recurso de conexión en el apartado host de la URL.

Uso

  • ssh2.shell://usuario:contraseña@ejemplo.com:22/xterm
  • ssh2.exec://usuario:contraseña@ejemplo.com:22/usr/local/bin/comando
  • ssh2.tunnel://usuario:contraseña@ejemplo.com:22/192.168.0.1:14
  • ssh2.sftp://usuario:contraseña@ejemplo.com:22/ruta/a/fichero

Opciones

Resumen de la Envoltura
Atributo | ssh2.shell | ssh2.exec | ssh2.tunnel | ssh2.sftp | ssh2.scp
Restringido por allow_url_fopen | Sí | Sí | Sí | Sí | Sí
Permite Lecturas | Sí | Sí | Sí | Sí | Sí
Permite Escrituras | Sí | Sí | Sí | Sí | No
Permite Añadir contenidos | No | No | No | Sí (cuando esté soportado por el servidor) | No
Permite Lecturas y Escrituras Simultáneas | Sí | Sí | Sí | Sí | No
Permite usar la función stat() | No | No | No | Sí | No
Permite usar la función unlink() | No | No | No | Sí | No
Permite usar la función rename() | No | No | No | Sí | No
Permite usar la función mkdir() | No | No | No | Sí | No
Permite usar la función rmdir() | No | No | No | Sí | No

Opciones de contexto
Nombre | Uso | Valor por omisión
session | Recurso ssh2 preconectado a utilizar |
sftp | Recurso sftp preubicado a reutilizar |
methods | métodos a usar de entre Key exchange, hostkey, cipher, compression, y MAC |
callbacks |  |
username | Nombre de usuario con el que conectar |
password | Contraseña a utilizar en autenticación con contraseña |
pubkey_file | Nombre del fichero con la clave pública que se usará para autenticar |
privkey_file | Nombre del fichero con la clave privada que se usará para autenticar |
env | Array asociativo con las variables de entorno que se van a asignar |
term | Tipo de emulación del terminal a solicitar cuando se asigne un pty (pseudo terminal) |
term_width | Ancho del terminal solicitado cuando se asigne un pty |
term_height | Altura del terminal solicitado cuando se asigne un pty |
term_units | Unidades a usar con term_width y con term_height | SSH2_TERM_UNIT_CHARS

Ejemplos

Ejemplo #1 Abriendo un flujo a partir de una conexión activa

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$stream = fopen("ssh2.tunnel://$session/remote.example.com:1234", 'r');
?>

Ejemplo #2 ¡La variable $session debe permanecer disponible!

Para utilizar la envoltura ssh2.*://$session debe mantenerse el recurso $session disponible. El código siguiente no tendrá el efecto deseado:

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$connection_string = "ssh2.sftp://$session/";
unset($session);
$stream = fopen($connection_string . "path/to/file", 'r');
?>

unset() cierra la sesión, ya que $connection_string no contiene una referencia a la variable $session, simplemente una representación de la cadena derivada de ella. Esto también ocurre cuando unset() va implícito porque se sale del ámbito (como dentro de una función).


RAR

  • « ssh2://
  • ogg:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • RAR

rar://

rar:// — RAR

Descripción

Esta envoltura se compone de una ruta al fichero RAR (relativa o absoluta) codificada como URL, un asterisco opcional (*), un signo de número opcional (#) y un nombre de entrada codificado como URL que también es opcional, tal como se almacena en el fichero. Cuando se especifique un nombre de entrada, será necesario también especificar un signo de número; además, se puede añadir al final del nombre una barra.

Esta envoltura puede abrir tanto ficheros como directorios. Cuando se abre un directorio, el signo asterisco obliga a que los nombres de las entradas del directorio se devuelvan decodificados. Si no se especifica, se devolverán codificadas como URL – esto es así para permitir hacer un uso correcto de la envoltura con determinadas funcionalidades, como RecursiveDirectoryIterator cuando se está en presencia de nombres de ficheros que podrían parecen datos codificados como URL.

Si no se proporciona ni un signo de número ni tampoco un número de entrada, se mostrará la raíz del fichero. La diferencia respecto a directorios convencionales es que el flujo no contendrá determinada información, tal como la fecha de modificación, dado que el directorio raíz no se almacena dentro el fichero comprimido en de una entrada individual. Para usar la envoltura con RecursiveDirectoryIterator es necesario que al acceder al raíz se incluya el signo de número en la URL, para que así las URLs de los nodos hijo se puedan construir correctamente.

Nota: Esta envoltura no está habilitada por omisión
Para poder usar la envoltura rar://, debe instalarse la extensión » rar disponible en » PECL.

rar:// Disponible desde PECL rar 3.0.0

Uso

  • rar://<nombre de archivo con codificación url>[*][#[<nombre de entrada con codificación url>]]

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Restringido por allow_url_include | No
Permite Lecturas | Sí
Permite Escrituras | No
Permite Añadir contenido | No
Permite Lecturas y Escrituras Simultáneas | No
Permite usar la función stat() | Sí
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Opciones de contexto
Nombre | Uso | Valor por omisión
open_password | Si la hubiera, contraseña utilizada para encriptar las cabeceras del archivo. WinRAR encriptará todos los ficheros con la misma contraseña que la cabecera siempre que ésta esté presente, por lo que se ignorará file_password en archivos que contengan cabeceras encriptadas. |
file_password | Si la hubiera, contraseña utilizada para encriptar un fichero. Si las cabeceras estuvieran también encriptadas, se ignoraría esta opción en favor de open_password. El motivo por el que hay dos opciones es para así cubrir la posibilidad de que haya un archivo con contraseñas diferentes para la cabecera y los ficheros. Tenga en cuenta que si el archivo no tuviera sus cabeceras encriptadas, se ignoraría open_password y tendría que usarse en su lugar esta opción. |
volume_callback | Llamada de retorno que determina la ruta de las partes que no se hayan podido capturar. Para más información, revise RarArchive::open(). |

Ejemplos

Ejemplo #1 Recorriendo un archivo RAR

<?php

class MyRecDirIt extends RecursiveDirectoryIterator {
    function current() {
        return rawurldecode($this->getSubPathName()) .
            (is_dir(parent::current())?" [DIR]":"");
    }
}

$f = "rar://" . rawurlencode(dirname(__FILE__)) .
    DIRECTORY_SEPARATOR . 'dirs_and_extra_headers.rar#';

$it = new RecursiveTreeIterator(new MyRecDirIt($f));

foreach ($it as $s) {
    echo $s, "\n";
}
?>

El resultado del ejemplo sería algo similar a:

|-allow_everyone_ni [DIR]
|-file1.txt
|-file2_?.txt
|-with_streams.txt
\-? [DIR]
  |-?\%2Fempty%2E [DIR]
  | \-?\%2Fempty%2E\file7.txt
  |-?\empty [DIR]
  |-?\file3.txt
  |-?\file4_?.txt
  \-?\?_2 [DIR]
    |-?\?_2\file5.txt
    \-?\?_2\file6_?.txt

Ejemplo #2 Abriendo un fichero encriptado (encriptación de cabeceras)

<?php
$stream = fopen("rar://" .
    rawurlencode(dirname(__FILE__)) . DIRECTORY_SEPARATOR .
    'encrypted_headers.rar' . '#encfile1.txt', "r", false,
    stream_context_create(
        array(
            'rar' =>
                array(
                    'open_password' => 'samplepassword'
                )
            )
        )
    );
var_dump(stream_get_contents($stream));
/* ni la fecha de creación ni la de último acceso es obligatoria WinRAR,
 * por esa razón la mayoría de ficheros no lo tendrán */
var_dump(fstat($stream));
?>

El resultado del ejemplo sería algo similar a:

string(34) "Contenido del fichero encriptado 1"
Array
(
    [0] => 0
    [1] => 0
    [2] => 33206
    [3] => 1
    [4] => 0
    [5] => 0
    [6] => 0
    [7] => 26
    [8] => 0
    [9] => 1259550052
    [10] => 0
    [11] => -1
    [12] => -1
    [dev] => 0
    [ino] => 0
    [mode] => 33206
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 26
    [atime] => 0
    [mtime] => 1259550052
    [ctime] => 0
    [blksize] => -1
    [blocks] => -1
)


Flujos de audio

  • « rar://
  • expect:// »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Flujos de audio

ogg://

ogg:// — Flujos de audio

Descripción

Los ficheros que se abran para lectura usando la envoltura ogg:// se utilizan como codificaciones de audio comprimido usando el códec OGG/Vorbis. De forma similar, los ficheros abiertos para escritura o para añadir contenido usando la envoltura ogg:// se escriben como datos de audio comprimidos. Cuando se use la función stream_get_meta_data() con un fichero OGG/Vorbis abierto para lectura, se devolverán diversos detalles del flujo, incluyendo la etiqueta vendor, cualquier comments que se haya añadido, el número de canales channels, el ratio de muestreo, y el rango del ratio de codificación descrito por: bitrate_lower, bitrate_upper, bitrate_nominal, y bitrate_window.

ogg:// (PECL)

Nota: Esta envoltura no está habilitada por omisión
Para usar la envoltura ogg:// es necesario instalar la extensión » OGG/Vorbis disponible en » PECL.

Uso

  • ogg://soundfile.ogg
  • ogg:///path/to/soundfile.ogg
  • ogg://http://www.example.com/path/to/soundstream.ogg

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Permite Lecturas | Sí
Permite Escrituras | Sí
Permite Añadir contenido | Sí
Permite Lecturas y Escrituras Simultánea | No
Permite usar la función stat() | No
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Opciones de contexto
Nombre | Uso | Valor por omisión | Modo
pcm_mode | codificación PCM que se aplicará en las lecturas, de entre: OGGVORBIS_PCM_U8, OGGVORBIS_PCM_S8, OGGVORBIS_PCM_U16_BE, OGGVORBIS_PCM_S16_BE, OGGVORBIS_PCM_U16_LE, y OGGVORBIS_PCM_S16_LE. (8 o 16 bit, con o sin signo, big o little endian) | OGGVORBIS_PCM_S16_LE | Lectura
rate | Ratio de muestreo en datos de entradas, expresado en Hz | 44100 | Escritura/Adición
bitrate | Si es un entero, definirá el bitrate fijo al que se codificará. (de 16000 a 131072) Si es un real, definirá la calidad del bitrate variable a usar. (de -1.0 a 1.0) | 128000 | Escritura/Adición
channels | El número de canales de audio a codificar, normalmente 1 (mono), o 2 (estéreo). Puede llegar a 16. | 2 | Escritura/Adición
comments | Un array de strings a codificar en la cabecera de la pista. |  | Escritura/Adición

Ejemplos


Flujos de Interacción de Procesos

  • « ogg://
  • Seguridad »
  • PHP Manual
  • Protocolos y Envolturas soportados
  • Flujos de Interacción de Procesos

expect://

expect:// — Flujos de Interacción de Procesos

Descripción

Los flujos que se hayan abierto con la envoltura expect://, darán acceso a stdio, stdout y stderr (entrada, salida y errores estándar respectivamente) de los procesos, vía PTY.

Nota: Esta envoltura no está habilitada por omisión
Para poder usar la envoltura expect:// se debe instalar la extensión » Expect disponible en » PECL.

expect:// (PECL)

Uso

  • expect://command

Opciones

Resumen de la Envoltura
Atributo | Permitido
Restringido por allow_url_fopen | No
Permites Lecturas | Sí
Permite Escrituras | No
Permite Añadir contenido | Sí
Permite Lecturas y Escrituras Simultáneas | No
Permite usar la función stat() | No
Permite usar la función unlink() | No
Permite usar la función rename() | No
Permite usar la función mkdir() | No
Permite usar la función rmdir() | No

Ejemplos


Seguridad

  • Introducción
  • Consideraciones generales
  • Instalado como CGI binario
    • Ataques posibles
    • Caso 1: Ficheros públicos servidos solamente
    • Caso 2: utilizando cgi.force_redirect
    • Caso 3: Configurando doc_root o user_dir
    • Caso 4: El analizador de PHP fuera del árbol de la web
  • Instalado como módulo de Apache
  • Seguridad de una Sesión
  • Seguridad del Sistema de Archivos
    • Cuestiones relacionadas a bytes nulos
  • Seguridad en bases de datos
    • Diseño de bases de datos
    • Conexión a una base de datos
    • Modelo de almacenamiento cifrado
    • Inyección de SQL
  • Reportando errores
  • Datos Enviados por el Usuario
  • Ocultar PHP
  • Mantenerse al día


Introducción

PHP es un potente lenguaje, y su intérprete, bien como módulo del servidor web o bien como binario CGI, puede acceder a ficheros, ejecutar comandos o abrir conexiones de red desde el servidor. Estas propiedades hacen que, por omisión, sea inseguro todo lo que se ejecute en un servidor web. PHP está diseñado específicamente para ser un lenguaje más seguro para escribir aplicaciones CGI que Perl o C. Partiendo de un correcto ajuste de opciones de configuración para tiempo de ejecución y en tiempo de compilación, y el uso de prácticas de programación apropiadas, pueden proporcionarle la combinación de libertad y de seguridad que necesita.

Dado que hay muchas vías para ejecutar PHP, existen muchas opciones de configuración para controlar su comportamiento. Al haber una extensa selección de opciones se garantiza poder usar PHP para un gran número de propósitos, pero a la vez significa que existen combinaciones que conllevan una configuración menos segura.

La flexibilidad de configuración de PHP rivaliza igualmente con la flexibilidad de su código. PHP puede ser usado para construir completas aplicaciones de servidor, con toda la potencia de un usuario de consola, o se puede usar sólo desde el lado del servidor implicando un menor riesgo dentro de un entorno controlado. El cómo construir ese entorno, y cómo de seguro es, depende del desarrollador PHP.

Este capítulo comienza con algunos consejos generales de seguridad, explica las diferentes combinaciones de opciones de configuración y las situaciones en que pueden ser útiles, y describe diferentes consideraciones relacionadas con la programación de acuerdo a diferentes niveles de seguridad.


Consideraciones generales

Un sistema completamente seguro es prácticamente un imposible, de modo que el enfoque usado con mayor frecuencia en la profesión de seguridad es uno que busque el balance adecuado entre riesgo y funcionalidad. Si cada variable enviada por un usuario requiriera de dos formas de validación biométrica (como rastreo de retinas y análisis dactilar), usted contaría con un nivel extremadamente alto de confiabilidad. También implicaría que llenar los datos de un formulario razonablemente complejo podría tomar media hora, cosa que podría incentivar a los usuarios a buscar métodos para esquivar los mecanismos de seguridad.

La mejor seguridad con frecuencia es lo suficientemente razonable como para suplir los requerimientos dados sin prevenir que el usuario realice su labor de forma natural, y sin sobrecargar al autor del código con una complejidad excesiva. De hecho, algunos ataques de seguridad son simples recursos que aprovechan las vulnerabilidades de este tipo de seguridad sobrecargada, que tiende a erosionarse con el tiempo.

Una frase que vale la pena recordar: Un sistema es apenas tan bueno como el eslabón más débil de una cadena. Si todas las transacciones son registradas copiosamente basándose en la fecha/hora, ubicación, tipo de transacción, etc. pero la verificación del usuario se realiza únicamente mediante una cookie sencilla, la validez de atar a los usuarios al registro de transacciones es mermada severamente.

Cuando realice pruebas, tenga en mente que no será capaz de probar todas las diferentes posibilidades, incluso para las páginas más simples. Los datos de entrada que usted puede esperar en sus aplicaciones no necesariamente tendrán relación alguna con el tipo de información que podría ingresar un empleado disgustado, un cracker con meses de tiempo entre sus manos, o un gato doméstico caminando sobre el teclado. Es por esto que es mejor observar el código desde una perspectiva lógica, para determinar en dónde podrían introducirse datos inesperados, y luego hacer un seguimiento de cómo esta información es modificada, reducida o amplificada.

Internet está repleto de personas que tratan de crearse fama al romper la seguridad de su código, bloquear su sitio, publicar contenido inapropiado, y por lo demás haciendo que sus días sean más interesantes. No importa si usted administra un sitio pequeño o grande, usted es un objetivo por el simple hecho de estar en línea, por tener un servidor al cual es posible conectarse. Muchas aplicaciones de cracking no hacen distinciones por tamaños, simplemente recorren bloques masivos de direcciones IP en busca de víctimas. Trate de no convertirse en una.


Instalado como CGI binario

Tabla de contenidos

  • Ataques posibles
  • Caso 1: Ficheros públicos servidos solamente
  • Caso 2: utilizando cgi.force_redirect
  • Caso 3: Configurando doc_root o user_dir
  • Caso 4: El analizador de PHP fuera del árbol de la web


Ataques posibles

Usar PHP como un binario CGI es una opción para configuraciones que por alguna razón no desean integrar PHP como un módulo dentro del software de servidor (como Apache), o usarán PHP con diferentes tipos de envoltorios CGI para crear entornos seguros chroot y setuid para scripts. Esta configuración usualmente involucra la instalación del binario ejecutable de PHP en el directorio cgi-bin del servidor web. La recomendación » CA-96.11 del CERT recomienda que está en contra de colocar cualquiera de los intérpretes dentro de cgi-bin. Aún si el binario de PHP puede ser usado como un intérprete independiente, PHP está diseñado para prevenir los ataques que esta configuración hace posible:

  • Accediendo a los ficheros del sistema: http://mi.servidor/cgi-bin/php?/etc/passwd La consulta de información en una URL después del signo de interrogación (?) es pasado como argumento de la línea de comandos al intérprete por la interfaz del CGI. Usualmente los intérpretes abren y ejecutan el fichero especificado como el primer argumento en la línea de comandos. Cuando es invocado como un binario de CGI, PHP se rehusa a interpretar los argumentos de línea de comandos.
  • Accediendo a cualquier documento web en el servidor: http://mi.servidor/cgi-bin/php/directorio/secreto/doc.html Parte de la ruta de información de la URL después del nombre del binario de PHP, /directorio/secreto/doc.html es convencionalmente utilizado para especificar el nombre del fichero a ser abierto e interpretado por el programa CGI. Usualmente las directivas de configuración de algunos servidores web (Apache: Acción) son utilizados para redirigir peticiones a los documentos como http://mi.servidor/directorio/secreto/script.php al intérprete de PHP. Con esta configuración, el servidor web revisa primero los permisos de acceso a los directorios /directorio/secreto, y después crea la petición redirigida http://mi.servidor/cgi-bin/php/directorio/secreto/script.php. Desafortunadamente, si la petición es proporcionada originalmente en esta forma, no se revisan los accesos a los directorios hechos por el servidor web /directorio/secreto/script.php, sino solamente al fichero /cgi-bin/php. De esta forma /cgi-bin/php cualquier usuario está habilitado a acceder a cualquier documento protegido en el servidor web. En PHP, las directivas de configuración en tiempo de ejecución cgi.force_redirect, doc_root y user_dir pueden ser utilizadas para prevenir este ataque, si el árbol de documentos del servidor tiene cualquiera de estos directorios con restricciones de acceso. Véase más abajo para una explicación completa de las diferentes combinaciones.


Caso 1: Ficheros públicos servidos solamente

Si su servidor no tiene ningún contenido que no esté restringido por contraseña o control de acceso basado en IP, no hay necesidad de estas opciones de configuración. Si su servidor web no le permite hacer redirecciones, o el servidor no tiene una forma de comunicar al binario de PHP que la petición es una forma segura de petición de redireccionamiento, puede especificar la opción --enable-force-cgi-redirect para el script de configuración. Usted todavía tiene que asegurarse que sus scripts de PHP no confían en una forma o en otra para llamar el script, ni directamente http://my.host/cgi-bin/php/dir/script.php ni por redirección http://my.host/dir/script.php.

La redirección puede ser configurada en Apache utilizando directivas Action y AddHandler (vea más abajo).


Caso 2: utilizando cgi.force_redirect

La directiva de configuración cgi.force_redirect previene a cualquiera que llame a PHP directamente por medio de una URL como esta http://mi.servidor/cgi-bin/php/directoriosecreto/script.php. En cambio, PHP solamente lo analizará en este modo si éste se ha ido a través de una regla directa del servidor web.

Usualmente la redirección en la configuración de Apache se hace con las siguientes directivas:

Action php-script /cgi-bin/php
AddHandler php-script .php

Esta opción ha sido probada solamente con el servidor web Apache, y se basa en que en Apache se configure en una variable de entorno no-estándar de CGI REDIRECT_STATUS para peticiones de redirección. Si su servidor web no soporta ninguna forma de decirle si la petición es directa o redirigida, usted no puede utilizar esta opción y debe usar una de las otras formas de ejecutar la versión CGI aquí documentadas.


Caso 3: Configurando doc_root o user_dir

Para incluir contenido activo, como scripts y ejecutables, en los directorios de documentos del servidor web es algunas veces considerado una práctica insegura. Si, por el hecho del algún error de configuración, los scripts no se ejecutan y son mostrados como documentos HTML regulares, esto podría resultar en una fuga de información de propiedad intelectual o de información de seguridad como las contraseñas. Por lo tanto muchos Administradores de Sistemas preferirán configurar otra estructura de directorios para scripts que sean accesibles solamente a través del CGI de PHP, y por lo tanto siempre interpretado y no desplegado como tal.

También si el método para asegurar las peticiones no es redirigido, como se describió en la sección anterior, no está disponible, es necesario configurar un script doc_root que sea diferente de la raíz del documento web.

Usted puede configurar el script de la raíz de documento de PHP en la directiva de configuración doc_root en el fichero de configuración, o puede configurar la variable de entorno PHP_DOCUMENT_ROOT. Si éste es configurado, la versión del CGI de PHP siempre construirá el nombre del fichero para abrir con este doc_root y la ruta de información en la petición, de tal forma que pueda estar seguro que ningún script será ejecutado fuera de este directorio (excepto por user_dir que se encuentra más abajo).

Otra opción utilizable es esta user_dir. Cuando user_dir no está configurado, lo único que controla el fichero abierto es doc_root. Al abrir una URL como http://mi.servidor/~usuario/documento.php no resulta en la apertura de un fichero bajo el directorio personal de los usuarios, pero si un fichero llamado ~usuario/documento.php debajo de doc_root (si, un nombre de directorio que inicia con una a tilde [~]).

Si user_dir es configurado, por ejemplo public_php, una petición como http://mi.servidor/~usuario/doc.php abrirá un fichero llamado doc.php bajo el directorio llamado public_php debajo de el directorio personal del usuario. Si el directorio personal del usuario es /home/usuario, el fichero ejecutado será /home/user/public_php/doc.php.

La expansión de user_dir sucede sin tomar en cuenta la configuración de doc_root, así que usted puede controlar el acceso a la raíz de los documentos y el directorio de los usuarios separadamente.


Caso 4: El analizador de PHP fuera del árbol de la web

Una opción muy segura es poner el binario analizador de PHP en algún lugar fuera del árbol de ficheros de la web. En /usr/local/bin, por ejemplo. El único inconveniente real con esta opción es que ahora tendrá que poner una línea similar a:

#!/usr/local/bin/php
como la primera línea de cualquier fichero que contenga etiquetas de PHP. También necesitará hacer que el fichero sea ejecutable. Eso significa, tratarlo exactamente como trataría cualquier otro script de CGI escrito en Perl, sh, bash, o cualquier otro lenguaje común de script el cual utilice #! como mecanismo de ejecución de si mismo.

Para que PHP maneje la información correctamente de PATH_INFO y PATH_TRANSLATED con esta configuración, el analizador de PHP debería ser compilado con la opción de configuración --enable-discard-path.


Instalado como módulo de Apache

Cuando PHP es usado como un módulo de Apache, hereda los permisos del usuario de Apache (generalmente los del usuario "nobody"). Este hecho representa varios impactos sobre la seguridad y las autorizaciones. Por ejemplo, si se está usando PHP para acceder a una base de datos, a menos que tal base de datos disponga de un control de acceso propio, se tendrá que hacer que la base de datos sea asequible por el usuario "nobody". Esto quiere decir que un script malicioso podría tener acceso y modificar la base de datos, incluso sin un nombre de usuario y contraseña. Es completamente posible que una araña web (bot) pudiera toparse con la página web de administración de una base de datos, y eliminar todo de la base de datos. Una protección ante este tipo de situaciones es mediante el uso del mecanismo de autorización de Apache, o con modelos de acceso de diseño propio usando LDAP, archivos .htaccess, etc. e incluir ese código como parte de los scripts PHP.

Con frecuencia, una vez la seguridad se ha establecido en un punto en donde el usuario de PHP (en este caso, el usuario de apache) tiene asociada muy poco riesgo, se descubre que PHP se encuentra ahora imposibilitado de escribir archivos en los directorios de los usuarios. O quizás se le haya desprovisto de la capacidad de acceder o modificar bases de datos. Se ha prevenido que pudiera escribir tanto archivos buenos como malos, o que pudiera realizar transacciones buenas o malas en la base de datos.

Un error de seguridad cometido con frecuencia en este punto es darle permisos de administrador (root) a apache, o incrementar las habilidades del usuario de apache de alguna otra forma.

Incrementar los permisos del usuario de Apache hasta el nivel de administrador es extremadamente peligroso y puede comprometer al sistema entero, así que el uso de entornos sudo, chroot, o cualquier otro mecanismo que sea ejecutado como root no debería ser considerado como una opción por aquellos que no son profesionales en seguridad.

Existen otras soluciones más simples. Mediante el uso de open_basedir se puede controlar y restringir qué directorios pueden ser usados por PHP. También se pueden definir áreas solo-Apache, para restringir todas las actividades basadas en web a archivos que no son de usuarios o del sistema.


Seguridad de una Sesión

Es importante mantener seguro el manejo de sesión HTTP. La seguridad relacionada a la Sesión está descrita en Seguridad de Sesión en la sección de referencia Módulo de Sesión.


Seguridad del Sistema de Archivos

Tabla de contenidos

  • Cuestiones relacionadas a bytes nulos

PHP está sujeto a la seguridad integrada en la mayoría de sistemas de servidores con respecto a los permisos de archivos y directorios. Esto permite controlar qué archivos en el sistema de archivos se pueden leer. Se debe tener cuidado con los archivos que son legibles para garantizar que son seguros para la lectura por todos los usuarios que tienen acceso al sistema de archivos.

Desde que PHP fue diseñado para permitir el acceso a nivel de usuarios para el sistema de archivos, es perfectamente posible escribir un script PHP que le permita leer archivos del sistema como /etc/passwd, modificar sus conexiones de red, enviar trabajos de impresión masiva, etc. Esto tiene algunas implicaciones obvias, es necesario asegurarse que los archivos que se van a leer o escribir son los apropiados.

Considere el siguiente script, donde un usuario indica que quiere borrar un archivo en su directorio home. Esto supone una situación en la que una interfaz web en PHP es usada regularmente para gestionar archivos, por lo que es necesario que el usuario Apache pueda borrar archivos en los directorios home de los usuarios.

Ejemplo #1 Un control pobre puede llevar a ....

<?php
// eliminar un archivo del directorio personal del usuario
$username = $_POST['user_submitted_name'];
$userfile = $_POST['user_submitted_filename'];
$homedir  = "/home/$username";

unlink("$homedir/$userfile");

echo "El archivo ha sido eliminado!";
?>
Dado que el nombre de usuario y el nombre del archivo son enviados desde un formulario, estos pueden representar un nombre de archivo y un nombre de usuario que pertenecen a otra persona, incluso se podría borrar el archivo a pesar que se supone que no estaría permitido hacerlo. En este caso, usted desearía usar algún otro tipo de autenticación. Considere lo que podría suceder si las variables enviadas son "../etc/" y "passwd". El código entonces se ejecutaría efectivamente como:

Ejemplo #2 ... Un ataque al sistema de archivos

<?php
// elimina un archivo desde cualquier lugar en el disco duro al que
// el usuario de PHP tiene acceso. Si PHP tiene acceso de root:
$username = $_POST['user_submitted_name']; // "../etc"
$userfile = $_POST['user_submitted_filename']; // "passwd"
$homedir  = "/home/$username"; // "/home/../etc"

unlink("$homedir/$userfile"); // "/home/../etc/passwd"

echo "El archivo ha sido eliminado!";
?>
Hay dos medidas importantes que usted debe tomar para prevenir estas cuestiones.
  • Únicamente permisos limitados al usuario web de PHP.
  • Revise todas las variables que se envían.
Aquí está una versión mejorada del script:

Ejemplo #3 Comprobación más segura del nombre de archivo

<?php
// elimina un archivo del disco duro al que
// el usuario de PHP tiene acceso.
$username = $_SERVER['REMOTE_USER']; // usando un mecanismo de autenticación
$userfile = basename($_POST['user_submitted_filename']);
$homedir  = "/home/$username";

$filepath = "$homedir/$userfile";

if (file_exists($filepath) && unlink($filepath)) {
    $logstring = "Se ha eliminado $filepath\n";
} else {
    $logstring = "No se ha podido eliminar $filepath\n";
}
$fp = fopen("/home/logging/filedelete.log", "a");
fwrite($fp, $logstring);
fclose($fp);

echo htmlentities($logstring, ENT_QUOTES);

?>
Sin embargo, incluso esto no está exento de defectos. Si la autenticación del sistema permite a los usuarios crear sus propios inicios de sesión de usuario, y un usuario eligió la entrada "../etc/", el sistema está expuesto una vez más. Por esta razón, puede que prefiera escribir un chequeo más personalizado:

Ejemplo #4 Comprobación más segura del nombre de archivo

<?php
$username     = $_SERVER['REMOTE_USER']; // usando un mecanismo de autenticación
$userfile     = $_POST['user_submitted_filename'];
$homedir      = "/home/$username";

$filepath     = "$homedir/$userfile";

if (!ctype_alnum($username) || !preg_match('/^(?:[a-z0-9_-]|\.(?!\.))+$/iD', $userfile)) {
    die("nombre de usuario o nombre de archivo incorrecto");
}

//etc...
?>

Dependiendo de sus sistema operativo, hay una gran variedad de archivos a los que debe estar atento, esto incluye las entradas de dispositivos (/dev/ o COM1), archivos de configuracion (archivos /etc/ y archivos .ini), las muy conocidas carpetas de almacenamiento (/home/, Mis documentos), etc. Por esta razón, por lo general es más fácil crear una política en donde se prohíba todo excepto lo que expresamente se permite.


Cuestiones relacionadas a bytes nulos

Como PHP utiliza las funciones de C para operaciones relacionadas al sistema de archivos, se podría manejar bytes nulos de manera bastante inesperada. Como un byte nulo denota el fin de una cadena en C, las cadenas que contengan estos no serán consideradas por completo, sino sólo hasta que ocurra un byte nulo. El siguiente ejemplo muestra un código vulnerable que presenta este problema:

Ejemplo #1 Script vulnerable a bytes nulos

<?php
$file = $_GET['file']; // "../../etc/passwd\0"
if (file_exists('/home/wwwrun/'.$file.'.php')) {
    // file_exists devolverá true si el archivo /home/wwwrun/../../etc/passwd existe
    include '/home/wwwrun/'.$file.'.php';
    // el archivo /etc/passwd se incluirá
}
?>

Por lo tanto, cualquier cadena que se utiliza en una operación de sistema de archivos siembre deben ser validados correctamente. He aquí una versión mejorada del ejemplo anterior:

Ejemplo #2 Validando correctamente la entrada

<?php
$file = $_GET['file'];

// Lista blanca de valores posibles
switch ($file) {
    case 'main':
    case 'foo':
    case 'bar':
        include '/home/wwwrun/include/'.$file.'.php';
        break;
    default:
        include '/home/wwwrun/include/main.php';
}
?>


Seguridad en bases de datos

Tabla de contenidos

  • Diseño de bases de datos
  • Conexión a una base de datos
  • Modelo de almacenamiento cifrado
  • Inyección de SQL

Hoy en día, las bases de datos son componentes esenciales de cualquier aplicación web, permitiendo a los sitios web proveer variedad de contenido dinámico. Puesto que se puede almacenar información muy delicada o secreta en una base de datos, debería considerarse ampliamente proteger las bases de datos.

Para obtener o almacenar cualquier información, es necesario conectarse a la base de datos, enviar una consulta válida, obtener el resultado, y cerrar la conexión. Hoy en día, el lenguaje de consultas más utilizado en esta interacción es el Lenguaje Estructurado de Consultas (SQL, por sus siglas en inglés). Vea como un atacante puede realizar manipulaciones maliciosas con una consulta SQL.

Como es de suponer, PHP no puede proteger una base de datos por sí mismo. Las siguientes secciones tienen como objetivo ser una introducción básica de cómo acceder y manipular bases de datos dentro de scripts de PHP.

Tenga en mente esta sencilla regla: Protección en profundidad. En cuantos más sitios se tomen acciones para aumentar la protección de una base de datos, menor es la probabilidad de que un atacante tenga éxito en exponer o abusar de cualquier información que tenga almacenada. Un buen diseño del esquema de la base de datos y de la aplicación se ocupará de sus mayores temores.


Diseño de bases de datos

El primer paso es siempre crear una base de datos, a menos que se quiera utilizar una de un tercero. Cuando se crea una base de datos, esta es asignada a un propietario, aquel que ejecutó la sentencia de creación. Usualmente, sólo el propietario (o un superusuario) puede hacer cualquier cosa con los objetos de esa base de datos. Para que otros usuarios puedan utilizarla, se les deben conceder privilegios.

Las aplicaciones nunca deberían conectarse a la base de datos como su propietario o como un superusuario, porque estos usuarios pueden ejecutar cualquier consulta a su antojo; por ejemplo, modificar el esquema (p.ej., eliminar tablas) o borrar su contenido por completo.

Se pueden crear distintos usuarios de una base de datos para cada aspecto de la aplicación con permisos muy limitados a los objetos de dicha base de datos. Solamente deberían otorgarse los privilegios necesarios, evitando así que el mismo usuario pueda interactuar con la base de datos en diferentes casos y uso. Esto significa que si un intruso obtiene acceso a una base de datos utilizando las credenciales de la aplicación, solamente puede efectuar los cambios que la aplicación permita.


Conexión a una base de datos

Se pueden establecer las conexiones sobre SSL para cifrar las comunicaciones cliente/servidor y aumentar la seguridad, o también emplear ssh para cifrar la conexión de red entre los clientes y el servidor de bases de datos. Si se utiliza algunas de estas opciones, será difícil para un posible atacante la monitorización del tráfico y la obtención de información de la base de datos.


Modelo de almacenamiento cifrado

SSL/SSH protege los datos que viajan desde el cliente al servidor: SSL/SSH no protege los datos persistentes almacenados en una base de datos. SSL es un protocolo que protege los datos mientras viajan por el cable.

Una vez que un atacante obtiene acceso directo a una base de datos (eludiendo el servidor web), los datos sensibles almacenados podrían ser divulgados o mal utilizados, a menos que la información esté protegida por la base de datos misma. Cifrar los datos es una buena forma de mitigar esta amenaza, pero muy pocas bases de datos ofrecen este tipo de cifrado de datos.

La forma más sencilla para evitar este problema es crear primero un paquete de cifrado propio y utilizarlo en los scripts de PHP. Hay muchas extensiones de PHP que pueden ser de ayuda para esto, tales como Mcrypt y Mhash, cubriendo así una amplia variedad de algoritmos de cifrado. El script cifra los datos antes de insertarlos en la base de datos, y los descifra al obtenerlos. Véanse las referencias para ejemplos adicionales del funcionamiento del cifrado.

'Hashing'

En caso de datos que deban estar realmente ocultos, si no fuera necesaria su representación real, (es decir, que no sean mostrados), quizás convenga utilizar algoritmos hash. El ejemplo más típico del uso del hash es a la hora de almacenar el hash criptográfico de una contraseña en una base de datos, en lugar de almacenar la contraseña en sí.

En PHP 5.5 o posterior las funciones de password proporcionan una forma adecuada de utilizar hash con datos delicados y trabajar con estos hash. En PHP 5.3.7+ se puede utilizar también la biblioteca » password_compat.

password_hash() se emplea para usar un hash con una cadena dada utilizando el algoritmo más fuerte actualmente disponible, mientras que password_verify() comprueba si la contraseña dada coincide con el hash almacenado en la base de datos.

Ejemplo #1 Campo de contraseña con hash

<?php

// Almacenar el hash de la contraseña
$consulta  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
                pg_escape_string($nombre_usuario),
                password_hash($contraseña, PASSWORD_DEFAULT));
$resultado = pg_query($conexión, $consulta);

// Consultar si el usuario envió la contraseña correcta
$consulta = sprintf("SELECT pwd FROM users WHERE name='%s';",
                pg_escape_string($nombre_usuario));
$fila = pg_fetch_assoc(pg_query($conexión, $consulta));

if ($fila && password_verify($contraseña, $fila['pwd'])) {
    echo 'Bienvenido, ' . htmlspecialchars($nombre_usuario) . '!';
} else {
    echo 'La autenticación ha fallado para ' . htmlspecialchars($nombre_usuario) . '.';
}

?>

En versiones anteriores de PHP esto se puede realizar con la función crypt().

Ejemplo #2 Contraseña con hash utilizando crypt()

<?php

// Almacenar el hash de la contraseña
// $caracteres_aleatorios se obtuvo, p.ej., utilizando /dev/random
$consulta  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
                 pg_escape_string($nombre_usuario),
                 pg_escape_string(crypt($contraseña, '$2a$07$' . $caracteres_aleatorios . '$')));
$resultado = pg_query($conexión, $consulta);

// Consultar si el usuario envió la contraseña correcta
$consulta = sprintf("SELECT pwd FROM users WHERE name='%s';",
                pg_escape_string($nombre_usuario));
$fila = pg_fetch_assoc(pg_query($conexión, $consulta));

if ($fila && crypt($contraseña, $fila['pwd']) == $fila['pwd']) {
    echo 'Bienvenido, ' . htmlspecialchars($nombre_usuario) . '!';
} else {
    echo 'La autenticación ha fallado para ' . htmlspecialchars($nombre_usuario) . '.';
}

?>


Inyección de SQL

Muchos desarrolladores web no son conscientes de cómo las consultas SQL pueden ser manipuladas, y asumen que una consulta SQL es una orden fiable. Esto significa que las consultas SQL son capaces de eludir controles de acceso, evitando así las comprobaciones de autenticación y autorización estándar, e incluso algunas veces, que las consultas SQL podrían permitir el acceso a comandos al nivel del sistema operativo del equipo anfitrión.

La inyección directa de comandos SQL es una técnica donde un atacante crea o altera comandos SQL existentes para exponer datos ocultos, sobrescribir los valiosos, o peor aún, ejecutar comandos peligrosos a nivel de sistema en el equipo que hospeda la base de datos. Esto se logra a través de la práctica de tomar la entrada del usuario y combinarla con parámetros estáticos para elaborar una consulta SQL. Los siguientes ejemplos están basados en historias reales, desafortunadamente.

Debido a la falta de validación en la entrada de datos y a la conexión a la base de datos con privilegios de superusuario o de alguien con privilegios para crear usuarios, el atacante podría crear un superusuario en la base de datos.

Ejemplo #1 Dividir el conjunto de resultados en páginas ... y crear superusuarios (PostgreSQL)

<?php

$índice    = $argv[0]; // ¡Cuidado, no hay validación en la entrada de datos!
$consulta  = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $índice;";
$resultado = pg_query($conexión, $consulta);

?>
Un usuario común hace clic en los enlaces 'siguiente' o 'atrás' donde el $índice está codificado en el URL. El script espera que el $índice entrante sea un número décimal. Sin embargo, ¿qué pasa si alguien intenta irrumpir anteponiendo a la URL algo como lo siguiente empleando urlencode()?
0;
insert into pg_shadow(usename,usesysid,usesuper,usecatupd,passwd)
    select 'crack', usesysid, 't','t','crack'
    from pg_shadow where usename='postgres';
--
Si esto sucediera, el script podría otrogar un acceso de superusuario al atacante. Observe que 0; es para proveer un índcie válido a la consulta original y así finalizarla.

Nota:

Es una técnica común forzar al analizador de SQL a ignorar el resto de la consulta escrita por el desarrollador con --, lo cual representa un comentario en SQL.

Una forma factible de obtener contraseñas es burlar las páginas de búsqueda de resultados. Lo único que el atacante necesita hacer es ver si hay variables que hayan sido enviadas y sean empleadas en sentencias SQL que no sean manejadas apropiadamente. Estos filtros se pueden establecer comunmente en un formulario anterior para personalizar las cláusulas WHERE, ORDER BY, LIMIT y OFFSET en las sentencias SELECT. Si la base de datos admite el constructor UNION, el atacante podría intentar anteponer una consulta entera a la consulta original para enumerar las contraseñas de una tabla arbitraria. Se recomienda encarecidamente utilizar campos de contraseña encriptadas.

Ejemplo #2 Enumerar artículos ... y algunas contraseñas (cualquier servidor de bases de datos)

<?php

$consulta  = "SELECT id, name, inserted, size FROM products
              WHERE size = '$tamaño'";
$resultado = odbc_exec($conexión, $consulta);

?>
La parte estática de la consulta se puede combinar con otra sentencia SELECT la cual revelará todas las contraseñas:
'
union select '1', concat(uname||'-'||passwd) as name, '1971-01-01', '0' from usertable;
--
Si esta consulta (jugando con ' y --) fuera asignada a una de las variables utilizadas en $consulta, despertaría a la consulta "monstruo".

Las sentecias UPDATE de SQL también son susceptibles a ataques. Estas consultas también están amenazadas por el corte y la anteposición de una consulta completamente nueva. El atacante podría juguetear con la cláusula SET, aunque en este caso, debe poseer algo de información sobre los esquemas para manipular la consulta con éxito. Esta información puede adquirirse examinando los nombres de las variables del formulario, o sencillamente mediante la fuerza bruta. No hay muchas convenciones de nombres para campos que almacenen contraseñas o nombres de usuarios.

Ejemplo #3 Desde restablecer una contraseña ... hasta obtener más privilegios (cualquier servidor de bases de datos)

<?php
$consulta = "UPDATE usertable SET pwd='$pwd' WHERE uid='$uid';";
?>
Pero si un usuario malicioso podría enviar el valor ' or uid like'%admin% a $uid para cambiar la contraseña del administrador, o simplemente cambiar $pwd a jejeje', trusted=100, admin='yes para obtener más privilegios, entonces, la consulta se tornaría:
<?php

// $uid: ' or uid like '%admin%
$consulta = "UPDATE usertable SET pwd='...' WHERE uid='' or uid like '%admin%';";

// $pwd: jejeje', trusted=100, admin='yes
$consulta = "UPDATE usertable SET pwd='jejeje', trusted=100, admin='yes' WHERE
...;";

?>

Un ejemplo turbador de cómo se puede acceder a los comandos a nivel del sistema operativo en algunos equipos anfitriones de bases de datos.

Ejemplo #4 Atacar el sistema operativo que hospeda la base de datos (Servidor MSSQL)

<?php

$consulta  = "SELECT * FROM products WHERE id LIKE '%$prod%'";
$resultado = mssql_query($consulta);

?>
Si un atacante envía el valor a%' exec master..xp_cmdshell 'net user test testpass /ADD' -- a $prod, la $consulta será:
<?php

$consulta  = "SELECT * FROM products
              WHERE id LIKE '%a%'
              exec master..xp_cmdshell 'net user test testpass /ADD' --%'";
$resultado = mssql_query($consulta);

?>
El servidor MSSQL ejecuta la sentencia SQL en el lote incluyendo un comando para añadir un usuario nuevo a la base de datos de cuentas local. Si esta aplicación estuviera ejecutándose como sa y el servicio MSSQLSERVER se estuviera ejecutando con los privilegios suficientes, el atacante ahora podría tener una cuenta con la cual acceder a esta máquina.

Nota:

Algunos de los ejemplos citados están vinculados a un servidor de bases de datos específico. Esto no significa que un ataque similar sea imposible en otros productos. Su servidor de base de datos también podría ser vulnerable de otra manera.

Un ejemplo comprobado de los problemas con respecto a las inyecciones de SQL
Imagen cortesía de » xkcd

Técnicas de evitación

Pese a que pueda parecer obvio que un atacante debe tener al menos algún conocimiento de arquitecturas de bases de datos para poder realizar un ataque con éxito, la obtención de esta información suele ser muy sencilla. Por ejemplo, cuando la base de datos forma parte de un software de código abierto o disponible públicamente con una instalación predefinida, dicha información se encuentra completamente libre y utilizable. Esta información podría haber sido divulgada en proyectos de código cerrado (incluso si está codificada, ofuscada o compilada), o incluso por el propio código mediante la visualización de mensajes de error. Otros métodos incluyen el uso de nombres frecuentes de tablas y columnas. Por ejemplo, un formulario de inicio de sesión que utiliza una tabla 'usuarios' con los nombres de columna 'id', 'username', y 'password'.

Estos ataques se basan principalmente en explotar el código que no ha sido escrito teniendo en cuenta la seguridad. Nunca se ha de confiar en ningún tipo de entrada, especialmente la que viene del lado del cliente, aún cuando esta venga de un cuadro de selección, un campo oculto o una cookie. El primer ejemplo muestra cómo una inofensiva consulta puede causar desastres.

  • Nunca se conecte como superusuario o como propietario de la base de datos. Siempre utilice usuarios personalizados con privilegios muy limitados.
  • Emplee sentencias preparadas con variables vinculadas. Son proporcionadas por PDO, MySQLi y otras bibliotecas.
  • Compruebe si la entrada proporcionada tiene el tipo de datos previsto. PHP tiene un amplio rango de funciones para validar la entrada de datos, desde las más simples, encontradas en Funciones de variables y en Funciones del tipo carácter (p.ej., is_numeric(), ctype_digit() respectivamente), hasta el soporte para Expresiones regulares compatibles con Perl.

  • Si la expresión espera una entrada numérica, considere verificar los datos con la función ctype_digit(), o silenciosamente cambie su tipo utilizando settype(), o emplee su representación numérica por medio de sprintf().

    Ejemplo #5 Una forma más segura de componer una consulta para paginación

    <?php

    settype    ($índice, 'integer');
    $consulta = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $índice;";

    // Observe %d en el string de formato; el uso de %s podría no tener un resultado significativo
    $consulta = sprintf("SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET %d;",
                            $índice);

    ?>

  • Si la capa de la base de datos no admite variables vinculadas, entrecomille cada valor no numérico proporcionado por el usuario que sea pasado a la base de datos con la función de escapado de cadenas específica de la base de datos (p.ej. mysql_real_escape_string(), sqlite_escape_string(), etc.). Las funciones genéricas como addslashes() son útiles solamente en un entorno muy específico (p.ej., MySQL en un juego de caracteres monobyte con NO_BACKSLASH_ESCAPES deshabilitada), por lo que es mejor evitarlas.
  • Sea como sea, no muestre ninguna información específica de la base de datos, especialmente sobre el esquema. Vea también Notificación de errores y Manejo de errores y funciones de registro.
  • Su pueden utilizar procedimientos almacenados y cursores previamente definidos para abstraer el acceso a datos para que los usuarios no tengan acceso directo a las tablas o vistas, aunque que esta solución tiene otros impactos.

Además, se puede beneficiar del registro de consultas, ya sea dentro de un script o mediante la base de datos en sí misma, si es que lo soporta. Obviamente, llevar un registro no previene los intentos dañinos, aunque puede ser útil para realizar un seguimiento de las aplicación que han sido eludidas. El registro no es útil por sí mismo, sino por la información que contiene. Normalmente cuantos más detalles, mejor.


Reportando errores

Con la seguridad de PHP, hay dos formas para reportar errores. Una es en beneficio, para incrementar la seguridad, y la otra es para perjudicar.

Una táctica estándar de ataque conlleva a perfilar un sistema; llenándolo de datos incorrectos, revisando los tipos y contextos de los errores que son devueltos. Esto le permite al atacante recolectar información acerca del servidor, para determinar posibles debilidades. Por ejemplo, si un atacante ha recogido información sobre una página basada en un envío previo, él podría intentar sobrescribir las variables, o modificarlas:

Ejemplo #1 Atacando variables con una página HTML personalizada

<form method="post" action="objetivodelataque?username=badfoo&amp;password=badfoo">
<input type="hidden" name="username" value="badfoo" />
<input type="hidden" name="password" value="badfoo" />
</form>

Los errores de PHP que normalmente son devueltos, pueden ser muy útiles para el desarrollador que está intentando depurar un script, indicando qué cosas, como por ejemplo, qué función o qué fichero de PHP falló, y el número de línea en donde la falla ocurrió. Toda esta es la información que puede ser explotada. Esto no es algo raro para un desarrollador de PHP que utilice las funciones show_source(), highlight_string(), o highlight_file() como una medida de depuración, pero en un sitio en escena, esto puede exponer variables ocultas, sintáxis sin revisar, y otra información peligrosa. Es especialmente peligroso el código en ejecución de fuentes conocidas con manejadores de depuración incluidos, o utilizar técnicas comunes de depuración. Si los atacantes pueden determinar qué técnica en general usted está utilizando, ellos podrían tratar de usar fuerza bruta en una página, enviando varias cadenas comunes de depuración:

Ejemplo #2 Explotando variables comunes de depuración

<form method="post" action="objetivodelataque?errors=Y&amp;showerrors=1&amp;debug=1">
<input type="hidden" name="errors" value="Y" />
<input type="hidden" name="showerrors" value="1" />
<input type="hidden" name="debug" value="1" />
</form>

Sin importar el método de manejo de errores, la capacidad de probar errores en un sistema conlleva a proveer a un atacante con mas información.

Por ejemplo, el estilo común de un error genérico de PHP indica que un sistema ciertamente está ejecutando PHP. Si un atacante está en una página .html, y quiere probar qué motor hay tras de ese servidor (para buscar debilidades en el sistema), lo alimenta con datos erróneos que lo podrían habilitar a que determine que ese sistema fue construido con PHP.

El error de una función puede indicar ya sea, un sistema que puede estar ejecutando un motor específico de base de datos, o dar las pistas de cómo una página web puede estar programada o diseñada. Esto permite una investigación más profunda dentro de los puertos abiertos de la base de datos, o buscar errores específicos o debilidades en una página web. Pasando diferentes porciones de datos erróneos, por ejemplo, un atacante puede determinar el orden de autenticación en un script, (por medio del número de línea de los errores) como también probar exploits que pueden ser utilizados en diferentes ubicaciones del script.

Un error del sistema de archivos o un error general de PHP puede indicar qué permisos tiene el servidor web, así también la estructura y organización de ficheros en el servidor web. El código de error escrito por el desarrollador puede agravar este problema, conllevando a la explotación fácil de la, hasta entonces, información "oculta".

Hay tres grandes soluciones a este problema. La primera consiste en examinar todas las funciones, e intentar arreglar la mayoría de los errores. La segunda es deshabilitar completamente la notificación de errores de el código en ejecución. La tercera es utilizar las funciones de manejo de error propias de PHP para crear su propio manejador de errores. Dependiendo de su política de seguridad, puede ser que encuentre que las tres sean aplicables a su situación.

Una forma de detectar este problema por adelantado es hacer uso de la función propia de PHP error_reporting(), para ayudarle a asegurar su código y encontrar el uso de variables que podrían ser peligrosas. Al probar su código, antes de distribuirlo, con E_ALL, usted puede encontrar rapidamente áreas donde sus variables pueden ser abiertas para envenenamiento o modificación en otras maneras. Una vez usted está listo para distribuirlo, debería deshabilitar completamente el reporte de errores poniendo el valor de error_reporting() a 0, o apagar el visor de errores utilizando la opción display_errors del fichero php.ini para aislar su código de ataques. Si decide hacer esto último, también debería definir la ruta de acceso a su archivo de registros utilizando la directiva error_log, y poner log_errors en "on".

Ejemplo #3 Buscando variables peligrosas con E_ALL

<?php
if ($usuario) {  // No se ha inicializado o revisado antes de utilizar
    $permitir_acceso = 1;
}
if ($permitir_acceso == 1) { // Si la prueba anterior falla, los que no estén inicializados o comprobados antes de utilizar, tendrán acceso
    readfile("/ruta/hacia/datos/altamente/sensibles/index.html");
}
?>


Datos Enviados por el Usuario

Las mayores debilidades de muchos programas PHP no son inherentes al lenguaje mismo, sino simplemente un problema generado cuando se escribe código sin pensar en la seguridad. Por esta razón, usted debería tomarse siempre el tiempo para considerar las implicaciones de cada pedazo de código, para averiguar el posible peligro involucrado cuando una variable inesperada es enviada.

Ejemplo #1 Uso Peligroso de Variables

<?php
// eliminar un archivo del directorio personal del usuario .. ¿o
// quizás de alguien más?

unlink ($variable_malvada);

// Imprimir el registro del acceso... ¿o quizás una entrada de /etc/passwd?
fwrite ($desc_archivo, $variable_malvada);

// Ejecutar algo trivial.. ¿o rm -rf *?
system ($variable_malvada);
exec ($variable_malvada);

?>

Usted debería examinar siempre, y cuidadosamente su código para asegurarse de que cualquier variable siendo enviada desde un navegador web sea chequeada apropiadamente, y preguntarse a sí mismo:

  • ¿Este script afectará únicamente los archivos que se pretende?
  • ¿Puede tomarse acción sobre datos inusuales o indeseados?
  • ¿Puede ser usado este script en formas malintencionadas?
  • ¿Puede ser usado en conjunto con otros scripts en forma negativa?
  • ¿Serán adecuadamente registradas las transacciones?

Al preguntarse adecuadamente estas preguntas mientras escribe su script, en lugar de hacerlo posteriormente, usted previene una desafortunada re-implementación del programa cuando desee incrementar el nivel de seguridad. Al comenzar con esta mentalidad, no garantizará la seguridad de su sistema, pero puede ayudar a mejorarla.

Puede que también desee considerar la deshabilitación de register_globals, magic_quotes, u otros parámetros convenientes que pueden causar confusión sobre la validez, fuente o valor de una determinada variable. Trabajar con PHP en modo error_reporting(E_ALL) también puede ayudarle a advertir variables que están siendo usadas antes de ser chequeadas o inicializadas (de modo que puede prevenir que datos inusuales produzcan operaciones inadvertidas).


Ocultar PHP

En general, la seguridad por ocultación es una de las formas más débiles de seguridad. Aunque en algunos casos, es aconsejable cada pequeño elemento extra de seguridad.

Unas cuantas técnicas simples pueden ayudar a ocultar PHP, posiblemente retrasando a un atacante que esté tratando de descubrir debilidades en el sistema. Al establecer expose_php a off en el fichero php.ini, se reduce la cantidad de información disponible.

Otra táctica es configurar servidores web como Apache para interpretar diferentes tipos de ficheros por medio de PHP, ya sea con una directiva de .htaccess o en el propio fichero de configuración de Apache. Así se pueden utilizar extensiones de ficheros engañosas:

Ejemplo #1 Ocultando PHP como si fuera otro lenguaje

# Hacer que el código de PHP parezca otro tipo de código
AddType application/x-httpd-php .asp .py .pl
U ocultarlo completamente:

Ejemplo #2 Utilizar tipos desconocidos para extensiones de PHP

# Hacer que el código de PHP parezca de tipo desconocido
AddType application/x-httpd-php .bop .foo .133t
U ocultarlo como código HTML, lo cual tiene un pequeño impacto de rendimiento debido a que todos los ficheros HTML serán procesados por el motor de PHP:

Ejemplo #3 Utilizar tipos HTML para extensiones de PHP

# Hacer que el código de PHP parezca HTML
AddType application/x-httpd-php .htm .html
Para que esto funcione eficazmente, se debe cambiar el nombre de los ficheros PHP con las extensiones de arriba. Si bien es una forma de seguridad por ocultamiento, es una medida preventiva menor con pocos inconvenientes.


Mantenerse al día

PHP, como cualquier otro sistema de tamaño considerable, está bajo constante escrutinio y mejoramiento. Cada nueva versión incluye con frecuencia cambios mayores y menores para mejorar la seguridad y reparar cualquier fallo, problemas de configuración, y otros asuntos que puedan afectar la seguridad y estabilidad global del sistema.

Como cualquier lenguaje y programa de script a nivel de sistema, la mejor estrategia es actualizar con frecuencia y mantenerse alerta sobre las últimas versiones y sus cambios.


Características

  • Autenticación HTTP con PHP
  • 'Cookies'
  • Sesiones
  • Manejo de XForms
  • Subida de ficheros
    • Subida con el método POST
    • Explicación de los mensajes de error
    • Dificultades comunes
    • Subida de varios ficheros
    • Soporte para el método PUT
    • Ver también
  • Empleo de ficheros remotos
  • Manejo de conexiones
  • Conexiones persistentes a bases de datos
  • Uso de la línea de comandos — PHP desde la línea de comandos
    • Introducción
    • Diferencias respecto a otras SAPIs
    • Opciones — Opciones de la línea de comandos
    • Uso — Ejecutando ficheros PHP
    • Flujos de E/S — Flujos de entrada/salida
    • Consola interactiva
    • Servidor web interno
    • Configuración INI
  • Recolección de basura
    • Introducción al contador de referencias
    • Recolección de referencias cíclicas
    • Consideraciones acerca del Rendimiento
  • Rastreo Dinámico con DTrace
    • Introducción a PHP y DTrace
    • Usando PHP y DTrace
    • Usando SystemTap con Sondas Estáticas en PHP DTrace


Autenticación HTTP con PHP

Con la función header() se puede enviar un mensaje de "Autenticación requerida" al navegador del cliente para mostrar una ventana emergente donde introducir un usuario y una contraseña. Una vez introducidos estos datos, el URL que contiene el script de PHP será invocado de nuevo con las variables predefinidas PHP_AUTH_USER, PHP_AUTH_PW y AUTH_TYPE establecidas al nombre de usuario, contraseña y tipo de autenticación, respectivamente. Estas variables se encuentran en el array $_SERVER. Se admiten ambos métodos de autenticación, 'Basic' y 'Digest' (desde PHP 5.1.0). Véase la función header() para más información.

Un fragmento de un script de ejemplo que forzaría la autenticación en una página es el siguiente:

Ejemplo #1 Ejemplo de autenticación HTTP 'Basic'

<?php
if (!isset($_SERVER['PHP_AUTH_USER'])) {
    header('WWW-Authenticate: Basic realm="Mi dominio"');
    header('HTTP/1.0 401 Unauthorized');
    echo 'Texto a enviar si el usuario pulsa el botón Cancelar';
    exit;
} else {
    echo "<p>Hola {$_SERVER['PHP_AUTH_USER']}.</p>";
    echo "<p>Introdujo {$_SERVER['PHP_AUTH_PW']} como su contraseña.</p>";
}
?>

Ejemplo #2 Ejemplo de autenticación HTTP 'Digest'

Este ejemplo muestra cómo implementar un sencillo script de autenticación HTTP 'Digest'. Para más información lea el » RFC 2617.

<?php
$dominio = 'Area restringida';

// usuario => contraseña
$usuarios = array('admin' => 'micontraseña', 'invitado' => 'invitado');

if (empty($_SERVER['PHP_AUTH_DIGEST'])) {
    header('HTTP/1.1 401 Unauthorized');
    header('WWW-Authenticate: Digest realm="'.$dominio.
           '",qop="auth",nonce="'.uniqid().'",opaque="'.md5($dominio).'"');

    die('Texto a enviar si el usuario pulsa el botón Cancelar');
}

// Analizar la variable PHP_AUTH_DIGEST
if (!($datos = analizar_http_digest($_SERVER['PHP_AUTH_DIGEST'])) ||
    !isset($usuarios[$datos['username']]))
    die('Credenciales incorrectas');

// Generar una respuesta válida
$A1 = md5($datos['username'] . ':' . $dominio . ':' . $usuarios[$datos['username']]);
$A2 = md5($_SERVER['REQUEST_METHOD'].':'.$datos['uri']);
$respuesta_válida = md5($A1.':'.$datos['nonce'].':'.$datos['nc'].':'.$datos['cnonce'].':'.$datos['qop'].':'.$A2);

if ($datos['response'] != $respuesta_válida)
    die('Credenciales incorrectas');

// Todo bien, usuario y contraseña válidos
echo 'Se ha identificado como: ' . $datos['username'];

// Función para analizar la cabecera de autenticación HTTP
function analizar_http_digest($txt)
{
    // Protección contra datos ausentes
    $partes_necesarias = array('nonce'=>1, 'nc'=>1, 'cnonce'=>1, 'qop'=>1, 'username'=>1, 'uri'=>1, 'response'=>1);
    $datos = array();
    $claves = implode('|', array_keys($partes_necesarias));

    preg_match_all('@(' . $claves . ')=(?:([\'"])([^\2]+?)\2|([^\s,]+))@', $txt, $coincidencias, PREG_SET_ORDER);

    foreach ($coincidencias as $c) {
        $datos[$c[1]] = $c[3] ? $c[3] : $c[4];
        unset($partes_necesarias[$c[1]]);
    }

    return $partes_necesarias ? false : $datos;
}
?>

Nota: Sobre la compatibilidad

Hay que tener cuidado al codificar las líneas de cabeceras HTTP. Para garantizar la mayor compatibilidad con todos los clientes, la palabra 'Basic' debe escribirse con 'B' mayúscula, la cadena del dominio debe estar entre comillas dobles (no simples), y debería haber exactamente un espacio precediendo al código 401 de la línea de la cabecera HTTP/1.0 401. Los parámetros de autenticación deben estar separados por comas, como se vió en el ejemplo de 'Digest' anterior.

En lugar de imprimir simplemente PHP_AUTH_USER y PHP_AUTH_PW como se hizo en el ejemplo anterior, podría ser conveniente validar el usuario y la contraseña, tal vez enviando una consulta a una base de datos o buscando el usuario en un fichero dbm.

Cuidado con los navegadores Internet Explorer defectuosos. Parecen ser muy quisquillosos con el orden de las cabeceras. Por ahora, parece ser que el truco está en enviar la cabecera WWW-Authenticate antes que la cabecera HTTP/1.0 401.

Para prevenir que alguien escriba un script que revele la contraseña de una página que se autenticó con un mecanismo externo tradicional, las variables PHP_AUTH no se establecerán si la autenticación externa está habilitada para esa página en particular. Independientemente, se puede emplear REMOTE_USER para identificar al usuario autenticado externamente. De este modo, se podrá usar $_SERVER['REMOTE_USER'].

Nota: Sobre la configuración

PHP utiliza la presencia de una directiva AuthType para determinar si una autenticación externa está en uso.

Observe, sin embargo, que lo anterior no impide que alguien que controle un URL no autenticado pueda robar contraseñas de URL autenticados en el mismo servidor.

Tanto Netscape Navigator como Internet Explorer borran la caché de autenticación de la ventana del navegador local para el dominio al recibr una respuesta 401 del servidor. Esto, en efecto, puede hacer que se cierre la sesión de un usuario, obligándolo a reintroducir su nombre de usuario y contraseña. Algunos utilizan esto para inicios de sesión «expiradas» o proveer un botón de «Cerrar sesión».

Ejemplo #3 Ejemplo de autenticación HTTP forzando un nuevo usuario/contraseña

<?php
function autenticar() {
    header('WWW-Authenticate: Basic realm="Sistema de autenticación de prueba"');
    header('HTTP/1.0 401 Unauthorized');
    echo "Debe introducir un ID y contraseña de identificación válidos para acceder a este recurso\n";
    exit;
}

if (!isset($_SERVER['PHP_AUTH_USER']) ||
    ($_POST['VistoAntes'] == 1 && $_POST['UsuarioAntiguo'] == $_SERVER['PHP_AUTH_USER'])) {
    autenticar();
} else {
    echo "<p>Bienvenido: " . htmlspecialchars($_SERVER['PHP_AUTH_USER']) . "<br />";
    echo "Antiguo: " . htmlspecialchars($_REQUEST['UsuarioAntiguo']);
    echo "<form action='' method='post'>\n";
    echo "<input type='hidden' name='VistoAntes' value='1' />\n";
    echo "<input type='hidden' name='UsuarioAntiguo' value=\"" . htmlspecialchars($_SERVER['PHP_AUTH_USER']) . "\" />\n";
    echo "<input type='submit' value='Reautenticar' />\n";
    echo "</form></p>\n";
}
?>

El estándar de autenticación HTTP Basic no requiere este funcionamiento, por lo que no se debería depender de ello. Las pruebas con Lynx han mostrado que Lynx no limpia las credenciales de autenticación con una respuesta 401 del servidor, por lo que al presionar «atrás» y luego «adelante» abrirá el recurso nuevamente mientras los requisitos de credenciales no hayan cambiado. Sin embargo, el usuario puede pulsar la tecla '_' para limpiar su información de autenticación.

Para que la Autenticación HTTP funcione en un servidor IIS con la versión CGI de PHP, se debe editar la configuracion de "Seguridad de directorios" de IIS: hacer clic en "Editar" y solo marcar "Acceso anónimo"; todos los demas campos deberían estar sin marcar.

Nota: Sobre IIS:
Para que funcione la Autenticación HTTP con IIS, la directiva de PHP cgi.rfc2616_headers debe establecerse a 0 (el valor predeterminado).


'Cookies'

PHP tiene soporte para las «cookies» de HTTP de forma transparente. Las cookies son un mecanismo por el que se almacenan datos en el navegador remoto para monitorizar o identificar a los usuarios que vuelvan al sito web. Las cookies se pueden configurar con las funciones setcookie() o setrawcookie(). Las cookies son parte de la cabecera HTTP, por lo que setcookie() será invocada antes de enviar cualquier otra salida al navegador. Esta es la misma limitación que tiene la función header(). Se pueden utilizar las funciones del búfer de salida para retrasar la salida del script hasta que se haya decidido si establecer o no alguna cookie o enviar cualquier otra cabecera.

Algunas cookies enviadas desde el cliente serán incluidas automáticamente en el array autoglobal $_COOKIE si variables_order contiene "C". Para asignar varios valores a una sola cookie, simplemente se debe agregar [] al nombre de la cookie.

Para más detalles, incluyendo notas sobre errores de los navegadores, véanse las funciones setcookie() y setrawcookie().


Sesiones

El soporte para sesiones en PHP consiste en una manera de preservar ciertos datos a través de accesos posteriores, lo que permite crear aplicaciones más personalizadas y mejorar el atractivo de un sitio web. Toda la información está en la sección Referencia de sesiones.


Manejo de XForms

» XForms define una variante de los formularios web tradicionales que permite emplearla en una gran variedad de plataformas y navegadores o incluso en medios no tradicionales como los documentos PDF.

La primera diferencia principal en XForms es la forma de enviar el formulario al cliente. » XForms for HTML Authors contiene una descripción detallada de cómo crear XForms; para el propósito de este tutorial únicamente veremos un ejemplo simple.

Ejemplo #1 Un formulario simple de búsqueda con XForms

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Búsqueda</h:title>
 <model>
  <submission action="http://example.com/search"
              method="post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Buscar</label></input>
  <submit submission="s"><label>Ir</label></submit>
 </h:p>
</h:body>
</h:html>

El formulario anterior muestra una caja de entrada de texto (llamada q), y un botón de envío. Al presionar este botón, el formulario se envía a la página indicada por action.

Aquí es donde comienzan a verse las diferencias desde el punto de vista de la aplicación web. En un formulario normal de HTML, los datos serían enviados como application/x-www-form-urlencoded; en el mundo de XForms, esta información es enviada como datos formateados en XML.

Si se elige trabajar con XForms, sería conveniente que los datos se obtuvieran como XML. En tal caso, se puede examinar $HTTP_RAW_POST_DATA para encontrar el documento XML generado por el navegador, el cual se puede pasar al motor de XSLT o al analizador de documentos favorito.

Si no se está interesado en formatear los datos y solo se desea que se carguen en la variable $_POST tradicional, se puede instruir al navegador del cliente para enviarlos como application/x-www-form-urlencoded cambiando el atributo method a urlencoded-post.

Ejemplo #2 Empleo de un Xform para rellenar $_POST

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Búsqueda</h:title>
 <model>
  <submission action="http://example.com/search"
              method="urlencoded-post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Buscar</label></input>
  <submit submission="s"><label>Ir</label></submit>
 </h:p>
</h:body>
</h:html>

Nota: En el momento de escribir esto, muchos navegadores no admiten XForms. Compruebe la versión de su navegador si los ejemplos anteriores fallan.


Subida de ficheros

Tabla de contenidos

  • Subida con el método POST
  • Explicación de los mensajes de error
  • Dificultades comunes
  • Subida de varios ficheros
  • Soporte para el método PUT
  • Ver también


Subida con el método POST

Esta característica permite la subida de ficheros de texto y binarios. Con la autenticación de PHP y las funciones de manipulación de ficheros se tiene control completo sobre quién está autorizado a realizar una subida y qué hay que hacer con el fichero una vez subido.

PHP es capaz de recibir subidas de ficheros de cualquier navegador compatible con el RFC-1867.

Nota: Nota sobre configuraciones relacionadas

Véanse también las directivas file_uploads, upload_max_filesize, upload_tmp_dir, post_max_size y max_input_time de php.ini

PHP también admite el método PUT para subir ficheros tal y como lo utilizan los clientes Netscape Composer y Amaya del W3C. Véase el Soporte para el método PUT para más detalles.

Ejemplo #1 Formulario para la subida de ficheros

Se puede construir una página de subida de ficheros creando un formulario especial parecido a este:

<!-- El tipo de codificación de datos, enctype, DEBE especificarse como sigue -->
<form enctype="multipart/form-data" action="__URL__" method="POST">
    <!-- MAX_FILE_SIZE debe preceder al campo de entrada del fichero -->
    <input type="hidden" name="MAX_FILE_SIZE" value="30000" />
    <!-- El nombre del elemento de entrada determina el nombre en el array $_FILES -->
    Enviar este fichero: <input name="fichero_usuario" type="file" />
    <input type="submit" value="Enviar fichero" />
</form>

El __URL__ del ejemplo anterior se debe sustituir y debe apuntar a un fichero de PHP.

El campo oculto MAX_FILE_SIZE (medido en bytes) debe preceder al campo de entrada del fichero, siendo su valor el tamaño de fichero máximo aceptado por PHP. Se debe utilizar siempre este elemento del formulario, ya que evita a los usuarios la molestia de esperar a que un fichero grande sea transferido sólo para descubrir que falló la transferencia porque era demasiado grande. Hay que tener en cuenta que engañar a esta configuración en el lado del navegador es muy fácil; nunca dependa de que los ficheros que tengan un tamaño mayor sean bloqueados por esta característica. Es simplemente una característica conventiene para los usuarios en el lado cliente de la aplicación. No obstante, la configuración de PHP (en el lado del servidor) para un tamaño máximo no puede ser engañada.

Nota:

Asegúrese de que el formulario de subida de ficheros tiene el atributo enctype="multipart/form-data" o de lo contrario la subida de ficheros no funcionará.

El array global $_FILES contendrá toda la información de los los ficheros subidos. Su contenido en el formulario del ejemplo es el siguiente. Observe que se asume el empleo del nombre fichero_usuario para el fichero subido, tal como se utiliza en el script de ejemplo anterior. Este puede ser cualquier nombre.

$_FILES['fichero_usuario']['name']

El nombre original del fichero en la máquina del cliente.

$_FILES['fichero_usuario']['type']

El tipo MIME del fichero, si el navegador proporcionó esta información. Un ejemplo sería "image/gif". Este tipo MIME, sin embargo, no se comprueba en el lado de PHP y por lo tanto no se garantiza su valor.

$_FILES['fichero_usuario']['size']

El tamaño, en bytes, del fichero subido.

$_FILES['fichero_usuario']['tmp_name']

El nombre temporal del fichero en el cual se almacena el fichero subido en el servidor.

$_FILES['fichero_usuario']['error']

El código de error asociado a esta subida.

Por defecto, los ficheros se almacenan en el directorio temporal predeterminado del servidor, a menos que se haya indicado otra ubicaicón con la directiva upload_tmp_dir en php.ini. Se puede cambiar el directorio predeterminado del servidor estableciendo la variable de entorno TMPDIR en el entorno en que se ejecuta PHP. Configurarlo usando putenv() desde un script de PHP no funcionará. Esta variable de entorno también se puede utilizar para asegurarse de que las demás operaciones están trabajando sobre los ficheros subidos.

Ejemplo #2 Validación de la subida de ficheros

Véanse también las entradas de las funciones is_uploaded_file() y move_uploaded_file() para más información. El siguiente ejemplo procesará la subida de fichero desde un formulario.

<?php
// En versiones de PHP anteriores a la 4.1.0, debería utilizarse $HTTP_POST_FILES en lugar
// de $_FILES.

$dir_subida = '/var/www/uploads/';
$fichero_subido = $dir_subida . basename($_FILES['fichero_usuario']['name']);

echo '<pre>';
if (move_uploaded_file($_FILES['fichero_usuario']['tmp_name'], $fichero_subido)) {
    echo "El fichero es válido y se subió con éxito.\n";
} else {
    echo "¡Posible ataque de subida de ficheros!\n";
}

echo 'Más información de depuración:';
print_r($_FILES);

print "</pre>";

?>

El script de PHP que recibe el fichero subido debería implementar cualquier lógica necesaria para determinar qué se debe hacer con el fichero subido. Se puede, por ejemplo, utilizar la variable $_FILES['fichero_usuario']['size'] para descartar cualquier fichero que sea demasiado pequeño o demasiado grande. Se podría utilizar la variable $_FILES['fichero_usuario']['type'] para descartar cualquier fichero que no corresponda con un cierto criterio de tipo, aunque esto se debe emplear solo como la primera de una serie de comprobaciones debido a que este valor está completamente bajo el control del cliente y no se comprueba en el lado de PHP. También se puede usar $_FILES['fichero_usuario']['error'] y planear la lógica de acuerdo con los códigos de error. Cualquiera que sea la lógica, se debería borrar el fichero del directorio temporal o moverlo a otra ubicación.

Si no se selecciona ningún fichero en el formulario para realizar la subida, PHP devolverá $_FILES['fichero_usuario']['size'] como 0, y $_FILES['fichero_usuario']['tmp_name'] como ninguno.

El fichero será borrado del directorio temporal al final de la solicitud si este no ha sido movido o renombrado.

Ejemplo #3 Subir un array de ficheros

PHP admite la funcionalidad de array en HTML incluso con ficheros.

<form action="" method="post" enctype="multipart/form-data">
<p>Imágenes:
<input type="file" name="imágenes[]" />
<input type="file" name="imágenes[]" />
<input type="file" name="imágenes[]" />
<input type="submit" value="Enviar" />
</p>
</form>
<?php
foreach ($_FILES["imágenes"]["error"] as $clave => $error) {
    if ($error == UPLOAD_ERR_OK) {
        $nombre_tmp = $_FILES["imágenes"]["tmp_name"][$clave];
        // basename() puede evitar ataques de denegació del sistema de ficheros;
        // podría ser apropiado más validación/saneamiento del nombre de fichero
        $nombre = basename($_FILES["imágenes"]["name"][$clave]);
        move_uploaded_file($nombre_tmp, "datos/$nombre");
    }
}
?>

Se puede implementar una barra de progreso de subida de ficheros con el Progreso de subida en sesiones.


Explicación de los mensajes de error

PHP devuelve un código de error apropiado junto con el array de ficheros. El código de error se puede encontrar en el segmento error del array de ficheros que PHP crea durante la subida de ficheros. En otras palabras, el error puede encontrarse en $_FILES['fichero_usuario']['error'].

UPLOAD_ERR_OK

Valor: 0; No hay error, fichero subido con éxito.

UPLOAD_ERR_INI_SIZE

Valor: 1; El fichero subido excede la directiva upload_max_filesize de php.ini.

UPLOAD_ERR_FORM_SIZE

Valor: 2; El fichero subido excede la directiva MAX_FILE_SIZE especificada en el formulario HTML.

UPLOAD_ERR_PARTIAL

Valor: 3; El fichero fue sólo parcialmente subido.

UPLOAD_ERR_NO_FILE

Valor: 4; No se subió ningún fichero.

UPLOAD_ERR_NO_TMP_DIR

Valor: 6; Falta la carpeta temporal. Introducido en PHP 5.0.3.

UPLOAD_ERR_CANT_WRITE

Valor: 7; No se pudo escribir el fichero en el disco. Introducido en PHP 5.1.0.

UPLOAD_ERR_EXTENSION

Valor: 8; Una extensión de PHP detuvo la subida de ficheros. PHP no proporciona una forma de determinar la extensión que causó la parada de la subida de ficheros; el examen de la lista de extensiones cargadas con phpinfo() puede ayudar. Introducido en PHP 5.2.0.


Dificultades comunes

El elemento MAX_FILE_SIZE no puede especificar un tamaño de fichero mayor que el establecido en la directiva upload_max_filesize del fichero php.ini. Por defecto es 2 megabytes.

Si hay un límite de memoria habilitado, podría ser necesario un valor de memory_limit más grande. Asegúrese de establecer un valor de memory_limit lo suficientemente grande.

Si el valor de max_execution_time es demasiado pequeño, la ejecución del script podría exceder este valor. Asegúrese de establecer un valor de max_execution_time lo suficientemente grande.

Nota: max_execution_time solo afecta al tiempo de ejecución del propio script. Todo tiempo empleado en actividades externas a la ejecución del script, tales como las llamadas al sistema con system(), la función sleep(), las consultas a base de datos, el tiempo que tarda el proceso de subida de ficheros, etc., no se incluye para determinar el tiempo máximo que el script ha estado en ejecución.

Advertencia

max_input_time establece el tiempo máximo, en segundos, que al script se le permite recibir información; esto incluye la subida de ficheros. Para ficheros grandes o varios ficheros, o usuarios con conexiones más lentas, podría excederse el valor predeterminado de 60 segundos.

Si el valor de post_max_size se establece demasiado pequeño, los ficheros grandes no podrán ser subidos. Asegúrese de establecer post_max_size lo suficientemente grande.

A partir de PHP 5.2.12, el ajuste de configuración max_file_uploads controla el número máximo de ficheros que se pueden subir en una petición. Si se suben más ficheros que el límite establecido, $_FILES parará de procesar ficheros una vez se alcance este límite. Por ejemplo, si max_file_uploads se establece a 10, $_FILES nunca contendrá más de 10 elementos.

No validar sobre qué fichero se opera podría significar que los usuarios pueden acceder a información delicada de otros directorios.

Por favor, observe que el CERN httpd parece quitar todo lo que empieza con primer espacio en blanco en la cabecera de tipo de contenido MIME que recibe desde el cliente. Mientras este sea el caso, el CERN httpd no tendrá soporte para la funcionalidad de subida de ficheros.

Debido a la gran cantidad de estilos de listados de directorios, no podemos garantizar que los ficheros con nombres exóticos (como el que contiene espacios en blanco) se manejen adecuadamente.

Los desarrolladores no deben mezclar los campos input normales con los de subida de ficheros en la misma variable de formulario (mediante un nombre de input como foo[]).


Subida de varios ficheros

Se pueden subir varios ficheros utilizando diferentes name para los input.

También es posible subir varios ficheros simultáneamente y tener la información organizada automáticamente en arrays. Para ello es necesario utilizar la misma sintaxis de presentación de array en el formulario HTML, tal como se hace con 'selects' y 'checkboxes' múltiples:

Ejemplo #1 Subida de varios ficheros

<form action="file-upload.php" method="post" enctype="multipart/form-data">
  Enviar estos ficheros:<br />
  <input name="fichero_usuario[]" type="file" /><br />
  <input name="fichero_usuario[]" type="file" /><br />
  <input type="submit" value="Enviar ficheros" />
</form>

Cuando se envía el formulario de arriba, se inicializarán los arrays $_FILES['fichero_usuario'], $_FILES['fichero_usuario']['name'] y $_FILES['fichero_usuario']['size'] serán inicializados.

Por ejemplo, suponga que se envían los nombres de fichero /home/test/review.html y /home/test/xwp.out. En este caso,$_FILES['fichero_usuario']['name'][0] contendría el valor review.html, y $_FILES['fichero_usuario']['name'][1] contendría el valor xwp.out. De manera similar, $_FILES['fichero_usuario']['size'][0] contendría el tamaño del fichero review.html, y así sucesivamente.

También se establecen $_FILES['fichero_usuario']['name'][0], $_FILES['fichero_usuario']['tmp_name'][0], $_FILES['fichero_usuario']['size'][0], y $_FILES['fichero_usuario']['type'][0].

Advertencia

A partir de PHP 5.2.12, el ajuste de configuración max_file_uploads actúa como límite del número de ficheros que se pueden subir en una petición. Es necesario asegurarse de que el formulario no intente subir más ficheros que este límite en una petición.


Soporte para el método PUT

PHP ofrece soporte para el método PUT de HTTP utilizado por algunos clientes para almacenar ficheros en un servidor. Las peticiones PUT son mucho más simples que una subida de ficheros mediante peticiones POST. Se ven algo como esto:

PUT /ruta/nombrefichero.html HTTP/1.1

Esto normalmente significaría que el cliente remoto quiere guardar el contenido que le sigue como: /ruta/nombrefichero.html en el árbol web. Obviamente, no es una buena idea que Apache o PHP permitan a todo el mundo sobrescribir automáticamente cualquier fichero del árbol web. Por tanto, para manejar tales peticiones se debe primero indicar al servidor web que cierto script de PHP maneje la petición. En Apache, esto se hace con la directiva Script. Esta se puede colocar casi en cualquier parte del fichero de configuración de Apache. Un lugar común es dentro de un bloque <Directory> o tal vez dentro de un bloque <VirtualHost>. Una línea como ésta resolvería el problema:

Script PUT /put.php

Esto le indica a Apache que envíe todas las peticiones PUT para los URI que coincidan con el contexto en el cual se pone esta línea en el script put.php. Se asume, por supuesto, que se tiene habilitado PHP para la extensión .php y que PHP está activo. El recurso de destino para todas las peiticiones PUT a este script tiene que ser el propio script, no el nombre de fichero que debería tener el fichero subido.

Entonces, con PHP se haría algo como lo siguiente en el fichero put.php. Se copiaría el contenido del fichero subido al fichero mificheroput.ext en el servidor. Podría ser conveniente realizar algunas comprobaciones y/o autenticar al usuario antes de realizar esta copia del fichero.

Ejemplo #1 Guardar ficheros PUT de HTTP

<?php
/* Los datos de PUT vienen en el flujo de entrada estándar */
$datosPUT = fopen("php://input", "r");

/* Abrir un fichero para escritura */
$fp = fopen("mificheroput.ext", "w");

/* Leer 1 KB de datos cada vez
   y escribir en el fichero */
while ($datos = fread($datosPUT, 1024))
  fwrite($fp, $datos);

/* Cerrar los flujos */
fclose($fp);
fclose($datosPUT);
?>


  • « Soporte para el método PUT
  • Empleo de ficheros remotos »
  • PHP Manual
  • Subida de ficheros
  • Ver también

Ver también

  • Seguridad del sistema de ficheros


Empleo de ficheros remotos

Siempre que allow_url_fopen esté habilitado en php.ini, se pueden usar los URL de HTTP y FTP con la mayoría de las funciones que toman un nombre de fichero como parámetro. Además, los URL se pueden emplear con las sentencias include, include_once, require y require_once (desde PHP 5.2.0, allow_url_include debe estar habilitado para ello). Véanse Protocolos y Envolturas soportados para más información sobre los protocolos admitidos por PHP.

Por ejemplo, se puede emplear para abrir un fichero en un servidor web remoto, analizar la salida de los datos deseados, y usar dichos datos en una consulta a una base de datos, o simplemente para mostrarlos en un estilo que haga juego con el del sitio web.

Ejemplo #1 Obtener el título de una página remota

<?php
$fichero = fopen ("http://www.example.com/", "r");
if (!$fichero) {
    echo "<p>Imposible abrir el fichero remoto.\n";
    exit;
}
while (!feof ($fichero)) {
    $línea = fgets ($fichero, 1024);
    /* Esto solo funciona si el título y sus etiquetas están en una línea */
    if (preg_match ("@\<title\>(.*)\</title\>@i", $línea, $salida)) {
       $título = $salida[1];
        break;
    }
}
fclose($fichero);
?>

También se puede escribir en ficheros de un servidor FTP (siempre que se esté conectado como un usuario con los permisos de acceso correctos). Con este método solamente se pueden crear ficheros nuevos. Si se intenta sobreescribir un fichero que ya existe, la llamada a la función fopen() fallará.

Para conectarse como un usuario distinto a 'anonymous', es necesario especificar el nombre de usuario (y posiblemente la contraseña) dentro del URL, tal como 'ftp://usuario:contraseña@ftp.example.com/ruta/al/fichero'. (Se puede utilizar la misma sintaxis para acceder a ficheros mediante HTTP cuando se requiera autenticación básica).

Ejemplo #2 Almacenar datos en un servidor remoto

<?php
$fichero = fopen ("ftp://ftp.example.com/incoming/outputfile", "w");
if (!$fichero) {
    echo "<p>Imposible abrir el fichero remoto para escritura.\n";
    exit;
}
/* Escribir los datos aqui. */
fwrite ($fichero, $_SERVER['HTTP_USER_AGENT'] . "\n");
fclose ($fichero);
?>

Nota:

Con el ejemplo anterior, se podría tener la idea de que se puede emplear esta técnica para escribir un fichero de registro remoto. Desafortunadamente esto no funcionaría porque la llamada a la función fopen() fallará si el fichero remoto ya existe. Para realizar registros distribuidos como ese, debería echar un vistazo a syslog().


Manejo de conexiones

Internamente, en PHP se mantiene un estado de conexión. Hay 4 posibles estados:

  • 0 - NORMAL
  • 1 - ABORTED
  • 2 - TIMEOUT
  • 3 - ABORTED y TIMEOUT

Cuando un script de PHP está ejecutándose normalmente está activo el estado NORMAL (normal). Si el cliente remoto se desconecta, se activa el indicador de estado ABORTED (abortada). Un cliente remoto se desconecta normalmente porque presiona su botón STOP. Si se alcanza el tiempo límite impuesto por PHP (véase set_time_limit()), se activa el indicador de estado TIMEOUT (expirada).

Se puede decidir si se desea que un cliente que se desconecte ocasione que se aborte el script. Algunas veces es útil que los scripts se ejecuten hasta su finalización, incluso si ya no hay un navegador remoto recibiendo la salida. Sin embargo, el comportamiento predeterminado es que el script sea abortado cuando el cliente remoto se desconecte. Este comportamiento puede ser establecido a través de la directiva ignore_user_abort de php.ini, así como a través de la directiva correspondiente de Apache php_value ignore_user_abort de httpd.conf, o con la función ignore_user_abort(). Si se decide no indicarle a PHP que ignore que el usuario aborte y el usuario aborta, el script finalizará. La única excepción es si se tiene registrada una función de apagado con register_shutdown_function(). Con una función de apagado, cuando el usuario remoto activa el botón STOP, la próxima vez que el script intente mostrar algo, PHP detectará que la conexión fue abortada, llamando así a la función de apagado. Esta función de apagado también se invoca al final del script cuando finaliza normalmente, así que para hacer algo diferente en caso de que un cliente se desconecte, se puede emplear la función connection_aborted(). Esta función devolverá true si la conexión fue abortada.

El script puede ser finalizado también por el temporizador de script incorporado. El tiempo predeterminado es de 30 segundos. Se puede cambiar con la directiva max_execution_time de php.ini o la correspondiente de Apache php_value max_execution_time de httpd.conf, así como con la función set_time_limit(). Cuando el temporizador expira, el script se abortará y, como el caso del cliente anterior que se desconectó, si la función de apagado ha sido registrada, será llamada. Dentro de esta función de apagado se puede comprobar si el tiempo de espera causó la llamada a la función de apagado invocando a la función connection_status(). Esta función devolverá 2 si el tiempo de espera causó la llamada a la función de apagado.

Una cosa a observar es que los estados ABORTED y TIMEOUT pueden estar activados al mismo tiempo. Esto es posible si se le indica a PHP que ignore los abortos que ocasione el usuario. PHP notará de hecho que un usuario podría haber roto la conexión, pero el script se mantendrá ejecutándose. Si entonces se alcanza el límite de tiempo, será abortado y la función de apagado, si la hubiera, será llamada. En este punto se encontrará que connection_status() devuelve 3.


Conexiones persistentes a bases de datos

Las conexiones persistentes son enlaces que no se cierran al finalizar la ejecución de un script. Cuando se solicita una conexión persistente, PHP comprueba si ya hay una idéntica (que ya estuviera abierta antes), utilizándola si existe. Si no, crea el enlace. Una conexión «idéntica» es una conexión que fue abierta por el mismo host, con el mismo usuario y la misma contraseña (donde sea aplicable).

Aquellos que no están plenamente familiarizados con la forma en que trabajan y distribuyen la carga los servidores web podrían confundir para qué sirven las conexiones persistentes. En particular, con ellas no se pueden abrir «sesiones de usuario» en un mismo enlace, no se puede construir una transacción eficiente y no hacen muchísimas otras cosas. De hecho, para ser sumamente precisos, las conexiones persistentes no proporcionan ninguna otra funcionalidad que no fuera posible realizar con sus hermanas no persistentes.

¿Por qué?

Esto tiene que ver con la manera en que los servidores web funcionan. Existen tres formas en las cuales un servidor web puede generar páginas web usando PHP.

El primer método es emplear PHP como una «envoltura» CGI. Cuando se ejecuta de esta forma, se crea y se destruye una instancia del intérprete de PHP por cada solicitud de página (para una página de PHP) al servidor web. Debido a que esta instancia se destruye después de cada solicitud, cualquier recurso que adquiera (tal como un enlace a un servidor de base de datos SQL) es cerrado en la destrucción de dicha instancia. En este caso, no se gana nada utilizando conexiones persistentes: simplemente no persisten.

El segundo método, y más popular, es ejecutar PHP como módulo en un servidor web multiproceso, lo que actualmente solo incluye a Apache. Un servidor multiproceso normalmente tiene un proceso (el padre) que coordina un grupo de procesos (sus hijos) los cuales son los que realmente hacen el trabajo de servir páginas web. Cuando una solicitud proviene de un cliente, esta es cedida a uno de los hijos que no esté ya sirviendo a otro cliente. Esto significa que cuando el mismo cliente hace una segunda solicitud al servidor, esta podría ser servida por un proceso hijo diferente a la primera vez. Cuando se abre una conexión persistente, cada página que solicite servicios SQL puede reusar la misma conexión establecida al servidor SQL.

El último método es utilizar PHP como complemento para un servidor web multihilo. Actualmente, PHP 4 tiene soporte para ISAPI, WSAPI, y NSAPI (en Windows), las cuales permiten usar PHP como un complemento en servidores multihilo como Nestcape FastTrack (iPlanet), Microsoft Internet Information Server (IIS), y O'Reilly's WebSite Pro. El comportamiento es esencialmente el mismo para el modelo multiproceso descrito antes.

Si las conexiones persistentes no tienen ninguna funcionalidad adicional, ¿para que son útiles?

La respuesta es extremadamente simple: Eficacia. Las conexiones persistentes son buenas si la sobrecarga para crear enlaces al servidor SQL es alta. Que esta sobrecarga sea realmente alta o no depende de muchos factores, como el tipo de base de datos que se emplea, si esta se encuentra en la misma computadora en la que está el servidor web, la carga de la máquina donde está el servidor SQL, etc. En resumidas cuentas, si la sobrecarga de una conexión es alta, las conexiones persistentes ayudan considerablemente, haciendo que un proceso hijo únicamente se conecte una vez durante su vida útil, en lugar de hacerlo cada vez que procese una página que requiera una conexión al servidor SQL. Esto significa que cada hijo que abra una conexión persistente tendrá su propia conexión persistente abierta al servidor. Por ejemplo, si se tienen 20 procesos hijos diferentes que ejecutan un script que realiza una conexión persistente al servidor SQL, se tendrán 20 conexiones diferentes al servidor SQL, una por cada hijo.

Observe, sin embargo, que esto puede tener algunos inconvenientes si se está usando una base de datos con un limite de conexiones que sea excedido por las conexiones persistentes hijas. Si la base de datos tiene un limite de 16 conexiones simultáneas, y en el curso de una sesión de un servidor ocupado 17 hilos hijos intentan conectarse, uno de ellos no será capaz de hacerlo. Si un script contiene errores que impidan el cierre de las conexiones (como un bucle infinito), la mencionada base de datos con solamente 16 conexiones podría saturarse rápidamente. Compruebe la documentación de su base de datos para obtener información sobre el manejo conexiones abandonadas o inactivas.

Advertencia

Hay un par de advertencias más a tener en cuenta cuando se utilizan conexiones persistentes. Una es que cuando se usan bloqueos de tablas con una conexión persistente, si el script por alguna razón no puede liberar el bloqueo, los scripts subsiguientes que empleen la misma conexión quedarán en espera indefinidamente, puediendo ser necesario reiniciar el servidor httpd o el servidor de la base de datos. Otra cosa es que cuando se usan transacciones, un bloque de las mismas también acarrearía al siguiente script que utiliza la conexión si la ejecución del script termina antes de que el bloque lo haga. En cualquier caso, se puede usar register_shutdown_function() para registrar una función de limpieza para desbloquear las tablas o deshacer las transacciones. Mejor aún, evitar este problema por completo no usando conexiones persistentes en scripts que utilicen bloqueos de tablas o transacciones (aún se pueden usar en otros lugares).

Un resumen importante. Las conexiones persistentes fueron diseñadas para tener una correspondencia uno a uno con las conexiones normales. Esto significa que siempre se pueden reemplazar las conexiones persistentes por conexiones no persistentes, no cambiando así la forma de funcionar un script. Esto podría (y probablemente lo hará) cambiar la eficacia del script, aunque no su funcionamiento.

Véanse también fbsql_pconnect(),
ibase_pconnect(), ifx_pconnect(),
ingres_pconnect(),
msql_pconnect(), mssql_pconnect(),
mysql_pconnect(), ociplogon(),
odbc_pconnect(), oci_pconnect(),
pfsockopen(), pg_pconnect() y
sybase_pconnect().


PHP desde la línea de comandos

Tabla de contenidos

  • Introducción
  • Diferencias respecto a otras SAPIs
  • Opciones
  • Uso
  • Flujos de E/S
  • Consola interactiva
  • Servidor web interno
  • Configuración INI


Introducción

El principal objetivo de la SAPI CLI es el desarrollo de aplicaciones de consola con PHP. En este capítulo se explican las diferencias que hay entre la SAPI CLI y otras SAPI. Vale la pena aclarar que CLI y CGI son SAPI diferentes pese a que comparten la mayoría de características.

La SAPI CLI se habilita por omisión con --enable-cli, aunque puede deshabilitarse usando la opción --disable-cli al ejecutar ./configure.

Tanto el nombre, ubicación y presencia de los binarios de CLI/CGI diferirán dependiendo de cómo se instale PHP en el sistema. Al ejecutar make de manera predeterminada, CGI y CLI se construyen y ubican como sapi/cgi/php-cgi y sapi/cli/php respectivamente, en el directorio origen de PHP. Debe tenerse en cuenta que las dos se llaman php. Lo que suceda durante la ejecución de make install dependerá de la línea de configuración. Si durante la configuración se elige una SAPI de módulo, tal como apxs, o bien se usa la opción --disable-cgi, se copiará CLI a {PREFIJO}/bin/php al ejecutar make install; de lo contrario se colocará CGI ahí. Por ejemplo, si se utiliza --with-apxs en la línea de configuración, CLI se copiaría a {PREFIJO}/bin/php durante make install. Si se desea sobrescribir la instalación del binario de CGI, debe usarse make install-cli tras make install. Alternativamente se puede especificar --disable-cgi en la línea de configuración.

Nota:

Ya que tanto --enable-cli como --enable-cgi están habilitadas predeterminadamente, el simple hecho de tener --enable-cli en la línea de configuración no implica que CLI se copie como {PREFIJO}/bin/php durante make install.

Desde PHP 5, en Windows el binario de CLI se distribuye en la carpeta principal con el nombre de php.exe. La versión CGI se distribuye como php-cgi.exe. Además, se distribuye un fichero php-win.exe si PHP se configuró con --enable-cli-win32. Este funciona igual que la versión CLI, solo que no muestra ninguna salida y, por tanto, no proporciona ninguna consola.

Nota: ¿Qué SAPI tengo?

Desde la consola, al escribir php -v sabremos si php es CGI o CLI. Véase también la función php_sapi_name() y la constante PHP_SAPI.

Nota:

En Unix hay disponible una página del manual escribiendo man php en la terminal.


Diferencias respecto a otras SAPIs

Principales diferencias de la SAPI CLI respecto a otras SAPI:

  • A diferencia de la SAPI CGI, no se envía ninguna cabecera a la salida.

    Pese a que la SAPI CGI tiene un mecanismo para suprimir las cabeceras HTTP, no existe un equivalente para habilitarlas en la SAPI CLI.

    Por omisión, CLI se inicia en modo silencioso, si bien se mantienen las opciones -q y --no-header por motivos de compatibilidad, de forma que pueda ser posible utilizar antiguos scripts CGI.

    No se cambia el directorio de trabajo al del script (las opciones -C y --no-chdir se mantienen por compatibilidad).

    Mensajes de error en texto plano (no se formatean en HTML).

  • Hay ciertas directivas de php.ini que se ignoran en la SAPI CLI debido a que no tienen sentido en un entorno de consola:

    Directivas php.ini anuladas
    Directiva | Valor predeterminado en la SAPI CLI | Comentario
    html_errors | false | Su valor predeterminado es false, ya que puede resultar complicado leer mensajes de error en la consola cuando estos están mezclados con etiquetas HTML no interpretadas.
    implicit_flush | true | En un entorno de consola, es preferible que las salidas que procedan de print, echo y y similares se muestren inmediatamente y no se mantenga en memoria intermedia. Aun así, es posible utilizar output buffering para postergar o manipular la salida estándar.
    max_execution_time | 0 (ilimitado) | PHP, en un entorno de consola, tiende a utilizarse para una gama mucho más amplia de los propósitos típicos de scripts basados en web, y como éstos pueden ser de muy larga duración, el tiempo de ejecución máximo se establece a ilimitado.
    register_argc_argv true

    Establecer esta directiva a true significa que los scripts ejecutados mediante la SAPI CLI siempre tienen acceso a argc (número de argumentos que se le pasan a la aplicación) y argv (array con los argumentos en sí).

    Las variables de PHP $argc y $argv se establecen automáticamente al valor apropiado cuando se utiliza la SAPI CLI. Esos valores se pueden encontrar también en el array $_SERVER, por ejemplo: $_SERVER['argv']

    output_buffering false

    Aunque la directiva php.ini está codificada como false, las funciones del buffer de salida sí están disponibles.

    max_input_time false

    CLI de PHP no tiene soporte para GET, POST o subidas de ficheros.

    Nota:

    Estas directivas no pueden ser inicializadas con otro valor desde el fichero de configuración php.ini o con un valor personalizado (si se especifica). Esta limitación se debe a que los valores son aplicados después que todos los ficheros de configuración han sido analizados. Sin embargo, sus valores pueden ser cambiados en tiempo de ejecución (aunque esto no es aplicable a todas ellas, como register_argc_argv).

    Nota:

    Se recomienda establecer ignore_user_abort en scripts de línea de comandos. Para más información, consulte ignore_user_abort().

  • Para facilitar el trabajo en entornos de consola, se definen varias constantes para flujos de entrada/salida.

  • La SAPI CLI no cambia el directorio actual a aquel en el que se encuentra el script ejecutado.

    Ejemplo #1 Ejemplo que muestra las diferencias respecto a la SAPI CGI:

    <?php
    // Aplicación de pruebas llamada test.php
    echo getcwd(), "\n";
    ?>

    Al usar la versión CGI, la salida es:

    $ pwd
/tmp

$ php -q otro_directorio/test.php
/tmp/otro_directorio

    Esto muestra claramente que PHP cambia el directorio actual a aquel en que se encuentre el script ejecutado.

    Al usar la SAPI CLI se obtiene:

    $ pwd
/tmp

$ php -f otro_directorio/test.php
/tmp

    Esto ofrece una gran flexibilidad a la hora de escribir herramientas de consola en PHP.

    Nota:

    La SAPI CGI admite este comportamiento propio de la SAPI CLI mediante la opción -C al ejecutarlo desde la línea de comandos.


Opciones de la línea de comandos

Se puede consultar en cualquier momento la lista de opciones de línea de comandos en el binario de PHP con el modificador -h:

Usage: php [opciones] [-f] <fichero> [--] [args...]
   php [opciones] -r <código> [--] [args...]
   php [opciones] [-B <código_inicial>] -R <código> [-E <código_final>] [--] [args...]
   php [opciones] [-B <código_inicial>] -F <fichero> [-E <código_final>] [--] [args...]
   php [opciones] -- [args...]
   php [opciones] -a

  -a                      Se ejecuta interactivamente.
  -c <ruta>|<fichero>     Busca el fichero php.ini en este directorio.
  -n                      No se usará el fichero php.ini.
  -d foo[=bar]            Define la entrada INI de foo con el valor 'bar'
  -e                      Generate información extendida para el depurador/perfilador.
  -f <fichero>            Analiza y ejecuta el <fichero>.
  -h                      Esta ayuda.
  -i                      Información de PHP.
  -l                      Solamente revisa la sintáxis (lint).
  -m                      Muestra lo compilado en módulos.
  -r <code>               Ejecuta el <código> PHP sin utilizar las etiquetas del script <?..?>.
  -B <código_inicial>     Ejecuta el <código_inicial> antes de procesar las líneas de entrada.
  -R <code>               Ejecuta el <código> PHP por cada línea de entrada.
  -F <file>               Analiza y ejecuta el <fichero> por cada línea de entrada.
  -E <código_final>       Ejecuta el <código_final> después de procesar todas las líneas de entrada.
  -H                      Oculta los argumentos pasados desde cualquier herramienta externa.
  -S <dirección>:<puerto> Ejecuta con el servidor web interno.
  -t <raíz_documento>     Especifica la raíz del documento <raíz_documento> para el servidor web interno.
  -s                      Salida de la fuente en sintáxis HTML resaltada.
  -v                      Número de versión.
  -w                      Salida de la fuente con espacios en blanco y comentarios subrayados.
  -z <fichero>            Carga un <fichero> con extensión de Zend.

  args...                 Argumentos pasados al script. Utilice argumentos con -- cuando el primer argumento
                          inicie con - o el script sea leído desde la entrada estándar stdin

  --ini                   Muestra los nombres de fichero de configuración.

  --rf <nombre>           Muestra información sobre la función <nombre>.
  --rc <nombre>           Muestra información acerca de la clase <nombre>.
  --re <nombre>           Muestra información acerca de la extensión <nombre>.
  --rz <nombre>           Muestra información acerca de la extensión Zend <nombre>.
  --ri <nombre>           Muestra la configuración para la extensión <nombre>.

Opciones de línea de comandos
Opción | Opción Larga | Descripción
-a --interactive

Ejecutar PHP de forma interactiva. Para más información, consúltese la sección Consola interactiva.

-b --bindpath

Ruta Ligada en modo de servidor FASTCGI externo (sólo en CGI).

-C --no-chdir

No cambiar el directorio del script (sólo en CGI).

-q --no-header

Modo silencioso. Elimina la salida de cabeceras HTTP (sólo en CGI).

-T --timing

Calcula el tiempo de ejecución del script un número de veces (sólo en CGI).

-c --php-ini

Especifica ya sea un directorio en el que se busca a php.ini o bien un fichero INI personalizado (que no tiene porqué llamarse php.ini necesariamente), p.ej.:

$ php -c /directorio/propio/mi_script.php

$ php -c /directorio/propio/fichero-propio.ini mi_script.php

Si no se especifica esta opción, se busca el fichero php.ini en las localizaciones predeterminadas.

-n --no-php-ini

Ignorar por completo el fichero php.ini.

-d --define

Establecer un valor predeterminado para cualquiera de las directivas de configuración permitidas en php.ini. Ésta es la sintaxis:

 -d directiva_de_configuracion[=valor]

# Si se omite el valor, se establecerá un "1" a la directiva
$ php -d max_execution_time
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(1) "1"

# Si se pasa un valor vacío, se establecerá "" a la directiva
php -d max_execution_time=
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(0) ""

# Se pasará lo que haya tras el caracter '=' a la directiva de configuración
$  php -d max_execution_time=20
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(2) "20"
$  php
        -d max_execution_time=doesntmakesense
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(15) "doesntmakesense"

-e --profile-info

Activa el modo de información expandida, para usar con un depurador/perfilador.

-f --file

Analiza y ejecuta el fichero proporcionado. El modificador -f es opcional y puede ser omitido - es suficiente con solo poner el nombre del fichero a ejecutar.

Nota:

Para pasar argumentos a un script, el primer argumento debe ser --, sino PHP los interpretará como opciones de PHP.

-h y -? | --help y --usage | Muestra una lista de opciones de línea de comandos, con descripciones de una línea sobre lo que hace.
-i | --info | Invoca a phpinfo(), y muestra el resultado. Si PHP no funcionara correctamente, es aconsejable utilizar php -i para ver donde se muestre cualquier mensaje de error antes o en el lugar de las tablas de información. Tenga en cuenta que al usarse en modo CGI la salida es en HTML y por lo tanto muy larga.
-l --syntax-check

Provee un método conveniente para realizar solamente una revisión de sintáxis del código proporcionado de PHP. En caso de éxito, se muestra el texto No syntax errors detected in <filename> en la salida estándar y se devuelve un código de retorno 0. Si fallara, se mostraría el texto Errors parsing <filename>, además del mensaje de error de análisis correspondiente en la salida estándar, y se retornaría el código -1.

Esta opción no encuentra errores fatales (como funciones no definidas). Utilice el modificador -f si se desea también comprobar errores fatales.

Nota:

Esta opción no funciona junto con la opción -r.

-m --modules

Ejemplo #1 Muestra los módulos PHP y Zend incorporados (y habilitados)

$ php -m
[PHP Modules]
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

-r --run

Permite ejecutar PHP desde la línea de comandos. Las etiquetas de inicio y fin (<?php y ?>) no son necesarias y provocarán un error sintáctico si estuvieran presentes.

Nota:

Debe tenerse cuidado al usar PHP de esta forma para no colisionar con sustituciones de variables de línea de comandos hechas por la propia consola.

Ejemplo #2 Obteniendo un error sintáctico usando comillas dobles

$ php -r "$foo = get_defined_constants();"
PHP Parse error:  syntax error, unexpected '=' in Command line code on line 1

Parse error: syntax error, unexpected '=' in Command line code on line 1

El problema aquí es que sh/bash lleva a cabo una sustitución de variables incluso si estamos usando comillas dobles ". Puesto que la variable $foo no está definida, no se sustituye por nada, haciendo que el código real que se le pasa a la ejecución de PHP sea:

$ php -r " = get_defined_constants();"

La forma correcta sería usar comillas simples '. Las variables de texto en comillas simples no se sustituyen en sh/bash.

Ejemplo #3 Usando comillas simples para prevenir la sustitución de variables de la consola

$ php -r '$foo = get_defined_constants(); var_dump($foo);'
array(370) {
  ["E_ERROR"]=>
  int(1)
  ["E_WARNING"]=>
  int(2)
  ["E_PARSE"]=>
  int(4)
  ["E_NOTICE"]=>
  int(8)
  ["E_CORE_ERROR"]=>
  [...]

Si se está usando una consola diferente de sh/bash, es posible experimentar otros errores. Le animamos a enviar un informe de error a » https://bugs.php.net/. Tenga en cuenta que es muy fácil verse en problemas al tratar de utilizar variables (de la consola o de PHP) en código de línea de comandos, o al usar el caracter de barra invertida (\) para escapar caracteres, así que tome mucho cuidado haciendo eso. Ha sido advertido!

Nota:

-r está disponible en SAPI CLI, pero no en CGI SAPI.

Nota:

Esta opción está pensada unicamente para código muy básico, así que algunas directivas de configuración (tales como auto_prepend_file y auto_append_file) se ignoran en este modo.

-B --process-begin

Código PHP a ejecutar antes de procesar la entrada. Añadido en PHP 5.

-R --process-code

Código PHP a ejecutar por cada línea de entrada. Añadido en PHP 5.

Hay dos variables especiales disponibles en este modo: $argn y $argi. $argn contendrá la línea que PHP está procesando en un momento dado, mientras que $argi contendrá el número de línea.

-F --process-file

Fichero PHP a ejecutar por cada línea de entrada. Añadido en PHP 5.

-E --process-end

Código PHP a ejecutar tras procesar cada línea. Añadido en PHP 5.

Ejemplo #4 Usando las opciones -B, -R y -E para contar el número de líneas de un proyecto.

$ find my_proj | php -B '$l=0;' -R '$l += count(@file($argn));' -E 'echo "Total Lines: $l\n";'
Total Lines: 37328

-S --server

Inicia el servidor web interno. Disponible a partir de PHP 5.4.0.

-t | --docroot | Especifiva la raíz del documento para el servidor web interno. Disponible a partir de PHP 5.4.0.
-s --syntax-highlight y --syntax-highlighting

Mostrar el código fuente destacando la sintaxis en color.

Esta opción utiliza los mecanismos internos de análisis del ficheros y escribe una versión HTML coloreada y la muestra en la salida estándar. Tenga en cuenta que todo lo que hace es generar un bloque de etiquetas HTML <code> [...] </code>, sin cabeceras HTML.

Nota:

Esta opción no puede funcionar junto con la opción -r.

-v --version

Ejemplo #5 Al usar -v obtenemos el nombre de la SAPI y la versión de PHP y Zend

$ php -v
PHP 5.3.1 (cli) (built: Dec 11 2009 19:55:07)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies

-w --strip

Mostrar código fuente sin comentarios ni líneas en blanco.

Nota:

Esta opción no puede usarse junto con la opción -r.

-z --zend-extension

Carga una extensión Zend. Si sólo se proporciona un nombre de fichero, PHP trata de cargar la extensión en el directorio de bibliotecas por defecto de su sistema (normalmente se especifica en /etc/ld.so.conf en sistemas Linux, por ejemplo). Si se proporciona un nombre de fichero con la ruta absoluta no se usarán las rutas de bibliotecas del sistema. Un nombre de fichero relativo que incluya algún directorio le indicará a PHP que sólo trate de cargar la extensión a partir del directorio actual.

--ini

Mostrar el nombre del fichero de configuración y de los directorios analizados. Disponible desde PHP 5.2.3.

Ejemplo #6 Ejemplo de --ini

$ php --ini
Configuration File (php.ini) Path: /usr/dev/php/5.2/lib
Loaded Configuration File:         /usr/dev/php/5.2/lib/php.ini
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)
--rf --rfunction

Mostrar información de la función o método proporcionado (p.ej. número y nombre de los parámetros). Disponible desde PHP 5.1.2.

Esta opción sólo está disponible si se compiló PHP con soporte para Reflection.

Ejemplo #7 Uso básico de --rf

$ php --rf var_dump
Function [ <internal> public function var_dump ] {

  - Parameters [2] {
    Parameter #0 [ <requerido> $var ]
    Parameter #1 [ <opcional> $... ]
  }
}
--rc --rclass

Muestra información de la clase dada (lista de constantes, propiedades y métodos). Disponible desde PHP 5.1.2.

Esta opción sólo está disponible si se compiló PHP con soporte para Reflection.

Ejemplo #8 Ejemplo de --rc

$ php --rc Directory
Class [ <internal:standard> class Directory ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [3] {
    Method [ <internal> public method close ] {
    }

    Method [ <internal> public method rewind ] {
    }

    Method [ <internal> public method read ] {
    }
  }
}
--re --rextension

Muestra información de la extensión dada (lista de opciones en php.ini, funciones definidas, constantes y clases). Disponible desde PHP 5.1.2.

Esta opción sólo está disponible si se compiló PHP con soporte para Reflection .

Ejemplo #9 Ejemplo de --re

$ php --re json
Extension [ <persistent> extension #19 json version 1.2.1 ] {

  - Functions {
    Function [ <internal> function json_encode ] {
    }
    Function [ <internal> function json_decode ] {
    }
  }
}
--rz --rzendextension

Mostrar la información de configuración para la extensión Zend proporcionada (la misma información que es devuelta por la función phpinfo()). Disponible como parte de PHP 5.4.0.

--ri --rextinfo

Mostrar información de configuración de la extensión dada (la misma información que muestra phpinfo()). Disponible desde PHP 5.2.2. La información relevante está disponible usando "main" como nombre de extensión.

Ejemplo #10 Ejemplo de --ri

$ php --ri date

date

date/time support => enabled
"Olson" Timezone Database Version => 2009.20
Timezone Database => internal
Default timezone => Europe/Oslo

Directive => Local Value => Master Value
date.timezone => Europe/Oslo => Europe/Oslo
date.default_latitude => 59.930972 => 59.930972
date.default_longitude => 10.776699 => 10.776699
date.sunset_zenith => 90.583333 => 90.583333
date.sunrise_zenith => 90.583333 => 90.583333

Nota:

Las opciones -rBRFEH, --ini y --r[fcezi] sólo están disponibles en CLI.


Ejecutando ficheros PHP

Hay tres formas distintas de proveer a la SAPI CLI con código PHP para que sea ejecutado:

  1. Decirle a PHP que ejecute un determinado fichero.

    $ php mi_script.php

$ php -f mi_script.php

    Ambas formas (usando o no el modificador -f) ejecutan el fichero mi_script.php. Nótese que no hay restricción sobre cuales ficheros puede ser ejecutado; en particular, el nombre del fichero no es necesario que tenga una extensión .php.

    Nota:

    Si se necesita proporcionar argumentos al script, utilizando el modificador -f, el primer argumento debe ser --.

  2. Pasar el código PHP para ejecutarlo directamente en la línea de comandos.

    $ php -r 'print_r(get_defined_constants());'

    Debe tomarse especial cuidado con respecto al uso de comillas y la sustitución de variables de la consola.

    Nota:

    Lea cuidadosamente el ejemplo: No hay etiquetas de inicio y fin. El modificador -r simplemente no lo necesita. Si se usare, provocaría un error sintáctico.

  3. Proporcionar el código PHP a ejecutar a través de la entrada estándar (stdin).

    Esto ofrece la posibilidad de crear código PHP dinámicamente para pasárselo al binario, tal y como se ve en este ejemplo (ficticio):

    $ alguna_aplicacion | algun_filtro | php | sort -u > salida_final.txt
No se pueden combinar las tres formas para ejecutar código.

Como todas las aplicaciones de consola, el binario de PHP acepta un determinado número de argumentos, sin embargo un script PHP también puede recibirlos. El número de argumentos que pueden ser pasados a su script no está limitado por PHP (aunque la consola tiene un determinado número de caracteres límite; usualmente usted no alcanzará este límite). Los argumentos pasados al script están disponibles en el array global $argv. El primer índice (cero) siempre contiene el nombre del script como se llamó desde la línea de comandos. Nótese que, si el código es ejecutado en la línea utilizando el modificador de consola -r, el valor de $argv[0] será simplemente un guión medio -). Lo mismo aplica si el código es ejecutado por medio de una tubería desde la entrada estándar STDIN.

Una segunda variable global, $argc, contiene el número de elementos en el arreglo $argv (pero no el número de argumentos pasados al script).

Dado que los argumentos que se pasan a un script no comienzan con el caracter -, no hay nada especial a tener en cuenta. Si se pasa a un script un argumento que comience por - provocará errores porque el intérprete de PHP pensará que debe manejarlo él, aún antes de ejecutar el script. Para prevenir esto, utilice el separador de lista de argumentos --. Una vez que PHP lea este separador, todos los argumentos que lo sigan se pasarán intactos al script.

# Esto no ejecutará el código dado, sino que mostrará el uso de PHP
$ php -r 'var_dump($argv);' -h
Usage: php [options] [-f] <file> [args...]
[...]

# Esto pasrá el argumento '-h' al script, impidiendo que PHP muestre su uso
$ php -r 'var_dump($argv);' -- -h
array(2) {
  [0]=>
  string(1) "-"
  [1]=>
  string(2) "-h"
}

Sin embargo, en sistemas Unix, hay otra forma de usar PHP para scripts de consola. Se puede escribir un script en el que la primera línea comience con #!/usr/bin/php (sustitúyalo por la ruta a su CLI binario de PHP si es diferente). El resto del fichero debería contener código PHP normal con las etiquetas usuales de inicio y fin de PHP. Una vez que se otorguen permisos de ejecución al fichero apropiadamente (p.ej. chmod +x test) el script podrá ejecutarse como cualquier otro script de consola o perl:

Ejemplo #1 Ejecutando un script PHP como un script de consola

#!/usr/bin/php
<?php
var_dump($argv);
?>

Asumiendo que este fichero se llama test y que está en el directorio actual, es posible hacer lo siguiente:

$ chmod +x test
$ ./test -h -- foo
array(4) {
  [0]=>
  string(6) "./test"
  [1]=>
  string(2) "-h"
  [2]=>
  string(2) "--"
  [3]=>
  string(3) "foo"
}

Tal y como puede verse, en este caso no hace falta tener cuidado al pasar al script parámetros que comienzan con -.

El ejecutable de PHP puede ser utilizado para ejecutar scripts de PHP que sean absolutamente independientes del servidor web. En sistemas Unix, los caracteres especiales #! (o conocido como "shebang") deben añadirse en la primera línea del script seguido de la ruta hacia el binario de PHP para que le indique autom[aticamente al sistema cual es el programa que debería ejecutar al script. En plataformas Windows puede asociar php.exe para que funcione al hacer doble clic en ficheros con extensión .php, o se puede hacer un fichero por lotes para ejecutar el script mediante PHP. La primera línea especial "shebang" que se añade a un script para que funcione en Unix no interferirá en Windows (ya que está formateado como un comentario de PHP), así que pueden escribirse programas para plataformas independientes incluyéndose sin ningún problema. Más abajo puede encontrarse un ejemplo sencillo de cómo escribir un programa de línea de comandos en PHP.

Ejemplo #2 Script destinado a ejecutarse desde la línea de comandos (script.php)

#!/usr/bin/php
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>

Éste es un script PHP de línea de comandos con un parámetro.

  Uso:
  <?php echo $argv[0]; ?> <parámetro>

  <parámetro> puede ser alguna palabra que desee
  mostrar en pantalla. Con las opciones --help, -help, -h,
  o -?, puede mostrarse esta ayuda.

<?php
} else {
    echo $argv[1];
}
?>

El script de arriba, incluye la primera línea especial "shebang" de Unix para indicar que este fichero debería ejecutarse por PHP. Puesto que aquí estamos trabajando con una versión CLI, no se mostrarán cabeceras HTTP.

El programa comprueba primero que hay más de un parámetro (adicionalmente al nombre del script, el cual también es contado). Si no lo hay, o si el parámetro fuese --help, -help, -h o -?, se imprime el mensaje de ayuda, utilizando $argv[0] para escribir el nombre del script dinámicamente tal como se escribió en la línea de comandos. De otra manera, el parámetro es mostrado exactamente como se recibió.

Para ejecutar el script superior en Unix, debe otorgarle permisos de ejecución al fichero para hacerlo ejecutable, y llamarlo simplemente como script.php mostrar_esto o script.php -h. En Windows, se puede crear un fichero por lotes para lograr esta tarea:

Ejemplo #3 Fichero por lotes para ejecutar un script PHP en línea de comandos (script.bat)

@echo OFF
"C:\php\php.exe" script.php %*

Asumiendo que el programa superior se llamara script.php, y CLI php.exe estuviera en C:\php\php.exe , este fichero por lotes lo ejecutaría automáticamente con los parámetros que se le hayan pasado: script.bat mostrar_esto o script.bat -h.

Vea también la documentación de extensión Readline para conocer más funciones que pueden ser utilizadas para mejorar las aplicaciones de línea de comandos en PHP.

Si está en Windows, puede configurar PHP para que no sea necesario añadir ni C:\php\php.exe ni la extensión .php, tal como se describe en PHP en Línea de Comandos en Microsoft Windows.


Flujos de entrada/salida

SAPI CLI define algunas constantes para flujos de E/S que simplifican la programación en línea de comandos.

Constantes específicas de CLI
Constante Descripción
STDIN

Flujo abierto a stdin. Ahorra tener que abrirlo con

<?php
$stdin = fopen('php://stdin', 'r');
?>
Si se desea leer una sola línea de stdin, puede usarse
<?php
$line = trim(fgets(STDIN)); // lee una línea de STDIN
fscanf(STDIN, "%d\n", $number); // lee un número de STDIN
?>

STDOUT

Flujo abierto a stdout. Ahorra tener que abrirlo con

<?php
$stdout = fopen('php://stdout', 'w');
?>

STDERR

Flujo abierto a stderr. Ahorra tener que abrirlo con

<?php
$stderr = fopen('php://stderr', 'w');
?>

Teniendo esto en cuenta, no es necesario abrir por ejemplo un flujo a stderr, sino que puede usarse la constante en lugar del recurso de tipo flujo:

php -r 'fwrite(STDERR, "stderr\n");'
No es necesario cerrar explícitamente estos flujos, ya que se cierra automáticamente por PHP al finalizar el script.

Nota:

Estas constantes no están disponibles si se leyera el script PHP a partir de stdin.


Consola interactiva

Desde PHP 5.1.0, SAPI CLI ofrece una consola interactiva si se usa con el modificador -a y PHP está compilado con la opción --with-readline.

Al usar la consola interactiva, se puede escribir directamente código PHP que se ejecuta al momento.

Ejemplo #1 Ejecutando código desde la consola interactiva

$ php -a
Interactive shell

php > echo 5+8;
13
php > function addTwo($n)
php > {
php { return $n + 2;
php { }
php > var_dump(addtwo(2));
int(4)
php >

La consola interactiva, además, proporciona autocompletado mediante el tabulador de funciones, constantes, nombres de clases, variables, llamadas a métodos estáticos y constantes de clases.

Ejemplo #2 Autocompletado con el tabulador

Al pulsar dos veces la tecla tabulador habiendo múltiples opciones de completados, se mostrará una lista con éstas:

php > strp[TAB][TAB]
strpbrk   strpos    strptime
php > strp

Cuando sólo hay una posible opción, sólo con pulsar una vez el tabulador se completará el resto de la línea:

php > strpt[TAB]ime(

También funciona el autocompletado para nombres que se han definido durante la sesión de consola interactiva:

php > $fooEsteEsUnNombreDeVariableMuyLargo = 42;
php > $foo[TAB]EsteEsUnNombreDeVariableMuyLargo

La consola interactiva almacena tu historial, al que se puede acceder usando las teclas arriba y abajo. El historial se almacena en el fichero ~/.php_history.

Ya en PHP 5.4.0, la SAPI CLI provee las configuraciones de php.ini, cli.pager y cli.prompt. La configuración de cli.pager permite a un programa externo (tal como less) para que funcione como un paginador para la salida en lugar de se desplegado directamente en la pantalla. Las configuraciones de cli.prompt permite cambiar el indicador de ingreso de órdenes php >.

In PHP 5.4.0 también fue posible establecer las configuraciones de php.ini en la shell interactiva utilizando una notación abreviada.

Ejemplo #3 Estableciendo configuraciones de php.ini en la shell interactiva

La configuración de cli.prompt:

php > #cli.prompt=hola mundo :>
  hola mundo :>

Usando comillas simples inclinadas es posible ejecutar código PHP en el indicador de órdenes:

php > #cli.prompt=`echo date('H:i:s');` php >
  15:49:35 php > echo 'hola';
  hola
  15:49:43 php > sleep(2);
  15:49:45 php >

Establecer el paginador a less:

php > #cli.pager=less
  php > phpinfo();
  (salida desplegada en less)
  php >

La configuración de cli.prompt soporta unas cuantas secuencias de escape:

Secuencias de escape de cli.prompt
Sequence: | Description:
\e | Utilizado para agregar colores al ingreso de órdenes. Un ejemplo podría ser \e[032m\v \e[031m\b \e[34m\> \e[0m
\v | La versión de PHP.
\b | Indica cual bloque de PHP está dentro. Por ejemplo /* se usa para indicar que está dentro de un comentario multilineal. El alcance externo es denotado por php.
\> | Indica el caracter de ingreso de órdenes. El caracter predeterminado es >, pero cambia cuando la shell está dentro de un bloque indeterminado o una cadena. Los caracteres posibles son: ' " { ( >

Nota:

Los ficheros que se han incluido en este modo mediante auto_prepend_file y auto_append_file se analizan con algunas restricciones - p.ej. las funciones deben estar definidas antes de que se carguen.

Nota:

La auto-carga no está disponible al usar PHP en modo interactivo en CLI.


Servidor web interno

Advertencia

Este servidor web ha sido diseñado para ayudar al desarrollo de aplicaciones. También puede ser útil para propósitos de prueba o para demostraciones de aplicaciones que se ejecutan en entornos controlados. No se pretende que sea un servidor web con todas las funciones. No debe ser utilizado en una red pública.

Desde PHP 5.4.0, la SAPI CLI provee un servidor web embebido.

El servidor web ejecuta solamente un único proceso monohilo, por lo que las aplicaciones PHP se detendrán si la solicitud está bloqueada.

Las peticiones de URI se sirven desde el actual directorio de trabajo donde PHP se inició, a menos que la opción -t sea utilizada para especificar una raíz de documentos explícita. Si una petición de URI no especifica un fichero, entonces el index.php o index.html que estén en el directorio dado serán devueltos. Si ninguno de los ficheros existen, la búsqueda de index.php e index.html continuará en el directorio padre y continuará así hasta encontrar uno de ello o se alcance el directorio raíz. Si se encuentra index.php o index.html, se devuelve este y $_SERVER['PATH_INFO'] se establece a la parte final del URI. De lo contrario se devuelve un código de respuesta 404.

Si un fichero PHP es proporcionado en la línea de comandos cuando se inicia el servidor web éste es tratado como un script "enrutador". El script es ejecutado al inicio de cada petición HTTP. Si este script devuelve false, entonces el recurso solicitado se devuelve tal cual está. De otra forma la salida del script se devuelve en el navegador.

Los tipos MIME estándar son devueltos para ficheros con extensiones: .3gp, .apk, .avi, .bmp, .css, .csv, .doc, .docx, .flac, .gif, .gz, .gzip, .htm, .html, .ics, .jpe, .jpeg, .jpg, .js, .kml, .kmz, .m4a, .mov, .mp3, .mp4, .mpeg, .mpg, .odp, .ods, .odt, .oga, .ogg, .ogv, .pdf, .pdf, .png, .pps, .pptx, .qt, .svg, .swf, .tar, .text, .tif, .txt, .wav, .webm, .wmv, .xls, .xlsx, .xml, .xsl, .xsd, y .zip.

Registro de cambios: Tipos MIME soportados (extensiones de ficheros)
Versión | Descripción
5.5.12 | .xml, .xsl, and .xsd
5.5.7 | .3gp, .apk, .avi, .bmp, .csv, .doc, .docx, .flac, .gz, .gzip, .ics, .kml, .kmz, .m4a, .mp3, .mp4, .mpg, .mpeg, .mov, .odp, .ods, .odt, .oga, .pdf, .pptx, .pps, .qt, .swf, .tar, .text, .tif, .wav, .wmv, .xls, .xlsx, y .zip
5.5.5 | .pdf
5.4.11 | .ogg, .ogv, and .webm
5.4.4 | .htm and .svg

Ejemplo #1 Iniciando el servidor web

$ cd ~/public_html
$ php -S localhost:8000

La terminal mostrará:

PHP 5.4.0 Servidor de desarrollo iniciado en Jueves Julio 21 10:43:28 2011
Escuchando en localhost:8000
La raíz de documentos es /home/usuario/html_público
Presione Ctrl-C para salir

Después de una petición de una URI para http://localhost:8000/ y http://localhost:8000/mi_script.html la terminal mostrará algo similar a:

PHP 5.4.0 Servidor de desarrollo iniciado en Jueves Julio 21 10:43:28 2011
Escuchando en localhost:8000
La raíz de documentos es /home/usuario/html_público
Presione Ctrl-C para salir.
[Thu Jul 21 10:48:48 2011] ::1:39144 GET /favicon.ico - Petición leída
[Thu Jul 21 10:48:50 2011] ::1:39146 GET / - Petición leída
[Thu Jul 21 10:48:50 2011] ::1:39147 GET /favicon.ico - Petición leída
[Thu Jul 21 10:48:52 2011] ::1:39148 GET /mi_script.html - Petición leída
[Thu Jul 21 10:48:52 2011] ::1:39149 GET /favicon.ico - Petición leída

Ejemplo #2 Iniciando con una raíz de documentos específica

$ cd ~/html_público
$ php -S localhost:8000 -t foo/

La terminal mostrará:

PHP 5.4.0 Servidor de desarrollo iniciado en Jueves Julio 21 10:50:26 2011
Escuchando en localhost:8000
La raíz de documentos es /home/usuario/html_público/foo
Presione Ctrl-C para salir

Ejemplo #3 Utilizando un Script enrutador

En este ejemplo, las peticiones a las imágenes se mostrarán, pero las peticiones a ficheros HTML mostrarán "Bienvenido a PHP":

<?php
// router.php
if (preg_match('/\.(?:png|jpg|jpeg|gif)$/', $_SERVER["REQUEST_URI"])){
    return false;    // servir la petición tal cual es.
}else {
    echo "<p>Bienvenido a PHP</p>";
}

?>
$ php -S localhost:8000 router.php

Ejemplo #4 Revisión del uso de la CLI del servidor web

Para reutilizar un framework de script enrutador durante el desarrollo con la CLI del servidor web server y luego con un servidor web en producción:

<?php
// router.php
if (php_sapi_name() == 'cli-server') {
    /* los activos de ruta estática y devolver falso */
}
/* seguir adelante con operaciones normales de index.php */
?>
$ php -S localhost:8000 router.php

Ejemplo #5 Manejando tipos de ficheros no soportados

Si necesita servir un recurso estático cuyo tipo MIME no es manejado por la CLI del servidor web, utilice:

<?php
// router.php
$path = pathinfo($_SERVER["SCRIPT_FILENAME"]);
if ($path["extension"] == "el") {
    header("Content-Type: text/x-script.elisp");
    readfile($_SERVER["SCRIPT_FILENAME"]);
}
else {
    return FALSE;
}
?>
$ php -S localhost:8000 router.php

Ejemplo #6 Accediendo a la CLI del servidor web desde máquinas remotas

Puede hacer que el servidor web sea accesible en el puerto 8000 a cualquier interfaz con:

$ php -S 0.0.0.0:8000


Configuración INI

Opciones de configuración de la SAPI CLI
Nombre | Por defecto | Cambiable | Historial de cambios
cli_server.color | "0" | PHP_INI_ALL | Disponible desde PHP 5.4.0.

He aquí una breve explicación de las directivas de configuración.

cli_server.color boolean

Habilita el servidor web de desarrollo interno para usa la codificación de color ANSI en la salida del terminal.


Recolección de basura

Tabla de contenidos

  • Introducción al contador de referencias
  • Recolección de referencias cíclicas
  • Consideraciones acerca del Rendimiento

Esta sección explica las ventajas del nuevo mecanismo de Recoleción de basura (GC por sus siglas en inglés de «Garbage Collection») de la versión 5.3 de PHP.


Introducción al contador de referencias

Una variable en PHP se almacena en un contenedor llamado "zval". Un contenedor zval contiene, además del tipo de la variable y su valor, dos bits adicionales de información. Al primero se le llama "is_ref" y contiene un valor booleano que indica si la variable es parte o no de un "conjunto de referencias". Con este bit, el motor de PHP sabe diferenciar entre variables normales y referencias. Puesto que PHP permite referencias definidas por el usuario, tal y como se crean con el operador &, un contenedor zval tiene también un mecanismo contador de referencias para optimizar el uso de memoria. Esta segunda pieza adicional de información, llamada "refcount", contiene el número de variables (también llamadas símbolos) que apuntan a este contenedor zval. Todos los símbolos se almacenan en una tabla de símbolos, de las cuales hay una por cada ámbito. Hay un ámbito para el script principal (es decir, el solicitado por el navegador), además de uno por cada función o método.

Se crea un contenedor zval al crear una nueva variable con un valor constante, como por ejemplo:

Ejemplo #1 Creación de un nuevo contenedor zval

<?php
$a = "nuevo string";
?>

En este caso, el nombre del nuevo símbolo, a, se crea en el ámbito actual y se crea un nuevo contenedor de variable con el tipo string y el valor nuevo string. El bit "is_ref" se establece por omisión a false dado que no se ha creado ninguna referencia en el espacio del usuario. "refcount" se establece a 1, pues solo hay un símbolo que haga uso de este contenedor de variable. Tenga en cuenta que si "refcount" es 1, "is_ref" siempre valdrá false. Si tiene » Xdebug instalado, puede mostrar esta información llamando a xdebug_debug_zval().

Ejemplo #2 Mostrar información de zval

<?php
xdebug_debug_zval('a');
?>

El resultado del ejemplo sería:

a: (refcount=1, is_ref=0)='nuevo string'

Al asignar esta variable a otro nombre de variable, se incrementará refcount.

Ejemplo #3 Incremento de refcount de un zval

<?php
$a = "nuevo string";
$b = $a;
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería:

a: (refcount=2, is_ref=0)='nuevo string'

Aquí, refcount vale 2, pues el mismo contenedor de variable está vinculado tanto por a como por b. PHP es lo suficiente inteligente para no copiar el contenedor de variable en sí cuando no es necesario. Los contenedores de variables se destruyen cuando "refcount" llega a cero. "refcount" se decrementa en uno cuando alguno de los símbolos vinculados al contenedor de variable abandona su ámbito (p.ej. cuando finaliza una función) o cuando un símbolo es desasignado (p. ej., llamando a unset()). El siguiente ejemplo muestra esto:

Ejemplo #4 Decremento de refcount de zval

<?php
$a = "nuevo string";
$c = $b = $a;
xdebug_debug_zval( 'a' );
$b = 42;
xdebug_debug_zval( 'a' );
unset( $c );
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería:

a: (refcount=3, is_ref=0)='nuevo string'
a: (refcount=2, is_ref=0)='nuevo string'
a: (refcount=1, is_ref=0)='nuevo string'

Si ahora llamáramos a unset($a);, el contenedor de variable, incluyendo tanto el tipo como el valor, se eliminarían de la memoría.

Tipos compuestos

Las cosas se complican con tipos compuestos tales como arrays y object. En lugar de un valor de tipo scalar, los arrays y objects almacenan sus propiedades en su propia tabla de símbolos. Esto significa que el siguiente ejemplo crea tres contenedores zval:

Ejemplo #5 Crear un zval de tipo array

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería algo similar a:

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=1, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42
)

Gráficamente

Los zval de un array simple

Los tres contenedores zval son: a, meaning, y number. Se aplican reglas similares a la hora de incrementar y decrementar "refcounts". Abajo, añadimos otro elemento al array, y fijamos su valor al contenido de un elemento ya existente:

Ejemplo #6 Añadir un elemento existente a un array

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería algo similar a:

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=2, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42,
   'life' => (refcount=2, is_ref=0)='life'
)

Gráficamente

Los zval de un array simple con una referencia

A partir de la salida de Xdebug, vemos que tanto el antiguo como el nuevo elemento del array apuntan a un contenedor zval cuyo "refcount" vale 2. Pese a que Xdebug muestra dos contenedores zval con valor 'life', son el mismo. La función xdebug_debug_zval() no muestra esto, aunque podria comprobarse mostrando también el puntero de memoria.

Eliminar un elemento del array es como eliminar un símbolo de un ámbito. Al hacerlo, el "refcount" del contenedor al que apunta el elemento del array se decrementa. De nuevo, cuando "refcount" alcanza cero, el contenedor de la variable se elimina de la memoria. Un ejemplo que muestra esto:

Ejemplo #7 Eliminar un elemento de un array

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
unset( $a['meaning'], $a['number'] );
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería algo similar a:

a: (refcount=1, is_ref=0)=array (
   'life' => (refcount=1, is_ref=0)='life'
)

Ahora, las cosas se vuelven interesantes si añadimos al propio array como elemento del array, como veremos en el siguiente ejemplo, en el que también usaremos el operador de referencia, ya que de lo contrario PHP crearía una copia:

Ejemplo #8 Añadir el propio array como elemento de sí mismo

<?php
$a = array( 'one' );
$a[] =& $a;
xdebug_debug_zval( 'a' );
?>

El resultado del ejemplo sería algo similar a:

a: (refcount=2, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=2, is_ref=1)=...
)

Gráficamente

Los zval para un array que contiene una referencia circular

Puede verse que tanto la variable de tipo array (a) como el segundo elemento (1) apuntan ahora a un contenedor de variable que tiene un "refcount" de 2. Los "..." mostrados arriba indican que hay una referencia cíclica, lo cual, por supuesto, significa que en este caso los "..." apuntan al array original.

Al igual que antes, al eliminar una variable se elimina el símbolo y el contador de referencias del contenedor de variable al que apunte se decrementa en uno. De modo que, si eliminamos la variable $a después de ejecutar el código anterior, el contador de referencias del contenedor de variable al que apuntan tanto $a como el elemento "1" se decrementa en uno, de "2" a "1". Se puede representar así:

Ejemplo #9 Eliminar $a

(refcount=1, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=1, is_ref=1)=...
)

Gráficamente

Los zval después de eliminar un array con referencia circular mostrando la fuga de memoria

Problemas de limpieza

Pese a que ya no hay ningún símbolo en ningún ámbito que apunte a esta estructura, esta no se puede limpiar ya que el elemento "1" del array todavía apunta al mismo array. Al no haber un símbolo externo que apunte a él, no hay forma por la que el usuario pueda eliminar esta estructura; por tanto tenemos una fuga de memoria. Afortunadamente, PHP limpiará esta estructura de datos al finalizar la petición, aunque hasta entonces esté ocupando un valioso espacio de memoria. Esta situación ocurre a menudo si se está implementando un algoritmo de análisis o en otras situaciones en las que un nodo hijo apunte de nuevo a un elemento "padre". Por supuesto, esta situación también puede suceder con objetos, donde es más frecuente que ocurra, ya que los objetos siempre se usan implícitamente por referencia.

Esto no debería ser un problema si sólo ocurre una o dos veces, pero si estas fugas de memoria suceden miles, o incluso millones de veces, lógicamente esto comenzaría a ser un problema. Es especialmente problemático en scripts de larga duración, tales como demonios donde básicamente nunca terminan las peticiones, o en un gran conjunto de pruebas unitarias. Esto último causó problemas al ejecutar las pruebas unitarias del componente Template de la biblioteca eZ Componentes. En algunos casos, podrían ser necesarios 2 GB de memoria que quizás no los tenga el servidor de pruebas.


Recolección de referencias cíclicas

Tradicionalmente, los mecanismos que contabilizan las referencias en memoria, tal como el que empleaba PHP anteriormente, fallaban al abordar las fugas de memoria de referencias cíclicas. Sin embargo, desde PHP 5.3.0 se implementa el algoritmo síncrono del artículo » Recolección de ciclos concurrentes en sistemas de contabilidad de referencias que resuelve este asunto.

Una explicación detallada del funcionamiento del algoritmo queda más allá del objetivo de esta sección, aunque aquí explicaremos el mecanismo básico. Antes de nada, debemos establecer unas reglas básicas. Si se incrementa un refcount, este aún sigue en uso: no es basura. Si se decrementa el refcount y llega a cero, el zval puede liberarse. Esto significa que la recolección de ciclos sólo puede llevarse a cabo cuando un argumento refcount se decrementa a un valor que no sea cero. En segundo lugar, en un ciclo de recolección de basura, es posible averiguar qué partes son basura comprobando si se puede decrementar en uno sus refcount, para después comprobar cuáles zval poseen un refcount de cero.

Algoritmo de recolección de basura

Para evitar llamar a la comprobación de ciclos de basura en cada posible decremento de un refcount, el algoritmo lo que hace es pasar todas las posibles raíces (zvals) al "buffer raíz" (marcándolos en "púrpura"). También se asegura de que cada raíz de basura sólo finaliza una vez en el buffer. Únicamente cuando el buffer raíz está completo, comienza el mecanismo de recolección para todos los zval diferentes que haya en su interior. Véase el paso A en la figura anterior.

En el paso B, el algoritmo inicia una primera búsqueda en profundidad de todas las posibles raíces en las que decrementa por uno los refcount de los zval que encuentra, asegurándose de que no decrementa dos veces el mismo zval (marcándolo en "gris"). En el paso C, el algoritmo vuelve a llevar a cabo una búsqueda en profundidad dentro de cada nodo raíz, para volver a comprobar el refcount de cada zval. Si ve que el refcount es cero, se marca al zval en "blanco" (azul en la figura). Si es mayor que cero, deshace el decremento con una búsqueda en profundidad partiendo de ese punto, y se le vuelve a marcar en "negro". En el último paso (D), el algoritmo recorre el buffer raíz eliminando las raíces zval que haya, y a la vez, comprueba qué zvals se han marcado en "blanco" en el paso anterior. Todos los zval marcados en "blanco" se eliminarán.

Ahora que ya tiene un conocimiento básico de cómo funciona el algoritmo, volveremos atrás para ver cómo se integra esto en PHP. Por omisión, el recolector de basuras de PHP está habilitado. Hay, sin embargo, una directiva en php.ini que permite cambiar esto: zend.enable_gc.

Cuando el recolector de basura está habilitado, el algoritmo que busca ciclos, tal y como se ha descrito arriba, se ejecuta cada vez que se llena el buffer raíz. Éste tiene un tamaño fijo de 10.000 raíces posibles (se puede modificar esto cambiando la contante GC_ROOT_BUFFER_MAX_ENTRIES en Zend/zend_gc.c del código fuente de PHP, y recompilando PHP). Cuando el recolector de basuras se deshabilita, no se ejecutará el algoritmo que busca ciclos. Sea como fuere, las posibles raíces seguirían registrándose en el buffer raíz, sin importar si el mecanismo recolector de basuras está habilitado en la configuración o no.

Si estando deshabilitado el mecanismo recolector de basuras se llenara el buffer raíz de posibles raíces, no se registraría al resto de raíces posibles, por lo que no llegarían a ser analizadas por el algoritmo. Si fueran parte de un ciclo de referencia circular, nunca se liberarían y podrían provocar una fuga de memoria.

La razón por la que se registran las posibles raíces estando deshabilitado el mecanismo es porque es más rápido registrarlas que comprobar en cada una de ellas si el mecanismo está habilitado. Sin embargo, el recolector de basuras y el propio mecanismo de análisis, sí puede conllevar una cantidad de tiempo considerable.

Ademas de poder cambiar la configuración zend.enable_gc, también es posible habilitar o deshabilitar el mecanismo recolector de basura llamando a gc_enable() o gc_disable() respectivamente. La llamada a estas funciones tiene el mismo efecto que habilitar o deshabilitar el mecanismo en la propia configuración. También es posible forzar la recolección de ciclos incluso sin que esté lleno el buffer raíz. Para hacer esto, se puede usar la función gc_collect_cycles(). Esta función devuelve el número de ciclos que fueron recolectados por el algoritmo.

El motivo por el que es posible habilitar o deshabilitar el mecanismo, o iniciar los ciclos de recolección a mano, es porque podría haber determinadas partes de una aplicación que necesiten mucha precisión de tiempo. En estos casos, quizás no se desee que funcione el mecanismo recolector de basuras. Por supuesto, al deshabilitar el recolector de basuras en algunas partes del código, se corre el riesgo de provocar fugas de memoria, ya que algunas raíces podrían no caber en el buffer raíz. Por tanto, lo mas prudente sería llamar a gc_collect_cycles() justo después de llamar a gc_disable() para que libere la memoria ocupada por posibles raíces ya registradas en el buffer raíz. Esto deja por tanto un buffer vacío, de modo que queda más espacio para almacenar posibles raíces en el tiempo en que el mecanismo recolector de ciclos está deshabilitado.


Consideraciones acerca del Rendimiento

Como mencionamos en la sección anterior, la recolección de raíces tiene muy bajo impacto en el rendimiento, pero aquí es cuando comparamos PHP 5.2 contra PHP 5.3. Si bien la recolección de posibles raíces comparado con la no recolección, como en PHP 5.2, es más lenta, hay otras modificaciones en tiempo de ejecución en PHP 5.3 que impiden que esta pérdida de rendimiento en particular pueda siquiera apreciarse.

Hay dos principales sectores en los que el rendimiento se ve afectado. El primero es el uso reducido de memoria, y mientras que el segunda es la reducción en tiempo de ejecución cuando el mecanismo recolector de basura lleva a cabo la limpieza de memoria. Revisaremos estos dos asuntos.

Uso Reducido de Memoria

Antes de nada, la razón por la que se implementa el mecanismo recolector de basuras es para reducir el uso de memoria limpiando, una vez que se cumplen las condiciones, las variables de referencias circulares. En la implementación de PHP, esto sucede cuando el buffer raíz está lleno, o cuando se invoca la función gc_collect_cycles(). En el gráfico mostrado abajo, se muestra el uso de memoria tanto en PHP 5.2 como en 5.3, excluyendo la memoria base que el propio PHP ocupa al arrancar.

Ejemplo #1 Ejemplo de uso de memoria

<?php
class Foo
{
    public $var = '3.14159265359';
}

$baseMemory = memory_get_usage();

for ( $i = 0; $i <= 100000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
    if ( $i % 500 === 0 )
    {
        echo sprintf( '%8d: ', $i ), memory_get_usage() - $baseMemory, "\n";
    }
}
?>
Comparación de uso de memoria entre PHP 5.2 y PHP 5.3

En este ejemplo didáctico, estamos creando un objeto en el que una propiedad enlaza de nuevo al propio objeto. Cuando la variable $a del script se reasigna en la siguiente iteración del bucle, típicamente ocurriría una fuga de memoria. En este caso, se fugan dos contenedores zval (el zval del objeto, y el zval de la propiead), pero sólo se encuentra una posible raíz: la variable que se desasignó. Tras 10.000 iteraciones, el buffer se llena (con un total de 10.000 posibles raíces), y se lanza el mecanismo recolector de basura y libera la memoria asociada con esas posibles raíces. Puede apreciarse claramente en el uso de memoria "dentado" de la gráfica para PHP 5.3. Tras las 10.000 iteraciones, el mecanismo libera la memoria asociada a las variables con referencias cíclicas. En este ejemplo, el propio mecanismo no debe hacer un gran trabajo, puesto que la estructura que produce la fuga es extremadamente sencilla. A partir del diagrama, se puede comprobar que el uso máximo de memoria en PHP 5.3 es en torno a 9 Mb, mientras que en PHP 5.2 el uso de memoria no para de aumentar.

Reducción en Tiempo de Ejecución

El segundo sector en el que el mecanismo recolector de basura influye en el rendimiento es en el tiempo que lleva a éste liberar la memoria "fugada". Para comprobar de cuánto estamos hablando, modificaremos ligeramente el script anterior para tener en cuenta un mayor número de iteraciones, y eliminaremos las figuras de uso de memoria intermedio. Este es el segundo script:

Ejemplo #2 Influencia en rendimiento de Recolector de Basuras

<?php
class Foo
{
    public $var = '3.14159265359';
}

for ( $i = 0; $i <= 1000000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
}

echo memory_get_peak_usage(), "\n";
?>

Ejecutaremos dos veces este script, una con el ajuste zend.enable_gc habilitado, y en la otra deshabilitado:

Ejemplo #3 Ejecutando el script anterior

time php -dzend.enable_gc=0 -dmemory_limit=-1 -n example2.php
# and
time php -dzend.enable_gc=1 -dmemory_limit=-1 -n example2.php

En la máquina de ejemplo, el primer comando parece llevar en torno a 10,7 segundos, mientras que al segundo comando le lleva 11,4. Esto es un incremento de en torno al 7%. Sin embargo, el uso máximo de memoria del script se ha reducido en un 98%, pasando de 931Mb a 10Mb. Esta prueba no es muy científica, ni siquiera representativa de aplicaciones reales, pero demuestra que el uso de memoria se beneficia del mecanismo recolector de basuras. Lo interesante es que para este script en particular el incremento es siempre del 7%, mientras que el ahorro de memoria aumenta a medida que se encuentran más referencias cíclicas en la ejecución del script.

Estadísticas Internas de PHP del Recolector de Basuras

Todavía es posible dar más información sobre cómo funciona el mecanismo recolector de basuras dentro de PHP. Pero para hacerlo, será necesario recompilar PHP para habilitar el código de análises y de recopilación de datos. Se tendrá que asignar a la variable de entorno CFLAGS el valor -DGC_BENCH=1 antes de ejecutar ./configure con las opciones deseadas. La siguiente secuencia muestra cómo hacerlo:

Ejemplo #4 Recompilando PHP para habilitar el análisis del Recolector de Basuras

export CFLAGS=-DGC_BENCH=1
./config.nice
make clean
make

Al ejecutar el ejemplo que vimos arriba con el nuevo binario de PHP que hemos creado, veremos que se muestra el siguiente resultado tras la ejecución de PHP:

Ejemplo #5 Estadísticas de Recolección de Basuras

GC Statistics
-------------
Runs:               110
Collected:          2072204
Root buffer length: 0
Root buffer peak:   10000

      Possible            Remove from  Marked
        Root    Buffered     buffer     grey
      --------  --------  -----------  ------
ZVAL   7175487   1491291    1241690   3611871
ZOBJ  28506264   1527980     677581   1025731

Las estadísticas más informativas son las que se muestran en el primer bloque. Puede comprobarse que el mecanismo recolector de basuras se ejecutó 110 veces, y en total, se liberaron más de 2 millones de ubicaciones en memoria durante esas 110 ejecuciones. Puesto que el mecanismo recolector de ciclos se ha ejecutado al menos una vez, el "pico del buffer raíz" es siempre 10.000.

Conclusión

En general el recolector de basuras de PHP sólo provocará un retraso cuando el algoritmo recolector de ciclos funcione, mientras que en scripts normales (más pequeños) no habrá un impacto real en el rendimiento.

Sin embargo, en el caso en el que el mecanismo recolector de ciclos se ejecute para scripts normales, la reducción de memoria permitirá que puedan funcionar más scripts concurrentemente en el servidor, ya que en total no utilizarán mucha memoria.

Los beneficios son más evidentss en scripts de larga duración, tales como grandes suits de pruebas o scripts demonios. También en las aplicaciones » PHP-GTK, que generalmente suelen ejecutarse durante más tiempo que scripts para la Web; el nuevo mecanismo marcará la diferencia en cuanto a las fugas de memoria progresivas en el tiempo.


Rastreo Dinámico con DTrace

Tabla de contenidos

  • Introducción a PHP y DTrace
  • Usando PHP y DTrace
  • Usando SystemTap con Sondas Estáticas en PHP DTrace


Introducción a PHP y DTrace

DTrace es un marco de rastreo de disponibilidad permanente, bajo consumo, y disponible en un gran número de plataformas incluyendo Solaris, Mac OS X, Oracle Linux y BSD. DTrace puede seguir el rastro del comportamiento del sistema operativo y la ejecución del programa del usuario. DTrace puede enseñar los valores de los argumentos y ser utilizados para inferir estadísticas de rendimiento. Los sondeos son monitorizados por scripts creados por el usuario, escritos en el programa de scripting DTrace D. Esto permite el análisis eficiente de puntos de datos.

Los sondeos en PHP que no son activamente monitorizados por scripts DTrace D del usuario no contienen código observado por lo cual no hay una degradación del rendimiento durante la ejecución normal de la aplicación. Los sondeos que estan siendo monitorizados incurren una perdida suficientemente baja para permitir monitorización con DTrace en entornos de producción activos.

PHP incorpora sondeos "User-level Statically Defined Tracing" (USDT) que son evaluados en tiempo de ejecución. Por ejemplo, cuando un script D está monitorizando una entrada de función, cada ve que la función de PHP es llamada, dispararía el sondeo y el código de acción que ésta tiene asociado. Esta código de acción podría, por ejemplo, imprimir los argumentos del sondeo tales como lo ubicación del fichero con la función PHP, o podría contabilizar el número de veces que esta función fue llamada.

Sólo sondas PHP USDT son descritas aquí. Refierase a documentación externa sobre DTrace de sistema operativo para ver como puede DTrace ser usado para rastrear funciones arbitrarias, y como puede ser usado para rastrear el comportamiento del sistema operativo. Tenga en cuenta que no todas las funcionalidades de DTrace estan disponibles en todas las implementaciones de DTrace.

Las sondas estáticas de DTrace están incluidas en PHP 5.4. Previo a esto estaba incluidas via una extensión » PECL, que ahora ha quedado obsoleta.

Las sondas estáticas DTrace en PHP pueden alternativamente ser usadas con las herramientas de SystemTap en algunas distribuciones Linux.


Usando PHP y DTrace

PHP puede ser configurado con sondas estáticas DTrace en plataformas que soportan Rastreo Dinámico DTrace.

Configurando PHP para Sondas Estáticas DTrace

Refierase a la documentación externa específica par su plataforma para habilitar el soporte para rastreo DTrace en el sistema operativo. Por ejemplo, en Oracle Linux arranque con un kernel UEK3 y haga:

# modprobe fasttrap
# chmod 666 /dev/dtrace/helper

En lugar de utilizar chmod, usted podria utilizar una regla de paquete ACL para limitar acceso a los dispositivos a ciertos usuarios.

Compile PHP con el parámetro de configuración --enable-dtrace:

# ./configure --enable-dtrace ...
# make
# make install

Esto habilita las sondas estáticas en el núcleo de PHP. Cualquiera de las extensiones que ofrezcan sus propios sondeos deberán ser compiladas de forma separada como extensiones compartidas.

Sondeos Estáticos DTrace en el núcleo de PHP

Los siguientes sondeos estáticos están disponibles en PHP
Nombre del Sondeo | Descripción del Sondeo | Argumentos del Sondeo
request-startup | Se dispara cuando comienza una petición. | char *file, char *request_uri, char *request_method
request-shutdown | Se dispara cuando se termina una petición. | char *file, char *request_uri, char *request_method
compile-file-entry | Se dispara cuando la compilación de un script comienza. | char *compile_file, char *compile_file_translated
compile-file-return | Se dispara cuando la compilación de un script termina. | char *compile_file, char *compile_file_translated
execute-entry | Se dispara cuando un código de operación array está por ser ejecutado. Por ejemplo, se dispara en llamadas a funciones, includes, y continuaciones de resumes. | char *request_file, int lineno
execute-return | Se dispara después de la ejecución de un código de operación array. | char *request_file, int lineno
function-entry | Se dispara cuando el motor de PHP entra a la llamada de una función o método. | char *function_name, char *request_file, int lineno, char *classname, char *scope
function-return | Se dispara cuando el motor de PHP regresa de la llamada a una función o método. | char *function_name, char *request_file, int lineno, char *classname, char *scope
exception-thrown | Se dispara cuando una excepción es lanzada. | char *classname
exception-caught | Se dispara cuando una excepción es capturada. | char *classname
error | Se dispara cuando ocurre un error, sin importar el nivel de error_reporting. | char *errormsg, char *request_file, int lineno

Otras extensiones PHP pueden también tener otras sondas estáticas adicionales.

Listando Sondas Estáticas DTrace en PHP

Para listar todas las sondas disponibles, inicie un proceso PHP y ejecute:

# dtrace -l

La salida será similar a:

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
    4   php15271               php               dtrace_compile_file compile-file-entry
    5   php15271               php               dtrace_compile_file compile-file-return
    6   php15271               php                        zend_error error
    7   php15271               php  ZEND_CATCH_SPEC_CONST_CV_HANDLER exception-caught
    8   php15271               php     zend_throw_exception_internal exception-thrown
    9   php15271               php                 dtrace_execute_ex execute-entry
   10   php15271               php           dtrace_execute_internal execute-entry
   11   php15271               php                 dtrace_execute_ex execute-return
   12   php15271               php           dtrace_execute_internal execute-return
   13   php15271               php                 dtrace_execute_ex function-entry
   14   php15271               php                 dtrace_execute_ex function-return
   15   php15271               php              php_request_shutdown request-shutdown
   16   php15271               php               php_request_startup request-startup

La columna Proveedor consiste en php y el id del proceso del proceso PHP que está ejecutandose.

Si el servidor web Apache está corriendo, el nombre del módulo será, por ejemplo, libphp5.so, y habría múltiples bloques de listado, uno por cada proceso Apache ejecutandose.

La columna Función se refiere los nombres internos de función de su implementación en C, donde cada proveedor está ubicado.

Si un proceso PHP no está ejecutandose, entonces ningún sondeo será mostrado.

DTrace con un ejemplo PHP

Este ejemplo muestra los conceptos básicos del lenguaje de scripting DTrace D.

Ejemplo #1 all_probes.d para monitorizar todos los Sondeos Estáticos en PHP con DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::compile-file-entry
{
    printf("PHP compile-file-entry\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::compile-file-return
{
    printf("PHP compile-file-return\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::error
{
    printf("PHP error\n");
    printf("  errormsg                  %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
}

php*:::exception-caught
{
    printf("PHP exception-caught\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::exception-thrown
{
    printf("PHP exception-thrown\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::execute-entry
{
    printf("PHP execute-entry\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::execute-return
{
    printf("PHP execute-return\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::function-entry
{
    printf("PHP function-entry\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::function-return
{
    printf("PHP function-return\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::request-shutdown
{
    printf("PHP request-shutdown\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

php*:::request-startup
{
    printf("PHP request-startup\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

Este script utiliza la opción -Z en dtrace, permitiendo que se ejecute aún cuando no hay procesos PHP ejecutandose. Si esta opción se hubiese omitido el script hubiese terminado inmediatamente porque no sabría que los sondeos a ser monitorizados realmente son válidos.

Este script rastrea todas las sondas estáticas del núcleo de PHP y puntos de muestreo a lo largo de la duración de un script PHP que esté corriendo:

# ./all_probes.d

Ejecuta un script o aplicación PHP. El script D de monitorización mostrará los argumentos de cada sondeo según vayan sucediendo.

Cuando la monitorización está completada, el script D puede ser terminado con ^C.

En máquinas con múltiples-CPU el orden de los sondeos podría no aparecer secuencialmente. Esto depende de en que CPU fue procesado, y como los hilos se mueven a través de las CPUs. Mostrar la fecha y hora del sondeo ayudará a reducir la confusión, por ejemplo:

php*:::function-entry
{
      printf("%lld: PHP function-entry ", walltimestamp);
      [ . . .]
}

Vea también

  • OCI8 y Rastreo Dinámico DTrace


Usando SystemTap con Sondas Estáticas en PHP DTrace

En algunas distribuciones Linux, la utilidad de rastreo SystemTap puede ser usada para rastrear sondas estáticas en PHP. Esto está disponible con PHP 5.4.20 y PHP 5.5.

Instalando PHP con SystemTap

Instalar el paquete de desarrollo SD de SystemTap:

# yum install systemtap-sdt-devel

Instalar PHP con los sondeos de DTrace habilitados:

# ./configure --enable-dtrace ...
# make

Listando Sondeos Estáticos con SystemTap

Los sondeos estáticos en PHP pueden ser listados usando stap:

# stap -l 'process.provider("php").mark("*")' -c 'sapi/cli/php -i'

Esto produce la salida:

process("sapi/cli/php").provider("php").mark("compile__file__entry")
process("sapi/cli/php").provider("php").mark("compile__file__return")
process("sapi/cli/php").provider("php").mark("error")
process("sapi/cli/php").provider("php").mark("exception__caught")
process("sapi/cli/php").provider("php").mark("exception__thrown")
process("sapi/cli/php").provider("php").mark("execute__entry")
process("sapi/cli/php").provider("php").mark("execute__return")
process("sapi/cli/php").provider("php").mark("function__entry")
process("sapi/cli/php").provider("php").mark("function__return")
process("sapi/cli/php").provider("php").mark("request__shutdown")
process("sapi/cli/php").provider("php").mark("request__startup")

SystemTap con un ejemplo PHP

Ejemplo #1 all_probes.stp para monitorizar todas los Sondeos Estáticos de PHP con SystemTap

probe process("sapi/cli/php").provider("php").mark("compile__file__entry") {
    printf("Probe compile__file__entry\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("compile__file__return") {
    printf("Probe compile__file__return\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("error") {
    printf("Probe error\n");
    printf("  errormsg %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
}
probe process("sapi/cli/php").provider("php").mark("exception__caught") {
    printf("Probe exception__caught\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("exception__thrown") {
    printf("Probe exception__thrown\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("execute__entry") {
    printf("Probe execute__entry\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("execute__return") {
    printf("Probe execute__return\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("function__entry") {
    printf("Probe function__entry\n");
    printf("  function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("function__return") {
    printf("Probe function__return: %s\n", user_string($arg1));
    printf(" function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("request__shutdown") {
    printf("Probe request__shutdown\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}
probe process("sapi/cli/php").provider("php").mark("request__startup") {
    printf("Probe request__startup\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}

El script anterior rastreará todas las sondas estáticas del núcleo de PHP y puntos de muestreo a lo largo de la duración de un script PHP que esté corriendo:

# stap -c 'sapi/cli/php test.php' all_probes.stp


Referencia de funciones

Sugerencia

Ver también Categorización de Extensiones.

  • Afecta el comportamiento de PHP
    • APCu — APC User Cache
    • Componere
    • Manejo de errores — Manejo y registro de errores
    • FFI — Foreign Function Interface
    • Memtrack
    • OPcache
    • Control de la salida — Control del búfer de salida
    • Opciones/Info de PHP — Opciones e Información de PHP
    • phpdbg — Interactive PHP Debugger
    • runkit
    • uopz — User Operations for Zend
    • Weakref — Referencias débiles
    • WinCache — Caché de Windows para PHP
    • Xhprof — Hierarchical Profiler
    • Yac
  • Manipulación de formatos de audio
    • OpenAL — Vinculaciones de audio del OpenAL
  • Servicios de autenticación
    • Radius
  • Extensiones específicas de la línea de comandos
    • Ncurses — Control de Terminal de Pantalla Ncurses
    • Readline — GNU Readline
  • Extensiones de compresión y archivos
    • Bzip2
    • LZF
    • Phar
    • Rar — Archivos Rar
    • Zip
    • Zlib — Compresión Zlib
  • Extensiones criptográficas
    • CSPRNG
    • Hash — HASH Framework para cifrar mensajes
    • Mcrypt
    • Mhash
    • OpenSSL
    • Hash de contraseñas
    • Sodium
  • Extensiones de bases de datos
    • Capas abstractas
    • Extensiones de bases de datos específicas del proveedor
  • Extensiones relacionadas con fecha y hora
    • Calendario
    • Fecha/Hora — Fecha y Hora
    • HRTime — HRTime - Medición del tiempo en alta resolución
  • Extensiones relacionadas con el sistema de ficheros
    • Direct IO
    • Directorios
    • Fileinfo — Información de un fichero
    • Sistema de Ficheros
    • Inotify
    • Proctitle
    • xattr
    • xdiff
  • Soporte para lenguaje humano y codificación de caracteres
    • Enchant — Biblioteca de ortografía Enchant
    • Gender — Determinar el género de un nombre
    • Gettext
    • iconv
    • intl — Funciones de internacionalización
    • Cadenas de caracteres multibyte
    • Pspell
    • Recode — GNU Recode
  • Procesamiento y generación de imágenes
    • Exif — Información de imagen intercambiable
    • GD — Procesamiento de imágenes y GD
    • Gmagick
    • ImageMagick — Procesamiento de imágenes (ImageMagick)
  • Extensiones relacionadas con Email
    • IMAP — IMAP, POP3 y NNTP
    • Mail
    • Mailparse
  • Extensiones matemáticas
    • BC Math — Matemáticas de precisión arbitraria BCMath
    • GMP — Precisión Múltiple de GNU (GNU Multiple Precision)
    • Math — Funciones matemáticas
    • Estadísticas
    • Trader — Análisis técnico para comerciantes
  • Salida MIME que no es texto
    • FDF — Formato de Datos de Formularios
    • GnuPG — GNU Privacy Guard
    • wkhtmltox
    • PS — Creación de documentos PostScript
    • RpmInfo
    • XLSWriter
  • Extensiones de control de procesos
    • Eio
    • Ev
    • Expect
    • PCNTL — Control de procesos
    • POSIX
    • Ejecución de programas — Ejecución de programas del sistema
    • parallel
    • pthreads
    • pht
    • Semaphore — Semáforo, Memoria Compartida e IPC
    • Memoria compartida
    • Sync
  • Otras extensiones básicas
    • GeoIP — Localización Geo IP
    • FANN — FANN (Fast Artificial Neural Network - Red Neuronal Artificial Rápida)
    • JSON — JavaScript Object Notation
    • Lua
    • LuaSandbox
    • Misc. — Funciones varias
    • Seaslog
    • SPL — SPL - Biblioteca estándar de PHP
    • Flujos
    • Swoole
    • Tidy
    • Tokenizer
    • URLs
    • V8js — Motor de integración V8 Javascript
    • Yaml — Serialización de datos YAML
    • Yaf — Yet Another Framework
    • Yaconf
    • Taint
    • Data Structures
  • Otros servicios
    • cURL — Biblioteca URL cliente
    • Event
    • FTP
    • Gearman
    • LDAP — Protocolo Ligero de Acceso a Directorios
    • Memcache
    • Memcached
    • mqseries
    • Network
    • RRD — RRDtool
    • ScoutAPM
    • SNMP
    • Sockets
    • SSH2 — Secure Shell2
    • Stomp — Cliente Stomp
    • SVM — Soporte Vector Machine
    • SVN — Subversion
    • TCP — Envolturas TCP
    • Varnish
    • YAZ
    • Mensajería de 0MQ — ZMQ
    • ZooKeeper
  • Extensiones para motores de búsqueda
    • Solr — Solr de Apache
    • Sphinx — Cliente Sphinx
  • Extensiones específicas para Servidores
    • Apache
    • FastCGI Process Manager
  • Extensiones de sesiones
    • Sesiones — Manejo de sesiones
  • Procesamiento de texto
    • CommonMark
    • Parle — Parsing and lexing
    • PCRE — Expresiones regulares (compatibles con Perl)
    • Expresiones Regulares de POSIX — Expresiones Regulares (POSIX Extendido)
    • ssdeep — ssdeep Fuzzy Hashing
    • Strings
  • Extensiones relacionadas con variable y tipo
    • Arrays
    • Clases/Objetos — Información de Clases/Objetos
    • Classkit
    • Ctype — Comprobación del tipo de carácter
    • Filter — Filtrado de datos
    • Manejo de Funciones
    • Quickhash
    • Reflection
    • Manejo de variables
  • Servicios web
    • OAuth
    • SOAP
    • Yar — Yet Another RPC Framework
    • XML-RPC
  • Extensiones específicas de Windows
    • COM — COM y .Net (Windows)
    • win32service
  • Manipulación de XML
    • DOM — Modelo de Objetos de Documento
    • libxml
    • SimpleXML
    • WDDX
    • XMLDiff — Diferencias y fusión de documentos XML
    • Analizador XML
    • XMLReader
    • XMLWriter
    • XSL
  • Extensiones de GUI
    • UI


Afecta el comportamiento de PHP

  • APCu — APC User Cache
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones APCu
    • APCUIterator — La clase APCUIterator
  • Componere
    • Introducción
    • Instalación/Configuración
    • Componere\Abstract\Definition — La clase Componere\Abstract\Definition
    • Componere\Definition — La clase Componere\Definition
    • Componere\Patch — La clase Componere\Patch
    • Componere\Method — La clase Componere\Method
    • Componere\Value — La clase Componere\Value
    • Funciones Componere
  • Manejo de errores — Manejo y registro de errores
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Manejo de Errores
  • FFI — Foreign Function Interface
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • FFI — Main interface to C code and data
    • FFI\CData — C Data Handles
    • FFI\CType — C Type Handles
    • FFI\Exception — FFI Exceptions
    • FFI\ParserException — FFI Parser Exceptions
  • Memtrack
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
  • OPcache
    • Introducción
    • Instalación/Configuración
    • Preloading
    • Funciones de OPcache
  • Control de la salida — Control del búfer de salida
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones del Control de la salida
  • Opciones/Info de PHP — Opciones e Información de PHP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Opciones/Info de PHP
  • phpdbg — Interactive PHP Debugger
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • phpdbg Funciones
  • runkit
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de runkit
  • uopz — User Operations for Zend
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Uopz Funciones
  • Weakref — Referencias débiles
    • Introducción
    • Instalación/Configuración
    • WeakRef — La clase WeakRef
    • WeakMap — La clase WeakMap
  • WinCache — Caché de Windows para PHP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de WinCache
    • Building for Windows
  • Xhprof — Hierarchical Profiler
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Xhprof Funciones
  • Yac
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Yac — La clase Yac


APC User Cache

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones APCu
    • apcu_add — Cache a new variable in the data store
    • apcu_cache_info — Recupera la información almacenada en la memoria APCu
    • apcu_cas — Actualiza un valor antiguo con un nuevo valor
    • apcu_clear_cache — Limpia el caché del APCu
    • apcu_dec — Disminuir un número almacenado
    • apcu_delete — Elimina una variable almacenada en caché
    • apcu_enabled — Si el APCu es utilizable en el entorno actual
    • apcu_entry — Atomically fetch or generate a cache entry
    • apcu_exists — Checks if entry exists
    • apcu_fetch — Fetch a stored variable from the cache
    • apcu_inc — Increase a stored number
    • apcu_key_info — Get detailed information about the cache key
    • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
    • apcu_store — Cache a variable in the data store
  • APCUIterator — La clase APCUIterator
    • APCUIterator::__construct — Construye un objeto iterador APCUIterator
    • APCUIterator::current — Obtener el elemento actual
    • APCUIterator::getTotalCount — Obtiene el conteo total
    • APCUIterator::getTotalHits — Obtener resultados totales de la memoria caché
    • APCUIterator::getTotalSize — Obtiene el tamaño total del caché
    • APCUIterator::key — Obtiene la clave del iterador
    • APCUIterator::next — Mueve el puntero al siguiente elemento
    • APCUIterator::rewind — Rebobina el iterador
    • APCUIterator::valid — Comprueba si la posición actual es válida


Introducción

APCu es APC despojado del almacenamiento en caché del código de operación.

La primera base de código de APCu tenía la versión 4.0.0, y se bifurcó de la rama principal de APC en ese momento.

El soporte para PHP 7 está disponible a partir de APCu 5.0.0.

APCu puede proporcionar un modo de compatibilidad, de modo que pueda proporcionar una caída en reemplazo para las partes aplicables de APC.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución
  • Tipos de recursos


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

No se requiere de ninguna biblioteca externa para compilar esta extensión.


Instalación

Si se requiere retrocompatibilidad con las partes de APC aplicables APCu debe configurarse con la opción --enable-apcu-bc.

Advertencia

PHP 7 tiene un módulo aparte (» apc.so) para la retrocompatibilidad con APC.

En el modo de retrocompatibilidad, APCu registra las funciones de APC aplicables con prototipos retrocompatibles.

Si una función de APC aceptaba cache_type, la ignora simplemente la versión retrocompatible, and omitted from the prototype for the APCu version.

Nota: En Windows, APC necesita una ruta temporal donde ubicarse, y debe ser escribible por el servidor web. Comprueba las variables de entorno TMP, TEMP y USERPROFILE, en este orden, y finalmente intenta el directorio WINDOWS si ninguno de los anteriores está establecido.

Nota: Para detalles de implementación más profundos y altamente téctino, veáse el » fichero TECHNOTES porporcionado por el desarrollador .

Los ficheros fuentes de APCu se pueden encontrar » aquí.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Although the default APCu settings are fine for many installations, serious users should consider tuning the following parameters.

There is one decision to be made configuring APCu. How much memory is going to be allocated to APCu. The ini directive that controls this is apc.shm_size Read the sections on this carefully below.

Once the server is running, the apc.php script that is bundled with the extension should be copied somewhere into the docroot and viewed with a browser as it provides a detailed analysis of the internal workings of APCu. If GD is enabled in PHP, it will even display some interesting graphs. If APCu is working, the Cache full count number (on the left) will display the number of times the cache has reached maximum capacity and has had to forcefully clean any entries that haven't been accessed in the last apc.ttl seconds. This number is minimized in a well-configured cache. If the cache is constantly being filled, and thusly forcefully freed, the resulting churning will have disparaging effects on script performance. The easiest way to minimize this number is to allocate more memory for APCu.

When APCu is compiled with mmap support (Memory Mapping), it will use only one memory segment, unlike when APCu is built with SHM (SysV Shared Memory) support that uses multiple memory segments. MMAP does not have a maximum limit like SHM does in /proc/sys/kernel/shmmax. In general MMAP support is recommended because it will reclaim the memory faster when the webserver is restarted and all in all reduces memory allocation impact at startup.

APCu configuration options
Nombre | Por defecto | Cambiable | Historial de cambios
apc.enabled | "1" | PHP_INI_SYSTEM |
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "32M" | PHP_INI_SYSTEM |
apc.entries_hint | "4096" | PHP_INI_SYSTEM |
apc.ttl | "0" | PHP_INI_SYSTEM |
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.slam_defense | "1" | PHP_INI_SYSTEM |
apc.enable_cli | "0" | PHP_INI_SYSTEM |
apc.use_request_time | "0" | PHP_INI_ALL | Prior to APCu 5.1.19, the default was "1".
apc.serializer | "php" | PHP_INI_SYSTEM | Prior to APCu 5.1.15, the default was "default".
apc.coredump_unmap | "0" | PHP_INI_SYSTEM |
apc.preload_path | NULL | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

apc.enabled bool

apc.enabled can be set to 0 to disable APC. This is primarily useful when APC is statically compiled into PHP, since there is no other way to disable it (when compiled as a DSO, the extension line in php.ini can just be commented-out).

apc.shm_segments int

The number of shared memory segments to allocate for the compiler cache. If APC is running out of shared memory but apc.shm_size is set as high as the system allows, raising this value might prevent APC from exhausting its memory.

apc.shm_size string

The size of each shared memory segment given by a shorthand notation as described in this FAQ. By default, some systems (including most BSD variants) have very low limits on the size of a shared memory segment.

apc.entries_hint int

A "hint" about the number of distinct variables that might be stored. Set to zero or omit if not sure.

apc.ttl int

The number of seconds a cache entry is allowed to idle in a slot in case this cache entry slot is needed by another entry. Leaving this at zero means that APC's cache could potentially fill up with stale entries while newer entries won't be cached. In the event of a cache running out of available memory, the cache will be completely expunged if ttl is equal to 0. Otherwise, if the ttl is greater than 0, APC will attempt to remove expired entries.

apc.gc_ttl int

The number of seconds that a cache entry may remain on the garbage-collection list. This value provides a fail-safe in the event that a server process dies while executing a cached source file; if that source file is modified, the memory allocated for the old version will not be reclaimed until this TTL reached. Set to zero to disable this feature.

apc.mmap_file_mask string

If compiled with MMAP support by using --enable-mmap this is the mktemp-style file_mask to pass to the mmap module for determining whether your mmap'ed memory region is going to be file-backed or shared memory backed. For straight file-backed mmap, set it to something like /tmp/apc.XXXXXX (exactly 6 Xs). To use POSIX-style shm_open/mmap put a .shm somewhere in your mask. e.g. /apc.shm.XXXXXX You can also set it to /dev/zero to use your kernel's /dev/zero interface to anonymous mmap'ed memory. Leaving it undefined will force an anonymous mmap.

apc.slam_defense int

On very busy servers whenever you start the server or modify files you can create a race of many processes all trying to cache the same file at the same time. This option sets the percentage of processes that will skip trying to cache an uncached file. Or think of it as the probability of a single process to skip caching. For example, setting apc.slam_defense to 75 would mean that there is a 75% chance that the process will not cache an uncached file. So, the higher the setting the greater the defense against cache slams. Setting this to 0 disables this feature.

apc.enable_cli int

Mostly for testing and debugging. Setting this enables APC for the CLI version of PHP. Under normal circumstances, it is not ideal to create, populate and destroy the APC cache on every CLI request, but for various test scenarios it is useful to be able to enable APC for the CLI version of PHP easily.

apc.serializer string

Used to configure APC to use a third party serializer.

apc.coredump_unmap bool

Enables APC handling of signals, such as SIGSEGV, that write core files when signaled. When these signals are received, APC will attempt to unmap the shared memory segment in order to exclude it from the core file. This setting may improve system stability when fatal signals are received and a large APC shared memory segment is configured.

Advertencia

This feature is potentially dangerous. Unmapping the shared memory segment in a fatal signal handler may cause undefined behaviour if a fatal error occurs.

Nota:

Although some kernels may provide a facility to ignore various types of shared memory when generating a core dump file, these implementations may also ignore important shared memory segments such as the Apache scoreboard.

apc.preload_path string

Optionally, set a path to the directory that APC will load cache data at startup.

apc.use_request_time bool

Use the SAPI request start time for TTL.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

APC_ITER_ALL (integer)
APC_ITER_ATIME (integer)
APC_ITER_CTIME (integer)
APC_ITER_DEVICE (integer)
APC_ITER_DTIME (integer)
APC_ITER_FILENAME (integer)
APC_ITER_INODE (integer)
APC_ITER_KEY (integer)
APC_ITER_MD5 (integer)
APC_ITER_MEM_SIZE (integer)
APC_ITER_MTIME (integer)
APC_ITER_NONE (integer)
APC_ITER_NUM_HITS (integer)
APC_ITER_REFCOUNT (integer)
APC_ITER_TTL (integer)
APC_ITER_TYPE (integer)
APC_ITER_VALUE (integer)
APC_LIST_ACTIVE (integer)
APC_LIST_DELETED (integer)


Funciones APCu

Tabla de contenidos

  • apcu_add — Cache a new variable in the data store
  • apcu_cache_info — Recupera la información almacenada en la memoria APCu
  • apcu_cas — Actualiza un valor antiguo con un nuevo valor
  • apcu_clear_cache — Limpia el caché del APCu
  • apcu_dec — Disminuir un número almacenado
  • apcu_delete — Elimina una variable almacenada en caché
  • apcu_enabled — Si el APCu es utilizable en el entorno actual
  • apcu_entry — Atomically fetch or generate a cache entry
  • apcu_exists — Checks if entry exists
  • apcu_fetch — Fetch a stored variable from the cache
  • apcu_inc — Increase a stored number
  • apcu_key_info — Get detailed information about the cache key
  • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
  • apcu_store — Cache a variable in the data store


Cache a new variable in the data store

  • « Funciones APCu
  • apcu_cache_info »
  • PHP Manual
  • Funciones APCu
  • Cache a new variable in the data store

apcu_add

(PECL apcu >= 4.0.0)

apcu_add — Cache a new variable in the data store

Descripción

apcu_add ( string $key , mixed $var , int $ttl = 0 ) : bool
apcu_add ( array $values , mixed $unused = NULL , int $ttl = 0 ) : array

Caches a variable in the data store, only if it's not already stored.

Nota: Unlike many other mechanisms in PHP, variables stored using apcu_add() will persist between requests (until the value is removed from the cache).

Parámetros

key

Store the variable using this name. keys are cache-unique, so attempting to use apcu_add() to store data with a key that already exists will not overwrite the existing data, and will instead return false. (This is the only difference between apcu_add() and apcu_store().)

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

Valores devueltos

Returns TRUE if something has effectively been added into the cache, FALSE otherwise. Second syntax returns array with error keys.

Ejemplos

Ejemplo #1 A apcu_add() example

<?php
$bar = 'BAR';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
$bar = 'NEVER GETS SET';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
?>

El resultado del ejemplo sería:

string(3) "BAR"
string(3) "BAR"

Ver también

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Elimina una variable almacenada en caché


Recupera la información almacenada en la memoria APCu

  • « apcu_add
  • apcu_cas »
  • PHP Manual
  • Funciones APCu
  • Recupera la información almacenada en la memoria APCu

apcu_cache_info

(PECL apcu >= 4.0.0)

apcu_cache_info — Recupera la información almacenada en la memoria APCu

Descripción

apcu_cache_info ( bool $limited = false ) : array

Recupera la información almacenada y los metadatos del almacén de datos de la APC.

Parámetros

limited

Si el parámetro limited es true, el valor devuelto excluirá la lista individual de entradas de la memoria caché. Esto es útil cuando se intentan optimizar las llamadas para la recopilación de estadísticas.

Valores devueltos

Array de datos en caché (y metadatos) o false en caso de error

Nota: apcu_cache_info() hará una advertencia si no puede recuperar los datos de la caché del APC. Esto suele ocurrir cuando el APC no está activado.

Historial de cambios

Versión | Descripción
3.0.11 | El parámetro limited fué introducido.
3.0.16 | La opción "filehits" para el parámetro cache_type fué introducido.

Ejemplos

Ejemplo #1 Un ejemplo de apcu_cache_info()

<?php
print_r(apcu_cache_info());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [num_slots] => 2000
    [ttl] => 0
    [num_hits] => 9
    [num_misses] => 3
    [start_time] => 1123958803
    [cache_list] => Array
        (
            [0] => Array
                (
                    [filename] => /path/to/apcu_test.php
                    [device] => 29954
                    [inode] => 1130511
                    [type] => file
                    [num_hits] => 1
                    [mtime] => 1123960686
                    [creation_time] => 1123960696
                    [deletion_time] => 0
                    [access_time] => 1123962864
                    [ref_count] => 1
                    [mem_size] => 677
                )
            [1] => Array (...iterates for each cached file)
)

Ver también

  • APCu configuration directives
  • APCUIterator::getTotalSize() - Obtiene el tamaño total del caché
  • APCUIterator::getTotalHits() - Obtener resultados totales de la memoria caché
  • APCUIterator::getTotalCount() - Obtiene el conteo total


Actualiza un valor antiguo con un nuevo valor

  • « apcu_cache_info
  • apcu_clear_cache »
  • PHP Manual
  • Funciones APCu
  • Actualiza un valor antiguo con un nuevo valor

apcu_cas

(PECL apcu >= 4.0.0)

apcu_cas — Actualiza un valor antiguo con un nuevo valor

Descripción

apcu_cas ( string $key , int $old , int $new ) : bool

apcu_cas() actualiza un valor entero ya existente si el parámetro old coincide el valor almacenado actualmente con el valor del parámetro new.

Parámetros

key

La clave del valor que se está actualizando.

old

El valor antiguo (el valor actualmente almacenado).

new

El nuevo valor al que actualizar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de apcu_cas()

<?php
apcu_store('foobar', 2);
echo '$foobar = 2', PHP_EOL;
echo '$foobar == 1 ? 2 : 1 = ', (apcu_cas('foobar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;
echo '$foobar == 2 ? 1 : 2 = ', (apcu_cas('foobar', 2, 1) ? 'ok' : 'fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;

echo '$f__bar == 1 ? 2 : 1 = ', (apcu_cas('f__bar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;

apcu_store('perfection', 'xyz');
echo '$perfection == 2 ? 1 : 2 = ', (apcu_cas('perfection', 2, 1) ? 'ok' : 'epic fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;
?>

El resultado del ejemplo sería algo similar a:

$foobar = 2
$foobar == 1 ? 2 : 1 = fail
$foobar == 2 ? 1 : 2 = ok
$foobar = 1
$f__bar == 1 ? 2 : 1 = fail
$perfection == 2 ? 1 : 2 = epic fail
$foobar = 1

Ver también

  • apcu_dec() - Disminuir un número almacenado
  • apcu_store() - Cache a variable in the data store


Limpia el caché del APCu

  • « apcu_cas
  • apcu_dec »
  • PHP Manual
  • Funciones APCu
  • Limpia el caché del APCu

apcu_clear_cache

(PECL apcu >= 4.0.0)

apcu_clear_cache — Limpia el caché del APCu

Descripción

apcu_clear_cache ( ) : bool

Limpia el caché.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve siempre true

Ver también

  • apcu_cache_info() - Recupera la información almacenada en la memoria APCu


Disminuir un número almacenado

  • « apcu_clear_cache
  • apcu_delete »
  • PHP Manual
  • Funciones APCu
  • Disminuir un número almacenado

apcu_dec

(PECL apcu >= 4.0.0)

apcu_dec — Disminuir un número almacenado

Descripción

apcu_dec ( string $key , int $step = 1 , bool &$success = ? , int $ttl = 0 ) : int

Disminuye un valor entero almacenado.

Parámetros

key

La clave de el valor a ser disminuido.

step

El paso, o valor a disminuir.

success

Opcionalmente pasa el valor booleano en caso de éxito o en caso de error a esta variable referenciada.

ttl

TTL para usar si la operación inserta un nuevo valor (en lugar de disminuir uno existente).

Valores devueltos

Devuelve el valor actual del valor de las claves (key) en caso de éxito, o false en caso de error

Historial de cambios

Versión | Descripción
5.1.12 | El parámetro ttl fué añadido.

Ejemplos

Ejemplo #1 Ejemplo de apcu_dec()

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_dec('anumber'), PHP_EOL;
echo apcu_dec('anumber', 10), PHP_EOL;
echo apcu_dec('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_dec('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

El resultado del ejemplo sería algo similar a:

Let's do something with success
42
41
31
21
bool(true)
Now, let's fail

bool(false)
bool(false)

Ver también

  • apcu_inc() - Increase a stored number


Elimina una variable almacenada en caché

  • « apcu_dec
  • apcu_enabled »
  • PHP Manual
  • Funciones APCu
  • Elimina una variable almacenada en caché

apcu_delete

(PECL apcu >= 4.0.0)

apcu_delete — Elimina una variable almacenada en caché

Descripción

apcu_delete ( mixed $key ) : bool

Elimina una variable almacenada en caché.

Parámetros

key

Una clave (key) empleada para almacenar el valor como un string para una única clave, o como un array de strings para varias claves, o como un object APCUIterator.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo deapcu_delete()

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
apcu_delete('foo');
// obviamente, esto no es útil de esta forma

// Alternativamente, borrar varias claves.
apcu_delete(['foo', 'bar', 'baz']);

// O utilizar un Iterator con una expresión regular.
apcu_delete(new APCUIterator('#^myprefix_#'));
?>

Ver también

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_clear_cache() - Limpia el caché del APCu
  • APCUIterator


Si el APCu es utilizable en el entorno actual

  • « apcu_delete
  • apcu_entry »
  • PHP Manual
  • Funciones APCu
  • Si el APCu es utilizable en el entorno actual

apcu_enabled

(PECL apcu >= 4.0.3)

apcu_enabled — Si el APCu es utilizable en el entorno actual

Descripción

apcu_enabled ( ) : bool

Devuelve si el APCu es utilizable en el entorno actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true uando el APCu es utilizable en el entorno actual, false en caso contrario.


Atomically fetch or generate a cache entry

  • « apcu_enabled
  • apcu_exists »
  • PHP Manual
  • Funciones APCu
  • Atomically fetch or generate a cache entry

apcu_entry

(PECL apcu >= 5.1.0)

apcu_entry — Atomically fetch or generate a cache entry

Descripción

apcu_entry ( string $key , callable $generator , int $ttl = 0 ) : mixed

Atomically attempts to find key in the cache, if it cannot be found generator is called, passing key as the only argument. The return value of the call is then cached with the optionally specified ttl, and returned.

Nota: When control enters apcu_entry() the lock for the cache is acquired exclusively, it is released when control leaves apcu_entry(): In effect, this turns the body of generator into a critical section, disallowing two processes from executing the same code paths concurrently. In addition, it prohibits the concurrent execution of any other APCu functions, since they will acquire the same lock.

Advertencia

The only APCu function that can be called safely by generator is apcu_entry().

Parámetros

key

Identity of cache entry

generator

A callable that accepts key as the only argument and returns the value to cache.

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

Valores devueltos

Returns the cached value

Ejemplos

Ejemplo #1 An apcu_entry() example

<?php
$config = apcu_entry("config", function($key) {
 return [
   "fruit" => apcu_entry("config.fruit", function($key){
     return [
       "apples",
       "pears"
     ];
   }),
   "people" => apcu_entry("config.people", function($key){
     return [
      "bob",
      "joe",
      "niki"
     ];
   })
 ];
});

var_dump($config);
?>

El resultado del ejemplo sería:

array(2) {
  ["fruit"]=>
  array(2) {
    [0]=>
    string(6) "apples"
    [1]=>
    string(5) "pears"
  }
  ["people"]=>
  array(3) {
    [0]=>
    string(3) "bob"
    [1]=>
    string(3) "joe"
    [2]=>
    string(4) "niki"
  }
}

Ver también

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Elimina una variable almacenada en caché


Checks if entry exists

  • « apcu_entry
  • apcu_fetch »
  • PHP Manual
  • Funciones APCu
  • Checks if entry exists

apcu_exists

(PECL apcu >= 4.0.0)

apcu_exists — Checks if entry exists

Descripción

apcu_exists ( mixed $keys ) : mixed

Checks if one or more APCu entries exist.

Parámetros

keys

A string, or an array of strings, that contain keys.

Valores devueltos

Returns true if the key exists, otherwise false Or if an array was passed to keys, then an array is returned that contains all existing keys, or an empty array if none exist.

Ejemplos

Ejemplo #1 apcu_exists() example

<?php
$fruit  = 'apple';
$veggie = 'carrot';

apcu_store('foo', $fruit);
apcu_store('bar', $veggie);

if (apcu_exists('foo')) {
    echo "Foo exists: ";
    echo apcu_fetch('foo');
} else {
    echo "Foo does not exist";
}

echo PHP_EOL;
if (apcu_exists('baz')) {
    echo "Baz exists.";
} else {
    echo "Baz does not exist";
}

echo PHP_EOL;

$ret = apcu_exists(array('foo', 'donotexist', 'bar'));
var_dump($ret);

?>

El resultado del ejemplo sería algo similar a:

Foo exists: apple
Baz does not exist
array(2) {
  ["foo"]=>
  bool(true)
  ["bar"]=>
  bool(true)
}

Ver también

  • apcu_cache_info() - Recupera la información almacenada en la memoria APCu
  • apcu_fetch() - Fetch a stored variable from the cache


Fetch a stored variable from the cache

  • « apcu_exists
  • apcu_inc »
  • PHP Manual
  • Funciones APCu
  • Fetch a stored variable from the cache

apcu_fetch

(PECL apcu >= 4.0.0)

apcu_fetch — Fetch a stored variable from the cache

Descripción

apcu_fetch ( mixed $key , bool &$success = ? ) : mixed

Fetches an entry from the cache.

Parámetros

key

The key used to store the value (with apcu_store()). If an array is passed then each element is fetched and returned.

success

Set to true in success and false in failure.

Valores devueltos

The stored variable or array of variables on success; false on failure

Ejemplos

Ejemplo #1 A apcu_fetch() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

El resultado del ejemplo sería:

string(3) "BAR"

Historial de cambios

Versión | Descripción
PECL apcu 3.0.17 | The success parameter was added.

Ver también

  • apcu_store() - Cache a variable in the data store
  • apcu_delete() - Elimina una variable almacenada en caché
  • APCUIterator


Increase a stored number

  • « apcu_fetch
  • apcu_key_info »
  • PHP Manual
  • Funciones APCu
  • Increase a stored number

apcu_inc

(PECL apcu >= 4.0.0)

apcu_inc — Increase a stored number

Descripción

apcu_inc ( string $key , int $step = 1 , bool &$success = ? , int $ttl = 0 ) : int|false

Increases a stored number.

Parámetros

key

The key of the value being increased.

step

The step, or value to increase.

success

Optionally pass the success or fail boolean value to this referenced variable.

ttl

TTL to use if the operation inserts a new value (rather than incrementing an existing one).

Valores devueltos

Returns the current value of key's value on success, o false en caso de error

Historial de cambios

Versión | Descripción
5.1.12 | The ttl parameter has been added.

Ejemplos

Ejemplo #1 apcu_inc() example

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_inc('anumber'), PHP_EOL;
echo apcu_inc('anumber', 10), PHP_EOL;
echo apcu_inc('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_inc('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

El resultado del ejemplo sería algo similar a:

Let's do something with success
42
43
53
63
bool(true)
Now, let's fail

bool(false)
bool(false)

Ver también

  • apcu_dec() - Disminuir un número almacenado


Get detailed information about the cache key

  • « apcu_inc
  • apcu_sma_info »
  • PHP Manual
  • Funciones APCu
  • Get detailed information about the cache key

apcu_key_info

(No hay información de versión disponible, podría estar únicamente en Git)

apcu_key_info — Get detailed information about the cache key

Descripción

apcu_key_info ( string $key ) : array

Get detailed information about the cache key

Parámetros

key

Get detailed information about the cache key

Valores devueltos

null or array info

Ejemplos

Ejemplo #1 A apcu_key_info() example

<?php
apcu_add('a','b');
var_dump(apcu_key_info('a'));
?>

El resultado del ejemplo sería:

array(7) {
  ["hits"]=>
  int(0)
  ["access_time"]=>
  int(1606701783)
  ["mtime"]=>
  int(1606701783)
  ["creation_time"]=>
  int(1606701783)
  ["deletion_time"]=>
  int(0)
  ["ttl"]=>
  int(0)
  ["refs"]=>
  int(0)
}

Ver también

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Elimina una variable almacenada en caché


Retrieves APCu Shared Memory Allocation information

  • « apcu_key_info
  • apcu_store »
  • PHP Manual
  • Funciones APCu
  • Retrieves APCu Shared Memory Allocation information

apcu_sma_info

(PECL apcu >= 4.0.0)

apcu_sma_info — Retrieves APCu Shared Memory Allocation information

Descripción

apcu_sma_info ( bool $limited = false ) : array

Retrieves APCu Shared Memory Allocation information.

Parámetros

limited

When set to false (default) apcu_sma_info() will return a detailed information about each segment.

Valores devueltos

Array of Shared Memory Allocation data; false on failure.

Ejemplos

Ejemplo #1 A apcu_sma_info() example

<?php
print_r(apcu_sma_info());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [num_seg] => 1
    [seg_size] => 31457280
    [avail_mem] => 31448408
    [block_lists] => Array
        (
            [0] => Array
                (
                    [0] => Array
                        (
                            [size] => 31448408
                            [offset] => 8864
                        )

                )

        )

)

Ver también

  • APCu configuration directives


Cache a variable in the data store

  • « apcu_sma_info
  • APCUIterator »
  • PHP Manual
  • Funciones APCu
  • Cache a variable in the data store

apcu_store

(PECL apcu >= 4.0.0)

apcu_store — Cache a variable in the data store

Descripción

apcu_store ( string $key , mixed $var , int $ttl = 0 ) : bool
apcu_store ( array $values , mixed $unused = NULL , int $ttl = 0 ) : array

Cache a variable in the data store.

Nota: Unlike many other mechanisms in PHP, variables stored using apcu_store() will persist between requests (until the value is removed from the cache).

Parámetros

key

Store the variable using this name. keys are cache-unique, so storing a second value with the same key will overwrite the original value.

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Second syntax returns array with error keys.

Ejemplos

Ejemplo #1 A apcu_store() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

El resultado del ejemplo sería:

string(3) "BAR"

Ver también

  • apcu_add() - Cache a new variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Elimina una variable almacenada en caché


La clase APCUIterator

(PECL apcu >= 5.0.0)

Introducción

La clase APCUIterator hace más fácil iterar sobre grandes cachés de APCu. Esto es útil ya que permite iterar sobre grandes cachés en pasos, al mismo tiempo que captura un número definido de entradas por instancia de bloqueo, por lo que libera los bloqueos de caché para otras actividades en lugar de mantener todo el caché para obtener 100 entradas (el valor por defecto). Además, utilizar comparación por expresiones regulares es más eficiente ya que se ha movido al nivel de C.

Sinopsis de la Clase

APCUIterator implements Iterator {
/* Métodos */
public __construct ( mixed $search = null , int $format = APC_ITER_ALL , int $chunk_size = 100 , int $list = APC_LIST_ACTIVE )
public current ( ) : mixed
public getTotalCount ( ) : int
public getTotalHits ( ) : int
public getTotalSize ( ) : int
public key ( ) : string
public next ( ) : bool
public rewind ( ) : void
public valid ( ) : bool
}

Tabla de contenidos

  • APCUIterator::__construct — Construye un objeto iterador APCUIterator
  • APCUIterator::current — Obtener el elemento actual
  • APCUIterator::getTotalCount — Obtiene el conteo total
  • APCUIterator::getTotalHits — Obtener resultados totales de la memoria caché
  • APCUIterator::getTotalSize — Obtiene el tamaño total del caché
  • APCUIterator::key — Obtiene la clave del iterador
  • APCUIterator::next — Mueve el puntero al siguiente elemento
  • APCUIterator::rewind — Rebobina el iterador
  • APCUIterator::valid — Comprueba si la posición actual es válida


Construye un objeto iterador APCUIterator

  • « APCUIterator
  • APCUIterator::current »
  • PHP Manual
  • APCUIterator
  • Construye un objeto iterador APCUIterator

APCUIterator::__construct

(PECL apcu >= 5.0.0)

APCUIterator::__construct — Construye un objeto iterador APCUIterator

Descripción

public APCUIterator::__construct ( mixed $search = null , int $format = APC_ITER_ALL , int $chunk_size = 100 , int $list = APC_LIST_ACTIVE )

Construye un APCUIterator object.

Parámetros

search

Una expresión regular del PCRE que coincide con los nombres clave de la APCu, ya sea como string para una sola expresión regular, o como un array de expresiones regular. O, opcionalmente pasar en null para saltarse la búsqueda.

format

El formato deseado, tal como está configurado con una o más de las constantes APC_ITER_*.

chunk_size

El tamaño del fragmento. Debe ser un valor mayor que 0. El valor por defecto es 100.

list

El tipo de lista. O bien pasar en APC_LIST_ACTIVE o APC_LIST_DELETED.

Valores devueltos

Un APCUIterator object en caso de éxito, o null en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de APCUIterator::__construct()

<?php
foreach (new APCUIterator('/^counter\./') as $counter) {
    echo "$counter[key]: $counter[value]\n";
    apc_dec($counter['key'], $counter['value']);
}
?>

Ver también

  • apcu_exists() - Checks if entry exists
  • apcu_cache_info() - Recupera la información almacenada en la memoria APCu


Obtener el elemento actual

  • « APCUIterator::__construct
  • APCUIterator::getTotalCount »
  • PHP Manual
  • APCUIterator
  • Obtener el elemento actual

APCUIterator::current

(PECL apcu >= 5.0.0)

APCUIterator::current — Obtener el elemento actual

Descripción

public APCUIterator::current ( ) : mixed

Obtiene el elemento actual de la pila APCUIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el elemento actual en caso de éxito, o false si no hay más elementos o no existen, o en caso de error.

Ver también

  • APCUIterator::next() - Mueve el puntero al siguiente elemento
  • Iterator::current() - Devuelve el elemento actual


Obtiene el conteo total

  • « APCUIterator::current
  • APCUIterator::getTotalHits »
  • PHP Manual
  • APCUIterator
  • Obtiene el conteo total

APCUIterator::getTotalCount

(PECL apcu >= 5.0.0)

APCUIterator::getTotalCount — Obtiene el conteo total

Descripción

public APCUIterator::getTotalCount ( ) : int

Obtener el conteo total.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El conteo total.

Ver también

  • APCUIterator::getTotalHits() - Obtener resultados totales de la memoria caché
  • APCUIterator::getTotalSize() - Obtiene el tamaño total del caché
  • apcu_cache_info() - Recupera la información almacenada en la memoria APCu


Obtener resultados totales de la memoria caché

  • « APCUIterator::getTotalCount
  • APCUIterator::getTotalSize »
  • PHP Manual
  • APCUIterator
  • Obtener resultados totales de la memoria caché

APCUIterator::getTotalHits

(PECL apcu >= 5.0.0)

APCUIterator::getTotalHits — Obtener resultados totales de la memoria caché

Descripción

public APCUIterator::getTotalHits ( ) : int

Obtiene el número total de visitas a la memoria caché.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de visitas en caso de éxito, o false en caso de error.

Ver también

  • APCUIterator::getTotalCount() - Obtiene el conteo total
  • APCUIterator::getTotalSize() - Obtiene el tamaño total del caché
  • apcu_cache_info() - Recupera la información almacenada en la memoria APCu


Obtiene el tamaño total del caché

  • « APCUIterator::getTotalHits
  • APCUIterator::key »
  • PHP Manual
  • APCUIterator
  • Obtiene el tamaño total del caché

APCUIterator::getTotalSize

(PECL apcu >= 5.0.0)

APCUIterator::getTotalSize — Obtiene el tamaño total del caché

Descripción

public APCUIterator::getTotalSize ( ) : int

Obtiene el tamaño total del caché.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El tamaño total del caché.

Ver también

  • APCUIterator::getTotalCount() - Obtiene el conteo total
  • APCUIterator::getTotalHits() - Obtener resultados totales de la memoria caché
  • apc_cache_info()


Obtiene la clave del iterador

  • « APCUIterator::getTotalSize
  • APCUIterator::next »
  • PHP Manual
  • APCUIterator
  • Obtiene la clave del iterador

APCUIterator::key

(PECL apcu >= 5.0.0)

APCUIterator::key — Obtiene la clave del iterador

Descripción

public APCUIterator::key ( ) : string

Obtiene la clave del iterador actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clave en caso de éxito, o false en caso de error.

Ver también

  • APCUIterator::current() - Obtener el elemento actual
  • Iterator::key() - Devuelve la clave del elemento actual


Mueve el puntero al siguiente elemento

  • « APCUIterator::key
  • APCUIterator::rewind »
  • PHP Manual
  • APCUIterator
  • Mueve el puntero al siguiente elemento

APCUIterator::next

(PECL apcu >= 5.0.0)

APCUIterator::next — Mueve el puntero al siguiente elemento

Descripción

public APCUIterator::next ( ) : bool

Mueve el puntero del iterador al siguiente elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • APCUIterator::current() - Obtener el elemento actual
  • APCUIterator::rewind() - Rebobina el iterador
  • Iterator::next() - Avanza al siguiente elemento


Rebobina el iterador

  • « APCUIterator::next
  • APCUIterator::valid »
  • PHP Manual
  • APCUIterator
  • Rebobina el iterador

APCUIterator::rewind

(PECL apcu >= 5.0.0)

APCUIterator::rewind — Rebobina el iterador

Descripción

public APCUIterator::rewind ( ) : void

Rebobina el iterador hasta el primer elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • APCUIterator::next() - Mueve el puntero al siguiente elemento
  • Iterator::next() - Avanza al siguiente elemento


Comprueba si la posición actual es válida

  • « APCUIterator::rewind
  • Componere »
  • PHP Manual
  • APCUIterator
  • Comprueba si la posición actual es válida

APCUIterator::valid

(PECL apcu >= 5.0.0)

APCUIterator::valid — Comprueba si la posición actual es válida

Descripción

public APCUIterator::valid ( ) : bool

Comprueba si la posición actual del iterador es válida.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la posición actual del iterador es válida, en caso contrario false.

Ver también

  • APCUIterator::current() - Obtener el elemento actual
  • Iterator::valid() - Comprueba si la posición actual es válido


Componere

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • Componere\Abstract\Definition — La clase Componere\Abstract\Definition
    • Componere\Abstract\Definition::addInterface — Añadir Interface
    • Componere\Abstract\Definition::addMethod — Añadir método
    • Componere\Abstract\Definition::addTrait — Añadir rasgo
    • Componere\Abstract\Definition::getReflector — Reflection
  • Componere\Definition — La clase Componere\Definition
    • Componere\Definition::__construct — Constructor Definition
    • Componere\Definition::addConstant — Añade constante
    • Componere\Definition::addProperty — Añade propiedad
    • Componere\Definition::register — Registro
    • Componere\Definition::isRegistered — Detección del estado
    • Componere\Definition::getClosure — Obtener Cierre
    • Componere\Definition::getClosures — Obtener Cierres
  • Componere\Patch — La clase Componere\Patch
    • Componere\Patch::__construct — Constructor Patch
    • Componere\Patch::apply — Aplicación
    • Componere\Patch::revert — Reversión
    • Componere\Patch::isApplied — Detección del estado
    • Componere\Patch::derive — Derivación del parche
    • Componere\Patch::getClosure — Obtener Cierre
    • Componere\Patch::getClosures — Obtener Cierres
  • Componere\Method — La clase Componere\Method
    • Componere\Method::__construct — Constructor Method
    • Componere\Method::setPrivate — Modificación de la accesibilidad
    • Componere\Method::setProtected — Modificación de la accesibilidad
    • Componere\Method::setStatic — Modificación de la accesibilidad
    • Componere\Method::getReflector — Reflection
  • Componere\Value — La clase Componere\Value
    • Componere\Value::__construct — Constructor Value
    • Componere\Value::setPrivate — Modificación de la accesibilidad
    • Componere\Value::setProtected — Modificación de la accesibilidad
    • Componere\Value::setStatic — Modificación de la accesibilidad
    • Componere\Value::isPrivate — Detección de accesibilidad
    • Componere\Value::isProtected — Detección de accesibilidad
    • Componere\Value::isStatic — Detección de accesibilidad
    • Componere\Value::hasDefault — Interacción de Value
  • Funciones Componere
    • Componere\cast — Moldeado
    • Componere\cast_by_ref — Moldeado


Introducción

Componere (latin, English: compose) se dirige a los entornos de producción y proporciona una API para composición de las clases, parches y moldeado.

Composición:

Componere\Definition se utiliza para definir (o redefinir) una clase en tiempo de ejecución; La clase puede entonces registrarse, y en caso de redefinición reemplaza a la clase original durante todo el tiempo que la clase Componere\Definition exista.

public Componere\Patch::__construct ( object $instance )
public Componere\Patch::__construct ( object $instance , array $interfaces )

Parcheado:

Componere\Patch se utiliza para cambiar la clase de una instancia específica de un objeto en tiempo de ejecución; Tras su aplicación, el parche permanecerá aplicado durante todo el tiempo que la clase Componere\Patch exista, y puede ser revertido explícitamente.

public Componere\Patch::__construct ( object $instance )
public Componere\Patch::__construct ( object $instance , array $interfaces )

Moldeado:

Componere\ Las funciones de moldeado pueden moldear entre tipos compatibles definidos por el usuario; Donde compatible significa Type es sub o super al tipo de object.

Componere\cast ( Type $type , $object ) : Type
Componere\cast_by_ref ( Type $type , $object ) : Type


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • Componere
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Se requiere Reflection


  • « Requerimientos
  • Componere\Abstract\Definition »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

La fuente de Componere y las liberaciones están disponibles en » github


La clase Componere\Abstract\Definition

(Componere 2 >= 2.1.0)

Introducción

Esta abstracta final representa una entrada de clase, y no debe ser usado por el programador.

Sinopsis de la Clase

final abstract Componere\Abstract\Definition {
/* Métodos */
public addInterface ( string $interface ) : Definition
public addMethod ( string $name , \Componere\Method $method ) : Definition
public addTrait ( string $trait ) : Definition
public getReflector ( ) : \ReflectionClass
}

Tabla de contenidos

  • Componere\Abstract\Definition::addInterface — Añadir Interface
  • Componere\Abstract\Definition::addMethod — Añadir método
  • Componere\Abstract\Definition::addTrait — Añadir rasgo
  • Componere\Abstract\Definition::getReflector — Reflection


Añadir Interface

  • « Componere\Abstract\Definition
  • Componere\Abstract\Definition::addMethod »
  • PHP Manual
  • Componere\Abstract\Definition
  • Añadir Interface

Componere\Abstract\Definition::addInterface

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addInterface — Añadir Interface

Descripción

public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition

Implementará la interface dada en la definición actual

Parámetros

interface

El nombre de una interface insensible a las mayúsculas y minúsculas

Valores devueltos

La definición actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró


Añadir método

  • « Componere\Abstract\Definition::addInterface
  • Componere\Abstract\Definition::addTrait »
  • PHP Manual
  • Componere\Abstract\Definition
  • Añadir método

Componere\Abstract\Definition::addMethod

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addMethod — Añadir método

Descripción

public Componere\Abstract\Definition::addMethod ( string $name , \Componere\Method $method ) : Definition

Creará o anulará un método en la definición actual.

Parámetros

name

El nombre del método insensible a las mayúsculas y minúsculas

method

\Componere\Method que no se haya añadido previamente a otra Definition

Valores devueltos

La Definition actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró

Advertencia

Lanzará RuntimeException si el método se añadió a otra definición


Añadir rasgo

  • « Componere\Abstract\Definition::addMethod
  • Componere\Abstract\Definition::getReflector »
  • PHP Manual
  • Componere\Abstract\Definition
  • Añadir rasgo

Componere\Abstract\Definition::addTrait

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addTrait — Añadir rasgo

Descripción

public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition

Usará el rasgo dado para la definición actual

Parámetros

trait

El nombre del rasgo insensible a las mayúsculas y minúsculas

Valores devueltos

La definición actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró


Reflection

  • « Componere\Abstract\Definition::addTrait
  • Componere\Definition »
  • PHP Manual
  • Componere\Abstract\Definition
  • Reflection

Componere\Abstract\Definition::getReflector

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::getReflector — Reflection

Descripción

public Componere\Abstract\Definition::getReflector ( ) : \ReflectionClass

Creará o devolverá una clase Reflection

Valores devueltos

Una clase Reflection para la definición actual (en caché)


La clase Componere\Definition

(Componere 2 >= 2.1.0)

Introducción

La clase Definition permite al programador construir y registrar un tipo en tiempo de ejecución.

En caso de que una Definition reemplace una clase existente, la clase existente será restaurada cuando la Definition sea destruida.

Sinopsis de la Clase

final Componere\Definition extends Componere\Abstract\Definition {
/* Constructores */
public __construct ( string $name )
public __construct ( string $name , string $parent )
public __construct ( string $name , array $interfaces )
public __construct ( string $name , string $parent , array $interfaces )
/* Métodos */
public addConstant ( string $name , \Componere\Value $value ) : Definition
public addProperty ( string $name , \Componere\Value $value ) : Definition
public register ( ) : void
public isRegistered ( ) : bool
public getClosure ( string $name ) : \Closure
public getClosures ( ) : array
/* Métodos heredados */
public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition
public Componere\Abstract\Definition::addMethod ( string $name , \Componere\Method $method ) : Definition
public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition
public Componere\Abstract\Definition::getReflector ( ) : \ReflectionClass
}

Tabla de contenidos

  • Componere\Definition::__construct — Constructor Definition
  • Componere\Definition::addConstant — Añade constante
  • Componere\Definition::addProperty — Añade propiedad
  • Componere\Definition::register — Registro
  • Componere\Definition::isRegistered — Detección del estado
  • Componere\Definition::getClosure — Obtener Cierre
  • Componere\Definition::getClosures — Obtener Cierres


Constructor Definition

  • « Componere\Definition
  • Componere\Definition::addConstant »
  • PHP Manual
  • Componere\Definition
  • Constructor Definition

Componere\Definition::__construct

(Componere 2 >= 2.1.0)

Componere\Definition::__construct — Constructor Definition

Descripción

public Componere\Definition::__construct ( string $name )
public Componere\Definition::__construct ( string $name , string $parent )
public Componere\Definition::__construct ( string $name , array $interfaces )
public Componere\Definition::__construct ( string $name , string $parent , array $interfaces )

Parámetros

name

Un nombre de clase insensible a las mayúsculas y minúsculas

parent

Un nombre de clase insensible a las mayúsculas y minúsculas

interfaces

Un array de nombres de clase insensibles a las mayúsculas y minúsculas

Exceptions

Advertencia

Lanzará InvalidArgumentException si se intenta reemplazar una clase interna

Advertencia

Lanzará InvalidArgumentException si se intenta sustituir una interface

Advertencia

Lanzará InvalidArgumentException si se intenta reemplazar un rasgo

Advertencia

Lanzará RuntimeException si una clase en interfaces no se puede encontrar

Advertencia

Lanzará RuntimeException si una clase en interfaces no es una interface


Añade constante

  • « Componere\Definition::__construct
  • Componere\Definition::addProperty »
  • PHP Manual
  • Componere\Definition
  • Añade constante

Componere\Definition::addConstant

(Componere 2 >= 2.1.0)

Componere\Definition::addConstant — Añade constante

Descripción

public Componere\Definition::addConstant ( string $name , \Componere\Value $value ) : Definition

Declarará una constante de clase en la definición actual

Parámetros

name

El nombre de la constante que distingue entre mayúsculas y minúsculas

value

El valor de la constante, no debe ser indefinido o estático

Valores devueltos

La definición actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition fué registrado

Advertencia

Lanzará RuntimeException si name ya está declarada como una constante

Advertencia

Lanzará RuntimeException si value es estática

Advertencia

Lanzará RuntimeException si value no está definida


Añade propiedad

  • « Componere\Definition::addConstant
  • Componere\Definition::register »
  • PHP Manual
  • Componere\Definition
  • Añade propiedad

Componere\Definition::addProperty

(Componere 2 >= 2.1.0)

Componere\Definition::addProperty — Añade propiedad

Descripción

public Componere\Definition::addProperty ( string $name , \Componere\Value $value ) : Definition

Declarará una propiedad de clase sobre la definición actual

Parámetros

name

El nombre de la propiedad distingue mayúsculas y minúsculas

value

El valor por omisión de la propiedad

Valores devueltos

La definición actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró

Advertencia

Lanzará RuntimeException si name ya está declarada como una propiedad


Registro

  • « Componere\Definition::addProperty
  • Componere\Definition::isRegistered »
  • PHP Manual
  • Componere\Definition
  • Registro

Componere\Definition::register

(Componere 2 >= 2.1.0)

Componere\Definition::register — Registro

Descripción

public Componere\Definition::register ( ) : void

Registrará la Definition actual

Exceptions

Advertencia

Lanzará RuntimeException si Definition fué registrada


Detección del estado

  • « Componere\Definition::register
  • Componere\Definition::getClosure »
  • PHP Manual
  • Componere\Definition
  • Detección del estado

Componere\Definition::isRegistered

(Componere 2 >= 2.1.0)

Componere\Definition::isRegistered — Detección del estado

Descripción

public Componere\Definition::isRegistered ( ) : bool

Deberá detectar el estado de registro de Definition

Valores devueltos

Devolverá true si Definition está registrada


Obtener Cierre

  • « Componere\Definition::isRegistered
  • Componere\Definition::getClosures »
  • PHP Manual
  • Componere\Definition
  • Obtener Cierre

Componere\Definition::getClosure

(Componere 2 >= 2.1.0)

Componere\Definition::getClosure — Obtener Cierre

Descripción

public Componere\Definition::getClosure ( string $name ) : \Closure

Devolverá un cierre para el método especificado por el nombre

Parámetros

name

El nombre del método insensible a las mayúsculas y minúsculas

Valores devueltos

Un cierre vinculado al alcance correcto

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró

Advertencia

Lanzará RuntimeException si name no se pudo encontrar


Obtener Cierres

  • « Componere\Definition::getClosure
  • Componere\Patch »
  • PHP Manual
  • Componere\Definition
  • Obtener Cierres

Componere\Definition::getClosures

(Componere 2 >= 2.1.0)

Componere\Definition::getClosures — Obtener Cierres

Descripción

public Componere\Definition::getClosures ( ) : array

Devolverá un array de cierres

Valores devueltos

Devolverá todos los métodos como un array de objetos de cierre vinculados al alcance correcto

Exceptions

Advertencia

Lanzará RuntimeException si Definition se registró


La clase Componere\Patch

(Componere 2 >= 2.1.0)

Introducción

La clase Patch permite al programador cambiar el tipo de una instancia en tiempo de ejecución sin registrar una nueva Definition

Cuando se destruye un parche se revierte, de modo que los casos que fueron parcheados durante la vida del Parche son restaurados a su tipo formal.

Sinopsis de la Clase

final Componere\Patch extends Componere\Abstract\Definition {
/* Constructors */
public __construct ( object $instance )
public __construct ( object $instance , array $interfaces )
/* Métodos */
public apply ( ) : void
public revert ( ) : void
public isApplied ( ) : bool
public derive ( object $instance ) : Patch
public getClosure ( string $name ) : \Closure
public getClosures ( ) : array
/* Métodos heredados */
public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition
public Componere\Abstract\Definition::addMethod ( string $name , \Componere\Method $method ) : Definition
public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition
public Componere\Abstract\Definition::getReflector ( ) : \ReflectionClass
}

Tabla de contenidos

  • Componere\Patch::__construct — Constructor Patch
  • Componere\Patch::apply — Aplicación
  • Componere\Patch::revert — Reversión
  • Componere\Patch::isApplied — Detección del estado
  • Componere\Patch::derive — Derivación del parche
  • Componere\Patch::getClosure — Obtener Cierre
  • Componere\Patch::getClosures — Obtener Cierres


Constructor Patch

  • « Componere\Patch
  • Componere\Patch::apply »
  • PHP Manual
  • Componere\Patch
  • Constructor Patch

Componere\Patch::__construct

(Componere 2 >= 2.1.0)

Componere\Patch::__construct — Constructor Patch

Descripción

public Componere\Patch::__construct ( object $instance )
public Componere\Patch::__construct ( object $instance , array $interfaces )

Parámetros

instance

El objetivo de este Patch

interfaces

Un array de nombres de clase insensibles a las mayúsculas y minúsculas

Exceptions

Advertencia

Lanzará RuntimeException si una clase en interfaces no se puede encontrar

Advertencia

Lanzará RuntimeException si una clase en interfaces no es una interface


Aplicación

  • « Componere\Patch::__construct
  • Componere\Patch::revert »
  • PHP Manual
  • Componere\Patch
  • Aplicación

Componere\Patch::apply

(Componere 2 >= 2.1.0)

Componere\Patch::apply — Aplicación

Descripción

public Componere\Patch::apply ( ) : void

Aplicará el parche actual


Reversión

  • « Componere\Patch::apply
  • Componere\Patch::isApplied »
  • PHP Manual
  • Componere\Patch
  • Reversión

Componere\Patch::revert

(Componere 2 >= 2.1.0)

Componere\Patch::revert — Reversión

Descripción

public Componere\Patch::revert ( ) : void

Revertirá el parche actual


Detección del estado

  • « Componere\Patch::revert
  • Componere\Patch::derive »
  • PHP Manual
  • Componere\Patch
  • Detección del estado

Componere\Patch::isApplied

(Componere 2 >= 2.1.0)

Componere\Patch::isApplied — Detección del estado

Descripción

public Componere\Patch::isApplied ( ) : bool


Derivación del parche

  • « Componere\Patch::isApplied
  • Componere\Patch::getClosure »
  • PHP Manual
  • Componere\Patch
  • Derivación del parche

Componere\Patch::derive

(Componere 2 >= 2.1.1)

Componere\Patch::derive — Derivación del parche

Descripción

public Componere\Patch::derive ( object $instance ) : Patch

Derivará un Patch (parche) para la instance (instancia) dada

Parámetros

instance

El objetivo del Parche derivado

Valores devueltos

Patch (parche) para la instance (instancia) derivada del Patch (parche) actual

Exceptions

Advertencia

Lanzará InvalidArgumentException si instance no es compatible


Obtener Cierre

  • « Componere\Patch::derive
  • Componere\Patch::getClosures »
  • PHP Manual
  • Componere\Patch
  • Obtener Cierre

Componere\Patch::getClosure

(Componere 2 >= 2.1.0)

Componere\Patch::getClosure — Obtener Cierre

Descripción

public Componere\Patch::getClosure ( string $name ) : \Closure

Devolverá un cierre para el método especificado por el nombre

Parámetros

name

El nombre del método insensible a las mayúsculas y minúsculas

Valores devueltos

Un cierre vinculado al ámbito y objeto correctos

Exceptions

Advertencia

Lanzará RuntimeException si name no se pudo encontrar


Obtener Cierres

  • « Componere\Patch::getClosure
  • Componere\Method »
  • PHP Manual
  • Componere\Patch
  • Obtener Cierres

Componere\Patch::getClosures

(Componere 2 >= 2.1.0)

Componere\Patch::getClosures — Obtener Cierres

Descripción

public Componere\Patch::getClosures ( ) : array

Devolverá un array de Cierres

Valores devueltos

Devolverá todos los métodos como un array de objetos de cierre unidos al ámbito y objeto correctos


La clase Componere\Method

(Componere 2 >= 2.1.0)

Introducción

Un método representa una función con banderas de accesibilidad modificables

Sinopsis de la Clase

final Componere\Method {
/* Constructor */
public __construct ( \Closure $closure )
/* Métodos */
public setPrivate ( ) : Method
public setProtected ( ) : Method
public setStatic ( ) : Method
public getReflector ( ) : \ReflectionMethod
}

Tabla de contenidos

  • Componere\Method::__construct — Constructor Method
  • Componere\Method::setPrivate — Modificación de la accesibilidad
  • Componere\Method::setProtected — Modificación de la accesibilidad
  • Componere\Method::setStatic — Modificación de la accesibilidad
  • Componere\Method::getReflector — Reflection


Constructor Method

  • « Componere\Method
  • Componere\Method::setPrivate »
  • PHP Manual
  • Componere\Method
  • Constructor Method

Componere\Method::__construct

(Componere 2 >= 2.1.0)

Componere\Method::__construct — Constructor Method

Descripción

public Componere\Method::__construct ( \Closure $closure )

Parámetros

closure


Modificación de la accesibilidad

  • « Componere\Method::__construct
  • Componere\Method::setProtected »
  • PHP Manual
  • Componere\Method
  • Modificación de la accesibilidad

Componere\Method::setPrivate

(Componere 2 >= 2.1.0)

Componere\Method::setPrivate — Modificación de la accesibilidad

Descripción

public Componere\Method::setPrivate ( ) : Method

Valores devueltos

El método actual

Exceptions

Advertencia

Lanzará RuntimeException si el nivel de acceso fue establecido previamente


Modificación de la accesibilidad

  • « Componere\Method::setPrivate
  • Componere\Method::setStatic »
  • PHP Manual
  • Componere\Method
  • Modificación de la accesibilidad

Componere\Method::setProtected

(Componere 2 >= 2.1.0)

Componere\Method::setProtected — Modificación de la accesibilidad

Descripción

public Componere\Method::setProtected ( ) : Method

Valores devueltos

El método actual

Exceptions

Advertencia

Lanzará RuntimeException si el nivel de acceso fue establecido previamente


Modificación de la accesibilidad

  • « Componere\Method::setProtected
  • Componere\Method::getReflector »
  • PHP Manual
  • Componere\Method
  • Modificación de la accesibilidad

Componere\Method::setStatic

(Componere 2 >= 2.1.0)

Componere\Method::setStatic — Modificación de la accesibilidad

Descripción

public Componere\Method::setStatic ( ) : Method

Valores devueltos

El método actual


Reflection

  • « Componere\Method::setStatic
  • Componere\Value »
  • PHP Manual
  • Componere\Method
  • Reflection

Componere\Method::getReflector

(Componere 2 >= 2.1.0)

Componere\Method::getReflector — Reflection

Descripción

public Componere\Method::getReflector ( ) : \ReflectionMethod

Creará o devolverá un Método de Reflection

Valores devueltos

Un método de Reflection para el método actual (en caché)


La clase Componere\Value

(Componere 2 >= 2.1.0)

Introducción

Una clase Value representa una variable PHP de todos los tipos, incluyendo las indefinidas

Sinopsis de la Clase

final Componere\Value {
/* Constructor */
public __construct ( $default = ? )
/* Métodos */
public setPrivate ( ) : Value
public setProtected ( ) : Value
public setStatic ( ) : Value
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isStatic ( ) : bool
public hasDefault ( ) : bool
}

Tabla de contenidos

  • Componere\Value::__construct — Constructor Value
  • Componere\Value::setPrivate — Modificación de la accesibilidad
  • Componere\Value::setProtected — Modificación de la accesibilidad
  • Componere\Value::setStatic — Modificación de la accesibilidad
  • Componere\Value::isPrivate — Detección de accesibilidad
  • Componere\Value::isProtected — Detección de accesibilidad
  • Componere\Value::isStatic — Detección de accesibilidad
  • Componere\Value::hasDefault — Interacción de Value


Constructor Value

  • « Componere\Value
  • Componere\Value::setPrivate »
  • PHP Manual
  • Componere\Value
  • Constructor Value

Componere\Value::__construct

(Componere 2 >= 2.1.0)

Componere\Value::__construct — Constructor Value

Descripción

public Componere\Value::__construct ( $default = ? )

Parámetros

default

Exceptions

Advertencia

Lanzará InvalidArgumentException si default no tiene un valor adecuado


Modificación de la accesibilidad

  • « Componere\Value::__construct
  • Componere\Value::setProtected »
  • PHP Manual
  • Componere\Value
  • Modificación de la accesibilidad

Componere\Value::setPrivate

(Componere 2 >= 2.1.0)

Componere\Value::setPrivate — Modificación de la accesibilidad

Descripción

public Componere\Value::setPrivate ( ) : Value

Valores devueltos

El valor actual

Exceptions

Advertencia

Lanzará RuntimeException si el nivel de acceso fue establecido previamente


Modificación de la accesibilidad

  • « Componere\Value::setPrivate
  • Componere\Value::setStatic »
  • PHP Manual
  • Componere\Value
  • Modificación de la accesibilidad

Componere\Value::setProtected

(Componere 2 >= 2.1.0)

Componere\Value::setProtected — Modificación de la accesibilidad

Descripción

public Componere\Value::setProtected ( ) : Value

Valores devueltos

El valor actual

Exceptions

Advertencia

Lanzará RuntimeException si el nivel de acceso fue establecido previamente


Modificación de la accesibilidad

  • « Componere\Value::setProtected
  • Componere\Value::isPrivate »
  • PHP Manual
  • Componere\Value
  • Modificación de la accesibilidad

Componere\Value::setStatic

(Componere 2 >= 2.1.0)

Componere\Value::setStatic — Modificación de la accesibilidad

Descripción

public Componere\Value::setStatic ( ) : Value

Valores devueltos

El valor actual


Detección de accesibilidad

  • « Componere\Value::setStatic
  • Componere\Value::isProtected »
  • PHP Manual
  • Componere\Value
  • Detección de accesibilidad

Componere\Value::isPrivate

(Componere 2 >= 2.1.0)

Componere\Value::isPrivate — Detección de accesibilidad

Descripción

public Componere\Value::isPrivate ( ) : bool


Detección de accesibilidad

  • « Componere\Value::isPrivate
  • Componere\Value::isStatic »
  • PHP Manual
  • Componere\Value
  • Detección de accesibilidad

Componere\Value::isProtected

(Componere 2 >= 2.1.0)

Componere\Value::isProtected — Detección de accesibilidad

Descripción

public Componere\Value::isProtected ( ) : bool


Detección de accesibilidad

  • « Componere\Value::isProtected
  • Componere\Value::hasDefault »
  • PHP Manual
  • Componere\Value
  • Detección de accesibilidad

Componere\Value::isStatic

(Componere 2 >= 2.1.0)

Componere\Value::isStatic — Detección de accesibilidad

Descripción

public Componere\Value::isStatic ( ) : bool


Interacción de Value

  • « Componere\Value::isStatic
  • Funciones Componere »
  • PHP Manual
  • Componere\Value
  • Interacción de Value

Componere\Value::hasDefault

(Componere 2 >= 2.1.0)

Componere\Value::hasDefault — Interacción de Value

Descripción

public Componere\Value::hasDefault ( ) : bool


  • « Componere\Value::hasDefault
  • Componere\cast »
  • PHP Manual
  • Componere
  • Funciones Componere

Funciones Componere

Tabla de contenidos

  • Componere\cast — Moldeado
  • Componere\cast_by_ref — Moldeado


Moldeado

  • « Funciones Componere
  • Componere\cast_by_ref »
  • PHP Manual
  • Funciones Componere
  • Moldeado

Componere\cast

(Componere 2 >= 2.1.2)

Componere\cast — Moldeado

Descripción

Componere\cast ( Type $type , $object ) : Type

Parámetros

type

Un tipo definido por el usuario

object

Un objeto con un tipo definido por el usuario compatible con Type

Valores devueltos

Un object de tipo Type, moldeado de object

Exceptions

Advertencia

Lanzará InvalidArgumentException si el tipo de object es o se deriva de una clase interna

Advertencia

Lanzará InvalidArgumentException si Type es una interface

Advertencia

Lanzará InvalidArgumentException si Type es un rasgo

Advertencia

Lanzará InvalidArgumentException si Type es una abstracta

Advertencia

Lanzará InvalidArgumentException si Type no es compatible con el tipo de object

Ver también

  • Componere\cast_by_ref


Moldeado

  • « Componere\cast
  • Manejo de errores »
  • PHP Manual
  • Funciones Componere
  • Moldeado

Componere\cast_by_ref

(Componere 2 >= 2.1.2)

Componere\cast_by_ref — Moldeado

Descripción

Componere\cast_by_ref ( Type $type , $object ) : Type

Parámetros

type

Un tipo definido por el usuario

object

Un objeto con un tipo definido por el usuario compatible con Type

Valores devueltos

Un object de tipo Type, moldeado de object, donde los miembros son referencias a miembros de object

Exceptions

Advertencia

Lanzará InvalidArgumentException si el tipo de object es o se deriva de una clase interna

Advertencia

Lanzará InvalidArgumentException si Type es una interface

Advertencia

Lanzará InvalidArgumentException si Type es un rasgo

Advertencia

Lanzará InvalidArgumentException si Type es una abstracta

Advertencia

Lanzará InvalidArgumentException si Type no es compatible con el tipo de object

Ver también

  • Componere\cast


Manejo y registro de errores

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Manejo de Errores
    • debug_backtrace — Genera un rastreo
    • debug_print_backtrace — Muestra un rastreo
    • error_clear_last — Limpiar el error más reciente
    • error_get_last — Obtener el último error que ocurrió
    • error_log — Enviar un mensaje de error a las rutinas de manejo de errores definidas
    • error_reporting — Establece cuáles errores de PHP son notificados
    • restore_error_handler — Recupera la función de gestión de errores previa
    • restore_exception_handler — Restaura la función de gestión de excepciones previamente definida
    • set_error_handler — Establecer una función de gestión de errores definida por el usuario
    • set_exception_handler — Establece una función de gestión de excepciones definida por el usuario
    • trigger_error — Generar un mensaje de error/advertencia/aviso de nivel de usuario
    • user_error — Alias de trigger_error


Introducción

Estas funciones se ocupan del manejo y registro de errores. Le permiten definir sus propias reglas de manejo de errores, así como modificar la manera en que los errores pueden ser registrados. Esto le permite cambiar y mejorar la notificación de errores para acomodarla a sus necesidades.

Con las funciones de registro se pueden enviar mensajes directamente a otras máquinas, a un e-mail (¡o un e-mail a un busca!), al registro del sistema, etc., por lo que puede registrar y monitorizar selectivamente las partes más importantes de sus aplicaciones y sitios web.

Las funciones de notificación de errores le permiten personalizar qué niveles y tipos de errores se dan, abarcando desde simples avisos hasta funciones personalizadas devueltas al originarse un error.


  • « Requerimientos
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

No se requiere de ninguna instalación para utilizar estas funciones; forman parte del núcleo de PHP.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de errores y registro
Nombre | Por defecto | Cambiable | Historial de cambios
error_reporting | NULL | PHP_INI_ALL |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
ignore_repeated_errors | "0" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
ignore_repeated_source | "0" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
report_memleaks | "1" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
track_errors | "0" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP <= 4.2.3.
xmlrpc_errors | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 4.1.0.
xmlrpc_error_number | "0" | PHP_INI_ALL | Disponible a partir de PHP 4.1.0.
docref_root | "" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
docref_ext | "" | PHP_INI_ALL | Disponible a partir de PHP 4.3.2.
error_prepend_string | NULL | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
syslog.facility | "LOG_USER" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.3.0.
syslog.filter | "no-ctrl" | PHP_INI_ALL | Disponible a partir de PHP 7.3.0.
syslog.ident | "php" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.3.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

error_reporting integer

Establece el nivel de notificación de errores. El parámetro es o bien un valor de tipo integer que representa un campo de bits, o bien constantes con nombre. Los niveles de error_reporting y las constantes están descritos en Constantes predefinidas, y en php.ini. Para establecerlo en tiempo de ejecución, se ha de usar la función error_reporting(). Vése también la directiva display_errors.

En PHP 5.3 o posterior, el valor predeterminado es E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED. Este ajuste no muestra los niveles de error E_NOTICE, E_STRICT y E_DEPRECATED. Quizás quiera mostrarlos durante el desarrollo. Antes de PHP 5.3.0, el valor predeterminado es E_ALL & ~E_NOTICE & ~E_STRICT. en PHP, el valor predeterminado es E_ALL & ~E_NOTICE.

Nota:

La habilitación de E_NOTICE durante el desarrollo tiene algunos beneficios. Para las depuración: los mensajes NOTICE avisarán de posibles errores en el código. Por ejemplo, se advierte del uso de valores no asignados. Es extremadamente útil para encontrar errartas y ahorrar tiempo en la depuración. Los mensajes NOTICE avisarán de un estilo malo. Por ejemplo, $arr[item] es mejor que sea escrito como $arr['item'] ya que PHP intenta tratar "item" como una constante. Si no es una constante, PHP asume que es un índice de string del array.

Nota:

En PHP 5 está disponible el nuevo nivel de error E_STRICT. Antes de PHP 5.4.0, E_STRICT no estaba incluido dentro de E_ALL, por lo que se teniía de habilitar explícitamente este tipo de nivel de error en PHP < 5.4.0. La habilitación de E_STRICT durante el desarrollo tiene algunos beneficios. Los mensajes STRICT proporcionan sugerencias que pueden ayudar a asegurarse de la mejor interoperabilidad y la compatibilidad hacia delante del código. Estos mensajes pueden incluir cosas como llamar a métodos no estáticos de forma estática, definir propiedades en una definición de clase compatible mientras se definió en un trait usado, y antes de PHP 5.3, algunas características obsoletas emitirían errores E_STRICT como asignar objetos por referencias durante la instanciación.

Nota: Constantes de PHP fuera de PHP

El uso de constantes de PHP fuera de PHP, como en httpd.conf, no tiene un propósito útil, por lo que, en tales casos, se requerirán los valores de tipo integer. Y ya que se añadirán más niveles de error en el futuro, el valor máximo (para E_ALL) cambiará igualmente. Por lo que, en lugar de E_ALL se ha de considerar el uso de un valor grande para cubrir todos los campos de bits desde la actualidad hasta bien entrado en el futuro, un valor numérico como 2147483647 (incluye todos los errores, no sólo E_ALL).

display_errors string

Determina si los errores deberían ser impresos en pantalla como parte de la salida o si deberían ocultarse al usuario.

El valor "stderr" envía los errores a stderr en vez de a stdout. Este valor está disponible a partir de PHP 5.2.4. En versiones anteriores esta directiva era de tipo boolean.

Nota:

Ésta es una característica para ayudar al desarrollo y nunca debería usarse en sistemas de producción (p.ej. en sistemas conectados a internet).

Nota:

Aunque display_errors puede ser establecido en tiempo de ejecución (con ini_set()), no tendrá ningún efecto si el script tiene errores fatales. Esto es debido a que la acción deseada en tiempo de ejecución no se ejecuta.

display_startup_errors boolean

Incluso cuando display_errors está activado, los errores que ocurren durante la secuencia de arranque de PHP no se muestran. Se recomienda encarecidamente mantener desactivado display_startup_errors, excepto para la depuración.

log_errors boolean

Indica si los mensajes de error del script deberían de registrarse en el registro del servidor o en error_log. Esta opción es, por lo tanto, específica para servidores.

Nota:

Se aconseja encarecidamente usar el registro de errores en lugar de mostrar los errores en sitios web de producción.

log_errors_max_len integer

Establece la longitud máxima de log_errors en bytes. En error_log se añade información acerca del origen. El valor predeterminado es 1024, y 0 permite no aplicar ninguna longitud máxima en absoluto. Esta longitud se aplica a los errores registrados, a los errores mostrados y también a $php_errormsg, pero no a las funciones llamadas explícitamente tal come error_log().

Cuando se usa un integer, el valor del mismo es medido en bytes. También se puede usar la notación reducida, tal como se describe en esta FAQ.
ignore_repeated_errors boolean

No registra mensajes repetidos. Los mensajes repetidos deben ocurrir en la misma línea del mismo fichero a menos que ignore_repeated_source esté establecido a true.

ignore_repeated_source boolean

Ignora el origen del mensaje cuando se ignoran mensajes repetidos. Cuando este ajuste está activado (On) no se registrarán errores con mensajes repetidos de diferentes ficheros o líneas del código fuente.

report_memleaks boolean

Si este parámetro está activado (On), que es lo predeterminado, mostrará un informe de pérdidas de memoria detectado por el gestor de memoria Zend. Este informe será enviado a stderr en las plataformas Posix. En Windows, será enviado al depurador usando OutputDebugString(), y podrá ser visto con herramientas como » DbgView. Este parámetro solo tiene efecto en una versión de depuración, y si error_reporting incluye E_WARNING en la lista permitida.

track_errors boolean

Si está habilitado, el último mensaje de error siempre estará presente en la variable $php_errormsg.

html_errors boolean

Si se habilita, los mensajes de error incluirán etiquetas HTML. El formato para los errores HTML produce mensajes clicables que dirigen al usuario a una página que describe el error o función que causó el error. Estas referencias se ven afectadas por docref_root y docref_ext.

Si se inhabilita, el mensaje de error será solamente texto plano.

xmlrpc_errors boolean

Si se habilita, se desactiva el reporte de errores normal y se formatean los errores como mensajes de error XML-RPC.

xmlrpc_error_number integer

Usado como el valor del elemento faultCode de XML-RPC.

docref_root string

El nuevo formato de error contiene una referencia a una página que describe el error o a la función que causa el error. En caso de páginas de manual, se puede descargar el manual en su idioma y establecer esta directiva ini al URL de su copia local. Si a su copia local del manual se puede llegar mediante "/manual/" puede usar simplemente docref_root=/manual/. Además tiene que establecer docref_ext para que coincida con las extensiones de fichero de su copia docref_ext=.html. Es posible usar referencias externas. Por ejemplo, se puede usar docref_root=http://manual/en/ o docref_root="http://landonize.it/?how=url&theme=classic&filter=Landon &url=http%3A%2F%2Fwww.php.net%2F"

La mayoría de las veces será necesario que el valor de docref_root termine con una barra "/". Sin embargo, veáse el segundo ejemplo de antes, el cuál ni la tiene ni la necesita.

Nota:

Esta es una característica para ayudar al desarrollo, ya que hace más fácil buscar una descripción de una función. Sin embargo, nunca debería usarse en sistemas de producción (p.ej. en sistemas conectados a internet).

docref_ext string

Véase docref_root.

Nota:

El valor de docref_ext debe comenzar con un punto ".".

error_prepend_string string

String a imprimir antes de un mensaje de error.

error_append_string string

String a imprimir después de un mensaje de error.

error_log string

Nombre del fichero donde los errores del script deberían ser registrados. El fichero debería ser modificable por el usuario del servidor web. Si se usa el valor especial syslog, los errores son enviados en su lugar al registro del sistema. En Unix, esto quiere decir syslog(3) y en Windows quiere decir el registro de sucesos. Véase también: syslog(). Si esta directiva no está establecida, los errores se enviarán al registro de error de la SAPI. Por ejemplo, un registro de error en Apache o stderr en CLI. Véase también error_log().

syslog.facility string

Especifica el tipo de programa que está registrando el mensaje. Solamente efectivo si error_log se establece a "syslog".

syslog.filter string

Especifica el tipo de filtro a aplicar a los mensajes registrados. Los caracteres pertimitos se pasan sin modificar; los demás se escriben en su representación hexadecimal prefijados con \x. Existen tres tipos de filtro permitidos:

  • all – todos los caracteres
  • no-ctrl – todos los caracteres excepto los de control
  • ascii – todos los caracteres ASCII imprimibles y NL
Solamente efectivo si error_log se establece a "syslog".

syslog.ident string

Especifica la cadena de sangrado que antecede a todo mensaje. Solamente efectivo si error_log se establece a "syslog".


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

Nota: Se pueden usar estos nombres de constantes en php.ini pero no fuera de PHP, como en httpd.conf, donde se deberían usar en su lugar valores de máscara de bits.

Errores y Registro
Valor | Constante | Descripción | Nota
1 | E_ERROR (integer) | Errores Fatales en tiempo de ejecución. Éstos indican errores que no se pueden recuperar, tales como un problema de asignación de memoria. La ejecución del script se interrumpe. |
2 | E_WARNING (integer) | Advertencias en tiempo de ejecución (errores no fatales). La ejecución del script no se interrumpe. |
4 | E_PARSE (integer) | Errores de análisis en tiempo de compilación. Los errores de análisis deberían ser generados únicamente por el analizador. |
8 | E_NOTICE (integer) | Avisos en tiempo de ejecución. Indican que el script encontró algo que podría señalar un error, pero que también podría ocurrir en el curso normal al ejecutar un script. |
16 | E_CORE_ERROR (integer) | Errores fatales que ocurren durante el arranque incial de PHP. Son como un E_ERROR, excepto que son generados por el núcleo de PHP. |
32 | E_CORE_WARNING (integer) | Advertencias (errores no fatales) que ocurren durante el arranque inicial de PHP. Son como un E_WARNING, excepto que son generados por el núcleo de PHP. |
64 | E_COMPILE_ERROR (integer) | Errores fatales en tiempo de compilación. Son como un E_ERROR, excepto que son generados por Motor de Script Zend. |
128 | E_COMPILE_WARNING (integer) | Advertencias en tiempo de compilación (errores no fatales). Son como un E_WARNING, excepto que son generados por Motor de Script Zend. |
256 | E_USER_ERROR (integer) | Mensaje de error generado por el usuario. Es como un E_ERROR, excepto que es generado por código de PHP mediante el uso de la función de PHP trigger_error(). |
512 | E_USER_WARNING (integer) | Mensaje de advertencia generado por el usuario. Es como un E_WARNING, excepto que es generado por código de PHP mediante el uso de la función de PHP trigger_error(). |
1024 | E_USER_NOTICE (integer) | Mensaje de aviso generado por el usuario. Es como un E_NOTICE, excepto que es generado por código de PHP mediante el uso de la función de PHP trigger_error(). |
2048 | E_STRICT (integer) | Habilítelo para que PHP sugiera cambios en su código, lo que asegurará la mejor interoperabilidad y compatibilidad con versiones posteriores de PHP de su código. | Desde PHP 5 pero no incluidoen E_ALL hasta PHP 5.4.0
4096 | E_RECOVERABLE_ERROR (integer) | Error fatal capturable. Indica que ocurrió un error probablemente peligroso, pero no dejó al Motor en un estado inestable. Si no se captura el error mediante un gestor definido por el usuario (vea también set_error_handler()), la aplicación se abortará como si fuera un E_ERROR. | Desde PHP 5.2.0
8192 | E_DEPRECATED (integer) | Avisos en tiempo de ejecución. Habilítelo para recibir avisos sobre código que no funcionará en futuras versiones. | Desde PHP 5.3.0
16384 | E_USER_DEPRECATED (integer) | Mensajes de advertencia generados por el usuario. Son como un E_DEPRECATED, excepto que es generado por código de PHP mediante el uso de la función de PHP trigger_error(). | Desde PHP 5.3.0
32767 | E_ALL (integer) | Todos los errores y advertencias soportados, excepto del nivel E_STRICT antes de PHP 5.4.0. | 32767 en PHP 5.4.x, 30719 en PHP 5.3.x, 6143 en PHP 5.2.x, 2047 anteriormente

Los valores de arriba (numéricos o simbólicos) se usan para construir una máscara de bits que especifica qué errores notificar. Se pueden usar los operadores a nivel de bit para combinar estos valores o para enmascarar ciertos tipos de errores. Observe que sólo serán interpretados '|', '~', '!', '^' y '&' dentro de php.ini.


Ejemplos

Abajo podemos ver un ejemplo del uso de las capacidades del manejo de errores de PHP. Definimos una función de gestión de errores que registra la información en un archivo (usado un foramto XML), y envía un e-mail a los desarrolladores en caso de que suceda un error crítico en la lógica.

Ejemplo #1 Usar el manejo de errores en un script

<?php
// haremos nuestro propio manejo de errores
error_reporting(0);

// función de gestión de errores definida por el usuario
function gestorErrores($númerr, $menserr, $nombrearchivo, $númlínea, $vars)
{
    // marca de tiempo para la entrada del error
    $fh = date("Y-m-d H:i:s (T)");

    // definir una matriz asociativa de cadena de error
    // en realidad las únicas entradas que deberíamos
    // considerar son E_WARNING, E_NOTICE, E_USER_ERROR,
    // E_USER_WARNING y E_USER_NOTICE
    $tipoerror = array (
                E_ERROR              => 'Error',
                E_WARNING            => 'Warning',
                E_PARSE              => 'Parsing Error',
                E_NOTICE             => 'Notice',
                E_CORE_ERROR         => 'Core Error',
                E_CORE_WARNING       => 'Core Warning',
                E_COMPILE_ERROR      => 'Compile Error',
                E_COMPILE_WARNING    => 'Compile Warning',
                E_USER_ERROR         => 'User Error',
                E_USER_WARNING       => 'User Warning',
                E_USER_NOTICE        => 'User Notice',
                E_STRICT             => 'Runtime Notice',
                E_RECOVERABLE_ERROR  => 'Catchable Fatal Error'
                );
    // conjunto de errores por el cuál se guardará un seguimiento de una variable
    $errores_usuario = array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);

    $err = "<errorentry>\n";
    $err .= "\t<datetime>" . $fh . "</datetime>\n";
    $err .= "\t<errornum>" . $númerr . "</errornum>\n";
    $err .= "\t<errortype>" . $tipoerror[$númerr] . "</errortype>\n";
    $err .= "\t<errormsg>" . $menserr . "</errormsg>\n";
    $err .= "\t<scriptname>" . $nombrearchivo . "</scriptname>\n";
    $err .= "\t<scriptlinenum>" . $númlínea . "</scriptlinenum>\n";

    if (in_array($númerr, $errores_usuario)) {
        $err .= "\t<vartrace>" . wddx_serialize_value($vars, "Variables") . "</vartrace>\n";
    }
    $err .= "</errorentry>\n\n";

    // para probar
    // echo $err;

    // guardar al registro de errores, y enviarme un e-mail si hay un error crítico de usuario
    error_log($err, 3, "/usr/local/php4/error.log");
    if ($númerr == E_USER_ERROR) {
        mail("phpdev@example.com", "Error Crítico de Usuario", $err);
    }
}

function distancia($vect1, $vect2)
{
    if (!is_array($vect1) || !is_array($vect2)) {
        trigger_error("Parámetros incorrectos, se esperaba una matriz", E_USER_ERROR);
        return NULL;
    }

    if (count($vect1) != count($vect2)) {
        trigger_error("Los vectores necesitan ser del mismo tamaño", E_USER_ERROR);
        return NULL;
    }

    for ($i=0; $i<count($vect1); $i++) {
        $c1 = $vect1[$i]; $c2 = $vect2[$i];
        $d = 0.0;
        if (!is_numeric($c1)) {
            trigger_error("La coordenada $i del vector 1 no es un número, se usará cero",
                            E_USER_WARNING);
            $c1 = 0.0;
        }
        if (!is_numeric($c2)) {
            trigger_error("La coordenada $i del vector 2 no es un número, se usará cero",
                            E_USER_WARNING);
            $c2 = 0.0;
        }
        $d += $c2*$c2 - $c1*$c1;
    }
    return sqrt($d);
}

$gestor_error_antiguo = set_error_handler("gestorErrores");

// constante no definida, genera una advertencia
$t = NO_ESTOY_DEFINIDA;

// definir algunos "vectores"
$a = array(2, 3, "foo");
$b = array(5.5, 4.3, -1.6);
$c = array(1, -3);

// generar un error de usuario
$t1 = distancia($c, $b) . "\n";

// generar otro error de usuario
$t2 = distancia($b, "no soy una matriz") . "\n";

// generar una advertencia
$t3 = distancia($a, $b) . "\n";

?>


Funciones de Manejo de Errores

Ver también

Véase también syslog().

Tabla de contenidos

  • debug_backtrace — Genera un rastreo
  • debug_print_backtrace — Muestra un rastreo
  • error_clear_last — Limpiar el error más reciente
  • error_get_last — Obtener el último error que ocurrió
  • error_log — Enviar un mensaje de error a las rutinas de manejo de errores definidas
  • error_reporting — Establece cuáles errores de PHP son notificados
  • restore_error_handler — Recupera la función de gestión de errores previa
  • restore_exception_handler — Restaura la función de gestión de excepciones previamente definida
  • set_error_handler — Establecer una función de gestión de errores definida por el usuario
  • set_exception_handler — Establece una función de gestión de excepciones definida por el usuario
  • trigger_error — Generar un mensaje de error/advertencia/aviso de nivel de usuario
  • user_error — Alias de trigger_error


Genera un rastreo

  • « Funciones de Manejo de Errores
  • debug_print_backtrace »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Genera un rastreo

debug_backtrace

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

debug_backtrace — Genera un rastreo

Descripción

debug_backtrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT , int $limit = 0 ) : array

debug_backtrace() genera un rastreo de PHP.

Parámetros

options

Desde 5.3.6, este parámetro es una mascara de bits para las siguientes opciones:

debug_backtrace() options
DEBUG_BACKTRACE_PROVIDE_OBJECT | Completar el índice "object" o no.
DEBUG_BACKTRACE_IGNORE_ARGS | Omitir el índice "args" y por lo tanto todos los argumentos de las funciones/métodos para ahorrar memoria o no.
Antes de 5.3.6, el único valor reconocido es true o false, que es lo mismo que establecer y desestablecer la opción DEBUG_BACKTRACE_PROVIDE_OBJECT.

limit

Desde 5.4.0, este parámetro puede ser usado para limitar el número de stack frames que se muestran. Por defecto (limit=0) imprime todos los stack frames.

Valores devueltos

Devuelve un array de array asociativos. Los posibles elementos devueltos son los siguientes:

Posibles elementos devueltos por debug_backtrace()
Nombre | Tipo | Descripción
function | string | El nombre de la función actual. Véase también __FUNCTION__.
line | integer | El número de línea actual. Véase también __LINE__.
file | string | El nombre de archivo actual. Véase también __FILE__.
class | string | El nombre de la clase actual. Véase también __CLASS__
object | object | El objeto actual.
type | string | El tipo de llamada actual. Si es una llamada a un método devuelve "->". Si es una llamada a un método estático devuelve "::". Si es una llamada a una función no se devuelve nada.
args | array | Dentro de una función se lista los argumentos de la función. Dentro de un archvo incluido se lista el nombre (o nombres) del archivo incluido.

Historial de cambios

Versión | Descripción
5.4.0 | Añadido el parámetro opcional limit.
5.3.6 | Se cambió el parámetro provide_object a options y se añadió la opción adicional DEBUG_BACKTRACE_IGNORE_ARGS.
5.2.5 | Se añadió el parámetro opcional provide_object.
5.1.1 | Se añadió el object actual como posible elemento devuelto.

Ejemplos

Ejemplo #1 Ejemplo de debug_backtrace()

<?php
// nombre de archivo: /tmp/a.php

function una_prueba($str)
{
    echo "\nHola: $str";
    var_dump(debug_backtrace());
}

una_prueba('amigo');
?>

<?php
// nombre de archivo: /tmp/b.php
include_once '/tmp/a.php';
?>

El resultado es similar al siguiente cuando se ejecuta /tmp/b.php:

Hola: amigo
array(2) {
[0]=>
array(4) {
    ["file"] => string(10) "/tmp/a.php"
    ["line"] => int(10)
    ["function"] => string(10) "una_prueba"
    ["args"]=>
    array(1) {
      [0] => &string(5) "amigo"
    }
}
[1]=>
array(4) {
    ["file"] => string(10) "/tmp/b.php"
    ["line"] => int(2)
    ["args"] =>
    array(1) {
      [0] => string(10) "/tmp/a.php"
    }
    ["function"] => string(12) "include_once"
  }
}

Ver también

  • trigger_error() - Generar un mensaje de error/advertencia/aviso de nivel de usuario
  • debug_print_backtrace() - Muestra un rastreo


Muestra un rastreo

  • « debug_backtrace
  • error_clear_last »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Muestra un rastreo

debug_print_backtrace

(PHP 5, PHP 7, PHP 8)

debug_print_backtrace — Muestra un rastreo

Descripción

debug_print_backtrace ( int $options = 0 , int $limit = 0 ) : void

debug_print_backtrace() muestra un rastreo PHP. muestra las llamadas a función, archivos incluídos y el material evaluado mediante eval().

Parámetros

options

Desde 5.3.6, este parámetro es una máscara de bits para las siguientes opciones:

Opciones de debug_print_backtrace()
DEBUG_BACKTRACE_IGNORE_ARGS Omitir el índice "args" y por lo tanto todos los argumentos de las funciones/métodos para ahorrar memoria o no.

limit

Desde 5.4.0, este parámetro puede ser usado para limitar el número de stack frames que se muestran. Por defecto (limit=0) imprime todos los stack frames.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.4.0 | Añadido el parámetro opcional limit.
5.3.6 | Añadido el parámetro opcional options.

Ejemplos

Ejemplo #1 Ejemplo de debug_print_backtrace()

<?php
// archivo include.php
function a() {
    b();
}

function b() {
    c();
}

function c(){
    debug_print_backtrace();
}

a();

?>
<?php
// archivo prueba.php
// este es el archivo que debe ejecutar

include 'include.php';
?>

El resultado del ejemplo sería algo similar a:

#0  c() called at [/tmp/include.php:10]
#1  b() called at [/tmp/include.php:6]
#2  a() called at [/tmp/include.php:17]
#3  include(/tmp/include.php) called at [/tmp/prueba.php:3]

Ver también

  • debug_backtrace() - Genera un rastreo


Limpiar el error más reciente

  • « debug_print_backtrace
  • error_get_last »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Limpiar el error más reciente

error_clear_last

(PHP 7, PHP 8)

error_clear_last — Limpiar el error más reciente

Descripción

error_clear_last ( ) : void

Valores devueltos

Limpia los errores más recientes, no pudiéndose recuperarlos así con error_get_last().

Ejemplos

Ejemplo #1 Un ejemplo de error_clear_last()

<?php
var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());

@$a = $b;

var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());
?>

El resultado del ejemplo sería algo similar a:

NULL
NULL
array(4) {
  ["type"]=>
  int(8)
  ["message"]=>
  string(21) "Undefined variable: b"
  ["file"]=>
  string(9) "%s"
  ["line"]=>
  int(6)
}
NULL

Ver también

  • Constantes de error


Obtener el último error que ocurrió

  • « error_clear_last
  • error_log »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Obtener el último error que ocurrió

error_get_last

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

error_get_last — Obtener el último error que ocurrió

Descripción

error_get_last ( ) : array

Obtiene información sobre el último error que ocurrió.

Valores devueltos

Devuelve una matriz asociativa describiendo el último error con las claves "type" (tipo), "message" (mensaje), "file" (archivo) y "line" (línea). Si el error ha sido causado por una función interna de PHP, el "message" (mensaje) comienza con su nombre. Devuelve null si no ha habido aún un error.

Ejemplos

Ejemplo #1 Un ejemplo de error_get_last()

<?php
echo $a;
print_r(error_get_last());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [type] => 8
    [message] => Undefined variable: a
    [file] => C:\WWW\index.php
    [line] => 2
)

Ver también

  • Constantes de error
  • La variable $php_errormsg
  • error_clear_last() - Limpiar el error más reciente
  • La directiva display_errors
  • La directiva html_errors
  • La directiva xmlrpc_errors


Enviar un mensaje de error a las rutinas de manejo de errores definidas

  • « error_get_last
  • error_reporting »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Enviar un mensaje de error a las rutinas de manejo de errores definidas

error_log

(PHP 4, PHP 5, PHP 7, PHP 8)

error_log — Enviar un mensaje de error a las rutinas de manejo de errores definidas

Descripción

error_log ( string $message , int $message_type = 0 , string $destination = ? , string $extra_headers = ? ) : bool

Envía un mensaje de error al registro de errores del servidor web o a un fichero.

Parámetros

message

El mensaje de error que debería ser registrado.

message_type

Indica dónde debería ir el error. Los tipos de mensaje posibles son:

Tipos de registro de error_log()
0 | message es enviado al registro del sistema de PHP, usando el mecanismo de registro del Sistema Operativo o un fichero, dependiendo de qué directiva de configuración esté establecida en error_log. Esta opción es la predeterminada.
1 | message es enviado por email a la dirección del parámetro destination. Este es el único tipo de mensaje donde se usa el cuarto parámetro extra_headers.
2 | Ya no es una opción.
3 | message es añadido al final del fichero destination. No se añade automáticamente una nueva línea al final del string message.
4 | message es enviado directamente al gestor de registro de la SAPI.

destination

El destino. Su significado depende del parámetro message_type tal como se describió arriba.

extra_headers

Las cabeceras extra. Se usa cuando el parámetro message_type está establecido a 1. Este tipo de mensaje usa la misma función interna que mail().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

error_log() no es seguro a nivel binario. message será truncado por un carácter null.

Sugerencia

message no debería contener un carácter null. Observe que message podría enviarse a un fichero, correo, syslog, etc. Use la función de conversión/escape apropiada, base64_encode(), rawurlencode() o addslashes(), antes de llamar a error_log().

Ejemplos

Ejemplo #1 Ejemplos de error_log()

<?php
// Enviar una notificación al registro del servidor si no podemos
// conectarnos a la base de datos.
if (!Ora_Logon($username, $password)) {
    error_log("¡La base de datos de Oracle no está disponible!", 0);
}

// Notificar al administrador mediante un email si agotamos FOO
if (!($foo = allocate_new_foo())) {
    error_log("Problema serio, nos hemos quedado sin FOOs!", 1,
               "operator@example.com");
}

// otra manera de llamar a error_log():
error_log("¡Lo echaste a perder!", 3, "/var/tmp/my-errors.log");
?>

Historial de cambios

Versión | Descripción
5.2.7 | El valor posible de 4 se añadió a message_type.


Establece cuáles errores de PHP son notificados

  • « error_log
  • restore_error_handler »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Establece cuáles errores de PHP son notificados

error_reporting

(PHP 4, PHP 5, PHP 7, PHP 8)

error_reporting — Establece cuáles errores de PHP son notificados

Descripción

error_reporting ( int $level = ? ) : int

La función error_reporting() establece la directiva error_reporting en tiempo de ejecución. PHP tiene varios niveles de errores para notificar, al utilizar ésta función se define el nivel de duración (tiempo de ejecución) de sus scripts. Si el parámetro opcional level no se define, la función error_reporting() sólo devolverá el nivel actual de notificación de error.

Parámetros

level

El nuevo nivel de error_reporting. Este nivel toma una máscara de bit o constantes nominadas. Al utilizar constantes nominadas se recomienda encarecidamente asegurar la compatibilidad para versiones futuras. Según se añaden niveles de error, el rango de los enteros incrementa, por lo que los niveles antiguos de errores basados en enteros no siempre se comportarán como se esperaba.

Las constantes de niveles de error disponibles, y los significados actuales de esos niveles de error están descritos en constantes predefinidas.

Valores devueltos

Devuelve el nivel antiguo de error_reporting o el nivel actual si el parámetro level no se proporciona.

Historial de cambios

Versión | Descripción
5.4.0 | Ahora E_STRICT es parte de E_ALL.
5.3.0 | Se introdujo E_DEPRECATED y E_USER_DEPRECATED.
5.2.0 | Se introdujo E_RECOVERABLE_ERROR.

Ejemplos

Ejemplo #1 Ejemplos de error_reporting()

<?php

// Desactivar toda notificación de error
error_reporting(0);

// Notificar solamente errores de ejecución
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// Notificar E_NOTICE también puede ser bueno (para informar de variables
// no inicializadas o capturar errores en nombres de variables ...)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// Notificar todos los errores excepto E_NOTICE
error_reporting(E_ALL ^ E_NOTICE);

// Notificar todos los errores de PHP (ver el registro de cambios)
error_reporting(E_ALL);

// Notificar todos los errores de PHP
error_reporting(-1);

// Lo mismo que error_reporting(E_ALL);
ini_set('error_reporting', E_ALL);

?>

Notas

Advertencia

La mayoría de errores E_STRICT son evaluados en tiempo de compilación por lo que tales errores no se notifican en el fichero donde error_reporting se mejora al incluir los errores de E_STRICT (y viceversa).

Sugerencia

Al pasar el valor -1 se mostrarán todos los errores posibles, incluso cuando se añadan nuevos niveles y constantes en futuras versiones de PHP. La constante E_ALL también se comporta de esta forma en PHP 5.4.

Ver también

  • La directiva display_errors
  • La directiva html_errors
  • La directiva xmlrpc_errors
  • ini_set() - Establece el valor de una directiva de configuración


Recupera la función de gestión de errores previa

  • « error_reporting
  • restore_exception_handler »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Recupera la función de gestión de errores previa

restore_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

restore_error_handler — Recupera la función de gestión de errores previa

Descripción

restore_error_handler ( ) : bool

Usada después de modificar la función de gestión de errores usando set_error_handler(), para revertir al gestor de errores previo (el cual puede ser el incorporado o una función definida por el usuario).

Valores devueltos

Esta función siempre devuelve true.

Ejemplos

Ejemplo #1 Ejemplo de restore_error_handler()

Decidir si unserialize() causó un error, entonces recuperar el gestor de errores original.

<?php
function gestor_unserialize($errno, $errstr)
{
    echo "Valor seriado inválido.\n";
}

$seriado = 'foo';
set_error_handler('gestor_unserialize');
$original = unserialize($seriado);
restore_error_handler();
?>

El resultado del ejemplo sería:

Valor seriado inválido.

Ver también

  • error_reporting() - Establece cuáles errores de PHP son notificados
  • set_error_handler() - Establecer una función de gestión de errores definida por el usuario
  • restore_exception_handler() - Restaura la función de gestión de excepciones previamente definida
  • trigger_error() - Generar un mensaje de error/advertencia/aviso de nivel de usuario


Restaura la función de gestión de excepciones previamente definida

  • « restore_error_handler
  • set_error_handler »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Restaura la función de gestión de excepciones previamente definida

restore_exception_handler

(PHP 5, PHP 7, PHP 8)

restore_exception_handler — Restaura la función de gestión de excepciones previamente definida

Descripción

restore_exception_handler ( ) : bool

Usada después de cambiar la función de gestión de excepciones al utilizar set_exception_handler(), para volver al gestor de excepciones anterior (el cuál puede ser la función interna o una definida por el usuario).

Valores devueltos

Esta función siempre devuelve true.

Ejemplos

Ejemplo #1 Ejemplo de restore_exception_handler()

<?php
    function gestor_excepciones_1(Exception $e)
    {
        echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
    }

    function gestor_excepciones_2(Exception $e)
    {
        echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
    }

    set_exception_handler('gestor_excepciones_1');
    set_exception_handler('gestor_excepciones_2');

    restore_exception_handler();

    throw new Exception('Esto dispara el primer gestor de excepciones...');
?>

El resultado del ejemplo sería:

[gestor_excepciones_1] Esto dispara el primer gestor de excepciones...

Ver también

  • set_exception_handler() - Establece una función de gestión de excepciones definida por el usuario
  • set_error_handler() - Establecer una función de gestión de errores definida por el usuario
  • restore_error_handler() - Recupera la función de gestión de errores previa
  • error_reporting() - Establece cuáles errores de PHP son notificados


Establecer una función de gestión de errores definida por el usuario

  • « restore_exception_handler
  • set_exception_handler »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Establecer una función de gestión de errores definida por el usuario

set_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

set_error_handler — Establecer una función de gestión de errores definida por el usuario

Descripción

set_error_handler ( callable $error_handler , int $error_types = E_ALL | E_STRICT ) : mixed

Establece una función de usuario (error_handler) para manejar los errores de un script.

Esta función se puede usar para definir su propia forma de manejar los errores en tiempo de ejecución, por ejemplo en aplicaciones en las que se necesita hacer una limpieza de datos/archivos cuando ocurre un error crítico, o cuando se necesita provocar un error bajo ciertas condiciones (usando trigger_error()).

Es importante recordar que el gestor de errores estándar de PHP es completamente evitado por los tipos de errores especificados por error_types a menos que la función de llamada de retorno devuelva false. La configuración de error_reporting() no tendrá efecto y su gestor de errores será llamado de todas formas - aunque aún es capaz de leer el valor actual de error_reporting y actuar de manera apropiada. En particular, observe que este valor será 0 si a la sentencia que causó el error se le añadió al principio el operador de control de errores @ .

También observe que es su responsabilidad realizar un die() si fuera necesario. Si la función de gestión de errores devuelve, la ejecución del script continuará con la siguiente sentencia después de la que causó el error.

Los siguientes tipos de errores no pueden ser manejados con una función definida por el usuario: E_ERROR, E_PARSE, E_CORE_ERROR, E_CORE_WARNING, E_COMPILE_ERROR, E_COMPILE_WARNING, y la mayoría de E_STRICT ocasionados en el archivo desde donde se llamó a set_error_handler().

Si sucede algún error antes de que el script sea ejecutado (p.ej. en la carga de archivos) el gestor de errores personalizado no podrá ser llamado ya que no está registrado en ese momento.

Parámetros

error_handler

Una llamada de retorno con la siguiente signatura. Se podría pasar null en su lugar para reiniciar este gestor a su estado predeterminado. También se puede proporcionar un nombre de una función, un array que contenga una referencia a un objeto y un nombre de un método.

handler ( int $errno , string $errstr , string $errfile = ? , int $errline = ? , array $errcontext = ? ) : bool
errno
El primer parámetro, errno, contiene el nivel del error ocasionado, como un valor de tipo integer.
errstr
El segundo parámetro, errstr, contiene el mensaje de error, como cadena.
errfile
El tercer parámetro es opcional, errfile, que contiene el nombre de archivo que ocasionó el error, como cadena.
errline
El cuarto parámetro es opcional, errline, que contiene el número de línea donde ocurrió el error, como valor de tipo integer.
errcontext
El quinto parámetro es opcional, errcontext, el cuál es una matriz que apunta a la tabla de símbolos activa en el punto donde ocurrió el error. En otras palabras, errcontext contendrá una matriz con cada variable que existe en el ámbito donde el error fue provocado. El gestor de errores de usuario no debe modificar el contexto del error.

Si la función devuelve false se continúa con el gestor de errores normal.

error_types

Se puede usar para enmascarar la provocación de la función error_handler al igual que la configuración error_reporting ini controla los errores que se muestran. Sin esta máscara establecida error_handler será llamada para cada error sin tener en cuenta la configuración de error_reporting.

Valores devueltos

Devuelve una cadena que contiene el gestor de errores definido anteriormente (si lo hay). Si se usa el gestor de errores interno se devuelve null. null también es devuelto en caso de un error como una llamada de retorno no válida. Si el gestor de errores anterior era un método de una clase, esta función devolverá una matriz indexada con los nombres de las clases y métodos.

Historial de cambios

Versión | Descripción
5.5.0 | error_handler ahora acepta null.
5.2.0 | El gestor de errores debe devolver false para rellenar $php_errormsg.

Ejemplos

Ejemplo #1 Manejo de errores con set_error_handler() y trigger_error()

El ejemplo de abajo muestra el manejo de excepciones internas mediante la provocación de errores y tratándolos con una función definida por el usuario:

<?php
// función de gestión de errores
function miGestorDeErrores($errno, $errstr, $errfile, $errline)
{
    if (!(error_reporting() & $errno)) {
        // Este código de error no está incluido en error_reporting
        return;
    }

    switch ($errno) {
    case E_USER_ERROR:
        echo "<b>Mi ERROR</b> [$errno] $errstr<br />\n";
        echo "  Error fatal en la línea $errline en el archivo $errfile";
        echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";
        echo "Abortando...<br />\n";
        exit(1);
        break;

    case E_USER_WARNING:
        echo "<b>Mi WARNING</b> [$errno] $errstr<br />\n";
        break;

    case E_USER_NOTICE:
        echo "<b>Mi NOTICE</b> [$errno] $errstr<br />\n";
        break;

    default:
        echo "Tipo de error desconocido: [$errno] $errstr<br />\n";
        break;
    }

    /* No ejecutar el gestor de errores interno de PHP */
    return true;
}

// función para probar el manejo de errores
function scale_by_log($vect, $scale)
{
    if (!is_numeric($scale) || $scale <= 0) {
        trigger_error("log(x) para x <= 0 no está definido, usó: scale = $scale", E_USER_ERROR);
    }

    if (!is_array($vect)) {
        trigger_error("Vector de entrada incorrecto, se esperaba una matriz de valores", E_USER_WARNING);
        return null;
    }

    $temp = array();
    foreach($vect as $pos => $valor) {
        if (!is_numeric($valor)) {
            trigger_error("El valor en la posición $pos no es un número, usando 0 (cero)", E_USER_NOTICE);
            $valor = 0;
        }
        $temp[$pos] = log($scale) * $valor;
    }

    return $temp;
}

// establecer el gestro de errores definido por el usuario
$gestor_errores_antiguo = set_error_handler("miGestorDeErrores");

// provocar algunos errores, primero definimos una matriz mixta con un elemento no numérico
echo "vector a\n";
$a = array(2, 3, "foo", 5.5, 43.3, 21.11);
print_r($a);

// ahora generamos una segunda matriz
echo "----\nvector b - a notice (b = log(PI) * a)\n";
/* Value at position $pos is not a number, using 0 (zero) */
$b = scale_by_log($a, M_PI);
print_r($b);

// esto es un problema, pasamos una cadena en vez de una matriz
echo "----\nvector c - a warning\n";
/* Vector de entrada incorrecto, se esperaba una matriz de valores */
$c = scale_by_log("no array", 2.3);
var_dump($c); // NULL

// esto es un error crítico, log de cero o de un número negativo es indefinido
echo "----\nvector d - fatal error\n";
/* log(x) para x <= 0 no está definido, usó: scale = $scale */
$d = scale_by_log($a, -2.5);
var_dump($d); // Nunca se alcanza
?>

El resultado del ejemplo sería algo similar a:

vector a
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
vector b - a notice (b = log(PI) * a)
<b>Mi NOTICE</b> [1024] El valor en la posición 2 no es un número, usando 0 (cero)<br />
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
vector c - a warning
<b>Mi WARNING</b> [512] Vector de entrada incorrecto, se esperaba una matriz de valores<br />
NULL
----
vector d - fatal error
<b>Mi ERROR</b> [256] log(x) para x <= 0 no está definido, usó: scale = -2.5<br />
  Error fatal en la línea 35 en el archivo trigger_error.php, PHP 5.2.1 (FreeBSD)<br />
Abortando...<br />

Ver también

  • ErrorException
  • error_reporting() - Establece cuáles errores de PHP son notificados
  • restore_error_handler() - Recupera la función de gestión de errores previa
  • trigger_error() - Generar un mensaje de error/advertencia/aviso de nivel de usuario
  • constantes de niveles de error


Establece una función de gestión de excepciones definida por el usuario

  • « set_error_handler
  • trigger_error »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Establece una función de gestión de excepciones definida por el usuario

set_exception_handler

(PHP 5, PHP 7, PHP 8)

set_exception_handler — Establece una función de gestión de excepciones definida por el usuario

Descripción

set_exception_handler ( callable $exception_handler ) : callable

Establece el manejador de excepciones predeterminado si una excepción no es capturada dentro de un bloque try/catch. La ejecución se detendrá después de la llamada a exception_handler.

Parámetros

exception_handler

Nombre de la función a llamar cuando ocurra una excepción no capturada. Es necesario que esta función de gestión acepte un parámetro, que será el objeto de excepción que fue lanzado. Esta es la firma del manejador:

handler ( Exception $ex ) : void

Desde PHP 7, la mayoría de los errores se notifican lanzando excepciones Error, las cuales serán también capturadas por el manejador. Error y Exception implementan la interfaz Throwable. Esta es la signatura del manejador desde PHP 7:

handler ( Throwable $ex ) : void

Se podría pasar null en su lugar para reiniciar este manejador a su estado predeterminado.

Precaución

Observe que al proporcionar una Exception explícita como tipo implicado al parámetro ex en una retrollamada causará problemas con la jerarquía de excepciones cambiada en PHP 7.

Valores devueltos

Devuelve el nombre del manejador de excepciones definido anteriormente, o null en caso de error. Si no se definió un manejador anterior también devolverá null.

Historial de cambios

Versión | Descripción
7.0.0 | Cambiado el tipo de parámetro pasado a exception_handler de Exception a Throwable
5.5.0 | Anteriormente, si se pasaba null, esta función devolvía true. Devuelve el manejador anterior desde PHP 5.5.0.

Ejemplos

Ejemplo #1 Ejemplo de set_exception_handler()

<?php
function manejador_excepciones($excepción) {
  echo "Excepción no capturada: " , $excepción->getMessage(), "\n";
}

set_exception_handler('manejador_excepciones');

throw new Exception('Excepción No Capturada');
echo "No Ejecutado\n";
?>

Ver también

  • restore_exception_handler() - Restaura la función de gestión de excepciones previamente definida
  • restore_error_handler() - Recupera la función de gestión de errores previa
  • error_reporting() - Establece cuáles errores de PHP son notificados
  • Excepciones de PHP 5


Generar un mensaje de error/advertencia/aviso de nivel de usuario

  • « set_exception_handler
  • user_error »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Generar un mensaje de error/advertencia/aviso de nivel de usuario

trigger_error

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

trigger_error — Generar un mensaje de error/advertencia/aviso de nivel de usuario

Descripción

trigger_error ( string $error_msg , int $error_type = E_USER_NOTICE ) : bool

Se usa para provocar una condición de error de usuario, se puede utilizar junto con el gestor de errores interno o con una función definida por el usuario que ha sido establecida como el nuevo gestor de errores (set_error_handler()).

Esta función es útil cuando se necesita generar una respuesta en particular a una excepción en tiempo de ejecución.

Parámetros

error_msg

El mensaje de error designado para este error. Está limitado a 1024 bytes de longitud. Cualquier carácter más allá de los 1024 será truncado.

error_type

El tipo de error designado para este error. Sólo funciona con la familia de constantes E_USER, y por defecto es E_USER_NOTICE.

Valores devueltos

Esta función devuelve false si se especifica un error_type erróneo, si no true.

Ejemplos

Ejemplo #1 Ejemplo de trigger_error()

Véase set_error_handler() para un ejemplo más extenso.

<?php
if ($divisor == 0) {
    trigger_error("No se puede dividir por cero", E_USER_ERROR);
}
?>

Notas

Advertencia

Las entidades HTML en error_msg no son escapadas. Use htmlentities() en el mensaje si el error se va a mostrar en un navegador.

Ver también

  • error_reporting() - Establece cuáles errores de PHP son notificados
  • set_error_handler() - Establecer una función de gestión de errores definida por el usuario
  • restore_error_handler() - Recupera la función de gestión de errores previa
  • Las constantes de niveles de error


Alias de trigger_error

  • « trigger_error
  • FFI »
  • PHP Manual
  • Funciones de Manejo de Errores
  • Alias de trigger_error

user_error

(PHP 4, PHP 5, PHP 7, PHP 8)

user_error — Alias de trigger_error()

Descripción

Esta función es un alias de: trigger_error().


Foreign Function Interface

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Basic FFI usage
    • PHP Callbacks
    • A Complete PHP/FFI/preloading Example
  • FFI — Main interface to C code and data
    • FFI::addr — Creates an unmanaged pointer to C data
    • FFI::alignof — Gets the alignment
    • FFI::arrayType — Dynamically constructs a new C array type
    • FFI::cast — Performs a C type cast
    • FFI::cdef — Creates a new FFI object
    • FFI::free — Releases an unmanaged data structure
    • FFI::isNull — Checks whether a FFI\CData is a null pointer
    • FFI::load — Loads C declarations from a C header file
    • FFI::memcmp — Compares memory areas
    • FFI::memcpy — Copies one memory area to another
    • FFI::memset — Fills a memory area
    • FFI::new — Creates a C data structure
    • FFI::scope — Instantiates an FFI object with C declarations parsed during preloading
    • FFI::sizeof — Gets the size of C data or types
    • FFI::string — Creates a PHP string from a memory area
    • FFI::type — Creates an FFI\CType object from a C declaration
    • FFI::typeof — Gets the FFI\CType of FFI\CData
  • FFI\CData — C Data Handles
  • FFI\CType — C Type Handles
  • FFI\Exception — FFI Exceptions
  • FFI\ParserException — FFI Parser Exceptions


Introducción

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.

This extension allows the loading of shared libraries (.DLL or .so), calling of C functions and accessing of C data structures in pure PHP, without having to have deep knowledge of the Zend extension API, and without having to learn a third “intermediate” language. The public API is implemented as a single class FFI with several static methods (some of them may be called dynamically), and overloaded object methods, which perform the actual interaction with C data.

Precaución

FFI is dangerous, since it allows to interface with the system on a very low level. The FFI extension should only be used by developers having a working knowledge of C and the used C APIs. To minimize the risk, the FFI API usage may be restricted with the ffi.enable php.ini directive.

Nota:

The FFI extension does not render the classic PHP extension API obsolete; it is merely provided for ad-hoc interfacing with C functions and data structures.

Sugerencia

Currently, accessing FFI data structures is significantly (about 2 times) slower than accessing native PHP arrays and objects. Therefore, it makes no sense to use the FFI extension for speed; however, it may make sense to use it to reduce memory consumption.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

This extension requires the » libffi library to be installed.


Instalación

To enable the FFI extension, PHP has to be configured with --with-ffi.

Windows users have to include php_ffi.dll into php.ini to enable the FFI extension.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

FFI Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
ffi.enable | "preload" | PHP_INI_SYSTEM |
ffi.preload | "" | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

ffi.enable string

Allows enabling ("true") or disabling ("false") FFI API usage, or restricting it only to the CLI SAPI and preloaded files ("preload").

The FFI API restrictions only affect the FFI class, but not overloaded functions of FFI\CData objects. This means that it is possible to create some FFI\CData objects in preloaded files, and then to use these directly in PHP scripts.

ffi.preload string

Allows preloading of FFI bindings during startup, which is not possible with FFI::load() if opcache.preload_user is set. This directive accepts a DIRECTORY_SEPARATOR delimited list of filenames. The preloaded bindings can be accessed by calling FFI::scope().


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • FFI
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Tabla de contenidos

  • Basic FFI usage
  • PHP Callbacks
  • A Complete PHP/FFI/preloading Example


Basic FFI usage

Before diving into the details of the FFI API, lets take a look at a few examples demonstrating the simplicity of the FFI API usage for regular tasks.

Nota:

Some of these examples require libc.so.6 and as such will not work on systems where it is not available.

Ejemplo #1 Calling a function from shared library

<?php
// create FFI object, loading libc and exporting function printf()
$ffi = FFI::cdef(
    "int printf(const char *format, ...);", // this is a regular C declaration
    "libc.so.6");
// call C's printf()
$ffi->printf("Hello %s!\n", "world");
?>

El resultado del ejemplo sería:

Hello world!

Nota:

Note that some C functions need specific calling conventions, e.g. __fastcall, __stdcall or ,__vectorcall.

Ejemplo #2 Calling a function, returning a structure through an argument

<?php
// create gettimeofday() binding
$ffi = FFI::cdef("
    typedef unsigned int time_t;
    typedef unsigned int suseconds_t;

    struct timeval {
        time_t      tv_sec;
        suseconds_t tv_usec;
    };

    struct timezone {
        int tz_minuteswest;
        int tz_dsttime;
    };

    int gettimeofday(struct timeval *tv, struct timezone *tz);
", "libc.so.6");
// create C data structures
$tv = $ffi->new("struct timeval");
$tz = $ffi->new("struct timezone");
// call C's gettimeofday()
var_dump($ffi->gettimeofday(FFI::addr($tv), FFI::addr($tz)));
// access field of C data structure
var_dump($tv->tv_sec);
// print the whole C data structure
var_dump($tz);
?>

El resultado del ejemplo sería algo similar a:

int(0)
int(1555946835)
object(FFI\CData:struct timezone)#3 (2) {
  ["tz_minuteswest"]=>
  int(0)
  ["tz_dsttime"]=>
  int(0)
}

Ejemplo #3 Accessing existing C variables

<?php
// create FFI object, loading libc and exporting errno variable
$ffi = FFI::cdef(
    "int errno;", // this is a regular C declaration
    "libc.so.6");
// print C's errno
var_dump($ffi->errno);
?>

El resultado del ejemplo sería:

int(0)

Ejemplo #4 Creating and Modifying C variables

<?php
// create a new C int variable
$x = FFI::new("int");
var_dump($x->cdata);

// simple assignment
$x->cdata = 5;
var_dump($x->cdata);

// compound assignment
$x->cdata += 2;
var_dump($x->cdata);
?>

El resultado del ejemplo sería:

int(0)
int(5)
int(7)

Ejemplo #5 Working with C arrays

<?php
// create C data structure
$a = FFI::new("long[1024]");
// work with it like with a regular PHP array
for ($i = 0; $i < count($a); $i++) {
    $a[$i] = $i;
}
var_dump($a[25]);
$sum = 0;
foreach ($a as $n) {
    $sum += $n;
}
var_dump($sum);
var_dump(count($a));
var_dump(FFI::sizeof($a));
?>

El resultado del ejemplo sería:

int(25)
int(523776)
int(1024)
int(8192)

Ejemplo #6 Working with C enums

<?php
$a = FFI::cdef('typedef enum _zend_ffi_symbol_kind {
    ZEND_FFI_SYM_TYPE,
    ZEND_FFI_SYM_CONST = 2,
    ZEND_FFI_SYM_VAR,
    ZEND_FFI_SYM_FUNC
} zend_ffi_symbol_kind;
');
var_dump($a->ZEND_FFI_SYM_TYPE);
var_dump($a->ZEND_FFI_SYM_CONST);
var_dump($a->ZEND_FFI_SYM_VAR);
?>

El resultado del ejemplo sería:

int(0)
int(2)
int(3)


PHP Callbacks

It is possible to assign a PHP closure to a native variable of function pointer type or to pass it as a function argument:

<?php
$zend = FFI::cdef("
    typedef int (*zend_write_func_t)(const char *str, size_t str_length);
    extern zend_write_func_t zend_write;
");

echo "Hello World 1!\n";

$orig_zend_write = clone $zend->zend_write;
$zend->zend_write = function($str, $len) {
    global $orig_zend_write;
    $orig_zend_write("{\n\t", 3);
    $ret = $orig_zend_write($str, $len);
    $orig_zend_write("}\n", 2);
    return $ret;
};
echo "Hello World 2!\n";
$zend->zend_write = $orig_zend_write;
echo "Hello World 3!\n";
?>

El resultado del ejemplo sería:

Hello World 1!
{
        Hello World 2!
}
Hello World 3!
Although this works, this functionality is not supported on all libffi platforms, is not efficient and leaks resources by the end of request.
Sugerencia

It is therefore recommended to minimize the usage of PHP callbacks.


A Complete PHP/FFI/preloading Example

php.ini

ffi.enable=preload
opcache.preload=preload.php

preload.php

<?php
FFI::load(__DIR__ . "/dummy.h");
opcache_compile_file(__DIR__ . "/dummy.php");
?>

dummy.h

#define FFI_SCOPE "DUMMY"
#define FFI_LIB "libc.so.6"

int printf(const char *format, ...);

dummy.php

<?php
final class Dummy {
    private static $ffi = null;
    function __construct() {
        if (is_null(self::$ffi)) {
            self::$ffi = FFI::scope("DUMMY");
        }
    }
    function printf($format, ...$args) {
       return (int)self::$ffi->printf($format, ...$args);
    }
}
?>

test.php

<?php
$d = new Dummy();
$d->printf("Hello %s!\n", "world");
?>


Main interface to C code and data

(PHP 7 >= 7.4.0)

Introducción

Objects of this class are created by the factory methods FFI::cdef(), FFI::load() or FFI::scope(). Defined C variables are made available as properties of the FFI instance, and defined C functions are made available as methods of the FFI instance. Declared C types can be used to create new C data structures using FFI::new() and FFI::type().

FFI definition parsing and shared library loading may take significant time. It is not useful to do it on each HTTP request in a Web environment. However, it is possible to preload FFI definitions and libraries at PHP startup, and to instantiate FFI objects when necessary. Header files may be extended with special FFI_SCOPE defines (e.g. #define FFI_SCOPE "foo"”"; the default scope is "C") and then loaded by FFI::load() during preloading. This leads to the creation of a persistent binding, that will be available to all the following requests through FFI::scope(). Refer to the complete PHP/FFI/preloading example for details.

It is possible to preload more than one C header file into the same scope.

Sinopsis de la Clase

FFI {
/* Métodos */
public static addr ( FFI\CData &$ptr ) : FFI\CData
public static alignof ( FFI\CData|FFI\CType &$ptr ) : int
public static arrayType ( FFI\CType $type , array $dimensions ) : FFI\CType
public static cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public static cdef ( string $code = "" , string|null $lib = null ) : FFI
public static free ( FFI\CData &$ptr ) : void
public static isNull ( FFI\CData &$ptr ) : bool
public static load ( string $filename ) : FFI|null
public static memcmp ( string|FFI\CData &$ptr1 , string|FFI\CData &$ptr2 , int $size ) : int
public static memcpy ( FFI\CData &$to , FFI\CData|string &$from , int $size ) : void
public static memset ( FFI\CData &$ptr , int $value , int $size ) : void
public static new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public static scope ( string $name ) : FFI
public static sizeof ( FFI\CData|FFI\CType &$ptr ) : int
public static string ( FFI\CData &$ptr , int|null $size = null ) : string
public static type ( string $type ) : FFI\CType|null
public type ( string $type ) : FFI\CType|null
public static typeof ( FFI\CData &$ptr ) : FFI\CType
}

Tabla de contenidos

  • FFI::addr — Creates an unmanaged pointer to C data
  • FFI::alignof — Gets the alignment
  • FFI::arrayType — Dynamically constructs a new C array type
  • FFI::cast — Performs a C type cast
  • FFI::cdef — Creates a new FFI object
  • FFI::free — Releases an unmanaged data structure
  • FFI::isNull — Checks whether a FFI\CData is a null pointer
  • FFI::load — Loads C declarations from a C header file
  • FFI::memcmp — Compares memory areas
  • FFI::memcpy — Copies one memory area to another
  • FFI::memset — Fills a memory area
  • FFI::new — Creates a C data structure
  • FFI::scope — Instantiates an FFI object with C declarations parsed during preloading
  • FFI::sizeof — Gets the size of C data or types
  • FFI::string — Creates a PHP string from a memory area
  • FFI::type — Creates an FFI\CType object from a C declaration
  • FFI::typeof — Gets the FFI\CType of FFI\CData


Creates an unmanaged pointer to C data

  • « FFI
  • FFI::alignof »
  • PHP Manual
  • FFI
  • Creates an unmanaged pointer to C data

FFI::addr

(PHP 7 >= 7.4.0)

FFI::addr — Creates an unmanaged pointer to C data

Descripción

public static FFI::addr ( FFI\CData &$ptr ) : FFI\CData

Creates an unmanaged pointer to the C data represented by the given FFI\CData. The source ptr must survive the resulting pointer. This function is mainly useful to pass arguments to C functions by pointer.

Parámetros

ptr

The handle of the pointer to a C data structure.

Valores devueltos

Returns the freshly created FFI\CData object.


Gets the alignment

  • « FFI::addr
  • FFI::arrayType »
  • PHP Manual
  • FFI
  • Gets the alignment

FFI::alignof

(PHP 7 >= 7.4.0)

FFI::alignof — Gets the alignment

Descripción

public static FFI::alignof ( FFI\CData|FFI\CType &$ptr ) : int

Gets the alignment of the given FFI\CData or FFI\CType object.

Parámetros

ptr

The handle of the C data or type.

Valores devueltos

Returns the alignment of the given FFI\CData or FFI\CType object.


Dynamically constructs a new C array type

  • « FFI::alignof
  • FFI::cast »
  • PHP Manual
  • FFI
  • Dynamically constructs a new C array type

FFI::arrayType

(PHP 7 >= 7.4.0)

FFI::arrayType — Dynamically constructs a new C array type

Descripción

public static FFI::arrayType ( FFI\CType $type , array $dimensions ) : FFI\CType

Dynamically constructs a new C array type with elements of type defined by type, and dimensions specified by dimensions. In the following example $t1 and $t2 are equivalent array types:

<?php
$t1 = FFI::type("int[2][3]");
$t2 = FFI::arrayType(FFI::type("int"), [2, 3]);
?>

Parámetros

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

dimensions

The dimensions of the type as array.

Valores devueltos

Returns the freshly created FFI\CType object.


Performs a C type cast

  • « FFI::arrayType
  • FFI::cdef »
  • PHP Manual
  • FFI
  • Performs a C type cast

FFI::cast

(PHP 7 >= 7.4.0)

FFI::cast — Performs a C type cast

Descripción

public static FFI::cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public FFI::cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null

FFI::cast() creates a new FFI\CData object, that references the same C data structure, but is associated with a different type. The resulting object does not own the C data, and the source ptr must survive the result. The C type may be specified as a string with any valid C type declaration or as FFI\CType object, created before. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

Parámetros

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

ptr

The handle of the pointer to a C data structure.

Valores devueltos

Returns the freshly created FFI\CData object.


Creates a new FFI object

  • « FFI::cast
  • FFI::free »
  • PHP Manual
  • FFI
  • Creates a new FFI object

FFI::cdef

(PHP 7 >= 7.4.0)

FFI::cdef — Creates a new FFI object

Descripción

public static FFI::cdef ( string $code = "" , string|null $lib = null ) : FFI

Creates a new FFI object.

Parámetros

code

A string containing a sequence of declarations in regular C language (types, structures, functions, variables, etc). Actually, this string may be copy-pasted from C header files.

Nota:

C preprocessor directives are not supported, i.e. #include, #define and CPP macros do not work.

lib

The name of a shared library file, to be loaded and linked with the definitions.

Nota:

If lib is omitted, platforms supporting RTLD_DEFAULT attempt to lookup symbols declared in code in the normal global scope. Other systems will fail to resolve these symbols.

Valores devueltos

Returns the freshly created FFI object.

Historial de cambios

Versión | Descripción
8.0.0 | lib is nullable now.


Releases an unmanaged data structure

  • « FFI::cdef
  • FFI::isNull »
  • PHP Manual
  • FFI
  • Releases an unmanaged data structure

FFI::free

(PHP 7 >= 7.4.0)

FFI::free — Releases an unmanaged data structure

Descripción

public static FFI::free ( FFI\CData &$ptr ) : void

Manually releases a previously created unmanaged data structure.

Parámetros

ptr

The handle of the unmanaged pointer to a C data structure.

Valores devueltos

No devuelve ningún valor.


Checks whether a FFI\CData is a null pointer

  • « FFI::free
  • FFI::load »
  • PHP Manual
  • FFI
  • Checks whether a FFI\CData is a null pointer

FFI::isNull

(PHP 7 >= 7.4.0)

FFI::isNull — Checks whether a FFI\CData is a null pointer

Descripción

public static FFI::isNull ( FFI\CData &$ptr ) : bool

Checks whether a FFI\CData is a null pointer.

Parámetros

ptr

The handle of the pointer to a C data structure.

Valores devueltos

Returns whether a FFI\CData is a null pointer.


Loads C declarations from a C header file

  • « FFI::isNull
  • FFI::memcmp »
  • PHP Manual
  • FFI
  • Loads C declarations from a C header file

FFI::load

(PHP 7 >= 7.4.0)

FFI::load — Loads C declarations from a C header file

Descripción

public static FFI::load ( string $filename ) : FFI|null

Loads C declarations from a C header file. It is possible to specify shared libraries that should be loaded, using special FFI_LIB defines in the loaded C header file.

Parámetros

filename

The name of a C header file.

C preprocessor directives are not supported, i.e. #include, #define and CPP macros do not work, except for special cases listed below.

The header file should contain a #define statement for the FFI_SCOPE variable, e.g.: #define FFI_SCOPE "MYLIB". Refer to the class introduction for details.

The header file may contain a #define statement for the FFI_LIB variable to specify the library it exposes. If it is a system library only the file name is required, e.g.: #define FFI_LIB "libc.so.6". If it is a custom library, a relative path is required, e.g.: #define FFI_LIB "./mylib.so".

Valores devueltos

Returns the freshly created FFI object, or null on failure.

Ver también

  • FFI::scope() - Instantiates an FFI object with C declarations parsed during preloading


Compares memory areas

  • « FFI::load
  • FFI::memcpy »
  • PHP Manual
  • FFI
  • Compares memory areas

FFI::memcmp

(PHP 7 >= 7.4.0)

FFI::memcmp — Compares memory areas

Descripción

public static FFI::memcmp ( string|FFI\CData &$ptr1 , string|FFI\CData &$ptr2 , int $size ) : int

Compares size bytes from the memory areas ptr1 and ptr2. Both ptr1 and ptr2 can be any native data structures (FFI\CData) or PHP strings.

Parámetros

ptr1

The start of one memory area.

ptr2

The start of another memory area.

size

The number of bytes to compare.

Valores devueltos

Returns < 0 if the contents of the memory area starting at ptr1 are considered less than the contents of the memory area starting at ptr2, > 0 if the contents of the first memory area are considered greater than the second, and 0 if they are equal.


Copies one memory area to another

  • « FFI::memcmp
  • FFI::memset »
  • PHP Manual
  • FFI
  • Copies one memory area to another

FFI::memcpy

(PHP 7 >= 7.4.0)

FFI::memcpy — Copies one memory area to another

Descripción

public static FFI::memcpy ( FFI\CData &$to , FFI\CData|string &$from , int $size ) : void

Copies size bytes from the memory area from to the memory area to.

Parámetros

to

The start of the memory area to copy to.

from

The start of the memory area to copy from.

size

The number of bytes to copy.

Valores devueltos

No devuelve ningún valor.


Fills a memory area

  • « FFI::memcpy
  • FFI::new »
  • PHP Manual
  • FFI
  • Fills a memory area

FFI::memset

(PHP 7 >= 7.4.0)

FFI::memset — Fills a memory area

Descripción

public static FFI::memset ( FFI\CData &$ptr , int $value , int $size ) : void

Fills size bytes of the memory area pointed to by ptr with the given byte value.

Parámetros

ptr

The start of the memory area to fill.

value

The byte to fill with.

size

The number of bytes to fill.

Valores devueltos

No devuelve ningún valor.


Creates a C data structure

  • « FFI::memset
  • FFI::scope »
  • PHP Manual
  • FFI
  • Creates a C data structure

FFI::new

(PHP 7 >= 7.4.0)

FFI::new — Creates a C data structure

Descripción

public static FFI::new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public FFI::new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null

Creates a native data structure of the given C type. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

Parámetros

type

type is a valid C declaration as string, or an instance of FFI\CType which has already been created.

owned

Whether to create owned (i.e. managed) or unmanaged data. Managed data lives together with the returned FFI\CData object, and is released when the last reference to that object is released by regular PHP reference counting or GC. Unmanaged data should be released by calling FFI::free(), when no longer needed.

persistent

Whether to allocate the C data structure permanently on the system heap (using malloc()), or on the PHP request heap (using emalloc()).

Valores devueltos

Returns the freshly created FFI\CData object, or null on failure.


Instantiates an FFI object with C declarations parsed during preloading

  • « FFI::new
  • FFI::sizeof »
  • PHP Manual
  • FFI
  • Instantiates an FFI object with C declarations parsed during preloading

FFI::scope

(PHP 7 >= 7.4.0)

FFI::scope — Instantiates an FFI object with C declarations parsed during preloading

Descripción

public static FFI::scope ( string $name ) : FFI

Instantiates an FFI object with C declarations parsed during preloading.

The FFI::scope() method is safe to call multiple times for the same scope. Multiple references to the same scope may be loaded at the same time.

Parámetros

name

The scope name defined by a special FFI_SCOPE define.

Valores devueltos

Returns the freshly created FFI object.

Ver también

  • FFI::load() - Loads C declarations from a C header file


Gets the size of C data or types

  • « FFI::scope
  • FFI::string »
  • PHP Manual
  • FFI
  • Gets the size of C data or types

FFI::sizeof

(PHP 7 >= 7.4.0)

FFI::sizeof — Gets the size of C data or types

Descripción

public static FFI::sizeof ( FFI\CData|FFI\CType &$ptr ) : int

Returns the size of the given FFI\CData or FFI\CType object.

Parámetros

ptr

The handle of the C data or type.

Valores devueltos

The size of the memory area pointed at by ptr.


Creates a PHP string from a memory area

  • « FFI::sizeof
  • FFI::type »
  • PHP Manual
  • FFI
  • Creates a PHP string from a memory area

FFI::string

(PHP 7 >= 7.4.0)

FFI::string — Creates a PHP string from a memory area

Descripción

public static FFI::string ( FFI\CData &$ptr , int|null $size = null ) : string

Creates a PHP string from size bytes of the memory area pointed to by ptr.

Parámetros

ptr

The start of the memory area from which to create a string.

size

The number of bytes to copy to the string. If size is omitted, ptr must be a zero terminated array of C chars.

Valores devueltos

The freshly created PHP string.

Historial de cambios

Versión | Descripción
8.0.0 | size is nullable now; previously, its default was 0.


Creates an FFI\CType object from a C declaration

  • « FFI::string
  • FFI::typeof »
  • PHP Manual
  • FFI
  • Creates an FFI\CType object from a C declaration

FFI::type

(PHP 7 >= 7.4.0)

FFI::type — Creates an FFI\CType object from a C declaration

Descripción

public static FFI::type ( string $type ) : FFI\CType|null
public FFI::type ( string $type ) : FFI\CType|null

This function creates and returns a FFI\CType object for the given string containing a C type declaration. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

Parámetros

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

Valores devueltos

Returns the freshly created FFI\CType object, or null on failure.


Gets the FFI\CType of FFI\CData

  • « FFI::type
  • FFI\CData »
  • PHP Manual
  • FFI
  • Gets the FFI\CType of FFI\CData

FFI::typeof

(PHP 7 >= 7.4.0)

FFI::typeof — Gets the FFI\CType of FFI\CData

Descripción

public static FFI::typeof ( FFI\CData &$ptr ) : FFI\CType

Gets the FFI\CType object representing the type of the given FFI\CData object.

Parámetros

ptr

The handle of the pointer to a C data structure.

Valores devueltos

Returns the FFI\CType object representing the type of the given FFI\CData object.


C Data Handles

(PHP 7 >= 7.4.0)

Introducción

FFI\CData objects can be used in a number of ways as a regular PHP data:

  • C data of scalar types can be read and assigned via the $cdata property, e.g. $x = FFI::new('int'); $x->cdata = 42;
  • C struct and union fields can be accessed as regular PHP object property, e.g. $cdata->field
  • C array elements can be accessed as regular PHP array elements, e.g. $cdata[$offset]
  • C arrays can be iterated using foreach statements.
  • C arrays can be used as arguments of count().
  • C pointers can be dereferenced as arrays, e.g. $cdata[0]
  • C pointers can be compared using regular comparison operators (<, <=, ==, !=, >=, >).
  • C pointers can be incremented and decremented using regular +/-/ ++/–- operations, e.g. $cdata += 5
  • C pointers can be subtracted from another using regular - operations.
  • C pointers to functions can be called as a regular PHP closure, e.g. $cdata()
  • Any C data can be duplicated using the clone operator, e.g. $cdata2 = clone $cdata;
  • Any C data can be visualized using var_dump(), print_r(), etc.

Nota: Notable limitations are that FFI\CData instances do not support isset(), empty() and unset(), and that wrapped C structs and unions do not implement Traversable.

Sinopsis de la Clase

FFI\CData {
}


C Type Handles

(PHP 7 >= 7.4.0)

Introducción

Sinopsis de la Clase

FFI\CType {
}


FFI Exceptions

(PHP 7 >= 7.4.0)

Introducción

Sinopsis de la Clase

FFI\Exception extends Error implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


FFI Parser Exceptions

(PHP 7 >= 7.4.0)

Introducción

Sinopsis de la Clase

FFI\ParserException extends FFI\Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


Memtrack

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico


Introducción

El propósito de esta extensión es detectar los scripts y las funciones más ávidos de memoria.

memtrack rastrea el consumo de memoria de los scripts de PHP y produce informes (warnings) cuando el consumo alcanza ciertos niveles establecidos por el usuario. Esto se lleva a cabo reemplazando la función ejecutora predeterminada por una función especial que compara el uso de memoria antes y después de ejecutar el ejecutor original - de esta manera se puede indicar cuánto ha cambiado el uso de memoria durante la ejecución de la parte actual del código.

El Motor Zend ejecuta su ejecutor para cada matriz de código de operaciones (op_array), que normalmente significa una función, un script plano, y tal, por lo que memtrack no tiene ningún efecto notable en el rendimiento.

memtrack no proporciona ninguna función, sólo existen directivas INI que permiten configurar la forma de su funcionamiento.

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/memtrack


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración de Memtrack
Nombre | Por defecto | Cambiable
memtrack.enabled | "0" | PHP_INI_SYSTEM
memtrack.soft_limit | "0" | PHP_INI_ALL
memtrack.hard_limit | "0" | PHP_INI_ALL
memtrack.vm_limit | "0" | PHP_INI_ALL
memtrack.ignore_functions | "" | PHP_INI_SYSTEM
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

memtrack.enabled boolean

Habilita o deshabilita la extensión. El valor predeterminado es 0, es decir, deshabilitado.

memtrack.soft_limit int

Límite suave de memoria.

La extensión verifica el consumo de memoria antes y después de la ejecución de un op_array y produce una advertencia si la diferencia entre los dos valores es igual o mayor que el límite suave, pero sólo si la función no es ignorada.

Al establecer esta opción a 0 también deshabilita las advertencias suaves y duras. El valor predeterminado es 0, es decir, no se producen advertencias.

memtrack.hard_limit int

Límite duro de memoria.

La extensión verifica el consumo de memoria antes y después de la ejecución de un op_array y produce una advertencia si la diferencia entre los dos valores es igual o mayor que el límite duro, incluso si la función es ignorada. EStablecer esta opción a 0 deshabilita las advertencias de límite duro completamente. El valor predeterminado es 0, es decir, no se porducen advertencias de límite duro.

memtrack.vm_limit int

Límite de memoria virtual (establecido en un proceso).

Este límite sólo se comprueba al cierre y se produce una advertencia si el valor es mayor o igual que el límite.

Esta función sólo está soportada actualmente en sistemas operativos donde está disponible la función mallinfo() (esto es, Linux).

memtrack.ignore_functions string

Una lista de funciones separada por comas o espacios en blanco que son ingoradas por soft_limit. Los valores son insensibles a mayúsculas-minúsculas, para métodos de clase use la sintasix clase::método.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Memtrack
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • Memtrack
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo básico del uso de la extension memtrack:

Ejemplo #1 Crear una matriz grande en una función

<?php

/* /tmp/ejemplo1.php */

function foo() {
    $a = array();
    for ($i = 0; $i < 10000; $i++) $a[] = "test";
    return $a;
}
$arr = foo();

?>

Ejecutar el ejemplo con el siguiente comando:

php -d memtrack.enabled=1 -d memtrack.soft_limit=1M -d memtrack.vm_limit=3M /tmp/ejemplo1.php

El resultado del ejemplo sería algo similar a:

Warning: [memtrack] [pid 26177] user function foo() executed in /tmp/ejemplo1.php on line 10 allocated 4194304 bytes in /tmp/ejemplo1.php on line 0
Warning: [memtrack] [pid 26177] virtual memory usage on shutdown: 32911360 bytes in Unknown on line 0


OPcache

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Preloading
  • Funciones de OPcache
    • opcache_compile_file — Compiles and caches a PHP script without executing it
    • opcache_get_configuration — Get configuration information about the cache
    • opcache_get_status — Get status information about the cache
    • opcache_invalidate — Invalidates a cached script
    • opcache_is_script_cached — Tells whether a script is cached in OPCache
    • opcache_reset — Resets the contents of the opcode cache


Introducción

OPcache mejora el rendimiento de PHP almacenando el código de bytes de un script precompilado en la memoria compartida, eliminando así la necesidad de que PHP cargue y analice los script en cada petición.

Esta extensión está incluída en PHP 5.5.0 y posteriores, y está » disponible en PECL para las versiones 5.2, 5.3 y 5.4 de PHP.


Instalación

El proceso de instalación de OPcache varía dependiendo de la versión de PHP que se esté usando. Consulte la sección de abajo acorde a la versión que se esté empleando.

Nota:

Si fuera necesario utilizar OPcache con » Xdebug, se debe cargar OPcache antes que Xdebug.

PHP 5.5.0 y posteriores

OPcache solamente se podrá compilar como una extensión compartida. Si se ha deshabilitado la construcción de extensiones predeterminadas por medio de --disable-all, se debe compilar PHP con la la opción --enable-opcache para que OPcache esté disponible.

Una vez compilada, se puede usar la directiva de configuración zend_extension para cargar la extensión OPcache en PHP. Esto se puede realizar por medio de zend_extension=/full/path/to/opcache.so en plataformas diferentes de Windows, y con zend_extension=C:\path\to\php_opcache.dll en Windows.

PHP 5.2, 5.3 y 5.4

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ZendOpcache.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .

Configuración php.ini recomendada

Se recomiendan generalmente las siguientes opciones para proveer un buen rendimiento:

opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

Tambien se podría considerar deshabilitar opcache.save_comments y habilitar opcache.enable_file_override, aunque se deberá probar el código antes de utilizarlas durante producción, ya que se sabe que causan problemas en marcos de trabajo y aplicaciones, particularmente en casos donde se utilizan anotaciones de comentarios en la documentación.

También está disponible una lista completa de directivas de configuración admitidas por OPcache.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de OPcache
Nombre | Por defecto | Cambiable | Historial de cambios
opcache.enable | "1" | PHP_INI_ALL |
opcache.enable_cli | "0" | PHP_INI_SYSTEM | Entre PHP 7.1.2 y 7.1.6 inclusive, el valor predetermindao era "1"
opcache.memory_consumption | "128" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "64"
opcache.interned_strings_buffer | "8" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "4"
opcache.max_accelerated_files | "10000" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "2000"
opcache.max_wasted_percentage | "5" | PHP_INI_SYSTEM |
opcache.use_cwd | "1" | PHP_INI_SYSTEM |
opcache.validate_timestamps | "1" | PHP_INI_ALL |
opcache.revalidate_freq | "2" | PHP_INI_ALL |
opcache.revalidate_path | "0" | PHP_INI_ALL |
opcache.save_comments | "1" | PHP_INI_SYSTEM |
opcache.load_comments | "1" | PHP_INI_ALL | Eliminado en PHP 7.0.0.
opcache.fast_shutdown | "0" | PHP_INI_SYSTEM | Eliminado en PHP 7.2.0.
opcache.enable_file_override | "0" | PHP_INI_SYSTEM |
opcache.optimization_level | "0x7FFFBFFF" | PHP_INI_SYSTEM | Cambiado desde 0xFFFFFFFF en PHP 5.6.18
opcache.inherited_hack | "1" | PHP_INI_SYSTEM | Eliminado en PHP 7.3.0.
opcache.dups_fix | "0" | PHP_INI_ALL |
opcache.blacklist_filename | "" | PHP_INI_SYSTEM |
opcache.max_file_size | "0" | PHP_INI_SYSTEM |
opcache.consistency_checks | "0" | PHP_INI_ALL |
opcache.force_restart_timeout | "180" | PHP_INI_SYSTEM |
opcache.error_log | "" | PHP_INI_SYSTEM |
opcache.log_verbosity_level | "1" | PHP_INI_SYSTEM |
opcache.preferred_memory_model | "" | PHP_INI_SYSTEM |
opcache.protect_memory | "0" | PHP_INI_SYSTEM |
opcache.mmap_base | null | PHP_INI_SYSTEM |
opcache.restrict_api | "" | PHP_INI_SYSTEM |
opcache.file_update_protection | "2" | PHP_INI_ALL |
opcache.huge_code_pages | "0" | PHP_INI_SYSTEM |
opcache.lockfile_path | "/tmp" | PHP_INI_SYSTEM |
opcache.opt_debug_level | "0" | PHP_INI_SYSTEM |
opcache.file_cache | NULL | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_only | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_consistency_checks | "1" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_fallback | "1" | PHP_INI_SYSTEM | Solo Windows. Disponible a partir de PHP 7.0.0
opcache.validate_permission | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.14
opcache.validate_root | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.14
opcache.preload | "" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.4.0
opcache.preload_user | "" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.4.0
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

opcache.enable boolean

Habilita la caché de opcode. Cuando está deshabilitado, el código no es optimizado o almacenado en caché. El ajuste opcache.enable no puede ser habilitado en tiempo de ejecución enabled at runtime a través de ini_set(), solamente puede ser deshabilitado. Intentar habilitarlo en un script gernerará una advertencia.

opcache.enable_cli boolean

Habilita la caché de opcode para la versión CLI de PHP.

opcache.memory_consumption integer

EL tamaño del almacén de memoria compartida utilizado por OPcache, en megabytes.

opcache.interned_strings_buffer integer

La cantidad de memoria utilizada para almacenar cadenas, en megabytes. Esta directiva de configuración es ignorada en PHP < 5.3.0.

opcache.max_accelerated_files integer

El número máximo de claves (y por lo tanto, de scripts) en la tabla de hash de OPcache. El valor que realmente se utilizará será el primer número en el conjunto de los números primos { 223, 463, 983, 1979, 3907, 7963, 16229, 32531, 65407, 130987 } que sea mayor o igual al valor configurado. El valor mínimo es 200. El valor máximo es 100000 en PHP < 5.5.6, y 1000000 en versiones posteriores.

opcache.max_wasted_percentage integer

El porcentaje máximo de memoria desperdiciada que está permitida antes de que un reinicio sea programado.

opcache.use_cwd boolean

Si está habilitada, OPcache añade el directorio de trabajo actual a la clave del script, eliminado así las posibles colisiones entre ficheros con el mismo nombre base. Deshabilitar esta directiva mejora el rendimiento pero podría generar problemas en aplicaciones existentes.

opcache.validate_timestamps boolean

Si está habilitado, OPcache consultará por scripts actualizados cada opcache.revalidate_freq segundos. Cuando esta directiva está deshabilitada, se debe reiniciar OPcache de forma manual mediante opcache_reset(), opcache_invalidate() o reiniciando el servidor web para que los cambios en el sistema de ficheros tomen efecto.

opcache.revalidate_freq integer

La frecuencia de verificación de las marcas temporales de Unix de los scripts por actualizaciones, en segundos. 0 hará que OPcache consulte por actualizaciones en cada petición.

Esta directiva de configuración es ignorada si opcache.validate_timestamps está deshabilitada.

opcache.revalidate_path boolean

Si está deshabilitada, los ficheros cacheados existentes que usen el mismo include_path serán reutilizados. Por lo tanto, si un fichero con el mismo nombre está en algún otro lado del include_path, no será encontrado.

opcache.save_comments boolean

Si está deshabilitada, todos los comentarios de la documentación serán elliminados de la caché de opcode para reducir el tamaño del código optimizado. Deshabilitar esta directiva de configuración podría generar problemas en aplicaciones y frameworks que dependen del análisis de comentarios para anotaciones, incluyendo Doctrine, Zend Framework 2 y PHPUnit.

opcache.load_comments boolean

Si está deshabilitada, los comentarios de la documentación no serán cargados de la caché de opcode aun si éstos existen. Esto puede ser usado junto con opcache.save_comments para cargar sólo los comentarios para las aplicaciones que los requieran.

opcache.fast_shutdown boolean

Si está habilitada, una secuencia de apagado rápida es utilizada que no libera cada bloque asignado sino que depende del gestor de memoria del Zend Engine para rescindir del conjunto de variables de petición completo.

Esta directiva ha sido eliminada en PHP 7.2.0. Se ha integrado una variante de la secuencia de apagado rápido en PHP, y será usada automáticamente si es posible.

opcache.enable_file_override boolean

Cuando está habilitada, la caché de opcode será consultado para determinar si un fichero ya ha sido cacheado cuando file_exists(), is_file() y is_readable() son llamadas. Esto puede incrementar el rendimiento en aplicaciones que chequean la existencia y legibilidad de los scripts PHP, pero arriesgando devolver datos obsoletos si opcache.validate_timestamps está deshabilitada.

opcache.optimization_level integer

Un bitmask que controla cúales permisos de optimización son ejecutados.

opcache.inherited_hack bool

Esta directiva de configuración es ignorada.

opcache.dups_fix boolean

Este hack debería estar habilitado para funcionar sólo para evitar errores "Cannot redeclare class".

opcache.blacklist_filename string

La ubicación del fichero de blacklist de OPcache. Un fichero blacklist es un texto que contiene los nombres de los ficheros que no deberían ser acelerados, uno por línea. Se permiten comodines, y prefijos también pueden ser provistos. Las líneas que comienzen con un punto y coma son ignoradas como comentarios.

Un fichero blacklist simple luciría así:

; Matches a specific file.
/var/www/broken.php
; A prefix that matches all files starting with x.
/var/www/x
; A wildcard match.
/var/www/*-broken.php
opcache.max_file_size integer

El tamaño de fichero máximo que será almacenado en caché, en bytes. Si es 0, todos los ficheros serán almacenados en caché.

opcache.consistency_checks integer

Si es distinto de cero, OPcache verificará el checksum de la caché cada N peticiones, donde N es el valor de esta directiva de configuración. Esto debería sólo estar habilitado durante la depuración ya que puede tener un impacto negativo en el rendimiento.

opcache.force_restart_timeout integer

La cantidad de tiempo a esperar el comienzo de un reinicio programado si la caché no está activa, en segundos. Si se acaba el tiempo, entonces OPcache asume que algo anda mal y terminará todos los procesos que bloqueen la caché para permitir un reinicio.

Si opcache.log_verbosity_level es 2 o más, una advertencia será guardada en el registro de errores si esto ocurre.

opcache.error_log string

El registro de errores de errores de OPcache. Una cadena vacía es tratada de igual forma que stderr, y resultará en registros siendo enviados a errores estándar (que será el registro de errores del servidor Web en la mayoría de los casos).

opcache.log_verbosity_level integer

El nivel de verbosidad del registro. Por defecto, sólo los errores fatales (nivel 0) y errores (nivel 1) son registrados. Otros niveles disponibles son advertencias (nivel 2), mensajes de información (nivel 3) y mensajes de depuración (nivel 4).

opcache.preferred_memory_model string

El modelo de memoria principal que utilizará OPcache. Si se deja vacío, OPcache seleccionará el modelo más apropiado, el cual es el comportamiento correcto en prácticamente todos los casos.

Los valores posibles incluyen mmap, shm, posix y win32.

opcache.protect_memory boolean

Protege la memoria compartida de escrituras inesperadas mientras se ejecutan scripts. Esto es útil sólo para depuración interna.

opcache.mmap_base string

La base usada para los segmentos de memoria compartida en Windows. Todos los procesos PHP deben mapear la memoria compartida con el mismo espacio de direcciones. Utilizando esta directiva se corrigen los errores "Unable to reattach to base address".

opcache.restrict_api string

Permite llamar a funciones de la API de OPcache solamente desde scripts de PHP cuya ruta comience con la cadena especificada. El valor predeterminado de "" significa sin restricciones.

opcache.file_update_protection string

Previene de almacenar en caché ficheros que estén menos que este número de segundos. Protege del almacenamiento en caché de ficheros no actualizados completamente. En caso de que todas las actualizaciones de ficheros del sitio sean atómicas, se puede aumentar el rendimiento estableciéndolo a "0".

opcache.huge_code_pages string

Habilita o inhabilita la copia de código de PHP (segmento de texto) a HUGE PAGES. Esto debería mejorar el rendimiento, aunque requiere una configuración apropiada del SO.

opcache.lockfile_path string

Ruta absoluta usada para almacenar shared lockfiles compartidos (solo para *nix)

opcache.opt_debug_level string

Produce volcados de opcode para depurar diferentes escenarios de optimización. 0x10000 generará opcodes a medida que el compilador los haya producido antes de ocurra cualquier optimización, mientras que 0x20000 generará códigos optimizados.

opcache.file_cache string

Habilita y establece el segundo nivel de directorio de caché. Debería mejorar el rendimiento cuando la memoria SHM esté llena, cuando se reinicie el servidor o se restablezca la SHM. El valor predeterminado "" inhabilita el almacenamiento en cache basado en ficheros.

opcache.file_cache_only boolean

Habilita o inhabilita el almacenamiento de opcodes en memoria compartida.

opcache.file_cache_consistency_checks boolean

Habilita o inhabilita la validación del checksum cuando un script sea cargado desde la caché de ficheros.

opcache.file_cache_fallback boolean

Implica opcache.file_cache_only=1 para ciertos procesos que fallan al volver a vincularse a la memoria conpartida (solo Windows). Es necesaria la caché de ficheros explícitamente.

Precaución

La inhabilitación de esta opción de configuración puede evitar el inicio de procesos, por lo que está desaconsejado.

opcache.validate_permission boolean

Valida los permisos de ficheros almacenados en caché con el usuario en uso.

opcache.validate_root boolean

Evita la colisión de nombres en entornos con chroot. Debe estar habilitado en todos los entornos con chroot para evitar el acceso a ficheros fuera de chroot.

opcache.preload string

Especifica un script de PHP que va a ser compilado y ejecutado en el arranque del servidor, lo que podría precargar otros ficheros, ya sea con include o usando la función opcache_compile_file(). Todas las entidades (p. ej. funciones y clases) definidas en estos ficheros estarán disponibles para peticiones listas para usar, hasta que el servidor sea apagado.

opcache.preload_user string

La precarga de código como «root» no está permitida por razones de seguridad. Esta directiva facilita que la precarga se ejecute como otro usuario.


  • « Configuración en tiempo de ejecución
  • Preloading »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Preloading

As of PHP 7.4.0, PHP can be configured to preload scripts into the opcache when the engine starts. Any symbols (functions, classes, etc.) in those files will then become globally available for all requests without needing to be explicitly included. That trades convenience and performance (because the code is always available) for baseline memory usage. It also requires restarting the PHP process to clear pre-loaded scripts, meaning this feature is only practical to use in production, not in a development environment.

Note that the optimal tradeoff between performance and memory may vary with the application. "Preload everything" may be the easiest strategy, but not necessarily the best strategy. Additionally, preloading is only useful when there is a persistent process from one request to another. That means while it can work in a CLI script if the opcache is enabled, it's generally pointless. The exception is when using preloading on FFI libraries.

Nota:

Preloading is not supported on Windows.

Configuring preloading involves two steps, and requires that the opcache be enabled. First, set the opcache.preload value in php.ini:

opcache.preload=preload.php

preload.php is an arbitrary file that will run once at server startup (PHP-FPM, mod_php, etc.) and load code into persistent memory. If PHP will be run as root (not recommended), the opcache.preload_user value can specify an alternate system user to run the preloading. Running preloading as root is not allowed.

In the preload.php script, any file referenced by include, include_once, require, require_once, or opcache_compile_file() will be parsed into persistent memory. In the following example, all .php files in the src directory will be preloaded, unless they are a Test file.

<?php
$directory = new RecursiveDirectoryIterator(__DIR__ . '/src');
$fullTree = new RecursiveIteratorIterator($directory);
$phpFiles = new RegexIterator($fullTree, '/.+((?<!Test)+\.php$)/i', RecursiveRegexIterator::GET_MATCH);

foreach ($phpFiles as $key => $file) {
    require_once($file[0]);
}
?>

Both include and opcache_compile_file() will work, but have different implications for how code gets handled.

  • include will execute code in the file, while opcache_compile_file() will not. That means only the former supports conditional declaration (functions declared inside an if-block).
  • Because include will execute code, nested included files will also be parsed and their declarations preloaded.
  • opcache_compile_file() can load files in any order. That is, if a.php defines class A and b.php defines class B that extends A, then opcache_compile_file() can load those two files in any order. When using include, however, a.php must be included first.
  • In either case, if a later script includes a file that has already been preloaded then its contents will still execute, but any symbols it defines will not be re-defined. Using include_once will not prevent the file from being included a second time.
Which approach is better therefore depends on the desired behavior. With code that would otherwise use an autoloader, opcache_compile_file() allows for greater flexibility. With code that would otherwise be loaded manually, include will be more robust.


Funciones de OPcache

Tabla de contenidos

  • opcache_compile_file — Compiles and caches a PHP script without executing it
  • opcache_get_configuration — Get configuration information about the cache
  • opcache_get_status — Get status information about the cache
  • opcache_invalidate — Invalidates a cached script
  • opcache_is_script_cached — Tells whether a script is cached in OPCache
  • opcache_reset — Resets the contents of the opcode cache


Compiles and caches a PHP script without executing it

  • « Funciones de OPcache
  • opcache_get_configuration »
  • PHP Manual
  • Funciones de OPcache
  • Compiles and caches a PHP script without executing it

opcache_compile_file

(PHP 5 >= 5.5.5, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_compile_file — Compiles and caches a PHP script without executing it

Descripción

opcache_compile_file ( string $filename ) : bool

This function compiles a PHP script and adds it to the opcode cache without executing it. This can be used to prime the cache after a Web server restart by pre-caching files that will be included in later requests.

Parámetros

filename

The path to the PHP script to be compiled.

Valores devueltos

Returns true if filename was compiled successfully o false en caso de error.

Errores/Excepciones

If filename cannot be loaded or compiled, an error of level E_WARNING is generated. You may use @ to suppress this warning.

Ver también

  • opcache_invalidate() - Invalidates a cached script


Get configuration information about the cache

  • « opcache_compile_file
  • opcache_get_status »
  • PHP Manual
  • Funciones de OPcache
  • Get configuration information about the cache

opcache_get_configuration

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_get_configuration — Get configuration information about the cache

Descripción

opcache_get_configuration ( ) : array|false

This function returns configuration information about the cache instance

Valores devueltos

Returns an array of information, including ini, blacklist and version

Errores/Excepciones

If opcache.restrict_api is in use and the current path is in violation of the rule, an E_WARNING will be raised; no status information will be returned.

Ver también

  • opcache_get_status() - Get status information about the cache


Get status information about the cache

  • « opcache_get_configuration
  • opcache_invalidate »
  • PHP Manual
  • Funciones de OPcache
  • Get status information about the cache

opcache_get_status

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_get_status — Get status information about the cache

Descripción

opcache_get_status ( bool $include_scripts = true ) : array|false

This function returns state information about the cache instance

Parámetros

include_scripts

Include script specific state information

Valores devueltos

Returns an array of information, optionally containing script specific state information, o false en caso de error.

Errores/Excepciones

If opcache.restrict_api is in use and the current path is in violation of the rule, an E_WARNING will be raised; no status information will be returned.

Ver también

  • opcache_get_configuration() - Get configuration information about the cache


Invalidates a cached script

  • « opcache_get_status
  • opcache_is_script_cached »
  • PHP Manual
  • Funciones de OPcache
  • Invalidates a cached script

opcache_invalidate

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.0)

opcache_invalidate — Invalidates a cached script

Descripción

opcache_invalidate ( string $filename , bool $force = false ) : bool

This function invalidates a particular script from the opcode cache. If force is unset or false, the script will only be invalidated if the modification time of the script is newer than the cached opcodes.

Parámetros

filename

The path to the script being invalidated.

force

If set to true, the script will be invalidated regardless of whether invalidation is necessary.

Valores devueltos

Returns true if the opcode cache for filename was invalidated or if there was nothing to invalidate, or false if the opcode cache is disabled.

Ver también

  • opcache_compile_file() - Compiles and caches a PHP script without executing it
  • opcache_reset() - Resets the contents of the opcode cache


Tells whether a script is cached in OPCache

  • « opcache_invalidate
  • opcache_reset »
  • PHP Manual
  • Funciones de OPcache
  • Tells whether a script is cached in OPCache

opcache_is_script_cached

(PHP 5 >= 5.5.11, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.4)

opcache_is_script_cached — Tells whether a script is cached in OPCache

Descripción

opcache_is_script_cached ( string $filename ) : bool

This function checks if a PHP script has been cached in OPCache. This can be used to more easily detect the "warming" of the cache for a particular script.

Parámetros

filename

The path to the PHP script to be checked.

Valores devueltos

Returns true if filename is cached in OPCache, false otherwise.

Ver también

  • opcache_compile_file() - Compiles and caches a PHP script without executing it


Resets the contents of the opcode cache

  • « opcache_is_script_cached
  • Control de la salida »
  • PHP Manual
  • Funciones de OPcache
  • Resets the contents of the opcode cache

opcache_reset

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.0)

opcache_reset — Resets the contents of the opcode cache

Descripción

opcache_reset ( ) : bool

This function resets the entire opcode cache. After calling opcache_reset(), all scripts will be reloaded and reparsed the next time they are hit.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the opcode cache was reset, or false if the opcode cache is disabled.

Ver también

  • opcache_invalidate() - Invalidates a cached script


Control del búfer de salida

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones del Control de la salida
    • flush — Vaciar el búfer de salida del sistema
    • ob_clean — Limpiar (eliminar) el búfer de salida
    • ob_end_clean — Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
    • ob_end_flush — Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
    • ob_flush — Vaciar (enviar) el búfer de salida
    • ob_get_clean — Obtiene el contenido del búfer actual y elimina el búfer de salida actual
    • ob_get_contents — Devolver el contenido del búfer de salida
    • ob_get_flush — Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida
    • ob_get_length — Devolver la longitud del búfer de salida
    • ob_get_level — Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida
    • ob_get_status — Obtener el estado de los búferes de salida
    • ob_gzhandler — Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip
    • ob_implicit_flush — Habilitar/deshabilitar el volcado implícito
    • ob_list_handlers — Enumerar todos los gestores de salida en uso
    • ob_start — Activa el almacenamiento en búfer de la salida
    • output_add_rewrite_var — Añadir valores al mecanismo de reescritura de URLs
    • output_reset_rewrite_vars — Restablecer los valores del mecanismo de reescritura de URLs


Introducción

Las funciones del Control de la salida permiten controlar cuándo la salida se evía desde un script. Esto puede ser útil en diferentes situaciones, especialmente si es necesario enviar cabeceras al navegador después de que el script haya comenzado a producir datos. Las funciones del Control de la salida no afectan a las cabeceras enviadas usando header() o setcookie(), solamente a las funciones como echo y a los datos entre bloques de código de PHP.

Nota:

Cuando se actualiza desde PHP 4.1.x (y 4.2.x) a 4.3.x, debido a un error en versones anteriores, ha de asegurarse de que implicit_flush esté en OFF en el fichero php.ini, de lo contrario cualquier cosa producida con ob_start() no se ocultará desde la salida.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración del Control de la salida
Nombre | Por defecto | Cambiable | Historial de cambios
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR | Disponible desde PHP 4.0.4.
implicit_flush | "0" | PHP_INI_ALL | PHP_INI_PERDIR en PHP <= 4.2.3.
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | Disponible desde PHP 4.0.4. Antes de PHP 7.1.0, se usaba para establecer reescriburas de trans sid de sesión. Desde 7.1.0 solamente lo utililza output_add_rewrite_var().
url_rewriter.hosts | $_SERVER['HTTP_HOST'] is used as default. | PHP_INI_ALL | Disponible desde PHP 7.1.0
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

output_buffering boolean/integer

Se puede habilitar el búfer de salida para todos los ficheros estableciendo esta directiva a 'On'. Si se necesita limitar el tamaño del búfer a un tamaño en particular, se puede usar un número máximo de bytes en lugar de 'On' como valor para esta directiva (p.ej., output_buffering=4096). A partir de PHP 4.3.5, esta direcitva siempre es 'Off' en PHP-CLI.

output_handler string

Se pueden redireccionar todas las salidas producidas por los scripts a una funcion. Por ejemplo, si se establece output_handler a mb_output_handler(), la codificación de caracteres será convertida de forma transparente a la codificación especificada. Al establecer cualquier gestor de salida automáticamente se activará el búfer de salida.

Nota:

No se puede usar mb_output_handler() con ob_iconv_handler(), y tampoco se puedem usar juntos ob_gzhandler() y zlib.output_compression.

Nota:

Solamente se pueden usar funciones internas con esta directiva. Para funciones definidas por el usuario se ha de usar ob_start().

implicit_flush boolean

Es false de forma predeterminada. Cambiarla a true le dirá a PHP que indique a la capa de salida que se vuelque a sí misma automáticamente después de cada bloque de salida. Esto es equivalente a llamar a la función de PHP flush() después de cada llamada a print o echo y de cada bloque de HTML.

Cuando se usa PHP dentro de un entorno web, la activación de esta opción tiene serias implicaciones de rendimiento, por lo que solamente se recomienda para propósitos de depuración. Este valor es true de forma predeterminada cuando se opera bajo la SAPI CLI.

Véase también ob_implicit_flush().

url_rewriter.tags string
url_rewriter.tags especifica qué etiquetas HTML son reescritas por valores de output_add_rewrite_var(). Las predeterminadas son a=href,area=href,frame=src,input=src,form= form es una etiqueta especial. <input hidden="id_sesión" name="nombre_sesión"> se añade como variable de formulario.

Nota: Antes de PHP 7.1.0, url_rewriter.tags se utilizaba para especificar session.trans_sid_tags. Desde PHP 7.1.0, fieldset ya no se considera una etiqueta especial.

url_rewriter.hosts string
url_rewriter.hosts especifica los 'hosts' que son reescritos para incluir valores de output_add_rewrite_var(). El predeterminado es $_SERVER['HTTP_HOST']. Se pueden especificar varios hosts mediante ",", y no se permiten espacios entre hosts. P.ej. php.net,wiki.php.net,bugs.php.net


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

PHP_OUTPUT_HANDLER_START (integer)

Indica que el almacenamiento en el búfer de salida ha comenzado.

PHP_OUTPUT_HANDLER_WRITE (integer)

Indica que el búfer de salida está siendo volcado y tiene datos para producir una salida.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_FLUSH (integer)

Indica que el búfer de salida ha sido volcado.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_CLEAN (integer)

Indica que el búfer de salida ha sido limpiado.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_FINAL (integer)

Indica que esta es la operación final del almacenamiento del búfer de salida.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_CONT (integer)

Indica que el búfer de salida ha sido volcado, pero que el almacenamiento en el búfer de salida continurá.

A partir de PHP 5.4, esta constante es un alias de PHP_OUTPUT_HANDLER_WRITE.

PHP_OUTPUT_HANDLER_END (integer)

Indica que el almacenamiento del búfer de salida ha finalizado.

A partir de PHP 5.4, esta constante es un alias de PHP_OUTPUT_HANDLER_FINAL.

PHP_OUTPUT_HANDLER_CLEANABLE (integer)

Controla si un búfer de salida creado por ob_start() puede ser limpiado.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_FLUSHABLE (integer)

Controla si un búfer de salida creado por ob_start() puede ser volcado.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_REMOVABLE (integer)

Controla si un búfer de salida creado por ob_start() puede ser eliminado antes de finalizar el script.

Disponible desde PHP 5.4.

PHP_OUTPUT_HANDLER_STDFLAGS (integer)

El conjunto predeterminado de banderas de búfer de salida; actualmente equivalente a PHP_OUTPUT_HANDLER_CLEANABLE | PHP_OUTPUT_HANDLER_FLUSHABLE | PHP_OUTPUT_HANDLER_REMOVABLE.

Disponible desde PHP 5.4.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • Control de la salida
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo #1 Ejemplo de control de la salida

<?php

ob_start();
echo "Hola\n";

setcookie("nombre_cookie", "datos_cookie");

ob_end_flush();

?>

En el ejemplo anterior, la salida de echo sería almacenada en el búfer de salida hasta que se llamara a ob_end_flush(). Mientras tanto, la llamada a setcookie() almacenaría con éxito una cookie sin causar ningún error. (Las cabeceras normalmente no se pueden enviar al navegador después de haber enviado ya los datos.)


Funciones del Control de la salida

Ver también

Véase también header() y setcookie().

Tabla de contenidos

  • flush — Vaciar el búfer de salida del sistema
  • ob_clean — Limpiar (eliminar) el búfer de salida
  • ob_end_clean — Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_flush — Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_flush — Vaciar (enviar) el búfer de salida
  • ob_get_clean — Obtiene el contenido del búfer actual y elimina el búfer de salida actual
  • ob_get_contents — Devolver el contenido del búfer de salida
  • ob_get_flush — Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida
  • ob_get_length — Devolver la longitud del búfer de salida
  • ob_get_level — Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida
  • ob_get_status — Obtener el estado de los búferes de salida
  • ob_gzhandler — Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip
  • ob_implicit_flush — Habilitar/deshabilitar el volcado implícito
  • ob_list_handlers — Enumerar todos los gestores de salida en uso
  • ob_start — Activa el almacenamiento en búfer de la salida
  • output_add_rewrite_var — Añadir valores al mecanismo de reescritura de URLs
  • output_reset_rewrite_vars — Restablecer los valores del mecanismo de reescritura de URLs


Vaciar el búfer de salida del sistema

  • « Funciones del Control de la salida
  • ob_clean »
  • PHP Manual
  • Funciones del Control de la salida
  • Vaciar el búfer de salida del sistema

flush

(PHP 4, PHP 5, PHP 7, PHP 8)

flush — Vaciar el búfer de salida del sistema

Descripción

flush ( ) : void

Vacía los búferes de escritura del sistema de PHP y de cualquiera que sea el backend en el que se esté usando PHP (CGI, un servidor web, etc.). Trata de enviar toda la salida producida hasta el momento al navegador, aunque se ha de tener en cuenta algunas cosas.

flush() podría no sobreescribir el esquema del almacenamiento en búfer del servidor web, por lo que no tiene efecto sobre ningún búfer en el lado del cliente del navegador. Tampoco afecta al mecanismo del búfer de salida del espacio de usuario de PHP. Esto significa que se ha de llamar tanto a ob_flush() como a flush() para volcar los búferes de salida si se están usando aquellos.

Algunos servidores, especialmente en Win32, seguirán almacenando en búfer la salida producida por un script hasta que éste termine antes de transmitir los resultados al navegador.

Puede que algunos módulos de servidor para Apache, como mod_gzip, usen búferes propios que causarán que flush() no resulte en un envío inmediato de los datos al cliente.

Incluso el navegador puede almacenar en búfer su entrada antes de mostrarla. Netscape, por ejemplo, almacena en búfer el texto hasta que recibe un final de línea o el comienzo de una etiqueta, por lo que no interpretará las tablas hasta que se encuentre la etiqueta </table> de la tabla más externa.

Algunas versiones de Microsoft Internet Explorer solo empezarán a mostrar la página después de que han recibido 256 bytes de salida, por lo que puede que sea necesario enviar espacios en blanco extra antes del volcado para que se muestre la página en tales navegadores.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ob_flush() - Vaciar (enviar) el búfer de salida
  • ob_clean() - Limpiar (eliminar) el búfer de salida
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Limpiar (eliminar) el búfer de salida

  • « flush
  • ob_end_clean »
  • PHP Manual
  • Funciones del Control de la salida
  • Limpiar (eliminar) el búfer de salida

ob_clean

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_clean — Limpiar (eliminar) el búfer de salida

Descripción

ob_clean ( ) : void

Esta función desecha el contenido del búfer de salida.

Esta función no destruye el búfer de salida como lo hace ob_end_clean().

El búfer de salida debe estar iniciado por ob_start() con el indicador PHP_OUTPUT_HANDLER_CLEANABLE. Si no, ob_clean() no funcionará.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ob_flush() - Vaciar (enviar) el búfer de salida
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo

  • « ob_clean
  • ob_end_flush »
  • PHP Manual
  • Funciones del Control de la salida
  • Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo

ob_end_clean

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_end_clean — Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo

Descripción

ob_end_clean ( ) : bool

Esta función desecha el contenido del búfer de salida en cola y lo desactiva. Si fuera necesario continuar procesando el contenido del búfer, se ha de llamar a ob_get_contents() antes que a ob_end_clean(), ya que el contenido del búfer es desechado cuando se llama a ob_end_clean().

El búfer de salida debe estar iniciado por ob_start() con los indicadores PHP_OUTPUT_HANDLER_CLEANABLE y PHP_OUTPUT_HANDLER_REMOVABLE. Si no, ob_end_clean() no funcionará.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Entre las posibles razones de un fallo se encuentra llamar a la función sin un búfer activo, o que por algún motivo no se pueda eliminar un búfer (posible en el caso de búferes especiales).

Errores/Excepciones

Si la función falla, genera un error de nivel E_NOTICE.

Ejemplos

El siguiente ejemplo muestra una forma sencilla de deshacerse de todos los búferes de salida:

Ejemplo #1 Ejemplo de ob_end_clean()

<?php
ob_start();
echo 'Texto que no será mostrado.';
ob_end_clean();
?>

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_get_contents() - Devolver el contenido del búfer de salida
  • ob_flush() - Vaciar (enviar) el búfer de salida


Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo

  • « ob_end_clean
  • ob_flush »
  • PHP Manual
  • Funciones del Control de la salida
  • Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo

ob_end_flush

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_end_flush — Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo

Descripción

ob_end_flush ( ) : bool

Esta función enviará el contenido del búfer de salida en cola (si existe) y los deshabilitará. Si fuera necesario procesar el contenido del búfer, se ha de llamar a ob_get_contents() antes que a ob_end_flush(), ya que el contenido del búfer es descartado después de llamar a ob_end_flush().

El búfer de salida debe estar iniciado por ob_start() con los indicadores PHP_OUTPUT_HANDLER_FLUSHABLE y PHP_OUTPUT_HANDLER_REMOVABLE Si no, ob_end_flush() no funcionará.

Nota: Esta función es similar a ob_get_flush(), excepto que ob_get_flush() devuelve el búfer como una cadena de caracteres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Entre las posibles razones de un fallo se encuentra llamar a la función sin un búfer activo, o que por algún motivo no se pueda eliminar un búfer (posible en el caso de búferes especiales).

Errores/Excepciones

Si la función falla, genera un error de nivel E_NOTICE.

Ejemplos

Ejemplo #1 Ejemplo de ob_end_flush()

El siguiente ejemplo muestra una forma sencilla de volcar y finalizar todos los búferes de salida:

<?php
  while (@ob_end_flush());
?>

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_get_contents() - Devolver el contenido del búfer de salida
  • ob_get_flush() - Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida
  • ob_flush() - Vaciar (enviar) el búfer de salida
  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Vaciar (enviar) el búfer de salida

  • « ob_end_flush
  • ob_get_clean »
  • PHP Manual
  • Funciones del Control de la salida
  • Vaciar (enviar) el búfer de salida

ob_flush

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_flush — Vaciar (enviar) el búfer de salida

Descripción

ob_flush ( ) : void

Esta función enviará el contenido del búfer de salida (si existe). Si fuera necesario continuar procesando el contenido del búfer, se ha de llamar a ob_get_contents() antes que a ob_flush(), ya que el contenido del búfer es descartado después de llamar a ob_flush().

Esta función no destruye el búfer de salida, como lo hace ob_end_flush().

Valores devueltos

No devuelve ningún valor.

Ver también

  • ob_get_contents() - Devolver el contenido del búfer de salida
  • ob_clean() - Limpiar (eliminar) el búfer de salida
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Obtiene el contenido del búfer actual y elimina el búfer de salida actual

  • « ob_flush
  • ob_get_contents »
  • PHP Manual
  • Funciones del Control de la salida
  • Obtiene el contenido del búfer actual y elimina el búfer de salida actual

ob_get_clean

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_get_clean — Obtiene el contenido del búfer actual y elimina el búfer de salida actual

Descripción

ob_get_clean ( ) : string

Obtiene el contenido del búfer actual y elimina el búfer de salida actual.

ob_get_clean() básicamente ejecuta
ob_get_contents() y
ob_end_clean().

El búfer de salida debe estar iniciado por ob_start() con el indicador PHP_OUTPUT_HANDLER_CLEANABLE Si no, ob_get_clean() no funcionará.

Valores devueltos

Devuelve el contenido del búfer de salida y finaliza el almacenamiento en el mismo. Si el almacenamiento en el búfer de salida no está activo, entonces devuelve false.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de ob_get_clean()

<?php

ob_start();

echo "Hola Mundo";

$salida = ob_get_clean();
$salida = strtolower($salida);

var_dump($salida);
?>

El resultado del ejemplo sería:

string(10) "hola mundo"

Ver también

  • ob_get_contents() - Devolver el contenido del búfer de salida
  • ob_start() - Activa el almacenamiento en búfer de la salida


Devolver el contenido del búfer de salida

  • « ob_get_clean
  • ob_get_flush »
  • PHP Manual
  • Funciones del Control de la salida
  • Devolver el contenido del búfer de salida

ob_get_contents

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_get_contents — Devolver el contenido del búfer de salida

Descripción

ob_get_contents ( ) : string

Obtiene el contenido del búfer de salida, sin borrarlo.

Valores devueltos

Devolverá el contenido del búfer de salida, o false si el almacenameinto en el búfer de salida no está activo.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de ob_get_contents()

<?php

ob_start();

echo "Hola ";

$salida1 = ob_get_contents();

echo "Mundo";

$salida2 = ob_get_contents();

ob_end_clean();

var_dump($salida1, $salida2);
?>

El resultado del ejemplo sería:

string(5) "Hola "
string(10) "Hola Mundo"

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_get_length() - Devolver la longitud del búfer de salida


Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida

  • « ob_get_contents
  • ob_get_length »
  • PHP Manual
  • Funciones del Control de la salida
  • Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida

ob_get_flush

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_get_flush — Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida

Descripción

ob_get_flush ( ) : string

ob_get_flush() vuelca el búfer de salida, lo devuelve como una cadena de caracteres y deshabilita el almacenamiento en el búfer de salida.

El búfer de salida debe estar iniciado por ob_start() con el indicador PHP_OUTPUT_HANDLER_FLUSHABLE Si no, ob_get_flush() no funcionará.

Nota: Esta función es similar a ob_end_flush(), excepto que esta función además devuelve el búfer como una cadena de caracteres.

Valores devueltos

Devuelve el búfer de salida, o false si el almacenamiento en el búfer no está activo.

Ejemplos

Ejemplo #1 Ejemplo de ob_get_flush()

<?php
//usar output_buffering=On
print_r(ob_list_handlers());

//guardar el búfer en un fichero
$búfer = ob_get_flush();
file_put_contents('bufer.txt', $búfer);

print_r(ob_list_handlers());
?>

El resultado del ejemplo sería:

Array
(
    [0] => default output handler
)
Array
(
)

Ver también

  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_list_handlers() - Enumerar todos los gestores de salida en uso


Devolver la longitud del búfer de salida

  • « ob_get_flush
  • ob_get_level »
  • PHP Manual
  • Funciones del Control de la salida
  • Devolver la longitud del búfer de salida

ob_get_length

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ob_get_length — Devolver la longitud del búfer de salida

Descripción

ob_get_length ( ) : int

Esta función devolverá la longitud del contenido del búfer de salida, en bytes.

Valores devueltos

Devuelve la longitud del contenido del búfer de salida, en bytes, o false si no está activo el almacenamiento en búfer.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de ob_get_length()

<?php

ob_start();

echo "Hola ";

$longitud1 = ob_get_length();

echo "Mundo";

$longitud2 = ob_get_length();

ob_end_clean();

echo $longitud1 . ", ." . $longitud2;
?>

El resultado del ejemplo sería:

5, 10

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_get_contents() - Devolver el contenido del búfer de salida


Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida

  • « ob_get_length
  • ob_get_status »
  • PHP Manual
  • Funciones del Control de la salida
  • Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida

ob_get_level

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_get_level — Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida

Descripción

ob_get_level ( ) : int

Devuelve el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida.

Valores devueltos

Devuelve el nivel de los gestores de almacenamiento en búfer de salida anidados, o cero si el almacenamiento en búfer no está activo.

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_get_contents() - Devolver el contenido del búfer de salida


Obtener el estado de los búferes de salida

  • « ob_get_level
  • ob_gzhandler »
  • PHP Manual
  • Funciones del Control de la salida
  • Obtener el estado de los búferes de salida

ob_get_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_get_status — Obtener el estado de los búferes de salida

Descripción

ob_get_status ( bool $full_status = FALSE ) : array

ob_get_status() devuelve la información de estado sobre el búfer de salida de nivel superior, o sobre todos los niveles activos de búferes de salida si full_status es establecido a true.

Parámetros

full_status

true para devolver todos los niveles de búferes de salida activos. Si es false o no se establece, solo es devuelto el búfer de salida de nivel más alto.

Valores devueltos

Si esta función es llamada sin el parámetro full_status, o con full_status = false, se devuelve un único array con los siguientes elementos:

Array
(
    [level] => 2
    [type] => 0
    [status] => 0
    [name] => URL-Rewriter
    [del] => 1
)
Resultados simples de ob_get_status()
Clave | Valor
level | Nivel de anidamiento de la salida
type | PHP_OUTPUT_HANDLER_INTERNAL(0) o PHP_OUTPUT_HANDLER_USER (1)
status | Un valor entre PHP_OUTPUT_HANDLER_START (0), PHP_OUTPUT_HANDLER_CONT (1) o PHP_OUTPUT_HANDLER_END (2)
name | Nombre del gestor de salida activo, o 'default output handler' si no hay uno establecido
del | Bandera de borrado, tal y como está establecido por ob_start()

Si se llama con full_status = true, se devuelve un array con un elemento por cada nivel de búfer de salida activo. El nivel de salida se usa como la clave del array de nivel superior, y cada elemento del array en sí es otro array que contiene información de estado sobre un nivel de salida activo.

Array
(
    [0] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 1
            [status] => 0
            [name] => default output handler
            [del] => 1
        )

    [1] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 0
            [buffer_size] => 0
            [status] => 0
            [name] => URL-Rewriter
            [del] => 1
        )

)

La salida completa contiene los siguientes elementos adicionales:

Resultados completos de ob_get_status()
Clave | Valor
chunk_size | Tamaño del segmento, tal y como es establecido por ob_start()
size | ...
blocksize | ...

Ver también

  • ob_get_level() - Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida
  • ob_list_handlers() - Enumerar todos los gestores de salida en uso


Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip

  • « ob_get_status
  • ob_implicit_flush »
  • PHP Manual
  • Funciones del Control de la salida
  • Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip

ob_gzhandler

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ob_gzhandler — Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip

Descripción

ob_gzhandler ( string $buffer , int $mode ) : string

ob_gzhandler() tiene por objeto usarse como una función de llamada de retorno para ob_start() para facilitar en envío de datos codificados con gz a los navegadores web que admiten la compresión de páginas web. Antes de que ob_gzhandler() realmente envíe datos comprimidos, determina el tipo de codificación de contenido que aceptará el navegador ("gzip", "deflate" o ninguno) y devolverá su salida en consecuencia. Se admiten todos los navegadores, ya que es responsabilidad de los mismos enviar la cabecera correcta que indique que acepta páginas web comprimidas. Si un navegador no admite páginas comprimidas, esta función devolverá false.

Parámetros

buffer

mode

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de ob_gzhandler()

<?php

ob_start("ob_gzhandler");

?>
<html>
<body>
<p>Esta debería ser una página comprimida.</p>
</body>
</html>

Notas

Nota:

ob_gzhandler() requiere la extensión zlib.

Nota:

No se pueden usar juntos ob_gzhandler() y zlib.output_compression. Observe también que se prefiere el uso de zlib.output_compression antes que ob_gzhandler().

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Habilitar/deshabilitar el volcado implícito

  • « ob_gzhandler
  • ob_list_handlers »
  • PHP Manual
  • Funciones del Control de la salida
  • Habilitar/deshabilitar el volcado implícito

ob_implicit_flush

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_implicit_flush — Habilitar/deshabilitar el volcado implícito

Descripción

ob_implicit_flush ( int $flag = true ) : void

ob_implicit_flush() habilitará o deshabilitará el volcado implícito. El volcado implícito resultará en una operación de volcado después de cada llamada que produzca salida, de modo que no son necesarias las llamadas explícitas a flush().

Parámetros

flag

true para habilitar el volcado implícito, false para deshabilitarlo.

Valores devueltos

No devuelve ningún valor.

Ver también

  • flush() - Vaciar el búfer de salida del sistema
  • ob_start() - Activa el almacenamiento en búfer de la salida
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo


Enumerar todos los gestores de salida en uso

  • « ob_implicit_flush
  • ob_start »
  • PHP Manual
  • Funciones del Control de la salida
  • Enumerar todos los gestores de salida en uso

ob_list_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_list_handlers — Enumerar todos los gestores de salida en uso

Descripción

ob_list_handlers ( ) : array

Enumera todos los gestores de salida en uso.

Valores devueltos

Esta función devolverá un array con los gestores de salida en uso (si existen). Si output_buffering está habilitado o se usó una función anónima con ob_start(), ob_list_handlers() devolverá "default output handler" (gestor de salida predeterminado).

Ejemplos

Ejemplo #1 Ejemplo de ob_list_handlers()

<?php
//usando output_buffering=On
print_r(ob_list_handlers());
ob_end_flush();

ob_start("ob_gzhandler");
print_r(ob_list_handlers());
ob_end_flush();

// funciones anónimas
ob_start(function($string) { return $string; });
print_r(ob_list_handlers());
ob_end_flush();
?>

El resultado del ejemplo sería:

Array
(
    [0] => default output handler
)

Array
(
    [0] => ob_gzhandler
)

Array
(
    [0] => Closure::__invoke
)

Ver también

  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_get_flush() - Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida
  • ob_start() - Activa el almacenamiento en búfer de la salida


Activa el almacenamiento en búfer de la salida

  • « ob_list_handlers
  • output_add_rewrite_var »
  • PHP Manual
  • Funciones del Control de la salida
  • Activa el almacenamiento en búfer de la salida

ob_start

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_start — Activa el almacenamiento en búfer de la salida

Descripción

ob_start ( callable $output_callback = null , int $chunk_size = 0 , int $flags = PHP_OUTPUT_HANDLER_STDFLAGS ) : bool

Esta función activará el almacenamiento en búfer de la salida. Mientras dicho almacenamiento esté activo, no se enviará ninguna salida desde el script (aparte de cabeceras); en su lugar la salida se almacenará en un búfer interno.

El contenido de este búfer interno se puede copiar a una variable de tipo string usando ob_get_contents(). Para producir la salida de lo almacenado en el búfer interno se ha de usar ob_end_flush(). De forma alternativa, ob_end_clean() desechará de manera silenciosa el contenido del búfer.

Advertencia

Algunos servidores web (p.ej. Apache) cambian en directorio de trabajo de un script cuando se invoca a la función de llamada de retorno. Se puede cambiar de nuevo mediante, por ejemplo, chdir(dirname($_SERVER['SCRIPT_FILENAME'])) en la función de llamada de retorno.

Los búferes de salida son apilables, es decir, que se podría llamar a ob_start() mientras otro ob_start() esté activo. Se ha de asegurar llamar a ob_end_flush() las veces apropiadas. Si están activas múltiples funciones de llamada de retorno de salida, la salida se filtrará secuencialmente por cada una de ellas en orden de anidamiento.

Parámetros

output_callback

Se puede especificar una función output_callback opcional. Esta función toma un string como parámetro y debería devolver otro string. La función se llamará cuando el búfer de salida sea volcado (enviado), limpiado (con ob_flush(), ob_clean() o alguna función similar) o cuando el búfer de salida sea volcado al navegador al final de la petición. Cuando se llame a output_callback, ésta recibirá el contenido del búfer de salida como su propio parámetro, y se espera que devuelva un nuevo búfer de salida como resultado, que será enviado al navegador. Si output_callback no es una función llamable, esta función devolverá false. Esta es la firma de la llamada de retorno:

handler ( string $buffer , int $phase = ? ) : string
buffer
Contenido del búfer de salida.
phase
Máscara de bits de constantes PHP_OUTPUT_HANDLER_*.

Si output_callback devuelve false, se enviará la entrada original al navegador.

El parámetro output_callback se puede omitir pasando un valor null.

ob_end_clean(), ob_end_flush(), ob_clean(), ob_flush() y ob_start() no se pueden llamar desde una función de llamada de retorno. Si se hace, el comportamiento no estará definido. Si se quiere borrar el contenido de un búfer, se ha de devolver "" (un string nulo) desde la función de llamada de retorno. Tampoco se pueden llamar a funciones usando las funciones de búfer de salida como print_r($expresión, true) o highlight_file($nombre_fichero, true) desde una función de llamada de retorno.

Nota:

En PHP 4.0.4, ob_gzhandler() se introdujo para facilitar el envío de datos codificados con gz a los navegadores web que admitan páginas web comprimidas. ob_gzhandler() determima el tipo de codificación de contenido que aceptará el navegador y devolverá su salida en consecuencia.

chunk_size

Si se proporciona el parámetro opcional chunk_size, el búffer será volcado después de cualquier llamada de salida que cause que la longitud del búfer sea igual o exceda a chunk_size. El valor predeterminado 0 significa que la función de salida será llamada únicamente cuando el búfer de salida se cierre.

Antes de PHP 5.4.0, el valor 1 era un caso especial que establecía el tamaño de segmento a 4096 bytes.

flags

El parámetro flags es una máscara de bits que controla las operaciones que se pueden realizar sobre el búfer de salida. Lo predeterminado es permitir que los búferes de salida sean limpiados, volcados y borrados, lo que se puede hacer explícitamente mediante PHP_OUTPUT_HANDLER_CLEANABLE | PHP_OUTPUT_HANDLER_FLUSHABLE | PHP_OUTPUT_HANDLER_REMOVABLE, o PHP_OUTPUT_HANDLER_STDFLAGS como clave.

Cada bandera (flag) controla el acceso a un conjunto de funciones, como está descrito a continuación:

Constante | Funciones
PHP_OUTPUT_HANDLER_CLEANABLE | ob_clean(), ob_end_clean(), y ob_get_clean().
PHP_OUTPUT_HANDLER_FLUSHABLE | ob_end_flush(), ob_flush(), y ob_get_flush().
PHP_OUTPUT_HANDLER_REMOVABLE | ob_end_clean(), ob_end_flush(), y ob_get_flush().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.0.0 | En caso de utilizar ob_start() dentro de una retrollamada del búfer de salida, esta función ya no emitirá un E_ERROR, si no un E_RECOVERABLE_ERROR, permitiendo a los manejadores de errores propios capturar tales errores.
5.4.0 | El tercer parámetro de ob_start() se cambió de un parámetro boolean llamado erase (el cual, si se establecía a false, prevenía al búfer de salida de ser eliminado hasta el final de la ejecución del script) a un parámetro integer llamado flags. Desafortunadamente, esto resulta en una rotura de compatibilidad de la API para código escrito antes de PHP 5.4.0 que use el tercer parámetro. Véase el ejemplo de banderas para saber cómo manejar esto con código que necesite ser compatible con ambas.
5.4.0 | Un tamaño de segmento de 1 ahora resulta en segmentos de 1 byte que se van a enviar al búfer de salida.
4.3.2 | Se modficó esta función que devuelva false en caso de que la función output_callback pasada no pueda ejecutarse.

Ejemplos

Ejemplo #1 Ejemplo de una función de llamada de retorno definida por el usuario

<?php

function callback($búfer)
{
  // reemplazar todas las manzanas por naranjas
  return (str_replace("manzanas", "naranjas", $búfer));
}

ob_start("callback");

?>
<html>
<body>
<p>Es como comparar manzanas con naranjas.</p>
</body>
</html>
<?php

ob_end_flush();

?>

El resultado del ejemplo sería:

<html>
<body>
<p>Es como comparar naranjas con naranjas.</p>
</body>
</html>

Ejemplo #2 Crear un búfer de salida imborrable de forma compatible con PHP 5.3 y 5.4

<?php

if (version_compare(PHP_VERSION, '5.4.0', '>=')) {
  ob_start(null, 0, PHP_OUTPUT_HANDLER_STDFLAGS ^
    PHP_OUTPUT_HANDLER_REMOVABLE);
} else {
  ob_start(null, 0, false);
}

?>

Ver también

  • ob_get_contents() - Devolver el contenido del búfer de salida
  • ob_end_clean() - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_end_flush() - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
  • ob_implicit_flush() - Habilitar/deshabilitar el volcado implícito
  • ob_gzhandler() - Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip
  • ob_iconv_handler() - Convierte la codificación de caracteres al manejador del buffer de salida
  • mb_output_handler() - Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida
  • ob_tidyhandler() - Función callback de ob_start para reparar el buffer


Añadir valores al mecanismo de reescritura de URLs

  • « ob_start
  • output_reset_rewrite_vars »
  • PHP Manual
  • Funciones del Control de la salida
  • Añadir valores al mecanismo de reescritura de URLs

output_add_rewrite_var

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

output_add_rewrite_var — Añadir valores al mecanismo de reescritura de URLs

Descripción

output_add_rewrite_var ( string $name , string $value ) : bool

Esta función añade otro par nombre/valor al mecanismo de reescritura de URLs. El nombre y el valor se agregarán a los URLs (como parámetros de GET) y a los formularios (como camos intput ocultos) de la misma forma que el ID de sesión cuando la reescritura de URLs de forma transparente está habilitada con session.use_trans_sid. Observe que los URLs absolutos (http://example.com/..) no son reescritos.

El comportamiento de esta función está controlado por el parámetro url_rewriter.tags de php.ini.

Nota: Al llamar a esta función se iniciará el almacenamiento implícito en búfer de salida si no estaba ya activo.

Parámetros

name

El nombre de la variable.

value

El valor de la variable.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de output_add_rewrite_var()

<?php
output_add_rewrite_var('var', 'valor');

// algunos enlaces
echo '<a href="fichero.php">enlace</a>
<a href="http://example.com">enlace2</a>';

// un formulario
echo '<form action="script.php" method="post">
<input type="text" name="var2" />
</form>';

print_r(ob_list_handlers());
?>

El resultado del ejemplo sería:

<a href="fichero.php?var=valor">enlace</a>
<a href="http://example.com">enlace2</a>

<form action="script.php" method="post">
<input type="hidden" name="var" value="valor" />
<input type="text" name="var2" />
</form>

Array
(
    [0] => URL-Rewriter
)

Ver también

  • output_reset_rewrite_vars() - Restablecer los valores del mecanismo de reescritura de URLs
  • ob_flush() - Vaciar (enviar) el búfer de salida
  • ob_list_handlers() - Enumerar todos los gestores de salida en uso


Restablecer los valores del mecanismo de reescritura de URLs

  • « output_add_rewrite_var
  • Opciones/Info de PHP »
  • PHP Manual
  • Funciones del Control de la salida
  • Restablecer los valores del mecanismo de reescritura de URLs

output_reset_rewrite_vars

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

output_reset_rewrite_vars — Restablecer los valores del mecanismo de reescritura de URLs

Descripción

output_reset_rewrite_vars ( ) : bool

Esta función restablece el mecanismo de reescritura de URLs y elimina todas las variables de reescritura establecidas previamente por la función output_add_rewrite_var().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.1.0 | Antes de PHP 7.1.0, la variables reescritas por output_add_rewrite_var() utilizaban el mismo buffer de salida del módulo de sesión trans sid. Desde PHP 7.1.0, se usa un buffer de salida dedicado y output_reset_rewrite_vars() solo elimina las variables reescritas definidas por output_add_rewrite_var().

Ejemplos

Ejemplo #1 Ejemplo de output_reset_rewrite_vars()

<?php
session_start();
output_add_rewrite_var('var', 'value');

echo '<a href="file.php">link</a>';
ob_flush();

output_reset_rewrite_vars();
echo '<a href="file.php">link</a>';
?>

El resultado del ejemplo sería:

<a href="file.php?PHPSESSID=xxx&var=value">link</a>
<a href="file.php">link</a>

Ver también

  • output_add_rewrite_var() - Añadir valores al mecanismo de reescritura de URLs
  • ob_flush() - Vaciar (enviar) el búfer de salida
  • ob_list_handlers() - Enumerar todos los gestores de salida en uso
  • url_rewriter.tags
  • url_rewriter.hosts
  • session.trans_sid_tags
  • session.trans_sid_hosts


Opciones e Información de PHP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Opciones/Info de PHP
    • assert_options — Establecer/obtener valores de las directivas relacionadas con las aserciones
    • Aserción — Verifica si la aserción es false
    • cli_get_process_title — Returns the current process title
    • cli_set_process_title — Sets the process title
    • dl — Carga una extensión de PHP durante la ejecución
    • extension_loaded — Encontrar si una extensión está cargada
    • gc_collect_cycles — Fuerza la recolección de los ciclos de basura existentes
    • gc_disable — Desactiva el recolector de referencia circular
    • gc_enable — Activa el colector de referencia circular
    • gc_enabled — Devuelve el estado del colector de referencia circular
    • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
    • gc_status — Gets information about the garbage collector
    • get_cfg_var — Obtiene el valor de una opción de configuración de PHP
    • get_current_user — Obtiene el nombre del propietario del script PHP actual
    • get_defined_constants — Devuelve un array asociativo con los nombres de todas las constantes y sus valores
    • get_extension_funcs — Devuelve una matriz con los nombres de funciones de un módulo
    • get_include_path — Obtiene la opción de configuración include_path actual
    • get_included_files — Devuelve un array con los nombres de los archivos incluidos o requeridos
    • get_loaded_extensions — Devuelve un array con los nombres de todos los módulos compilados y cargados
    • get_magic_quotes_gpc — Obtiene el valor actual de configuración de magic_quotes_gpc
    • get_magic_quotes_runtime — Obtiene el valor de configuración activo actual de magic_quotes_runtime
    • get_required_files — Alias de get_included_files
    • get_resources — Returns active resources
    • getenv — Obtiene el valor de una variable de entorno
    • getlastmod — Obtiene la hora de la última modificación de la página
    • getmygid — Obtener el GID del dueño del script PHP
    • getmyinode — Obtiene el inode del script actual
    • getmypid — Obtiene el ID del proceso PHP
    • getmyuid — Obtiene el UID del dueño del script PHP
    • getopt — Obtiene las opciones de la lista de argumentos de la línea de comandos
    • getrusage — Obtiene el uso de los recursos actuales
    • ini_alter — Alias de ini_set
    • ini_get_all — Obtiene todas las opciones de configuración
    • ini_get — Devuelve el valor de una directiva de configuración
    • ini_restore — Restablece el valor de una opción de configuración
    • ini_set — Establece el valor de una directiva de configuración
    • main — Función main falsa
    • memory_get_peak_usage — Devuelve el máximo de memoria asignada por PHP
    • memory_get_usage — Devuelve la cantidad de memoria asignada a PHP
    • php_ini_loaded_file — Recupera la ruta de acceso al archivo php.ini cargado
    • php_ini_scanned_files — Devuelve una lista de ficheros .ini procesados del directorio adicional ini
    • php_sapi_name — Devuelve el tipo de interfaz que hay entre PHP y el servidor
    • php_uname — Devuelve información sobre el sistema operativo en que se está ejecutando PHP
    • phpcredits — Imprime los créditos de PHP
    • phpinfo — Muestra información sobre la configuración de PHP
    • phpversion — Obtiene la versión de PHP
    • putenv — Establece el valor de una variable de entorno
    • restore_include_path — Restablece el valor de la opción de configuración include_path
    • set_include_path — Establece la opción de configuración include_path
    • set_time_limit — Limita el tiempo máximo de ejecución
    • sys_get_temp_dir — Devuelve la ruta del directorio para archivos temporales
    • version_compare — Compara dos números de versiones estandarizados de PHP
    • zend_thread_id — Devuelve un identificador único del thread actual
    • zend_version — Obtiene la versión del motor Zend actual


Introducción

Estas funciones permiten obtener mucha información sobre PHP, p.ej., configuración en tiempo de ejecución, extensiones en uso, versión, y mucho más. También se pueden encontrar funciones para establecer opciones al ejecutar PHP. Aquí se puede encontrar la función probablemente más conocida de PHP - phpinfo() -.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de opciones/información de PHP
Nombre | Por defecto | Cambiable | Historial de cambios
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL | Disponible desde PHP 7.0.0.
enable_dl | "1" | PHP_INI_SYSTEM | Esta característica obsoleta será eliminada con certeza en el futuro.
max_execution_time | "30" | PHP_INI_ALL |
max_input_time | "-1" | PHP_INI_PERDIR | Disponible desde PHP 4.3.0.
max_input_nesting_level | "64" | PHP_INI_PERDIR | Disponible desde PHP 4.4.8. y PHP 5.2.3.
max_input_vars | 1000 | PHP_INI_PERDIR | Available since PHP 5.3.9.
magic_quotes_gpc | "1" | PHP_INI_PERDIR | PHP_INI_ALL en PHP <= 4.2.3. Eliminado en PHP 5.4.0
magic_quotes_runtime | "0" | PHP_INI_ALL | Eliminado en PHP 5.4.0
zend.enable_gc | "1" | PHP_INI_ALL | Disponible desde PHP 5.3.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

assert.active boolean

Activa la evaluación de aserciones().

assert.bail boolean

Terminar la ejecución del script si falla una aserción.

assert.warning boolean

Lanzar un PHP warning for cada aserción que falle.

assert.callback string

Función de usuario a llamar cuando fallen las aserciones.

assert.quiet_eval boolean

Usar la configuración actual de error_reporting() durante las expresiones de evaluación de aserciones. Si está habilitado, no se mostrarán errores (incondicional error_reporting(0)) durante evaluación. Si está deshabitado, se mostrarán errores según la configuración de error_reporting()

assert.exception boolean

Emite una excepción AssertionError para la afirmación fallida.

enable_dl boolean

Esta directiva es muy útil solamente en la versión PHP con el módulo Apache. Se puede activar o desactivar la carga dinámica de extensiones PHP con dl() por servidor virtual o directorio.

La razón principal para desactivar la carga dinámica es por seguridad. Con la carga dinámica, es posible ignorar todas las restricciones open_basedir. De forma predeterminada se permite la carga dinámica.

max_execution_time integer

Este valor establece el tiempo máximo en segundos que se permite ejecutar antes de que el analizador termine. Esto ayuda a prevenir que scripts mal escritos bloqueen el servidor. El valor por defecto es 30. Cuando se ejecuta PHP desde la línea de comandos el valor por defecto es 0.

El tiempo de ejecución máxima no está afectada por llamadas al sistema, operaciones de stream etc. Por favor véase la función set_time_limit() para más información.

El servidor web puede tener otras configuraciones de tiempo de espera que quizá interrumpan la ejecución de PHP. Apache tiene la directiva Timeout y IIS tiene la función CGI timeout. Las dos de 300 segundos por omisión. Véase la documentación del servidor web para información específica.

max_input_time integer

Establece el tiempo máximo en segundos que se permite a un script analizar datos de entrada, como POST y GET. La medición comienza en el momento en que PHP es invocado en el servidor y finaliza cuando la ejecución comienza.

max_input_nesting_level integer

Establece el máximo de profundidad de anidamiento para variables de entrada (p.ej. $_GET, $_POST.)

max_input_vars integer

Cuantas variables de entrada pueden ser aceptadas (el límite se aplica a los arrays superglobales $_GET, $_POST y $_COOKIE de forma separada). El uso de esta directiva mitiga la posibilidad de ataques de denegación de servicio que utilizan colisiones de hash. Si hay más variables de entrada que las especificadas por la presente directiva, un E_WARNING es emitido, y otras variables entrada son truncadas a partir de la solicitud.

magic_quotes_gpc boolean
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

Establece las magic_quotes state para operaciones GPC (Get/Post/Cookie). Cuando las magic_quotes están activadas, todas las ' (comillas simples), " (comillas dobles), \ (barra invertida) y NUL's son escapados con una barra invertida de forma automática..

Ver también get_magic_quotes_gpc()

magic_quotes_runtime boolean
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

Si magic_quotes_runtime está activado, la mayoría de funciones que devuelven datos desde cualquier tipo de recurso externo incluyendo bases de datos y ficheros de texto contendrán comillas escapadas con barras invertidas.

Funciones afectadas por magic_quotes_runtime (no incluye funciones de PECL):

  • get_meta_tags()
  • file_get_contents()
  • file()
  • fgets()
  • fwrite()
  • fread()
  • fputcsv()
  • stream_socket_recvfrom()
  • exec()
  • system()
  • passthru()
  • stream_get_contents()
  • bzread()
  • gzfile()
  • gzgets()
  • gzwrite()
  • gzread()
  • exif_read_data()
  • dba_insert()
  • dba_replace()
  • dba_fetch()
  • ibase_fetch_row()
  • ibase_fetch_assoc()
  • ibase_fetch_object()
  • mssql_fetch_row()
  • mssql_fetch_object()
  • mssql_fetch_array()
  • mssql_fetch_assoc()
  • mysqli_fetch_row()
  • mysqli_fetch_array()
  • mysqli_fetch_assoc()
  • mysqli_fetch_object()
  • pg_fetch_row()
  • pg_fetch_assoc()
  • pg_fetch_array()
  • pg_fetch_object()
  • pg_fetch_all()
  • pg_select()
  • sybase_fetch_object()
  • sybase_fetch_array()
  • sybase_fetch_assoc()
  • SplFileObject::fgets()
  • SplFileObject::fgetcsv()
  • SplFileObject::fwrite()

zend.enable_gc boolean

Habilita o deshabilita el colector de referencia circular.


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

Constantes predefinidas en phpcredits()
Constante | Valor | Descripción
CREDITS_GROUP | 1 | Lista de los desarrolladores del núcleo
CREDITS_GENERAL | 2 | Créditos generales: Diseño del lenguaje y concepto, autores de PHP y módulos SAPI.
CREDITS_SAPI | 4 | Lista de los módulos API para PHP y sus autores.
CREDITS_MODULES | 8 | Lista de los módulos de extensión para PHP y sus autores.
CREDITS_DOCS | 16 | Los créditos del equipo de documentación.
CREDITS_FULLPAGE | 32 | Normalmente se utiliza en combiación con otras opciones.Indica que una página HTML independiente debe ser mostrada incluyendo la información indicada por otras opciones.
CREDITS_QA | 64 | Los créditos del equipo de testers.
CREDITS_ALL | -1 | Todos los créditos, es equivalente a usar: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_QA CREDITS_FULLPAGE. Genera una página HTML independiente con las apropiadas etiquetas. Este es el valor por defecto.
Constantes de phpinfo()
Constante | Valor | Descripción
INFO_GENERAL | 1 | La línea de comandos de configuración, php.ini ruta, fecha del build, servidor Web, sistema y demás.
INFO_CREDITS | 2 | Créditos de PHP. Ver también phpcredits().
INFO_CONFIGURATION | 4 | Valores locales y maestros actuales para directivas PHP. Ver también ini_get().
INFO_MODULES | 8 | Módulos cargados y sus respectivas opciones.
INFO_ENVIRONMENT | 16 | Información de variables de entorno, también está disponible en $_ENV.
INFO_VARIABLES | 32 | Muestra todas las variables predefinidas desde EGPCS (Entorno, GET, POST, Cookie, Server).
INFO_LICENSE | 64 | Información de la licencia de PHP. Ver también » FAQ de la licencia.
INFO_ALL | -1 | Muestra todas las directivas que se han indicado hasta ahora. Este es el valor por defecto.
INI constants
Constante | Valor | Descripción
INI_USER | 1 | Sin uso
INI_PERDIR | 2 | Sin uso
INI_SYSTEM | 4 | Sin uso
INI_ALL | 7 | Sin uso

Constantes de aserción, estos valores se usan para definir opciones de aserción en assert_options().

Constantes assert()
Constante | Opción INI | Descripción
ASSERT_ACTIVE | assert.active | Habilita la evaluación de assert().
ASSERT_CALLBACK | assert.callback | Llamada de retorno a llamar en caso que falle la aserción.
ASSERT_BAIL | assert.bail | Terminar la ejecucción al finalizar aserciones.
ASSERT_WARNING | assert.warning | Genera un warning PHP por cada aserción que falle
ASSERT_QUIET_EVAL | assert.quiet_eval | Desactiva error_reporting durante la evaluación de expresiones de aserción.

Las siguientes constantes están disponibles únicamente si se está ejecutando el sistema operativo Windows y muestran información sobre las diferentes versiones. Esto hace posible el detectar determinadas características para poder hacer uso de ellas. Disponibles desde PHP 5.3.0.

Constantes específicas para Windows
Constante | Descripción
PHP_WINDOWS_VERSION_MAJOR | El número mayor de la versión de Windows, que puede tener el valor 4 (NT4/Me/98/95), 5 (XP/2003 R2/2003/2000) o 6 (Vista/2008/7/8/8.1).
PHP_WINDOWS_VERSION_MINOR | El número menor de la versión de Windows, que puede tener el valor 0 (Vista/2008/2000/NT4/95), 1 (XP), 2 (2003 R2/2003/XP x64), 10 (98) o 90 (ME).
PHP_WINDOWS_VERSION_BUILD | El número del build de Windows (por ejemplo, Windows Vista con SP1 sería el build número 6001)
PHP_WINDOWS_VERSION_PLATFORM | La plataforma en la que PHP se está ejecutando, su valor es 2 en Windows Vista/XP/2000/NT4, Server 2008/2003 y en Windows ME/98/95 su valor es 1.
PHP_WINDOWS_VERSION_SP_MAJOR | El número mayor de la versión del service pack instalado, su valor es 0 si no hay ningún service pack instalado. Por ejemplo, Windows XP con service pack 3 instalado hará que el valor sea 3.
PHP_WINDOWS_VERSION_SP_MINOR | El número menor de la versión del service pack instalado, su valor es 0 si no hay ningún service pack instalado.
PHP_WINDOWS_VERSION_SUITEMASK | El suitemask es una máscara de bits que puede indicar si determinadas características de Windows están instaladas, consulte la siguiente tabla para ver los diferentes valores del campo de bits.
PHP_WINDOWS_VERSION_PRODUCTTYPE | Contiene el valor usado para determinar las constantes PHP_WINDOWS_NT_*. Este valor puede ser una de las constantes PHP_WINDOWS_NT_* que indica el tipo de sistema que se está usando.
PHP_WINDOWS_NT_DOMAIN_CONTROLLER | El controlador de dominio
PHP_WINDOWS_NT_SERVER | El servidor del sistema (ej. Server 2008/2003/2000), observe que si es un controlador de dominio será informado como PHP_WINDOWS_NT_DOMAIN_CONTROLLER.
PHP_WINDOWS_NT_WORKSTATION | Es una estación de trabajo (pej. Vista/XP/2000/NT4)

Esta tabla muestra una lista de características que pueden ser comprobadas al usar la máscara de bits PHP_WINDOWS_VERSION_SUITEMASK.

Windows suitemask campos de bits
Bits | Descripción
0x00000004 | Los componentes de Microsoft BackOffice están instalados.
0x00000400 | Windows Server 2003, Web Edition está instalado.
0x00004000 | Windows Server 2003, Compute Cluster Edition está instalado.
0x00000080 | Windows Server 2008 Datacenter, Windows Server 2003, Datacenter Edition o Windows 2000 Datacenter Server está instalado.
0x00000002 | Windows Server 2008 Enterprise, Windows Server 2003, Enterprise Edition, Windows 2000 Advanced Server, o Windows NT Server 4.0 Enterprise Edition está instalado.
0x00000040 | Windows XP Embedded está instalado.
0x00000200 | Windows Vista Home Premium, Windows Vista Home Basic, o Windows XP Home Edition está instalado.
0x00000100 | Escritorio remoto habilitado, limitado a una sesión interactiva. Este valor está definido a no ser que el sistema se ejecute en modo de servidor de aplicaciones.
0x00000001 | Microsoft Small Business Server fue instalado en el sistema, pero quizá ha sido actualizado a otra versión de Windows.
0x00000020 | Microsoft Small Business Server está instalado con la restricción de licencia en vigor.
0x00002000 | Windows Storage Server 2003 R2 o Windows Storage Server 2003 está instalado.
0x00000010 | Terminal Services está instalado. Este valor siempre está definido. En caso que lo esté pero 0x00000100 no, entonces el sistema estará ejecutándose en modo de servidor de aplicaciones.
0x00008000 | Windows Home Server está instalado.


Funciones de Opciones/Info de PHP

Tabla de contenidos

  • assert_options — Establecer/obtener valores de las directivas relacionadas con las aserciones
  • Aserción — Verifica si la aserción es false
  • cli_get_process_title — Returns the current process title
  • cli_set_process_title — Sets the process title
  • dl — Carga una extensión de PHP durante la ejecución
  • extension_loaded — Encontrar si una extensión está cargada
  • gc_collect_cycles — Fuerza la recolección de los ciclos de basura existentes
  • gc_disable — Desactiva el recolector de referencia circular
  • gc_enable — Activa el colector de referencia circular
  • gc_enabled — Devuelve el estado del colector de referencia circular
  • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
  • gc_status — Gets information about the garbage collector
  • get_cfg_var — Obtiene el valor de una opción de configuración de PHP
  • get_current_user — Obtiene el nombre del propietario del script PHP actual
  • get_defined_constants — Devuelve un array asociativo con los nombres de todas las constantes y sus valores
  • get_extension_funcs — Devuelve una matriz con los nombres de funciones de un módulo
  • get_include_path — Obtiene la opción de configuración include_path actual
  • get_included_files — Devuelve un array con los nombres de los archivos incluidos o requeridos
  • get_loaded_extensions — Devuelve un array con los nombres de todos los módulos compilados y cargados
  • get_magic_quotes_gpc — Obtiene el valor actual de configuración de magic_quotes_gpc
  • get_magic_quotes_runtime — Obtiene el valor de configuración activo actual de magic_quotes_runtime
  • get_required_files — Alias de get_included_files
  • get_resources — Returns active resources
  • getenv — Obtiene el valor de una variable de entorno
  • getlastmod — Obtiene la hora de la última modificación de la página
  • getmygid — Obtener el GID del dueño del script PHP
  • getmyinode — Obtiene el inode del script actual
  • getmypid — Obtiene el ID del proceso PHP
  • getmyuid — Obtiene el UID del dueño del script PHP
  • getopt — Obtiene las opciones de la lista de argumentos de la línea de comandos
  • getrusage — Obtiene el uso de los recursos actuales
  • ini_alter — Alias de ini_set
  • ini_get_all — Obtiene todas las opciones de configuración
  • ini_get — Devuelve el valor de una directiva de configuración
  • ini_restore — Restablece el valor de una opción de configuración
  • ini_set — Establece el valor de una directiva de configuración
  • main — Función main falsa
  • memory_get_peak_usage — Devuelve el máximo de memoria asignada por PHP
  • memory_get_usage — Devuelve la cantidad de memoria asignada a PHP
  • php_ini_loaded_file — Recupera la ruta de acceso al archivo php.ini cargado
  • php_ini_scanned_files — Devuelve una lista de ficheros .ini procesados del directorio adicional ini
  • php_sapi_name — Devuelve el tipo de interfaz que hay entre PHP y el servidor
  • php_uname — Devuelve información sobre el sistema operativo en que se está ejecutando PHP
  • phpcredits — Imprime los créditos de PHP
  • phpinfo — Muestra información sobre la configuración de PHP
  • phpversion — Obtiene la versión de PHP
  • putenv — Establece el valor de una variable de entorno
  • restore_include_path — Restablece el valor de la opción de configuración include_path
  • set_include_path — Establece la opción de configuración include_path
  • set_time_limit — Limita el tiempo máximo de ejecución
  • sys_get_temp_dir — Devuelve la ruta del directorio para archivos temporales
  • version_compare — Compara dos números de versiones estandarizados de PHP
  • zend_thread_id — Devuelve un identificador único del thread actual
  • zend_version — Obtiene la versión del motor Zend actual


Establecer/obtener valores de las directivas relacionadas con las aserciones

  • « Funciones de Opciones/Info de PHP
  • Aserción »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Establecer/obtener valores de las directivas relacionadas con las aserciones

assert_options

(PHP 4, PHP 5, PHP 7, PHP 8)

assert_options — Establecer/obtener valores de las directivas relacionadas con las aserciones

Descripción

assert_options ( int $what , mixed $value = ? ) : mixed

Se utiliza para establecer el valor de las diferentes opciones de la función assert() o consultar su valor actual.

Parámetros

what

Assert Options
Opción | Configuración inicial | Valor predeterminado | Descripción
ASSERT_ACTIVE | assert.active | 1 | Activa la función assert()
ASSERT_WARNING | assert.warning | 1 | Cada vez que una aserción falla se genera una advertencia
ASSERT_BAIL | assert.bail | 0 | Termina la ejecución cuando falla una aserción
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | Desactiva la directiva error_reporting durante la evaluación de la aserción
ASSERT_CALLBACK | assert.callback | (null) | Función que se encargará de gestionar las aserciones cuando fallen

value

Nuevo valor para la directiva.

Valores devueltos

Devuelve el valor original de cualquiera de las opciones o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de assert_options()

<?php
// Esta es nuestra función manejadora
// de los fallos en un aserción
function assert_failure()
{
    echo 'Assert failed';
}

// Esta es nuestra función de test
function test_assert($parameter)
{
    assert(is_bool($parameter));
}

// Establecemos nuestras propias opciones para gestionar las aserciones
// Activamos las aserciones
assert_options(ASSERT_ACTIVE,   true);
// Si una aserción falla se detiene la ejecución
assert_options(ASSERT_BAIL,     true);
// Si una aserción falla NO se genera una advertencia
assert_options(ASSERT_WARNING,  false);
// Establecemos la función 'assert_failure' como manejadora (callback) de las aserciones
assert_options(ASSERT_CALLBACK, 'assert_failure');

// Creamos una aserción la cual queremos que falle
test_assert(1);

// Este código nunca se ejecuta porque ASSERT_BAIL
// está a TRUE
echo 'Never reached';
?>

Ver también

  • assert()


Verifica si la aserción es false

  • « assert_options
  • cli_get_process_title »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Verifica si la aserción es false

Aserción

(No hay información de versión disponible, podría estar únicamente en Git)

Aserción — Verifica si la aserción es false

Descripción

PHP 5 y 7

assert ( mixed $assertion , string $description = ? ) : bool

PHP 7

assert ( mixed $assertion , Throwable $exception = ? ) : bool

La función assert() revisará el parámetro assertion proporcionado y tomará la acción apropiada si su resultado es false.

Aserciones tradicionales (PHP 5 y 7)

Si el parámetro assertion es proporcionado como un string será evaluado como código PHP por la función assert(). Las ventajas de un parámetro assertion como string es que son menos sobrecargados cuando la comprobación de la aserción está deshabilitada y los mensajes que contienen la expresión assertion, la expresión falla. Esto significa que si pasa una condición de tipo boolean como assertion esta condición no se mostrará como parámetro a la función de aserción la cual tiene que haber definido con la función assert_options(), la condición es convertida a un string antes de llamar ese manejador de función, y el tipo boolean false es convertido como el string vacío.

Las aserciones deberían ser utilizadas solamente como una característica de depuración. Debería utilizarlas para las revisiones de buen funcionamiento las cuales comprueban las condiciones que siempre deberían ser true y que indican algunos errores de programación o si no, para revisar la presencia de algunas características, como funciones de extensión o ciertos límites del sistema y características.

Las aserciones no deberían utilizarse para operaciones normales en tiempo de ejecución como revisiones de parámetros de entrada. Como regla general su código siempre debería ser capaz de funcionar correctamente aún si la verificación de aserción no está activada.

El comportamiento de la función assert() podría ser configurado por la función assert_options() o por .ini-settings el cual está descrito en la página del manual de esas funciones.

La función assert_options() y/o la directiva de configuración ASSERT_CALLBACK permite que una función de llamada de retorno sea establecida para manejar aseciones fallidas.

Las llamadas de retorno assert() son particularmente útiles para construir conjuntos de pruebas automatizadas porque le permiten capturar fácilmente el código pasado a la aserción, junto con la información en donde fue hecha la aserción. Mientras que la información puede ser capturada a través de otros métodos, utilizar asernciones lo hace mucho más rápido y más fácil!

La función de llamada de retorno debería aceptar tres argumentos. El primero contendrá el fichero en que falló la aserción. El segundo contendrá la línea en la que falló la aserción y el tercer argumento contendrá la expresión que falló (si la hubiera — valores literales tales como 1 o "dos" no se pasarán a través de este argumento). Los usuarios de PHP 5.4.8 y versiones posteriores también podrían proveer un cuarto argumento opcional, que contendrá el parámetro description proporcionado a la función assert(), si fue establecido.

Expectativas (solamente PHP 7)

La función assert() es una construcción de lenguaje en PHP 7, que permite la definición de expectativas: las aserciones que surten efecto en ambientes de desarrollo y pruebas, pero que se optimizan para que tengan costo cero en la producción.

************* desde aqui *************** Mientras que assert_options() puede ser utilizada para controlar el comportamiento como se describe anteriormente por la compatibilidad con versiones anteriores, el código PHP 7 sólo debería usar las dos directivas nuevas de configuración para controlar el comportamiento de assert() y no llamar a assert_options().

*************** DESDE AQUI **************** PHP 7 configuration directives for assert()
Directive Default value Possible values
zend.assertions 1
  • 1: generate and execute code (development mode)
  • 0: generate code but jump around it at runtime
  • -1: do not generate code (production mode)
assert.exception 0
  • 1: throw when the assertion fails, either by throwing the object provided as the exception or by throwing a new AssertionError object if exception wasn't provided
  • 0: use or generate a Throwable as described above, but only generate a warning based on that object rather than throwing it (compatible with PHP 5 behaviour)

Parámetros

assertion

The assertion. In PHP 5, this must be either a string to be evaluated or a boolean to be tested. In PHP 7, this may also be any expression that returns a value, which will be executed and the result used to indicate whether the assertion succeeded or failed.

description

An optional description that will be included in the failure message if the assertion fails.

exception

In PHP 7, the second parameter can be a Throwable object instead of a descriptive string, in which case this is the object that will be thrown if the assertion fails and the assert.exception configuration directive is enabled.

Valores devueltos

false if the assertion is false, true otherwise.

Historial de cambios

Versión | Descripción
7.0.0 | assert() is now a language construct and not a function. assertion() can now be an expression. The second parameter is now interpreted either as an exception (if a Throwable object is given), or as the description supported from PHP 5.4.8 onwards.
5.4.8 | The description parameter was added. The description is also now provided to a callback function in ASSERT_CALLBACK mode as the fourth argument.

Ejemplos

Traditional assertions (PHP 5 and 7)

Ejemplo #1 Handle a failed assertion with a custom handler

<?php
// Active assert and make it quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

// Create a handler function
function my_assert_handler($file, $line, $code)
{
    echo "<hr>Assertion Failed:
        File '$file'<br />
        Line '$line'<br />
        Code '$code'<br /><hr />";
}

// Set up the callback
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('mysql_query("")');
?>

Ejemplo #2 Using a custom handler to print a description

<?php
// Active assert and make it quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

// Create a handler function
function my_assert_handler($file, $line, $code, $desc = null)
{
    echo "Assertion failed at $file:$line: $code";
    if ($desc) {
        echo ": $desc";
    }
    echo "\n";
}

// Set up the callback
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('2 < 1');
assert('2 < 1', 'Two is less than one');
?>

El resultado del ejemplo sería:

 Assertion failed at test.php:21: 2 < 1
 Assertion failed at test.php:22: 2 < 1: Two is less than one

Expectations (PHP 7 only)

Ejemplo #3 Expectations without a custom exception

<?php
assert(true == false);
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): assert(true == false) failed in - on line 2
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught AssertionError: assert(true == false) in -:2
Stack trace:
#0 -(2): assert(false, 'assert(true == ...')
#1 {main}
  thrown in - on line 2

Ejemplo #4 Expectations with a custom exception

<?php
class CustomError extends AssertionError {}

assert(true == false, new CustomError('True is not false!'));
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): CustomError: True is not false! in -:4
Stack trace:
#0 {main} failed in - on line 4
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught CustomError: True is not false! in -:4
Stack trace:
#0 {main}
  thrown in - on line 4

Ver también

  • assert_options() - Establecer/obtener valores de las directivas relacionadas con las aserciones


Returns the current process title

  • « Aserción
  • cli_set_process_title »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Returns the current process title

cli_get_process_title

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

cli_get_process_title — Returns the current process title

Descripción

cli_get_process_title ( ) : string|null

Returns the current process title, as set by cli_set_process_title(). Note that this may not exactly match what is shown in ps or top, depending on your operating system.

This function is available only in CLI mode.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return a string with the current process title or null on error.

Errores/Excepciones

An E_WARNING will be generated if the operating system is unsupported.

Ejemplos

Ejemplo #1 cli_get_process_title() example

<?php
echo "Process title: " . cli_get_process_title() . "\n";
?>

Ver también

  • cli_set_process_title() - Sets the process title


Sets the process title

  • « cli_get_process_title
  • dl »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Sets the process title

cli_set_process_title

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

cli_set_process_title — Sets the process title

Descripción

cli_set_process_title ( string $title ) : bool

Sets the process title visible in tools such as top and ps. This function is available only in CLI mode.

Parámetros

title

The new title.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

An E_WARNING will be generated if the operating system is unsupported.

Ejemplos

Ejemplo #1 cli_set_process_title() example

<?php
$title = "My Amazing PHP Script";
$pid = getmypid(); // you can use this to see your process title in ps

if (!cli_set_process_title($title)) {
    echo "Unable to set process title for PID $pid...\n";
    exit(1);
} else {
    echo "The process title '$title' for PID $pid has been set for your process!\n";
    sleep(5);
}
?>

Ver también

  • cli_get_process_title() - Returns the current process title
  • setproctitle() - Establecer el título de proceso


Carga una extensión de PHP durante la ejecución

  • « cli_set_process_title
  • extension_loaded »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Carga una extensión de PHP durante la ejecución

dl

(PHP 4, PHP 5, PHP 7, PHP 8)

dl — Carga una extensión de PHP durante la ejecución

Descripción

dl ( string $library ) : bool

Carga la extensión PHP dada por el parámetro library.

Utilice la función extension_loaded() para comprobar si la extensión ya está cargada o no. Funciona tanto para extensiones ya integradas en PHP o para extensiones que se han cargado dinámicamente (ya sea a través de php.ini o dl()).

Advertencia

Esta función ha sido eliminada de la mayoría de las SAPI en PHP 5.3.0, y de PHP-FPM en PHP 7.0.0.

Parámetros

library

Este parámetro es solamente el fichero de la extensión a cargar el cual depende del sistema operativo. Por ejemplo, la extensión sockets (si se compila como librería, no como parte de PHP) Se llamará sockets.so en sistemas Unix mientras que en Windows se llamará php_sockets.dll.

El directorio desde donde la extensión será cargada también depende del sistema operativo:

En Windows - a no ser que se defina explicitamente en php.ini, la extensión será cargada por defecto desde C:\php4\extensions\ (PHP4) o C:\php5\ en (PHP 5).

Unix - a no ser que se defina en php.ini, el directorio de extensiones por defecto depende de

  • Si PHP fué compilado con la opción --enable-debug o no
  • Si PHP fué comiplado con soporte (experimental) ZTS (Zend Thread Safety) o no
  • El módulo interno actual ZEND_MODULE_API_NO (Número interno del API Zend, que es básicamente la fecha en que se produjo un cambio de versión, p.ej. 20010901)
Teniendo esto en cuenta el directorio por defecto será <install-dir>/lib/php/extensions/ <debug-or-not>-<zts-or-not>-ZEND_MODULE_API_NO, p.ej. /usr/local/php/lib/php/extensions/debug-non-zts-20010901 o /usr/local/php/lib/php/extensions/no-debug-zts-20010901.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si la funcionalidad de cargar módulos no está disponible o ha sido deshabilitada (ya sea activando enable_dl off en php.ini) Se producirá un E_ERROR y se parará la ejecucción de PHP. Si dl() falló porque la librería especificacda no pudo cargarse a demás de false se producirá un mensaje E_WARNING.

Ejemplos

Ejemplo #1 Ejemplos de dl()

<?php
// En este ejemplo se carga una extensión u otra dependiendo del sistema operativo
if (!extension_loaded('sqlite')) {
    if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
        dl('php_sqlite.dll');
    } else {
        dl('sqlite.so');
    }
}

// O si la constante PHP_SHLIB_SUFFIX está disponible desde PHP 4.3.0
if (!extension_loaded('sqlite')) {
    $prefix = (PHP_SHLIB_SUFFIX === 'dll') ? 'php_' : '';
    dl($prefix . 'sqlite.' . PHP_SHLIB_SUFFIX);
}
?>

Historial de cambios

Versión | Descripción
7.0.0 | dl() está deshabilitado en PHP-FPM.
5.3.9 | dl() está deshabilitado en PHP-FPM, aunque se desaconseja.
5.3.0 | dl() está desactivado en algunos módulos SAPI por problemas de estabilidad. Los únicos modulos SAPI que permiten dl() son: CLI, CGI and Embed. En su lugar usar las directivas Directivas de carga de extensiones

Notas

Nota:

dl() no se soporta cuando PHP es compilado con soporte ZTS. Use en su lugar Directivas de carga de extensiones instead.

Nota:

dl() es sensible a mayúsculas en sistemas Unix.

Ver también

  • Directivas de cargas de extensiones
  • extension_loaded() - Encontrar si una extensión está cargada


Encontrar si una extensión está cargada

  • « dl
  • gc_collect_cycles »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Encontrar si una extensión está cargada

extension_loaded

(PHP 4, PHP 5, PHP 7, PHP 8)

extension_loaded — Encontrar si una extensión está cargada

Descripción

extension_loaded ( string $name ) : bool

Encuentra si la extensión está cargada.

Parámetros

name

El nombre de la extensión. Este parámetro considera el uso de mayúsculas/minúsculas.

Es posible ver los nombres de varias extensiones usando phpinfo(), o si usted usa la versión CGI o CLI de PHP, puede usar la bandera -m para listar todas las extensiones disponibles:

$ php -m
[PHP Modules]
xml
tokenizer
standard
sockets
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

Valores devueltos

Devuelve true si la extensión identificada por nombre está cargada, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de extension_loaded()

<?php
if (!extension_loaded('gd')) {
    if (!dl('gd.so')) {
        exit;
    }
}
?>

Ver también

  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • get_extension_funcs() - Devuelve una matriz con los nombres de funciones de un módulo
  • phpinfo() - Muestra información sobre la configuración de PHP
  • dl() - Carga una extensión de PHP durante la ejecución
  • function_exists() - Devuelve true si la función dada ha sido definida


Fuerza la recolección de los ciclos de basura existentes

  • « extension_loaded
  • gc_disable »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Fuerza la recolección de los ciclos de basura existentes

gc_collect_cycles

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_collect_cycles — Fuerza la recolección de los ciclos de basura existentes

Descripción

gc_collect_cycles ( ) : int

Recogida de las fuerzas de los ciclos de basura existentes.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de ciclos de recogida.

Ver también

  • Recolección de Basura


Desactiva el recolector de referencia circular

  • « gc_collect_cycles
  • gc_enable »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Desactiva el recolector de referencia circular

gc_disable

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_disable — Desactiva el recolector de referencia circular

Descripción

gc_disable ( ) : void

Desactiva el recolector de referencia circular. zend.enable_gc a 0.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Recolección de Basura


Activa el colector de referencia circular

  • « gc_disable
  • gc_enabled »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Activa el colector de referencia circular

gc_enable

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_enable — Activa el colector de referencia circular

Descripción

gc_enable ( ) : void

Activa el colector de referencia circular, estableciendo zend.enable_gc a 1.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Garbage Collection


Devuelve el estado del colector de referencia circular

  • « gc_enable
  • gc_mem_caches »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve el estado del colector de referencia circular

gc_enabled

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_enabled — Devuelve el estado del colector de referencia circular

Descripción

gc_enabled ( ) : bool

Devuelve el estado del colector de referencia circular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el recolector de basura está activado, false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de gc_enabled()

<?php
if(gc_enabled()) gc_collect_cycles();
?>

Ver también

  • Recolección de Basura


Reclaims memory used by the Zend Engine memory manager

  • « gc_enabled
  • gc_status »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Reclaims memory used by the Zend Engine memory manager

gc_mem_caches

(PHP 7, PHP 8)

gc_mem_caches — Reclaims memory used by the Zend Engine memory manager

Descripción

gc_mem_caches ( ) : int

Reclaims memory used by the Zend Engine memory manager.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of bytes freed.

Ver también

  • Garbage Collection


Gets information about the garbage collector

  • « gc_mem_caches
  • get_cfg_var »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Gets information about the garbage collector

gc_status

(PHP 7 >= 7.3.0, PHP 8)

gc_status — Gets information about the garbage collector

Descripción

gc_status ( ) : array

Gets information about the current state of the garbage collector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an associative array with the following elements:

  • "runs"
  • "collected"
  • "threshold"
  • "roots"

Ejemplos

Ejemplo #1 gc_status() Usage

<?php

// create object tree that needs gc collection
$a = new stdClass();
$a->b = [];
for ($i = 0; $i < 100000; $i++) {
    $b = new stdClass();
    $b->a = $a;
    $a->b[] = $b;
}
unset($a);
unset($b);
gc_collect_cycles();

var_dump(gc_status());

El resultado del ejemplo sería algo similar a:

array(4) {
  ["runs"]=>
  int(5)
  ["collected"]=>
  int(100002)
  ["threshold"]=>
  int(50001)
  ["roots"]=>
  int(0)
}

Ver también

  • Garbage Collection


Obtiene el valor de una opción de configuración de PHP

  • « gc_status
  • get_current_user »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el valor de una opción de configuración de PHP

get_cfg_var

(PHP 4, PHP 5, PHP 7, PHP 8)

get_cfg_var — Obtiene el valor de una opción de configuración de PHP

Descripción

get_cfg_var ( string $option ) : mixed

Obtiene el valor de una opción de configuración de PHP.

Esta función no retornará información de configuración establecida cuando PHP fue compilado, o lee un fichero de configuración de Apache.

Para comprobar si el sistema está usando un fichero de configuración, intente recuperar el valor de la opción de configuración cfg_file_path. Si está disponible, un fichero de configuración está siendo utilizado.

Parámetros

option

El nombre de la opción de configuración.

Valores devueltos

Devuelve el valor actual de la variable de configuración de PHP especificada por option, o false si se produce un error.

Historial de cambios

Versión | Descripción
5.3.0 | get_cfg_var() se fijó para ser capaz de retornar un "array" con las opciones ini.

Ver también

  • ini_get() - Devuelve el valor de una directiva de configuración
  • ini_get_all() - Obtiene todas las opciones de configuración


Obtiene el nombre del propietario del script PHP actual

  • « get_cfg_var
  • get_defined_constants »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el nombre del propietario del script PHP actual

get_current_user

(PHP 4, PHP 5, PHP 7, PHP 8)

get_current_user — Obtiene el nombre del propietario del script PHP actual

Descripción

get_current_user ( ) : string

Devuelve el nombre del propietario del script PHP actual.

Valores devueltos

Devuelve el nombre de usuario como un string.

Ejemplos

Ejemplo #1 get_current_user() ejemplo

<?php
echo 'Propietario script actual: ' . get_current_user();
?>

El resultado del ejemplo sería algo similar a:

Propietario script actual: SYSTEM

Ver también

  • getmyuid() - Obtiene el UID del dueño del script PHP
  • getmygid() - Obtener el GID del dueño del script PHP
  • getmypid() - Obtiene el ID del proceso PHP
  • getmyinode() - Obtiene el inode del script actual
  • getlastmod() - Obtiene la hora de la última modificación de la página


Devuelve un array asociativo con los nombres de todas las constantes y sus valores

  • « get_current_user
  • get_extension_funcs »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve un array asociativo con los nombres de todas las constantes y sus valores

get_defined_constants

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

get_defined_constants — Devuelve un array asociativo con los nombres de todas las constantes y sus valores

Descripción

get_defined_constants ( bool $categorize = false ) : array

Devuelve los nombres y valores de todas las constantes definidas actualmente. Esto incluye las creadas por las extensiones, así como las creadas con la función define().

Parámetros

categorize

Provoca que la función retorne un array multi-dimensional con categorias en las claves de la primera dimensión y constantes y sus valores en la segunda dimensión.

<?php
define("MI_CONSTANTE", 1);
print_r(get_defined_constants(true));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [Core] => Array
        (
            [E_ERROR] => 1
            [E_WARNING] => 2
            [E_PARSE] => 4
            [E_NOTICE] => 8
            [E_CORE_ERROR] => 16
            [E_CORE_WARNING] => 32
            [E_COMPILE_ERROR] => 64
            [E_COMPILE_WARNING] => 128
            [E_USER_ERROR] => 256
            [E_USER_WARNING] => 512
            [E_USER_NOTICE] => 1024
            [E_ALL] => 2047
            [TRUE] => 1
        )

    [pcre] => Array
        (
            [PREG_PATTERN_ORDER] => 1
            [PREG_SET_ORDER] => 2
            [PREG_OFFSET_CAPTURE] => 256
            [PREG_SPLIT_NO_EMPTY] => 1
            [PREG_SPLIT_DELIM_CAPTURE] => 2
            [PREG_SPLIT_OFFSET_CAPTURE] => 4
            [PREG_GREP_INVERT] => 1
        )

    [user] => Array
        (
            [MI_CONSTANTE] => 1
        )

)

Valores devueltos

Devuelve un array de arrays nombre_constante => valor_constante, opcionalmente agrupados por nombre de extensión registrando la constante.

Historial de cambios

Versión | Descripción
5.3.1 | Sólo para Windows: las constantes fundamentales se clasifican en Core, previamente mhash.
5.3.0 | Constantes fundamentales se clasifican en Core, antes internal. En Windows, las constantes fundamentales se clasifican en mhash.
5.2.11 | El parámetro categorize ahora funciona correctamente. Anteriormente, el parámetro categorize era interpretado como !is_null($categorize), por lo que cualquier valor distinto de null fuerza a las constantes a ser clasificadas.

Ejemplos

Ejemplo #1 Ejemplo de get_defined_constants()

<?php
print_r(get_defined_constants());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [E_ERROR] => 1
    [E_WARNING] => 2
    [E_PARSE] => 4
    [E_NOTICE] => 8
    [E_CORE_ERROR] => 16
    [E_CORE_WARNING] => 32
    [E_COMPILE_ERROR] => 64
    [E_COMPILE_WARNING] => 128
    [E_USER_ERROR] => 256
    [E_USER_WARNING] => 512
    [E_USER_NOTICE] => 1024
    [E_ALL] => 2047
    [TRUE] => 1
)

Ver también

  • defined() - Comprueba si existe una constante con nombre dada
  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • get_defined_functions() - Devuelve un array de todas las funciones definidas
  • get_defined_vars() - Devuelve una matriz con todas las variables definidas


Devuelve una matriz con los nombres de funciones de un módulo

  • « get_defined_constants
  • get_include_path »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve una matriz con los nombres de funciones de un módulo

get_extension_funcs

(PHP 4, PHP 5, PHP 7, PHP 8)

get_extension_funcs — Devuelve una matriz con los nombres de funciones de un módulo

Descripción

get_extension_funcs ( string $module_name ) : array

Esta función devuelve los nombres de todas las funciones definidas en el módulo indicado por nombre_modulo.

Parámetros

module_name

El nombre del módulo.

Nota:

Este parámetro debe estar en minúsculas.

Valores devueltos

Devuelve una matriz con todas las funciones, o false si nombre_modulo no es una extensión válida.

Ejemplos

Ejemplo #1 Imprime las funciones XML

<?php
print_r(get_extension_funcs("xml"));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => xml_parser_create
    [1] => xml_parser_create_ns
    [2] => xml_set_object
    [3] => xml_set_element_handler
    [4] => xml_set_character_data_handler
    [5] => xml_set_processing_instruction_handler
    [6] => xml_set_default_handler
    [7] => xml_set_unparsed_entity_decl_handler
    [8] => xml_set_notation_decl_handler
    [9] => xml_set_external_entity_ref_handler
    [10] => xml_set_start_namespace_decl_handler
    [11] => xml_set_end_namespace_decl_handler
    [12] => xml_parse
    [13] => xml_parse_into_struct
    [14] => xml_get_error_code
    [15] => xml_error_string
    [16] => xml_get_current_line_number
    [17] => xml_get_current_column_number
    [18] => xml_get_current_byte_index
    [19] => xml_parser_free
    [20] => xml_parser_set_option
    [21] => xml_parser_get_option
    [22] => utf8_encode
    [23] => utf8_decode
)

Ver también

  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • ReflectionExtension::getFunctions() - Obtiene las funciones de una extensión


Obtiene la opción de configuración include_path actual

  • « get_extension_funcs
  • get_included_files »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene la opción de configuración include_path actual

get_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

get_include_path — Obtiene la opción de configuración include_path actual

Descripción

get_include_path ( ) : string

Obtiene el valor actual de la opción de configuración include_path.

Valores devueltos

Devuelve la ruta, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de get_include_path()

<?php
echo get_include_path();

// O utilizando ini_get()
echo ini_get('include_path');
?>

Ver también

  • ini_get() - Devuelve el valor de una directiva de configuración
  • restore_include_path() - Restablece el valor de la opción de configuración include_path
  • set_include_path() - Establece la opción de configuración include_path
  • include - include


Devuelve un array con los nombres de los archivos incluidos o requeridos

  • « get_include_path
  • get_loaded_extensions »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve un array con los nombres de los archivos incluidos o requeridos

get_included_files

(PHP 4, PHP 5, PHP 7, PHP 8)

get_included_files — Devuelve un array con los nombres de los archivos incluidos o requeridos

Descripción

get_included_files ( ) : array

Obtiene los nombres de todos los archivos que han sido incluidos usando include, include_once, require o require_once.

Valores devueltos

Devuelve un array con los nombres de los archivos.

El script llamado originalmente es considerado un "archivo incluido", así que será listado junto con los archivos referenciados por la familia de funciones include.

Los archivos que son incluidos o requeridos múltiples veces solo aparecen una vez en el array devuelto.

Ejemplos

Ejemplo #1 Ejemplo de get_included_files()

<?php
// Este archivo es abc.php

include 'test1.php';
include_once 'test2.php';
require 'test3.php';
require_once 'test4.php';

$archivos_incluidos = get_included_files();

foreach ($archivos_incluidos as $nombre_archivo) {
    echo "$nombre_archivo\n";
}

?>

El resultado del ejemplo sería:

/path/to/abc.php
/path/to/test1.php
/path/to/test2.php
/path/to/test3.php
/path/to/test4.php

Ver también

  • include - include
  • include_once - include_once
  • require - require
  • require_once - require_once
  • get_required_files() - Alias de get_included_files


Devuelve un array con los nombres de todos los módulos compilados y cargados

  • « get_included_files
  • get_magic_quotes_gpc »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve un array con los nombres de todos los módulos compilados y cargados

get_loaded_extensions

(PHP 4, PHP 5, PHP 7, PHP 8)

get_loaded_extensions — Devuelve un array con los nombres de todos los módulos compilados y cargados

Descripción

get_loaded_extensions ( bool $zend_extensions = false ) : array

Esta función devuelve los nombres de todos los módulos compilados y cargados en el intérprete de PHP.

Parámetros

zend_extensions

Sólo retorna extensiones Zend, si no, las extensiones regulares, como mysqli. El valor predeterminado es false (retorna extensiones regulares).

Valores devueltos

Devuelve un array indexado de todos los nombres de los módulos.

Historial de cambios

Versión | Descripción
5.2.4 | Fue añadido el parámetro opcional zend_extensions

Ejemplos

Ejemplo #1 get_loaded_extensions()

<?php
print_r(get_loaded_extensions());
?>

El resultado del ejemplo sería algo similar a:

Array
(
   [0] => xml
   [1] => wddx
   [2] => standard
   [3] => session
   [4] => posix
   [5] => pgsql
   [6] => pcre
   [7] => gd
   [8] => ftp
   [9] => db
   [10] => calendar
   [11] => bcmath
)

Ver también

  • get_extension_funcs() - Devuelve una matriz con los nombres de funciones de un módulo
  • extension_loaded() - Encontrar si una extensión está cargada
  • dl() - Carga una extensión de PHP durante la ejecución
  • phpinfo() - Muestra información sobre la configuración de PHP


Obtiene el valor actual de configuración de magic_quotes_gpc

  • « get_loaded_extensions
  • get_magic_quotes_runtime »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el valor actual de configuración de magic_quotes_gpc

get_magic_quotes_gpc

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_gpc — Obtiene el valor actual de configuración de magic_quotes_gpc

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.4.0, y es ELIMINADA desde PHP 8.0.0. Su uso está totalmente desaconsejado.

Descripción

get_magic_quotes_gpc ( ) : bool

Siempre retorna false.

Valores devueltos

Siempre retorna false.

Historial de cambios

Versión | Descripción
7.4.0 | Esta función ha quedado en desuso.

Ver también

  • addslashes() - Escapa un string con barras invertidas
  • stripslashes() - Quita las barras de un string con comillas escapadas
  • get_magic_quotes_runtime() - Obtiene el valor de configuración activo actual de magic_quotes_runtime
  • ini_get() - Devuelve el valor de una directiva de configuración


Obtiene el valor de configuración activo actual de magic_quotes_runtime

  • « get_magic_quotes_gpc
  • get_required_files »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el valor de configuración activo actual de magic_quotes_runtime

get_magic_quotes_runtime

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_runtime — Obtiene el valor de configuración activo actual de magic_quotes_runtime

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.4.0. Su uso está totalmente desaconsejado

Descripción

get_magic_quotes_runtime ( ) : bool

Devuelve el valor de configuración activo actual de magic_quotes_runtime.

Valores devueltos

Devuelve 0 si magic_quotes_runtime está off, 1 en caso contrario. O siempre devuelve false a partir de PHP 5.4.0.

Historial de cambios

Versión | Descripción
7.4.0 | Esta función es obsoleta.
5.4.0 | Siempre devuelve false debido a que la característica de comillas mágicas ha sido eliminada de PHP.

Ejemplos

Ejemplo #1 get_magic_quotes_runtime() ejemplo

<?php
// Comprueba si magic_quotes_runtime está activado
if(get_magic_quotes_runtime())
{
    // Desactivar
    set_magic_quotes_runtime(false);
}
?>

Ver también

  • get_magic_quotes_gpc() - Obtiene el valor actual de configuración de magic_quotes_gpc
  • set_magic_quotes_runtime()


Alias de get_included_files

  • « get_magic_quotes_runtime
  • get_resources »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Alias de get_included_files

get_required_files

(PHP 4, PHP 5, PHP 7, PHP 8)

get_required_files — Alias de get_included_files()

Descripción

Esta función es un alias de: get_included_files().


Returns active resources

  • « get_required_files
  • getenv »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Returns active resources

get_resources

(PHP 7, PHP 8)

get_resources — Returns active resources

Descripción

get_resources ( string $type = ? ) : array

Returns an array of all currently active resources, optionally filtered by resource type.

Parámetros

type

If defined, this will cause get_resources() to only return resources of the given type. A list of resource types is available.

If the string Unknown is provided as the type, then only resources that are of an unknown type will be returned.

If omitted, all resources will be returned.

Valores devueltos

Returns an array of currently active resources, indexed by resource number.

Ejemplos

Ejemplo #1 Unfiltered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources());
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [1]=>
  resource(1) of type (stream)
}

Ejemplo #2 Filtered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources('stream'));
var_dump(get_resources('curl'));
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [1]=>
  resource(1) of type (stream)
}
array(0) {
}

Ver también

  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • get_defined_constants() - Devuelve un array asociativo con los nombres de todas las constantes y sus valores
  • get_defined_functions() - Devuelve un array de todas las funciones definidas
  • get_defined_vars() - Devuelve una matriz con todas las variables definidas


Obtiene el valor de una variable de entorno

  • « get_resources
  • getlastmod »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el valor de una variable de entorno

getenv

(PHP 4, PHP 5, PHP 7, PHP 8)

getenv — Obtiene el valor de una variable de entorno

Descripción

getenv ( string $varname ) : string

Obtiene el valor de una variable de entorno.

Se puede ver una lista de todas las variables de entorno usando phpinfo(). Muchas de estas variables están listadas bajo la especificación » RFC 3875, específicamente la sección 4.1, "Request Meta-Variables".

Parámetros

varname

El nombre de variable.

Valores devueltos

Devuelve el valor de la variable de entorno varname, o false si la variable entorno varname no existe.

Ejemplos

Ejemplo #1 Ejemplo de getenv()

<?php
// Ejemplo de uso de getenv()
$ip = getenv('REMOTE_ADDR');

// O simplemente use una Superglobal ($_SERVER o $_ENV)
$ip = $_SERVER['REMOTE_ADDR'];
?>

Ver también

  • putenv() - Establece el valor de una variable de entorno
  • apache_getenv() - Obtiene una variable del entorno subprocess_env de Apache
  • Superglobales


Obtiene la hora de la última modificación de la página

  • « getenv
  • getmygid »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene la hora de la última modificación de la página

getlastmod

(PHP 4, PHP 5, PHP 7, PHP 8)

getlastmod — Obtiene la hora de la última modificación de la página

Descripción

getlastmod ( ) : int

Obtiene la hora de la última modificación del script principal de la ejecución.

Si está interesado en obtener la hora de la última modificación de un archivo diferente, considere el uso de filemtime().

Valores devueltos

Devuelve la hora de la última modificación de la página actual. El valor devuelto es una marca de tiempo Unix, apropiada para ser pasada a date(). Devuelve false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de getlastmod()

<?php
// imprime p.ej. 'Ultima modificación: March 04 1998 20:43:59.'
echo "Ultima modificación: " . date ("F d Y H:i:s.", getlastmod());
?>

Ver también

  • date() - Dar formato a la fecha/hora local
  • getmyuid() - Obtiene el UID del dueño del script PHP
  • getmygid() - Obtener el GID del dueño del script PHP
  • get_current_user() - Obtiene el nombre del propietario del script PHP actual
  • getmyinode() - Obtiene el inode del script actual
  • getmypid() - Obtiene el ID del proceso PHP
  • filemtime() - Obtiene el momento de la última modificación de un archivo


Obtener el GID del dueño del script PHP

  • « getlastmod
  • getmyinode »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtener el GID del dueño del script PHP

getmygid

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

getmygid — Obtener el GID del dueño del script PHP

Descripción

getmygid ( ) : int

Obtiene el ID de grupo del script actual.

Valores devueltos

Devuelve el ID de grupo del script actual, o false en caso de error.

Ver también

  • getmyuid() - Obtiene el UID del dueño del script PHP
  • getmypid() - Obtiene el ID del proceso PHP
  • get_current_user() - Obtiene el nombre del propietario del script PHP actual
  • getmyinode() - Obtiene el inode del script actual
  • getlastmod() - Obtiene la hora de la última modificación de la página


Obtiene el inode del script actual

  • « getmygid
  • getmypid »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el inode del script actual

getmyinode

(PHP 4, PHP 5, PHP 7, PHP 8)

getmyinode — Obtiene el inode del script actual

Descripción

getmyinode ( ) : int

Obtiene el inode del script actual.

Valores devueltos

Devuelve el inodo del script actual como un entero, o false en caso de error.

Ver también

  • getmygid() - Obtener el GID del dueño del script PHP
  • getmyuid() - Obtiene el UID del dueño del script PHP
  • getmypid() - Obtiene el ID del proceso PHP
  • get_current_user() - Obtiene el nombre del propietario del script PHP actual
  • getlastmod() - Obtiene la hora de la última modificación de la página


Obtiene el ID del proceso PHP

  • « getmyinode
  • getmyuid »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el ID del proceso PHP

getmypid

(PHP 4, PHP 5, PHP 7, PHP 8)

getmypid — Obtiene el ID del proceso PHP

Descripción

getmypid ( ) : int

Obtiene el ID del proceso PHP actual.

Valores devueltos

Devuelve el ID del proceso PHP actual, o false si ocurre un error.

Notas

Advertencia

Los IDs de proceso no son únicos, por lo tanto son una fuente débil de entropía. Es recomendable no depender en ids de proceso en contextos sujetos a consideraciones de seguridad.

Ver también

  • getmygid() - Obtener el GID del dueño del script PHP
  • getmyuid() - Obtiene el UID del dueño del script PHP
  • get_current_user() - Obtiene el nombre del propietario del script PHP actual
  • getmyinode() - Obtiene el inode del script actual
  • getlastmod() - Obtiene la hora de la última modificación de la página


Obtiene el UID del dueño del script PHP

  • « getmypid
  • getopt »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el UID del dueño del script PHP

getmyuid

(PHP 4, PHP 5, PHP 7, PHP 8)

getmyuid — Obtiene el UID del dueño del script PHP

Descripción

getmyuid ( ) : int

Obtiene el ID de usuario para el script actual.

Valores devueltos

Devuelve el ID de usuario del script actual, o false en caso de error.

Ver también

  • getmygid() - Obtener el GID del dueño del script PHP
  • getmypid() - Obtiene el ID del proceso PHP
  • get_current_user() - Obtiene el nombre del propietario del script PHP actual
  • getmyinode() - Obtiene el inode del script actual
  • getlastmod() - Obtiene la hora de la última modificación de la página


Obtiene las opciones de la lista de argumentos de la línea de comandos

  • « getmyuid
  • getrusage »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene las opciones de la lista de argumentos de la línea de comandos

getopt

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

getopt — Obtiene las opciones de la lista de argumentos de la línea de comandos

Descripción

getopt ( string $options , array $longopts = ? ) : array

Analiza las opciones pasadas al script.

Parámetros

options
Cada carácter de esta cadena de texto se usará como un carácter de opción y se comparará con aquellas opciones pasadas al script que comiencen con un guión simple (-). Por ejemplo, el string de opciones "x" reconocerá la opción -x. Sólo se permiten a-z, A-Z y 0-9.
longopts
Matriz de opciones. Cada elemento de este array se usará como texto de opciones y se compararán con aquellas opciones pasadas al script que comiencen con dos guiones (--). Por ejemplo, longopts tuviera un elemento con "opt", reconocería la opción --opt.

El parámetro options puede contener los siguientes elementos:

  • Caracteres individuales (no acepta valores)
  • Caracteres seguidos por dos puntos (el parámetro exige un valor)
  • Caracteres seguidos dos veces por dos puntos (valor opcional)
Los valores de opción serán el primer argumento tras el string. Si se requiere un valor, no importa si este tiene espacios en blanco delante o no. Véase la nota.

Nota: Los valores opcionales no aceptan un " " (espacio) como separador.

Nota:

El formato de options y de longopts es casi igual. La única diferencia es que longopts contiene un array de opciones (donde cada elemento es la opción) mientras que options contiene un string (donde cada carácter es la opción).

Valores devueltos

Esta función devolverá un array de parejas opciones / argumentos, o false en caso de error.

Nota:

El análisis de opciones finalizará cuando se encuentre alguna no-opción. Todo lo que haya a continuación será descartado.

Historial de cambios

Versión | Descripción
5.3.0 | Añadido soporte para usar "=" como separador de argumento/valor.
5.3.0 | Añadido soporte para valores opcionales (especificado mediante "::").
5.3.0 | El parámetro longopts está disponible en todos los sistemas.
5.3.0 | Esta función ya no depende del sistema y funciona también en Windows.

Ejemplos

Ejemplo #1 Ejemplo de getopt(): Lo básico

<?php
// Script example.php
$options = getopt("f:hp:");
var_dump($options);
?>
shell> php example.php -fvalue -h

El resultado del ejemplo sería:

array(2) {
  ["f"]=>
  string(5) "value"
  ["h"]=>
  bool(false)
}

Ejemplo #2 Ejemplo de getopt(): Introducir opciones long

<?php
// Script example.php
$shortopts  = "";
$shortopts .= "f:";  // Valor obligatorio
$shortopts .= "v::"; // Valor opcional
$shortopts .= "abc"; // Estas opciones no aceptan valores

$longopts  = array(
    "required:",     // Valor obligatorio
    "optional::",    // Valor opcional
    "option",        // Sin valores
    "opt",           // Sin valores
);
$options = getopt($shortopts, $longopts);
var_dump($options);
?>
shell> php example.php -f "value for f" -v -a --required value --optional="optional value" --option

El resultado del ejemplo sería:

array(6) {
  ["f"]=>
  string(11) "value for f"
  ["v"]=>
  bool(false)
  ["a"]=>
  bool(false)
  ["required"]=>
  string(5) "value"
  ["optional"]=>
  string(14) "optional value"
  ["option"]=>
  bool(false)
}

Ejemplo #3 Ejemplo de getopt(): Pasar varias opciones como una

<?php
// Script example.php
$options = getopt("abc");
var_dump($options);
?>
shell> php example.php -aaac

El resultado del ejemplo sería:

array(2) {
  ["a"]=>
  array(3) {
    [0]=>
    bool(false)
    [1]=>
    bool(false)
    [2]=>
    bool(false)
  }
  ["c"]=>
  bool(false)
}

Ver también

  • $argv


Obtiene el uso de los recursos actuales

  • « getopt
  • ini_alter »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene el uso de los recursos actuales

getrusage

(PHP 4, PHP 5, PHP 7, PHP 8)

getrusage — Obtiene el uso de los recursos actuales

Descripción

getrusage ( int $who = 0 ) : array

Esta es una interfaz de getrusage(2). Obtiene datos devueltos de la llamada al sistema.

Parámetros

who

Si el parámetro who es 1, getrusage será llamado con RUSAGE_CHILDREN.

Valores devueltos

Devuelve un array asociativo que contiene los datos devueltos por la llamada al sistema. Todas las entradas son accesibles mediante el uso de sus nombres de campo documentado.

Ejemplos

Ejemplo #1 getrusage() ejemplo

<?php
$dat = getrusage();
echo $dat["ru_oublock"];       // número de operaciones de salida en bloque
echo $dat["ru_inblock"];       // número de operaciones de entrada de bloques
echo $dat["ru_msgsnd"];        // número de mensajes de IPC enviados
echo $dat["ru_msgrcv"];        // número de mensajes de IPC recibidos
echo $dat["ru_maxrss"];        // tamaño máximo de los conjuntos de residentes
echo $dat["ru_ixrss"];         // tamaño de memoria integral compartida
echo $dat["ru_idrss"];         // tamaño integral de los datos no compartidos
echo $dat["ru_minflt"];        // número de reivindicaciones de página (fallos suaves de página)
echo $dat["ru_majflt"];        // número de fallos de página (fallos duros de página)
echo $dat["ru_nsignals"];      // número de señales recibidas
echo $dat["ru_nvcsw"];         // número de cambios de contexto voluntarios
echo $dat["ru_nivcsw"];        // número de cambios de contexto involuntarios
echo $dat["ru_nswap"];         // número de intercambios
echo $dat["ru_utime.tv_usec"]; // tiempo de usuario utilizado (microsegundos)
echo $dat["ru_utime.tv_sec"];  // tiempo de usuario utilizado (segundos)
echo $dat["ru_stime.tv_usec"]; // tiempo del sistema utilizado (microsegundos)
?>

Historial de cambios

Versión | Descripción
7.0.0 | Esta función ahora está soportada en Windows

Notas

Nota:

En Windows, getrusage() solamente devolverá los siguientes miembros:

  • "ru_stime.tv_sec"
  • "ru_stime.tv_usec"
  • "ru_utime.tv_sec"
  • "ru_utime.tv_usec"
  • "ru_majflt" (solo si who es RUSAGE_SELF)
  • "ru_maxrss" (solo si who es RUSAGE_SELF)

Si a getrusage() se le llama con who establecido a 1 (RUSAGE_CHILDREN), se recopilan los usos de recursos para los hilos (lo que significa que la función es llamada internamente con RUSAGE_THREAD).

Nota:

En BeOS 2000, solamente se devuelven los siguientes miembros:

  • "ru_stime.tv_sec"
  • "ru_stime.tv_usec"
  • "ru_utime.tv_sec"
  • "ru_utime.tv_usec"

Ver también

  • Página principal de sistema sobre getrusage(2)


Alias de ini_set

  • « getrusage
  • ini_get_all »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Alias de ini_set

ini_alter

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_alter — Alias de ini_set()

Descripción

Esta función es un alias de: ini_set().


Obtiene todas las opciones de configuración

  • « ini_alter
  • ini_get »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene todas las opciones de configuración

ini_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ini_get_all — Obtiene todas las opciones de configuración

Descripción

ini_get_all ( string $extension = ? , bool $details = true ) : array

Devuelve todas las opciones de configuración registradas.

Parámetros

extension

Un nombre de extensión opcional. Si se establece, la función de retornará únicamente opciones específicas para esa extensión.

details

Recupera los detalles de configuración o sólo el valor actual de cada configuración. Por omisión es true (recuperar detalles).

Valores devueltos

Devuelve un array asociativo con el nombre de la directiva como la clave del array.

Cuando el parámetro details es true (por omisión) el array contendrá global_value (establecido en php.ini), local_value (tal vez establecido con ini_set() o .htaccess), y access (el nivel de acceso).

Cuando el parámetro details es false el valor será el valor actual de la opción.

Vea la sección del manual para obtener información sobre lo que significan los niveles de acceso.

Nota:

Es posible que una directiva tenga múltiples niveles de acceso, por lo que el access muestra los valores de máscara de bits adecuado.

Notas

Nota:

ini_get_all() ignora las opciones ini de "array" como pdo.dsn.*.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió details.

Ejemplos

Ejemplo #1 ini_get_all() ejemplos

<?php
print_r(ini_get_all("pcre"));
print_r(ini_get_all());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [pcre.backtrack_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

    [pcre.recursion_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

)
Array
(
    [allow_call_time_pass_reference] => Array
        (
            [global_value] => 0
            [local_value] => 0
            [access] => 6
        )

    [allow_url_fopen] => Array
        (
            [global_value] => 1
            [local_value] => 1
            [access] => 4
        )

    ...

)

Ejemplo #2 Disabling details

<?php
print_r(ini_get_all("pcre", false)); // Se añadió en PHP 5.3.0
print_r(ini_get_all(null, false)); // Se añadió en PHP 5.3.0
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [pcre.backtrack_limit] => 100000
    [pcre.recursion_limit] => 100000
)
Array
(
    [allow_call_time_pass_reference] => 0
    [allow_url_fopen] => 1
    ...
)

Ver también

  • Cómo cambiar los ajustes de configuración
  • ini_get() - Devuelve el valor de una directiva de configuración
  • ini_restore() - Restablece el valor de una opción de configuración
  • ini_set() - Establece el valor de una directiva de configuración
  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • phpinfo() - Muestra información sobre la configuración de PHP
  • ReflectionExtension::getINIEntries() - Obtiene las entradas INI de la extensión


Devuelve el valor de una directiva de configuración

  • « ini_get_all
  • ini_restore »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve el valor de una directiva de configuración

ini_get

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_get — Devuelve el valor de una directiva de configuración

Descripción

ini_get ( string $varname ) : string

En caso de éxito devuelve el valor de una directiva de configuración.

Parámetros

varname

Nombre de la directiva de configuración.

Valores devueltos

Devuelve el valor de la opción de configuración como cadena en caso de éxito, o una cadena vacía para valores null. Devuelve false si la opción de configuración no existe.

Ejemplos

Ejemplo #1 Unos cuantos ejemplos de la función ini_get()

<?php
/*
Dentro del php.ini tenemos las siguientes directivas junto con sus valores iniciales:

display_errors = On
register_globals = Off
post_max_size = 8M
*/

echo 'display_errors = ' . ini_get('display_errors') . "\n";
echo 'register_globals = ' . ini_get('register_globals') . "\n";
echo 'post_max_size = ' . ini_get('post_max_size') . "\n";
echo 'post_max_size+1 = ' . (ini_get('post_max_size')+1) . "\n";
echo 'post_max_size in bytes = ' . return_bytes(ini_get('post_max_size'));

function return_bytes($val) {
    $val = trim($val);
    $last = strtolower($val[strlen($val)-1]);
    switch($last) {
        // El modificador 'G' está disponble desde PHP 5.1.0
        case 'g':
            $val *= 1024;
        case 'm':
            $val *= 1024;
        case 'k':
            $val *= 1024;
    }

    return $val;
}

?>

El resultado del ejemplo sería algo similar a:

display_errors = 1
register_globals = 0
post_max_size = 8M
post_max_size+1 = 9
post_max_size in bytes = 8388608

Notas

Nota: Cuando se consultan valores booleanos

El valor booleano off será devuelto como una cadena vacía o "0", mientras que el valor booleano on será devuelto será devuelto como "1". Esta función también puede devolver valores iniciales como cadenas.

Nota: Cuando se consultan valores de tamaños de memoria

Muchos valores iniciales de tamaños de memoria, tales como upload_max_filesize, están almacenados en el fichero php.ini en notación abreviada. ini_get() devolverá la cadena exacta almacenada en el fichero php.ini y NO su valor de tipo integer equivalente. Utilizar estos valores en funciones aritméticas puede provocar resultados inesperados. El ejemplo anterior muestra una manera de convertir la notación abreviada a bytes, muy similar a cómo lo hace el código fuente de PHP.

Nota:

ini_get() no puede leer las opciones ini "array" como pdo.dsn.*, devolviendo false en este caso.

Historial de cambios

Versión | Descripción
5.3.0 | Anteriormente, se devolvía un string si la opción de configuración no existía. Ahora en su lugar se devuelve false.

Ver también

  • get_cfg_var() - Obtiene el valor de una opción de configuración de PHP
  • ini_get_all() - Obtiene todas las opciones de configuración
  • ini_restore() - Restablece el valor de una opción de configuración
  • ini_set() - Establece el valor de una directiva de configuración


Restablece el valor de una opción de configuración

  • « ini_get
  • ini_set »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Restablece el valor de una opción de configuración

ini_restore

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_restore — Restablece el valor de una opción de configuración

Descripción

ini_restore ( string $varname ) : void

Restaura una opción de configuración dado su valor original.

Parámetros

varname

El nombre de la opción de configuración.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ini_restore() ejemplo

<?php
$setting = 'y2k_compliance';

echo 'Valor actual \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;

ini_set($setting, ini_get($setting) ? 0 : 1);
echo 'Nuevo valor \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;

ini_restore($setting);
echo 'Valor original \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;
?>

El resultado del ejemplo sería:

Valor actual 'y2k_compliance': 1
Nuevo valor 'y2k_compliance': 0
Valor original 'y2k_compliance': 1

Ver también

  • ini_get() - Devuelve el valor de una directiva de configuración
  • ini_get_all() - Obtiene todas las opciones de configuración
  • ini_set() - Establece el valor de una directiva de configuración


Establece el valor de una directiva de configuración

  • « ini_restore
  • main »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Establece el valor de una directiva de configuración

ini_set

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_set — Establece el valor de una directiva de configuración

Descripción

ini_set ( string $varname , string $newvalue ) : string

Establece el valor de la directiva de configuración dada. La opción de configuración mantendrá este nuevo valor durante la ejecución del script, y se restaurará cuando acabe el mismo.

Parámetros

varname

No todas las directivas pueden ser modificadas con ini_set(). Hay una lista con todas las directivas disponibles en el apéndice.

newvalue

El nuevo valor para la opción.

Valores devueltos

Devuelve el valor anterior en caso de éxito, false en caso de error.

Ejemplos

Ejemplo #1 Establece una opción ini

<?php
echo ini_get('display_errors');

if (!ini_get('display_errors')) {
    ini_set('display_errors', '1');
}

echo ini_get('display_errors');
?>

Ver también

  • get_cfg_var() - Obtiene el valor de una opción de configuración de PHP
  • ini_get() - Devuelve el valor de una directiva de configuración
  • ini_get_all() - Obtiene todas las opciones de configuración
  • ini_restore() - Restablece el valor de una opción de configuración
  • Cómo cambiar los ajustes de configuración


Función main falsa

  • « ini_set
  • memory_get_peak_usage »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Función main falsa

main

main — Función main() falsa

Descripción

No existe ninguna función main(), salvo en el código fuente de PHP. En PHP 4.3.0, se introdujo un nuevo tipo de manejador de errores en el código fuente de PHP (php_error_docref). Existe una opción que permite enlazar a páginas del manual de PHP en los errores de mensaje cuando las directivas de PHP html_errors (habilitado por omisión) y docref_root (hasta PHP 4.3.2, habilitado por omisión) están habilitadas.

Algunos mensajes de error apuntan a la página del manual para la función main(), que es por lo que esta página existe. Si descubre alguna referencia a esta página, por favor » reporte un informe de error, indicando la función PHP que provocó el error que apuntó a main(), para que sea corregido y documentado.

Errores conocidos que apuntaban a main()
Nombre de la función | No apunta aquí desde
include | 5.1.0
include_once | 5.1.0
require | 5.1.0
require_once | 5.1.0

Ver también

  • html_errors
  • display_errors


Devuelve el máximo de memoria asignada por PHP

  • « main
  • memory_get_usage »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve el máximo de memoria asignada por PHP

memory_get_peak_usage

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

memory_get_peak_usage — Devuelve el máximo de memoria asignada por PHP

Descripción

memory_get_peak_usage ( bool $real_usage = false ) : int

Devuelve el máximo de memoria, en bytes, que se ha asignado a su script PHP.

Parámetros

real_usage

Si se deja en true puede obtener el tamaño real de memoria asignada por el sistema. Si no se establece o es false, la memoria utilizada por emalloc() es reportada.

Valores devueltos

Devuelve el máximo de memoria en bytes.

Historial de cambios

Versión | Descripción
5.2.1 | Compilar con --enable-memory-limit ya no es necesario para que esta función exista.
5.2.0 | Se añade real_usage.

Ver también

  • memory_get_usage() - Devuelve la cantidad de memoria asignada a PHP
  • memory_limit


Devuelve la cantidad de memoria asignada a PHP

  • « memory_get_peak_usage
  • php_ini_loaded_file »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve la cantidad de memoria asignada a PHP

memory_get_usage

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

memory_get_usage — Devuelve la cantidad de memoria asignada a PHP

Descripción

memory_get_usage ( bool $real_usage = false ) : int

Devuelve la cantidad de memoria, en bytes, que actualmente se asigna a su script PHP.

Parámetros

real_usage

Establecer esto a true para obtener el tamaño real de memoria asignada por el sistema. Incluyendo las páginas no usadas. Si no se establece o es false solo se informa de la memoria utilizada.

Nota:

PHP no rastrea la memoria que no es asignada por emalloc()

Valores devueltos

Devuelve la cantidad de memoria en bytes.

Historial de cambios

Versión | Descripción
5.2.1 | Compilar con --enable-memory-limit ya no es necesario para que exista esta función.
5.2.0 | Se añadió real_usage.

Ejemplos

Ejemplo #1 A memory_get_usage() ejemplo

<?php
// Este es sólo un ejemplo, los siguientes números
// serán diferentes dependiendo de su sistema

echo memory_get_usage() . "\n"; // 36640

$a = str_repeat("Hello", 4242);

echo memory_get_usage() . "\n"; // 57960

unset($a);

echo memory_get_usage() . "\n"; // 36744

?>

Ver también

  • memory_get_peak_usage() - Devuelve el máximo de memoria asignada por PHP
  • memory_limit


Recupera la ruta de acceso al archivo php.ini cargado

  • « memory_get_usage
  • php_ini_scanned_files »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Recupera la ruta de acceso al archivo php.ini cargado

php_ini_loaded_file

(PHP 5 >= 5.2.4, PHP 7, PHP 8)

php_ini_loaded_file — Recupera la ruta de acceso al archivo php.ini cargado

Descripción

php_ini_loaded_file ( ) : string

Comprueba si un archivo php.ini se ha cargado, y recupera su ruta de acceso.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La ruta de php.ini cargado, o false si uno no se ha cargado.

Ejemplos

Ejemplo #1 php_ini_loaded_file() ejemplo

<?php
$inipath = php_ini_loaded_file();

if ($inipath) {
    echo 'archivo php.ini cargado: ' . $inipath;
} else {
    echo 'ningún archivo php.ini ha sido cargado';
}
?>

El resultado del ejemplo sería algo similar a:

Loaded php.ini: /usr/local/php/php.ini

Ver también

  • php_ini_scanned_files() - Devuelve una lista de ficheros .ini procesados del directorio adicional ini
  • phpinfo() - Muestra información sobre la configuración de PHP
  • El archivo de configuración


Devuelve una lista de ficheros .ini procesados del directorio adicional ini

  • « php_ini_loaded_file
  • php_sapi_name »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve una lista de ficheros .ini procesados del directorio adicional ini

php_ini_scanned_files

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

php_ini_scanned_files — Devuelve una lista de ficheros .ini procesados del directorio adicional ini

Descripción

php_ini_scanned_files ( ) : string

php_ini_scanned_files() devuelve una lista separada por comas de los ficheros de configuración procesados por php.ini. Los directorios buscados se establecen por una opción de tiempo de compilación y, opcionalmente, por una variable de entorno en tiempo de ejecución: se puede encontrar más información en la guía de instalación.

Los archivos de configuración devueltos incluyen la ruta completa.

Valores devueltos

Devuelve un string de archivos .ini separados por comas en caso de éxito. Cada coma va seguida por una nueva línea. Si la directiva de configuración --with-config-file-scan-dir no fué establecida y la variable de entorno PHP_INI_SCAN_DIR no es establecida, false es retornado. Si estaba configurado y el directorio está vacío, un string vacío es retornado. Si un archivo es irreconocible, el archivo todavía se convertirá en el string retornado pero un error de PHP también resultará. Este error de PHP puede ser visto en tiempo de compilación como mientras se usa php_ini_scanned_files().

Ejemplos

Ejemplo #1 Un ejemplo simple para enumerar los archivos ini devueltos

<?php
if ($filelist = php_ini_scanned_files()) {
    if (strlen($filelist) > 0) {
        $files = explode(',', $filelist);

        foreach ($files as $file) {
            echo "<li>" . trim($file) . "</li>\n";
        }
    }
}
?>

Ver también

  • ini_set() - Establece el valor de una directiva de configuración
  • phpinfo() - Muestra información sobre la configuración de PHP
  • php_ini_loaded_file() - Recupera la ruta de acceso al archivo php.ini cargado


Devuelve el tipo de interfaz que hay entre PHP y el servidor

  • « php_ini_scanned_files
  • php_uname »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve el tipo de interfaz que hay entre PHP y el servidor

php_sapi_name

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

php_sapi_name — Devuelve el tipo de interfaz que hay entre PHP y el servidor

Descripción

php_sapi_name ( ) : string

Devuelve una cadena en minúsculas que describe el tipo de interfaz (la API de Servidor, SAPI) que está utilizando PHP. Por ejemplo, en PHP CLI esta cadena será "cli" mientras que en Apache podría tener varios valores diferentes dependiendo de la SAPI que se utilice. Más abajo se enumeran los posibles valores.

Valores devueltos

Devuelve el tipo de interfaz, como cadena de texto en minúsculas.

Pese a no ser una lista completa, los posibles valores incluyen aolserver, apache, apache2filter, apache2handler, caudium, cgi (hasta PHP 5.3), cgi-fcgi, cli, cli-server, continuity, embed, fpm-fcgi, isapi, litespeed, milter, nsapi, phttpd, pi3web, roxen, thttpd, tux, y webjames.

Ejemplos

Ejemplo #1 Ejemplo de php_sapi_name()

Este ejemplo comprueba si está la cadena cgi, ya que podría darse un nombre como cgi-fcgi.

<?php
$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) == 'cgi') {
    echo "Está usando PHP CGI\n";
} else {
    echo "No está usando PHP CGI\n";
}
?>

Notas

Nota: Una forma alternativa

La constante de PHP PHP_SAPI contiene el mismo valor que php_sapi_name().

Sugerencia

Posible malentendido

Podría no ser evidente cuál es la SAPI en uso, ya que, por ejemplo, en lugar de apache podría aparecer definida como apache2handler o como apache2filter.

Ver también

  • PHP_SAPI


Devuelve información sobre el sistema operativo en que se está ejecutando PHP

  • « php_sapi_name
  • phpcredits »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve información sobre el sistema operativo en que se está ejecutando PHP

php_uname

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

php_uname — Devuelve información sobre el sistema operativo en que se está ejecutando PHP

Descripción

php_uname ( string $mode = "a" ) : string

php_uname() devuelve una descripción del sistema operativo en que se está ejecutando PHP. Esta misma información se muestra en la parte superior de phpinfo(). Para obtener solamente el nombre del sistema operativo, considere el uso de la constante PHP_OS, pero tenga en mente que la constante contendrá el sistema operativo en que PHP fue compilado.

En algunos sistemas más antigos de UNIX, es posible que no se pueda determinar la información del SO actual en cuyo caso se revertirá mostrando el SO en que PHP fue compilado. Esto solo sucederá si la llamada a la libreria uname() no existe o no funciona.

Parámetros

mode

mode es un caracter simple que define qué información es devuelta:

  • 'a': Elegida por defecto. Contiene todos los modos en la secuencia "s n r v m".
  • 's': Nombre del sistema operativo. ej. FreeBSD.
  • 'n': Nombre del Host. ej. localhost.example.com.
  • 'r': Nombre de la versión liberada. ej. 5.1.2-RELEASE.
  • 'v': Información de la versión. Varia mucho entre los sistemas operativos.
  • 'm': Tipo de máquina. ej. i386.

Valores devueltos

Devuelve la descripción, como una cadena de texto.

Ejemplos

Ejemplo #1 Algúnos ejemplos de php_uname()

<?php
echo php_uname();
echo PHP_OS;

/* Algúnos posibles resultados:
Linux localhost 2.4.21-0.13mdk #1 Fri Mar 14 15:08:06 EST 2003 i686
Linux

FreeBSD localhost 3.2-RELEASE #15: Mon Dec 17 08:46:02 GMT 2001
FreeBSD

Windows NT XN1 5.1 build 2600
WINNT
*/

if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
    echo 'Este un servidor usando Windows!';
} else {
    echo 'Este es un servidor que no usa Windows!';
}

?>

También existen algunas constantes PHP predefinidas que pueden ser útiles, por ejemplo:

Ejemplo #2 Algunos ejemplos de las constantes relacionadas al SO

<?php
// *nix
echo DIRECTORY_SEPARATOR; // /
echo PHP_SHLIB_SUFFIX;    // so
echo PATH_SEPARATOR;      // :

// Win*
echo DIRECTORY_SEPARATOR; // \
echo PHP_SHLIB_SUFFIX;    // dll
echo PATH_SEPARATOR;      // ;
?>

Ver también

  • phpversion() - Obtiene la versión de PHP
  • php_sapi_name() - Devuelve el tipo de interfaz que hay entre PHP y el servidor
  • phpinfo() - Muestra información sobre la configuración de PHP


Imprime los créditos de PHP

  • « php_uname
  • phpinfo »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Imprime los créditos de PHP

phpcredits

(PHP 4, PHP 5, PHP 7, PHP 8)

phpcredits — Imprime los créditos de PHP

Descripción

phpcredits ( int $flag = CREDITS_ALL ) : bool

Esta función imprime la lista de créditos de los desarrolladores de PHP, módulos, etc Genera los códigos HTML apropiados para insertar la información en una página.

Parámetros

flag

Para generar una página de créditos personalizada, puede utilizar el parámetro flag.

Pre-defined phpcredits() flags
name | description
CREDITS_ALL | Todos los créditos, equivalente a usar: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_FULLPAGE. Genera una completa e independiente, página HTML con las etiquetas apropiadas.
CREDITS_DOCS | Los créditos para el equipo de documentación
CREDITS_FULLPAGE | Por lo general se utiliza en combinación con las otras flags. Indica que es independiente de la página HTML debe ser impreso con la información indicada por las otras flags.
CREDITS_GENERAL | Créditos generales: Diseño y concepto del lenguaje, autores de PHP y el módulo SAPI.
CREDITS_GROUP | Una lista de los desarrolladores del núcleo.
CREDITS_MODULES | Una lista de los módulos de extensión para PHP, y sus autores.
CREDITS_SAPI | Una lista de los módulos de servidor API para PHP, y sus autores.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Imprimir los créditos generales

<?php
phpcredits(CREDITS_GENERAL);
?>

Ejemplo #2 Imprimir los desarrolladores principales y el grupo de documentación

<?php
phpcredits(CREDITS_GROUP | CREDITS_DOCS | CREDITS_FULLPAGE);
?>

Ejemplo #3 Imprimir todos los créditos

<html>
 <head>
  <title>Mi página de créditos</title>
 </head>
 <body>
<?php
// Algún código propio
phpcredits(CREDITS_ALL - CREDITS_FULLPAGE);
// algo más de código
?>
 </body>
</html>

Notas

Nota:

phpcredits() genera texto plano en lugar de HTML al usar el modo CLI.

Ver también

  • phpversion() - Obtiene la versión de PHP
  • php_logo_guid()
  • phpinfo() - Muestra información sobre la configuración de PHP


Muestra información sobre la configuración de PHP

  • « phpcredits
  • phpversion »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Muestra información sobre la configuración de PHP

phpinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

phpinfo — Muestra información sobre la configuración de PHP

Descripción

phpinfo ( int $what = INFO_ALL ) : bool

Muestra gran cantidad de información sobre el estado actual de PHP. Incluye información sobre las opciones de compilación y extensiones de PHP, versión de PHP, información del servidor y entorno (si se compiló como módulo), entorno PHP, versión del OS, rutas, valor de las opciones de configuración locales y generales, cabeceras HTTP y licencia de PHP.

Como cada sistema se instala diferente phpinfo() se usa comúnmente para revisar opciones de configuración y variables predefinidas disponibles en un sistema dado

phpinfo() también es una valiosa herramienta de depuración ya que contiene todos valores EGPCS (Environment, GET, POST, Cookie, Server).

Parámetros

what

El resultado de salida puede ser personalizado al pasar una o más de las siguientes constantes sumadas juntas bit a bit en el parámetro opcional what. También se pueden combinar las respectivas constantes con el operador bit a bit or.

phpinfo() opciones
Nombre(constante) | Valor | Descripción
INFO_GENERAL | 1 | La línea de configuración, ubicación de php.ini, fecha de compilación, servidor Web, sistema y más.
INFO_CREDITS | 2 | Créditos de PHP. Ver también phpcredits().
INFO_CONFIGURATION | 4 | Valores Locales y Maestros actuales de las directivas PHP. Ver también ini_get().
INFO_MODULES | 8 | Módulos cargados y sus respectivos parámetros Ver también get_loaded_extensions().
INFO_ENVIRONMENT | 16 | Información de las variables de entorno. Tambien disponibles en $_ENV.
INFO_VARIABLES | 32 | Muestra todas las variables predefinidas de EGPCS (Environment, GET, POST, Cookie, Server).
INFO_LICENSE | 64 | Información de Licencia de PHP. Ver también el » FAQ de licencia.
INFO_ALL | -1 | Muestra toda la información anterior

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Los GUIDs de logos fueron reemplazados con URIs de datos, por lo que desactivar ahora expose_php no tiene efecto sobre el resutaldo de phpinfo(). Los créditos ahora también han sido embebidos en la salida misma en vez mediante enlaces.
5.2.2 | Se añadió la información del "Fichero de configuración cargado", mientras que anteriormente solo existía "Ruta del fichero de configuración (php.ini).

Ejemplos

Ejemplo #1 Ejemplo de phpinfo()

<?php

// Muestra toda la información, por defecto INFO_ALL
phpinfo();

// Muestra solamente la información de los módulos.
// phpinfo(8) hace exactamente lo mismo.
phpinfo(INFO_MODULES);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.5.0, las partes de la información que se muestra están deshabilidadas cuando la opción de configuración expose_php está establecida a off. Esto incluye los logos de PHP y Zend y los créditos.

Nota:

phpinfo() muestra texto plano en lugar de HTML cuando se utiliza en la línea de comandos.

Ver también

  • phpversion() - Obtiene la versión de PHP
  • phpcredits() - Imprime los créditos de PHP
  • php_logo_guid()
  • ini_get() - Devuelve el valor de una directiva de configuración
  • ini_set() - Establece el valor de una directiva de configuración
  • get_loaded_extensions() - Devuelve un array con los nombres de todos los módulos compilados y cargados
  • Variables predefinidas


Obtiene la versión de PHP

  • « phpinfo
  • putenv »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene la versión de PHP

phpversion

(PHP 4, PHP 5, PHP 7, PHP 8)

phpversion — Obtiene la versión de PHP

Descripción

phpversion ( string $extension = ? ) : string

Devuelve una cadena que contiene la versión del analizador de PHP en ejecución o extensión.

Parámetros

extension

Un nombre de extensión opcional.

Valores devueltos

Si el parámetro opcional extension ha sido especificado, phpversion() devuelve la versión de la extensión, o false si no hay información de versión asociada o la extensión no está habilitada.

Ejemplos

Ejemplo #1 phpversion() Ejemplo básico

<?php
// Imprime ejemplo 'Versión actual de PHP: 5.3.8'
echo 'Versión actual de PHP: ' . phpversion();

// Imprime ejemplo '2.0' o nada si la extensión no está habilitada
echo phpversion('tidy');
?>

Ejemplo #2 PHP_VERSION_ID Ejemplo y uso

<?php
// PHP_VERSION_ID está disponible a partir de PHP 5.2.7, si nuestra
// versión es inferior a eso, entonces emular
if (!defined('PHP_VERSION_ID')) {
    $version = explode('.', PHP_VERSION);

    define('PHP_VERSION_ID', ($version[0] * 10000 + $version[1] * 100 + $version[2]));
}

// PHP_VERSION_ID se define como un número, donde el mayor número,
// es la versión más reciente de PHP usada. Se define tal como se utiliza la
// expresión anterior.
//
// $version_id = $major_version * 10000 + $minor_version * 100 + $release_version;
//
// Ahora, con PHP_VERSION_ID podemos comprobar las características que la versión de
// PHP pueda tener, esto no requiere el uso version_compare () cada vez que compruebe si la
// versión de PHP no es compatible con una característica.
//
// Por ejemplo, aquí podemos definir las constantes PHP_VERSION_ * que
// no están disponibles en las versiones anteriores a 5.2.7

if (PHP_VERSION_ID < 50207) {
    define('PHP_MAJOR_VERSION',   $version[0]);
    define('PHP_MINOR_VERSION',   $version[1]);
    define('PHP_RELEASE_VERSION', $version[2]);

    // Y así sucesivamente, ...
}
?>

Notas

Nota:

Esta información también está disponible en la constante predefinida PHP_VERSION. Más información de versión está disponible utilizando las constantes PHP_VERSION_*

Ver también

  • constantes predefinidas
  • version_compare() - Compara dos números de versiones estandarizados de PHP
  • phpinfo() - Muestra información sobre la configuración de PHP
  • phpcredits() - Imprime los créditos de PHP
  • php_logo_guid()
  • zend_version() - Obtiene la versión del motor Zend actual


Establece el valor de una variable de entorno

  • « phpversion
  • restore_include_path »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Establece el valor de una variable de entorno

putenv

(PHP 4, PHP 5, PHP 7, PHP 8)

putenv — Establece el valor de una variable de entorno

Descripción

putenv ( string $assignment ) : bool

Agrega setting al entorno del servidor. La variable de entorno existirá únicamente durante la petición actual. Al final de la petición el entorno es recuperado a su estado original.

Parámetros

asignación

El parámetro, como p.ej. "FOO=BAR"

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Definición de una variable de entorno

<?php
putenv("UNIQID=$uniqid");
?>

Ver también

  • getenv() - Obtiene el valor de una variable de entorno
  • apache_setenv() - Establece una variable subprocess_env de Apache


Restablece el valor de la opción de configuración include_path

  • « putenv
  • set_include_path »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Restablece el valor de la opción de configuración include_path

restore_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

restore_include_path — Restablece el valor de la opción de configuración include_path

Descripción

restore_include_path ( ) : void

Restablece la opción de configuración include_path a su valor maestro original, tal y como se encuentre definido en php.ini

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de restore_include_path()

<?php

echo get_include_path();  // .:/usr/local/lib/php

set_include_path('/inc');

echo get_include_path();  // /inc

restore_include_path();

// O utilizando ini_restore()
ini_restore('include_path');

echo get_include_path();  // .:/usr/local/lib/php

?>

Ver también

  • ini_restore() - Restablece el valor de una opción de configuración
  • get_include_path() - Obtiene la opción de configuración include_path actual
  • set_include_path() - Establece la opción de configuración include_path
  • include - include


Establece la opción de configuración include_path

  • « restore_include_path
  • set_time_limit »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Establece la opción de configuración include_path

set_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

set_include_path — Establece la opción de configuración include_path

Descripción

set_include_path ( string $new_include_path ) : string

Establece la opción de configuración include_path durante la duración del script.

Parámetros

new_include_path

El nuevo valor para include_path

Valores devueltos

Devuelve el valor antiguo de include_path en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de set_include_path()

<?php
// Funciona a partir de PHP 4.3.0
set_include_path('/usr/lib/pear');

// Funciona en todas las versiones de PHP
ini_set('include_path', '/usr/lib/pear');
?>

Ejemplo #2 Añadir a la ruta de inclusión

Haciendo uso de la constante PATH_SEPARATOR es posible extender la ruta de inclusión independientemente del sistema operativo.

En este ejemplo agregamos /usr/lib/pear al final del valor include_path actual.

<?php
$ruta = '/usr/lib/pear';
set_include_path(get_include_path() . PATH_SEPARATOR . $ruta);
?>

Ver también

  • ini_set() - Establece el valor de una directiva de configuración
  • get_include_path() - Obtiene la opción de configuración include_path actual
  • restore_include_path() - Restablece el valor de la opción de configuración include_path
  • include - include


Limita el tiempo máximo de ejecución

  • « set_include_path
  • sys_get_temp_dir »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Limita el tiempo máximo de ejecución

set_time_limit

(PHP 4, PHP 5, PHP 7, PHP 8)

set_time_limit — Limita el tiempo máximo de ejecución

Descripción

set_time_limit ( int $seconds ) : bool

Establece el número de segundos que se permite la ejecución de un script. Si esto se alcanza, el script devuelve un error fatal. El límite predeterminado es de 30 segundos o, si es que existe, el valor max_execution_time definido en el php.ini.

Cuando es llamado, set_time_limit() reinicia el contador de tiempo de espera de cero. En otras palabras, si el tiempo de espera por defecto es de 30 segundos, y 25 segundos en la ejecución del script se hace la llamada set_time_limit(20), el script se ejecutará durante un total de 45 segundos antes de que se agote el tiempo.

Parámetros

seconds

El tiempo de ejecución máximo, en segundos. Si se pone a cero se impone sin límite de tiempo.

Valores devueltos

Devuelve true en caso de éxito, o false en caso de fallo.

Notas

Nota:

La función set_time_limit() y la directiva de configuración max_execution_time sólo afectan el tiempo de ejecución del script mismo. Todo el tiempo dedicado a la actividad que ocurre fuera de la ejecución del script, como las llamadas al sistema usando system(), operaciones de secuencia, consultas a la bases de datos, etc. No se incluyen cuando se determina el tiempo máximo del script en funcionamiento. Esto no es cierto en Windows, donde el tiempo medido es real.

Ver también

  • max_execution_time
  • max_input_time


Devuelve la ruta del directorio para archivos temporales

  • « set_time_limit
  • version_compare »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve la ruta del directorio para archivos temporales

sys_get_temp_dir

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

sys_get_temp_dir — Devuelve la ruta del directorio para archivos temporales

Descripción

sys_get_temp_dir ( ) : string

Devuelve la ruta del directorio donde PHP almacena los archivos temporales por defecto.

Valores devueltos

Devuelve la ruta del directorio temporal.

Ejemplos

Ejemplo #1 sys_get_temp_dir() example

<?php
// Crear un fichero en el temporal
// directorio de archivos utilizando sys_get_temp_dir()
$temp_file = tempnam(sys_get_temp_dir(), 'Tux');

echo $temp_file;
?>

El resultado del ejemplo sería algo similar a:

C:\Windows\Temp\TuxA318.tmp

Ver también

  • tmpfile() - Crea un archivo temporal
  • tempnam() - Crea un fichero con un nombre de fichero único


Compara dos números de versiones estandarizados de PHP

  • « sys_get_temp_dir
  • zend_thread_id »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Compara dos números de versiones estandarizados de PHP

version_compare

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

version_compare — Compara dos números de versiones estandarizados de PHP

Descripción

version_compare ( string $version1 , string $version2 , string $operator = ? ) : mixed

version_compare() compara dos string de números de versiones estandarizados de PHP.

Esta función, en primer lugar reemplaza los _, - y + por puntos . y las cadenas de texto de versiones y añade puntos . antes y después de cualquier código no numérico, de manera que '4.3.2RC1' sería '4.3.2.RC.1'. Después, compara cada una de las partes, de izquierda a derecha. Si alguna parte contuviera un texto especial de versión, se manejarían con el siguiente orden: cualquier texto que no se encuentre en esta lista < dev < alpha = a < beta = b < RC = rc < # < pl = p. De esta forma, no solo se pueden comparar versiones con diferentes niveles, como '4.1' y '4.1.2', sino que también se pueden comparar versiones específicas de PHP que contengan el estado de desarrollo en que se encuentran.

Parámetros

version1

Primer número de versión.

version2

Segundo número de versión.

operator

Si se especifica el tercer argumento opcional operator, se prueba para una relación en particular. Los posibles operadores son: <, lt, <=, le, >, gt, >=, ge, ==, =, eq, !=, <>, ne respectivamente.

Este parámetro es sensible a mayúsculas, por lo que los valores debes estar en minúsculas.

Valores devueltos

Por omisión, version_compare() devuelve -1 si la primera versión es inferior a la segunda, 0 si son iguales, y 1 si la segunda es inferior.

Al usar el argumento opcional operator, la función de volverá true si se cumpliera la relación especificada por el operador, o false en caso contrario.

Ejemplos

Los siguientes ejemplos usan la constante PHP_VERSION, ya que esta contiene el valor de la versión de PHP con que se está ejecutando el código.

Ejemplo #1 Ejemplos de version_compare()

<?php
if (version_compare(PHP_VERSION, '6.0.0') >= 0) {
    echo 'Soy al menos la versión 6.0.0 de PHP, mi versión: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.3.0') >= 0) {
    echo 'Soy al menos la versión 5.3.0 de PHP, mi versión: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '>=')) {
    echo 'Estoy usando la versión 5 de PHP, mi versión: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '<')) {
    echo 'Estoy usando la versión 4 de PHP, mi versión: ' . PHP_VERSION . "\n";
}
?>

Notas

Nota:

La constante PHP_VERSION almacena la versión de PHP en uso.

Nota:

Tenga presente que las versiones preeliminares, como por ejemplo 5.3.0-dev, se las considera inferiroes a la versión final (como por ejemplo 5.3.0).

Nota:

Las cadenas de versiones especiales como alpha y beta son sensibles a mayúsculas/minúsculas. Las cadenas de versiones desde fuentes arbitrarias que no se adhieren al estándar de PHP podrían necesitar ser convertidas a minúsculas mediante strtolower() antes de llamar a version_compare().

Ver también

  • phpversion() - Obtiene la versión de PHP
  • php_uname() - Devuelve información sobre el sistema operativo en que se está ejecutando PHP
  • function_exists() - Devuelve true si la función dada ha sido definida


Devuelve un identificador único del thread actual

  • « version_compare
  • zend_version »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Devuelve un identificador único del thread actual

zend_thread_id

(PHP 5, PHP 7, PHP 8)

zend_thread_id — Devuelve un identificador único del thread actual

Descripción

zend_thread_id ( ) : int

Esta función devuelve un identificador único del thread actual.

Valores devueltos

Devuelve thread id en formato integer.

Ejemplos

Ejemplo #1 Ejemplo de zend_thread_id()

<?php
$thread_id = zend_thread_id();

echo 'El thread id actual es: ' . $thread_id;
?>

El resultado del ejemplo sería algo similar a:

El thread actual es: 7864

Notas

Nota:

Esta función solo está disponible en PHP compilado con soporte ZTS (Zend Thread Safety) y modo debug (--enable-debug).


Obtiene la versión del motor Zend actual

  • « zend_thread_id
  • phpdbg »
  • PHP Manual
  • Funciones de Opciones/Info de PHP
  • Obtiene la versión del motor Zend actual

zend_version

(PHP 4, PHP 5, PHP 7, PHP 8)

zend_version — Obtiene la versión del motor Zend actual

Descripción

zend_version ( ) : string

Devuelve una cadena que contiene la versión del Motor Zend ejecutándose actualmente.

Valores devueltos

Devuelve el número de versión del Motor Zend, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de zend_version()

<?php
echo "Versión del motor Zend: " . zend_version();
?>

El resultado del ejemplo sería algo similar a:

Versión del motor Zend: 2.2.0

Ver también

  • phpinfo() - Muestra información sobre la configuración de PHP
  • phpcredits() - Imprime los créditos de PHP
  • php_logo_guid()
  • phpversion() - Obtiene la versión de PHP


Interactive PHP Debugger

  • Introducción
  • Instalación/Configuración
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • phpdbg Funciones
    • phpdbg_break_file — Inserts a breakpoint at a line in a file
    • phpdbg_break_function — Inserts a breakpoint at entry to a function
    • phpdbg_break_method — Inserts a breakpoint at entry to a method
    • phpdbg_break_next — Inserts a breakpoint at the next opcode
    • phpdbg_clear — Clears all breakpoints
    • phpdbg_color — Sets the color of certain elements
    • phpdbg_end_oplog — Descripción
    • phpdbg_exec — Attempts to set the execution context
    • phpdbg_get_executable — Descripción
    • phpdbg_prompt — Sets the command prompt
    • phpdbg_start_oplog — Descripción


Introducción

Implemented as a SAPI module, phpdbg can exert complete control over the environment without impacting the functionality or performance of your code.

phpdbg aims to be a lightweight, powerful, easy to use debugging platform for PHP. It offers the following features:

  • Step-Through Debugging
  • Flexible Breakpoints (Class Method, Function, File:Line, Address, Opcode)
  • Easy Access to PHP with built-in eval()
  • Userland API
  • SAPI Agnostic - Easily Integrated
  • PHP Configuration File Support
  • JIT Super Globals - Set Your Own !!
  • Optional readline Support - Comfortable Terminal Operation
  • Easy Operation - See Help :)

Command line options
Option | Example Argument | Description
-c | -c/my/php.ini | Set php.ini file to load
-d | -dmemory_limit=4G | Set a php.ini directive
-n |  | Disable default php.ini
-q |  | Suppress welcome banner
-v |  | Enable oplog output
-b |  | Disable color
-i | -imy.init | Set .phpdbginit file
-I |  | Ignore default .phpdbginit
-O | -Omy.oplog | Set oplog output file
-r |  | Run execution context
-rr |  | Run execution context and quit after execution (not respecting breakpoints)
-e |  | Generate extended information for debugger/profiler
-E |  | Enable step through eval, careful!
-s | -s=, -s=foo | Read code to execute from stdin with an optional delimiter
-S | -Scli | Override SAPI name, careful!
-l | -l4000 | Setup remote console ports
-a | -a192.168.0.3 | Setup remote console bind address
-x |  | Enable xml output (instead of normal text output)
-p | -p, -p=func, -p* | Output opcodes and quit
-h |  | Print the help overview
-V |  | Print version number
-- | -- arg1 arg2 | Use to delimit phpdbg arguments and php $argv; append any $argv argument after it


  • « Introducción
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • phpdbg
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Configuración en tiempo de ejecución


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

phpdbg Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
phpdbg.eol | 2 | PHP_INI_ALL | Available as of PHP 7.0.0
phpdbg.path |  | 6 | Available as of PHP 5.6.3

He aquí una breve explicación de las directivas de configuración.

phpdbg.eol mixed

The kind of line ending to use for output. For setting the value, one of the string aliases must be used.

int Value | string Alias
0 | CRLF, crlf, DOS, dos
1 | LF, lf, UNIX, unix
2 | CR, cr, MAC, mac

phpdbg.path string


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

PHPDBG_VERSION (string)
PHPDBG_FILE (int)
Removed as of PHP 7.3.0.
PHPDBG_METHOD (int)
Removed as of PHP 7.3.0.
PHPDBG_LINENO (int)
Removed as of PHP 7.3.0.
PHPDBG_FUNC (int)
Removed as of PHP 7.3.0.
PHPDBG_COLOR_PROMPT (int)
PHPDBG_COLOR_NOTICE (int)
PHPDBG_COLOR_ERROR (int)


phpdbg Funciones

Tabla de contenidos

  • phpdbg_break_file — Inserts a breakpoint at a line in a file
  • phpdbg_break_function — Inserts a breakpoint at entry to a function
  • phpdbg_break_method — Inserts a breakpoint at entry to a method
  • phpdbg_break_next — Inserts a breakpoint at the next opcode
  • phpdbg_clear — Clears all breakpoints
  • phpdbg_color — Sets the color of certain elements
  • phpdbg_end_oplog — Descripción
  • phpdbg_exec — Attempts to set the execution context
  • phpdbg_get_executable — Descripción
  • phpdbg_prompt — Sets the command prompt
  • phpdbg_start_oplog — Descripción


Inserts a breakpoint at a line in a file

  • « phpdbg Funciones
  • phpdbg_break_function »
  • PHP Manual
  • phpdbg Funciones
  • Inserts a breakpoint at a line in a file

phpdbg_break_file

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_file — Inserts a breakpoint at a line in a file

Descripción

phpdbg_break_file ( string $file , int $line ) : void

Insert a breakpoint at the given line in the given file.

Parámetros

file

The name of the file.

line

The line number.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at entry to a function

  • « phpdbg_break_file
  • phpdbg_break_method »
  • PHP Manual
  • phpdbg Funciones
  • Inserts a breakpoint at entry to a function

phpdbg_break_function

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_function — Inserts a breakpoint at entry to a function

Descripción

phpdbg_break_function ( string $function ) : void

Insert a breakpoint at the entry to the given function.

Parámetros

function

The name of the function.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at entry to a method

  • « phpdbg_break_function
  • phpdbg_break_next »
  • PHP Manual
  • phpdbg Funciones
  • Inserts a breakpoint at entry to a method

phpdbg_break_method

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_method — Inserts a breakpoint at entry to a method

Descripción

phpdbg_break_method ( string $class , string $method ) : void

Insert a breakpoint at the entry to the given method of the given class.

Parámetros

class

The name of the class.

method

The name of the method.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at the next opcode

  • « phpdbg_break_method
  • phpdbg_clear »
  • PHP Manual
  • phpdbg Funciones
  • Inserts a breakpoint at the next opcode

phpdbg_break_next

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_next — Inserts a breakpoint at the next opcode

Descripción

phpdbg_break_next ( ) : void

Insert a breakpoint at the next opcode.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_clear() - Clears all breakpoints


Clears all breakpoints

  • « phpdbg_break_next
  • phpdbg_color »
  • PHP Manual
  • phpdbg Funciones
  • Clears all breakpoints

phpdbg_clear

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_clear — Clears all breakpoints

Descripción

phpdbg_clear ( ) : void

Clear all breakpoints that have been set, either via one of the phpdbg_break_*() functions or interactively in the console.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode


Sets the color of certain elements

  • « phpdbg_clear
  • phpdbg_end_oplog »
  • PHP Manual
  • phpdbg Funciones
  • Sets the color of certain elements

phpdbg_color

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_color — Sets the color of certain elements

Descripción

phpdbg_color ( int $element , string $color ) : void

Set the color of the given element.

Parámetros

element

One of the PHPDBG_COLOR_* constants.

color

The name of the color. One of white, red, green, yellow, blue, purple, cyan or black, optionally with either a trailing -bold or -underline, for instance, white-bold or green-underline.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_prompt() - Sets the command prompt


Descripción

  • « phpdbg_color
  • phpdbg_exec »
  • PHP Manual
  • phpdbg Funciones
  • Descripción

phpdbg_end_oplog

(PHP 7, PHP 8)

phpdbg_end_oplog —

Descripción

phpdbg_end_oplog ( array $options = [] ) : array|null

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

options

Valores devueltos


Attempts to set the execution context

  • « phpdbg_end_oplog
  • phpdbg_get_executable »
  • PHP Manual
  • phpdbg Funciones
  • Attempts to set the execution context

phpdbg_exec

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_exec — Attempts to set the execution context

Descripción

phpdbg_exec ( string $context ) : string|bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

context

Valores devueltos

If the execution context was set previously it is returned. If the execution context was not set previously true is returned. If the request to set the context fails, false is returned, and an E_WARNING raised.


Descripción

  • « phpdbg_exec
  • phpdbg_prompt »
  • PHP Manual
  • phpdbg Funciones
  • Descripción

phpdbg_get_executable

(PHP 7, PHP 8)

phpdbg_get_executable —

Descripción

phpdbg_get_executable ( array $options = [] ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

options

Valores devueltos


Sets the command prompt

  • « phpdbg_get_executable
  • phpdbg_start_oplog »
  • PHP Manual
  • phpdbg Funciones
  • Sets the command prompt

phpdbg_prompt

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_prompt — Sets the command prompt

Descripción

phpdbg_prompt ( string $string ) : void

Set the command prompt to the given string.

Parámetros

string

The string to use as command prompt.

Valores devueltos

No devuelve ningún valor.

Ver también

  • phpdbg_color() - Sets the color of certain elements


Descripción

  • « phpdbg_prompt
  • runkit »
  • PHP Manual
  • phpdbg Funciones
  • Descripción

phpdbg_start_oplog

(PHP 7, PHP 8)

phpdbg_start_oplog —

Descripción

phpdbg_start_oplog ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


runkit

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de runkit
    • runkit_constant_add — Similar a define(), excepto que también permite definir en definiciones de clase
    • runkit_constant_redefine — Redefinir una constante ya definida
    • runkit_constant_remove — Eliminar/Borrar una constante ya definida
    • runkit_function_add — Añadir una nueva función, similar a create_function
    • runkit_function_copy — Copiar una función a un nombre de función nuevo
    • runkit_function_redefine — Reemplazar una definición de función con una nueva implementación
    • runkit_function_remove — Eliminar una definición de función
    • runkit_function_rename — Cambiar el nombre de una función
    • runkit_import — Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado
    • runkit_method_add — Añadir dinámicamente un nuevo método a una clase dada
    • runkit_method_copy — Copia un método de una clase a otra
    • runkit_method_redefine — Cambiar dinámicamente el código del método dado
    • runkit_method_remove — Eliminar dinámicamente el método dado
    • runkit_method_rename — Cambiar dinámicamente el nombre del método dado
    • runkit7_object_id — Return the integer object handle for given object
    • runkit_superglobals — Devolver el array indexado numéricamente de las superglobales registradas
    • runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc


Introducción

La extensión runkit proporciona medios para modificar constantes, funciones definidas por el usuario y clases definidas por el usuario. También proporciona variables superglobales personalizadas y sub-intérpretes que se pueden embeber mediante aislamiento de procesos (sandboxing).

Este paquete está hecho como una característica añadida para reemplazar al paquete » classkit. Cuando se compila con la opción --enable-runkit=classkit a ./configure, exportará las definiciones de funciones y constantes compatibles con classkit.


Requerimientos

Modificar Constantes, Funciones, Clases y Métodos funciona con todas las distribuciones de PHP 4 y PHP 5. No se necesitan requisitos especiales.

Las Superglobales Personalizadas sólo están disponibles en PHP 4.2.0 o posterior.

El Aislamiento de Procesos (Sandboxing) requiere PHP 5.1.0 o posterior, o PHP 5.0.0 con un parche TSRM especial aplicado. Sin importar qué versión de PHP está en uso se debe compilar con la opción --enable-maintainer-zts. Vea el archivo README en el paquete de runkit para información adicional.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/runkit.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración de Runkit
Nombre | Por defecto | Cambiable | Historial de cambios
runkit.superglobal | "" | PHP_INI_PERDIR |
runkit.internal_override | "0" | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

runkit.superglobal string
Una lista separada por comas de nombres de variables que van a ser tratadas como superglobales. Este valor debería estar establecido a través del archivo php.ini, pero puede funcionar en contextos de configuración por directorio dependiendo de su SAPI.

Ejemplo #1 Superglobales personalizadas con runkit.superglobal=_FOO,_BAR en php.ini

<?php
function mostrar_valores() {
  echo "Foo es $_FOO\n";
  echo "Bar es $_BAR\n";
  echo "Baz es $_BAZ\n";
}

$_FOO = 'foo';
$_BAR = 'bar';
$_BAZ = 'baz';

/* Muestra foo y bar, pero no baz */
mostrar_valores();
?>
runkit.internal_override boolean
Habilita la capacidad de modificar/renombrar/eliminar funciones internas.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

RUNKIT_IMPORT_FUNCTIONS (integer)
Bandera de runkit_import() que indica que las funciones normales deberían ser importadas desde el archivo especificado.
RUNKIT_IMPORT_CLASS_METHODS (integer)
Bandera de runkit_import() que indica que los métodos de clases deberían ser importados desde el archivo especificado.
RUNKIT_IMPORT_CLASS_CONSTS (integer)
Bandera de runkit_import() que indica que las constantes de clases deberían ser importadas desde el archivo especificado. Observe que esta bandera sólo tiene sentido en versiones de PHP 5.1.0 y superiores.
RUNKIT_IMPORT_CLASS_PROPS (integer)
Bandera de runkit_import() que indica que las propiedades estándar de clases deberían ser importadas desde el archivo especificado.
RUNKIT_IMPORT_CLASS_STATIC_PROPS (integer)
Bandera de runkit_import() que indica que las propiedades estáticas de clases deben ser importadas desde el fichero especificado. Disponible desde Runkit 1.0.1.
RUNKIT_IMPORT_CLASSES (integer)
Bandera de runkit_import() que representa un operador OR a nivel de bit de las constantes RUNKIT_IMPORT_CLASS_*.
RUNKIT_IMPORT_OVERRIDE (integer)
Bandera de runkit_import() que indica que si cualesquiera de las funciones, métodos, contantes o propiedades importados ya existen deberían ser reemplazados con las nuevas definiciones. Si esta bandera no está establecida, cualquier definición importada que ya exista será descartada.
RUNKIT_ACC_PUBLIC (integer)
Bandera específica de PHP 5 para runkit_method_add() y runkit_method_redefine()
RUNKIT_ACC_PROTECTED (integer)
Bandera específica de PHP 5 para runkit_method_add() y runkit_method_redefine()
RUNKIT_ACC_PRIVATE (integer)
Bandera específica de PHP 5 para runkit_method_add() y runkit_method_redefine()
RUNKIT_ACC_STATIC (integer)
Bandera específica de PHP 5 para runkit_method_add() y runkit_method_redefine(). Disponible desde Runkit 1.0.1.
CLASSKIT_ACC_PUBLIC (integer)
Bandera específica de PHP 5 para classkit_method_add() Sólo definida cuando la compatibilidad con classkit está habilitada.
CLASSKIT_ACC_PROTECTED (integer)
Bandera específica de PHP 5 para classkit_method_add() Sólo definida cuando la compatibilidad con classkit está habilitada.
CLASSKIT_ACC_PRIVATE (integer)
Bandera específica de PHP 5 para classkit_method_add() Sólo definida cuando la compatibilidad con classkit está habilitada.
CLASSKIT_AGGREGATE_OVERRIDE (integer)
Bandera específica de PHP 5 para classkit_import() Sólo definida cuando la compatibilidad con classkit está habilitada.
RUNKIT_VERSION (string)
Definida para la versión actual del paquete runkit.
CLASSKIT_VERSION (string)
Definida para la versión actual del paquete runkit. Sólo definida cuando la compatibilidad con classkit está habilitada.


Funciones de runkit

Tabla de contenidos

  • runkit_constant_add — Similar a define(), excepto que también permite definir en definiciones de clase
  • runkit_constant_redefine — Redefinir una constante ya definida
  • runkit_constant_remove — Eliminar/Borrar una constante ya definida
  • runkit_function_add — Añadir una nueva función, similar a create_function
  • runkit_function_copy — Copiar una función a un nombre de función nuevo
  • runkit_function_redefine — Reemplazar una definición de función con una nueva implementación
  • runkit_function_remove — Eliminar una definición de función
  • runkit_function_rename — Cambiar el nombre de una función
  • runkit_import — Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado
  • runkit_method_add — Añadir dinámicamente un nuevo método a una clase dada
  • runkit_method_copy — Copia un método de una clase a otra
  • runkit_method_redefine — Cambiar dinámicamente el código del método dado
  • runkit_method_remove — Eliminar dinámicamente el método dado
  • runkit_method_rename — Cambiar dinámicamente el nombre del método dado
  • runkit7_object_id — Return the integer object handle for given object
  • runkit_superglobals — Devolver el array indexado numéricamente de las superglobales registradas
  • runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc


Similar a define(), excepto que también permite definir en definiciones de clase

  • « Funciones de runkit
  • runkit_constant_redefine »
  • PHP Manual
  • Funciones de runkit
  • Similar a define(), excepto que también permite definir en definiciones de clase

runkit_constant_add

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_constant_add — Similar a define(), excepto que también permite definir en definiciones de clase

Descripción

runkit_constant_add ( string $constname , mixed $value ) : bool

Parámetros

constname

Nombre de la constante a declarar. Una cadena que indica la constante global, o nombreclase::constname que indica la constante de clase.

value

Valor NULL, Bool, Long, Double, String, o Resource a almacenar en la nueva constante.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • define() - Define una constante con nombre
  • runkit_constant_redefine() - Redefinir una constante ya definida
  • runkit_constant_remove() - Eliminar/Borrar una constante ya definida


Redefinir una constante ya definida

  • « runkit_constant_add
  • runkit_constant_remove »
  • PHP Manual
  • Funciones de runkit
  • Redefinir una constante ya definida

runkit_constant_redefine

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_constant_redefine — Redefinir una constante ya definida

Descripción

runkit_constant_redefine ( string $constname , mixed $newvalue ) : bool

Parámetros

constname

Constante a redefinir. Una cadena que indica la constante global, o nombreclase::constname que indica la constante de clase.

newvalue

El nuevo valor a asignar a la constante.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • runkit_constant_add() - Similar a define(), excepto que también permite definir en definiciones de clase
  • runkit_constant_remove() - Eliminar/Borrar una constante ya definida


Eliminar/Borrar una constante ya definida

  • « runkit_constant_redefine
  • runkit_function_add »
  • PHP Manual
  • Funciones de runkit
  • Eliminar/Borrar una constante ya definida

runkit_constant_remove

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_constant_remove — Eliminar/Borrar una constante ya definida

Descripción

runkit_constant_remove ( string $constname ) : bool

Parámetros

constname

Nombre de la constante a eliminar. Una cadena que indica la constante global, o nombreclase::constname que indica la constante de clase.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • define() - Define una constante con nombre
  • runkit_constant_add() - Similar a define(), excepto que también permite definir en definiciones de clase
  • runkit_constant_redefine() - Redefinir una constante ya definida


Añadir una nueva función, similar a create_function

  • « runkit_constant_remove
  • runkit_function_copy »
  • PHP Manual
  • Funciones de runkit
  • Añadir una nueva función, similar a create_function

runkit_function_add

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_function_add — Añadir una nueva función, similar a create_function()

Descripción

runkit_function_add ( string $funcname , string $arglist , string $code ) : bool

Parámetros

funcname

Nombre de la función que va a ser creada

arglist

Lista de argumentos separados por comas

code

Código que compone la función

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de runkit_function_add()

<?php
runkit_function_add('testme','$a,$b','echo "El valor de a es $a\n"; echo "El valor de b es $b\n";');
testme(1,2);
?>

El resultado del ejemplo sería:

El valor de a es 1
El valor de b es 2

Ver también

  • create_function() - Crear una función anónima (estilo lambda)
  • runkit_function_redefine() - Reemplazar una definición de función con una nueva implementación
  • runkit_function_copy() - Copiar una función a un nombre de función nuevo
  • runkit_function_rename() - Cambiar el nombre de una función
  • runkit_function_remove() - Eliminar una definición de función
  • runkit_method_add() - Añadir dinámicamente un nuevo método a una clase dada


Copiar una función a un nombre de función nuevo

  • « runkit_function_add
  • runkit_function_redefine »
  • PHP Manual
  • Funciones de runkit
  • Copiar una función a un nombre de función nuevo

runkit_function_copy

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_function_copy — Copiar una función a un nombre de función nuevo

Descripción

runkit_function_copy ( string $funcname , string $targetname ) : bool

Parámetros

funcname

Nombre de la función existente

targetname

Nombre de la función donde se va a copiar la definición

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de runkit_function_copy()

<?php
function original() {
  echo "En una función\n";
}
runkit_function_copy('original','duplicado');
original();
duplicado();
?>

El resultado del ejemplo sería:

En una función
En una función

Ver también

  • runkit_function_add() - Añadir una nueva función, similar a create_function
  • runkit_function_redefine() - Reemplazar una definición de función con una nueva implementación
  • runkit_function_rename() - Cambiar el nombre de una función
  • runkit_function_remove() - Eliminar una definición de función


Reemplazar una definición de función con una nueva implementación

  • « runkit_function_copy
  • runkit_function_remove »
  • PHP Manual
  • Funciones de runkit
  • Reemplazar una definición de función con una nueva implementación

runkit_function_redefine

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_function_redefine — Reemplazar una definición de función con una nueva implementación

Descripción

runkit_function_redefine ( string $funcname , string $arglist , string $code ) : bool

Nota: Por defecto, sólo funciones del espacio de usuario pueden ser eliminadas, renombradas, o modificadas. Para controlar funciones internas, la opción runkit.internal_override en php.ini debe ser habilitada.

Parámetros

funcname

Nombre de la función a redefinir

arglist

Nueva lista de argumentos a ser aceptados por la función

code

Nueva implementación de código

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de runkit_function_redefine()

<?php
function testme() {
  echo "Implementación Original de Testme\n";
}
testme();
runkit_function_redefine('testme','','echo "Nueva Implementación de Testme\n";');
testme();
?>

El resultado del ejemplo sería:

Implementación Original de Testme
Nueva Implementación de Testme

Ver también

  • runkit_function_add() - Añadir una nueva función, similar a create_function
  • runkit_function_copy() - Copiar una función a un nombre de función nuevo
  • runkit_function_rename() - Cambiar el nombre de una función
  • runkit_function_remove() - Eliminar una definición de función


Eliminar una definición de función

  • « runkit_function_redefine
  • runkit_function_rename »
  • PHP Manual
  • Funciones de runkit
  • Eliminar una definición de función

runkit_function_remove

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_function_remove — Eliminar una definición de función

Descripción

runkit_function_remove ( string $funcname ) : bool

Nota: Por defecto, sólo funciones del espacio de usuario pueden ser eliminadas, renombradas, o modificadas. Para controlar funciones internas, la opción runkit.internal_override en php.ini debe ser habilitada.

Parámetros

funcname

Nombre de la función a ser borrada

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • runkit_function_add() - Añadir una nueva función, similar a create_function
  • runkit_function_copy() - Copiar una función a un nombre de función nuevo
  • runkit_function_redefine() - Reemplazar una definición de función con una nueva implementación
  • runkit_function_rename() - Cambiar el nombre de una función


Cambiar el nombre de una función

  • « runkit_function_remove
  • runkit_import »
  • PHP Manual
  • Funciones de runkit
  • Cambiar el nombre de una función

runkit_function_rename

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_function_rename — Cambiar el nombre de una función

Descripción

runkit_function_rename ( string $funcname , string $newname ) : bool

Nota: Por defecto, sólo funciones del espacio de usuario pueden ser eliminadas, renombradas, o modificadas. Para controlar funciones internas, la opción runkit.internal_override en php.ini debe ser habilitada.

Parámetros

funcname

Nombre actual de la función

newname

Nombre nuevo de la función

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • runkit_function_add() - Añadir una nueva función, similar a create_function
  • runkit_function_copy() - Copiar una función a un nombre de función nuevo
  • runkit_function_redefine() - Reemplazar una definición de función con una nueva implementación
  • runkit_function_remove() - Eliminar una definición de función


Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado

  • « runkit_function_rename
  • runkit_method_add »
  • PHP Manual
  • Funciones de runkit
  • Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado

runkit_import

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_import — Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado

Descripción

runkit_import ( string $filename , int $flags = RUNKIT_IMPORT_CLASS_METHODS ) : bool

Similar a include, sin embargo cualquier código que resida fuera de una función o clase es simplemente ignorado. Además, dependiendo del valor de flags, cualquier función o clase ya existente en el entorno de ejecución actual podría ser sobrescrito automáticamente por sus nuevas definiciones.

Parámetros

filename

El nombre de archivo desde que se va a importar las definiciones de funciones y clases

flags

Operador OR a nivel de bit de la familia de constantes RUNKIT_IMPORT_*.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de runkit_import()

<?php
// importar clases completamente
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASSES);

/* importar clases, aunque no importar sus propiedades estáticas
   (RUNKIT_IMPORT_CLASS_STATIC_PROPS está disponible desde 1.0.1) */
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASSES & ~RUNKIT_IMPORT_CLASS_STATIC_PROPS);

/* importar solamente las propiedades estáticas de las clases
   (RUNKIT_IMPORT_CLASS_STATIC_PROPS está disponible desde 1.0.1) */
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASS_STATIC_PROPS);
?>


Añadir dinámicamente un nuevo método a una clase dada

  • « runkit_import
  • runkit_method_copy »
  • PHP Manual
  • Funciones de runkit
  • Añadir dinámicamente un nuevo método a una clase dada

runkit_method_add

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_method_add — Añadir dinámicamente un nuevo método a una clase dada

Descripción

runkit_method_add ( string $classname , string $methodname , string $args , string $code , int $flags = RUNKIT_ACC_PUBLIC ) : bool

Parámetros

classname

La clase donde se va a añadir el método

methodname

El nombre del método a añadir

args

Lista de argumentos delimitados por comas para el recién creado método

code

El código a ser evaluado cuando methodname sea llamado

flags

El tipo de método a crear, puede ser RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED o RUNKIT_ACC_PRIVATE opcionalmente combinado mediante OR de bits con RUNKIT_ACC_STATIC (desde 1.0.1)

Nota:

Este parámetro sólo se usa a partir de PHP 5, ya que, antes de esta versión, todos los métodos eran públicos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de runkit_method_add()

<?php
class Ejemplo {
    function foo() {
        echo "foo!\n";
    }
}

// crear un objeto de Ejemplo
$e = new Ejemplo();

// Añadir un nuevo método público
runkit_method_add(
    'Ejemplo',
    'sumar',
    '$num1, $num2',
    'return $num1 + $num2;',
    RUNKIT_ACC_PUBLIC
);

// sumar 12 + 4
echo $e->sumar(12, 4);
?>

El resultado del ejemplo sería:

16

Ver también

  • runkit_method_copy() - Copia un método de una clase a otra
  • runkit_method_redefine() - Cambiar dinámicamente el código del método dado
  • runkit_method_remove() - Eliminar dinámicamente el método dado
  • runkit_method_rename() - Cambiar dinámicamente el nombre del método dado
  • runkit_function_add() - Añadir una nueva función, similar a create_function


Copia un método de una clase a otra

  • « runkit_method_add
  • runkit_method_redefine »
  • PHP Manual
  • Funciones de runkit
  • Copia un método de una clase a otra

runkit_method_copy

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_method_copy — Copia un método de una clase a otra

Descripción

runkit_method_copy ( string $dClass , string $dMethod , string $sClass , string $sMethod = ? ) : bool

Parámetros

dClass

Clase destino del método a copiar

dMethod

Nombre del método destino

sClass

Clase fuente del método a copiar

sMethod

Nombre del método a copiar desde la clase fuente. Si se omite este parámetro, se asume el valor de dMethod.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de runkit_method_copy()

<?php
class Foo {
    function ejemplo() {
        return "foo!\n";
    }
}

class Bar {
    // inicialmete sin métodos
}

// copiar el método ejemplo() desde la clase Foo a la clase Bar, como baz()
runkit_method_copy('Bar', 'baz', 'Foo', 'ejemplo');

// imprimir la función copiada
echo Bar::baz();
?>

El resultado del ejemplo sería:

foo!

Ver también

  • runkit_method_add() - Añadir dinámicamente un nuevo método a una clase dada
  • runkit_method_redefine() - Cambiar dinámicamente el código del método dado
  • runkit_method_remove() - Eliminar dinámicamente el método dado
  • runkit_method_rename() - Cambiar dinámicamente el nombre del método dado
  • runkit_function_copy() - Copiar una función a un nombre de función nuevo


Cambiar dinámicamente el código del método dado

  • « runkit_method_copy
  • runkit_method_remove »
  • PHP Manual
  • Funciones de runkit
  • Cambiar dinámicamente el código del método dado

runkit_method_redefine

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_method_redefine — Cambiar dinámicamente el código del método dado

Descripción

runkit_method_redefine ( string $classname , string $methodname , string $args , string $code , int $flags = RUNKIT_ACC_PUBLIC ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Parámetros

classname

La clase en la que se va a redefinir el método

methodname

El nombre del método a redefinir

args

Lista de argumentos delimitados por coma para el método redefinido

code

El nuevo código a ser evaluado cuando methodname sea llamado

flags

El método redefinido puede ser RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED o RUNKIT_ACC_PRIVATE opcionalmente combinado mediante OR de bits con RUNKIT_ACC_STATIC (desde 1.0.1)

Nota:

Este parámetro sólo se usa a partir de PHP 5, ya que, antes de esta versión, todos los métodos eran públicos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de runkit_method_redefine()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }
}

// crear un objeto de Ejemplo
$e = new Ejemplo();

// imprimir Ejemplo::foo() (antes de redefinir)
echo "Antes: " . $e->foo();

// Redefinir el método 'foo'
runkit_method_redefine(
    'Ejemplo',
    'foo',
    '',
    'return "bar!\n";',
    RUNKIT_ACC_PUBLIC
);

// imprimir Ejemplo::foo() (después de redefinir)
echo "Después: " . $e->foo();
?>

El resultado del ejemplo sería:

Antes: foo!
Después: bar!

Ver también

  • runkit_method_add() - Añadir dinámicamente un nuevo método a una clase dada
  • runkit_method_copy() - Copia un método de una clase a otra
  • runkit_method_remove() - Eliminar dinámicamente el método dado
  • runkit_method_rename() - Cambiar dinámicamente el nombre del método dado
  • runkit_function_redefine() - Reemplazar una definición de función con una nueva implementación


Eliminar dinámicamente el método dado

  • « runkit_method_redefine
  • runkit_method_rename »
  • PHP Manual
  • Funciones de runkit
  • Eliminar dinámicamente el método dado

runkit_method_remove

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_method_remove — Eliminar dinámicamente el método dado

Descripción

runkit_method_remove ( string $classname , string $methodname ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Parámetros

classname

La clase en la que se va a eliminar el método

methodname

El nombre del método a eliminar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de runkit_method_remove()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Eliminar el método 'foo'
runkit_method_remove(
    'Ejemplo',
    'foo'
);

echo implode(' ', get_class_methods('Ejemplo'));

?>

El resultado del ejemplo sería:

bar

Ver también

  • runkit_method_add() - Añadir dinámicamente un nuevo método a una clase dada
  • runkit_method_copy() - Copia un método de una clase a otra
  • runkit_method_redefine() - Cambiar dinámicamente el código del método dado
  • runkit_method_rename() - Cambiar dinámicamente el nombre del método dado
  • runkit_function_remove() - Eliminar una definición de función


Cambiar dinámicamente el nombre del método dado

  • « runkit_method_remove
  • runkit7_object_id »
  • PHP Manual
  • Funciones de runkit
  • Cambiar dinámicamente el nombre del método dado

runkit_method_rename

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_method_rename — Cambiar dinámicamente el nombre del método dado

Descripción

runkit_method_rename ( string $classname , string $methodname , string $newname ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Parámetros

classname

La clase en la que se renombrará el método

methodname

El nombre del método a renombrar

newname

El nombre nuevo a dar al método renombrado

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo derunkit_method_rename()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }
}

// Renombrar el método 'foo' a 'bar'
runkit_method_rename(
    'Ejemplo',
    'foo',
    'bar'
);

// salida de la función renombrada
echo Ejemplo::bar();
?>

El resultado del ejemplo sería:

foo!

Ver también

  • runkit_method_add() - Añadir dinámicamente un nuevo método a una clase dada
  • runkit_method_copy() - Copia un método de una clase a otra
  • runkit_method_redefine() - Cambiar dinámicamente el código del método dado
  • runkit_method_remove() - Eliminar dinámicamente el método dado
  • runkit_function_rename() - Cambiar el nombre de una función


Return the integer object handle for given object

  • « runkit_method_rename
  • runkit_superglobals »
  • PHP Manual
  • Funciones de runkit
  • Return the integer object handle for given object

runkit7_object_id

(PECL runkit7 >= Unknown)

runkit7_object_id — Return the integer object handle for given object

Descripción

runkit7_object_id ( object $obj ) : int

This function returns a unique identifier for the object. The object id is unique for the lifetime of the object. Once the object is destroyed, its id may be reused for other objects. This behavior is similar to spl_object_hash().

Parámetros

obj

Any object.

Valores devueltos

An integer identifier that is unique for each currently existing object and is always the same for each object.

Notas

Nota:

When an object is destroyed, its id may be reused for other objects.


Devolver el array indexado numéricamente de las superglobales registradas

  • « runkit7_object_id
  • runkit7_zval_inspect »
  • PHP Manual
  • Funciones de runkit
  • Devolver el array indexado numéricamente de las superglobales registradas

runkit_superglobals

(No hay información de versión disponible, podría estar únicamente en Git)

runkit_superglobals — Devolver el array indexado numéricamente de las superglobales registradas

Descripción

runkit_superglobals ( ) : array

Valores devueltos

Devuelve un array indexado numéricamente de las globales registradas actualmente, esto es, _GET, _POST, _REQUEST, _COOKIE, _SESSION, _SERVER, _ENV, _FILES

Ver también

  • Ámbito de Variable


Returns information about the passed in value with data types, reference counts, etc

  • « runkit_superglobals
  • uopz »
  • PHP Manual
  • Funciones de runkit
  • Returns information about the passed in value with data types, reference counts, etc

runkit7_zval_inspect

(PECL runkit7 >= Unknown)

runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc

Descripción

runkit7_zval_inspect ( string $value ) : array

Parámetros

value

The value to return the representation of


User Operations for Zend

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Uopz Funciones
    • uopz_add_function — Adds non-existent function or method
    • uopz_allow_exit — Allows control over disabled exit opcode
    • uopz_backup — Backup a function
    • uopz_compose — Compose a class
    • uopz_copy — Copy a function
    • uopz_del_function — Deletes previously added function or method
    • uopz_delete — Delete a function
    • uopz_extend — Extend a class at runtime
    • uopz_flags — Get or set flags on function or class
    • uopz_function — Creates a function at runtime
    • uopz_get_exit_status — Retrieve the last set exit status
    • uopz_get_hook — Gets previously set hook on function or method
    • uopz_get_mock — Get the current mock for a class
    • uopz_get_property — Gets value of class or instance property
    • uopz_get_return — Gets a previous set return value for a function
    • uopz_get_static — Gets the static variables from function or method scope
    • uopz_implement — Implements an interface at runtime
    • uopz_overload — Overload a VM opcode
    • uopz_redefine — Redefine a constant
    • uopz_rename — Rename a function at runtime
    • uopz_restore — Restore a previously backed up function
    • uopz_set_hook — Sets hook to execute when entering a function or method
    • uopz_set_mock — Use mock instead of class for new objects
    • uopz_set_property — Sets value of existing class or instance property
    • uopz_set_return — Provide a return value for an existing function
    • uopz_set_static — Sets the static variables in function or method scope
    • uopz_undefine — Undefine a constant
    • uopz_unset_hook — Removes previously set hook on function or method
    • uopz_unset_mock — Unset previously set mock
    • uopz_unset_return — Unsets a previously set return value for a function


Introducción

The uopz - User Operations for Zend - extension exposes Zend Engine functionality normally used at compilation and execution time in order to allow modification of the internal structures that represent PHP code, and for user code to interact with the VM.

uopz supports the following activities:

  • Overloading some opcodes including ZEND_EXIT and ZEND_NEW
  • Backup and restore functions and methods
  • Renaming functions and methods
  • Copying of functions and methods
  • Deletion of functions and methods
  • Redefinition of global and class constants
  • Deletion of global and class constants
  • Runtime composition and modification of classes

Nota:

All of the activities supported are compatible with opcache

Precaución

PECL uopz 6.1.1 is not compatible with Xdebug >= 2.9.4. Later uopz versions are not compatible with Xdebug < 2.9.4.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

uopz 2 requires PHP 5.4+. uopz 5.0 requires PHP 7. As of uopz 5.1, PHP 7.1+ is required.


Instalación

uopz releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/uopz.

Windows users can download prebuilt release binaries from the » PECL website.

As of uopz 5.0.0 the extension must be loaded as extension. Before this version it must be loaded as zend_extension.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

uopz Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
uopz.disable | "0" | PHP_INI_SYSTEM | Available as of uopz 5.0.2
uopz.exit | "0" | PHP_INI_SYSTEM | Available as of uopz 6.0.1
uopz.overloads | "1" | PHP_INI_SYSTEM | Available as of uopz 2.0.2. Removed as of uopz 5.0.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

uopz.disable bool

If enabled, uopz should stop having any effect on the engine.

uopz.exit bool

Whether to allow the execution of exit opcodes or not. This setting can be overridden during runtime by calling uopz_allow_exit().

uopz.exit bool

Enables the ability to use uopz_overload().

Nota: When running with OPcache enabled, it may be necessary to disable all OPcache optimizations (opcache.optimization_level=0).


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

The following opcodes are defined as constants by uopz before 5.0.0:

ZEND_EXIT (int)
Invoked by exit() and die(), receives no arguments. Return boolean true to exit, false to continue
ZEND_NEW (int)
Invoked by object construction, receives the class of object being created as the only argument
ZEND_THROW (int)
Invoked by the throw construct, receives the class of exception being thrown as the only argument
ZEND_FETCH_CLASS (int)
Invoked upon composure, receives the class the name of the class being fetched as the only argument
ZEND_ADD_TRAIT (int)
Invoked upon composure, receives the class the trait is being added to as the first argument, and the name of the trait as the second argument
ZEND_ADD_INTERFACE (int)
Invoked upon composure, receives the class the interface is being added to as the first argument, and the name of the interface as the second argument
ZEND_INSTANCEOF (int)
Invoked by instanceof operator, receives the object being verified as the first argument, and the name of the class which that object should be as the second argument

The following constants control the VM's behaviour after a user handler is invoked, be extremely careful! These constants are removed as of uopz 5.0.0.

ZEND_USER_OPCODE_CONTINUE (int)
Advance 1 opcode and continuue
ZEND_USER_OPCODE_ENTER (int)
Enter into new op_array without recursion
ZEND_USER_OPCODE_LEAVE (int)
Return to calling op_array within the same executor
ZEND_USER_OPCODE_DISPATCH (int)
Dispatch to original opcode handler
ZEND_USER_OPCODE_DISPATCH_TO (int)
Dispatch to a specific handler (OR'd with ZEND opcode constant)
ZEND_USER_OPCODE_RETURN (int)
Exit from executor (return from function)

The following modifiers are registered as constants by uopz

ZEND_ACC_PUBLIC (int)
Mark function as public, the default
ZEND_ACC_PROTECTED (int)
Mark function as protected
ZEND_ACC_PRIVATE (int)
Mark function as private
ZEND_ACC_STATIC (int)
Mark function as static
ZEND_ACC_FINAL (int)
Mark function as final
ZEND_ACC_ABSTRACT (int)
Mark function as abstract
ZEND_ACC_CLASS (int)
Dummy registered for consistency, the default kind of class entry. Removed as of uopz 5.0.0.
ZEND_ACC_INTERFACE (int)
Mark class as interface. Removed as of uopz 5.0.0.
ZEND_ACC_TRAIT (int)
Mark class as trait. Removed as of uopz 5.0.0.
ZEND_ACC_FETCH (int)
Used for getting flags only. Removed as of uopz 5.0.0.


Uopz Funciones

Tabla de contenidos

  • uopz_add_function — Adds non-existent function or method
  • uopz_allow_exit — Allows control over disabled exit opcode
  • uopz_backup — Backup a function
  • uopz_compose — Compose a class
  • uopz_copy — Copy a function
  • uopz_del_function — Deletes previously added function or method
  • uopz_delete — Delete a function
  • uopz_extend — Extend a class at runtime
  • uopz_flags — Get or set flags on function or class
  • uopz_function — Creates a function at runtime
  • uopz_get_exit_status — Retrieve the last set exit status
  • uopz_get_hook — Gets previously set hook on function or method
  • uopz_get_mock — Get the current mock for a class
  • uopz_get_property — Gets value of class or instance property
  • uopz_get_return — Gets a previous set return value for a function
  • uopz_get_static — Gets the static variables from function or method scope
  • uopz_implement — Implements an interface at runtime
  • uopz_overload — Overload a VM opcode
  • uopz_redefine — Redefine a constant
  • uopz_rename — Rename a function at runtime
  • uopz_restore — Restore a previously backed up function
  • uopz_set_hook — Sets hook to execute when entering a function or method
  • uopz_set_mock — Use mock instead of class for new objects
  • uopz_set_property — Sets value of existing class or instance property
  • uopz_set_return — Provide a return value for an existing function
  • uopz_set_static — Sets the static variables in function or method scope
  • uopz_undefine — Undefine a constant
  • uopz_unset_hook — Removes previously set hook on function or method
  • uopz_unset_mock — Unset previously set mock
  • uopz_unset_return — Unsets a previously set return value for a function


Adds non-existent function or method

  • « Uopz Funciones
  • uopz_allow_exit »
  • PHP Manual
  • Uopz Funciones
  • Adds non-existent function or method

uopz_add_function

(PECL uopz 5, PECL uopz 6)

uopz_add_function — Adds non-existent function or method

Descripción

uopz_add_function ( string $function , Closure $handler , int &$flags = ZEND_ACC_PUBLIC ) : bool
uopz_add_function ( string $class , string $function , Closure $handler , int &$flags = ZEND_ACC_PUBLIC , int &$all = true ) : bool

Adds a non-existent function or method.

Parámetros

class

The name of the class.

function

The name of the function or method.

handler

The Closure that defines the new function or method.

flags

Flags to set for the new function or method.

all

Whether all classes that descend from class will also be affected.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

uopz_add_function() throws a RuntimeException if the function or method to add already exists.

Ejemplos

Ejemplo #1 Basic uopz_add_function() Usage

<?php
uopz_add_function('foo', function () {echo 'bar';});
foo();
?>

El resultado del ejemplo sería:

bar

Ver también

  • uopz_del_function() - Deletes previously added function or method
  • uopz_set_return() - Provide a return value for an existing function


Allows control over disabled exit opcode

  • « uopz_add_function
  • uopz_backup »
  • PHP Manual
  • Uopz Funciones
  • Allows control over disabled exit opcode

uopz_allow_exit

(PECL uopz 5, PECL uopz 6)

uopz_allow_exit — Allows control over disabled exit opcode

Descripción

uopz_allow_exit ( bool $allow ) : void

By default uopz disables the exit opcode, so exit() calls are practically ignored. uopz_allow_exit() allows to control this behavior.

Parámetros

allow

Whether to allow the execution of exit opcodes or not.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 uopz_allow_exit() example

<?php
exit(1);
echo 1;
uopz_allow_exit(true);
exit(2);
echo 2;
?>

El resultado del ejemplo sería:

1

Notas

Precaución

OPcache optimizes away dead code after unconditional exit.

Ver también

  • uopz_get_exit_status() - Retrieve the last set exit status


Backup a function

  • « uopz_allow_exit
  • uopz_compose »
  • PHP Manual
  • Uopz Funciones
  • Backup a function

uopz_backup

(PECL uopz 1 >= 1.0.3, PECL uopz 2)

uopz_backup — Backup a function

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_backup ( string $function ) : void
uopz_backup ( string $class , string $function ) : void

Backup a function at runtime, to be restored on shutdown

Parámetros

class

The name of the class containing the function to backup

function

The name of the function

Valores devueltos

Ejemplos

Ejemplo #1 uopz_backup() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
?>

El resultado del ejemplo sería:

bool(true)


Compose a class

  • « uopz_backup
  • uopz_copy »
  • PHP Manual
  • Uopz Funciones
  • Compose a class

uopz_compose

(PECL uopz 1, PECL uopz 2)

uopz_compose — Compose a class

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_compose ( string $name , array $classes , array $methods = ? , array $properties = ? , int $flags = ? ) : void

Creates a new class of the given name that implements, extends, or uses all of the provided classes

Parámetros

name

A legal class name

classes

An array of class, interface and trait names

methods

An associative array of methods, values are either closures or [modifiers => closure]

properties

An associative array of properties, keys are names, values are modifiers

flags

Entry type, by default ZEND_ACC_CLASS

Valores devueltos

Ejemplos

Ejemplo #1 uopz_compose() example

<?php
class myClass {}
trait myTrait {}
interface myInterface {}

uopz_compose(
    Composed::class, [
        myClass::class,
        myTrait::class,
        myInterface::class
    ], [
    "__construct" => function() {
        /* ... */
    }
]);

var_dump(
 class_uses(Composed::class),
 class_parents(Composed::class),
 class_implements(Composed::class));
?>

El resultado del ejemplo sería:

array(1) {
  ["myTrait"]=>
  string(7) "myTrait"
}
array(1) {
  ["myClass"]=>
  string(7) "myClass"
}
array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}


Copy a function

  • « uopz_compose
  • uopz_del_function »
  • PHP Manual
  • Uopz Funciones
  • Copy a function

uopz_copy

(PECL uopz 1 >= 1.0.4, PECL uopz 2)

uopz_copy — Copy a function

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_copy ( string $function ) : Closure
uopz_copy ( string $class , string $function ) : Closure

Copy a function by name

Parámetros

class

The name of the class containing the function to copy

function

The name of the function

Valores devueltos

A Closure for the specified function

Ejemplos

Ejemplo #1 uopz_copy() example

<?php
$strtotime = uopz_copy('strtotime');

uopz_function("strtotime", function($arg1, $arg2) use($strtotime) {
    /* can call original strtotime from here */
    var_dump($arg1);
});

var_dump(strtotime('dummy'));
?>

El resultado del ejemplo sería:

string(5) "dummy"


Deletes previously added function or method

  • « uopz_copy
  • uopz_delete »
  • PHP Manual
  • Uopz Funciones
  • Deletes previously added function or method

uopz_del_function

(PECL uopz 5, PECL uopz 6)

uopz_del_function — Deletes previously added function or method

Descripción

uopz_del_function ( string $function ) : bool
uopz_del_function ( string $class , string $function , int &$all = true ) : bool

Deletes a previously added function or method.

Parámetros

class

The name of the class.

function

The name of the function or method.

all

Whether all classes that descend from class will also be affected.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

uopz_del_function() throws a RuntimeException if the function or method to delete has not been added by uopz_add_function().

Ejemplos

Ejemplo #1 Basic uopz_del_function() Usage

<?php
uopz_add_function('foo', function () {echo 'bar';});
var_dump(function_exists('foo'));
uopz_del_function('foo');
var_dump(function_exists('foo'));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ver también

  • uopz_add_function() - Adds non-existent function or method
  • uopz_unset_return() - Unsets a previously set return value for a function


Delete a function

  • « uopz_del_function
  • uopz_extend »
  • PHP Manual
  • Uopz Funciones
  • Delete a function

uopz_delete

(PECL uopz 1, PECL uopz 2)

uopz_delete — Delete a function

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_delete ( string $function ) : void
uopz_delete ( string $class , string $function ) : void

Deletes a function or method

Parámetros

class

function

Valores devueltos

Ejemplos

Ejemplo #1 uopz_delete() example

<?php
uopz_delete("strlen");

echo strlen("Hello World");
?>

El resultado del ejemplo sería algo similar a:

PHP Fatal error: Call to undefined function strlen() in /path/to/script.php on line 4

Ejemplo #2 uopz_delete() class example

<?php
class My {
    public static function strlen($arg) {
        return strlen($arg);
    }
}

uopz_delete(My::class, "strlen");

echo My::strlen("Hello World");
?>

El resultado del ejemplo sería algo similar a:

PHP Fatal error: Call to undefined method My::strlen() in /path/to/script.php on line 10


Extend a class at runtime

  • « uopz_delete
  • uopz_flags »
  • PHP Manual
  • Uopz Funciones
  • Extend a class at runtime

uopz_extend

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_extend — Extend a class at runtime

Descripción

uopz_extend ( string $class , string $parent ) : bool

Makes class extend parent

Parámetros

class

The name of the class to extend

parent

The name of the class to inherit

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

As of PHP 7.4.0, uopz_extends() throws a RuntimeException, if OPcache is enabled, and the class entry of either class or parent (if it is a trait) is immutable.

Ejemplos

Ejemplo #1 uopz_extend() example

<?php
class A {}
class B {}

uopz_extend(A::class, B::class);

var_dump(class_parents(A::class));
?>

El resultado del ejemplo sería:

array(1) {
  ["B"]=>
  string(1) "B"
}


Get or set flags on function or class

  • « uopz_extend
  • uopz_function »
  • PHP Manual
  • Uopz Funciones
  • Get or set flags on function or class

uopz_flags

(PECL uopz 2 >= 2.0.2, PECL uopz 5, PECL uopz 6)

uopz_flags — Get or set flags on function or class

Descripción

uopz_flags ( string $function , int $flags = PHP_INT_MAX ) : int
uopz_flags ( string $class , string $function , int $flags = PHP_INT_MAX ) : int

Get or set the flags on a class or function entry at runtime

Parámetros

class

The name of a class

function

The name of the function. If class is given and an empty string is passed as function, uopz_flags() gets or sets the flags of the class entry.

flags

A valid set of ZEND_ACC_ flags. If omitted, uopz_flags() acts as getter.

Valores devueltos

If setting, returns old flags, else returns flags

Errores/Excepciones

As of PHP 7.4.0, if the parameter flags is passed, uopz_flags() throws a RuntimeException, if OPcache is enabled, and the class entry of class or the function entry of function is immutable.

Historial de cambios

Versión | Descripción
PECL uopz 5.0.0 | The flags parameter is now optional. Formerly, ZEND_ACC_FETCH had to be passed to use uopz_flags() as getter.

Ejemplos

Ejemplo #1 uopz_flags() example

<?php
class Test {
    public function method() {
        return __CLASS__;
    }
}

$flags = uopz_flags("Test", "method");

var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_STATIC));

var_dump(uopz_flags("Test", "method", $flags|ZEND_ACC_STATIC|ZEND_ACC_PRIVATE));

var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_STATIC));
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
int(1234567890)
bool(true)
bool(true)

Ejemplo #2 "Unfinalize" a Class

<?php
final class MyClass
{
}

$flags = uopz_flags(MyClass::class, '');
uopz_flags(MyClass::class, '', $flags & ~ZEND_ACC_FINAL);
var_dump((new ReflectionClass(MyClass::class))->isFinal());
?>

El resultado del ejemplo sería:

bool(false)


Creates a function at runtime

  • « uopz_flags
  • uopz_get_exit_status »
  • PHP Manual
  • Uopz Funciones
  • Creates a function at runtime

uopz_function

(PECL uopz 1, PECL uopz 2)

uopz_function — Creates a function at runtime

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_function ( string $function , Closure $handler , int $modifiers = ? ) : void
uopz_function ( string $class , string $function , Closure $handler , int $modifiers = ? ) : void

Creates a function at runtime

Parámetros

class

The name of the class to receive the new function

function

The name of the function

handler

The Closure for the function

modifiers

The modifiers for the function, by default copied or ZEND_ACC_PUBLIC

Valores devueltos

Ejemplos

Ejemplo #1 uopz_function() example

<?php
uopz_function("my_strlen", function($arg) {
    return strlen($arg);
});
echo my_strlen("Hello World");
?>

El resultado del ejemplo sería:

11

Ejemplo #2 uopz_function() class example

<?php
class My {}

uopz_function(My::class, "strlen", function($arg) {
    return strlen($arg);
}, ZEND_ACC_STATIC);

echo My::strlen("Hello World");
?>

El resultado del ejemplo sería:

11


Retrieve the last set exit status

  • « uopz_function
  • uopz_get_hook »
  • PHP Manual
  • Uopz Funciones
  • Retrieve the last set exit status

uopz_get_exit_status

(PECL uopz 5, PECL uopz 6)

uopz_get_exit_status — Retrieve the last set exit status

Descripción

uopz_get_exit_status ( ) : mixed

Retrieves the last set exit status, i.e. the value passed to exit().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This function returns the last exit status, or null if exit() has not been called.

Ejemplos

Ejemplo #1 uopz_get_exit_status() example

<?php
exit(123);
echo uopz_get_exit_status();?>

El resultado del ejemplo sería:

123

Notas

Precaución

OPcache optimizes away dead code after unconditional exit.

Ver también

  • uopz_allow_exit() - Allows control over disabled exit opcode


Gets previously set hook on function or method

  • « uopz_get_exit_status
  • uopz_get_mock »
  • PHP Manual
  • Uopz Funciones
  • Gets previously set hook on function or method

uopz_get_hook

(PECL uopz 5, PECL uopz 6)

uopz_get_hook — Gets previously set hook on function or method

Descripción

uopz_get_hook ( string $function ) : Closure
uopz_get_hook ( string $class , string $function ) : Closure

Gets the previously set hook on a function or method.

Parámetros

class

The name of the class.

function

The name of the function or method.

Valores devueltos

Returns the previously set hook on a function or method, or null if no hook has been set.

Ejemplos

Ejemplo #1 Basic uopz_get_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
var_dump(uopz_get_hook('foo'));
?>

El resultado del ejemplo sería algo similar a:

object(Closure)#2 (0) {
}

Ver también

  • uopz_set_hook() - Sets hook to execute when entering a function or method
  • uopz_unset_hook() - Removes previously set hook on function or method


Get the current mock for a class

  • « uopz_get_hook
  • uopz_get_property »
  • PHP Manual
  • Uopz Funciones
  • Get the current mock for a class

uopz_get_mock

(PECL uopz 5, PECL uopz 6)

uopz_get_mock — Get the current mock for a class

Descripción

uopz_get_mock ( string $class ) : mixed

Returns the current mock for class.

Parámetros

class

The name of the mocked class.

Valores devueltos

Either a string containing the name of the mock, or an object, or null if no mock has been set.

Ejemplos

Ejemplo #1 uopz_get_mock() example

<?php
class A {
    public static function who() {
        echo "A";
    }
}

class mockA {
    public static function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
echo uopz_get_mock(A::class);
?>

El resultado del ejemplo sería:

mockA

Ver también

  • uopz_set_mock() - Use mock instead of class for new objects
  • uopz_unset_mock() - Unset previously set mock


Gets value of class or instance property

  • « uopz_get_mock
  • uopz_get_return »
  • PHP Manual
  • Uopz Funciones
  • Gets value of class or instance property

uopz_get_property

(PECL uopz 5, PECL uopz 6)

uopz_get_property — Gets value of class or instance property

Descripción

uopz_get_property ( string $class , string $property ) : mixed
uopz_get_property ( object $instance , string $property ) : mixed

Gets the value of a static class property, if class is given, or the value of an instance property, if instance is given.

Parámetros

class

The name of the class.

instance

The object instance.

property

The name of the property.

Valores devueltos

Returns the value of the class or instance property, or null if the property is not defined.

Ejemplos

Ejemplo #1 Basic uopz_get_property() Usage

<?php
class Foo {
    private static $staticBar = 10;
    private $bar = 100;
}
$foo = new Foo;
var_dump(uopz_get_property('Foo', 'staticBar'));
var_dump(uopz_get_property($foo, 'bar'));
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(100)

Ver también

  • uopz_set_property() - Sets value of existing class or instance property


Gets a previous set return value for a function

  • « uopz_get_property
  • uopz_get_static »
  • PHP Manual
  • Uopz Funciones
  • Gets a previous set return value for a function

uopz_get_return

(PECL uopz 5, PECL uopz 6)

uopz_get_return — Gets a previous set return value for a function

Descripción

uopz_get_return ( string $function ) : mixed
uopz_get_return ( string $class , string $function ) : mixed

Gets the return value of the function previously set by uopz_set_return().

Parámetros

class

The name of the class containing the function

function

The name of the function

Valores devueltos

The return value or Closure previously set.

Ejemplos

Ejemplo #1 uopz_get_return() example

<?php
uopz_set_return("strlen", 42);
echo uopz_get_return("strlen");
?>

El resultado del ejemplo sería:

42


Gets the static variables from function or method scope

  • « uopz_get_return
  • uopz_implement »
  • PHP Manual
  • Uopz Funciones
  • Gets the static variables from function or method scope

uopz_get_static

(PECL uopz 5, PECL uopz 6)

uopz_get_static — Gets the static variables from function or method scope

Descripción

uopz_get_static ( string $class , string $function ) : array
uopz_get_static ( string $function ) : array

Gets the static variables from function or method scope.

Parámetros

class

The name of the class.

function

The name of the function or method.

Valores devueltos

Returns an associative array of variable names mapped to their current values on success, or null if the function or method does not exist.

Ejemplos

Ejemplo #1 Basic uopz_get_static() Usage

<?php
function foo() {
    static $bar = 'baz';
}
var_dump(uopz_get_static('foo'));
?>

El resultado del ejemplo sería:

array(1) {
  ["bar"]=>
  string(3) "baz"
}

Ver también

  • uopz_set_static() - Sets the static variables in function or method scope


Implements an interface at runtime

  • « uopz_get_static
  • uopz_overload »
  • PHP Manual
  • Uopz Funciones
  • Implements an interface at runtime

uopz_implement

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_implement — Implements an interface at runtime

Descripción

uopz_implement ( string $class , string $interface ) : bool

Makes class implement interface

Parámetros

class

interface

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

As of PHP 7.4.0, uopz_implements() throws a RuntimeException, if OPcache is enabled, and the class entry of class is immutable.

Ejemplos

Ejemplo #1 uopz_implement() example

<?php
interface myInterface {}

class myClass {}

uopz_implement(myClass::class, myInterface::class);

var_dump(class_implements(myClass::class));
?>

El resultado del ejemplo sería:

array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}


Overload a VM opcode

  • « uopz_implement
  • uopz_redefine »
  • PHP Manual
  • Uopz Funciones
  • Overload a VM opcode

uopz_overload

(PECL uopz 1, PECL uopz 2)

uopz_overload — Overload a VM opcode

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_overload ( int $opcode , Callable $callable ) : void

Overloads the specified opcode with the user defined function

Parámetros

opcode

A valid opcode, see constants for details of supported codes

callable

Valores devueltos

Ejemplos

Ejemplo #1 uopz_overload() example

<?php
uopz_overload(ZEND_EXIT, function(){});

exit();
echo "Hello World";
?>

El resultado del ejemplo sería:

Hello World


Redefine a constant

  • « uopz_overload
  • uopz_rename »
  • PHP Manual
  • Uopz Funciones
  • Redefine a constant

uopz_redefine

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_redefine — Redefine a constant

Descripción

uopz_redefine ( string $constant , mixed $value ) : bool
uopz_redefine ( string $class , string $constant , mixed $value ) : bool

Redefines the given constant as value

Parámetros

class

The name of the class containing the constant

constant

The name of the constant

value

The new value for the constant, must be a valid type for a constant variable

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 uopz_redefine() example

<?php
define("MY", 100);

uopz_redefine("MY", 1000);

echo MY;
?>

El resultado del ejemplo sería:

1000


Rename a function at runtime

  • « uopz_redefine
  • uopz_restore »
  • PHP Manual
  • Uopz Funciones
  • Rename a function at runtime

uopz_rename

(PECL uopz 1, PECL uopz 2)

uopz_rename — Rename a function at runtime

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_rename ( string $function , string $rename ) : void
uopz_rename ( string $class , string $function , string $rename ) : void

Renames function to rename

Nota:

If both functions exist, this effectively swaps their names

Parámetros

class

The name of the class containing the function

function

The name of an existing function

rename

The new name for the function

Valores devueltos

Ejemplos

Ejemplo #1 uopz_rename() example

<?php
uopz_rename("strlen", "original_strlen");

echo original_strlen("Hello World");
?>

El resultado del ejemplo sería:

11

Ejemplo #2 uopz_rename() class example

<?php
class My {
    public function strlen($arg) {
        return strlen($arg);
    }
}

uopz_rename(My::class, "strlen", "original_strlen");

echo My::original_strlen("Hello World");
?>

El resultado del ejemplo sería:

11


Restore a previously backed up function

  • « uopz_rename
  • uopz_set_hook »
  • PHP Manual
  • Uopz Funciones
  • Restore a previously backed up function

uopz_restore

(PECL uopz 1 >= 1.0.3, PECL uopz 2)

uopz_restore — Restore a previously backed up function

Advertencia

Esta función ha sido ELIMINADA en PECL uopz 5.0.0.

Descripción

uopz_restore ( string $function ) : void
uopz_restore ( string $class , string $function ) : void

Restore a previously backed up function

Parámetros

class

The name of the class containing the function to restore

function

The name of the function

Valores devueltos

Ejemplos

Ejemplo #1 uopz_restore() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
uopz_restore('fgets');
fgets();
?>

El resultado del ejemplo sería algo similar a:

Warning: fgets() expects at least 1 parameter, 0 given in /path/to/script.php on line 8


Sets hook to execute when entering a function or method

  • « uopz_restore
  • uopz_set_mock »
  • PHP Manual
  • Uopz Funciones
  • Sets hook to execute when entering a function or method

uopz_set_hook

(PECL uopz 5, PECL uopz 6)

uopz_set_hook — Sets hook to execute when entering a function or method

Descripción

uopz_set_hook ( string $function , Closure $hook ) : bool
uopz_set_hook ( string $class , string $function , Closure $hook ) : bool

Sets a hook to execute when entering a function or method.

Parámetros

class

The name of the class.

function

The name of the function or method.

hook

A closure to execute when entering the function or method.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Basic uopz_set_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
foo();
?>

El resultado del ejemplo sería:

barfoo

Ver también

  • uopz_get_hook() - Gets previously set hook on function or method
  • uopz_unset_hook() - Removes previously set hook on function or method


Use mock instead of class for new objects

  • « uopz_set_hook
  • uopz_set_property »
  • PHP Manual
  • Uopz Funciones
  • Use mock instead of class for new objects

uopz_set_mock

(PECL uopz 5, PECL uopz 6)

uopz_set_mock — Use mock instead of class for new objects

Descripción

uopz_set_mock ( string $class , mixed $mock ) : void

If mock is a string containing the name of a class then it will be instantiated instead of class. mock can also be an object.

Nota:

Only dynamic access to properties and methods will use the mock object. Static access still uses the original class. See example below.

Parámetros

class

The name of the class to be mocked.

mock

The mock to use in the form of a string containing the name of the class to use or an object. If a string is passed, it has to be the fully qualified class name. It is recommended to use the ::class magic constant in this case.

Historial de cambios

Versión | Descripción
uopz 6.0.0 | Mocking static members is no longer supported by this function. uopz_redefine() and uopz_set_return(), or Componere can be used instead.

Ejemplos

Ejemplo #1 uopz_set_mock() example

<?php
class A {
    public function who() {
        echo "A";
    }
}

class mockA {
    public function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
(new A)->who();
?>

El resultado del ejemplo sería:

mockA

Ejemplo #2 uopz_set_mock() example

<?php
class A {
    public function who() {
        echo "A";
    }
}

uopz_set_mock(A::class, new class {
                            public function who() {
                                echo "mockA";
                            }
                        });
(new A)->who();
?>

El resultado del ejemplo sería:

mockA

Ejemplo #3 uopz_set_mock() and static members

As of uopz 6.0.0 mocking static members is no longer supported.

<?php
class A {
    const CON = 'A';
    public static function who() {
        echo "A";
    }
}

uopz_set_mock(A::class, new class {
                            const CON = 'mockA';
                            public static function who() {
                                echo "mockA";
                            }
                        });
echo A::CON, PHP_EOL;
A::who();
?>

El resultado del ejemplo sería:

A
A

Output of the above example in uopz 5:

mockA
mockA

Ver también

  • uopz_get_mock() - Get the current mock for a class
  • uopz_unset_mock() - Unset previously set mock


Sets value of existing class or instance property

  • « uopz_set_mock
  • uopz_set_return »
  • PHP Manual
  • Uopz Funciones
  • Sets value of existing class or instance property

uopz_set_property

(PECL uopz 5, PECL uopz 6)

uopz_set_property — Sets value of existing class or instance property

Descripción

uopz_set_property ( string $class , string $property , mixed $value ) : void
uopz_set_property ( object $instance , string $property , mixed $value ) : void

Sets the value of an existing static class property, if class is given, or the value of an instance property (regardless whether the instance property already exists), if instance is given.

Parámetros

class

The name of the class.

instance

The object instance.

property

The name of the property.

value

The value to assign to the property.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Basic uopz_set_property() Usage

<?php
class Foo {
   private static $staticBar;
   private $bar;
   public static function testStaticBar() {
      return self::$staticBar;
   }
   public function testBar() {
      return $this->bar;
   }
}
$foo = new Foo;
uopz_set_property('Foo', 'staticBar', 10);
uopz_set_property($foo, 'bar', 100);
var_dump(Foo::testStaticBar());
var_dump($foo->testBar());
?>

El resultado del ejemplo sería:

int(10)

Ver también

  • uopz_get_property() - Gets value of class or instance property


Provide a return value for an existing function

  • « uopz_set_property
  • uopz_set_static »
  • PHP Manual
  • Uopz Funciones
  • Provide a return value for an existing function

uopz_set_return

(PECL uopz 5, PECL uopz 6)

uopz_set_return — Provide a return value for an existing function

Descripción

uopz_set_return ( string $function , mixed $value , bool $execute = false ) : bool
uopz_set_return ( string $class , string $function , mixed $value , bool $execute = false ) : bool

Sets the return value of the function to value. If value is a Closure and execute is set, the Closure will be executed in place of the original function. It is possible to call the original function from the Closure.

Nota:

This function replaces uopz_rename().

Parámetros

class

The name of the class containing the function

function

The name of an existing function

value

The value the function should return. If a Closure is provided and the execute flag is set, the Closure will be executed in place of the original function.

execute

If true, and a Closure was provided as the value, the Closure will be executed in place of the original function.

Valores devueltos

True if succeeded, false otherwise.

Ejemplos

Ejemplo #1 uopz_set_return() example

<?php
uopz_set_return("strlen", 42);
echo strlen("Banana");
?>

El resultado del ejemplo sería:

42

Ejemplo #2 uopz_set_return() example

<?php
uopz_set_return("strlen", function($str) { return strlen($str) * 2; }, true );
echo strlen("Banana");
?>

El resultado del ejemplo sería:

12

Ejemplo #3 uopz_set_return() class example

<?php
class My {
    public static function strlen($arg) {
        return strlen($arg);
    }
}
uopz_set_return(My::class, "strlen", function($str) { return strlen($str) * 2; }, true );
echo My::strlen("Banana");
?>

El resultado del ejemplo sería:

12


Sets the static variables in function or method scope

  • « uopz_set_return
  • uopz_undefine »
  • PHP Manual
  • Uopz Funciones
  • Sets the static variables in function or method scope

uopz_set_static

(PECL uopz 5, PECL uopz 6)

uopz_set_static — Sets the static variables in function or method scope

Descripción

uopz_set_static ( string $function , array $static ) : void
uopz_set_static ( string $class , string $function , array $static ) : void

Sets the static variables in function or method scope.

Parámetros

class

The name of the class.

function

The name of the function or method.

static

The associative array of variable names mapped to their values.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Basic uopz_set_static() Usage

<?php
function foo() {
    static $bar = 'baz';
    var_dump($bar);
}
uopz_set_static('foo', ['bar' => 'qux']);
foo();
?>

El resultado del ejemplo sería:

string(3) "qux"

Ver también

  • uopz_get_static() - Gets the static variables from function or method scope


Undefine a constant

  • « uopz_set_static
  • uopz_unset_hook »
  • PHP Manual
  • Uopz Funciones
  • Undefine a constant

uopz_undefine

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_undefine — Undefine a constant

Descripción

uopz_undefine ( string $constant ) : bool
uopz_undefine ( string $class , string $constant ) : bool

Removes the constant at runtime

Parámetros

class

The name of the class containing constant

constant

The name of an existing constant

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 uopz_undefine() example

<?php
define("MY", true);

uopz_undefine("MY");

var_dump(defined("MY"));
?>

El resultado del ejemplo sería:

bool(false)


Removes previously set hook on function or method

  • « uopz_undefine
  • uopz_unset_mock »
  • PHP Manual
  • Uopz Funciones
  • Removes previously set hook on function or method

uopz_unset_hook

(PECL uopz 5, PECL uopz 6)

uopz_unset_hook — Removes previously set hook on function or method

Descripción

uopz_unset_hook ( string $function ) : bool
uopz_unset_hook ( string $class , string $function ) : bool

Removes the previously set hook on a function or method.

Parámetros

class

The name of the class.

function

The name of the function or method.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Basic uopz_unset_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
foo();
echo PHP_EOL;
uopz_unset_hook('foo');
foo();
?>

El resultado del ejemplo sería:

barfoo
foo

Ver también

  • uopz_set_hook() - Sets hook to execute when entering a function or method
  • uopz_get_hook() - Gets previously set hook on function or method


Unset previously set mock

  • « uopz_unset_hook
  • uopz_unset_return »
  • PHP Manual
  • Uopz Funciones
  • Unset previously set mock

uopz_unset_mock

(PECL uopz 5, PECL uopz 6)

uopz_unset_mock — Unset previously set mock

Descripción

uopz_unset_mock ( string $class ) : void

Unsets the previously set mock for class.

Parámetros

class

The name of the mocked class.

Errores/Excepciones

A RuntimeException is thrown, if no mock was previously set for class.

Ejemplos

Ejemplo #1 uopz_unset_mock() example

<?php
class A {
    public static function who() {
        echo "A";
    }
}

class mockA {
    public static function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
uopz_unset_mock(A::class);
A::who();
?>

El resultado del ejemplo sería:

A

Ver también

  • uopz_set_mock() - Use mock instead of class for new objects
  • uopz_get_mock() - Get the current mock for a class


Unsets a previously set return value for a function

  • « uopz_unset_mock
  • Weakref »
  • PHP Manual
  • Uopz Funciones
  • Unsets a previously set return value for a function

uopz_unset_return

(PECL uopz 5, PECL uopz 6)

uopz_unset_return — Unsets a previously set return value for a function

Descripción

uopz_unset_return ( string $function ) : bool
uopz_unset_return ( string $class , string $function ) : bool

Unsets the return value of the function previously set by uopz_set_return().

Parámetros

class

The name of the class containing the function

function

The name of the function

Valores devueltos

True on success

Ejemplos

Ejemplo #1 uopz_unset_return() example

<?php
uopz_set_return("strlen", 42);
$len = strlen("Banana");
uopz_unset_return("strlen");
echo $len + strlen("Banana");
?>

El resultado del ejemplo sería:

48


Referencias débiles

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Tipos de recursos
  • WeakRef — La clase WeakRef
    • Weakref::acquire — Adquiere una referencia fuerte de un objeto
    • Weakref::__construct — Construye una nueva referencia débil
    • Weakref::get — Devuelve el objeto apuntado por una referencia débil
    • Weakref::release — Libera una referencia previmente adquirida
    • Weakref::valid — Comprueba si el objeto referenciado aún existe
  • WeakMap — La clase WeakMap
    • WeakMap::__construct — Construye un nuevo mapa
    • WeakMap::count — Cuenta el número de entradas vivas de un mapa
    • WeakMap::current — Devuelve el valor actual de la iteración
    • WeakMap::key — Devuelve la clave actual de la iteración
    • WeakMap::next — Avanza al siguiente elemento del mapa
    • WeakMap::offsetExists — Comprueba si un cierto objeto está en un mapa
    • WeakMap::offsetGet — Devuelve el valor apuntado por un cierto objeto
    • WeakMap::offsetSet — Actualiza el mapa con un nuevo par clave-valor
    • WeakMap::offsetUnset — Elimina una entrada del mapa
    • WeakMap::rewind — Sitúa el iterador al comienzo del mapa
    • WeakMap::valid — Devuelve si el iterador aún está sobre un elemento válido de un mapa


Introducción

Las referencias débiles proporcionan una vía no invasiva para objetos efímeros. A diferencia de las referencias normales (fuertes), las referencias débiles no evita que el recolector de basura libere un objeto. Por esta razón, un objeto podría ser destruido aunque aún exista una referencia débil a tal objeto. En tales condiciones, la referencia débil sería perfectamente inválida.

Ejemplo #1 Ejemplo de uso de Weakref

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto está muerto!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto está muerto!\n";
}
?>

El resultado del ejemplo sería:

¡El objeto aún existe!
object(MiClase)#1 (0) {
}
¡Destruyendo el objeto!
¡El objeto está muerto!


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Tipos de recursos


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/weakref.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Instalación
  • WeakRef »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


La clase WeakRef

(PECL weakref >= 0.1.0)

Introducción

La clase WeakRef proporciona una vía para objetos sin evitar que el recolector de basura libere tales objetos. También proporciona una manera de convertir una referencia débil en una fuerte.

Nota:

La clase WeakRef no debe confundirse con la clase WeakReference.

Sinopsis de la Clase

WeakRef {
/* Métodos */
public Weakref::__construct ( object $object )
public Weakref::acquire ( ) : bool
public Weakref::get ( ) : object
public Weakref::release ( ) : bool
public Weakref::valid ( ) : bool
}

Ejemplos

Ejemplo #1 Ejemplo de uso de WeakRef

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto está muerto!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto está muerto!\n";
}
?>

El resultado del ejemplo sería:

¡El objeto aún existe!
object(MiClase)#1 (0) {
}
¡Destruyendo el objeto!
¡El objeto está muerto!

Tabla de contenidos

  • Weakref::acquire — Adquiere una referencia fuerte de un objeto
  • Weakref::__construct — Construye una nueva referencia débil
  • Weakref::get — Devuelve el objeto apuntado por una referencia débil
  • Weakref::release — Libera una referencia previmente adquirida
  • Weakref::valid — Comprueba si el objeto referenciado aún existe


Adquiere una referencia fuerte de un objeto

  • « WeakRef
  • Weakref::__construct »
  • PHP Manual
  • WeakRef
  • Adquiere una referencia fuerte de un objeto

Weakref::acquire

(PECL weakref >= 0.1.0)

Weakref::acquire — Adquiere una referencia fuerte de un objeto

Descripción

public Weakref::acquire ( ) : bool

Adquiere una referencia fuerte de un objeto, convirtiendo virtualmente la referencia débil en una fuerte.

La instancia de Weakref guarda un contador de adquiridas interno para el seguimiento de referencias fuertes pendientes. Si la llamada a Weakref::acquire() tiene éxito, este contador se incrementará en uno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la referencia era válida y pudo ser convertida a una referencia fuerte, de lo contrario false.

Ejemplos

Ejemplo #1 Ejemplo de Weakref::acquire()

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Destruyendo o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Destruyendo o2...\n";
unset($o2);
?>

El resultado del ejemplo sería:

Destruyendo  o1...
Destruyendo  o2...
¡Destruyendo el objeto!

Ejemplo #2 Ejemplo de acquire/release anidados

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

echo "Adquiriendo...\n";
$r1->acquire();

echo "  Destruyendo...\n";
unset($o1);

echo "  Adquiriendo...\n";
$r1->acquire();

echo "    Adquiriendo...\n";
$r1->acquire();

echo "    Liberando...\n";
$r1->release();

echo "  Liberando...\n";
$r1->release();

echo "Liberando...\n";
$r1->release();

?>

El resultado del ejemplo sería:

Adquiriendo...
  Destruyendo...
  Adquiriendo...
    Adquiriendo...
    Liberando...
  Liberando...
Liberando...
¡Destruyendo el objeto!

Ver también

  • Weakref::release() - Libera una referencia previmente adquirida


Construye una nueva referencia débil

  • « Weakref::acquire
  • Weakref::get »
  • PHP Manual
  • WeakRef
  • Construye una nueva referencia débil

Weakref::__construct

(PECL weakref >= 0.1.0)

Weakref::__construct — Construye una nueva referencia débil

Descripción

public Weakref::__construct ( object $object )

Construye una nueva referencia débil.

Parámetros

object

El objeto al que hacer referencia.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de Weakref::__construct()

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto se ha eliminado!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "¡El objeto aún existe!\n";
    var_dump($r1->get());
} else {
    echo "¡El objeto se ha eliminado!\n";
}
?>

El resultado del ejemplo sería:

¡El objeto aún existe!
object(MiClase)#1 (0) {
}
¡Destruyendo el objeto!
¡El objeto se ha eliminado!


Devuelve el objeto apuntado por una referencia débil

  • « Weakref::__construct
  • Weakref::release »
  • PHP Manual
  • WeakRef
  • Devuelve el objeto apuntado por una referencia débil

Weakref::get

(PECL weakref >= 0.1.0)

Weakref::get — Devuelve el objeto apuntado por una referencia débil

Descripción

public Weakref::get ( ) : object

Devuelve el objeto apuntado por una referencia débil.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el objeto si la referencia aún es válida, o null en caso contrario.

Ver también

  • Weakref::valid() - Comprueba si el objeto referenciado aún existe


Libera una referencia previmente adquirida

  • « Weakref::get
  • Weakref::valid »
  • PHP Manual
  • WeakRef
  • Libera una referencia previmente adquirida

Weakref::release

(PECL weakref >= 0.1.0)

Weakref::release — Libera una referencia previmente adquirida

Descripción

public Weakref::release ( ) : bool

Libera una referencia previmente adquirida, potencialmente, volviendo a convertir una referencia fuerte en una débil.

The Weakref instance maintains an internal acquired counter to track outstanding strong references. If the call to Weakref::release() is successful, this counter will be decremented by one. Once this counter reaches zero, the strong reference is turned back into a weak reference. La instancia de Weakref guarda un contador de adquiridas interno para el seguimiento de referencias fuertes pendientes. Si la llamada a Weakref::release() tiene éxito, este contador se decrementará en uno. Una vez este contador llegue a cero, la referencia fuerte se volverá a convertir en una referencia débil.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la referencia fue previamente adquirida y pudo ser liberada, de lo contrario false.

Ejemplos

Ejemplo #1 Ejemplo de Weakref::release()

<?php
class MiClase {
    public function __destruct() {
        echo "¡Destruyendo el objeto!\n";
    }
}

$o1 = new MiClase;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Detruyendo o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Detruyendo o2...\n";
unset($o2);
?>

El resultado del ejemplo sería:

Detruyendo o1...
Detruyendo o2...
¡Destruyendo el objeto!

Ver también

  • Weakref::acquire() - Adquiere una referencia fuerte de un objeto


Comprueba si el objeto referenciado aún existe

  • « Weakref::release
  • WeakMap »
  • PHP Manual
  • WeakRef
  • Comprueba si el objeto referenciado aún existe

Weakref::valid

(PECL weakref >= 0.1.0)

Weakref::valid — Comprueba si el objeto referenciado aún existe

Descripción

public Weakref::valid ( ) : bool

Comprueba si el objeto referenciado aún existe.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el objeto aún existe y es accesible mediante Weakref::get(), o false en caso contrario.

Ver también

  • Weakref::get() - Devuelve el objeto apuntado por una referencia débil


La clase WeakMap

(PECL weakref >= 0.2.0)

Introducción

Sinopsis de la Clase

WeakMap implements Countable , ArrayAccess , Iterator {
/* Métodos */
public __construct ( )
public count ( ) : int
public current ( ) : mixed
public key ( ) : object
public next ( ) : void
public offsetExists ( object $object ) : bool
public offsetGet ( object $object ) : mixed
public offsetSet ( object $object , mixed $value ) : void
public offsetUnset ( object $object ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Ejemplos

Ejemplo #1 Ejemplo de uso de Weakmap

<?php
$wm = new WeakMap();

$o = new StdClass;

class A {
    public function __destruct() {
        echo "¡Muerto!\n";
    }
}

$wm[$o] = new A;

var_dump(count($wm));
echo "Destruyendo..\n";
unset($o);
echo "Hecho\n";
var_dump(count($wm));

El resultado del ejemplo sería:

int(1)
Destruyendo..
¡Muerto!
Hecho
int(0)

Tabla de contenidos

  • WeakMap::__construct — Construye un nuevo mapa
  • WeakMap::count — Cuenta el número de entradas vivas de un mapa
  • WeakMap::current — Devuelve el valor actual de la iteración
  • WeakMap::key — Devuelve la clave actual de la iteración
  • WeakMap::next — Avanza al siguiente elemento del mapa
  • WeakMap::offsetExists — Comprueba si un cierto objeto está en un mapa
  • WeakMap::offsetGet — Devuelve el valor apuntado por un cierto objeto
  • WeakMap::offsetSet — Actualiza el mapa con un nuevo par clave-valor
  • WeakMap::offsetUnset — Elimina una entrada del mapa
  • WeakMap::rewind — Sitúa el iterador al comienzo del mapa
  • WeakMap::valid — Devuelve si el iterador aún está sobre un elemento válido de un mapa


Construye un nuevo mapa

  • « WeakMap
  • WeakMap::count »
  • PHP Manual
  • WeakMap
  • Construye un nuevo mapa

WeakMap::__construct

(PECL weakref >= 0.2.0)

WeakMap::__construct — Construye un nuevo mapa

Descripción

public WeakMap::__construct ( )

Construye un nuevo mapa.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Cuenta el número de entradas vivas de un mapa

  • « WeakMap::__construct
  • WeakMap::current »
  • PHP Manual
  • WeakMap
  • Cuenta el número de entradas vivas de un mapa

WeakMap::count

(PECL weakref >= 0.2.0)

WeakMap::count — Cuenta el número de entradas vivas de un mapa

Descripción

public WeakMap::count ( ) : int

Cuenta el número de entradas vivas de un mapa.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de entradas vivas de un mapa.


Devuelve el valor actual de la iteración

  • « WeakMap::count
  • WeakMap::key »
  • PHP Manual
  • WeakMap
  • Devuelve el valor actual de la iteración

WeakMap::current

(PECL weakref >= 0.2.0)

WeakMap::current — Devuelve el valor actual de la iteración

Descripción

public WeakMap::current ( ) : mixed

Devuelve el valor actual del mapa que está siendo iterado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor actual que está siendo iterado.


Devuelve la clave actual de la iteración

  • « WeakMap::current
  • WeakMap::next »
  • PHP Manual
  • WeakMap
  • Devuelve la clave actual de la iteración

WeakMap::key

(PECL weakref >= 0.2.0)

WeakMap::key — Devuelve la clave actual de la iteración

Descripción

public WeakMap::key ( ) : object

Devuelve el objeot que sirve como clave del mapa, en la posición actual de la iteración.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave del objeto que está siendo iterado.


Avanza al siguiente elemento del mapa

  • « WeakMap::key
  • WeakMap::offsetExists »
  • PHP Manual
  • WeakMap
  • Avanza al siguiente elemento del mapa

WeakMap::next

(PECL weakref >= 0.2.0)

WeakMap::next — Avanza al siguiente elemento del mapa

Descripción

public WeakMap::next ( ) : void

Avanza al siguiente elemento del mapa.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Comprueba si un cierto objeto está en un mapa

  • « WeakMap::next
  • WeakMap::offsetGet »
  • PHP Manual
  • WeakMap
  • Comprueba si un cierto objeto está en un mapa

WeakMap::offsetExists

(PECL weakref >= 0.2.0)

WeakMap::offsetExists — Comprueba si un cierto objeto está en un mapa

Descripción

public WeakMap::offsetExists ( object $object ) : bool

Comprueba si el objeto pasado está referenciado en el mapa.

Parámetros

object

El objeto que comprobar.

Valores devueltos

Devuelve true si el objeto está contenido en el mapa, false en caso contrario.


Devuelve el valor apuntado por un cierto objeto

  • « WeakMap::offsetExists
  • WeakMap::offsetSet »
  • PHP Manual
  • WeakMap
  • Devuelve el valor apuntado por un cierto objeto

WeakMap::offsetGet

(PECL weakref >= 0.2.0)

WeakMap::offsetGet — Devuelve el valor apuntado por un cierto objeto

Descripción

public WeakMap::offsetGet ( object $object ) : mixed

Devuelve el valor apuntado por un cierto objeto.

Parámetros

object

Algún objeto contenido como clave del mapa.

Valores devueltos

Devuelve el valor asociado al objeto pasado como argumento, o null en caso contrario.


Actualiza el mapa con un nuevo par clave-valor

  • « WeakMap::offsetGet
  • WeakMap::offsetUnset »
  • PHP Manual
  • WeakMap
  • Actualiza el mapa con un nuevo par clave-valor

WeakMap::offsetSet

(PECL weakref >= 0.2.0)

WeakMap::offsetSet — Actualiza el mapa con un nuevo par clave-valor

Descripción

public WeakMap::offsetSet ( object $object , mixed $value ) : void

Actualiza el mapa con un nuevo par clave-valor. Si la clave ya existiera en el mapa, el valor antiguo se reemplazaría con el nuevo.

Parámetros

object

El objeto que sirve como clave del par clave-valor.

value

Los datos arbitrarios que sirven como valor del par clave-valor.

Valores devueltos

No devuelve ningún valor.


Elimina una entrada del mapa

  • « WeakMap::offsetSet
  • WeakMap::rewind »
  • PHP Manual
  • WeakMap
  • Elimina una entrada del mapa

WeakMap::offsetUnset

(PECL weakref >= 0.2.0)

WeakMap::offsetUnset — Elimina una entrada del mapa

Descripción

public WeakMap::offsetUnset ( object $object ) : void

Elimina una entrada del mapa.

Parámetros

object

El objeto clave a eliminar del mapa.

Valores devueltos

No devuelve ningún valor.


Sitúa el iterador al comienzo del mapa

  • « WeakMap::offsetUnset
  • WeakMap::valid »
  • PHP Manual
  • WeakMap
  • Sitúa el iterador al comienzo del mapa

WeakMap::rewind

(PECL weakref >= 0.2.0)

WeakMap::rewind — Sitúa el iterador al comienzo del mapa

Descripción

public WeakMap::rewind ( ) : void

Sitúa el iterador al comienzo del mapa.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Devuelve si el iterador aún está sobre un elemento válido de un mapa

  • « WeakMap::rewind
  • WinCache »
  • PHP Manual
  • WeakMap
  • Devuelve si el iterador aún está sobre un elemento válido de un mapa

WeakMap::valid

(PECL weakref >= 0.2.0)

WeakMap::valid — Devuelve si el iterador aún está sobre un elemento válido de un mapa

Descripción

public WeakMap::valid ( ) : bool

Devuelve si el iterador aún está sobre un elemento válido de un mapa.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el iterador está sobre un elemento válido al que se puede acceder, false en caso contrario.


Caché de Windows para PHP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • WinCache Statistics Script
    • WinCache Session Handler
    • WinCache Functions Reroutes
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de WinCache
    • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo — Recupera información sobre el uso de memoria caché de ficheros
    • wincache_lock — Obtiene un bloqueo exclusivo en una clave dada
    • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
    • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info — Retrieves information about files cached in the session cache
    • wincache_scache_meminfo — Recupera información sobre el uso de memoria caché de sesión
    • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas — Compara la variable con el valor antiguo y le asigna un nuevo valor a este
    • wincache_ucache_clear — Elimina todo el contenido de la caché del usuario
    • wincache_ucache_dec — Disminuye el valor asociado a la clave
    • wincache_ucache_delete — Elimina las variables de la memoria caché del usuario
    • wincache_ucache_exists — Comprueba si una variable existe en la caché del usuario
    • wincache_ucache_get — Obtiene una variable almacenada en la caché del usuario
    • wincache_ucache_inc — Incrementa el valor asociado a la clave
    • wincache_ucache_info — Recupera información sobre los datos almacenados en la caché del usuario
    • wincache_ucache_meminfo — Recupera información sobre el uso de memoria caché de usuario
    • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock — Libera un bloqueo exclusivo sobre una clave dada
  • Building for Windows
    • Prerequisites
    • Compiling and building
    • Verifying the build


Introducción

La Extensión de Caché de Windows para PHP es un acelerador de PHP utilizado para incrementar la velocidad de las aplicaciones de PHP que se ejecutan sobre Windows y Windows Server. Una vez que la Extensión de Caché de Windows para PHP está habilitada y cargada por el motor de PHP, las aplicaciones de PHP se podrán aprovechar de la funcionalidad sin ninguna modificación en el código.

La Extensión de Caché de Windows para PHP incluye 5 tipos diferentes de cachés. A continuación se describe el propósito de cada tipo de caché y los beneficios que ofrece.

  • Caché de opcodes de PHP - PHP es un motor de procesamiento de scripts que lee un flujo de datos de entrada que contiene texto, instrucciones de PHP, o ambas, y produce otro flujo de datos, generalmente en formato HTML. Esto significa que, en un servidor web, el motor de PHP lee, analiza, compila y ejecuta un script de PHP cada vez que es solicitado por un cliente web. Las operaciones de lectura, análisis y compilación añaden una carga adicional a la CPU del servidor web y del sistema de ficheros y por tanto afectar al rendimiento global de una aplicación web PHP. La caché de bytecodes (opcodes) de PHP se utiliza para almacenar, en memoria compartida, el script de bytecodes ya compilado de manera que pueda ser re-utilizado por el motor de PHP para ejecuciones posteriores del mismo script.

    El soporte para el almacenamiento en caché de opcode fue eliminado en Wincache 2.0.0, todos los usuarios que desean tener un opcache debe utilizar la extensión OPcache que se incluye en PHP a partir de PHP 5.5.0.

  • Caché de Fichero - Incluso con la caché de opcodes de PHP activada, en un sistema de ficheros el motor de PHP, debe acceder a los ficheros de script. Cuando los script de PHP son almacenados en un UNC remoto de compartición de ficheros, las operaciones sobre ficheros introducen una considerable sobrecarga de rendimiento. La Extensión de Caché de Windows para PHP incluye una caché de ficheros que es utilizada para almacenar los contenidos de los ficheros de script de PHP en memoria compartida, lo que reduce la cantidad de operaciones en el sistema de ficheros realizado por el motor de PHP.

  • Caché de Resolución de Rutas de Ficheros - Los script de PHP a menudo incluyen u operan con ficheros mediante el uso de rutas relativas. Cada ruta de fichero debe ser normalizada por el motor de PHP a una ruta de fichero absoluta. Cuando una aplicación de PHP emplea muchos ficheros PHP y accede a ellos mediante rutas relativas, el tener que resolver las rutas puede afectar de manera negativa al rendimiento de la aplicación. La Extensión de Caché de Windows para PHP ofrece una caché de Resolución de Rutas de Ficheros, que se emplea para almacenar los mapeos entre las rutas relativas de ficheros y las absolutas, reduciendo por tanto la cantidad de resoluciones de rutas que el motor de PHP tiene que realizar.

  • Caché de Usuario (disponible desde la versión 1.1.0) - Los scripts de PHP pueden aprovecharse de la caché de la memoria compartida mediante el uso del API de la caché de usuario. Los objetos PHP y las variables se pueden almacenar en la caché de usuario y ser reutilizadas en posteriores peticiones. Esto se puede emplear para mejorar el rendimiento de los script de PHP y para compartir datos entre múltiples procesos de PHP.

  • Gestor de Sesión (disponible desde la versión 1.1.0) - El gestor de sesión WinCache se puede emplear para almacenar los datos de la sesión PHP en la memoria compartida. Esto evita operaciones del sistema de ficheros para leer y escribir datos de sesión, lo que mejora el rendimiento cuando se almacenan grandes cantidades de datos en la sesión de PHP.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución
  • WinCache Statistics Script
  • WinCache Session Handler
  • WinCache Functions Reroutes
  • Tipos de recursos


Requerimientos

The extension is currently supported only on the following configurations:

Windows OS:

  • Windows XP SP3 with IIS 5.1 and » FastCGI Extension
  • Windows Server 2003 with IIS 6.0 and » FastCGI Extension
  • Windows Vista SP1 with IIS 7.0 and FastCGI Module
  • Windows Server 2008 with IIS 7.0 and FastCGI Module
  • Windows 7 with IIS 7.5 and FastCGI Module
  • Windows Server 2008 R2 with IIS 7.5 and FastCGI Module

PHP:

  • PHP 5.2.X, Non-thread-safe build
  • PHP 5.3 X86, Non-thread-safe VC9 build

Nota: The WinCache Extension can only be used when IIS is configured to run PHP via FastCGI.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/wincache.

There are two packages for this extension: one package is for PHP versions 5.2.X, and the other package is for PHP 5.3.X. Select the package that is appropriate for the PHP version being used.

To install and enable the extension, follow these steps:

  1. Unpack the package into some temporary location.

  2. Copy the php_wincache.dll file into the PHP extensions folder. Typically this folder is called "ext" and it is located in the same folder with all PHP binary files. For example: C:\Program Files\PHP\ext.

  3. Using a text editor, open the php.ini file, which is usually located in the same folder where all PHP binary files are. For example: C:\Program Files\PHP\php.ini.

  4. Add the following line at the end of the php.ini file: extension = php_wincache.dll.

  5. Save and close the php.ini file.

  6. Recycle the IIS Application Pools for PHP to pick up the configuration changes. To check that the extension has been enabled, create a file called phpinfo.php with a PHP code that calls phpinfo function.

  7. Save the phpinfo.php file in the root folder of a IIS web site that uses PHP, then open a browser and make a request to http://localhost/phpinfo.php. Search within the returned web page for a section called wincache. If the extension is enabled, then the phpinfo output will list the configuration settings provided by the WinCache.

Nota: Do not forget to remove phpinfo.php file from the web site's root folder after verifying that extension has been enabled.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

La siguiente tabla enumera y explica los ajustes de configuración proporcionados por la extensión WinCache:

Opciones de configuración de WinCache
Nombre | Por defecto | Mínimo | Máximo | Cambiable | Historial de cambios
wincache.fcenabled | "1" | "0" | "1" | PHP_INI_ALL | Disponible a partir de WinCache 1.0.0
wincache.fcenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.fcachesize | "24" | "5" | "255" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.fcndetect | "1" | "0" | "1" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.1.0
wincache.maxfilesize | "256" | "10" | "2048" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.ocenabled | "1" | "0" | "1" | PHP_INI_ALL | Disponible a partir de WinCache 1.0.0. Eliminada a partir de 2.0.0.0
wincache.ocenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0. Eliminada a partir de 2.0.0.0
wincache.ocachesize | "96" | "15" | "255" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0. Eliminada a partir de 2.0.0.0
wincache.filecount | "4096" | "1024" | "16384" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.chkinterval | "30" | "0" | "300" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.ttlmax | "1200" | "0" | "7200" | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.enablecli | 0 | 0 | 1 | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.ignorelist | NULL | NULL | NULL | PHP_INI_ALL | Disponible a partir de WinCache 1.0.0
wincache.namesalt | NULL | NULL | NULL | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.0.0
wincache.ucenabled | 1 | 0 | 1 | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.1.0
wincache.ucachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.1.0
wincache.scachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.1.0
wincache.rerouteini | NULL | NULL | NULL | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.2.0. Eliminada a partir de 1.3.7
wincache.reroute_enabled | 1 | 0 | 1 | PHP_INI_SYSTEM | PHP_INI_PERDIR | Disponible a partir de WinCache 1.3.7
wincache.srwlocks | 1 | 0 | 1 | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.3.6.3. Eliminada a partir de 2.0.0.0
wincache.filemapdir | NULL | NULL | NULL | PHP_INI_SYSTEM | Disponible a partir de WinCache 1.3.7.4
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

wincache.fcenabled boolean
Habilita o deshabilita la caché de ficheros.
wincache.fcenabledfilter string
Define una lista separada por comas de identificadores de sitios web de IIS donde debería habilitarse o deshabilitarse la caché de ficheros. Esta opción funciona junto con wincache.fcenabled: si wincache.fcenabled se establece a 1, los sitios enumerados en wincache.fcenabledfilter tendrán la caché de ficheros desactivada; si wincache.fcenabled se establece a 0, los sitios enumerados en wincache.fcenabledfilter tendrán la caché activada.
wincache.fcachesize integer
Define el tamaño máximo de memoria (en megabytes) que se asigna a la caché de ficheros. Si el tamaño total de ficheros en caché excede el valor especificado en este ajuste, se eliminarán los ficheros más antiguos de la caché de ficheros.
wincache.fcndetect boolean
Habilita o deshabilita la detección de notificaciones de cambios en ficheros. Si está soportada la notificación de cambios en ficheros, se usará para refrescar las entradas de la caché de códigos de operación y de ficheros en cuanto los ficheros correspondientes sean modificados en un sistema de ficheros. Si la notificación de cambios en ficheros no está soportada, por ejemplo, al usar la compartición de ficheros en red, wincache hará un sondeo para los cambios en ficheros en intervalos de tiempo regulares especificados por wincache.chkinterval.
wincache.maxfilesize integer
Define el tamaño máximo permitido (en kilobytes) para que un fichero sea almacenado en caché. Si un fichero excede el valor especificado, no será almacenado en caché. Este ajuste se aplica solamente a la caché de ficheros.
wincache.ocenabled boolean
Habilita o deshabilita la caché de códigos de operaciones ("opcodes") Esta opción ha sido eliminada a partir de 2.0.0.0
wincache.ocenabledfilter string
Define una lista separada por comas de identificadores de sitios web de IIS donde se debería habilitar o deshabilitar la caché de códigos de operaciones. Este ajuste funciona junto con wincache.ocenabled: si wincache.ocenabled se establece a 1, los sitios enumerados en wincache.ocenabledfilter tendrán la caché de códigos de operaciones desactivada; si wincache.ocenabled se establece a 0, los sitios enumerados en wincache.ocenabledfilter tendrán la caché de códigos de operaciones activada. Esta opción ha sido eliminada a partir de 2.0.0.0
wincache.ocachesize integer
Define el tamaño máximo de memoria (en megabytes) que se asigna a la caché de códigos de operaciones. Si el tamaño de dicha caché excede el valor especificado se eliminarán de la caché los códigos de operación más antiguos. Observe que el tamaño de la caché de códigos de operaciones debe ser al menos tres veces mayor que el tamaño de la caché de ficheros. Si no fuera así, el tamaño de la caché de códigos de operaciones será aumentada automáticamente. Esta opción ha sido eliminada a partir de 2.0.0.0
wincache.filecount integer
Define cuántos ficheros se preveen que almacene en caché la extensión, para así asignar el tamaño de memoria apropiada en el momento del arranque. Si el número de ficheros excede el valor especificado, WinCache reasignará tanta memoria como sea necesaria.
wincache.chkinterval integer
Define la frecuencia (en segundos) con que la extensión comprobará los cambios en ficheros para refrescar la caché. Si se establece a 0 se deshabilitará el refresco de la caché. Los cambios en ficheros no se verán reflejados en la caché al menos que la entrada de la caché para tales ficheros sea eliminada mediante limpieza ("scavenger"), o la provisión ("pool") de aplicaciones de IIS sea reclicada, o se llame a la función wincache_refresh_if_changed.
wincache.ttlmax integer
Define el tiempo máximo de vida (en segundos) para una entrada de caché que no se esté usando. Si se establece a 0, se desactivará la limpieza de la caché, por lo que las entradas en caché nunca serán eliminadas durante el tiempo de vida del proceso obrero ("worker") de IIS.
wincache.enablecli boolean
Define si la caché se habilita cuando PHP se está ejecutando en modo de línea de comandos (CLI).
wincache.ignorelist string

Define una lista de ficheros que no deberían ser almacenados en caché por la extensión. La lista de ficheros se especifica empleando solamente nombres de ficheros, separados por el símbolo tubería - "|".

Ejemplo #1 Ejemplo de wincache.ignorelist

wincache.ignorelist = "index.php|misc.php|admin.php"

wincache.namesalt string
Define un string que será usado al nombrar los objetos específicos de la extensión que están almacenados en la memoria compartida. Se emplea para evitar conflictos que podrían causarse si otras aplicaciones dentro de un proceso obrero de IIS intenta acceder a la memoria compartida. La longitud del sting namesalt no puede exceder de 8 caracteres.
wincache.ucenabled boolean
Habilita o deshabilita la caché de usuarios.
wincache.ucachesize integer
Define el tamaño máximo de memoria en megabytes que se asigna para la caché de usuario. Si el tamaño total de las variables almacenadas en la caché de usuario excede el valor especificado, se eliminarán las variables más antiguas de la caché.
wincache.scachesize integer
Define el tamaño máximo de memoria en megabytes que se asigna para la caché de sesión. Si el tamaño total de los datos almacenados en la caché de sesión excede el valor especificado, se eliminarán los datos más antiguos de la caché.
wincache.rerouteini string
Especifica una ruta absoluta o relativa al fichero reroute.ini que contiene la lista de funciones de PHP cuya implementación debería ser remplazada con las funciones equivalentes de WinCache. Si se especifica una ruta relativa, se asume que sea relativa a la ubicación del fichero php-cgi.exe. Esta opción ha sido eliminada a partir de 1.3.7. Véase wincache.reroute_enabled para una funcionalidad similar a partir de 1.3.7.
wincache.reroute_enabled boolean
Habilita o deshabilita el redireccionamiento de varias funciones de E/S de ficheros a través de la caché de ficheros.
wincache.srwlocks boolean
Habilita o deshabilita el uso de bloqueos ("locks) de lectura/escritura compartidos. La deshabilitación es útil cuando se dan condiciones de problemas de punto muerto ("deadlock") en WinCache. Esta opción ha sido eliminada a partir de 2.0.0.0
wincache.filemapdir string
Especifica una ruta absoluta al directorio donde WinCache almacenará los ficheros temporales empleados para segmentos de memoria compartida. Este directorio debe estar en la máquina local y no en un sistema de ficheros en la red. Si no se especifica este directorio, WinCache utilizará el fichero de paginación de Windows para todos los segmentos de memoria compartida.


WinCache Statistics Script

The installation package for WinCache includes a PHP script, wincache.php, that can be used to obtain cache information and statistics.

If the WinCache extension was installed via the Microsoft Web Platform Installer, then this script is located in %SystemDrive%\Program Files\IIS\Windows Cache for PHP\. On a 64-bit version of the Windows Server operating system, the script is located in %SystemDrive%\Program Files (x86)\IIS\Windows Cache for PHP. If the extension was installed manually, then the wincache.php will be located in the same folder from which the content of the installation package was extracted.

To use wincache.php, copy it into a root folder of a Web site or into any subfolder. To protect the script, open it in any text editor and replace the values for USERNAME and PASSWORD constants. If any other IIS authentication is enabled on the server, then follow the instructions in the comments:

Ejemplo #1 Authentication configuration for wincache.php

<?php
/**
 * ======================== CONFIGURATION SETTINGS ==============================
 * If you do not want to use authentication for this page, set USE_AUTHENTICATION to 0.
 * If you use authentication then replace the default password.
 */
define('USE_AUTHENTICATION', 1);
define('USERNAME', 'wincache');
define('PASSWORD', 'wincache');

/**
 * The Basic PHP authentication will work only when IIS is configured to support
 * Anonymous Authentication' and nothing else. If IIS is configured to support/use
 * any other kind of authentication like Basic/Negotiate/Digest etc, this will not work.
 * In that case use the array below to define the names of users in your
 * domain/network/workgroup which you want to grant access to.
 */
$user_allowed = array('DOMAIN\user1', 'DOMAIN\user2', 'DOMAIN\user3');

/**
 * If the array contains string 'all', then all the users authenticated by IIS
 * will have access to the page. Uncomment the below line and comment above line
 * to grant access to all users who gets authenticated by IIS.
 */
/* $user_allowed = array('all'); */

/** ===================== END OF CONFIGURATION SETTINGS ========================== */
?>

Nota: Always protect the wincache.php script by using either the built-in authentication or the server's authentication mechanism. Leaving this script unprotected may compromise the security of your web application and web server.


WinCache Session Handler

The WinCache session handler (available since WinCache 1.1.0) can be used to configure PHP to store the session data in shared memory session cache. Using shared memory instead of the default file session storage helps improve performance of PHP applications that store large amount of data in session objects. Wincache session cache uses file-backed shared memory, which ensures that the session data is not lost during recycling of IIS application pools.

To configure PHP to use WinCache session handler set the php.ini setting session.save_handler to wincache. By default the Windows temporary file location is used for storing the session data. To change the location of the session file use session.save_path directive.

Ejemplo #1 Enabling WinCache session handler

session.save_handler = wincache
session.save_path = C:\inetpub\temp\session\


WinCache Functions Reroutes

NOTE: wincache.rerouteini was removed as of WinCache 1.3.7.0. It has been replaced with automatic function reroutes. See: wincache.reroute_enabled.

The WinCache functions reroutes (available since WinCache 1.2.0, removed since WinCache 1.3.7.0) can be used to replace built-in PHP functions with their equivalents that are optimized for a particular purpose. WinCache extension includes Windows-optimized implementation of PHP file functions that may improve performance of PHP applications in cases when PHP has to access files on network shares. The optimized implementation is provided for the following functions:

  • file_exists
  • file_get_contents
  • readfile
  • is_readable
  • is_writable
  • is_dir
  • realpath
  • filesize

To configure WinCache to use the functions reroutes use the file reroute.ini that is included in WinCache installation package. Copy this file into the same directory where php.ini file is located. After that add the wincache.rerouteini setting in php.ini and specify an absolute or relative path to the reroute.ini file.

Ejemplo #1 Enabling WinCache functions reroutes

wincache.rerouteini = C:\PHP\reroute.ini

Nota: If WinCache functions reroutes are enabled it is recommended to increase the WinCache file cache size. This can be done by using wincache.fcachesize setting.

The reroute.ini file contains the mappings between the native PHP functions and their equivalents in WinCache. Each line in the file defines a mapping by using the following syntax:

<PHP function name>:[<number of function parameters>]=<wincache function name>

The example of the file is shown below. In this example the calls to PHP function file_get_contents() will be replaced with calls to wincache_file_get_contents() only if the number of parameters passed to the function is less than or equals to 2. Specifying the number of parameters is useful when replacement function does not handle all the function's parameters.

Ejemplo #2 Reroute.ini file content

[FunctionRerouteList]
file_exists=wincache_file_exists
file_get_contents:2=wincache_file_get_contents
readfile:2=wincache_readfile
is_readable=wincache_is_readable
is_writable=wincache_is_writable
is_writeable=wincache_is_writable
is_file=wincache_is_file
is_dir=wincache_is_dir
realpath=wincache_realpath
filesize=wincache_filesize


  • « WinCache Functions Reroutes
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


  • « Tipos de recursos
  • Funciones de WinCache »
  • PHP Manual
  • WinCache
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de WinCache

Tabla de contenidos

  • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo — Recupera información sobre el uso de memoria caché de ficheros
  • wincache_lock — Obtiene un bloqueo exclusivo en una clave dada
  • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
  • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
  • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
  • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
  • wincache_scache_info — Retrieves information about files cached in the session cache
  • wincache_scache_meminfo — Recupera información sobre el uso de memoria caché de sesión
  • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_cas — Compara la variable con el valor antiguo y le asigna un nuevo valor a este
  • wincache_ucache_clear — Elimina todo el contenido de la caché del usuario
  • wincache_ucache_dec — Disminuye el valor asociado a la clave
  • wincache_ucache_delete — Elimina las variables de la memoria caché del usuario
  • wincache_ucache_exists — Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_get — Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_inc — Incrementa el valor asociado a la clave
  • wincache_ucache_info — Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_ucache_meminfo — Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_unlock — Libera un bloqueo exclusivo sobre una clave dada


Retrieves information about files cached in the file cache

  • « Funciones de WinCache
  • wincache_fcache_meminfo »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about files cached in the file cache

wincache_fcache_fileinfo

(PECL wincache >= 1.0.0)

wincache_fcache_fileinfo — Retrieves information about files cached in the file cache

Descripción

wincache_fcache_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about file cache content and its usage.

Parámetros

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the file cache summary.

Valores devueltos

Array of meta data about file cache o false en caso de error

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the file cache has been active
  • total_file_count - total number of files that are currently in the file cache
  • total_hit_count - number of times the files have been served from the file cache
  • total_miss_count - number of times the files have not been found in the file cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the file cache
    • use_time - time in seconds since the file has been accessed in the file cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • file_size - size of the cached file in bytes

Ejemplos

Ejemplo #1 A wincache_fcache_fileinfo() example

<pre>
<?php
print_r(wincache_fcache_fileinfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(   [total_cache_uptime] => 3234
    [total_file_count] => 5
    [total_hit_count] => 0
    [total_miss_count] => 1
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 1
                    [use_time] => 0
                    [last_check] => 1
                    [hit_count] => 1
                    [file_size] => 2435
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ver también

  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Recupera información sobre el uso de memoria caché de ficheros

  • « wincache_fcache_fileinfo
  • wincache_lock »
  • PHP Manual
  • Funciones de WinCache
  • Recupera información sobre el uso de memoria caché de ficheros

wincache_fcache_meminfo

(PECL wincache >= 1.0.0)

wincache_fcache_meminfo — Recupera información sobre el uso de memoria caché de ficheros

Descripción

wincache_fcache_meminfo ( ) : array

Recupera información sobre el uso de la memoria caché del fichero.

Valores devueltos

Array de meta datos sobre el uso de memoria caché de ficheros o false en caso de error

El array devuelta por esta función contiene los siguientes elementos:

  • memory_total - cantidad de memoria en bytes asignados para la caché de ficheros
  • memory_free - cantidad de memoria libre en bytes disponibles para la caché de ficheros
  • num_used_blks - número de bloques de memoria utilizados por la caché de ficheros
  • num_free_blks - número de bloques de memoria libre disponibles para la caché de ficheros
  • memory_overhead - cantidad de memoria en bytes utilizados para las estructuras internas de la caché de ficheros

Ejemplos

Ejemplo #1 Un ejemplo de wincache_fcache_meminfo()

<pre>
<?php
print_r(wincache_fcache_meminfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [memory_total] => 134217728
    [memory_free] => 131339120
    [num_used_blks] => 361
    [num_free_blks] => 3
    [memory_overhead] => 5856
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Obtiene un bloqueo exclusivo en una clave dada

  • « wincache_fcache_meminfo
  • wincache_ocache_fileinfo »
  • PHP Manual
  • Funciones de WinCache
  • Obtiene un bloqueo exclusivo en una clave dada

wincache_lock

(PECL wincache >= 1.1.0)

wincache_lock — Obtiene un bloqueo exclusivo en una clave dada

Descripción

wincache_lock ( string $key , bool $isglobal = false ) : bool

Obtiene un bloqueo exclusivo sobre una clave dada. La ejecución del script actual quedará en espera que se pueda obtener el bloqueo. Una vez obtenido el bloqueo, el otro script que intente solicitar dicho bloqueo utilizando la misma clave quedará en espera, hasta que el script actual libere el bloqueo con wincache_unlock().

Advertencia

El uso de wincache_lock() y wincache_unlock() puede causar bloqueos de punto muerto al ejecutar scripts de PHP en un entorno multiproceso como FastCGI. No emplear estas funciones a menos que se esté absolutamente seguro de que son necesarias. Para la mayoría de las operaciones en la caché de usuario no es necesario usar esar estas funciones.

Parámetros

key

Nombre de la clave en la cahcé para adquirir el bloqueo.

isglobal

Controla si el ámbito del bloqueo es a nivel de sistema o local. Los bloqueos locales tienen alcance para la «pool» de la aplicación en el caso de FastCGI de IIS o a todos los procesos de php que tengan el mismo identificador de proceso padre.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Empleo de wincache_lock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock(“lock_txt_lock”)) { // realizar un bloqueo exclusivo
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Write something here\n");
    wincache_unlock(“lock_txt_lock”); // liberar el bloqueo
} else {
    echo "No se pudo obtener el bloqueo";
}
fclose($fp);
?>

Ver también

  • wincache_unlock() - Libera un bloqueo exclusivo sobre una clave dada
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Retrieves information about files cached in the opcode cache

  • « wincache_lock
  • wincache_ocache_meminfo »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about files cached in the opcode cache

wincache_ocache_fileinfo

(PECL wincache >= 1.0.0)

wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache

Descripción

wincache_ocache_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about opcode cache content and its usage.

Advertencia

Esta función fue ELILMINADA en PHP 7.0.0.

Parámetros

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the opcode cache summary.

Valores devueltos

Array of meta data about opcode cache o false en caso de error

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the opcode cache has been active
  • total_file_count - total number of files that are currently in the opcode cache
  • total_hit_count - number of times the compiled opcode have been served from the cache
  • total_miss_count - number of times the compiled opcode have not been found in the cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the opcode cache
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • function_count - number of functions in the cached file
    • class_count - number of classes in the cached file

Ejemplos

Ejemplo #1 A wincache_ocache_fileinfo() example

<pre>
<?php
print_r(wincache_ocache_fileinfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Retrieves information about opcode cache memory usage

  • « wincache_ocache_fileinfo
  • wincache_refresh_if_changed »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about opcode cache memory usage

wincache_ocache_meminfo

(PECL wincache >= 1.0.0)

wincache_ocache_meminfo — Retrieves information about opcode cache memory usage

Descripción

wincache_ocache_meminfo ( ) : array|false

Retrieves information about memory usage by opcode cache.

Valores devueltos

Array of meta data about opcode cache memory usage o false en caso de error

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the opcode cache
  • memory_free - amount of free memory in bytes available for the opcode cache
  • num_used_blks - number of memory blocks used by the opcode cache
  • num_free_blks - number of free memory blocks available for the opcode cache
  • memory_overhead - amount of memory in bytes used for the opcode cache internal structures

Advertencia

Esta función fue ELILMINADA en PHP 7.0.0.

Ejemplos

Ejemplo #1 A wincache_ocache_meminfo() example

<pre>
<?php
print_r(wincache_ocache_meminfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [memory_total] => 134217728
    [memory_free] => 112106972
    [num_used_blks] => 15469
    [num_free_blks] => 4
    [memory_overhead] => 247600
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Refreshes the cache entries for the cached files

  • « wincache_ocache_meminfo
  • wincache_rplist_fileinfo »
  • PHP Manual
  • Funciones de WinCache
  • Refreshes the cache entries for the cached files

wincache_refresh_if_changed

(PECL wincache >= 1.0.0)

wincache_refresh_if_changed — Refreshes the cache entries for the cached files

Descripción

wincache_refresh_if_changed ( array $files = NULL ) : bool

Refreshes the cache entries for the files, whose names were passed in the input argument. If no argument is specified then refreshes all the entries in the cache.

Parámetros

files

An array of file names for files that need to be refreshed. An absolute or relative file paths can be used.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

WinCache performs regular checks on the cached files to ensure that if any file has changed then the corresponding entry in the cache is updated. By default this check is performed every 30 seconds. If, for example, a PHP script updates another PHP script where the application's configuration settings are stored, then it may happen that after the configuration settings have been saved to a file, the application is still using old settings for some time until the cache is refreshed. In those cases it may be preferrable to refresh the cache right after the file has been changed. The following example shows how this can be done.

Ejemplo #1 A wincache_refresh_if_changed() example

<?php
$filename = 'C:\inetpub\wwwroot\config.php';
$handle = fopen($filename, 'w+');
if ($handle === FALSE) die('Failed to open file '.$filename.' for writing');
fwrite($handle, '<?php $setting=something; ?>');
fclose($handle);
wincache_refresh_if_changed(array($filename));
?>

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario


Retrieves information about resolve file path cache

  • « wincache_refresh_if_changed
  • wincache_rplist_meminfo »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about resolve file path cache

wincache_rplist_fileinfo

(PECL wincache >= 1.0.0)

wincache_rplist_fileinfo — Retrieves information about resolve file path cache

Descripción

wincache_rplist_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about cached mappings between relative file paths and corresponding absolute file paths.

Valores devueltos

Array of meta data about the resolve file path cache o false en caso de error

The array returned by this function contains the following elements:

  • total_file_count - total number of file path mappings stored in the cache

  • rplist_entries - an array that contains the information about all the cached file paths:

    • resolve_path - path to a file
    • subkey_data - corresponding absolute path to a file

Ejemplos

Ejemplo #1 A wincache_rplist_fileinfo() example

<pre>
<?php
print_r(wincache_rplist_fileinfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [total_file_count] => 5
    [rplist_entries] => Array
        (
            [1] => Array
                (
                    [resolve_path] => checkcache.php
                    [subkey_data] => c:\inetpub\wwwroot|c:\inetpub\wwwroot\checkcache.php
                )

            [2] => Array (...iterates for each cached file)
        )
)

Ver también

  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Retrieves information about memory usage by the resolve file path cache

  • « wincache_rplist_fileinfo
  • wincache_scache_info »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about memory usage by the resolve file path cache

wincache_rplist_meminfo

(PECL wincache >= 1.0.0)

wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache

Descripción

wincache_rplist_meminfo ( ) : array|false

Retrieves information about memory usage by resolve file path cache.

Valores devueltos

Array of meta data that describes memory usage by resolve file path cache. o false en caso de error

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the resolve file path cache
  • memory_free - amount of free memory in bytes available for the resolve file path cache
  • num_used_blks - number of memory blocks used by the resolve file path cache
  • num_free_blks - number of free memory blocks available for the resolve file path cache
  • memory_overhead - amount of memory in bytes used for the internal structures of resolve file path cache

Ejemplos

Ejemplo #1 A wincache_rplist_meminfo() example

<pre>
<?php
print_r(wincache_rplist_meminfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [memory_total] => 9437184
    [memory_free] => 9416744
    [num_used_blks] => 23
    [num_free_blks] => 1
    [memory_overhead] => 416
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Retrieves information about files cached in the session cache

  • « wincache_rplist_meminfo
  • wincache_scache_meminfo »
  • PHP Manual
  • Funciones de WinCache
  • Retrieves information about files cached in the session cache

wincache_scache_info

(PECL wincache >= 1.1.0)

wincache_scache_info — Retrieves information about files cached in the session cache

Descripción

wincache_scache_info ( bool $summaryonly = false ) : array|false

Retrieves information about session cache content and its usage.

Parámetros

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the session cache summary.

Valores devueltos

Array of meta data about session cache o false en caso de error

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the session cache has been active
  • total_item_count - total number of elements that are currently in the session cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache
  • total_hit_count - number of times the data has been served from the cache
  • total_miss_count - number of times the data has not been found in the cache

  • scache_entries - an array that contains the information about all the cached items:

    • key_name - name of the key which is used to store the data
    • value_type - type of value stored by the key
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • ttl_seconds - time remaining for the data to live in the cache, 0 meaning infinite
    • age_seconds - time elapsed from the time data has been added in the cache
    • hitcount - number of times data has been served from the cache

Ejemplos

Ejemplo #1 A wincache_scache_info() example

<pre>
<?php
print_r(wincache_scache_info());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [scache_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Recupera información sobre el uso de memoria caché de sesión

  • « wincache_scache_info
  • wincache_ucache_add »
  • PHP Manual
  • Funciones de WinCache
  • Recupera información sobre el uso de memoria caché de sesión

wincache_scache_meminfo

(PECL wincache >= 1.1.0)

wincache_scache_meminfo — Recupera información sobre el uso de memoria caché de sesión

Descripción

wincache_scache_meminfo ( ) : array

Recupera información sobre el uso de memoria caché de la sesión.

Valores devueltos

Array de metadatos sobre el uso de la memoria caché de sesión o false en caso de error

El array devuelto por esta función contiene los siguientes elementos:

  • memory_total - cantidad de memoria en bytes asignado para la caché de sesión
  • memory_free - cantidad de memoria libre en bytes disponible para la caché de sesión
  • num_used_blks - número de bloques de memoria utilizados por el caché de la sesión
  • num_free_blks - número de bloques disponibles en la memoria de la caché de sesión
  • memory_overhead - cantidad de memoria en bytes utilizado para las estructuras de sesión de caché interna

Ejemplos

Ejemplo #1 Ejemplo de wincache_scache_meminfo()

<pre>
<?php
print_r(wincache_scache_meminfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Adds a variable in user cache only if variable does not already exist in the cache

  • « wincache_scache_meminfo
  • wincache_ucache_cas »
  • PHP Manual
  • Funciones de WinCache
  • Adds a variable in user cache only if variable does not already exist in the cache

wincache_ucache_add

(PECL wincache >= 1.1.0)

wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache

Descripción

wincache_ucache_add ( string $key , mixed $value , int $ttl = 0 ) : bool
wincache_ucache_add ( array $values , mixed $unused = NULL , int $ttl = 0 ) : bool

Adds a variable in user cache, only if this variable doesn't already exist in the cache. The added variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Parámetros

key

Store the variable using this key name. If a variable with same key is already present the function will fail and return false. key is case sensitive. To override the value even if key is present use wincache_ucache_set() function instad. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass null as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Valores devueltos

If key is string, the function returns true on success and false on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns false;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

Ejemplos

Ejemplo #1 wincache_ucache_add() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_get('foo'));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
string(3) "BAR"

Ejemplo #2 wincache_ucache_add() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

El resultado del ejemplo sería:

array(0) { }
array(4) {
  ["green"]=> int(-1)
  ["Blue"]=> int(-1)
  ["yellow"]=> int(-1)
  ["cyan"]=> int(-1)
}
string(1) "6"

Ver también

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • __sleep()


Compara la variable con el valor antiguo y le asigna un nuevo valor a este

  • « wincache_ucache_add
  • wincache_ucache_clear »
  • PHP Manual
  • Funciones de WinCache
  • Compara la variable con el valor antiguo y le asigna un nuevo valor a este

wincache_ucache_cas

(PECL wincache >= 1.1.0)

wincache_ucache_cas — Compara la variable con el valor antiguo y le asigna un nuevo valor a este

Descripción

wincache_ucache_cas ( string $key , int $old_value , int $new_value ) : bool

Compara la variable asociada con la key con old_value y si coincide entonces asigna el new_value a este.

Parámetros

key

El parámetro key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas.

old_value

Valor anterior de la variable apuntada por key en la memoria caché del usuario. El valor debe ser de tipo long, en caso contrario la función devuelve false.

new_value

El nuevo valor que se asigna a una variable New value which will get assigned to variable indicado por la key si se encuentra una coincidencia. El valor debe ser de tipo long, en caso contrario la función devolverá false.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Usando wincache_ucache_cas()

<?php
wincache_ucache_set('counter', 2922);
var_dump(wincache_ucache_cas('counter', 2922, 1));
var_dump(wincache_ucache_get('counter'));
?>

El resultado del ejemplo sería:

bool(true)
int(1)

Ver también

  • wincache_ucache_inc() - Incrementa el valor asociado a la clave
  • wincache_ucache_dec() - Disminuye el valor asociado a la clave


Elimina todo el contenido de la caché del usuario

  • « wincache_ucache_cas
  • wincache_ucache_dec »
  • PHP Manual
  • Funciones de WinCache
  • Elimina todo el contenido de la caché del usuario

wincache_ucache_clear

(PECL wincache >= 1.1.0)

wincache_ucache_clear — Elimina todo el contenido de la caché del usuario

Descripción

wincache_ucache_clear ( ) : bool

Borra o elimina todos los valores almacenados en la caché del usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Usando wincache_ucache_clear()

<?php
wincache_ucache_set('green', 1);
wincache_ucache_set('red', 2);
wincache_ucache_set('orange', 4);
wincache_ucache_set('blue', 8);
wincache_ucache_set('cyan', 16);
$array1 = array('green', 'red', 'orange', 'blue', 'cyan');
var_dump(wincache_ucache_get($array1));
var_dump(wincache_ucache_clear());
var_dump(wincache_ucache_get($array1));
?>

El resultado del ejemplo sería:

array(5) { ["green"]=> int(1)
           ["red"]=> int(2)
           ["orange"]=> int(4)
           ["blue"]=> int(8)
           ["cyan"]=> int(16) }
bool(true)
bool(false)

Ver también

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario


Disminuye el valor asociado a la clave

  • « wincache_ucache_clear
  • wincache_ucache_delete »
  • PHP Manual
  • Funciones de WinCache
  • Disminuye el valor asociado a la clave

wincache_ucache_dec

(PECL wincache >= 1.1.0)

wincache_ucache_dec — Disminuye el valor asociado a la clave

Descripción

wincache_ucache_dec ( string $key , int $dec_by = 1 , bool &$success = ? ) : mixed

Disminuye el valor asociado a la key por 1 o como se especifica por dec_by.

Parámetros

key

El parámetro key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas.

dec_by

El valor de la variable asociada por el que conseguirá que key disminuya. Si el argumento es un número de punto flotante se truncará al integer más cercano. La variable asociada con la key debe ser de tipo long, en caso contrario la función falla y devolverá false.

success

Será establecido a true en caso de éxito y false en caso de error.

Valores devueltos

Devuelve el valor decrementado en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 Usando wincache_ucache_dec()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_dec('counter', 2923, $success));
var_dump($success);
?>

El resultado del ejemplo sería:

int(2922)
bool(true)

Ver también

  • wincache_ucache_inc() - Incrementa el valor asociado a la clave
  • wincache_ucache_cas() - Compara la variable con el valor antiguo y le asigna un nuevo valor a este


Elimina las variables de la memoria caché del usuario

  • « wincache_ucache_dec
  • wincache_ucache_exists »
  • PHP Manual
  • Funciones de WinCache
  • Elimina las variables de la memoria caché del usuario

wincache_ucache_delete

(PECL wincache >= 1.1.0)

wincache_ucache_delete — Elimina las variables de la memoria caché del usuario

Descripción

wincache_ucache_delete ( mixed $key ) : bool

Elimina los elementos de la caché del usuario apuntado por key.

Parámetros

key

El parámetro key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas. key puede ser un array de claves.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Si key es un array, entonces la función devuelve false si cada elemento del array no se borra de la memoria caché del usuario, en caso contrario devuelve un array que consta de todas las claves que se eliminan.

Ejemplos

Ejemplo #1 Usando wincache_ucache_delete() con key como un string

<?php
wincache_ucache_set('foo', 'bar');
var_dump(wincache_ucache_delete('foo'));
var_dump(wincache_ucache_exists('foo'));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ejemplo #2 Usingwincache_ucache_delete() con key como un array

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'blue', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

El resultado del ejemplo sería:

array(4) { [0]=> string(5) "green"
           [1]=> string(4) "Blue"
           [2]=> string(6) "yellow"
           [3]=> string(4) "cyan" }

Ejemplo #3 Using wincache_ucache_delete() con key como un array donde algunos elementos no se pueden eliminar

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('orange', 'red', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

El resultado del ejemplo sería:

array(2) { [0]=> string(6) "yellow"
           [1]=> string(4) "cyan" }

Ver también

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario


Comprueba si una variable existe en la caché del usuario

  • « wincache_ucache_delete
  • wincache_ucache_get »
  • PHP Manual
  • Funciones de WinCache
  • Comprueba si una variable existe en la caché del usuario

wincache_ucache_exists

(PECL wincache >= 1.1.0)

wincache_ucache_exists — Comprueba si una variable existe en la caché del usuario

Descripción

wincache_ucache_exists ( string $key ) : bool

Comprueba si una variable con la key existe en la caché de usuario o no.

Parámetros

key

La key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas.

Valores devueltos

Devuelve true si la variable con la key existe, en caso contrario devuelve false.

Ejemplos

Ejemplo #1 Usando wincache_ucache_exists()

<?php
if (!wincache_ucache_exists('green'))
    wincache_ucache_set('green', 1);
var_dump(wincache_ucache_exists('green'));
?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario


Obtiene una variable almacenada en la caché del usuario

  • « wincache_ucache_exists
  • wincache_ucache_inc »
  • PHP Manual
  • Funciones de WinCache
  • Obtiene una variable almacenada en la caché del usuario

wincache_ucache_get

(PECL wincache >= 1.1.0)

wincache_ucache_get — Obtiene una variable almacenada en la caché del usuario

Descripción

wincache_ucache_get ( mixed $key , bool &$success = ? ) : mixed

Obtiene una variable almacenada en la caché del usuario.

Parámetros

key

La key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas. key puede ser un array de claves. En este caso el valor de retorno será un array de valores de cada elemento en el array key. Si un objeto, o un array que contiene objetos, es retornado, entonces los objetos serán decodificados. Véase __wakeup() para más detalles sobre decodificar objetos.

success

Se establecerá en true en caso de éxito y false en caso de error.

Valores devueltos

Si key es un string, la función devuelve el valor de la variable almacenada con esa clave. El parámetro success es establecido a true en caso de éxito y a false en caso de error.

El parámetro key es un array, el parámetro success siempre se establece en true. El array devuelto (pares nombre => valor) will contendrá sólo aquellos pares nombre => valor en donde la operación de obtención de caché de usuario se ha realizado correctamente. Si ninguna de las claves del array encuentran una coincidencia en la caché del usuario, un array vacío será devuelto.

Ejemplos

Ejemplo #1 wincache_ucache_get() con key como un string

<?php
wincache_ucache_add('color', 'blue');
var_dump(wincache_ucache_get('color', $success));
var_dump($success);
?>

El resultado del ejemplo sería:

string(4) "blue"
bool(true)

Ejemplo #2 wincache_ucache_get() con key como un array

<?php
$array1 = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'Blue', 'yellow', 'cyan');
var_dump(wincache_ucache_get($array2, $success));
var_dump($success);
?>

El resultado del ejemplo sería:

array(4) { ["green"]=> string(1) "5"
           ["Blue"]=> string(1) "6"
           ["yellow"]=> string(1) "7"
           ["cyan"]=> string(1) "8" }
bool(true)

Ver también

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • __wakeup()


Incrementa el valor asociado a la clave

  • « wincache_ucache_get
  • wincache_ucache_info »
  • PHP Manual
  • Funciones de WinCache
  • Incrementa el valor asociado a la clave

wincache_ucache_inc

(PECL wincache >= 1.1.0)

wincache_ucache_inc — Incrementa el valor asociado a la clave

Descripción

wincache_ucache_inc ( string $key , int $inc_by = 1 , bool &$success = ? ) : mixed

Incrementa el valor asociado a la key por 1 o como se especifica por inc_by.

Parámetros

key

La key que se utiliza para almacenar la variable en la caché. key distingue mayúsculas de minúsculas.

inc_by

El valor por el cual la variable asociada con la key será incrementada. Si el argumento es un número de punto flotante se truncará al integer más cercano. La variable asociada con la key debe ser de tipo long, de lo contrario la función falla y devuelve false.

success

Se establecerá en true en caso de éxito y false en caso de error.

Valores devueltos

Devuelve el valor incrementado en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 Usando wincache_ucache_inc()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_inc('counter', 2921, $success));
var_dump($success);
?>

El resultado del ejemplo sería:

int(2922)
bool(true)

Ver también

  • wincache_ucache_dec() - Disminuye el valor asociado a la clave
  • wincache_ucache_cas() - Compara la variable con el valor antiguo y le asigna un nuevo valor a este


Recupera información sobre los datos almacenados en la caché del usuario

  • « wincache_ucache_inc
  • wincache_ucache_meminfo »
  • PHP Manual
  • Funciones de WinCache
  • Recupera información sobre los datos almacenados en la caché del usuario

wincache_ucache_info

(PECL wincache >= 1.1.0)

wincache_ucache_info — Recupera información sobre los datos almacenados en la caché del usuario

Descripción

wincache_ucache_info ( bool $summaryonly = false , string $key = NULL ) : array

Recupera información sobre los datos almacenados en la caché del usuario.

Parámetros

summaryonly

Controla si el array devuelto contiene información sobre las entradas de caché individuales junto con el resumen caché del usuario.

key

La clave de una entrada en la caché del usuario. Si se especifica a continuación, el array devuelto contendrá información sólo acerca de que la entrada de caché. Si no se especifica y summaryonly es establecido a false entonces el array devuelto contendrá información sobre todas las entradas en la caché.

Valores devueltos

Array de metadatos sobre caché de usuario o false en caso de error

El array devuelto por esta función contiene los siguientes elementos:

  • total_cache_uptime - tiempo total en segundos que el caché de usuario ha sido activo
  • total_item_count - número total de elementos que están actualmente en la caché del usuario
  • is_local_cache - true si el caché es de metadatos para una instancia de caché local, false si los metadatos es para el la caché global
  • total_hit_count - número de veces que los datos se han servido de la memoria caché
  • total_miss_count - número de veces que los datos no se han encontrado en la caché

  • ucache_entries - un array que contiene la información sobre todos los elementos almacenados en caché:

    • key_name - nombre de la clave que se utiliza para almacenar los datos
    • value_type - tipo de valor almacenado por la clave
    • use_time - tiempo en segundos desde el fichero ha sido visitado en la caché de código de operación
    • last_check - tiempo en segundos desde el fichero ha sido chequeado para modificaciones
    • is_session - indica si los datos son una variable de sesión
    • ttl_seconds - el tiempo restante de los datos a vivir en la memoria caché, 0 significa infinito
    • age_seconds - tiempo transcurrido desde el momento que los datos han sido añadidos en la caché
    • hitcount - número de veces que los datos se han servido de la memoria caché

Ejemplos

Ejemplo #1 Usar wincache_ucache_info()

<?php
wincache_ucache_get('green');
wincache_ucache_set('green', 2922);
wincache_ucache_get('green');
wincache_ucache_get('green');
wincache_ucache_get('green');
print_r(wincache_ucache_info());
?>

El resultado del ejemplo sería:

Array
( ["total_cache_uptime"] => int(0)
  ["is_local_cache"] => bool(false)
  ["total_item_count"] => int(1)
  ["total_hit_count"] => int(3)
  ["total_miss_count"] => int(1)
  ["ucache_entries"] => Array(1)
    ( [1] => Array(6)
      (
        ["key_name"] => string(5) "green"
        ["value_type"] => string(4) "long"
        ["is_session"] => int(0)
        ["ttl_seconds"] => int(0)
        ["age_seconds"] => int(0)
        ["hitcount"] => int(3)
       )
    )
)

Ver también

  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Recupera información sobre el uso de memoria caché de usuario

  • « wincache_ucache_info
  • wincache_ucache_set »
  • PHP Manual
  • Funciones de WinCache
  • Recupera información sobre el uso de memoria caché de usuario

wincache_ucache_meminfo

(PECL wincache >= 1.1.0)

wincache_ucache_meminfo — Recupera información sobre el uso de memoria caché de usuario

Descripción

wincache_ucache_meminfo ( ) : array

Recupera información sobre el uso de memoria caché del usuario.

Valores devueltos

Array de metadatos sobre el uso de la memoria caché de usuario o false en caso de error

El array devuelto por esta función contiene los siguientes elementos:

  • memory_total - cantidad de memoria en bytes asignado para la caché de usuario
  • memory_free - cantidad de memoria libre en bytes disponible para la caché de usuario
  • num_used_blks - número de bloques de memoria utilizados por el caché del usuario
  • num_free_blks - número de bloques disponibles en la memoria de la caché del usuario
  • memory_overhead - cantidad de memoria en bytes utilizado para las estructuras de los usuarios de caché interna

Ejemplos

Ejemplo #1 Ejemplo de wincache_ucache_meminfo()

<pre>
<?php
print_r(wincache_ucache_meminfo());
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

Ver también

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Recupera información sobre el uso de memoria caché de ficheros
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Recupera información sobre el uso de memoria caché de sesión


Adds a variable in user cache and overwrites a variable if it already exists in the cache

  • « wincache_ucache_meminfo
  • wincache_unlock »
  • PHP Manual
  • Funciones de WinCache
  • Adds a variable in user cache and overwrites a variable if it already exists in the cache

wincache_ucache_set

(PECL wincache >= 1.1.0)

wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache

Descripción

wincache_ucache_set ( mixed $key , mixed $value , int $ttl = 0 ) : bool
wincache_ucache_set ( array $values , mixed $unused = NULL , int $ttl = 0 ) : bool

Adds a variable in user cache. Overwrites a variable if it already exists in the cache. The added or updated variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Parámetros

key

Store the variable using this key name. If a variable with same key is already present the function will overwrite the previous value with the new one. key is case sensitive. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass null as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Valores devueltos

If key is string, the function returns true on success and false on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns false;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

Ejemplos

Ejemplo #1 wincache_ucache_set() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_set('foo', $bar));
var_dump(wincache_ucache_get('foo'));
$bar1 = 'BAR1';
var_dump(wincache_ucache_set('foo', $bar1));
var_dump(wincache_ucache_get('foo'));
?>

El resultado del ejemplo sería:

bool(true)
string(3) "BAR"
bool(true)
string(3) "BAR1"

Ejemplo #2 wincache_ucache_set() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

El resultado del ejemplo sería:

array(0) {}
array(0) {}
string(1) "6"

Ver también

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • __sleep()


Libera un bloqueo exclusivo sobre una clave dada

  • « wincache_ucache_set
  • Building for Windows »
  • PHP Manual
  • Funciones de WinCache
  • Libera un bloqueo exclusivo sobre una clave dada

wincache_unlock

(PECL wincache >= 1.1.0)

wincache_unlock — Libera un bloqueo exclusivo sobre una clave dada

Descripción

wincache_unlock ( string $key ) : bool

Libera un bloqueo exclusivo que se obtuvo en una clave dada mediante wincache_lock(). Si cualquier otro proceso fue bloqueado en espera de el bloqueo en esta clave, este proceso será capaz de obtener el bloqueo.

Advertencia

Usando wincache_lock() y wincache_unlock() puede causar bloqueos al ejecutar los scripts PHP en un entorno de multi-proceso, como FastCGI. No utilice estas funciones a menos que esté absolutamente seguro de que necesitan para su uso. Para la mayoría de las operaciones en la caché de usuario no es necesario el uso de estas funciones.

Parámetros

key

Nombre de la llave en la caché para liberar el bloqueo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Usar wincache_unlock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock(“lock_txt_lock”)) { // hacer un bloqueo exclusivo
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Escribir algo aquí\n");
    wincache_unlock(“lock_txt_lock”); // liberar el bloqueo
} else {
    echo "No se pudo obtener el bloqueo!";
}
fclose($fp);
?>

Ver también

  • wincache_lock() - Obtiene un bloqueo exclusivo en una clave dada
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Obtiene una variable almacenada en la caché del usuario
  • wincache_ucache_delete() - Elimina las variables de la memoria caché del usuario
  • wincache_ucache_clear() - Elimina todo el contenido de la caché del usuario
  • wincache_ucache_exists() - Comprueba si una variable existe en la caché del usuario
  • wincache_ucache_meminfo() - Recupera información sobre el uso de memoria caché de usuario
  • wincache_ucache_info() - Recupera información sobre los datos almacenados en la caché del usuario
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Building for Windows

Tabla de contenidos

  • Prerequisites
  • Compiling and building
  • Verifying the build


Prerequisites

Building WinCache extension will require:

  1. PHP source code
  2. PHP build environment
  3. WinCache source code

For completing first two steps, follow the step-by-step guide for how to » build PHP on Windows.

For getting the WinCache source code follow the instructions described in Downloading PECL extensions.


Compiling and building

The following steps describe how to compile and build WinCache on Windows OS:

  1. Open a command prompt which is used to build PHP

  2. Go to the root folder where PHP sources are present

  3. Run the command:

    cscript.exe win32\build\buildconf.js

  4. Run the command:

    configure.bat --help
    The output will contain a new flag --enable-wincache.

  5. Run the command:

    configure.js [all options used to build PHP] --enable-wincache
    --enable-wincache is the only extra option which is required to ensure that WinCache extension gets built properly. This option will build WinCache and will statically link it with PHP dll. To build WinCache extension as a stand-alone DLL use the option --enable-wincache=shared.

  6. Run the command:

    nmake


Verifying the build

The following steps describe how to verify that WinCache has been built correctly:

  1. Go to the folder where the PHP binaries are built

  2. Run the command:

    php.exe -n -d extension=php_wincache.dll -re wincache
    If WinCache has been built properly, the output of this command will list the INI directives and functions supported by WinCache.


Hierarchical Profiler

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Xhprof Funciones
    • xhprof_disable — Detiene el perfilador xhprof
    • xhprof_enable — Inicia perfil xhprof
    • xhprof_sample_disable — Detiene la muestra del perfilador xhprof
    • xhprof_sample_enable — Iniciar el analisis de XHProf en modo de muestreo


Introducción

El XHProf es un perfilador ligero jerárquico y basado en la instrumentación. Durante la fase de recopilación de datos, lleva un registro de los recuentos de llamadas e incluso métricas para los arcos en el calibre dinámico de un programa. Calcula las exclusivas métricas en la fase de reporte/procesamiento posterior, como el tiempo de espera (transcurrido), El tiempo de la CPU y el uso de la memoria. Un perfil de funciones puede ser dividido por los llamantes o llamadas. El XHProf maneja funciones recursivas detectando ciclos en la caligrafía en el propio momento de la recogida de datos y evitar los ciclos dando nombres calificados de profundidad para las invocaciones recursivas.

XHProf incluye una sencilla interfaz de usuario basada en HTML (escrita en PHP). El navegador basado en La interfaz de usuario para ver los resultados de los perfiles hace que sea fácil ver los resultados o compartirlos. con los compañeros. También se admite una vista de imagen de caligrafía.

Los informes del XHProf a menudo pueden ser útiles para entender la estructura del código siendo ejecutado. La naturaleza jerárquica de los informes puede ser utilizada para determinar, por ejemplo, qué cadena de llamadas llevó a que se llamara a una función en particular.

El XHProf permite comparar dos ejecuciones (también conocidas como informes "diff") o agregar datos de múltiples ejecuciones. Informes diferenciales y agregados, muy parecidos a los informes de una sola ejecución, ofrecen vistas "planas" y "jerárquicas" del perfil.

Se puede encontrar documentación adicional a través del sitio » facebook xhprof.


Requerimientos

Aunque no es obligatorio, xhprof incluye una interfaz que está escrito en PHP. Se utiliza para guardar y mostrar los datos reseñados en una forma utilizable, donde la observación se realiza mediante un navegador web. Por lo tanto, un servidor web PHP activado probablemente mejorará la experiencia xhprof.

También hay un "fork" (bifurcación del desarrollo) de la interfaz gráfica de usuario en » http://github.com/preinheimer/xhprof


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/xhprof


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Xhprof Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
xhprof.output_dir | "" | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

xhprof.output_dir string

Directorio utilizado por la aplicación por defecto de la interfaz iXHProfRuns (es decir, la clase XHProfRuns_Default) para el almacenamiento XHProf.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

XHPROF_FLAGS_NO_BUILTINS (integer)
Se utiliza para saltar todas las funciones incorporadas (internas)
XHPROF_FLAGS_CPU (integer)
Se utiliza para agregar información de la CPU a la salida.
XHPROF_FLAGS_MEMORY (integer)
Se utiliza para agregar información de la memoria a la salida.


Ejemplos

Ejemplo #1 Ejemplo Xhprof con interfaz gráfica de usuario opcional

En este ejemplo se inicia y detiene el perfilador, a continuación, utiliza interfaz gráfica de usuario para guardar y analizar los resultados. En otras palabras, el código de la extensión se termina en la llamada a xhprof_disable() .

<?php
xhprof_enable(XHPROF_FLAGS_CPU + XHPROF_FLAGS_MEMORY);

for ($i = 0; $i <= 1000; $i++) {
    $a = $i * $i;
}

$xhprof_data = xhprof_disable();

$XHPROF_ROOT = "/tools/xhprof/";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_lib.php";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_runs.php";

$xhprof_runs = new XHProfRuns_Default();
$run_id = $xhprof_runs->save_run($xhprof_data, "xhprof_testing");

echo "http://localhost/xhprof/xhprof_html/index.php?run={$run_id}&source=xhprof_testing\n";

?>

El resultado del ejemplo sería algo similar a:

http://localhost/xhprof/xhprof_html/index.php?run=t11_4bdf44d21121f&source=xhprof_testing


Xhprof Funciones

Tabla de contenidos

  • xhprof_disable — Detiene el perfilador xhprof
  • xhprof_enable — Inicia perfil xhprof
  • xhprof_sample_disable — Detiene la muestra del perfilador xhprof
  • xhprof_sample_enable — Iniciar el analisis de XHProf en modo de muestreo


Detiene el perfilador xhprof

  • « Xhprof Funciones
  • xhprof_enable »
  • PHP Manual
  • Xhprof Funciones
  • Detiene el perfilador xhprof

xhprof_disable

(PECL xhprof >= 0.9.0)

xhprof_disable — Detiene el perfilador xhprof

Descripción

xhprof_disable ( ) : array

Detiene el perfilador, y devuelve los datos xhprof de la ejecución.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de los datos xhprof, de la ejecución.

Ejemplos

Ejemplo #1 xhprof_disable() ejemplo

<?php
xhprof_enable();

$foo = strlen("foo bar");

$xhprof_data = xhprof_disable();

print_r($xhprof_data);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [main()==>strlen] => Array
        (
            [ct] => 1
            [wt] => 279
        )

    [main()==>xhprof_disable] => Array
        (
            [ct] => 1
            [wt] => 9
        )

    [main()] => Array
        (
            [ct] => 1
            [wt] => 610
        )

)


Inicia perfil xhprof

  • « xhprof_disable
  • xhprof_sample_disable »
  • PHP Manual
  • Xhprof Funciones
  • Inicia perfil xhprof

xhprof_enable

(PECL xhprof >= 0.9.0)

xhprof_enable — Inicia perfil xhprof

Descripción

xhprof_enable ( int $flags = 0 , array $options = ? ) : void

Inicia perfiles xhprof.

Parámetros

flags

Flags opcionales para añadir información adicional a la creación de perfiles. Véase las constantes XHprof Para obtener más información acerca de estos flags, p. ej., XHPROF_FLAGS_MEMORY para permitir perfiles de memoria.

options

Un array de opciones opcionales, es decir, la opción 'ignored_functions' para pasar en las funciones que se ignoraron durante el perfilado.

Valores devueltos

null

Historial de cambios

Versión | Descripción
0.9.2 | El parámetro opcional options fué agregado.

Ejemplos

Ejemplo #1 Ejemplos de xhprof_enable()

<?php
// 1. tiempo transcurrido + memoria + perfiles CPU; e ignorar las funciones integradas (internas)
xhprof_enable(XHPROF_FLAGS_NO_BUILTINS | XHPROF_FLAGS_CPU | XHPROF_FLAGS_MEMORY);

// 2. perfil tiempo transcurrido; ignorando call_user_func* durante el perfilado
xhprof_enable(
    0,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));

// 3. tiempo transcurrido + perfil de memoria; ignorando call_user_func* durante el perfilado
xhprof_enable(
    XHPROF_FLAGS_MEMORY,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));
?>

Ver también

  • xhprof_disable() - Detiene el perfilador xhprof
  • xhprof_sample_enable() - Iniciar el analisis de XHProf en modo de muestreo
  • memory_get_usage() - Devuelve la cantidad de memoria asignada a PHP
  • getrusage() - Obtiene el uso de los recursos actuales


Detiene la muestra del perfilador xhprof

  • « xhprof_enable
  • xhprof_sample_enable »
  • PHP Manual
  • Xhprof Funciones
  • Detiene la muestra del perfilador xhprof

xhprof_sample_disable

(PECL xhprof >= 0.9.0)

xhprof_sample_disable — Detiene la muestra del perfilador xhprof

Descripción

xhprof_sample_disable ( ) : array

Detiene la muestra el modo perfilador xhprof, y

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de los datos de muestra xhprof, de la ejecución.

Ejemplos

Ejemplo #1 Ejemplo de xhprof_sample_disable()

<?php
xhprof_sample_enable();

for ($i = 0; $i <= 10000; $i++) {
    $a = strlen($i);
    $b = $i * $a;
    $c = rand();
}

$xhprof_data = xhprof_sample_disable();

print_r($xhprof_data);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [1272935300.800000] => main()
    [1272935300.900000] => main()
)


Iniciar el analisis de XHProf en modo de muestreo

  • « xhprof_sample_disable
  • Yac »
  • PHP Manual
  • Xhprof Funciones
  • Iniciar el analisis de XHProf en modo de muestreo

xhprof_sample_enable

(PECL xhprof >= 0.9.0)

xhprof_sample_enable — Iniciar el analisis de XHProf en modo de muestreo

Descripción

xhprof_sample_enable ( ) : void

Inicia la creación de perfiles en modo de muestra, que es una versión más ligera de peso de xhprof_enable() . El intervalo de muestreo es 0,1 segundos, y las muestras de registro de la pila de llamadas de función completa. El caso de uso principal es en gastos indirectos más bajos se requiere cuando se hace la supervisión del rendimiento y de diagnóstico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null

Ver también

  • xhprof_sample_disable() - Detiene la muestra del perfilador xhprof
  • xhprof_enable() - Inicia perfil xhprof
  • memory_get_usage() - Devuelve la cantidad de memoria asignada a PHP
  • getrusage() - Obtiene el uso de los recursos actuales


Yac

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Yac — La clase Yac
    • Yac::add — Guardar en caché
    • Yac::__construct — Constructor
    • Yac::delete — Eliminar los artículos de la memoria caché
    • Yac::dump — Volcar cache
    • Yac::flush — Limpiar el caché
    • Yac::get — Recuperar los valores de caché
    • Yac::__get — Getter
    • Yac::info — Estado del caché
    • Yac::set — Guardar en el caché
    • Yac::__set — Setter


Introducción

Yac (Otro caché), es un caché de datos de usuario de memoria compartida sin bloqueo, podría utilizarse para reemplazar el APC, el memcache local.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yac.

Los binarios de Windows (ficheros DLL) para esta extensión de PECL están disponibles en el sitio web de PECL.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Yac Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
yac.compress_threshold | -1 | PHP_INI_SYSTEM |
yac.debug | 0 | PHP_INI_ALL |
yac.enable | 1 | PHP_INI_SYSTEM |
yac.enable_cli | 0 | PHP_INI_SYSTEM |
yac.keys_memory_size | 4M | PHP_INI_SYSTEM |
yac.serializer | php | PHP_INI_SYSTEM |
yac.values_memory_size | 64M | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

yac.compress_threshold integer

yac.debug integer

yac.enable integer

yac.enable_cli integer

yac.keys_memory_size string

yac.serializer string

yac.values_memory_size string


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

YAC_VERSION (string)
YAC_MAX_KEY_LEN (integer)
La longitud máxima de una clave podría ser, es de 48 bytes.
YAC_MAX_VALUE_RAW_LEN (integer)
YAC_MAX_RAW_COMPRESSED_LEN (integer)
YAC_SERIALIZER_PHP (integer)
Usa php serialize como serializador
YAC_SERIALIZER_JSON (integer)
Usa json como serializador (requrie --enable-json)
YAC_SERIALIZER_IGBINARY (integer)
Usa igbinary como serializador (require --enable-igbinary)
YAC_SERIALIZER_MSGPACK (integer)
Usa msgpack como serializador (require --enable-msgpack)
YAC_SERIALIZER (string)
Qué serializador está yac usando


La clase Yac

(PECL yac >= 1.0.0)

Introducción

Sinopsis de la Clase

Yac {
/* Propiedades */
protected $_prefix ;
/* Métodos */
public __construct ( string $prefix = "" )
public add ( string $keys , mixed $value , int $ttl = 0 ) : bool
public add ( array $key_vals ) : bool
public delete ( string|array $keys , int $ttl = ? ) : bool
public dump ( int $$num ) : mixed
public flush ( ) : bool
public get ( string|array $key , int &$cas = null ) : mixed
public __get ( string $key ) : mixed
public info ( ) : array
public set ( string $keys , mixed $value , int $ttl = 0 ) : bool
public add ( array $key_vals ) : bool
public __set ( string $keys , mixed $value ) : mixed
}

Propiedades

_prefix

Tabla de contenidos

  • Yac::add — Guardar en caché
  • Yac::__construct — Constructor
  • Yac::delete — Eliminar los artículos de la memoria caché
  • Yac::dump — Volcar cache
  • Yac::flush — Limpiar el caché
  • Yac::get — Recuperar los valores de caché
  • Yac::__get — Getter
  • Yac::info — Estado del caché
  • Yac::set — Guardar en el caché
  • Yac::__set — Setter


Guardar en caché

  • « Yac
  • Yac::__construct »
  • PHP Manual
  • Yac
  • Guardar en caché

Yac::add

(PECL yac >= 1.0.0)

Yac::add — Guardar en caché

Descripción

public Yac::add ( string $keys , mixed $value , int $ttl = 0 ) : bool
public Yac::add ( array $key_vals ) : bool

Añadir un artículo al caché.

Parámetros

keys

string clave

value

valor mixto, Todo tipo de valor php podría ser almacenado excepto recurso

ttl

tiempo de expiración

Valores devueltos

bool, true en caso de éxito, false en caso de fallar.

Nota:

Yac::add() puede fallar si el casillero no se puede obtener, así que, si necesitas que el valor se almacene correctamente, puedes escribir códigos como:

Ejemplo #1 Asegúrate de que el artículo se almacene

while(!$yac->set("key", "vale));


Constructor

  • « Yac::add
  • Yac::delete »
  • PHP Manual
  • Yac
  • Constructor

Yac::__construct

(PECL yac >= 1.0.0)

Yac::__construct — Constructor

Descripción

public Yac::__construct ( string $prefix = "" )

se utiliza un prefijo para preparar las claves, esto podría utilizarse para evitar conflictos entre aplicaciones.

Parámetros

prefix

string prefix


Eliminar los artículos de la memoria caché

  • « Yac::__construct
  • Yac::dump »
  • PHP Manual
  • Yac
  • Eliminar los artículos de la memoria caché

Yac::delete

(PECL yac >= 1.0.0)

Yac::delete — Eliminar los artículos de la memoria caché

Descripción

public Yac::delete ( string|array $keys , int $ttl = ? ) : bool

retira los artículos de la memoria caché

Parámetros

keys

clave string, o array de multiples claves para ser removidas.

ttl

si se establece un retraso, la eliminación marcará los elementos como inválidos en ttl segundo.

Valores devueltos


Volcar cache

  • « Yac::delete
  • Yac::flush »
  • PHP Manual
  • Yac
  • Volcar cache

Yac::dump

(PECL yac >= 1.0.0)

Yac::dump — Volcar cache

Descripción

public Yac::dump ( int $$num ) : mixed

Volcar valores almacenados en caché

Parámetros

num

El número máximo de artículos debe ser devuelto

Valores devueltos

mixed


Limpiar el caché

  • « Yac::dump
  • Yac::get »
  • PHP Manual
  • Yac
  • Limpiar el caché

Yac::flush

(PECL yac >= 1.0.0)

Yac::flush — Limpiar el caché

Descripción

public Yac::flush ( ) : bool

Eliminar todos los valores almacenados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

bool, siempre true


Recuperar los valores de caché

  • « Yac::flush
  • Yac::__get »
  • PHP Manual
  • Yac
  • Recuperar los valores de caché

Yac::get

(PECL yac >= 1.0.0)

Yac::get — Recuperar los valores de caché

Descripción

public Yac::get ( string|array $key , int &$cas = null ) : mixed

Recuperar los valores de caché

Parámetros

key

claves string, o array de multiples claves.

cas

Si no es null, se ajustará al caso del artículo recuperado.

Valores devueltos

mixed en caso de éxito, false en caso de error


Getter

  • « Yac::get
  • Yac::info »
  • PHP Manual
  • Yac
  • Getter

Yac::__get

(PECL yac >= 1.0.0)

Yac::__get — Getter

Descripción

public Yac::__get ( string $key ) : mixed

Recupera los valores del caché

Parámetros

key

clave string

Valores devueltos

mixed en caso de éxito, null en caso de error.


Estado del caché

  • « Yac::__get
  • Yac::set »
  • PHP Manual
  • Yac
  • Estado del caché

Yac::info

(PECL yac >= 1.0.0)

Yac::info — Estado del caché

Descripción

public Yac::info ( ) : array

Obtener el estado del sistema de caché

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array, consistente con: "memory_size", "slots_memory_size", "values_memory_size", "segment_size", "segment_num", "miss", "hits", "fails", "kicks", "recycles", "slots_size", "slots_used"


Guardar en el caché

  • « Yac::info
  • Yac::__set »
  • PHP Manual
  • Yac
  • Guardar en el caché

Yac::set

(PECL yac >= 1.0.0)

Yac::set — Guardar en el caché

Descripción

public Yac::set ( string $keys , mixed $value , int $ttl = 0 ) : bool
public Yac::add ( array $key_vals ) : bool

Añade un elemento a la caché, si la clave ya existe, se sobreescribe.

Parámetros

keys

clave string

value

valor mixed, Todo tipo de valor php podría ser almacenado excepto recurso

ttl

tiempo de expiración

Valores devueltos

el valor de sí mismo


Setter

  • « Yac::set
  • Manipulación de formatos de audio »
  • PHP Manual
  • Yac
  • Setter

Yac::__set

(PECL yac >= 1.0.0)

Yac::__set — Setter

Descripción

public Yac::__set ( string $keys , mixed $value ) : mixed

almacena un elemento en el caché

Parámetros

keys

clave string

value

valor mixed, Todo tipo de valor php podría ser almacenado excepto recurso

Valores devueltos

Siempre devuelve el valor de sí mismo


Manipulación de formatos de audio

  • OpenAL — Vinculaciones de audio del OpenAL
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de OpenAL


Vinculaciones de audio del OpenAL

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de OpenAL
    • openal_buffer_create — Genera un buffer OpenAL
    • openal_buffer_data — Carga un buffer con datos
    • openal_buffer_destroy — Destruye un buffer OpenAL
    • openal_buffer_get — Recupera una propiedad del buffer OpenAL
    • openal_buffer_loadwav — Carga un archivo .wav dentro de un buffer
    • openal_context_create — Crea un contexto de procesamiento de audio
    • openal_context_current — Crea el corriente contexto especificado
    • openal_context_destroy — Destruye un contexto
    • openal_context_process — Procesa un contexto especificado
    • openal_context_suspend — Suspende el contexto especificado
    • openal_device_close — Cierra un dispositivo OpenAL
    • openal_device_open — Inicia la capa de audio del OpenAL
    • openal_listener_get — Devuelve una propiedad de oyente
    • openal_listener_set — Establece una propiedad de oyente
    • openal_source_create — Genera una fuente de recursos
    • openal_source_destroy — Destruye una fuente de recursos
    • openal_source_get — Recupera una propiedad de una fuente del OpenAL
    • openal_source_pause — Pausa la fuente
    • openal_source_play — Empieza la reproducción de la fuente
    • openal_source_rewind — Rebobina la fuente
    • openal_source_set — Establece la propiedad de la fuente
    • openal_source_stop — Detiene la reproducción de la fuente
    • openal_stream — Empieza la salida de una fuente


Introducción

Vinculaciones de audio independientes de la plataforma. Requiere la » biblioteca OpenAL.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/openal.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Instalación
  • Tipos de recursos »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


Tipos de recursos

Esta extensión define cuatro tipos de recursos:
Open AL(Device) - Devuelto por openal_device_open(),
Open AL(Context) - Devuelto por openal_context_create(),
Open AL(Buffer) - Devuelto por openal_buffer_create(),
y Open AL(Source) - Devuelto por openal_source_create().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

ALC_FREQUENCY (integer)
Atributo de contexto
ALC_REFRESH (integer)
Atributo de contexto
ALC_SYNC (integer)
Atributo de contexto
AL_FREQUENCY (integer)
Establecer el buffer
AL_BITS (integer)
Establecer el buffer
AL_CHANNELS (integer)
Establecer el buffer
AL_SIZE (integer)
Establecer el buffer
AL_BUFFER (integer)
Establecer Fuente/Oyente (Entero)
AL_SOURCE_RELATIVE (integer)
Establecer Fuente/Oyente (Entero)
AL_SOURCE_STATE (integer)
Establecer Fuente/Oyente (Entero)
AL_PITCH (integer)
Establecer Fuente/Oyente (Flotante)
AL_GAIN (integer)
Establecer Fuente/Oyente (Flotante)
AL_MIN_GAIN (integer)
Establecer Fuente/Oyente (Flotante)
AL_MAX_GAIN (integer)
Establecer Fuente/Oyente (Flotante)
AL_MAX_DISTANCE (integer)
Establecer Fuente/Oyente (Flotante)
AL_ROLLOFF_FACTOR (integer)
Establecer Fuente/Oyente (Flotante)
AL_CONE_OUTER_GAIN (integer)
Establecer Fuente/Oyente (Flotante)
AL_CONE_INNER_ANGLE (integer)
Establecer Fuente/Oyente (Flotante)
AL_CONE_OUTER_ANGLE (integer)
Establecer Fuente/Oyente (Flotante)
AL_REFERENCE_DISTANCE (integer)
Establecer Fuente/Oyente (Flotante)
AL_POSITION (integer)
Establecer Fuente/Oyente (Vector Flotante)
AL_VELOCITY (integer)
Establecer Fuente/Oyente (Vector Flotante)
AL_DIRECTION (integer)
Establecer Fuente/Oyente (Vector Flotante)
AL_ORIENTATION (integer)
Establecer Fuente/Oyente (Vector Flotante)
AL_FORMAT_MONO8 (integer)
Formato PCM
AL_FORMAT_MONO16 (integer)
Formato PCM
AL_FORMAT_STEREO8 (integer)
Formato PCM
AL_FORMAT_STEREO16 (integer)
Formato PCM
AL_INITIAL (integer)
Fuente de Estado
AL_PLAYING (integer)
Fuente de Estado
AL_PAUSED (integer)
Fuente de Estado
AL_STOPPED (integer)
Fuente de Estado
AL_LOOPING (integer)
Fuente de Estado
AL_TRUE (integer)
Valor Booleano reconocido por OpenAL
AL_FALSE (integer)
Valor Booleano reconocido por OpenAL


Funciones de OpenAL

Tabla de contenidos

  • openal_buffer_create — Genera un buffer OpenAL
  • openal_buffer_data — Carga un buffer con datos
  • openal_buffer_destroy — Destruye un buffer OpenAL
  • openal_buffer_get — Recupera una propiedad del buffer OpenAL
  • openal_buffer_loadwav — Carga un archivo .wav dentro de un buffer
  • openal_context_create — Crea un contexto de procesamiento de audio
  • openal_context_current — Crea el corriente contexto especificado
  • openal_context_destroy — Destruye un contexto
  • openal_context_process — Procesa un contexto especificado
  • openal_context_suspend — Suspende el contexto especificado
  • openal_device_close — Cierra un dispositivo OpenAL
  • openal_device_open — Inicia la capa de audio del OpenAL
  • openal_listener_get — Devuelve una propiedad de oyente
  • openal_listener_set — Establece una propiedad de oyente
  • openal_source_create — Genera una fuente de recursos
  • openal_source_destroy — Destruye una fuente de recursos
  • openal_source_get — Recupera una propiedad de una fuente del OpenAL
  • openal_source_pause — Pausa la fuente
  • openal_source_play — Empieza la reproducción de la fuente
  • openal_source_rewind — Rebobina la fuente
  • openal_source_set — Establece la propiedad de la fuente
  • openal_source_stop — Detiene la reproducción de la fuente
  • openal_stream — Empieza la salida de una fuente


Genera un buffer OpenAL

  • « Funciones de OpenAL
  • openal_buffer_data »
  • PHP Manual
  • Funciones de OpenAL
  • Genera un buffer OpenAL

openal_buffer_create

(PECL openal >= 0.1.0)

openal_buffer_create — Genera un buffer OpenAL

Descripción

openal_buffer_create ( ) : resource

Valores devueltos

Devuelve un recurso Open AL(Buffer) en éxito o false en fallo.

Ver también

  • openal_buffer_loadwav() - Carga un archivo .wav dentro de un buffer
  • openal_buffer_data() - Carga un buffer con datos


Carga un buffer con datos

  • « openal_buffer_create
  • openal_buffer_destroy »
  • PHP Manual
  • Funciones de OpenAL
  • Carga un buffer con datos

openal_buffer_data

(PECL openal >= 0.1.0)

openal_buffer_data — Carga un buffer con datos

Descripción

openal_buffer_data ( resource $buffer , int $format , string $data , int $freq ) : bool

Parámetros

buffer

Un recurso Open AL(Buffer) (previamente creado por openal_buffer_create()).

format

Formato de data, uno de: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 y AL_FORMAT_STEREO16

data

Bloque de datos de audio binario en el format y el freq especificado.

freq

Frecuencia de data dados en Hz.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_buffer_loadwav() - Carga un archivo .wav dentro de un buffer
  • openal_stream() - Empieza la salida de una fuente


Destruye un buffer OpenAL

  • « openal_buffer_data
  • openal_buffer_get »
  • PHP Manual
  • Funciones de OpenAL
  • Destruye un buffer OpenAL

openal_buffer_destroy

(PECL openal >= 0.1.0)

openal_buffer_destroy — Destruye un buffer OpenAL

Descripción

openal_buffer_destroy ( resource $buffer ) : bool

Parámetros

buffer

Un recurso Open AL(Buffer) (previamente creado por openal_buffer_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_buffer_create() - Genera un buffer OpenAL


Recupera una propiedad del buffer OpenAL

  • « openal_buffer_destroy
  • openal_buffer_loadwav »
  • PHP Manual
  • Funciones de OpenAL
  • Recupera una propiedad del buffer OpenAL

openal_buffer_get

(PECL openal >= 0.1.0)

openal_buffer_get — Recupera una propiedad del buffer OpenAL

Descripción

openal_buffer_get ( resource $buffer , int $property ) : int

Parámetros

buffer

Un recurso Open AL(Buffer) (previamente creado por openal_buffer_create()).

property

Propiedad especifica, una de: AL_FREQUENCY, AL_BITS, AL_CHANNELS y AL_SIZE.

Valores devueltos

Devuelve un valor entero apropiada a la property requerida o false en caso de error.

Ver también

  • openal_buffer_create() - Genera un buffer OpenAL


Carga un archivo .wav dentro de un buffer

  • « openal_buffer_get
  • openal_context_create »
  • PHP Manual
  • Funciones de OpenAL
  • Carga un archivo .wav dentro de un buffer

openal_buffer_loadwav

(PECL openal >= 0.1.0)

openal_buffer_loadwav — Carga un archivo .wav dentro de un buffer

Descripción

openal_buffer_loadwav ( resource $buffer , string $wavfile ) : bool

Parámetros

buffer

Un recurso Open AL(Buffer) (previamente creado por openal_buffer_create()).

wavfile

Ruta al archivo .wav en el sistema de archivo local.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_buffer_data() - Carga un buffer con datos
  • openal_stream() - Empieza la salida de una fuente


Crea un contexto de procesamiento de audio

  • « openal_buffer_loadwav
  • openal_context_current »
  • PHP Manual
  • Funciones de OpenAL
  • Crea un contexto de procesamiento de audio

openal_context_create

(PECL openal >= 0.1.0)

openal_context_create — Crea un contexto de procesamiento de audio

Descripción

openal_context_create ( resource $device ) : resource

Parámetros

device

Un recurso Open AL(Device) (previamente creado por openal_device_open()).

Valores devueltos

Devuelve un recurso Open AL(Context) en éxito o false en fallo.

Ver también

  • openal_device_open() - Inicia la capa de audio del OpenAL
  • openal_context_destroy() - Destruye un contexto


Crea el corriente contexto especificado

  • « openal_context_create
  • openal_context_destroy »
  • PHP Manual
  • Funciones de OpenAL
  • Crea el corriente contexto especificado

openal_context_current

(PECL openal >= 0.1.0)

openal_context_current — Crea el corriente contexto especificado

Descripción

openal_context_current ( resource $context ) : bool

Parámetros

context

Un recurso Open AL(Context) (previamente creado por openal_context_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_context_create() - Crea un contexto de procesamiento de audio


Destruye un contexto

  • « openal_context_current
  • openal_context_process »
  • PHP Manual
  • Funciones de OpenAL
  • Destruye un contexto

openal_context_destroy

(PECL openal >= 0.1.0)

openal_context_destroy — Destruye un contexto

Descripción

openal_context_destroy ( resource $context ) : bool

Parámetros

context

Un recurso Open AL(Context) (previamente creado por openal_context_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_context_create() - Crea un contexto de procesamiento de audio


Procesa un contexto especificado

  • « openal_context_destroy
  • openal_context_suspend »
  • PHP Manual
  • Funciones de OpenAL
  • Procesa un contexto especificado

openal_context_process

(PECL openal >= 0.1.0)

openal_context_process — Procesa un contexto especificado

Descripción

openal_context_process ( resource $context ) : bool

Parámetros

context

Un recurso Open AL(Context) (previamente creado por openal_context_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_context_create() - Crea un contexto de procesamiento de audio
  • openal_context_current() - Crea el corriente contexto especificado
  • openal_context_suspend() - Suspende el contexto especificado


Suspende el contexto especificado

  • « openal_context_process
  • openal_device_close »
  • PHP Manual
  • Funciones de OpenAL
  • Suspende el contexto especificado

openal_context_suspend

(PECL openal >= 0.1.0)

openal_context_suspend — Suspende el contexto especificado

Descripción

openal_context_suspend ( resource $context ) : bool

Parámetros

context

Un recurso Open AL(Context) (previamente creado por openal_context_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_context_create() - Crea un contexto de procesamiento de audio
  • openal_context_current() - Crea el corriente contexto especificado
  • openal_context_process() - Procesa un contexto especificado


Cierra un dispositivo OpenAL

  • « openal_context_suspend
  • openal_device_open »
  • PHP Manual
  • Funciones de OpenAL
  • Cierra un dispositivo OpenAL

openal_device_close

(PECL openal >= 0.1.0)

openal_device_close — Cierra un dispositivo OpenAL

Descripción

openal_device_close ( resource $device ) : bool

Parámetros

device

Un recurso Open AL(Device) (previamente creado por openal_device_open()) para ser cerrado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_device_open() - Inicia la capa de audio del OpenAL


Inicia la capa de audio del OpenAL

  • « openal_device_close
  • openal_listener_get »
  • PHP Manual
  • Funciones de OpenAL
  • Inicia la capa de audio del OpenAL

openal_device_open

(PECL openal >= 0.1.0)

openal_device_open — Inicia la capa de audio del OpenAL

Descripción

openal_device_open ( string $device_desc = ? ) : resource

Parámetros

device_desc

Abre un dispositivo de audio especiado opcionalmente por device_desc. Si device_desc no está especificado el primer dispositivo de audio disponible será usado.

Valores devueltos

Devuelve un recurso Open AL(Device) en éxito o false en fallo.

Ver también

  • openal_device_close() - Cierra un dispositivo OpenAL
  • openal_context_create() - Crea un contexto de procesamiento de audio


Devuelve una propiedad de oyente

  • « openal_device_open
  • openal_listener_set »
  • PHP Manual
  • Funciones de OpenAL
  • Devuelve una propiedad de oyente

openal_listener_get

(PECL openal >= 0.1.0)

openal_listener_get — Devuelve una propiedad de oyente

Descripción

openal_listener_get ( int $property ) : mixed

Parámetros

property

Propiedad para recuperar, una de:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) y
AL_ORIENTATION (array(float,float,float)).

Valores devueltos

Devuelve un flotante o un arreglo de flotantes (como apropiado) o false en caso de error.

Ver también

  • openal_listener_set() - Establece una propiedad de oyente


Establece una propiedad de oyente

  • « openal_listener_get
  • openal_source_create »
  • PHP Manual
  • Funciones de OpenAL
  • Establece una propiedad de oyente

openal_listener_set

(PECL openal >= 0.1.0)

openal_listener_set — Establece una propiedad de oyente

Descripción

openal_listener_set ( int $property , mixed $setting ) : bool

Parámetros

property

Propiedad a establecer, una de:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) y
AL_ORIENTATION (array(float,float,float)).

setting

Valor a establecer, ya sea flotante, o un arreglo de flotantes como apropiado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_listener_get() - Devuelve una propiedad de oyente


Genera una fuente de recursos

  • « openal_listener_set
  • openal_source_destroy »
  • PHP Manual
  • Funciones de OpenAL
  • Genera una fuente de recursos

openal_source_create

(PECL openal >= 0.1.0)

openal_source_create — Genera una fuente de recursos

Descripción

openal_source_create ( ) : resource

Valores devueltos

Devuelve un recurso Open AL(Source) en éxito o false en fallo.

Ver también

  • openal_source_set() - Establece la propiedad de la fuente
  • openal_source_play() - Empieza la reproducción de la fuente
  • openal_source_destroy() - Destruye una fuente de recursos


Destruye una fuente de recursos

  • « openal_source_create
  • openal_source_get »
  • PHP Manual
  • Funciones de OpenAL
  • Destruye una fuente de recursos

openal_source_destroy

(PECL openal >= 0.1.0)

openal_source_destroy — Destruye una fuente de recursos

Descripción

openal_source_destroy ( resource $source ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_create() - Genera una fuente de recursos


Recupera una propiedad de una fuente del OpenAL

  • « openal_source_destroy
  • openal_source_pause »
  • PHP Manual
  • Funciones de OpenAL
  • Recupera una propiedad de una fuente del OpenAL

openal_source_get

(PECL openal >= 0.1.0)

openal_source_get — Recupera una propiedad de una fuente del OpenAL

Descripción

openal_source_get ( resource $source , int $property ) : mixed

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

property

Propiedad para obtener, una de: AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

Valores devueltos

Devuelve el tipo asociado con la propiedad que se recupera o false en caso de error.

Ver también

  • openal_source_create() - Genera una fuente de recursos
  • openal_source_set() - Establece la propiedad de la fuente
  • openal_source_play() - Empieza la reproducción de la fuente


Pausa la fuente

  • « openal_source_get
  • openal_source_play »
  • PHP Manual
  • Funciones de OpenAL
  • Pausa la fuente

openal_source_pause

(PECL openal >= 0.1.0)

openal_source_pause — Pausa la fuente

Descripción

openal_source_pause ( resource $source ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_stop() - Detiene la reproducción de la fuente
  • openal_source_play() - Empieza la reproducción de la fuente
  • openal_source_rewind() - Rebobina la fuente


Empieza la reproducción de la fuente

  • « openal_source_pause
  • openal_source_rewind »
  • PHP Manual
  • Funciones de OpenAL
  • Empieza la reproducción de la fuente

openal_source_play

(PECL openal >= 0.1.0)

openal_source_play — Empieza la reproducción de la fuente

Descripción

openal_source_play ( resource $source ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_stop() - Detiene la reproducción de la fuente
  • openal_source_pause() - Pausa la fuente
  • openal_source_rewind() - Rebobina la fuente


Rebobina la fuente

  • « openal_source_play
  • openal_source_set »
  • PHP Manual
  • Funciones de OpenAL
  • Rebobina la fuente

openal_source_rewind

(PECL openal >= 0.1.0)

openal_source_rewind — Rebobina la fuente

Descripción

openal_source_rewind ( resource $source ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_stop() - Detiene la reproducción de la fuente
  • openal_source_pause() - Pausa la fuente
  • openal_source_play() - Empieza la reproducción de la fuente


Establece la propiedad de la fuente

  • « openal_source_rewind
  • openal_source_stop »
  • PHP Manual
  • Funciones de OpenAL
  • Establece la propiedad de la fuente

openal_source_set

(PECL openal >= 0.1.0)

openal_source_set — Establece la propiedad de la fuente

Descripción

openal_source_set ( resource $source , int $property , mixed $setting ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

property

Propiedad para establecer, una de: AL_BUFFER (OpenAL(Source)), AL_LOOPING (bool), AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

setting

El valor para asignar a la property especifica. Consulta la descripción de la property para una descripción de el valor(es) esperando.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_create() - Genera una fuente de recursos
  • openal_source_get() - Recupera una propiedad de una fuente del OpenAL
  • openal_source_play() - Empieza la reproducción de la fuente


Detiene la reproducción de la fuente

  • « openal_source_set
  • openal_stream »
  • PHP Manual
  • Funciones de OpenAL
  • Detiene la reproducción de la fuente

openal_source_stop

(PECL openal >= 0.1.0)

openal_source_stop — Detiene la reproducción de la fuente

Descripción

openal_source_stop ( resource $source ) : bool

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openal_source_play() - Empieza la reproducción de la fuente
  • openal_source_pause() - Pausa la fuente
  • openal_source_rewind() - Rebobina la fuente


Empieza la salida de una fuente

  • « openal_source_stop
  • Servicios de autenticación »
  • PHP Manual
  • Funciones de OpenAL
  • Empieza la salida de una fuente

openal_stream

(PECL openal >= 0.1.0)

openal_stream — Empieza la salida de una fuente

Descripción

openal_stream ( resource $source , int $format , int $rate ) : resource

Parámetros

source

Un recurso Open AL(Source) (previamente creado por openal_source_create()).

format

Formato de data, uno de: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 y AL_FORMAT_STEREO16

rate

Frecuencias de datos para las salidas dadas en Hz.

Valores devueltos

Devuelve un recurso de salida en success o false en caso de error.

Ver también

  • openal_source_create() - Genera una fuente de recursos
  • fwrite() - Escritura de un archivo en modo binario seguro


Servicios de autenticación

  • Radius
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones Radius


Radius

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • RADIUS Options
    • RADIUS Packet Types
    • RADIUS Attribute Types
    • RADIUS Vendor Specific Attribute Types
  • Ejemplos
  • Funciones Radius
    • radius_acct_open — Crea un manejador Radius para el conteo
    • radius_add_server — Adds a server
    • radius_auth_open — Crea un identificador de Radius para la autenticación
    • radius_close — Libera todos los recursos
    • radius_config — Causes the library to read the given configuration file
    • radius_create_request — Create accounting or authentication request
    • radius_cvt_addr — Converts raw data to IP-Address
    • radius_cvt_int — Converts raw data to integer
    • radius_cvt_string — Converts raw data to string
    • radius_demangle_mppe_key — Derives mppe-keys from mangled data
    • radius_demangle — Demangles data
    • radius_get_attr — Extracts an attribute
    • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
    • radius_get_vendor_attr — Extracts a vendor specific attribute
    • radius_put_addr — Attaches an IP address attribute
    • radius_put_attr — Attaches a binary attribute
    • radius_put_int — Attaches an integer attribute
    • radius_put_string — Attaches a string attribute
    • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr — Attaches a vendor specific binary attribute
    • radius_put_vendor_int — Attaches a vendor specific integer attribute
    • radius_put_vendor_string — Attaches a vendor specific string attribute
    • radius_request_authenticator — Returns the request authenticator
    • radius_salt_encrypt_attr — Salt-encrypts a value
    • radius_send_request — Sends the request and waits for a reply
    • radius_server_secret — Returns the shared secret
    • radius_strerror — Devuelve un mensaje de error


Introducción

Este paquete se basa en los libradius de FreeBSD (Autenticación remota telefónica de servicio de usuario). Permite a los clientes realizar la autenticación y la contabilidad por medio de solicitudes de red a servidores remotos.

Esta extensión PECL añade soporte completo para la autenticación Radius (» RFC 2865) y contabilidad Radius (» RFC 2866). Este paquete está disponible para Unix (probado en FreeBSD y Linux) y para Windows.

Nota:

Una descripción exacta de libradius se pueden encontrar » aquí. Una descripción detallada del archivo de configuración se puede encontrar » aquí.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/radius.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Constantes predefinidas

Tabla de contenidos

  • RADIUS Options
  • RADIUS Packet Types
  • RADIUS Attribute Types
  • RADIUS Vendor Specific Attribute Types

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

RADIUS_MPPE_KEY_LEN (int)
The maximum length of MPPE keys.


RADIUS Options

Several RADIUS functions accept option flags as bitmasks. The constants representing those flags are listed below.

RADIUS_OPTION_SALT (int)

When set, this option will result in the attribute value being salt-encrypted.

RADIUS_OPTION_TAGGED (int)

When set, this option will result in the attribute value being tagged with the value of the tag parameter.


RADIUS Packet Types

RADIUS packets, whether requests or responses, always include a type. These constants are provided to make it easier to specify types when using radius_create_request() and when comparing the result of radius_send_request().

RADIUS_ACCESS_REQUEST (int)

An Access-Request, used to authenticate a user against a RADIUS server. Access request packets must include a RADIUS_NAS_IP_ADDRESS or a RADIUS_NAS_IDENTIFIER attribute, must also include a RADIUS_USER_PASSWORD, RADIUS_CHAP_PASSWORD or a RADIUS_STATE attribute, and should include a RADIUS_USER_NAME attribute.

RADIUS_ACCESS_ACCEPT (int)

An Access-Accept response to an Access-Request indicating that the RADIUS server authenticated the user successfully.

RADIUS_ACCESS_REJECT (int)

An Access-Reject response to an Access-Request indicating that the RADIUS server could not authenticate the user.

RADIUS_ACCESS_CHALLENGE (int)

An Access-Challenge response to an Access-Request indicating that the RADIUS server requires further information in another Access-Request before authenticating the user.

RADIUS_ACCOUNTING_REQUEST (int)

An Accounting-Request, used to convey accounting information for a service to the RADIUS server.

RADIUS_ACCOUNTING_RESPONSE (int)

An Accounting-Response response to an Accounting-Request.

RADIUS_COA_REQUEST (int)

A CoA-Request, sent from the RADIUS server to indicate that the authorisations within the user session have changed. A response must be sent in the form of a CoA-ACK or a CoA-NAK.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_ACK (int)

A CoA-ACK, sent to the RADIUS server to indicate that the user authorisations have been updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_NAK (int)

A CoA-NAK, sent to the RADIUS server to indicate that the user authorisations could not be updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_REQUEST (int)

A Disconnect-Request, sent from the RADIUS server to indicate that the user session must be terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_ACK (int)

A Disconnect-ACK, sent to the RADIUS server to indicate that the user session has been terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_NAK (int)

A Disconnect-NAK, sent to the RADIUS server to indicate that the user session could not be terminated.

This constant is available in PECL radius 1.3.0 and later.


RADIUS Attribute Types

These constants define RADIUS attribute types that can be used with
radius_put_addr(), radius_put_attr(),
radius_put_int() and
radius_put_string().

RADIUS_USER_NAME (int)

The User-Name attribute. The attribute value is expected to be a string containing the name of the user being authenticated, and can be set using radius_put_attr().

RADIUS_USER_PASSWORD (int)

The User-Password attribute. The attribute value is expected to be a string containing the user's password, and can be set using radius_put_attr(). This value will be obfuscated on transmission as described in » section 5.2 of RFC 2865.

RADIUS_CHAP_PASSWORD (int)

The Chap-Password attribute. The attribute value is expected to be a string with the first byte containing the CHAP identifier, and the subsequent 16 bytes containing the MD5 hash of the CHAP identifier, the plaintext password and the CHAP challenge value concatenated together. Note that the CHAP challenge value should also be sent separately in a RADIUS_CHAP_CHALLENGE attribute.

Ejemplo #1 Using CHAP passwords

<?php
// Firstly, we'll create an authentication handle and request.
$radh = radius_auth_open();
radius_add_server($radh, $server, $port, $secret, 3, 3);
radius_create_request($radh, RADIUS_ACCESS_REQUEST);

// Assuming $password contains the plaintext password, we now:

// Generate a challenge.
$challenge = mt_rand();

// Specify a CHAP identifier.
$ident = 1;

// Add the Chap-Password attribute.
$cp = md5(pack('Ca*', $ident, $password.$challenge), true);
radius_put_attr($radh, RADIUS_CHAP_PASSWORD, pack('C', $ident).$cp);

// Add the Chap-Challenge attribute.
radius_put_attr($radh, RADIUS_CHAP_CHALLENGE, $challenge);

/* From here, you would add the remaining attributes and
 * call radius_send_request(). */
?>

RADIUS_NAS_IP_ADDRESS (int)

The NAS-IP-Address attribute. The attribute value is expected to the IP address of the RADIUS client encoded as an int, which can be set using radius_put_addr().

RADIUS_NAS_PORT (int)

The NAS-Port attribute. The attribute value is expected to be the physical port of the user on the RADIUS client encoded as an int, which can be set using radius_put_int().

RADIUS_SERVICE_TYPE (int)

The Service-Type attribute. The attribute value indicates the service type the user is requesting, and is expected to be an int, which can be set using radius_put_int().

A number of constants are provided to represent the possible values of this attribute. They include:

  • RADIUS_LOGIN
  • RADIUS_FRAMED
  • RADIUS_CALLBACK_LOGIN
  • RADIUS_CALLBACK_FRAMED
  • RADIUS_OUTBOUND
  • RADIUS_ADMINISTRATIVE
  • RADIUS_NAS_PROMPT
  • RADIUS_AUTHENTICATE_ONLY
  • RADIUS_CALLBACK_NAS_PROMPT

RADIUS_FRAMED_PROTOCOL (int)

The Framed-Protocol attribute. The attribute value is expected to be an int indicating the framing to be used for framed access, and can be set using radius_put_int(). The possible attribute values include these constants:

  • RADIUS_PPP
  • RADIUS_SLIP
  • RADIUS_ARAP
  • RADIUS_GANDALF
  • RADIUS_XYLOGICS

RADIUS_FRAMED_IP_ADDRESS (int)

The Framed-IP-Address attribute. The attribute value is expected to be the address of the user's network encoded as an int, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_IP_NETMASK (int)

The Framed-IP-Netmask attribute. The attribute value is expected to be the netmask of the user's network encoded as an int, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_ROUTING (int)

The Framed-Routing attribute. The attribute value is expected to be an int indicating the routing method for the user, which can be set using radius_put_int().

Possible values include:

  • 0: No routing
  • 1: Send routing packets
  • 2: Listen for routing packets
  • 3: Send and listen

RADIUS_FILTER_ID (int)

The Filter-ID attribute. The attribute value is expected to be an implementation-specific, human-readable string of filters, which can be set using radius_put_attr().

RADIUS_FRAMED_MTU (int)

The Framed-MTU attribute. The attribute value is expected to be an int indicating the MTU to be configured for the user, and can be set using radius_put_int().

RADIUS_FRAMED_COMPRESSION (int)

The Framed-Compression attribute. The attribute value is expected to be an int indicating the compression protocol to be used, and can be set using radius_put_int(). Possible values include these constants:

  • RADIUS_COMP_NONE: No compression
  • RADIUS_COMP_VJ: VJ TCP/IP header compression
  • RADIUS_COMP_IPXHDR: IPX header compression
  • RADIUS_COMP_STAC_LZS: Stac-LZS compression (added in PECL radius 1.3.0b2)

RADIUS_LOGIN_IP_HOST (int)

The Login-IP-Host attribute. The attribute value is expected to the IP address to connect the user to, encoded as an int, which can be set using radius_put_addr().

RADIUS_LOGIN_SERVICE (int)

The Login-Service attribute. The attribute value is an int indicating the service to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_LOGIN_TCP_PORT (int)

The Login-TCP-Port attribute. The attribute value is an int indicating the port to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_REPLY_MESSAGE (int)

The Reply-Message attribute. The attribute value is a string containing text that may be displayed to the user in response to an access request.

RADIUS_CALLBACK_NUMBER (int)

The Callback-Number attribute. The attribute value is a string containing the dialing string to use for callback.

RADIUS_CALLBACK_ID (int)

The Callback-Id attribute. The attribute value is a string containing an implementation-specific name of the place to be called.

RADIUS_FRAMED_ROUTE (int)

The Framed-Route attribute. The attribute value is a string containing an implementation-specific set of routes to be configured for the user.

RADIUS_FRAMED_IPX_NETWORK (int)

The Framed-IPX-Network attribute. The attribute value is an int containing the IPX network to be configured for the user, or 0xFFFFFFFE to indicate that the RADIUS client should select the network, and can be accessed via radius_cvt_int().

RADIUS_STATE (int)

The State attribute. The attribute value is an implementation-defined string included in an Access-Challenge from a server that must be included in the subsequent Access-Request, and can be set using radius_put_attr().

RADIUS_CLASS (int)

The Class attribute. The attribute value is an arbitrary string included in an Access-Accept message that should then be sent to the accounting server in Accounting-Request messages, and can be set using radius_put_attr().

RADIUS_VENDOR_SPECIFIC (int)

The Vendor-Specific attribute. In general, vendor attribute values
should be set using radius_put_vendor_addr(),
radius_put_vendor_attr(),
radius_put_vendor_int() and
radius_put_vendor_string(), rather than directly.

This constant is mostly useful when interpreting vendor specific attributes in responses from a RADIUS server; when a vendor specific attribute is received, the radius_get_vendor_attr() function should be used to access the vendor ID, attribute type and attribute value.

RADIUS_SESSION_TIMEOUT (int)

Session timeout

RADIUS_IDLE_TIMEOUT (int)

Idle timeout

RADIUS_TERMINATION_ACTION (int)

Termination action

RADIUS_CALLED_STATION_ID (int)

Called Station Id

RADIUS_CALLING_STATION_ID (int)

Calling Station Id

RADIUS_NAS_IDENTIFIER (int)

NAS ID

RADIUS_PROXY_STATE (int)

Proxy State

RADIUS_LOGIN_LAT_SERVICE (int)

Login LAT Service

RADIUS_LOGIN_LAT_NODE (int)

Login LAT Node

RADIUS_LOGIN_LAT_GROUP (int)

Login LAT Group

RADIUS_FRAMED_APPLETALK_LINK (int)

Framed Appletalk Link

RADIUS_FRAMED_APPLETALK_NETWORK (int)

Framed Appletalk Network

RADIUS_FRAMED_APPLETALK_ZONE (int)

Framed Appletalk Zone

RADIUS_CHAP_CHALLENGE (int)

Challenge

RADIUS_NAS_PORT_TYPE (int)

NAS port type, one of:

  • RADIUS_ASYNC
  • RADIUS_SYNC
  • RADIUS_ISDN_SYNC
  • RADIUS_ISDN_ASYNC_V120
  • RADIUS_ISDN_ASYNC_V110
  • RADIUS_VIRTUAL
  • RADIUS_PIAFS
  • RADIUS_HDLC_CLEAR_CHANNEL
  • RADIUS_X_25
  • RADIUS_X_75
  • RADIUS_G_3_FAX
  • RADIUS_SDSL
  • RADIUS_ADSL_CAP
  • RADIUS_ADSL_DMT
  • RADIUS_IDSL
  • RADIUS_ETHERNET
  • RADIUS_XDSL
  • RADIUS_CABLE
  • RADIUS_WIRELESS_OTHER
  • RADIUS_WIRELESS_IEEE_802_11

RADIUS_PORT_LIMIT (int)

Port Limit

RADIUS_LOGIN_LAT_PORT (int)

Login LAT Port

RADIUS_CONNECT_INFO (int)

Connect info

RADIUS_ACCT_STATUS_TYPE (int)

Accounting status type, one of:

  • RADIUS_START
  • RADIUS_STOP
  • RADIUS_ACCOUNTING_ON
  • RADIUS_ACCOUNTING_OFF

RADIUS_ACCT_DELAY_TIME (int)

Accounting delay time

RADIUS_ACCT_INPUT_OCTETS (int)

Accounting input bytes

RADIUS_ACCT_OUTPUT_OCTETS (int)

Accounting output bytes

RADIUS_ACCT_SESSION_ID (int)

Accounting session ID

RADIUS_ACCT_AUTHENTIC (int)

Accounting authentic, one of:

  • RADIUS_AUTH_RADIUS
  • RADIUS_AUTH_LOCAL
  • RADIUS_AUTH_REMOTE

RADIUS_ACCT_SESSION_TIME (int)

Accounting session time

RADIUS_ACCT_INPUT_PACKETS (int)

Accounting input packets

RADIUS_ACCT_OUTPUT_PACKETS (int)

Accounting output packets

RADIUS_ACCT_TERMINATE_CAUSE (int)

Accounting terminate cause, one of:

  • RADIUS_TERM_USER_REQUEST
  • RADIUS_TERM_LOST_CARRIER
  • RADIUS_TERM_LOST_SERVICE
  • RADIUS_TERM_IDLE_TIMEOUT
  • RADIUS_TERM_SESSION_TIMEOUT
  • RADIUS_TERM_ADMIN_RESET
  • RADIUS_TERM_ADMIN_REBOOT
  • RADIUS_TERM_PORT_ERROR
  • RADIUS_TERM_NAS_ERROR
  • RADIUS_TERM_NAS_REQUEST
  • RADIUS_TERM_NAS_REBOOT
  • RADIUS_TERM_PORT_UNNEEDED
  • RADIUS_TERM_PORT_PREEMPTED
  • RADIUS_TERM_PORT_SUSPENDED
  • RADIUS_TERM_SERVICE_UNAVAILABLE
  • RADIUS_TERM_CALLBACK
  • RADIUS_TERM_USER_ERROR
  • RADIUS_TERM_HOST_REQUEST

RADIUS_ACCT_MULTI_SESSION_ID (int)

Accounting multi session ID

RADIUS_ACCT_LINK_COUNT (int)

Accounting link count


RADIUS Vendor Specific Attribute Types

RADIUS_VENDOR_MICROSOFT (int)

Microsoft specific vendor attributes (» RFC 2548), one of:

  • RADIUS_MICROSOFT_MS_CHAP_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP_ERROR
  • RADIUS_MICROSOFT_MS_CHAP_PW_1
  • RADIUS_MICROSOFT_MS_CHAP_PW_2
  • RADIUS_MICROSOFT_MS_CHAP_LM_ENC_PW
  • RADIUS_MICROSOFT_MS_CHAP_NT_ENC_PW
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_POLICY
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_TYPES
  • RADIUS_MICROSOFT_MS_RAS_VENDOR
  • RADIUS_MICROSOFT_MS_CHAP_DOMAIN
  • RADIUS_MICROSOFT_MS_CHAP_CHALLENGE
  • RADIUS_MICROSOFT_MS_CHAP_MPPE_KEYS
  • RADIUS_MICROSOFT_MS_BAP_USAGE
  • RADIUS_MICROSOFT_MS_LINK_UTILIZATION_THRESHOLD
  • RADIUS_MICROSOFT_MS_LINK_DROP_TIME_LIMIT
  • RADIUS_MICROSOFT_MS_MPPE_SEND_KEY
  • RADIUS_MICROSOFT_MS_MPPE_RECV_KEY
  • RADIUS_MICROSOFT_MS_RAS_VERSION
  • RADIUS_MICROSOFT_MS_OLD_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_NEW_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_ARAP_PASSWORD_CHANGE_REASON
  • RADIUS_MICROSOFT_MS_FILTER
  • RADIUS_MICROSOFT_MS_ACCT_AUTH_TYPE
  • RADIUS_MICROSOFT_MS_ACCT_EAP_TYPE
  • RADIUS_MICROSOFT_MS_CHAP2_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP2_SUCCESS
  • RADIUS_MICROSOFT_MS_CHAP2_PW
  • RADIUS_MICROSOFT_MS_PRIMARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_ARAP_CHALLENGE


Ejemplos

¿Cómo iniciar?

  • Obtener un recurso radius
  • Configurar la librería
  • Crear la petición
  • Poner atributos
  • Enviar la petición
  • Recibir atributos
  • Cerrar el recurso radius (opcional)
También sirve echar un vistazo a los ejemplos en este paquete.

El paquete contiene un ejemplo de script php. Este script demuestra como autenticar con radius utilizando PAP o CHAP (md5). Si se autentica con servidores Microsoft Radius entonces no le será posible utilizar CHAP (md5). Si quisiera autenticarse con servidores Microsoft tiene que utilizar MS-CHAPv1 o MS-CHAPv2, pero es más complicado, porque usted necesita md4, sha1 y des para generar los datos correctos. Los ejemplos adjuntos demuestran todos los métodos de autenticación, incluyendo MS-CHAPv1 y MS-CHAPv2. Para tener funcionando MS-CHAP necesita las extensiones mcrypt y mhash iniciando con la version 1.2 de este paquete, la extensión mcrypt ya no es necesaria.


Funciones Radius

Tabla de contenidos

  • radius_acct_open — Crea un manejador Radius para el conteo
  • radius_add_server — Adds a server
  • radius_auth_open — Crea un identificador de Radius para la autenticación
  • radius_close — Libera todos los recursos
  • radius_config — Causes the library to read the given configuration file
  • radius_create_request — Create accounting or authentication request
  • radius_cvt_addr — Converts raw data to IP-Address
  • radius_cvt_int — Converts raw data to integer
  • radius_cvt_string — Converts raw data to string
  • radius_demangle_mppe_key — Derives mppe-keys from mangled data
  • radius_demangle — Demangles data
  • radius_get_attr — Extracts an attribute
  • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
  • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
  • radius_get_vendor_attr — Extracts a vendor specific attribute
  • radius_put_addr — Attaches an IP address attribute
  • radius_put_attr — Attaches a binary attribute
  • radius_put_int — Attaches an integer attribute
  • radius_put_string — Attaches a string attribute
  • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
  • radius_put_vendor_attr — Attaches a vendor specific binary attribute
  • radius_put_vendor_int — Attaches a vendor specific integer attribute
  • radius_put_vendor_string — Attaches a vendor specific string attribute
  • radius_request_authenticator — Returns the request authenticator
  • radius_salt_encrypt_attr — Salt-encrypts a value
  • radius_send_request — Sends the request and waits for a reply
  • radius_server_secret — Returns the shared secret
  • radius_strerror — Devuelve un mensaje de error


Crea un manejador Radius para el conteo

  • « Funciones Radius
  • radius_add_server »
  • PHP Manual
  • Funciones Radius
  • Crea un manejador Radius para el conteo

radius_acct_open

(PECL radius >= 1.1.0)

radius_acct_open — Crea un manejador Radius para el conteo

Descripción

radius_acct_open ( ) : resource

Valores devueltos

Devuelve un manejador en caso de tener éxito, false en caso de error. Esta función falla solamente si hay insuficiencia de memoria.

Ejemplos

Ejemplo #1 radius_acct_open() example

<?php
$res = radius_acct_open ()
    or die ("No se pudo crear un manejador handle");
print("Manejador creado exitosamente");
?>


Adds a server

  • « radius_acct_open
  • radius_auth_open »
  • PHP Manual
  • Funciones Radius
  • Adds a server

radius_add_server

(PECL radius >= 1.1.0)

radius_add_server — Adds a server

Descripción

radius_add_server ( resource $radius_handle , string $hostname , int $port , string $secret , int $timeout , int $max_tries ) : bool

radius_add_server() may be called multiple times, and it may be used together with radius_config(). At most 10 servers may be specified. When multiple servers are given, they are tried in round-robin fashion until a valid response is received, or until each server's max_tries limit has been reached.

Parámetros

radius_handle

hostname

The hostname parameter specifies the server host, either as a fully qualified domain name or as a dotted-quad IP address in text form.

port

The port specifies the UDP port to contact on the server. If port is given as 0, the library looks up the radius/udp or radacct/udp service in the network services database, and uses the port found there. If no entry is found, the library uses the standard Radius ports, 1812 for authentication and 1813 for accounting.

secret

The shared secret for the server host is passed to the secret parameter. The Radius protocol ignores all but the leading 128 bytes of the shared secret.

timeout

The timeout for receiving replies from the server is passed to the timeout parameter, in units of seconds.

max_tries

The maximum number of repeated requests to make before giving up is passed into the max_tries.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 radius_add_server() example

<?php
if (!radius_add_server($res, 'radius.example.com', 1812, 'testing123', 3, 3)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br>";
    exit;
}
?>

Ver también

  • radius_config() - Causes the library to read the given configuration file


Crea un identificador de Radius para la autenticación

  • « radius_add_server
  • radius_close »
  • PHP Manual
  • Funciones Radius
  • Crea un identificador de Radius para la autenticación

radius_auth_open

(PECL radius >= 1.1.0)

radius_auth_open — Crea un identificador de Radius para la autenticación

Descripción

radius_auth_open ( ) : resource

Valores devueltos

Devuelve un manejador en caso de éxito, false en caso de error. Esta función sólo falla si hay insuficiente memoria disponible.

Ejemplos

Ejemplo #1 Ejemplo de radius_auth_open()

<?php
$radh = radius_auth_open()
    or die ("No se pudo crear el manejador");
echo "Manejador creado con éxito";
?>


Libera todos los recursos

  • « radius_auth_open
  • radius_config »
  • PHP Manual
  • Funciones Radius
  • Libera todos los recursos

radius_close

(PECL radius >= 1.1.0)

radius_close — Libera todos los recursos

Descripción

radius_close ( resource $radius_handle ) : bool

No es necesario llamar a esta función debido a que php libera todos los recursos al final de cada petición.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Causes the library to read the given configuration file

  • « radius_close
  • radius_create_request »
  • PHP Manual
  • Funciones Radius
  • Causes the library to read the given configuration file

radius_config

(PECL radius >= 1.1.0)

radius_config — Causes the library to read the given configuration file

Descripción

radius_config ( resource $radius_handle , string $file ) : bool

Before issuing any Radius requests, the library must be made aware of the servers it can contact. The easiest way to configure the library is to call radius_config(). radius_config() causes the library to read a configuration file whose format is described in » radius.conf.

Parámetros

radius_handle

file

The pathname of the configuration file is passed as the file argument to radius_config(). The library can also be configured programmatically by calls to radius_add_server().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • radius_add_server() - Adds a server


Create accounting or authentication request

  • « radius_config
  • radius_cvt_addr »
  • PHP Manual
  • Funciones Radius
  • Create accounting or authentication request

radius_create_request

(PECL radius >= 1.1.0)

radius_create_request — Create accounting or authentication request

Descripción

radius_create_request ( resource $radius_handle , int $type ) : bool

A Radius request consists of a code specifying the kind of request, and zero or more attributes which provide additional information. To begin constructing a new request, call radius_create_request().

Nota: Attention: You must call this function, before you can put any attribute!

Parámetros

radius_handle

type

Type is RADIUS_ACCESS_REQUEST or RADIUS_ACCOUNTING_REQUEST.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 radius_create_request() example

<?php
if (!radius_create_request($res, RADIUS_ACCESS_REQUEST)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ver también

  • radius_send_request() - Sends the request and waits for a reply


Converts raw data to IP-Address

  • « radius_create_request
  • radius_cvt_int »
  • PHP Manual
  • Funciones Radius
  • Converts raw data to IP-Address

radius_cvt_addr

(PECL radius >= 1.1.0)

radius_cvt_addr — Converts raw data to IP-Address

Descripción

radius_cvt_addr ( string $data ) : string

Ejemplos

Ejemplo #1 radius_cvt_addr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_IP_ADDRESS:
        $ip = radius_cvt_addr($data);
        echo "IP: $ip<br>\n";
        break;

    case RADIUS_FRAMED_IP_NETMASK:
        $mask = radius_cvt_addr($data);
        echo "MASK: $mask<br>\n";
        break;
    }
}
?>

Ver también

  • radius_cvt_int() - Converts raw data to integer
  • radius_cvt_string() - Converts raw data to string


Converts raw data to integer

  • « radius_cvt_addr
  • radius_cvt_string »
  • PHP Manual
  • Funciones Radius
  • Converts raw data to integer

radius_cvt_int

(PECL radius >= 1.1.0)

radius_cvt_int — Converts raw data to integer

Descripción

radius_cvt_int ( string $data ) : int

Ejemplos

Ejemplo #1 radius_cvt_int() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_MTU:
        $mtu = radius_cvt_int($data);
        echo "MTU: $mtu<br>\n";
        break;
    }
}
?>

Ver también

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_string() - Converts raw data to string


Converts raw data to string

  • « radius_cvt_int
  • radius_demangle_mppe_key »
  • PHP Manual
  • Funciones Radius
  • Converts raw data to string

radius_cvt_string

(PECL radius >= 1.1.0)

radius_cvt_string — Converts raw data to string

Descripción

radius_cvt_string ( string $data ) : string

Ejemplos

Ejemplo #1 radius_cvt_string() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FILTER_ID:
        $id = radius_cvt_string($data);
        echo "Filter ID: $id<br>\n";
        break;
    }
}
?>

Ver también

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_int() - Converts raw data to integer


Derives mppe-keys from mangled data

  • « radius_cvt_string
  • radius_demangle »
  • PHP Manual
  • Funciones Radius
  • Derives mppe-keys from mangled data

radius_demangle_mppe_key

(PECL radius >= 1.2.0)

radius_demangle_mppe_key — Derives mppe-keys from mangled data

Descripción

radius_demangle_mppe_key ( resource $radius_handle , string $mangled ) : string

When using MPPE with MS-CHAPv2, the send- and recv-keys are mangled (see » RFC 2548), however this function is useless, because I don't think that there is or will be a PPTP-MPPE implementation in PHP.

Valores devueltos

Returns the demangled string, or false on error.


Demangles data

  • « radius_demangle_mppe_key
  • radius_get_attr »
  • PHP Manual
  • Funciones Radius
  • Demangles data

radius_demangle

(PECL radius >= 1.2.0)

radius_demangle — Demangles data

Descripción

radius_demangle ( resource $radius_handle , string $mangled ) : string

Some data (Passwords, MS-CHAPv1 MPPE-Keys) is mangled for security reasons, and must be demangled before you can use them.

Valores devueltos

Returns the demangled string, or false on error.


Extracts an attribute

  • « radius_demangle
  • radius_get_tagged_attr_data »
  • PHP Manual
  • Funciones Radius
  • Extracts an attribute

radius_get_attr

(PECL radius >= 1.1.0)

radius_get_attr — Extracts an attribute

Descripción

radius_get_attr ( resource $radius_handle ) : mixed

Like Radius requests, each response may contain zero or more attributes. After a response has been received successfully by radius_send_request(), its attributes can be extracted one by one using radius_get_attr(). Each time radius_get_attr() is called, it gets the next attribute from the current response.

Valores devueltos

Returns an associative array containing the attribute-type and the data, or error number <= 0.

Ejemplos

Ejemplo #1 radius_get_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
}
?>

Ver también

  • radius_put_attr() - Attaches a binary attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute
  • radius_send_request() - Sends the request and waits for a reply


Extracts the data from a tagged attribute

  • « radius_get_attr
  • radius_get_tagged_attr_tag »
  • PHP Manual
  • Funciones Radius
  • Extracts the data from a tagged attribute

radius_get_tagged_attr_data

(PECL radius >= 1.3.0)

radius_get_tagged_attr_data — Extracts the data from a tagged attribute

Descripción

radius_get_tagged_attr_data ( string $data ) : string|false

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the data from the attribute.

Parámetros

data

The tagged attribute to be decoded.

Valores devueltos

Returns the data from the tagged attribute o false en caso de error.

Ejemplos

Ejemplo #1 radius_get_tagged_attr_data() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

Ver también

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_tag() - Extracts the tag from a tagged attribute


Extracts the tag from a tagged attribute

  • « radius_get_tagged_attr_data
  • radius_get_vendor_attr »
  • PHP Manual
  • Funciones Radius
  • Extracts the tag from a tagged attribute

radius_get_tagged_attr_tag

(PECL radius >= 1.3.0)

radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute

Descripción

radius_get_tagged_attr_tag ( string $data ) : int|false

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the tag from the attribute.

Parámetros

data

The tagged attribute to be decoded.

Valores devueltos

Returns the tag from the tagged attribute o false en caso de error.

Ejemplos

Ejemplo #1 radius_get_tagged_attr_tag() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

Ver también

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_data() - Extracts the data from a tagged attribute


Extracts a vendor specific attribute

  • « radius_get_tagged_attr_tag
  • radius_put_addr »
  • PHP Manual
  • Funciones Radius
  • Extracts a vendor specific attribute

radius_get_vendor_attr

(PECL radius >= 1.1.0)

radius_get_vendor_attr — Extracts a vendor specific attribute

Descripción

radius_get_vendor_attr ( string $data ) : array

If radius_get_attr() returns RADIUS_VENDOR_SPECIFIC, radius_get_vendor_attr() may be called to determine the vendor.

Valores devueltos

Returns an associative array containing the attribute-type, vendor and the data, or false on error.

Ejemplos

Ejemplo #1 radius_get_vendor_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
    if ($attr == RADIUS_VENDOR_SPECIFIC) {

        $resv = radius_get_vendor_attr($data);
        if (is_array($resv)) {
            $vendor = $resv['vendor'];
            $attrv = $resv['attr'];
            $datav = $resv['data'];
            printf("Got Vendor Attr:%d %d Bytes %s\n", $attrv, strlen($datav), bin2hex($datav));
        }

    }
}
?>

Ver también

  • radius_get_attr() - Extracts an attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute


Attaches an IP address attribute

  • « radius_get_vendor_attr
  • radius_put_attr »
  • PHP Manual
  • Funciones Radius
  • Attaches an IP address attribute

radius_put_addr

(PECL radius >= 1.1.0)

radius_put_addr — Attaches an IP address attribute

Descripción

radius_put_addr ( resource $radius_handle , int $type , string $addr , int $options = 0 , int $tag = ? ) : bool

Attaches an IP address attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

type

El tipo de atributo.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.


Attaches a binary attribute

  • « radius_put_addr
  • radius_put_int »
  • PHP Manual
  • Funciones Radius
  • Attaches a binary attribute

radius_put_attr

(PECL radius >= 1.1.0)

radius_put_attr — Attaches a binary attribute

Descripción

radius_put_attr ( resource $radius_handle , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a binary attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

type

El tipo de atributo.

value

The attribute value, which will be treated as a raw binary string.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 radius_put_attr() example

<?php
mt_srand(time());
$chall = mt_rand();
$chapval = md5(pack('Ca*',1 , 'sepp' . $chall));
$pass = pack('CH*', 1, $chapval);
if (!radius_put_attr($res, RADIUS_CHAP_PASSWORD, $pass)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ver también

  • radius_get_attr() - Extracts an attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute


Attaches an integer attribute

  • « radius_put_attr
  • radius_put_string »
  • PHP Manual
  • Funciones Radius
  • Attaches an integer attribute

radius_put_int

(PECL radius >= 1.1.0)

radius_put_int — Attaches an integer attribute

Descripción

radius_put_int ( resource $radius_handle , int $type , int $value , int $options = 0 , int $tag = ? ) : bool

Attaches an integer attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

type

El tipo de atributo.

value

The attribute value.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ejemplos

Ejemplo #1 radius_put_int() example

<?php
if (!radius_put_int($res, RAD_FRAMED_PROTOCOL, RAD_PPP)) {
   echo 'RadiusError:' . radius_strerror($res). "\n<br />";
   exit;
}
?>

Ver también

  • radius_put_string() - Attaches a string attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a string attribute

  • « radius_put_int
  • radius_put_vendor_addr »
  • PHP Manual
  • Funciones Radius
  • Attaches a string attribute

radius_put_string

(PECL radius >= 1.1.0)

radius_put_string — Attaches a string attribute

Descripción

radius_put_string ( resource $radius_handle , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a string attribute to the current RADIUS request. In general, radius_put_attr() is a more useful function for attaching string attributes, as it is binary safe.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

type

El tipo de atributo.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ejemplos

Ejemplo #1 radius_put_string() example

<?php
if (!radius_put_string($res, RADIUS_USER_NAME, 'billy')) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ver también

  • radius_put_int() - Attaches an integer attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a vendor specific IP address attribute

  • « radius_put_string
  • radius_put_vendor_attr »
  • PHP Manual
  • Funciones Radius
  • Attaches a vendor specific IP address attribute

radius_put_vendor_addr

(PECL radius >= 1.1.0)

radius_put_vendor_addr — Attaches a vendor specific IP address attribute

Descripción

radius_put_vendor_addr ( resource $radius_handle , int $vendor , int $type , string $addr ) : bool

Attaches an IP address vendor specific attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

vendor

El ID del vendedor.

type

El tipo de atributo.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.


Attaches a vendor specific binary attribute

  • « radius_put_vendor_addr
  • radius_put_vendor_int »
  • PHP Manual
  • Funciones Radius
  • Attaches a vendor specific binary attribute

radius_put_vendor_attr

(PECL radius >= 1.1.0)

radius_put_vendor_attr — Attaches a vendor specific binary attribute

Descripción

radius_put_vendor_attr ( resource $radius_handle , int $vendor , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific binary attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

vendor

El ID del vendedor.

type

El tipo de atributo.

value

The attribute value, which will be treated as a raw binary string.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ejemplos

Ejemplo #1 radius_put_vendor_attr() example

<?php
if (!radius_put_vendor_attr($res, RADIUS_VENDOR_MICROSOFT, RAD_MICROSOFT_MS_CHAP_CHALLENGE, $challenge)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ver también

  • radius_get_vendor_attr() - Extracts a vendor specific attribute


Attaches a vendor specific integer attribute

  • « radius_put_vendor_attr
  • radius_put_vendor_string »
  • PHP Manual
  • Funciones Radius
  • Attaches a vendor specific integer attribute

radius_put_vendor_int

(PECL radius >= 1.1.0)

radius_put_vendor_int — Attaches a vendor specific integer attribute

Descripción

radius_put_vendor_int ( resource $radius_handle , int $vendor , int $type , int $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific integer attribute to the current RADIUS request.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

vendor

El ID del vendedor.

type

El tipo de atributo.

value

The attribute value.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ver también

  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a vendor specific string attribute

  • « radius_put_vendor_int
  • radius_request_authenticator »
  • PHP Manual
  • Funciones Radius
  • Attaches a vendor specific string attribute

radius_put_vendor_string

(PECL radius >= 1.1.0)

radius_put_vendor_string — Attaches a vendor specific string attribute

Descripción

radius_put_vendor_string ( resource $radius_handle , int $vendor , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific string attribute to the current RADIUS request. In general, radius_put_vendor_attr() is a more useful function for attaching string attributes, as it is binary safe.

Nota:

Se debe crear una solicitud mediante radius_create_request() antes de llamar a esta función.

Parámetros

radius_handle

El recurso RADIUS.

vendor

El ID del vendedor.

type

El tipo de atributo.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

Una máscara de bits de las opciones de atributo. Las opciones disponibles incluyen RADIUS_OPTION_TAGGED y RADIUS_OPTION_SALT.

tag

LA etiqueta de atributo. Este parámetro es ignorado a menos que la opción RADIUS_OPTION_TAGGED esté establecida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
PECL radius 1.3.0 | The options and tag parameters were added.

Ver también

  • radius_put_vendor_int() - Attaches a vendor specific integer attribute


Returns the request authenticator

  • « radius_put_vendor_string
  • radius_salt_encrypt_attr »
  • PHP Manual
  • Funciones Radius
  • Returns the request authenticator

radius_request_authenticator

(PECL radius >= 1.1.0)

radius_request_authenticator — Returns the request authenticator

Descripción

radius_request_authenticator ( resource $radius_handle ) : string

The request authenticator is needed for demangling mangled data like passwords and encryption-keys.

Valores devueltos

Returns the request authenticator as string, or false on error.

Ver también

  • radius_demangle() - Demangles data


Salt-encrypts a value

  • « radius_request_authenticator
  • radius_send_request »
  • PHP Manual
  • Funciones Radius
  • Salt-encrypts a value

radius_salt_encrypt_attr

(PECL radius >= 1.3.0)

radius_salt_encrypt_attr — Salt-encrypts a value

Descripción

radius_salt_encrypt_attr ( resource $radius_handle , string $data ) : string|false

Applies the RADIUS salt-encryption algorithm to the given value.

In general, this is achieved automatically by providing the RADIUS_OPTION_SALT option to an attribute setter function, but this function can be used if low-level request construction is required.

Parámetros

data

The data to be salt-encrypted.

Valores devueltos

Returns the salt-encrypted data o false en caso de error.

Ver también

  • radius_put_addr() - Attaches an IP address attribute
  • radius_put_attr() - Attaches a binary attribute
  • radius_put_int() - Attaches an integer attribute
  • radius_put_string() - Attaches a string attribute


Sends the request and waits for a reply

  • « radius_salt_encrypt_attr
  • radius_server_secret »
  • PHP Manual
  • Funciones Radius
  • Sends the request and waits for a reply

radius_send_request

(PECL radius >= 1.1.0)

radius_send_request — Sends the request and waits for a reply

Descripción

radius_send_request ( resource $radius_handle ) : int

After the Radius request has been constructed, it is sent by radius_send_request().

The radius_send_request() function sends the request and waits for a valid reply, retrying the defined servers in round-robin fashion as necessary.

Valores devueltos

If a valid response is received, radius_send_request() returns the Radius code which specifies the type of the response. This will typically be RADIUS_ACCESS_ACCEPT, RADIUS_ACCESS_REJECT, or RADIUS_ACCESS_CHALLENGE. If no valid response is received, radius_send_request() returns false.

Ver también

  • radius_create_request() - Create accounting or authentication request


Returns the shared secret

  • « radius_send_request
  • radius_strerror »
  • PHP Manual
  • Funciones Radius
  • Returns the shared secret

radius_server_secret

(PECL radius >= 1.1.0)

radius_server_secret — Returns the shared secret

Descripción

radius_server_secret ( resource $radius_handle ) : string

The shared secret is needed as salt for demangling mangled data like passwords and encryption-keys.

Valores devueltos

Returns the server's shared secret as string, or false on error.


Devuelve un mensaje de error

  • « radius_server_secret
  • Extensiones específicas de la línea de comandos »
  • PHP Manual
  • Funciones Radius
  • Devuelve un mensaje de error

radius_strerror

(PECL radius >= 1.1.0)

radius_strerror — Devuelve un mensaje de error

Descripción

radius_strerror ( resource $radius_handle ) : string

Si las funciones radio fallan entonces guardan un mensaje de error. Este mensaje de error puede ser obtenido con esta función.

Valores devueltos

Devuelve mensajes de error como string de funciones radio fallidas.


Extensiones específicas de la línea de comandos

  • Ncurses — Control de Terminal de Pantalla Ncurses
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Ncurses
  • Readline — GNU Readline
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones Readline


Control de Terminal de Pantalla Ncurses

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • Códigos de error
    • Colores
    • Claves
    • Ratón
  • Funciones de Ncurses
    • ncurses_addch — Agregar un caracter en la posición actual y avanzar el cursor
    • ncurses_addchnstr — Agregar cadena con atributos y longitud especificada en la posición actual
    • ncurses_addchstr — Agregar una cadena con atributos en la posición actual
    • ncurses_addnstr — Agregar una cadena con la longitud especificada en la posición actual
    • ncurses_addstr — Imprimir texto en la posición actual
    • ncurses_assume_default_colors — Definir colores predeterminados para el color 0
    • ncurses_attroff — Deshabilitar los atributos dados
    • ncurses_attron — Habilitar los atributos dados
    • ncurses_attrset — Establecer los atributos dados
    • ncurses_baudrate — Devuelve la tasa de baudios de la terminal
    • ncurses_beep — Producir un beep en la terminal
    • ncurses_bkgd — Establecer la propiedad de segundo plano para la pantalla de la terminal
    • ncurses_bkgdset — Controla el segundo plano de la pantalla
    • ncurses_border — Dibujar un borde alrededor de la pantalla usando caracteres con atributos
    • ncurses_bottom_panel — Mueve un panel visible al fondo de la pila
    • ncurses_can_change_color — Comprobar si las definiciones de color del terminal se pueden cambiar
    • ncurses_cbreak — Desactivar el búfer de entrada
    • ncurses_clear — Limpiar la pantalla
    • ncurses_clrtobot — Limpiar la pantalla desde la posición actual al final
    • ncurses_clrtoeol — Limpiar la pantalla desde la posición actual al final de la línea
    • ncurses_color_content — Obtiene los componentes RGB de un color
    • ncurses_color_set — Establecer los colores de primer plano y fondo activos
    • ncurses_curs_set — Establecer el estado del cursor
    • ncurses_def_prog_mode — Guarda los modos de terminal (programa)
    • ncurses_def_shell_mode — Guarda los modos de terminal (intérprete de comandos)
    • ncurses_define_key — Definir un código de tecla
    • ncurses_del_panel — Remover un panel de la pila y eliminarlo (pero no la ventana asociada)
    • ncurses_delay_output — Retrasar la salida en la terminal usando caracteres de relleno
    • ncurses_delch — Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda
    • ncurses_deleteln — Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba
    • ncurses_delwin — Eliminar una ventana ncurses
    • ncurses_doupdate — Escribir todas las actualizaciones preparadas sobre la terminal
    • ncurses_echo — Activar la repetición de entrada del teclado
    • ncurses_echochar — Salida de un caracter sencillo, incluyendo actualización
    • ncurses_end — Dejar de usar ncurses, limpiar la pantalla
    • ncurses_erase — Limpiar pantalla de terminal
    • ncurses_erasechar — Devuelve el caracter de borrado actual
    • ncurses_filter — Definir LINES para iniscr() y newterm() a 1
    • ncurses_flash — Relampaguear la pantalla de terminal (campana visual)
    • ncurses_flushinp — Volcar el búfer de entrada de teclado
    • ncurses_getch — Leer un caracter desde el teclado
    • ncurses_getmaxyx — Devuelve el tamaño de una ventana
    • ncurses_getmouse — Lee los eventos del ratón
    • ncurses_getyx — Devuelve la posición de cursor actual para una ventana
    • ncurses_halfdelay — Colocar la terminal en modo de medio retraso
    • ncurses_has_colors — Comprueba si el terminal tiene capacidades de color
    • ncurses_has_ic — Chequear por el soporte de inserción y borrado
    • ncurses_has_il — Chequea el soporte de inserción y borrado
    • ncurses_has_key — Chequear por la presencia de una tecla de función en el teclado de la terminal
    • ncurses_hide_panel — Remover un panel de la pila, haciéndolo invisible
    • ncurses_hline — Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo
    • ncurses_inch — Obtener el caracter y los atributos de la posición actual
    • ncurses_init_color — Definir un color de termimal
    • ncurses_init_pair — Definir una pareja de colores
    • ncurses_init — Inicializar ncurses
    • ncurses_insch — Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual
    • ncurses_insdelln — Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)
    • ncurses_insertln — Insertar una línea, mover el resto de la pantalla hacia abajo
    • ncurses_insstr — Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha
    • ncurses_instr — Lee una cadena desde la pantalla de terminal
    • ncurses_isendwin — Ncurses está en modo endwin, se puede realizar una salida normal por pantalla
    • ncurses_keyok — Habilitar o deshabilitar un código de tecla
    • ncurses_keypad — Activa o desactiva el teclado numérico
    • ncurses_killchar — Devuelve el caracter de eliminación de línea actual
    • ncurses_longname — Devuelve la descripción de la terminal
    • ncurses_meta — Habilita/deshabilita la meta-información de 8-bits de tecla
    • ncurses_mouse_trafo — Transforma coordenadas
    • ncurses_mouseinterval — Establecer el tiempo de espera para clics de botón del mouse
    • ncurses_mousemask — Establece las opciones del ratón
    • ncurses_move_panel — Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]
    • ncurses_move — Mover la posición de salida
    • ncurses_mvaddch — Mover la posición actual y agregar un caracter
    • ncurses_mvaddchnstr — Mover la posición y agregar una cadena con atributos con la longitud especificada
    • ncurses_mvaddchstr — Mover la posición y agregar una cadena con atributos
    • ncurses_mvaddnstr — Mover la posición y agregar una cadena con la longitud especificada
    • ncurses_mvaddstr — Mover la posición y agregar una cadena
    • ncurses_mvcur — Mover el cursor inmediatamente
    • ncurses_mvdelch — Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda
    • ncurses_mvgetch — Mover la posición y obtener el caracter en la nueva posición
    • ncurses_mvhline — Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_mvinch — Mover la posición y obtener el caracter con atributos en la nueva posición
    • ncurses_mvvline — Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_mvwaddstr — Añadir una cadena en una posicón nueva de la ventana
    • ncurses_napms — Dormir
    • ncurses_new_panel — Crear un nuevo panel y asociarlo con una ventana
    • ncurses_newpad — Crea un nuevo pad (ventana)
    • ncurses_newwin — Crear una nueva ventana
    • ncurses_nl — Traducir línea nueva y retorno de carro / alimentación de línea
    • ncurses_nocbreak — Cambiar la terminal a modo normal (cooked)
    • ncurses_noecho — Desactivar la repetición de entrada del teclado
    • ncurses_nonl — No traducir línea nueva y retorno de carro / alimentación de línea
    • ncurses_noqiflush — No realizar volcados en caracteres de señales
    • ncurses_noraw — Salir del modo puro en la terminal
    • ncurses_pair_content — Obtiene los colores de primer plano y fondo de una pareja de colores
    • ncurses_panel_above — Devuelve el panel encima del panel indicado
    • ncurses_panel_below — Devuelve el panel por debajo del panel indicado
    • ncurses_panel_window — Devuelve la ventana asociada con el panel
    • ncurses_pnoutrefresh — Copia una región desde un pad a la pantalla virtual
    • ncurses_prefresh — Copia una región desde un pad a la pantalla virtual
    • ncurses_putp — Aplicar la información de márgenes a la cadena e imprimirla
    • ncurses_qiflush — Producir volcado en caracteres de señales
    • ncurses_raw — Colocar la terminal en modo puro
    • ncurses_refresh — Refrescar la pantalla
    • ncurses_replace_panel — Reemplaza la ventana asociada con el panel
    • ncurses_reset_prog_mode — Restablece el modo de programa guardado por def_prog_mode
    • ncurses_reset_shell_mode — Restablece el modo de intérprete de comandos guardado por def_shell_mode
    • ncurses_resetty — Restablece el estado guardado de la terminal
    • ncurses_savetty — Guarda el estado de la terminal
    • ncurses_scr_dump — Vuelca el contenido de la pantalla en un archivo
    • ncurses_scr_init — Inicializar la pantalla desde un volcado en un archivo
    • ncurses_scr_restore — Recuperar la pantalla desde un volcado en un archivo
    • ncurses_scr_set — Heredar la pantalla de un volcado en un archivo
    • ncurses_scrl — Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual
    • ncurses_show_panel — Coloca un panel invisible al comienzo de la pila, haciéndola visible
    • ncurses_slk_attr — Devuelve el atributo de la etiqueta suave de teclado
    • ncurses_slk_attroff — Deshabilitar los atributos dados para las etiquetas suaves de teclado
    • ncurses_slk_attron — Habilitar los atributos dados para las etiquetas suaves de funciones de teclado
    • ncurses_slk_attrset — Definir los atributos dados para las etiquetas suaves de funciones de teclado
    • ncurses_slk_clear — Limpia las etiquetas suaves de la pantalla
    • ncurses_slk_color — Establece el color para las etiquetas suaves de teclado
    • ncurses_slk_init — Inicializa las funciones de tecla de etiquetación suave
    • ncurses_slk_noutrefresh — Copia las etiquetas suaves de teclado a la pantalla virtual
    • ncurses_slk_refresh — Copia las etiquetas suaves de teclado a la pantalla
    • ncurses_slk_restore — Recupera las etiquetas suaves de teclado
    • ncurses_slk_set — Establece las etiquetas de teclado
    • ncurses_slk_touch — Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh
    • ncurses_standend — Dejar de usar el atributo 'standout'
    • ncurses_standout — Comenzar a usar el atributo 'standout'
    • ncurses_start_color — Inicializa la funcionalidad de color
    • ncurses_termattrs — Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal
    • ncurses_termname — Devuelve el nombre (corto) de la terminal
    • ncurses_timeout — Establecer el tiempo de espera para secuencias especiales de teclas
    • ncurses_top_panel — Mueve un panel visible al tope de la pila
    • ncurses_typeahead — Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente
    • ncurses_ungetch — Colocar un caracter de vuelta en la secuencia de entrada
    • ncurses_ungetmouse — Coloca un evento de mouse en la cola
    • ncurses_update_panels — Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila
    • ncurses_use_default_colors — Asignar los colores predeterminados de la terminal al id de color -1
    • ncurses_use_env — Controlar el uso de información del entorno sobre el tamaño de la terminal
    • ncurses_use_extended_names — Controlar el uso de nombres extendidos en descripciones de información de terminal
    • ncurses_vidattr — Desplegar la cadena en la terminal con el atributo de modo de video
    • ncurses_vline — Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_waddch — Agrega un caracter en la posición actual de una ventana y avanza el cursor
    • ncurses_waddstr — Imprime un texto en la posición actual de una ventana
    • ncurses_wattroff — Deshabilita los atributos para una ventana
    • ncurses_wattron — Habilita los atributos para una ventana
    • ncurses_wattrset — Establecer los atributos para una ventana
    • ncurses_wborder — Dibuja un borde alrededor de la ventana usando caracteres con atributos
    • ncurses_wclear — Limpia la ventana
    • ncurses_wcolor_set — Establece parejas de colores en la ventana
    • ncurses_werase — Eliminar los contenidos de la ventana
    • ncurses_wgetch — Lee un caracter desde el teclado (en la ventana)
    • ncurses_whline — Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres
    • ncurses_wmouse_trafo — Transforma coordenadas de ventana/stdscr
    • ncurses_wmove — Mueve la posición de salida de la ventana
    • ncurses_wnoutrefresh — Copia la ventana a la pantalla virtual
    • ncurses_wrefresh — Refrescar la ventana en la pantalla de terminal
    • ncurses_wstandend — Finaliza el modo standout para una ventana
    • ncurses_wstandout — Ingresar a modo standout en una ventana
    • ncurses_wvline — Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres


Introducción

ncurses (new curses) es una emulacion de software gratuito de curses en System V Rel 4.0 (y superior). Usa el formato terminfo, soporta rellenos, colores, resaltados múltiples, forma de caracteres y función de mapeo de teclas. Debido a la naturaleza interactiva de esta biblioteca, será de uso pequeño para escribir aplicaciones Web, pero puede ser útil al escribir scripts que tienen la intención de usar PHP desde la línea de comandos.

Las características disponibles, como los colores, dependen del terminal que se esté usando. Use funciones tales como ncurses_has_colors(), ncurses_can_change_color(), y ncurses_has_ic() para comprobar las capacidades individuales.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.3.0.

ncurses está disponible para las siguientes plataformas:

  • AIX
  • BeOS
  • BSD (variantes) (FreeBSD, NetBSD, OpenBSD)
  • Cygwin
  • Digital Unix (aka OSF1)
  • GNU/Linux
  • HPUX
  • IRIX64
  • Mac OS X
  • OS/2
  • QNX
  • SCO OpenServer
  • Solaris
  • Tru64


Requerimientos

Necesita las bibliotecas y ficheros de cabecera de ncurses. Descargue la última versión desde » ftp://ftp.gnu.org/pub/gnu/ncurses/ o desde otro servidor copia GNU.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ncurses.

El soporte para caracteres anchos CRT en pantalla (ncursesw) se añadió en la versión 1.0.1 de esta versión de PECL.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión recursos de ventana, panel y relleno.


Constantes predefinidas

Tabla de contenidos

  • Códigos de error
  • Colores
  • Claves
  • Ratón

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.


Códigos de error

En caso de error, las funciones de ncurses devuelven -1. Algunas funciones devuelven 0 en caso de éxito. Véase las páginas pertinenetes en la documentación para los valores de retorno reales.


Colores

Constantes de color de ncurses
constante | sifnificado
NCURSES_COLOR_BLACK | sin color (negro)
NCURSES_COLOR_WHITE | blanco
NCURSES_COLOR_RED | rojo - soportado cuando el terminal está en modo color
NCURSES_COLOR_GREEN | verde - soportado cuando el terminal está en modo color
NCURSES_COLOR_YELLOW | amarillo - soportado cuando el terminal está en modo color
NCURSES_COLOR_BLUE | azul - soportado cuando el terminal está en modo color
NCURSES_COLOR_CYAN | cian - soportado cuando el terminal está en modo color
NCURSES_COLOR_MAGENTA | magenta - soportado cuando el terminal está en modo color


Claves

Constantes de clave de ncurses
constante | significado
NCURSES_KEY_F0 - NCURSES_KEY_F64 | teclas de función F1 - F64
NCURSES_KEY_DOWN | flecha abajo
NCURSES_KEY_UP | flecha arriba
NCURSES_KEY_LEFT | flecha izquierda
NCURSES_KEY_RIGHT | flecha derecha
NCURSES_KEY_HOME | tecla inicio (arriba+flecha izquierda)
NCURSES_KEY_BACKSPACE | retroceso
NCURSES_KEY_DL | borra línea
NCURSES_KEY_IL | insertar línea
NCURSES_KEY_DC | borra carácter
NCURSES_KEY_IC | insertar carcter o entrar en modo insertar
NCURSES_KEY_EIC | salir del modo insertar carcácter
NCURSES_KEY_CLEAR | limpiar pantalla
NCURSES_KEY_EOS | limpiar hasta el final de la pantalla
NCURSES_KEY_EOL | limpiar hasta el final de línea
NCURSES_KEY_SF | avanzar una línea
NCURSES_KEY_SR | retroceder una línea
NCURSES_KEY_NPAGE | página siguiente
NCURSES_KEY_PPAGE | página anterior
NCURSES_KEY_STAB | establecer tabulación
NCURSES_KEY_CTAB | limpiar tabulación
NCURSES_KEY_CATAB | limpiar todas las tabulaciones
NCURSES_KEY_SRESET | reset suave (parcial)
NCURSES_KEY_RESET | reset o reset duro
NCURSES_KEY_PRINT | imprimir
NCURSES_KEY_LL | inferior izquierda
NCURSES_KEY_A1 | superior izquierda del teclado numérico
NCURSES_KEY_A3 | superio derecha del teclado numérico
NCURSES_KEY_B2 | centro del teclado numérico
NCURSES_KEY_C1 | inferior izquierda del teclado numérico
NCURSES_KEY_C3 | nferior derecha del teclado numérico
NCURSES_KEY_BTAB | retroceso tabulación
NCURSES_KEY_BEG | principio
NCURSES_KEY_CANCEL | cancelar
NCURSES_KEY_CLOSE | cerrar
NCURSES_KEY_COMMAND | cmd (comando)
NCURSES_KEY_COPY | copiar
NCURSES_KEY_CREATE | crear
NCURSES_KEY_END | fin
NCURSES_KEY_EXIT | salir
NCURSES_KEY_FIND | buscar
NCURSES_KEY_HELP | ayuda
NCURSES_KEY_MARK | marcar
NCURSES_KEY_MESSAGE | mensaje
NCURSES_KEY_MOVE | mover
NCURSES_KEY_NEXT | siguiente
NCURSES_KEY_OPEN | abrir
NCURSES_KEY_OPTIONS | opciones
NCURSES_KEY_PREVIOUS | anterior
NCURSES_KEY_REDO | re-hacer
NCURSES_KEY_REFERENCE | ref (referencia)
NCURSES_KEY_REFRESH | refrescar
NCURSES_KEY_REPLACE | reemplazar
NCURSES_KEY_RESTART | reiniciar
NCURSES_KEY_RESUME | continuar
NCURSES_KEY_SAVE | guardar
NCURSES_KEY_SBEG | principio corrido
NCURSES_KEY_SCANCEL | cancelar corrido
NCURSES_KEY_SCOMMAND | comando corrido
NCURSES_KEY_SCOPY | copiar corrido
NCURSES_KEY_SCREATE | crear corrido
NCURSES_KEY_SDC | borrar caracter corrido
NCURSES_KEY_SDL | borrar línea corrido
NCURSES_KEY_SELECT | seleccionar
NCURSES_KEY_SEND | fin corrido
NCURSES_KEY_SEOL | fin de línea corrido
NCURSES_KEY_SEXIT | salir corrido
NCURSES_KEY_SFIND | buscar corrido
NCURSES_KEY_SHELP | ayuda corrido
NCURSES_KEY_SHOME | inicio corrido
NCURSES_KEY_SIC | entrada corrido
NCURSES_KEY_SLEFT | flecha izquierda corrido
NCURSES_KEY_SMESSAGE | mensaje corrido
NCURSES_KEY_SMOVE | mover corrido
NCURSES_KEY_SNEXT | siguiente corrido
NCURSES_KEY_SOPTIONS | opciones corrido
NCURSES_KEY_SPREVIOUS | anterior corrido
NCURSES_KEY_SPRINT | imprimir corrido
NCURSES_KEY_SREDO | re-hacer corrido
NCURSES_KEY_SREPLACE | reemplazar corrido
NCURSES_KEY_SRIGHT | flecha derecha corrido
NCURSES_KEY_SRSUME | continuar corrido
NCURSES_KEY_SSAVE | guardar corrido
NCURSES_KEY_SSUSPEND | suspender corrido
NCURSES_KEY_UNDO | deshacer
NCURSES_KEY_MOUSE | ha ocurrido un evento del ratón
NCURSES_KEY_MAX | valor máximo de tecla


Ratón

Constantes de ratón
constante | significado
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | botón (1-4) soltado
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | botón (1-4) presionado
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | botón (1-4) clicado
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | botón (1-4) doble clicado
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | botón (1-4) triple clicado
NCURSES_BUTTON_CTRL | ctrl pulsada durante clic
NCURSES_BUTTON_SHIFT | shift pulsada durante clic
NCURSES_BUTTON_ALT | alt pulsada durante clic
NCURSES_ALL_MOUSE_EVENTS | niformar de todos los eventos de ratón
NCURSES_REPORT_MOUSE_POSITION | informar de la posición del ratón


Funciones de Ncurses

Tabla de contenidos

  • ncurses_addch — Agregar un caracter en la posición actual y avanzar el cursor
  • ncurses_addchnstr — Agregar cadena con atributos y longitud especificada en la posición actual
  • ncurses_addchstr — Agregar una cadena con atributos en la posición actual
  • ncurses_addnstr — Agregar una cadena con la longitud especificada en la posición actual
  • ncurses_addstr — Imprimir texto en la posición actual
  • ncurses_assume_default_colors — Definir colores predeterminados para el color 0
  • ncurses_attroff — Deshabilitar los atributos dados
  • ncurses_attron — Habilitar los atributos dados
  • ncurses_attrset — Establecer los atributos dados
  • ncurses_baudrate — Devuelve la tasa de baudios de la terminal
  • ncurses_beep — Producir un beep en la terminal
  • ncurses_bkgd — Establecer la propiedad de segundo plano para la pantalla de la terminal
  • ncurses_bkgdset — Controla el segundo plano de la pantalla
  • ncurses_border — Dibujar un borde alrededor de la pantalla usando caracteres con atributos
  • ncurses_bottom_panel — Mueve un panel visible al fondo de la pila
  • ncurses_can_change_color — Comprobar si las definiciones de color del terminal se pueden cambiar
  • ncurses_cbreak — Desactivar el búfer de entrada
  • ncurses_clear — Limpiar la pantalla
  • ncurses_clrtobot — Limpiar la pantalla desde la posición actual al final
  • ncurses_clrtoeol — Limpiar la pantalla desde la posición actual al final de la línea
  • ncurses_color_content — Obtiene los componentes RGB de un color
  • ncurses_color_set — Establecer los colores de primer plano y fondo activos
  • ncurses_curs_set — Establecer el estado del cursor
  • ncurses_def_prog_mode — Guarda los modos de terminal (programa)
  • ncurses_def_shell_mode — Guarda los modos de terminal (intérprete de comandos)
  • ncurses_define_key — Definir un código de tecla
  • ncurses_del_panel — Remover un panel de la pila y eliminarlo (pero no la ventana asociada)
  • ncurses_delay_output — Retrasar la salida en la terminal usando caracteres de relleno
  • ncurses_delch — Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda
  • ncurses_deleteln — Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba
  • ncurses_delwin — Eliminar una ventana ncurses
  • ncurses_doupdate — Escribir todas las actualizaciones preparadas sobre la terminal
  • ncurses_echo — Activar la repetición de entrada del teclado
  • ncurses_echochar — Salida de un caracter sencillo, incluyendo actualización
  • ncurses_end — Dejar de usar ncurses, limpiar la pantalla
  • ncurses_erase — Limpiar pantalla de terminal
  • ncurses_erasechar — Devuelve el caracter de borrado actual
  • ncurses_filter — Definir LINES para iniscr() y newterm() a 1
  • ncurses_flash — Relampaguear la pantalla de terminal (campana visual)
  • ncurses_flushinp — Volcar el búfer de entrada de teclado
  • ncurses_getch — Leer un caracter desde el teclado
  • ncurses_getmaxyx — Devuelve el tamaño de una ventana
  • ncurses_getmouse — Lee los eventos del ratón
  • ncurses_getyx — Devuelve la posición de cursor actual para una ventana
  • ncurses_halfdelay — Colocar la terminal en modo de medio retraso
  • ncurses_has_colors — Comprueba si el terminal tiene capacidades de color
  • ncurses_has_ic — Chequear por el soporte de inserción y borrado
  • ncurses_has_il — Chequea el soporte de inserción y borrado
  • ncurses_has_key — Chequear por la presencia de una tecla de función en el teclado de la terminal
  • ncurses_hide_panel — Remover un panel de la pila, haciéndolo invisible
  • ncurses_hline — Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo
  • ncurses_inch — Obtener el caracter y los atributos de la posición actual
  • ncurses_init_color — Definir un color de termimal
  • ncurses_init_pair — Definir una pareja de colores
  • ncurses_init — Inicializar ncurses
  • ncurses_insch — Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual
  • ncurses_insdelln — Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)
  • ncurses_insertln — Insertar una línea, mover el resto de la pantalla hacia abajo
  • ncurses_insstr — Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha
  • ncurses_instr — Lee una cadena desde la pantalla de terminal
  • ncurses_isendwin — Ncurses está en modo endwin, se puede realizar una salida normal por pantalla
  • ncurses_keyok — Habilitar o deshabilitar un código de tecla
  • ncurses_keypad — Activa o desactiva el teclado numérico
  • ncurses_killchar — Devuelve el caracter de eliminación de línea actual
  • ncurses_longname — Devuelve la descripción de la terminal
  • ncurses_meta — Habilita/deshabilita la meta-información de 8-bits de tecla
  • ncurses_mouse_trafo — Transforma coordenadas
  • ncurses_mouseinterval — Establecer el tiempo de espera para clics de botón del mouse
  • ncurses_mousemask — Establece las opciones del ratón
  • ncurses_move_panel — Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]
  • ncurses_move — Mover la posición de salida
  • ncurses_mvaddch — Mover la posición actual y agregar un caracter
  • ncurses_mvaddchnstr — Mover la posición y agregar una cadena con atributos con la longitud especificada
  • ncurses_mvaddchstr — Mover la posición y agregar una cadena con atributos
  • ncurses_mvaddnstr — Mover la posición y agregar una cadena con la longitud especificada
  • ncurses_mvaddstr — Mover la posición y agregar una cadena
  • ncurses_mvcur — Mover el cursor inmediatamente
  • ncurses_mvdelch — Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda
  • ncurses_mvgetch — Mover la posición y obtener el caracter en la nueva posición
  • ncurses_mvhline — Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres
  • ncurses_mvinch — Mover la posición y obtener el caracter con atributos en la nueva posición
  • ncurses_mvvline — Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres
  • ncurses_mvwaddstr — Añadir una cadena en una posicón nueva de la ventana
  • ncurses_napms — Dormir
  • ncurses_new_panel — Crear un nuevo panel y asociarlo con una ventana
  • ncurses_newpad — Crea un nuevo pad (ventana)
  • ncurses_newwin — Crear una nueva ventana
  • ncurses_nl — Traducir línea nueva y retorno de carro / alimentación de línea
  • ncurses_nocbreak — Cambiar la terminal a modo normal (cooked)
  • ncurses_noecho — Desactivar la repetición de entrada del teclado
  • ncurses_nonl — No traducir línea nueva y retorno de carro / alimentación de línea
  • ncurses_noqiflush — No realizar volcados en caracteres de señales
  • ncurses_noraw — Salir del modo puro en la terminal
  • ncurses_pair_content — Obtiene los colores de primer plano y fondo de una pareja de colores
  • ncurses_panel_above — Devuelve el panel encima del panel indicado
  • ncurses_panel_below — Devuelve el panel por debajo del panel indicado
  • ncurses_panel_window — Devuelve la ventana asociada con el panel
  • ncurses_pnoutrefresh — Copia una región desde un pad a la pantalla virtual
  • ncurses_prefresh — Copia una región desde un pad a la pantalla virtual
  • ncurses_putp — Aplicar la información de márgenes a la cadena e imprimirla
  • ncurses_qiflush — Producir volcado en caracteres de señales
  • ncurses_raw — Colocar la terminal en modo puro
  • ncurses_refresh — Refrescar la pantalla
  • ncurses_replace_panel — Reemplaza la ventana asociada con el panel
  • ncurses_reset_prog_mode — Restablece el modo de programa guardado por def_prog_mode
  • ncurses_reset_shell_mode — Restablece el modo de intérprete de comandos guardado por def_shell_mode
  • ncurses_resetty — Restablece el estado guardado de la terminal
  • ncurses_savetty — Guarda el estado de la terminal
  • ncurses_scr_dump — Vuelca el contenido de la pantalla en un archivo
  • ncurses_scr_init — Inicializar la pantalla desde un volcado en un archivo
  • ncurses_scr_restore — Recuperar la pantalla desde un volcado en un archivo
  • ncurses_scr_set — Heredar la pantalla de un volcado en un archivo
  • ncurses_scrl — Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual
  • ncurses_show_panel — Coloca un panel invisible al comienzo de la pila, haciéndola visible
  • ncurses_slk_attr — Devuelve el atributo de la etiqueta suave de teclado
  • ncurses_slk_attroff — Deshabilitar los atributos dados para las etiquetas suaves de teclado
  • ncurses_slk_attron — Habilitar los atributos dados para las etiquetas suaves de funciones de teclado
  • ncurses_slk_attrset — Definir los atributos dados para las etiquetas suaves de funciones de teclado
  • ncurses_slk_clear — Limpia las etiquetas suaves de la pantalla
  • ncurses_slk_color — Establece el color para las etiquetas suaves de teclado
  • ncurses_slk_init — Inicializa las funciones de tecla de etiquetación suave
  • ncurses_slk_noutrefresh — Copia las etiquetas suaves de teclado a la pantalla virtual
  • ncurses_slk_refresh — Copia las etiquetas suaves de teclado a la pantalla
  • ncurses_slk_restore — Recupera las etiquetas suaves de teclado
  • ncurses_slk_set — Establece las etiquetas de teclado
  • ncurses_slk_touch — Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh
  • ncurses_standend — Dejar de usar el atributo 'standout'
  • ncurses_standout — Comenzar a usar el atributo 'standout'
  • ncurses_start_color — Inicializa la funcionalidad de color
  • ncurses_termattrs — Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal
  • ncurses_termname — Devuelve el nombre (corto) de la terminal
  • ncurses_timeout — Establecer el tiempo de espera para secuencias especiales de teclas
  • ncurses_top_panel — Mueve un panel visible al tope de la pila
  • ncurses_typeahead — Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente
  • ncurses_ungetch — Colocar un caracter de vuelta en la secuencia de entrada
  • ncurses_ungetmouse — Coloca un evento de mouse en la cola
  • ncurses_update_panels — Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila
  • ncurses_use_default_colors — Asignar los colores predeterminados de la terminal al id de color -1
  • ncurses_use_env — Controlar el uso de información del entorno sobre el tamaño de la terminal
  • ncurses_use_extended_names — Controlar el uso de nombres extendidos en descripciones de información de terminal
  • ncurses_vidattr — Desplegar la cadena en la terminal con el atributo de modo de video
  • ncurses_vline — Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres
  • ncurses_waddch — Agrega un caracter en la posición actual de una ventana y avanza el cursor
  • ncurses_waddstr — Imprime un texto en la posición actual de una ventana
  • ncurses_wattroff — Deshabilita los atributos para una ventana
  • ncurses_wattron — Habilita los atributos para una ventana
  • ncurses_wattrset — Establecer los atributos para una ventana
  • ncurses_wborder — Dibuja un borde alrededor de la ventana usando caracteres con atributos
  • ncurses_wclear — Limpia la ventana
  • ncurses_wcolor_set — Establece parejas de colores en la ventana
  • ncurses_werase — Eliminar los contenidos de la ventana
  • ncurses_wgetch — Lee un caracter desde el teclado (en la ventana)
  • ncurses_whline — Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres
  • ncurses_wmouse_trafo — Transforma coordenadas de ventana/stdscr
  • ncurses_wmove — Mueve la posición de salida de la ventana
  • ncurses_wnoutrefresh — Copia la ventana a la pantalla virtual
  • ncurses_wrefresh — Refrescar la ventana en la pantalla de terminal
  • ncurses_wstandend — Finaliza el modo standout para una ventana
  • ncurses_wstandout — Ingresar a modo standout en una ventana
  • ncurses_wvline — Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres


Agregar un caracter en la posición actual y avanzar el cursor

  • « Funciones de Ncurses
  • ncurses_addchnstr »
  • PHP Manual
  • Funciones de Ncurses
  • Agregar un caracter en la posición actual y avanzar el cursor

ncurses_addch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addch — Agregar un caracter en la posición actual y avanzar el cursor

Descripción

ncurses_addch ( int $ch ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ch


Agregar cadena con atributos y longitud especificada en la posición actual

  • « ncurses_addch
  • ncurses_addchstr »
  • PHP Manual
  • Funciones de Ncurses
  • Agregar cadena con atributos y longitud especificada en la posición actual

ncurses_addchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchnstr — Agregar cadena con atributos y longitud especificada en la posición actual

Descripción

ncurses_addchnstr ( string $s , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

s

n


Agregar una cadena con atributos en la posición actual

  • « ncurses_addchnstr
  • ncurses_addnstr »
  • PHP Manual
  • Funciones de Ncurses
  • Agregar una cadena con atributos en la posición actual

ncurses_addchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchstr — Agregar una cadena con atributos en la posición actual

Descripción

ncurses_addchstr ( string $s ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

s


Agregar una cadena con la longitud especificada en la posición actual

  • « ncurses_addchstr
  • ncurses_addstr »
  • PHP Manual
  • Funciones de Ncurses
  • Agregar una cadena con la longitud especificada en la posición actual

ncurses_addnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addnstr — Agregar una cadena con la longitud especificada en la posición actual

Descripción

ncurses_addnstr ( string $s , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

s

n


Imprimir texto en la posición actual

  • « ncurses_addnstr
  • ncurses_assume_default_colors »
  • PHP Manual
  • Funciones de Ncurses
  • Imprimir texto en la posición actual

ncurses_addstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addstr — Imprimir texto en la posición actual

Descripción

ncurses_addstr ( string $text ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

text


Definir colores predeterminados para el color 0

  • « ncurses_addstr
  • ncurses_attroff »
  • PHP Manual
  • Funciones de Ncurses
  • Definir colores predeterminados para el color 0

ncurses_assume_default_colors

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_assume_default_colors — Definir colores predeterminados para el color 0

Descripción

ncurses_assume_default_colors ( int $fg , int $bg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fg

bg


Deshabilitar los atributos dados

  • « ncurses_assume_default_colors
  • ncurses_attron »
  • PHP Manual
  • Funciones de Ncurses
  • Deshabilitar los atributos dados

ncurses_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attroff — Deshabilitar los atributos dados

Descripción

ncurses_attroff ( int $attributes ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

attributes


Habilitar los atributos dados

  • « ncurses_attroff
  • ncurses_attrset »
  • PHP Manual
  • Funciones de Ncurses
  • Habilitar los atributos dados

ncurses_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attron — Habilitar los atributos dados

Descripción

ncurses_attron ( int $attributes ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

attributes


Establecer los atributos dados

  • « ncurses_attron
  • ncurses_baudrate »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer los atributos dados

ncurses_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attrset — Establecer los atributos dados

Descripción

ncurses_attrset ( int $attributes ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

attributes


Devuelve la tasa de baudios de la terminal

  • « ncurses_attrset
  • ncurses_beep »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve la tasa de baudios de la terminal

ncurses_baudrate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_baudrate — Devuelve la tasa de baudios de la terminal

Descripción

ncurses_baudrate ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Producir un beep en la terminal

  • « ncurses_baudrate
  • ncurses_bkgd »
  • PHP Manual
  • Funciones de Ncurses
  • Producir un beep en la terminal

ncurses_beep

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_beep — Producir un beep en la terminal

Descripción

ncurses_beep ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

ncurses_beep() envía una alerta auditiva (campana), y si no es posible produce un relampagueo en la pantalla.

Ver también

  • ncurses_flash() - Relampaguear la pantalla de terminal (campana visual)


Establecer la propiedad de segundo plano para la pantalla de la terminal

  • « ncurses_beep
  • ncurses_bkgdset »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer la propiedad de segundo plano para la pantalla de la terminal

ncurses_bkgd

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgd — Establecer la propiedad de segundo plano para la pantalla de la terminal

Descripción

ncurses_bkgd ( int $attrchar ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

attrchar


Controla el segundo plano de la pantalla

  • « ncurses_bkgd
  • ncurses_border »
  • PHP Manual
  • Funciones de Ncurses
  • Controla el segundo plano de la pantalla

ncurses_bkgdset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgdset — Controla el segundo plano de la pantalla

Descripción

ncurses_bkgdset ( int $attrchar ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

attrchar


Dibujar un borde alrededor de la pantalla usando caracteres con atributos

  • « ncurses_bkgdset
  • ncurses_bottom_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Dibujar un borde alrededor de la pantalla usando caracteres con atributos

ncurses_border

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_border — Dibujar un borde alrededor de la pantalla usando caracteres con atributos

Descripción

ncurses_border ( int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Dibuja las líneas y esquinas especificadas alrededor de la ventana principal.

¡Utilice ncurses_wborder() para los bordes alrededor de sub-ventanas!

Parámetros

Cada parámetro espera 0 para dibujar una línea, o 1 para ignorarla.

izquierda

derecha

arriba

abajo

esquina_sup_izq

Esquina superior izquierda

esquina_sup_der

Esquina superior derecha

esquina_inf_izq

Esquina inferior izquierda

esquina_inf_der

Esquina inferior derecha

Ver también

  • ncurses_wborder() - Dibuja un borde alrededor de la ventana usando caracteres con atributos


Mueve un panel visible al fondo de la pila

  • « ncurses_border
  • ncurses_can_change_color »
  • PHP Manual
  • Funciones de Ncurses
  • Mueve un panel visible al fondo de la pila

ncurses_bottom_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bottom_panel — Mueve un panel visible al fondo de la pila

Descripción

ncurses_bottom_panel ( resource $panel ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Comprobar si las definiciones de color del terminal se pueden cambiar

  • « ncurses_bottom_panel
  • ncurses_cbreak »
  • PHP Manual
  • Funciones de Ncurses
  • Comprobar si las definiciones de color del terminal se pueden cambiar

ncurses_can_change_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_can_change_color — Comprobar si las definiciones de color del terminal se pueden cambiar

Descripción

ncurses_can_change_color ( ) : bool

Comprueba si el terminal tiene capacidades de color y si el programador puede cambiar las definiciones de color usando ncurses_init_color(). ncurses debe ser inicializado usando ncurses_init() antes de llamar a esta función.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el programador puede cambiar las definiciones de color, false si no.

Ver también

  • ncurses_has_colors() - Comprueba si el terminal tiene capacidades de color
  • ncurses_init_color() - Definir un color de termimal
  • ncurses_start_color() - Inicializa la funcionalidad de color


Desactivar el búfer de entrada

  • « ncurses_can_change_color
  • ncurses_clear »
  • PHP Manual
  • Funciones de Ncurses
  • Desactivar el búfer de entrada

ncurses_cbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_cbreak — Desactivar el búfer de entrada

Descripción

ncurses_cbreak ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Deshabilita el buffer de líneas y el procesamiento de caracteres (la interrumpción y el control de flujo de caracteres no se ven afectados), haciendo que los caracterse tecleados por el usuario estén disponibles inmediatamente para el programa.

Valores devueltos

Devuelve true o NCURSES_ERR si ocurrión un error.

Ver también

  • ncurses_nocbreak() - Cambiar la terminal a modo normal (cooked)


Limpiar la pantalla

  • « ncurses_cbreak
  • ncurses_clrtobot »
  • PHP Manual
  • Funciones de Ncurses
  • Limpiar la pantalla

ncurses_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clear — Limpiar la pantalla

Descripción

ncurses_clear ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Limpia la pantalla completamente sin usar caracteres en blanco.

Nota: ncurses_clear() limpia la pantalla sin usar caracteres en blanco, que tienen la misma apariencia del segundo plano actual. Para limpiar la pantalla con caracteres en blanco, use ncurses_erase().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ncurses_erase() - Limpiar pantalla de terminal


Limpiar la pantalla desde la posición actual al final

  • « ncurses_clear
  • ncurses_clrtoeol »
  • PHP Manual
  • Funciones de Ncurses
  • Limpiar la pantalla desde la posición actual al final

ncurses_clrtobot

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtobot — Limpiar la pantalla desde la posición actual al final

Descripción

ncurses_clrtobot ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Elimina todas las líneas desde el cursor hasta el fin de la pantalla y crea caracteres en blanco. Los caracteres en blanco creados por ncurses_clrtobot() tienen la apariencia del segundo plano actual.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ncurses_clear() - Limpiar la pantalla
  • ncurses_clrtoeol() - Limpiar la pantalla desde la posición actual al final de la línea


Limpiar la pantalla desde la posición actual al final de la línea

  • « ncurses_clrtobot
  • ncurses_color_content »
  • PHP Manual
  • Funciones de Ncurses
  • Limpiar la pantalla desde la posición actual al final de la línea

ncurses_clrtoeol

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtoeol — Limpiar la pantalla desde la posición actual al final de la línea

Descripción

ncurses_clrtoeol ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Elimina la línea actual desde la posición actual hasta el final. Los caracteres en blanco creados por ncurses_clrtoeol() tienen la apariencia del segundo plano actual.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ncurses_clear() - Limpiar la pantalla
  • ncurses_clrtobot() - Limpiar la pantalla desde la posición actual al final


Obtiene los componentes RGB de un color

  • « ncurses_clrtoeol
  • ncurses_color_set »
  • PHP Manual
  • Funciones de Ncurses
  • Obtiene los componentes RGB de un color

ncurses_color_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_content — Obtiene los componentes RGB de un color

Descripción

ncurses_color_content ( int $color , int &$r , int &$g , int &$b ) : int

Obtiene los componentes rojo, verde y azul de la definición de color dada. Las capacidades de color del terminal deben ser inicializadas con ncurses_start_color() antes de llamar a esta función.

Parámetros

color

El número del color del que se va a obtener información. Puede ser una de las constantes de color predefinidas.

r

Una referencia a la que devolver el componente rojo del color. El valor devuelto a la referencia estará entre 0 y 1000.

g

Una referencia a la que devolver el componente verde del color. El valor devuelto a la referencia estará entre 0 y 1000.

b

Una referencia a la que devolver el componente azul del color. El valor devuelto a la referencia estará entre 0 y 1000.

Valores devueltos

Returns -1 si la función tuvo éxito, y 0 si ncurses o las capacidades de color del terminal no han sido inicializadas.

Ver también

  • ncurses_init_color() - Definir un color de termimal
  • ncurses_start_color() - Inicializa la funcionalidad de color


Establecer los colores de primer plano y fondo activos

  • « ncurses_color_content
  • ncurses_curs_set »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer los colores de primer plano y fondo activos

ncurses_color_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_set — Establecer los colores de primer plano y fondo activos

Descripción

ncurses_color_set ( int $pair ) : int

Establecer los colores de primer plano y fondo activos. Cualquier carácter escrito después de llamar a esta función tendrá estos colores. Esta función requiere colores de terminal para ser soportados e inicializados usando ncurses_start_color() con antelación.

ncurses utiliza pares de colores para especificar los colores de primer plano y fondo. Use ncurses_init_pair() para definir una pareja de colores.

Parámetros

pair

La pareja de colores que va a obtener los colores de primer plano y fondo para establecer los colores activos.

Valores devueltos

Devuelve -1 en caso de éxito, y 0 en caso de fallo.

Ejemplos

Ejemplo #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// Si el terminal soporta colores, inicializar y establecer el color activo
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Escribir una cadena en la ubicación especificada
ncurses_mvaddstr(10, 10, "¡Hola mundo! ¡Amarillo sobre texto azul!");

// Volcar la salida a la pantalla
ncurses_refresh();

ncurses_end();
?>

Ver también

  • ncurses_init_pair() - Definir una pareja de colores
  • ncurses_start_color() - Inicializa la funcionalidad de color


Establecer el estado del cursor

  • « ncurses_color_set
  • ncurses_def_prog_mode »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer el estado del cursor

ncurses_curs_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_curs_set — Establecer el estado del cursor

Descripción

ncurses_curs_set ( int $visibility ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

visibility


Guarda los modos de terminal (programa)

  • « ncurses_curs_set
  • ncurses_def_shell_mode »
  • PHP Manual
  • Funciones de Ncurses
  • Guarda los modos de terminal (programa)

ncurses_def_prog_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_prog_mode — Guarda los modos de terminal (programa)

Descripción

ncurses_def_prog_mode ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Guarda los modos de terminal actuales para programa (en curses) para su uso por ncurses_reset_prog_mode().

Valores devueltos

Devuelve false en caso de éxito, true de lo contrario.

Ver también

  • ncurses_reset_prog_mode() - Restablece el modo de programa guardado por def_prog_mode


Guarda los modos de terminal (intérprete de comandos)

  • « ncurses_def_prog_mode
  • ncurses_define_key »
  • PHP Manual
  • Funciones de Ncurses
  • Guarda los modos de terminal (intérprete de comandos)

ncurses_def_shell_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_shell_mode — Guarda los modos de terminal (intérprete de comandos)

Descripción

ncurses_def_shell_mode ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Guarda los modos de terminal actuales de intérprete de comandos (no en curses) para su uso con ncurses_reset_shell_mode().

Valores devueltos

Devuelve false en caso de éxito, true de lo contrario.

Ver también

  • ncurses_reset_shell_mode() - Restablece el modo de intérprete de comandos guardado por def_shell_mode


Definir un código de tecla

  • « ncurses_def_shell_mode
  • ncurses_del_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Definir un código de tecla

ncurses_define_key

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_define_key — Definir un código de tecla

Descripción

ncurses_define_key ( string $definition , int $keycode ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

definicion

codigo_tecla


Remover un panel de la pila y eliminarlo (pero no la ventana asociada)

  • « ncurses_define_key
  • ncurses_delay_output »
  • PHP Manual
  • Funciones de Ncurses
  • Remover un panel de la pila y eliminarlo (pero no la ventana asociada)

ncurses_del_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_del_panel — Remover un panel de la pila y eliminarlo (pero no la ventana asociada)

Descripción

ncurses_del_panel ( resource $panel ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Retrasar la salida en la terminal usando caracteres de relleno

  • « ncurses_del_panel
  • ncurses_delch »
  • PHP Manual
  • Funciones de Ncurses
  • Retrasar la salida en la terminal usando caracteres de relleno

ncurses_delay_output

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delay_output — Retrasar la salida en la terminal usando caracteres de relleno

Descripción

ncurses_delay_output ( int $milliseconds ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

milliseconds


Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda

  • « ncurses_delay_output
  • ncurses_deleteln »
  • PHP Manual
  • Funciones de Ncurses
  • Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda

ncurses_delch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delch — Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda

Descripción

ncurses_delch ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Elimina el caracter bajo el cursor. Todos los caracteres a la derecha del cursor en la misma línea son desplazados una posición hacia la izquierda, y el último caracter en la línea es llenado con un caracter en blanco. La posición del cursor no cambia.

Valores devueltos

Devuelve false en caso de tener éxito, o true de lo contrario.

Ver también

  • ncurses_deleteln() - Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba


Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba

  • « ncurses_delch
  • ncurses_delwin »
  • PHP Manual
  • Funciones de Ncurses
  • Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba

ncurses_deleteln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_deleteln — Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba

Descripción

ncurses_deleteln ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Elimina la línea actual bajo la posición del cursor. Todas las líneas por debajo de la línea actual son desplazadas una línea hacia arriba. La línea más baja es limpiada. La posición del cursor no cambia.

Valores devueltos

Devuelve false en caso de éxito, true de lo contrario.

Ver también

  • ncurses_delch() - Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda


Eliminar una ventana ncurses

  • « ncurses_deleteln
  • ncurses_doupdate »
  • PHP Manual
  • Funciones de Ncurses
  • Eliminar una ventana ncurses

ncurses_delwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delwin — Eliminar una ventana ncurses

Descripción

ncurses_delwin ( resource $window ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Escribir todas las actualizaciones preparadas sobre la terminal

  • « ncurses_delwin
  • ncurses_echo »
  • PHP Manual
  • Funciones de Ncurses
  • Escribir todas las actualizaciones preparadas sobre la terminal

ncurses_doupdate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_doupdate — Escribir todas las actualizaciones preparadas sobre la terminal

Descripción

ncurses_doupdate ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Compara la pantalla virtual con la pantalla física y actualiza la pantalla física. De esta forma es más efectivo que usando múltiples llamadas de actualización.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Activar la repetición de entrada del teclado

  • « ncurses_doupdate
  • ncurses_echochar »
  • PHP Manual
  • Funciones de Ncurses
  • Activar la repetición de entrada del teclado

ncurses_echo

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echo — Activar la repetición de entrada del teclado

Descripción

ncurses_echo ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Habilita el modo de repetición. Todos los caracteres escritos por el usuario son repetidos por ncurses_getch().

Valores devueltos

Devuelve false de tener éxito, o true si ocurrió algún error.

Ver también

  • ncurses_noecho() - Desactivar la repetición de entrada del teclado para deshabilitar el modo de repetición


Salida de un caracter sencillo, incluyendo actualización

  • « ncurses_echo
  • ncurses_end »
  • PHP Manual
  • Funciones de Ncurses
  • Salida de un caracter sencillo, incluyendo actualización

ncurses_echochar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echochar — Salida de un caracter sencillo, incluyendo actualización

Descripción

ncurses_echochar ( int $character ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

character


Dejar de usar ncurses, limpiar la pantalla

  • « ncurses_echochar
  • ncurses_erase »
  • PHP Manual
  • Funciones de Ncurses
  • Dejar de usar ncurses, limpiar la pantalla

ncurses_end

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_end — Dejar de usar ncurses, limpiar la pantalla

Descripción

ncurses_end ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Limpiar pantalla de terminal

  • « ncurses_end
  • ncurses_erasechar »
  • PHP Manual
  • Funciones de Ncurses
  • Limpiar pantalla de terminal

ncurses_erase

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erase — Limpiar pantalla de terminal

Descripción

ncurses_erase ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Llena la pantalla de terminal con caracteres en blanco.

Los caracteres creados tienen la apariencia del segundo plano actual, establecida por ncurses_bkgd().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ncurses_bkgd() - Establecer la propiedad de segundo plano para la pantalla de la terminal
  • ncurses_clear() - Limpiar la pantalla


Devuelve el caracter de borrado actual

  • « ncurses_erase
  • ncurses_filter »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el caracter de borrado actual

ncurses_erasechar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erasechar — Devuelve el caracter de borrado actual

Descripción

ncurses_erasechar ( ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve el caracter de borrado actual.

Valores devueltos

El caracter de borrado actual, como una cadena.

Ver también

  • ncurses_killchar() - Devuelve el caracter de eliminación de línea actual


Definir LINES para iniscr() y newterm() a 1

  • « ncurses_erasechar
  • ncurses_flash »
  • PHP Manual
  • Funciones de Ncurses
  • Definir LINES para iniscr() y newterm() a 1

ncurses_filter

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_filter — Definir LINES para iniscr() y newterm() a 1

Descripción

ncurses_filter ( ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Relampaguear la pantalla de terminal (campana visual)

  • « ncurses_filter
  • ncurses_flushinp »
  • PHP Manual
  • Funciones de Ncurses
  • Relampaguear la pantalla de terminal (campana visual)

ncurses_flash

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flash — Relampaguear la pantalla de terminal (campana visual)

Descripción

ncurses_flash ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Relampaguea la pantalla, y si no es posible, envía una aletra auditiva (campana).

Valores devueltos

Devuelve false de tener éxito, true de lo contrario.

Ver también

  • ncurses_beep() - Producir un beep en la terminal


Volcar el búfer de entrada de teclado

  • « ncurses_flash
  • ncurses_getch »
  • PHP Manual
  • Funciones de Ncurses
  • Volcar el búfer de entrada de teclado

ncurses_flushinp

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flushinp — Volcar el búfer de entrada de teclado

Descripción

ncurses_flushinp ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Envía cualquier contenido que haya sido escrito y no haya sido leido aun por su programa.

Valores devueltos

Devuelve false en caso de tener éxito, true de lo contrario.


Leer un caracter desde el teclado

  • « ncurses_flushinp
  • ncurses_getmaxyx »
  • PHP Manual
  • Funciones de Ncurses
  • Leer un caracter desde el teclado

ncurses_getch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getch — Leer un caracter desde el teclado

Descripción

ncurses_getch ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve el tamaño de una ventana

  • « ncurses_getch
  • ncurses_getmouse »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el tamaño de una ventana

ncurses_getmaxyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmaxyx — Devuelve el tamaño de una ventana

Descripción

ncurses_getmaxyx ( resource $window , int &$y , int &$x ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Obtiene los tamaños horizontal y vertical de la ventana dada y los coloca en las variables entregadas.

Las variables deben ser pasadas como referencias, de modo que sean actualizadas cuando el usuario cambie el tamaño de la terminal.

Parámetros

window

La ventana medida

y

Esto será establecido con la altura de la ventana

x

Esto será establecido con el ancho de la ventana

Valores devueltos

No devuelve ningún valor.


Lee los eventos del ratón

  • « ncurses_getmaxyx
  • ncurses_getyx »
  • PHP Manual
  • Funciones de Ncurses
  • Lee los eventos del ratón

ncurses_getmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmouse — Lee los eventos del ratón

Descripción

ncurses_getmouse ( array &$mevent ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

ncurses_getmouse() lee los eventos del ratón de la cola.

Parámetros

mevent

Las opciones del evento serán distribuidas en este parámetro que ha de ser un array, pasado por referencia (véase el ejemplo de abajo).

En caso de éxito será distribuido un array con las siguientes claves:

  • "id" : Id para distinguir múltiples dispositivos

  • "x" : posición x relativa a la pantalla en las celdas de caracteres

  • "y" : posición y relativa a la pantalla en las celdas de caracteres

  • "z" : actualmente no soportado

  • "mmask" : Acción del ratón

Valores devueltos

Devuelve false si un evento de ratón está realmente visible en la ventana dada, de otro modo devuelve true.

Ejemplos

Ejemplo #1 Ejemplo de ncurses_getmouse()

<?php
switch (ncurses_getch()){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse($mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Guardar la posición del ratón
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    /* .... */
}
?>

Ver también

  • ncurses_ungetmouse() - Coloca un evento de mouse en la cola


Devuelve la posición de cursor actual para una ventana

  • « ncurses_getmouse
  • ncurses_halfdelay »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve la posición de cursor actual para una ventana

ncurses_getyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getyx — Devuelve la posición de cursor actual para una ventana

Descripción

ncurses_getyx ( resource $window , int &$y , int &$x ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

y

x


Colocar la terminal en modo de medio retraso

  • « ncurses_getyx
  • ncurses_has_colors »
  • PHP Manual
  • Funciones de Ncurses
  • Colocar la terminal en modo de medio retraso

ncurses_halfdelay

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_halfdelay — Colocar la terminal en modo de medio retraso

Descripción

ncurses_halfdelay ( int $tenth ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

decimo


Comprueba si el terminal tiene capacidades de color

  • « ncurses_halfdelay
  • ncurses_has_ic »
  • PHP Manual
  • Funciones de Ncurses
  • Comprueba si el terminal tiene capacidades de color

ncurses_has_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_colors — Comprueba si el terminal tiene capacidades de color

Descripción

ncurses_has_colors ( ) : bool

Comprueba si el terminal tiene capacidades de color. Esta función se puede usar para escribir programas independientes del terminal. ncurses debe ser inicializado usando ncurses_init() antes de llamar a esta función.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el terminal tiene capacidades de color, false si no.

Ejemplos

Ejemplo #1 Escribir una cadena con un color especificado en la pantalla

<?php
ncurses_init();

// Si el terminal soporta colores, inicializar y establecer el color activo
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Escribir una cadena en la ubicación especificada
ncurses_mvaddstr(10, 10, "¡Hola mundo! ¡Amarillo sobre texto azul!");

// Volcar la salida a la pantalla
ncurses_refresh();

ncurses_end();
?>

Ver también

  • ncurses_can_change_color() - Comprobar si las definiciones de color del terminal se pueden cambiar
  • ncurses_start_color() - Inicializa la funcionalidad de color


Chequear por el soporte de inserción y borrado

  • « ncurses_has_colors
  • ncurses_has_il »
  • PHP Manual
  • Funciones de Ncurses
  • Chequear por el soporte de inserción y borrado

ncurses_has_ic

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_ic — Chequear por el soporte de inserción y borrado

Descripción

ncurses_has_ic ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Chequea si existe soporte de inserción y borrado de la terminal.

Valores devueltos

Devuelve true cuando la terminal tiene soporte de inserción/borrado, false de lo contrario.

Ver también

  • ncurses_has_il() - Chequea el soporte de inserción y borrado


Chequea el soporte de inserción y borrado

  • « ncurses_has_ic
  • ncurses_has_key »
  • PHP Manual
  • Funciones de Ncurses
  • Chequea el soporte de inserción y borrado

ncurses_has_il

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_il — Chequea el soporte de inserción y borrado

Descripción

ncurses_has_il ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Chequea si existe soporte de inserción y borrado de líneas de la terminal.

Valores devueltos

Devuelve true cuando la terminal tiene soporte de inserción/borrado de líneas, false de lo contrario.

Ver también

  • ncurses_has_ic() - Chequear por el soporte de inserción y borrado


Chequear por la presencia de una tecla de función en el teclado de la terminal

  • « ncurses_has_il
  • ncurses_hide_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Chequear por la presencia de una tecla de función en el teclado de la terminal

ncurses_has_key

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_key — Chequear por la presencia de una tecla de función en el teclado de la terminal

Descripción

ncurses_has_key ( int $keycode ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

keycode


Remover un panel de la pila, haciéndolo invisible

  • « ncurses_has_key
  • ncurses_hline »
  • PHP Manual
  • Funciones de Ncurses
  • Remover un panel de la pila, haciéndolo invisible

ncurses_hide_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hide_panel — Remover un panel de la pila, haciéndolo invisible

Descripción

ncurses_hide_panel ( resource $panel ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo

  • « ncurses_hide_panel
  • ncurses_inch »
  • PHP Manual
  • Funciones de Ncurses
  • Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo

ncurses_hline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hline — Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo

Descripción

ncurses_hline ( int $charattr , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

caracter_atributos

n


Obtener el caracter y los atributos de la posición actual

  • « ncurses_hline
  • ncurses_init_color »
  • PHP Manual
  • Funciones de Ncurses
  • Obtener el caracter y los atributos de la posición actual

ncurses_inch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_inch — Obtener el caracter y los atributos de la posición actual

Descripción

ncurses_inch ( ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve el caracter desde de la posición actual.

Valores devueltos

Devuelve el caracter, como una cadena.


Definir un color de termimal

  • « ncurses_inch
  • ncurses_init_pair »
  • PHP Manual
  • Funciones de Ncurses
  • Definir un color de termimal

ncurses_init_color

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_color — Definir un color de termimal

Descripción

ncurses_init_color ( int $color , int $r , int $g , int $b ) : int

Define o redefine el color dado. Cuando se llama a esta función, todas los casos del color dado en la pantalla, si los hay, son cambiados inmediatamente a la nueva definición.

Las capacidades de color deben ser soportadas por el terminal e inicializadas usando ncurses_start_color() antes de llamar a esta función Además, el terminal debe tener capacidad para cambiar de color; use ncurses_can_change_color() para comprobarlo.

Parámetros

color

El número de identificación del color a redefinir. Puede ser una de las constnates de color predeterminadas.

r

Un valor de color, entre 0 y 1000, para el componente rojo.

g

Un valor de color, entre 0 y 1000, para el componente verde.

b

Un valor de color, entre 0 y 1000, para el componente azul.

Valores devueltos

Devuelve -1 si la función tuvo éxito, y 0 si ncurses o las capacidades de color del terminal no han sido inicializadas o el terminal no tiene capacidad de cambiar de color.

Ver también

  • ncurses_color_content() - Obtiene los componentes RGB de un color
  • ncurses_start_color() - Inicializa la funcionalidad de color


Definir una pareja de colores

  • « ncurses_init_color
  • ncurses_init »
  • PHP Manual
  • Funciones de Ncurses
  • Definir una pareja de colores

ncurses_init_pair

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_pair — Definir una pareja de colores

Descripción

ncurses_init_pair ( int $pair , int $fg , int $bg ) : int

Define o redefine la pareja de colores dada para obtener los colores de primer plano y fondo dados. Si la pareja de colores estaba previamente inicializada, se refresca la pantalla y todas los casos de ella son cambiados para reflejar la nueva definición.

Las capacidades de color deben ser inicializadas usando ncurses_start_color() antes de llamar a esta función. Por omisión, la primera pareja de colores (pareja de colores 0) se asume que es blanco sobre negro, pero se puede cambiar usando ncurses_assume_default_colors().

Parámetros

pair

El número de la pareja de colores a definir.

fg

El color de primer plano de la pareja de colroes. Pude ser uno de los colores predefinidos o uno definido por ncurses_init_color() si el terminal tiene capacidades de cambio de color.

bg

El color de fondo de la pareja de colores. Pude ser uno de los colores predefinidos o uno definido por ncurses_init_color() si el terminal tiene capacidades de cambio de color.

Valores devueltos

Devuelve -1 si la función tuvo éxito, y 0 si ncurses o el soporte para colores no fue inicializado.

Notas

Observe que las capacidades de cambio de color no son necesarias para definir pares de colores de colores preexistentes, excepto solo para los cambios de definiciones (componentes rojo, verde y azul) de los colores en sí por ncurses_init_color().

Ejemplos

Ejemplo #1 Escrivir una cadena con un color especificado en la pantalla

<?php
ncurses_init();

// Si el terminal soporta colores, inicializar y establecer el color activo
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Escrivir una cadena en una ubicación especificada
ncurses_mvaddstr(10, 10, "¡Hola mundo! ¡Amarillo sobre texto azul!");

// Volcar la salida a la pantalla
ncurses_refresh();

ncurses_end();
?>

Ver también

  • ncurses_pair_content() - Obtiene los colores de primer plano y fondo de una pareja de colores
  • ncurses_start_color() - Inicializa la funcionalidad de color


Inicializar ncurses

  • « ncurses_init_pair
  • ncurses_insch »
  • PHP Manual
  • Funciones de Ncurses
  • Inicializar ncurses

ncurses_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init — Inicializar ncurses

Descripción

ncurses_init ( ) : void

Inicializa la interfaz de ncurses. Esta función debe ser usada antes de otras llamadas funciones de ncurses.

Observe que ncurses_end() debe ser llamada antes de salir del programa, o el terminal no será restaurado a un modo no visual porpio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ncurses_end() - Dejar de usar ncurses, limpiar la pantalla


Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual

  • « ncurses_init
  • ncurses_insdelln »
  • PHP Manual
  • Funciones de Ncurses
  • Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual

ncurses_insch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insch — Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual

Descripción

ncurses_insch ( int $character ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

character


Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)

  • « ncurses_insch
  • ncurses_insertln »
  • PHP Manual
  • Funciones de Ncurses
  • Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)

ncurses_insdelln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insdelln — Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)

Descripción

ncurses_insdelln ( int $count ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

count


Insertar una línea, mover el resto de la pantalla hacia abajo

  • « ncurses_insdelln
  • ncurses_insstr »
  • PHP Manual
  • Funciones de Ncurses
  • Insertar una línea, mover el resto de la pantalla hacia abajo

ncurses_insertln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insertln — Insertar una línea, mover el resto de la pantalla hacia abajo

Descripción

ncurses_insertln ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Inserta una nueva línea antes de la línea actual. La línea más baja se perderá.


Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha

  • « ncurses_insertln
  • ncurses_instr »
  • PHP Manual
  • Funciones de Ncurses
  • Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha

ncurses_insstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insstr — Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha

Descripción

ncurses_insstr ( string $text ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

text


Lee una cadena desde la pantalla de terminal

  • « ncurses_insstr
  • ncurses_isendwin »
  • PHP Manual
  • Funciones de Ncurses
  • Lee una cadena desde la pantalla de terminal

ncurses_instr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_instr — Lee una cadena desde la pantalla de terminal

Descripción

ncurses_instr ( string &$buffer ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Lee una cadena desde la terminal y devuelve el número de caracteres leidos desde la posición del caracter actual hasta el fin de línea.

Parámetros

buffer

Los caracteres. Los atributos son retirados de los caracteres.

Valores devueltos

Devuelve el número de caracteres.


Ncurses está en modo endwin, se puede realizar una salida normal por pantalla

  • « ncurses_instr
  • ncurses_keyok »
  • PHP Manual
  • Funciones de Ncurses
  • Ncurses está en modo endwin, se puede realizar una salida normal por pantalla

ncurses_isendwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_isendwin — Ncurses está en modo endwin, se puede realizar una salida normal por pantalla

Descripción

ncurses_isendwin ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Comprueba si ncurses está en modo endwin.

Valores devueltos

Devuelve true, si ncurses_end() ha sido llamada sin ninguna llamada subsiguiente a ncurses_wrefresh(), false si no.

Ver también

  • ncurses_end() - Dejar de usar ncurses, limpiar la pantalla
  • ncurses_wrefresh() - Refrescar la ventana en la pantalla de terminal


Habilitar o deshabilitar un código de tecla

  • « ncurses_isendwin
  • ncurses_keypad »
  • PHP Manual
  • Funciones de Ncurses
  • Habilitar o deshabilitar un código de tecla

ncurses_keyok

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keyok — Habilitar o deshabilitar un código de tecla

Descripción

ncurses_keyok ( int $keycode , bool $enable ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

keycode

enable


Activa o desactiva el teclado numérico

  • « ncurses_keyok
  • ncurses_killchar »
  • PHP Manual
  • Funciones de Ncurses
  • Activa o desactiva el teclado numérico

ncurses_keypad

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keypad — Activa o desactiva el teclado numérico

Descripción

ncurses_keypad ( resource $window , bool $bf ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

bf


Devuelve el caracter de eliminación de línea actual

  • « ncurses_keypad
  • ncurses_longname »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el caracter de eliminación de línea actual

ncurses_killchar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_killchar — Devuelve el caracter de eliminación de línea actual

Descripción

ncurses_killchar ( ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve el caracter de eliminación de línea actual.

Valores devueltos

Devuelve el caracter de eliminación de línea, como una cadena.

Ver también

  • ncurses_erasechar() - Devuelve el caracter de borrado actual


Devuelve la descripción de la terminal

  • « ncurses_killchar
  • ncurses_meta »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve la descripción de la terminal

ncurses_longname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_longname — Devuelve la descripción de la terminal

Descripción

ncurses_longname ( ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve una descripción detallada de la terminal.

Valores devueltos

Devuelve la descripción, como una cadena truncada a 128 caracteres. En caso de fallos, devuelve null.

Ver también

  • ncurses_termname() - Devuelve el nombre (corto) de la terminal


Habilita/deshabilita la meta-información de 8-bits de tecla

  • « ncurses_longname
  • ncurses_mouse_trafo »
  • PHP Manual
  • Funciones de Ncurses
  • Habilita/deshabilita la meta-información de 8-bits de tecla

ncurses_meta

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_meta — Habilita/deshabilita la meta-información de 8-bits de tecla

Descripción

ncurses_meta ( resource $window , bool $8bit ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

8bit


Transforma coordenadas

  • « ncurses_meta
  • ncurses_mouseinterval »
  • PHP Manual
  • Funciones de Ncurses
  • Transforma coordenadas

ncurses_mouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouse_trafo — Transforma coordenadas

Descripción

ncurses_mouse_trafo ( int &$y , int &$x , bool $toscreen ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

toscreen


Establecer el tiempo de espera para clics de botón del mouse

  • « ncurses_mouse_trafo
  • ncurses_mousemask »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer el tiempo de espera para clics de botón del mouse

ncurses_mouseinterval

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouseinterval — Establecer el tiempo de espera para clics de botón del mouse

Descripción

ncurses_mouseinterval ( int $milliseconds ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

milliseconds


Establece las opciones del ratón

  • « ncurses_mouseinterval
  • ncurses_move_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Establece las opciones del ratón

ncurses_mousemask

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mousemask — Establece las opciones del ratón

Descripción

ncurses_mousemask ( int $newmask , int &$oldmask ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Establece los eventos del ratón para ser reportados. Por omisión no se informará de ningún evento de ratón.

Los eventos de ratón están representados por NCURSES_KEY_MOUSE en el flujo de entrada de ncurses_wgetch(). Para leer la información del evento y sacar el evento de la cola, llame a ncurses_getmouse().

Parámetros

newmask

Las opciones de máscara del ratón pueden ser establecida con las siguienetes constantes predefinidas:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

Como efecto secundario, establecer una máscara de ratón a cero en newmask descativa el puntero del ratón. Establecer un valor distinto de cero activa el puntero del ratón.

oldmask

Esto establecerá el valor anterior de la máscara de eventos del ratón.

Valores devueltos

Devuelve la máscara de los eventos que pueden ser notificador. En caso de fallo completo devuelve 0.

Ejemplos

Ejemplo #1 Ejemplo de ncurses_mousemask()

<?php
$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, $oldmask);
if ($mask & $newmask){
    printf("Todas las opciones de ratón especificadas serán soportadas\n");
}
?>

Ver también

  • ncurses_getch() - Leer un caracter desde el teclado
  • ncurses_getmouse() - Lee los eventos del ratón
  • ncurses_ungetmouse() - Coloca un evento de mouse en la cola


Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]

  • « ncurses_mousemask
  • ncurses_move »
  • PHP Manual
  • Funciones de Ncurses
  • Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]

ncurses_move_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move_panel — Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]

Descripción

ncurses_move_panel ( resource $panel , int $startx , int $starty ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel

startx

starty


Mover la posición de salida

  • « ncurses_move_panel
  • ncurses_mvaddch »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición de salida

ncurses_move

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move — Mover la posición de salida

Descripción

ncurses_move ( int $y , int $x ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x


Mover la posición actual y agregar un caracter

  • « ncurses_move
  • ncurses_mvaddchnstr »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición actual y agregar un caracter

ncurses_mvaddch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddch — Mover la posición actual y agregar un caracter

Descripción

ncurses_mvaddch ( int $y , int $x , int $c ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

c


Mover la posición y agregar una cadena con atributos con la longitud especificada

  • « ncurses_mvaddch
  • ncurses_mvaddchstr »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y agregar una cadena con atributos con la longitud especificada

ncurses_mvaddchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchnstr — Mover la posición y agregar una cadena con atributos con la longitud especificada

Descripción

ncurses_mvaddchnstr ( int $y , int $x , string $s , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

s

n


Mover la posición y agregar una cadena con atributos

  • « ncurses_mvaddchnstr
  • ncurses_mvaddnstr »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y agregar una cadena con atributos

ncurses_mvaddchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchstr — Mover la posición y agregar una cadena con atributos

Descripción

ncurses_mvaddchstr ( int $y , int $x , string $s ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

s


Mover la posición y agregar una cadena con la longitud especificada

  • « ncurses_mvaddchstr
  • ncurses_mvaddstr »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y agregar una cadena con la longitud especificada

ncurses_mvaddnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddnstr — Mover la posición y agregar una cadena con la longitud especificada

Descripción

ncurses_mvaddnstr ( int $y , int $x , string $s , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

s

n


Mover la posición y agregar una cadena

  • « ncurses_mvaddnstr
  • ncurses_mvcur »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y agregar una cadena

ncurses_mvaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddstr — Mover la posición y agregar una cadena

Descripción

ncurses_mvaddstr ( int $y , int $x , string $s ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

s


Mover el cursor inmediatamente

  • « ncurses_mvaddstr
  • ncurses_mvdelch »
  • PHP Manual
  • Funciones de Ncurses
  • Mover el cursor inmediatamente

ncurses_mvcur

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvcur — Mover el cursor inmediatamente

Descripción

ncurses_mvcur ( int $old_y , int $old_x , int $new_y , int $new_x ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

old_y

old_x

new_y

new_x


Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda

  • « ncurses_mvcur
  • ncurses_mvgetch »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda

ncurses_mvdelch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvdelch — Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda

Descripción

ncurses_mvdelch ( int $y , int $x ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x


Mover la posición y obtener el caracter en la nueva posición

  • « ncurses_mvdelch
  • ncurses_mvhline »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y obtener el caracter en la nueva posición

ncurses_mvgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvgetch — Mover la posición y obtener el caracter en la nueva posición

Descripción

ncurses_mvgetch ( int $y , int $x ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x


Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres

  • « ncurses_mvgetch
  • ncurses_mvinch »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres

ncurses_mvhline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvhline — Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres

Descripción

ncurses_mvhline ( int $y , int $x , int $attrchar , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

attrchar

n


Mover la posición y obtener el caracter con atributos en la nueva posición

  • « ncurses_mvhline
  • ncurses_mvvline »
  • PHP Manual
  • Funciones de Ncurses
  • Mover la posición y obtener el caracter con atributos en la nueva posición

ncurses_mvinch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvinch — Mover la posición y obtener el caracter con atributos en la nueva posición

Descripción

ncurses_mvinch ( int $y , int $x ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x


Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres

  • « ncurses_mvinch
  • ncurses_mvwaddstr »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres

ncurses_mvvline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvvline — Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres

Descripción

ncurses_mvvline ( int $y , int $x , int $attrchar , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

y

x

attrchar

n


Añadir una cadena en una posicón nueva de la ventana

  • « ncurses_mvvline
  • ncurses_napms »
  • PHP Manual
  • Funciones de Ncurses
  • Añadir una cadena en una posicón nueva de la ventana

ncurses_mvwaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvwaddstr — Añadir una cadena en una posicón nueva de la ventana

Descripción

ncurses_mvwaddstr ( resource $window , int $y , int $x , string $text ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

y

x

text


Dormir

  • « ncurses_mvwaddstr
  • ncurses_new_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Dormir

ncurses_napms

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_napms — Dormir

Descripción

ncurses_napms ( int $milliseconds ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

milliseconds


Crear un nuevo panel y asociarlo con una ventana

  • « ncurses_napms
  • ncurses_newpad »
  • PHP Manual
  • Funciones de Ncurses
  • Crear un nuevo panel y asociarlo con una ventana

ncurses_new_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_new_panel — Crear un nuevo panel y asociarlo con una ventana

Descripción

ncurses_new_panel ( resource $window ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Crea un nuevo pad (ventana)

  • « ncurses_new_panel
  • ncurses_newwin »
  • PHP Manual
  • Funciones de Ncurses
  • Crea un nuevo pad (ventana)

ncurses_newpad

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newpad — Crea un nuevo pad (ventana)

Descripción

ncurses_newpad ( int $rows , int $cols ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

rows

cols


Crear una nueva ventana

  • « ncurses_newpad
  • ncurses_nl »
  • PHP Manual
  • Funciones de Ncurses
  • Crear una nueva ventana

ncurses_newwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newwin — Crear una nueva ventana

Descripción

ncurses_newwin ( int $rows , int $cols , int $y , int $x ) : resource
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Crea una nueva ventana en donde dibujar elementos.

Cuando se creen ventanas adicionales, recuerde usar ncurses_getmaxyx() para verificar el espacio disponible, ya que el tamaño de terminal es individual y puede variar.

Parámetros

rows

Número de filas

cols

Número de columnas

y

coordenada y del origen

x

coordenada x del origen

Valores devueltos

Devuelve un ID de recurso para la nueva ventana.


Traducir línea nueva y retorno de carro / alimentación de línea

  • « ncurses_newwin
  • ncurses_nocbreak »
  • PHP Manual
  • Funciones de Ncurses
  • Traducir línea nueva y retorno de carro / alimentación de línea

ncurses_nl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nl — Traducir línea nueva y retorno de carro / alimentación de línea

Descripción

ncurses_nl ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Cambiar la terminal a modo normal (cooked)

  • « ncurses_nl
  • ncurses_noecho »
  • PHP Manual
  • Funciones de Ncurses
  • Cambiar la terminal a modo normal (cooked)

ncurses_nocbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nocbreak — Cambiar la terminal a modo normal (cooked)

Descripción

ncurses_nocbreak ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve la terminal a modo normal (cooked). Inicialmente la terminal puede o no estar en modo cbreak, ya que el modo se hereda. De tal modo que un programa debería llamar a ncurses_cbreak() y ncurses_nocbreak() explícitamente.

Valores devueltos

Devuelve true si ocurrió un error, o false de lo contrario.

Ver también

  • ncurses_cbreak() - Desactivar el búfer de entrada


Desactivar la repetición de entrada del teclado

  • « ncurses_nocbreak
  • ncurses_nonl »
  • PHP Manual
  • Funciones de Ncurses
  • Desactivar la repetición de entrada del teclado

ncurses_noecho

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noecho — Desactivar la repetición de entrada del teclado

Descripción

ncurses_noecho ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Previene la repetición de los caracteres escritos por el usuario.

Valores devueltos

Devuelve true si ocurre un error, o false de lo contrario.

Ver también

  • ncurses_echo() - Activar la repetición de entrada del teclado
  • ncurses_getch() - Leer un caracter desde el teclado


No traducir línea nueva y retorno de carro / alimentación de línea

  • « ncurses_noecho
  • ncurses_noqiflush »
  • PHP Manual
  • Funciones de Ncurses
  • No traducir línea nueva y retorno de carro / alimentación de línea

ncurses_nonl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nonl — No traducir línea nueva y retorno de carro / alimentación de línea

Descripción

ncurses_nonl ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


No realizar volcados en caracteres de señales

  • « ncurses_nonl
  • ncurses_noraw »
  • PHP Manual
  • Funciones de Ncurses
  • No realizar volcados en caracteres de señales

ncurses_noqiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noqiflush — No realizar volcados en caracteres de señales

Descripción

ncurses_noqiflush ( ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Salir del modo puro en la terminal

  • « ncurses_noqiflush
  • ncurses_pair_content »
  • PHP Manual
  • Funciones de Ncurses
  • Salir del modo puro en la terminal

ncurses_noraw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noraw — Salir del modo puro en la terminal

Descripción

ncurses_noraw ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Retira la terminal del modo puro. El modo puro (raw) es similar al modo cbrek, en tanto que los caracteres escritos son pasados inmediatamente al programa del usuario. Las diferencias consisten en que, en modo puro, los caracteres de control de interrupción, salida, suspensión y flujo son todos pasados sin ser interpretados, en lugar de generar una señal.

Valores devueltos

Devuelve true si ocurrió un error, o false de lo contrario.

Ver también

  • ncurses_raw() - Colocar la terminal en modo puro
  • ncurses_cbreak() - Desactivar el búfer de entrada
  • ncurses_nocbreak() - Cambiar la terminal a modo normal (cooked)


Obtiene los colores de primer plano y fondo de una pareja de colores

  • « ncurses_noraw
  • ncurses_panel_above »
  • PHP Manual
  • Funciones de Ncurses
  • Obtiene los colores de primer plano y fondo de una pareja de colores

ncurses_pair_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pair_content — Obtiene los colores de primer plano y fondo de una pareja de colores

Descripción

ncurses_pair_content ( int $pair , int &$f , int &$b ) : int

Obtiene los colores de primer plano y fondo que constituyen la pareja de colores dada. La capacidad de color del terminal debe ser inicializada con ncurses_start_color() antes de llamar a esta función.

Parámetros

pair

EL númeero de la pareja de colores de la que obtener información.

f

Una referencia para la cual devuelve el color de primer plano de la pareja de colores. La información devuelta será un número de color aludiendo a uno de los colores predefinidos o a un color previamente definido por ncurses_init_color() si el terminal soporta el cambio de color.

b

Una referencia para la cual devuelve el color de fondo de la pareja de colores. La información devuelta será un número de color aludiendo a uno de los colores predefinidos o a un color previamente definido por ncurses_init_color() si el terminal soporta el cambio de color.

Valores devueltos

Devuelve -1 si la función tuvo éxito, y 0 si ncurses o las capacidades de color del terminal no han sido inicializadas.

Ver también

  • ncurses_init_pair() - Definir una pareja de colores
  • ncurses_start_color() - Inicializa la funcionalidad de color


Devuelve el panel encima del panel indicado

  • « ncurses_pair_content
  • ncurses_panel_below »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el panel encima del panel indicado

ncurses_panel_above

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_above — Devuelve el panel encima del panel indicado

Descripción

ncurses_panel_above ( resource $panel ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel

Valores devueltos

Si el panel es null, devuelve el panel al fondo de la pila.


Devuelve el panel por debajo del panel indicado

  • « ncurses_panel_above
  • ncurses_panel_window »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el panel por debajo del panel indicado

ncurses_panel_below

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_below — Devuelve el panel por debajo del panel indicado

Descripción

ncurses_panel_below ( resource $panel ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel

Parámetros

Si el panel no existe, devuelve el panel más arriba en la pila


Devuelve la ventana asociada con el panel

  • « ncurses_panel_below
  • ncurses_pnoutrefresh »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve la ventana asociada con el panel

ncurses_panel_window

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_window — Devuelve la ventana asociada con el panel

Descripción

ncurses_panel_window ( resource $panel ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Copia una región desde un pad a la pantalla virtual

  • « ncurses_panel_window
  • ncurses_prefresh »
  • PHP Manual
  • Funciones de Ncurses
  • Copia una región desde un pad a la pantalla virtual

ncurses_pnoutrefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pnoutrefresh — Copia una región desde un pad a la pantalla virtual

Descripción

ncurses_pnoutrefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol


Copia una región desde un pad a la pantalla virtual

  • « ncurses_pnoutrefresh
  • ncurses_putp »
  • PHP Manual
  • Funciones de Ncurses
  • Copia una región desde un pad a la pantalla virtual

ncurses_prefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_prefresh — Copia una región desde un pad a la pantalla virtual

Descripción

ncurses_prefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol


Aplicar la información de márgenes a la cadena e imprimirla

  • « ncurses_prefresh
  • ncurses_qiflush »
  • PHP Manual
  • Funciones de Ncurses
  • Aplicar la información de márgenes a la cadena e imprimirla

ncurses_putp

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_putp — Aplicar la información de márgenes a la cadena e imprimirla

Descripción

ncurses_putp ( string $text ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

text


Producir volcado en caracteres de señales

  • « ncurses_putp
  • ncurses_raw »
  • PHP Manual
  • Funciones de Ncurses
  • Producir volcado en caracteres de señales

ncurses_qiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_qiflush — Producir volcado en caracteres de señales

Descripción

ncurses_qiflush ( ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Colocar la terminal en modo puro

  • « ncurses_qiflush
  • ncurses_refresh »
  • PHP Manual
  • Funciones de Ncurses
  • Colocar la terminal en modo puro

ncurses_raw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_raw — Colocar la terminal en modo puro

Descripción

ncurses_raw ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Coloca la terminal en modo puro. El modo puro es similar al modo cbreak, en tanto que los caracteres escritos son pasados inmediatamente al programa del usuario. Las diferencias consisten en que, en modo puro, los caracteres de control de interrupción, salida, suspensión y flujo son todos pasados sin ser interpretados, en lugar de generar una señal.

Valores devueltos

Devuelve true si ocurre algún error, o false de lo contrario.

Ver también

  • ncurses_noraw() - Salir del modo puro en la terminal
  • ncurses_cbreak() - Desactivar el búfer de entrada
  • ncurses_nocbreak() - Cambiar la terminal a modo normal (cooked)


Refrescar la pantalla

  • « ncurses_raw
  • ncurses_replace_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Refrescar la pantalla

ncurses_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_refresh — Refrescar la pantalla

Descripción

ncurses_refresh ( int $ch ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ch


Reemplaza la ventana asociada con el panel

  • « ncurses_refresh
  • ncurses_reset_prog_mode »
  • PHP Manual
  • Funciones de Ncurses
  • Reemplaza la ventana asociada con el panel

ncurses_replace_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_replace_panel — Reemplaza la ventana asociada con el panel

Descripción

ncurses_replace_panel ( resource $panel , resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel

window


Restablece el modo de programa guardado por def_prog_mode

  • « ncurses_replace_panel
  • ncurses_reset_shell_mode »
  • PHP Manual
  • Funciones de Ncurses
  • Restablece el modo de programa guardado por def_prog_mode

ncurses_reset_prog_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_prog_mode — Restablece el modo de programa guardado por def_prog_mode

Descripción

ncurses_reset_prog_mode ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Restablece el modo de intérprete de comandos guardado por def_shell_mode

  • « ncurses_reset_prog_mode
  • ncurses_resetty »
  • PHP Manual
  • Funciones de Ncurses
  • Restablece el modo de intérprete de comandos guardado por def_shell_mode

ncurses_reset_shell_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_shell_mode — Restablece el modo de intérprete de comandos guardado por def_shell_mode

Descripción

ncurses_reset_shell_mode ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Restablece el estado guardado de la terminal

  • « ncurses_reset_shell_mode
  • ncurses_savetty »
  • PHP Manual
  • Funciones de Ncurses
  • Restablece el estado guardado de la terminal

ncurses_resetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_resetty — Restablece el estado guardado de la terminal

Descripción

ncurses_resetty ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Recupera el estado de la terminal, el cual fue guardado previamente al llamar ncurses_savetty().

Valores devueltos

Siempre devuelve false.

Ver también

  • ncurses_savetty() - Guarda el estado de la terminal


Guarda el estado de la terminal

  • « ncurses_resetty
  • ncurses_scr_dump »
  • PHP Manual
  • Funciones de Ncurses
  • Guarda el estado de la terminal

ncurses_savetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_savetty — Guarda el estado de la terminal

Descripción

ncurses_savetty ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Guarda el estado actual de la terminal. El estado de terminal guardado puede ser recuperado con la función ncurses_resetty().

Valores devueltos

Siempre devuelve false.

Ver también

  • ncurses_resetty() - Restablece el estado guardado de la terminal


Vuelca el contenido de la pantalla en un archivo

  • « ncurses_savetty
  • ncurses_scr_init »
  • PHP Manual
  • Funciones de Ncurses
  • Vuelca el contenido de la pantalla en un archivo

ncurses_scr_dump

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_dump — Vuelca el contenido de la pantalla en un archivo

Descripción

ncurses_scr_dump ( string $filename ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

filename


Inicializar la pantalla desde un volcado en un archivo

  • « ncurses_scr_dump
  • ncurses_scr_restore »
  • PHP Manual
  • Funciones de Ncurses
  • Inicializar la pantalla desde un volcado en un archivo

ncurses_scr_init

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_init — Inicializar la pantalla desde un volcado en un archivo

Descripción

ncurses_scr_init ( string $filename ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

filename


Recuperar la pantalla desde un volcado en un archivo

  • « ncurses_scr_init
  • ncurses_scr_set »
  • PHP Manual
  • Funciones de Ncurses
  • Recuperar la pantalla desde un volcado en un archivo

ncurses_scr_restore

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_restore — Recuperar la pantalla desde un volcado en un archivo

Descripción

ncurses_scr_restore ( string $filename ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

filename


Heredar la pantalla de un volcado en un archivo

  • « ncurses_scr_restore
  • ncurses_scrl »
  • PHP Manual
  • Funciones de Ncurses
  • Heredar la pantalla de un volcado en un archivo

ncurses_scr_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_set — Heredar la pantalla de un volcado en un archivo

Descripción

ncurses_scr_set ( string $filename ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

filename


Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual

  • « ncurses_scr_set
  • ncurses_show_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual

ncurses_scrl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scrl — Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual

Descripción

ncurses_scrl ( int $count ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

count


Coloca un panel invisible al comienzo de la pila, haciéndola visible

  • « ncurses_scrl
  • ncurses_slk_attr »
  • PHP Manual
  • Funciones de Ncurses
  • Coloca un panel invisible al comienzo de la pila, haciéndola visible

ncurses_show_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_show_panel — Coloca un panel invisible al comienzo de la pila, haciéndola visible

Descripción

ncurses_show_panel ( resource $panel ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Devuelve el atributo de la etiqueta suave de teclado

  • « ncurses_show_panel
  • ncurses_slk_attroff »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el atributo de la etiqueta suave de teclado

ncurses_slk_attr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attr — Devuelve el atributo de la etiqueta suave de teclado

Descripción

ncurses_slk_attr ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve el atributo de la etiqueta suave de teclado actual.

Valores devueltos

El atributo, como un entero.


Deshabilitar los atributos dados para las etiquetas suaves de teclado

  • « ncurses_slk_attr
  • ncurses_slk_attron »
  • PHP Manual
  • Funciones de Ncurses
  • Deshabilitar los atributos dados para las etiquetas suaves de teclado

ncurses_slk_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attroff — Deshabilitar los atributos dados para las etiquetas suaves de teclado

Descripción

ncurses_slk_attroff ( int $intarg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

intarg


Habilitar los atributos dados para las etiquetas suaves de funciones de teclado

  • « ncurses_slk_attroff
  • ncurses_slk_attrset »
  • PHP Manual
  • Funciones de Ncurses
  • Habilitar los atributos dados para las etiquetas suaves de funciones de teclado

ncurses_slk_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attron — Habilitar los atributos dados para las etiquetas suaves de funciones de teclado

Descripción

ncurses_slk_attron ( int $intarg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

intarg


Definir los atributos dados para las etiquetas suaves de funciones de teclado

  • « ncurses_slk_attron
  • ncurses_slk_clear »
  • PHP Manual
  • Funciones de Ncurses
  • Definir los atributos dados para las etiquetas suaves de funciones de teclado

ncurses_slk_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attrset — Definir los atributos dados para las etiquetas suaves de funciones de teclado

Descripción

ncurses_slk_attrset ( int $intarg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

intarg


Limpia las etiquetas suaves de la pantalla

  • « ncurses_slk_attrset
  • ncurses_slk_color »
  • PHP Manual
  • Funciones de Ncurses
  • Limpia las etiquetas suaves de la pantalla

ncurses_slk_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_clear — Limpia las etiquetas suaves de la pantalla

Descripción

ncurses_slk_clear ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

La función ncurses_slk_clear() limpia las etiquetas suaves de teclado de la pantalla.

Valores devueltos

Devuelve true en caso de fallo, o false de lo contrario.


Establece el color para las etiquetas suaves de teclado

  • « ncurses_slk_clear
  • ncurses_slk_init »
  • PHP Manual
  • Funciones de Ncurses
  • Establece el color para las etiquetas suaves de teclado

ncurses_slk_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_color — Establece el color para las etiquetas suaves de teclado

Descripción

ncurses_slk_color ( int $intarg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

intarg


Inicializa las funciones de tecla de etiquetación suave

  • « ncurses_slk_color
  • ncurses_slk_noutrefresh »
  • PHP Manual
  • Funciones de Ncurses
  • Inicializa las funciones de tecla de etiquetación suave

ncurses_slk_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_init — Inicializa las funciones de tecla de etiquetación suave

Descripción

ncurses_slk_init ( int $format ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Inicializa las funciones de tecla de etiquetación suave

Esta función debe ser llamada antes de llamar a ncurses_init() o a ncurses_newwin().

Parámetros

format

Si ncurses_init() utiliza finalmente una línea desde stdscr para emular etiquetas suaves, este parámetro determina cómo las etiquetas están dispuestas en la pantalla.

0 indica una disposición 3-2-3 de las etiquetas, 1 indica una disposición 4-4 y 2 indica el modo PC como 4-4-4, pero además se creará una línea de índice.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Copia las etiquetas suaves de teclado a la pantalla virtual

  • « ncurses_slk_init
  • ncurses_slk_refresh »
  • PHP Manual
  • Funciones de Ncurses
  • Copia las etiquetas suaves de teclado a la pantalla virtual

ncurses_slk_noutrefresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_noutrefresh — Copia las etiquetas suaves de teclado a la pantalla virtual

Descripción

ncurses_slk_noutrefresh ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Copia las etiquetas suaves de teclado a la pantalla

  • « ncurses_slk_noutrefresh
  • ncurses_slk_restore »
  • PHP Manual
  • Funciones de Ncurses
  • Copia las etiquetas suaves de teclado a la pantalla

ncurses_slk_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_refresh — Copia las etiquetas suaves de teclado a la pantalla

Descripción

ncurses_slk_refresh ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Copia etiquetas suaves de teclado desde la pantalla virtual a la pantalla física.


Recupera las etiquetas suaves de teclado

  • « ncurses_slk_refresh
  • ncurses_slk_set »
  • PHP Manual
  • Funciones de Ncurses
  • Recupera las etiquetas suaves de teclado

ncurses_slk_restore

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_restore — Recupera las etiquetas suaves de teclado

Descripción

ncurses_slk_restore ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Recupera las etiquetas suaves de teclado después de que se ha completado un proceso ncurses_slk_clear().


Establece las etiquetas de teclado

  • « ncurses_slk_restore
  • ncurses_slk_touch »
  • PHP Manual
  • Funciones de Ncurses
  • Establece las etiquetas de teclado

ncurses_slk_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_set — Establece las etiquetas de teclado

Descripción

ncurses_slk_set ( int $labelnr , string $label , int $format ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

labelnr

label

format


Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh

  • « ncurses_slk_set
  • ncurses_standend »
  • PHP Manual
  • Funciones de Ncurses
  • Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh

ncurses_slk_touch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_touch — Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh

Descripción

ncurses_slk_touch ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Obliga a que todas las etiquetas suaves sean desplegadas la próxima vez que se realice un llamado a ncurses_slk_noutrefresh().


Dejar de usar el atributo 'standout'

  • « ncurses_slk_touch
  • ncurses_standout »
  • PHP Manual
  • Funciones de Ncurses
  • Dejar de usar el atributo 'standout'

ncurses_standend

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standend — Dejar de usar el atributo 'standout'

Descripción

ncurses_standend ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Comenzar a usar el atributo 'standout'

  • « ncurses_standend
  • ncurses_start_color »
  • PHP Manual
  • Funciones de Ncurses
  • Comenzar a usar el atributo 'standout'

ncurses_standout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standout — Comenzar a usar el atributo 'standout'

Descripción

ncurses_standout ( ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Inicializa la funcionalidad de color

  • « ncurses_standout
  • ncurses_termattrs »
  • PHP Manual
  • Funciones de Ncurses
  • Inicializa la funcionalidad de color

ncurses_start_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_start_color — Inicializa la funcionalidad de color

Descripción

ncurses_start_color ( ) : int

Inicializa la funcionalidad de color en ncurses. Esta función debe ser llamada antes de llamar a cualquier función de manipulación de color y después de llamar a ncurses_init(). Es una buena práctica llamar a esta función justo después de ncurses_init().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve 0 en caso de éxito, o -1 si la tabla de colores no pudo ser asignada o ncurses no fue inicializado.

Ejemplos

Ejemplo #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// Si el terminal soporta colores, inicializar y establecer el color activo
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Escribir una cadena en la ubicación especificada
ncurses_mvaddstr(10, 10, "¡Hola mundo! ¡Amarillo sobre texto azul!");

// Volcar la salida a la pantalla
ncurses_refresh();

ncurses_end();
?>

Ver también

  • ncurses_can_change_color() - Comprobar si las definiciones de color del terminal se pueden cambiar
  • ncurses_has_colors() - Comprueba si el terminal tiene capacidades de color


Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal

  • « ncurses_start_color
  • ncurses_termname »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal

ncurses_termattrs

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termattrs — Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal

Descripción

ncurses_termattrs ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve el nombre (corto) de la terminal

  • « ncurses_termattrs
  • ncurses_timeout »
  • PHP Manual
  • Funciones de Ncurses
  • Devuelve el nombre (corto) de la terminal

ncurses_termname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termname — Devuelve el nombre (corto) de la terminal

Descripción

ncurses_termname ( ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Devuelve el nombre corto de las terminales.

Valores devueltos

Devuelve el nombre corto de la terminal, truncado a 14 caracteres. En caso de fallo, devuelve null.

Ver también

  • ncurses_longname() - Devuelve la descripción de la terminal


Establecer el tiempo de espera para secuencias especiales de teclas

  • « ncurses_termname
  • ncurses_top_panel »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer el tiempo de espera para secuencias especiales de teclas

ncurses_timeout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_timeout — Establecer el tiempo de espera para secuencias especiales de teclas

Descripción

ncurses_timeout ( int $millisec ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

millisec


Mueve un panel visible al tope de la pila

  • « ncurses_timeout
  • ncurses_typeahead »
  • PHP Manual
  • Funciones de Ncurses
  • Mueve un panel visible al tope de la pila

ncurses_top_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_top_panel — Mueve un panel visible al tope de la pila

Descripción

ncurses_top_panel ( resource $panel ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

panel


Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente

  • « ncurses_top_panel
  • ncurses_ungetch »
  • PHP Manual
  • Funciones de Ncurses
  • Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente

ncurses_typeahead

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_typeahead — Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente

Descripción

ncurses_typeahead ( int $fd ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fd


Colocar un caracter de vuelta en la secuencia de entrada

  • « ncurses_typeahead
  • ncurses_ungetmouse »
  • PHP Manual
  • Funciones de Ncurses
  • Colocar un caracter de vuelta en la secuencia de entrada

ncurses_ungetch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetch — Colocar un caracter de vuelta en la secuencia de entrada

Descripción

ncurses_ungetch ( int $keycode ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

keycode


Coloca un evento de mouse en la cola

  • « ncurses_ungetch
  • ncurses_update_panels »
  • PHP Manual
  • Funciones de Ncurses
  • Coloca un evento de mouse en la cola

ncurses_ungetmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetmouse — Coloca un evento de mouse en la cola

Descripción

ncurses_ungetmouse ( array $mevent ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Coloca un evento KEY_MOUSE en la cola de eventos devueltos y asocia con él los datos de estado y coordenadas relativas-a-pantalla de celda de caracter especificadas en evento_mouse.

Parámetros

mevent

Una matriz asociativa especificando las opciones del evento:

  • "id" : Id para distinguir múltiples dispositivos

  • "x" : posición x relativa a la pantalla en celdas de caracter

  • "y" : posición y relativa a la pantalla en celdas de caracter

  • "z" : por el momento sin soporte

  • "mmask" : acción del mouse

Valores devueltos

Devuelve false en caso de éxito, o true de lo contrario.

Ver también

  • ncurses_getmouse() - Lee los eventos del ratón


Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila

  • « ncurses_ungetmouse
  • ncurses_use_default_colors »
  • PHP Manual
  • Funciones de Ncurses
  • Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila

ncurses_update_panels

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_update_panels — Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila

Descripción

ncurses_update_panels ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Asignar los colores predeterminados de la terminal al id de color -1

  • « ncurses_update_panels
  • ncurses_use_env »
  • PHP Manual
  • Funciones de Ncurses
  • Asignar los colores predeterminados de la terminal al id de color -1

ncurses_use_default_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_default_colors — Asignar los colores predeterminados de la terminal al id de color -1

Descripción

ncurses_use_default_colors ( ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Controlar el uso de información del entorno sobre el tamaño de la terminal

  • « ncurses_use_default_colors
  • ncurses_use_extended_names »
  • PHP Manual
  • Funciones de Ncurses
  • Controlar el uso de información del entorno sobre el tamaño de la terminal

ncurses_use_env

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_env — Controlar el uso de información del entorno sobre el tamaño de la terminal

Descripción

ncurses_use_env ( bool $flag ) : void
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

flag


Controlar el uso de nombres extendidos en descripciones de información de terminal

  • « ncurses_use_env
  • ncurses_vidattr »
  • PHP Manual
  • Funciones de Ncurses
  • Controlar el uso de nombres extendidos en descripciones de información de terminal

ncurses_use_extended_names

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_extended_names — Controlar el uso de nombres extendidos en descripciones de información de terminal

Descripción

ncurses_use_extended_names ( bool $flag ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

flag


Desplegar la cadena en la terminal con el atributo de modo de video

  • « ncurses_use_extended_names
  • ncurses_vline »
  • PHP Manual
  • Funciones de Ncurses
  • Desplegar la cadena en la terminal con el atributo de modo de video

ncurses_vidattr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vidattr — Desplegar la cadena en la terminal con el atributo de modo de video

Descripción

ncurses_vidattr ( int $intarg ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

intarg


Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

  • « ncurses_vidattr
  • ncurses_waddch »
  • PHP Manual
  • Funciones de Ncurses
  • Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

ncurses_vline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vline — Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

Descripción

ncurses_vline ( int $charattr , int $n ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

charattr

n


Agrega un caracter en la posición actual de una ventana y avanza el cursor

  • « ncurses_vline
  • ncurses_waddstr »
  • PHP Manual
  • Funciones de Ncurses
  • Agrega un caracter en la posición actual de una ventana y avanza el cursor

ncurses_waddch

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddch — Agrega un caracter en la posición actual de una ventana y avanza el cursor

Descripción

ncurses_waddch ( resource $window , int $ch ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

ch


Imprime un texto en la posición actual de una ventana

  • « ncurses_waddch
  • ncurses_wattroff »
  • PHP Manual
  • Funciones de Ncurses
  • Imprime un texto en la posición actual de una ventana

ncurses_waddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddstr — Imprime un texto en la posición actual de una ventana

Descripción

ncurses_waddstr ( resource $window , string $str , int $n = ? ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

str

n


Deshabilita los atributos para una ventana

  • « ncurses_waddstr
  • ncurses_wattron »
  • PHP Manual
  • Funciones de Ncurses
  • Deshabilita los atributos para una ventana

ncurses_wattroff

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattroff — Deshabilita los atributos para una ventana

Descripción

ncurses_wattroff ( resource $window , int $attrs ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

attrs


Habilita los atributos para una ventana

  • « ncurses_wattroff
  • ncurses_wattrset »
  • PHP Manual
  • Funciones de Ncurses
  • Habilita los atributos para una ventana

ncurses_wattron

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattron — Habilita los atributos para una ventana

Descripción

ncurses_wattron ( resource $window , int $attrs ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

attrs


Establecer los atributos para una ventana

  • « ncurses_wattron
  • ncurses_wborder »
  • PHP Manual
  • Funciones de Ncurses
  • Establecer los atributos para una ventana

ncurses_wattrset

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattrset — Establecer los atributos para una ventana

Descripción

ncurses_wattrset ( resource $window , int $attrs ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

attrs


Dibuja un borde alrededor de la ventana usando caracteres con atributos

  • « ncurses_wattrset
  • ncurses_wclear »
  • PHP Manual
  • Funciones de Ncurses
  • Dibuja un borde alrededor de la ventana usando caracteres con atributos

ncurses_wborder

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wborder — Dibuja un borde alrededor de la ventana usando caracteres con atributos

Descripción

ncurses_wborder ( resource $window , int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Dibuja las líneas y esquinas indicadas alrededor de la window dada.

Use ncurses_border() for borders around the main window.

Parámetros

Cada parámetro espera 0 para dibujar una línea, y 1 para saltarla.

window

La ventana en la cual operar

left

right

top

bottom

tl_corner

Esquina superior izquierda

tr_corner

Esquina superior derecha

bl_corner

Esquina inferior izquierda

br_corner

Esquina inferior derecha

Ver también

  • ncurses_border() - Dibujar un borde alrededor de la pantalla usando caracteres con atributos


Limpia la ventana

  • « ncurses_wborder
  • ncurses_wcolor_set »
  • PHP Manual
  • Funciones de Ncurses
  • Limpia la ventana

ncurses_wclear

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wclear — Limpia la ventana

Descripción

ncurses_wclear ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Establece parejas de colores en la ventana

  • « ncurses_wclear
  • ncurses_werase »
  • PHP Manual
  • Funciones de Ncurses
  • Establece parejas de colores en la ventana

ncurses_wcolor_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wcolor_set — Establece parejas de colores en la ventana

Descripción

ncurses_wcolor_set ( resource $window , int $color_pair ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

color_pair


Eliminar los contenidos de la ventana

  • « ncurses_wcolor_set
  • ncurses_wgetch »
  • PHP Manual
  • Funciones de Ncurses
  • Eliminar los contenidos de la ventana

ncurses_werase

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_werase — Eliminar los contenidos de la ventana

Descripción

ncurses_werase ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Lee un caracter desde el teclado (en la ventana)

  • « ncurses_werase
  • ncurses_whline »
  • PHP Manual
  • Funciones de Ncurses
  • Lee un caracter desde el teclado (en la ventana)

ncurses_wgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wgetch — Lee un caracter desde el teclado (en la ventana)

Descripción

ncurses_wgetch ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres

  • « ncurses_wgetch
  • ncurses_wmouse_trafo »
  • PHP Manual
  • Funciones de Ncurses
  • Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres

ncurses_whline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_whline — Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres

Descripción

ncurses_whline ( resource $window , int $charattr , int $n ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

charattr

n


Transforma coordenadas de ventana/stdscr

  • « ncurses_whline
  • ncurses_wmove »
  • PHP Manual
  • Funciones de Ncurses
  • Transforma coordenadas de ventana/stdscr

ncurses_wmouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmouse_trafo — Transforma coordenadas de ventana/stdscr

Descripción

ncurses_wmouse_trafo ( resource $window , int &$y , int &$x , bool $toscreen ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

x

y

toscreen


Mueve la posición de salida de la ventana

  • « ncurses_wmouse_trafo
  • ncurses_wnoutrefresh »
  • PHP Manual
  • Funciones de Ncurses
  • Mueve la posición de salida de la ventana

ncurses_wmove

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmove — Mueve la posición de salida de la ventana

Descripción

ncurses_wmove ( resource $window , int $y , int $x ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

y

x


Copia la ventana a la pantalla virtual

  • « ncurses_wmove
  • ncurses_wrefresh »
  • PHP Manual
  • Funciones de Ncurses
  • Copia la ventana a la pantalla virtual

ncurses_wnoutrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wnoutrefresh — Copia la ventana a la pantalla virtual

Descripción

ncurses_wnoutrefresh ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Refrescar la ventana en la pantalla de terminal

  • « ncurses_wnoutrefresh
  • ncurses_wstandend »
  • PHP Manual
  • Funciones de Ncurses
  • Refrescar la ventana en la pantalla de terminal

ncurses_wrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wrefresh — Refrescar la ventana en la pantalla de terminal

Descripción

ncurses_wrefresh ( resource $window ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Finaliza el modo standout para una ventana

  • « ncurses_wrefresh
  • ncurses_wstandout »
  • PHP Manual
  • Funciones de Ncurses
  • Finaliza el modo standout para una ventana

ncurses_wstandend

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandend — Finaliza el modo standout para una ventana

Descripción

ncurses_wstandend ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Ingresar a modo standout en una ventana

  • « ncurses_wstandend
  • ncurses_wvline »
  • PHP Manual
  • Funciones de Ncurses
  • Ingresar a modo standout en una ventana

ncurses_wstandout

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandout — Ingresar a modo standout en una ventana

Descripción

ncurses_wstandout ( resource $window ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window


Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

  • « ncurses_wstandout
  • Readline »
  • PHP Manual
  • Funciones de Ncurses
  • Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

ncurses_wvline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wvline — Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres

Descripción

ncurses_wvline ( resource $window , int $charattr , int $n ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

window

charattr

n


GNU Readline

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones Readline
    • readline_add_history — Agrega una línea a la historia
    • readline_callback_handler_install — Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente
    • readline_callback_handler_remove — Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal
    • readline_callback_read_char — Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida
    • readline_clear_history — Limpia el historial
    • readline_completion_function — Registra una función de autocompletado
    • readline_info — Obtiene/Modifica variables internas a readline
    • readline_list_history — Obtener el historial
    • readline_on_new_line — Informar a readline que el cursor se ha movido a una nueva línea
    • readline_read_history — Lee el historial
    • readline_redisplay — Redibuja la vista
    • readline_write_history — Escribe el historial
    • readline — Lee una línea


Introducción

Las funciones de readline implementan una interfaz a la biblioteca GNU Readline. Estas funciones proporcionan líneas de comando editables. Un ejemplo es Bash, que permite utilizar las teclas de dirección para insertar caracteres o desplazarse a través del historial de comandos. Debido a la naturaleza interactiva de esta biblioteca, será de poca utilidad para la creación de aplicaciones Web, pero puede ser útil cuando se escriben scripts utilizando la línea de comandos.

A partir de PHP 7.1.0 esta extensión está soportada en Windows.

Precaución

¡La extensión de la línea de lectura no es segura para el hilo! Por lo tanto, se desaconseja su uso con cualquier SAPI verdaderamente segura para los hilos (como el Apache mod_winnt).


Requerimientos

Para usar las funciones readline, es necesario instalar libreadline. Se puede encontrar libreadline en la página principal del proyecto GNU Readline, en » http://cnswww.cns.cwru.edu/~chet/readline/rltop.html. Este proyecto es administrado por Chet Ramey, quien es también el autor de Bash.

También puede utilizar estas funciones con la libreria libedit, un reemplazo no-GPL para la biblioteca readline. La biblioteca libedit tiene licencia BSD y está disponible para su descarga desde » http://www.thrysoee.dk/editline/.


Instalación

Para utilizar estas funciones, debe compilar la versión CGI o CLI de PHP con soporte para readline. Es necesario configurar PHP --with-readline[=DIR]. Si desea utilizar el reemplazo de readline libedit, es necesario configurar PHP --with-libedit[=DIR].

En Windows esta extensión está disponible por defecto a partir de PHP 7.1.0.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración Readline
Nombre | Por defecto | Cambiable | Historial de cambios
cli.pager | "" | PHP_INI_ALL | Disponible desde PHP 5.4.0.
cli.prompt | "\\b \\> " | PHP_INI_ALL | Disponible desde PHP 5.4.0.

He aquí una breve explicación de las directivas de configuración.

cli.pager string

Herramienta externa para mostrar la salida de la línea de comandos.

cli.prompt string

Véase Línea de Comandos.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

READLINE_LIB (string)
La biblioteca que se utiliza para el soporte de la línea de lectura; actualmente readline o libedit. Disponible a partir de PHP 5.5.0.


Funciones Readline

Tabla de contenidos

  • readline_add_history — Agrega una línea a la historia
  • readline_callback_handler_install — Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente
  • readline_callback_handler_remove — Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal
  • readline_callback_read_char — Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida
  • readline_clear_history — Limpia el historial
  • readline_completion_function — Registra una función de autocompletado
  • readline_info — Obtiene/Modifica variables internas a readline
  • readline_list_history — Obtener el historial
  • readline_on_new_line — Informar a readline que el cursor se ha movido a una nueva línea
  • readline_read_history — Lee el historial
  • readline_redisplay — Redibuja la vista
  • readline_write_history — Escribe el historial
  • readline — Lee una línea


Agrega una línea a la historia

  • « Funciones Readline
  • readline_callback_handler_install »
  • PHP Manual
  • Funciones Readline
  • Agrega una línea a la historia

readline_add_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_add_history — Agrega una línea a la historia

Descripción

readline_add_history ( string $line ) : bool

Esta función agrega una línea a la historia de la línea de comandos.

Parámetros

line

La línea a ser agregada en la historia.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente

  • « readline_add_history
  • readline_callback_handler_remove »
  • PHP Manual
  • Funciones Readline
  • Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente

readline_callback_handler_install

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_handler_install — Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente

Descripción

readline_callback_handler_install ( string $prompt , callable $callback ) : bool

Configura una interfaz de llamada readline y luego imprime mensaje, luego de lo cual retorna. Si llamas a esta función más de una vez sin eliminar la interfaz de llamada anterior automaticamente reemplazará la versión anterior.

La interfaz de llamada es útil cuando se combina con stream_select() ya que permite la intercalación de IO (entrada/salida) y entrada del usuario, a diferencia de readline().

Parámetros

mensaje

El mensaje a imprimir.

funcion

La función funcion recibe un parámetro; la entrada del usuario retornada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de interfaz de llamada readline

<?php
function rl_callback($ret)
{
    global $c, $prompting;

    echo "Has ingresado: $ret\n";
    $c++;

    if ($c > 10) {
        $prompting = false;
        readline_callback_handler_remove();
    } else {
        readline_callback_handler_install("[$c] Ingresa algo: ", 'rl_callback');
    }
}

$c = 1;
$prompting = true;

readline_callback_handler_install("[$c] Ingresa algo: ", 'rl_callback');

while ($prompting) {
    $w = NULL;
    $e = NULL;
    $n = stream_select($r = array(STDIN), $w, $e, null);
    if ($n && in_array(STDIN, $r)) {
        // lee un carácter, llama a la funcion cuando una nueva línea es ingresada
        readline_callback_read_char();
    }
}

echo "Mensaje deshabilitado. Todo hecho.\n";
?>

Ver también

  • readline_callback_handler_remove() - Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal
  • readline_callback_read_char() - Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida
  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec


Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal

  • « readline_callback_handler_install
  • readline_callback_read_char »
  • PHP Manual
  • Funciones Readline
  • Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal

readline_callback_handler_remove

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_handler_remove — Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal

Descripción

readline_callback_handler_remove ( ) : bool

Elimina una interfaz de llamada configurada anteriormente y restaura la configuración de terminal.

Valores devueltos

Retorna true si una interfaz de llamada instalada anteriormente fue eliminada, o false si no pudo hallarse una.

Ejemplos

Ver readline_callback_handler_install() para un ejemplo sobre como utilizar la interfaz de llamada de readline.

Ver también

  • readline_callback_handler_install() - Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente
  • readline_callback_read_char() - Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida


Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida

  • « readline_callback_handler_remove
  • readline_clear_history »
  • PHP Manual
  • Funciones Readline
  • Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida

readline_callback_read_char

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_read_char — Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida

Descripción

readline_callback_read_char ( ) : void

Lee un carácter del usuario. Cuando una línea es recibida, esta función informa a la interfaz de llamada de readline utilizando readline_callback_handler_install(), especificando así que hay una línea lista como entrada.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Veáse readline_callback_handler_install() para un ejemplo sobre cómo utilizar la interfaz de llamada de readline.

Ver también

  • readline_callback_handler_install() - Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente
  • readline_callback_handler_remove() - Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal


Limpia el historial

  • « readline_callback_read_char
  • readline_completion_function »
  • PHP Manual
  • Funciones Readline
  • Limpia el historial

readline_clear_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_clear_history — Limpia el historial

Descripción

readline_clear_history ( ) : bool

Esta función limpia completamente el historial de línea de comandos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Registra una función de autocompletado

  • « readline_clear_history
  • readline_info »
  • PHP Manual
  • Funciones Readline
  • Registra una función de autocompletado

readline_completion_function

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_completion_function — Registra una función de autocompletado

Descripción

readline_completion_function ( callable $function ) : bool

Esta función reistra una función para ser utilizada para autocompletar comandos. Es la misma funcionalidad que obtendrías si presionas la tecla Tab mientras escribes un comando en Bash.

Parámetros

funcion

El nombre de una función que acepta una línea de comandos parcial y devuelve un array con las entradas coincidentes.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtiene/Modifica variables internas a readline

  • « readline_completion_function
  • readline_list_history »
  • PHP Manual
  • Funciones Readline
  • Obtiene/Modifica variables internas a readline

readline_info

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_info — Obtiene/Modifica variables internas a readline

Descripción

readline_info ( string $varname = ? , string $newvalue = ? ) : mixed

Obtiene o modifica numerosas variables internas de readline.

Parámetros

variable

Un nombre de variable.

valor

Si se especifica, este será el nuevo valor de la variable.

Valores devueltos

Si esta función es llamada sin parámetros, retornará un array de valores para todos los usos de readline. Los elementos estarán indexados por los siguientes valores: done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name, y terminal_name.

Si es llamado por uno o dos parámetros, el valor anterior de la variable es retornado.


Obtener el historial

  • « readline_info
  • readline_on_new_line »
  • PHP Manual
  • Funciones Readline
  • Obtener el historial

readline_list_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_list_history — Obtener el historial

Descripción

readline_list_history ( ) : array

Obtiene el historial completo de comandos.

Valores devueltos

Retorna un array correspondiente al historial completo de la línea de comandos. Los elementos son indexados por enteros, comenzando desde cero.


Informar a readline que el cursor se ha movido a una nueva línea

  • « readline_list_history
  • readline_read_history »
  • PHP Manual
  • Funciones Readline
  • Informar a readline que el cursor se ha movido a una nueva línea

readline_on_new_line

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_on_new_line — Informar a readline que el cursor se ha movido a una nueva línea

Descripción

readline_on_new_line ( ) : void

Le informa a readline que el cursor se ha movido a una nueva línea.

Valores devueltos

No devuelve ningún valor.


Lee el historial

  • « readline_on_new_line
  • readline_redisplay »
  • PHP Manual
  • Funciones Readline
  • Lee el historial

readline_read_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_read_history — Lee el historial

Descripción

readline_read_history ( string $filename = ? ) : bool

Esta función lee el historial de comandos desde un archivo.

Parámetros

archivo

Ubicación del archivo que contiene el historial de comandos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Redibuja la vista

  • « readline_read_history
  • readline_write_history »
  • PHP Manual
  • Funciones Readline
  • Redibuja la vista

readline_redisplay

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_redisplay — Redibuja la vista

Descripción

readline_redisplay ( ) : void

Redibuja readline para volver a dibujar la vista.

Valores devueltos

No devuelve ningún valor.


Escribe el historial

  • « readline_redisplay
  • readline »
  • PHP Manual
  • Funciones Readline
  • Escribe el historial

readline_write_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_write_history — Escribe el historial

Descripción

readline_write_history ( string $filename = ? ) : bool

Esta función escribe el historial de comandos en un archivo.

Parámetros

archivo

Ubicación del archivo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Lee una línea

  • « readline_write_history
  • Extensiones de compresión y archivos »
  • PHP Manual
  • Funciones Readline
  • Lee una línea

readline

(PHP 4, PHP 5, PHP 7, PHP 8)

readline — Lee una línea

Descripción

readline ( string $prompt = null ) : string

Lee una sola línea del usuario. Debe agregar esta línea al historial utilizando readline_add_history().

Parámetros

mensaje

Puedes especificar un mensaje que se muestra al usuario.

Valores devueltos

Devuelve un único string del usuario. Esta línea retornada tiene el avance de línea al final eliminado.

Ejemplos

Ejemplo #1 Ejemplo de readline()

<?php
//obtener 3 comandos del usuario
for ($i=0; $i < 3; $i++) {
        $linea = readline("Comando: ");
        readline_add_history($linea);
}

//mostrar historial
print_r(readline_list_history());

//mostrar variables
print_r(readline_info());
?>


Extensiones de compresión y archivos

  • Bzip2
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Bzip2
  • LZF
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones LZF
  • Phar
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Utilizar Archivos Phar
    • Creación de archivos Phar
    • ¿Qué hace de un phar un phar y no un tar o un zip?
    • Phar — La clase Phar
    • PharData — La clase PharData
    • PharFileInfo — La clase PharFileInfo
    • PharException — La clase PharException
  • Rar — Archivos Rar
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones Rar
    • RarArchive — La clase RarArchive
    • RarEntry — La clase RarEntry
    • RarException — La clase RarException
  • Zip
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • ZipArchive — The ZipArchive class
    • Funciones Zip
  • Zlib — Compresión Zlib
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Zlib
    • DeflateContext — The DeflateContext class
    • InflateContext — The InflateContext class


Bzip2

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Bzip2
    • bzclose — Cierra un fichero bzip2
    • bzcompress — Comprime una cadena en datos codificados en bzip2
    • bzdecompress — Descomprime datos codificados con bzip2
    • bzerrno — Devuelve el número de erro de bzip2
    • bzerror — Devuelve el número de error y la cadena del error de bzip2 en un array
    • bzerrstr — Devuelve una cadena de error de bzip2
    • bzflush — Fuerza la escritura de todos los datos del búfer
    • bzopen — Abre un fichero comprimido con bzip2
    • bzread — Lectura segura de ficheros bzip2
    • bzwrite — Escribe en un fichero bzip2 de forma segura binariamente


Introducción

Las funciones de bzip2 se utilizan para leer y escribir ficheros comprimidos con bzip2 (.bz2) de forma transparente.


Requerimientos

Este módulo usa las funciones de la librería » bzip2 por Julian Seward. Este módulo requiere bzip2/libbzip2 version >= 1.0.x.


Instalación

El soporte de Bzip2 en PHP no está activado por defecto. Se necesita usar la opción de configuración --with-bz2[=DIR] al compilar PHP para activar soporte de bzip2.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un tipo de recurso: apunta a un archivo identificando el fichero bz2 a trabajar.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Bzip2
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Este ejemplo abre un fichero temporal y escribe una cadena de prueba en el, muestra el contenido del fichero.

Ejemplo #1 Pequeño ejemplo de bzip2

<?php

$filename = "/tmp/testfile.bz2";
$str = "Esto es una cadena de prueba.\n";

// Abriendo fichero para escribir
$bz = bzopen($filename, "w");

// escribe la cadena en el fichero
bzwrite($bz, $str);

// cierra el fichero
bzclose($bz);

// abre el fichero para escritura
$bz = bzopen($filename, "r");

// lee 10 caracteres
echo bzread($bz, 10);

// muestra salida hasta el final del fichero (o los siguientes 1024 caracteres) y lo cierra.
echo bzread($bz);

bzclose($bz);

?>


Funciones de Bzip2

Tabla de contenidos

  • bzclose — Cierra un fichero bzip2
  • bzcompress — Comprime una cadena en datos codificados en bzip2
  • bzdecompress — Descomprime datos codificados con bzip2
  • bzerrno — Devuelve el número de erro de bzip2
  • bzerror — Devuelve el número de error y la cadena del error de bzip2 en un array
  • bzerrstr — Devuelve una cadena de error de bzip2
  • bzflush — Fuerza la escritura de todos los datos del búfer
  • bzopen — Abre un fichero comprimido con bzip2
  • bzread — Lectura segura de ficheros bzip2
  • bzwrite — Escribe en un fichero bzip2 de forma segura binariamente


Cierra un fichero bzip2

  • « Funciones de Bzip2
  • bzcompress »
  • PHP Manual
  • Funciones de Bzip2
  • Cierra un fichero bzip2

bzclose

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzclose — Cierra un fichero bzip2

Descripción

bzclose ( resource $bz ) : bool

Cierra el dado puntero del fichero bzip2.

Parámetros

bz

El puntero del fichero. Debe ser un puntero válido a un fichero abierto con bzopen() satisfactoriamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • bzopen() - Abre un fichero comprimido con bzip2


Comprime una cadena en datos codificados en bzip2

  • « bzclose
  • bzdecompress »
  • PHP Manual
  • Funciones de Bzip2
  • Comprime una cadena en datos codificados en bzip2

bzcompress

(No hay información de versión disponible, podría estar únicamente en Git)

bzcompress — Comprime una cadena en datos codificados en bzip2

Descripción

bzcompress ( string $source , int $blocksize = 4 , int $workfactor = 0 ) : mixed

bzcompress() comprime la cadena dada y la devuelve como datos codificados con bzip2.

Parámetros

source

La cadena a comprimir.

blocksize

Especifica el blocksize usado durante la compresión y debería ser un número entre 1 y 9 siendo 9 la máxima compresión, pero también utiliza más recursos.

workfactor

Controla como se comportan las fases de compresión cuando se presenta en el peor de los casos, datos que se repiten continuamente. El valor puede estar entre 0 y 250 siendo 0 un caso especial.

Independientemente de workfactor, el valor generado de salida es el mismo.

Valores devueltos

La cadena comprimida, o el número de error en caso de error.

Ejemplos

Ejemplo #1 Comprimiendo datos

<?php
$str = "sample data";
$bzstr = bzcompress($str, 9);
echo $bzstr;
?>

Ver también

  • bzdecompress() - Descomprime datos codificados con bzip2


Descomprime datos codificados con bzip2

  • « bzcompress
  • bzerrno »
  • PHP Manual
  • Funciones de Bzip2
  • Descomprime datos codificados con bzip2

bzdecompress

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzdecompress — Descomprime datos codificados con bzip2

Descripción

bzdecompress ( string $source , int $small = 0 ) : mixed

bzdecompress() descomprime el string pasado por parámetro que contiene los datos codificados en bzip2.

Parámetros

source

String a descomprimir.

small

Si es true, se usará un algoritmo de descompresión alternativo que utiliza menos memoria (disminuye el requisito máximo de memoria a entorno a 2300K) pero por otra parte es la mitad de lento aproximadamente.

Consulte la » documentación de bzip2 para más información sobre este comportamiento.

Valores devueltos

El string descromprimido, o el número de error en caso de error.

Ejemplos

Ejemplo #1 Descompresión de un String

<?php
$start_str = "This is not an honest face?";
$bzstr = bzcompress($start_str);

echo "String Comprimido: ";
echo $bzstr;
echo "\n<br />\n";

$str = bzdecompress($bzstr);
echo "String Descomprimido: ";
echo $str;
echo "\n<br />\n";
?>

Ver también

  • bzcompress() - Comprime una cadena en datos codificados en bzip2


Devuelve el número de erro de bzip2

  • « bzdecompress
  • bzerror »
  • PHP Manual
  • Funciones de Bzip2
  • Devuelve el número de erro de bzip2

bzerrno

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerrno — Devuelve el número de erro de bzip2

Descripción

bzerrno ( resource $bz ) : int

Devuelve el número de error de cualquier error bzip2 devuelto por el puntero del fichero dado.

Parámetros

bz

El puntero del fichero. Debe ser un puntero a un fichero abierto con bzopen() satisfactoriamente.

Valores devueltos

Devuelve el número de error como entero.

Ver también

  • bzerror() - Devuelve el número de error y la cadena del error de bzip2 en un array
  • bzerrstr() - Devuelve una cadena de error de bzip2


Devuelve el número de error y la cadena del error de bzip2 en un array

  • « bzerrno
  • bzerrstr »
  • PHP Manual
  • Funciones de Bzip2
  • Devuelve el número de error y la cadena del error de bzip2 en un array

bzerror

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerror — Devuelve el número de error y la cadena del error de bzip2 en un array

Descripción

bzerror ( resource $bz ) : array

Devuelve el número de error y la cadena de error de cualquier error bzip2 devuelto por el puntero del fichero dado.

Parámetros

bz

El puntero del fichero. Debe ser un puntero a un fichero abierto con bzopen() satisfactoriamente.

Valores devueltos

Devuelve un array asociativo, con el código de error en la entrada errno y el mensaje de error en la entrada errstr.

Ejemplos

Ejemplo #1 Ejemplo de bzerror()

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

Ver también

  • bzerrno() - Devuelve el número de erro de bzip2
  • bzerrstr() - Devuelve una cadena de error de bzip2


Devuelve una cadena de error de bzip2

  • « bzerror
  • bzflush »
  • PHP Manual
  • Funciones de Bzip2
  • Devuelve una cadena de error de bzip2

bzerrstr

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerrstr — Devuelve una cadena de error de bzip2

Descripción

bzerrstr ( resource $bz ) : string

Obtiene la cadena de error de cualquier error bzip2 devuelto por el puntero dado.

Parámetros

bz

El puntero del fichero. Debe ser un puntero a un fichero abierto con bzopen() satisfactoriamente.

Valores devueltos

Devuelve una cadena que contiene el mensaje de error.

Ver también

  • bzerrno() - Devuelve el número de erro de bzip2
  • bzerror() - Devuelve el número de error y la cadena del error de bzip2 en un array


Fuerza la escritura de todos los datos del búfer

  • « bzerrstr
  • bzopen »
  • PHP Manual
  • Funciones de Bzip2
  • Fuerza la escritura de todos los datos del búfer

bzflush

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzflush — Fuerza la escritura de todos los datos del búfer

Descripción

bzflush ( resource $bz ) : bool

Fuerza la escritura de todos los datos del búfer bzip2 para el puntero del fichero bz.

Parámetros

bz

El puntero del fichero. Debe ser un puntero a un fichero abierto con bzopen() satisfactoriamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • bzread() - Lectura segura de ficheros bzip2
  • bzwrite() - Escribe en un fichero bzip2 de forma segura binariamente


Abre un fichero comprimido con bzip2

  • « bzflush
  • bzread »
  • PHP Manual
  • Funciones de Bzip2
  • Abre un fichero comprimido con bzip2

bzopen

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzopen — Abre un fichero comprimido con bzip2

Descripción

bzopen ( string $filename , string $mode ) : resource

bzopen() abre un fichero bzip2 (.bz2) para lectura o escritura.

Parámetros

filename

El nombre del fichero a abrir, o un recurso de flujo existente.

mode

Similar a la función fopen(), solamente 'r' (lectura) y 'w' (escritura) están soportados. Todo lo demás hará que bzopen devuelva false.

Valores devueltos

Si al abrir el fichero se produce un error, bzopen() devolverá false, en caso contrario devolverá el puntero del nuevo fichero abierto.

Ejemplos

Ejemplo #1 Ejemplo de bzopen()

<?php

$file = "/tmp/foo.bz2";
$bz = bzopen($file, "r") or die("No se pudo abrir el fichero $file para lectura");

bzclose($bz);

?>

Ver también

  • bzclose() - Cierra un fichero bzip2


Lectura segura de ficheros bzip2

  • « bzopen
  • bzwrite »
  • PHP Manual
  • Funciones de Bzip2
  • Lectura segura de ficheros bzip2

bzread

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzread — Lectura segura de ficheros bzip2

Descripción

bzread ( resource $bz , int $length = 1024 ) : string

bzread() lee del puntero de fichero bzip2 pasado como parámetro.

La lectura finaliza una vez que se han leído length bytes (descomprimidos) o cuando se alcanza EOF, lo primero que suceda.

Parámetros

bz

El puntero al fichero. Tiene que ser válido y debe apuntar a un fichero que se haya abierto con éxito con bzopen().

length

Si no se especifica, bzread() leerá bloques de 1024 bytes (descomprimidos) al momento. Un máximo de 8192 bytes descomprimidos serán leídos.

Valores devueltos

Devuelve la información descomprimida, o false en caso de error.

Ejemplos

Ejemplo #1 ejemplo de bzread()

<?php

$file = "/tmp/foo.bz2";
$bz = bzopen($file, "r") or die("No se ha podido abrir $file");

$decompressed_file = '';
while (!feof($bz)) {
  $decompressed_file .= bzread($bz, 4096);
}
bzclose($bz);

echo "El contenido de $file es: <br />\n";
echo $decompressed_file;

?>

Ver también

  • bzwrite() - Escribe en un fichero bzip2 de forma segura binariamente
  • feof() - Comprueba si el puntero a un archivo está al final del archivo
  • bzopen() - Abre un fichero comprimido con bzip2


Escribe en un fichero bzip2 de forma segura binariamente

  • « bzread
  • LZF »
  • PHP Manual
  • Funciones de Bzip2
  • Escribe en un fichero bzip2 de forma segura binariamente

bzwrite

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzwrite — Escribe en un fichero bzip2 de forma segura binariamente

Descripción

bzwrite ( resource $bz , string $data , int $length = ? ) : int

bzwrite() escribe una cadena en el fichero gzip2 dado.

Parámetros

bz

El puntero del fichero. Debe apuntar a un fichero abierto satisfactoriamente con bzopen().

data

Los datos a escribir.

length

Si se proporciona, la escritura terminará después de que el length (no comprimido) en bytes hayan sido escritos o se haya llegado al final de data, lo que llegue primero.

Valores devueltos

Devuelve el número de bytes escritos, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de bzwrite()

<?php
$str = "uncompressed data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

Ver también

  • bzread() - Lectura segura de ficheros bzip2
  • bzopen() - Abre un fichero comprimido con bzip2


LZF

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones LZF
    • lzf_compress — Compresión LZF
    • lzf_decompress — Descompresión LZF
    • lzf_optimized_for — Determina para qué fue optimizada la extensión LZF


Introducción

LZF es un algoritmo de compresión muy rápido, ideal para ahorrar espacio con solamente un ligero costo de velocidad. Puede optimizarse para velocidad o espacio a la hora de compilar. Esta extensión utiliza la librería » liblzf por Marc Lehmann para sus operaciones.


Instalación

Esta extensión » PECL no se distribuye con PHP. Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/lzf.

Pata utilizar estas funciones se debe compilar PHP con soporte para lzf empleando la opción de configuración --with-lzf[=DIR]. También se puede pasar --enable-lzf-better-compression para optimizar LZF para espacio en vez de para velocidad.

Los usuarios de Windows habilitarán php_lzf.dll dentro de php.ini para utilizar estas funciones. Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Tipos de recursos
  • Funciones LZF »
  • PHP Manual
  • LZF
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones LZF

Tabla de contenidos

  • lzf_compress — Compresión LZF
  • lzf_decompress — Descompresión LZF
  • lzf_optimized_for — Determina para qué fue optimizada la extensión LZF


Compresión LZF

  • « Funciones LZF
  • lzf_decompress »
  • PHP Manual
  • Funciones LZF
  • Compresión LZF

lzf_compress

(PECL lzf >= 0.1.0)

lzf_compress — Compresión LZF

Descripción

lzf_compress ( string $data ) : string

lzf_compress() comprime el string data dado utilizando codificación LZF.

Parámetros

data

El string a comprimir.

Valores devueltos

Devuelve los datos comprimidos o false si ocurrió un error.

Ver también

  • lzf_decompress() - Descompresión LZF


Descompresión LZF

  • « lzf_compress
  • lzf_optimized_for »
  • PHP Manual
  • Funciones LZF
  • Descompresión LZF

lzf_decompress

(PECL lzf >= 0.1.0)

lzf_decompress — Descompresión LZF

Descripción

lzf_decompress ( string $data ) : string

lzf_compress() descomprime la cadena data dada que contiene los datos codificados en lzf.

Parámetros

data

La cadena comprimida.

Valores devueltos

Devuelve los datos descomprimidos o false si ocurrió un error.

Ver también

  • lzf_compress() - Compresión LZF


Determina para qué fue optimizada la extensión LZF

  • « lzf_decompress
  • Phar »
  • PHP Manual
  • Funciones LZF
  • Determina para qué fue optimizada la extensión LZF

lzf_optimized_for

(PECL lzf >= 1.0.0)

lzf_optimized_for — Determina para qué fue optimizada la extensión LZF

Descripción

lzf_optimized_for ( ) : int

Determina para qué fue optimizada la extensión LZF durante la compilación.

Valores devueltos

Devuelve 1 si LZF fue optimizada para velocidad, 0 para compresión.


Phar

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Utilizar Archivos Phar
    • Utilizar Archivos Phar: Introduction
    • Utilizar Archivos Phar: la envoltura de flujos phar
    • Utilizar Archivos Phar: las clases Phar y PharData
  • Creación de archivos Phar
    • Creación de archivos Phar: Introducción
  • ¿Qué hace de un phar un phar y no un tar o un zip?
    • Ingredientes de todos los archivos Phar, independientes del formato de fichero
    • Rutina de interoperabilidad del fichero Phar
    • Comparación cara a cara de Phar, Tar y Zip
    • Archivos phar basados en tar
    • Archivos phar basados en zip
    • El Formato de Fichero Phar
    • Banderas mapeadas en bit globales de Phar
    • Definición de la entrada de fichero del manifiesto de Phar
    • Formato de la firma de Phar
  • Phar — La clase Phar
    • Phar::addEmptyDir — Añadir un directorio vacío al archvo phar
    • Phar::addFile — Añadir un fichero desde el sistema de ficheros al archivo phar
    • Phar::addFromString — Añadir un fichero desde un string al archivo phar
    • Phar::apiVersion — Devolver la versión de la API
    • Phar::buildFromDirectory — Construir un archivo phar desde los ficheros de un directorio
    • Phar::buildFromIterator — Construir un archivo phar desde un iterador
    • Phar::canCompress — Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
    • Phar::canWrite — Devolver si la extensión phar soporta la escritura y creación de archivos phar
    • Phar::compress — Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
    • Phar::compressFiles — Comprime todos los ficheros del archivo Phar actual
    • Phar::__construct — Construir un objeto de archivo Phar
    • Phar::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable
    • Phar::convertToExecutable — Convertir un archivo phar en otro formato de archivo phar ejecutable
    • Phar::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
    • Phar::count — Devuelve el número de entradas (ficheros) en el archivo Phar
    • Phar::createDefaultStub — Crear una rutina de interoperabilidad específica del formato de fichero phar
    • Phar::decompress — Descomprimir un archivo Phar entero
    • Phar::decompressFiles — Descomprimir todos los ficheros del archivo Phar actual
    • Phar::delMetadata — Eliminar la metainformación global del phar
    • Phar::delete — Borrar un fichero dentro de un archivo phar
    • Phar::extractTo — Extraer el contenido de un archivo phar a un directorio
    • Phar::getAlias — Get the alias for Phar
    • Phar::getMetadata — Devolver la metainformación de un archivo phar
    • Phar::getModified — Devolver si el phar fue modificado
    • Phar::getPath — Get the real path to the Phar archive on disk
    • Phar::getSignature — Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar
    • Phar::getStub — Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
    • Phar::getSupportedCompression — Devolver un array de los algoritmos de compresión soportados
    • Phar::getSupportedSignatures — Devolver un array con los tipos de firmas soportados
    • Phar::getVersion — Devolver información de la versión del archivo Phar
    • Phar::hasMetadata — Devolver si el phar tiene metainformación global
    • Phar::interceptFileFuncs — Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas
    • Phar::isBuffering — Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco
    • Phar::isCompressed — Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
    • Phar::isFileFormat — Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro
    • Phar::isValidPharFilename — Devolver si el nombre de fichero dado es un nombre de fichero phar válido
    • Phar::isWritable — Devolver si el archivo phar se puede modificar
    • Phar::loadPhar — Cargar cualquier archivo phar con un alias
    • Phar::mapPhar — Leer el fichero (un phar) que está en ejecución y registrar su manifiesto
    • Phar::mount — Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar
    • Phar::mungServer — Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución
    • Phar::offsetExists — Determina si un fichero existe en un phar
    • Phar::offsetGet — Obtener un objeto de la clase PharFileInfo para un fichero específico
    • Phar::offsetSet — Establecer el contenido de un fichero interno a aquel de un fichero externo
    • Phar::offsetUnset — Eliminar un fichero de un phar
    • Phar::running — Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución
    • Phar::setAlias — Establecer el alias para un archivo Phar
    • Phar::setDefaultStub — Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado
    • Phar::setMetadata — Establecer la metainformación de un archivo phar
    • Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo
    • Phar::setStub — Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
    • Phar::startBuffering — Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco
    • Phar::stopBuffering — Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco
    • Phar::unlinkArchive — Elimiar completamente un archivo phar del disco y de la memoria
    • Phar::webPhar — mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web
  • PharData — La clase PharData
    • PharData::addEmptyDir — Añadir un directorio vacío al archivo tar/zip
    • PharData::addFile — Añadir un fichero desde el sistema de ficheros al archivo tar/zip
    • PharData::addFromString — Añadir un fichero desde el sistema de ficheros al archivo tar/zip
    • PharData::buildFromDirectory — Construir un archivo tar/zip desde los ficheros de un directorio
    • PharData::buildFromIterator — Construir un archivo tar o zip desde un iterador
    • PharData::compress — Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
    • PharData::compressFiles — Comprime todos los ficheros del archivo tar/zip actual
    • PharData::__construct — Construir un objeto de archivo tar o zip no ejecutable
    • PharData::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable
    • PharData::convertToExecutable — Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable
    • PharData::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
    • PharData::decompress — Descomprimir un archivo Phar entero
    • PharData::decompressFiles — Descomprimir todos los ficheros del archivo zip actual
    • PharData::delMetadata — Eliminar la metainformación global de un archivo zip
    • PharData::delete — Borrar un fichero dentro de un archivo tar/zip
    • PharData::extractTo — Extraer el contenido de un archivo tar/zip a un directorio
    • PharData::isWritable — Devolver si el archivo tar/zip se puede modificar
    • PharData::offsetSet — Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos
    • PharData::offsetUnset — Eliminar un ficerho de un archivo tar/zip
    • PharData::setAlias — función sin sentido (Phar::setAlias no es válido para PharData)
    • PharData::setDefaultStub — función sin sentido (Phar::setStub no es válido para PharData)
    • Phar::setMetadata — Establecer la metainformación de un archivo phar
    • Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo
    • PharData::setStub — función sin sentido (Phar::setStub no es válido para PharData)
  • PharFileInfo — La clase PharFileInfo
    • PharFileInfo::chmod — Esteblecer los bits de permiso específicos del fichero
    • PharFileInfo::compress — Comprimir la entrada del Phar actual con la compresión zlib o bzip2
    • PharFileInfo::__construct — Construir un objeto de entrada Phar
    • PharFileInfo::decompress — Descomprimir la entrada Phar actual dentro del phar
    • PharFileInfo::delMetadata — Eliminar la metainformación de una entrada
    • PharFileInfo::getCRC32 — Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado
    • PharFileInfo::getCompressedSize — Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
    • PharFileInfo::getContent — Get the complete file contents of the entry
    • PharFileInfo::getMetadata — Devolver la metainformación específica de un fichero almacenada con un fichero
    • PharFileInfo::getPharFlags — Devolver las banderas de una entrada de fichero
    • PharFileInfo::hasMetadata — Devolver la metainformación de una entrada
    • PharFileInfo::isCRCChecked — Devolver si la entrada de fichero tiene su CRC verificada
    • PharFileInfo::isCompressed — Devolver si la entrada está comprimida
    • PharFileInfo::setMetadata — Establecer la metainformación específica de un fichero almacenda con un fichero
  • PharException — La clase PharException
    • PharException — La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch


Introducción

La extensión phar proporciona una manera de colocar aplicaciones PHP enteras dentro de un único fichero llamado "phar" (PHP Archive) para una distribución e instalación sencillas. Además de proporcionar este servicio, la extensión phar también provee de un método de abstracción de formato de fichero para crear y manipular ficheros tar y zip a través de la clase PharData, tal como PDO proporciona una interfaz unificada para acceder a diferentes bases de datos. A diferencia de PDO, la cual no puede realizar conversiones entre bases de datos diferentes, Phar también realiza conversiones entre los formatos de ficheros tar, zip phar con una sencilla línea de código. Véase Phar::convertToExecutable() para un ejemplo.

¿Qué es phar? Lo archivos Phar están mejor caracterizados como una forma conveniente de agrupar varios ficheros en un único fichero. Como tal, un archvo phar proporciona una forma para distribuir una aplicación PHP completa en un único fichero y ejecutarla desde ese mismo fichero sin necesidad de extraerlo en el disco. Además, los archivos phar pueden ser ejecutados por PHP fácilmente al igual que cualquier otro fichero, tanto desde la línea de comandos como desde un servidor web. Phar a web server. Phar es como una memoria USB para aplicaciones PHP.

Phar implementa esta funcionalidad a través de una Envoltura de Flujo. Normalmente, para utilizar un fichero externo dentro de un script de PHP, se debería usar include

Ejemplo #1 Utilizar un fichero externo

<?php
 include '/ruta/al/fichero/externo.php';
 ?>

Puede considerarse que PHP traduce realemte /ruta/al/fichero/externo.php a una envoltura de flujo como file:///ruta/al/fichero/externo.php, y bajo la cubierta de hecho hace uso de funciones de flujo de envolturas de flujo de ficheros para acceder a todos los ficheros locales.

Para utilizar un fichero llamado fichero.php contenido en un archivo phar /ruta/a/miphar.phar, la sintaxis es muy similar a la sintaxis file:// de arriba.

Ejemplo #2 Utilizar un fichero dentro de un archivo phar

<?php
 include 'phar:///ruta/a/miphar.phar/fichero.php';
 ?>

De hecho, se puede tratar un archivo phar exactamente como si fuera un disco externo, usando cualquiera de las funciones relacionadas con fopen(), opendir() y funciones relacionadas con mkdir() para leer, cambiar, o crear nuevos ficheros y directorios dentro del archivo phar. Esto permite que aplicaciones de PHP completas sean distribuidas en un único fichero y ejecutarlas directamente desde ese fichero.

El uso más común de un archivo phar es distribuir una aplicación completa en un único fichero. Por ejemplo, el Instalador de PEAR que se incluye con las versiones de PHP está distribuido como un archivo phar. Para usar un archivo phar distribuido de esta forma, se puede ejecutar en línea de comandos o mediante un servidor web.

Los archivos phar pueden ser distribuidos como archivos tar, zip, o como formato de fichero phar personalizado diseñado específicamente por la extensión phar. Cada formato de fichero tiene sus ventajas y desventajas. Los formatos de fichero tar y zip se pueden leer o extraer mediante cualquier herramienta de terceros que pueda leer el formato, pero necesia la extensión phar para ejecutarlo con PHP. El formato de fichero phar es personalizado y único para la extensión phar, y sólo puede ser creado por la extensión phar o el paquete de PEAR » PHP_Archive, pero tiene la ventaja de que las apliaciones creadas en este formato se ejecutarán incluso si la extensión phar no está habilitada.

En otras palabra, incluso con la extensión phar deshabilitada, se puede ejecutar o incluir un archivo basado en phar. El acceso a ficheros dentro de un archivo phar solamente es posible con la extesnión phar a menos que el archivo phar fuese creado por PHP_Archive.

La extensión phar también es capaz de convertir un archivo phar desde los formatos de fichero tar a zip o a phar en un único comando:

Ejemplo #3 Convertir un archivo phar, desde phar al formato de fichero tar

<?php
 $phar = new Phar('miphar.phar');
 $pgz = $phar->convertToExecutable(Phar::TAR, Phar::GZ); // crea miphar.phar.tar.gz
 ?>

Phar puede comprimir ficheros individuales o un archivo entero usando la compresión gzip o la bzip2, y puede verificar la integridad del archivo automáticamente a través del uso de las signaturas MD5, SHA-1, SHA-256 o SHA-512.

Por último, la extensión Phar se preocupa de la seguridad, y deshabilita el acceso a la escritura de archivos phar ejecutables de manera predeterminada, y requiere la deshabilitación a nivel de sistema del ajuste phar.readonly de php.ini para crear o modificar archivos phar. Los archivos tar y zip normales sin una rutina de interoperabilidad ejecutable siempre pueden ser creador o modificados utilizando la clase PharData.

Si está creando aplicaciones para su distribución, le interesará leer Cómo crear Archivos Phar. Si desea más información de las diferencias entre los tres formatos de ficheros que soporta phar, debería leer Phar, Tar y Zip.

Si usa aplicaciones phar, existen consejos útiles en Cómo utilizar archivos Phar

La palabra phar es una composición de PHP y Archive y está basada indirectamente en el familiar jar (Java Archive) para los desarrolladores Java.

La implementación de archivos Phar está basada en el paquete de PEAR » PHP_Archive, y los detalles de implementación son similares, aunque la extensión Phar es mucho más potente. Además, la extensión Phar permite a la mayoría de las aplicaciones de PHP ejecutarse sin modificaciones, mientras que los archivos phar basados en PHP_Archive a menudo requieren una extensa modificiación para que funcionen.


Requerimientos

Phar requiere PHP 5.2.0 o superior. Las caracteristicas adicionales requieren la extensión SPL para aprovechar la iteración y el acceso a arrays del contenido de un fichero de Phar. El flujo phar no requiere ninguna extensión adicional para que funcione.

Opcionalmente, se puede habilitar las extensiones zlib y bzip2 para aprovechar el soporte de phar comprimidos. Además, para aprovechar la firma OpenSSL, debe estar habilidata la extensión OpenSSL.

Observe que un error en el filtro de flujos zlib.deflate corregido en la versión 5.2.6 y posteriores de PHP puede ocasionar el truncamiento de archivos phar comprimidos con gzip bzip2.

PHP 5.3 configurado con --enable-zend-multibyte hace que phar dependa de la opción ini detect_unicode.


Instalación

La extensión Phar está integrada a partir de la versión 5.3.0 de PHP. Phar se puede instalar a través de la extensión PECL con las versiones anteriores de PHP. La » página de PECL de Phar contiene información adicional y su historia.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración de Flujos y Sistema de Ficheros
Nombre | Por defecto | Cambiable | Historial de cambios
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
phar.extract_list | "" | PHP_INI_ALL | Disponible desde phar 1.1.0 a 1.2.3, eliminado en 2.0.0.
phar.cache_list | "" | PHP_INI_SYSTEM | Disponible desde phar 2.0.0.

He aquí una breve explicación de las directivas de configuración.

phar.readonly boolean

Esta opción deshabilita la modificación o creación de archivos Phar usando el flujo phar o el soporte para escritura de objetos Phar. Este ajuste debería estar siempre activado en máquinas de producción, ya que el soporte para escritura conveniente de la extensión phar podría permitir la simple creación de un virus basado en PHP al asociarse con otras vulnerabilidades de seguridad comunes.

Nota:

Este ajuste sólo puede ser desactivado en php.ini por motivos de seguridad. Si phar.readonly está deshabilitado en php.ini, un usuario puede habilitar phar.readonly en un script o deshabilitarlo después. Si phar.readonly está habilitado en php.ini, un scrip puede "re-habilitar" inofensivamente la variable INI, pero no puede deshabilitarla.

phar.require_hash boolean

Esta opción forzará a todos los archivos Phar abiertos a que contengan algún tipo de signatura (actualmente está soportadas MD5, SHA1, SHA256 y SHA512), y rehusará procesar cualquer archivo Phar que no contenga una signatura.

Nota:

Este ajuste sólo puede ser desactivado en php.ini por motivos de seguridad. Si phar.require_hash está deshabilitado en php.ini, un usuario puede habilitar phar.require_hash en un script o deshabilitarlo después. Si phar.require_hash está habilitado en php.ini, un scrip puede "re-habilitar" inofensivamente la variable INI, pero no puede deshabilitarla.

Este ajuste no afecta a la lectura de ficheros tar planos con la clase PharData.

phar.extract_list string

Este ajuste INI ha sido eliminado desde phar 2.0.0

Permite el mapeo desde una ruta completa a un archivo phar o su alias hacia la ubicación de sus ficheros extraídos. El formato del parámetro es nombre=archivo,nombre2=archivo2. Esto permite la extracción de ficheros phar al disco, y permite a phar acutar como una especie de mapeador para extraer ficheros de discos. A menudo, esto se reailza por motivos de rendimiento, o para ayudar a la depuración de un phar.

Ejemplo #1 phar.extract_list usage example

in php.ini:
phar.extract_list = archivo=/ruta/completa/al/archivo/,archivo2=/ruta/completa/al/archivo2
<?php
include "phar://archivo/contenido.php";
include "phar://archivo2/foo.php";
?>

phar.cache_list string

Este ajuste INI fue añadido en 2.0.0

Permite mapear archivos phar para que sean preanalizados en el arranque del servidor web, proporcionando una mejora de rendimiento que saca ficheros en ejecución de un archivo phar casi tan rápido como si esos ficheros se ejecutaran desde una instalación tradicional basada en disco.

Ejemplo #2 Ejemplo de uso de phar.cache_list

en php.ini (windows):
phar.cache_list =C:\ruta\a\phar1.phar;C:\ruta\a\phar2.phar
en php.ini (unix):
phar.cache_list =/ruta/a/phar1.phar:/ruta/a/phar2.phar


Tipos de recursos

La extensión Phar proporciona el flujo phar, el cual permite el acceso a ficheros contenidos en un phar de manera transparente. Véase también la descripción de formato de fichero Phar.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes de compresión de Phar
Constante | Valor | Descripción
Phar::NONE (integer) | 0x00000000 | sin compresión
Phar::COMPRESSED (integer) | 0x0000F000 | máscara de bit que puede ser usada con banderas de fichero para determinar si está presente algún tipo de compresión
Phar::GZ (integer) | 0x00001000 | compression zlib (gzip)
Phar::BZ2 (integer) | 0x00002000 | compression bzip2
Constanten de formato de fichero de Phar
Constante | Valor | Descripción
Phar::SAME (integer) | 0 | conservar el mismo formato de fichero
Phar::PHAR (integer) | 1 | formato de fichero phar
Phar::TAR (integer) | 2 | formato de fichero tar
Phar::ZIP (integer) | 3 | formato de fichero zip
Constantes de signatura de Phar
Constante | Valor | Descripción
Phar::MD5 (integer) | 0x0001 | singnatura con el algoritmo hash md5
Phar::SHA1 (integer) | 0x0002 | singnatura con el algoritmo hash sha1
Phar::SHA256 (integer) | 0x0003 | singnatura con el algoritmo hash sha256 (requiere la extensión Hash)
Phar::SHA512 (integer) | 0x0004 | singnatura con el algoritmo hash sha512 (requiere la extensión Hash)
Phar::OPENSSL (integer) | 0x0010 | signatura con la pareja de claves pública/privada de OpenSSL. Esta es una signatura de clave asimétrica verdadera.
Constantes de sobrescritura MIME de webPhar de Phar
Constante | Valor | Descripción
Phar::PHP (integer) | 1 | usada para ordenar al parámetro de sobrescritura MIME de Phar::webPhar() que la extensión debería ser analizada como un fichero de PHP
Phar::PHPS (integer) | 2 | usada para ordenar al parámetro de sobrescritura MIME de Phar::webPhar() que la extensión debería ser analizada como un fichero fuente de PHP a través de highlight_file()


Utilizar Archivos Phar

Tabla de contenidos

  • Utilizar Archivos Phar: Introduction
  • Utilizar Archivos Phar: la envoltura de flujos phar
  • Utilizar Archivos Phar: las clases Phar y PharData


Utilizar Archivos Phar: Introduction

Los archivos phar son similares en concepto a los archivo JAR de Java, pero están adaptados a las necesidades y a la flexibilidad de aplicaciones de PHP. Un archivo Phar se usa para distribuir una aplicación o biblioteca PHP completa en un único fichero. Una aplicación de un archivo Phar se utiliza exactamente de la misma manera que otra aplicación PHP:

php aplicacion.phar

Utilizar una biblioteca de archivo Phar es idéntico a usar cualquier otra biblioteca de PHP:

<?php
include 'biblioteca.phar';
?>

La envoltura de flujos phar proporciona el núcleo de la extensión Phar, y está explicada en detalle aquí. La envoltura de flujos phar permite el acceso a los ficheros dentro de un archivo phar utilizando las funciones estándar de ficheros de PHP fopen(), opendir(), y y otras que trabajan sobre ficheros normales. La envoltura de flujos phar soporta todas las operaciones de lectura/escritura tanto en ficheros como en directorios.

<?php
include 'phar://biblioteca.phar/fichero/interno.php';
header('Content-type: image/jpeg');
// a los phar se puede acceder con la ruta completa o mediante un alias
echo file_get_contents('phar:///ruta_completa/a/biblioteca.phar/imagenes/wow.jpg');
?>

La clase Phar implementa una funcionalidad avanzada para acceder a ficheros y crear arhivos phar. La clas Phar está explicada en detalle aquí.

<?php
try {
    // abrir un phar existente
    $p = new Phar('biblioteca.phar', 0);
    // Phar extiende la clase DirectoryIterator de SPL
    foreach (new RecursiveIteratorIterator($p) as $fichero) {
        // $fichero en una clase PharFileInfo, y hereda de SplFileInfo
        echo $fichero->getFileName() . "\n";
        echo file_get_contents($fichero->getPathName()) . "\n"; // mostrar el contenido;
    }
    if (isset($p['fichero/interno.php'])) {
        var_dump($p['fichero/interno.php']->getMetadata());
    }

    // crear un nuevo phar - phar.readonly debe ser 0 en php.ini
    // phar.readonly está habilitado por omisión por motivos de seguridad.
    // En servidores de producción, los archivos Phar nunca se crean,
    // sólo se ejecutan.
    if (Phar::canWrite()) {
        $p = new Phar('nuevo_phar.tar.phar', 0, 'nuevo_phar.tar.phar');
        // hacerlo un archivo phar basado en tar, comprimido con gzip (.tar.gz)
        $p = $p->convertToExecutable(Phar::TAR, Phar::GZ);

        // crear una transacción -  no se escribe nada en nuevo_phar.phar
        // hasta que stopBuffering() sea llamado, aunque se necesita almacenamiento temporal
        $p->startBuffering();
        // añadir todos los ficheros de /ruta/del/proyecto, guardándolos en el phar con el prefijo "proyecto"
        $p->buildFromIterator(new RecursiveIteratorIterator(new DirectoryIterator('/ruta/del/proyecto')), '/ruta/del/');

        // añadir un nuevo fichero mediante la API de acceso a arrays
        $p['fichero1.txt'] = 'Información';
        $fp = fopen('fichero_enorme.dat', 'rb');
        // copiar toda la información del flujo
        $p['datos/fichero_enorme.dat'] = $fp;

        if (Phar::canCompress(Phar::GZ)) {
            $p['datos/fichero_enorme.dat']->compress(Phar::GZ);
        }

        $p['imagenes/wow.jpg'] = file_get_contents('imagenes/wow.jpg');
        // cualquier valor se puede guardar como metainformación específica del fichero
        $p['imagenes/wow.jpg']->setMetadata(array('mime-type' => 'image/jpeg'));
        $p['index.php'] = file_get_contents('index.php');
        $p->setMetadata(array('bootstrap' => 'index.php'));

        // cuardar el archivo phar en el disco
        $p->stopBuffering();
    }
} catch (Exception $e) {
    echo 'No se pudo abrir Phar: ', $e;
}
?>

Además, la verificación del contenido de ficheros phar se puede realizar utilizando cualquiera de los algoritmos hash simétricos soportados (MD5, SHA1, SHA256 y SHA512 si la extensión Hash está habilitada) y utilizando firmas de clave pública/privada asimétricas de OpenSSL (nuevo en Phar 2.0.0). Para aprovechar la firmas de OpenSSL, se necesita generar una pareja de claves pública/privada, y utilizar la clave privada para establecer la firma usando Phar::setSignatureAlgorithm(). Además, la clave pública se extrae usando este código:

<?php
$public = openssl_get_publickey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($public, $pkey);
?>
debe ser guardada junto al archivo phar que verifica. Si el archivo phar es guardado como /ruta/a/mi.phar, la clave pública debe guardarse como /ruta/a/mi.phar.pubkey, o phar no será capaz de verificar la firma OpenSSL.

A partir de la verisón 2.0.0, la clase Phar también proporciona tres métodos estáticos, Phar::webPhar(), Phar::mungServer() y Phar::interceptFileFuncs(), los cuales son cruiciales para empaquetar aplicaciones PHP diseñadas para un uso en sistemas de ficheros normales y aplicación basadas en web. Phar::webPhar() implementa un controlador principal que direcciona llamadas HTTP a la ubicación correcta dentro del archivo phar. Phar::mungServer() se utiliza para modificar los valores del array $_SERVER para hacer que las aplicaciones procesen estos valores. Phar::interceptFileFuncs() ordena a Phar que intercepte llamdas a fopen(), file_get_contents(), opendir(), y a todas las funciones basadas en estadísticas (file_exists(), is_readable(), etc.) y direccione todas las rutas relativas a las ubicaciones dentro del archivo phar.

Como ejemplo, empaquetar una versión de la popular aplicación phpMyAdmin para usarla cono un archivo phar, requiere solamente este sencillo script, y después se puede acceder a phpMyAdmin.phar.tar.php como un fichero normal desde el servidor web después de modificar el usuario/contraseña:

<?php
@unlink('phpMyAdmin.phar.tar.php');
copy('phpMyAdmin-2.11.3-english.tar.gz', 'phpMyAdmin.phar.tar.php');
$a = new Phar('phpMyAdmin.phar.tar.php');
$a->startBuffering();
$a["phpMyAdmin-2.11.3-english/config.inc.php"] = '<?php
/* Servers configuration */
$i = 0;

/* Server localhost (config:root) [1] */
$i++;
$cfg[\'Servers\'][$i][\'host\'] = \'localhost\';
$cfg[\'Servers\'][$i][\'extension\'] = \'mysqli\';
$cfg[\'Servers\'][$i][\'connect_type\'] = \'tcp\';
$cfg[\'Servers\'][$i][\'compress\'] = false;
$cfg[\'Servers\'][$i][\'auth_type\'] = \'config\';
$cfg[\'Servers\'][$i][\'user\'] = \'root\';
$cfg[\'Servers\'][$i][\'password\'] = \'\';

/* End of servers configuration */
if (strpos(PHP_OS, \'WIN\') !== false) {
    $cfg[\'UploadDir\'] = getcwd();
} else {
    $cfg[\'UploadDir\'] = \'/tmp/pharphpmyadmin\';
    @mkdir(\'/tmp/pharphpmyadmin\');
    @chmod(\'/tmp/pharphpmyadmin\', 0777);
}';
$a->setStub('<?php
Phar::interceptFileFuncs();
Phar::webPhar("phpMyAdmin.phar", "phpMyAdmin-2.11.3-english/index.php");
echo "phpMyAdmin está intentando ejecutarse desde un navegador web\n";
exit -1;
__HALT_COMPILER();
');
$a->stopBuffering();
?>


Utilizar Archivos Phar: la envoltura de flujos phar

La envoltura de flujos phar soporta completamente fopen() para leer y escribir (no añadir), unlink(), stat(), fstat(), fseek(), rename() y operaciones de flujo de directorios opendir() y a partir de la versión 2.0.0, rmdir() y mkdir().

También se pueden manipular compresiones de ficheros individuales y metadatos por fichero en un archivo Phar usando contextos de flujo:

<?php
$contexto = stream_context_create(array('phar' =>
                                    array('compress' => Phar::GZ)),
                                    array('metadata' => array('user' => 'cellog')));
file_put_contents('phar://mi.phar/fichero.php', 0, $contexto);
?>

La envoltura de flujos phar no opera sobre ficheros remotos, y no puede operar sobre ficheros remotos, and cannot operate on remote files, and so is allowed even when the allow_url_fopen and allow_url_include INI options are disabled.

Aunque es posible crear archivos phar desde cero simplemente usando operaciones de flujos, es mejor utilizar la funcionalidad interna de la clase Phar. La envoltura de flujos se usa mejor para operaciones de sólo lectura.


Utilizar Archivos Phar: las clases Phar y PharData

La clase Phar admite la lectura y la manipulación de archivos Phar, así como la iteración a través de la funcionalidad de la clase RecursiveDirectoryIterator. Con el soporte para la interfaz ArrayAccess, se puede acceder a los ficheros que están dentro de un archivo Phar como si fueran parte de un array asociativo.

La clase PharData extiende la clase Phar, y permite crear y modificar archivos tar y zip no ejecutables (datos) incluso si phar.readonly=1 en php.ini. Por lo tanto, PharData::setAlias() y PharData::setStub() están desactivados ya que los conceptos de alias y rutina de interoperabilidad (stub) son válidos únicamente para archivos phar ejecutables.

Observe que al crear un archivo Phar, se debería pasar la ruta completa al contructor del objeto de la clase Phar. Las rutas relativas causarán un error en la inicialización.

Asumiendo que $p es un objeto de la clase Phar inicializado como sigue:

<?php
$p = new Phar('/ruta/a/miphar.phar', 0, 'miphar.phar');
?>

se creará un archivo Phar vacío en /ruta/a/miphar.phar, o si /ruta/a/miphar.phar ya existe, se abrirá de nuevo. El literal miphar.phar demuestra el concepto de un alias que puede ser usado para referenciar a /ruta/a/miphar.phar en URLs, como en:

<?php
// estas dos llamadas a file_get_contents() son equivalentes si
// /ruta/a/miphar.phar tiene un alias especificado como "miphar.phar"
// en su manifiesto, o si el phar fue inicializado con la
// configuración del objeto Phar del ejemplo anterior
$f = file_get_contents('phar:///ruta/a/miphar.phar/loquesea.txt');
$f = file_get_contents('phar://miphar.phar/loquesea.txt');
?>

Con el recién creado objeto $p de la clase Phar, lo siguiente es posible:

  • $a = $p['fichero.php'] creates a PharFileInfo class that refers to the contents of phar://miphar.phar/fichero.php
  • $p['fichero.php'] = $v crea un nuevo fichero (phar://miphar.phar/fichero.php), o sobrescribe un fichero existente dentro de miphar.phar. $v puede ser una cadena o un puntero de fichero abierto, en cuyo caso todo el contenido del fichero se usará para crear el nuevo fichero. Observe que $p->addFromString('fichero.php', $v) es funcionalmente equivalente a lo de más arriba. También es posible añadir el contenido de un fichero con $p->addFile('/path/to/fichero.php', 'fichero.php'). Por ultimo, se puede crear un directorio vacío con $p->addEmptyDir('vacio').
  • isset($p['fichero.php']) se puede usar para determinar si phar://miphar.phar/fichero.php existe dentro de miphar.phar.
  • unset($p['fichero.php']) borra phar://miphar.phar/fichero.php de miphar.phar.

Además, el objeto de la clase Phar es la única manera de acceder a metainformación específica de Phar, a través de Phar::getMetadata(), y la única manera de establecer o recuperar una rutina de interoperabilidad (stub) del cargador de PHP de un archivo Phar a través de Phar::getStub() y Phar::setStub(). Además, la compresión del archivo completo Phar de una vez, sólo puede ser manipulada utilizando la clase Phar.

La lista completa de la funcionalidad de objetos de la clase Phar está documentada más adelante.

La clase PharFileInfo extiende a la clase SplFileInfo, y añade varios métodos para manipular detalles específicos de Phar de un fichero contenido en un Phar, tales como la manipulación de la compresión y la metainformación.


  • « Utilizar Archivos Phar: las clases Phar y PharData
  • Creación de archivos Phar: Introducción »
  • PHP Manual
  • Phar
  • Creación de archivos Phar

Creación de archivos Phar

Tabla de contenidos

  • Creación de archivos Phar: Introducción


Creación de archivos Phar: Introducción

Para ser escrita completamente en un futuro próximo. Antes de leer esto, asegúrese de leer Como utilizar archivos PHAR.

Un buen lugar para empezar es leer acerca de Phar::buildFromIterator(), y los detalles de la elección del formato de fichero disponible para los archivos. Una adecuada comprensión de lo que es y hace una rutina de interoperabilidad (stub), es crucial para la creación de un archivo PHAR, así Phar::setStub() y Phar::createDefaultStub() son buenos lugares para comenzar. Si va a distribuir una aplicación basada en web es fundamental saber qué es y cómo funciona Phar::webPhar() y el método relacionado Phar::mungServer(). Cualquier aplicación que tenga acceso a sus propios ficheros también debe considerar el uso de Phar::interceptFileFuncs().


¿Qué hace de un phar un phar y no un tar o un zip?

Tabla de contenidos

  • Ingredientes de todos los archivos Phar, independientes del formato de fichero
  • Rutina de interoperabilidad del fichero Phar
  • Comparación cara a cara de Phar, Tar y Zip
  • Archivos phar basados en tar
  • Archivos phar basados en zip
  • El Formato de Fichero Phar
  • Banderas mapeadas en bit globales de Phar
  • Definición de la entrada de fichero del manifiesto de Phar
  • Formato de la firma de Phar


Ingredientes de todos los archivos Phar, independientes del formato de fichero

Todos los archivos Phar contienen tres o cuatro secciones:

  1. una rutina de interoperabilidad (stub)

  2. un manifiesto describiendo el contenido

  3. el contenido de ficheros

  4. [opcional] una firma para verificar la integridad del Phar (solamente el formtado de fichero phar)


Rutina de interoperabilidad del fichero Phar

Una rutina de interoperabilidad de un Phar es un simple fichero PHP. La rutina de interoperabilidad más pequeña posible es:

<?php __HALT_COMPILER();

Una rutina de interoperabilidad debe contener como mínimo el token __HALT_COMPILER(); en su conclusión. Normalmente, una rutina de interoperabilidad contendrá funcionalidad cargadora como:

<?php
Phar::mapPhar();
include 'phar://miphar.phar/index.php';
__HALT_COMPILER();

No existen restricciones para el contenido de una rutina de interoperabilidad de Phar, excepto el requerimiento de que concluya con __HALT_COMPILER();. La etiqueta de cierre de PHP

?>
se puede incluir u omitir, pero no puede haber más de un espacio entre el ; y la etiqueta de cierre
?>
 o la extensión phar no podrá procesar el manifiesto del archivo Phar.

En un archivo phar basado en tar o zip, la rutina de interoperabilidad es alamcenada en el fichero .phar/stub.php. La rutina de interoperabilidad predeterminada para archivos Phar basados en phar contiene aproximadamente 7k de código para extraer el contenido del phar y ejecutarlo. Véase Phar::createDefaultStub() para más información.

El alias de phar se alamcena en un archivo phar basado en zip en el fichero .phar/alias.txt como texto plano.


Comparación cara a cara de Phar, Tar y Zip

¿Cuáles son los aspectos positivos y negativos de los tres formatos de fichero soportados en la extensión phar? Esta tabla intenta responder esta pregunta.

Matriz de características: Phar contra Tar contra Zip
Característica | Phar | Tar | Zip
Formato de Fichero Estádar | No | Sí | Sí
Puede ser ejecutado con la extensión Phar [1] | Sí | No | No
Compresión por fichero | Sí | No | Sí
Compresión de archivo entero | Sí | Sí | No
Validación de firmas del archivo entero | Sí | Sí | Sí (PHP 5.3.1+)
Soporte para aplicaciones específicas de web | Sí | Sí | Sí
Metainformación por fichero | Sí | Sí | Sí
Metainformación del archivo entero | Sí | Sí | Sí
Modificación creación de archivos [2] | Sí | Sí | Sí
Soporte completa para todas las funciones de envoltura de flujos | Sí | Sí | Sí
Puede ser creado/modificado incluso si phar.readonly=1 [3] | No | Sí | Sí

Sugerencia

[1] PHP solamente puede acceder directamente al contenido de un archivo Phar sin la extensión Phar si está utilizando una rutina de interoperabilidad que extraiga el contenido del archivo phar. La rutina de interoperabilidad creada por Phar::createDefaultStub() extrae el archivo phar y ejecuta su contenido desde un directorio temporal si no se encuentra la extensión phar.

Sugerencia

[2] Todos los accesos de escritura requieren que phar.readonly sea deshabilitado en php.ini o directamente or la línea de comandos.

Sugerencia

[3] Solamente se pueden crear archivos tar y zip sin .phar en su nombre de fichero y sin una rutina de interoperabilidad ejecutable .phar/stub.php si phar.readonly=1.


Archivos phar basados en tar

Los archivos basados en el formato de fichero tar siguen el formato de fichero USTAR más moderno. El diseño de la cabecera de fichero tar los hace más eficientes en el acceso que el formato de fichero zip, y casi tan efiniciente que el formato de fichero phar. Los nombres de fichero están limitados a 255 bytes, incluyentdo la ruta completa dentro de archivo phar. No existe límite en el número de ficheros que un archivo phar basado en tar puede contener. Estos archivos pueden ser comprimidos completamente en los formatos gzip o bzip2 y aún ser ejecutados por la extensión Phar.

Para comprimir un archivo entero, use Phar::compress(). Para descomprimir un archvo entero, use Phar::decompress().


Archivos phar basados en zip

Los archivos basados en el formato de fichero zip soportan varias característica incorporadas del formato de fichero zip. La metainformación por fichero y del archivo entero es almacenda en el comentario del fichero zip y en el comentario del archivo zip como una cadena serializada. Los comentarios zip preexistentes serán leídos de manera satisfactoria como una cadena. La lectura/escritura de la compresión por fichero está soportada con la compresión zlib, y el acceso a lectura está soportado con la compresión bzip2. No existe límite en el número de ficheros que un archivo phar basado en zip puede contener. Los directorios vacíos son almacenados en el archivo zip como ficheros con una barra al final, como mi/directorio/


El Formato de Fichero Phar

El formato de fichero phar está dispuesto literalmente como rutina_de_interoperabilidad/manifiesto/contenido/firma, y almacena la información crucial de lo que está incluido en el archivo phar en su manifiesto.

El manifiesto de phar es un formato altamente optimizado que permite especificaciones por fichero de compresión de ficheros, permisos de ficheros, e incluso metainformación definida por el usuario como el usuario o grupo del fichero. Todos los valores mayores que 1 byte son almacenados en el orden de byte little-endian, con la excepción de la versión de la API, que por motivos históricos es almacenada como 3 en el orden big-endian.

Todas las banderas sin utilizar están reservadas para un uso futuro, y no deben usarse para almacenar información personalizada.to store custom information. Use la característica de metainformación por fichero para alamacenar información personalizada sobre ficheros en particular.

El formato de fichero básico de un manifiesto Phar es como sigue:

Formato del manifiesto global de Phar
Tamaño en bytes | Descripción
4 bytes | Longitud del manifiesto en bytes (límite 1 MB)
4 bytes | Número de ficheros en el Phar
2 bytes | Versión de la API del manifiesto de Phar (actualmente 1.0.0)
4 bytes | Banderas mapeadas en bit globales de Phar
4 bytes | Longitud del alisa del Phar
?? | Alias del Phar (la longitud basada en lo anterior)
4 bytes | Longitud de la metainformación del Phar (0 para ninguna)
?? | Metainformación de Phar serializada, almacenada en el formato de serialize()
al menos 24 * número de entradas bytes | entradas para cada fichero


Banderas mapeadas en bit globales de Phar

Aquí están las banderas mapeadas en bit actualmente reconocidas por la extensión Phar para el mapeo de bit plano global de Phar:

Valores de mapeo de bit reconocidos
Valor | Descripción
0x00010000 | Si se establece, el Phar contendrá una firma de verificaición
0x00001000 | Si se establece, el Phar contendrá al menos 1 fichero que está comprimido con la compresión zlib
0x00002000 | Si se establece, el Phar contendrá al menos 1 fichero que está comprimido con la compresión bzip


Definición de la entrada de fichero del manifiesto de Phar

Cada fichero en el manifiesto contiene la siguiente información:

Entrada de fichero del manifiesto de Phar
Tamaño en bytes | Descripción
4 bytes | Longitud del nombre del fichero en bytes
?? | Nombre del fichero (la longitud especificada en lo anterior)
4 bytes | Tamaño del fichero sin comprimir en bytes
4 bytes | Marca de tiempo Unix del fichero
4 bytes | Tamaño del fichero comprimido en bytes
4 bytes | Suma de verificación CRC32 del contenido del fichero si comprimir
4 bytes | Banderas mapeadas en bit específicas del fichero
4 bytes | Longitud de la metainformación del fichero serializada (0 para ninguna)
?? | Metainformación del fichero serializada, almacenada en el formato de serialize()

Observe que a partir de la versión 1.1.1 de la API, los directorios vacíos son almacenados como nombres de fichero con una barra al final, como mi/directorio/

Los valores de mapeo de bit específicos de fichero reconocidos son:

Valores de mapeo de bit reconocidos
Valor | Descripción
0x000001FF | Estos bits están reservador para la definición de los permisos de fichero específicos de un fichero. Los permisos son usados por fstat() y se pueden utilizar para recrear permisos deseados en la extracción.
0x00001000 | Si se establece, el fichero es comprimido con la compresión zlib
0x00002000 | Si se establece, el fichero es comprimido con la compresión bzip


Formato de la firma de Phar

Los archivos Phar que contienen una firma siempre la tienen añadida al final del archivo Phar después del cargador, el manifiesto y el contenido de ficheros. Los dos formatos de firma soportados en este momento son MD5 y SHA1.

Formato de firma
Longitud en bytes | Descripción
16 ó 20 bytes | La firma real, 20 bytes para una firma SHA1, 16 bytes para una firma MD5, 32 bytes para una firma SHA256, y 64 bytes para una firma SHA512.
4 bytes | Banderas de firma. 0x0001 se usa para definir una firma MD5, 0x0002 se usa para definir una firma SHA1, 0x0004 se usa para definir una firma SHA256, y 0x0008 se usaupara definir una firma SHA512. El soporte para las firmas SHA256 y SHA512 se introdujo con la versión 1.1.0 de la API.
4 bytes | GBMB mágico usado para definir la presencia de una firma.


La clase Phar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Introducción

La clase Phar proporciona una interfaz de alto nivel para el acceso y la creación de archivos phar.

Sinopsis de la Clase

Phar extends RecursiveDirectoryIterator implements Countable , ArrayAccess {
/* Métodos */
public addEmptyDir ( string $dirname ) : void
public addFile ( string $file , string $localname = ? ) : void
public addFromString ( string $localname , string $contents ) : void
final public static apiVersion ( ) : string
public buildFromDirectory ( string $base_dir , string $regex = ? ) : array
public buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array
final public static canCompress ( int $type = 0 ) : bool
final public static canWrite ( ) : bool
public compress ( int $compression , string $extension = ? ) : object
public compressFiles ( int $compression ) : void
public __construct ( string $fname , int $flags = ? , string $alias = ? )
public convertToData ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : PharData
public convertToExecutable ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : Phar
public copy ( string $oldfile , string $newfile ) : bool
public count ( ) : int
final public static createDefaultStub ( string $indexfile = ? , string $webindexfile = ? ) : string
public decompress ( string $extension = ? ) : object
public decompressFiles ( ) : bool
public delMetadata ( ) : bool
public delete ( string $entry ) : bool
public extractTo ( string $pathto , string|array $files = ? , bool $overwrite = false ) : bool
public getAlias ( ) : string
public getMetadata ( ) : mixed
public getModified ( ) : bool
public getPath ( ) : string
public getSignature ( ) : array
public getStub ( ) : string
final public static getSupportedCompression ( ) : array
final public static getSupportedSignatures ( ) : array
public getVersion ( ) : string
public hasMetadata ( ) : bool
final public static interceptFileFuncs ( ) : void
public isBuffering ( ) : bool
public isCompressed ( ) : mixed
public isFileFormat ( int $format ) : bool
final public static isValidPharFilename ( string $filename , bool $executable = true ) : bool
public isWritable ( ) : bool
final public static loadPhar ( string $filename , string $alias = ? ) : bool
final public static mapPhar ( string $alias = ? , int $dataoffset = 0 ) : bool
final public static mount ( string $pharpath , string $externalpath ) : void
final public static mungServer ( array $munglist ) : void
public offsetExists ( string $offset ) : bool
public offsetGet ( string $offset ) : int
public offsetSet ( string $offset , string $value ) : void
public offsetUnset ( string $offset ) : bool
final public static running ( bool $retphar = true ) : string
public setAlias ( string $alias ) : bool
public setDefaultStub ( string $index = ? , string $webindex = ? ) : bool
public setMetadata ( mixed $metadata ) : void
public setSignatureAlgorithm ( int $sigtype , string $privatekey = ? ) : void
public setStub ( string $stub , int $len = -1 ) : bool
public startBuffering ( ) : void
public stopBuffering ( ) : void
final public static unlinkArchive ( string $archive ) : bool
final public static webPhar ( string $alias = ? , string $index = "index.php" , string $f404 = ? , array $mimetypes = ? , callable $rewrites = ? ) : void
}

Tabla de contenidos

  • Phar::addEmptyDir — Añadir un directorio vacío al archvo phar
  • Phar::addFile — Añadir un fichero desde el sistema de ficheros al archivo phar
  • Phar::addFromString — Añadir un fichero desde un string al archivo phar
  • Phar::apiVersion — Devolver la versión de la API
  • Phar::buildFromDirectory — Construir un archivo phar desde los ficheros de un directorio
  • Phar::buildFromIterator — Construir un archivo phar desde un iterador
  • Phar::canCompress — Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::canWrite — Devolver si la extensión phar soporta la escritura y creación de archivos phar
  • Phar::compress — Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::compressFiles — Comprime todos los ficheros del archivo Phar actual
  • Phar::__construct — Construir un objeto de archivo Phar
  • Phar::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable
  • Phar::convertToExecutable — Convertir un archivo phar en otro formato de archivo phar ejecutable
  • Phar::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
  • Phar::count — Devuelve el número de entradas (ficheros) en el archivo Phar
  • Phar::createDefaultStub — Crear una rutina de interoperabilidad específica del formato de fichero phar
  • Phar::decompress — Descomprimir un archivo Phar entero
  • Phar::decompressFiles — Descomprimir todos los ficheros del archivo Phar actual
  • Phar::delMetadata — Eliminar la metainformación global del phar
  • Phar::delete — Borrar un fichero dentro de un archivo phar
  • Phar::extractTo — Extraer el contenido de un archivo phar a un directorio
  • Phar::getAlias — Get the alias for Phar
  • Phar::getMetadata — Devolver la metainformación de un archivo phar
  • Phar::getModified — Devolver si el phar fue modificado
  • Phar::getPath — Get the real path to the Phar archive on disk
  • Phar::getSignature — Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar
  • Phar::getStub — Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::getSupportedCompression — Devolver un array de los algoritmos de compresión soportados
  • Phar::getSupportedSignatures — Devolver un array con los tipos de firmas soportados
  • Phar::getVersion — Devolver información de la versión del archivo Phar
  • Phar::hasMetadata — Devolver si el phar tiene metainformación global
  • Phar::interceptFileFuncs — Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas
  • Phar::isBuffering — Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco
  • Phar::isCompressed — Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::isFileFormat — Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro
  • Phar::isValidPharFilename — Devolver si el nombre de fichero dado es un nombre de fichero phar válido
  • Phar::isWritable — Devolver si el archivo phar se puede modificar
  • Phar::loadPhar — Cargar cualquier archivo phar con un alias
  • Phar::mapPhar — Leer el fichero (un phar) que está en ejecución y registrar su manifiesto
  • Phar::mount — Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar
  • Phar::mungServer — Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución
  • Phar::offsetExists — Determina si un fichero existe en un phar
  • Phar::offsetGet — Obtener un objeto de la clase PharFileInfo para un fichero específico
  • Phar::offsetSet — Establecer el contenido de un fichero interno a aquel de un fichero externo
  • Phar::offsetUnset — Eliminar un fichero de un phar
  • Phar::running — Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución
  • Phar::setAlias — Establecer el alias para un archivo Phar
  • Phar::setDefaultStub — Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado
  • Phar::setMetadata — Establecer la metainformación de un archivo phar
  • Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo
  • Phar::setStub — Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::startBuffering — Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco
  • Phar::stopBuffering — Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco
  • Phar::unlinkArchive — Elimiar completamente un archivo phar del disco y de la memoria
  • Phar::webPhar — mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web


Añadir un directorio vacío al archvo phar

  • « Phar
  • Phar::addFile »
  • PHP Manual
  • Phar
  • Añadir un directorio vacío al archvo phar

Phar::addEmptyDir

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addEmptyDir — Añadir un directorio vacío al archvo phar

Descripción

public Phar::addEmptyDir ( string $dirname ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Con este método se crea un directorio vacío con la ruta dada por dirname. Este método es similar a ZipArchive::addEmptyDir().

Parámetros

dirname

El nombre de directorio vacío a crear en el archivo phar

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::addEmptyDir()

<?php
try {
    $a = new Phar('/ruta/a/phar.phar');

    $a->addEmptyDir('/ruta/completa/a/fichero');
    // demuestra cómo se almacena este fichero
    $b = $a['ruta/completa/a/fichero']->isDir();
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • PharData::addEmptyDir() - Añadir un directorio vacío al archivo tar/zip
  • Phar::addFile() - Añadir un fichero desde el sistema de ficheros al archivo phar
  • Phar::addFromString() - Añadir un fichero desde un string al archivo phar


Añadir un fichero desde el sistema de ficheros al archivo phar

  • « Phar::addEmptyDir
  • Phar::addFromString »
  • PHP Manual
  • Phar
  • Añadir un fichero desde el sistema de ficheros al archivo phar

Phar::addFile

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addFile — Añadir un fichero desde el sistema de ficheros al archivo phar

Descripción

public Phar::addFile ( string $file , string $localname = ? ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Con este método, cualquier fichero o URL se puede añadir al arcivo phar. Si se especifica el segundo parámetro opcional localname, el fichero será almacenado en el archivo con el nombre dado por el parámetro, si no se usará el parámetro file como la ruta para almacentar dentro del archivo. Las URLs deben tener un nombre local o se lanzará una excepción. Este método es similar a ZipArchive::addFile().

Parámetros

file

La ruta completa o relativa del fichero del disco a ser añadido al archivo phar.

localname

Ruta con la que el fichero será almacenado en el archivo.

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::addFile()

<?php
try {
    $a = new Phar('/ruta/a/phar.phar');

    $a->addFile('/ruta/completa/a/fichero');
    // demuestra cómo se almacena este fichero
    $b = $a['ruta/completa/a/fichero']->getContent();

    $a->addFile('/ruta/completa/a/fichero', 'mi/fichero.txt');
    $c = $a['mi/fichero.txt']->getContent();

    // demostrar el uso de una URL
    $a->addFile('http://www.ejemplo.com', 'ejemplo.html');
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo
  • PharData::addFile() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • Phar::addFromString() - Añadir un fichero desde un string al archivo phar
  • Phar::addEmptyDir() - Añadir un directorio vacío al archvo phar


Añadir un fichero desde un string al archivo phar

  • « Phar::addFile
  • Phar::apiVersion »
  • PHP Manual
  • Phar
  • Añadir un fichero desde un string al archivo phar

Phar::addFromString

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addFromString — Añadir un fichero desde un string al archivo phar

Descripción

public Phar::addFromString ( string $localname , string $contents ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Con este método, cuanquierl cadena se puede añadir al archivo phar. El fichero será almacenado en el archivo con localname como su ruta. Este método es similar a ZipArchive::addFromString().

Parámetros

localname

Ruta con la que el fichero será almacenado en el archivo.

contents

El contenido del fichero a almacenar

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::addFromString()

<?php
try {
    $a = new Phar('/ruta/a/phar.phar');

    $a->addFromString('ruta/a/fichero.txt', 'mi sencillo fichero');
    $b = $a['ruta/a/fichero.txt']->getContent();

    // para añadir contenido desde un gestor de flujos para ficheros grandes, use offsetSet()
    $c = fopen('/ruta/a/fichero_enorme.bin');
    $a['fichero_grande.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo
  • PharData::addFromString() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • Phar::addFile() - Añadir un fichero desde el sistema de ficheros al archivo phar
  • Phar::addEmptyDir() - Añadir un directorio vacío al archvo phar


Devolver la versión de la API

  • « Phar::addFromString
  • Phar::buildFromDirectory »
  • PHP Manual
  • Phar
  • Devolver la versión de la API

Phar::apiVersion

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::apiVersion — Devolver la versión de la API

Descripción

final public static Phar::apiVersion ( ) : string

Devuelve la versión de la API del formato de fichero phar que será usado al crear phars. La extensión Phar soporta la lectura de la versión de la API 1.0.0 o superior. Se requiere la versión 1.1.0 de la API para los algoritmos hash SHA-256 y SHA-512, y la versión 1.1.1 de la API para almacenar directorios vacíos.

Parámetros

Valores devueltos

La cadena de la versión de la API como "1.0.0".

Ejemplos

Ejemplo #1 Un ejemplo de Phar::apiVersion()

<?php
echo Phar::apiVersion();
?>

El resultado del ejemplo sería:

1.1.1


Construir un archivo phar desde los ficheros de un directorio

  • « Phar::apiVersion
  • Phar::buildFromIterator »
  • PHP Manual
  • Phar
  • Construir un archivo phar desde los ficheros de un directorio

Phar::buildFromDirectory

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::buildFromDirectory — Construir un archivo phar desde los ficheros de un directorio

Descripción

public Phar::buildFromDirectory ( string $base_dir , string $regex = ? ) : array

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Rellena un archivo phar con el contenido de un directorio. El segundo parámtro opcional es una expresión regular (pcre) que se utiliza para excluir ficheros. Cualquier nombre de fichero que coincida con la expresión regular será incluido, todos los demás serán excluidos. Para un control más exhaustivo, use Phar::buildFromIterator().

Parámetros

base_dir

La ruta completa o relativa al directorio que contiene todos los ficheros a añadir al archivo.

regex

Una expresión regular de pcre opcional que se usa para filtrar la lista de ficheros. Solamente las rutas de fichero que coincidan con la expresión regular serán incluidas en el archivo.

Valores devueltos

Phar::buildFromDirectory() devuelve un array asociativo que que mapea la ruta interna del fichero a la ruta completa del mismo en el sistema de ficheros.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no puede instanciar los iteradores intermos del directorio, o una excepción de tipo PharException si hubo errores al guardar el archivo phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::buildFromDirectory()

<?php
// crear con el alias "proyecto.phar"
$phar = new Phar('proyecto.phar', 0, 'proyecto.phar');
// añadir todos los ficheros del proyecto
$phar->buildFromDirectory(dirname(__FILE__) . '/proyecto');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));

$phar2 = new Phar('proyecto2.phar', 0, 'proyecto2.phar');
// añadir todos los ficheros del, incluir solamente los ficheros php
$phar2->buildFromDirectory(dirname(__FILE__) . '/proyecto', '/\.php$/');
$phar2->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Ver también

  • Phar::buildFromIterator() - Construir un archivo phar desde un iterador


Construir un archivo phar desde un iterador

  • « Phar::buildFromDirectory
  • Phar::canCompress »
  • PHP Manual
  • Phar
  • Construir un archivo phar desde un iterador

Phar::buildFromIterator

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::buildFromIterator — Construir un archivo phar desde un iterador

Descripción

public Phar::buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Rellena un archivo phar desde un iterador. Están soportados dos estilos de iteradores, los iteradores que mapean el nombre de fichero dentro del phar al nombre del fichero en disco, y los iteradores como DirectoryIterator que devuelven objetos de la clase SplFileInfo. Se requiere el segundo parámetro para los iteradores que devuelven objetos de la clase SplFileInfo.

Parámetros

iter

Cualquier iterador que mapee de forma asociativa el fichero phar a la ubiciación o que devuelva objetos de la clase SplFileInfo

base_directory

Para los iteradores que devuelven objetos de la clase SplFileInfo, es la porción de cada ruta completa de fichero a eliminar cuando de añada al archivo phar

Valores devueltos

Phar::buildFromIterator() devuelve un array asociativo que que mapea la ruta interna del fichero a la ruta completa del mismo en el sistema de ficheros.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::buildFromIterator() con SplFileInfo

Para la mayoría de los archivos tar/zip, el archivo reflejará la distribución real de directorios, y el segundo estilo es el más útil. Por ejemplo, para crear un archivo phar que contenga los ficheros n esta distribución de muestra de directorios:

/ruta/al/proyecto/
                  config/
                         dist.xml
                         debug.xml
                  lib/
                      fichero1.php
                      fichero2.php
                  src/
                      procesa_algo.php
                  www/
                      index.php
                  cli/
                      index.php

Este código podría usarse para añadir estos ficheros al archivo phar "proyecto.phar":

<?php
// crear con el alias "proyecto.phar"
$phar = new Phar('proyecto.phar', 0, 'proyecto.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/ruta/al/proyecto')),
    '/ruta/al/proyecto');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

El fichero proyecto.phar se puede usar inmediatamente. Phar::buildFromIterator() no establece valores como la compresión y metainformación, que se puede hacer después de crear el archivo phar.

Como observación interesante, Phar::buildFromIterator() también se puede usar para copiar el contenido de un archivo phar existente, ya que los objetos de la clase Phar descienden de la clase DirectoryIterator:

<?php
// crear con el alias "proyecto.phar"
$phar = new Phar('proyecto.phar', 0, 'proyecto.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/ruta/a/otro_phar.phar')),
    'phar:///ruta/a/otro_phar.phar/ruta/al/proyecto');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Ejemplo #2 Un ejemplo de Phar::buildFromIterator() con otros iteradores

La segunda forma de iterador se puede usar con cualquier iterador que devuelva un mapeo clave => valor, tal como un objeto de la clase ArrayIterator:

<?php
// crear con el alias "proyecto.phar"
$phar = new Phar('proyecto.phar', 0, 'proyecto.phar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'fichero/interno.php' => dirname(__FILE__) . '/algun_fichero.php',
        'otro/fichero.jpg' => fopen('/rota/a/archivo_grande.jpg', 'rb'),
     )));
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Errores/Excepciones

Este método lanza una excepción de tipo UnexpectedValueException cuando el iterador devuelve valores incorrectos, tales como una clave de tipo integer en lugar de una cadena, una excepción de tipo BadMethodCallException cuando se pasa un iterador basado en SplFileInfo sin un parámetro base_directory, o una excepción de tipo PharException si hubo errores al guardar el archivo phar.

Ver también

  • Phar::buildFromDirectory() - Construir un archivo phar desde los ficheros de un directorio


Devuelve si la extensión phar soporta la compresión usando zlib o bzip2

  • « Phar::buildFromIterator
  • Phar::canWrite »
  • PHP Manual
  • Phar
  • Devuelve si la extensión phar soporta la compresión usando zlib o bzip2

Phar::canCompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::canCompress — Devuelve si la extensión phar soporta la compresión usando zlib o bzip2

Descripción

final public static Phar::canCompress ( int $type = 0 ) : bool

Este método debería usarse para comprobar si es posible una compresicón antes de cargar un archivo phar que contiene ficheros comprimidos.

Parámetros

type

Se puede usar tanto Phar::GZ o Phar::BZ2 para comprobar si la compresión es posible con un algoritmo de compresión específico (zlib o bzip2).

Valores devueltos

true si la compresión/descompresión está disponible, false si no.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::canCompress()

<?php
if (Phar::canCompress()) {
    echo file_get_contents('phar://phar_comprimido.phar/fichero/interno.txt');
} else {
    echo 'La compresión no está disponible';
}
?>

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::convertToExecutable() - Convertir un archivo phar en otro formato de archivo phar ejecutable
  • Phar::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable


Devolver si la extensión phar soporta la escritura y creación de archivos phar

  • « Phar::canCompress
  • Phar::compress »
  • PHP Manual
  • Phar
  • Devolver si la extensión phar soporta la escritura y creación de archivos phar

Phar::canWrite

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::canWrite — Devolver si la extensión phar soporta la escritura y creación de archivos phar

Descripción

final public static Phar::canWrite ( ) : bool

Este método estático determina si ha sido deshabilitado el acceso a escritura en el php.ini del sistema mediante la variable INI phar.readonly.

Parámetros

Valores devueltos

true si el acceso a escritura esta habilitado, false si está deshabilitado.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::canWrite()

<?php
if (Phar::canWrite()) {
    file_put_contents('phar://miphar.phar/fichero.txt', 'hola, qué tal');
}
?>

Ver también

  • phar.readonly
  • Phar::isWritable() - Devolver si el archivo phar se puede modificar


Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2

  • « Phar::canWrite
  • Phar::compressFiles »
  • PHP Manual
  • Phar
  • Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2

Phar::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::compress — Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2

Descripción

public Phar::compress ( int $compression , string $extension = ? ) : object

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Para archivos phar basados en tar y en phar, este método comprime el archivo entero usando la compresión gzip o bzip2. El fichero resultante puede ser procesado con el comando gunzip/bunzip, o se puede acceder a él directa y transparentemente con la extensión Phar.

Para archivos phar basados en Zip, este método falla con el lanzamiento de una excepción. La extensión zlib debe estar habilitada para poder comprimir con la compresión gzip, y la extensión bzip2 debe estar habilitada para poder comprimir con la compresión bzip2. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto.

Además, este método renombra automáticamente el archivo, añadiéndole .gz, .bz2 o eliminado la extensión si se pasa Phar::NONE para eliminar la compresión. De forma alternativa, se puede expecificar una extensión de fichero con el segundo parámetro.

Parámetros

compression

La compresión debe ser Phar::GZ o Phar::BZ2 para añadir compresión, o Phar::NONE para eliminarla.

extension

Por omisión, la extensión es .phar.gz o .phar.bz2 para comprimir archivos phar, y .phar.tar.gz o .phar.tar.bz2 para comprimir archivos tar. Para la descompresión, las extensiones de fichero predeterminadas son .phar y .phar.tar.

Valores devueltos

Devuelve un objeto de la clase Phar.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión zlib no está disponible, o la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::compress()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
$p['mifichero1.txt'] = 'hola';
$p['mifichero12.txt'] = 'hola';
$p1 = $p->compress(Phar::GZ); // copia a /ruta/a/mi.phar.gz
$p2 = $p->compress(Phar::BZ2); // copia a /ruta/a/mi.phar.bz2
$p3 = $p2->compress(Phar::NONE); // excepción: /ruta/a/mi.phar ya existe
?>

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual


Comprime todos los ficheros del archivo Phar actual

  • « Phar::compress
  • Phar::__construct »
  • PHP Manual
  • Phar
  • Comprime todos los ficheros del archivo Phar actual

Phar::compressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::compressFiles — Comprime todos los ficheros del archivo Phar actual

Descripción

public Phar::compressFiles ( int $compression ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Para archivos phar basados en tar, este método lanza una excepción de tipo BadMethodCallException, ya que la compresión de ficheros individuales dentro de un archivo tar no está soportada por el formato de fichero. Use Phar::compress() para comprimir un archivo phar entero basado en tar.

Para achivos phar basados en Zip y phar, este método comprime todos los ficheros del archivo Phar usando la compresión especificada. Las extensiones zlib o bzip2 deben estar habilitadas para aprovechar esta característica. Además, si cualquier fichero ya está comprimido con la compresión bzip2/zlib, la extensión respectiva debe estar habilitada para poder descomprimir los ficheros antes de re-comprimirlos. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto.

Parámetros

compression

La compresión debe ser Phar::GZ o Phar::BZ2 para añadir compresión, o Phar::NONE para eliminarla.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión zlib no está disponible, o si cualquier fichero está comprimido con la compresión bzip2 y la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::compressFiles()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
$p['mifichero.txt'] = 'hola';
$p['mifichero2.txt'] = 'hola';
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
?>

El resultado del ejemplo sería:

string(13) "mifichero.txt"
bool(false)
bool(false)
bool(false)
string(14) "mifichero2.txt"
bool(false)
bool(false)
bool(false)
string(13) "mifichero.txt"
int(4096)
bool(false)
bool(true)
string(14) "mifichero2.txt"
int(4096)
bool(false)
bool(true)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero


Construir un objeto de archivo Phar

  • « Phar::compressFiles
  • Phar::convertToData »
  • PHP Manual
  • Phar
  • Construir un objeto de archivo Phar

Phar::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::__construct — Construir un objeto de archivo Phar

Descripción

public Phar::__construct ( string $fname , int $flags = ? , string $alias = ? )

Parámetros

fname

Ruta a un archivo Phar existente o para ser creado La extensión del nombre del fichero debe contener .phar.

flags

Banderas a pasar a la clase padre RecursiveDirectoryIterator.

alias

Alias con el que referirse al archivo Phar en las llamadas a funcionalidades de flujos.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si se llama dos veces, o una excepción de tipo UnexpectedValueException si no se puede abrir el archivo phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::__construct()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::KEY_AS_FILENAME,
                  'mi.phar');
} catch (UnexpectedValueException $e) {
    die('No se pudo abrir mi.phar');
} catch (BadMethodCallException $e) {
    echo 'Técnicamente esto no puede suceder';
}
// esto funciona ahora
echo file_get_contents('phar://mi.phar/ejemplo.txt');
// y funciona si hemos escrito
echo file_get_contents('phar:///ruta/a/mi.phar/ejemplo.txt');
?>


Convertir un archivo phar en un fichero tar o zip no ejecutable

  • « Phar::__construct
  • Phar::convertToExecutable »
  • PHP Manual
  • Phar
  • Convertir un archivo phar en un fichero tar o zip no ejecutable

Phar::convertToData

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable

Descripción

public Phar::convertToData ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : PharData

Este método se usa para convertir un archivo phar ejecutable en un fichero tar o zip. Para hacer del tar o zip un fichero no ejecutable, se eliminan los ficheros del phar de rutina de interoperabilidad y de alias del recién creado nuevo archivo.

Si no se especifica ningún cambio, este método lanza una excepción de tipo BadMethodCallException si el archivo está en el formato de fichero phar. Para archivos en el formato tar o zip, este método convierte el archivo en un archivo no ejecutable.

En caso de éxito, el metodo crea un nuevo archivo en disco y devuelve un objeto de la clase PharData. El archivo antiguo no se elimina del disco, y debería hacerse manualmente después de que el proceso haya finalizado.

Parámetros

format

Este parámetro debería ser Phar::TAR o Phar::ZIP. Si se establece a null, se conservará el formato de fichero existente.

compression

Este parámetro debería ser Phar::NONE para no comprimir el archivo completo, Phar::GZ para la compresión basada en zlib, y Phar::BZ2 para la compresión basada en bzip.

extension

Este parámetro se utiliza para sobrescribir la extensión de fichero predeterminada de un archivo convertido. Observe que .phar no puede ser usado en ningún lugar del nombre de fichero de un archivo tar o zip no ejecutable.

Si se convierte a un archivo basado en tar, las extensiones predeterminadas son .tar, .tar.gz, y .tar.bz2 dependiendo de la compresión especificada. Para archivos basados en zip, la extensión predetermianda es .zip.

Valores devueltos

El método devuelve un objeto PharData en caso de éxito, y lanza una excepción en caso de error.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no se puede comprimir, se ha especificado un método de compresión desconocido, el archivo solicitado está almacenado en buffer con Phar::startBuffering() y no se ha cerrado con Phar::stopBuffering(), y una excepción de tipo PharException si se encontró algún problema durante el proceso de la creación de phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::convertToData()

Utilizar Phar::convertToData():

<?php
try {
    $tarphar = new Phar('miphar.phar.tar');
    // observe que miphar.phar.tar *no* está desvinculado.
    // convertirlo a un formato de fichero tar no ejecutable,
    // se crea miphar.tar
    $tar = $tarphar->convertToData();
    // convertirlo a un formato zip no ejecutable, se crea miphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // crear miphar.tbz
    $tgz = $tarphar->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // crear miphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // lanza una excepción
} catch (Exception $e) {
    // manejar el error aquí
}
?>

Ver también

  • Phar::convertToExecutable() - Convertir un archivo phar en otro formato de archivo phar ejecutable
  • PharData::convertToExecutable() - Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable
  • PharData::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable


Convertir un archivo phar en otro formato de archivo phar ejecutable

  • « Phar::convertToData
  • Phar::copy »
  • PHP Manual
  • Phar
  • Convertir un archivo phar en otro formato de archivo phar ejecutable

Phar::convertToExecutable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::convertToExecutable — Convertir un archivo phar en otro formato de archivo phar ejecutable

Descripción

public Phar::convertToExecutable ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : Phar

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Este método se utiliza para convertir un archivo phar en otro formato de fichero. Por ejemplo, se puede utilizar para crear un archivo phar ejecutable basado en tar desde un archivo phar ejecutable basado en zip, o desde un archivo phar ejecutable en el formato de fichero phar. Además, se puede utilizar para aplicar la compresión al archivo completo a un archivo basado en phar o tar.

Si no se especifica ningún cambio, este método lanza una excepción de tipo BadMethodCallException

En caso de éxito, el metodo crea un nuevo archivo en disco y devuelve un objeto de la clase PharData. El archivo antiguo no se elimina del disco, y debería hacerse manualmente después de que el proceso haya finalizado.

Parámetros

format

Este parámetro debería ser Phar::PHAR, Phar::TAR, o Phar::ZIP. Si se establece a null, se conservará el formato de fichero existente.

compression

Este parámetro debería ser Phar::NONE para no comprimir el archivo completo, Phar::GZ para la compresión basada en zlib, y Phar::BZ2 para la compresión basada en bzip.

extension

Este parámetro se utiliza para sobrescribir la extensión de fichero predeterminada de un archivo convertido. Observe que todos los archivos phar basados en zip o en tar deben contener .phar en su extensión de fichero para poder ser procesados como un archivo phar.

Si se convierte a un archivo basado en phar, las extensiones predeterminadas son .phar, .phar.gz, o .phar.bz2 dependiendo de la compresión especificada. Para archivos phar basados en tar, las extensiones predeterminadas son .phar.tar, .phar.tar.gz, y .phar.tar.bz2. Para archivos phar basados en zip, la estensión predeterminada es .phar.zip.

Valores devueltos

El método devuelve un objeto Phar en caso de éxito, y lanza una excepción en caso de error.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no se puede comprimir, se ha especificado un método de compresión desconocido, el archivo solicitado está almacenado en buffer con Phar::startBuffering() y no se ha cerrado con Phar::stopBuffering(), una excepción de tipo UnexpectedValueException si el soporte para escritura está deshabilitado, y una excepción de tipo PharException si se encontró algún problema durante el proceso de la creación de phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::convertToExecutable()

Utilizar Phar::convertToExecutable():

<?php
try {
    $tarphar = new Phar('miphar.phar.tar');
    // convertirlo al formato de fichero phar
    // observe que miphar.phar.tar *no* está desvinculado
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // crea miphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // crea miphar.phar.tgz
    $comprimido = $phar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // manejar el error aquí
}
?>

Ver también

  • Phar::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable
  • PharData::convertToExecutable() - Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable
  • PharData::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable


Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

  • « Phar::convertToExecutable
  • Phar::count »
  • PHP Manual
  • Phar
  • Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

Phar::copy

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

Descripción

public Phar::copy ( string $oldfile , string $newfile ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Copia un fichero interno de un archivo phar a otro fichero nuevo dentro del phar. Esta es una alternativa orientada a objetos para usar copy() con la envoltura de flujos phar.

Parámetros

oldfile

newfile

Valores devueltos

Devuelve true en caso de éxito, pero es más seguro encerrar la llamada al método en un bloque try/catch y asumir el éxito si no se lanza ninguna excepción.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException si el fichero origen no exite, el fichero destino ya existe, el acceso a escritura está deshabilitado, la apertura de cualquiera de los dos ficheros falla, la lectura del fichero fuente falla, o una excepción de tipo PharException si la escritura de los cambios del phar falla.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::copy()

Este ejemplo muestra el uso de Phar::copy() y su equivalente con envoltura de flujos. La principal diferencia entre los dos enfoques es el manejo de errores. Todos los métodos de Phar lanzan excepciones, mientras que la envoltura de flujos utiliza trigger_error().

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar['a'] = 'hola';
    $phar->copy('a', 'b');
    echo $phar['b']; // imprime "hola"
} catch (Exception $e) {
    // manejar errores
}

// el equivalente con envoltura de flujos del código de arriba.
// Se dispara E_WARNINGS en caso de error en vez de excepciones.
copy('phar://miphar.phar/a', 'phar//miphar.phar/c');
echo file_get_contents('phar://miphar.phar/c'); // imprimie "hola"
?>


Devuelve el número de entradas (ficheros) en el archivo Phar

  • « Phar::copy
  • Phar::createDefaultStub »
  • PHP Manual
  • Phar
  • Devuelve el número de entradas (ficheros) en el archivo Phar

Phar::count

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::count — Devuelve el número de entradas (ficheros) en el archivo Phar

Descripción

public Phar::count ( ) : int

Parámetros

Valores devueltos

El número de archivos que contiene Phar, o 0 (el número cero) si no contiene.

Ejemplos

Ejemplo #1 Phar::count() ejemplo

<?php
// asegurarse de que no existe
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'No se pudo crear Phar:', $e;
}
echo 'El nuevo Phar tiene ' . $p->count() . " entradas\n";
$p['file.txt'] = 'hi';
echo 'El nuevo Phar tiene ' . $p->count() . " entradas\n";
?>

El resultado del ejemplo sería:

El nuevo Phar tiene 0 entradas
El nuevo Phar tiene 1 entradas


Crear una rutina de interoperabilidad específica del formato de fichero phar

  • « Phar::count
  • Phar::decompress »
  • PHP Manual
  • Phar
  • Crear una rutina de interoperabilidad específica del formato de fichero phar

Phar::createDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::createDefaultStub — Crear una rutina de interoperabilidad específica del formato de fichero phar

Descripción

final public static Phar::createDefaultStub ( string $indexfile = ? , string $webindexfile = ? ) : string

Este método está destinado a la creación de rutinas de interoperabilidad (stubs) específicas del formato de fichero phar, y no está destinado a ustilizarlo con archivo phar basados en tar o zip.

Los archivos Phar contienen una rutina de interoperabilidad cargadora (en inglés stub) escrita en PHP que se ejecuta cuando el archivo es ejecutado en el propio PHP mediante inclusión:

<?php
include 'miphar.phar';
?>
o por simple ejecución:
php miphar.phar

Este método proporciona una manera simple y sencilla de crear una rutina de interoperabilidad que ejecutará un fichero inicial desde el archivo phar. Además, se pueden especificar diferentes ficheros para ejecutar el archivo phar desde la línea de comandos o a través de un servidor web. La rutina de interoperabilidad cargadora también llama a Phar::interceptFileFuncs() para permitir empaquetar de manera sencilla una aplicación PHP que accede al sistema de ficheros. Si la extensión phar no está presente, la rutina de interoperabilidad cargadora extraerá el archivo phar en un directorio temporal y después operará sobre los archivos. Una función d cierre borra los ficheros temporales a la salida.

Valores devueltos

Devuelve una cadena que contiene una rutina de interoperabildad personalizada (stub) que permite al archivo Phar creado funcionar con o sin la extensón Phar habilitada.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException si cualquier parámetro es mayor de 400 bytes.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::createDefaultStub()

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::setStub() - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::getStub() - Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar


Descomprimir un archivo Phar entero

  • « Phar::createDefaultStub
  • Phar::decompressFiles »
  • PHP Manual
  • Phar
  • Descomprimir un archivo Phar entero

Phar::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::decompress — Descomprimir un archivo Phar entero

Descripción

public Phar::decompress ( string $extension = ? ) : object

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Para archivos phar basados en tar y phar, este método descomprime el archivo entero.

Para archivos phar basados en Zip, este método este método falla con el lanzamiento de una excepción. La extensión zlib debe estar habilitada para descomprimir un archivo comprimido con la compresión gzip, y la extensión bzip2 debe estar habilitada para descomprimir un archivo comprimido con la compresión bzip2. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto.

Además, este método cambia automáticamente la extensión del archivo, .phar por omisión para archivos phar, o .phar.tar para archivos phar basados en tar. De forma alternativa, se puede expecificar una extensión de fichero con el segundo parámetro.

Parámetros

extension

Para la descompresión, las extensiones de fichero predeterminadas son .phar y .phar.tar. Use este parámetro para especificar otra extensión de fichero. Observe que todos los archivos phar ejecutables deben contener .phar en su nombre de fichero.

Valores devueltos

Devuelve un objeto de la clase Phar.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión zlib no está disponible, o la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::decompress()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar.gz');
$p['mifichero1.txt'] = 'hola';
$p['mifichero12.txt'] = 'hola';
$p3 = $p2->decompress(); // crea /ruta/a/mi.phar
?>

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual


Descomprimir todos los ficheros del archivo Phar actual

  • « Phar::decompress
  • Phar::delMetadata »
  • PHP Manual
  • Phar
  • Descomprimir todos los ficheros del archivo Phar actual

Phar::decompressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::decompressFiles — Descomprimir todos los ficheros del archivo Phar actual

Descripción

public Phar::decompressFiles ( ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Para archivos phar basados en tar, este método lanza una excepción de tipo BadMethodCallException, ya que la compresión de ficheros individuales dentro de un archivo tar no está soportada por el formato de fichero. Use Phar::compress() para comprimir un archivo phar entero basado en tar.

Para achivos phar basados en Zip y phar, este método descomprime todos los ficheros del archivo Phar. Las extensiones zlib o bzip2 deben estar habilitadas para aprovechar esta característica si cualquier fichero está comprimido con la compresión bzip2/zlib. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión zlib no está disponible, o si cualquier fichero está comprimido con la compresión bzip2 y la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::decompressFiles()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
$p['mifichero.txt'] = 'hola';
$p['mifichero2.txt'] = 'hola';
$p->compressFiles(Phar::GZ);
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
?>

El resultado del ejemplo sería:

string(13) "mifichero.txt"
int(4096)
bool(false)
bool(true)
string(14) "mifichero2.txt"
int(4096)
bool(false)
bool(true)
string(13) "mifichero.txt"
bool(false)
bool(false)
bool(false)
string(14) "mifichero2.txt"
bool(false)
bool(false)
bool(false)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero


Eliminar la metainformación global del phar

  • « Phar::decompressFiles
  • Phar::delete »
  • PHP Manual
  • Phar
  • Eliminar la metainformación global del phar

Phar::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::delMetadata — Eliminar la metainformación global del phar

Descripción

public Phar::delMetadata ( ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Elimina la metainformación global del phar

Parámetros

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::delMetaData()

<?php
try {
    $phar = new Phar('miphar.phar');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hola, qué tal");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // manejar errores
}
?>

El resultado del ejemplo sería:

NULL
string(14) "hola, qué tal"
NULL

Ver también

  • Phar::getMetadata() - Devolver la metainformación de un archivo phar
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global


Borrar un fichero dentro de un archivo phar

  • « Phar::delMetadata
  • Phar::extractTo »
  • PHP Manual
  • Phar
  • Borrar un fichero dentro de un archivo phar

Phar::delete

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::delete — Borrar un fichero dentro de un archivo phar

Descripción

public Phar::delete ( string $entry ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Borra un fichero dentro de un archivo. Esto es el equivalente funcional de llamar a unlink() en el equivalente de envoltura de flujos, tal como se muestra en el ejemplo de abajo.

Parámetros

entry

La ruta dentro de un archivo para borrar el fichero.

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si se produjo algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::delete()

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar->delete('desvincular/yo.php');
    // esto es equivalente a:
    unlink('phar://miphar.phar/desvincular/yo.php');
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • PharData::delete() - Borrar un fichero dentro de un archivo tar/zip
  • Phar::unlinkArchive() - Elimiar completamente un archivo phar del disco y de la memoria


Extraer el contenido de un archivo phar a un directorio

  • « Phar::delete
  • Phar::getAlias »
  • PHP Manual
  • Phar
  • Extraer el contenido de un archivo phar a un directorio

Phar::extractTo

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::extractTo — Extraer el contenido de un archivo phar a un directorio

Descripción

public Phar::extractTo ( string $pathto , string|array $files = ? , bool $overwrite = false ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Extrae todos los ficheros de un archivo phar al disco. Los ficheros y directorios extraídos conservan los mismos permisos que los almacenados en el archivo. Los parámetros opcionales permiten controlar qué ficheros serán extraídos, y si los ficheros existentes en disco podrán ser sobrescritos. El segundo parámetro files puede ser el nombre de un fichero o directorio a extraer, o un array de nombre de ficheros y directorios a extraer. Por omisión, este método no sobrescribirá los ficheros existentes, aunque el tercer parámetro se puede establecer a true para habilitar la sobrescritura de ficheros. Este método es similar a ZipArchive::extractTo().

Parámetros

pathto

Ruta dentro de un archivo al fichero a borrar.

files

El nombre de un fichero o directorio a extraer, o un array de ficheros/directorios a extraer.

overwrite

Esteblecer a true para habilitar la sobrescritura de ficheros existentes

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::extractTo()

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar->extractTo('/ruta/completa'); // extraer todos los ficheros
    $phar->extractTo('/otra/ruta', 'fichero.txt'); // extraer solamente fichero.txt
    $phar->extractTo('/esta/ruta',
        array('fichero1.txt', 'fichero2.txt')); // extraer solamente 2 ficheros
    $phar->extractTo('/tercera/ruta', null, true); // extraer todos los ficheros y sobrescribirlos
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • PharData::extractTo() - Extraer el contenido de un archivo tar/zip a un directorio


Get the alias for Phar

  • « Phar::extractTo
  • Phar::getMetadata »
  • PHP Manual
  • Phar
  • Get the alias for Phar

Phar::getAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.1)

Phar::getAlias — Get the alias for Phar

Descripción

public Phar::getAlias ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the alias or null if there's no alias.


Devolver la metainformación de un archivo phar

  • « Phar::getAlias
  • Phar::getModified »
  • PHP Manual
  • Phar
  • Devolver la metainformación de un archivo phar

Phar::getMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getMetadata — Devolver la metainformación de un archivo phar

Descripción

public Phar::getMetadata ( ) : mixed

Recupera la información de un archivo. La metainformación puede ser cualquier variable de PHP que pueda ser serializada.

Parámetros

No tiene parámetros.

Valores devueltos

Cualquier variable de PHP que pueda ser serializada y almacenada como metainformación del archivo Phar, o null si no hay metainformación almacenada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::getMetadata()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.php'] = '<?php echo "hola";';
    $p->setMetadata(array('bootstrap' => 'fichero.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'No se pudo crear y/o modificar el phar:', $e;
}
?>

El resultado del ejemplo sería:

array(1) {
  ["bootstrap"]=>
  string(11) "fichero.php"
}

Ver también

  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::delMetadata() - Eliminar la metainformación global del phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global


Devolver si el phar fue modificado

  • « Phar::getMetadata
  • Phar::getPath »
  • PHP Manual
  • Phar
  • Devolver si el phar fue modificado

Phar::getModified

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getModified — Devolver si el phar fue modificado

Descripción

public Phar::getModified ( ) : bool

Este método se puede usar para determinar si un phar tiene un fichero interno eliminado, o el contenido de un fichero ha cambiado de alguna forma.

Parámetros

No tiene parámetros.

Valores devueltos

true si el phar ha sido modificado desde su apertura, false si no.


Get the real path to the Phar archive on disk

  • « Phar::getModified
  • Phar::getSignature »
  • PHP Manual
  • Phar
  • Get the real path to the Phar archive on disk

Phar::getPath

(PHP 5 >= 5.3.0, PHP 7)

Phar::getPath — Get the real path to the Phar archive on disk

Descripción

public Phar::getPath ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar

  • « Phar::getPath
  • Phar::getStub »
  • PHP Manual
  • Phar
  • Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar

Phar::getSignature

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getSignature — Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar

Descripción

public Phar::getSignature ( ) : array

Devuelve la firma de verificación de un archivo phar en una cadena hexadecimal.

Parámetros

Valores devueltos

Un array con las firmas del archivo abierto en la clave hash, y MD5, SHA-1, SHA-256, SHA-512, o OpenSSL en la clave hash_type. Esta firma es un hash calculado sobre el contenido entero del phar, y puede ser usada para verificar la integridad del archivo. Se requiere absolutamente una firma válida de todos los archivos phar ejecutables si la variable INI phar.require_hash está establecida a true.


Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

  • « Phar::getSignature
  • Phar::getSupportedCompression »
  • PHP Manual
  • Phar
  • Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

Phar::getStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getStub — Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

Descripción

public Phar::getStub ( ) : string

Los archivos Phar contienen una rutina de interoperabilidad cargadora (en inglés stub) escrita en PHP que se ejecuta cuando el archivo es ejecutado en el propio PHP mediante inclusión:

<?php
include 'myphar.phar';
?>
o por simple ejecución:
php myphar.phar

Valores devueltos

Devuelve una cadena que contiene la rutina de interoperabilidad cargadora (stub) del archivo Phar actual.

Errores/Excepciones

Lanza una excepción de tipo RuntimeException si no es posible leer la rutina de interoperabilidad del archivo Phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::getStub()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
echo $p->getStub();
echo "==NEXT==\n";
$p->setStub("<?php
function __autoload($clase)
{
    include 'phar://' . str_replace('_', '/', $clase);
}
Phar::mapPhar('miphar.phar');
include 'phar://miphar.phar/arrancar.php';
__HALT_COMPILER(); ?>");
echo $p->getStub();
?>

El resultado del ejemplo sería:

<?php __HALT_COMPILER(); ?>
==NEXT==
<?php
function __autoload($clase)
{
    include 'phar://' . str_replace('_', '/', $clase);
}
Phar::mapPhar('miphar.phar');
include 'phar://miphar.phar/arrancar.php';
__HALT_COMPILER(); ?>

Ver también

  • Phar::setStub() - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::createDefaultStub() - Crear una rutina de interoperabilidad específica del formato de fichero phar


Devolver un array de los algoritmos de compresión soportados

  • « Phar::getStub
  • Phar::getSupportedSignatures »
  • PHP Manual
  • Phar
  • Devolver un array de los algoritmos de compresión soportados

Phar::getSupportedCompression

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::getSupportedCompression — Devolver un array de los algoritmos de compresión soportados

Descripción

final public static Phar::getSupportedCompression ( ) : array

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve un array que contiene Phar::GZ o Phar::BZ2, dependiendo de la disponibilidad de la extensión zlib o de la extensión bz2.

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual


Devolver un array con los tipos de firmas soportados

  • « Phar::getSupportedCompression
  • Phar::getVersion »
  • PHP Manual
  • Phar
  • Devolver un array con los tipos de firmas soportados

Phar::getSupportedSignatures

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.1.0)

Phar::getSupportedSignatures — Devolver un array con los tipos de firmas soportados

Descripción

final public static Phar::getSupportedSignatures ( ) : array

Devuelve un array con los tipos de firmas soportados

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve un array que contiene cualquiera de las firmas MD5, SHA-1, SHA-256, SHA-512, o OpenSSL.

Ver también

  • Phar::getSignature() - Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar
  • Phar::setSignatureAlgorithm() - Establecer el algoritmo de firma para un phar y aplicarlo


Devolver información de la versión del archivo Phar

  • « Phar::getSupportedSignatures
  • Phar::hasMetadata »
  • PHP Manual
  • Phar
  • Devolver información de la versión del archivo Phar

Phar::getVersion

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getVersion — Devolver información de la versión del archivo Phar

Descripción

public Phar::getVersion ( ) : string

Devuelve la versión de la API de un archvo Phar abierto.

Parámetros

Valores devueltos

La versión de la API del arcivo abierto. No se debe confundir con la versión de la API que la extensión phar cargada usará para crear nuevos phars. Cada archivo Phar tiene la versión de la API codificada dentro de su manifiesto. Véase la documentación del formato de fichero Phar para más información.

Ver también

  • Phar::apiVersion() - Devolver la versión de la API


Devolver si el phar tiene metainformación global

  • « Phar::getVersion
  • Phar::interceptFileFuncs »
  • PHP Manual
  • Phar
  • Devolver si el phar tiene metainformación global

Phar::hasMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::hasMetadata — Devolver si el phar tiene metainformación global

Descripción

public Phar::hasMetadata ( ) : bool

Devuelve si el phar tiene metainformación global establecida.

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve true si la metainformación ha sido establecida, y false si no.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::hasMetadata()

<?php
try {
    $phar = new Phar('miphar.phar');
    var_dump($phar->hasMetadata());
    $phar->setMetadata(array('cosa' => 'hola'));
    var_dump($phar->hasMetadata());
    $phar->delMetadata();
    var_dump($phar->hasMetadata());
} catch (Exception $e) {
    // manejar errores
}
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)

Ver también

  • Phar::getMetadata() - Devolver la metainformación de un archivo phar
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::delMetadata() - Eliminar la metainformación global del phar


Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas

  • « Phar::hasMetadata
  • Phar::isBuffering »
  • PHP Manual
  • Phar
  • Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas

Phar::interceptFileFuncs

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::interceptFileFuncs — Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas

Descripción

final public static Phar::interceptFileFuncs ( ) : void

Ordena a phar interceptar fopen(), readfile(), file_get_contents(), opendir(), y todas las funciones relacionadas con estadísticas. Si cualquiera de estas tres funciones es llamada desde dentro de un archivo phar con una ruta relativa, la llamada es modificada para acceder al fichero dentro del archivo phar. Se asume que las rutas absolutas son intentos para cargar ficheros externos desde el sistema de ficheros.

Esta función hace posible ejecutar aplicaciones de PHP diseñadas para ejecutarse desde un disco duro como una aplicación phar.

Parámetros

No tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Un ejemplo de Phar::interceptFileFuncs()

<?php
Phar::interceptFileFuncs();
include 'phar://' . __FILE__ . '/fichero.php';
?>

Se asume que este phar está en /ruta/a/miphar.phar y que contiene fichero.php y fichero2.txt, si fichero.php contiene este código:

Ejemplo #2 Un ejemplo de Phar::interceptFileFuncs()

<?php
echo file_get_contents('fichero2.txt');
?>

Normalmente, PHP buscará fichero2.txt en el directorio actual, que traducirá como el directorio del fichero.php, o el direcotorio actual de un usuario de la línea de comandos. En el código del ejemplo anterior, Phar::interceptFileFuncs() ordena a PHP que considere el directorio actual como phar:///ruta/a/miphar.phar/ y por lo tanto abra phar:///ruta/a/miphar.phar/fichero2.txt.


Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco

  • « Phar::interceptFileFuncs
  • Phar::isCompressed »
  • PHP Manual
  • Phar
  • Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco

Phar::isBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::isBuffering — Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco

Descripción

public Phar::isBuffering ( ) : bool

Este método se puede usar para determinar si un Phar guardará los cambios al disco inmediatamente, o si se necesita una llamada Phar::stopBuffering() para habilitar el guardado de los cambios.

La escritura en buffer de Phar es por archivo, el almacenamiento activo en buffer del archivo Phar foo.phar no afecta a los cambios hechos al archivo Phar bar.phar.

Valores devueltos

Devuelve true si las operaciones de escritura están siendo almacenadas en buffer, false si no.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::isBuffering()

<?php
$p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
$p2 = new Phar('phar_existente.phar');
$p['fichero1.txt'] = 'hola';
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>
=2=
<?php
$p->startBuffering();
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
$p->stopBuffering();
?>
=3=
<?php
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
=2=
bool(true)
bool(false)
=3=
bool(false)
bool(false)

Ver también

  • Phar::startBuffering() - Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco
  • Phar::stopBuffering() - Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco


Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)

  • « Phar::isBuffering
  • Phar::isFileFormat »
  • PHP Manual
  • Phar
  • Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)

Phar::isCompressed

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isCompressed — Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)

Descripción

public Phar::isCompressed ( ) : mixed

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Devuelve Phar::GZ o PHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.). Los archivos phar basados en Zip no pueden ser comprimidos como un fichero, y por lo tanto, este método devolverá siempre false si se requiere un archivo phar basado en zip.

Parámetros

No tiene parámetros.

Valores devueltos

Phar::GZ, Phar::BZ2 o false

Ejemplos

Ejemplo #1 Un ejemplo de Phar::isCompressed()

<?php
try {
    $phar1 = new Phar('miphar.zip.phar');
    var_dump($phar1->isCompressed());
    $phar2 = new Phar('sin_comprimir.tar.phar');
    var_dump($phar2->isCompressed());
    $phar2->compress(Phar::GZ);
    var_dump($phar2->isCompressed() == Phar::GZ);
} catch (Exception $e) {
}
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(true)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados


Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro

  • « Phar::isCompressed
  • Phar::isValidPharFilename »
  • PHP Manual
  • Phar
  • Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro

Phar::isFileFormat

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isFileFormat — Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro

Descripción

public Phar::isFileFormat ( int $format ) : bool

Parámetros

format

Phar::PHAR, Phar::TAR, o Phar::ZIP para comprobar el formato del archivo.

Valores devueltos

Devuelve true si el archivo phar coincide con el formato de fichero solicitado por el parámetro

Errores/Excepciones

Se lanza una excepción de tipo PharException si el parámetro es un especificador de formato de fichero desconocido.

Ver también

  • Phar::convertToExecutable() - Convertir un archivo phar en otro formato de archivo phar ejecutable
  • Phar::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable


Devolver si el nombre de fichero dado es un nombre de fichero phar válido

  • « Phar::isFileFormat
  • Phar::isWritable »
  • PHP Manual
  • Phar
  • Devolver si el nombre de fichero dado es un nombre de fichero phar válido

Phar::isValidPharFilename

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::isValidPharFilename — Devolver si el nombre de fichero dado es un nombre de fichero phar válido

Descripción

final public static Phar::isValidPharFilename ( string $filename , bool $executable = true ) : bool

Devuelve si el nombre de fichero dado es un nombre de fichero phar válido que será reconocido como un archivo phar por la extensión phar. Este método se puede usar para comprobar un nombre sin tener que instanciar un archivo phar y capturar la inevitable excepción que será lanzada si se especifica un nombre no válido.

Parámetros

filename

El nombre o la ruta completa al archivo phar aún no creado

executable

Este parámetro determina si el nombre de fichero debería ser tratado como un archivo phar ejecutable o un archivo de datos no ejecutable

Valores devueltos

Devuelve true si el nombre de fichero es válido, false si no.


Devolver si el archivo phar se puede modificar

  • « Phar::isValidPharFilename
  • Phar::loadPhar »
  • PHP Manual
  • Phar
  • Devolver si el archivo phar se puede modificar

Phar::isWritable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isWritable — Devolver si el archivo phar se puede modificar

Descripción

public Phar::isWritable ( ) : bool

Este método devuelve true si phar.readonly es 0, y el archivo phar real del disco no es de sólo lectura.

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve true si el archivo phar puede ser modificado

Ver también

  • Phar::canWrite() - Devolver si la extensión phar soporta la escritura y creación de archivos phar
  • PharData::isWritable() - Devolver si el archivo tar/zip se puede modificar


Cargar cualquier archivo phar con un alias

  • « Phar::isWritable
  • Phar::mapPhar »
  • PHP Manual
  • Phar
  • Cargar cualquier archivo phar con un alias

Phar::loadPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::loadPhar — Cargar cualquier archivo phar con un alias

Descripción

final public static Phar::loadPhar ( string $filename , string $alias = ? ) : bool

Este método se puede usar para leer el contenido de una archivo Phar externo. Esto es más útil para asignar un alias a un phar, por lo que las referencias subsiguientes al phar puedan usar el alias más corto, o para cargar archivos Phar que contengan solamente datos y no estén concebidos para la ejecución/inclusión en scripts de PHP.

Parámetros

filename

La ruta completa o relativa al archivo phar a abrir

alias

El alias que puede usarse para referirse al archivo phar. Observe que muchos archivos phar especifican un alias explícito dentro del archivo phar, y que una excepción de tipo PharException será lanzada si en este caso se especifica un nuevo alias.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo PharException si se pasa un alias y en archivo phat ya tiene uno explícito

Ejemplos

Ejemplo #1 Un ejemplo de Phar::loadPhar()

Phar::loadPhar puede usarse en cualquier lugar para cargar un archivo Phar externo, mientras que Phar::mapPhar debería usarse en una rutina de interoperabilidad cargadora para un Phar.

<?php
try {
    Phar::loadPhar('/ruta/a/phar.phar', 'mi.phar');
    echo file_get_contents('phar://mi.phar/fichero.txt');
} catch (PharException $e) {
    echo $e;
}
?>

Ver también

  • Phar::mapPhar() - Leer el fichero (un phar) que está en ejecución y registrar su manifiesto


Leer el fichero (un phar) que está en ejecución y registrar su manifiesto

  • « Phar::loadPhar
  • Phar::mount »
  • PHP Manual
  • Phar
  • Leer el fichero (un phar) que está en ejecución y registrar su manifiesto

Phar::mapPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::mapPhar — Leer el fichero (un phar) que está en ejecución y registrar su manifiesto

Descripción

final public static Phar::mapPhar ( string $alias = ? , int $dataoffset = 0 ) : bool

Este método estático solamente se puede usar dentro de una rutina de interoperabilidad cargadora de un archivo Phar para inicializar el phar cuando sea directamente ejecutado, o cuando se incluya en otro scrip.

Parámetros

alias

El alias que puede usarse en las URL phar:// para referirse a este archivo, en vez de su ruta completa.

dataoffset

Variable sin uso, está aquí por compatibilidad con los PHP_Archive de PEAR.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Se lanza una excepción de tipo PharException si no se llama directamente dentro de la ejecución de PHP, si no se encuentra el token __HALT_COMPILER(); en el fichero fuente actual, o si el fichero no se puede abrir para lectura.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::mapPhar()

mapPhar debería usarse dentro de una rutina de interoperabilidad cargadora de phar. Utilice loadPhar para cargar un phar externo en memoria.

Aquí está una rutina de interoperabilidad de Phar de muestra que usa mapPhar.

<?php
function __autoload($clase)
{
    include 'phar://mi.phar/' . str_replace('_', '/', $clase) . '.php';
}
try {
    Phar::mapPhar('mi.phar');
    include 'phar://mi.phar/inicio.php';
} catch (PharException $e) {
    echo $e->getMessage();
    die('No se puede inicializar el Phar');
}
__HALT_COMPILER();

Ver también

  • Phar::loadPhar() - Cargar cualquier archivo phar con un alias


Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar

  • « Phar::mapPhar
  • Phar::mungServer »
  • PHP Manual
  • Phar
  • Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar

Phar::mount

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::mount — Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar

Descripción

final public static Phar::mount ( string $pharpath , string $externalpath ) : void

Al igual que con el concepto del sistema de ficheros de Unix de montar dispositivos externos en rutas dentro del árbol de directorios, Phar::mount() siempre se refiere a ficheros y directorios externos como si estuvieran dentro de un archivo phar. Esto perimte una potente abstracción tal como referirse a ficheros de configuración externos como si estuvieran dentro del archivo.

Parámetros

pharpath

La ruta interna a usar dentro del archivo phar como la ubicación de la ruta montada. Debe ser una ruta relativa dentro del archivo phar, y no debe existir.

externalpath

Una ruta o un URL a un fichero o directorio externo a montar dentro del archivo phar.

Valores devueltos

No devuelve nada. Lanza una excepción de tipo PharException en caso de fallo.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún problema al montar la ruta.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::mount()

El siguiente ejemplo muestra el acceso a un fichero de configuración externo como si fuera una ruta dentro de un archivo phar.

Lo primero, el código dentro de un archivo phar:

<?php
$configuración = simplexml_load_string(file_get_contents(
    Phar::running(false) . '/config.xml'));
?>

Lo siguiente, el código externo utilizado para montar el fichero de configuración:

<?php
// primero se establece la asociación entre el config.xml abstracto
// y el real del disco
Phar::mount('phar://config.xml', '/home/example/config.xml');
// ahora ejecutar la aplicación
include '/ruta/a/archivo.phar';
?>

Otro método es poner el codigo de montaje dentro de la rutina de interoperabilidad del archivo phar. Aquí está un ejemplo de establecer un fichero de configuración predeterminado si no se especifica una configuración de usuario:

<?php
// primero se establece la asociación entre el config.xml abstracto
// y el real del disco
if (defined('EXTERNAL_CONFIG')) {
    Phar::mount('config.xml', EXTERNAL_CONFIG);
    if (file_exists(__DIR__ . '/extra_config.xml')) {
        Phar::mount('extra.xml', __DIR__ . '/extra_config.xml');
    }
} else {
    Phar::mount('config.xml', 'phar://' . __FILE__ . '/default_config.xml');
    Phar::mount('extra.xml', 'phar://' . __FILE__ . '/default_extra.xml');
}
// ahora ejecutar la aplicación
include 'phar://' . __FILE__ . '/index.php';
__HALT_COMPILER();
?>

...y el código externo para cargar este archivo phar:

<?php
define('EXTERNAL_CONFIG', '/inicio/ejemplo/config.xml');
// ahora ejecutar la aplicación
include '/ruta/a/archivo.phar';
?>


Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución

  • « Phar::mount
  • Phar::offsetExists »
  • PHP Manual
  • Phar
  • Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución

Phar::mungServer

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::mungServer — Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución

Descripción

final public static Phar::mungServer ( array $munglist ) : void

Phar::mungServer() solamente debería ser llamado dentro de la rutina de interoperabilidad de un archivo phar.

Define una lista de hasta 4 variables $_SERVER que deberían ser modificadas para la ejecución. Las variables que pueden ser modificadas para eliminar rastros de una ejecución de un phar son REQUEST_URI, PHP_SELF, SCRIPT_NAME y SCRIPT_FILENAME.

Por sí solo, este método no hace nada. Solamente al combinarlo con Phar::webPhar() hace que tenga efecto, y sólo cuando el fichero solicitado es un fichero de PHP a ser procesado. Observe que las variables PATH_INFO y PATH_TRANSLATED son siempre modificadas.

Los valores originales de las variables que son modificadas son almacenados en el array SERVER con el prefijo PHAR_, así por ejemplo SCRIPT_NAME sería guardado como PHAR_SCRIPT_NAME.

Parámetros

munglist

Un array que contiene como índices de cadenas REQUEST_URI, PHP_SELF, SCRIPT_NAME y SCRIPT_FILENAME. Otros valores lanzan una excepción, y Phar::mungServer() es sensible a mayúsculas-minúsculas.

Valores devueltos

No devuelve nada.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException si se encontró algún problema con la información pasada.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::mungServer()

<?php
// rutina de interoperabilidad de ejemplo
Phar::mungServer(array('REQUEST_URI'));
Phar::webPhar();
__HALT_COMPILER();
?>

Ver también

  • Phar::webPhar() - mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web
  • Phar::setStub() - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar


Determina si un fichero existe en un phar

  • « Phar::mungServer
  • Phar::offsetGet »
  • PHP Manual
  • Phar
  • Determina si un fichero existe en un phar

Phar::offsetExists

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetExists — Determina si un fichero existe en un phar

Descripción

public Phar::offsetExists ( string $offset ) : bool

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo Phar utilizando los corchetes de acceso al array.

offsetExists() es llamado siempre que isset() sea llamada.

Parámetros

offset

El nombre del fichero (ruta relativa) a buscar en un Phar.

Valores devueltos

Devuelve true si el fichero existe dentro del phar, o false si no.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::offsetExists()

<?php
$p = new Phar(dirname(__FILE__) . '/mi.phar', 0, 'mi.phar');
$p['primer_fichero.txt'] = 'primer fichero';
$p['segundo_fichero.txt'] = 'segundo_fichero';
// las siguientes líneas llama a offsetExists() indirectamente
var_dump(isset($p['primer_fichero.txt']));
var_dump(isset($p['no_existe.txt']));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ver también

  • Phar::offsetGet() - Obtener un objeto de la clase PharFileInfo para un fichero específico
  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo
  • Phar::offsetUnset() - Eliminar un fichero de un phar


Obtener un objeto de la clase PharFileInfo para un fichero específico

  • « Phar::offsetExists
  • Phar::offsetSet »
  • PHP Manual
  • Phar
  • Obtener un objeto de la clase PharFileInfo para un fichero específico

Phar::offsetGet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetGet — Obtener un objeto de la clase PharFileInfo para un fichero específico

Descripción

public Phar::offsetGet ( string $offset ) : int

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo Phar utilizando los corchetes de acceso al array. Phar::offsetGet() se usa para recuperar ficheros de un archivo Phar.

Parámetros

offset

El nombre del fichero (ruta relativa) a buscar en un Phar.

Valores devueltos

Devuelve un objeto de la clase PharFileInfo que puede usarse para iterar sobre el contenido de un fichero o para recuperar información sobre el fichero actual.

Errores/Excepciones

Este método lanza una extepción de tipo BadMethodCallException si el fichero no existe en el archivo Phar.

Ejemplos

Ejemplo #1 Ejemplo de Phar::offsetGet()

Ya que todas las clases implementan la iterfaz ArrayAccess, Phar::offsetGet() es automáticamente llamada a utilizar el operador [].

<?php
$p = new Phar(dirname(__FILE__) . '/miphar.phar', 0, 'miphar.phar');
$p['existe.txt'] = "el fichero existe\n";
try {
    // automáticamente llama a offsetGet()
    echo $p['existe.txt'];
    echo $p['no_existe.txt'];
} catch (BadMethodCallException $e) {
    echo $e;
}
?>

El resultado del ejemplo sería:

el fichero existe
Entry no_existe.txt does not exist

Ver también

  • Phar::offsetExists() - Determina si un fichero existe en un phar
  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo
  • Phar::offsetUnset() - Eliminar un fichero de un phar


Establecer el contenido de un fichero interno a aquel de un fichero externo

  • « Phar::offsetGet
  • Phar::offsetUnset »
  • PHP Manual
  • Phar
  • Establecer el contenido de un fichero interno a aquel de un fichero externo

Phar::offsetSet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetSet — Establecer el contenido de un fichero interno a aquel de un fichero externo

Descripción

public Phar::offsetSet ( string $offset , string $value ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo Phar utilizando los corchetes de acceso al array. offsetSet se utiliza para modificar un fichero existente, o añadir un nuevo fichero al archivo Phar.

Parámetros

offset

El nombre del fichero (ruta relativa) a modificar en un Phar.

value

El contenido del fichero.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Si phar.readonly es 1, lanza una excepción de tipo BadMethodCallException, ya que modificar un Phar sólo está permitido cuando phar.readonly está establecido a 0. Lanza un excepción de tipo PharException si existe cualquier problema volcando los cambios hechos al archivo Phar al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::offsetSet()

No se debería acceder directamente a offsetSet, en su lugar se utiliza el operador [] para acceder al array.

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
try {
    // llama a offsetSet
    $p['fichero.txt'] = 'Hola qué tal';
} catch (Exception $e) {
    echo 'No se pudo modificar fichero.txt:', $e;
}
?>

Ver también

  • Phar::offsetExists() - Determina si un fichero existe en un phar
  • Phar::offsetGet() - Obtener un objeto de la clase PharFileInfo para un fichero específico
  • Phar::offsetUnset() - Eliminar un fichero de un phar


Eliminar un fichero de un phar

  • « Phar::offsetSet
  • Phar::running »
  • PHP Manual
  • Phar
  • Eliminar un fichero de un phar

Phar::offsetUnset

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetUnset — Eliminar un fichero de un phar

Descripción

public Phar::offsetUnset ( string $offset ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo Phar utilizando los corchetes de acceso al array. offsetUnset se utiliza para borrar un fichero existente, y es llamado por el constructor de lenguaje unset().

Parámetros

offset

El nombre del fichero (ruta relativa) a eliminar en un Phar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Si phar.readonly es 1, lanza una excepción de tipo BadMethodCallException, ya que modificar un Phar sólo está permitido cuando phar.readonly está establecido a 0. Lanza un excepción de tipo PharException si existe cualquier problema volcando los cambios hechos al archivo Phar al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::offsetUnset()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
try {
    // borra fichero.txt de mi.phar llamando a offsetUnset
    unset($p['fichero.txt']);
} catch (Exception $e) {
    echo 'No se pudo borrar fichero.txt: ', $e;
}
?>

Ver también

  • Phar::offsetExists() - Determina si un fichero existe en un phar
  • Phar::offsetGet() - Obtener un objeto de la clase PharFileInfo para un fichero específico
  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo
  • Phar::unlinkArchive() - Elimiar completamente un archivo phar del disco y de la memoria
  • Phar::delete() - Borrar un fichero dentro de un archivo phar


Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución

  • « Phar::offsetUnset
  • Phar::setAlias »
  • PHP Manual
  • Phar
  • Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución

Phar::running

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::running — Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución

Descripción

final public static Phar::running ( bool $retphar = true ) : string

Devuelve la ruta completa del archivo phar en ejecución. Este método tiene la intención de utilizarse como la constante mágica __FILE__, y solamente tiene efecto dentro de un archivo phar en ejecución.

Dentro de una rutina de interoperabilidad de un archivo, Phar::running() devuelve "". Use simplemente __FILE__ para acceder al phar que está ejecutándose acualmente dentro de una rutina de interoperabilidad.

Parámetros

retphar

Si es false, se devuelve la ruta completa del disco del archivo phar. Si es true, se devuelve el URL phar completo.

Valores devueltos

Devuelve el nombre de fichero si es válido, si no una cadena vacía.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::running()

Para el siguiente ejemplo se asume que el archivo phar está ubicado en /ruta/a/phar/mi.phar.

<?php
$a = Phar::running(); // $a es "phar:///ruta/a/mi.phar"
$b = Phar::running(false); // $b es "/ruta/a/mi.phar"
?>


Establecer el alias para un archivo Phar

  • « Phar::running
  • Phar::setDefaultStub »
  • PHP Manual
  • Phar
  • Establecer el alias para un archivo Phar

Phar::setAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.1)

Phar::setAlias — Establecer el alias para un archivo Phar

Descripción

public Phar::setAlias ( string $alias ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Establece el alias par un archivo Phar, y lo escribe como el alias permanente para este archivo phar. Un alias puede usarse internamente a un archivo phar para asegurarse de que el uso de la envoltura de flujo phar para acceder a ficheros internos, siempre funcione sin tener en cuenta la ubicación del archivo phar en el sistema de ficheros. Otra alternativa es confiar en la intercepción de Phar de include o utilizar Phar::interceptFileFuncs() y usar rutas relativas.

Parámetros

alias

Una cadena abreviada para referirse a este archivo en el acceso con la envoltura de flujo phar.

Valores devueltos

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException cuando el acceso a escritura está deshabilitado, y una excepción de tipo PharException si el alias ya está en uso o se encontró algún problema al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::setAlias()

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar->setAlias('mip.phar');
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::__construct() - Construir un objeto de archivo Phar
  • Phar::interceptFileFuncs() - Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas


Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado

  • « Phar::setAlias
  • Phar::setMetadata »
  • PHP Manual
  • Phar
  • Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado

Phar::setDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::setDefaultStub — Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado

Descripción

public Phar::setDefaultStub ( string $index = ? , string $webindex = ? ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Este método es un método cómodo que combina la funcionalidad de Phar::createDefaultStub() y Phar::setStub().

Parámetros

index

La ruta relativa dentro del archivo phar a ejectuar si se accede desde la línea de comandos

webindex

La ruta relativa dentro del archivo phar a ejectuar si se accede desde un servidor web

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Se lanza una excepción de tipo UnexpectedValueException si phar.readonly está habilitado en php.ini. Se lanza una excepción de tipo PharException si se encuentra cualquier problema al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::setDefaultStub()

<?php
try {
    $phar = new Phar('miphar.phar');
    $phar->setDefaultStub('cli.php', 'web/index.php');
    // esto es lo mismo que:
    // $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::setStub() - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::createDefaultStub() - Crear una rutina de interoperabilidad específica del formato de fichero phar


Establecer la metainformación de un archivo phar

  • « Phar::setDefaultStub
  • Phar::setSignatureAlgorithm »
  • PHP Manual
  • Phar
  • Establecer la metainformación de un archivo phar

Phar::setMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::setMetadata — Establecer la metainformación de un archivo phar

Descripción

public Phar::setMetadata ( mixed $metadata ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Phar::setMetadata() debería usarse para almacenar información personalizada que describa algo sobre el archivo phar como una entidad completa. PharFileInfo::setMetadata() debería usarse para metainformación específica de cada fichero. La metainformación puede ralentizar la velocidad de carga de un archivo phar si la información es grande.

Algunos posibles usos para la metainformación incluyen especificar qué fichero dentro del archivo debería usarse para cargar el archivo, o la ubicación de un fichero de manifiesto como el fichero package.xml de » PEAR. Sin embargo, se puede almacenar cualquier información útil que describa el archivo phar.

Parámetros

metadata

Cualquier variable de PHP que contenga la información a almacenar que describa el archivo phar

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::setMetadata()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.php'] = '<?php echo "hola"';
    $p->setMetadata(array('bootstrap' => 'fichero.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'No se pudo crear y/o modificar el phar:', $e;
}
?>

El resultado del ejemplo sería:

array(1) {
  ["bootstrap"]=>
  string(11) "fichero.php"
}

Ver también

  • Phar::getMetadata() - Devolver la metainformación de un archivo phar
  • Phar::delMetadata() - Eliminar la metainformación global del phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global


Establecer el algoritmo de firma para un phar y aplicarlo

  • « Phar::setMetadata
  • Phar::setStub »
  • PHP Manual
  • Phar
  • Establecer el algoritmo de firma para un phar y aplicarlo

Phar::setSignatureAlgorithm

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.1.0)

Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo

Descripción

public Phar::setSignatureAlgorithm ( int $sigtype , string $privatekey = ? ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Establece el algoritmo de firma para un phar y lo aplica. El algoritmo de firma debe ser una de las constantes Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, o Phar::OPENSSL.

Observe que todos los archivos phar ejecutables tienen una firma creada automáticamente, SHA1 por omisión. Los archivos de datos basados en tar o en zip (archivos creados con la clase PharData class) deben tener su signatura creada y establecerla explícitamente mediante Phar::setSignatureAlgorithm().

Parámetros

sigtype

Una de las constantes Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, o Phar::OPENSSL

privatekey

El contenido de una clave privada OpenSSL, como la extraída de un certificado o de un fichero de clave OpenSSL:

<?php
$private = openssl_get_privatekey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($private, $pkey);
$p->setSignatureAlgorithm(Phar::OPENSSL, $pkey);
?>
Véase la Introducción de phar para instrucciones sobre la designación y ubicaión del fichero de clave pública.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException para muchos errores, y una excepción de tipo PharException si ocurrió algún problema al volcar los cambios al disco.

Ver también

  • Phar::getSupportedSignatures() - Devolver un array con los tipos de firmas soportados
  • Phar::getSignature() - Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar


Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

  • « Phar::setSignatureAlgorithm
  • Phar::startBuffering »
  • PHP Manual
  • Phar
  • Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

Phar::setStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::setStub — Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar

Descripción

public Phar::setStub ( string $stub , int $len = -1 ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Este método se utiliza para añadir una rutina de interoperabilidad cargadora a un nuevo archivo Phar, o reemlazar la rutina de interoperabilidad de un archivo Phar existente.

La rutina de interoperabilidad cargadora de un archivo Phar se utiliza siempre que un archivo esté incluido directamente como en este ejemplo:

<?php
include 'miphar.phar';
?>

Al cargador no se accede cuando se incluye un archivo a través de la envoltura de flujos phar como aquí:

<?php
include 'phar://miphar.phar/un_fichero.php';
?>

Parámetros

stub

Una cadena o un gestor de flujo abierto para usarlo como la rutina de interoperabilidad ejecutable de este archivo phar.

len

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Se lanza una excepción de tipo UnexpectedValueException si phar.readonly está habilitado en php.ini. Se lanza una excepción de tipo PharException si se encuentra cualquier problema al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::setStub()

<?php
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['a.php'] = '<?php var_dump("Hola");';
    $p->setStub('<?php var_dump("Primero"); Phar::mapPhar("nuevo_phar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://nuevo_phar.phar/a.php';
    var_dump($p->getStub());
    $p['b.php'] = '<?php var_dump("Mundo");';
    $p->setStub('<?php var_dump("Segundo"); Phar::mapPhar("nuevo_phar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://nuevo_phar.phar/b.php';
    var_dump($p->getStub());
} catch (Exception $e) {
    echo 'Las operaciones de escritura sobre nuevo_phar.phar fallaron: ', $e;
}
?>

El resultado del ejemplo sería:

string(4) "Hola"
string(84) "<?php var_dump("Primero"); Phar::mapPhar("nuevo_phar.phar"); __HALT_COMPILER(); ?>"
string(5) "Mundo"
string(84) "<?php var_dump("Segundo"); Phar::mapPhar("nuevo_phar.phar"); __HALT_COMPILER(); ?>"

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro len.

Ver también

  • Phar::getStub() - Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
  • Phar::createDefaultStub() - Crear una rutina de interoperabilidad específica del formato de fichero phar


Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco

  • « Phar::setStub
  • Phar::stopBuffering »
  • PHP Manual
  • Phar
  • Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco

Phar::startBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::startBuffering — Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco

Descripción

public Phar::startBuffering ( ) : void

Aunque es técnicamente innecesario, el método Phar::startBuffering() puede proporcionar un aumento significativo de rendimiento al crear o modificar un archivo Phar con un gran número de ficheros. Normalmente, cada vez que un fichero dentro de un archivo Phar es creado o modificado de alguna manera, el archivo Phar entero se re-creará con los cambios. De esta forma, el archivo estará actualizado con la actividad realizada sobre él.

Sin embargo, esto puede ser innecesario al crear simplemente un nuevo archivo Phar, que tendría más sentido escribir el archivo entero de una vez. De forma similar, a menudo es necesario realizar una serie de cambios y asegurarse de que todos son posibles antes de hacer cualquier cambio en disco, similar al concepto de transacciones en bases de datos relacionales. La pareja de métodos Phar::startBuffering()/Phar::stopBuffering() está prevista para este propósito.

La escritura en buffer de Phar es por archivo, el almacenamiento activo en buffer del archivo Phar foo.phar no afecta a los cambios hechos al archivo Phar bar.phar.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::startBuffering()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
} catch (Exception $e) {
    echo 'No se pudo crear el phar:', $e;
}
echo 'El nuevo phar tiene ' . $p->count() . " entradas\n";
$p->startBuffering();
$p['fichero.txt'] = 'hola';
$p['fichero2.txt'] = 'qué tal';
$p['fichero2.txt']->setCompressedGZ();
$p['fichero3.txt'] = 'cara de niño';
$p['fichero3.txt']->setMetadata(42);
$p->setStub("<?php
function __autoload($clase)
{
    include 'phar://miphar.phar/' . str_replace('_', '/', $clase) . '.php';
}
Phar::mapPhar('miphar.phar');
include 'phar://miphar.phar/inicio.php';
__HALT_COMPILER();");
$p->stopBuffering();
?>

Ver también

  • Phar::stopBuffering() - Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco
  • Phar::isBuffering() - Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco


Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco

  • « Phar::startBuffering
  • Phar::unlinkArchive »
  • PHP Manual
  • Phar
  • Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco

Phar::stopBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::stopBuffering — Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco

Descripción

public Phar::stopBuffering ( ) : void

Phar::stopBuffering() se usa junto con el método Phar::startBuffering(). Phar::startBuffering() puede proporcionar un aumento significativo de rendimiento al crear o modificar un archivo Phar con un gran número de ficheros. Normalmente, cada vez que un fichero dentro de un archivo Phar es creado o modificado de alguna manera, el archivo Phar entero se re-creará con los cambios. De esta forma, el archivo estará actualizado con la actividad realizada sobre él.

Sin embargo, esto puede ser innecesario al crear simplemente un nuevo archivo Phar, que tendría más sentido escribir el archivo entero de una vez. De forma similar, a menudo es necesario realizar una serie de cambios y asegurarse de que todos son posibles antes de hacer cualquier cambio en disco, similar al concepto de transacciones en bases de datos relacionales. La pareja de métodos Phar::startBuffering()/Phar::stopBuffering() está prevista para este propósito.

La escritura en buffer de Phar es por archivo, el almacenamiento activo en buffer del archivo Phar foo.phar no afecta a los cambios hechos al archivo Phar bar.phar.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Se lanza una excepción de tipo PharException si se encontró algún problema volcando los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::stopBuffering()

<?php
$p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
$p['fichero1.txt'] = 'hola';
$p->startBuffering();
var_dump($p->getStub());
$p->setStub("<?php
function __autoload(\$clase)
{
    include 'phar://nuevo_phar.phar/' . str_replace('_', '/', \$clase) . '.php';
}
Phar::mapPhar('nuevo_phar.phar');
include 'phar://nuevo_phar.phar/incio.php';
__HALT_COMPILER();");
$p->stopBuffering();
var_dump($p->getStub());
?>

El resultado del ejemplo sería:

string(24) "<?php __HALT_COMPILER();"
string(195) "<?php
function __autoload($clase)
{
    include 'phar://' . str_replace('_', '/', $clase);
}
Phar::mapPhar('nuevo_phar.phar');
include 'phar://nuevo_phar.phar/incio.php';
__HALT_COMPILER();"

Ver también

  • Phar::startBuffering() - Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco
  • Phar::isBuffering() - Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco


Elimiar completamente un archivo phar del disco y de la memoria

  • « Phar::stopBuffering
  • Phar::webPhar »
  • PHP Manual
  • Phar
  • Elimiar completamente un archivo phar del disco y de la memoria

Phar::unlinkArchive

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::unlinkArchive — Elimiar completamente un archivo phar del disco y de la memoria

Descripción

final public static Phar::unlinkArchive ( string $archive ) : bool

Elimina un archivo phar del disco y de la memoria.

Parámetros

archive

La ruta en el disco al archivo phar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Se lanza una excepción de tipo PharException si existe cualquier fichero abierto que apunte al archivo phar, o cualquier objeto existente de las clases Phar, PharData, o PharFileInfo que haga referencia al archivo phar.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::unlinkArchive()

<?php
// uso simple
Phar::unlinkArchive('/ruta/a/mi.phar');

// ejemplo más común:
$p = new Phar('mi.phar');
$fp = fopen('phar://mi.phar/fichero.txt', 'r');
// esto crea 'mi.phar.gz'
$gp = $p->compress(Phar::GZ);
// eliminar todas las referencias al archivo
unset($p);
fclose($fp);
// ahora, eliminar todas los indicions del archivo
Phar::unlinkArchive('mi.phar');
?>

Ver también

  • Phar::delete() - Borrar un fichero dentro de un archivo phar
  • Phar::offsetUnset() - Eliminar un fichero de un phar


mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web

  • « Phar::unlinkArchive
  • PharData »
  • PHP Manual
  • Phar
  • mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web

Phar::webPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::webPhar — mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web

Descripción

final public static Phar::webPhar ( string $alias = ? , string $index = "index.php" , string $f404 = ? , array $mimetypes = ? , callable $rewrites = ? ) : void

Phar::mapPhar() para archivos phar basados en web. Este método procesa $_SERVER['REQUEST_URI'] y direcciona una petición de un navegador web a un fichero interno dentro de un archivo phar. En esencia, simula un servidor web, direccionando las peticiones al fichero correcto, enviando las cabeceras correctas y procesando ficheros PHP según sea necesario. Este poderoso método es parte de lo que hace sencillo convertir una apliación PHP existene en un archivo phar. Combinado con Phar::mungServer() y Phar::interceptFileFuncs(), cualquier aplicación web se puede utilizar sin modificaciones desde un archivo phar.

Phar::webPhar() debería llamarse solamente desde la rutina de interoperabilidad (stub) de un archivo phar (aquí hay más información de lo que es una rutina de interorperabilidad).

Parámetros

alias

El alias que puede usarse en las URL phar:// para referirse a este archivo, en vez de su ruta completa.

index

La ubicación dentro del phar del índice de directorios.

f404

La ubicación del script a ejecutar cuando no se encuentra el fichero. Este script debería mostrar las cabeceras HTTP 404 apropiadas.

mimetypes

Un array que mapea extensiones de fichero adicionales a tipos de MIME. Si el mapeo predeterminado es suficiente, se ha de pasar un array vacío. Por omisión, estas extensiones son mapeadas a estos tipos de MIME:

<?php
$mimes = array(
    'phps' => Phar::PHPS, // pasa a highlight_file()
    'c' => 'text/plain',
    'cc' => 'text/plain',
    'cpp' => 'text/plain',
    'c++' => 'text/plain',
    'dtd' => 'text/plain',
    'h' => 'text/plain',
    'log' => 'text/plain',
    'rng' => 'text/plain',
    'txt' => 'text/plain',
    'xsd' => 'text/plain',
    'php' => Phar::PHP, // procesado como PHP
    'inc' => Phar::PHP, // procesado como PHP
    'avi' => 'video/avi',
    'bmp' => 'image/bmp',
    'css' => 'text/css',
    'gif' => 'image/gif',
    'htm' => 'text/html',
    'html' => 'text/html',
    'htmls' => 'text/html',
    'ico' => 'image/x-ico',
    'jpe' => 'image/jpeg',
    'jpg' => 'image/jpeg',
    'jpeg' => 'image/jpeg',
    'js' => 'application/x-javascript',
    'midi' => 'audio/midi',
    'mid' => 'audio/midi',
    'mod' => 'audio/mod',
    'mov' => 'movie/quicktime',
    'mp3' => 'audio/mp3',
    'mpg' => 'video/mpeg',
    'mpeg' => 'video/mpeg',
    'pdf' => 'application/pdf',
    'png' => 'image/png',
    'swf' => 'application/shockwave-flash',
    'tif' => 'image/tiff',
    'tiff' => 'image/tiff',
    'wav' => 'audio/wav',
    'xbm' => 'image/xbm',
    'xml' => 'text/xml',
);
?>

rewrites

A la función rewrites se le proporciona un string como único parámetro y debe devolver un string o false.

Si se está utilizando fast-cgi o cgi, el parámetro pasado a la función es el valor de la variable $_SERVER['PATH_INFO']. De otro modo, el parámetro pasado a la función es el valor de la variable $_SERVER['REQUEST_URI'].

Si se devuelve un string, este se usa como la ruta de fichero interno. Si se devuelve false, webPhar() enviará un código de rechazo HTTP 403.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo PharException cuando no se puede abrir el fichero interno para salida, o si se llama desde un lugar que no sea una rutina de interoperabilidad. Si se pasa un array no válido a mimetypes o se proporciona una llamada de retorno no válida a rewrites, se lanza una excepción de tipo UnexpectedValueException.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::webPhar()

Con el ejemplo siguiente, el phar creado mostrará Hola Mundo si uno explora /miphar.phar/index.php o /miphar.phar, y mostrará la fuente de index.phps si uno explora /miphar.phar/index.phps.

<?php
// creating the phar archive:
try {
    $phar = new Phar('miphar.phar');
    $phar['index.php'] = '<?php echo "Hola Mundo"; ?>';
    $phar['index.phps'] = '<?php echo "Hola Mundo"; ?>';
    $phar->setStub('<?php
Phar::webPhar();
__HALT_COMPILER(); ?>');
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::mungServer() - Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución
  • Phar::interceptFileFuncs() - Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas


La clase PharData

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Introducción

La clase PharData proporciona una interfaz de alto nivel para el acceso y la creación de archivos tar y zip no ejecutables. Debido a que estos archivos no contienen una rutina de interoperabilidad y no pueden ser ejecutados por la extensión phar, es posible crear y manipular ficheros zip y tar normales con la clase PharData incluso si la opción del php.ini phar.readonly está establecida a 1.

Sinopsis de la Clase

PharData extends Phar {
/* Métodos */
addEmptyDir ( string $dirname ) : bool
public Phar::addFile ( string $file , string $localname = ? ) : void
addFromString ( string $localname , string $contents ) : bool
public Phar::buildFromDirectory ( string $base_dir , string $regex = ? ) : array
buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array
compress ( int $compression , string $extension = ? ) : object
compressFiles ( int $compression ) : bool
__construct ( string $fname , int $flags = ? , string $alias = ? , int $format = Phar::TAR )
convertToData ( int $format = ? , int $compression = ? , string $extension = ? ) : PharData
convertToExecutable ( int $format = ? , int $compression = ? , string $extension = ? ) : Phar
copy ( string $oldfile , string $newfile ) : bool
decompress ( string $extension = ? ) : object
decompressFiles ( ) : bool
delMetadata ( ) : bool
delete ( string $entry ) : bool
extractTo ( string $pathto , string|array $files = ? , bool $overwrite = false ) : bool
isWritable ( ) : bool
offsetSet ( string $offset , string $value ) : void
offsetUnset ( string $offset ) : bool
setAlias ( string $alias ) : bool
setDefaultStub ( string $index = ? , string $webindex = ? ) : bool
public Phar::setMetadata ( mixed $metadata ) : void
public Phar::setSignatureAlgorithm ( int $sigtype ) : void
setStub ( string $stub , int $len = -1 ) : bool
/* Métodos heredados */
public Phar::addEmptyDir ( string $dirname ) : void
public Phar::addFile ( string $file , string $localname = ? ) : void
public Phar::addFromString ( string $localname , string $contents ) : void
final public static Phar::apiVersion ( ) : string
public Phar::buildFromDirectory ( string $base_dir , string $regex = ? ) : array
public Phar::buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array
final public static Phar::canCompress ( int $type = 0 ) : bool
final public static Phar::canWrite ( ) : bool
public Phar::compress ( int $compression , string $extension = ? ) : object
public Phar::compressFiles ( int $compression ) : void
public Phar::__construct ( string $fname , int $flags = ? , string $alias = ? )
public Phar::convertToData ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : PharData
public Phar::convertToExecutable ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : Phar
public Phar::copy ( string $oldfile , string $newfile ) : bool
public Phar::count ( ) : int
final public static Phar::createDefaultStub ( string $indexfile = ? , string $webindexfile = ? ) : string
public Phar::decompress ( string $extension = ? ) : object
public Phar::decompressFiles ( ) : bool
public Phar::delMetadata ( ) : bool
public Phar::delete ( string $entry ) : bool
public Phar::extractTo ( string $pathto , string|array $files = ? , bool $overwrite = false ) : bool
public Phar::getAlias ( ) : string
public Phar::getMetadata ( ) : mixed
public Phar::getModified ( ) : bool
public Phar::getPath ( ) : string
public Phar::getSignature ( ) : array
public Phar::getStub ( ) : string
final public static Phar::getSupportedCompression ( ) : array
final public static Phar::getSupportedSignatures ( ) : array
public Phar::getVersion ( ) : string
public Phar::hasMetadata ( ) : bool
final public static Phar::interceptFileFuncs ( ) : void
public Phar::isBuffering ( ) : bool
public Phar::isCompressed ( ) : mixed
public Phar::isFileFormat ( int $format ) : bool
final public static Phar::isValidPharFilename ( string $filename , bool $executable = true ) : bool
public Phar::isWritable ( ) : bool
final public static Phar::loadPhar ( string $filename , string $alias = ? ) : bool
final public static Phar::mapPhar ( string $alias = ? , int $dataoffset = 0 ) : bool
final public static Phar::mount ( string $pharpath , string $externalpath ) : void
final public static Phar::mungServer ( array $munglist ) : void
public Phar::offsetExists ( string $offset ) : bool
public Phar::offsetGet ( string $offset ) : int
public Phar::offsetSet ( string $offset , string $value ) : void
public Phar::offsetUnset ( string $offset ) : bool
final public static Phar::running ( bool $retphar = true ) : string
public Phar::setAlias ( string $alias ) : bool
public Phar::setDefaultStub ( string $index = ? , string $webindex = ? ) : bool
public Phar::setMetadata ( mixed $metadata ) : void
public Phar::setSignatureAlgorithm ( int $sigtype , string $privatekey = ? ) : void
public Phar::setStub ( string $stub , int $len = -1 ) : bool
public Phar::startBuffering ( ) : void
public Phar::stopBuffering ( ) : void
final public static Phar::unlinkArchive ( string $archive ) : bool
final public static Phar::webPhar ( string $alias = ? , string $index = "index.php" , string $f404 = ? , array $mimetypes = ? , callable $rewrites = ? ) : void
}

Tabla de contenidos

  • PharData::addEmptyDir — Añadir un directorio vacío al archivo tar/zip
  • PharData::addFile — Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • PharData::addFromString — Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • PharData::buildFromDirectory — Construir un archivo tar/zip desde los ficheros de un directorio
  • PharData::buildFromIterator — Construir un archivo tar o zip desde un iterador
  • PharData::compress — Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • PharData::compressFiles — Comprime todos los ficheros del archivo tar/zip actual
  • PharData::__construct — Construir un objeto de archivo tar o zip no ejecutable
  • PharData::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable
  • PharData::convertToExecutable — Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable
  • PharData::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
  • PharData::decompress — Descomprimir un archivo Phar entero
  • PharData::decompressFiles — Descomprimir todos los ficheros del archivo zip actual
  • PharData::delMetadata — Eliminar la metainformación global de un archivo zip
  • PharData::delete — Borrar un fichero dentro de un archivo tar/zip
  • PharData::extractTo — Extraer el contenido de un archivo tar/zip a un directorio
  • PharData::isWritable — Devolver si el archivo tar/zip se puede modificar
  • PharData::offsetSet — Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos
  • PharData::offsetUnset — Eliminar un ficerho de un archivo tar/zip
  • PharData::setAlias — función sin sentido (Phar::setAlias no es válido para PharData)
  • PharData::setDefaultStub — función sin sentido (Phar::setStub no es válido para PharData)
  • Phar::setMetadata — Establecer la metainformación de un archivo phar
  • Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo
  • PharData::setStub — función sin sentido (Phar::setStub no es válido para PharData)


Añadir un directorio vacío al archivo tar/zip

  • « PharData
  • PharData::addFile »
  • PHP Manual
  • PharData
  • Añadir un directorio vacío al archivo tar/zip

PharData::addEmptyDir

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addEmptyDir — Añadir un directorio vacío al archivo tar/zip

Descripción

PharData::addEmptyDir ( string $dirname ) : bool

Con este método se crea un directorio vacío con la ruta dada por dirname. Este método es similar a ZipArchive::addEmptyDir().

Parámetros

dirname

El nombre de directorio vacío a crear en el archivo tar o zip

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::addEmptyDir()

<?php
try {
    $a = new PharData('/ruta/a/phar.phar');

    $a->addEmptyDir('/ruta/completa/a/fichero');
    // demuestra cómo se almacena este fichero
    $b = $a['ruta/completa/a/fichero']->isDir();
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • Phar::addEmptyDir() - Añadir un directorio vacío al archvo phar
  • PharData::addFile() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • PharData::addFromString() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip


Añadir un fichero desde el sistema de ficheros al archivo tar/zip

  • « PharData::addEmptyDir
  • PharData::addFromString »
  • PHP Manual
  • PharData
  • Añadir un fichero desde el sistema de ficheros al archivo tar/zip

PharData::addFile

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addFile — Añadir un fichero desde el sistema de ficheros al archivo tar/zip

Descripción

public Phar::addFile ( string $file , string $localname = ? ) : void

Con este método, cualquier fichero o URL se puede añadir al arcivo tar/zip. Si se especifica el segundo parámetro opcional localname, el fichero será almacenado en el archivo con el nombre dado por el parámetro, si no se usará el parámetro file como la ruta para almacentar dentro del archivo. Las URLs deben tener un nombre local o se lanzará una excepción. Este método es similar a ZipArchive::addFile().

Parámetros

file

La ruta completa o relativa del fichero del disco a ser añadido al archivo phar.

localname

Ruta con la que el fichero será almacenado en el archivo.

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::addFile()

<?php
try {
    $a = new PharData('/ruta/a/phar.phar');

    $a->addFile('/ruta/completa/a/fichero');
    // demuestra cómo se almacena este fichero
    $b = $a['ruta/completa/a/fichero']->getContent();

    $a->addFile('/ruta/completa/a/fichero', 'mi/fichero.txt');
    $c = $a['mi/fichero.txt']->getContent();

    // demostrar el uso de una URL
    $a->addFile('http://www.ejemplo.com', 'ejemplo.html');
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • PharData::offsetSet() - Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos
  • Phar::addFile() - Añadir un fichero desde el sistema de ficheros al archivo phar
  • PharData::addFromString() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • PharData::addEmptyDir() - Añadir un directorio vacío al archivo tar/zip


Añadir un fichero desde el sistema de ficheros al archivo tar/zip

  • « PharData::addFile
  • PharData::buildFromDirectory »
  • PHP Manual
  • PharData
  • Añadir un fichero desde el sistema de ficheros al archivo tar/zip

PharData::addFromString

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addFromString — Añadir un fichero desde el sistema de ficheros al archivo tar/zip

Descripción

PharData::addFromString ( string $localname , string $contents ) : bool

Con este método, cuanquierl cadena se puede añadir al archivo tar/zip. El fichero será almacenado en el archivo con localname como su ruta. Este método es similar a ZipArchive::addFromString().

Parámetros

localname

Ruta con la que el fichero será almacenado en el archivo.

contents

El contenido del fichero a almacenar

Valores devueltos

No devuelve ningún valor, se lanza una excepción en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::addFromString()

<?php
try {
    $a = new PharData('/ruta/a/phar.phar');

    $a->addFromString('ruta/a/fichero.txt', 'mi sencillo fichero');
    $b = $a['ruta/a/fichero.txt']->getContent();

    // para añadir contenido desde un gestor de flujos para ficheros grandes, use offsetSet()
    $c = fopen('/ruta/a/fichero_enorme.bin');
    $a['fichero_grande.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // manejar los errores aquí
}
?>

Ver también

  • PharData::offsetSet() - Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos
  • Phar::addFromString() - Añadir un fichero desde un string al archivo phar
  • PharData::addFile() - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
  • PharData::addEmptyDir() - Añadir un directorio vacío al archivo tar/zip


Construir un archivo tar/zip desde los ficheros de un directorio

  • « PharData::addFromString
  • PharData::buildFromIterator »
  • PHP Manual
  • PharData
  • Construir un archivo tar/zip desde los ficheros de un directorio

PharData::buildFromDirectory

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::buildFromDirectory — Construir un archivo tar/zip desde los ficheros de un directorio

Descripción

public Phar::buildFromDirectory ( string $base_dir , string $regex = ? ) : array

Rellena un archivo phar con el contenido de un directorio. El segundo parámtro opcional es una expresión regular (pcre) que se utiliza para excluir ficheros. Cualquier nombre de fichero que coincida con la expresión regular será incluido, todos los demás serán excluidos. Para un control más exhaustivo, use PharData::buildFromIterator().

Parámetros

base_dir

La ruta completa o relativa al directorio que contiene todos los ficheros a añadir al archivo.

regex

Una expresión regular de pcre opcional que se usa para filtrar la lista de ficheros. Solamente las rutas de fichero que coincidan con la expresión regular serán incluidas en el archivo.

Valores devueltos

Phar::buildFromDirectory() devuelve un array asociativo que que mapea la ruta interna del fichero a la ruta completa del mismo en el sistema de ficheros.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no puede instanciar los iteradores intermos del directorio, o una excepción de tipo PharException si hubo errores al guardar el archivo phar.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::buildFromDirectory()

<?php
$phar = new PharData('proyecto.tar');
// añadir todos los ficheros del proyecto
$phar->buildFromDirectory(dirname(__FILE__) . '/proyecto');

$phar2 = new PharData('proyecto2.zip');
// añadir todos los ficheros del, incluir solamente los ficheros php
$phar2->buildFromDirectory(dirname(__FILE__) . '/proyecto', '/\.php$/');
?>

Ver también

  • Phar::buildFromDirectory() - Construir un archivo phar desde los ficheros de un directorio
  • PharData::buildFromIterator() - Construir un archivo tar o zip desde un iterador


Construir un archivo tar o zip desde un iterador

  • « PharData::buildFromDirectory
  • PharData::compress »
  • PHP Manual
  • PharData
  • Construir un archivo tar o zip desde un iterador

PharData::buildFromIterator

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::buildFromIterator — Construir un archivo tar o zip desde un iterador

Descripción

PharData::buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array

Rellena un archivo tar o zip desde un iterador. Están soportados dos estilos de iteradores, los iteradores que mapean el nombre de fichero dentro del tar/zip al nombre del fichero en disco, y los iteradores como DirectoryIterator que devuelven objetos de la clase SplFileInfo. Se requiere el segundo parámetro para los iteradores que devuelven objetos de la clase SplFileInfo.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::buildFromIterator() con SplFileInfo

Para la mayoría de los archivos tar/zip, el archivo reflejará la distribución real de directorios, y el segundo estilo es el más útil. Por ejemplo, para crear un archivo tar/zip que contenga los ficheros n esta distribución de muestra de directorios:

/ruta/al/proyecto/
                 config/
                        dist.xml
                        debug.xml
                 lib/
                     fichero1.php
                     fichero2.php
                 src/
                     procesa_algo.php
                 www/
                     index.php
                 cli/
                     index.php

Este código podría usarse para añadir estos ficheros al archivo tar "proyecto.tar":

<?php
$phar = new PharData('proyecto.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/ruta/al/proyecto')),
    '/ruta/al/proyecto');
?>

El fichero project.tar se puede usar inmediatamente. PharData::buildFromIterator() no establece valores como la compresión y metainformación, que se puede hacer después de crear el archivo tar/zip.

Como observación interesante, PharData::buildFromIterator() también se puede usar para copiar el contenido de un archivo phar, tar o zip existentese, ya que los objetos de la clase PharData descienden de la clase DirectoryIterator:

<?php
$phar = new PharData('proyecto.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/ruta/a/otro_phar.phar')),
    'phar:///ruta/a/otro_phar.phar/ruta/al/proyecto');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Ejemplo #2 Un ejemplo de PharData::buildFromIterator() con otros iteradores

La segunda forma de iterador se puede usar con cualquier iterador que devuelva un mapeo clave => valor, tal como un objeto de la clase ArrayIterator:

<?php
$phar = new PharData('proyecto.tar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'fichero/interno.php' => dirname(__FILE__) . '/algun_fichero.php',
        'otro/fichero.jpg' => fopen('/rota/a/archivo_grande.jpg', 'rb'),
     )));
?>

Parámetros

iter

Cualquier iterador que mapee de forma asociativa el fichero tar/zip a la ubiciación o que devuelva objetos de la clase SplFileInfo

base_directory

Para los iteradores que devuelven objetos de la clase SplFileInfo, es la porción de cada ruta completa de fichero a eliminar cuando de añada al archivo tar/zip

Valores devueltos

PharData::buildFromIterator() devuelve un array asociativo que que mapea la ruta interna del fichero a la ruta completa del mismo en el sistema de ficheros.

Errores/Excepciones

Este método lanza una excepción de tipo UnexpectedValueException cuando el iterador devuelve valores incorrectos, tales como una clave de tipo integer en lugar de una cadena, una excepción de tipo BadMethodCallException cuando se pasa un iterador basado en SplFileInfo sin un parámetro base_directory, o una excepción de tipo PharException si hubo errores al guardar el archivo phar.

Ver también

  • Phar::buildFromIterator() - Construir un archivo phar desde un iterador


Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2

  • « PharData::buildFromIterator
  • PharData::compressFiles »
  • PHP Manual
  • PharData
  • Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2

PharData::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::compress — Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2

Descripción

PharData::compress ( int $compression , string $extension = ? ) : object

Para archivos tar, este método comprime el archivo entero usando la compresión gzip o bzip2. El fichero resultante puede ser procesado con el comando gunzip/bunzip, o se puede acceder a él directa y transparentemente con la extensión Phar.

Para archivos phar basados en Zip, este método falla con el lanzamiento de una excepción. La extensión zlib debe estar habilitada para poder comprimir con la compresión gzip, y la extensión bzip2 debe estar habilitada para poder comprimir con la compresión bzip2.

Además, este método renombra automáticamente el archivo, añadiéndole .gz, .bz2 o eliminado la extensión si se pasa Phar::NONE para eliminar la compresión. De forma alternativa, se puede expecificar una extensión de fichero con el segundo parámetro.

Parámetros

compression

La compresión debe ser Phar::GZ o Phar::BZ2 para añadir compresión, o Phar::NONE para eliminarla.

extension

Por omisión, la extensión es .tar.gz o .tar.bz2 para comprimir un tar, y .tar para descomprimirlo.

Valores devueltos

Devuelve un objeto de la clase PharData.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la extensión zlib no está disponible, o la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::compress()

<?php
$p = new PharData('/ruta/a/mi.tar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p1 = $p->compress(Phar::GZ); // copia a /ruta/a/mi.tar.gz
$p2 = $p->compress(Phar::BZ2); // copia a /ruta/a/mi.tar.bz2
$p3 = $p2->compress(Phar::NONE); // excepción: /ruta/a/mi.tar ya existe
?>

Ver también

  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2


Comprime todos los ficheros del archivo tar/zip actual

  • « PharData::compress
  • PharData::__construct »
  • PHP Manual
  • PharData
  • Comprime todos los ficheros del archivo tar/zip actual

PharData::compressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::compressFiles — Comprime todos los ficheros del archivo tar/zip actual

Descripción

PharData::compressFiles ( int $compression ) : bool

Para archivos phar basados en tar, este método lanza una excepción de tipo BadMethodCallException, ya que la compresión de ficheros individuales dentro de un archivo tar no está soportada por el formato de fichero. Use Phar::compress() para comprimir un archivo phar entero basado en tar.

Para achivos basados en Zip, este método comprime todos los ficheros del archivo usando la compresión especificada. Las extensiones zlib o bzip2 deben estar habilitadas para aprovechar esta característica. Además, si cualquier fichero ya está comprimido con la compresión bzip2/zlib, la extensión respectiva debe estar habilitada para poder descomprimir los ficheros antes de re-comprimirlos.

Parámetros

compression

La compresión debe ser Phar::GZ o Phar::BZ2 para añadir compresión, o Phar::NONE para eliminarla.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión zlib no está disponible, o si cualquier fichero está comprimido con la compresión bzip2 y la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::compressFiles()

<?php
$p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
$p['mifichero.txt'] = 'hola';
$p['mifichero2.txt'] = 'hola';
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
?>

El resultado del ejemplo sería:

string(13) "mifichero.txt"
bool(false)
bool(false)
bool(false)
string(14) "mifichero2.txt"
bool(false)
bool(false)
bool(false)
string(13) "mifichero.txt"
int(4096)
bool(false)
bool(true)
string(14) "mifichero2.txt"
int(4096)
bool(false)
bool(true)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • PharData::decompressFiles() - Descomprimir todos los ficheros del archivo zip actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • PharData::decompress() - Descomprimir un archivo Phar entero


Construir un objeto de archivo tar o zip no ejecutable

  • « PharData::compressFiles
  • PharData::convertToData »
  • PHP Manual
  • PharData
  • Construir un objeto de archivo tar o zip no ejecutable

PharData::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::__construct — Construir un objeto de archivo tar o zip no ejecutable

Descripción

PharData::__construct ( string $fname , int $flags = ? , string $alias = ? , int $format = Phar::TAR )

Parámetros

fname

Ruta a un archivo tar/zip existente o para ser creado

flags

Banderas a pasar a la clase padre RecursiveDirectoryIterator.

alias

Alias con el que referirse al archivo Phar en las llamadas a funcionalidades de flujos.

format

Una de las constantes de formato de fichero disponiblies dentro de la clase Phar.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si se llama dos veces, o una excepción de tipo UnexpectedValueException si no se puede abrir el archivo phar.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::__construct()

<?php
try {
    $p = new PharData('/ruta/a/mi.tar', Phar::CURRENT_AS_FILEINFO | Phar::KEY_AS_FILENAME);
} catch (UnexpectedValueException $e) {
    die('No se pudo abrir mi.tar');
} catch (BadMethodCallException $e) {
    echo 'Técnicamente esto no puede suceder';
}
echo file_get_contents('phar:///ruta/a/mi.tar/ejemplo.txt');
?>


Convertir un archivo phar en un fichero tar o zip no ejecutable

  • « PharData::__construct
  • PharData::convertToExecutable »
  • PHP Manual
  • PharData
  • Convertir un archivo phar en un fichero tar o zip no ejecutable

PharData::convertToData

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::convertToData — Convertir un archivo phar en un fichero tar o zip no ejecutable

Descripción

PharData::convertToData ( int $format = ? , int $compression = ? , string $extension = ? ) : PharData

Este método se usa para convertir un archivo tar o zip no ejecutable a otro formato no ejecutable.

Si no se especifica ningún cambio, este método lanza una excepción de tipo BadMethodCallException Este método debería usarse para convertir un archivo tar a formato zip o viceversa. Aunque es posible cambiar la compresión de un archivo tar simplemente usando este método, es mejor utilizad el método PharData::compress() para una consistencia lógica.

En caso de éxito, el metodo crea un nuevo archivo en disco y devuelve un objeto de la clase PharData. El archivo antiguo no se elimina del disco, y debería hacerse manualmente después de que el proceso haya finalizado.

Parámetros

format

Este parámetro debería ser Phar::TAR o Phar::ZIP. Si se establece a null, se conservará el formato de fichero existente.

compression

Este parámetro debería ser Phar::NONE para no comprimir el archivo completo, Phar::GZ para la compresión basada en zlib, y Phar::BZ2 para la compresión basada en bzip.

extension

Este parámetro se utiliza para sobrescribir la extensión de fichero predeterminada de un archivo convertido. Observe que .phar no puede ser usado en ningún lugar del nombre de fichero de un archivo tar o zip no ejecutable.

Si se convierte a un archivo basado en tar, las extensiones predeterminadas son .tar, .tar.gz, y .tar.bz2 dependiendo de la compresión especificada. Para archivos basados en zip, la extensión predetermianda es .zip.

Valores devueltos

El método devuelve un objeto PharData en caso de éxito, y lanza una excepción en caso de error.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no se puede comprimir, se ha especificado un método de compresión desconocido, el archivo solicitado está almacenado en buffer con Phar::startBuffering() y no se ha cerrado con Phar::stopBuffering(), y una excepción de tipo PharException si se encontró algún problema durante el proceso de la creación de phar.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::convertToData()

Utilizar PharData::convertToData():

<?php
try {
    $tarphar = new PharData('miphar.tar');
    // observe que miphar.phar.tar *no* está desvinculado.
    // convertirlo a un formato de fichero tar no ejecutable,
    // se crea miphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // crear miphar.tbz
    $tgz = $tarphar->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // crear miphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // lanza una excepción
} catch (Exception $e) {
    // manejar el error aquí
}
?>

Ver también

  • Phar::convertToExecutable() - Convertir un archivo phar en otro formato de archivo phar ejecutable
  • Phar::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable
  • PharData::convertToExecutable() - Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable


Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable

  • « PharData::convertToData
  • PharData::copy »
  • PHP Manual
  • PharData
  • Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable

PharData::convertToExecutable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::convertToExecutable — Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable

Descripción

PharData::convertToExecutable ( int $format = ? , int $compression = ? , string $extension = ? ) : Phar

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Este método se utiliza para convertir un arhivo tar o zip no ejecutable en un archivo phar ejecutable. Se puede usar cualquiera de los tres formatos de fichero (phar, tar o zip), y también se puede realizar la compresión del archivo completo.

Si no se especifica ningún cambio, este método lanza una excepción de tipo BadMethodCallException

En caso de éxito, el metodo crea un nuevo archivo en disco y devuelve un objeto de la clase PharData. El archivo antiguo no se elimina del disco, y debería hacerse manualmente después de que el proceso haya finalizado. If successful, the method creates a new archive on disk and returns a Phar object. The old archive is not removed from disk, and should be done manually after the process has finished.

Parámetros

format

Este parámetro debería ser Phar::PHAR, Phar::TAR, o Phar::ZIP. Si se establece a null, se conservará el formato de fichero existente.

compression

Este parámetro debería ser Phar::NONE para no comprimir el archivo completo, Phar::GZ para la compresión basada en zlib, y Phar::BZ2 para la compresión basada en bzip.

extension

Este parámetro se utiliza para sobrescribir la extensión de fichero predeterminada de un archivo convertido. Observe que todos los archivos phar basados en zip o en tar deben contener .phar en su extensión de fichero para poder ser procesados como un archivo phar.

Si se convierte a un archivo basado en phar, las extensiones predeterminadas son .phar, .phar.gz, o .phar.bz2 dependiendo de la compresión especificada. Para archivos phar basados en tar, las extensiones predeterminadas son .phar.tar, .phar.tar.gz, y .phar.tar.bz2. Para archivos phar basados en zip, la estensión predeterminada es .phar.zip.

Valores devueltos

El método devuelve un objeto Phar en caso de éxito, y lanza una excepción en caso de error.

Errores/Excepciones

Este método lanza una excepción de tipo BadMethodCallException cuando no se puede comprimir, se ha especificado un método de compresión desconocido, el archivo solicitado está almacenado en buffer con Phar::startBuffering() y no se ha cerrado con Phar::stopBuffering(), una excepción de tipo UnexpectedValueException si el soporte para escritura está deshabilitado, y una excepción de tipo PharException si se encontró algún problema durante el proceso de la creación de phar.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::convertToExecutable()

Utilizar PharData::convertToExecutable():

<?php
try {
    $tarphar = new PharData('miphar.tar');
    // convertirlo al formato de fichero phar
    // observe que miphar.tar *no* está desvinculado
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // crea miphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // crea miphar.phar.tgz
    $comprimido = $tarphar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // manejar el error aquí
}
?>

Ver también

  • Phar::convertToExecutable() - Convertir un archivo phar en otro formato de archivo phar ejecutable
  • Phar::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable
  • PharData::convertToData() - Convertir un archivo phar en un fichero tar o zip no ejecutable


Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

  • « PharData::convertToExecutable
  • PharData::decompress »
  • PHP Manual
  • PharData
  • Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

PharData::copy

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::copy — Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar

Descripción

PharData::copy ( string $oldfile , string $newfile ) : bool

Copia un fichero interno de un archivo tar/zip a otro fichero nuevo dentro del mismo archivo. Esta es una alternativa orientada a objetos para usar copy() con la envoltura de flujos phar.

Parámetros

oldfile

newfile

Valores devueltos

Devuelve true en caso de éxito, pero es más seguro encerrar la llamada al método en un bloque try/catch y asumir el éxito si no se lanza ninguna excepción.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException si el fichero origen no exite, el fichero destino ya existe, el acceso a escritura está deshabilitado, la apertura de cualquiera de los dos ficheros falla, la lectura del fichero fuente falla, o una excepción de tipo PharException si la escritura de los cambios del phar falla.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::copy()

Este ejemplo muestra el uso de PharData::copy() y su equivalente con envoltura de flujos. La principal diferencia entre los dos enfoques es el manejo de errores. Todos los métodos de PharData lanzan excepciones, mientras que la envoltura de flujos utiliza trigger_error().

<?php
try {
    $phar = new PharData('miphar.tar');
    $phar['a'] = 'hola';
    $phar->copy('a', 'b');
    echo $phar['b']; // imprime "phar://miphar.tar/b"
} catch (Exception $e) {
    // manejar errores
}

// el equivalente con envoltura de flujos del código de arriba.
// Se dispara E_WARNINGS en caso de error en vez de excepciones.
copy('phar://miphar.tar/a', 'phar//miphar.tar/c');
echo file_get_contents('phar://miphar.tar/c'); // imprime "hola"
?>


Descomprimir un archivo Phar entero

  • « PharData::copy
  • PharData::decompressFiles »
  • PHP Manual
  • PharData
  • Descomprimir un archivo Phar entero

PharData::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::decompress — Descomprimir un archivo Phar entero

Descripción

PharData::decompress ( string $extension = ? ) : object

Para archivos phar basados en tar, este método descomprime el archivo entero.

Para archivos phar basados en Zip, este método este método falla con el lanzamiento de una excepción. La extensión zlib debe estar habilitada para descomprimir un archivo comprimido con la compresión gzip, y la extensión bzip2 debe estar habilitada para descomprimir un archivo comprimido con la compresión bzip2.

Además, este método renombra automáticamente la extensión de fichero del archivo, .tar por omisión. De forma alternativa, se puede expecificar una extensión de fichero con el segundo parámetro.

Parámetros

extension

Para la descompresión, las extensión de fichero predeterminada es .phar.tar. Use este parámetro para especificar otra extensión de fichero. Observe que todos los archivos no ejecutables no pueden contener .phar en su nombre de fichero.

Valores devueltos

Devuelve un objeto de la clase PharData.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la extensión zlib no está disponible, o la extensión bzip2 no está habilitada.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::decompress()

<?php
$p = new PharData('/ruta/a/mi.tar.gz');
$p->decompress(); // crea /ruta/a/mi.tar
?>

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • PharData::compressFiles() - Comprime todos los ficheros del archivo tar/zip actual
  • PharData::decompressFiles() - Descomprimir todos los ficheros del archivo zip actual


Descomprimir todos los ficheros del archivo zip actual

  • « PharData::decompress
  • PharData::delMetadata »
  • PHP Manual
  • PharData
  • Descomprimir todos los ficheros del archivo zip actual

PharData::decompressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::decompressFiles — Descomprimir todos los ficheros del archivo zip actual

Descripción

PharData::decompressFiles ( ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Para archivos basados en tar, este método lanza una excepción de tipo BadMethodCallException, ya que la compresión de ficheros individuales dentro de un archivo tar no está soportada por el formato de fichero. Use Phar::compress() para comprimir un archivo phar entero basado en tar.

Para achivos phar basados en Zip y phar, este método descomprime todos los ficheros del archivo. Las extensiones zlib o bzip2 deben estar habilitadas para aprvechar esta característica si cualquier fichero está comprimido con la compresión bzip2/zlib.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la extensión zlib no está disponible, o si cualquier fichero está comprimido con la compresión bzip2 y la extensión bzip2 no está habilitada. Throws BadMethodCallException if the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::decompressFiles()

<?php
$p = new PharData('/ruta/a/mi.zip');
$p['mifichero.txt'] = 'hola';
$p['mifichero2.txt'] = 'hola';
$p->compressFiles(Phar::GZ);
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $fichero) {
    var_dump($fichero->getFileName());
    var_dump($fichero->isCompressed());
    var_dump($fichero->isCompressed(Phar::BZ2));
    var_dump($fichero->isCompressed(Phar::GZ));
}
?>

El resultado del ejemplo sería:

string(13) "mifichero.txt"
int(4096)
bool(false)
bool(true)
string(14) "mifichero2.txt"
int(4096)
bool(false)
bool(true)
string(13) "mifichero.txt"
bool(false)
bool(false)
bool(false)
string(14) "mifichero2.txt"
bool(false)
bool(false)
bool(false)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • PharData::compressFiles() - Comprime todos los ficheros del archivo tar/zip actual
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • PharData::compress() - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
  • PharData::decompress() - Descomprimir un archivo Phar entero


Eliminar la metainformación global de un archivo zip

  • « PharData::decompressFiles
  • PharData::delete »
  • PHP Manual
  • PharData
  • Eliminar la metainformación global de un archivo zip

PharData::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::delMetadata — Eliminar la metainformación global de un archivo zip

Descripción

PharData::delMetadata ( ) : bool

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Elimina la metainformación global de un archivo zip

Parámetros

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::delMetaData()

<?php
try {
    $phar = new PharData('miphar.zip');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hola, qué tal");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // manejar errores
}
?>

El resultado del ejemplo sería:

NULL
string(14) "hola, qué tal"
NULL

Ver también

  • Phar::delMetadata() - Eliminar la metainformación global del phar


Borrar un fichero dentro de un archivo tar/zip

  • « PharData::delMetadata
  • PharData::extractTo »
  • PHP Manual
  • PharData
  • Borrar un fichero dentro de un archivo tar/zip

PharData::delete

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::delete — Borrar un fichero dentro de un archivo tar/zip

Descripción

PharData::delete ( string $entry ) : bool

Borra un fichero dentro de un archivo. Esto es el equivalente funcional de llamar a unlink() en el equivalente de envoltura de flujos, tal como se muestra en el ejemplo de abajo.

Parámetros

entry

La ruta dentro de un archivo para borrar el fichero.

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si se produjo algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::delete()

<?php
try {
    $phar = new PharData('miphar.zip');
    $phar->delete('desvincular/yo.php');
    // esto es equivalente a:
    unlink('phar://miphar.phar/desvincular/yo.php');
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::delete() - Borrar un fichero dentro de un archivo phar


Extraer el contenido de un archivo tar/zip a un directorio

  • « PharData::delete
  • PharData::isWritable »
  • PHP Manual
  • PharData
  • Extraer el contenido de un archivo tar/zip a un directorio

PharData::extractTo

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::extractTo — Extraer el contenido de un archivo tar/zip a un directorio

Descripción

PharData::extractTo ( string $pathto , string|array $files = ? , bool $overwrite = false ) : bool

Extrae todos los ficheros de un archivo tar/zip al disco. Los ficheros y directorios extraídos conservan los mismos permisos que los almacenados en el archivo. Los parámetros opcionales permiten controlar qué ficheros serán extraídos, y si los ficheros existentes en disco podrán ser sobrescritos. El segundo parámetro files puede ser el nombre de un fichero o directorio a extraer, o un array de nombre de ficheros y directorios a extraer. Por omisión, este método no sobrescribirá los ficheros existentes, aunque el tercer parámetro se puede establecer a true para habilitar la sobrescritura de ficheros. Este método es similar a ZipArchive::extractTo().

Parámetros

pathto

Ruta donde extraer los ficheros dados por files

files

El nombre de un fichero o directorio a extraer, o un array de ficheros/directorios a extraer.

overwrite

Esteblecer a true para habilitar la sobrescritura de ficheros existentes

Valores devueltos

Devuelve true en caso de éxito, pero es mejor comprobar si lanza alguna excepción, y asumir el éxito si no se lanza ninguna.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún error al volcar los cambios al disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::extractTo()

<?php
try {
    $phar = new PharData('miphar.tar');
    $phar->extractTo('/ruta/completa'); // extraer todos los ficheros
    $phar->extractTo('/otra/ruta', 'fichero.txt'); // extraer solamente fichero.txt
    $phar->extractTo('/esta/ruta',
        array('fichero1.txt', 'fichero2.txt')); // extraer solamente 2 ficheros
    $phar->extractTo('/tercera/ruta', null, true); // extraer todos los ficheros y sobrescribirlos
} catch (Exception $e) {
    // manejar errores
}
?>

Ver también

  • Phar::extractTo() - Extraer el contenido de un archivo phar a un directorio


Devolver si el archivo tar/zip se puede modificar

  • « PharData::extractTo
  • PharData::offsetSet »
  • PHP Manual
  • PharData
  • Devolver si el archivo tar/zip se puede modificar

PharData::isWritable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::isWritable — Devolver si el archivo tar/zip se puede modificar

Descripción

PharData::isWritable ( ) : bool

Este método devuelve true si el archivo tar/zip archive del disco no es de sólo lectura. A diferencia de Phar::isWritable(), los archivos tar/zip de sólo datos se pueden modificar incluso si phar.readonly está establecido a 1.

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve true si el archivo tar/zip puede ser modificado

Ver también

  • Phar::canWrite() - Devolver si la extensión phar soporta la escritura y creación de archivos phar
  • Phar::isWritable() - Devolver si el archivo phar se puede modificar


Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos

  • « PharData::isWritable
  • PharData::offsetUnset »
  • PHP Manual
  • PharData
  • Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos

PharData::offsetSet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::offsetSet — Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos

Descripción

PharData::offsetSet ( string $offset , string $value ) : void

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo tar/zip utilizando los corchetes de acceso al array. offsetSet se utiliza para modificar un fichero existente, o añadir un nuevo fichero al archivo tar/zip.

Parámetros

offset

El nombre del fichero (ruta relativa) a modificar en un archivo tar o zip.

value

El contenido del fichero.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza un excepción de tipo PharException si existe cualquier problema volcando los cambios hechos al archivo tar/zip al disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::offsetSet()

No se debería acceder directamente a offsetSet, en su lugar se utiliza el operador [] para acceder al array.

<?php
$p = new PharData('/ruta/a/mi.phar', 0, 'mi.phar');
try {
    // llama a offsetSet
    $p['fichero.txt'] = 'Hola qué tal';
} catch (Exception $e) {
    echo 'No se pudo modificar fichero.txt:', $e;
}
?>

Ver también

  • Phar::offsetSet() - Establecer el contenido de un fichero interno a aquel de un fichero externo


Eliminar un ficerho de un archivo tar/zip

  • « PharData::offsetSet
  • PharData::setAlias »
  • PHP Manual
  • PharData
  • Eliminar un ficerho de un archivo tar/zip

PharData::offsetUnset

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::offsetUnset — Eliminar un ficerho de un archivo tar/zip

Descripción

PharData::offsetUnset ( string $offset ) : bool

Ésta es una implementación de la interfaz ArrayAccess que permite la manipulación directa del contenido de un archivo tar/zip utilizando los corchetes de acceso al array. offsetUnset se utiliza para borrar un fichero existente, y es llamado por el constructor de lenguaje unset().

Parámetros

offset

El nombre del fichero (ruta relativa) a eliminar en un archivo tar o zip.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza un excepción de tipo PharException si existe cualquier problema volcando los cambios hechos al archivo tar/zip al disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharData::offsetUnset()

<?php
$p = new PharData('/ruta/a/mi.phar', 0, 'mi.phar');
try {
    // borra fichero.txt de mi.phar llamando a offsetUnset
    unset($p['fichero.txt']);
} catch (Exception $e) {
    echo 'No se pudo borrar fichero.txt: ', $e;
}
?>

Ver también

  • Phar::offsetUnset() - Eliminar un fichero de un phar


función sin sentido (Phar::setAlias no es válido para PharData)

  • « PharData::offsetUnset
  • PharData::setDefaultStub »
  • PHP Manual
  • PharData
  • función sin sentido (Phar::setAlias no es válido para PharData)

PharData::setAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setAlias — función sin sentido (Phar::setAlias no es válido para PharData)

Descripción

PharData::setAlias ( string $alias ) : bool

Los archivos tar/zip no ejecutables no pueden tener un alias, por lo que este método simplemente lanza una excepción.

Parámetros

alias

Una cadena abreviada para referirse a este archivo en el acceso con la envoltura de flujo phar. Este parámetro es ignorado.

Valores devueltos

Errores/Excepciones

Lanza una excepción de tipo PharException en todas las llamdas al método

Ver también

  • Phar::setAlias() - Establecer el alias para un archivo Phar


función sin sentido (Phar::setStub no es válido para PharData)

  • « PharData::setAlias
  • Phar::setMetadata »
  • PHP Manual
  • PharData
  • función sin sentido (Phar::setStub no es válido para PharData)

PharData::setDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setDefaultStub — función sin sentido (Phar::setStub no es válido para PharData)

Descripción

PharData::setDefaultStub ( string $index = ? , string $webindex = ? ) : bool

Los archivos tar/zip no ejecutables no pueden tener una rutina de interoperabilidad, por lo que este método simplemente lanza una excepción.

Parámetros

index

La ruta relativa dentro del archivo phar a ejectuar si se accede desde la línea de comandos

webindex

La ruta relativa dentro del archivo phar a ejectuar si se accede desde un servidor web

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo PharException en todas las llamadas al método

Ver también

  • Phar::setDefaultStub() - Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado


Establecer la metainformación de un archivo phar

  • « PharData::setDefaultStub
  • Phar::setSignatureAlgorithm »
  • PHP Manual
  • PharData
  • Establecer la metainformación de un archivo phar

Phar::setMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::setMetadata — Establecer la metainformación de un archivo phar

Descripción

public Phar::setMetadata ( mixed $metadata ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Phar::setMetadata() debería usarse para almacenar información personalizada que describa algo sobre el archivo phar como una entidad completa. PharFileInfo::setMetadata() debería usarse para metainformación específica de cada fichero. La metainformación puede ralentizar la velocidad de carga de un archivo phar si la información es grande.

Algunos posibles usos para la metainformación incluyen especificar qué fichero dentro del archivo debería usarse para cargar el archivo, o la ubicación de un fichero de manifiesto como el fichero package.xml de » PEAR. Sin embargo, se puede almacenar cualquier información útil que describa el archivo phar.

Parámetros

metadata

Cualquier variable de PHP que contenga la información a almacenar que describa el archivo phar

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de Phar::setMetadata()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.php'] = '<?php echo "hola"';
    $p->setMetadata(array('bootstrap' => 'fichero.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'No se pudo crear y/o modificar el phar:', $e;
}
?>

El resultado del ejemplo sería:

array(1) {
  ["bootstrap"]=>
  string(11) "fichero.php"
}

Ver también

  • Phar::getMetadata() - Devolver la metainformación de un archivo phar
  • Phar::delMetadata() - Eliminar la metainformación global del phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global


Establecer el algoritmo de firma para un phar y aplicarlo

  • « Phar::setMetadata
  • PharData::setStub »
  • PHP Manual
  • PharData
  • Establecer el algoritmo de firma para un phar y aplicarlo

Phar::setSignatureAlgorithm

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.1.0)

Phar::setSignatureAlgorithm — Establecer el algoritmo de firma para un phar y aplicarlo

Descripción

public Phar::setSignatureAlgorithm ( int $sigtype ) : void

Nota:

Este método requiere que la opción de php.ini phar.readonly esté establecida a 0 para que trabaje con objetos Phar. De otra manera, se lanzará una excepción de tipo PharException.

Establece el algoritmo de firma para un phar y lo aplica. El algoritmo de firma debe ser una de las constantes Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, o Phar::OPENSSL. (PGP aún no está soportado y se recurre a SHA-1).

Parámetros

sigtype

Una de las constantes Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, or Phar::PGP

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException para muchos errores, una excepción de tipo BadMethodCallException si se llamó para un archivo basao en zip o en tar, y una excepción de tipo PharException si ocurrió algún problema al volcar los cambios al disco.

Ver también

  • Phar::getSupportedSignatures() - Devolver un array con los tipos de firmas soportados
  • Phar::getSignature() - Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar


función sin sentido (Phar::setStub no es válido para PharData)

  • « Phar::setSignatureAlgorithm
  • PharFileInfo »
  • PHP Manual
  • PharData
  • función sin sentido (Phar::setStub no es válido para PharData)

PharData::setStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setStub — función sin sentido (Phar::setStub no es válido para PharData)

Descripción

PharData::setStub ( string $stub , int $len = -1 ) : bool

Los archivos tar/zip no ejecutables no pueden tener una rutina de interoperabilidad, por lo que este método simplemente lanza una excepción.

Parámetros

stub

Una cadena o un gestor de flujo abierto para usarlo como la rutina de interoperabilidad ejecutable de este archivo phar. Este parámetro es ignorado.

len

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo PharException en todas las llamadas al método

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro len.

Ver también

  • Phar::setStub() - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar


La clase PharFileInfo

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Introducción

La clase PharFileInfo proporciona una interfaz de alto nivel para el contenido y los atributos de un único fichero dentro de un archivo phar.

Sinopsis de la Clase

PharFileInfo extends SplFileInfo {
/* Métodos */
public chmod ( int $permissions ) : void
public compress ( int $compression ) : bool
public __construct ( string $entry )
public decompress ( ) : bool
public delMetadata ( ) : bool
public getCRC32 ( ) : int
public getCompressedSize ( ) : int
public getContent ( ) : string
public getMetadata ( ) : mixed
public getPharFlags ( ) : int
public hasMetadata ( ) : bool
public isCRCChecked ( ) : bool
public isCompressed ( int $compression_type = 9021976 ) : bool
public setMetadata ( mixed $metadata ) : void
}

Tabla de contenidos

  • PharFileInfo::chmod — Esteblecer los bits de permiso específicos del fichero
  • PharFileInfo::compress — Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • PharFileInfo::__construct — Construir un objeto de entrada Phar
  • PharFileInfo::decompress — Descomprimir la entrada Phar actual dentro del phar
  • PharFileInfo::delMetadata — Eliminar la metainformación de una entrada
  • PharFileInfo::getCRC32 — Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado
  • PharFileInfo::getCompressedSize — Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::getContent — Get the complete file contents of the entry
  • PharFileInfo::getMetadata — Devolver la metainformación específica de un fichero almacenada con un fichero
  • PharFileInfo::getPharFlags — Devolver las banderas de una entrada de fichero
  • PharFileInfo::hasMetadata — Devolver la metainformación de una entrada
  • PharFileInfo::isCRCChecked — Devolver si la entrada de fichero tiene su CRC verificada
  • PharFileInfo::isCompressed — Devolver si la entrada está comprimida
  • PharFileInfo::setMetadata — Establecer la metainformación específica de un fichero almacenda con un fichero


Esteblecer los bits de permiso específicos del fichero

  • « PharFileInfo
  • PharFileInfo::compress »
  • PHP Manual
  • PharFileInfo
  • Esteblecer los bits de permiso específicos del fichero

PharFileInfo::chmod

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::chmod — Esteblecer los bits de permiso específicos del fichero

Descripción

public PharFileInfo::chmod ( int $permissions ) : void

PharFileInfo::chmod() permite el ajuste del bit de permiso ejecutable de un fichero, así como el bit de sólo lectura. El bit de escritura se ignora, y se establece en tiempo de ejecución basándose en la variable INI phar.readonly. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto si el fichero está dentro de un archivo Phar. Los ficheros dentro de archivos PharData no tienen esta restricción.

Parámetros

permissions

Los permisos (véase chmod())

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::chmod()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar('nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.sh'] = '#!/usr/local/lib/php
    <?php echo "hi"; ?>';
    // establecer el bit ejecutable
    $p['fichero.sh']->chmod(0555);
    var_dump($p['fichero.sh']->isExecutable());
} catch (Exception $e) {
    echo 'No se pudo crear/modificar el phar: ', $e;
}
?>

El resultado del ejemplo sería:

bool(true)


Comprimir la entrada del Phar actual con la compresión zlib o bzip2

  • « PharFileInfo::chmod
  • PharFileInfo::__construct »
  • PHP Manual
  • PharFileInfo
  • Comprimir la entrada del Phar actual con la compresión zlib o bzip2

PharFileInfo::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharFileInfo::compress — Comprimir la entrada del Phar actual con la compresión zlib o bzip2

Descripción

public PharFileInfo::compress ( int $compression ) : bool

Este método comprime el fichero dentro de un archivo Phar usando la compresión bzip2 o zlib. Las extensiones bzip2 o zlib deben estar habilitadas para aprovechar esta característica. Además, si el fichero ya está comprimido, la extensión respectiva debe estar habilitada para poder descomprimir el fichero. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto si el fichero está dentro de un archivo Phar. Los ficheros dentro de archivos PharData no tienen esta restricción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión bzip2/zlib no está disponible.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::compress()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    var_dump($fichero->isCompressed(Phar::BZ2));
    $p['mifichero.txt']->compress(Phar::BZ2);
    var_dump($fichero->isCompressed(Phar::BZ2));
} catch (Exception $e) {
    echo 'Falló la operación de crear/modificar mi.phar: ', $e;
}
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados


Construir un objeto de entrada Phar

  • « PharFileInfo::compress
  • PharFileInfo::decompress »
  • PHP Manual
  • PharFileInfo
  • Construir un objeto de entrada Phar

PharFileInfo::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::__construct — Construir un objeto de entrada Phar

Descripción

public PharFileInfo::__construct ( string $entry )

Este método no debería llamarse directamente. En su lugar, un objeto de la clase PharFileInfo se inicializa al llamar a Phar::offsetGet() a traves del acceso a un array.

Parámetros

entry

La URL completa para recuperar un fichero. Si se desea recuperar la informacion del fichoer mi/fichero.php desde el phar boo.phar, la entrada debería ser phar://boo.phar/mi/fichero.php.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si __construct() es llamado dos veces. Lanza una excepción de tipo UnexpectedValueException si la URL del phar solicitado está malformada, el phar solicitado no se puede abrir, o el fichero no se puede encontrar dentro del phar.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::__construct()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['fichero_prueba.txt'] = "hola\nqué tal\namigo";
    $fichero = $p['fichero_prueba.txt'];
    foreach ($fichero as $línea => $texto) {
        echo "línea número $línea: $texto";
    }
    // esto también funciona
    $fichero = new PharFileInfo('phar:///ruta/a/mi.phar/fichero_prueba.txt');
    foreach ($fichero as $línea => $texto) {
        echo "línea número $línea: $texto";
    }
} catch (Exception $e) {
    echo 'Las operaciones Phar fallaron: ', $e;
}
?>

El resultado del ejemplo sería:

línea número 1: hola
línea número 2: qué tal
línea número 3: amigo
línea número 1: hola
línea número 2: qué tal
línea número 3: amigo


Descomprimir la entrada Phar actual dentro del phar

  • « PharFileInfo::__construct
  • PharFileInfo::delMetadata »
  • PHP Manual
  • PharFileInfo
  • Descomprimir la entrada Phar actual dentro del phar

PharFileInfo::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharFileInfo::decompress — Descomprimir la entrada Phar actual dentro del phar

Descripción

public PharFileInfo::decompress ( ) : bool

Este método descompribe el fichero dentro de un archivo Phar. Dependiendo de cómo esté comprimido el fichero, las extensiones bzip2 o zlib deben estar habilitadas para aprovechar esta característica. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto si el fichero está dentro de un archivo Phar. Los ficheros dentro de archivos PharData no tienen esta restricción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si la variable INI phar.readonly está activada, la extensión bzip2/zlib no está disponible.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::decompress()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    $fichero->compress(Phar::GZ);
    var_dump($fichero->isCompressed());
    $p['mifichero.txt']->decompress();
    var_dump($fichero->isCompressed());
} catch (Exception $e) {
    echo 'La operación de crear/modificar mi.phar falló: ', $e;
}
?>

El resultado del ejemplo sería:

int(4096)
bool(false)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados


Eliminar la metainformación de una entrada

  • « PharFileInfo::decompress
  • PharFileInfo::getCRC32 »
  • PHP Manual
  • PharFileInfo
  • Eliminar la metainformación de una entrada

PharFileInfo::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

PharFileInfo::delMetadata — Eliminar la metainformación de una entrada

Descripción

public PharFileInfo::delMetadata ( ) : bool

Eliminar la metainformación de una entrada, si existe.

Parámetros

No parameters.

Valores devueltos

Devuelve true en caso de éxito, false si la entrada no tiene metainformación. Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto si el fichero está dentro de un archivo Phar. Los ficheros dentro de archivos PharData no tienen esta restricción.

Errores/Excepciones

Lanza una excepción de tipo PharException si ocurrió algún error al volcar los cambios al disco, y una excepción de tipo BadMethodCallException si el acceso a escritura está deshabilitado.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::delMetaData()

<?php
try {
    $a = new Phar('miphar.phar');
    $a['hola'] = 'hola';
    var_dump($a['hola']->delMetadata());
    $a['hola']->setMetadata('qué tal');
    var_dump($a['hola']->delMetadata());
    var_dump($a['hola']->delMetadata());
} catch (Exception $e) {
    // manejar errores
}
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)

Ver también

  • PharFileInfo::setMetadata() - Establecer la metainformación específica de un fichero almacenda con un fichero
  • PharFileInfo::hasMetadata() - Devolver la metainformación de una entrada
  • PharFileInfo::getMetadata() - Devolver la metainformación específica de un fichero almacenada con un fichero
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global
  • Phar::getMetadata() - Devolver la metainformación de un archivo phar


Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado

  • « PharFileInfo::delMetadata
  • PharFileInfo::getCompressedSize »
  • PHP Manual
  • PharFileInfo
  • Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado

PharFileInfo::getCRC32

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getCRC32 — Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado

Descripción

public PharFileInfo::getCRC32 ( ) : int

Este método devuelve la suma de verificación crc32() del fichero dentro de un archivo Phar.

Valores devueltos

La suma de verificaicón crc32() de un fichero dentro de un archivo Phar.

Errores/Excepciones

Lanza una excepción de tipo BadMethodCallException si el fichero no tiene aún su CRC32 verificado. Esto sería imposible con un uso normal, ya que la CRC es verificada al abrir el fichero para lectura o escritura.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::getCRC32()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    echo $fichero->getCRC32();
} catch (Exception $e) {
    echo 'Las operaciones de escritura sobre mi.phar.phar fallaron: ', $e;
}
?>

El resultado del ejemplo sería:

1872820616


Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar

  • « PharFileInfo::getCRC32
  • PharFileInfo::getContent »
  • PHP Manual
  • PharFileInfo
  • Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar

PharFileInfo::getCompressedSize

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getCompressedSize — Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar

Descripción

public PharFileInfo::getCompressedSize ( ) : int

Devuelve el tamaño del fichero dentro del archivo Phar. Los ficheros no comprimidos devolverán el mismo valor que si se utilizara filesize() en vez de filesize()

Valores devueltos

El tamaño en bytes del fichero dentro del archivo Phar en disco.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::getCompressedSize()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    echo $fichero->getCompressedSize();
} catch (Exception $e) {
    echo 'Las operaciones de escritura sobre mi.phar fallaron: ', $e;
}
?>

El resultado del ejemplo sería:

2

Ver también

  • PharFileInfo::isCompressed() - Devolver si la entrada está comprimida
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual


Get the complete file contents of the entry

  • « PharFileInfo::getCompressedSize
  • PharFileInfo::getMetadata »
  • PHP Manual
  • PharFileInfo
  • Get the complete file contents of the entry

PharFileInfo::getContent

(PHP 5 >= 5.3.0, PHP 7)

PharFileInfo::getContent — Get the complete file contents of the entry

Descripción

public PharFileInfo::getContent ( ) : string

This function behaves like file_get_contents() but for Phar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the file contents.


Devolver la metainformación específica de un fichero almacenada con un fichero

  • « PharFileInfo::getContent
  • PharFileInfo::getPharFlags »
  • PHP Manual
  • PharFileInfo
  • Devolver la metainformación específica de un fichero almacenada con un fichero

PharFileInfo::getMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getMetadata — Devolver la metainformación específica de un fichero almacenada con un fichero

Descripción

public PharFileInfo::getMetadata ( ) : mixed

Devuelve la metainformación que fue almacenada en el manifiesto del archivo Phar para este fichero.

Parámetros

Valores devueltos

Cualquier variable de PHP que pueda ser serializada y almacenada como metainformación del fichero, o null si no hay metainformación almacenada.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::getMetadata()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.txt'] = 'hello';
    $p['fichero.txt']->setMetadata(array('usuario' => 'bill', 'tipo-mime' => 'text/plain'));
    var_dump($p['fichero.txt']->getMetadata());
} catch (Exception $e) {
    echo 'No se pudo crear y/o modificar nuevo_phar.phar:', $e;
}
?>

El resultado del ejemplo sería:

array(2) {
  ["usuario"]=>
  string(4) "bill"
  ["tipo-mime"]=>
  string(10) "text/plain"
}

Ver también

  • PharFileInfo::setMetadata() - Establecer la metainformación específica de un fichero almacenda con un fichero
  • PharFileInfo::hasMetadata() - Devolver la metainformación de una entrada
  • PharFileInfo::delMetadata() - Eliminar la metainformación de una entrada
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global
  • Phar::getMetadata() - Devolver la metainformación de un archivo phar


Devolver las banderas de una entrada de fichero

  • « PharFileInfo::getMetadata
  • PharFileInfo::hasMetadata »
  • PHP Manual
  • PharFileInfo
  • Devolver las banderas de una entrada de fichero

PharFileInfo::getPharFlags

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getPharFlags — Devolver las banderas de una entrada de fichero

Descripción

public PharFileInfo::getPharFlags ( ) : int

Este método devuelve las banderas establecidas en el manifiesto de un Phar. Siempre devolverá 0 en la implementacion actual.

Valores devueltos

Las banderas del Phar (siempre 0 en la implementacion actual)

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::getPharFlags()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    var_dump($fichero->getPharFlags());
} catch (Exception $e) {
    echo 'No se pudo crear/modificar my.phar: ', $e;
}
?>

El resultado del ejemplo sería:

int(0)


Devolver la metainformación de una entrada

  • « PharFileInfo::getPharFlags
  • PharFileInfo::isCRCChecked »
  • PHP Manual
  • PharFileInfo
  • Devolver la metainformación de una entrada

PharFileInfo::hasMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

PharFileInfo::hasMetadata — Devolver la metainformación de una entrada

Descripción

public PharFileInfo::hasMetadata ( ) : bool

Devuelve la metainformación de una fichero dentro de un archivo phar.

Parámetros

No tiene parámetros.

Valores devueltos

Devuelve false si no está establecida la metainformación o es null, true si la metainformación no es null

Ver también

  • PharFileInfo::setMetadata() - Establecer la metainformación específica de un fichero almacenda con un fichero
  • PharFileInfo::getMetadata() - Devolver la metainformación específica de un fichero almacenada con un fichero
  • PharFileInfo::delMetadata() - Eliminar la metainformación de una entrada
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global
  • Phar::getMetadata() - Devolver la metainformación de un archivo phar


Devolver si la entrada de fichero tiene su CRC verificada

  • « PharFileInfo::hasMetadata
  • PharFileInfo::isCompressed »
  • PHP Manual
  • PharFileInfo
  • Devolver si la entrada de fichero tiene su CRC verificada

PharFileInfo::isCRCChecked

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::isCRCChecked — Devolver si la entrada de fichero tiene su CRC verificada

Descripción

public PharFileInfo::isCRCChecked ( ) : bool

Este método devuelve si un fichero dentro de un archivo Phar tiene su CRC verificada.

Valores devueltos

true si el fichero tiene su CRC verificada, false si no.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::isCRCChecked()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $fichero = $p['mifichero.txt'];
    var_dump($fichero->isCRCChecked());
} catch (Exception $e) {
    echo 'Las operaciones de creación/modificación sobre mi.phar fallaron: ', $e;
}
?>

El resultado del ejemplo sería:

bool(true)


Devolver si la entrada está comprimida

  • « PharFileInfo::isCRCChecked
  • PharFileInfo::setMetadata »
  • PHP Manual
  • PharFileInfo
  • Devolver si la entrada está comprimida

PharFileInfo::isCompressed

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::isCompressed — Devolver si la entrada está comprimida

Descripción

public PharFileInfo::isCompressed ( int $compression_type = 9021976 ) : bool

Este método devuelve si un fichero está comprimido dentro de un archivo Phar con la compresión Gzip o Bzip2.

Parámetros

compression_type

Una de las constantes Phar::GZ o Phar::BZ2, por defecto es cualquier compresión.

Valores devueltos

true si el fichero está comprimido dentro del archivo Phar, false si no.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::isCompressed()

<?php
try {
    $p = new Phar('/ruta/a/mi.phar', 0, 'mi.phar');
    $p['mifichero.txt'] = 'hola';
    $p['mifichero2.txt'] = 'hola';
    $p['mifichero2.txt']->setCompressedGZ();
    $fichero = $p['mifichero.txt'];
    $fichero2 = $p['mifichero2.txt'];
    var_dump($fichero ->isCompressed());
    var_dump($fichero 2->isCompressed());
} catch (Exception $e) {
    echo 'La creación/modificación del phar mi.phar falló: ', $e;
}
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • PharFileInfo::getCompressedSize() - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
  • PharFileInfo::decompress() - Descomprimir la entrada Phar actual dentro del phar
  • PharFileInfo::compress() - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
  • Phar::decompress() - Descomprimir un archivo Phar entero
  • Phar::compress() - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
  • Phar::canCompress() - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
  • Phar::isCompressed() - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
  • Phar::getSupportedCompression() - Devolver un array de los algoritmos de compresión soportados
  • Phar::decompressFiles() - Descomprimir todos los ficheros del archivo Phar actual
  • Phar::compressFiles() - Comprime todos los ficheros del archivo Phar actual


Establecer la metainformación específica de un fichero almacenda con un fichero

  • « PharFileInfo::isCompressed
  • PharException »
  • PHP Manual
  • PharFileInfo
  • Establecer la metainformación específica de un fichero almacenda con un fichero

PharFileInfo::setMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::setMetadata — Establecer la metainformación específica de un fichero almacenda con un fichero

Descripción

public PharFileInfo::setMetadata ( mixed $metadata ) : void

PharFileInfo::setMetadata() solamente debería usarse para almacenar información personalizada en un fichero que con pueda ser representado con la información almacenada existente con un fichero. La metainformación puede ralentizar significativamente la velocidad de carga de un archivo phar si la información es grande, o si existen muchos ficheros que contienen metainformación. Es importante observar que esos permisos de fichero están soportados nativamente dentro de un phar; es posible establecerlo con el método PharFileInfo::chmod(). Al igual que con toda la funcionalidad que modifica el contenido de un Phar, la variable INI phar.readonly debe estar desactivada para poder realizar esto si el fichero está dentro de un archivo Phar. Los ficheros dentro de archivos PharData no tienen esta restricción.

Algunos posibles usos para la metainformación incluten pasar un usuario/grupo que debería establecerse al extraer el fichero desde el phar al disco. Otros usos podrían incluir explicitamente especificar un tipo MIME a devolver. Sin embargo, cualquier información útil que describa un fichero, excepto la que no debería estar contenida dentro del mismo, puede ser almacenada.

Parámetros

metadata

Cualquier variable de PHP que contenga información a almacenar junto a un fichero

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de PharFileInfo::setMetadata()

<?php
// asegurarse de que no existe
@unlink('nuevo_phar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/nuevo_phar.phar', 0, 'nuevo_phar.phar');
    $p['fichero.txt'] = 'hola';
    $p['fichero.txt']->setMetadata(array('usuario' => 'bill', 'tipo-mime' => 'text/plain'));
    var_dump($p['fichero.txt']->getMetadata());
} catch (Exception $e) {
    echo 'No se pudo crear y/o modificar el phar:', $e;
}
?>

El resultado del ejemplo sería:

array(2) {
  ["usuario"]=>
  string(4) "bill"
  ["tipo-mime"]=>
  string(10) "text/plain"
}

Ver también

  • PharFileInfo::hasMetadata() - Devolver la metainformación de una entrada
  • PharFileInfo::getMetadata() - Devolver la metainformación específica de un fichero almacenada con un fichero
  • PharFileInfo::delMetadata() - Eliminar la metainformación de una entrada
  • Phar::setMetadata() - Establecer la metainformación de un archivo phar
  • Phar::hasMetadata() - Devolver si el phar tiene metainformación global
  • Phar::getMetadata() - Devolver la metainformación de un archivo phar


La clase PharException

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Introducción

La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch.

Sinopsis de la Clase

PharException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Tabla de contenidos

  • PharException — La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch


La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch

  • « PharException
  • Rar »
  • PHP Manual
  • PharException
  • La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch

PharException

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharException — La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch

Descripción


Archivos Rar

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones Rar
    • rar_wrapper_cache_stats — Caché de aciertos y errores del URL wrapper
  • RarArchive — La clase RarArchive
    • RarArchive::close — Cerrar archivo RAR y liberar todos los recursos
    • RarArchive::getComment — Obtener comentarios de texto desde el archivo RAR
    • RarArchive::getEntries — Obtener la lista completa de entradas del archivo RAR
    • RarArchive::getEntry — Obtener el objeto entrada desde el archivo RAR
    • RarArchive::isBroken — Comprobar si un archivo está dañado (incompleto)
    • RarArchive::isSolid — Comprueba si el archivo RAR es sólido
    • RarArchive::open — Abre un archivo RAR
    • RarArchive::setAllowBroken — Determina si la apertura de archivos dañados se permite
    • RarArchive::__toString — Obtener representación de texto
  • RarEntry — La clase RarEntry
    • RarEntry::extract — Extraer entrada del archivo
    • RarEntry::getAttr — Obtener los atributos de la entrada
    • RarEntry::getCrc — Obtener el CRC de la entrada
    • RarEntry::getFileTime — Devolver entrada última fecha de modificación
    • RarEntry::getHostOs — Obtener sistema operativo anfitrión del archivo de entrada
    • RarEntry::getMethod — Obtener método pack de la entrada
    • RarEntry::getName — Obtener el nombre de la entrada
    • RarEntry::getPackedSize — Obtiene el tamaño empaquetado de la entrada
    • RarEntry::getStream — Obtener manejador de archivo para entrada
    • RarEntry::getUnpackedSize — Obtener el tamaño descomprimido de la entrada
    • RarEntry::getVersion — Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada
    • RarEntry::isDirectory — Comprobar si una entrada representa un directorio
    • RarEntry::isEncrypted — Comprobar si una entrada está cifrada
    • RarEntry::__toString — Obtener texto representación de entrada
  • RarException — La clase RarException
    • RarException::isUsingExceptions — Comprobar si el manejador de errores con excepciones está en uso
    • RarException::setUsingExceptions — Activar y desactivar el manejador de errores con excepciones


Introducción

Rar es un potente y eficaz archivador creado por Eugene Roshal. Esta extensión proporciona la posibilidad de leer archivos Rar, pero no soporta la escritura de los mismos, ya que no es compatible con la biblioteca UnRar y está directamente prohibido por su licencia.

Se puede encontrar más información sobre Rar y UnRar en » http://www.rarlabs.com/.


Instalación

Rar está actualmente disponible a través de PECL » https://pecl.php.net/package/rar.

También puede usar el instalador PECL para instalar la extensión Rar, utilizando el siguiente comando: pecl -v install rar.

Siempre puede descargar el paquete tar.gz e instalar Rar a mano:

Ejemplo #1 Instalación Rar

gunzip rar-xxx.tgz
tar -xvf rar-xxx.tar
cd rar-xxx
phpize
./configure && make && make install

Los usuarios de Windows habilitarán php_rar.dll en el interior de php.ini con el fin de utilizar estas funciones. Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Tipos de recursos

Esta extensión registra tres clases internas: Las representaciones de archivo devuelto por rar_open() – RarArchive –, las representaciones de entrada devuelto por rar_list() y rar_entry_get() – RarEntry y el tipo de excepción RarException.

Esta extensión también registra un recurso de secuencia, llamado "rar" y una envoltura URL llamada "envoltura rar" y registrada bajo el prefijo "rar".


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

RAR_HOST_MSDOS (integer)
Use RarEntry::HOST_MSDOS en su lugar.
RAR_HOST_OS2 (integer)
Use RarEntry::HOST_OS2 en su lugar.
RAR_HOST_WIN32 (integer)
Use RarEntry::HOST_WIN32 en su lugar.
RAR_HOST_UNIX (integer)
Use RarEntry::HOST_UNIX en su lugar.
RAR_HOST_BEOS (integer)
Use RarEntry::HOST_BEOS en su lugar.


Ejemplos

Ver también rar://.

Ejemplo #1 Descompresión "al vuelo"

<?php

if (!array_key_exists("i", $_GET) || !is_numeric($_GET["i"]))
    die("Index unspecified or non-numeric");
$index = (int) $_GET["i"];

$arch = RarArchive::open("example.rar");
if ($arch === FALSE)
    die("Cannot open example.rar");

$entries = $arch->getEntries();
if ($entries === FALSE)
    die("Cannot retrieve entries");

if (!array_key_exists($index, $entries))
    die("No such index: $index");

$orfilename = $entries[$index]->getName(); //UTF-8 encoded

$filesize = $entries[$index]->getUnpackedSize();

/* you could check HTTP_IF_MODIFIED_SINCE here and compare with
 * $entries[$index]->getFileTime(). You could also send a
 * "Last modified" header */

$fp = $entries[$index]->getStream();
if ($fp === FALSE)
    die("Cannot open file with index $index insided the archive.");

$arch->close(); //no longer needed; stream is independent

function detectUserAgent() {
    if (!array_key_exists('HTTP_USER_AGENT', $_SERVER))
        return "Other";

    $uas = $_SERVER['HTTP_USER_AGENT'];
    if (preg_match("@Opera/@", $uas))
        return "Opera";
    if (preg_match("@Firefox/@", $uas))
        return "Firefox";
    if (preg_match("@Chrome/@", $uas))
        return "Chrome";
    if (preg_match("@MSIE ([0-9.]+);@", $uas, $matches)) {
        if (((float)$matches[1]) >= 7.0)
            return "IE";
    }

    return "Other";
}

/*
 * We have 3 options:
 * - For FF and Opera, which support RFC 2231, use that format.
 * - For IE and Chrome, use attwithfnrawpctenclong
 *   (http://greenbytes.de/tech/tc2231/#attwithfnrawpctenclong)
 * - For the others, convert to ISO-8859-1, if possible
 */
$formatRFC2231 = 'Content-Disposition: attachment; filename*=UTF-8\'\'%s';
$formatDef = 'Content-Disposition: attachment; filename="%s"';

switch (detectUserAgent()) {
    case "Opera":
    case "Firefox":
        $orfilename = rawurlencode($orfilename);
        $format = $formatRFC2231;
        break;

    case "IE":
    case "Chrome":
        $orfilename = rawurlencode($orfilename);
        $format = $formatDef;
        break;
    default:
        if (function_exists('iconv'))
            $orfilename =
                @iconv("UTF-8", "ISO-8859-1//TRANSLIT", $orfilename);
        $format = $formatDef;
}

header(sprintf($format, $orfilename));
//cannot send error messages from now on (headers already sent)

//replace by real content type, perhaps infering from the file extension
$contentType = "application/octet-stream";
header("Content-Type: $contentType");

header("Content-Transfer-Encoding: binary");

header("Content-Length: $filesize");

if ($_SERVER['REQUEST_METHOD'] == "HEAD")
    die();

while (!feof($fp)) {
    $s = @fread($fp, 8192);
    if ($s === false)
        break; //useless to send error messages

    echo $s;
}
?>

En este ejemplo se obtiene el archivo que contiene el archivo RAR y se ofrece para descargar.

Ejemplo #2 Ejemplo de sistema de extracción de archivos Rar

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entries = rar_list($rar_file);

foreach ($entries as $entry) {
    echo 'Filename: ' . $entry->getName() . "\n";
    echo 'Packed size: ' . $entry->getPackedSize() . "\n";
    echo 'Unpacked size: ' . $entry->getUnpackedSize() . "\n";

    $entry->extract('/dir/extract/to/');
}

rar_close($rar_file);

?>

Este ejemplo extrae cada archivo del archivo Rar en el directorio especificado.


Funciones Rar

Tabla de contenidos

  • rar_wrapper_cache_stats — Caché de aciertos y errores del URL wrapper


Caché de aciertos y errores del URL wrapper

  • « Funciones Rar
  • RarArchive »
  • PHP Manual
  • Funciones Rar
  • Caché de aciertos y errores del URL wrapper

rar_wrapper_cache_stats

(PECL rar >= 3.0.0)

rar_wrapper_cache_stats — Caché de aciertos y errores del URL wrapper

Descripción

rar_wrapper_cache_stats ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase RarArchive

(PECL rar >= 2.0.0)

Introducción

Esta clase representa un archivo RAR que puede estar formado por varios volúmenes (partes) y que contiene una serie de entradas RAR (por ejemplo: archivos, directorios y otros objetos especiales, como enlaces simbólicos).

Los objetos de esta clase puede ser atravesado, dando las entradas almacenadas en el archivo RAR respectivamente. Estas entradas también pueden ser obtenidas mediante RarArchive::getEntry() y RarArchive::getEntries().

Sinopsis de la Clase

final RarArchive implements Traversable {
/* Métodos */
public close ( ) : bool
public getComment ( ) : string
public getEntries ( ) : array
public getEntry ( string $entryname ) : RarEntry
public isBroken ( ) : bool
public isSolid ( ) : bool
public static open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive
public setAllowBroken ( bool $allow_broken ) : bool
public __toString ( ) : string
}

Tabla de contenidos

  • RarArchive::close — Cerrar archivo RAR y liberar todos los recursos
  • RarArchive::getComment — Obtener comentarios de texto desde el archivo RAR
  • RarArchive::getEntries — Obtener la lista completa de entradas del archivo RAR
  • RarArchive::getEntry — Obtener el objeto entrada desde el archivo RAR
  • RarArchive::isBroken — Comprobar si un archivo está dañado (incompleto)
  • RarArchive::isSolid — Comprueba si el archivo RAR es sólido
  • RarArchive::open — Abre un archivo RAR
  • RarArchive::setAllowBroken — Determina si la apertura de archivos dañados se permite
  • RarArchive::__toString — Obtener representación de texto


Cerrar archivo RAR y liberar todos los recursos

  • « RarArchive
  • RarArchive::getComment »
  • PHP Manual
  • RarArchive
  • Cerrar archivo RAR y liberar todos los recursos

RarArchive::close

rar_close

(PECL rar >= 2.0.0)

RarArchive::close -- rar_close — Cerrar archivo RAR y liberar todos los recursos

Descripción

Estilo orientado a objetos (método):

public RarArchive::close ( ) : bool

Estilo por procedimientos:

rar_close ( RarArchive $rarfile ) : bool

Cerar archivo RAR y liberar todos los recursos asignados.

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
2.0.0 | Las entradas RAR devueltas por RarArchive::getEntry() y RarArchive::getEntries() son ahora invalidadas cuando se llama a este método. Esto significa que todos los métodos de instancia llamados por tales entradas y no garantizan el éxito.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

El resultado del ejemplo sería algo similar a:

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)

Ejemplo #2 Estilo por procedimientos

<?php
$rar_arch = rar_open('latest_winrar.rar');
echo $rar_arch."\n";
rar_close($rar_arch);
echo $rar_arch."\n";
?>


Obtener comentarios de texto desde el archivo RAR

  • « RarArchive::close
  • RarArchive::getEntries »
  • PHP Manual
  • RarArchive
  • Obtener comentarios de texto desde el archivo RAR

RarArchive::getComment

rar_comment_get

(PECL rar >= 2.0.0)

RarArchive::getComment -- rar_comment_get — Obtener comentarios de texto desde el archivo RAR

Descripción

Estilo orientado a objetos (method):

public RarArchive::getComment ( ) : string

Estilo por procedimientos:

rar_comment_get ( RarArchive $rarfile ) : string

Obtener (global) comentario almacenado en el archivo RAR. Este puede ser de hasta 64 KiB de longitud.

Nota:

Esta extensión no es compatible con los comentarios en el nivel de entrada.

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

Valores devueltos

Devuelve el comentario o null si no hay ninguno.

Nota:

RAR no tiene actualmente soporte para comentarios unicode. La codificación de los resultados de esta función no es especificado, pero esta debe ser probablemente Windows-1252.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$rar_arch = RarArchive::open('commented.rar');
echo $rar_arch->getComment();
?>

El resultado del ejemplo sería algo similar a:

This is the comment of the file commented.rar.

Ejemplo #2 Estilo por procedimientos

<?php
$rar_arch = rar_open('commented.rar');
echo rar_comment_get($rar_arch);
?>


Obtener la lista completa de entradas del archivo RAR

  • « RarArchive::getComment
  • RarArchive::getEntry »
  • PHP Manual
  • RarArchive
  • Obtener la lista completa de entradas del archivo RAR

RarArchive::getEntries

rar_list

(PECL rar >= 2.0.0)

RarArchive::getEntries -- rar_list — Obtener la lista completa de entradas del archivo RAR

Descripción

Estilo orientado a objetos (método):

public RarArchive::getEntries ( ) : array

Estilo por procedimientos:

rar_list ( RarArchive $rarfile ) : array

Obtener la lista de entradas (archivos y directorios) de el archivo RAR.

Nota:

Si el archivo tiene entradas con el mismo nombre, este método, junto con RarArchive foreach iteraciona y otorga un acceso array-like con índices numéricos, únicos para acceder a todas las entradas (por ejemplo, RarArchive::getEntry() y el rar:// wrapper son insuficientes).

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

Valores devueltos

rar_list() devuelve array de objetos RarEntry o false en caso de error.

Historial de cambios

Versión | Descripción
3.0.0 | Soporte para archivos RAR con nombres entrada repetidos que ya no produce deficiencias.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = $rar_arch->getEntries();
if ($rar_entries === FALSE)
    die("Could retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
$rar_arch->close();
?>

El resultado del ejemplo sería algo similar a:

Found 2 entries.
RarEntry for file "tese.txt" (23b93a7a)
RarEntry for file "unrardll.txt" (2ed64b6e)

Ejemplo #2 Estilo por procedimientos

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = rar_list($rar_arch);
if ($rar_entries === FALSE)
    die("Could retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
rar_close($rar_arch);
?>

Ver también

  • RarArchive::getEntry() - Obtener el objeto entrada desde el archivo RAR
  • rar:// wrapper


Obtener el objeto entrada desde el archivo RAR

  • « RarArchive::getEntries
  • RarArchive::isBroken »
  • PHP Manual
  • RarArchive
  • Obtener el objeto entrada desde el archivo RAR

RarArchive::getEntry

rar_entry_get

(PECL rar >= 2.0.0)

RarArchive::getEntry -- rar_entry_get — Obtener el objeto entrada desde el archivo RAR

Descripción

Estilo orientado a objetos (método):

public RarArchive::getEntry ( string $entryname ) : RarEntry

Estilo por procedimientos:

rar_entry_get ( RarArchive $rarfile , string $entryname ) : RarEntry

Obtener el objeto entrada (archivo o directorio) desde el archivo RAR.

Nota:

También puede obtener objetos de entrada utilizando RarArchive::getEntries().

Tenga en cuenta que un archivo RAR puede tener varias entradas con el mismo nombre; este método recuperará sólo el primero.

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

entryname

Ruta a la entrada dentro del archivo RAR.

Nota:

La ruta debe ser la misma devuelta por RarEntry::getName().

Valores devueltos

Devuelve el objeto RarEntry encontrado o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = $rar_arch->getEntry('tese.txt');
if ($rar_entry === FALSE)
    die("Could get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
$rar_arch->close();
?>

El resultado del ejemplo sería algo similar a:

RarEntry
RarEntry for file "tese.txt" (23b93a7a)

Ejemplo #2 Estilo por procedimientos

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = rar_entry_get($rar_arch, 'tese.txt');
if ($rar_entry === FALSE)
    die("Could get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
rar_close($rar_arch);
?>

Ver también

  • RarArchive::getEntries() - Obtener la lista completa de entradas del archivo RAR
  • rar:// wrapper


Comprobar si un archivo está dañado (incompleto)

  • « RarArchive::getEntry
  • RarArchive::isSolid »
  • PHP Manual
  • RarArchive
  • Comprobar si un archivo está dañado (incompleto)

RarArchive::isBroken

rar_broken_is

(PECL rar >= 3.0.0)

RarArchive::isBroken -- rar_broken_is — Comprobar si un archivo está dañado (incompleto)

Descripción

Estilo orientado a objetos (método):

public RarArchive::isBroken ( ) : bool

Estilo por procedimientos:

rar_broken_is ( RarArchive $rarfile ) : bool

Esta función determina si un archivo está incompleto, por ejemplo, Si un volumen no se encuentra o un volumen está truncado.

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

Valores devueltos

Devuelve true si el archivo está dañado, false en caso contrario. Esta función puede también devolver false si el archivo pasado fue cerrado. La única manera para poder distinguir aparte ambos casos es habilitando y permitiendo excepciones con RarException::setUsingExceptions(); sin embargo, esto debería ser innecesario, ya que un programa no debe funcionar con archivos cerrados.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* El tercer argumento es utilizado para omitir avisos */
$arch = RarArchive::open($file, null, 'retnull');
var_dump($arch->isBroken());
?>

El resultado del ejemplo sería algo similar a:

bool(true)

Ejemplo #2 Estilo por procedimientos

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* El tercer argumento es utilizado para omitir avisos */
$arch = rar_open($file, null, 'retnull');
var_dump(rar_broken_is($arch));
?>

Ver también

  • RarArchive::setAllowBroken() - Determina si la apertura de archivos dañados se permite


Comprueba si el archivo RAR es sólido

  • « RarArchive::isBroken
  • RarArchive::open »
  • PHP Manual
  • RarArchive
  • Comprueba si el archivo RAR es sólido

RarArchive::isSolid

rar_solid_is

(PECL rar >= 2.0.0)

RarArchive::isSolid -- rar_solid_is — Comprueba si el archivo RAR es sólido

Descripción

Estilo orientado a objetos (método):

public RarArchive::isSolid ( ) : bool

Estilo por procedimientos:

rar_solid_is ( RarArchive $rarfile ) : bool

Comprueba si el archivo RAR es sólido. La extracción individual de ficheros es más lenta en archivos sólidos.

Parámetros

rarfile

La instancia del RarArchive, abierto con rar_open().

Valores devueltos

Devuelve true si el archivo es sólido, de lo contrario retorna false.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$arch1 = RarArchive::open("store_method.rar");
$arch2 = RarArchive::open("solid.rar");
echo "$arch1: " . ($arch1->isSolid()?'yes':'no') ."\n";
echo "$arch2: " . ($arch2->isSolid()?'yes':'no') . "\n";
?>

El resultado del ejemplo sería algo similar a:

RAR Archive "C:\php_rar\trunk\tests\store_method.rar": no
RAR Archive "C:\php_rar\trunk\tests\solid.rar": yes

Ejemplo #2 Estilo por procedimientos

<?php
$arch1 = rar_open("store_method.rar");
$arch2 = rar_open("solid.rar");
echo "$arch1: " . (rar_solid_is($arch1)?'yes':'no') ."\n";
echo "$arch2: " . (rar_solid_is($arch2)?'yes':'no') . "\n";
?>


Abre un archivo RAR

  • « RarArchive::isSolid
  • RarArchive::setAllowBroken »
  • PHP Manual
  • RarArchive
  • Abre un archivo RAR

RarArchive::open

rar_open

(PECL rar >= 2.0.0)

RarArchive::open -- rar_open — Abre un archivo RAR

Descripción

Estilo orientado a objetos (método):

public static RarArchive::open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive

Estilo por procedimientos:

rar_open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive

Abre un archivo RAR especificado y devuelve la instancia RarArchive que lo representa.

Nota:

Si el archivo a abrir esta dividido en volúmenes, se deberá pasar la ruta del primer volúmen como parámetro de la función. De lo contrario, no todos los archivos se mostraran.

Parámetros

filename

Ruta del archivo Rar.

password

Contraseña en texto plano, si fuera necesario descifrar la cabecera del archivo. También se utilizará por defecto si hay archivos encriptados encontrados. Tenga en cuenta que los archivos pueden poseer diferentes contraseñas en cuanto a las cabeceras y entre ellos.

volume_callback

Una función que recibe como parámetro la ruta del volúmen que no fue encontrado y retorna una cadena con la ruta correcta para dicho archivo o null si el volúmen no existe o no es conocido. El programador debería asegurar que la función pasada no cause bucles, ya que esta función es llamada repetidas veces si la ruta devuelta en una llamada previa no corresponde con el volúmen solicitado. Especificando este parámetro se omite la notice que se emitiría cuando un volúmen no es encontrado; una implementación que solo devuelva null puede, por lo tanto, utilizarce para omitir dichos notices.

Advertencia

En versiones menores a 2.0.0 de PHP, esta función no manejaria rutas relativas correctamente. Use realpath() como una solución.

Valores devueltos

Devuelve una instancia del RarArchive solicitado o false en caso de error.

Historial de cambios

Versión | Descripción
3.0.0 | volume_callback fue agregada.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$rar_arch = RarArchive::open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = $rar_arch->getEntries();
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

$rar_arch->close();

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

El resultado del ejemplo sería algo similar a:

Found 2 files.
Content of first one follows:
Encrypted file 1 contents.

Ejemplo #2 Estilo por procedimientos

<?php
$rar_arch = rar_open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = rar_list($rar_arch);
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

rar_close($rar_arch);

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

Ejemplo #3 Volume Callback

<?php
/* En este ejemplo, hay un volúmen llamdo multi_broken.part1.rar
 * cuyo próximo volúmen es llamado multi.part2.rar */
function resolve($vol) {
    if (preg_match('/_broken/', $vol))
        return str_replace('_broken', '', $vol);
    else
        return null;
}
$rar_file1 = rar_open(dirname(__FILE__).'/multi_broken.part1.rar', null, 'resolve');
$entry = $rar_file1->getEntry('file2.txt');
$entry->extract(null, dirname(__FILE__) . "/temp_file2.txt");
?>

Ver también

  • rar:// wrapper


Determina si la apertura de archivos dañados se permite

  • « RarArchive::open
  • RarArchive::__toString »
  • PHP Manual
  • RarArchive
  • Determina si la apertura de archivos dañados se permite

RarArchive::setAllowBroken

(PECL rar >= 3.0.0)

RarArchive::setAllowBroken — Determina si la apertura de archivos dañados se permite

Descripción

Estilo orientado a objetos (method):

public RarArchive::setAllowBroken ( bool $allow_broken ) : bool

Estilo por procedimientos:

rar_allow_broken_set ( RarArchive $rarfile , bool $allow_broken ) : bool

Este método determina si los archivos dañados pueden ser leidos o todas las operaciones que intenten extraer el archivo de las entradas producirán un error. Los archivos rotos son archivos para los cuales ningún error es detectado cuando el archivo es abierto pero un error se produce cuando leemos las entradas.

Parámetros

rarfile

Un objeto RarArchive, abierto con rar_open().

allow_broken

Determina si se permite la lectura de archivos dañados (true) o no (false).

Valores devueltos

Devuelve true o false en caso de error. Sólo se producirá un error si el archivo ya fue cerrado.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* El tercer argumento omite el mensaje "volumen no encontrado" */
$a = RarArchive::open($file, null, 'retnull');
$a->setAllowBroken(true);
foreach ($a->getEntries() as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

El resultado del ejemplo sería algo similar a:

RarEntry for file "file1.txt" (52b28202)
int(1)

Ejemplo #2 Estilo por procedimientos

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* El tercer argumento omite el mensaje "volumen no encontrado" */
$a = rar_open($file, null, 'retnull');
rar_allow_broken_set($a, true);
foreach (rar_list($a) as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

Ver también

  • RarArchive::isBroken() - Comprobar si un archivo está dañado (incompleto)


Obtener representación de texto

  • « RarArchive::setAllowBroken
  • RarEntry »
  • PHP Manual
  • RarArchive
  • Obtener representación de texto

RarArchive::__toString

(PECL rar >= 2.0.0)

RarArchive::__toString — Obtener representación de texto

Descripción

public RarArchive::__toString ( ) : string

Proporciona una representación de cadena para este objeto RarArchive. Esta actualmente muestra la ruta completa del volumen de archivo que fue abierto y si el recurso es válido o ya estaba cerrado a través de una llamada a RarArchive::close().

Este método debe ser utilizado sólo para propósitos de depuración, ya que no existen garantías en cuanto a la información que contiene el resultado o cómo esta es formateada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una representación textual de este objeto RarArchive. El contenido de esta representación no es especificado.

Ejemplos

Ejemplo #1 Ejemplo de RarArchive::__toString()

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

El resultado del ejemplo sería algo similar a:

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)


La clase RarEntry

(PECL rar >= 0.1)

Introducción

Una entrada RAR, representa un directorio o un archivo comprimido dentro de un archivo RAR.

Sinopsis de la Clase

final RarEntry {
/* Constantes */
const integer HOST_MSDOS = 0 ;
const integer HOST_OS2 = 1 ;
const integer HOST_WIN32 = 2 ;
const integer HOST_UNIX = 3 ;
const integer HOST_MACOS = 4 ;
const integer HOST_BEOS = 5 ;
const integer ATTRIBUTE_WIN_READONLY = 1 ;
const integer ATTRIBUTE_WIN_HIDDEN = 2 ;
const integer ATTRIBUTE_WIN_SYSTEM = 4 ;
const integer ATTRIBUTE_WIN_DIRECTORY = 16 ;
const integer ATTRIBUTE_WIN_ARCHIVE = 32 ;
const integer ATTRIBUTE_WIN_DEVICE = 64 ;
const integer ATTRIBUTE_WIN_NORMAL = 128 ;
const integer ATTRIBUTE_WIN_TEMPORARY = 256 ;
const integer ATTRIBUTE_WIN_SPARSE_FILE = 512 ;
const integer ATTRIBUTE_WIN_REPARSE_POINT = 1024 ;
const integer ATTRIBUTE_WIN_COMPRESSED = 2048 ;
const integer ATTRIBUTE_WIN_OFFLINE = 4096 ;
const integer ATTRIBUTE_WIN_NOT_CONTENT_INDEXED = 8192 ;
const integer ATTRIBUTE_WIN_ENCRYPTED = 16384 ;
const integer ATTRIBUTE_WIN_VIRTUAL = 65536 ;
const integer ATTRIBUTE_UNIX_WORLD_EXECUTE = 1 ;
const integer ATTRIBUTE_UNIX_WORLD_WRITE = 2 ;
const integer ATTRIBUTE_UNIX_WORLD_READ = 4 ;
const integer ATTRIBUTE_UNIX_GROUP_EXECUTE = 8 ;
const integer ATTRIBUTE_UNIX_GROUP_WRITE = 16 ;
const integer ATTRIBUTE_UNIX_GROUP_READ = 32 ;
const integer ATTRIBUTE_UNIX_OWNER_EXECUTE = 64 ;
const integer ATTRIBUTE_UNIX_OWNER_WRITE = 128 ;
const integer ATTRIBUTE_UNIX_OWNER_READ = 256 ;
const integer ATTRIBUTE_UNIX_STICKY = 512 ;
const integer ATTRIBUTE_UNIX_SETGID = 1024 ;
const integer ATTRIBUTE_UNIX_SETUID = 2048 ;
const integer ATTRIBUTE_UNIX_FINAL_QUARTET = 61440 ;
const integer ATTRIBUTE_UNIX_FIFO = 4096 ;
const integer ATTRIBUTE_UNIX_CHAR_DEV = 8192 ;
const integer ATTRIBUTE_UNIX_DIRECTORY = 16384 ;
const integer ATTRIBUTE_UNIX_BLOCK_DEV = 24576 ;
const integer ATTRIBUTE_UNIX_REGULAR_FILE = 32768 ;
const integer ATTRIBUTE_UNIX_SYM_LINK = 40960 ;
const integer ATTRIBUTE_UNIX_SOCKET = 49152 ;
/* Métodos */
public extract ( string $dir , string $filepath = "" , string $password = NULL , bool $extended_data = false ) : bool
public getAttr ( ) : int
public getCrc ( ) : string
public getFileTime ( ) : string
public getHostOs ( ) : int
public getMethod ( ) : int
public getName ( ) : string
public getPackedSize ( ) : int
public getStream ( string $password = ? ) : resource
public getUnpackedSize ( ) : int
public getVersion ( ) : int
public isDirectory ( ) : bool
public isEncrypted ( ) : bool
public __toString ( ) : string
}

Constantes predefinidas

RarEntry::HOST_MSDOS

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, MS-DOS fue utilizado para añadir esta entrada. Utilizar en lugar de RAR_HOST_MSDOS.

RarEntry::HOST_OS2

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, OS/2 fue utilizado para añadir esta entrada. Destinado para sustituir a RAR_HOST_OS2.

RarEntry::HOST_WIN32

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, Microsoft Windows fue utilizado para añadir esta entrada. Destinado para sustituir a RAR_HOST_WIN32.

RarEntry::HOST_UNIX

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, un Sistema Operativo UNIX no especificado fue utilizado para añadir esta entrada. Destinado para sustituir a RAR_HOST_UNIX.

RarEntry::HOST_MACOS

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, un Sistema Operativo Mac fue utilizado para añadir esta entrada.

RarEntry::HOST_BEOS

Si el valor devuelto por RarEntry::getHostOs() es igual a esta constante, un Sistema Operativo BeOS fue utilizado para añadir esta entrada. Destinado para sustituir a RAR_HOST_BEOS.

RarEntry::ATTRIBUTE_WIN_READONLY

Bit que representa una entrada de Windows con un atributo de sólo lectura. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_HIDDEN

Bit que representa una entrada de Windows con un atributo oculto. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SYSTEM

Bits que representa una entrada de Windows con un atributo del sistema. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DIRECTORY

Bit que representa una entrada de Windows con un atributo de directorio (entrada es un directorio). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows. Véase también RarEntry::isDirectory(), que también trabaja con entradas que no fueron añadidas en WinRAR.

RarEntry::ATTRIBUTE_WIN_ARCHIVE

Bit que representa una entrada de Windows con un atributo de archivo. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DEVICE

Bit que representa una entrada de Windows con un atributo de dispositivo. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NORMAL

Bit que representa una entrada de Windows con un atributo de archivo normal (entrada NO es un directorio). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows. Véase también RarEntry::isDirectory(), que también trabaja con entradas que no fueron añadidas en WinRAR.

RarEntry::ATTRIBUTE_WIN_TEMPORARY

Bit que representa una entrada de Windows con un atributo temporal. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SPARSE_FILE

Bit que representa una entrada de Windows con un atributo de archivo disperso (archivo es un archivo disperso NTFS). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_REPARSE_POINT

Bit que representa una entrada de Windows con un atributo punto de re-análisis (entrada es un punto de re-análisis NTFS, por ejemplo, un directorio enlace o un sistema de montaje de archivos). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_COMPRESSED

Bit que representa una entrada de Windows con un atributo comprimido (sólo NTFS). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_OFFLINE

Bit que representa una entrada de Windows con un atributo fuera de línea (entrada es desconectada y no accesible). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NOT_CONTENT_INDEXED

Bit que representa una entrada de Windows con un atributo de contenido no indexado (entrada deberá ser indexada). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_ENCRYPTED

Bit que representa una entrada de Windows con un atributo cifrado (sólo NTFS). Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_VIRTUAL

Bit que representa una entrada de Windows con un atributo virtual. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es Microsoft Windows.

RarEntry::ATTRIBUTE_UNIX_WORLD_EXECUTE

Bit que representa una entrada que es ejecutable en el mundo UNIX. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_WRITE

Bit que representa una entrada que es escribible en el mundo UNIX. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_READ

Bit que representa una entrada que es leible en el mundo UNIX. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_EXECUTE

Bit que representa una entrada UNIX que es grupo ejecutable. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_WRITE

Bit que representa una entrada UNIX que es grupo escribible. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_READ

Bit que representa una entrada UNIX que es grupo leible. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_EXECUTE

Bit que representa una entrada UNIX que es propietario ejecutable. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_WRITE

Bit que representa una entrada UNIX que es propietario escribible. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_READ

Bit que representa una entrada UNIX que es propietario leible. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_STICKY

Bit que representa el sticky bit UNIX. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_SETGID

Bit que representa el atributo UNIX setgid. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_SETUID

Bit que representa el atributo UNIX setuid. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX.

RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET

Máscara para aislar a los últimos cuatro bits (nibble) de atributos UNIX
      (_S_IFMT, el tipo de máscara de archivo). Para ser utilizado con
      RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con las
      constantes RarEntry::ATTRIBUTE_UNIX_FIFO,
      RarEntry::ATTRIBUTE_UNIX_CHAR_DEV,
      RarEntry::ATTRIBUTE_UNIX_DIRECTORY,
      RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV,
      RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE,
      RarEntry::ATTRIBUTE_UNIX_SYM_LINK and
      RarEntry::ATTRIBUTE_UNIX_SOCKET.

RarEntry::ATTRIBUTE_UNIX_FIFO

FIFOs Unix tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_CHAR_DEV

Dispositivo de tipo carácter Unix tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_DIRECTORY

Directorios Unix tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. Véase también RarEntry::isDirectory(), que también trabaja con entradas que fueron añadidas en otros sistemas operativos.

RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV

Dispositivo de tipo bloque Unix tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE

Archivos regular Unix (no directorios) tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. Véase también RarEntry::isDirectory(), ue también trabaja con entradas que fueron añadidas en otros sistemas operativos.

RarEntry::ATTRIBUTE_UNIX_SYM_LINK

Enlace simbólico Unix tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_SOCKET

Sockets Unix will tendrá atributos cuyos últimos cuatro bits tienen este valor. Para ser utilizado con RarEntry::getAttr() en entradas cuyo sistema operativo anfitrión es UNIX y con la constante RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

Tabla de contenidos

  • RarEntry::extract — Extraer entrada del archivo
  • RarEntry::getAttr — Obtener los atributos de la entrada
  • RarEntry::getCrc — Obtener el CRC de la entrada
  • RarEntry::getFileTime — Devolver entrada última fecha de modificación
  • RarEntry::getHostOs — Obtener sistema operativo anfitrión del archivo de entrada
  • RarEntry::getMethod — Obtener método pack de la entrada
  • RarEntry::getName — Obtener el nombre de la entrada
  • RarEntry::getPackedSize — Obtiene el tamaño empaquetado de la entrada
  • RarEntry::getStream — Obtener manejador de archivo para entrada
  • RarEntry::getUnpackedSize — Obtener el tamaño descomprimido de la entrada
  • RarEntry::getVersion — Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada
  • RarEntry::isDirectory — Comprobar si una entrada representa un directorio
  • RarEntry::isEncrypted — Comprobar si una entrada está cifrada
  • RarEntry::__toString — Obtener texto representación de entrada


Extraer entrada del archivo

  • « RarEntry
  • RarEntry::getAttr »
  • PHP Manual
  • RarEntry
  • Extraer entrada del archivo

RarEntry::extract

(PECL rar >= 0.1)

RarEntry::extract — Extraer entrada del archivo

Descripción

public RarEntry::extract ( string $dir , string $filepath = "" , string $password = NULL , bool $extended_data = false ) : bool

RarEntry::extract() extrae los datos de entrada. Esto creará un nuevo archivo en el dir especificado con el mismo nombre que el nombre de la entrada, a menos que el segundo argumento sea especificado. Siga leyendo más abajo para obtener mayor información.

Parámetros

dir

Ruta al directorio donde los archivos deben ser extraídos. Este parámetro es considerado si y sólo si no es filepath. Si ambos parámetros están vacíos se intentará una extracción en el directorio actual.

filepath

Ruta (relativa o absoluta) que contiene el directorio y el nombre del archivo extraído. Este parámetro anula los parámetros dir y el nombre del archivo original.

password

La contraseña utilizada para cifrar esta entrada. Si la entrada no está cifrada, este valor no se utilizará y puede ser omitido. Si se omite este parámetro y la entrada está cifrada, la contraseña dada a rar_open(), será utlizada. Si una contraseña incorrecta es dada, de forma explicita o implicita via rar_open(), la comprobación CRC fallará y este método fallará y devolverá false. Si no se da la contraseña y se requiere una, este método fallará y devolverá false. Puede comprobar si una entrada está cifrada con RarEntry::isEncrypted().

extended_data

Si true, información extendida tales como NTFS ACLs e información propietaria Unix será establecida en los archivos extraidos, siempre que esta esté presente en el archivo.

Advertencia

Antes de la versión 2.0.0, esta función no manejaba las rutas relativas correctamente. Utilice realpath() como una solución.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
3.0.0 | extended_data fue añadido.
3.0.0 | Soporte para archivos RAR con nombres de entrada que se repiten ya no es defectuoso

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::extract()

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

$entry->extract('/dir/to'); // crear /dir/to/Dir/file.txt
$entry->extract(false, '/dir/to/new_name.txt'); // crear /dir/to/new_name.txt

?>

Ejemplo #2 ¿Cómo extraer todos los archivos en archivo?:

<?php

/* ejemplo por Erik Jenssen también conocido como erix */

$filename = "foobar.rar";
$filepath = "/home/foo/bar/";

$rar_file = rar_open($filepath.$filename);
$list = rar_list($rar_file);
foreach($list as $file) {
    $entry = rar_entry_get($rar_file, $file);
    $entry->extract("."); // extraer el directorio actual
}
rar_close($rar_file);

?>

Ver también

  • RarEntry::getStream() - Obtener manejador de archivo para entrada
  • rar:// wrapper


Obtener los atributos de la entrada

  • « RarEntry::extract
  • RarEntry::getCrc »
  • PHP Manual
  • RarEntry
  • Obtener los atributos de la entrada

RarEntry::getAttr

(PECL rar >= 0.1)

RarEntry::getAttr — Obtener los atributos de la entrada

Descripción

public RarEntry::getAttr ( ) : int

Devuelve los atributos dependientes del SO del archivo de entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los atributos o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getAttr()

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entry = rar_entry_get($rar_file, 'dir/in/the/archive') or die("Can't find such entry");

$host_os = $entry->getHostOs();
$attr = $entry->getAttr();

switch($host_os) {
    case RAR_HOST_MSDOS:
    case RAR_HOST_OS2:
    case RAR_HOST_WIN32:
    case RAR_HOST_MACOS:
        printf("%c%c%c%c%c%c\n",
                ($attr & 0x08) ? 'V' : '.',
                ($attr & 0x10) ? 'D' : '.',
                ($attr & 0x01) ? 'R' : '.',
                ($attr & 0x02) ? 'H' : '.',
                ($attr & 0x04) ? 'S' : '.',
                ($attr & 0x20) ? 'A' : '.');
        break;
    case RAR_HOST_UNIX:
    case RAR_HOST_BEOS:
        switch ($attr & 0xF000)
        {
            case 0x4000:
                printf("d");
                break;
            case 0xA000:
                printf("l");
                break;
            default:
                printf("-");
                break;
        }
        printf("%c%c%c%c%c%c%c%c%c\n",
                ($attr & 0x0100) ? 'r' : '-',
                ($attr & 0x0080) ? 'w' : '-',
                ($attr & 0x0040) ? (($attr & 0x0800) ? 's':'x'):(($attr & 0x0800) ? 'S':'-'),
                ($attr & 0x0020) ? 'r' : '-',
                ($attr & 0x0010) ? 'w' : '-',
                ($attr & 0x0008) ? (($attr & 0x0400) ? 's':'x'):(($attr & 0x0400) ? 'S':'-'),
                ($attr & 0x0004) ? 'r' : '-',
                ($attr & 0x0002) ? 'w' : '-',
                ($attr & 0x0001) ? 'x' : '-');
        break;
}

rar_close($rar_file);

?>

Ver también

  • RarEntry::getHostOs() - Obtener sistema operativo anfitrión del archivo de entrada
  • Las constantes de RarEntry


Obtener el CRC de la entrada

  • « RarEntry::getAttr
  • RarEntry::getFileTime »
  • PHP Manual
  • RarEntry
  • Obtener el CRC de la entrada

RarEntry::getCrc

(PECL rar >= 0.1)

RarEntry::getCrc — Obtener el CRC de la entrada

Descripción

public RarEntry::getCrc ( ) : string

Devuelve una cadena hexadecimal representación de el CRC del archivo de entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el CRC del archivo de entrada o false en caso de error.

Historial de cambios

Versión | Descripción
2.0.0 | Este método devuelve ahora valores correctos para archivos de varios volúmenes.


Devolver entrada última fecha de modificación

  • « RarEntry::getCrc
  • RarEntry::getHostOs »
  • PHP Manual
  • RarEntry
  • Devolver entrada última fecha de modificación

RarEntry::getFileTime

(PECL rar >= 0.1)

RarEntry::getFileTime — Devolver entrada última fecha de modificación

Descripción

public RarEntry::getFileTime ( ) : string

Devuelve entrada última fecha modificación.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve entrada última fecha de modificación como una cadena en formato YYYY-MM-DD HH:II:SS, o false en caso de error.


Obtener sistema operativo anfitrión del archivo de entrada

  • « RarEntry::getFileTime
  • RarEntry::getMethod »
  • PHP Manual
  • RarEntry
  • Obtener sistema operativo anfitrión del archivo de entrada

RarEntry::getHostOs

(PECL rar >= 0.1)

RarEntry::getHostOs — Obtener sistema operativo anfitrión del archivo de entrada

Descripción

public RarEntry::getHostOs ( ) : int

Devuelve el código del sistema operativo anfitrión del archivo de entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el código del sistema operativo anfitrión, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getHostOs() (version >= 2.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RarEntry::HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RarEntry::HOST_OS2:
        echo "OS2\n";
        break;
    case RarEntry::HOST_WIN32:
        echo "Win32\n";
        break;
    case RarEntry::HOST_MACOS:
        echo "MacOS\n";
        break;
    case RarEntry::HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RarEntry::HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Ejemplo #2 RarEntry::getHostOs() example (version <= 1.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RAR_HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RAR_HOST_OS2:
        echo "OS2\n";
        break;
    case RAR_HOST_WIN32:
        echo "Win32\n";
        break;
    case RAR_HOST_MACOS:
        echo "MacOS\n";
        break;
    case RAR_HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RAR_HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Ver también

  • RarEntry::extract() - Extraer entrada del archivo


Obtener método pack de la entrada

  • « RarEntry::getHostOs
  • RarEntry::getName »
  • PHP Manual
  • RarEntry
  • Obtener método pack de la entrada

RarEntry::getMethod

(PECL rar >= 0.1)

RarEntry::getMethod — Obtener método pack de la entrada

Descripción

public RarEntry::getMethod ( ) : int

RarEntry::getMethod() devuelve el número del método utilizado cuando añadimos archivo actual de entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de método o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getMethod()

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Method number: " . $entry->getMethod();

?>


Obtener el nombre de la entrada

  • « RarEntry::getMethod
  • RarEntry::getPackedSize »
  • PHP Manual
  • RarEntry
  • Obtener el nombre de la entrada

RarEntry::getName

(PECL rar >= 0.1)

RarEntry::getName — Obtener el nombre de la entrada

Descripción

public RarEntry::getName ( ) : string

Devuelve el nombre (con la ruta) de el archivo entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de la entrada como una cadena, o false en caso de error.

Historial de cambios

Versión | Descripción
2.0.0 | Desde la versión 2.0.0, la cadena devuelta está codificada en Unicode/UTF-8.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getName()

<?php

//este ejemplo, es seguro, incluso en páginas no codificados en UTF-8
//para esa codificación en UTF-8, la llamada a mb_convert_encoding es innecesaria.

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Entry name: " . mb_convert_encoding(
    htmlentities(
        $entry->getName(),
        ENT_COMPAT,
        "UTF-8"
    ),
    "HTML-ENTITIES",
    "UTF-8"
);

?>


Obtiene el tamaño empaquetado de la entrada

  • « RarEntry::getName
  • RarEntry::getStream »
  • PHP Manual
  • RarEntry
  • Obtiene el tamaño empaquetado de la entrada

RarEntry::getPackedSize

(PECL rar >= 0.1)

RarEntry::getPackedSize — Obtiene el tamaño empaquetado de la entrada

Descripción

public RarEntry::getPackedSize ( ) : int

Obtiene el tamaño empaquetado del archivo entrada.

Nota:

Tenga en cuenta que en las plataformas de 32 bits de longitud (que incluye Windows x64), el tamaño máximo devuelto está limitado a 2 GB. Compruebe la constante PHP_INT_MAX.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño empaquetado, o false en caso de error.

Historial de cambios

Versión | Descripción
2.0.0 | Este método devuelve ahora los valores correctos de empaquetado mayores a 2 GB en plataformas de 64-bit integers y nunca devuelve valores negativos en otras plataformas.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getPackedSize()

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Packed size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>


Obtener manejador de archivo para entrada

  • « RarEntry::getPackedSize
  • RarEntry::getUnpackedSize »
  • PHP Manual
  • RarEntry
  • Obtener manejador de archivo para entrada

RarEntry::getStream

(PECL rar >= 2.0.0)

RarEntry::getStream — Obtener manejador de archivo para entrada

Descripción

public RarEntry::getStream ( string $password = ? ) : resource

Devuelve un manejador de archivo que soporta operaciones de lectura. Este manejador proporciona descompresión al vuelo para esta entrada.

El manejador no es invalidado por llamar a rar_close().

Advertencia

El flujo resultante no tiene verificación de integridad. En particular, archivo corrupto y descifrado con una clave errónea, no será detectado. Es responsabilidad del programador utilizar la entrada CRC para comprobar la integridad, si así lo desea.

Parámetros

password

La contraseña utilizada para cifrar esta entrada. Si la entrada no está cifrada, este valor no se utilizará y puede ser omitido. Si el parámetro es omitido y la entrada está cifrada, la contraseña dada a rar_open(), será utilizada. Si una contraseña incorrecta es dada, ya sea explícita o implícitamente via rar_open(), teste método resultante de flujo producirá error de salida. Si no se especifica la contraseña y se requiere una, este método fallará y devolverá false. Puede comprobar si una entrada está cifrada con RarEntry::isEncrypted().

Valores devueltos

El manejador de archivo o false en caso de error.

Historial de cambios

Versión | Descripción
3.0.0 | Soporte para archivos RAR con nombres de entrada que se repiten ya no es defectuoso.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getStream()

<?php

$rar_file = rar_open('example.rar');
if ($rar_file === false)
    die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt');
if ($entry === false)
    die("Failed to find such entry");

$stream = $entry->getStream();
if ($stream === false)
    die("Failed to obtain stream.");

rar_close($rar_file); //flujo es independiente de archivo

while (!feof($stream)) {
    $buff = fread($stream, 8192);
    if ($buff !== false)
        echo $buff;
    else
        break; //error fread
}

fclose($stream);

?>

Ver también

  • RarEntry::extract() - Extraer entrada del archivo
  • rar:// wrapper


Obtener el tamaño descomprimido de la entrada

  • « RarEntry::getStream
  • RarEntry::getVersion »
  • PHP Manual
  • RarEntry
  • Obtener el tamaño descomprimido de la entrada

RarEntry::getUnpackedSize

(PECL rar >= 0.1)

RarEntry::getUnpackedSize — Obtener el tamaño descomprimido de la entrada

Descripción

public RarEntry::getUnpackedSize ( ) : int

Obtiene el tamaño descomprimido del archivo entrada.

Nota:

Tenga en cuenta que en las plataformas de 32 bits de longitud (que incluye Windows x64), el tamaño máximo devueltos está limitado a 2 GB. Compruebe la constante PHP_INT_MAX.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño descomprimido, o false en caso de error.

Historial de cambios

Versión | Descripción
2.0.0 | Este método devuelve ahora valores correctos de tamaño descomprimido superiores a 2 GB en plataformas con 64-bit integers y nunca devuelve valores negativos en otras plataformas.

Valores devueltos

Ejemplo #1 Ejemplo de RarEntry::getUnpackedSize()

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Unpacked size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>


Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada

  • « RarEntry::getUnpackedSize
  • RarEntry::isDirectory »
  • PHP Manual
  • RarEntry
  • Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada

RarEntry::getVersion

(PECL rar >= 0.1)

RarEntry::getVersion — Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada

Descripción

public RarEntry::getVersion ( ) : int

Devuelve la versión mínima del programa RAR (por ejemplo WinRAR) requerida para desempaquetar la entrada. Esta es codificada como 10 * version mayor + versión menor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la versión o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de RarEntry::getVersion()

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Rar version required for unpacking: " . $entry->getVersion();

?>


Comprobar si una entrada representa un directorio

  • « RarEntry::getVersion
  • RarEntry::isEncrypted »
  • PHP Manual
  • RarEntry
  • Comprobar si una entrada representa un directorio

RarEntry::isDirectory

(PECL rar >= 2.0.0)

RarEntry::isDirectory — Comprobar si una entrada representa un directorio

Descripción

public RarEntry::isDirectory ( ) : bool

Comprueba si una entrada representa un directorio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada es un directorio y false en caso contrario.

Notas

Esta función sólo está disponible desde la versión 2.0.0, pero también puede comprobarse si una entrada es un directorio mediante la comprobación de los atributos de entrada, así (sólo funciona para los archivos comprimidos en RAR por Windows o Unix):

<?php
//...
//Abrir archivo, obtener la entrada y almacenarla en la variable $e...
//...

$isDirectory = (bool) ((($e->getHostOs() == RAR_HOST_WIN32) && ($e->getAttr() & 0x10)) ||
    (($e->getHostOs() == RAR_HOST_UNIX) && (($e->getAttr() & 0xf000) == 0x4000)));
?>


Comprobar si una entrada está cifrada

  • « RarEntry::isDirectory
  • RarEntry::__toString »
  • PHP Manual
  • RarEntry
  • Comprobar si una entrada está cifrada

RarEntry::isEncrypted

(PECL rar >= 2.0.0)

RarEntry::isEncrypted — Comprobar si una entrada está cifrada

Descripción

public RarEntry::isEncrypted ( ) : bool

Comprueba si el contenido de la entrada actual está cifrado.

Nota:

La contraseña utilizada puede variar entre los archivos dentro del mismo archivo RAR.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada actual se encuentra cifrada y false en caso contrario.


Obtener texto representación de entrada

  • « RarEntry::isEncrypted
  • RarException »
  • PHP Manual
  • RarEntry
  • Obtener texto representación de entrada

RarEntry::__toString

(PECL rar >= 2.0.0)

RarEntry::__toString — Obtener texto representación de entrada

Descripción

public RarEntry::__toString ( ) : string

RarEntry::__toString() devuelve una representación textual de esta entrada. Esta incluye si la entrada es un archivo o un directorio (enlaces simbólicos y otros objetos especiales serán tratados como archivos), el nombre UTF-8 de la entrada y su CRC. La forma y el contenido de esta representación puede cambiar en el futuro, así que no son fiables.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una representación textual de la entrada.


La clase RarException

(PECL rar >= 2.0.0)

Introducción

Esta clase sirve para dos propósitos: estas son el tipo de las excepciones lanzadas por la extensión RAR funciones y métodos y esto permite, a través de métodos estáticos consultar y definir el error y el comportamiento de la extensión, por ejemplo, si las excepciones son lanzadas o solamente se emiten advertencias.

Los códigos de error que se utilizan los siguientes:

  • -1 - error fuera de biblioteca UnRAR
  • 11 - memoria insuficiente
  • 12 - datos dañados
  • 13 - archivo dañado
  • 14 - formato desconocido
  • 15 - error de apertura de archivo
  • 16 - error al crear archivo
  • 17 - error al cerrar archivo
  • 18 - error de lectura
  • 19 - error de escritura
  • 20 - búfer demasiado pequeño
  • 21 - error RAR desconocido
  • 22 - contraseña requerida pero no especificada

Sinopsis de la Clase

final RarException extends Exception {
/* Métodos */
public static isUsingExceptions ( ) : bool
public static setUsingExceptions ( bool $using_exceptions ) : void
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Tabla de contenidos

  • RarException::isUsingExceptions — Comprobar si el manejador de errores con excepciones está en uso
  • RarException::setUsingExceptions — Activar y desactivar el manejador de errores con excepciones


Comprobar si el manejador de errores con excepciones está en uso

  • « RarException
  • RarException::setUsingExceptions »
  • PHP Manual
  • RarException
  • Comprobar si el manejador de errores con excepciones está en uso

RarException::isUsingExceptions

(PECL rar >= 2.0.0)

RarException::isUsingExceptions — Comprobar si el manejador de errores con excepciones está en uso

Descripción

public static RarException::isUsingExceptions ( ) : bool

Comprueba si las funciones RAR emitirán avisos y devolverán valores de error o si ellas lanzarán excepciones en la mayoría de las circunstancias (no incluye algunos errores de programación tales como pasar el tipo incorrecto de argumento).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si las excepciones estan siendo utilizadas, false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de RarException::isUsingExceptions()

<?php
//El valor predeterminado es no usar excepciones
var_dump(RarException::isUsingExceptions());
?>

El resultado del ejemplo sería algo similar a:

bool(false)

Ver también

  • RarException::setUsingExceptions() - Activar y desactivar el manejador de errores con excepciones


Activar y desactivar el manejador de errores con excepciones

  • « RarException::isUsingExceptions
  • Zip »
  • PHP Manual
  • RarException
  • Activar y desactivar el manejador de errores con excepciones

RarException::setUsingExceptions

(PECL rar >= 2.0.0)

RarException::setUsingExceptions — Activar y desactivar el manejador de errores con excepciones

Descripción

public static RarException::setUsingExceptions ( bool $using_exceptions ) : void

Si y sólo si el argumento es true, entonces, en lugar de emitir advertencias y devolver un valor especial indicando error cuando la biblioteca UnRAR encuentre un error, una excepción de tipo RarException será lanzada.

Las excepciones también será lanzado para los siguientes errores, que se producen fuera de la biblioteca (su código de error será -1):

  • intentar algunas operaciones en un objeto RarArchive cerrado o un objeto RarEntry relativo al primero;
  • intentar obtener una entrada que no existe con RarArchive::getEntry().

Parámetros

using_exceptions

Debe ser true para activar lanzamiento de excepciones, false para descativarlo (el valor por defecto).

Ejemplos

Ejemplo #1 Ejemplo de RarException::setUsingExceptions()

<?php
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch);

RarException::setUsingExceptions(true);
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch); //not reached
?>

El resultado del ejemplo sería algo similar a:

bool(false)

Warning: RarArchive::open(): Failed to open does_not_exist.rar: ERAR_EOPEN (file open error) in C:\php_rar\trunk\tests\test.php on line 3
bool(false)
bool(true)

Fatal error: Uncaught exception 'RarException' with message 'unRAR internal error: Failed to open does_not_exist.rar: ERAR_EOPEN (file open error)' in C:\php_rar\trunk\tests\test.php:8
Stack trace:
#0 C:\php_rar\trunk\tests\test.php(8): RarArchive::open('does_not_exist....')
#1 {main}
  thrown in C:\php_rar\trunk\tests\test.php on line 8

Ver también

  • RarException::isUsingExceptions() - Comprobar si el manejador de errores con excepciones está en uso


Zip

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • ZipArchive — The ZipArchive class
    • ZipArchive::addEmptyDir — Añadir un nuevo directorio
    • ZipArchive::addFile — Añade un fichero al archivo ZIP para la ruta dada
    • ZipArchive::addFromString — Añadir un fichero al archivo ZIP usando su contenido
    • ZipArchive::addGlob — Añadir ficheros de un directorio mediante un patrón glob
    • ZipArchive::addPattern — Añade ficheros de un directorio a partir de un patrón PCRE
    • ZipArchive::close — Cierra el fichero activo (abierto o el nuevo creado)
    • ZipArchive::count — Cuenta el número de archivos en el archivo
    • ZipArchive::deleteIndex — Elimina una entrada en el archivo usando su índice
    • ZipArchive::deleteName — Elimina una entrada en el archivo por su nombre
    • ZipArchive::extractTo — Extraer el contenido del archivo
    • ZipArchive::getArchiveComment — Devuelve el comentario del archivo ZIP
    • ZipArchive::getCommentIndex — Devuelve el comentario de una entrada usando la entrada díndice
    • ZipArchive::getCommentName — Devuelve el comentario de una entrada usando el nombre de la entrada
    • ZipArchive::getExternalAttributesIndex — Obtener los atributos externos de una entrada definida por su índice
    • ZipArchive::getExternalAttributesName — Obtener los atributos externos de una entrada definida por su nombre
    • ZipArchive::getFromIndex — Devuelve el contenido de la entrada usando su índice
    • ZipArchive::getFromName — Devuelve el contenido de la entrada utilizando su nombre
    • ZipArchive::getNameIndex — Devuelve el nombre de una entrada utilizando su índice
    • ZipArchive::getStatusString — Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip
    • ZipArchive::getStream — Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)
    • ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip
    • ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip
    • ZipArchive::locateName — Devuelve el índice de la entrada en el archivo
    • ZipArchive::open — Abrir un fichero de archivo en formato ZIP
    • ZipArchive::registerCancelCallback — Registrar una llamada para permitir la cancelación durante el cierre del archivo
    • ZipArchive::registerProgressCallback — Registra una llamada para proporcionar actualizaciones durante el cierre del archivo
    • ZipArchive::renameIndex — Renombra una entrada definida por su índice
    • ZipArchive::renameName — Renombra una entrada definida por su nombre
    • ZipArchive::replaceFile — Reemplaza fichero en el archivo ZIP con una ruta determinada
    • ZipArchive::setArchiveComment — Establece el comentario de un archivo ZIP
    • ZipArchive::setCommentIndex — Establece el comentario de una entrada definido por su índice
    • ZipArchive::setCommentName — Establece el comentario de una entrada definido por su nombre
    • ZipArchive::setCompressionIndex — Establecer el método de compresión de una entrada definida por su índice
    • ZipArchive::setCompressionName — Establecer el método de compresión de una entrada definida por su nombre
    • ZipArchive::setEncryptionIndex — Establece el método de cifrado de una entrada definida por su índice
    • ZipArchive::setEncryptionName — Establece el método de cifrado de una entrada definida por su nombre
    • ZipArchive::setExternalAttributesIndex — Establece los atributos externos de una entrada definida por su índice
    • ZipArchive::setExternalAttributesName — Establece los atributos externos de una entrada definida por su nombre
    • ZipArchive::setMtimeIndex — Establece el tiempo de modificación de una entrada definido por su índice
    • ZipArchive::setMtimeName — Establece la hora de modificación de una entrada definida por su nombre
    • ZipArchive::setPassword — Establece la contraseña para el archivo activo
    • ZipArchive::statIndex — Obtiene los detalles de una entrada definida por su índice
    • ZipArchive::statName — Obtener los detalles de una entrada definida por su nombre
    • ZipArchive::unchangeAll — Deshacer todos los cambios hechos en el archivo
    • ZipArchive::unchangeArchive — Revertir todos los cambios globales hechos en el archivo
    • ZipArchive::unchangeIndex — Revertir todos los cambios hechos a una entrada en el índice dado
    • ZipArchive::unchangeName — Deshace todos los cambios realizados a una entrada con un nombre dado
  • Funciones Zip
    • zip_close — Cierra un fichero ZIP
    • zip_entry_close — Cierra la entrada a un directorio
    • zip_entry_compressedsize — Obtiene el tamaño comprimido de una entrada de directorio
    • zip_entry_compressionmethod — Devuelve el método de compresión de una entrada de directorio
    • zip_entry_filesize — Devuelve el tamaño del fichero actual de una entrada de directorio
    • zip_entry_name — Devuelve el nombre de la entrada de un directorio
    • zip_entry_open — Abrir una entrada de directorio para lectura
    • zip_entry_read — Leer desde una entrada de directorio abierta
    • zip_open — Abre un fichero ZIP
    • zip_read — Leer la siguiente entrada en el fichero ZIP


Introducción

Esta extensión permite leer o escribir de forma transparente archivos comprimidos ZIP y los ficheros que hay dentro.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

PHP 5.2.0 or later

Esta extensión usa las funciones de » zlib por Jean-loup Gailly y Mark Adler.


Instalación

PHP 5.2.0 o superior

Sistemas Linux

Para poder utilizar estas funciones, se debe compilar PHP con soporte para zip usando la opción de configuración --enable-zip.

Windows

Los usuarios de Windows deben habilitar php_zip.dll dentro del fichero php.ini para poder usar estas funciones.

Instalación mediante PECL

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/zip.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Tipos de recursos

Existen dos tipos de recursos usados en el módulo Zip. El primero es el directorio Zip para el fichero Zip, el segundo la entrada Zip para la entrada de archivos.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

ZipArchive usa constantes de clase. Existen tres tipos de constantes: Flags (prefijadas con FL_), errores (prefijados con ER_) y modos (sin prefijo).

ZipArchive::CREATE (integer)
Crea el archivo si no existe.
ZipArchive::OVERWRITE (integer)
Si existe un archivo, ignora su contenido actual. En otras palabras, lo trata de la misma manera que un archivo vacío.
ZipArchive::EXCL (integer)
Error si el fichero ya existe.
ZipArchive::RDONLY (integer)
Abrir archivo en modo de solo lectura. Disponible a partir de PHP 7.4.3 y PECL zip 1.17.1, respectivamente, si se compila con libzip = 1.0.0.
ZipArchive::CHECKCONS (integer)
Realiza comprobaciones de coherencia adicionales al archivo, producirá un error si falla.
ZipArchive::FL_NOCASE (integer)
Ignorar mayúsculas el lookup del nombre
ZipArchive::FL_NODIR (integer)
Ignorar el componente directorio
ZipArchive::FL_COMPRESSED (integer)
Leer datos comprimidos
ZipArchive::FL_UNCHANGED (integer)
Usar los datos originales, ignorando cambios.
ZipArchive::FL_RECOMPRESS (integer)
Forzar la recompresión de los datos. Disponible a partir de PHP 8.0.0 y PECL zip 1.18.0.
ZipArchive::FL_ENCRYPTED (integer)
Leer datos encriptados (implica FL_COMPRESSED). Disponible a partir de PHP 8.0.0 y PECL zip 1.18.0.
ZipArchive::FL_OVERWRITE (integer)
Si existe un archivo con nombre, sobrescríbalo (reemplácelo). Disponible a partir de PHP 8.0.0 y PECL zip 1.18.0.
ZipArchive::FL_LOCAL (integer)
En la cabecera local. Disponible a partir de PHP 8.0.0 y PECL zip 1.18.0.
ZipArchive::ZIP_FL_CENTRAL (integer)
En el directorio central. Disponible a partir de PHP 8.0.0 y PECL zip 1.18.0.
ZipArchive::FL_ENC_GUESS (integer)
Codificación de la cadena de suposición (guess string) (predeterminado). Disponible a partir de PHP 7.0.8.
ZipArchive::FL_ENC_RAW (integer)
Obtener la cadena sin modificaciones. Disponible a partir de PHP 7.0.8.
ZipArchive::FL_ENC_STRICT (integer)
Seguir la especificación estrictamente. Disponible a partir de PHP 7.0.8.
ZipArchive::FL_ENC_UTF_8 (integer)
La cadena está codificada en UTF-8. Disponible a partir de PHP 7.0.8.
ZipArchive::FL_ENC_CP437 (integer)
La cadena está codifica en CP437. Disponible a partir de PHP 7.0.8.
ZipArchive::CM_DEFAULT (integer)
Mejor para desinflar o almacenar.
ZipArchive::CM_STORE (integer)
almacenar (no comprimir).
ZipArchive::CM_SHRINK (integer)
Reducir
ZipArchive::CM_REDUCE_1 (integer)
reducido con factor 1
ZipArchive::CM_REDUCE_2 (integer)
reducido con factor 2
ZipArchive::CM_REDUCE_3 (integer)
reducido con factor 3
ZipArchive::CM_REDUCE_4 (integer)
reducido con factor 4
ZipArchive::CM_IMPLODE (integer)
implodado
ZipArchive::CM_DEFLATE (integer)
Deflactado
ZipArchive::CM_DEFLATE64 (integer)
deflate64
ZipArchive::CM_PKWARE_IMPLODE (integer)
PKWARE imploding
ZipArchive::CM_BZIP2 (integer)
usar algoritmo BZIP2
ZipArchive::CM_LZMA (integer)
Algoritmo LZMA
ZipArchive::CM_LZMA2 (integer)
Algoritmo LZMA2. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.0, respectivamente, si se compila con libzip = 1.6.0.
ZipArchive::CM_XZ (integer)
Algoritmo XZ. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.6.0.
ZipArchive::ER_OK (integer)
Sin errores.
ZipArchive::ER_MULTIDISK (integer)
Archivos zip multi-disk no soportados.
ZipArchive::ER_RENAME (integer)
Mantener fichero temporal fallado.
ZipArchive::ER_CLOSE (integer)
Cerrar fichero zip fallado.
ZipArchive::ER_SEEK (integer)
Buscar error
ZipArchive::ER_READ (integer)
Leer error
ZipArchive::ER_WRITE (integer)
Escribir error
ZipArchive::ER_CRC (integer)
error CRC
ZipArchive::ER_ZIPCLOSED (integer)
Conteniendo el fichero zip que ha sido cerrado
ZipArchive::ER_NOENT (integer)
No existe el fichero.
ZipArchive::ER_EXISTS (integer)
El fichero ya existe
ZipArchive::ER_OPEN (integer)
No se puede abrir el fichero
ZipArchive::ER_TMPOPEN (integer)
Fallo al intentar crear fichero temporal.
ZipArchive::ER_ZLIB (integer)
Error de Zlib
ZipArchive::ER_MEMORY (integer)
Error de asignación de memoria
ZipArchive::ER_CHANGED (string)
La entrada a cambiado
ZipArchive::ER_COMPNOTSUPP (integer)
Método de compresión no soportado.
ZipArchive::ER_EOF (integer)
EOF precoz.
ZipArchive::ER_INVAL (integer)
Argumento inválido
ZipArchive::ER_NOZIP (integer)
No es un archivo zip
ZipArchive::ER_INTERNAL (integer)
Error interno
ZipArchive::ER_INCONS (integer)
Fichero Zip inconsistente
ZipArchive::ER_REMOVE (integer)
No se puede eliminar el fichero
ZipArchive::ER_DELETED (integer)
La entrada ha sido eliminada
ZipArchive::ER_ENCRNOTSUPP (integer)
No se admite el método de cifrado. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente.
ZipArchive::ER_RDONLY (integer)
Archivo de sólo lectura. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente.
ZipArchive::ER_NOPASSWD (integer)
No se ha proporcionado ninguna contraseña. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente.
ZipArchive::ER_WRONGPASSWD (integer)
Contraseña incorrecta proporcionada. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente.
ZipArchive::ZIP_ER_OPNOTSUPP (integer)
Operación no soportada. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.0.0.
ZipArchive::ZIP_ER_INUSE (integer)
Recurso todavía en uso. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.0.0.
ZipArchive::ZIP_ER_TELL (integer)
Diga error. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.0.0.
ZipArchive::ZIP_ER_COMPRESSED_DATA (integer)
Los datos comprimidos no son válidos. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.6.0.
ZipArchive::ER_CANCELLED (integer)
Operación cancelada. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.1, respectivamente, si se compila con libzip = 1.6.0.
ZipArchive::EM_NONE (integer)
No hay encriptación. Disponible a partir de PHP 7.2.0 y PECL zip 1.14.0, respectivamente, si se compila con libzip = 1.2.0.
ZipArchive::EM_AES_128 (integer)
Encriptación AES 128. Disponible a partir de PHP 7.2.0 y PECL zip 1.14.0, respectivamente, si se compila con libzip = 1.2.0.
ZipArchive::EM_AES_192 (integer)
Encriptación AES 192. Disponible a partir de PHP 7.2.0 y PECL zip 1.14.0, respectivamente, si se compila con libzip = 1.2.0.
ZipArchive::EM_AES_256 (integer)
Encriptación AES 256. Disponible a partir de PHP 7.2.0 y PECL zip 1.14.0, respectivamente, si se compila con libzip = 1.2.0.
ZipArchive::LIBZIP_VERSION (string)
Versión de la biblioteca Zip. Disponible a partir de PHP 7.4.3 y PECL zip 1.16.0.
Constantes de sistema operativo para atributos externos
ZipArchive::OPSYS_DOS (integer)
ZipArchive::OPSYS_AMIGA (integer)
ZipArchive::OPSYS_OPENVMS (integer)
ZipArchive::OPSYS_UNIX (integer)
ZipArchive::OPSYS_VM_CMS (integer)
ZipArchive::OPSYS_ATARI_ST (integer)
ZipArchive::OPSYS_OS_2 (integer)
ZipArchive::OPSYS_MACINTOSH (integer)
ZipArchive::OPSYS_Z_SYSTEM (integer)
ZipArchive::OPSYS_CPM (integer)
ZipArchive::OPSYS_WINDOWS_NTFS (integer)
ZipArchive::OPSYS_MVS (integer)
ZipArchive::OPSYS_VSE (integer)
ZipArchive::OPSYS_ACORN_RISC (integer)
ZipArchive::OPSYS_VFAT (integer)
ZipArchive::OPSYS_ALTERNATE_MVS (integer)
ZipArchive::OPSYS_BEOS (integer)
ZipArchive::OPSYS_TANDEM (integer)
ZipArchive::OPSYS_OS_400 (integer)
ZipArchive::OPSYS_OS_X (integer)
ZipArchive::OPSYS_DEFAULT (integer)
Desde PHP 5.6.0, PECL zip 1.12.4


Ejemplos

Ejemplo #1 Crear un fichero Zip

<?php

$zip = new ZipArchive();
$filename = "./test112.zip";

if ($zip->open($filename, ZipArchive::CREATE)!==TRUE) {
    exit("cannot open <$filename>\n");
}

$zip->addFromString("testfilephp.txt" . time(), "#1 Esto es una cadena de prueba añadida como  testfilephp.txt.\n");
$zip->addFromString("testfilephp2.txt" . time(), "#2 Esto es una cadena de prueba añadida como testfilephp2.txt.\n");
$zip->addFile($thisdir . "/too.php","/testfromfile.php");
echo "numficheros: " . $zip->numFiles . "\n";
echo "estado:" . $zip->status . "\n";
$zip->close();
?>

Ejemplo #2 Volcar la información del archivo y listarlos

<?php
$za = new ZipArchive();

$za->open('test_with_comment.zip');
print_r($za);
var_dump($za);
echo "numFicheros: " . $za->numFiles . "\n";
echo "estado: " . $za->status  . "\n";
echo "estadosSis: " . $za->statusSys . "\n";
echo "nombreFichero: " . $za->filename . "\n";
echo "comentario: " . $za->comment . "\n";

for ($i=0; $i<$za->numFiles;$i++) {
    echo "index: $i\n";
    print_r($za->statIndex($i));
}
echo "numFichero:" . $za->numFiles . "\n";
?>

Ejemplo #3 Usando contenedor Zip, leer meta info de OpenOffice

<?php
$reader = new XMLReader();

$reader->open('zip://' . dirname(__FILE__) . '/test.odt#meta.xml');
$odt_meta = array();
while ($reader->read()) {
    if ($reader->nodeType == XMLREADER::ELEMENT) {
        $elm = $reader->name;
    } else {
        if ($reader->nodeType == XMLREADER::END_ELEMENT && $reader->name == 'office:meta') {
            break;
        }
        if (!trim($reader->value)) {
            continue;
        }
        $odt_meta[$elm] = $reader->value;
    }
}
print_r($odt_meta);
?>

Este ejemplo utiliza la antigua API (PHP 4), abre un fichero ZIP, lee cada fichero del archivo y imprime su contenido. El archivotest2.zip usado en este ejmplo es uno de los archivos de prueba la fuente de distribución de ZZIPlib.

Ejemplo #4 Ejemplo del uso de Zip

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {
    while ($zip_entry = zip_read($zip)) {
        echo "Nombre:               " . zip_entry_name($zip_entry) . "\n";
        echo "Tamaño actual del fichero:    " . zip_entry_filesize($zip_entry) . "\n";
        echo "Tamaño comprimido:    " . zip_entry_compressedsize($zip_entry) . "\n";
        echo "Método de compresión: " . zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "Contenido del fichero:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}
?>


The ZipArchive class

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

Introducción

Un fichero, comprimido con Zip.

Sinopsis de la Clase

ZipArchive {
/* Propiedades */
int $status;
int $statusSys;
int $numFiles;
string $filename;
string $comment;
/* Métodos */
addEmptyDir ( string $dirname ) : bool
addFile ( string $filename , string $localname = null , int $start = 0 , int $length = 0 ) : bool
addFromString ( string $localname , string $contents ) : bool
addGlob ( string $pattern , int $flags = 0 , array $options = array() ) : bool
addPattern ( string $pattern , string $path = "." , array $options = array() ) : array
close ( ) : bool
public count ( ) : int
deleteIndex ( int $index ) : bool
deleteName ( string $name ) : bool
extractTo ( string $destination , mixed $entries = ? ) : bool
getArchiveComment ( int $flags = ? ) : string
getCommentIndex ( int $index , int $flags = ? ) : string
getCommentName ( string $name , int $flags = ? ) : string
GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr , int $flags = ? ) : bool
getExternalAttributesName ( string $name , int &$opsys , int &$attr , int $flags = ? ) : bool
getFromIndex ( int $index , int $length = 0 , int $flags = ? ) : string
getFromName ( string $name , int $length = 0 , int $flags = ? ) : string
getNameIndex ( int $index , int $flags = ? ) : string
getStatusString ( ) : string
getStream ( string $name ) : resource
public static isCompressionMethodSupported ( int $method , bool $enc = true ) : bool
public static isEncryptionMethodSupported ( int $method , bool $enc = true ) : bool
locateName ( string $name , int $flags = ? ) : int
open ( string $filename , int $flags = ? ) : mixed
registerCancelCallback ( callable $callback ) : bool
registerProgressCallback ( float $rate , callable $callback ) : bool
renameIndex ( int $index , string $newname ) : bool
renameName ( string $name , string $newname ) : bool
replaceFile ( string $filename , int $index , int $start = 0 , int $length = 0 , int $flags = 0 ) : bool
setArchiveComment ( string $comment ) : bool
setCommentIndex ( int $index , string $comment ) : bool
setCommentName ( string $name , string $comment ) : bool
setCompressionIndex ( int $index , int $comp_method , int $comp_flags = 0 ) : bool
setCompressionName ( string $name , int $comp_method , int $comp_flags = 0 ) : bool
setEncryptionIndex ( int $index , string $method , string $password = ? ) : bool
setEncryptionName ( string $name , int $method , string $password = ? ) : bool
setExternalAttributesIndex ( int $index , int $opsys , int $attr , int $flags = ? ) : bool
setExternalAttributesName ( string $name , int $opsys , int $attr , int $flags = ? ) : bool
setMtimeIndex ( int $index , int $timestamp , int $flags = ? ) : bool
setMtimeName ( string $name , int $timestamp , int $flags = ? ) : bool
public setPassword ( string $password ) : bool
statIndex ( int $index , int $flags = ? ) : array
statName ( string $name , int $flags = ? ) : array
unchangeAll ( ) : bool
unchangeArchive ( ) : bool
unchangeIndex ( int $index ) : bool
unchangeName ( string $name ) : bool
}

Propiedades

status

Estado del archivo Zip

statusSys

Estado del sistema del archivo Zip

numFiles

Número de ficheros en el archivo

filename

Nombre del archivo en le sistema de archivos

comment

Comentario para el archivo

Tabla de contenidos

  • ZipArchive::addEmptyDir — Añadir un nuevo directorio
  • ZipArchive::addFile — Añade un fichero al archivo ZIP para la ruta dada
  • ZipArchive::addFromString — Añadir un fichero al archivo ZIP usando su contenido
  • ZipArchive::addGlob — Añadir ficheros de un directorio mediante un patrón glob
  • ZipArchive::addPattern — Añade ficheros de un directorio a partir de un patrón PCRE
  • ZipArchive::close — Cierra el fichero activo (abierto o el nuevo creado)
  • ZipArchive::count — Cuenta el número de archivos en el archivo
  • ZipArchive::deleteIndex — Elimina una entrada en el archivo usando su índice
  • ZipArchive::deleteName — Elimina una entrada en el archivo por su nombre
  • ZipArchive::extractTo — Extraer el contenido del archivo
  • ZipArchive::getArchiveComment — Devuelve el comentario del archivo ZIP
  • ZipArchive::getCommentIndex — Devuelve el comentario de una entrada usando la entrada díndice
  • ZipArchive::getCommentName — Devuelve el comentario de una entrada usando el nombre de la entrada
  • ZipArchive::getExternalAttributesIndex — Obtener los atributos externos de una entrada definida por su índice
  • ZipArchive::getExternalAttributesName — Obtener los atributos externos de una entrada definida por su nombre
  • ZipArchive::getFromIndex — Devuelve el contenido de la entrada usando su índice
  • ZipArchive::getFromName — Devuelve el contenido de la entrada utilizando su nombre
  • ZipArchive::getNameIndex — Devuelve el nombre de una entrada utilizando su índice
  • ZipArchive::getStatusString — Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip
  • ZipArchive::getStream — Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)
  • ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip
  • ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip
  • ZipArchive::locateName — Devuelve el índice de la entrada en el archivo
  • ZipArchive::open — Abrir un fichero de archivo en formato ZIP
  • ZipArchive::registerCancelCallback — Registrar una llamada para permitir la cancelación durante el cierre del archivo
  • ZipArchive::registerProgressCallback — Registra una llamada para proporcionar actualizaciones durante el cierre del archivo
  • ZipArchive::renameIndex — Renombra una entrada definida por su índice
  • ZipArchive::renameName — Renombra una entrada definida por su nombre
  • ZipArchive::replaceFile — Reemplaza fichero en el archivo ZIP con una ruta determinada
  • ZipArchive::setArchiveComment — Establece el comentario de un archivo ZIP
  • ZipArchive::setCommentIndex — Establece el comentario de una entrada definido por su índice
  • ZipArchive::setCommentName — Establece el comentario de una entrada definido por su nombre
  • ZipArchive::setCompressionIndex — Establecer el método de compresión de una entrada definida por su índice
  • ZipArchive::setCompressionName — Establecer el método de compresión de una entrada definida por su nombre
  • ZipArchive::setEncryptionIndex — Establece el método de cifrado de una entrada definida por su índice
  • ZipArchive::setEncryptionName — Establece el método de cifrado de una entrada definida por su nombre
  • ZipArchive::setExternalAttributesIndex — Establece los atributos externos de una entrada definida por su índice
  • ZipArchive::setExternalAttributesName — Establece los atributos externos de una entrada definida por su nombre
  • ZipArchive::setMtimeIndex — Establece el tiempo de modificación de una entrada definido por su índice
  • ZipArchive::setMtimeName — Establece la hora de modificación de una entrada definida por su nombre
  • ZipArchive::setPassword — Establece la contraseña para el archivo activo
  • ZipArchive::statIndex — Obtiene los detalles de una entrada definida por su índice
  • ZipArchive::statName — Obtener los detalles de una entrada definida por su nombre
  • ZipArchive::unchangeAll — Deshacer todos los cambios hechos en el archivo
  • ZipArchive::unchangeArchive — Revertir todos los cambios globales hechos en el archivo
  • ZipArchive::unchangeIndex — Revertir todos los cambios hechos a una entrada en el índice dado
  • ZipArchive::unchangeName — Deshace todos los cambios realizados a una entrada con un nombre dado


Añadir un nuevo directorio

  • « ZipArchive
  • ZipArchive::addFile »
  • PHP Manual
  • ZipArchive
  • Añadir un nuevo directorio

ZipArchive::addEmptyDir

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.8.0)

ZipArchive::addEmptyDir — Añadir un nuevo directorio

Descripción

ZipArchive::addEmptyDir ( string $dirname ) : bool

Añade un directoro vacío en el archivo.

Parámetros

dirname

El directorio a añadir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Crea un nuevo directorio en un archivo

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    if($zip->addEmptyDir('newDirectory')) {
        echo 'Creado nuevo directorio root';
    } else {
        echo 'No se puede crear el directorio';
    }
    $zip->close();
} else {
    echo 'falló';
}
?>


Añade un fichero al archivo ZIP para la ruta dada

  • « ZipArchive::addEmptyDir
  • ZipArchive::addFromString »
  • PHP Manual
  • ZipArchive
  • Añade un fichero al archivo ZIP para la ruta dada

ZipArchive::addFile

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::addFile — Añade un fichero al archivo ZIP para la ruta dada

Descripción

ZipArchive::addFile ( string $filename , string $localname = null , int $start = 0 , int $length = 0 ) : bool

Añade un fichero al archivo ZIP par la ruta dada.

Parámetros

filename

La ruta del fichero a añadir.

localname

Si corresponde, este es el nombre local dentro del archivo ZIP que reemplazará el filename.

start

Este parámetro no se utiliza, pero es requerido si se extiende ZipArchive.

length

Este parámetro no se utiliza, pero es requerido si se extiende ZipArchive.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo abre un archivo ZIP test.zip y añade el fichero /path/to/index.txt. como newname.txt.

Ejemplo #1 Abrir y extraer

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFile('/path/to/index.txt', 'newname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Notas

Nota:

Cuando un fichero es añadido al archivo, PHP intentará bloquear el fichero y solamente lo desbloqueará cuando finalice la operación con el ZIP. En resumen, significa que se puede eliminar un fichero añadido después que se cierre el archivo.


Añadir un fichero al archivo ZIP usando su contenido

  • « ZipArchive::addFile
  • ZipArchive::addGlob »
  • PHP Manual
  • ZipArchive
  • Añadir un fichero al archivo ZIP usando su contenido

ZipArchive::addFromString

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::addFromString — Añadir un fichero al archivo ZIP usando su contenido

Descripción

ZipArchive::addFromString ( string $localname , string $contents ) : bool

Añade un fichero al archivo ZIP usando su contenido.

Parámetros

localname

Nombre de la entrada a crear.

contents

El contenido a usar para crear la entrada. Es usado en modo binary safe.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añade una entrada al nuevo fichero

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'el contenido del fichero va aquí');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Ejemplo #2 Añade un fichero en un directorio dentro de un archivo

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFromString('dir/test.txt', 'el contenido del fichero va aquí');
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>


Añadir ficheros de un directorio mediante un patrón glob

  • « ZipArchive::addFromString
  • ZipArchive::addPattern »
  • PHP Manual
  • ZipArchive
  • Añadir ficheros de un directorio mediante un patrón glob

ZipArchive::addGlob

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL zip >= 1.9.0)

ZipArchive::addGlob — Añadir ficheros de un directorio mediante un patrón glob

Descripción

ZipArchive::addGlob ( string $pattern , int $flags = 0 , array $options = array() ) : bool

Añade ficheros de un directorio que corresponde con el patrón global pattern.

Parámetros

pattern

Un patrón glob()contra el cual se hará la correspondencia con los ficheros.

flags

Una máscara de un bit de marcas glob().

options

Un array asociativo de opciones. Las opciones disponibles son:

  • "add_path"

    Prefijo a indicar cuando se traduce la ruta de acceso del fichero dentro del archivo. Esta traducción se aplica después de cualquier operación de eliminación definida por las opciones "remove_path" o "remove_all_path" .

  • "remove_path"

    Prefijo para eliminar la ruta de acceso de los ficheros antes de añadirlos al archivo.

  • "remove_all_path"

    true para utilizar únicamente el nombre del fichero y añadirlo a la raíz del archivo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo con ZipArchive::addGlob()

Añadir todos los ficheros de scripts y texto php del directorio de trabajo actual

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Erróneo con el código %d', $ret);
} else {
    $options = array('add_path' => 'sources/', 'remove_all_path' => TRUE);
    $zip->addGlob('*.{php,txt}', GLOB_BRACE, $options);
    $zip->close();
}
?>

Ver también

  • ZipArchive::addFile() - Añade un fichero al archivo ZIP para la ruta dada
  • ZipArchive::addPattern() - Añade ficheros de un directorio a partir de un patrón PCRE


Añade ficheros de un directorio a partir de un patrón PCRE

  • « ZipArchive::addGlob
  • ZipArchive::close »
  • PHP Manual
  • ZipArchive
  • Añade ficheros de un directorio a partir de un patrón PCRE

ZipArchive::addPattern

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL zip >= 1.9.0)

ZipArchive::addPattern — Añade ficheros de un directorio a partir de un patrón PCRE

Descripción

ZipArchive::addPattern ( string $pattern , string $path = "." , array $options = array() ) : array

Añade ficheros de un directorio que coinciden con la expresión regular pattern. La operación no es recursiva. Únicamente se hará la correspondencia del patrón con el nombre del fichero.

Parámetros

pattern

Un patrón PCRE contra el cual se realizará la correspondencia.

path

El directorio que será escaneado. Por defecto es el directorio de trabajo actual.

options

Un array asociativo de opciones aceptadas por ZipArchive::addGlob().

Valores devueltos

Un array de archivos añadidos en caso de éxito o false en caso de error

Ejemplos

Ejemplo #1 Ejemplo con ZipArchive::addPattern()

Añadir todos los scripts y ficheros de texto php del directorio actual

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Erróneo con código %d', $ret);
} else {
    $directory = realpath('.');
    $options = array('add_path' => 'sources/', 'remove_path' => $directory);
    $zip->addPattern('/\.(?:php|txt)$/', $directory, $options);
    $zip->close();
}
?>

Ver también

  • ZipArchive::addFile() - Añade un fichero al archivo ZIP para la ruta dada
  • ZipArchive::addGlob() - Añadir ficheros de un directorio mediante un patrón glob


Cierra el fichero activo (abierto o el nuevo creado)

  • « ZipArchive::addPattern
  • ZipArchive::count »
  • PHP Manual
  • ZipArchive
  • Cierra el fichero activo (abierto o el nuevo creado)

ZipArchive::close

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::close — Cierra el fichero activo (abierto o el nuevo creado)

Descripción

ZipArchive::close ( ) : bool

Cierra fichero abierto o creado y guarda los cambios. Este método es automáticamente llamado al finalizar el script.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Cuenta el número de archivos en el archivo

  • « ZipArchive::close
  • ZipArchive::deleteIndex »
  • PHP Manual
  • ZipArchive
  • Cuenta el número de archivos en el archivo

ZipArchive::count

(PHP 7 >= 7.2.0, PHP 8, PECL zip >= 1.15.0)

ZipArchive::count — Cuenta el número de archivos en el archivo

Descripción

public ZipArchive::count ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de ficheros en el archivo.


Elimina una entrada en el archivo usando su índice

  • « ZipArchive::count
  • ZipArchive::deleteName »
  • PHP Manual
  • ZipArchive
  • Elimina una entrada en el archivo usando su índice

ZipArchive::deleteIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::deleteIndex — Elimina una entrada en el archivo usando su índice

Descripción

ZipArchive::deleteIndex ( int $index ) : bool

Elimina una entrada en su archivo usando su índice.

Parámetros

index

Índice de la entrada a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Elimina el fichero desde el archivo usando su índice

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->deleteIndex(2);
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>


Elimina una entrada en el archivo por su nombre

  • « ZipArchive::deleteIndex
  • ZipArchive::extractTo »
  • PHP Manual
  • ZipArchive
  • Elimina una entrada en el archivo por su nombre

ZipArchive::deleteName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::deleteName — Elimina una entrada en el archivo por su nombre

Descripción

ZipArchive::deleteName ( string $name ) : bool

Elimina una entrada en el archivo por su nombre

Parámetros

name

Nombre de la entrada a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Eliminado un fichero y un directorio desde un archivo, usando nombres

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    $zip->deleteName('testfromfile.php');
    $zip->deleteName('testDir/');
    $zip->close();
    echo 'ok';
} else {
    echo 'Falló';
}
?>


Extraer el contenido del archivo

  • « ZipArchive::deleteName
  • ZipArchive::getArchiveComment »
  • PHP Manual
  • ZipArchive
  • Extraer el contenido del archivo

ZipArchive::extractTo

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::extractTo — Extraer el contenido del archivo

Descripción

ZipArchive::extractTo ( string $destination , mixed $entries = ? ) : bool

Extrae el archivo completo o los ficheros dados en la ruta que se especifique.

Advertencia

Los permisos por omisión para los archivos y directorios extraídos dan el más amplio acceso posible. Esto se puede restringir estableciendo la umask actual, que se puede cambiar usando umask().

Parámetros

destination

Destino en donde extraer los ficheros.

entries

Las entradas a extraer. Acepta tanto un solo nombre o un array de nombres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Extraer todas las entradas

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->extractTo('/my/destination/dir/');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Ejemplo #2 Extraer dos entradas

<?php
$zip = new ZipArchive;
$res = $zip->open('test_im.zip');
if ($res === TRUE) {
    $zip->extractTo('/my/destination/dir/', array('pear_item.gif', 'testfromfile.php'));
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Devuelve el comentario del archivo ZIP

  • « ZipArchive::extractTo
  • ZipArchive::getCommentIndex »
  • PHP Manual
  • ZipArchive
  • Devuelve el comentario del archivo ZIP

ZipArchive::getArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getArchiveComment — Devuelve el comentario del archivo ZIP

Descripción

ZipArchive::getArchiveComment ( int $flags = ? ) : string

Devuelve el comentario del archivo ZIP.

Parámetros

flags

Si las flags se establecen en ZipArchive::FL_UNCHANGED, el comentario original se devuelve sin cambios.

Valores devueltos

Devuelve el comentario del archivo Zip o false en caso de error.

Ejemplos

Ejemplo #1 Vuelca el comentario del archivo

<?php
$zip = new ZipArchive;
$res = $zip->open('test_with_comment.zip');
if ($res === TRUE) {
    var_dump($zip->getArchiveComment());
    /* O usando la propiedad del archivo */
    var_dump($zip->comment);
} else {
    echo 'falló, código:' . $res;
}
?>


Devuelve el comentario de una entrada usando la entrada díndice

  • « ZipArchive::getArchiveComment
  • ZipArchive::getCommentName »
  • PHP Manual
  • ZipArchive
  • Devuelve el comentario de una entrada usando la entrada díndice

ZipArchive::getCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::getCommentIndex — Devuelve el comentario de una entrada usando la entrada díndice

Descripción

ZipArchive::getCommentIndex ( int $index , int $flags = ? ) : string

Devuelve el comentario de una entrada usando la entrada índice.

Parámetros

index

Índice de la entrada

flags

Si flags ZipArchive::FL_UNCHANGED, se devolverá el comentario original no cambiado.

Valores devueltos

Con éxito devuelve el comentario o false en caso de error.

Ejemplos

Ejemplo #1 Vuelca el comentario de la entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentIndex(1));
} else {
    echo 'falló, código:' . $res;
}
?>


Devuelve el comentario de una entrada usando el nombre de la entrada

  • « ZipArchive::getCommentIndex
  • ZipArchive::getExternalAttributesIndex »
  • PHP Manual
  • ZipArchive
  • Devuelve el comentario de una entrada usando el nombre de la entrada

ZipArchive::getCommentName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::getCommentName — Devuelve el comentario de una entrada usando el nombre de la entrada

Descripción

ZipArchive::getCommentName ( string $name , int $flags = ? ) : string

Devuelve el comentario de una entrada usando el nombre de la entrada.

Parámetros

name

Nombre de la entrada

flags

Si flags está defindo a ZipArchive::FL_UNCHANGED, se devuelve el comentario original no cambiado.

Valores devueltos

Devuelve el comentario si se ejecutó con éxito o false en caso de error.

Ejemplos

Ejemplo #1 Vuelca el comentario de la entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentName('test/entry1.txt'));
} else {
    echo 'Falló, código:' . $res;
}
?>


Obtener los atributos externos de una entrada definida por su índice

  • « ZipArchive::getCommentName
  • ZipArchive::getExternalAttributesName »
  • PHP Manual
  • ZipArchive
  • Obtener los atributos externos de una entrada definida por su índice

ZipArchive::getExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesIndex — Obtener los atributos externos de una entrada definida por su índice

Descripción

ZipArchive::GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr , int $flags = ? ) : bool

Recuperar los atributos externos de una entrada definida por su índice.

Parámetros

index

El índice de la entrada.

opsys

En caso de éxito, recibe el código del sistema operativo definido por una de las constantes ZipArchive::OPSYS_.

attr

En caso de éxito, recibe los atributos externos. El valor dependerá del sistema operativo.

flags

Si flags se establece a ZipArchive::FL_UNCHANGED, se devuelven los atributos originales sin cambios.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo extrae todas las entradas de un archivo ZIP test.zip y asigna los permisos Unix tomados de los atributos externos.

Ejemplo #1 Extraer todas las entradas con permisos Unix

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip') === TRUE) {
    for ($idx=0 ; $s = $zip->statIndex($idx) ; $idx++) {
        if ($zip->extractTo('.', $s['name'])) {
            if ($zip->getExternalAttributesIndex($idx, $opsys, $attr)
                && $opsys==ZipArchive::OPSYS_UNIX) {
               chmod($s['name'], ($attr >> 16) & 0777);
            }
        }
    }
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>


Obtener los atributos externos de una entrada definida por su nombre

  • « ZipArchive::getExternalAttributesIndex
  • ZipArchive::getFromIndex »
  • PHP Manual
  • ZipArchive
  • Obtener los atributos externos de una entrada definida por su nombre

ZipArchive::getExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesName — Obtener los atributos externos de una entrada definida por su nombre

Descripción

ZipArchive::getExternalAttributesName ( string $name , int &$opsys , int &$attr , int $flags = ? ) : bool

Obtener los atributos externos de una entrada definida por su nombre.

Parámetros

name

El nombre de la entrada.

opsys

En caso de éxito, recibe el código del sistema operativo definido por una de las constantes ZipArchive::OPSYS_.

attr

En caso de éxito, recibe los atributos externos. El valor depende del sistema operativo.

flags

Si flags se establece a ZipArchive::FL_UNCHANGED, se devuelven los atributos originales sin cambios.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve el contenido de la entrada usando su índice

  • « ZipArchive::getExternalAttributesName
  • ZipArchive::getFromName »
  • PHP Manual
  • ZipArchive
  • Devuelve el contenido de la entrada usando su índice

ZipArchive::getFromIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getFromIndex — Devuelve el contenido de la entrada usando su índice

Descripción

ZipArchive::getFromIndex ( int $index , int $length = 0 , int $flags = ? ) : string

Devuelve el contenido de la entrada usando su índice.

Parámetros

index

El índice de la entrada

length

La longitud que se see desde la entrada. Si es 0, entonces toda la entrada se lee.

flags

Las flags usadas para abrir el fichero. Los siguientes valores pueden ser Ored.

  • ZipArchive::FL_UNCHANGED

  • ZipArchive::FL_COMPRESSED

Valores devueltos

Devuelve el contenido de la entrada si se ejecutó con éxito o false en caso de error.

Ejemplos

Ejemplo #1 Obtener el contenido del fichero

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    echo $zip->getFromIndex(2);
    $zip->close();
} else {
    echo 'falló';
}
?>

Ver también

  • ZipArchive::getFromName() - Devuelve el contenido de la entrada utilizando su nombre


Devuelve el contenido de la entrada utilizando su nombre

  • « ZipArchive::getFromIndex
  • ZipArchive::getNameIndex »
  • PHP Manual
  • ZipArchive
  • Devuelve el contenido de la entrada utilizando su nombre

ZipArchive::getFromName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getFromName — Devuelve el contenido de la entrada utilizando su nombre

Descripción

ZipArchive::getFromName ( string $name , int $length = 0 , int $flags = ? ) : string

Devuelve el contenido de la entrada utilizando su nombre

Parámetros

name

Nombre de la entrada

length

La longitud a ser leída desde la entrada. Si es 0, entonces toda la entrada es leída.

flags

Los indicadores a utilizar para abrir el archivo. Los siguientes valores podrían ser escritos juntos con un OR lógico en él.

  • ZipArchive::FL_UNCHANGED

  • ZipArchive::FL_COMPRESSED

  • ZipArchive::FL_NOCASE

Valores devueltos

Devuelve el contenido de la entrada en caso de tener éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Obtener el contenido de los ficheros

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    echo $zip->getFromName('testfromfile.php');
    $zip->close();
} else {
    echo 'falló';
}
?>

Ejemplo #2 Convierte una imagen desde una entrada de fichero zip

<?php
$z = new ZipArchive();
if ($z->open(dirname(__FILE__) . '/test_im.zip')) {
    $im_string = $z->getFromName("pear_item.gif");
    $im = imagecreatefromstring($im_string);
    imagepng($im, 'b.png');
}
?>

Ver también

  • ZipArchive::getFromIndex() - Devuelve el contenido de la entrada usando su índice


Devuelve el nombre de una entrada utilizando su índice

  • « ZipArchive::getFromName
  • ZipArchive::getStatusString »
  • PHP Manual
  • ZipArchive
  • Devuelve el nombre de una entrada utilizando su índice

ZipArchive::getNameIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::getNameIndex — Devuelve el nombre de una entrada utilizando su índice

Descripción

ZipArchive::getNameIndex ( int $index , int $flags = ? ) : string

Devuelve el nombre de una entrada utilizando su índice.

Parámetros

index

El índice de la entrada.

flags

Si las flags se establecen en ZipArchive::FL_UNCHANGED, el nombre original es devuelto sin cambios.

Valores devueltos

Devuelve el nombre en caso de tener éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ZipArchive::getNameIndex()

<?php
if ($zip->open('test.zip') == TRUE) {
 for ($i = 0; $i < $zip->numFiles; $i++) {
     $filename = $zip->getNameIndex($i);
     // ...
 }
}
?>


Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip

  • « ZipArchive::getNameIndex
  • ZipArchive::getStream »
  • PHP Manual
  • ZipArchive
  • Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip

ZipArchive::getStatusString

(PHP 5 >= 5.2.7, PHP 7, PHP 8)

ZipArchive::getStatusString — Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip

Descripción

ZipArchive::getStatusString ( ) : string

Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string con el mensaje de estado en caso de tener éxito, o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 / 1.18.0 | Este método puede ser llamado en un archivo cerrado.


Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)

  • « ZipArchive::getStatusString
  • ZipArchive::isCompressionMethodSupported »
  • PHP Manual
  • ZipArchive
  • Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)

ZipArchive::getStream

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getStream — Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)

Descripción

ZipArchive::getStream ( string $name ) : resource

Obtener un manejador de fichero para la entrada definido por su nombre. Por ahora, éste solamente soporta operaciones de lectura.

Parámetros

name

El nombre de la entrada a utilizar.

Valores devueltos

Devuelve un puntero de fichero (un recurso) en caso de tener éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Obtiene los contenidos de entrada con fread() y lo almacena

<?php
$contents = '';
$z = new ZipArchive();
if ($z->open('test.zip')) {
    $fp = $z->getStream('test');
    if(!$fp) exit("failed\n");

    while (!feof($fp)) {
        $contents .= fread($fp, 2);
    }

    fclose($fp);
    file_put_contents('t',$contents);
    echo "done.\n";
}
?>

Ejemplo #2 Lo mismo como el ejemplo anterior pero con fopen() y el envoltorio de flujo de zip

<?php
$contents = '';
$fp = fopen('zip://' . dirname(__FILE__) . '/test.zip#test', 'r');
if (!$fp) {
    exit("cannot open\n");
}
while (!feof($fp)) {
    $contents .= fread($fp, 2);
}
echo "$contents\n";
fclose($fp);
echo "done.\n";
?>

Ejemplo #3 El flujo de envoltorio y la imagen, también pueden ser utilizados con la función xml

<?php
$im = imagecreatefromgif('zip://' . dirname(__FILE__) . '/test_im.zip#pear_item.gif');
imagepng($im, 'a.png');
?>


Check if a compression method is supported by libzip

  • « ZipArchive::getStream
  • ZipArchive::isEncryptionMethodSupported »
  • PHP Manual
  • ZipArchive
  • Check if a compression method is supported by libzip

ZipArchive::isCompressionMethodSupported

(PHP >= 8.0.0, PECL zip >= 1.19.0)

ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip

Descripción

public static ZipArchive::isCompressionMethodSupported ( int $method , bool $enc = true ) : bool

Check if a compression method is supported by libzip.

Parámetros

method

The compression method, one of the ZipArchive::CM_* constants.

enc

If true check for compression, else check for decompression.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

This function is only available if built against libzip = 1.7.0.

Ver también

  • ZipArchive::setCompressionIndex() - Establecer el método de compresión de una entrada definida por su índice
  • ZipArchive::setCompressionName() - Establecer el método de compresión de una entrada definida por su nombre


Check if a encryption method is supported by libzip

  • « ZipArchive::isCompressionMethodSupported
  • ZipArchive::locateName »
  • PHP Manual
  • ZipArchive
  • Check if a encryption method is supported by libzip

ZipArchive::isEncryptionMethodSupported

(PHP >= 8.0.0, PECL zip >= 1.19.0)

ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip

Descripción

public static ZipArchive::isEncryptionMethodSupported ( int $method , bool $enc = true ) : bool

Check if a compression method is supported by libzip.

Parámetros

method

The encryption method, one of the ZipArchive::EM_* constants.

enc

If true check for encryption, else check for decryption.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

This function is only available if built against libzip = 1.7.0.

Ver también

  • ZipArchive::setEncryptionIndex() - Establece el método de cifrado de una entrada definida por su índice
  • ZipArchive::setEncryptionName() - Establece el método de cifrado de una entrada definida por su nombre


Devuelve el índice de la entrada en el archivo

  • « ZipArchive::isEncryptionMethodSupported
  • ZipArchive::open »
  • PHP Manual
  • ZipArchive
  • Devuelve el índice de la entrada en el archivo

ZipArchive::locateName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::locateName — Devuelve el índice de la entrada en el archivo

Descripción

ZipArchive::locateName ( string $name , int $flags = ? ) : int

Localiza una entrada utilizando su nombre.

Parámetros

name

El nombre de la entrada a buscar

flags

Los indicadores son especificados agregándoles OR a los siguientes valores, ó 0 para ninguno de ellos.

  • ZipArchive::FL_NOCASE

  • ZipArchive::FL_NODIR

Valores devueltos

Devuelve el índice de la entrada en caso de tener éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Crear un archivo y luego utilizarlo con ZipArchive::locateName()

<?php
$file = 'testlocate.zip';

$zip = new ZipArchive;
if ($zip->open($file, ZipArchive::CREATE) !== TRUE) {
    exit('falló');
}

$zip->addFromString('entry1.txt', 'entry #1');
$zip->addFromString('entry2.txt', 'entry #2');
$zip->addFromString('dir/entry2d.txt', 'entry #2');

if (!$zip->status == ZipArchive::ER_OK) {
    echo "falló al escribir en el archivo zip\n";
}
$zip->close();

if ($zip->open($file) !== TRUE) {
    exit('falló');
}

echo $zip->locateName('entry1.txt') . "\n";
echo $zip->locateName('eNtry2.txt') . "\n";
echo $zip->locateName('eNtry2.txt', ZipArchive::FL_NOCASE) . "\n";
echo $zip->locateName('enTRy2d.txt', ZipArchive::FL_NOCASE|ZipArchive::FL_NODIR) . "\n";
$zip->close();

?>

El resultado del ejemplo sería:

El ejemplo de arriba mostrará la salida:

0

1
2


Abrir un fichero de archivo en formato ZIP

  • « ZipArchive::locateName
  • ZipArchive::registerCancelCallback »
  • PHP Manual
  • ZipArchive
  • Abrir un fichero de archivo en formato ZIP

ZipArchive::open

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::open — Abrir un fichero de archivo en formato ZIP

Descripción

ZipArchive::open ( string $filename , int $flags = ? ) : mixed

Abre un archivo zip nuevo o existente para leer, escribir o modificar.

Desde libzip 1.6.0, un archivo vacío ya no es un archivo válido.

Parámetros

filename

El nombre del fichero del archivo ZIP para ser abierto.

flags

El modo a utilizar para abrir el archivo.

  • ZipArchive::OVERWRITE

  • ZipArchive::CREATE

  • ZipArchive::RDONLY

  • ZipArchive::EXCL

  • ZipArchive::CHECKCONS

Valores devueltos

Error codes

Devuelve true en caso de éxito o el código de error.

  • ZipArchive::ER_EXISTS

    El fichero ya existe.

  • ZipArchive::ER_INCONS

    Archivo zip inconsistente.

  • ZipArchive::ER_INVAL

    Argumento no válido.

  • ZipArchive::ER_MEMORY

    Falló malloc.

  • ZipArchive::ER_NOENT

    No existe el fichero.

  • ZipArchive::ER_NOZIP

    No es un archivo zip.

  • ZipArchive::ER_OPEN

    No se puede abrir el fichero.

  • ZipArchive::ER_READ

    Error de lectura.

  • ZipArchive::ER_SEEK

    Error de búsqueda.

Ejemplos

Ejemplo #1 Abrir y extraer

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    echo 'ok';
    $zip->extractTo('test');
    $zip->close();
} else {
    echo 'falló, código:' . $res;
}
?>

Ejemplo #2 Crear un fichero

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'el contenido del fichero va aquí');
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>

Ejemplo #3 Crear un fichero temporal

<?php
$name = tempnam(sys_get_temp_dir(), "FOO");
$zip = new ZipArchive;
$res = $zip->open($name, ZipArchive::OVERWRITE); /* truncate as empty file is not valid */
if ($res === TRUE) {
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Registrar una llamada para permitir la cancelación durante el cierre del archivo

  • « ZipArchive::open
  • ZipArchive::registerProgressCallback »
  • PHP Manual
  • ZipArchive
  • Registrar una llamada para permitir la cancelación durante el cierre del archivo

ZipArchive::registerCancelCallback

(PHP >= 8.0.0, PECL zip >= 1.17.0)

ZipArchive::registerCancelCallback — Registrar una llamada para permitir la cancelación durante el cierre del archivo

Descripción

ZipArchive::registerCancelCallback ( callable $callback ) : bool

Registrar una función callback para permitir la cancelación durante el cierre del archivo.

Parámetros

callback

Si esta función vuelve a 0, la operación continuará, otro valor será cancelado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.6.0.

Ejemplos

Este ejemplo crea un archivo ZIP php.zip y cancela la operación en alguna condición de operación.

Ejemplo #1 Archive a file

<?php
$zip = new ZipArchive();
if ($zip->open('php.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE)) {
    $zip->addFile(PHP_BINARY, 'php');
    $zip->registerCancelCallback(function () {
        return ($someruncondition ? -1 : 0);
    });
    $zip->close();
}

Ver también

  • ZipArchive::registerProgressCallback() - Registra una llamada para proporcionar actualizaciones durante el cierre del archivo


Registra una llamada para proporcionar actualizaciones durante el cierre del archivo

  • « ZipArchive::registerCancelCallback
  • ZipArchive::renameIndex »
  • PHP Manual
  • ZipArchive
  • Registra una llamada para proporcionar actualizaciones durante el cierre del archivo

ZipArchive::registerProgressCallback

(PHP >= 8.0.0, PECL zip >= 1.17.0)

ZipArchive::registerProgressCallback — Registra una llamada para proporcionar actualizaciones durante el cierre del archivo

Descripción

ZipArchive::registerProgressCallback ( float $rate , callable $callback ) : bool

Registra una función callback para proporcionar actualizaciones durante el cierre del archivo.

Parámetros

rate

Cambiar entre cada llamada de la devolución de llamada (de 0.0 a 1.0).

callback

Esta función recibirá el actual state como un float (de 0.0 a 1.0).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.3.0.

Ejemplos

Este ejemplo crea un archivo ZIP php.zip y muestra la progresión.

Ejemplo #1 Archive a file

$zip = new ZipArchive();
if ($zip->open('php.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE)) {
    $zip->addFile(PHP_BINARY, 'php');
    $zip->registerProgressCallback(0.05, function ($r) {
        printf("%d%%\n", $r * 100);
    });
    $zip->close();
}

Ver también

  • ZipArchive::registerCancelCallback() - Registrar una llamada para permitir la cancelación durante el cierre del archivo


Renombra una entrada definida por su índice

  • « ZipArchive::registerProgressCallback
  • ZipArchive::renameName »
  • PHP Manual
  • ZipArchive
  • Renombra una entrada definida por su índice

ZipArchive::renameIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::renameIndex — Renombra una entrada definida por su índice

Descripción

ZipArchive::renameIndex ( int $index , string $newname ) : bool

Renombra una entrada definida por su índice.

Parámetros

index

Índice de la entrada a renombrar.

newname

Nombre nuevo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Renombra una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameIndex(2,'newname.txt');
    $zip->close();
} else {
    echo 'falló, código:' . $res;
}
?>


Renombra una entrada definida por su nombre

  • « ZipArchive::renameIndex
  • ZipArchive::replaceFile »
  • PHP Manual
  • ZipArchive
  • Renombra una entrada definida por su nombre

ZipArchive::renameName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::renameName — Renombra una entrada definida por su nombre

Descripción

ZipArchive::renameName ( string $name , string $newname ) : bool

Renombra una entrada definida por su nombre.

Parámetros

name

Nombre de la entrada a renombrar.

newname

Nombre nuevo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Renombra una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameName('currentname.txt','newname.txt');
    $zip->close();
} else {
    echo 'falló, código:' . $res;
}
?>


Reemplaza fichero en el archivo ZIP con una ruta determinada

  • « ZipArchive::renameName
  • ZipArchive::setArchiveComment »
  • PHP Manual
  • ZipArchive
  • Reemplaza fichero en el archivo ZIP con una ruta determinada

ZipArchive::replaceFile

(PHP >= 8.0.0, PECL zip >= 1.18.0)

ZipArchive::replaceFile — Reemplaza fichero en el archivo ZIP con una ruta determinada

Descripción

ZipArchive::replaceFile ( string $filename , int $index , int $start = 0 , int $length = 0 , int $flags = 0 ) : bool

Reemplaza fichero en el archivo ZIP con una ruta determinada.

Nota: Para una portabilidad máxima, se recomienda utilizar siempre barras hacia adelante (/) como separador de directorios en nombres de ficheros ZIP.

Parámetros

filename

La ruta del archivo a añadir.

index

El índice del archivo a reemplazar, su nombre no ha cambiado.

start

Para la copia parcial, posición de inicio.

length

Para la copia parcial, la longitud a copiar, si 0 o -1 el archivo completo es usado (a partir de start).

flags

La máscara de bits consiste en ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. El comportamiento de estas constantes se describe en la página constantes ZIP.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo abre un archivo ZIP test.zip y sustituye la entrada del índice 1 con /path/to/index.txt.

Ejemplo #1 Abrir y reemplazar

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->replaceFile('/path/to/index.txt', 1);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Ver también

  • ZipArchive::addFile() - Añade un fichero al archivo ZIP para la ruta dada


Establece el comentario de un archivo ZIP

  • « ZipArchive::replaceFile
  • ZipArchive::setCommentIndex »
  • PHP Manual
  • ZipArchive
  • Establece el comentario de un archivo ZIP

ZipArchive::setArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setArchiveComment — Establece el comentario de un archivo ZIP

Descripción

ZipArchive::setArchiveComment ( string $comment ) : bool

Establece el comentario de un archivo ZIP.

Parámetros

comment

Los contenidos del comentario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Crear un archivo y establecer un comentario

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'El contenido del fichero va aquí');
    $zip->setArchiveComment('nuevo comentario del archivo');
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>


Establece el comentario de una entrada definido por su índice

  • « ZipArchive::setArchiveComment
  • ZipArchive::setCommentName »
  • PHP Manual
  • ZipArchive
  • Establece el comentario de una entrada definido por su índice

ZipArchive::setCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setCommentIndex — Establece el comentario de una entrada definido por su índice

Descripción

ZipArchive::setCommentIndex ( int $index , string $comment ) : bool

Establece el comentario de una entrada definido por su índice.

Parámetros

index

Índice de la entrada.

comment

Los contenidos del comentario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Abrir un archivo y establecer un comentario para una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentIndex(2, 'comentario de la entrada nueva');
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>


Establece el comentario de una entrada definido por su nombre

  • « ZipArchive::setCommentIndex
  • ZipArchive::setCompressionIndex »
  • PHP Manual
  • ZipArchive
  • Establece el comentario de una entrada definido por su nombre

ZipArchive::setCommentName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setCommentName — Establece el comentario de una entrada definido por su nombre

Descripción

ZipArchive::setCommentName ( string $name , string $comment ) : bool

Establece el comentario de una entrada definido por su nombre.

Parámetros

name

Nombre de la entrada.

comment

Los contenidos del comentario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Abrir un archivo y establecer un comentario para una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentName('entry1.txt', 'comentario de la entrada nueva');
    $zip->close();
    echo 'ok';
} else {
    echo 'falló';
}
?>


Establecer el método de compresión de una entrada definida por su índice

  • « ZipArchive::setCommentName
  • ZipArchive::setCompressionName »
  • PHP Manual
  • ZipArchive
  • Establecer el método de compresión de una entrada definida por su índice

ZipArchive::setCompressionIndex

(PHP 7, PHP 8, PECL zip >= 1.13.0)

ZipArchive::setCompressionIndex — Establecer el método de compresión de una entrada definida por su índice

Descripción

ZipArchive::setCompressionIndex ( int $index , int $comp_method , int $comp_flags = 0 ) : bool

Establecer el método de compresión de una entrada definida por su índice.

Parámetros

index

El índice de la entrada.

comp_method

El método de compresión, una de las constantes ZipArchive::CM_*.

comp_flags

Nivel de compresión.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añadir ficheros con diferentes métodos de compresión a un archivo

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Un texto');
    $zip->addFromString('bar', 'Otro texto');
    $zip->setCompressionIndex(0, ZipArchive::CM_STORE);
    $zip->setCompressionIndex(1, ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'fallo';
}
?>


Establecer el método de compresión de una entrada definida por su nombre

  • « ZipArchive::setCompressionIndex
  • ZipArchive::setEncryptionIndex »
  • PHP Manual
  • ZipArchive
  • Establecer el método de compresión de una entrada definida por su nombre

ZipArchive::setCompressionName

(PHP 7, PHP 8, PECL zip >= 1.13.0)

ZipArchive::setCompressionName — Establecer el método de compresión de una entrada definida por su nombre

Descripción

ZipArchive::setCompressionName ( string $name , int $comp_method , int $comp_flags = 0 ) : bool

Establecer el método de compresión de una entrada definida por su nombre.

Parámetros

name

El nombre de la entrada.

comp_method

El método de compresión. Una de las constantes ZipArchive::CM_*.

comp_flags

Nivel de compresión.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añadir ficheros con diferentes métodos de compresión a un archivo

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Un texto');
    $zip->addFromString('bar', 'Otro texto');
    $zip->setCompressionName('foo', ZipArchive::CM_STORE);
    $zip->setCompressionName('bar', ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'fallo';
}
?>

Ejemplo #2 Añadir fichero y establecer el método de compresión

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFile('foo.jpg', 'bar.jpg');
    $zip->setCompressionName('bar.jpg', ZipArchive::CM_XZ);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Establece el método de cifrado de una entrada definida por su índice

  • « ZipArchive::setCompressionName
  • ZipArchive::setEncryptionName »
  • PHP Manual
  • ZipArchive
  • Establece el método de cifrado de una entrada definida por su índice

ZipArchive::setEncryptionIndex

(PHP >= 7.2.0, PHP 8, PECL zip >= 1.14.0)

ZipArchive::setEncryptionIndex — Establece el método de cifrado de una entrada definida por su índice

Descripción

ZipArchive::setEncryptionIndex ( int $index , string $method , string $password = ? ) : bool

Establece el método de cifrado de una entrada definida por su índice.

Parámetros

index

Índice de la entrada.

method

El método de cifrado definido por una de las constantes ZipArchive::EM_ constants.

password

Contraseña opcional, se utiliza por defecto cuando falta.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.2.0.

Ver también

  • ZipArchive::setPassword() - Establece la contraseña para el archivo activo
  • ZipArchive::setEncryptionName() - Establece el método de cifrado de una entrada definida por su nombre


Establece el método de cifrado de una entrada definida por su nombre

  • « ZipArchive::setEncryptionIndex
  • ZipArchive::setExternalAttributesIndex »
  • PHP Manual
  • ZipArchive
  • Establece el método de cifrado de una entrada definida por su nombre

ZipArchive::setEncryptionName

(PHP >= 7.2.0, PHP 8, PECL zip >= 1.14.0)

ZipArchive::setEncryptionName — Establece el método de cifrado de una entrada definida por su nombre

Descripción

ZipArchive::setEncryptionName ( string $name , int $method , string $password = ? ) : bool

Establece el método de cifrado de una entrada definida por su nombre.

Parámetros

name

Nombre de la entrada.

method

El método de encriptación definido por una de las constantes ZipArchive::EM_constants.

password

Contraseña opcional, se utiliza por defecto cuando falta.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo crea un archivo ZIP test.zip y añade al archivo test.txt encriptado usando el método AES 256.

Ejemplo #1 Archivar y encriptar un archivo

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->setPassword('secret');
    $zip->addFile('text.txt');
    $zip->setEncryptionName('text.txt', ZipArchive::EM_AES_256);
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.2.0.

Ver también

  • ZipArchive::setPassword() - Establece la contraseña para el archivo activo
  • ZipArchive::setEncryptionIndex() - Establece el método de cifrado de una entrada definida por su índice


Establece los atributos externos de una entrada definida por su índice

  • « ZipArchive::setEncryptionName
  • ZipArchive::setExternalAttributesName »
  • PHP Manual
  • ZipArchive
  • Establece los atributos externos de una entrada definida por su índice

ZipArchive::setExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesIndex — Establece los atributos externos de una entrada definida por su índice

Descripción

ZipArchive::setExternalAttributesIndex ( int $index , int $opsys , int $attr , int $flags = ? ) : bool

Establece los atributos externos de una entrada definida por su índice.

Parámetros

index

El índice de la entrada.

opsys

El código del sistema operativo definido por una de las constantes ZipArchive::OPSYS_.

attr

Los atributos externos. El valor depende del sistema operativo.

flags

Banderas opcionales. Actualmente no se utiliza.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece los atributos externos de una entrada definida por su nombre

  • « ZipArchive::setExternalAttributesIndex
  • ZipArchive::setMtimeIndex »
  • PHP Manual
  • ZipArchive
  • Establece los atributos externos de una entrada definida por su nombre

ZipArchive::setExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesName — Establece los atributos externos de una entrada definida por su nombre

Descripción

ZipArchive::setExternalAttributesName ( string $name , int $opsys , int $attr , int $flags = ? ) : bool

Establece los atributos externos de una entrada definida por su nombre.

Parámetros

name

El nombre de la entrada.

opsys

El código del sistema operativo definido por una de las constantes ZipArchive::OPSYS_.

attr

Los atributos externos. El valor depende del sistema operativo.

flags

Banderas opcionales. Actualmente no se utiliza.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo abre un archivo comprimido ZIP test.zip y añade el fichero test.txt con sus permisos Unix como atributos externos.

Ejemplo #1 Archivar un fichero, con sus permisos Unix

<?php
$zip = new ZipArchive();
$stat = stat($filename='test.txt');
if (is_array($stat) && $zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile($filename);
    $zip->setExternalAttributesName($filename, ZipArchive::OPSYS_UNIX, $stat['mode'] << 16);
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>


Establece el tiempo de modificación de una entrada definido por su índice

  • « ZipArchive::setExternalAttributesName
  • ZipArchive::setMtimeName »
  • PHP Manual
  • ZipArchive
  • Establece el tiempo de modificación de una entrada definido por su índice

ZipArchive::setMtimeIndex

(PHP >= 8.0.0, PECL zip >= 1.16.0)

ZipArchive::setMtimeIndex — Establece el tiempo de modificación de una entrada definido por su índice

Descripción

ZipArchive::setMtimeIndex ( int $index , int $timestamp , int $flags = ? ) : bool

Establece el tiempo de modificación de una entrada definido por su índice.

Parámetros

index

Índice de la entrada.

timestamp

La hora de modificación (unix timestamp) del archivo.

flags

Flags opcionales, sin usar por ahora.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo crea un archivo ZIP test.zip y añade al archivo test.txt con su fecha de modificación.

Ejemplo #1 Archivar un fichero

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile('text.txt');
    $zip->setMtimIndex(0, mktime(0,0,0,12,25,2019));
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.0.0.

Ver también

  • ZipArchive::setMtimeName() - Establece la hora de modificación de una entrada definida por su nombre


Establece la hora de modificación de una entrada definida por su nombre

  • « ZipArchive::setMtimeIndex
  • ZipArchive::setPassword »
  • PHP Manual
  • ZipArchive
  • Establece la hora de modificación de una entrada definida por su nombre

ZipArchive::setMtimeName

(PHP >= 8.0.0, PECL zip >= 1.16.0)

ZipArchive::setMtimeName — Establece la hora de modificación de una entrada definida por su nombre

Descripción

ZipArchive::setMtimeName ( string $name , int $timestamp , int $flags = ? ) : bool

Establece la hora de modificación de una entrada definida por su nombre.

Parámetros

name

Nombre de la entrada.

timestamp

La hora de modificación (unix timestamp) del archivo.

flags

Flags opcionales, sin usar por ahora.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Este ejemplo crea un archivo ZIP test.zip y añade al archivo test.txt con su fecha de modificación.

Ejemplo #1 Archivar un fichero

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile('text.txt');
    $zip->setMtimeName('text.txt', mktime(0,0,0,12,25,2019));
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

Notas

Nota:

Esta función sólo está disponible si se construye con libzip = 1.0.0.

Ver también

  • ZipArchive::setMtimeIndex() - Establece el tiempo de modificación de una entrada definido por su índice


Establece la contraseña para el archivo activo

  • « ZipArchive::setMtimeName
  • ZipArchive::statIndex »
  • PHP Manual
  • ZipArchive
  • Establece la contraseña para el archivo activo

ZipArchive::setPassword

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setPassword — Establece la contraseña para el archivo activo

Descripción

public ZipArchive::setPassword ( string $password ) : bool

Establece la contraseña para el archivo activo.

Parámetros

password

La contraseña a emplear para el archivo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

A partir de PHP 7.2.0 y libzip 1.2.0 la contraseña se utiliza para descomprimir el archivo, y también es la contraseña por omisión para ZipArchive::setEncryptionName() y ZipArchive::setEncryptionIndex(). Anteriormente, esta función sólo establecía la contraseña que se usaría para descomprimir el archivo; No se convirtió en un no protegido con contraseña ZipArchive en un protegido con contraseña ZipArchive.

Ver también

  • ZipArchive::setEncryptionIndex() - Establece el método de cifrado de una entrada definida por su índice
  • ZipArchive::setEncryptionName() - Establece el método de cifrado de una entrada definida por su nombre


Obtiene los detalles de una entrada definida por su índice

  • « ZipArchive::setPassword
  • ZipArchive::statName »
  • PHP Manual
  • ZipArchive
  • Obtiene los detalles de una entrada definida por su índice

ZipArchive::statIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::statIndex — Obtiene los detalles de una entrada definida por su índice

Descripción

ZipArchive::statIndex ( int $index , int $flags = ? ) : array

La función obtiene información acerca de la entrada definida por su índice.

Parámetros

index

Índice de la entrada

flags

ZipArchive::FL_UNCHANGED podría ser puesto con otros OR lógicos en él para pedir información acerca del fichero original en el archivo, ignorando cualquiera de los cambios hechos.

Valores devueltos

Devuelve una matríz conteniendo los detalles de la entrada, o false en caso de error.

Ejemplos

Ejemplo #1 Volcar la información estadística de una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statIndex(3));
    $zip->close();
} else {
    echo 'falló, código:' . $res;
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)


Obtener los detalles de una entrada definida por su nombre

  • « ZipArchive::statIndex
  • ZipArchive::unchangeAll »
  • PHP Manual
  • ZipArchive
  • Obtener los detalles de una entrada definida por su nombre

ZipArchive::statName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::statName — Obtener los detalles de una entrada definida por su nombre

Descripción

ZipArchive::statName ( string $name , int $flags = ? ) : array

La función obtiene información acerca de la entrada definida por su nombre.

Parámetros

name

Nombre de la entrada

flags

El argumento flags especifica cómo la búsqueda del nombre debería se hecho. También, ZipArchive::FL_UNCHANGED podría ser puesta con otros OR en él para solicitar la información acerca del fichero original en el archivo, ignorando cualquier cambio realizado.

  • ZipArchive::FL_NOCASE

  • ZipArchive::FL_NODIR

  • ZipArchive::FL_UNCHANGED

Valores devueltos

Devuelve una matríz que contenie detalles de la entrada o false en caso de error.

Ejemplos

Ejemplo #1 Volcar la información estadística de una entrada

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statName('foobar/baz'));
    $zip->close();
} else {
    echo 'falló, código:' . $res;
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)


Deshacer todos los cambios hechos en el archivo

  • « ZipArchive::statName
  • ZipArchive::unchangeArchive »
  • PHP Manual
  • ZipArchive
  • Deshacer todos los cambios hechos en el archivo

ZipArchive::unchangeAll

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeAll — Deshacer todos los cambios hechos en el archivo

Descripción

ZipArchive::unchangeAll ( ) : bool

Deshacer todos los cambios hechos en el archivo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Revertir todos los cambios globales hechos en el archivo

  • « ZipArchive::unchangeAll
  • ZipArchive::unchangeIndex »
  • PHP Manual
  • ZipArchive
  • Revertir todos los cambios globales hechos en el archivo

ZipArchive::unchangeArchive

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeArchive — Revertir todos los cambios globales hechos en el archivo

Descripción

ZipArchive::unchangeArchive ( ) : bool

Revertir todos los cambios globales en el archivo. Por ahora, esto solamente revierte los cambios de los comentarios del archivo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Revertir todos los cambios hechos a una entrada en el índice dado

  • « ZipArchive::unchangeArchive
  • ZipArchive::unchangeName »
  • PHP Manual
  • ZipArchive
  • Revertir todos los cambios hechos a una entrada en el índice dado

ZipArchive::unchangeIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeIndex — Revertir todos los cambios hechos a una entrada en el índice dado

Descripción

ZipArchive::unchangeIndex ( int $index ) : bool

Revertir todos los cambios hechos a una entrada en el índice dado.

Parámetros

index

Índice de la entrada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Deshace todos los cambios realizados a una entrada con un nombre dado

  • « ZipArchive::unchangeIndex
  • Funciones Zip »
  • PHP Manual
  • ZipArchive
  • Deshace todos los cambios realizados a una entrada con un nombre dado

ZipArchive::unchangeName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::unchangeName — Deshace todos los cambios realizados a una entrada con un nombre dado

Descripción

ZipArchive::unchangeName ( string $name ) : bool

Deshacer todos los cambios hechos a una entrada.

Parámetros

name

Nombre de la entrada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Funciones Zip

Tabla de contenidos

  • zip_close — Cierra un fichero ZIP
  • zip_entry_close — Cierra la entrada a un directorio
  • zip_entry_compressedsize — Obtiene el tamaño comprimido de una entrada de directorio
  • zip_entry_compressionmethod — Devuelve el método de compresión de una entrada de directorio
  • zip_entry_filesize — Devuelve el tamaño del fichero actual de una entrada de directorio
  • zip_entry_name — Devuelve el nombre de la entrada de un directorio
  • zip_entry_open — Abrir una entrada de directorio para lectura
  • zip_entry_read — Leer desde una entrada de directorio abierta
  • zip_open — Abre un fichero ZIP
  • zip_read — Leer la siguiente entrada en el fichero ZIP


Cierra un fichero ZIP

  • « Funciones Zip
  • zip_entry_close »
  • PHP Manual
  • Funciones Zip
  • Cierra un fichero ZIP

zip_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_close — Cierra un fichero ZIP

Descripción

zip_close ( resource $zip ) : void

Cierra el archivo ZIP archivo dado.

Parámetros

zip

Un fichero ZIP previamente abierto con zip_open().

Valores devueltos

No devuelve ningún valor.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_read() - Leer la siguiente entrada en el fichero ZIP


Cierra la entrada a un directorio

  • « zip_close
  • zip_entry_compressedsize »
  • PHP Manual
  • Funciones Zip
  • Cierra la entrada a un directorio

zip_entry_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_close — Cierra la entrada a un directorio

Descripción

zip_entry_close ( resource $zip_entry ) : bool

Cierra la entrada del directorio especificado.

Parámetros

zip_entry

Una entrada del directorio previamente abierto con zip_entry_open().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • zip_entry_open() - Abrir una entrada de directorio para lectura
  • zip_entry_read() - Leer desde una entrada de directorio abierta


Obtiene el tamaño comprimido de una entrada de directorio

  • « zip_entry_close
  • zip_entry_compressionmethod »
  • PHP Manual
  • Funciones Zip
  • Obtiene el tamaño comprimido de una entrada de directorio

zip_entry_compressedsize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_compressedsize — Obtiene el tamaño comprimido de una entrada de directorio

Descripción

zip_entry_compressedsize ( resource $zip_entry ) : int

Devuelve el tamaño comprimido de una especifica entrada de directorio.

Parámetros

zip_entry

Una entrada de directorio devuelva por zip_read().

Valores devueltos

El tamaño comprimido.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_read() - Leer la siguiente entrada en el fichero ZIP


Devuelve el método de compresión de una entrada de directorio

  • « zip_entry_compressedsize
  • zip_entry_filesize »
  • PHP Manual
  • Funciones Zip
  • Devuelve el método de compresión de una entrada de directorio

zip_entry_compressionmethod

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_compressionmethod — Devuelve el método de compresión de una entrada de directorio

Descripción

zip_entry_compressionmethod ( resource $zip_entry ) : string

Devuelve el método de compresión de una entrada de directorio especificada por zip_entry.

Parámetros

zip_entry

Una entrada de directorio devuelta por zip_read().

Valores devueltos

El método de compresión.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_read() - Leer la siguiente entrada en el fichero ZIP


Devuelve el tamaño del fichero actual de una entrada de directorio

  • « zip_entry_compressionmethod
  • zip_entry_name »
  • PHP Manual
  • Funciones Zip
  • Devuelve el tamaño del fichero actual de una entrada de directorio

zip_entry_filesize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_filesize — Devuelve el tamaño del fichero actual de una entrada de directorio

Descripción

zip_entry_filesize ( resource $zip_entry ) : int

Devuelve el tamaño actual de una entrada de directorio específica.

Parámetros

zip_entry

Una entrada de directorio devuelva por zip_read().

Valores devueltos

El tamaño de una entrada de directorio.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_read() - Leer la siguiente entrada en el fichero ZIP


Devuelve el nombre de la entrada de un directorio

  • « zip_entry_filesize
  • zip_entry_open »
  • PHP Manual
  • Funciones Zip
  • Devuelve el nombre de la entrada de un directorio

zip_entry_name

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_name — Devuelve el nombre de la entrada de un directorio

Descripción

zip_entry_name ( resource $zip_entry ) : string

Devuelve el nombre de una entrada de directorio específica.

Parámetros

zip_entry

Una entrada de directorio devuelta por zip_read().

Valores devueltos

El nombre de la entrada de directorio.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_read() - Leer la siguiente entrada en el fichero ZIP


Abrir una entrada de directorio para lectura

  • « zip_entry_name
  • zip_entry_read »
  • PHP Manual
  • Funciones Zip
  • Abrir una entrada de directorio para lectura

zip_entry_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_open — Abrir una entrada de directorio para lectura

Descripción

zip_entry_open ( resource $zip , resource $zip_entry , string $mode = ? ) : bool

Abre una entrada de directorio en un fichero zip para lectura.

Parámetros

zip

Un válido controlador de recurso es devuelto por zip_open().

zip_entry

Una entrada de directorio es devuelta por zip_read().

mode

Cualquiera de los modos especificados en la documentación de fopen().

Nota:

Actualmente, el mode es ignorado y es siempre "rb". Esto es debido al hecho que el soporte zip en PHP es solamente de acceso lectura.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Nota:

A diferencia de fopen() y otras funciones similares, el valor devuelto por zip_entry_open() solo indica el resultado de la operación y no es necesario para la lectura o cerrado de la entrada de directorio.

Ver también

  • zip_entry_close() - Cierra la entrada a un directorio
  • zip_entry_read() - Leer desde una entrada de directorio abierta


Leer desde una entrada de directorio abierta

  • « zip_entry_open
  • zip_open »
  • PHP Manual
  • Funciones Zip
  • Leer desde una entrada de directorio abierta

zip_entry_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_read — Leer desde una entrada de directorio abierta

Descripción

zip_entry_read ( resource $zip_entry , int $length = 1024 ) : string

Lee desde una entrada de directorio abierta.

Parámetros

zip_entry

Un directorio devuelto por zip_read().

length

El número de bytes a devolver.

Nota:

Esto debería ser el tramo descomprimido que se desea leer.

Valores devueltos

Devuelve los datos leídos, un string vacío si se encuentra al final de un fichero, o false en case de error.

Ver también

  • zip_entry_open() - Abrir una entrada de directorio para lectura
  • zip_entry_close() - Cierra la entrada a un directorio
  • zip_entry_filesize() - Devuelve el tamaño del fichero actual de una entrada de directorio


Abre un fichero ZIP

  • « zip_entry_read
  • zip_read »
  • PHP Manual
  • Funciones Zip
  • Abre un fichero ZIP

zip_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_open — Abre un fichero ZIP

Descripción

zip_open ( string $filename ) : resource

Abre un nuevo fichero ZIP para su lectura.

Parámetros

filename

El nombre del fichero ZIP a abrir.

Valores devueltos

Devuelve un manejador del recurso para usarlo después con zip_read() y zip_close() o devolver el número de error si filename no existe o en caso de otro error.

Ver también

  • zip_read() - Leer la siguiente entrada en el fichero ZIP
  • zip_close() - Cierra un fichero ZIP


Leer la siguiente entrada en el fichero ZIP

  • « zip_open
  • Zlib »
  • PHP Manual
  • Funciones Zip
  • Leer la siguiente entrada en el fichero ZIP

zip_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_read — Leer la siguiente entrada en el fichero ZIP

Descripción

zip_read ( resource $zip ) : resource

Lee la siguiente entrada en un fichero zip.

Parámetros

zip

Un fichero ZIP previamente abierto con zip_open().

Valores devueltos

Devuelve un recurso de una entrada de directorio para poder usar luego las funciones zip_entry_..., o false si no hay más entradas a leer, o código de error en caso de ocurrir otro error.

Ver también

  • zip_open() - Abre un fichero ZIP
  • zip_close() - Cierra un fichero ZIP
  • zip_entry_open() - Abrir una entrada de directorio para lectura
  • zip_entry_read() - Leer desde una entrada de directorio abierta


Compresión Zlib

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Zlib
    • deflate_add — Incrementally deflate data
    • deflate_init — Initialize an incremental deflate context
    • gzclose — Cierra el apuntador de un archivo gz abierto
    • gzcompress — Comprime una cadena
    • gzdecode — Decodifica una cadena comprimida con gzip
    • gzdeflate — Comprime una cadena
    • gzencode — Crea una cadena comprimida con gzip
    • gzeof — Prueba de apuntador para EOF de archivo gz
    • gzfile — Lee un archivo gz completo en una matriz
    • gzgetc — Obtiene el caracter donde está el apuntador al archivo gz
    • gzgets — Obtiene la línea del apuntador al archivo
    • gzgetss — Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML
    • gzinflate — Descomprime una cadena comprimida
    • gzopen — Abre un archivo gz
    • gzpassthru — Muestra todos los datos restantes a partir del apuntador al achivo gz
    • gzputs — Alias de gzwrite
    • gzread — Lectura de archivo gz segura a nivel binario
    • gzrewind — Reinicia la posición del apuntador a un archivo gz
    • gzseek — Ubica el apuntador a un archivo gz
    • gztell — Indica la posición de lectura/escritura del apuntador al archivo gz
    • gzuncompress — Descomprime una cadena comprimida
    • gzwrite — Escritura en un archivo gz, segura a nivel binario
    • inflate_add — Incrementally inflate encoded data
    • inflate_get_read_len — Get number of bytes read so far
    • inflate_get_status — Get decompression status
    • inflate_init — Initialize an incremental inflate context
    • readgzfile — Muestra un archivo gz
    • zlib_decode — Descomprime datos codificados en craw/gzip/zlib
    • zlib_encode — Comprime datos con la codificación especificada
    • zlib_get_coding_type — Retorna el tipo de codificación utilizada para hacer la compresión
  • DeflateContext — The DeflateContext class
  • InflateContext — The InflateContext class


Introducción

Este módulo permite leer y escribir ficheros comprimidos con gzip (.gz) de forma transparente, a través de las versiones de la mayoría de las funciones de sistemas de ficheros que trabajan con ficheros comprimidos con gzip (y también con ficheros descomprimidos, pero no con sockets).

Nota:

La versión 4.0.4 introdujo una envoltura basada en fopen para ficheros .gz, así que se puede usar la URL especial zlib: para acceder de forma trasparente a los ficheros comprimidos usando las funciones normales f*() de acceso a ficheros si se prefija el nombre de fichero o la ruta con zlib: cuando se llama a fopen(). Esta característica requiere una biblioteca en tiempo de ejecución en C que provea la función fopencookie(). Hasta ahora, GNU libc parece ser la única biblioteca que ofrece esta característica.

En PHP 4.3.0, zlib: ha sido cambiado a compress.zlib:// para evitar ambigüedades con los nombres de fichero que contengan caracteres ':'. La función fopencookie() ya no es necesaria. Hay más información disponible en la sección sobre zlib://.


Requerimientos

Este módulo usa las funciones de » zlib por Jean-loup Gailly y Mark Adler. Se tiene que utilizar la versión >= 1.0.9 de zlib con éste módulo. Desde PHP 5.4.0 se tiene que usar zlib >= 1.2.0.4.


Instalación

El soporte para Zlib en PHP no está activado por defecto. Es necesario configurar PHP con la opción --with-zlib[=DIR]

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

La extensión zlib ofrece la opción de comprimir de manera trasparente las páginas sobre la marcha, si el navegador que hace la solicitud lo soporta. Por lo tanto hay tres opciones en el archivo de configuración php.ini.

Opciones de Configuración de Zlib
Nombre | Por defecto | Cambiable | Historial de cambios
zlib.output_compression | "0" | PHP_INI_ALL |
zlib.output_compression_level | "-1" | PHP_INI_ALL |
zlib.output_handler | "" | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

zlib.output_compression boolean/integer

Para comprimir páginas transparentemente. Si esta opción está configurada en "On" en php.ini o en la configuración de Apache, las páginas serán comprimidas si el navegador envía un encabezado "Accept-Encoding: gzip" o "deflate". Los encabezados "Content-Encoding: gzip" (respectivamente "deflate") y "Vary: Accept-Encoding" serán agregados a la salida. En tiempo de ejecución, esto se puede configurar sólo antes de enviar cualquier salida.

Esta opción también acepta valores enteros en lugar del booleano "On"/"Off", usando esto se puede configurar el tamaño del buffer de salida (por defecto es 4KB).

Nota:

output_handler debe estar vacío si ésta se configura en 'On' ! De otra manera se debe usar zlib.output_handler.

zlib.output_compression_level integer

Nivel de compresión usado para la salida de la compresión transparente. Especifica un valor entre 0 (no comprimido) y 9 (máxima compresión). El valor por defecto es -1, que deja que el servidor decida cual nivel utilizar.

zlib.output_handler string

No se pueden especificar manejadores adicionales de salida si zlib.output_compression está activada aquí. Esta configuración hace lo mismo que output_handler pero en un orden diferente.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un recurso de archivo puntero retornado por gzopen().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

FORCE_GZIP (integer)
FORCE_DEFLATE (integer)
ZLIB_ENCODING_RAW (integer)
Algoritmo DEFLATE según RFC 1951. Disponible desde PHP 7.0.0.
ZLIB_ENCODING_DEFLATE (integer)
Algoritmo de compresión ZLIB según RFC 1950. Disponible desde PHP 7.0.0.
ZLIB_ENCODING_GZIP (integer)
Algoritmo GZIP según RFC 1952. Disponible desde PHP 7.0.0.
ZLIB_FILTERED (integer)
Disponible desde PHP 7.0.0.
ZLIB_HUFFMAN_ONLY (integer)
Disponible desde PHP 7.0.0.
ZLIB_FIXED (integer)
Disponible desde PHP 7.0.0.
ZLIB_RLE (integer)
Disponible desde PHP 7.0.0.
ZLIB_DEFAULT_STRATEGY (integer)
Disponible desde PHP 7.0.0.
ZLIB_BLOCK (integer)
Disponible desde PHP 7.0.0.
ZLIB_NO_FLUSH (integer)
Disponible desde PHP 7.0.0.
ZLIB_PARTIAL_FLUSH (integer)
Disponible desde PHP 7.0.0.
ZLIB_SYNC_FLUSH (integer)
Disponible desde PHP 7.0.0.
ZLIB_FULL_FLUSH (integer)
Disponible desde PHP 7.0.0.
ZLIB_FINISH (integer)
Disponible desde PHP 7.0.0.


Ejemplos

Este ejemplo abre un archivo temporal y escribe una cadena de prueba en él, entonces muestra el contenido de este archivo dos veces.

Ejemplo #1 Pequeño Ejemplo de Zlib

<?php

$filename = tempnam('/tmp', 'zlibtest') . '.gz';
echo "<html>\n<head></head>\n<body>\n<pre>\n";
$s = "Sólo una prueba, prueba, prueba, prueba, prueba, prueba!\n";

// abre el archivo para escribir con compresión máxima
$zp = gzopen($filename, "w9");

// escribe la cadena en el archivo
gzwrite($zp, $s);

// cierra el archivo
gzclose($zp);

// abre el archivo para lectura
$zp = gzopen($filename, "r");

// lee el tercer carácter
echo gzread($zp, 3);

// salida hasta el fin del archivo y lo cierra
gzpassthru($zp);
gzclose($zp);

echo "\n";

// abre el archivo y muestra el contenido (por segunda vez).
if (readgzfile($filename) != strlen($s)) {
        echo "Error con funciones de zlib!";
}
unlink($filename);
echo "</pre>\n</body>\n</html>\n";

?>

Ejemplo #2 Trabajando con la API de compresión y descompresión increemental desde PHP 7.0.0

// Perform GZIP compression:
$deflateContext = deflate_init(ZLIB_ENCODING_GZIP);
$compressed = deflate_add($deflateContext, "Data to compress", ZLIB_NO_FLUSH);
$compressed .= deflate_add($deflateContext, ", more data", ZLIB_NO_FLUSH);
$compressed .= deflate_add($deflateContext, ", and even more data!", ZLIB_FINISH);?>

// Perform GZIP decompression:
$inflateContext = inflate_init(ZLIB_ENCODING_GZIP);
$uncompressed = inflate_add($inflateContext, $compressed, ZLIB_NO_FLUSH);
$uncompressed .= inflate_add($inflateContext, NULL, ZLIB_FINISH);
echo $uncompressed;

El resultado del ejemplo sería:

Data to compress, more data, and even more data!


Funciones de Zlib

Tabla de contenidos

  • deflate_add — Incrementally deflate data
  • deflate_init — Initialize an incremental deflate context
  • gzclose — Cierra el apuntador de un archivo gz abierto
  • gzcompress — Comprime una cadena
  • gzdecode — Decodifica una cadena comprimida con gzip
  • gzdeflate — Comprime una cadena
  • gzencode — Crea una cadena comprimida con gzip
  • gzeof — Prueba de apuntador para EOF de archivo gz
  • gzfile — Lee un archivo gz completo en una matriz
  • gzgetc — Obtiene el caracter donde está el apuntador al archivo gz
  • gzgets — Obtiene la línea del apuntador al archivo
  • gzgetss — Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML
  • gzinflate — Descomprime una cadena comprimida
  • gzopen — Abre un archivo gz
  • gzpassthru — Muestra todos los datos restantes a partir del apuntador al achivo gz
  • gzputs — Alias de gzwrite
  • gzread — Lectura de archivo gz segura a nivel binario
  • gzrewind — Reinicia la posición del apuntador a un archivo gz
  • gzseek — Ubica el apuntador a un archivo gz
  • gztell — Indica la posición de lectura/escritura del apuntador al archivo gz
  • gzuncompress — Descomprime una cadena comprimida
  • gzwrite — Escritura en un archivo gz, segura a nivel binario
  • inflate_add — Incrementally inflate encoded data
  • inflate_get_read_len — Get number of bytes read so far
  • inflate_get_status — Get decompression status
  • inflate_init — Initialize an incremental inflate context
  • readgzfile — Muestra un archivo gz
  • zlib_decode — Descomprime datos codificados en craw/gzip/zlib
  • zlib_encode — Comprime datos con la codificación especificada
  • zlib_get_coding_type — Retorna el tipo de codificación utilizada para hacer la compresión


Incrementally deflate data

  • « Funciones de Zlib
  • deflate_init »
  • PHP Manual
  • Funciones de Zlib
  • Incrementally deflate data

deflate_add

(PHP 7, PHP 8)

deflate_add — Incrementally deflate data

Descripción

deflate_add ( DeflateContext $context , string $data , int $flush_mode = ZLIB_SYNC_FLUSH ) : string|false

Incrementally deflates data in the specified context.

Parámetros

context

A context created with deflate_init().

data

A chunk of data to compress.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

Valores devueltos

Returns a chunk of compressed data, o false en caso de error.

Errores/Excepciones

If invalid arguments are given, an error of level E_WARNING is generated.

Historial de cambios

Versión | Descripción
8.0.0 | context expects a DeflateContext instance now; previously, a resource was expected.

Ver también

  • deflate_init() - Initialize an incremental deflate context


Initialize an incremental deflate context

  • « deflate_add
  • gzclose »
  • PHP Manual
  • Funciones de Zlib
  • Initialize an incremental deflate context

deflate_init

(PHP 7, PHP 8)

deflate_init — Initialize an incremental deflate context

Descripción

deflate_init ( int $encoding , array $options = [] ) : DeflateContext|false

Initializes an incremental deflate context using the specified encoding.

Note that the window option here only sets the window size of the algorithm, differently from the zlib filters where the same parameter also sets the encoding to use; the encoding must be set with the encoding parameter.

Limitation: there is currently no way to set the header information on a GZIP compressed stream, which are set as follows: GZIP signature (\x1f\x8B); compression method (\x08 == DEFLATE); 6 zero bytes; the operating system set to the current system (\x00 = Windows, \x03 = Unix, etc.)

Parámetros

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15. zlib changes a window size of 8 to 9, and as of zlib 1.2.8 fails with a warning, if a window size of 8 is requested for ZLIB_ENCODING_RAW or ZLIB_ENCODING_GZIP.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

Valores devueltos

Returns a deflate context resource (zlib.deflate) on success, o false en caso de error.

Errores/Excepciones

If an invalid option is passed to options or the context couldn't be created, an error of level E_WARNING is generated.

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns a DeflateContext instance now; previously, a resource was returned.

Ver también

  • deflate_add() - Incrementally deflate data
  • inflate_init() - Initialize an incremental inflate context


Cierra el apuntador de un archivo gz abierto

  • « deflate_init
  • gzcompress »
  • PHP Manual
  • Funciones de Zlib
  • Cierra el apuntador de un archivo gz abierto

gzclose

(PHP 4, PHP 5, PHP 7, PHP 8)

gzclose — Cierra el apuntador de un archivo gz abierto

Descripción

gzclose ( resource $zp ) : bool

Cierra el apuntador del archivo gz dado.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gzclose()

<?php
$gz = gzopen('somefile.gz','w9');
gzputs ($gz, 'I was added to somefile.gz');
gzclose($gz);
?>

Ver también

  • gzopen() - Abre un archivo gz


Comprime una cadena

  • « gzclose
  • gzdecode »
  • PHP Manual
  • Funciones de Zlib
  • Comprime una cadena

gzcompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

gzcompress — Comprime una cadena

Descripción

gzcompress ( string $data , int $level = -1 , int $encoding = ZLIB_ENCODING_DEFLATE ) : string

Esta función comprime la cadena dada usando el formato de datos ZLIB.

Para detalles sobre el algoritmo de compresión ZLIB, ver el documento "» ZLIB Compressed Data Format Specification version 3.3" (RFC 1950).

Nota:

Esto no es lo mismo que la compresión que gzip, la cuál incluye algunos encabezados de datos. Ver gzencode() para la compresión gzip.

Parámetros

data

Los datos a comprimir.

level

El nivel de compresión. Se puede dar como 0 para ninguna compresión, hasta 9 para la máxima compresión.

Si se utiliza -1, se usará la compresión por defecto de la librería zlib la cual es 6.

encoding

Una de las constentes ZLIB_ENCODING_*.

Valores devueltos

La cadena comprimida o false si ocurre un error.

Ejemplos

Ejemplo #1 Ejemplo de gzcompress()

<?php
$compressed = gzcompress('Compress me', 9);
echo $compressed;
?>

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro encoding.

Ver también

  • gzdeflate() - Comprime una cadena
  • gzinflate() - Descomprime una cadena comprimida
  • gzuncompress() - Descomprime una cadena comprimida
  • gzencode() - Crea una cadena comprimida con gzip


Decodifica una cadena comprimida con gzip

  • « gzcompress
  • gzdeflate »
  • PHP Manual
  • Funciones de Zlib
  • Decodifica una cadena comprimida con gzip

gzdecode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

gzdecode — Decodifica una cadena comprimida con gzip

Descripción

gzdecode ( string $data , int $length = ? ) : string

Está función retorna una versión decodificada de la entrada data.

Parámetros

data

Los datos para decodificar, codificados con gzencode().

length

La longitud máxima de datos que decodificar.

Valores devueltos

La cadena decodificada o false si ocurre un error.

Ver también

  • gzencode() - Crea una cadena comprimida con gzip


Comprime una cadena

  • « gzdecode
  • gzencode »
  • PHP Manual
  • Funciones de Zlib
  • Comprime una cadena

gzdeflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzdeflate — Comprime una cadena

Descripción

gzdeflate ( string $data , int $level = -1 , int $encoding = ZLIB_ENCODING_RAW ) : string

Esta función comprime la cadena dada utilizando el formato de datos DEFLATE.

Para más detalles sobre el algoritmo de compresión DEFLATE ver el documento "» DEFLATE Compressed Data Format Specification version 1.3" (RFC 1951).

Parámetros

data

Los datos a comprimir.

level

El nivel de compresión. Se puede dar desde 0 para ninguna compresión hasta 9 para máxima compresión. Si no se especifica, se utilizará el nivel de compresión por defecto de la librería zlib.

encoding

Una de las constantes ZLIB_ENCODING_*.

Valores devueltos

La cadena comprimida o false si ocurre un error.

Ejemplos

Ejemplo #1 Ejemplo de gzdeflate()

<?php
$compressed = gzdeflate('Compress me', 9);
echo $compressed;
?>

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro encoding.

Ver también

  • gzinflate() - Descomprime una cadena comprimida
  • gzcompress() - Comprime una cadena
  • gzuncompress() - Descomprime una cadena comprimida
  • gzencode() - Crea una cadena comprimida con gzip


Crea una cadena comprimida con gzip

  • « gzdeflate
  • gzeof »
  • PHP Manual
  • Funciones de Zlib
  • Crea una cadena comprimida con gzip

gzencode

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzencode — Crea una cadena comprimida con gzip

Descripción

gzencode ( string $data , int $level = -1 , int $encoding_mode = FORCE_GZIP ) : string

Esta función retorna una versión comprimida de la data de entrada, compatible con la salida del programa gzip.

Para más información sobre el formato de archivo GZIP, ver el documento: » GZIP file format specification version 4.3 (RFC 1952).

Parámetros

data

Los datos a codificar.

level

El nivel de compresión. Se puede dar como 0 para ninguna compresión, hasta 9 para la máxima compresión. Si no se incluye, se utilizará el nivel de compresión por defecto de la librería zlib.

encoding_mode

El modo de codificación. Puede ser FORCE_GZIP (por defecto) o FORCE_DEFLATE.

Antes de PHP 5.4.0, utilizar FORCE_DEFLATE resultaba en un string comprimido zlib estándar (incluyendo encabezados de la librería) después del encabezado de archivo gzip pero sin el cierre de la suma de control crc32.

En PHP 5.4.0 y posterior, FORCE_DEFLATE genera una salida que cumple el RFC 1950, consistente en un encabezado zlib, los datos comprimidos y una suma de control Adler.

Valores devueltos

La cadena codificada o false si ocurre un error.

Historial de cambios

Versión | Descripción
5.4.0 | FORCE_DEFLATE ahora genera una salida que cumple el RFC 1950.

Ejemplos

Los datos resultantes contienen los encabezados y estructura de datos apropiados para construir un archivo .gz estándar, por ejemplo:

Ejemplo #1 Creando un archivo gzip

<?php
$data = implode("", file("bigfile.txt"));
$gzdata = gzencode($data, 9);
$fp = fopen("bigfile.txt.gz", "w");
fwrite($fp, $gzdata);
fclose($fp);
?>

Ver también

  • gzdecode() - Decodifica una cadena comprimida con gzip
  • gzdeflate() - Comprime una cadena
  • gzinflate() - Descomprime una cadena comprimida
  • gzuncompress() - Descomprime una cadena comprimida
  • gzcompress() - Comprime una cadena
  • » Especificación del formato ZLIB de compresión de datos (RFC 1950)


Prueba de apuntador para EOF de archivo gz

  • « gzencode
  • gzfile »
  • PHP Manual
  • Funciones de Zlib
  • Prueba de apuntador para EOF de archivo gz

gzeof

(PHP 4, PHP 5, PHP 7, PHP 8)

gzeof — Prueba de apuntador para EOF de archivo gz

Descripción

gzeof ( resource $zp ) : int

Prueba el apuntador de archivo GZ dado en busca del EOF (fin de archivo).

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

Retorna true si el apuntador GZ está al EOF del archivo o si ocurrió un error; de lo contrario retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gzeof()

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>


Lee un archivo gz completo en una matriz

  • « gzeof
  • gzgetc »
  • PHP Manual
  • Funciones de Zlib
  • Lee un archivo gz completo en una matriz

gzfile

(PHP 4, PHP 5, PHP 7, PHP 8)

gzfile — Lee un archivo gz completo en una matriz

Descripción

gzfile ( string $filename , int $use_include_path = 0 ) : array

Está función es identica a readgzfile(), excepto que retorna el archivo en una matriz.

Parámetros

filename

El nombre del archivo.

use_include_path

Se puede asignar este parámetro opcional en 1, si se desea buscar también el archivo en la ruta include_path.

Valores devueltos

Una matriz que contiene el archivo, una línea por celda, incluidas líneas vacías, y con líneas nuevas aún unidas.

Ejemplos

Ejemplo #1 Ejemplo de gzfile()

<?php
$lines = gzfile('somefile.gz');
foreach ($lines as $line) {
    echo $line;
}
?>

Ver también

  • readgzfile() - Muestra un archivo gz
  • gzopen() - Abre un archivo gz


Obtiene el caracter donde está el apuntador al archivo gz

  • « gzfile
  • gzgets »
  • PHP Manual
  • Funciones de Zlib
  • Obtiene el caracter donde está el apuntador al archivo gz

gzgetc

(PHP 4, PHP 5, PHP 7, PHP 8)

gzgetc — Obtiene el caracter donde está el apuntador al archivo gz

Descripción

gzgetc ( resource $zp ) : string

Retorna una cadena que contiene un solo caracter (sin comprimir) leído del apuntador al archivo gz dado.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

El caracter sin comprimir o false en caso de EOF (a diferencia de gzeof()).

Ejemplos

Ejemplo #1 Ejemplo de gzgetc()

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

Ver también

  • gzopen() - Abre un archivo gz
  • gzgets() - Obtiene la línea del apuntador al archivo


Obtiene la línea del apuntador al archivo

  • « gzgetc
  • gzgetss »
  • PHP Manual
  • Funciones de Zlib
  • Obtiene la línea del apuntador al archivo

gzgets

(PHP 4, PHP 5, PHP 7, PHP 8)

gzgets — Obtiene la línea del apuntador al archivo

Descripción

gzgets ( resource $zp , int $length = ? ) : string

Obtiene una cadena (sin comprimir) de hasta un largo de - 1 bytes leídos desde el apuntador al archivo dado. La lectura termina cuando el largo de - 1 bytes ha sido leído, en un salto de línea o cuando se alcance el fin del archivo (EOF), lo que ocurra primero.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

length

La longitud de los datos a obtener.

Valores devueltos

La cadena sin comprimir o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gzgets()

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgets($handle, 4096);
   echo $buffer;
}
gzlose($handle);;
?>

Ver también

  • gzopen() - Abre un archivo gz
  • gzgetc() - Obtiene el caracter donde está el apuntador al archivo gz
  • gzwrite() - Escritura en un archivo gz, segura a nivel binario


Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML

  • « gzgets
  • gzinflate »
  • PHP Manual
  • Funciones de Zlib
  • Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML

gzgetss

(PHP 4, PHP 5, PHP 7)

gzgetss — Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.3.0. Su uso está totalmente desaconsejado.

Descripción

gzgetss ( resource $zp , int $length , string $allowable_tags = ? ) : string

Función identica a gzgets(), excepto que gzgetss() intenta retirar cualquier etiqueta HTML y PHP del texto que esta leyendo.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

length

La longitud de los datos a obtener.

allowable_tags

Se puede usar éste parámetro opcional para especificar cuales etiquetas no se deben retirar.

Valores devueltos

La cadena descomprimida y sin etiquetas o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gzgetss()

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgetss($handle, 4096);
   echo $buffer;
}
gzlose($handle);
?>

Ver también

  • gzopen() - Abre un archivo gz
  • gzgets() - Obtiene la línea del apuntador al archivo
  • strip_tags() - Retira las etiquetas HTML y PHP de un string


Descomprime una cadena comprimida

  • « gzgetss
  • gzopen »
  • PHP Manual
  • Funciones de Zlib
  • Descomprime una cadena comprimida

gzinflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzinflate — Descomprime una cadena comprimida

Descripción

gzinflate ( string $data , int $length = 0 ) : string

Esta función descomprime una cadena comprimida.

Parámetros

data

Los datos comprimidos con gzdeflate().

length

La longitud máxima de datos a decodificar.

Valores devueltos

Los datos originales descomprimidos o false en caso de error.

La función retornará un error si los datos descomprimidos son más de 32768 veces la longitud de la data de entrada o mayores que el parámetro opcional length.

Ejemplos

Ejemplo #1 Ejemplo de gzinflate()

<?php
$compressed   = gzdeflate('Compress me', 9);
$uncompressed = gzinflate($compressed);
echo $uncompressed;
?>

Ver también

  • gzdeflate() - Comprime una cadena
  • gzcompress() - Comprime una cadena
  • gzuncompress() - Descomprime una cadena comprimida
  • gzencode() - Crea una cadena comprimida con gzip


Abre un archivo gz

  • « gzinflate
  • gzpassthru »
  • PHP Manual
  • Funciones de Zlib
  • Abre un archivo gz

gzopen

(PHP 4, PHP 5, PHP 7, PHP 8)

gzopen — Abre un archivo gz

Descripción

gzopen ( string $filename , string $mode , int $use_include_path = 0 ) : resource

Abre un archivo gzip (.gz) para lectura o escritura.

gzopen() se puede usar para leer un archivo el cual no esté en formato gzip; en este caso gzread() leerá directamente el archivo sin descomprimirlo.

Parámetros

filename

El nombre del archivo.

mode

Como en fopen() (rb o wb) pero también puede incluir un nivel de compresión (wb9) u una estrategia: f para datos filtrados como en wb6f, h para compresión Huffman solamente como en wb1h. (Ver la descripción de deflateInit2 en zlib.h para más información sobre el parámetro de estrategia.)

use_include_path

Se puede configurar este parámetro opcional en 1, si se desea buscar también el archivo en la ruta include_path.

Valores devueltos

Retorna un apuntador hacia el archivo abierto, después de eso, cualquier cosa que se lea desde este descriptor de archivo sera descomprimido de forma transparente y lo que se escriba será comprimido.

Si falla la apertura, la función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gzopen()

<?php
$fp = gzopen("/tmp/file.gz", "r");
?>

Ver también

  • gzclose() - Cierra el apuntador de un archivo gz abierto


Muestra todos los datos restantes a partir del apuntador al achivo gz

  • « gzopen
  • gzputs »
  • PHP Manual
  • Funciones de Zlib
  • Muestra todos los datos restantes a partir del apuntador al achivo gz

gzpassthru

(PHP 4, PHP 5, PHP 7, PHP 8)

gzpassthru — Muestra todos los datos restantes a partir del apuntador al achivo gz

Descripción

gzpassthru ( resource $zp ) : int

Lee hasta el EOF desde la posición en el apuntador al archivo gz y escribe los resultados (sin comprimir) en la salida estándar.

Nota:

Se puede necesitar llamar a la función gzrewind() para restablecer el apuntador al inicio del archivo, si ya se han escrito datos en él.

Sugerencia

Si sólo se desea volcar el contenido de un archivo en el buffer de salida, sin modificarlo primero o buscando una posición particular, se puede usar la función readgzfile(), la cual ahorra el llamado a la función gzopen().

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

El número de carácteres sin comprimir leídos de gz y pasados a través de la entrada, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gzpassthru()

<?php
$fp = gzopen('file.gz', 'r');
gzpassthru($fp);
gzclose($fp);
?>


Alias de gzwrite

  • « gzpassthru
  • gzread »
  • PHP Manual
  • Funciones de Zlib
  • Alias de gzwrite

gzputs

(PHP 4, PHP 5, PHP 7, PHP 8)

gzputs — Alias de gzwrite()

Descripción

Esta función es un alias de: gzwrite().


Lectura de archivo gz segura a nivel binario

  • « gzputs
  • gzrewind »
  • PHP Manual
  • Funciones de Zlib
  • Lectura de archivo gz segura a nivel binario

gzread

(PHP 4, PHP 5, PHP 7, PHP 8)

gzread — Lectura de archivo gz segura a nivel binario

Descripción

gzread ( resource $zp , int $length ) : string

gzread() lee los bytes hasta el parámetro length desde el apuntador al archivo gz dado. La lectura se detiene cuando los bytes del parámetro length (sin comprimir) sean leídos o cuando se alcance el fin del archivo (EOF), lo que ocurra primero.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

length

El número de bytes a leer.

Valores devueltos

Los datos que han sido leídos.

Ejemplos

Ejemplo #1 Ejemplo de gzread()

<?php
// pasar los contenidos de un archivo gz a una cadena
$filename = "/usr/local/something.txt.gz";
$zd = gzopen($filename, "r");
$contents = gzread($zd, 10000);
gzclose($zd);
?>

Ver también

  • gzwrite() - Escritura en un archivo gz, segura a nivel binario
  • gzopen() - Abre un archivo gz
  • gzgets() - Obtiene la línea del apuntador al archivo
  • gzgetss() - Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML
  • gzfile() - Lee un archivo gz completo en una matriz
  • gzpassthru() - Muestra todos los datos restantes a partir del apuntador al achivo gz


Reinicia la posición del apuntador a un archivo gz

  • « gzread
  • gzseek »
  • PHP Manual
  • Funciones de Zlib
  • Reinicia la posición del apuntador a un archivo gz

gzrewind

(PHP 4, PHP 5, PHP 7, PHP 8)

gzrewind — Reinicia la posición del apuntador a un archivo gz

Descripción

gzrewind ( resource $zp ) : bool

Coloca el indicador de posición del apuntador al archivo gz dado al comienzo del flujo del archivo.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • gzseek() - Ubica el apuntador a un archivo gz
  • gztell() - Indica la posición de lectura/escritura del apuntador al archivo gz


Ubica el apuntador a un archivo gz

  • « gzrewind
  • gztell »
  • PHP Manual
  • Funciones de Zlib
  • Ubica el apuntador a un archivo gz

gzseek

(PHP 4, PHP 5, PHP 7, PHP 8)

gzseek — Ubica el apuntador a un archivo gz

Descripción

gzseek ( resource $zp , int $offset , int $whence = SEEK_SET ) : int

Establece el indicador de posición para el apuntador al archivo dado en el desplazamiento de bytes fijado en el flujo del archivo. Es equivalente a llamar (en C) a gzseek(zp, offset, SEEK_SET).

Si el archivo está abierto para lectura, ésta función es emulada pero puede ser extremadamente lenta. Si el archivo está abierto para escritura, sólo está soportada la búsqueda hacia adelante; entonces gzseek() comprime una secuencia de ceros hasta la nueva posición de inicio.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

offset

El desplazamiento buscado.

whence

Los valores de whence son:

  • SEEK_SET - Establece la posición igual al offset de bytes.
  • SEEK_CUR - Establece la posición en la posición actual más el offset.

Si whence no se especifica, se asume que es SEEK_SET.

Valores devueltos

En caso de éxito, retorna 0; en caso contrario, devuelve -1. Notese que buscar pasado el EOF no es considerado un error.

Ejemplos

Ejemplo #1 Ejamplo de gzseek()

<?php
$gz = gzopen('somefile.gz', 'r');
gzseek($gz,2);
echo gzgetc($gz);
gzclose($gz);
?>

Ver también

  • gztell() - Indica la posición de lectura/escritura del apuntador al archivo gz
  • gzrewind() - Reinicia la posición del apuntador a un archivo gz


Indica la posición de lectura/escritura del apuntador al archivo gz

  • « gzseek
  • gzuncompress »
  • PHP Manual
  • Funciones de Zlib
  • Indica la posición de lectura/escritura del apuntador al archivo gz

gztell

(PHP 4, PHP 5, PHP 7, PHP 8)

gztell — Indica la posición de lectura/escritura del apuntador al archivo gz

Descripción

gztell ( resource $zp ) : int

Obtiene la posición del apuntador al archivo dado; por ejemplo, su desplazamiento en el flujo del archivo sin comprimir.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

Valores devueltos

La posición del apuntador al archivo o false si ocurre un error.

Ver también

  • gzopen() - Abre un archivo gz
  • gzseek() - Ubica el apuntador a un archivo gz
  • gzrewind() - Reinicia la posición del apuntador a un archivo gz


Descomprime una cadena comprimida

  • « gztell
  • gzwrite »
  • PHP Manual
  • Funciones de Zlib
  • Descomprime una cadena comprimida

gzuncompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

gzuncompress — Descomprime una cadena comprimida

Descripción

gzuncompress ( string $data , int $length = 0 ) : string

Está función descomprime una cadena comprimida

Parámetros

data

Los datos comprimidos con gzcompress().

length

La longitud máxima de datos a decodificar.

Valores devueltos

Los datos originales sin comprimir o false en caso de error.

La función retornará un error si los datos descomprimidos son más de 32768 veces la longitud de la entrada comprimida data o mayores que el parámetro opcional length.

Ejemplos

Ejemplo #1 Ejemplo de gzuncompress()

<?php
$compressed   = gzcompress('Compress me', 9);
$uncompressed = gzuncompress($compressed);
echo $uncompressed;
?>

Ver también

  • gzcompress() - Comprime una cadena
  • gzinflate() - Descomprime una cadena comprimida
  • gzdeflate() - Comprime una cadena
  • gzencode() - Crea una cadena comprimida con gzip


Escritura en un archivo gz, segura a nivel binario

  • « gzuncompress
  • inflate_add »
  • PHP Manual
  • Funciones de Zlib
  • Escritura en un archivo gz, segura a nivel binario

gzwrite

(PHP 4, PHP 5, PHP 7, PHP 8)

gzwrite — Escritura en un archivo gz, segura a nivel binario

Descripción

gzwrite ( resource $zp , string $string , int $length = ? ) : int

gzwrite() escribe el contenido de cadena al archivo gz dado.

Parámetros

zp

El apuntador al archivo gz. Debe ser válido y debe apuntar a un archivo abierto exitosamente por gzopen().

string

La cadena a escribir.

length

El número de bytes sin comprimir a escribir. Si se suministra, la escritura se detendrá después de que se hayan escrito los bytes (sin comprimir) del parámetro length o de que sea alcanzado el fin de la string, lo que ocurra primero.

Nota:

Nótese que si se da el argumento length, entonces la opción de configuración magic_quotes_runtime será ignorada y ningún slash será retirado de la string.

Valores devueltos

Retorna el número de bytes (sin comprimir) escritos en el flujo del archivo gz dado.

Ejemplos

Ejemplo #1 Ejemplo de gzwrite()

<?php
$string = 'Some information to compress';
$gz = gzopen('somefile.gz','w9');
gzwrite($gz, $string);
gzclose($gz);
?>

Ver también

  • gzread() - Lectura de archivo gz segura a nivel binario
  • gzopen() - Abre un archivo gz


Incrementally inflate encoded data

  • « gzwrite
  • inflate_get_read_len »
  • PHP Manual
  • Funciones de Zlib
  • Incrementally inflate encoded data

inflate_add

(PHP 7, PHP 8)

inflate_add — Incrementally inflate encoded data

Descripción

inflate_add ( InflateContext $context , string $data , int $flush_mode = ZLIB_SYNC_FLUSH ) : string|false

Incrementally inflates encoded data in the specified context.

Limitation: header information from GZIP compressed data are not made available.

Parámetros

context

A context created with inflate_init().

data

A chunk of compressed data.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

Valores devueltos

Returns a chunk of uncompressed data, o false en caso de error.

Errores/Excepciones

If invalid parameters are given, inflating the data requires a preset dictionary, but none is specified, the compressed stream is corrupt or has an invalid checksum, an error of level E_WARNING is generated.

Historial de cambios

Versión | Descripción
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.

Ver también

  • inflate_init() - Initialize an incremental inflate context


Get number of bytes read so far

  • « inflate_add
  • inflate_get_status »
  • PHP Manual
  • Funciones de Zlib
  • Get number of bytes read so far

inflate_get_read_len

(PHP 7 >= 7.2.0, PHP 8)

inflate_get_read_len — Get number of bytes read so far

Descripción

inflate_get_read_len ( InflateContext $context ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

context

Valores devueltos

Returns number of bytes read so far o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.


Get decompression status

  • « inflate_get_read_len
  • inflate_init »
  • PHP Manual
  • Funciones de Zlib
  • Get decompression status

inflate_get_status

(PHP 7 >= 7.2.0, PHP 8)

inflate_get_status — Get decompression status

Descripción

inflate_get_status ( InflateContext $context ) : int

Usually returns either ZLIB_OK or ZLIB_STREAM_END.

Parámetros

context

Valores devueltos

Returns decompression status o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.


Initialize an incremental inflate context

  • « inflate_get_status
  • readgzfile »
  • PHP Manual
  • Funciones de Zlib
  • Initialize an incremental inflate context

inflate_init

(PHP 7, PHP 8)

inflate_init — Initialize an incremental inflate context

Descripción

inflate_init ( int $encoding , array $options = [] ) : InflateContext|false

Initialize an incremental inflate context with the specified encoding.

Parámetros

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

Valores devueltos

Returns an inflate context resource (zlib.inflate) on success, o false en caso de error.

Errores/Excepciones

If an invalid encoding or option is passed to options, or the context couldn't be created, an error of level E_WARNING is generated.

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns an InflateContext instance now; previously, a resource was returned.

Ver también

  • inflate_add() - Incrementally inflate encoded data
  • deflate_init() - Initialize an incremental deflate context


Muestra un archivo gz

  • « inflate_init
  • zlib_decode »
  • PHP Manual
  • Funciones de Zlib
  • Muestra un archivo gz

readgzfile

(PHP 4, PHP 5, PHP 7, PHP 8)

readgzfile — Muestra un archivo gz

Descripción

readgzfile ( string $filename , int $use_include_path = 0 ) : int

Lee un archivo, lo descomprime y lo escribe en la salida estándar.

La función readgzfile() puede ser usada para leer un archivo que no esté en formato gzip; en éste caso readgzfile() leerá directamente el archivo sin hacer la descompresión.

Parámetros

filename

El nombre del archivo. Este archivo será abierto del sistema de archivos y sus contenidos escritos en la salida estándar.

use_include_path

Se puede especificar éste parámetro opcional en 1, si también se desea buscar el archivo en la ruta include_path.

Valores devueltos

Devuelve el número de bytes (sin comprimir) leídos del archivo en caso de éxito, o false en caso de error

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Ver también

  • gzpassthru() - Muestra todos los datos restantes a partir del apuntador al achivo gz
  • gzfile() - Lee un archivo gz completo en una matriz
  • gzopen() - Abre un archivo gz


Descomprime datos codificados en craw/gzip/zlib

  • « readgzfile
  • zlib_encode »
  • PHP Manual
  • Funciones de Zlib
  • Descomprime datos codificados en craw/gzip/zlib

zlib_decode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

zlib_decode — Descomprime datos codificados en craw/gzip/zlib

Descripción

zlib_decode ( string $data , string $max_decoded_len = ? ) : string

Descomprime datos codificados en raw/gzip/zlib.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

max_decoded_len

Valores devueltos

Devuelve los datos no comprimidos, o false en caso de error.

Ver también

  • zlib_encode() - Comprime datos con la codificación especificada


Comprime datos con la codificación especificada

  • « zlib_decode
  • zlib_get_coding_type »
  • PHP Manual
  • Funciones de Zlib
  • Comprime datos con la codificación especificada

zlib_encode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

zlib_encode — Comprime datos con la codificación especificada

Descripción

zlib_encode ( string $data , int $encoding , int $level = -1 ) : string

Comprime datos con la codificación especificada.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

Los datos a comprimir.

encoding

El algoritmo de compresión. O bien ZLIB_ENCODING_RAW, ZLIB_ENCODING_DEFLATE o ZLIB_ENCODING_GZIP.

level

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de zlib_encode()

<?php
$str = 'hello world';
$enc = zlib_encode($str, ZLIB_ENCODING_DEFLATE);
echo bin2hex($enc);
?>

El resultado del ejemplo sería:

789ccb48cdc9c95728cf2fca4901001a0b045d

Ver también

  • zlib_decode() - Descomprime datos codificados en craw/gzip/zlib


Retorna el tipo de codificación utilizada para hacer la compresión

  • « zlib_encode
  • DeflateContext »
  • PHP Manual
  • Funciones de Zlib
  • Retorna el tipo de codificación utilizada para hacer la compresión

zlib_get_coding_type

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

zlib_get_coding_type — Retorna el tipo de codificación utilizada para hacer la compresión

Descripción

zlib_get_coding_type ( ) : string

Retorna el tipo de codificación utilizada para hacer la compresión.

Valores devueltos

Los posibles valores de retorno son gzip, deflate o false.

Ver también

  • La directiva zlib.output_compression


The DeflateContext class

(PHP 8)

Introducción

A fully opaque class which replaces zlib.deflate resources as of PHP 8.0.0.

Sinopsis de la Clase

final DeflateContext {
}


The InflateContext class

(PHP 8)

Introducción

A fully opaque class which replaces zlib.inflate resources as of PHP 8.0.0.

Sinopsis de la Clase

final InflateContext {
}


Extensiones criptográficas

  • CSPRNG
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de CSPRNG
  • Hash — HASH Framework para cifrar mensajes
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de hash
  • Mcrypt
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Cifradores mcrypt
    • Ejemplos
    • Funciones de Mcrypt
  • Mhash
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Mhash
  • OpenSSL
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Parámetros de Clave/Certificado
    • Verificación de Certificados
    • Funciones de OpenSSL
  • Hash de contraseñas
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de hashing de contraseñas
  • Sodium
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Sodium Funciones
    • SodiumException — The SodiumException class


CSPRNG

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de CSPRNG
    • random_bytes — Genera bytes seudoaleatorios criptográficamente seguros
    • random_int — Genera números enteros seudoaleatorios criptográficamente seguros


Introducción

La API » generador de números seudoaleatorios criptográficamente seguros (CSPRNG por sus siglas en ingés) proporciona una manera sencilla y fiable de generar enteros y bytes aleatorios criptográficamente fuertes para emplearlos dentro de contextos criptográficos.

Existe a partir de PHP 7.0.0, aunque también existe una » implementación del espacio de usuario para PHP >= 5.2.0.


  • « Tipos de recursos
  • Funciones de CSPRNG »
  • PHP Manual
  • CSPRNG
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de CSPRNG

Tabla de contenidos

  • random_bytes — Genera bytes seudoaleatorios criptográficamente seguros
  • random_int — Genera números enteros seudoaleatorios criptográficamente seguros


Genera bytes seudoaleatorios criptográficamente seguros

  • « Funciones de CSPRNG
  • random_int »
  • PHP Manual
  • Funciones de CSPRNG
  • Genera bytes seudoaleatorios criptográficamente seguros

random_bytes

(PHP 7, PHP 8)

random_bytes — Genera bytes seudoaleatorios criptográficamente seguros

Descripción

random_bytes ( int $length ) : string

Genera una cadena de longitud arbitraria de bytes aleatorios criptográficos aptos para usos criptográficos, como la generación de sales, claves o inicialización de vectores.

Las fuentes de aleatoriedad empleadas por esta función son las siguientes:

  • En Windows, se utilizará siempre » CryptGenRandom(). A partir de PHP 7.2.0, se usará siempre » CNG-API.
  • En Linux, se utilizará la llamada al sistema » getrandom(2) si está disponible.
  • En otras plataformas, se utilizará /dev/urandom.
  • Si no están disponibles ninguna de las fuentes citadas anteriormente, se lanzará una Exception.

Nota: Aunque esta función se añadió a PHP en PHP 7.0, hay disponible una » implementación de espacio de usuario para PHP 5.2 hasta 5.6, inclusive.

Parámetros

length

La longitud de la cadena aleatoria que debería ser devuelta en bytes.

Valores devueltos

Devuelve un string que contiene el número solicitado de bytes aleatorios criptográficamente seguros.

Errores/Excepciones

  • Si no se puede encontrar una fuente de aleatoriedad apropiada, se lanzará una Exception.
  • Si se proporcionan parámetros inválidos, se lanzará un TypeError.
  • Si se proporciona un número de bytes para length inválidos, se lanzará un Error.

Ejemplos

Ejemplo #1 Ejemplo de random_bytes()

<?php
$bytes = random_bytes(5);
var_dump(bin2hex($bytes));
?>

El resultado del ejemplo sería algo similar a:

string(10) "385e33f741"

Ver también

  • random_int() - Genera números enteros seudoaleatorios criptográficamente seguros
  • openssl_random_pseudo_bytes() - Genera una cadena de bytes pseudo-aleatoria
  • bin2hex() - Convierte datos binarios en su representación hexadecimal


Genera números enteros seudoaleatorios criptográficamente seguros

  • « random_bytes
  • Hash »
  • PHP Manual
  • Funciones de CSPRNG
  • Genera números enteros seudoaleatorios criptográficamente seguros

random_int

(PHP 7, PHP 8)

random_int — Genera números enteros seudoaleatorios criptográficamente seguros

Descripción

random_int ( int $min , int $max ) : int

Genera números enteros aleatorios criptográficos aptos para resultados imparciales críticos, tales como barajar una baraja de cartas de póquer.

Las fuentes de aleatoriedad empleadas por esta función son las siguientes:

  • En Windows, se utilizará siempre » CryptGenRandom(). A partir de PHP 7.2.0, se usará siempre » CNG-API.
  • En Linux, se utilizará la llamada al sistema » getrandom(2) si está disponible.
  • En otras plataformas, se utilizará /dev/urandom.
  • Si no están disponibles ninguna de las fuentes citadas anteriormente, se lanzará una Exception.

Nota: Aunque esta función se añadió a PHP en PHP 7.0, hay disponible una » implementación de espacio de usuario para PHP 5.2 hasta 5.6, inclusive.

Parámetros

min

El valor mínimo a devolver, el cual debe ser PHP_INT_MIN o mayor.

max

El valor máximo a devolver, el cual debe ser menor o igual que PHP_INT_MAX.

Valores devueltos

Devuelve un número entero aleatorio criptográficamente seguro en el rango min a max, inclusive.

Errores/Excepciones

  • Si no se puede encontrar una fuente de aleatoriedad apropiada, se lanzará una Exception.
  • Si se proporcionan parámetros inválidos, se lanzará un TypeError.
  • Si max es menor que min, se lanzará un Error.

Ejemplos

Ejemplo #1 Ejmplo de random_int()

<?php
var_dump(random_int(100, 999));
var_dump(random_int(-1000, 0));
?>

El resultado del ejemplo sería algo similar a:

int(248)
int(-898)

Ver también

  • random_bytes() - Genera bytes seudoaleatorios criptográficamente seguros


HASH Framework para cifrar mensajes

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de hash
    • hash_algos — Devuelve una lista con los algoritmos de cifrado soportados
    • hash_copy — Copia un recurso de contexto de cifrado
    • hash_equals — Comparación de strings segura contra ataques de temporización
    • hash_file — Generar un valor hash usando el contenido de un fichero dado
    • hash_final — Finaliza un contexto incremental y devuelve el resultado cifrado
    • hash_hkdf — Generate a HKDF key derivation of a supplied key input
    • hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac
    • hash_hmac_file — Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado
    • hash_hmac — Genera un valor cifrado mediante una clave especificada usando el método HMAC
    • hash_init — Iniciar un contexto de hashing incremental
    • hash_pbkdf2 — Genera una derivación de clave PBKDF2 de una contraseña proporcionada
    • hash_update_file — Inyecta datos en un contexto de cifrado activo desde un fichero
    • hash_update_stream — Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
    • hash_update — Pega más datos en un contexto incremental de cifrado activo
    • hash — Generar un valor hash (resumen de mensaje)


Introducción

Motor para cifrar mensajes (hash). Permite la transformación directa o incremental de mensajes de longitud arbitraria usando una variedad de algoritmos hash.


Requerimientos

No se requiere de ninguna instalación para utilizar estas funciones; forman parte del núcleo de PHP.


Instalación

A partir de PHP 5.1.2, la extensión Hash está incluida y copilada en PHP de forma predeterminada.

Se puede deshabilitar explícitamente utilizando la opción --disable-hash de la configuración. En versiones anteriores de PHP se puede incorporar la extensión Hash instalando el » módulo PECL.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un recurso de Contexto de Hash devuelto por hash_init().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

HASH_HMAC (integer)
Bandera opcional para hash_init(). Indica que el algoritmo de cifrado de claves HMAC debe ser aplicado al contexto actual de hashing.


Funciones de hash

Tabla de contenidos

  • hash_algos — Devuelve una lista con los algoritmos de cifrado soportados
  • hash_copy — Copia un recurso de contexto de cifrado
  • hash_equals — Comparación de strings segura contra ataques de temporización
  • hash_file — Generar un valor hash usando el contenido de un fichero dado
  • hash_final — Finaliza un contexto incremental y devuelve el resultado cifrado
  • hash_hkdf — Generate a HKDF key derivation of a supplied key input
  • hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac
  • hash_hmac_file — Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado
  • hash_hmac — Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_init — Iniciar un contexto de hashing incremental
  • hash_pbkdf2 — Genera una derivación de clave PBKDF2 de una contraseña proporcionada
  • hash_update_file — Inyecta datos en un contexto de cifrado activo desde un fichero
  • hash_update_stream — Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
  • hash_update — Pega más datos en un contexto incremental de cifrado activo
  • hash — Generar un valor hash (resumen de mensaje)


Devuelve una lista con los algoritmos de cifrado soportados

  • « Funciones de hash
  • hash_copy »
  • PHP Manual
  • Funciones de hash
  • Devuelve una lista con los algoritmos de cifrado soportados

hash_algos

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_algos — Devuelve una lista con los algoritmos de cifrado soportados

Descripción

hash_algos ( ) : array

Valores devueltos

Devuelve un array numérico que contiene una lista con los tipos de algoritmos de cifrado soportados.

Historial de cambios

Versión | Descripción
5.6.0 | Se añadió soprte para gost-crypto. Este implementa la función de hash GOST empleando las tablas CryptoPro S-box como está especificado en la » RFC 4357, sección 11.2.
5.4.0 | Se añade soporte para joaat, fnv132 y para fnv164. Soporte para Salsa10 y Salsa20 fué eliminado.
5.3.0 | Se añade soporte para md2, ripemd256, ripemd320, salsa10, salsa20, snefru256 y para sha224

Ejemplos

Ejemplo #1 hash_algos() ejemplo

A partir de PHP 5.6.0, hash_algos() devuelve la siguiente lista de nombres de algoritmos.

<?php
print_r(hash_algos());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => md2
    [1] => md4
    [2] => md5
    [3] => sha1
    [4] => sha224
    [5] => sha256
    [6] => sha384
    [7] => sha512
    [8] => ripemd128
    [9] => ripemd160
    [10] => ripemd256
    [11] => ripemd320
    [12] => whirlpool
    [13] => tiger128,3
    [14] => tiger160,3
    [15] => tiger192,3
    [16] => tiger128,4
    [17] => tiger160,4
    [18] => tiger192,4
    [19] => snefru
    [20] => snefru256
    [21] => gost
    [22] => gost-crypto
    [23] => adler32
    [24] => crc32
    [25] => crc32b
    [26] => fnv132
    [27] => fnv1a32
    [28] => fnv164
    [29] => fnv1a64
    [30] => joaat
    [31] => haval128,3
    [32] => haval160,3
    [33] => haval192,3
    [34] => haval224,3
    [35] => haval256,3
    [36] => haval128,4
    [37] => haval160,4
    [38] => haval192,4
    [39] => haval224,4
    [40] => haval256,4
    [41] => haval128,5
    [42] => haval160,5
    [43] => haval192,5
    [44] => haval224,5
    [45] => haval256,5
)


Copia un recurso de contexto de cifrado

  • « hash_algos
  • hash_equals »
  • PHP Manual
  • Funciones de hash
  • Copia un recurso de contexto de cifrado

hash_copy

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

hash_copy — Copia un recurso de contexto de cifrado

Descripción

hash_copy ( resource $context ) : resource

Parámetros

context

Contexto para cifrado que se obtiene mediante hash_init().

Valores devueltos

Devuelve una copia del recurso de un contexto de cifrado.

Ejemplos

Ejemplo #1 Ejemplo de hash_copy()

<?php
$context = hash_init("md5");
hash_update($context, "data");

/* copy context to be able to continue using it */
$copy_context = hash_copy($context);

echo hash_final($context), "\n";

hash_update($copy_context, "data");
echo hash_final($copy_context), "\n";
?>

El resultado del ejemplo sería:

8d777f385d3dfec8815d20f7496026dc
511ae0b1c13f95e5f08f1a0dd3da3d93


Comparación de strings segura contra ataques de temporización

  • « hash_copy
  • hash_file »
  • PHP Manual
  • Funciones de hash
  • Comparación de strings segura contra ataques de temporización

hash_equals

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

hash_equals — Comparación de strings segura contra ataques de temporización

Descripción

hash_equals ( string $known_string , string $user_string ) : bool

Compara dos strings empleando el mismo tiempo, sin importar si son iguales o no.

Esta función debería utilizarse para mitigar los ataques de temporización, por ejemplo, al probar hash de contraseñas de crypt().

Parámetros

known_string

El string de longitud conocida con el que comparar

user_string

El string proporcionado por el usuario

Valores devueltos

Devuelve true cuando los dos strings son iguales, o false si no.

Errores/Excepciones

Emite un mensaje de nivel E_WARNING cuando ninguno de los parámetros proporcionados es un string.

Ejemplos

Ejemplo #1 Ejemplo

<?php
$esperado   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correcto   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrecto = crypt('apple',  '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($esperado, $correcto));
var_dump(hash_equals($esperado, $incorrecto));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Notas

Nota:

Ambos argumentos deber tener la misma longitud para que se puedan comparar. Cuando se proporcionan argumentos con diferente longitud, se devuelve false inmediatamente, pudiéndose filtrar la longitud del string conocido en caso de un ataque de temporización.

Nota:

Es importante proveer el string proporcionado por el usuario como segundo parámetro, en vez de como el primero.


Generar un valor hash usando el contenido de un fichero dado

  • « hash_equals
  • hash_final »
  • PHP Manual
  • Funciones de hash
  • Generar un valor hash usando el contenido de un fichero dado

hash_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_file — Generar un valor hash usando el contenido de un fichero dado

Descripción

hash_file ( string $algo , string $filename , bool $raw_output = false ) : string

Parámetros

algo

Nombre del algoritmo hash seleccionado (es decir "md5", "sha256", "haval160,4", etc..). Para una lista de los algoritmos soportados véase hash_algos().

filename

URL que describe la ubicación del fichero que se va a procesar; Soporta envoltorios abiertos (fopen).

raw_output

Cuando se establece en true la salida serán datos binarios sin formato, false la salida serán dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene el resumen del mensaje calculado como hexágonos en minúsculas a menos que el parámetro raw_output sea establecido en cuyo caso se devuelve la representación binaria en bruto del resumen del mensaje.

Ejemplos

Ejemplo #1 Usando hash_file()

<?php
/* Creamos un fichero para calcular su resultante valor cifrado */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');

echo hash_file('md5', 'example.txt');
?>

El resultado del ejemplo sería:

5c6ffbdd40d9556b73a21e63c3e0e904

Ver también

  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_hmac_file() - Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado
  • hash_update_file() - Inyecta datos en un contexto de cifrado activo desde un fichero
  • md5_file() - Calcula el resumen criptográfico md5 de un archivo dado
  • sha1_file() - Calcula el hash sha1 de un archivo


Finaliza un contexto incremental y devuelve el resultado cifrado

  • « hash_file
  • hash_hkdf »
  • PHP Manual
  • Funciones de hash
  • Finaliza un contexto incremental y devuelve el resultado cifrado

hash_final

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_final — Finaliza un contexto incremental y devuelve el resultado cifrado

Descripción

hash_final ( resource $context , bool $raw_output = false ) : string

Parámetros

context

Contexto para cifrado que se obtiene mediante hash_init().

raw_output

Cuando se establece en true la salida serán datos binarios sin formato, false la salida serán dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene el mensaje cifrado como dígitos hexadecimales en minúsculas, a menos que raw_output sea establecido en true, en cuyo caso la salida devuelta será el mensaje cifrado como datos binarios sin formato.

Ejemplos

Ejemplo #1 Ejemplo de hash_final()

<?php
$ctx = hash_init('sha1');
hash_update($ctx, 'The quick brown fox jumped over the lazy dog.');
echo hash_final($ctx);
?>

El resultado del ejemplo sería:

c0854fb9fb03c41cce3802cb0d220529e6eef94e

Ver también

  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_update() - Pega más datos en un contexto incremental de cifrado activo
  • hash_update_stream() - Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
  • hash_update_file() - Inyecta datos en un contexto de cifrado activo desde un fichero


Generate a HKDF key derivation of a supplied key input

  • « hash_final
  • hash_hmac_algos »
  • PHP Manual
  • Funciones de hash
  • Generate a HKDF key derivation of a supplied key input

hash_hkdf

(PHP 7 >= 7.1.2, PHP 8)

hash_hkdf — Generate a HKDF key derivation of a supplied key input

Descripción

hash_hkdf ( string $algo , string $key , int $length = 0 , string $info = "" , string $salt = "" ) : string

Parámetros

algo

Name of selected hashing algorithm (i.e. "sha256", "sha512", "haval160,4", etc..) See hash_algos() for a list of supported algorithms.

Nota:

Non-cryptographic hash functions are not allowed.

key

Input keying material (raw binary). Cannot be empty.

length

Desired output length in bytes. Cannot be greater than 255 times the chosen hash function size.

If length is 0, the output length will default to the chosen hash function size.

info

Application/context-specific info string.

salt

Salt to use during derivation.

While optional, adding random salt significantly improves the strength of HKDF.

Valores devueltos

Returns a string containing a raw binary representation of the derived key (also known as output keying material - OKM); or false on failure.

Errores/Excepciones

An E_WARNING will be raised if key is empty, algo is unknown/non-cryptographic, length is less than 0 or too large (greater than 255 times the size of the hash function).

Ejemplos

Ejemplo #1 hash_hkdf() example

<?php
// Generate a random key, and salt to strengthen it during derivation.
$inputKey = random_bytes(32);
$salt = random_bytes(16);

// Derive a pair of separate keys, using the same input created above.
$encryptionKey = hash_hkdf('sha256', $inputKey, 32, 'aes-256-encryption', $salt);
$authenticationKey = hash_hkdf('sha256', $inputKey, 32, 'sha-256-authentication', $salt);

var_dump($encryptionKey !== $authenticationKey); // bool(true)
?>

The above example produces a pair of separate keys, suitable for creation of an encrypt-then-HMAC construct, using AES-256 and SHA-256 for encryption and authentication respectively.

Ver también

  • hash_pbkdf2() - Genera una derivación de clave PBKDF2 de una contraseña proporcionada
  • » RFC 5869
  • » userland implementation


Return a list of registered hashing algorithms suitable for hash_hmac

  • « hash_hkdf
  • hash_hmac_file »
  • PHP Manual
  • Funciones de hash
  • Return a list of registered hashing algorithms suitable for hash_hmac

hash_hmac_algos

(PHP 7 >= 7.2.0, PHP 8)

hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac

Descripción

hash_hmac_algos ( ) : array

Valores devueltos

Returns a numerically indexed array containing the list of supported hashing algorithms suitable for hash_hmac().

Ejemplos

Ejemplo #1 hash_hmac_algos() example

<?php
print_r(hash_hmac_algos());

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => md2
    [1] => md4
    [2] => md5
    [3] => sha1
    [4] => sha224
    [5] => sha256
    [6] => sha384
    [7] => sha512/224
    [8] => sha512/256
    [9] => sha512
    [10] => sha3-224
    [11] => sha3-256
    [12] => sha3-384
    [13] => sha3-512
    [14] => ripemd128
    [15] => ripemd160
    [16] => ripemd256
    [17] => ripemd320
    [18] => whirlpool
    [19] => tiger128,3
    [20] => tiger160,3
    [21] => tiger192,3
    [22] => tiger128,4
    [23] => tiger160,4
    [24] => tiger192,4
    [25] => snefru
    [26] => snefru256
    [27] => gost
    [28] => gost-crypto
    [29] => haval128,3
    [30] => haval160,3
    [31] => haval192,3
    [32] => haval224,3
    [33] => haval256,3
    [34] => haval128,4
    [35] => haval160,4
    [36] => haval192,4
    [37] => haval224,4
    [38] => haval256,4
    [39] => haval128,5
    [40] => haval160,5
    [41] => haval192,5
    [42] => haval224,5
    [43] => haval256,5
)

Notas

Nota:

Before PHP 7.2.0 the only means to get a list of supported hash algorithms has been to call hash_algos() which also returns hash algorithms that are not suitable for hash_hmac().

Ver también

  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_algos() - Devuelve una lista con los algoritmos de cifrado soportados


Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado

  • « hash_hmac_algos
  • hash_hmac »
  • PHP Manual
  • Funciones de hash
  • Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado

hash_hmac_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_hmac_file — Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado

Descripción

hash_hmac_file ( string $algo , string $filename , string $key , bool $raw_output = false ) : string

Parámetros

algo

Nombre del algoritmo para cifrar seleccionado (es decir "md5", "sha256", "haval160,4", etc..). Ver hash_algos() para saber la lista de algoritmos soportados.

filename

URL que describe la localización del fichero cuyo contenido vamos a cifrar; Soporta fopen wrappers.

key

Clave secreta compartida que se usará para generar el mensaje cifrado de la variante HMAC.

raw_output

Cuando se establece en true la salida serán datos binarios sin formato, false la salida serán dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene el mensaje cifrado como dígitos hexadecimales en minúsculas, a menos que raw_output sea establecido en true, en cuyo caso la salida devuelta será el mensaje cifrado como datos binarios sin formato.

Ejemplos

Ejemplo #1 Ejemplo de hash_hmac_file()

<?php
/* Creamos un fichero para calcular su resultante valor cifrado */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');

echo hash_hmac_file('md5', 'example.txt', 'secret');
?>

El resultado del ejemplo sería:

7eb2b5c37443418fc77c136dd20e859c

Ver también

  • hash_algos() - Devuelve una lista con los algoritmos de cifrado soportados
  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_file() - Generar un valor hash usando el contenido de un fichero dado


Genera un valor cifrado mediante una clave especificada usando el método HMAC

  • « hash_hmac_file
  • hash_init »
  • PHP Manual
  • Funciones de hash
  • Genera un valor cifrado mediante una clave especificada usando el método HMAC

hash_hmac

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_hmac — Genera un valor cifrado mediante una clave especificada usando el método HMAC

Descripción

hash_hmac ( string $algo , string $data , string $key , bool $raw_output = false ) : string

Parámetros

algo

Nombre del algoritmo para cifrar seleccionado (es decir "md5", "sha256", "haval160,4", etc..). Ver hash_algos() para saber la lista de algoritmos soportados.

data

Mensaje para cifrar.

key

Clave secreta compartida que se usará para generar el mensaje cifrado de la variante HMAC.

raw_output

Cuando se establece en true la salida serán datos binarios sin formato, false la salida serán dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene el mensaje cifrado como dígitos hexadecimales en minúsculas, a menos que raw_output sea establecido en true, en cuyo caso la salida devuelta será el mensaje cifrado como datos binarios sin formato. Devuelve false cuando algo es desconocido.

Ejemplos

Ejemplo #1 hash_hmac() example

<?php
echo hash_hmac('ripemd160', 'The quick brown fox jumped over the lazy dog.', 'secret');
?>

El resultado del ejemplo sería:

b8e7ae12510bdfb1812e463a7f086122cf37e4f7

Ver también

  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_algos() - Devuelve una lista con los algoritmos de cifrado soportados
  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_hmac_file() - Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado


Iniciar un contexto de hashing incremental

  • « hash_hmac
  • hash_pbkdf2 »
  • PHP Manual
  • Funciones de hash
  • Iniciar un contexto de hashing incremental

hash_init

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_init — Iniciar un contexto de hashing incremental

Descripción

hash_init ( string $algo , int $options = 0 , string $key = null ) : HashContext

Parámetros

algo

Nombre del algoritmo hash seleccionado (es decir "md5", "sha256", "haval160,4", etc..). Para una lista de los algoritmos admitidos véase hash_algos().

options

Configuración opcional para la generación del cifrado, normalmente soporta solo una opción: HASH_HMAC, en el caso de utilizar esta opción también deberemos especificar el parámetro key.

key

Cuando se especifique HASH_HMAC en options, se debe suministrar una clave secreta compartida en este parámetro para ser utilizada en el método de cifrado HMAC.

Valores devueltos

Devuelve un recurso de contexto para cifrado, el cual será incrementado con hash_update(), hash_update_stream(), hash_update_file(), y hash_final().

Historial de cambios

Versión | Descripción
7.2.0 | Uso de funciones de hash no criptográficas (adler32, crc32, crc32b, fnv132, fnv1a32, fnv164, fnv1a64, joaat) con HASH_HMAC ha sido deshabilitado.
7.2.0 | Devuelve HashContext en lugar de recurso.

Ejemplos

Ejemplo #1 Ejemplo de hashing incremental

<?php
$ctx = hash_init('md5');
hash_update($ctx, 'The quick brown fox ');
hash_update($ctx, 'jumped over the lazy dog.');
echo hash_final($ctx);
?>

El resultado del ejemplo sería:

5c6ffbdd40d9556b73a21e63c3e0e904

Ver también

  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_algos() - Devuelve una lista con los algoritmos de cifrado soportados
  • hash_file() - Generar un valor hash usando el contenido de un fichero dado
  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_hmac_file() - Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado


Genera una derivación de clave PBKDF2 de una contraseña proporcionada

  • « hash_init
  • hash_update_file »
  • PHP Manual
  • Funciones de hash
  • Genera una derivación de clave PBKDF2 de una contraseña proporcionada

hash_pbkdf2

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

hash_pbkdf2 — Genera una derivación de clave PBKDF2 de una contraseña proporcionada

Descripción

hash_pbkdf2 ( string $algo , string $password , string $salt , int $iterations , int $length = 0 , bool $raw_output = false ) : string

Parámetros

algo

El nombre del algoritmo hash seleccionado (esto es, "md5", "sha256", "haval160,4", etc.). Véase hash_algos() para una lista de los algoritmos admitidos.

password

La contraseña a usar para la derivación.

salt

La sal a usar para la derivación. Este valor debería ser generado aleatoriamente.

iterations

El número de iteraciones internas para realizar la derivación.

length

La longitud del string de salida. Si raw_output es true, se corresponde con la longitud en bytes de la clave derivada; si raw_output es false, se corresponde con dos veces la longitud en bytes de la clave derivada (ya que cada byte de la clave es devuelto como dos dígitos hexadecimales).

Si se pasa 0, se usará la salida completa del algoritmo proporcionado.

raw_output

Cuando se establece a true, genera datos binarios puros. false genera dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene la clave derivada como dígitos hexadecimales en minúsculas, a menos que raw_output sea establecido a true, en cuyo caso devuelve la represetación binaria pura de la clave derivada.

Errores/Excepciones

Se emitirá un E_WARNING si el algoritmo es desconocido, el parámetro iterations es menor o igual a 0, el parámetro length es menor que 0 o el parámetro salt es demasiado grande (mayor que INT_MAX - 4).

Ejemplos

Ejemplo #1 Ejemplo de uso básico de hash_pbkdf2()

<?php
$contraseña = "password";
$iteraciones = 1000;

// Generar una IV aleatoria usando mcrypt_create_iv(),
// openssl_random_pseudo_bytes() u otra fuente disponible de aleatoriedad
$sal = mcrypt_create_iv(16, MCRYPT_DEV_URANDOM);

$hash = hash_pbkdf2("sha256", $contraseña, $sal, $iteraciones, 20);
echo $hash;
?>

El resultado del ejemplo sería algo similar a:

120fb6cffcf8b32c43e7

Notas

Precaución

El método PBKDF2 se puede usar para el almacenamiento de contraseñas de hash. Sin embargo, se debería observar que password_hash() o crypt() con CRYPT_BLOWFISH son más adecuados para el almacenamiento de contraseñas.

Ver también

  • crypt() - Hash de cadenas de un sólo sentido
  • password_hash() - Crea un hash de contraseña
  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_algos() - Devuelve una lista con los algoritmos de cifrado soportados
  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_hmac_file() - Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado


Inyecta datos en un contexto de cifrado activo desde un fichero

  • « hash_pbkdf2
  • hash_update_stream »
  • PHP Manual
  • Funciones de hash
  • Inyecta datos en un contexto de cifrado activo desde un fichero

hash_update_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update_file — Inyecta datos en un contexto de cifrado activo desde un fichero

Descripción

hash_update_file ( resource $hcontext , string $filename , resource $scontext = null ) : bool

Parámetros

hcontext

Un contexto de cifrado devuelto por hash_init().

filename

URL que describe la ubicación del fichero a cifrar; admite envolturas fopen.

scontext

Un contexto de flujo, como el devuelto por stream_context_create().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_update() - Pega más datos en un contexto incremental de cifrado activo
  • hash_update_stream() - Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
  • hash_final() - Finaliza un contexto incremental y devuelve el resultado cifrado
  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_file() - Generar un valor hash usando el contenido de un fichero dado


Pega datos en un contexto de cifrado activo desde un flujo de datos abierto

  • « hash_update_file
  • hash_update »
  • PHP Manual
  • Funciones de hash
  • Pega datos en un contexto de cifrado activo desde un flujo de datos abierto

hash_update_stream

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update_stream — Pega datos en un contexto de cifrado activo desde un flujo de datos abierto

Descripción

hash_update_stream ( resource $context , resource $handle , int $length = -1 ) : int

Parámetros

context

Contexto para cifrado que se obtiene mediante hash_init().

handle

Gestor de fichero abierto devuelto mediante alguna función de creación de flujo de datos.

length

Número máximo de caracteres para copiar desde handle en el contexto de cifrado.

Valores devueltos

Actual número de bytes añadidos desde handle para el contexto de datos de cifrado.

Ejemplos

Ejemplo #1 Ejemplo de hash_update_stream()

<?php
$fp = tmpfile();
fwrite($fp, 'The quick brown fox jumped over the lazy dog.');
rewind($fp);

$ctx = hash_init('md5');
hash_update_stream($ctx, $fp);
echo hash_final($ctx);
?>

El resultado del ejemplo sería:

5c6ffbdd40d9556b73a21e63c3e0e904

Ver también

  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_update() - Pega más datos en un contexto incremental de cifrado activo
  • hash_final() - Finaliza un contexto incremental y devuelve el resultado cifrado
  • hash() - Generar un valor hash (resumen de mensaje)
  • hash_file() - Generar un valor hash usando el contenido de un fichero dado


Pega más datos en un contexto incremental de cifrado activo

  • « hash_update_stream
  • hash »
  • PHP Manual
  • Funciones de hash
  • Pega más datos en un contexto incremental de cifrado activo

hash_update

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update — Pega más datos en un contexto incremental de cifrado activo

Descripción

hash_update ( resource $context , string $data ) : bool

Parámetros

context

Contexto para cifrado que se obtiene mediante hash_init().

data

Mensaje que se pegará al valor del contexto para cifrar.

Valores devueltos

Returns true.

Ver también

  • hash_init() - Iniciar un contexto de hashing incremental
  • hash_update_file() - Inyecta datos en un contexto de cifrado activo desde un fichero
  • hash_update_stream() - Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
  • hash_final() - Finaliza un contexto incremental y devuelve el resultado cifrado


Generar un valor hash (resumen de mensaje)

  • « hash_update
  • Mcrypt »
  • PHP Manual
  • Funciones de hash
  • Generar un valor hash (resumen de mensaje)

hash

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash — Generar un valor hash (resumen de mensaje)

Descripción

hash ( string $algo , string $data , bool $raw_output = false ) : string

Parámetros

algo

Nombre del algoritmo hash seleccionado (es decir, "md5", "sha256", "haval160,4", etc..). Para una lista de los algoritmos soportados véase hash_algos().

data

Mensaje a ser procesado.

raw_output

Cuando se establece en true la salida serán datos binarios sin formato, false la salida serán dígitos hexadecimales en minúsculas.

Valores devueltos

Devuelve un string que contiene el digesto(hash) como dígitos hexadecimales en minúsculas, a menos que raw_output esté establecido en true, en cuyo caso la salida devuelta será el digesto del mensaje (hash) como datos binarios sin formato.

Historial de cambios

Versión | Descripción
5.4.0 | El algoritmo tiger ahora utiliza orden de byte «big-endian». Véase también el ejemplo de más abajo.

Ejemplos

Ejemplo #1 Un ejemplo de hash()

<?php
echo hash('ripemd160', 'The quick brown fox jumped over the lazy dog.');
?>

El resultado del ejemplo sería:

ec457d0a974c48d5685a7efa03d137dc8bbde7e3

Ejemplo #2 Calcular unos 'hashes' Tiger anteriores a PHP 5.4 con PHP 5.4 y superior

<?php
function old_tiger($data = "", $width=192, $rounds = 3) {
    return substr(
        implode(
            array_map(
                function ($h) {
                    return str_pad(bin2hex(strrev($h)), 16, "0");
                },
                str_split(hash("tiger192,$rounds", $data, true), 8)
            )
        ),
        0, 48-(192-$width)/4
    );
}
echo hash('tiger192,3', 'a-string'), PHP_EOL;
echo old_tiger('a-string'), PHP_EOL;
?>

Salida del ejemplo anterior en PHP 5.3:

146a7492719b3564094efe7abbd40a7416fd900179d02773
64359b7192746a14740ad4bb7afe4e097327d0790190fd16

Salida del ejemplo anterior en PHP 5.4:

64359b7192746a14740ad4bb7afe4e097327d0790190fd16
146a7492719b3564094efe7abbd40a7416fd900179d02773

Ver también

  • hash_file() - Generar un valor hash usando el contenido de un fichero dado
  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • hash_init() - Iniciar un contexto de hashing incremental
  • md5() - Calcula el 'hash' md5 de un string
  • sha1() - Calcula el 'hash' sha1 de un string


Mcrypt

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Cifradores mcrypt
  • Ejemplos
  • Funciones de Mcrypt
    • mcrypt_cbc — Encripta/decripta datos en modo CBC
    • mcrypt_cfb — Encripta/decripta datos en modo CFB
    • mcrypt_create_iv — Crea un vector de inicialización (IV) desde una fuente aleatoria
    • mcrypt_decrypt — Desencripta texto cifrado con los parámetros dados
    • mcrypt_ecb — Obsoleto: Encripta/decripta datos en modo ECB
    • mcrypt_enc_get_algorithms_name — Devuelve el nombre del algoritmo abierto
    • mcrypt_enc_get_block_size — Devuelve el tamaño del bloque del algoritmo abierto
    • mcrypt_enc_get_iv_size — Devuelve el tamaño del IV del algoritmo abierto
    • mcrypt_enc_get_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto
    • mcrypt_enc_get_modes_name — Devuelve el nombre del modo abierto
    • mcrypt_enc_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados por el algoritmo abierto
    • mcrypt_enc_is_block_algorithm_mode — Chequea si el cifrado del modo abierto trabaja sobre bloques
    • mcrypt_enc_is_block_algorithm — Chequea si el algoritmo del modo abierto es un algoritmo por bloques
    • mcrypt_enc_is_block_mode — Chequea si el modo abierto retorna bloques
    • mcrypt_enc_self_test — Ejecuta una prueba automática sobre el módulo abierto
    • mcrypt_encrypt — Cifra texto plano con los parámetros dados
    • mcrypt_generic_deinit — Esta función deinicializa un módulo de cifrado
    • mcrypt_generic_end — Esta función termina el cifrado
    • mcrypt_generic_init — Esta función inicializa todos los buffers requeridos para el cifrado
    • mcrypt_generic — Esta función encripta datos
    • mcrypt_get_block_size — Toma el tamaño del bloque del cifrador especificado
    • mcrypt_get_cipher_name — Toma el nombre del cifrador especificado
    • mcrypt_get_iv_size — Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica
    • mcrypt_get_key_size — Toma el tamaño de clave del cifrador especificado
    • mcrypt_list_algorithms — Obtiene un array con todos los cifradores soportados
    • mcrypt_list_modes — Obtiene un array con todos los modos soportados
    • mcrypt_module_close — Cierra el módulo mcrypt
    • mcrypt_module_get_algo_block_size — Devuelve el tamaño de bloque del algoritmo especificado
    • mcrypt_module_get_algo_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto
    • mcrypt_module_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados del algoritmo abierto
    • mcrypt_module_is_block_algorithm_mode — Devuelve si el módulo especificado es un algoritmo por bloques o no
    • mcrypt_module_is_block_algorithm — Esta función chequea si el algoritmo especificado es un algoritmo por bloques
    • mcrypt_module_is_block_mode — Devuelve si el modo especificado retorna bloques o no
    • mcrypt_module_open — Abre el módulo del algoritmo y el modo a ser utilizados
    • mcrypt_module_self_test — Esta función ejecuta una prueba automática sobre el módulo especificado
    • mcrypt_ofb — Encripta/desencripta datos en modo OFB
    • mdecrypt_generic — Desencripta datos


Introducción

Advertencia

Esta extensión está obsoleta desde PHP 7.1.0 y ha sido movida a PECL a partir de PHP 7.2.0.

Esta es una interfaz para la biblioteca mcrypt, que admite una gran variedad de algoritmos de bloques tales como DES, TRipleDES, Blowfish (predeterminado), 3-WAY, SAFER-SK64, SAFER-SK128,TWOFISH, TEA, RC2 y GOST en los modos de cifrado CBC, OFB, CFB y ECB. Además, admite RC6 e IDEA, que son considerados "no libres". CFB/OFB son de 8 bits por defecto.


Requerimientos

Estas funciones trabajan utilizando » mcrypt. Para usarla, descargue libmcrypt-x.x.tar.gz desde » http://mcrypt.sourceforge.net/ y siga las instrucciones de instalación incluídas.

A partir de PHP 5.0.0 necesitará libmcrypt Versión 2.5.6 o superior.

Usuarios de Windows encontrarán la biblioteca en los binarios de Windows de PHP 5.2. Los binarios de PHP 5.3 para Windows utilizan la versión estática de la biblioteca Mcrypt, no se necesita de ningún DLL adicional.

Si lo enlaza con libmcrypt 2.4.x o superiores, las siguientes bloques de algoritmos adicionales serán soportados: CAST, LOKI97, RIJNDAEL, SAFERPLUS, SERPENT y los siguientes cifradores de flujo: ENIGMA (crypt), PANAMA, RC4 y WAKE. Con libmcrypt 2.4.x o superiores, otro modo de cifrado está también disponible: nOFB.


Instalación

Necesita compilar PHP con el parámetro --with-mcrypt[=DIR] para habilitar esta extensión. DIR es el directorio de instalación de mcrypt. Asegúrese de compilar libmcrypt con la opción --disable-posix-threads.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Mcrypt
Nombre | Por defecto | Cambiable | Historial de cambios
mcrypt.algorithms_dir | null | PHP_INI_ALL |
mcrypt.modes_dir | null | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mcrypt.algorithms_dir string

El directorio que contiene los algoritmos. El valor predeterminado es el directorio a través del cual se compiló libmcrypt, que generalmente es /usr/local/lib/libmcrypt. Vea mcrypt_list_algorithms() para detalles adicionales.

mcrypt.modes_dir string

El directorio que contiene los modos. El valor predeterminado es el directorio a través del cual se compiló libmcrypt, que generalmente es /usr/local/lib/libmcrypt. Vea mcrypt_list_modes() para detralles adicionales.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

mcrypt_module_open() devuelve un descriptor de cifrado.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Mcrypt puede operar en cuatro modos de cifrado de bloques (CBC, OFB, CFB, y ECB). Si está enlazado con libmcrypt-2.4.x o superiores las funciones también pueden operar en el modo de cifrado por bloques nOFB y en modo STREAM. Abajo se enumeran todos los modos de cifrado soportados junto con las constantes que están definidas para el modo de cifrado. Para una referencia más completa y discusión, véase Applied Cryptography by Schneier (ISBN 0-471-11709-9).

  • MCRYPT_MODE_ECB (electronic codebook) es útil para datos aleatorios, tal como para encriptar otras claves. Dado que los datos son cortos y aleatorios, las desventajas de ECB tienen un efecto negativo favorable.
  • MCRYPT_MODE_CBC (cipher block chaining) es especialmente útil para cifrar archivos donde la seguridad se incrementa significativamente sobre la de ECB.
  • MCRYPT_MODE_CFB (cipher feedback) es el mejor modo de cifrado para secuencias de bytes donde cada byte debe ser encriptado.
  • MCRYPT_MODE_OFB (output feedback, en 8 bits) es comparable a CFB, pero puede ser utilizado en aplicaciones donde la propagación de errores no puede ser tolerada. No es segura (debido a que opera en modo 8 bits) por lo que no es recomendado su uso.
  • MCRYPT_MODE_NOFB (output feedback, en nbit) es comparable a OFB, pero es más seguro porque opera en el tamaño de bloque del algoritmo.
  • MCRYPT_MODE_STREAM es un modo extra para incluir algunos algoritmos de flujo tales como "WAKE" o "RC4".

Algunos otros modos y constantes de dispositivos aleatorios:

MCRYPT_ENCRYPT (integer)
MCRYPT_DECRYPT (integer)
MCRYPT_DEV_RANDOM (integer)
MCRYPT_DEV_URANDOM (integer)
MCRYPT_RAND (integer)


Cifradores mcrypt

Aqui hay una lista de los cifradores que actualmente son soportados por la extensión mcrypt. Para una lista completa de los cifradores soportados, vea los defines al final de mcrypt.h. La regla general con la API de mcrypt-2.2.x es que se puede acceder al cifrador desde PHP con MCRYPT_ciphername. Con la API de libmcrypt-2.4.x y libmcrypt-2.5.x estas constantes también trabajan, pero es posible especificar el nombre del cifrador como una string al invocar a mcrypt_module_open().

  • MCRYPT_3DES
  • MCRYPT_ARCFOUR_IV (solo libmcrypt > 2.4.x)
  • MCRYPT_ARCFOUR (solo libmcrypt > 2.4.x)
  • MCRYPT_BLOWFISH
  • MCRYPT_CAST_128
  • MCRYPT_CAST_256
  • MCRYPT_CRYPT
  • MCRYPT_DES
  • MCRYPT_DES_COMPAT (solo libmcrypt 2.2.x)
  • MCRYPT_ENIGMA (solo libmcrypt > 2.4.x, alias de MCRYPT_CRYPT)
  • MCRYPT_GOST
  • MCRYPT_IDEA (no libre)
  • MCRYPT_LOKI97 (solo libmcrypt > 2.4.x)
  • MCRYPT_MARS (solo libmcrypt > 2.4.x, no libre)
  • MCRYPT_PANAMA (libmcrypt > 2.4.x only)
  • MCRYPT_RIJNDAEL_128 (solo libmcrypt > 2.4.x)
  • MCRYPT_RIJNDAEL_192 (solo libmcrypt > 2.4.x)
  • MCRYPT_RIJNDAEL_256 (solo libmcrypt > 2.4.x)
  • MCRYPT_RC2
  • MCRYPT_RC4 (solo libmcrypt 2.2.x)
  • MCRYPT_RC6 (solo libmcrypt > 2.4.x)
  • MCRYPT_RC6_128 (solo libmcrypt 2.2.x)
  • MCRYPT_RC6_192 (solo libmcrypt 2.2.x)
  • MCRYPT_RC6_256 (solo libmcrypt 2.2.x)
  • MCRYPT_SAFER64
  • MCRYPT_SAFER128
  • MCRYPT_SAFERPLUS (solo libmcrypt > 2.4.x)
  • MCRYPT_SERPENT (solo libmcrypt > 2.4.x)
  • MCRYPT_SERPENT_128 (solo libmcrypt 2.2.x)
  • MCRYPT_SERPENT_192 (solo libmcrypt 2.2.x)
  • MCRYPT_SERPENT_256 (solo libmcrypt 2.2.x)
  • MCRYPT_SKIPJACK (solo libmcrypt > 2.4.x)
  • MCRYPT_TEAN (solo libmcrypt 2.2.x)
  • MCRYPT_THREEWAY
  • MCRYPT_TRIPLEDES (solo libmcrypt > 2.4.x)
  • MCRYPT_TWOFISH (para versiones de mcrypt inferiores a la 2.x, o mcrypt > 2.4.x )
  • MCRYPT_TWOFISH128 (TWOFISHxxx están disponibles en las más recientes versiones 2.x, pero no en las versiones 2.4.x)
  • MCRYPT_TWOFISH192
  • MCRYPT_TWOFISH256
  • MCRYPT_WAKE (solo libmcrypt > 2.4.x)
  • MCRYPT_XTEA (solo libmcrypt > 2.4.x)

Se debe (en modo CFB y OFB) o se puede (en modo CBC) suministrar un vector de inicialización (IV) a la función de cifrado correspondiente. El IV debe ser único y debe ser el mismo cuando cifra/descifra. Con información que es almacenada encriptada, se puede tomar la salida de una función del índice con el que la información es almacenada (por ej., la clave MD5 de un nombre de archivo). Alternativamente, se puede transmitir el IV junto con los datos encriptados (ver el capítulo 9.3 de Applied Cryptography by Schneier (ISBN 0-471-11709-9) para una discusión sobre este tema).


Ejemplos

Mcrypt puede ser utilizada para el cifrado y descifrado empleando los cifradores arriba mencionados. Si se enlazó con libmcrypt-2.2.x, los cuatro comandos importantes de mcrypt (mcrypt_cfb(), mcrypt_cbc(), mcrypt_ecb(), y mcrypt_ofb()) puede operar en ambos modos, los cuales son denominados MCRYPT_ENCRYPT y MCRYPT_DECRYPT, respectivamente.

Si se enlazó con libmcrypt 2.4.x o 2.5.x, estas funciones todavía están disponibles, pero es recomendable que se utilicen las funciones avanzadas.

Ejemplo #1 Cifrar un valor de entrada con AES con una clave de 256 bits bajo 2.4.x y superiores en modo CBC

<?php
    $clave = hash('sha256', 'esta es una clave secreta', true);
    $entrada = "Encontrémonos a las 9 en punto en el escondite.";

    $td = mcrypt_module_open('rijndael-128', '', 'cbc', '');
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_URANDOM);
    mcrypt_generic_init($td, $clave, $iv);
    $datos_encriptados = mcrypt_generic($td, $entrada);
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);
?>
Este ejemplo proporcionará los datos encriptados como un string en $datos_encriptados. Para un ejemplo completo, véase mcrypt_module_open().


Funciones de Mcrypt

Tabla de contenidos

  • mcrypt_cbc — Encripta/decripta datos en modo CBC
  • mcrypt_cfb — Encripta/decripta datos en modo CFB
  • mcrypt_create_iv — Crea un vector de inicialización (IV) desde una fuente aleatoria
  • mcrypt_decrypt — Desencripta texto cifrado con los parámetros dados
  • mcrypt_ecb — Obsoleto: Encripta/decripta datos en modo ECB
  • mcrypt_enc_get_algorithms_name — Devuelve el nombre del algoritmo abierto
  • mcrypt_enc_get_block_size — Devuelve el tamaño del bloque del algoritmo abierto
  • mcrypt_enc_get_iv_size — Devuelve el tamaño del IV del algoritmo abierto
  • mcrypt_enc_get_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto
  • mcrypt_enc_get_modes_name — Devuelve el nombre del modo abierto
  • mcrypt_enc_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados por el algoritmo abierto
  • mcrypt_enc_is_block_algorithm_mode — Chequea si el cifrado del modo abierto trabaja sobre bloques
  • mcrypt_enc_is_block_algorithm — Chequea si el algoritmo del modo abierto es un algoritmo por bloques
  • mcrypt_enc_is_block_mode — Chequea si el modo abierto retorna bloques
  • mcrypt_enc_self_test — Ejecuta una prueba automática sobre el módulo abierto
  • mcrypt_encrypt — Cifra texto plano con los parámetros dados
  • mcrypt_generic_deinit — Esta función deinicializa un módulo de cifrado
  • mcrypt_generic_end — Esta función termina el cifrado
  • mcrypt_generic_init — Esta función inicializa todos los buffers requeridos para el cifrado
  • mcrypt_generic — Esta función encripta datos
  • mcrypt_get_block_size — Toma el tamaño del bloque del cifrador especificado
  • mcrypt_get_cipher_name — Toma el nombre del cifrador especificado
  • mcrypt_get_iv_size — Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica
  • mcrypt_get_key_size — Toma el tamaño de clave del cifrador especificado
  • mcrypt_list_algorithms — Obtiene un array con todos los cifradores soportados
  • mcrypt_list_modes — Obtiene un array con todos los modos soportados
  • mcrypt_module_close — Cierra el módulo mcrypt
  • mcrypt_module_get_algo_block_size — Devuelve el tamaño de bloque del algoritmo especificado
  • mcrypt_module_get_algo_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto
  • mcrypt_module_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados del algoritmo abierto
  • mcrypt_module_is_block_algorithm_mode — Devuelve si el módulo especificado es un algoritmo por bloques o no
  • mcrypt_module_is_block_algorithm — Esta función chequea si el algoritmo especificado es un algoritmo por bloques
  • mcrypt_module_is_block_mode — Devuelve si el modo especificado retorna bloques o no
  • mcrypt_module_open — Abre el módulo del algoritmo y el modo a ser utilizados
  • mcrypt_module_self_test — Esta función ejecuta una prueba automática sobre el módulo especificado
  • mcrypt_ofb — Encripta/desencripta datos en modo OFB
  • mdecrypt_generic — Desencripta datos


Encripta/decripta datos en modo CBC

  • « Funciones de Mcrypt
  • mcrypt_cfb »
  • PHP Manual
  • Funciones de Mcrypt
  • Encripta/decripta datos en modo CBC

mcrypt_cbc

(PHP 4, PHP 5)

mcrypt_cbc — Encripta/decripta datos en modo CBC

Advertencia

Esta función está OBSOLETA en PHP 5.5.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

Descripción

mcrypt_cbc ( int $cipher , string $key , string $data , int $mode , string $iv = ? ) : string
mcrypt_cbc ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

El primer prototipo es cuando se enlazó con libmcrypt 2.2.x, el segundo cuando se enlazó con libmcrypt 2.4.x o superiores. El parámetro mode debería ser o MCRYPT_ENCRYPT o MCRYPT_DECRYPT.


Encripta/decripta datos en modo CFB

  • « mcrypt_cbc
  • mcrypt_create_iv »
  • PHP Manual
  • Funciones de Mcrypt
  • Encripta/decripta datos en modo CFB

mcrypt_cfb

(PHP 4, PHP 5)

mcrypt_cfb — Encripta/decripta datos en modo CFB

Advertencia

Esta función está OBSOLETA en PHP 5.5.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

Descripción

mcrypt_cfb ( int $cipher , string $key , string $data , int $mode , string $iv ) : string
mcrypt_cfb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

El primer prototipo es cuando se enlazó con libmcrypt 2.2.x, el segundo cuando se enlazó con libmcrypt 2.4.x o superiores. El parámetro mode debería ser o MCRYPT_ENCRYPT o MCRYPT_DECRYPT.


Crea un vector de inicialización (IV) desde una fuente aleatoria

  • « mcrypt_cfb
  • mcrypt_decrypt »
  • PHP Manual
  • Funciones de Mcrypt
  • Crea un vector de inicialización (IV) desde una fuente aleatoria

mcrypt_create_iv

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_create_iv — Crea un vector de inicialización (IV) desde una fuente aleatoria

Advertencia

Esta función está OBSOLETA en PHP 7.1.0. y ELIMINADA en PHP 7.2.0.

Las alternativas a esta función son:

  • random_bytes()

Descripción

mcrypt_create_iv ( int $size , int $source = MCRYPT_DEV_URANDOM ) : string

Crea un vector de inicialización (IV) desde una fuente aleatoria.

El IV está destinado sólo a proveer una semilla alternativa a las rutinas de cifrado. Este IV no necesita ser secreto en absoluto, aunque ello puede ser deseable. Aún asi se lo puede enviar junto con su texto cifrado sin perder seguridad.

Parámetros

size

El tamaño del IV.

source

La fuente del IV. El parámetro source puede ser MCRYPT_RAND (generador de números aleatorios del sistema), MCRYPT_DEV_RANDOM (lee datos de /dev/random) y MCRYPT_DEV_URANDOM (lee datos de /dev/urandom). Antes de 5.3.0, MCRYPT_RAND era la única soportada en Windows.

Obsérvese que el valor predeterminado de este parámetro era MCRYPT_DEV_RANDOM antes de PHP 5.6.0.

Nota: Observe que MCRYPT_DEV_RANDOM podría hacer que la función quede en espera hasta que haya más entropía disponible.

Valores devueltos

Devuelve el vector de inicialización, o false en caso de error.

Historial de cambios

Versión | Descripción
5.6.0 | MCRYPT_DEV_URANDOM ahora es el valor predetermniado de source.
5.3.0 | MCRYPT_DEV_RANDOM y MCRYPT_DEV_URANDOM se volvieron disponibles en plataformas Windows.
5.3.0 | Ya no se requiere invocar primero a srand(). Esto ahora se realiza de forma automática.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_create_iv()

<?php
    $size = mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB);
    $iv = mcrypt_create_iv($size, MCRYPT_DEV_RANDOM);
?>

Ver también

  • » http://www.ciphersbyritter.com/GLOSSARY.HTM#IV
  • » http://www.quadibloc.com/crypto/co0409.htm
  • Capítulo 9.3 de Applied Cryptography by Schneier (ISBN 0-471-11709-9)
  • random_bytes() - Genera bytes seudoaleatorios criptográficamente seguros


Desencripta texto cifrado con los parámetros dados

  • « mcrypt_create_iv
  • mcrypt_ecb »
  • PHP Manual
  • Funciones de Mcrypt
  • Desencripta texto cifrado con los parámetros dados

mcrypt_decrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_decrypt — Desencripta texto cifrado con los parámetros dados

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0 y será ELIMINADA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_decrypt ( string $cipher , string $key , string $data , string $mode , string $iv = ? ) : string

Desencripta data y devuelve los datos sin cifrar.

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

key

La clave con la cual los datos fueron cifrados. Si la clave proporcionada no está soportada por el cifrador, la función emitirá una advertencia y devolverá false

data

La información que será descifrada con el cifrador y modo dados por los parámetros cipher y mode. Si el tamaño de la información no es n * blocksize, la información será rellenada con '\0'.

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

iv

Utilizado para la inicialización en los modos CBC, CFB, OFB, y en algunos algoritmos en el modo STREAM. Si el tamañlo del IV proporcionado no está soportado por el modo de encadenamiento o no se proporcionó ninún IV, y el modo de encadenamiento requiere uno, la función emitirá una advertencia y devolverá false.

Valores devueltos

Devuelve los datos descifrados en formato cadena o false en caso de error.

Historial de cambios

Versión | Descripción
5.6.0 | Tamaños incorrectos en key y iv ya no son admitidos. mcrypt_decrypt() emitirá una advertencia y devolverá false si los datos de entrada son incorrectos. Anteriormente la clave y el IV eran rellenados con bytes '\0' hasta el siguiente tamaño válido.

Ver también

  • mcrypt_encrypt() - Cifra texto plano con los parámetros dados


Obsoleto: Encripta/decripta datos en modo ECB

  • « mcrypt_decrypt
  • mcrypt_enc_get_algorithms_name »
  • PHP Manual
  • Funciones de Mcrypt
  • Obsoleto: Encripta/decripta datos en modo ECB

mcrypt_ecb

(PHP 4, PHP 5)

mcrypt_ecb — Obsoleto: Encripta/decripta datos en modo ECB

Advertencia

Esta función está OBSOLETA en PHP 5.5.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

Descripción

mcrypt_ecb ( int $cipher , string $key , string $data , int $mode ) : string
mcrypt_ecb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

El primer prototipo es cuando se enlazó con libmcrypt 2.2.x, el segundo cuando se enlazó con libmcrypt 2.4.x o superiores. El parámetro mode debería ser o MCRYPT_ENCRYPT o MCRYPT_DECRYPT.


Devuelve el nombre del algoritmo abierto

  • « mcrypt_ecb
  • mcrypt_enc_get_block_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el nombre del algoritmo abierto

mcrypt_enc_get_algorithms_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_algorithms_name — Devuelve el nombre del algoritmo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_algorithms_name ( resource $td ) : string

Esta función devuelve el nombre del algoritmo.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve el nombre del algoritmo abierto en formato cadena.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_enc_get_algorithms_name()

<?php
$td = mcrypt_module_open(MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";

$td = mcrypt_module_open('cast-256', '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";
?>

El resultado del ejemplo sería:

CAST-256
CAST-256


Devuelve el tamaño del bloque del algoritmo abierto

  • « mcrypt_enc_get_algorithms_name
  • mcrypt_enc_get_iv_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño del bloque del algoritmo abierto

mcrypt_enc_get_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_block_size — Devuelve el tamaño del bloque del algoritmo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_block_size ( resource $td ) : int

Toma el tamaño del bloque del algoritmo abierto.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve el tamaño del bloque del algoritmo especificado en bytes.


Devuelve el tamaño del IV del algoritmo abierto

  • « mcrypt_enc_get_block_size
  • mcrypt_enc_get_key_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño del IV del algoritmo abierto

mcrypt_enc_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_iv_size — Devuelve el tamaño del IV del algoritmo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_iv_size ( resource $td ) : int

Esta función devuelve el tamaño en bytes del IV del algoritmo especificado por el descriptor de cifrado. Un IV es utilizado en los modos cbc, cfb y ofb, y en algunos algoritmos en modo stream.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve el tamaño del IV, o 0 si el IV es ignorado por el algoritmo.


Devuelve el tamaño de clave máximo soportado por el modo abierto

  • « mcrypt_enc_get_iv_size
  • mcrypt_enc_get_modes_name »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño de clave máximo soportado por el modo abierto

mcrypt_enc_get_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_key_size ( resource $td ) : int

Toma el tamaño de clave máximo soportado por el algoritmo en bytes.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve el tamaño de clave máximo soportado por el algoritmo en bytes.


Devuelve el nombre del modo abierto

  • « mcrypt_enc_get_key_size
  • mcrypt_enc_get_supported_key_sizes »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el nombre del modo abierto

mcrypt_enc_get_modes_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_modes_name — Devuelve el nombre del modo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_modes_name ( resource $td ) : string

Esta función devuelve el nombre del modo.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve el nombre en formato cadena.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_enc_get_modes_name()

<?php
$td = mcrypt_module_open (MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_modes_name($td). "\n";

$td = mcrypt_module_open ('cast-256', '', 'ecb', '');
echo mcrypt_enc_get_modes_name($td). "\n";
?>

El resultado del ejemplo sería:

CFB
ECB


Devuelve un array con los tamaños de clave soportados por el algoritmo abierto

  • « mcrypt_enc_get_modes_name
  • mcrypt_enc_is_block_algorithm_mode »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve un array con los tamaños de clave soportados por el algoritmo abierto

mcrypt_enc_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados por el algoritmo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_get_supported_key_sizes ( resource $td ) : array

Toma los tamaños de clave soportados por el algoritmo abierto.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve un array con los tamaños de clave soportados por el algoritmo especificado por el descriptor de cifrado. Si devuelve un array vacío es porque todos los tamaños de clave entre 1 y mcrypt_enc_get_key_size() son soportados por el algoritmo.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_enc_get_supported_key_sizes()

<?php
    $td = mcrypt_module_open('rijndael-256', '', 'ecb', '');
    var_dump(mcrypt_enc_get_supported_key_sizes($td));
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  int(16)
  [1]=>
  int(24)
  [2]=>
  int(32)
}


Chequea si el cifrado del modo abierto trabaja sobre bloques

  • « mcrypt_enc_get_supported_key_sizes
  • mcrypt_enc_is_block_algorithm »
  • PHP Manual
  • Funciones de Mcrypt
  • Chequea si el cifrado del modo abierto trabaja sobre bloques

mcrypt_enc_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_algorithm_mode — Chequea si el cifrado del modo abierto trabaja sobre bloques

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_is_block_algorithm_mode ( resource $td ) : bool

Dice si el algoritmo del modo abierto trabaja sobre bloques (por ej., false para stream, y true para cbc, cfb, ofb).

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve true si el modo es para ser utilizado con algoritmos por bloques, de lo contrario devuelve false.


Chequea si el algoritmo del modo abierto es un algoritmo por bloques

  • « mcrypt_enc_is_block_algorithm_mode
  • mcrypt_enc_is_block_mode »
  • PHP Manual
  • Funciones de Mcrypt
  • Chequea si el algoritmo del modo abierto es un algoritmo por bloques

mcrypt_enc_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_algorithm — Chequea si el algoritmo del modo abierto es un algoritmo por bloques

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_is_block_algorithm ( resource $td ) : bool

Dice si el algoritmo del modo abierto es un algoritmo por bloques.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve true si el algoritmo es un algoritmo por bloques o false si es uno de flujo.


Chequea si el modo abierto retorna bloques

  • « mcrypt_enc_is_block_algorithm
  • mcrypt_enc_self_test »
  • PHP Manual
  • Funciones de Mcrypt
  • Chequea si el modo abierto retorna bloques

mcrypt_enc_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_mode — Chequea si el modo abierto retorna bloques

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_is_block_mode ( resource $td ) : bool

Dice si el modo abierto retorna bloques (por ej., true para cbc y ecb, y false para cfb y stream).

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve true si el modo retorna bloques de bytes, o false si retorna solo bytes.


Ejecuta una prueba automática sobre el módulo abierto

  • « mcrypt_enc_is_block_mode
  • mcrypt_encrypt »
  • PHP Manual
  • Funciones de Mcrypt
  • Ejecuta una prueba automática sobre el módulo abierto

mcrypt_enc_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_self_test — Ejecuta una prueba automática sobre el módulo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_enc_self_test ( resource $td ) : int

Esta función ejecuta la prueba automática sobre el algoritmo especificado a través del descriptor td.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Si el test automático resulta satisfactorio, devuelve false. En caso de error, devuelve true.


Cifra texto plano con los parámetros dados

  • « mcrypt_enc_self_test
  • mcrypt_generic_deinit »
  • PHP Manual
  • Funciones de Mcrypt
  • Cifra texto plano con los parámetros dados

mcrypt_encrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_encrypt — Cifra texto plano con los parámetros dados

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_encrypt ( string $cipher , string $key , string $data , string $mode , string $iv = ? ) : string

Cifra los datos y los devuelve.

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

key

La clave con la que los datos serán cifrados. Si el tamaño de la clave proporcionada no está soportado por el cifrador, la función emitirá una advertencia y devolverá false

data

Los datos que serán cifrados con el cifrador y modo dados a través de cipher y mode. Si el tamaño de la información no es n * blocksize, ésta será rellenada con '\0'.

El texto cifrado devuelto puede ser mayor al tamaño de datos que fue especificado por el parámetro data.

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

iv

Utilizado para la inicialización en los modos CBC, CFB, OFB, y en algunos algoritmos en el modo STREAM. Si el tamañlo del IV proporcionado no está soportado por el modo de encadenamiento o no se proporcionó ninún IV, y el modo de encadenamiento requiere uno, la función emitirá una advertencia y devolverá false.

Valores devueltos

Devuelve los datos cifrados, en formato cadena o false en caso de error.

Historial de cambios

Versión | Descripción
5.6.0 | Tamaños incorrectos en key y iv ya no son admitidos. mcrypt_encrypt() emitirá una advertencia y devolverá false si los datos de entrada son incorrectos. Anteriormente la clave y el IV eran rellenados con bytes '\0' hasta el siguiente tamaño válido.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_encrypt()

<?php
    # --- ENCRYPTION ---

    # la clave debería ser binaria aleatoria, use scrypt, bcrypt o PBKDF2 para
    # convertir un string en una clave
    # la clave se especifica en formato hexadecimal
    $key = pack('H*', "bcb04b7e103a0cd8b54763051cef08bc55abe029fdebae5e1d417e2ffb2a00a3");

    # mostrar el tamaño de la clave, use claves de 16, 24 o 32 bytes para AES-128, 192
    # y 256 respectivamente
    $key_size =  strlen($key);
    echo "Tamaño de la clave: " . $key_size . "\n";

    $plaintext = "Este estring estaba encriptado con AES-256 / CBC / ZeroBytePadding.";

    # crear una aleatoria IV para utilizarla co condificación CBC
    $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_128, MCRYPT_MODE_CBC);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    # crea un texto cifrado compatible con AES (tamaño de bloque Rijndael = 128)
    # para hacer el texto confidencial
    # solamente disponible para entradas codificadas que nunca finalizan con el
    # el valor  00h (debido al relleno con ceros)
    $ciphertext = mcrypt_encrypt(MCRYPT_RIJNDAEL_128, $key,
                                 $plaintext, MCRYPT_MODE_CBC, $iv);

    # anteponer la IV para que esté disponible para el descifrado
    $ciphertext = $iv . $ciphertext;

    # codificar el texto cifrado resultante para que pueda ser representado por un string
    $ciphertext_base64 = base64_encode($ciphertext);

    echo  $ciphertext_base64 . "\n";

    # === ADVERTENCIA ===

    # El texto cifrado resultante no tiene añadida integridad o autenticidad
    # y no está protegido contra los ataques de relleno de oracle.

    # --- DESCIFRADO ---

    $ciphertext_dec = base64_decode($ciphertext_base64);

    # recupera la IV, iv_size debería crearse usando mcrypt_get_iv_size()
    $iv_dec = substr($ciphertext_dec, 0, $iv_size);

    # recupera el texto cifrado (todo excepto el $iv_size en el frente)
    $ciphertext_dec = substr($ciphertext_dec, $iv_size);

    # podrían eliminarse los caracteres con valor 00h del final del texto puro
    $plaintext_dec = mcrypt_decrypt(MCRYPT_RIJNDAEL_128, $key,
                                    $ciphertext_dec, MCRYPT_MODE_CBC, $iv_dec);

    echo  $plaintext_dec . "\n";
?>

El resultado del ejemplo sería:

Tamaño de la clave: 32
ENJW8mS2KaJoNB5E5CoSAAu0xARgsR1bdzFWpEn+poYw45q+73az5kYi4j+0haevext1dGrcW8Qi59txfCBV8BBj3bzRP3dFCp3CPQSJ8eU=
Este estring estaba encriptado con AES-256 / CBC / ZeroBytePadding.

Ver también

  • mcrypt_decrypt() - Desencripta texto cifrado con los parámetros dados
  • mcrypt_module_open() - Abre el módulo del algoritmo y el modo a ser utilizados


Esta función deinicializa un módulo de cifrado

  • « mcrypt_encrypt
  • mcrypt_generic_end »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función deinicializa un módulo de cifrado

mcrypt_generic_deinit

(PHP 4 >= 4.0.7, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic_deinit — Esta función deinicializa un módulo de cifrado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_generic_deinit ( resource $td ) : bool

Esta función termina el cifrado especificado a través del descriptor de cifrado (el parámetro td). Limpia todos los buffers, pero no cierra el módulo. Se necesita invocar a mcrypt_module_close() para cerrarlo. (Aunque PHP hace esto al final del script).

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mcrypt_module_open() - Abre el módulo del algoritmo y el modo a ser utilizados
  • mcrypt_generic_init() - Esta función inicializa todos los buffers requeridos para el cifrado


Esta función termina el cifrado

  • « mcrypt_generic_deinit
  • mcrypt_generic_init »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función termina el cifrado

mcrypt_generic_end

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_end — Esta función termina el cifrado

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • mcrypt_generic_deinit()

Descripción

mcrypt_generic_end ( resource $td ) : bool

Advertencia

Debería utilizarse mcrypt_generic_deinit() en lugar de esta función, ya que puede ocasionar colisiones al utilizarla con mcrypt_module_close() debido a múltiples libreaciones de búfer.

Esta función termina con el cifrado esecificado por el descriptor de cifrado (el parámetro td). En realidad, limpia todos los buffers y cierra los módulos utilizados. Devuelve false en caso de error, o true en caso de éxito.


Esta función inicializa todos los buffers requeridos para el cifrado

  • « mcrypt_generic_end
  • mcrypt_generic »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función inicializa todos los buffers requeridos para el cifrado

mcrypt_generic_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic_init — Esta función inicializa todos los buffers requeridos para el cifrado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_generic_init ( resource $td , string $key , string $iv ) : int

Se necesita invocar esta función antes de cada llamada a mcrypt_generic() o mdecrypt_generic().

Parámetros

td

El descriptor de cifrado.

key

La longitud máxima de la clave debería ser la misma obtenida al invocar a mcrypt_enc_get_key_size() y todos los valores menores son legales.

iv

El IV debería tener normalmente el tamaño del bloque del algoritmo, pero debe obtener el tamaño tras invocar a mcrypt_enc_get_iv_size(). El IV es ignorado en modo ECB. El IV DEBE existir en modo CFB, CBC, STREAM, nOFB Y OFB. Requiere ser aleatorio y único (pero no secreto). El mismo IV debe ser utilizado para el cifrado/desencriptado. Si no se desea usarlo se debería setearlo con ceros, pero no es recomendado.

Valores devueltos

Esta función devuelve un valor negativo en caso de error: -3 cuando la longitud es incorrecta, -4 cuando hubo un problema de asignación de memoria y todos los demás valores retornados son errores desconocidos. Si ocurre un error, se imprimirá el correspondiente warning. false es devueto si fueron pasados argumentos incorrectos.

Ver también

  • mcrypt_module_open() - Abre el módulo del algoritmo y el modo a ser utilizados


Esta función encripta datos

  • « mcrypt_generic_init
  • mcrypt_get_block_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función encripta datos

mcrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic — Esta función encripta datos

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_generic ( resource $td , string $data ) : string

Esta función encripta datos. Estos datos son rellenados con "\0" para asegurarse de que la longitud de los datos sea n * blocksize. Esta función devuelve los datos cifrados. Note que la longitud de la cadena devuelta puede ser más larga que la de entrada, debido al relleno de la información.

Si se desea almacenar los datos en una base de datos se debe asegurar que la cadena completa retornada por mcrypt_generic se almacene, o la cadena no será desencriptada apropiadamente. Si la cadena original tiene una longitud de 10 caracteres, y el tamaño del bloque es 8 (utilice mcrypt_enc_get_block_size() para determinar el tamaño del bloque), serán necerarios al menos 16 caracteres en el campo de su base de datos. Tenga en cuenta que la cadena devuelta por mdecrypt_generic() será también de 16 caracteres. Utilice rtrim($str, "\0") para remover el relleno.

Si se está, por ejemplo, almacenando los datos en una base de datos MySQL, se debe tener en cuenta que durante la inserción en campos varchar, los espacios finales son removidos. Ya que la información cifrada puede finalizar con un espacio (ASCII 32), los datos serán dañados por esta remoción. En cambio, almacene los datos en un campo tinyblob/tinytext (o mayor).

Parámetros

td

El descriptor de cifrado.

El gestor de cifrado debería siempre ser inicializado con mcrypt_generic_init() con una clave y un IV antes de invocar a esta función. Cuando el cifrado haya terminado, se debería liberar los buffers de cifrado al invocar a mcrypt_generic_deinit() Véase mcrypt_module_open() para un ejemplo.

data

Los datos a encriptar.

Valores devueltos

Devuelve la información cifrada.

Ver también

  • mdecrypt_generic() - Desencripta datos
  • mcrypt_generic_init() - Esta función inicializa todos los buffers requeridos para el cifrado
  • mcrypt_generic_deinit() - Esta función deinicializa un módulo de cifrado


Toma el tamaño del bloque del cifrador especificado

  • « mcrypt_generic
  • mcrypt_get_cipher_name »
  • PHP Manual
  • Funciones de Mcrypt
  • Toma el tamaño del bloque del cifrador especificado

mcrypt_get_block_size

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_block_size — Toma el tamaño del bloque del cifrador especificado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_get_block_size ( int $cipher ) : int
mcrypt_get_block_size ( string $cipher , string $mode ) : int

El primer prototipo es cuando se enlaza con libmcrypt 2.2.x, el segundo cuando se enlaza con libmcrypt 2.4.x o 2.5.x.

mcrypt_get_block_size() es utilizada para tomar el tamaño de un bloque del cifrador especificado a través de cipher (en combinación con un modo de algoritmo).

Es más útil utilizar la función mcrypt_enc_get_block_size() ya que ésta última utiliza el valor resource devuelto por mcrypt_module_open().

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

Valores devueltos

Devuelve el tamaño de bloque del algoritmo en bytes o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_get_block_size()

Este ejemplo muestra cómo utilizar ésta función cuando está enlazada con libmcrypt 2.4.x y 2.5.x.

<?php

echo mcrypt_get_block_size('tripledes', 'ecb'); // 8

?>

Ver también

  • mcrypt_get_key_size() - Toma el tamaño de clave del cifrador especificado
  • mcrypt_enc_get_block_size() - Devuelve el tamaño del bloque del algoritmo abierto
  • mcrypt_encrypt() - Cifra texto plano con los parámetros dados


Toma el nombre del cifrador especificado

  • « mcrypt_get_block_size
  • mcrypt_get_iv_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Toma el nombre del cifrador especificado

mcrypt_get_cipher_name

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_cipher_name — Toma el nombre del cifrador especificado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_get_cipher_name ( int $cipher ) : string
mcrypt_get_cipher_name ( string $cipher ) : string

mcrypt_get_cipher_name() es utilizada para tomar el nombre del cifrador especificado.

mcrypt_get_cipher_name() toma el número del cifrador como un argumento (libmcrypt 2.2.x) o toma el nombre del cifrador como un argumento (libmcrypt 2.4.x o superiores) y devuelve el nombre del cifrador o false si el cifrador no existe.

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

Valores devueltos

Esta función devuelve el nombre del cifrador o false si el cifrador no existe.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_get_cipher_name()

<?php
   $cipher = MCRYPT_TripleDES;

   echo mcrypt_get_cipher_name($cipher);
?>

El resultado del ejemplo sería:

3DES


Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica

  • « mcrypt_get_cipher_name
  • mcrypt_get_key_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica

mcrypt_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_iv_size — Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_get_iv_size ( string $cipher , string $mode ) : int

Toma el tamaño del IV perteneciente a una combinación específica de los parámetros cipher/mode.

Es más útil utilizar la función mcrypt_enc_get_iv_size() debido a que ésta última hace uso del valor resource devuelto por mcrypt_module_open().

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

El IV es ignorado en modo ECB ya que este modo no lo necesita. Necesitará tener el mismo IV (piense: punto de partida) para tanto la etapa de cifrado como la de desencriptación, de lo contrario la encriptación fallará.

Valores devueltos

Devuelve el tamaño del vector de inicialización (IV) en bytes. En caso de error la función devuelve false. Si el IV es ignorado en la combinación cifrador/modo especificada el valor devuelto es cero.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_get_iv_size()

<?php
    echo mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB) . "\n";

    echo mcrypt_get_iv_size('des', 'ecb') . "\n";
?>

Ver también

  • mcrypt_get_block_size() - Toma el tamaño del bloque del cifrador especificado
  • mcrypt_enc_get_iv_size() - Devuelve el tamaño del IV del algoritmo abierto
  • mcrypt_create_iv() - Crea un vector de inicialización (IV) desde una fuente aleatoria


Toma el tamaño de clave del cifrador especificado

  • « mcrypt_get_iv_size
  • mcrypt_list_algorithms »
  • PHP Manual
  • Funciones de Mcrypt
  • Toma el tamaño de clave del cifrador especificado

mcrypt_get_key_size

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_key_size — Toma el tamaño de clave del cifrador especificado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_get_key_size ( int $cipher ) : int
mcrypt_get_key_size ( string $cipher , string $mode ) : int

El primer prototipo es cuando está enlazado con libmcrypt 2.2.x, el segundo cuando está enlazado con libmcrypt 2.4.x o 2.5.x.

mcrypt_get_key_size() es utilizada para tomar el tamaño de la clave del cifrador especificado con el parámetro cipher (en combinación con un modo de cifrado).

Es más útil usar la función mcrypt_enc_get_key_size() ya que ésta última hace uso del valor resource devuelto por mcrypt_module_open().

Parámetros

cipher

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

Valores devueltos

Devuelve el tamaño máximo soportado de la clave del algoritmo en bytes o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_get_key_size()

<?php
    echo mcrypt_get_key_size('tripledes', 'ecb');
?>

Este ejemplo anterior muestra cómo utilizar esta función cuando está enlazada con libmcrypt 2.4.x o 2.5.x.

El resultado del ejemplo sería:

24

Ver también

  • mcrypt_get_block_size() - Toma el tamaño del bloque del cifrador especificado
  • mcrypt_enc_get_key_size() - Devuelve el tamaño de clave máximo soportado por el modo abierto
  • mcrypt_encrypt() - Cifra texto plano con los parámetros dados


Obtiene un array con todos los cifradores soportados

  • « mcrypt_get_key_size
  • mcrypt_list_modes »
  • PHP Manual
  • Funciones de Mcrypt
  • Obtiene un array con todos los cifradores soportados

mcrypt_list_algorithms

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_list_algorithms — Obtiene un array con todos los cifradores soportados

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_list_algorithms ( string $lib_dir = ini_get("mcrypt.algorithms_dir") ) : array

Obtiene una lista de todos los algoritmos soportados en el parámetro lib_dir.

Parámetros

lib_dir

Especifica el directorio donde todos los algoritmos están ubicados. Si no se especifica, se utiliza el valor de la directiva mcrypt.algorithms_dir del fichero php.ini.

Valores devueltos

Devuelve un array con todos los algoritmos soportados.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_list_algorithms()

<?php
    $algorithms = mcrypt_list_algorithms("/usr/local/lib/libmcrypt");

    foreach ($algorithms as $cipher) {
        echo "$cipher<br />\n";
    }
?>

El ejemplo anterior produrirá una lista con todos los algoritmos soportados en el directorio "/usr/local/lib/libmcrypt".


Obtiene un array con todos los modos soportados

  • « mcrypt_list_algorithms
  • mcrypt_module_close »
  • PHP Manual
  • Funciones de Mcrypt
  • Obtiene un array con todos los modos soportados

mcrypt_list_modes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_list_modes — Obtiene un array con todos los modos soportados

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_list_modes ( string $lib_dir = ini_get("mcrypt.modes_dir") ) : array

Obtiene una lista de todos modos soportados por el parámetro lib_dir.

Parámetros

lib_dir

Especifica el directorio donde todos los modos están ubicados. Si no se especifica, se utiliza el valor de la directiva mcrypt.modes_dir del fichero php.ini.

Valores devueltos

Devuelve un array con todos los modos soportados.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_list_modes()

<?php
    $modes = mcrypt_list_modes();

    foreach ($modes as $mode) {
        echo "$mode <br />\n";
    }
?>

El ejemplo anterior producirá una lista con todos los algoritmos soportados en el directorio de modos por defecto. Si no es seteado con la directiva mcrypt.modes_dir del fichero php.ini, se utiliza el directorio por defecto de mcrypt (que es /usr/local/lib/libmcrypt).


Cierra el módulo mcrypt

  • « mcrypt_list_modes
  • mcrypt_module_get_algo_block_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Cierra el módulo mcrypt

mcrypt_module_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_close — Cierra el módulo mcrypt

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_close ( resource $td ) : bool

Cierra el gestor de cifrado especificado.

Parámetros

td

El descriptor de cifrado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mcrypt_module_open() - Abre el módulo del algoritmo y el modo a ser utilizados


Devuelve el tamaño de bloque del algoritmo especificado

  • « mcrypt_module_close
  • mcrypt_module_get_algo_key_size »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño de bloque del algoritmo especificado

mcrypt_module_get_algo_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_algo_block_size — Devuelve el tamaño de bloque del algoritmo especificado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_get_algo_block_size ( string $algorithm , string $lib_dir = ? ) : int

Toma el tamaño de bloque del algoritmo especificado.

Parámetros

algorithm

El nombre del algoritmo.

lib_dir

Este parámetro opcional puede contener la ubicación donde el módulo de modos se encuentra dentro del sistema.

Valores devueltos

Devuelve el tamaño de bloque del algoritmo especificado en bytes.


Devuelve el tamaño de clave máximo soportado por el modo abierto

  • « mcrypt_module_get_algo_block_size
  • mcrypt_module_get_supported_key_sizes »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve el tamaño de clave máximo soportado por el modo abierto

mcrypt_module_get_algo_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_algo_key_size — Devuelve el tamaño de clave máximo soportado por el modo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_get_algo_key_size ( string $algorithm , string $lib_dir = ? ) : int

Toma el tamaño de clave máximo soportado por el modo abierto.

Parámetros

algorithm

El nombre del algoritmo.

lib_dir

Este parámetro opcional puede contener la ubicación donde el módulo de modos se encuentra dentro del sistema.

Valores devueltos

Esta función devuelve el tamaño de clave máximo soportado por el algoritmo especificado en bytes.


Devuelve un array con los tamaños de clave soportados del algoritmo abierto

  • « mcrypt_module_get_algo_key_size
  • mcrypt_module_is_block_algorithm_mode »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve un array con los tamaños de clave soportados del algoritmo abierto

mcrypt_module_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_supported_key_sizes — Devuelve un array con los tamaños de clave soportados del algoritmo abierto

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_get_supported_key_sizes ( string $algorithm , string $lib_dir = ? ) : array

Devuelve un array con los tamaños de clave soportados por el algoritmo especificado Si devuelve un array vacío es porque todos los tamaños de clave entre 1 y mcrypt_module_get_algo_key_size() son soportados por el algoritmo.

Parámetros

algorithm

El algoritmo a ser utilizado.

lib_dir

El parámetro opcional lib_dir puede contener la ubicación donde el módulo de algoritmos se encuentra dentro del sistema.

Valores devueltos

Devuelve un array con los tamaños de clave soportados por el algoritmo especificado Si devuelve un array vacío es porque todos los tamaños de clave entre 1 y mcrypt_module_get_algo_key_size() son soportados por el algoritmo.

Ver también

  • mcrypt_enc_get_supported_key_sizes() - Devuelve un array con los tamaños de clave soportados por el algoritmo abierto


Devuelve si el módulo especificado es un algoritmo por bloques o no

  • « mcrypt_module_get_supported_key_sizes
  • mcrypt_module_is_block_algorithm »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve si el módulo especificado es un algoritmo por bloques o no

mcrypt_module_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_algorithm_mode — Devuelve si el módulo especificado es un algoritmo por bloques o no

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_is_block_algorithm_mode ( string $mode , string $lib_dir = ? ) : bool

Esta función devuelve true si el modo especificado es para ser utilizado con algoritmos por bloques, o de lo contrario devuelve false. (por ej., false para stream, y true para cbc, cfb, ofb).

Parámetros

mode

El modo a chequear.

lib_dir

El parámetro opcional lib_dir puede contener la ubicación donde el módulo de algoritmos se encuentra dentro del sistema.

Valores devueltos

Esta función devuelve true si el modo especificado es para ser utilizado con algoritmos por bloques, o de lo contrario devuelve false. (por ej., false para stream, y true para cbc, cfb, ofb).


Esta función chequea si el algoritmo especificado es un algoritmo por bloques

  • « mcrypt_module_is_block_algorithm_mode
  • mcrypt_module_is_block_mode »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función chequea si el algoritmo especificado es un algoritmo por bloques

mcrypt_module_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_algorithm — Esta función chequea si el algoritmo especificado es un algoritmo por bloques

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_is_block_algorithm ( string $algorithm , string $lib_dir = ? ) : bool

Esta función devuelve true si el algoritmo especificado es un algoritmo por bloques, o false si es uno de flujo.

Parámetros

algorithm

El algoritmo a chequear.

lib_dir

El parámetro opcional lib_dir puede contener la ubicación donde el módulo de algoritmos se encuentra dentro del sistema.

Valores devueltos

Esta función devuelve true si el algoritmo especificado es un algoritmo por bloques, o false si es uno de flujo.


Devuelve si el modo especificado retorna bloques o no

  • « mcrypt_module_is_block_algorithm
  • mcrypt_module_open »
  • PHP Manual
  • Funciones de Mcrypt
  • Devuelve si el modo especificado retorna bloques o no

mcrypt_module_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_mode — Devuelve si el modo especificado retorna bloques o no

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_is_block_mode ( string $mode , string $lib_dir = ? ) : bool

Esta función devuelve true si el modo especificado retorna bloques de bytes o false si retorna tan solo bytes. (por ej., true para cbc y ecb, y false para cfb y stream).

Parámetros

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

lib_dir

El parámetro opcional lib_dir puede contener la ubicación donde el módulo de algoritmos se encuentra dentro del sistema.

Valores devueltos

Esta función devuelve true si el modo especificado retorna bloques de bytes o false si retorna tan solo bytes. (por ej., true para cbc y ecb, y false para cfb y stream).


Abre el módulo del algoritmo y el modo a ser utilizados

  • « mcrypt_module_is_block_mode
  • mcrypt_module_self_test »
  • PHP Manual
  • Funciones de Mcrypt
  • Abre el módulo del algoritmo y el modo a ser utilizados

mcrypt_module_open

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_open — Abre el módulo del algoritmo y el modo a ser utilizados

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_open ( string $algorithm , string $algorithm_directory , string $mode , string $mode_directory ) : resource

Esta función abre el módulo del algoritmo y el modo a ser utilizados. El nombre del algoritmo es especificado en algorithm, por ejemplo "twofish" o una de las constantes MCRYPT_ciphername. El módulo es cerrado al invocar a mcrypt_module_close().

Parámetros

algorithm

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

algorithm_directory

El parámetro algorithm_directory se utiliza para ubicar el módulo de encriptación. Cuando se pasa un nombre de directorio, es utilizado. Cuando se pasa una cadena vacía (""), se utiliza el valor configurado en la directiva mcrypt.algorithms_dir del fichero php.ini. Cuando no se pasa nada, el directorio por defecto que se utiliza es en el que libmcrypt fue compilado (generalmente /usr/local/lib/libmcrypt).

mode

Una de las constantes MCRYPT_MODE_nombredelmodo, o una de las siguientes strings: "ecb", "cbc", "cfb", "ofb", "nofb" o "stream".

mode_directory

El parámetro mode_directory se utiliza para ubicar el módulo de encriptación. Cuando se pasa un nombre de directorio, es utilizado. Cuando se pasa una cadena vacía (""), se utiliza el valor configurado en la directiva mcrypt.modes_dir del fichero php.ini. Cuando no se pasa nada, el directorio por defecto que se utiliza es en el que libmcrypt fue compilado (generalmente /usr/local/lib/libmcrypt).

Valores devueltos

Normalmente devuelve un descriptor de cifrado, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_module_open()

<?php
    $td = mcrypt_module_open(MCRYPT_DES, '',
        MCRYPT_MODE_ECB, '/usr/lib/mcrypt-modes');

    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');
?>

La primer línea del ejemplo anterior intentará abrir el cifrador DES desde el directorio por defecto y el modo ECB desde el directorio /usr/lib/mcrypt-modes. El segundo ejemplo utiliza cadenas como nombres para el cifrador y el modo, esto solo funciona cuando la extensión está enlazado con libmcrypt 2.4.x o 2.5.x.

Ejemplo #2 Utilizando mcrypt_module_open() en el proceso de cifrado

<?php
    /* Open the cipher */
    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');

    /* Create the IV and determine the keysize length, use MCRYPT_RAND
     * on Windows instead */
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_RANDOM);
    $ks = mcrypt_enc_get_key_size($td);

    /* Create key */
    $key = substr(md5('very secret key'), 0, $ks);

    /* Intialize encryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Encrypt data */
    $encrypted = mcrypt_generic($td, 'This is very important data');

    /* Terminate encryption handler */
    mcrypt_generic_deinit($td);

    /* Initialize encryption module for decryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Decrypt encrypted string */
    $decrypted = mdecrypt_generic($td, $encrypted);

    /* Terminate decryption handle and close module */
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);

    /* Show string */
    echo trim($decrypted) . "\n";
?>

Ver también

  • mcrypt_module_close() - Cierra el módulo mcrypt
  • mcrypt_generic() - Esta función encripta datos
  • mdecrypt_generic() - Desencripta datos
  • mcrypt_generic_init() - Esta función inicializa todos los buffers requeridos para el cifrado
  • mcrypt_generic_deinit() - Esta función deinicializa un módulo de cifrado


Esta función ejecuta una prueba automática sobre el módulo especificado

  • « mcrypt_module_open
  • mcrypt_ofb »
  • PHP Manual
  • Funciones de Mcrypt
  • Esta función ejecuta una prueba automática sobre el módulo especificado

mcrypt_module_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_self_test — Esta función ejecuta una prueba automática sobre el módulo especificado

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mcrypt_module_self_test ( string $algorithm , string $lib_dir = ? ) : bool

Esta función ejecuta la prueba automática sobre el algoritmo especificado.

Parámetros

algorithm

Una de las constantes MCRYPT_nombredelcifrado, o el nombre del algoritmo como string.

lib_dir

El parámetro opcional lib_dir puede contener la ubicación donde el módulo de algoritmos se encuentra dentro del sistema.

Valores devueltos

Esta fucnión devuelve true si la prueba automática es exitosa, o false cuando falla.

Ejemplos

Ejemplo #1 Ejemplo de mcrypt_module_self_test()

<?php
var_dump(mcrypt_module_self_test(MCRYPT_RIJNDAEL_128)) . "\n";
var_dump(mcrypt_module_self_test(MCRYPT_BOGUS_CYPHER));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)


Encripta/desencripta datos en modo OFB

  • « mcrypt_module_self_test
  • mdecrypt_generic »
  • PHP Manual
  • Funciones de Mcrypt
  • Encripta/desencripta datos en modo OFB

mcrypt_ofb

(PHP 4, PHP 5)

mcrypt_ofb — Encripta/desencripta datos en modo OFB

Advertencia

Esta función está OBSOLETA en PHP 5.5.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

Descripción

mcrypt_ofb ( int $cipher , string $key , string $data , int $mode , string $iv ) : string
mcrypt_ofb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

El primer prototipo es cuando se enlazó con libmcrypt 2.2.x, el segundo cuando se enlazó con libmcrypt 2.4.x o superiores. El parámetro mode debería ser o MCRYPT_ENCRYPT o MCRYPT_DECRYPT.


Desencripta datos

  • « mcrypt_ofb
  • Mhash »
  • PHP Manual
  • Funciones de Mcrypt
  • Desencripta datos

mdecrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mdecrypt_generic — Desencripta datos

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

mdecrypt_generic ( resource $td , string $data ) : string

Esta función desencripta datos. Note que la longitud de la cadena retornada puede ser mayor a la cadena no cifrada, debido al relleno de la información.

Parámetros

td

Un descriptor de cifrado devuelto por mcrypt_module_open()

data

Los datos encriptados.

Ejemplos

Ejemplo #1 Ejemplo de mdecrypt_generic()

<?php
    /* Data */
    $key = 'esta es una clave muy larga, aún para el cifrador';
    $plain_text = 'información muy importante';

    /* Apertura de un modo, y creación de un IV */
    $td = mcrypt_module_open('des', '', 'ecb', '');
    $key = substr($key, 0, mcrypt_enc_get_key_size($td));
    $iv_size = mcrypt_enc_get_iv_size($td);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    /* Iniciando gestor de encriptación */
    if (mcrypt_generic_init($td, $key, $iv) != -1) {

        /* Encriptación de los datos */
        $c_t = mcrypt_generic($td, $plain_text);
        mcrypt_generic_deinit($td);

        /* Reinicialización de los buffers para desencriptación */
        mcrypt_generic_init($td, $key, $iv);
        $p_t = mdecrypt_generic($td, $c_t);

        /* Finalización */
        mcrypt_generic_deinit($td);
        mcrypt_module_close($td);
    }

    if (strncmp($p_t, $plain_text, strlen($plain_text)) == 0) {
        echo "ok\n";
    } else {
        echo "error\n";
    }
?>

El ejemplo anterior muestra cómo chequear si los datos antes del cifrado son los mismos después de la decriptación. Es muy importante reinicializar el buffer de cifrado con mcrypt_generic_init() antes de intentar descifrar los datos.

El identificador de descifrado debería siempre ser inicializado con mcrypt_generic_init() con una clave y un IV antes de invocar a esta función. Cuando el cifrado haya terminado, se debería liberar los buffers de cifrado al invocar a mcrypt_generic_deinit() Véase mcrypt_module_open() para un ejemplo.

Ver también

  • mcrypt_generic() - Esta función encripta datos
  • mcrypt_generic_init() - Esta función inicializa todos los buffers requeridos para el cifrado
  • mcrypt_generic_deinit() - Esta función deinicializa un módulo de cifrado


Mhash

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Mhash
    • mhash_count — Toma el mayor ID de hash disponible
    • mhash_get_block_size — Toma el tamaño de bloque del algoritmo hash especificado
    • mhash_get_hash_name — Toma el nombre del algoritmo hash especificado
    • mhash_keygen_s2k — Genera una clave
    • mhash — Calcula el hash


Introducción

Estas funciones están destinadas a trabajar con » mhash. Mhash puede ser utilizada para crear sumas de comprobación, resúmenes de mensajes, códigos de autentificación de mensajes, y más.

Es una interfaz a la biblioteca mhash. Mhash admite una gran variedad de algoritmos hash tales como MD5, SHA1, GOST y muchos otros. Una lista completa sobre los algoritmos hash admitidos se encuentra en la página de constantes predefinidas. La regla general es que se puede acceder a un algoritmo hash desde PHP con MHASH_nombrehash. Por ejemplo, para acceder a TIGER se puede usar la constante MHASH_TIGER de PHP.

Nota:

Esta extensión a quedado obsoleta por Hash.


Requerimientos

Para utilizarla, se debe descargar la distribución mhash de » su sitio web y seguir las instrucciones de instalación incluidas.


Instalación

Se necesita compilar PHP con el parámetro --with-mhash[=DIR] para habilitar esta extensión. DIR es el directorio de instalación de mhash.

A partir de PHP 5.3.0, la extensión mhash esta emulada a través de la extensión Hash. Esto hace que el directorio de instalación de mhash no tenga efecto, y requiera de la extensión hash habilitada para habilitar el soporte de mhash.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

He aquí una lista de los algoritmos hash que actualmente son soportados por mhash. Si un algoritmo no esta listado aquí, pero está mencionado en la documentación de mhash como soportado, puede asumir tranquilamente que esta documentación está desactualizada.

  • MHASH_ADLER32
  • MHASH_CRC32
  • MHASH_CRC32B
  • MHASH_GOST
  • MHASH_HAVAL128
  • MHASH_HAVAL160
  • MHASH_HAVAL192
  • MHASH_HAVAL224
  • MHASH_HAVAL256
  • MHASH_MD2
  • MHASH_MD4
  • MHASH_MD5
  • MHASH_RIPEMD128
  • MHASH_RIPEMD256
  • MHASH_RIPEMD320
  • MHASH_SHA1
  • MHASH_SHA192
  • MHASH_SHA224
  • MHASH_SHA256
  • MHASH_SHA384
  • MHASH_SHA512
  • MHASH_SNEFRU128
  • MHASH_SNEFRU256
  • MHASH_TIGER
  • MHASH_TIGER128
  • MHASH_TIGER160
  • MHASH_WHIRLPOOL


Ejemplos

Ejemplo #1 Calcula el MD5 y el hmac, y lo imprime como hexadecimal

<?php
$input = "what do ya want for nothing?";
$hash = mhash(MHASH_MD5, $input);
echo "El hash es " . bin2hex($hash) . "<br />\n";
$hash = mhash(MHASH_MD5, $input, "Jefe");
echo "El hmac es " . bin2hex($hash) . "<br />\n";
?>

El resultado del ejemplo sería:

El hash es d03cb659cbf9192dcd066272249f8412
El hmac es 750c783e6ab0b503eaa86e310a5db738


Funciones de Mhash

Tabla de contenidos

  • mhash_count — Toma el mayor ID de hash disponible
  • mhash_get_block_size — Toma el tamaño de bloque del algoritmo hash especificado
  • mhash_get_hash_name — Toma el nombre del algoritmo hash especificado
  • mhash_keygen_s2k — Genera una clave
  • mhash — Calcula el hash


Toma el mayor ID de hash disponible

  • « Funciones de Mhash
  • mhash_get_block_size »
  • PHP Manual
  • Funciones de Mhash
  • Toma el mayor ID de hash disponible

mhash_count

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_count — Toma el mayor ID de hash disponible

Descripción

mhash_count ( ) : int

Toma el mayor ID de hash disponible.

Valores devueltos

Devuelve el mayor ID de hash disponible. Los hash son enumerados de 0 a este ID de hash.

Ejemplos

Ejemplo #1 Atravesando todos los hash

<?php

$nr = mhash_count();

for ($i = 0; $i <= $nr; $i++) {
    echo sprintf("El tamaño de bloque de %s es %d\n",
        mhash_get_hash_name($i),
        mhash_get_block_size($i));
}
?>


Toma el tamaño de bloque del algoritmo hash especificado

  • « mhash_count
  • mhash_get_hash_name »
  • PHP Manual
  • Funciones de Mhash
  • Toma el tamaño de bloque del algoritmo hash especificado

mhash_get_block_size

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_get_block_size — Toma el tamaño de bloque del algoritmo hash especificado

Descripción

mhash_get_block_size ( int $hash ) : int

Toma el tamaño de bloque del algoritmo hash especificado.

Parámetros

hash

El ID de hash. Una de las constantes MHASH_hashname.

Valores devueltos

Devuelve el tamaño en bytes o false si el algoritmo hash pasado no existe.

Ejemplos

Ejemplo #1 Ejemplo de mhash_get_block_size()

<?php

echo mhash_get_block_size(MHASH_MD5); // 16

?>


Toma el nombre del algoritmo hash especificado

  • « mhash_get_block_size
  • mhash_keygen_s2k »
  • PHP Manual
  • Funciones de Mhash
  • Toma el nombre del algoritmo hash especificado

mhash_get_hash_name

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_get_hash_name — Toma el nombre del algoritmo hash especificado

Descripción

mhash_get_hash_name ( int $hash ) : string

Toma el nombre del algoritmo hash especificado.

Parámetros

hash

El ID de hash. Una de las constantes MHASH_hashname.

Valores devueltos

Devuelve el nombre del algoritmo hash o false si el algoritmo hash pasado no existe.

Ejemplos

Ejemplo #1 Ejemplo de mhash_get_hash_name()

<?php

echo mhash_get_hash_name(MHASH_MD5); // MD5

?>


Genera una clave

  • « mhash_get_hash_name
  • mhash »
  • PHP Manual
  • Funciones de Mhash
  • Genera una clave

mhash_keygen_s2k

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

mhash_keygen_s2k — Genera una clave

Descripción

mhash_keygen_s2k ( int $hash , string $password , string $salt , int $bytes ) : string

Genera una clave de acuerdo al algoritmo hash dado, utilizando el password provisto por el usuario.

Este es el algoritmo S2K con Sal, tal y como se encuentra especificado en el documento OpenPGP (» RFC 2440).

Tener en cuenta que las contraseñas suministradas por el usuario no son realmente útiles como claves en algoritmos criptográficos, ya que los usuarios normalmente eligen claves que pueden escribir con el teclado. Estas contraseñas utilizan sólo 6 o 7 bits por caracter (o menos). Es altamente recomendable utilizar algún tipo de transformación (como esta función) a la clave provista por el usuario.

Parámetros

hash

El ID de hash utilizado para crear la clave. Una de las constantes MHASH_hashname.

password

Una contraseña suministrada por el usuario.

salt

Debe ser diferente y lo suficientemente aleatorio para cada clave generada con el fin de crear claves distintas. Debido a que el parámetro salt debe ser conocido cuando se comprueban las claves, es una buena idea anexarle la clave. Este parámetro tienen una longitud fija de 8 bytes y será rellenada con ceros si se suministran menos bytes.

bytes

La longitud de la clave, en bytes.

Valores devueltos

Devuelve la clave generada en formato cadena, o false en caso de error.


Calcula el hash

  • « mhash_keygen_s2k
  • OpenSSL »
  • PHP Manual
  • Funciones de Mhash
  • Calcula el hash

mhash

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash — Calcula el hash

Descripción

mhash ( int $hash , string $data , string $key = ? ) : string

La función mhash() aplica la función hash especificada por el parámetro hash a los datos del parámetro data.

Parámetros

hash

El ID de hash. Una de las constantes MHASH_hashname.

data

La entrada del usuario, en formato cadena.

key

De ser especificado, la función devolverá, en cambio, el HMAC resultante. HMAC es un algoritmo de autentificación de clave secreta, o simplemente resumen de mensaje que depende de la clave especificada. No todos los algoritmos soportados por mhash pueden ser utilizados en modo HMAC.

Valores devueltos

Devuelve el hash (también llamado digest) o HMAC resultante en formato cadena, o false en caso de error.


OpenSSL

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • Banderas de comprobación de propósito
    • Banderas de relleno para encriptación asimétrica
    • Tipos de claves
    • Banderas/Constantes PKCS7
    • Algoritmos de Firma
    • Cifrados
    • Constantes de Versión
    • Constantes de Indicación del Nombre del Servidor
  • Parámetros de Clave/Certificado
  • Verificación de Certificados
  • Funciones de OpenSSL
    • openssl_cipher_iv_length — Obtener la longitud del iv de cipher
    • openssl_cms_decrypt — Decrypt a CMS message
    • openssl_cms_encrypt — Encrypt a CMS message
    • openssl_cms_read — Export the CMS file to an array of PEM certificates
    • openssl_cms_sign — Sign a file
    • openssl_cms_verify — Verify a CMS signature
    • openssl_csr_export_to_file — Exporta una CSR a un archivo
    • openssl_csr_export — Exporta una CSR como una cadena
    • openssl_csr_get_public_key — Devuelve la clave púbilca de un CERT
    • openssl_csr_get_subject — Devuelve el sujeto de un CERT
    • openssl_csr_new — Genera una CSR
    • openssl_csr_sign — Firmar una CSR con otro certificado (o autofirmar) y generar un certificado
    • openssl_decrypt — Desencripta datos
    • openssl_dh_compute_key — Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local
    • openssl_digest — Computa un método de resumen
    • openssl_encrypt — Cifra datos
    • openssl_error_string — Devolver un mensaje de error openSSL
    • openssl_free_key — Liberar el recurso de clave
    • openssl_get_cert_locations — Obtener las ubicaciones de certificados disponibles
    • openssl_get_cipher_methods — Obtiene los métodos de cifrado disponibles
    • openssl_get_curve_names — Gets list of available curve names for ECC
    • openssl_get_md_methods — Obtener los métodos de resumen disponibles
    • openssl_get_privatekey — Alias de openssl_pkey_get_private
    • openssl_get_publickey — Alias de openssl_pkey_get_public
    • openssl_open — Abre información sellada
    • openssl_pbkdf2 — Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1
    • openssl_pkcs12_export_to_file — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12
    • openssl_pkcs12_export — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable
    • openssl_pkcs12_read — Convierte un Almacén de Certificado PKCS#12 a una matriz
    • openssl_pkcs7_decrypt — Desencripta un mensaje S/MIME encriptado
    • openssl_pkcs7_encrypt — Encriptar un mensaje S/MIME
    • openssl_pkcs7_read — Export the PKCS7 file to an array of PEM certificates
    • openssl_pkcs7_sign — Firma un mensaje S/MIME
    • openssl_pkcs7_verify — Verifica la firma de un mensaje S/MIME firmado
    • openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key
    • openssl_pkey_export_to_file — Obtiene una representación de una clave exportable a un archivo
    • openssl_pkey_export — Obtiene una representación de una clave exportable a una cadena
    • openssl_pkey_free — Libera una clave privada
    • openssl_pkey_get_details — Devuelve una matriz con los detalles de la clave
    • openssl_pkey_get_private — Obtener una clave privada
    • openssl_pkey_get_public — Extrae la clave pública del certificado y la prepara para usarla
    • openssl_pkey_new — Genera una clave privada nueva
    • openssl_private_decrypt — Desencripta información con la clave privada
    • openssl_private_encrypt — Encripta información con la clave privada
    • openssl_public_decrypt — Desencripta información con la clave pública
    • openssl_public_encrypt — Encripta información con una clave pública
    • openssl_random_pseudo_bytes — Genera una cadena de bytes pseudo-aleatoria
    • openssl_seal — Sellar (encriptar) información
    • openssl_sign — Genera una firma
    • openssl_spki_export_challenge — Exporta el desafío asociados con una clave pública y desafío firmados
    • openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge
    • openssl_spki_new — Generate a new signed public key and challenge
    • openssl_spki_verify — Verifies a signed public key and challenge
    • openssl_verify — Verificar una firma
    • openssl_x509_check_private_key — Comprueba si una clave privada se corresponde a un certificado
    • openssl_x509_checkpurpose — Verifica si un certificado se puede usar para un propósito en particular
    • openssl_x509_export_to_file — Exporta un certificado a un archivo
    • openssl_x509_export — Exporta un certificado como una cadena
    • openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate
    • openssl_x509_free — Liberar un recurso de certificado
    • openssl_x509_parse — Analiza un certificado X509 y devuelve la información como un matriz
    • openssl_x509_read — Analiza un certificado X.509 y devuelve un identificador de recurso para él
    • openssl_x509_verify — Verifies digital signature of x509 certificate against a public key


Introducción

Este módulo utiliza las funciones de » OpenSSL para la generación y verificación de firmas y para sellar (cifrar) y abrir (descifrar) datos. OpenSSL ofrece muchas características que este módulo no soporta actualmente. Algunas de éstas podrían añadirse en el futuro.


Requerimientos

Para usar las funciones OpenSSL necesita instalar el paquete » OpenSSL. PHP, entre las versiones 4.0.5 y 4.3.1, funcionará con OpenSSL >= 0.9.5. Otras versiones (PHP <=4.0.4 y >= 4.3.2) requieren OpenSSL >= 0.9.6.

Advertencia

Se recomienda encarecidamente usar la versión más reciente de OpenSSL, si no su servidor web podría ser vulnerable a ataques.


Instalación

Para usar el soporte de OpenSSL en PHP debe también compilar PHP con --with-openssl[=DIR].

La biblioteca OpenSSL también tiene requerimientos adicionales para la operación normal en tiempo de ejecución. En particular, OpenSSL requiere acceso a un generador de números aleatorios o pseudoaleatorios; en la mayoría de plataformas Unix y similares a Unix (incluyendo Linux), esto significa que se debe tener acceso a dispositivo /dev/urandom o /dev/random.

Nota: Nota para los usuarios de Win32

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: libeay32.dll

Adicionalmente, si está planeando usar las funciones de generación de claves y firma de certificados, necesitará instalar un archivo openssl.cnf válido en su sistema. A partir de PHP 4.3.0, incluimos un archivo de configuración de ejemplo en nuestras distribuciones binarias de win32. En PHP 4.3.x y 4.4.x el archivo está en el directorio openssl. En PHP 5.x y 6.x el archivo está en el directorio extras/openssl. Si está utilizado PHP 4.2.x o ha perdido el archivo, puede obtenerlo en la página de binarios de OpenSSL o descargar una versión reciente de PHP. Sepa que Windows Explorer oculta la extensión .cnf por defecto y dice que el tipo de archivo es SpeedDial.

PHP buscará el archivo openssl.cnf usando la siguiente lógica:

  • la variable de entorno OPENSSL_CONF, si está establecida, se usará como la ruta (incluido el nombre de archivo) del archivo de configuración.
  • la variable de entorno SSLEAY_CONF, si está establecida, se usará como la ruta (incluido el nombre de archivo) del archivo de configuración.
  • El archivo openssl.cnf se asume que está en el área de certificados por defecto, como se configuró en el momento en que la DLL de OpenSSL fue compilada. Esto normalmente significa que el nombre de archivo por defecto es c:\usr\local\ssl\openssl.cnf.

Durante la instalación, necesita decidir si instalar el archivo de configuración en c:\usr\local\ssl\openssl.cnf o si instalarlo en otro lugar y usar variables de entorno (posiblemente de acuerdo a un servidor virtual) para ubicar el archivo de configuración. Observe que es posible sobrescribir la ruta por defecto desde el script usando el parámetro configargs de las funciones que requieren un archivo de configuración.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

openssl Opciones de configuración
Nombre | Por defecto | Cambiable | Registro de cambios
openssl.cafile | "" | PHP_INI_PERDIR | Disponible desde PHP 5.6.0.
openssl.capath | "" | PHP_INI_PERDIR | Disponible desde PHP 5.6.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

openssl.cafile string

Ubicación del fichero de la Autoridad de certificación (AC) en el sistema de ficheros local que debería emplearse con la opción de contexto verify_peer para autenticar la identidad del par remoto.

openssl.capath string

Si no se especifica cafile o si el certificado no se encuentra allí, se busca un certificado apropiado en el directorio al que apunta capath. capath debe ser un directorio de certificados con hash correcto.

Véase también las opciones de contexto de flujo de SSL.


Constantes predefinidas

Tabla de contenidos

  • Banderas de comprobación de propósito
  • Banderas de relleno para encriptación asimétrica
  • Tipos de claves
  • Banderas/Constantes PKCS7
  • Algoritmos de Firma
  • Cifrados
  • Constantes de Versión
  • Constantes de Indicación del Nombre del Servidor

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.


Banderas de comprobación de propósito

X509_PURPOSE_SSL_CLIENT (integer)
X509_PURPOSE_SSL_SERVER (integer)
X509_PURPOSE_NS_SSL_SERVER (integer)
X509_PURPOSE_SMIME_SIGN (integer)
X509_PURPOSE_SMIME_ENCRYPT (integer)
X509_PURPOSE_CRL_SIGN (integer)
X509_PURPOSE_ANY (integer)


Banderas de relleno para encriptación asimétrica

OPENSSL_PKCS1_PADDING (integer)
OPENSSL_SSLV23_PADDING (integer)
OPENSSL_NO_PADDING (integer)
OPENSSL_PKCS1_OAEP_PADDING (integer)


Tipos de claves

OPENSSL_KEYTYPE_RSA (integer)
OPENSSL_KEYTYPE_DSA (integer)
OPENSSL_KEYTYPE_DH (integer)
OPENSSL_KEYTYPE_EC (integer)
Esta constante únicamente está disponible cuando PHP está compilado con OpenSSL 0.9.8+.

Nota:

Esta constante fue añadida en la versión 5.2.0.

OPENSSL_KEYTYPE_EC


Banderas/Constantes PKCS7

Las funciones S/MIME hacen uso de banderas que están especificadas utilizando un campo de bit que puede incluir uno o más de los siguientes valores:

CONSTANTES PKCS7
Constante | Descripción
PKCS7_TEXT | Añade cabeceras de tipo de contenido texto/plano al mensaje encriptado/firmado. Si se desencripta o verifica, se desmontan esas cabeceras de la salida - si el mensaje desencriptado o verificado no es del tipo MIME texto/plano ocurrirá un error.
PKCS7_BINARY | Normalmente el mensaje de entrada es convertido a formato "canónico" en el que de hecho se usa CR y LF como final de línea: como se require por la especificación S/MIME. Cuando esta opción está presente, no se realiza ninguna traducción. Ésto es útil cuando se maneja información binaria que puede no estar en formato MIME.
PKCS7_NOINTERN | Cuando se verifica un mensaje, los certificados (si hay alguno) incluidos en el mensaje son buscados normalmente por el certificado de firma. Con esta opción sólo los certificados especificados el el parámetro extracerts de openssl_pkcs7_verify() se usan. Sin embargo, los certificados proporcionados pueden aún ser usados como AC que no son de confianza.
PKCS7_NOVERIFY | No verificar los certificados de firmas de un mensaje firmado.
PKCS7_NOCHAIN | No encadenar la verificación de certificados de firmas: es decir, no usar los certificados en el mensaje firmado como AC que no es de confianza.
PKCS7_NOCERTS | Cuando se firma un mensaje, el certificado del firmante normalmente está incluido - con esta opción se excluye. Esto reducirá el tamaño del mensaje firmado pero el verificador debe tener una copia del certificado del firmante que esté disponible localmente (usando al pasar extracerts a openssl_pkcs7_verify() por ejemplo).
PKCS7_NOATTR | Normalmente cuando un mensaje está firmado se incluyen un conjunto de atributos como el momento de la firma y los algoritmos simétricos soportados. Con esta opción todos éstos no se incluyen.
PKCS7_DETACHED | Cuando se firma un mensaje, se usa la firma de texto claro con el tipo MIME "multiparte/firmado". Esto es lo predeterminado si no se especifican algunos flags a openssl_pkcs7_sign(). Si se desactiva esta opción, el mensaje será firmado usando la firma opaca, que es más resistente a traducciones por transmisiones de correo, pero no puede ser leída por agentes de correo que no soporten S/MIME.
PKCS7_NOSIGS | No poner a prueba y verificar las firmas de un mensaje

Nota:

Estas constantes fueron añadidas en la versión 4.0.6.


Algoritmos de Firma

OPENSSL_ALGO_DSS1 (integer)
OPENSSL_ALGO_SHA1 (integer)
Usado como algoritmo predeterminado por openssl_sign() y openssl_verify().
OPENSSL_ALGO_SHA224 (integer)
OPENSSL_ALGO_SHA256 (integer)
OPENSSL_ALGO_SHA384 (integer)
OPENSSL_ALGO_SHA512 (integer)
OPENSSL_ALGO_RMD160 (integer)
OPENSSL_ALGO_MD5 (integer)
OPENSSL_ALGO_MD4 (integer)
OPENSSL_ALGO_MD2 (integer)
A partir de PHP 5.2.13 y PHP 5.3.2, esta constante únicamete está disponible si PHP está compilado con soporte para MD2. Esto requiere pasar -DHAVE_OPENSSL_MD2_H CFLAG al compilar PHP, y enable-md2 al compilar OpenSSL 1.0.0+.

Nota:

Estas constantes fueron añadidas en la versión 5.0.0.

OPENSSL_ALGO_MD2, OPENSSL_ALGO_MD4, OPENSSL_ALGO_MD5, OPENSSL_ALGO_SHA1, OPENSSL_ALGO_DSS1

Nota:

Estas constantes fueron añadidas en la versión 5.4.8.

OPENSSL_ALGO_RMD160, OPENSSL_ALGO_SHA224, OPENSSL_ALGO_SHA256, OPENSSL_ALGO_SHA384, OPENSSL_ALGO_SHA512


Cifrados

OPENSSL_CIPHER_RC2_40 (integer)
OPENSSL_CIPHER_RC2_128 (integer)
OPENSSL_CIPHER_RC2_64 (integer)
OPENSSL_CIPHER_DES (integer)
OPENSSL_CIPHER_3DES (integer)

Nota:

Estas constantes fueron añadidas en la versión 4.3.0.

OPENSSL_CIPHER_AES_128_CBC (integer)
OPENSSL_CIPHER_AES_192_CBC (integer)
OPENSSL_CIPHER_AES_256_CBC (integer)

Nota:

Estas constantes fueron añadadidas en la versión 5.4.0.


Constantes de Versión

OPENSSL_VERSION_TEXT (string)
OPENSSL_VERSION_NUMBER (integer)

Nota:

Estas constantes fueron añadidas en la versión 5.2.0.


Constantes de Indicación del Nombre del Servidor

OPENSSL_TLSEXT_SERVER_NAME (string)
Si el sopore para SNI está disponible o no.

Nota:

Estas constantes fueron añadidas en la versión 5.3.2 y requieren que PHP se construya con OpenSSL 0.9.8j o posterior.


Parámetros de Clave/Certificado

Bastantes funciones de openssl requieren un parámetro de clave o de certificado. PHP 4.0.5 y versiones anteriores tienen que usar un recurso resource de clave o certificado devuelto por una de las funciones openssl_get_xxx(). Las últimas versiones pueden usar uno de los siguientes métodos:

  • Certificados

    1. Un recurso X.509 devuelto por openssl_x509_read()
    2. Una cadena con el formato file://ruta/al/cert.pem; el fichero nombrado debe contener un certificado codificado con PEM
    3. Una cadena con el contenido de un certificado, codificado con PEM

  • Claves Públicas/Privadas

    1. Un recurso de clave devuelto por openssl_get_publickey() o openssl_get_privatekey()
    2. Sólo para claves públicas: un recurso X.509
    3. Una cadena con el formato file://ruta/al/archivo.pem - el archivo nombrado debe contener un certificado/clave privado codificado con PEM (puede contener ambos)
    4. Una cadena con el contenido de un certificado/clave, codificado con PEM
    5. Para claves privadas, también se debe usar la sintaxis array($clave, $passphrase) donde $clave representa una clave especificada usando la notación file:// o el contenido textual de arriba, y $passphrase representa una cadena que contiene una frase de contraseña para esa clave privada


Verificación de Certificados

Cuando se llama a una función para que verifique una firma/certificado, el parámetro cainfo es una matriz que contiene los nombres del archivo y del directorio que especifican las ubicaciones de los archivos de la AC (Autoridad de Certificación, CA en inglés) de confianza. Si se especifica un directorio, éste debe ser un directorio correctamente formado, como el comando openssl usaría.


Funciones de OpenSSL

Tabla de contenidos

  • openssl_cipher_iv_length — Obtener la longitud del iv de cipher
  • openssl_cms_decrypt — Decrypt a CMS message
  • openssl_cms_encrypt — Encrypt a CMS message
  • openssl_cms_read — Export the CMS file to an array of PEM certificates
  • openssl_cms_sign — Sign a file
  • openssl_cms_verify — Verify a CMS signature
  • openssl_csr_export_to_file — Exporta una CSR a un archivo
  • openssl_csr_export — Exporta una CSR como una cadena
  • openssl_csr_get_public_key — Devuelve la clave púbilca de un CERT
  • openssl_csr_get_subject — Devuelve el sujeto de un CERT
  • openssl_csr_new — Genera una CSR
  • openssl_csr_sign — Firmar una CSR con otro certificado (o autofirmar) y generar un certificado
  • openssl_decrypt — Desencripta datos
  • openssl_dh_compute_key — Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local
  • openssl_digest — Computa un método de resumen
  • openssl_encrypt — Cifra datos
  • openssl_error_string — Devolver un mensaje de error openSSL
  • openssl_free_key — Liberar el recurso de clave
  • openssl_get_cert_locations — Obtener las ubicaciones de certificados disponibles
  • openssl_get_cipher_methods — Obtiene los métodos de cifrado disponibles
  • openssl_get_curve_names — Gets list of available curve names for ECC
  • openssl_get_md_methods — Obtener los métodos de resumen disponibles
  • openssl_get_privatekey — Alias de openssl_pkey_get_private
  • openssl_get_publickey — Alias de openssl_pkey_get_public
  • openssl_open — Abre información sellada
  • openssl_pbkdf2 — Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1
  • openssl_pkcs12_export_to_file — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12
  • openssl_pkcs12_export — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable
  • openssl_pkcs12_read — Convierte un Almacén de Certificado PKCS#12 a una matriz
  • openssl_pkcs7_decrypt — Desencripta un mensaje S/MIME encriptado
  • openssl_pkcs7_encrypt — Encriptar un mensaje S/MIME
  • openssl_pkcs7_read — Export the PKCS7 file to an array of PEM certificates
  • openssl_pkcs7_sign — Firma un mensaje S/MIME
  • openssl_pkcs7_verify — Verifica la firma de un mensaje S/MIME firmado
  • openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key
  • openssl_pkey_export_to_file — Obtiene una representación de una clave exportable a un archivo
  • openssl_pkey_export — Obtiene una representación de una clave exportable a una cadena
  • openssl_pkey_free — Libera una clave privada
  • openssl_pkey_get_details — Devuelve una matriz con los detalles de la clave
  • openssl_pkey_get_private — Obtener una clave privada
  • openssl_pkey_get_public — Extrae la clave pública del certificado y la prepara para usarla
  • openssl_pkey_new — Genera una clave privada nueva
  • openssl_private_decrypt — Desencripta información con la clave privada
  • openssl_private_encrypt — Encripta información con la clave privada
  • openssl_public_decrypt — Desencripta información con la clave pública
  • openssl_public_encrypt — Encripta información con una clave pública
  • openssl_random_pseudo_bytes — Genera una cadena de bytes pseudo-aleatoria
  • openssl_seal — Sellar (encriptar) información
  • openssl_sign — Genera una firma
  • openssl_spki_export_challenge — Exporta el desafío asociados con una clave pública y desafío firmados
  • openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge
  • openssl_spki_new — Generate a new signed public key and challenge
  • openssl_spki_verify — Verifies a signed public key and challenge
  • openssl_verify — Verificar una firma
  • openssl_x509_check_private_key — Comprueba si una clave privada se corresponde a un certificado
  • openssl_x509_checkpurpose — Verifica si un certificado se puede usar para un propósito en particular
  • openssl_x509_export_to_file — Exporta un certificado a un archivo
  • openssl_x509_export — Exporta un certificado como una cadena
  • openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate
  • openssl_x509_free — Liberar un recurso de certificado
  • openssl_x509_parse — Analiza un certificado X509 y devuelve la información como un matriz
  • openssl_x509_read — Analiza un certificado X.509 y devuelve un identificador de recurso para él
  • openssl_x509_verify — Verifies digital signature of x509 certificate against a public key


Obtener la longitud del iv de cipher

  • « Funciones de OpenSSL
  • openssl_cms_decrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtener la longitud del iv de cipher

openssl_cipher_iv_length

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

openssl_cipher_iv_length — Obtener la longitud del iv de cipher

Descripción

openssl_cipher_iv_length ( string $method ) : int

Obtiene la longitud del vector de inicialización (iv) de cipher.

Parámetros

method

El método de cipher, véase openssl_get_cipher_methods() para una lista de valores potenciales.

Valores devueltos

Devuelve la longitud de cipher en caso de éxito, o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING cuando el algoritimo de cipher es desconocido.

Ejemplos

Ejemplo #1 Ejemplo de openssl_cipher_iv_length()

<?php
$método = 'AES-128-CBC';
$longitud_iv = openssl_cipher_iv_length($método);

echo $longitud_iv;
?>

El resultado del ejemplo sería algo similar a:

16


Decrypt a CMS message

  • « openssl_cipher_iv_length
  • openssl_cms_encrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Decrypt a CMS message

openssl_cms_decrypt

(PHP 8)

openssl_cms_decrypt — Decrypt a CMS message

Descripción

openssl_cms_decrypt ( string $input_filename , string $output_filename , OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string|null $private_key = null , int $encoding = OPENSSL_ENCODING_SMIME ) : bool

Decrypts a CMS message.

Parámetros

input_filename

The name of a file containing encrypted content.

output_filename

The name of the file to deposit the decrypted content.

certificate

The name of the file containing a certificate of the recipient.

private_key

The name of the file containing a PKCS#8 key.

encoding

The encoding of the input file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Encrypt a CMS message

  • « openssl_cms_decrypt
  • openssl_cms_read »
  • PHP Manual
  • Funciones de OpenSSL
  • Encrypt a CMS message

openssl_cms_encrypt

(PHP 8)

openssl_cms_encrypt — Encrypt a CMS message

Descripción

openssl_cms_encrypt ( string $input_filename , string $output_filename , OpenSSLCertificate|array|string $certificate , array|null $headers , int $flags = 0 , int $encoding = OPENSSL_ENCODING_SMIME , int $cipher_algo = OPENSSL_CIPHER_RC2_40 ) : bool

This function encrypts content to one or more recipients, based on the certificates that are passed to it.

Parámetros

input_filename

The file to be encrypted.

output_filename

The output file.

certificate

Recipients to encrypt to.

headers

Headers to include when S/MIME is used.

flags

Flags to be passed to CMS_sign.

encoding

An encoding to output. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

cipher_algo

A cypher to use.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Export the CMS file to an array of PEM certificates

  • « openssl_cms_encrypt
  • openssl_cms_sign »
  • PHP Manual
  • Funciones de OpenSSL
  • Export the CMS file to an array of PEM certificates

openssl_cms_read

(PHP 8)

openssl_cms_read — Export the CMS file to an array of PEM certificates

Descripción

openssl_cms_read ( string $input_filename , array &$certificates ) : bool

Performs the exact analog to openssl_pkcs7_read().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

input_filename

certificates

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Sign a file

  • « openssl_cms_read
  • openssl_cms_verify »
  • PHP Manual
  • Funciones de OpenSSL
  • Sign a file

openssl_cms_sign

(PHP 8)

openssl_cms_sign — Sign a file

Descripción

openssl_cms_sign ( string $input_filename , string $output_filename , OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $private_key , array|null $headers , int $flags = 0 , int $encoding = OPENSSL_ENCODING_SMIME , string|null $untrusted_certificates_filename = null ) : bool

This function signs a file with an X.509 certificate and key.

Parámetros

input_filename

The name of the file to be signed.

output_filename

The name of the file to deposit the results.

certificate

The name of the file containing the signing certificate.

private_key

The name of file containing the key associated with certificate.

headers

An array of headers to be included in S/MIME output.

flags

Flags to be passed to cms_sign().

encoding

The encoding of the output file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

untrusted_certificates_filename

Intermediate certificates to be included in the signature.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Verify a CMS signature

  • « openssl_cms_sign
  • openssl_csr_export_to_file »
  • PHP Manual
  • Funciones de OpenSSL
  • Verify a CMS signature

openssl_cms_verify

(PHP 8)

openssl_cms_verify — Verify a CMS signature

Descripción

openssl_cms_verify ( string $input_filename , int $flags = 0 , string|null $certificates = null , array $ca_info = [] , string|null $untrusted_certificates_filename = null , string|null $content = null , string|null $pk7 = null , string|null $sigfile = null , int $encoding = OPENSSL_ENCODING_SMIME ) : bool

This function verifies a CMS signature, either attached or detached, with the specified encoding.

Parámetros

input_filename

The input file.

flags

Flags to pass to cms_verify().

certificates

A file with the signer certificate and optionally intermediate certificates.

ca_info

An array containing self-signed certificate authority certificates.

untrusted_certificates_filename

A file containing additional intermediate certificates.

content

A file pointing to the content when signatures are detached.

pk7

sigfile

A file to save the signature to.

encoding

The encoding of the input file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Exporta una CSR a un archivo

  • « openssl_cms_verify
  • openssl_csr_export »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta una CSR a un archivo

openssl_csr_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_export_to_file — Exporta una CSR a un archivo

Descripción

openssl_csr_export_to_file ( resource $csr , string $outfilename , bool $notext = true ) : bool

openssl_csr_export_to_file() toma la Petición de Frima de Certificado (CSR en inglés) representada por csr y la almacena como texto ascii blindado en el archivo nombrado por outfilename.

Parámetros

csr

outfilename

Ruta del archivo de salida.

notext

El parámetro opcional notext afecta la verbosidad de la salida; si es false, se incluirá información adicional en la salida entendible por seres humanos. El valor por defecto para notext es true.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_csr_export() - Exporta una CSR como una cadena
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Exporta una CSR como una cadena

  • « openssl_csr_export_to_file
  • openssl_csr_get_public_key »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta una CSR como una cadena

openssl_csr_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_export — Exporta una CSR como una cadena

Descripción

openssl_csr_export ( resource $csr , string &$out , bool $notext = true ) : bool

openssl_csr_export() toma la Petición de Firma de Certificado (CSR en inglés) represenatada por csr y la almacena como texto ascii blindado en out, que es pasado por referencia.

Parámetros

csr

out

notext

El parámetro opcional notext afecta la verbosidad de la salida; si es false, se incluirá información adicional en la salida entendible por seres humanos. El valor por defecto para notext es true.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_csr_export_to_file() - Exporta una CSR a un archivo
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Devuelve la clave púbilca de un CERT

  • « openssl_csr_export
  • openssl_csr_get_subject »
  • PHP Manual
  • Funciones de OpenSSL
  • Devuelve la clave púbilca de un CERT

openssl_csr_get_public_key

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_csr_get_public_key — Devuelve la clave púbilca de un CERT

Descripción

openssl_csr_get_public_key ( mixed $csr , bool $use_shortnames = true ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve el sujeto de un CERT

  • « openssl_csr_get_public_key
  • openssl_csr_new »
  • PHP Manual
  • Funciones de OpenSSL
  • Devuelve el sujeto de un CERT

openssl_csr_get_subject

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_csr_get_subject — Devuelve el sujeto de un CERT

Descripción

openssl_csr_get_subject ( mixed $csr , bool $use_shortnames = true ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Genera una CSR

  • « openssl_csr_get_subject
  • openssl_csr_sign »
  • PHP Manual
  • Funciones de OpenSSL
  • Genera una CSR

openssl_csr_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_new — Genera una CSR

Descripción

openssl_csr_new ( array $dn , resource &$privkey , array $configargs = ? , array $extraattribs = ? ) : mixed

openssl_csr_new() genera una nueva CSR (Certificate Signing Request - Petición de Firma de Certificado) basada en la información proporcionada por dn, el cuál representa el Nombre Distinguido que se va a usar en el certificado.

Nota: Necesita tener instalado un openssl.cnf válido para que esta función opere correctamente. Vea las notas sobre la sección de instalación para más información.

Parámetros

dn

El Nombre Distinguido que se va a usar en el certificado.

privkey

privkey podría estar establecida a una clave privada que fue generada previamente por openssl_pkey_new() (o de otro modo, obtenida desde la otra familia de funciones openssl_pkey). La parte pública correspondiente de la clave será usada para firmar la CSR.

configargs

Por defecto, la información de su sistema openssl.conf se usa para inicializar la petición; puede especificar una sección del archivo de configuración estableciendo la clave config_sección_sección de configargs. También puede especificar un archivo de configuración de openssl alternativo estableciendo el valor de la clave config a la ruta del archivo que quiere utilizar. Las siguientes claves, si están presentes en configargs, se comportan como sus equivalentes en el archivo openssl.conf, como está listado en la tabla de abajo.

Sobrescritura de Configuración
clave configargs | tipo | equivalente openssl.conf | descripción
digest_alg | string | default_md | Selecciona qué método de resumen (digest) se va a usar
x509_extensions | string | x509_extensions | Selecciona qué extensiones debería usarse cuando se crea un certificado x509
req_extensions | string | req_extensions | Selecciona qué extensiones debería usarse cuando se crea una CSR
private_key_bits | integer | default_bits | Specifica cuántos bits deberían usarse para generar una clave privada
private_key_type | integer | ninguno | Especifica el tipo de clave privada a crear. Ésta puede ser OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH o OPENSSL_KEYTYPE_RSA. El valor por defecto es OPENSSL_KEYTYPE_RSA el cuál es el úncio tipo de clave soportado actualmente.
encrypt_key | boolean | encrypt_key | ¿Debería ser encriptada una clave exportada (con frase de contraseña)?
encrypt_key_cipher | integer | none | Una de las constantes de cipher.

extraattribs

extraattribs se usa para especificar opciones de configuración adicionales para la CSR. Ambos, dn y extraattribs, son matrices asociativas cuyas claves son convertidas a identificadores de objetos y aplicadas a las partes relevantes de la petición.

Valores devueltos

Devuelve la CSR.

Ejemplos

Ejemplo #1 Crear un certificado autofirmado

<?php
// Rellenar la información del nombre distinguido que se va a usar en el certificado
// Debe cambiar los valores de estas claves para que coincidan con su nombre y
// compañía, o para se más exactos, el nombre y la compañía de la persona/sitio
// para el que va a generar el certificado.
// Para los certificados SSL, el nombre común (commonName) normalmente es el nombre de
// dominio que va a usar el certificado, pero para certificados S/MIME,
// el nombre común será el nombre de la persona que usará el
// certificado.
$dn = array(
    "countryName" => "UK",
    "stateOrProvinceName" => "Somerset",
    "localityName" => "Glastonbury",
    "organizationName" => "The Brain Room Limited",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com"
);

// Generar una nueva pareja de clave privada (y pública)
$privkey = openssl_pkey_new();

// Generar una petición de firma de certificado
$csr = openssl_csr_new($dn, $privkey);

// Normalmente querrá crear un certificado autofirmado en este
// punto hasta que su AC satisfaga su petición.
// Esto crea un certificado autofirmado que es válido por 365 días
$sscert = openssl_csr_sign($csr, null, $privkey, 365);

// Ahora querrá preservar su clave privada, CSR y certificado
// autofirmado por lo que pueden ser instalados en su servidor web, servidor de correo
// o cliente de correo (dependiendo del uso previsto para el certificado).
// Este ejemplo muestra cómo obtener estas cosas con variables, pero
// también puede almacenarlas directamente en archivos.
// Normalmente, enviará la CSR a su AC, la cuál se la emitirá después
// con el certificado "real".
openssl_csr_export($csr, $csrout) and var_dump($csrout);
openssl_x509_export($sscert, $certout) and var_dump($certout);
openssl_pkey_export($privkey, $pkeyout, "mypassword") and var_dump($pkeyout);

// Mostrar cualquier error que ocurra
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>


Firmar una CSR con otro certificado (o autofirmar) y generar un certificado

  • « openssl_csr_new
  • openssl_decrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Firmar una CSR con otro certificado (o autofirmar) y generar un certificado

openssl_csr_sign

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_sign — Firmar una CSR con otro certificado (o autofirmar) y generar un certificado

Descripción

openssl_csr_sign ( mixed $csr , mixed $cacert , mixed $priv_key , int $days , array $configargs = ? , int $serial = 0 ) : resource

openssl_csr_sign() genera un recurso de certificado x509 desde la CSR dada.

Nota: Necesita tener instalado un openssl.cnf válido para que esta función opere correctamente. Vea las notas sobre la sección de instalación para más información.

Parámetros

csr

Una CSR previamente generada por openssl_csr_new(). También puede ser la ruta de una CSR codificada con PEM cuando se especifica con file://ruta/a/csr o una cadena exportada generada por openssl_csr_export().

cacert

El certificado generado será firmado por cacert. Si cacert es null, el certificado generado será un certificado autofirmado.

priv_key

priv_key es la clave privada que se corresponde con cacert.

days

days especifica la duración durante la cuál el certificado generado será válido, en días.

configargs

Se puede ajustar la firma de la CSR mediante configargs. Véase openssl_csr_new() para más información acerca de configargs.

serial

El número de serie opcional del certificado emitido. Si no se especifica será 0 por defecto.

Valores devueltos

Devuelve un recurso de certificado x509 si se tuvo éxito, false si falló.

Ejemplos

Ejemplo #1 Ejemplo de openssl_csr_sign() - firmar una CSR (cómo implementar su propia AC)

<?php
// Asumimos que este script está establecido para recivir una CSR que ha
// sido pegada al área de texto desde otra página
$csrdata = $_POST["CSR"];

// Firmaremos la petición usando nuestro propio certificado de "autoridad
// certificadora". También puede usar cualquier certificado para firmar otro, pero
// el proceso no vale de nada a menos que el certificado de firma sea acreditado
// por el software/usuarios que tratarán con el certificado recién firmado

// Necesitamos nuestro certificado de AC y su clave privada
$cacert = "file://ruta/a/ca.crt";
$privkey = array("file://ruta/a/ca.key", "su_frase_de_contraseña");

$usercert = openssl_csr_sign($csrdata, $cacert, $privkey, 365, array('digest_alg'=>'sha256') );

// Ahora mostramos el certificado generado por lo que el ususario puede
// copiarlo y pegarlo a su configuración local (tal como un archivo
// para guardar el certificado para su servidor SSL)
openssl_x509_export($usercert, $certout);
echo $certout;

// Mostrar cualquier error que ocurra
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>


Desencripta datos

  • « openssl_csr_sign
  • openssl_dh_compute_key »
  • PHP Manual
  • Funciones de OpenSSL
  • Desencripta datos

openssl_decrypt

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_decrypt — Desencripta datos

Descripción

openssl_decrypt ( string $data , string $method , string $password , int $options = 0 , string $iv = "" ) : string

Toma una cadena codificada en bruto o mediante base64 y la desencripta usando un método y una clave.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

Los datos.

method

El método de cifrado.

password

La contraseña.

options

options puede ser una de las constantes OPENSSL_RAW_DATA, OPENSSL_ZERO_PADDING.

iv

Un Vector de Inicialización no NULL.

Valores devueltos

La cadena desencriptada si se tuvo éxito o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING si se pasa un algoritmo de cifrado desconocido mediante el parámetro method.

Emite un error de nivel E_WARNING si se le pasa un valor vacío mediante en parámetro iv.

Historial de cambios

Versión | Descripción
5.3.3 | Se añadió el parámetro iv.
5.4.0 | raw_output se cambió a options.

Ver también

  • openssl_encrypt() - Cifra datos


Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local

  • « openssl_decrypt
  • openssl_digest »
  • PHP Manual
  • Funciones de OpenSSL
  • Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local

openssl_dh_compute_key

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_dh_compute_key — Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local

Descripción

openssl_dh_compute_key ( string $pub_key , resource $dh_key ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

pub_key

Clave pública

dh_key

Clave DH

Valores devueltos

Devuelve la clave computada si se tuvo éxito o false en caso de error.


Computa un método de resumen

  • « openssl_dh_compute_key
  • openssl_encrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Computa un método de resumen

openssl_digest

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_digest — Computa un método de resumen

Descripción

openssl_digest ( string $data , string $method , bool $raw_output = false ) : string

Computa un valor hash del método de resumen (digest) para la información dada usando el método dado, y devuelve una cadena codificada en bruto o mediante binhex.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

La información.

method

El método de resumen.

raw_output

Establecido a true devolverá información de salida en bruto, si no, devolverá el valor codificado mediante binhex.

Valores devueltos

Devuelve el valor hash del método de resumen si se tuvo éxito o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING si se pasa un algoritmo de cifrado desconocido mediante el parámetro method.

Ver también

  • openssl_get_md_methods() - Obtener los métodos de resumen disponibles


Cifra datos

  • « openssl_digest
  • openssl_error_string »
  • PHP Manual
  • Funciones de OpenSSL
  • Cifra datos

openssl_encrypt

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_encrypt — Cifra datos

Descripción

openssl_encrypt ( string $data , string $method , string $password , int $options = 0 , string $iv = "" ) : string

Cifra la información dada con el método y la clave dados, y devuelve una cadena codificada en bruto o mediante base64.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

Los datos.

method

El método de cifrado. Para una lista de los métodos de cifrado disponible, use openssl_get_cipher_methods().

password

La contraseña.

options

options puede ser una de las constantes OPENSSL_RAW_DATA, OPENSSL_ZERO_PADDING.

iv

Un Vector de Inicialización no NULL.

Valores devueltos

Devuelve la cadena cifrada si se tuvo éxito o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING si se pasa un algoritmo de cifrado desconocido mediante el parámetro method.

Emite un error de nivel E_WARNING si se le pasa un valor vacío mediante el parámetro iv.

Historial de cambios

Versión | Descripción
5.3.3 | Se añadió el parámetro iv.
5.4.0 | raw_output se cambió a options.

Ver también

  • openssl_decrypt() - Desencripta datos


Devolver un mensaje de error openSSL

  • « openssl_encrypt
  • openssl_free_key »
  • PHP Manual
  • Funciones de OpenSSL
  • Devolver un mensaje de error openSSL

openssl_error_string

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_error_string — Devolver un mensaje de error openSSL

Descripción

openssl_error_string ( ) : string

openssl_error_string() devuelve el último error de la biblioteca openSSL. Los mensajes de error se ponen en cola, por lo que esta función debería ser llamada múltiples veces para reunir toda la información. El último error será la más reciente.

Valores devueltos

Devuelve una cadena de mensaje de error, o false si no hay más mensajes de error a devolver.

Ejemplos

Ejemplo #1 Ejemplo de openssl_error_string()

<?php
// asumimos que se llamó a una función openssl que falló
while ($msg = openssl_error_string())
    echo $msg . "<br />\n";
?>


Liberar el recurso de clave

  • « openssl_error_string
  • openssl_get_cert_locations »
  • PHP Manual
  • Funciones de OpenSSL
  • Liberar el recurso de clave

openssl_free_key

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_free_key — Liberar el recurso de clave

Descripción

openssl_free_key ( resource $key_identifier ) : void

openssl_free_key() libera la clave asociada con el indetificador de clave key_identifier especificado de la memoria.

Parámetros

key_identifier

Valores devueltos

No devuelve ningún valor.


Obtener las ubicaciones de certificados disponibles

  • « openssl_free_key
  • openssl_get_cipher_methods »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtener las ubicaciones de certificados disponibles

openssl_get_cert_locations

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_get_cert_locations — Obtener las ubicaciones de certificados disponibles

Descripción

openssl_get_cert_locations ( ) : array

openssl_get_cert_locations() devuelve un array con información sobre la ubicaciones de certificados disponibles donde buscar certificados SSL.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con las ubicaciones de certificados disponibles.

Ejemplos

Ejemplo #1 Ejemplo de openssl_get_cert_locations()

<?php
var_dump(openssl_get_cert_locations());
?>

El resultado del ejemplo sería:

array(8) {
  ["default_cert_file"]=>
  string(21) "/usr/lib/ssl/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/usr/lib/ssl/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/usr/lib/ssl/private"
  ["default_default_cert_area"]=>
  string(12) "/usr/lib/ssl"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}


Obtiene los métodos de cifrado disponibles

  • « openssl_get_cert_locations
  • openssl_get_curve_names »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtiene los métodos de cifrado disponibles

openssl_get_cipher_methods

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_get_cipher_methods — Obtiene los métodos de cifrado disponibles

Descripción

openssl_get_cipher_methods ( bool $aliases = false ) : array

Obtiene una lista de los métodos de cifrado disponibles.

Parámetros

aliases

Establecer a true si los alias de los métodos de cifrado se deberían incluir en el array devuelto.

Valores devueltos

Un array de los métodos de cifrado disponibles.

Ejemplos

Ejemplo #1 Ejemplo de openssl_get_cipher_methods()

Muestra qué pinta tienen los métodos de cifrado disponibles, y también qué alias podrían estar disponibles.

<?php
$cifrados         = openssl_get_cipher_methods();
$cifrados_y_alias = openssl_get_cipher_methods(true);
$alias_cifrados   = array_diff($cifrados_y_alias, $cifrados);

print_r($cifrados);

print_r($alias_cifrados);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => AES-128-CBC
    [1] => AES-128-CFB
    [2] => AES-128-CFB1
    [3] => AES-128-CFB8
    [4] => AES-128-ECB
    [5] => AES-128-OFB
    [6] => AES-192-CBC
    [7] => AES-192-CFB
    [8] => AES-192-CFB1
    [9] => AES-192-CFB8
    [10] => AES-192-ECB
    [11] => AES-192-OFB
    [12] => AES-256-CBC
    [13] => AES-256-CFB
    [14] => AES-256-CFB1
    [15] => AES-256-CFB8
    [16] => AES-256-ECB
    [17] => AES-256-OFB
    [18] => BF-CBC
    [19] => BF-CFB
    [20] => BF-ECB
    [21] => BF-OFB
    [22] => CAST5-CBC
    [23] => CAST5-CFB
    [24] => CAST5-ECB
    [25] => CAST5-OFB
    [26] => DES-CBC
    [27] => DES-CFB
    [28] => DES-CFB1
    [29] => DES-CFB8
    [30] => DES-ECB
    [31] => DES-EDE
    [32] => DES-EDE-CBC
    [33] => DES-EDE-CFB
    [34] => DES-EDE-OFB
    [35] => DES-EDE3
    [36] => DES-EDE3-CBC
    [37] => DES-EDE3-CFB
    [38] => DES-EDE3-OFB
    [39] => DES-OFB
    [40] => DESX-CBC
    [41] => IDEA-CBC
    [42] => IDEA-CFB
    [43] => IDEA-ECB
    [44] => IDEA-OFB
    [45] => RC2-40-CBC
    [46] => RC2-64-CBC
    [47] => RC2-CBC
    [48] => RC2-CFB
    [49] => RC2-ECB
    [50] => RC2-OFB
    [51] => RC4
    [52] => RC4-40
    [53] => aes-128-cbc
    [54] => aes-128-cfb
    [55] => aes-128-cfb1
    [56] => aes-128-cfb8
    [57] => aes-128-ecb
    [58] => aes-128-ofb
    [59] => aes-192-cbc
    [60] => aes-192-cfb
    [61] => aes-192-cfb1
    [62] => aes-192-cfb8
    [63] => aes-192-ecb
    [64] => aes-192-ofb
    [65] => aes-256-cbc
    [66] => aes-256-cfb
    [67] => aes-256-cfb1
    [68] => aes-256-cfb8
    [69] => aes-256-ecb
    [70] => aes-256-ofb
    [71] => bf-cbc
    [72] => bf-cfb
    [73] => bf-ecb
    [74] => bf-ofb
    [75] => cast5-cbc
    [76] => cast5-cfb
    [77] => cast5-ecb
    [78] => cast5-ofb
    [79] => des-cbc
    [80] => des-cfb
    [81] => des-cfb1
    [82] => des-cfb8
    [83] => des-ecb
    [84] => des-ede
    [85] => des-ede-cbc
    [86] => des-ede-cfb
    [87] => des-ede-ofb
    [88] => des-ede3
    [89] => des-ede3-cbc
    [90] => des-ede3-cfb
    [91] => des-ede3-ofb
    [92] => des-ofb
    [93] => desx-cbc
    [94] => idea-cbc
    [95] => idea-cfb
    [96] => idea-ecb
    [97] => idea-ofb
    [98] => rc2-40-cbc
    [99] => rc2-64-cbc
    [100] => rc2-cbc
    [101] => rc2-cfb
    [102] => rc2-ecb
    [103] => rc2-ofb
    [104] => rc4
    [105] => rc4-40
)
Array
(
    [18] => AES128
    [19] => AES192
    [20] => AES256
    [21] => BF
    [26] => CAST
    [27] => CAST-cbc
    [32] => DES
    [47] => DES3
    [48] => DESX
    [50] => IDEA
    [55] => RC2
    [82] => aes128
    [83] => aes192
    [84] => aes256
    [85] => bf
    [90] => blowfish
    [91] => cast
    [92] => cast-cbc
    [97] => des
    [112] => des3
    [113] => desx
    [115] => idea
    [120] => rc2
)

Ver también

  • openssl_get_md_methods() - Obtener los métodos de resumen disponibles


Gets list of available curve names for ECC

  • « openssl_get_cipher_methods
  • openssl_get_md_methods »
  • PHP Manual
  • Funciones de OpenSSL
  • Gets list of available curve names for ECC

openssl_get_curve_names

(PHP 7 >= 7.1.0, PHP 8)

openssl_get_curve_names — Gets list of available curve names for ECC

Descripción

openssl_get_curve_names ( ) : array|false

Gets the list of available curve names for use in Elliptic curve cryptography (ECC) for public/private key operations. The two most widely standardized/supported curves are prime256v1 (NIST P-256) and secp384r1 (NIST P-384).

Approximate Equivalancies of AES, RSA, DSA and ECC Keysizes
AES Symmetric Keysize (Bits) | RSA and DSA Keysize (Bits) | ECC Keysize (Bits)
80 | 1024 | 160
112 | 2048 | 224
128 | 3072 | 256
192 | 7680 | 384
256 | 15360 | 512
» NIST recommends using ECC curves with at least 256 bits.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array of available curve names, o false en caso de error.

Ejemplos

Ejemplo #1 openssl_get_curve_names() example

<?php
$curve_names = openssl_get_curve_names();
print_r($curve_names);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => secp112r1
    [1] => secp112r2
    [2] => secp128r1
    [3] => secp128r2
    [4] => secp160k1
    [5] => secp160r1
    [6] => secp160r2
    [7] => secp192k1
    [8] => secp224k1
    [9] => secp224r1
    [10] => secp256k1
    [11] => secp384r1
    [12] => secp521r1
    [13] => prime192v1
    [14] => prime192v2
    [15] => prime192v3
    [16] => prime239v1
    [17] => prime239v2
    [18] => prime239v3
    [19] => prime256v1
    [20] => sect113r1
    [21] => sect113r2
    [22] => sect131r1
    [23] => sect131r2
    [24] => sect163k1
    [25] => sect163r1
    [26] => sect163r2
    [27] => sect193r1
    [28] => sect193r2
    [29] => sect233k1
    [30] => sect233r1
    [31] => sect239k1
    [32] => sect283k1
    [33] => sect283r1
    [34] => sect409k1
    [35] => sect409r1
    [36] => sect571k1
    [37] => sect571r1
    [38] => c2pnb163v1
    [39] => c2pnb163v2
    [40] => c2pnb163v3
    [41] => c2pnb176v1
    [42] => c2tnb191v1
    [43] => c2tnb191v2
    [44] => c2tnb191v3
    [45] => c2pnb208w1
    [46] => c2tnb239v1
    [47] => c2tnb239v2
    [48] => c2tnb239v3
    [49] => c2pnb272w1
    [50] => c2pnb304w1
    [51] => c2tnb359v1
    [52] => c2pnb368w1
    [53] => c2tnb431r1
    [54] => wap-wsg-idm-ecid-wtls1
    [55] => wap-wsg-idm-ecid-wtls3
    [56] => wap-wsg-idm-ecid-wtls4
    [57] => wap-wsg-idm-ecid-wtls5
    [58] => wap-wsg-idm-ecid-wtls6
    [59] => wap-wsg-idm-ecid-wtls7
    [60] => wap-wsg-idm-ecid-wtls8
    [61] => wap-wsg-idm-ecid-wtls9
    [62] => wap-wsg-idm-ecid-wtls10
    [63] => wap-wsg-idm-ecid-wtls11
    [64] => wap-wsg-idm-ecid-wtls12
    [65] => Oakley-EC2N-3
    [66] => Oakley-EC2N-4
    [67] => brainpoolP160r1
    [68] => brainpoolP160t1
    [69] => brainpoolP192r1
    [70] => brainpoolP192t1
    [71] => brainpoolP224r1
    [72] => brainpoolP224t1
    [73] => brainpoolP256r1
    [74] => brainpoolP256t1
    [75] => brainpoolP320r1
    [76] => brainpoolP320t1
    [77] => brainpoolP384r1
    [78] => brainpoolP384t1
    [79] => brainpoolP512r1
    [80] => brainpoolP512t1
)


Obtener los métodos de resumen disponibles

  • « openssl_get_curve_names
  • openssl_get_privatekey »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtener los métodos de resumen disponibles

openssl_get_md_methods

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_get_md_methods — Obtener los métodos de resumen disponibles

Descripción

openssl_get_md_methods ( bool $aliases = false ) : array

Obtiene una lista de los métodos de resumen disponibles.

Parámetros

aliases

Establecer a true si los alias del método de resumen deberían incluirse dentro del array devuelto.

Valores devueltos

Un array de los métodos de resumen disponibles.

Ejemplos

Ejemplo #1 Ejemplo de openssl_get_md_methods()

Muestra qué pinta tienen los métodos de resumen disponibles, y también qué alias podrían estar disponibles.

<?php
$métodos         = openssl_get_md_methods();
$métodos_y_alias = openssl_get_md_methods(true);
$alias_métodos   = array_diff($métodos_y_alias, $métodos);

print_r($métodos);

print_r($alias_métodos);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => DSA
    [1] => DSA-SHA
    [2] => MD2
    [3] => MD4
    [4] => MD5
    [5] => RIPEMD160
    [6] => SHA
    [7] => SHA1
    [8] => SHA224
    [9] => SHA256
    [10] => SHA384
    [11] => SHA512
    [12] => dsaEncryption
    [13] => dsaWithSHA
    [14] => ecdsa-with-SHA1
    [15] => md2
    [16] => md4
    [17] => md5
    [18] => ripemd160
    [19] => sha
    [20] => sha1
    [21] => sha224
    [22] => sha256
    [23] => sha384
    [24] => sha512
)
Array
(
    [2] => DSA-SHA1
    [3] => DSA-SHA1-old
    [4] => DSS1
    [9] => RSA-MD2
    [10] => RSA-MD4
    [11] => RSA-MD5
    [12] => RSA-RIPEMD160
    [13] => RSA-SHA
    [14] => RSA-SHA1
    [15] => RSA-SHA1-2
    [16] => RSA-SHA224
    [17] => RSA-SHA256
    [18] => RSA-SHA384
    [19] => RSA-SHA512
    [28] => dsaWithSHA1
    [29] => dss1
    [32] => md2WithRSAEncryption
    [34] => md4WithRSAEncryption
    [36] => md5WithRSAEncryption
    [37] => ripemd
    [39] => ripemd160WithRSA
    [40] => rmd160
    [43] => sha1WithRSAEncryption
    [45] => sha224WithRSAEncryption
    [47] => sha256WithRSAEncryption
    [49] => sha384WithRSAEncryption
    [51] => sha512WithRSAEncryption
    [52] => shaWithRSAEncryption
    [53] => ssl2-md5
    [54] => ssl3-md5
    [55] => ssl3-sha1
)

Ver también

  • openssl_digest() - Computa un método de resumen
  • openssl_get_cipher_methods() - Obtiene los métodos de cifrado disponibles


Alias de openssl_pkey_get_private

  • « openssl_get_md_methods
  • openssl_get_publickey »
  • PHP Manual
  • Funciones de OpenSSL
  • Alias de openssl_pkey_get_private

openssl_get_privatekey

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_get_privatekey — Alias de openssl_pkey_get_private()

Descripción

Esta función es un alias de: openssl_pkey_get_private().


Alias de openssl_pkey_get_public

  • « openssl_get_privatekey
  • openssl_open »
  • PHP Manual
  • Funciones de OpenSSL
  • Alias de openssl_pkey_get_public

openssl_get_publickey

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_get_publickey — Alias de openssl_pkey_get_public()

Descripción

Esta función es un alias de: openssl_pkey_get_public().


Abre información sellada

  • « openssl_get_publickey
  • openssl_pbkdf2 »
  • PHP Manual
  • Funciones de OpenSSL
  • Abre información sellada

openssl_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_open — Abre información sellada

Descripción

openssl_open ( string $sealed_data , string &$open_data , string $env_key , mixed $priv_key_id , string $method = ? ) : bool

openssl_open() abre (desencripta) sealed_data usando la clave privada asociada con el indentificador de clave priv_key_id y la clave de sobre env_key, y rellena open_data con la información desencriptada. La clave de sobre es generada cuando la información es sellada y sólo puede usarse por una clave privada específica. Véase openssl_seal() para más información.

Parámetros

sealed_data

open_data

Si la llamada tiene éxtio la información abierta es devuelta en este parámetro.

env_key

priv_key_id

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_open()

<?php
// se asume que $sealed y $env_key contienen la información sellada
// y nuestra clave de sobre, ambas entregadas a nosotros por el sellador.

// traer la clave privada del archivo y prepararla
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// desencriptar la información y guardarla en $open
if (openssl_open($sealed, $open, $env_key, $pkeyid)) {
    echo "aquí está la información abierta: ", $open;
} else {
    echo "fallo al abrir la información";
}

// liberar la clave privada de la memoria
openssl_free_key($pkeyid);
?>

Ver también

  • openssl_seal() - Sellar (encriptar) información


Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1

  • « openssl_open
  • openssl_pkcs12_export_to_file »
  • PHP Manual
  • Funciones de OpenSSL
  • Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1

openssl_pbkdf2

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

openssl_pbkdf2 — Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1

Descripción

openssl_pbkdf2 ( string $password , string $salt , int $key_length , int $iterations , string $digest_algorithm = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

password

salt

key_length

iterations

digest_algorithm

Valores devueltos

Devuelve un string o false en caso de error.


Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12

  • « openssl_pbkdf2
  • openssl_pkcs12_export »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12

openssl_pkcs12_export_to_file

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_export_to_file — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12

Descripción

openssl_pkcs12_export_to_file ( mixed $x509 , string $filename , mixed $priv_key , string $pass , array $args = ? ) : bool

openssl_pkcs12_export_to_file() guarda x509 en un archivo nombrado por filename en un formato de archivo PKCS#12.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

filename

Ruta del archivo de salida.

priv_key

El componente clave privada del archivo PKCS#12.

pass

Contraseña de encriptación para desbloquear el archivo PKCS#12.

args

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable

  • « openssl_pkcs12_export_to_file
  • openssl_pkcs12_read »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable

openssl_pkcs12_export

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_export — Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable

Descripción

openssl_pkcs12_export ( mixed $x509 , string &$out , mixed $priv_key , string $pass , array $args = ? ) : bool

openssl_pkcs12_export() guarda x509 en una cadena nombrada por out en un formato de archivo PKCS#12.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

out

Si se tiene éxito, ésto contendrá el PKCS#12.

priv_key

El componente clave privada del archivo PKCS#12.

pass

Contraseña de encriptación para desbloquear el archivo PKCS#12.

args

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Convierte un Almacén de Certificado PKCS#12 a una matriz

  • « openssl_pkcs12_export
  • openssl_pkcs7_decrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Convierte un Almacén de Certificado PKCS#12 a una matriz

openssl_pkcs12_read

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_read — Convierte un Almacén de Certificado PKCS#12 a una matriz

Descripción

openssl_pkcs12_read ( string $pkcs12 , array &$certs , string $pass ) : bool

openssl_pkcs12_read() convierte el almacén de certificado PKCS#12 proporcionado por pkcs12 a una matriz nombrada por certs.

Parámetros

pkcs12

El contenido del almacén de certificados, no su nombre de fichero.

certs

Si se tiene éxito, ésto contentrá la Información del Almacén de Certificado.

pass

Contraseña de encriptación para desbloquear el archivo PKCS#12.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_pkcs12_read()

<?php
if (!$almacén_cert = file_get_contents("/certs/file.p12")) {
    echo "Error: No se puede leer el fichero del certificado\n";
    exit;
}

if (openssl_pkcs12_read($almacén_cert, $info_cert, "mi_clave_secreta")) {
    echo "Información del certificado\n";
    print_r($info_cert);
} else {
    echo "Error: No se puede leer el almacén de certificados.\n";
    exit;
}
?>


Desencripta un mensaje S/MIME encriptado

  • « openssl_pkcs12_read
  • openssl_pkcs7_encrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Desencripta un mensaje S/MIME encriptado

openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_decrypt — Desencripta un mensaje S/MIME encriptado

Descripción

openssl_pkcs7_decrypt ( string $infilename , string $outfilename , mixed $recipcert , mixed $recipkey = ? ) : bool

Desencripta el mensaje S/MIME encriptado que contiene el archivo especificado por infilename usando el certificado y su clave privada asociada, especificados por recipcert y recipkey.

Parámetros

infilename

outfilename

El mensaje desencriptado está escrito en el archivo especificado por outfilename.

recipcert

recipkey

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_pkcs7_decrypt()

<?php
// se asume que $cert y $clave contienen su par certificado personal y clave
// privada, y que usted es el destinatario de un mensaje S/MIME
$infilename = "encriptado.msg";  // este archivo contiene su mensaje encriptado
$outfilename = "desencriptado.msg"; // asegúrese de que puede escribir en este archivo

if (openssl_pkcs7_decrypt($infilename, $outfilename, $cert, $clave)) {
    echo "¡desencriptado!";
} else {
    echo "¡fallo al desencriptar!";
}
?>


Encriptar un mensaje S/MIME

  • « openssl_pkcs7_decrypt
  • openssl_pkcs7_read »
  • PHP Manual
  • Funciones de OpenSSL
  • Encriptar un mensaje S/MIME

openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_encrypt — Encriptar un mensaje S/MIME

Descripción

openssl_pkcs7_encrypt ( string $infile , string $outfile , mixed $recipcerts , array $headers , int $flags = 0 , int $cipherid = OPENSSL_CIPHER_RC2_40 ) : bool

openssl_pkcs7_encrypt() toma el contenido del archivo nombrado por infile y lo encripta usando un cifrado RC2 de 40 bits por lo que sólo lo podrá leer los destinatarios previstos especificados por recipcerts.

Parámetros

infile

outfile

recipcerts

Un único certificado X.509, o una matriz de certificados X.509.

headers

headers es una matriz de cabeceras que serán añadidas delante de la información después de que haya sido encriptada.

headers puede ser una matriz asociativa con las claves como el nombre de la cabecera, o una matriz indexada, donde cada elemento contiene una sola línea de cabecera.

flags

flags se puede usar para especificar las opciones que afectan al proceso de codificación - véase constantes PKCS7.

cipherid

Una de las constants de cipher.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_pkcs7_encrypt()

<?php
// el mensaje que quiere encriptar y enviar a su agente secreto
// en el campo, conocido como nighthawk. Tiene su certificado
// en el archivo nighthawk.pem
$data = <<<EOD
Nighthawk,

Alto secreto, ¡Confidencial!

¡El enemigo nos está rodeando! ¡Encuéntrese conmigo en el café a las 8.30am
para obtener su pasaporte falso!

C.G.
EOD;

// cargar la clave
$clave = file_get_contents("nighthawk.pem");

// guardar el mensaje en un archivo
$fp = fopen("mensaje.txt", "w");
fwrite($fp, $data);
fclose($fp);

// encriptarlo
if (openssl_pkcs7_encrypt("mensaje.txt", "enc.txt", $clave,
    array("Para" => "nighthawk@example.com", // sintaxis asociativa
          "De: C.G. <cg@example.com>", // sintaxis indexada
          "Tema" => "Confidencial"))) {
    // mensaje firmado - ¡envíelo!
    exec(ini_get("ruta_correo") . " < enc.txt");
}
?>


Export the PKCS7 file to an array of PEM certificates

  • « openssl_pkcs7_encrypt
  • openssl_pkcs7_sign »
  • PHP Manual
  • Funciones de OpenSSL
  • Export the PKCS7 file to an array of PEM certificates

openssl_pkcs7_read

(PHP 7 >= 7.2.0, PHP 8)

openssl_pkcs7_read — Export the PKCS7 file to an array of PEM certificates

Descripción

openssl_pkcs7_read ( string $input_filename , array &$certificates ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

input_filename

certificates

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Firma un mensaje S/MIME

  • « openssl_pkcs7_read
  • openssl_pkcs7_verify »
  • PHP Manual
  • Funciones de OpenSSL
  • Firma un mensaje S/MIME

openssl_pkcs7_sign

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_sign — Firma un mensaje S/MIME

Descripción

openssl_pkcs7_sign ( string $infilename , string $outfilename , mixed $signcert , mixed $privkey , array $headers , int $flags = PKCS7_DETACHED , string $extracerts = ? ) : bool

openssl_pkcs7_sign() toma el contenido del archivo nombrado por infilename y lo firma usando el certificado y su clave privada coincidente especificados por los parámetros signcert y privkey.

Parámetros

infilename

outfilename

signcert

privkey

headers

headers es una matriz de cabeceras que serán añadidas delante de la información después de que se haya firmado (véase openssl_pkcs7_encrypt() para más información acerca del formato de este parámetro).

flags

flags se puede usar para alterar la salida - véase constantes PKCS7.

extracerts

extracerts especifica el nombre de un archivo que contiene un grupo de certificados extra, para incluir en la firma, que puede ser usado para, por ejemplo, ayudar al destinatario a verificar el certificado que se usó.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_pkcs7_sign()

<?php
// el mensaje que quiere firmar, por lo que el destinatario puede estar serguro de fue usted
// el que lo envió
$data = <<<EOD

Tiene mi autorización para emplear $10,000 en gastos de comida.

El Presidente
EOD;
// guardar el mensaje en un archivo
$fp = fopen("mensaje.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encriptarlo
if (openssl_pkcs7_sign("mensaje.txt", "firmado.txt", "micert.pem",
    array("file://micert.pem", "mi_frase_de_contraseña"),
    array("Para" => "joes@example.com", // sintaxis asociativa
          "DE: C.G. <presidente@example.com>", // sintaxis indexada
          "Tema" => "Confidencial")
    )) {
    // mensaje firmado - ¡envíelo!
    exec(ini_get("ruta_correo") . " < firmado.txt");
}
?>


Verifica la firma de un mensaje S/MIME firmado

  • « openssl_pkcs7_sign
  • openssl_pkey_derive »
  • PHP Manual
  • Funciones de OpenSSL
  • Verifica la firma de un mensaje S/MIME firmado

openssl_pkcs7_verify

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_verify — Verifica la firma de un mensaje S/MIME firmado

Descripción

openssl_pkcs7_verify ( string $filename , int $flags , string $outfilename = ? , array $cainfo = ? , string $extracerts = ? , string $content = ? ) : mixed

openssl_pkcs7_verify() lee el mensaje S/MIME contenido en el archivo dado y examina la firma digital.

Parámetros

filename

Ruta del mensaje.

flags

flags se puede usar para indicar cómo se verifica la firma - véase constantes PKCS7 para más información.

outfilename

Si se especifica outfilename, debería se una cadena que contiene el nombre de un archivo en el que los certificados de las personas que firmaron los mensajes serán guardados en formato PEM.

cainfo

Si se especifica cainfo, debería contener información sobre los certificados de la AC de confianza para usarla en el proceso de verificación - véase verificación de certificados para más información acerca de este parámetro.

extracerts

Si se especifica extracerts, éste es el nombre de archivo de un archivo que contiene un grupo de certificados que se van a usar como AC que no sea de confianza.

content

Se puede especificar un nombre de archivo con content, que será rellenado con la información verificada, pero con la información de la firma eliminada.

Valores devueltos

Devuelve true si la firma es verificada, false si no es correcta (el mensaje ha sido interferido, o el certificado de firma no es válido), o -1 si se produjo un error.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro content.

Notas

Nota: Como está especificado en RFC 2045, la líneas no pueden ser más largas de 76 caracteres en el parámetro filename.


Computes shared secret for public value of remote and local DH or ECDH key

  • « openssl_pkcs7_verify
  • openssl_pkey_export_to_file »
  • PHP Manual
  • Funciones de OpenSSL
  • Computes shared secret for public value of remote and local DH or ECDH key

openssl_pkey_derive

(PHP 7 >= 7.3.0, PHP 8)

openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key

Descripción

openssl_pkey_derive ( OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $public_key , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $private_key , int $key_length = 0 ) : string|false

openssl_pkey_derive() takes a set of a public_key and private_key and derives a shared secret, for either DH or EC keys.

Parámetros

public_key

public_key is the public key for the derivation. See Public/Private Key parameters for a list of valid values.

private_key

private_key is the private key for the derivation. See Public/Private Key parameters for a list of valid values.

key_length

If not zero, will set the desired length of the derived secret.

Valores devueltos

The derived secret on success o false en caso de error.

Ejemplos

Ejemplo #1 openssl_pkey_derive() example

<?php
// Load in private key
$priv = openssl_pkey_get_private("-----BEGIN PRIVATE KEY-----
MIICJgIBADCCARcGCSqGSIb3DQEDATCCAQgCggEBAJLxRCaZ933uW+AXmabHFDDy
upojBIRlbmQLJZfigDaSA1f9YOTsIv+WwVFTX/J1mtCyx9uBcz0Nt2kmVwxWuc2f
VtCEMPsmLsVXX7xRUFLpyX1Y1IYGBVXQOoOvLWYQjpZgnx47Pkh1Ok1+smffztfC
0DCNt4KorWrbsPcmqBejXHN79KvWFjZmXOksRiNu/Bn76RiqvofC4z8Ri3kHXQG2
197JGZzzFXHadGC3xbkg8UxsNbYhVMKbm0iANfafUH7/hoS9UjAVQYtvwe7YNiW/
HnyfVCrKwcc7sadd8Iphh+3lf5P1AhaQEAMytanrzq9RDXKBxuvpSJifRYasZYsC
AQIEggEEAoIBAGwAYC2E81Y1U2Aox0U7u1+vBcbht/OO87tutMvc4NTLf6NLPHsW
cPqBixs+3rSn4fADzAIvdLBmogjtiIZoB6qyHrllF/2xwTVGEeYaZIupQH3bMK2b
6eUvnpuu4Ytksiz6VpXBBRMrIsj3frM+zUtnq8vKUr+TbjV2qyKR8l3eNDwzqz30
dlbKh9kIhZafclHfRVfyp+fVSKPfgrRAcLUgAbsVjOjPeJ90xQ4DTMZ6vjiv6tHM
hkSjJIcGhRtSBzVF/cT38GyCeTmiIA/dRz2d70lWrqDQCdp9ArijgnpjNKAAulSY
CirnMsGZTDGmLOHg4xOZ5FEAzZI2sFNLlcw=
-----END PRIVATE KEY-----
");

// Load in public key
$pub = openssl_pkey_get_public("-----BEGIN PUBLIC KEY-----
MIICJDCCARcGCSqGSIb3DQEDATCCAQgCggEBAJLxRCaZ933uW+AXmabHFDDyupoj
BIRlbmQLJZfigDaSA1f9YOTsIv+WwVFTX/J1mtCyx9uBcz0Nt2kmVwxWuc2fVtCE
MPsmLsVXX7xRUFLpyX1Y1IYGBVXQOoOvLWYQjpZgnx47Pkh1Ok1+smffztfC0DCN
t4KorWrbsPcmqBejXHN79KvWFjZmXOksRiNu/Bn76RiqvofC4z8Ri3kHXQG2197J
GZzzFXHadGC3xbkg8UxsNbYhVMKbm0iANfafUH7/hoS9UjAVQYtvwe7YNiW/Hnyf
VCrKwcc7sadd8Iphh+3lf5P1AhaQEAMytanrzq9RDXKBxuvpSJifRYasZYsCAQID
ggEFAAKCAQAiCSBpxvGgsTorxAWtcAlSmzAJnJxFgSPef0g7OjhESytnc8G2QYmx
ovMt5KVergcitztWh08hZQUdAYm4rI+zMlAFDdN8LWwBT/mGKSzRkWeprd8E7mvy
ucqC1YXCMqmIwPySvLQUB/Dl8kgau7BLAnIJm8VP+MVrn8g9gghD0qRCgPgtEaDV
vocfgnOU43rhKnIgO0cHOKtw2qybSFB8QuZrYugq4j8Bwkrzh6rdMMeyMl/ej5Aj
c0wamOzuBDtXt0T9+Fx3khHaowjCc7xJZRgZCxg43SbqMWJ9lUg94I7+LTX61Gyv
dtlkbGbtoDOnxeNnN93gwQZngGYZYciu
-----END PUBLIC KEY-----
");

// Outputs the hex version of the derived key
echo bin2hex(openssl_pkey_derive($pub,$priv));


Obtiene una representación de una clave exportable a un archivo

  • « openssl_pkey_derive
  • openssl_pkey_export »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtiene una representación de una clave exportable a un archivo

openssl_pkey_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_export_to_file — Obtiene una representación de una clave exportable a un archivo

Descripción

openssl_pkey_export_to_file ( mixed $key , string $outfilename , string $passphrase = ? , array $configargs = ? ) : bool

openssl_pkey_export_to_file() guarda una interpretación (codificada con PEM) ascii blindada de key en un archivo nombrado por outfilename.

Nota: Necesita tener instalado un openssl.cnf válido para que esta función opere correctamente. Vea las notas sobre la sección de instalación para más información.

Parámetros

key

outfilename

Ruta del archivo de salida.

passphrase

La clave se puede proteger opcionalmente con una passphrase.

configargs

configargs se puede usar para ajustar el proceso de exportación especificando y/o sobrescribiendo las opciones del archivo de configuración de openssl. Véase openssl_csr_new() para más información acerca de configargs.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtiene una representación de una clave exportable a una cadena

  • « openssl_pkey_export_to_file
  • openssl_pkey_free »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtiene una representación de una clave exportable a una cadena

openssl_pkey_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_export — Obtiene una representación de una clave exportable a una cadena

Descripción

openssl_pkey_export ( mixed $key , string &$out , string $passphrase = ? , array $configargs = ? ) : bool

openssl_pkey_export() exporta la clave key como una cadena PEM codificada y la almacena en out (que es pasado por referencia).

Nota: Necesita tener instalado un openssl.cnf válido para que esta función opere correctamente. Vea las notas sobre la sección de instalación para más información.

Parámetros

key

out

passphrase

La clave es protegida opcionalmente mediante passphrase.

configargs

configargs se puede usar para ajustar el proceso de exportación especificando y/o sobrescribiendo las opciones del archivo de configuración de openssl. Véase openssl_csr_new() para más información acerca de configargs.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Libera una clave privada

  • « openssl_pkey_export
  • openssl_pkey_get_details »
  • PHP Manual
  • Funciones de OpenSSL
  • Libera una clave privada

openssl_pkey_free

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_free — Libera una clave privada

Descripción

openssl_pkey_free ( resource $key ) : void

Esta función libera una clave privada creada por openssl_pkey_new().

Parámetros

key

Un recurso que contiene la clave.

Valores devueltos

No devuelve ningún valor.


Devuelve una matriz con los detalles de la clave

  • « openssl_pkey_free
  • openssl_pkey_get_private »
  • PHP Manual
  • Funciones de OpenSSL
  • Devuelve una matriz con los detalles de la clave

openssl_pkey_get_details

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_pkey_get_details — Devuelve una matriz con los detalles de la clave

Descripción

openssl_pkey_get_details ( resource $key ) : array

Esta función devuelve los detalles de la clave (bits, key, type).

Parámetros

key

Un recurso que contiene la clave.

Valores devueltos

Devuelve una matriz con los detalles de la clave si se tuvo éxito o false si falló. La matriz devuelta tiene indexados bits (número de bits), key (representación de cadena de la clave pública) y type (el tipo de la clave que es OPENSSL_KEYTYPE_RSA, OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_EC o -1 significa desconocido).

Dependiendo del tipo de clave usada, se pueden devolver detalles adicionales. Observe que algunos elementos pueden no estar disponibles.

  • OPENSSL_KEYTYPE_RSA, una clave adicional del array llamada "rsa", que contiene la información de la clave, es devuelta.
    Clave Descripción
    "n"
    "e"
    "d"
    "p"
    "q"
    "dmp1"
    "dmq1"
    "iqmp"
  • OPENSSL_KEYTYPE_DSA, una clave adicional del array llamada "dsa", que contiene la información de la clave, es devuelta.
    Clave Descripción
    "p"
    "q"
    "g"
    "priv_key"
    "pub_key"
  • OPENSSL_KEYTYPE_DH, una clave adicional del array llamada "dh", que contiene la información de la clave, es devuelta.
    Clave Descripción
    "p"
    "g"
    "priv_key"
    "pub_key"


Obtener una clave privada

  • « openssl_pkey_get_details
  • openssl_pkey_get_public »
  • PHP Manual
  • Funciones de OpenSSL
  • Obtener una clave privada

openssl_pkey_get_private

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_get_private — Obtener una clave privada

Descripción

openssl_pkey_get_private ( mixed $key , string $passphrase = "" ) : resource

openssl_get_privatekey() analiza la clave key y la prepara para usarla con otras funciones.

Parámetros

key

key puede ser una de las siguientes:

  1. una cadena con el formato file://ruta/al/archivo.pem. El archivo nombrado debe contener un certificado/clave privada PEM codificada (puede contener ambos).
  2. una clave privada con formato PEM.

passphrase

El parámetro opcional passphrase se debe usar si la clave especificada está encriptada (protegida por una frase de contraseña).

Valores devueltos

Devuelve un identificador de clave positivo si se tuvo éxito, o false si se produjo un error.


Extrae la clave pública del certificado y la prepara para usarla

  • « openssl_pkey_get_private
  • openssl_pkey_new »
  • PHP Manual
  • Funciones de OpenSSL
  • Extrae la clave pública del certificado y la prepara para usarla

openssl_pkey_get_public

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_get_public — Extrae la clave pública del certificado y la prepara para usarla

Descripción

openssl_pkey_get_public ( mixed $certificate ) : resource

openssl_get_publickey() extrae la clave pública de certificate y la prepara para usarla con otras funciones.

Parámetros

certificate

certificate puede ser lo siguiente:

  1. un recurso de certificado X.509
  2. un string con el formato file://ruta/al/archivo.pem. El archivo nombrado debe contener un certificado/clave público PEM codificado (podría contener ambos).
  3. una clave pública con formato PEM.

Valores devueltos

Devuelve un identificador de clave positivo si tuvo éxito, o false si se produjo un error.


Genera una clave privada nueva

  • « openssl_pkey_get_public
  • openssl_private_decrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Genera una clave privada nueva

openssl_pkey_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_new — Genera una clave privada nueva

Descripción

openssl_pkey_new ( array $configargs = ? ) : resource

openssl_pkey_new() genera un nuevo par clave privada y clave pública. El componente público de la clave se puede obtener usando openssl_pkey_get_public().

Nota: Necesita tener instalado un openssl.cnf válido para que esta función opere correctamente. Vea las notas sobre la sección de instalación para más información.

Parámetros

configargs

Se puede ajustar la generación de la clave (tal como especificando el número de bits) usando configargs. Véase openssl_csr_new() para más información acerca de configargs.

Valores devueltos

Devuelve un identificador de recurso para la clave privada si se tuvo éxito, o false si se produjo un error.


Desencripta información con la clave privada

  • « openssl_pkey_new
  • openssl_private_encrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Desencripta información con la clave privada

openssl_private_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_private_decrypt — Desencripta información con la clave privada

Descripción

openssl_private_decrypt ( string $data , string &$decrypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_private_decrypt() desncripta la información data la cuál fue previamente encriptada mediante openssl_public_encrypt() y almacena el resultado en decrypted.

Puede usar esta función para, por ejemplo, desencriptar información que es sólo para usted.

Parámetros

data

decrypted

key

key debe ser la clave privada correspondiente a la usada para encriptar la información.

padding

padding puede ser OPENSSL_PKCS1_PADDING, OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_public_encrypt() - Encripta información con una clave pública
  • openssl_public_decrypt() - Desencripta información con la clave pública


Encripta información con la clave privada

  • « openssl_private_decrypt
  • openssl_public_decrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Encripta información con la clave privada

openssl_private_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_private_encrypt — Encripta información con la clave privada

Descripción

openssl_private_encrypt ( string $data , string &$crypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_private_encrypt() encripta data con la clave privada key y almacena el resultado en crypted. La información encriptada se puede desencriptar mediante openssl_public_decrypt().

Esta función se puede usar para, p.ej., firmar información (o su hash) para demostrar que no está escrita por otro cualquiera.

Parámetros

data

crypted

key

padding

padding puede ser OPENSSL_PKCS1_PADDING, OPENSSL_NO_PADDING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_public_encrypt() - Encripta información con una clave pública
  • openssl_public_decrypt() - Desencripta información con la clave pública


Desencripta información con la clave pública

  • « openssl_private_encrypt
  • openssl_public_encrypt »
  • PHP Manual
  • Funciones de OpenSSL
  • Desencripta información con la clave pública

openssl_public_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_public_decrypt — Desencripta información con la clave pública

Descripción

openssl_public_decrypt ( string $data , string &$decrypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_public_decrypt() desencripta la información data que fue previamente encriptada mediante openssl_private_encrypt() y almacena el resultado en decrypted.

Se puede usar esta función para, p.ej., verificar si el mensaje fué escrito por el propietario de la clave privada.

Parámetros

data

decrypted

key

key debe ser la clave pública que se corresponde con la usada para encriptar la información.

padding

padding puede ser OPENSSL_PKCS1_PADDING, OPENSSL_NO_PADDING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_private_encrypt() - Encripta información con la clave privada
  • openssl_private_decrypt() - Desencripta información con la clave privada


Encripta información con una clave pública

  • « openssl_public_decrypt
  • openssl_random_pseudo_bytes »
  • PHP Manual
  • Funciones de OpenSSL
  • Encripta información con una clave pública

openssl_public_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_public_encrypt — Encripta información con una clave pública

Descripción

openssl_public_encrypt ( string $data , string &$crypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_public_encrypt() encripta data con la clave pública key y almacena el resultado en crypted. La información encriptada puede ser desencriptada mediante openssl_private_decrypt().

Esta función se puede usar para, p.ej., encriptar un mensaje que se pueda leer después sólo por el propietario de la clave privada. También se puede usar para almacenar información segura en una base de datos.

Parámetros

data

crypted

Esto contendrá el resultado de la encriptación.

key

La clave pública.

padding

padding puede ser OPENSSL_PKCS1_PADDING, OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • openssl_private_encrypt() - Encripta información con la clave privada
  • openssl_private_decrypt() - Desencripta información con la clave privada


Genera una cadena de bytes pseudo-aleatoria

  • « openssl_public_encrypt
  • openssl_seal »
  • PHP Manual
  • Funciones de OpenSSL
  • Genera una cadena de bytes pseudo-aleatoria

openssl_random_pseudo_bytes

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_random_pseudo_bytes — Genera una cadena de bytes pseudo-aleatoria

Descripción

openssl_random_pseudo_bytes ( int $length , bool &$crypto_strong = ? ) : string

Genera una cadena de bytes pseudo-aleatoria, con el número de bytes determinado por el parámetro length.

También indica si se usó un algoritmo criptográficamente fuerte para producir los bytes pseudo-aleatorios, y hace esto mediante el parámetro opcional crypto_strong. Es raro que este parámetro sea false, pero algunos sistemas pueden ser antiguos rotos.

Parámetros

length

La longitud de la cadena de bytes deseada. Debe ser un entero positivo. PHP intentará asignar este parámetro a un entero no nulo para usarlo.

crypto_strong

Si se pasó en la función, mantendrá un valor booleano value que determina si el algoritmo usado fue "criptográficamente fuerte", p.ej., seguro para el uso con GPG, contraseñas, etc. true si lo hizo, de otro modo false

Valores devueltos

Devuelve el string de bytes generado si se tuvo éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_random_pseudo_bytes()

<?php
for ($i = -1; $i <= 4; $i++) {
    $bytes = openssl_random_pseudo_bytes($i, $cstrong);
    $hex   = bin2hex($bytes);

    echo "Longitudes: Bytes: $i y Hex: " . strlen($hex) . PHP_EOL;
    var_dump($hex);
    var_dump($cstrong);
    echo PHP_EOL;
}
?>

El resultado del ejemplo sería algo similar a:

Longitudes: Bytes: -1 y Hex: 0
string(0) ""
NULL

Longitudes: Bytes: 0 y Hex: 0
string(0) ""
NULL

Longitudes: Bytes: 1 y Hex: 2
string(2) "42"
bool(true)

Longitudes: Bytes: 2 y Hex: 4
string(4) "dc6e"
bool(true)

Longitudes: Bytes: 3 y Hex: 6
string(6) "288591"
bool(true)

Longitudes: Bytes: 4 y Hex: 8
string(8) "ab86d144"
bool(true)

Ver también

  • random_bytes() - Genera bytes seudoaleatorios criptográficamente seguros
  • bin2hex() - Convierte datos binarios en su representación hexadecimal
  • crypt() - Hash de cadenas de un sólo sentido
  • mt_rand() - Genera un mejor número entero aleatorio
  • uniqid() - Generar un ID único


Sellar (encriptar) información

  • « openssl_random_pseudo_bytes
  • openssl_sign »
  • PHP Manual
  • Funciones de OpenSSL
  • Sellar (encriptar) información

openssl_seal

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_seal — Sellar (encriptar) información

Descripción

openssl_seal ( string $data , string &$sealed_data , array &$env_keys , array $pub_key_ids , string $method = "RC4" ) : int

openssl_seal() sella (encripta) la información dada por data mediante el método dado por method con una clave secreta generada aleatoriamente. La clave es encriptada con cada clave pública asociada con los identificadores de pub_key_ids y cada clave encriptada es devuelta en env_keys. Esto significa que se puede enviar información sellada a múltiples destinatarios (siempre que se hayan obtenido sus claves públicas). Cada destinatario debe recibir tanto la información sellada como la clave de sobre que fue encriptada con la clave publica del destinatario.

Parámetros

data

Los datos a sellar.

sealed_data

Los datos sellados.

env_keys

Un array de claves encriptadas.

pub_key_ids

Un array de identificadores de recursos de clave pública.

method

El método de cifrado.

Valores devueltos

Devuelve la longitud de la información sellada si se tuvo éxito, o false si se produjo un error. Si se tuvo éxito, la información sellada es devuelta en sealed_data, y las claves de sobre en env_keys.

Ejemplos

Ejemplo #1 Ejemplo de openssl_seal()

<?php
// se asume que $data contiene la información que va a ser sellada

// traer las claves públicas para nuestros destinatarios, y prepararlas
$fp = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk1 = openssl_get_publickey($cert);
// Repetir para el segundo destinatario
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk2 = openssl_get_publickey($cert);

// sellar el mensaje, sólo los propietarios de $pk1 y $pk2 pueden desencriptar $sealed
// con las claves $ekeys[0] y $ekeys[1] respectivamente.
openssl_seal($data, $sealed, $ekeys, array($pk1, $pk2));

// liberar las claves de la memoria
openssl_free_key($pk1);
openssl_free_key($pk2);
?>

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el parámetro method.

Ver también

  • openssl_open() - Abre información sellada


Genera una firma

  • « openssl_seal
  • openssl_spki_export_challenge »
  • PHP Manual
  • Funciones de OpenSSL
  • Genera una firma

openssl_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_sign — Genera una firma

Descripción

openssl_sign ( string $data , string &$signature , mixed $priv_key_id , mixed $signature_alg = OPENSSL_ALGO_SHA1 ) : bool

openssl_sign() computa una firma para la información data especificada, generando una firma digital criptográfica usando la clave privada asociada con priv_key_id. Observe que la información misma no está encriptada.

Parámetros

data

El string de datos que se quieren firmar.

signature

Si la llamada tuvo éxito, la firma es devuelta en signature.

priv_key_id

resource - una clave, devuelta por openssl_get_privatekey()

string - una clave con formato PEM

signature_alg

int - uno de estos Algoritmos de firma.

string - un string válido devuelto por openssl_get_md_methods(); p.ej., "sha256WithRSAEncryption" o "sha384".

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de openssl_sign()

<?php
// se asume que $datos contiene la información que se va a firmar

// obtener la clave privada desde el fichero y prepararla
$pkeyid = openssl_pkey_get_private("file://src/openssl-0.9.6/demos/sign/key.pem");

// computar la firma
openssl_sign($datos, $firma, $pkeyid);

// liberar la clave de la memoria
openssl_free_key($pkeyid);
?>

Ejemplo #2 Ejemplo de openssl_sign()

<?php
// datos que se quieren firmar
$datos = 'mis datos';

// crear unas claves pública y privada nuevas
$new_key_pair = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
openssl_pkey_export($new_key_pair, $private_key_pem);

$details = openssl_pkey_get_details($new_key_pair);
$public_key_pem = $details['key'];

// crear la firma
openssl_sign($datos, $firma, $private_key_pem, OPENSSL_ALGO_SHA256);

// guardar para después
file_put_contents('private_key.pem', $private_key_pem);
file_put_contents('public_key.pem', $public_key_pem);
file_put_contents('signature.dat', $firma);

// comprobar la firma
$r = openssl_verify($datos, $firma, $public_key_pem, "sha256WithRSAEncryption");
var_dump($r);
?>

Ver también

  • openssl_verify() - Verificar una firma


Exporta el desafío asociados con una clave pública y desafío firmados

  • « openssl_sign
  • openssl_spki_export »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta el desafío asociados con una clave pública y desafío firmados

openssl_spki_export_challenge

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_export_challenge — Exporta el desafío asociados con una clave pública y desafío firmados

Descripción

openssl_spki_export_challenge ( string &$spkac ) : string

Exporta el desafío desde una clave pública y desafío firmados y codificados

Parámetros

spkac

Una clave pública y desafío firmados válidos

Valores devueltos

Devuelve el string del desafío asociado o NULL en caso de fallo.

Errores/Excepciones

Emite un error de nivel E_WARNING si se proporciona un argumento no válido mediante el parámtro spkac.

Ejemplos

Ejemplo #1 Ejemplo de openssl_spki_export_challenge()

Extraer el string del desafío asociado o NULL en caso de fallo.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $spkac));
?>

Ejemplo #2 Ejemplo de openssl_spki_export_challenge() desde <keygen>

Extraer el string del desafío asociado emitido desde el elemento <keygen>

<?php
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $_POST['spkac']));
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ver también

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_verify() - Verifies a signed public key and challenge
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_md_method()
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Exports a valid PEM formatted public key signed public key and challenge

  • « openssl_spki_export_challenge
  • openssl_spki_new »
  • PHP Manual
  • Funciones de OpenSSL
  • Exports a valid PEM formatted public key signed public key and challenge

openssl_spki_export

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge

Descripción

openssl_spki_export ( string $spki ) : string|false

Exports PEM formatted public key from encoded signed public key and challenge

Parámetros

spki

Expects a valid signed public key and challenge

Valores devueltos

Returns the associated PEM formatted public key or false on failure.

Errores/Excepciones

Emits an E_WARNING level error if an invalid argument is passed via the spki parameter.

Ejemplos

Ejemplo #1 openssl_spki_export() example

Extracts the associated PEM formatted public key or NULL on failure.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$pubKey = openssl_spki_export(preg_replace('/SPKAC=/', '', $spkac));

if ($pubKey) {
    echo $pubKey;
}
?>

Ejemplo #2 openssl_spki_export() example from <keygen>

Extracts the associated PEM formatted public key issued from the <keygen> element

<?php
$spkac = openssl_spki_export(preg_replace('/SPKAC=/', '', $_POST['spkac']));
if ($spkac != NULL) {
    echo $spkac;
} else {
    echo "Extraction of pub key failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ver también

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_verify() - Verifies a signed public key and challenge
  • openssl_spki_export_challenge() - Exporta el desafío asociados con una clave pública y desafío firmados
  • openssl_get_md_methods() - Obtener los métodos de resumen disponibles
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Generate a new signed public key and challenge

  • « openssl_spki_export
  • openssl_spki_verify »
  • PHP Manual
  • Funciones de OpenSSL
  • Generate a new signed public key and challenge

openssl_spki_new

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_new — Generate a new signed public key and challenge

Descripción

openssl_spki_new ( OpenSSLAsymmetricKey $private_key , string $challenge , int $digest_algo = OPENSSL_ALGO_MD5 ) : string|false

Generates a signed public key and challenge using specified hashing algorithm

Parámetros

private_key

private_key should be set to a private key that was previously generated by openssl_pkey_new() (or otherwise obtained from the other openssl_pkey family of functions). The corresponding public portion of the key will be used to sign the CSR.

challenge

The challenge associated to associate with the SPKAC

digest_algo

The digest algorithm. See openssl_get_md_method().

Valores devueltos

Returns a signed public key and challenge string or false on failure.

Errores/Excepciones

Emits an E_WARNING level error if an unknown signature algorithm is passed via the digest_algo parameter.

Historial de cambios

Versión | Descripción
8.0.0 | private_key accepts an OpenSSLAsymmetricKey instance now; previously, a recurso of type OpenSSL key was accepted.

Ejemplos

Ejemplo #1 openssl_spki_new() example

Generate a new SPKAC with the default digest (MD5)

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'testing');

if ($spkac !== NULL) {
    echo $spkac;
} else {
    echo "SPKAC generation failed";
}
?>

El resultado del ejemplo sería algo similar a:

MIICRzCCAS8wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDM3V3sS4o4
mB9dczziRnjGAmSp+JwPrHoYMAFGvDNmZGyiWfU586X4BKs++BAj7e/FsAfno0Hd
hN9FwpCNFSox30L03nQvLYJE7f/WqigwBeMRT7Op/xvFks4sT70xP2HRYv4KqP9a
WRcKU6cFH8VxhFhqM2txEIxZKdFLaL28yT7bEDmcglf4JLDdgNMb9rET1dkgtKE6
dOaJHPGjf1uvnOH4YwkQr7n4sLUR3Kdbh0ZJAFuQVDZulo+LLzxBBkqJJcB6FhF+
oXCdHTKZnqAhpWDz+NXYytAmevab6IYm5TWPWsJUv1YKJA5lg2mXbbloIZlN9Mgc
i9fi03bdw+crAgMBAAEWB3Rlc3RpbmcwDQYJKoZIhvcNAQEEBQADggEBALyUvP/o
pPSoWBlorFyZ2RnGwKf9qMpE0q2IJP7G3oDR4LyK/m933DUiZ+YnqThrH/CWb4Ek
y5I3OCyl3S4wCuU1ibZZwDVwYShr5ELp0J9PEf7qMQZOhNsizoC7k+Czb2xB6hYW
sKfsfTKm3cXBtH3fdgc/Z1Z7VSWnAzYo38snqm72NTf5yFRnrQdphNNXi+kn1zHA
lxXRyFDXHOcYsOnwAWfyXFA4QDHQ0ezz0UoCY8gJXovcZb4GRYqOLUAsF2HcNboy
29WN8VqE29sL9QxVZFlwMcqyoLcNnyw38GvNvAGqSvzzbnEFP2MAQXJVe0H0hdp/
MML5G2iNVgNozAo=

Ver también

  • openssl_spki_verify() - Verifies a signed public key and challenge
  • openssl_spki_export_challenge() - Exporta el desafío asociados con una clave pública y desafío firmados
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_get_md_methods() - Obtener los métodos de resumen disponibles
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Verifies a signed public key and challenge

  • « openssl_spki_new
  • openssl_verify »
  • PHP Manual
  • Funciones de OpenSSL
  • Verifies a signed public key and challenge

openssl_spki_verify

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_verify — Verifies a signed public key and challenge

Descripción

openssl_spki_verify ( string $spki ) : bool

Validates the supplied signed public key and challenge

Parámetros

spki

Expects a valid signed public key and challenge

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emits an E_WARNING level error if an invalid argument is passed via the spki parameter.

Ejemplos

Ejemplo #1 openssl_spki_verify() example

Validates an existing signed public key and challenge

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');

if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $spkac))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>

Ejemplo #2 openssl_spki_verify() example from <keygen>

Validates an existing signed public key and challenge issued from the <keygen> element

<?php
if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $_POST['spkac']))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ver también

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_export_challenge() - Exporta el desafío asociados con una clave pública y desafío firmados
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_get_md_methods() - Obtener los métodos de resumen disponibles
  • openssl_csr_new() - Genera una CSR
  • openssl_csr_sign() - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado


Verificar una firma

  • « openssl_spki_verify
  • openssl_x509_check_private_key »
  • PHP Manual
  • Funciones de OpenSSL
  • Verificar una firma

openssl_verify

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_verify — Verificar una firma

Descripción

openssl_verify ( string $data , string $signature , mixed $pub_key_id , mixed $signature_alg = OPENSSL_ALGO_SHA1 ) : int

openssl_verify() verifica que la firma signature es correcta para la información data especificada usando la clave pública asociada con pub_key_id. Ésta debe ser la clave pública que se corresponde con la clave privada usada para firmar.

Parámetros

data

El string de datos utilizado anteriormente para generar la firma.

signature

Un string binario puro generado por openssl_sign() o por medios similares

pub_key_id

resource - una clave, devuelta por openssl_get_publickey()

string - una clave con formato PEM; p.ej., "-----BEGIN PUBLIC KEY----- MIIBCgK..."

signature_alg

int - uno de estos Algoritmos de firma.

string - un string válido devuelto por openssl_get_md_methods(); p.ej., "sha1WithRSAEncryption" o "sha512".

Valores devueltos

Devuelve 1 si la firma es correcta, 0 si es incorrecta, y -1 si se produjo un error.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro signature_alg.

Ejemplos

Ejemplo #1 Ejemplo de openssl_verify()

<?php
// se asume que $data y $signature contienen la información y la firma

// obtener la clave pública desde el certifiado y prepararla
$pubkeyid = openssl_pkey_get_public("file://src/openssl-0.9.6/demos/sign/cert.pem");

// especificar si la firma es correcta o no
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1) {
    echo "buena";
} elseif ($ok == 0) {
    echo "mala";
} else {
    echo "alarmante, error verificando la firma";
}
// liberar la clave de la memoria
openssl_free_key($pubkeyid);
?>

Ejemplo #2 openssl_verify() example

<?php
// datos que se quieren firmar
$datos = 'mis datos';

// crear unas claves pública y privada nuevas
$private_key_res = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$details = openssl_pkey_get_details($private_key_res);
$public_key_res = openssl_pkey_get_public($details['key']);

// crear la firma
openssl_sign($datos, $firma, $private_key_res, "sha1WithRSAEncryption");

// comprobar la firma
$ok = openssl_verify($datos, $firma, $public_key_res, OPENSSL_ALGO_SHA1);
if ($ok == 1) {
    echo "válida";
} elseif ($ok == 0) {
    echo "no válida";
} else {
    echo "error: ".openssl_error_string();
}
?>

Ver también

  • openssl_sign() - Genera una firma


Comprueba si una clave privada se corresponde a un certificado

  • « openssl_verify
  • openssl_x509_checkpurpose »
  • PHP Manual
  • Funciones de OpenSSL
  • Comprueba si una clave privada se corresponde a un certificado

openssl_x509_check_private_key

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_check_private_key — Comprueba si una clave privada se corresponde a un certificado

Descripción

openssl_x509_check_private_key ( mixed $cert , mixed $key ) : bool

Comprueba si key es la clave privada que se corresponde con cert.

Parámetros

cert

El certificado.

key

La clave privada.

Valores devueltos

Devuelve true si key el la clave privada que se conrresponde con cert, o false si no.


Verifica si un certificado se puede usar para un propósito en particular

  • « openssl_x509_check_private_key
  • openssl_x509_export_to_file »
  • PHP Manual
  • Funciones de OpenSSL
  • Verifica si un certificado se puede usar para un propósito en particular

openssl_x509_checkpurpose

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_checkpurpose — Verifica si un certificado se puede usar para un propósito en particular

Descripción

openssl_x509_checkpurpose ( mixed $x509cert , int $purpose , array $cainfo = array() , string $untrustedfile = ? ) : int

openssl_x509_checkpurpose() examina un certificado para ver si se puede usar para el propósito purpose especificado.

Parámetros

x509cert

El certificado examinado.

purpose

Propósitos de openssl_x509_checkpurpose()
Constante | Descripción
X509_PURPOSE_SSL_CLIENT | ¿El certificado puede ser usado por el lado del cliente de una conexión SSL?
X509_PURPOSE_SSL_SERVER | ¿El certificado puede ser usado por el lado del servidor de una conexión SSL?
X509_PURPOSE_NS_SSL_SERVER | ¿El certificado puede ser usado por un servidor SSL Netscape?
X509_PURPOSE_SMIME_SIGN | ¿Se puede usar el certificado para firmar un email S/MIME?
X509_PURPOSE_SMIME_ENCRYPT | ¿Se puede usar el certificado para encriptar un email S/MIME?
X509_PURPOSE_CRL_SIGN | ¿Se puede usar el certificado para firmar una Lista de Revocación de Certificado (CRL en inglés)?
X509_PURPOSE_ANY | ¿Se puede usar el certificado para Cualquier/Todos los propósitos?
Estas opciones no son campos de bits - ¡sólo se puede especificar una!

cainfo

cainfo debería ser una matriz de archivos/directorios de una AC de confianza, como está descrito en Verificación de Certificados.

untrustedfile

Si se especifica debería ser el nombre de un archivo PEM codificado que contiene los certificados que se pueden usar para ayudar a verificar el certificado, aunque no se pone confianza en los certificados que vienen de ese archivo.

Valores devueltos

Devuelve true si el certificado se puede usar para el propósito previsto, false si no se puede, o -1 si se produjo un error.


Exporta un certificado a un archivo

  • « openssl_x509_checkpurpose
  • openssl_x509_export »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta un certificado a un archivo

openssl_x509_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_export_to_file — Exporta un certificado a un archivo

Descripción

openssl_x509_export_to_file ( mixed $x509 , string $outfilename , bool $notext = true ) : bool

openssl_x509_export_to_file() guarda x509 en un archivo nombrado por outfilename en un formato PEM codificado.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

outfilename

Ruta del archivo de salida.

notext

El parámetro opcional notext afecta la verbosidad de la salida; si es false, se incluirá información adicional en la salida entendible por seres humanos. El valor por defecto para notext es true.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Exporta un certificado como una cadena

  • « openssl_x509_export_to_file
  • openssl_x509_fingerprint »
  • PHP Manual
  • Funciones de OpenSSL
  • Exporta un certificado como una cadena

openssl_x509_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_export — Exporta un certificado como una cadena

Descripción

openssl_x509_export ( mixed $x509 , string &$output , bool $notext = true ) : bool

openssl_x509_export() guarda x509 en una cadena nombrada por output en un formato PEM codificado.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

output

Si se tiene éxito, ésto contendrá el PEM.

notext

El parámetro opcional notext afecta la verbosidad de la salida; si es false, se incluirá información adicional en la salida entendible por seres humanos. El valor por defecto para notext es true.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Calculates the fingerprint, or digest, of a given X.509 certificate

  • « openssl_x509_export
  • openssl_x509_free »
  • PHP Manual
  • Funciones de OpenSSL
  • Calculates the fingerprint, or digest, of a given X.509 certificate

openssl_x509_fingerprint

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate

Descripción

openssl_x509_fingerprint ( OpenSSLCertificate|string $certificate , string $digest_algo = "sha1" , bool $binary = false ) : string|false

openssl_x509_fingerprint() returns the digest of certificate as a string.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

digest_algo

The digest method or hash algorithm to use, e.g. "sha256", one of openssl_get_md_methods().

binary

When set to true, outputs raw binary data. false outputs lowercase hexits.

Valores devueltos

Returns a string containing the calculated certificate fingerprint as lowercase hexits unless binary is set to true in which case the raw binary representation of the message digest is returned.

Returns false on failure.

Historial de cambios

Versión | Descripción
8.0.0 | certificate accepts an OpenSSLCertificate instance now; previously, a recurso of type OpenSSL X.509 was accepted.


Liberar un recurso de certificado

  • « openssl_x509_fingerprint
  • openssl_x509_parse »
  • PHP Manual
  • Funciones de OpenSSL
  • Liberar un recurso de certificado

openssl_x509_free

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_free — Liberar un recurso de certificado

Descripción

openssl_x509_free ( resource $x509cert ) : void

openssl_x509_free() libera un certificado asociado con el recurso x509cert especificado de la memoria.

Parámetros

x509cert

Valores devueltos

No devuelve ningún valor.


Analiza un certificado X509 y devuelve la información como un matriz

  • « openssl_x509_free
  • openssl_x509_read »
  • PHP Manual
  • Funciones de OpenSSL
  • Analiza un certificado X509 y devuelve la información como un matriz

openssl_x509_parse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_parse — Analiza un certificado X509 y devuelve la información como un matriz

Descripción

openssl_x509_parse ( mixed $x509cert , bool $shortnames = true ) : array

openssl_x509_parse() devuelve la información sobre el certificado x509cert proporcionado, incluyendo los campos tales como subject name, issuer name, purposes, fechas valid from y valid to, etc.

Parámetros

x509cert

shortnames

shortnames controla cómo se indexa la información en la matriz - si shortnames es true (por defecto) los campos serán indexados con el nombre corto, si no, se usará el nombre largo - p.ej.: CN es el nombre corto de commonName.

Valores devueltos

La estructura de la información devuleta no está (deliberadamente) documentada aún, ya que todavía está sujeta a cambios.


Analiza un certificado X.509 y devuelve un identificador de recurso para él

  • « openssl_x509_parse
  • openssl_x509_verify »
  • PHP Manual
  • Funciones de OpenSSL
  • Analiza un certificado X.509 y devuelve un identificador de recurso para él

openssl_x509_read

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_read — Analiza un certificado X.509 y devuelve un identificador de recurso para él

Descripción

openssl_x509_read ( mixed $x509certdata ) : resource

openssl_x509_read() analiza un certificado proporcionado por x509certdata y devuelve un identificador de recurso para él.

Parámetros

x509certdata

Valores devueltos

Devuelve un identificador de recurso si se tuvo éxito o false en caso de error.


Verifies digital signature of x509 certificate against a public key

  • « openssl_x509_read
  • Hash de contraseñas »
  • PHP Manual
  • Funciones de OpenSSL
  • Verifies digital signature of x509 certificate against a public key

openssl_x509_verify

(PHP 7 >= 7.4.0, PHP 8)

openssl_x509_verify — Verifies digital signature of x509 certificate against a public key

Descripción

openssl_x509_verify ( OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $public_key ) : int

openssl_x509_verify() verifies that the certificate certificate was signed by the private key corresponding to public key public_key.

Parámetros

x509

Ver parámetros Key/Certificate para un listado de valores válidos.

public_key

OpenSSLAsymmetricKey - a key, returned by openssl_get_publickey()

string - a PEM formatted key, example, "-----BEGIN PUBLIC KEY----- MIIBCgK..."

Valores devueltos

Returns 1 if the signature is correct, 0 if it is incorrect, and -1 on error.

Historial de cambios

Versión | Descripción
8.0.0 | certificate accepts an OpenSSLCertificate instance now; previously, a recurso of type OpenSSL X.509 was accepted.
8.0.0 | public_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a recurso of type OpenSSL key or OpenSSL X.509 was accepted.

Ejemplos

Ejemplo #1 openssl_x509_verify() example

<?php
$hostname = "news.php.net";
$ssloptions = array(
    "capture_peer_cert" => true,
    "capture_peer_cert_chain" => true,
    "allow_self_signed"=> false,
    "CN_match" => $hostname,
    "verify_peer" => true,
    "SNI_enabled" => true,
    "SNI_server_name" => $hostname,
);

$ctx = stream_context_create( array("ssl" => $ssloptions) );
$result = stream_socket_client("ssl://$hostname:443", $errno, $errstr, 30, STREAM_CLIENT_CONNECT, $ctx);
$cont = stream_context_get_params($result);
$x509 = $cont["options"]["ssl"]["peer_certificate"];
$certparsed = openssl_x509_parse($x509);

foreach($cont["options"]["ssl"]["peer_certificate_chain"] as $chaincert)
{
    $chainparsed = openssl_x509_parse($chaincert);
    $chain_public_key = openssl_get_publickey($chaincert);
    $r = openssl_x509_verify($x509, $chain_public_key);
    if ($r==1)
    {
        echo $certparsed['subject']['CN'];
        echo " was digitally signed by ";
        echo $chainparsed['subject']['CN']."\n";
    }
}
?>

Ver también

  • openssl_verify() - Verificar una firma
  • openssl_get_publickey() - Alias de openssl_pkey_get_public


Hash de contraseñas

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de hashing de contraseñas
    • password_algos — Get available password hashing algorithm IDs
    • password_get_info — Devuelve información sobre el hash proporcionado
    • password_hash — Crea un hash de contraseña
    • password_needs_rehash — Comprueba si el hash facilitado coincide con las opciones proporcionadas
    • password_verify — Comprueba que la contraseña coincida con un hash


Introducción

La API de hash de contraseñas proporciona una envoltura fácil de usar sobre crypt() para hacer sencilla la creación y administración de contraseñas de una forma segura.

Esta extensión está disponible desde PHP 5.5.0, aunque también existe una » implementación del espacio de usuario para PHP >= 5.3.7.


Requerimientos

No se requiere de ninguna biblioteca externa para compilar esta extensión.

Para el cálculo de hashes con Argon2, sin embargo, » libargon2 es requerida.


Instalación

No se requiere de ninguna instalación para utilizar estas funciones; forman parte del núcleo de PHP.

Para habilitar el cálculo de hashes de contraseña con Argon2, sin embargo, PHP debe ser compilado con soporte a libargon2 utilizando --with-password-argon2[=DIR] como opción al hacer el configure.


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

PASSWORD_BCRYPT (integer)

PASSWORD_BCRYPT se utiliza para crear nuevos hash de contraseñas empleando el algoritmo CRYPT_BLOWFISH.

Siempre resultará en un hash que utiliza el formato criptgráfico "$2y$", el cual siempre tiene un ancho de 60.

Opciones admitidas:

  • salt (string) - para proporcionar manualmente una sal cuando se realiza el hash de la contraseña. Observe que esto sobrescribirá, previniendo así que se genere una sal automáticamente.

    Si se omite, se generará una sal aleatoria mediante password_hash() para cada contraseña con hash. Este es el modo de operación previsto y a partir de PHP 7.0.0 la opción salt ha sido marcada como obsoleta.

  • cost (integer) - el cual denota el coste algorítmico que debería utilizarse. Se pueden encontrar ejemplos de estos valores en la página de crypt().

    Si se omite, se usará un valor predeterminado de 10. Este es un buen coste base, aunque se podría considerar aumentarlo dependiendo del hardware utilizado.

PASSWORD_ARGON2I (integer)

PASSWORD_ARGON2I se utiliza para crear una nuevos hashes de contraseña mediante el algoritmo Argon2.

Opciones admitidas:

  • memory_cost (integer) - Máximo de memoria (en bytes) que puede ser usado para calcular el hash Argon2. Por defecto es PASSWORD_ARGON2_DEFAULT_MEMORY_COST.

  • time_cost (integer) - Máximo de tiempo que puede ser usado para calcular el hash Argon2. Por defecto es PASSWORD_ARGON2_DEFAULT_TIME_COST.

  • threads (integer) - Número de hilos a utilizar para calcular el hash Argon2. Por defecto es PASSWORD_ARGON2_DEFAULT_THREADS.

Disponible desde PHP 7.2.0.

PASSWORD_ARGON2ID (integer)

Disponible desde PHP 7.3.0.

PASSWORD_ARGON2_DEFAULT_MEMORY_COST (integer)

Cantidad de memoria en bytes por defecto que utilizará Argon2lib para tratar de calcular un hash.

Disponible desde PHP 7.2.0.

PASSWORD_ARGON2_DEFAULT_TIME_COST (integer)

Cantidad de tiempo por defecto que utilizará Argon2lib para tratar de calcular un hash.

Disponible desde PHP 7.2.0.

PASSWORD_ARGON2_DEFAULT_THREADS (integer)

Número de hilos por defecto que utilizará Argon2lib.

Disponible desde PHP 7.2.0.

PASSWORD_DEFAULT (integer)

El algoritmo que se utilizará por defecto si no se especifica otro distinto. Esto puede cambiar en versiones futuras de PHP, cuando métodos más nuevos y fuertes de hashing estén disponibles.

Cabe señalar que con el tiempo esta constante puede (y probablemente lo hará) cambiar. Por tanto, se debería considerar que la longitud del hash resultante puede cambiar. Así, si se emplea PASSWORD_DEFAULT se debería almacenar el hash resultante de forma que se pueda almacenar más de 60 caracteres (255 es el ancho recomendado).

Valores para esta constante:

  • PHP 5.5.0 - PASSWORD_BCRYPT


Funciones de hashing de contraseñas

Tabla de contenidos

  • password_algos — Get available password hashing algorithm IDs
  • password_get_info — Devuelve información sobre el hash proporcionado
  • password_hash — Crea un hash de contraseña
  • password_needs_rehash — Comprueba si el hash facilitado coincide con las opciones proporcionadas
  • password_verify — Comprueba que la contraseña coincida con un hash


Get available password hashing algorithm IDs

  • « Funciones de hashing de contraseñas
  • password_get_info »
  • PHP Manual
  • Funciones de hashing de contraseñas
  • Get available password hashing algorithm IDs

password_algos

(PHP 7 >= 7.4.0, PHP 8)

password_algos — Get available password hashing algorithm IDs

Descripción

password_algos ( ) : array

Returns a complete list of all registered password hashing algorithm IDs as an array of strings.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the available password hashing algorithm IDs.

Ejemplos

Ejemplo #1 Basic password() usage

<?php
print_r(password_algos());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 2y
    [1] => argon2i
    [2] => argon2id
)


Devuelve información sobre el hash proporcionado

  • « password_algos
  • password_hash »
  • PHP Manual
  • Funciones de hashing de contraseñas
  • Devuelve información sobre el hash proporcionado

password_get_info

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_get_info — Devuelve información sobre el hash proporcionado

Descripción

password_get_info ( string $hash ) : array

Cuando se le pasa un hash válido creado con un algoritmo soportado por password_hash(), esta función devolverá un array con información sobre dicho hash.

Parámetros

hash

Un hash creado por password_hash().

Valores devueltos

Devuelve un array asociativo con tres elementos:

  • algo, que coincidirá con una constante de algoritmo de contraseñas
  • algoName, que tiene el nombre legible por humanos del algoritmo
  • options, que incluye las opciones proporcionadas al llamar a password_hash()


Crea un hash de contraseña

  • « password_get_info
  • password_needs_rehash »
  • PHP Manual
  • Funciones de hashing de contraseñas
  • Crea un hash de contraseña

password_hash

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_hash — Crea un hash de contraseña

Descripción

password_hash ( string $password , integer $algo , array $options = ? ) : string

password_hash() crea un nuevo hash de contraseña usando un algoritmo de hash fuerte de único sentido. password_hash() es compatible con crypt(). Por lo tanto, los hash de contraseñas creados con crypt() se pueden usar con password_hash().

Actualmente se admiten los siguientes algoritmos:

  • PASSWORD_DEFAULT - Usar el algoritmo bcrypt (predeterminado a partir de PHP 5.5.0). Observe que esta constante está diseñada para cambiar siempre que se añada un algoritmo nuevo y más fuerte a PHP. Por esta razón, la longitud del resultado de usar este identificador puede cambiar con el tiempo. Por lo tanto, se recomienda almacenar el resultado en una columna de una base de datos que pueda apliarse a más de 60 caracteres (255 caracteres sería una buena elección).
  • PASSWORD_BCRYPT - Usar el algoritmo CRYPT_BLOWFISH para crear el hash. Producirá un hash estándar compatible con crypt() utilizando el identificador "$2y$". El resultado siempre será un string de 60 caracteres, o false en caso de error.

    Opciones admitidas:

    • salt - para proporcionar manualmente una sal a usar cuando se realiza el hash de la contraseña. Observe que esto sobrescribirá y prevendrá que una sal sea generada automáticamente.

      Si se omite, se generará una sal aleatoria mediante password_hash() para cada hash. Este es el modo de operación intencionado.

      Advertencia

      La opción salt está obsoleta a partir de PHP 7.0.0. Ahora se prefiere simplemente utilizar generada de manera predeterminada.

    • cost - denota el coste del algoritmo que debería usarse. Se pueden encontrar ejemplo de estos valores en la página de crypt().

      Si se omite, se usará el valor predeterminado 10. Este es un buen coste de referencia, pero se podría considerar aumentarlo dependiendo del hardware.

Parámetros

password

La contraseña del usuario.

Precaución

El uso de PASSWORD_BCRYPT como el algoritmo resultará en el truncamiento del parámetro password a un máximo de 72 caracteres de longitud.

algo

A constante del algoritmo de contraseñas indicando qué algoritmo utilizar para crear el hash de la contraseña.

options

Un array asociativo de opciones. Véanse las constantes de algoritmos de contraseñas para la documentación sobre las opociones admitidas de cada algoritmo.

Si no se indica, se creará una sal aleatoria y el coste algorítmico por defecto será utilizado.

Valores devueltos

Devuelve el hash de la contraseña, o false en caso de error.

El algoritmo, coste y sal usados son devueltos como parte del hash. Por lo tanto, toda la información que es necesaria para verificar el hash, está incluida en él. Esto permite que la función password_verify() verifique el hash sin tener que almacenar por separado la información de la sal o del algoritmo.

Ejemplos

Ejemplo #1 Ejemplo de password_hash()

<?php
/**
 * Queremos crear un hash de nuestra contraseña uando el algoritmo DEFAULT actual.
 * Actualmente es BCRYPT, y producirá un resultado de 60 caracteres.
 *
 * Hay que tener en cuenta que DEFAULT puede cambiar con el tiempo, por lo que debería prepararse
 * para permitir que el almacenamento se amplíe a más de 60 caracteres (255 estaría bien)
 */
echo password_hash("rasmuslerdorf", PASSWORD_DEFAULT)."\n";
?>

El resultado del ejemplo sería algo similar a:

$2y$10$.vGA1O9wmRjrwAVXD98HNOgsNpDczlqm3Jq7KnEd1rVAGv3Fykk1a

Ejemplo #2 Ejemplo de password_hash() estableciendo el coste manualmente

<?php
/**
 * En este caso, queremos aumentar el coste predeterminado de BCRYPT a 12.
 * Observe que también cambiamos a BCRYPT, que tendrá siempre 60 caracteres.
 */
$opciones = [
    'cost' => 12,
];
echo password_hash("rasmuslerdorf", PASSWORD_BCRYPT, $opciones)."\n";
?>

El resultado del ejemplo sería algo similar a:

$2y$12$QjSH496pcT5CEbzjD/vtVeH03tfHKFy36d4J0Ltp3lRtee9HDxY3K

Ejemplo #3 Ejemplo de password_hash() estableciendo la sal manualmente

<?php
/**
 * Observe que la sal se genera aleatoriamente aquí.
 * No use nunca una sal estática o una que no se genere aleatoriamente.
 *
 * Para la GRAN mayoría de los casos de uso, dejar que password_hash genere la sal aleatoriamente
 */
$opciones = [
    'cost' => 11,
    'salt' => mcrypt_create_iv(22, MCRYPT_DEV_URANDOM),
];
echo password_hash("rasmuslerdorf", PASSWORD_BCRYPT, $opciones)."\n";
?>

El resultado del ejemplo sería algo similar a:

$2y$11$q5MkhSBtlsJcNEVsYh64a.aCluzHnGog7TQAKVmQwO9C8xb.t89F.

Ejemplo #4 Ejemplo de password_hash() buscando un buen coste

<?php
/**
 * Este código evaluará el servidor para determinar el coste permitido.
 * Se establecerá el mayor coste posible sin disminuir demasiando la velocidad
 * del servidor. 8-10 es una buena referencia, y más es bueno si los servidores
 * son suficientemente rápidos. El código que sigue tiene como objetivo un tramo de
 * = 50 milisegundos, que es una buena referencia para sistemas con registros interactivos.
 */
$timeTarget = 0.05; // 50 milisegundos

$coste = 8;
do {
    $coste++;
    $inicio = microtime(true);
    password_hash("test", PASSWORD_BCRYPT, ["cost" => $coste]);
    $fin = microtime(true);
} while (($fin - $inicio) < $timeTarget);

echo "Coste apropiado encontrado: " . $coste . "\n";
?>

El resultado del ejemplo sería algo similar a:

Coste apropiado encontrado: 10

Notas

Precaución

Se recomienda encarecidamente que no se genere una sal propia para esta función. Creará una sal segura automáticamente si no se especifica una.

Como se ha observado arriba, proporcionar la opción salt en PHP 7.0 generará una advertencia de obsolescencia. El soporte para proporcionar una sal manualmente podría ser eliminado en una versión futura de future.

Nota:

Se recomienda probar esta función en los servidores que se estén usando, y ajustar el parámetro de coste para que la ejecución de la función tome menos de 100 milisegundos en sistemas interactivos. El script en el ejemplo de antes le ayudará a elegir un buen valor de coste para su hardware.

Nota: Las actualizaciones para los algoritmos admitidos por esta función (o los cambios al predeterminado) deben serguir las siguientes reglas:

  • Cualquier algoritmo nuevo debe estar en el núcleo por lo menos una versión completa de PHP antes de convertirse en predeterminado. Por lo que si, por ejemplo, un nuevo algoritmo se añade en la 7.5.5, no sería apto para ser el predeterminado hasta la 7.7 (ya que la 7.6 sería la primera versión completa). Pero si se añadió un algoritmo diferente en la 7.6.0, también sería apto para ser el predeterminado en la 7.7.0.
  • El predeterminado debería cambiar únicamente en una versión completa (7.3.0, 8.0.0, etc.) y no en una versión de revisión. La única excepción es la emergencia de que se encuentre un fallo de seguridad crítico en el predeterminado actual.

Ver también

  • password_verify() - Comprueba que la contraseña coincida con un hash
  • crypt() - Hash de cadenas de un sólo sentido
  • » implementación en el espacio de usuario


Comprueba si el hash facilitado coincide con las opciones proporcionadas

  • « password_hash
  • password_verify »
  • PHP Manual
  • Funciones de hashing de contraseñas
  • Comprueba si el hash facilitado coincide con las opciones proporcionadas

password_needs_rehash

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_needs_rehash — Comprueba si el hash facilitado coincide con las opciones proporcionadas

Descripción

password_needs_rehash ( string $hash , int $algo , array $options = ? ) : bool

Esta función comprueba si el hash facilitado implementa el algoritmo y opciones proporcionadas. Si no, asume que el hash necesita volver a ser generado.

Parámetros

hash

Un hash creado por password_hash().

algo

A constante del algoritmo de contraseñas indicando qué algoritmo utilizar para crear el hash de la contraseña.

options

Un array asociativo de opciones. Véanse las constantes de algoritmos de contraseñas para la documentación sobre las opociones admitidas de cada algoritmo.

Ejemplos

Ejemplo #1 Empleo de password_needs_rehash()

<?php

$password = 'rasmuslerdorf';
$hash = '$2y$10$YCFsG6elYca568hBi2pZ0.3LDL5wjgxct1N8w/oLR/jfHsiQwCqTS';

// El parámetro cost puede cambiar con el tiempo al mejorar el hardware
$options = array('cost' => 11);

// Verificar el hash almacenado con la contraseña en texto plano
if (password_verify($password, $hash)) {
    // Comprobar hay un nuevo algoritmo de hash
    // o ha cambiado el coste
    if (password_needs_rehash($hash, PASSWORD_DEFAULT, $options)) {
        // Si es así, crear un nuevo hash y reemplazar el antiguo
        $newHash = password_hash($password, PASSWORD_DEFAULT, $options);
    }

    // Identificar al usuario
}
?>

Valores devueltos

Devuelve true si el hash debe ser generado de nuevo para coincidir con la información pasada a algo y options, o false en cualquier otro caso.


Comprueba que la contraseña coincida con un hash

  • « password_needs_rehash
  • Sodium »
  • PHP Manual
  • Funciones de hashing de contraseñas
  • Comprueba que la contraseña coincida con un hash

password_verify

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_verify — Comprueba que la contraseña coincida con un hash

Descripción

password_verify ( string $password , string $hash ) : bool

Comprueba que el hash proporcionado coincida con la contraseña facilitada.

Observe que password_hash() devuelve el algoritmo, el coste y el salt como parte del hash devuelto. Por lo tanto, toda la información que es necesaria para verificar el hash está incluida. Esto permite a la función de verificación comprobar el hash sin la necesidad de almacenar por separado la información del salt o del algoritmo.

Esta función es segura contra ataques basado en tiempo.

Parámetros

password

La contraseña del usuario.

hash

Un hash creado por password_hash().

Valores devueltos

Devuelve true si la contraseña y el hash coinciden, o false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de password_verify()

<?php
// Ver el ejemplo de password_hash() para ver de dónde viene este hash.
$hash = '$2y$07$BCryptRequires22Chrcte/VlQH0piJtjXl.0t1XkA8pw9dMXTpOq';

if (password_verify('rasmuslerdorf', $hash)) {
    echo '¡La contraseña es válida!';
} else {
    echo 'La contraseña no es válida.';
}
?>

El resultado del ejemplo sería:

¡La contraseña es válida!

Ver también

  • password_hash() - Crea un hash de contraseña
  • » implementación en el espacio de usuario
  • sodium_crypto_pwhash_str_verify() - Verifies that a password matches a hash


Sodium

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Sodium Funciones
    • sodium_add — Add large numbers
    • sodium_base642bin — Description
    • sodium_bin2base64 — Description
    • sodium_bin2hex — Encode to hexadecimal
    • sodium_compare — Compare large numbers
    • sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM
    • sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key
    • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description
    • sodium_crypto_auth_keygen — Get random bytes for key
    • sodium_crypto_auth_verify — Verifies that the tag is valid for the message
    • sodium_crypto_auth — Compute a tag for the message
    • sodium_crypto_box_keypair_from_secretkey_and_publickey — Description
    • sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key
    • sodium_crypto_box_open — Verify and decrypt a ciphertext
    • sodium_crypto_box_publickey_from_secretkey — Description
    • sodium_crypto_box_publickey — Description
    • sodium_crypto_box_seal_open — Decrypt the ciphertext
    • sodium_crypto_box_seal — Encrypt a message
    • sodium_crypto_box_secretkey — Description
    • sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key
    • sodium_crypto_box — Encrypt a message
    • sodium_crypto_generichash_final — Complete the hash
    • sodium_crypto_generichash_init — Initialize a hash
    • sodium_crypto_generichash_keygen — Get random bytes for key
    • sodium_crypto_generichash_update — Add message to a hash
    • sodium_crypto_generichash — Get a hash of the message
    • sodium_crypto_kdf_derive_from_key — Derive a subkey
    • sodium_crypto_kdf_keygen — Get random bytes for key
    • sodium_crypto_kx_client_session_keys — Description
    • sodium_crypto_kx_keypair — Creates a new sodium keypair
    • sodium_crypto_kx_publickey — Description
    • sodium_crypto_kx_secretkey — Description
    • sodium_crypto_kx_seed_keypair — Description
    • sodium_crypto_kx_server_session_keys — Description
    • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string
    • sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash
    • sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password
    • sodium_crypto_pwhash_str_needs_rehash — Description
    • sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash
    • sodium_crypto_pwhash_str — Get an ASCII-encoded hash
    • sodium_crypto_pwhash — Derive a key from a password
    • sodium_crypto_scalarmult_base — Alias de sodium_crypto_box_publickey_from_secretkey
    • sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key
    • sodium_crypto_secretbox_keygen — Get random bytes for key
    • sodium_crypto_secretbox_open — Verify and decrypt a ciphertext
    • sodium_crypto_secretbox — Encrypt a message
    • sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description
    • sodium_crypto_secretstream_xchacha20poly1305_init_push — Description
    • sodium_crypto_secretstream_xchacha20poly1305_keygen — Description
    • sodium_crypto_secretstream_xchacha20poly1305_pull — Description
    • sodium_crypto_secretstream_xchacha20poly1305_push — Description
    • sodium_crypto_secretstream_xchacha20poly1305_rekey — Description
    • sodium_crypto_shorthash_keygen — Get random bytes for key
    • sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message
    • sodium_crypto_sign_detached — Sign the message
    • sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key
    • sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key
    • sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description
    • sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key
    • sodium_crypto_sign_open — Check that the signed message has a valid signature
    • sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key
    • sodium_crypto_sign_publickey — Description
    • sodium_crypto_sign_secretkey — Description
    • sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key
    • sodium_crypto_sign_verify_detached — Verify signature for the message
    • sodium_crypto_sign — Sign a message
    • sodium_crypto_stream_keygen — Get random bytes for key
    • sodium_crypto_stream_xor — Encrypt a message
    • sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed
    • sodium_hex2bin — Decodes a hexadecimally encoded binary string
    • sodium_increment — Increment large number
    • sodium_memcmp — Test for equality in constant-time
    • sodium_memzero — Overwrite buf with zeros
    • sodium_pad — Add padding data
    • sodium_unpad — Remove padding data
  • SodiumException — The SodiumException class


  • « Sodium
  • Instalación/Configuración »
  • PHP Manual
  • Sodium
  • Introducción

Introducción


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

This extension requires » libsodium = 1.0.8.


Instalación

As of PHP 7.2.0 this extension is bundled with PHP. For older PHP versions this extension is available via PECL.

Linux Systems

In order to use this extension you must compile PHP with sodium support by using the --with-sodium[=DIR] configure option.

Windows

In order to use this extension you have to add extension=php_sodium.dll to php.ini.

Installation via PECL

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/libsodium


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SODIUM_LIBRARY_VERSION (string)
SODIUM_LIBRARY_MAJOR_VERSION (int)
SODIUM_LIBRARY_MINOR_VERSION (int)
SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES (int)
SODIUM_CRYPTO_AUTH_BYTES (int)
SODIUM_CRYPTO_AUTH_KEYBYTES (int)
SODIUM_CRYPTO_BOX_SEALBYTES (int)
SODIUM_CRYPTO_BOX_SECRETKEYBYTES (int)
SODIUM_CRYPTO_BOX_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_BOX_KEYPAIRBYTES (int)
SODIUM_CRYPTO_BOX_MACBYTES (int)
SODIUM_CRYPTO_BOX_NONCEBYTES (int)
SODIUM_CRYPTO_BOX_SEEDBYTES (int)
SODIUM_CRYPTO_KDF_BYTES_MIN (int)
SODIUM_CRYPTO_KDF_BYTES_MAX (int)
SODIUM_CRYPTO_KDF_CONTEXTBYTES (int)
SODIUM_CRYPTO_KDF_KEYBYTES (int)
SODIUM_CRYPTO_KX_SEEDBYTES (int)
SODIUM_CRYPTO_KX_SESSIONKEYBYTES (int)
SODIUM_CRYPTO_KX_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_KX_SECRETKEYBYTES (int)
SODIUM_CRYPTO_KX_KEYPAIRBYTES (int)
SODIUM_CRYPTO_GENERICHASH_BYTES (int)
SODIUM_CRYPTO_GENERICHASH_BYTES_MIN (int)
SODIUM_CRYPTO_GENERICHASH_BYTES_MAX (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX (int)
SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 (int)
SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 (int)
SODIUM_CRYPTO_PWHASH_ALG_DEFAULT (int)
SODIUM_CRYPTO_PWHASH_SALTBYTES (int)
SODIUM_CRYPTO_PWHASH_STRPREFIX (string)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE (int)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX (string)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_SCALARMULT_BYTES (int)
SODIUM_CRYPTO_SCALARMULT_SCALARBYTES (int)
SODIUM_CRYPTO_SHORTHASH_BYTES (int)
SODIUM_CRYPTO_SHORTHASH_KEYBYTES (int)
SODIUM_CRYPTO_SECRETBOX_KEYBYTES (int)
SODIUM_CRYPTO_SECRETBOX_MACBYTES (int)
SODIUM_CRYPTO_SECRETBOX_NONCEBYTES (int)
SODIUM_CRYPTO_SIGN_BYTES (int)
SODIUM_CRYPTO_SIGN_SEEDBYTES (int)
SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_SIGN_SECRETKEYBYTES (int)
SODIUM_CRYPTO_SIGN_KEYPAIRBYTES (int)
SODIUM_CRYPTO_STREAM_NONCEBYTES (int)
SODIUM_CRYPTO_STREAM_KEYBYTES (int)


Sodium Funciones

Tabla de contenidos

  • sodium_add — Add large numbers
  • sodium_base642bin — Description
  • sodium_bin2base64 — Description
  • sodium_bin2hex — Encode to hexadecimal
  • sodium_compare — Compare large numbers
  • sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation
  • sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation
  • sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM
  • sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key
  • sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag
  • sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key
  • sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key
  • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description
  • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description
  • sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description
  • sodium_crypto_auth_keygen — Get random bytes for key
  • sodium_crypto_auth_verify — Verifies that the tag is valid for the message
  • sodium_crypto_auth — Compute a tag for the message
  • sodium_crypto_box_keypair_from_secretkey_and_publickey — Description
  • sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key
  • sodium_crypto_box_open — Verify and decrypt a ciphertext
  • sodium_crypto_box_publickey_from_secretkey — Description
  • sodium_crypto_box_publickey — Description
  • sodium_crypto_box_seal_open — Decrypt the ciphertext
  • sodium_crypto_box_seal — Encrypt a message
  • sodium_crypto_box_secretkey — Description
  • sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key
  • sodium_crypto_box — Encrypt a message
  • sodium_crypto_generichash_final — Complete the hash
  • sodium_crypto_generichash_init — Initialize a hash
  • sodium_crypto_generichash_keygen — Get random bytes for key
  • sodium_crypto_generichash_update — Add message to a hash
  • sodium_crypto_generichash — Get a hash of the message
  • sodium_crypto_kdf_derive_from_key — Derive a subkey
  • sodium_crypto_kdf_keygen — Get random bytes for key
  • sodium_crypto_kx_client_session_keys — Description
  • sodium_crypto_kx_keypair — Creates a new sodium keypair
  • sodium_crypto_kx_publickey — Description
  • sodium_crypto_kx_secretkey — Description
  • sodium_crypto_kx_seed_keypair — Description
  • sodium_crypto_kx_server_session_keys — Description
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string
  • sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash
  • sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password
  • sodium_crypto_pwhash_str_needs_rehash — Description
  • sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash
  • sodium_crypto_pwhash_str — Get an ASCII-encoded hash
  • sodium_crypto_pwhash — Derive a key from a password
  • sodium_crypto_scalarmult_base — Alias de sodium_crypto_box_publickey_from_secretkey
  • sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key
  • sodium_crypto_secretbox_keygen — Get random bytes for key
  • sodium_crypto_secretbox_open — Verify and decrypt a ciphertext
  • sodium_crypto_secretbox — Encrypt a message
  • sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description
  • sodium_crypto_secretstream_xchacha20poly1305_init_push — Description
  • sodium_crypto_secretstream_xchacha20poly1305_keygen — Description
  • sodium_crypto_secretstream_xchacha20poly1305_pull — Description
  • sodium_crypto_secretstream_xchacha20poly1305_push — Description
  • sodium_crypto_secretstream_xchacha20poly1305_rekey — Description
  • sodium_crypto_shorthash_keygen — Get random bytes for key
  • sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message
  • sodium_crypto_sign_detached — Sign the message
  • sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key
  • sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description
  • sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key
  • sodium_crypto_sign_open — Check that the signed message has a valid signature
  • sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key
  • sodium_crypto_sign_publickey — Description
  • sodium_crypto_sign_secretkey — Description
  • sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key
  • sodium_crypto_sign_verify_detached — Verify signature for the message
  • sodium_crypto_sign — Sign a message
  • sodium_crypto_stream_keygen — Get random bytes for key
  • sodium_crypto_stream_xor — Encrypt a message
  • sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed
  • sodium_hex2bin — Decodes a hexadecimally encoded binary string
  • sodium_increment — Increment large number
  • sodium_memcmp — Test for equality in constant-time
  • sodium_memzero — Overwrite buf with zeros
  • sodium_pad — Add padding data
  • sodium_unpad — Remove padding data


Add large numbers

  • « Sodium Funciones
  • sodium_base642bin »
  • PHP Manual
  • Sodium Funciones
  • Add large numbers

sodium_add

(PHP 7 >= 7.2.0, PHP 8)

sodium_add — Add large numbers

Descripción

sodium_add ( string &$string1 , string $string2 ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string1

string2

Valores devueltos

No devuelve ningún valor.


Description

  • « sodium_add
  • sodium_bin2base64 »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_base642bin

(PHP 7 >= 7.2.0, PHP 8)

sodium_base642bin — Description

Descripción

sodium_base642bin ( string $string , int $id , string $ignore = "" ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

id

ignore

Valores devueltos


Description

  • « sodium_base642bin
  • sodium_bin2hex »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_bin2base64

(PHP 7 >= 7.2.0, PHP 8)

sodium_bin2base64 — Description

Descripción

sodium_bin2base64 ( string $string , int $id ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

id

Valores devueltos


Encode to hexadecimal

  • « sodium_bin2base64
  • sodium_compare »
  • PHP Manual
  • Sodium Funciones
  • Encode to hexadecimal

sodium_bin2hex

(PHP 7 >= 7.2.0, PHP 8)

sodium_bin2hex — Encode to hexadecimal

Descripción

sodium_bin2hex ( string $string ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

Valores devueltos


Compare large numbers

  • « sodium_bin2hex
  • sodium_crypto_aead_aes256gcm_decrypt »
  • PHP Manual
  • Sodium Funciones
  • Compare large numbers

sodium_compare

(PHP 7 >= 7.2.0, PHP 8)

sodium_compare — Compare large numbers

Descripción

sodium_compare ( string $string1 , string $string2 ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string1

string2

Valores devueltos


Decrypt in combined mode with precalculation

  • « sodium_compare
  • sodium_crypto_aead_aes256gcm_encrypt »
  • PHP Manual
  • Sodium Funciones
  • Decrypt in combined mode with precalculation

sodium_crypto_aead_aes256gcm_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation

Descripción

sodium_crypto_aead_aes256gcm_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

additional_data

nonce

key

Valores devueltos


Encrypt in combined mode with precalculation

  • « sodium_crypto_aead_aes256gcm_decrypt
  • sodium_crypto_aead_aes256gcm_is_available »
  • PHP Manual
  • Sodium Funciones
  • Encrypt in combined mode with precalculation

sodium_crypto_aead_aes256gcm_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation

Descripción

sodium_crypto_aead_aes256gcm_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

additional_data

nonce

key

Valores devueltos


Check if hardware supports AES256-GCM

  • « sodium_crypto_aead_aes256gcm_encrypt
  • sodium_crypto_aead_aes256gcm_keygen »
  • PHP Manual
  • Sodium Funciones
  • Check if hardware supports AES256-GCM

sodium_crypto_aead_aes256gcm_is_available

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM

Descripción

sodium_crypto_aead_aes256gcm_is_available ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get random bytes for key

  • « sodium_crypto_aead_aes256gcm_is_available
  • sodium_crypto_aead_chacha20poly1305_decrypt »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_aead_aes256gcm_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key

Descripción

sodium_crypto_aead_aes256gcm_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Verify that the ciphertext includes a valid tag

  • « sodium_crypto_aead_aes256gcm_keygen
  • sodium_crypto_aead_chacha20poly1305_encrypt »
  • PHP Manual
  • Sodium Funciones
  • Verify that the ciphertext includes a valid tag

sodium_crypto_aead_chacha20poly1305_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag

Descripción

sodium_crypto_aead_chacha20poly1305_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

additional_data

nonce

key

Valores devueltos


Encrypt a message

  • « sodium_crypto_aead_chacha20poly1305_decrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_aead_chacha20poly1305_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message

Descripción

sodium_crypto_aead_chacha20poly1305_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

additional_data

nonce

key

Valores devueltos


Verify that the ciphertext includes a valid tag

  • « sodium_crypto_aead_chacha20poly1305_encrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt »
  • PHP Manual
  • Sodium Funciones
  • Verify that the ciphertext includes a valid tag

sodium_crypto_aead_chacha20poly1305_ietf_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag

Descripción

sodium_crypto_aead_chacha20poly1305_ietf_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

additional_data

nonce

key

Valores devueltos


Encrypt a message

  • « sodium_crypto_aead_chacha20poly1305_ietf_decrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_aead_chacha20poly1305_ietf_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message

Descripción

sodium_crypto_aead_chacha20poly1305_ietf_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

additional_data

nonce

key

Valores devueltos


Get random bytes for key

  • « sodium_crypto_aead_chacha20poly1305_ietf_encrypt
  • sodium_crypto_aead_chacha20poly1305_keygen »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_aead_chacha20poly1305_ietf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key

Descripción

sodium_crypto_aead_chacha20poly1305_ietf_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get random bytes for key

  • « sodium_crypto_aead_chacha20poly1305_ietf_keygen
  • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_aead_chacha20poly1305_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key

Descripción

sodium_crypto_aead_chacha20poly1305_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « sodium_crypto_aead_chacha20poly1305_keygen
  • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description

Descripción

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

additional_data

nonce

key

Valores devueltos


Description

  • « sodium_crypto_aead_xchacha20poly1305_ietf_decrypt
  • sodium_crypto_aead_xchacha20poly1305_ietf_keygen »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description

Descripción

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

additional_data

nonce

key

Valores devueltos


Description

  • « sodium_crypto_aead_xchacha20poly1305_ietf_encrypt
  • sodium_crypto_auth_keygen »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description

Descripción

sodium_crypto_aead_xchacha20poly1305_ietf_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get random bytes for key

  • « sodium_crypto_aead_xchacha20poly1305_ietf_keygen
  • sodium_crypto_auth_verify »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_auth_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth_keygen — Get random bytes for key

Descripción

sodium_crypto_auth_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Verifies that the tag is valid for the message

  • « sodium_crypto_auth_keygen
  • sodium_crypto_auth »
  • PHP Manual
  • Sodium Funciones
  • Verifies that the tag is valid for the message

sodium_crypto_auth_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth_verify — Verifies that the tag is valid for the message

Descripción

sodium_crypto_auth_verify ( string $mac , string $message , string $key ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mac

message

key

Valores devueltos


Compute a tag for the message

  • « sodium_crypto_auth_verify
  • sodium_crypto_box_keypair_from_secretkey_and_publickey »
  • PHP Manual
  • Sodium Funciones
  • Compute a tag for the message

sodium_crypto_auth

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth — Compute a tag for the message

Descripción

sodium_crypto_auth ( string $message , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

key

Valores devueltos


Description

  • « sodium_crypto_auth
  • sodium_crypto_box_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_box_keypair_from_secretkey_and_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_keypair_from_secretkey_and_publickey — Description

Descripción

sodium_crypto_box_keypair_from_secretkey_and_publickey ( string $secret_key , string $public_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

secret_key

public_key

Valores devueltos


Randomly generate a secret key and a corresponding public key

  • « sodium_crypto_box_keypair_from_secretkey_and_publickey
  • sodium_crypto_box_open »
  • PHP Manual
  • Sodium Funciones
  • Randomly generate a secret key and a corresponding public key

sodium_crypto_box_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key

Descripción

sodium_crypto_box_keypair ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Verify and decrypt a ciphertext

  • « sodium_crypto_box_keypair
  • sodium_crypto_box_publickey_from_secretkey »
  • PHP Manual
  • Sodium Funciones
  • Verify and decrypt a ciphertext

sodium_crypto_box_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_open — Verify and decrypt a ciphertext

Descripción

sodium_crypto_box_open ( string $ciphertext , string $nonce , string $key_pair ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

nonce

key_pair

Valores devueltos


Description

  • « sodium_crypto_box_open
  • sodium_crypto_box_publickey »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_box_publickey_from_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_publickey_from_secretkey — Description

Descripción

sodium_crypto_box_publickey_from_secretkey ( string $secret_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

secret_key

Valores devueltos


Description

  • « sodium_crypto_box_publickey_from_secretkey
  • sodium_crypto_box_seal_open »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_box_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_publickey — Description

Descripción

sodium_crypto_box_publickey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Decrypt the ciphertext

  • « sodium_crypto_box_publickey
  • sodium_crypto_box_seal »
  • PHP Manual
  • Sodium Funciones
  • Decrypt the ciphertext

sodium_crypto_box_seal_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seal_open — Decrypt the ciphertext

Descripción

sodium_crypto_box_seal_open ( string $ciphertext , string $key_pair ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

key_pair

Valores devueltos


Encrypt a message

  • « sodium_crypto_box_seal_open
  • sodium_crypto_box_secretkey »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_box_seal

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seal — Encrypt a message

Descripción

sodium_crypto_box_seal ( string $message , string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

key_pair

Valores devueltos


Description

  • « sodium_crypto_box_seal
  • sodium_crypto_box_seed_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_box_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_secretkey — Description

Descripción

sodium_crypto_box_secretkey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Deterministically derive the key pair from a single key

  • « sodium_crypto_box_secretkey
  • sodium_crypto_box »
  • PHP Manual
  • Sodium Funciones
  • Deterministically derive the key pair from a single key

sodium_crypto_box_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key

Descripción

sodium_crypto_box_seed_keypair ( string $seed ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

seed

Valores devueltos


Encrypt a message

  • « sodium_crypto_box_seed_keypair
  • sodium_crypto_generichash_final »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_box

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box — Encrypt a message

Descripción

sodium_crypto_box ( string $message , string $nonce , string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

nonce

key_pair

Valores devueltos


Complete the hash

  • « sodium_crypto_box
  • sodium_crypto_generichash_init »
  • PHP Manual
  • Sodium Funciones
  • Complete the hash

sodium_crypto_generichash_final

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_final — Complete the hash

Descripción

sodium_crypto_generichash_final ( string &$state , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

state

length

Valores devueltos


Initialize a hash

  • « sodium_crypto_generichash_final
  • sodium_crypto_generichash_keygen »
  • PHP Manual
  • Sodium Funciones
  • Initialize a hash

sodium_crypto_generichash_init

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_init — Initialize a hash

Descripción

sodium_crypto_generichash_init ( string $key = "" , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key

length

Valores devueltos


Get random bytes for key

  • « sodium_crypto_generichash_init
  • sodium_crypto_generichash_update »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_generichash_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_keygen — Get random bytes for key

Descripción

sodium_crypto_generichash_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Add message to a hash

  • « sodium_crypto_generichash_keygen
  • sodium_crypto_generichash »
  • PHP Manual
  • Sodium Funciones
  • Add message to a hash

sodium_crypto_generichash_update

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_update — Add message to a hash

Descripción

sodium_crypto_generichash_update ( string &$state , string $message ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

state

message

Valores devueltos


Get a hash of the message

  • « sodium_crypto_generichash_update
  • sodium_crypto_kdf_derive_from_key »
  • PHP Manual
  • Sodium Funciones
  • Get a hash of the message

sodium_crypto_generichash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash — Get a hash of the message

Descripción

sodium_crypto_generichash ( string $message , string $key = "" , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

key

length

Valores devueltos


Derive a subkey

  • « sodium_crypto_generichash
  • sodium_crypto_kdf_keygen »
  • PHP Manual
  • Sodium Funciones
  • Derive a subkey

sodium_crypto_kdf_derive_from_key

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kdf_derive_from_key — Derive a subkey

Descripción

sodium_crypto_kdf_derive_from_key ( int $subkey_length , int $subkey_id , string $context , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

subkey_length

subkey_id

context

key

Valores devueltos


Get random bytes for key

  • « sodium_crypto_kdf_derive_from_key
  • sodium_crypto_kx_client_session_keys »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_kdf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kdf_keygen — Get random bytes for key

Descripción

sodium_crypto_kdf_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « sodium_crypto_kdf_keygen
  • sodium_crypto_kx_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_kx_client_session_keys

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_client_session_keys — Description

Descripción

sodium_crypto_kx_client_session_keys ( string $client_key_pair , string $server_key ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

client_key_pair

server_key

Valores devueltos


Creates a new sodium keypair

  • « sodium_crypto_kx_client_session_keys
  • sodium_crypto_kx_publickey »
  • PHP Manual
  • Sodium Funciones
  • Creates a new sodium keypair

sodium_crypto_kx_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_keypair — Creates a new sodium keypair

Descripción

sodium_crypto_kx_keypair ( ) : string

Create a new sodium keypair consisting of the secret key (32 bytes) followed by the public key (32 bytes). The keys can be retrieved by calling sodium_crypto_kx_secretkey() and sodium_crypto_kx_publickey(), respectively.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the new keypair on success; throws an exception otherwise.

Ejemplos

Ejemplo #1 sodium_crypto_kx_keypair() usage

Create a new keypair and retrieve the secret and the public key from it.

<?php
$keypair = sodium_crypto_kx_keypair();
$secret = sodium_crypto_kx_secretkey($keypair);
$public = sodium_crypto_kx_publickey($keypair);
printf("secret: %s\npublic: %s", bin2hex($secret), bin2hex($public));
?>

El resultado del ejemplo sería algo similar a:

secret: e7c5c918fdc40762e6000542c0118f4368ce8fd242b0e48c1e17202797a25daf
public: d1f59fda8652caf40ed1a01d2b6f3802b60846986372cd8fa337b7c12c428b18


Description

  • « sodium_crypto_kx_keypair
  • sodium_crypto_kx_secretkey »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_kx_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_publickey — Description

Descripción

sodium_crypto_kx_publickey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Description

  • « sodium_crypto_kx_publickey
  • sodium_crypto_kx_seed_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_kx_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_secretkey — Description

Descripción

sodium_crypto_kx_secretkey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Description

  • « sodium_crypto_kx_secretkey
  • sodium_crypto_kx_server_session_keys »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_kx_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_seed_keypair — Description

Descripción

sodium_crypto_kx_seed_keypair ( string $seed ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

seed

Valores devueltos


Description

  • « sodium_crypto_kx_seed_keypair
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_kx_server_session_keys

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_server_session_keys — Description

Descripción

sodium_crypto_kx_server_session_keys ( string $server_key_pair , string $client_key ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

server_key_pair

client_key

Valores devueltos


Verify that the password is a valid password verification string

  • « sodium_crypto_kx_server_session_keys
  • sodium_crypto_pwhash_scryptsalsa208sha256_str »
  • PHP Manual
  • Sodium Funciones
  • Verify that the password is a valid password verification string

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string

Descripción

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify ( string $hash , string $password ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

hash

password

Valores devueltos


Get an ASCII encoded hash

  • « sodium_crypto_pwhash_scryptsalsa208sha256_str_verify
  • sodium_crypto_pwhash_scryptsalsa208sha256 »
  • PHP Manual
  • Sodium Funciones
  • Get an ASCII encoded hash

sodium_crypto_pwhash_scryptsalsa208sha256_str

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash

Descripción

sodium_crypto_pwhash_scryptsalsa208sha256_str ( string $password , int $opslimit , int $memlimit ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

password

opslimit

memlimit

Valores devueltos


Derives a key from a password

  • « sodium_crypto_pwhash_scryptsalsa208sha256_str
  • sodium_crypto_pwhash_str_needs_rehash »
  • PHP Manual
  • Sodium Funciones
  • Derives a key from a password

sodium_crypto_pwhash_scryptsalsa208sha256

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password

Descripción

sodium_crypto_pwhash_scryptsalsa208sha256 ( int $length , string $password , string $salt , int $opslimit , int $memlimit ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

length

password

salt

opslimit

memlimit

Valores devueltos


Description

  • « sodium_crypto_pwhash_scryptsalsa208sha256
  • sodium_crypto_pwhash_str_verify »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_pwhash_str_needs_rehash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str_needs_rehash — Description

Descripción

sodium_crypto_pwhash_str_needs_rehash ( string $password , int $opslimit , int $memlimit ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

password

opslimit

memlimit

Valores devueltos


Verifies that a password matches a hash

  • « sodium_crypto_pwhash_str_needs_rehash
  • sodium_crypto_pwhash_str »
  • PHP Manual
  • Sodium Funciones
  • Verifies that a password matches a hash

sodium_crypto_pwhash_str_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash

Descripción

sodium_crypto_pwhash_str_verify ( string $hash , string $password ) : bool

Checks that a password hash created using sodium_crypto_pwhash_str() matches a given plain-text password. Note that the parameters are in the opposite order to the same parameters in the similar password_hash() function.

Parámetros

hash

Un hash creado por password_hash().

password

La contraseña del usuario.

Valores devueltos

Returns true if the password and hash match, or false otherwise.

Notas

Nota:

Hashes are calculated using the Argon2ID algorithm, providing resistance to both GPU and side-channel attacks.

Ver también

  • sodium_crypto_pwhash_str() - Get an ASCII-encoded hash
  • password_hash() - Crea un hash de contraseña
  • password_verify() - Comprueba que la contraseña coincida con un hash


Get an ASCII-encoded hash

  • « sodium_crypto_pwhash_str_verify
  • sodium_crypto_pwhash »
  • PHP Manual
  • Sodium Funciones
  • Get an ASCII-encoded hash

sodium_crypto_pwhash_str

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str — Get an ASCII-encoded hash

Descripción

sodium_crypto_pwhash_str ( string $password , int $opslimit , int $memlimit ) : string

Uses a CPU- and memory-hard hash algorithm along with a randomly-generated salt, and memory and CPU limits to generate an ASCII-encoded hash suitable for password storage.

Parámetros

password

string; The password to generate a hash for.

opslimit

Represents a maximum amount of computations to perform. Raising this number will make the function require more CPU cycles to compute a key. There are constants available to set the operations limit to appropriate values depending on intended use, in order of strength: SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE and SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE.

memlimit

The maximum amount of RAM that the function will use, in bytes. There are constants to help you choose an appropriate value, in order of size: SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE, and SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE. Typically these should be paired with the matching opslimit values.

Valores devueltos

Returns the hashed password.

In order to produce the same password hash from the same password, the same values for opslimit and memlimit must be used. These are embedded within the generated hash, so everything that's needed to verify the hash is included. This allows the sodium_crypto_pwhash_str_verify() function to verify the hash without needing separate storage for the other parameters.

Notas

Nota:

Hashes are calculated using the Argon2ID algorithm, providing resistance to both GPU and side-channel attacks. In contrast to the password_hash() function, there is no salt parameter (a salt is generated automatically), and the opslimit and memlimit parameters are not optional.

Ejemplos

Ejemplo #1 password_hash() example

<?php
$password = 'password';
echo sodium_crypto_pwhash_str(
    $password,
    SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE,
    SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE
);

El resultado del ejemplo sería algo similar a:

$argon2id$v=19$m=65536,t=2,p=1$oWIfdaXwWwhVmovOBc2NAQ$EbsZ+JnZyyavkafS0hoc4HdaOB0ILWZESAZ7kVGa+Iw

Ver también

  • sodium_crypto_pwhash_str_verify() - Verifies that a password matches a hash
  • sodium_crypto_pwhash() - Derive a key from a password
  • password_hash() - Crea un hash de contraseña
  • password_verify() - Comprueba que la contraseña coincida con un hash
  • » Libsodium Argon2 docs


Derive a key from a password

  • « sodium_crypto_pwhash_str
  • sodium_crypto_scalarmult_base »
  • PHP Manual
  • Sodium Funciones
  • Derive a key from a password

sodium_crypto_pwhash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash — Derive a key from a password

Descripción

sodium_crypto_pwhash ( int $length , string $password , string $salt , int $opslimit , int $memlimit , int $algo = SODIUM_CRYPTO_PWHASH_ALG_DEFAULT ) : string

This function provides low-level access to libsodium's crypto_pwhash key derivation function. Unless you have specific reason to use this function, you should use sodium_crypto_pwhash_str() or password_hash() functions instead.

Parámetros

length

int; The length of the password hash to generate, in bytes.

password

string; The password to generate a hash for.

salt

string A salt to add to the password before hashing. The salt should be unpredictable, ideally generated from a good random mumber source such as random_bytes(), and have a length of at least SODIUM_CRYPTO_PWHASH_SALTBYTES bytes.

opslimit

Represents a maximum amount of computations to perform. Raising this number will make the function require more CPU cycles to compute a key. There are some constants available to set the operations limit to appropriate values depending on intended use, in order of strength: SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE and SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE.

memlimit

The maximum amount of RAM that the function will use, in bytes. There are constants to help you choose an appropriate value, in order of size: SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE, and SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE. Typically these should be paired with the matching opslimit values.

algo

int A number indicating the hash algorithm to use. By default SODIUM_CRYPTO_PWHASH_ALG_DEFAULT (the currently recommended algorithm, which can change from one version of libsodium to another), or explicitly using SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13, representing the Argon2id algorithm version 1.3.

Valores devueltos

Returns the derived key. The return value is a binary string of the hash, not an ASCII-encoded representation, and does not contain additional information about the parameters used to create the hash, so you will need to keep that information if you are ever going to verify the password in future. Use sodium_crypto_pwhash_str() to avoid needing to do all that.

Ejemplos

Ejemplo #1 password_hash() example

<?php
//Need to keep the salt if we're ever going to be able to check this password
$salt = random_bytes(SODIUM_CRYPTO_PWHASH_SALTBYTES);
//Using bin2hex to keep output readable
echo bin2hex(
    sodium_crypto_pwhash(
        16, // == 128 bits
        'password',
        $salt,
        SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE,
        SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE,
        SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13
    )
);
?>

El resultado del ejemplo sería algo similar a:

a18f346ba57992eb7e4ae6abf3fd30ee


Alias de sodium_crypto_box_publickey_from_secretkey

  • « sodium_crypto_pwhash
  • sodium_crypto_scalarmult »
  • PHP Manual
  • Sodium Funciones
  • Alias de sodium_crypto_box_publickey_from_secretkey

sodium_crypto_scalarmult_base

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_scalarmult_base — Alias de sodium_crypto_box_publickey_from_secretkey()

Descripción

Esta función es un alias de: sodium_crypto_box_publickey_from_secretkey().


Compute a shared secret given a user's secret key and another user's public key

  • « sodium_crypto_scalarmult_base
  • sodium_crypto_secretbox_keygen »
  • PHP Manual
  • Sodium Funciones
  • Compute a shared secret given a user's secret key and another user's public key

sodium_crypto_scalarmult

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key

Descripción

sodium_crypto_scalarmult ( string $n , string $p ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

n

p

Valores devueltos


Get random bytes for key

  • « sodium_crypto_scalarmult
  • sodium_crypto_secretbox_open »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_secretbox_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox_keygen — Get random bytes for key

Descripción

sodium_crypto_secretbox_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Verify and decrypt a ciphertext

  • « sodium_crypto_secretbox_keygen
  • sodium_crypto_secretbox »
  • PHP Manual
  • Sodium Funciones
  • Verify and decrypt a ciphertext

sodium_crypto_secretbox_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox_open — Verify and decrypt a ciphertext

Descripción

sodium_crypto_secretbox_open ( string $ciphertext , string $nonce , string $key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

nonce

key

Valores devueltos


Encrypt a message

  • « sodium_crypto_secretbox_open
  • sodium_crypto_secretstream_xchacha20poly1305_init_pull »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_secretbox

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox — Encrypt a message

Descripción

sodium_crypto_secretbox ( string $message , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

nonce

key

Valores devueltos


Description

  • « sodium_crypto_secretbox
  • sodium_crypto_secretstream_xchacha20poly1305_init_push »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_init_pull

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_init_pull ( string $header , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

header

key

Valores devueltos


Description

  • « sodium_crypto_secretstream_xchacha20poly1305_init_pull
  • sodium_crypto_secretstream_xchacha20poly1305_keygen »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_init_push

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_init_push — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_init_push ( string $key ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key

Valores devueltos


Description

  • « sodium_crypto_secretstream_xchacha20poly1305_init_push
  • sodium_crypto_secretstream_xchacha20poly1305_pull »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_keygen — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « sodium_crypto_secretstream_xchacha20poly1305_keygen
  • sodium_crypto_secretstream_xchacha20poly1305_push »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_pull

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_pull — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_pull ( string &$state , string $ciphertext , string $additional_data = "" ) : array|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

state

ciphertext

additional_data

Valores devueltos


Description

  • « sodium_crypto_secretstream_xchacha20poly1305_pull
  • sodium_crypto_secretstream_xchacha20poly1305_rekey »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_push

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_push — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_push ( string &$state , string $message , string $additional_data = "" , int $tag = SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_MESSAGE ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

state

message

additional_data

tag

Valores devueltos


Description

  • « sodium_crypto_secretstream_xchacha20poly1305_push
  • sodium_crypto_shorthash_keygen »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_secretstream_xchacha20poly1305_rekey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_rekey — Description

Descripción

sodium_crypto_secretstream_xchacha20poly1305_rekey ( string &$state ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

state

Valores devueltos


Get random bytes for key

  • « sodium_crypto_secretstream_xchacha20poly1305_rekey
  • sodium_crypto_shorthash »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_shorthash_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_shorthash_keygen — Get random bytes for key

Descripción

sodium_crypto_shorthash_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Compute a fixed-size fingerprint for the message

  • « sodium_crypto_shorthash_keygen
  • sodium_crypto_sign_detached »
  • PHP Manual
  • Sodium Funciones
  • Compute a fixed-size fingerprint for the message

sodium_crypto_shorthash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message

Descripción

sodium_crypto_shorthash ( string $message , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

key

Valores devueltos


Sign the message

  • « sodium_crypto_shorthash
  • sodium_crypto_sign_ed25519_pk_to_curve25519 »
  • PHP Manual
  • Sodium Funciones
  • Sign the message

sodium_crypto_sign_detached

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_detached — Sign the message

Descripción

sodium_crypto_sign_detached ( string $message , string $secret_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

secret_key

Valores devueltos


Convert an Ed25519 public key to a Curve25519 public key

  • « sodium_crypto_sign_detached
  • sodium_crypto_sign_ed25519_sk_to_curve25519 »
  • PHP Manual
  • Sodium Funciones
  • Convert an Ed25519 public key to a Curve25519 public key

sodium_crypto_sign_ed25519_pk_to_curve25519

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key

Descripción

sodium_crypto_sign_ed25519_pk_to_curve25519 ( string $public_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

public_key

Valores devueltos


Convert an Ed25519 secret key to a Curve25519 secret key

  • « sodium_crypto_sign_ed25519_pk_to_curve25519
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey »
  • PHP Manual
  • Sodium Funciones
  • Convert an Ed25519 secret key to a Curve25519 secret key

sodium_crypto_sign_ed25519_sk_to_curve25519

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key

Descripción

sodium_crypto_sign_ed25519_sk_to_curve25519 ( string $secret_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

secret_key

Valores devueltos


Description

  • « sodium_crypto_sign_ed25519_sk_to_curve25519
  • sodium_crypto_sign_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_sign_keypair_from_secretkey_and_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description

Descripción

sodium_crypto_sign_keypair_from_secretkey_and_publickey ( string $secret_key , string $public_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

secret_key

public_key

Valores devueltos


Randomly generate a secret key and a corresponding public key

  • « sodium_crypto_sign_keypair_from_secretkey_and_publickey
  • sodium_crypto_sign_open »
  • PHP Manual
  • Sodium Funciones
  • Randomly generate a secret key and a corresponding public key

sodium_crypto_sign_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key

Descripción

sodium_crypto_sign_keypair ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Check that the signed message has a valid signature

  • « sodium_crypto_sign_keypair
  • sodium_crypto_sign_publickey_from_secretkey »
  • PHP Manual
  • Sodium Funciones
  • Check that the signed message has a valid signature

sodium_crypto_sign_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_open — Check that the signed message has a valid signature

Descripción

sodium_crypto_sign_open ( string $ciphertext , string $public_key ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ciphertext

public_key

Valores devueltos


Extract the public key from the secret key

  • « sodium_crypto_sign_open
  • sodium_crypto_sign_publickey »
  • PHP Manual
  • Sodium Funciones
  • Extract the public key from the secret key

sodium_crypto_sign_publickey_from_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key

Descripción

sodium_crypto_sign_publickey_from_secretkey ( string $secret_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

secret_key

Valores devueltos


Description

  • « sodium_crypto_sign_publickey_from_secretkey
  • sodium_crypto_sign_secretkey »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_sign_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_publickey — Description

Descripción

sodium_crypto_sign_publickey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Description

  • « sodium_crypto_sign_publickey
  • sodium_crypto_sign_seed_keypair »
  • PHP Manual
  • Sodium Funciones
  • Description

sodium_crypto_sign_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_secretkey — Description

Descripción

sodium_crypto_sign_secretkey ( string $key_pair ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key_pair

Valores devueltos


Deterministically derive the key pair from a single key

  • « sodium_crypto_sign_secretkey
  • sodium_crypto_sign_verify_detached »
  • PHP Manual
  • Sodium Funciones
  • Deterministically derive the key pair from a single key

sodium_crypto_sign_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key

Descripción

sodium_crypto_sign_seed_keypair ( string $seed ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

seed

Valores devueltos


Verify signature for the message

  • « sodium_crypto_sign_seed_keypair
  • sodium_crypto_sign »
  • PHP Manual
  • Sodium Funciones
  • Verify signature for the message

sodium_crypto_sign_verify_detached

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_verify_detached — Verify signature for the message

Descripción

sodium_crypto_sign_verify_detached ( string $signature , string $message , string $public_key ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

signature

message

public_key

Valores devueltos


Sign a message

  • « sodium_crypto_sign_verify_detached
  • sodium_crypto_stream_keygen »
  • PHP Manual
  • Sodium Funciones
  • Sign a message

sodium_crypto_sign

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign — Sign a message

Descripción

sodium_crypto_sign ( string $message , string $secret_key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

secret_key

Valores devueltos


Get random bytes for key

  • « sodium_crypto_sign
  • sodium_crypto_stream_xor »
  • PHP Manual
  • Sodium Funciones
  • Get random bytes for key

sodium_crypto_stream_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream_keygen — Get random bytes for key

Descripción

sodium_crypto_stream_keygen ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Encrypt a message

  • « sodium_crypto_stream_keygen
  • sodium_crypto_stream »
  • PHP Manual
  • Sodium Funciones
  • Encrypt a message

sodium_crypto_stream_xor

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream_xor — Encrypt a message

Descripción

sodium_crypto_stream_xor ( string $message , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

message

nonce

key

Valores devueltos


Generate a deterministic sequence of bytes from a seed

  • « sodium_crypto_stream_xor
  • sodium_hex2bin »
  • PHP Manual
  • Sodium Funciones
  • Generate a deterministic sequence of bytes from a seed

sodium_crypto_stream

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed

Descripción

sodium_crypto_stream ( int $length , string $nonce , string $key ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

length

nonce

key

Valores devueltos


Decodes a hexadecimally encoded binary string

  • « sodium_crypto_stream
  • sodium_increment »
  • PHP Manual
  • Sodium Funciones
  • Decodes a hexadecimally encoded binary string

sodium_hex2bin

(PHP 7 >= 7.2.0, PHP 8)

sodium_hex2bin — Decodes a hexadecimally encoded binary string

Descripción

sodium_hex2bin ( string $string , string $ignore = "" ) : string

Decodes a hexadecimally encoded binary string.

Like sodium_bin2hex(), sodium_hex2bin() is resistant to side-channel attacks while hex2bin() is not.

Parámetros

string

Hexadecimal representation of data.

ignore

Optional string argument for characters to ignore.

Valores devueltos

Returns the binary representation of the given string data.


Increment large number

  • « sodium_hex2bin
  • sodium_memcmp »
  • PHP Manual
  • Sodium Funciones
  • Increment large number

sodium_increment

(PHP 7 >= 7.2.0, PHP 8)

sodium_increment — Increment large number

Descripción

sodium_increment ( string &$string ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

Valores devueltos


Test for equality in constant-time

  • « sodium_increment
  • sodium_memzero »
  • PHP Manual
  • Sodium Funciones
  • Test for equality in constant-time

sodium_memcmp

(PHP 7 >= 7.2.0, PHP 8)

sodium_memcmp — Test for equality in constant-time

Descripción

sodium_memcmp ( string $string1 , string $string2 ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string1

string2

Valores devueltos


Overwrite buf with zeros

  • « sodium_memcmp
  • sodium_pad »
  • PHP Manual
  • Sodium Funciones
  • Overwrite buf with zeros

sodium_memzero

(PHP 7 >= 7.2.0, PHP 8)

sodium_memzero — Overwrite buf with zeros

Descripción

sodium_memzero ( string &$string ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

Valores devueltos


Add padding data

  • « sodium_memzero
  • sodium_unpad »
  • PHP Manual
  • Sodium Funciones
  • Add padding data

sodium_pad

(PHP 7 >= 7.2.0, PHP 8)

sodium_pad — Add padding data

Descripción

sodium_pad ( string $string , int $length ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

length

Valores devueltos


Remove padding data

  • « sodium_pad
  • SodiumException »
  • PHP Manual
  • Sodium Funciones
  • Remove padding data

sodium_unpad

(PHP 7 >= 7.2.0, PHP 8)

sodium_unpad — Remove padding data

Descripción

sodium_unpad ( string $string , int $block_size ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

block_size

Valores devueltos


The SodiumException class

(PHP 7 >= 7.2.0, PHP 8)

Introducción

Exceptions thrown by the sodium functions.

Sinopsis de la Clase

SodiumException extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Extensiones de bases de datos

  • Capas abstractas
    • DBA — Capa de Abstracción de Base de Datos (estilo dbm)
    • ODBC — ODBC (Unificada)
    • PDO — Objetos de datos de PHP
  • Extensiones de bases de datos específicas del proveedor
    • CUBRID
    • DB++
    • dBase
    • filePro
    • Firebird/InterBase
    • FrontBase
    • IBM DB2 — IBM DB2, Cloudscape y Apache Derby
    • Ingres — Ingres DBMS, EDBC, y Enterprise Access Gateways
    • Mongo — Controlador de MongoDB (antiguo)
    • MongoDB — Controlador de MongoDB
    • MySQL — Controladores y complementos de MySQL
    • OCI8 — Oracle OCI8
    • Paradox — Acceso a archivos Paradox
    • PostgreSQL
    • SQLite3
    • SQLSRV — Driver de Microsoft SQL Server para PHP
    • tokyo_tyrant


Capas abstractas

  • DBA — Capa de Abstracción de Base de Datos (estilo dbm)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de DBA
  • ODBC — ODBC (Unificada)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones ODBC
  • PDO — Objetos de datos de PHP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Conexiones y su administración
    • Transacciones y autoconsigna ("auto-commit")
    • Sentencias preparadas y procedimientos almacenados
    • Errores y su manejo
    • Objetos grandes (LOB)
    • PDO — La clase PDO
    • PDOStatement — La clase PDOStatement
    • PDOException — La clase PDOException
    • Controladores de PDO


Capa de Abstracción de Base de Datos (estilo dbm)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones de DBA
    • dba_close — Cerrar una base de datos DBA
    • dba_delete — Elimina una entrada DBA especificada por clave
    • dba_exists — Verificar si la clave existe
    • dba_fetch — Recuperar datos especificados por clave
    • dba_firstkey — Recuperar la primera clave
    • dba_handlers — Listar todos los gestores disponibles
    • dba_insert — Insertar entrada
    • dba_key_split — Separa una clave en representación de cadena en representación de array
    • dba_list — Listar todos los archivos de base de datos abiertos
    • dba_nextkey — Recuperar la siguiente clave
    • dba_open — Abrir una base de datos
    • dba_optimize — Optimizar base de datos
    • dba_popen — Abrir una base de datos de forma persistente
    • dba_replace — Reemplazar o insertar una entrada
    • dba_sync — Sincronizar base de datos


Introducción

Estas funciones construyen los cimientos para acceder a las bases de datos estilo Berkeley DB.

Es una capa de abstracción general para varias bases de datos basadas en ficheros. Como tal, la funcionalidad está limitada a un subconjunto común de características admitidas por las bases de datos modernas como » Oracle Berkeley DB.


Requerimientos

El comportamiento de varios aspectos depende de la implementación de la base de datos subyacente. Funciones tales como dba_optimize() y dba_sync() harán que se prometa para una base de datos y no harán nada para otras. Tiene que descargar e instalar los gestores de dba soportados.

Lista de los gestores de DBA
Gestor | Notas
dbm | Dbm es el tipo más antiguo (original) de las bases de datos estilo Berkeley DB. Se debería evitar si es posible. No se tiene soporte para la compatibilidad de funciones contruidas dentrode DB2 y gdbm, ya que sólo son compatibles con el nivel de código fuente, pero no pueden manejar el formato original de dbm.
ndbm | Ndbm es un tipo más reciente y flexible que dbm. Todavía tiene la mayoría de los límites arbitrarios de dbm (aunque está obsoleto).
gdbm | Gdbm es el » GNU database manager.
db2 | DB2 es para » Oracle Berkeley DB 2. Está descrito como "un conjunto de herramientas programático que proporciona soporte para bases de datos internas de alto rendimiento para aplicaciones autónomas y de cliente/servidor".
db3 | DB3 es para » Oracle Berkeley DB 3.
db4 | DB4 es para » Oracle Berkeley DB 4 o 5. Esta opción está disponible desde PHP 4.3.2. Se puede usar con BDB 5 desde PHP 5.3.3.
cdb | Cdb es "un paquete rápido, fiable, ligero para crear y leer bases de datos constantes." Es del autor de qmail y se puede encontrar en » http://cr.yp.to/cdb.html. Ya que es consntante, solo se soportan las operaciones de lectura. Y desde PHP 4.3.0 se soporta la escritura (no la actualización) a través de la biblioteca interna de cdb.
cdb_make | Desde PHP 4.3.0 se soporta la creación (no la actualización) de ficheros cdb cuando se usa la biblioteca interna cdb.
flatfile | Está disponible desde PHP 4.3.0 únicamente para la compatibilidad con la extensión obsoleta dbm y debería de evitarse. Sin embargo, se puede usar para los ficheros creados con este formato. Esto ocurre cuando configure no puede encontrar una biblioteca externa.
inifile | Está disponible desde PHP 4.3.3 para ser capaz de modificar ficheros php.ini desde dentro de scripts de PHP. Cuando se trabaja con ficheros ini se pueden pasar arrays de la forma array(0=>grupo,1=>nombre_valor) o cadenas de la forma "[grupo]nombre_valor" donde grupo es opcional. Ya que las funciones dba_firstkey() y dba_nextkey() devuelve una cadenas que representan la clave, existe una nueva función, dba_key_split(), disponbile desde PHP 5, la cual permite convertir las claves de cadena en claves de array sin ocasionar false.
qdbm | Está disponilbe desde PHP 5.0.0. La biblioteca qdbm se puede cargar desde » http://fallabs.com/qdbm/index.html.

Cuando se invoca a las funciones dba_open() o dba_popen(), se debe proporcionar uno de los nombres de gestores como argumento. La lista real de gestores disponibles se muestra invocando a phpinfo() o dba_handlers().


Instalación

Usando la opción de configuración --enable-dba=shared se puede construir un módulo cargable dinámico para habilitar PHP para el soporte básico de bases de datos estilo dbm. También se tiene que añadir soporte para al menos uno de los siguientes gestores especificando el conmutador --with-XXXX de configure a la línea de configuración de PHP.

Advertencia

Después de configurar y compilar PHP debe ejecutar la siguiente prueba desde la línea de comandos: php run-tests.php ext/dba. Esto muestra si la combinación de gestores funciona. Los más problemáticos son dbm y ndbm ya que entran en conflicto con muchas instalaciones. La razón de esto es que en muchos sistemas estas bibliotecas son parte de más de una biblioteca. La prueba de configuración sólo previene del malfuncionamiento de configuración de gestores únicos, pero no de combinaciones.

Gestores de DBA soportados
Gestor | Conmuntador de Configuración
dbm

Para habilitar el soporte para dbm añada --with-dbm[=DIR].

Nota:

dbm es normalmente una envoltura que a menudo resulta en fallo. Esto significa que debería usar dbm sólo si está seguro de que funciona y que realmente necesita este formato.

ndbm

Para habilitar el soporte para ndbm añada --with-ndbm[=DIR].

Nota:

ndbm es normalmente una envoltura que a menudo resulta en fallo. Esto significa que debería usar ndbm sólo si está seguro de que funciona y que realmente necesita este formato.

gdbm | Para habilitar el soporte para gdbm añada --with-gdbm[=DIR].
db2

Para habilitar el soporte para Oracle Berkeley DB 2 añada --with-db2[=DIR].

Nota:

db2 entra en conflicto con db3 y db4.

db3

Para habilitar el soporte para Oracle Berkeley DB 3 añada --with-db3[=DIR].

Nota:

db3 entra en conflicto con db2 y db4.

db4

Para habilitar el soporte para Oracle Berkeley DB 4 o 5 añada --with-db4[=DIR].

Nota:

db4 entra en conflicto con db3 y db3.

Nota:

La opción db4 se añadió en PHP 4.3.2. En versiones anteriores de PHP se necesita usar --with-db3=DIR, siendo DIR la ruta a la biblioteca db4. No es posible usar versiones de db de 4.1 en adelante con PHP anterior a la versión 4.3.0. También, las bibliotecas db con versiones 4.1 hasta 4.1.24 no se pueden usar en ninguna versión de PHP.

Se añadión el soporte para BDB 5 en PHP 5.3.3.

cdb

Para habilitar el soporte para cdb añada --with-cdb[=DIR].

Nota:

Desde PHP 4.3.0 se puede omitir DIR para usar la biblioteca cdb incluida que añade el gestor cdb_make, el cual permite la creación de ficheros cdb y el acceso a ficheros cdb en la red usando flujos de PHP.

flatfile

Para habilitar el soporte para flatfile añada --with-flatfile.

Nota:

Esto se añadio en PHP 4.3.0 para añadir compatibilidad con la extensión dbm obsoleta. Use este gestor solamente cuando no pueda instalar una de las bibliotecas requeridas por otros gestores y cuando no pueda usar el gestor cdb interno.

inifile

Para habilitar el soporte para inifile añada --with-inifile.

Nota:

Esto se añadió en PHP 5.0.0 y permite leer y establecer ficheros .ini estilo microsoft (como el fichero php.ini).

qdbm

Para habilitar el soporte para qdbm añada --with-qdbm[=DIR].

Nota:

qdbm entra en conflicto con dbm y gdbm.

Nota:

Esto se añadió en PHP 5.0.0. La biblioteca qdbm puede ser cargada desde » http://fallabs.com/qdbm/index.html.

Nota:

Hasta PHP 4.3.0 se puede añadir el gestor db2 y db3 pero sólo uno de ellos se puede usar internamente. Esto significa que no se pueden tener ambos formatos de fichero. Desde PHP 5.0.0 existe una comprobación de configuración que evita tales configuraciones erróneas.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

DBA Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
dba.default_handler | DBA_DEFAULT | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

dba.default_handler string

El nombre del gestor predeterminado


Tipos de recursos

Las funciones dba_open() y dba_popen() devuelven un gestor al fichero de base de datos especificado que se va a acceder, el cual es usado por las demás llamadas a funciones dba.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • DBA
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • DBA
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo #1 Ejemplo de DBA

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if (!$id) {
    echo "Falló dba_open\n";
    exit;
}

dba_replace("key", "¡Este es un ejemplo!", $id);

if (dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA es seguro a nivel binario y no tiene límites arbitrarios. Sin embargo, hereda todos los límites establecidos por la implementación de la base de datos subyacente.

Todas las bases de datos basadas en ficheros deben proporcionar una manera de establecer el modo de fichero de una nueva base de datos creada, si es posible. El modo de fichero se pasa comúnmente como el cuarto argumento a dba_open() o dba_popen().

Se puede acceder a todas las entradas de una base de datos de forma lineal usando las funciones dba_firstkey() y dba_nextkey(). No se puede cambiar la base de datos mientras se la atraviesa.

Ejemplo #2 Atravesar una base de datos

<?php

// ...abrir la base de datos...

$clave = dba_firstkey($id);

while ($clave != false) {
    if (true) {          // recuerde la clave para realizar alguna acción posterior
        $handle_later[] = $clave;
    }
    $clave = dba_nextkey($id);
}

foreach ($handle_later as $val) {
    dba_delete($val, $id);
}

?>


Funciones de DBA

Tabla de contenidos

  • dba_close — Cerrar una base de datos DBA
  • dba_delete — Elimina una entrada DBA especificada por clave
  • dba_exists — Verificar si la clave existe
  • dba_fetch — Recuperar datos especificados por clave
  • dba_firstkey — Recuperar la primera clave
  • dba_handlers — Listar todos los gestores disponibles
  • dba_insert — Insertar entrada
  • dba_key_split — Separa una clave en representación de cadena en representación de array
  • dba_list — Listar todos los archivos de base de datos abiertos
  • dba_nextkey — Recuperar la siguiente clave
  • dba_open — Abrir una base de datos
  • dba_optimize — Optimizar base de datos
  • dba_popen — Abrir una base de datos de forma persistente
  • dba_replace — Reemplazar o insertar una entrada
  • dba_sync — Sincronizar base de datos


Cerrar una base de datos DBA

  • « Funciones de DBA
  • dba_delete »
  • PHP Manual
  • Funciones de DBA
  • Cerrar una base de datos DBA

dba_close

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_close — Cerrar una base de datos DBA

Descripción

dba_close ( resource $handle ) : void

dba_close() cierra la base de datos establecida y libera todos los recursos del gestor de base de datos especificado.

Parámetros

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

No devuelve ningún valor.

Ver también

  • dba_open() - Abrir una base de datos
  • dba_popen() - Abrir una base de datos de forma persistente


Elimina una entrada DBA especificada por clave

  • « dba_close
  • dba_exists »
  • PHP Manual
  • Funciones de DBA
  • Elimina una entrada DBA especificada por clave

dba_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_delete — Elimina una entrada DBA especificada por clave

Descripción

dba_delete ( string $key , resource $handle ) : bool

dba_delete() elimina la entrada especificada de la base de datos.

Parámetros

key

La clave de la entrada que está siendo eliminada.

gestor

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dba_exists() - Verificar si la clave existe
  • dba_fetch() - Recuperar datos especificados por clave
  • dba_insert() - Insertar entrada
  • dba_replace() - Reemplazar o insertar una entrada


Verificar si la clave existe

  • « dba_delete
  • dba_fetch »
  • PHP Manual
  • Funciones de DBA
  • Verificar si la clave existe

dba_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_exists — Verificar si la clave existe

Descripción

dba_exists ( string $key , resource $handle ) : bool

dba_exists() verifica si la key especificada existe en la base de datos.

Parámetros

key

La clave usada para el chequeo.

gestor

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true si la clave existe, false de lo contrario.

Ver también

  • dba_delete() - Elimina una entrada DBA especificada por clave
  • dba_fetch() - Recuperar datos especificados por clave
  • dba_insert() - Insertar entrada
  • dba_replace() - Reemplazar o insertar una entrada


Recuperar datos especificados por clave

  • « dba_exists
  • dba_firstkey »
  • PHP Manual
  • Funciones de DBA
  • Recuperar datos especificados por clave

dba_fetch

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_fetch — Recuperar datos especificados por clave

Descripción

dba_fetch ( string $key , resource $handle ) : string
dba_fetch ( string $key , int $skip , resource $handle ) : string

dba_fetch() recupera los datos especificados por key desde la base de datos indicada con handle.

Parámetros

key

La clave que apunta a los datos.

Nota:

Cuando se trabaja con archivos ini, esta función acepta arrays como claves, en donde el índice 0 es el grupo y el índice 1 es el nombre del valor. Vea: dba_key_split().

skip

El número de parejas clave-valor a ignorar cuando se usan bases de datos cdb. Este valor es ignorado por todas las otras bases de datos que no soportan múltiples claves con el mismo nombre.

gestor

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve la cadena asociada si la pareja clave/datos es encontrada, false de lo contrario.

Historial de cambios

Versión | Descripción
4.3.0 | El parámetro skip se encuentra disponible para ofrecer soporte a la capacidad de gdb de claves múltiples con el mismo nombre.

Ver también

  • dba_exists() - Verificar si la clave existe
  • dba_delete() - Elimina una entrada DBA especificada por clave
  • dba_insert() - Insertar entrada
  • dba_replace() - Reemplazar o insertar una entrada
  • dba_key_split() - Separa una clave en representación de cadena en representación de array


Recuperar la primera clave

  • « dba_fetch
  • dba_handlers »
  • PHP Manual
  • Funciones de DBA
  • Recuperar la primera clave

dba_firstkey

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_firstkey — Recuperar la primera clave

Descripción

dba_firstkey ( resource $handle ) : string

dba_firstkey() devuelve la primera clave de la base de datos y reestablece el apuntador de clave interno. Esto permite una búsqueda lineal a través de la base de datos completa.

Parámetros

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve la clave en caso de tener éxito o false en caso de error.

Ver también

  • dba_nextkey() - Recuperar la siguiente clave
  • dba_key_split() - Separa una clave en representación de cadena en representación de array
  • Ejemplo 2 en los ejemplos de DBA


Listar todos los gestores disponibles

  • « dba_firstkey
  • dba_insert »
  • PHP Manual
  • Funciones de DBA
  • Listar todos los gestores disponibles

dba_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

dba_handlers — Listar todos los gestores disponibles

Descripción

dba_handlers ( bool $full_info = false ) : array

dba_handlers() lista todos los gestores soportados por esta extensión.

Parámetros

full_info

Activa/desactiva la mostración de la información completa en el resultado.

Valores devueltos

Devuelve un array de gestores de bases de datos. Si full_info está establecido a true, el array será asociativo con los nombres de los gestores como claves y la información de su versión com valor. De otro modo, el resultado será un array indexado de nombres de gestores.

Nota:

Cuando se usa la biblioteca cdb interna verá cdb y cdb_make.

Ejemplos

Ejemplo #1 Ejemplo de dba_handlers()

<?php

echo "Gestores de DBA disponibles:\n";
foreach (dba_handlers(true) as $nombre_gestor => $versión_gestor) {
  // limpiar las versiones
  $versión_gestor = str_replace('$', '', $versión_gestor);
  echo " - $nombre_gestor: $versión_gestor\n";
}

?>

El resultado del ejemplo sería algo similar a:

Gestores de DBA disponibles:
 - cdb: 0.75, Revision: 1.3.2.3
 - cdb_make: 0.75, Revision: 1.2.2.4
 - db2: Sleepycat Software: Berkeley DB 2.7.7: (08/20/99)
 - inifile: 1.0, Revision: 1.6.2.3
 - flatfile: 1.0, Revision: 1.5.2.4


Insertar entrada

  • « dba_handlers
  • dba_key_split »
  • PHP Manual
  • Funciones de DBA
  • Insertar entrada

dba_insert

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_insert — Insertar entrada

Descripción

dba_insert ( string $key , string $value , resource $handle ) : bool

dba_insert() inserta la entrada descrita con clave y valor en la base de datos.

Parámetros

key

La clave de la entrada a ser insertada. Si esta clave ya existe en la base de datos, esta función fallará. Use dba_replace() si necesita reemplazar una clave existente.

value

El valor a ser insertado.

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dba_exists() - Verificar si la clave existe
  • dba_delete() - Elimina una entrada DBA especificada por clave
  • dba_fetch() - Recuperar datos especificados por clave
  • dba_replace() - Reemplazar o insertar una entrada


Separa una clave en representación de cadena en representación de array

  • « dba_insert
  • dba_list »
  • PHP Manual
  • Funciones de DBA
  • Separa una clave en representación de cadena en representación de array

dba_key_split

(PHP 5, PHP 7, PHP 8)

dba_key_split — Separa una clave en representación de cadena en representación de array

Descripción

dba_key_split ( mixed $key ) : mixed

dba_key_split() separa una clave (representación tipo cadena) en una representación tipo array.

Parámetros

key

La clave en representación de cadena.

Valores devueltos

Devuelve un array de la forma array(0 => grupo, 1 => nombre_valor). Esta función devolverá false si clave es null o false.

Ver también

  • dba_firstkey() - Recuperar la primera clave
  • dba_nextkey() - Recuperar la siguiente clave
  • dba_fetch() - Recuperar datos especificados por clave


Listar todos los archivos de base de datos abiertos

  • « dba_key_split
  • dba_nextkey »
  • PHP Manual
  • Funciones de DBA
  • Listar todos los archivos de base de datos abiertos

dba_list

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

dba_list — Listar todos los archivos de base de datos abiertos

Descripción

dba_list ( ) : array

dba_list() lista todos los archivos de bases de datos abiertos.

Valores devueltos

Un array asociativo, en la forma id_recurso => nombre_archivo.


Recuperar la siguiente clave

  • « dba_list
  • dba_open »
  • PHP Manual
  • Funciones de DBA
  • Recuperar la siguiente clave

dba_nextkey

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_nextkey — Recuperar la siguiente clave

Descripción

dba_nextkey ( resource $handle ) : string

dba_nextkey() devuelve la siguiente clave de la base de datos y avanza el apuntador de clave interno.

Parámetros

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve la clave si tiene éxito o false en caso de error.

Ver también

  • dba_firstkey() - Recuperar la primera clave
  • dba_key_split() - Separa una clave en representación de cadena en representación de array
  • Ejemplo 2 en los ejemplos de DBA


Abrir una base de datos

  • « dba_nextkey
  • dba_optimize »
  • PHP Manual
  • Funciones de DBA
  • Abrir una base de datos

dba_open

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_open — Abrir una base de datos

Descripción

dba_open ( string $path , string $mode , string $handler = ? , mixed $... = ? ) : resource

dba_open() establece una instancia de una base de datos para path con mode usando handler.

Parámetros

path

Comúnmente una ruta normal de su sistema de ficheros.

mode

Es r para acceso de lectura, w para acceso de lectura/escritura de una base de datos existente, c para acceso de lectura/escritura y creación de una base de datos si no existe actualmente, y n para crear, truncar y acceso de lectura/escritura. La base de datos se crea en el modo BTree, los demás modos (como Hash o Queue) no están soportados.

Además se puede establecer el método de bloqueo de la base de datos con el siguiente carácter. Use l para bloquear la base de datos con un fichero .lck o d para bloquear el fichero de la base de datos mismo. Es importante que todas sus aplicaciones hagan esto de manera consistente.

Si quiere probar el acceso y no quiere esperar para el bloqueo puede añadir t como tercer carácter. Cuando está absolutamente seguro de que no se requiere el bloqueo de la base de datos, puede usar - en lugar de l o d. Cuando no se usar d, l o -, dba bloqueará el archivo de la base de datos como si lo estuviera con d.

Nota:

Sólo puede haber un escritor para el archivo de la base de datos. Cuando se usa dba en un servidor web y más de una solicitud requiere operaciones de escritura, sólo pueden hacerlo una tras otra. Tampoco está permitido la lectura durante la escritura. La extensión dba usa bloqueos para impedirlo. Véase la siguiente tabla:

Bloqueo de DBA
ya abierta | mode = "rl" | mode = "rlt" | mode = "wl" | mode = "wlt" | mode = "rd" | mode = "rdt" | mode = "wd" | mode = "wdt"
sin abrir | ok | ok | ok | ok | ok | ok | ok | ok
mode = "rl" | ok | ok | wait | false | illegal | illegal | illegal | illegal
mode = "wl" | wait | false | wait | false | illegal | illegal | illegal | illegal
mode = "rd" | illegal | illegal | illegal | illegal | ok | ok | wait | false
mode = "wd" | illegal | illegal | illegal | illegal | wait | false | wait | false
  • ok: la segunda llamada tendrá éxito.
  • wait: la sedunda llamada esperará hasta que se llame a dba_close() la primera vez.
  • false: la segunda llamada devuelve false.
  • illegal: no se pueden mezclar los modificadores "l" y "d" con el parámetro mode.

handler

El nombre del gestor que será usado para acceder a path. Se le pasan todos los parámetros opcionales dados a dba_open() y puede actuar en su nombre.

Valores devueltos

Devuelve un gestor positivo en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
4.3.0 | Es posible abrir ficheros de bases de datos sobre conexiones de red. Sin embargo, en el caso en que se use una conexión de socket (como con http o ftp) la conexión se bloqueará en lugar del recurso en sí. Esto es importante para saber que en tales casos el bloqueo es ignorado simplemente en el recurso y se tienen que encontrar otras soluciones.

Ver también

  • dba_popen() - Abrir una base de datos de forma persistente
  • dba_close() - Cerrar una base de datos DBA


Optimizar base de datos

  • « dba_open
  • dba_popen »
  • PHP Manual
  • Funciones de DBA
  • Optimizar base de datos

dba_optimize

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_optimize — Optimizar base de datos

Descripción

dba_optimize ( resource $handle ) : bool

dba_optimize() optimiza la base de datos interna.

Parámetros

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dba_sync() - Sincronizar base de datos


Abrir una base de datos de forma persistente

  • « dba_optimize
  • dba_replace »
  • PHP Manual
  • Funciones de DBA
  • Abrir una base de datos de forma persistente

dba_popen

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_popen — Abrir una base de datos de forma persistente

Descripción

dba_popen ( string $path , string $mode , string $handler = ? , mixed $... = ? ) : resource

dba_popen() establece una instancia de base de datos persistente para el archivo en path con el mode indicado, usando handler.

Parámetros

path

Usualmente una ruta normal en su sistema de archivos.

mode

Es r para acceso de lectura, w para acceso de lectura/escritura a una base de datos existente, c para acceso de lectura/escritura y creación de base de datos si no existe actualmente, y n para crear, truncar y tener acceso de lectura/escritura.

handler

El nombre del gestor que será usado para acceder a path. A él se le pasan todos los parámetros opcionales dados a dba_popen() y puede actuar sobre ellos.

Valores devueltos

Devuelve un gestor positivo en caso de éxito, o o false en caso de error.

Ver también

  • dba_open() - Abrir una base de datos
  • dba_close() - Cerrar una base de datos DBA


Reemplazar o insertar una entrada

  • « dba_popen
  • dba_sync »
  • PHP Manual
  • Funciones de DBA
  • Reemplazar o insertar una entrada

dba_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_replace — Reemplazar o insertar una entrada

Descripción

dba_replace ( string $key , string $value , resource $handle ) : bool

dba_replace() reemplaza o inserta la entrada descrita con key y value en la base de datos especificada por handle.

Parámetros

key

La clave de la entrada a ser reemplazada.

value

El valor a ser reemplazado.

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dba_exists() - Verificar si la clave existe
  • dba_delete() - Elimina una entrada DBA especificada por clave
  • dba_fetch() - Recuperar datos especificados por clave
  • dba_insert() - Insertar entrada


Sincronizar base de datos

  • « dba_replace
  • ODBC »
  • PHP Manual
  • Funciones de DBA
  • Sincronizar base de datos

dba_sync

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_sync — Sincronizar base de datos

Descripción

dba_sync ( resource $handle ) : bool

dba_sync() sincroniza la base de datos. Esto probablemente desencadenará una escritura en disco, si es soportado.

Parámetros

handle

El gestor de base de datos, devuelto por dba_open() o dba_popen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dba_optimize() - Optimizar base de datos


ODBC (Unificada)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones ODBC
    • odbc_autocommit — Activa el comportamiento automático de envío
    • odbc_binmode — Manejo de información de columna binaria
    • odbc_close_all — Cerrar todas las conexiones ODBC
    • odbc_close — Cerrar una conexión ODBC
    • odbc_columnprivileges — Lista las columnas y los privilegios asociados para la tabla dada
    • odbc_columns — Lista los nombres de columnas de la tabla especificada
    • odbc_commit — Envía una transacción ODBC
    • odbc_connect — Conectar a una fuente de datos
    • odbc_cursor — Obtener el nombre del cursor
    • odbc_data_source — Devuelve información sobre una conexión actual
    • odbc_do — Alias de odbc_exec
    • odbc_error — Obtener el último código de error
    • odbc_errormsg — Obtener el último mensaje de error
    • odbc_exec — Preparar y ejecutar una sentencia SQL
    • odbc_execute — Ejecutar una declaración preparada
    • odbc_fetch_array — Obtener una fila de resultados como una matriz asociativa
    • odbc_fetch_into — Traer una fila de resultados en una matriz
    • odbc_fetch_object — Obtener una fila de resultados como un objeto
    • odbc_fetch_row — Traer una fila
    • odbc_field_len — Obtener la longitud (precisión) de un campo
    • odbc_field_name — Obtener el nombre de una columna
    • odbc_field_num — Devolver el número de columna
    • odbc_field_precision — Alias de odbc_field_len
    • odbc_field_scale — Obtener la escala de un campo
    • odbc_field_type — Tipo de datos de un campo
    • odbc_foreignkeys — Recupera información de una lista de claves extranjeras
    • odbc_free_result — Liberar los recursos asociados con un resultado
    • odbc_gettypeinfo — Recupera información sobre los tipos de datos soportados por la fuente de datos
    • odbc_longreadlen — Manejo de columnas LONG
    • odbc_next_result — Verifica si están disponibles múltiples resultados
    • odbc_num_fields — Número de columnas de un resultado
    • odbc_num_rows — Número de filas de un resultado
    • odbc_pconnect — Abrir una conexión persistente a una base de datos
    • odbc_prepare — Prepara una declaración para su ejecución
    • odbc_primarykeys — Obtiene las claves primarias de una tabla
    • odbc_procedurecolumns — Recuperar información sobre los parámetros a procedimientos
    • odbc_procedures — Obtener la lista de procedimientos almacenados en una fuente de datos específica
    • odbc_result_all — Imprimir el resultado como una tabla HTML
    • odbc_result — Obtener información de resultado
    • odbc_rollback — Revertir una transacción
    • odbc_setoption — Ajustar la configuración de ODBC
    • odbc_specialcolumns — Recupera columnas especiales
    • odbc_statistics — Recuperar las estadísticas de un tabla
    • odbc_tableprivileges — Lista las tablas y los privilegios asociados con cada tabla
    • odbc_tables — Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica


Introducción

Además del soporte habitual para ODBC, las funciones de ODBC Unificada de PHP permiten acceder a varias bases de datos que toman prestada la semántica de la API ODBC para implementar su propia API. En lugar de mantener múltiples controladores de bases de datos que son casi idénticos, éstos han sido unificados en un único conjunto de funciones ODBC.

Las siguientes bases de datos están soportadas por la funciones de ODBC Unificada: » Adabas D, » IBM DB2, » iODBC, » Solid, y » Sybase SQL Anywhere.

Nota:

Con la excepción de iODBC, no está involucrada ninguna ODBC al conectarse a las bases de datos mencionadas. Ocurre que las funciones que se usan para comunicarse de forma nativa con las bases de datos comparten los mismos nombres y la misma sintaxis que las funciones de ODBC. Sin embargo, al construir PHP con soporte para iODBC, se permite el uso de cualquier controlador que cumpla con ODBC en las aplicaciones de PHP. Hay más unformaicón disponible sobre iODBC en » www.iodbc.org con la alternativa unixODBC disponible en » www.unixodbc.org.


Requerimientos

Para acceder a cualquiera de las bases de datos soportadas se necesitan tener instaladas las bibliotecas requeridas.


Instalación

--with-adabas[=DIR]

Incluir el soporte para Adabas D. DIR es el directorio de instalación base de Adabas, por defecto es /usr/local.

--with-sapdb[=DIR]

Incluir soporte para SAP DB. DIR es el directorio de instalación base de SAP DB, por defecto es /usr/local.

--with-solid[=DIR]

Incluir el soporte para Solid. DIR es el directorio de instalación base de Solid, por defecto es /usr/local/solid.

--with-ibm-db2[=DIR]

Incluir el soporte para IBM DB2. DIR es el directorio de instalación base de DB2, por defecto es /home/db2inst1/sqllib.

--with-empress[=DIR]

Incluir el soporte para Empress. DIR es el directorio de instalación base de Empress, por defecto es $EMPRESSPATH. Esta opción sólo soporta Empress Version 8.60 y superior.

--with-empress-bcs[=DIR]

Incluir el soporte para "Empress Local Access". DIRes el directorio de instalación base de Empress, por defecto es $EMPRESSPATH. Esta opción sólo soporta Empress Version 8.60 y superior.

--with-birdstep[=DIR]

Incluir el soporte para Birdstep. DIR es el directorio de instalación base de Birdstep, por defecto es /usr/local/birdstep.

--with-custom-odbc[=DIR]

Incluir soporte para ODBC definida por el usuario. DIR es el directorio de instalación base de ODBC, que por defecto es /usr/local. Asegúrese de definir CUSTOM_ODBC_LIBS y tener odbc.h en los directorios de inclución. P.ej., debería definir como sigue para Sybase SQL Anywhere 5.5.00 en QNX, antes de ejecutar el script de configuración:

   CPPFLAGS="-DODBC_QNX -DSQLANY_BUG"
   LDFLAGS=-lunix
   CUSTOM_ODBC_LIBS="-ldblib -lodbc".

--with-iodbc[=DIR]

Incluir el soporte para iODBC. DIR es el directorio de instalación base de iODBC, por defecto es /usr/local.

--with-esoob[=DIR]

Incluir el soporte para Easysoft OOB. DIR es el directorio de instalación base de OOB, por defecto es /usr/local/easysoft/oob/client.

--with-unixODBC[=DIR]

Incluir el soporte para unixODBC. DIR es el directorio de instalación base de unixODBC, por defecto es /usr/local.

--with-openlink[=DIR]

Incluir el soporte para OpenLink ODBC. DIR es el directorio de instalación base de OpenLink, por defecto es /usr/local. Es el mismo que el de iODBC.

--with-dbmaker[=DIR]

Incluir el soporte para DBMaker. DIR es el directorio de instalación base de DBMaker, por defecto donde está instalada la última versión de DBMaker (como /home/dbmaker/3.6).

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opdiones de configuración de ODBC Unidficada
Nombre | Por defecto | Cambiable | Historial de cambios
odbc.default_db * | NULL | PHP_INI_ALL |
odbc.default_user * | NULL | PHP_INI_ALL |
odbc.default_pw * | NULL | PHP_INI_ALL |
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.default_cursortype | "3" | PHP_INI_ALL | Disponible a partir de PHP 5.3.0

Nota: Las entradas marcadas con * no están aún implementadas.

Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

odbc.default_db string

Fuente de datos ODBC a usar si no se especifica ninguna en odbc_connect() o odbc_pconnect().

odbc.default_user string

Nombre de usuario a usar si no se especifica ninguno en odbc_connect() o odbc_pconnect().

odbc.default_pw string

Contraseña a usar si no se especifica ninguna en odbc_connect() o odbc_pconnect().

odbc.allow_persistent boolean

Si se permiten conexiones ODBC persistentes.

odbc.check_persistent boolean

Verificar que una conexión es todavía válida antes de reusarla.

odbc.max_persistent integer

El número máximo de conexiones ODBC persistentes por proceso.

odbc.max_links integer

El número máximo de conexiones ODBC por porceso, incluyendo las conexiones persistentes.

odbc.defaultlrl integer

Manejo de campor LONG. Especifica el número de bytes devueltos a las variables.

Cuando se usa un integer, el valor del mismo es medido en bytes. También se puede usar la notación reducida, tal como se describe en esta FAQ.
odbc.defaultbinmode integer

Manejor de información binaria.

odbc.default_cursortype integer

Controla el modelo de cursor de ODBC. Los valores posibles son SQL_CURSOR_FORWARD_ONLY, SQL_CURSOR_KEYSET_DRIVEN, SQL_CURSOR_DYNAMIC y SQL_CURSOR_STATIC (predeterminado).


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define dos tipos de recursos: un indentificador de conexión ODBC y un identificador de resultado ODBC.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

ODBC_TYPE (integer)
ODBC_BINMODE_PASSTHRU (integer)
ODBC_BINMODE_RETURN (integer)
ODBC_BINMODE_CONVERT (integer)
SQL_ODBC_CURSORS (integer)
SQL_CUR_USE_DRIVER (integer)
SQL_CUR_USE_IF_NEEDED (integer)
SQL_CUR_USE_ODBC (integer)
SQL_CONCURRENCY (integer)
SQL_CONCUR_READ_ONLY (integer)
SQL_CONCUR_LOCK (integer)
SQL_CONCUR_ROWVER (integer)
SQL_CONCUR_VALUES (integer)
SQL_CURSOR_TYPE (integer)
SQL_CURSOR_FORWARD_ONLY (integer)
SQL_CURSOR_KEYSET_DRIVEN (integer)
SQL_CURSOR_DYNAMIC (integer)
SQL_CURSOR_STATIC (integer)
SQL_KEYSET_SIZE (integer)
SQL_CHAR (integer)
SQL_VARCHAR (integer)
SQL_LONGVARCHAR (integer)
SQL_DECIMAL (integer)
SQL_NUMERIC (integer)
SQL_BIT (integer)
SQL_TINYINT (integer)
SQL_SMALLINT (integer)
SQL_INTEGER (integer)
SQL_BIGINT (integer)
SQL_REAL (integer)
SQL_FLOAT (integer)
SQL_DOUBLE (integer)
SQL_BINARY (integer)
SQL_VARBINARY (integer)
SQL_LONGVARBINARY (integer)
SQL_DATE (integer)
SQL_TIME (integer)
SQL_TIMESTAMP (integer)
SQL_TYPE_DATE (integer)
SQL_TYPE_TIME (integer)
SQL_TYPE_TIMESTAMP (integer)
SQL_BEST_ROWID (integer)
SQL_ROWVER (integer)
SQL_SCOPE_CURROW (integer)
SQL_SCOPE_TRANSACTION (integer)
SQL_SCOPE_SESSION (integer)
SQL_NO_NULLS (integer)
SQL_NULLABLE (integer)
SQL_INDEX_UNIQUE (integer)
SQL_INDEX_ALL (integer)
SQL_ENSURE (integer)
SQL_QUICK (integer)


Funciones ODBC

Tabla de contenidos

  • odbc_autocommit — Activa el comportamiento automático de envío
  • odbc_binmode — Manejo de información de columna binaria
  • odbc_close_all — Cerrar todas las conexiones ODBC
  • odbc_close — Cerrar una conexión ODBC
  • odbc_columnprivileges — Lista las columnas y los privilegios asociados para la tabla dada
  • odbc_columns — Lista los nombres de columnas de la tabla especificada
  • odbc_commit — Envía una transacción ODBC
  • odbc_connect — Conectar a una fuente de datos
  • odbc_cursor — Obtener el nombre del cursor
  • odbc_data_source — Devuelve información sobre una conexión actual
  • odbc_do — Alias de odbc_exec
  • odbc_error — Obtener el último código de error
  • odbc_errormsg — Obtener el último mensaje de error
  • odbc_exec — Preparar y ejecutar una sentencia SQL
  • odbc_execute — Ejecutar una declaración preparada
  • odbc_fetch_array — Obtener una fila de resultados como una matriz asociativa
  • odbc_fetch_into — Traer una fila de resultados en una matriz
  • odbc_fetch_object — Obtener una fila de resultados como un objeto
  • odbc_fetch_row — Traer una fila
  • odbc_field_len — Obtener la longitud (precisión) de un campo
  • odbc_field_name — Obtener el nombre de una columna
  • odbc_field_num — Devolver el número de columna
  • odbc_field_precision — Alias de odbc_field_len
  • odbc_field_scale — Obtener la escala de un campo
  • odbc_field_type — Tipo de datos de un campo
  • odbc_foreignkeys — Recupera información de una lista de claves extranjeras
  • odbc_free_result — Liberar los recursos asociados con un resultado
  • odbc_gettypeinfo — Recupera información sobre los tipos de datos soportados por la fuente de datos
  • odbc_longreadlen — Manejo de columnas LONG
  • odbc_next_result — Verifica si están disponibles múltiples resultados
  • odbc_num_fields — Número de columnas de un resultado
  • odbc_num_rows — Número de filas de un resultado
  • odbc_pconnect — Abrir una conexión persistente a una base de datos
  • odbc_prepare — Prepara una declaración para su ejecución
  • odbc_primarykeys — Obtiene las claves primarias de una tabla
  • odbc_procedurecolumns — Recuperar información sobre los parámetros a procedimientos
  • odbc_procedures — Obtener la lista de procedimientos almacenados en una fuente de datos específica
  • odbc_result_all — Imprimir el resultado como una tabla HTML
  • odbc_result — Obtener información de resultado
  • odbc_rollback — Revertir una transacción
  • odbc_setoption — Ajustar la configuración de ODBC
  • odbc_specialcolumns — Recupera columnas especiales
  • odbc_statistics — Recuperar las estadísticas de un tabla
  • odbc_tableprivileges — Lista las tablas y los privilegios asociados con cada tabla
  • odbc_tables — Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica


Activa el comportamiento automático de envío

  • « Funciones ODBC
  • odbc_binmode »
  • PHP Manual
  • Funciones ODBC
  • Activa el comportamiento automático de envío

odbc_autocommit

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_autocommit — Activa el comportamiento automático de envío

Descripción

odbc_autocommit ( resource $connection_id , bool $OnOff = false ) : mixed

Activa el comportamiento automático de envío.

Por defecto, el auto envío está activado en una conexión. Deshabilitar el auto envío es equivalente a iniciar una transacción.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

OnOff

Si OnOff es true, el auto envío está habilitado, si es false el auto envío está deshabilitado.

Valores devueltos

Sin el parámetro OnOff, está función devuelve el estado de auto envío para connection_id. Se devuelve un valor distinto de cero si el auto envío está activado, 0 si está desactivado, o false si se produjo un error.

Si está establecido OnOff, esta función devolverá true si se tuvo éxito y false si falló.

Ver también

  • odbc_commit() - Envía una transacción ODBC
  • odbc_rollback() - Revertir una transacción


Manejo de información de columna binaria

  • « odbc_autocommit
  • odbc_close_all »
  • PHP Manual
  • Funciones ODBC
  • Manejo de información de columna binaria

odbc_binmode

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_binmode — Manejo de información de columna binaria

Descripción

odbc_binmode ( resource $result_id , int $mode ) : bool

Habilita el manejo de información de columna binaria. Los tipos de SQL ODBC son BINARY, VARBINARY, y LONGVARBINARY.

Cuando se convierte informaicón SQL binaria a información C de carácter, cada byte (8 bits) de información fuente está representado como dos caractéres ASCII. Estos caracteres la representación de caracteres ASCII del número en su forma hexadecimal. Por ejemplo, el número binario 00000001 se convierte a "01" y 11111111 se convierte a "FF".

Manejo de LONGVARBINARY
binmode | longreadlen | result
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_RETURN | 0 | passthru
ODBC_BINMODE_CONVERT | 0 | passthru
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_PASSTHRU | >0 | passthru
ODBC_BINMODE_RETURN | >0 | devuelve como es
ODBC_BINMODE_CONVERT | >0 | devuelve como tipo char

Si se usa odbc_fetch_into(), passthru significa se devuelve una cadena vacía para esta columnas.

Parámetros

result_id

El identificador de resultado.

Si result_id es 0, las configuraciones se aplican por defecto para los nuevos resultados.

Nota: longreadlen por defecto es 4096 y mode por defecto es ODBC_BINMODE_RETURN. El manejo de columnas binarias de tipo long también está afectado por odbc_longreadlen().

mode

Los valores posibles para mode son:

  • ODBC_BINMODE_PASSTHRU: Realiza passthru en daots BINARY
  • ODBC_BINMODE_RETURN: Devuelve como es
  • ODBC_BINMODE_CONVERT: Covierte a tipo char y devuelve

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Cerrar todas las conexiones ODBC

  • « odbc_binmode
  • odbc_close »
  • PHP Manual
  • Funciones ODBC
  • Cerrar todas las conexiones ODBC

odbc_close_all

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_close_all — Cerrar todas las conexiones ODBC

Descripción

odbc_close_all ( ) : void

odbc_close_all() cerrará todas las conexión del/de los servidor/es de bases de datos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

Esta función fallará si hay transaccines abiertas sobre una conexión. En este caso la conexión permanecerá abierta.


Cerrar una conexión ODBC

  • « odbc_close_all
  • odbc_columnprivileges »
  • PHP Manual
  • Funciones ODBC
  • Cerrar una conexión ODBC

odbc_close

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_close — Cerrar una conexión ODBC

Descripción

odbc_close ( resource $connection_id ) : void

Cierra una conexión a un servidor de bases de datos.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

Esta función fallará si hay transaccines abiertas sobre una conexión. En este caso la conexión permanecerá abierta.


Lista las columnas y los privilegios asociados para la tabla dada

  • « odbc_close
  • odbc_columns »
  • PHP Manual
  • Funciones ODBC
  • Lista las columnas y los privilegios asociados para la tabla dada

odbc_columnprivileges

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_columnprivileges — Lista las columnas y los privilegios asociados para la tabla dada

Descripción

odbc_columnprivileges ( resource $connection_id , string $qualifier , string $owner , string $table_name , string $column_name ) : resource

Lista las columnas y los privilegios asociados para la tabla dada.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario.

table_name

El nombre de la table.

column_name

El argumento column_name acepta patrones de búsqueda ('%' para comparar cero o más caracteres y '_' para comparar un único carácter).

Los parámetros schema, table_name y column_name aceptan patrones de búsqueda ('%' para comparar cero o más caracteres y '_' para comparar un único carácter).

Valores devueltos

Devuelve un identificador de resultado de ODBC o false en caso de error. Este identificador de resultado se puede usar para traer una lista de columnas y privilegios asociados.

El conjunto de resultados tiene las siguientes columnas:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

El conjunto de resultados está ordenados según TABLE_QUALIFIER, TABLE_OWNER y TABLE_NAME.


Lista los nombres de columnas de la tabla especificada

  • « odbc_columnprivileges
  • odbc_commit »
  • PHP Manual
  • Funciones ODBC
  • Lista los nombres de columnas de la tabla especificada

odbc_columns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_columns — Lista los nombres de columnas de la tabla especificada

Descripción

odbc_columns ( resource $connection_id , string $qualifier = ? , string $schema = ? , string $table_name = ? , string $column_name = ? ) : resource

Lista todas las columnas en el rango solicitado.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

schema

El propietariio.

table_name

El nombre de la table.

column_name

El nombre de la columna.

Los parámetros schema, table_name y column_name aceptan patrones de búsqueda ('%' para comparar cero o más caracteres y '_' para comparar un único carácter).

Valores devueltos

Devuelve un idenrificador de resultado de ODBC o false en caso de error.

El conjunto de resultados tiene las siguietes columnas:

  • TABLE_QUALIFIER
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

El conjunto de resultados está ordenado según TABLE_QUALIFIER, TABLE_SCHEM y TABLE_NAME.

Ver también

  • odbc_columnprivileges() - Lista las columnas y los privilegios asociados para la tabla dada para recuperar los privilegios asociados


Envía una transacción ODBC

  • « odbc_columns
  • odbc_connect »
  • PHP Manual
  • Funciones ODBC
  • Envía una transacción ODBC

odbc_commit

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_commit — Envía una transacción ODBC

Descripción

odbc_commit ( resource $connection_id ) : bool

Envía todas las transacciones pendientes en una conexión.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Conectar a una fuente de datos

  • « odbc_commit
  • odbc_cursor »
  • PHP Manual
  • Funciones ODBC
  • Conectar a una fuente de datos

odbc_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_connect — Conectar a una fuente de datos

Descripción

odbc_connect ( string $dsn , string $user , string $password , int $cursor_type = ? ) : resource

El id de conexión devuelto por estas funciones es necesario por otras funciones ODBC. Se pueden tener abiertas mútiples conexiones de una vez mientras que usen bases de datos o credenciales diferentes.

Con algunos controladores ODBC, el ejecutar un procedimiento de almacenamiento complejo puede fallar con un error similar a: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it" (No se pudo abrir un cursor en un procedimiento de almacenamiento que tiene una única declaración de selección). Se puede evitar este error usando SQL_CUR_USE_ODBC. También, algunos controladores no soportan el parámetro opcional row_number en odbc_fetch_row(). SQL_CUR_USE_ODBC might también ayuda en este case.

Parámetros

dsn

El nombre de la fuente de base de datos para la conexión. Alternativamente se puede usar una cadena de conexión sin DSN.

user

El nombre de usuario.

password

La contraseña.

cursor_type

Establece el tipo de cursor a usar para esta conexión. Este parámetro normalmente no es necesario, pero puede ser útil para evitar problemas con algunos controladores ODBC.

Las siguientes constantes están definidas para el tipo de cursor:

  • SQL_CUR_USE_IF_NEEDED
  • SQL_CUR_USE_ODBC
  • SQL_CUR_USE_DRIVER

Valores devueltos

Devuelve una conexión ODBC o (false) si ocurre un error.

Ejemplos

Ejemplo #1 Conexiones sin DSN

<?php
// Microsoft SQL Server usando SQL Native Client 10.0 ODBC Driver - permite la conexión a SQL 7, 2000, 2005 y 2008
$conexión = odbc_connect("Driver={SQL Server Native Client 10.0};Server=$server;Database=$database;", $user, $password);

// Microsoft Access
$conexión = odbc_connect("Driver={Microsoft Access Driver (*.mdb)};Dbq=$mdbFilename", $user, $password);

// Microsoft Excel
$excelFile = realpath('C:/ExcelData.xls');
$excelDir = dirname($excelFile);
$conexión = odbc_connect("Driver={Microsoft Excel Driver (*.xls)};DriverId=790;Dbq=$excelFile;DefaultDir=$excelDir" , '', '');
?>

Ver también

  • Para conexiones persistentes: odbc_pconnect() - Abrir una conexión persistente a una base de datos


Obtener el nombre del cursor

  • « odbc_connect
  • odbc_data_source »
  • PHP Manual
  • Funciones ODBC
  • Obtener el nombre del cursor

odbc_cursor

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_cursor — Obtener el nombre del cursor

Descripción

odbc_cursor ( resource $result_id ) : string

Obtiene el nombre del cursor para el párametro result_id dado.

Parámetros

result_id

El indentificador de resultados.

Valores devueltos

Devuelve el nombre del cursor, como cadena.


Devuelve información sobre una conexión actual

  • « odbc_cursor
  • odbc_do »
  • PHP Manual
  • Funciones ODBC
  • Devuelve información sobre una conexión actual

odbc_data_source

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

odbc_data_source — Devuelve información sobre una conexión actual

Descripción

odbc_data_source ( resource $connection_id , int $fetch_type ) : array

Esta función devolverá la lista de DSN disponibles (después de llamarla varias veces).

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

fetch_type

El parámetro fetch_type puede ser uno de los dos tipos de constantes: SQL_FETCH_FIRST, SQL_FETCH_NEXT. Use SQL_FETCH_FIRST la primera vez que llame a esta función, a partir de entonces use SQL_FETCH_NEXT.

Valores devueltos

Devuelve false si se produjo un error, y un array si tuvo éxito.


Alias de odbc_exec

  • « odbc_data_source
  • odbc_error »
  • PHP Manual
  • Funciones ODBC
  • Alias de odbc_exec

odbc_do

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_do — Alias de odbc_exec()

Descripción

Esta función es un alias de: odbc_exec().


Obtener el último código de error

  • « odbc_do
  • odbc_errormsg »
  • PHP Manual
  • Funciones ODBC
  • Obtener el último código de error

odbc_error

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_error — Obtener el último código de error

Descripción

odbc_error ( resource $connection_id = ? ) : string

Devuelve el estado de ODBC mediante un número de seis dígitos, o una cadena vacía si no hubo errores.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

Valores devueltos

Si se especifica connection_id, se devuelve el último estado de esta conexión, si no, se devuleve el último estado de cualquier conexión.

Esta función devuelve un valor significativo sólo si la última consultaodbc falló (es decir, odbc_exec() devolvió false).

Ver también

  • odbc_errormsg() - Obtener el último mensaje de error
  • odbc_exec() - Preparar y ejecutar una sentencia SQL


Obtener el último mensaje de error

  • « odbc_error
  • odbc_exec »
  • PHP Manual
  • Funciones ODBC
  • Obtener el último mensaje de error

odbc_errormsg

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_errormsg — Obtener el último mensaje de error

Descripción

odbc_errormsg ( resource $connection_id = ? ) : string

Devuelve una cadena que contiene el último mensaje de error de ODBC, o una cadena vacía si no hubo errores.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

Valores devueltos

Si se especifica connection_id, se devuelve el último estado de esa conexión, si no se devuelve el último estado de cualquier conexión.

Esta función devuelve un valor significativo sólo si falló la última consulta odbc (es decir, si odbc_exec() devolvió false).

Ver también

  • odbc_error() - Obtener el último código de error
  • odbc_exec() - Preparar y ejecutar una sentencia SQL


Preparar y ejecutar una sentencia SQL

  • « odbc_errormsg
  • odbc_execute »
  • PHP Manual
  • Funciones ODBC
  • Preparar y ejecutar una sentencia SQL

odbc_exec

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_exec — Preparar y ejecutar una sentencia SQL

Descripción

odbc_exec ( resource $connection_id , string $query_string , int $flags = ? ) : resource

Envía una sentencia SQL al servidor de bases de datos.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

query_string

La sentencia SQL.

flags

Este parámetro no se usa actualmente.

Valores devueltos

Devuelve un identificador de resultado de ODBC si el comando SQL se ejecutó con éxito, o false si se produjo un error.

Ver también

  • odbc_prepare() - Prepara una declaración para su ejecución
  • odbc_execute() - Ejecutar una declaración preparada


Ejecutar una declaración preparada

  • « odbc_exec
  • odbc_fetch_array »
  • PHP Manual
  • Funciones ODBC
  • Ejecutar una declaración preparada

odbc_execute

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_execute — Ejecutar una declaración preparada

Descripción

odbc_execute ( resource $result_id , array $parameters_array = ? ) : bool

Ejecuta una declaración preparado con odbc_prepare().

Parámetros

result_id

El resource de identificación de resultado, desde odbc_prepare().

parameters_array

Los parámetros en parameter_array serán sustituidoss por parámetros de sustitución en la declaración preparada en orden. Los elementos de este array serán convertidos a cadenas al llamar a esta función.

Cualquier parámetro de parameter_array que comience y finalice con comillas simples se tomará como el nombre de un archivo para leer y enviar al servor de la base de datos como la información para el parámetro de sustitución apropiado.

Si desea almacenar una cadena que comienza y finaliza con comillas simples, debe añadir un espacio u otro carácter distinto de las comillas simples al inicio o final del parámetro, lo que prevendrá al parámetro de ser tomado como un nombre de archivo. Si esto no es una opción, entonces debe usar otro mecanismo para almacenar la cadena, tal como ejecutar la consulta directamente con odbc_exec()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de odbc_execute() y odbc_prepare()

En el código siguiente, $éxito solamente será true si los tres parámetros de myproc son parámetros IN:

<?php
$a = 1;
$b = 2;
$c = 3;
$declaración    = odbc_prepare($conexión, 'CALL myproc(?,?,?)');
$éxito = odbc_execute($declaración, array($a, $b, $c));
?>

Si se necesita llamar a procedimientos almacendos usando parámetros INOUT o OUT, una solución recomendada es usar una extensión nativa para la base de datos (por ejemplo, oci8 para Oracle).

Ver también

  • odbc_prepare() - Prepara una declaración para su ejecución


Obtener una fila de resultados como una matriz asociativa

  • « odbc_execute
  • odbc_fetch_into »
  • PHP Manual
  • Funciones ODBC
  • Obtener una fila de resultados como una matriz asociativa

odbc_fetch_array

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

odbc_fetch_array — Obtener una fila de resultados como una matriz asociativa

Descripción

odbc_fetch_array ( resource $result , int $rownumber = ? ) : array

Obtiene un array asociativo desde una consulta de ODBC.

Parámetros

result

El recurso del resultado de odbc_exec().

rownumber

Escoger opcionalmente qué número de fila a recuperar.

Valores devueltos

Devuelve una matriz que se corresponde con la fila traída, o false si ya no hay más filas.

Notas

Nota: Esta función existe cuando se compila con soporte para DBMaker, IBM DB2 o UnixODBC.

Ver también

  • odbc_fetch_row() - Traer una fila
  • odbc_fetch_object() - Obtener una fila de resultados como un objeto
  • odbc_num_rows() - Número de filas de un resultado


Traer una fila de resultados en una matriz

  • « odbc_fetch_array
  • odbc_fetch_object »
  • PHP Manual
  • Funciones ODBC
  • Traer una fila de resultados en una matriz

odbc_fetch_into

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_fetch_into — Traer una fila de resultados en una matriz

Descripción

odbc_fetch_into ( resource $result_id , array &$result_array , int $rownumber = ? ) : int

Trae una fila de resultados en un array.

Parámetros

result_id

El resource del resultado.

result_array

El array resultante que puede ser de cualquier tipo ya que será convertido a tipo array. La matriz contendrá los valores de columnas comenzando en el índice de matriz 0.

rownumber

El número de fila.

Valores devueltos

Devuelve el número de columnas del resultado; false si se produjo un error.

Ejemplos

Ejemplo #1 Ejemplos de odbc_fetch_into()

<?php
$rc = odbc_fetch_into($res_id, $mi_array);
?>

o

<?php
$rc = odbc_fetch_into($res_id, $mi_array, 2);
?>


Obtener una fila de resultados como un objeto

  • « odbc_fetch_into
  • odbc_fetch_row »
  • PHP Manual
  • Funciones ODBC
  • Obtener una fila de resultados como un objeto

odbc_fetch_object

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

odbc_fetch_object — Obtener una fila de resultados como un objeto

Descripción

odbc_fetch_object ( resource $result , int $rownumber = ? ) : object

Obtiene un object desde una consulta de ODBC.

Parámetros

result

El recurso de resultado de odbc_exec().

rownumber

Escoger opcionalmente qué número de fila recuperar.

Valores devueltos

Devuelve un objeto que se corresponde con la fila traída, o false si ya no hay más filas.

Notas

Nota: Esta función existe cuando se compila con soporte para DBMaker, IBM DB2 o UnixODBC.

Ver también

  • odbc_fetch_row() - Traer una fila
  • odbc_fetch_array() - Obtener una fila de resultados como una matriz asociativa
  • odbc_num_rows() - Número de filas de un resultado


Traer una fila

  • « odbc_fetch_object
  • odbc_field_len »
  • PHP Manual
  • Funciones ODBC
  • Traer una fila

odbc_fetch_row

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_fetch_row — Traer una fila

Descripción

odbc_fetch_row ( resource $result_id , int $row_number = ? ) : bool

Trae una fila de la información que fue devuelta por odbc_do() o odbc_exec(). Después de llamar a odbc_fetch_row(), se puede acceder a los campos de esa fila con odbc_result().

Parámetros

result_id

El indentificador de resultado.

row_number

Si no se especifica row_number, odbc_fetch_row() intentará traer la siguiente fila del conjunto de resultados. Se pueden mezclar las llamadas a odbc_fetch_row() con o sin row_number.

Para revisar el resultado más de una vez se puede llamar a odbc_fetch_row() con row_number 1, y después continuar haciendo odbc_fetch_row() sin row_number para revisar el resultado. Si un controlador no soporta traer filas mediante número, el parámetro row_number es ignorado.

Valores devueltos

Devuelve true si hubo una fila, de otro modo false.


Obtener la longitud (precisión) de un campo

  • « odbc_fetch_row
  • odbc_field_name »
  • PHP Manual
  • Funciones ODBC
  • Obtener la longitud (precisión) de un campo

odbc_field_len

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_len — Obtener la longitud (precisión) de un campo

Descripción

odbc_field_len ( resource $result_id , int $field_number ) : int

Obtiene la longitud de un campo referenciado por número del indentificador de resultado dado.

Parámetros

result_id

El identificador de resultado.

field_number

El número de campo. La numeración de campos empieza en 1.

Valores devueltos

Devuelve la longitud del campo, o false en caso de error.

Ver también

  • odbc_field_scale() - Obtener la escala de un campo para obtener la escala de un número de coma flotante


Obtener el nombre de una columna

  • « odbc_field_len
  • odbc_field_num »
  • PHP Manual
  • Funciones ODBC
  • Obtener el nombre de una columna

odbc_field_name

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_name — Obtener el nombre de una columna

Descripción

odbc_field_name ( resource $result_id , int $field_number ) : string

Obtiene el nombre de la columna que ocupa el número de columna dado del identificador de resultado dado.

Parámetros

result_id

El identificador de resultado.

field_number

El número de columna. La numeración de columnas comienza en 1.

Valores devueltos

Devuelve el nombre del campo como cadena, o false si se produjo un error.


Devolver el número de columna

  • « odbc_field_name
  • odbc_field_precision »
  • PHP Manual
  • Funciones ODBC
  • Devolver el número de columna

odbc_field_num

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_num — Devolver el número de columna

Descripción

odbc_field_num ( resource $result_id , string $field_name ) : int

Obtiene el número del espacio de columna que se corresponde con el campo nominado del identificador de resultado dado.

Parámetros

result_id

El identificador de resultado.

field_name

El nombre del campo.

Valores devueltos

Devuelve el número de campo como un valor entero, o false si se produjo un error. La numeración de campos comienza en 1.


Alias de odbc_field_len

  • « odbc_field_num
  • odbc_field_scale »
  • PHP Manual
  • Funciones ODBC
  • Alias de odbc_field_len

odbc_field_precision

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_precision — Alias de odbc_field_len()

Descripción

Esta función es un alias de: odbc_field_len().

Ver también

  • odbc_field_scale() - Obtener la escala de un campo para obtener la escala de un número de coma flotante.


Obtener la escala de un campo

  • « odbc_field_precision
  • odbc_field_type »
  • PHP Manual
  • Funciones ODBC
  • Obtener la escala de un campo

odbc_field_scale

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_scale — Obtener la escala de un campo

Descripción

odbc_field_scale ( resource $result_id , int $field_number ) : int

Obtiene la escala de un campo referenciado mediante número del identificador de resultado dado.

Parámetros

result_id

El identificador de resultado.

field_number

El número de campo. La numeración de campos comienza en 1.

Valores devueltos

Devuelve la escala del campo como un valor de tipo integer, o false si se produjo un error.


Tipo de datos de un campo

  • « odbc_field_scale
  • odbc_foreignkeys »
  • PHP Manual
  • Funciones ODBC
  • Tipo de datos de un campo

odbc_field_type

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_type — Tipo de datos de un campo

Descripción

odbc_field_type ( resource $result_id , int $field_number ) : string

Obtiene el tipo SQL de un campo referenciado mediante número en el identificador de resultado dado.

Parámetros

result_id

El identificador de resultado.

field_number

El número de campo. La numeración de campos comienza en 1.

Valores devueltos

Devuelve el tipo de campo como cadena, o false si se produjo un error.


Recupera información de una lista de claves extranjeras

  • « odbc_field_type
  • odbc_free_result »
  • PHP Manual
  • Funciones ODBC
  • Recupera información de una lista de claves extranjeras

odbc_foreignkeys

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_foreignkeys — Recupera información de una lista de claves extranjeras

Descripción

odbc_foreignkeys ( resource $connection_id , string $pk_qualifier , string $pk_owner , string $pk_table , string $fk_qualifier , string $fk_owner , string $fk_table ) : resource

Recupera una lista de claves extranjeras de la tabla especificada o una lista de claves extranjeras de otras tablas que hacen referencia a la clave primaria de la tabla especificada

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

pk_qualifier

El cualificador de clave primaria.

pk_owner

El propietario de la clave primaria.

pk_table

La tabla de la clave primaria.

fk_qualifier

El cualificador de la clave extranjera.

fk_owner

El propietario de la clave extranjera.

fk_table

La tabla de la clave extranjera.

Valores devueltos

Devuelve un identificador de resultado ODBC o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • PKTABLE_QUALIFIER
  • PKTABLE_OWNER
  • PKTABLE_NAME
  • PKCOLUMN_NAME
  • FKTABLE_QUALIFIER
  • FKTABLE_OWNER
  • FKTABLE_NAME
  • FKCOLUMN_NAME
  • KEY_SEQ
  • UPDATE_RULE
  • DELETE_RULE
  • FK_NAME
  • PK_NAME

Si pk_table contiene un nombre de tabla, odbc_foreignkeys() devuelve un conjunto de resultados que contienen la clave primaria de la tabla especificada y todas las claves extranjeras que hacen referencia a ella.

Si fk_table contiene un nombre de tabla, odbc_foreignkeys() devuelve un conjunto de resultados que contienen todas las claves extranjeras de la tabla especificada y las claves primarias (de otras tablas) a las que hacen referencia.

Si pk_table y fk_table contienen nombres de tablas, odbc_foreignkeys() devuelve las claves extranjeras de la tabla especificada en fk_table que hacen referencia a la clave primaria de la tabla especificada en pk_table. Debería ser una clave como máximo.


Liberar los recursos asociados con un resultado

  • « odbc_foreignkeys
  • odbc_gettypeinfo »
  • PHP Manual
  • Funciones ODBC
  • Liberar los recursos asociados con un resultado

odbc_free_result

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_free_result — Liberar los recursos asociados con un resultado

Descripción

odbc_free_result ( resource $result_id ) : bool

Libera los recursos asociados con un resultado.

odbc_free_result() sólo necesita ser llamado si se tiene preocupación de usar demasiada memoria mientras se está ejecutando el script. Toda la memoria de resultados será liberada cuando el script finalice.

Parámetros

result_id

El identificador de resultado.

Valores devueltos

Siempre devuelve true.

Notas

Nota:

Si el auto-envío está deshabilitado (véase odbc_autocommit()) y se llama a odbc_free_result() antes del envío, todas las transacciones pendientes serán reanudadas.


Recupera información sobre los tipos de datos soportados por la fuente de datos

  • « odbc_free_result
  • odbc_longreadlen »
  • PHP Manual
  • Funciones ODBC
  • Recupera información sobre los tipos de datos soportados por la fuente de datos

odbc_gettypeinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_gettypeinfo — Recupera información sobre los tipos de datos soportados por la fuente de datos

Descripción

odbc_gettypeinfo ( resource $connection_id , int $data_type = ? ) : resource

Recupera información sobre los tipos de datos soportados por la fuente de datos.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

data_type

El tipo de datos, el cuál se puede usar para restringir la información a un único tipo de datos.

Valores devueltos

Devuelve un identificador de resultado ODBC o false si se produjo un error.

El conjunto de resultados tiene las siguientes columnas:

  • TYPE_NAME
  • DATA_TYPE
  • PRECISION
  • LITERAL_PREFIX
  • LITERAL_SUFFIX
  • CREATE_PARAMS
  • NULLABLE
  • CASE_SENSITIVE
  • SEARCHABLE
  • UNSIGNED_ATTRIBUTE
  • MONEY
  • AUTO_INCREMENT
  • LOCAL_TYPE_NAME
  • MINIMUM_SCALE
  • MAXIMUM_SCALE

El conjunto de resultados está ordenado por DATA_TYPE y TYPE_NAME.


Manejo de columnas LONG

  • « odbc_gettypeinfo
  • odbc_next_result »
  • PHP Manual
  • Funciones ODBC
  • Manejo de columnas LONG

odbc_longreadlen

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_longreadlen — Manejo de columnas LONG

Descripción

odbc_longreadlen ( resource $result_id , int $length ) : bool

Habilita el manejo de columnas de tipo LONG y LONGVARBINARY.

Parámetros

result_id

El identificador de resultado.

length

El número de bytes devueltos a PHP está controlado por el parámetro length. Si está establecido a 0, la información de la columna Long se pasa a través del cliente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

El manejo de columnas LONGVARBINARY también está afectado por odbc_binmode().


Verifica si están disponibles múltiples resultados

  • « odbc_longreadlen
  • odbc_num_fields »
  • PHP Manual
  • Funciones ODBC
  • Verifica si están disponibles múltiples resultados

odbc_next_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_next_result — Verifica si están disponibles múltiples resultados

Descripción

odbc_next_result ( resource $result_id ) : bool

Verifica si hay más conjuntos de resultados disponibles así como permitir el acceso al siguiente conjunto de resultados mediante odbc_fetch_array(), odbc_fetch_row(), odbc_result(), etc.

Parámetros

result_id

El identificador de resultado.

Valores devueltos

Devuelve true si hay más conjuntos de resultados, false si no.

Ejemplos

Ejemplo #1 odbc_next_result()

<?php
$r_Connection = odbc_connect($dsn, $username, $password);

$s_SQL = <<<END_SQL
SELECT 'A'
SELECT 'B'
SELECT 'C'
END_SQL;

$r_Results = odbc_exec($r_Connection, $s_SQL);

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump first result set";
var_dump($a_Row1, $a_Row2);

echo "Get second results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump second result set ";
var_dump($a_Row1, $a_Row2);

echo "Get third results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump third result set ";
var_dump($a_Row1, $a_Row2);

echo "Try for a fourth result set ";
var_dump(odbc_next_result($r_Results));
?>

El resultado del ejemplo sería:

Dump first result set array(1) {
  ["A"]=>
  string(1) "A"
}
bool(false)
Get second results set bool(true)
Dump second result set array(1) {
  ["B"]=>
  string(1) "B"
}
bool(false)
Get third results set bool(true)
Dump third result set array(1) {
  ["C"]=>
  string(1) "C"
}
bool(false)
Try for a fourth result set bool(false)


Número de columnas de un resultado

  • « odbc_next_result
  • odbc_num_rows »
  • PHP Manual
  • Funciones ODBC
  • Número de columnas de un resultado

odbc_num_fields

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_num_fields — Número de columnas de un resultado

Descripción

odbc_num_fields ( resource $result_id ) : int

Obtiene el número de campos (columnas) de un resultado ODBC.

Parámetros

result_id

El identificador de resultado devuelto por odbc_exec().

Valores devueltos

Devuelve el número de campos, o -1 si se produjo un error.


Número de filas de un resultado

  • « odbc_num_fields
  • odbc_pconnect »
  • PHP Manual
  • Funciones ODBC
  • Número de filas de un resultado

odbc_num_rows

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_num_rows — Número de filas de un resultado

Descripción

odbc_num_rows ( resource $result_id ) : int

Obtiene el número de filas de un resultado. Para las declaraciones INSERT, UPDATE y DELETE, odbc_num_rows() devuelve el número de filas afectadas. Para la cláusula SELECT este puede ser el número de filas disponibles.

Parámetros

result_id

El identificador de resultado devuelto por odbc_exec().

Valores devueltos

Devuelve el número de filas de un resultado ODBC. Esta función devolverá -1 si se produjo un error.

Notas

Nota:

Usar odbc_num_rows() para determinar el número de filas disponibles después de que SELECT devuelva -1 con varios controladores.


Abrir una conexión persistente a una base de datos

  • « odbc_num_rows
  • odbc_prepare »
  • PHP Manual
  • Funciones ODBC
  • Abrir una conexión persistente a una base de datos

odbc_pconnect

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_pconnect — Abrir una conexión persistente a una base de datos

Descripción

odbc_pconnect ( string $dsn , string $user , string $password , int $cursor_type = ? ) : resource

Abre una conexión persistente a una base de datos.

Esta función es como odbc_connect(), excepto que la conexión no se cierra en realidad cuando el script finaliza. Futuras consultas para una conexión con la misma combinación de dsn, user, password (mediante odbc_connect() y odbc_pconnect()) pueden reusar la conexión persistente.

Parámetros

Véase odbc_connect() para más detalles.

Valores devueltos

Devuelve un identificador de conexión ODBCo 0 (false) si se produjo un error.

Notas

Nota: Las conexiones persistentes no tienen efecto si PHP se usa como programa CGI.

Ver también

  • odbc_connect() - Conectar a una fuente de datos
  • Conexiones Persistentes a Bases de Datos


Prepara una declaración para su ejecución

  • « odbc_pconnect
  • odbc_primarykeys »
  • PHP Manual
  • Funciones ODBC
  • Prepara una declaración para su ejecución

odbc_prepare

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_prepare — Prepara una declaración para su ejecución

Descripción

odbc_prepare ( resource $connection_id , string $query_string ) : resource

Prepara una declaración para su ejecución. El identificador de resultado se puede usar después para ejecutar la declaración con odbc_execute().

Algunas bases de datos (como IBM DB2, MS SQL Server, y Oracle) soportan procedimientos almacenados que aceptan parámetros de tipo IN, INOUT, y OUT como están definidos por la especificación ODBC. Sin embargo, el controlador ODBC Unificado actualmente sólo soporta parámetros de tipo IN para procedimientos almacenados.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

query_string

La declaración de cadena de consulta que va a ser preparada.

Valores devueltos

Devuelve un identificador de resultado ODBC si el comando SQL se preparó con éxito. Devuleve false si se produjo un error.

Ejemplos

Ejemplo #1 Ejemplo de odbc_execute() y odbc_prepare()

En el siguiente código, $éxito sólo será true si todos los parámetros de miproc son parámetros IN:

<?php
$a = 1;
$b = 2;
$c = 3;
$stmt    = odbc_prepare($conn, 'CALL miproc(?,?,?)');
$éxito = odbc_execute($stmt, array($a, $b, $c));
?>

Si se necesita llamar a un procedimiento almacenado usando parámetros INOUT o OUT, la solución recomendada es usar una extensión nativa para la base de datos (por ejemplo, oci8 para Oracle).

Ver también

  • odbc_execute() - Ejecutar una declaración preparada


Obtiene las claves primarias de una tabla

  • « odbc_prepare
  • odbc_procedurecolumns »
  • PHP Manual
  • Funciones ODBC
  • Obtiene las claves primarias de una tabla

odbc_primarykeys

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_primarykeys — Obtiene las claves primarias de una tabla

Descripción

odbc_primarykeys ( resource $connection_id , string $qualifier , string $owner , string $table ) : resource

Devuelve un identificador de resultado que puede usarse para traer los nombres de columnas que componen la clave primaria de una tabla.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

owner

table

Valores devueltos

Devuelve un identificador de resultado ODBC o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • COLUMN_NAME
  • KEY_SEQ
  • PK_NAME


Recuperar información sobre los parámetros a procedimientos

  • « odbc_primarykeys
  • odbc_procedures »
  • PHP Manual
  • Funciones ODBC
  • Recuperar información sobre los parámetros a procedimientos

odbc_procedurecolumns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_procedurecolumns — Recuperar información sobre los parámetros a procedimientos

Descripción

odbc_procedurecolumns ( resource $connection_id ) : resource
odbc_procedurecolumns ( resource $connection_id , string $qualifier , string $owner , string $proc , string $column ) : resource

Recuperar información sobre los parámetros a procedimientos.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario. Este parámetro acepta los siguientes patrones de búsqueda: "%" para coincidir cero o más caracteres, y "_" para coincidir un solo caracter.

proc

El procedimiento. Este parámetro acepta los siguientes patrones de búsqueda: "%" para coincidir cero o más caracteres, y "_" para coincidir un solo caracter.

column

La columna. Este parámetro acepta los siguientes patrones de búsqueda: "%" para coincidir cero o más caracteres, y "_" para coincidir un solo caracter.

Valores devueltos

Devuelve una lista de parámetros de entrada y de salida, así como las columnas que componen el conjunto de resultados para los procedimientos especificados. Devuelve un identificador de resultado ODBC o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • COLUMN_NAME
  • COLUMN_TYPE
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

El conjunto de resultados está ordenado por PROCEDURE_QUALIFIER, PROCEDURE_OWNER, PROCEDURE_NAME y COLUMN_TYPE.


Obtener la lista de procedimientos almacenados en una fuente de datos específica

  • « odbc_procedurecolumns
  • odbc_result_all »
  • PHP Manual
  • Funciones ODBC
  • Obtener la lista de procedimientos almacenados en una fuente de datos específica

odbc_procedures

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_procedures — Obtener la lista de procedimientos almacenados en una fuente de datos específica

Descripción

odbc_procedures ( resource $connection_id ) : resource
odbc_procedures ( resource $connection_id , string $qualifier , string $owner , string $name ) : resource

Lista todos los procedimientos en el rango solicitado.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario. Este parámetro acepta los siguientes patrones de búsqueda: "%" para coincidir cero o más caracteres, y "_" para coincidir un solo caracter.

name

El nombre. Este parámetro acepta los siguientes patrones de búsqueda: "%" para coincidir cero o más caracteres, y "_" para coincidir un solo caracter.

Valores devueltos

Devuelve un identificador de resultaod ODBC que contiene la información o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • NUM_INPUT_PARAMS
  • NUM_OUTPUT_PARAMS
  • NUM_RESULT_SETS
  • REMARKS
  • PROCEDURE_TYPE


Imprimir el resultado como una tabla HTML

  • « odbc_procedures
  • odbc_result »
  • PHP Manual
  • Funciones ODBC
  • Imprimir el resultado como una tabla HTML

odbc_result_all

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_result_all — Imprimir el resultado como una tabla HTML

Descripción

odbc_result_all ( resource $result_id , string $format = ? ) : int

Imprime todas las filas de un identificador de resultado producido por odbc_exec(). El resultado se imprime con formato de tabla HTML.

Parámetros

result_id

El identificador de resultado.

format

Formateo de tabla global adicional.

Valores devueltos

Devuelve el número de filas del resultado o false si se produjo un error.


Obtener información de resultado

  • « odbc_result_all
  • odbc_rollback »
  • PHP Manual
  • Funciones ODBC
  • Obtener información de resultado

odbc_result

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_result — Obtener información de resultado

Descripción

odbc_result ( resource $result_id , mixed $field ) : mixed

Obtener información de resultado

Parámetros

result_id

El resource ODBC.

field

El nombre de campo a ser traído. Puede ser un entero que contiene el número de columna o el campo que se quiera; o puede ser una cadena que contiene el nombre del campo.

Valores devueltos

Devuelve los contenidos de cadena del campo, false si se produjo un error, null para datos NULL, o true para datos binarios.

Ejemplos

La primera llamada a odbc_result() devuelve el valor del tercer campo del registro actual del resultado de la consulta. La segunda llamada a odbc_result() devuelve el valor del campo cuyo nombre de campo es "val" en el registro actual del resultado de la consulta. Ocurrirá un error si un parámetro de número de columna para un campo es menor o excede al número de columnas (o campos) del registro actual. De forma similar, ocurrirá un error si un campo con un nombre que no es uno de los nombres de campos de la/s tabla/s que está/n siendo consultada/s.

Ejemplo #1 Ejemplos de odbc_result()

<?php
$item_3   = odbc_result($Query_ID, 3);
$item_val = odbc_result($Query_ID, "val");
?>

Notas

Los índices de campos comienzan en 1. Respecto a la forma en que la información binaria o de tipo long es devuelta, consulte odbc_binmode() y odbc_longreadlen().


Revertir una transacción

  • « odbc_result
  • odbc_setoption »
  • PHP Manual
  • Funciones ODBC
  • Revertir una transacción

odbc_rollback

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_rollback — Revertir una transacción

Descripción

odbc_rollback ( resource $connection_id ) : bool

Revierte todas las sentencias pendientes de la conexión.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Ajustar la configuración de ODBC

  • « odbc_rollback
  • odbc_specialcolumns »
  • PHP Manual
  • Funciones ODBC
  • Ajustar la configuración de ODBC

odbc_setoption

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_setoption — Ajustar la configuración de ODBC

Descripción

odbc_setoption ( resource $id , int $function , int $option , int $param ) : bool

Esta función permite juguetear con las opciones de ODBC para una conexión o resultado de consulta en particular. Fue escrita para ayudar a encontrar soluciones a problemas en controladoes ODBC estrafalarios. Probablemente, debería usar esta función sólo si es un programador de ODBC y entiende los efectos de las opciones que se dan. Desde luego necesitará una buena referencia de ODBC para explicar todas las diferentes opciones y valores que se pueden usar. Diferentes versiones de controlardes soportan diferentes opciones.

Ya que los efectos pueden variar dependiendo del controlador ODBC, se desaconseja el uso de esta función en scripts que van a estar disponilbes públicamente. También, algunas opciones ODBC no están disponibles para esta función ya que deben ser establecidas antes de que se establezca la conexión o la consulta esté preparada. No obstante, lo que realmente importa es que si en trabajo en particular hace que PHP funcione, su jefe no le diga que use un producto comercial.

Parámetros

id

Es un id de conexión o de resultado sobre el que cambiar las configuraciones. Para SQLSetConnectOption(), es un id de conexión. Para SQLSetStmtOption(), es un id de resultado.

function

Es la función ODBC a usar. El valor debería ser 1 para SQLSetConnectOption() y 2 para SQLSetStmtOption().

option

La opción a establecer.

param

El valor para la opción dada por option.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplos de odbc_setoption()

<?php
// 1. Opción 102 de SQLSetConnectOption() es SQL_AUTOCOMMIT.
//    Valor 1 de SQL_AUTOCOMMIT es SQL_AUTOCOMMIT_ON.
//    Este ejemplo tiene el mismo efecto que
//    odbc_autocommit($conexión, true);

odbc_setoption($conexión, 1, 102, 1);

// 2. Opción 0 de SQLSetStmtOption() es SQL_QUERY_TIMEOUT.
//    Este ejemplo establece la consulta para que termine después de 30 segundos.

$resultado = odbc_prepare($conexión, $sql);
odbc_setoption($resultado, 2, 0, 30);
odbc_execute($resultado);
?>


Recupera columnas especiales

  • « odbc_setoption
  • odbc_statistics »
  • PHP Manual
  • Funciones ODBC
  • Recupera columnas especiales

odbc_specialcolumns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_specialcolumns — Recupera columnas especiales

Descripción

odbc_specialcolumns ( resource $connection_id , int $type , string $qualifier , string $owner , string $table , int $scope , int $nullable ) : resource

Recupera o bien el conjunto óptimo de columnas que identifican de manera única una fila de la tabla, o las columnas que son actualizadas automáticamente cuando cualquier valor de la fila es actualizado por una transacción.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

type
Cuando el tipo de argumento es SQL_BEST_ROWID, odbc_specialcolumns() devuelve la columna o columnas que identifican de forma única cada fila de la tabla. Cuando el tipo de argumento es SQL_ROWVER, odbc_specialcolumns() devuelve la columnas o columnas de la tabla especificada, si hibiera alguna, que son actualizadas automáticamente por la fuente de datos cuando cualquier valor de la fila es actualizado por cualquier transacción.
qualifier

El cualificador.

owner

El propietario.

table

La tabla.

scope

El alcance, el cual ordena el conjunto de resultados.

nullable

La opción nullable.

Valores devueltos

Devuelve un identificador de resultado ODBC o false si se produjo un fallo.

El conjunto de resultados tiene las siguientes columnas:

  • SCOPE
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • PSEUDO_COLUMN


Recuperar las estadísticas de un tabla

  • « odbc_specialcolumns
  • odbc_tableprivileges »
  • PHP Manual
  • Funciones ODBC
  • Recuperar las estadísticas de un tabla

odbc_statistics

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_statistics — Recuperar las estadísticas de un tabla

Descripción

odbc_statistics ( resource $connection_id , string $qualifier , string $owner , string $table_name , int $unique , int $accuracy ) : resource

Obteber las estadísticas de una tabla y sus índices.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario.

table_name

El nombre de la tabla.

unique

El atributo unique.

accuracy

La presición.

Valores devueltos

Devuelve un identificador de resultado ODBC o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • NON_UNIQUE
  • INDEX_QUALIFIER
  • INDEX_NAME
  • TYPE
  • SEQ_IN_INDEX
  • COLUMN_NAME
  • COLLATION
  • CARDINALITY
  • PAGES
  • FILTER_CONDITION

El conjunto de resultados está ordenado por NON_UNIQUE, TYPE, INDEX_QUALIFIER, INDEX_NAME y SEQ_IN_INDEX.


Lista las tablas y los privilegios asociados con cada tabla

  • « odbc_statistics
  • odbc_tables »
  • PHP Manual
  • Funciones ODBC
  • Lista las tablas y los privilegios asociados con cada tabla

odbc_tableprivileges

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_tableprivileges — Lista las tablas y los privilegios asociados con cada tabla

Descripción

odbc_tableprivileges ( resource $connection_id , string $qualifier , string $owner , string $name ) : resource

Lista las tablas en el rango solicitado y los privilegios asociados con cada tabla.

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario. Acepta los siguientes patrones de búsqueda: ('%' para comparar cero o más caracteres y '_' para comparar un único carácter)

name

EL nombre. Acepta los siguientes patrones de búsqueda: ('%' para comparar cero o más caracteres y '_' para comparar un único carácter)

Valores devueltos

Un identificador de resultado ODBC o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

El conjunto de resultados está ordenado por TABLE_QUALIFIER, TABLE_OWNER y TABLE_NAME.


Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica

  • « odbc_tableprivileges
  • PDO »
  • PHP Manual
  • Funciones ODBC
  • Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica

odbc_tables

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_tables — Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica

Descripción

odbc_tables ( resource $connection_id , string $qualifier = ? , string $owner = ? , string $name = ? , string $types = ? ) : resource

Lista todas las tablas del rango solicitado.

Para soportar la enumeración de cualificadores, propietarios y tipos de tabla, están disponibles las siguientes semánticas especiales para qualifier, owner, name, y table_type:

  • Si qualifier es un único carácter de porcentaje (%) y owner y name son cadenas vacías, el conjunto de resultados contendrá una lista de cualificadores válidos para la fuente de datos. (Todas las columnas excepto la columna TABLE_QUALIFIER contienen NULLs.)
  • Si owner es un único carácter de porcentaje (%) y qualifier y name son cadenas vacías, el conjunto de resultados contendrá una lista de propietarios válidos para la fuente de datos. (Todas las columnas excepto la columna TABLE_OWNER contienen NULLs.)
  • Si table_type es un único carácter de porcentaje (%) y qualifier, owner y name son cadenas vacías, el conjunto de resultados contendrá una lista de tipos de tablas válidos para la fuente de datos. (Todas las columnas excepto la conlumna TABLE_TYPE contienen NULLs.)

Parámetros

connection_id

El conector identificador ODBC, ver odbc_connect() para más información.

qualifier

El cualificador.

owner

El propietario. Acepta patrones de búsqueda ('%' para comparar cero o más caracteres y '_' para comparar un único carácter).

name

El nombre. Acepta patrones de búsqueda ('%' para comparar cero o más caracteres y '_' para comparar un único carácter).

types

Si table_type no es una cadena vacía debe contener una lista de valores serparados por comas para los tipos que son de interés; cada valor puede ser encerrado en comillas simples (') o sin comillas. Por ejemplo, "'TABLE','VIEW'" o "TABLE, VIEW". Si la fuente de datos no soporta un tipo de tabla especificado, odbc_tables() no devolverá ningún resultado para ese tipo.

Valores devueltos

Devuelve un identificador de resultado ODBC que contiene la información o false en caso de error.

El conjunto de resultados tiene las siguientes columnas:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • TABLE_TYPE
  • REMARKS

El conjunto de resultados está ordenado por TABLE_TYPE, TABLE_QUALIFIER, TABLE_OWNER y TABLE_NAME.

Ver también

  • odbc_tableprivileges() - Lista las tablas y los privilegios asociados con cada tabla


Objetos de datos de PHP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Conexiones y su administración
  • Transacciones y autoconsigna ("auto-commit")
  • Sentencias preparadas y procedimientos almacenados
  • Errores y su manejo
  • Objetos grandes (LOB)
  • PDO — La clase PDO
    • PDO::beginTransaction — Inicia una transacción
    • PDO::commit — Consigna una transacción
    • PDO::__construct — Crea una instancia de PDO que representa una conexión a una base de datos
    • PDO::errorCode — Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
    • PDO::errorInfo — Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
    • PDO::exec — Ejecuta una sentencia SQL y devuelve el número de filas afectadas
    • PDO::getAttribute — Devuelve un atributo de la conexión a la base de datos
    • PDO::getAvailableDrivers — Devuelve un array con los controladores de PDO disponibles
    • PDO::inTransaction — Comprueba si una transacción está activa
    • PDO::lastInsertId — Devuelve el ID de la última fila o secuencia insertada
    • PDO::prepare — Prepara una sentencia para su ejecución y devuelve un objeto sentencia
    • PDO::query — Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
    • PDO::quote — Entrecomilla una cadena de caracteres para usarla en una consulta
    • PDO::rollBack — Revierte una transacción
    • PDO::setAttribute — Establece un atributo
  • PDOStatement — La clase PDOStatement
    • PDOStatement::bindColumn — Vincula una columna a una variable de PHP
    • PDOStatement::bindParam — Vincula un parámetro al nombre de variable especificado
    • PDOStatement::bindValue — Vincula un valor a un parámetro
    • PDOStatement::closeCursor — Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez
    • PDOStatement::columnCount — Devuelve el número de columnas de un conjunto de resultados
    • PDOStatement::debugDumpParams — Vuelca un comando preparado de SQL
    • PDOStatement::errorCode — Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia
    • PDOStatement::errorInfo — Obtiene información ampliada del error asociado con la última operación del gestor de sentencia
    • PDOStatement::execute — Ejecuta una sentencia preparada
    • PDOStatement::fetch — Obtiene la siguiente fila de un conjunto de resultados
    • PDOStatement::fetchAll — Devuelve un array que contiene todas las filas del conjunto de resultados
    • PDOStatement::fetchColumn — Devuelve una única columna de la siguiente fila de un conjunto de resultados
    • PDOStatement::fetchObject — Obtiene la siguiente fila y la devuelve como un objeto
    • PDOStatement::getAttribute — Recupera un atributo de sentencia
    • PDOStatement::getColumnMeta — Devuelve metadatos de una columna de un conjunto de resultados
    • PDOStatement::nextRowset — Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas
    • PDOStatement::rowCount — Devuelve el número de filas afectadas por la última sentencia SQL
    • PDOStatement::setAttribute — Establece un atributo de sentencia
    • PDOStatement::setFetchMode — Establece el modo de obtención para esta sentencia
  • PDOException — La clase PDOException
  • Controladores de PDO
    • CUBRID (PDO) — Funciones de CUBRID (PDO_CUBRID)
    • MS SQL Server (PDO) — Funciones de Microsoft SQL Server y Sybase (PDO_DBLIB)
    • Firebird (PDO) — Funciones de Firebird (PDO_FIREBIRD)
    • IBM (PDO) — Funciones de IBM (PDO_IBM)
    • Informix (PDO) — Funciones de Informix (PDO_INFORMIX)
    • MySQL (PDO) — Funciones de MySQL (PDO_MYSQL)
    • MS SQL Server (PDO) — Funciones de Microsoft SQL Server (PDO_SQLSRV)
    • Oracle (PDO) — Funciones de Oracle (PDO_OCI)
    • ODBC y DB2 (PDO) — Funciones de ODBC y DB2 (PDO_ODBC)
    • PostgreSQL (PDO) — Funciones de PostgreSQL (PDO_PGSQL)
    • SQLite (PDO) — Funciones de SQLite (PDO_SQLITE)


Introducción

La extensión Objetos de Datos de PHP (PDO por sus siglás en inglés) define una interfaz ligera para poder acceder a bases de datos en PHP. Cada controlador de bases de datos que implemente la interfaz PDO puede exponer características específicas de la base de datos, como las funciones habituales de la extensión. Se ha de observar que no se puede realizar ninguna de las funciones de las bases de datos utilizando la extensión PDO por sí misma; se debe utilizar un controlador de PDO específico de la base de datos para tener acceso a un servidor de bases de datos.

PDO proporciona una capa de abstracción de acceso a datos, lo que significa que, independientemente de la base de datos que se esté utilizando, se emplean las mismas funciones para realizar consultas y obtener datos. PDO no proporciona una abstracción de bases de datos; no reescribe SQL ni emula características ausentes. Se debería usar una capa de abstracción totalmente desarrollada si fuera necesaria tal capacidad.

PDO viene con PHP 5.1, y está disponible como una extensión PECL para PHP 5.0; PDO requiere las características nuevas de OO del núcleo de PHP 5, por lo que no se ejecutará con versiones anteriores de PHP.


Instalación

Instalar PDO en sistemas UNIX

  1. PDO y el controlador PDO_SQLITE están activados de manera predeterminada a partir de PHP 5.1.0. Podría ser necesario activar el controlador PDO para la base de datos de su elección; consulte la documentación sobre los Controladores de PDO para bases de datos específicas para obtener más información.

    Nota:

    Cuando se construya PDO como una extensión compartida (no recomendado), todos los controladores de PDO deben ser cargados después del propio PDO.

  2. Cuando se instale PDO como un módulo compartido, será necesario actualizar el fichero php.ini. Así, la extensión PDO será cargada automáticamente cuando se ejecute PHP. También será necesario activar cualquier controlador de bases de datos específico en dicho fichero. Asegúrese de que estén declarados después de la línea pdo.so, pues PDO debe inicilizarse antes de cargar las extensiones específicas para bases de datos. Si se construyen estáticamente PDO y las extensiones específicas para bases de datos, se puede omitir este paso.

    extension=pdo.so

Usuarios de Windows

  1. PDO y la mayoría de controladores vienen en PHP como extensiones compartidas; para activarlas, simplemente se debe editar el fichero php.ini

    extension=php_pdo.dll

    Nota:

    Este paso no es necesario para PHP 5.3 o superior, pues ya no se requiere la DLL para utilizar PDO.

  2. Después, elija los demás ficheros DLL de bases de datos específicas, y utilice dl() para cargarlos en tiempo de ejecución, o actívelos en php.ini por debajo de la línea php_pdo.dll. Por ejemplo:

    extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_informix.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll
extension=php_pdo_odbc.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll

    Estas DLL deberían existir en el directorio extension_dir del sistema.

Nota:

Recuerde que después de realizar cambios en el fichero php.ini, será necesario reiniciar PHP para que las nuevas directivas de configuración surtan efecto.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de PDO
Nombre | Por defecto | Cambiable | Historial de cambios
pdo.dsn.* |  | Solamente php.ini |

He aquí una breve explicación de las directivas de configuración.

pdo.dsn.* string

Define un alias de un DSN. Véase PDO::__construct() para una explicación detallada.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Advertencia

PDO utiliza constantes de clase desde PHP 5.1. Las versiones anteriores emplean constantes globales bajo la forma PDO_PARAM_BOOL.

PDO::PARAM_BOOL (integer)
Representa un tipo de dato booleano.
PDO::PARAM_NULL (integer)
Representa el tipo de dato NULL de SQL.
PDO::PARAM_INT (integer)
Representa el tipo de dato INTEGER de SQL .
PDO::PARAM_STR (integer)
Representa el tipo de dato CHAR, VARCHAR de SQL, u otro tipo de datos de cadena.
PDO::PARAM_STR_NATL (integer)
Disponible desde PHP 7.2.0
PDO::PARAM_STR_CHAR (integer)
Disponible desde PHP 7.2.0
PDO::PARAM_LOB (integer)
Representa el tipo de dato de objeto grande (LOB) de SQL.
PDO::PARAM_STMT (integer)
Representa un tipo de conjunto de registros. No está soportado actualmente por ningún controlador.
PDO::PARAM_INPUT_OUTPUT (integer)
Especifica que el parámetro es de entrada/salida (INOUT) para un procedimiento almacenado. Se debe realizar un OR a nivel de bit con un tipo de datos PDO::PARAM_* explícito.
PDO::FETCH_LAZY (integer)
Especifica que el método de obtención debe devolver cada fila como un objeto con los nombres de las variables equivalentes a los nombres de las columnas devueltos en el conjunto de resultados. PDO::FETCH_LAZY crea los nombres de las variables del objeto a medida que se acceden a ellas. No es válida dentro de PDOStatement::fetchAll().
PDO::FETCH_ASSOC (integer)
Especifica que el método de obtención debe devolver cada fila como un array indexado por los nombres de las columnas devueltos en el correspondiente conjunto de resultados. Si éste contiene varias columnas con el mismo nombre, PDO::FETCH_ASSOC devuelve un único valor por nombre de columna.
PDO::FETCH_NAMED (integer)
Especifica que el método de obtención debe devolver cada fila como un array indexado por los nombres de las columnas devueltos en el correspondiente conjunto de resultados. Si éste contiene varias columnas con el mismo nombre, PDO::FETCH_NAMED devuelve un array de valores por nombre de columna.
PDO::FETCH_NUM (integer)
Especifica que el método de obtención debe devolver cada fila como un array indexado por los números de columna devueltos en el correspondiente conjunto de resultados, comenzando por la columna 0.
PDO::FETCH_BOTH (integer)
Especifica que el método de obtención debe devolver cada fila como un array indexado tanto por los nombres como por los números de las columnas devueltos en el correspondiente conjunto de resultados, comenzando por la columna 0.
PDO::FETCH_OBJ (integer)
Especifica que el método de obtención debe devolver cada fila como un objeto con los nombres de sus propiedades equivalentes a los nombres de las columnas devueltos en el conjunto de resultados.
PDO::FETCH_BOUND (integer)
Especifica que el método de obtención debe devolver TRUE y asignar los valores de las columnas del conjunto de resultados a las variables de PHP a las cuales están vinculadas con los métodos PDOStatement::bindParam() o PDOStatement::bindColumn().
PDO::FETCH_COLUMN (integer)
Especifica que el método de obtención debe devolver una única columna solicitada de la siguiente fila del conjunto de resultados.
PDO::FETCH_CLASS (integer)
Especifica que el método de obtención debe devolver una nueva instancia de la clase solicitada, haciendo corresponder las columnas con los nombres de las propiedades de la clase.

Nota: El método mágico __set() se invoca si la propiedad no existe en la clase solicitada.

PDO::FETCH_INTO (integer)
Especifica que el método de obtencion debe actualizar una instancia existente de la clase solicitada, haciendo corresponder las columnas con los nombres de las propiedades de la clase.
PDO::FETCH_FUNC (integer)
Permite personalizar completamente la forma en que los datos son tratados sobre la marcha (únicamente válida dentro de PDOStatement::fetchAll()).
PDO::FETCH_GROUP (integer)
Grupo devuelto según valores. Usualmente combinada con PDO::FETCH_COLUMN o PDO::FETCH_KEY_PAIR.
PDO::FETCH_UNIQUE (integer)
Obtener solamente los valores únicos.
PDO::FETCH_KEY_PAIR (integer)
Obtener un resultado de dos columnas como un array donde la primera columna es la clave y la segunda el valor. Disponible desde PHP 5.2.3.
PDO::FETCH_CLASSTYPE (integer)
Determinar el nombre de la clase desde el valor de la primera columna.
PDO::FETCH_SERIALIZE (integer)
Igual que PDO::FETCH_INTO salvo que el objeto es proporcionado como una cadena serializada. Disponible desde PHP 5.1.0. Desde PHP 5.3.0, nunca se llama al constructor de la clase si está establecido este indicador.
PDO::FETCH_PROPS_LATE (integer)
Llamar al contructor antes de establecer propiedades. Disponible desde PHP 5.2.0
PDO::ATTR_AUTOCOMMIT (integer)
Si este valor es false, PDO intenta desactivar la autoconsigna para que la conexión comience una transacción.
PDO::ATTR_PREFETCH (integer)
Establecer el tamaño de la precarga permite obtener un equilibrio entre rapidez y utilización de memoria para la aplicación. No todas las combinaciones de base de datos y controlador permiten establecer el tamaño de la precarga. Un valor más grande de precarga da como resultado un aumento del rendimiento a costa de un mayor uso de memoria.
PDO::ATTR_TIMEOUT (integer)
Establece el valor del tiempo de espera, en segundos, para las comunicaciones con la base de datos.
PDO::ATTR_ERRMODE (integer)
Véase la sección Errores y su manejo para obtener más información sobre este atributo.
PDO::ATTR_SERVER_VERSION (integer)
Este es un atributo de sólo lectura; devuelve información sobre la versión del servidor de bases de datos al que está conectado PDO.
PDO::ATTR_CLIENT_VERSION (integer)
Este es un atributo de sólo lectura; devuelve información sobre la versión de las bibliotecas cliente que está usando el controlador PDO.
PDO::ATTR_SERVER_INFO (integer)
Este es un atributo de sólo lectura; devuelve alguna metainformación sobre el servidor de bases de datos al que está conectado PDO.
PDO::ATTR_CONNECTION_STATUS (integer)
PDO::ATTR_CASE (integer)
Forzar a los nombres de las columnas a emplear las mayúsculas/minúsculas especificadas por las constantes PDO::CASE_*.
PDO::ATTR_CURSOR_NAME (integer)
Obtener o establecer el nombre del cursor a utilizar. Es más útil cuando se emplean cursores desplazables y actualizaciones posicionadas.
PDO::ATTR_CURSOR (integer)
Selecciona el tipo de cursor. PDO actualmente admite
PDO::CURSOR_FWDONLY y
PDO::CURSOR_SCROLL. Cíñase a
PDO::CURSOR_FWDONLY a menos que necesite un
cursor desplazable.
PDO::ATTR_DRIVER_NAME (string)
Devuelve el nombre del controlador.

Ejemplo #1 Uso de PDO::ATTR_DRIVER_NAME

<?php
if ($bd->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
  echo "Ejecutándose sobre mysql; hacer algo específico de mysql aquí\n";
}
?>

PDO::ATTR_ORACLE_NULLS (integer)
Convertir string vacíos a valores NULL de SQL en la obtención de datos.
PDO::ATTR_PERSISTENT (integer)
Solicitar una conexión persistente, en vez de crear una nueva conexión. Véase Conexiones y su administración para obtener más información sobre este atributo.
PDO::ATTR_STATEMENT_CLASS (integer)
PDO::ATTR_FETCH_CATALOG_NAMES (integer)
Anteponer el nombre del catálogo contenedor a cada nombre de columna devuelto en el conjunto de resultados. El nombre del catálogo y el nombre de columna están separados por un carácter punto (.). El soporte de este atributo es a nivel del controlador; podría no estar admitido por el controlador que se esté utilizando.
PDO::ATTR_FETCH_TABLE_NAMES (integer)
Anteponer el nombre de la tabla contenedora a cada nombre de columna devuelto en el conjunto de resultados. El nombre de la tabla y el nombre de columna están separados por un carácter punto (.). El soporte de este atributo es a nivel del controlador; podría no estar admitido por el controlador que se esté utilizando.
PDO::ATTR_STRINGIFY_FETCHES (integer)
PDO::ATTR_MAX_COLUMN_LEN (integer)
PDO::ATTR_DEFAULT_FETCH_MODE (integer)
Disponible desde PHP 5.2.0.
PDO::ATTR_EMULATE_PREPARES (integer)
Disponible desde PHP 5.1.3.
PDO::ATTR_DEFAULT_STR_PARAM (integer)
Disponible desde PHP 7.2.0.
PDO::ERRMODE_SILENT (integer)
No emitir ningún error o excepción si ocurrieran. El desarrollador es responsable de comprobar explícitamente los errores. Este es el modo predeterminado. Véase Errores y su manejo para obtener más información sobre este atributo.
PDO::ERRMODE_WARNING (integer)
Emitir un mensaje E_WARNING de PHP si ocurre algún error. Véase Errores y su manejo para obtener más información sobre este atributo.
PDO::ERRMODE_EXCEPTION (integer)
Lanzar una PDOException si ocurre algún error. Véase Errores y su manejo para obtener más información sobre este atributo.
PDO::CASE_NATURAL (integer)
Dejar los nombres de las columnas tal como son devueltos por el controlador de la base de datos.
PDO::CASE_LOWER (integer)
Forzar los nombres de las columnas a minúsculas.
PDO::CASE_UPPER (integer)
Forzar los nombres de las columnas a mayúsculas.
PDO::NULL_NATURAL (integer)
PDO::NULL_EMPTY_STRING (integer)
PDO::NULL_TO_STRING (integer)
PDO::FETCH_ORI_NEXT (integer)
Obtener la siguiente fila del conjunto de resultados. Únicamente válida para cursores desplazables.
PDO::FETCH_ORI_PRIOR (integer)
Obtener la fila anterior del conjunto de resultados. Únicamente válida para cursores desplazables.
PDO::FETCH_ORI_FIRST (integer)
Obtener la primera fila del conjunto de resultados. Únicamente válida para cursores desplazables.
PDO::FETCH_ORI_LAST (integer)
Obtener la última fila del conjunto de resultados. Únicamente válida para cursores desplazables.
PDO::FETCH_ORI_ABS (integer)
Obtener la fila solicitada del conjunto de resultados mediante el número de fila. Únicamente válida para cursores desplazables.
PDO::FETCH_ORI_REL (integer)
Obtener la fila solicitada del conjunto de resultados mediante la posición relativa de la posición actual del cursor. Únicamente válida para cursores desplazables.
PDO::CURSOR_FWDONLY (integer)
Crear un objeto PDOStatement con un cursor de sólo avance. Este es la elección del cursor predeterminada, ya que es el patrón de acceso a datos más rápido y común en PHP.
PDO::CURSOR_SCROLL (integer)
Crear un objeto PDOStatement con un cursor desplazable. De deben pasar las constantes PDO::FETCH_ORI_* para controlar las filas obtenidas del conjunto de resultados.
PDO::ERR_NONE (string)
Corresponde al SQLSTATE '00000', el cual significa que la sentencia SQL fue ejecutada con éxito, sin errores ni advertencias. Esta constante sirve para la comprobación de PDO::errorCode() o PDOStatement::errorCode() para determinar si ha ocurrido algún error. En cualquier caso, normalmente se sabrá si este es el caso examinando el código devuelto por el método que provocó la condición de error.
PDO::PARAM_EVT_ALLOC (integer)
Evento de asignación
PDO::PARAM_EVT_FREE (integer)
Evento de desasigncación
PDO::PARAM_EVT_EXEC_PRE (integer)
Evento provocado antes de la ejecución de una sentencia preparada.
PDO::PARAM_EVT_EXEC_POST (integer)
Evento provocado después de la ejecución de una sentencia preparada.
PDO::PARAM_EVT_FETCH_PRE (integer)
Evento provocado antes de la obtención de un resultado de un conjunto de resultados.
PDO::PARAM_EVT_FETCH_POST (integer)
Evento provocado después de la obtención de un resultado de un conjunto de resultados.
PDO::PARAM_EVT_NORMALIZE (integer)
Evento provocado durante el registro de un parámetro vinculado, permitiendo al controlador normalizar el nombre del parámetro.


Conexiones y su administración

Las conexiones se establecen creando instancias de la clase base PDO. No importa el controlador que se utilice; siempre se usará el nombre de la clase PDO. El constructor acepta parámetros para especificar el origen de la base de datos (conocido como DSN) y, opcionalmente, el nombre de usuario y la contraseña (si la hubiera).

Ejemplo #1 Conectarse a MySQL

<?php
$mbd = new PDO('mysql:host=localhost;dbname=prueba', $usuario, $contraseña);
?>

Si hubieran errores de conexión, se lanzará un objeto PDOException. Se puede capturar la excepción si fuera necesario manejar la condición del error, o se podría optar por dejarla en manos de un manejador de excepciones global de aplicación configurado mediante set_exception_handler().

Ejemplo #2 Manejo de errores de conexión

<?php
try {
    $mbd = new PDO('mysql:host=localhost;dbname=prueba', $usuario, $contraseña);
    foreach($mbd->query('SELECT * from FOO') as $fila) {
        print_r($fila);
    }
    $mbd = null;
} catch (PDOException $e) {
    print "¡Error!: " . $e->getMessage() . "<br/>";
    die();
}
?>

Advertencia

Si la aplicación no captura la excepción lanzada por el constructor de PDO, la acción predeterminada que toma el motor zend es la de finalizar el script y mostrar información de seguimiento. Esta información probablemente revelará todos los detalles de la conexión a la base de datos, incluyendo el nombre de usuario y la contraseña. Es su responsabilidad capturar esta excepción, ya sea explícitamente (con una sentencia catch) o implícitamente por medio de set_exception_handler().

Una vez realizada con éxito una conexión a la base de datos, será devuelta una instancia de la clase PDO al script. La conexión permanecerá activa durante el tiempo de vida del objeto PDO. Para cerrar la conexión, es necesario destruir el objeto asegurándose de que todas las referencias a él existentes sean eliminadas; esto se puede hacer asignando null a la variable que contiene el objeto. Si no se realiza explícitamente, PHP cerrará automáticamente la conexión cuando el script finalice.

Nota: Si aún existen otras referencias a esta instancia de PDO (tales como desde una instancia de PDOStatement, o desde otras variables que hacen referencia a la misma instancia de PDO), estas también han de eliminarse (por ejemplo, asignando NULL a la variable que hace referencia al PDOStatement).

Ejemplo #3 Cerrar una conexión

<?php
$mbd = new PDO('mysql:host=localhost;dbname=prueba', $usuario, $contraseña);
// Utilizar la conexión aquí
$sth = $mbd->query('SELECT * FROM foo');

// Ya se ha terminado; se cierra
$sth = null;
$mbd = null;
?>

Muchas aplicaciones web se beneficiarán del uso de conexiones persistentes a servidores de bases de datos. Las conexiones persistentes no son cerradas al final del script, sino que son almacenadas en caché y reutilizadas cuando otro script solicite una conexión que use las mismas credenciales. La caché de conexiones persistentes permite evitar la carga adicional de establecer una nueva conexión cada vez que un script necesite comunicarse con la base de datos, dando como resultado una aplicación web más rápida.

Ejemplo #4 Conexiones persistentes

<?php
$mbd = new PDO('mysql:host=localhost;dbname=prueba', $usuario, $contraseña, array(
    PDO::ATTR_PERSISTENT => true
));
?>

Nota:

Para utilizar conexiones persistentes, se deberá establecer PDO::ATTR_PERSISTENT en las opciones del array del controlador pasado al constructor de PDO. Si este atributo se establece con PDO::setAttribute() después de la instanciación del objeto, el controlador no utilizará conexiones persistentes.

Nota:

Si se usa el controlador PDO y las bibliotecas ODBC admiten el aprovisionamiento de conexiones ODBC (unixODBC y Windows lo hacen; podrían haber más), se recomienda no utilizar las conexiones persistentes de PDO, y, en su lugar, dejar el almacenamiento en caché de conexiones a la capa del aprovisionamiento de conexiones de ODBC. La provisión de conexiones de ODBC se comparte con otros módulos en el proceso; si se le indica a PDO que almacene en caché la conexión, entonces dicha conexión nunca será devuelta a la provisión de conexiones de ODBC, dando como resultado la creación de conexiones adicionales para servir a los demás módulos.


Transacciones y autoconsigna ("auto-commit")

Una vez realizada una conexión a través de PDO, es necesario comprender cómo PDO gestiona las transacciones antes de comenzar a realizar consultas. Para aquellos que no han manejado anteriormente transacciones, estas ofrecen cuatro características principales: Atomicidad, Consistencia, Aislamiento y Durabilidad (ACID por sus siglas en inglés). En términos sencillos, se garantiza que cualquier trabajo llevado a cabo en una transacción, incluso si se hace por etapas, sea aplicado a la base de datos de forma segura, y sin interferencia de otras conexiones, cuando sea consignado. El trabajo transaccional puede también ser deshecho automáticamente bajo petición (siempre y cuando no se haya consignado ya), lo que hace más sencillo el manejo de errores en los scripts.

Una transacción se implementa normalmente para hacer que el lote de cambios se aplique a la vez. Esto tiene el buen efecto secundario de mejorar drásticamente la eficiencia de las actualizaciones. En otras palabras, las transacciones pueden hacer los scripts más rápidos y potencialmente más robustos (aún así es necesario utilizarlas correctamente para obtener tal beneficio).

Desafortunadamente, no todas las bases de datos admiten transacciones, por lo que PDO necesita ejecutarse en lo que es conocido como el modo "auto-commit" cuando se abra por primera vez la conexión. El modo auto-commit significa que toda consulta que se ejecute tiene su propia transacción implícita, si la base de datos la admite, o ninguna transacción si la base de datos no las admite. Para iniciar una transacción, si fuera necesario, se debe usar el método PDO::beginTransaction(). Si el controlador subyacente no admite transacciones, se lanzará una PDOException (independientemente de la configuración del manejo de errores: esto es siempre una condición de error serio). Una vez dentro de una transacción, se puede utilizar PDO::commit() o PDO::rollBack() para finalizarla, dependiendo del éxito del código que se ejecute durante la transacción.

Advertencia

PDO solamente comprueba la funcionalidad de transacciones a nivel del controlador. Si una cierta condición durante la ejecución implica que las transacciones no estén disponibles, PDO::beginTransaction() seguirá devolviendo true sin ningún error si el servidor de bases de datos acepta la solicitud de iniciar una transacción.

Un ejemplo podría ser el intento de utilizar transacciones en tablas MyISAM en una base de datos MySQL.

Cuando el script finaliza o cuando una conexión está a punto de ser cerrada, si existe una transacción pendiente, PDO la revertirá automáticamente. Esto es una medida de seguridad que ayuda a evitar inconsistencia en los casos donde el script finaliza inesperadamente (si no se consignó la transacción, se asume que algo salió mal, con lo cual se realiza la reversión para la seguridad de los datos).

Advertencia

La reversión automática solamente ocurre si se inicia una transacción a través de PDO::beginTransaction(). Si se ejecuta manualmente una consulta que inicie una transacción, PDO no tiene forma de saber nada sobre la misma y, por tanto, no puede revertirla si algo saliera mal.

Ejemplo #1 Ejecución de un lote en una transacción

En el siguiente ejemplo, se asume que se ha creado un conjunto de entradas para un nuevo empleado, al cual se le ha asignado el número de ID 23. Además de introducir los datos básicos de una persona, también es necesario registrar su sueldo. Es bastante simple realizar dos actualizaciones independientes, pero realizándolas entre las llamadas a PDO::beginTransaction() y PDO::commit() se garantiza que nadie más será capaz de ver los cambios hasta que se hayan completado. Si algo sale mal, el bloque catch revierte los cambios realizados desde que se creó la transacción y luego imprime un mensaje de error.

<?php
try {
  $mbd = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2',
      array(PDO::ATTR_PERSISTENT => true));
  echo "Conectado\n";
} catch (Exception $e) {
  die("No se pudo conectar: " . $e->getMessage());
}

try {
  $mbd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

  $mbd->beginTransaction();
  $mbd->exec("insert into staff (id, first, last) values (23, 'Joe', 'Bloggs')");
  $mbd->exec("insert into salarychange (id, amount, changedate)
      values (23, 50000, NOW())");
  $mbd->commit();

} catch (Exception $e) {
  $mbd->rollBack();
  echo "Fallo: " . $e->getMessage();
}
?>

No exite límite al realizar actualizaciones en una transacción. También es posible ejecutar consultas complejas para extraer datos, con al posibilidad de utilizar esa información para construir más actualizaciones y consultas; mientras que la transacción esté activa, se garantiza que nadie más pueda realizar cambios mientras se esté en mitad del trabajo. Para más información sobre transacciones, consulte la documentación proporcionada por su servidor de base de datos.


Sentencias preparadas y procedimientos almacenados

Muchas de las bases de datos más maduras admiten el concepto de sentencias preparadas. Estas pueden definirse como un tipo de plantillas compiladas para SQL que las aplicaciones quieren ejecutar, pudiendo ser personalizadas utilizando parámetros variables. Las sentencias preparadas ofrecen dos grandes beneficios:

  • La consulta sólo necesita ser analizada (o preparada) una vez, pero puede ser ejecutada muchas veces con los mismos o diferentes parámetros. Cuando la consulta se prepara, la base de datos analizará, compilará y optimizará su plan para ejecutarla. Para consultas complejas, este proceso puede tomar suficiente tiempo como para ralentizar notablemente una aplicación si fuera necesario repetir la misma consulta muchas veces con los mismos parámetros. Mediante el empleo de una sentencia preparada, la aplicación evita repetir el ciclo de análisis/compilación/optimización. Esto significa que las sentencias preparadas utilizan menos recursos y se ejecutan más rápidamente.
  • Los parámetros para las sentencias preparadas no necesitan estar entrecomillados; el controlador automáticamente se encarga de esto. Si una aplicación usa exclusivamente sentencias preparadas, el desarrollador puede estar seguro de que no hay cabida para inyecciones de SQL (sin embargo, si otras partes de la consulta se construyen con datos de entrada sin escapar, aún es posible que ocurran ataques de inyecciones de SQL).

Las sentencias preparadas son tan útiles que son la única característica que PDO emulará para los controladores que no las soporten. Esto asegura que una aplicación sea capaz de emplear el mismo paradigma de acceso a datos independientemente de las capacidades de la base de datos.

Ejemplo #1 Inserciones repetidas utilizando sentencias preparadas

Este ejemplo realiza dos consultas INSERT sustituyendo name y value por los marcadores correspondientes.

<?php
$sentencia = $mbd->prepare("INSERT INTO REGISTRY (name, value) VALUES (:name, :value)");
$sentencia->bindParam(':name', $nombre);
$sentencia->bindParam(':value', $valor);

// insertar una fila
$nombre = 'uno';
$valor = 1;
$sentencia->execute();

// insertar otra fila con diferentes valores
$nombre = 'dos';
$valor = 2;
$sentencia->execute();
?>

Ejemplo #2 Inserciones repetidas utilizando sentencias preparadas

Este ejemplo realiza dos consultas INSERT sustituyendo name y value por los marcadores posicionales '?'.

<?php
$sentencia = $mbd->prepare("INSERT INTO REGISTRY (name, value) VALUES (?, ?)");
$sentencia->bindParam(1, $nombre);
$sentencia->bindParam(2, $valor);

// insertar una fila
$nombre = 'uno';
$valor = 1;
$sentencia->execute();

// insertar otra fila con diferentes valores
$nombre = 'dos';
$valor = 2;
$sentencia->execute();
?>

Ejemplo #3 Obtener datos empleando sentencias preparadas

Este ejemplo obtiene datos basándose en un valor de clave proporcionado por un formulario. La entrada del usuario es entrecomillada automáticamente, con lo cual no hay riesgo de un ataque por inyección de SQL.

<?php
$sentencia = $mbd->prepare("SELECT * FROM REGISTRY where name = ?");
if ($sentencia->execute(array($_GET['name']))) {
  while ($fila = $sentencia->fetch()) {
    print_r($fila);
  }
}
?>

Ejemplo #4 Llamar a un procedimiento almacenado con un parámetro de salida

Si el controlador de la base de datos lo admite, una aplicación podría también vincular parámetros para salida y para entrada. Los parámetros de salida se emplean típicamente para recuperar valores de procedimientos almacenados. Los parámetros de salida son ligeramente más complejos de usar que los de entrada, de manera que el desarrollador debe conocer la magnitud de un parámetro dado cuando se vincula. Si el valor resulta ser más grande que el tamaño indicado, se emitirá un error.

<?php
$sentencia = $mbd->prepare("CALL sp_returns_string(?)");
$sentencia->bindParam(1, $valor_devuleto, PDO::PARAM_STR, 4000);

// llamar al procedimiento almacenado
$sentencia->execute();

print "El procedimiento devolvió $valor_devuleto\n";
?>

Ejemplo #5 Llamar a un procedimiento almacenado con un parámetro de entrada/salida

Un desarrollador podría también especificar parámetros que contienen valores tanto de entrada como de salida; la sintaxis es similar a la de los parámetros de salida. En el siguiente ejemplo, la cadena 'hola' es pasada al procedimiento almacenado, y cuando éste finaliza, 'hola' es reemplazada con el valor de retorno del procedimiento.

<?php
$sentencia = $mbd->prepare("CALL sp_takes_string_returns_string(?)");
$valor = 'hola';
$sentencia->bindParam(1, $valor, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 4000);

// llamar al procedimiento almacenado
$sentencia->execute();

print "El procedimiento devolvió $valor\n";
?>

Ejemplo #6 Uso inválido de un marcador de posición

<?php
$sentencia = $mbd->prepare("SELECT * FROM REGISTRY where name LIKE '%?%'");
$sentencia->execute(array($_GET['name']));

// los marcadores de posición deben emplearse en el lugar del valor completo
$sentencia = $mbd->prepare("SELECT * FROM REGISTRY where name LIKE ?");
$sentencia->execute(array("%$_GET[name]%"));
?>


Errores y su manejo

PDO ofrece tres estrategias diferentes de manejar errores para adaptarse a cualquier estilo de desarrollo de aplicaciones.

  • PDO::ERRMODE_SILENT

    Este es el modo predeterminado. PDO simplemente establecerá él mismo el código de error para su inspección utilizando los métodos PDO::errorCode() y PDO::errorInfo() tanto en objetos de sentencias como de bases de datos. Si el error resultó de una llamada a un objeto de sentencia, se deberá invocar al método PDOStatement::errorCode() o PDOStatement::errorInfo() sobre dicho objeto. Si el error resultó de una llamada a un objeto de bases de datos, se deberá invocar, en su lugar, a los métodos del objeto de bases de datos.

  • PDO::ERRMODE_WARNING

    Además de establecer el código de error, PDO emitirá un mensaje E_WARNING tradicional. Esta configuración es útil durante la depuración o realización de pruebas para visualizar los problemas que han ocurrido sin interrumpir el flujo de la aplicación.

  • PDO::ERRMODE_EXCEPTION

    Además de establecer el código de error, PDO lanzará una PDOException y establecerá sus propiedades para reflejar el error y la información del mismo. Esta configuración también es útil durante la depuración, ya que, de hecho, señalará el lugar del error del script, apuntando a áreas potencialmente problemáticas del código (recuerde: las transacciones son automáticamente revertidas si la excepción causa la finalización del script).

    El modo Exception también es útil porque se puede estructurar el manejo de errores con más claridad que con el estilo tradicional de advertencias de PHP, y con menos código/anidación que con la ejecución en modo silencioso, comprobando así explícitamente el valor devuelto de cada llamada a la base de datos.

    Véase la referencia de Excepciones para más información sobre excepciones en PHP.

PDO utiliza las cadenas de código de error SQLSTATE del estándar SQL-92; cada controlador de PDO es responsable de la correspondencia de su códigos nativos con los códigos SQLSTATE apropiados. El método PDO::errorCode() devuelve un único código SQLSTATE. Si fuera necesaria más información específica sobre el error, PDO también ofrece el método PDO::errorInfo(), que devuelve un array que contiene el código SQLSTATE, el código de error específico del controlador, y la cadena de error específica.

Ejemplo #1 Crear una instancia de PDO y establecer el modo de error

<?php
$dsn = 'mysql:dbname=prueba;host=127.0.0.1';
$usuario = 'usuario';
$contraseña = 'contraseña';

try {
    $mbd = new PDO($dsn, $usuario, $contraseña);
    $mbd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
} catch (PDOException $e) {
    echo 'Falló la conexión: ' . $e->getMessage();
}

?>

Nota:

PDO::__construct() siempre lanzará una PDOException si la conexión falla, independientemente de que PDO::ATTR_ERRMODE esté esteblecido. Las excepciones no capturadas son fatales.

Ejemplo #2 Crear una instancia de PDO y establecer el modo de error desde el constructor

<?php
$dsn = 'mysql:dbname=prueba;host=127.0.0.1';
$usuario = 'usuario';
$contraseña = 'contraseña';

/*
    El empleo de try/catch en el constructor sigue siendo válido aunque se establezca ERRMODE a WARNING,
    ya que PDO::__construct siempre lanzará una PDOException si la conexión falla.
*/
try {
    $mbd = new PDO($dsn, $usuario, $contraseña, array(PDO::ATTR_ERRMODE => PDO::ERRMODE_WARNING));
} catch (PDOException $e) {
    echo 'Error de conexión: ' . $e->getMessage();
    exit;
}

// Esto hará que PDO lance un error de nivel E_WARNING en lugar de una excepción (cuando la tabla no exista)
$mbd->query("SELECT columna_incorrecta FROM tabla_incorrecta");
?>

El resultado del ejemplo sería:

Warning: PDO::query(): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'prueba.tabla_incorrecta' doesn't exist in
/tmp/prueba_pdo.php on line 18


Objetos grandes (LOB)

En algún momento, una aplicación podría necesitar almacenar datos "grandes" en la base de datos. Grande típicamente significa "alrededor de 4kb o más", aunque algunas bases de datos pueden manejar fácilmente hasta 32kb antes de que los datos se consideren "grandes". Los objetos grandes, o LOB (acrónimo en inglés de 'Large OBjects'), pueden ser de texto o binarios. PDO permite trabajar con este tipo de datos grandes utilizando el código del tipo PDO::PARAM_LOB en llamadas a PDOStatement::bindParam() o PDOStatement::bindColumn(). PDO::PARAM_LOB indica a PDO que haga corresponder los datos como un flujo, pudiendo manipularlos así utilizando la API de flujos de PHP.

Ejemplo #1 Mostrar una imagen desde una base de datos

Este ejemplo vincula un LOB a una variable llamada $lob, y luego lo envía al navegador usando fpassthru(). Ya que el LOB está representado como un flujo, se pueden emplear funciones tales como fgets(), fread() y stream_get_contents() para manejarlo.

<?php
$bd = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$sentencia = $bd->prepare("select contenttype, imagedata from images where id=?");
$sentencia->execute(array($_GET['id']));
$sentencia->bindColumn(1, $tipo, PDO::PARAM_STR, 256);
$sentencia->bindColumn(2, $lob, PDO::PARAM_LOB);
$sentencia->fetch(PDO::FETCH_BOUND);

header("Content-Type: $tipo");
fpassthru($lob);
?>

Ejemplo #2 Insertar una imagen en una base de datos

Este ejemplo abre un fichero y pasa el manejador del fichero a PDO para insertarlo como un LOB. PDO hará todo lo posible para enviar el contenido del fichero a la base de datos de la manera más eficiente.

<?php
$bd = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$sentencia = $bd->prepare("insert into images (id, contenttype, imagedata) values (?, ?, ?)");
$id = get_new_id(); // alguna función para asignar un nuevo ID

// Se asume que se está ejecutando como parte de un formulario de subida de ficheros
// Se puede encontrar más información en la documentación de PHP

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$sentencia->bindParam(1, $id);
$sentencia->bindParam(2, $_FILES['file']['type']);
$sentencia->bindParam(3, $fp, PDO::PARAM_LOB);

$bd->beginTransaction();
$sentencia->execute();
$bd->commit();
?>

Ejemplo #3 Insertar una imagen en una base de datos: Oracle

Oracle requiere una sintaxis ligeramente diferente para insertar un LOB desde un fichero. También es esencial que se realice la inserción bajo una transacción, si no, el LOB recién insertado será consignado con una longitud cero como parte de la consigna implícita que ocurre cuando la consulta se ejecuta:

<?php
$bd = new PDO('oci:', 'scott', 'tiger');
$sentencia = $bd->prepare("insert into images (id, contenttype, imagedata) " .
"VALUES (?, ?, EMPTY_BLOB()) RETURNING imagedata INTO ?");
$id = get_new_id(); // alguna función para asignar un nuevo ID

// Se asume que se está ejecutando como parte de un formulario de subida de ficheros
// Se puede encontrar más información en la documentación de PHP

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$sentencia->bindParam(1, $id);
$sentencia->bindParam(2, $_FILES['file']['type']);
$sentencia->bindParam(3, $fp, PDO::PARAM_LOB);

$bd->beginTransaction();
$sentencia->execute();
$bd->commit();
?>


La clase PDO

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

Introducción

Representa una conexión entre PHP y un servidor de bases de datos.

Sinopsis de la Clase

PDO {
public __construct ( string $dsn , string $username = ? , string $password = ? , array $options = ? )
public beginTransaction ( ) : bool
public commit ( ) : bool
public errorCode ( ) : mixed
public errorInfo ( ) : array
public exec ( string $statement ) : int
public getAttribute ( int $attribute ) : mixed
public static getAvailableDrivers ( ) : array
public inTransaction ( ) : bool
public lastInsertId ( string $name = null ) : string
public prepare ( string $statement , array $driver_options = array() ) : PDOStatement
public query ( string $statement ) : PDOStatement
public quote ( string $string , int $parameter_type = PDO::PARAM_STR ) : string
public rollBack ( ) : bool
public setAttribute ( int $attribute , mixed $value ) : bool
}

Tabla de contenidos

  • PDO::beginTransaction — Inicia una transacción
  • PDO::commit — Consigna una transacción
  • PDO::__construct — Crea una instancia de PDO que representa una conexión a una base de datos
  • PDO::errorCode — Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
  • PDO::errorInfo — Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
  • PDO::exec — Ejecuta una sentencia SQL y devuelve el número de filas afectadas
  • PDO::getAttribute — Devuelve un atributo de la conexión a la base de datos
  • PDO::getAvailableDrivers — Devuelve un array con los controladores de PDO disponibles
  • PDO::inTransaction — Comprueba si una transacción está activa
  • PDO::lastInsertId — Devuelve el ID de la última fila o secuencia insertada
  • PDO::prepare — Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDO::query — Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
  • PDO::quote — Entrecomilla una cadena de caracteres para usarla en una consulta
  • PDO::rollBack — Revierte una transacción
  • PDO::setAttribute — Establece un atributo


Inicia una transacción

  • « PDO
  • PDO::commit »
  • PHP Manual
  • PDO
  • Inicia una transacción

PDO::beginTransaction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::beginTransaction — Inicia una transacción

Descripción

public PDO::beginTransaction ( ) : bool

Desctiva el modo 'autocommit'. Mientras el modo 'autocommit' esté desactivado, no se consignarán los cambios realizados en la base de datos a través de una instancia de PDO hasta que se finalice la transacción con una llamada a PDO::commit(). Una llamada a PDO::rollBack() revertirá todos los cambios de la base de datos y devolverá la conexión al modo 'autocommit'.

Algunas bases de datos, incluida MySQL, ejecután automáticamente un COMMIT implícito cuando una sentencia de definición de lenguaje de base de datos (DDL), tal como DROP TABLE o CREATE TABLE, se ejecutan en una transacción. El COMMIT implícito prevendrá de la reversión de cualquier otro cambio dentro del límite de la transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una PDOException si ya hay una transacción iniciada o el controlador no admite transacciones.

Nota: Se emite una excepción inclusi cuando el atributo PDO::ATTR_ERRMODE no es PDO::ERRMODE_EXCEPTION.

Ejemplos

Ejemplo #1 Revertir una transacción

El siguiente ejemplo inicia una transacción y ejecuta dos sentencias que modifican la base de datos antes de revertir los cambios. En MySQL, sin embargo, la sentencia DROP TABLE automáticamente consigna la transacción, con lo cual, ninguno de los cambios en la transacción son revertidos.

<?php
/* Iniciar una transacción, desactivando 'autocommit' */
$gbd->beginTransaction();

/* Cambiar el esquema y datos de la base de datos */
$gsent = $gbd->exec("DROP TABLE fruit");
$gsent = $gbd->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Reconocer un error y revertir los cambios */
$gbd->rollBack();

/* La conexión a la base de datos ahora vuelve al modo 'autocommit' */
?>

Ver también

  • PDO::commit() - Consigna una transacción
  • PDO::rollBack() - Revierte una transacción
  • Transacciones y autoconsigna


Consigna una transacción

  • « PDO::beginTransaction
  • PDO::__construct »
  • PHP Manual
  • PDO
  • Consigna una transacción

PDO::commit

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::commit — Consigna una transacción

Descripción

public PDO::commit ( ) : bool

Consigna una transacción, devolviendo la conexión a la base de datos al modo 'autocommit' hasta que la siguiente llamada a PDO::beginTransaction() inicie una nueva transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una PDOException si no hay ninguna transacción activa.

Nota: Se emite una excepción inclusi cuando el atributo PDO::ATTR_ERRMODE no es PDO::ERRMODE_EXCEPTION.

Ejemplos

Ejemplo #1 Consignar una transacción básica

<?php
/* Iniciar una transacción, desactivando 'autocommit' */
$gbd->beginTransaction();

/* Insertar múltiples registros según "todo o nada" */
$sql = 'INSERT INTO fruit
    (name, colour, calories)
    VALUES (?, ?, ?)';

$gsent = $gbd->prepare($sql);

foreach ($frutas as $fruta) {
    $gsent->execute(array(
        $fruta->name,
        $fruta->colour,
        $fruta->calories,
    ));
}

/* Consignar los cambios */
$gbd->commit();

/* La conexión a la base de datos ahora a vuelto al modo 'autocommit' */
?>

Ejemplo #2 Consignar una transacción DDL

<?php
/* Iniciar una transacción, desactivando 'autocommit' */
$gbd->beginTransaction();

/* Cambiar el esquema de la base de datos */
$gsent = $gbd->exec("DROP TABLE fruit");

/* Consignar los cambios */
$gbd->commit();

/* La conexión a la base de datos ahora a vuelto al modo 'autocommit' */
?>

Nota: No todas las bases de datos permitirán que las transacciones operen sobre sentencias DDL: algunas generarán errores, mientras que otras (incluida MySQL) automáticamente consignarán la transacción después de encontrar la primera sentencia DDL.

Ver también

  • PDO::beginTransaction() - Inicia una transacción
  • PDO::rollBack() - Revierte una transacción
  • Transacciones y 'auto-commit'


Crea una instancia de PDO que representa una conexión a una base de datos

  • « PDO::commit
  • PDO::errorCode »
  • PHP Manual
  • PDO
  • Crea una instancia de PDO que representa una conexión a una base de datos

PDO::__construct

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::__construct — Crea una instancia de PDO que representa una conexión a una base de datos

Descripción

public PDO::__construct ( string $dsn , string $username = ? , string $password = ? , array $options = ? )

Crea una instancia de PDO para representar una conexión a la base de datos solicitada.

Parámetros

dsn

EL Nombre del Origen de Datos (DSN), contiene la información requerida para conectarse a la base de datos.

En general, un DSN consiste en el nombre del controlador de PDO, seguido por dos puntos, seguido por la sintaxis específica del controlador de PDO para la conexión. Hay más información disponible en la documentación de controladores específicos de PDO.

El parámetro dsn admite tres métodos diferentes de especificar los parámetros requeridos para crear la conexión a la base de datos:

Invocación del controlador

dsn contiene el DSN completo.

Invocación del URI

dsn está formado por uri: seguido por un URI que define la ubicación de un fichero que contiene el string del DSN. El URI puede especificar un fichero local o un URL remoto.

uri:file:///ruta/al/fichero_dsn

Mediante un alias

dsn está formado por un nombre, name, que se corresponde con pdo.dsn.name en php.ini, definiendo el string del DSN.

Nota:

El alias debe estar definido en php.ini, y no en .htaccess o httpd.conf

username

El nombre de usuario para el string del DSN. Este parámetro es opcional para algunos controladores de PDO.

password

La contraseña para el string del DSN. Este parámetro es opcional para algunos controladores de PDO.

options

Un array de la forma clave=>valor con opciones de conexión específicas del controlador.

Valores devueltos

Devuelve un objeto PDO en caso de éxito.

Errores/Excepciones

PDO::__construct() lanza una PDOException si el intento de conexión a la base de datos requerida falla.

Ejemplos

Ejemplo #1 Crear una instancia PDO a través de una invocación al controlador

<?php
/* Conectar a una base de datos de MySQL invocando al controlador */
$dsn = 'mysql:dbname=testdb;host=127.0.0.1';
$usuario = 'usuario_bd';
$contraseña = 'contraseña_bd';

try {
    $gbd = new PDO($dsn, $usuario, $contraseña);
} catch (PDOException $e) {
    echo 'Falló la conexión: ' . $e->getMessage();
}

?>

Ejemplo #2 Crear una instancia PDO a través de una invocación a la URI

En el siguiente ejemplo se asume que el fichero /usr/local/dbconnect existe, con los permisos necesarios para que PHP lo lea. El fichero contiene el DSN de PDO necesario para conectarse a una base de datos de DB2 a través del controlador PDO_ODBC:

odbc:DSN=SAMPLE;UID=john;PWD=mypass

El script de PHP puede crear una conexión a una base de datos simplemente pasando el parámetro uri: y apuntando al URI del fichero:

<?php
/* Conectar a una base de datos de ODBC invocando al controlador */
$dsn = 'uri:file:///usr/local/dbconnect';
$usuario = '';
$contraseña = '';

try {
    $gbd = new PDO($dsn, $usuario, $contraseña);
} catch (PDOException $e) {
    echo 'Falló la conexión: ' . $e->getMessage();
}

?>

Ejemplo #3 Crear una instancia de PDO usando un alias

En el siguiente ejemplo se asume que php.ini contiene la siguiente entrada para permitir la conexión a una base de datos de MySQL usando solamente el alias mydb:

[PDO]
     pdo.dsn.mydb="mysql:dbname=testdb;host=localhost"
<?php
/* Conectar auna base de datos de ODBC usando un alias */
$dsn = 'mydb';
$usuario = '';
$contraseña = '';

try {
    $gbd = new PDO($dsn, $usuario, $contraseña);
} catch (PDOException $e) {
    echo 'Falló la conexión: ' . $e->getMessage();
}

?>

Nota:

Antes de PHP 5.3, una clase que extiende a PDO e implementa el mágico __call siempre redibe un $method en minúsculas.


Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos

  • « PDO::__construct
  • PDO::errorInfo »
  • PHP Manual
  • PDO
  • Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos

PDO::errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorCode — Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos

Descripción

public PDO::errorCode ( ) : mixed

Valores devueltos

Devuelve un SQLSTATE, un identificador de cinco caracteres definidos en el estándar ANSI SQL-92. Brevemente, un SQLSTATE está formado por dos caracteres con el valor de la clase seguidos por tres caracteres con el valor de la subclase. Un valor de clase de 01 indica un aviso y se encuentra acompañado por un código de retorno de SQL_SUCCESS_WITH_INFO. Valores de clase distintos del '01', excepto la clase 'IM', indican un error. La clase 'IM' es específica para avisos y errores que derivan de la implementación del PDO (o quizás ODBC, si se está usando el driver ODBC) por sí mismo. El valor de subclase '000' en cualquier clase indica que no hay subclases para ese SQLSTATE.

PDO::errorCode() sólo devuelve códigos de error en operaciones realizadas directamente sobre el manejador de la base de datos. Si se crea un objeto PDOStatement con PDO::prepare() o PDO::query() y éstas provocan un error en el manejador de la sentencia, PDO::errorCode() no reflejará ese error. Se debe llamar a PDOStatement::errorCode() para devolver el código de error para una operación realizada por un manejador de sentencia particular.

Devuelve null si no se ha ejecutado ninguna operación en el manejador de la base de datos.

Ejemplos

Ejemplo #1 Recuperación de un código SQLSTATE

<?php
/* Provoca un error -- la tabla BONES no existe */
$dbh->exec("INSERT INTO bones(skull) VALUES ('lucy')");

echo "\nPDO::errorCode(): ", $dbh->errorCode();
?>

El resultado del ejemplo sería:

PDO::errorCode(): 42S02

Ver también

  • PDO::errorInfo() - Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
  • PDOStatement::errorCode() - Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia
  • PDOStatement::errorInfo() - Obtiene información ampliada del error asociado con la última operación del gestor de sentencia


Obtiene información extendida del error asociado con la última operación del manejador de la base de datos

  • « PDO::errorCode
  • PDO::exec »
  • PHP Manual
  • PDO
  • Obtiene información extendida del error asociado con la última operación del manejador de la base de datos

PDO::errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorInfo — Obtiene información extendida del error asociado con la última operación del manejador de la base de datos

Descripción

public PDO::errorInfo ( ) : array

Valores devueltos

PDO::errorInfo() devuelve un array con la información del error sobre la última operación realizada por el manejador de la base de datos. El array contiene los siguientes campos:

Element | Information
0 | Código de error SQLSTATE (un identificador de cinco caracteres alfanuméricos definidos según el estándar ANSI SQL).
1 | Código de error específico del driver.
2 | Mensaje del error específico del driver.

Nota:

Si el código de error SQLSTATE no está definido o no hay un error específico del driver, los elementos siguientes al 0 estarán establecidos como null.

PDO::errorInfo() sólo devuelve información de error para operaciones realizadas directamente sobre el manejador de la base de datos. Si se crea un objeto PDOStatement con PDO::prepare() o PDO::query() y se eleva un error sobre el manejador de la sentencia, PDO::errorInfo() no reflejará el error desde el manejador de la sentencia. Se deberá llamar a PDOStatement::errorInfo() para devolver la información del error para una operación realizada sobre un manejador de sentencia concreto.

Ejemplos

Ejemplo #1 Muestra los campos de errorInfo() para una conexión PDO_ODBC a una base de datos DB2

<?php
/* Provoca un error -- sintaxis SQL falsa */
$stmt = $dbh->prepare('bogus sql');
if (!$stmt) {
    echo "\nPDO::errorInfo():\n";
    print_r($dbh->errorInfo());
}
?>

El resultado del ejemplo sería:

PDO::errorInfo():
Array
(
    [0] => HY000
    [1] => 1
    [2] => near "bogus": syntax error
)

Ver también

  • PDO::errorCode() - Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
  • PDOStatement::errorCode() - Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia
  • PDOStatement::errorInfo() - Obtiene información ampliada del error asociado con la última operación del gestor de sentencia


Ejecuta una sentencia SQL y devuelve el número de filas afectadas

  • « PDO::errorInfo
  • PDO::getAttribute »
  • PHP Manual
  • PDO
  • Ejecuta una sentencia SQL y devuelve el número de filas afectadas

PDO::exec

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::exec — Ejecuta una sentencia SQL y devuelve el número de filas afectadas

Descripción

public PDO::exec ( string $statement ) : int

PDO::exec() ejecuta una sentencia SQL en una única llamada a la función, devolviendo el número de filas afectadas por la sentencia.

PDO::exec() no devuelve resultados de una sentencia SELECT. Para una sentencia SELECT que sólo se necesita ejecutar una vez en el programa, se debe considerar el uso de PDO::query(). Para una sentencia que se deba ejecutar en múltiples ocasiones, preparar un objeto PDOStatement con PDO::prepare() y ejecutarlo con PDOStatement::execute().

Parámetros

statement

La sentencia SQL para preparar y ejecutar.

Los datos dentro de la consulta deben ser debidamente escapados.

Valores devueltos

PDO::exec() devuelve el número de filas modificadas o borradas por la sentencia SQL ejecutada. Si no hay filas afectadas, PDO::exec() devuelve 0.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

El siguiente ejemplo confía incorrectamente en el valor de retorno de PDO::exec(), donde en una sentencia que afecta a 0 filas resulta en una llamada a die():

<?php
$db->exec() or die(print_r($db->errorInfo(), true));
?>

Ejemplos

Ejemplo #1 Ejecutando una sentencia DELETE

Cuenta el número de filas afectadas por una sentencia DELETE sin cláusula WHERE.

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

/* Borra todas las filas de la tabla FRUIT */
$count = $dbh->exec("DELETE FROM fruit WHERE colour = 'red'");

/* Devuelve el número de filas borradas */
print("Deleted $count rows.\n");
?>

El resultado del ejemplo sería:

Deleted 1 rows.

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
  • PDOStatement::execute() - Ejecuta una sentencia preparada


Devuelve un atributo de la conexión a la base de datos

  • « PDO::exec
  • PDO::getAvailableDrivers »
  • PHP Manual
  • PDO
  • Devuelve un atributo de la conexión a la base de datos

PDO::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::getAttribute — Devuelve un atributo de la conexión a la base de datos

Descripción

public PDO::getAttribute ( int $attribute ) : mixed

Esta función devuelve el valor de un atributo de la conexión a la base de datos. Para recuperar atributos de objetos PDOStatement, véase PDOStatement::getAttribute().

Nótese que algunas combinaciones de bases de datos/driver pueden no soportar todos los atributos de conexión a la base de datos.

Parámetros

attribute

Una de las constantes PDO::ATTR_*. Las constantes que se aplican a las conexiones de las bases de datos son las siguientes:

  • PDO::ATTR_AUTOCOMMIT
  • PDO::ATTR_CASE
  • PDO::ATTR_CLIENT_VERSION
  • PDO::ATTR_CONNECTION_STATUS
  • PDO::ATTR_DRIVER_NAME
  • PDO::ATTR_ERRMODE
  • PDO::ATTR_ORACLE_NULLS
  • PDO::ATTR_PERSISTENT
  • PDO::ATTR_PREFETCH
  • PDO::ATTR_SERVER_INFO
  • PDO::ATTR_SERVER_VERSION
  • PDO::ATTR_TIMEOUT

Valores devueltos

Una llamada con éxito devuelve el valor del atributo PDO solicitado. Una llamada fallida devuelve null.

Ejemplos

Ejemplo #1 Obtiene los atributos de la conexión a la base de datos

<?php
$conn = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');
$attributes = array(
    "AUTOCOMMIT", "ERRMODE", "CASE", "CLIENT_VERSION", "CONNECTION_STATUS",
    "ORACLE_NULLS", "PERSISTENT", "PREFETCH", "SERVER_INFO", "SERVER_VERSION",
    "TIMEOUT"
);

foreach ($attributes as $val) {
    echo "PDO::ATTR_$val: ";
    echo $conn->getAttribute(constant("PDO::ATTR_$val")) . "\n";
}
?>

Ver también

  • PDO::setAttribute() - Establece un atributo
  • PDOStatement::getAttribute() - Recupera un atributo de sentencia
  • PDOStatement::setAttribute() - Establece un atributo de sentencia


Devuelve un array con los controladores de PDO disponibles

  • « PDO::getAttribute
  • PDO::inTransaction »
  • PHP Manual
  • PDO
  • Devuelve un array con los controladores de PDO disponibles

PDO::getAvailableDrivers

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.3)

PDO::getAvailableDrivers — Devuelve un array con los controladores de PDO disponibles

Descripción

public static PDO::getAvailableDrivers ( ) : array
pdo_drivers ( ) : array

Esta función devuelve todos los controladores de PDO actualmente disponibles que se pueden usar en el parámetro DSN de PDO::__construct().

Valores devueltos

PDO::getAvailableDrivers() devuelve un array con los nombres de los controladores de PDO. Si no hubiera ningún controlador disponible, devuelve un array vacío.

Ejemplos

Ejemplo #1 Un ejemplo de PDO::getAvailableDrivers()

<?php
print_r(PDO::getAvailableDrivers());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => mysql
    [1] => sqlite
)


Comprueba si una transacción está activa

  • « PDO::getAvailableDrivers
  • PDO::lastInsertId »
  • PHP Manual
  • PDO
  • Comprueba si una transacción está activa

PDO::inTransaction

(PHP 5 >= 5.3.3, Bundled pdo_pgsql, PHP 7)

PDO::inTransaction — Comprueba si una transacción está activa

Descripción

public PDO::inTransaction ( ) : bool

Comprueba si una transacción está actualmente activa dentro del controlador. Este método únicamente funciona para controladores de bases de datos que admitan transacciones.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si una transacción está activa actualmente, y false si no.


Devuelve el ID de la última fila o secuencia insertada

  • « PDO::inTransaction
  • PDO::prepare »
  • PHP Manual
  • PDO
  • Devuelve el ID de la última fila o secuencia insertada

PDO::lastInsertId

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::lastInsertId — Devuelve el ID de la última fila o secuencia insertada

Descripción

public PDO::lastInsertId ( string $name = null ) : string

Devuelve el ID de la última fila insertada, o el último valor de una secuencia de objetos, dependiendo del driver subyacente. Por ejemplo, PDO_PGSQL requiere especificar el nombre de la secuencia de objetos para el parámetro name.

Nota:

Este método puede no devolver resultados significativos o consistentes para diferentes drivers PDO, debido a que la base de datos subyacente puede no soportar el concepto de campos auto-incrementales o secuencias.

Parámetros

name

Nombre de la secuencia de objetos de la cual el ID debe ser devuelto.

Valores devueltos

Si el nombre de la secuencia no se especifica en el parámetro name, PDO::lastInsertId() devuelve un string representando el ID de la última fila que ha sido insertada en la base de datos.

Si el nombre de la secuencia se especifica en el parámetro name, PDO::lastInsertId() devuelve una cadena representando el último valor recibido de la secuencia de objetos especificada.

Si el driver PDO no soporta esta prestación, PDO::lastInsertId() dispara un IM001 SQLSTATE.


Prepara una sentencia para su ejecución y devuelve un objeto sentencia

  • « PDO::lastInsertId
  • PDO::query »
  • PHP Manual
  • PDO
  • Prepara una sentencia para su ejecución y devuelve un objeto sentencia

PDO::prepare

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::prepare — Prepara una sentencia para su ejecución y devuelve un objeto sentencia

Descripción

public PDO::prepare ( string $statement , array $driver_options = array() ) : PDOStatement

Prepara una sentencia SQL para ser ejecutada por el método PDOStatement::execute(). La sentencia SQL puede contener cero o más marcadores de parámetros con nombre (:name) o signos de interrogación (?) por los cuales los valores reales serán sustituidos cuando la sentencia sea ejecutada. No se pueden usar marcadores de parámetros con nombre y signos de interrogación en la misma sentencia SQL; se debe elegir uno de los dos estilos de parámetros. Se deben usar estos parámetros para sustituir cualquier dato de usuario, y no usarlos directamente en la consulta.

Se debe incluir un único marcador de parámetro para cada valor que se desee pasar a la sentencia cuando se llame a PDOStatement::execute(). No se puede usar un marcador de parámetro con nombre con el mismo nombre más de una vez en una sentencia preparada, a menos que el modo de emulación esté activado.

Nota:

Los marcadores de parámetros solamente pueden representar un literal de datos completo. No se pueden vincular usando parámetros una parte del literal, ni una palabra clave, ni un identificador, ni ninguna parte arbitraria de una consulta. Por ejemplo, no se puede vincular valores múltiples a un único parámetro en la cláusula IN() de una sentencia SQL.

Llamar a PDO::prepare() y a PDOStatement::execute() para sentencias que serán ejecutadas en múltiples ocasiones con diferentes parámetros optimiza el rendimiento de la aplicación permitiendo al driver negociar en lado del cliente y/o servidor el almacenamiento en caché del plan de consulta y meta información, y ayuda a prevenir inyecciones SQL eliminando la necesidad de entrecomillar manualmente los parámetros.

PDO emulará sentencias preparadas/parámetros de sustitución para drivers que no lo soporten nativamente, y puede reescribir el estilo de los parámetros de sustitución por una forma más apropiada, si el driver soporta un estilo pero no el otro.

Parámetros

statement

Debe ser una plantilla de sentencia SQL válida para el servidor de base de datos destino.

driver_options

Este array guarda uno o más pares clave=>valor para establecer el valor de los atributos del objeto PDOStatement que este método devuelve. Comúnmente se establece el valor PDO::ATTR_CURSOR a PDO::CURSOR_SCROLL para solicitar el cursor desplazable. Algunos drivers tienen opciones específicas que pueden ser establecidas en el momento de la preparación.

Valores devueltos

Si el servidor de la base de datos prepara con éxito la sentencia, PDO::prepare() devuelve un objeto PDOStatement. Si no es posible, PDO::prepare() devuelve false o emite una excepciónPDOException (dependiendo del manejo de errores).

Nota:

Las sentencias preparadas emuladas no se comunican con el servidor de la base de datos con lo cual PDO::prepare() no comprueba la sentencia.

Ejemplos

Ejemplo #1 Prepara una sentencia SQL con parámetros de sustitución nombrados

<?php
/* Ejecuta una sentencia preparada pasando un array de valores */
$sql = 'SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour';
$sth = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_FWDONLY));
$sth->execute(array(':calories' => 150, ':colour' => 'red'));
$red = $sth->fetchAll();
$sth->execute(array(':calories' => 175, ':colour' => 'yellow'));
$yellow = $sth->fetchAll();
?>

Ejemplo #2 Prepara una sentencia SQL con parámetros de signos de interrogación

<?php
/* Ejecuta una sentencia preparada pasando un array de valores */
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array(150, 'red'));
$red = $sth->fetchAll();
$sth->execute(array(175, 'yellow'));
$yellow = $sth->fetchAll();
?>

Ver también

  • PDO::exec() - Ejecuta una sentencia SQL y devuelve el número de filas afectadas
  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
  • PDOStatement::execute() - Ejecuta una sentencia preparada


Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement

  • « PDO::prepare
  • PDO::quote »
  • PHP Manual
  • PDO
  • Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement

PDO::query

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::query — Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement

Descripción

public PDO::query ( string $statement ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_COLUMN , int $colno ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_CLASS , string $classname , array $ctorargs ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_INTO , object $object ) : PDOStatement

PDO::query() ejecuta una sentencia SQL en una única llamada a función, devolviendo el conjunto de resultados (si los hay) que devuelve la sentencia como un objeto PDOStatement.

Para una consulta que se necesite ejecutar en múltiples ocasiones, se obtendrá una mejor rendimiento si se prepara un objeto PDOStatement usando PDO::prepare() y ejecutando la sentencia con múltiple llamadas a PDOStatement::execute().

Si no se buscan todos los datos del conjunto de resultados antes de ejecutar la siguiente llamada a PDO::query(), ésta puede fallar. Llamando a PDOStatement::closeCursor() se liberan los recursos de la base de datos asociados al objeto PDOStatement antes de ejecutar la siguiente llamada a PDO::query().

Nota:

Aunque esta función está documentada solamente teniendo un único parámetro, se pueden pasar argumentos adicionales a esta función. Éstos serán tratados como si se llamase a PDOStatement::setFetchMode() con el objeto de la sentencia resultante.

Parámetros

statement

La sentencia SQL a preparar y ejecutar.

Los datos dentro de la consulta deben ser debidamente escapados.

Valores devueltos

PDO::query() devuelve un objeto PDOStatement, o false en caso de error.

Ejemplos

Ejemplo #1 Demostración de PDO::query

Una buena característica de PDO::query() es que permite iterar sobre el conjunto de filas devueltos por una ejecución de una sentencia SELECT con éxito.

<?php
function getFruit($conn) {
    $sql = 'SELECT name, color, calories FROM fruit ORDER BY name';
    foreach ($conn->query($sql) as $row) {
        print $row['name'] . "\t";
        print $row['color'] . "\t";
        print $row['calories'] . "\n";
    }
}
?>

El resultado del ejemplo sería:

apple   red     150
banana  yellow  250
kiwi    brown   75
lemon   yellow  25
orange  orange  300
pear    green   150
watermelon      pink    90

Ver también

  • PDO::exec() - Ejecuta una sentencia SQL y devuelve el número de filas afectadas
  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada


Entrecomilla una cadena de caracteres para usarla en una consulta

  • « PDO::query
  • PDO::rollBack »
  • PHP Manual
  • PDO
  • Entrecomilla una cadena de caracteres para usarla en una consulta

PDO::quote

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.1)

PDO::quote — Entrecomilla una cadena de caracteres para usarla en una consulta

Descripción

public PDO::quote ( string $string , int $parameter_type = PDO::PARAM_STR ) : string

PDO::quote() entrecomilla el string de entrada (si fuera necesario) y escapa los caracteres especiales contenidos en dicho string, usando un estilo de entrecomillado apropiado para el controlador subyacente.

Si se usa esta función para construir sentencias SQL, se recomienda encarecidamente usar PDO::prepare() para preparar sentencias SQL con los parámetros vinculados en vez de usar PDO::quote() para interpolar entradas del usuario en una consulta SQL. Las sentencias preparadas con parámetros vinculados no son sólo más portables, más convenientes, e inmunes a inyecciones SQL, sino que son mucho más rápidas de ejecutar que las consultas interpoladas, ya que tanto el lado del servidor como el del cliente pueden almacenar en caché una forma compilada de la consulta.

No todos los controladores de PDO implementan este método (como ejemplo notable, PDO_ODBC). En su lugar, se ha de considerar el uso de sentencias preparadas.

Precaución

Seguridad: el conjunto de caracteres predeterminado

El conjunto de caracteres debe establecerse o bien al nivel del servidor, o dentro de la misma conexión a la base de datos (dependiendo del controlador) para que afecte a PDO::quote(). Véase la documentación específica del controlador para más información.

Parámetros

string

La cadena de caracteres a entrecomillar.

parameter_type

Proporciona una declaración de tipo de datos para los controladores que tengan un estilo de entrecomillado alternativo.

Valores devueltos

Devuelve un string entrecomillado teóricamente seguro para pasarlo a una sentencia SQL. Devuelve false si el controlador no soporta el entrecomillado en esta forma.

Ejemplos

Ejemplo #1 Entrecomillar una cadena de caracteres normal

<?php
$conexión = new PDO('sqlite:/home/lynn/music.sql3');

/* Cadena simple */
$cadena = 'Agradable';
print "Cadena sin entrecomillar: $cadena\n";
print "Cadena entrecomillada: " . $conexión->quote($cadena) . "\n";
?>

El resultado del ejemplo sería:

Cadena sin entrecomillar: Agradable
Cadena entrecomillada: 'Agradable'

Ejemplo #2 Entrecomillar una cadena peligrosa

<?php
$conexión = new PDO('sqlite:/home/lynn/music.sql3');

/* Cadena peligrosa */
$cadena = 'Cadena \' desagradable';
print "Cadena sin entrecomillar: $cadena\n";
print "Cadena entrecomillada:" . $conexión->quote($cadena) . "\n";
?>

El resultado del ejemplo sería:

Cadena sin entrecomillar: Cadena ' desagradable
Cadena entrecomillada: 'Cadena '' desagradable'

Ejemplo #3 Entrecomillar una cadena compleja

<?php
$conexión = new PDO('sqlite:/home/lynn/music.sql3');

/* Cadena compleja */
$cadena = "Ca'de''na \"co'\"mpleja";
print "Cadena sin entrecomillar: $cadena\n";
print "Cadena entrecomillada: " . $conexión->quote($cadena) . "\n";
?>

El resultado del ejemplo sería:

Cadena sin entrecomillar: Ca'de''na "co'"mpleja
Cadena entrecomillada: 'Ca''de''''na "co''"mpleja'

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada


Revierte una transacción

  • « PDO::quote
  • PDO::setAttribute »
  • PHP Manual
  • PDO
  • Revierte una transacción

PDO::rollBack

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::rollBack — Revierte una transacción

Descripción

public PDO::rollBack ( ) : bool

Revierte la transacción actual, que fue iniciada por PDO::beginTransaction().

Si la base de datos se estableció al modo 'autocommit', esta función restablecerá el modo 'autocommit' después de haber revertido la transacción.

Algunas bases de datos, incluyendo MySQL, ejecutan un COMMIT implícito cuando una sentencia de lenguaje de definición de base de datos (DDL), como DROP TABLE o CREATE TABLE, se ejecuta dentro de una transacción. El COMMIT implícito pevendrá de revertir cualquier otro cambio dentro de los límites de la transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una PDOException si no hay ninguna transacción activa.

Nota: Se emite una excepción inclusi cuando el atributo PDO::ATTR_ERRMODE no es PDO::ERRMODE_EXCEPTION.

Ejemplos

Ejemplo #1 Revertir una transacción

El siguiente ejemplo comienza una transacción y ejecuta dos sentencias que modifican la base de datos antes de revertir los cambios. En MySQL, sin embargo, la sentencia DROP TABLE consigna automáticamente la transacción, por lo que no son revertidos ninguno de los cambios en la transacción.

<?php
/* Comenzar una transacción, desactivando el modo 'autocommit' */
$gbd->beginTransaction();

/* Cambiar el esquema y los datos de la base de datos */
$sth = $gbd->exec("DROP TABLE fruit");
$sth = $gbd->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Reconocer el error y revertir los cambios */
$gbd->rollBack();

/* Ahora la conexión a la base de datos a vuelto al modo 'autocommit' */
?>

Ver también

  • PDO::beginTransaction() - Inicia una transacción
  • PDO::commit() - Consigna una transacción
  • Transacciones y 'auto-commit'


Establece un atributo

  • « PDO::rollBack
  • PDOStatement »
  • PHP Manual
  • PDO
  • Establece un atributo

PDO::setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::setAttribute — Establece un atributo

Descripción

public PDO::setAttribute ( int $attribute , mixed $value ) : bool

Establece un atributo en el manejador de la base de datos. Algunos de los atributos genéricos disponibles están listados a continuación; algunos drivers pueden hacer uso de atributos adicionales específicos.

  • PDO::ATTR_CASE: Fuerza a los nombres de columnas a una capitalización específica.

    • PDO::CASE_LOWER: Fuerza a los nombres de columnas a minúsculas.

    • PDO::CASE_NATURAL: Deja los nombres de columnas como son devueltas por el driver de la base de datos.

    • PDO::CASE_UPPER: Fuerza a los nombres de columnas a mayúsculas.

  • PDO::ATTR_ERRMODE: Reporte de errores.

    • PDO::ERRMODE_SILENT: Establece los códigos de error.

    • PDO::ERRMODE_WARNING: Eleva E_WARNING.

    • PDO::ERRMODE_EXCEPTION: Lanza exceptions.

  • PDO::ATTR_ORACLE_NULLS (disponible para todos los drivers, no sólo Oracle): Conversión de NULL y cadenas vacías.

    • PDO::NULL_NATURAL: Sin conversión.

    • PDO::NULL_EMPTY_STRING: Las cadenas vacías son convertidas a null.

    • PDO::NULL_TO_STRING: NULL se convierte a cadenas vacías.

  • PDO::ATTR_STRINGIFY_FETCHES: Convierte los valores numéricos a cadenas cuando se buscan. Requiere bool.

  • PDO::ATTR_STATEMENT_CLASS: Establece la clase de sentencia proporcionada por el usuario derivada de PDOStatement. No puede ser usado con instancias PDO persistentes. Requiere array(string classname, array(mixed constructor_args)).

  • PDO::ATTR_TIMEOUT: Especifica la duración del tiempo de espera en segundos Specifies the timeout duration in seconds. Not all drivers support this option, and it's meaning may differ from driver to driver. For example, sqlite will wait for up to this time value before giving up on obtaining an writable lock, but other drivers may interpret this as a connect or a read timeout interval. Requires int.

  • PDO::ATTR_AUTOCOMMIT (available in OCI, Firebird and MySQL): Whether to autocommit every single statement.

  • PDO::ATTR_EMULATE_PREPARES Enables or disables emulation of prepared statements. Some drivers do not support native prepared statements or have limited support for them. Use this setting to force PDO to either always emulate prepared statements (if true), or to try to use native prepared statements (if false). It will always fall back to emulating the prepared statement if the driver cannot successfully prepare the current query. Requires bool.

  • PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (available in MySQL): Use buffered queries.

  • PDO::ATTR_DEFAULT_FETCH_MODE: Set default fetch mode. Description of modes is available in PDOStatement::fetch() documentation.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


La clase PDOStatement

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

Introducción

Representa una sentencia preparada y, después de la ejecución de la instrucción, un conjunto de resultados asociados.

Sinopsis de la Clase

PDOStatement implements Traversable {
/* Propiedades */
readonly string $queryString;
/* Métodos */
public bindColumn ( mixed $column , mixed &$param , int $type = ? , int $maxlen = ? , mixed $driverdata = ? ) : bool
public bindParam ( mixed $parameter , mixed &$variable , int $data_type = PDO::PARAM_STR , int $length = ? , mixed $driver_options = ? ) : bool
public bindValue ( mixed $parameter , mixed $value , int $data_type = PDO::PARAM_STR ) : bool
public closeCursor ( ) : bool
public columnCount ( ) : int
public debugDumpParams ( ) : void
public errorCode ( ) : string
public errorInfo ( ) : array
public execute ( array $input_parameters = ? ) : bool
public fetch ( int $fetch_style = ? , int $cursor_orientation = PDO::FETCH_ORI_NEXT , int $cursor_offset = 0 ) : mixed
public fetchAll ( int $fetch_style = ? , mixed $fetch_argument = ? , array $ctor_args = array() ) : array
public fetchColumn ( int $column_number = 0 ) : mixed
public fetchObject ( string $class_name = "stdClass" , array $ctor_args = ? ) : mixed
public getAttribute ( int $attribute ) : mixed
public getColumnMeta ( int $column ) : array
public nextRowset ( ) : bool
public rowCount ( ) : int
public setAttribute ( int $attribute , mixed $value ) : bool
public setFetchMode ( int $mode ) : bool
}

Propiedades

queryString

La cadena de consulta utilizada.

Tabla de contenidos

  • PDOStatement::bindColumn — Vincula una columna a una variable de PHP
  • PDOStatement::bindParam — Vincula un parámetro al nombre de variable especificado
  • PDOStatement::bindValue — Vincula un valor a un parámetro
  • PDOStatement::closeCursor — Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez
  • PDOStatement::columnCount — Devuelve el número de columnas de un conjunto de resultados
  • PDOStatement::debugDumpParams — Vuelca un comando preparado de SQL
  • PDOStatement::errorCode — Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia
  • PDOStatement::errorInfo — Obtiene información ampliada del error asociado con la última operación del gestor de sentencia
  • PDOStatement::execute — Ejecuta una sentencia preparada
  • PDOStatement::fetch — Obtiene la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchAll — Devuelve un array que contiene todas las filas del conjunto de resultados
  • PDOStatement::fetchColumn — Devuelve una única columna de la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchObject — Obtiene la siguiente fila y la devuelve como un objeto
  • PDOStatement::getAttribute — Recupera un atributo de sentencia
  • PDOStatement::getColumnMeta — Devuelve metadatos de una columna de un conjunto de resultados
  • PDOStatement::nextRowset — Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas
  • PDOStatement::rowCount — Devuelve el número de filas afectadas por la última sentencia SQL
  • PDOStatement::setAttribute — Establece un atributo de sentencia
  • PDOStatement::setFetchMode — Establece el modo de obtención para esta sentencia


Vincula una columna a una variable de PHP

  • « PDOStatement
  • PDOStatement::bindParam »
  • PHP Manual
  • PDOStatement
  • Vincula una columna a una variable de PHP

PDOStatement::bindColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::bindColumn — Vincula una columna a una variable de PHP

Descripción

public PDOStatement::bindColumn ( mixed $column , mixed &$param , int $type = ? , int $maxlen = ? , mixed $driverdata = ? ) : bool

PDOStatement::bindColumn() se encarga de tener una variable en particular vinculada a una columna dada en el conjunto de resultados desde una consulta. Cada llamada a PDOStatement::fetch() o a PDOStatement::fetchAll() actualizará todas las variables que estén vinculadas a columnas.

Nota:

Ya que la información sobre las columnas no siempre está disponible para PDO hasta que la sentencia sea ejecutada, las aplicaciones portables debería invocar esta función despúes de PDOStatement::execute().

Sin embargo, para poder vincular una columna LOB como un flujo cuando se usa el controlador PgSQL, las aplicaciones deberían invocar este método antes de llamar a PDOStatement::execute(), si no, el OID del objeto grande será devuelto como un número entero.

Parámetros

column

El número (de primer índice 1) o el nombre de la columna del conjunto de resultados. Si se utiliza el nombre de la columna, tenga en cuenta que el nombre debería coincidir en mayúsculas/minúsculas con la columna, tal como la devuelve el controlador.

param

El nombre de la variable de PHP a la que vincular la columna.

type

El tipo de datos del parámetro, especificado por las constantes PDO::PARAM_*.

maxlen

La longitud máxima sugerida para la preasingnación.

driverdata

Parámetro/s opcional/es para el controlador.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Vincular la salida de un conjunto de resultados a variables de PHP

La vinculación de columnas del conjunto de resultados a variables de PHP es una forma efectiva de hacer que los datos contenidos en cada fila estén disponibles de inmediato para la aplicación. El siguiente ejemplo demuestra cómo PDO permite vincular y recuperar columnas con varias opciones y con valores predeterminados inteligentes.

<?php
function readData($gbd) {
  $sql = 'SELECT name, colour, calories FROM fruit';
  try {
    $sentencia = $gbd->prepare($sql);
    $sentencia->execute();

    /* Vincular por número de columna */
    $sentencia->bindColumn(1, $nombre);
    $sentencia->bindColumn(2, $color);

    /* Vincular por nombre de columna */
    $sentencia->bindColumn('calories', $calorías);

    while ($fila = $sentencia->fetch(PDO::FETCH_BOUND)) {
      $datos = $nombre . "\t" . $color . "\t" . $calorías . "\n";
      print $datos;
    }
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
readData($gbd);
?>

El resultado del ejemplo sería:

apple   red     150
banana  yellow  175
kiwi    green   75
orange  orange  150
mango   red     200
strawberry      red     25

Ver también

  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::fetch() - Obtiene la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchAll() - Devuelve un array que contiene todas las filas del conjunto de resultados
  • PDOStatement::fetchColumn() - Devuelve una única columna de la siguiente fila de un conjunto de resultados


Vincula un parámetro al nombre de variable especificado

  • « PDOStatement::bindColumn
  • PDOStatement::bindValue »
  • PHP Manual
  • PDOStatement
  • Vincula un parámetro al nombre de variable especificado

PDOStatement::bindParam

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::bindParam — Vincula un parámetro al nombre de variable especificado

Descripción

public PDOStatement::bindParam ( mixed $parameter , mixed &$variable , int $data_type = PDO::PARAM_STR , int $length = ? , mixed $driver_options = ? ) : bool

Vincula una variable de PHP a un parámetro de sustitución con nombre o de signo de interrogación correspondiente de la sentencia SQL que fue usada para preparar la sentencia. A diferencia de PDOStatement::bindValue(), la variable es vinculada como una referencia y solamente será evaluada en el momento en el que se llame a PDOStatement::execute().

Muchos parámetros son de entrada, es decir, que son usados en un modo de sólo lectura para construir la consulta. Algunos controladores admiten la invocación de procedimientos almacenados que devuelven datos como parámetros de salida, y algunos también como parámetros de entrada/salida, donde se envían datos y son actualizados al recibirlos.

Parámetros

parameter

El identificador del parámetro. Para sentencias preparadas que usen parámetros de sustición con nombre, esto será un nombre de parámetro con la forma :nombre. Para sentencias preparadas que usen parámetros de sustición de signos de interrogación, esto será la posición índice-1 del parámetro.

variable

Nombre de la variable de PHP a vincular al parámetro de la sentencia SQL.

data_type

El tipo de datos explícito para el parámetro, usando las constantes PDO::PARAM_*. Para devolver un parámetro INOUT desde un procedimiento almacenado, se ha de usar el operador OR a nivel de bits para establecer los bits de PDO::PARAM_INPUT_OUTPUT para el parámetro data_type.

length

La longitud del tipo de datos. Para indicar que el parámetro es un parámetro OUT de un procedimiento almacenado, se debe establecer explícitamente la longitud.

driver_options

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejecutar una sentencia preparada con parámetros de sustitución con nombre

<?php
/* Ejecutar una sentencia preparada vinculando varialbes de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$gsent->bindParam(':calories', $calorías, PDO::PARAM_INT);
$gsent->bindParam(':colour', $color, PDO::PARAM_STR, 12);
$gsent->execute();
?>

Ejemplo #2 Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación

<?php
/* Ejecutar una sentencia preparada vinculando varialbes de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$gsent->bindParam(1, $calorías, PDO::PARAM_INT);
$gsent->bindParam(2, $color, PDO::PARAM_STR, 12);
$gsent->execute();
?>

Ejemplo #3 Llamar a un procedimiento almacenado con un parámetro INOUT

<?php
/* Llamar a un procedimiento almacenado con un parámetro INOUT */
$color = 'red';
$gsent = $gbd->prepare('CALL puree_fruit(?)');
$gsent->bindParam(1, $color, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 12);
$gsent->execute();
print("Después de hacer puré la fruta, el color es: $color");
?>

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::bindValue() - Vincula un valor a un parámetro


Vincula un valor a un parámetro

  • « PDOStatement::bindParam
  • PDOStatement::closeCursor »
  • PHP Manual
  • PDOStatement
  • Vincula un valor a un parámetro

PDOStatement::bindValue

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

PDOStatement::bindValue — Vincula un valor a un parámetro

Descripción

public PDOStatement::bindValue ( mixed $parameter , mixed $value , int $data_type = PDO::PARAM_STR ) : bool

Vincula un valor al parámetro de sustitución con nombre o de signo de interrogación de la sentencia SQL que se utilizó para preparar la sentencia.

Parámetros

parameter

El identificador del parámetro. Para sentencias preparadas que usen parámetros de sustición con nombre, esto será un nombre de parámetro con la forma :nombre. Para sentencias preparadas que usen parámetros de sustición de signos de interrogación, esto será la posición índice-1 del parámetro.

value

El valor a vincular al parámetro.

data_type

El tipo de datos explícito para el parámetro, usando las constantes PDO::PARAM_*.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejecutar una sentencia preparada con parámetros de sustitución con nombre

<?php
/* Ejecutar una sentencia preparada vinculando varialbes de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$gsent->bindValue(':calories', $calorías, PDO::PARAM_INT);
$gsent->bindValue(':colour', $color, PDO::PARAM_STR);
$gsent->execute();
?>

Ejemplo #2 Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación

<?php
/* Ejecutar una sentencia preparada vinculando varialbes de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$gsent->bindValue(1, $calorías, PDO::PARAM_INT);
$gsent->bindValue(2, $color, PDO::PARAM_STR);
$gsent->execute();
?>

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::bindParam() - Vincula un parámetro al nombre de variable especificado


Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez

  • « PDOStatement::bindValue
  • PDOStatement::columnCount »
  • PHP Manual
  • PDOStatement
  • Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez

PDOStatement::closeCursor

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::closeCursor — Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez

Descripción

public PDOStatement::closeCursor ( ) : bool

PDOStatement::closeCursor() libera la conexión al servidor, por lo que otras sentencias SQL podrían ejecutarse, pero deja la sentencia en un estado que la habilita para ser ejecutada otra vez.

Este método es útil para los controladores de bases de datos que no admiten la ejecución de un objeto PDOStatement cuando otro objeto PDOStatement previamente ejecutado aún le restan filas por obtener. Si su controlador de bases de datos tiene esta limitación, el problema podría manifestarse en un error de "fuera de sencuencia".

PDOStatement::closeCursor() está implementado como un método opcional específico del controlador (permitienedo la máxima eficiencia), o como la alternativa genérica de PDO si no está instalada ninguna función específica del controlador. La alternativa genérica de PDO es semánticamente la misma que si se escribiera el siguiente código en un script de PHP:

<?php
do {
    while ($sentencia->fetch())
        ;
    if (!$sentencia->nextRowset())
        break;
} while (true);
?>

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PDOStatement::closeCursor()

En el siguiente ejemplo, el objeto PDOStatement $sentencia devuelve múltiples filas, aunque la aplicación solamente obtenga la primera, dejando al objeto PDOStatement con filas aún por obtener. Para asegurarse de que la aplicación funcionará con todos los controladores de bases de datos, el autor inserta una llmada a PDOStatement::closeCursor() sobre $sentencia antes de ejecutar el objeto PDOStatement $otraSentencia.

<?php
/* Crear un objeto PDOStatement */
$sentencia = $gbd->prepare('SELECT foo FROM bar');

/* Crear un segundo objeto PDOStatement */
$otraSentencia = $gbd->prepare('SELECT foobaz FROM foobar');

/* Ejecutar la primera sentencia */
$sentencia->execute();

/* Obtener solamente la primera fila de los resultados */
$sentencia->fetch();

/* La siguiente llamada a closeCursor() podría ser necesaria para algunos controladores */
$sentencia->closeCursor();

/* Ahora se puede ejecutar la segunda sentencia */
$otraSentencia->execute();
?>

Ver también

  • PDOStatement::execute() - Ejecuta una sentencia preparada


Devuelve el número de columnas de un conjunto de resultados

  • « PDOStatement::closeCursor
  • PDOStatement::debugDumpParams »
  • PHP Manual
  • PDOStatement
  • Devuelve el número de columnas de un conjunto de resultados

PDOStatement::columnCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::columnCount — Devuelve el número de columnas de un conjunto de resultados

Descripción

public PDOStatement::columnCount ( ) : int

Use PDOStatement::columnCount() para devolver el número de columnas del conjunto representado por el objeto PDOStatement.

S el objeto PDOStatement fue devuelto desde PDO::query(), el número de columnas estará inmediatamente disponible.

Si el objeto PDOStatement fue devuelto desde PDO::prepare(), un número preciso de columnas no estará disponible hasta que se invoque a PDOStatement::execute().

Valores devueltos

Devuelve el número de columnas del conjunto de resultados representado por el objeto PDOStatement, incluso si el conjunto de resultados está vacío. Si no hubiera conjunto de resultados, PDOStatement::columnCount() devuelve 0.

Ejemplos

Ejemplo #1 Contar columnas

Este ejemplo demuestra cómo PDOStatement::columnCount() opera con y sin un conjunto de resultados.

<?php
$gbd = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

$gsent = $gbd->prepare("SELECT name, colour FROM fruit");

/* Cuenta el número de columnas del (no existente) conjunto de resultados */
$cuenta_col = $gsent->columnCount();
print("Antes de execute(), el conjunto de resultados tiene $cuenta_col columnas (debería ser 0)\n");

$gsent->execute();

/* Cuenta el número de columnas del conjunto de resultados */
$cuenta_col = $gsent->columnCount();
print("Después de execute(), el conjunto de resultados tiene $cuenta_col columnas (debería ser 2)\n");

?>

El resultado del ejemplo sería:

Antes de execute(), el conjunto de resultados tiene 0 columnas (debería ser 0)
Después de execute(), el conjunto de resultados tiene 2 columnas (debería ser 2)

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::rowCount() - Devuelve el número de filas afectadas por la última sentencia SQL


Vuelca un comando preparado de SQL

  • « PDOStatement::columnCount
  • PDOStatement::errorCode »
  • PHP Manual
  • PDOStatement
  • Vuelca un comando preparado de SQL

PDOStatement::debugDumpParams

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::debugDumpParams — Vuelca un comando preparado de SQL

Descripción

public PDOStatement::debugDumpParams ( ) : void

Vuelca la información contenida en una sentencia preparada directamente en la salida. Proporcionará la consulta SQL en uso, el número de parámetros usados (Params), la lista de parámetros con su nombre de clave o posición, su nombre, su posición en la consulta (si lo admite el controlador de PDO, si no, será -1), el tipo (param_type) como entero, y un valor booleano is_param.

Esta es una función de depuración que vuelca directamente los datos en la salida habitual.

Sugerencia

Como con todo lo que genera un resultado directamente en el navegador, se pueden utilizar las funciones de control de salida para capturar el resultado de esta función y guardarlo, por ejemplo, en un string.

Solamente volcará los parámetros de la sentencia en el momento del vuelco. Los parámetros extra no son almacenados en la sentencia, y tampoco son mostrados.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de PDOStatement::debugDumpParams() con parámetros con nombre

<?php
/* Ejecutar una sentencia preparada vinculando variables de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$gsent->bindParam(':calories', $calorías, PDO::PARAM_INT);
$gsent->bindValue(':colour', $color, PDO::PARAM_STR, 12);
$gsent->execute();

$gsent->debugDumpParams();

?>

El resultado del ejemplo sería:

SQL: [96] SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour
Params:  2
Key: Name: [9] :calories
paramno=-1
name=[9] ":calories"
is_param=1
param_type=1
Key: Name: [7] :colour
paramno=-1
name=[7] ":colour"
is_param=1
param_type=2

Ejemplo #2 Ejemplo de PDOStatement::debugDumpParams() con parámetros sin nombre

<?php

/* Ejecutar una sentencia preparada vinculando variables de PHP */
$calorías = 150;
$color = 'red';
$name = 'apple';

$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$gsent->bindParam(1, $calorías, PDO::PARAM_INT);
$gsent->bindValue(2, $color, PDO::PARAM_STR);
$gsent->execute();

$gsent->debugDumpParams();

?>

El resultado del ejemplo sería:

SQL: [82] SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?
Params:  2
Key: Position #0:
paramno=0
name=[0] ""
is_param=1
param_type=1
Key: Position #1:
paramno=1
name=[0] ""
is_param=1
param_type=2

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::bindParam() - Vincula un parámetro al nombre de variable especificado
  • PDOStatement::bindValue() - Vincula un valor a un parámetro


Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia

  • « PDOStatement::debugDumpParams
  • PDOStatement::errorInfo »
  • PHP Manual
  • PDOStatement
  • Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia

PDOStatement::errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::errorCode — Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia

Descripción

public PDOStatement::errorCode ( ) : string

Valores devueltos

Es idéntico a PDO::errorCode(), excepto que PDOStatement::errorCode() solamente recupera los códigos de error de operaciones llevadas a cabo con objetos PDOStatement.

Ejemplos

Ejemplo #1 Recuperar un código SQLSTATE

<?php
/* Provocar un error -- la tabla BONES no existe */
$err = $gbd->prepare('SELECT skull FROM bones');
$err->execute();

echo "\nPDOStatement::errorCode(): ";
print $err->errorCode();
?>

El resultado del ejemplo sería:

PDOStatement::errorCode(): 42S02

Ver también

  • PDO::errorCode() - Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
  • PDO::errorInfo() - Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
  • PDOStatement::errorInfo() - Obtiene información ampliada del error asociado con la última operación del gestor de sentencia


Obtiene información ampliada del error asociado con la última operación del gestor de sentencia

  • « PDOStatement::errorCode
  • PDOStatement::execute »
  • PHP Manual
  • PDOStatement
  • Obtiene información ampliada del error asociado con la última operación del gestor de sentencia

PDOStatement::errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::errorInfo — Obtiene información ampliada del error asociado con la última operación del gestor de sentencia

Descripción

public PDOStatement::errorInfo ( ) : array

Valores devueltos

PDOStatement::errorInfo() devuelve un array con la información de error de la última operación realizada por este gestor de sentencia. El array consiste en los siguiente campos:

Elemento | Información
0 | Código de error de SQLSTATE (un identificador alfanumérico de cinco caracteres definido en el estándar ANSI SQL).
1 | Código de error específico del controlador.
2 | Mensaje de error específico del controlador.

Ejemplos

Ejemplo #1 Mostrar los campos de errorInfo() para una conexión PDO_ODBC a una base de datos de DB2

<?php
/* Provocar un error -- la tabla BONES no existe */
$gsent = $gbd->prepare('SELECT skull FROM bones');
$gsent->execute();

echo "\nPDOStatement::errorInfo():\n";
$arr = $gsent->errorInfo();
print_r($arr);
?>

El resultado del ejemplo sería:

PDOStatement::errorInfo():
Array
(
    [0] => 42S02
    [1] => -204
    [2] => [IBM][CLI Driver][DB2/LINUX] SQL0204N  "DANIELS.BONES" is an undefined name.  SQLSTATE=42704
)

Ver también

  • PDO::errorCode() - Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
  • PDO::errorInfo() - Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
  • PDOStatement::errorCode() - Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia


Ejecuta una sentencia preparada

  • « PDOStatement::errorInfo
  • PDOStatement::fetch »
  • PHP Manual
  • PDOStatement
  • Ejecuta una sentencia preparada

PDOStatement::execute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::execute — Ejecuta una sentencia preparada

Descripción

public PDOStatement::execute ( array $input_parameters = ? ) : bool

Ejecuta la sentencia preparada. Si ésta incluía marcadores de parámetros, se debe:

  • llamar a PDOStatement::bindParam() y/o PDOStatement::bindValue() para vincular variables o valores (respectivamente) a los marcadores de parámetros. Las variables vinculadas pasan su valor como entrada y reciben el valor de salida, si lo hubiera, de sus marcadores de parámetros asociados

  • o pasar un array de valores de parámetros de sólo entrada

Parámetros

input_parameters

Un array de valores con tantos elementos como parámetros vinculados en la sentencia SQL que va a ser ejecutada. Todos los valores son tratados como PDO::PARAM_STR.

No es posible vincular múltiples valores a un único parámetro; por ejemplo, no se puede vincular dos valores a un único parámetro con nombre en una cláusula IN().

Tampoco es posible vincular más valores que los especificados; si existen más claves en input_parameters que en la sentencia SQL especificada en PDO::prepare(), entonces la sentencia fallará y se emitirá un error.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.2.0 | Las claves de input_parameters deben coincidir con aquellas declaradas en la sentencia SQL. Antes de PHP 5.2.0 esto se ignoraba silenciosamente.

Ejemplos

Ejemplo #1 Ejecutar una sentencia preparada con una variable y valor vinculados

<?php
/* Ejecutar una sentencia preparada vinculando una variable y un valor */
$calorías = 150;
$color = 'gre';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calorías AND colour LIKE :color');
$gsent->bindParam(':calories', $calorías, PDO::PARAM_INT);
$sth->bindValue(':colour', "%{$color}%");
$gsent->execute();
?>

Ejemplo #2 Ejecutar una sentencia preparada con un array de valores de inserción (parámetros con nombre)

<?php
/* Ejecutar una sentencia preparada proporcionando un array de valores de inserción */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$gsent->execute(array(':calories' => $calorías, ':colour' => $color));
?>

Ejemplo #3 Ejecutar una sentencia preparada con un array de valores de inserción (parámetros de sustitución)

<?php
/* Ejecutar una sentencia preparada proporcionando un array de valores de inserción */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$gsent->execute(array($calorías, $color));
?>

Ejemplo #4 Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación

<?php
/* Ejecutar una sentencia preparada vinculando variables de PHP */
$calorías = 150;
$color = 'red';
$gsent = $gbd->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$gsent->bindParam(1, $calorías, PDO::PARAM_INT);
$gsent->bindParam(2, $color, PDO::PARAM_STR, 12);
$gsent->execute();
?>

Ejemplo #5 Ejecutar una sentencia preparada usando un array para la cláusula IN

<?php
/* Ejecutar una sentencia preparada usando un array de valores para una cláusula IN */
$parámetros = array(1, 21, 63, 171);
/* Crear una cadena para los parámetros de sustitución rellenados con el número de parámetros */
$place_holders = implode(',', array_fill(0, count($parámetros), '?'));

/*
    Esto prepara una sentencia con suficientes parámetros de sustitución sin nombre para
    cada valor del array $parámetros. Los valores del array $parámetros son vinculados a
    los parámetros de sustitución de la sentencia preparada cuando ésta sea ejecutada.
    Esto no es lo mismo que usar PDOStatement::bindParam(), pues esto último
    requiere una referencia a la variable. En su lugar, PDOStatement::execute() sólo
    vincula por valor.
*/
$gsent = $gbd->prepare("SELECT id, name FROM contacts WHERE id IN ($place_holders)");
$gsent->execute($parámetros);
?>

Notas

Nota:

Algunos controladores necesitan cerrar los cursores antes de poder ejecutar la siguiente sentencia.

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::bindParam() - Vincula un parámetro al nombre de variable especificado
  • PDOStatement::fetch() - Obtiene la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchAll() - Devuelve un array que contiene todas las filas del conjunto de resultados
  • PDOStatement::fetchColumn() - Devuelve una única columna de la siguiente fila de un conjunto de resultados


Obtiene la siguiente fila de un conjunto de resultados

  • « PDOStatement::execute
  • PDOStatement::fetchAll »
  • PHP Manual
  • PDOStatement
  • Obtiene la siguiente fila de un conjunto de resultados

PDOStatement::fetch

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::fetch — Obtiene la siguiente fila de un conjunto de resultados

Descripción

public PDOStatement::fetch ( int $fetch_style = ? , int $cursor_orientation = PDO::FETCH_ORI_NEXT , int $cursor_offset = 0 ) : mixed

Obtiene una fila de un conjunto de resultados asociado al objeto PDOStatement. El parámetro fetch_style determina cómo PDO devuelve la fila.

Parámetros

fetch_style

Controla cómo se devolverá la siguiente fila al llamador. Este valor debe ser una de las constantes PDO::FETCH_*, estando predeterminado PDO::ATTR_DEFAULT_FETCH_MODE (el cual por defecto es PDO::FETCH_BOTH).

  • PDO::FETCH_ASSOC: devuelve un array indexado por los nombres de las columnas del conjunto de resultados.

  • PDO::FETCH_BOTH (predeterminado): devuelve un array indexado tanto por nombre de columna, como numéricamente con índice de base 0 tal como fue devuelto en el conjunto de resultados.

  • PDO::FETCH_BOUND: devuelve true y asigna los valores de las columnas del conjunto de resultados a las variables de PHP a las que fueron vinculadas con el método PDOStatement::bindColumn().

  • PDO::FETCH_CLASS: devuelve una nueva instancia de la clase solicitada, haciendo corresponder las columnas del conjunto de resultados con los nombres de las propiedades de la clase, y llamando al constructor después, a menos que también se proporcione PDO::FETCH_PROPS_LATE. Si fetch_style incluye PDO::FETCH_CLASSTYPE (por ejemplo, PDO::FETCH_CLASS | PDO::FETCH_CLASSTYPE), entonces el nombre de la clase se determina a partir del valor de la primera columna.

  • PDO::FETCH_INTO: actualiza una instancia existente de la clase solicitada, haciendo coincidir el nombre de las columnas con los nombres de las propiedades de la clase.

  • PDO::FETCH_LAZY: combina PDO::FETCH_BOTH y PDO::FETCH_OBJ, creando los nombres de la variables del objeto tal como se accedieron.

  • PDO::FETCH_NAMED: devuelve un array con la misma forma que PDO::FETCH_ASSOC, excepto que si hubiera múltiples columnas con el mismo nombre, el valor al que hace referencia dicha clave será un array con todos los valores de la fila de tuviera ese nombre de columna.

  • PDO::FETCH_NUM: devuelve un array indexado por el número de columna tal como fue devuelto en el conjunto de resultados, comenzando por la columna 0.

  • PDO::FETCH_OBJ: devuelve un objeto anónimo con nombres de propiedades que se corresponden a los nombres de las columnas devueltas en el conjunto de resultados.

  • PDO::FETCH_PROPS_LATE: cuando se usa con PDO::FETCH_CLASS, se llama al constructor de la clase antes de que las proiedades sean asignadas desde los valores de la columna respectiva.

cursor_orientation

Para un objeto PDOStatement que represente un cursor desplazable, este valor determina qué columna será devuelta por el llamador. Este valor debe ser una de las constantes PDO::FETCH_ORI_*, siendo la predeterminada PDO::FETCH_ORI_NEXT. Para solicitar un cursor desplazable para el objeto PDOStatement, se debe establecer el atributo PDO::ATTR_CURSOR a PDO::CURSOR_SCROLL cuando se prepare la sentencia SQL con PDO::prepare().

offset

Para un objeto PDOStatement que represente un cursor desplazable para el cual el parámetro cursor_orientation está establecido a PDO::FETCH_ORI_ABS, este valor especifica el número absoluto de la fila del conjunto de resultados que se desea obtener.

Para un objeto PDOStatement que represente un cursor desplazable para el cual el parámetro cursor_orientation está establecido a PDO::FETCH_ORI_REL, este valor especifica la fila a obtener relativa a la posición del cursor antes de que se llame a PDOStatement::fetch().

Valores devueltos

El valor de retorno de esta función en caso de éxito depende del tipo de obtención. En todos los casos, se devuelve false en caso de error.

Ejemplos

Ejemplo #1 Obtención de filas usando diferentes tipos de obtención

<?php
$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

/* Prueba de tipos de PDOStatement::fetch */
print("PDO::FETCH_ASSOC: ");
print("Devolver la siguiente fila como un array indexado por nombre de colunmna\n");
$result = $gsent->fetch(PDO::FETCH_ASSOC);
print_r($result);
print("\n");

print("PDO::FETCH_BOTH: ");
print("Devolver la siguiente fila como un array indexado por nombre y número de columna\n");
$result = $gsent->fetch(PDO::FETCH_BOTH);
print_r($result);
print("\n");

print("PDO::FETCH_LAZY: ");
print("Devolver la siguiente fila como un objeto anónimo con nombres de columna como propiedades\n");
$result = $gsent->fetch(PDO::FETCH_LAZY);
print_r($result);
print("\n");

print("PDO::FETCH_OBJ: ");
print("Devolver la siguiente fila como un objeto anónimo con nombres de columna como propiedades\n");
$result = $gsent->fetch(PDO::FETCH_OBJ);
print $result->name;
print("\n");
?>

El resultado del ejemplo sería:

PDO::FETCH_ASSOC: Devolver la siguiente fila como un array indexado por nombre de colunmna
Array
(
    [name] => apple
    [colour] => red
)

PDO::FETCH_BOTH: Devolver la siguiente fila como un array indexado por nombre y número de columna
Array
(
    [name] => banana
    [0] => banana
    [colour] => yellow
    [1] => yellow
)

PDO::FETCH_LAZY: Devolver la siguiente fila como un objeto anónimo con nombres de columna como propiedades
PDORow Object
(
    [name] => orange
    [colour] => orange
)

PDO::FETCH_OBJ: Devolver la siguiente fila como un objeto anónimo con nombres de columna como propiedades
kiwi

Ejemplo #2 Obtener filas con un cursor desplazable

<?php
function leerDatosHaciaAdelante($gbd) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY BET';
  try {
    $sentencia = $gbd->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $sentencia->execute();
    while ($fila = $sentencia->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_NEXT)) {
      $datos = $fila[0] . "\t" . $fila[1] . "\t" . $fila[2] . "\n";
      print $datos;
    }
    $sentencia = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
function leerDatosHaciaAtrás($gbd) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY bet';
  try {
    $sentencia = $gbd->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $sentencia->execute();
    $fila = $sentencia->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_LAST);
    do {
      $datos = $fila[0] . "\t" . $fila[1] . "\t" . $fila[2] . "\n";
      print $datos;
    } while ($fila = $sentencia->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_PRIOR));
    $sentencia = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}

print "Leyendo hacia adelante:\n";
leerDatosHaciaAdelante($conexión);

print "Leyendo hacia atrás:\n";
leerDatosHaciaAtrás($conexión);
?>

El resultado del ejemplo sería:

Reading forwards:
21    10    5
16    0     5
19    20    10

Reading backwards:
19    20    10
16    0     5
21    10    5

Ejemplo #3 Orden de construcción

Cuando los objetos se obtienen mediante PDO::FETCH_CLASS, las propiedades del objeto se asignan primero, y luego se invoca al constructor de la clase. Si también se proporciona PDO::FETCH_PROPS_LATE, este orden se invierte, es decir, primero se llama al constructor y luego se asignan las propiedades.

<?php
class Persona
{
    private $name;

    public function __construct()
    {
        $this->decir();
    }

    public function decir()
    {
        if (isset($this->name)) {
            echo "Soy {$this->name}.\n";
        } else {
            echo "Aún no tengo nombre.\n";
        }
    }
}

$sth = $dbh->query("SELECT * FROM people");
$sth->setFetchMode(PDO::FETCH_CLASS, 'Persona');
$persona = $sth->fetch();
$persona->decir();
$sth->setFetchMode(PDO::FETCH_CLASS|PDO::FETCH_PROPS_LATE, 'Persona');
$persona = $sth->fetch();
$persona->decir();
?>

El resultado del ejemplo sería algo similar a:

Soy Alice.
Soy Alice.
Aún no tengo nombre.
Soy Bob.

Ver también

  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::fetchAll() - Devuelve un array que contiene todas las filas del conjunto de resultados
  • PDOStatement::fetchColumn() - Devuelve una única columna de la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchObject() - Obtiene la siguiente fila y la devuelve como un objeto
  • PDOStatement::setFetchMode() - Establece el modo de obtención para esta sentencia


Devuelve un array que contiene todas las filas del conjunto de resultados

  • « PDOStatement::fetch
  • PDOStatement::fetchColumn »
  • PHP Manual
  • PDOStatement
  • Devuelve un array que contiene todas las filas del conjunto de resultados

PDOStatement::fetchAll

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::fetchAll — Devuelve un array que contiene todas las filas del conjunto de resultados

Descripción

public PDOStatement::fetchAll ( int $fetch_style = ? , mixed $fetch_argument = ? , array $ctor_args = array() ) : array

Parámetros

fetch_style

Controla el contenido del array devuelto, tal como está documentado en
PDOStatement::fetch().
El valor predeterminado es PDO::ATTR_DEFAULT_FETCH_MODE
(el cual por defecto es PDO::FETCH_BOTH).

Para devolver un array que contenga todos los valores de una única columna del conjunto de resultados, se debe especificar PDO::FETCH_COLUMN. Se puede especificar qué columna se desea obtener con el parámetro fetch_argument.

Para obtener solamente los valores únicos de una sola columna del conjunto de resultados, se ha de realizar un OR a nivel de bits de PDO::FETCH_COLUMN con PDO::FETCH_UNIQUE.

Para devolver un array asociativo agrupado según los valores de una columna especificada, se ha de realilar un OR a nivel de bits de PDO::FETCH_COLUMN con PDO::FETCH_GROUP.

fetch_argument

Este argumento tiene un significado diferente dependiendo del valor del parámetro fetch_style:

  • PDO::FETCH_COLUMN: Devuelve la columna con el índice indicado basado en 0.

  • PDO::FETCH_CLASS: Devuelve instancias de la clase especificada, haciendo corresponder las columnas de cada fila con las propiedades con nombre de la clase.

  • PDO::FETCH_FUNC: Devuelve el resultado de llamar a la función especificada, usando cada columna de fila como parámetro de la llamada.

ctor_args

Los argumentos del constructor de la case cuando el parámetro fetch_style es PDO::FETCH_CLASS.

Valores devueltos

PDOStatement::fetchAll() devuelve un array que contiene todas las filas restantes del conjunto de resultados. El array representa cada fila como un array con valores de las columnas, o como un objeto con propiedades correspondientes a cada nombre de columna. Es devuelto un array vacío si hay cero resultados que obtener, o false en caso de fallo.

Usar este método para obtener conjuntos de resultados grandes dará como resultado una fuerte demanda del sistema y, posiblemente, de los recursos de red. En lugar de recuperar todos los datos y manipularlos en PHP, considérese usar el servidor de bases de datos para manipular los conjuntos de resultados. Por ejemplo, se pueden usar las cláusulas WHERE y ORDER BY en sentencias SQL para restringir el resultado antes de recuperarlos y procesarlos con PHP.

Ejemplos

Ejemplo #1 Obtener todas las filas restantes de un conjunto de resultados

<?php
$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

/* Obtener todas las filas restantes del conjunto de resultados */
print("Obtener todas las filas restantes del conjunto de resultados:\n");
$resultado = $gsent->fetchAll();
print_r($resultado);
?>

El resultado del ejemplo sería algo similar a:

Obtener todas las filas restantes del conjunto de resultados:
Array
(
    [0] => Array
        (
            [name] => pear
            [0] => pear
            [colour] => green
            [1] => green
        )

    [1] => Array
        (
            [name] => watermelon
            [0] => watermelon
            [colour] => pink
            [1] => pink
        )

)

Ejemplo #2 Obtener todos los valores de una única columna de un conjunto de resultados

El siguiente ejemplo demuestra cómo devolver todos los valores de una única columna de un conjunto de resultados, incluso si la sentencia SQL podría devolver múltiples columnas por cada fila.

<?php
$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

/* Obtener todos los valores de la primera columna */
$resultado = $gsent->fetchAll(PDO::FETCH_COLUMN, 0);
var_dump($resultado);
?>

El resultado del ejemplo sería algo similar a:

Array(3)
(
    [0] =>
    string(5) => apple
    [1] =>
    string(4) => pear
    [2] =>
    string(10) => watermelon
)

Ejemplo #3 Agrupar todos los valores según una única columna

El siguiente ejemplo demuestra cómo devolver un array asociativo agrupado según los valores de la columna especificada del conjunto de resultados. El array contiene tres claves: los valores apple y pear son devueltos como arrays que contienen dos colores diferentes, mientras que watermelon es devuelto como un array que contiene un solo color.

<?php
$insert = $gbd->prepare("INSERT INTO fruit(name, colour) VALUES (?, ?)");
$insert->execute(array('apple', 'green'));
$insert->execute(array('pear', 'yellow'));

$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

/* Agrupar valores según la primera columna */
var_dump($gsent->fetchAll(PDO::FETCH_COLUMN|PDO::FETCH_GROUP));
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["apple"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(3) "red"
  }
  ["pear"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(6) "yellow"
  }
  ["watermelon"]=>
  array(1) {
    [0]=>
    string(5) "green"
  }
}

Ejemplo #4 Instanciar una clase para cada resultado

El siguiente ejemplo demuestra el comportamiento del estilo de obtención de PDO::FETCH_CLASS.

<?php
class fruit {
    public $name;
    public $colour;
}

$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

$resultado = $gsent->fetchAll(PDO::FETCH_CLASS, "fruit");
var_dump($resultado);
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  object(fruit)#1 (2) {
    ["name"]=>
    string(5) "apple"
    ["colour"]=>
    string(5) "green"
  }
  [1]=>
  object(fruit)#2 (2) {
    ["name"]=>
    string(4) "pear"
    ["colour"]=>
    string(6) "yellow"
  }
  [2]=>
  object(fruit)#3 (2) {
    ["name"]=>
    string(10) "watermelon"
    ["colour"]=>
    string(4) "pink"
  }
}

Ejemplo #5 Invocar a una función por cada resultado

El siguiente ejemplo demuestra el comportamiento del estilo de obtención de PDO::FETCH_FUNC.

<?php
function fruit($name, $colour) {
    return "{$name}: {$colour}";
}

$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

$resultado = $gsent->fetchAll(PDO::FETCH_FUNC, "fruit");
var_dump($resultado);
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  string(12) "apple: green"
  [1]=>
  string(12) "pear: yellow"
  [2]=>
  string(16) "watermelon: pink"
}

Ver también

  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
  • PDOStatement::fetch() - Obtiene la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchColumn() - Devuelve una única columna de la siguiente fila de un conjunto de resultados
  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::setFetchMode() - Establece el modo de obtención para esta sentencia


Devuelve una única columna de la siguiente fila de un conjunto de resultados

  • « PDOStatement::fetchAll
  • PDOStatement::fetchObject »
  • PHP Manual
  • PDOStatement
  • Devuelve una única columna de la siguiente fila de un conjunto de resultados

PDOStatement::fetchColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::fetchColumn — Devuelve una única columna de la siguiente fila de un conjunto de resultados

Descripción

public PDOStatement::fetchColumn ( int $column_number = 0 ) : mixed

Devuelve una única columna de la siguiente fila de un conjunto de resultados, o false si no existen más filas.

Nota:

No debería utilizarse PDOStatement::fetchColumn() para recuperar columnas booleanas, ya que es imposible distinguir el valor false de la ausencia de filas a recurperar. Use PDOStatement::fetch() en su lugar.

Parámetros

column_number

El número de índice basado en 0 de la columna que se quiere obtener desde la fila. Si no se proporicona ningún valor, PDOStatement::fetchColumn() obtiene la primera columna.

Valores devueltos

PDOStatement::fetchColumn() devuelve una única columna de la siguiente fila de un conjunto de resultados.

Advertencia

No existe una forma de devolver otra columna de la misma fila si se utiliza PDOStatement::fetchColumn() para recuperar datos.

Ejemplos

Ejemplo #1 Devolver la primera columna de la siguiente fila

<?php
$gsent = $gbd->prepare("SELECT name, colour FROM fruit");
$gsent->execute();

print("Obtener la primera columna de la primera fila del conjunto de resultados:\n");
$resultado = $gsent->fetchColumn();
print("nombre = $resultado\n");

print("Obtener la segunda columna de la segunda fila del conjunto de resultados:\n");
$resultado = $gsent->fetchColumn(1);
print("color = $resultado\n");
?>

El resultado del ejemplo sería:

Obtener la primera columna de la primera fila del conjunto de resultados:
nombre = lemon
Obtener la segunda columna de la segunda fila del conjunto de resultados:
color = red

Ver también

  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
  • PDOStatement::fetch() - Obtiene la siguiente fila de un conjunto de resultados
  • PDOStatement::fetchAll() - Devuelve un array que contiene todas las filas del conjunto de resultados
  • PDO::prepare() - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
  • PDOStatement::setFetchMode() - Establece el modo de obtención para esta sentencia


Obtiene la siguiente fila y la devuelve como un objeto

  • « PDOStatement::fetchColumn
  • PDOStatement::getAttribute »
  • PHP Manual
  • PDOStatement
  • Obtiene la siguiente fila y la devuelve como un objeto

PDOStatement::fetchObject

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.4)

PDOStatement::fetchObject — Obtiene la siguiente fila y la devuelve como un objeto

Descripción

public PDOStatement::fetchObject ( string $class_name = "stdClass" , array $ctor_args = ? ) : mixed

Obtiene la siguiente fila y la devuelve como un objeto. Esta función es una
alternativa para PDOStatement::fetch() con el estilo
PDO::FETCH_CLASS o
PDO::FETCH_OBJ.

Cuando se obtiene un objeto, sus propiedades son asignadas desde los valores de la columna respectiva, y después se invoca a su constructor.

Parámetros

class_name

El nombre de la clase creada.

ctor_args

Los elementos de este array son pasados al constructor.

Valores devueltos

Devuelve una instancia de la clase requerida con los nombres de sus propiedades que se corresponden a los nombre de las columnas, o false en caso de error.

Ver también

  • PDOStatement::fetch() - Obtiene la siguiente fila de un conjunto de resultados


Recupera un atributo de sentencia

  • « PDOStatement::fetchObject
  • PDOStatement::getColumnMeta »
  • PHP Manual
  • PDOStatement
  • Recupera un atributo de sentencia

PDOStatement::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::getAttribute — Recupera un atributo de sentencia

Descripción

public PDOStatement::getAttribute ( int $attribute ) : mixed

Obtiene un atributo de una sentencia. Actualemente, no existen atributos genéricos, sino solamente específicos del controlador:

  • PDO::ATTR_CURSOR_NAME (específico de Firebird y ODBC): Obtiene el nombre del cursor para UPDATE ... WHERE CURRENT OF.

Valores devueltos

Devuelve el valor del atributo.

Ver también

  • PDO::getAttribute() - Devuelve un atributo de la conexión a la base de datos
  • PDO::setAttribute() - Establece un atributo
  • PDOStatement::setAttribute() - Establece un atributo de sentencia


Devuelve metadatos de una columna de un conjunto de resultados

  • « PDOStatement::getAttribute
  • PDOStatement::nextRowset »
  • PHP Manual
  • PDOStatement
  • Devuelve metadatos de una columna de un conjunto de resultados

PDOStatement::getColumnMeta

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::getColumnMeta — Devuelve metadatos de una columna de un conjunto de resultados

Descripción

public PDOStatement::getColumnMeta ( int $column ) : array

Devuelve los metadatos de una columna de índice basado 0 de un conjunto de resultados como un array asociativo.

Advertencia

No todos los controladores de PDO admiten PDOStatement::getColumnMeta().

Los siguientes controladores admiten este método:

  • PDO_DBLIB
  • PDO_MYSQL
  • PDO_PGSQL
  • PDO_SQLITE

Parámetros

column

La columna de índice basado en 0 del conjunto de resultados.

Valores devueltos

Devuelve un array asociativo que contiene los siguientes valores que representan los metadatos de una única columna:

Metadatos de la columna
Nombre | Valor
native_type | El tipo nativo de PHP usado para representar el valor de la columna.
driver:decl_type | El tipo de SQL usado para representar el valor de la columna de la base de datos. Si la columna del conjunto de resultado es el resultado de una función, este valor no es devuelto por PDOStatement::getColumnMeta().
flags | Cualquier bandera establecida para esta columna.
name | El nombre de esta columna tal como es devuelto por la base de datos.
table | El nombre de la tabla de esta columna tal como es devuelto por la base de datos.
len | La longitud de esta columna. Normalmente es -1 para tipos distintos de decimales de punto flotante.
precision | La precisión numérica de esta columna. Normalmente es 0 para tipos distintos de decimales de punto flotante.
pdo_type | El tipo de esta columna tal como está representado por las constantes PDO::PARAM_*.

Devuelve false si la columna solicitada no exite en el conjunto de resultados, o si no existe dicho conjunto.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el soporte para el controlador PDO_DBLIB
5.2.3 | El campo table

Ejemplos

Ejemplo #1 Recuperar metadatos de una columna

El siguiente ejemplo muestra el resultado de recuperar los metadatos para una única columna generada por una función (COUNT) en un controlador PDO_SQLITE.

<?php
$select = $DB->query('SELECT COUNT(*) FROM fruit');
$meta = $select->getColumnMeta(0);
var_dump($meta);
?>

El resultado del ejemplo sería:

array(6) {
  ["native_type"]=>
  string(7) "integer"
  ["flags"]=>
  array(0) {
  }
  ["name"]=>
  string(8) "COUNT(*)"
  ["len"]=>
  int(-1)
  ["precision"]=>
  int(0)
  ["pdo_type"]=>
  int(2)
}

Ver también

  • PDOStatement::columnCount() - Devuelve el número de columnas de un conjunto de resultados
  • PDOStatement::rowCount() - Devuelve el número de filas afectadas por la última sentencia SQL


Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas

  • « PDOStatement::getColumnMeta
  • PDOStatement::rowCount »
  • PHP Manual
  • PDOStatement
  • Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas

PDOStatement::nextRowset

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::nextRowset — Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas

Descripción

public PDOStatement::nextRowset ( ) : bool

Algunas bases de datos admiten procedimientos almacenados que devuelve más de un conjunto de filas (también conocido como conjunto de resultados). Con PDOStatement::nextRowset() se puede accedar al segundo y subsiguiente conjunto de filas asociado con un objeto PDOStatement. Cada conjunto de filas puede tener un conjunto de columnas diferente del conjunto de filas precedente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Obtener múltiples conjuntos de filas devueltas por un procedimiento almacenado

El siguiente ejemplo muestra cómo llamar a un procedimiento almacenado, MULTIPLE_ROWSETS, que devuelve tres conjuntos de filas. Se usa un bucle do / while para iterar sobre el método PDOStatement::nextRowset(), el cual devuelve false y finaliza el bucle cuando no se pueden devolver más conjuntos de filas.

<?php
$sql = 'CALL multiple_rowsets()';
$sentencia = $conexión->query($sql);
$i = 1;
do {
    $conjunto_filas = $sentencia->fetchAll(PDO::FETCH_NUM);
    if ($conjunto_filas) {
        printResultSet($conjunto_filas, $i);
    }
    $i++;
} while ($sentencia->nextRowset());

function printResultSet(&$conjunto_filas, $i) {
    print "Conjunto de resultados $i:\n";
    foreach ($conjunto_filas as $fila) {
        foreach ($fila as $columna) {
            print $columna . "\t";
        }
        print "\n";
    }
    print "\n";
}
?>

El resultado del ejemplo sería:

Conjunto de resultados 1:
apple    red
banana   yellow

Conjunto de resultados 2:
orange   orange    150
banana   yellow    175

Conjunto de resultados 3:
lime     green
apple    red
banana   yellow

Ver también

  • PDOStatement::columnCount() - Devuelve el número de columnas de un conjunto de resultados
  • PDOStatement::execute() - Ejecuta una sentencia preparada
  • PDOStatement::getColumnMeta() - Devuelve metadatos de una columna de un conjunto de resultados
  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement


Devuelve el número de filas afectadas por la última sentencia SQL

  • « PDOStatement::nextRowset
  • PDOStatement::setAttribute »
  • PHP Manual
  • PDOStatement
  • Devuelve el número de filas afectadas por la última sentencia SQL

PDOStatement::rowCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::rowCount — Devuelve el número de filas afectadas por la última sentencia SQL

Descripción

public PDOStatement::rowCount ( ) : int

PDOStatement::rowCount() devuelve el número de filas afectadas por la última sentencia DELETE, INSERT, o UPDATE ejecutada por el correspondiente objeto PDOStatement.

Si la última sentencia SQL ejecutada por el objeto PDOStatement asociado fue una sentencia SELECT, algunas bases de datos podrían devolver el número de filas devuelto por dicha sentencia. Sin embargo, este comportamiento no está garantizado para todas las bases de datos y no debería confiarse en él para aplicaciones portables.

Valores devueltos

Devuelve el número de filas.

Ejemplos

Ejemplo #1 Devolver el número de filas eliminadas

PDOStatement::rowCount() devuelve el número de filas afectadas por una sentencia DELETE, INSERT, o UPDATE.

<?php
/* Borrar todas las filas de la tabla FRUIT */
$del = $gbd->prepare('DELETE FROM fruit');
$del->execute();

/* Devolver el número de filas que fueron eliminadas */
print("Devolver el número de filas que fueron eliminadas:\n");
$cuenta = $del->rowCount();
print("Eliminadas $cuenta filas.\n");
?>

El resultado del ejemplo sería:

Devolver el número de filas que fueron eliminadas:
Eliminadas 9 filas.

Ejemplo #2 Contar las filas devueltas por una sentencia SELECT

Para muchas bases de datos, PDOStatement::rowCount() no devuelve el número de filas afectadas por una sentencia SELECT. En su lugar, use PDO::query() para ejecutar una sentencia SELECT COUNT(*) con las mismas declaraciones que la sentencia SELECT pretendida, luego use PDOStatement::fetchColumn() para recuperar el número de filas que serán devueltas. La aplicación podrá entonces realizar la acción correcta.

<?php
$sql = "SELECT COUNT(*) FROM fruit WHERE calories > 100";
if ($resultado = $conexión->query($sql)) {

    /* Comprobar el número de filas que coinciden con la sentencia SELECT */
  if ($resultado->fetchColumn() > 0) {

        /* Ejecutar la sentencia SELECT real y trabajar con los resultados */
         $sql = "SELECT name FROM fruit WHERE calories > 100";
       foreach ($conexión->query($sql) as $fila) {
           print "Nombre: " .  $fila['NAME'] . "\n";
         }
    }
    /* No coincide ningua fila -- hacer algo en consecuencia */
  else {
      print "Ninguna fila coincide con la consulta.";
    }
}

$resultado = null;
$conexión = null;
?>

El resultado del ejemplo sería:

apple
banana
orange
pear

Ver también

  • PDOStatement::columnCount() - Devuelve el número de columnas de un conjunto de resultados
  • PDOStatement::fetchColumn() - Devuelve una única columna de la siguiente fila de un conjunto de resultados
  • PDO::query() - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement


Establece un atributo de sentencia

  • « PDOStatement::rowCount
  • PDOStatement::setFetchMode »
  • PHP Manual
  • PDOStatement
  • Establece un atributo de sentencia

PDOStatement::setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::setAttribute — Establece un atributo de sentencia

Descripción

public PDOStatement::setAttribute ( int $attribute , mixed $value ) : bool

Establece un atributo de una sentencia. Actualmente, no se establecen atributos genéricos, sino solamente específicos del controlador:

  • PDO::ATTR_CURSOR_NAME (específico de Firebird y ODBC): Establece el nombre del cursor para UPDATE ... WHERE CURRENT OF.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • PDO::getAttribute() - Devuelve un atributo de la conexión a la base de datos
  • PDO::setAttribute() - Establece un atributo
  • PDOStatement::getAttribute() - Recupera un atributo de sentencia


Establece el modo de obtención para esta sentencia

  • « PDOStatement::setAttribute
  • PDOException »
  • PHP Manual
  • PDOStatement
  • Establece el modo de obtención para esta sentencia

PDOStatement::setFetchMode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::setFetchMode — Establece el modo de obtención para esta sentencia

Descripción

public PDOStatement::setFetchMode ( int $mode ) : bool
public PDOStatement::setFetchMode ( int $PDO::FETCH_COLUMN , int $colno ) : bool
public PDOStatement::setFetchMode ( int $PDO::FETCH_CLASS , string $classname , array $ctorargs ) : bool
public PDOStatement::setFetchMode ( int $PDO::FETCH_INTO , object $object ) : bool

Parámetros

mode

El modo de obtención debe ser una de las constantes PDO::FETCH_*.

colno

El número de la columna.

classname

El nombre de la clase.

ctorargs

Los argumentos del constructor.

object

El objeto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establece el modo de obtención

El siguiente ejemplo demuestra cómo PDOStatement::setFetchMode() cambia el modo de obtención predeterminado para un objeto PDOStatement.

<?php
$sql = 'SELECT name, colour, calories FROM fruit';
try {
  $sentencia = $gbd->query($sql);
  $resultado = $sentencia->setFetchMode(PDO::FETCH_NUM);
  while ($fila = $sentencia->fetch()) {
    print $fila[0] . "\t" . $fila[1] . "\t" . $fila[2] . "\n";
  }
}
catch (PDOException $e) {
  print $e->getMessage();
}
?>

El resultado del ejemplo sería:

apple   red     150
banana  yellow  250
orange  orange  300
kiwi    brown   75
lemon   yellow  25
pear    green   150
watermelon      pink    90


La clase PDOException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Representa un error generado por PDO. No se debería lanzar una PDOException desde el código. Véase Excepciones para más información acerca de las excepciones en PHP.

Sinopsis de la Clase

PDOException extends RuntimeException {
/* Propiedades */
public array $errorInfo ;
protected string $code ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

errorInfo

Corresponde a PDO::errorInfo() o PDOStatement::errorInfo()

code

Código de error de SQLSTATE. Utilice Exception::getCode() para acceder a él.


Controladores de PDO

Tabla de contenidos

  • CUBRID (PDO)
  • MS SQL Server (PDO)
  • Firebird (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • MS SQL Server (PDO)
  • Oracle (PDO)
  • ODBC y DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)

Los siguientes controladores implementan actualmente la interfaz PDO:

Nombre del controlador | Bases de datos admitidas
PDO_CUBRID | Cubrid
PDO_DBLIB | FreeTDS / Microsoft SQL Server / Sybase
PDO_FIREBIRD | Firebird
PDO_IBM | IBM DB2
PDO_INFORMIX | IBM Informix Dynamic Server
PDO_MYSQL | MySQL 3.x/4.x/5.x
PDO_OCI | Oracle Call Interface
PDO_ODBC | ODBC v3 (IBM DB2, unixODBC y win32 ODBC)
PDO_PGSQL | PostgreSQL
PDO_SQLITE | SQLite 3 y SQLite 2
PDO_SQLSRV | Microsoft SQL Server / SQL Azure


Funciones de CUBRID (PDO_CUBRID)

Introducción

PDO_CUBRID es un controlador que implementa la interfaz de Objetos de Datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de CUBRID.

Nota:

Por ahora, la versión actual de PDO_CUBRID no admite conexiones persistentes.

Instalación

Para construir la extensión PDO_CUBRID, CUBRID DBMS debe estar instalado en el mismo sistema donde se ejecute PHP. PDO_CUBRID es una extensión » PECL, por lo que se han de seguir las instrucciones dadas en Instalación de extensiones PECL para instalar la extensión PDO_CUBRID. Ejecute el comando configure para indicar la ubicación del directorio base de CUBRID de la siguiente manera:

   $ ./configure --with-pdo-cubrid=/path/to/CUBRID[,shared]
El valor predeterminado del comando configure es el de la variable de entorno de CUBRID.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows . Para información detallada sobre la instalación manual en Linux y Windows, por favor lea build-guide.html en el paquete PECL CUBRID para obtener referencias.

Características

Características de PDO_CUBRID
Característica | Descripción
Cursores desplazables | PDO_CUBRID admite cursores desplazables. El tipo de cursor predeterminado es de sólo avance, y se puede usar el parámetro driver_options de PDO::prepare() para cambiar el tipo de cursor.
Tiempo de espera | PDO_CUBRID admite la configuracion del tiempo de espera de las ejecuciones de sentencias SQL; Se puede utilizar PDO::setAttribute() para establecer el valor del tiempo de espera.
Autocommit_mode y transacciones PDO_CUBRID admite autocommit_mode y transacciones, y autocommit_mode está habilitado por omisión. Se puede usar PDO::setAttribute() para cambiar su estado.

Si se usa PDO::beginTransaction() para iniciar una transacción, se desactivará autocommit_mode automaticamente y PDO::rollBack(). Obsérvese que antes de deshabilitar autocommit_mode, cualquier trabajo pendiente es consignado automáticamente.

Sentencias SQL múltiples | PDO_CUBRID admite sentencias SQL múltiples. Las sentencias SQL múltiples están serparadas por puntos y comas (;)
Información del esquema | PDO_CUBRID implementa la función PDO::cubrid_schema() para obtener la información del esquema.
LOBs PDO_CUBRID admite los tipos de datos BLOB/CLOB. El tipo LOB en PDO es representado como un flujo, por lo que pueden insertarse LOBs vinculando un flujo, y obtener LOBs leyendo de un flujo devuelto por CUBRID PDO. Por ejemplo:

Ejemplo #1 Insertar LOBs en CUBRID PDO

<?php
$fp = fopen('lob_test.png', 'rb');

$sent_sql = "INSERT INTO lob_test(name, content) VALUES('lob_test.png', ?)";

$sentencia = $dbh->prepare($sent_sql);
$ret = $sentencia->bindParam(1, $fp, PDO::PARAM_LOB);
$ret = $sentencia->execute();
?>

Ejemplo #2 Obtener LOBs en CUBRID PDO

<?php
$sent_sql = "SELECT content FROM lob_test WHERE name='lob_test.png'";

$sentencia = $dbh->prepare($sent_sql);
$sentencia->execute();
$resultado = $sentencia->fetch(PDO::FETCH_NUM);

header("Content-Type: image/png");
fpassthru($resultado[0]);
?>

Metadatos de columna La función PDOStatement::getColumnMeta() de CUBRID PDO devolverá un array asociativo que contiene los siguientes valores:
  • type
  • name
  • table
  • def
  • precision
  • scale
  • not_null
  • auto_increment
  • unique_key
  • multiple_key
  • primary_key
  • foreign_key
  • reverse_index
  • reverse_unique
Tipos de datos de colecciones PDO_CUBRID admite los tipos de datos SET/MULTISET/SEQUENCE. Si no se especifica el tipo de datos, el predeterminado es char, por ejemplo:

Ejemplo #3 Insertar un conjunto en CUBRID PDO con el tipo de datos predeterminado.

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(VARCHAR))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array("abc","def","ghi");
$ret = $stmt->bindParam(1, $data, PDO::PARAM_NULL);
$ret = $stmt->execute();
var_Dump($ret);
?>

Ejemplo #4 Especificar un tipo de datos al insertar un conjunto en CUBRID PDO

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(int))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array(1,2,3,4);
$ret = $stmt->bindParam(1, $data, 0,0,"int");
$ret = $stmt->execute();
var_Dump($ret);
?>

Tipos de datos de vinculación de CUBRID:(El quinto parámetro de PDOStatement::bindParam):
  • CHAR
  • STRING
  • NCHAR
  • VARNCHAR
  • BIT
  • VARBIT
  • NUMERIC
  • NUMBER
  • INT
  • SHORT
  • BIGINT
  • MONETARY
  • FLOAT
  • DOUBLE
  • DATE
  • TIME
  • DATETIME
  • TIMESTAMP

Constantes predefinidas

Estas constantes están definidas por este controlador, y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución. Además, estas constantes específicas del controlador deberían ser utilizadas sólo si está usando este controlador. Usar atributos específicos del controlador con otro controlador podría resultar en un comportamiento inesperado. PDO::getAttribute() puede ser empleado para obtener el atributo PDO::ATTR_DRIVER_NAME para verificar el controlador, si el código puede ejecutarse con múltiples controladores.

Las siguientes constantes se puden usar al establecer el atributo de la base de datos. Se puede pasar a PDO::getAttribute() o a PDO::setAttribute().

Banderas de atributo de PDO::CUBRID
Constante | Descripción
PDO::CUBRID_ATTR_ISOLATION_LEVEL | Nivel de aislamiento de las transacciones para la conexión de la base de datos.
PDO::CUBRID_ATTR_LOCK_TIMEOUT | Tiempo de espera de las transacciones en segundos.
PDO::CUBRID_ATTR_MAX_STRING_LENGTH | Sólo lectura. La longitud máxima de cadena para los diversos tipos de datos bit, varbit, char, varchar, nchar, nchar al utilizar la API de CUBRID PDO.

Las siguientes constantes se puden usar al estableder el nivel de aislamiento de las transacciones. Se pueden pasar a PDO::getAttribute() o ser devueltas por PDO::setAttribute().

Banderas de nivel de aislamiento de PDO::CUBRID
Constante | Descripción
PDO::TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | El nivel de aislamiento más bajo (1). Podría ocurrir una lectura sucia, no repetible o fantasma para la tupla, y puede ocurrir también una lectura no repetible para la tabla.
PDO::TRAN_COMMIT_CLASS_COMMIT_INSTANCE | Un nivel relativamente bajo de aislamiento (2). No ocurre una lectura sucia, pero podría ocurrir una lectura no repetible o fantasma.
PDO::TRAN_REP_CLASS_UNCOMMIT_INSTANCE | El nivel predeterminado de aislamiento de CUBRID (3). Podría ocurrir una lectura sucia, no repetible o fantasma para la tupla, pero se garantiza una lectura repetible para la tabla.
PDO::TRAN_REP_CLASS_COMMIT_INSTANCE | Un nivel relativamente bajo de aislamiento (4). No ocurre una lectura sucia, pero sí podría ocurrir una lectura no repetible o fantasma.
PDO::TRAN_REP_CLASS_REP_INSTANCE | Un nivel de aislamiento relativamente alto (5). No ocurre una lectura sucia o no repetible, pero sí podría ocurrir una lectura fantasma.
PDO::TRAN_SERIALIZABLE | El nivel de aislamiento más alto (6). No ocurren los problemas concernientes a la concurrencia (p.ej. lectura sucia, no repetible, fantasma, etc.).

Las siguientes constantes se pueden usar al obtener la información del esquema. Se pueden pasar a PDO::cubrid_schema().

Banderas de esquema de PDO::CUBRID
Constante | Descripción
PDO::CUBRID_SCH_TABLE | Obtener el nombre y el tipo de tabla de CUBRID.
PDO::CUBRID_SCH_VIEW | Obtener el nombre y el tipo de vista de CUBRID.
PDO::CUBRID_SCH_QUERY_SPEC | Obtener la definición de la consulta de la vista.
PDO::CUBRID_SCH_ATTRIBUTE | Obtener los atributos de la columnas de la tabla.
PDO::CUBRID_SCH_TABLE_ATTRIBUTE | Obtener los atributos de la tabla.
PDO::CUBRID_SCH_METHOD | Obtener el método de instancia. El método de instancia es un método invocado por una instancia de clase. Se usa más a menudo que el método de la clase, ya que se ejecutan más operaciones en la instancia.
PDO::CUBRID_SCH_TABLE_METHOD | Obtener el método de la clase. El método de la clase es un método invocado por un objeto de clase. Se usa normalmente para crear una nueva instancia de clase o para inicializarla. También se usa para acceder o actualizar los atributos de la clase.
PDO::CUBRID_SCH_METHOD_FILE | Obtener la información del fichero donde el método de la tabla está definido.
PDO::CUBRID_SCH_SUPER_TABLE | Obtener el nombre y el tipo de la tabla desde la que se heredan atributos.
PDO::CUBRID_SCH_SUB_TABLE | Obtener el nombre y el tipo de la tabla que hereda los atributos desde esta tabla.
PDO::CUBRID_SCH_CONSTRAINT | Obtener las restricciones de la tabla.
PDO::CUBRID_SCH_TRIGGER | Obtener los disparadores de la tabla.
PDO::CUBRID_SCH_TABLE_PRIVILEGE | Obtener la información de privilegios de la tabla.
PDO::CUBRID_SCH_COL_PRIVILEGE | Obtener la información de los privilegios de la columna.
PDO::CUBRID_SCH_DIRECT_SUPER_TABLE | Obtener la super tabla directa de la tabla.
PDO::CUBRID_SCH_PRIMARY_KEY | Obtener la clave primaria de la tabla.
PDO::CUBRID_SCH_IMPORTED_KEYS | Obtener las claves importadas de la tabla.
PDO::CUBRID_SCH_EXPORTED_KEYS | Obtener las claves exportadas de la tabla.
PDO::CUBRID_SCH_CROSS_REFERENCE | Obtener la relación de referencia de las tablas a remolque.

Tabla de contenidos

  • DSN de PDO_CUBRID — Conectar con bases de datos de CUBRID
  • PDO::cubrid_schema — Obtiene la información del esquema solicitada


Conectar con bases de datos de CUBRID

  • « CUBRID (PDO)
  • PDO::cubrid_schema »
  • PHP Manual
  • CUBRID (PDO)
  • Conectar con bases de datos de CUBRID

DSN de PDO_CUBRID

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_CUBRID — Conectar con bases de datos de CUBRID

Descripción

El Nombre del Origen de Datos (DSN) de PDO_CUBRID está compuesto por los siguientes elementos, delimitados por punto y coma:

Prefijo DSN

El prefijo DSN es cubrid:.

host

El nombre del host en el que reside el servidor de bases dedatos.

port

El puerto en el que se está ejecutando el servidor de bases de datos.

dbname

El nombre de la base de datos.

Notas

Nota:

Cuando se establezca la conexión a CUBRID, se debería proporcionar el nombre de usario y la contraseña excepto el DSN.

Ejemplos

Ejemplo #1 Ejemplos de DSN de PDO_CUBRID

El siguiente ejemplo muestra un DSN de PDO_CUBRID para conectarse a una base de datos de CUBRID:

cubrid:host=localhost;port=33000;dbname=demodb


Obtiene la información del esquema solicitada

  • « DSN de PDO_CUBRID
  • MS SQL Server (PDO) »
  • PHP Manual
  • CUBRID (PDO)
  • Obtiene la información del esquema solicitada

PDO::cubrid_schema

(PECL PDO_CUBRID >= 8.3.0.0001)

PDO::cubrid_schema — Obtiene la información del esquema solicitada

Descripción

public PDO::cubrid_schema ( int $schema_type , string $table_name = ? , string $col_name = ? ) : array

Esta función se usa para obtener la información del esquema solicitada de una base de datos. Se ha de designar table_name, si se quiere obtener información sobre una cierta tabla, col_name, si se quiere obtener información sobre una cierta columna (se puede usar solamente con PDO::CUBRID_SCH_COL_PRIVILEGE).

El resultado de esta función es devuelto como un array de dos dimensiones (columna (array asociativo) * fila (array numérico)). La siguiente tabla muestra los tipos de esquemas y la estructura de columna del array resultante que se devuelve basándose en el tipo de esquema.

Composición del resultado de cada tipo
Esquema | Número de columna | Nombre de columna | Valor
PDO::CUBRID_SCH_TABLE | 1 | NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_VIEW | 1 | NAME |
 | 2 | TYPE | 1:view
PDO::CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
PDO::CUBRID_SCH_ATTRIBUTE / PDO::CUBRID_SCH_TABLE_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
PDO::CUBRID_SCH_METHOD / PDO::CUBRID_SCH_TABLE_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
PDO::CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
PDO::CUBRID_SCH_SUPER_TABLE / PDO::CUBRID_SCH_DIRECT_SUPER_TABLE / PDO::CUBRID_SCH_SUB_TABLE | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
PDO::CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
PDO::CUBRID_SCH_TABLE_PRIVILEGE / PDO::CUBRID_SCH_COL_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
PDO::CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
PDO::CUBRID_SCH_IMPORTED_KEYS / PDO::CUBRID_SCH_EXPORTED_KEYS / PDO::CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

Parámetros

schema_type

El tipo de esquema del que se quiere saber.

table_name

La tabla de la que se quiere conocer el esquema.

col_name

La columna de la que se quiere conocer el esquema.

Valores devueltos

Un array que contiene la información del esquema, cuando el proceso tiene éxito;

FALSE, cuando el proceso no tiene éxito

Ejemplos

Ejemplo #1 Un ejemplo de PDO::cubrid_schema()

Este ejemplo muestra cómo obtener la clave primaria y las claves foráneas de la tabla "game".

<?php
$lista_pk = $gbd->cubrid_schema(PDO::CUBRID_SCH_PRIMARY_KEY, "game");
print_r($lista_pk);

$lista_fk = $gbd->cubrid_schema(PDO::CUBRID_SCH_IMPORTED_KEYS, "game");
print_r($lista_fk);
?>

El resultado del ejemplo sería:

Result:
Array
(
    [0] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => athlete_code
            [KEY_SEQ] => 3
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [1] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => event_code
            [KEY_SEQ] => 2
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [2] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => host_year
            [KEY_SEQ] => 1
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

)
Array
(
    [0] => Array
        (
            [PKTABLE_NAME] => athlete
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => athlete_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_athlete_code
            [PK_NAME] => pk_athlete_code
        )

    [1] => Array
        (
            [PKTABLE_NAME] => event
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => event_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_event_code
            [PK_NAME] => pk_event_code
        )

)


Funciones de Microsoft SQL Server y Sybase (PDO_DBLIB)

Introducción

PDO_DBLIB es un controlador que implementa la interfaz de objetos de datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de Microsoft SQL Server y Sybase a través de la biblioteca FreeTDS.

Esta ya extensión no está disponible para Windows con PHP 5.3 o posterior.

En Windows, se debería de usar SqlSrv, un controlador alternativo para MS SQL que está disponible desde Microsoft: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx .

Si no fuera posible usar SqlSrv, se puede utilizar el controlador PDO_ODBC para conectarse a bases de datos de Microsoft SQL Server y Sybase, ya que la biblioteca Windows DB-LIB nativa está anticuado, no es seguro con subprocesos y Microsoft ya no le proporciona soporte.

Tabla de contenidos

  • PDO_DBLIB DSN — Conectarse a bases de datos de Microsoft SQL Server y Sybase


Conectarse a bases de datos de Microsoft SQL Server y Sybase

  • « MS SQL Server (PDO)
  • Firebird (PDO) »
  • PHP Manual
  • MS SQL Server (PDO)
  • Conectarse a bases de datos de Microsoft SQL Server y Sybase

PDO_DBLIB DSN

(PECL PDO_DBLIB >= 0.9.0)

PDO_DBLIB DSN — Conectarse a bases de datos de Microsoft SQL Server y Sybase

Descripción

El Nombre del origen de datos (DSN) de PDO_DBLIB está compuesto por los siguientes elementos:

DSN prefix

El prefijo DSN prefix is sybase: si PDO_DBLIB fue vinculado con la bibliotecas ct-lib de Sybase, mssql: si PDO_DBLIB fue vinculado con las bibliotecas de Microsoft SQL Server, or dblib: si PDO_DBLIB fue vinculado con las bibliotecas de FreeTDS.

host

El nombre del host en el cual la reside el servidor de bases de datos. El predeterminado es 127.0.0.1.

dbname

El nombre de la base de datos.

charset

El conjunto de caracters del cliente.

appname

El nombre de la aplicación (usado en sysprocesses). El valor predeterminado es "PHP Generic DB-lib" o "PHP freetds".

secure

Actualmente no se utiliza.

Ejemplos

Ejemplo #1 PDO_DBLIB DSN examples

El siguiente ejemeplo muestra una DSN de PDO_DBLIB para conectarse a bases de datos de Microsoft SQL Server y Sybase:

mssql:host=localhost;dbname=testdb
sybase:host=localhost;dbname=testdb
dblib:host=localhost;dbname=testdb


Funciones de Firebird (PDO_FIREBIRD)

Introducción

PDO_FIREBIRD es un controlador que imlementa la interfaz de Objetos de datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de Firebird.

Instalación

Use --with-pdo-firebird[=DIR] para instalar la extensión PDO Firebird, donde [=DIR] es el directorio base de intalación de Firebird.

$ ./configure --with-pdo-firebird

Constantes predefinidas

Estas constantes están definidas por este controlador, y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución. Además, estas constantes específicas del controlador deberían ser utilizadas sólo si está usando este controlador. Usar atributos específicos del controlador con otro controlador podría resultar en un comportamiento inesperado. PDO::getAttribute() puede ser empleado para obtener el atributo PDO::ATTR_DRIVER_NAME para verificar el controlador, si el código puede ejecutarse con múltiples controladores.

PDO::FB_ATTR_DATE_FORMAT (integer)

Establece el formato de fecha.

Disponible desde PHP 5.3.0.

PDO::FB_ATTR_TIME_FORMAT (integer)

Establece el formato de hora.

Disponible desde PHP 5.3.0.

PDO::FB_ATTR_TIMESTAMP_FORMAT (integer)

Establece el formato de marca de tiempo.

Disponible desde PHP 5.3.0.

Tabla de contenidos

  • PDO_FIREBIRD DSN — Conectarse a bases de datos de Firebird


Conectarse a bases de datos de Firebird

  • « Firebird (PDO)
  • IBM (PDO) »
  • PHP Manual
  • Firebird (PDO)
  • Conectarse a bases de datos de Firebird

PDO_FIREBIRD DSN

(PECL PDO_FIREBIRD >= 0.1.0)

PDO_FIREBIRD DSN — Conectarse a bases de datos de Firebird

Descripción

El Nombre del Origen de Datos (DSN) de PDO_FIREBIRD está compuesto por los siguientes elementos:

DSN prefix

El prefijo DSN es firebird:.

dbname

El nombre de la base de datos.

charset

El juego de caracteres.

role

El nombre del rol de SQL.

Ejemplos

Ejemplo #1 Ejemplo de DSN de PDO_FIREBIRD DSN con ruta

El siguiente ejemplo muestra un DSN de PDO_FIREBIRD DSN para conectarse a bases de datos de Firebird:

firebird:dbname=/ruta/a/BASEDATOS.FDB

Ejemplo #2 Ejemplo de DSN de PDO_FIREBIRD DSN con puerto y ruta

El siguiente ejemplo muestra un DSN de PDO_FIREBIRD DSN para conectarse a una base de datos de Firebird usando el puerto del nombre del host y la ruta:

firebird:dbname=nombre_host/puerto:/ruta/A/BASEDATOS.FDB

Ejemplo #3 Ejemplo de DSN de PDO_FIREBIRD con localhost y ruta hacia empleado.fdb en un sistema Debian

El siguiente ejemplo muestra un DSN de PDO_FIREBIRD DSN para conectarse a la base de datos empleado.fdb de Firebird usando:

firebird:dbname=localhost:/var/lib/firebird/2.5/data/empleado.fdb


Funciones de IBM (PDO_IBM)

Introducción

PDO_IBM es un controlador que implementa la interfaz de Objetos de datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de IBM.

Instalación

Para construir la extensión PDO_IBM, DB2 Client v9.1 o posterior debe estar instalado en el mismo sistema que PHP. DB2 Client se puede descargar Desde el » Sitio de desarrollo de aplicaciones de IBM.

Nota: Nota

DB2 Client v9.1 o posterior da soporte al acceso directo de DB2 para servidores Linux, UNIX, y Windows v8 y v9.1.

DB2 Client v9.1 también da soporte para el acceso a DB2 UDB para i5 y DB2 UDB para servidores z/OS utilizando la adquisición por separada del producto » DB2 Connect.

PDO_IBM es una extensión » PECL, por lo que siga las instrucciones en Instalación de extensiones PECL para instalar la extensión PDO_IBM. Ejecute el comando configure para que apunte a la ubicación de los ficheros de cabecera y a las bibliotecas de DB2 como sigue:

bash$ ./configure --with-pdo-ibm=/path/to/sqllib[,shared]
El valor predeterminado de configure es la variables de entorno DB2DIR.

Tabla de contenidos

  • DSN de PDO_IBM — Conectarse a bases de datos de IBM


Conectarse a bases de datos de IBM

  • « IBM (PDO)
  • Informix (PDO) »
  • PHP Manual
  • IBM (PDO)
  • Conectarse a bases de datos de IBM

DSN de PDO_IBM

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_IBM — Conectarse a bases de datos de IBM

Descripción

El Nombre del origen de datos (DSN) de PDO_IBM (DSN) está basado en el DSN de CLI de IBM. Los componentes princiaples del DSN de PDO_IBM DSN son:

Prefijo DSN

El prefijo DSN es ibm:.

DSN

El DSN puede ser lo siguiente:

  • a) La configuración del origen de datos usando db2cli.ini o odbc.ini

  • b) El nombre de la base de datos catalogada, es decir, el alias de la base de datos en el catálogo cliente de DB2

  • c) Una cadena de conexión completa con el siguiente formato: DRIVER={IBM DB2 ODBC DRIVER};DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password; donde cada parámetro representa los siguientes valores:

    database

    El nombre de la base de datos.

    hostname

    El nombre o la dirección IP del host del servidor de bases de datos.

    port

    El puerto TCP/IP en el que la base de dtaos escuchará peticiones.

    username

    El nombre de usuario con el cual conectarse a la base de datos.

    password

    La contraseña con la cual conectarse a la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de DSN de PDO_IBM DSN usando db2cli.ini

El siguiente ejemplo muestra un DSN de PDO_IBM DSN para conectarse a una base de datos de DB2 catalogada como DB2_9 en db2cli.ini:

$bd = new PDO("ibm:DSN=DB2_9", "", "");

[DB2_9]
Database=testdb
Protocol=tcpip
Hostname=11.22.33.444
Servicename=56789

Ejemplo #2 Ejemplo de DSN de PDO_IBM usando una cadena de conexión

El siguiente ejemplo muestra un DSN de PDO_IBM para conectarse a un base de datos de DB2 llamada testdb usando la sintaxis de cadena de conexión de DB2 CLI.

$bd = new PDO("ibm:DRIVER={IBM DB2 ODBC DRIVER};DATABASE=testdb;" .
  "HOSTNAME=11.22.33.444;PORT=56789;PROTOCOL=TCPIP;", "testuser", "tespass");


Funciones de Informix (PDO_INFORMIX)

Introducción

PDO_INFORMIX es un controlador que implementa la interfaz de Objetos de datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de Informix.

Instalación

Para construir la extensión PDO_INFORMIX, Informix Client SDK 2.81 UC1 o superior debe estar instalado en el mismo sistema que PHP. Informix Client SDK está disponible desde el » Sitio de soporte de Informix de IBM.

PDO_INFORMIX es una extensión » PECL, por lo que siga las instrucciones en Instalación de extensiones PECL para instalar la extensión PDO_INFORMIX. Ejecute el comando configure para que apunte a la ubicación de los ficheros de cabecera y las bibliotecas de Informix Client SDK como sigue:

   bash$ ./configure --with-pdo-informix=/path/to/SDK[,shared]
El valor predetermiando de configure es la variable de entorno INFORMIXDIR.

Cursores desplazables

PDO_INFORMIX admite los cursores desplazables; sin embargo, estos no están habilitados de forma predeterminada. Para habilitar el soporte de cursores desplazables, se debe establecer ENABLESCROLLABLECURSORS=1 en los ajustes de conexión de ODBC correspondientes en odbc.ini, o pasar la cláusula EnableScrollableCursors=1 en la cadena de conexión de DSN.

Tabla de contenidos

  • DSN de PDO_INFORMIX — Conectarse a bases de datos de Informix


Conectarse a bases de datos de Informix

  • « Informix (PDO)
  • MySQL (PDO) »
  • PHP Manual
  • Informix (PDO)
  • Conectarse a bases de datos de Informix

DSN de PDO_INFORMIX

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_INFORMIX — Conectarse a bases de datos de Informix

Descripción

El Nombre del Origen de Datos (DSN) de PDO_INFORMIX está basado en la cadena del DSN de ODBC de Informix. Los detalles sobre la configuración de un DSN de ODBC de Informix están disponbles en el » Centro de información de servidores dinámicas de Informix. Los pricipales componentes del DSN de PDO_INFORMIX son:

Prefijo DSN

El prefijo DSN es informix:.

DSN

El DSN puede ser una configuración de origen de datos usando odbc.ini, o una » cadena de conexión completa.

Ejemplos

Ejemplo #1 Ejemplo de DSN de PDO_INFORMIX usando odbc.ini

El siguiente ejemplo muestra un DSN de PDO_INFORMIX para conectarse a una base de datos de Informix catalogada como Infdrv33 en odbc.ini:

$bd = new PDO("informix:DSN=Infdrv33", "", "");

[ODBC Data Sources]
Infdrv33=INFORMIX 3.3 32-BIT

[Infdrv33]
Driver=/opt/informix/csdk_2.81.UC1G2/lib/cli/iclis09b.so
Description=INFORMIX 3.3 32-BIT
Database=common_db
LogonID=testuser
pwd=testpass
Servername=ids_server
DB_LOCALE=en_US.819
OPTIMIZEAUTOCOMMIT=1
ENABLESCROLLABLECURSORS=1

Ejemplo #2 Ejemplo de DSN de PDO_INFORMIX usando una cadena de conexión

El siguiente ejemplo muestra un DSN de PDO_INFORMIX DSN para conectarse a una base de datos de Informix llamada common_db usando la sintaxis de cadena de conexión de Informix.

$bd = new PDO("informix:host=host.domain.com; service=9800;
    database=common_db; server=ids_server; protocol=onsoctcp;
    EnableScrollableCursors=1", "testuser", "tespass");


Funciones de MySQL (PDO_MYSQL)

Introducción

PDO_MYSQL es un controlador que implementa la interfaz de Objetos de Datos de PHP (PDO) para permitir el acceso de PHP a bases de datos de MySQL 3.x, 4.x y 5.x.

PDO_MYSQL aprovechará el soporte nativo de sentencias preparadas presente en MySQL 4.1 y superior. Si se utiliza una versión anterior de las bibliotecas cliente de MySQL, PDO las emulará.

Advertencia

Algunos tipos de tablas (motores de almacenamiento) de MySQL no admiten transacciones. Cuando se escribe código de base de datos transaccional usando un tipo de tabla que no soporta transacciones, MySQL aparentará que se inició una transacción éxito. Además, cualquier consulta DDL ejecutada consignará implícitamente cualquier transacción pendiente.

Instalación

Las distribuciones comunes de Unix incluyen versiones binarias de PHP que se pueden instalar. Aunque estas versiones binarias son típicamente construidas con soporte para las extensiones de MySQL, podría ser necesario instarlar las bibliotecas de extensiones en sí utilizando un paquete adicional. Compruebe el gestor de paquetes que viene con la distribución elegida para su disponibilidad.

Por ejemplo, en Ubuntu el paquete php5-mysql instala las extensiones de PHP ext/mysql, ext/mysqli, y pdo_mysql. En CentOS, el paquete php-mysql también instala estas tres extensiones de PHP.

De forma alternativa, esta extensión la puede compilar uno mismo. Construir PHP desde la fuente permite especificar las extensiones de MySQL que se quieren usar, así como elegir la biblioteca cliente para cada extensión.

Al compilar, utilice --with-pdo-mysql[=DIR] para instalar la extensión PDO MySQL, donde la opción [=DIR] es la biblioteca base de MySQL. A partir de PHP 5.4, mysqlnd es la biblioteca predeterminada. Para más detalles sobre la elección de una biblioteca, véase Elegir una biblioteca de MySQL.

Opcionalmente, --with-mysql-sock[=DIR] establece la ubicación del puntero del socket de unix de MySQL para todas las extensiones de MySQL, incluyendo PDO_MYSQL. Si no se especifica, se buscará en las ubicaciones predeterminadas.

Opcionalmente, --with-zlib-dir[=DIR] se utiliza para establecer la ruta para el prefijo de instalación de libz.

$ ./configure --with-pdo-mysql --with-mysql-sock=/var/mysql/mysql.sock

El soporte para SSL se habilita mediante las constantes de PDO_MySQL apropiadas, lo cual es equivalente a llamar a la » función mysql_ssl_set() de la API en C de MySQL. Asimismo, SSL no se puede habilitar con PDO::setAttribute, debido a que la conexión ya existe. Véase también la documentación de MySQL sobre » conectarse a MySQL con SSL.

Historial de cambios
Versión | Descripción
5.4.0 | mysqlnd se convirtió en la biblioteca predeterminada de MySQL al compilar PDO_MYSQL. Anteriormente, libmysqlclient era la biblioteca predeterminada de MySQL.
5.4.0 | Las versiones 4.1 y anteriores de la biblioteca cliente de MySQL ya no tienen soporte.
5.3.9 | Agregado el soporte para SSL con mysqlnd y OpenSSL.
5.3.7 | Agregado el soporte para SSL con libmysqlclient y OpenSSL.

Constantes predefinidas

Estas constantes están definidas por este controlador, y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución. Además, estas constantes específicas del controlador deberían ser utilizadas sólo si está usando este controlador. Usar atributos específicos del controlador con otro controlador podría resultar en un comportamiento inesperado. PDO::getAttribute() puede ser empleado para obtener el atributo PDO::ATTR_DRIVER_NAME para verificar el controlador, si el código puede ejecutarse con múltiples controladores.

MYSQL_ATTR_USE_BUFFERED_QUERY (integer)
Si este atributo es definido como true en PDOStatement, el controlador de MySQL usará las versiones de la API de MySQL guardadas en el búfer. Si se está escribiendo código portable, en su lugar se debería usar PDOStatement::fetchAll().

Ejemplo #1 Forzar consultas para que sean guardadas en el búfer en mysql

<?php
if ($bs->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
    $sentencia = $bs->prepare('select * from foo',
        array(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY => true));
} else {
    die("mi aplicación sólo funciona con mysql; debería usar \$sentencia->fetchAll() en su lugar");
}
?>

MYSQL_ATTR_LOCAL_INFILE (integer)

Activa LOAD LOCAL INFILE.

Se ha de tener en cuenta que esta constante se puede usar solamente en el array driver_options cuando se construye un nuevo gestor de base de datos.

MYSQL_ATTR_INIT_COMMAND (integer)

Comando a ejecutar cuando se conecta al servidor MySQL. Al reconectar se volverá a ejecutar automáticamente.

Se ha de tener en cuenta que esta constante se puede usar solamente en el array driver_options cuando se construye un nuevo gestor de base de datos.

MYSQL_ATTR_READ_DEFAULT_FILE (integer)

Lee las opciones desde el fichero indicado en lugar de my.cnf. Si se usa mysqlnd, esta opción no está disponible debido a que mysqlnd no lee los fichero de configuración de mysql.

MYSQL_ATTR_READ_DEFAULT_GROUP (integer)

Opciones de lectura del grupo indicado desde my.cnf o desde el fichero especificado con MYSQL_READ_DEFAULT_FILE. Si se usa mysqlnd, esta opción no está disponible debido a que mysqlnd no lee los ficheros de configuración de mysql.

MYSQL_ATTR_MAX_BUFFER_SIZE (integer)

Tamaño máximo del búfer. Lo predeterminado es MiB. Esta constante no está admitida cuando se compila para mysqlnd.

MYSQL_ATTR_DIRECT_QUERY (integer)

Realiza consultas directas, no usa setencias preparadas.

MYSQL_ATTR_FOUND_ROWS (integer)

Devuelve el número de filas encontradas (coindicentes), no el número de filas modificadas.

MYSQL_ATTR_IGNORE_SPACE (integer)

Permite espacios después de los nombres de función. Hace de todos los nombres de función palabras reservadas.

MYSQL_ATTR_COMPRESS (integer)

Activa la compresión de comunicación de red. Esta también se admite cuando se realizó la compilación con mysqlnd, a partir de PHP 5.3.11.

MYSQL_ATTR_SSL_CA (integer)

La ruta al fichero de la autoridad certificadora SSL.

Existe a partir de PHP 5.3.7.

MYSQL_ATTR_SSL_CAPATH (integer)

La ruta al directorio que contiene los certificados AC SSL autorizados, los cuales están almacenados en formato PEM.

Existe a partir de PHP 5.3.7.

MYSQL_ATTR_SSL_CERT (integer)

La ruta al fichero del certificado SSL.

Existe a partir de PHP 5.3.7.

PDO::MYSQL_ATTR_SSL_CIPHER (integer)

Una lista de uno o más cifradores permisibles a usar para la encriptación SSL, en un formato entendido por OpenSSL. Por ejemplo: DHE-RSA-AES256-SHA:AES128-SHA

Existe a partir de PHP 5.3.7.

PDO::MYSQL_ATTR_SSL_KEY (integer)

La ruta al fichero de la clave SSL.

Existe a partir de PHP 5.3.7.

PDO::MYSQL_ATTR_MULTI_STATEMENTS (integer)

Inhabilita la ejecución de multiconsultas tanto en PDO::prepare() como en PDO::query() cuando se setablece a false.

Observe que esta constante solamente se puede emplear en el array driver_options al construir un nuevo manejador de base de datos.

Existe a partir de PHP 5.5.21 y PHP 5.6.5.

Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de PDO_MYSQL
Nombre | Por defecto | Cambiable
pdo_mysql.default_socket | "/tmp/mysql.sock" | PHP_INI_SYSTEM
pdo_mysql.debug | NULL | PHP_INI_SYSTEM
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

pdo_mysql.default_socket string

Establece un socket de dominio Unix. Este valor se puede establecer en tiempo de compilación si un socket de dominio se encuentra en la configuración. Este ajuste ini es sólo de Unix.

pdo_mysql.debug boolean

Activa la depuración de PDO_MYSQL. Este ajuste solo está disponible cuando PDO_MYSQL está compilado para mysqlnd y en el modo de depuración de PDO.

Tabla de contenidos

  • PDO_MYSQL DSN — Conectarse a bases de datos de MySQL


Conectarse a bases de datos de MySQL

  • « MySQL (PDO)
  • MS SQL Server (PDO) »
  • PHP Manual
  • MySQL (PDO)
  • Conectarse a bases de datos de MySQL

PDO_MYSQL DSN

(PECL PDO_MYSQL >= 0.1.0)

PDO_MYSQL DSN — Conectarse a bases de datos de MySQL

Descripción

El Nombre de Origen de Datos (DSN) de PDO_MYSQL está compuesto por los siguientes elementos:

prefijo DSN

El prefijo DSN es mysql:.

host

El nombre del equipo anfitrión donde reside el servidor de bases de datos.

port

El número de puerto que el servidor de bases de datos está escuchando.

dbname

El nombre de la base de datos.

unix_socket

El socket Unix de MySQL (no debe usarse con host o port).

charset

El conjunto de caracteres. Véase la documentación sobre los conceptos de conjuntos de caracteres para más información.

Antes de PHP 5.3.6, este elemento era ignorado de forma silenciosa. Se puede replicar el mismo comportamiento parcialmente con la opción PDO::MYSQL_ATTR_INIT_COMMAND del controlador, como muestra el siguiente ejemplo.

Advertencia

El método del siguiente ejemplo sólo puede usarse con juegos de caracteres que compartan una misma represntación ASCII de los 7 últimos bits, como ISO-8859-1 o UTF-8. Los usuarios que utilicen juegos de caracteres con representaciones distintas (como UTF-16 o Big5) deben usar la opción charset que ofrece la versión 5.3.6 de PHP y posterior.

Ejemplo #1 Establecer el juego de caracteres de la conexión a UTF-8, antes de PHP 5.3.6

<?php
$dsn = 'mysql:host=localhost;dbname=testdb';
$nombre_usuario = 'nombre_usuario';
$contraseña = 'contraseña';
$opciones = array(
    PDO::MYSQL_ATTR_INIT_COMMAND => 'SET NAMES utf8',
);

$gbd = new PDO($dsn, $nombre_usuario, $contraseña, $opciones);
?>

Historial de cambios

Versión | Descripción
5.3.6 | Antes de la versión 5.3.6, charset era ignorado.

Ejemplos

Ejemplo #2 ejemplos PDO_MYSQL DSN

El siguiente ejemplo muestra un DSN de PDO_MYSQL para conectarse a una base de datos de MySQL:

mysql:host=localhost;dbname=testdb
Más ejemplos completos:
mysql:host=localhost;port=3307;dbname=testdb
mysql:unix_socket=/tmp/mysql.sock;dbname=testdb

Notas

Nota: Unix solamente:

Cuando el nombre de equipo anfitrión está definido como "localhost", la conexión al servidor se realiza a través de un socket de dominio. Si PDO_MYSQL se compila para libmysqlclient, entonces la ubicación del fichero del socket será la ubicación donde se compiló libmysqlclient. Si PDO_MYSQL se compila para mysqlnd, se puede establecer un socket predeterminado a través del ajuste pdo_mysql.default_socket.


Funciones de Microsoft SQL Server (PDO_SQLSRV)

Introducción

PDO_SQLSRV es un controlador que implementa la interfaz de Objetos de Datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos de MS SQL Server (comenzando con SQL Server 2005) y de SQL Azure.

Instalación

La extensión PDO_SQLSRV se habilita añadiendo el fichero DLL apropiado al directorio de extensiones de PHP y la entrada correspondiente al fichero php.ini. La descarga de PDO_SQLSRV viene con ocho ficheros de controlador, cuatro de los cuales son para dar soporte a PDO. Si se está ejecutando PHP como no seguro con subprocesos (PHP 5.3), use el fichero php_pdo_sqlsrv_53_nts.dll. (Debería de usarse una versión no segura con subprocesos si se utiliza IIS como servidor web). Si se está ejecutando PHP como seguro con subprocesos, use el fichero php_pdo_sqlsrv_53_ts.dll. De manera similar para PHP 5.4, use php_pdo_sqlsrv_54_nts.dll o php_pdo_sqlsrv_54_ts.dll, dependiendo de si la instalación de PHP no es o es segura con subprocesos.

La versión más reciente del controlador está disponible aquí: » Descarga de SQLSRV 3.0. Si fuera necesario dar soporte paraor PHP 5.2 y/o PHP compilado con VC6, use la versión 2.0 del controlador: » Descarga de SQLSRV 2.0.

Para más información sobre los requisitos del sistema, véase » Requisitos del sistema de SQLSRV.

La extensión PDO_SQLSRV solamente es compatible con PHP ejecutándose bajo Windows. Para Linux, véase ODBC y » Microsoft's SQL Server ODBC Driver para Linux.

Constantes predefinidas

Estas constantes están definidas por este controlador, y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución. Además, estas constantes específicas del controlador deberían ser utilizadas sólo si está usando este controlador. Usar atributos específicos del controlador con otro controlador podría resultar en un comportamiento inesperado. PDO::getAttribute() puede ser empleado para obtener el atributo PDO::ATTR_DRIVER_NAME para verificar el controlador, si el código puede ejecutarse con múltiples controladores.

PDO::SQLSRV_TXN_READ_UNCOMMITTED (integer)
Esta constante es un valor aceptable para la clave TransactionIsolation del DSN de SQLSRV. Esta constante establece el nivel de aislamiento para la conexión a Read Uncommitted.
PDO::SQLSRV_TXN_READ_COMMITTED (integer)
Esta constante es un valor aceptable para la clave TransactionIsolation del DSN de SQLSRV. Esta constante establece el nivel de aislamiento para la conexión a Read Committed.
PDO::SQLSRV_TXN_REPEATABLE_READ (integer)
Esta constante es un valor aceptable para la clave TransactionIsolation del DSN de SQLSRV. Esta constante establece el nivel de aislamiento para la conexión a Repeateable Read.
PDO::SQLSRV_TXN_SNAPSHOT (integer)
Esta constante es un valor aceptable para la clave TransactionIsolation del DSN de SQLSRV. Esta constante establece el nivel de aislamiento para la conexión a Snapshot.
PDO::SQLSRV_TXN_SERIALIZABLE (integer)
Esta constante es un valor aceptable para la clave TransactionIsolation del DSN de SQLSRV. Esta constante establece el nivel de aislamiento para la conexión a Serializable.
PDO::SQLSRV_ENCODING_BINARY (integer)
Specifies that data is sent/retrieved as a raw byte stream to/from the server without performing encoding or translation. This constant can be passed to PDOStatement::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_SYSTEM (integer)
Specifies that data is sent/retrieved to/from the server as 8-bit characters as specified in the code page of the Windows locale that is set on the system. Any multi-byte characters or characters that do not map into this code page are substituted with a single byte question mark (?) character. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_UTF8 (integer)
Specifies that data is sent/retrieved to/from the server in UTF-8 encoding. This is the default encoding. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_DEFAULT (integer)
Specifies that data is sent/retrieved to/from the server according to PDO::SQLSRV_ENCODING_SYSTEM if specified during connection. The connection's encoding is used if specified in a prepare statement. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ATTR_QUERY_TIMEOUT (integer)
A non-negative integer representing the timeout period, in seconds. Zero (0) is the default and means no timeout. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, and PDO::prepare.
PDO::SQLSRV_ATTR_DIRECT_QUERY (integer)
Indicates that a query should be executed directly, without being prepared. This constant can be passed to PDO::setAttribute, and PDO::prepare. For more information, see » Direct and Prepared Statement Execution.

Tabla de contenidos

  • DSN de PDO_SQLSRV — Conectar a bases de datos de MS SQL Server y de SQL Azure


Conectar a bases de datos de MS SQL Server y de SQL Azure

  • « MS SQL Server (PDO)
  • Oracle (PDO) »
  • PHP Manual
  • MS SQL Server (PDO)
  • Conectar a bases de datos de MS SQL Server y de SQL Azure

DSN de PDO_SQLSRV

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_SQLSRV — Conectar a bases de datos de MS SQL Server y de SQL Azure

Descripción

El Nombre del Origen de Datos (DSN) de PDO_SQLSRV está compuesto de los siguientes elementos:

DSN prefix

El prefijo DSN es sqlsrv:.

APP

El nombre de la aplicación usada en el rastreo.

ConnectionPooling

Especifica si la conexión se asigna desde una agrupación de conexiones (1 o true) o no (0 o false).

Database

El nombre de la base de datos.

Encrypt

Especifica si la comunicación con SQL Server está encriptada (1 o true) o desencriptada (0 o false).

Failover_Partner

Especifica si el servidor y la instancia de la copia de la base de datos (si está habilitada y configurada) a utilizar cuando el servidor primario no esté disponible.

LoginTimeout

Especifica el número de segundos a esperar antes de dar como fallido el intento de conexión.

MultipleActiveResultSets

Deshabilita o explítamente habilita el soporte para múltiples conjutos de resultados activos (MARS por sus siglas en íngles).

QuotedId

Especifica si utilizar las normas de SQL-92 para identificadores entrecomillados (1 o true) o utilizar las normas antiguas de Transact-SQL (0 o false).

Server

El nombre del servidor de bases de datos.

TraceFile

Especifica la ruta del fichero utilizado para datos de rastreo.

TraceOn

Especifica si el rastreo de ODBC está habilitado (1 o true) o deshabilitado (0 o false) para la conexión que se va a establecer.

TransactionIsolation

Especifica el nivel de aislamiento de las transacciones. Los valores aceptados para
esta opción son PDO::SQLSRV_TXN_READ_UNCOMMITTED, PDO::SQLSRV_TXN_READ_COMMITTED,
PDO::SQLSRV_TXN_REPEATABLE_READ, PDO::SQLSRV_TXN_SNAPSHOT, y
PDO::SQLSRV_TXN_SERIALIZABLE.

TrustServerCertificate

Especifica si el cliente debería confiar en (1 o true) o rechazar (0 o false) un certificado de servidor autofirmado.

WSID

Especifica el nombre de la computadora para rastreos.

Ejemplos

Ejemplo #1 Ejemplos de DSN de PDO_SQLSRV

El siguiente ejemeplo muestra cómo conectar a una base de datos de MS SQL Server especificada:

$c = new PDO("sqlsrv:Server=localhost;Database=testdb", "NombreUsuario", "Contraseña");

El siguiente ejemplo muestra cómo conectar a una base de datos de MS SQL Server en un puerto especificado:

$c = new PDO("sqlsrv:Server=localhost,1521;Database=testdb", "NombreUsuario", "Contraseña");

El siguiente ejemplo muestra cómo conectar a un base de datos de SQL Azure con el ID de servidor 12345abcde. Obsérvese que cuando se realiza una conexión a SQL Azure con PDO, el nombre del usuario será NombreUsuario@12345abcde (NombreUsuario@IdServidor).

$c = new PDO("sqlsrv:Server=12345abcde.database.windows.net;Database=testdb", "NombreUsuario@12345abcde", "Password");


Funciones de Oracle (PDO_OCI)

Instalación

Utilice --with-pdo-oci[=DIR] para instalar la extensión PDO Oracle OCI, donde el opcional [=DIR] es el directorio base de la instalación de Oracle. [=DIR] por defecto es la variable de entorno $ORACLE_HOME.

Utilice --with-pdo-oci=instantclient,prefijo,versión para un cliente de la Instancia Oracle SDK, donde prefijo y versión se configuran.

// Usando $ORACLE_HOME
$ ./configure --with-pdo-oci

// Usando OCI para Linux con la versión 10.2.0.3 con un prefijo /usr
$ ./configure --with-pdo-oci=instantclient,/usr,10.2.0.3

Tabla de contenidos

  • DSN de PDO_OCI — Conectar a bases de datos de Oracle


Conectar a bases de datos de Oracle

  • « Oracle (PDO)
  • ODBC y DB2 (PDO) »
  • PHP Manual
  • Oracle (PDO)
  • Conectar a bases de datos de Oracle

DSN de PDO_OCI

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_OCI — Conectar a bases de datos de Oracle

Descripción

El Nombre de Orígenes de Datos (DSN, por sus siglas en inglés) de PDO_OCI está compuesto por los siguientes elementos:

Prefijo DSN

El prefijo DSN es oci:.

dbname (Oracle Instant Client)

La URI para la conexión a Oracle Instant Client toma la forma de nombre_bd=//nombre_host:número_puerto/basedatos. Si la conexión se realiza a una base de datos definida en tnsnames.ora, solamente se ha de usar el nombre de la base de datos: nombre_bd=basedatos.

charset

El conjunto de caracters del lado del cliente para el gestor de entorno en uso.

Ejemplos

Ejemplo #1 Ejemplos del DSN de PDO_OCI

Los siguientes ejemplos muestran una DSN de PDO_OCI para conectarse a bases de datos de Oracle:

// Conectar a un base de datos definida en tnsnames.ora
oci:dbname=mydb

// Conectarse usando Oracle Instant Client
oci:dbname=//localhost:1521/mydb


Funciones de ODBC y DB2 (PDO_ODBC)

Introducción

PDO_ODBC es un controlador que implementa la interfaz de Objetos de datos de PHP (PDO) para habilitar el acceso desde PHP a bases de datos a través de contorladores ODBC o de la biblioteca IBM DB2 Call Level Interface (DB2 CLI). PDO_ODBC admite actualmente tres "sabores" diferentes de controladores de bases de datos:

ibm-db2

Da soporte para el acceso a servidores de IBM DB2 Universal Database, Cloudscape, y Apache a través del cliente gratuito DB2.

unixODBC

Da soporte para el acceso a servidores de bases de datos a través del administrador de gestores de unixODBC y de los controladores de ODBC proppietarios de bases de datos.

generic

Ofrece una opción de compilación para los administradores de gestores de ODBC que no están admitidos explícitamente pore PDO_ODBC.

En Windows, PDO_ODBC está construido dentor del núcleo de PHP de manera predeterminada. Está vinculado con Windows ODBC Driver Manager, por lo que PHP puede conectarse a cualquier base de datos catalogada en un DSN de sistema, y es el controlador recomendado para conectarse a bases de datos de Microsoft SQL Server.

Instalación

PDO_ODBC en sistemas UNIX

  1. A partir de PHP 5.1, PDO_ODBC está incluido en los ficheros fuente de PHP. Se puede compilar la extensión PDO_ODBC como un módulo estático o compartido usando los siguientes comandos configure.

    ibm_db2

    ./configure --with-pdo-odbc=ibm-db2,/opt/IBM/db2/V8.1/
    Para contruir PDO_ODBC con el sabor ibm-db2, se han de tener instaladas previamente las cabeceras de desarrollo de aplicaciones de DB2 en la misma máquina en la que se compile PDO_ODBC. Las cabeceras de desarrollo de aplicaciones de DB2 son una opción instalable en los servidores de DB2, y también están disponibles como parte de DB2 Application Development Client, disponible para descargar gratuitamente desde el » sitio de soporte de IBM DB2 Universal Database.

    Si no se proporciona una ubicación para las bibliotecas y cabeceras de DB2 al comando configure, PDO_ODBC usará como valor predeterminado /home/db2inst1/sqllib.

    unixODBC

    ./configure --with-pdo-odbc=unixODBC,/usr/local
    Si no se proporciona una ubicación para las bibliotecas y cabeceras de unixODBC al comando configure, PDO_ODBC usará como valor predetermiando /usr/local.

    generic
    ./configure --with-pdo-odbc=generic,/usr/local,libname,ldflags,cflags

Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de PDO_ODBC
Nombre | Por defecto | Cambiable | Historial de cambios
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | Disponible desde PHP 5.1.0.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | Disponible desde PHP 5.1.1. Esta característica obsoleta será eliminada con certeza en el futuro.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

pdo_odbc.connection_pooling string

Si agrupar conexiones de ODBC. Se puede usar "strict", "relaxed" o "off" (que es igual a ""). El parámetro describe cómo de estricta debería ser el administrador de conexiones cuando coincidan los parámetros de conexión con conexiones existentes en la agrupación. strict es el valor predetermiando recomendado, y dará como resultado en el uso de conexiones almacenadas en caché solamente cuando todos los parámetros de conexión coincidan exactamente. relaxed dará como resultado el uso de conexiones almacenadas en caché cuando se utilicen parámetros de conexión similares. Esto puede resultar en el aumento del uso de la caché, con el riesgo de perder información de conexión entre (por ejemplo) hosts virtuales.

Este ajuste solamente se puede cambiar desde el fichero php.ini, y afecta al proceso completo; cualquier otro módulo dentro del proceso que utilice las mismas bibliotecas de ODBC también se verá afectado, incluyendo la Extensión ODBC Unificada.

Advertencia

relaxed no debería usarse en servidores compartidos, por razones de seguridad.

Sugerencia

Deje este ajuste a la configuración strict predeterminada a menos que tenga una buena razón para cambiarlo.

pdo_odbc.db2_instance_name string

Si se compila PDO_ODBC usando el sabor db2, este ajuste establece el valor de la variable de entorno DB2INSTANCE en sistemas operativos Linux y UNIX al nombre especificado de la instancia de DB2. También habilita PDO_ODBC para resolver la ubicación de las bibliotecas de DB2 y realizar conexiones catalogadas a bases de datos DB2.

Este ajuste solamente se puede cambiar desde el fichero php.ini, y afecta al proceso completo; cualquier otro módulo dentro del proceso que utilice las mismas bibliotescas de ODBC también se verá afectado, incluyendo la Extensión ODBC Unificada.

Este ajuste no tiene efecto en Windows.

Tabla de contenidos

  • DSN de PDO_ODBC — Conectarse a bases de datos de ODBC o de DB2


Conectarse a bases de datos de ODBC o de DB2

  • « ODBC y DB2 (PDO)
  • PostgreSQL (PDO) »
  • PHP Manual
  • ODBC y DB2 (PDO)
  • Conectarse a bases de datos de ODBC o de DB2

DSN de PDO_ODBC

(No hay información de versión disponible, podría estar únicamente en Git)

DSN de PDO_ODBC — Conectarse a bases de datos de ODBC o de DB2

Descripción

El Nombre del Origen de Datos (DSN) de PDO_ODBC está compuesto por los siguientes elementos:

Prefijo DSN

El prefijo DSN es odbc:. Si se realiza un conexión a una base de datos catalogada en el administrador de controladores de ODBC o en el catálogo de DB2, se puede añadir el nombre del catálogo de la base de datos al DSN.

DSN

El nombre de la base de datos tal como está catalogada en el administrador de controladores de ODBC o en el catálogo de DB2. Alternativamente, se puede proporcionar una cadena de conexión de ODBC completa para conectarse a una base de datos como está descrito en » http://www.connectionstrings.com/.

UID

El nombre del usuario para la conexión. Si se especifica el nombre de usuario en el DSN, PDO ignorará el valor del argumento de nombre de usuario en el constructor de PDO.

PWD

La contraseña del usuario para la conexión. Si se especifica la contraseña en el DSN, PDO ignorará el valor del argumento de contraseña en el constructor de PDO.

Ejemplos

Ejemplo #1 Ejemplo de DSN de PDO_ODBC (administrador de controladores de ODBC)

El siguiente ejemplo muestra un DSN de PDO_ODBC para conectarse a una base de datos de ODBC catalogada en testdb en el administrador de controladores de ODBC:

odbc:testdb

Ejemplo #2 Ejemplo de DSN de PDO_ODBC (conexión no catalogada de IBM DB2)

El siguiente ejemplo muestra un DSN de PDO_ODBC para conectarse a una base de datos de IBM DB2 llamada SAMPLE usando la sintaxis completa de DSN de ODBC:

odbc:DRIVER={IBM DB2 ODBC DRIVER};HOSTNAME=localhost;PORT=50000;DATABASE=SAMPLE;PROTOCOL=TCPIP;UID=db2inst1;PWD=ibmdb2;

Ejemplo #3 Ejemplo de DSN de PDO_ODBC (conexión no catalogada de Microsoft Access)

El siguiente ejemplo muestra un DSN de PDO_ODBC para conectarse a una base de datos de Microsoft Access almacenada en C:\db.mdb usando la sintaxis completa de DSN de ODBC:

odbc:Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\\db.mdb;Uid=Admin


Funciones de PostgreSQL (PDO_PGSQL)

Introducción

PDO_PGSQL es un controlador que implementa la interfaz de Objetos de Datos de PHP (PDO) para permitir el acceso desde PHP a bases de datos de PostgreSQL.

Tipos de recursos

Esta extensión define un recurso de flujo devuelto por PDO::pgsqlLOBOpen().

Instalación

Utilice --with-pdo-pgsql[=DIR] para instalar la extensión PDO PostgreSQL, donde el opcional [=DIR] es el directorio base de la instalación de PostgreSQL o la ruta a pg_config.

$ ./configure --with-pdo-pgsql

Tabla de contenidos

  • PDO_PGSQL DSN — Conectarse a bases de datos de PostgreSQL
  • PDO::pgsqlCopyFromArray — Copiar datos de un array de PHP a una tabla
  • PDO::pgsqlCopyFromFile — Copiar datos de un fichero a una tabla
  • PDO::pgsqlCopyToArray — Copiar datos de una tabla de una base de datos a un array de PHP
  • PDO::pgsqlCopyToFile — Copiar datos desde una tabla a un fichero
  • PDO::pgsqlGetNotify — Obtener una notificación asíncrona
  • PDO::pgsqlGetPid — Obtener el PID del servidor
  • PDO::pgsqlLOBCreate — Crear un nuevo objeto grande
  • PDO::pgsqlLOBOpen — Abrir un flujo de un objeto grande existente
  • PDO::pgsqlLOBUnlink — Eliminar un objeto grande


Conectarse a bases de datos de PostgreSQL

  • « PostgreSQL (PDO)
  • PDO::pgsqlCopyFromArray »
  • PHP Manual
  • PostgreSQL (PDO)
  • Conectarse a bases de datos de PostgreSQL

PDO_PGSQL DSN

(PHP 5 >= 5.1.0, PHP 7, PECL PDO_PGSQL >= 0.1.0)

PDO_PGSQL DSN — Conectarse a bases de datos de PostgreSQL

Descripción

El Nombre de origen de datos (DNS) de PDO_PGSQL está compuesto de los siguientes elementos, delimitados por espacios o punto y comas:

prefijo DSN

El prefijo DSN es pgsql:.

host

El nombre del host donde reside el servidor de base de datos.

port

El puerto en el que el servidor de base de datos se está ejecutando.

dbname

El nombre de la base de datos.

user

El nombre del usuario para la conexión. Si se especifica el nombre de usuario en el DSN, PDO ignora el valor del argumento del nombre de usuario del constructor de PDO.

password

La contraseña del usuario para la conexión. Si se especifica la contraseña en el DSN, PDO ignora el valor del argumento de la contraseña del constructor de PDO.

Nota:

Los campos de tipo bytea son devueltos como flujos.

Ejemplos

Ejemplo #1 Ejemplos de DSN de PDO_PGSQL

El siguiente ejemplo muestra un DSN de PDO_PGSQL para conectarse a una base de datos PostgreSQL:

pgsql:host=localhost;port=5432;dbname=testdb;user=bruce;password=mypass


Copiar datos de un array de PHP a una tabla

  • « PDO_PGSQL DSN
  • PDO::pgsqlCopyFromFile »
  • PHP Manual
  • PostgreSQL (PDO)
  • Copiar datos de un array de PHP a una tabla

PDO::pgsqlCopyFromArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromArray — Copiar datos de un array de PHP a una tabla

Descripción

public PDO::pgsqlCopyFromArray ( string $table_name , array $rows , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copia los datos del array rows a la tabla table_name empleando delimiter como delimitador de campos y la lista de campos fields

Parámetros

table_name

Una cadena que contiene el nombre de la tabla

rows

Un array de cadenas con los campos separados por delimiter

delimiter

El delimitador empleado en el array rows

null_as

Cómo interpretar valores nulos

fields

El listado de campos a insertar

Valores devueltos

Devuelve true en caso de éxito, o false en caso de error.


Copiar datos de un fichero a una tabla

  • « PDO::pgsqlCopyFromArray
  • PDO::pgsqlCopyToArray »
  • PHP Manual
  • PostgreSQL (PDO)
  • Copiar datos de un fichero a una tabla

PDO::pgsqlCopyFromFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromFile — Copiar datos de un fichero a una tabla

Descripción

public PDO::pgsqlCopyFromFile ( string $table_name , string $filename , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copia los datos del fichero especificado por filename a la tabla table_name empleando delimiter como delimitador de campos y la lista de campos fields

Parámetros

table_name

Una cadena que contiene el nombre de la tabla

filename

El nombre del fichero que contiene los datos a importar

delimiter

El delimitador empleado en el fichero especificado por filename

null_as

Cómo interpretar valores nulos

fields

El listado de campos a insertar

Valores devueltos

Devuelve true en caso de éxito, o false en caso de error.


Copiar datos de una tabla de una base de datos a un array de PHP

  • « PDO::pgsqlCopyFromFile
  • PDO::pgsqlCopyToFile »
  • PHP Manual
  • PostgreSQL (PDO)
  • Copiar datos de una tabla de una base de datos a un array de PHP

PDO::pgsqlCopyToArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToArray — Copiar datos de una tabla de una base de datos a un array de PHP

Descripción

public PDO::pgsqlCopyToArray ( string $table_name , array $rows , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : array

Copia los datos de la tabla dada por table a un array empleando delimiter como delimitador de campos y la lista de campos fields

Parámetros

table_name

Una cadena que contiene el nombre de la tabla

delimiter

El delimitador empleado en el array rows

null_as

Cómo interpretar valores nulos

fields

El listado de campos a exportar

Valores devueltos

Devuelve un array de filas o false en caso de error.


Copiar datos desde una tabla a un fichero

  • « PDO::pgsqlCopyToArray
  • PDO::pgsqlGetNotify »
  • PHP Manual
  • PostgreSQL (PDO)
  • Copiar datos desde una tabla a un fichero

PDO::pgsqlCopyToFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToFile — Copiar datos desde una tabla a un fichero

Descripción

public PDO::pgsqlCopyToFile ( string $table_name , string $filename , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copia los datos desde la tabla al fichero especificado por filename empleando delimiter como delimitador de campos y la lista de campos fields

Parámetros

table_name

Una cadena que contiene el nombre de la tabla

filename

El nombre del fichero donde exportar los datos

delimiter

El delimitador empleado en el fichero especificado por filename

null_as

Cómo interpretar valores nulos

fields

El listado de campos a insertar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener una notificación asíncrona

  • « PDO::pgsqlCopyToFile
  • PDO::pgsqlGetPid »
  • PHP Manual
  • PostgreSQL (PDO)
  • Obtener una notificación asíncrona

PDO::pgsqlGetNotify

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetNotify — Obtener una notificación asíncrona

Descripción

public PDO::pgsqlGetNotify ( int $result_type = PDO::FETCH_USE_DEFAULT , int $ms_timeout = 0 ) : array

Devuelve un conjunto de resultados que representa una notificación asíncrona pendiente.

Parámetros

result_type

El formato del conjunto de resultados debería ser devueto representando una constante PDO::FETCH_*.

ms_timeout

La duración del tiempo de espera de una respuesta, en milisegundos.

Valores devueltos

Si hay una o más notificaciones pendientes, devuelve una única fila con los campos message y pid; de lo contrario devuelve false.


Obtener el PID del servidor

  • « PDO::pgsqlGetNotify
  • PDO::pgsqlLOBCreate »
  • PHP Manual
  • PostgreSQL (PDO)
  • Obtener el PID del servidor

PDO::pgsqlGetPid

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetPid — Obtener el PID del servidor

Descripción

public PDO::pgsqlGetPid ( ) : int

Devuelve el PID del servidor.

Valores devueltos

El PID del servidor.


Crear un nuevo objeto grande

  • « PDO::pgsqlGetPid
  • PDO::pgsqlLOBOpen »
  • PHP Manual
  • PostgreSQL (PDO)
  • Crear un nuevo objeto grande

PDO::pgsqlLOBCreate

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBCreate — Crear un nuevo objeto grande

Descripción

public PDO::pgsqlLOBCreate ( ) : string

PDO::pgsqlLOBCreate() crea un objeto grande y devuelve el OID del mismo. Se podrá entonces abrir un flujo sobre el objeto usando PDO::pgsqlLOBOpen() para leer o escribir datos en él. El OID se puede almacenar en columnas de tipo OID y se puede usar para hacer referencia al objeto grande, sin causar que la fila se vuelva arbitrariamente grande. El objeto grande continuará estando en la base de datos hasta que sea eliminado mediante una llamada a PDO::pgsqlLOBUnlink().

Los objetos grandes pueden tener un tamaño de hasta 2GB, pero son incómodos de usar; es necesario asegurarse de que se invoca a PDO::pgsqlLOBUnlink() antes de borrar la última fila que hacía referencia a su OID desde la base de datos. Además, los objetos grandes no tienen controles de acceso. Como alternativa, se ha de intentar con el tipo de columna BYTEA; las versiones recientes de PostgreSQL permiten un tamaño para las columnas BYTEA de hasta 1GB y administran de forma transparente el almacenamiento para un tamaño de fila óptimo.

Nota: Esta función debe ser llamada dentro de una transacción.

Parámetros

PDO::pgsqlLOBCreate() no tiene parámetros.

Valores devueltos

Devuelve el OID del objeto grande recién creado en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PDO::pgsqlLOBCreate()

Este ejemplo crea un nuevo objeto grande y copia el contenido de un fichero en él. El OID es entonces almacenado en una tabla.

<?php
$bd = new PDO('pgsql:dbname=test host=localhost', $usuario, $contraseña);
$bd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$bd->beginTransaction();
$oid = $bd->pgsqlLOBCreate();
$flujo = $bd->pgsqlLOBOpen($oid, 'w');
$local = fopen($filename, 'rb');
stream_copy_to_stream($local, $flujo);
$local = null;
$flujo = null;
$sentencia = $bd->prepare("INSERT INTO BLOBS (ident, oid) VALUES (?, ?)");
$sentencia->execute(array($algún_id, $oid));
$bd->commit();
?>

Ver también

  • PDO::pgsqlLOBOpen() - Abrir un flujo de un objeto grande existente
  • PDO::pgsqlLOBUnlink() - Eliminar un objeto grande
  • pg_lo_create() - Create a large object


Abrir un flujo de un objeto grande existente

  • « PDO::pgsqlLOBCreate
  • PDO::pgsqlLOBUnlink »
  • PHP Manual
  • PostgreSQL (PDO)
  • Abrir un flujo de un objeto grande existente

PDO::pgsqlLOBOpen

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBOpen — Abrir un flujo de un objeto grande existente

Descripción

public PDO::pgsqlLOBOpen ( string $oid , string $mode = "rb" ) : resource

PDO::pgsqlLOBOpen() abre un flujo para acceder a los datos a los que hace referencia oid. Si mode es r, el flujo será abierto para lectura; si mode es w, el flujo será abierto para escritura. Se pueden utilizar todas las funciones de sistema de ficheros usuales, tales como fread(), fwrite() y fgets() para manipular el contenido del flujo.

Nota: Esta función, y todas las manipulaciones del objeto grande, debe ser invocada y realizada dentro de una transacción.

Parámetros

oid

Un identificador de objeto grande.

mode

Si el modo es r, se abre el flujo para lectura. Si el modo es w, se abre el flujo para escritura.

Valores devueltos

Devuelve un recurso de flujo en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PDO::pgsqlLOBOpen()

Siguiendo el ejemplo de PDO::pgsqlLOBCreate(), este trozo de código recupera el objeto grande de la base de datos y lo envía al navegador.

<?php
$bd = new PDO('pgsql:dbname=test host=localhost', $usuario, $contraseña);
$bd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$bd->beginTransaction();
$sentencia = $bd->prepare("select oid from BLOBS where ident = ?");
$sentencia->execute(array($some_id));
$sentencia->bindColumn('oid', $oid, PDO::PARAM_STR);
$sentencia->fetch(PDO::FETCH_BOUND);
$flujo = $bd->pgsqlLOBOpen($oid, 'r');
header("Content-type: application/octet-stream");
fpassthru($flujo);
?>

Ver también

  • PDO::pgsqlLOBCreate() - Crear un nuevo objeto grande
  • PDO::pgsqlLOBUnlink() - Eliminar un objeto grande
  • pg_lo_open() - Open a large object


Eliminar un objeto grande

  • « PDO::pgsqlLOBOpen
  • SQLite (PDO) »
  • PHP Manual
  • PostgreSQL (PDO)
  • Eliminar un objeto grande

PDO::pgsqlLOBUnlink

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBUnlink — Eliminar un objeto grande

Descripción

public PDO::pgsqlLOBUnlink ( string $oid ) : bool

Elimina un objeto grande de la base de datos identificado por OID.

Nota: Esta función debe invocarse dentro de una transacción.

Parámetros

oid

Un identificador de objeto grande.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de PDO::pgsqlLOBUnlink()

Este ejemplo desvincula un objeto grande de la base de datos antes de eliminar la fila que hace referencia a él desde la tabla de blobs que se ha utilizado en los ejemplos de PDO::pgsqlLOBCreate() y PDO::pgsqlLOBOpen().

<?php
$bd = new PDO('pgsql:dbname=test host=localhost', $usuario, $contraseña);
$bd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$bd->beginTransaction();
$bd->pgsqlLOBUnlink($oid);
$sentencia = $bd->prepare("DELETE FROM BLOBS where ident = ?");
$sentencia->execute(array($some_id));
$bd->commit();
?>

Ver también

  • PDO::pgsqlLOBOpen() - Abrir un flujo de un objeto grande existente
  • PDO::pgsqlLOBCreate() - Crear un nuevo objeto grande


Funciones de SQLite (PDO_SQLITE)

Introducción

PDO_SQLITE es un controlador que implementa la interfaz Objetos de Datos de PHP (PDO, siglas en inglés de PHP Data Objects) para habilitar el acceso a bases de datos de SQLite 3.

Nota:

PDO_SQLITE permite usar cadenas aparte de flujos junto con PDO::PARAM_LOB.

Instalación

El controlador PDO_SQLITE PDO está habilitado por omisión. Para deshabilitarlo, se puede usar --without-pdo-sqlite[=DIR], donde el parámetro opcional [=DIR] es el directorio base de instalación de sqlite. A partir de PHP 7.4.0 se requiere » libsqlite = 3.5.0. Anteriormente, si libsqlite incluido podría haberse usado en su lugar, por omisión, si [=DIR] era omitido.

Tabla de contenidos

  • PDO_SQLITE DSN — Conectar a las bases de datos de SQLite
  • PDO::sqliteCreateAggregate — Registra una función acumuladora definida por el usuario para usarla en sentencias SQL
  • PDO::sqliteCreateCollation — Registra una función definida por el usuario para emplearla como función de cotejo en sentencias SQL
  • PDO::sqliteCreateFunction — Registra una función definida por el usuario para utilizarla en sentencias SQL


Conectar a las bases de datos de SQLite

  • « SQLite (PDO)
  • PDO::sqliteCreateAggregate »
  • PHP Manual
  • SQLite (PDO)
  • Conectar a las bases de datos de SQLite

PDO_SQLITE DSN

(PHP 5 >= 5.1.0, PHP 7, PECL PDO_SQLITE >= 0.2.0)

PDO_SQLITE DSN — Conectar a las bases de datos de SQLite

Descripción

El Nombre de la Fuente de Datos de PDO_SQLITE (DSN, siglas en inglés de Data Source Name) está compuesto de los siguientes elementos:

Prefijo DSN (SQLite 3)

El prefijo DSN es sqlite:.

  • Para acceder a una base de datos almacenada en disco, se añade al final del prefijo la ruta absoluta.

  • Para crear una base de datos almacenada en memoria, se añade al final del prefijo :memory:.

  • Si el DSN consta únicamente del prefijo DSN, se utiliza una base de datos temporal, que se elimina cuando se cierra la conexión.

Ejemplos

Ejemplo #1 Ejemplos de PDO_SQLITE DSN

Los siguientes ejemplos muestran el uso de PDO_SQLITE DSN para conectarse a bases de datos de SQLite:

sqlite:/opt/databases/midb.sq3
sqlite::memory:
sqlite2:/opt/databases/midb.sq2
sqlite2::memory:


Registra una función acumuladora definida por el usuario para usarla en sentencias SQL

  • « PDO_SQLITE DSN
  • PDO::sqliteCreateCollation »
  • PHP Manual
  • SQLite (PDO)
  • Registra una función acumuladora definida por el usuario para usarla en sentencias SQL

PDO::sqliteCreateAggregate

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateAggregate — Registra una función acumuladora definida por el usuario para usarla en sentencias SQL

Descripción

public PDO::sqliteCreateAggregate ( string $function_name , callable $step_func , callable $finalize_func , int $num_args = ? ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Estemétodo es similar a PDO::sqliteCreateFunction, excepto que registra funciones que pueden ser usadas para calcular un resultado acumulado a través de todas las filas de una consulta.

La diferencia clave entre este método y PDO::sqliteCreateFunction es que son necesarias dos funciones para administrar la acumulación.

Parámetros

function_name

El nombre de la función usado en las sentencias SQL.

step_func

Una función de llamada de retorno para cada fila del conjunto de resultados. La función de PHP debería acumular el resultado y almacenarlo en el contexto de la acumulación.

Esta función necesita ser definida como:

step ( mixed $context , int $rownumber , mixed $value1 , mixed $value2 = ? , mixed $.. = ? ) : mixed

context será null para la primera fila; en filas subsiguientes tendrá el valor que fue devuelto anteriormente desde la función 'step'; se debería usar esto para mantener el estado de la acumulación.

rownumber contendrá el número de fila actual.

El valor devuelto por esta función se empleará como el argumento para context en la siguiente llamada del "step" o funciones finalizadorasf.

finalize_func

Función de llamada de retorno para acumular los datos usados en "step" desde cada fila. Una vez que todas las fila han sido procesadasOnce, se invocará a esta función y debería tomar los datos del contexto de la acumulación y devolver el resultado. Las funciones de llamada de retorno deberían devolver un tipo comprendido por SQLite (esto es, del tipo escalar).

Esta función necesita ser definida como:

fini ( mixed $context , int $rownumber ) : mixed

context contendrá el valor de retorno de cada última llamada a la función 'step'.

rownumber contendrá el número de filas sobre las que se realiza la acumulación.

El valor devuelto por esta función será utilizado como valor de retorno de la acumulación.

num_args

Una sugerencia para el analizador de SQLite si la función de llamada de retorno acepta un número predeterminado de argumentos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de función acumuladora max_length

<?php
$datos = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$bd = new PDO('sqlite::memory:');
$bd->exec("CREATE TABLE strings(a)");
$insert = $bd->prepare('INSERT INTO strings VALUES (?)');
foreach ($datos as $str) {
    $insert->execute(array($str));
}
$insert = null;

function max_len_step(&$context, $rownumber, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
    return $context;
}

function max_len_finalize(&$context, $rownumber)
{
    return $context;
}

$bd->sqliteCreateAggregate('max_len', 'max_len_step', 'max_len_finalize');

var_dump($bd->query('SELECT max_len(a) from strings')->fetchAll());

?>

En este ejemplo, se crea una función acumuladora que calculará la longitud de la cadena más larga de las columnas de la tabla. Para cada fila, la función max_len_step se invoca y se le pasa un parámetro context. El parámetro 'context' es como otra variables cualquiera de PHP y se establece para contener un array o incluso un valor de un objeto. En este ejemplo, se usa simplemente para que contenga la longitud máxima que se ha visto hasta aquí; si string tiene una longitud mayor que el máximo actual, se actualiza el contexto para que contenga esta nueva longitud máxima.

Después de haber procesado todas las filas, SQLite llama a la función max_len_finalize para determinar el resultado acumulado. Aquí, se podría realizar algún tipo de cálcula basado en los datos encontrados en context; aunque, en este sencillo ejemplo se ha calculado el resultado mientras la consulta progresaba, necesitando así devolver simplemente el valor de 'context'.

Sugerencia

NO se recomienda almacenar una copia de los valores de 'context' y luego procesarlos al final, ya que causariá que SQLite utilizara mucha memoria para procesar la consulta; piense simplemente cúanta memoria sería necesaria si estuvieran almacenadas en ella un millón de filas, cada una conteniendo una cadena de 32 bytes de longitud.

Sugerencia

Se puede usar PDO::sqliteCreateFunction y PDO::sqliteCreateAggregate para invalidar funciones SQL nativas de SQLite.

Nota:

Este método no está disponible con el controlador SQLite2. Use la API de sqlite de estilo antiguo en su lugar.

Ver también

  • PDO::sqliteCreateFunction
  • sqlite_create_function()
  • sqlite_create_aggregate()


Registra una función definida por el usuario para emplearla como función de cotejo en sentencias SQL

  • « PDO::sqliteCreateAggregate
  • PDO::sqliteCreateFunction »
  • PHP Manual
  • SQLite (PDO)
  • Registra una función definida por el usuario para emplearla como función de cotejo en sentencias SQL

PDO::sqliteCreateCollation

(PHP 5 >= 5.3.11, PHP 7)

PDO::sqliteCreateCollation — Registra una función definida por el usuario para emplearla como función de cotejo en sentencias SQL

Descripción

public PDO::sqliteCreateCollation ( string $name , callable $callback ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

name

Nombre de la función de cotejo de SQL a crear o redefinir.

callback

El nombre de una función de PHP o una definida por el usuario para aplicarla como retrollamada, definiendo el comportamiento del cotejamiento. Debería aceptar dos cadenas y devolver lo mismo que strcmp(), es decir, debería devolver -1, 1, o 0 si la primera cadena es anterior en orden, posterior, o es igual a la segunda.

Es necesario definir esta función como:

collation ( string $string1 , string $string2 ) : int

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de PDO::sqliteCreateCollation()

<?php
$bd = new PDO('sqlite::memory:');
$bd->exec("CREATE TABLE test (col1 string)");
$bd->exec("INSERT INTO test VALUES ('a1')");
$bd->exec("INSERT INTO test VALUES ('a10')");
$bd->exec("INSERT INTO test VALUES ('a2')");

$bd->sqliteCreateCollation('NATURAL_CMP', 'strnatcmp');
foreach ($bd->query("SELECT col1 FROM test ORDER BY col1") as $fila) {
  echo $fila['col1'] . "\n";
}
echo "\n";
foreach ($bd->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP") as $fila) {
  echo $fila['col1'] . "\n";
}
?>

El resultado del ejemplo sería:

a1
a10
a2

a1
a2
a10

Notas

Nota:

Este método no está disponible con el controlador de SQLite2. Use la API de sqlite del estilo antiguo en su lugar.


Registra una función definida por el usuario para utilizarla en sentencias SQL

  • « PDO::sqliteCreateCollation
  • Extensiones de bases de datos específicas del proveedor »
  • PHP Manual
  • SQLite (PDO)
  • Registra una función definida por el usuario para utilizarla en sentencias SQL

PDO::sqliteCreateFunction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateFunction — Registra una función definida por el usuario para utilizarla en sentencias SQL

Descripción

public PDO::sqliteCreateFunction ( string $function_name , callable $callback , int $num_args = ? ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Este método permite registrar una función de PHP con SQLite como una FDU (Función Definida por el Usuario), y así poder invocarla desde dentro de sentencias SQL.

LA FDU se puede usar en cualquier sentencia SQL que pueda invocar funciones, tales como SELECT y UPDATE, y también en disparadores.

Parámetros

function_name

El nombre de la función usada en sentencias SQL.

callback

Una función de llamada de retorno para manejar la función SQL definida.

Nota: Las funciones de llamada de retorno deberían devolver un tipo comprendido por SQLite (esto es, del tipo escalar).

num_args

Una sugerencia para el analizador de SQLite si la función de llamada de retorno acepta un número predeterminado de argumentos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de PDO::sqliteCreateFunction()

<?php
function md5_e_invertir($string)
{
    return strrev(md5($string));
}

$bd = new PDO('sqlite:sqlitedb');
$bd->sqliteCreateFunction('md5rev', 'md5_e_invertir', 1);
$filas = $bd->query('SELECT md5rev(filename) FROM files')->fetchAll();
?>

En este ejemplo, se tiene una función que calcula la suma md5 de una cadena, y luego la inverte. Cuando se ejecuta la sentencia SQL, devuelve el valor del nombre del fichero transformado por dicha función. Los datos devueltos en $filas contienen el resultado procesado.

La belleza de esta técnica consiste en que no se necesario procesar el resultado usando un bucle foreach después de haber consultado los datos.

Sugerencia

Se puede usar PDO::sqliteCreateFunction y PDO::sqliteCreateAggregate para invalidar funciones SQL nativas de SQLite.

Nota:

Este método no está disponible con el controlador SQLite2. Use la API de sqlite de estilo antiguo en su lugar.

Ver también

  • PDO::sqliteCreateAggregate
  • sqlite_create_function()
  • sqlite_create_aggregate()


Extensiones de bases de datos específicas del proveedor

  • CUBRID
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de CUBRID
    • Funciones de compatibilidad CUBRID MySQL
    • Alias y Funciones Obsoletas de CUBRID
  • DB++
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de DB++
  • dBase
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de dBase
  • filePro
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de filePro
  • Firebird/InterBase
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Firebird/InterBase
  • FrontBase
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de FrontBase
  • IBM DB2 — IBM DB2, Cloudscape y Apache Derby
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de IBM DB2
  • Ingres — Ingres DBMS, EDBC, y Enterprise Access Gateways
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Ingres
  • Mongo — Controlador de MongoDB (antiguo)
    • Instalación/Configuración
    • Constantes predefinidas
    • Manual
    • Clases del núcleo
    • Tipos
    • Clases de GridFS
    • Clases de procesamiento por lotes
    • Miscelánea
    • Funciones de Mongo
    • Excepciones
    • Registro de cambios
  • MongoDB — Controlador de MongoDB
    • Instalación/Configuración
    • Tutoriales
    • Arquitectura del controlador y sus entresijos — Explicación de la arquitectura del controlador y de características especiales
    • Security
    • MongoDB\Controlador — Clases del controlador de MongoDB
    • MongoDB\BSON — Clases de tipo BSON y funciones de serialización
    • MongoDB\Controlador\Excepciones — Clases de excepcines
  • MySQL — Controladores y complementos de MySQL
    • Información general de los controladores de MySQL para PHP
    • MySQLi — Extensión MySQL mejorada
    • MySQL (Original) — API original de MySQL
    • Mysqlnd — Controlador Nativo de MySQL
    • mysqlnd_ms — Complemento de equilibrado de carga y replicación de mysqlnd
    • mysqlnd_qc — Complemento de caché de resultados de consultas de mysqlnd
    • mysqlnd_uh — Complemento de gestión del usuario de mysqlnd
    • mysqlnd_mux — Complemento de multiplexación de conexiones de mysqlnd
    • mysqlnd_memcache — Complemento de Memcache de Mysqlnd
  • OCI8 — Oracle OCI8
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Manejo de conexiones de OCI8 y agrupamiento de conexiones
    • OCI8 Fast Application Notification (FAN) Support
    • Soporte para 'Transparent Application Failover' (TAF) de OCI8
    • OCI8 y rastreo dinámico de DTrace
    • Tipos de datos admitidos
    • Funciones de OCI8
    • OCI-Collection — La clase OCI-Collection
    • OCI-Lob — La clase OCI-Lob
    • Funciones y alias de OCI8 obsoletos
  • Paradox — Acceso a archivos Paradox
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Paradox
  • PostgreSQL
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de PostgreSQL
  • SQLite3
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • SQLite3 — La clase de SQLite3
    • SQLite3Stmt — La clase SQLite3Stmt
    • SQLite3Result — La clase SQLite3Result
  • SQLSRV — Driver de Microsoft SQL Server para PHP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • SQLSRV Funciones
  • tokyo_tyrant
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantException — The TokyoTyrantException class


CUBRID

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de CUBRID
    • cubrid_bind — Vincular variables para una sentencia preparada como parámetros
    • cubrid_close_prepare — Cerrar el gestor de solicitud
    • cubrid_close_request — Cerrar el gestor de solicitud
    • cubrid_col_get — Obtener el contenido de la columna del tipo de colecctión usando OID
    • cubrid_col_size — Obtener el número de elementos de la columna del tipo de colección usando OID
    • cubrid_column_names — Obtener los nombres de las columnas del resultado
    • cubrid_column_types — Obtener los tipos de columnas del resultado
    • cubrid_commit — Consigna una transacción
    • cubrid_connect_with_url — Establecer el entorno para la conexión al servidor de CUBRID
    • cubrid_connect — Abrir una conexión al servidor CUBRID
    • cubrid_current_oid — Obtener el OID de la posición del cursor actual
    • cubrid_disconnect — Cerrar una conexión a una base de datos
    • cubrid_drop — Borrar una instancia usando OID
    • cubrid_error_code_facility — Obtener el código de error del dispositivo
    • cubrid_error_code — Obtener el código de error de la llamada a una función más reciente
    • cubrid_error_msg — Obtener el último mensaje de error de la llamada a la función más reciente
    • cubrid_execute — Ejecutar una sentencia SQL preparada
    • cubrid_fetch — Obtener la siguiente fila de un conjunto de resultados
    • cubrid_free_result — Liberar la memoria ocupada por los datos del resultado
    • cubrid_get_autocommit — Devuelve el modo auto-commit de la conexión
    • cubrid_get_charset — Devolver el conjunto de caracteres de la conexión CUBRID actual
    • cubrid_get_class_name — Obtener el nombre de la clase usando OID
    • cubrid_get_client_info — Devolver la versión de la biblioteca cliente
    • cubrid_get_db_parameter — Devuelve los parámetros de la base de datos CUBRID
    • cubrid_get_query_timeout — Obtener el valor del tiempo de espera de consulta de la petición
    • cubrid_get_server_info — Devolver la versión del servidor CUBRID
    • cubrid_get — Obtener una columna usando OID
    • cubrid_insert_id — Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT
    • cubrid_is_instance — Comprobar si existe la instancia apuntada por OID
    • cubrid_lob_close — Cerrar información BLOB/CLOB
    • cubrid_lob_export — Exportar datos BLOB/CLOB a un fichero
    • cubrid_lob_get — Obtener información BLOB/CLOB
    • cubrid_lob_send — Leer información BLOB/CLOB y enviarla directamente al navegador
    • cubrid_lob_size — Obtener el tamaño de datos BLOB/CLOB
    • cubrid_lob2_bind — Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros
    • cubrid_lob2_close — Cierra un objeto LOB
    • cubrid_lob2_export — Exporta un objeto LOB a un fichero
    • cubrid_lob2_import — Importa datos BLOB/CLOB desde un fichero
    • cubrid_lob2_new — Crea un objeto LOB
    • cubrid_lob2_read — Lee desde datos BLOB/CLOB
    • cubrid_lob2_seek64 — Mover el cursor de un objeto LOB
    • cubrid_lob2_seek — Mover el cursor de un objeto LOB
    • cubrid_lob2_size64 — Obtiene el tamaño de un objeto LOB
    • cubrid_lob2_size — Obtiene el tamaño de un objeto LOB
    • cubrid_lob2_tell64 — Indica la posición del cursor de un objeto LOB
    • cubrid_lob2_tell — Indica la posición del cursor de un objeto LOB
    • cubrid_lob2_write — Escribe en un objeto LOB
    • cubrid_lock_read — Establecer un bloqueo de lectura sobre el OID dado
    • cubrid_lock_write — Establecer un bloqueo de escritura para el OID dado
    • cubrid_move_cursor — Mover el cursor en el resultado
    • cubrid_next_result — Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL
    • cubrid_num_cols — Devolver el número de columnas del conjunto de resultados
    • cubrid_num_rows — Obtener el número de filas del conjunto de resultados
    • cubrid_pconnect_with_url — Abrir una conexión persistente al servidor CUBRID
    • cubrid_pconnect — Abrir una conexión persistente a un servidor CUBRID
    • cubrid_prepare — Preparar una sentencia SQL para su ejecución
    • cubrid_put — Actualizar un atributo usando OID
    • cubrid_rollback — Retroceder una transacción
    • cubrid_schema — Obtener la información del esquema solicitado
    • cubrid_seq_drop — Borrar un elemento de una columna tipo secuencia usando OID
    • cubrid_seq_insert — Insertar un elemento en una columna tipo secuencia usando OID
    • cubrid_seq_put — Actualizar el valor del elemento de la columna de tipo secuencia usando OID
    • cubrid_set_add — Insertar un único elemento en la columna del tipo de conjunto usando OID
    • cubrid_set_autocommit — Establece el modo de confirmación automática de la conexión
    • cubrid_set_db_parameter — Configura los parámetros de la base de datos CUBRID
    • cubrid_set_drop — Borrar un elemento de la columna del tipo de conjunto usando OID
    • cubrid_set_query_timeout — Establecer el tiempo de espera de la ejecución de consultas
    • cubrid_version — Obtener la versión del módulo de PHP de CUBRID
  • Funciones de compatibilidad CUBRID MySQL
    • cubrid_affected_rows — Devolver el número de filas afectadas por la última sentencia SQL
    • cubrid_client_encoding — Devuelve el actual conjunto de caracteres de la conexión a CUBRID
    • cubrid_close — Cerrar la conexión de CUBRID
    • cubrid_data_seek — Mueve el puntero interno de la fila del resultado CUBRID
    • cubrid_db_name — Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs
    • cubrid_errno — Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa
    • cubrid_error — Se usa para obtener el mensaje de error
    • cubrid_fetch_array — Extrae una fila como array asociativo, numérico o ambos
    • cubrid_fetch_assoc — Devuelve un array asociativo que se corresponde con la fila obtenida
    • cubrid_fetch_field — Devuelve un objeto con ciertas propiedades
    • cubrid_fetch_lengths — Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual
    • cubrid_fetch_object — Devuelve un objeto con los nombres de las columnas
    • cubrid_fetch_row — Devuelve un array numérico con los valores de la fila actual
    • cubrid_field_flags — Devuelve una cadena con las banderas del índice del campo dado
    • cubrid_field_len — Devuelve la longitud máxima del campo especificado
    • cubrid_field_name — Devuelve el nombre del índice del campo especificado
    • cubrid_field_seek — Mueve el cursor del conjunto de resultados al índece del campo especificado
    • cubrid_field_table — Devuelve el nombre de la tabla del campo especificado
    • cubrid_field_type — Devuelve el tipo de columna que se corresponde con el índice del campo dado
    • cubrid_list_dbs — Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes
    • cubrid_num_fields — Devuelve el número de columnas del conjunto de resultados
    • cubrid_ping — Hacer ping en una conexión al servidor o reconectar si no hay conexión
    • cubrid_query — Enviar una consulta CUBRID
    • cubrid_real_escape_string — Escapar caracteres especiales en una cadena para usarla en una sentencia SQL
    • cubrid_result — Devuelve el valor de un campo específico de una fila específica
    • cubrid_unbuffered_query — Realiza una consulta sin traer los resultados a memoria
  • Alias y Funciones Obsoletas de CUBRID
    • cubrid_load_from_glo — Leer información de una instancia GLO y guardarla en un fichero
    • cubrid_new_glo — Crear una instancia glo
    • cubrid_save_to_glo — Guardar el fichero solicitado en una instancia GLO
    • cubrid_send_glo — Leer información de un glo y enviarla a la salida estándar


Introducción

Estas funciones permiten acceder a servidores de bases de datos CUBRID. Se puede encontrar más información sobre CUBRID en » CUBRID.

La documentación de CUBRID se puede encontrar en » Documentación de CUBRID.


Requerimientos

Para que estas funciones estén disponibles, se debe instalar CUBRID, y compilar la Biblioteca de PHP de CUBRID con soporte para CUBRID.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/cubrid.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .

Para obtener información sobre la instalación manual en Linux y en Windows, por favor, lea el fichero build-guide.html incluido en el paquete.


  • « Instalación
  • Tipos de recursos »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

No existe configuración en tiempo de ejecución.


Tipos de recursos

En CUBRID se usan cuatro tipos de recursos. El primero es un identificador de enlace para una conexión de base de datos, el segundo es un recurso que guarda el resultado de una consulta, y los dos últimos son recursos que guardan los resultados de una consulta de tipos de datos BLOB/CLOB.

connection identifier

Un identificador de conexión devuelto por cubrid_connect(),
cubrid_connect_with_url(),
cubrid_pconnect() y
cubrid_pconnect_with_url().

request identifier

Un identificador de solicitud devuelto por cubrid_prepare() y cubrid_execute().

LOB identifier

Un identificador LOB devuelto por cubrid_lob_get().

LOB2 identifier

Un identificador LOB devuelto por cubrid_lob2_new() u obtenido de un conjunto de resultados.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las siguientes constantes se pueden usar al ejecutar una sentencia SQL. Pueden ser pasadas a cubrid_prepare() y a cubrid_execute().

Banderas de ejecución SQL de CUBRID
Constante | Descripción
CUBRID_INCLUDE_OID | Determinar si obtener el OID durante la ejecución de la consulta.
CUBRID_ASYNC | Ejecutar la consulta en modo asíncorno.
CUBRID_EXEC_QUERY_ALL | Ejecutar la consulta en modo síncrono. Esta bandera debe ser establecida cuando se ejecutan múltiples sentencias SQL.

Las siguientes constantes se pueden usar al traer los resultados para especificar el comportamiento de la obtención. Se pueden pasar a cubrid_fetch() y a cubrid_fetch_array().

Banderas de obtención de CUBRID
Constante | Descripción
CUBRID_NUM | Obtener el resultado de la consulta como un array numérico (0-predeterminado).
CUBRID_ASSOC | Obtener el resultado de la consulta como un array asociativo.
CUBRID_BOTH | Obtener el resultado de la consulta como arrays numérico y asociativo (valor predeterminado).
CUBRID_OBJECT | Obtener el resultado de la consulta como un objeto.
CUBRID_LOB | La constante CUBRID_LOB se puede usar al operar con objetos lob. Se puede pasar a cubrid_fetch(), cubrid_fetch_row(), cubrid_fetch_array(), cubrid_fetch_assoc() y cubrid_fetch_object().

Las siguientes constantes se pueden usar al posicionar el cursor en los resultados de la consulta. Pueden ser pasadas a, o devueltas por cubrid_move_cursor().

Banderas de posición del cursor de CUBRID
Constante | Descripción
CUBRID_CURSOR_FIRST | Mover el cursor actual a la primera posición del resultado.
CUBRID_CURSOR_CURRENT | Mover el cursor actual como valor por defecto si no se especifica el origen.
CUBRID_CURSOR_LAST | Mover el cursor actual a la última posición del resultado.
CUBRID_CURSOR_SUCCESS | Valor devuelto de la función cubrid_move_cursor() en caso de éxito. Esta bandera ha sido eliminada desde 8.4.1
CUBRID_NO_MORE_DATA | Valor devuelto de la función cubrid_move_cursor() en caso de fallo. Esta bandera ha sido eliminada desde 8.4.1
CUBRID_CURSOR_ERROR | Valor devuelto de la función cubrid_move_cursor() en caso de fallo. Esta bandera ha sido eliminada desde 8.4.1

Las siguientes constantes se pueden usar cuando se establece el modo auto-commit para la conexión a la base de datos. Pueden ser pasada a cubrid_set_autocommit() o devuelta por cubrid_get_autocommit().

Banderas del modo auto-commit de CUBRID
Constante | Descripción
CUBRID_AUTOCOMMIT_TRUE | Habilitar el modo auto-commit.
CUBRID_AUTOCOMMIT_FALSE | Deshabilitar el modo auto-commit.

Las siguientes constantes se pueden usar al establecer el parámetro de la base de datos. Se pueden pasar a cubrid_set_db_parameter().

Banderas de parámetro de CUBRID
Constante | Descripción
CUBRID_PARAM_ISOLATION_LEVEL | Nivel de aislamiento de las transacciones para la conexión de la base de datos.
CUBRID_PARAM_LOCK_TIMEOUT | Tiempo de espera de las transacciones en segundos.

Las siguientes constantes se pueden usar al establecer el nivel de aislamiento de la transacción. Se pueden pasar a cubrid_set_db_parameter() o ser devueltas por cubrid_get_db_parameter().

Banderas de nivel de aislamiento de CUBRID
Constante | Descripción
TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | El nivel de aislamiento más bajo (1). Puede ocurrir una lectura sucia, no repetible o fantasma para la tupla y puede ocurrir también una lectura no repetible para la tabla.
TRAN_COMMIT_CLASS_COMMIT_INSTANCE | Un nivel relativamente bajo de aislamiento (2). No ocurre una lectura sucia, pero puede ocurrir una lectura no repetible o fantasma.
TRAN_REP_CLASS_UNCOMMIT_INSTANCE | El nivel predeterminado de aislamiento de CUBRID (3). Puede ocurrir una lectura sucia, no repetible o fantasma para la tupla, pero se garantiza una lectura repetible para la tabla.
TRAN_REP_CLASS_COMMIT_INSTANCE | Un nivel relativamente bajo de aislamiento (4). No puede ocurrir una lectura sucia, pero sí una lectura no repetible o fantasma.
TRAN_REP_CLASS_REP_INSTANCE | Un nivel de aislamiento relativamente alto (5). No ocurre una lectura sucia o no repetible, pero sí puede ocurrir una lectura fantasma.
TRAN_SERIALIZABLE | El nivel de aislamiento más alto (6). No ocurren los problemas concernientes a la concurrencia (p.ej. lectura sucia, no repetible, fantasma, etc.).

Las siguientes constantes se pueden usar al obtener la información del esquema. Se pueden pasar a cubrid_schema().

Banderas de esquema de CUBRID
Constante | Descripción
CUBRID_SCH_CLASS | Obtener el nombre y el tipo de tabla de CUBRID.
CUBRID_SCH_VCLASS | Obtener el nombre y el tipo de vista de CUBRID.
CUBRID_SCH_QUERY_SPEC | Obtener la definición de la consulta de la vista.
CUBRID_SCH_ATTRIBUTE | Obtener los atributos de la columna tabla.
CUBRID_SCH_CLASS_ATTRIBUTE | Obtener los atributos de la tabla.
CUBRID_SCH_METHOD | Obtener el método de instancia. El método de instancia es un método llamado por una instancia de una clase. Se usa más a menudo que el método de la clase ya que se ejecutan más operaciones en la instancia.
CUBRID_SCH_CLASS_METHOD | Obtener el método de la clase. El método de la clase es un método llamado por un objeto de clase. Se usar normalmente para crear una nueva instnacia de clase o para inicializarla. También se usa para acceder o actualizar los atributos de la clase.
CUBRID_SCH_METHOD_FILE | Obtener la información del fichero donde el método de la tabla está definido.
CUBRID_SCH_SUPERCLASS | Obtener el nombre y el tipo de la tabla desde la que hereda atributos.
CUBRID_SCH_SUBCLASS | Obtener el nombre y el tipo de la tabla que hereda los atributos desde esta tabla.
CUBRID_SCH_CONSTRAINT | Obtener las restricciones de la tabla.
CUBRID_SCH_TRIGGER | Obtener los desencadenantes de la tabla.
CUBRID_SCH_CLASS_PRIVILEGE | Obtener la información de privilegios de la tabla.
CUBRID_SCH_ATTR_PRIVILEGE | Obtener la información de privilegios de la columna.
CUBRID_SCH_DIRECT_SUPER_CLASS | Obtener la super tabla directa de la tabla.
CUBRID_SCH_PRIMARY_KEY | Obtener la clave primaria de la tabla.
CUBRID_SCH_IMPORTED_KEYS | Obtener las claves importadas de la tabla.
CUBRID_SCH_EXPORTED_KEYS | Obtener las claves exportadas de la tabla.
CUBRID_SCH_CROSS_REFERENCE | Obtener la relación de referencia de las tablas a remolque.

Las siguientes constantes se pueden usar al informar de errores. Pueden ser devueltas desde cubrid_error_code_facility().

Código de facilidades de error de CUBRID
Constante | Descripción
CUBRID_FACILITY_DBMS | El error ocurrió en el dbms de CUBRID.
CUBRID_FACILITY_CAS | El error ocurrió en el agente cas de CUBRID.
CUBRID_FACILITY_CCI | El error ocurrió en el cci de CUBRID.
CUBRID_FACILITY_CLIENT | El error ocurrió en el cliente PHP de CUBRID.


Ejemplos

El siguiente es un ejemplo sencillo que establece una conexión entre PHP y CUBRID. Esta conexión cubrirá la características más básicas y significativas. El siguiente código requiere conectarse a una base de datos CUBRID, lo que significa que CUBRID Server (servidor) y CUBRID Broker (agente) tienen que estar ejecutándose.

El ejemplo de abajo usa la base de datos demodb de ejemplo. Por defecto se crea durante la instalación. Asegúrese de que ha sido creada.

Ejemplo #1 Ejemplo de Recuperación de Datos

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc-kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * Establecer la información para conexión de CUBRID. ip_host es la direccion
         * IP donde el Agente de CUBRID está instalado (localhost en este
         * ejemplo), y puerto_host es el número de puerto del Agecte de CUBRID.
         * El número de puerto es el predeterminado dado durante la instalación.
         * Para más detalles, véase "Guía del Administrador."
         */
        $ip_host = "localhost";
        $puerto_host = 33000;
        $nombre_bd = "demodb";
        /**
         * Conectar al Servidor CUBRID. No realiza la conexión,
         * sólo conserva la información de ésta. La razón de no realizar
         * la conexión actual es manejar la transacción de forma más eficaz
         * en la arquitectura de 3 capas.
         */
        $cubrid_con = @cubrid_connect($ip_host, $puerto_host, $nombre_bd);

        if (!$cubrid_con) {
            echo "Error de Conexión con la Base de Datos";
            exit;
        }
    ?>
    <?php
        $sql = "select sports, count(players) as players from event group by sports";
        /**
         * Solicitar al Servidor CUBRID los resultados de la declaración SQL.
         * Ahora se hace la conexión actual al Servidor CUBRID.
         */
        $resultado = cubrid_execute($cubrid_con, $sql);

        if ($resultado) {
            /**
             * Obtener el nombre de las columnas del conjunto de resultados creado por la consulta SQL.
             */
            $columnas = cubrid_column_names($resultado);
            /**
             * Obtener el número de columnas del conjunto de resultados creado por la consulta SQL.
             */
            $número_campos = cubrid_num_cols($resultado);
            /**
             * Listar los nombres de las columnas del conunto de resultados por la pantalla.
             */
            echo("<tr>");

            while (list($clave, $nomcol) = each($columnas)) {
                echo("<td align=center>$nomcol</td>");
            }

            echo("</tr>");

            /**
             * Obtener los resultados del conjunto de resultados.
             */
            while ($fila = cubrid_fetch($resultado)) {
                echo("<tr>");

                for ($i = 0; $i < $número_campos; $i++) {
                    echo("<td align=center>");
                    echo($fila[$i]);
                    echo("</td>");
                }

                echo("</tr>");
            }
        }
        /**
         * El módulo de PHP en CUBRID se ejecuta en una arquitectura de 3 capas. Incluso cuando
         * se llama a SELECT para el procesamiento de la transacción, es pasado como parte
         * de la transacción. Por lo tanto, la transacción necesita ser reiniciada
         * llamando a commit o incluso cuando se llamó a SELECT para un rendimiento
         * pulido.
         */
        cubrid_commit($cubrid_con);
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>

Ejemplo #2 Ejemplo de Inserción de Datos

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc- kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * ip_host es la dirección IP d donde está instalado el Agente de CUBRID
         * puerto_host es el número de puerto del Agente de CUBRID
         * nombre_bd es el nombre de la Base de Datos de CUBRID
         */
        $ip_host = "localhost";
        $puerto_host = 33000;
        $nombre_bd = "demodb";
        $cubrid_con = @cubrid_connect($ip_host, $puerto_host, $nombre_bd);

        if (!$cubrid_con) {
            echo "Error en la Conexión a la Base de Datos";
            exit;
        }
    ?>
    <?php
        $sql = "insert into olympic (host_year,host_nation,host_city,"
            . "opening_date,closing_date) values (2008, 'China', 'Beijing',"
            . "to_date('08-08-2008','mm-dd- yyyy'),to_date('08-24-2008','mm-dd-yyyy')) ;"
        $resultado = cubrid_execute($cubrid_con, $sql);
        if ($resultado) {
            /**
             * Manejado con éxito, por lo que se envía.
             */
            cubrid_commit($cubrid_con);
            echo("Insertado con éxito");
        } else {
            /**
             * Ocurrió un error, por lo que el mensaje de error se imprime y se llama a rollback.
             */
            echo(cubrid_error_msg());
            cubrid_rollback($cubrid_con);
        }
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>


Funciones de CUBRID

Tabla de contenidos

  • cubrid_bind — Vincular variables para una sentencia preparada como parámetros
  • cubrid_close_prepare — Cerrar el gestor de solicitud
  • cubrid_close_request — Cerrar el gestor de solicitud
  • cubrid_col_get — Obtener el contenido de la columna del tipo de colecctión usando OID
  • cubrid_col_size — Obtener el número de elementos de la columna del tipo de colección usando OID
  • cubrid_column_names — Obtener los nombres de las columnas del resultado
  • cubrid_column_types — Obtener los tipos de columnas del resultado
  • cubrid_commit — Consigna una transacción
  • cubrid_connect_with_url — Establecer el entorno para la conexión al servidor de CUBRID
  • cubrid_connect — Abrir una conexión al servidor CUBRID
  • cubrid_current_oid — Obtener el OID de la posición del cursor actual
  • cubrid_disconnect — Cerrar una conexión a una base de datos
  • cubrid_drop — Borrar una instancia usando OID
  • cubrid_error_code_facility — Obtener el código de error del dispositivo
  • cubrid_error_code — Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_msg — Obtener el último mensaje de error de la llamada a la función más reciente
  • cubrid_execute — Ejecutar una sentencia SQL preparada
  • cubrid_fetch — Obtener la siguiente fila de un conjunto de resultados
  • cubrid_free_result — Liberar la memoria ocupada por los datos del resultado
  • cubrid_get_autocommit — Devuelve el modo auto-commit de la conexión
  • cubrid_get_charset — Devolver el conjunto de caracteres de la conexión CUBRID actual
  • cubrid_get_class_name — Obtener el nombre de la clase usando OID
  • cubrid_get_client_info — Devolver la versión de la biblioteca cliente
  • cubrid_get_db_parameter — Devuelve los parámetros de la base de datos CUBRID
  • cubrid_get_query_timeout — Obtener el valor del tiempo de espera de consulta de la petición
  • cubrid_get_server_info — Devolver la versión del servidor CUBRID
  • cubrid_get — Obtener una columna usando OID
  • cubrid_insert_id — Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT
  • cubrid_is_instance — Comprobar si existe la instancia apuntada por OID
  • cubrid_lob_close — Cerrar información BLOB/CLOB
  • cubrid_lob_export — Exportar datos BLOB/CLOB a un fichero
  • cubrid_lob_get — Obtener información BLOB/CLOB
  • cubrid_lob_send — Leer información BLOB/CLOB y enviarla directamente al navegador
  • cubrid_lob_size — Obtener el tamaño de datos BLOB/CLOB
  • cubrid_lob2_bind — Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros
  • cubrid_lob2_close — Cierra un objeto LOB
  • cubrid_lob2_export — Exporta un objeto LOB a un fichero
  • cubrid_lob2_import — Importa datos BLOB/CLOB desde un fichero
  • cubrid_lob2_new — Crea un objeto LOB
  • cubrid_lob2_read — Lee desde datos BLOB/CLOB
  • cubrid_lob2_seek64 — Mover el cursor de un objeto LOB
  • cubrid_lob2_seek — Mover el cursor de un objeto LOB
  • cubrid_lob2_size64 — Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size — Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_tell64 — Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell — Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_write — Escribe en un objeto LOB
  • cubrid_lock_read — Establecer un bloqueo de lectura sobre el OID dado
  • cubrid_lock_write — Establecer un bloqueo de escritura para el OID dado
  • cubrid_move_cursor — Mover el cursor en el resultado
  • cubrid_next_result — Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL
  • cubrid_num_cols — Devolver el número de columnas del conjunto de resultados
  • cubrid_num_rows — Obtener el número de filas del conjunto de resultados
  • cubrid_pconnect_with_url — Abrir una conexión persistente al servidor CUBRID
  • cubrid_pconnect — Abrir una conexión persistente a un servidor CUBRID
  • cubrid_prepare — Preparar una sentencia SQL para su ejecución
  • cubrid_put — Actualizar un atributo usando OID
  • cubrid_rollback — Retroceder una transacción
  • cubrid_schema — Obtener la información del esquema solicitado
  • cubrid_seq_drop — Borrar un elemento de una columna tipo secuencia usando OID
  • cubrid_seq_insert — Insertar un elemento en una columna tipo secuencia usando OID
  • cubrid_seq_put — Actualizar el valor del elemento de la columna de tipo secuencia usando OID
  • cubrid_set_add — Insertar un único elemento en la columna del tipo de conjunto usando OID
  • cubrid_set_autocommit — Establece el modo de confirmación automática de la conexión
  • cubrid_set_db_parameter — Configura los parámetros de la base de datos CUBRID
  • cubrid_set_drop — Borrar un elemento de la columna del tipo de conjunto usando OID
  • cubrid_set_query_timeout — Establecer el tiempo de espera de la ejecución de consultas
  • cubrid_version — Obtener la versión del módulo de PHP de CUBRID


Vincular variables para una sentencia preparada como parámetros

  • « Funciones de CUBRID
  • cubrid_close_prepare »
  • PHP Manual
  • Funciones de CUBRID
  • Vincular variables para una sentencia preparada como parámetros

cubrid_bind

(PECL CUBRID >= 8.3.0)

cubrid_bind — Vincular variables para una sentencia preparada como parámetros

Descripción

cubrid_bind ( resource $req_identifier , int $bind_index , mixed $bind_value , string $bind_value_type = ? ) : bool

La función cubrid_bind() se usa para vincular valores a un marcador de posición nominado o signo de interrogación correspondiente en la sentencia SQL que fue pasada a cubrid_prepare(). Si no se da bind_value_type, string será lo predeterminado.

Nota:

Si el tipo de datos a ser vinculados es BLOB/CLOB, CUBRID intentará mapear la información como un flujo de PHP. Si el tipo real de valor vinculado no es un flujo, CUBRID intentará convertirlo a cadena, y usarlo como la ruta completa y el nombre de fichero de un fichero del sistema de ficheros cliente.

Si el tipo de datos a ser vinculados explícitamente es ENUM, el argumento $bind_value debería ser el elemento enum que esté en formato string.

En un entorno fragmentado de CUBRID, se debe incluir de $bind_value_type en la función cubrid_bind function.

La siguiente tabla muestra los tipos de los valores sustitutos.

Tipos de Datos de Vinculación de CUBRID
Soporte | Tipo de Vinculación | Tipo SQL Correspondiente
Soportado | STRING | CHAR, VARCHAR
 | NCHAR | NCHAR, NVARCHAR
 | BIT | BIT, VARBIT
 | NUMERIC or NUMBER | SHORT, INT, NUMERIC
 | FLOAT | FLOAT
 | DOUBLE | DOUBLE
 | TIME | TIME
 | DATE | DATE
 | TIMESTAMP | TIMESTAMP
 | OBJECT | OBJECT
 | ENUM | ENUM
 | BLOB | BLOB
 | CLOB | CLOB
 | NULL | NULL
No soportado | SET | SET
 | MULTISET | MULTISET
 | SEQUENCE | SEQUENCE

Parámetros

req_identifier

Identificador de solicitud como resultado de cubrid_prepare()

bind_index

Índice de ubicación de los parámetros de vinculación. Comienza con 1.

bind_value

Valor actual para el vínculo.

bind_index

Un tipo de valor a vincular. (Es omitido por defecto. Así, el sistema internamente usa una cadena por omisión. Sin embargo, se necesita especificar el tipo exacto del valor como argumento cuando son de tipo NCHAR, BIT, o BLOB/CLOB).

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Historial de cambios

Versión | Descripción
8.3.1 | Añadido el soporte para tipos de datos BLOB/CLOB.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_bind()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE sports='Basketball' and gender='M'");
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$game_req = cubrid_prepare($conn, "SELECT athlete_code FROM game WHERE host_year=1992 and event_code=? and nation_code='USA'");
cubrid_bind($game_req, 1, $event_code, "number");
cubrid_execute($game_req);

printf("--- Dream Team (1992 United States men's Olympic basketball team) ---\n");
while ($athlete_code = cubrid_fetch_array($game_req, CUBRID_NUM)) {
    $athlete_req  = cubrid_prepare($conn, "SELECT name FROM athlete WHERE code=? AND  nation_code='USA' AND event='Basketball' AND gender='M'");
    cubrid_bind($athlete_req, 1, $athlete_code[0], "number");
    cubrid_execute($athlete_req);
    $row = cubrid_fetch_assoc($athlete_req);
    printf("%s\n", $row["name"]);
}

cubrid_close_request($game_req);
cubrid_close_request($athlete_req);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

--- Dream Team (1992 United States men's Olympic basketball team) ---
Stockton John
Robinson David
Pippen Scottie
Mullin C.
Malone Karl
Laettner C.
Jordan Michael
Johnson Earvin
Ewing Patrick
Drexler Clyde
Bird Larry
Barkley Charles

Ejemplo #2 Ejemplo de BLOB/CLOB de cubrid_bind()

<?php
$con = cubrid_connect("localhost", 33000, "demodb", "dba", "");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (doc_content CLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(doc_content) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    $fp = fopen("book.txt", "rb");

    cubrid_bind($req, 1, $fp, "clob");
    cubrid_execute($req);
}
?>

Ejemplo #3 Ejemplo de BLOB/CLOB de cubrid_bind()

<?php
$con = cubrid_connect("localhost", 33000, "foo");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (image BLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(image) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    cubrid_bind($req, 1, "cubrid_logo.png", "blob");
    cubrid_execute($req);
}
?>

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_prepare() - Preparar una sentencia SQL para su ejecución


Cerrar el gestor de solicitud

  • « cubrid_bind
  • cubrid_close_request »
  • PHP Manual
  • Funciones de CUBRID
  • Cerrar el gestor de solicitud

cubrid_close_prepare

(PECL CUBRID >= 8.3.0)

cubrid_close_prepare — Cerrar el gestor de solicitud

Descripción

cubrid_close_prepare ( resource $req_identifier ) : bool

La función cubrid_close_prepare() cierra el gestor de solicitud dado por el argumento req_identifier, y libera la región de memoria relacionada con el gestor. Es un alias de cubrid_close_request().

Parámetros

req_identifier

Identificador de solicitud.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_close_prepare()

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "conectado con éxito";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $nombre) = cubrid_fetch ($req) ){
         echo $id;
         echo $nombre;
      }
      cubrid_close_prepare($req); // o se puede usar cubrid_close_request($req)
   }
   cubrid_disconnect($con);
}
?>

Ver también

  • cubrid_close_request() - Cerrar el gestor de solicitud


Cerrar el gestor de solicitud

  • « cubrid_close_prepare
  • cubrid_col_get »
  • PHP Manual
  • Funciones de CUBRID
  • Cerrar el gestor de solicitud

cubrid_close_request

(PECL CUBRID >= 8.3.0)

cubrid_close_request — Cerrar el gestor de solicitud

Descripción

cubrid_close_request ( resource $req_identifier ) : bool

La función cubrid_close_request() cierra el gestor de solicitud dado por el argumento req_identifier, y libera la región de memoria relacionada con el gestor. Es un alias de cubrid_close_prepare().

Parámetros

req_identifier

Identificador de solicitud.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_close_request()

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $name) = cubrid_fetch ($req) ){
         echo $id;
         echo $name;
      }
      cubrid_close_request($req); // o se puede usar cubrid_close_prepare($req)
   }
   cubrid_disconnect($con);
}
?>

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Obtener el contenido de la columna del tipo de colecctión usando OID

  • « cubrid_close_request
  • cubrid_col_size »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el contenido de la columna del tipo de colecctión usando OID

cubrid_col_get

(PECL CUBRID >= 8.3.0)

cubrid_col_get — Obtener el contenido de la columna del tipo de colecctión usando OID

Descripción

cubrid_col_get ( resource $conn_identifier , string $oid , string $attr_name ) : array

La función cubrid_col_get() se usa para obtener el contenido de los elementos del atributo del tipo de colección (conjunto, multiconjunto, secuencia) que se solicitó como array.

Parámetros

conn_identifier

Identificador de conexión.

oid

El OID de la instancia que se quiere leer.

attr_name

El nombre del atributo de la instancia que se quiere leer.

Valores devueltos

Matriz (númerica basada en 0) que contiene los elementos que se solicitaron, cuando el proceso tiene éxito;

false (para diferenciar del error de la situación en la que el atributo tiene una colección vacía o NULL, en caso de error, se muestra un mensaje de advertencia; en tal caso se puede comprobar el error usando cubrid_error_code()), cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_col_get()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)


Obtener el número de elementos de la columna del tipo de colección usando OID

  • « cubrid_col_get
  • cubrid_column_names »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el número de elementos de la columna del tipo de colección usando OID

cubrid_col_size

(PECL CUBRID >= 8.3.0)

cubrid_col_size — Obtener el número de elementos de la columna del tipo de colección usando OID

Descripción

cubrid_col_size ( resource $conn_identifier , string $oid , string $attr_name ) : int

La función cubrid_col_size() se usa para obtener el número de elementos de un atributo de tipo de colección (conjunto, multiconjunto, secuencia).

Parámetros

conn_identifier

Identificador de conexión.

oid

El OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo con el que se quiere trabajar.

Valores devueltos

Número de elementos, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Historial de cambios

Versión | Descripción
8.3.1 | Cambio del valor devuelto: cuando el proceso no tiene éxito devuelve false, no -1.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_col_size()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)


Obtener los nombres de las columnas del resultado

  • « cubrid_col_size
  • cubrid_column_types »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener los nombres de las columnas del resultado

cubrid_column_names

(PECL CUBRID >= 8.3.0)

cubrid_column_names — Obtener los nombres de las columnas del resultado

Descripción

cubrid_column_names ( resource $req_identifier ) : array

La función cubrid_column_names() se usa para obtener los nombres de las columnas del resutado de la consulta usando req_identifier.

Parámetros

req_identifier

Identificador de solicitud.

Valores devueltos

Un array de valores de tipo string que contiene los nombres de las columnas, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_column_names()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

Ver también

  • cubrid_prepare() - Preparar una sentencia SQL para su ejecución
  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_column_types() - Obtener los tipos de columnas del resultado


Obtener los tipos de columnas del resultado

  • « cubrid_column_names
  • cubrid_commit »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener los tipos de columnas del resultado

cubrid_column_types

(PECL CUBRID >= 8.3.0)

cubrid_column_types — Obtener los tipos de columnas del resultado

Descripción

cubrid_column_types ( resource $req_identifier ) : array

La función cubrid_column_types() obtiene los tipos de columnas de los resultados de la consulta usando req_identifier.

Parámetros

req_identifier

Identificador de solicitud.

Valores devueltos

Un array de valores de tipo string que contiene los tipos de las columnas, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_column_types()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

Ver también

  • cubrid_column_names() - Obtener los nombres de las columnas del resultado
  • cubrid_prepare() - Preparar una sentencia SQL para su ejecución
  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Consigna una transacción

  • « cubrid_column_types
  • cubrid_connect_with_url »
  • PHP Manual
  • Funciones de CUBRID
  • Consigna una transacción

cubrid_commit

(PECL CUBRID >= 8.3.0)

cubrid_commit — Consigna una transacción

Descripción

cubrid_commit ( resource $conn_identifier ) : bool

La función cubrid_commit() se usa para ejecutar el envío de la transacción a la que apunta conn_handle, actualmente en progreso. La conexión al servidor se cierra después de llamar a la función cubrid_commit(); sin embargo, el gestor de conexión todavía es válido.

En CUBRID PHP, se deshabilita un modo de auto consigna por opmisión para la administración de transacciones. Se puede establecer usando cubrid_set_autocommit(). Se puede obtener su estado usando cubrid_get_autocommit(). Antes de comenzar una transacción, acuérdese de deshabilitar el modo de auto consigna.

Parámetros

conn_identifier

Identificador de conexión.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_commit()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;
cubrid_set_autocommit($conn,false);
if (!cubrid_execute($conn, $sql)) {
    printf("Error  facility: %d\nError code: %d\nError msg: %s\n",  cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

Ver también

  • cubrid_rollback() - Retroceder una transacción
  • cubrid_get_autocommit() - Devuelve el modo auto-commit de la conexión
  • cubrid_set_autocommit() - Establece el modo de confirmación automática de la conexión


Establecer el entorno para la conexión al servidor de CUBRID

  • « cubrid_commit
  • cubrid_connect »
  • PHP Manual
  • Funciones de CUBRID
  • Establecer el entorno para la conexión al servidor de CUBRID

cubrid_connect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_connect_with_url — Establecer el entorno para la conexión al servidor de CUBRID

Descripción

cubrid_connect_with_url ( string $conn_url , string $userid = ? , string $passwd = ? , bool $new_link = false ) : resource

La función cubrid_connect_with_url() se usa para establecer el entorno de conexión a su servidor usando la información de conexión pasada con un argumento de cadena de url. Si la característica HA está habilitada en CUBRID, se debe especificar la información de conexión del servidor de emergencia, el cual se usa para la recuperación de fallos cuando sucede uno, en el argumento de cadena de url de esta función. Si el nombre de usuario y la contraseña no se dan se realizará la conexión "PUBLIC" por omisión.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : Un nombre de host o dirección IP de la base de datos maestra
  • db_name : Un nombre de la base de datos
  • db_user : Un nombre del usuario de la base de datos
  • db_password : Una contraseña de usuario de la base de datos
  • alhosts: Especifica la información del agente del servidor de emergencia, el cual se usa para la recuperación de fallos cuando es imposible conectar al servidor activo. Se pueden especificar múltiples agentes para la recuperación de fallos, y la conexión a los agentes se intenta en el orden listado en alhosts
  • rctime : Un intervalo entre los intentos de conexión al agente activo en el que ocurrió el fallo. Después de que ocurra un fallo, el sistema se conecta al agente especificado por althosts (recuperación de fallos), finaliza la transacción, y después intenta conectarse al agente activo de la base de datos maestra cada rctime. El valor predeterminado es 600 segundos.
  • login_timeout : Valor de tiempo de espera (unidad: mseg.) para la identificación en la base de datos. El valor predeterminado es 0, lo que significa un aplazamiento infinito.
  • query_timeout : Valor de tiempo de espera (unidad: mseg.) para la solicitud de consulta. Cuando finaliza el tiempo de espera, se envía al servidor un mensaje para cancelar la transferencia de la consulta. El valor devuelto puede depender de de la configuración de disconnect_on_query_timeout; incluso si el mensaje para cancelar una petición es enviado al servidor, tal peticioón puede realizarse.
  • disconnect_on_query_timeout : Configura un valor para establecer si devolver inmediantamente un error de función que está siendo ejecutada al finalizar el tiempo de espera. El valor predeterminado es false.

Nota:

? y :, que son usados como identificadores en el URL de conexión de PHP, no pueden ser incluidos en la contraseña. El siguiente es un ejemplo de una contraseña que no es válida para usarla como URL de conexión ya que contiene "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Las contraseñas que contengan ? o : se pueden pasar como un parámetro aparte.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_connect_with_url($url, "dba", "12?");

Si el usuario o la contraseña están vacíos no se podrá borrar ":". He aquí un ejemplo:

$url = "CUBRID:localhost:33000:demodb:::";

Parámetros

conn_url

Una cadena de caracteres que contiene la información de conexión al servidor.

userid

El nombre de usuario de la base de datos.

passwd

La contraseña del usuario.

new_link

Si se hace una segunda llamada a cubrid_connect_with_url() con los mismos argumentos, no se establecerá una nueva conexión, en su lugar, se devolverá el identificador de conexión de la conexión ya abierta. El parámetro new_link modifica este comportamiento y hace que cubrid_connect_with_url() abra siempre una nueva conexión, incluso si cubrid_connect_with_url() fue llamada antes con los mismos parámetros.

Valores devueltos

El identificador de conexión, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_connect_with_url(), url sin propiedades

<?php
$conn_url = "CUBRID:localhost:33000:demodb:dba::";
$con = cubrid_connect_with_url($conn_url);

if ($con) {
   echo "Se conectó con éxito";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Ejemplo #2 Ejemplo de cubrid_connect_with_url(), url con propiedades

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?login_timeout=100"
$con = cubrid_connect_with_url ($conn_url);

if ($con) {
   echo "Se conectó con éxito";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Ver también

  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_pconnect() - Abrir una conexión persistente a un servidor CUBRID
  • cubrid_pconnect_with_url() - Abrir una conexión persistente al servidor CUBRID
  • cubrid_disconnect() - Cerrar una conexión a una base de datos
  • cubrid_close() - Cerrar la conexión de CUBRID


Abrir una conexión al servidor CUBRID

  • « cubrid_connect_with_url
  • cubrid_current_oid »
  • PHP Manual
  • Funciones de CUBRID
  • Abrir una conexión al servidor CUBRID

cubrid_connect

(PECL CUBRID >= 8.3.1)

cubrid_connect — Abrir una conexión al servidor CUBRID

Descripción

cubrid_connect ( string $host , int $port , string $dbname , string $userid = ? , string $passwd = ? , bool $new_link = false ) : resource

La función cubrid_connect() se usa para establecer el entorno para la conexión al servidor usando la dirección del servidor, número de puerto, nombre de la base de datos, nombre de usuario, y contraseña. Si no se dan el nombre de usuario y la contraseña, se realizará la conexión "PUBLIC" por defecto.

Parámetros

host

Nombre del host o dirección IP del servidor CAS de CUBRID.

port

Número de puerto del servidor CAS de CUBRID (BROKER_PORT configurado en $CUBRID/conf/cubrid_broker.conf).

dbname

Nombre de la base de datos.

userid

Nombre de usuario para la base de datos. Si no se da, el valor por omisión es "public".

passwd

Contraseña del usuario. Si no se da, el valor por omisión es "".

new_link

Si se hace una segunda llamada a cubrid_connect() con los mismos argumentos, no se establecerá una nueva conexión, en su lugar, se devolverá el identificador de conexión de la conexión ya abierta. El parámetro new_link modifica este comportamiento y hace que cubrid_connect() abra siempre una nueva conexión, incluso si cubrid_connect() fue llamada antes con los mismos parámetros.

Valores devueltos

El identificador de conexión, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_connect()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Información del Servidor:", $server_info);
printf("%-30s %s\n", "Información del Cliente:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "Conjunto de carac.:", $charset);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              0

Información del Servidor:      9.1.0.0212
Información del Cliente:       9.1.0

Conjunto de carac. de CUBRID:  iso8859-1

Ver también

  • cubrid_pconnect() - Abrir una conexión persistente a un servidor CUBRID
  • cubrid_connect_with_url() - Establecer el entorno para la conexión al servidor de CUBRID
  • cubrid_pconnect_with_url() - Abrir una conexión persistente al servidor CUBRID
  • cubrid_disconnect() - Cerrar una conexión a una base de datos
  • cubrid_close() - Cerrar la conexión de CUBRID


Obtener el OID de la posición del cursor actual

  • « cubrid_connect
  • cubrid_disconnect »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el OID de la posición del cursor actual

cubrid_current_oid

(PECL CUBRID >= 8.3.0)

cubrid_current_oid — Obtener el OID de la posición del cursor actual

Descripción

cubrid_current_oid ( resource $req_identifier ) : string

La función cubrid_current_oid() se usa para obtener el oid de la posición del cursor actual desde el resultado de la consulta. Para usar cubrid_current_oid(), la consulta ejecutada debe ser una consulta actualizable, y se debe incluir la opción CUBRID_INCLUDE_OID durante la ejecución de la consulta.

Parámetros

req_identifier

Identificador de solicitud.

Valores devueltos

Oid de la posición del cursor actual, cuando el proceso tiene éxito

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_current_oid()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$res = cubrid_get($conn, $oid);

print_r($res);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Array
(
    [s_name] => X
    [f_name] => Mixed
)

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Cerrar una conexión a una base de datos

  • « cubrid_current_oid
  • cubrid_drop »
  • PHP Manual
  • Funciones de CUBRID
  • Cerrar una conexión a una base de datos

cubrid_disconnect

(PECL CUBRID >= 8.3.0)

cubrid_disconnect — Cerrar una conexión a una base de datos

Descripción

cubrid_disconnect ( resource $conn_identifier = ? ) : bool

La función cubrid_disconnect() cierra el gestor de conexión y se desconecta del servidor. Si algún gestor de solicitud no se ha sido cerrado en este punto, será cerrado. Es similar a la función de CUBRID compatible con MySQL cubrid_close().

Parámetros

conn_identifier

Identificador de conexión.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_disconnect()

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "conectado con éxito";

   $req = cubrid_execute( $con, "create table person(id int,name char(10))");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }

   $req = cubrid_execute( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Ver también

  • cubrid_close() - Cerrar la conexión de CUBRID
  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_connect_with_url() - Establecer el entorno para la conexión al servidor de CUBRID


Borrar una instancia usando OID

  • « cubrid_disconnect
  • cubrid_error_code_facility »
  • PHP Manual
  • Funciones de CUBRID
  • Borrar una instancia usando OID

cubrid_drop

(PECL CUBRID >= 8.3.0)

cubrid_drop — Borrar una instancia usando OID

Descripción

cubrid_drop ( resource $conn_identifier , string $oid ) : bool

La función cubrid_drop() se usa para borrar una instancia de la base de datos usando el oid de la instancia.

Parámetros

conn_identifier

Identificador de conexión.

oid

Oid de la instancia que se quiere borrar.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_drop()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("--- Antes de Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

if (cubrid_drop($conn, $oid)) {
    cubrid_commit($conn);
} else {
    cubrid_rollback($conn);
}

cubrid_close_request($req);

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("\n--- Después de Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

--- Antes de Drop: ---
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

--- Después de Drop: ---
array(4) {
  ["a"]=>
  string(1) "2"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "4"
    [1]=>
    string(1) "5"
    [2]=>
    string(1) "7"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "44"
    [1]=>
    string(2) "55"
    [2]=>
    string(2) "66"
    [3]=>
    string(3) "666"
  }
  ["d"]=>
  string(10) "b         "
}

Ver también

  • cubrid_is_instance() - Comprobar si existe la instancia apuntada por OID


Obtener el código de error del dispositivo

  • « cubrid_drop
  • cubrid_error_code »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el código de error del dispositivo

cubrid_error_code_facility

(PECL CUBRID >= 8.3.0)

cubrid_error_code_facility — Obtener el código de error del dispositivo

Descripción

cubrid_error_code_facility ( ) : int

La función cubrid_error_code_facility() se usa para obtener el código de dispositivo (nivel en el que ocurrió el error) desde el código de error del error que ocurrió durante la ejecución de la API. Normalmente, se puede obtener el código de error cuando la API devuelve false como valor de retorno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Código de dispositivo del código de error que ocuriió: CUBRID_FACILITY_DBMS, CUBRID_FACILITY_CAS, CUBRID_FACILITY_CCI, CUBRID_FACILITY_CLIENT

Ejemplos

Ejemplo #1 Ejemplo de cubrid_error_code_facility()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = @cubrid_execute($conn, "SELECT * FROM unknown");
if (!$req) {
    printf("Dispositivo del error: %d\nCódigo de error: %d\nMensaje de error: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

El resultado del ejemplo sería:

Dispositivo del error: 1
Código de error: -493
Mensaje de error: Syntax: In line 1, column 15 before END OF STATEMENT
Syntax error: unexpected 'unknown'

Ver también

  • cubrid_error_code() - Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_msg() - Obtener el último mensaje de error de la llamada a la función más reciente


Obtener el código de error de la llamada a una función más reciente

  • « cubrid_error_code_facility
  • cubrid_error_msg »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el código de error de la llamada a una función más reciente

cubrid_error_code

(PECL CUBRID >= 8.3.0)

cubrid_error_code — Obtener el código de error de la llamada a una función más reciente

Descripción

cubrid_error_code ( ) : int

La función cubrid_error_code() se usa para obtener el código de error del error que ocurrión durante la ejecución de la API. Normalmente obtiene el código de error cuando la API devuelve false como valor de retorno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Código de error del error que ocurrió, o 0 (cero) si no ocurre ningún error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_error_code()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_prepare($conn , "SELECT * FROM code WHERE s_name=?");

$req = @cubrid_execute($req);
if (!$req) {
    printf("Dispositivo del error: %d\nCódigo de error: %d\nMensaje de error: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

El resultado del ejemplo sería:

Dispositivo del error: 4
Código de error: -30015
Mensaje de error: Some parameter not binded

Ver también

  • cubrid_error_code_facility() - Obtener el código de error del dispositivo
  • cubrid_error_msg() - Obtener el último mensaje de error de la llamada a la función más reciente


Obtener el último mensaje de error de la llamada a la función más reciente

  • « cubrid_error_code
  • cubrid_execute »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el último mensaje de error de la llamada a la función más reciente

cubrid_error_msg

(PECL CUBRID >= 8.3.0)

cubrid_error_msg — Obtener el último mensaje de error de la llamada a la función más reciente

Descripción

cubrid_error_msg ( ) : string

La función cubrid_error_msg() se usa para obtener el mensaje de error que ocurrió durante la utilización de la API CUBRID. Normalmente obtiene el mensaje de error cuando la API devuelve false como valor de retorno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El mensaje de error que ocurrió.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_error_msg()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

if (!@cubrid_schema($conn, 100000)) {
    printf("Dispositivo del error: %d\nCódigo de error: %d\nMensaje de error: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

El resultado del ejemplo sería:

Dispositivo del error: 2
Código de error: -10015
Mensaje de error: Invalid T_CCI_SCH_TYPE value

Ver también

  • cubrid_error_code() - Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_code_facility() - Obtener el código de error del dispositivo


Ejecutar una sentencia SQL preparada

  • « cubrid_error_msg
  • cubrid_fetch »
  • PHP Manual
  • Funciones de CUBRID
  • Ejecutar una sentencia SQL preparada

cubrid_execute

(PECL CUBRID >= 8.3.0)

cubrid_execute — Ejecutar una sentencia SQL preparada

Descripción

cubrid_execute ( resource $conn_identifier , string $sql , int $option = 0 ) : resource
cubrid_execute ( resource $request_identifier , int $option = 0 ) : bool

La función cubrid_execute() se usa para ejecutar la sentencia SQL dada. Ejecuta la consulta usando conn_identifier y SQL, y luego devuelve el gestor de solicitud creado. Se usa para la simple ejecución de la consulta, donde el parámetro de enlace no es necesario. Además, la función cubrid_execute() se usa para ejecutar la sentencia preparada por medio de cubrid_prepare() y cubrid_bind(). En este momento se necesitan especificar los argumentos request_identifier y option.

El argumento option se usa para determinar si recibir el OID después de la ejecución de la consulta y si ejecutar la consulta en modo síncrono o asíncrono. Se pueden especificar CUBRID_INCLUDE_OID y CUBRID_ASYNC (o CUBRID_EXEC_QUERY_ALL si se desea ejecutar múltiples sentencias SQL) usando un operador OR a nivel de bit. Si no se especifica, ninguna de ellas será seleccionada. Si la bandera CUBRID_EXEC_QUERY_ALL está activa, el modo síncrono (sync_mode) se usa para devolver los resultados de la consulta, y en esos casos las siguientes reglas serán aplicadas:

  • El valor devuelto es el resultado de la primera petición.
  • Si sucede un error en la consulta, la ejecución se procesa como un fallo.
  • En una consulta compuesta por c1, c2, c3, si sucede un error en c2 después del éxito de la ejecución de c1, el resultado de c1 permanece válido. Esto es, los éxitos previos en las ejecucuiones de consultas no se repiten cuando sucede un error.
  • Si una consulta se ejecuta de forma satisfactoria, el resultado de la segunda consulta puede obtenerse usando la función cubrid_next_result().

Si el primer argumento es request_identifier para ejecutar la función cubrid_prepare(), se puede especificar una opción, solamente CUBRID_ASYNC.

Parámetros

conn_identifier

Identificador de conexión.

sql

SQL a ser ejecutado.

option

La opción de ejecución de la consulta CUBRID_INCLUDE_OID, CUBRID_ASYNC, CUBRID_EXEC_QUERY_ALL.

request_identifier

Identificador de cubrid_prepare().

Valores devueltos

Gestor de solicitud, cuando el proceso tiene éxito y el primer parámetro es conn_identifier; true, cuando el proceso tiene éxito y el primer argumento es request_identifier.

false, cuando el proceso no tiene éxito.

Historial de cambios

Versión | Descripción
8.4.0 | Añade CUBRID_EXEC_QUERY_ALL como opción nueva.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_execute()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE name='100m Butterfly' and gender='M'", CUBRID_ASYNC);
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$history_req = cubrid_prepare($conn, "SELECT * FROM history WHERE event_code=?");
cubrid_bind($history_req, 1, $event_code, "number");
cubrid_execute($history_req);

printf("%-20s %-9s %-10s %-5s\n", "athlete", "host_year", "score", "unit");
while ($row = cubrid_fetch_array($history_req, CUBRID_ASSOC)) {
    printf("%-20s %-9s %-10s %-5s\n",
        $row["athlete"], $row["host_year"], $row["score"], $row["unit"]);
}

cubrid_close_request($history_req);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

athlete              host_year score      unit
Phelps Michael       2004      51.25      time

Ver también

  • cubrid_prepare() - Preparar una sentencia SQL para su ejecución
  • cubrid_bind() - Vincular variables para una sentencia preparada como parámetros
  • cubrid_next_result() - Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL
  • cubrid_close_request() - Cerrar el gestor de solicitud
  • cubrid_commit() - Consigna una transacción
  • cubrid_rollback() - Retroceder una transacción


Obtener la siguiente fila de un conjunto de resultados

  • « cubrid_execute
  • cubrid_free_result »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener la siguiente fila de un conjunto de resultados

cubrid_fetch

(PECL CUBRID >= 8.3.0)

cubrid_fetch — Obtener la siguiente fila de un conjunto de resultados

Descripción

cubrid_fetch ( resource $result , int $type = CUBRID_BOTH ) : mixed

La función cubrid_fetch() se usa para obtener una única fila del resultado de la consulta. El cursor se mueve automáticamente a la siguiente columna después de obtener el resultado.

Parámetros

result

result proviene de una llamada a la función cubrid_execute().

type

Tipo de array del resultado obtenido: CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH, CUBRID_OBJECT. Si se operan con objetos lob, se puede usar CUBRID_LOB.

Valores devueltos

Un array de resultados u objeto, cuando el proceso tiene éxito.

false, cuando no existen más filas; NULL, cuando el proceso no tiene éxito.

El resultado se puede recibir como array o como objeto, por lo que se puede decidir qué tipo de datos usar estableciendo el argumento type. La variable type se puede establecer a uno de los siguientes valores:

  • CUBRID_NUM : Array numérico (basado en 0)
  • CUBRID_ASSOC : Array asociativo
  • CUBRID_BOTH : Array numérico y asociativo (predeterminado)
  • CUBRID_OBJECT : Objeto que tiene el nombre del atributo como el nombre de la columna del resultado de la consulta

Cuando se omite el argumento type, el resultado será recibido usando la opción predeterminada CUBRID_BOTH. Cuando se quiere recibir el resultado de la consulta como objeto, el nombre de la columna del resultado debe obedecer las reglas de nombres de los identificadores de PHP. Por ejemplo, un nombre de columna como "count(*)" no puede ser recibido como objeto.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$solicitud = cubrid_execute($conexión, "SELECT * FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($fila = cubrid_fetch($solicitud)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $fila["name"], $fila["area"], $fila["seats"], $fila["address"]);
}

// si se operan con objetos lob, se puede usar cubrid_fetch($solicitud, CUBRID_LOB)

cubrid_close_request($solicitud);

cubrid_disconnect($conexión);
?>

El resultado del ejemplo sería:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_fetch_array() - Extrae una fila como array asociativo, numérico o ambos
  • cubrid_fetch_row() - Devuelve un array numérico con los valores de la fila actual
  • cubrid_fetch_assoc() - Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_fetch_object() - Devuelve un objeto con los nombres de las columnas


Liberar la memoria ocupada por los datos del resultado

  • « cubrid_fetch
  • cubrid_get_autocommit »
  • PHP Manual
  • Funciones de CUBRID
  • Liberar la memoria ocupada por los datos del resultado

cubrid_free_result

(PECL CUBRID >= 8.3.0)

cubrid_free_result — Liberar la memoria ocupada por los datos del resultado

Descripción

cubrid_free_result ( resource $req_identifier ) : bool

Esta función libera la memoria ocupada por los datos del resultado. Devuelve TRUE en caso de éxito o FALSE en caso de error. Observe que sólo se puede liberar el buffer de obtención del cliente, y si se quiere liberar toda la memoria, use la función cubrid_close_request().

Parámetros

req_identifier

Éste es el identificador de solicitud.

Valores devueltos

true en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_free_result()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM history WHERE host_year=2004 ORDER BY event_code");
$row = cubrid_fetch_assoc($req);
var_dump($row);

cubrid_free_result($req);
cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(5) {
  ["event_code"]=>
  string(5) "20005"
  ["athlete"]=>
  string(12) "Hayes Joanna"
  ["host_year"]=>
  string(4) "2004"
  ["score"]=>
  string(5) "12.37"
  ["unit"]=>
  string(4) "time"
}


Devuelve el modo auto-commit de la conexión

  • « cubrid_free_result
  • cubrid_get_charset »
  • PHP Manual
  • Funciones de CUBRID
  • Devuelve el modo auto-commit de la conexión

cubrid_get_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_get_autocommit — Devuelve el modo auto-commit de la conexión

Descripción

cubrid_get_autocommit ( resource $conn_identifier ) : bool

La función cubrid_get_autocommit() se usa para obtener el estado del modo auto-commit de la conexión de dase de batos CUBIRD.

Para CUBRID 8.4.0, el modo auto-commit está deshabilitado de forma predeterminada para administración de transacciones.

Para CUBRID 8.4.1, el modo auto-commit está habilitado de forma predeterminada para administración de transacciones.

Parámetros

conn_identifier

Identificador de conexión.

Valores devueltos

true, cuando el auto-commit está activado.

false, cuando el auto-commit está desactivado.

null en caso de error.

Ver también

  • cubrid_set_autocommit() - Establece el modo de confirmación automática de la conexión
  • cubrid_commit() - Consigna una transacción


Devolver el conjunto de caracteres de la conexión CUBRID actual

  • « cubrid_get_autocommit
  • cubrid_get_class_name »
  • PHP Manual
  • Funciones de CUBRID
  • Devolver el conjunto de caracteres de la conexión CUBRID actual

cubrid_get_charset

(PECL CUBRID >= 8.3.0)

cubrid_get_charset — Devolver el conjunto de caracteres de la conexión CUBRID actual

Descripción

cubrid_get_charset ( resource $conn_identifier ) : string

Esta función devuelve el conjunto de caracteres de la conexión CUBRID actual y es similar a la función de CUBRID compatible con MySQL cubrid_client_encoding().

Parámetros

conn_identifier

La conexión CUBRID.

Valores devueltos

Una cadena que representa el conjunto de caracteres de la conexión CUBRID; en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_charset()

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('No se pudo realizar la conexión.');
}

printf("Conjunto de caracteres actual de CUBRID: %s\n", cubrid_get_charset($con));

?>

El resultado del ejemplo sería:

CUBRID current charset: iso8859-1

Ver también

  • cubrid_client_encoding() - Devuelve el actual conjunto de caracteres de la conexión a CUBRID


Obtener el nombre de la clase usando OID

  • « cubrid_get_charset
  • cubrid_get_client_info »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el nombre de la clase usando OID

cubrid_get_class_name

(PECL CUBRID >= 8.3.0)

cubrid_get_class_name — Obtener el nombre de la clase usando OID

Descripción

cubrid_get_class_name ( resource $conn_identifier , string $oid ) : string

La función cubrid_get_class_name() se usa para obtener el nombre de la clase del oid. No funciona al seleccionar datos desde las tablas del sistema, por ejemplo db_class.

Parámetros

conn_identifier

Identificador de conexión.

oid

Oid de la instancia de la que se quiere comprobar su existencia.

Valores devueltos

El nombre de la clase cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_class_name()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$class_name = cubrid_get_class_name($conn, $oid);

print_r($class_name);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

code

Ver también

  • cubrid_is_instance() - Comprobar si existe la instancia apuntada por OID
  • cubrid_drop() - Borrar una instancia usando OID


Devolver la versión de la biblioteca cliente

  • « cubrid_get_class_name
  • cubrid_get_db_parameter »
  • PHP Manual
  • Funciones de CUBRID
  • Devolver la versión de la biblioteca cliente

cubrid_get_client_info

(PECL CUBRID >= 8.3.0)

cubrid_get_client_info — Devolver la versión de la biblioteca cliente

Descripción

cubrid_get_client_info ( ) : string

Esta función devuelve una cadena que representa la versión de la biblioteca cliente.

Parámetros

Valores devueltos

Una cadena que representa la versión de la biblioteca cliente; en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_client_info()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              0

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1


Devuelve los parámetros de la base de datos CUBRID

  • « cubrid_get_client_info
  • cubrid_get_query_timeout »
  • PHP Manual
  • Funciones de CUBRID
  • Devuelve los parámetros de la base de datos CUBRID

cubrid_get_db_parameter

(PECL CUBRID >= 8.3.0)

cubrid_get_db_parameter — Devuelve los parámetros de la base de datos CUBRID

Descripción

cubrid_get_db_parameter ( resource $conn_identifier ) : array

Esta función devuelve los parámetros de la base de datos CUBRID o FALSE en caso de error. Devuelve un array asociativo con los valores de los siguientes parámetros:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT
  • PARAM_MAX_STRING_LENGTH
  • PARAM_AUTO_COMMIT

Parámetros de la base de datos
Parámetro | Descripción
PARAM_ISOLATION_LEVEL | El nivel de aislamiento de la transacción.
LOCK_TIMEOUT | CUBRID proporciona la característica de bloqueo de tiempo de espera, que establece el tiempo de espera (en segundos) para el bloqueo hasta que el ajuste de bloqueo de transacción se permite. El valor predeterminado del parámetro lock_timeout_in_secs es -1, lo que significa que la aplicación cliente esperará indefinidamente hasta que se permita el bloqueo de transacción.
PARAM_AUTO_COMMIT | En CUBRID PHP, el modo de auto consigna es desabilitado por omisión por el gestor de transacciones. Puede establecerse usando la función cubrid_set_autocommit().

La siguiente tabla muestra los niveles de aislamiento desde 1 hasta 6. Consiste en esquema de tabla (fila) y nivel de aislamiento:

Niveles de Aislamiento Soportados por CUBRID
Nombre | Descripción
SERIALIZABLE (6) | En este nivel de aislamiento, los problemas concernientes a la concurrencia (p.ej. lectura basura, lectura no repetible, lectura fantasma, etc.) no ocurren.
CLASE DE LECTURA REPETIBLE con INSTANCIAS DE LECTURA REPETIBLE (5) | Otra transacción T2 no puede actualizar el esquema de una tabla A mientras la transacción T1 está viendo la tabla A. La transacción T1 puede experimentar lectura fantasma para el registro R que fue insertado por otra transacción T2 cuando está obtenido repetidamente un registro especificado.
CLASE DE LECTURA REPETIBLE con INSTANCIAS CONSIGNADAS DE LECTURA (o ESTABILIDAD DE CURSOR) (4) | Otra transacción T2 no puede actualizar el esquema de una tabla A mientras la transacción T1 está viendo la tabla A. La transacción T1 puede experimentar lectura R (lectura no repetible) que fue actualizada y consignada por otra transacción T2 cuando está obteniendo repetidamente el registro R.
CLASE DE LECTURA REPETIBLE con INSTANCIAS NO CONSIGNADAS DE LECTURA (3) | Nivel de aislamiento predeterminado. Otra transacción T2 no puede actualizar el esquema de la tabla A mientras la transacción T1 está viendo la tabla A. La transacción T1 puede experimentar lectura R' (lectura basura) para el registro que fue actualizado pero no consignado por otra transacción T2.
CLASE CONSIGNADA DE LECTURA con INSTANCIAS CONSIGNADAS DE LECTURA (2) | La transacción T1 puede experimentar lectura A' (lectura no repetible) para la tabla que fue actualizada y consignada por otra transacción T2 mientras que está viendo la tabla A repetidamente. La transacción T1 puede experimentar lectura R' (lectura no repetible) para el registro que fue actualizado y consignado por otra transacción T2 mientras se está obteniendo el registro R repetidamente.
CLASE CONSIGNADA DE LECTURA con INSTANCIAS NO CONSIGNADAS DE LECTURA (1) | La transacción T1 puede experimentar lectura A' (lectura no repetible) para la tabla que fue actualizada y consignada por otra transacción T2 mientras que se ve repetidamente la tabla A. La transacción T1 puede experimentar lectura R' (lectura basura) para el registro qeu fue actualizado pero no consignado por otra transacción T2.

Parámetros

conn_identifier

La conexión CUBRID. Si el identificador de conexión no se especifica, se asume el último enlace abierto por cubrid_connect().

Valores devueltos

Una matriz asociativa con los parámetros de la base de datos CUBRID; en caso de éxito.

false en caso de error.

Historial de cambios

Versión | Descripción
8.4.0 | Cambia LOCK_TIMEOUT a PARAM_LOCK_TIMEOUT, y MAX_STRING_LENGTH a PARAM_MAX_STRING_LENGTH en el resultado.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_db_parameter()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ver también

  • cubrid_set_db_parameter() - Configura los parámetros de la base de datos CUBRID
  • cubrid_get_autocommit() - Devuelve el modo auto-commit de la conexión


Obtener el valor del tiempo de espera de consulta de la petición

  • « cubrid_get_db_parameter
  • cubrid_get_server_info »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el valor del tiempo de espera de consulta de la petición

cubrid_get_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_get_query_timeout — Obtener el valor del tiempo de espera de consulta de la petición

Descripción

cubrid_get_query_timeout ( resource $req_identifier ) : int

La función cubrid_get_query_timeout() se usa para obtener el tiempo de espera de consulta de la petición.

Parámetros

req_identifier

Identificador de petición.

Valores devueltos

Éxito: el valor del tiempo de espera de constula de la petición actual. Unidades de milisegundos.

Fallo: FALSE

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_query_timeout()

<?php

$host = "localhost";
$port = 33000;
$db = "demodb";

$conn =
cubrid_connect_with_url("CUBRID:$host:$port:$db:::?login_timeout=50000&query_timeout=5000&disconnect_on_query_timeout=yes");

$req = cubrid_prepare($conn, "SELECT * FROM code");

$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_set_query_timeout($req, 1000);
$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_close($conn);
?>

El resultado del ejemplo sería:

int(5000)
int(1000)

Ver también

  • cubrid_set_query_timeout() - Establecer el tiempo de espera de la ejecución de consultas


Devolver la versión del servidor CUBRID

  • « cubrid_get_query_timeout
  • cubrid_get »
  • PHP Manual
  • Funciones de CUBRID
  • Devolver la versión del servidor CUBRID

cubrid_get_server_info

(PECL CUBRID >= 8.3.0)

cubrid_get_server_info — Devolver la versión del servidor CUBRID

Descripción

cubrid_get_server_info ( resource $conn_identifier ) : string

Esta función devuelve una cadena que representa la versión del servidor CUBRID.

Parámetros

conn_identifier

La conexión CUBRID.

Valores devueltos

Una cadena que representa la versión del servidor CUBRID; en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_server_info()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1


Obtener una columna usando OID

  • « cubrid_get_server_info
  • cubrid_insert_id »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener una columna usando OID

cubrid_get

(PECL CUBRID >= 8.3.0)

cubrid_get — Obtener una columna usando OID

Descripción

cubrid_get ( resource $conn_identifier , string $oid , mixed $attr = ? ) : mixed

La función cubrid_get() se usa para obtener el atributo de la instancia del oid dado. Se puede obtener un solo atributo usando el tipo de datos de cadena para el argumento attr, o muchos atributos usando el tipo de datos array para el argumento attr.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia que se quiere leer.

attr

Nombre del atributo que se quiere leer.

Valores devueltos

Contenido del atributo solicitado, cuando el proceso tiene éxito; Cuando attr se establece al tipo de datos de cadena, el resultado es devuelto como una cadena; cuando attr se establece como tipo de datos array (númerico basado en 0), el resultado es devuelto como un array asociativo. Cuanso se omite attr, entonces todos los atributos se reciben como array.

false cuando el proceso no tiene éxito o el resultado es NULL (Si ocurre un error para diferenciar una cadena vacía de NULL, se imprime un mensaje de advertencia. Se puede comprobar el error usando cubrid_error_code())

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

Ver también

  • cubrid_put() - Actualizar un atributo usando OID


Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT

  • « cubrid_get
  • cubrid_is_instance »
  • PHP Manual
  • Funciones de CUBRID
  • Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT

cubrid_insert_id

(PECL CUBRID >= 8.3.0)

cubrid_insert_id — Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT

Descripción

cubrid_insert_id ( resource $conn_identifier = ? ) : string

La función cubrid_insert_id() recupera el ID generado para la columna AUTO_INCREMENT que fue actualizada por la consulta INSERT previa. Devuelve 0 si la consulta previa no generó nuevas filas, o FALSE en caso de error.

Nota:

CUBRID soporta AUTO_INCREMENT para más de una columna en una tabla. En la mayoría de los casos, habrá una única columna AUTO_INCREMENT en una tabla. Si hay varias columnas AUTO_INCREMENT, esta función no debería ser usada aunque devuelva un valor.

Parámetros

conn_identifier

El Identificador de conexión previamente obtenido por una llamada a cubrid_connect().

Valores devueltos

Un string representa el ID generado para una columna AUTO:INCREMENT por la consulta previa, en caso de éxito.

0, si la consulta previa no generó nuevas filas.

false en caso de fallo.

Historial de cambios

Versión | Descripción
8.4.0 | Cambia el valor devuelto de un array a un string; elimina el primer parámetro class_name.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_insert_id()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d int AUTO_INCREMENT(1, 2), t varchar)");

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($conn, "INSERT INTO cubrid_test(t) VALUES('cubrid_test')");
}

$id = cubrid_insert_id();
var_dump($id);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

string(2) "19"


Comprobar si existe la instancia apuntada por OID

  • « cubrid_insert_id
  • cubrid_lob_close »
  • PHP Manual
  • Funciones de CUBRID
  • Comprobar si existe la instancia apuntada por OID

cubrid_is_instance

(PECL CUBRID >= 8.3.0)

cubrid_is_instance — Comprobar si existe la instancia apuntada por OID

Descripción

cubrid_is_instance ( resource $conn_identifier , string $oid ) : int

La función cubrid_is_instance() se usa para comprobar si existe la instancia apuntada por el oid dado o no.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia que se quiere comprobar su existencia.

Valores devueltos

1, si tal instancia existe;

0, si tal instancia no existe;

-1, en caso de error

Ejemplos

Ejemplo #1 Ejemplo de cubrid_is_instance()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT host_year, medal, game_date
FROM game
WHERE athlete_code IN
    (SELECT code FROM athlete WHERE name='Thorpe Ian');
EOD;

$req = cubrid_execute($conn, $sql, CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);

$res = cubrid_is_instance ($conn, $oid);
if ($res == 1) {
    echo "La instancia a puntada por $oid existe.\n";
} else if ($res == 0){
    echo "La instancia a puntada por $oid no existe.\n";
} else {
    echo "error\n";
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

La instancia apuntada por @0|0|0 no existe.

Ver también

  • cubrid_drop() - Borrar una instancia usando OID
  • cubrid_get_class_name() - Obtener el nombre de la clase usando OID


Cerrar información BLOB/CLOB

  • « cubrid_is_instance
  • cubrid_lob_export »
  • PHP Manual
  • Funciones de CUBRID
  • Cerrar información BLOB/CLOB

cubrid_lob_close

(PECL CUBRID >= 8.3.1)

cubrid_lob_close — Cerrar información BLOB/CLOB

Descripción

cubrid_lob_close ( array $lob_identifier_array ) : bool

cubrid_lob_close() se usa para cerrar todos los BLOB/CLOB devueltos desde cubrid_lob_get().

Parámetros

lob_identifier_array

Array de identificadores LOB devuelto desde cubrid_lob_get.

Valores devueltos

true, cuando el proceso tiene éxito

false, cuando el proceso no tiene éxito

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob_close()

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ver también

  • cubrid_lob_get() - Obtener información BLOB/CLOB
  • cubrid_lob_size() - Obtener el tamaño de datos BLOB/CLOB
  • cubrid_lob_export() - Exportar datos BLOB/CLOB a un fichero
  • cubrid_lob_send() - Leer información BLOB/CLOB y enviarla directamente al navegador


Exportar datos BLOB/CLOB a un fichero

  • « cubrid_lob_close
  • cubrid_lob_get »
  • PHP Manual
  • Funciones de CUBRID
  • Exportar datos BLOB/CLOB a un fichero

cubrid_lob_export

(PECL CUBRID >= 8.3.1)

cubrid_lob_export — Exportar datos BLOB/CLOB a un fichero

Descripción

cubrid_lob_export ( resource $conn_identifier , resource $lob_identifier , string $path_name ) : bool

cubrid_lob_export() se usa para obtener información BLOB/CLOB de una base de datos CUBRID, y guarda su contenido a un fichero. Para usar esta función, debe utilizar cubrid_lob_get() primero para obtener información BLOB/CLOB desde CUBRID.

Parámetros

conn_identifier

Identificador de conexión.

lob_identifier

Identificador LOB.

path_name

Nombre de la ruta al fichero.

Valores devueltos

true, cuando el proceso tiene éxito

false, cuando el proceso no tiene éxito

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob_export()

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ver también

  • cubrid_lob_get() - Obtener información BLOB/CLOB
  • cubrid_lob_close() - Cerrar información BLOB/CLOB
  • cubrid_lob_size() - Obtener el tamaño de datos BLOB/CLOB
  • cubrid_lob_send() - Leer información BLOB/CLOB y enviarla directamente al navegador


Obtener información BLOB/CLOB

  • « cubrid_lob_export
  • cubrid_lob_send »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener información BLOB/CLOB

cubrid_lob_get

(PECL CUBRID >= 8.3.1)

cubrid_lob_get — Obtener información BLOB/CLOB

Descripción

cubrid_lob_get ( resource $conn_identifier , string $sql ) : array

cubrid_lob_get() se usa para obtener meta-información BLOB/CLOB desde la base de datos de CUBRID, CUBRID obtiene BLOB/CLOB ejecutando la sentencia SQL, y devuelve todos los LOBs como un array de recursos. Asegúrese de que SQL solo recupera una columna y su tipo de información es BLOB o CLOB.

Recuerde usar cubrid_lob_close() para liberar los LOBs si ya no los necesita más.

Parámetros

conn_identifier

Identificador de conexión.

sql

La sentencia SQL a ser ejecutada.

Valores devueltos

Devuelve un array de recursos LOB, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob_get()

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ver también

  • cubrid_lob_close() - Cerrar información BLOB/CLOB
  • cubrid_lob_size() - Obtener el tamaño de datos BLOB/CLOB
  • cubrid_lob_export() - Exportar datos BLOB/CLOB a un fichero
  • cubrid_lob_send() - Leer información BLOB/CLOB y enviarla directamente al navegador


Leer información BLOB/CLOB y enviarla directamente al navegador

  • « cubrid_lob_get
  • cubrid_lob_size »
  • PHP Manual
  • Funciones de CUBRID
  • Leer información BLOB/CLOB y enviarla directamente al navegador

cubrid_lob_send

(PECL CUBRID >= 8.3.1)

cubrid_lob_send — Leer información BLOB/CLOB y enviarla directamente al navegador

Descripción

cubrid_lob_send ( resource $conn_identifier , resource $lob_identifier ) : bool

cubrid_lob_send() lee información BLOB/CLOB y la pasa directamente a través del navegador. Para usar esta función se debe utilizar cubrid_lob_get() primero para obtener información BLOB/CLOB desde CUBRID.

Parámetros

conn_identifier

Identificador de conexión.

lob_identifier

Identificador LOB.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob_send()

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");

cubrid_lob_send($conn, $lobs[0]);
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ver también

  • cubrid_lob_get() - Obtener información BLOB/CLOB
  • cubrid_lob_close() - Cerrar información BLOB/CLOB
  • cubrid_lob_size() - Obtener el tamaño de datos BLOB/CLOB
  • cubrid_lob_export() - Exportar datos BLOB/CLOB a un fichero


Obtener el tamaño de datos BLOB/CLOB

  • « cubrid_lob_send
  • cubrid_lob2_bind »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el tamaño de datos BLOB/CLOB

cubrid_lob_size

(PECL CUBRID >= 8.3.1)

cubrid_lob_size — Obtener el tamaño de datos BLOB/CLOB

Descripción

cubrid_lob_size ( resource $lob_identifier ) : string

cubrid_lob_size() se usa para obtener el tamaño de datos BLOB/CLOB.

Parámetros

lob_identifier

Identificador LOB.

Valores devueltos

Un string representando el tamaño de datos LOB, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Historial de cambios

Versión | Descripción
8.4.0 | Cambia el tipo de valor de retorno de int a string.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob_size()

<?php
$lobs = cubrid_lob_get($con, "SELECT doc_content FROM doc WHERE doc_id=5");
echo "Tamño del documento:".cubrid_lob_size($lobs[0]);
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
?>

Ver también

  • cubrid_lob_get() - Obtener información BLOB/CLOB
  • cubrid_lob_close() - Cerrar información BLOB/CLOB
  • cubrid_lob_export() - Exportar datos BLOB/CLOB a un fichero
  • cubrid_lob_send() - Leer información BLOB/CLOB y enviarla directamente al navegador


Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros

  • « cubrid_lob_size
  • cubrid_lob2_close »
  • PHP Manual
  • Funciones de CUBRID
  • Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros

cubrid_lob2_bind

(PECL CUBRID >= 8.4.1)

cubrid_lob2_bind — Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros

Descripción

cubrid_lob2_bind ( resource $req_identifier , int $bind_index , mixed $bind_value , string $bind_value_type = ? ) : bool

La función cubrid_lob2_bind() se usa para vincular datos BLOB/CLOB a un parámetro de sustitución de signo de interrogación correspondiente en la sentencia SQL que fue pasada a cubrid_prepare(). Si bind_value_type no se proporciona, el string será "BLOB" de manera predeterminada. Pero si se usa antes cubrid_lob2_new(), bind_value_type será consistente con type en cubrid_lob2_new() de manera predeterminada.

Parámetros

req_identifier

Un identificador de petición, como un resultado de cubrid_prepare().

bind_index

La ubicacaión de los parámetros de vinculación. Comienza en 1.

bind_value

El valor real para la vinculación.

bind_value_type

Debe ser "BLOB" o "CLOB" y no distingue mayúsculas/minúsculas. Si no se proporciona, el valor predeterminado es "BLOB".

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob2_bind()

<?php
// Tabla: test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");

$petición = cubrid_prepare($conexión, "INSERT INTO test_lob VALUES (?, ?)");

cubrid_bind($petición,1, 3);

$lob = cubrid_lob2_new($conexión, 'CLOB');
cubrid_lob2_bind($petición, 2, $lob);

cubrid_execute($petición);

cubrid_bind($petición, 1, 4);

cubrid_lob2_bind($petición, 2, 'CUBRID LOB2 TEST', 'CLOB');

cubrid_execute($petición);

cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_new() - Crea un objeto LOB
  • cubrid_lob2_close() - Cierra un objeto LOB


Cierra un objeto LOB

  • « cubrid_lob2_bind
  • cubrid_lob2_export »
  • PHP Manual
  • Funciones de CUBRID
  • Cierra un objeto LOB

cubrid_lob2_close

(PECL CUBRID >= 8.4.1)

cubrid_lob2_close — Cierra un objeto LOB

Descripción

cubrid_lob2_close ( resource $lob_identifier ) : bool

La función cubrid_lob2_close() se usa para cerra un objeto LOB devuelveto por cubrid_lob2_new() u obtenido de un conjunto de resultados.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

Valores devueltos

true, en caso de éxito.

false, en caso de error.

Ver también

  • cubrid_lob2_new() - Crea un objeto LOB


Exporta un objeto LOB a un fichero

  • « cubrid_lob2_close
  • cubrid_lob2_import »
  • PHP Manual
  • Funciones de CUBRID
  • Exporta un objeto LOB a un fichero

cubrid_lob2_export

(PECL CUBRID >= 8.4.1)

cubrid_lob2_export — Exporta un objeto LOB a un fichero

Descripción

cubrid_lob2_export ( resource $lob_identifier , string $file_name ) : bool

La función cubrid_lob2_export() se usa para guardar el contenido de datos BLOB/CLOB en un fichero. Para usar esta función se debe utilizar cubrid_lob2_new() u obtener primero un objeto LOB desde la base de datos de CUBRID. Si el fichero ya existe, la operación fallará. Esta función no influenciará en la posición del cursor del objeto LOB. Opera sobre el objeto LOB entero.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

filename

El nombre del fichero donde se quieren almacenar los datos BLOB/CLOB. También admite la ruta del fichero.

Valores devueltos

true si el proceso tiene éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob2_export()

<?php
// Tabla: test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists doc");
cubrid_execute($conexión,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conexión,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$petición = cubrid_prepare($conexión, "select * from doc");

cubrid_execute($petición);

cubrid_move_cursor($petición, 1, CUBRID_CURSOR_FIRST);

$fila = cubrid_fetch($petición, CUBRID_NUM | CUBRID_LOB);

cubrid_lob2_export($fila[1], "doc_3.txt");

cubrid_lob2_close($fila[1]);
cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_new() - Crea un objeto LOB
  • cubrid_lob2_close() - Cierra un objeto LOB
  • cubrid_lob2_import() - Importa datos BLOB/CLOB desde un fichero
  • cubrid_lob2_bind() - Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros


Importa datos BLOB/CLOB desde un fichero

  • « cubrid_lob2_export
  • cubrid_lob2_new »
  • PHP Manual
  • Funciones de CUBRID
  • Importa datos BLOB/CLOB desde un fichero

cubrid_lob2_import

(PECL CUBRID >= 8.4.1)

cubrid_lob2_import — Importa datos BLOB/CLOB desde un fichero

Descripción

cubrid_lob2_import ( resource $lob_identifier , string $file_name ) : bool

La función cubrid_lob2_export() se usa para guardar el contenido de datos BLOB/CLOB desde un fichero. Para usar esta función se debe utilizar cubrid_lob2_new() u obtener primero un objeto LOB desde la base de datos de CUBRID. Si el fichero ya existe, la operación fallará. Esta función no influenciará en la posición del cursor del objeto LOB. Opera sobre el objeto LOB entero.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

filename

El nombre del fichero desde donde se quieren importar los datos BLOB/CLOB. También admite la ruta del fichero.

Valores devueltos

true si el proceso tiene éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob2_export()

<?php

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");

$petición = cubrid_prepare($conexión, "INSERT INTO test_lob (?, ?)");
cubrid_bind($petición, 1, 1);

$lob = cubrid_lob2_new($conexión, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($petición, 2, $lob, 'CLOB'); // or cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($petición);

cubrid_lob2_close($lob);
cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_new() - Crea un objeto LOB
  • cubrid_lob2_close() - Cierra un objeto LOB
  • cubrid_lob2_export() - Exporta un objeto LOB a un fichero
  • cubrid_lob2_bind() - Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros


Crea un objeto LOB

  • « cubrid_lob2_import
  • cubrid_lob2_read »
  • PHP Manual
  • Funciones de CUBRID
  • Crea un objeto LOB

cubrid_lob2_new

(PECL CUBRID >= 8.4.1)

cubrid_lob2_new — Crea un objeto LOB

Descripción

cubrid_lob2_new ( resource $conn_identifier = ? , string $type = "BLOB" ) : resource

La función cubrid_lob2_new() se usa para crear un objeto LOB (BLOB y CLOB). Se debería usar esta función antes de vincular un objeto LOB.

Parámetros

conn_identifier

Un identificador de conexión. Si no se especifica un identificador de conexión, se asumirá la última conexión abierte mediante cubrid_connect() o cubrid_connect_with_url().

type

Puede ser "BLOB" o "CLOB", y no distingue mayúsculas/minúsculas. El valor predeterminado es "BLOB".

Valores devueltos

Un identificador de LOB cuando tiene éxito.

false en caso de error.

Ver también

  • cubrid_lob2_close() - Cierra un objeto LOB


Lee desde datos BLOB/CLOB

  • « cubrid_lob2_new
  • cubrid_lob2_seek64 »
  • PHP Manual
  • Funciones de CUBRID
  • Lee desde datos BLOB/CLOB

cubrid_lob2_read

(PECL CUBRID >= 8.4.1)

cubrid_lob2_read — Lee desde datos BLOB/CLOB

Descripción

cubrid_lob2_read ( resource $lob_identifier , int $len ) : string

La función cubrid_lob2_read() lee len bytes desde los datos LOB y devuelve los biytes leídos.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

len

La longitud del búfer del cual se quieren leer los datos LOB.

Valores devueltos

Devuelve el contenido, en forma de string.

false cuando no hay más datos.

NULL en caso de error.

Ejemplos

Ejemplo #1 Ejemplo 1 de cubrid_lob2_read()

<?php
// test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "public", "");

$petición = cubrid_execute($conexión, "select * from test_lob");

$fila = cubrid_fetch_row($petición, CUBRID_LOB);

print "La posción ahora es " . cubrid_lob2_tell($fila[1]) . "\n";

cubrid_lob2_seek($fila[1], 10, CUBRID_CURSOR_FIRST);

print "\nLa posición después de avanzar es " . cubrid_lob2_tell($fila[1]) . "\n";

$datos = cubrid_lob2_read($fila[1], 12);

print "\nLa posición después de leer es " . cubrid_lob2_tell($fila[1]) . "\n";

print $datos . "\n";

cubrid_lob2_seek($fila[1], 5, CUBRID_CURSOR_CURRENT);

print "\nLa posición después de mover de nuevo es " . cubrid_lob2_tell($fila[1]) . "\n";

$datos = cubrid_lob2_read($fila[1], 20);
print $datos . "\n";

cubrid_disconnect($conexión);
?>

Ejemplo #2 Ejemplo 2 cubrid_lob2_read()

<?php
// test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

$petición = cubrid_execute($conexión, "select * from test_lob");

$fila = cubrid_fetch_row($petición, CUBRID_LOB);

while (true) {
 if ($datos = cubrid_lob2_read($fila[1], 1024)) {
  print $datos . "\n";
 }
 elseif ($datos === false) {
  print "No hay más datos\n";
  break;
 }
 else {
  print "Debe haber algún error\n";
  break;
 }
}

cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Mover el cursor de un objeto LOB

  • « cubrid_lob2_read
  • cubrid_lob2_seek »
  • PHP Manual
  • Funciones de CUBRID
  • Mover el cursor de un objeto LOB

cubrid_lob2_seek64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek64 — Mover el cursor de un objeto LOB

Descripción

cubrid_lob2_seek64 ( resource $lob_identifier , string $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

La función cubrid_lob2_seek64() se usa para mover la posición del cursor de un objeto LOB mediante el valor establecido en el argumento offset, a la dirección establecida en el argumento origin. Si el offset que se quiere mover es mayor que los datos de tipo integer que se puedan almacenar, se puede usar esta función.

Para establecer el argumento origin, se puede usar CUBRID_CURSOR_FIRST para establecer la posición del cursor avanzando offset unidades desde el primer comienzo. En este caso, offset debe ser un valor positivo.

Si se usa CUBRID_CURSOR_CURRENT para origin, se puede avanzar o retroceder, por lo que offset puede ser positivo o negativo.

Si se usa CUBRID_CURSOR_LAST para origin, se puede retroceder offset unidades desde el final del objeto LOB, por lo que offset solamente puede ser positivo.

Nota:

Si se usa esta función para mover la posición del cursor de un objeto LOB, se debería pasar offset como string.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

offset

El número de unidades que se quiere mover el cursor.

origin

Este parámetro admite los siguientes valores:

CUBRID_CURSOR_FIRST: avanzar desde el primer comienzo.

CUBRID_CURSOR_CURRENT: avanzar o retroceder desde la posición actual del cursor.

CUBRID_CURSOR_LAST: retroceder desde el final del objeto LOB.

Valores devueltos

true si el proceso tiene éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob2_seek64()

<?php
// test_lob (id INT, contents CLOB)
// La longitud de los datos de doc_1.txt debería ser mayor que 20101029056306120215.

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");

$petición = cubrid_prepare($conexión, "INSERT INTO test_lob VALUES (?, ?)");
cubrid_bind($petición, 1, 1);

$lob = cubrid_lob2_new($conexión, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($petición, 2, $lob, 'CLOB'); // o cubrid_lob2_bind($petición, 2, $lob);

cubrid_execute($petición);

cubrid_lob2_close($lob);

$petición = cubrid_execute($conexión, "select * from test_lob");
$fila = cubrid_fetch_row($petición, CUBRID_LOB);
$lob = $fila[1];

cubrid_lob2_seek64($lob, "20101029056306120215", CUBRID_CURSOR_FIRST);
$datos = cubrid_lob2_read($lob, 20);
echo $datos."\n";
cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Mover el cursor de un objeto LOB

  • « cubrid_lob2_seek64
  • cubrid_lob2_size64 »
  • PHP Manual
  • Funciones de CUBRID
  • Mover el cursor de un objeto LOB

cubrid_lob2_seek

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek — Mover el cursor de un objeto LOB

Descripción

cubrid_lob2_seek ( resource $lob_identifier , int $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

La función cubrid_lob2_seek() se usa para mover la posición del cursor de un objeto LOB mediante el valor establecido en el argumento offset, a la dirección establecida en el argumento origin.

Para establecer el argumento origin, se puede usar CUBRID_CURSOR_FIRST para establecer la posición del cursor avanzando offset unidades desde el primer comienzo. En este caso, offset debe ser un valor positivo.

Si se usa CUBRID_CURSOR_CURRENT para origin, se puede avanzar o retroceder, por lo que offset puede ser positivo o negativo.

Si se usa CUBRID_CURSOR_LAST para origin, se puede retroceder offset unidades desde el final del objeto LOB, por lo que offset solamente puede ser positivo.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

offset

El número de unidades que se quiere mover el cursor.

origin

Este parámetro admite los siguientes valores:

CUBRID_CURSOR_FIRST: avanzar desde el primer comienzo.

CUBRID_CURSOR_CURRENT: avanzar o retroceder desde la posición actual del cursor.

CUBRID_CURSOR_LAST: retroceder desde el final del objeto LOB.

Valores devueltos

true si el proceso tiene éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lob2_seek()

<?php
// test_lob (id INT, contents CLOB)
$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");
$petición = cubrid_prepare($conexión, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conexión, 'CLOB');
$longitud = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_seek($lob, 0, CUBRID_CURSOR_LAST);
cubrid_lob2_write($lob, "beautiful");

cubrid_lob2_seek($lob, 15, CUBRID_CURSOR_FIRST);
$datos = cubrid_lob2_read($lob, 5);

echo $datos."\n";

cubrid_lob2_bind($petición, 1, $lob);
cubrid_execute($petición);

cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Obtiene el tamaño de un objeto LOB

  • « cubrid_lob2_seek
  • cubrid_lob2_size »
  • PHP Manual
  • Funciones de CUBRID
  • Obtiene el tamaño de un objeto LOB

cubrid_lob2_size64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size64 — Obtiene el tamaño de un objeto LOB

Descripción

cubrid_lob2_size64 ( resource $lob_identifier ) : string

La función cubrid_lob2_size64() se usa para obtener el tamaño de un objeto LOB. Si el tamaño del objeto LOB es mayor que los datos de tipo integer que se pueden almacenar, se puede usar esta función para devolver el tamaño como string.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

Valores devueltos

Devuelve el tamaño del objeto LOB como string cuando el proceso tiene éxito.

false en caso de error.

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB


Obtiene el tamaño de un objeto LOB

  • « cubrid_lob2_size64
  • cubrid_lob2_tell64 »
  • PHP Manual
  • Funciones de CUBRID
  • Obtiene el tamaño de un objeto LOB

cubrid_lob2_size

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size — Obtiene el tamaño de un objeto LOB

Descripción

cubrid_lob2_size ( resource $lob_identifier ) : int

La función cubrid_lob2_size() se usa para obtener el tamaño de un objeto LOB.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

Valores devueltos

Devuelve el tamaño del objeto LOB cuando el proceso tiene éxito.

false en caso de error.

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Indica la posición del cursor de un objeto LOB

  • « cubrid_lob2_size
  • cubrid_lob2_tell »
  • PHP Manual
  • Funciones de CUBRID
  • Indica la posición del cursor de un objeto LOB

cubrid_lob2_tell64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell64 — Indica la posición del cursor de un objeto LOB

Descripción

cubrid_lob2_tell64 ( resource $lob_identifier ) : string

La función cubrid_lob2_tell64() se usa para indicar la posición del cursor de un objeto LOB. Si el tamaño del objeto LOB es mayor que los datos de tipo integer que se puedan almacenar, se puede usar esta función para devolver la información de la posición como string.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

Valores devueltos

Devuelve la posición del cursor de un objeto LOB como string cuando el proceso tiene éxito.

false en caso de error.

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Indica la posición del cursor de un objeto LOB

  • « cubrid_lob2_tell64
  • cubrid_lob2_write »
  • PHP Manual
  • Funciones de CUBRID
  • Indica la posición del cursor de un objeto LOB

cubrid_lob2_tell

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell — Indica la posición del cursor de un objeto LOB

Descripción

cubrid_lob2_tell ( resource $lob_identifier ) : int

La función cubrid_lob2_tell() se usa para indicar la posición del cursor de un objeto LOB.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

Valores devueltos

devuelve la posición del cursor del objeto LOB cuando el proceso tiene éxito.

false en caso de error.

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_write() - Escribe en un objeto LOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Escribe en un objeto LOB

  • « cubrid_lob2_tell
  • cubrid_lock_read »
  • PHP Manual
  • Funciones de CUBRID
  • Escribe en un objeto LOB

cubrid_lob2_write

(PECL CUBRID >= 8.4.1)

cubrid_lob2_write — Escribe en un objeto LOB

Descripción

cubrid_lob2_write ( resource $lob_identifier , string $buf ) : bool

La función cubrid_lob2_write() lee datos de buf y los almacena en el objeto LOB. Observe que esta función solamente agrega caracteres, por ahora.

Parámetros

lob_identifier

Un identificador de LOB, como un resultado de cubrid_lob2_new() u obtenido de un conjunto de resultados.

buf

Los datos que se necesitan escribir en el objeto LOB.

Valores devueltos

true si el proceso tiene éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo 1 de cubrid_lob2_write()

<?php
// test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");

$petición = cubrid_prepare($conexión, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conexión, 'CLOB');
$longitud = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_bind($petición, 1, $lob);
cubrid_execute($petición);

cubrid_disconnect($conexión);
?>

Ejemplo #2 Ejemplo 2 de cubrid_lob2_write()

<?php
// test_lob (id INT, contents CLOB)

$conexión = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conexión,"DROP TABLE if exists test_lob");
cubrid_execute($conexión,"CREATE TABLE test_lob (id INT, contents CLOB)");

$petición = cubrid_prepare($conexión, "INSERT INTO test_lob VALUES(1, ?)");
$lob1 = cubrid_lob2_new($conexión, 'CLOB');
$len = cubrid_lob2_write($lob1, "cubrid php driver");
cubrid_lob2_bind($petición, 1, $lob1);
cubrid_execute($petición);

$petición = cubrid_execute($conexión, "select * from test_lob");

$fila = cubrid_fetch_row($petición, CUBRID_LOB);
$lob2 = $fila[1];
cubrid_lob2_seek($lob2, 0, CUBRID_CURSOR_LAST);

$pos = cubrid_lob2_tell($lob2);
print "posición antes de la escritura: $pos\n";

cubrid_lob2_write($lob2, "Hola mundo");

$pos = cubrid_lob2_tell($lob2);
print "posición después de la escritura: $pos\n";

cubrid_disconnect($conexión);
?>

Ver también

  • cubrid_lob2_read() - Lee desde datos BLOB/CLOB
  • cubrid_lob2_seek() - Mover el cursor de un objeto LOB
  • cubrid_lob2_seek64() - Mover el cursor de un objeto LOB
  • cubrid_lob2_tell() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_tell64() - Indica la posición del cursor de un objeto LOB
  • cubrid_lob2_size() - Obtiene el tamaño de un objeto LOB
  • cubrid_lob2_size64() - Obtiene el tamaño de un objeto LOB


Establecer un bloqueo de lectura sobre el OID dado

  • « cubrid_lob2_write
  • cubrid_lock_write »
  • PHP Manual
  • Funciones de CUBRID
  • Establecer un bloqueo de lectura sobre el OID dado

cubrid_lock_read

(PECL CUBRID >= 8.3.0)

cubrid_lock_read — Establecer un bloqueo de lectura sobre el OID dado

Descripción

cubrid_lock_read ( resource $conn_identifier , string $oid ) : bool

La función cubrid_lock_read() se usa para poner el bloqueo de lectura en la instancia apuntada por el oid dado.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia en la que se quiere porner el bloqueo de lectura.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lock_read()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_read($conn, $oid);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

Ver también

  • cubrid_lock_write() - Establecer un bloqueo de escritura para el OID dado


Establecer un bloqueo de escritura para el OID dado

  • « cubrid_lock_read
  • cubrid_move_cursor »
  • PHP Manual
  • Funciones de CUBRID
  • Establecer un bloqueo de escritura para el OID dado

cubrid_lock_write

(PECL CUBRID >= 8.3.0)

cubrid_lock_write — Establecer un bloqueo de escritura para el OID dado

Descripción

cubrid_lock_write ( resource $conn_identifier , string $oid ) : bool

La función cubrid_lock_write() se usa para poner el bloqueo de escritura en la instancia apuntada por el oid dado.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia en la que se quiere poner el bloqueo de escritura.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_lock_write()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_write($conn, $oid);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

Ver también

  • cubrid_lock_read() - Establecer un bloqueo de lectura sobre el OID dado


Mover el cursor en el resultado

  • « cubrid_lock_write
  • cubrid_next_result »
  • PHP Manual
  • Funciones de CUBRID
  • Mover el cursor en el resultado

cubrid_move_cursor

(PECL CUBRID >= 8.3.0)

cubrid_move_cursor — Mover el cursor en el resultado

Descripción

cubrid_move_cursor ( resource $req_identifier , int $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

La función cubrid_move_cursor() se usa para mover la posición del cursor actual de req_handle por el valor establecido en el argumento offset, a la dirección establecida en el argumento origin. Para establecer el argumento origin se puede usar CUBRID_CURSOR_FIRST como primera parte del resultado, CUBRID_CURSOR_CURRENT como la posición actual del resultado, o CUBRID_CURSOR_LAST como la última parte del resultado. Si el argumento origin no es designado explícitamente, la función usa CUBRID_CURSOR_CURRENT como valor predeterminado.

Si el valor del alcance de movimiento del cursor se sale del límite válido, el cursor se mueve a la siguiente posición después del alcance válido del cursor. Por ejemplo, si se mueve 20 unidades en un resultado cuyo tamaño es 10, el cursor se moverá al lugar 11 y devolverá CUBRID_NO_MORE_DATA.

Parámetros

req_identifier

Identificador de solicitud.

offset

Número de unidades que se quiere mover el cursor.

origin

Posición donde se quiere mover el cursor desde CUBRID_CURSOR_FIRST, CUBRID_CURSOR_CURRENT, CUBRID_CURSOR_LAST.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_move_cursor()

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_move_cursor($req, 1, CUBRID_CURSOR_LAST);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_CURRENT);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  string(1) "G"
  [1]=>
  string(4) "Gold"
}
array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL

  • « cubrid_move_cursor
  • cubrid_num_cols »
  • PHP Manual
  • Funciones de CUBRID
  • Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL

cubrid_next_result

(PECL CUBRID >= 8.4.0)

cubrid_next_result — Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL

Descripción

cubrid_next_result ( resource $result ) : bool

La función cubrid_next_result() se utiliza para obtener resultados de la consulta siguiente, si varias instrucciones SQL se ejecutan y CUBRID_EXEC_QUERY_ALL y la bandera cubrid_execute() esta establecida como activa.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

Valores devueltos

true, cuando el proceso ha sido exitoso.

false, cuando el proceso no fué exitoso.

Ejemplos

Ejemplo #1 cubrid_next_result() ejemplo

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$sql_stmt = "SELECT * FROM code; SELECT * FROM history WHERE host_year=2004 AND event_code=20281";
$res = cubrid_execute($conn, $sql_stmt, CUBRID_EXEC_QUERY_ALL);

get_result_info($res);
cubrid_next_result($res);
get_result_info($res);

function get_result_info($req)
{
    printf("\n------------ get_result_info --------------------\n");

    $row_num = cubrid_num_rows($req);
    $col_num = cubrid_num_cols($req);

    $column_name_list = cubrid_column_names($req);
    $column_type_list = cubrid_column_types($req);

    $column_last_name = cubrid_field_name($req, $col_num - 1);
    $column_last_table = cubrid_field_table($req, $col_num - 1);

    $column_last_type = cubrid_field_type($req, $col_num - 1);
    $column_last_len = cubrid_field_len($req, $col_num - 1);

    $column_1_flags = cubrid_field_flags($req, 1);

    printf("%-30s %d\n", "Row count:", $row_num);
    printf("%-30s %d\n", "Column count:", $col_num);
    printf("\n");

    printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Len");
    printf("------------------------------------------------------------------------------\n");

    $size = count($column_name_list);
    for($i = 0; $i < $size; $i++) {
        $column_len = cubrid_field_len($req, $i);
        printf("%-30s %-30s %-15s\n", $column_name_list[$i], $column_type_list[$i], $column_len);
    }
    printf("\n\n");

    printf("%-30s %s\n", "Last Column Name:", $column_last_name);
    printf("%-30s %s\n", "Last Column Table:", $column_last_table);
    printf("%-30s %s\n", "Last Column Type:", $column_last_type);
    printf("%-30s %d\n", "Last Column Len:", $column_last_len);
    printf("%-30s %s\n", "Second Column Flags:", $column_1_flags);

    printf("\n\n");
}
?>

El resultado del ejemplo sería:

------------ get_result_info --------------------
Row count:                     6
Column count:                  2

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
s_name                         char                           1
f_name                         varchar                        6

Last Column Name:              f_name
Last Column Table:             code
Last Column Type:              varchar
Last Column Len:               6
Second Column Flags:

------------ get_result_info --------------------
Row count:                     4
Column count:                  5

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
event_code                     integer                        11
athlete                        varchar                        40
host_year                      integer                        11
score                          varchar                        10
unit                           varchar                        5

Last Column Name:              unit
Last Column Table:             history
Last Column Type:              varchar
Last Column Len:               5
Second Column Flags:           not_null primary_key unique_key

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Devolver el número de columnas del conjunto de resultados

  • « cubrid_next_result
  • cubrid_num_rows »
  • PHP Manual
  • Funciones de CUBRID
  • Devolver el número de columnas del conjunto de resultados

cubrid_num_cols

(PECL CUBRID >= 8.3.0)

cubrid_num_cols — Devolver el número de columnas del conjunto de resultados

Descripción

cubrid_num_cols ( resource $result ) : int

La función cubrid_num_cols() se usa para obtener el número de columnas del resultado de la consulta. Se puede usar sólo cuando la consulta ejecutada es una sentencia SELECT.

Parámetros

result

El resultado.

Valores devueltos

El número de columnas, cuando el proceso tiene éxito.

false, si la sentencia SQL no es SELECT.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_num_cols()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Row Num: 6
Column Num: 2

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_num_rows() - Obtener el número de filas del conjunto de resultados


Obtener el número de filas del conjunto de resultados

  • « cubrid_num_cols
  • cubrid_pconnect_with_url »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener el número de filas del conjunto de resultados

cubrid_num_rows

(PECL CUBRID >= 8.3.0)

cubrid_num_rows — Obtener el número de filas del conjunto de resultados

Descripción

cubrid_num_rows ( resource $result ) : int

La función cubrid_num_rows() se usa para obtener el número de filas del resultado de la consulta. Se puede usar sólo cuando la consulta ejecutada es una sentencia SELECT. Cuando se quiere conocer dicho valor para consultas INSERT, UPDATE, o DELETE, se tiene que usar la función cubrid_affected_rows().

Nota: La función cubrid_num_rows() sólo puede ser usada para consultas síncronas; devuelve 0 cuando se usa para consultas asíncronas.

Parámetros

result

result viene de una llamada a cubrid_execute(), cubrid_query() y cubrid_prepare()

Valores devueltos

El número de filas, cuando el proceso tiene éxito.

0 cuando la consulta fue hecha en modo asíncrono.

-1, si la sentencia SQL no es SELECT.

false cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_num_rows()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Row Num: 6
Column Num: 2

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_num_cols() - Devolver el número de columnas del conjunto de resultados
  • cubrid_affected_rows() - Devolver el número de filas afectadas por la última sentencia SQL


Abrir una conexión persistente al servidor CUBRID

  • « cubrid_num_rows
  • cubrid_pconnect »
  • PHP Manual
  • Funciones de CUBRID
  • Abrir una conexión persistente al servidor CUBRID

cubrid_pconnect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_pconnect_with_url — Abrir una conexión persistente al servidor CUBRID

Descripción

cubrid_pconnect_with_url ( string $conn_url , string $userid = ? , string $passwd = ? ) : resource

Establece una conexión persistente a un servidor CUBRID.

cubrid_pconnect_with_url() actúa de manera muy similar a cubrid_connect_with_url() con dos diferencias importantes.

Primera, al conectar, la función intenta encontrar un enlace (persistente) que ya estuviera abierto con el mismo host, puerto, nombre de base de datos e id de usuario. Si se encuentra uno, se devolverá un identificador para él en lugar de abrir una nueva conexión.

Segunda, la conexión al servidor SQL no se cerrará cuando la
ejecución del script termine. En su lugar, el enlace permanece abierto para
usos futuros (cubrid_close() o
cubrid_disconnect() no cerrarán enlaces establecido por
cubrid_pconnect_with_url()).

Por eso a este tipo de enlace se le llama 'persistente'.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : Un nombre de host o dirección IP de la base de datos maestra
  • db_name : Un nombre de la base de datos
  • db_user : Un nombre del usuario de la base de datos
  • db_password : Una contraseña de usuario de la base de datos
  • alhosts: Especifica la información del agente del servidor de emergencia, el cual se usa para la recuperación de fallos cuando es imposible conectar al servidor activo. Se pueden especificar múltiples agentes para la recuperación de fallos, y la conexión a los agentes se intenta en el orden listado en alhosts
  • rctime : Un intervalo entre los intentos de conexión al agente activo en el que ocurrió el fallo. Después de que ocurra un fallo, el sistema se conecta al agente especificado por althosts (recuperación de fallos), finaliza la transacción, y después intenta conectarse al agente activo de la base de datos maestra cada rctime. El valor predeterminado es 600 segundos.
  • login_timeout : Valor de tiempo de espera (unidad: mseg.) para la identificación en la base de datos. El valor predeterminado es 0, lo que significa un aplazamiento infinito.
  • query_timeout : Valor de tiempo de espera (unidad: mseg.) para la solicitud de consulta. Cuando finaliza el tiempo de espera, se envía al servidor un mensaje para cancelar la transferencia de la consulta. El valor devuelto puede depender de de la configuración de disconnect_on_query_timeout; incluso si el mensaje para cancelar una petición es enviado al servidor, tal peticioón puede realizarse.
  • disconnect_on_query_timeout : Configura un valor para establecer si devolver inmediantamente un error de función que está siendo ejecutada al finalizar el tiempo de espera. El valor predeterminado es false.

Nota:

? y :, que son usados como identificadores en el URL de conexión de PHP, no pueden ser incluidos en la contraseña. El siguiente es un ejemplo de una contraseña que no es válida para usarla como URL de conexión ya que contiene "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Las contraseñas que contengan ? o : se pueden pasar como un parámetro aparte.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_pconnect_with_url ($url, "dba", "12?");

Si el usuario o la contraseña están vacíos no se podrá borrar ":". He aquí un ejemplo:

$url = "CUBRID:localhost:33000:demodb:::";

Parámetros

conn_url

Una cadena de caracteres que contiene la información de conexión al servidor.

userid

El nombre de usuario de la base de datos.

passwd

La contraseña del usuario.

Valores devueltos

El identificador de conexión, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de url de cubrid_pconnect_with_url() sin propiedades

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "Se conectó con éxito";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

Ejemplo #2 Ejemplo de url de cubrid_pconnect_with_url() con propiedades

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?althost=10.34.63.132:33088&rctime=100"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "Se conectó con éxito";
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

Ver también

  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_connect_with_url() - Establecer el entorno para la conexión al servidor de CUBRID
  • cubrid_pconnect() - Abrir una conexión persistente a un servidor CUBRID
  • cubrid_disconnect() - Cerrar una conexión a una base de datos
  • cubrid_close() - Cerrar la conexión de CUBRID


Abrir una conexión persistente a un servidor CUBRID

  • « cubrid_pconnect_with_url
  • cubrid_prepare »
  • PHP Manual
  • Funciones de CUBRID
  • Abrir una conexión persistente a un servidor CUBRID

cubrid_pconnect

(PECL CUBRID >= 8.3.1)

cubrid_pconnect — Abrir una conexión persistente a un servidor CUBRID

Descripción

cubrid_pconnect ( string $host , int $port , string $dbname , string $userid = ? , string $passwd = ? ) : resource

Establece una conexión persistente a un servidor CUBRID.

cubrid_pconnect() actúa de manera muy similar a cubrid_connect() con dos diferencias importantes.

Primera, al conectar, la función intenta encontrar un enlace (persistente) que ya estuviera abierto con el mismo host, puerto, nombre de base de datos e id de usuario. Si se encuentra uno, se devolverá un identificador para él en lugar de abrir una nueva conexión.

Segunda, la conexión al servidor SQL no se cerrará cuando la
ejecución del script termine. En su lugar, el enlace permanece abierto para
usos futuros (cubrid_close() o
cubrid_disconnect() no cerrarán enlaces establecido por
cubrid_pconnect_with_url()).

Por eso a este tipo de enlace se le llama 'persistente'.

Parámetros

host

Nombre del host o dirección IP del servidor CAS de CUBRID.

port

Número de puerto del servidor CAS de CUBRID (BROKER_PORT configurado en $CUBRID/conf/cubrid_broker.conf).

dbname

Nombre de la base de datos.

userid

Nombre de usuario para la base de datos.

passwd

Contraseña del usuario.

Valores devueltos

El identificador de conexión, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_pconnect()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_pconnect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ver también

  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_connect_with_url() - Establecer el entorno para la conexión al servidor de CUBRID
  • cubrid_pconnect_with_url() - Abrir una conexión persistente al servidor CUBRID
  • cubrid_disconnect() - Cerrar una conexión a una base de datos
  • cubrid_close() - Cerrar la conexión de CUBRID


Preparar una sentencia SQL para su ejecución

  • « cubrid_pconnect
  • cubrid_put »
  • PHP Manual
  • Funciones de CUBRID
  • Preparar una sentencia SQL para su ejecución

cubrid_prepare

(PECL CUBRID >= 8.3.0)

cubrid_prepare — Preparar una sentencia SQL para su ejecución

Descripción

cubrid_prepare ( resource $conn_identifier , string $prepare_stmt , int $option = 0 ) : resource

La función cubrid_prepare() es un tipo de API que representa sentencias SQL compiladas previamente para un gestor de conexión dado. Estas sentencias SQL precompiladas serán incluidas en la función cubrid_prepare().

Por consiguiente, se puede usar esta sentencia para ejecutar repetidamente o procesar datos grandes. Sólo se puede usar una única sentencia y se puede poner un signo de interrogación (?) en un parámetro en el área apropiada de una senciencia SQL. Añada un parámetro cuando vincule un valor en la cláusula VALUES de la sentencia INSERT o en la cláusula WHERE. Observe que está permitido vincular un valor a MARK(?) sólo mediante cubrid_bind().

Parámetros

conn_identifier

Identificador de conexión.

prepare_stmt

Consulta preparada.

option

OID devuelto por la opción CUBRID_INCLUDE_OID.

Valores devueltos

Identificador de solicitud, si el proceso tiene éxito;

false, si el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_prepare()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT g.event_code, e.name
FROM game g
JOIN event e ON g.event_code=e.code
WHERE host_year = ? AND event_code NOT IN (SELECT event_code FROM game WHERE host_year=?) GROUP BY event_code;
EOD;

$req = cubrid_prepare($conn, $sql);

cubrid_bind($req, 1, 2004);
cubrid_bind($req, 2, 2000);
cubrid_execute($req);

$row_num = cubrid_num_rows($req);
printf("Hay %d eventos que existen en las olimpiadas 2004 pero no en las del 2000. Por ejemplo:\n\n", $row_num);

printf("%-15s %s\n", "Event_code", "Event_name");
printf("----------------------------\n");

$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);
$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Hay 27 eventos que existen en las olimpiadas 2004 pero no en las del 2000. Por ejemplo:

Event_code      Event_name
----------------------------
20063           +91kg
20070           64kg

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_bind() - Vincular variables para una sentencia preparada como parámetros


Actualizar un atributo usando OID

  • « cubrid_prepare
  • cubrid_rollback »
  • PHP Manual
  • Funciones de CUBRID
  • Actualizar un atributo usando OID

cubrid_put

(PECL CUBRID >= 8.3.0)

cubrid_put — Actualizar un atributo usando OID

Descripción

cubrid_put ( resource $conn_identifier , string $oid , string $attr = ? , mixed $value ) : bool

La función cubrid_put() se usa para actualizar un atributo de la instancia del oid dado.

Se puede actualizar un único atributo usando un tipo de datos de cadena para establecer attr. En tal caso, se puede usar información de tipo entero, coma flotante o cadena para el argumento value. Para actualizar múltiples atributos se puede ignorar el argumento attr, y establecer el argumento value con un array asociativo.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia que se quiere actualizar.

attr

Nombre del atributo que se quiere actualizar.

value

Nuevo valor que se quiere asignar al atributo.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_put()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

Ver también

  • cubrid_get() - Obtener una columna usando OID
  • cubrid_set_add() - Insertar un único elemento en la columna del tipo de conjunto usando OID
  • cubrid_set_drop() - Borrar un elemento de la columna del tipo de conjunto usando OID
  • cubrid_seq_insert() - Insertar un elemento en una columna tipo secuencia usando OID
  • cubrid_seq_drop() - Borrar un elemento de una columna tipo secuencia usando OID
  • cubrid_seq_put() - Actualizar el valor del elemento de la columna de tipo secuencia usando OID


Retroceder una transacción

  • « cubrid_put
  • cubrid_schema »
  • PHP Manual
  • Funciones de CUBRID
  • Retroceder una transacción

cubrid_rollback

(PECL CUBRID >= 8.3.0)

cubrid_rollback — Retroceder una transacción

Descripción

cubrid_rollback ( resource $conn_identifier ) : bool

La función cubrid_rollback() ejecuta un retroceso en la transacción apuntada por conn_handle, actualmente en progreso.

La conexión al servidor se cierra después de llamar a cubrid_rollback(). El gestor de conexión, sin embargo, es todavía válido.

Parámetros

conn_identifier

Identificador de conexión.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_rollback()

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");
cubrid_set_autocommit($conn,false);

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;

if (!cubrid_execute($conn, $sql)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n", cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

Ver también

  • cubrid_commit() - Consigna una transacción
  • cubrid_disconnect() - Cerrar una conexión a una base de datos


Obtener la información del esquema solicitado

  • « cubrid_rollback
  • cubrid_seq_drop »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener la información del esquema solicitado

cubrid_schema

(PECL CUBRID >= 8.3.0)

cubrid_schema — Obtener la información del esquema solicitado

Descripción

cubrid_schema ( resource $conn_identifier , int $schema_type , string $class_name = ? , string $attr_name = ? ) : array

La función cubrid_schema() se usa para obtener la información del esquema solicitado de la base de datos. Se debe designar class_name, si se desea obtener información de ciertas clases, attr_name, si se quiere obtener información de ciertos atributos (sólo se puede usar con CUBRID_ SCH_ATTR_PRIVILEGE).

El resultado de la función cubrid_schema es devuelto como un array de dos dimensiones (columna (array asociativo) * fila (array numérico)). Las siguientes tablas muestran los tipos de esquemas y las estructura de la columna del array resultante para ser devuelto basándose en el tipo de esquema.

Composición del Resultado de Cada Tipo
Esquema | Número de Columna | Nombre de Columna | Valor
CUBRID_SCH_CLASS | 1 | NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_VCLASS | 1 | NAME |
 | 2 | TYPE | 1:vclass
CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
CUBRID_SCH_ATTRIBUTE / CUBRID_SCH_CLASS_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
CUBRID_SCH_METHOD / CUBRID_SCH_CLASS_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
CUBRID_SCH_SUPERCLASS / CUBRID_SCH_DIRECT_SUPER_CLASS / CUBRID_SCH_SUBCLASS | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
CUBRID_SCH_CLASS_PRIVILEGE / CUBRID_SCH_ATTR_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
CUBRID_SCH_IMPORTED_KEYS / CUBRID_SCH_EXPORTED_KEYS / CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

Parámetros

conn_identifier

Identificador de conexión.

schema_type

Información del esquema que se quiere conocer.

class_name

Clase del esquema que se quiere conocer.

attr_name

Atributo del esquema que se quiere conocer.

Valores devueltos

Matriz que contiene la información del esquema, cuando el proceso tiene éxito;

false, cuando el proceso no tiene éxito

Historial de cambios

Versión | Descripción
8.3.1 | Cambio del valor devuelto: cuando el proceso no tiene éxito, devuelve false, no -1.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_schema()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

printf("\n--- Primary Key ---\n");
$pk = cubrid_schema($conn, CUBRID_SCH_PRIMARY_KEY, "game");
var_dump($pk);

printf("\n--- Foreign Keys ---\n");
$fk = cubrid_schema($conn, CUBRID_SCH_IMPORTED_KEYS, "game");
var_dump($fk);

printf("\n--- Column Attribute ---\n");
$attr = cubrid_schema($conn, CUBRID_SCH_ATTRIBUTE, "stadium", "area");
var_dump($attr);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

--- Primary Key ---
array(3) {
  [0]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "3"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [1]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "2"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [2]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(9) "host_year"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
}

--- Foreign Keys ---
array(2) {
  [0]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(7) "athlete"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(20) "fk_game_athlete_code"
    ["PK_NAME"]=>
    string(15) "pk_athlete_code"
  }
  [1]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(5) "event"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(18) "fk_game_event_code"
    ["PK_NAME"]=>
    string(13) "pk_event_code"
  }
}

--- Column Attribute ---
array(1) {
  [0]=>
  array(13) {
    ["ATTR_NAME"]=>
    string(4) "area"
    ["DOMAIN"]=>
    string(1) "7"
    ["SCALE"]=>
    string(1) "2"
    ["PRECISION"]=>
    string(2) "10"
    ["INDEXED"]=>
    string(1) "0"
    ["NON_NULL"]=>
    string(1) "0"
    ["SHARED"]=>
    string(1) "0"
    ["UNIQUE"]=>
    string(1) "0"
    ["DEFAULT"]=>
    NULL
    ["ATTR_ORDER"]=>
    string(1) "4"
    ["CLASS_NAME"]=>
    string(7) "stadium"
    ["SOURCE_CLASS"]=>
    string(7) "stadium"
    ["IS_KEY"]=>
    string(1) "0"
  }
}


Borrar un elemento de una columna tipo secuencia usando OID

  • « cubrid_schema
  • cubrid_seq_insert »
  • PHP Manual
  • Funciones de CUBRID
  • Borrar un elemento de una columna tipo secuencia usando OID

cubrid_seq_drop

(PECL CUBRID >= 8.3.0)

cubrid_seq_drop — Borrar un elemento de una columna tipo secuencia usando OID

Descripción

cubrid_seq_drop ( resource $conn_identifier , string $oid , string $attr_name , int $index ) : bool

La función cubrid_seq_drop() se usa para borrar un elemento que se solicitó desde el atributo de tipo secuencia de la base de datos.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo del que se quiere borrar un elemento.

index

ïndice del elemento que se quiere borrar (basado en 1).

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_seq_drop()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_drop($conn, $oid, "c", 4);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(3) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
}

Ver también

  • cubrid_seq_insert() - Insertar un elemento en una columna tipo secuencia usando OID
  • cubrid_seq_put() - Actualizar el valor del elemento de la columna de tipo secuencia usando OID


Insertar un elemento en una columna tipo secuencia usando OID

  • « cubrid_seq_drop
  • cubrid_seq_put »
  • PHP Manual
  • Funciones de CUBRID
  • Insertar un elemento en una columna tipo secuencia usando OID

cubrid_seq_insert

(PECL CUBRID >= 8.3.0)

cubrid_seq_insert — Insertar un elemento en una columna tipo secuencia usando OID

Descripción

cubrid_seq_insert ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element ) : bool

La función cubrid_col_insert() se usa para insertar un elemento en un atributo de tipo secuencia en la posició solicitada.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo en donde insertar una instancia.

index

Posición del elemento donde se quiere insertar el elemento (basado en 1).

seq_element

Contenido del elemento que se quiere insertar.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_seq_insert()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_insert($conn, $oid, "c", 5, "44");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(5) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
  [4]=>
  string(2) "44"
}

Ver también

  • cubrid_seq_drop() - Borrar un elemento de una columna tipo secuencia usando OID
  • cubrid_seq_put() - Actualizar el valor del elemento de la columna de tipo secuencia usando OID


Actualizar el valor del elemento de la columna de tipo secuencia usando OID

  • « cubrid_seq_insert
  • cubrid_set_add »
  • PHP Manual
  • Funciones de CUBRID
  • Actualizar el valor del elemento de la columna de tipo secuencia usando OID

cubrid_seq_put

(PECL CUBRID >= 8.3.0)

cubrid_seq_put — Actualizar el valor del elemento de la columna de tipo secuencia usando OID

Descripción

cubrid_seq_put ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element ) : bool

La función cubrid_seq_put() se usa para actualizar el contenido del elemento solicitado en un atributo de tipo secuencia usando OID.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo en el que se quiere actualizar un elemento.

index

Índice (basado en 1) del elemento que se quiere actualizar.

seq_element

Nuevo contenido que se quiere usar para la actualización.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_seq_put()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_put($conn, $oid, "c", 1, "111");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(4) {
  [0]=>
  string(3) "111"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}

Ver también

  • cubrid_seq_drop() - Borrar un elemento de una columna tipo secuencia usando OID
  • cubrid_seq_insert() - Insertar un elemento en una columna tipo secuencia usando OID


Insertar un único elemento en la columna del tipo de conjunto usando OID

  • « cubrid_seq_put
  • cubrid_set_autocommit »
  • PHP Manual
  • Funciones de CUBRID
  • Insertar un único elemento en la columna del tipo de conjunto usando OID

cubrid_set_add

(PECL CUBRID >= 8.3.0)

cubrid_set_add — Insertar un único elemento en la columna del tipo de conjunto usando OID

Descripción

cubrid_set_add ( resource $conn_identifier , string $oid , string $attr_name , string $set_element ) : bool

La función cubrid_set_add() se usa para insertar un único elemento en un atributo de tipo de conjunto (conjunto, multiconjunto, secuencia) que se solicitó.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo en donde se quiere insertar un elemento.

set_element

Contenido del elemento que se quiere insertar.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_set_add()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_add($conn, $oid, "b", "4");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(4) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
  [3]=>
  string(1) "4"
}

Ver también

  • cubrid_seq_drop() - Borrar un elemento de una columna tipo secuencia usando OID


Establece el modo de confirmación automática de la conexión

  • « cubrid_set_add
  • cubrid_set_db_parameter »
  • PHP Manual
  • Funciones de CUBRID
  • Establece el modo de confirmación automática de la conexión

cubrid_set_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_set_autocommit — Establece el modo de confirmación automática de la conexión

Descripción

cubrid_set_autocommit ( resource $conn_identifier , bool $mode ) : bool

La función cubrid_set_autocommit() es usada para establecer el modo de confirmación automática de la conexión de base de datos actual.

En CUBRID PHP, el modo de confirmación automática está desactivado por defecto para el manejo de la transacción. Cuando el modo de confirmación automática es encendido, cualquier trabajo pendiente es confirmado automáticamente.

Parámetros

conn_identifier

Identifiador de conexión.

mode

Modo de confirmación automática. Las siguientes constantes podrán ser utilizadas:

  • CUBRID_AUTOCOMMIT_FALSE
  • CUBRID_AUTOCOMMIT_TRUE

Valores devueltos

true, cuando el proceso ha sido exitoso.

false, cuando el proceso no tuvo éxito.

Ver también

  • cubrid_get_autocommit() - Devuelve el modo auto-commit de la conexión
  • cubrid_commit() - Consigna una transacción


Configura los parámetros de la base de datos CUBRID

  • « cubrid_set_autocommit
  • cubrid_set_drop »
  • PHP Manual
  • Funciones de CUBRID
  • Configura los parámetros de la base de datos CUBRID

cubrid_set_db_parameter

(PECL CUBRID >= 8.4.0)

cubrid_set_db_parameter — Configura los parámetros de la base de datos CUBRID

Descripción

cubrid_set_db_parameter ( resource $conn_identifier , int $param_type , int $param_value ) : bool

La función cubrid_set_db_parameter() se utiliza para establecer los parámetros de la base de datos CUBRID. Se pueden configurar los siguientes parámetros de la base de datos CUBRID:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT

Nota:

El modo auto-commit se puede configurar mediante el uso de cubrid_set_autocommit().

Parámetros

conn_identifier

La conexión CUBRID. Si el identificador de conexión no se especifica, se asume el último enlace abierto por cubrid_connect().

param_type

Tipo de parámetro de la base de datos.

param_value

Valor del nivel de aislamiento (1-6) o valor del tiempo de espera de bloqueo (en segundos).

Valores devueltos

true en caso de éxito.

false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_get_db_parameter()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$params = cubrid_get_db_parameter($conn);
var_dump($params);

cubrid_set_autocommit($conn, CUBRID_AUTOCOMMIT_TRUE);
cubrid_set_db_parameter($conn, CUBRID_PARAM_ISOLATION_LEVEL, 2);

$params_new = cubrid_get_db_parameter($conn);
var_dump($params_new);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(3)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(0)
}
array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(2)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(1)
}

Ver también

  • cubrid_get_db_parameter() - Devuelve los parámetros de la base de datos CUBRID
  • cubrid_set_autocommit() - Establece el modo de confirmación automática de la conexión


Borrar un elemento de la columna del tipo de conjunto usando OID

  • « cubrid_set_db_parameter
  • cubrid_set_query_timeout »
  • PHP Manual
  • Funciones de CUBRID
  • Borrar un elemento de la columna del tipo de conjunto usando OID

cubrid_set_drop

(PECL CUBRID >= 8.3.0)

cubrid_set_drop — Borrar un elemento de la columna del tipo de conjunto usando OID

Descripción

cubrid_set_drop ( resource $conn_identifier , string $oid , string $attr_name , string $set_element ) : bool

La función cubrid_set_drop() se usa para borrar un elemento que se solicitó desde el atributo del tipo de conjunto dado (conjunto, multiconjunto) de la base de datos.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia con la que se quiere trabajar.

attr_name

Nombre del atributo del que se quiere borrar un elemento.

set_element

Contenido del elemento que se quiere borrar.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_set_drop()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_drop($conn, $oid, "b", "1");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(2) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "3"
}

Ver también

  • cubrid_set_add() - Insertar un único elemento en la columna del tipo de conjunto usando OID


Establecer el tiempo de espera de la ejecución de consultas

  • « cubrid_set_drop
  • cubrid_version »
  • PHP Manual
  • Funciones de CUBRID
  • Establecer el tiempo de espera de la ejecución de consultas

cubrid_set_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_set_query_timeout — Establecer el tiempo de espera de la ejecución de consultas

Descripción

cubrid_set_query_timeout ( resource $req_identifier , int $timeout ) : bool

La función cubrid_set_query_timeout() se usa para establecer el tiempo de espera de la ejecución de consultas.

Parámetros

req_identifier

Identificador de petición.

timeout

El tiempo de espera, unidades de milisegundos

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ver también

  • cubrid_get_query_timeout() - Obtener el valor del tiempo de espera de consulta de la petición


Obtener la versión del módulo de PHP de CUBRID

  • « cubrid_set_query_timeout
  • Funciones de compatibilidad CUBRID MySQL »
  • PHP Manual
  • Funciones de CUBRID
  • Obtener la versión del módulo de PHP de CUBRID

cubrid_version

(PECL CUBRID >= 8.3.0)

cubrid_version — Obtener la versión del módulo de PHP de CUBRID

Descripción

cubrid_version ( ) : string

La función cubrid_version() se usa para obtener la versión del módulo de PHP de CUBRID.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Información de la versión (p.ej. "8.3.1.0001").

Ejemplos

Ejemplo #1 Ejemplo de cubrid_version()

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

El resultado del ejemplo sería:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ver también

  • cubrid_error_code() - Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_code_facility() - Obtener el código de error del dispositivo


Funciones de compatibilidad CUBRID MySQL

Tabla de contenidos

  • cubrid_affected_rows — Devolver el número de filas afectadas por la última sentencia SQL
  • cubrid_client_encoding — Devuelve el actual conjunto de caracteres de la conexión a CUBRID
  • cubrid_close — Cerrar la conexión de CUBRID
  • cubrid_data_seek — Mueve el puntero interno de la fila del resultado CUBRID
  • cubrid_db_name — Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs
  • cubrid_errno — Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa
  • cubrid_error — Se usa para obtener el mensaje de error
  • cubrid_fetch_array — Extrae una fila como array asociativo, numérico o ambos
  • cubrid_fetch_assoc — Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_fetch_field — Devuelve un objeto con ciertas propiedades
  • cubrid_fetch_lengths — Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual
  • cubrid_fetch_object — Devuelve un objeto con los nombres de las columnas
  • cubrid_fetch_row — Devuelve un array numérico con los valores de la fila actual
  • cubrid_field_flags — Devuelve una cadena con las banderas del índice del campo dado
  • cubrid_field_len — Devuelve la longitud máxima del campo especificado
  • cubrid_field_name — Devuelve el nombre del índice del campo especificado
  • cubrid_field_seek — Mueve el cursor del conjunto de resultados al índece del campo especificado
  • cubrid_field_table — Devuelve el nombre de la tabla del campo especificado
  • cubrid_field_type — Devuelve el tipo de columna que se corresponde con el índice del campo dado
  • cubrid_list_dbs — Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes
  • cubrid_num_fields — Devuelve el número de columnas del conjunto de resultados
  • cubrid_ping — Hacer ping en una conexión al servidor o reconectar si no hay conexión
  • cubrid_query — Enviar una consulta CUBRID
  • cubrid_real_escape_string — Escapar caracteres especiales en una cadena para usarla en una sentencia SQL
  • cubrid_result — Devuelve el valor de un campo específico de una fila específica
  • cubrid_unbuffered_query — Realiza una consulta sin traer los resultados a memoria


Devolver el número de filas afectadas por la última sentencia SQL

  • « Funciones de compatibilidad CUBRID MySQL
  • cubrid_client_encoding »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devolver el número de filas afectadas por la última sentencia SQL

cubrid_affected_rows

(PECL CUBRID >= 8.3.0)

cubrid_affected_rows — Devolver el número de filas afectadas por la última sentencia SQL

Descripción

cubrid_affected_rows ( resource $conn_identifier = ? ) : int
cubrid_affected_rows ( resource $req_identifier = ? ) : int

La función cubrid_affected_rows() se usa para obtener el número de filas afectadas por la última sentencia SQL (INSERT, DELETE, UPDATE).

Parámetros

conn_identifier

La conexión CUBRID. Si no se especifica el identificador de conexión, se asume el último enlace abierto por cubrid_connect().

req_identifier

Identificador de petición. Podría ser devuelto desde cubrid_prepare() o cubrid_execute(). Si el identificador de petición no se especifica, se asume el último identificador solicitado por cubrid_prepare() o cubrid_execute().

Valores devueltos

El número de filas afectadas por la sentencia SQL, cuando el proceso tiene éxito.

-1, cuando la sentencia SQL no es INSERT, DELETE o UPDATE.

false, cuando el identificador de solicitud no está especificado, y no existe una última petición.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_affected_rows()

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
cubrid_execute($conn, "DROP TABLE IF EXISTS cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d varchar)");
$sql_stmt = "INSERT INTO cubrid_test(d) VALUES('php-test')";
$req = cubrid_prepare($conn, $sql_stmt);

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($req);
}
cubrid_commit($conn);

$req = cubrid_execute($conn, "DELETE FROM cubrid_test WHERE d='php-test'", CUBRID_ASYNC);
var_dump(cubrid_affected_rows());
var_dump(cubrid_affected_rows($conn));
var_dump(cubrid_affected_rows($req));

cubrid_disconnect($conn);

print "¡Hecho!";
?>

El resultado del ejemplo sería:

Rows deleted: 5

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada


Devuelve el actual conjunto de caracteres de la conexión a CUBRID

  • « cubrid_affected_rows
  • cubrid_close »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el actual conjunto de caracteres de la conexión a CUBRID

cubrid_client_encoding

(PECL CUBRID >= 8.3.1)

cubrid_client_encoding — Devuelve el actual conjunto de caracteres de la conexión a CUBRID

Descripción

cubrid_client_encoding ( resource $conn_identifier = ? ) : string

Esta función devuelve el actual conjunto de caracteres de conexión a CUBRID y es similar a la función CUBRID cubrid_get_charset().

Parámetros

conn_identifier

Conexión CUBRID. Si no se especifica el identificador de conexión, se asumirá el último enlace abierto por cubrid_connect().

Valores devueltos

Cadena que representa el conjunto de caracteres de la conexión a CUBRID; en caso de éxito.

false en caso de falla.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_client_encoding()

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('No se pudo conectar.');
}

printf("Conjunto actual de caracteres de CUBRID: %s\n", cubrid_client_encoding($con));

?>

El resultado del ejemplo sería:

CUBRID current charset: iso8859-1

Ver también

  • cubrid_get_charset() - Devolver el conjunto de caracteres de la conexión CUBRID actual


Cerrar la conexión de CUBRID

  • « cubrid_client_encoding
  • cubrid_data_seek »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Cerrar la conexión de CUBRID

cubrid_close

(PECL CUBRID >= 8.3.1)

cubrid_close — Cerrar la conexión de CUBRID

Descripción

cubrid_close ( resource $conn_identifier = ? ) : bool

La función cubrid_close() termina la transacción en proceso actual, cierra el gestor de conexión y se desconecta del servidor. Si existe cualquier gestor de petición que no se haya cerrado todavía em este punto, éste se cerrará. Es similar a la función de CUBRID cubrid_disconnect().

Parámetros

conn_identifier

El identificador de conexión de CUBRID. Si no se especifica el identificador de conexión, se asume la última conexión abierta por cubrid_connect().

Valores devueltos

true, cuando el proceso es satisfactorio.

false, cuando el proceso es insatisfactorio.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_close()

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "conectado satisfactoriamente";
   $req = cubrid_execute ( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_close ($con);
}
?>

Ver también

  • cubrid_disconnect() - Cerrar una conexión a una base de datos
  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_connect_with_url() - Establecer el entorno para la conexión al servidor de CUBRID


Mueve el puntero interno de la fila del resultado CUBRID

  • « cubrid_close
  • cubrid_db_name »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Mueve el puntero interno de la fila del resultado CUBRID

cubrid_data_seek

(PECL CUBRID >= 8.3.0)

cubrid_data_seek — Mueve el puntero interno de la fila del resultado CUBRID

Descripción

cubrid_data_seek ( resource $result , int $row_number ) : bool

Esta función desplaza el puntero interno de las filas del resultado CUBRID (asociado con el identificador especificado) para apuntar al número de fila especificada. Hay funciones, como cubrid_fetch_assoc(), que utilizan el valor almacenado en uso de row number.

Parámetros

result

El resultado.

row_number

Éste es el número de fila deseado del puntero del nuevo resultado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_data_seek()

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_data_seek($req, 0);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 2);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 4);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}
array(2) {
  [0]=>
  string(1) "S"
  [1]=>
  string(6) "Silver"
}


Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs

  • « cubrid_data_seek
  • cubrid_errno »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs

cubrid_db_name

(PECL CUBRID >= 8.3.1)

cubrid_db_name — Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs

Descripción

cubrid_db_name ( array $result , int $index ) : string

Recupera el nombre de la base de datos desde una llamada a cubrid_list_dbs().

Parámetros

result

El puntero resultado desde un llamada a cubrid_list_dbs().

index

El índice dentro del conjunto resultado.

Valores devueltos

Devuelve el nombre de la base de datos en caso de éxito, y false en caso de fallo. Si se devuelve false, use cubrid_error() para determinar la naturaleza del error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_db_name()

<?php
error_reporting(E_ALL);

$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$db_list = cubrid_list_dbs($conn);

$i = 0;
$cnt = count($db_list);
while ($i < $cnt) {
    echo cubrid_db_name($db_list, $i) . "\n";
    $i++;
}
?>

El resultado del ejemplo sería:

demodb

Ver también

  • cubrid_list_dbs() - Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes


Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa

  • « cubrid_db_name
  • cubrid_error »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa

cubrid_errno

(PECL CUBRID >= 8.3.1)

cubrid_errno — Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa

Descripción

cubrid_errno ( resource $conn_identifier = ? ) : int

Devuelve el número de error de la última función CUBRID.

La función cubrid_errno() se usa para obtener el código de error que ocurrió durante la ejecución de la API. Normalmente, obtiene el error cuando la API devuelve false como su valor de retorno.

Parámetros

conn_identifier

El identificador de conexión de CUBRID. Si el identificador de conexión no se especifica, se asume la última conexión abierta por cubrid_connect().

Valores devueltos

Devuelve el número de error de la última función CUBRID, o 0 (cero) si no ocurrio ningún error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_errno()

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Código de error: ", cubrid_errno($con);
    echo "Mensaje de error: ", cubrid_error($con);
}
?>

El resultado del ejemplo sería:

Código de error: -493 Mensaje de error:: Syntax: Unknown class "person". select id, [name] from person

Ver también

  • cubrid_error() - Se usa para obtener el mensaje de error
  • cubrid_error_code() - Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_msg() - Obtener el último mensaje de error de la llamada a la función más reciente


Se usa para obtener el mensaje de error

  • « cubrid_errno
  • cubrid_fetch_array »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Se usa para obtener el mensaje de error

cubrid_error

(PECL CUBRID >= 8.3.1)

cubrid_error — Se usa para obtener el mensaje de error

Descripción

cubrid_error ( resource $connection = ? ) : string

La función cubrid_error() se usa para obtener el mensaje de error que ocurrió durante el uso de la API CUBRID. Normalmente, obtiene el mensaje de error cuando la API devuelve false como su valor de retorno.

Parámetros

connection

La conexión CUBRID

Valores devueltos

Mensaje de error que ocurrió.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_error()

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Código de error: ", cubrid_errno($con);
    echo "Mensaje de error: ", cubrid_error($con);
}
?>

El resultado del ejemplo sería:

Código de error: -493 Mensaje de error: Syntax: Unknown class "person". select id, [name] from person

Ver también

  • cubrid_errno() - Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa
  • cubrid_error_code() - Obtener el código de error de la llamada a una función más reciente
  • cubrid_error_msg() - Obtener el último mensaje de error de la llamada a la función más reciente


Extrae una fila como array asociativo, numérico o ambos

  • « cubrid_error
  • cubrid_fetch_assoc »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Extrae una fila como array asociativo, numérico o ambos

cubrid_fetch_array

(PECL CUBRID >=8.3.0)

cubrid_fetch_array — Extrae una fila como array asociativo, numérico o ambos

Descripción

cubrid_fetch_array ( resource $result , int $type = CUBRID_BOTH ) : array

La función cubrid_fetch_array() se utiliza para consultar una única fila del resultado de la consulta, y lo devuelve como array. El cursor avanza automáticamente a la siguiente fila del resultado.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

type

Tipo de array del resultado obtenido: CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH, CUBRID_OBJECT. Si se operan con objetos lob, se puede usar CUBRID_LOB.

Valores devueltos

Devuelve un array de cadenas que se corresponden a la fila consultada, cuando ésta tenga éxito.

false, cuando no existen más filas; NULL, cuando el proceso no tiene éxito.

El tipo del array devuelto se definirá dependiendo de cómo se haya solicitado. Usando CUBRID_BOTH (por omisión), se obtendrá un array con índices numéricos y asociativos, y se podrá decidir qué tipo de datos usar mediante el parámetro type. En la variable type puede asignarse uno de los siguientes valores:

  • CUBRID_NUM : Array numérico (basado en 0)
  • CUBRID_ASSOC : Array asociativo
  • CUBRID_BOTH : Array numérico y asociativo (predeterminado)

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_array()

<?php
$conexión = cubrid_connect("localhost", 33000, "demodb");
$solicitud = cubrid_execute($conexión, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($fila = cubrid_fetch_array($solicitud, CUBRID_NUM)) {
    printf("%-40s %-10s %-6s %-20s\n", $fila[0], $fila[1], $fila[2], $fila[3]);
}

// si se operan con objetos lob, se puede usar cubrid_fetch_array($solicitud, CUBRID_NUM | CUBRID_LOB)

cubrid_close_request($solicitud);

cubrid_disconnect($conexión);
?>

El resultado del ejemplo sería:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_fetch() - Obtener la siguiente fila de un conjunto de resultados
  • cubrid_fetch_row() - Devuelve un array numérico con los valores de la fila actual
  • cubrid_fetch_assoc() - Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_fetch_object() - Devuelve un objeto con los nombres de las columnas


Devuelve un array asociativo que se corresponde con la fila obtenida

  • « cubrid_fetch_array
  • cubrid_fetch_field »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve un array asociativo que se corresponde con la fila obtenida

cubrid_fetch_assoc

(PECL CUBRID >= 8.3.0)

cubrid_fetch_assoc — Devuelve un array asociativo que se corresponde con la fila obtenida

Descripción

cubrid_fetch_assoc ( resource $result , int $type = ? ) : array

Esta función devuelve un array asociativo que se corresponde con la fila obtenida, y después mueve el puntero interno de datos hacia adelante, o devuelve FALSE cuando se ha alcanzado el final.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

type

El tipo solamente puede ser CUBRID_LOB. Este parámetro se usará solamente cuando sea necesario operar con objetos lob.

Valores devueltos

Un array asociativo, cuando el proceso tuvo éxito.

false, cuando no existen más filas; NULL, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_assoc()

<?php
$conexión = cubrid_connect("localhost", 33000, "demodb");
$solicitud = cubrid_execute($conexión, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($fila = cubrid_fetch_assoc($solicitud)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $fila["name"], $fila["area"], $fila["seats"], $fila["address"]);
}

// si se operan con objetos lob, se puede usar cubrid_fetch_assoc($solicitud, CUBRID_LOB)

cubrid_close_request($solicitud);

cubrid_disconnect($conexión);
?>

El resultado del ejemplo sería:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_fetch() - Obtener la siguiente fila de un conjunto de resultados
  • cubrid_fetch_row() - Devuelve un array numérico con los valores de la fila actual
  • cubrid_fetch_array() - Extrae una fila como array asociativo, numérico o ambos
  • cubrid_fetch_object() - Devuelve un objeto con los nombres de las columnas


Devuelve un objeto con ciertas propiedades

  • « cubrid_fetch_assoc
  • cubrid_fetch_lengths »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve un objeto con ciertas propiedades

cubrid_fetch_field

(PECL CUBRID >= 8.3.1)

cubrid_fetch_field — Devuelve un objeto con ciertas propiedades

Descripción

cubrid_fetch_field ( resource $result , int $field_offset = 0 ) : object

Esta función devuelve un objeto con ciertas propiedades de la columna especificada. Las propiedades del objeto son:

name

nombre de la columna

table

nombre de la tabla a la que pertenece la columna

def

valor predeterminado de la columna

max_length

longitud máxima de la columna

not_null

1 si la columna no puede ser NULL

primary_key

1 si la columna es una clave primaria

unique_key

1 si la columna es clave única

multiple_key

1 si la columna no es clave única

numeri

1 si la columna es numérica

blob

1 si la columna es un BLOB

type

el tipo de la columna

unsigned

1 si la columna no tiene signo

zerofill

1 si la columna se rellena con ceros

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

field_offset

El índice del campo numérico. Si el índice del campo no se especifica, se recupera el siguiente campo (el que aún no ha sido recuperado por esta función). field_offset comienza en 0.

Valores devueltos

Un objeto con ciertas propiedades de la columna especificada, cuando el proceso tuvo éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_field()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "primary key:", $field->primary_key);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %d\n", "blob:", $field->blob);
printf("%-30s %s\n", "type:", $field->type);
printf("%-30s %d\n", "unsigned:", $field->unsigned);
printf("%-30s %d\n", "zerofill:", $field->zerofill);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16681"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-9-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
primary key:                   1
unique key:                    1
multiple key:                  0
numeric:                       1
blob:                          0
type:                          integer
unsigned:                      0
zerofill:                      0


Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual

  • « cubrid_fetch_field
  • cubrid_fetch_object »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual

cubrid_fetch_lengths

(PECL CUBRID >= 8.3.0)

cubrid_fetch_lengths — Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual

Descripción

cubrid_fetch_lengths ( resource $result ) : array

Esta función devuelve una matriz numérica con las longitudes de los valores de cada campo de la fila actual del conjunto de resultados o FALSE en caso de fallo.

Nota:

Si el tipo de información del campo es BLOB/CLOB, se debería tomar su longitud usando cubrid_lob_size().

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

Valores devueltos

Una matriz numérica, cuando el proceso tuvo éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_lengths()

$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$row = cubrid_fetch_row($result);
print_r($row);

$lens = cubrid_fetch_lengths($result);
print_r($lens);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Array
(
    [0] => 2004
    [1] => 20085
    [2] => 15118
    [3] => 30134
    [4] => AUS
    [5] => G
    [6] => 2004-8-20
)
Array
(
    [0] => 4
    [1] => 5
    [2] => 5
    [3] => 5
    [4] => 3
    [5] => 1
    [6] => 10
)


Devuelve un objeto con los nombres de las columnas

  • « cubrid_fetch_lengths
  • cubrid_fetch_row »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve un objeto con los nombres de las columnas

cubrid_fetch_object

(PECL CUBRID >= 8.3.0)

cubrid_fetch_object — Devuelve un objeto con los nombres de las columnas

Descripción

cubrid_fetch_object ( resource $result , string $class_name = ? , array $params = ? , int $type = ? ) : object

Esta función devuelve un objeto con los nombres de las columnas del conjunto de resultados como propiedades. Los valores de estas propiedades son extraídos de la fila actual del resultado.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

class_name

El nombre de la clase a instanciar, Si no se especifica, se devuelve un objeto stdClass (stdClass es una clase génerica vacía de PHP que se usa al convertir otros tipos a objetos).

params

Un array opcional de parámetros a pasar al constructor de los objetos class_name.

type

El tipo solamente puede ser CUBRID_LOB. Este parámetro se usará solamente cuando sea necesario operar con objetos lob.

Valores devueltos

Un objeto, cuando el proceso tuvo éxito.

false, cuando no existen más filas; NULL, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_object()

<?php
$conexión = cubrid_connect("localhost", 33000, "demodb");
$resultado = cubrid_execute($conexión, "SELECT * FROM code");

var_dump(cubrid_fetch_object($resultado));

// si se operan con objetos lob, se puede usar cubrid_fetch_object($resultado, CUBRID_LOB)

class demodb_code {
    public $s_name = null;
    public $f_name = null;

    public function toString() {
        var_dump($this);
    }
}

var_dump(cubrid_fetch_object($resultado, "demodb_code"));

// si se operan con objetos lob, se puede usar cubrid_fetch_object($resultado, "demodb_code", CUBRID_LOB)

class demodb_code_construct extends demodb_code {
    public function __construct($s, $f) {
        $this->s_name = $s;
        $this->f_name = $f;
    }
}

var_dump(cubrid_fetch_object($resultado, 'demodb_code_construct', array('s_name', 'f_name')));

// si se operan con objetos lob, se puede usar cubrid_fetch_object($resultado, 'demodb_code_construct', array('s_name', 'f_name'), CUBRID_LOB)

var_dump(cubrid_fetch_object($resultado));

cubrid_close_request($resultado);
cubrid_disconnect($conexión);
?>

El resultado del ejemplo sería:

object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "X"
  ["f_name"]=>
  string(5) "Mixed"
}
object(demodb_code)#1 (2) {
  ["s_name"]=>
  string(1) "W"
  ["f_name"]=>
  string(5) "Woman"
}
object(demodb_code_construct)#1 (2) {
  ["s_name"]=>
  string(6) "s_name"
  ["f_name"]=>
  string(6) "f_name"
}
object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "B"
  ["f_name"]=>
  string(6) "Bronze"
}

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_fetch() - Obtener la siguiente fila de un conjunto de resultados
  • cubrid_fetch_array() - Extrae una fila como array asociativo, numérico o ambos
  • cubrid_fetch_assoc() - Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_fetch_row() - Devuelve un array numérico con los valores de la fila actual


Devuelve un array numérico con los valores de la fila actual

  • « cubrid_fetch_object
  • cubrid_field_flags »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve un array numérico con los valores de la fila actual

cubrid_fetch_row

(PECL CUBRID >= 8.3.0)

cubrid_fetch_row — Devuelve un array numérico con los valores de la fila actual

Descripción

cubrid_fetch_row ( resource $result , int $type = ? ) : array

Esta función devuelve un array numérico con los valores de la fila actual del conjunto de resultados, comenzando en 0, y mueve hacia adelante el puntero de datos interno.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

type

El tipo solamente puede ser CUBRID_LOB. Este parámetro se usará solamente cuando sea necesario operar con objetos lob.

Valores devueltos

Un array numérico, cuando es proceso tuvo éxito.

false, cuando no existen más filas; NULL, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_fetch_row()

<?php
$conexión = cubrid_connect("localhost", 33000, "demodb");
$solicitud = cubrid_execute($conexión, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($fila = cubrid_fetch_row($solicitud)) {
    printf("%-40s %-10s %-6s %-20s\n", $fila[0], $fila[1], $fila[2], $fila[3]);
}

// si se operan con objetos lob, se puede usar cubrid_fetch_row($solicitud, CUBRID_LOB)

cubrid_close_request($solicitud);

cubrid_disconnect($conexión);
?>

El resultado del ejemplo sería:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ver también

  • cubrid_execute() - Ejecutar una sentencia SQL preparada
  • cubrid_fetch() - Obtener la siguiente fila de un conjunto de resultados
  • cubrid_fetch_array() - Extrae una fila como array asociativo, numérico o ambos
  • cubrid_fetch_assoc() - Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_fetch_object() - Devuelve un objeto con los nombres de las columnas


Devuelve una cadena con las banderas del índice del campo dado

  • « cubrid_fetch_row
  • cubrid_field_len »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve una cadena con las banderas del índice del campo dado

cubrid_field_flags

(PECL CUBRID >= 8.3.0)

cubrid_field_flags — Devuelve una cadena con las banderas del índice del campo dado

Descripción

cubrid_field_flags ( resource $result , int $field_offset ) : string

Esta función devuelve una cadena con las banderas del índice del campo dado separadas mediante espacios. Se puede dividir el valor devuelto usando explode. La posibles banderas podrían ser: not_null, primary_key, unique_key, foreign_key, auto_increment, shared, reverse_index, reverse_unique y timestamp.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

Una cadena con banderas, cuando el proceso tuvo éxito.

false cuando hay un valor no válido de field_offset.

-1 si la sentencia SQL no es SELECT.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_flags()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date


Devuelve la longitud máxima del campo especificado

  • « cubrid_field_flags
  • cubrid_field_name »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve la longitud máxima del campo especificado

cubrid_field_len

(PECL CUBRID >= 8.3.0)

cubrid_field_len — Devuelve la longitud máxima del campo especificado

Descripción

cubrid_field_len ( resource $result , int $field_offset ) : int

Esta función devuelve la longitud máxima del campo especificado en caso de éxito, o FALSE en caso de fallo.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

La longitud máxima, cuando el proceso ha tenido éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_len()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10


Devuelve el nombre del índice del campo especificado

  • « cubrid_field_len
  • cubrid_field_seek »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el nombre del índice del campo especificado

cubrid_field_name

(PECL CUBRID >= 8.3.0)

cubrid_field_name — Devuelve el nombre del índice del campo especificado

Descripción

cubrid_field_name ( resource $result , int $field_offset ) : string

Esta función devuelve el nombre del índice del campo especificado en caso de éxito o FALSE en caso de fallo.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

El nombre del índice del campo especificado, en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_name()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date


Mueve el cursor del conjunto de resultados al índece del campo especificado

  • « cubrid_field_name
  • cubrid_field_table »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Mueve el cursor del conjunto de resultados al índece del campo especificado

cubrid_field_seek

(PECL CUBRID >= 8.3.0)

cubrid_field_seek — Mueve el cursor del conjunto de resultados al índece del campo especificado

Descripción

cubrid_field_seek ( resource $result , int $field_offset = 0 ) : bool

Esta función mueve el cursor del conjunto de resultados al índece del campo especificado. Este índice es usado por cubrid_fetch_field() si no se incluye un índice de campo. Devuelve TRUE en caso de éxito o FALSE en caso de fallo.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

true en caso de éxito.

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_seek()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %s\n", "type:", $field->type);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16132"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-09-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
unique key:                    1
multiple key:                  0
numeric:                       1
type:                          integer


Devuelve el nombre de la tabla del campo especificado

  • « cubrid_field_seek
  • cubrid_field_type »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el nombre de la tabla del campo especificado

cubrid_field_table

(PECL CUBRID >= 8.3.0)

cubrid_field_table — Devuelve el nombre de la tabla del campo especificado

Descripción

cubrid_field_table ( resource $result , int $field_offset ) : string

Esta función devuelve el nombre de la tabla del campo especificado. Esto es útil cuando se usan consultas SELECT largas con JOINS.

Parámetros

result

Array type of the fetched result CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH.

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

El nombre de la tabla del campo especificado, en caso de éxito.

false cuando field_offset tiene un valor no válido.

-1 si la sentencia SQL no es SELECT.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_table()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar


Devuelve el tipo de columna que se corresponde con el índice del campo dado

  • « cubrid_field_table
  • cubrid_list_dbs »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el tipo de columna que se corresponde con el índice del campo dado

cubrid_field_type

(PECL CUBRID >= 8.3.0)

cubrid_field_type — Devuelve el tipo de columna que se corresponde con el índice del campo dado

Descripción

cubrid_field_type ( resource $result , int $field_offset ) : string

Esta función devuelve el tipo de columna que se corresponde con el índice del campo dado. El tipo de campo devuelto debería ser uno de los siguientes: "int", "real", "string", etc.

Parámetros

result

Tipo array del resultado traído CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH.

field_offset

El índice de campo numérico. field_offset comienza en 0. Si field_offset no existe, se emitirá un error de nivel E_WARNING.

Valores devueltos

El tipo de la columna, en caso de éxito.

false cuando field_offset no tiene un valor válido.

-1 si la sentencia SQL no es SELECT.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_field_type()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar


Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes

  • « cubrid_field_type
  • cubrid_num_fields »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes

cubrid_list_dbs

(PECL CUBRID >= 8.3.0)

cubrid_list_dbs — Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes

Descripción

cubrid_list_dbs ( resource $conn_identifier = ? ) : array

Esta función devuelve una matriz con la lista de todas las bases de datos Cubrid existentes.

Parámetros

conn_identifier

La conexión CUBRID.

Valores devueltos

Una matriz numérica con todas las bases de datos Cubrid existentes; en caso de éxito.

false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_list_dbs()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$db_list = cubrid_list_dbs($conn);
var_dump($db_list);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  string(6) "demodb"
}


Devuelve el número de columnas del conjunto de resultados

  • « cubrid_list_dbs
  • cubrid_ping »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el número de columnas del conjunto de resultados

cubrid_num_fields

(PECL CUBRID >= 8.3.0)

cubrid_num_fields — Devuelve el número de columnas del conjunto de resultados

Descripción

cubrid_num_fields ( resource $result ) : int

Esta función devuelve el número de columnas del conjunto de resultados, en caso de éxito, o FALSE en caso de fallo.

Parámetros

result

result proviene de una llamada a cubrid_execute(), cubrid_query() y cubrid_prepare()

Valores devueltos

El número de columnas, en caso de éxito.

-1 si la sentencia SQL no es SELECT.

false cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_num_fields()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_fields($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

Row Num: 6
Column Num: 2


Hacer ping en una conexión al servidor o reconectar si no hay conexión

  • « cubrid_num_fields
  • cubrid_query »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Hacer ping en una conexión al servidor o reconectar si no hay conexión

cubrid_ping

(PECL CUBRID >= 8.3.1)

cubrid_ping — Hacer ping en una conexión al servidor o reconectar si no hay conexión

Descripción

cubrid_ping ( resource $conn_identifier = ? ) : bool

Verifica si la conexión al servidor está funcionando..

Parámetros

conn_identifier

El identificador de conexión de CUBRID. Si el identificador de conexión no se especifica, se asume la última conexión abierta por cubrid_connect().

Valores devueltos

Devuelve true si la conexión al servidor CUBRID está funcionando, si no false.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_ping()

<?php
set_time_limit(0);

$con = cubrid_connect('localhost', 33000, 'demodb');

/* Se asume que esta consulta tomará mucho tiempo */
$sql = "select * from athlete";
$result = cubrid_query($sql);
if (!$result) {
    echo 'La consulta #1 falló, saliendo.';
    exit;
}

/* Asegurarse de que la conexión todavía perdura, si no, intentar reconectar */
if (!cubrid_ping($con)) {
    echo 'Conexión perdida, saliendo después de la consulta #1';
    exit;
}
cubrid_free_result($result);

/* Ya que la conexión aún perdura, vamos a ejecutar otra consulta */
$sql2 = "select * from code";
$result2 = cubrid_query($sql2);
?>


Enviar una consulta CUBRID

  • « cubrid_ping
  • cubrid_real_escape_string »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Enviar una consulta CUBRID

cubrid_query

(PECL CUBRID >= 8.3.1)

cubrid_query — Enviar una consulta CUBRID

Descripción

cubrid_query ( string $query , resource $conn_identifier = ? ) : resource

cubrid_query() envía una consulta única (no están soportadas consultas múltiples) a la base de datos activa actual en el servidor que está asociado con el conn_identifier especificado.

Parámetros

query

Una consulta SQL

La información dentro de la consulta debería estar adecuadamente escapada.

conn_identifier

La conexión CUBRID. Si el identificador de conexión no se especifica, se asume la última conexión abierta por cubrid_connect().

Valores devueltos

Para SELECT, SHOW, DESCRIBE, EXPLAIN y otras sentencias que devuelven conjuntos de resultadosa, cubrid_query() devuelve un resource en caso de éxito, o false en caso de error.

Para otros tipos de sentencias SQL, INSERT, UPDATE, DELETE, DROP, etc, cubrid_query() devuelve true en caso de éxito o false en caso de error.

El recurso resultado devuelto debería ser pasado a cubrid_fetch_array(), y a otras funciones para tratar con las tablas de resultados, para acceder a la información devuelta.

Use cubrid_num_rows() para vaeriguar cuántas filas fueron devueltas por una sentencia SELECT o cubrid_affected_rows() para averiguar cuántas filas fueron afectadas por una sentencia DELETE, INSERT, REPLACE, o UPDATE.

cubrid_query() también podrá fallar y devolver false si el usuario no tiene permiso para acceder a la/s tabla/s referenciada/s por la consulta.

Ejemplos

Ejemplo #1 Consulta No Válida

La siguiente consulta no es válida sintácticamente, por lo que cubrid_query() fallará y devolverá false.

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb');

$result = cubrid_query('SELECT * WHERE 1=1');
if (!$result) {
    die('Invalid query: ' . cubrid_error());
}

?>

Ejemplo #2 Consulta Válida

La siguiente consulta es válida, por lo que cubrid_query() devolverá un resource.

<?php
// Esto podría ser proporcionado por el usuario, por ejemplo
$nombre = 'fred';
$apellido  = 'fox';

cubrid_execute($conn,"DROP TABLE if exists friends");
cubrid_execute($conn,"create table friends(firstname varchar,lastname varchar,address char(24),age int)");
cubrid_execute($conn,"insert into friends values('fred','fox','home-1','20')");
cubrid_execute($conn,"insert into friends values('blue','cat','home-2','21')");
// Formular la Consulta
// Esta es la mejor manera de realizar una consulta SQL
// Para más ejemplos, véase cubrid_real_escape_string()
$consulta = sprintf("SELECT firstname, lastname, address, age FROM friends WHERE firstname='%s' AND lastname='%s'",
cubrid_real_escape_string($nombre),
cubrid_real_escape_string($apellido));

// Realizar la Constulta
$result = cubrid_query($consulta);

// Verificar el resultado
// Esto muestra la consulta real enviada a CUBRID, y el error. Útil para depuración.
if (!$result) {
    $mensaje  = 'Consulta no válida: ' . cubrid_error() . "\n";
    $mensaje .= 'Consulta completa: ' . $consulta;
    die($mensaje);
}

// Usar el resultado
// Intentar imprimir $result no permitirá el acceso a la información en el recurso
// Se debe usar una de las funciones de resultados de cubrid
// Véase también cubrid_result(), cubrid_fetch_array(), cubrid_fetch_row(), etc.
while ($fila = cubrid_fetch_assoc($result)) {
    echo $fila['firstname'];
    echo $fila['lastname'];
    echo $fila['address'];
    echo $fila['age'];
}

// Liberar los recursos asociados con el conjunto de resultados
// Esto se hace automáticamente al final del script
cubrid_free_result($result);
?>

Ver también

  • cubrid_connect() - Abrir una conexión al servidor CUBRID
  • cubrid_error() - Se usa para obtener el mensaje de error
  • cubrid_real_escape_string() - Escapar caracteres especiales en una cadena para usarla en una sentencia SQL
  • cubrid_result() - Devuelve el valor de un campo específico de una fila específica
  • cubrid_fetch_assoc() - Devuelve un array asociativo que se corresponde con la fila obtenida
  • cubrid_unbuffered_query() - Realiza una consulta sin traer los resultados a memoria


Escapar caracteres especiales en una cadena para usarla en una sentencia SQL

  • « cubrid_query
  • cubrid_result »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Escapar caracteres especiales en una cadena para usarla en una sentencia SQL

cubrid_real_escape_string

(PECL CUBRID >= 8.3.0)

cubrid_real_escape_string — Escapar caracteres especiales en una cadena para usarla en una sentencia SQL

Descripción

cubrid_real_escape_string ( string $unescaped_string , resource $conn_identifier = ? ) : string

Esta función devuelve la versión escapada de la cadena dada. Escapará los siguientes caracteres: '. En general, las comillas simples se usan para encerrar cadenas de caracteres. Las comillas dobles se pueden usar también dependiendo del valor de ansi_quotes, que es un parámetro relacionado con sentencias SQL. Si el valor de ansi_quotes value está establecido a no, las cadenas de caracteres encerradas entre comillas dobles se tratan como cadenas de caracteres, no como identificadores. El valor predeterminado es yes. Si quiere incluir una comilla simple como parte de una cadena de caracteres, introduzca dos comillas simples en una fila.

Parámetros

unescaped_string

La cadena que va a ser escapada.

conn_identifier

La conexión CUBRID. Si el identificador de conexión no se especifica, se asume el último enlace abierto por cubrid_connect().

Valores devueltos

La versión escapada de la cadena dada, en caso de éxito.

false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_real_escape_string()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$unescaped_str = ' !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~';
$escaped_str = cubrid_real_escape_string($unescaped_str);

$len = strlen($unescaped_str);

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (t char($len))");
cubrid_execute($conn, "INSERT INTO cubrid_test (t) VALUES('$escaped_str')");

$req = cubrid_execute($conn, "SELECT * FROM cubrid_test");
$row = cubrid_fetch_assoc($req);

var_dump($row);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

array(1) {
  ["t"]=>
  string(95) " !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~"
}


Devuelve el valor de un campo específico de una fila específica

  • « cubrid_real_escape_string
  • cubrid_unbuffered_query »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Devuelve el valor de un campo específico de una fila específica

cubrid_result

(PECL CUBRID >= 8.3.0)

cubrid_result — Devuelve el valor de un campo específico de una fila específica

Descripción

cubrid_result ( resource $result , int $row , mixed $field = 0 ) : string

Esta función devuelve el valor de un campo específico de una fila específica de un conjunto de resultados.

Parámetros

result

result proviene de una llamada a la función cubrid_execute()

row

El número de fila del resultado que está siendo traído. Los números de fila comienzan en 0.

field

El nombre o índice del campo dado por field que está siendo obtenido. Puede ser el índice del campo, el nombre del campo, o la tabla del campo punto nombre del campo (nombretabla.nombrecampo). Si el nombre de la columna ha sido apodado ('select foo as bar from...'), use el alias en vez del nombre de la columna. Si no está definido se trae el primer campo.

Valores devueltos

El valor de un campo específico, en caso de éxito (NULL si el valor es nulo).

false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_result()

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$result = cubrid_result($req, 0);
var_dump($result);

$result = cubrid_result($req, 0, 1);
var_dump($result);

$result = cubrid_result($req, 5, "f_name");
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

El resultado del ejemplo sería:

string(1) "X"
string(5) "Mixed"
string(4) "Gold"


Realiza una consulta sin traer los resultados a memoria

  • « cubrid_result
  • Alias y Funciones Obsoletas de CUBRID »
  • PHP Manual
  • Funciones de compatibilidad CUBRID MySQL
  • Realiza una consulta sin traer los resultados a memoria

cubrid_unbuffered_query

(PECL CUBRID >= 8.3.0)

cubrid_unbuffered_query — Realiza una consulta sin traer los resultados a memoria

Descripción

cubrid_unbuffered_query ( string $query , resource $conn_identifier = ? ) : resource

Esta función realiza una consulta sin esperar a que todos los resultados de consulta hayan sido completados. Devolverá cuando los resultados están siendo generados.

Parámetros

query

Una consulta SQL.

conn_identifier

La conexión CUBRID. Si el identificador de conexión no se especifica, se asume el último enlace abierto por cubrid_connect().

Valores devueltos

Para sentencias SELECT, SHOW, DESCRIBE o EXPLAIN devuelve un recurso identificador de petición en caso de éxito.

Para otro tipo de sentencias SQL, UPDATE, DELETE, DROP, etc,, devuelve true en caso de éxito.

false en caso de fallo.

Notas

Nota:

Los beneficios de cubrid_unbuffered_query() tienen un coste: no se puede usar cubrid_num_rows() y cubrid_data_seek() en un conjunto de resultados devueltos desde cubrid_unbuffered_query().

Ejemplos

Ejemplo #1 Ejemplo de cubrid_unbuffered_query()

<?php
    $enlace = cubrid_connect("localhost", 30000, "demodb", "dba", "");
    if (!$enlace)
    {
        die('No se pudo conectar.');
    }
    $consulta = "select * from code";
    $resultado = cubrid_unbuffered_query($consulta, $enlace);

    while ($fila = cubrid_fetch($resultado))
    {
        var_dump($fila);
    }

    cubrid_close_request($resultado);
    cubrid_disconnect($enlace);
?>


Alias y Funciones Obsoletas de CUBRID

Tabla de contenidos

  • cubrid_load_from_glo — Leer información de una instancia GLO y guardarla en un fichero
  • cubrid_new_glo — Crear una instancia glo
  • cubrid_save_to_glo — Guardar el fichero solicitado en una instancia GLO
  • cubrid_send_glo — Leer información de un glo y enviarla a la salida estándar


Leer información de una instancia GLO y guardarla en un fichero

  • « Alias y Funciones Obsoletas de CUBRID
  • cubrid_new_glo »
  • PHP Manual
  • Alias y Funciones Obsoletas de CUBRID
  • Leer información de una instancia GLO y guardarla en un fichero

cubrid_load_from_glo

(PECL CUBRID >= 8.3.0)

cubrid_load_from_glo — Leer información de una instancia GLO y guardarla en un fichero

Descripción

cubrid_load_from_glo ( resource $conn_identifier , string $oid , string $file_name ) : int

La función cubrid_load_from_glo() se usa para leer una información desde una instancia glo, y guardarla en el fichero indicado.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia glo desde la que se quiere leer la información.

file_name

Nombre del fichero en donde se quiere guardar la información.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_load_from_glo()

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_load_from_glo ($con, $oid, "output.jpg");
   if ($res) {
      echo "imagen cambiada con éxito";
   }
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: cubrid_load_from_glo()

Nota:

Esta función está eliminada desde CUBRID 3.1.

Ver también

  • cubrid_new_glo() - Crear una instancia glo
  • cubrid_save_to_glo() - Guardar el fichero solicitado en una instancia GLO
  • cubrid_send_glo() - Leer información de un glo y enviarla a la salida estándar


Crear una instancia glo

  • « cubrid_load_from_glo
  • cubrid_save_to_glo »
  • PHP Manual
  • Alias y Funciones Obsoletas de CUBRID
  • Crear una instancia glo

cubrid_new_glo

(PECL CUBRID >= 8.3.0)

cubrid_new_glo — Crear una instancia glo

Descripción

cubrid_new_glo ( resource $conn_identifier , string $class_name , string $file_name ) : string

La función cubrid_new_glo() se usa para crear una instancia glo en la clase solicitada (clase glo). El glo creado es un tipo LO, y es almacenado en el fichero file_name.

Parámetros

conn_identifier

Identificador de conexión.

class_name

Nombre de la clase en la que se quiere crear un glo.

file_name

El nombre del archivo en el que se quiere guardar el glo recién creado.

Valores devueltos

Oid de la instancia creada, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_new_glo()

<?php
$oid = cubrid_new_glo ($con, "glo", "input.jpg");
if ($oid){
   // el tipo de la columna "image" es "object"
   $req = cubrid_execute ($con, "insert into person(image) values($oid)");
   if ($req) {
      echo "imagem insertada con éxito";
      cubrid_close_request ($req);
      cubrid_commit($con);
   }
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: cubrid_new_glo()

Nota:

Esta función está eliminada desde CUBRID 3.1.

Ver también

  • cubrid_save_to_glo() - Guardar el fichero solicitado en una instancia GLO
  • cubrid_load_from_glo() - Leer información de una instancia GLO y guardarla en un fichero
  • cubrid_send_glo() - Leer información de un glo y enviarla a la salida estándar


Guardar el fichero solicitado en una instancia GLO

  • « cubrid_new_glo
  • cubrid_send_glo »
  • PHP Manual
  • Alias y Funciones Obsoletas de CUBRID
  • Guardar el fichero solicitado en una instancia GLO

cubrid_save_to_glo

(PECL CUBRID >= 8.3.0)

cubrid_save_to_glo — Guardar el fichero solicitado en una instancia GLO

Descripción

cubrid_save_to_glo ( resource $conn_identifier , string $oid , string $file_name ) : int

La función cubrid_save_to_glo() se usa para guardar el fichero solicitado en una instancia glo.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia glo en donde se quiere guardar un fichero.

file_name

El nombre del archivo que quierer guardar.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_save_to_glo()

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_save_to_glo ($con, $oid, "input.jpg");
   if ($res) {
      echo "imagen cambiada con éxito";
   }
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: cubrid_save_to_glo()

Nota:

Esta función está eliminada desde CUBRID 3.1.

Ver también

  • cubrid_new_glo() - Crear una instancia glo
  • cubrid_load_from_glo() - Leer información de una instancia GLO y guardarla en un fichero
  • cubrid_send_glo() - Leer información de un glo y enviarla a la salida estándar


Leer información de un glo y enviarla a la salida estándar

  • « cubrid_save_to_glo
  • DB++ »
  • PHP Manual
  • Alias y Funciones Obsoletas de CUBRID
  • Leer información de un glo y enviarla a la salida estándar

cubrid_send_glo

(PECL CUBRID >= 8.3.0)

cubrid_send_glo — Leer información de un glo y enviarla a la salida estándar

Descripción

cubrid_send_glo ( resource $conn_identifier , string $oid ) : int

La función cubrid_send_glo() se usa para leer información de una instancia glo y enviarla a la salida estándar de PHP.

Parámetros

conn_identifier

Identificador de conexión.

oid

OID de la instancia glo de la que se quiere leer información.

Valores devueltos

true, cuando el proceso tiene éxito.

false, cuando el proceso no tiene éxito.

Ejemplos

Ejemplo #1 Ejemplo de cubrid_send_glo()

<?php
$req = cubrid_execute ($con, "select image from person where id =1");
if ($req) {
  list ($oid) = cubrid_fetch($req);
  cubrid_close_request($req);
  Header ("Content-type: image/jpeg");
  cubrid_send_glo ($con, $oid);
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: cubrid_send_glo()

Nota:

Esta función está eliminada desde CUBRID 3.1.

Ver también

  • cubrid_new_glo() - Crear una instancia glo
  • cubrid_save_to_glo() - Guardar el fichero solicitado en una instancia GLO
  • cubrid_load_from_glo() - Leer información de una instancia GLO y guardarla en un fichero


DB++

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • códigos de errores de db++
  • Funciones de DB++
    • dbplus_add — Añade una tupla a una relación
    • dbplus_aql — Realizar una consulta AQL
    • dbplus_chdir — Obtener/Estabecer el directorio virtual actual de la base de datos
    • dbplus_close — Cierra una relación
    • dbplus_curr — Get current tuple from relation
    • dbplus_errcode — Obtener la cadena de error de un código de error dado o del último error
    • dbplus_errno — Obtener el código de error de la última operación
    • dbplus_find — Establecer una restricción en una relación
    • dbplus_first — Obtener la primera tupla de una relación
    • dbplus_flush — Vuelca todos los cambios hechos en una relación
    • dbplus_freealllocks — Liberar todos los bloqueos mantenidos por este cliente
    • dbplus_freelock — Libera el bloqueo de escritura en una tupla
    • dbplus_freerlocks — Liberar todos los bloqueos de una relación dada
    • dbplus_getlock — Obtener un bloqueo de escritura en una tupla
    • dbplus_getunique — Obtener un único número de identificación para una relación
    • dbplus_info — Obtener información sobre una relación
    • dbplus_last — Obtener la última tupla de una relación
    • dbplus_lockrel — Solictar un bloqueo de escritura en una relación
    • dbplus_next — Obtener la siguiente tupla de una relación
    • dbplus_open — Abre un archivo de relación
    • dbplus_prev — Obtener la tupla previa de una relación
    • dbplus_rchperm — Cambiar los permisos de una relación
    • dbplus_rcreate — Crea una nueva relación de DB++
    • dbplus_rcrtexact — Crea una copia exacta pero vacía de una relación incluyendo los índices
    • dbplus_rcrtlike — Crea una copia vacía de una relación con los índeces predeterminados
    • dbplus_resolve — Resuelve la información del host de la relación
    • dbplus_restorepos — Restablece la posición
    • dbplus_rkeys — Especificar una nueva clave primaria para un relaición
    • dbplus_ropen — Abrir un archivo local de relación
    • dbplus_rquery — Realizar una consulta AQL local (en bruto)
    • dbplus_rrename — Renombrar una relación
    • dbplus_rsecindex — Crear un nuevo índice secundario para una relación
    • dbplus_runlink — Eliminar una relación del sistema de archivos
    • dbplus_rzap — Eliminar todas las tuplas de una relación
    • dbplus_savepos — Guardar la posición
    • dbplus_setindex — Establecer el índice
    • dbplus_setindexbynumber — Establecer el índice por número
    • dbplus_sql — Realiza una consulta SQL
    • dbplus_tcl — Ejecutar código TCL en el lado del servidor
    • dbplus_tremove — Eliminar una tupla y devolver la nueva tupla actual
    • dbplus_undo — Deshacer
    • dbplus_undoprepare — Preparara deshacer
    • dbplus_unlockrel — Liberar un bloqueo de escritura en una relación
    • dbplus_unselect — Eliminar una restricción de una relación
    • dbplus_update — Actualizar la tupla especificada en la relación
    • dbplus_xlockrel — Solicitar un bloqueo exclusivo de una relación
    • dbplus_xunlockrel — Liberar un bloqueo exclusivo en una relación


Introducción

db++, hecha por la compañía alemanama » Concept asa, es un sistema de base de datos relacional que tiene en mente el alto redimiento y el bajo uso de memoria y disco. Aunque proporciona SQL como una interfaz de lenguaje adicional, no es realmente una base de datos SQL en primera instancia pero proporciona su propio lenguaje de consulta AQL, que está más influenciado por el álgebra relacional que SQL.

Concept asa siempre ha estado interesado en apoyar lenguajes de código abierto, db++ ha tenido Perl y llamadas Tcl durante años y ahora usa Tcl como su lenguaje interno de procedimientos de almacenamiento.

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.


Requerimientos

Esta extensión depende de librerías cliente externas por lo que ha de tener un cliente db++ instalado en el sistema que quiera que use esta extensión.

» Concept asa proporciona » versiones db++ Demo y » documentación para Linux y algunas versiones de Unix. También existe una versión de db++ para Windows, pero esta extensión no está soportada (aún).


Instalación

Para construir esta extensión se necesita que estén instaladas las bibliotecas cliente de db++ y los archivos de cabeceras en sus sistema (están incluidos por defecto en los archivos de instalación de db++). Se tiene que ejecutar configure con la opción --with-dbplus para construir esta extensión.

configure examina las bibliotecas cliente y los archivos de cabeceras bajo las rutas predeterminadas /usr/dbplus, /usr/local/dbplus y /opt/dblus. Si tiene instalado db++ en un lugar diferente tiene que añadir la ruta de instalación a la opción de configure como sigue: --with-dbplus=/su/ruta_de/instalacion.


Tipos de recursos

dbplus_relation

La mayoría de la funciones de db++ operan con o devuelven recursos dbplus_relation. Una dbplus_relation es un gestor para una relación almacenada o generada por el resultado de una consulta.


Constantes predefinidas

Tabla de contenidos

  • códigos de errores de db++

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.


códigos de errores de db++

Códigos de Errores de DB++
Constante PHP | constante db++ | significado
DBPLUS_ERR_NOERR (integer) | ERR_NOERR | Condición de error nulo
DBPLUS_ERR_DUPLICATE (integer) | ERR_DUPLICATE | Se intentó insertar una tupla duplicada
DBPLUS_ERR_EOSCAN (integer) | ERR_EOSCAN | Final del escaneo desde rget()
DBPLUS_ERR_EMPTY (integer) | ERR_EMPTY | La relación está vacía (servidor)
DBPLUS_ERR_CLOSE (integer) | ERR_CLOSE | El servidor no se puede cerrar
DBPLUS_ERR_WLOCKED (integer) | ERR_WLOCKED | El registro está bloqueado contra escritura
DBPLUS_ERR_LOCKED (integer) | ERR_LOCKED | La relación ya fue cerrada
DBPLUS_ERR_NOLOCK (integer) | ERR_NOLOCK | La relación no se puede cerrar
DBPLUS_ERR_READ (integer) | ERR_READ | Error de lectura en la relación
DBPLUS_ERR_WRITE (integer) | ERR_WRITE | Error de escritura en la relación
DBPLUS_ERR_CREATE (integer) | ERR_CREATE | Falló la llamada al sistema de Create()
DBPLUS_ERR_LSEEK (integer) | ERR_LSEEK | Falló la llamada al sistema de Lseek()
DBPLUS_ERR_LENGTH (integer) | ERR_LENGTH | La tupla excede la longitud máxima
DBPLUS_ERR_OPEN (integer) | ERR_OPEN | Falló la llamada al sistema de Open()
DBPLUS_ERR_WOPEN (integer) | ERR_WOPEN | La relación ya fue abierta para escritura
DBPLUS_ERR_MAGIC (integer) | ERR_MAGIC | El archivo no es una relación
DBPLUS_ERR_VERSION (integer) | ERR_VERSION | El archivo es una relación muy antigua
DBPLUS_ERR_PGSIZE (integer) | ERR_PGSIZE | La relación usa un tamaño de página diferente
DBPLUS_ERR_CRC (integer) | ERR_CRC | CRC no válido en la superpágina
DBPLUS_ERR_PIPE (integer) | ERR_PIPE | La relación de tubería requiere lseek()
DBPLUS_ERR_NIDX (integer) | ERR_NIDX | Demasiados índices secundarios
DBPLUS_ERR_MALLOC (integer) | ERR_MALLOC | Falló la llamada a Malloc()
DBPLUS_ERR_NUSERS (integer) | ERR_NUSERS | Error de uso del máximo de usuarios
DBPLUS_ERR_PREEXIT (integer) | ERR_PREEXIT | Causado por uso no válido
DBPLUS_ERR_ONTRAP (integer) | ERR_ONTRAP | Causado por una señal
DBPLUS_ERR_PREPROC (integer) | ERR_PREPROC | Error en el preprocesador
DBPLUS_ERR_DBPARSE (integer) | ERR_DBPARSE | Error en el analizador
DBPLUS_ERR_DBRUNERR (integer) | ERR_DBRUNERR | Error de ejecución en la base de datos
DBPLUS_ERR_DBPREEXIT (integer) | ERR_DBPREEXIT | Condición de salida causada por el procedimiento prexit() *
DBPLUS_ERR_WAIT (integer) | ERR_WAIT | Espera un momento (Sólo Simple)
DBPLUS_ERR_CORRUPT_TUPLE (integer) | ERR_CORRUPT_TUPLE | Un cliente envió una tupla corrupta
DBPLUS_ERR_WARNING0 (integer) | ERR_WARNING0 | Las rutinas Simple encontraron un error no fatal que fue corregido
DBPLUS_ERR_PANIC (integer) | ERR_PANIC | El servidor no debería morir realmente excepto después de que un desastre envíe ERR_PANIC a todos sus clientes
DBPLUS_ERR_FIFO (integer) | ERR_FIFO | No se puede crear un fifo
DBPLUS_ERR_PERM (integer) | ERR_PERM | Permiso denegado
DBPLUS_ERR_TCL (integer) | ERR_TCL | Error TCL
DBPLUS_ERR_RESTRICTED (integer) | ERR_RESTRICTED | Sólo dos usuarios
DBPLUS_ERR_USER (integer) | ERR_USER | Un error en el uso de la biblioteca por un programdor de aplicaciones
DBPLUS_ERR_UNKNOWN (integer) | ERR_UNKNOWN |


Funciones de DB++

Tabla de contenidos

  • dbplus_add — Añade una tupla a una relación
  • dbplus_aql — Realizar una consulta AQL
  • dbplus_chdir — Obtener/Estabecer el directorio virtual actual de la base de datos
  • dbplus_close — Cierra una relación
  • dbplus_curr — Get current tuple from relation
  • dbplus_errcode — Obtener la cadena de error de un código de error dado o del último error
  • dbplus_errno — Obtener el código de error de la última operación
  • dbplus_find — Establecer una restricción en una relación
  • dbplus_first — Obtener la primera tupla de una relación
  • dbplus_flush — Vuelca todos los cambios hechos en una relación
  • dbplus_freealllocks — Liberar todos los bloqueos mantenidos por este cliente
  • dbplus_freelock — Libera el bloqueo de escritura en una tupla
  • dbplus_freerlocks — Liberar todos los bloqueos de una relación dada
  • dbplus_getlock — Obtener un bloqueo de escritura en una tupla
  • dbplus_getunique — Obtener un único número de identificación para una relación
  • dbplus_info — Obtener información sobre una relación
  • dbplus_last — Obtener la última tupla de una relación
  • dbplus_lockrel — Solictar un bloqueo de escritura en una relación
  • dbplus_next — Obtener la siguiente tupla de una relación
  • dbplus_open — Abre un archivo de relación
  • dbplus_prev — Obtener la tupla previa de una relación
  • dbplus_rchperm — Cambiar los permisos de una relación
  • dbplus_rcreate — Crea una nueva relación de DB++
  • dbplus_rcrtexact — Crea una copia exacta pero vacía de una relación incluyendo los índices
  • dbplus_rcrtlike — Crea una copia vacía de una relación con los índeces predeterminados
  • dbplus_resolve — Resuelve la información del host de la relación
  • dbplus_restorepos — Restablece la posición
  • dbplus_rkeys — Especificar una nueva clave primaria para un relaición
  • dbplus_ropen — Abrir un archivo local de relación
  • dbplus_rquery — Realizar una consulta AQL local (en bruto)
  • dbplus_rrename — Renombrar una relación
  • dbplus_rsecindex — Crear un nuevo índice secundario para una relación
  • dbplus_runlink — Eliminar una relación del sistema de archivos
  • dbplus_rzap — Eliminar todas las tuplas de una relación
  • dbplus_savepos — Guardar la posición
  • dbplus_setindex — Establecer el índice
  • dbplus_setindexbynumber — Establecer el índice por número
  • dbplus_sql — Realiza una consulta SQL
  • dbplus_tcl — Ejecutar código TCL en el lado del servidor
  • dbplus_tremove — Eliminar una tupla y devolver la nueva tupla actual
  • dbplus_undo — Deshacer
  • dbplus_undoprepare — Preparara deshacer
  • dbplus_unlockrel — Liberar un bloqueo de escritura en una relación
  • dbplus_unselect — Eliminar una restricción de una relación
  • dbplus_update — Actualizar la tupla especificada en la relación
  • dbplus_xlockrel — Solicitar un bloqueo exclusivo de una relación
  • dbplus_xunlockrel — Liberar un bloqueo exclusivo en una relación


Añade una tupla a una relación

  • « Funciones de DB++
  • dbplus_aql »
  • PHP Manual
  • Funciones de DB++
  • Añade una tupla a una relación

dbplus_add

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_add — Añade una tupla a una relación

Descripción

dbplus_add ( resource $relation , array $tuple ) : int

Añade una tupla a relation.

Parámetros

relation

tuple

Una matriz de pares atributo/valor que se va a insertar en la relación relation dada.

Después de una ejecución con éxito, esta matriz contendrá la información completa de la recién creada tupla, incluyendo todos los campos de dominio establecidos implícitamente como secuencias.

Valores devueltos

La función devolverá DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_errcode() - Obtener la cadena de error de un código de error dado o del último error


Realizar una consulta AQL

  • « dbplus_add
  • dbplus_chdir »
  • PHP Manual
  • Funciones de DB++
  • Realizar una consulta AQL

dbplus_aql

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_aql — Realizar una consulta AQL

Descripción

dbplus_aql ( string $query , string $server = ? , string $dbpath = ? ) : resource

Ejecuta una query AQL sobre el server y dbpath dados.

Parámetros

query

LA consulta AQL a ejecutar. Más información sobre AQL (Algebraic Query Language - Lenguaje de Consulta Algebraico) se proporciona el el manual original de db++.

server

dbpath

Valores devueltos

Devuelve un gestor de relación si se tuvo éxito. La información resultante se puede traer desde esta relación llamando a dbplus_next() y a dbplus_curr(). Otras funciones de acceso a relaciones no funcionarán sore una relación resultante.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener/Estabecer el directorio virtual actual de la base de datos

  • « dbplus_aql
  • dbplus_close »
  • PHP Manual
  • Funciones de DB++
  • Obtener/Estabecer el directorio virtual actual de la base de datos

dbplus_chdir

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_chdir — Obtener/Estabecer el directorio virtual actual de la base de datos

Descripción

dbplus_chdir ( string $newdir = ? ) : string

Cambia el directorio virtual actual donde se buscarán los archivos de relaciones mediante dbplus_open().

Parámetros

newdir

El nuevo directorio para los archivos de relaciones. Se puede omitir este parámetro para preguntar por el directorio de trabajo actual.

Valores devueltos

Devuelve la ruta absoluta del directorio actual.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Cierra una relación

  • « dbplus_chdir
  • dbplus_curr »
  • PHP Manual
  • Funciones de DB++
  • Cierra una relación

dbplus_close

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_close — Cierra una relación

Descripción

dbplus_close ( resource $relation ) : mixed

Cierra una relación abierta previamente con dbplus_open().

Parámetros

relation

Una relación abierta mediante dbplus_open().

Valores devueltos

Devuelve true si se tuvo éxito o DBPLUS_ERR_UNKNOWN si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Get current tuple from relation

  • « dbplus_close
  • dbplus_errcode »
  • PHP Manual
  • Funciones de DB++
  • Get current tuple from relation

dbplus_curr

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_curr — Get current tuple from relation

Descripción

dbplus_curr ( resource $relation , array &$tuple ) : int

Lee la información de la tupla actual de la relación relation dada.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

La información será devuelta a este parámetro como una matriz asociativa.

Valores devueltos

La función devolverá cero (es decir, DBPLUS_ERR_NOERR) si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_first() - Obtener la primera tupla de una relación
  • dbplus_prev() - Obtener la tupla previa de una relación
  • dbplus_next() - Obtener la siguiente tupla de una relación
  • dbplus_last() - Obtener la última tupla de una relación
  • dbplus_errcode() - Obtener la cadena de error de un código de error dado o del último error


Obtener la cadena de error de un código de error dado o del último error

  • « dbplus_curr
  • dbplus_errno »
  • PHP Manual
  • Funciones de DB++
  • Obtener la cadena de error de un código de error dado o del último error

dbplus_errcode

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_errcode — Obtener la cadena de error de un código de error dado o del último error

Descripción

dbplus_errcode ( int $errno = ? ) : string

Devuelve una cadena de error limpia del código de error dado.

Parámetros

errno

El código de error. Si no se proporcionó, se asume el código resultante de la última operación de db++.

Valores devueltos

Devuelve el mensaje de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener el código de error de la última operación

  • « dbplus_errcode
  • dbplus_find »
  • PHP Manual
  • Funciones de DB++
  • Obtener el código de error de la última operación

dbplus_errno

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_errno — Obtener el código de error de la última operación

Descripción

dbplus_errno ( ) : int

Devuelve un código de error devuelto por la última operación de db++.

Valores devueltos

Devuelve el código de error como un entero.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_errcode() - Obtener la cadena de error de un código de error dado o del último error


Establecer una restricción en una relación

  • « dbplus_errno
  • dbplus_first »
  • PHP Manual
  • Funciones de DB++
  • Establecer una restricción en una relación

dbplus_find

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_find — Establecer una restricción en una relación

Descripción

dbplus_find ( resource $relation , array $constraints , mixed $tuple ) : int

Pone una restricción a la relación relation dada.

Llamadas posteriores a funciones como dbplus_curr() o dbplus_next() devolverán sólamente las tuplas que coincidan las restricciones dadas.

Parámetros

relation

Una relación abierta por dbplus_open().

constraints

Las restricciones son tríos de cadenas de contienen un nombre de dominio, un operador de comparación y un valor de comparación. El parámetro matriz constraints puede consistir en una colección de matrices de cadenas, cada una conteniendo un dominio, un operador y un valor, o una matriz de cadenas simple conteniendo un múltiplo de tres elementos.

El operador de comparación puede ser una de las siguientes cadenas: '==', '>', '>=', '<', '<=', '!=', '~' para una comparación de expresión regular y 'BAND' o 'BOR' para operaciones a nivel de bits.

tuple

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_unselect() - Eliminar una restricción de una relación


Obtener la primera tupla de una relación

  • « dbplus_find
  • dbplus_flush »
  • PHP Manual
  • Funciones de DB++
  • Obtener la primera tupla de una relación

dbplus_first

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_first — Obtener la primera tupla de una relación

Descripción

dbplus_first ( resource $relation , array &$tuple ) : int

Lee la información de la primera tupla de relation, la hace la actual y la devuelve como una matriz asociativa en tuple.

Parámetros

relation

Una relación abierta mediante dbplus_open().

tuple

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Obtener la tupla previa de una relación
  • dbplus_next() - Obtener la siguiente tupla de una relación
  • dbplus_last() - Obtener la última tupla de una relación
  • dbplus_errcode() - Obtener la cadena de error de un código de error dado o del último error


Vuelca todos los cambios hechos en una relación

  • « dbplus_first
  • dbplus_freealllocks »
  • PHP Manual
  • Funciones de DB++
  • Vuelca todos los cambios hechos en una relación

dbplus_flush

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_flush — Vuelca todos los cambios hechos en una relación

Descripción

dbplus_flush ( resource $relation ) : int

Escribe todos los cambios aplicados a relation desde el último vuelco a disco.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_errcode() - Obtener la cadena de error de un código de error dado o del último error


Liberar todos los bloqueos mantenidos por este cliente

  • « dbplus_flush
  • dbplus_freelock »
  • PHP Manual
  • Funciones de DB++
  • Liberar todos los bloqueos mantenidos por este cliente

dbplus_freealllocks

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freealllocks — Liberar todos los bloqueos mantenidos por este cliente

Descripción

dbplus_freealllocks ( ) : int

Libera todos los bloqueos de tupla mantenidos por este cliente.

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_getlock() - Obtener un bloqueo de escritura en una tupla
  • dbplus_freelock() - Libera el bloqueo de escritura en una tupla
  • dbplus_freerlocks() - Liberar todos los bloqueos de una relación dada


Libera el bloqueo de escritura en una tupla

  • « dbplus_freealllocks
  • dbplus_freerlocks »
  • PHP Manual
  • Funciones de DB++
  • Libera el bloqueo de escritura en una tupla

dbplus_freelock

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freelock — Libera el bloqueo de escritura en una tupla

Descripción

dbplus_freelock ( resource $relation , string $tuple ) : int

Libera el bloqueo de escritura en tuple previamente obtenido mediante dbplus_getlock().

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_getlock() - Obtener un bloqueo de escritura en una tupla
  • dbplus_freerlocks() - Liberar todos los bloqueos de una relación dada
  • dbplus_freealllocks() - Liberar todos los bloqueos mantenidos por este cliente


Liberar todos los bloqueos de una relación dada

  • « dbplus_freelock
  • dbplus_getlock »
  • PHP Manual
  • Funciones de DB++
  • Liberar todos los bloqueos de una relación dada

dbplus_freerlocks

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freerlocks — Liberar todos los bloqueos de una relación dada

Descripción

dbplus_freerlocks ( resource $relation ) : int

Libera todos los bloqueos de tuplas mantenidos por relation.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_getlock() - Obtener un bloqueo de escritura en una tupla
  • dbplus_freelock() - Libera el bloqueo de escritura en una tupla
  • dbplus_freealllocks() - Liberar todos los bloqueos mantenidos por este cliente


Obtener un bloqueo de escritura en una tupla

  • « dbplus_freerlocks
  • dbplus_getunique »
  • PHP Manual
  • Funciones de DB++
  • Obtener un bloqueo de escritura en una tupla

dbplus_getlock

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_getlock — Obtener un bloqueo de escritura en una tupla

Descripción

dbplus_getlock ( resource $relation , string $tuple ) : int

Solicita un bloqueo de escritura en la tupla tuple especificada.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Devuelve cero si se tuvo éxito o un código de error distinto de cero, especialmente DBPLUS_ERR_WLOCKED, si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_freelock() - Libera el bloqueo de escritura en una tupla
  • dbplus_freerlocks() - Liberar todos los bloqueos de una relación dada
  • dbplus_freealllocks() - Liberar todos los bloqueos mantenidos por este cliente


Obtener un único número de identificación para una relación

  • « dbplus_getlock
  • dbplus_info »
  • PHP Manual
  • Funciones de DB++
  • Obtener un único número de identificación para una relación

dbplus_getunique

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_getunique — Obtener un único número de identificación para una relación

Descripción

dbplus_getunique ( resource $relation , int $uniqueid ) : int

Obtiene un número que garantiza ser único para relation y se devolverá en la variable dada como uniqueid.

Parámetros

relation

Una relación abierta con dbplus_open().

uniqueid

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener información sobre una relación

  • « dbplus_getunique
  • dbplus_last »
  • PHP Manual
  • Funciones de DB++
  • Obtener información sobre una relación

dbplus_info

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_info — Obtener información sobre una relación

Descripción

dbplus_info ( resource $relation , string $key , array &$result ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

key

result

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener la última tupla de una relación

  • « dbplus_info
  • dbplus_lockrel »
  • PHP Manual
  • Funciones de DB++
  • Obtener la última tupla de una relación

dbplus_last

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_last — Obtener la última tupla de una relación

Descripción

dbplus_last ( resource $relation , array &$tuple ) : int

Lee la información de la última tupla de relation, la hace la tupla actual y la devuelve como una matriz asociativa en tuple.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_first() - Obtener la primera tupla de una relación
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Obtener la tupla previa de una relación
  • dbplus_next() - Obtener la siguiente tupla de una relación


Solictar un bloqueo de escritura en una relación

  • « dbplus_last
  • dbplus_next »
  • PHP Manual
  • Funciones de DB++
  • Solictar un bloqueo de escritura en una relación

dbplus_lockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_lockrel — Solictar un bloqueo de escritura en una relación

Descripción

dbplus_lockrel ( resource $relation ) : int

Solicita un bloqueo de escritura en la relación relation dada.

Los demás clientes pueden seguir consultando la relación, pero no pueden alterarla mientras esté bloqueada.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener la siguiente tupla de una relación

  • « dbplus_lockrel
  • dbplus_open »
  • PHP Manual
  • Funciones de DB++
  • Obtener la siguiente tupla de una relación

dbplus_next

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_next — Obtener la siguiente tupla de una relación

Descripción

dbplus_next ( resource $relation , array &$tuple ) : int

Lee la información de la siguiente tupla de relation, la hace la tupla actual y la devuelve como una matriz asociativa en tuple.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_first() - Obtener la primera tupla de una relación
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Obtener la tupla previa de una relación
  • dbplus_last() - Obtener la última tupla de una relación


Abre un archivo de relación

  • « dbplus_next
  • dbplus_prev »
  • PHP Manual
  • Funciones de DB++
  • Abre un archivo de relación

dbplus_open

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_open — Abre un archivo de relación

Descripción

dbplus_open ( string $name ) : resource

Abre el archivo de relación dado.

Parámetros

name

Puede ser un nombre de archivo o un nombre de ruta absoluta o relativa. Será mapeado en cualquier caso a una ruta de archivo de relación absoluto en una máquina y servidor específicos.

Valores devueltos

Si se tuvo éxito, se devuelve un recurso de archivo de relación (cursor) que debe ser usado en cualquier comando subsiguiente que referencie a la relación. El fallo conduce a un valor de retorno cero, el códigon de error actual puede ser solicitado llamando a dbplus_errno().

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtener la tupla previa de una relación

  • « dbplus_open
  • dbplus_rchperm »
  • PHP Manual
  • Funciones de DB++
  • Obtener la tupla previa de una relación

dbplus_prev

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_prev — Obtener la tupla previa de una relación

Descripción

dbplus_prev ( resource $relation , array &$tuple ) : int

Lee la información de la tupla previa de la relación dada por relation, la hace la tupla actual y la devuelve como una matriz asociativa en tuple.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Devuelve DBPLUS_ERR_NOERR si se tuvo éxito o un código de error de db++ si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_first() - Obtener la primera tupla de una relación
  • dbplus_curr() - Get current tuple from relation
  • dbplus_next() - Obtener la siguiente tupla de una relación
  • dbplus_last() - Obtener la última tupla de una relación


Cambiar los permisos de una relación

  • « dbplus_prev
  • dbplus_rcreate »
  • PHP Manual
  • Funciones de DB++
  • Cambiar los permisos de una relación

dbplus_rchperm

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rchperm — Cambiar los permisos de una relación

Descripción

dbplus_rchperm ( resource $relation , int $mask , string $user , string $group ) : int

Cambia los permisos de acceso de la manera especificada por mask, user y group. Los valores para estos parámetros son específicos del sistema operativo.

Parámetros

relation

Una relación abierta con dbplus_open().

mask

user

group

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea una nueva relación de DB++

  • « dbplus_rchperm
  • dbplus_rcrtexact »
  • PHP Manual
  • Funciones de DB++
  • Crea una nueva relación de DB++

dbplus_rcreate

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcreate — Crea una nueva relación de DB++

Descripción

dbplus_rcreate ( string $name , mixed $domlist , bool $overwrite = ? ) : resource

Crea una nueva relación. Cualquier relación existente que comparta el mismo nombre dado por name será sobrescrita si la relación no está actualmente en uso y overwrite está establecido a TRUE.

Parámetros

name

domlist

Una combinación de dominios. Se puede pasar como una cadena simple de nombre de dominio o como una matriz de nombres de dominio.

Este parámetro debería contener la especificación de dominio para la nueva relación dentro de una matriz de cadenas de descripción de dominios. Una cadena de descripción de dominios consiste en un nombre de dominio único para esta relación, una barra y un carácter de especificación de tipo. Véase la documentación de db++, especialmente la página del manual de dbcreate(1), para una descripción de los especificadores de tipo y sus significados.

Nota:

Esta función también aceptará una cadena con cadenas de descripción de dominio delimitadas por espacios, pero se recomienda usar una matriz

overwrite

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea una copia exacta pero vacía de una relación incluyendo los índices

  • « dbplus_rcreate
  • dbplus_rcrtlike »
  • PHP Manual
  • Funciones de DB++
  • Crea una copia exacta pero vacía de una relación incluyendo los índices

dbplus_rcrtexact

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcrtexact — Crea una copia exacta pero vacía de una relación incluyendo los índices

Descripción

dbplus_rcrtexact ( string $name , resource $relation , bool $overwrite = ? ) : mixed

dbplus_rcrtexact() creará una copia exacta pero vacía de relation bajo un nuevo nombre dado por name.

Parámetros

name

relation

La relación copiada, abierta por dbplus_open().

overwrite

Una relación existente con el mismo nombre dado por name sólo será sobrescirta si este parámetro está establecido a true y ningún otro proceso está actualmente usando la relación.

Valores devueltos

Devuelve un recurso si se tuvo éxito o DBPLUS_ERR_UNKNOWN si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea una copia vacía de una relación con los índeces predeterminados

  • « dbplus_rcrtexact
  • dbplus_resolve »
  • PHP Manual
  • Funciones de DB++
  • Crea una copia vacía de una relación con los índeces predeterminados

dbplus_rcrtlike

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcrtlike — Crea una copia vacía de una relación con los índeces predeterminados

Descripción

dbplus_rcrtlike ( string $name , resource $relation , int $overwrite = ? ) : mixed

dbplus_rcrtexact() creará una copia vacía de la relación dada por relation bajo un nuevo nombre dado por name, pero con los índices predeterminados.

Parámetros

name

relation

La relación copiada, abierta mediante dbplus_open().

overwrite

Una relación existente con el mismo nombre dado por name sólo será sobrescirta si este parámetro está establecido a true y ningún otro proceso está actualmente usando la relación.

Valores devueltos

Devuelve un recurso si se tuvo éxito o DBPLUS_ERR_UNKNOWN si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Resuelve la información del host de la relación

  • « dbplus_rcrtlike
  • dbplus_restorepos »
  • PHP Manual
  • Funciones de DB++
  • Resuelve la información del host de la relación

dbplus_resolve

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_resolve — Resuelve la información del host de la relación

Descripción

dbplus_resolve ( string $relation_name ) : array

dbplus_resolve() intentará resolver relation_name y encontrar el id interno del servidor, el nombre real del host y la ruta de la base de datos en este host.

Parámetros

relation_name

El nombre de la relación.

Valores devueltos

Devuelve una matriz que contiene estos valores bajo las claves sid, host y host_path o false si ocurrió un error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_tcl() - Ejecutar código TCL en el lado del servidor


Restablece la posición

  • « dbplus_resolve
  • dbplus_rkeys »
  • PHP Manual
  • Funciones de DB++
  • Restablece la posición

dbplus_restorepos

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_restorepos — Restablece la posición

Descripción

dbplus_restorepos ( resource $relation , array $tuple ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Especificar una nueva clave primaria para un relaición

  • « dbplus_restorepos
  • dbplus_ropen »
  • PHP Manual
  • Funciones de DB++
  • Especificar una nueva clave primaria para un relaición

dbplus_rkeys

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rkeys — Especificar una nueva clave primaria para un relaición

Descripción

dbplus_rkeys ( resource $relation , mixed $domlist ) : mixed

dbplus_rkeys() reemplazará la clave primaria actual de relation con la combinación de dominios especificados por domlist.

Parámetros

relation

Una relación abierta con dbplus_open().

domlist

Una combinación de dominios. Se puede pasar como una simple cadena de nombre de dominio o como una matriz de nombres de dominio.

Valores devueltos

Devuelve un recurso si se tuvo éxito o DBPLUS_ERR_UNKNOWN si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Abrir un archivo local de relación

  • « dbplus_rkeys
  • dbplus_rquery »
  • PHP Manual
  • Funciones de DB++
  • Abrir un archivo local de relación

dbplus_ropen

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_ropen — Abrir un archivo local de relación

Descripción

dbplus_ropen ( string $name ) : resource

dbplus_ropen() abrirá el archivo de relación file localmente para un acceso rápido sin ningún overhead de cliente/servidor. El acceso es de sólo lectura y solamente puede ser aplicado dbplus_curr() y dbplus_next() a la relación devuelta.

Parámetros

name

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Realizar una consulta AQL local (en bruto)

  • « dbplus_ropen
  • dbplus_rrename »
  • PHP Manual
  • Funciones de DB++
  • Realizar una consulta AQL local (en bruto)

dbplus_rquery

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rquery — Realizar una consulta AQL local (en bruto)

Descripción

dbplus_rquery ( string $query , string $dbpath = ? ) : resource

dbplus_rquery() realiza una consulta AQL local (en bruto) usando un intérprete de AQL embebido dentro de la biblioteca cliente de db++. dbplus_rquery() es más rápitda que dbplus_aql() pero sólo trabajará sobre información local.

Parámetros

query

dbpath

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Renombrar una relación

  • « dbplus_rquery
  • dbplus_rsecindex »
  • PHP Manual
  • Funciones de DB++
  • Renombrar una relación

dbplus_rrename

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rrename — Renombrar una relación

Descripción

dbplus_rrename ( resource $relation , string $name ) : int

dbplus_rrename() cambiará el nombre de relation al dado por name.

Parámetros

relation

Una relación abierta con dbplus_open().

name

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crear un nuevo índice secundario para una relación

  • « dbplus_rrename
  • dbplus_runlink »
  • PHP Manual
  • Funciones de DB++
  • Crear un nuevo índice secundario para una relación

dbplus_rsecindex

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rsecindex — Crear un nuevo índice secundario para una relación

Descripción

dbplus_rsecindex ( resource $relation , mixed $domlist , int $type ) : mixed

dbplus_rsecindex() Creará un nuevo índice secundario para relation que consiste en los dominios especificados por domlist y es del tipo type

Parámetros

relation

Una relación abierta con dbplus_open().

domlist

Una combinación de dominios. Se puede pasar como una cadena simple dominio o como una matriz de nombres de dominio.

type

Valores devueltos

Devuelve un recurso si tuvo éxito o DBPLUS_ERR_UNKNOWN si falló.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Eliminar una relación del sistema de archivos

  • « dbplus_rsecindex
  • dbplus_rzap »
  • PHP Manual
  • Funciones de DB++
  • Eliminar una relación del sistema de archivos

dbplus_runlink

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_runlink — Eliminar una relación del sistema de archivos

Descripción

dbplus_runlink ( resource $relation ) : int

dbplus_runlink() Cerrará y eliminará la relación dada por relation.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Eliminar todas las tuplas de una relación

  • « dbplus_runlink
  • dbplus_savepos »
  • PHP Manual
  • Funciones de DB++
  • Eliminar todas las tuplas de una relación

dbplus_rzap

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rzap — Eliminar todas las tuplas de una relación

Descripción

dbplus_rzap ( resource $relation ) : int

dbplus_rzap() eliminará todas las tuplas de relation.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Guardar la posición

  • « dbplus_rzap
  • dbplus_setindex »
  • PHP Manual
  • Funciones de DB++
  • Guardar la posición

dbplus_savepos

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_savepos — Guardar la posición

Descripción

dbplus_savepos ( resource $relation ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Establecer el índice

  • « dbplus_savepos
  • dbplus_setindexbynumber »
  • PHP Manual
  • Funciones de DB++
  • Establecer el índice

dbplus_setindex

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_setindex — Establecer el índice

Descripción

dbplus_setindex ( resource $relation , string $idx_name ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

idx_name

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Establecer el índice por número

  • « dbplus_setindex
  • dbplus_sql »
  • PHP Manual
  • Funciones de DB++
  • Establecer el índice por número

dbplus_setindexbynumber

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_setindexbynumber — Establecer el índice por número

Descripción

dbplus_setindexbynumber ( resource $relation , int $idx_number ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

idx_number

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Realiza una consulta SQL

  • « dbplus_setindexbynumber
  • dbplus_tcl »
  • PHP Manual
  • Funciones de DB++
  • Realiza una consulta SQL

dbplus_sql

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_sql — Realiza una consulta SQL

Descripción

dbplus_sql ( string $query , string $server = ? , string $dbpath = ? ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

query

server

dbpath

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Ejecutar código TCL en el lado del servidor

  • « dbplus_sql
  • dbplus_tremove »
  • PHP Manual
  • Funciones de DB++
  • Ejecutar código TCL en el lado del servidor

dbplus_tcl

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_tcl — Ejecutar código TCL en el lado del servidor

Descripción

dbplus_tcl ( int $sid , string $script ) : string

Un servidor db++ preparará un intérprete de TCL para una conexión cliente. Este intérprete habilitará el servidor para ejecutar código TCL proporcionado por el cliente como un tipo de procedimientos para mejorar el rendimiento de las operaciones de la base de datos evitando transferencias de datos cliente/servidor e intercambio de contextos.

dbplus_tcl() necesita pasar el id de conexión de cliente que debería ejecutar el código de script TCL. dbplus_resolve() proporcionará esta id de conexión. La función devolverá lo que sea que devuelve el código TCL o un mensaje de error TCL si el código TCL falla.

Parámetros

sid

script

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_resolve() - Resuelve la información del host de la relación


Eliminar una tupla y devolver la nueva tupla actual

  • « dbplus_tcl
  • dbplus_undo »
  • PHP Manual
  • Funciones de DB++
  • Eliminar una tupla y devolver la nueva tupla actual

dbplus_tremove

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_tremove — Eliminar una tupla y devolver la nueva tupla actual

Descripción

dbplus_tremove ( resource $relation , array $tuple , array &$current = ? ) : int

dbplus_tremove() elimina tuple de relation si coincide exactamente con una tupla dentro de la relación. current, si se da, contentrá la información de la nueva tupla actual después de llamar a dbplus_tremove().

Parámetros

relation

Una relación abierta con dbplus_open().

tuple

current

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Deshacer

  • « dbplus_tremove
  • dbplus_undoprepare »
  • PHP Manual
  • Funciones de DB++
  • Deshacer

dbplus_undo

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_undo — Deshacer

Descripción

dbplus_undo ( resource $relation ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Preparara deshacer

  • « dbplus_undo
  • dbplus_unlockrel »
  • PHP Manual
  • Funciones de DB++
  • Preparara deshacer

dbplus_undoprepare

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_undoprepare — Preparara deshacer

Descripción

dbplus_undoprepare ( resource $relation ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Liberar un bloqueo de escritura en una relación

  • « dbplus_undoprepare
  • dbplus_unselect »
  • PHP Manual
  • Funciones de DB++
  • Liberar un bloqueo de escritura en una relación

dbplus_unlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_unlockrel — Liberar un bloqueo de escritura en una relación

Descripción

dbplus_unlockrel ( resource $relation ) : int

Libera un bloqueo de escritura obtenido previamente por dbplus_lockrel().

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Eliminar una restricción de una relación

  • « dbplus_unlockrel
  • dbplus_update »
  • PHP Manual
  • Funciones de DB++
  • Eliminar una restricción de una relación

dbplus_unselect

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_unselect — Eliminar una restricción de una relación

Descripción

dbplus_unselect ( resource $relation ) : int

Al llamar a dbplus_unselect() se eliminará una restricción previamente establecida por dbplus_find() en relation.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Actualizar la tupla especificada en la relación

  • « dbplus_unselect
  • dbplus_xlockrel »
  • PHP Manual
  • Funciones de DB++
  • Actualizar la tupla especificada en la relación

dbplus_update

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_update — Actualizar la tupla especificada en la relación

Descripción

dbplus_update ( resource $relation , array $old , array $new ) : int

dbplus_update() reemplaza la tupla old con la información de la dada por new, sólo si old coincide completamente con una tupla dentro de relation.

Parámetros

relation

Una relación abierta con dbplus_open().

old

La tupla antigua.

new

La nueva tupla.

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Solicitar un bloqueo exclusivo de una relación

  • « dbplus_update
  • dbplus_xunlockrel »
  • PHP Manual
  • Funciones de DB++
  • Solicitar un bloqueo exclusivo de una relación

dbplus_xlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_xlockrel — Solicitar un bloqueo exclusivo de una relación

Descripción

dbplus_xlockrel ( resource $relation ) : int

Solicita un bloqueo exclusivo de relation previniendo incluso de acceso a lectura de otros clientes.

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • dbplus_xunlockrel() - Liberar un bloqueo exclusivo en una relación


Liberar un bloqueo exclusivo en una relación

  • « dbplus_xlockrel
  • dBase »
  • PHP Manual
  • Funciones de DB++
  • Liberar un bloqueo exclusivo en una relación

dbplus_xunlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_xunlockrel — Liberar un bloqueo exclusivo en una relación

Descripción

dbplus_xunlockrel ( resource $relation ) : int

Libera un bloqueo exclusivo previamente obtenido por dbplus_xlockrel().

Parámetros

relation

Una relación abierta con dbplus_open().

Valores devueltos

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


dBase

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de dBase
    • dbase_add_record — Añade un registro a una base de datos
    • dbase_close — Cierra una base de datos
    • dbase_create — Crea una base de datos
    • dbase_delete_record — Borra un registro de una base de datos
    • dbase_get_header_info — Obtiene la información de cabecera de una base de datos
    • dbase_get_record_with_names — Obtiene un registro de una base de datos como una matriz asociativa
    • dbase_get_record — Obtiene un registro de una base de datos como una matriz indexada
    • dbase_numfields — Obtiene el número de campos de una base de datos
    • dbase_numrecords — Obtener el número de registros de una base de datos
    • dbase_open — Abre una base de datos
    • dbase_pack — Empaquetar una base de datos
    • dbase_replace_record — Reemplaza un registro en una base de datos


Introducción

Estas funciones permiten el acceso a registros almacenados en bases de datos con formato dBase (dbf).

Los ficheros dBase son sencillamete ficheros secuenciales de registros de longitud fija. Los registros se añaden al final del fichero, y los registros borrados son guardados hasta que se llame a dbase_pack().

Los tipos de campos de dBase disponibles son:

Tipos de campos disponibles
Campo | Tipo de dBase | Formato | Información adicional
M | Memo | n/a | Este tipo no está soportado por PHP, por lo que este campo será ignorado
D | Date | YYYYMMDD | La longitud del campo está limitada a 8
N | Number | Un número | Se puede declarar la longitud y la precisión (el número de dígitos después del punto decimal)
C | String | Una cadena | Se puede declarar la longitud. Cuando se recuperan datos, la cadena será rellenada con espacios a la derecha para ajustarse a la longitud declarada.
L | Boolean | T o Y para true, F o N para false | Almacenado y devuelto como un valor de tipo integer (1 o 0)
F | Float | Un número de punto flotante | El soporte para este tipo de campo se añadió en PHP 5.2.0

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.3.0.

Advertencia

No hay soporte para campos de índices o de memo. Tampoco hay soporte para el bloqueo. Dos procesos del servidor web concurrentes que modifiquen el mismo fichero de dBase arruinará la base de datos.

Se recomienda que no use ficheros dBase como su base de datos de producción. Elija cualquier servidor SQL real en su lugar; » MySQL o » Postgres son elecciones comunes con PHP. El soporte para dBase está permitido aquí para importar y exportar datos desde y hacia su base de datos web, ya que el formato de fichero comúnmente lo entienden hojas de cálculo y organizadores de Windows.


Instalación

Para habilitar la biblioteca incluida de dbase y usar estas funciones se debe compilar PHP con la opción --enable-dbase .


  • « Tipos de recursos
  • Funciones de dBase »
  • PHP Manual
  • dBase
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de dBase

Ejemplos

Muchos ejemplos en esta referencia requieren una base de datos dBase. Se usará /tmp/test.dbf que será creada en el ejemplo de dbase_create().

Tabla de contenidos

  • dbase_add_record — Añade un registro a una base de datos
  • dbase_close — Cierra una base de datos
  • dbase_create — Crea una base de datos
  • dbase_delete_record — Borra un registro de una base de datos
  • dbase_get_header_info — Obtiene la información de cabecera de una base de datos
  • dbase_get_record_with_names — Obtiene un registro de una base de datos como una matriz asociativa
  • dbase_get_record — Obtiene un registro de una base de datos como una matriz indexada
  • dbase_numfields — Obtiene el número de campos de una base de datos
  • dbase_numrecords — Obtener el número de registros de una base de datos
  • dbase_open — Abre una base de datos
  • dbase_pack — Empaquetar una base de datos
  • dbase_replace_record — Reemplaza un registro en una base de datos


Añade un registro a una base de datos

  • « Funciones de dBase
  • dbase_close »
  • PHP Manual
  • Funciones de dBase
  • Añade un registro a una base de datos

dbase_add_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_add_record — Añade un registro a una base de datos

Descripción

dbase_add_record ( int $dbase_identifier , array $record ) : bool

Añade la información dad a la base de datos.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

record

Una matriz indexada de información. El número de elementos debe ser igual al número de campos de la base de datos, si no otherwise dbase_add_record() fallará.

Nota:

Si se está usando el valor devuelto por dbase_get_record() para este parámetro, recuerde de reiniciar la clave llamada deleted.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Insertar un registro en una base de datos dBase

<?php

// abrir en modo lectura-escritura
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  dbase_add_record($db, array(
      date('Ymd'),
      'Maxim Topolov',
      '23',
      'max@example.com',
      'T'));
  dbase_close($db);
}

?>

Ver también

  • dbase_delete_record() - Borra un registro de una base de datos
  • dbase_replace_record() - Reemplaza un registro en una base de datos


Cierra una base de datos

  • « dbase_add_record
  • dbase_create »
  • PHP Manual
  • Funciones de dBase
  • Cierra una base de datos

dbase_close

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_close — Cierra una base de datos

Descripción

dbase_close ( int $dbase_identifier ) : bool

Cierra el identificador de enlace de la base de datos dado.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cerrar un archivo de base de datos de dBase

<?php

// abrir en modo sólo lectura
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // leer alguna información ..

  dbase_close($db);
}

?>

Ver también

  • dbase_open() - Abre una base de datos
  • dbase_create() - Crea una base de datos


Crea una base de datos

  • « dbase_close
  • dbase_delete_record »
  • PHP Manual
  • Funciones de dBase
  • Crea una base de datos

dbase_create

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_create — Crea una base de datos

Descripción

dbase_create ( string $filename , array $fields ) : int

dbase_create() crea una base de datos dBase con la definición dada.

Nota:

Esta función se ve afectada por open_basedir.

Parámetros

filename

El nombre de la base de datos. Puede ser una ruta relativa o absoluta al archivo donde dBase almacenará la información.

fields

Una matriz de matrices, donde cada matriz describe el formato de un campo de la base de datos. Cada campo consiste en un nombre, un carácter que indica el tipo de campo y, opcionalmte, una longitud y una precisión.

Nota:

Los nombres de los campos están limitados en longitud y no deben exceder 10 caracteres.

Valores devueltos

Devuelve un identificador de enlace de la base de datos si la base de datos se creó con éxito, o false si ocurrión un error.

Ejemplos

Ejemplo #1 Crear un archivo de base de datos dBase

<?php

// "Definición" de la base de datos
$def = array(
  array("date",     "D"),
  array("name",     "C",  50),
  array("age",      "N",   3, 0),
  array("email",    "C", 128),
  array("ismember", "L")
);

// creación
if (!dbase_create('/tmp/test.dbf', $def)) {
  echo "Error, no se puede crear la base de datos\n";
}

?>

Ver también

  • dbase_open() - Abre una base de datos
  • dbase_close() - Cierra una base de datos


Borra un registro de una base de datos

  • « dbase_create
  • dbase_get_header_info »
  • PHP Manual
  • Funciones de dBase
  • Borra un registro de una base de datos

dbase_delete_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_delete_record — Borra un registro de una base de datos

Descripción

dbase_delete_record ( int $dbase_identifier , int $record_number ) : bool

Marca el registro dado para ser borrado de la base de datos.

Nota:

En realidad, para eliminar el registro de la base de datos, se debe llamar también a dbase_pack().

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

record_number

Un entero que abarca desde 1 al número de registros de la base de datos (como el devuelto por dbase_numrecords()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • dbase_add_record() - Añade un registro a una base de datos
  • dbase_replace_record() - Reemplaza un registro en una base de datos


Obtiene la información de cabecera de una base de datos

  • « dbase_delete_record
  • dbase_get_record_with_names »
  • PHP Manual
  • Funciones de dBase
  • Obtiene la información de cabecera de una base de datos

dbase_get_header_info

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_header_info — Obtiene la información de cabecera de una base de datos

Descripción

dbase_get_header_info ( int $dbase_identifier ) : array

Devuelve la información de la estructura de columna del identificador de enlace de la base de datos dada.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

Valores devueltos

Una matriz indexada con una entrada para cada columna de la base de datos. El índice de la matriz comienza en 0.

Cada elemento de la matriz contiene una matriz asociativa de información de columna, como se describe a continuación:

name
El nombre de la columna
type
El nombre legible por humanos del tipo de dbase de la columna (p.ej. date, boolean, etc.)
length
El número de bytes que puede soportar esta columna
precision
El número de dígitos de precisión decimal de la columna
format
Un especificador de formato de printf() sugerido para la columna
offset
El índice de byte de la columna desde el inicio de la fila

Si no se puede leer la información de la cabecera de la base de datos, se devuleve false.

Ejemplos

Ejemplo #1 Mostrar la información de cabecera de un archivo de base de datos dBase

<?php
// Ruta al archivo dbase
$ruta_db = "/tmp/test.dbf";

// Abrir un el archivo dbase
$dbh = dbase_open($ruta_db, 0)
  or die("¡Error! No se pudo abrir el archivo de base de datos dbase '$ruta_db'.");

// Obtener la información de columna
$info_columna = dbase_get_header_info($dbh);

// Mostrar la información
print_r($info_columna);
?>


Obtiene un registro de una base de datos como una matriz asociativa

  • « dbase_get_header_info
  • dbase_get_record »
  • PHP Manual
  • Funciones de dBase
  • Obtiene un registro de una base de datos como una matriz asociativa

dbase_get_record_with_names

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record_with_names — Obtiene un registro de una base de datos como una matriz asociativa

Descripción

dbase_get_record_with_names ( int $dbase_identifier , int $record_number ) : array

Obtiene un registro de una base de datos dBase como una matriz asociativa.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

record_number

El índice del registro.

Valores devueltos

Una matriz asociativa con le registro. Esto también incluye una clave llamada deleted que está establecida a 1 si el registro ha sido marcado para el borrado (véase dbase_delete_record()).

Cada campo se convierte en el tipo de PHP apropiado, excepto:

  • Las fechas se dejan como cadenas.
  • Los valores int que habrían causado un desbordamiento (> 32 bits) se devuelve como cadenas.

Si ocurre un error, dbase_get_record_with_names() devolverá false.

Ejemplos

Ejemplo #1 Listar todos los miembros registrados en la base de datos

<?php
// abrir en modo sólo lectura
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $número_registros = dbase_numrecords($db);
  for ($i = 1; $i <= $número_registros; $i++) {
      $fila = dbase_get_record_with_names($db, $i);
      if ($fila['ismember'] == 1) {
          echo "Member #$i: " . trim($fila['name']) . "\n";
      }
  }
}
?>

Ver también

  • dbase_get_record() - Obtiene un registro de una base de datos como una matriz indexada


Obtiene un registro de una base de datos como una matriz indexada

  • « dbase_get_record_with_names
  • dbase_numfields »
  • PHP Manual
  • Funciones de dBase
  • Obtiene un registro de una base de datos como una matriz indexada

dbase_get_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record — Obtiene un registro de una base de datos como una matriz indexada

Descripción

dbase_get_record ( int $dbase_identifier , int $record_number ) : array

Obtiene un registro de una base de datos como una matriz indexada

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

record_number

El índice del registro.

Valores devueltos

Una matriz indexada con el registro. Esto también incluye una clave llamada deleted que está establecida a 1 si el registro ha sido marcado para el borrado (véase dbase_delete_record()).

Cada campo se convierte en el tipo de PHP apropiado, excepto:

  • Las fechas se dejan como cadenas.
  • Los valores int que habrían causado un desbordamiento (> 32 bits) se devuelve como cadenas.

Si ocurre un error, dbase_get_record() devolverá false.

Ver también

  • dbase_get_record_with_names() - Obtiene un registro de una base de datos como una matriz asociativa


Obtiene el número de campos de una base de datos

  • « dbase_get_record
  • dbase_numrecords »
  • PHP Manual
  • Funciones de dBase
  • Obtiene el número de campos de una base de datos

dbase_numfields

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numfields — Obtiene el número de campos de una base de datos

Descripción

dbase_numfields ( int $dbase_identifier ) : int

Obtiene el número de campos (columnas) de la base de datos especificada.

Nota:

El número de campos está entre 0 y dbase_numfields($db)-1, mientras que el número de registro está entre 1 y dbase_numrecords($db).

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

Valores devueltos

El número de campos de la base de datos, o false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de dbase_numfields()

<?php

$reg = dbase_get_record($db, $recno);
$nc  = dbase_numfields($db);
for ($i = 0; $i < $nc; $i++) {
  echo $reg[$i], "\n";
}

?>

Ver también

  • dbase_numrecords() - Obtener el número de registros de una base de datos


Obtener el número de registros de una base de datos

  • « dbase_numfields
  • dbase_open »
  • PHP Manual
  • Funciones de dBase
  • Obtener el número de registros de una base de datos

dbase_numrecords

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numrecords — Obtener el número de registros de una base de datos

Descripción

dbase_numrecords ( int $dbase_identifier ) : int

Obtiene el número de registros (filas) en la base de datos especificada.

Nota:

El número de registros está entre 1 y dbase_numrecords($db), mientras que el número de campos está entre 0 y dbase_numfields($db)-1.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

Valores devueltos

El número de registros de la base de datos, o false si ocurrió un error.

Ejemplos

Ejemplo #1 Recorrer todos los registros de la base de datos

<?php

// abrir en modo sólo lectura
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $número_registros = dbase_numrecords($db);
  for ($i = 1; $i <= $número_registros; $i++) {
      // hacer algo aquí para cada registro
  }
}

?>

Ver también

  • dbase_numfields() - Obtiene el número de campos de una base de datos


Abre una base de datos

  • « dbase_numrecords
  • dbase_pack »
  • PHP Manual
  • Funciones de dBase
  • Abre una base de datos

dbase_open

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_open — Abre una base de datos

Descripción

dbase_open ( string $filename , int $mode ) : int

dbase_open() abre una base de datos dBase con el modo de acceso dado.

Nota:

Esta función se ve afectada por open_basedir.

Parámetros

filename

El nombre de la base de datos. Puede ser una ruta relativa o absoluta al archivo donde dBase almacenará la información.

mode

Un entero que se corresponde a aquéllos de la llamada al sistema de open() (Normalmente 0 significa sólo lectura, 1 sólo escritura, y 2 lectura y escritura).

Nota:

No se puede abrir un archivo dBase en modo sólo escritura ya que la función fallará al leer la información de las cabeceras, por lo que no se puede usar 1 como mode.

Ejemplos

Ejemplo #1 Abrir un archivo de base de datos de dBase

<?php

// abrir en modo sólo lectura
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // leer alguna información ..

  dbase_close($db);
}

?>

Valores devueltos

Devuelve un identificador de enlace de la base de datos si ésta se abrió con éxito, o false si ocurrió un error.

Ver también

  • dbase_create() - Crea una base de datos
  • dbase_close() - Cierra una base de datos


Empaquetar una base de datos

  • « dbase_open
  • dbase_replace_record »
  • PHP Manual
  • Funciones de dBase
  • Empaquetar una base de datos

dbase_pack

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_pack — Empaquetar una base de datos

Descripción

dbase_pack ( int $dbase_identifier ) : bool

Empaqueta una base de datos borrando permanentemente todos los registros marcados para el borrado usando dbase_delete_record().

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create()..

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Vaciar una base de datos dBase

<?php

// abrir en modo lectura-escritura
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  $número_registros = dbase_numrecords($db);
  for ($i = 1; $i <= $número_registros; $i++) {
      dbase_delete_record($db, $i);
  }
  // expurgar la base de datos
  dbase_pack($db);
}

?>

Ver también

  • dbase_delete_record() - Borra un registro de una base de datos


Reemplaza un registro en una base de datos

  • « dbase_pack
  • filePro »
  • PHP Manual
  • Funciones de dBase
  • Reemplaza un registro en una base de datos

dbase_replace_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_replace_record — Reemplaza un registro en una base de datos

Descripción

dbase_replace_record ( int $dbase_identifier , array $record , int $record_number ) : bool

Reemplaza el registro dado en la base de datos con la información dada.

Parámetros

dbase_identifier

El identificador de enlace de la base de datos, devuelto por dbase_open() o dbase_create().

record

Ina matriz indexada de información. El número de elementos debe ser igual que el número de campos de la base de datos, de otro modo dbase_replace_record() fallará.

Nota:

Si se está usando el valor devulto por dbase_get_record() para este parámetro, recuerde de reiniciar la clave llamada deleted.

record_number

Un entero que abarca desde 1 hasta el número de registros de la base de datos (como el devuelto por dbase_numrecords()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Actualizar un registro en la base de datos

<?php

// abrir en modo lectura-escritura
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  // obtiene la fila antigua
  $fila = dbase_get_record_with_names($db, 1);

  // eliminar la entrada 'deleted'
  unset($fila['deleted']);

  // Actualizar el campo de fecga con la fecha actual
  $fila['date'] = date('Ymd');

  // Reemplazar el registro
  dbase_replace_record($db, $fila, 1);
  dbase_close($db);
}

?>

Ver también

  • dbase_add_record() - Añade un registro a una base de datos
  • dbase_delete_record() - Borra un registro de una base de datos


filePro

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de filePro
    • filepro_fieldcount — Encuentra cuantos campos hay en una base de datos filePro
    • filepro_fieldname — Obtiene el nombre de un campo
    • filepro_fieldtype — Obtiene el tipo de campo
    • filepro_fieldwidth — Obtiene el ancho de un campo
    • filepro_retrieve — Obtiene datos de una base de datos filePro
    • filepro_rowcount — Averigüa cuantas filas hay en una base de datos filePro
    • filepro — Lee y verifica el mapa del fichero


Introducción

Estas funciones permite acceso solo-lectura a datos almacenados en bases de datos filePro.

filePro es una marca registrada de fP Technologies, Inc. Se puede encontrar más información a cerca de filePro en » http://www.fptech.com/.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.2.0.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/filepro.


  • « Tipos de recursos
  • Funciones de filePro »
  • PHP Manual
  • filePro
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de filePro

Tabla de contenidos

  • filepro_fieldcount — Encuentra cuantos campos hay en una base de datos filePro
  • filepro_fieldname — Obtiene el nombre de un campo
  • filepro_fieldtype — Obtiene el tipo de campo
  • filepro_fieldwidth — Obtiene el ancho de un campo
  • filepro_retrieve — Obtiene datos de una base de datos filePro
  • filepro_rowcount — Averigüa cuantas filas hay en una base de datos filePro
  • filepro — Lee y verifica el mapa del fichero


Encuentra cuantos campos hay en una base de datos filePro

  • « Funciones de filePro
  • filepro_fieldname »
  • PHP Manual
  • Funciones de filePro
  • Encuentra cuantos campos hay en una base de datos filePro

filepro_fieldcount

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldcount — Encuentra cuantos campos hay en una base de datos filePro

Descripción

filepro_fieldcount ( ) : int

Devuelve el número de campos (columnas) de la base de datos abierta filePro.

Valores devueltos

Devuelve el número de campos en la base de datos abierta filePro, o false si ocurre un error.

Ver también

  • filepro() - Lee y verifica el mapa del fichero


Obtiene el nombre de un campo

  • « filepro_fieldcount
  • filepro_fieldtype »
  • PHP Manual
  • Funciones de filePro
  • Obtiene el nombre de un campo

filepro_fieldname

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldname — Obtiene el nombre de un campo

Descripción

filepro_fieldname ( int $field_number ) : string

Devuelve el nombre del campo que corresponde a field_number.

Parámetros

field_number

El número de campo.

Valores devueltos

Devuelve el nombre del campo como cadena, o false en caso de error.


Obtiene el tipo de campo

  • « filepro_fieldname
  • filepro_fieldwidth »
  • PHP Manual
  • Funciones de filePro
  • Obtiene el tipo de campo

filepro_fieldtype

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldtype — Obtiene el tipo de campo

Descripción

filepro_fieldtype ( int $field_number ) : string

Devuelve el tipo de edición del campo correspondiente a field_number.

Parámetros

field_number

El campo numérico.

Valores devueltos

Devuelve el tipo de campo de edición como cadena, o false en caso de error.


Obtiene el ancho de un campo

  • « filepro_fieldtype
  • filepro_retrieve »
  • PHP Manual
  • Funciones de filePro
  • Obtiene el ancho de un campo

filepro_fieldwidth

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldwidth — Obtiene el ancho de un campo

Descripción

filepro_fieldwidth ( int $field_number ) : int

Devuelve el ancho de un campo correspondiente a field_number.

Parámetros

field_number

El número del campo.

Valores devueltos

Devuelve el ancho de un campo como entero, o false en caso de errores.


Obtiene datos de una base de datos filePro

  • « filepro_fieldwidth
  • filepro_rowcount »
  • PHP Manual
  • Funciones de filePro
  • Obtiene datos de una base de datos filePro

filepro_retrieve

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_retrieve — Obtiene datos de una base de datos filePro

Descripción

filepro_retrieve ( int $row_number , int $field_number ) : string

Devuelve los datos de una localización específica en la base de datos.

Parámetros

row_number

El número de la fila. Debe estar entre cero y el número total de filas menos uno (0..filepro_rowcount() - 1)

field_number

El número de la columna. Acepta valores entre cero y el número total de columnas menos uno (0..filepro_fieldcount() - 1)

Valores devueltos

Devuelve los datos especificados, o false en caso de errores.


Averigüa cuantas filas hay en una base de datos filePro

  • « filepro_retrieve
  • filepro »
  • PHP Manual
  • Funciones de filePro
  • Averigüa cuantas filas hay en una base de datos filePro

filepro_rowcount

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_rowcount — Averigüa cuantas filas hay en una base de datos filePro

Descripción

filepro_rowcount ( ) : int

Devuelve el número de columnas de una base de datos abierta filePro.

Valores devueltos

Devuelve el número de columnas de una base de datos abierta filePro, o false en caso de errores.

Ver también

  • filepro() - Lee y verifica el mapa del fichero


Lee y verifica el mapa del fichero

  • « filepro_rowcount
  • Firebird/InterBase »
  • PHP Manual
  • Funciones de filePro
  • Lee y verifica el mapa del fichero

filepro

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro — Lee y verifica el mapa del fichero

Descripción

filepro ( string $directory ) : bool

Lee y verifica el mapa del fichero, guardando el número de campos e información.

No se produce ningún bloqueo, así que se debería evitar modificar la base de datos cuando es abierto con PHP.

Parámetros

directory

El directorio del mapa.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Firebird/InterBase

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Firebird/InterBase
    • fbird_add_user — Alias de ibase_add_user
    • fbird_affected_rows — Alias de ibase_affected_rows
    • fbird_backup — Alias de ibase_backup
    • fbird_blob_add — Alias de ibase_blob_add
    • fbird_blob_cancel — Cancel creating blob
    • fbird_blob_close — Alias de ibase_blob_close
    • fbird_blob_create — Alias de ibase_blob_create
    • fbird_blob_echo — Alias de ibase_blob_echo
    • fbird_blob_get — Alias de ibase_blob_get
    • fbird_blob_import — Alias de ibase_blob_import
    • fbird_blob_info — Alias de ibase_blob_info
    • fbird_blob_open — Alias de ibase_blob_open
    • fbird_close — Alias de ibase_close
    • fbird_commit_ret — Alias de ibase_commit_ret
    • fbird_commit — Alias de ibase_commit
    • fbird_connect — Alias de ibase_connect
    • fbird_db_info — Alias de ibase_db_info
    • fbird_delete_user — Alias de ibase_delete_user
    • fbird_drop_db — Alias de ibase_drop_db
    • fbird_errcode — Alias de ibase_errcode
    • fbird_errmsg — Alias de ibase_errmsg
    • fbird_execute — Alias de ibase_execute
    • fbird_fetch_assoc — Alias de ibase_fetch_assoc
    • fbird_fetch_object — Alias de ibase_fetch_object
    • fbird_fetch_row — Alias de ibase_fetch_row
    • fbird_field_info — Alias de ibase_field_info
    • fbird_free_event_handler — Alias de ibase_free_event_handler
    • fbird_free_query — Alias de ibase_free_query
    • fbird_free_result — Alias de ibase_free_result
    • fbird_gen_id — Alias de ibase_gen_id
    • fbird_maintain_db — Alias de ibase_maintain_db
    • fbird_modify_user — Alias de ibase_modify_user
    • fbird_name_result — Alias de ibase_name_result
    • fbird_num_fields — Alias de ibase_num_fields
    • fbird_num_params — Alias de ibase_num_params
    • fbird_param_info — Alias de ibase_param_info
    • fbird_pconnect — Alias de ibase_pconnect
    • fbird_prepare — Alias de ibase_prepare
    • fbird_query — Alias de ibase_query
    • fbird_restore — Alias de ibase_restore
    • fbird_rollback_ret — Alias de ibase_rollback_ret
    • fbird_rollback — Alias de ibase_rollback
    • fbird_server_info — Alias de ibase_server_info
    • fbird_service_attach — Alias de ibase_service_attach
    • fbird_service_detach — Alias de ibase_service_detach
    • fbird_set_event_handler — Alias de ibase_set_event_handler
    • fbird_trans — Alias de ibase_trans
    • fbird_wait_event — Alias de ibase_wait_event
    • ibase_add_user — Añade un usuario a una base de datos segura
    • ibase_affected_rows — Devuelve el número de columnas afectadas por la última consulta
    • ibase_backup — Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente
    • ibase_blob_add — Añade datos a un nuevo blob
    • ibase_blob_cancel — Cancela la creación de un blob
    • ibase_blob_close — Cierra un blob
    • ibase_blob_create — Crea un nuevo blob al que añadir datos
    • ibase_blob_echo — Imprime el contenido de un blob
    • ibase_blob_get — Consulta un determinado número de bytes de un blob
    • ibase_blob_import — Crea un blob, copia un fichero en él, y lo cierra
    • ibase_blob_info — Devuelve el tamaño de un blob y otra información útil
    • ibase_blob_open — Abre un blob para su consulta
    • ibase_close — Cerrar una conexión con una base de datos InterBase
    • ibase_commit_ret — Lleva a cabo una transacción sin cerrarla
    • ibase_commit — Lleva a cabo una transacción
    • ibase_connect — Abrir una conexión a una base de datos
    • ibase_db_info — Consulta estadísticas de una base de datos
    • ibase_delete_user — Elimina un usuario de una base de datos segura
    • ibase_drop_db — Elimina una base de datos
    • ibase_errcode — Devuelve un código de error
    • ibase_errmsg — Devuelve un mensaje de error
    • ibase_execute — Ejecutar una consulta previamente preparada
    • ibase_fetch_assoc — Extra una fila en forma de array asociativo de una consulta
    • ibase_fetch_object — Consulta un objeto de una base de datos InterBase
    • ibase_fetch_row — Recuperar una fila desde una base de datos InterBase
    • ibase_field_info — Consulta información sobre un determinado campo
    • ibase_free_event_handler — Cancela un manejador de eventos ya registrado
    • ibase_free_query — Liberar la memoria reservada por una consulta preparada
    • ibase_free_result — Liberar un conjunto de resultados
    • ibase_gen_id — Incrementa el generador de nombres y devuelve su nuevo valor
    • ibase_maintain_db — Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos
    • ibase_modify_user — Modifica un usuario en una base de datos segura
    • ibase_name_result — Asigna un nombre a un juego de resultados
    • ibase_num_fields — Consulta el número de campos de un resultado
    • ibase_num_params — Devuelve el número de parámetros de una sentencia preparada
    • ibase_param_info — Devuelve información sobre un parámetro de una sentencia preparada
    • ibase_pconnect — Abrir una conexión persistente con una base de datos InterBase
    • ibase_prepare — Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior
    • ibase_query — Ejecutar una consulta en una base de datos InterBase
    • ibase_restore — Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente
    • ibase_rollback_ret — Deshace una transacción sin cerrarla
    • ibase_rollback — Deshace una transacción
    • ibase_server_info — Solicita información sobre un servidor de bases de datos
    • ibase_service_attach — Conecta al administrador de servicios
    • ibase_service_detach — Desconecta del administrador de servicios
    • ibase_set_event_handler — Registra una función manejadora de un determinado evento
    • ibase_trans — Comienza una transacción
    • ibase_wait_event — Espera a que la base de datos emita un determinado evento


Introducción

Firebird es una base de datos relacional que ofrece muchas características del ISO SQL-2003 y que se ejecuta en Linux, Windows, y varias plataformas Unix. Firebird ofrece una excelente concurrencia, un alto rendimiento, y un excelente soporte de lenguaje para procedimientos almacenados y disparadores. Se ha usado en sistemas en producción, bajo diferentes nombres, desde 1981.

InterBase es el nombre de la variante de código cerrado de este SGBDR que fue desarrollado por Embarcadero/Inprise. Hay más información de InterBase disponible en » http://www.embarcadero.com/products/interbase.

Firebird es un proyecto comercial independiente (fundación) creado por programadores C++, consejeros técnicos y desarrolladores auxiliares, que mejora el sistema gestor de bases de datos relacionales multiplataforma, basándose en el código fuente de Inprise Corp (ahora conocido como Embarcadero) bajo la licencia InterBase Public License v.1.0 del 25 de julio de 2000. Hay más información disponible de Firebird en » http://www.firebirdsql.org/.

Nota:

Esta extensión admite InterBase desde la versión 6 en adelante y Firebird desde la versión 2.0 en adelante.

Este base de datos utiliza un carácter de comilla simple (') para realizar el escapado. Se ha de añadir al php.ini la siguiente directiva (obsoleta en PHP 5.3.0. Eliminada en PHP 5.4.0):

magic_quotes_sybase = On


Instalación

Para habilitar el soporte a Firebird/InterBase, debe configurarse PHP con --with-interbase[=DIR], donde DIR es el directorio base de instalación de Firebird/InterBase, que por omisión es /usr.

Nota: Nota para usuarios de Win32/Win64

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: fbclient.dll,gds32.dll

En caso de que se instale el servidor de bases de datos Firebird/InterBase en la misma máquina donde se ejecuta PHP, se tendrá ya esta DLL y fbclient.dll,gds32.dll (gds32.dll se genera desde el instalador para aplicaciones antiguas) ya estará en la ruta señalada por PATH.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de InterBase
Nombre | Por defecto | Cambiable | Historial de cambios
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.default_db | NULL | PHP_INI_SYSTEM | Disponible desde PHP 5.0.0.
ibase.default_user | NULL | PHP_INI_ALL |
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

ibase.allow_persistent boolean

Indica si permite o no conexiones persistentes a Firebird/InterBase.

ibase.max_persistent integer

Número máximo de conexiones persistentes a Firebird/InterBase por proceso. Si se excediera este número, las nuevas conexiones que se creen mediante ibase_pconnect() no serán persistentes.

ibase.max_links integer

Número máximo de conexiones de Firebird/InterBase por proceso, incluyendo las conexiones persistentes.

ibase.default_db string

Base de datos por omisión a la que conectar cuando se invoque ibase_[p]connect() sin especificar el nombre de base de datos. Si se establece este valor, y está habilitado el modo SQL seguro, no se permitirá que se conecte a ninguna otra base de datos.

ibase.default_user string

Nombre de usuario con el que conectar a la base de datos si no se especificara ningún nombre.

ibase.default_password string

Contraseña que se usará para conectar a la base de datos si no se especificara ninguna.

ibase.default_charset string

Juego de caracteres a utilizar al conectar a una base de datos cuando no se especifique ninguno.

ibase.timestampformat string

ibase.dateformat string

ibase.timeformat string

Estas directivas se usan para establecer el format de fecha y hora que se usarán las fechas y horas en los resultados, o al proporcionar un parámetro de fecha y hora.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Se pueden usar las siguientes constantes en ibase_trans() para especificar cómo debe comportarse una transacción.

Banderas de transacciones de Firebird/InterBase
Constante | Descripción
IBASE_DEFAULT | Configuración por omisión. Es determinado por la biblioteca de cliente, que se define como IBASE_WRITE|IBASE_CONCURRENCY|IBASE_WAIT en la mayoría de los casos.
IBASE_READ | Comienza una transacción de sólo lectura.
IBASE_WRITE | Comienza una transacción de sólo escritura.
IBASE_CONSISTENCY | Comienza una transacción con nivel de aislamiento 'consistency', que significa que la transacción no puede leer de tablas que estén siendo modificadas por otras transacciones concurrentes.
IBASE_CONCURRENCY | Comienza una transacción con nivel de aislamiento 'concurrency' (o 'snapshot'), que significa que la transacción tiene acceso a todas las tablas, pero no podrá ver los cambios que hayan realizado otras transacciones una vez que ésta ha comenzado.
IBASE_COMMITTED | Comienza una transacción con nivel de aislamiento 'read committed'. Esta bandera se tiene que combinar con IBASE_REC_VERSION o con IBASE_REC_NO_VERSION. Este nivel de aislamiento permite acceder a los cambios realizados una vez que ésta transacción haya dado comienzo. Si se especificó IBASE_REC_NO_VERSION, sólo se podrá leer la última versión de cada fila. Si se especificó IBASE_REC_VERSION, se podrá leer cualquier fila incluso aunque haya una transacción concurrente de modificación pendiente de ejecutarse.
IBASE_WAIT | Indica que cuando haya algún conflicto, la transacción deberá esperar y reintentarlo.
IBASE_NOWAIT | Indica que cuando haya algún conflicto, la transacción debe fallar inmediatamente.

Se pueden pasar las constantes ibase_fetch_row(), ibase_fetch_assoc() o ibase_fetch_object() para definir el comportamiento.

banderas de capturas en Firebird/InterBase
Constante | Descripción
IBASE_FETCH_BLOBS | También disponible como IBASE_TEXT por retrocompatibilidad. Hace que se capturen los contenidos BLOB directamente, en lugar de obtener un identificador BLOB.
IBASE_FETCH_ARRAYS | Hace que se obtenga un array directamente. Si no, se devolverá el identificador del array. Los identificadores de array sólo se pueden usar como parámetros para operaciones INSERT, ya que actualmente no hay funciones para manejar identificadores de array.
IBASE_UNIXTIME | Hace que las fechas y horas no se devuelvan en forma de string sino como fechas Unix (número de segundos transcurridos desde el 1 de enero de 1970 a las 0:00 hora UTC). En algunos sistemas, puede dar problemas si se utiliza con fechas anteriores a 1970.

Las siguientes constantes se usan para proporcionar peticiones y opciones a las funciones de la
API del servicio (ibase_server_info(), ibase_db_info(),
ibase_backup(), ibase_restore()
y ibase_maintain_db()). Por favor, consulte el
manual de Firebird/InterBase para conocer el significado de estas opciones.

IBASE_BKP_IGNORE_CHECKSUMS
IBASE_BKP_IGNORE_LIMBO
IBASE_BKP_METADATA_ONLY
IBASE_BKP_NO_GARBAGE_COLLECT
IBASE_BKP_OLD_DESCRIPTIONS
IBASE_BKP_NON_TRANSPORTABLE
IBASE_BKP_CONVERT
Opciones para ibase_backup()
IBASE_RES_DEACTIVATE_IDX
IBASE_RES_NO_SHADOW
IBASE_RES_NO_VALIDITY
IBASE_RES_ONE_AT_A_TIME
IBASE_RES_REPLACE
IBASE_RES_CREATE
IBASE_RES_USE_ALL_SPACE
Opciones para ibase_restore()
IBASE_PRP_PAGE_BUFFERS
IBASE_PRP_SWEEP_INTERVAL
IBASE_PRP_SHUTDOWN_DB
IBASE_PRP_DENY_NEW_TRANSACTIONS
IBASE_PRP_DENY_NEW_ATTACHMENTS
IBASE_PRP_RESERVE_SPACE
IBASE_PRP_RES_USE_FULL
IBASE_PRP_RES
IBASE_PRP_WRITE_MODE
IBASE_PRP_WM_ASYNC
IBASE_PRP_WM_SYNC
IBASE_PRP_ACCESS_MODE
IBASE_PRP_AM_READONLY
IBASE_PRP_AM_READWRITE
IBASE_PRP_SET_SQL_DIALECT
IBASE_PRP_ACTIVATE
IBASE_PRP_DB_ONLINE
IBASE_RPR_CHECK_DB
IBASE_RPR_IGNORE_CHECKSUM
IBASE_RPR_KILL_SHADOWS
IBASE_RPR_MEND_DB
IBASE_RPR_VALIDATE_DB
IBASE_RPR_FULL
IBASE_RPR_SWEEP_DB
Opciones para ibase_maintain_db()
IBASE_STS_DATA_PAGES
IBASE_STS_DB_LOG
IBASE_STS_HDR_PAGES
IBASE_STS_IDX_PAGES
IBASE_STS_SYS_RELATIONS
Opciones para ibase_db_info()
IBASE_SVC_SERVER_VERSION
IBASE_SVC_IMPLEMENTATION
IBASE_SVC_GET_ENV
IBASE_SVC_GET_ENV_LOCK
IBASE_SVC_GET_ENV_MSG
IBASE_SVC_USER_DBPATH
IBASE_SVC_SVR_DB_INFO
IBASE_SVC_GET_USERS
Opciones para ibase_server_info()


Funciones de Firebird/InterBase

Tabla de contenidos

  • fbird_add_user — Alias de ibase_add_user
  • fbird_affected_rows — Alias de ibase_affected_rows
  • fbird_backup — Alias de ibase_backup
  • fbird_blob_add — Alias de ibase_blob_add
  • fbird_blob_cancel — Cancel creating blob
  • fbird_blob_close — Alias de ibase_blob_close
  • fbird_blob_create — Alias de ibase_blob_create
  • fbird_blob_echo — Alias de ibase_blob_echo
  • fbird_blob_get — Alias de ibase_blob_get
  • fbird_blob_import — Alias de ibase_blob_import
  • fbird_blob_info — Alias de ibase_blob_info
  • fbird_blob_open — Alias de ibase_blob_open
  • fbird_close — Alias de ibase_close
  • fbird_commit_ret — Alias de ibase_commit_ret
  • fbird_commit — Alias de ibase_commit
  • fbird_connect — Alias de ibase_connect
  • fbird_db_info — Alias de ibase_db_info
  • fbird_delete_user — Alias de ibase_delete_user
  • fbird_drop_db — Alias de ibase_drop_db
  • fbird_errcode — Alias de ibase_errcode
  • fbird_errmsg — Alias de ibase_errmsg
  • fbird_execute — Alias de ibase_execute
  • fbird_fetch_assoc — Alias de ibase_fetch_assoc
  • fbird_fetch_object — Alias de ibase_fetch_object
  • fbird_fetch_row — Alias de ibase_fetch_row
  • fbird_field_info — Alias de ibase_field_info
  • fbird_free_event_handler — Alias de ibase_free_event_handler
  • fbird_free_query — Alias de ibase_free_query
  • fbird_free_result — Alias de ibase_free_result
  • fbird_gen_id — Alias de ibase_gen_id
  • fbird_maintain_db — Alias de ibase_maintain_db
  • fbird_modify_user — Alias de ibase_modify_user
  • fbird_name_result — Alias de ibase_name_result
  • fbird_num_fields — Alias de ibase_num_fields
  • fbird_num_params — Alias de ibase_num_params
  • fbird_param_info — Alias de ibase_param_info
  • fbird_pconnect — Alias de ibase_pconnect
  • fbird_prepare — Alias de ibase_prepare
  • fbird_query — Alias de ibase_query
  • fbird_restore — Alias de ibase_restore
  • fbird_rollback_ret — Alias de ibase_rollback_ret
  • fbird_rollback — Alias de ibase_rollback
  • fbird_server_info — Alias de ibase_server_info
  • fbird_service_attach — Alias de ibase_service_attach
  • fbird_service_detach — Alias de ibase_service_detach
  • fbird_set_event_handler — Alias de ibase_set_event_handler
  • fbird_trans — Alias de ibase_trans
  • fbird_wait_event — Alias de ibase_wait_event
  • ibase_add_user — Añade un usuario a una base de datos segura
  • ibase_affected_rows — Devuelve el número de columnas afectadas por la última consulta
  • ibase_backup — Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente
  • ibase_blob_add — Añade datos a un nuevo blob
  • ibase_blob_cancel — Cancela la creación de un blob
  • ibase_blob_close — Cierra un blob
  • ibase_blob_create — Crea un nuevo blob al que añadir datos
  • ibase_blob_echo — Imprime el contenido de un blob
  • ibase_blob_get — Consulta un determinado número de bytes de un blob
  • ibase_blob_import — Crea un blob, copia un fichero en él, y lo cierra
  • ibase_blob_info — Devuelve el tamaño de un blob y otra información útil
  • ibase_blob_open — Abre un blob para su consulta
  • ibase_close — Cerrar una conexión con una base de datos InterBase
  • ibase_commit_ret — Lleva a cabo una transacción sin cerrarla
  • ibase_commit — Lleva a cabo una transacción
  • ibase_connect — Abrir una conexión a una base de datos
  • ibase_db_info — Consulta estadísticas de una base de datos
  • ibase_delete_user — Elimina un usuario de una base de datos segura
  • ibase_drop_db — Elimina una base de datos
  • ibase_errcode — Devuelve un código de error
  • ibase_errmsg — Devuelve un mensaje de error
  • ibase_execute — Ejecutar una consulta previamente preparada
  • ibase_fetch_assoc — Extra una fila en forma de array asociativo de una consulta
  • ibase_fetch_object — Consulta un objeto de una base de datos InterBase
  • ibase_fetch_row — Recuperar una fila desde una base de datos InterBase
  • ibase_field_info — Consulta información sobre un determinado campo
  • ibase_free_event_handler — Cancela un manejador de eventos ya registrado
  • ibase_free_query — Liberar la memoria reservada por una consulta preparada
  • ibase_free_result — Liberar un conjunto de resultados
  • ibase_gen_id — Incrementa el generador de nombres y devuelve su nuevo valor
  • ibase_maintain_db — Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos
  • ibase_modify_user — Modifica un usuario en una base de datos segura
  • ibase_name_result — Asigna un nombre a un juego de resultados
  • ibase_num_fields — Consulta el número de campos de un resultado
  • ibase_num_params — Devuelve el número de parámetros de una sentencia preparada
  • ibase_param_info — Devuelve información sobre un parámetro de una sentencia preparada
  • ibase_pconnect — Abrir una conexión persistente con una base de datos InterBase
  • ibase_prepare — Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior
  • ibase_query — Ejecutar una consulta en una base de datos InterBase
  • ibase_restore — Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente
  • ibase_rollback_ret — Deshace una transacción sin cerrarla
  • ibase_rollback — Deshace una transacción
  • ibase_server_info — Solicita información sobre un servidor de bases de datos
  • ibase_service_attach — Conecta al administrador de servicios
  • ibase_service_detach — Desconecta del administrador de servicios
  • ibase_set_event_handler — Registra una función manejadora de un determinado evento
  • ibase_trans — Comienza una transacción
  • ibase_wait_event — Espera a que la base de datos emita un determinado evento


Alias de ibase_add_user

  • « Funciones de Firebird/InterBase
  • fbird_affected_rows »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_add_user

fbird_add_user

(PHP 5, PHP 7 < 7.4.0)

fbird_add_user — Alias de ibase_add_user()

Descripción

Esta función es un alias de: ibase_add_user().

Ver también

  • fbird_modify_user() - Alias de ibase_modify_user
  • fbird_delete_user() - Alias de ibase_delete_user


Alias de ibase_affected_rows

  • « fbird_add_user
  • fbird_backup »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_affected_rows

fbird_affected_rows

(PHP 5, PHP 7 < 7.4.0)

fbird_affected_rows — Alias de ibase_affected_rows()

Descripción

Esta función es un alias de: ibase_affected_rows().

Ver también

  • fbird_query() - Alias de ibase_query
  • fbird_execute() - Alias de ibase_execute


Alias de ibase_backup

  • « fbird_affected_rows
  • fbird_blob_add »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_backup

fbird_backup

(PHP 5, PHP 7 < 7.4.0)

fbird_backup — Alias de ibase_backup()

Descripción

Esta función es un alias de: ibase_backup().


Alias de ibase_blob_add

  • « fbird_backup
  • fbird_blob_cancel »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_add

fbird_blob_add

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_add — Alias de ibase_blob_add()

Descripción

Esta función es un alias de: ibase_blob_add().

Ver también

  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_create() - Alias de ibase_blob_create
  • fbird_blob_import() - Alias de ibase_blob_import


Cancel creating blob

  • « fbird_blob_add
  • fbird_blob_close »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Cancel creating blob

fbird_blob_cancel

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_cancel — Cancel creating blob

Descripción

fbird_blob_cancel ( resource $blob_handle ) : bool

This function will discard a BLOB if it has not yet been closed by fbird_blob_close().

Parámetros

blob_handle

A BLOB handle opened with fbird_blob_create().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_create() - Alias de ibase_blob_create
  • fbird_blob_import() - Alias de ibase_blob_import


Alias de ibase_blob_close

  • « fbird_blob_cancel
  • fbird_blob_create »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_close

fbird_blob_close

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_close — Alias de ibase_blob_close()

Descripción

Esta función es un alias de: ibase_blob_close().

Ver también

  • fbird_blob_create() - Alias de ibase_blob_create
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_open() - Alias de ibase_blob_open
  • fbird_blob_import() - Alias de ibase_blob_import


Alias de ibase_blob_create

  • « fbird_blob_close
  • fbird_blob_echo »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_create

fbird_blob_create

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_create — Alias de ibase_blob_create()

Descripción

Esta función es un alias de: ibase_blob_create().

Ver también

  • fbird_blob_add() - Alias de ibase_blob_add
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_import() - Alias de ibase_blob_import


Alias de ibase_blob_echo

  • « fbird_blob_create
  • fbird_blob_get »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_echo

fbird_blob_echo

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_echo — Alias de ibase_blob_echo()

Descripción

Esta función es un alias de: ibase_blob_echo().

Ver también

  • fbird_blob_open() - Alias de ibase_blob_open
  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_get() - Alias de ibase_blob_get


Alias de ibase_blob_get

  • « fbird_blob_echo
  • fbird_blob_import »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_get

fbird_blob_get

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_get — Alias de ibase_blob_get()

Descripción

Esta función es un alias de: ibase_blob_get().

Ver también

  • fbird_blob_open() - Alias de ibase_blob_open
  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_echo() - Alias de ibase_blob_echo


Alias de ibase_blob_import

  • « fbird_blob_get
  • fbird_blob_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_import

fbird_blob_import

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_import — Alias de ibase_blob_import()

Descripción

Esta función es un alias de: ibase_blob_import().

Ver también

  • fbird_blob_add() - Alias de ibase_blob_add
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_create() - Alias de ibase_blob_create


Alias de ibase_blob_info

  • « fbird_blob_import
  • fbird_blob_open »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_info

fbird_blob_info

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_info — Alias de ibase_blob_info()

Descripción

Esta función es un alias de: ibase_blob_info().


Alias de ibase_blob_open

  • « fbird_blob_info
  • fbird_close »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_blob_open

fbird_blob_open

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_open — Alias de ibase_blob_open()

Descripción

Esta función es un alias de: ibase_blob_open().

Ver también

  • fbird_blob_close() - Alias de ibase_blob_close
  • fbird_blob_echo() - Alias de ibase_blob_echo
  • fbird_blob_get() - Alias de ibase_blob_get


Alias de ibase_close

  • « fbird_blob_open
  • fbird_commit_ret »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_close

fbird_close

(PHP 5, PHP 7 < 7.4.0)

fbird_close — Alias de ibase_close()

Descripción

Esta función es un alias de: ibase_close().

Ver también

  • fbird_connect() - Alias de ibase_connect
  • fbird_pconnect() - Alias de ibase_pconnect


Alias de ibase_commit_ret

  • « fbird_close
  • fbird_commit »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_commit_ret

fbird_commit_ret

(PHP 5, PHP 7 < 7.4.0)

fbird_commit_ret — Alias de ibase_commit_ret()

Descripción

Esta función es un alias de: ibase_commit_ret().


Alias de ibase_commit

  • « fbird_commit_ret
  • fbird_connect »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_commit

fbird_commit

(PHP 5, PHP 7 < 7.4.0)

fbird_commit — Alias de ibase_commit()

Descripción

Esta función es un alias de: ibase_commit().


Alias de ibase_connect

  • « fbird_commit
  • fbird_db_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_connect

fbird_connect

(PHP 5, PHP 7 < 7.4.0)

fbird_connect — Alias de ibase_connect()

Descripción

Esta función es un alias de: ibase_connect().

Ver también

  • fbird_pconnect() - Alias de ibase_pconnect
  • fbird_close() - Alias de ibase_close


Alias de ibase_db_info

  • « fbird_connect
  • fbird_delete_user »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_db_info

fbird_db_info

(PHP 5, PHP 7 < 7.4.0)

fbird_db_info — Alias de ibase_db_info()

Descripción

Esta función es un alias de: ibase_db_info().


Alias de ibase_delete_user

  • « fbird_db_info
  • fbird_drop_db »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_delete_user

fbird_delete_user

(PHP 5, PHP 7 < 7.4.0)

fbird_delete_user — Alias de ibase_delete_user()

Descripción

Esta función es un alias de: ibase_delete_user().

Ver también

  • fbird_add_user() - Alias de ibase_add_user
  • fbird_modify_user() - Alias de ibase_modify_user


Alias de ibase_drop_db

  • « fbird_delete_user
  • fbird_errcode »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_drop_db

fbird_drop_db

(PHP 5, PHP 7 < 7.4.0)

fbird_drop_db — Alias de ibase_drop_db()

Descripción

Esta función es un alias de: ibase_drop_db().

Ver también

  • fbird_connect() - Alias de ibase_connect
  • fbird_pconnect() - Alias de ibase_pconnect


Alias de ibase_errcode

  • « fbird_drop_db
  • fbird_errmsg »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_errcode

fbird_errcode

(PHP 5, PHP 7 < 7.4.0)

fbird_errcode — Alias de ibase_errcode()

Descripción

Esta función es un alias de: ibase_errcode().

Ver también

  • fbird_errmsg() - Alias de ibase_errmsg


Alias de ibase_errmsg

  • « fbird_errcode
  • fbird_execute »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_errmsg

fbird_errmsg

(PHP 5, PHP 7 < 7.4.0)

fbird_errmsg — Alias de ibase_errmsg()

Descripción

Esta función es un alias de: ibase_errmsg().

Ver también

  • fbird_errcode() - Alias de ibase_errcode


Alias de ibase_execute

  • « fbird_errmsg
  • fbird_fetch_assoc »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_execute

fbird_execute

(PHP 5, PHP 7 < 7.4.0)

fbird_execute — Alias de ibase_execute()

Descripción

Esta función es un alias de: ibase_execute().

Ver también

  • fbird_query() - Alias de ibase_query


Alias de ibase_fetch_assoc

  • « fbird_execute
  • fbird_fetch_object »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_fetch_assoc

fbird_fetch_assoc

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_assoc — Alias de ibase_fetch_assoc()

Descripción

Esta función es un alias de: ibase_fetch_assoc().

Ver también

  • fbird_fetch_row() - Alias de ibase_fetch_row
  • fbird_fetch_object() - Alias de ibase_fetch_object


Alias de ibase_fetch_object

  • « fbird_fetch_assoc
  • fbird_fetch_row »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_fetch_object

fbird_fetch_object

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_object — Alias de ibase_fetch_object()

Descripción

Esta función es un alias de: ibase_fetch_object().

Ver también

  • fbird_fetch_row() - Alias de ibase_fetch_row
  • fbird_fetch_assoc() - Alias de ibase_fetch_assoc


Alias de ibase_fetch_row

  • « fbird_fetch_object
  • fbird_field_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_fetch_row

fbird_fetch_row

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_row — Alias de ibase_fetch_row()

Descripción

Esta función es un alias de: ibase_fetch_row().

Ver también

  • fbird_fetch_assoc() - Alias de ibase_fetch_assoc
  • fbird_fetch_object() - Alias de ibase_fetch_object


Alias de ibase_field_info

  • « fbird_fetch_row
  • fbird_free_event_handler »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_field_info

fbird_field_info

(PHP 5, PHP 7 < 7.4.0)

fbird_field_info — Alias de ibase_field_info()

Descripción

Esta función es un alias de: ibase_field_info().

Ver también

  • fbird_num_fields() - Alias de ibase_num_fields


Alias de ibase_free_event_handler

  • « fbird_field_info
  • fbird_free_query »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_free_event_handler

fbird_free_event_handler

(PHP 5, PHP 7 < 7.4.0)

fbird_free_event_handler — Alias de ibase_free_event_handler()

Descripción

Esta función es un alias de: ibase_free_event_handler().

Ver también

  • fbird_set_event_handler() - Alias de ibase_set_event_handler


Alias de ibase_free_query

  • « fbird_free_event_handler
  • fbird_free_result »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_free_query

fbird_free_query

(PHP 5, PHP 7 < 7.4.0)

fbird_free_query — Alias de ibase_free_query()

Descripción

Esta función es un alias de: ibase_free_query().


Alias de ibase_free_result

  • « fbird_free_query
  • fbird_gen_id »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_free_result

fbird_free_result

(PHP 5, PHP 7 < 7.4.0)

fbird_free_result — Alias de ibase_free_result()

Descripción

Esta función es un alias de: ibase_free_result().


Alias de ibase_gen_id

  • « fbird_free_result
  • fbird_maintain_db »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_gen_id

fbird_gen_id

(PHP 5, PHP 7 < 7.4.0)

fbird_gen_id — Alias de ibase_gen_id()

Descripción

Esta función es un alias de: ibase_gen_id().


Alias de ibase_maintain_db

  • « fbird_gen_id
  • fbird_modify_user »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_maintain_db

fbird_maintain_db

(PHP 5, PHP 7 < 7.4.0)

fbird_maintain_db — Alias de ibase_maintain_db()

Descripción

Esta función es un alias de: ibase_maintain_db().


Alias de ibase_modify_user

  • « fbird_maintain_db
  • fbird_name_result »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_modify_user

fbird_modify_user

(PHP 5, PHP 7 < 7.4.0)

fbird_modify_user — Alias de ibase_modify_user()

Descripción

Esta función es un alias de: ibase_modify_user().

Ver también

  • fbird_add_user() - Alias de ibase_add_user
  • fbird_delete_user() - Alias de ibase_delete_user


Alias de ibase_name_result

  • « fbird_modify_user
  • fbird_num_fields »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_name_result

fbird_name_result

(PHP 5, PHP 7 < 7.4.0)

fbird_name_result — Alias de ibase_name_result()

Descripción

Esta función es un alias de: ibase_name_result().

Ver también

  • fbird_prepare() - Alias de ibase_prepare
  • fbird_execute() - Alias de ibase_execute


Alias de ibase_num_fields

  • « fbird_name_result
  • fbird_num_params »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_num_fields

fbird_num_fields

(PHP 5, PHP 7 < 7.4.0)

fbird_num_fields — Alias de ibase_num_fields()

Descripción

Esta función es un alias de: ibase_num_fields().

Ver también

  • fbird_field_info() - Alias de ibase_field_info


Alias de ibase_num_params

  • « fbird_num_fields
  • fbird_param_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_num_params

fbird_num_params

(PHP 5, PHP 7 < 7.4.0)

fbird_num_params — Alias de ibase_num_params()

Descripción

Esta función es un alias de: ibase_num_params().

Ver también

  • fbird_prepare() - Alias de ibase_prepare
  • fbird_param_info() - Alias de ibase_param_info


Alias de ibase_param_info

  • « fbird_num_params
  • fbird_pconnect »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_param_info

fbird_param_info

(PHP 5, PHP 7 < 7.4.0)

fbird_param_info — Alias de ibase_param_info()

Descripción

Esta función es un alias de: ibase_param_info().

Ver también

  • fbird_field_info() - Alias de ibase_field_info
  • fbird_num_params() - Alias de ibase_num_params


Alias de ibase_pconnect

  • « fbird_param_info
  • fbird_prepare »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_pconnect

fbird_pconnect

(PHP 5, PHP 7 < 7.4.0)

fbird_pconnect — Alias de ibase_pconnect()

Descripción

Esta función es un alias de: ibase_pconnect().

Ver también

  • fbird_close() - Alias de ibase_close
  • fbird_connect() - Alias de ibase_connect


Alias de ibase_prepare

  • « fbird_pconnect
  • fbird_query »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_prepare

fbird_prepare

(PHP 5, PHP 7 < 7.4.0)

fbird_prepare — Alias de ibase_prepare()

Descripción

Esta función es un alias de: ibase_prepare().


Alias de ibase_query

  • « fbird_prepare
  • fbird_restore »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_query

fbird_query

(PHP 5, PHP 7 < 7.4.0)

fbird_query — Alias de ibase_query()

Descripción

Esta función es un alias de: ibase_query().

Ver también

  • fbird_errmsg() - Alias de ibase_errmsg
  • fbird_fetch_row() - Alias de ibase_fetch_row
  • fbird_fetch_object() - Alias de ibase_fetch_object
  • fbird_free_result() - Alias de ibase_free_result


Alias de ibase_restore

  • « fbird_query
  • fbird_rollback_ret »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_restore

fbird_restore

(PHP 5, PHP 7 < 7.4.0)

fbird_restore — Alias de ibase_restore()

Descripción

Esta función es un alias de: ibase_restore().


Alias de ibase_rollback_ret

  • « fbird_restore
  • fbird_rollback »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_rollback_ret

fbird_rollback_ret

(PHP 5, PHP 7 < 7.4.0)

fbird_rollback_ret — Alias de ibase_rollback_ret()

Descripción

Esta función es un alias de: ibase_rollback_ret().


Alias de ibase_rollback

  • « fbird_rollback_ret
  • fbird_server_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_rollback

fbird_rollback

(PHP 5, PHP 7 < 7.4.0)

fbird_rollback — Alias de ibase_rollback()

Descripción

Esta función es un alias de: ibase_rollback().


Alias de ibase_server_info

  • « fbird_rollback
  • fbird_service_attach »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_server_info

fbird_server_info

(PHP 5, PHP 7 < 7.4.0)

fbird_server_info — Alias de ibase_server_info()

Descripción

Esta función es un alias de: ibase_server_info().


Alias de ibase_service_attach

  • « fbird_server_info
  • fbird_service_detach »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_service_attach

fbird_service_attach

(PHP 5, PHP 7 < 7.4.0)

fbird_service_attach — Alias de ibase_service_attach()

Descripción

Esta función es un alias de: ibase_service_attach().


Alias de ibase_service_detach

  • « fbird_service_attach
  • fbird_set_event_handler »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_service_detach

fbird_service_detach

(PHP 5, PHP 7 < 7.4.0)

fbird_service_detach — Alias de ibase_service_detach()

Descripción

Esta función es un alias de: ibase_service_detach().


Alias de ibase_set_event_handler

  • « fbird_service_detach
  • fbird_trans »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_set_event_handler

fbird_set_event_handler

(PHP 5, PHP 7 < 7.4.0)

fbird_set_event_handler — Alias de ibase_set_event_handler()

Descripción

Esta función es un alias de: ibase_set_event_handler().

Ver también

  • fbird_free_event_handler() - Alias de ibase_free_event_handler
  • fbird_wait_event() - Alias de ibase_wait_event


Alias de ibase_trans

  • « fbird_set_event_handler
  • fbird_wait_event »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_trans

fbird_trans

(PHP 5, PHP 7 < 7.4.0)

fbird_trans — Alias de ibase_trans()

Descripción

Esta función es un alias de: ibase_trans().


Alias de ibase_wait_event

  • « fbird_trans
  • ibase_add_user »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Alias de ibase_wait_event

fbird_wait_event

(PHP 5, PHP 7 < 7.4.0)

fbird_wait_event — Alias de ibase_wait_event()

Descripción

Esta función es un alias de: ibase_wait_event().

Ver también

  • fbird_set_event_handler() - Alias de ibase_set_event_handler
  • fbird_free_event_handler() - Alias de ibase_free_event_handler


Añade un usuario a una base de datos segura

  • « fbird_wait_event
  • ibase_affected_rows »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Añade un usuario a una base de datos segura

ibase_add_user

(PHP 5, PHP 7 < 7.4.0)

ibase_add_user — Añade un usuario a una base de datos segura

Descripción

ibase_add_user ( resource $service_handle , string $user_name , string $password , string $first_name = ? , string $middle_name = ? , string $last_name = ? ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_modify_user() - Modifica un usuario en una base de datos segura
  • ibase_delete_user() - Elimina un usuario de una base de datos segura


Devuelve el número de columnas afectadas por la última consulta

  • « ibase_add_user
  • ibase_backup »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve el número de columnas afectadas por la última consulta

ibase_affected_rows

(PHP 5, PHP 7 < 7.4.0)

ibase_affected_rows — Devuelve el número de columnas afectadas por la última consulta

Descripción

ibase_affected_rows ( resource $link_identifier = ? ) : int

Esta función devuelve el número de filas que se vieron afectadas por la última consulta (INSERT, UPDATE o DELETE) que se ejecutó en el contexto de la transacción especificada.

Parámetros

link_identifier

Contexto de transacción. Si link_identifier fuera un recurso de conexión, se utilizará la transacción por omisión.

Valores devueltos

Devuelve el número de filas en forma de número entero.

Ver también

  • ibase_query() - Ejecutar una consulta en una base de datos InterBase
  • ibase_execute() - Ejecutar una consulta previamente preparada


Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente

  • « ibase_affected_rows
  • ibase_blob_add »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente

ibase_backup

(PHP 5, PHP 7 < 7.4.0)

ibase_backup — Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente

Descripción

ibase_backup ( resource $service_handle , string $source_db , string $dest_file , int $options = 0 , bool $verbose = false ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Añade datos a un nuevo blob

  • « ibase_backup
  • ibase_blob_cancel »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Añade datos a un nuevo blob

ibase_blob_add

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_add — Añade datos a un nuevo blob

Descripción

ibase_blob_add ( resource $blob_handle , string $data ) : void

ibase_blob_add() añade datos a un blob creado con ibase_blob_create().

Parámetros

blob_handle

Manejador de blob, abierto con ibase_blob_create().

data

Datos a añadir.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ibase_blob_cancel() - Cancela la creación de un blob
  • ibase_blob_close() - Cierra un blob
  • ibase_blob_create() - Crea un nuevo blob al que añadir datos
  • ibase_blob_import() - Crea un blob, copia un fichero en él, y lo cierra


Cancela la creación de un blob

  • « ibase_blob_add
  • ibase_blob_close »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Cancela la creación de un blob

ibase_blob_cancel

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_cancel — Cancela la creación de un blob

Descripción

ibase_blob_cancel ( resource $blob_handle ) : bool

Esta función descarta un BLOB, siempre y cuando no se haya cerrado ya mediante ibase_blob_close().

Parámetros

blob_handle

Manejador de BLOB, abierto con ibase_blob_create().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_blob_close() - Cierra un blob
  • ibase_blob_create() - Crea un nuevo blob al que añadir datos
  • ibase_blob_import() - Crea un blob, copia un fichero en él, y lo cierra


Cierra un blob

  • « ibase_blob_cancel
  • ibase_blob_create »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Cierra un blob

ibase_blob_close

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_close — Cierra un blob

Descripción

ibase_blob_close ( resource $blob_handle ) : mixed

Esta función cierra un BLOB previamente abierto para lectura mediante ibase_blob_open() o para escritura mediante ibase_blob_create().

Parámetros

blob_handle

Manejador de BLOB abierto mediante ibase_blob_create() o mediante ibase_blob_open().

Valores devueltos

Si el BLOB era de lectura, esta función devuelve true en caso de éxito, y si el BLOB era de escritura, esta función devuelve un string con el identificador que asignó la base de datos a este BLOB. En caso de error, devuelve false.

Ver también

  • ibase_blob_cancel() - Cancela la creación de un blob
  • ibase_blob_open() - Abre un blob para su consulta


Crea un nuevo blob al que añadir datos

  • « ibase_blob_close
  • ibase_blob_echo »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Crea un nuevo blob al que añadir datos

ibase_blob_create

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_create — Crea un nuevo blob al que añadir datos

Descripción

ibase_blob_create ( resource $link_identifier = null ) : resource

ibase_blob_create() crea un nuevo BLOB al que añadir datos.

Parámetros

link_identifier

Identificador de enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

Valores devueltos

Devuelve un manejador BLOB para usar posteriormente con ibase_blob_add() o false en caso de error.

Ver también

  • ibase_blob_add() - Añade datos a un nuevo blob
  • ibase_blob_cancel() - Cancela la creación de un blob
  • ibase_blob_close() - Cierra un blob
  • ibase_blob_import() - Crea un blob, copia un fichero en él, y lo cierra


Imprime el contenido de un blob

  • « ibase_blob_create
  • ibase_blob_get »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Imprime el contenido de un blob

ibase_blob_echo

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_echo — Imprime el contenido de un blob

Descripción

ibase_blob_echo ( string $blob_id ) : bool
ibase_blob_echo ( resource $link_identifier , string $blob_id ) : bool

Esta función abre un BLOB en modo lectura y envía su contenido directamente a la salida estándar (en la mayoría de los casos, será al navegador).

Parámetros

link_identifier

Identificador de un enlace a InterBase. Si se omite, se utilizará el último enlace abierto.

blob_id

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_blob_open() - Abre un blob para su consulta
  • ibase_blob_close() - Cierra un blob
  • ibase_blob_get() - Consulta un determinado número de bytes de un blob


Consulta un determinado número de bytes de un blob

  • « ibase_blob_echo
  • ibase_blob_import »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Consulta un determinado número de bytes de un blob

ibase_blob_get

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_get — Consulta un determinado número de bytes de un blob

Descripción

ibase_blob_get ( resource $blob_handle , int $len ) : string

Esta función devuelve hasta len bytes de un BLOB que se haya abierto para lectura mediante ibase_blob_open().

Nota:

No se podrá leer de un BLOB que se haya abierto en modo escritura mediante ibase_blob_create().

Parámetros

blob_handle

Manejador de BLOB, abierto por ibase_blob_open().

len

Tamaño de la lectura.

Valores devueltos

Devuelve hasta len bytes del BLOB, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ibase_blob_get()

<?php
$result    = ibase_query("SELECT blob_value FROM table");
$data      = ibase_fetch_object($result);
$blob_data = ibase_blob_info($data->BLOB_VALUE);
$blob_hndl = ibase_blob_open($data->BLOB_VALUE);
echo         ibase_blob_get($blob_hndl, $blob_data[0]);
?>
A pesar de que este ejemplo no hace nada que no haga 'ibase_blob_echo($data->BLOB_VALUE)', ilustra cómo consultar información en una variable para poder manipularla posteriormente.

Ver también

  • ibase_blob_open() - Abre un blob para su consulta
  • ibase_blob_close() - Cierra un blob
  • ibase_blob_echo() - Imprime el contenido de un blob


Crea un blob, copia un fichero en él, y lo cierra

  • « ibase_blob_get
  • ibase_blob_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Crea un blob, copia un fichero en él, y lo cierra

ibase_blob_import

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_import — Crea un blob, copia un fichero en él, y lo cierra

Descripción

ibase_blob_import ( resource $link_identifier , resource $file_handle ) : string
ibase_blob_import ( resource $file_handle ) : string

Esta función crea un BLOB, escribe un fichero al completo en él, lo cierra y devuelve el id del BLOB asignado.

Parámetros

link_identifier

Identificador de un enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

file_handle

Manejador de fichero, devuelto por fopen().

Valores devueltos

En caso de éxito devuelve el id del BLOB, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ibase_blob_import()

<?php
$dbh = ibase_connect($host, $username, $password);
$filename = '/tmp/bar';

$fd = fopen($filename, 'r');
if ($fd) {

    $blob = ibase_blob_import($dbh, $fd);
    fclose($fd);

    if (!is_string($blob)) {
        // importado fallido
    } else {
        $query = "INSERT INTO foo (name, data) VALUES ('$filename', ?)";
        $prepared = ibase_prepare($dbh, $query);
        if (!ibase_execute($prepared, $blob)) {
            // falló la inserción del registro
        }
    }
} else {
    // imposible abrir el fichero de datos
}
?>

Ver también

  • ibase_blob_add() - Añade datos a un nuevo blob
  • ibase_blob_cancel() - Cancela la creación de un blob
  • ibase_blob_close() - Cierra un blob
  • ibase_blob_create() - Crea un nuevo blob al que añadir datos


Devuelve el tamaño de un blob y otra información útil

  • « ibase_blob_import
  • ibase_blob_open »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve el tamaño de un blob y otra información útil

ibase_blob_info

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_info — Devuelve el tamaño de un blob y otra información útil

Descripción

ibase_blob_info ( resource $link_identifier , string $blob_id ) : array
ibase_blob_info ( string $blob_id ) : array

Devuelve el tamaño de un BLOB y otra información útil.

Parámetros

link_identifier

Identificador de enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

blob_id

Identificador del BLOB.

Valores devueltos

Devuelve un array con información sobre el BLOB. La información devuelta consiste en el tamaño del BLOB, el número de segmentos que contiene, el tamaño del segmento más largo, así como si es un BLOB de tipo flujo o segmentado.


Abre un blob para su consulta

  • « ibase_blob_info
  • ibase_close »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Abre un blob para su consulta

ibase_blob_open

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_open — Abre un blob para su consulta

Descripción

ibase_blob_open ( resource $link_identifier , string $blob_id ) : resource
ibase_blob_open ( string $blob_id ) : resource

Abre un BLOB existente para su lectura.

Parámetros

link_identifier

Identificador de enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

blob_id

Identificador del BLOB.

Valores devueltos

Devuelve un manejador de BLOB para utilizar con ibase_blob_get() o false en caso de error.

Ver también

  • ibase_blob_close() - Cierra un blob
  • ibase_blob_echo() - Imprime el contenido de un blob
  • ibase_blob_get() - Consulta un determinado número de bytes de un blob


Cerrar una conexión con una base de datos InterBase

  • « ibase_blob_open
  • ibase_commit_ret »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Cerrar una conexión con una base de datos InterBase

ibase_close

(PHP 5, PHP 7 < 7.4.0)

ibase_close — Cerrar una conexión con una base de datos InterBase

Descripción

ibase_close ( resource $connection_id = null ) : bool

Cierra el enlace con una base de datos InterBase que esté asociado con un id de conexión devuelto por ibase_connect(). La transacción predeterminada en el enlace es aplicada, las demás transacciones son revertidas.

Parámetros

connection_id

Un identificador de enlace InterBase devuelto por ibase_connect(). Si se omite, se asume el último enlace abierto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_connect() - Abrir una conexión a una base de datos
  • ibase_pconnect() - Abrir una conexión persistente con una base de datos InterBase


Lleva a cabo una transacción sin cerrarla

  • « ibase_close
  • ibase_commit »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Lleva a cabo una transacción sin cerrarla

ibase_commit_ret

(PHP 5, PHP 7 < 7.4.0)

ibase_commit_ret — Lleva a cabo una transacción sin cerrarla

Descripción

ibase_commit_ret ( resource $link_or_trans_identifier = null ) : bool

Lleva a cabo una transacción sin cerrarla.

Parámetros

link_or_trans_identifier

Si se invoca sin argumentos, esta función lleva a cabo la transacción por omisión del enlace por omisión. Si el argumento es un identificador de conexión, se llevará a cabo su transacción por omisión. Si el argumento fuera un identificador de transacción, se llevará a cabo ésta. Se mantendrá el contexto, de forma que no se invalidarán las sentencias que se hayan ejecutado en esta transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Lleva a cabo una transacción

  • « ibase_commit_ret
  • ibase_connect »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Lleva a cabo una transacción

ibase_commit

(PHP 5, PHP 7 < 7.4.0)

ibase_commit — Lleva a cabo una transacción

Descripción

ibase_commit ( resource $link_or_trans_identifier = null ) : bool

Lleva a cabo una transacción.

Parámetros

link_or_trans_identifier

Si se invoca sin argumentos, esta función lleva a cabo la transacción por omisión del enlace por omisión. Si el argumento es un identificador de conexión, se llevará a cabo su transacción por omisión. Si el argumento fuera un identificador de transacción, se llevará a cabo ésta.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Abrir una conexión a una base de datos

  • « ibase_commit
  • ibase_db_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Abrir una conexión a una base de datos

ibase_connect

(PHP 5, PHP 7 < 7.4.0)

ibase_connect — Abrir una conexión a una base de datos

Descripción

ibase_connect ( string $database = ? , string $username = ? , string $password = ? , string $charset = ? , int $buffers = ? , int $dialect = ? , string $role = ? , int $sync = ? ) : resource

Establece una conexión con un servidor Firebird/InterBase.

En case de que se haga una segunda llamada a ibase_connect() con los mismos argumentos, no se establecerá un nuevo enlace, en cambio, el identificador de enlace previamente abierto será devuelto. El enlace al servidor será cerrado apenas finalice la ejecución del script, a menos que sea cerrado prematuramente llamando explícitamente ibase_close().

Parámetros

database

El argumento database debe ser una ruta válida al archivo de base de datos en el servidor en el que reside. Si el servidor no es local, debe ser precedido por 'nombre_host:' (TCP/IP), '//nombre_host/' (NetBEUI), dependiendo del protocolo de conexión usado.

username

El nombre de usuario. Puede ser definido mediante la directiva de php.ini ibase.default_user.

password

La contraseña para username. Puede ser definida con la directiva de php.ini ibase.default_password.

charset

charset es el juego de caracteres predeterminado para una base de datos.

bufers

bufers es el número de búfers de base de datos a reservar para el caché en el lado del servidor. Si es 0 o se omite, el servidor elige su propio valor predeterminado.

dialect

dialect selecciona el dialecto SQL predeterminado para cualquier sentencia ejecutada en la conexión, y su valor por omisión es el más alto admitido por las bibliotecas cliente.

role

Funcional únicamente con InterBase 5 y versiones posteriores.

sync

Valores devueltos

Devuelve un identificador de enlace Firebird/InterBase en caso de éxito, o false si ocurre un error.

Errores/Excepciones

Si obtiene un error del tipo "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (esto ocurre cuando intenta usar algún caracter con acentos) cuando usa esta extensión después de llamar ibase_query(), debe definir el juego de caracteres (puede ser ISO8859_1 o su juego de caracteres actual).

Ejemplos

Ejemplo #1 Ejemplo de ibase_connect()

<?php
$host = 'localhost:/ruta/a/su/base_de_datos.gdb';

$gestor_db = ibase_connect($host, $nombre_usuario, $contrasenya);
$sentencia = 'SELECT * FROM nombre_tabla';
$gestor_sent = ibase_query($gestor_db, $sentencia);
while ($fila = ibase_fetch_object($gestor_sent)) {
    echo $fila->email, "\n";
}
ibase_free_result($gestor_sent);
ibase_close($gestor_db);
?>

Ver también

  • ibase_pconnect() - Abrir una conexión persistente con una base de datos InterBase
  • ibase_close() - Cerrar una conexión con una base de datos InterBase


Consulta estadísticas de una base de datos

  • « ibase_connect
  • ibase_delete_user »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Consulta estadísticas de una base de datos

ibase_db_info

(PHP 5, PHP 7 < 7.4.0)

ibase_db_info — Consulta estadísticas de una base de datos

Descripción

ibase_db_info ( resource $service_handle , string $db , int $action , int $argument = 0 ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Elimina un usuario de una base de datos segura

  • « ibase_db_info
  • ibase_drop_db »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Elimina un usuario de una base de datos segura

ibase_delete_user

(PHP 5, PHP 7 < 7.4.0)

ibase_delete_user — Elimina un usuario de una base de datos segura

Descripción

ibase_delete_user ( resource $service_handle , string $user_name ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_add_user() - Añade un usuario a una base de datos segura
  • ibase_modify_user() - Modifica un usuario en una base de datos segura


Elimina una base de datos

  • « ibase_delete_user
  • ibase_errcode »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Elimina una base de datos

ibase_drop_db

(PHP 5, PHP 7 < 7.4.0)

ibase_drop_db — Elimina una base de datos

Descripción

ibase_drop_db ( resource $connection = null ) : bool

Esta función elimina una base de datos abierta con ibase_connect() o con ibase_pconnect(). La base de datos se cierra y se elimina del servidor.

Parámetros

connection

Identificador de enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_connect() - Abrir una conexión a una base de datos
  • ibase_pconnect() - Abrir una conexión persistente con una base de datos InterBase


Devuelve un código de error

  • « ibase_drop_db
  • ibase_errmsg »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve un código de error

ibase_errcode

(PHP 5, PHP 7 < 7.4.0)

ibase_errcode — Devuelve un código de error

Descripción

ibase_errcode ( ) : int

Devuelve un código de error correspondiente a la última llamada a una función InterBase.

Valores devueltos

Devuelve el código de error en forma de entero, o false si no hubo ningún error.

Ver también

  • ibase_errmsg() - Devuelve un mensaje de error


Devuelve un mensaje de error

  • « ibase_errcode
  • ibase_execute »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve un mensaje de error

ibase_errmsg

(PHP 5, PHP 7 < 7.4.0)

ibase_errmsg — Devuelve un mensaje de error

Descripción

ibase_errmsg ( ) : string

Devuelve el mensaje de error que hubo en la última llamada a una función de InterBase.

Valores devueltos

Devuelve el mensaje de error como string, o false si no hubiera ningún error.

Ver también

  • ibase_errcode() - Devuelve un código de error


Ejecutar una consulta previamente preparada

  • « ibase_errmsg
  • ibase_fetch_assoc »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Ejecutar una consulta previamente preparada

ibase_execute

(PHP 5, PHP 7 < 7.4.0)

ibase_execute — Ejecutar una consulta previamente preparada

Descripción

ibase_execute ( resource $query , mixed $bind_arg = ? , mixed $... = ? ) : resource

Ejecuta una consulta preparada por ibase_prepare().

Este mecanismo es mucho más eficiento que el uso de ibase_query() si repite el mismo tipo de consulta varias veces sólamente modificando ciertos parámetros.

Parámetros

query

Una consulta InterBase preparada por ibase_prepare().

bind_arg

...

Valores devueltos

Si la consulta genera un error, se devuelve false. Si tiene éxito y existe un conjunto de resultados (posiblemente vacío), tal como ocurre con una consulta SELECT, se devuelve el identificador de resultado. Si la consulta fue exitosa y no hay resultados, se devuelve true.

Nota:

Esta función devuelve el número de filas afectadas por la consulta (si es > 0 y aplicable al tipo de sentencia). Una consulta que haya tenido éxito, pero no afectó fila alguna (p.ej. una operación UPDATE sobre un registro inexistente) devolverá true.

Ejemplos

Ejemplo #1 Ejemplo de ibase_execute()

<?php

$dbh = ibase_connect($host, $nombre_usuario, $contrasenya);

$cambios = array(
    1 => 'Eric',
    5 => 'Filip',
    7 => 'Larry'
);

$consulta = ibase_prepare($dbh, "UPDATE FOO SET BAR = ? WHERE BAZ = ?");

foreach ($cambios as $baz => $bar) {
    ibase_execute($consulta, $bar, $baz);
}

?>

Ver también

  • ibase_query() - Ejecutar una consulta en una base de datos InterBase


Extra una fila en forma de array asociativo de una consulta

  • « ibase_execute
  • ibase_fetch_object »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Extra una fila en forma de array asociativo de una consulta

ibase_fetch_assoc

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_assoc — Extra una fila en forma de array asociativo de una consulta

Descripción

ibase_fetch_assoc ( resource $result , int $fetch_flag = 0 ) : array

Extrae en forma de array asociativo una fila a partir de una consulta.

ibase_fetch_assoc() extrae una fila de result. Si hubiera dos o más columnas de este resultado con el mismo nombre, tendrá precedencia la última. Para acceder a la/s otra/s con el mismo nombre, se tendrá que acceder mediante sus índices usando ibase_fetch_row() o usando alias en la consulta.

Parámetros

result

Manejador de resultado.

fetch_flag

fetch_flag es una combinación OR de las constantes IBASE_TEXT y IBASE_UNIXTIME. Al pasar IBASE_TEXT se provocará que esta función devuelva el contenido de los BLOB en lugar de sus identificadores. Si se pasara IBASE_UNIXTIME provocará que esta función devuelva la fecha/hora en formato Unix, en lugar de como cadena de texto.

Valores devueltos

Devuelve un array asociativo que corresponde a la fila consultada. El resto de llamadas capturarán las siguientes filas del resultado, o false si no quedaran más.

Ver también

  • ibase_fetch_row() - Recuperar una fila desde una base de datos InterBase
  • ibase_fetch_object() - Consulta un objeto de una base de datos InterBase


Consulta un objeto de una base de datos InterBase

  • « ibase_fetch_assoc
  • ibase_fetch_row »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Consulta un objeto de una base de datos InterBase

ibase_fetch_object

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_object — Consulta un objeto de una base de datos InterBase

Descripción

ibase_fetch_object ( resource $result_id , int $fetch_flag = 0 ) : object

Captura una fila en forma de pseudo-objeto, a partir de un identificador de resultado.

El resto de llamadas a ibase_fetch_object() devolverán la siguiente fila del juego de resultados.

Parámetros

result_id

Identificador de resultado de InterBase obtenido por ibase_query() o por ibase_execute().

fetch_flag

fetch_flag es una combinación OR de las constantes IBASE_TEXT y IBASE_UNIXTIME. Si se pasara IBASE_TEXT provocaría que esta función devolviera el contenido de los BLOB en lugar de sus identificadores. Si se pasara IBASE_UNIXTIME provocaría que esta función devolviera las fechas/hora en formato Unix en lugar de en forma de cadena de texto.

Valores devueltos

Devuelve un objeto con información de la siguiente fila, o false si no hubiera más filas.

Ejemplos

Ejemplo #1 Ejemplo de ibase_fetch_object()

<?php
$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email . "\n";
}
ibase_close($dbh);
?>

Ver también

  • ibase_fetch_row() - Recuperar una fila desde una base de datos InterBase
  • ibase_fetch_assoc() - Extra una fila en forma de array asociativo de una consulta


Recuperar una fila desde una base de datos InterBase

  • « ibase_fetch_object
  • ibase_field_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Recuperar una fila desde una base de datos InterBase

ibase_fetch_row

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_row — Recuperar una fila desde una base de datos InterBase

Descripción

ibase_fetch_row ( resource $result_identifier , int $fetch_flag = 0 ) : array

ibase_fetch_row() recupera una fila de datos desde el conjunto de resultados dado.

Las llamadas subsiguientes a ibase_fetch_row() devuelven la siguiente fila en el conjunto de resultados, o false si no hay más filas.

Parámetros

result_identifier

Un identificador de resultado InterBase.

fetch_flag

fetch_flag es una combinación de las constantes IBASE_TEXT y IBASE_UNIXTIME unidas con el operador lógico OR. Al pasar IBASE_TEXT, esta función devuelve contenidos BLOB en lugar de identificadores BLOB. Al pasar IBASE_UNIXTIME, esta función devuelve valores de fecha/hora como marcas de tiempo Unix en lugar de cadenas con formato.

Valores devueltos

Devuelve un array que corresponde a la fila recuperada, o false si no hay más filas. Cada columna del resultado es almacenado en una posición del array, comenzando en 0.

Ver también

  • ibase_fetch_assoc() - Extra una fila en forma de array asociativo de una consulta
  • ibase_fetch_object() - Consulta un objeto de una base de datos InterBase


Consulta información sobre un determinado campo

  • « ibase_fetch_row
  • ibase_free_event_handler »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Consulta información sobre un determinado campo

ibase_field_info

(PHP 5, PHP 7 < 7.4.0)

ibase_field_info — Consulta información sobre un determinado campo

Descripción

ibase_field_info ( resource $result , int $field_number ) : array

Devuelve un array con información acerca de un campo de una consulta que ya se haya ejecutado.

Parámetros

result

Identificador de resultado de InterBase.

field_number

Posición del campo.

Valores devueltos

Devuelve un array con las siguientes claves: name, alias, relation, length y type.

Ejemplos

Ejemplo #1 Ejemplo de ibase_field_info()

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: ". $col_info['name']. "\n";
    echo "alias: ". $col_info['alias']. "\n";
    echo "relation: ". $col_info['relation']. "\n";
    echo "length: ". $col_info['length']. "\n";
    echo "type: ". $col_info['type']. "\n";
}
?>

Ver también

  • ibase_num_fields() - Consulta el número de campos de un resultado


Cancela un manejador de eventos ya registrado

  • « ibase_field_info
  • ibase_free_query »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Cancela un manejador de eventos ya registrado

ibase_free_event_handler

(PHP 5, PHP 7 < 7.4.0)

ibase_free_event_handler — Cancela un manejador de eventos ya registrado

Descripción

ibase_free_event_handler ( resource $event ) : bool

Esta función provoca la cancelación del manejador de eventos especificado por event. Ya no se llamará a esta función manejadora del evento para el que se registró.

Parámetros

event

Recurso de evento, creado por ibase_set_event_handler().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_set_event_handler() - Registra una función manejadora de un determinado evento


Liberar la memoria reservada por una consulta preparada

  • « ibase_free_event_handler
  • ibase_free_result »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Liberar la memoria reservada por una consulta preparada

ibase_free_query

(PHP 5, PHP 7 < 7.4.0)

ibase_free_query — Liberar la memoria reservada por una consulta preparada

Descripción

ibase_free_query ( resource $query ) : bool

Libera una consulta preparada.

Parámetros

query

Una consulta preparada con ibase_prepare().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Liberar un conjunto de resultados

  • « ibase_free_query
  • ibase_gen_id »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Liberar un conjunto de resultados

ibase_free_result

(PHP 5, PHP 7 < 7.4.0)

ibase_free_result — Liberar un conjunto de resultados

Descripción

ibase_free_result ( resource $result_identifier ) : bool

Libera un conjunto de resultados.

Parámetros

result_identifier

Un conjunto de resultados creado por ibase_query() o ibase_execute().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Incrementa el generador de nombres y devuelve su nuevo valor

  • « ibase_free_result
  • ibase_maintain_db »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Incrementa el generador de nombres y devuelve su nuevo valor

ibase_gen_id

(PHP 5, PHP 7 < 7.4.0)

ibase_gen_id — Incrementa el generador de nombres y devuelve su nuevo valor

Descripción

ibase_gen_id ( string $generator , int $increment = 1 , resource $link_identifier = null ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve en forma de string el nuevo valor generado, o como string si el valor fuera demasiado grande.


Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos

  • « ibase_gen_id
  • ibase_modify_user »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos

ibase_maintain_db

(PHP 5, PHP 7 < 7.4.0)

ibase_maintain_db — Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos

Descripción

ibase_maintain_db ( resource $service_handle , string $db , int $action , int $argument = 0 ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Modifica un usuario en una base de datos segura

  • « ibase_maintain_db
  • ibase_name_result »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Modifica un usuario en una base de datos segura

ibase_modify_user

(PHP 5, PHP 7 < 7.4.0)

ibase_modify_user — Modifica un usuario en una base de datos segura

Descripción

ibase_modify_user ( resource $service_handle , string $user_name , string $password , string $first_name = ? , string $middle_name = ? , string $last_name = ? ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ibase_add_user() - Añade un usuario a una base de datos segura
  • ibase_delete_user() - Elimina un usuario de una base de datos segura


Asigna un nombre a un juego de resultados

  • « ibase_modify_user
  • ibase_num_fields »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Asigna un nombre a un juego de resultados

ibase_name_result

(PHP 5, PHP 7 < 7.4.0)

ibase_name_result — Asigna un nombre a un juego de resultados

Descripción

ibase_name_result ( resource $result , string $name ) : bool

Esta función establece un nombre a un juego de resultados. Posteriormente se podrá utilizar este nombre en sentencias UPDATE|DELETE ... WHERE CURRENT OF name.

Parámetros

result

Juego de resultados de InterBase.

name

Nombre que se asigna.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ibase_name_result()

<?php
$result = ibase_query("SELECT field1,field2 FROM table FOR UPDATE");
ibase_name_result($result, "my_cursor");

$updateqry = ibase_prepare("UPDATE table SET field2 = ? WHERE CURRENT OF my_cursor");

for ($i = 0; ibase_fetch_row($result); ++$i) {
    ibase_execute($updateqry, $i);
}
?>

Ver también

  • ibase_prepare() - Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior
  • ibase_execute() - Ejecutar una consulta previamente preparada


Consulta el número de campos de un resultado

  • « ibase_name_result
  • ibase_num_params »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Consulta el número de campos de un resultado

ibase_num_fields

(PHP 5, PHP 7 < 7.4.0)

ibase_num_fields — Consulta el número de campos de un resultado

Descripción

ibase_num_fields ( resource $result_id ) : int

Obtiene el número de campos de un juego de resultados.

Parámetros

result_id

Identificador de resultado de InterBase.

Valores devueltos

Devuelve el número de campos en forma de entero.

Ejemplos

Ejemplo #1 Ejemplo de ibase_num_fields()

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: " . $col_info['name'] . "\n";
    echo "alias: " . $col_info['alias'] . "\n";
    echo "relation: " . $col_info['relation'] . "\n";
    echo "length: " . $col_info['length'] . "\n";
    echo "type: " . $col_info['type'] . "\n";
}
?>

Ver también

  • ibase_field_info() - Consulta información sobre un determinado campo


Devuelve el número de parámetros de una sentencia preparada

  • « ibase_num_fields
  • ibase_param_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve el número de parámetros de una sentencia preparada

ibase_num_params

(PHP 5, PHP 7 < 7.4.0)

ibase_num_params — Devuelve el número de parámetros de una sentencia preparada

Descripción

ibase_num_params ( resource $query ) : int

Esta función devuelve el número de parámetros de la sentencia preparada especificada en query. Este es el número de argumentos que se deben proporcionar al invocar a ibase_execute().

Parámetros

query

Manejador de consulta preparada.

Valores devueltos

Devuelve el número de parámetros en forma de entero.

Ver también

  • ibase_prepare() - Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior
  • ibase_param_info() - Devuelve información sobre un parámetro de una sentencia preparada


Devuelve información sobre un parámetro de una sentencia preparada

  • « ibase_num_params
  • ibase_pconnect »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Devuelve información sobre un parámetro de una sentencia preparada

ibase_param_info

(PHP 5, PHP 7 < 7.4.0)

ibase_param_info — Devuelve información sobre un parámetro de una sentencia preparada

Descripción

ibase_param_info ( resource $query , int $param_number ) : array

Devuelve un array con información sobre un parámetro de una consulta que ya ha sido preparada.

Parámetros

query

Manejador de sentencia preparada de InterBase.

param_number

Posición del parámetro.

Valores devueltos

Devuelve un array con las siguientes claves: name, alias, relation, length y type.

Ver también

  • ibase_field_info() - Consulta información sobre un determinado campo
  • ibase_num_params() - Devuelve el número de parámetros de una sentencia preparada


Abrir una conexión persistente con una base de datos InterBase

  • « ibase_param_info
  • ibase_prepare »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Abrir una conexión persistente con una base de datos InterBase

ibase_pconnect

(PHP 5, PHP 7 < 7.4.0)

ibase_pconnect — Abrir una conexión persistente con una base de datos InterBase

Descripción

ibase_pconnect ( string $database = ? , string $username = ? , string $password = ? , string $charset = ? , int $buffers = ? , int $dialect = ? , string $role = ? , int $sync = ? ) : resource

Abre una conexión persistente con una base de datos InterBase.

ibase_pconnect() actúa de forma muy similar a ibase_connect() con dos diferencias significativas.

Primero, cuando se crea una conexión, la función intentará primero encontrar un enlace (persistente) ya abierto con los mismos parámetros. Si se encuentra uno, se devolverá un identificador para él, en lugar de abrir una nueva conexión.

Segundo, la conexión con el servidor InterBase no será cerrada cuando finalice la ejecución del script. En su lugar, el enlace permanecerá abierto para su uso futuro (ibase_close() no cerrará enlaces establecidos con ibase_pconnect()). Este tipo de enlace es por lo tanto llamado 'persistente'.

Parámetros

database

El argumento database debe ser una ruta válida al archivo de base de datos en el servidor en el que reside. Si el servidor no es local, debe ser precedido por 'nombre_host:' (TCP/IP), '//nombre_host/' (NetBEUI) o 'nombre_host@' (IPX/SPX), dependiendo del protocolo usado.

username

El nombre de usuario. Puede ser definido mediante la directiva de php.ini ibase.default_user.

password

La contraseña para username. Puede ser definida con la directiva de php.ini ibase.default_password.

charset

charset es el juego de caracteres predeterminado para una base de datos.

buffers

buffers es el número de búfers de base de datos a reservar para el caché en el lado del servidor. Si es 0 o se omite, el servidor elige su propio valor predeterminado.

dialect

dialect selecciona el dialecto SQL predeterminado para cualquier sentencia ejecutada en la conexión, y su valor por omisión es el más alto soportado por las bibliotecas cliente. Este parámetro es funcional únicamente con InterBase 6 y versiones posteriores.

role

Funcional únicamente con InterBase 5 y versiones posteriores.

sync

Valores devueltos

Devuelve un identificador de enlace InterBase en caso de éxito, o false si ocurre un error.

Ver también

  • ibase_close() - Cerrar una conexión con una base de datos InterBase
  • ibase_connect() - Abrir una conexión a una base de datos


Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior

  • « ibase_pconnect
  • ibase_query »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior

ibase_prepare

(PHP 5, PHP 7 < 7.4.0)

ibase_prepare — Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior

Descripción

ibase_prepare ( string $query ) : resource
ibase_prepare ( resource $link_identifier , string $query ) : resource
ibase_prepare ( resource $link_identifier , string $trans , string $query ) : resource

Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior (mediante ibase_execute()).

Parámetros

query

Una consulta InterBase.

Valores devueltos

Devuelve un gestor de consulta preparado, o false en caso de fallo.


Ejecutar una consulta en una base de datos InterBase

  • « ibase_prepare
  • ibase_restore »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Ejecutar una consulta en una base de datos InterBase

ibase_query

(PHP 5, PHP 7 < 7.4.0)

ibase_query — Ejecutar una consulta en una base de datos InterBase

Descripción

ibase_query ( resource $link_identifier = ? , string $query , int $bind_args = ? ) : resource

Realiza una consulta sobre una base de datos InterBase.

Parámetros

link_identifier

Un identificador de enlace InterBase. Si se omite, se asume el último enlace abierto.

query

Una consulta InterBase.

bind_args

Valores devueltos

Si la consulta genera un error, se devuelve false. Si tiene éxito y existe un conjunto de resultados (posiblemente vacío), tal como ocurre con una consulta SELECT, se devuelve el identificador de resultado. Si la consulta fue exitosa y no hay resultados, se devuelve true.

Nota:

En PHP 5.0.0 y versiones posteriores, esta función devuelve el número de filas afectadas por la consulta para sentencias INSERT, UPDATE y DELETE. Con el propósito de mantener compatibilidad hacia atrás, devolverá true para estas sentencias si la consulta tuvo éxito sin afectar filas.

Errores/Excepciones

Si obtiene un error del tipo "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (esto ocurre cuando intenta usar algún caracter con acentos) cuando usa esta extensión después de llamar ibase_query(), debe definir el juego de caracteres (puede ser ISO8859_1 o su juego de caracteres actual).

Historial de cambios

Versión | Descripción
5.3.1 | Si no hay rows afectados, la función ahora devuelve true en caso de éxito, donde anteriormente devolvía 0 (un cero seguido por un espacio en blanco).

Ejemplos

Ejemplo #1 Ejemplo de ibase_query()

<?php

$host = 'localhost:/ruta/a/su/base_de_datos.gdb';

$gestor_bd = ibase_connect($host, $nombre_usuario, $contrasenya);
$sent = 'SELECT * FROM nombre_tabla';

$gestor_sent = ibase_query($gestor_bd, $sent) or die(ibase_errmsg());

?>

Ver también

  • ibase_errmsg() - Devuelve un mensaje de error
  • ibase_fetch_row() - Recuperar una fila desde una base de datos InterBase
  • ibase_fetch_object() - Consulta un objeto de una base de datos InterBase
  • ibase_free_result() - Liberar un conjunto de resultados


Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente

  • « ibase_query
  • ibase_rollback_ret »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente

ibase_restore

(PHP 5, PHP 7 < 7.4.0)

ibase_restore — Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente

Descripción

ibase_restore ( resource $service_handle , string $source_file , string $dest_db , int $options = 0 , bool $verbose = false ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Deshace una transacción sin cerrarla

  • « ibase_restore
  • ibase_rollback »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Deshace una transacción sin cerrarla

ibase_rollback_ret

(PHP 5, PHP 7 < 7.4.0)

ibase_rollback_ret — Deshace una transacción sin cerrarla

Descripción

ibase_rollback_ret ( resource $link_or_trans_identifier = null ) : bool

Deshace una transacción sin cerrarla.

Parámetros

link_or_trans_identifier

Si se invoca sin argumentos, esta función deshace la transacción por omisión del enlace por omisión. Si el argumento fuera un identificador de conexión, se desharía su transacción por omisión. Si, por contra, fuera un identificador de transacción, ésta se desharía. Se mantendrá el contexto de la transacción, de forma que no se invalidarán las sentencias ejecutadas en esta transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Deshace una transacción

  • « ibase_rollback_ret
  • ibase_server_info »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Deshace una transacción

ibase_rollback

(PHP 5, PHP 7 < 7.4.0)

ibase_rollback — Deshace una transacción

Descripción

ibase_rollback ( resource $link_or_trans_identifier = null ) : bool

Deshace una transacción.

Parámetros

link_or_trans_identifier

Si se invoca sin argumentos, esta función deshace la transacción por omisión del enlace por omisión. Si el argumento fuera un identificador de conexión, se desharía su transacción por omisión. Si, por contra, fuera un identificador de transacción, ésta se desharía.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Solicita información sobre un servidor de bases de datos

  • « ibase_rollback
  • ibase_service_attach »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Solicita información sobre un servidor de bases de datos

ibase_server_info

(PHP 5, PHP 7 < 7.4.0)

ibase_server_info — Solicita información sobre un servidor de bases de datos

Descripción

ibase_server_info ( resource $service_handle , int $action ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Conecta al administrador de servicios

  • « ibase_server_info
  • ibase_service_detach »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Conecta al administrador de servicios

ibase_service_attach

(PHP 5, PHP 7 < 7.4.0)

ibase_service_attach — Conecta al administrador de servicios

Descripción

ibase_service_attach ( string $host , string $dba_username , string $dba_password ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Desconecta del administrador de servicios

  • « ibase_service_attach
  • ibase_set_event_handler »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Desconecta del administrador de servicios

ibase_service_detach

(PHP 5, PHP 7 < 7.4.0)

ibase_service_detach — Desconecta del administrador de servicios

Descripción

ibase_service_detach ( resource $service_handle ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Registra una función manejadora de un determinado evento

  • « ibase_service_detach
  • ibase_trans »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Registra una función manejadora de un determinado evento

ibase_set_event_handler

(PHP 5, PHP 7 < 7.4.0)

ibase_set_event_handler — Registra una función manejadora de un determinado evento

Descripción

ibase_set_event_handler ( callable $event_handler , string $event_name1 , string $event_name2 = ? , string $... = ? ) : resource
ibase_set_event_handler ( resource $connection , callable $event_handler , string $event_name1 , string $event_name2 = ? , string $... = ? ) : resource

Esta función registra una función PHP como manejadora para los eventos especificados.

Parámetros

event_handler

A esta función se la invoca, proporcionándola como argumentos el nombre del evento y el enlace al recurso, cada vez que la base de datos emita el evento especificado.

La función devolverá false si se tiene que cancelar el evento. Cualquier otro valor se ignorará. Esta función puede vincularse hasta a 15 eventos.

event_name1

Nombre del evento.

event_name2

Se permiten hasta 15 eventos.

Valores devueltos

El valor devuelto es un recurso de evento. Este recurso se puede usar para liberar un manejador de eventos mediante ibase_free_event_handler().

Ejemplos

Ejemplo #1 Ejemplo de ibase_set_event_handler()

<?php

function event_handler($event_name, $link)
{
    if ($event_name == "NEW ORDER") {
        // procesar nueva petición
        ibase_query($link, "UPDATE orders SET status='handled'");
    } else if ($event_name == "DB_SHUTDOWN") {
        // liberar manejador de evento
        return false;
    }
}

ibase_set_event_handler($link, "event_handler", "NEW_ORDER", "DB_SHUTDOWN");
?>

Ver también

  • ibase_free_event_handler() - Cancela un manejador de eventos ya registrado
  • ibase_wait_event() - Espera a que la base de datos emita un determinado evento


Comienza una transacción

  • « ibase_set_event_handler
  • ibase_wait_event »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Comienza una transacción

ibase_trans

(PHP 5, PHP 7 < 7.4.0)

ibase_trans — Comienza una transacción

Descripción

ibase_trans ( int $trans_args = ? , resource $link_identifier = ? ) : resource
ibase_trans ( resource $link_identifier = ? , int $trans_args = ? ) : resource

Comienza una transacción.

Nota:

La primera llamada a ibase_trans() no devolverá la transacción predeterminada de una conexión. Todas las transacciones que comiencen por ibase_trans() se desharán al finalizar el script siempre y cuando no se hayan llevado a cabo explícitamente, o ya se hubieran deshecho mediante ibase_commit() o ibase_rollback() respectivamente.

Nota:

Esta función aceptará múltiples argumentos trans_args y link_identifier. Esto permite llevar a cabo transacciones sobre múltiples conexiones a bases de datos, las cuales se llevan a cabo utilizando un algoritmo de dos fases. Esto significa que una actualización podría o bien fallar en todas las bases de datos, o bien tener éxito en todas. NO significa que se puedan usar en una misma consulta tablas de distintas bases de datos.

Si se usaran transacciones sobre múltiples bases de datos, se deberá especificar tanto el link_id como el transaction_id en las llamadas a ibase_query() y a ibase_prepare().

Parámetros

trans_args

trans_args puede ser una combinación de IBASE_READ, IBASE_WRITE, IBASE_COMMITTED, IBASE_CONSISTENCY, IBASE_CONCURRENCY, IBASE_REC_VERSION, IBASE_REC_NO_VERSION, IBASE_WAIT y IBASE_NOWAIT.

link_identifier

Identificador de enlace a InterBase. Si se omite, se utilizará el último enlace que se haya abierto.

Valores devueltos

Devuelve un manejador de transacción, o false en caso de error.


Espera a que la base de datos emita un determinado evento

  • « ibase_trans
  • FrontBase »
  • PHP Manual
  • Funciones de Firebird/InterBase
  • Espera a que la base de datos emita un determinado evento

ibase_wait_event

(PHP 5, PHP 7 < 7.4.0)

ibase_wait_event — Espera a que la base de datos emita un determinado evento

Descripción

ibase_wait_event ( string $event_name1 , string $event_name2 = ? , string $... = ? ) : string
ibase_wait_event ( resource $connection , string $event_name1 , string $event_name2 = ? , string $... = ? ) : string

Esta función suspende la ejecución del script hasta que la base de datos emita uno de los eventos especificados. Devuelve el nombre del evento emitido. Esta función acepta hasta 15 eventos como parámetros.

Parámetros

event_name1

Nombre de evento.

event_name2

...

Valores devueltos

Devuelve el nombre del evento que se emitió.

Ver también

  • ibase_set_event_handler() - Registra una función manejadora de un determinado evento
  • ibase_free_event_handler() - Cancela un manejador de eventos ya registrado


FrontBase

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de FrontBase
    • fbsql_affected_rows — Obtiene el numero de filas afectadas en la anterior operación de FrontBase
    • fbsql_autocommit — Activa o desactiva el autocommit
    • fbsql_blob_size — Obtiene el tamaño de un BLOB
    • fbsql_change_user — Cambia el usuario logueado en la conexión activa
    • fbsql_clob_size — Obtiene el tamaño de un CLOB
    • fbsql_close — Cierra la conexión FrontBase
    • fbsql_commit — Ejecuta un commit de la transacción sobre la base de datos
    • fbsql_connect — Abre una conexión a un servidor FrontBase
    • fbsql_create_blob — Crea un BLOB
    • fbsql_create_clob — Crea un CLOB
    • fbsql_create_db — Crea una base de datos FrontBase
    • fbsql_data_seek — Mueve el puntero interno de resultado
    • fbsql_database_password — Asigna o recupera el password de una base de datos FrontBase
    • fbsql_database — Obtiene o especifica la base de datos usada por la conexión
    • fbsql_db_query — Ejecuta una consulta a FrontBase
    • fbsql_db_status — Obtiene el estado de una base de datos dada
    • fbsql_drop_db — Elimina (drop) una base de datos FrontBase
    • fbsql_errno — Devuelve el número de error de la última operación
    • fbsql_error — Devuelve el mensaje de error de la última operación
    • fbsql_fetch_array — Obtiene una fila de resultados como array asociativo, array numérico, o ambos
    • fbsql_fetch_assoc — Obtiene una fila de resultados como array asociativo
    • fbsql_fetch_field — Obtiene información de columnas de un resultado y la devuelve como objeto
    • fbsql_fetch_lengths — Obtiene la longitud de cada salida en un resultado
    • fbsql_fetch_object — Obtiene una fila de resultados como objeto
    • fbsql_fetch_row — Obtiene una fila de resultados como array enumerado
    • fbsql_field_flags — Obtiene los flags de un campo especificado en un resultado
    • fbsql_field_len — Devuleve la longitud de un campo especificado
    • fbsql_field_name — Obtiene el nombre de un campo especificado en un resultado
    • fbsql_field_seek — Mueve el puntero interno de resultado al campo con la posición especificada
    • fbsql_field_table — Obtiene el nombre de la tabla donde se encuentra el campo especificado
    • fbsql_field_type — Obtiene el tipo de campo especificado en un resultado
    • fbsql_free_result — Libera la memoria de resultados
    • fbsql_get_autostart_info — Descripción
    • fbsql_hostname — Obtiene o establece el nombre host de una conexión
    • fbsql_insert_id — Obtiene el valor id generado por la anterior operación INSERT
    • fbsql_list_dbs — Lista las bases de datos disponibles en un servidor FrontBase
    • fbsql_list_fields — Lista los campos de un resultado de FrontBase
    • fbsql_list_tables — Lista las tablas de una base de datos FrontBase
    • fbsql_next_result — Mover el puntero del resultado interno por el resultado de al lado
    • fbsql_num_fields — Obtener el número de campos del resultado
    • fbsql_num_rows — Obtener el número de filas del resultado
    • fbsql_password — Obtiene o asigna el password usado en una conexión
    • fbsql_pconnect — Abrir una conexión persistente a un servidor FrontBase
    • fbsql_query — Realiza una consulta FrontBase
    • fbsql_read_blob — Lee un BLOB de la base de datos
    • fbsql_read_clob — Lee un CLOB de la base de datos
    • fbsql_result — Obtiene los datos de resultado
    • fbsql_rollback — Retrocede una transacción a la base de datos
    • fbsql_rows_fetched — Obtiene el número de filas afectadas por la última consulta
    • fbsql_select_db — Selecciona una base de datos FrontBase
    • fbsql_set_characterset — Cambia el juego de caracteres de entrada/salida
    • fbsql_set_lob_mode — Asigna el modo de recuperación LOB para un set de resultados FrontBase
    • fbsql_set_password — Cambia la contraseña para el usuario especificado
    • fbsql_set_transaction — Asigna el bloqueo y aislamiento de la transacción
    • fbsql_start_db — Inicia una base de datos en un servidor local o remoto
    • fbsql_stop_db — Detiene una base de datos en un servidor local o remoto
    • fbsql_table_name — Obtiene el nombre de una tabla
    • fbsql_tablename — Alias de fbsql_table_name
    • fbsql_username — Obtiene o asigna el nombre de usuario de la conexión
    • fbsql_warnings — Activa o desactiva los warnings de FrontBase


Introducción

Estas funciones permiten el acceso a servidores de base de datos FrontBase. Se puede obtener más información sobre FrontBase en » http://www.frontbase.com/.

La documentación de FrontBase se puede encontrar en » http://www.frontbase.com/cgi-bin/WebObjects/FBWebSite.woa.

El soporte para Frontbase se añadió en PHP 4.0.6.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.3.0.


Requerimientos

Debes instalar el servidor de base de datos FrontBase o, al menos, las bibliotecas de cliente fbsql para usar estas funciones. Puedes conseguir FrontBase desde » http://www.frontbase.com/.


Instalación

Para poder disponer de estas funciones tienes que compilar PHP con soporte para fbsql usando la opción --with-fbsql[=DIR]. Si se usa esta opción sin especificar la ruta a fbsql, PHP buscará las bibliotecas de cliente fbsql en el directorio de instalación por defecto para esa plataforma. Si se ha instalado FrontBase en un directorio no estandar, se debería especificar siempre la ruta a fbsql: --with-fbsql=/path/to/fbsql. Así se fuerza a PHP para que use las bibliotecas de cliente instaladas por FrontBase, evitando cualquier conflicto.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de FrontBase
Nombre | Por defecto | Cambiable | Historial de cambios
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.max_links | "128" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.max_connections | "128" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.max_results | "128" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.batchSize | "1000" | PHP_INI_SYSTEM | Disponible desde PHP 4.2.0. Eliminado en PHP 5.1.0.
fbsql.default_host | NULL | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.default_password | "" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.default_database | "" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.default_database_password | "" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.mbatchSize | "1000" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6. Eliminado en PHP 4.2.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

FBSQL_ASSOC (integer)
FBSQL_NUM (integer)
FBSQL_BOTH (integer)
FBSQL_LOCK_DEFERRED (integer)
FBSQL_LOCK_OPTIMISTIC (integer)
FBSQL_LOCK_PESSIMISTIC (integer)
FBSQL_ISO_READ_UNCOMMITTED (integer)
FBSQL_ISO_READ_COMMITTED (integer)
FBSQL_ISO_REPEATABLE_READ (integer)
FBSQL_ISO_SERIALIZABLE (integer)
FBSQL_ISO_VERSIONED (integer)
FBSQL_UNKNOWN (integer)
FBSQL_STOPPED (integer)
FBSQL_STARTING (integer)
FBSQL_RUNNING (integer)
FBSQL_STOPPING (integer)
FBSQL_NOEXEC (integer)
FBSQL_LOB_DIRECT (integer)
FBSQL_LOB_HANDLE (integer)


Funciones de FrontBase

Tabla de contenidos

  • fbsql_affected_rows — Obtiene el numero de filas afectadas en la anterior operación de FrontBase
  • fbsql_autocommit — Activa o desactiva el autocommit
  • fbsql_blob_size — Obtiene el tamaño de un BLOB
  • fbsql_change_user — Cambia el usuario logueado en la conexión activa
  • fbsql_clob_size — Obtiene el tamaño de un CLOB
  • fbsql_close — Cierra la conexión FrontBase
  • fbsql_commit — Ejecuta un commit de la transacción sobre la base de datos
  • fbsql_connect — Abre una conexión a un servidor FrontBase
  • fbsql_create_blob — Crea un BLOB
  • fbsql_create_clob — Crea un CLOB
  • fbsql_create_db — Crea una base de datos FrontBase
  • fbsql_data_seek — Mueve el puntero interno de resultado
  • fbsql_database_password — Asigna o recupera el password de una base de datos FrontBase
  • fbsql_database — Obtiene o especifica la base de datos usada por la conexión
  • fbsql_db_query — Ejecuta una consulta a FrontBase
  • fbsql_db_status — Obtiene el estado de una base de datos dada
  • fbsql_drop_db — Elimina (drop) una base de datos FrontBase
  • fbsql_errno — Devuelve el número de error de la última operación
  • fbsql_error — Devuelve el mensaje de error de la última operación
  • fbsql_fetch_array — Obtiene una fila de resultados como array asociativo, array numérico, o ambos
  • fbsql_fetch_assoc — Obtiene una fila de resultados como array asociativo
  • fbsql_fetch_field — Obtiene información de columnas de un resultado y la devuelve como objeto
  • fbsql_fetch_lengths — Obtiene la longitud de cada salida en un resultado
  • fbsql_fetch_object — Obtiene una fila de resultados como objeto
  • fbsql_fetch_row — Obtiene una fila de resultados como array enumerado
  • fbsql_field_flags — Obtiene los flags de un campo especificado en un resultado
  • fbsql_field_len — Devuleve la longitud de un campo especificado
  • fbsql_field_name — Obtiene el nombre de un campo especificado en un resultado
  • fbsql_field_seek — Mueve el puntero interno de resultado al campo con la posición especificada
  • fbsql_field_table — Obtiene el nombre de la tabla donde se encuentra el campo especificado
  • fbsql_field_type — Obtiene el tipo de campo especificado en un resultado
  • fbsql_free_result — Libera la memoria de resultados
  • fbsql_get_autostart_info — Descripción
  • fbsql_hostname — Obtiene o establece el nombre host de una conexión
  • fbsql_insert_id — Obtiene el valor id generado por la anterior operación INSERT
  • fbsql_list_dbs — Lista las bases de datos disponibles en un servidor FrontBase
  • fbsql_list_fields — Lista los campos de un resultado de FrontBase
  • fbsql_list_tables — Lista las tablas de una base de datos FrontBase
  • fbsql_next_result — Mover el puntero del resultado interno por el resultado de al lado
  • fbsql_num_fields — Obtener el número de campos del resultado
  • fbsql_num_rows — Obtener el número de filas del resultado
  • fbsql_password — Obtiene o asigna el password usado en una conexión
  • fbsql_pconnect — Abrir una conexión persistente a un servidor FrontBase
  • fbsql_query — Realiza una consulta FrontBase
  • fbsql_read_blob — Lee un BLOB de la base de datos
  • fbsql_read_clob — Lee un CLOB de la base de datos
  • fbsql_result — Obtiene los datos de resultado
  • fbsql_rollback — Retrocede una transacción a la base de datos
  • fbsql_rows_fetched — Obtiene el número de filas afectadas por la última consulta
  • fbsql_select_db — Selecciona una base de datos FrontBase
  • fbsql_set_characterset — Cambia el juego de caracteres de entrada/salida
  • fbsql_set_lob_mode — Asigna el modo de recuperación LOB para un set de resultados FrontBase
  • fbsql_set_password — Cambia la contraseña para el usuario especificado
  • fbsql_set_transaction — Asigna el bloqueo y aislamiento de la transacción
  • fbsql_start_db — Inicia una base de datos en un servidor local o remoto
  • fbsql_stop_db — Detiene una base de datos en un servidor local o remoto
  • fbsql_table_name — Obtiene el nombre de una tabla
  • fbsql_tablename — Alias de fbsql_table_name
  • fbsql_username — Obtiene o asigna el nombre de usuario de la conexión
  • fbsql_warnings — Activa o desactiva los warnings de FrontBase


Obtiene el numero de filas afectadas en la anterior operación de FrontBase

  • « Funciones de FrontBase
  • fbsql_autocommit »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el numero de filas afectadas en la anterior operación de FrontBase

fbsql_affected_rows

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_affected_rows — Obtiene el numero de filas afectadas en la anterior operación de FrontBase

Descripción

fbsql_affected_rows ( resource $link_identifier = ? ) : int

fbsql_affected_rows() devuelve el número de filas afectadas por la última consulta INSERT, UPDATE o DELETE asociada al link_identifier.

Nota:

En caso de utilizar transacciones, se tiene que llamar fbsql_affected_rows() después de la consulta INSERT, UPDATE, o DELETE, no después del commit.

Si la última consulta fue un DELETE sin WHERE, todos los registros habrán sido borrados de la tabla, sin embargo la función devolverá cero.

Nota:

Cuando se usa UPDATE, FrontBase no actualiza las columnas donde el nuevo valor es el mismo que el antiguo. Esto da la posibilidad de que fbsql_affected_rows() no devuelva el número de columnas encontradas, sino únicamente el número de columnas afectadas literalmente por la consulta.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Si la última consulta falló, esta función devolverá -1.

Ver también

  • fbsql_num_rows() - Obtener el número de filas del resultado


Activa o desactiva el autocommit

  • « fbsql_affected_rows
  • fbsql_blob_size »
  • PHP Manual
  • Funciones de FrontBase
  • Activa o desactiva el autocommit

fbsql_autocommit

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_autocommit — Activa o desactiva el autocommit

Descripción

fbsql_autocommit ( resource $link_identifier , bool $OnOff = ? ) : bool

Devuelve el estado actual del autocommit.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

OnOff

Si se recibe este parametro opcional, se cambiará el estado del autocommit

Con OnOff a true cada sentencia tendrá un commit automático en caso de no encontrarse errores.

Con OnOff a false el usuario deberá hacer commit o rollback de la transacción, usando fbsql_commit() o fbsql_rollback() respectivamente.

Valores devueltos

Devuelve el estado actual del autocommit, como boolean.

Ver también

  • fbsql_commit() - Ejecuta un commit de la transacción sobre la base de datos
  • fbsql_rollback() - Retrocede una transacción a la base de datos


Obtiene el tamaño de un BLOB

  • « fbsql_autocommit
  • fbsql_change_user »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el tamaño de un BLOB

fbsql_blob_size

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_blob_size — Obtiene el tamaño de un BLOB

Descripción

fbsql_blob_size ( string $blob_handle , resource $link_identifier = ? ) : int

Devuelve el tamaño del BLOB recibido.

Parámetros

blob_handle

Un handle BLOB, devuelto por fbsql_create_blob().

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve el tamaño del BLOB como integer, o false en caso de error.

Ver también

  • fbsql_clob_size() - Obtiene el tamaño de un CLOB


Cambia el usuario logueado en la conexión activa

  • « fbsql_blob_size
  • fbsql_clob_size »
  • PHP Manual
  • Funciones de FrontBase
  • Cambia el usuario logueado en la conexión activa

fbsql_change_user

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_change_user — Cambia el usuario logueado en la conexión activa

Descripción

fbsql_change_user ( string $user , string $password , string $database = ? , resource $link_identifier = ? ) : bool

fbsql_change_user() cambia el usuario logueado en la conexión especificada. Si falla la autorización del nuevo usuario/password, se mantiene activa la conexión con el usuario actual.

Parámetros

user

El nuevo nombre de usuario.

password

El nuevo password.

database

Si se especifica, se aplicará como base de datos por defecto una vez el usuario se haya cambiado.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtiene el tamaño de un CLOB

  • « fbsql_change_user
  • fbsql_close »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el tamaño de un CLOB

fbsql_clob_size

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_clob_size — Obtiene el tamaño de un CLOB

Descripción

fbsql_clob_size ( string $clob_handle , resource $link_identifier = ? ) : int

Devuelve el tamaño del CLOB recibido.

Parámetros

clob_handle

Un handle CLOB, devuelto por fbsql_create_clob().

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve el tamaño del CLOB como un integer, o false en caso de error.

Ver también

  • fbsql_blob_size() - Obtiene el tamaño de un BLOB


Cierra la conexión FrontBase

  • « fbsql_clob_size
  • fbsql_commit »
  • PHP Manual
  • Funciones de FrontBase
  • Cierra la conexión FrontBase

fbsql_close

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_close — Cierra la conexión FrontBase

Descripción

fbsql_close ( resource $link_identifier = ? ) : bool

Cierra la conexión con el servidor FrontBase asociado al link_identifier especificado.

No suele ser necesario usar fbsql_close(), ya que los enlaces no-persistentes abiertos se cierran de forma automática al final de la ejecución del script.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_close()

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
echo "Conectado correctamente";
fbsql_close($link);
?>

Ver también

  • fbsql_connect() - Abre una conexión a un servidor FrontBase
  • fbsql_pconnect() - Abrir una conexión persistente a un servidor FrontBase


Ejecuta un commit de la transacción sobre la base de datos

  • « fbsql_close
  • fbsql_connect »
  • PHP Manual
  • Funciones de FrontBase
  • Ejecuta un commit de la transacción sobre la base de datos

fbsql_commit

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_commit — Ejecuta un commit de la transacción sobre la base de datos

Descripción

fbsql_commit ( resource $link_identifier = ? ) : bool

Finaliza la transaccion actual escribiendo todos los INSERTs, UPDATEs y DELETEs en el disco y desbloqueando todos los bloqueos de fila y tabla mantenidos por la transacción. Este comando sólo se necesita si el autocommit está asignado a false.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_autocommit() - Activa o desactiva el autocommit
  • fbsql_rollback() - Retrocede una transacción a la base de datos


Abre una conexión a un servidor FrontBase

  • « fbsql_commit
  • fbsql_create_blob »
  • PHP Manual
  • Funciones de FrontBase
  • Abre una conexión a un servidor FrontBase

fbsql_connect

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_connect — Abre una conexión a un servidor FrontBase

Descripción

fbsql_connect
 ( string $hostname = ini_get("fbsql.default_host")
, string $username = ini_get("fbsql.default_user")
, string $password = ini_get("fbsql.default_password")
) : resource

fbsql_connect() establece una conexión a un servidor FrontBase.

Si se hace una segunda llamada a fbsql_connect() con los mismos argumentos, no se establecerá un nuevo enlace, sino que se devolverá el identificador del enlace ya abierto en su lugar.

El enlace al servidor se cerrará tan pronto como acabe la ejecución del script, a no ser que se cierre antes explicitamente llamando fbsql_close().

Parámetros

hostname

El nombre de host del servidor.

username

El nombre de usuario para la conexión.

password

El password para la conexión.

Valores devueltos

Devuelve un identificador de enlace FrontBase positivo, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_connect()

<?php

$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
echo "Conectado correctamente";
fbsql_close($link);

?>

Ver también

  • fbsql_pconnect() - Abrir una conexión persistente a un servidor FrontBase
  • fbsql_close() - Cierra la conexión FrontBase


Crea un BLOB

  • « fbsql_connect
  • fbsql_create_clob »
  • PHP Manual
  • Funciones de FrontBase
  • Crea un BLOB

fbsql_create_blob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_create_blob — Crea un BLOB

Descripción

fbsql_create_blob ( string $blob_data , resource $link_identifier = ? ) : string

Crea un BLOB a partir de los datos recibidos.

Parámetros

blob_data

Los datos BLOB.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un handle a un nuevo recurso BLOB, que puede usarse con comandos INSERT y UPDATE para almacenar el BLOB en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_create_blob()

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
$filename = "blobfile.bin";
$fp = fopen($filename, "rb");
$blobdata = fread($fp, filesize($filename));
fclose($fp);

$blobHandle = fbsql_create_blob($blobdata, $link);

$sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
$rs = fbsql_query($sql, $link);
?>

Ver también

  • fbsql_create_clob() - Crea un CLOB
  • fbsql_read_blob() - Lee un BLOB de la base de datos
  • fbsql_read_clob() - Lee un CLOB de la base de datos
  • fbsql_set_lob_mode() - Asigna el modo de recuperación LOB para un set de resultados FrontBase


Crea un CLOB

  • « fbsql_create_blob
  • fbsql_create_db »
  • PHP Manual
  • Funciones de FrontBase
  • Crea un CLOB

fbsql_create_clob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_create_clob — Crea un CLOB

Descripción

fbsql_create_clob ( string $clob_data , resource $link_identifier = ? ) : string

Crea un CLOB a partir de los datos recibidos.

Parámetros

clob_data

Los datos CLOB.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un handle a un nuevo recurso CLOB, que puede usarse con comandos INSERT y UPDATE para almacenar el CLOB en la base de datos.

Ejemplos

Ejemplo #1 fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
$filename = "clob_file.txt";
$fp = fopen($filename, "rb");
$clobdata = fread($fp, filesize($filename));
fclose($fp);

$clobHandle = fbsql_create_clob($clobdata, $link);

$sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
$rs = fbsql_query($sql, $link);
?>

Ver también

  • fbsql_create_blob() - Crea un BLOB
  • fbsql_read_blob() - Lee un BLOB de la base de datos
  • fbsql_read_clob() - Lee un CLOB de la base de datos
  • fbsql_set_lob_mode() - Asigna el modo de recuperación LOB para un set de resultados FrontBase


Crea una base de datos FrontBase

  • « fbsql_create_clob
  • fbsql_data_seek »
  • PHP Manual
  • Funciones de FrontBase
  • Crea una base de datos FrontBase

fbsql_create_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_create_db — Crea una base de datos FrontBase

Descripción

fbsql_create_db ( string $database_name , resource $link_identifier = ? , string $database_options = ? ) : bool

Intenta crear una nueva base de datos en el servidor especificado.

Parámetros

database_name

El nombre de la base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

database_options

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_create_db().

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
if (fbsql_create_db("my_db")) {
    echo "Base de datos creada correctamente\n";
} else {
    printf("Error creando base de datos: %s\n", fbsql_error());
}
?>

Ver también

  • fbsql_drop_db() - Elimina (drop) una base de datos FrontBase


Mueve el puntero interno de resultado

  • « fbsql_create_db
  • fbsql_database_password »
  • PHP Manual
  • Funciones de FrontBase
  • Mueve el puntero interno de resultado

fbsql_data_seek

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_data_seek — Mueve el puntero interno de resultado

Descripción

fbsql_data_seek ( resource $result , int $row_number ) : bool

Mueve el puntero interno a fila del resultado FrontBase asociado con el identificador de resultado indicado, para que apunte el número de fila especificado.

La siguiente llamada a fbsql_fetch_row() devolvería esa fila.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

row_number

El número de fila. Comienza en 0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 fbsql_data_seek() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");

fbsql_select_db("samp_db")
    or die("No se puede seleccionar la base de datos");

$query = "SELECT last_name, first_name FROM friends;";
$result = fbsql_query($query)
    or die("Consulta fallida");

// Obtiene las filas en orden inverso

for ($i = fbsql_num_rows($result) - 1; $i >=0; $i--) {
    if (!fbsql_data_seek($result, $i)) {
        printf("No se puede mover a la fila %d\n", $i);
        continue;
    }

    if (!($row = fbsql_fetch_object($result)))
        continue;

    echo $row->last_name . $row->first_name . "<br />\n";
}

fbsql_free_result($result);
?>


Asigna o recupera el password de una base de datos FrontBase

  • « fbsql_data_seek
  • fbsql_database »
  • PHP Manual
  • Funciones de FrontBase
  • Asigna o recupera el password de una base de datos FrontBase

fbsql_database_password

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_database_password — Asigna o recupera el password de una base de datos FrontBase

Descripción

fbsql_database_password ( resource $link_identifier , string $database_password = ? ) : string

Asigna o recupera el database password de la base de datos usado por la conexión. Si una base de datos está protegida por un password, el usuario debe llamar esta función antes de llamar fbsql_select_db().

Si no hay enlace abierto, la función intentará establecer un enlace como si se hubiese llamado a fbsql_connect(), y lo usará.

Esta función no modifica el database password en la propia base de datos ni tampoco puede usarse para obtener el database password de una base de datos.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

database_password

El database password, en un string. Si se proporicona, la función asigna el database password para el identificador de enlace especificado.

Valores devueltos

Devuelve el database password asociado con el identificador de enlace.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_database_password()

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se puede conectar");
fbsql_database_password($link, "secret db password");
fbsql_select_db($database, $link);
?>

Ver también

  • fbsql_connect() - Abre una conexión a un servidor FrontBase
  • fbsql_pconnect() - Abrir una conexión persistente a un servidor FrontBase
  • fbsql_select_db() - Selecciona una base de datos FrontBase


Obtiene o especifica la base de datos usada por la conexión

  • « fbsql_database_password
  • fbsql_db_query »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene o especifica la base de datos usada por la conexión

fbsql_database

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_database — Obtiene o especifica la base de datos usada por la conexión

Descripción

fbsql_database ( resource $link_identifier , string $database = ? ) : string

Obtiene o especifica la base de datos que usa la conexión.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

database

El nombre de la base de datos. Si se indica, se cambiará la base de datos por defecto de la conexión por la database especificada.

Valores devueltos

Devuelve el nombre de la base de datos usada en esta conexión.


Ejecuta una consulta a FrontBase

  • « fbsql_database
  • fbsql_db_status »
  • PHP Manual
  • Funciones de FrontBase
  • Ejecuta una consulta a FrontBase

fbsql_db_query

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_db_query — Ejecuta una consulta a FrontBase

Descripción

fbsql_db_query ( string $database , string $query , resource $link_identifier = ? ) : resource

Selecciona una base de datos y ejecuta una consulta sobre ella.

Parámetros

database

La base de datos a seleccionar.

query

La consulta SQL a ejecutar.

Nota:

La consulta deberá acabar siempre con un punto y coma (;).

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve el identificador de resultado positivo de la consulta, o false si es error.

Ver también

  • fbsql_query() - Realiza una consulta FrontBase
  • fbsql_connect() - Abre una conexión a un servidor FrontBase


Obtiene el estado de una base de datos dada

  • « fbsql_db_query
  • fbsql_drop_db »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el estado de una base de datos dada

fbsql_db_status

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0)

fbsql_db_status — Obtiene el estado de una base de datos dada

Descripción

fbsql_db_status ( string $database_name , resource $link_identifier = ? ) : int

Obtiene el estado actual de la base de datos especificada.

Parámetros

database_name

El nombre de la base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un integer con el estado actual. Puede ser una de las siguientes constantes:

  • false - El exec handler del host es inválido. Este error puede ocurrir cuando link_identifier conecta directamente a la base de datos usando un número de puerto. Puede que FBExec esté disponible en el servidor, pero no se ha realizado una conexión para él.
  • FBSQL_UNKNOWN - El estado desconocido.
  • FBSQL_STOPPED - La base de datos no esta en marcha. Use fbsql_start_db() para iniciar la base de datos.
  • FBSQL_STARTING - La base de datos se esta iniciando.
  • FBSQL_RUNNING - La base de datos es en marcha y se pueden realizar operaciones SQL.
  • FBSQL_STOPPING - La base de datos se está deteniendo.
  • FBSQL_NOEXEC - FBExec no está en funcionando en el servidor y no es posible obtener el estado de la base de datos.

Ver también

  • fbsql_start_db() - Inicia una base de datos en un servidor local o remoto
  • fbsql_stop_db() - Detiene una base de datos en un servidor local o remoto


Elimina (drop) una base de datos FrontBase

  • « fbsql_db_status
  • fbsql_errno »
  • PHP Manual
  • Funciones de FrontBase
  • Elimina (drop) una base de datos FrontBase

fbsql_drop_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_drop_db — Elimina (drop) una base de datos FrontBase

Descripción

fbsql_drop_db ( string $database_name , resource $link_identifier = ? ) : bool

fbsql_drop_db() intenta eliminar (drop) por completo una base de datos en el servidor asociado al identificador de enlace especificado.

Parámetros

database_name

El nombre de la base de datos, como string.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_create_db() - Crea una base de datos FrontBase


Devuelve el número de error de la última operación

  • « fbsql_drop_db
  • fbsql_error »
  • PHP Manual
  • Funciones de FrontBase
  • Devuelve el número de error de la última operación

fbsql_errno

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_errno — Devuelve el número de error de la última operación

Descripción

fbsql_errno ( resource $link_identifier = ? ) : int

Devuelve el valor numérico del mensaje de error de la última operación FrontBase.

Los errores procedentes el gestor de base de datos fbsql no emiten warnings. En su lugar, use fbsql_errno() para obtener el código de error. Recuerde que esta función solo devuelve el código de error generado por la función fbsql ejecutada más recientemente (sin incluir fbsql_error() y fbsql_errno()), así que para usarla hay que asegurarse de comprobar el valor antes de ejecutar otra función de fbsql.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve el número de error de la última función fbsql, o 0 (cero) si no hubo error.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_errno()

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Ver también

  • fbsql_error() - Devuelve el mensaje de error de la última operación
  • fbsql_warnings() - Activa o desactiva los warnings de FrontBase


Devuelve el mensaje de error de la última operación

  • « fbsql_errno
  • fbsql_fetch_array »
  • PHP Manual
  • Funciones de FrontBase
  • Devuelve el mensaje de error de la última operación

fbsql_error

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_error — Devuelve el mensaje de error de la última operación

Descripción

fbsql_error ( resource $link_identifier = ? ) : string

Devuelve el mensaje de error de la última operación FrontBase.

Los errores procedentes el gestor de base de datos fbsql no emiten warnings. En su lugar, use fbsql_error() para obtener el mensaje de error. Recuerde que esta función solo devuelve el mensaje de error generado por la función fbsql ejecutada más recientemente (sin incluir fbsql_error() y fbsql_errno()), así que para usarla hay que asegurarse de comprobar el valor antes de ejecutar otra función de fbsql.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_error()

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Ver también

  • fbsql_errno() - Devuelve el número de error de la última operación
  • fbsql_warnings() - Activa o desactiva los warnings de FrontBase


Obtiene una fila de resultados como array asociativo, array numérico, o ambos

  • « fbsql_error
  • fbsql_fetch_assoc »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene una fila de resultados como array asociativo, array numérico, o ambos

fbsql_fetch_array

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_array — Obtiene una fila de resultados como array asociativo, array numérico, o ambos

Descripción

fbsql_fetch_array ( resource $result , int $result_type = ? ) : array

fbsql_fetch_array() es una combinación de
fbsql_fetch_row() y
fbsql_fetch_assoc().

Es importante saber que usar fbsql_fetch_array() NO es significativamente más lento que usar fbsql_fetch_row(), y además proporciona un reseñable valor añadido.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

result_type

Una constante, que puede ser uno de los siguientes valores: FBSQL_ASSOC, FBSQL_NUM, or FBSQL_BOTH.

Usando FBSQL_BOTH, además de almacenar los datos en índices numéricos del array resultante, también los almacena en índices asociativos, usando como clave el nombre del campo.

Valores devueltos

Devuelve un array que corresponde a la fila obtenida, o false si no quedan más filas.

Si hay dos o más columnas del resultado con los mismos nombres de campo, la última columna tendrá prioridad. Para acceder a la otra(s) columna(s) con el mismo nombre será necesario utilizar el índice numérico, o bien hacer un alias para la(s) columna(s).

select t1.f1 as foo t2.f1 as bar from t1, t2

Ejemplos

Ejemplo #1 Ejemplo de fbsql_fetch_array()

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select user_id, fullname from table");
while ($row = fbsql_fetch_array($result)) {
    echo "user_id: " . $row["user_id"] . "<br />\n";
    echo "user_id: " . $row[0] . "<br />\n";
    echo "fullname: " . $row["fullname"] . "<br />\n";
    echo "fullname: " . $row[1] . "<br />\n";
}
fbsql_free_result($result);
?>

Ver también

  • fbsql_fetch_row() - Obtiene una fila de resultados como array enumerado
  • fbsql_fetch_assoc() - Obtiene una fila de resultados como array asociativo
  • fbsql_fetch_object() - Obtiene una fila de resultados como objeto


Obtiene una fila de resultados como array asociativo

  • « fbsql_fetch_array
  • fbsql_fetch_field »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene una fila de resultados como array asociativo

fbsql_fetch_assoc

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_assoc — Obtiene una fila de resultados como array asociativo

Descripción

fbsql_fetch_assoc ( resource $result ) : array

Llamar a fbsql_fetch_assoc() es equivalente a hacerlo a fbsql_fetch_array() con FBSQL_ASSOC como segundo parámetro. Sólo devuelve un array asociativo.

fbsql_fetch_array() funcionaba originalmente así. Si se necesitan índices numéricos además de los asociativos, , se puede usar fbsql_fetch_array().

Es importante saber que usar fbsql_fetch_assoc() NO es significativamente más lento que usar fbsql_fetch_row(), y además proporciona un reseñable valor añadido.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve un array que corresponde a la fila obtenida, o false si no quedan más filas.

Si hay dos o más columnas del resultado con los mismos nombres de campo, la última columna tendrá prioridad. Para acceder a la otra(s) columna(s) con el mismo nombre será necesario utilizar fbsql_fetch_array() y hacer que devuelva también los índices numéricos.

Ejemplos

Ejemplo #1 fbsql_fetch_assoc() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_assoc($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result($result);
?>

Ver también

  • fbsql_fetch_row() - Obtiene una fila de resultados como array enumerado
  • fbsql_fetch_array() - Obtiene una fila de resultados como array asociativo, array numérico, o ambos
  • fbsql_fetch_object() - Obtiene una fila de resultados como objeto


Obtiene información de columnas de un resultado y la devuelve como objeto

  • « fbsql_fetch_assoc
  • fbsql_fetch_lengths »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene información de columnas de un resultado y la devuelve como objeto

fbsql_fetch_field

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_field — Obtiene información de columnas de un resultado y la devuelve como objeto

Descripción

fbsql_fetch_field ( resource $result , int $field_offset = ? ) : object

Usada para obtener información acerca de los campos en un resultado de consulta determinado.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

field_offset

El offset numerico del campo. El índice de campos empieza en 0. Si no se especifica, se obtiene el siguiente campo que todavía no haya sido obtenido fbsql_fetch_field().

Valores devueltos

Devuelve un objeto conteniendo la información del campo, o false en caso de error.

Las propiedades de los objetos son:

  • name - nombre de la columna
  • table - nombre de la tabla a la que pertenece la columna
  • max_length - longitud máxima de la columna
  • not_null - 1 si la columna no puede ser null
  • type - el tipo de dato de la columna

Ejemplos

Ejemplo #1 Ejemplo de fbsql_fetch_field()

<?php
fbsql_connect($host, $user, $password)
    or die("No se puede conectar");
$result = fbsql_db_query("database", "select * from table")
    or die("Consulta fallida");
// Obtiene los metadatos de la columna
$i = 0;
while ($i < fbsql_num_fields($result)) {
    echo "Información para la columna $i:<br />\n";
    $meta = fbsql_fetch_field($result);
    if (!$meta) {
        echo "No hay información disponible<br />\n";
    }
    echo "<pre>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</pre>";
    $i++;
}
fbsql_free_result($result);
?>

Ver también

  • fbsql_field_seek() - Mueve el puntero interno de resultado al campo con la posición especificada


Obtiene la longitud de cada salida en un resultado

  • « fbsql_fetch_field
  • fbsql_fetch_object »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene la longitud de cada salida en un resultado

fbsql_fetch_lengths

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_lengths — Obtiene la longitud de cada salida en un resultado

Descripción

fbsql_fetch_lengths ( resource $result ) : array

Almacena en un array las longitudes de cada columna de resultado,
de la última fila devuelta por
fbsql_fetch_row(),
fbsql_fetch_array() y
fbsql_fetch_object().

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve un array (desde offset 0) que corresponde a las longitudes de cada campo en la última fila obtenida por fbsql_fetch_row(), o false en caso de error.

Ver también

  • fbsql_fetch_row() - Obtiene una fila de resultados como array enumerado


Obtiene una fila de resultados como objeto

  • « fbsql_fetch_lengths
  • fbsql_fetch_row »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene una fila de resultados como objeto

fbsql_fetch_object

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_object — Obtiene una fila de resultados como objeto

Descripción

fbsql_fetch_object ( resource $result ) : object

fbsql_fetch_object() es similar a fbsql_fetch_array(), con una diferencia, se devuelve un objeto en lugar de un array. Indirectamente, eso significa que solo se puede acceder a los datos mediante el nombre del campo, y no por sus offsets (no se aceptan los números como nombres de un atributo de un objeto).

En lo relativo a la velocidad, esta función es idéntica a fbsql_fetch_array(), y prácticamente tan rápida como fbsql_fetch_row() (la diferencia es insignificante).

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve un objeto cuyos atributos corresponden a la fila obtenida, o false si no quedan más filas.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_fetch_object()

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result($result);
?>

Ver también

  • fbsql_fetch_array() - Obtiene una fila de resultados como array asociativo, array numérico, o ambos
  • fbsql_fetch_row() - Obtiene una fila de resultados como array enumerado
  • fbsql_fetch_assoc() - Obtiene una fila de resultados como array asociativo


Obtiene una fila de resultados como array enumerado

  • « fbsql_fetch_object
  • fbsql_field_flags »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene una fila de resultados como array enumerado

fbsql_fetch_row

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_row — Obtiene una fila de resultados como array enumerado

Descripción

fbsql_fetch_row ( resource $result ) : array

fbsql_fetch_row() obtiene una fila de datos del resultado asociado con el identificador de resultado especificado.

Las siguientes llamadas a fbsql_fetch_row() devolverán la siguiente fila en el resultset, o false si no hay más filas.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve el array que corresponde a la fila obtenida, donde cada columna se guarda en un offset (comenzando desde 0), o false si no hay más filas.

Ver también

  • fbsql_fetch_array() - Obtiene una fila de resultados como array asociativo, array numérico, o ambos
  • fbsql_fetch_assoc() - Obtiene una fila de resultados como array asociativo
  • fbsql_fetch_object() - Obtiene una fila de resultados como objeto
  • fbsql_data_seek() - Mueve el puntero interno de resultado
  • fbsql_fetch_lengths() - Obtiene la longitud de cada salida en un resultado
  • fbsql_result() - Obtiene los datos de resultado


Obtiene los flags de un campo especificado en un resultado

  • « fbsql_fetch_row
  • fbsql_field_len »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene los flags de un campo especificado en un resultado

fbsql_field_flags

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_flags — Obtiene los flags de un campo especificado en un resultado

Descripción

fbsql_field_flags ( resource $result , int $field_offset = ? ) : string

Obtiene los flags del campo especificado en un resultado.

Parámetros

result

Un puntero a un resultado devuelto por fbsql_list_fields().

field_offset

El offset numérico del campo. El índice de campos comienza en 0.0.

Valores devueltos

Devuelve los flags del campo especificado en una cadena, una palabra por flag separada por un espacio, de forma que se pueden separar usando a función explode().


Devuleve la longitud de un campo especificado

  • « fbsql_field_flags
  • fbsql_field_name »
  • PHP Manual
  • Funciones de FrontBase
  • Devuleve la longitud de un campo especificado

fbsql_field_len

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_len — Devuleve la longitud de un campo especificado

Descripción

fbsql_field_len ( resource $result , int $field_offset = ? ) : int

Devuelve la longitud del campo especificado.

Parámetros

result

Un puntero a resultado, devuelto por fbsql_list_fields().

field_offset

El offset del campo. El índice de campos comienza en 0.

Valores devueltos

Devuelve la longitud de campo especificado.


Obtiene el nombre de un campo especificado en un resultado

  • « fbsql_field_len
  • fbsql_field_seek »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el nombre de un campo especificado en un resultado

fbsql_field_name

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_name — Obtiene el nombre de un campo especificado en un resultado

Descripción

fbsql_field_name ( resource $result , int $field_index = ? ) : string

Devuelve el nombre del campo en la posición especificada.

Parámetros

result

Un puntero a resultado, devuelto por fbsql_list_fields().

field_index

El offset del campo. El índice de campos comienza en 0.

Valores devueltos

Devuelve el nombre como una cadena, o false si el campo no existe.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_field_name()

<?php
// La tabla usuarios consiste en tres campos:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);
?>

El resultado del ejemplo sería:

user_id
password

Ver también

  • fbsql_field_type() - Obtiene el tipo de campo especificado en un resultado


Mueve el puntero interno de resultado al campo con la posición especificada

  • « fbsql_field_name
  • fbsql_field_table »
  • PHP Manual
  • Funciones de FrontBase
  • Mueve el puntero interno de resultado al campo con la posición especificada

fbsql_field_seek

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_seek — Mueve el puntero interno de resultado al campo con la posición especificada

Descripción

fbsql_field_seek ( resource $result , int $field_offset = ? ) : bool

Busca la posición (offset) de campo espcificada. Si la siguiente llamada a fbsql_fetch_field() no incluye un offset de campo, se devolverá la del campo cuyo offset se definiese mediante fbsql_field_seek().

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

field_offset

La posición numérica del campo. El índice comienza por 0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_fetch_field() - Obtiene información de columnas de un resultado y la devuelve como objeto


Obtiene el nombre de la tabla donde se encuentra el campo especificado

  • « fbsql_field_seek
  • fbsql_field_type »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el nombre de la tabla donde se encuentra el campo especificado

fbsql_field_table

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_table — Obtiene el nombre de la tabla donde se encuentra el campo especificado

Descripción

fbsql_field_table ( resource $result , int $field_offset = ? ) : string

Devuelve el nombre de la tabla donde se encuentra el campo especificado.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

field_offset

La posición (offset) del campo. El índice comienza por 0.

Valores devueltos

Devuelve el nombre de la tabla, como un string.


Obtiene el tipo de campo especificado en un resultado

  • « fbsql_field_table
  • fbsql_free_result »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el tipo de campo especificado en un resultado

fbsql_field_type

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_type — Obtiene el tipo de campo especificado en un resultado

Descripción

fbsql_field_type ( resource $result , int $field_offset = ? ) : string

fbsql_field_type() es similar a la función fbsql_field_name(), pero se devuelve el tipo de campo en su lugar.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

field_offset

La posición numérica (offset) del campo. El índice comienza por 0.

Valores devueltos

Devuelve el tipo de campo, como string.

Puede ser: int, real, string, blob, además de otras, como se detalla en la » documentación de FrontBase.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_field_type()

<?php

fbsql_connect("localhost", "_SYSTEM", "");
fbsql_select_db("wisconsin");
$result = fbsql_query("SELECT * FROM onek;");
$fields = fbsql_num_fields($result);
$rows   = fbsql_num_rows($result);
$i = 0;
$table = fbsql_field_table($result, $i);
echo "La tabla '" . $table . "' tiene " . $fields . " campos y " . $rows . " registros <br />";
echo "La tabla tiene los siguientes campos: <br />";
while ($i < $fields) {
    $type  = fbsql_field_type($result, $i);
    $name  = fbsql_field_name($result, $i);
    $len   = fbsql_field_len($result, $i);
    $flags = fbsql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "<br />";
    $i++;
}
fbsql_close();

?>

Ver también

  • fbsql_field_name() - Obtiene el nombre de un campo especificado en un resultado


Libera la memoria de resultados

  • « fbsql_field_type
  • fbsql_get_autostart_info »
  • PHP Manual
  • Funciones de FrontBase
  • Libera la memoria de resultados

fbsql_free_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_free_result — Libera la memoria de resultados

Descripción

fbsql_free_result ( resource $result ) : bool

Libera toda la memoria asociada al identificador de result recibido como parámetro.

Solo es necesario llamar fbsql_free_result() si se está preocupado sobre cuánta memoria se está usando en consultas que devuelven result-sets grandes. Toda la memoria de resultado a asociada se libera de forma automática al final de la ejecución del script.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Descripción

  • « fbsql_free_result
  • fbsql_hostname »
  • PHP Manual
  • Funciones de FrontBase
  • Descripción

fbsql_get_autostart_info

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0)

fbsql_get_autostart_info —

Descripción

fbsql_get_autostart_info ( resource $link_identifier = ? ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.


Obtiene o establece el nombre host de una conexión

  • « fbsql_get_autostart_info
  • fbsql_insert_id »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene o establece el nombre host de una conexión

fbsql_hostname

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_hostname — Obtiene o establece el nombre host de una conexión

Descripción

fbsql_hostname ( resource $link_identifier , string $host_name = ? ) : string

Obtiene o establece el nombre host de una conexión.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

host_name

Si se recibe, se establecerá como nuevo nombre de host de la conexión.

Valores devueltos

Devuelve el nombre de host actual de la conexión.

Ver también

  • fbsql_username() - Obtiene o asigna el nombre de usuario de la conexión
  • fbsql_password() - Obtiene o asigna el password usado en una conexión


Obtiene el valor id generado por la anterior operación INSERT

  • « fbsql_hostname
  • fbsql_list_dbs »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el valor id generado por la anterior operación INSERT

fbsql_insert_id

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_insert_id — Obtiene el valor id generado por la anterior operación INSERT

Descripción

fbsql_insert_id ( resource $link_identifier = ? ) : int

Obtiene el id generado por la anterior operación INSERT que haya creado un valor DEFAULT UNIQUE.

Nota:

El valor de la función SQL FrontBase fbsql_insert_id() siempre contiene el valor DEFAULT UNIQUE generado más recientemente, y no se reinicia entre consultas.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve el ID generado por la anterior consulta INSERT, o 0 si la consulta anterior no generó un valor DEFAULT UNIQUE.

Si se necesita guardar el valor para después, hay que asegurarse de llamar a esta función inmediatamente después de que la consulta que genera el valor.

Ver también

  • fbsql_affected_rows() - Obtiene el numero de filas afectadas en la anterior operación de FrontBase


Lista las bases de datos disponibles en un servidor FrontBase

  • « fbsql_insert_id
  • fbsql_list_fields »
  • PHP Manual
  • Funciones de FrontBase
  • Lista las bases de datos disponibles en un servidor FrontBase

fbsql_list_dbs

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_dbs — Lista las bases de datos disponibles en un servidor FrontBase

Descripción

fbsql_list_dbs ( resource $link_identifier = ? ) : resource

Devuelve un puntero a resultado, conteniendo las bases de datos disponibles en el daemon fbsql. Use la función fbsql_tablename() para recorrer este puntero a resultado.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un puntero a resultado, false si hay error.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_list_dbs()

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

database1
database2
database3
...

Nota:

El código anterior podría funcionar fácilmente con fbsql_fetch_row() u otras funciones similares.

Ver también

  • fbsql_list_fields() - Lista los campos de un resultado de FrontBase
  • fbsql_list_tables() - Lista las tablas de una base de datos FrontBase


Lista los campos de un resultado de FrontBase

  • « fbsql_list_dbs
  • fbsql_list_tables »
  • PHP Manual
  • Funciones de FrontBase
  • Lista los campos de un resultado de FrontBase

fbsql_list_fields

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_fields — Lista los campos de un resultado de FrontBase

Descripción

fbsql_list_fields ( string $database_name , string $table_name , resource $link_identifier = ? ) : resource

Obtiene información acerca de la tabla especificada.

Parámetros

database_name

El nombre de la base de datos.

table_name

El nombre de la tabla.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un puntero a resultado que puede usarse con las funciones fbsql_field_xxx , o false si hay error.

Errores/Excepciones

Una cadena con la descripción del error se pondrá en $phperrmsg, y a menos que la función fuese llamada con @fbsql() , esta cadena de error también será mostrada.

Ejemplos

Ejemplo #1 fbsql_list_fields() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}
?>

El resultado del ejemplo sería algo similar a:

field1
field2
field3
...

Ver también

  • fbsql_field_len() - Devuleve la longitud de un campo especificado
  • fbsql_field_name() - Obtiene el nombre de un campo especificado en un resultado
  • fbsql_field_type() - Obtiene el tipo de campo especificado en un resultado
  • fbsql_field_flags() - Obtiene los flags de un campo especificado en un resultado


Lista las tablas de una base de datos FrontBase

  • « fbsql_list_fields
  • fbsql_next_result »
  • PHP Manual
  • Funciones de FrontBase
  • Lista las tablas de una base de datos FrontBase

fbsql_list_tables

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_tables — Lista las tablas de una base de datos FrontBase

Descripción

fbsql_list_tables ( string $database , resource $link_identifier = ? ) : resource

Returns a result pointer describing the database.

Parámetros

database

El nombre de la base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve un puntero a resultado que puede usarse con la función fbsql_tablename() para leer los nombres de las tablas, o false si hay error.

Ver también

  • fbsql_list_fields() - Lista los campos de un resultado de FrontBase
  • fbsql_list_dbs() - Lista las bases de datos disponibles en un servidor FrontBase


Mover el puntero del resultado interno por el resultado de al lado

  • « fbsql_list_tables
  • fbsql_num_fields »
  • PHP Manual
  • Funciones de FrontBase
  • Mover el puntero del resultado interno por el resultado de al lado

fbsql_next_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_next_result — Mover el puntero del resultado interno por el resultado de al lado

Descripción

fbsql_next_result ( resource $result ) : bool

Al enviar más de una instrucción SQL a el servidor o ejecutar un procedimiento almacenado con varios resultados hará que el servidor retorne varios conjuntos de resultados. Esta función pondrá a prueba para obtener resultados adicionales disponible en el servidor. Si un conjunto de resultados adicionales que existe el resultado conjunto existente y prepararse para ir a buscar las palabras del nuevo conjunto de resultados.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Retorna true si un conjunto de resultados esta disponible o false de otro modo.

Ejemplos

Ejemplo #1 fbsql_next_result() ejemplo

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret");
fbsql_select_db("MyDB", $link);
$SQL = "Select * from table1; select * from table2;";
$rs = fbsql_query($SQL, $link);
do {
    while ($row = fbsql_fetch_row($rs)) {
    }
} while (fbsql_next_result($rs));
fbsql_free_result($rs);
fbsql_close($link);
?>


Obtener el número de campos del resultado

  • « fbsql_next_result
  • fbsql_num_rows »
  • PHP Manual
  • Funciones de FrontBase
  • Obtener el número de campos del resultado

fbsql_num_fields

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_num_fields — Obtener el número de campos del resultado

Descripción

fbsql_num_fields ( resource $result ) : int

Devuelve el número de campos del result set dado.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve el número de campos, como entero.

Ver también

  • fbsql_db_query() - Ejecuta una consulta a FrontBase
  • fbsql_query() - Realiza una consulta FrontBase
  • fbsql_fetch_field() - Obtiene información de columnas de un resultado y la devuelve como objeto
  • fbsql_num_rows() - Obtener el número de filas del resultado


Obtener el número de filas del resultado

  • « fbsql_num_fields
  • fbsql_password »
  • PHP Manual
  • Funciones de FrontBase
  • Obtener el número de filas del resultado

fbsql_num_rows

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_num_rows — Obtener el número de filas del resultado

Descripción

fbsql_num_rows ( resource $result ) : int

Obtiene el número de filas del result set dado.

Esta función solo es válida para SELECTs. Para obtener el número de filas devueltas por una consulta del tipo INSERT, UPDATE o DELETE, use fbsql_affected_rows().

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve el número de filas devueltas por el último SELECT.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_num_rows()

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Filas\n";

?>

Ver también

  • fbsql_affected_rows() - Obtiene el numero de filas afectadas en la anterior operación de FrontBase
  • fbsql_connect() - Abre una conexión a un servidor FrontBase
  • fbsql_select_db() - Selecciona una base de datos FrontBase
  • fbsql_query() - Realiza una consulta FrontBase


Obtiene o asigna el password usado en una conexión

  • « fbsql_num_rows
  • fbsql_pconnect »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene o asigna el password usado en una conexión

fbsql_password

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_password — Obtiene o asigna el password usado en una conexión

Descripción

fbsql_password ( resource $link_identifier , string $password = ? ) : string

Obtiene o asigna el password usado en una conexión.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

password

Si se recibe, se asignará como password para la conexión.

Valores devueltos

Devuelve el password usado actualmente en la conexión.

Ver también

  • fbsql_username() - Obtiene o asigna el nombre de usuario de la conexión
  • fbsql_hostname() - Obtiene o establece el nombre host de una conexión


Abrir una conexión persistente a un servidor FrontBase

  • « fbsql_password
  • fbsql_query »
  • PHP Manual
  • Funciones de FrontBase
  • Abrir una conexión persistente a un servidor FrontBase

fbsql_pconnect

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_pconnect — Abrir una conexión persistente a un servidor FrontBase

Descripción

fbsql_pconnect
 ( string $hostname = ini_get("fbsql.default_host")
, string $username = ini_get("fbsql.default_user")
, string $password = ini_get("fbsql.default_password")
) : resource

Establece una conexión persisten a un servidor FrontBase.

Para definir el número de puerto, use fbsql_select_db().

fbsql_pconnect() funciona de forma similar a fbsql_connect() con dos grandes diferencias:

Primero, al conectarse, la función tratará de encontrar un enlace (persistente) que ya esté abierto con el mismo host, usuario y contraseña. Si se encuentra uno, se devolverá un identificador en lugar de abrir una nueva conexión.

Segundo, la conexión con el servidor SQL no se cerrará al finalizar la ejecución del script. En su lugar, el enlace permanecerá abierto para su futuro uso.

Por esta razón este tipo de enlaces es llamado 'persistente'.

Parámetros

hostname

Nombre del servidor.

username

El nombre de usuario para la conexión.

password

El password para la conexión.

Valores devueltos

Devuelve un enlace persistente positivo FrontBase en caso de éxito, o false en caso de error.

Ver también

  • fbsql_connect() - Abre una conexión a un servidor FrontBase


Realiza una consulta FrontBase

  • « fbsql_pconnect
  • fbsql_read_blob »
  • PHP Manual
  • Funciones de FrontBase
  • Realiza una consulta FrontBase

fbsql_query

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_query — Realiza una consulta FrontBase

Descripción

fbsql_query ( string $query , resource $link_identifier = ? , int $batch_size = ? ) : resource

Envia la query a la base de datos activa en el servidor.

Si la consulta tiene éxito, se puede llamar fbsql_num_rows() para saber cuantas filas se devolvieron para una instrucción SELECT, o fbsql_affected_rows() para saber cuantas filas se vieron afectadas por una instrucción DELETE, INSERT, REPLACE, o UPDATE.

Parámetros

query

La consulta SQL a ejecutar.

Nota:

La cadena de consulta debe acabar siempre con punto y coma.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

batch_size

Valores devueltos

fbsql_query() devuelve true (non-zero) o false para indicar si la consulta tuvo éxito. Un valor devuelto true implica que la consulta significa que la consulta es lícita y podría ser ejecutada por el servidor. No indica nada acerca del número de filas afectadas o devueltas. Es perfectamente posible que una consulta tenga éxito pero no devuelva o afecte ninguna fila.

Para instrucciones SELECT, fbsql_query() devuelve un nuevo identificador de resultado que se puede pasar a fbsql_result().

fbsql_query() también fallará y devolverá false si no se tiene permiso para acceder a la(s) tabla(s) referidas por la consulta.

Ejemplos

La siguiente consulta es sintácticamente inválida, así que fbsql_query() falla y devuelve false:

Ejemplo #1 Ejemplo fbsql_query()

<?php
$result = fbsql_query("SELECT * WHERE 1=1")
    or die ("Consulta inválida");
?>

La siguiente consulta es semánticamente inválida si my_col no es una columna de la tabla my_tbl, así que fbsql_query() falla y devuelve false:

Ejemplo #2 Ejemplo fbsql_query()

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl;")
    or die ("Consulta inválida");
?>

Ver también

  • fbsql_affected_rows() - Obtiene el numero de filas afectadas en la anterior operación de FrontBase
  • fbsql_db_query() - Ejecuta una consulta a FrontBase
  • fbsql_free_result() - Libera la memoria de resultados
  • fbsql_result() - Obtiene los datos de resultado
  • fbsql_select_db() - Selecciona una base de datos FrontBase
  • fbsql_connect() - Abre una conexión a un servidor FrontBase


Lee un BLOB de la base de datos

  • « fbsql_query
  • fbsql_read_clob »
  • PHP Manual
  • Funciones de FrontBase
  • Lee un BLOB de la base de datos

fbsql_read_blob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_read_blob — Lee un BLOB de la base de datos

Descripción

fbsql_read_blob ( string $blob_handle , resource $link_identifier = ? ) : string

Lee datos BLOB de la base de datos.

Si la consulta SELECT contiene columnas BLOB y/o CLOB, Frontbase los devolverá directamente cuando se recuperen los datos. Este funcionamiento por defecto puede cambiarse con fbsql_set_lob_mode() para que las funciones de recuperación devuelvan handles a los datos BLOB y CLOB. Si se recupera un handle, se deberá llamar a fbsql_read_blob() para obtener los datos BLOB de la base de datos.

Parámetros

blob_handle

Un handle BLOB, devuelto por fbsql_create_blob().

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve una cadena conteniendo los datos BLOB especificados.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_read_blob()

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se pudo conectar");
$sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] contendrá ahora los datos BLOB de la primera fila
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] contiene ahora un handle a los datos BLOB de la primera fila
$blob_data = fbsql_read_blob($row_data[0]);
fbsql_free_result($rs);

?>

Ver también

  • fbsql_create_blob() - Crea un BLOB
  • fbsql_read_clob() - Lee un CLOB de la base de datos
  • fbsql_set_lob_mode() - Asigna el modo de recuperación LOB para un set de resultados FrontBase


Lee un CLOB de la base de datos

  • « fbsql_read_blob
  • fbsql_result »
  • PHP Manual
  • Funciones de FrontBase
  • Lee un CLOB de la base de datos

fbsql_read_clob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_read_clob — Lee un CLOB de la base de datos

Descripción

fbsql_read_clob ( string $clob_handle , resource $link_identifier = ? ) : string

Lee datos CLOB de la base de datos.

Si la consulta SELECT contiene columnas BLOB y/o CLOB, Frontbase los devolverá directamente cuando se recuperen los datos. Este funcionamiento por defecto puede cambiarse con fbsql_set_lob_mode() para que las funciones de recuperación devuelvan handles a los datos BLOB y CLOB. Si se recupera un handle, se deberá llamar a fbsql_read_clob() para obtener los datos CLOB de la base de datos.

Parámetros

clob_handle

Un handle CLOB, devuelto por fbsql_create_clob().

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve una cadena conteniendo los datos CLOB especificados.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_read_clob()

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("No se pudo conectar");
$sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] contendrá ahora los datos CLOB de la primera fila
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] contiene ahora un handle a los datos CLOB de la primera fila
$clob_data = fbsql_read_clob($row_data[0]);
fbsql_free_result($rs);

?>

Ver también

  • fbsql_create_clob() - Crea un CLOB
  • fbsql_read_blob() - Lee un BLOB de la base de datos
  • fbsql_set_lob_mode() - Asigna el modo de recuperación LOB para un set de resultados FrontBase


Obtiene los datos de resultado

  • « fbsql_read_clob
  • fbsql_rollback »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene los datos de resultado

fbsql_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_result — Obtiene los datos de resultado

Descripción

fbsql_result ( resource $result , int $row = ? , mixed $field = ? ) : mixed

Devuelve el contenido de una celda de un set de result FrontBase .

Si se trabaja con sets de resultados grandes, se debería considerar usar una de las funciones que obtienen una fila completa (especificadas más abajo). Como estas funciones devuelve los contenidos de múltiples celdas en una sola llamada, son MUCHO más rápidas que fbsql_result().

Las llamadas a fbsql_result() no deberían mezclarse con llamadas a otras funciones que trabajan con el set de resultados.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

row

field

Puede ser la posición o el nombre del campo, o el nombre de la tabla punto nombre del campo (nombredetabla.nombredelcampo).

Si se ha creado un alias para la columna ('select foo as bar from...'), use el alias en lugar del nombre de la columna.

Nota:

Especificar una posición numérica como argumento es mucho más rápido que especificando un argumento como nombre de campo o nombredetabla.nombredecampo.

Valores devueltos

Ver también

Alternativas de alto rendimiento:

  • fbsql_fetch_row() - Obtiene una fila de resultados como array enumerado
  • fbsql_fetch_array() - Obtiene una fila de resultados como array asociativo, array numérico, o ambos
  • fbsql_fetch_assoc() - Obtiene una fila de resultados como array asociativo
  • fbsql_fetch_object() - Obtiene una fila de resultados como objeto


Retrocede una transacción a la base de datos

  • « fbsql_result
  • fbsql_rows_fetched »
  • PHP Manual
  • Funciones de FrontBase
  • Retrocede una transacción a la base de datos

fbsql_rollback

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_rollback — Retrocede una transacción a la base de datos

Descripción

fbsql_rollback ( resource $link_identifier = ? ) : bool

Finaliza la transacción actual retrocediendo todas las sentencias emitidas desde el último commit.

Este comando solo se necesita si autocommit está asignado a false.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_autocommit() - Activa o desactiva el autocommit
  • fbsql_commit() - Ejecuta un commit de la transacción sobre la base de datos


Obtiene el número de filas afectadas por la última consulta

  • « fbsql_rollback
  • fbsql_select_db »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el número de filas afectadas por la última consulta

fbsql_rows_fetched

(PHP 5 >= 5.1.0 < 5.3.0)

fbsql_rows_fetched — Obtiene el número de filas afectadas por la última consulta

Descripción

fbsql_rows_fetched ( resource $result ) : int

Obtiene el número de filas afectadas por la última consulta.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

Valores devueltos

Devuelve el número de filas, como entero.


Selecciona una base de datos FrontBase

  • « fbsql_rows_fetched
  • fbsql_set_characterset »
  • PHP Manual
  • Funciones de FrontBase
  • Selecciona una base de datos FrontBase

fbsql_select_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_select_db — Selecciona una base de datos FrontBase

Descripción

fbsql_select_db ( string $database_name = ? , resource $link_identifier = ? ) : bool

Asigna la base de datos activa para el identificador de enlace especificado.

El cliente contacta con FBExec para obtener el puerto a usar con la conexión a la base de datos. Si en el nombre de la base de datos se especifica un número, este se usará como puerto y no se consultará FBExec para obtener el puerto. El servidor FrontBase server puede iniciarse como FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

Parámetros

database_name

El nombre de la base de datos a seleccionar.

Si la base de datos está protegida con contraseña, se tendrá que llamar a fbsql_database_password() antes de seleccionar esta base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_connect() - Abre una conexión a un servidor FrontBase
  • fbsql_pconnect() - Abrir una conexión persistente a un servidor FrontBase
  • fbsql_database_password() - Asigna o recupera el password de una base de datos FrontBase
  • fbsql_query() - Realiza una consulta FrontBase


Cambia el juego de caracteres de entrada/salida

  • « fbsql_select_db
  • fbsql_set_lob_mode »
  • PHP Manual
  • Funciones de FrontBase
  • Cambia el juego de caracteres de entrada/salida

fbsql_set_characterset

(PHP 5 >= 5.1.0 < 5.3.0)

fbsql_set_characterset — Cambia el juego de caracteres de entrada/salida

Descripción

fbsql_set_characterset ( resource $link_identifier , int $characterset , int $in_out_both = ? ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

No devuelve ningún valor.


Asigna el modo de recuperación LOB para un set de resultados FrontBase

  • « fbsql_set_characterset
  • fbsql_set_password »
  • PHP Manual
  • Funciones de FrontBase
  • Asigna el modo de recuperación LOB para un set de resultados FrontBase

fbsql_set_lob_mode

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_set_lob_mode — Asigna el modo de recuperación LOB para un set de resultados FrontBase

Descripción

fbsql_set_lob_mode ( resource $result , int $lob_mode ) : bool

Asigna el modo para la recuperación de datos LOB de una base de datos.

Cuando se recuperan datos BLOB y CLOB en FrontBase puede hacerse de forma directa o indirecta. Los datos LOB recuperados directamente se recuperarán siempre sin importar la configuración del modo lob. Si los datos LOB son menores de 512 bytes siempre se recuperarán de forma directa.

Parámetros

result

Un identificador de resultado devuelto por fbsql_query() o fbsql_db_query().

lob_mode

Can be one of:

  • FBSQL_LOB_DIRECT - Los datos LOB se recuperan directamente. Cuando se obtienen datos de una base de datos con fbsql_fetch_row(), y otras funciones de obtención, todas las columnas CLOB y BLOB serán devueltas como columnas comunes. Este es el valor por defecto para cualquier nuevo resultado de FrontBase.
  • FBSQL_LOB_HANDLE - Los datos LOB se recuperan como handles a los datos. Cuando se obtienen datos de una base de datos con fbsql_fetch_row(), y otras funciones de obtención, los datos LOB se devolverán como un handle a los datos si los datos están almacenados indirectamente o los datos si están almacenados directamente. Si se devuelve un handle, será una cadena de a 27 bytes formateada como @'000000000000000000000000'.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_create_blob() - Crea un BLOB
  • fbsql_create_clob() - Crea un CLOB
  • fbsql_read_blob() - Lee un BLOB de la base de datos
  • fbsql_read_clob() - Lee un CLOB de la base de datos


Cambia la contraseña para el usuario especificado

  • « fbsql_set_lob_mode
  • fbsql_set_transaction »
  • PHP Manual
  • Funciones de FrontBase
  • Cambia la contraseña para el usuario especificado

fbsql_set_password

(PHP 5 < 5.3.0)

fbsql_set_password — Cambia la contraseña para el usuario especificado

Descripción

fbsql_set_password ( resource $link_identifier , string $user , string $password , string $old_password ) : bool

Cambia la contraseña para el user especificado.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

user

El nombre de usuario.

password

La nueva contraseña a asignar.

old_password

La antigua contraseña a sustituir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Asigna el bloqueo y aislamiento de la transacción

  • « fbsql_set_password
  • fbsql_start_db »
  • PHP Manual
  • Funciones de FrontBase
  • Asigna el bloqueo y aislamiento de la transacción

fbsql_set_transaction

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_set_transaction — Asigna el bloqueo y aislamiento de la transacción

Descripción

fbsql_set_transaction ( resource $link_identifier , int $locking , int $isolation ) : void

Asigna el locking y isolation de la transacción.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

locking

El tipo de bloqueo a establecer. Puede ser una de las siguientes constantes: FBSQL_LOCK_DEFERRED, FBSQL_LOCK_OPTIMISTIC, or FBSQL_LOCK_PESSIMISTIC.

isolation

El tipo de aislamiento a establecer. Puede ser una de las siguientes constantes: FBSQL_ISO_READ_UNCOMMITTED, FBSQL_ISO_READ_COMMITTED, FBSQL_ISO_REPEATABLE_READ, FBSQL_ISO_SERIALIZABLE, or FBSQL_ISO_VERSIONED.

Valores devueltos

No devuelve ningún valor.


Inicia una base de datos en un servidor local o remoto

  • « fbsql_set_transaction
  • fbsql_stop_db »
  • PHP Manual
  • Funciones de FrontBase
  • Inicia una base de datos en un servidor local o remoto

fbsql_start_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_start_db — Inicia una base de datos en un servidor local o remoto

Descripción

fbsql_start_db ( string $database_name , resource $link_identifier = ? , string $database_options = ? ) : bool

Inicia la base de datos en un servidor local o remoto.

Parámetros

database_name

El nombre de la base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

database_options

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_db_status() - Obtiene el estado de una base de datos dada
  • fbsql_stop_db() - Detiene una base de datos en un servidor local o remoto


Detiene una base de datos en un servidor local o remoto

  • « fbsql_start_db
  • fbsql_table_name »
  • PHP Manual
  • Funciones de FrontBase
  • Detiene una base de datos en un servidor local o remoto

fbsql_stop_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_stop_db — Detiene una base de datos en un servidor local o remoto

Descripción

fbsql_stop_db ( string $database_name , resource $link_identifier = ? ) : bool

Detiene una base de datos en un servidor local o remoto.

Parámetros

database_name

El nombre de la base de datos.

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fbsql_db_status() - Obtiene el estado de una base de datos dada
  • fbsql_start_db() - Inicia una base de datos en un servidor local o remoto


Obtiene el nombre de una tabla

  • « fbsql_stop_db
  • fbsql_tablename »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene el nombre de una tabla

fbsql_table_name

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_table_name — Obtiene el nombre de una tabla

Descripción

fbsql_table_name ( resource $result , int $index ) : string

fbsql_table_name() obtiene el nombre de la tabla actual para el result set especificado.

La función fbsql_num_rows() puede usarse para determinar el número de tablas en el puntero a resultado.

Parámetros

result

Un puntero a resultado devuelto por fbsql_list_tables().

index

Un integer indicando el índice de la tabla actual.

Valores devueltos

Devuelve el nombre de la tabla, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de fbsql_table_name()

<?php
fbsql_connect("localhost", "_SYSTEM", "");
$result = fbsql_list_tables("wisconsin");
$i = 0;
while ($i < fbsql_num_rows($result)) {
    $tb_names[$i] = fbsql_table_name($result, $i);
    echo $tb_names[$i] . "<br />";
    $i++;
}
?>


Alias de fbsql_table_name

  • « fbsql_table_name
  • fbsql_username »
  • PHP Manual
  • Funciones de FrontBase
  • Alias de fbsql_table_name

fbsql_tablename

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_tablename — Alias de fbsql_table_name()

Descripción

Esta función es un alias de: fbsql_table_name().


Obtiene o asigna el nombre de usuario de la conexión

  • « fbsql_tablename
  • fbsql_warnings »
  • PHP Manual
  • Funciones de FrontBase
  • Obtiene o asigna el nombre de usuario de la conexión

fbsql_username

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_username — Obtiene o asigna el nombre de usuario de la conexión

Descripción

fbsql_username ( resource $link_identifier , string $username = ? ) : string

Obtiene o asigna el nombre de usuario usado en la conexión.

Parámetros

link_identifier

Un identificador de enlace FrontBase devuelto por fbsql_connect() o fbsql_pconnect().

Es opcional y si no se especifica, la función intentará encontrar un enlace abierto al servidor FrontBase y de no encontrarse ningún enlace abierto intentará crear uno como si fbsql_connect() fuese invocada sin parámetros.

username

Si se recibe, el nuevo nombre de usuario que se asignará.

Valores devueltos

Devuelve el nombre de usuario usado actualmente en la conexión, como cadena.

Ver también

  • fbsql_password() - Obtiene o asigna el password usado en una conexión
  • fbsql_hostname() - Obtiene o establece el nombre host de una conexión


Activa o desactiva los warnings de FrontBase

  • « fbsql_username
  • IBM DB2 »
  • PHP Manual
  • Funciones de FrontBase
  • Activa o desactiva los warnings de FrontBase

fbsql_warnings

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_warnings — Activa o desactiva los warnings de FrontBase

Descripción

fbsql_warnings ( bool $OnOff = ? ) : bool

Activa o desactiva los warnings de FrontBase.

Parámetros

OnOff

Activar o desactivar los warnings.

Valores devueltos

Devuelve true si los warnings están activados, o false en caso contrario.

Ver también

  • fbsql_errno() - Devuelve el número de error de la última operación
  • fbsql_error() - Devuelve el mensaje de error de la última operación


IBM DB2, Cloudscape y Apache Derby

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de IBM DB2
    • db2_autocommit — Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos
    • db2_bind_param — Vincula una variable PHP a un parámetro de una sentencia SQL
    • db2_client_info — Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2
    • db2_close — Cierra una conexión a base de datos
    • db2_column_privileges — Obtiene la lista de columnas y permisos asociados a una tabla
    • db2_columns — Devuelve los campos de una tabla y sus metadatos asociados.
    • db2_commit — Confirmar una transacción
    • db2_conn_error — Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
    • db2_conn_errormsg — Devolver el último mensaje de error de la conexión y su valor SQLCODE
    • db2_connect — Devolver una conexión a la base de datos
    • db2_cursor_type — Determinar el tipo de cursor utilizado en una consulta
    • db2_escape_string — Escapar ciertos caracteres especiales
    • db2_exec — Ejecutar directamente una sentencia SQL
    • db2_execute — Ejecutar una sentencia SQL preparada
    • db2_fetch_array — Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
    • db2_fetch_assoc — Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
    • db2_fetch_both — Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
    • db2_fetch_object — Devolver un objeto con atributos que representan a las columnas de una fila extraida
    • db2_fetch_row — Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
    • db2_field_display_size — Devolver el número máximo de bytes requeridos para mostrar una columna
    • db2_field_name — Devolver el nombre de la columna indicada del resultado
    • db2_field_num — Devolver la posición de la columna indicada en un resultado
    • db2_field_precision — Devolver la precisión de la columna indicada en el resultado
    • db2_field_scale — Devolver la escala de la columna indicada en el resultado
    • db2_field_type — Devolver el tipo de dato de la columna indicada en un resultado
    • db2_field_width — Devolver el tamaño del valor contenido en la columna indicada
    • db2_foreign_keys — Devolver un resultado que contenga las llaves foraneas de una tabla
    • db2_free_result — Liberar los recursos asociados con un resultado
    • db2_free_stmt — Liberar un recurso indicado
    • db2_get_option — Devolver el valor de la opción correpondiente a una conexión o sentencia
    • db2_last_insert_id — Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión
    • db2_lob_read — Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB
    • db2_next_result — Solicitar el siguiente resultado de un procedimiento almacendo
    • db2_num_fields — Devolver el número de campos que contiene un resultado
    • db2_num_rows — Devolver el número de filas afectadas por una sentencia SQL
    • db2_pclose — Cerrar una conexión persistente a la base de datos
    • db2_pconnect — Devolver una conexión persistente a la base de datos
    • db2_prepare — Prepara un comando SQL para su ejecución
    • db2_primary_keys — Devolver un resultado con las llaves primarias de una tabla
    • db2_procedure_columns — Devolver un resultado con los parámetros de los procedimientos almacenados
    • db2_procedures — Devolver un resultado con los procedimientos almacenados registrados en la base de datos
    • db2_result — Devolver una columna específica del resultado
    • db2_rollback — Cancelar una transacción
    • db2_server_info — Returns an object with properties that describe the DB2 database server
    • db2_set_option — Set options for connection or statement resources
    • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
    • db2_statistics — Returns a result set listing the index and statistics for a table
    • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
    • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
    • db2_tables — Returns a result set listing the tables and associated metadata in a database


Introducción

Estas funciones permiten acceder a la Base de datos Universal IBM DB2, IBM Cloudscape y Apache Derby usando la interfaz DB2 Call Level (DB2 CLI).


Requerimientos

Para conectar a IBM DB2 Universal Database para Linux, Unix y Windows, o a IBM Cloudscape, o a Apache Derby, se debe instalar el cliente de IBM DB2 Universal Database en el mismo equipo en que se ejecuta PHP. Esta extensión se ha desarrollado y probado con DB2 Version 8.2.

Para conectar a IBM DB2 Universal Database en z/OS o iSeries, es necesario también IBM DB2 Connect o un software enrutador DRDA equivalente.

Requisitos en Linux y Unix

The user invoking the PHP executable or SAPI must specify the DB2 instance before accessing these functions. You can set the name of the DB2 instance in php.ini using the ibm_db2.instance_name configuration option, or you can source the DB2 instance profile before invoking the PHP executable.

If you created a DB2 instance named db2inst1 in /home/db2inst1/, for example, you can add the following line to php.ini:

ibm_db2.instance_name=db2inst1
If you do not set this option in php.ini, you must issue the following command to modify your environment variables to enable access to DB2:
bash$ source /home/db2inst1/sqllib/db2profile
To enable your PHP-enabled Web server to access these functions, you must either set the ibm_db2.instance_name configuration option in php.ini, or source the DB2 instance environment in your Web server start script (typically /etc/init.d/httpd or /etc/init.d/apache).


Instalación

Para construir la extensión ibm_db2, deben estar instaladas en el sistema tanto las cabeceras como las bibliotecas de desarrollo de aplicaciones DB2. DB2 no lo instala por omisión, por lo que se debe habilitar explícitamente en el instalador de DB2. Los ficheros de cabeceras vienen incluidos de forma gratuita en Cliente de Desarrollo de Aplicaciones DB2 de la » página de soporte de la Base de datos Universal IBM DB2.

Si se añadieran las cabeceras y bibliotecas de desarrollo de aplicaciones DB2 a un sistema Linux o Unix en el que DB2 ya estuviera instalado, será necesario ejecutar el comando db2iupdt -e para actualizar los enlaces simbólicos a las cabeceras y bibliotecas de la instancia DB2.

ibm_db2 es una extensión » PECL, por lo que se deben seguir las instrucciones de Instalación de extensiones PECL para instalar esta extensión en PHP. Debe ejecutarse el comando configure apuntando a la localización de las cabeceras y bibliotecas DB2 de la siguiente forma:

bash$ ./configure --with-IBM_DB2=/path/to/DB2
El comando configure apunta por omisión a /opt/IBM/db2/V8.1.

Nota: Nota para usuarios de IIS

Si desea usar el driver ibm_db2 con Microsoft Internet Information Server (IIS) es posible que sea necesario realizar los siguientes pasos:

  • Instalar DB2 con seguridad de sistema operativo extendidad
  • Añadir la ruta del binario PHP a la variable de entorno del sistema PATH (por omisión C:\php\).
  • Crear una nueva variable de entorno del sistema que contenga la ruta al fichero PHP.INI (por ejemplo: PHPRC = C:\php\).
  • Añadir IUSR_COMPUTERNAME al grupo DB2USERS.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de ibm_db2
Nombre | Por defecto | Cambiable | Registro de cambios
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.8.0.

He aquí una breve explicación de las directivas de configuración.

ibm_db2.binmode integer

Esta opción controla el modo que se usará para convertir desde y hasta datos binarios en la aplicación PHP.

  • 1 (DB2_BINARY)

  • 2 (DB2_CONVERT)

  • 3 (DB2_PASSTHRU)

ibm_db2.i5_all_pconnect integer

Esta opción sobrescribe la apertura y cierre i5 db2_connect() dentro de PHP. Cuando ibm_db2.i5_all_pconnect = 1, todas las conexiones de db2 serán persistentes (db2_pconnect()). En i5/OS, db2_pconnect() lo realiza significativamente mejor, empleando menos recurso de máquina que db2_connect(). Es un buen reemplazo de db2_connect() para invocar db2_pconnect() sin modificaciones del código fuente de PHP.

  • 0 db2_connect() apertura y cierre completo por omisión

  • 1 db2_connect() sobrescribe db2_pconnect() sólo en conexiones persistentes

ibm_db2.i5_allow_commit integer

Esta opción controla el modo de 'commit' (aplicar cambios) que se usa en conelciones de esquemas i5 en aplicaciones PHP.

  • 0 sin commit (vea i5_commit para sobrescribir)

  • 1 permite commit (vea i5_commit para sobrescribirlo)

ibm_db2.i5_dbcs_alloc integer

Esta opción controla la ubicación interna de esquemas ibm_db2 en buffers de columnas DBCS de gran tamaño.

  • 0 sin expandir su ubicación (vea i5_dbcs_alloc para sobrescribirlo)

  • 1 usa ubicaciones expandidas (vea i5_dbcs_alloc para sobrescribirlo)

ibm_db2.instance_name string

En sistemas Linux y Unix, esta opción declara el nombre de instancia que se utilizará para catalogar las conexiones a bases de datos. Si se estableciera un valor, sobrescribirá la variable de entorno DB2INSTANCE.

En sistemas operativos Windows, esta opción se ignora.

ibm_db2.i5_ignore_userid integer

Esta opción establece el id de usuario y la contraseña en i5 db2_(p)connect dentro de una aplicación PHP. Cuando ibm_db2.i5_ignore_userid = 1, todas las conexiones db2 establecen a null el id de usuario y la contraseña. De ese modo, las tareas de Apache usarán el perfil activo (NOBODY). Este perfil es útil sobre todo en páginas web sencillas basadas en DB2 que no necesiten cambiar perfiles, y por tanto se pueda evitar todo el consumo adicional del modo de servidor de tareas QSQSRVR adicionales. Es un remplazo conveiente de db2_(p)connect para asignar null en los valores de userid y password sin tener que modificar el fuente de PHP. Se puede usar junto con ibm_db2.i5_all_pconnect = 1.

  • 0 db2_(p)connect - conecta con el id de usuario y contraseña especificados

  • 1 db2_(p)connect - establece a null el id de usuario y contraseña de la conexión


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

La extensión ibm_db2 devuelve recursos de conexión, recursos de sentencias, y recursos de juegos de resultados.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

DB2_BINARY (integer)
Indica que los datos binarios se tienen que devolver tal cual. Este es el modo por omisión.
DB2_CONVERT (integer)
Indica que los datos binarios se tienen que codificar a hexadecimal y se devuelven en forma de string ASCII.
DB2_PASSTHRU (integer)
Indica que los datos binarios se tienen que convertir al valor null.
DB2_SCROLLABLE (integer)
Especifica un cursor trasladable en un recurso de tipo sentencia. Este modo permite acceder libremente a las filas de un juego de resultados, pero por ahora sólo está soportado por la Base de datos Universal IBM DB2.
DB2_FORWARD_ONLY (integer)
Especifica un cursor de sólo avance en un recurso de tipo sentencia. Este es el tipo de cursor por omisión y está soportado por todas las bases de datos.
DB2_PARAM_IN (integer)
Indifica que la variable PHP se utilizará como parámetro IN en los procedimientos almacenados.
DB2_PARAM_OUT (integer)
Especifica que la variable PHP se utilizará como parámetro OUT en los procedimientos almacenados.
DB2_PARAM_INOUT (integer)
Especifica que la variable PHP se utilizará como parámetro INOUT en los procedimientos almacenados.
DB2_PARAM_FILE (integer)
Indica que la columna debe vincularse directamente a un fichero de entrada.
DB2_AUTOCOMMIT_ON (integer)
Indica que se debe habilitar la opción autocommit (Realizar cambios inmediatamente).
DB2_AUTOCOMMIT_OFF (integer)
Indica que se debe deshabilitar la opción autocommit (No se realizan los cambios inmediatamente).
DB2_DOUBLE (integer)
Indica que la variable se establecerá en forma de DOUBLE, FLOAT, o REAL.
DB2_LONG (integer)
Indica que la variable se establecerá en forma de SMALLINT, INTEGER, o BIGINT.
DB2_CHAR (integer)
Indica que la variable se establecerá en forma de CHAR o VARCHAR.
DB2_CASE_NATURAL (integer)
Especifica que los nombres de columnas se devolverán respetando mayúsculas y minúsculas.
DB2_CASE_LOWER (integer)
Indica que los nombres de las columnas se devolverán en minúsculas.
DB2_CASE_UPPER (integer)
Indica que los nombres de las columnas se devolverán en mayúsculas.
DB2_DEFERRED_PREPARE_ON (integer)
Habilita las sentencias preparadas en el recurso especificado.
DB2_DEFERRED_PREPARE_OFF (integer)
Deshabilita las sentencias preparadas en el recurso especificado.


Funciones de IBM DB2

Tabla de contenidos

  • db2_autocommit — Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos
  • db2_bind_param — Vincula una variable PHP a un parámetro de una sentencia SQL
  • db2_client_info — Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2
  • db2_close — Cierra una conexión a base de datos
  • db2_column_privileges — Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns — Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_commit — Confirmar una transacción
  • db2_conn_error — Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
  • db2_conn_errormsg — Devolver el último mensaje de error de la conexión y su valor SQLCODE
  • db2_connect — Devolver una conexión a la base de datos
  • db2_cursor_type — Determinar el tipo de cursor utilizado en una consulta
  • db2_escape_string — Escapar ciertos caracteres especiales
  • db2_exec — Ejecutar directamente una sentencia SQL
  • db2_execute — Ejecutar una sentencia SQL preparada
  • db2_fetch_array — Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc — Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both — Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_object — Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_fetch_row — Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_field_display_size — Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name — Devolver el nombre de la columna indicada del resultado
  • db2_field_num — Devolver la posición de la columna indicada en un resultado
  • db2_field_precision — Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale — Devolver la escala de la columna indicada en el resultado
  • db2_field_type — Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width — Devolver el tamaño del valor contenido en la columna indicada
  • db2_foreign_keys — Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_free_result — Liberar los recursos asociados con un resultado
  • db2_free_stmt — Liberar un recurso indicado
  • db2_get_option — Devolver el valor de la opción correpondiente a una conexión o sentencia
  • db2_last_insert_id — Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión
  • db2_lob_read — Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB
  • db2_next_result — Solicitar el siguiente resultado de un procedimiento almacendo
  • db2_num_fields — Devolver el número de campos que contiene un resultado
  • db2_num_rows — Devolver el número de filas afectadas por una sentencia SQL
  • db2_pclose — Cerrar una conexión persistente a la base de datos
  • db2_pconnect — Devolver una conexión persistente a la base de datos
  • db2_prepare — Prepara un comando SQL para su ejecución
  • db2_primary_keys — Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns — Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures — Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_result — Devolver una columna específica del resultado
  • db2_rollback — Cancelar una transacción
  • db2_server_info — Returns an object with properties that describe the DB2 database server
  • db2_set_option — Set options for connection or statement resources
  • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
  • db2_statistics — Returns a result set listing the index and statistics for a table
  • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
  • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
  • db2_tables — Returns a result set listing the tables and associated metadata in a database


Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos

  • « Funciones de IBM DB2
  • db2_bind_param »
  • PHP Manual
  • Funciones de IBM DB2
  • Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos

db2_autocommit

(PECL ibm_db2 >= 1.0.0)

db2_autocommit — Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos

Descripción

db2_autocommit ( resource $connection , bool $value = ? ) : mixed

Devuelve o establece el comportamiento de AUTOCOMMIT del recurso de conexión especificado.

Parámetros

connection

Variable válida de tipo recurso de conexión a base de datos, devuelta por db2_connect() o por db2_pconnect().

value

Una de las siguientes constantes:

DB2_AUTOCOMMIT_OFF

Desactiva AUTOCOMMIT.

DB2_AUTOCOMMIT_ON

Activa AUTOCOMMIT.

Valores devueltos

Cuando a db2_autocommit() sólo se le proporciona el parámetro connection, devuelve en forma de integer el valor actual de AUTOCOMMIT para la conexión solicitada. Un valor de 0 indica que AUTOCOMMIT está deshabilitado, mientras que un valor de 1 indica que AUTOCOMMIT está habibilitado.

Cuando db2_autocommit() recibe tanto el parámetro connection como autocommit, establece el valor correspondiente en el estado de AUTOCOMMIT de la conexión solicitada. Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Consultando el valor de AUTOCOMMIT de una conexión

En el siguiente ejemplo, se comprueba con la función db2_autocommit() una conexión creada con AUTOCOMMIT deshabilitado.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT está a off.";
} else {
    print "$ac -- AUTOCOMMIT está a on.";
}
?>

El resultado del ejemplo sería:

0 -- AUTOCOMMIT está a off.

Ejemplo #2 Asignando el valor de AUTOCOMMIT en una conexión

En el siguiente ejemplo, sobre una conexión inicialmente creada con AUTOCOMMIT dehasbilitado, se cambia su comportamiento a AUTOCOMMIT on.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);

// Activación de AUTOCOMMIT
$rc = db2_autocommit($conn, DB2_AUTOCOMMIT_ON);
if ($rc) {
    print "Activación de AUTOCOMMIT con éxito.\n";
}

// Comprobar estado de AUTOCOMMIT
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT está a off.";
} else {
    print "$ac -- AUTOCOMMIT está a on.";
}
?>

El resultado del ejemplo sería:

Activación de AUTOCOMMIT con éxito.
1 -- AUTOCOMMIT está a on.

Ver también

  • db2_connect() - Devolver una conexión a la base de datos
  • db2_pconnect() - Devolver una conexión persistente a la base de datos


Vincula una variable PHP a un parámetro de una sentencia SQL

  • « db2_autocommit
  • db2_client_info »
  • PHP Manual
  • Funciones de IBM DB2
  • Vincula una variable PHP a un parámetro de una sentencia SQL

db2_bind_param

(PECL ibm_db2 >= 1.0.0)

db2_bind_param — Vincula una variable PHP a un parámetro de una sentencia SQL

Descripción

db2_bind_param ( resource $stmt , int $parameter-number , string $variable-name , int $parameter-type = ? , int $data-type = 0 , int $precision = -1 , int $scale = 0 ) : bool

Vincula una variabel PHP a una sentencia SQL de un recurso devuelto por db2_prepare(). Esta función proporciona más control sobre el tipo de parámetro, tipo de dato, procesión, y escala del parámetro que cuando se pasa la variabel como parte del array de entrada opcional en db2_execute().

Parámetros

stmt

Sentencia preparada devuelta por db2_prepare().

parameter-number

Especifica la posición del parámetro en la sentencia preparada, utilizando 1 como primera posición.

variable-name

String con el nombre de la variabel PHP que se vinculará al parámetro especificado por parameter-number.

parameter-type

Constante que especifica si la variable PHP debe vincularse al parámetro SQL como un parámetro de entrada (DB2_PARAM_IN), de salida (DB2_PARAM_OUT), o como un parámetro que acepta entrada y salida (DB2_PARAM_INOUT). Para evitar fugas de memoria, puede especificarse DB2_PARAM_FILE para vincular la variable PHP al nombre de un fichero que contiene objetos de gran tamaño (BLOB, CLOB, o DBCLOB).

data-type

Constante que especifica el tipo de dato SQL de la variable PHP que se vincula: de entre DB2_BINARY, DB2_CHAR, DB2_DOUBLE, o DB2_LONG.

precision

Especifica la precisión con la que se debe vincular a la base de datos. Este parámetro se puede utilizar también para consultar valores de salida XML de procedimientos almacenados. Un valor no negativo especifica el tamaño máximo de datos XML que se consultarán de la base de datos. Si este parámetro no se utiliza, se asumirá por omisión 1MB para consultar el valor de salida XML del procedimiento almacenado.

scale

Especifica la escala de la variable que se vinculará a la base de datos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Vinculando variables PHP a sentencias preparadas

La sentencia SQL del siguiente ejemplo utiliza dos parámetros de entrada en la cláusula WHERE. Invocamos db2_bind_param() para vincular dos variables PHP a los correspondientes parámetros SQL. Debe tenerse en cuenta que no es necesario que se hayan declarado o asignado las variables PHP antes de llamar a db2_bind_param(); en el ejemplo, se asigna un valor a $lower_limit antes de llamar a db2_bind_param(), a diferencia de $upper_limit, donde el valor se asigna tras llamar a db2_bind_param(). Se deben vincular las variables y, para parámetros que acepten entradas, debe asignarse el valor antes de llamar a parameters that accept input, must have any value assigned, before calling db2_execute().

<?php

$sql = 'SELECT name, breed, weight FROM animals
    WHERE weight > ? AND weight < ?';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

// Podemos declarar la variable antes de llamar a db2_bind_param()
$lower_limit = 1;

db2_bind_param($stmt, 1, "lower_limit", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "upper_limit", DB2_PARAM_IN);

// Podemos declarar la variable tras llamar a db2_bind_param()
$upper_limit = 15.0;

if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
        print "{$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

El resultado del ejemplo sería:

Pook, cat, 3.2
Rickety Ride, goat, 9.7
Peaches, dog, 12.3

Ejemplo #2 Llamada a procedimientos almacenados con parámetros de Entrada y Salida

El procedimiento almacenado match_animal del siguiente ejemplo acepta tres parámetros:

  1. un parámetro (IN) de entrada que acepta el nombre del primer animal como entrada

  2. un parámetro (INOUT) de entrada-salida que acepta el nombre del segundo animal como entrada y devuelve el string TRUE si coincidiera algún animal de la base de datos

  3. un parámetro (OUT) de salida que devuelve la suma del peso de los dos animales identificados

Además, el procedimiento almacenado devuelve el juego de resultados que corresponde a la lista de animales en orden alfabética comenzando por el animal del valor de entrada del primer parámetro, y terminando en el animal correspondiente al valor de entrada del segundo parámetro.

<?php

$sql = 'CALL match_animal(?, ?, ?)';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

$name = "Peaches";
$second_name = "Rickety Ride";
$weight = 0;

db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "second_name", DB2_PARAM_INOUT);
db2_bind_param($stmt, 3, "weight", DB2_PARAM_OUT);

print "Valores de los parámetros vinculados _antes_ de la llamada:\n";
print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

if (db2_execute($stmt)) {
    print "Valores de los parámetros vinculados _tras_ la llamada:\n";
    print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

    print "Resultados:\n";
    while ($row = db2_fetch_array($stmt)) {
        print "  {$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

El resultado del ejemplo sería:

Valores de los parámetros vinculados _antes_ de la llamada:
  1: Peaches 2: Rickety Ride 3: 0

Valores de los parámetros vinculados _tras_ la llamada:
  1: Peaches 2: TRUE 3: 22

Resultados:
  Peaches, dog, 12.3
  Pook, cat, 3.2
  Rickety Ride, goat, 9.7

Ejemplo #3 Insertando un objeto extenso binario (BLOB) directamente desde un fichero

Los datos de objetos extensos se suelen almacenar en ficheros, como por ejemplo documentos XML o ficheros de audio. En lugar de guardar el fichero completo en una variable PHP, para después vincular ésta a una sentencia SQL, se puede evitar esta sobrecarga de memoria vinculando directamente el fichero al parámetro de entrada de la sentencia SQL. El siguiente ejemplo demuestra cómo vincular directamente un fichero a una columna BLOB.

<?php
$stmt = db2_prepare($conn, "INSERT INTO animal_pictures(picture) VALUES (?)");

$picture = "/opt/albums/spook/grooming.jpg";
$rc = db2_bind_param($stmt, 1, "picture", DB2_PARAM_FILE);
$rc = db2_execute($stmt);
?>

Ver también

  • db2_execute() - Ejecutar una sentencia SQL preparada
  • db2_prepare() - Prepara un comando SQL para su ejecución


Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2

  • « db2_bind_param
  • db2_close »
  • PHP Manual
  • Funciones de IBM DB2
  • Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2

db2_client_info

(PECL ibm_db2 >= 1.1.1)

db2_client_info — Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2

Descripción

db2_client_info ( resource $connection ) : object

Esta función devuelve un objeto, con propiedades de sólo lectura, con información sobre el cliente de base de datos DB2. La siguiente tabla lista las propiedades del cliente DB2:

DB2 client properties
Nombre de la propiedad | Tipo devuelto | Descripción
APPL_CODEPAGE | int | Código de página de la aplicación.
CONN_CODEPAGE | int | Código de página de la conexión activa.
DATA_SOURCE_NAME | string | Nombre fuente de datos (DSN) usado para crear la conexión actual a la base de datos.
DRIVER_NAME | string | Nombre de la biblioteca que implementa la especificación de la Interfaz a nivel de Llamada (CLI) de DB2.
DRIVER_ODBC_VER | string | Versión de ODBC que soporta el cliente DB2. Devuelve un string del tipo "MM.mm" donde MM es la versión principal y mm la secundaria. El cliente DB2 siempre devuelve "03.51".
DRIVER_VER | string | Versión del driver, en forma de string "MM.mm.uuuu" donde MM es la versión principal, mm es la versión secundaria, y uuuu la actualización. Por ejemplo, "08.02.0001" representa la versión principal 8, versión secundaria 2, actualización 1.
ODBC_SQL_CONFORMANCE string

Nivel de gramática SQL ODBC soportado por el cliente.

MINIMUM

Soporta la gramática mínima ODBC SQL.

CORE

Soporta la gramática de tipo core de ODBC SQL.

EXTENDED

Soporta la gramática extendida de ODBC SQL.

ODBC_VER | string | Versión de ODBC que soporta el gestor de drivers de ODBC. Devuelve un strong del tipo "MM.mm.rrrr" donde MM es la versión principal, mm es la versión secundaria, y rrrr es la edición. El cliente DB2 siempre devuelve "03.01.0000".

Parámetros

connection

Especifica una conexión de cliente DB2 activa.

Valores devueltos

Devuelve un objeto en caso de éxito. Devuelve false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de db2_client_info()

Para consultar información del cliente, se debe proporcionar un recurso de conexión a base de datos válido a db2_client_info().

<?php
$conn = db2_connect( 'SAMPLE', 'db2inst1', 'ibmdb2' );
$client = db2_client_info( $conn );

if ($client) {
    echo "DRIVER_NAME: ";           var_dump( $client->DRIVER_NAME );
    echo "DRIVER_VER: ";            var_dump( $client->DRIVER_VER );
    echo "DATA_SOURCE_NAME: ";      var_dump( $client->DATA_SOURCE_NAME );
    echo "DRIVER_ODBC_VER: ";       var_dump( $client->DRIVER_ODBC_VER );
    echo "ODBC_VER: ";              var_dump( $client->ODBC_VER );
    echo "ODBC_SQL_CONFORMANCE: ";  var_dump( $client->ODBC_SQL_CONFORMANCE );
    echo "APPL_CODEPAGE: ";         var_dump( $client->APPL_CODEPAGE );
    echo "CONN_CODEPAGE: ";         var_dump( $client->CONN_CODEPAGE );
}
else {
    echo "Error al consultar información del cliente.
     Es posible que la conexión a base de datos sea inválida.";
}
db2_close($conn);

?>

El resultado del ejemplo sería:

DRIVER_NAME: string(8) "libdb2.a"
DRIVER_VER: string(10) "08.02.0001"
DATA_SOURCE_NAME: string(6) "SAMPLE"
DRIVER_ODBC_VER: string(5) "03.51"
ODBC_VER: string(10) "03.01.0000"
ODBC_SQL_CONFORMANCE: string(8) "EXTENDED"
APPL_CODEPAGE: int(819)
CONN_CODEPAGE: int(819)

Ver también

  • db2_server_info() - Returns an object with properties that describe the DB2 database server


Cierra una conexión a base de datos

  • « db2_client_info
  • db2_column_privileges »
  • PHP Manual
  • Funciones de IBM DB2
  • Cierra una conexión a base de datos

db2_close

(PECL ibm_db2 >= 1.0.0)

db2_close — Cierra una conexión a base de datos

Descripción

db2_close ( resource $connection ) : bool

Esta función cierra una conexión cliente DB2 creada con db2_connect() y devuelve el recurso correspondiente al servidor de base de datos.

Si se tratara de cerrar una conexión de cliente DB2 persistente creada con db2_pconnect(), la petición de cierre se ignoraría y la conexión de cliente DB2 permanecería disponibel para la siguiente llmada.

Parámetros

connection

Especifica la conexión a cliente DB2 activa.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cierre de una conexión

El siguiente ejemplo demuestra un intento de cierre exitoso de una conexión a una base de datos IBM DB2, Cloudscape, o Apache Derby.

<?php
$conn = db2_connect('SAMPLE', 'db2inst1', 'ibmdb2');
$rc = db2_close($conn);
if ($rc) {
    echo "Conexión cerrada con éxito.";
}
?>

El resultado del ejemplo sería:

Conexión cerrada con éxito.

Ver también

  • db2_connect() - Devolver una conexión a la base de datos
  • db2_pclose() - Cerrar una conexión persistente a la base de datos
  • db2_pconnect() - Devolver una conexión persistente a la base de datos


Obtiene la lista de columnas y permisos asociados a una tabla

  • « db2_close
  • db2_columns »
  • PHP Manual
  • Funciones de IBM DB2
  • Obtiene la lista de columnas y permisos asociados a una tabla

db2_column_privileges

(PECL ibm_db2 >= 1.0.0)

db2_column_privileges — Obtiene la lista de columnas y permisos asociados a una tabla

Descripción

db2_column_privileges ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $column-name = ? ) : resource

Obtiene la lista de columnas y permisos asociados a una tabla.

Parámetros

connection

Una conexión a IBM DB2, Cloudscape, o Apache Derby.

qualifier

Un calificador para bases de datos DB2 que se ejecutan en servidores OS/390 o z/OS. Para otras bases de datos, use null o una cadena vacía.

schema

El esquema que contiene la tabla indicada. Para buscar en todos los esquemas, use null o una cadena vacía.

table-name

El nombre de la tabla o vista. Para consultar todas las tablas en la base de datos, use null o una cadena vacía.

column-name

El nombre de la columna. Para consultar todas las columnas en la tabla, use null o una cadena vacía.

Valores devueltos

Devuelve una lista de registros que describen los permisos de las columnas especificadas a través de los parámetros entregados a la función. Los registros contienen los siguientes campos:

Columna | Descripción
TABLE_CAT | Nombre del catálogo. Puede ser null si esta tabla no tiene catálogo.
TABLE_SCHEM | Nombre del esquema.
TABLE_NAME | Nombre de la tabla o vista.
COLUMN_NAME | Nombre de la columna.
GRANTOR | Identificador del usuario que otorgó el permiso.
GRANTEE | Identificador del usuario a quien se le dió el permiso.
PRIVILEGE | Permisos de la columna.
IS_GRANTABLE | Informa si el usuario que obtiene el permiso puede otorgárselo a otros usuarios.

Ver también

  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Devuelve los campos de una tabla y sus metadatos asociados.

  • « db2_column_privileges
  • db2_commit »
  • PHP Manual
  • Funciones de IBM DB2
  • Devuelve los campos de una tabla y sus metadatos asociados.

db2_columns

(PECL ibm_db2 >= 1.0.0)

db2_columns — Devuelve los campos de una tabla y sus metadatos asociados.

Descripción

db2_columns ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $column-name = ? ) : resource

Devuelve los campos de una tabla y sus metadatos asociados.

Parámetros

connection

Una conexión a IBM DB2, Cloudscape, o Apache Derby.

qualifier

Un calificador para bases de datos DB2 que se ejecutan en servidores OS/390 o z/OS. Para otras bases de datos, use null o una cadena vacía.

schema

El esquema que contiene la tabla indicada. Para buscar en todos los esquemas, use '%'.

table-name

El nombre de la tabla o vista. Para consultar todas las tablas en la base de datos, use null o una cadena vacía.

column-name

El nombre del campo. Para consultar todos los campos en la tabla, use null o una cadena vacía.

Valores devueltos

Devuelve información de los campos especificados a través de los parámetros de la función. Los registros contienen las siguientes columnas:

Nombre del campo | Descripción
TABLE_CAT | Nombre del catálogo. Puede ser null si la tabla no contiene un catálogo.
TABLE_SCHEM | Nombre del esquema.
TABLE_NAME | Nombre de la tabla o vista.
COLUMN_NAME | Nombre del campo.
DATA_TYPE | El tipo de dato SQL como un entero.
TYPE_NAME | El nombre del tipo de dato como cadena de texto.
COLUMN_SIZE | El tamaño del campo como un entero.
BUFFER_LENGTH | El tamaño en bytes que se requieren como máximo para almacenar datos desde este campo.
DECIMAL_DIGITS | La escala de este campo, o null si no es aplicable.
NUM_PREC_RADIX | Un entero que puede ser 10 (para un tipo de dato exacto), 2 (para un tipo de dato aproximado), o null (para un tipo de dato donde la precisión no es aplicable).
NULLABLE | Indica si este campo puede guardar valores null.
REMARKS | Descripción del campo.
COLUMN_DEF | Valor por defecto.
SQL_DATA_TYPE | El tamaño del campo como un entero.
SQL_DATETIME_SUB | Devuelve el código del subtipo de fecha y hora, o null para tipos de datos donde no es aplicable.
CHAR_OCTET_LENGTH | Tamaño máximo en octetos para el tipo de datos de carácter, que coincida con COLUMN_SIZE para conjuntos de caracteres de un sólo byte, o null para tipos de datos distintos.
ORDINAL_POSITION | La posición del campo en la tabla (contando desde 1).
IS_NULLABLE | Una cadena de texto que contiene 'YES' si puede guardar valores nulos y 'NO' cuando no permita valores nulos.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Confirmar una transacción

  • « db2_columns
  • db2_conn_error »
  • PHP Manual
  • Funciones de IBM DB2
  • Confirmar una transacción

db2_commit

(PECL ibm_db2 >= 1.0.0)

db2_commit — Confirmar una transacción

Descripción

db2_commit ( resource $connection ) : bool

Confirma una transacción en progreso en la conexión especificada e inicia una nueva transacción. Las aplicaciones en PHP normalmente confirman las transacciones automáticamente debido a que el modo AUTOCOMMIT por defecto está activado, por lo que el uso de db2_commit() no es necesario a menos que el modo AUTOCOMMIT haya sido desactivado en la conexión especificada.

Parámetros

connection

Es la conexión válida devuelta por db2_connect() o db2_pconnect().

Valores devueltos

Devuelve true en caso de éxito, o false en caso de error.

Ver también

  • db2_autocommit() - Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos
  • db2_rollback() - Cancelar una transacción


Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.

  • « db2_commit
  • db2_conn_errormsg »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.

db2_conn_error

(PECL ibm_db2 >= 1.0.0)

db2_conn_error — Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.

Descripción

db2_conn_error ( resource $connection = ? ) : string

db2_conn_error() devuelve un valor SQLSTATE que representa el motivo por el que el último intento de conexión a la base de datos falló. Como db2_connect() devuelve false cuando un intento de conexión falla, no es necesario pasar algún argumento a db2_conn_error() para que devuelva el valor SQLSTATE.

Si, de todos modos, la conexión fue exitosa pero en algún momento dejó de ser válida, se puede pasar el parámetro opcional connection para extraer el valor SQLSTATE para una conexión específica.

Para verificar el valor representado por SQLSTATE, se puede utilizar el siguiente comando en alguna ventana de línea de comandos de DB2: db2 '? sqlstate-value'. Además se puede llamasr a db2_conn_errormsg() para obtener el mensaje de error explícito asociado al valor SQLCODE.

Parámetros

connection

Es la conexión que se inició correctamente, pero que en algún momento dejó de ser válida.

Valores devueltos

Devuelve el valor SQLSTATE que resultó de un intento de conexión fallido. Devuelve una cadena vacía si no hay ningún error asociado con el último intento de conexión.

Ejemplos

Ejemplo #1 Extrayendo el valor SQLSTATE de un intento de conexión fallido

El siguiente ejemplo demuestra como obtener el valor SQLSTATE después de pasar parámetros inválidos intencionalmente a db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print "Valor SQLSTATE: " . db2_conn_error();
}
?>

El resultado del ejemplo sería:

SQLSTATE value: 08001

Ver también

  • db2_conn_errormsg() - Devolver el último mensaje de error de la conexión y su valor SQLCODE
  • db2_connect() - Devolver una conexión a la base de datos
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Devolver el último mensaje de error de la conexión y su valor SQLCODE

  • « db2_conn_error
  • db2_connect »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el último mensaje de error de la conexión y su valor SQLCODE

db2_conn_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_conn_errormsg — Devolver el último mensaje de error de la conexión y su valor SQLCODE

Descripción

db2_conn_errormsg ( resource $connection = ? ) : string

db2_conn_errormsg() devuelve un mensaje de error y el valor SQLCODE que representa el motivo por el que el último intento de conexión a la base de datos falló. Como db2_connect() devuelve false en caso de que un intento de conexión falle, no es necesario pasar argumentos a db2_conn_errormsg() para extrer el mensaje de error y el valor SQLCODE asociados.

Si, de todod modos, la conexión fue exitosa pero en algún momento dejó de ser válida, se puede pasar el parámetro connection para obtener el mensaje de error y el valor SQLCODE asociados a una conexión especifica.

Parámetros

connection

Un recurso de conexión asociado a la conexión que inicialmente fue exitosa, pero que en algún momento llego a ser inválida.

Valores devueltos

Devuelve una cadena que contiene el mensaje de error y el valor SQLCODE derivados de un intento de conexión fallido. Si no hay algún error asociado con el último intento de conexión, db2_conn_errormsg() devuelve una cadena vacía.

Ejemplos

Ejemplo #1 Extrayendo el mensaje de error devuelto por un intento de conexión fallido

El siguiente ejemplo muestra como devolver un mensaje de error y el valor SQLCODE después de pasar parámetros inválidos intencionalmente a db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print db2_conn_errormsg();
}
?>

El resultado del ejemplo sería:

[IBM][CLI Driver] SQL1013N  The database alias name
or database name "BADNAME" could not be found.  SQLSTATE=42705
 SQLCODE=-1013

Ver también

  • db2_conn_error() - Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
  • db2_connect() - Devolver una conexión a la base de datos
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Devolver una conexión a la base de datos

  • « db2_conn_errormsg
  • db2_cursor_type »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver una conexión a la base de datos

db2_connect

(PECL ibm_db2 >= 1.0.0)

db2_connect — Devolver una conexión a la base de datos

Descripción

db2_connect ( string $database , string $username , string $password , array $options = ? ) : resource

Devuelve una conexión a una base de datos IBM DB2 Universal Database, IBM Cloudscape o Apache Derby.

Parámetros

database

El alias de la base de datos en al catálogo del cliente DB2.

Para una conexión sin catalogar a una base de datos, se puede representar database con una cadena de conexión completa en el siguiente formato:

DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password;
donde los parámetros representan los siguientes valores:
database

El nombre de la base de datos.

hostname

El Host o la IP del servidor de la base de datos.

port

El puerto TCP/IP sobre el cual la base de datos está escuchando solicitudes.

username

El usuario con el que se conecta a la base de datos.

password

La contraseña con la que se conecta a la base de datos.

username

El usuario con el que se conecta a la base de datos.

Para conexiones sin catalogar se debe pasar null o una cadena vacia.

password

La contraseña con la que se conecta a la base de datos.

Para conexiones sin catalogar se debe pasar null o una cadena vacia.

options

Un arreglo asociativo de opciones que afectan el comportamiento de la conexión, entre las claves válidas están:

autocommit

Si se pasa el valor DB2_AUTOCOMMIT_ON se confirmarán automáticamente las transacciones de la conexión.

Si se pasa el valor DB2_AUTOCOMMIT_OFF no se confirmarán automáticamente las transacciones de la conexión.

DB2_ATTR_CASE

Si se pasa el valor DB2_CASE_NATURAL los nombres de las columnas serán devueltos con sus mayúsculas y minúsculas originales.

Si se pasa el valor DB2_CASE_LOWER los nombres de las columnas serán devueltos en minúsculas.

Si se pasa el valor DB2_CASE_UPPER los nombres de las columnas serán devueltos en mayúsculas.

CURSOR

Si se pasa el valor DB2_FORWARD_ONLY se establece un cursor de no-recorrido (sólo hacia adelante). Este cursor es predeterminado y soportado por todos los servidores de base de datos.

Si se pasa el valor DB2_SCROLLABLE se establece un cursor de recorrido. Con este modo es posible acceder de manera aleatoria a las filas del resultado pero actualmente sólo es soportado por IBM DB2 Universal Database.

Las siguientes opciones están disponibles en las versiones 1.7.0 y superiores de ibm_db2.

trustedcontext

Si se pasa el valor DB2_TRUSTED_CONTEXT_ENABLE se establece una conexión de confianza. Este parámetro no puede ser establecido mediante db2_set_option().

Esta clave solo funciona si la base de datos está catalogada (aún cuando la base de datos sea local), o si se especifica un DSN completo cuando se crea la conexión.

Para catalogar la base de datos se usan los siguientes comandos:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
            db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
            db2 "update dbm cfg using svcename <SERVICENAME>"
            db2set DB2COMM=TCPIP

Las siguientes opciones i5/OS están disponibles en las versiones 1.5.1 y superiores de ibm_db2.

i5_lib

Una cadena que indica la lista de bibliotecas que se utilizará por default para resolver referencias no evaluadas a archivos. Este parámetro no es válido si en la conexión se utiliza el modo de nombrado de sistema.

i5_naming

DB2_I5_NAMING_ON habilita el modo de nombrado de sistema DB2 UDB CLI iSeries. Los archivos son evaluados utilizando una diagonal (/) como delimitador. Los archivos que no pueden ser evaluados son resueltos utilizando la lista de bibliotecas.

DB2_I5_NAMING_OFF esta valor predeterminado habilita el modo de nombrado DB2 UDB CLI, que es el sistema de nombrado de SQL. Los archivos son evaluados utilizando un punto (.) como delimitador. Los archivos que no se pueden evaluar son resueltos utilizando tanto la biblioteca predeterminada como el identificador del usuario actual.

i5_commit

Se recomienda establecer el parámetro i5_commit antes que db2_pconnect(). Si el valor es modificado después de que la conexión ha sido establecida y la conexión es hacia una fuente remota, el cambio no tendrá efecto hasta la siguiente llamada exitosa a db2_pconnect() para el manejo de conexión.

Nota:

El parámetro ibm_db2.i5_allow_commit==0 en php.ini o DB2_I5_TXN_NO_COMMIT son opciones predeterminadas pero pueden ser remplazadas con la opción i5_commit.

DB2_I5_TXN_NO_COMMIT - No se utiliza ningún control de transacciones.

DB2_I5_TXN_READ_UNCOMMITTED - Se permiten lecturas sucias, lecturas no repetibles, y lecturas fantasma.

DB2_I5_TXN_READ_COMMITTED - No se permiten lecturas sucias. Se permiten lecturas no repetibles y lecturas fantasma.

DB2_I5_TXN_REPEATABLE_READ - No se permiten lecturas sucias ni lecturas no repetibles. Se permiten lecturas fantasma.

DB2_I5_TXN_SERIALIZABLE - Las transacciones son serializables. No se permiten lecturas sucias, lecturas no repetibles ni lecturas fantasma.

i5_query_optimize

DB2_FIRST_IO - Todas las consultas son optimazadas con el objetivo de devolver la primera página de resultados lo más rápido posible. Esta opción se recomienda cuando el resultado es controlado por un usuario que puede cancelar la consulta después de visualizar la primera página de resultados. Esta funcionalidad también se puede lograr utilizando OPTIMIZE FOR nnn ROWS en una consulta.

DB2_ALL_IO - Todas las consultas son optimizadas con el objetivo de ejecutar la consulta completa en el menor tiempo posible. Esta opción predeterminada se recomienda cuando el resultado de una consulta es escrito en un archivo o reporte. Esta funcionalidad tambien se puede lograr utilizando OPTIMIZE FOR nnn ROWS en una consulta.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON habilita el esquema de alojamiento DB2 6X para incremento de tamaño en columnas de traducción DBCS.

DB2_I5_DBCS_ALLOC_OFF deshabilita el esquema de alojamiento DB2 6X para incremento de tamaño en columnas de traducción DBCS.

Nota: El parámetro ibm_db2.i5_dbcs_alloc==0 en php.ini o DB2_I5_DBCS_ALLOC_OFF son opciones predeterminadas pero pueden ser remplazadas con la opción i5_dbcs_alloc.

i5_date_fmt

DB2_I5_FMT_ISO - Se utiliza el formato de fechas estandar (ISO) yyyy-mm-dd. Esta opción es predeterminada.

DB2_I5_FMT_USA - Se utiliza el formato de fechas de Estados Unidos mm/dd/yyyy.

DB2_I5_FMT_EUR - Se utiliza el formato de fechas Europeo dd.mm.yyyy.

DB2_I5_FMT_JIS - Se utiliza el formato de fechas Japonés yyyy-mm-dd.

DB2_I5_FMT_MDY - Se utiliza el formato de fechas mm/dd/yyyy.

DB2_I5_FMT_DMY - Se utiliza el formato de fechas dd/mm/yyyy.

DB2_I5_FMT_YMD - Se utiliza el formato de fechas yy/mm/dd.

DB2_I5_FMT_JUL - Se utiliza el formato de fechas Juliano yy/ddd.

DB2_I5_FMT_JOB - El formato de trabajo es utilizado.

i5_date_sep

DB2_I5_SEP_SLASH - Se utiliza una diagonal ( / ) como separador de fechas. Esta opción es predeterminada.

DB2_I5_SEP_DASH - Se utiliza un guión medio ( - ) como separador de fechas.

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador de fechas.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador de fechas.

DB2_I5_SEP_BLANK - Se utiliza un espacio como separador de fechas.

DB2_I5_SEP_JOB - Se utiliza el separador de fechas de trabajo.

i5_time_fmt

DB2_I5_FMT_ISO - Se utiliza el formato de tiempo estandar (ISO) hh.mm.ss. Esta opción es predeterminada.

DB2_I5_FMT_USA - Se utiliza el formato de tiempo de Estados Unidos hh:mmxx, donde xx es AM o PM.

DB2_I5_FMT_EUR - Se utiliza el formato de tiempo Europeo hh.mm.ss.

DB2_I5_FMT_JIS - Se utiliza el formato de tiempo Japonés hh:mm:ss.

DB2_I5_FMT_HMS - Se utiliza el formato de tiempo hh:mm:ss.

i5_time_sep

DB2_I5_SEP_COLON - Se utiliza el signo de dos puntos ( : ) como separador de tiempo. Esta opción es predeterminada.

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador de tiempo.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador de tiempo.

DB2_I5_SEP_BLANK - Se utiliza un espacio como separador de tiempo.

DB2_I5_SEP_JOB - Se utiliza el separador de tiempo de trabajo.

i5_decimal_sep

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador decimal. Esta opción es predeterminada.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador decimal.

DB2_I5_SEP_JOB - Se utiliza el separador decimal de trabajo.

La siguiente opción i5/OS está disponible en las versiones 1.8.0 y superiores de ibm_db2.

i5_libl

Un cadena que indica la lista de bibliotecas que se utilizará para resolver referencias no evaluadas a archivos. Se especifican los elementos de la lista separados por espacios 'i5_libl'=>"LIBRERIA1 LIBRERIA2 LIBRERIA3".

Nota:

i5_libl llama a qsys2/qcmdexc('cmd',cmdlen), que sólo está disponible en i5/OS V5R4 y versiones superiores.

Valores devueltos

Devuelve un recurso de conexión si el intento de conexión es exitoso. Si el intento de conexión falla db2_connect() devuelve false.

Ejemplos

Ejemplo #1 Creando una conexión catalogada

Las conexiones catalogadas requieren que previamente se haya guardado la configuración mediante la consola DB2 Command Line Processor (CLP) o el asistente DB2 Configuration Assistant.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$conn = db2_connect($database, $user, $password);

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

El resultado del ejemplo sería:

Connection succeeded.

Ejemplo #2 Creando una conexión no catalogada

Con una conexión no catalogada es posible conectarse de manera dinámica a la base de datos.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$hostname = 'localhost';
$port = 50000;

$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;" .
  "HOSTNAME=$hostname;PORT=$port;PROTOCOL=TCPIP;UID=$user;PWD=$password;";
$conn = db2_connect($conn_string, '', '');

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

El resultado del ejemplo sería:

Connection succeeded.

Ejemplo #3 Creando una conexión con confirmaciones automáticas de transacciones deshabilitadas

Si se pasa un arreglo de opciones a db2_connect() se puede modificar el conportamiento predeterminado de la conexión.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);

$conn = db2_connect($database, $user, $password, $options);

if ($conn) {
    echo "Connection succeeded.\n";
    if (db2_autocommit($conn)) {
         echo "Autocommit is on.\n";
    }
    else {
         echo "Autocommit is off.\n";
    }
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

El resultado del ejemplo sería:

Connection succeeded.
Autocommit is off.

Ejemplo #4 Optimizando en i5/OS

Para lograr un mejor rendimiento en las aplicaciones de i5/OS ibm_db2 1.5.1 se puede usar el Host, usuario y contraseña predeterminados en db2_connect().

<?php
  $library = "ADC";
  $i5 = db2_connect("", "", "", array("i5_lib"=>"qsys2"));
  $result = db2_exec($i5,
       "select * from systables where table_schema = '$library'");
  while ($row = db2_fetch_both($result)) {
     echo $row['TABLE_NAME']."</br>";
  }
  db2_close($i5);
?>

El resultado del ejemplo sería:

ANIMALS
NAMES
PICTURES

Ejemplo #5 Usando contexto de confianza

El siguiente ejemplo muestra como habilitar el contexto de confianza, cambia usuarios y obtiene el identificador del usuario actual.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_connect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

El resultado del ejemplo sería:

Explicit trusted connection succeeded.
User has been switched.

Ver también

  • db2_close() - Cierra una conexión a base de datos
  • db2_pconnect() - Devolver una conexión persistente a la base de datos


Determinar el tipo de cursor utilizado en una consulta

  • « db2_connect
  • db2_escape_string »
  • PHP Manual
  • Funciones de IBM DB2
  • Determinar el tipo de cursor utilizado en una consulta

db2_cursor_type

(PECL ibm_db2 >= 1.0.0)

db2_cursor_type — Determinar el tipo de cursor utilizado en una consulta

Descripción

db2_cursor_type ( resource $stmt ) : int

Devuelve el tipo de cursor utilizado en una consulta. Se puede utilizar para determinar si se está trabajando con un curso de tipo "forward-only" (sin recorrido) o "scrollable" (con recorrido).

Parámetros

stmt

Un recurso de sentencia válido.

Valores devueltos

Devuelve DB2_FORWARD_ONLY si la consulta utiliza un cursor de tipo "forward-only" (sin recorrido) o DB2_SCROLLABLE si utiliza un cursor de tipo "scrollable" (con recorrido).

Ver también

  • db2_prepare() - Prepara un comando SQL para su ejecución


Escapar ciertos caracteres especiales

  • « db2_cursor_type
  • db2_exec »
  • PHP Manual
  • Funciones de IBM DB2
  • Escapar ciertos caracteres especiales

db2_escape_string

(PECL ibm_db2 >= 1.6.0)

db2_escape_string — Escapar ciertos caracteres especiales

Descripción

db2_escape_string ( string $string_literal ) : string

Agrega un caracter de escape (barra invertida) antes de cada caracter especial de la cadena enviada como parámetro.

Parámetros

string_literal

La cadena que contiene los caracteres especiales y que necesita ser escapada. Los carecteres especiales a los que se les agrega el caracter de escape son \x00, \n, \r, \, ', " y \x1a.

Valores devueltos

Devuelve string_literal con todos los caracteres especiales ya escapados.

Ejemplos

Ejemplo #1 Ejemplo de db2_escape_string()

Resultado del uso de la función db2_escape_string()

<?php

$conn = db2_connect($database, $user, $password);

if ($conn) {
    $str[0] = "Todos los caracteres: \x00 , \n , \r , \ , ' , \" , \x1a .";
    $str[1] = "Barra invertida (\). Comilla simple ('). Comilla doble (\")";
    $str[2] = "El caracter NULL \0 debe ser citado también";
    $str[3] = "Caracteres interesantes: \x1a , \x00 .";
    $str[4] = "Nada que citar";
    $str[5] = 200676;
    $str[6] = "";

    foreach( $str as $string ) {
        echo "db2_escape_string: " . db2_escape_string($string). "\n";
    }
}
?>

El resultado del ejemplo sería:

db2_escape_string: Todos los caracteres: \0 , \n , \r , \\ , \' , \" , \Z .
db2_escape_string: Barra invertida (\\). Comilla simple (\'). Comilla doble (\")
db2_escape_string: El caracter NULL \0 debe ser citado también
db2_escape_string: Caracteres interesantes: \Z , \0 .
db2_escape_string: Nada que citar
db2_escape_string: 200676
db2_escape_string:

Ver también

  • db2_prepare() - Prepara un comando SQL para su ejecución


Ejecutar directamente una sentencia SQL

  • « db2_escape_string
  • db2_execute »
  • PHP Manual
  • Funciones de IBM DB2
  • Ejecutar directamente una sentencia SQL

db2_exec

(PECL ibm_db2 >= 1.0.0)

db2_exec — Ejecutar directamente una sentencia SQL

Descripción

db2_exec ( resource $connection , string $statement , array $options = ? ) : resource

Ejecuta directamente una sentencia SQL.

Si se planea utilizar variables de PHP en una sentencia SQL, hay que considerar que este es uno de los risgos de seguridad más comunes. Hay que considerar el uso de db2_prepare() para agregar marcadores de parámetros a los valores de entrada que serán utilizados en una sentencia an SQL. Después se puede llamar a db2_execute() para pasar los valores de entrada ya marcados y evitar ataques por inyección SQL.

Si se planea ejecutar repetidamente la misma sentencia SQL pero con diferentes parámetros, hay que considerar el uso de db2_prepare() y db2_execute() para habilitar en el servidor la reutilización del plan de acceso e incrementar la eficiencia de los accesos a la base de datos.

Parámetros

connection

Una conexión válida a la base de datos devuelta por db2_connect() o db2_pconnect().

statement

Una sentencia SQL. La sentencia no puede contener ningún marcador de parámetros.

options

Un arreglo asociativo que contiene opciones para la sentencia. Se puede utilizar este parámetro para solicitar un cursor de tipo SCROLLABLE en una base de datos que soporte esta funcionalidad.

Para una descripción válida de las opciones para la sentencia está db2_set_option().

Valores devueltos

Devuelve un recurso de sentencia si la sentencia SQL fue ejecutada correctamente, o false si hubo un error al ejecutar la sentencia SQL.

Ejemplos

Ejemplo #1 Creando una tabla con db2_exec()

El siguiente ejemplo utiliza db2_exec() para ejecutar una serie de sentencias DDL.

<?php
$conn = db2_connect($database, $user, $password);

// Create the test table
$create = 'CREATE TABLE animals (id INTEGER, breed VARCHAR(32),
    name CHAR(16), weight DECIMAL(7,2))';
$result = db2_exec($conn, $create);
if ($result) {
    print "Successfully created the table.\n";
}

// Populate the test table
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
    array(3, 'gold fish', 'Bubbles', 0.1),
    array(4, 'budgerigar', 'Gizmo', 0.2),
    array(5, 'goat', 'Rickety Ride', 9.7),
    array(6, 'llama', 'Sweater', 150)
);

foreach ($animals as $animal) {
    $rc = db2_exec($conn, "INSERT INTO animals (id, breed, name, weight)
      VALUES ({$animal[0]}, '{$animal[1]}', '{$animal[2]}', {$animal[3]})");
    if ($rc) {
        print "Insert... ";
    }
}
?>

El resultado del ejemplo sería:

Successfully created the table.
Insert... Insert... Insert... Insert... Insert... Insert... Insert...

Ejemplo #2 Ejecutando una sentencia SELECT con cursor de tipo SCROLLABLE

El siguiente ejemplo demuestra como solicitar un cursor de tipo SCROLLABLE para una sentencia SQL ejecutada por db2_exec().

<?php
$conn = db2_connect($database, $user, $password);
$sql = "SELECT name FROM animals
    WHERE weight < 10.0
    ORDER BY name";
if ($conn) {
    require_once('prepare.inc');
    $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
    while ($row = db2_fetch_array($stmt)) {
        print "$row[0]\n";
    }
}
?>

El resultado del ejemplo sería:

Bubbles
Gizmo
Pook
Rickety Ride

Ejemplo #3 Devolviendo datos XML como resultado

El siguiente ejemplo demuestra como trabajar con documentos almacenados en una columna XML utilizando la base de datos SAMPLE. Utilizando SQL/XML, este ejemplo devuelve algunos nodos en un documento XML en un formato claro para la mayoría de los usuarios.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = \'Kathy Smith\'
    ';
$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
}
db2_close($conn);

?>

El resultado del ejemplo sería:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Ejemplo #4 Ejecutando un JOIN con datos XML

El siguiente ejemplo trabaja con documentos almacenados en dos diferentes columnas XML en la base de datos SAMPLE. Se crean dos tablas temporales de los documentos XML y devuelve un resultado SQL con información acerca del estatus de envío a los clientes.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
    SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
    FROM
    XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" BIGINT PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) as A,
    PURCHASEORDER AS B,
    XMLTABLE (
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
    COLUMNS
    "PONUM"  BIGINT PATH \'@PoNum\',
    "STATUS" VARCHAR (50) PATH \'@Status\'
    ) as C
    WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = \'Kathy Smith\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
}

db2_close($conn);

?>

El resultado del ejemplo sería:

1001     Kathy Smith     905-555-7258     5002     Shipped

Ejemplo #5 Devolviendo datos SQL como parte de un documento XML extenso

El siguiente ejemplo trabaja con una porción de los documentos PRODUCT.DESCRIPTION en la base de datos SAMPLE. Se crea un documento XML que contiene descripciones de productos (datos XML) y precios (datos SQL).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
        } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = \'100-100-01\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
}
db2_close($conn);

?>

El resultado del ejemplo sería:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Ver también

  • db2_execute() - Ejecutar una sentencia SQL preparada
  • db2_prepare() - Prepara un comando SQL para su ejecución


Ejecutar una sentencia SQL preparada

  • « db2_exec
  • db2_fetch_array »
  • PHP Manual
  • Funciones de IBM DB2
  • Ejecutar una sentencia SQL preparada

db2_execute

(PECL ibm_db2 >= 1.0.0)

db2_execute — Ejecutar una sentencia SQL preparada

Descripción

db2_execute ( resource $stmt , array $parameters = ? ) : bool

db2_execute() ejecuta una sentencia SQL que ha sido preparada por db2_prepare().

Si la sentencia SQL devuelve un bloque de resultados, por ejemplo, una sentencia SELECT o una llamada a un procedimiento que devuelve bloques de resultados, se puede extraer una fila como arreglo a partir del recurso stmt usando db2_fetch_assoc(), db2_fetch_both(), o db2_fetch_array(). Alternativamente, se puede usar db2_fetch_row() para mover el apuntador del resultado a la siguiente fila y extraer una columna de esa fila con db2_result().

En la función db2_prepare() se discuten brevementen las ventajas de utilizar db2_prepare() y db2_execute() en lugar de db2_exec().

Parámetros

stmt

La sentencia preparada devuelta por db2_prepare().

parameters

Un arreglo de parámetros de entrada que reemplazarán a los marcadores contenidos en la sentencia preparada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Preparando y ejecutando una sentencia SQL con marcadores de parámetros

El siguiente ejemplo prepara una sentencia INSERT que acepta cuatro marcadores de parámetros, después la ejecuta con db2_execute().

<?php
$pet = array(0, 'cat', 'Pook', 3.2);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';

$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    $result = db2_execute($stmt, $pet);
    if ($result) {
        print "Successfully added new pet.";
    }
}
?>

El resultado del ejemplo sería:

Successfully added new pet.

Ejemplo #2 Llamando a un procedimiento almacenado con un parámetro OUT

El siguiente ejemplo prepara una sentencia CALL que acepta un marcador de parámetro que representa al parámetro OUT, enlaza la variable de PHP $my_pets al parámetro utilizando db2_bind_param(), después utiliza db2_execute() para ejecutar la sentencia CALL. Después de que la llamada al procedimiento almacenado se ha hecho, el valor de $num_pets se actualiza con el valor devuelto por el procedimiento almacenado para ese parámetro OUT.

<?php
$num_pets = 0;
$res = db2_prepare($conn, "CALL count_my_pets(?)");
$rc = db2_bind_param($res, 1, "num_pets", DB2_PARAM_OUT);
$rc = db2_execute($res);
print "I have $num_pets pets!";
?>

El resultado del ejemplo sería:

I have 7 pets!

Ejemplo #3 Devolviendo datos XML como resultado SQL

El siguiente ejemplo demuestra como trabajar con documentos almacenados en una columna XML usando la base de datos SAMPLE. Por medio de SQL/XML, este ejemplo devuelve algunos nodos en un documento XML contendos en un resultado SQL.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = ?
    ';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
    }
}
db2_close($conn);

?>

El resultado del ejemplo sería:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Ejemplo #4 Ejecutando un "JOIN" con datos XML

El siguiente ejemplo funciona con documentos almacenados en dos diferentes columnas XML en la base de datos SAMPLE. Crea dos tablas temporales de los documentos XML de las dos columnas y devuelve un resultado SQL con información acerca del estado de compra de un cliente.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
FROM
XMLTABLE(
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
COLUMNS
"CID" BIGINT PATH \'@Cid\',
"NAME" VARCHAR (50) PATH \'name\',
"PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
) as A,
PURCHASEORDER AS B,
XMLTABLE (
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
COLUMNS
"PONUM"  BIGINT PATH \'@PoNum\',
"STATUS" VARCHAR (50) PATH \'@Status\'
) as C
WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = ?
';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
    }
}

db2_close($conn);

?>

El resultado del ejemplo sería:

1001     Kathy Smith     905-555-7258     5002     Shipped

Ejemplo #5 Devolviendo datos SQL como parte un documento XML más extenso

El siguiente ejemplo trabaja con una parte de los documentos PRODUCT.DESCRIPTION en la base de datos SAMPLE. Crea un documento XML que contiene descripciones del producto (datos XML) y precios (datos SQL).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
            } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = ?
';

$stmt = db2_prepare($conn, $query);

$pid = "100-100-01";

if ($stmt) {
    db2_bind_param($stmt, 1, "pid", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
    }
}

db2_close($conn);

?>

El resultado del ejemplo sería:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Ver también

  • db2_exec() - Ejecutar directamente una sentencia SQL
  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_prepare() - Prepara un comando SQL para su ejecución
  • db2_result() - Devolver una columna específica del resultado


Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados

  • « db2_execute
  • db2_fetch_assoc »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados

db2_fetch_array

(PECL ibm_db2 >= 1.0.1)

db2_fetch_array — Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados

Descripción

db2_fetch_array ( resource $stmt , int $row_number = -1 ) : array

Devuelve un arreglo, indexado por la posición de las columnas, que representa una fila en un bloque de resultados. El primer índice es cero.

Parámetros

stmt

Un resurso stmt válido que contenga el resultado de la consulta.

row_number

Extrae una fila específica del bloque de resultados indexada a partir de uno. Este argumento puede provocar una advertencia en PHP si el resultado utiliza un cursor de no-recorrido (sólo hacia adelante).

Valores devueltos

Devuelve un arreglo, indexado a partir de cero de acuerdo a la posición de la columna, que representa la fila solicitada en un bloque de resultados. Devuelve false si no quedan más filas en el bloque de resultados o si la fila solicitada por row_number no existe en el bloque.

Ejemplos

Ejemplo #1 Iterando a través de un cursor de no-recorrido (sólo hacia adelante)

Si se llama a db2_fetch_array() sin un número de fila específico, automáticamente extrae la siguiente fila del bloque de resultados.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_array($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ejemplo #2 Extrayendo filas específicas con db2_fetch_array() con un cursor de recorrido

Si el bloque de resultados utiliza un cursor de recorrido, se puede llamar a db2_fetch_array() con un número de fila específico. El siguiente ejemplo extrae el resto de las filas comenzando por la segunda fila.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_array($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
    $i = $i + 2;
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ver también

  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_object() - Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_result() - Devolver una columna específica del resultado


Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados

  • « db2_fetch_array
  • db2_fetch_both »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados

db2_fetch_assoc

(PECL ibm_db2 >= 1.0.0)

db2_fetch_assoc — Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados

Descripción

db2_fetch_assoc ( resource $stmt , int $row_number = -1 ) : array

Devuelve un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados.

Parámetros

stmt

Un recurso stmt válido que contenga el bloque de resultados.

row_number

Solicita una fila específica, indexada a partir de uno, del bloque de resultados. Este parámetro provoca una advertencia de PHP si el bloque de resultados utiliza cursor de no-recorrido (sólo hacia adelante).

Valores devueltos

Devuelve un arreglo asociativo con los valores de las columnas indexados por el nombre de las mismas, representando la fila siguiente o la fila solicitada en el bloque de resultados. Devuelve false si no hay más filas en el resultado o si la fila solicitada por row_number no existe en el bloque de resultados.

Ejemplos

Ejemplo #1 Iterando a través de un cursor de no-recorrido (sólo hacia adelante)

Si se llama a db2_fetch_assoc() sin un número específico de fila, la siguiente fila del bloque de resultados se devuelve automáticamente.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_assoc($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ejemplo #2 Extrayendo filas específicas con db2_fetch_assoc() a partir de un cursor de recorrido

Si el bloque de resultados utiliza un cursor de recorrido, se puede llamar db2_fetch_assoc() con un número específico de fila. El siguiente ejemplo extrae todas las filas del resultado, comenzando con la segunda fila.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_assoc($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
    $i = $i + 2;
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ver también

  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_object() - Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_result() - Devolver una columna específica del resultado


Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados

  • « db2_fetch_assoc
  • db2_fetch_object »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados

db2_fetch_both

(PECL ibm_db2 >= 1.0.0)

db2_fetch_both — Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados

Descripción

db2_fetch_both ( resource $stmt , int $row_number = -1 ) : array

Devuelve un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados. Hay que considerar que la fila devuelta por db2_fetch_both() requiere más memoria que las filas devueltas por db2_fetch_assoc() o db2_fetch_array(), ya que estas últimas sólo devuelven un índice.

Parámetros

stmt

Un recurso stmt válido que contenga los resultados.

row_number

Solicita una fila específica, indexada a partir de uno, del bloque de resultados. Este parámetro provoca una advertencia de PHP si el resultado utiliza cursor de no-recorrido (sólo hacia adelante).

Valores devueltos

Devuelve un arreglo asociativo con las columnas indexadas por el nombre y también por el número de columna (indexada a partir de cero). El arreglo representa la siguiente fila o la fila específica solicitada del bloque de resultados. Devuelve false si no hay más filas en los resultados o si la fila solicitada por row_number no existe entre los resultados.

Ejemplos

Ejemplo #1 Iterando a través de un cursor de no-recorrido (sólo hacia adelante)

Si se llama a db2_fetch_both() sin especificar un número de fila, automáticamente extrae la siguiente fila del bloque de resultados. El siguiente ejemplo accesa a las columnas del arreglo devuelto utilizando tanto los nombres de la columnas como sus posiciones en el índice.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_both($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row[0], $row['BREED'], $row[3]);
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ejemplo #2 Extrayendo filas específicas con db2_fetch_both() a partir de un cursor de recorrido

Si el bloque de resultados utiliza un cursor de recorrido, se puede llamar a db2_fetch_both() con un número específico de fila. El siguiente ejemplo extrae cada fila del bloque de resultados, comenzando por la segunda fila.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_both($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row['NAME'], $row[2], $row['WEIGHT']);
    $i = $i + 2;
}
?>

El resultado del ejemplo sería:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ver también

  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_object() - Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_result() - Devolver una columna específica del resultado


Devolver un objeto con atributos que representan a las columnas de una fila extraida

  • « db2_fetch_both
  • db2_fetch_row »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un objeto con atributos que representan a las columnas de una fila extraida

db2_fetch_object

(PECL ibm_db2 >= 1.0.0)

db2_fetch_object — Devolver un objeto con atributos que representan a las columnas de una fila extraida

Descripción

db2_fetch_object ( resource $stmt , int $row_number = -1 ) : object

Devuelve un objeto en el que cada atributo representa una columna devuelta de una fila extraida del bloque de resultados.

Parámetros

stmt

Un recurso stmt válido que contenga el bloque de resultados.

row_number

Solicita una fila específica, indexada a partir de uno, del bloque de resultados. Este parámetro provoca una advertencia de PHP si los resultados utilizan cursor de no-recorrido.

Valores devueltos

Devuelve un objeto que representa una fila del bloque de resultados. Los atributos del objeto son creados a partir de los nombres de las columnas del resultado.

Los servidores de base de datos como IBM DB2, Cloudscape, y Apache Derby usualmente convierten a mayúsculas los nombres de las columnas por lo que esto se verá reflejado en los atributos del objeto.

Si una sentencia SELECT a su vez llama a una función escalar para modificar el valor de una columna, los servidores de base de datos devuelven el número de la columna como si fuera el nombre de la misma para ser usada como atributo. Si se quiere un nombre de columna más descriptivo, se puede usar la clausula AS para asignar un alias a la columna del resultado.

Devuelve false si no hay fila devuelta.

Ejemplos

Ejemplo #1 Ejemplo de db2_fetch_object()

El siguiente ejemplo ejecuta una sentencia SELECT con una función escalar (RTRIM) que elimina espacios al final de la columna. En lugar de crear un objeto con las propiedades "BREED" y "2", se utilizará la claúsula AS en la sentencia SELECT para asignar el nombre "name" a la columna modificada. El servidor de base de datos convierte los nombres de las columnas a mayúsculas, lo que resultará en un objeto con los atributos "BREED" y "NAME".

<?php
$conn = db2_connect($database, $user, $password);

$sql = "SELECT breed, RTRIM(name) AS name
    FROM animals
    WHERE id = ?";

if ($conn) {
    $stmt = db2_prepare($conn, $sql);
    db2_execute($stmt, array(0));

    while ($pet = db2_fetch_object($stmt)) {
        echo "Come here, {$pet->NAME}, my little {$pet->BREED}!";
    }
    db2_close($conn);
}
?>

El resultado del ejemplo sería:

Come here, Pook, my little cat!

Ver también

  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_result() - Devolver una columna específica del resultado


Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada

  • « db2_fetch_object
  • db2_field_display_size »
  • PHP Manual
  • Funciones de IBM DB2
  • Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada

db2_fetch_row

(PECL ibm_db2 >= 1.0.0)

db2_fetch_row — Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada

Descripción

db2_fetch_row ( resource $stmt , int $row_number = ? ) : bool

db2_fetch_row() se utiliza para iterar a través de un bloque de resultados o para apuntar a una fila específica del resultado si se utiliza un cursor de recorrido.

Para extraer campos individuales del resultado hay que llamar a la función db2_result().

En lugar de llamar a db2_fetch_row() y db2_result(), la mayoría de las aplicaciones utilizan las funciones db2_fetch_assoc(), db2_fetch_both() o db2_fetch_array() para avanzar el apuntador del bloque de resultados y devolver una fila completa como arreglo.

Parámetros

stmt

Un recurso stmt válido.

row_number

Con cursores de recorrido, se puede solicitar un número de fila específica del bloque de resultados. Las filas se indexan a partir de uno.

Valores devueltos

Devuelve true si la fila solicitada existe dentro de los resultados. Devuelve false si la fila solicitada no existe entre los resultados.

Ejemplos

Ejemplo #1 Iterando a través de un bloque de resultados

El siguiente ejemplo demuestra como iterar a través de los resultados con db2_fetch_row() y extraer las columnas del resultado con db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 1);
    print "$name $breed";
}
?>

El resultado del ejemplo sería:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Ejemplo #2 Alternativas recomendadas para db2_fetch_row/db2_result en i5/OS

En i5/OS se recomienda el uso de db2_fetch_both(), db2_fetch_array() o db2_fetch_object() en lugar de db2_fetch_row()/db2_result(). En general db2_fetch_row()/db2_result() tienen más problemas con la traducción de EBCIDIC a ASCII en algunos tipos de columnas, incluyendo posibles truncamientos en aplicaciones DBCS. Es posible que el rendimiento de db2_fetch_both(), db2_fetch_array() y db2_fetch_object() sea superior comparado con db2_fetch_row()/db2_result().

<?php
  $conn = db2_connect("","","");
  $sql = 'SELECT SPECIFIC_SCHEMA, SPECIFIC_NAME, ROUTINE_SCHEMA, ROUTINE_NAME, ROUTINE_TYPE, ROUTINE_CREATED, ROUTINE_BODY, IN_PARMS, OUT_PARMS, INOUT_PARMS, PARAMETER_STYLE, EXTERNAL_NAME, EXTERNAL_LANGUAGE FROM QSYS2.SYSROUTINES FETCH FIRST 2 ROWS ONLY';
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_both($stmt)){
    echo "<br>db2_fetch_both {$row['SPECIFIC_NAME']} {$row['ROUTINE_CREATED']} {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_array($stmt)){
    echo "<br>db2_fetch_array {$row[1]}  {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_object($stmt)){
    echo "<br>db2_fetch_object {$row->SPECIFIC_NAME} {$row->ROUTINE_CREATED}";
  }
  db2_close($conn);
?>

El resultado del ejemplo sería:

db2_fetch_both MATCH_ANIMAL 2006-08-25-17.10.23.775000 2006-08-25-17.10.23.775000
db2_fetch_both MULTIRESULTS 2006-10-17-10.11.05.308000 2006-10-17-10.11.05.308000
db2_fetch_array MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_array MULTIRESULTS 2006-10-17-10.11.05.308000
db2_fetch_object MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_object MULTIRESULTS 2006-10-17-10.11.05.308000

Ver también

  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_object() - Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_result() - Devolver una columna específica del resultado


Devolver el número máximo de bytes requeridos para mostrar una columna

  • « db2_fetch_row
  • db2_field_name »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el número máximo de bytes requeridos para mostrar una columna

db2_field_display_size

(PECL ibm_db2 >= 1.0.0)

db2_field_display_size — Devolver el número máximo de bytes requeridos para mostrar una columna

Descripción

db2_field_display_size ( resource $stmt , mixed $column ) : int

Devuelve el número máximo de bytes requeridos para mostrar una columna de un bloque de resultados.

Parámetros

stmt

Especifica un recurso válido que contiene los resultados.

column

Especifica la columna del resultado. Puede ser tanto un número entero que represente la posición de la columna (indexada a partir de cero) como una cadena con el nombre de la columna.

Valores devueltos

Devuelve un valor entero con el número máximo de bytes requeridos para mostrar una columna específica. Si la columna no existe en el resultado, db2_field_display_size() devuelve false.

Ver también

  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver el nombre de la columna indicada del resultado

  • « db2_field_display_size
  • db2_field_num »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el nombre de la columna indicada del resultado

db2_field_name

(PECL ibm_db2 >= 1.0.0)

db2_field_name — Devolver el nombre de la columna indicada del resultado

Descripción

db2_field_name ( resource $stmt , mixed $column ) : string

Devuelve el nombre de la columna especificada del resultado.

Parámetros

stmt

Especifica un recurso válido que contiene los resultados.

column

Especifica la columna en el resultado. Puede ser tanto un entero que represente la posición de la columna (indexadas a partir de cero) o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve una cadena con el nombre de la columna especificada. Si la columna especificada no existe en el resultado, db2_field_name() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver la posición de la columna indicada en un resultado

  • « db2_field_name
  • db2_field_precision »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver la posición de la columna indicada en un resultado

db2_field_num

(PECL ibm_db2 >= 1.0.0)

db2_field_num — Devolver la posición de la columna indicada en un resultado

Descripción

db2_field_num ( resource $stmt , mixed $column ) : int

Devuelve la posición de la columna especificada en un resultado.

Parámetros

stmt

Especifica un recurso válido que contiene los resultados.

column

Especifica la columna en el resultado. Puede ser tanto un entero que represente la posición de la columna (indexada a partir de cero), o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve un entero que contiene la posición de la columna (indexada a partir de cero) en el resultado. Si la columna especificada no existe en el resultado, db2_field_num() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver la precisión de la columna indicada en el resultado

  • « db2_field_num
  • db2_field_scale »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver la precisión de la columna indicada en el resultado

db2_field_precision

(PECL ibm_db2 >= 1.0.0)

db2_field_precision — Devolver la precisión de la columna indicada en el resultado

Descripción

db2_field_precision ( resource $stmt , mixed $column ) : int

Devuelve la precisión de la columna especificada en el resultado.

Parámetros

stmt

Especifica un recurso válido que contiene los resultados.

column

Especifica la columna en el resultado. Puede ser tanto un entero que represente la posición de la columna (indexada a partir de cero), o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve un entero que contiene la precisión de la columna especificada. Si la columna especifida no existe el el resultado, db2_field_precision() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver la escala de la columna indicada en el resultado

  • « db2_field_precision
  • db2_field_type »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver la escala de la columna indicada en el resultado

db2_field_scale

(PECL ibm_db2 >= 1.0.0)

db2_field_scale — Devolver la escala de la columna indicada en el resultado

Descripción

db2_field_scale ( resource $stmt , mixed $column ) : int

Devuelve la escala de la columna especificada en el resultado.

Parámetros

stmt

Especifica un recurso válido que contiene el resultado.

column

Especifica la columna en el resultado. Puede ser tanto un entero representando la posición de la columna (indexada a partir de cero), o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve un entero que contiene la escala de la columna especificada. Si la columna especificada no existe en el resultado, db2_field_scale() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver el tipo de dato de la columna indicada en un resultado

  • « db2_field_scale
  • db2_field_width »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el tipo de dato de la columna indicada en un resultado

db2_field_type

(PECL ibm_db2 >= 1.0.0)

db2_field_type — Devolver el tipo de dato de la columna indicada en un resultado

Descripción

db2_field_type ( resource $stmt , mixed $column ) : string

Devuelve el tipo de dato de la columna especificada en el resultado.

Parámetros

stmt

Especifica un recurso válido que contenga los resultados.

column

Especifica la columna en el resultado. Puede ser tanto un entero representando la posición de la columna (indexada a partir de cero), o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve una cadena que contiene el tipo de dato de la columna especificada. Si la columna especificada no existe en el resultado, db2_field_type() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver el tamaño del valor contenido en la columna indicada

  • « db2_field_type
  • db2_foreign_keys »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el tamaño del valor contenido en la columna indicada

db2_field_width

(PECL ibm_db2 >= 1.0.0)

db2_field_width — Devolver el tamaño del valor contenido en la columna indicada

Descripción

db2_field_width ( resource $stmt , mixed $column ) : int

Devuelve el tamaño del valor contenido en la columna especificada en el resultado. Este valor es el tamaño máximo de la columna para tipos de dato con tamaños fijos o el tamaño actual de la columna para tipos de dato con tamaños variables.

Parámetros

stmt

Especifica un recurso válido que contiene los resultados.

column

Especifica la columna en el resultado. Puede ser tanto un entero representando la posición de la columna (indexada a partir de cero), o una cadena que contenga el nombre de la columna.

Valores devueltos

Devuelve un entero que contiene el tamaño de la columna indicada, ya sea de tipo de dato binario o de caracter, en el resultado. Si la columna especificada no existe en el resultado, db2_field_width() devuelve false.

Ver también

  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado


Devolver un resultado que contenga las llaves foraneas de una tabla

  • « db2_field_width
  • db2_free_result »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un resultado que contenga las llaves foraneas de una tabla

db2_foreign_keys

(PECL ibm_db2 >= 1.0.0)

db2_foreign_keys — Devolver un resultado que contenga las llaves foraneas de una tabla

Descripción

db2_foreign_keys ( resource $connection , string $qualifier , string $schema , string $table-name ) : resource

Devuelve un resultado que contiene las llaves foraneas de una tabla.

Parámetros

connection

Una conexión válida a una base de datos IBM DB2, Cloudscape o Apache Derby.

qualifier

Un indice para bases de datos en DB2 ejecutándose en servidores OS/390 o z/OS. Para otras bases de datos se puede pasar null o una cadena vacia.

schema

El esquema que contiene las tablas. Si schema es null, db2_foreign_keys() busca en el esquema de la conexión actual.

table-name

El nombre de la tabla.

Valores devueltos

Devuelve un recurso con el resultado que contiene las filas con la información de las llaves foraneas de la tabla especificada. El resultado se compone de las siguientes columnas:

Nombre de la columna | Descripción
PKTABLE_CAT | Nombre del catálogo de la tabla que contiene la llave primaria. El valor es nulo si esta tabla no tiene catálogos.
PKTABLE_SCHEM | Nombre del esquema de la tabla que contiene la llave primaria.
PKTABLE_NAME | Nombre de la tabla que contiene la llave primaria.
PKCOLUMN_NAME | Nombre de la columna que contiene la llave primaria.
FKTABLE_CAT | Nombre del catálogo de la tabla que contiene la llave foranea. El valor es nulo si esta tala no tiene catálogos.
FKTABLE_SCHEM | Nombre del esquema que contiene la llave foranea.
FKTABLE_NAME | Nombre de la tabla que contiene la llave foranea.
FKCOLUMN_NAME | Nombre de la columna que contiene la llave foranea.
KEY_SEQ | Posición de la columna en la llave (indexada a partir de uno).
UPDATE_RULE | Valor entero que representa la acción a aplicarse en la llave foranea cuando ocurre alguna operación UPDATE.
DELETE_RULE | Valor entero que representa la acción a aplicarse en la llave foranea cuando ocurre alguna operación DELETE.
FK_NAME | El nombre de la llave foranea.
PK_NAME | El nombre de la llave primaria.
DEFERRABILITY | Valor entero que representa cuándo se checa que la llave foranea se cumpla, puede ser SQL_INITIALLY_DEFERRED, SQL_INITIALLY_IMMEDIATE o SQL_NOT_DEFERRABLE.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Liberar los recursos asociados con un resultado

  • « db2_foreign_keys
  • db2_free_stmt »
  • PHP Manual
  • Funciones de IBM DB2
  • Liberar los recursos asociados con un resultado

db2_free_result

(PECL ibm_db2 >= 1.0.0)

db2_free_result — Liberar los recursos asociados con un resultado

Descripción

db2_free_result ( resource $stmt ) : bool

Libera los recursos del Sistema y de la Base de Datos que están asociados con un resultado. Los recursos se liberan automáticamente cuando un script finaliza, pero se puede llamar a db2_free_result() para liberarlos en ese momento y no hasta que el script finalice.

Parámetros

stmt

Un recurso válido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • db2_free_stmt() - Liberar un recurso indicado


Liberar un recurso indicado

  • « db2_free_result
  • db2_get_option »
  • PHP Manual
  • Funciones de IBM DB2
  • Liberar un recurso indicado

db2_free_stmt

(PECL ibm_db2 >= 1.0.0)

db2_free_stmt — Liberar un recurso indicado

Descripción

db2_free_stmt ( resource $stmt ) : bool

Libera los recursos del Sistema y de la Base de Datos que están asociados con un determinado recurso (de sentencias). Los recursos son liberados automáticamente cuando un script finaliza, pero se puede llamar a db2_free_stmt() para liberarlos en ese momento y no hasta que el script finalice.

Parámetros

stmt

Un recurso (de sentencias) válido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • db2_free_result() - Liberar los recursos asociados con un resultado


Devolver el valor de la opción correpondiente a una conexión o sentencia

  • « db2_free_stmt
  • db2_last_insert_id »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el valor de la opción correpondiente a una conexión o sentencia

db2_get_option

(PECL ibm_db2 >= 1.6.0)

db2_get_option — Devolver el valor de la opción correpondiente a una conexión o sentencia

Descripción

db2_get_option ( resource $resource , string $option ) : string

Devuelve el valor de la opción especificada para una conexión o sentencia.

Parámetros

resource

Un recurso válido devuelto por
db2_prepare() o devuelto por
db2_connect() o
db2_pconnect().

option

Opciones válidas para la sentencia o conexión. Las nuevas opciones siguientes están disponibles a partir de la versión 1.6.0 de ibm_db2. Proveen información de rastreo útil que puede ser establecida durante la ejecución con db2_get_option().

Nota:

Las versiones anteriores de ibm_db2 no soportan estas nuevas opciones.

Cuando el valor de cada opción se establece, es posible que algunos servidores no manejen toda la longitud especificada y puede que el valor sea truncado.

Para asegurar que la información especificada en cada opción sea convertida correctamente cuando se transmita a un Host utilice únicamente caracteres de la A a la Z, 0 a 9, guiones bajos (_) y puntos (.).

userid

SQL_ATTR_INFO_USERID - Un apuntador a una cadena que representa el identificador del cliente enviado al servidor cuando se conecta al servidor usando db2_connect().

Nota:

Los servidores z/OS y OS/390 soportan longitudes hasta 16 caracteres. Este identificador de usuario no debe ser confundido con el usuario de autenticación, sólo es para propósitos de identificación y no se usa para autorización.

acctstr

SQL_ATTR_INFO_ACCTSTR - Un apuntador a una cadena utilizada para identificar la cuenta del cliente enviada al Host cuando se conecta al servidor usando db2_connect().

Nota:

Los servidores z/OS y OS/390 soportan longitudes de hasta 200 caracteres.

applname

SQL_ATTR_INFO_APPLNAME - Un apuntador a una cadena utilizada para identificar el nombre de la aplicación del cliente enviado al Host cuando se conecta al servidor usando db2_connect().

Nota:

Los servidores z/OS y OS/390 soportan longitudes de hasta 32 caracteres.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - Un apuntador a una cadena utilizada para identificar el nombre de la estación de trabajo del cliente enviado al Host cuando se conecta al servidor usando db2_connect().

Nota:

Los servidores z/OS y OS/390 soportan longitudes de hasta 18 caracteres.

La siguiente tabla especifica cuáles opciones son compatibles con los tipos de recurso disponibles:

Matriz Recursos-Paramétros
Clave | Valor | Tipo de recurso
 |  | Conección | Sentencia | Resultado
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Valores devueltos

Devuelve la configuración actual del atributo especificado en la conexión en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estableciendo y extrayendo parámetros a través de una conexión

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$user     = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($database, $user, $password);

echo "Client attributes passed through connection string:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes through connection string */
/* Access the options specified */
$options1 = array('userid' => 'db2inst1');
$conn1 = db2_connect($database, $user, $password, $options1);
$val = db2_get_option($conn1, 'userid');
echo $val . "\n";

$options2 = array('acctstr' => 'account');
$conn2 = db2_connect($database, $user, $password, $options2);
$val = db2_get_option($conn2, 'acctstr');
echo $val . "\n";

$options3 = array('applname' => 'myapp');
$conn3 = db2_connect($database, $user, $password, $options3);
$val = db2_get_option($conn3, 'applname');
echo $val . "\n";

$options4 = array('wrkstnname' => 'workstation');
$conn4 = db2_connect($database, $user, $password, $options4);
$val = db2_get_option($conn4, 'wrkstnname');
echo $val . "\n";

echo "Client attributes passed post-connection:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes after a connection is made */
/* Access the options specified */
$options5 = array('userid' => 'db2inst1');
$conn5 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn5, $options5, 1);
$val = db2_get_option($conn5, 'userid');
echo $val . "\n";

$options6 = array('acctstr' => 'account');
$conn6 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn6, $options6, 1);
$val = db2_get_option($conn6, 'acctstr');
echo $val . "\n";

$options7 = array('applname' => 'myapp');
$conn7 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn7, $options7, 1);
$val = db2_get_option($conn7, 'applname');
echo $val . "\n";

$options8 = array('wrkstnname' => 'workstation');
$conn8 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn8, $options8, 1);
$val = db2_get_option($conn8, 'wrkstnname');
echo $val . "\n";
?>

El resultado del ejemplo sería:

Client attributes passed through connection string:
db2inst1
account
myapp
workstation
Client attributes passed post-connection:
db2inst1
account
myapp
workstation

Ver también

  • db2_connect() - Devolver una conexión a la base de datos
  • db2_cursor_type() - Determinar el tipo de cursor utilizado en una consulta
  • db2_exec() - Ejecutar directamente una sentencia SQL
  • db2_set_option() - Set options for connection or statement resources
  • db2_pconnect() - Devolver una conexión persistente a la base de datos
  • db2_prepare() - Prepara un comando SQL para su ejecución


Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión

  • « db2_get_option
  • db2_lob_read »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión

db2_last_insert_id

(PECL ibm_db2 >= 1.7.1)

db2_last_insert_id — Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión

Descripción

db2_last_insert_id ( resource $resource ) : string

Devuelve el ID autogenerado de la última sentencia INSERT ejecutada correctamente en la conexión.

El resultado de esta función no se ve afectado por lo siguiente:

  • Una sentencia INSERT sencilla con la cláusula VALUES para una tabla sin una columna de identidad.

  • Una sentencia INSERT múltiple con la claúsula VALUES.

  • Una sentencia INSERT con FULLSELECT.

  • Una sentencia ROLLBACK.

Parámetros

resource

Una conexión válida devuelta por db2_connect() o db2_pconnect(). El valor de este parámetro no puede ser un recurso de sentencia o de resultado.

Valores devueltos

Devuelve el ID autogenerado de la última sentencia INSERT que se ejecutó correctamente en esta conexión.

Ejemplos

Ejemplo #1 Ejemplo de db2_last_insert_id()

El siguiente ejemplo muestra como devolver el ID autogenerado por la última sentencia INSERT ejecutada correctamente.

<?php

$database = "SAMPLE";
$user = "db2inst1";
$password = "ibmdb2";

$conn = db2_connect($database, $user, $password);
if($conn) {
    $createTable = "CREATE TABLE lastInsertID
      (id integer GENERATED BY DEFAULT AS IDENTITY, name varchar(20))";
    $insertTable = "INSERT INTO lastInsertID (name) VALUES ('Temp Name')";

    $stmt = @db2_exec($conn, $createTable);

    /* Checking for single row inserted. */
    $stmt = db2_exec($conn, $insertTable);
    $ret =  db2_last_insert_id($conn);
    if($ret) {
        echo "Last Insert ID is : " . $ret . "\n";
    } else {
        echo "No Last insert ID.\n";
    }

    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

El resultado del ejemplo sería:

Last Insert ID is : 1


Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB

  • « db2_last_insert_id
  • db2_next_result »
  • PHP Manual
  • Funciones de IBM DB2
  • Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB

db2_lob_read

(PECL ibm_db2 >= 1.6.0)

db2_lob_read — Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB

Descripción

db2_lob_read ( resource $stmt , int $colnum , int $length ) : string

db2_lob_read() se usa para iterar a través de una columna específica dentro de un resultado y extraer un segmento de datos LOB de tamaño definido por el usuario.

Parámetros

stmt

Un recurso stmt válido que contenga datos LOB.

colnum

Un número de columna válido en el resultado del recurso stmt.

length

El tamaño del segmento de datos LOB que se va a extraer del recurso stmt.

Valores devueltos

Devuelve la cantidad de datos que el usuario especifica. Devuelve false si los datos no pueden ser extraidos.

Ejemplos

Ejemplo #1 Iterando a través de diferentes tipos de datos

<?php

/* Database Connection Parameters */
$db = 'SAMPLE';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($db,$username,$password);

if ($conn) {
    $drop = 'DROP TABLE clob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE clob_stream (id INTEGER, my_clob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO clob_stream (id,my_clob) VALUES (1, ?)");
    $variable = "THIS IS A CLOB TEST. THIS IS A CLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_clob FROM clob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }

    $drop = 'DROP TABLE blob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE blob_stream (id INTEGER, my_blob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO blob_stream (id,my_blob) VALUES (1, ?)");
    $variable = "THIS IS A BLOB TEST. THIS IS A BLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_blob FROM blob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }
} else {
    echo 'no connection: ' . db2_conn_errormsg();
}

?>

El resultado del ejemplo sería:

Loop 0: THIS I
Loop 1: S A CL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  CLOB
Loop 6: TEST.
Loop 0: THIS I
Loop 1: S A BL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  BLOB
Loop 6: TEST.

Ver también

  • db2_bind_param() - Vincula una variable PHP a un parámetro de una sentencia SQL
  • db2_exec() - Ejecutar directamente una sentencia SQL
  • db2_execute() - Ejecutar una sentencia SQL preparada
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
  • db2_prepare() - Prepara un comando SQL para su ejecución
  • db2_result() - Devolver una columna específica del resultado


Solicitar el siguiente resultado de un procedimiento almacendo

  • « db2_lob_read
  • db2_num_fields »
  • PHP Manual
  • Funciones de IBM DB2
  • Solicitar el siguiente resultado de un procedimiento almacendo

db2_next_result

(PECL ibm_db2 >= 1.0.0)

db2_next_result — Solicitar el siguiente resultado de un procedimiento almacendo

Descripción

db2_next_result ( resource $stmt ) : resource

Un procedimiento almacenado puede o no devolver bloques de resultados. El primer resultado devuelto se maneja de la misma manera que se manejan los resultados devueltos por una sentencia SELECT normal, en cambio, para extraer el segundo y los siguientes bloques de un procedimiento almacenado se debe llamar a db2_next_result() y almacenar el resultado en una variable de PHP.

Parámetros

stmt

Una sentencia preparada devuelta por db2_exec() o db2_execute().

Valores devueltos

La función devuelve un nuevo recurso de sentencia que contiene el siguiente bloque de resultados si el procedimiento almacenado regresa otro bloque de resultados. La función devuelve false si el procedimiento almacenado no regresa otro resultado.

Ejemplos

Ejemplo #1 Llamando a un procedimiento almacenado que devuelve múltiples resultados

En el siguiente ejemplo, se llama a un procedimiento almacenado que devuelve tres bloques de resultados. El primer resultado se extrae directamente con el mismo recurso de sentencia que invoca a la instrucción CALL, el segundo y el tercer resultado se extraen con un recurso de sentencia devuelto por db2_next_result().

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
  $stmt = db2_exec($conn, 'CALL multiResults()');

  print "Fetching first result set\n";
  while ($row = db2_fetch_array($stmt)) {
    var_dump($row);
  }

  print "\nFetching second result set\n";
  $res = db2_next_result($stmt);
  if ($res) {
    while ($row = db2_fetch_array($res)) {
      var_dump($row);
    }
  }

  print "\nFetching third result set\n";
  $res2 = db2_next_result($stmt);
  if ($res2) {
    while ($row = db2_fetch_array($res2)) {
      var_dump($row);
    }
  }

  db2_close($conn);
}
?>

El resultado del ejemplo sería:

Fetching first result set
array(2) {
  [0]=>
  string(16) "Bubbles         "
  [1]=>
  int(3)
}
array(2) {
  [0]=>
  string(16) "Gizmo           "
  [1]=>
  int(4)
}

Fetching second result set
array(4) {
  [0]=>
  string(16) "Sweater         "
  [1]=>
  int(6)
  [2]=>
  string(5) "llama"
  [3]=>
  string(6) "150.00"
}
array(4) {
  [0]=>
  string(16) "Smarty          "
  [1]=>
  int(2)
  [2]=>
  string(5) "horse"
  [3]=>
  string(6) "350.00"
}

Fetching third result set
array(1) {
  [0]=>
  string(16) "Bubbles         "
}
array(1) {
  [0]=>
  string(16) "Gizmo           "
}


Devolver el número de campos que contiene un resultado

  • « db2_next_result
  • db2_num_rows »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el número de campos que contiene un resultado

db2_num_fields

(PECL ibm_db2 >= 1.0.0)

db2_num_fields — Devolver el número de campos que contiene un resultado

Descripción

db2_num_fields ( resource $stmt ) : int

Devuelve el número de campos que contiene un resultado. Esta función es muy útil cuando se manejan resultados devueltos por consultas generadas dinámicamente o para resultados devueltos por procedimientos almacenados, donde la aplicación no puede determinar de otro modo cómo extraer y utilizar los resultados.

Parámetros

stmt

Un recurso válido que contenga el resultado.

Valores devueltos

Devuelve un valor entero que representa el número de campos de un resultado asociado con el recurso especificado. Devuelve false si el recurso no es válido.

Ejemplos

Ejemplo #1 Extrayendo el número de campos de un resultado

El siguiente ejemplo demuestra cómo extraer el número de campos devueltos en un resultado.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, $sql);
$columns = db2_num_fields($stmt);

echo "There are {$columns} columns in the result set.";
?>

El resultado del ejemplo sería:

There are 4 columns in the result set.

Ver también

  • db2_execute() - Ejecutar una sentencia SQL preparada
  • db2_field_display_size() - Devolver el número máximo de bytes requeridos para mostrar una columna
  • db2_field_name() - Devolver el nombre de la columna indicada del resultado
  • db2_field_num() - Devolver la posición de la columna indicada en un resultado
  • db2_field_precision() - Devolver la precisión de la columna indicada en el resultado
  • db2_field_scale() - Devolver la escala de la columna indicada en el resultado
  • db2_field_type() - Devolver el tipo de dato de la columna indicada en un resultado
  • db2_field_width() - Devolver el tamaño del valor contenido en la columna indicada


Devolver el número de filas afectadas por una sentencia SQL

  • « db2_num_fields
  • db2_pclose »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver el número de filas afectadas por una sentencia SQL

db2_num_rows

(PECL ibm_db2 >= 1.0.0)

db2_num_rows — Devolver el número de filas afectadas por una sentencia SQL

Descripción

db2_num_rows ( resource $stmt ) : int

Devuelve el número de filas eliminadas, insertadas o actualizadas por una sentencia SQL.

Para determinar el número de filas que serán devueltas por una sentencia SELECT se puede utilizar una consulta de tipo SELECT COUNT(*) con los mismos predicados que la consulta original.

Si la aplicación revisa el número de filas devueltas por una sentencia SELECT comparando si el número de filas es cero, es mejor considerar modificar la aplicación intentando extraer la primer fila con db2_fetch_assoc(), db2_fetch_both(), db2_fetch_array(), o db2_fetch_row() y comparar si la función devuelve false.

Nota:

Si se utiliza una sentencia SELECT con un cursor de recorrido, db2_num_rows() devuelve el número de filas devueltas por la sentencia SELECT. Sin embargo, lo anterior requiere significativamente de mayores recursos para la aplicación, por lo tanto, si ésta es la única razón por la que se utilizan cursores de recorrido en la aplicación, es mejor utilizar cursores de no-recorrido así como una consulta SELECT COUNT(*) o utilizar el valor boolean devuelto por las funciones de extracción con el objetivo de lograr una mayor optimización.

Parámetros

stmt

Un recurso stmt válido que contenga el resultado.

Valores devueltos

Devuelve el número de filas afectadas por la última sentencia SQL asociada con el recurso indicado.


Cerrar una conexión persistente a la base de datos

  • « db2_num_rows
  • db2_pconnect »
  • PHP Manual
  • Funciones de IBM DB2
  • Cerrar una conexión persistente a la base de datos

db2_pclose

(PECL ibm_db2 >= 1.8.0)

db2_pclose — Cerrar una conexión persistente a la base de datos

Descripción

db2_pclose ( resource $resource ) : bool

Cierra una conexión cliente de DB2 creada con db2_pconnect() y devuelve los recursos correspondientes al servidor de la base de datos.

Nota:

Esta función solo está disponible en i5/OS es respuesta al sistema de administración de i5/OS.

Si se tiene una conexión persistente a DB2 creda con db2_pconnect(), se puede usar esta función para cerrar la conexión. Para evitar reducciones en el rendimiento de las conexiones, esta función solo debería usarse en casos especiales donde la conexión persistente no responda o la conexión no se necesite por mucho tiempo.

Parámetros

connection

Especifica una conexión cliente activa de DB2.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cerrando una conexión persistente

El siguiente ejemplo demuestra como cerrar una conexión a una base de datos en IBM DB2 i5/OS.

<?php
$conn = db2_pconnect('', '', '');
$rc = db2_pclose($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

El resultado del ejemplo sería:

Connection was successfully closed.

Ver también

  • db2_close() - Cierra una conexión a base de datos
  • db2_pconnect() - Devolver una conexión persistente a la base de datos


Devolver una conexión persistente a la base de datos

  • « db2_pclose
  • db2_prepare »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver una conexión persistente a la base de datos

db2_pconnect

(PECL ibm_db2 >= 1.0.0)

db2_pconnect — Devolver una conexión persistente a la base de datos

Descripción

db2_pconnect ( string $database , string $username , string $password , array $options = ? ) : resource

Devuelve una conexión persistente a una base de datos IBM DB2 Universal Database, IBM Cloudscape o Apache Derby.

Más información acerca de conexiones persistentes se puede encontrar en: Conexiones persistentes a bases de datos.

Si se llama a db2_close() en una conexión persistente, siempre se devolverá true, sin embargo la conexión permenecerá abierta en modo de espera para utilizarse en la siguiente solicitud de db2_pconnect().

Para las versiones 1.9.0 y superiores de ibm_db2, hay que considerar que al final de la solicitud siempre se ejecutará una cancelación ("rollback") de la transacción en la conexión persistente para terminar la transacción. Lo anterior evita que el bloqueo de información permanezca en la siguiente solicitud que utilice esa conexión.

Parámetros

database

El álias de la base de datos en al catálogo del cliente DB2.

username

El usuario con el se conecta a la base de datos.

password

La contraseña con la que se conecta a la base de datos.

options

Un arreglo asociativo de opciones que afectan el comportamiento de la conexión, entre las claves válidas están:

autocommit

Si se pasa el valor DB2_AUTOCOMMIT_ON se confirmarán automáticamente las transacciones de la conexión.

Si se pasa el valor DB2_AUTOCOMMIT_OFF no se confirmarán automáticamente las transacciones de la conexión.

DB2_ATTR_CASE

Si se pasa el valor DB2_CASE_NATURAL los nombres de las columnas serán devueltos con sus mayúsculas y minúsculas originales.

Si se pasa el valor DB2_CASE_LOWER los nombres de las columnas serán devueltos en minúsculas.

Si se pasa el valor DB2_CASE_UPPER los nombres de las columnas serán devueltos en mayúsculas.

CURSOR

Si se pasa el valor DB2_FORWARD_ONLY se establece un cursor de no-recorrido (sólo hacia adelante). Este cursor es predeterminado y soportado por todos los servidores de base de datos.

Si se pasa el valor DB2_SCROLLABLE se establece un cursor de recorrido. Con este modo es posible acceder de manera aleatoria a las filas del resultado pero actualmente sólo es soportado por IBM DB2 Universal Database.

Las siguientes opciones están disponibles en las versiones 1.7.0 y superiores de ibm_db2.

trustedcontext

Si se pasa el valor DB2_TRUSTED_CONTEXT_ENABLE se establece una conexión de confianza. Este parámetro no puede ser establecido mediante db2_set_option().

Esta clave solo funciona si la base de datos está catalogada (aún cuando la base de datos sea local), o si se especifica un DSN completo cuando se crea la conexión.

Para catalogar la base de datos se usan los siguientes comandos:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
db2 "update dbm cfg using svcename <SERVICENAME>"
db2set DB2COMM=TCPIP

Las siguientes opciones i5/OS están disponibles en las versiones 1.5.1 y superiores de ibm_db2.

Sugerencia

Si se utilizan atributos de conexión conflictivos en conexiones persistentes se pueden provocar resultados indeterminados en i5/OS. Las políticas de sitio deberían establecer el uso de perfiles con conexiones persistentes para todas las aplicacioneses. Se sugiere el uso de DB2_AUTOCOMMIT_ON en conexiones persistentes.

i5_lib

Una cadena que indica la lista de bibliotecas que se utilizará por default para resolver referencias no evaluadas a archivos. Este parámetro no es válido si en la conexión se utiliza el modo de nombrado de sistema.

i5_naming

DB2_I5_NAMING_ON habilita el modo de nombrado de sistema DB2 UDB CLI iSeries. Los archivos son evaluados utilizando una diagonal (/) como delimitador. Los archivos que no pueden ser evaluados son resueltos utilizando la lista de bibliotecas.

DB2_I5_NAMING_OFF esta valor predeterminado habilita el modo de nombrado DB2 UDB CLI, que es el sistema de nombrado de SQL. Los archivos son evaluados utilizando un punto (.) como delimitador. Los archivos que no se pueden evaluar son resueltos utilizando tanto la biblioteca predeterminada como el identificador del usuario actual.

i5_commit

Se recomienda establecer el parámetro i5_commit antes que db2_pconnect(). Si el valor es modificado después de que la conexión ha sido establecida y la conexión es hacia una fuente remota, el cambio no tendrá efecto hasta la siguiente llamada exitosa a db2_pconnect() para el manejo de conexión.

Nota:

El parámetro ibm_db2.i5_allow_commit==0 en php.ini o DB2_I5_TXN_NO_COMMIT son opciones predeterminadas pero pueden ser remplazadas con la opción i5_commit.

DB2_I5_TXN_NO_COMMIT - No se utiliza ningún control de transacciones.

DB2_I5_TXN_READ_UNCOMMITTED - Se permiten lecturas sucias, lecturas no repetibles, y lecturas fantasma.

DB2_I5_TXN_READ_COMMITTED - No se permiten lecturas sucias. Se permiten lecturas no repetibles y lecturas fantasma.

DB2_I5_TXN_REPEATABLE_READ - No se permiten lecturas sucias ni lecturas no repetibles. Se permiten lecturas fantasma.

DB2_I5_TXN_SERIALIZABLE - Las transacciones son serializables. No se permiten lecturas sucias, lecturas no repetibles ni lecturas fantasma.

i5_query_optimize

DB2_FIRST_IO - Todas las consultas son optimazadas con el objetivo de devolver la primera página de resultados lo más rápido posible. Esta opción se recomienda cuando el resultado es controlado por un usuario que puede cancelar la consulta después de visualizar la primera página de resultados. Esta funcionalidad también se puede lograr utilizando OPTIMIZE FOR nnn ROWS en una consulta.

DB2_ALL_IO - Todas las consultas son optimizadas con el objetivo de ejecutar la consulta completa en el menor tiempo posible. Esta opción predeterminada se recomienda cuando el resultado de una consulta es escrito en un archivo o reporte. Esta funcionalidad tambien se puede lograr utilizando OPTIMIZE FOR nnn ROWS en una consulta.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON habilita el esquema de alojamiento DB2 6X para incremento de tamaño en columnas de traducción DBCS.

DB2_I5_DBCS_ALLOC_OFF deshabilita el esquema de alojamiento DB2 6X para incremento de tamaño en columnas de traducción DBCS.

Nota:

El parámetro ibm_db2.i5_dbcs_alloc==0 en php.ini o DB2_I5_DBCS_ALLOC_OFF son opciones predeterminadas pero pueden ser remplazadas con la opción i5_dbcs_alloc.

i5_date_fmt

DB2_I5_FMT_ISO - Se utiliza el formato de fechas estandar (ISO) yyyy-mm-dd. Esta opción es predeterminada.

DB2_I5_FMT_USA - Se utiliza el formato de fechas de Estados Unidos mm/dd/yyyy.

DB2_I5_FMT_EUR - Se utiliza el formato de fechas Europeo dd.mm.yyyy.

DB2_I5_FMT_JIS - Se utiliza el formato de fechas Japonés yyyy-mm-dd.

DB2_I5_FMT_MDY - Se utiliza el formato de fechas mm/dd/yyyy.

DB2_I5_FMT_DMY - Se utiliza el formato de fechas dd/mm/yyyy.

DB2_I5_FMT_YMD - Se utiliza el formato de fechas yy/mm/dd.

DB2_I5_FMT_JUL - Se utiliza el formato de fechas Juliano yy/ddd.

DB2_I5_FMT_JOB - El formato de trabajo es utilizado.

i5_date_sep

DB2_I5_SEP_SLASH - Se utiliza una diagonal ( / ) como separador de fechas. Esta opción es predeterminada.

DB2_I5_SEP_DASH - Se utiliza un guión medio ( - ) como separador de fechas.

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador de fechas.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador de fechas.

DB2_I5_SEP_BLANK - Se utiliza un espacio como separador de fechas.

DB2_I5_SEP_JOB - Se utiliza el separador de fechas de trabajo.

i5_time_fmt

DB2_I5_FMT_ISO - Se utiliza el formato de tiempo estandar (ISO) hh.mm.ss. Esta opción es predeterminada.

DB2_I5_FMT_USA - Se utiliza el formato de tiempo de Estados Unidos hh:mmxx, donde xx es AM o PM.

DB2_I5_FMT_EUR - Se utiliza el formato de tiempo Europeo hh.mm.ss.

DB2_I5_FMT_JIS - Se utiliza el formato de tiempo Japonés hh:mm:ss.

DB2_I5_FMT_HMS - Se utiliza el formato de tiempo hh:mm:ss.

i5_time_sep

DB2_I5_SEP_COLON - Se utiliza el signo de dos puntos ( : ) como separador de tiempo. Esta opción es predeterminada.

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador de tiempo.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador de tiempo.

DB2_I5_SEP_BLANK - Se utiliza un espacio como separador de tiempo.

DB2_I5_SEP_JOB - Se utiliza el separador de tiempo de trabajo.

i5_decimal_sep

DB2_I5_SEP_PERIOD - Se utiliza un punto ( . ) como separador decimal. Esta opción es predeterminada.

DB2_I5_SEP_COMMA - Se utiliza una coma ( , ) como separador decimal.

DB2_I5_SEP_JOB - Se utiliza el separador decimal de trabajo.

La siguiente opción i5/OS está disponible en las versiones 1.8.0 y superiores de ibm_db2.

i5_libl

Un cadena que indica la lista de bibliotecas que se utilizará para resolver referencias no evaluadas a archivos. Se especifican los elementos de la lista separados por espacios 'i5_libl'=>"LIBRERIA1 LIBRERIA2 LIBRERIA3".

Nota:

i5_libl llama a qsys2/qcmdexc('cmd',cmdlen), que sólo está disponible en i5/OS V5R4 y versiones superiores.

Valores devueltos

Devuelve un recurso de conexión si el intento de conexión es exitoso. db2_pconnect() intenta reutilizar recursos de conexión existentes que coinciden exactamente con los parámetros database, username, y password. Si el intento de conexión falla db2_pconnect() devuelve false.

Historial de cambios

Versión | Descripción
ibm_db2 1.9.0 | Las transacciones activas en una conexión persistente serán canceladas al final de cada solicitud.
ibm_db2 1.8.0 | La opción i5_libl está disponible para los usuarios de i5/OS.
ibm_db2 1.7.0 | La opción trustedcontext está disponible.
ibm_db2 1.5.1 | Las opciones i5_lib, i5_naming, i5_commit, i5_query_optimize, i5_dbcs_alloc, i5_date_fmt, i5_date_sep, i5_time_fmt, i5_time_sep y i5_decimal_sep están disponibles para los usuarios de i5/OS.

Ejemplos

Ejemplo #1 Ejemplo de db2_pconnect()

En el siguiente ejemplo, la primera llamada a db2_pconnect() devuelve un nuevo recurso de conexión persistente. La segunda llamada a db2_pconnect() devuelve un recurso de conexión persistente que reutiliza el primer recurso.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$pconn = db2_pconnect($database, $user, $password);

if ($pconn) {
    echo "Persistent connection succeeded.";
}
else {
    echo "Persistent connection failed.";
}

$pconn2 = db2_pconnect($database, $user, $password);
if ($pconn) {
    echo "Second persistent connection succeeded.";
}
else {
    echo "Second persistent connection failed.";
}
?>

El resultado del ejemplo sería:

Persistent connection succeeded.
Second persistent connection succeeded.

Ejemplo #2 Utilizando contexto de confianza

El siguiente ejemplo muestra como habilitar el contexto de confianza, cambia usuarios y obtiene el identificador del usuario actual.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_pconnect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

El resultado del ejemplo sería:

Explicit trusted connection succeeded.
User has been switched.

Ver también

  • db2_connect() - Devolver una conexión a la base de datos


Prepara un comando SQL para su ejecución

  • « db2_pconnect
  • db2_primary_keys »
  • PHP Manual
  • Funciones de IBM DB2
  • Prepara un comando SQL para su ejecución

db2_prepare

(PECL ibm_db2 >= 1.0.0)

db2_prepare — Prepara un comando SQL para su ejecución

Descripción

db2_prepare ( resource $connection , string $statement , array $options = ? ) : resource

db2_prepare() Crea un comando SQL preparado que puede incluir 0 o más marcadores de parámetro (con el carácter ?) los cuales representan parámetros de entrada, salida o entrada/salida. Se pueden pasar parámetros al comando SQL preparado usando db2_bind_param(), o sólo para valores de entrada, como un arreglo enviado a db2_execute().

Hay tres ventajas principales al usar comandos SQL preparados en una aplicación:

  • Rendimiento: Cuando se prepara un comando SQL, el servidor de base de datos crea un plan de acceso optimizado para devolver datos con ese comando SQL. Posteriormente al enviar el comando SQL preparado a través de db2_execute() se podrá reutilizar el plan de acceso y así se evitará la sobrecarga que se produce cuando éste debe crearse nuevamente.

  • Seguridad: Cuando se prepara un comando SQL, se pueden incluir marcadores de parámetros para valores de entrada. Cuando se ejecuta ese comando usando los marcadores con valores de entrada, la base de datos puede chequear cada valor de entrada para asegurar que el tipo de dato enviado coincide con la definición del campo o del parámetro.

  • Funcionalidad avanzada: Los marcadores de parámetros no solo permiten pasar valores de entrada, además permiten obtener datos OUT e INOUT desde procedimientos almacenados usando db2_bind_param().

Parámetros

connection

Una variable de conexión obtenida con db2_connect() o con db2_pconnect().

statement

Un comando SQL, que puede contener opcionalmente uno o más marcadores de parámetros.

options

Un arreglo asociativo que contiene opciones para el comando. Se puede usar para solicitar un cursor desplazable en servidores que lo permitan.

Se pueden revisar las opciones en db2_set_option().

Valores devueltos

Si el comando SQL fue parseado y preparado exitosamente devuelve un resource, o false en caso de producirse un error. Se puede determinar qué error ocurrió utilizando db2_stmt_error() o db2_stmt_errormsg().

Ejemplos

Ejemplo #1 Preparando y ejecutando un comando SQL con marcadores de parámetros.

El siguiente ejemplo prepara un comando INSERT que acepta cuatro marcadores de parámetros, y luego ejecuta iteraciones sobre un arreglo que contiene los valores de entrada, y éstos son enviados a través de db2_execute().

<?php
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';
$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    foreach ($animals as $animal) {
        $result = db2_execute($stmt, $animal);
    }
}
?>

Ver también

  • db2_bind_param() - Vincula una variable PHP a un parámetro de una sentencia SQL
  • db2_execute() - Ejecutar una sentencia SQL preparada
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Devolver un resultado con las llaves primarias de una tabla

  • « db2_prepare
  • db2_procedure_columns »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un resultado con las llaves primarias de una tabla

db2_primary_keys

(PECL ibm_db2 >= 1.0.0)

db2_primary_keys — Devolver un resultado con las llaves primarias de una tabla

Descripción

db2_primary_keys ( resource $connection , string $qualifier , string $schema , string $table-name ) : resource

Devuelve un resultado con las llaves primarias de una tabla.

Parámetros

connection

Una conexión válida a la base de datos IBM DB2, Cloudscape, o Apache Derby.

qualifier

Un índice para bases de datos DB2 ejecutándose en servidores OS/390 o z/OS. Para otras bases de datos se debe pasar null o una cadena vacía.

schema

El esquema que contiene las tablas. Si schema es null, db2_primary_keys() revisa el esquema de la conexión actual.

table-name

El nombre de la tabla.

Valores devueltos

Devuelve un recurso de sentencia con el resultado que contiene las llaves primarias de la tabla especificada. El resultado se compone de las siguientes columnas:

Columna | Descripción
TABLE_CAT | Nombre del catálogo de la tabla que contiene la llave primaria. Este valor es nulo si la tabla no tiene catálogos.
TABLE_SCHEM | Nombre del esquema de la tabla que contiene la llave primaria.
TABLE_NAME | Nombre de la tabla que contiene la llave primaria.
COLUMN_NAME | Nombre de la columna que contiene la llave primaria.
KEY_SEQ | Posición (indexada a partir de uno) de la columna en la llave primaria.
PK_NAME | Nombre de la llave primaria.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Devolver un resultado con los parámetros de los procedimientos almacenados

  • « db2_primary_keys
  • db2_procedures »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un resultado con los parámetros de los procedimientos almacenados

db2_procedure_columns

(PECL ibm_db2 >= 1.0.0)

db2_procedure_columns — Devolver un resultado con los parámetros de los procedimientos almacenados

Descripción

db2_procedure_columns ( resource $connection , string $qualifier , string $schema , string $procedure , string $parameter ) : resource

Devuelve un resultado con los parámetros de uno o más procedimientos almacenados.

Parámetros

connection

Una conexión válida a una base de datos IBM DB2, Cloudscape, o Apache Derby.

qualifier

Un calificador para bases de datos ejecutándose en servidores OS/390 o z/OS. Para otras bases de datos se debe pasar null o una cadena vacia.

schema

El esquema que contiene los procedimientos. Este perámetro acepta las etiquetas _ y % para búsquedas de cadena.

procedure

El nombre del procedimiento. Este parámetro acepta las etiquetas _ y % para búsquedas de cadena.

parameter

El nombre del parámetro. Este parámetro acepta las etiquetas _ y % para búsquedas de cadena. Si el parámetro es null, todos los parámetros para el procedimiento almacenado serán devueltos.

Valores devueltos

Devuelve un recurso de sentencia con un bloque de resultados que contienen los parámetros de los procedimientos almacenados que coinciden con los criterios de búsqueda. Las filas devueltas se componen de las siguientes columnas:

Columna | Descripción
PROCEDURE_CAT | El catálogo que contiene el procedimiento. El valor es null si esta tabla no tiene catálogos.
PROCEDURE_SCHEM | Nombre del esquema que contiene el procedimiento almacenado.
PROCEDURE_NAME | Nombre del procedimiento.
COLUMN_NAME | Nombre del parámetro.
COLUMN_TYPE

Un valor entero que representa el tipo de parámetro:

Valor devuelto | Tipo de parámetro
1 (SQL_PARAM_INPUT) | Parámetro de entrada (IN).
2 (SQL_PARAM_INPUT_OUTPUT) | Parámetro de entrada/salida (INOUT).
3 (SQL_PARAM_OUTPUT) | Parámetro de salida (OUT).
DATA_TYPE | El tipo de dato SQL para el parámetro representado como un valor entero.
TYPE_NAME | El tipo de dato SQL para el parámetro en forma de cadena.
COLUMN_SIZE | Un valor entero que representa el tamaño del parámetro.
BUFFER_LENGTH | Número máximo de bytes necesarios para almacenar información del parámetro.
DECIMAL_DIGITS | La escala del parámetro o null si la escala no es aplicable.
NUM_PREC_RADIX | Un valor entero de 10 (que representa un tipo de dato numérico exacto), 2 (que representa un tipo de dato número aproximado), o null (que representa un tipo de dato sin base aplicable).
NULLABLE | Un valor entero que representa si un parámetro puede ser nulo o no.
REMARKS | Descripción del parámetro.
COLUMN_DEF | Valor predeterminado del parámetro.
SQL_DATA_TYPE | Un valor entero que representa el tamaño del parámetro.
SQL_DATETIME_SUB | Devuelve un valor entero que representa el código de un subtipo de dato fecha, o null para tipos de dato SQL donde esto no aplica.
CHAR_OCTET_LENGTH | Longitud máxima en octetos para parámetros con tipo de dato caracter, en cual coincide con COLUMN_SIZE para datos de caracter de un solo byte, o null para tipos de dato que no son caracter.
ORDINAL_POSITION | La posición (indexada a partir de uno) del parámetro en la sentencia.
IS_NULLABLE | Una cadena donde 'YES' significa que el parámetro acepta o devuelve valores null y donde 'NO' significa que el parámetro no acepta o devuelve valores null.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Devolver un resultado con los procedimientos almacenados registrados en la base de datos

  • « db2_procedure_columns
  • db2_result »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver un resultado con los procedimientos almacenados registrados en la base de datos

db2_procedures

(PECL ibm_db2 >= 1.0.0)

db2_procedures — Devolver un resultado con los procedimientos almacenados registrados en la base de datos

Descripción

db2_procedures ( resource $connection , string $qualifier , string $schema , string $procedure ) : resource

Devuelve un resultado con los procedimientos almacenados registrados en una base de datos.

Parámetros

connection

Una conexión válida a una base de datos IBM DB2, Cloudscape, o Apache Derby.

qualifier

Un calificador para bases de datos DB2 ejecutándose sobre servidores OS/390 o z/OS. Para otras bases de datos se puede pasar null o una cadena vacia.

schema

El esquema que contiene los procedimientos. Este parámetro acepta las etiquetas _ y % para realizar búsquedas de cadena.

procedure

El nombre del procedimiento. Este parámetro acepta las etiquetas _ y % para realizar búsquedas de cadena.

Valores devueltos

Devuelve un recurso de sentencia con un resultado que contiene las filas que representan a los procedimientos almacenados que coinciden con el criterio de búsqueda. Las filas se componen de las siguientes columnas:

Columna | Descripción
PROCEDURE_CAT | El catálogo que contiene el procedimiento. El valor es null si la tabla no tiene catálogos.
PROCEDURE_SCHEM | Nombre del esquema que contiene el procediento almacenado.
PROCEDURE_NAME | Nombre del procedimiento.
NUM_INPUT_PARAMS | Número de parámetros de entrada (IN) para el procedimiento almacenado.
NUM_OUTPUT_PARAMS | Número de parámetros de salida (OUT) para el procedimiento almacenado.
NUM_RESULT_SETS | Número de resultados devueltos por el procedimiento almacenado.
REMARKS | Descripción del procedimiento almacenido.
PROCEDURE_TYPE | Siempre devuelve 1, indicando que el procedimiento almacenado no devuelve un valor.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Devolver una columna específica del resultado

  • « db2_procedures
  • db2_rollback »
  • PHP Manual
  • Funciones de IBM DB2
  • Devolver una columna específica del resultado

db2_result

(PECL ibm_db2 >= 1.0.0)

db2_result — Devolver una columna específica del resultado

Descripción

db2_result ( resource $stmt , mixed $column ) : mixed

db2_result() devuelve el valor de una columna especificada en la fila actual del resultado. Se debe llamar primero a db2_fetch_row() antes de db2_result() para establecer el apuntador del resultado.

Parámetros

stmt

Un recurso stmt válido.

column

Tanto un entero que representa el campo del resultado (indexado a partir de cero) como una cadena con el nombre de la columna.

Valores devueltos

Devuelve el valor del campo solicitado si el campo existe en el resultado. Devuelve NULL y lanza una advertencia si el campo no existe.

Ejemplos

Ejemplo #1 Ejemplo de db2_result()

El siguiente ejemplo demuestra como iterar a través de un resultado con db2_fetch_row() y extrae columnas del resultdo mediante db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 'BREED');
    print "$name $breed";
}
?>

El resultado del ejemplo sería:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Ver también

  • db2_fetch_array() - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
  • db2_fetch_assoc() - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
  • db2_fetch_both() - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
  • db2_fetch_object() - Devolver un objeto con atributos que representan a las columnas de una fila extraida
  • db2_fetch_row() - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada


Cancelar una transacción

  • « db2_result
  • db2_server_info »
  • PHP Manual
  • Funciones de IBM DB2
  • Cancelar una transacción

db2_rollback

(PECL ibm_db2 >= 1.0.0)

db2_rollback — Cancelar una transacción

Descripción

db2_rollback ( resource $connection ) : bool

Cancela una transacción en progreso en el recurso de conexión especificado y comienza una nueva transacción. Comunmente las aplicaciones de PHP confirman las transacciones de manera automática por lo que la función db2_rollback() no tendría efecto a menos que este modo haya sido desactivado para este recurso.

Parámetros

connection

Un recurso de conexión válido devuelto por db2_connect() o db2_pconnect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cancelando una sentencia DELETE

En el siguiente ejemplo se cuenta el número de filas en una tabla, se cancelan las confirmaciones automáticas en la conexión, se eliminan todas las filas de la tabla y devuelve el total de 0 para confirmar que las filas se han borrado. Cuando se llama a db2_rollback() y se devuelve el total actualizado de filas en la tabla para demostrar que el número es igual al original (antes de ejecutar la sentancia DELETE). Esto demuestra que la cancelación de la transacción fue correcto.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Turn AUTOCOMMIT off
    db2_autocommit($conn, DB2_AUTOCOMMIT_OFF);

    // Delete all rows from ANIMALS
    db2_exec($conn, "DELETE FROM animals");

    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Roll back the DELETE statement
    db2_rollback( $conn );

    $stmt = db2_exec( $conn, "SELECT count(*) FROM animals" );
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";
    db2_close($conn);
}
?>

El resultado del ejemplo sería:

7
0
7

Ver también

  • db2_autocommit() - Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos
  • db2_commit() - Confirmar una transacción


Returns an object with properties that describe the DB2 database server

  • « db2_rollback
  • db2_set_option »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns an object with properties that describe the DB2 database server

db2_server_info

(PECL ibm_db2 >= 1.1.1)

db2_server_info — Returns an object with properties that describe the DB2 database server

Descripción

db2_server_info ( resource $connection ) : object

This function returns an object with read-only properties that return information about the IBM DB2, Cloudscape, or Apache Derby database server. The following table lists the database server properties:

Database server properties
Property name | Return type | Description
DBMS_NAME | string | The name of the database server to which you are connected. For DB2 servers this is a combination of DB2 followed by the operating system on which the database server is running.
DBMS_VER | string | The version of the database server, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
DB_CODEPAGE | int | The code page of the database to which you are connected.
DB_NAME | string | The name of the database to which you are connected.
DFT_ISOLATION string

The default transaction isolation level supported by the server:

UR

Uncommitted read: changes are immediately visible by all concurrent transactions.

CS

Cursor stability: a row read by one transaction can be altered and committed by a second concurrent transaction.

RS

Read stability: a transaction can add or remove rows matching a search condition or a pending transaction.

RR

Repeatable read: data affected by pending transaction is not available to other transactions.

NC

No commit: any changes are visible at the end of a successful operation. Explicit commits and rollbacks are not allowed.

IDENTIFIER_QUOTE_CHAR | string | The character used to delimit an identifier.
INST_NAME | string | The instance on the database server that contains the database.
ISOLATION_OPTION | array | An array of the isolation options supported by the database server. The isolation options are described in the DFT_ISOLATION property.
KEYWORDS | array | An array of the keywords reserved by the database server.
LIKE_ESCAPE_CLAUSE | bool | true if the database server supports the use of % and _ wildcard characters. false if the database server does not support these wildcard characters.
MAX_COL_NAME_LEN | int | Maximum length of a column name supported by the database server, expressed in bytes.
MAX_IDENTIFIER_LEN | int | Maximum length of an SQL identifier supported by the database server, expressed in characters.
MAX_INDEX_SIZE | int | Maximum size of columns combined in an index supported by the database server, expressed in bytes.
MAX_PROC_NAME_LEN | int | Maximum length of a procedure name supported by the database server, expressed in bytes.
MAX_ROW_SIZE | int | Maximum length of a row in a base table supported by the database server, expressed in bytes.
MAX_SCHEMA_NAME_LEN | int | Maximum length of a schema name supported by the database server, expressed in bytes.
MAX_STATEMENT_LEN | int | Maximum length of an SQL statement supported by the database server, expressed in bytes.
MAX_TABLE_NAME_LEN | int | Maximum length of a table name supported by the database server, expressed in bytes.
NON_NULLABLE_COLUMNS | bool | true if the database server supports columns that can be defined as NOT NULL, false if the database server does not support columns defined as NOT NULL.
PROCEDURES | bool | true if the database server supports the use of the CALL statement to call stored procedures, false if the database server does not support the CALL statement.
SPECIAL_CHARS | string | A string containing all of the characters other than a-Z, 0-9, and underscore that can be used in an identifier name.
SQL_CONFORMANCE string

The level of conformance to the ANSI/ISO SQL-92 specification offered by the database server:

ENTRY

Entry-level SQL-92 compliance.

FIPS127

FIPS-127-2 transitional compliance.

FULL

Full level SQL-92 compliance.

INTERMEDIATE

Intermediate level SQL-92 compliance.

Parámetros

connection

Specifies an active DB2 client connection.

Valores devueltos

Returns an object on a successful call. Returns false on failure.

Ejemplos

Ejemplo #1 A db2_server_info() example

To retrieve information about the server, you must pass a valid database connection resource to db2_server_info().

<?php

$conn = db2_connect('sample', 'db2inst1', 'ibmdb2');

$server = db2_server_info( $conn );

if ($server) {
    echo "DBMS_NAME: ";                 var_dump( $server->DBMS_NAME );
    echo "DBMS_VER: ";                  var_dump( $server->DBMS_VER );
    echo "DB_CODEPAGE: ";               var_dump( $server->DB_CODEPAGE );
    echo "DB_NAME: ";                   var_dump( $server->DB_NAME );
    echo "INST_NAME: ";                 var_dump( $server->INST_NAME );
    echo "SPECIAL_CHARS: ";             var_dump( $server->SPECIAL_CHARS );
    echo "KEYWORDS: ";                  var_dump( sizeof($server->KEYWORDS) );
    echo "DFT_ISOLATION: ";             var_dump( $server->DFT_ISOLATION );
    echo "ISOLATION_OPTION: ";
    $il = '';
    foreach( $server->ISOLATION_OPTION as $opt )
    {
       $il .= $opt." ";
    }
    var_dump( $il );
    echo "SQL_CONFORMANCE: ";           var_dump( $server->SQL_CONFORMANCE );
    echo "PROCEDURES: ";                var_dump( $server->PROCEDURES );
    echo "IDENTIFIER_QUOTE_CHAR: ";     var_dump( $server->IDENTIFIER_QUOTE_CHAR );
    echo "LIKE_ESCAPE_CLAUSE: ";        var_dump( $server->LIKE_ESCAPE_CLAUSE );
    echo "MAX_COL_NAME_LEN: ";          var_dump( $server->MAX_COL_NAME_LEN );
    echo "MAX_ROW_SIZE: ";              var_dump( $server->MAX_ROW_SIZE );
    echo "MAX_IDENTIFIER_LEN: ";        var_dump( $server->MAX_IDENTIFIER_LEN );
    echo "MAX_INDEX_SIZE: ";            var_dump( $server->MAX_INDEX_SIZE );
    echo "MAX_PROC_NAME_LEN: ";         var_dump( $server->MAX_PROC_NAME_LEN );
    echo "MAX_SCHEMA_NAME_LEN: ";       var_dump( $server->MAX_SCHEMA_NAME_LEN );
    echo "MAX_STATEMENT_LEN: ";         var_dump( $server->MAX_STATEMENT_LEN );
    echo "MAX_TABLE_NAME_LEN: ";        var_dump( $server->MAX_TABLE_NAME_LEN );
    echo "NON_NULLABLE_COLUMNS: ";      var_dump( $server->NON_NULLABLE_COLUMNS );

    db2_close($conn);
}
?>

El resultado del ejemplo sería:

DBMS_NAME: string(9) "DB2/LINUX"
DBMS_VER: string(10) "08.02.0000"
DB_CODEPAGE: int(1208)
DB_NAME: string(6) "SAMPLE"
INST_NAME: string(8) "db2inst1"
SPECIAL_CHARS: string(2) "@#"
KEYWORDS: int(179)
DFT_ISOLATION: string(2) "CS"
ISOLATION_OPTION: string(12) "UR CS RS RR "
SQL_CONFORMANCE: string(7) "FIPS127"
PROCEDURES: bool(true)
IDENTIFIER_QUOTE_CHAR: string(1) """
LIKE_ESCAPE_CLAUSE: bool(true)
MAX_COL_NAME_LEN: int(30)
MAX_ROW_SIZE: int(32677)
MAX_IDENTIFIER_LEN: int(18)
MAX_INDEX_SIZE: int(1024)
MAX_PROC_NAME_LEN: int(128)
MAX_SCHEMA_NAME_LEN: int(30)
MAX_STATEMENT_LEN: int(2097152)
MAX_TABLE_NAME_LEN: int(128)
NON_NULLABLE_COLUMNS: bool(true)

Ver también

  • db2_client_info() - Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2


Set options for connection or statement resources

  • « db2_server_info
  • db2_special_columns »
  • PHP Manual
  • Funciones de IBM DB2
  • Set options for connection or statement resources

db2_set_option

(PECL ibm_db2 >= 1.0.0)

db2_set_option — Set options for connection or statement resources

Descripción

db2_set_option ( resource $resource , array $options , int $type ) : bool

Sets options for a statement resource or a connection resource. You cannot set options for result set resources.

Parámetros

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

options

An associative array containing valid statement or connection options. This parameter can be used to change autocommit values, cursor types (scrollable or forward), and to specify the case of the column names (lower, upper, or natural) that will appear in a result set.

autocommit

Passing DB2_AUTOCOMMIT_ON turns autocommit on for the specified connection resource.

Passing DB2_AUTOCOMMIT_OFF turns autocommit off for the specified connection resource.

cursor

Passing DB2_FORWARD_ONLY specifies a forward-only cursor for a statement resource. This is the default cursor type, and is supported by all database servers.

Passing DB2_SCROLLABLE specifies a scrollable cursor for a statement resource. Scrollable cursors enable result set rows to be accessed in non-sequential order, but are only supported by IBM DB2 Universal Database databases.

binmode

Passing DB2_BINARY specifies that binary data will be returned as is. This is the default mode. This is the equivalent of setting ibm_db2.binmode=1 in php.ini.

Passing DB2_CONVERT specifies that binary data will be converted to hexadecimal encoding, and will be returned as such. This is the equivalent of setting ibm_db2.binmode=2 in php.ini.

Passing DB2_PASSTHRU specifies that binary data will be converted to null. This is the equivalent of setting ibm_db2.binmode=3 in php.ini.

db2_attr_case

Passing DB2_CASE_LOWER specifies that column names of the result set are returned in lower case.

Passing DB2_CASE_UPPER specifies that column names of the result set are returned in upper case.

Passing DB2_CASE_NATURAL specifies that column names of the result set are returned in natural case.

deferred_prepare

Passing DB2_DEFERRED_PREPARE_ON turns deferred prepare on for the specified statement resource.

Passing DB2_DEFERRED_PREPARE_OFF turns deferred prepare off for the specified statement resource.

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later. These options apply only when running PHP and ibm_db2 natively on i5 systems.

i5_fetch_only

DB2_I5_FETCH_ON - Cursors are read-only and cannot be used for positioned updates or deletes. This is the default unless SQL_ATTR_FOR_FETCH_ONLY environment has been set to SQL_FALSE.

DB2_I5_FETCH_OFF - Cursors can be used for positioned updates and deletes.

The following new option is available in ibm_db2 version 1.8.0 and later.

rowcount

DB2_ROWCOUNT_PREFETCH_ON - Client can request the full row count prior to fetching, which means that db2_num_rows() returns the number of rows selected even when a ROLLFORWARD_ONLY cursor is used.

DB2_ROWCOUNT_PREFETCH_OFF - Client cannot request the full row count prior to fetching.

The following new options are available in ibm_db2 version 1.7.0 and later.

trusted_user

To switch the user to a trusted user, pass the User ID (String) of the trusted user as the value of this key. This option can be set on a connection resource only. To use this option, trusted context must be enabled on the connection resource.

trusted_password

The password (String) that corresponds to the user specified by the trusted_user key.

The following new options are available in ibm_db2 version 1.6.0 and later. These options provide useful tracking information that can be accessed during execution with db2_get_option().

Nota:

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Nota:

DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Nota:

DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Nota:

DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Nota:

DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

type

An integer value that specifies the type of resource that was passed into the function. The type of resource and this value must correspond.

Passing 1 as the value specifies that a connection resource has been passed into the function.

Passing any integer not equal to 1 as the value specifies that a statement resource has been passed into the function.

The following table specifies which options are compatible with the available resource types:

Resource-Parameter Matrix
Key | Value | Resource Type
 |  | Connection | Statement | Result Set
autocommit | DB2_AUTOCOMMIT_ON | X | - | -
autocommit | DB2_AUTOCOMMIT_OFF | X | - | -
cursor | DB2_SCROLLABLE | - | X | -
cursor | DB2_FORWARD_ONLY | - | X | -
binmode | DB2_BINARY | X | X | -
binmode | DB2_CONVERT | X | X | -
binmode | DB2_PASSTHRU | X | X | -
db2_attr_case | DB2_CASE_LOWER | X | X | -
db2_attr_case | DB2_CASE_UPPER | X | X | -
db2_attr_case | DB2_CASE_NATURAL | X | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_ON | - | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_OFF | - | X | -
i5_fetch_only | DB2_I5_FETCH_ON | - | X | -
i5_fetch_only | DB2_I5_FETCH_OFF | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_ON | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_OFF | - | X | -
trusted_user | <USER NAME> (String) | X | - | -
trusted_password | <PASSWORD> (String) | X | - | -
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Setting one parameter with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_ON);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Options Set Successfully

Ejemplo #2 Setting multiple parameters with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Options Set Successfully

Ejemplo #3 Setting multiple parameters with an invalid key

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
             'MY_INVALID_KEY' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Could Not Set Options

Ejemplo #4 Setting multiple parameters with an invalid value

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => 'INVALID_VALUE',
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Could Not Set Options

Ejemplo #5 Setting multiple parameters with a connection resource and the wrong type

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and the wrong type value */
$result = db2_set_option($conn, $options, 2);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Could Not Set Options

Ejemplo #6 Setting multiple parameters with the wrong resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE');

/* Call the function using the wrong resource, and the correct options array, and type values */
$result = db2_set_option($stmt, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

El resultado del ejemplo sería:

Could Not Set Options

Ejemplo #7 Putting it all together

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('db2_attr_case' => DB2_CASE_LOWER,
                        'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE WHERE EMPNO = ? OR EMPNO = ?');

/* Call the function using the correct resource, options array, and type values */
$option_result = db2_set_option($stmt, $options, 2);
$result = db2_execute($stmt, array('000130', '000140'));

/* Get Row 2 before Row 1 since Scrollable Cursor */
print_r(db2_fetch_assoc($stmt, 2));
print '<br /><br />';
print_r(db2_fetch_assoc($stmt, 1));

?>

El resultado del ejemplo sería:

Array
(
    [empno] => 000140
    [firstnme] => HEATHER
    [midinit] => A
    [lastname] => NICHOLLS
    [workdept] => C01
    [phoneno] => 1793
    [hiredate] => 1976-12-15
    [job] => ANALYST
    [edlevel] => 18
    [sex] => F
    [birthdate] => 1946-01-19
    [salary] => 28420.00
    [bonus] => 600.00
    [comm] => 2274.00
)

Array
(
    [empno] => 000130
    [firstnme] => DELORES
    [midinit] => M
    [lastname] => QUINTANA
    [workdept] => C01
    [phoneno] => 4578
    [hiredate] => 1971-07-28
    [job] => ANALYST
    [edlevel] => 16
    [sex] => F
    [birthdate] => 1925-09-15
    [salary] => 23800.00
    [bonus] => 500.00
    [comm] => 1904.00
)

Ejemplo #8 i5/OS cursors are read-only

<?php
  $conn = db2_connect("", "", "", array("i5_lib"=>"nobody"));
  $stmt = db2_prepare($conn, 'select * from names where first = ?');
  $name = "first2";
  db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
  $options = array("i5_fetch_only"=>DB2_I5_FETCH_ON);
  db2_set_option($stmt,$options,0);
  if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
      echo "{$row[0]} {$row[1]}";
    }
  }
?>

El resultado del ejemplo sería:

first2 last2

Ver también

  • db2_connect() - Devolver una conexión a la base de datos
  • db2_pconnect() - Devolver una conexión persistente a la base de datos
  • db2_exec() - Ejecutar directamente una sentencia SQL
  • db2_prepare() - Prepara un comando SQL para su ejecución
  • db2_cursor_type() - Determinar el tipo de cursor utilizado en una consulta


Returns a result set listing the unique row identifier columns for a table

  • « db2_set_option
  • db2_statistics »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a result set listing the unique row identifier columns for a table

db2_special_columns

(PECL ibm_db2 >= 1.0.0)

db2_special_columns — Returns a result set listing the unique row identifier columns for a table

Descripción

db2_special_columns ( resource $connection , string $qualifier , string $schema , string $table_name , int $scope ) : resource

Returns a result set listing the unique row identifier columns for a table.

Parámetros

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables.

table_name

The name of the table.

scope

Integer value representing the minimum duration for which the unique row identifier is valid. This can be one of the following values:

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.

Valores devueltos

Returns a statement resource with a result set containing rows with unique row identifier information for a table. The rows are composed of the following columns:

Column name | Description
SCOPE

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.
COLUMN_NAME | Name of the unique column.
DATA_TYPE | SQL data type for the column.
TYPE_NAME | Character string representation of the SQL data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or null where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or null (representing a data type for which radix is not applicable).
PSEUDO_COLUMN | Always returns 1.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the index and statistics for a table

  • « db2_special_columns
  • db2_stmt_error »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a result set listing the index and statistics for a table

db2_statistics

(PECL ibm_db2 >= 1.0.0)

db2_statistics — Returns a result set listing the index and statistics for a table

Descripción

db2_statistics ( resource $connection , string $qualifier , string $schema , string $table-name , bool $unique ) : resource

Returns a result set listing the index and statistics for a table.

Parámetros

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema that contains the targeted table. If this parameter is null, the statistics and indexes are returned for the schema of the current user.

table_name

The name of the table.

unique

An integer value representing the type of index information to return.

0

Return only the information for unique indexes on the table.

1

Return the information for all indexes on the table.

Valores devueltos

Returns a statement resource with a result set containing rows describing the statistics and indexes for the base tables matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
NON_UNIQUE

An integer value representing whether the index prohibits unique values, or whether the row represents statistics on the table itself:

Return value | Parameter type
0 (SQL_FALSE) | The index allows duplicate values.
1 (SQL_TRUE) | The index values must be unique.
null | This row is statistics information for the table itself.
INDEX_QUALIFIER | A string value representing the qualifier that would have to be prepended to INDEX_NAME to fully qualify the index.
INDEX_NAME | A string representing the name of the index.
TYPE

An integer value representing the type of information contained in this row of the result set:

Return value | Parameter type
0 (SQL_TABLE_STAT) | The row contains statistics about the table itself.
1 (SQL_INDEX_CLUSTERED) | The row contains information about a clustered index.
2 (SQL_INDEX_HASH) | The row contains information about a hashed index.
3 (SQL_INDEX_OTHER) | The row contains information about a type of index that is neither clustered nor hashed.
ORDINAL_POSITION | The 1-indexed position of the column in the index. null if the row contains statistics information about the table itself.
COLUMN_NAME | The name of the column in the index. null if the row contains statistics information about the table itself.
ASC_OR_DESC | A if the column is sorted in ascending order, D if the column is sorted in descending order, null if the row contains statistics information about the table itself.
CARDINALITY

If the row contains information about an index, this column contains an integer value representing the number of unique values in the index.

If the row contains information about the table itself, this column contains an integer value representing the number of rows in the table.

PAGES

If the row contains information about an index, this column contains an integer value representing the number of pages used to store the index.

If the row contains information about the table itself, this column contains an integer value representing the number of pages used to store the table.

FILTER_CONDITION | Always returns null.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a string containing the SQLSTATE returned by an SQL statement

  • « db2_statistics
  • db2_stmt_errormsg »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a string containing the SQLSTATE returned by an SQL statement

db2_stmt_error

(PECL ibm_db2 >= 1.0.0)

db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement

Descripción

db2_stmt_error ( resource $stmt = ? ) : string

Returns a string containing the SQLSTATE value returned by an SQL statement.

If you do not pass a statement resource as an argument to db2_stmt_error(), the driver returns the SQLSTATE value associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_stmt_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

Parámetros

stmt

A valid statement resource.

Valores devueltos

Returns a string containing an SQLSTATE value.

Ver también

  • db2_conn_error() - Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
  • db2_conn_errormsg() - Devolver el último mensaje de error de la conexión y su valor SQLCODE
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Returns a string containing the last SQL statement error message

  • « db2_stmt_error
  • db2_table_privileges »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a string containing the last SQL statement error message

db2_stmt_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_stmt_errormsg — Returns a string containing the last SQL statement error message

Descripción

db2_stmt_errormsg ( resource $stmt = ? ) : string

Returns a string containing the last SQL statement error message.

If you do not pass a statement resource as an argument to db2_stmt_errormsg(), the driver returns the error message associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

Parámetros

stmt

A valid statement resource.

Valores devueltos

Returns a string containing the error message and SQLCODE value for the last error that occurred issuing an SQL statement.

Ver también

  • db2_conn_error() - Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
  • db2_conn_errormsg() - Devolver el último mensaje de error de la conexión y su valor SQLCODE
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement


Returns a result set listing the tables and associated privileges in a database

  • « db2_stmt_errormsg
  • db2_tables »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a result set listing the tables and associated privileges in a database

db2_table_privileges

(PECL ibm_db2 >= 1.0.0)

db2_table_privileges — Returns a result set listing the tables and associated privileges in a database

Descripción

db2_table_privileges ( resource $connection , string $qualifier = ? , string $schema = ? , string $table_name = ? ) : resource

Returns a result set listing the tables and associated privileges in a database.

Parámetros

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table_name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

Valores devueltos

Returns a statement resource with a result set containing rows describing the privileges for the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege that has been granted. This can be one of ALTER, CONTROL, DELETE, INDEX, INSERT, REFERENCES, SELECT, or UPDATE.
IS_GRANTABLE | A string value of "YES" or "NO" indicating whether the grantee can grant the privilege to other users.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the tables and associated metadata in a database

  • « db2_table_privileges
  • Ingres »
  • PHP Manual
  • Funciones de IBM DB2
  • Returns a result set listing the tables and associated metadata in a database

db2_tables

(PECL ibm_db2 >= 1.0.0)

db2_tables — Returns a result set listing the tables and associated metadata in a database

Descripción

db2_tables ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $table-type = ? ) : resource

Returns a result set listing the tables and associated metadata in a database.

Parámetros

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table-name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

table-type

A list of comma-delimited table type identifiers. To match all table types, pass null or an empty string. Valid table type identifiers include: ALIAS, HIERARCHY TABLE, INOPERATIVE VIEW, NICKNAME, MATERIALIZED QUERY TABLE, SYSTEM TABLE, TABLE, TYPED TABLE, TYPED VIEW, and VIEW.

Valores devueltos

Returns a statement resource with a result set containing rows describing the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
TABLE_TYPE | Table type identifier for the table.
REMARKS | Description of the table.

Ver también

  • db2_column_privileges() - Obtiene la lista de columnas y permisos asociados a una tabla
  • db2_columns() - Devuelve los campos de una tabla y sus metadatos asociados.
  • db2_foreign_keys() - Devolver un resultado que contenga las llaves foraneas de una tabla
  • db2_primary_keys() - Devolver un resultado con las llaves primarias de una tabla
  • db2_procedure_columns() - Devolver un resultado con los parámetros de los procedimientos almacenados
  • db2_procedures() - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database


Ingres DBMS, EDBC, y Enterprise Access Gateways

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones de Ingres
    • ingres_autocommit_state — Comprueba si la conexión usa la autoconsigna
    • ingres_autocommit — Activa o desactiva la autoconsigna
    • ingres_charset — Devuelve el conjunto de caracteres de la instalación
    • ingres_close — Cierra una conexión a una base de datos de Ingres
    • ingres_commit — Consigna una trasacción
    • ingres_connect — Abre una conexión a una base de datos de Ingres
    • ingres_cursor — Obtiene el nombre de un cursor de un recurso de resultados dado
    • ingres_errno — Obtiene el número del último error generado de Ingres
    • ingres_error — Obtener un mensaje de error coherente del último error generado
    • ingres_errsqlstate — Obtiene el código del último error SQLSTATE generado
    • ingres_escape_string — Escapa caracteres especiales para usuarlos en una consulta
    • ingres_execute — Ejecuta una consulta preparada
    • ingres_fetch_array — Obtiene una fila de resultados en un array
    • ingres_fetch_assoc — Obtienen una fila de resultados en un array asociativo
    • ingres_fetch_object — Obtiene una fila de resultados en un objeto
    • ingres_fetch_proc_return — Obtiene el valor de retorno de una llamada a un procedimiento
    • ingres_fetch_row — Obtiene una fila de resultados en un array enumerado
    • ingres_field_length — Obtiene la longitud de un campo
    • ingres_field_name — Obtiene el nombre de un campo de un resultado de una consulta
    • ingres_field_nullable — Comprueba si un campo puede contener valores null
    • ingres_field_precision — Obtiene la precisión de un campo
    • ingres_field_scale — Obtiene la escala de un campo
    • ingres_field_type — Obtiene el tipo de un campo de un resultado de una consulta
    • ingres_free_result — Libera los recursos asociados a un identificador de resultados
    • ingres_next_error — Obtiene el siguiente error de Ingres
    • ingres_num_fields — Obtiene el número de campos devueltos por la última consulta
    • ingres_num_rows — Obtener el número de filas afectadas o devueltas por una consulta
    • ingres_pconnect — Abre una conexión persistente a una base de datos de Ingres
    • ingres_prepare — Prepara una consulta para su ejecución posterior
    • ingres_query — Envía una consulta SQL a Ingres
    • ingres_result_seek — Establece la posición de una fila antes de obtener datos
    • ingres_rollback — Revierte una transacción
    • ingres_set_environment — Establece las características de entorno que controlan las opciones de salida
    • ingres_unbuffered_query — Envía una consulta SQL no almacenada en búfer a Ingres


Introducción

El controlador Ingres para PHP permite conectarse y realizar consultas a Ingres DBMS, EDBC, y Enterprise Access Gateways.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.1.0.


Requerimientos

Para utilizar o compilar la extensión de PHP para Ingres se ha de tener un cliente Ingres funcionando. Se puede descargar el software cliente de Ingres desde » http://esd.ingres.com/.


Instalación

Esta extensión » PECL no se distribuye con PHP. Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ingres.

Se puede descargar la DLL para esta extensión PECL desde » http://esd.ingres.com/product/drivers/PHP/.

Para que estas funciones estén disponibles, se ha de » descargar y compilar esta extensión, habilitando el soporte para Ingres mediante la opción --with-ingres[=DIR], donde DIR es el directorio base de Ingres. Si la variable de entorno II_SYSTEM no está establecida correctamente, podría ser necesario usar --with-ingres=DIR para especificar el directorio de instalación de Ingres.

El código de PHP escrito para las versiones 2.x y posteriores no es retrocompatible con versiones anteriores de esta extensión para PHP. Sin embargo, es posible ejecutar dos versiones incompatibles dentro del mismo entorno de PHP usando la opción --enable-ingres2. Esta opción de configuración renombra la extensión a ingres2, cambiando los nombres de las funciones, los ajustes de configuración, y las constantes. Por ejemplo, con esta opción habilitada, ingres_connect() se convertirá en ingres2_connect().

Para usar esta extensión, la variable de entorno de sistema II_SYSTEM debe estar definida. Los usuarios de Linux y UNIX también necesitarán definir la rúta de búsqueda de las bibliotecas compartidas, por ejemplo, LD_LIBRARY_PATH. Cuando se usa junto con el servidor web Apache, estas variables deben estar explícitamente establecidas en el script de arranque de Apache. Además, se requiere la directiva PassEnv para que la extensión Ingres carque las bibliotecas compartidas correctar. Por ejemplo:

Ejemplo #1 Ejemplo de uso de PassEnv para Ingres

<IfModule mod_env.c>
    PassEnv II_SYSTEM
    PassEnv LD_LIBRARY_PATH
</IfModule>

Nota:

Para ejemplos de configuraciones de diferentes servidores web y sistemas operativos, véase » http://community.ingres.com/wiki/Ingres_Articles#Ingres_and_Web_Servers.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Ingres
Nombre | Por defecto | Cambiable | Historial de cambios
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Disponible desde ingres 1.4.0
ingres.auto | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Disponible desde ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Disponible desde ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Disponible desde ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

ingres.allow_persistent boolean

Especifica si se pertmiten conexiones persistentes a Ingres

ingres.array_index_start integer

Especifica el valor inicial de una clave de número entero para arrays generados por ingres_fetch_row() o por ingres_fetch_array(). Por omisión, ingres.array_index_start está establecido a 1. Si se quiere que la extensión ignres funciones como otras extensiones de bases de datos, se ha de establecer esta opción de configuración a 0.

ingres.auto boolean

Habilita o deshabilita la emulación de autoconsigna. Ingres no puede tener múltiples cursores abiertos con el modo 'autocommit' habilitado. Cuando se habilita, el controlador lo emula.

ingres.blob_segment_length integer

Especifica la cantidad de memoria a usar al leer datos BLOB, en bytes

ingres.cursor_mode integer

Especifica el modo predeterminado para los cursores abiertos con ingres_prepare(). Los valores válidos son INGRES_CURSOR_UPDATE o INGRES_CURSOR_READONLY.

ingres.default_database string

Especifica del nombre de la base de datos predeterminada a usar al conectarse al servidor de bases de datos si no se especifica ningún nombre. No es aplicable en el modo seguro de SQL.

ingres.default_password string

Especifica la contraseña predeterminada a usar al conectarse al servidor de bases de datos si no se especifica ninguna. No es aplicable en el modo seguro de SQL.

ingres.default_user string

Especifica el nombre de usuario predeterminado a usar al conectarse al servidor de bases de datos si no se especifica ningún nombre. No es aplicable en el modo seguro de SQL.

ingres.describe boolean

Habilita el uso de DESCRIBE INPUT para poder determinar los tipos de datos esperados para consultas que usan parámetros. Disponible con Ingres 9.1.0 y posteriores. Cuando se deshabilita, la consultas que tienen parámetros pasados podría ser necesario describir manualmente los tipos de estos parámetros usando el parámetro types en ingres_query().

Nota:

La habilitación de esta característica con ingres_query() causará tráfico de comunicaciones adicional entre esta extensión y el servidor. Para minimizar este tráfico adicional, use ingres_prepare() y ingres_execute().

ingres.fetch_buffer_size integer

Especifica el número de filas preobtienidas que ingres_fetch_array(), ingres_fetch_object() y ingres_fetch_row() intentarán obtener en una operación.

ingres.max_links integer

Especifica el número máximo de sesiones de Ingres permitidas por proceso o subproceso. El número de sesiones debería no exceder el número total de sesiones conectadas configuradas dentro de Ingres.

ingres.max_persistent integer

Especifica el número máximo de sesiones persistentes de Ingres permitidas por proceso o subproceso. El número de sesiones debería no exceder el número total de sesiones conectadas configuradas dentro de Ingres.

ingres.reuse_connection boolean

Reutiliza un conexión activa existente si se conecta a la misma base de datos con el mismo nombre de usuario.

ingres.scrollable boolean

Habilita el soporte para cursores desplazables. Cuando se obtengan datos CLOB o BLOB, esto debería estar establecido a false. Disponibe con Ingres 9.2.0 o posteriores.

ingres.trace boolean

Habilita el rastreo sencillo usando mensajes E_NOTICE.

ingres.trace_connect boolean

Imprimer mensajes E_NOTICE durante las llamadas a ingres_connect() o ingres_pconnect().

ingres.utf8 boolean

Asume que las cadenas de caracteres pasadas a los tipos de columna Carácter Nacional (NVARCHAR o NCHAR) utilizan la codificación UTF8 y las convierte a UTF16 para el servidor.


Tipos de recursos

ingres_connect() y ingres_pconnect() devuelven un identificador de enlace de Ingres.

ingres_query() y ingres_unbuffered_query() devuelven un identificador de resultado de Ingres.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

INGRES_ASSOC (integer)
Las columnas son devueltas en un array, siendo el nombre del campo el índice de dicho arrary. Usada con ingres_fetch_array().
INGRES_NUM (integer)
Las columnas son devueltas en un array que tiene un índice numérico por cada camps. Por omisión, este índice empieza en 1, el primer campo del resultado. Para cambiar este valor, véase ingres.array_index_start. Usada con ingres_fetch_array().
INGRES_BOTH (integer)
Las columnas son devueltas en un array que tiene tanto índices numéricos como índices del nombre del campo. Usada con ingres_fetch_array().
INGRES_EXT_VERSION (string)
Especifica la versión de la Extensión Ingres. Disponible desde la versión 1.2.0 de la extensión de PECL.
INGRES_API_VERSION (integer)
Especifica la versión de la OpenAPI de Ingres con la que se construyó la extensión. Disponible desde la versión 1.2.0 de la extensión de PECL.
INGRES_CURSOR_READONLY (integer)
Especifica que los cursores de Ingres deberían abrirse en modo de solo lectura. Disponible desde la versión 1.2.0 de la extensión de PECL. Usada con ingres.cursor_mode.
INGRES_CURSOR_UPDATE (integer)
Especifica que los cursoser de Ingres deberían abrirse para actualizar. Disponible desde la versión 1.2.0 de la extensión de PECL. Usada con ingres.cursor_mode.
INGRES_DATE_MULTINATIONAL (integer)
Equivalente al ajuste II_DATE_FORMAT de MULTINATIONAL. Disponible desde la versión 1.2.0 de la extensión de PECL. Usada con ingres_connect(), ingres_pconnect() y ingres_set_environment(). Véase options en ingres_set_environment().
INGRES_DATE_MULTINATIONAL4 (integer)
Equivalente al ajuste II_DATE_FORMAT de MULTINATIONAL4. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_FINNISH (integer)
Equivalente al ajuste II_DATE_FORMAT de FINNISH. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_ISO (integer)
Equivalente al ajuste II_DATE_FORMAT de ISO. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_ISO4 (integer)
Equivalente al ajuste II_DATE_FORMAT de ISO4. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_GERMAN (integer)
Equivalente al ajuste II_DATE_FORMAT de GERMAN. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_MDY (integer)
Equivalente al ajuste II_DATE_FORMAT de MDY. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_DMY (integer)
Equivalente al ajuste II_DATE_FORMAT de DMY. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_DATE_YMD (integer)
Equivalente al ajuste II_DATE_FORMAT de YMD. Disponible desde la versión 1.2.0 de la extensión de PECL.
Usada con
ingres_connect(), ingres_pconnect()
y ingres_set_environment(). Véase options
en ingres_set_environment().
INGRES_MONEY_LEADING (integer)
Especifica el carácter monetario que debería ser colocado al inicio de un valor monetario. Equivalente al ajuste II_MONEY_FORMAT para "L:". Disponible desde la versión 1.2.0 de la extensión de PECL. Usada con ingres_connect(), ingres_pconnect() y ingres_set_environment(). Véase options en ingres_set_environment().
INGRES_MONEY_TRAILING (integer)
Especifica el carácter monetario que debería ser colocado al final de un valor monetario. Equivalente al ajuste II_MONEY_FORMAT para "T:". Disponible desde la versión 1.2.0 de la extensión de PECL. Usada con ingres_connect(), ingres_pconnect() y ingres_set_environment(). Véase options en ingres_set_environment().
INGRES_STRUCTURE_BTREE (integer)
Especifica la tabla o la estructura de índices predeterminada para BTREE cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_CBTREE (integer)
Especifica la tabla o la estructura de índices predeterminada para COMPRESSED BTREE cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_HASH (integer)
Especifica la tabla o la estructura de índices predeterminada para HASH cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_CHASH (integer)
Especifica la tabla o la estructura de índices predeterminada para COMPRESSED HASH cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_HEAP (integer)
Especifica la tabla o la estructura de índices predeterminada para HEAP cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_CHEAP (integer)
Especifica la tabla o la estructura de índices predeterminada para COMPRESSED HEAP cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_ISAM (integer)
Especifica la tabla o la estructura de índices predeterminada para ISAM cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().
INGRES_STRUCTURE_CISAM (integer)
Especifica la tabla o la estructura de índices predeterminada para COMPRESSED ISAM cuando se usa junto con las
opciones, o con la opción index_structure al conectarse. Disponible desde la versión 1.4.0 de la extensión de PECL.
Usada con ingres_connect() y
ingres_pconnect(). Véase options
en ingres_connect().


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • Ingres
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

El siguiente ejemplo sencillo muestra cómo conectarse a una base de datos Ingres, ejecutar una consulta, imprimir las filas resultantes y desconectarse de la base de datos.

Ejemplo #1 Simple Ingres Example

<?php
// Conectarse, seleccionando la base de datos
$enlace = ingres_connect("base_datos", "usuario", "contraseña")
    or die("No se pudo conectar: " . ingres_error($enlace));
echo "Conexión realizada con éxito";

// Realizar una selección de una tabla que existe en todas las bases de datos Ingres
$consulta = "SELECT * FROM iitables";
$resultado = ingres_query($enlace,$consulta) or die("Falló la consulta: " .
ingres_error($enlace));

// Imprimir los resultados en HTML
// relid - nombre de la tabla
// relowner - propietario de la tabla
echo "<table>\n";
while ($iitables = ingres_fetch_object($resultado)) {
    echo "\t<tr>\n";
    echo "\t\t<td>" . $iitables->relid . "</td>\n";
    echo "\t\t<td>" . $iitables->relowner . "</td>\n";
    echo "\t</tr>\n";
}
echo "</table>\n";

// Liberara los resultados
ingres_free_result($resultado);

// Consignar la transacción
ingres_commit($enlace);

// Cerrar la conexión
ingres_close($enlace);
?>


Funciones de Ingres

Tabla de contenidos

  • ingres_autocommit_state — Comprueba si la conexión usa la autoconsigna
  • ingres_autocommit — Activa o desactiva la autoconsigna
  • ingres_charset — Devuelve el conjunto de caracteres de la instalación
  • ingres_close — Cierra una conexión a una base de datos de Ingres
  • ingres_commit — Consigna una trasacción
  • ingres_connect — Abre una conexión a una base de datos de Ingres
  • ingres_cursor — Obtiene el nombre de un cursor de un recurso de resultados dado
  • ingres_errno — Obtiene el número del último error generado de Ingres
  • ingres_error — Obtener un mensaje de error coherente del último error generado
  • ingres_errsqlstate — Obtiene el código del último error SQLSTATE generado
  • ingres_escape_string — Escapa caracteres especiales para usuarlos en una consulta
  • ingres_execute — Ejecuta una consulta preparada
  • ingres_fetch_array — Obtiene una fila de resultados en un array
  • ingres_fetch_assoc — Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object — Obtiene una fila de resultados en un objeto
  • ingres_fetch_proc_return — Obtiene el valor de retorno de una llamada a un procedimiento
  • ingres_fetch_row — Obtiene una fila de resultados en un array enumerado
  • ingres_field_length — Obtiene la longitud de un campo
  • ingres_field_name — Obtiene el nombre de un campo de un resultado de una consulta
  • ingres_field_nullable — Comprueba si un campo puede contener valores null
  • ingres_field_precision — Obtiene la precisión de un campo
  • ingres_field_scale — Obtiene la escala de un campo
  • ingres_field_type — Obtiene el tipo de un campo de un resultado de una consulta
  • ingres_free_result — Libera los recursos asociados a un identificador de resultados
  • ingres_next_error — Obtiene el siguiente error de Ingres
  • ingres_num_fields — Obtiene el número de campos devueltos por la última consulta
  • ingres_num_rows — Obtener el número de filas afectadas o devueltas por una consulta
  • ingres_pconnect — Abre una conexión persistente a una base de datos de Ingres
  • ingres_prepare — Prepara una consulta para su ejecución posterior
  • ingres_query — Envía una consulta SQL a Ingres
  • ingres_result_seek — Establece la posición de una fila antes de obtener datos
  • ingres_rollback — Revierte una transacción
  • ingres_set_environment — Establece las características de entorno que controlan las opciones de salida
  • ingres_unbuffered_query — Envía una consulta SQL no almacenada en búfer a Ingres


Comprueba si la conexión usa la autoconsigna

  • « Funciones de Ingres
  • ingres_autocommit »
  • PHP Manual
  • Funciones de Ingres
  • Comprueba si la conexión usa la autoconsigna

ingres_autocommit_state

(PECL ingres >= 2.0.0)

ingres_autocommit_state — Comprueba si la conexión usa la autoconsigna

Descripción

ingres_autocommit_state ( resource $link ) : bool

ingres_autocommit_state() se invoca para determinar si el enlace de conexión actual tiene habilitada la autoconsigna.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve true si la autoconsigna está habilitada o false cuando está deshabilitada

Ver también

  • ingres_autocommit() - Activa o desactiva la autoconsigna
  • ingres_query() - Envía una consulta SQL a Ingres


Activa o desactiva la autoconsigna

  • « ingres_autocommit_state
  • ingres_charset »
  • PHP Manual
  • Funciones de Ingres
  • Activa o desactiva la autoconsigna

ingres_autocommit

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_autocommit — Activa o desactiva la autoconsigna

Descripción

ingres_autocommit ( resource $link ) : bool

ingres_autocommit() se invoca antes de abrir una transacción (antes de la primera llamada a ingres_query(), o justo después de una llamada a ingres_rollback() o a ingres_commit()) para activar o desactivar el modo autoconsigna del servidor (cuando se inicia el script, el modo autoconsigan está desactivado).

Cuando el modo autoconsigna está activado, cada consulta es automáticamente consignada por el servidor, igual que si ingres_commit() fuera invocada después de cada llamada a ingres_query(). Para ver si la autoconsigna está habilitada, use ingres_autocommit_state().

Por omisión, Ingres revertirá cualquier transacción no consignada al final de una petición. Use esta función o ingres_commit() para asegurarse que los datos son consignados a la base de datos.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ingres_autocommit_state() - Comprueba si la conexión usa la autoconsigna
  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_rollback() - Revierte una transacción
  • ingres_commit() - Consigna una trasacción


Devuelve el conjunto de caracteres de la instalación

  • « ingres_autocommit
  • ingres_close »
  • PHP Manual
  • Funciones de Ingres
  • Devuelve el conjunto de caracteres de la instalación

ingres_charset

(PECL ingres >= 2.1.0)

ingres_charset — Devuelve el conjunto de caracteres de la instalación

Descripción

ingres_charset ( resource $link ) : string

ingres_charset() se invoca para determinar el conjunto de caracteres que está usando el cliente Ingres, desde II_CHARSETxx (donce xx es el código de instalación).

Nota:

Se puede anular el valor devuelto usando la función putenv(). Cambiar el valor de II_CHARSETxx en una instalación de Ingres que se esté ejecutando puede corromper los datos.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve un string con el valor de II_CHARSETxx, o NULL si el valor no se pudo determinar.

Ejemplos

Ejemplo #1 ingres_charset() - Obtener el conjunto de caracteres de la instalación

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

echo ingres_charset($enlace) . "\n";

ingres_close($enlace);
?>

Ver también

  • ingres_connect() - Abre una conexión a una base de datos de Ingres
  • ingres_query() - Envía una consulta SQL a Ingres


Cierra una conexión a una base de datos de Ingres

  • « ingres_charset
  • ingres_commit »
  • PHP Manual
  • Funciones de Ingres
  • Cierra una conexión a una base de datos de Ingres

ingres_close

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_close — Cierra una conexión a una base de datos de Ingres

Descripción

ingres_close ( resource $link ) : bool

ingres_close() cierra la conexión al servidor Ingres que está asociada con el enlace especificado.

ingres_close() normalmente no es necesaria, ya que no cerrará las conexiones persistentes, y todas las conexiones no persistentes serán automáticamente cerradas al finalizar el script.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ingres_connect() - Abre una conexión a una base de datos de Ingres
  • ingres_pconnect() - Abre una conexión persistente a una base de datos de Ingres


Consigna una trasacción

  • « ingres_close
  • ingres_connect »
  • PHP Manual
  • Funciones de Ingres
  • Consigna una trasacción

ingres_commit

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_commit — Consigna una trasacción

Descripción

ingres_commit ( resource $link ) : bool

ingres_commit() consigna la transacción abierta actualmente, haciendo que todos los cambios hechos a la base de datos sean permanentes.

Esta función cierra la transacción. Se puede abrir una nueva transacción enviando una consulta con ingres_query().

También se puede hacer que el servidor consigne automáticamente después de cada consulota llamando a ingres_autocommit() antes de abrir la transacción.

Por omisión, Ingres revertirá cualquier transacción no consignada al final de una petición. Use esta función o ingres_commit() para asegurarse que los datos son consignados a la base de datos.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_rollback() - Revierte una transacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna


Abre una conexión a una base de datos de Ingres

  • « ingres_commit
  • ingres_cursor »
  • PHP Manual
  • Funciones de Ingres
  • Abre una conexión a una base de datos de Ingres

ingres_connect

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_connect — Abre una conexión a una base de datos de Ingres

Descripción

ingres_connect ( string $database = ? , string $username = ? , string $password = ? , array $options = ? ) : resource

ingres_connect() abre una conexión con la base de datos de Ingres dada por database.

La conexión se cierra cuando el script finaliza o cuando ingres_close() se invoca para este enlace.

Parámetros

Si se omiten algunos parámetros, ingres_connect() utilizará los valores de php.ini para ingres.default_database, ingres.default_user y ingres.default_password.

database

El nombre de la base de datos. Debe serguir la sintaxis:

[vnode::]dbname[/svr_class]

username

El nombre de usuario de Ingres

password

La contraseña asociada con username

options

Opciones de ingres_connect()

Nombre de la opción | Tipo de la opción | Descripción | Ejemplo
date_century_boundary | integer | El umbral por el cual se determina si un año de dos dígitos está en el siglo actual o en el siglo siguiente. Equivalente a II_DATE_CENTURY_BOUNDARY. | 50
group | string | Especifica el ID del grupo del usuario, equivalente a la bandera "-G" | payroll
role | string | El ID del rol de la aplicación. Si se requiere una contraseña de rol, el valor del parámetro debería especificarse como "rol/contraseña"
effective_user | string | La cuenta del usuario de ingres por la que se está haciendo pasar, equivalente a la bandera "-u" | another_user
dbms_password | string | La contraseña interna de la base de datos del usuario que se está conectando a Ingres | s3cr3t
table_structure string

La estructura predeteminada para la nuevas tablas. Los valores válidos para table_structure son:

  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_HEAP
  • INGRES_STRUCTURE_ISAM
  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_CHEAP

 INGRES_STRUCTURE_BTREE
index_structure string

La estructura predeterminada para los índeces secundarios nuevos. Los valores válidos para index_structure son:

  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_ISAM

 INGRES_STRUCTURE_HASH
login_local | boolean | Determina cómo se usan el ID del usuario y la contraseña cuando se incluye un VNODE en el string de la base de datos objetivo. Si se establece a TRUE, El ID del usuario y la contraseña se usarán para acceder localmente al VNODE, y la información de identificación del VNODE se usaraá para establecer la conexión al SGBD. Si se establece a FALSE, se usará el ID del usuario del proceso para acceder al VNODE, y el ID del usuario de la conexión y la contraseña se usarán en lugar de la información de identificación del VNODE para establecer la conexión al SGBD. Este parámetro es ignorado si no se incluye ningún VNODE en el string de la base de datos objetivo. Lo predeterminado es FALSE. | TRUE
timezone | string | Controla la zona horaria de la sesión. Si no se establece, se usará el valor definido por II_TIMEZONE_NAME. Si II_TIMEZONE_NAME no está definido, se usarán NA-PACIFIC (GMT-8 con horara de verano).
date_format integer

Establece el formato de entrada y salida permisible para las fechas de Ingres. El valor predeterminado es el definido por II_DATE_FORMAT. Si II_DATE_FORMAT no está establecido, se usará el formato de fecha US, p.j. mm/dd/aa. Los valores válidos para date_format son:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_MULTINATIONAL4
decimal_separator string El identificador del carácter para los datos decimales ","
money_lort integer

El símbolo monetario que va antes o después del valor. Los valores válidos para money_lort son:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_TRAILING
money_sign string El símpbolo monetario a usar con el tipo de datos MONEY €
money_precision | integer | La precisión del tipo de datos MONEY | 3
float4_precision | integer | La precisión del tipo de datos FLOAT4 | 10
float8_precision | integer | La precisión del tipo de datos FLOAT8 | 10
blob_segment_length | integer | La cantidad de datos en bytes a obtener de una vez cuando se recuperan datos BLOB o CLOB. El valor predeterminado es de 4096 si no se establece explícitamente | 8192

Valores devueltos

Devuelve un recurso de enlace a Ingres en caso de éxito o false en caso de error

Ejemplos

Ejemplo #1 Abrir una conexión a un base de datos de Ingres

<?php
$enlace = ingres_connect("mi_bd", "usuario", "contraseña")
    or die("No se pudo conectar");
echo "Conexión realizada con éxito";
ingres_close($enlace);
?>

Ver también

  • ingres_pconnect() - Abre una conexión persistente a una base de datos de Ingres
  • ingres_close() - Cierra una conexión a una base de datos de Ingres


Obtiene el nombre de un cursor de un recurso de resultados dado

  • « ingres_connect
  • ingres_errno »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el nombre de un cursor de un recurso de resultados dado

ingres_cursor

(PECL ingres >= 1.1.0)

ingres_cursor — Obtiene el nombre de un cursor de un recurso de resultados dado

Descripción

ingres_cursor ( resource $result ) : string

Devuelve un string con el nombre del cursor activo. Si no hay ningún cursor activo, se devolverá NULL.

Parámetros

result

El identificador de resultados de una consulta

Valores devueltos

Devuelve un string que contiene el nombre del cursor activo. Si no hay ningún cursor activo, se devolverá NULL.

Ejemplos

Ejemplo #1 Obtener el nombre del cursor para un recurso de consultas

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_prepare($enlace, "select * from table");

$nombre_cursor = ingres_cursor($resultado);

echo $nombre_cursor;

?>

Ver también

  • ingres_prepare() - Prepara una consulta para su ejecución posterior
  • ingres_execute() - Ejecuta una consulta preparada


Obtiene el número del último error generado de Ingres

  • « ingres_cursor
  • ingres_error »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el número del último error generado de Ingres

ingres_errno

(PECL ingres >= 1.1.0)

ingres_errno — Obtiene el número del último error generado de Ingres

Descripción

ingres_errno ( resource $link = ? ) : int

Devuelve un valor de tipo integer que contiene el número del último error. Si no se notificó ningún error, devolverá 0.

Si se pasa un recurso link a ingres_errno(), devolverá el último error registrado para el enlace. Si no se pasa ningún enlace, ingres_errno() devolverá el último error notificado usando el enlace predeterminado.

La función ingres_errno() debería llamarse siempre después de ejecutar una consulta a la base de datos. La llamada a otra función antes de llamar a ingres_errno() reiniciará o cambiará cualquier código de error de la última función de Ingres.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve un valor de tipo integer que contiene el número del último error. Si no se nofiticó ninún erorr, devolverá 0.

Ejemplos

Ejemplo #1 Obtener el númeor del último error generado de Ingres

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace, "select * from table");

$código_error = ingres_errno($enlace);

if ( $código_error != 0 ) {
   echo "Ocurrió un error - " . $código_error;
}
?>

Ver también

  • ingres_error() - Obtener un mensaje de error coherente del último error generado
  • ingres_errsqlstate() - Obtiene el código del último error SQLSTATE generado
  • ingres_next_error() - Obtiene el siguiente error de Ingres


Obtener un mensaje de error coherente del último error generado

  • « ingres_errno
  • ingres_errsqlstate »
  • PHP Manual
  • Funciones de Ingres
  • Obtener un mensaje de error coherente del último error generado

ingres_error

(PECL ingres >= 1.1.0)

ingres_error — Obtener un mensaje de error coherente del último error generado

Descripción

ingres_error ( resource $link = ? ) : string

Devuelve un valor de tipo string que contiene el último error, o NULL si ocurrió ninguno.

Si se pasa un recurso link a ingres_error(), devolverá el último error registrado para el enlace. Si no se pasa ningún enlace, ingres_error() devolverá el último error notificado usando el enlace predeterminado.

La función ingres_error() debería llamarse siempre después de ejecutar una consulta a la base de datos. La llamada a otra función antes de llamar a ingres_error() reiniciará o cambiará cualquier código de error de la última función de Ingres.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve un valor de tipo string que contiene el último error, o NULL si ocurrió ninguno.

Ejemplos

Ejemplo #1 Obtener un mensaje del último error generado

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace, "select * from table");

$texto_error = ingres_error();

if (!is_null($texto_error)) {
   echo "Ocurrió un error - " . $texto_error;
}
?>

Ver también

  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_errsqlstate() - Obtiene el código del último error SQLSTATE generado
  • ingres_next_error() - Obtiene el siguiente error de Ingres


Obtiene el código del último error SQLSTATE generado

  • « ingres_error
  • ingres_escape_string »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el código del último error SQLSTATE generado

ingres_errsqlstate

(PECL ingres >= 1.1.0)

ingres_errsqlstate — Obtiene el código del último error SQLSTATE generado

Descripción

ingres_errsqlstate ( resource $link = ? ) : string

Devuelve un valor de tipo string que contiene el último SQLSTATE, o NULL si no ocurrió ningún error.

Si se pasa un recurso link a ingres_errsqlstate(), devolverá el último error registrado para el enlace. Si no se pasa ningún enlace, ingres_errsqlstate() devolverá el último error notificado usando el enlace predeterminado.

La función ingres_errsqlstate() debería llamarse siempre después de ejecutar una consulta a la base de datos. La llamada a otra función antes de llamar a ingres_errsqlstate() reiniciará o cambiará cualquier código de error de la última función de Ingres.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve un valor de tipo string que contiene el último SQLSTATE, o NULL si no ocurrió ningún error.

Ejemplos

Ejemplo #1 Obtener el código del último error SQLSTATE generado

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace, "select * from table");

$error_sqlstate = ingres_error();

if (!is_null($error_sqlstate)) {
   echo "Ocurrió un error - " . $texto_error;
}
?>

Ver también

  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado
  • ingres_next_error() - Obtiene el siguiente error de Ingres


Escapa caracteres especiales para usuarlos en una consulta

  • « ingres_errsqlstate
  • ingres_execute »
  • PHP Manual
  • Funciones de Ingres
  • Escapa caracteres especiales para usuarlos en una consulta

ingres_escape_string

(PECL ingres >= 2.1.0)

ingres_escape_string — Escapa caracteres especiales para usuarlos en una consulta

Descripción

ingres_escape_string ( resource $link , string $source_string ) : string

ingres_escape_string() se usa para escapar ciertos caracteres de un string antes de eviarlo al sevidor de la base de datos.

Parámetros

link

El identificador de enlace de la conexión

source_string

El string origen a analizar

Valores devueltos

Deveulve un string que contiene los datos escapados

Ejemplos

Ejemplo #1 Escape special characters for use in a query

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$apellido = "O'Connor";

$sql = sprintf("select * from user_profile where up_last = '%s'", ingres_escape_string( $enlace, $apellido));

$resultado = ingres_query($enlace, $sql);

while ($usuario = ingres_fetch_object($resultado))
{
  echo $usuario->up_first . '<BR/>';
}

ingres_commit($enlace);

ingres_close($enlace);

?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres


Ejecuta una consulta preparada

  • « ingres_escape_string
  • ingres_fetch_array »
  • PHP Manual
  • Funciones de Ingres
  • Ejecuta una consulta preparada

ingres_execute

(PECL ingres >= 1.1.0)

ingres_execute — Ejecuta una consulta preparada

Descripción

ingres_execute ( resource $result , array $params = ? , string $types = ? ) : bool

Ejecuta una consulta preparada anterioremente con ingres_prepare().

Nota: Configuraciones relacionadas

Véase también las directivas ingres.describe, ingres.scrollable y ingres.utf8 de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de enlace de la conexión

params

Un array con los valores de los parámetros a usar con la consulta

types

Un string que contiene una secuencia con los tipos de los valores de los parámetros proporcionados. Véase el parámetro types de ingres_query() para una lista de los códigos de los tipos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ingres_unbuffered_query() - Envía una consulta SQL no almacenada en búfer a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado
  • ingres_commit() - Consigna una trasacción
  • ingres_rollback() - Revierte una transacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna
  • ingres_set_environment() - Establece las características de entorno que controlan las opciones de salida
  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado


Obtiene una fila de resultados en un array

  • « ingres_execute
  • ingres_fetch_assoc »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene una fila de resultados en un array

ingres_fetch_array

(PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_array — Obtiene una fila de resultados en un array

Descripción

ingres_fetch_array ( resource $result , int $result_type = ? ) : array

Esta función es una versión extendida de ingres_fetch_row(). Además de almacenar los datos en índices numéricos del array resultante, también los almacena en índices asociativos, usando los nombres de los campos como claves.

Si dos o más columnas del resultados tuvieran los mismos nombres, la última columna tomará precedencia. Para acceder a otra u otras columnas con el mismo nombres, se debe usare el índice numérico de la columna o poner un alias a la misma. Por ejemplo:

<?php

$resultado = ingres_query($enlace, "select ap_place as city, ap_ccode as country from airport where ap_iatacode = 'VLL'");
$resultado = ingres_fetch_array($resultado);
$foo = $resultado["city"];
$bar = $resultado["country"];

?>

Con respecto a la velocidad, la función es idéntica a ingres_fetch_object(), y casi tan rápida como ingres_fetch_row() (la diferencia es indignificante).

De manera predeterminada, los arrays creados por ingres_fetch_array() empiezan en la posición 1, y no en la 0 como en otras extensiones de SGBDs. La posición de inicio se puede ajustar a 0 usando el parámetro de configuración ingres.array_index_start.

Nota: Configuraciones relacionadas

Véanse también las directivas ingres.array_index_start, ingres.fetch_buffer_size y ingres.utf8 de la sección Configuración en tiempo de ejecución.

Parámetros

result

El identificador de resultados de la consulta

result_type

El tipo de resultado. result_type puede ser INGRES_NUM arrays enumerados, INGRES_ASSOC para arrays asociativos, o INGRES_BOTH (predeterminado).

Valores devueltos

Devuelve un array que se corresponde con la fila obtenida, o false si no existen más filas

Ejemplos

Ejemplo #1 Obtener una fila de resultados en un array

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace,"select * from table");
while ($fila = ingres_fetch_array($resultado)) {
    echo $fila["user_id"];  // usar un array asociativo
    echo $fila["fullname"];
    echo $fila[1];          // usar un array enumerado
    echo $fila[2];
}
?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_num_fields() - Obtiene el número de campos devueltos por la última consulta
  • ingres_field_name() - Obtiene el nombre de un campo de un resultado de una consulta
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtienen una fila de resultados en un array asociativo

  • « ingres_fetch_array
  • ingres_fetch_object »
  • PHP Manual
  • Funciones de Ingres
  • Obtienen una fila de resultados en un array asociativo

ingres_fetch_assoc

(PECL ingres >= 2.2.2)

ingres_fetch_assoc — Obtienen una fila de resultados en un array asociativo

Descripción

ingres_fetch_assoc ( resource $result ) : array

Esta función almacena los datos obtenidos desde un consulta ejecutada usando ingres_query() en un array asociativo, usando los nombres de los campos como claves.

Con respecto a la velocidad, la función es idéntica a ingres_fetch_object(), y casi tan rápida como ingres_fetch_row() (la diferencia es indignificante).

De manera predeterminada, los arrays creados por ingres_fetch_assoc() empiezan en la posición 1, y no en la 0 como en otras extensiones de SGBDs. La posición de inicio se puede ajustar a 0 usando el parámetro de configuración ingres.array_index_start.

Nota: Configuraciones relacionadas

Véanse también las directivas ingres.array_index_start, ingres.fetch_buffer_size y ingres.utf8 de la sección Configuración en tiempo de ejecución.

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Devuelve un array asociativo que se corresponde con la fila obtenida, o false si no existen más filas

Ejemplos

Ejemplo #1 Obtener una fila en un array asociativo

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace,"select * from table");
while ($fila = ingres_fetch_assoc($resultado)) {
    echo $fila["user_id"];  // usar un array asociativo
    echo $fila["fullname"];
}
?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_num_fields() - Obtiene el número de campos devueltos por la última consulta
  • ingres_field_name() - Obtiene el nombre de un campo de un resultado de una consulta
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene una fila de resultados en un objeto

  • « ingres_fetch_assoc
  • ingres_fetch_proc_return »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene una fila de resultados en un objeto

ingres_fetch_object

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_object — Obtiene una fila de resultados en un objeto

Descripción

ingres_fetch_object ( resource $result , int $result_type = ? ) : object

Esta función es similar a ingres_fetch_array(), con una diferencia: se devuelve un objeto en lugar de un array. Indirectamente, esto significa que se puede acceder a los datos solamente por los nombres de los campos, y no or otros índices (los números son nombres de propiedades ilegales).

Con respecto a la velocidad, la función es idéntica a ingres_fetch_array(), y casi tan rápida como ingres_fetch_row() (la diferencia es indignificante).

Nota: Configuraciones relacionadas

Véanse también las directivas ingres.fetch_buffer_size y ingres.utf8 de la sección Configuración en tiempo de ejecución.

Parámetros

link

El identificador de resultados de la consulta

result_type

(Argumento opcional) result_type es una constante que puede tomar los siguientes valores: INGRES_ASSOC, INGRES_NUM, y INGRES_BOTH.

Valores devueltos

Devuelve un objeto que se corresponde con la fila obtenida, o false si no existen más filas

Ejemplos

Ejemplo #1 Obtener una fila en un objeto

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);
$resultado = ingres_query($enlace,"select * from table");
while ($fila = ingres_fetch_object($resultado)) {
    echo $fila->user_id;
    echo $fila->fullname;
}
?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_num_fields() - Obtiene el número de campos devueltos por la última consulta
  • ingres_field_name() - Obtiene el nombre de un campo de un resultado de una consulta
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene el valor de retorno de una llamada a un procedimiento

  • « ingres_fetch_object
  • ingres_fetch_row »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el valor de retorno de una llamada a un procedimiento

ingres_fetch_proc_return

(PECL ingres >= 1.4.0)

ingres_fetch_proc_return — Obtiene el valor de retorno de una llamada a un procedimiento

Descripción

ingres_fetch_proc_return ( resource $result ) : int

Esta función se usa para recuperar el valor de retorno que sigue a la ejecución de un procedimiento de una base de datos de Ingres (procedimiento al macenado).

Nota:

Si se usa con un procedimiento que produce filas, esta función debería invocarse después de haber obtenido todas las filas del procedmiento usando ingres_fetch_array(), ingres_fetch_object() o ingres_fetch_row(). Esta fnción eliminará cualquier fila aún no obtenida que quedara pendiente.

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Devuelve valor de tipo integer si existe un valor de retorno, si no, devolverá null.

Ejemplos

Ejemplo #1 Obtener el valor de retorno de una llamada a un procedimiento

<?php

$enlace = ingres_connect($base_datos);

if ( ingres_errno() != 0 ) {
    $texto_error = ingres_error();
    die($texto_error);
}

$resultado = ingres_query($enlace, "execute procedure php_proc (value = 1000)");

if ( ingres_errno() != 0 ) {
    $texto_error = ingres_error();
    die($texto_error);
}

echo "valor de retorno - " . ingres_fetch_proc_return($resultado) . "\n";

ingres_close($enlace);

?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene una fila de resultados en un array enumerado

  • « ingres_fetch_proc_return
  • ingres_field_length »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene una fila de resultados en un array enumerado

ingres_fetch_row

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_row — Obtiene una fila de resultados en un array enumerado

Descripción

ingres_fetch_row ( resource $result ) : array

ingres_fetch_row() devuelve un array que se corresponde con la fila obtenida, o false si no existen más filas. Cada columna del resultado se almacena en un índice del array, empezando en el índice 1.

Las llamadas subsiguientes a ingres_fetch_row() devolverán la siguientes fila del conjunto de resultados, o false si no existieran más filas.

De manera predeterminada, los arrays creados por ingres_fetch_row() empiezan en la posición 1, y no en la 0 como en otras extensiones de SGBDs. La posición de inicio se puede ajustar a 0 usando el parámetro de configuración ingres.array_index_start.

Nota: Configuraciones relacionadas

Véanse también las directivas ingres.array_index_start, ingres.fetch_buffer_size y ingres.utf8 de la sección Configuración en tiempo de ejecución.

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Devuelve un array que se corresponde con la fila obtenida, o false si no existieran más filas

Ejemplos

Ejemplo #1 Obttener una fila de resultados en un array enumerado

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace, "select * from table");
while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
?>

Ver también

  • ingres_num_fields() - Obtiene el número de campos devueltos por la última consulta
  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto


Obtiene la longitud de un campo

  • « ingres_fetch_row
  • ingres_field_name »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene la longitud de un campo

ingres_field_length

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_length — Obtiene la longitud de un campo

Descripción

ingres_field_length ( resource $result , int $index ) : int

ingres_field_length() devuelve la longitud de un campo. Este es el número de bytes que el servidor usa para almacenar dicho campo. Para una información detallada, véase la Guía de usuairo de OpenAPI y el apéndice "Tipos de datos" de la documentación de Ingres.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el número de columna de la que se va a obtener su longitud.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

Devuelve la longitud de un campo.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene el nombre de un campo de un resultado de una consulta

  • « ingres_field_length
  • ingres_field_nullable »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el nombre de un campo de un resultado de una consulta

ingres_field_name

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_name — Obtiene el nombre de un campo de un resultado de una consulta

Descripción

ingres_field_name ( resource $result , int $index ) : string

ingres_field_name() devuelve el nombre de un campo de un resultado de una consulta.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el campo del que se va a obtener su nombre.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

Devuelve el nombre de un campo de un resultado de una consulta o false en caso de error

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Comprueba si un campo puede contener valores null

  • « ingres_field_name
  • ingres_field_precision »
  • PHP Manual
  • Funciones de Ingres
  • Comprueba si un campo puede contener valores null

ingres_field_nullable

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_nullable — Comprueba si un campo puede contener valores null

Descripción

ingres_field_nullable ( resource $result , int $index ) : bool

Comprueba si un campo puede contener valores null.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el campo del cual se quiere saber si puede contener valores null.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

ingres_field_nullable() devuelve true si el campo se puede establecer al valor null, y false si no.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene la precisión de un campo

  • « ingres_field_nullable
  • ingres_field_scale »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene la precisión de un campo

ingres_field_precision

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_precision — Obtiene la precisión de un campo

Descripción

ingres_field_precision ( resource $result , int $index ) : int

ingres_field_precision() devuelve la precisión de un campo. Este valor se usa solamente para tipos de datos SQL 'decimal', 'float', y 'money'. Para una información detallada, véase la Guía de usuario de OpenAPI y el apéndice "Tipos de datos" de la documentación de Ingres.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el campo del que se va a obtener la precisión.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

Devuelve la precisión del campo como un valor de tipo integer

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene la escala de un campo

  • « ingres_field_precision
  • ingres_field_type »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene la escala de un campo

ingres_field_scale

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_scale — Obtiene la escala de un campo

Descripción

ingres_field_scale ( resource $result , int $index ) : int

ingres_field_scale() devuelve la escala de un campo. Este valor se usa solamente para tipos de datos SQL 'decimal'. Para una información detallada, véase la Guía de usuario de OpenAPI y el apéndice "Tipos de datos" de la documentación de Ingres.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el campo del que se va a obtener su escala.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

Devuelve la escala del campo, como un valor de tipo integer

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtiene el tipo de un campo de un resultado de una consulta

  • « ingres_field_scale
  • ingres_free_result »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el tipo de un campo de un resultado de una consulta

ingres_field_type

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_type — Obtiene el tipo de un campo de un resultado de una consulta

Descripción

ingres_field_type ( resource $result , int $index ) : string

Obtiene el tipo de un campo de un resultado de una consulta.

Nota: Configuraciones relacionadas

Véase ingres.array_index_start de la sección Configuración en tiempo de ejecución

Parámetros

result

El identificador de resultados de la consulta

index

index es el campo del que se va a obtener su tipo.

Los posibles valores de index dependen del valor de ingres.array_index_start. Si ingres.array_index_start es 1 (lo predeterminado), index debe estar entre 1 y el valor devuelto por ingres_num_fields(). Si ingres.array_index_start es 0, index debe estar entre 0 y ingres_num_fields() - 1.

Valores devueltos

ingres_field_type() devuelve el tipo de un campo de un resultado de una consulta o false en caso de error. Ejemplos de los tipos devueltos: IIAPI_BYTE_TYPE, IIAPI_CHA_TYPE, IIAPI_DTE_TYPE, IIAPI_FLT_TYPE, IIAPI_INT_TYPE, IIAPI_VCH_TYPE. Algunos de estos tipos pueden hacer referencia a más de un tipo SQL, dependiendo de la longitud del campo (véase ingres_field_length()). Por ejemplo IIAPI_FLT_TYPE puede ser un float4 o un float8. Para una información detallada, véase la Guía de usuario de OpenAPI y el apéndice "Tipos de datos" de la documentación de Ingres.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Libera los recursos asociados a un identificador de resultados

  • « ingres_field_type
  • ingres_next_error »
  • PHP Manual
  • Funciones de Ingres
  • Libera los recursos asociados a un identificador de resultados

ingres_free_result

(PECL ingres >= 2.0.0)

ingres_free_result — Libera los recursos asociados a un identificador de resultados

Descripción

ingres_free_result ( resource $result ) : bool

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Liberar un recurso de resultados

<?php
$enlace = ingres_connect($base_datos, $usuario, $contraseña);

$resultado = ingres_query($enlace,"select * from table");

while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
ingres_free_result($resultado);

ingres_close($enlace)

?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres


Obtiene el siguiente error de Ingres

  • « ingres_free_result
  • ingres_num_fields »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el siguiente error de Ingres

ingres_next_error

(PECL ingres >= 2.0.0)

ingres_next_error — Obtiene el siguiente error de Ingres

Descripción

ingres_next_error ( resource $link = ? ) : bool

Obtiene el siguiente error de Ingres de la última consulta ejecutada. Cada llamada a ingres_next_error() puede ser seguida por una llamada a ingres_errno(), ingres_error() o ingres_errsqlstate() para obtener, respectivamente, el número del error, el texto del error, o el SQL STATE. Mientras ingres_next_error() devuelva true, existirán más errores que obtener.

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

ingres_next_error() devuelve true si existen otro error que recuperar, o false cuando no existen más errores.

Ver también

  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado
  • ingres_errsqlstate() - Obtiene el código del último error SQLSTATE generado


Obtiene el número de campos devueltos por la última consulta

  • « ingres_next_error
  • ingres_num_rows »
  • PHP Manual
  • Funciones de Ingres
  • Obtiene el número de campos devueltos por la última consulta

ingres_num_fields

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_num_fields — Obtiene el número de campos devueltos por la última consulta

Descripción

ingres_num_fields ( resource $result ) : int

ingres_num_fields() devuelve el número de campos de los resultados devueltos por el servidor Ingres después de una llamada a ingres_query().

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Devuelve el número de campos

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Obtener el número de filas afectadas o devueltas por una consulta

  • « ingres_num_fields
  • ingres_pconnect »
  • PHP Manual
  • Funciones de Ingres
  • Obtener el número de filas afectadas o devueltas por una consulta

ingres_num_rows

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_num_rows — Obtener el número de filas afectadas o devueltas por una consulta

Descripción

ingres_num_rows ( resource $result ) : int

Con esta función, principalmente se pretende obtener el número de filas modificadas en la base de datos. Sin embargo, se puede usar para recuperar el número de filas obtenidas por una sentencia SELECT.

Nota:

Si los cursores desplazables están deshabilitados y se llama a esta función antes de usar ingres_fetch_array(), ingres_fetch_object(), o ingres_fetch_row(), el servidor borrará los datos de los resultados, por lo que el script no será capaz de obtenerlos.

En su lugar, se deberían de recuperar los datos de los resultados usando una de estas funciones de obtenición en un buble hasta que devuelvan false, indicando que no hay más resultados disponibles.

Parámetros

result

El identificador de resultados de la consulta

Valores devueltos

Para consultas de eliminación, insertado, o actualización, ingres_num_rows() devuelve el número de filas afectadas por la consulta. Para otras consultas, ingres_num_rows() devuelve el número de filas del resultado de la consulta.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Abre una conexión persistente a una base de datos de Ingres

  • « ingres_num_rows
  • ingres_prepare »
  • PHP Manual
  • Funciones de Ingres
  • Abre una conexión persistente a una base de datos de Ingres

ingres_pconnect

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_pconnect — Abre una conexión persistente a una base de datos de Ingres

Descripción

ingres_pconnect ( string $database = ? , string $username = ? , string $password = ? , array $options = ? ) : resource

Abre una conexión persistente a una base de datos de Ingres.

Existen solamente dos diferencias esta función y ingres_connect(): La primera es que, al conectarse, esta función inicialmente intentará encontrar un enlace (persistente) que ya esté abierto con los mismos parámetros. Si se encuentra uno, será devuelto un identificador para dicho enlace en lugar de abrir una nueva conexión. La segunda diferencia es que la conexión al servidor Ingres no se cerrará al finalizar la ejecución del script. En su lugar, el enlace permanecerá abierto para usos futuros (ingres_close() no cerrará los enlaces establecidos por ingres_pconnect()). Por esto, a este tipos de enlaces de les llama "persistentes".

Parámetros

database

El nombre de la base de datos. Debe serguir la sintaxis:

[vnode::]dbname[/svr_class]

username

El nombre de usuario de Ingres

password

La contraseña asociada con username

options

Véase ingres_connect() para una lista de las opciones que se pueden pasar

Valores devueltos

Devuelve un recurso de enlace a Ingres en caso de éxito o false en caso de error

Ver también

  • ingres_connect() - Abre una conexión a una base de datos de Ingres
  • ingres_close() - Cierra una conexión a una base de datos de Ingres


Prepara una consulta para su ejecución posterior

  • « ingres_pconnect
  • ingres_query »
  • PHP Manual
  • Funciones de Ingres
  • Prepara una consulta para su ejecución posterior

ingres_prepare

(PECL ingres >= 1.1.0)

ingres_prepare — Prepara una consulta para su ejecución posterior

Descripción

ingres_prepare ( resource $link , string $query ) : mixed

Prepara una consulta para su ejecución posterior mediante ingres_execute().

La consulta es parte de la transacción abierta actualmente. Si no hay ninguna transacción abierta, ingres_query() abrirá una nueva. Para cerrar la transacción, se puede llamar tanto a ingres_commit() para consignar los cambios hechos a la base de datos, como a ingres_rollback() para cancelar dichos cambios. Cuando el script finaliza, cualquier transacción abierta será revertida (invocando a ingres_rollback()). También se puede usar ingres_autocommit() antes de abrir una nueva transacción para que cada consulta SQL sea consignada automáticamente.

Nota: Configuraciones relacionadas

Véase también las directivas ingres.describe, ingres.scrollable y ingres.utf8 de la sección Configuración en tiempo de ejecución

Parámetros

link

El identificador de enlace de la conexión

query

Una consulta SQL válida (véase la guía de referencia de SQL) en la documentación de Ingres. Véase el parámetro query de ingres_query() para una lista de las sentencias SQL que no se pueden ejecutar usando ingres_prepare()

Valores devueltos

ingres_prepare() devuelve un identificador de resultados que
se usa con ingres_execute() para ejecutar la consulta. Para comprobar
si ocurrió un error, use ingres_errno(),
ingres_error(), o
ingres_errsqlstate().

Ver también

  • ingres_unbuffered_query() - Envía una consulta SQL no almacenada en búfer a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado
  • ingres_commit() - Consigna una trasacción
  • ingres_rollback() - Revierte una transacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna
  • ingres_set_environment() - Establece las características de entorno que controlan las opciones de salida
  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado


Envía una consulta SQL a Ingres

  • « ingres_prepare
  • ingres_result_seek »
  • PHP Manual
  • Funciones de Ingres
  • Envía una consulta SQL a Ingres

ingres_query

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_query — Envía una consulta SQL a Ingres

Descripción

ingres_query ( resource $link , string $query , array $params = ? , string $types = ? ) : mixed

ingres_query() envía la consulta dada por query al servidor Ingres.

La consulta es parte de la transacción abierta actualmente. Si no hay ninguna transacción abierta, ingres_query() abrirá una nueva. Para cerrar la transacción, se puede llamar tanto a ingres_commit() para consignar los cambios hechos a la base de datos, como a ingres_rollback() para cancelar dichos cambios. Cuando el script finaliza, cualquier transacción abierta será revertida (invocando a ingres_rollback()). También se puede usar ingres_autocommit() antes de abrir una nueva transacción para que cada consulta SQL sea consignada automáticamente.

Nota: Configuración relacionada

Véase también las directivas ingres.describe, ingres.scrollable y ingres.utf8 de la sección Configuración en tiempo de ejecución

Parámetros

link

El identificador de enlace de la conexión

query

Una consulta SQL válida (véase la guía de referencia de SQL de la documentación de Ingres).

Los datos dentro de la consulta deberían estar apropiadamente escapados.

Los siguientes tipos de consultas SQL no se pueden enviar con esta función:

  • close (véase ingres_close())
  • commit (véase ingres_commit())
  • connect (véase ingres_connect())
  • disconnect (véase ingres_close())
  • get dbevent
  • prepare to commit
  • rollback (véase ingres_rollback())
  • savepoint
  • set autocommit (véase ingres_autocommit())
  • todas las consultas relacionadas con cursores no están soportadas

params

Un array de valores de parámetros para usarlos con la consulta

types

Un string que contiene una secuencia de los tipos de los valores de los parámetros pasados. Cuando ingres.describe está habilitado, este parámetro se puede ignorar, ya que el controlador obtiene automáticamente los tipos esperados de los parámetros desde el servidor.

Código del tipo | Tipo de Ingres
a | BOOLEAN
b | BYTE
B | LONG BYTE/BLOB
c | CHAR
d | DATE/ANSIDATE/TIMESTAMP/TIME
f | FLOAT
i | INTEGER
L | LONG TEXT
m | MONEY
M | LONG NVARCHAR
n | NCHAR
N | NVARCHAR
t | TEXT
v | VARCHAR
V | LONG VARCHAR

Valores devueltos

ingres_query() devuelve un identificador de resultados de consulta en
caso de éxito, o false en caso de error. Para comprobar si ocurrió
un error, use ingres_errno(),
ingres_error() o
ingres_errsqlstate().

Ejemplos

Ejemplo #1 Enviar un simple select

<?php
$enlace = ingres_connect("demodb");

$resultado = ingres_query($enlace, "select * from user_profile");
while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
?>

Ejemplo #2 Pasar parámetros de consulta a ingres_query()

<?php
$enlace = ingres_connect("demodb");

$parámetros[] = "Emma";
$consulta = "select * from user_profile where up_first = ?";
$resultado = ingres_query($enlace, $consulta, $parámetros);
while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
?>

Ejemplo #3 Insertar datos BLOB con tipos de parámetros

<?php
$enlace = ingres_connect("demodb");

//Abrir una foto
$fh = fopen("photo.jpg","r");
$datos_blob = stream_get_contents($fh);
fclose($fh);

//Preparar los parámetros
$parámetros[] = $datos_blob;
$parámetros[] = 1201;

//Definir los tipos de parámetros
$tipos_parámetros = "Bi";

$consulta = "update user_profile set up_image = ? where up_id = ?";
$resultado = ingres_query($enlace, $consulta , $parámetros, $tipos_parámetros);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}

ingres_commit($enlace);

ingres_close($enlace);
?>

Ver también

  • ingres_unbuffered_query() - Envía una consulta SQL no almacenada en búfer a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado
  • ingres_commit() - Consigna una trasacción
  • ingres_rollback() - Revierte una transacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna
  • ingres_set_environment() - Establece las características de entorno que controlan las opciones de salida
  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado


Establece la posición de una fila antes de obtener datos

  • « ingres_query
  • ingres_rollback »
  • PHP Manual
  • Funciones de Ingres
  • Establece la posición de una fila antes de obtener datos

ingres_result_seek

(PECL ingres >= 2.1.0)

ingres_result_seek — Establece la posición de una fila antes de obtener datos

Descripción

ingres_result_seek ( resource $result , int $position ) : bool

Esta función se usa para posicionar el cursor asociado al recurso de resultados antes de realizar una obtención. Si ingres.array_index_start está establecido a 0, la primera fila es 0, y no 1. ingres_result_seek() se puede usar solamente con consultas que hacen uso de cursores desplazables. No se puede usar con ingres_unbuffered_query().

Nota: Related Configurations

Véanse también las directivas ingres.scrollable y ingres.array_index_start de la sección Configuración en tiempo de ejcución.

Parámetros

result

El identificador de resultados de la consulta

position

La fila donde posicionar el cursor. Si ingres.array_index_start está establecido a 0, la primera fila es 0, y no 1

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Posicionar el cursor a la 3ª fila

<?php

$resultado=ingres_query($enlace, "select * from airport where ap_ccode = 'ES' order by ap_place asc");

/* ir a la fila 3 */
if (!ingres_result_seek($resultado, 3))
{
    echo ingres_errno() . " - " . ingres_error . "\n";
    die("he muerto");
}
else
{
    $aeropuerto = ingres_fetch_object ($resultado);
    {
        echo $aeropuerto->ap_iatacode . " - " .  $aeropuerto->ap_name . "\n";
    }
}

ingres_commit($enlace);

?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado


Revierte una transacción

  • « ingres_result_seek
  • ingres_set_environment »
  • PHP Manual
  • Funciones de Ingres
  • Revierte una transacción

ingres_rollback

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_rollback — Revierte una transacción

Descripción

ingres_rollback ( resource $link ) : bool

ingres_rollback() revierte la transacción abierta actualmente, realmente cancelando todos los cambios hechos a la base de datos durante dicha transacción.

Esta función cierra la transacción. Se puede abrir una nueva transacción enviando una consulta con ingres_query().

Parámetros

link

El identificador de enlace de la conexión

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_commit() - Consigna una trasacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna


Establece las características de entorno que controlan las opciones de salida

  • « ingres_rollback
  • ingres_unbuffered_query »
  • PHP Manual
  • Funciones de Ingres
  • Establece las características de entorno que controlan las opciones de salida

ingres_set_environment

(PECL ingres >= 1.2.0)

ingres_set_environment — Establece las características de entorno que controlan las opciones de salida

Descripción

ingres_set_environment ( resource $link , array $options ) : bool

ingres_set_environment() se invoca para establecer las opciones de entorno que afectan a la salida de cierots valores desde Ingres, tales como la zona horaria, el format de fecha, el carácter separador decimal, y la precisión del tipo float.

Parámetros

link

El identificador de enlace de la conexión

options

Un array enumerado de pares nombre/valor de opciones. La siguiente tabla enumera el nombre de la opción y el tipo esperado

Nombre de la opción | Tipo de la opción | Descripción | Ejemplo
date_century_boundary | integer | El umbral por el cual se determina si un año de dos dígitos está en el siglo actual o en el siglo siguiente. Equivalente a II_DATE_CENTURY_BOUNDARY. | 50
timezone | string | Controla la zona horaria de la sesión. Si no se establece, se usará el valor definido por II_TIMEZONE_NAME. Si II_TIMEZONE_NAME no está definido, se usarán NA-PACIFIC (GMT-8 con horara de verano). | UNITED-KINGDOM
date_format integer

Establece el formato de entrada y salida permisible para las fechas de Ingres. El valor predeterminado es el definido por II_DATE_FORMAT. Si II_DATE_FORMAT no está establecido, se usará el formato de fecha US, p.j. mm/dd/aa. Los valores válidos para date_format son:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_MULTINATIONAL4
decimal_separator string El identificador del carácter para los datos decimales ","
money_lort integer

El símbolo monetario que va antes o después del valor. Los valores válidos para money_lort son:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_TRAILING
money_sign string El símpbolo monetario a usar con el tipo de datos MONEY €
money_precision | integer | La precisión del tipo de datos MONEY | 3
float4_precision | integer | La precisión del tipo de datos FLOAT4 | 10
float8_precision | integer | La precisión del tipo de datos FLOAT8 | 10
blob_segment_length | integer | La cantidad de datos en bytes a obtener de una vez cuando se recuperan datos BLOB o CLOB. El valor predeterminado es de 4096 si no se establece explícitamente | 8192

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer el formato de fecha a ISO4

<?php
$opciones = array( "date_format" => INGRES_DATE_ISO4 );

if (ingres_set_environment($enlace, $opciones))
{
    $result=ingres_query($enlace,"select date('now') as date");

    while ( $objeto = ingres_fetch_object ($resultado) ) {
        echo $objeto->date."\n";
    }
}
?>

Ejemplo #2 Set timezone to HONG-KONG

<?php

$opciones = array( "timezone" => "HONG-KONG");

if (ingres_set_environment($enlace, $opciones))
{
    $result=ingres_query($enlace,"select date('now') as date");

    while ( $objeto = ingres_fetch_object ($resultado) ) {
        echo $objeto->date."\n";
    }
}
?>

Ver también

  • ingres_connect() - Abre una conexión a una base de datos de Ingres
  • ingres_query() - Envía una consulta SQL a Ingres


Envía una consulta SQL no almacenada en búfer a Ingres

  • « ingres_set_environment
  • Mongo »
  • PHP Manual
  • Funciones de Ingres
  • Envía una consulta SQL no almacenada en búfer a Ingres

ingres_unbuffered_query

(No hay información de versión disponible, podría estar únicamente en Git)

ingres_unbuffered_query — Envía una consulta SQL no almacenada en búfer a Ingres

Descripción

ingres_unbuffered_query ( resource $link , string $query , array $params = ? , string $types = ? ) : mixed

ingres_unbuffered_query() sends the given query to the Ingres server.

La consulta es parte de la transacción abierta actualmente. Si no hay ninguna transacción abierta, ingres_unbuffered_query() abrirá una nueva. Para cerrar la transacción, se puede llamar tanto a ingres_commit() para consignar los cambios hechos a la base de datos, como a ingres_rollback() para cancelar dichos cambios. Cuando el script finaliza, cualquier transacción abierta será revertida (invocando a ingres_rollback()). También se puede usar ingres_autocommit() antes de abrir una nueva transacción para que cada consulta SQL sea consignada automáticamente. Igres solamente permite la activación de una sentencia almacenada en búfer. La extensión cerrará cualquier sentencia no almacenada en búfer activa antes de ejecuatar una sentencia SQL. Además, no se puede usar ingres_result_seek() para posicionar la fila antes de la obtención.

Nota: Configuraciones relacionadas

Véanse tambén las directivas ingres.describe y ingres.utf8 en la sección Configuración en tiempo de ejecución.

Parámetros

link

El identificador de enlace de la conexión

query

Una consulta SQL válida (véase la Guía de referencia de SQL en la documentación de Ingres). Véase el parámetor query de ingres_query() para una lista de las sentencias SQL que no se pueden ejecutar mediante ingres_unbuffered_query().

Los datos dentro de la consulta deberían estar apropiadamente escapados.

params

Un array de valores de parámetros para usarlos con la consulta

types

Un string que contiene una secuencia de los tipos de los valores de los parámetros pasados. Véaes el parámetro types de ingres_query() para una lista de los códigos de los tipos.

Valores devueltos

ingres_unbuffered_query() devuelve un identificador de resultados de consulta cuando hay más filas que obtener, o false cuando no hay más filas, como en el case de las sentencias sentencia INSERT, UPDATE o DELETE. Para comprobar si ocurrió un error, use ingres_errno(), ingres_error() o ingres_errsqlstate().

Ejemplos

Ejemplo #1 Ejecutar un SELECT sencillo no almacenado en búfer

<?php
$enlace = ingres_connect("demodb");

$resultado = ingres_unbuffered_query($enlace, "select * from user_profile");
while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
?>

Ejemplo #2 Passing query parameters to ingres_unbuffered_query()

<?php
$enlace = ingres_connect("demodb");

$params[] = "Emma";
$query = "select * from user_profile where up_first = ?";
$resultado = ingres_unbuffered_query($enlace, $query, $params);
while ($fila = ingres_fetch_row($resultado)) {
    echo $fila[1];
    echo $fila[2];
}
?>

Ejemplo #3 Insertar datos BLOB con tipos de parámetros

<?php
$enlace = ingres_connect("demodb");

//Abrir una foto
$fh = fopen("photo.jpg","r");
$datos_blob = stream_get_contents($fh);
fclose($fh);

//Preparar los parámetros
$parámetros[] = $datos_blob;
$parámetros[] = 1201;

//Definir los tipos de parámetros
$tipos_parámetros = "Bi";

$consulta = "update user_profile set up_image = ? where up_id = ?";
$resultado = ingres_unbuffered_query($enlace, $consulta , $parámetros, $tipos_parámetros);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}
?>

Ver también

  • ingres_query() - Envía una consulta SQL a Ingres
  • ingres_fetch_array() - Obtiene una fila de resultados en un array
  • ingres_fetch_assoc() - Obtienen una fila de resultados en un array asociativo
  • ingres_fetch_object() - Obtiene una fila de resultados en un objeto
  • ingres_fetch_row() - Obtiene una fila de resultados en un array enumerado
  • ingres_commit() - Consigna una trasacción
  • ingres_rollback() - Revierte una transacción
  • ingres_autocommit() - Activa o desactiva la autoconsigna
  • ingres_set_environment() - Establece las características de entorno que controlan las opciones de salida
  • ingres_errno() - Obtiene el número del último error generado de Ingres
  • ingres_error() - Obtener un mensaje de error coherente del último error generado


Controlador de MongoDB (antiguo)

  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Manual
    • Tutorial
    • Preferencias de lectura
    • Asuntos de Escritura (Write Concerns)
    • Tabla de correlación de SQL a Mongo
    • Conexión
    • Opciones de Contexto de flugo
    • Escrituras
    • Consultas
    • Actualizaciones
    • Seguridad
    • Solución a problemas
    • Ejecutar los test del controlador
  • Clases del núcleo
    • MongoClient — La clase MongoClient
    • MongoDB — La clase MongoDB
    • MongoCollection — La clase MongoCollection
    • MongoCursor — La clase MongoCursor
    • MongoCursorInterface — La interfaz MongoCursorInterface
    • MongoCommandCursor — La clase MongoCommandCursor
  • Tipos
    • MongoId — La clase MongoId
    • MongoCode — La clase MongoCode
    • MongoDate — La clase MongoDate
    • MongoRegex — La clase MongoRegex
    • MongoBinData — La clase MongoBinData
    • MongoInt32 — La clase MongoInt32
    • MongoInt64 — La clase MongoInt64
    • MongoDBRef — La clase MongoDBRef
    • MongoMinKey — La clase MongoMinKey
    • MongoMaxKey — La clase MongoMaxKey
    • MongoTimestamp — La clase MongoTimestamp
  • Clases de GridFS
    • MongoGridFS — Clase MongoGridFS
    • MongoGridFSFile — Clase MongoGridFSFile
    • MongoGridFSCursor — Clase MongoGridFSCursor
  • Clases de procesamiento por lotes
    • MongoWriteBatch — La clase MongoWriteBatch
    • MongoInsertBatch — La clase MongoInsertBatch
    • MongoUpdateBatch — The MongoUpdateBatch class
    • MongoDeleteBatch — La clase MongoDeleteBatch
  • Miscelánea
    • MongoLog — La clase MongoLog
    • MongoPool — La clase MongoPool
    • Mongo — La clase Mongo [obsoleta]
  • Funciones de Mongo
    • bson_decode — Decodifica un objecto BSON a un array PHP
    • bson_encode — Serializa una variable PHP a un string BSON
  • Excepciones
    • MongoException — Clase MongoException
    • MongoResultException — La clase MongoResultException
    • MongoCursorException — La clase MongoCursorException
    • MongoCursorTimeoutException — La clase MongoCursorTimeoutException
    • MongoConnectionException — Clase MongoConnectionException
    • MongoGridFSException — Clase MongoGridFSException
    • MongoDuplicateKeyException — La clase MongoDuplicateKeyException
    • MongoProtocolException — La clase MongoProtocolException
    • MongoExecutionTimeoutException — La clase MongoExecutionTimeoutException
    • MongoWriteConcernException — La clase MongoWriteConcernException
  • Registro de cambios


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución
Advertencia

Esta extensión está obsoleta. Debe usarse en su lugar la extensión MongoDB.


Instalación

Advertencia

Esta extensión está obsoleta. Debe usarse en su lugar la extensión MongoDB.

El controlador de MongoDB para PHP debe funcionar en cualquier sistema: Windows, Mac OS X, Unix, y Linux; en máquinas «little-endian» y «big-endian»; en plataformas de 32 y 64 bits; en PHP 5.3 hasta 5.6 (las versiones anteriores a la 1.6 también admiten PHP 5.2).

Esta extensión » PECL no se distribuye con PHP.

  • Instalación manual
  • Instalación en *NIX
  • Instalación en Windows
  • OS X
  • Gentoo
  • Red Hat
  • Instrucciones de instalación de terceros

Instalación manual

Para los desarrolladores de controladores y los interesados en las últimas correcciones, el controlador se puede compilar desde las últimas versiones en » Github. Ir a Github y presione en el botón "download". Ejecute:

$ tar zxvf mongodb-mongodb-php-driver-<commit_id>.tar.gz
$ cd mongodb-mongodb-php-driver-<commit_id>
$ phpize
$ ./configure
$ make all
$ sudo make install

Realice los siguientes cambios en php.ini:

  • Asegúrese de que la variable extension_dir este apuntando al directrio que contiene mongo.so. El build se mostrará dónde se encuetre instalado el controlador de PHP, la salida será algo similar a esto:

    Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/mongo.so'
    Asegúrese de que este en el mismo directorio en donde PHP se encuentre, ejecute:
    $ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    Si no es así, cambia extension_dir en php.ini o mueva mongo.so

  • Para cargar la extensión en el arranque de PHP, agregar una línea:

    extension=mongo.so

Instalación en *NIX

Ejecute:

$ sudo pecl install mongo

Agregar la siguiente línea en el fichero php.ini:

extension=mongo.so

Si pecl se quedará sin memoria al instalar, asegúrese de que memory_limit en php.ini sea de al menos de 32MB.

Instalación en Windows

Los binarios precompilados para cada versión están disponibles en » PECL para una gran variedad de combinaciones de versiones, seguridad en hilos, y bibliotecas VC. Descomprima el fichero y copie php_mongo.dll en el directorio de extensiones de PHP ("ext" por omisión).

Agregar la siguiente línea al fichero php.ini:

extension=php_mongo.dll

Nota: Dependencias de DLL adicionales para usuarios de Windows

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: libsasl.dll

OS X

En la mayoría de los casos la instalación es más sencilla desde pecl:

$ sudo pecl install mongo

Si utiliza » Homebrew, el tap de PHP incluye una fórmula para el cotrolador. Por ejemplo, se podría instalar el controlador para PHP 5.6 con el siguiente comando:

$ brew install php56-mongo

Si utiliza » XAMPP, observe que tiene su propio binario de pecl y fichero de cofiguración php.ini. Debería poder instalar el controlador con el siguiente comando:

$ sudo /Applications/XAMPP/xamppfiles/bin/pecl install mongo

Nota: Dependencia de Xcode para compilar sobre OS X

La compilación del controlador sobre OS X requiere las herremientas de desarrollo Xcode, las cuales pueden ser instaladas con xcode-select --install. Si el comnado no está disponible, se ha de instalar primero el paquete » Command Line Tools.

Gentoo

Gentoo tiene un paquete para el controlador de PECL de PHP llamado dev-php5/mongo que puede ser instalado con:

$ sudo emerge -va dev-php/pecl-mongo

Si se utiliza PECL, quizá obtiene un error de versión incorrecta en libtool. Compile desde las fuentes que necesite y ejecute aclocal y autoconf.

$ phpize
$ aclocal
$ autoconf
$ ./configure
$ make
$ sudo make install

Red Hat

Incluye Fedora y CentOS

En estos sistemas, la configuración predeterminada de Apache no permite a las peticiones establecer conexiones de red, haciendo que el driver genere errores de "Permiso denegado" cuando se intenta conectar a la base de datos. Si este fuera el caso, pruebe a ejecutar:

$ /usr/sbin/setsebool -P httpd_can_network_connect 1
Y finalmente reinicie Apache. (Este comportamiento también se da con SELinux.)

Instrucciones de instalación de terceros

Un gran número de personas han creado excelentes tutoriales de instalación de controlador de PHP.

  • » (Re)instalar PHP en Mac OS X

    Este excelente artículo de Justin Hileman detalla la instalación de PHP y de extensiones adicionales con Homebrew sobre OS X. Estas instrucciones complementan las anteriores de esta página para instalar el controlador con Homebrew.

  • » PHP 5.3.1 condebug, MongoDB y Lithium sobre Ubuntu 9.10 / Apache 2.2

    Este 'screencast' de Jon Adams muestra cómo comenzar rápidamente con PHP 5.3.1, Xdebug, y MongoDB en Ubuntu 9.10 con Apache.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Mongo
Nombre | Por defecto | Cambiable | Historial de cambios
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Eliminado en 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Añadido en 1.2.10, antes de 1.3.0 el valor predeterminado era 60.
mongo.long_as_object | o | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Antes de la versión 1.5.0, el valor predeterminado era 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Añadido en 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mongo.allow_empty_keys int

Añadido en la versión 1.0.11.

Si deberían permitirse las cadenas vacías ("") como nombres de claves. Por omisión, el controlador lanzará una excepción si se intenta pasar la cadena vacía como una clave a la base de datos. Es extremadamente fácil hacer esto inadvertidamente usando comillas dobles con operadores $, por lo que se recomienda que se deje este ajuste predeterminado. Sin embargo, si se necesita guardar claves que son cadenas vacías, se puede establecer esta opción a true para que el controlador permita pasar cadenas vacías a la base de datos.

mongo.allow_persistent int

Indica si se permiten o no conexiones persistentes. (Eliminado en 1.2.0 - ahora todas las conexiones son persistentes).

mongo.chunk_size int

El número de bytes por bloque. Se usa al fragmentar ficheros GridFS. Este valor debe ser al menos 100 veces menor que 4 megabytes (máx: 4194204) y se recomienda que sea incluso menor.

mongo.cmd string

Un carácter que se utiliza en lugar de $ en los modificadores y comparaciones.

En vista de que es fácil olvidar escapar el carácter "$", puede elegirse cualquier otro en su lugar. Escoja un carácter que no aparezca en sus nombres de clave, como por ejemplo ":":

mongo.cmd = ":"

Ahora, para hacer una comparación, sería:

<?php

$query = array( "i" => array( ":gt" => 20, ":lte" => 30 ) );

?>

Puede cambiarse también en tiempo de ejecución usando ini_set("mongo.cmd", ":"). Por supuesto, también pueden usarse comillas simples o la barra \ para escapar el carácter $.

mongo.default_host string

Nombre de host predeterminaodo en caso de que no se especifique en el constructor.

mongo.default_port string

Puerto TCP predeterminado al conectar al servidor de bases de datos en caso de que no se especifique ningún puerto. El predeterminado para la base de datos es 27017.

mongo.is_master_interval int

Añadido en la versión 1.2.10.

Para conexiones de conjuntos réplica: El intervalo mínimo con el que el controlador enviará peticiones "isMaster" al servidor MongoDB. Si el valor es bajo, existirán más peticiones, pero el controlador será más rápido si la topología del conjunto réplica ha sido cambiada.

mongo.long_as_object int

Devuelve un BSON_LONG como una instancia de MongoInt64 (en lugar de usar el tipo primitivo).

mongo.native_long int

Este valor predeterminado ha cambiado a true en 1.5.0, deberá asegurarse de establecer el valor deseado (probablemente true) de manera que el comportamiento del controlador no se vea afectado al actualizarlo.

En plataformas de 64 bits, el ajuste mongo.native_long permite almacenar enteros de 64 bits en MongoDB. Si no se habilita, sólo se podrán almacenar enteros de 32 bits. El tipo de dato MongoDB usado en este caso es el BSON LONG, en lugar del BSON INT, que es el que funciona cuando se deshabilita este ajuste.

Este ajuste también cambia el modo en que los tipos BSON LONG se comportan cuando se consultan en MongoDB. Cuando mongo.native_long no está habilitado, el driver convierte todos los BSON LONG al tipo double de PHP, por lo que podría provocar una pérdida de precisión.

En plataformas de 32 bits, el ajuste mongo.native_log no tiene efecto al almacenar enteros en MongoDB: los enteros se almacenan como BSON INT. Sin embargo, cuando este ajuste está habilitado y se consulta un tipo BSON LONG en MongDB, se emitirá una excepción MongoCursorException alertando de que los datos podrían no leerse sin pérdida de precisión.

Se recomienda que, en sistemas de 32 bits especialmente, se combine esto con la habilitación de mongo.long_as_object.

mongo.ping_interval int

Añadido en la versión 1.2.10.

Para conexiones de conjuntos réplica: El intervalo mínimo con el que el controlador enviará peticiones "ping" al servidor MongoDB. Si el valor es bajo, existirán más pings, pero el controlador será más rápido si un nodo ya no sepuede recuperar del conjunto réplica.

mongo.utf8 int

Indica si se debe lanzar una excepción con cadenas que no sean UTF8. Hasta la versión 1.0.4, el controlador de PHP ignoraba las cadenas que no eran UTF8, incluso cuando no se esperaba que se fueran a insertar. Desde 1.0.4, el controlador emite una MongoException. Para facilitar la transición en las aplicaciones que insertan cadenas que no son UTF8, puede deshabiltiarse esta opción para emular el comportamiento anterior en el que no se emitían excepciones. Sin embargo, esta opción será eliminada en la versión 1.1.0, de manera que siempre se emitirán excepciones en textos que no son UTF8.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

MONGO_STREAMS (integer)
Alias de MONGO_SUPPORTS_STREAMS
MONGO_SUPPORTS_STREAMS (integer)
1 cuando se compila con Flujos de PHP (lo predeterminado desde 1.4.0).
MONGO_SUPPORTS_SSL (integer)
1 cuando OpenSSL está habilitado y disponible.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_CR (integer)
1 cuando la autenticación MongoDB-Challenge/Reponse está compilada.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_X509 (integer)
1 cuando la autenticación x.509 está compilda.
MONGO_SUPPORTS_AUTH_MECHANISM_GSSAPI (integer)
1 cuando la autenticación GSSAPI está compilda.
MONGO_SUPPORTS_AUTH_MECHANISM_PLAIN (integer)
1 cuando la autenticación PLAIN está compilda.
MONGO_STREAM_NOTIFY_TYPE_IO_INIT (integer)
MONGO_STREAM_NOTIFY_TYPE_LOG (integer)
MONGO_STREAM_NOTIFY_IO_READ (integer)
MONGO_STREAM_NOTIFY_IO_WRITE (integer)
MONGO_STREAM_NOTIFY_IO_PROGRESS (integer)
MONGO_STREAM_NOTIFY_IO_COMPLETED (integer)
MONGO_STREAM_NOTIFY_LOG_INSERT (integer)
MONGO_STREAM_NOTIFY_LOG_QUERY (integer)
MONGO_STREAM_NOTIFY_LOG_UPDATE (integer)
MONGO_STREAM_NOTIFY_LOG_DELETE (integer)
MONGO_STREAM_NOTIFY_LOG_GETMORE (integer)
MONGO_STREAM_NOTIFY_LOG_KILLCURSOR (integer)
MONGO_STREAM_NOTIFY_LOG_BATCHINSERT (integer)
MONGO_STREAM_NOTIFY_LOG_RESPONSE_HEADER (integer)
MONGO_STREAM_NOTIFY_LOG_WRITE_REPLY (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_INSERT (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_UPDATE (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_DELETE (integer)
MONGO_STREAM_NOTIFY_LOG_WRITE_BATCH (integer)


Manual

Tabla de contenidos

  • Tutorial
  • Preferencias de lectura
  • Asuntos de Escritura (Write Concerns)
  • Tabla de correlación de SQL a Mongo
  • Conexión
  • Opciones de Contexto de flugo
  • Escrituras
  • Consultas
  • Actualizaciones
  • Seguridad
  • Solución a problemas
  • Ejecutar los test del controlador
Advertencia

Esta extensión está obsoleta. Debe usarse en su lugar la extensión MongoDB.

Este manual trata algunos detalles sobre cómo usar MongoDB, aunque mayormente cubre el uso del controlador de PHP. Para más información sobre cómo diseñar un esquema, qué significa cada término, y cómo configurar el servidor de bases de datos, revise la » documentación de MongoDB.


Tutorial

Tabla de contenidos

  • Estableciendo una Conexión
  • Obteniendo una Base de Datos
  • Obteniendo Una Colección
  • Insertando un Documento
  • Localizando documentos usando MongoCollection::findOne
  • Añadiendo Múltiples Documentos
  • Contando los Documentos de una Colección
  • Usando un Cursor para Obtener Todo de los Documentos
  • Estableciendo el Criterio de la Consulta
  • Consultando un Conjunto de Documentos con una Consulta
  • Creando un Índice
Advertencia

Esta extensión está obsoleta. Debe usarse en su lugar la extensión MongoDB.

Este es el controlador oficial de MongoDB para PHP.

Lo siguiente es una muestra de código que conecta, inserta documentos, consulta a documentos, itera sobre resultados de consultas, y desconecta de MongoDB. Hay más detalles de cada paso del tutorial más abajo.

<?php

// conectar
$m = new MongoClient();

// seleccionar una base de datos
$bd = $m->comedy;

// seleccionar una colección (equivalente a una tabla en una base de datos relacional)
$colección = $bd->cartoons;

// añadir un registro
$documento = array( "title" => "Calvin and Hobbes", "author" => "Bill Watterson" );
$colección->insert($documento);

// añadir un nuevo registro, con un distinto "perfil"
$documento = array( "title" => "XKCD", "online" => true );
$colección->insert($documento);

// encontrar todo lo que haya en la colección
$cursor = $colección->find();

// recorrer el resultado
foreach ($cursor as $documento) {
    echo $documento["title"] . "\n";
}

?>

El resultado del ejemplo sería:

Calvin and Hobbes
XKCD


Estableciendo una Conexión

Para conectar al servidor de bases de datos, utilice alguna de las siguientes formas:

<?php
$conexión = new MongoClient(); // conectar a localhost:27017
$conexión = new MongoClient( "mongodb://example.com" ); // conectar a un host remoto (puerto predeterminado: 27017)
$conexión = new MongoClient( "mongodb://example.com:65432" ); // concectar a un host remoto en un puerto dado
?>

No es necesario desconectar explícitamente de la base de datos. El controlador usa conexiones persistentes y reutilizará las conexiones ya establecidas.

Ver también

El capítulo connecting cubre los distintos tipos de conexiones.

Tanto la documentación de la API de la clase MongoClient como MongoClient::__construct() proporcionan un exhaustivo repaso a todas las opciones disponibles, y un gran número de ejemplos.


Obteniendo una Base de Datos

Para seleccionar una base de datos, utilice.

<?php
$conexión = new MongoClient();
$bd = $conexión->dbname;
?>

La base de datos no debe necesariamente haber sido ya creada, sino que pueden crearse con sólo seleccionarlas.

¡Tenga cuidado con los errores tipográficos! Podría, por inadvertencia, crear una nueva base de datos, provocando errores (aquí, name está mal escrito como anme en la segunda selección:

<?php
$conexión = new MongoClient();

$bd = $conexión->mybiglongdbname;
// hacemos algo

$bd = $conexión->mybiglongdbanme;
// ¡ahora estamos conectando a una nueva base de datos!
?>

Ver También

La documentación API de la clase MongoDB contiene más información sobre los objetos de bases de datos.


Obteniendo Una Colección

Para obtener una conexión se utiliza la misma sintaxis que para obtener una base de datos:

<?php
$conexión = new MongoClient();
$bd = $conexión->baz;

// seleccionar una colección:
$colección = $bd->foobar;

// o, directamente una base de datos y una colección:
$colección = $conexión->baz->foobar;
?>

Las colecciones son análogos a las tablas (para aquéllos que estén familiarizados con bases de datos relacionales).

Ver También

La documentación API de la clase MongoCollection contiene más información sobre objetos de colecciones.


Insertando un Documento

Los objetos básicos para almacenar en una colección de una base de datos son los arrays asociativos. Un "documento" cualquiera podría ser:

<?php
$doc = array(
    "name" => "MongoDB",
    "type" => "database",
    "count" => 1,
    "info" => (object)array( "x" => 203, "y" => 102),
    "versions" => array("0.9.7", "0.9.8", "0.9.9")
);
?>

Observe que se pueden tener arrays y objetos anidados. El controlador siempre almacenará un array asociativo como un objeto en la base de datos. Un array indexado numéricamente es almacenado como un array en caso de que las claves empiecen en 0 y no estén interrumpidas, y como un objeto si las claves del array no empiezan en 0 o tienen huecos (esto es: 0, 1, 4, 5).

Para insertar este documento, utilice MongoCollection::insert():

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$colección->insert( $doc );
?>

Ver También

La documentación API de MongoCollection::insert() contiene más información sobre la inserción de datos.


Localizando documentos usando MongoCollection::findOne

  • « Insertando un Documento
  • Añadiendo Múltiples Documentos »
  • PHP Manual
  • Tutorial
  • Localizando documentos usando MongoCollection::findOne

Localizando documentos usando MongoCollection::findOne()

Para comprobar que el documento que insertamos en el paso anterior está almacenado en la base de datos, podemos realizar una operación MongoCollection::findOne() para obtener un único documento de la colección. Este método es útil cuando sólo hay un documento que concuerde con la consulta, o cuando sólo se está interesado en un resultado.

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$documento = $colección->findOne();
var_dump( $documento );
?>

El resultado del ejemplo sería:

array(6) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "4e2995576803fab768000000"
  }
  ["name"]=>
  string(7) "MongoDB"
  ["type"]=>
  string(8) "database"
  ["count"]=>
  int(1)
  ["info"]=>
  array(2) {
    ["x"]=>
    int(203)
    ["y"]=>
    int(102)
  }
  ["versions"]=>
  array(3) {
    [0]=>
    string(5) "0.9.7"
    [1]=>
    string(5) "0.9.8"
    [2]=>
    string(5) "0.9.9"
  }
}

Hay un campo _id que se ha añadido automáticamente al documento. _id es el campo de la "clave primaria". Si el documento no especifica una, el controlador la añadirá automáticamente.

Si se ha especificado un campo _id, debe ser único en toda la colección. Por ejemplo:

<?php
$conexión = new MongoClient();
$bd = $conexión->database;

$bd->foo->insert(array("_id" => 1));
// esto lanzará una excepción
$bd->foo->insert(array("_id" => 1));

// esto está bien, ya que es una colección diferente
$bd->bar->insert(array("_id" => 1));
?>

Por omisión, el controlador se asegurará de que el servidor ha aceptado la escritura antes de devolver. Opcionalmente se puede desactivar este comportamiento pasando array("w" => 0) como segundo argumento. Esto significa que el controlador debería no esperar a que la base de datos acepte la escritura y no lanzar la excepción de _id duplicado.

Ver También

MongoCollection::findOne() contiene más información sobre cómo localizar datos.

MongoId ofrece más detalles de los identificadores únicos.

La sección writes trata las escrituras en mayor profundidad, y el capítulo Asuntos de Escritura (Write Concerns) entra en detalles sobre las diferentes opciones de Write Concern.


Añadiendo Múltiples Documentos

Para hacer más interesante el tema de las consultas, vamos a añadir varios documentos a la colección. Estos documentos serán simplemente de la forma array( "i" => value ); y podemos hacerlo de un modo muy eficiente en un bucle:

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

for ( $i = 0; $i < 100; $i++ )
{
    $colección->insert( array( 'i' => $i, "field{$i}" => $i * 2 ) );
}
?>

Tenga en cuenta que podemos insertar en una misma colección arrays con claves diferentes. A esta característica nos referimos cuando decimos que MongoDB es independiente de esquemas. En el ejemplo de arriba cada documento tiene un campo i, aunque también un nombre de campo en la forma field + $i.


Contando los Documentos de una Colección

Ahora que hemos insertado 101 documentos (los 100 del bucle, junto con el primero), podemos comprobar si los tenemos todos usando el método MongoCollection::count().

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

echo $colección->count();
?>
y debería mostrar 101.


Usando un Cursor para Obtener Todo de los Documentos

Para obtener todos los documentos, usaremos MongoCollection::find(). El método find() devuelve un objeto MongoCursor que nos permite recorrer el conjunto de documentos que concuerdan con nuestra consulta. De ese modo, para consultar todos los documentos y mostrarlos por pantalla:

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$cursor = $colección->find();
foreach ( $cursor as $id => $valor )
{
    echo "$id: ";
    var_dump( $valor );
}
?>
y mostrará los 101 documentos de la colección. $id es el campo _id del documento (transformado a string) y $valor es el documento en sí.

Ver También

La documentación API de MongoCollection::find() contiene más información sobre cómo localizar datos.


Estableciendo el Criterio de la Consulta

Podemos crear una consulta para pasar al método MongoCollection::find() y así obtener un subconjunto de documentos de nuestra colección. Por ejemplo, si quisiéramos encontrar el documento cuyo valor en el campo "i" es 71, haríamos lo siguiente:

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$consulta = array( 'i' => 71 );
$cursor = $colección->find( $consulta );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

El resultado del ejemplo sería:

array(2) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["i"]=>
  int(71)
  ["_ns"]=>
  "testCollection"
}


Consultando un Conjunto de Documentos con una Consulta

Podemos usar la consulta para obtener un conjunto de documentos de nuestra colección. Por ejemplo, si quisiéramos obtener todos los documentos en los que "i" > 50, podríamos poner:

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$consulta = array( "i" => array( '$gt' => 50 ) ); // observar las comillas simples de '$gt'
$cursor = $colección->find( $consulta );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

lo cual mostraría los documentos en que "i" > 50. Podemos también consultar un rango, digamos 20 < i <= 30:

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$consulta = array( 'i' => array( '$gt' => 20, "\$lte" => 30 ) );
$cursor = $colección->find( $consulta );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

Recuerde escapar siempre el símbolo $ o utilizar comillas simples. Si no, PHP lo interpretará como la variable $gt.


Creando un Índice

MongoDB soporta índices, y es muy fácil añadirlos a una colección. Para crear un Índice, debe indicar el nombre del campo y la dirección: ascendente (1) o descendente (-1). A continuación, creamos un índice ascendente en el campo "i":

<?php
$conexión = new MongoClient();
$colección = $conexión->database->collectionName;

$colección->ensureIndex( array( "i" => 1 ) );  // crear un índice en "i"
$colección->ensureIndex( array( "i" => -1, "j" => 1 ) );  // índice de "i" descendente, "j" ascendente
?>

A medida que los datos crecen, la indexación se vuelve crítica para un buen rendimiento de lectura. Si no está familiarizado con las indexaciones, revise la documentación de MongoCollection::ensureIndex() y l a » documentación de indexación de MongoDB.


Preferencias de lectura

MongoDB 2.2 y la versión 1.3.0 del controlador añaden el soporte para » preferencias de lectura, que permiten controlar cuántas consultas son dirigidas a instancias de mongod en un entorno de conjunto de réplica. Las preferencias de lectura podrían especificarse en función a cada conexión, cada base de datos, o cada colección. Las preferencias definidas en un nivel más alto serán heredadas de forma predeterminada (p.ej. MongoCollection heredará las preferencias de lectura definidas en la instancia de MongoDB conrrespondiente).

Las preferencias de lectura son especificadas con una combinación de modos y conjuntos de etiquetas. Los modos determinan cómo se priorizan instancias, mientras que los » conjuntos de etiquetas especifican criterios para elegir instancias de mongod. Las instancias de mongod solamente son elegibles si el timepo de ping está dentro de 15ms desde la instancia de mongod más cercana.

Modos de preferencias de lectura

Advertencia

Todos los modos de preferencias de lectura excepto MongoClient::RP_PRIMARY podrían devolver datos antiguos, puesto que los secundarios replican operaciones del primario con alguna demora. Asegúrese de que su aplicación puede admitir datos antiguos si elige usar un modo distinto de MongoClient::RP_PRIMARY.

  • MongoClient::RP_PRIMARY

    Todas las opearciones de lectura utilizarn únicamente el primario del conjunto de réplica actual. Esto es lo predeterminado. Si el primario no está disponible, las operaciones de lectura producirán una excepción.

    Este modo es incompatible con el uso de conjuntos de etiquetas. Especificar un conjunto de etiquetas con MongoClient::RP_PRIMARY resultará en una excepción.

  • MongoClient::RP_PRIMARY_PREFERRED

    En muchas situaciones, las operaciones leen desde el miembro primario del conjunto. Sin embargo, si el primario no está disponible, como durante situaciones de tolerancia a fallos, las operacoines leen desde miembros secundarios.

    Cuando la preferencias de lectura incluye un conjunto de etiquetas, el cliente lee primero desde el primario, si está disponible, y luego desde los secundarios que coinciden con las etiquetas especificadas. Si ningún segundario coincide con alguna etiqueta, la operación de lectura producirá una excepción.

    Advertencia

    La versión 2.2 de mongos añade soporte completo para preferencias de lectura. Al conectar a instancias más antiguas de mongos, MongoClient::RP_PRIMARY_PREFERRED enviará las consultas a los secundarios.

  • MongoClient::RP_SECONDARY

    Operations read only from the secondary members of the set. If no secondaries are available, read operations will produce an exception.

    La mayoría de los conjuntos tienen al menos un secundario, pero hay situaciones donde podría no haber ningún secundario disponible. Por ejemplo, un conjunto con un primario, un secundario, y un árbitro podría no tener ningún secundario si un miembro está en estado de recuperación o indisponible.

    Cuando la preferencia de lectura incluye un conjunto de etiquetas, el cliente intenta encontrar miembros secundarios que coincidan con el conjunto de etiquetas especificado y dirigir las lecturas a un secundario aleatorio de entre el grupo más cercano. Si ningún secundario ha coincidido con las etiquetas, la operación de lectura producirá una excepción.

  • MongoClient::RP_SECONDARY_PREFERRED

    En muchas situaciones, las operaciones leen desde miembros secundarios, pero en situaciones donde el conjunto consiste el un único primario sin ningún otro miembro, la operación de lectura usará el primario del conjunto.

    Cuando la preferencia de lectura incluye un conjunto de etiquetas, el cliente intenta encontrar un miembro secundario que coincida con el conjunto de etiquetas especificado y dirigir las lecturas a un secundario aleatorio de entre el grupo más cercano. Si ningún secundario ha coincidido con las etiquetas, la operación de lectura producirá una excepción.

  • MongoClient::RP_NEAREST

    El controlador lee desde un miembro aleatorio del conjunto que posea un timepo de ping que sea menos de 15ms más lento que el miembro con el tiempo de ping más lento. Las lecturas en el modo MongoClient::RP_NEAREST no consideran el tipo de miembro y podría leerse tanto desde primarios como de secundarios.

    Establezca este modo para minimizar el efecto de latencia de red en operaciones de lectura sin tener preferencia para datos actuales o antiguos.

    Si se especifica un conjunto de etiquetas, el cliente intenta encontrar un miembro que coincida con el conjunto de etiquetas especificado y dirigir las lecturas a un nodo aleatorio de entre el grupo más cercano.

    Nota:

    Todas las operaciones leen desde el miembro más cercano del conjunto de réplica que coincida con el modo de preferencia de lectura especificado. El modo MongoClient::RP_NEAREST prefiere lecturas de baja latencia sobre un estado de miembro primario o secundario.

Conjuntos de etiquetas

Los » conjuntos de etiquetas permiten especificar criterios para que una aplicación pueda dirigir operaciones de lectura hacia miembros específicos, basándose en parámetros personalizados. Los conjuntos de etiquetas aseguran que las operaciones de lectura apunten a miembros de un centro de datos en particular o a instancias de mongod diseñadas para una clase de operaciones en concreto, tales como de información o análisis.

Se pueden especificar conjuntos de etiquetas con los siguientes modos de preferencia de lectura:

  • MongoClient::RP_PRIMARY_PREFERRED

  • MongoClient::RP_SECONDARY

  • MongoClient::RP_SECONDARY_PREFERRED

  • MongoClient::RP_NEAREST

No se pueden especificar conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY. Las etiquetas se aplican solamente al seleccionar un miembro secundario de un conjunto, excepto para el cuándo en el modo más cercano.

Especificar preferencias de lectura

Las preferencias de lectura se pueden especificar en una URI proporcionada a MongoClient::__construct(), el cual utiliza una sintaxis decadena de consulta, o mediante métodos modificadores (setter) en las clases núcleo, que usan una sintaxis de array para los conjuntos de etiquetas.

Cuando se especifican los modos de preferencia de lectura en una cadena de consulta, los conjuntos de etiquetas para el valor readPreferenceTags deberían ser una secuencia delimitada por comas de pares clave/valor delimitados por dos puntos.

Nota:

Cada conjunto de etiquetas definida en la cadena de consulta utilizará el nombre readPreferenceTags. A diferencia de cómo PHP pudiera tratar cadenas de consulta de URL, los valores sucesivos para readPreferenceTags no se sobrescribirán. El controlador recopilará conjuntos de etiquetas en el orden en que aparecen en la cadena de consulta.

Advertencia

¡Si el controlador no puede encontrar un conjunto de etiquetas coincidente, la lectura fallará! Es su responsabilidad el proporcionar recursos adecuados, tales como un valor de readPreferenceTags vacío para recurrir a "no tag set preference".

Ejemplo #1 Preferencias de lectura de URI de coneción con sintaxis de cadena de consulta

<?php
// Preferir el servidor más cercano sin preferencia de etiqueta
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Elegir el servidor más cercano en el centro de datos "east"
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir a un servidor en el centro de datos "west"
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east,use:reporting';
$uri .= '&readPreferenceTags=dc:west';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Preferir el servidor más cercano del centro de datos "east", luego un servidor del
// centro de datos "west", y finalmente recurrir a preferencia sin conjunto de etiquetas
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$uri .= '&readPreferenceTags=dc:west';
$uri .= '&readPreferenceTags=';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

Ejemplo #2 Establecer las preferencias de lectura con sintaxis de array para conjuntos de etiquetas

<?php

$m = new MongoClient('mongodb://rs1.example.com,rs2.example.com', array(
    'replicaSet' => 'rs',
));

// Preferir el servidor más cercano sin preferencia de etiqueta
$m->setReadPreference(MongoClient::RP_NEAREST, array());

// Elegir el servidor más cercano en el centro de datos "east"
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
));

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir a un servidor en el centro de datos "west"
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));

// Preferir el servidor más cercano del centro de datos "east", luego un servidor del
// centro de datos "west", y finalmente recurrir a preferencia sin conjunto de etiquetas
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
    array('dc' => 'west'),
    array(),
));
?>


Asuntos de Escritura (Write Concerns)

MongoDB proporciona diferentes maneras de seleccionar la duración de una escritura a la base de datos. Estas formas se llaman Asuntos de Escritura y lo abarcan todo: desde ignorar completamente todos los errores, a seleccionar específicamente qué servidores son necesarios para confirmar la escritura antes de devolver la operación.

Cuando una a escritura (como con MongoCollection::insert(), MongoCollection::update(), y MongoCollection::remove()) se le proporciona una opción de Asunto de Escritura ("w"), el controlador enviará la consulta a MongoDB y luego proseguirá con un comando getLastError (GLE) con la opción de Asunto de Escritura al mismo tiempo. El servidor solo devuelve cuando la condición de Asunto de Escritura se verifica que se cumple, o la consulta expira (controlado con la opción"wtimeout", 10000 milisegundos es lo predeterminado).

Advertencia

Incluso si un comando getLastError expira, los datos habrán sido escritos probablemente en el servidor primario y serán replicados a todos los secundarios una vez se hayan finalizado con ellos.

La típica razón para que una expiración ocurra es si se especifica un Asunto de Escritura que requiera confirmación de más servidores de los que estén disponibles en ese momento.

Cuando se usan escrituras reconocidas y el conjunto de réplica ha fallado, el controlador se desconectará automáticamente del primario, lanzando una excepción, e intentará encontrar un nuevo primario en la siguiente operación (una aplicación debe decidir si reintentar o no la operación en el nuevo primario).

Cuando se usan escrituras no reconocidas (w=0) y el conjunto de réplica ha fallado, no hay manera de que el controlador esté al tanto del campo, por lo que continuará y fallará en la escritura silenciosamente.

El Asunto de Escritura predeterminado para MongoClient es 1: operaciones de escritura reconocidas.

Asuntos de Escritura disponibles
Asunto de Escritura | Significado | Descripción
w=0 | Sin reconocimiento | A una escritura no le seguirá una llamada a GLE, por lo que no será verificada ("dispara y olvida")
w=1 | Con reconocimiento | El servidor reconocerá la escritura (el primario en una configuración de conjunto de réplica)
w=N | Reconocimiento por parte del conjunto de réplica | El servidor primario reconocerá la escritra, que será replicada a N-1 secundarios.
w=majority | Reconociemiento por la mayoría | La escritura será reconocia por la mayoría del conjunto de réplica (primario inclusive). Es un string reservado especial.
w=<tag set> | Reconocimiento por parte del conjunto de etiquetas del conjunto de réplica | La escritura será reconocida por miembros de conjunto de etiquetas completo
j=true | Con diario | El primario reconocerá la escritura y el diario será volcado a disco

Usar WriteConcerns

Cada método que causa escrituras (MongoCollection::insert(), MongoCollection::update(), MongoCollection::remove(), y MongoCollection::batchInsert()) permite un argumento opcional para enviar un conjunto de opciones al servidor de MongoDB. Con este array de opciones se puede establecer el WriteConcern como ilustra el siguiente ejemplo:

Ejemplo #1 Pasar un WriteConcern a una operación de escritura

<?php
// Establecer w=0 para insertar:
$colección->insert($someDoc, array("w" => 0));

// Establecer w=majority para acutalizar:
$colección->update($someDoc, $someUpdates, array("w" => "majority"));

// Establecer w=5 y j=true para eliminar:
$colección->update($someDoc, array("w" => 5, "j" => true));

// Establecer w="AllDCs" para batchInsert:
$colección->update(array($someDoc1, $someDoc2), array("w" => "AllDCs"));
?>

Además de establecer WriteConcerns por operación como un argumento de opción, es también posible establecer un WriteConcern predeterminado de diferentes formas.

La primera forma es a través de la cadena de conexión. La cadena de conexión acpeta las opciones journal, w, y wTimeoutMS:

Ejemplo #2 WriteConcerns en cadena de conexión

<?php
$m = new MongoClient("mongodb://localhost/?journal=true&w=majority&wTimeoutMS=20000");
?>

Desde la versión 1.5 del controlador, también es posible llamar a MongoDB::setWriteConcern() y a MongoCollection::setWriteConcern() para establecer un WriteConcern predeterminado para todas las operaciones creadas desde ese objeto MongoDB o MongoCollection específico:

Ejemplo #3 MongoDB::setWriteConcern y MongoCollection::setWriteConcern

<?php
$m = new MongoClient("mongodb://localhost/");
$d = $m->demoDb;
$c = $d->demoCollection;

// Establecer w=3 en el objeto de base de datos con un tiempo de espera de 25000ms
$d->setWriteConcern(3, 25000);

// Establecer w=majority en el objeto de colección sin cambiar el tiempo de espera
$c->setWriteConcern("majority");
?>

Escrituras no reconocidas

Al no requerir que el servidor reconozca las escrituras, estas se pueden realizar extremadamente rápido, pero no se sabrá si realmente han tenido éxito. Las escritura puede fallas por varias razones: si hay problemas de red, si un servidor de bases de datos falla, o si la escritura simplemente no era válida (p.ej., al escribir en una colección de sistema, o errores de clave duplicada).

Durante el desarrollo, siempre se deberían usar escrituras reconocidas (para evitar errores inadvertidos, tales como errores de sintaxis, operadores no válidos, errores de clave duplicada , etc.). En la producción, las escrituras no reconocidas se pueden usar para datos "no importantes". Estos varían según la aplicación, pero generalmente son datos automáticos (al contrario de generados por el usuario), como el rastreo de clics o ubicaciones GPS, donde se pueden obtener miles de registros por segundo.

Es muy recomendable realizar una escritura reconocida al final de una serie de escrituras no reconocidas. Esto no incurrirá en una penalización muy grande de redimiento, pero aún se puede capturar cualquier error que pudiera ocurrir.

Ejemplo #4 Asunto de escritura no reconocido, seguido de una escritura reconocida

<?php
$colección->insert($documento, array("w" => 0));
$colección->update($criterios, $nuevonObj, array("w" => 0));
$colección->insert($otraCosa, array("w" => 0));
try {
    $colección->remove($something, array("w" => 1));
} catch(MongoCursorException $e) {
    /* Manejar la excepción... */
    /* Aquí se debería emitir consultas find() en los IDs generados para
    $otraCosa y $documento, para verificar que han sido escritos en la base de datos
    e intentar resolver dónde ocurrió algo en la serie. */
}
?>

Si la última escritura lanza una excepción, se sabrá que hay un problema en la base de datos.

Escrituras reconocidas

Este tipo de operaciones de escritura se asegura de que la base de datos ha aceptado la operación de escritura antes de indicar que ha tenido éxito. Si la escritura falla, lanzará una MongoCursorException con una explicación del fallo. El comportamiento predeterminado dee MongoClient es reconocer la escritura (w=1).

Es posible especificar cuántos miembros de un conjunto de réplica tienen que reconocer la escritura (esto es, tiene que replicarla) antes de que la escritura se estime como reconocida y la operación devuelve.

Ejemplo #5 Escrituras reconocidas

<?php
// Forzar el reconocimiento por parte del primario solamente
$colección->insert($doc, array("w" => 1));

// Forzar el reconocimiento por parte del primario, y otro miembro del
// conjunto de réplica
$colección->insert($doc, array("w" => 2));

// Forzar el reconocimiento por parte del primario, y otros seis miembros del
// conjunto de réplica (probablemente nunca debería hacer esto):
$colección->insert($doc, array("w" => 7));
?>

Recuerde seleccionar el Asunto de Escritura con cuidado. Si se tiene un conjunto de réplica con 5 miembros y se selecciona un Asunto de Escritura de 4, se corre el riesgo de bloquear la escritura para siempre cuando un miembro del conjunto de réplica se desconecte por matenimiento o por un corte temporal de la red.

Advertencia

El paso de un valor de tipo string al Asunto de Escritura posee un significado específico (Reconocimiento por parte del conjunto de etiquetas del conjunto de réplica). Tenga cuidado de NO usar valores de tipo string para números (esto es, array("w" => "1")) ya que serán tratados como el nombre de un conjunto de etiquetas.

Escrituras reconocidas por la mayoría

Usar la opción de Asunto de Escritura majority es la forma recomendada para escrituras que requieren sobrevidir al apocalipsis, ya que se asegurá de que la mayoría del conjunto de réplica tendrá la escritura y, por lo tanto, se garantizará que sobrevivirá a todos los escenarios de corte sospechosos usuales.

Ejemplo #6 Escritura reconocida por la mayoría

<?php
$colección->insert($documento, array("w" => "majority"));
?>

Escrituras con diario

Al conectarse a un conjunto de réplica, el Asunto de Escritura predeterminado es hacer que solamente el servidor primario reconozca al escritura. Hay, sin embargo, una ventata de 100 ms hasta que la escritura se escriba en el diario y sea volcada al disco. Es posible forzar a que la escritura sea escrita en el diario antes de que sea reconocia estableicendo la opción j:

Ejemplo #7 Escritura reconocida y esctrita en el diario

Forzar el volcado del diatio

<?php
$opciones = array(
    "w" => 1,
    "j" => true,
);
try {
    $colección->insert($documento, $opciones);
} catch(MongoCursorException $e) {
    /* manejar la excpeción */
}
?>

Ver también

  • » MongoDB WriteConcern docs

Historial de cambios

Versión | Descripción
1.3.0 | Se introdujo MongoClient, cuyo comportamiento predeterminado es reconocer escrituras. La obsoleta Mongo no reconoce las escrituras de forma predeterminada.
1.3.0 | La opción de escritura "safe" ahora es obsoleta y no está disponible con la nueva clase MongoClient. Use la opción "w" en su lugar.


Tabla de correlación de SQL a Mongo

Esta es una versión específica de PHP de la tabla de correlación de » SQL a Mongo de la documentación principal.

Sentencia SQL | Sentencia en el Lenguaje de Consulta Mongo
CREATE TABLE USERS (a Number, b Number) | Implícito, o utilice MongoDB::createCollection().
INSERT INTO USERS VALUES(1,1) | $db->users->insert(array("a" => 1, "b" => 1));
SELECT a,b FROM users | $db->users->find(array(), array("a" => 1, "b" => 1));
SELECT * FROM users WHERE age=33 | $db->users->find(array("age" => 33));
SELECT a,b FROM users WHERE age=33 | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1));
SELECT a,b FROM users WHERE age=33 ORDER BY name | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1))->sort(array("name" => 1));
SELECT * FROM users WHERE age>33 | $db->users->find(array("age" => array('$gt' => 33)));
SELECT * FROM users WHERE age<33 | $db->users->find(array("age" => array('$lt' => 33)));
SELECT * FROM users WHERE name LIKE "%Joe%" | $db->users->find(array("name" => new MongoRegex("/Joe/")));
SELECT * FROM users WHERE name LIKE "Joe%" | $db->users->find(array("name" => new MongoRegex("/^Joe/")));
SELECT * FROM users WHERE age>33 AND age<=40 | $db->users->find(array("age" => array('$gt' => 33, '$lte' => 40)));
SELECT * FROM users ORDER BY name DESC | $db->users->find()->sort(array("name" => -1));
CREATE INDEX myindexname ON users(name) | $db->users->ensureIndex(array("name" => 1));
CREATE INDEX myindexname ON users(name,ts DESC) | $db->users->ensureIndex(array("name" => 1, "ts" => -1));
SELECT * FROM users WHERE a=1 and b='q' | $db->users->find(array("a" => 1, "b" => "q"));
SELECT * FROM users LIMIT 20, 10 | $db->users->find()->limit(10)->skip(20);
SELECT * FROM users WHERE a=1 or b=2 | $db->users->find(array('$or' => array(array("a" => 1), array("b" => 2))));
SELECT * FROM users LIMIT 1 | $db->users->find()->limit(1);
EXPLAIN SELECT * FROM users WHERE z=3 | $db->users->find(array("z" => 3))->explain()
SELECT DISTINCT last_name FROM users | $db->command(array("distinct" => "users", "key" => "last_name"));
SELECT COUNT(*y) FROM users | $db->users->count();
SELECT COUNT(*y) FROM users where AGE > 30 | $db->users->find(array("age" => array('$gt' => 30)))->count();
SELECT COUNT(AGE) from users | $db->users->find(array("age" => array('$exists' => true)))->count();
UPDATE users SET a=1 WHERE b='q' | $db->users->update(array("b" => "q"), array('$set' => array("a" => 1)));
UPDATE users SET a=a+2 WHERE b='q' | $db->users->update(array("b" => "q"), array('$inc' => array("a" => 2)));
DELETE FROM users WHERE z="abc" | $db->users->remove(array("z" => "abc"));


Conexión

Tabla de contenidos

  • Conectar sobre SSL
  • Autenticación
  • Conjuntos de réplicas
  • Fragmentación
  • Soporte de Socket de dominio
  • Conexiones persistentes (versión 1.3.0+)
  • Agrupación de conexiones (versión 1.2.0-1.2.12 *solamente*)
  • Connexiones persistentes manuales (versiones hasta 1.1.4 *solamente*

La conexión a MongoDB es tan fácil como usar new MongoClient, pero hay muchas más opciones y configuraciones adicionales. La documentación para Mongo::__construct() cubre todas las opciones de la API, pero está página ofrece más detalles y consejos para casos de uso prácticos.


Conectar sobre SSL

El controlador admite conexiones a » MongoDB sobre SSL y puede opcionalmente usar opciones Contexto de flujos de SSL para proporcionar más detalles, tales como verificar certificados con cadenas de certificado específicas, o autenticar a » MongoDB usando la certificación X509.

Ejemplo #1 Conectar a una instancia de MongoDB con encriptación SSL

<?php
$mc = new MongoClient("mongodb://server1", array("ssl" => true));
?>

Ejemplo #2 Conectar a una instancia de MongoDB con encriptación SSL, verificando que es quien se espera

<?php
$SSL_DIR = "/vagrant/certs";
$SSL_FILE = "CA_Root_Certificate.pem";

$ctx = stream_context_create(array(
    "ssl" => array(
        /* Certificate Authority the remote server certificate must be signed by */
        "cafile"            => $SSL_DIR . "/" . $SSL_FILE,

        /* Disable self signed certificates */
        "allow_self_signed" => false,

        /* Verify the peer certificate against our provided Certificate Authority root certificate */
        "verify_peer"       => true, /* Default to false pre PHP 5.6 */

        /* Verify the peer name (e.g. hostname validation) */
        /* Will use the hostname used to connec to the node */
        "verify_peer_name"  => true,

        /* Verify the server certificate has not expired */
        "verify_expiry"     => true, /* Only available in the MongoDB PHP Driver */
    ),
);

$mc = new MongoClient(
    "mongodb://server1",
    array("ssl" => true),
    array("context" => $ctx)
);
?>

Nota:

"verify_peer_name" es nuevo en PHP 5.6.0. Sin embargo, el controlador de MongoDB, a partir de la versión 1.6.5, ha hecho retrocompatible esta característica incluyéndola en el mismo controlador, por lo que funciona con PHP 5.3 y 5.4 también.

Ejemplo #3 Conectar a una instancia de MongoDB que requiera certificados cliente

<?php
$SSL_DIR  = "/vagrant/certs";
$SSL_FILE = "CA_Root_Certificate.pem";

$MYCERT   = "/vagrant/certs/ca-signed-client.pem";

$ctx = stream_context_create(array(
    "ssl" => array(
        "local_cert"        => $MYCERT,
        /* If the certificate we are providing was passphrase encoded, we need to set it here */
        "passphrase"        => "My Passphrase for the local_cert",

        /* Optionally verify the server is who he says he is */
        "cafile"            => $SSL_DIR . "/" . $SSL_FILE,
        "allow_self_signed" => false,
        "verify_peer"       => true,
        "verify_peer_name"  => true,
        "verify_expiry"     => true,
    ),
));

$mc = new MongoClient(
    "mongodb://server1/?ssl=true",
    array(),
    array("context" => $ctx)
);
?>

Ejemplo #4 Autenticación con certificados X.509

El nombre de usuario es el sujeto del certificado de X509, el cual puede extraerse así:

openssl x509 -in /vagrant/certs/ca-signed-client.pem -inform PEM -subject -nameopt RFC2253
<?php
$ctx = stream_context_create( array(
    "ssl" => array(
        "local_cert" => "/vagrant/certs/ca-signed-client.pem",
    )
) );

$mc = new MongoClient(
    'mongodb://username@server1/?authSource=$external&authMechanism=MONGODB-X509&ssl=true',
    array(),
    array("context" => $ctx)
);
?>

Donde username es el sujeto del certificado.

Historial de cambios

Versión | Descripción
1.5.0 | Se añadió soporte para autenticación X509.
1.4.0 | Se añadió soporte para conectar con MongoDB habilitado para SSL.


Autenticación

Si MongoDB se inicia con las opciones --auth o --keyFile, se debe autenticar antes de poder realizar cualquier operación con el controlador. Se podría autenticar una conexión especificando el nombre de usuario y la contraseña, o bien en el URI de conexión, o bien en las opciones "username" y "password" de MongoClient::__construct().

Ejemplo #1 Autenticación en la base de datos "admin"

<?php
// Especificar el nombre de usuario y la contraseña en el URI de conexión (preferido)
$m = new MongoClient("mongodb://${username}:${password}@localhost");

// Especificar el nombre de usuario y la contraseña mediante el array de opciones (alternativa)
$m = new MongoClient("mongodb://localhost", array("username" => $username, "password" => $password));
?>

Por omisión, el controlador autenticará en la base de datos admin. Se podría autenticar en una base de datos diferente especificándola en el URI de conexión o en la opción "db" de MongoClient::__construct().

Ejemplo #2 Autenticación en bases de datos normales

<?php
// Especificar la base de datos de autenticación en la URI de conexión (preferido)
$m = new MongoClient("mongodb://${username}:${password}@localhost/myDatabase");

// Especificar la base de datos de autenticación mediante el array de opciones (alternativa)
$m = new MongoClient("mongodb://${username}:${password}@localhost", array("db" => "myDatabase"));
?>

Si la conexión se your connection is dropped, the driver will automatically attempt to reconnect and reauthenticate you.


Conjuntos de réplicas

Para conectarse a un grupo réplica, se debe especificar uno o más miembros del grupo usando la opción replicaSet. Se pueden delimitar múltiples servidores mediante comas.

Ejemplo #1 Lista de semillas de ReplicaSet

<?php
// Usar múltiples servidores como lista de semillas (preferido)
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017/?replicaSet=myReplSetName");

// Usar un servidor como lista de semillas
$m = new MongoClient("mongodb://rs1.example.com:27017", array("replicaSet" => "myReplSetName"));

// Usar múltiples servidores como lista de semillas
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017", array("replicaSet" => "myReplSetName"));
?>

El driver de PHP hará una petición al servidor(es) de base de datos listados para determinar el primario. Mientras se pueda conectar almenos a uno de los servidores listados y pueda encontrar un primario, la conexión se establecerá con éxito. Si no se puede realizar una conexión a ninguno de los servidores listados o no puede encontrar un primario, será lanzada una MongoConnectionException.

Sugerencia

Se debería proporcionar siempre una lista de semillas con más de un miembro del ReplicaSet. Para una mayor disponibilidad se debería sembrar con al menos un servidor de cada centro de datos.

Advertencia

Los nombres de host que se especifiquen en la lista de semillas deben coincidir con los nombres de la configuración del conjunto de réplica. Esto es así debido a que el controlador solamente utiliza los nombres de host de la configuración del conjunto de réplica para crear el hash para sus conexiones persistentes.

Por ejemplo, si una dirección IP se emplea en la lista de semillas y el conjunto de réplica se configura con nombres de host, el controlador desechará cualquier conexión de lista de semillas que difiera de los nombres de host canónicos declarados por el conjunto de réplica. De hecho, estas conexiones de listas de semillas no canónicas serán recreadas en cada petición, reduciendo enormemente el beneficio de utilizar conexiones presistentes.

Advertencia

El controlador no admite la conexión a diferentes conjuntos de réplica con el mismo nombre. Esto se extiende más allá de un script, por lo que se ha de asegurar de tener diferentes nombres para cada conjunto de réplica. Esto también significa que no se puede hacer esto:

Ejemplo #2 Duplicación errónea de un nombre de un conjunto de réplica

<?php
$m = new MongoClient("mongodb://devserver1,devserver2,devserver3/?replicaSet=repset");
$m = new MongoClient("mongodb://prodserver1,prodserver2,prodserver3/?replicaSet=repset");
?>

En su lugar, se han de tener dos nombre diferentes para los conjuntos de réplica:

Ejemplo #3 Uso correcto de dos nombres de conjuntos de réplica

<?php
$m = new MongoClient("mongodb://devserver1,devserver2,devserver3/?replicaSet=devset");
$m = new MongoClient("mongodb://prodserver1,prodserver2,prodserver3/?replicaSet=prodset");
?>

Si el primario no está disponible, se hará una elección y se promoverá un secundario al rol de primario (a menos que no se pueda establecer un voto mayoritario). Durante este tiempo (» 20-60 segundos), la conexión no podrá ralizar ninguna operación de escritura, por lo que intentarlo resultará en una excepción. Las conexiones a secundarios aún podrán realizar lecturas.

Nota:

La Preferencias de lectura predeterminada solamente es para leer desde el primario. Durante el proceso de elección no hay primario, por lo que todas las lecturas fallarán.

Se recomienda usar la preferencia de lectura MongoClient::RP_PRIMARY_PREFERRED para aplicaciones que requieren una alta disponibilidad de lecturas, ya que las lecturas solamente serán ejecutadas en los secundarios cuando simplemente no haya un primario disponible.

Una vez que el primario es elegido, el intento de realizar una lectura o escritura permitirá al controlador detectar el nuevo primario. El controlador hará de esta su conexión de bases de datos primaria y continuará operando normalmente.

La salud y el estado de un secundario se comprueba cada 5 segundos (configurable con mongo.ping_interval) o cuando la siguiente operación ocurra después de 5 segundos. También recomprobará la configuración cuando el controlador tenga un problema al llegar al servidor.

La tolerancia a fallos del conjunto de réplicas se verifica cada 60 segundos (configurable con mongo.is_master_interval), y siempre que una operación de escritura falle cuando se utilicen escrituras aceptadas.

Precaución

Los secundarios podrían estar detrás del primario en las operaciones, por lo que la aplicación debe poder manejar datos desactualizados cuando se usan preferencias de lectura distintas de MongoClient::RP_PRIMARY.

Para obtener más información acerca de conjuntos de réplica, consulte la » documentación del núcleo.

Ver también

  • Preferencias de lectura
  • Asuntos de Escritura (Write Concerns)

Historial de cambios

Versión | Descripción
1.0.9 | Se añadió el soporte para conexiones a ReplicaSet y tolerancia a fallos automática.


Fragmentación

Para conectarse a un clúster fragmentado se ha de especificar la dirección de una o más instancias de mongos en la cadena de conexión. Se pueden delimitar múltiples servidores mediante comas.

<?php
// Usar un servidor como lista de semillas
$m = new MongoClient("mongodb://mongos1.example.com:27017");

// Usar múltiples servidores como lista de semillas
$m = new MongoClient("mongodb://mongos1.example.com:27017,mongos2.example.com:27017"));
?>

Independientemente de si cada fragmento es un servidor mongod independiente o un conjunto de réplicas complemto, el proceso de conexión del controlador es el mismo. Toda comunicación con la base de datos será enviada a través de mongos.

Para más información sobre la fragmentación con MongoDB, véase la » documentación de fragmentación.


Soporte de Socket de dominio

MongoDB posee un soporte interno para socket de dominio Unix y abrirá el socket al inicio, por omisión unicado en /tmp/mongodb-<port>.sock..

Para conectarse al fichero socket, especifique la ruta de la conexión MongoDB:

<?php
$m = new MongoClient("mongodb:///tmp/mongo-27017.sock");
?>

Si se quisiera autenticarse en una base de datos (como está descrito arriba) con un fichero de socket, se debe especificar un puerto de 0, y así el analizador de cadenas de conexiones podrá detectar el final de la ruta del socket. Alternativamente, se pueden usar las opciones del constructor.

<?php
$m = new MongoClient("mongodb://username:password@/tmp/mongo-27017.sock:0/foo");
?>

Historial de cambios

Versión | Descripción
1.0.9 | Se añadió el soporte para sockets de domicio Unix.


Conexiones persistentes (versión 1.3.0+)

Todas las versiones del controlador desde la 1.3.0 utilizan conexiones persistentes para minimizar el número de conexiones realizadas a cada servidor de bases de datos. Estas conexiones son guardadas por el proceso obrero de PHP, pudiéndo ser reutilizadas entre varias peticiones.

Antes de conectar a servidor de bases de datos, el controlador creará un hash para la conexión basándose en su host, puerto, nombre del conjunto de réplica (si lo hay), cualquier credencial de autenticación (p. ej., nombre de usuario, contraseña, base de datos), y el ID del proceso. Si una conexión ya existe para dicho hash será utilizada en lugar de crear una nueva conexión asociada este hash. Se puede usar MongoClient::getConnections() para obtener información sobre cada conexión persistente. Considérese el siguiente programa:

<?php

$m1 = new MongoClient('mongodb://localhost');
$m2 = new MongoClient('mongodb://localhost');
$m3 = new MongoClient('mongodb://user:pw@localhost');
$m4 = new MongoClient('mongodb://127.0.0.1');
$m5 = new MongoClient('mongodb://rs1.local:30017,rs2.local:30018/?replicaSet=rs');
$m6 = new MongoClient('mongodb://sharding.local:40017');

foreach (MongoClient::getConnections() as $conn) {
    echo $conn['hash'], "\n";
}

?>

El resultado del ejemplo sería algo similar a:

localhost:27017;-;X;15487
localhost:27017;-;admin/user/c56c…8bbc;15487
127.0.0.1:27017;-;X;15487
rs1.local:30017;rs;X;15487
rs2.local:30018;rs;X;15487
sharding.local:40017;-;X;15487

En este ejemplo $m1 y $m2 tienen el mismo hash y comparten una conexión persistente. Las conexiones para los demás instancias de MongoClient poseen valores únicos de hash y utilizan sus propios sockets. Observe que "localhost" y "127.0.0.1" no comparten el mismo hash; la resolución de DNS no se toma en cuenta.


Agrupación de conexiones (versión 1.2.0-1.2.12 *solamente*)

Nota:

Esta sección ya no tiene relevancia a partir de la versión 1.3.0 del controlador y únicamente sirve como información histórica de cómo solía funcionar la agrupación.

Las últimas versiones del controlador ya no posee el concepto de agrupación, por lo que solamente mantendrá una conexión por proceso, para cada tipo de conexión (ReplicaSet/standalone/mongos), para cada combinación de credenciales.

La creación de conexiones es uno de las cosas más pesada que el driver realiza. Puede tomar miles de milisegundos establecer una conexión correcta, incluso en una red rápida. Por lo tanto, el driver intentará reducir el número de nuevas conexiones creadas mediante la reutilización del pool de conexiones.

Cuando un usuario crea una nueva instancia de MongoClient, todas las conexiones necesarias serán tomadas por el pool (un conjunto de replicas de conexiones pueden requerir conexiones múltiples). Cuando la instancia de MongoClient se sale del ámbito, las conexiones se retornarán al pool. Cuando el proceso en PHP termine, todas las conexiones en el pools serán cerrados.

"¿Por qué tengo tantas conexiones abiertas?"

Las conexiones en el pool pueden generar un gran número de estas. Esto es normal y, con un poco de aritmética, es posible averiguar la cantidad de conexiones que se crearán. Hay tres factores que determinan el número total de conexiones:

  • connections_per_pool

    Cada pool creará, por omisión, un número ilimitado de conexiones. Uno puede suponer que este es un problema: si puede crear un número ilimitado de conexiones, no se podría crear miles y el servidor se quedaría sin descriptores de ficheros. En la práctica, es poco probable, ya que las conexiones no utilizadas son devueltas al pool para usarlos luego, Así las futuras conexiones van a utilizar la misma conexión en lugar de crear uno nuevo. A menos que cree miles de conexiones a la vez sin que ninguna este fuera del ámbito, el número de conexiones abiertas deben permanecer en un número razonable.

    Puede verse cuantas conexiones se tiene en el pool utilizando la función MongoPool::info(). Agregue los campos "in use" y "in pool" de un servidor determinado. Ese será el número total de conexiones de ese pool.

  • pools_per_process

    Cada dirección del servidor MongoDB al cual se va a conectar contiene su propio pool de conexiones. Por ejemplo, si el hostname local es "example.net", connectarse a "example.net:27017", "localhost:27017", y "/tmp/mongodb-27017.sock" creará tres grupos pools de conexiones. Puede ver como muchos grupos pools de conexiones tienes abiertas usando MongoPool::info().

  • processes

    Cada proceso PHP tiene un conjunto independiente de pools. PHP-FPM y Apache generalmente crean entre 6 y un par de docenas de PHP worker children. Compruebe su configuración y vea cuál es el máximo número de procesos de PHP que se pueden procesar.

    Si está usando PHP-FPM, la estimación del número de conexiones puede ser difícil porque este puede procesar más workers de PHP-FPM y así volver pesado la carga. Para estar en lado de la seguro, mire en parámetro max_children o sume spare_servers + start_servers (elegir el número más alto). Esto indicará cuántos procesos de PHP (es decir, conjuntos de agrpuaciones) se deberían planificar.

Las tres variables de arriba se pueen multiplicar juntas para obtener el número máximo de conexiones esperadas: connections_per_pool * pools_per_process * processes. Observe que connections_per_pool puede ser diferente para diferentes agrupaciones, por lo que connections_per_pool debería ser el máximo.

Por ejemplo, supongamos que se recibe 30 conexiones por pool, 10 pools por procesos en PHP, y 128 procesos PHP. Entonces podemos esperar 38400 conexiones desde esta máquina. Por lo tanto, debemos establecer el límite del descriptor del fichero para ser lo suficientemente alto para manejar todas las conexiones o pueda ejecutarse los ficheros de descriptores.

See MongoPool para obtener más información sobre la conexión pooling.


Connexiones persistentes manuales (versiones hasta 1.1.4 *solamente*

Nota:

Esta sección no es relevante para 1.2.0+. En 1.2.0+, siempre las conexiones que son persistentes son administradas automáticamente por el driver. Si se utiliza una versión 1.2.x (pero no 1.3.x o posterior), véase MongoPool para más información sobre agrupaciones.

Crear una nueva conexión cada vez a la base de datos es muy lento. Para minimizar el número de conexiones que se necesite, se pueden usar las conexiones persistentes. Una conexión persistente es guardada por PHP, para que pueda usarse la misma conexión en múltiples peticiones.

Por ejemplo, este simple programa para conectarse 1000 veces a la base de datos:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient();
}

?>

Esto tarda apróximadamente 18 segundos en ejecutarse. Pero si lo cambiamos para que utilice una conexión persistente:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient("localhost:27017", array("persist" => "x"));
}

?>

...tardará menos de 0.02 segundos en ejecutarse, ya que solo se realiza una sola conexión a la base de datos.

Las conexiones persistentes necesitan indicarse usando la variable de identificación (tal y como se muestra "x" en el ejemplo anterior). Para que la conexión persistente pueda usarse, el hostname, puerto, variable persist y las credenciales de autenticación (nombre de usuario, contraseña y base de datos) debe coincidir con una conexión persistente ya existente. De lo contrario, se creará una nueva conexión los datos proporcionados.

Las conexiones persistentes son altamente recomendables y se deberían usar siempre en producción a no ser que exista una razón con fundamento para hacer lo contrario. La mayoría de razones por las cuales no son recomendadas para bases de datos relacionales son totalmente irrelevantes para MongoDB.


Opciones de Contexto de flugo

La extensión de MongoDB para PHP proporciona Soporte para contextos de flujo usando el contexto de mongodb.

Un contexto de flujo se debe crear con stream_context_create() y pasarlo a MongoClient::__construct() antes de que se realice la conexión real a MongoDB. No es posible aplicar un contexto de flujo a flujos ya creados.

También hay soporte para parámetros y opciones de contexto adicionales, como ssl y notification parameters.

Las opciones de contexto de MongoDB proporcionan una inteerfaz rica para registrar tráfico de red entre el controlador y servidores de MongoDB. Esta interfaz se puede usar para proporcionar el registro de consultas, perfilamiento, depuradores, o cualquier cosa que fuera necesaria para inspeccionar las opciones de protocolos y comandos subyacentes.

Ver también

  • Opciones de contexto para SSL
  • Opciones de contexto de sockets
  • Contexto parámetros

Tabla de contenidos

  • log_cmd_delete — Función de retrollamada al borrar documentos
  • log_cmd_insert — Función de retrollamada al insertar documentos
  • log_cmd_update — Función de retrollamada al actualizar documentos
  • log_getmore — Función de retrollamada al obtener el próximo lote del cursor
  • log_killcursor — Función de retrollamada al ejecutar operaciones KILLCURSOR
  • log_reply — Función de retrollamada al leer una réplica de MongoDB
  • log_write_batch — Función de retrollamada al escribir lotes


Función de retrollamada al borrar documentos

  • « Opciones de Contexto de flugo
  • log_cmd_insert »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al borrar documentos

log_cmd_delete

(PECL mongo >= 1.5.0)

log_cmd_delete — Función de retrollamada al borrar documentos

Descripción

log_cmd_delete ( array $server , array $writeOptions , array $deleteOptions , array $protocolOptions )

Una función de tipo callable, usada por la opción de contexto log_cmd_delete, al borrar un documento.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

writeOptions

Clave | Valor
ordered | boolean, si la operación (en caso de que sea por lotes) debe ejecutarse secuencialmente (ordered=true)
writeConcern | Un array de opciones de writeConcern (véase más abajo)
Valores del array writeConcern
Clave | Valor
fsync | boolean, forzar el vuelco al disco antes de la devolución
j | boolean, forzar la escritura en el diario ante de la devolución
wtimeout | integer, milisegundos, tiempo máximo de espera del primario para verificar la réplica
w | integer=cuenta del servidor, o string=etiqueta de réplica

deleteOptions

Clave | Valor
limit | integer, 1 o 0. Si es 0, se borran todos los documentos coincidentes.
q | Array, el criterio de búsqueda

protocolOptions

Clave | Valor
message_length | El tamaño total (en bytes) del mensaje codificado a enviar por el cable
request_id | El identificador de petición para este mensaje: 42
namespace | El espacio de nombres de MongoDB usado para el protocolo del mensaje dbname.collectionname

Historial de cambios

Versión | Descripción
1.5.0 | Solamente disponible al conectarse a MongoDB 2.6.0+


Función de retrollamada al insertar documentos

  • « log_cmd_delete
  • log_cmd_update »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al insertar documentos

log_cmd_insert

(PECL mongo >= 1.5.0)

log_cmd_insert — Función de retrollamada al insertar documentos

Descripción

log_cmd_insert ( array $server , array $document , array $writeOptions , array $protocolOptions )

Una función de tipo callable, usada por la opción de contexto log_cmd_insert, al insertar un documento.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

document

El documento que ha sido preparado para su inserción.

writeOptions

Clave | Valor
ordered | boolean, si la operación (en caso de que sea por lotes) debe ejecutarse secuencialmente (ordered=true)
writeConcern | Un array de opciones de writeConcern (véase más abajo)
Valores del array writeConcern
Clave | Valor
fsync | boolean, forzar el vuelco al disco antes de la devolución
j | boolean, forzar la escritura en el diario ante de la devolución
wtimeout | integer, milisegundos, tiempo máximo de espera del primario para verificar la réplica
w | integer=cuenta del servidor, o string=etiqueta de réplica

protocolOptions

Clave | Valor
message_length | El tamaño total (en bytes) del mensaje codificado a enviar por el cable
request_id | El identificador de petición para este mensaje: 42
namespace | El espacio de nombres de MongoDB usado para el protocolo del mensaje dbname.collectionname

Historial de cambios

Versión | Descripción
1.5.0 | Solamente disponible al conectarse a MongoDB 2.6.0+


Función de retrollamada al actualizar documentos

  • « log_cmd_insert
  • log_getmore »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al actualizar documentos

log_cmd_update

(PECL mongo >= 1.5.0)

log_cmd_update — Función de retrollamada al actualizar documentos

Descripción

log_cmd_update ( array $server , array $writeOptions , array $updateOptions , array $protocolOptions )

Una función de tipo callable, usada por la opción de contexto log_cmd_update, al actualizar un documento.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

writeOptions

Clave | Valor
ordered | boolean, si la operación (en caso de que sea por lotes) debe ejecutarse secuencialmente (ordered=true)
writeConcern | Un array de opciones de writeConcern (véase más abajo)
Valores del array writeConcern
Clave | Valor
fsync | boolean, forzar el vuelco al disco antes de la devolución
j | boolean, forzar la escritura en el diario ante de la devolución
wtimeout | integer, milisegundos, tiempo máximo de espera del primario para verificar la réplica
w | integer=cuenta del servidor, o string=etiqueta de réplica

updateOptions

Clave | Valor
multi | Booleano, true si a esta actualización se le permite actualizar todos los criterios coincidentes
upsert | Booleano, true si el documento debería ser creado si los criterios no coinciden
q | Array, los criterios de búsqueda
u | Array, el nuevo/s objeto/modificaciones

protocolOptions

Clave | Valor
message_length | El tamaño total (en bytes) del mensaje codificado a enviar por el cable
request_id | El identificador de petición para este mensaje: 42
namespace | El espacio de nombres de MongoDB usado para el protocolo del mensaje dbname.collectionname

Historial de cambios

Versión | Descripción
1.5.0 | Solamente disponible al conectarse a MongoDB 2.6.0+


Función de retrollamada al obtener el próximo lote del cursor

  • « log_cmd_update
  • log_killcursor »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al obtener el próximo lote del cursor

log_getmore

(PECL mongo >= 1.5.0)

log_getmore — Función de retrollamada al obtener el próximo lote del cursor

Descripción

log_getmore ( array $server , array $info )

Una función de tipo callable, usada por la opción de contexto log_getmore, al ejecutar una operación GET_MORE.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

info

Clave | Valor
request_id | integer, el identificador de petición del controlador
cursor_id | integer, el identificador del cursor a usar para obtener más datos
batch_size | integer, número máximo de documentos a solicitar


Función de retrollamada al ejecutar operaciones KILLCURSOR

  • « log_getmore
  • log_reply »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al ejecutar operaciones KILLCURSOR

log_killcursor

(PECL mongo >= 1.5.0)

log_killcursor — Función de retrollamada al ejecutar operaciones KILLCURSOR

Descripción

log_killcursor ( array $server , array $info )

Una función de tipo callable, usada por la opción de contexto log_killcursor, al leer 'killcursor' de MongoDB.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

info

Clave | Valor
cursor_id | integer, el identificador del cursor a eliminar


Función de retrollamada al leer una réplica de MongoDB

  • « log_killcursor
  • log_write_batch »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al leer una réplica de MongoDB

log_reply

(PECL mongo >= 1.5.0)

log_reply — Función de retrollamada al leer una réplica de MongoDB

Descripción

log_reply ( array $server , array $messageHeaders , array $operationHeaders )

Una función de tipo callable, usada por la opción de contexto log_reply, al leer una réplica de MongoDB.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

messageHeaders

Clave | Valor
length | integer, bytes, longitud del mensaje de réplica
request_id | integer, el identificador de petición del servidor
response_id | integer, el identificador de petición del servidor del cual este mensaje es una respuesta
opcode | integer, el identificador del código de operación

operationHeaders

Clave | Valor
flags | integer, máscara de bit de indicadores de protocolo
cursor_id | integer, ID del cursor creado en el servidor (0 si no se creó ninguno a ha expirado)
start | El índice de inicio de este cursor
returned | integer, cúantos documentos se devuelven

Ver también

  • La » Definición de OP_REPLY en el Protocolo Wire


Función de retrollamada al escribir lotes

  • « log_reply
  • Escrituras »
  • PHP Manual
  • Opciones de Contexto de flugo
  • Función de retrollamada al escribir lotes

log_write_batch

(PECL mongo >= 1.5.0)

log_write_batch — Función de retrollamada al escribir lotes

Descripción

log_write_batch ( array $server , array $writeOptions , array $batch , array $protocolOptions )

Una función de tipo callable, usada por la opción de contexto log_write_batch, al ejecutar una operación por lotes.

Nota:

Esta no es una función real, es solamente un prototipo de cómo debería ser la función.

Parámetros

server

Un array que contiene la información básica sobre el servidor elegido.

Clave | Valor
Hash | Hash del servidor, ejemplo: localhost:27017;-;X;56052
type | Tipo de nodo (primario/secundario/mongos/árbitro): 2
max_bson_size | El tamaño máximo de BSON que acepta este nodo por el cable: 16777216
max_message_size | El tamaño máximo de mensaje que acepta este nodo por el cable: 48000000
request_id | El identificador de petición para este mensaje: 42

writeOptions

Clave | Valor
ordered | boolean, si la operación (en caso de que sea por lotes) debe ejecutarse secuencialmente (ordered=true)
writeConcern | Un array de opciones de writeConcern (véase más abajo)
Valores del array writeConcern
Clave | Valor
fsync | boolean, forzar el vuelco al disco antes de la devolución
j | boolean, forzar la escritura en el diario ante de la devolución
wtimeout | integer, milisegundos, tiempo máximo de espera del primario para verificar la réplica
w | integer=cuenta del servidor, o string=etiqueta de réplica

batch

Array, la operación por lotes real.

protocolOptions

Clave | Valor
message_length | El tamaño total (en bytes) del mensaje codificado a enviar por el cable
request_id | El identificador de petición para este mensaje: 42
namespace | El espacio de nombres de MongoDB usado para el protocolo del mensaje dbname.collectionname

Historial de cambios

Versión | Descripción
1.5.0 | Solamente disponible al conectarse a MongoDB 2.6.0+


Escrituras

Actualización de objetos anidados

Supongamos que queremos cambiar el nombre del autor de un comentario en este documento:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
Para cambiar un campo interno usamos $set (de manera que el resto de campos no se eliminen) con el índice del comentario a cambiar:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

El operador posicional

El operador posicional $ es útil a la hora de actualizar objetos de arrays. En el ejemplo anterior, por ejemplo, podríamos no conocer el índice del comentario que necesitamos modificar; sólo sabemos que queremos cambiar "John" a "Jim". Podemos usar $ para lograrlo.

<?php

$blog->update(
    array("comments.author" => "John"),
    array('$set' => array('comments.$.author' => "Jim")));

?>


Consultas

Distribuyendo consultas a esclavos

Todas las consultas (lecturas y escrituras) solamente se envian al miembro primario de un conjunto de réplicas de manera predeterminada. Sin embargo, esto es fácilmente configurable usando las Preferencias de lectura, que permiten establecer algunas preferencias de lectura genéricas (tales como permitir que un secundario lea del servidor más cercano), y también proporcionar formas de dirigir específicamente un servidor en un país concreto, o incluso hardware, usando los conjuntos de etiquetas de conjuntos de réplicas.

Las preferencias de lectura se pueden configurar en cualquier nivel del controlador:

  • Como parámetro de consulta u opción a MongoClient::__construct()
  • Específicamente invocando a MongoClient::setReadPreference()
  • A nivel de la base de datos con MongoDB::setReadPreference()
  • A nivel de la colección con MongoCollection::setReadPreference()
  • A nivel de cursor con MongoCursor::setReadPreference() o MongoCommandCursor::setReadPreference()
Cada clase hereda su configuración de preferencias de lectura del contexto "padre".

Ejemplo #1 Herencia de las preferencias de lectura del nivel de la base de datos hacia el cursor

<?php
$db->setReadPreference(MongoClient::RP_SECONDARY_PREFERRED);
$c = $db->myCollection;

$cursor = $c->find();
?>

En este ejemplo, la consulta se ejecutará en un secundario. La colección hereda MongoClient::RP_SECONDARY_PREFERRED de la base de datos y el cursor lo hereda de la colección.

Cómo se escogen los esclavos

Cada instancia de MongoClient escoge su propio secundario utilizando el secundario disponible con el menor tiempo de respuesta. Es decir, si tuviéramos un cliente PHP en Europa y otro en Australia y tuviéramos un secundario en cada uno de estos centros de datos, podríamos hacer:

<?php
$options = array("replicaSet" => "setName", "readPreference" => MongoClient::RP_SECONDARY_PREFERRED);

// en el cliente de Australia
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Leyendo desde: ", $cursor->info()["server"], "\n";

// en el cliente de Europa
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Leyendo desde: ", $cursor->info()["server"], "\n";
?>

El resultado del ejemplo sería algo similar a:

Reading from: australianHost
Reading from: europeanHost

Tenga en cuenta que se debe realizar una consulta antes de elegir un secundario: los secundarios los elige el controlador de forma retardada, y para cada consulta por separado.

Se puede ver los que el controlador piensa que es el estado actual de los miembros del conjunto ejecutando MongoClient::getHosts() o MongoClient::getConnections().

Si un secundario no es legible, el controlador enviará las lecturas al primario que se especificó con MongoClient::RP_SECONDARY_PREFERRED, que recurrirá a ejecutar una consulta en un primario si no estuviera disponible un secundario. Un servidor es considerado legible si su estado es 2 (SECONDARY) y su salud es 1. Se puede verificar esto con MongoClient::getHosts() y MongoClient::getConnections().

Notas aleatorias

Las escrituras siempre se envian al primario y, de forma predeterminada, todas las lecturas son enviada también al primario.

Consultando por _id

A cada objeto que se inserta se le asigna automáticamente un campo _id único, el cual, a menudo, es un campo útil para usarlo en consultas. Esto funciona de forma similar a la funcionalidad "obtener el último ID insertado", excepto que el _id es escogido por el cliente.

Supongamos que queremos localizar el documento que acabamos de insertar. Las inserciones añaden un campo _id al documento, de modo que podemos realizar una consulta a partir de él:

<?php
$person = array("name" => "joe");

$people->insert($person);

// ahora $joe tiene un campo _id
$joe = $people->findOne(array("_id" => $person['_id']));
?>

Salvo que se indique lo contrario, el campo _id será de tipo MongoId. El error más frecuente consiste en usar una cadena de texto que concuerde con un MongoId. Debe tenerse presente que son dos tipos de datos distintos, y no concuerdan, del mismo modo que el texto "array()" no es lo mismo que un array vacío. Por ejemplo:

<?php
$person = array("name" => "joe");

$people->insert($person);

// convertimos el _id a texto
$pid = $person['_id'] . "";

// FALLO - $pid es un texto, no un MongoId
$joe = $people->findOne(array("_id" => $pid));
?>

Arrays

Los arrays son especiales por varias razones. En primer lugar, hay dos tipos de arrays que MongoDB utiliza: arrays "normales" y arrays asociativos. Los arrays asociativos pueden tener cualquier combinación de claves y valores. Los arrays "normales" se definen como arrays con un índice numérico ascendente que comienza por 0 y se incrementa en uno por cada elemento. Estos son, normalmente, los arrays de PHP más comunes.

Por ejemplo, si se quisiera guardar una lista de premios en un documento, podríamos poner:

<?php

$collection->save(array("awards" => array("gold", "silver", "bronze")));

?>

Las consultas pueden llegar hasta los arrays en busca de elementos. Supongamos que queremos encontrar todos los documentos que contienen un elemento de un array con un determinado valor. Por ejemplo, documentos con un premio "gold", como por ejemplo:

{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "awards" : ["gold", "silver", "bronze"]}

Esto puede lograrse con una única consulta, ignorando el hecho de que "awards" es un array:

<?php

  $cursor = $collection->find(array("awards" => "gold"));

?>

Supongamos que estamos consultando un objeto más complejo, si cada elemento del array fuera un objeto en sí mismo, como en:

{
     "_id" : ObjectId("4b06c282edb87a281e09dad9"),
     "awards" :
     [
        {
            "first place" : "gold"
        },
        {
            "second place" : "silver"
        },
        {
            "third place" :  "bronze"
        }
     ]
}

Incluso aquí, ignorando que se trata de un array, podemos usar la misma notación para consultar al subobjeto:

<?php

$cursor = $collection->find(array("awards.first place" => "gold"));

?>

Debe tenerse en cuenta que no importa que haya espacios en los nombres de campos (pese a que sea mejor no usarlos, sólo por mantenerlo más legible).

Puede también usarse un array para consultar un determinado número de posibles valores. Por ejemplo, si buscáramos documentos "gold" o "copper", podríamos hacer:

<?php

$cursor = $collection->find(array("awards" => array('$in' => array("gold", "copper"))));

?>

Historial de cambios

Versión | Descripción
1.3.0 | Se introdujo el framwork Preferencias de Lectura para poder tener más control sobre las lecturas de secundarios.
1.3.0 | Uso obsoleto de slaveOkay, la alternativa es Preferencias de Lectura.
1.1.0 | Se introdujo la posibilidad de enviar lecturas a secundarios de miembros de conjuntos de réplicas usando Mongo::setSlaveOkay()


Actualizaciones

Las actualizaciones quizás sean las operaciones más complicadas de las disponibles en MongoDB. Combinan una consulta junto con una acción, modificando los documentos que concuerdan con los criterios de selección. Son también muy potentes, permitiendo cambiar rápidamente los documentos y reemplazarlos. Se realiza al momento (siempre y cuando sea posible), minimizando el consumo de recursos.

Modificación o reemplazo de documentos

Existen dos tipos de actualizaciones: actualizaciones de modificación y actualizaciones de reemplazado. Las actualizaciones de modificación contienen operandos $ y cambian los campos de un documento: pueden incrementar contadores, agregar elementos a un array, o modificar el tipo de dato de un campo.

Por ejemplo, una actualización de modificación puede añadir un nuevo campo a un documento.

<?php
/** supongamos un documento así:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array('$set' => array("twitter" => "@joe4153")));

/** ahora el documento sería así:
 * {"username" : "joe", "password" : "...", "email" : "...", "twitter" : "@joe4153"}
 */
?>

Las actualizaciones de reemplazado modifican todo el documento seleccionado por otro nuevo. Generalmente no es tan eficientes como usar operandos $, pero pueden ser muy útiles en operaciones complejas o en actualizaciones que no se pueden expresar en términos de operandos $.

Por ejemplo, una actualización de reemplazado puede cambiar por completo la estructura de un documento.

<?php
/** supongamos un documento así:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array("userId" => 12345, "info" => array(
    "name" => "joe", "twitter" => "@joe4153", "email" => "..."), "likes" => array()));

/** ahora el documento quedaría así:
 * {
 *     "userId" : 12345,
 *     "info" : {
 *         "name" : "joe",
 *         "twitter" : "@joe4153",
 *         "email" : "..."
 *     },
 *     "likes" : []
 * }
 */
?>

Actualizando Objetos Anidados

Supongamos que queremos cambiar el nombre del autor de un comentario en este documento:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
Para cambiar el campo interno, usamos $set (de manera que no se eliminen el resto de campos) con el índice del comentario a cambiar:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

El Operador Posicional

El operador posicional $ es útil a la hora de actualizar objetos en arrays. En el ejemplo anterior, por ejemplo, podríamos no conocer el índice del comentario que necesitamos modificar, sólo sabemos que queremos cambiar "John" a "Jim". Podemos usar $ para lograrlo.

<?php

$blog->update(
    array("comments.author" => "John"),
    array('$set' => array('comments.$.author' => "Jim")));

?>


Seguridad

Ataques de Inyección de Petición

Al pasar parámetros $_GET (o $_POST) a una consulta, se ha de asegurar de que están convertidos a string. Un usuario puede insertar un array asociativo en peticiones GET y POST, lo que provocaría consultas $ no deseadas.

Un ejemplo aparentemente inofensivo: supongamos que estamos buscando información de un usuario con la petición http://www.example.com?username=bob. La aplicación realiza la consulta $collection->find(array("username" => $_GET['username'])).

Alguien podría alterarlo realizando una consulta a http://www.example.com?username[$ne]=foo, con lo que PHP lo convertirá automáticamente a un array asociativo, creando la consulta $collection->find(array("username" => array('$ne' => "foo"))), que devolverá todos los usuarios con nombre distinto de "foo" (probablemente, todos).

Es sencillo defenderse de un ataque como éste: hay que asegurarse de que los parámetros $_GET y $_POST son del tipo demandado antes de enviarlos a la base de datos (en este caso, se han de convertir a string).

Tenga en cuenta que este tipo de ataque se puede usar con cualquier interacción con una base de datos que localice documentos, incluyendo actualizaciones, busquedas con modificación, y eliminaciones.

Gracias a » Phil por apuntar esto.

Para más información sobre ataques tipo inyección SQL con MongoDB revise » la documentación principal.

Ataques de Inyección de Código

Si se está usando JavaScript, debemos asegurarnos que cualquier variable que cruce los límites PHP-JavaScript se pasa en el campo scope de MongoCode, y no interpolado en el código JavaScript. Esto sucede al llamar a MongoDB::execute(), consultas $where, MapReduces, agrupaciones, y cualquier otra situación en que se proporcione código JavaScript a la base de datos.

Nota:

MapReduce ignora el campo scope de MongoCode, pero hay una opción scope disponible en el comando que puede utilizarse en su lugar.

Por ejemplo, supongamos que tenemos un código JavaScript para saludar a los usuarios en los registros de la base de datos. Podríamos:

<?php

// ¡no haga esto!

$username = $_POST['username'];
$db->execute("print('Hola, $username!');");

?>

Pero, ¿qué ocurriría si un usuario malicioso metiera código JavaScript?

<?php

// ¡no haga esto!

// $username tiene como valor "'); db.users.drop(); print('"
$db->execute("print('Hola, $username!');");

?>

Ahora MongoDB ejecuta el código JavaScript "print('Hola, '); db.users.drop(); print('!');". Este ataque es fácil de evitar: utilice scope al pasar variables de PHP a Javascript:

<?php

$scope = array("user" => $username);
$db->execute(new MongoCode("print('Hello, '+user+'!');", $scope));

?>

Esto añade la variable user al ámbito de JavaScript. Si ahora alguien quisiera añadir código malicioso, MongoDB imprimiría, sin causar daños, Hello, '); db.dropDatabase(); print('!.

El uso de scope ayuda a prevenir que se ejecutene en la base de datos entradas maliciosas. Sin embargo, debe asegurarse de que su código no cambie y ejecute los datos de entrada. Por ejemplo, nunca utilice la función eval de JavaScript con los datos de entrada de un usuario:

<?php

// ¡no haga esto!

// $jsShellInput es "db.users.drop();"
$scope = array("input" => $jsShellInput);
$db->execute(new MongoCode("eval(input);", $scope));

?>

Use siempre scope y nunca permita que la base de datos ejecute como código los datos de entrada del usuario.


Solución a problemas

En caso de que tuviera problemas, existe un gran número de recursos que consultar.

  • IRC

    El canal IRC oficial de MongoDB es irc.freenode.net/#mongodb. Éste es el método mas rápido para conseguir ayuda.

  • Listas de correo

    La » lista de correo de MongoDB es un buen (y por lo general rápido) método para encontrar respuestas.

  • Seguimiento de fallos

    ¿Ha encontrado un fallo? ¿Echa algo en falta? ¿Tiene alguna pregunta? Archívela en el » bug track del driver de PHP.

Se puede hacer que el controlador registre todos los tipo de mensajes de error como mensajes de error de PHP de nivel E_NOTICE. Héchele un vistazo a la clase MongoLog para un ejemplo.


Ejecutar los test del controlador

El paquete PECL no incluyen los test, pero están disponible en » Github.

Los test .phpt

Los test .phpt son la forma estándar de probar extensiones de PHP. Después de compilar el controlador MongoDB con "make", se puede hacer "make test" para ejecutar los test. Estos test requieren que MongoDB se esté ejecutando, y por lo tanto, es necesario configurar el conjunto de test en sí.

Hay más información sobre la ejecución de test en las directivas de contribución en » GitHub.

Notificar errores

Por favor, notifique cualquier fallo o error en el » bugtracker. Podría haber test que se omitan. Esto es normal, por lo que puede ignorarlo.

¡Los nuevos test siempre son bienvenidos! Por favor, no dude en contribuir con nuevos test de cualquier tipo que pongan a prueba cualquier funcionalidad.


Clases del núcleo

Tabla de contenidos

  • MongoClient
  • MongoDB
  • MongoCollection
  • MongoCursor
  • MongoCursorInterface
  • MongoCommandCursor
Advertencia

Esta extensión está obsoleta. Debe usarse en su lugar la extensión MongoDB.

Las clases del núcleo son la parte más importante del controlador.


La clase MongoClient

(PECL mongo >=1.3.0)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\Driver\Manager

Introducción

Un administrador de conexiones para PHP y MongoDB.

Esta clase sirve para crear un administrar conexiones. Un uso típico es:

Ejemplo #1 Uso básido de MongoClient

<?php

$m = new MongoClient(); // conectar
$bd = $m->foo; // obtener la base de datos "foo"

?>

Véase MongoClient::__construct() y la sección sobre conexiones para más información para crear conexiones.

Sinopsis de la Clase

MongoClient {
/* Constantes */
const string VERSION ;
const string DEFAULT_HOST = "localhost" ;
const int DEFAULT_PORT = 27017 ;
const string RP_PRIMARY = "primary" ;
const string RP_PRIMARY_PREFERRED = "primaryPreferred" ;
const string RP_SECONDARY = "secondary" ;
const string RP_SECONDARY_PREFERRED = "secondaryPreferred" ;
const string RP_NEAREST = "nearest" ;
/* Propiedades */
public boolean $connected = false ;
public string $status = null ;
protected string $server = null ;
protected boolean $persistent = null ;
/* Métodos */
public __construct ( string $server = "mongodb://localhost:27017" , array $options = array("connect" => true) , array $driver_options = ? )
public close ( boolean|string $connection = ? ) : bool
public connect ( ) : bool
public dropDB ( mixed $db ) : array
public __get ( string $dbname ) : MongoDB
public static getConnections ( ) : array
public getHosts ( ) : array
public getReadPreference ( ) : array
public getWriteConcern ( ) : array
public killCursor ( string $server_hash , int|MongoInt64 $id ) : bool
public listDBs ( ) : array
public selectCollection ( string $db , string $collection ) : MongoCollection
public selectDB ( string $name ) : MongoDB
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public __toString ( ) : string
}

Constantes predefinidas

Constantes de MongoClient

MongoClient::VERSION
Versión del controlador de PHP. Podría estar sufijado con "dev", "+" o "-" si está entre versiones.
MongoClient::DEFAULT_HOST
"localhost"
Host al que conectar si no se proporciona uno.
MongoClient::DEFAULT_PORT
27017
Puerto al que conectar si no se proporciona uno.
MongoClient::RP_PRIMARY
"primary"
Preferencia de lectura para el miembro primario del conjunto de réplica.
MongoClient::RP_PRIMARY_PREFERRED
"primaryPreferred"
Preferencia de lectura para elegir el miembro primario del conjunto de réplica.
MongoClient::RP_SECONDARY
"secondary"
Preferencia de lectura para un miembro secundario del conjunto de réplica.
MongoClient::RP_SECONDARY_PREFERRED
"secondaryPreferred"
Preferencia de lectura para elegir un miembro secundario del conjunto de réplica.
MongoClient::RP_NEAREST
"nearest"
Preferencia de lectura para el miembro más cercano del conjunto de réplica.

Campos

connected

Esta propiedad será establecida a true si se tienen una conexión abierta a la base de datos, o false de lo contrario. Si la conexión es a un conjunto de réplica, esta propiedad solamente será true si el controlador tiene una conexión a un nodo que coincida con la preferencia de lectura actual. Esta propiedad no toma en cuenta la autenticación.

Esta propiedad está obsoleta desde la versión 1.5.0.

status

Esta propiedad ya no se usa y será establecida a null. En las versiones 1.1.x y anteriores del controlador, podría establecerse a un valor string (p.ej. "recycled", "new") cuando se usen conexiones persistentes.

Esta propiedad está obsoleta desde la versión 1.5.0.

Ver también

  • Preferencias de lectura
  • Asuntos de Escritura (Write Concerns)
  • Conexión
  • Documentación del núcleo de MongoDB sobre » conexiones

Tabla de contenidos

  • MongoClient::close — Cierra esta conexión
  • MongoClient::connect — Conecta a un servidor de bases de datos
  • MongoClient::__construct — Crea un nuevo objeto de conexión a base de datos
  • MongoClient::dropDB — Elimina una base de datos [obsoleto]
  • MongoClient::__get — Obtiene una base de datos
  • MongoClient::getConnections — Devuelve información sobre todas las conexiones abiertas
  • MongoClient::getHosts — Actualiza el estado de todos los hosts asociados
  • MongoClient::getReadPreference — Obtener la preferencia de lectura para esta conexión
  • MongoClient::getWriteConcern — Obteenr el asunto de escritura para esta conexión
  • MongoClient::killCursor — Elimina un cursor específico del servidor
  • MongoClient::listDBs — Enumera todas las bases de datos disponibles
  • MongoClient::selectCollection — Obtiene una colección de bases de datos
  • MongoClient::selectDB — Obtiene una base de datos
  • MongoClient::setReadPreference — Establece la preferencia de lectura para esta conexión
  • MongoClient::setWriteConcern — Establecer el asunto de escritura para esta conexión
  • MongoClient::__toString — Representación de cadena de esta conexión


Cierra esta conexión

  • « MongoClient
  • MongoClient::connect »
  • PHP Manual
  • MongoClient
  • Cierra esta conexión

MongoClient::close

(PECL mongo >=1.3.0)

MongoClient::close — Cierra esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::close ( boolean|string $connection = ? ) : bool

El método MongoClient::close() cierra forzosamente una conexión a la base de datos, incluso si se están usando conexiones persistentes. Nunca se debería realizar esto bajo circunstancias normales.

Parámetros

connection

La conexión. Si no se proporciona una, o es false, la conexión que fuera seleccionada para escrituras será cerrada. En una configuración de un solo nodo, esto es, la conexión completa, y si se está conectado a un conjunto de réplica, close() solamente cerrará la conexión al servidor primario.

Si connection es true, todas las conexiones disponibles en el administrador de conexiones serán cerradas. Esto puede incluir conexiones a las que no hace referencia la cadena de conexión usada para crear el objeto que se usa para invocar el cierre.

Si connection es un argumento de tipop string, solamente se cerrará la conexión identificada por este hash. Los hash son identificadores para una conexión que pueden obtenerse llamando a MongoClient::getConnections().

Valores devueltos

Devuelve si la conexión fue cerrada con éxito.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::close()

Este ejemplo muestra cómo cerrar selectivamente todas las conexiones únicamente a secundarios.

<?php
// Conectar a un conjunto de réplica
$a = new MongoClient("mongodb://whisky:13000/?replicaset=seta");

$conexiones = $a->getConnections();

foreach ( $conexiones as $con )
{
    // Iterar sobre todas las conexiones, y cuando el tipo es "SECONDARY"
    // cerramos la conexión
    if ( $con['connection']['connection_type_desc'] == "SECONDARY" )
    {
        echo "Cerrando '{$con['hash']}': ";
        $cerrada = $a->close( $con['hash'] );
        echo $cerrada ? "ok" : "falló", "\n";
    }
}
?>

El resultado del ejemplo sería:

Closing 'whisky:13001;X;4948': ok

Historial de cambios

Versión | Descripción
1.3.0 | El parámetro connection de esta función fue añadido en la versión 1.3.0. Anteriormente, solamente se podía cerra la conexión de escritura mediante este método.
1.2.0 | Antes de la versión 1.2.0, el controlador no utilizaba conexiones persistentes de forma predeterminada, por lo que todas las conexiones se cerraban tan pronto como una conexión de MongoDB estuviera fuera de ámbito. Desde la versión 1.2.0, este ya no es el caso, y es una mala idea invocar a close, ya que se podría terminar por sobrecargar el servidor con conexiones bajo una alta carga.

Ver también

  • MongoClient::getConnections() - Devuelve información sobre todas las conexiones abiertas


Conecta a un servidor de bases de datos

  • « MongoClient::close
  • MongoClient::__construct »
  • PHP Manual
  • MongoClient
  • Conecta a un servidor de bases de datos

MongoClient::connect

(PECL mongo >=1.3.0)

MongoClient::connect — Conecta a un servidor de bases de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::connect ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Si la conexión se realizó con éxito.

Errores/Excepciones

Lanza una MongoConnectionException si falla al conectarse a la base de datos.


Crea un nuevo objeto de conexión a base de datos

  • « MongoClient::connect
  • MongoClient::dropDB »
  • PHP Manual
  • MongoClient
  • Crea un nuevo objeto de conexión a base de datos

MongoClient::__construct

(PECL mongo >=1.3.0)

MongoClient::__construct — Crea un nuevo objeto de conexión a base de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\Driver\Manager::__construct()

Descripción

public MongoClient::__construct
 ( string $server = "mongodb://localhost:27017"
, array $options = array("connect" => true)
, array $driver_options = ?
)

Si no se proporció ninúng parámetro, se conectará a "localhost:27017" (o lo que fuera especificado en php.ini para mongo.default_host y mongo.default_port).

server debería tener la forma:

mongodb://[nombre_usuario:contraseña@]host1[:puerto1][,host2[:puerto2:],...]/bd

El string de conexión siempre comienza con mongodb://, para indicar que es un string de conexión con esta forma.

Si se especifican nombre_usuario y contraseña, el constructor intenrará autenticar la conexión con la base de datos antes de devolver. El nombre de usuario y la contraseña son opcionales y deben estar seguidos por un @, si se especifican.

Se debe proporcionar al menos un host (el puerto es opcional, cuyo valor predeterminado siempre es 27017) yand as many hosts as desired may be connected to. Los nombres de host están separados por comas, y el constructor devolverá con éxito si se conectó a, al menos, un host. Si no se pudo conectar a ninguno, lanzará una excepción de tipo MongoConnectionException. Véase la sección Conjuntos de réplica para información sobre cómo conectarse a Conjuntos de réplica.

Si se especifica un nombre de usuario y una contraseña, se podría especificar una base de datos a la que autenticarse. Si bd no se especifica, se usará "admin".

Se puede usar un string de conexión opcional para especificar opciones extra. Las mismas opciones también son admitidas a través del array options, y, por lo tanto, están descritas allí. Véanse los ejemplo de abajo sobre como establecer estas opciones.

Una parte de las opciones gobierna la forma en la que el controlador lee desde nodos secundarios en un entorno de conjunto de réplica. Hay disponible también información extra de cómo funcionan las preferencias de lectura en la página de la documentación de preferencias de lectura.

Parámetros

server

El nombre del servidor.

options

Un array con opciones para la conexión. Las opciones disponibles actualmente son:

  • "authMechanism"

    Los mecanismos de autenticación son:

    authMechanism | Descripción | Disponibilidad
    MONGODB-CR | Autenticar usando el mecanismo de Respuesta de Reto. Este es el valor predeterminado. | Todas las versiones de MongoDB
    X509 | Autenticar usando certificados X509 | MongoDB 2.6. Solamente disponible si OpenSSL está habilitado
    PLAIN | Autenticar usando nombre_usuario+contraseña plano no encriptado. Debe usarse sobre conexiones SSL. Generalmente usado por MongoDB para identificarse mediante un servidor LDAP de terceros | MongoDB Enterprise 2.4. El controlador debe compilarse con CyrusSASL2
    GSSAPI | Autenticar mediante sistemas kerberos | MongoDB Enterprise 2.4. El controlador debe compilarse con CyrusSASL2

  • "authSource"

    Debería estar establecido al nombre de la base de datos cuando lo defina.

  • "connect"

    Si el constructor debería conectar antes de devolver. El valor predeterminado es true. Si se establece a false, el controlador se conectará automáticamente al servidor cuando sea necesario realizar una consulta. Alternativamente, se puede ejecutar MongoClient::connect() de forma manual.

    Advertencia

    Esta opción no está admitida a través del string de conexión.

  • "connectTimeoutMS"

    Cuánto puede tomar una conexión para ser abierta antes de expirar en milisegundos. El valor predeterminado es 60000 (60 segundos).

    Si se especifica -1, no se aplicará un tiempo límite a la conexión y PHP usará default_socket_timeout.

  • "db"

    La base de datos en la que autenticarse se puede especificar aquí, en lugar de incluirla en la lista de hosts. Esto anula una base de datos proporcionada en la lista de hosts.

  • "fsync"

    Cuando "fsync" está establecido, todas las operaciones de escritura bloquearán hasta que la base de datos haya volcado los cambios al disco. Esto hace que las operaciones de escritura sean más lentas, pero garantiza su éxito y que puedan ser recuperadas en caso de un fallo total del sistema.

    Si el servidor de MongoDB tiene el registro en el diario habilitado, esta opción es idéntica a "journal". Si el registro no está habilitado, esta opción se asegura de que las operaciones de escritura se sincronicen con los ficheros de la base de dato del disco.

    Nota: Si el registro en el diario está habilitado, se recomienda utilizar la opción "journal" en lugar de "fsync". No use "fsync" y "journal" simultáneamente, ya que resultará en un error.

  • "journal"

    Cuando "journal" está establecido, todas las operaciones de escritura bloquearán hasta que la base de datos haya volcado los cambios del diario al disco. Esto hace que las operaciones de escritura sean más lentas, pero garantiza su éxito y que puedan ser recuperadas en caso de un fallo total del sistema.

    Nota: Si está operación se usa y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignorarán esta opción.

  • "gssapiServiceName"

    Establece el » Jefe de servicios de Kerberos. Aplicable solamente si authMechanism=GSSAPI. El valor predeterminado es "mongodb".

  • "password"

    La contraseña se puede especificar aquí, en lugar de hacerlo en la lista de hosts. Esto es especialmente útil si una contraseña contuviera un carácter "@". Esto anula a una contraseña establecida en la lista de hosts.

  • "readPreference"

    Especifica el tipo de preferencia de lectura. Las preferencias de lectura proporcionan control sobre los secundarios desde los que se pueden leer datos.

    Los valores permitidos son: MongoClient::RP_PRIMARY,
MongoClient::RP_PRIMARY_PREFERRED,
MongoClient::RP_SECONDARY,
MongoClient::RP_SECONDARY_PREFERRED y
MongoClient::RP_NEAREST.

    Véase la documentación sobre preferencias de lectura para más información.

  • "readPreferenceTags"

    Especifica las etiquetas de preferencia de lectura como un array de strings. Las etiquetas se pueden usar junto con la opción readPreference para un control mayor sobre los secundarios desde los que se podrían leer datos.

    Véase la documentación sobre preferencias de lectura para más información.

  • "replicaSet"

    El nombre del conjunto de réplica al que conectarse. Si se proporciona, el primario se determinará automáticamente. Esto significa que el controlador podría acabar por conectarse a un servidor que no estuviera en la lista. Véase el ejemplo del conjunto de réplica abajo para mas detalles.

  • "secondaryAcceptableLatencyMS"

    Cuando se lee de un secundario (usando ReadPreferences), no leer de secundarios que se sabe que están a más de secondaryAcceptableLatencyMS de nosotros. El valor predeterminado es 15

  • "socketTimeoutMS"

    Cuánto puede tomar una operación de socket (lectura o escritura) antes de expirar, en milisegundos. El valor predeterminado es 30000 (30 segundos).

    Si se especifica -1, las operaciones de socket podrían quedar en espera indefinidamente. Esta opción también podría establecerse de acuerdo a cada operación usando MongoCursor::timeout() para consultas o la opción "socketTimeoutMS" para métodos de escritura.

    Nota: Este es un tiempo límite del lado del cliente. Si un una operación de escritura expira, no hay forma de saber si el servidor manejó realmente la escritura o no, ya que se lanzará una MongoCursorTimeoutException en lugar de devolver un resultado de escritura.

  • "ssl"

    Un booleano para especificar si se desea habilitar SSL para las conexiones a MongoDB. Las opciones extra, como los certificados, se pueden establecer con Opciones de contexto para SSL.

  • "username"

    El nombre de usuario se puede especificar aquí, en lugar de incluirlo en la lista de hosts. Esto es especialmente útil de un nombre de usuario contuviera un carácter ":". Esto anula un nombre de usuario establecido en la lista de hosts.

  • "w"

    La opción w especifica el Asunto de Escritura para el controlador, que determina por cuánto tiempo éste bloqueará al escribir. El valor predeterminado es 1.

    Esta opción es aplicable al conectar tanto a servidores únicos como a conjuntos de réplica. Un valor positivo controla cuántos nodos deberán reconocer la instrucción de escritura antes de que el controlador continue. Un valor de 1 requerirá que el servidor único o primario (en un conjunto de réplica) reconozca la operación de escritura. Un valor de 3 hará que el controlador bloquee hasta que la escritura haya sido aplicada al servidor primario y a dos secundarios (en un conjunto de réplica).

    Se usa un valor de tipo string para controlar qué conjuntos de etiquetas se toman en cuenta para asuntos de escritura. "majority" es especial y se asegura de que la opración de escritura haya sido replicada a la mayoría (más del 50%) de los nodos participantes.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable para operaciones de escritura donde "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "slaveOkay"

    Obsoleta. Use las opciones de preferencias de lectura.

  • "timeout"

    Alias obsoleto de "connectTimeoutMS".

  • "wTimeout"

    Alias obsoleto de "wTimeoutMS".

driver_options

Un array de opciones para el controlador de MongoDB. Las opciones incluyen los ajustes de conexión opciones de contexto para SSL o retrollamadas de identificación.

  • "context"

    El contexto de flujo a adjuntar a todas las conexiones nuevas. Esto permite, por ejemplo, configurar certificados SSL. Están descritos en las opciones de contexto de SSL. Véase el tutorial Conectar sobre SSL.

Valores devueltos

Devuelve un nuevo objeto de conexión a bases de datos.

Errores/Excepciones

Lanza una MongoConnectionException si falla al intentar conectarse a la base de datos para todos los nombres de host dados. También lanzará una MongoConnnectionException si se proporciona un nombre de usuario o contraseña no válidos. Véase la documentación de MongoConnectionException para excepciones comunes y sus causas.

Ejemplos

Ejemplo #1 Ejemplo de conjunto de réplica con MongoClient::__construct()

Este ejemplo muestra cómo el controlador se conecta a un conjunto de réplica. Se asume que hay un conjunto con tres servidores: sf1.example.com, sf2.example.com, y ny1.example.com. El primario podría ser cualquiera de ellos.

<?php

// pasar una lista separada por comas con los nombres de los servidores al constructor
// Observe que no es necesario pasar todos los miembros del conjunto réplica, el controlador
// derivará la lista completa.
$m1 = new MongoClient("mongodb://sf2.example.com,ny1.example.com", array("replicaSet" => "myReplSet"));

?>

Si el primario principal falla, el controlador resolverá qué servidor secundario se convertirá en el nuevo primario y empezará a usar automáticamente esa conexión. La tolerancia a fallos no funcionará correctamente si no se especifica el conjunto de réplica dado por replicaSet.

Al menos una semilla de la lista debe estar funcionando para que el controlador pueda conectarse al conjunto de réplica.

Si se incluyen semillas de dos conjuntos de réplicas distintos, el comportamiento será indefinido.

Véase la » documentación principal sobre conjuntos de réplica para más información.

Ejemplo #2 Conectarse a un socket de dominio

En la versión 1.0.9+, se puede usar un socket de dominio UNIX para conectarse a una instancia de MongoDB que se ejecute localmente. Esto debería ser ligeramente más rápido que utilizar una conexión de red.

En la versión 1.5.0, el servidor de MongoDB abre automáticamente un socket en /tmp/mongodb-<puerto>.sock. Se puede conectar a este socket especificado la ruta en el string de conexión:

<?php

// Servidor de MongoDB ejecutándose localmente en el puerto 20000
$m = new MongoClient("mongodb:///tmp/mongodb-20000.sock");

?>

Se puede combinar esto con cualquier otra conexión:

<?php

// intentar conectarse al socket de dominio, recurrir a la conexión de localhost
$m = new MongoClient("mongodb:///tmp/mongodb-27017.sock,localhost:27017");

?>

Ejemplo #3 Ejemplo de autenticación con MongoClient::__construct()

Debe existir un usuario en la base de datos 'admin' antes de intentar usar la autenticación. Se puede crear uno con la interfaz de línea de comandos de Mongo ejecutando:

> use admin
switched to db admin
> db.addUser("testUser", "testPass");
{
        "_id" : ObjectId("4b21272fd9ab21611d19095c"),
        "user" : "testUser",
        "pwd" : "03b9b27e0abf1865e2f6fcbd9845dd59"
}
>

Después de crear un usuario, en este caso, con nombre "testUser" y contraseña "testPass", se puede crear una conexión autenticada:

<?php

$m = new MongoClient("mongodb://testUser:testPass@localhost");

?>

Ejemplo #4 Ejemplo de preferencia de lectura con MongoClient::__construct()

<?php

// Preferir el servidor más cercano del centro de datos "east"
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

Véase la sección Preferencias de lectura de este manual para más información.

Ejemplo #5 Ejemplo de opciones de MongoClient::__construct()

Las opciones puede pasarse a través del string de consulta en el string de conexión, o como un array pasado al constructor como segundo argumento.

Aquí se establece la opción 'journal' a true y 'readPreference' al secundario preferido como predeterminado para todas las operaciones de escritura:

<?php
$m = new MongoClient("mongodb://localhost/?journal=true&readPreference=secondary");
?>

Y ahora se hace lo mismo, pero con un array de opciones:

<?php
$opciones = array(
    'journal' => true,
    'readPreference' => 'secondary',
);
$m = new MongoClient("mongodb://localhost/", $opciones);
?>

Ejemplo #6 Ejemplo de preferencia de lectura de MongoClient::__construct()

<?php

// Preferir el servidor más cercano en el centro de datos "east"
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

Véase la sección Preferencias de lectura de este manual para más información.

Historial de cambios

Versión | Descripción
1.5.0

Se añadieron "authMechanism", "gssapiServiceName", y "secondaryAcceptableLatencyMS".

1.4.0

Se añadió la opción "ssl" y el soporte para conexiones sobre SSL.

Se añadió la opción "wTimeoutMS", que remplaza a "wTimeout".

Emite un error de nivel E_DEPRECATED al usar "slaveOkay" o "timeout".

1.5.0

Se añadió "authSource".

1.3.4

Se añadieron las opciones "connectTimeoutMS" y "socketTimeoutMS".

1.3.0

Se añadieron las opciones "readPreference", "readPreferenceTags", "w" y "wTimeout".

1.2.0

Se añadieron las opciones "username" y "password".

Eliminada la opción "persist", ya que ahora todas las conexiones son persistentes. Aún se puede usar, pero no afecta a nada.

"persist"

Si la conexión debiera ser persistente. Si se establece, la conexión será persistente. La representación de tipo string del valor se usa como un ID para la conexión, por lo que dos instancias de MongoClient que hayan sido inicializadas con array("persist" => "foobar") compartirán la misma conexión a la base de datos, mientras que una instancia inicializada con array("persist" => "barbaz") usará una conexión diferente a la base de datos.

La opción "replicaSet" ahora toma un string, no un booleano.

1.0.9 | Se añadió la opción "replicaSet".
1.0.2

Se cambió el constructor para que tome un array de opciones. Antes de la versión 1.0.2, el constructor tomaba los siguientes parámetros:

server

El nombre del servidor.

connect

Parámetro booleano opcional que especifica si el constructor debe conectarse a la base de datos antes de devolver. El valor predeterminado es true.

persistent

Si la conexión debería se persistente.

paired

Si la conexión debería estar emparejada.


Elimina una base de datos [obsoleto]

  • « MongoClient::__construct
  • MongoClient::__get »
  • PHP Manual
  • MongoClient
  • Elimina una base de datos [obsoleto]

MongoClient::dropDB

(PECL mongo >=1.3.0)

MongoClient::dropDB — Elimina una base de datos [obsoleto]

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión, aunque existe una alterenativa en la biblioteca de PHP:

  • » MongoDB\Database\drop

Descripción

public MongoClient::dropDB ( mixed $db ) : array
Advertencia

Obsoleto

Use MongoDB::drop() en su lugar.

Parámetros

db

La base de datos a eliminar. Puede ser un objeto MongoDB o el nombre de la base de datos.

Valores devueltos

Devuelve la respuesta de la base de datos.


Obtiene una base de datos

  • « MongoClient::dropDB
  • MongoClient::getConnections »
  • PHP Manual
  • MongoClient
  • Obtiene una base de datos

MongoClient::__get

(PECL mongo >=1.3.0)

MongoClient::__get — Obtiene una base de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión, aunque existe una alterenativa en la biblioteca de PHP:

  • » MongoDB\Client\selectDatabase

Descripción

public MongoClient::__get ( string $dbname ) : MongoDB

Esta es la forma más limpia de obtener una base de datos. Si el nombre de la base de datos posee caracteres especiales, será necesario usar MongoClient::selectDB(); sin embargo, este método debería ser suficiente en la mayoría de los casos.

<?php

$mongo = new MongoClient();

// las dos líneas siguientes son equivalentes
$bd = $mongo->selectDB("foo");
$bd = $mongo->foo;

?>

Parámetros

dbname

El nombre de la base de datos.

Valores devueltos

Returns a new db object.

Errores/Excepciones

Lanza una excepción genérica si el nombre de la base de datos no es válido.


Devuelve información sobre todas las conexiones abiertas

  • « MongoClient::__get
  • MongoClient::getHosts »
  • PHP Manual
  • MongoClient
  • Devuelve información sobre todas las conexiones abiertas

MongoClient::getConnections

(PECL mongo >=1.3.0)

MongoClient::getConnections — Devuelve información sobre todas las conexiones abiertas

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public static MongoClient::getConnections ( ) : array

Devuelve un array con todas las conexiones abiertas, e información sobra cada uno de los servidores.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con las conexiones abiertas.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::getConnections()

<?php
$m = new MongoClient;
var_dump($m->getConnections());
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  array(3) {
    ["hash"]=>
    string(26) "localhost:27017;-;X;56052"
    ["server"]=>
    array(3) {
      ["host"]=>
      string(10) "localhost"
      ["port"]=>
      int(27017)
      ["pid"]=>
      int(56052)
    }
    ["connection"]=>
    array(8) {
      ["last_ping"]=>
      int(1354076401)
      ["last_ismaster"]=>
      int(0)
      ["ping_ms"]=>
      int(0)
      ["connection_type"]=>
      int(1)
      ["connection_type_desc"]=>
      string(10) "STANDALONE"
      ["max_bson_size"]=>
      int(16777216)
      ["tag_count"]=>
      int(0)
      ["tags"]=>
      array(0) {
      }
    }
  }
}


Actualiza el estado de todos los hosts asociados

  • « MongoClient::getConnections
  • MongoClient::getReadPreference »
  • PHP Manual
  • MongoClient
  • Actualiza el estado de todos los hosts asociados

MongoClient::getHosts

(PECL mongo >=1.3.0)

MongoClient::getHosts — Actualiza el estado de todos los hosts asociados

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\Driver\Manager::getServers()

Descripción

public MongoClient::getHosts ( ) : array

Este método solamente es útil con una conexión a un conjunto de réplica. Devuelve el estado de todos los hosts del conjunto. Sin un conjunto de réplica, solamente devolverá un array con un elemento que contiene el host al que se está conectado.

Véase la sección de consultas de este manula para información sobre la distribución de lecturas a secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con la información sobre los hosts del conjunto. Incluye el nombre de cada host, su salud (1 para saludable), su estado (1 para primario, 2 para secundairo, 0 para lo demás), el tiempo que toma en realizar un 'ping' al servidor, y cúando ocurrió el último 'ping'. Por ejemplo, en un conjunto de réplica de tres miembros, el array podría parecerse a esto:

array(3) {
  ["A:27017"]=>
  array(4) {
    ["host"]=>
    "A"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(369)
    ["lastPing"]=>
    int(1309470644)
  }
  ["B:27017"]=>
  array(4) {
    ["host"]=>
    "B"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(1)
    ["ping"]=>
    int(139)
    ["lastPing"]=>
    int(1309470644)
  }
  ["C:27017"]=>
  array(4) {
    ["host"]=>
    "C"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(1012)
    ["lastPing"]=>
    int(1309470644)
  }
}

Historial de cambios

Versión | Descripción
1.2.10 | Se añadió el soporte para hosts que no pertenecen a un conjunto de réplica. Los elementos del array devuelto ahora también incluyen hostname y port.

Ver también

  • MongoClient::getConnections() - Devuelve información sobre todas las conexiones abiertas


Obtener la preferencia de lectura para esta conexión

  • « MongoClient::getHosts
  • MongoClient::getWriteConcern »
  • PHP Manual
  • MongoClient
  • Obtener la preferencia de lectura para esta conexión

MongoClient::getReadPreference

(PECL mongo >=1.3.0)

MongoClient::getReadPreference — Obtener la preferencia de lectura para esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Historial de cambios

Versión | Descripción
1.3.3 | El valor devuelto ha cambiado para ser consistente con MongoClient::setReadPreference(). El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa etiquetas como pares clave/valor en lugar de string delimitados por dos puntos.

Ejemplos

Ejemplo #1 Ejemplo de valor devuelto por MongoClient::getReadPreference()

<?php

$m = new MongoClient();
$m->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($m->getReadPreference());
?>

El resultado del ejemplo sería:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}
?>

Ver también

  • La documentación de preferencias de lecutra.
  • MongoClient::setReadPreference() - Establece la preferencia de lectura para esta conexión


Obteenr el asunto de escritura para esta conexión

  • « MongoClient::getReadPreference
  • MongoClient::killCursor »
  • PHP Manual
  • MongoClient
  • Obteenr el asunto de escritura para esta conexión

MongoClient::getWriteConcern

(PECL mongo >=1.5.0)

MongoClient::getWriteConcern — Obteenr el asunto de escritura para esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::getWriteConcern ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe el asunto de escritura. El array contiene los valores w para el nivel de reconocimiento de tipo integer o el modo de tipo, y wtimeout que denota el número máximo de milisegundos que tiene que esperar el servidor para satisfacer el asunto de escritura.

Ejemplos

Ejemplo #1 Ejemplo del valor devuelto por MongoClient::getWriteConcern()

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
var_dump($mc->getWriteConcern());

$mc->setWriteConcern(1, 1000);
var_dump($mc->getWriteConcern());
?>

El resultado del ejemplo sería:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoClient::setWriteConcern() - Establecer el asunto de escritura para esta conexión


Elimina un cursor específico del servidor

  • « MongoClient::getWriteConcern
  • MongoClient::listDBs »
  • PHP Manual
  • MongoClient
  • Elimina un cursor específico del servidor

MongoClient::killCursor

(PECL mongo >=1.5.0)

MongoClient::killCursor — Elimina un cursor específico del servidor

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id ) : bool

En ciertas situaciones, podría ser necesario eliminar un cursor del servidor. Normalmente, los cursores expiran tras 10 minutos de inactividad, pero es posible crear un cursor inmortal con MongoCursor::immortal() que nunca expira. Para poder eliminar dicho cursor inmortal, se puede llamar a este método con la información proporcionada por MongoCursor::info().

Parámetros

server_hash

El hash del servidor que posee el cursor. Puede obtenerse a través de MongoCursor::info().

id

El ID del cursor a eliminar. Se puede proporcionar un valor de tipo int que contenga el ID de 6a bits del cursor , o un objeto de la clase MongoInt64. Lo último es necesario en plataformas de 32 bits (y en Windows).

Valores devueltos

Devuelve true si el método intentó eliminar el cursor, y false si había algo erróneo en los argumentos (tal como un server_hash erróneo). El estado devuelto no refleja dónde fue elminado el cursor, ya que el servidor no proporciona tal información.

Errores/Excepciones

Este método muestra una advertencia si el server_hash proporcionado no coincide con una conexión existente. No intentar eliminar un cursor tampoco se intenta en este caso.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::killCursor()

Este ejemplo muestra cómo conectarse, realizar una consulta, obtener la información del cursor y luego eliminarlo.

<?php
$m = new MongoClient();
$c = $m->testdb->collection;
$cursor = $c->find();
$resultado = $cursor->next();

// Ahora el cursor es válido, por lo que se puede obtener el hash y el ID:
$info = $cursor->info();

// Eliminar el cursor the cursor
MongoClient::killCursor( $info['server'], $info['id'] );
?>


Enumera todas las bases de datos disponibles

  • « MongoClient::killCursor
  • MongoClient::selectCollection »
  • PHP Manual
  • MongoClient
  • Enumera todas las bases de datos disponibles

MongoClient::listDBs

(PECL mongo >=1.3.0)

MongoClient::listDBs — Enumera todas las bases de datos disponibles

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión, aunque existe una alterenativa en la biblioteca de PHP:

  • » MongoDB\Client\listDatabases

Descripción

public MongoClient::listDBs ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array asociativo que contiene tres campos. El primero es databases, que a su vez contiene un array. Cada elemento del array es un array asociativo que se corresponde a una base de datos, proporcionando el nombre de la base de datos, el tamaño, y si está vacía. Los otros dos campos son totalSize (tamaño total en bytes) y ok, que es 1 si este método se ejecutó con éxito.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::listDBs()

Ejemplo que demuestra cómo usar listDBs y la estructura de datos devuelta.

<?php

$mongo = new MongoClient();
$bds = $mongo->listDBs();
print_r($bds);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [databases] => Array
        (
            [0] => Array
                (
                    [name] => doctrine
                    [sizeOnDisk] => 218103808
                    [empty] =>
                )
        )

    [totalSize] => 218103808
    [ok] => 1
)


Obtiene una colección de bases de datos

  • « MongoClient::listDBs
  • MongoClient::selectDB »
  • PHP Manual
  • MongoClient
  • Obtiene una colección de bases de datos

MongoClient::selectCollection

(PECL mongo >=1.3.0)

MongoClient::selectCollection — Obtiene una colección de bases de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión, aunque existe una alterenativa en la biblioteca de PHP:

  • » MongoDB\Client\selectCollection

Descripción

public MongoClient::selectCollection ( string $db , string $collection ) : MongoCollection

Parámetros

db

El nombre de la base de datos.

collection

El nombre de la colección.

Valores devueltos

Returns a new collection object.

Errores/Excepciones

Lanza una Exception si el nombre de la base de datos o el de la colección no son válidos.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::selectCollection()

<?php
$m = new MongoClient();

$c1 = $m->selectCollection("foo", "bar.baz");
// que es equivalente a
$c2 = $m->selectDB("foo")->selectCollection("bar.baz");

// $c1 y $c2 ahora representan la misma colección
?>


Obtiene una base de datos

  • « MongoClient::selectCollection
  • MongoClient::setReadPreference »
  • PHP Manual
  • MongoClient
  • Obtiene una base de datos

MongoClient::selectDB

(PECL mongo >=1.3.0)

MongoClient::selectDB — Obtiene una base de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión, aunque existe una alterenativa en la biblioteca de PHP:

  • » MongoDB\Client\selectDatabase

Descripción

public MongoClient::selectDB ( string $name ) : MongoDB

Parámetros

name

El nombre de la base de datos.

Valores devueltos

Devuelve un objeto de base de datos.

Errores/Excepciones

Lanza una Exception si el nombre de la base de datos no es válido.


Establece la preferencia de lectura para esta conexión

  • « MongoClient::selectDB
  • MongoClient::setWriteConcern »
  • PHP Manual
  • MongoClient
  • Establece la preferencia de lectura para esta conexión

MongoClient::setReadPreference

(PECL mongo >=1.3.0)

MongoClient::setReadPreference — Establece la preferencia de lectura para esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::setReadPreference ( string $read_preference , array $tags = ? ) : bool

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ejemplos

Ejemplo #1 Ejemplo de sintaxis de array de conjunto de etiquetas con MongoClient::setReadPreference()

<?php

$m = new MongoClient();

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir al servidor del centro de datos "west"
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ver también

  • La documentación de preferencias de lecutra.
  • MongoClient::getReadPreference() - Obtener la preferencia de lectura para esta conexión


Establecer el asunto de escritura para esta conexión

  • « MongoClient::setReadPreference
  • MongoClient::__toString »
  • PHP Manual
  • MongoClient
  • Establecer el asunto de escritura para esta conexión

MongoClient::setWriteConcern

(PECL mongo >=1.5.0)

MongoClient::setWriteConcern — Establecer el asunto de escritura para esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

Parámetros

w

El asunto de escritura. Podría ser un valor de tipo integer denotando el número de servidores requeridos para reconocer la escritura, o un string con el modo (p.ej. "majority").

wtimeout

El número máximo de milisegundos que tienen que esperar es servidor para satisfacer el asunto de escritura.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un E_WARNING si el parámetro w no es un valor de tipo integer o string.

Ejemplos

Ejemplo #1 Ejemplo de MongoClient::setWriteConcern()

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');

// Requiere que la mayoría de los servidores en el conjunto de réplica reconozcan escrituras
// en un intervalo de tiempo de tres segundos.
$mc->setWriteConcern('majority', 3000);
?>

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoClient::getWriteConcern() - Obteenr el asunto de escritura para esta conexión


Representación de cadena de esta conexión

  • « MongoClient::setWriteConcern
  • MongoDB »
  • PHP Manual
  • MongoClient
  • Representación de cadena de esta conexión

MongoClient::__toString

(PECL mongo >=1.3.0)

MongoClient::__toString — Representación de cadena de esta conexión

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoClient::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del host y el puerto de esta conexión.


La clase MongoDB

(PECL mongo >=0.9.0)

Introducción

Las instancias de esta clase se utilizan para interactuar con la base de datos. Para seleccionar una base de datos:

Ejemplo #1 Seleccionar una base de datos

<?php

$m = new MongoClient(); // conectar
$db = $m->selectDB("ejemplo");

?>
Los nombres de bases de datos pueden utilizar prácticamente cualquier carácter del rango ASCII. Sin embargo no pueden contener ni " ", "." ni un texto vacío. El nombre "system" también está reservado.

Hay algunos nombres poco usuales de bases de datos que sí son válidos: "null", "[x,y]", "3", "\"", "/".

A diferencia de los nombres de colecciones, los nombres bases de datos pueden contener "$".

Sinopsis de la Clase

MongoDB {
/* Constantes */
const int PROFILING_OFF = 0 ;
const int PROFILING_SLOW = 1 ;
const int PROFILING_ON = 2 ;
/* Campos */
public integer $w = 1 ;
public integer $wtimeout = 10000 ;
/* Métodos */
public authenticate ( string $username , string $password ) : array
public command ( array $command , array $options = array() , string &$hash = ? ) : array
public __construct ( MongoClient $conn , string $name )
public createCollection ( string $name , array $options = ? ) : MongoCollection
public createDBRef ( string $collection , mixed $document_or_id ) : array
public drop ( ) : array
public dropCollection ( mixed $coll ) : array
public execute ( mixed $code , array $args = array() ) : array
public forceError ( ) : bool
public __get ( string $name ) : MongoCollection
public getCollectionInfo ( array $options = array() ) : array
public getCollectionNames ( array $options = array() ) : array
public getDBRef ( array $ref ) : array
public getGridFS ( string $prefix = "fs" ) : MongoGridFS
public getProfilingLevel ( ) : int
public getReadPreference ( ) : array
public getSlaveOkay ( ) : bool
public getWriteConcern ( ) : array
public lastError ( ) : array
public listCollections ( array $options = array() ) : array
public prevError ( ) : array
public repair ( bool $preserve_cloned_files = false , bool $backup_original_files = false ) : array
public resetError ( ) : array
public selectCollection ( string $name ) : MongoCollection
public setProfilingLevel ( int $level ) : int
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public __toString ( ) : string
}

Constantes predefinidas

Niveles de Logs de MongoDB

MongoDB::PROFILING_OFF
0
Profiling deshabilitado.
MongoDB::PROFILING_SLOW
1
Profiling habilitado para operaciones lentas (>100 ms).
MongoDB::PROFILING_ON
2
Profiling habilitado para todas las operaciones.

Campos

w
1

Número de servidores en los que replicar los cambios antes de retornar éxito. Se hereda por las instancias de MongoCollection que deriven de este objeto. w sólo está disponible en versiones 1.5.1+ del servidor MongoDB y 1.0.8+ del driver.

w se usa cada vez que sea necesario ajustar el nivel de aceptación (MongoCollection::insert(), MongoCollection::update(), MongoCollection::remove(), MongoCollection::save(), y MongoCollection::ensureIndex() soportan esta opción). Con el valor predeterminado (1), una operación aceptada devolverá una vez que el servidor de bases de datos obtenga la operación. Si el servidor se cayera antes de que la operación fuera replicada a un secundario, podría perderse la operación de forma permanente. De esta forma, se puede especificar en w un valor superior a uno para garantizar que al menos un secundario ha recibido la operación antes de que se considere que ha habido éxito.

Por ejemplo, si w fuera 2, el primario y un secundario tendrán un registro de la operación o el controlador lanzará una MongoCursorException. Puede ser tentador establecer en w el total de secundarios + primario, pero entonces, si un secundario se cayera, la operación fallaría y se lanzaría una excepción, por lo que suele ser más seguro establecer w=2 (primario y un secundario).

wtimeout
10000

Número de milisegundos a esperar a que las réplicas de MongoDB::$w tengan lugar. Se hereda por las instancias de MongoCollection que deriven de este objeto. w sólo está disponible en las versiones 1.5.1+ del servidor MongoDB y en las 1.0.8+ del driver.

A no ser que se establezca un valor en wtimeout, el servidor esperará eternamente a que se replique a w servidores para finalizar. Por omisión el driver esperará 10 segundos. Puede modificarse este valor para alterar este comportamiento.

Ver también

Documentación de MongoDB de » bases de datos.

Tabla de contenidos

  • MongoDB::authenticate — Iniciar sesión en esta base de datos
  • MongoDB::command — Ejecuta una orden de base de datos
  • MongoDB::__construct — Crea una nueva base de datos
  • MongoDB::createCollection — Crea una colección
  • MongoDB::createDBRef — Crea una referencia a base de datos
  • MongoDB::drop — Borra esta base de datos
  • MongoDB::dropCollection — Borra una colección [obsoleto]
  • MongoDB::execute — Ejecuta código JavaScript en el servidor de bases de datos [obsoleto]
  • MongoDB::forceError — Crea un error de base de datos
  • MongoDB::__get — Obtiene una colección
  • MongoDB::getCollectionInfo — Devuelve información sobre las colecciones de esta base de datos
  • MongoDB::getCollectionNames — Obtiene un array con los nombres de todas las colecciones de esta base de datos
  • MongoDB::getDBRef — Captura el documento que está siendo apuntado por una referencia de base de datos
  • MongoDB::getGridFS — Obtiene un objeto para trabajar con ficheros almacenados en esta base de datos
  • MongoDB::getProfilingLevel — Obtiene el nivel de perfilado (profiling) de la base de datos
  • MongoDB::getReadPreference — Obtener la preferencia de lectura para esta base de datos
  • MongoDB::getSlaveOkay — Devuelve el valor de slaveOkay de esta base de datos
  • MongoDB::getWriteConcern — Obtener el asunto de escritura para esta base de datos
  • MongoDB::lastError — Comprueba si hubo un error en la última operación de base de datos llevada a cabo
  • MongoDB::listCollections — Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos
  • MongoDB::prevError — Comprueba el último error emitido durante una operación de base de datos
  • MongoDB::repair — Repara y compacta esta base de datos
  • MongoDB::resetError — Limpia cualquier error de la base de datos que se haya apuntado
  • MongoDB::selectCollection — Obtiene una colección
  • MongoDB::setProfilingLevel — Establece el nivel de perfilado (profiling) de la base de datos
  • MongoDB::setReadPreference — Establece la preferencia de lectura para esta base de datos
  • MongoDB::setSlaveOkay — Cambiar el valor de slaveOkay de esta base de datos
  • MongoDB::setWriteConcern — Establecer el asunto de escritura para esta base de datos
  • MongoDB::__toString — Nombre de esta base de datos


Iniciar sesión en esta base de datos

  • « MongoDB
  • MongoDB::command »
  • PHP Manual
  • MongoDB
  • Iniciar sesión en esta base de datos

MongoDB::authenticate

(PECL mongo >=1.0.1)

MongoDB::authenticate — Iniciar sesión en esta base de datos

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

En su lugar, es necesario proporcionar credenciales a través de la cadena de conexión.

Descripción

public MongoDB::authenticate ( string $username , string $password ) : array

Este método hace que esta conexión sea autenticada. Si el servidor de bases de datos tiene la autenticación habilitada (de forma predeterminada, no lo está), deberá iniciar sesión antes de poder hacer cualquier cosa.

En general, deberá se recomienda utilizar la autenticación que incorpora MongoClient::__construct() antes que este método. Si se autentica sobre la conexión, y la conexión se cae y se reconecta durante la sesión, automáticamente será re-autenticado. Si se autentica manualmente usando este método, y la conexión se cae, deberá llamar a este método de nuevo cuando la conexión vuelva.

Este método es equivalente a ejecutar:

<?php

$salted = "${username}:mongo:${password}";
$hash = md5($salted);

$nonce = $db->command(array("getnonce" => 1));

$saltedHash = md5($nonce["nonce"]."${username}${hash}");

$result = $db->command(array("authenticate" => 1,
    "user" => $username,
    "nonce" => $nonce["nonce"],
    "key" => $saltedHash
));

?>

Una vez que una conexión ha sido autenticada, sólo puede ser des-autenticada mediante el comando de base de datos "logout":

<?php

$db->command(array("logout" => 1));

?>

Parámetros

username

Nombre de usuario.

password

La contraseña (en texto plano).

Valores devueltos

Devuelve la respuesta de la base de datos. Si el inicio de sesión tuvo éxito, devolverá:

<?php
array("ok" => 1);
?>
Si algo fue mal, devolverá:
<?php
array("ok" => 0, "errmsg" => "auth fails");
?>
("auth fails" puede ser otro mensaje, dependiendo de la versión de la base de datos y de qué fuera mal).

Ver también

Documentación de MongoDB sobre » autenticación.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa. Por favor, pase los detalles de autenticación al constructor.


Ejecuta una orden de base de datos

  • « MongoDB::authenticate
  • MongoDB::__construct »
  • PHP Manual
  • MongoDB
  • Ejecuta una orden de base de datos

MongoDB::command

(PECL mongo >=0.9.2)

MongoDB::command — Ejecuta una orden de base de datos

Descripción

public MongoDB::command ( array $command , array $options = array() , string &$hash = ? ) : array

Prácticamente todo lo que no son operaciones CRUD se puede realizar con una orden de base de datos. ¿Necesita conocer la versión de la base de datos? Hay una orden para ello. ¿Necesita hacer una agregación? Hay una orden para ello. ¿Necesia habilitar la identificación? Ha captado la idea.

Este método es idéntico a:

<?php

public function command($datos) {
    return $this->selectCollection('$cmd')->findOne($datos);
}

?>

Parámetros

command

La Consulta a enviar.

options

Un array de opciones para la creación del índice. Actualmente las opciones disponibles incluyen:

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

Las siguientes opciones están obsoletas y no deberían utilizarse más:

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

hash

Establecer el hash de conexión del servidor que ejecutó la orden. Cuando el resultado de la orden es apropiado para crear un MongoCommandCursor, el objeto del hash es pasarlo a MongoCommandCursor::createFromDocument().

El hash también se corresponderá con una conexión devuelta desde MongoClient::getConnections().

Historial de cambios

Versión | Descripción
1.5.0 | Se renombró la opción "timeout" a "socketTimeoutMS". Emite un error E_DEPRECATED al utilizar "timeout". Se añadió el parámetro por referencia hash.
1.2.0 | Se añadió el parámetro options con una única opción: timeout.

Valores devueltos

Devuelve la respuesta de la base de datos. Cada respuesta de la base de datos siempre es como máximo un documento, lo que significa que el resultado de una orden de base de datos nunca puede exceder 16 MB. La estructura del documento resultante depende de la orden, pero la mayoría de los resultados tendrán el campo ok para indicar éxito o fracaso, y results, que contiene un array por cada documento resultante.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::command() con "distinct"

Buscar todos los valores distintos de una clave.

<?php

$personas = $bd->personas;

$personas->insert(array("nombre" => "Joe", "edad" => 4));
$personas->insert(array("nombre" => "Sally", "edad" => 22));
$personas->insert(array("nombre" => "Dave", "edad" => 22));
$personas->insert(array("nombre" => "Molly", "edad" => 87));

$edades = $bd->command(array("distinct" => "personas", "key" => "edad"));

foreach ($edades['values'] as $edad) {
    echo "$edad\n";
}

?>

El resultado del ejemplo sería algo similar a:

4
22
87

Ejemplo #2 Ejemplo de MongoDB::command() con "distinct"

Buscar todos los valores distintos de una clave, donde el valor es mayor o igual a 18.

<?php

$personas= $bd->personas;

$personas->insert(array("nombre" => "Joe", "edad" => 4));
$personas->insert(array("nombre" => "Sally", "edad" => 22));
$personas->insert(array("nombre" => "Dave", "edad" => 22));
$personas->insert(array("nombre" => "Molly", "edad" => 87));

$edades = $bd->command(
    array(
        "distinct" => "personas",
        "key" => "edad",
        "query" => array("edad" => array('$gte' => 18))
    )
);

foreach ($edades['values'] as $edad) {
    echo "$edad\n";
}

?>

El resultado del ejemplo sería algo similar a:

22
87

Ejemplo #3 Ejemplo de MongoDB::command() con MapReduce

Obtener todos los usuarios con al menos un evento de venta ("sale"), y cuántas veces han realizado ventas cada uno de esos usuarios.

<?php

// documento de eventos de ejemplo
$eventos->insert(array("user_id" => $id,
    "type" => $tipo,
    "time" => new MongoDate(),
    "desc" => $descripción));

// construcción del mapa y función reductora
$mapa = new MongoCode("function() { emit(this.user_id,1); }");
$reductora = new MongoCode("function(k, vals) { ".
    "var sum = 0;".
    "for (var i in vals) {".
        "sum += vals[i];".
    "}".
    "return sum; }");

$sales = $bd->command(array(
    "mapreduce" => "events",
    "map" => $mapa,
    "reduce" => $reductora,
    "query" => array("type" => "sale"),
    "out" => array("merge" => "eventCounts")));

$usuarios = $bd->selectCollection($sales['result'])->find();

foreach ($usuarios as $usuario) {
    echo "El usuario {$usuario['_id']} realizó {$usuario['value']} venta(s).\n";
}

?>

El resultado del ejemplo sería algo similar a:

El usuario 47cc67093475061e3d9536d2 realizó 3 venta(s).
El usuario 49902cde5162504500b45c2c realizó 14 venta(s).
El usuario 4af467e4fd543cce7b0ea8e2 realizó 1 venta(s).

Nota: Usando MongoCode

Este ejemplo utiliza MongoCode, que puede utilizar también un argumento de ámbito. Sin embargo, por el momento, MongoDB no admite el uso de ámbitos en MapReduce. Si fuera necesario usar variables en el lado del cliente con las funciones MapReduce, puede añairlas al ámbito global usando el campo opcional de ámbito con la orden de la base de datos. Consulte la » documentación de MapReduce para más información.

Nota: El argumento out

Antes de 1.8.0, el argumento out era opcional. Si no se iba a usar, los resultados de MapReduce se escribían a una colección temporal, que se eliminaba cuando se cerraba la conexión. A partir de la versión 1.8.0, el argumento out es obligatorio. Consulte la » documentación de MapReduce para más información.

Ejemplo #4 Ejemplo de MongoDB::command() con "geoNear"

Este ejemplo muestra cómo usar la orden geoNear.

<?php
$m = new MongoClient();
$d = $m->demo;
$c = $d->poiConcat;

$r = $d->command(array(
    'geoNear' => "poiConcat",      // Buscar en la colección poiConcat
    'near' => array(-0.08, 51.48), // Buscar cerca de 51.48°N, 0.08°E
    'spherical' => true,           // Habilitar la búsqueda esférica
    'num' => 5,                    // 5 documentos devueltos como máximo
));
print_r($r);
?>

Ver también

  • MongoCollection::aggregate() - Realiza una acumulación usando el framework de acumulación
  • MongoCollection::findAndModify() - Actualizar un documento y devolverlo
  • MongoCollection::group() - Lleva a cabo una operación similar al comando GROUP BY de SQL

La documentación de MongoDB sobre » órdenes de base de datos y las órdenes individuales: » findAndModify, » getLastError, y » repair (existen muchas más, éstos son sólo unos pocos ejemplos).


Crea una nueva base de datos

  • « MongoDB::command
  • MongoDB::createCollection »
  • PHP Manual
  • MongoDB
  • Crea una nueva base de datos

MongoDB::__construct

(PECL mongo >=0.9.0)

MongoDB::__construct — Crea una nueva base de datos

Descripción

public MongoDB::__construct ( MongoClient $conn , string $name )

Este método no está hecho para ser llamado directamente. La forma recomendada de crear una instancia de MongoDB es mediante MongoClient::__get() o mediante MongoClient::selectDB().

Si va a ignorar el párrafo anterior y desea llamar directamente al constructor, puede hacerlo así:

<?php

$m = new MongoClient();
$db = new MongoDB($m, 'mydbname');

?>

Pero no lo haga. Es mucho mas elegante así:

<?php

$m = new MongoClient();
$db = $m->mydbname;

// o, si el nombre contiene caracteres raros:

$db = $m->selectDB('my,db:name');

?>

Parámetros

MongoClient conn

Conexión a la base de datos.

name

Nombre de la base de datos.

Valores devueltos

Devuelve la base de datos.

Errores/Excepciones

Lanza una excepción por defecto si el nombre no fuera válido.


Crea una colección

  • « MongoDB::__construct
  • MongoDB::createDBRef »
  • PHP Manual
  • MongoDB
  • Crea una colección

MongoDB::createCollection

(PECL mongo >=0.9.0)

MongoDB::createCollection — Crea una colección

Descripción

public MongoDB::createCollection ( string $name , array $options = ? ) : MongoCollection

Este método se usa para crear colecciones "capped" (de tamaño fijo) y otras colecciones que requieren opciones especiales. Es idéntico a ejecutar:

<?php

$collection = $db->command(array(
    "create" => $name,
    "capped" => $options["capped"],
    "size" => $options["size"],
    "max" => $options["max"],
    "autoIndexId" => $options["autoIndexId"],
));

?>
Consulte MongoDB::command() para más información sobre comandos de base de datos.

Parámetros

name

Nombre de la colección.

options

Un array que contiene opciones para las colecciones. Cada opción es su propio elemento en el array de opciones, con el nombre de la opción enumerada abajo, siendo la clave del elemento. Las opciones admitidas dependen de la versión del servidor de MongoDB y del motor de almacenamiento, ya que el controlador pasa cualquier opción que se le proporcione directamente al servidor. Unas pocas de las opciones soportadas son las siguientes, aunque se puede encontrar una lista completa en la documentación principal de MongoDB en » createCollection:

capped

Si la colección debería tener un tamaño fijo.

size

Si la colección fuera de tamaño fijo, aquí indicamos su tamaño en bytes.

max

Si la colección fuera de tamaño fijo, aquí establecemos el número máximo de elementos que podrá almacenar.

autoIndexId

Si 'capped' es true, se puede especificar false para deshabilitar el índice atómico creado en el campo _id. Antes de MongoDB 2.2, el valor predeterminado para autoIndexId era false.

Valores devueltos

Devuelve un objeto de colección que representa la nueva colección.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::createCollection() para colección de tamaño fijo

Una colección "capped" es un tipo especial de colección que tiene un tamaño fijo o un número fijo de elementos. Una vez que la colección está "llena", los elementos más viejos se eliminan cada vez que añadimos nuevos. Estas colecciones pueden ser muy útiles para usos como registro de mensajes, donde quizás se desee mantener una determinada cantidad de espacio para mensajes sin preocuparse por si crece demasiado.

Este ejemplo crea una colección de mensajes de error muy pequeña, que mantendrá hasta 10 documentos.

<?php

$log = $db->createCollection(
    "logger",
    array(
        'capped' => true,
        'size' => 10*1024,
        'max' => 10
    )
);

for ($i = 0; $i < 100; $i++) {
    $log->insert(array("level" => WARN, "msg" => "mensaje de error #$i", "ts" => new MongoDate()));
}

$msgs = $log->find();

foreach ($msgs as $msg) {
    echo $msg['msg']."\n";
}

?>

El resultado del ejemplo sería algo similar a:

mensaje de error #90
mensaje de error #91
mensaje de error #92
mensaje de error #93
mensaje de error #94
mensaje de error #95
mensaje de error #96
mensaje de error #97
mensaje de error #98
mensaje de error #99

Historial de cambios

Versión Descripción
1.4.0

En versiones anteriores a la 1.4.0, las opciones eran todas argumentos del método. La sinopsis de la función en esas versiones antiguas es:

public MongoDB::createCollection ( string $name , bool $capped = false , int $size = 0 , int $max = 0 ) : MongoCollection

El significado de las opciones es el mismo que el descrito bajo el argumento options de arriba.


Crea una referencia a base de datos

  • « MongoDB::createCollection
  • MongoDB::drop »
  • PHP Manual
  • MongoDB
  • Crea una referencia a base de datos

MongoDB::createDBRef

(PECL mongo >=0.9.0)

MongoDB::createDBRef — Crea una referencia a base de datos

Descripción

public MongoDB::createDBRef ( string $collection , mixed $document_or_id ) : array

Este método es una interfaz flexible que permite crear referencias a bases de datos (vea MongoDBRef).

Parámetros

collection

Colección a la que apuntará la referencia de base de datos.

document_or_id

Si se proporciona un array o un objeto, su campo _id será usado como ID de referencia. Si se proporciona un MongoId o un escalar, se usará como ID de referencia.

Valores devueltos

Devuelve un array de referencia a base de datos.

Si se proporcionó un array sin el campo _id como parámetro document_or_id, será devuelto null.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::createDBRef()

Ejemplo que muestra cómo crear una referencia a base de datos a partir de un documento.

<?php

$articulos = $db->articulos;

$articulo = array(
 'titulo' => 'Articulo de prueba',
 'descripcion' => 'Descripcion de articulo de prueba'
);

$articulos->insert($articulo);
$ref = $db->createDBRef('articulos', $articulo);

print_r($articulo);
print_r($ref);
?>

El resultado del ejemplo sería algo similar a:

     Array
     (
         [title] => Articulo de prueba
         [description] => Descripcion de articulo de prueba
         [_id] => MongoId Object
             (
             )

     )
     Array
     (
         [$ref] => articulos
         [$id] => MongoId Object
             (
             )

     )

Ahora, $ref puede ser almacenado en otro documento, y consultado más adelante con MongoDB::getDBRef() o con MongoCollection::getDBRef().

Ejemplo #2 Ejemplo de MongoDB::createDBRef()

Ejemplo que muestra cómo crear una referencia a base de datos a partir de un id.

<?php

$id = new MongoId('47cc67093475061e3d9536d2');
$ref = $db->createDBRef('articulos', $id);
?>


Borra esta base de datos

  • « MongoDB::createDBRef
  • MongoDB::dropCollection »
  • PHP Manual
  • MongoDB
  • Borra esta base de datos

MongoDB::drop

(PECL mongo >=0.9.0)

MongoDB::drop — Borra esta base de datos

Descripción

public MongoDB::drop ( ) : array

Borra la base de datos que está en uso.

Es equivalente a ejecutar:

<?php

public function drop() {
    $this->command(array("dropDatabase" => 1));
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta de la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::drop()

Este ejemplo muestra cómo borrar una base de datos mongo.

<?php

$db = $mongo->foo;
$response = $db->drop();
print_r($response);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [dropped] => foo.$cmd
    [ok] => 1
)


Borra una colección [obsoleto]

  • « MongoDB::drop
  • MongoDB::execute »
  • PHP Manual
  • MongoDB
  • Borra una colección [obsoleto]

MongoDB::dropCollection

(PECL mongo >=0.9.0)

MongoDB::dropCollection — Borra una colección [obsoleto]

Descripción

public MongoDB::dropCollection ( mixed $coll ) : array
Advertencia

Obsoleto

Utilice en su lugar MongoCollection::drop().

¡Esta función tiene fugas de memoria en versiones 1.0.7 y anteriores!

Parámetros

coll

MongoCollection o nombre de la colección a borrar.

Valores devueltos

Devuelve la respuesta de la base de datos.


Ejecuta código JavaScript en el servidor de bases de datos [obsoleto]

  • « MongoDB::dropCollection
  • MongoDB::forceError »
  • PHP Manual
  • MongoDB
  • Ejecuta código JavaScript en el servidor de bases de datos [obsoleto]

MongoDB::execute

(PECL mongo >=0.9.3)

MongoDB::execute — Ejecuta código JavaScript en el servidor de bases de datos [obsoleto]

Descripción

public MongoDB::execute ( mixed $code , array $args = array() ) : array
Advertencia

La orden » eval, la cual invoca este método, está obsoleta en MongoDB 3.0+.

El servidor de bases de datos de Mongo contiene un motor JavaScript. Este método permite ejecutar cualquier código JavaScript en la base de datos. Puede resultar útil si se desea trabajar ligeramente sobre algunas colecciones, o procesar algunos resultados en el lado del servidor para reducir la cantidad de datos que se enviará al cliente.

Al ejecutar JavaScript en la base de datos se hace un bloqueo de escrituras, lo cual significa que se bloquean otras operaciones. Asegúrese de que tiene esto en consideración antes de ejecutar scripts costosos.

Este método es una envoltura para la orden de base de datos » eval. Este método es básicamente:

<?php

public function execute($code, $args) {
    return $this->command(array('eval' => $code, 'args' => $args));
}

?>

Si se tuviera una única sentencia en una única línea, MongoDB devuelve un valor. Esto puede provocar comportamientos inesperados. Por ejemplo, el siguiente código devuelvo "foo":

<?php

$db->execute('"foo";');

?>

Sin embargo, este código devuelve null:

<?php

$db->execute('"bar"; "foo";'); // más de una sentencia

$db->execute('db.foo.count(
);'); // más de una línea

?>

Para evitar comportamientos inesperados, lo mejor es no dejar que MongoDB decida qué devolver, usando en su lugar una sentencia "return" explícita. Podríamos cambiar los ejemplos superiores por lo siguiente:

<?php

$db->execute('"bar"; return "foo";');

$db->execute('return db.foo.count(
);');

?>

Ahora, la primera sentencia devolverá "foo" y la segunda devolverá un contador de la colección "foo".

Parámetros

code

MongoCode o texto a ejecutar.

args

Argumentos que se deben pasar a code.

Valores devueltos

Devuelve el resultado de la evaluación.

Ejemplos

Ejemplo #1 Ejemplo sencillo de MongoDB::execute()

<?php

$response = $db->execute("function() { return 'Hola, mundo!'; }");
echo $response['retval'];

?>

El resultado del ejemplo sería algo similar a:

Hola, mundo!

Ejemplo #2 Ejemplo de parámetros en MongoDB::execute()

Pasaremos a la función JavaScript valores del array del parámetro opcional.

<?php

$response = $db->execute("function(despedida, nombre) { return despedida+', '+nombre+'!'; }", array("Hasta pronto", "Juan"));
echo $response['retval'];

?>

El resultado del ejemplo sería algo similar a:

Hasta pronto, Juan!

Ejemplo #3 Ejemplo de ámbito

Si en lugar de un string, usáramos un MongoCode en el primer parámetro, podrá pasarse un ámbito en el cual se ejecutará JavaScript.

<?php

$func =
    "function(despedida, nombre) { ".
        "return despedida+', '+nombre+', dice '+despedidor;".
    "}";
$scope = array("despedidor" => "Fran");

$code = new MongoCode($func, $scope);

$response = $db->execute($code, array("Hasta pronto", "Juan"));
echo $response['retval'];

?>

El resultado del ejemplo sería algo similar a:

Hasta pronto, Juan, dice Fran

Ver también

  • La documentación de » la orden eval de MongoDB

Historial de cambios

Versión | Descripción
1.7.0 | Este método ha sido declarado obsoleto como resultado de estar también obsoleta en MongoDB 3.0+ la orden » eval.


Crea un error de base de datos

  • « MongoDB::execute
  • MongoDB::__get »
  • PHP Manual
  • MongoDB
  • Crea un error de base de datos

MongoDB::forceError

(PECL mongo >=0.9.5)

MongoDB::forceError — Crea un error de base de datos

Descripción

public MongoDB::forceError ( ) : bool

Este método no es muy útil para el uso normal de MongoDB. Obliga a que se produzca un error de base de datos. Esto quiere decir que MongoDB::lastError() devolverá un error de base de datos genérico después de ejecutar este comando.

Este comando es idéntico a la ejecución de:

<?php

public function forceError() {
    return $this->command(array('forceerror' => 1));
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta de base de datos.

Historial de cambios

Versión | Descripción
1.2.11 | Emite E_DEPRECATED cuando es usada.


Obtiene una colección

  • « MongoDB::forceError
  • MongoDB::getCollectionInfo »
  • PHP Manual
  • MongoDB
  • Obtiene una colección

MongoDB::__get

(PECL mongo >=1.0.2)

MongoDB::__get — Obtiene una colección

Descripción

public MongoDB::__get ( string $name ) : MongoCollection

Ésta es la forma más fácil de obtener uan colección a partir de un objeto de base de datos. Si el nombre de la colección contiene caracteres extraños, se usará en su lugar MongoDB::selectCollection().

<?php

$mongo = new MongoClient();

// las dos siguientes líneas son equivalentes
$collection = $mongo->selectDB("foo")->selectCollection("bar");
$collection = $mongo->foo->bar;

?>

Parámetros

name

Nombre de la colección.

Valores devueltos

Devuelve la colección.


Devuelve información sobre las colecciones de esta base de datos

  • « MongoDB::__get
  • MongoDB::getCollectionNames »
  • PHP Manual
  • MongoDB
  • Devuelve información sobre las colecciones de esta base de datos

MongoDB::getCollectionInfo

(PECL mongo >=1.6.0)

MongoDB::getCollectionInfo — Devuelve información sobre las colecciones de esta base de datos

Descripción

public MongoDB::getCollectionInfo ( array $options = array() ) : array

Obtiene una lista de todas las colecciones de la base de datos y las devuelve como un array de documentos, los cuales contienen sus nombres y opcioines.

Nota: Este método empleará el comando de bases de datos » listCollections al comunicarse con MongoDB 2.8+. Para versiones de bases de datos anteriores, el método consultará la colección especial system.namespaces.

Parámetros

options

Un array de opciones para enumerar las colecciones. Las opciones actualmente disponibles son:

  • "filter"

    Criterios de consulta opcionales. Si se proporcionan, estos criterios se emplearán para filtrar las colecciones incluidas en el resultado.

    Los campoa relevantes que podrían ser requeridos incluyen "name" (el nombre de la colección como string, sin el prefijo del nombre de la base de datos) y "options" (un objeto que contiene opciones empleadas para crear la colección)..

    Nota: MongoDB 2.6 y anteriores requieren que los criterios "name", si se especifican, sean un valor de tipo string (esto es, coincidencia de igualdad). Esto es así debido a que el controlador debe prefijar el valor con el nombre de la base de datos para poder consultar la colección system.namespaces. Las versiones posteriores de MongoDB no tienen esta limitación, ya que el controlador emplea el comando listCollections.

  • "includeSystemCollections"

    Booleano, predeterminado a false. Determina si las colecciones del sistema deberían ser incluidas en el resultado.

La siguiente opción se puede utilizar con MongoDB 2.8+:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Esta función devuelve un array donde cada elemento es un array que describe una colección. Los elementos contendrán una clave name denotando el nombre de la colección, y opcionalmente una clave options denotando un array de objetos los empleados para crear la colección. Por ejemplo, las colecciones limitadas incluirán las opciones capped y size.

Errores/Excepciones

En MongoDB 2.6 y anteriores, se lanzará una MongoException si se especifica un valor distinto de un string para el criterio "name" de la opción "filter".

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::getCollectionInfo()

<?php
$m = new MongoClient();
$db = $m->selectDB("demo");
var_dump($db->getCollectionInfo());
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  [0]=>
  array(2) {
    ["name"]=>
    string(4) "logs"
    ["options"]=>
    array(2) {
      ["capped"]=>
      bool(true)
      ["size"]=>
      int(10240)
    }
  }
  [1]=>
  array(2) {
    ["name"]=>
    string(5) "users"
    ["options"]=>
    array(1) {
      ["flags"]=>
      int(1)
    }
  }
}

Ver también

  • MongoDB::getCollectionNames() - Obtiene un array con los nombres de todas las colecciones de esta base de datos
  • MongoDB::listCollections() - Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos


Obtiene un array con los nombres de todas las colecciones de esta base de datos

  • « MongoDB::getCollectionInfo
  • MongoDB::getDBRef »
  • PHP Manual
  • MongoDB
  • Obtiene un array con los nombres de todas las colecciones de esta base de datos

MongoDB::getCollectionNames

(PECL mongo >=1.3.0)

MongoDB::getCollectionNames — Obtiene un array con los nombres de todas las colecciones de esta base de datos

Descripción

public MongoDB::getCollectionNames ( array $options = array() ) : array

Obtiene una lista con todas las colecciones de la base de datos y devuelve sus nombres en un array de string.

Nota: Este método empleará el comando de bases de datos » listCollections al comunicarse con MongoDB 2.8+. Para versiones de bases de datos anteriores, el método consultará la colección especial system.namespaces.

Parámetros

options

Un array de opciones para enumerar las colecciones. Actualmente las opciones disponibles son:

  • "filter"

    Criterios de consulta opcionales. Si se proporcionan, estos criterios se emplearán para filtrar las colecciones incluidas en el resultado.

    Los campoa relevantes que podrían ser requeridos incluyen "name" (el nombre de la colección como string, sin el prefijo del nombre de la base de datos) y "options" (un objeto que contiene opciones empleadas para crear la colección)..

    Nota: MongoDB 2.6 y anteriores requieren que los criterios "name", si se especifican, sean un valor de tipo string (esto es, coincidencia de igualdad). Esto es así debido a que el controlador debe prefijar el valor con el nombre de la base de datos para poder consultar la colección system.namespaces. Las versiones posteriores de MongoDB no tienen esta limitación, ya que el controlador emplea el comando listCollections.

  • "includeSystemCollections"

    Booleano, predeterminado a false. Determina si las colecciones del sistema deberían ser incluidas en el resultado.

La siguiente opción se puede utilizar con MongoDB 2.8+:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Devuelve los nombres de las colecciones en un array de string.

Errores/Excepciones

Para MongoDB 2.6 y anteriores, se lanzará una MongoException se especifica un valor no existente para los criterios "name" de la opción "filter".

Historial de cambios

Versión | Descripción
1.6.0 | Se cambió el primer parámetro para que sea un array de opciones. Antes de la versión 1.6.0, el primer parámetro era un booleano que indicaba la opción "includeSystemCollections".

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::getCollectionNames()

<?php
$m = new MongoClient();
$bd = $m->selectDB("demo");
$colecciones = $bd->getCollectionNames();

foreach ($colecciones as $nombreColección) {
    echo "Colección encontrada: ", $nombreColección, "\n";
}
?>

El resultado del ejemplo sería algo similar a:

...
Colección encontrada: img
Colección encontrada: beer
Colección encontrada: collation
...

Ver también

  • MongoDB::listCollections() - Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos
  • MongoDB::getCollectionInfo() - Devuelve información sobre las colecciones de esta base de datos


Captura el documento que está siendo apuntado por una referencia de base de datos

  • « MongoDB::getCollectionNames
  • MongoDB::getGridFS »
  • PHP Manual
  • MongoDB
  • Captura el documento que está siendo apuntado por una referencia de base de datos

MongoDB::getDBRef

(PECL mongo >=0.9.0)

MongoDB::getDBRef — Captura el documento que está siendo apuntado por una referencia de base de datos

Descripción

public MongoDB::getDBRef ( array $ref ) : array

Parámetros

ref

Referencia de base de datos.

Valores devueltos

Devuelve el documento apuntado por la referencia.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::getDBRef()

Ejemplo que demuestra cómo obtener una referencia a una base de datos y cuáles son los datos de entrada esperados.

<?php

 $ref = array(
   '$ref' => 'profiles',
   '$id' => new MongoId('47cc67093475061e3d9536d2')
 );

 $profile = $db->getDBRef($ref);
 ?>

Revise MongoDB::createDBRef() para más información sobre cómo crear referencias a bases de datos.


Obtiene un objeto para trabajar con ficheros almacenados en esta base de datos

  • « MongoDB::getDBRef
  • MongoDB::getProfilingLevel »
  • PHP Manual
  • MongoDB
  • Obtiene un objeto para trabajar con ficheros almacenados en esta base de datos

MongoDB::getGridFS

(PECL mongo >=0.9.0)

MongoDB::getGridFS — Obtiene un objeto para trabajar con ficheros almacenados en esta base de datos

Descripción

public MongoDB::getGridFS ( string $prefix = "fs" ) : MongoGridFS

Parámetros

prefix

Prefijo de la colección de ficheros y bloques.

Valores devueltos

Devuelve un nuevo objeto gridfs para esta base de datos.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::getGridFS()

Este ejemplo muestra cómo obtener una instancia de MongoGridFS.

<?php

$db = $mongo->my_db;

$prefix = 'files';
$collection = $db->getGridFS($prefix);

?>

Lea más sobre MongoGridFS para aprender cómo almacenar ficheros con MongoDB.


Obtiene el nivel de perfilado (profiling) de la base de datos

  • « MongoDB::getGridFS
  • MongoDB::getReadPreference »
  • PHP Manual
  • MongoDB
  • Obtiene el nivel de perfilado (profiling) de la base de datos

MongoDB::getProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::getProfilingLevel — Obtiene el nivel de perfilado (profiling) de la base de datos

Descripción

public MongoDB::getProfilingLevel ( ) : int

Devuelve el nivel de perfilado actual de la base de datos.

El perfilador de la base de datos rastrea el tiempo de ejecución de consultas. Si se habilita (digamos, usando MongoDB::setProfilingLevel() o por consola), puede consultar cuánta consultas tardan más que un determinado número de milisegundos, o el tiempo que tardan toda las consultas.

Tenga presente que el perfilado ralentiza las consultas. Por eso, es mejor utilizarlo en entornos de desarrollo o de pruebas antes que en aplicaciones donde el tiempo sea crucial.

Esta función es equivalente a:

<?php

public function getProfilingLevel() {
    return $this->command(array('profile' => -1));
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nivel de perfilado.

Ver también

  • Documentación de MongoDB sobre » profiling
  • MongoDB::setProfilingLevel() - Establece el nivel de perfilado (profiling) de la base de datos


Obtener la preferencia de lectura para esta base de datos

  • « MongoDB::getProfilingLevel
  • MongoDB::getSlaveOkay »
  • PHP Manual
  • MongoDB
  • Obtener la preferencia de lectura para esta base de datos

MongoDB::getReadPreference

(PECL mongo >=1.3.0)

MongoDB::getReadPreference — Obtener la preferencia de lectura para esta base de datos

Descripción

public MongoDB::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Historial de cambios

Versión | Descripción
1.3.3 | El valor devuelto ha cambiado para ser consistente con MongoDB::setReadPreference(). El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa etiquetas como pares clave/valor en lugar de cadenas delimitadas por dos puntos.

Ejemplos

Ejemplo #1 Ejemplo de valor devuelto de MongoDB::getReadPreference()

<?php

$m = new MongoClient();
$bd = $m->test;
$bd->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($bd->getReadPreference());
?>

El resultado del ejemplo sería:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ver también

  • La documentación de preferencias de lectura.
  • MongoDB::setReadPreference() - Establece la preferencia de lectura para esta base de datos


Devuelve el valor de slaveOkay de esta base de datos

  • « MongoDB::getReadPreference
  • MongoDB::getWriteConcern »
  • PHP Manual
  • MongoDB
  • Devuelve el valor de slaveOkay de esta base de datos

MongoDB::getSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::getSlaveOkay — Devuelve el valor de slaveOkay de esta base de datos

Descripción

public MongoDB::getSlaveOkay ( ) : bool

Revise la sección de consultas de este manual para más información sobre distribución de lecturas a secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor de slaveOkay para esta instancia.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoDB::getReadPreference() - Obtener la preferencia de lectura para esta base de datos
  • MongoDB::setReadPreference() - Establece la preferencia de lectura para esta base de datos


Obtener el asunto de escritura para esta base de datos

  • « MongoDB::getSlaveOkay
  • MongoDB::lastError »
  • PHP Manual
  • MongoDB
  • Obtener el asunto de escritura para esta base de datos

MongoDB::getWriteConcern

(PECL mongo >=1.5.0)

MongoDB::getWriteConcern — Obtener el asunto de escritura para esta base de datos

Descripción

public MongoDB::getWriteConcern ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe el asunto de escritura. El array contiene los valores w para el nivel de reconocimiento de tipo integer o el modo de tipo, y wtimeout que denota el número máximo de milisegundos que tiene que esperar el servidor para satisfacer el asunto de escritura.

Ejemplos

Ejemplo #1 Ejemplo del valor devuelto por MongoDB::getWriteConcern()

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$db = $mc->selectDB('test');
var_dump($db->getWriteConcern());

$db->setWriteConcern(1, 1000);
var_dump($db->getWriteConcern());
?>

El resultado del ejemplo sería:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoDB::setWriteConcern() - Establecer el asunto de escritura para esta base de datos


Comprueba si hubo un error en la última operación de base de datos llevada a cabo

  • « MongoDB::getWriteConcern
  • MongoDB::listCollections »
  • PHP Manual
  • MongoDB
  • Comprueba si hubo un error en la última operación de base de datos llevada a cabo

MongoDB::lastError

(PECL mongo >=0.9.5)

MongoDB::lastError — Comprueba si hubo un error en la última operación de base de datos llevada a cabo

Descripción

public MongoDB::lastError ( ) : array

Este método es equivalente a:

<?php

public function lastError() {
    return $this->command(array('getlasterror' => 1));
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el error, si lo hubo.

Ejemplos

Ejemplo #1 Ejemplo de error null de MongoDB::lastError()

<?php
$db->resetError();
var_dump($db->lastError());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["err"]=>
  NULL
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}

Ejemplo #2 Ejemplo de error de clave duplicada con MongoDB::lastError()

<?php
$c = $db->selectCollection("foo");

// insertar dos documentos con el mismo _id
$c->insert(array("_id" => 1));
$c->insert(array("_id" => 1));

var_dump($db->lastError());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["err"]=>
  string(64) "E11000 duplicate key errorindex: foo.foo.$_id_  dup key: { : 1 }"
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}


Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos

  • « MongoDB::lastError
  • MongoDB::prevError »
  • PHP Manual
  • MongoDB
  • Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos

MongoDB::listCollections

(PECL mongo >=0.9.0)

MongoDB::listCollections — Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos

Descripción

public MongoDB::listCollections ( array $options = array() ) : array

Obtiene una lista con todas las colecciones de la base de datos y las devuelve en un array de objetos MongoCollection.

Nota: Este método empleará el comando de bases de datos » listCollections al comunicarse con MongoDB 2.8+. Para versiones de bases de datos anteriores, el método consultará la colección especial system.namespaces.

Parámetros

options

Un array de opciones para enumerar las colecciones. Actualmente las opciones disponibles son:

  • "filter"

    Criterios de consulta opcionales. Si se proporcionan, estos criterios se emplearán para filtrar las colecciones incluidas en el resultado.

    Los campoa relevantes que podrían ser requeridos incluyen "name" (el nombre de la colección como string, sin el prefijo del nombre de la base de datos) y "options" (un objeto que contiene opciones empleadas para crear la colección)..

    Nota: MongoDB 2.6 y anteriores requieren que los criterios "name", si se especifican, sean un valor de tipo string (esto es, coincidencia de igualdad). Esto es así debido a que el controlador debe prefijar el valor con el nombre de la base de datos para poder consultar la colección system.namespaces. Las versiones posteriores de MongoDB no tienen esta limitación, ya que el controlador emplea el comando listCollections.

  • "includeSystemCollections"

    Booleano, predeterminado a false. Determina si las colecciones del sistema deberían ser incluidas en el resultado.

La siguiente opción se puede utilizar con MongoDB 2.8+:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Devuelve un array de objetos MongoCollections.

Errores/Excepciones

Para MongoDB 2.6 y anteriores, se lanzará una MongoException se especifica un valor no existente para los criterios "name" de la opción "filter".

Historial de cambios

Versión | Descripción
1.6.0 | Se cambió el primer parámetro para que sea un array de opciones. Antes de la versión 1.6.0, el primer parámetro era un booleano que indicaba la opción "includeSystemCollections".
1.3.0 | Se añadió el parámetro includeSystemCollections.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::listCollections()

El siguiente ejemplo muestra la ejecución de count en cada una de las colecciones de una base de datos.

<?php

$m = new MongoClient();
$bd = $m->selectDB("demo");
$colecciones = $bd->listCollections();

foreach ($colecciones as $colección) {
    echo "cantidad de documentos en $colección: ";
    echo $colección->count(), "\n";
}

?>

El resultado del ejemplo sería algo similar a:

...
cantidad de documentos en demo.pubs: 4
cantidad de documentos en demo.elephpants: 3
cantidad de documentos en demo.cities: 22840
...

Ver también

  • MongoDB::getCollectionNames() - Obtiene un array con los nombres de todas las colecciones de esta base de datos
  • MongoDB::getCollectionInfo() - Devuelve información sobre las colecciones de esta base de datos


Comprueba el último error emitido durante una operación de base de datos

  • « MongoDB::listCollections
  • MongoDB::repair »
  • PHP Manual
  • MongoDB
  • Comprueba el último error emitido durante una operación de base de datos

MongoDB::prevError

(PECL mongo >=0.9.5)

MongoDB::prevError — Comprueba el último error emitido durante una operación de base de datos

Descripción

public MongoDB::prevError ( ) : array

En general, se recomienda utilizar MongoDB::lastError() en lugar de este método. Este método devuelve el último error de base de datos que tuvo lugar, y hace cuántas operaciones sucedió. Ha quedado prácticamente obsoleto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el error y hace cuántas operaciones sucedió.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.


Repara y compacta esta base de datos

  • « MongoDB::prevError
  • MongoDB::resetError »
  • PHP Manual
  • MongoDB
  • Repara y compacta esta base de datos

MongoDB::repair

(PECL mongo >=0.9.0)

MongoDB::repair — Repara y compacta esta base de datos

Descripción

public MongoDB::repair ( bool $preserve_cloned_files = false , bool $backup_original_files = false ) : array

Crea una nueva copia de todos los datos de la base de datos. Eliminará cualquier dato corrupto y la compactará y aumentará los trampos vacíos que encuentre. Esta operación es muy lenta en bases de datos extensas.

Generalmente se ejecuta desde la consola o desde la línea de comandos, y no por el driver.

Es equivalente a la función:

<?php

public function repair() {
    return $this->command(array('repairDatabase' => 1));
}

?>

Parámetros

preserve_cloned_files

Indica si los ficheros clonados deben mantenerse cuando la reparación falle.

backup_original_files

Si se debe guardar una copia de seguridad de los ficheros originales.

Valores devueltos

Devuelve la respuesta de la base de datos.

Ver también

Documentación de MongoDB sobre » reparación.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::repair()

Este ejemplo muestra cómo reparar y compactar una base de datos.

<?php

$db = $mongo->foo;

$response = $db->repair();
print_r($response);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [ok] => 1
)


Limpia cualquier error de la base de datos que se haya apuntado

  • « MongoDB::repair
  • MongoDB::selectCollection »
  • PHP Manual
  • MongoDB
  • Limpia cualquier error de la base de datos que se haya apuntado

MongoDB::resetError

(PECL mongo >=0.9.5)

MongoDB::resetError — Limpia cualquier error de la base de datos que se haya apuntado

Descripción

public MongoDB::resetError ( ) : array

Generalmente, este método no se utiliza. Reinicia el seguimiento de errores de la base de datos (que puede ser incrementado con MongoDB::forceError(), que tampoco se utiliza normalmente).

Es equivalente a ejecutar:

<?php

public function resetError() {
    return $this->command(array('reseterror' => 1));
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta de la base de datos.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.


Obtiene una colección

  • « MongoDB::resetError
  • MongoDB::setProfilingLevel »
  • PHP Manual
  • MongoDB
  • Obtiene una colección

MongoDB::selectCollection

(PECL mongo >=0.9.0)

MongoDB::selectCollection — Obtiene una colección

Descripción

public MongoDB::selectCollection ( string $name ) : MongoCollection

Parámetros

name

El nombre de la colección.

Valores devueltos

Devuelve un objeto de la colección nueva.

Errores/Excepciones

Lanza una Exception si el nombre de la colección es inválido.


Establece el nivel de perfilado (profiling) de la base de datos

  • « MongoDB::selectCollection
  • MongoDB::setReadPreference »
  • PHP Manual
  • MongoDB
  • Establece el nivel de perfilado (profiling) de la base de datos

MongoDB::setProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::setProfilingLevel — Establece el nivel de perfilado (profiling) de la base de datos

Descripción

public MongoDB::setProfilingLevel ( int $level ) : int

Modifica el nivel actual de profiling de la base de datos.

Esta función es equivalente a:

<?php

public function setProfilingLevel($level) {
    return $this->command(array('profile' => $level));
}

?>

Las opciones de niveles son 0 (deshabilitado), 1 (consultas de más de 100ms), y 2 (todas las consultas). Si se deseara perfilar tan sólo las consultas que llevan más que otro periodo de tiempo, utilice el comando de base de datos con un segundo parámetro: el número de milisegundos. Por ejemplo, para perfil todas las consultas que llevan más de on segundo, ejecute:

<?php

$result = $this->command(array('profile' => 1, 'slowms' => 1000));

?>

Las consultas perfiladas aparecerán en la colección system.profile de esta base de datos.

Parámetros

level

Nivel de perfilado.

Valores devueltos

Devuelve el valor anterior del nivel de perfilado.

Ver también

  • Documentación de MongoDB sobre » profiling
  • MongoDB::getProfilingLevel() - Obtiene el nivel de perfilado (profiling) de la base de datos


Establece la preferencia de lectura para esta base de datos

  • « MongoDB::setProfilingLevel
  • MongoDB::setSlaveOkay »
  • PHP Manual
  • MongoDB
  • Establece la preferencia de lectura para esta base de datos

MongoDB::setReadPreference

(PECL mongo >=1.3.0)

MongoDB::setReadPreference — Establece la preferencia de lectura para esta base de datos

Descripción

public MongoDB::setReadPreference ( string $read_preference , array $tags = ? ) : bool

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ejemplos

Ejemplo #1 Ejemplo de sintaxis de array de conjunto de etiquetas con MongoDB::setReadPreference()

<?php

$m = new MongoClient();
$bd = $m->test;

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir a un servidor el centro de datos "west"
$bd->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ver también

  • La documentación de preferencias de lectura.
  • MongoDB::getReadPreference() - Obtener la preferencia de lectura para esta base de datos


Cambiar el valor de slaveOkay de esta base de datos

  • « MongoDB::setReadPreference
  • MongoDB::setWriteConcern »
  • PHP Manual
  • MongoDB
  • Cambiar el valor de slaveOkay de esta base de datos

MongoDB::setSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::setSlaveOkay — Cambiar el valor de slaveOkay de esta base de datos

Descripción

public MongoDB::setSlaveOkay ( bool $ok = true ) : bool

Revise la sección de consultas de este manual para más información sobre distribución de lecturas a secundarios.

Parámetros

ok

Indica si las lecturas deben enviarse a miembros secundarios de un conjunto de réplicas para todas las posibles consultas que se realicen con esta instancia de MongoDB.

Valores devueltos

Devuelve el valor anterior de slaveOkay de esta instancia.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoDB::setReadPreference() - Establece la preferencia de lectura para esta base de datos
  • MongoDB::getReadPreference() - Obtener la preferencia de lectura para esta base de datos


Establecer el asunto de escritura para esta base de datos

  • « MongoDB::setSlaveOkay
  • MongoDB::__toString »
  • PHP Manual
  • MongoDB
  • Establecer el asunto de escritura para esta base de datos

MongoDB::setWriteConcern

(PECL mongo >=1.5.0)

MongoDB::setWriteConcern — Establecer el asunto de escritura para esta base de datos

Descripción

public MongoDB::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

Parámetros

w

El asunto de escritura. Podría ser un valor de tipo integer denotando el número de servidores requeridos para reconocer la escritura, o un string con el modo (p.ej. "majority").

wtimeout

El número máximo de milisegundos que tienen que esperar es servidor para satisfacer el asunto de escritura.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un E_WARNING si el parámetro w no es un valor de tipo integer o string.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::setWriteConcern()

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$db = $mc->selectDB('test');

// Requiere que la mayoría de los servidores en el conjunto de réplica reconozcan escrituras
// en un intervalo de tiempo de tres segundos.
$db->setWriteConcern('majority', 3000);
?>

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoDB::getWriteConcern() - Obtener el asunto de escritura para esta base de datos


Nombre de esta base de datos

  • « MongoDB::setWriteConcern
  • MongoCollection »
  • PHP Manual
  • MongoDB
  • Nombre de esta base de datos

MongoDB::__toString

(PECL mongo >=0.9.0)

MongoDB::__toString — Nombre de esta base de datos

Descripción

public MongoDB::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de esta base de datos.


La clase MongoCollection

(PECL mongo >=0.9.0)

Introducción

Representa una colección de MongoDB.

Los nombres de colecciones pueden usar cualquier carácter del código ASCII. Algunos ejemplos de nombres válidos de colecciones son "", "...", "mi coleccion", y "*&#@".

Los nombres de colecciones definidos por el usuario no pueden contener el símbolo $. Existen colecciones del sistema que utilizan $ en sus nombres (p.ej., local.oplog.$main), pero es un carácter reservado. Si se intentara crear y usar una colección que incluya $ en su nombre, MongoDB lo notificará.

Sinopsis de la Clase

MongoCollection {
/* Constantes */
const int ASCENDING = 1 ;
const int DESCENDING = -1 ;
/* Campos */
public MongoDB $db = null ;
public integer $w ;
public integer $wtimeout ;
/* Métodos */
public aggregate ( array $pipeline , array $options = ? ) : array
public aggregateCursor ( array $command , array $options = ? ) : MongoCommandCursor
public batchInsert ( array $a , array $options = array() ) : mixed
public __construct ( MongoDB $db , string $name )
public count ( array $query = array() , array $options = array() ) : int
public createDBRef ( mixed $document_or_id ) : array
public createIndex ( array $keys , array $options = array() ) : bool
public deleteIndex ( string|array $keys ) : array
public deleteIndexes ( ) : array
public distinct ( string $key , array $query = ? ) : array
public drop ( ) : array
public ensureIndex ( string|array $key|keys , array $options = array() ) : bool
public find ( array $query = array() , array $fields = array() ) : MongoCursor
public findAndModify ( array $query , array $update = ? , array $fields = ? , array $options = ? ) : array
public findOne
 ( array $query = array()
, array $fields = array()
, array $options = array()
) : array
public __get ( string $name ) : MongoCollection
public getDBRef ( array $ref ) : array
public getIndexInfo ( ) : array
public getName ( ) : string
public getReadPreference ( ) : array
public getSlaveOkay ( ) : bool
public getWriteConcern ( ) : array
public group ( mixed $keys , array $initial , MongoCode $reduce , array $options = array() ) : array
public insert ( array|object $document , array $options = array() ) : bool|array
public parallelCollectionScan ( int $num_cursors ) : array[MongoCommandCursor]
public remove ( array $criteria = array() , array $options = array() ) : bool|array
public save ( array|object $document , array $options = array() ) : mixed
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
static protected toIndexString ( mixed $keys ) : string
public __toString ( ) : string
public update ( array $criteria , array $new_object , array $options = array() ) : bool|array
public validate ( bool $scan_data = false ) : array
}

Constantes predefinidas

MongoCollection::ASCENDING
1
Sentido ascendente para ordenaciones y creaciones de índices.
MongoCollection::DESCENDING
-1
Sentido descendente para ordenaciones y creaciones de índices.

Campos

db

La base de datos "madre" de esta colección.

w

Número de servidores a los que replicar un cambio antes de confirmar el éxito. Este valor se hereda de la base de datos madre. La clase MongoDB indica de forma más detallada cómo funciona w.

wtimeout

El número de milisegundos a esperar a que las operaciones se realicen en las réplicas de $this->w. Este valor se hereda de la base de datos madre. La clase MongoDB indica de forma más detallada cómo funciona wtimeout.

Ver también

Documentación de MongoDB sobre » collections.

Tabla de contenidos

  • MongoCollection::aggregate — Realiza una acumulación usando el framework de acumulación
  • MongoCollection::aggregateCursor — Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor
  • MongoCollection::batchInsert — Inserta múltiples documentos en esta colección
  • MongoCollection::__construct — Crea una nueva colección
  • MongoCollection::count — Cuenta el número de documentos de esta colección
  • MongoCollection::createDBRef — Crea una referencia a una base de datos
  • MongoCollection::createIndex — Crea un índice en el campo o campos especificados, si aún no existen
  • MongoCollection::deleteIndex — Elimina un índice de esta colección
  • MongoCollection::deleteIndexes — Elimina todos los índices de esta colección
  • MongoCollection::distinct — Recupera una lista de valores distintos para una clave dada a través de una colección
  • MongoCollection::drop — Borra esta colección
  • MongoCollection::ensureIndex — Crea un índice en el campo o campos especificados, si aún no existen
  • MongoCollection::find — Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados
  • MongoCollection::findAndModify — Actualizar un documento y devolverlo
  • MongoCollection::findOne — Realiza una consulta a esta colección, devolviendo sólo un elemento
  • MongoCollection::__get — Obtiene una colección
  • MongoCollection::getDBRef — Captura el documento al que apunta una referencia de base de datos
  • MongoCollection::getIndexInfo — Devuelve información sobre los índices de esta colección
  • MongoCollection::getName — Devuelve el nombre de esta colección
  • MongoCollection::getReadPreference — Obtener la preferencia de lectura psrs esta colección
  • MongoCollection::getSlaveOkay — Consulta el valor de slaveOkay de esta colección
  • MongoCollection::getWriteConcern — Obtener el asunto de escritura para esta colección
  • MongoCollection::group — Lleva a cabo una operación similar al comando GROUP BY de SQL
  • MongoCollection::insert — Inserta un documento en la colección
  • MongoCollection::parallelCollectionScan — Devuelve un array con cursores para recorrer una colección completa en paralelo
  • MongoCollection::remove — Eliminar registros de esta colección
  • MongoCollection::save — Guarda un documento en esta colección
  • MongoCollection::setReadPreference — Establecer la preferencia de lectura para esta colección
  • MongoCollection::setSlaveOkay — Cambia el valor de slaveOkay de esta colección
  • MongoCollection::setWriteConcern — Establecer el asunto de escritura para esta base de datos
  • MongoCollection::toIndexString — Convierte claves especificando un índice para su string de identificación
  • MongoCollection::__toString — Representación en forma de string de esta colección
  • MongoCollection::update — Actualizar registros basándose en los criterios proporcionados
  • MongoCollection::validate — Valida esta colección


Realiza una acumulación usando el framework de acumulación

  • « MongoCollection
  • MongoCollection::aggregateCursor »
  • PHP Manual
  • MongoCollection
  • Realiza una acumulación usando el framework de acumulación

MongoCollection::aggregate

(PECL mongo >=1.3.0)

MongoCollection::aggregate — Realiza una acumulación usando el framework de acumulación

Descripción

public MongoCollection::aggregate ( array $pipeline , array $options = ? ) : array
public MongoCollection::aggregate ( array $op , array $op = ? , array $... = ? ) : array

El » framework de agregación de MongoDB proporciona medios para calcular valores acumulados sin tener que usar MapReduce. Aunque MapReduce es potente, a menudo es más dificultoso de lo necesario para muchas tareas sencillas de acumulación, tales como totalizar o hallar la media de valores de campos.

Este método acepta tanto una cantidad variable de operadores de tubería como un único array de dichos operadores constituyendo la tubería.

Parámetros

pipeline

Un array de operadores de tubería.

options

Opciones para el comando de acumulación. Las opciones válidas son:

  • "allowDiskUse"

    Permitir que la agregación pueda escribir ficheros temporales

  • "cursor"

    Opciones para controlar la creación del objeto cursor. Esta opción causa que el comando devuelva un documento de resultados apto para construir un MongoCommandCursor. Si fuera necesario usar esta opción, se debería considerar el uso MongoCollection::aggregateCursor().

  • "explain"

    Devuelve información sobre el procesamiento de la tubería.

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Or

op

Primer operador de tubería.

op

Segundo operador de tubería.

...

Operadores de tubería adicionales.

Valores devueltos

Un array con el resultado de la acumulación. ok será establecido a 1 en caso de éxito, 0 en caso de error.

Errores/Excepciones

Cuando ocurre un error se devuelve un array con las siguientes claves:

  • errmsg - contiene la razón del fallo
  • code - el código de error del fallo
  • ok - será establecido a 0.

Historial de cambios

Versión | Descripción
1.5.0 | Se añadió el parámetro opcional options

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::aggregate()

El siguiente ejemplo de operación acumulativa pivota datos para crear un conjunto de nombres de autores agrupados por etiquetas aplicadas a un artículo. Se llama al framework de acumulación usando el siguiente comando:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("examples")->selectCollection("article");
$datos = array (
    'title' => 'this is my title',
    'author' => 'bob',
    'posted' => new MongoDate,
    'pageViews' => 5,
    'tags' => array ( 'fun', 'good', 'fun' ),
    'comments' => array (
      array (
        'author' => 'joe',
        'text' => 'this is cool',
      ),
      array (
        'author' => 'sam',
        'text' => 'this is bad',
      ),
    ),
    'other' =>array (
      'foo' => 5,
    ),
);
$d = $c->insert($datos, array("w" => 1));

$ops = array(
    array(
        '$project' => array(
            "author" => 1,
            "tags"   => 1,
        )
    ),
    array('$unwind' => '$tags'),
    array(
        '$group' => array(
            "_id" => array("tags" => '$tags'),
            "authors" => array('$addToSet' => '$author'),
        ),
    ),
);
$resultados = $c->aggregate($ops);
var_dump($resultados);
?>

El resultado del ejemplo sería:

array(2) {
  ["result"]=>
  array(2) {
    [0]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(4) "good"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
    [1]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(3) "fun"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
  }
  ["ok"]=>
  float(1)
}

El siguiente ejemplo usa el » conjunto de datos de códigos zip. Utilice mongoimport para cargar este conjunto de datos en una instancia de mongod.

Ejemplo #2 Ejemplo de MongoCollection::aggregate()

Para devolver todos los estados con una población de más de 10 millones, se usa la siguiente operación acumulativa:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("test")->selectCollection("zips");

$tubería = array(
    array(
        '$group' => array(
            '_id' => array('state' => '$state'),
            'totalPop' => array('$sum' => '$pop')
        )
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
);
$salida = $c->aggregate($tubería);
var_dump($salida);
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["result"]=>
  array(7) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "TX"
      ["totalPop"]=>
      int(16986510)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "PA"
      ["totalPop"]=>
      int(11881643)
    }
    [2]=>
    array(2) {
      ["_id"]=>
      string(2) "NY"
      ["totalPop"]=>
      int(17990455)
    }
    [3]=>
    array(2) {
      ["_id"]=>
      string(2) "IL"
      ["totalPop"]=>
      int(11430602)
    }
    [4]=>
    array(2) {
      ["_id"]=>
      string(2) "CA"
      ["totalPop"]=>
      int(29760021)
    }
    [5]=>
    array(2) {
      ["_id"]=>
      string(2) "OH"
      ["totalPop"]=>
      int(10847115)
    }
    [6]=>
    array(2) {
      ["_id"]=>
      string(2) "FL"
      ["totalPop"]=>
      int(12937926)
    }
  }
  ["ok"]=>
  float(1)
}

Ejemplo #3 Ejemplo de MongoCollection::aggregate()

Para devolver la población media de las ciudades de cada estado, use la siguiente operación acumulativa:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("test")->selectCollection("zips");

$salida = $c->aggregate(
    array(
        '$group' => array(
            '_id' => array('state' => '$state', 'city' => '$city' ),
            'pop' => array('$sum' => '$pop' )
        )
    ),
    array(
        '$group' => array(
            '_id' => '$_id.state',
            'avgCityPop' => array('$avg' => '$pop')
        )
    )
);

var_dump($salida);
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["result"]=>
  array(51) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "DC"
      ["avgCityPop"]=>
      float(303450)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "DE"
      ["avgCityPop"]=>
      float(14481.913043478)
    }
...
    [49]=>
    array(2) {
      ["_id"]=>
      string(2) "WI"
      ["avgCityPop"]=>
      float(7323.0074850299)
    }
    [50]=>
    array(2) {
      ["_id"]=>
      string(2) "WV"
      ["avgCityPop"]=>
      float(2759.1953846154)
    }
  }
  ["ok"]=>
  float(1)
}

Ejemplo #4 MongoCollection::aggregate() con opciones de comandos

Para devolver información sobre cómo será procesada la tubería, se use la opción de comando explain

<?php
$m = new MongoClient;
$c = $m->selectDB("test")->selectCollection("zips");

$tubería = array(
    array(
        '$group' => array(
            '_id' => '$state',
           'totalPop' => array('$sum' => '$pop'),
        ),
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
    array(
        '$sort' => array("totalPop" => -1),
    ),
);

$opciones = array("explain" => true);
$salida = $c->aggregate($tubería, $opciones);
var_dump($salida);
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["stages"]=>
  array(4) {
    [0]=>
    array(1) {
      ["$cursor"]=>
      array(3) {
        ["query"]=>
        array(0) {
        }
        ["fields"]=>
        array(3) {
          ["pop"]=>
          int(1)
          ["state"]=>
          int(1)
          ["_id"]=>
          int(0)
        }
        ["plan"]=>
        array(4) {
          ["cursor"]=>
          string(11) "BasicCursor"
          ["isMultiKey"]=>
          bool(false)
          ["scanAndOrder"]=>
          bool(false)
          ["allPlans"]=>
          array(1) {
            [0]=>
            array(3) {
              ["cursor"]=>
              string(11) "BasicCursor"
              ["isMultiKey"]=>
              bool(false)
              ["scanAndOrder"]=>
              bool(false)
            }
          }
        }
      }
    }
    [1]=>
    array(1) {
      ["$group"]=>
      array(2) {
        ["_id"]=>
        string(6) "$state"
        ["totalPop"]=>
        array(1) {
          ["$sum"]=>
          string(4) "$pop"
        }
      }
    }
    [2]=>
    array(1) {
      ["$match"]=>
      array(1) {
        ["totalPop"]=>
        array(1) {
          ["$gte"]=>
          int(10000000)
        }
      }
    }
    [3]=>
    array(1) {
      ["$sort"]=>
      array(1) {
        ["sortKey"]=>
        array(1) {
          ["totalPop"]=>
          int(-1)
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}

Ver también

  • MongoCollection::aggregateCursor() - Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor
  • El » framework de acumulación de MongoDB


Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor

  • « MongoCollection::aggregate
  • MongoCollection::batchInsert »
  • PHP Manual
  • MongoCollection
  • Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor

MongoCollection::aggregateCursor

(PECL mongo >=1.5.0)

MongoCollection::aggregateCursor — Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor

Descripción

public MongoCollection::aggregateCursor ( array $command , array $options = ? ) : MongoCommandCursor

Con este método se pueden ejecutar tuberías del Marco de Acumulación y recuperar los resultados mediante un cursor, en lugar de obtener solamente un documento tal como se haría con MongoCollection::aggregate(). Este método devuelve un objeto MongoCommandCursor. Este objeto de cursor implementa la interfaz Iterator al igual que los objetos MongoCursor devueltos por el método MongoCollection::find().

Nota: El objeto MongoCommandCursor resultante heredará esta preferencia de lectura de colección. Se podría utilizar MongoCommandCursor::setReadPreference() para cambiar la preferencia de lectura antes de recorrer el cursor.

Parámetros

pipeline

La tubería del Marco de Acumulación a ejecutar.

options

Opciones para el comando acumulador. Las opciones válidas son:

  • "allowDiskUse"

    Permitir que los estados acumulados se escriban en ficheros temporales

  • "cursor"

    Es posible configurar cuántos documentos iniciales debería devolver el servidor con el primer conjunto de resultados. El tamaño predeterminado del lote inicial es 101. Se puede cambiar este valor añadiendo la opción batchSize:

    <?php
    $colección    ->aggregateCursor(
            $pipeline,
        [     "cursor" => [ "batchSize" => 4 ] ]
    );

    Esta opción solamente configura el tamaño del primer lote. Para configurar el tamaño de los demás lotes, emplee el método MongoCommandCursor::batchSize() del objeto MongoCommandCursor devuelto.

  • "explain"

    Devolver información del procesamiento de la tubería. Si fuera necesario usar esta opción, se debería considerar el empleo de MongoCollection::aggregate().

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Devuelve un objeto MongoCommandCursor. Puesto que implementa la interfaz Iterator, se puede recorrer cada uno de los resultados mientras los devuelve la consulta de comando. MongoCommandCursor también implementa la interfaz MongoCursorInterface, la cual añade los métodos MongoCommandCursor::batchSize(), MongoCommandCursor::dead() y MongoCommandCursor::info().

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::aggregateCursor()

Encontrar todos los valores distintos de una clave.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

$ages = $people->aggregateCursor( [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
] );

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

El resultado del ejemplo sería algo similar a:

Molly: 130
Joe: 26
Sally: 22

Ejemplo #2 Ejemplo de MongoCollection::aggregateCursor() con un tamaño inicial de lote diferente

Encontrar todos los valores distintos de una clave.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

/* Insert some sample data */
$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

/* Run the command cursor */
$ages = $people->aggregateCursor(
    [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
    ],
    [ "cursor" => [ "batchSize" => 4 ] ]
);

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

El resultado del ejemplo sería algo similar a:

Molly: 130
Joe: 26
Sally: 22

Ver también

  • MongoDB::command() - Ejecuta una orden de base de datos
  • MongoCommandCursor
  • MongoCommandCursor::batchSize() - Limita el número de elementos devueltos en un lote
  • MongoCollection::aggregate() - Realiza una acumulación usando el framework de acumulación
  • El » marco de acumulación de MongoDB


Inserta múltiples documentos en esta colección

  • « MongoCollection::aggregateCursor
  • MongoCollection::__construct »
  • PHP Manual
  • MongoCollection
  • Inserta múltiples documentos en esta colección

MongoCollection::batchInsert

(PECL mongo >=0.9.0)

MongoCollection::batchInsert — Inserta múltiples documentos en esta colección

Descripción

public MongoCollection::batchInsert ( array $a , array $options = array() ) : mixed

Parámetros

a

Un array de arrays u objetos. Si se utilizan objetos, estos no pueden tener propiedades protegidas o privadas.

Nota:

Si los documentos a insertar no poseen una clave o propiedad _id, se creará una nueva instancia de MongoId y se le asignará. Véase MongoCollection::insert() para información adicional sobre este comportamiento.

options

Un array de opciones para las operaciones de inserción de lotes. Las opciones disponibles actualmente son:

  • "continueOnError"

    Booleano, por omisión es false. Si se establece, la base de datos no parará de procesar un volumen de inserciones si una falla (p.ej. debido a IDs duplicados). Esto hace que el volumen de inserciones se comporte de manera similar a una insercioón única, excepto que con la llamada a MongoDB::lastError() se obtendrá un error establecido si cualquier inserción falla, no sólo la primera. Si ocurren varios errores, sólo se informará de más reciente, mediante MongoDB::lastError().

    Nota:

    Observe que continueOnError afecta únicamentea los errores del lado del servidor. Si se intenta insertar un documento que tiene errores (por ejemplo que contiene una clave con un nombre vacío), el documento no será transferido a la base de datos, ya que el controlador detecta este error y no continúa. continueOnError no tiene efecto sobre errores detectados por el controlador en los documentos.

  • "fsync"

    Booleano, cuyo valor predeterminado es false. Si el registro en el diario está habilitado, funciona exactamente igual que "j". Si no está habilidato, la operación de escriturá bloqueará hasta que se sincronice con los ficheros de la base de datos del disco. Si es true, implica una inserción reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si está habilitada, se recomienda a los usuarios usar la opción "j" en lugar de "fsync". No use "fsync" y "j" simultáneamente, ya que resultará en un error.

  • "j"

    Booleano, cuyo valor predeterminado es false. Fuerza a la operación de escritura a bloquear hasta que sea sincronizada con el diario del disco. Si es true, implica una escritura reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si se usa esta opción y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignoran esta opción.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Si el parámetro w está establecido para aceptar la escritura, devuelve un array asociativo con el estado de las inserciones ("ok") y cualquier error que pudiera ocurrir ("err"). De lo contrario, devuelve true si la inserción por lotes fue enviada con éxito, si no, false.

Errores/Excepciones

Lanza una MongoException si cualquier documento insertado está vacío o si contiene claves de longitud cero. Intentar insertar un objeto con propiedades protegidas o privadas causará un error de clave de longitud cero.

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Historial de cambios

Versión | Descripción
1.5.0

Se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout".

Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout".

Emite un error de nivel E_DEPRECATED al usar "safe".

1.3.4 | Se añadió la opción "wtimeout".
1.3.0 | Se añadió la opción "w".
1.2.7 | Se añadió la opción "continueOnError".
1.0.9

Se añadió la capacidad de pasar números enteros a la opción "safe", que anteriormente sólo aceptaba booleanos.

Se añadió la opción "fsync".

1.0.5 | Se añadió el parámetro options.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::batchInsert()

Las inserciones por lotes son una forma rápida de añadir muchos elementos a la base de datos de una sola vez

<?php

$usuarios = array();
for ($i = 0; $i<100; $i++) {
  $usuarios[] = array('nombreUsuario' => 'usuario'.$i, 'i' => $i);
}

$mongo = new MongoClient();
$collection = $mongo->my_db->usuarios;
$collection->drop();

$collection->batchInsert($usuarios);

foreach ($usuarios as $usuario) {
  echo $usuario['_id']."\n"; // completado con instanceof MongoId
}

$usuarios = $collection->find()->sort(array('i' => 1));
foreach ($usuarios as $usuario) {
    var_dump($usuario['nombreUsuario']);
}

?>

El resultado del ejemplo sería algo similar a:

4bf43ac68ead0e1971000000
4bf43ac68ead0e1971010000
4bf43ac68ead0e1971020000
...
string(5) "usuario1"
string(5) "usuario2"
string(5) "usuario3"
...

Ejemplo #2 Ejemplo de MongoCollection::batchInsert() ignorando errores

<?php

$con = new Mongo;
$db = $con->demo;

$doc1 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010001'),
        'id' => 1,
        'desc' => "ONE",
);
$doc2 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'),
        'id' => 2,
        'desc' => "TWO",
);
$doc3 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'), // el mismo _id que el anteior
        'id' => 3,
        'desc' => "THREE",
);
$doc4 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010004'),
        'id' => 4,
        'desc' => "FOUR",
);

$c = $db->selectCollection('c');
$c->batchInsert(
    array($doc1, $doc2, $doc3, $doc4),
    array('continueOnError' => true)
);

$docs = $c->find();
foreach ($docs as $doc) {
    var_dump($doc['desc']);
}
?>

El resultado del ejemplo sería algo similar a:

string(3) "ONE"
string(3) "TWO"
string(4) "FOUR"

Ver también

  • MongoCollection::insert() - Inserta un documento en la colección
  • MongoCollection::update() - Actualizar registros basándose en los criterios proporcionados
  • MongoCollection::find() - Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados
  • MongoCollection::remove() - Eliminar registros de esta colección
  • Documentación de MongoDB sobre » insert.


Crea una nueva colección

  • « MongoCollection::batchInsert
  • MongoCollection::count »
  • PHP Manual
  • MongoCollection
  • Crea una nueva colección

MongoCollection::__construct

(PECL mongo >=0.9.0)

MongoCollection::__construct — Crea una nueva colección

Descripción

public MongoCollection::__construct ( MongoDB $db , string $name )

Parámetros

MongoDB db

Base de datos padre.

name

Nombre de esta colección.

Valores devueltos

Devuelve un nuevo objeto de tipo colección.

Errores/Excepciones

Si el nombre no fuera válido, emite una excepción por defecto.


Cuenta el número de documentos de esta colección

  • « MongoCollection::__construct
  • MongoCollection::createDBRef »
  • PHP Manual
  • MongoCollection
  • Cuenta el número de documentos de esta colección

MongoCollection::count

(PECL mongo >=0.9.0)

MongoCollection::count — Cuenta el número de documentos de esta colección

Descripción

public MongoCollection::count
 ( array $query = array()
, array $options = array()
) : int

Parámetros

query

Array asociativo u objeto con los campos que deben coincidir.

options

Un array de opciones para creación del índice. Las opciones disponibles actualmente son:

Nombre | Tipo | Descripción
hint mixed

Índice para la consulta. Si se pasa un string, debería corresponderse con un nombre de índice. Si se pasa un array y objeto, debería corresponderse con la especificación empelada al crear el índice (esto es, el primer argumento de MongoCollection::createIndex()).

Esta opción solamente está soportada en MongoDB 2.6+.
limit | integer | El número máximo de documentos coincidentes a devolver.
maxTimeMS integer

Especifica un límite de tiempo acumulativo en milisegundos para el procesamiento de la operación (no incluye tiempo inactivo). Si la operación no se completa dentro del período de espera, se lanzará una MongoExecutionTimeoutException.

Esta opción solamente está soportada en MongoDB 2.6+.
skip | integer | El número de documentos coincidentes a saltarse antes de devolver los resultados.

Valores devueltos

Devuelve el número de documentos que coinciden con la consulta.

Errores/Excepciones

Lanza una MongoResultException si el servidor no pudo ejecutar el comando debido a un error.

Lanza una MongoExecutionTimeoutException si la ejecución del comando finalizó debido a maxTimeMS.

Historial de cambios

Versión | Descripción
1.6.0 | El segundo parámetro ahora es el array de opciones options. Pasar limit y skip como segundo y tercer parámetros, respectivamente, ahora está obsoleto.
1.0.7 | Se añadieron los parámetros limit y skip como segundo y tercer parámetros, respectivamente.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::count()

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

var_dump($collection->count());
var_dump($collection->count(array('x'=>1)));

?>

El resultado del ejemplo sería algo similar a:

int(3)
int(1)


Crea una referencia a una base de datos

  • « MongoCollection::count
  • MongoCollection::createIndex »
  • PHP Manual
  • MongoCollection
  • Crea una referencia a una base de datos

MongoCollection::createDBRef

(PECL mongo >=0.9.0)

MongoCollection::createDBRef — Crea una referencia a una base de datos

Descripción

public MongoCollection::createDBRef ( mixed $document_or_id ) : array

Parámetros

document_or_id

Si se proporciona un array o un objeto, su campo _id será usado como ID de referencia. Si se proporciona un MongoId o un escalar, se usará como ID de referencia.

Valores devueltos

Devuelve un array de referencia a base de datos.

Si se proporcionó un array sin el campo _id como parámetro document_or_id, será devuelto null.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::createDBRef()

<?php

$canciones = $db->canciones;
$listasDeReproduccion = $db->listasdereproduccion;

// crea una referencia a una canción
$manamana = $canciones->findOne(array('titulo' => 'Ma na ma na'));
$refACancion = $canciones->createDBRef($manamana);

// añade la referencia a mi lista de reproducción
$listasDeReproduccion->update(array('usuario' => 'yo'), array('$push' => array('listadecanciones' => $refACancion)));

?>

Ver también

  • MongoCollection::getDBRef() - Captura el documento al que apunta una referencia de base de datos


Crea un índice en el campo o campos especificados, si aún no existen

  • « MongoCollection::createDBRef
  • MongoCollection::deleteIndex »
  • PHP Manual
  • MongoCollection
  • Crea un índice en el campo o campos especificados, si aún no existen

MongoCollection::createIndex

(PECL mongo >=1.5.0)

MongoCollection::createIndex — Crea un índice en el campo o campos especificados, si aún no existen

Descripción

public MongoCollection::createIndex ( array $keys , array $options = array() ) : bool

Crea un índice en el/los campo/s especificado/s si aún no existe. Los campos podrían estar indexados con una dirección (p.ej., ascendente o descendente) o un tipo especial (p.ej., texto, geoespacial, hash).

Nota:

Este método utilizará el comando de base de datos » createIndexes al comunicarse con MongoDB 2.6+. Para versiones anteriores de bases de datos, este método realizará una operación de inserción en la colección especial system.indexes.

Parámetros

keys

Un array que tiene como claves los campos de índice. Para cada campo, el valor es la dirección del índice o el » tipo de índice. Si se especifica la dirección, se ha de indicar 1 para ascendente o -1 para descendente.

options

Un array de opciones para la creación del índice. Se pasan todas las opciones dadas directas al servidor, aunque se muestra una lista no exhaustiva de las opciones actualmente disponibles:

  • "unique"

    Especificar true para crear un índice único. El valor predeterminado es false. Esta opción se aplica únicamente a índices ascendentes/descendentes.

    Nota:

    Cuando MongoDB indexa un campo, si un documento no tiene un valor para dicho campo, se indexará un valor null. Si varios documentos no contienen un campo, un índice único rechazará todos excepto el primero de dichos documentos. La opción "sparse" podría usarse para superar esto, ya que prevendrá de que sean indexados los documentos sin tal campo.

  • "dropDups"

    Especificar true para forzar la creación de un índice único donde la colección podría contener valores duplicados para una clave. MongoDB indexará la primera aparición de una clave y borrará todos los documentos subsiguientes de la colección que contengan un valor duplicado para dicha clave. El valor predeterminado es false.

    Advertencia

    "dropDups" podría borrar datos de la base de datos. Úselo con extrema precaución.

    Nota:

    Esta opción no está soportada por MongoDB 2.8+. La creación del índice fallará si la colección contiene valores duplicados.

  • "sparse"

    Especificar true para crear un índice disperso, el cual solamente indexa documentos que contienen un campo específico. El valor predeterminado es false.

  • "expireAfterSeconds"

    El valor de esta opción debería especificarel número de segundos tras los cuales debería un documento ser considerado expirado y automáticamente eliminaod de la colección. Esta opción solamente es compatible con índices de campo único donde el campo contendrá valores MongoDate.

    Nota:

    Esta característica está disponible en MongoDB 2.2+. Véase » Expirar datos de colecciones estableciendo el TTL para más información.

  • "name"

    Un nombre opcional que identifica de forma única al índice.

    Nota:

    Por omisión, el controlador generará un nombre de índice basado en el/los campo/s del índice y el orden o tipo. Por ejemplo, un índice compuesto array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") se llamaría "loc_2dsphere". Para índices con muchos campos, es posible que el nombre generado pueda exceder el » límite para nombres de índices de MongoDB. Se podría usar la opción "name" en tal caso para proporcionar un nombre más corto.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

La siguiente opción podría usarse con MongoDB 2.6+:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Las siguientes opciones podrían usarse con versiones de MongoDB anteriores a la 2.8:

  • "dropDups"

    Especificar true para forzar la creación de un índice único donde la colección podría contener valores duplicados para una clave. MongoDB indexará la primera aparición de una clave y borrará todos los documentos subsiguientes de la colección que contengan un valor duplicado para dicha clave. El valor predeterminado es false.

    Advertencia

    "dropDups" podría borrar datos de la base de datos. Úselo con extrema precaución.

    Nota:

    Esta opción no está soportada por MongoDB 2.8+. La creación del índice fallará si la colección contiene valores duplicados.

Las siguientes opciones podrían usarse con versiones de MongoDB anteriores a la 2.6:

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Devuelve un array que contiene el estado de la creación del índice. El array contiene si la operación tuvo éxito ("ok"), el número de índices antes y después de la operación ("numIndexesBefore" y "numIndexesAfter"), y si la colección a la que pertenece el índice ha sido creada ("createdCollectionAutomatically"). Si el índice ya existe y no fue necesario crearlo, podría estar presente el campo "note" en lugar de "numIndexesAfter".

Con MongoDB 2.4 y anteriores, solamente se devolvía un documento de estado si el asunto de escritura es al menos 1. De lo contrario devuelve true. Los campos del documento de estado son diferentes, excepto por el campo "ok", el cual describe si la creación del índice tuvo éxito. Los campos adicionales están descritos en la documentación de MongoCollection::insert().

Errores/Excepciones

Lanza una MongoException si el nombre del índice es mayor de 128, o si la especificación del índice no es un array.

Lanza una MongoDuplicateKeyException si el servidor no pudo crear el índice único debido a documentos conflictivos.

Lanza una MongoResultException si el servidor no pudo crear el índice debido a un error.

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::ensureIndex()

<?php

$c = new MongoCollection($db, 'foo');

// crear un índice sobre 'x' ascendente
$c->ensureIndex(array('x' => 1));

// crear un índice único sobre 'y'
$c->ensureIndex(array('y' => 1), array('unique' => true));

// crear un índice compuesto sobre 'za' ascendente y 'zb' descendente
$c->ensureIndex(array('za' => 1, 'zb' => -1));

?>

Ejemplo #2 Indexación geoespacial

Mongo soporta índices geoespaciales, los cuales permiten buscar documentos cercanos a una determinada localización o que estén dentro de una determinada forma. Por ejemplo, para crear un índice geoespacial en el campo "loc":

<?php

$colección->ensureIndex(array("loc" => "2d"));

?>

Ejemplo #3 Ejemplo de eliminación de duplicados

<?php

$colección->insert(array('nombreUsuario' => 'joeschmoe'));
$colección->insert(array('nombreUsuario' => 'joeschmoe'));

/* Falla la creación del índice; no se puede crear un índice único en un campo
 * cuando existen duplicados.
 */
$colección->ensureIndex(array('nombreUsuario' => 1), array('unique' => 1));

/* MongoDB uno de los documentos conflictivos y permitirá la creación del
 * índice único.
 */
$colección->ensureIndex(array('nombreUsuario' => 1), array('unique' => 1, 'dropDups' => 1));

/* Ahora tenemos un índice único, por lo que las inserciones subsiguientes con el
 * mismo nombre de usuario fallarán.
 */
$colección->insert(array('nombreUsuario' => 'joeschmoe'));

?>

Ver también

  • MongoCollection::deleteIndex() - Elimina un índice de esta colección
  • MongoCollection::deleteIndexes() - Elimina todos los índices de esta colección
  • La documentación sobre » índices y » tipos de índices de MongoDB.


Elimina un índice de esta colección

  • « MongoCollection::createIndex
  • MongoCollection::deleteIndexes »
  • PHP Manual
  • MongoCollection
  • Elimina un índice de esta colección

MongoCollection::deleteIndex

(PECL mongo >=0.9.0)

MongoCollection::deleteIndex — Elimina un índice de esta colección

Descripción

public MongoCollection::deleteIndex ( string|array $keys ) : array

Este método es identico a:

<?php

public function deleteIndexes($keys) {
  $indexName = $this->toIndexString($keys);

  return $this->db->command(array(
    "deleteIndexes" => $this->getName(),
    "index" => $indexName,
  ));
}

?>

A cada índice se de da un nombre único cuando es creado. A menudo, es generado por el controlador basándose en la/s clave/s del índice y en el orden/tipo, aunque también se podrían especificar nombres personalizados con la opción "name" de MongoCollection::createIndex()).

Desafortunadamente, MongoCollection::deleteIndex() no puede eliminar índices con nombres personalizados por razones de retrocompatibilidada. Cuando se proporciona un argumento de tipo string, se asume que sea el nombre de campo único de un índice ascendente (p.ej., el nombre "x_1" sería utilizado para el argumento "x"). Si se proporciona un array u objeto, se generará un nombre de índice tal como si dicho argumento fuera pasado a MongoCollection::createIndex().

Para poder borrar un índice con nombre personalizado con el controlador de PHP, se debe usar el comando de base de datos deleteIndexes. Por ejemplo, un índice llamado "myIndex" podría borrarse con el controlador de PHP ejecutando:

<?php

$db->command(array(
  "deleteIndexes" => $collection->getName(),
  "index" => "myIndex",
));

?>

Para determinar el nombre de un índice con el controlador de PHP, se puede consultar la colección system.indexes de una base de datos y buscar por el campo "name" cada resultado. El campo "ns" indicará la colección a la que pertenece cada índice.

Parámetros

keys

Un array que tiene como claves los campos de índice. Para cada campo, el valor es la dirección del índice o el » tipo de índice. Si se especifica la dirección, se ha de indicar 1 para ascendente o -1 para descendente.

Si se proporciona un string, se asume que sea el nombre único de campo de un índece ascendente.

Valores devueltos

Devuelve la respuesta de la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::deleteIndex()

Este ejemplo ilustra cómo pasar tanto un stringo como un array a la función.

<?php

$m = new MongoClient();
$c = $m->example->indices;

// crear y eliminar un único índice
$c->createIndex(array("i"=>1));
$c->deleteIndex("i");

// crear y eliminar un índice multiclave
$c->ensureIndex(array("j" => 1, "k" => 1));
$c->deleteIndex(array("j" => 1, "k" => 1));

?>

Ver también

  • MongoCollection::createIndex() - Crea un índice en el campo o campos especificados, si aún no existen
  • MongoCollection::deleteIndexes() - Elimina todos los índices de esta colección
  • MongoCollection::toIndexString() - Convierte claves especificando un índice para su string de identificación
  • La documentación sobre » índices y » tipos de índcies de MongoDB.


Elimina todos los índices de esta colección

  • « MongoCollection::deleteIndex
  • MongoCollection::distinct »
  • PHP Manual
  • MongoCollection
  • Elimina todos los índices de esta colección

MongoCollection::deleteIndexes

(PECL mongo >=0.9.0)

MongoCollection::deleteIndexes — Elimina todos los índices de esta colección

Descripción

public MongoCollection::deleteIndexes ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta de la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::deleteIndexes()

Este ejemplo demuestra cómo eliminar todos los índices de una colección, y muestra también la respuesta demandada.

<?php

$colección = $mongo->my_db->articles;
$respuesta = $colección->deleteIndexes();
print_r($respuesta);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ok] => 1
)

Ver también

  • MongoCollection::createIndex() - Crea un índice en el campo o campos especificados, si aún no existen
  • MongoCollection::deleteIndex() - Elimina un índice de esta colección


Recupera una lista de valores distintos para una clave dada a través de una colección

  • « MongoCollection::deleteIndexes
  • MongoCollection::drop »
  • PHP Manual
  • MongoCollection
  • Recupera una lista de valores distintos para una clave dada a través de una colección

MongoCollection::distinct

(PECL mongo >=1.2.11)

MongoCollection::distinct — Recupera una lista de valores distintos para una clave dada a través de una colección

Descripción

public MongoCollection::distinct ( string $key , array $query = ? ) : array

El comando distinct devuelve una lista de valores distintos para la clave dada a través de una colección.

Parámetros

key

La clave a usar.

query

Parámetros de consulta opcionales.

Valores devueltos

Devuelve un array con valores distintos, o false en caso de error

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::distinct()

<?php
$m = new Mongo;
$bd = $m->selectDB("test");
$bd->dropCollection("distinct");
$c = $bd->distinct;

$c->insert(array("stuff" => "bar", "zip-code" => 10010));
$c->insert(array("stuff" => "foo", "zip-code" => 10010));
$c->insert(array("stuff" => "bar", "zip-code" => 99701), array("w" => 1));

$retval = $c->distinct("zip-code");
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "foo"));
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "bar"));
var_dump($retval);

?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}
array(1) {
  [0]=>
  int(10010)
}
array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}

Ejemplo #2 Ejemplo de MongoCollection::distinct() sobre un documento embebido

<?php
$c->insert(array("user" => array("points" => 25)));
$c->insert(array("user" => array("points" => 31)));
$c->insert(array("user" => array("points" => 25)));

$retval = $c->distinct("user.points");
var_dump($retval);

$retval = $c->distinct("user.nonexisting");
var_dump($retval);
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  int(25)
  [1]=>
  int(31)
}
array(0) {
}


Borra esta colección

  • « MongoCollection::distinct
  • MongoCollection::ensureIndex »
  • PHP Manual
  • MongoCollection
  • Borra esta colección

MongoCollection::drop

(PECL mongo >=0.9.0)

MongoCollection::drop — Borra esta colección

Descripción

public MongoCollection::drop ( ) : array

Borra esta colección y elimina sus índices.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta de la base de datos.

Ejemplos

Ejemplo #1 MongoCollection::drop() example

Este ejemplo demuestra cómo borrar una colección, y muestra también la respuesta esperada.

<?php

$collection = $mongo->my_db->articles;
$response = $collection->drop();
print_r($response);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ns] => my_db.articles
    [ok] => 1
)


Crea un índice en el campo o campos especificados, si aún no existen

  • « MongoCollection::drop
  • MongoCollection::find »
  • PHP Manual
  • MongoCollection
  • Crea un índice en el campo o campos especificados, si aún no existen

MongoCollection::ensureIndex

(PECL mongo >=0.9.0)

MongoCollection::ensureIndex — Crea un índice en el campo o campos especificados, si aún no existen

Descripción

public MongoCollection::ensureIndex ( string|array $key|keys , array $options = array() ) : bool
Advertencia

Este método está obsoleto desde la versión 1.5.0. Use MongoCollection::createIndex() en su lugar.

Crea un índice con el campo o campos especificados si aún no existen. Los campos podría indexarse con una dirección (p.ej., ascendente o descendente) o un tipo especial (p.ej., texto, geoespacial, de tipo hash).

Nota:

Este método utilizará el comando de base de datos » createIndexes al comunicarse con MongoDB 2.6+. Para versiones anteriores de bases de datos, este método realizará una operación de inserción en la colección especial system.indexes.

Parámetros

keys

Un array que tiene como claves los campos de índice. Para cada campo, el valor es la dirección del índice o el » tipo de índice. Si se especifica la dirección, se ha de indicar 1 para ascendente o -1 para descendente.

options

Un array de opciones para la creación del índice. Las opciones actualmente disponibles son:

  • "unique"

    Especificar true para crear un índice único. El valor predeterminado es false. Esta opción se aplica únicamente a índices ascendentes/descendentes.

    Nota:

    Cuando MongoDB indexa un campo, si un documento no tiene un valor para dicho campo, se indexará un valor null. Si varios documentos no contienen un campo, un índice único rechazará todos excepto el primero de dichos documentos. La opción "sparse" podría usarse para superar esto, ya que prevendrá de que sean indexados los documentos sin tal campo.

  • "sparse"

    Especificar true para crear un índice disperso, el cual solamente indexa documentos que contienen un campo específico. El valor predeterminado es false.

  • "expireAfterSeconds"

    El valor de esta opción debería especificarel número de segundos tras los cuales debería un documento ser considerado expirado y automáticamente eliminaod de la colección. Esta opción solamente es compatible con índices de campo único donde el campo contendrá valores MongoDate.

    Nota:

    Esta característica está disponible en MongoDB 2.2+. Véase » Expirar datos de colecciones estableciendo el TTL para más información.

  • "name"

    Un nombre opcional que identifica de forma única al índice.

    Nota:

    Por omisión, el controlador generará un nombre de índice basado en el/los campo/s del índice y el orden o tipo. Por ejemplo, un índice compuesto array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") se llamaría "loc_2dsphere". Para índices con muchos campos, es posible que el nombre generado pueda exceder el » límite para nombres de índices de MongoDB. Se podría usar la opción "name" en tal caso para proporcionar un nombre más corto.

  • "background"

    Construye el índice en segundo plano para no bloquear otras actividades de la base de datos. Especificar true para la construcción en segundo plano. El valor predeterminado es false.

    Advertencia

    Antes de MongoDB 2.6.0, la construcción de índices en secundarios era ejecutada como operaciones de primer plano, independientemente de esta opción. Véase » Construir índices con Conjuntos de Réplica para más información.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

La siguiente opción podría usarse con MongoDB 2.6+:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Las siguientes opciones podrían usarse con versiones de MongoDB anteriores a la 2.8:

  • "dropDups"

    Especificar true para forzar la creación de un índice único donde la colección podría contener valores duplicados para una clave. MongoDB indexará la primera aparición de una clave y borrará todos los documentos subsiguientes de la colección que contengan un valor duplicado para dicha clave. El valor predeterminado es false.

    Advertencia

    "dropDups" podría borrar datos de la base de datos. Úselo con extrema precaución.

    Nota:

    Esta opción no está soportada por MongoDB 2.8+. La creación del índice fallará si la colección contiene valores duplicados.

Las siguientes opciones podrían usarse con versiones de MongoDB anteriores a la 2.6:

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Devuelve un array que contiene el estado de la creación del índice. El array contiene si la operación tuvo éxito ("ok"), el número de índices antes y después de la operación ("numIndexesBefore" y "numIndexesAfter"), y si la colección a la que pertenece el índice ha sido creada ("createdCollectionAutomatically"). Si el índice ya existe y no fue necesario crearlo, podría estar presente el campo "note" en lugar de "numIndexesAfter".

Con MongoDB 2.4 y anteriores, solamente se devolvía un documento de estado si el asunto de escritura es al menos 1. De lo contrario devuelve true. Los campos del documento de estado son diferentes, excepto por el campo "ok", el cual describe si la creación del índice tuvo éxito. Los campos adicionales están descritos en la documentación de MongoCollection::insert().

Historial de cambios

Versión | Descripción
1.5.0

Se renombró la opción "wtimeout" a "wTimeoutMS". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout".

Se renombró la opción "wtimeout" a "socketTimeoutMS". Emite un error de nivel E_DEPRECATED cuando se usa "timeout".

Emite un error de nivel E_DEPRECATED cuando se usa "safe".

1.3.4 | Se añadió la opción "wtimeout".
1.3.0

Se añadió la opción "w".

El parámetro options ya no acepta un booleano para identificar un índice único. En su lugar, ahora debe hacerse con array('unique' => true).

1.2.11 | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.
1.2.0 | Se añadió la opción "timeout".
1.0.11

La opción "safe" desencadenará una tolerancia a fallos en el primario, si fuera necesario.

Se lanzará una MongoException si el nombre del índice (generado o establecido) es mayor que 128 bytes.

1.0.5 | Se añadió la opción "name" para sobrescribir la creación del nombre del índice.
1.0.2 | Se cambió el parámetro options de booleano a array. Antes de la versión 1.0.2, el segundo parámetro era un valor booleano opcional que especificaba si era o no un índice único.

Errores/Excepciones

Lanza una MongoException si el nombre del índice es mayor de 128, o si la especificación del índice no es un array.

Lanza una MongoDuplicateKeyException si el servidor no pudo crear el índice único debido a documentos conflictivos.

Lanza una MongoResultException si el servidor no pudo crear el índice debido a un error.

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::ensureIndex()

<?php

$c = new MongoCollection($db, 'foo');

// crear un índice sobre 'x' ascendente
$c->ensureIndex(array('x' => 1));

// crear un índice único sobre 'y'
$c->ensureIndex(array('y' => 1), array('unique' => true));

// crear un índice compuesto sobre 'za' ascendente y 'zb' descendente
$c->ensureIndex(array('za' => 1, 'zb' => -1));

?>

Ejemplo #2 Indexación geoespacial

Mongo soporta índices geoespaciales, los cuales permiten buscar documentos cercanos a una determinada localización o que estén dentro de una determinada forma. Por ejemplo, para crear un índice geoespacial en el campo "loc":

<?php

$colección->ensureIndex(array("loc" => "2d"));

?>

Ejemplo #3 Ejemplo de eliminación de duplicados

<?php

$colección->insert(array('nombreUsuario' => 'joeschmoe'));
$colección->insert(array('nombreUsuario' => 'joeschmoe'));

/* Falla la creación del índice; no se puede crear un índice único en un campo
 * cuando existen duplicados.
 */
$colección->ensureIndex(array('nombreUsuario' => 1), array('unique' => 1));

/* MongoDB uno de los documentos conflictivos y permitirá la creación del
 * índice único.
 */
$colección->ensureIndex(array('nombreUsuario' => 1), array('unique' => 1, 'dropDups' => 1));

/* Ahora tenemos un índice único, por lo que las inserciones subsiguientes con el
 * mismo nombre de usuario fallarán.
 */
$colección->insert(array('nombreUsuario' => 'joeschmoe'));

?>

Ver también

  • MongoCollection::createIndex() - Crea un índice en el campo o campos especificados, si aún no existen
  • MongoCollection::deleteIndex() - Elimina un índice de esta colección
  • MongoCollection::deleteIndexes() - Elimina todos los índices de esta colección
  • La documentación sobre » índices y » tipos de índices de MongoDB.


Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados

  • « MongoCollection::ensureIndex
  • MongoCollection::findAndModify »
  • PHP Manual
  • MongoCollection
  • Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados

MongoCollection::find

(PECL mongo >=0.9.0)

MongoCollection::find — Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados

Descripción

public MongoCollection::find
 ( array $query = array()
, array $fields = array()
) : MongoCursor

Parámetros

query

Los campos en los que buscar. El lenguaje de consultas de MongoDB es bastante extenso. El controlador de PHP, en la mayoría de los casos, pasará la consulta directamente al servidor, por lo que es una buena idea leer el manual de MongoDB sobre » find.

Advertencia

Asegúrese de que en todos los operadores de consulta especiales (los que empiezan con $) se usen comillas simples, ya que así PHP no intentará reemplazar "$exists" con el valor de la variable $exists.

fields

Campos del resultado que se devolverán. El array está en el formato array('nombrecampo' => true, 'nombrecampo2' => true). El campo _id se devuelve siempre.

Valores devueltos

Devuelve un cursor para los resultados de la búsqueda.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::find()

Este ejemplo demuestra las opciones de búsqueda básica.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'produce');

// buscar frutas
$fruitQuery = array('Type' => 'Fruit');

$cursor = $collection->find($fruitQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

// buscar los que son dulces. Taste es un hijo de Details.
$sweetQuery = array('Details.Taste' => 'Sweet');
echo "Sweet\n";
$cursor = $collection->find($sweetQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

El resultado del ejemplo sería:

array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}
array(4) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "50a87de084f045a19b220dd7"
  }
  ["Name"]=>
  string(5) "Lemon"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(4) "Sour"
    ["Colour"]=>
    string(5) "Green"
  }
}

Sweet:
array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}

Véase MongoCursor para más información sobre cómo trabajar con cursores.

Ejemplo #2 Ejemplo de MongoCollection::find()

Este ejemplo muestra como buscar en un rango.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$colección = new MongoCollection($db, 'phpmanual');

// buscar documentos donde 5 < x < 20
$rangeQuery = array('x' => array( '$gt' => 5, '$lt' => 20 ));

$cursor = $colección->find($rangeQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

El resultado del ejemplo sería:

array(2) {
  ["_id"]=>
  object(MongoId)#10 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000000"
  }
  ["x"]=>
  int(12)
}
array(2) {
  ["_id"]=>
  object(MongoId)#11 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000001"
  }
  ["x"]=>
  int(12)
}

Véase MongoCursor para más información sobre cómo trabajar con cursores.

Ejemplo #3 Ejemplo de MongoCollection::find() usando $where

Este ejemplo demuestra cómo buscar en una colección usando código javascript para reducir el conjunto de resultados.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$colección = new MongoCollection($db, 'phpmanual');

$js = "function() {
    return this.name == 'Joe' || this.age == 50;
}";
$cursor = $colección->find(array('$where' => $js));
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

El resultado del ejemplo sería:

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Ejemplo #4 Ejemplo de MongoCollection::find() usando $in

Este ejemplo demuestra cómo buscar una colección usando el operador $in.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$colección = new MongoCollection($db, 'phpmanual');

$cursor = $colección->find(array(
    'name' => array('$in' => array('Joe', 'Wendy'))
));

?>

El resultado del ejemplo sería:

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Ejemplo #5 Obtener resultados en forma de array

Devuelve un MongoCursor. A menudo, los principiantes se sienten más cómodos usando arrays. Para convertir un cursor en un array, utilice la función iterator_to_array().

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$colección = new MongoCollection($db, 'phpmanual');

$cursor = $colección->find();
$array = iterator_to_array($cursor);

?>

El resultado del ejemplo sería:

array(3) {
  ["4ebc40af10b89f5149000000"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#6 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000000"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000001"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#11 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000001"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000002"]=>
  array(3) {
    ["_id"]=>
    object(MongoId)#12 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000002"
    }
    ["name"]=>
    string(3) "Joe"
    ["age"]=>
    int(20)
  }
}

Al usar iterator_to_array() se fuerza a que el controlador cargue todos los resultados en memoria. ¡No lo use cuando el resultado supere el tamaño máximo de memoria!

Además, algunas colecciones del sistema no tienen un campo _id. Si se trabaja con colecciones que pudieran tener documentos sin _ids, establezca false el segundo argumento de iterator_to_array() (así, no tratará de usar como clave el valor del campo _id inexistente).

Ver también

  • MongoCollection::findOne() - Realiza una consulta a esta colección, devolviendo sólo un elemento
  • MongoCollection::insert() - Inserta un documento en la colección
  • Documentación de MongoDB sobre » find.


Actualizar un documento y devolverlo

  • « MongoCollection::find
  • MongoCollection::findOne »
  • PHP Manual
  • MongoCollection
  • Actualizar un documento y devolverlo

MongoCollection::findAndModify

(PECL mongo >=1.3.0)

MongoCollection::findAndModify — Actualizar un documento y devolverlo

Descripción

public MongoCollection::findAndModify ( array $query , array $update = ? , array $fields = ? , array $options = ? ) : array

El comando findAndModify modifica atómicamente y devuelve un único documento. Por omisión, el documento devuelto no incluye las modificaciones realizadas en la actualización. Para devolver el documento con las modificaciones hechas en la actualización, use la opción new.

Parámetros

query

Los criterios de consulta con los que buscar.

update

Los criterios de actualización.

fields

Devolver opcionalmente estos campos solamente.

options

Un array de opciones a aplicar, tal como eliminar el documento coincidente de la BD y devolverlo.

Opción | Descripción
sort array | Determina qué documento modificará la operación si la consulta selecciona varios. findAndModify modificará el primer documento en el orden especificado por este argumento.
remove boolean | Opcional si el campo update existe. Cuando es true, elimina el documento seleccionado. El valor predeterminado es false.
update array | Opcional si existe el campo remove. Realiza una actualización del documento seleccionado.
new boolean | Opcional. Si es true, devulve el documento modificado en lugar del original. El método findAndModify ignora la opción new en operaciones de eliminación. El valor predeterminado es false.
upsert boolean | Opcional. Usada junto con el campo update. Se es true, el comando findAndModify crea un nuevo documento si la consulta no devuelve ningujo. El valor predeterminado es false. En MongoDB 2.2, el comando findAndModify devuelve null cuando upsert es true.

Valores devueltos

Devuelve el documento original, o el modificado si new está establecido.

Errores/Excepciones

Lanza una MongoResultException en case de error.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::findAndModify()

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;

$col->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => 1)
);

$retval = $col->findAndModify(
     array("inprogress" => false, "name" => "Biz report"),
     array('$set' => array('inprogress' => true, "started" => new MongoDate())),
     null,
     array(
        "sort" => array("priority" => -1),
        "new" => true,
    )
);

var_dump($retval);
?>

El resultado del ejemplo sería algo similar a:

array(6) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "5091b5b244415e8cc3000002"
  }
  ["inprogress"]=>
  bool(true)
  ["name"]=>
  string(10) "Biz report"
  ["priority"]=>
  int(2)
  ["started"]=>
  object(MongoDate)#8 (2) {
    ["sec"]=>
    int(1351726514)
    ["usec"]=>
    int(925000)
  }
  ["tasks"]=>
  array(2) {
    [0]=>
    string(20) "run marketing report"
    [1]=>
    string(12) "email report"
  }
}

Ejemplo #2 Manejo de errores de MongoCollection::findAndModify()

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;
try {
    $retval = $col->findAndModify(
         array("inprogress" => false, "name" => "Next promo"),
         array('$pop' => array("tasks" => -1)),
         array("tasks" => array('$pop' => array("stuff"))),
         array("new" => true)
    );
} catch(MongoResultException $e) {
    echo $e->getCode(), " : ", $e->getMessage(), "\n";
    var_dump($e->getDocument());
}

?>

El resultado del ejemplo sería algo similar a:

13097 : exception: Unsupported projection option: $pop
array(3) {
  ["errmsg"]=>
  string(46) "exception: Unsupported projection option: $pop"
  ["code"]=>
  int(13097)
  ["ok"]=>
  float(0)
}

Ver también

  • La documentación de MongoDB sobre el » comando findAndModify


Realiza una consulta a esta colección, devolviendo sólo un elemento

  • « MongoCollection::findAndModify
  • MongoCollection::__get »
  • PHP Manual
  • MongoCollection
  • Realiza una consulta a esta colección, devolviendo sólo un elemento

MongoCollection::findOne

(PECL mongo >=0.9.0)

MongoCollection::findOne — Realiza una consulta a esta colección, devolviendo sólo un elemento

Descripción

public MongoCollection::findOne
 ( array $query = array()
, array $fields = array()
, array $options = array()
) : array

A diferencia de MongoCollection::find(), este método solamente devolverá el primer resultado del conjunto de resultados, y no una instancia de MongoCursor que se pueda recorrer.

Parámetros

query

Los campos en los que buscar. El lenguaje de consultas de MongoDB es bastante extenso. El controlador de PHP, en la mayoría de los casos, pasará la consulta directamente al servidor, por lo que es una buena idea leer el manual de MongoDB sobre » find.

Advertencia

Asegúrese de que en todos los operadores de consulta especiales (los que empiezan con $) se usen comillas simples, ya que así PHP no intentará reemplazar "$exists" con el valor de la variable $exists.

fields

Campos del resultado que se devolverán. El array está en el formato array('nombrecampo' => true, 'nombrecampo2' => true). El campo _id se devuelve siempre.

options

Este parámetro es un array asociativo de la forma array("nombre" => <valor>, ...). Las opciones disponibles actualmente son:

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Devuelve el registro que coincide con la búsqueda, o null.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos.

Historial de cambios

Versión | Descripción
1.5.0 | Se añadió el parámetro opcional options.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::findOne() buscando por id.

Este ejemplo muestra cómo buscar un documento en una colección a partir de su id.

<?php

$artículos = $mongo->mi_bd->artículos;

$artículo = $artículos->findOne(array('_id' => new MongoId('47cc67093475061e3d9536d2')));

?>

Ejemplo #2 Ejemplo de MongoCollection::findOne() a partir de una condición.

Este ejemplo muestra como buscar un documento en una colección a partir de una condición, limitando los campos devueltos.

<?php

$usuarios = $mongo->mi_bd->usuarios;
$usuario = $usuarios->findOne(array('nombreusuario' => 'jwage'), array('contraseña'));
print_r($usuario);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [_id] => MongoId Object
        (
        )

    [password] => test
)

Observe que, incluso si el documento no contiene el campo "nombreusuario", se limitan los resultados para que únicamente contengan el campo "contraseña".

Ver también

  • MongoCollection::find() - Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados
  • MongoCollection::insert() - Inserta un documento en la colección
  • Documentación de MongoDB sobre » find.


Obtiene una colección

  • « MongoCollection::findOne
  • MongoCollection::getDBRef »
  • PHP Manual
  • MongoCollection
  • Obtiene una colección

MongoCollection::__get

(PECL mongo >=1.0.2)

MongoCollection::__get — Obtiene una colección

Descripción

public MongoCollection::__get ( string $name ) : MongoCollection

Forma concisa de obtener una colección con un nombre separado por el carácter punto. Si el nombre de colección contuviera caracteres extraños, se debería utilizar en su lugar MongoDB::selectCollection().

<?php

$mongo = new MongoClient();

// las dos siguientes sentencias son equivalentes
$collection = $mongo->selectDB("foo")->selectCollection("bar.baz");
$collection = $mongo->foo->bar->baz;

?>

Parámetros

name

Siguiente string en el nombre de la colección.

Valores devueltos

Devuelve la colección.


Captura el documento al que apunta una referencia de base de datos

  • « MongoCollection::__get
  • MongoCollection::getIndexInfo »
  • PHP Manual
  • MongoCollection
  • Captura el documento al que apunta una referencia de base de datos

MongoCollection::getDBRef

(PECL mongo >=0.9.0)

MongoCollection::getDBRef — Captura el documento al que apunta una referencia de base de datos

Descripción

public MongoCollection::getDBRef ( array $ref ) : array

Parámetros

ref

Referencia a una base de datos.

Valores devueltos

Devuelve el documente de base de datos al que apunta esta referencia.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::getDBRef()

<?php

$listasdereproduccion = $db->listasdereproduccion;

$miLista = $listasdereproduccion->findOne(array('usuario' => 'yo'));

// capturar cada canción de la lista de reproducción
foreach ($miLista['listacancion'] as $refCancion) {
    $cancion = $listasdereproduccion->getDBRef($refCancion);
    echo $cancion['titulo'] . "\n";
}

?>

El resultado del ejemplo sería algo similar a:

Dazed and Confused
Ma na ma na
Bohemian Rhapsody

En el ejemplo anterior cada $refCancion será similar a lo siguiente:
    Array
    (
        [$ref] => canciones
        [$id] => 49902cde5162504500b45c2c
    )

Ver también

  • MongoCollection::createDBRef() - Crea una referencia a una base de datos


Devuelve información sobre los índices de esta colección

  • « MongoCollection::getDBRef
  • MongoCollection::getName »
  • PHP Manual
  • MongoCollection
  • Devuelve información sobre los índices de esta colección

MongoCollection::getIndexInfo

(PECL mongo >=0.9.0)

MongoCollection::getIndexInfo — Devuelve información sobre los índices de esta colección

Descripción

public MongoCollection::getIndexInfo ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array en el cual cada elemento describe un índice. Los elementos contendrán los valores name para el nombre del índice, ns para el espacio de nombres (una combianción del nombre de la base de datos y el de la colección), y key para una lista de todos los campos del índice y su orden. Podrían estar presentes valores adicionales para índices especiales, tales como unique o sparse.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::getIndexInfo()

<?php

$m = new MongoClient();
$c = $m->selectCollection('test', 'venues');
var_dump($c->getIndexInfo());

?>

El resultado del ejemplo sería algo similar a:

array(4) {
  [0]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["_id"]=>
      int(1)
    }
    ["name"]=>
    string(4) "_id_"
    ["ns"]=>
    string(11) "test.venues"
  }
  [1]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["name"]=>
      float(1)
    }
    ["name"]=>
    string(6) "name_1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [2]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(2) {
      ["type"]=>
      float(1)
      ["createdAt"]=>
      float(-1)
    }
    ["name"]=>
    string(19) "type_1_createdAt_-1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [3]=>
  array(5) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["location"]=>
      string(8) "2dsphere"
    }
    ["name"]=>
    string(17) "location_2dsphere"
    ["ns"]=>
    string(11) "test.venues"
    ["2dsphereIndexVersion"]=>
    int(2)
  }
}

Ver también

La documentación principal de MongoDB sobre » índices de vainilla e » índices geoespaciales.


Devuelve el nombre de esta colección

  • « MongoCollection::getIndexInfo
  • MongoCollection::getReadPreference »
  • PHP Manual
  • MongoCollection
  • Devuelve el nombre de esta colección

MongoCollection::getName

(PECL mongo >=0.9.0)

MongoCollection::getName — Devuelve el nombre de esta colección

Descripción

public MongoCollection::getName ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de esta colección.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::getName()

<?php

$m = new MongoClient();
$c = $m->foo->bar->baz;

echo "Trabajando con la colección " . $c->getName() . ".\n";

// El espacio de nombres completo viene dado por el método MongoCollection::__toString()
echo "Trabajando en el espacio de nombres $c.\n";

?>

El resultado del ejemplo sería algo similar a:

Trabajando con la colección bar.baz.
Trabajando en el espacio de nombres foo.bar.baz.


Obtener la preferencia de lectura psrs esta colección

  • « MongoCollection::getName
  • MongoCollection::getSlaveOkay »
  • PHP Manual
  • MongoCollection
  • Obtener la preferencia de lectura psrs esta colección

MongoCollection::getReadPreference

(PECL mongo >=1.3.0)

MongoCollection::getReadPreference — Obtener la preferencia de lectura psrs esta colección

Descripción

public MongoCollection::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Historial de cambios

Versión | Descripción
1.3.3 | El valor devuelto ha cambiado para ser consistente con MongoCollection::setReadPreference(). El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa las etiquetas como pares calve/valor en lugar de cadenas delimitadas por dos puntos.

Ejemplos

Ejemplo #1 Ejemplo de valor devueto por MongoCollection::getReadPreference()

<?php

$m = new MongoClient();
$c = $m->test->users;
$c->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($c->getReadPreference());
?>

El resultado del ejemplo sería:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ver también

  • La documentación de preferencias de lectura.
  • MongoCollection::setReadPreference() - Establecer la preferencia de lectura para esta colección


Consulta el valor de slaveOkay de esta colección

  • « MongoCollection::getReadPreference
  • MongoCollection::getWriteConcern »
  • PHP Manual
  • MongoCollection
  • Consulta el valor de slaveOkay de esta colección

MongoCollection::getSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::getSlaveOkay — Consulta el valor de slaveOkay de esta colección

Descripción

public MongoCollection::getSlaveOkay ( ) : bool

Revise la sección de consultas de este manual para más información sobre distribución de lecturas a secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor de slaveOkay para esta instancia.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoCollection::getReadPreference() - Obtener la preferencia de lectura psrs esta colección


Obtener el asunto de escritura para esta colección

  • « MongoCollection::getSlaveOkay
  • MongoCollection::group »
  • PHP Manual
  • MongoCollection
  • Obtener el asunto de escritura para esta colección

MongoCollection::getWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::getWriteConcern — Obtener el asunto de escritura para esta colección

Descripción

public MongoCollection::getWriteConcern ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe el asunto de escritura. El array contiene los valores w para el nivel de reconocimiento de tipo integer o el modo de tipo, y wtimeout que denota el número máximo de milisegundos que tiene que esperar el servidor para satisfacer el asunto de escritura.

Ejemplos

Ejemplo #1 Ejemplo del valor devuelto por MongoCollection::getWriteConcern()

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$coll = $mc->selectCollection('test', 'foo');
var_dump($coll->getWriteConcern());

$coll->setWriteConcern(1, 1000);
var_dump($coll->getWriteConcern());
?>

El resultado del ejemplo sería:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoCollection::setWriteConcern() - Establecer el asunto de escritura para esta base de datos


Lleva a cabo una operación similar al comando GROUP BY de SQL

  • « MongoCollection::getWriteConcern
  • MongoCollection::insert »
  • PHP Manual
  • MongoCollection
  • Lleva a cabo una operación similar al comando GROUP BY de SQL

MongoCollection::group

(PECL mongo >=0.9.2)

MongoCollection::group — Lleva a cabo una operación similar al comando GROUP BY de SQL

Descripción

public MongoCollection::group ( mixed $keys , array $initial , MongoCode $reduce , array $options = array() ) : array

Parámetros

keys

Campos a agrupar. Si se pasa un array o un objeto que no es de código, será la clave usada para agrupar resultados.

1.0.4+: Si keys es una instancia de MongoCode, keys será tratado como una función que devuelve la clave con la que agrupar (revise el ejemplo de abajo sobre "Pasar una función a keys").

initial

Valor inicial del objeto contador de acumulación.

reduce

Una función que toma dos argumentos (el documento actual y la acumulación en este punto) y realiza la acumulación.

options

Parámetros opcionales para el comando group. Las opciones válidas son:

  • "condition"

    Condición para incluir un documento a la acumulación.

  • "finalize"

    Función que se invoca por cada clave única que toma la salida de la función reduce.

  • "maxTimeMS"

    Especifica un tiempo límite acumulativo en milisegundos para procesar la operación en el servdiro (no incluye el tiempo improductivo). Si la operación no la completa el servidor dentro del período de tiempo límite, se lanzará una MongoExecutionTimeoutException.

Valores devueltos

Devuelve un array que contiene el resultado.

Historial de cambios

Versión | Descripción
1.5.0 | Se añadió la opción "maxTimeMS".
1.2.11 | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::group()

Agrupa los documentos por categoría y crea una lista de los nombres que hay dentro de dicha categoría.

<?php

$colección->insert(array("categoria" => "fruta", "nombre" => "manzana"));
$colección->insert(array("categoria" => "fruta", "nombre" => "melocoton"));
$colección->insert(array("categoria" => "fruta", "nombre" => "platano"));
$colección->insert(array("categoria" => "verdura", "nombre" => "maiz"));
$colección->insert(array("categoria" => "verdura", "nombre" => "brocoli"));

$keys = array("categoria" => 1);

$initial = array("items" => array());

$reduce = "function (obj, prev) { prev.items.push(obj.nombre); }";

$g = $colección->group($keys, $initial, $reduce);

echo json_encode($g['retval']);

?>

El resultado del ejemplo sería algo similar a:

[{"categoria":"fruta","items":["manzana","melocoton","platano"]},{"categoria":"verdura","items":["maiz","brocoli"]}]

Ejemplo #2 Ejemplo de MongoCollection::group()

Este ejemplo no utiliza ninguna clave, por lo que cada documento será su propio grupo. Además, usa una condición: sólo los documentos que la cumplan serán procesados por la función de agrupación.

<?php

$colección->save(array("a" => 2));
$colección->save(array("b" => 5));
$colección->save(array("a" => 1));

// usar todos los campos
$claves = array();

// establecer valores iniciales
$inicial = array("count" => 0);

// función JavaScript a realizar
$reduce = "function (obj, prev) { prev.count++; }";

// usar sólo los documentos donde el campo "a" es mayor que 1
$condicion = array('condition' => array("a" => array( '$gt' => 1)));

$g = $colección->group($claves, $inicial, $reduce, $condicion);

var_dump($g);

?>

El resultado del ejemplo sería algo similar a:

array(4) {
  ["retval"]=>
  array(1) {
    [0]=>
    array(1) {
      ["count"]=>
      float(1)
    }
  }
  ["count"]=>
  float(1)
  ["claves"]=>
  int(1)
  ["ok"]=>
  float(1)
}

Ejemplo #3 Pasar una función a keys

Si se desea agrupar por algo distinto a un nombre de campo, se puede pasar una función como primer parámetro de MongoCollection::group(), y así se ejecutará con cada documento. Se usará el valor devuelto de la función como valor de agrupación.

Este ejemplo demuestra cómo agrupar por el campo num módulo 4 (num % 4).

<?php

$c->group(new MongoCode('function(doc) { return {mod : doc.num % 4}; }'),
     array("count" => 0),
     new MongoCode('function(current, total) { total.count++; }'));

?>


Inserta un documento en la colección

  • « MongoCollection::group
  • MongoCollection::parallelCollectionScan »
  • PHP Manual
  • MongoCollection
  • Inserta un documento en la colección

MongoCollection::insert

(PECL mongo >=0.9.0)

MongoCollection::insert — Inserta un documento en la colección

Descripción

public MongoCollection::insert ( array|object $document , array $options = array() ) : bool|array

Todas los string que se envíen a la base de datos deben estar en UTF-8. Si un string no estuviera en UTF-8, se lanzará una MongoException. Para insertar (o consultar) un texto que no esté en UTF-8, utilice MongoBinData.

Parámetros

document

Un array u objeto. Si se utiliza un objeto, este no puede tener propiedades protegidas o privadas.

Nota:

Si el parámetro no posee una clave o propiedad _id, se creará una nueva instancia de MongoId y se le asignará. Este comportamiento especial no implica que el parámetro sea pasado por referencia.

options

Un array de opciones para la operación de inserción. Las opciones disponibles actualmente son:

  • "fsync"

    Booleano, cuyo valor predeterminado es false. Si el registro en el diario está habilitado, funciona exactamente igual que "j". Si no está habilidato, la operación de escriturá bloqueará hasta que se sincronice con los ficheros de la base de datos del disco. Si es true, implica una inserción reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si está habilitada, se recomienda a los usuarios usar la opción "j" en lugar de "fsync". No use "fsync" y "j" simultáneamente, ya que resultará en un error.

  • "j"

    Booleano, cuyo valor predeterminado es false. Fuerza a la operación de escritura a bloquear hasta que sea sincronizada con el diario del disco. Si es true, implica una escritura reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si se usa esta opción y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignoran esta opción.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Devuelve un array que contiene el estado de la inserción si la opción "w" está establecida. De lo contrario, devuelve true si el array insertado no está vacío (se lanzará una MongoException si el array insertado está vacío).

Si devuelve un array, las siguientes claves podrían estar presentes:

ok

Debería ser casi siempre 1 (a menos que last_error falle por sí mismo).

err

Si este campo es diferente de null, un error ocurrido en la operación anterior. Si este campo está establecido, será un string describiendo el error que ocurrió.

code

Si ocurrión un error de base de datos, el código de error relevante será devuelto al cliente.

errmsg

Este campo está establecido si algo va mal con un comando de base de datos. Está asociado con ok igual a 0. Por ejemplo, si se establece w y se agota el tiempo, errmsg será establecido a "timed out waiting for slaves" y ok será 0. Si este campo es establecido, será un string que describe el error ocurrido.

n

Si la última operación fue de inserción, una upsert, o una eliminación, será devuelto el número de objetos afectados. Para operaciones de inserción, este valor siempre es 0.

wtimeout

Si la opción anterior agota el tiempo, esperará a una réplica.

waited

Cuánto esperará la operación antes de agotarse el tiempo.

wtime

Si w fue establecido y la operación tiene éxito, cuánto toma la réplica a los servidores de w.

upserted

Si ocurre una upsert, este campo contendrá el nuevo campo _id del registro. Para upserts, estará presente este campo o updatedExisting (a menos que ocurra un error).

updatedExisting

Si una upsert actualiza un elemento existente, este campo será "true". Para upsert, estará presente este campo o 'upserted' (a menos que ocurra un error).

Errores/Excepciones

Lanza una MongoException si el documento insertado está vacío o si contiene claves de longitud cero. Intentar insertar un objeto con propiedades protegidas o privadas causará un error de clave de longitud cero.

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Historial de cambios

Versión | Descripción
1.5.0

Se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout".

Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout".

Emite un error de nivel E_DEPRECATED al usar "safe".

1.3.4 | Se añadió la opción "wtimeout".
1.3.0

Se añadió la opción "w".

El parámetro options ya no acepta un booleano para indicar una escritura aceptada. En su lugar, ahora esto tiene que realizarse con array('w' => 1) (El comportamiento predeterminado de MongoClient).

1.2.0 | Se añadió el parámetro "timeout".
1.0.11 | Se desconecta en errores "not master" si "safe" está establecido.
1.0.9

Añadida la capacidad de pasar enteros a la opción "safe", la cual anteriormente únicamente aceptaba booleanos.

Añadida la opción "fsync".

Cambiado el tipo devuelto por un array que contiene información si se utiliza la opción "safe". De otro modo, se devuelve un booleano como antes.

1.0.2 | Cambiado el segundo parámetro a un array de opciones. Antes de la versión 1.0.2, el segundo parámetro era un booleano indicando la opción "safe".
1.0.1 | Lanza una MongoCursorException si la opción "safe" está establecida y la inserción falla.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::insert() con _id

Un campo _id será añadido al documento insertado si no estuviera ya presente. Dependiendo de cómo el parámetro sea pasado, estará disponible o no un _id generado para llamar al código.

<?php

$m = new MongoClient();
$colección = $m->selectCollection('test', 'phpmanual');

// Si se usa un array literal, no hay forma de acceder al _id generado
$colección->insert(array('x' => 1));

// El _id está disponible en un array pasado por valor
$a = array('x' => 2);
$colección->insert($a);
var_dump($a);

// El _id no está disponible en un array pasado por referencia
$b = array('x' => 3);
$ref = &$b;
$colección->insert($ref);
var_dump($ref);

// El _id está disponible si una función envolvente no desencadena una copia durante la escritura
function insert_no_cow($colección, $documento)
{
    $colección->insert($documento);
}

$c = array('x' => 4);
insert_no_cow($colección, $c);
var_dump($c);

// El _id no está disponible si una función envolvente desencadena una copia durante la escritura
function insert_cow($colección, $documento)
{
    $documento['y'] = 1;
    $colección->insert($documento);
}

$d = array('x' => 5);
insert_cow($colección, $d);
var_dump($d);

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["x"]=>
  int(2)
  ["_id"]=>
  object(MongoId)#4 (0) {
  }
}
array(1) {
  ["x"]=>
  int(3)
}
array(2) {
  ["x"]=>
  int(4)
  ["_id"]=>
  object(MongoId)#5 (0) {
  }
}
array(1) {
  ["x"]=>
  int(5)
}

Ejemplo #2 Ejemplo de escritura aceptada con MongoCollection::insert()

Este ejemplo muestra cómo al insertar dos elementos con el mismo _id, se provoca que se lance una excepción MongoCursorException, ya que w está habilitado.

<?php

$persona = array("nombre" => "Joe", "edad" => 20);
$colección->insert($persona);

// ahora $persona tiene un campo _id, así que si intentamos guardarlo
// de nuevo, obtendremos una excepción
try {
    $collection->insert($persona, array("w" => 1));
} catch(MongoCursorException $e) {
    echo "No se puede guardar dos veces la misma persona!\n";
}

?>

Ver también

  • MongoCollection::batchInsert() - Inserta múltiples documentos en esta colección
  • MongoCollection::update() - Actualizar registros basándose en los criterios proporcionados
  • MongoCollection::find() - Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados
  • MongoCollection::remove() - Eliminar registros de esta colección
  • Documentación de MongoDB sobre » insert.


Devuelve un array con cursores para recorrer una colección completa en paralelo

  • « MongoCollection::insert
  • MongoCollection::remove »
  • PHP Manual
  • MongoCollection
  • Devuelve un array con cursores para recorrer una colección completa en paralelo

MongoCollection::parallelCollectionScan

(PECL mongo >=1.5.0)

MongoCollection::parallelCollectionScan — Devuelve un array con cursores para recorrer una colección completa en paralelo

Descripción

public MongoCollection::parallelCollectionScan ( int $num_cursors ) : array[MongoCommandCursor]

Este método devuelve un array con un número máximo de num_cursors cursores. Recorrer uno de los cursores devueltos iterará en un conjunto parcial de documentos de una colección. Recorrer todos los cursores devueltos resultará en la obtención de cada documento de la colección.

Este método es una envoltura para el comando parallelCollectionScan de MongoDB.

Parámetros

num_cursors

El número de cursores a solicitar al servidor. Observe que el servidor puede devolver menos cursores que los solicitados.

Valores devueltos

Devuelve un array de objetos MongoCommandCursor.

Ejemplos

Ejemplo #1 Ejmplo de MongoCollection::parallelCollectionScan()

Devolver todos los documentos de una colección empleando varios cursores.

<?php
$m = new MongoClient;
$c = $m->demo->cities;

/* Solicitar tres cursores */
$cursores = $c->parallelCollectionScan( 3 );

/* Añadir todos los cursores a MultipleIterator */
$mi = new MultipleIterator( MultipleIterator::MIT_NEED_ANY );
foreach ( $cursores as $cursor )
{
    $mi->attachIterator( $cursor );
}

/* Recorrer todos los cursores asociados */
foreach ( $mi as $items )
{
    foreach ( $items as $item )
    {
        if ( $item !== NULL )
        {
            echo $item['name'], "\n";
        }
    }
}
?>

Ver también

  • MultipleIterator
  • MongoCommandCursor
  • MongoDB::command() - Ejecuta una orden de base de datos


Eliminar registros de esta colección

  • « MongoCollection::parallelCollectionScan
  • MongoCollection::save »
  • PHP Manual
  • MongoCollection
  • Eliminar registros de esta colección

MongoCollection::remove

(PECL mongo >=0.9.0)

MongoCollection::remove — Eliminar registros de esta colección

Descripción

public MongoCollection::remove
 ( array $criteria = array()
, array $options = array()
) : bool|array

Parámetros

criteria

Criterios de consulta para los documentos a borrar.

options

Un array de opciones para la operación de eliminación. Las opciones actualmente disponibles son:

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "justOne"

    Especificar true para limitar la eliminación a sólo un documento. Si es false o se omite, se borrarán todos los documentos que coincidan con los criterios.

  • "fsync"

    Booleano, cuyo valor predeterminado es false. Si el registro en el diario está habilitado, funciona exactamente igual que "j". Si no está habilidato, la operación de escriturá bloqueará hasta que se sincronice con los ficheros de la base de datos del disco. Si es true, implica una inserción reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si está habilitada, se recomienda a los usuarios usar la opción "j" en lugar de "fsync". No use "fsync" y "j" simultáneamente, ya que resultará en un error.

  • "j"

    Booleano, cuyo valor predeterminado es false. Fuerza a la operación de escritura a bloquear hasta que sea sincronizada con el diario del disco. Si es true, implica una escritura reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si se usa esta opción y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignoran esta opción.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Devuelve un array que contiene el estado de la eliminación si está establecida la opción "w". De lo contrario, devuelve true.

Los campos del array de estado están descritros en la documentación de MongoCollection::insert().

Errores/Excepciones

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Historial de cambios

Versión | Descripción
1.5.0

se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout".

Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout".

Emite un error de nivel E_DEPRECATED al usar "safe".

1.3.4 | Se añadió la opción "wtimeout".
1.3.0

Se añadió la opción "w".

El parámetro options ya no acepta un valor booleano que indique "justOne". En su lugar, ahora se debe hacer con array('justOne' => true).

1.2.11 | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.
1.2.0 | Se añadió la opción "timeout".
1.0.11 | Se desconcecta cuando ocurren errores "not master" si "safe" está establecido.
1.0.9

Se añadió la capacidad de pasar números enteros a la opción "safe", la cual anteriomente sólo aceptaba valores booleanos.

Se añadío la opción "fsync".

Es tipo devuelto se cambio para que fuera un array que contuviera la información del error si se usaba la opción "safe". De otro modo, se devolvía un valor booleano como antes.

1.0.5 | Cambiado el segundo parámetro a un array de opciones. Antes de 1.0.5, el segundo parámetro era un booleano indicando la opción "safe".

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::remove() con justOne

<?php

$radioactivo = $db->radioactivo;

// contar cuánto plution queda
$restante = $radioactivo->count(array('type' => 94));

$vidamedia = $restante/2;

// eliminar la mitad
while ($vidamedia > 0) {
    $radioactivo->remove(array('type' => 94), array("justOne" => true));
    $vidamedia--;
}

?>

Ver también

  • MongoCollection::insert() - Inserta un documento en la colección
  • MongoCollection::update() - Actualizar registros basándose en los criterios proporcionados
  • Documentación de MongoDB sobre » remove.


Guarda un documento en esta colección

  • « MongoCollection::remove
  • MongoCollection::setReadPreference »
  • PHP Manual
  • MongoCollection
  • Guarda un documento en esta colección

MongoCollection::save

(PECL mongo >=0.9.0)

MongoCollection::save — Guarda un documento en esta colección

Descripción

public MongoCollection::save ( array|object $document , array $options = array() ) : mixed

Si el objeto fuera de la base de datos, se actualizará. En caso contrario, se insertará.

Parámetros

document

Array u objeto a guardar. Si se usa un objeto, este no puede tener propiedades protegidas o privadas.

Nota:

Si el parámetro no posee una clave o propiedad _id, se creará una nueva instancia de MongoId y se le asignará. Véase MongoCollection::insert() para información adicional sobre este comportamiento.

options

Opciones para el guardado.

  • "fsync"

    Booleano, cuyo valor predeterminado es false. Si el registro en el diario está habilitado, funciona exactamente igual que "j". Si no está habilidato, la operación de escriturá bloqueará hasta que se sincronice con los ficheros de la base de datos del disco. Si es true, implica una inserción reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si está habilitada, se recomienda a los usuarios usar la opción "j" en lugar de "fsync". No use "fsync" y "j" simultáneamente, ya que resultará en un error.

  • "j"

    Booleano, cuyo valor predeterminado es false. Fuerza a la operación de escritura a bloquear hasta que sea sincronizada con el diario del disco. Si es true, implica una escritura reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si se usa esta opción y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignoran esta opción.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

Valores devueltos

Si w estuviera habilitado, devolverá un array que contiene el estado de la escritura. En cualquier otro caso, devuelve un booleano que representa si el array no estaba vacío (un array vacío no se insertará).

Errores/Excepciones

Lanza una MongoException si el documento insertado está vacío o si contiene claves de longitud cero. Intentar insertar un objeto con propiedades protegidas o privadas causará un error de clave de longitud cero.

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Historial de cambios

Versión | Descripción
1.5.0

Se añadió la opción "wTimeoutMS", la cual reemplaza a "wtimeout". Emite un error E_DEPRECATED al utilizar "wtimeout".

Se añadió la opción "socketTimeoutMS", la cual reemplaza a "timeout". Emite un error E_DEPRECATED al utilizar "wtimeout".

Emite un error E_DEPRECATED al utilizar "safe".

1.2.0 | Añadida la opción "timeout".
1.0.11 | Se desconecta en errores "not master" si "safe" está establecido.
1.0.9

Añadida la opción "fsync".

1.0.5 | Añadido el parámetro options.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::save()

<?php

$obj = array('x' => 1);

// insertar $obj en la base de datos
$collection->save($obj);
var_dump($obj);

// añadir otro campo
$obj['foo'] = 'bar';

// $obj no puede insertarse de nuevo; provoca un error de _id duplicado
$collection->insert($obj);

// la función save actualiza $obj con el nuevo campo
$collection->save($obj);

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["x"]=>
  int(1)
  ["_id"]=>
  object(MongoId)#4 (1) {
    ["$id"]=>
    string(24) "50b6afe544415ed606000000"
  }
}


Establecer la preferencia de lectura para esta colección

  • « MongoCollection::save
  • MongoCollection::setSlaveOkay »
  • PHP Manual
  • MongoCollection
  • Establecer la preferencia de lectura para esta colección

MongoCollection::setReadPreference

(PECL mongo >=1.3.0)

MongoCollection::setReadPreference — Establecer la preferencia de lectura para esta colección

Descripción

public MongoCollection::setReadPreference ( string $read_preference , array $tags = ? ) : bool

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ejemplos

Ejemplo #1 Ejemplo de sintaxis de array de conjunto de etiquetas con MongoCollection::setReadPreference()

<?php

$m = new MongoClient();
$c = $m->test->users;

// Preferir el servidor más cercano del centro de datos "east" también usado para notificación,
// pero recurrir a un servidor del centro de datos "west"
$c->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ver también

  • La documentación de preferencias de lectura.
  • MongoCollection::getReadPreference() - Obtener la preferencia de lectura psrs esta colección


Cambia el valor de slaveOkay de esta colección

  • « MongoCollection::setReadPreference
  • MongoCollection::setWriteConcern »
  • PHP Manual
  • MongoCollection
  • Cambia el valor de slaveOkay de esta colección

MongoCollection::setSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::setSlaveOkay — Cambia el valor de slaveOkay de esta colección

Descripción

public MongoCollection::setSlaveOkay ( bool $ok = true ) : bool

Revise la sección de consultas de este manual para más información sobre distribución de lecturas a secundarios.

Parámetros

ok

Indica si las lecturas deben enviarse a miembros secundarios del conjunto de réplicas para todas las posibles consultas que utilicen esta instancia de MongoCollection.

Valores devueltos

Devuelve el valor anterior de slaveOkay de esta instancia.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoCollection::setReadPreference() - Establecer la preferencia de lectura para esta colección


Establecer el asunto de escritura para esta base de datos

  • « MongoCollection::setSlaveOkay
  • MongoCollection::toIndexString »
  • PHP Manual
  • MongoCollection
  • Establecer el asunto de escritura para esta base de datos

MongoCollection::setWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::setWriteConcern — Establecer el asunto de escritura para esta base de datos

Descripción

public MongoCollection::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

Parámetros

w

El asunto de escritura. Podría ser un valor de tipo integer denotando el número de servidores requeridos para reconocer la escritura, o un string con el modo (p.ej. "majority").

wtimeout

El número máximo de milisegundos que tienen que esperar es servidor para satisfacer el asunto de escritura.

Valores devueltos

Devuelve true en caso de éxito, o false en caso contrario.

Errores/Excepciones

Emite un E_WARNING si el parámetro w no es un valor de tipo integer o string.

Ejemplos

Ejemplo #1 Ejemplo de MongoDB::setWriteConcern()

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$coll = $mc->selectCollection('test', 'foo');

// Requiere que la mayoría de los servidores en el conjunto de réplica reconozcan escrituras
// en un intervalo de tiempo de tres segundos.
$coll->setWriteConcern('majority', 3000);
?>

Ver también

  • La documentación sobre asuntos de escritura.
  • MongoCollection::getWriteConcern() - Obtener el asunto de escritura para esta colección


Convierte claves especificando un índice para su string de identificación

  • « MongoCollection::setWriteConcern
  • MongoCollection::__toString »
  • PHP Manual
  • MongoCollection
  • Convierte claves especificando un índice para su string de identificación

MongoCollection::toIndexString

(PECL mongo >=0.9.0)

MongoCollection::toIndexString — Convierte claves especificando un índice para su string de identificación

Descripción

static protected MongoCollection::toIndexString ( mixed $keys ) : string
Advertencia

Este método está obsoleto desde la versión 1.5.0.

Parámetros

keys

Campo/s a convertir al string de identificación

Valores devueltos

Devuelve un string que describe el índice.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::toIndexString()

Este ejemplo muestra cómo se puede crear un nombre de índice de claves. Debido a que este es un método protegido (estático), es necesario sobrecargarlo primero en una clase hija.

<?php
// Crear una clase heredada para hacer el método "public".
class MiColección extends MongoCollection
{
    static public function toIndexString($a)
    {
        return parent::toIndexString($a);
    }
}

echo MyCollection::toIndexString("foo"), "\n";
// Imprime: foo_1

echo MiColección::toIndexString(array('name' => 1, 'age' => -1)), "\n";
// Imprime: name_1_age_-1
?>

Ver también

La documentación de MongoDB sobre » índices.

Historial de cambios

Versión | Descripción
1.5.0 | Este método está obsoleto.


Representación en forma de string de esta colección

  • « MongoCollection::toIndexString
  • MongoCollection::update »
  • PHP Manual
  • MongoCollection
  • Representación en forma de string de esta colección

MongoCollection::__toString

(PECL mongo >=0.9.0)

MongoCollection::__toString — Representación en forma de string de esta colección

Descripción

public MongoCollection::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre completo de esta colección.

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::__toString()

<?php

$m = new MongoClient();

$c1 = $m->foo->bar->baz;
echo "Trabajando con la colección $c1.";

$c2 = $m->selectCollection('[]', '&');
echo "Trabajando con la colección $c2.";

?>

El resultado del ejemplo sería algo similar a:

Trabajando con la colección foo.bar.baz.
Trabajando con la colección [].&.


Actualizar registros basándose en los criterios proporcionados

  • « MongoCollection::__toString
  • MongoCollection::validate »
  • PHP Manual
  • MongoCollection
  • Actualizar registros basándose en los criterios proporcionados

MongoCollection::update

(PECL mongo >=0.9.0)

MongoCollection::update — Actualizar registros basándose en los criterios proporcionados

Descripción

public MongoCollection::update ( array $criteria , array $new_object , array $options = array() ) : bool|array

Parámetros

criteria

Criterios de consulta para los documentos a actualizar.

new_object

El objeto usado para actualizar los documentos coincidentes. Podría contener operadores de actualización (para modificar campos específicos) o ser un documento de remplazo.

options

Un array de opciones para la operación de actualización. Las opciones disponibles actualmente son:

  • "upsert"

    Si ningún documento cumple las condiciones de $criteria, se insertará un nuevo documento.

    Si se insertara un nuevo documento y $new_object contiene modificadores atómicos (esto es, operadores $), esas operaciones serán aplicadas al parámetro $criteria para crear el nuevo documento. Si $new_object no contiene modificadores atómicos, será utilizado tal cual para el documento insterdo. Véase los ejemplos de upsert abajo para más información.

  • "multiple"

    Todos los documentos que cumplan las condiciones de $criteria se actualizarán. MongoCollection::update() tiene exactamente el comportamiento contrario que MongoCollection::remove(): de forma predeterminada, actualiza sólo un documento, no todos los que cumplan las condiciones. Se recomienda especificar siempre se si deben actualizar múltiples documentos o un único documento, ya que el comportamiento predeterminado de la base de datos podría cambiar en el futuro.

  • "fsync"

    Booleano, cuyo valor predeterminado es false. Si el registro en el diario está habilitado, funciona exactamente igual que "j". Si no está habilidato, la operación de escriturá bloqueará hasta que se sincronice con los ficheros de la base de datos del disco. Si es true, implica una inserción reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si está habilitada, se recomienda a los usuarios usar la opción "j" en lugar de "fsync". No use "fsync" y "j" simultáneamente, ya que resultará en un error.

  • "j"

    Booleano, cuyo valor predeterminado es false. Fuerza a la operación de escritura a bloquear hasta que sea sincronizada con el diario del disco. Si es true, implica una escritura reconocida y sobrescribirá el ajuste "w" a 0.

    Nota: Si se usa esta opción y el registro en el diario está deshabilitado, MongoDB 2.6+ emitirá un error y la escritura fallará; las versiones más antiguas del servidor simplemente ignoran esta opción.

  • "socketTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para las comunicaciones con socket. Si el servidor no responde en el periodo especificado, se lanzará una MongoCursorTimeoutException y no habrá forma de determinar si el servidor manejó realmente la escritura o no. Se podría especificar un valor de -1 para bloquear indefinidamente. El valor predeterminado para MongoClient es 30000 (30 segundos).

  • "w"

    Véase WriteConcerns. El valor predeterminado de MongoClient es 1.

  • "wTimeoutMS"

    Esta opción especifica el tiempo límite, en milisegundos, para el reconocimiento de un asunto de escritura. Solamente es aplicable cuando "w" sea mayor que 1, ya que el tiempo de espera está relacionado con la replecación. Si el asunto de escritura no se satisface dentro del tiempo límite, se lanzará una MongoCursorException. Se puede especificar un valor de 0 para bloquear indefinidamente. El valor predeterminado es 10000 (diez segundos).

Las siguientes opciones están obsoletas y no deberían usarse más:

  • "safe"

    Obsoleto. Use la opción w de los asuntos de escritura.

  • "timeout"

    Alias obsoleto de "socketTimeoutMS".

  • "wtimeout"

    Alias obsoleto de "wTimeoutMS".

Valores devueltos

Devuelve un array que contiene el estado de la actualización si la opción "w" está establecida. De lo contrario, devuelve true.

Los campos del array de estado están descritos en la documentación para MongoCollection::insert().

Errores/Excepciones

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.

Historial de cambios

Versión | Descripción
1.5.0

se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout".

Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout".

Emite un error de nivel E_DEPRECATED al usar "safe".

1.3.4 | Se añadió la opción "wtimeout".
1.3.0

Se añadió la opción "w".

El parámetro options ya no acepta un valor booleano para indicar un 'upsert'. En su lugar, esto ahora se tiene que hacer con array('upsert' => true).

1.2.11 | Emite E_DEPRECATED cuando options es de tipo scalar.
1.2.0 | Se añadió la opción "timeout".
1.0.11 | Se desconecta en errores "not master" si "safe" está establecido.
1.0.9

Añadida la capacidad de pasar enteros a la opción "safe", la cual anteriormente únicamente aceptaba booleanos.

Añadida la opción "fsync".

Cambiado el tipo devuelto por un array que contiene información si se utiliza la opción "safe". De otro modo, se devuelve un booleano como antes.

1.0.5 | Se añadió la opción "safe".
1.0.1 | Cambiado el parámetro "opciones" de un booleano a un array. Antes de la versión 1.0.1, el segundo parámetro era valor booleano opcional especificando un upsert.

Ejemplos

Ejemplo #1 MongoCollection::update()

Añadiendo el campo dirección a un documento

<?php

$c->insert(array("nombre" => "Pedro", "apellido" => "Ruiz" ));
$nuevosdatos = array('$set' => array("direccion" => "Calle Juan, 1"));
$c->update(array("nombre" => "Pedro"), $nuevosdatos);

var_dump($c->findOne(array("nombre" => "Pedro")));

?>

El resultado del ejemplo sería algo similar a:

array(4) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["nombre"]=>
  string(3) "Pedro"
  ["apellido"]=>
  string(5) "Ruiz"
  ["direccion"]=>
  string(12) "Calle Juan, 1"
}

Ejemplo #2 Ejemplos de MongoCollection::update() con upsert

Los upserts pueden simplificar el código, ya que con una única línea se puede crear el documento si no existe (basado en $criteria), o actualizar un documento existente si coincide.

En el siguiente ejemplo, $new_object contiene un modificador atómico. Ya que la colección está vacía y upsert debe insertar un nuevo documento, aplicará esas operaciones al parámetro $criteria para crear el documento.

<?php

$c->drop();
$c->update(
    array("uri" => "/summer_pics"),
    array('$inc' => array("page hits" => 1)),
    array("upsert" => true)
);
var_dump($c->findOne());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["_id"]=>
  object(MongoId)#9 (0) {
  }
  ["uri"]=>
  string(12) "/fotos_verano"
  ["accesos"]=>
  int(1)
}

Si $new_object no contiene modificadores atómicos (esto es, operadores $), upsert utilizará $new_object tal cual para el nuevo documento. Esto coincide con el comportamiento de una actualización normal, donde la no utilización de modificadores atómicos ocasiona la sobrescritura del documento.

<?php

$c->drop();
$c->update(
    array("name" => "joe"),
    array("username" => "joe312", "createdAt" => new MongoDate()),
    array("upsert" => true)
);
var_dump($c->findOne());

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["_id"]=>
  object(MongoId)#10 (0) {
  }
  ["usuario"]=>
  string(6) "juan312"
  ["fechaAlta"]=>
  object(MongoDate)#4 (0) {
  }
}

Ejemplo #3 Ejemplo de múltiples MongoCollection::update()

De forma predeterminada, MongoCollection::update() sólo actualizará el primer documento que encuentre que cumpla las condiciones de $criteria. Si fuera necesario, mediante la opción "multiple" podremos sobrescribir este comportamiento.

Este ejemplo añade un campo "regalo" a cada persona cuyo cumpleaños sea el próximo día.

<?php

$today = array('$gt' => new MongoDate(), '$lt' => new MongoDate(strtotime("+1 day")));
$people->update(
    array("birthday" => $today),
    array('$set' => array('gift' => $surprise)),
    array("multiple" => true)
);

?>

Ver también

La documentación de PHP sobre actualizaciones y la » documentacion en MongoDB.


Valida esta colección

  • « MongoCollection::update
  • MongoCursor »
  • PHP Manual
  • MongoCollection
  • Valida esta colección

MongoCollection::validate

(PECL mongo >=0.9.0)

MongoCollection::validate — Valida esta colección

Descripción

public MongoCollection::validate ( bool $scan_data = false ) : array

Parámetros

scan_data

Sólo valida los índices, no la colección base.

Valores devueltos

Devuelve la evaluación de la base de datos de este objeto.


La clase MongoCursor

(PECL mongo >=0.9.0)

Introducción

Un cursor se utiliza parar recorrer el resultado de una consulta a la base de datos. Por ejemplo, para consultar la base de datos y revisar los resultados, se podría hacer lo siguiente:

Ejemplo #1 Uso básico de MongoCursor

<?php

$cursor = $collection->find();
var_dump(iterator_to_array($cursor));

?>

Por norma general, los cursores no se crean utilizando el constructor MongoCursor, ya que se obtienen al invicar a MongoCollection::find() (como en el ejemplo superior).

Supóngase que, en el ejemplo superior, $collection fuera una colección de 50GB. No quisiéramos tener que alojar en memoria todo de una vez, y esto es lo que solucionan los cursores: permiten al cliente acceder a la colección gota a gota.

Si tuviéramos un resultado extenso, podríamos recorrerlo cargando unos pocos megabytes a memoria cada vez. Por ejemplo:

Ejemplo #2 Iterar sobre MongoCursor

<?php

$cursor = $collection->find();

foreach ($cursor as $doc) {
    // hacer algo a cada documento
}

?>
Esto recorrerá cada documento de la colección, cargando y eliminando de memoria cada documento según se necesite.

Debe tenerse en cuenta que esto significa que un cursor no "contiene" el resultado de la base de datos, sino que sólo lo gestiona. Por tanto, si se imprimiera un cursor (con, digamos, var_dump() o print_r()), sólo se obtendría el propio objeto cursor, sin los documentos. Para obtener los documentos en sí, debe utilizarse alguno de los métodos vistos arriba.

Estados de un Cursor

Un MongoCursor tiene dos estados: pre y post consulta. Al crear un cursor, éste no se conecta a la base de datos, por lo que está en estado pre-consulta. En este estado, el cliente puede indicar qué quiere consultar, definiendo límites, saltos, ordenaciones y más opciones avanzadas.

Cuando el cliente solicita el resultado (invocando MongoCursor::next(), directa o indirectamente), el cursor avanza al estado post-consulta. En este punto, la consulta ya se ha ejecutado por la base de datos y ya no se puede modificar.

Ejemplo #3 Añadir opciones a MongoCursor

<?php

$cursor = $collection->find()->limit(10);

// todavía no se ha consultado la base de datos, de modo que se pueden añadir más opciones
$cursor = $cursor->sort(array("a" => 1));

var_dump($cursor->getNext());
// ya se ha consultado la base de datos, y no se pueden añadir más opciones

// por lo que esto lanzaría una excepción:
$cursor->skip(4);
?>

Sinopsis de la Clase

MongoCursor implements MongoCursorInterface , Iterator {
/* Campos Estáticos */
static boolean $slaveOkay = false ;
static integer $timeout = 30000 ;
/* Métodos */
public addOption ( string $key , mixed $value ) : MongoCursor
public awaitData ( bool $wait = true ) : MongoCursor
public batchSize ( int $batchSize ) : MongoCursor
public __construct ( MongoClient $connection , string $ns , array $query = array() , array $fields = array() )
public count ( bool $foundOnly = false ) : int
public current ( ) : array
public dead ( ) : bool
protected doQuery ( ) : void
public explain ( ) : array
public fields ( array $f ) : MongoCursor
public getNext ( ) : array
public getReadPreference ( ) : array
public hasNext ( ) : bool
public hint ( mixed $index ) : MongoCursor
public immortal ( bool $liveForever = true ) : MongoCursor
public info ( ) : array
public key ( ) : string|int
public limit ( int $num ) : MongoCursor
public maxTimeMS ( int $ms ) : MongoCursor
public next ( ) : array
public partial ( bool $okay = true ) : MongoCursor
public reset ( ) : void
public rewind ( ) : void
public setFlag ( int $flag , bool $set = true ) : MongoCursor
public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursor
public skip ( int $num ) : MongoCursor
public slaveOkay ( bool $okay = true ) : MongoCursor
public snapshot ( ) : MongoCursor
public sort ( array $fields ) : MongoCursor
public tailable ( bool $tail = true ) : MongoCursor
public timeout ( int $ms ) : MongoCursor
public valid ( ) : bool
}

Variables Estáticas

slaveOkay

Si la consulta debe o no tener asignada la bandera "slaveOkay", la cual permite leer el secundario (por omisión, los secundarios son para hacer copias de seguridad, no consultas). Puede sobrescribirse con MongoCursor::slaveOkay().

Esta funcionalidad es obsoleta. Por favor, use Preferencias de lectura en su lugar.

timeout

Establecer el tiempo de espera en milisegundos para las respuestas de todas las bases de datos. Use -1 para esperar eternamente. Se puede sobcrescribir con MongoCursor::timeout(). Esto no hace que el servidor de MongoDB cancele la operación; sólo hace que el controlador deje de esperar una respuesta y lanza una MongoCursorTimeoutException después de un tiempo establecido.

Ver también

Documentación de MongoDB sobre » cursores.

Tabla de contenidos

  • MongoCursor::addOption — Añade un par clave/valor de alto nivel a una consulta
  • MongoCursor::awaitData — Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos
  • MongoCursor::batchSize — Limita el número de elementos devueltos en un lote
  • MongoCursor::__construct — Crea un nuevo cursor
  • MongoCursor::count — Cuenta el número de resultados de esta consulta
  • MongoCursor::current — Devuelve el elemento actual
  • MongoCursor::dead — Comprueba si hay resultados que no han sido enviados aún de la base de datos
  • MongoCursor::doQuery — Ejecutar un sentencia
  • MongoCursor::explain — Devuelve una explicación de la consulta, útil para la optimización y depuración
  • MongoCursor::fields — Establece los campos para una consulta
  • MongoCursor::getNext — Avanza el cursor al siguiente resultado y devuelve dicho resultado
  • MongoCursor::getReadPreference — Obtener la preferencia de lectura para esta consulta
  • MongoCursor::hasNext — Comprueba si existe algún elemento más en este cursor
  • MongoCursor::hint — Da a la base de datos un indicio sobre la consulta
  • MongoCursor::immortal — Establece si este cursor expirará
  • MongoCursor::info — Obtiene la información sobre la creación e iteración del cursor
  • MongoCursor::key — Devuelve el _id del resultado actual, o su índice dentro del conjunto de resultados
  • MongoCursor::limit — Limita el número de resultados devueltos
  • MongoCursor::maxTimeMS — Establece un tiempo límite en el lado del cliente para esta consulta
  • MongoCursor::next — Avanza el cursor al siguiente resultado, y devuelve dicho resultado
  • MongoCursor::partial — Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído
  • MongoCursor::reset — Limpia el cursor
  • MongoCursor::rewind — Devuelve el cursor al inicio del conjunto de resultados
  • MongoCursor::setFlag — Establece banderas arbitrarias en caso de que no haya métodos disponibles para una bandera específica
  • MongoCursor::setReadPreference — Establece la preferencia de lectura para esta consulta
  • MongoCursor::skip — Omite un número de resultados
  • MongoCursor::slaveOkay — Establece si esta consulta puede realizarse en un secundario [obsoleto]
  • MongoCursor::snapshot — Usar el modo 'snapshot' para la consulta
  • MongoCursor::sort — Ordena los resultados por el campo que se indique
  • MongoCursor::tailable — Establece si este cursor se dejará abierto después de obtener los últimos resultados
  • MongoCursor::timeout — Establece un tiempo de espera en el lado del cliente para esta consulta
  • MongoCursor::valid — Comprueba si el cursor está leyendo un resultado válido


Añade un par clave/valor de alto nivel a una consulta

  • « MongoCursor
  • MongoCursor::awaitData »
  • PHP Manual
  • MongoCursor
  • Añade un par clave/valor de alto nivel a una consulta

MongoCursor::addOption

(PECL mongo >=1.0.4)

MongoCursor::addOption — Añade un par clave/valor de alto nivel a una consulta

Descripción

public MongoCursor::addOption ( string $key , mixed $value ) : MongoCursor

Esta es una función avanzada y no debería usarse a menos que se sepa lo que se está haciendo.

Una consulta puede ser opcionalmente anidada en un campo "query" si se proporcionan otras opciones, como una ordenación o sugerencia. Por ejemplo, añadir una ordenación ocasiona que la consulta se convierta en un subcampo de un objeto de consulta mayor, como:

<?php

$query = array("query" => $query, "orderby" => $sort);

?>

Este método se usa para añadir un campo de alto nivel a una consulta. Hace que la consulta sea subobjeto (si ya no lo fuera) y añade el par clave/valor elegido al nivel más alto.

Advertencia

No se puede usar para añadir criterios extra a una consulta al vuelo. Por ejemplo, esto no funcionará:

<?php

// INCORRECTO
$cursor = $users->find()->addOption("name", "joe")->addOption("age", 20);

?>
Esto no consultará por un ususario llamado "joe" de 20 años.

Parámetros

key

El nombre del campo a añadir.

value

El valor a añadir.

Valores devueltos

Returns this cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ejemplos

Ejemplo #1 Ejemplo para añadir un comentario con MongoCursor::addOption()

MongoDB admite el envío de opciones especiales al servidor. El shell utiliza la opción _addSpecial para enviar un comentario dado por $comment al servidor. Este comentario aparecerá en el registro de perfiles (para consultas lentas, p.ej.). En el controlador de PHP, se utilizar el método MongoCursor::addOption().

<?php
$m = new MongoClient;
$c = $m->demo->demo;
$cursor = $c->find();
$cursor->addOption('$comment', "Este comentario se mostrará en el registro de perfiles");

foreach ($cursor as $documento) { /* vacío */ }
?>

El resultado del ejemplo sería algo similar a:

{
    "op" : "query",
    "ns" : "demo.demo",
    "query" : {
        "$query" : {

        },
        "$comment" : "Este comentario se mostrará en el registro de perfiles"
    },
    "cursorid" : 168463566447,
    "ntoreturn" : 0,
    "ntoskip" : 0,
    "nscanned" : 101,
    "nscannedObjects" : 101,
    "keyUpdates" : 0,
    "numYield" : 0,
…

Ejemplo #2 Ejemplo de MongoCursor::addOption()

El uso de MongoCursor::skip() para omitir millones de resultados puede ser lento. Un atajo para esto es usar las opciones $min o $max para la consulta. Pueden ser útiles, pero requieren un índice exactamente en los campos que van a ser buscados. Este es un ejemplo de cómo usar $min como alternativa a MongoCursor::skip().

<?php

// asegurarse de tener un índice
$c->ensureIndex(array("ts" => 1));

// podría ser necesario modificar esto para ejecutarlo en un tiempo razonable en
// máquinas lentas (debería tomar unos 30 segundos en una buena máquina)
for ($i = 0; $i < 30000000; $i++) {
    $c->insert(array("ts" => new MongoDate(), "i" => $i));
}

$ahora = strtotime("now");

// buscar documentos insertados en los últimos 2 segundos
$cursor = $c->find()->addOption('$min', array("ts" => $ahora-2));

?>


Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos

  • « MongoCursor::addOption
  • MongoCursor::batchSize »
  • PHP Manual
  • MongoCursor
  • Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos

MongoCursor::awaitData

(PECL mongo >=1.2.11)

MongoCursor::awaitData — Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos

Descripción

public MongoCursor::awaitData ( bool $wait = true ) : MongoCursor

Este método se usa con cursores de seguimiento. Si se está al final de los datos, se bloquea un momento en lugar de no devolver datos. Después de un tiempo de espera, se devuelve de la manera normal.

Parámetros

wait

Si el cursor debería esperar a que estén disponibles más datos.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::awaitData()

En este ejemplo, le seguimos la pista a "oplog" y, en lugar de dormir durante cada iteración, se establece la opción MongoCursor::awaitData(). MongoCursor::hasNext() ahora bloqueará hasta que haya más datos disponibles.

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->tailable( true );
$cursor->awaitData( true );

while (true) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
    } else {
        var_dump( $cursor->getNext() );
    }
}
?>

Ver también

La documentación principal de MongoDB sobre » cursores de seguimiento.

  • MongoCursor::tailable() - Establece si este cursor se dejará abierto después de obtener los últimos resultados


Limita el número de elementos devueltos en un lote

  • « MongoCursor::awaitData
  • MongoCursor::__construct »
  • PHP Manual
  • MongoCursor
  • Limita el número de elementos devueltos en un lote

MongoCursor::batchSize

(PECL mongo >=1.0.11)

MongoCursor::batchSize — Limita el número de elementos devueltos en un lote

Descripción

public MongoCursor::batchSize ( int $batchSize ) : MongoCursor

Un cursor normalmente obtiene un lote de objetos de resultados y los almacena localmente. Este método establece el valor de batchSize para configurar la cantidad de documentos obtenidos desde el servidor en viaje de ida y vuelta. Sin embargo, nunca devolverá más documentos que los que no sobrepasen el límite del tamaño del lote (normalmente 4 MB).

Parámetros

batchSize

El número de resultados a devolver por lote. Cada lote requiere un viaje de ida y vuelta al servidor.

Si batchSize is 2 o más, representa el tamaño de cada lote de objetos recuperados. Se puede ajustar para optimizar el rendimiento y limitar la transferencia de datos.

Si batchSize es 1 o negativo, limitará el número de documentos devueltos al valor absoluto de batchSize, y el cursor se cerrará. Por ejemplo, si batchSize es -10, el servidor devolverá un máximo de 10 documentos siempre que quepan en 4 MB; luego cerrará el cursor.

Advertencia

Un batchSize de 1 es especial, y significa lo mismo que -1, esto es, un valor de 1 hace que el cursor solamente devuelva un documento.

Observe que esta característica se diferencia de MongoCursor::limit() en que los documentos deben ajustarse dentro de un tamaño máximo, por lo que elimina la necesidad de enviar una petición para cerrar el cursor en el lado del servidor. El tamaño del lote se puede cambiar incluso después de que un cursor sea iterado, en cuyo caso el ajuste se aplicará solamente a la obtención del siguiente lote.

Esto no anula al límite de MongoDB de la cantidad de datos que serán devueltos al cliente (esto es, si se establece el tamaño del lote a 1,000,000,000, MongoDB todavía devolverá 4-16 MB de resultados por lote).

Para asegurarse de un comportamiento consistente, las reglas de MongoCursor::batchSize() y MongoCursor::limit() son un poco complejas, aunque funcionan "como se esperaba". Las reglas son: los límites fuertes anulan a los ligeros, con preferencia dada a MongoCursor::limit() sobre MongoCursor::batchSize(). Después, lo que sea establecido y sea menor que el otro, tomará precedencia. Véase la sección de abajo para algunos ejemplos.

Valores devueltos

Returns this cursor.

Ejemplos

Ejemplo #1 MongoCursor::batchSize() y combinaciones con MongoCursor::limit()

<?php

// un lote, como mucho 10 elementos. -10 hace que el servidor devuelva 10 elementos,
// y luego elimine el cursor.
$cursor->limit(20)->batchSize(-10);

// primer lote: como mucho 10 elementos
$cursor->limit(10);

// primer lote: como mucho 10 elementos
$cursor->limit(10)->batchSize(20);

// los resultados se obtienen en lotes de 10, con un máximo de 20 elementos
// devueltos (lo que significa dos lotes de 10).
$cursor->limit(20)->batchSize(10);

// los resultados se obtienen en lotes de 7, con un máximo de 30 elementos
// devueltos (lo que significa que el controlador solicita 4 lotes de 7, y
// un lote de 2).
$cursor->limit(30)->batchSize(7)
?>

Ver también

La documentación principal de MongoDB sobre » límites.

  • MongoCursor::limit() - Limita el número de resultados devueltos
  • MongoCursorInterface::batchSize() - Limita el número de elementos devueltos en un lote

Historial de cambios

Versión | Descripción
1.4.5 | Antes de la versión 1.4.5, este método lanzaba una MongoCursorException si el cursor ya había comenzado a iterar.


Crea un nuevo cursor

  • « MongoCursor::batchSize
  • MongoCursor::count »
  • PHP Manual
  • MongoCursor
  • Crea un nuevo cursor

MongoCursor::__construct

(PECL mongo >=0.9.0)

MongoCursor::__construct — Crea un nuevo cursor

Descripción

public MongoCursor::__construct ( MongoClient $connection , string $ns , array $query = array() , array $fields = array() )

Parámetros

connection

Conexión de base de datos.

ns

Nombre completo de la base de datos y de la colección.

query

Consulta a la base de datos.

fields

Campos a devolver.

Valores devueltos

Devuelve el nuevo cursor.


Cuenta el número de resultados de esta consulta

  • « MongoCursor::__construct
  • MongoCursor::current »
  • PHP Manual
  • MongoCursor
  • Cuenta el número de resultados de esta consulta

MongoCursor::count

(PECL mongo >=0.9.2)

MongoCursor::count — Cuenta el número de resultados de esta consulta

Descripción

public MongoCursor::count ( bool $foundOnly = false ) : int

Este método no afecta al estado del cursor: si todavía no se le ha consultado, se podrán aplicar límites, saltos,e tc. Si ya se ha comenzado a recorrer sus resultados, no moverá la posición actual del cursor. Si ya se ha recorrido el cursor, no lo reiniciará.

Parámetros

foundOnly

Si fuera aplicable, enviar límite de cursor e información de datos saltados.

Valores devueltos

Número de documentos que devuelve la consulta de este cursor.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::count()

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

$cursor = $collection->find();

var_dump($cursor->count());
var_dump($cursor->count(true));

$cursor->limit(2);

var_dump($cursor->count());
var_dump($cursor->count(true));

?>

El resultado del ejemplo sería algo similar a:

int(3)
int(3)
int(3)
int(2)

Errores/Excepciones

Lanza MongoConnectionException si no se pudiera acceder a la base de datos.


Devuelve el elemento actual

  • « MongoCursor::count
  • MongoCursor::dead »
  • PHP Manual
  • MongoCursor
  • Devuelve el elemento actual

MongoCursor::current

(PECL mongo >=0.9.0)

MongoCursor::current — Devuelve el elemento actual

Descripción

public MongoCursor::current ( ) : array

Devuelve null hasta que se llame a MongoCursor::next().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El documento de resultados actual como array asociativo. Se devolverá null si no hubiera resultados.

Ver también

  • Iterator::current() - Devuelve el elemento actual


Comprueba si hay resultados que no han sido enviados aún de la base de datos

  • « MongoCursor::current
  • MongoCursor::doQuery »
  • PHP Manual
  • MongoCursor
  • Comprueba si hay resultados que no han sido enviados aún de la base de datos

MongoCursor::dead

(PECL mongo >=0.9.6)

MongoCursor::dead — Comprueba si hay resultados que no han sido enviados aún de la base de datos

Descripción

public MongoCursor::dead ( ) : bool

La base de datos envía respuestas en lotes de documentos, de hasta 4 MB de documentos por repuesta. Este método comprueba si la base de datos tiene más lotes o si el conjunto de resultados se ha agotado.

Un cursor muerto ("dead") no significa que MongoCursor::hasNext() devuelva false, solamente que la base de datos ha terminado de enviar resultados al cliente. Éste debería continuar iterando a través de los resultados hasta que MongoCursor::hasNext() sea false.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si hay más resultados que no han sido enviados aún al cliente, o false de lo contrario.

Ver también

  • MongoCursorInterface::dead() - Comprueba si existen resultados que aún no han sido enviados desde la base de datos


Ejecutar un sentencia

  • « MongoCursor::dead
  • MongoCursor::explain »
  • PHP Manual
  • MongoCursor
  • Ejecutar un sentencia

MongoCursor::doQuery

(PECL mongo >=0.9.0 <1.6.0)

MongoCursor::doQuery — Ejecutar un sentencia

Descripción

protected MongoCursor::doQuery ( ) : void
Advertencia

Por favor, no utilice este método.

Esta función realmente consulta la base de datos. Todas las consultas y comandos van a través de esta función. Así, esta función puede ser sobrescrita para proporcionar un manejo de consultas personalizado.

Maneja la serialización de la consulta, enviándola a la base de datos, recibiendo una respuesta, y deserializándola. Por lo tanto, si se está planeando sobrescribirlo, el código seguramente debiera de invocar al original para usar la funcionalidad existente (véase el ejemplo de más abajo).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::doQuery()

Se prodría sobrescribir esta función para intentar una consulta a un secundario y, si fallase, intentarlo de nuevo en el primario.

<?php

class MyCursor extends MongoCursor {

    protected function doQuery() {

        $this->slaveOkay();

        try {
            MongoCursor::doQuery();
        }
        catch(MongoCursorException $e) {
            $this->slaveOkay(false);
            MongoCursor::doQuery();
        }
    }
}

?>


Devuelve una explicación de la consulta, útil para la optimización y depuración

  • « MongoCursor::doQuery
  • MongoCursor::fields »
  • PHP Manual
  • MongoCursor
  • Devuelve una explicación de la consulta, útil para la optimización y depuración

MongoCursor::explain

(PECL mongo >=0.9.2)

MongoCursor::explain — Devuelve una explicación de la consulta, útil para la optimización y depuración

Descripción

public MongoCursor::explain ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la explicación de la consulta.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::explain()

<?php

$cursor = $collection->find(array("x"=>1), array("y"));
$cursor->sort(array("z" => 1))->limit(4)->skip(5);

var_dump($cursor->explain());

?>

El resultado del ejemplo sería algo similar a:

array(8) {
  ["cursor"]=>
  string(15) "BtreeCursor x_1"
  ["startKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["endKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["nscanned"]=>
  float(4)
  ["n"]=>
  int(4)
  ["scanAndOrder"]=>
  int(1)
  ["millis"]=>
  int(3)
  ["allPlans"]=>
  array(2) {
    [0]=>
    array(3) {
      ["cursor"]=>
      string(15) "BtreeCursor x_1"
      ["startKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
      ["endKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
    }
    [1]=>
    array(3) {
      ["cursor"]=>
      string(11) "BasicCursor"
      ["startKey"]=>
      array(0) {
      }
      ["endKey"]=>
      array(0) {
      }
    }
  }
}

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos.

Ver también

La documentación principal de MongoDB sobre » explain.


Establece los campos para una consulta

  • « MongoCursor::explain
  • MongoCursor::getNext »
  • PHP Manual
  • MongoCursor
  • Establece los campos para una consulta

MongoCursor::fields

(PECL mongo >=1.0.6)

MongoCursor::fields — Establece los campos para una consulta

Descripción

public MongoCursor::fields ( array $f ) : MongoCursor

Los cambpo se especifican mediante "nombre_campo" : bool. true indica que se debería devolver un campo, false indica que no debería ser devuelto. También se puede usar 1 y 0 en lugar de true y false.

Así, para devolver solamente el campo "summary", sería:

<?php

$cursor->fields(array("summary" => true));

?>

Para devolver todos los campos excepto el campo "hidden":

<?php

$cursor->fields(array("hidden" => false));

?>

Parámetros

f

Los campo a devolver (o no).

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar o se proporciona un argumento escalar.


Avanza el cursor al siguiente resultado y devuelve dicho resultado

  • « MongoCursor::fields
  • MongoCursor::getReadPreference »
  • PHP Manual
  • MongoCursor
  • Avanza el cursor al siguiente resultado y devuelve dicho resultado

MongoCursor::getNext

(PECL mongo >=0.9.0)

MongoCursor::getNext — Avanza el cursor al siguiente resultado y devuelve dicho resultado

Descripción

public MongoCursor::getNext ( ) : array

Nota:

MongoCursor::getNext() es un alias de MongoCursor::next().


Obtener la preferencia de lectura para esta consulta

  • « MongoCursor::getNext
  • MongoCursor::hasNext »
  • PHP Manual
  • MongoCursor
  • Obtener la preferencia de lectura para esta consulta

MongoCursor::getReadPreference

(PECL mongo >=1.3.3)

MongoCursor::getReadPreference — Obtener la preferencia de lectura para esta consulta

Descripción

public MongoCursor::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Ejemplos

Ejemplo #1 Ejemplo de valor devuelto de MongoCursor::getReadPreference()

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();
$cursor->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($cursor->getReadPreference());
?>

El resultado del ejemplo sería:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ver también

  • La documentación de preferencias de lectura.
  • MongoCursor::setReadPreference() - Establece la preferencia de lectura para esta consulta
  • MongoCursorInterface::getReadPreference() - Obtener la preferencia de lectura para esta consulta


Comprueba si existe algún elemento más en este cursor

  • « MongoCursor::getReadPreference
  • MongoCursor::hint »
  • PHP Manual
  • MongoCursor
  • Comprueba si existe algún elemento más en este cursor

MongoCursor::hasNext

(PECL mongo >=0.9.0)

MongoCursor::hasNext — Comprueba si existe algún elemento más en este cursor

Descripción

public MongoCursor::hasNext ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve si existe otro elemento.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos, y una MongoCursorTimeoutException si se excede el tiempo de espera.


Da a la base de datos un indicio sobre la consulta

  • « MongoCursor::hasNext
  • MongoCursor::immortal »
  • PHP Manual
  • MongoCursor
  • Da a la base de datos un indicio sobre la consulta

MongoCursor::hint

(PECL mongo >=0.9.0)

MongoCursor::hint — Da a la base de datos un indicio sobre la consulta

Descripción

public MongoCursor::hint ( mixed $index ) : MongoCursor

Parámetros

index

El índice a usar para la consulta. Si se proporciona un string, debería corresponderse con un nombre de índice. Si se proporciona un array u objeto, debería corresponderse con la especificación usada para crear el índice (esto es, el primer argumento de MongoCollection::ensureIndex()).

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Historial de cambios

Versión | Descripción
1.4.0 | El argumento index ahora admite nombres de índices como valores de tipo string. En versiones anteriores a la 1.4.0, solamente eran aceptados valores de array u objeto.


Establece si este cursor expirará

  • « MongoCursor::hint
  • MongoCursor::info »
  • PHP Manual
  • MongoCursor
  • Establece si este cursor expirará

MongoCursor::immortal

(PECL mongo >=1.0.1)

MongoCursor::immortal — Establece si este cursor expirará

Descripción

public MongoCursor::immortal ( bool $liveForever = true ) : MongoCursor

Después de permanecer inactivo en el servidor por algún tiempo, los cursores, por omisión, "mueren". Este es el compotamiento general que se desea. La base de datos limpia un cursor una vez que todos sus resultados han sido enviados al cliente, pero si el cliente no solicita todos los resultados, el cursor decaerá en ese momento, tomando recursos. Por lo tanto, después de unos minutos, el cursor "expira" y la base de datos asume que el cliente ha obtenido todo lo que necesita, y limpia los recursos del cursor.

Si, por cualquier motivo, fuera necesario que un cursor espere durante más tiempo, se puede evitar que la base de datos lo limpie usando este método. Sin embargo, si se hace inmortal a un cursor, es necesario iterar a través de todos sus resultados (o al menos hasta que MongoCursor::dead() devuelva true) o el cursor esperará a la base de datos para siempre, tomando recursos.

Parámetros

liveForever

Si el cursor debería ser inmortal.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.


Obtiene la información sobre la creación e iteración del cursor

  • « MongoCursor::immortal
  • MongoCursor::key »
  • PHP Manual
  • MongoCursor
  • Obtiene la información sobre la creación e iteración del cursor

MongoCursor::info

(PECL mongo >=1.0.5)

MongoCursor::info — Obtiene la información sobre la creación e iteración del cursor

Descripción

public MongoCursor::info ( ) : array

Se puede invocar antes o después de haber empezao a iterar el cursor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el espacio de nombres, tamaño del lote, límite, salto, banderas, consulta, y campos protegidos de este cursor. Si el cursor ha empezado a iterar, se incluirá información adicional sobre la iteración y la conexión.

Historial de cambios

Versión | Descripción
1.1.0 | Se añadieron varios campos, incluyendo id (el id del cursor), at (la cuenta del contador de cual es el documento actual), numReturned (el número devuelto por el servidor del lote actual), y server (el servidor al que se le envió la consulta; útil junto con Preferencias de lectura.
1.0.10 | Se añadió el campo started_iterating, un booleano que indica si el cursor es preconsulta o postconsulta.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::info()

<?php
$m = new MongoClient();

$cursor = $m->test->foo->find(array("x" => 4), array("y" => 0));

echo "Antes de iniciar la iteración:\n";
var_dump($cursor->info());

echo "\nDespués de iniciar la iteración:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

El resultado del ejemplo sería algo similar a:

Antes de iniciar la iteración:
array(8) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(false)
}

Después de iniciar la iteración:
array(15) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(0)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(1)
  ["server"]=>
  string(25) "localhost:27017;-;.;26450"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
}

Ver también

  • MongoCursorInterface::info() - Obtiene información sobre la creación e iteración del cursor


Devuelve el _id del resultado actual, o su índice dentro del conjunto de resultados

  • « MongoCursor::info
  • MongoCursor::limit »
  • PHP Manual
  • MongoCursor
  • Devuelve el _id del resultado actual, o su índice dentro del conjunto de resultados

MongoCursor::key

(PECL mongo >=0.9.0)

MongoCursor::key — Devuelve el _id del resultado actual, o su índice dentro del conjunto de resultados

Descripción

public MongoCursor::key ( ) : string|int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El _id del resultado actual como string. Si el resultado no posee un _id, se devolverá como entero su índice numérico dentro del conjunto de resultados.

Ver también

  • Iterator::key() - Devuelve la clave del elemento actual


Limita el número de resultados devueltos

  • « MongoCursor::key
  • MongoCursor::maxTimeMS »
  • PHP Manual
  • MongoCursor
  • Limita el número de resultados devueltos

MongoCursor::limit

(PECL mongo >=0.9.0)

MongoCursor::limit — Limita el número de resultados devueltos

Descripción

public MongoCursor::limit ( int $num ) : MongoCursor

Parámetros

num

El número de resultados a devolver.

Valores devueltos

Returns this cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ver también

  • La documentación principal de MongoDB sobre » límites.
  • MongoCursor::batchSize() - Limita el número de elementos devueltos en un lote
  • MongoCursor::skip() - Omite un número de resultados


Establece un tiempo límite en el lado del cliente para esta consulta

  • « MongoCursor::limit
  • MongoCursor::next »
  • PHP Manual
  • MongoCursor
  • Establece un tiempo límite en el lado del cliente para esta consulta

MongoCursor::maxTimeMS

(PECL mongo >=1.5.0)

MongoCursor::maxTimeMS — Establece un tiempo límite en el lado del cliente para esta consulta

Descripción

public MongoCursor::maxTimeMS ( int $ms ) : MongoCursor

Especifica el tiempo límite acumulativo en milisegundos permitido para que el sevidor procese operaciones en el cursor.

Parámetros

ms

Especifica el tiempo límite acumulativo en milisegundos permitido para que el sevidor procese operaciones en el cursor.

Valores devueltos

Este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha comenzado a iterar.

Causa que los métodos que obtengan resultados lancen una MongoExecutionTimeoutException si una consulta toma más del número de milisegundos especificado en procesarse.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::maxTimeMS()

En el siguiente ejemplo, el servidor abortará la consulta si el cursor requiere más de dos segundos en precesarla para que devuelva los resultados.

<?php

$cursor = $collection->find();
$cursor->maxTimeMS(2000);

try {
    $results = iterator_to_array($cursor);
} catch (MongoExecutionTimeoutException $e) {
    echo "!la consulta tomó demasiado tiempo!";
}

?>

Notas

Advertencia

A diferencia de MongoCursor::timeout(), el cual especifica un timepo límite en el cliente, MongoCursor::maxTimeMS() puede ser empleado para que el servidor de MongoDB aborte consultas que tomen mucho tiempo en ejecutarse. Dicho tiempo es acumulativo para el tiempo de vida del cursor (es decir, cada lote contribuirá a este tiempo límite). El tiempo límite solamente considera el tiempo de procesamiento; el tiempo no efectivo no se considera.


Avanza el cursor al siguiente resultado, y devuelve dicho resultado

  • « MongoCursor::maxTimeMS
  • MongoCursor::partial »
  • PHP Manual
  • MongoCursor
  • Avanza el cursor al siguiente resultado, y devuelve dicho resultado

MongoCursor::next

(PECL mongo >=0.9.0)

MongoCursor::next — Avanza el cursor al siguiente resultado, y devuelve dicho resultado

Descripción

public MongoCursor::next ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el siguiente documento.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos, y una MongoCursorTimeoutException si se excede el tiempo de espera.

Ver también

  • Iterator::next() - Avanza al siguiente elemento


Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído

  • « MongoCursor::next
  • MongoCursor::reset »
  • PHP Manual
  • MongoCursor
  • Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído

MongoCursor::partial

(PECL mongo >=1.2.0)

MongoCursor::partial — Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído

Descripción

public MongoCursor::partial ( bool $okay = true ) : MongoCursor

Esta opción permite que mongos envíe resultados de consultas parciales si un trozo está inaccesible. Solamente es aplicable al ejecutar un clúster de MongoDB troceado y conectarse a un mongos.

Si un trozo no está disponible y la consulta necesita enviarse a dicho trozo, mongos devolverá los resultados (si los hubiere) desde los trozos con los que ya ha conectado, y luego un mensaje de error diciendo que no se pudo acceder al trozo (una MongoCursorException en PHP). Si fuera necesario obtener los resultados que mongos puede proporcionar y sin excepcines, se puede usar este método. Observe que esto significa que no se tendrá una indicación de que un trozo no está accesible en la respuesta de la conulta.

Esto no tiene efecto sobre la consulta si todos los trozos son accesibles. Esta bandera fue implementada en la versión 1.7.5 de MongoDB, Por lo que solamente funcionará en esta versión y superiores.

Parámetros

okay

Si se acepta la recepción de resultados parciales.

Valores devueltos

Returns this cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.


Limpia el cursor

  • « MongoCursor::partial
  • MongoCursor::rewind »
  • PHP Manual
  • MongoCursor
  • Limpia el cursor

MongoCursor::reset

(PECL mongo >=0.9.0)

MongoCursor::reset — Limpia el cursor

Descripción

public MongoCursor::reset ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null.


Devuelve el cursor al inicio del conjunto de resultados

  • « MongoCursor::reset
  • MongoCursor::setFlag »
  • PHP Manual
  • MongoCursor
  • Devuelve el cursor al inicio del conjunto de resultados

MongoCursor::rewind

(PECL mongo >=0.9.0)

MongoCursor::rewind — Devuelve el cursor al inicio del conjunto de resultados

Descripción

public MongoCursor::rewind ( ) : void

Es idéntico a la función:

<?php

public function rewind() {
    $this->reset();
    $this->next();
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede acceder a la base de datos, y una MongoCursorTimeoutException si se excede el tiempo de espera.

Ver también

  • Iterator::rewind() - Rebobine la Iterator al primer elemento


Establece banderas arbitrarias en caso de que no haya métodos disponibles para una bandera específica

  • « MongoCursor::rewind
  • MongoCursor::setReadPreference »
  • PHP Manual
  • MongoCursor
  • Establece banderas arbitrarias en caso de que no haya métodos disponibles para una bandera específica

MongoCursor::setFlag

(PECL mongo >=1.2.11)

MongoCursor::setFlag — Establece banderas arbitrarias en caso de que no haya métodos disponibles para una bandera específica

Descripción

public MongoCursor::setFlag ( int $flag , bool $set = true ) : MongoCursor

La clase MongoCursor posee varios métodos para establecer banderas en el objeto de consulta. Este método está disponible en caso de que el protocolo de cable de MongoDB haya adquirido una nueva bandera, y el controlador no haya sido actualizado con un método para esta nueva bandera. El los demás casos, se debería usar el método. Véase la sección "Ver también" para los métodos disponibles.

Parámetros

flag

Qué bandera establecer. No se puede establecer la bandera 6 (EXHAUST), ya que el controlador no sabe como manejarla. Se generará una advertencia si se intenta usarla. Para las banderas disponibles, cosulte la » documentación del protocolo de cable.

set

Si debería establecerse la bandera (true) o no (false).

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Muestra una advertencia al intentar establecer una bandera no soportada.

Historial de cambios

Versión | Descripción
1.4.0 | Se añadió el soporte para la bandera 3 (OPLOG_REPLAY). Las versiones anteriorea a la 1.4.0 lanzarán una advertencia diciendo que la bandera no está soportada.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::setFlag()

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->setFlag( 1, true ); // sets the tailable flag
$cursor->setFlag( 5, true ); // sets the await data flag
?>

Ver también

  • MongoCursor::tailable() - Establece si este cursor se dejará abierto después de obtener los últimos resultados
  • MongoCursor::immortal() - Establece si este cursor expirará
  • MongoCursor::awaitData() - Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos
  • MongoCursor::partial() - Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído
  • La documentación principal de MongoDB sobre » banderas de consulta del protocolo de cable


Establece la preferencia de lectura para esta consulta

  • « MongoCursor::setFlag
  • MongoCursor::skip »
  • PHP Manual
  • MongoCursor
  • Establece la preferencia de lectura para esta consulta

MongoCursor::setReadPreference

(PECL mongo >=1.3.3)

MongoCursor::setReadPreference — Establece la preferencia de lectura para esta consulta

Descripción

public MongoCursor::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursor

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ejemplos

Ejemplo #1 Ejemplo de sintaxis de array de conjunto de etiquetas con MongoCursor::setReadPreference()

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir a un servidor del centro de datos "west"
$cursor->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ver también

  • La documentación de preferencias de lectura.
  • MongoCursor::getReadPreference() - Obtener la preferencia de lectura para esta consulta
  • MongoCursorInterface::setReadPreference() - Establecer la preferencia de lectura para esta consulta


Omite un número de resultados

  • « MongoCursor::setReadPreference
  • MongoCursor::slaveOkay »
  • PHP Manual
  • MongoCursor
  • Omite un número de resultados

MongoCursor::skip

(PECL mongo >=0.9.0)

MongoCursor::skip — Omite un número de resultados

Descripción

public MongoCursor::skip ( int $num ) : MongoCursor

Parámetros

num

El número de resultados a omitir.

Valores devueltos

Returns this cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ver también

  • MongoCursor::limit() - Limita el número de resultados devueltos


Establece si esta consulta puede realizarse en un secundario [obsoleto]

  • « MongoCursor::skip
  • MongoCursor::snapshot »
  • PHP Manual
  • MongoCursor
  • Establece si esta consulta puede realizarse en un secundario [obsoleto]

MongoCursor::slaveOkay

(PECL mongo >=0.9.4)

MongoCursor::slaveOkay — Establece si esta consulta puede realizarse en un secundario [obsoleto]

Descripción

public MongoCursor::slaveOkay ( bool $okay = true ) : MongoCursor
Advertencia

Este método está obsoleto desde la versión 1.5.0. Use en su lugar MongoCursor::setReadPreference() y Preferencias de lectura.

Al invocar a este método el controlador leerá de un secundario si:

  • Se está usando un conjunto de réplica, y
  • Se creó una instancia de MongoClient usando la opción "replicaSet" => "setName", y
  • Existe un secundario sano con el que puede conectarse el controlador.
Se puede comprobar el servidor que se usó para esta consulta invocando a MongoCursor::info() después de ejecutarla. Su campo server mostrará el servidor al que se le envió la consulta.

Observe que se debería usar esta función incluso si no se utiliza la asignación de rutas automática a secundarios. Si se contecta directamente a un secundario de un conjunto de réplica, aún será necesario llamar a esta función, que básicamente le indica a la base de datos que se está al tanto de que se podrían obtener datos antiguos, aceptándolo. Si no se invoca, se obtendran errores de tipo "sin maestro" al intentar realizar la consulta.

Este método anulará a la variable de clase estática
MongoCursor::$slaveOkay. También anulará a
Mongo::setSlaveOkay(),
MongoDB::setSlaveOkay() y
MongoCollection::setSlaveOkay().

Parámetros

okay

Si se acepta consultar al secundario.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::slaveOkay()

<?php

MongoCursor::$slaveOkay = false;

// no se puede consultar al secundario
$cursor = $collection->find();

// se puede consultar al secundario
$cursor = $collection->find()->slaveOkay();

MongoCursor::$slaveOkay = true;

// se puede consultar al secundario
$cursor = $collection->find();

// no se puede consultar al secundario
$cursor = $collection->find()->slaveOkay(false);

?>

Ver también

  • Preferencias de lectura
  • MongoCursor::setReadPreference() - Establece la preferencia de lectura para esta consulta
  • MongoCursor::getReadPreference() - Obtener la preferencia de lectura para esta consulta

Historial de cambios

Versión | Descripción
1.5.0 | Este método está obsoleto en favor de MongoCursor::setReadPreference() y Preferencias de lectura.


Usar el modo 'snapshot' para la consulta

  • « MongoCursor::slaveOkay
  • MongoCursor::sort »
  • PHP Manual
  • MongoCursor
  • Usar el modo 'snapshot' para la consulta

MongoCursor::snapshot

(PECL mongo >=0.9.4)

MongoCursor::snapshot — Usar el modo 'snapshot' para la consulta

Descripción

public MongoCursor::snapshot ( ) : MongoCursor

Usar el modo instantánea ('snapshot') para la consulta. Este modo se asegura de que un documento no sea devuelto más de una vez a causa de que una operación de escritura que intervenga resulte en el movimiento del documento. Los documentos insertados o eliminados durante el tiempo de vida del cursor podrían o no ser devueltos, irrespectivamente del modo instantánea.

Las consultas con respuestas cortas (menos de 1MB) siempre se les realiza una instantánea de forma efectiva.

El modo instantánea no puede emplearse en sugerencias cortas y explícitas o en consultas sobre colecciones compartidas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ver también

La documentación de MongoDB sobre » el operador $snapshot.


Ordena los resultados por el campo que se indique

  • « MongoCursor::snapshot
  • MongoCursor::tailable »
  • PHP Manual
  • MongoCursor
  • Ordena los resultados por el campo que se indique

MongoCursor::sort

(PECL mongo >=0.9.0)

MongoCursor::sort — Ordena los resultados por el campo que se indique

Descripción

public MongoCursor::sort ( array $fields ) : MongoCursor

Parámetros

fields

Array de campos en función de los que se va a ordenar. Cada elemento del array tiene de clave el nombre del campo, y como valor, o bien 1 para orden ascendente, o bien -1 para orden descendente.

En primer lugar, se ordena de acuerdo al primer campo del array. Después (si existe) de acuerdo al segundo, etc. Esto quiere decir que el orden de los campos del array fields es importante. Revise la sección de ejemplos.

Valores devueltos

Devuelve el mismo cursor con el que se invocó a este método.

Errores/Excepciones

Lanza MongoCursorException si ya se hubiera empezado a recorrer el cursor.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::sort()

<?php
// ordenar por x ascendentemente
$cursor->sort(array('x' => 1));

// El orden del array asociativo es importante. Por ejemplo, estos dos
// ejemplos generarán distintos resultados:

// ordena por fecha ascendentemente y después por edad descendentemente
$cursor->sort(array('date' => 1, 'age' => -1));

// ordena por edad descendentemente y después por fecha ascendentemente
$cursor->sort(array('age' => -1, 'date' => 1));
?>


Establece si este cursor se dejará abierto después de obtener los últimos resultados

  • « MongoCursor::sort
  • MongoCursor::timeout »
  • PHP Manual
  • MongoCursor
  • Establece si este cursor se dejará abierto después de obtener los últimos resultados

MongoCursor::tailable

(PECL mongo >=0.9.4)

MongoCursor::tailable — Establece si este cursor se dejará abierto después de obtener los últimos resultados

Descripción

public MongoCursor::tailable ( bool $tail = true ) : MongoCursor

Mongo posee una característica conocia como cursores de seguimiento ("tailable"), que son similares al comando de Unix "tail -f".

"De seguimiento" significa que el cursor no se cierra al obtener los últimos datos. En su lugar, el cursor marca la posición final del objeto. Se puede continuar usando el cursor más tarde, desde donde estaba ubicado, si se recibieron más datos.

Como cualquie "cursor latente", el cursor podría no ser válido en algún punto; por ejemplo, si el final del objeto al que hace referencia fue eliminado. Por lo tanto, se debería preparado para reconsultar si el cursor está MongoCursor::dead().

Parámetros

tail

Si el cursor debería ser de seguimiento.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Lanza una MongoCursorException si este cursor ha empezado a iterar.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::tailable()

<?php

$cursor = $collection->find()->tailable();

$resultados = array();

while (1) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
        // read all results so far, wait for more
        sleep(10);
    }
    else {
        $resultados[] = $cursor->getNext();
    }
}

?>

Ver también

La documentación principal de MongoDB sobre » sursores de seguimiento.

  • MongoCursor::awaitData() - Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos


Establece un tiempo de espera en el lado del cliente para esta consulta

  • « MongoCursor::tailable
  • MongoCursor::valid »
  • PHP Manual
  • MongoCursor
  • Establece un tiempo de espera en el lado del cliente para esta consulta

MongoCursor::timeout

(PECL mongo >=1.0.3)

MongoCursor::timeout — Establece un tiempo de espera en el lado del cliente para esta consulta

Descripción

public MongoCursor::timeout ( int $ms ) : MongoCursor

Se puede establecer un tiempo de espera en cualquier momento y afectará a consultas subsiguientes del cursor, incluyendo la obtención de más resultados desde la base de datos.

Parámetros

ms

El número de milisegundos que ha de esperar el cursor a una respuesta. Use -1 para esperar eternamente. Por omisión, el cursor esperará 30000 milisegundos (30 segundos).

Valores devueltos

Este cursor.

Errores/Excepciones

Hace que los métodos que obtienen resultados lancen una MongoCursorTimeoutException si la consulta toma más tiempo de los milisegundos especificados.

Ejemplos

Ejemplo #1 Ejemplo de MongoCursor::timeout()

En el siguiente ejemplo, el controlador esperará a una respuesta inicial de la base de datos, y luego esperará 100 ms para las respuestas subsiguientes.

<?php

$cursor = $collection->find();
$cursor->timeout(-1);

/* $cursor->hasNext() ejecuta la consulta. Se ha establecido un tiempo de espera
 * infinito, por lo que el controlador esperará lo necesario a una respuesta.
 */
while ($cursor->hasNext()) {
    $cursor->timeout(100);

    /* Ahora se ha establecido el tiempo de espera, por lo que, si el cursor necesita obtener
     * más resultados de la base de datos, solo esperará 100 ms a una respuesta.
     */
    try {
        print_r($cursor->getNext());
    } catch (MongoCursorTimeoutException $e) {
        echo "¡La consulta tomó demasiado tiempo!";
    }
}

?>

Notas

Advertencia

Esto no hace que el servidor de MongoDB cancele las operaciones que se ejecuten durante mucho tiempo; solamente instruye al controlador para que deje de esperar a una respuesta y lance una MongoCursorTimeoutException después de un tiempo establecido. Si fuera necesario especificar un tiempo límite para una consulta, se puede considerar el uso de MongoCursor::maxTimeMS().

Ver también

  • MongoCursorInterface::timeout() - Establece un tiempo de espera en el lado del cliente para esta consulta
  • La opción socketTimeoutMS de MongoClient::__construct()


Comprueba si el cursor está leyendo un resultado válido

  • « MongoCursor::timeout
  • MongoCursorInterface »
  • PHP Manual
  • MongoCursor
  • Comprueba si el cursor está leyendo un resultado válido

MongoCursor::valid

(PECL mongo >=0.9.0)

MongoCursor::valid — Comprueba si el cursor está leyendo un resultado válido

Descripción

public MongoCursor::valid ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el resultado actual no es nulo, y false de lo contrario.

Ver también

  • Iterator::valid() - Comprueba si la posición actual es válido


La interfaz MongoCursorInterface

(PECL mongo >=1.5.0)

Introducción

Interfaz para cursores que se puede emplear para recorrer los resultados de una orden o consulta de una base de datos. Esta interfaz está implementada por las clases MongoCursor y MongoCommandCursor.

Nota: Al igual que Traversable, esta interfaz no puede ser implementada en un script de PHP.

Sinopsis de la Clase

MongoCursorInterface extends Iterator {
/* Métodos */
abstract public batchSize ( int $batchSize ) : MongoCursorInterface
abstract public dead ( ) : bool
abstract public getReadPreference ( ) : array
abstract public info ( ) : array
abstract public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursorInterface
abstract public timeout ( int $ms ) : MongoCursorInterface
/* Métodos heredados */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Tabla de contenidos

  • MongoCursorInterface::batchSize — Limita el número de elementos devueltos en un lote
  • MongoCursorInterface::dead — Comprueba si existen resultados que aún no han sido enviados desde la base de datos
  • MongoCursorInterface::getReadPreference — Obtener la preferencia de lectura para esta consulta
  • MongoCursorInterface::info — Obtiene información sobre la creación e iteración del cursor
  • MongoCursorInterface::setReadPreference — Establecer la preferencia de lectura para esta consulta
  • MongoCursorInterface::timeout — Establece un tiempo de espera en el lado del cliente para esta consulta


Limita el número de elementos devueltos en un lote

  • « MongoCursorInterface
  • MongoCursorInterface::dead »
  • PHP Manual
  • MongoCursorInterface
  • Limita el número de elementos devueltos en un lote

MongoCursorInterface::batchSize

(PECL mongo >=1.5.0)

MongoCursorInterface::batchSize — Limita el número de elementos devueltos en un lote

Descripción

abstract public MongoCursorInterface::batchSize ( int $batchSize ) : MongoCursorInterface

Un cursor típicamente obtiene un lote de objetos de resultados y los almacena localmente. Este método establece el valor del tamaño del lote para configurar la cantidad de documentos obtenidos de un servidor en un viaje de ida y vuelta.

Parámetros

batchSize

El número de resultados a devolver por lote.

Valores devueltos

Devuelve este cursor.


Comprueba si existen resultados que aún no han sido enviados desde la base de datos

  • « MongoCursorInterface::batchSize
  • MongoCursorInterface::getReadPreference »
  • PHP Manual
  • MongoCursorInterface
  • Comprueba si existen resultados que aún no han sido enviados desde la base de datos

MongoCursorInterface::dead

(PECL mongo >=1.5.0)

MongoCursorInterface::dead — Comprueba si existen resultados que aún no han sido enviados desde la base de datos

Descripción

abstract public MongoCursorInterface::dead ( ) : bool

Este método comprueba si el cursor ha finalizado y la base de datos no tiene más resultados que enviar al cliente. Un cursor "muerto" no significa necesariamente que no hayan más resultados disponibles que iterar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si hay más resutaldos que aún no han sido enviados al cliente, y false en caso contrario.


Obtener la preferencia de lectura para esta consulta

  • « MongoCursorInterface::dead
  • MongoCursorInterface::info »
  • PHP Manual
  • MongoCursorInterface
  • Obtener la preferencia de lectura para esta consulta

MongoCursorInterface::getReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::getReadPreference — Obtener la preferencia de lectura para esta consulta

Descripción

abstract public MongoCursorInterface::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Ver también

  • La documentación de las preferencias de lectura.
  • MongoCursorInterface::setReadPreference() - Establecer la preferencia de lectura para esta consulta


Obtiene información sobre la creación e iteración del cursor

  • « MongoCursorInterface::getReadPreference
  • MongoCursorInterface::setReadPreference »
  • PHP Manual
  • MongoCursorInterface
  • Obtiene información sobre la creación e iteración del cursor

MongoCursorInterface::info

(PECL mongo >=1.5.0)

MongoCursorInterface::info — Obtiene información sobre la creación e iteración del cursor

Descripción

abstract public MongoCursorInterface::info ( ) : array

Devuelve información sobre la creación e iteración del cursor. Esta función se puede llamar antes o después de que el cursor haya empezado a iterar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el espacio de nombres, tamaño del lote, límite, salto, banderas, consulta, y campos protegidos de este cursor. Si el cursor ha empezado a iterar, se incluirá información adicional sobre la iteración y la conexión.


Establecer la preferencia de lectura para esta consulta

  • « MongoCursorInterface::info
  • MongoCursorInterface::timeout »
  • PHP Manual
  • MongoCursorInterface
  • Establecer la preferencia de lectura para esta consulta

MongoCursorInterface::setReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::setReadPreference — Establecer la preferencia de lectura para esta consulta

Descripción

abstract public MongoCursorInterface::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursorInterface

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Devuelve este cursor.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ver también

  • La documentación de las preferencias de lectura.
  • MongoCursorInterface::getReadPreference() - Obtener la preferencia de lectura para esta consulta


Establece un tiempo de espera en el lado del cliente para esta consulta

  • « MongoCursorInterface::setReadPreference
  • MongoCommandCursor »
  • PHP Manual
  • MongoCursorInterface
  • Establece un tiempo de espera en el lado del cliente para esta consulta

MongoCursorInterface::timeout

(PECL mongo >=1.5.0)

MongoCursorInterface::timeout — Establece un tiempo de espera en el lado del cliente para esta consulta

Descripción

abstract public MongoCursorInterface::timeout ( int $ms ) : MongoCursorInterface

Se puede establecer un tiempo de espera en cualquier momento, por lo que afectará a la recuperación de datos subsiguientes asociados a este cursor, incluyento la obtención de más resultados de la base de datos.

Parámetros

ms

El número de milisegundos que ha de esperar el cursor a un a respuesta. Use -1 para una espera ilimitada. Por defecto, el cursor esperará 30000 milisegundos (30 segundos).

Valores devueltos

Returns this cursor.

Errores/Excepciones

Causa que los métodos que obtengan resutados lancen una MongoCursorTimeoutException si la obtención de los datos toma más del número de milisegundos especificados.

Ver también

  • La opción socketTimeoutMS de MongoClient::__construct()


La clase MongoCommandCursor

(PECL mongo >=1.5.0)

Introducción

Un cursor de comandos es similar a un MongoCursor excepto que se utiliza para recorrer los resultados de un comando de la base de datos en lugar de una consulta normal. Los cursores de comandos son útiles para recorrer conjuntos de resultados grandes que podrían exceder el límite del tamaño del documento (actualmente 16MB) de una respuesta MongoDB::command() sencilla.

Aunque se pueden crear cursores de comandos con MongoCommandCursor::__construct() o el método de fábrica MongoCommandCursor::createFromDocument(), normalmente se utilizarán ayudantes específicos de comandos como MongoCollection::aggregateCursor().

Observe que el cursor no "contiene" los resultados del comando de la base de datos, solamente gestiona su recorrido. Por lo tanto, si se imprime un cursor (p.ej., con var_dump() o print_r()), se obtendrá el objeto cursor, no los documentos de resultados.

Escenarios de un cursor

Un MongoCommandCursor tiene dos "escenarios de vida": pre y pos comando. Cuando un cursor se crea, aún no ha contactado con la base de datos, por lo que está en un estado de precomando. Cuando el cliente primero intenta obtener un resultado (llamando a MongoCommandCursor::rewind(), directa o indirectamente), el cursor se mueve al estado de poscomando.

El tamaño del lote y el tiempo de espera del socket de cursor de comando puede configurarse tanto en el estado de precomando como en el de poscomando.

Ejemplo #1 Añadir opciones a MongoCommandCursor

<?php

$cursor = new MongoCommandCursor(...);

$cursor = $cursor->batchSize( 4 );

foreach ($cursor as $resultado) {
    var_dump($resultado);
}
?>

Sinopsis de la Clase

MongoCommandCursor implements MongoCursorInterface , Iterator {
/* Métodos */
public batchSize ( int $batchSize ) : MongoCommandCursor
public __construct ( MongoClient $connection , string $ns , array $command = array() )
public static createFromDocument ( MongoClient $connection , string $hash , array $document ) : MongoCommandCursor
public current ( ) : array
public dead ( ) : bool
public getReadPreference ( ) : array
public info ( ) : array
public key ( ) : string
public next ( ) : void
public rewind ( ) : array
public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCommandCursor
public timeout ( int $ms ) : MongoCommandCursor
public valid ( ) : bool
}

Ver también

  • MongoDB::command()
  • MongoCollection::aggregateCursor()

Tabla de contenidos

  • MongoCommandCursor::batchSize — Limita el número de elementos devueltos en un lote
  • MongoCommandCursor::__construct — Crear un nuevo cursor de comando
  • MongoCommandCursor::createFromDocument — Crear un nuevo cursor de comando desde un documento de cursor existente
  • MongoCommandCursor::current — Devuelve el elemento actual
  • MongoCommandCursor::dead — Comprueba si hay resultados que aún no han sido enviados desde la base de datos
  • MongoCommandCursor::getReadPreference — Obtener la preferencia de lectura para este comando
  • MongoCommandCursor::info — Obtiene información sobre la creación e iteración del cursor
  • MongoCommandCursor::key — Devuelve el _id del resultado acutal
  • MongoCommandCursor::next — Avanza el cursor al siguiente resultado
  • MongoCommandCursor::rewind — Ejecuta el comando y reinicia el cursor al comienzo del conjunto de resultados
  • MongoCommandCursor::setReadPreference — Establecer la preferencia de lectura para este comando
  • MongoCommandCursor::timeout — Establece el tiempo de espera del lado del cliente para este comando
  • MongoCommandCursor::valid — Comprueba si el cursor está leyendo un resultado válido


Limita el número de elementos devueltos en un lote

  • « MongoCommandCursor
  • MongoCommandCursor::__construct »
  • PHP Manual
  • MongoCommandCursor
  • Limita el número de elementos devueltos en un lote

MongoCommandCursor::batchSize

(PECL mongo >=1.5.0)

MongoCommandCursor::batchSize — Limita el número de elementos devueltos en un lote

Descripción

public MongoCommandCursor::batchSize ( int $batchSize ) : MongoCommandCursor

Un cursor normalmente obtiene un lote de objetos de resultado y los almacena localmente. Este método establece el valor de batchSize para configurar la cantidad de documentos recuperados del servidor en viaje de ida y vuelta.

Parámetros

batchSize

El número de resultados a devolver por lote. Cada lote requiere un viaje de ida y vuelta al servidor.

Este parámetro no puede sobrescribir el límite de MongoDB de cuántos datos serán devueltos al cliente (es decir, si se establece el tamaño del lote a 1,000,000,000, MongoDB aún devolverá solamente 4-16 MB de resultados por lote).

Valores devueltos

Devuelve este cursor.

Ejemplos

Ejemplo #1 MongoCommandCursor::batchSize()

<?php
$commandCursor->batchSize(20);
?>

Ver también

  • MongoCursorInterface::batchSize() - Limita el número de elementos devueltos en un lote


Crear un nuevo cursor de comando

  • « MongoCommandCursor::batchSize
  • MongoCommandCursor::createFromDocument »
  • PHP Manual
  • MongoCommandCursor
  • Crear un nuevo cursor de comando

MongoCommandCursor::__construct

(PECL mongo >=1.5.0)

MongoCommandCursor::__construct — Crear un nuevo cursor de comando

Descripción

public MongoCommandCursor::__construct ( MongoClient $connection , string $ns , array $command = array() )

Generalmente, no se debería tener que construir un MongoCommandCursor manualmente, ya que existen funciones ayudantes como MongoCollection::aggregateCursor() y MongoCollection::parallelCollectionScan(). Sin embargo, si el servidor introduce nuevos comandos que puedan devolver cursores, este constructor será útil debido a la ausencia de métodos ayudantes específicos. Se podría también considerar el empleo de MongoCommandCursor::createFromDocument().

Parámetros

connection

La conexión a la base de datos.

ns

Nombre completo de la base de datos y la colección (p.ej. "test.foo")

command

Comando de la base de datos.

Valores devueltos

Devuelve el nuevo cursor.

Ejemplos

Ejemplo #1 Ejemplo de MongoCommandCursor

<?php
$m = new MongoClient;

// Definir la tubería de totalización
$pipeline = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Construir un objeto MongoCommandCursor
$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => $pipeline,
        'cursor' => [ 'batchSize' => 0 ],
    ]
);

foreach($cursor as $result) {
   …
}
?>

Ver también

  • MongoCommandCursor::createFromDocument() - Crear un nuevo cursor de comando desde un documento de cursor existente
  • MongoCollection::aggregateCursor() - Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor
  • MongoCollection::parallelCollectionScan() - Devuelve un array con cursores para recorrer una colección completa en paralelo


Crear un nuevo cursor de comando desde un documento de cursor existente

  • « MongoCommandCursor::__construct
  • MongoCommandCursor::current »
  • PHP Manual
  • MongoCommandCursor
  • Crear un nuevo cursor de comando desde un documento de cursor existente

MongoCommandCursor::createFromDocument

(PECL mongo >=1.5.0)

MongoCommandCursor::createFromDocument — Crear un nuevo cursor de comando desde un documento de cursor existente

Descripción

public static MongoCommandCursor::createFromDocument ( MongoClient $connection , string $hash , array $document ) : MongoCommandCursor

Use este método si tiene un resultado de comando sin tratar con información de cursor en él. Observe que los cursores creados con este método no se pueden iterar varias veces, ya que carecen del comando original necesario para la reejecución.

Parámetros

connection

La conexión a la base de datos.

hash

El hash de la conexión, obtenida mediante el tercer argumento por referencia de MongoDB:command().

document

El documento con información de cursor en él. Es neceario que este documento contenga los campos id, ns y firstBatch. Tal documento se obtiene invocando a MongoDB:command() con los argumentos apropiados para que devuelva un cursor, y no un resultado. Véase el ejemplo de más abajo.

Valores devueltos

Devuelve el nuevo cursor.

Ejemplos

Ejemplo #1 MongoCommandCursor::createFromDocument()

<?php
$m = new MongoClient;
$d = $m->demo;

// Definir la tubería de totalización
$tubería = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Ejecutar el comando. La opción "cursor" le indica al servidor que devuelva
// información del cursor en la respuesta en lugar de los resultados en línea.
$r = $d->command(
    [
        'aggregate' => 'cities',
        'pipeline' => $tubería,
        'cursor' => [ 'batchSize' => 1 ],
    ],
    null,
    $hash
);

// Mostrar el resultado y el hash
var_dump( $r, $hash );

// Construir el cursor de comando
$cursor = MongoCommandCursor::createFromDocument( $m, $hash, $r );
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "392143983421"
    }
    ["ns"]=>
    string(11) "demo.cities"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        string(2) "AD"
        ["timezones"]=>
        array(1) {
          [0]=>
          string(14) "Europe/Andorra"
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}
string(25) "localhost:27017;-;.;17617"

Como se puede ver, la información del cursor devuelta posee los campos id, ns y firstBatch.

Ver también

  • MongoCommandCursor::__construct() - Crear un nuevo cursor de comando


Devuelve el elemento actual

  • « MongoCommandCursor::createFromDocument
  • MongoCommandCursor::dead »
  • PHP Manual
  • MongoCommandCursor
  • Devuelve el elemento actual

MongoCommandCursor::current

(PECL mongo >=1.5.0)

MongoCommandCursor::current — Devuelve el elemento actual

Descripción

public MongoCommandCursor::current ( ) : array

Devuelve null hasta que se invoque a MongoCommandCursor::rewind().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El documento de resultados actual como un array asociativo. Se devolverá null si no hay más resultados.

Ver también

  • Iterator::current() - Devuelve el elemento actual


Comprueba si hay resultados que aún no han sido enviados desde la base de datos

  • « MongoCommandCursor::current
  • MongoCommandCursor::getReadPreference »
  • PHP Manual
  • MongoCommandCursor
  • Comprueba si hay resultados que aún no han sido enviados desde la base de datos

MongoCommandCursor::dead

(PECL mongo >=1.5.0)

MongoCommandCursor::dead — Comprueba si hay resultados que aún no han sido enviados desde la base de datos

Descripción

public MongoCommandCursor::dead ( ) : bool

Este método comprueba si el cursor MongoCommandCursor ha expirado y la base de datos no tiene más resultados que enviar al cliente. Un cursor "muerto" no significa necesariamente que ya no haya más resultados disponibles para la iteración.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si no hay más resultados que aún no han sido enviados al cliente, y false de lo contrario.

Ver también

  • MongoCursorInterface::dead() - Comprueba si existen resultados que aún no han sido enviados desde la base de datos


Obtener la preferencia de lectura para este comando

  • « MongoCommandCursor::dead
  • MongoCommandCursor::info »
  • PHP Manual
  • MongoCommandCursor
  • Obtener la preferencia de lectura para este comando

MongoCommandCursor::getReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::getReadPreference — Obtener la preferencia de lectura para este comando

Descripción

public MongoCommandCursor::getReadPreference ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta función devuelve un array que describe la preferencia de lectura. El array contiene los valores type para el string del modo de preferencia de lectura (correspondiente a constantes de MongoClient), y tagsets que contiene una lista de todos los criterios de conjuntos de etiquetas. Si no se especificó ningún conjunto de etiquetas, tagsets no estará presente en el array.

Ejemplos

Ejemplo #1 Ejemplo de valor devuelto por MongoCommandCursor::getReadPreference()

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

// Si un MongoCommandCursor se construye directamente, heredará la preferencia
// de lectura de la instancia de MongoClient pasada a su constructor; sin embargo,
// MongoCollection::aggregateCursor() tendrá el que MongoCommandCursor hereda
// la preferencia de lectura de la colección.
$collection->setReadPreference(MongoClient::RP_SECONDARY);

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

var_dump($cursor->getReadPreference());

?>

El resultado del ejemplo sería:

array(1) {
  ["type"]=>
  string(9) "secondary"
}

Ver también

  • La documentación de las preferencias de lectura.
  • MongoCommandCursor::setReadPreference() - Establecer la preferencia de lectura para este comando
  • MongoCursorInterface::getReadPreference() - Obtener la preferencia de lectura para esta consulta


Obtiene información sobre la creación e iteración del cursor

  • « MongoCommandCursor::getReadPreference
  • MongoCommandCursor::key »
  • PHP Manual
  • MongoCommandCursor
  • Obtiene información sobre la creación e iteración del cursor

MongoCommandCursor::info

(PECL mongo >=1.5.0)

MongoCommandCursor::info — Obtiene información sobre la creación e iteración del cursor

Descripción

public MongoCommandCursor::info ( ) : array

Se puede llamar antes o después de haber empezado a iterar el cursor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el espacio de nombres, tamaño del lote, límite salto, banderas, consulta, y campos protegidos de este cursor. Si el cursor ya ha empezado a iterar, se incluirá información adicional sobre la iteración y la conexión.

Ejemplos

Ejemplo #1 Ejemplo de MongoCommandCursor::info()

<?php
$m = new MongoClient();

$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => [ [ '$match' => [ '_id' => [ '$exists' => true ] ] ] ],
        'cursor' => [ 'batchSize' => 1 ],
    ]
);

echo "Antes de iniciar la iteración:\n";
var_dump($cursor->info());

echo "\nDespués de iniciar la iteración:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

El resultado del ejemplo sería algo similar a:

Antes de iniciar la iteración:
array(8) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(false)
}

Después de iniciar la iteración:
array(17) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(185840310129)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(0)
  ["server"]=>
  string(25) "localhost:27017;-;.;23991"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
  ["firstBatchAt"]=>
  int(0)
  ["firstBatchNumReturned"]=>
  int(1)
}

Ver también

  • MongoCursorInterface::info() - Obtiene información sobre la creación e iteración del cursor


Devuelve el _id del resultado acutal

  • « MongoCommandCursor::info
  • MongoCommandCursor::next »
  • PHP Manual
  • MongoCommandCursor
  • Devuelve el _id del resultado acutal

MongoCommandCursor::key

(PECL mongo >=1.5.0)

MongoCommandCursor::key — Devuelve el _id del resultado acutal

Descripción

public MongoCommandCursor::key ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice del resultado actual dentro del conjunto de resultados.

Ver también

  • Iterator::key() - Devuelve la clave del elemento actual


Avanza el cursor al siguiente resultado

  • « MongoCommandCursor::key
  • MongoCommandCursor::rewind »
  • PHP Manual
  • MongoCommandCursor
  • Avanza el cursor al siguiente resultado

MongoCommandCursor::next

(PECL mongo >=1.5.0)

MongoCommandCursor::next — Avanza el cursor al siguiente resultado

Descripción

public MongoCommandCursor::next ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null.

Errores/Excepciones

Lanza una MongoConnectionException si no se puede conectar con la base de datos, y una MongoCursorTimeoutException si se excede el tiempo límite.

Ver también

  • Iterator::next() - Avanza al siguiente elemento


Ejecuta el comando y reinicia el cursor al comienzo del conjunto de resultados

  • « MongoCommandCursor::next
  • MongoCommandCursor::setReadPreference »
  • PHP Manual
  • MongoCommandCursor
  • Ejecuta el comando y reinicia el cursor al comienzo del conjunto de resultados

MongoCommandCursor::rewind

(PECL mongo >=1.5.0)

MongoCommandCursor::rewind — Ejecuta el comando y reinicia el cursor al comienzo del conjunto de resultados

Descripción

public MongoCommandCursor::rewind ( ) : array

Si el cursor ya a empezado a iterar, el comando será reejecutado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El documento resultante sin tratar.

Errores/Excepciones

Lanza una MongoConnectionException si no puede conectar a la base de datos, y una MongoCursorTimeoutException si se excede el tiempo de espera.

Lanza una MongoCursorException si el cursor se creó con MongoCommandCursor::createFromDocument() y ya se ha iniciado la iteración. Tales cursores no se pueden iterar varias veces, ya que carecen del comando original necesario para la reejecución.

Ejemplos

Ejemplo #1 MongoCommandCursor::rewind()

<?php
$rawResult = $commandCursor->rewind();

// El cursor del comando ahora se reinicia al principio del conjunto de resultados

var_dump($rawResult);
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "310050110216"
    }
    ["ns"]=>
    string(9) "demo.test"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        object(MongoId)#6 (1) {
          ["$id"]=>
          string(24) "52f5691544670a8077b0dc51"
        }
        ["value"]=>
        string(2) "42"
      }
    }
  }
  ["ok"]=>
  float(1)
}

Ver también

  • Iterator::rewind() - Rebobine la Iterator al primer elemento


Establecer la preferencia de lectura para este comando

  • « MongoCommandCursor::rewind
  • MongoCommandCursor::timeout »
  • PHP Manual
  • MongoCommandCursor
  • Establecer la preferencia de lectura para este comando

MongoCommandCursor::setReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::setReadPreference — Establecer la preferencia de lectura para este comando

Descripción

public MongoCommandCursor::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCommandCursor

Parámetros

read_preference

El modo de preferencia de lectura: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, o MongoClient::RP_NEAREST.

tags

Un array de cero o más conjuntos de etiquetas, donde cada conjunto de etiquetas es también un array de criterios usados para comparar etiquetas con miembros de un conjunto de réplicas.

Valores devueltos

Returns this cursor.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro no es válido, o si se proporcionan uno o más conjuntos de etiquetas con el modo de preferencia de lectura MongoClient::RP_PRIMARY.

Ejemplos

Ejemplo #1 Ejemplo de sintaxis de array de conjunto de etiquetas de MongoCommandCursor::setReadPreference()

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

// Preferir el servidor más cercano del centro de datos "east" también usado para información,
// pero recurrir a un servidor del centro de datos "west"
$cursor->setReadPreference(MongoClient::RP_NEAREST, [
    [ 'dc' => 'east', 'use' => 'reporting' ],
    [ 'dc' => 'west' ],
] );

foreach ($cursor as $person) {
    // ...
}

// Si se cambia la preferencia de lecutra, esta se utilizará la siguiente vez que el cursor
// sea rebobinado y sea reejecutado el comando.
$cursor->setReadPreference(MongoClient::RP_PRIMARY);

foreach ($cursor as $person) {
    // ...
}

?>

Ver también

  • La documentación de las preferencias de lectura.
  • MongoCommandCursor::getReadPreference() - Obtener la preferencia de lectura para este comando
  • MongoCursorInterface::setReadPreference() - Establecer la preferencia de lectura para esta consulta


Establece el tiempo de espera del lado del cliente para este comando

  • « MongoCommandCursor::setReadPreference
  • MongoCommandCursor::valid »
  • PHP Manual
  • MongoCommandCursor
  • Establece el tiempo de espera del lado del cliente para este comando

MongoCommandCursor::timeout

(PECL mongo >=1.6.0)

MongoCommandCursor::timeout — Establece el tiempo de espera del lado del cliente para este comando

Descripción

public MongoCommandCursor::timeout ( int $ms ) : MongoCommandCursor

Se puede establecer un tiempo de espera en cualquier momento, por lo que afectará a la recuperación de datos subsiguientes asociados a este cursor, incluyento la obtención de más resultados de la base de datos.

Parámetros

ms

El número de milisegundos que ha de esperar el cursor a un a respuesta. Use -1 para una espera ilimitada. Por defecto, el cursor esperará 30000 milisegundos (30 segundos).

Valores devueltos

Este cursor.

Errores/Excepciones

Causa que los métodos que obtengan resutados lancen una MongoCursorTimeoutException si la obtención de los datos toma más del número de milisegundos especificados.

Ejemplos

Ejemplo #1 Ejemplo de MongoCommandCursor::timeout()

En el siguiente ejemplo, el controlador esperará 60 segundos a la primera respuesta del comando totalizador. También esperará 60 segundos cada vez que el servidor necesite ser consultado para más información.

<?php

$m = new MongoClient;
$col = $m->database->collection;

$pipeline = [ … ];

$cursor = $col->aggregateCursor( $pipeline );
$cursor->timeout( 60000 ); // para 60 segundos

foreach ( $cursor as $result ) {
   …
}

?>

Notas

Advertencia

Esto no hace que el servidor de MongoDB cancele las operaciones de ejecución larga; solamente instruye al controlador a dejar de esperar una respuesta y lanzar una MongoCursorTimeoutException después del tiempo establecido. Si fuera necesario especificar un tiempo de espera en el lado del servidor para un comando, considérese pasara la opción maxTimeMS a MongoCollection::aggregateCursor().

Ver también

  • MongoCollection::aggregateCursor() - Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor
  • MongoCursorInterface::timeout() - Establece un tiempo de espera en el lado del cliente para esta consulta
  • La opción socketTimeoutMS para MongoClient::__construct()


Comprueba si el cursor está leyendo un resultado válido

  • « MongoCommandCursor::timeout
  • Tipos »
  • PHP Manual
  • MongoCommandCursor
  • Comprueba si el cursor está leyendo un resultado válido

MongoCommandCursor::valid

(PECL mongo >=1.5.0)

MongoCommandCursor::valid — Comprueba si el cursor está leyendo un resultado válido

Descripción

public MongoCommandCursor::valid ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el resultado actual no es nulo, y false en caso contrario.

Ver también

  • Iterator::valid() - Comprueba si la posición actual es válido


Tipos

Tabla de contenidos

  • MongoId
  • MongoCode
  • MongoDate
  • MongoRegex
  • MongoBinData
  • MongoInt32
  • MongoInt64
  • MongoDBRef
  • MongoMinKey
  • MongoMaxKey
  • MongoTimestamp

MongoDB permite a los programadores guardar y consultar datos expresados tanto en los tipos básicos de PHP, los tipos compuestos (arrays, arrays asociativos, y objetos), y en media docena de clases que proporciona el driver MongoDB de PHP (para expresiones regulares, fechas, y otras aplicaciones especializadas).

Booleanos y null

true, false, y null pueden usarse tal cual.

Números

En MongoDB los números son distintos de los strings: "123" no es lo mismo que 123. Por tanto, si se desea asegurar de que los números se ordenan y comparan correctamente, debe asegurarse de que realmente se almacenan como números.

<?php

$doc = array("a" => 123, "b" => "123");
$collection->insert($doc);

$doc->find(array("a" => 123));   // coincide
$doc->find(array("a" => "123")); // no coincide
$doc->find(array("a" => 123.0)); // coincide
$doc->find(array("b" => 123));   // no coincide
$doc->find(array("b" => "123")); // coincide

?>

Como vemos, los números en coma flotante se comparan y coinciden con los números enteros tal como cabría esperar.

Números Largos

Por omisión, en sistemas de 32 bits, los números se envían a la base de datos como enteros de 32 bit. En sistemas 64 bits, se envían como enteros de 64 bit. Para guardar la compatibilidad, todos los sistemas deserializan los enteros de 64 bit como números en coma flotante. Los números en coma flotante no son exactos. Si fuera necesario usar valores exactos, habría que hacerlo ajsutando el fichero php.ini.

En sistemas de 32 bits, si mongo.long_as_object está habilitado, los enteros de 64 bit se devolverán como objetos MongoInt64. El entero se almacenará en el campo value con una precisión perfecta (como un string). MongoInt64 puede usarse también para guardar enteros de 64 bit en máquinas de 32 bits.

En sistemas de 64 bits, puede o bien habilitarse mongo.long_as_object o mongo.native_long. mongo.native_long devolverá enteros de 64 bit y enteros "normales" de PHP. MongoInt32 puede usarse para almacenar enteros de 32 bit en máquinas de 64 bits.

Debe establecerse un valor en mongo.long_as_object y en mongo.native_long de acuerdo al comportamiento que se espere, incluso en el caso de que coincida con los valores por omisión (para prevenir futuros cambios de estos valores).

Vea también: Opciones de php.ini, MongoInt32, MongoInt64.

Strings

Los strings deben ser UTF-8. Si no, o bien se convierten a UTF-8 antes de enviarse a la base de datos, o bien se almacenan como datos binarios.

Pueden usarse expresiones regulares para consultar strings, y se expresan usando la clase MongoRegex.

Datos Binarios

Tanto los textos que no son UTF-8, como las imágenes, o cualuier otro dato binario, debe enviarse a la base de datos usando el tipo MongoBinData.

Fechas

Pueden crearse fechas usando la clase MongoDate. Se almacenan como milisegundos a partir de la fecha de referencia.

MongoTimestamp no es para almacenar fechas ni timestamps, sino que se usa internamente por MongoDB. A no ser que se esté creando una herramienta que interactúe con los entresijos de réplicas o sharding, se deberá usar MongoDate, y no MongoTimestamp.

Ids Únicos

El driver creará automáticamente un campo _id antes de insertar un documento (a no ser que el usuario haya especificado uno). Este campo es una instancia de MongoId (en otros lenguajes habitualmente se le llama "ObjectId").

Estos ids se componen de 12 bytes:

  • 4 bytes de timestamp

    Dos registros no pueden tener el mismo id si se han insertado en momentos diferentes.

  • 3 bytes de id de máquina

    Dos registros no pueden tener el mismo id si se han insertado en máquinas diferentes.

  • 2 bytes de id de hebra

    Dos registros no pueden tener el mismo id si se han insertado por diferentes hebras en la misma máquina.

  • 3 bytes de valor incremental

    Cada vez que se crea un id, un contador global se incrementa, y se usa para el incremento del siguiente id.

Por tanto, dos registros no pueden tener el mismo id, a no ser que un único proceso en una misma máquina trate de insertar 256^3 (más de 16 millones) de documentos en un segundo, desbordando el campo de incremento.

JavaScript

MongoDB incorpora un motor JavaScript, de modo que se pueden incluir código JavaScript en las consultas (usando la claúsula $where), enviarlo directamente a la base de datos para ejecutarlo, y usarlo para llevar a cabo agregaciones.

Por seguridad, en MongoCode utilice el campo scope cuando vaya a usar variables PHP en JavaScript. Cuando el código no requiera de valores externos, se puede o bien usar MongoCode o símplemente un string. Revise la sección de seguridad para más información sobre cómo enviar código JavaScript a la base de datos.

Arrays y Objetos

También pueden guardarse arrays y objetos en la base de datos. Los arrays con clave numérica incremental se almacenarán como arrays. En cualquier otro caso, se almacenarán como objetos.

<?php

// $puntuaciones se almacenará como array
$puntuaciones = array(98, 100, 73, 85);
$collection->insert(array("puntuaciones" => $puntuaciones));

// $puntuaciones se almacenará como un objeto
$puntuaciones = array("pregunta1" => 98, "examen" => 100, "pregunta2" => 73, "final" => 85);
$collection->insert(array("puntuaciones" => $puntuaciones));

?>

Si consultamos estos objetos en la consola de la base de dato, obtendremos algo similar a esto:

> db.students.find()
{ "_id" : ObjectId("4b06beada9ad6390dab17c43"), "puntuaciones" : [ 98, 100, 73, 85 ] }
{ "_id" : ObjectId("4b06bebea9ad6390dab17c44"), "puntuaciones" : { "pregunta1" : 98, "examen" : 100, "pregunta2" : 73, "final" : 85 } }

La base de datos puede almacenar también objetos PHP arbitrarios (pese a que se devolverán como arrays asociativos). Los campos se usan para pares clave/valor. Por ejemplo, la entrada de un blog podría ser así:

<?php

  // clase de la entrada de un blog
  class Entrada {

  var $autor;
  var $contenido;
  var $comentarios = array();
  var $fecha;

  public function __construct($autor, $contenido) {
  $this->autor = $autor;
$this->contenido = $contenido;
    $this->fecha = new MongoDate();
  }

  public function establecerTitulo($titulo) {
    $this->titulo = $titulo;
  }
}

// crear una entrada de blog sencilla e insertarla en base de datos
$entrada1 = new Entrada("Adam", "Esto es una entrada de un blog");

$blog->insert($entrada1);

// no hay niguna restricción del tipo usado en el campo "autor", de manera que podemos
// usarlo como un objeto anidado
$autor = array("nombre" => "Fred", "karma" => 42);
$entrada2 = new Entrada($autor, "Ésta es otra entrada de blog.");

// creamos un campo más para el título
$entrada2->establecerTitulo("Segunda Entrada");

$blog->insert($entrada2);

?>

En la consola de la base de datos, lo veríamos parecido a esto:

> db.blog.find()
{ "_id" : ObjectId("4b06c263edb87a281e09dad8"), "autor" : "Adam", "contenido" : "Esto es una entrada de un blog", "comentarios" : [ ], "fecha" : "Fri Nov 20 2009 11:22:59 GMT-0500 (EST)" }
{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "autor" : { "nombre" : "Fred", "karma" : 42 }, "contenido" : "Ésta es otra entrada de blog", "comentarios" : [ ], "fecha" : "Fri Nov 20 2009 11:23:30 GMT-0500 (EST)", "titulo" : "Segunda Entrada" }

El driver no detecta referencias cíclicas en arrays ni en objetos. Por ejemplo, esto emitiría un error fatal:

<?php

$collection->insert($GLOBALS);

?>
Fatal error: Nesting level too deep - recursive dependency?
Si se necesitara insertar documentos que pudieran tener dependencias cíclicas, deberá comprobarse a mano antes de pasarlo al driver.


La clase MongoId

(PECL mongo >=0.8.0)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\ObjectID

Introducción

Identificador único creado para objetos de bases de datos. Se se inserta un objeto sin un campo _id en una base de datos , éste se añadirá con una instancia de MongoId. Si los datos tuvieran un campo único natural (p.ej., un nombre de usuario o una marca de tiempo) no habría problema en usarlo como _id, y en este caso no se reemplazaría por un MongoId.

Las instancias de MongoId cumplen la función de los campos autoincrementales de las base de datos relacionales: ofrecen una clave única cuando los datos no tienen una clave natural. Los autoincrementales no funcionan correctamente en bases de datos compartidas, ya que es difícil determinar el siguiente número de la secuencia. Esta clase establece las limitaciones necesarias para generar rápidamente un valor único entre servidores compartidos.

Cada MongoId contiene 12 bytes (componiendo un string de 24 caracteres hexadecimales). Los cuatro primeros bytes son un timestamp, los tres siguientes son un hash del nombre de máquina del cliente, los dos siguiente son los bytes menos significativos del id del proceso en ejecución del script, y los últimos tres corresponden a un valor incremental.

MongoId es serializable y deserializable. Su forma serializada es similar a su forma en string:

C:7:"MongoId":24:{4af9f23d8ead0e1d32000000}

Sinopsis de la Clase

MongoId {
public string $$id = null ;
/* Métodos */
public __construct ( string|MongoId $id = null )
public static getHostname ( ) : string
public getInc ( ) : int
public getPID ( ) : int
public getTimestamp ( ) : int
public static isValid ( mixed $value ) : bool
public static __set_state ( array $props ) : MongoId
public __toString ( ) : string
}

Campos

$id
Este campo contiene la respresentación string de este objeto.

Nota: El nombre de la propiedad comienza con un carácter $. Se podría acceder a ella empleando la sintaxis analizada de variables complejas (p.ej., $mongoId->{'$id'}).

Ver también

Documentación de MongoDB sobre » ObjectIds.

Tabla de contenidos

  • MongoId::__construct — Crea un nuevo id
  • MongoId::getHostname — Obtiene el nombre de host que se usa para el id de esta máquina
  • MongoId::getInc — Obtiene el valor incremental usado para crear este id
  • MongoId::getPID — Obtiene el ID del proceso
  • MongoId::getTimestamp — Devuelve el número de segundos desde la fecha de referencia con el que se creó este id
  • MongoId::isValid — Comprobar si un valor es un ObjectId válido
  • MongoId::__set_state — Crea un objeto MongoId trivial
  • MongoId::__toString — Devuelve la representación hexadecimal de este id


Crea un nuevo id

  • « MongoId
  • MongoId::getHostname »
  • PHP Manual
  • MongoId
  • Crea un nuevo id

MongoId::__construct

(PECL mongo >= 0.8.0)

MongoId::__construct — Crea un nuevo id

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\ObjectID::__construct()

Descripción

public MongoId::__construct ( string|MongoId $id = null )

Parámetros

id

Un string (debe ser de 24 caracteres hexadecimales) o una instancia de MongoId.

Valores devueltos

Devuelve un nuevo id.

Historial de cambios

Versión | Descripción
1.4.0 | Se lanza una excepción al proporcionar un string no válido

Ejemplos

Ejemplo #1 MongoId::__construct() example

Este ejemplo muestra cómo crear un nuevo id. Rara vez es neceasrio usar esto, ya que el controlador añade automáticamente un id a los arrays antes de almacenarlos en base de datos.

<?php

  $id1 = new MongoId();
  echo "$id1\n";

  $id2 = new MongoId();
  echo "$id2\n";

  ?>

El resultado del ejemplo sería algo similar a:

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d

Ejemplo #2 Ejemplo con parámetros

Este ejemplo muestra cómo usar un parámetro de tipo string para inicializar un MongoId con el valor proporcionado.

<?php
  $id1 = new MongoId();

  // crea un nuevo id a partir de $id1
  $id2 = new MongoId("$id1");

  // muestra que $id1 e $id2 tienen el mismo valor hexadecimal
  var_dump($id1 == $id2);
  ?>

El resultado del ejemplo sería algo similar a:

bool(true)

Ver también

  • MongoId::__toString() - Devuelve la representación hexadecimal de este id
  • MongoId::isvalid() - Comprobar si un valor es un ObjectId válido


Obtiene el nombre de host que se usa para el id de esta máquina

  • « MongoId::__construct
  • MongoId::getInc »
  • PHP Manual
  • MongoId
  • Obtiene el nombre de host que se usa para el id de esta máquina

MongoId::getHostname

(PECL mongo >= 1.0.8)

MongoId::getHostname — Obtiene el nombre de host que se usa para el id de esta máquina

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public static MongoId::getHostname ( ) : string

Devuelve el nombre de host que usa MongoId para generar identificadores únicos. Es el mismo valor que devuelve gethostname().

Es idéntico a esta función:

<?php

public static function getHostname() {
    return gethostname();
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de host.


Obtiene el valor incremental usado para crear este id

  • « MongoId::getHostname
  • MongoId::getPID »
  • PHP Manual
  • MongoId
  • Obtiene el valor incremental usado para crear este id

MongoId::getInc

(PECL mongo >= 1.0.11)

MongoId::getInc — Obtiene el valor incremental usado para crear este id

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoId::getInc ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor incremental usado para crear este MongoId.


Obtiene el ID del proceso

  • « MongoId::getInc
  • MongoId::getTimestamp »
  • PHP Manual
  • MongoId
  • Obtiene el ID del proceso

MongoId::getPID

(PECL mongo >= 1.0.11)

MongoId::getPID — Obtiene el ID del proceso

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoId::getPID ( ) : int

Extrase el PID del ID de Mongo

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el PID del MongoId.


Devuelve el número de segundos desde la fecha de referencia con el que se creó este id

  • « MongoId::getPID
  • MongoId::isValid »
  • PHP Manual
  • MongoId
  • Devuelve el número de segundos desde la fecha de referencia con el que se creó este id

MongoId::getTimestamp

(PECL mongo >= 1.0.1)

MongoId::getTimestamp — Devuelve el número de segundos desde la fecha de referencia con el que se creó este id

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoId::getTimestamp ( ) : int

Devuelve lo mismo que cuando se ejecuta time() al crear el id.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de segundos desde la fecha de referencias con el que se creó este id. Tan sólo hay cuatro bytes para almacenar el timestamp, por lo que MongoDate es una opción mejor si se desea almacenar fechas exacta de alto alcance.


Comprobar si un valor es un ObjectId válido

  • « MongoId::getTimestamp
  • MongoId::__set_state »
  • PHP Manual
  • MongoId
  • Comprobar si un valor es un ObjectId válido

MongoId::isValid

(PECL mongo >= 1.5.0)

MongoId::isValid — Comprobar si un valor es un ObjectId válido

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public static MongoId::isValid ( mixed $value ) : bool

Este método puede usarse para comprobar una variable antes de pasarla como un argumento a MongoId::__construct().

Parámetros

value

El valor a comprobar su validez.

Valores devueltos

Devuelve true si value es una instancia de MongoId o un string que consiste en exactamente 24 caracteres hexadecimales; de lo contrario devuelve false.


Crea un objeto MongoId trivial

  • « MongoId::isValid
  • MongoId::__toString »
  • PHP Manual
  • MongoId
  • Crea un objeto MongoId trivial

MongoId::__set_state

(PECL mongo >= 1.0.8)

MongoId::__set_state — Crea un objeto MongoId trivial

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public static MongoId::__set_state ( array $props ) : MongoId

Esta función sólo la utiliza PHP internamente, no debería ser necesario que sea llamada por el usuario.

Es idéntica a la función:

<?php

public static function __set_state($props) {
    return new MongoId("000000000000000000000000");
}

?>

Parámetros

props

En teoría, un array de propiedades utilizado para crear el nueva ID. Sin embargo, ya que las instancias de MongoId no tienen propiedades, no se utiliza.

Valores devueltos

Un nuevo ID con el valor "000000000000000000000000".


Devuelve la representación hexadecimal de este id

  • « MongoId::__set_state
  • MongoCode »
  • PHP Manual
  • MongoId
  • Devuelve la representación hexadecimal de este id

MongoId::__toString

(PECL mongo >= 0.8.0)

MongoId::__toString — Devuelve la representación hexadecimal de este id

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\ObjectID::__toString()

Descripción

public MongoId::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este id.

Ejemplos

Ejemplo #1 Ejemplo de MongoId::__toString()

<?php

$m = new MongoClient();
$collection = $m->selectDB("foo")->selectCollection("bar");

$collection->insert(array( "x" => "y" ));
$collection->insert(array( "x" => "y" ));

$cursor = $collection->find();
$r1 = $cursor->next();
$r2 = $cursor->next();

echo $r1["_id"] . "\n";
echo $r2["_id"] . "\n";

?>

El resultado del ejemplo sería algo similar a:

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d


La clase MongoCode

(PECL mongo >=0.8.3)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\JavaScript

Introducción

Representa código JavaScript para la base de datos.

Los objetos MongoCode se componen de dos partes: el texto del código y un ámbito opcional. El texto del código debe ser JavaScript válido. El ámbito es un array asociativo de pares nombre/valor.

Sinopsis de la Clase

MongoCode {
/* Métodos */
public __construct ( string $code , array $scope = array() )
public __toString ( ) : string
}

Tabla de contenidos

  • MongoCode::__construct — Crea un nuevo objeto de código
  • MongoCode::__toString — Devuelve este código en forma de texto


Crea un nuevo objeto de código

  • « MongoCode
  • MongoCode::__toString »
  • PHP Manual
  • MongoCode
  • Crea un nuevo objeto de código

MongoCode::__construct

(PECL mongo >= 0.8.3)

MongoCode::__construct — Crea un nuevo objeto de código

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\JavaScript::__construct()

Descripción

public MongoCode::__construct ( string $code , array $scope = array() )

Parámetros

code

Texto del código.

scope

Ámbito que se usará para este código.

Valores devueltos

Devuelve un nuevo objeto de código.

Ejemplos

Ejemplo #1 Ejemplo de MongoCode::__construct()

<?php

$code = new MongoCode('function() { '.
    'for(i=0;i<10;i++) {'.
        'db.foo.update({z : i}, {z : x});'.
    '}'.
    'return x-1;'.
 '}', array("x" => 4));
var_dump($code);

?>

El resultado del ejemplo sería algo similar a:

object(MongoCode)#1 (2) {
  ["scope"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["code"]=>
  string(80) "function() { for(i=0;i<10;i++) { db.foo.update({z : i}, {z : x}); } return x-1; }"
}

Ejemplo #2 Usando MongoCode con $where

Este ejemplo consulta la colección de elementos cuyos campos 'x' valgan menos que $y. Tenga en cuenta que se pasan objetos PHP al ámbito de JavaScript y que la función JavaScript devuelve un booleano.

<?php

$cursor = $collection->find(array('$where' => new MongoCode('function() { return this.x < y; }', array('y'=>$y))));

?>


Devuelve este código en forma de texto

  • « MongoCode::__construct
  • MongoDate »
  • PHP Manual
  • MongoCode
  • Devuelve este código en forma de texto

MongoCode::__toString

(PECL mongo >= 0.8.3)

MongoCode::__toString — Devuelve este código en forma de texto

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. No hay equivalente para este método en la nueva extensión.

Descripción

public MongoCode::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este código. No se devuelve el ámbito.

Ejemplos

Ejemplo #1 Ejemplo de MongoCode::__toString()

<?php

$code = new MongoCode('return x;', array("x"=>"hi"));
echo "$code\n";

$code = new MongoCode('function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }');
echo "$code\n";

?>

El resultado del ejemplo sería algo similar a:

return x;
function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }


La clase MongoDate

(PECL mongo >=0.8.1)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\UTCDateTime

Introducción

Representa objetos de tipo fecha para la base de datos. Esta clase debe usarse para almacenar fechas en la base de datos y para consultarlas. Por ejemplo:

Ejemplo #1 Almacenar datos con MongoDate

<?php

// guardar una fecha en base de datos
$collection->save(array("ts" => new MongoDate()));

$start = new MongoDate(strtotime("2010-01-15 00:00:00"));
$end = new MongoDate(strtotime("2010-01-30 00:00:00"));

// encontrar fechas entre 1/15/2010 y 1/30/2010
$collection->find(array("ts" => array('$gt' => $start, '$lte' => $end)));

?>

MongoDB almacena fechas en milisegundos tras la fecha de referencia. Esto significa que las fechas no contienen información de zonas horarias. Si fuera necesario, la zona horaria deberá ser almacenada en otro campo. Además, esto significa que cualquier nivel de precisión más allá de milisegundos se perderá al leer o escribir en la base de datos.

Sinopsis de la Clase

MongoDate {
/* Campos */
public int $sec ;
public int $usec ;
/* Métodos */
public __construct ( int $sec = time() , int $usec = 0 )
public toDateTime ( ) : DateTime
public __toString ( ) : string
}

Tabla de contenidos

  • MongoDate::__construct — Crea una nueva fecha
  • MongoDate::toDateTime — Devuelve un objeto DateTime que representa esta fecha
  • MongoDate::__toString — Devuelve una representación en forma de texto de esta fecha


Crea una nueva fecha

  • « MongoDate
  • MongoDate::toDateTime »
  • PHP Manual
  • MongoDate
  • Crea una nueva fecha

MongoDate::__construct

(PECL mongo >= 0.8.1)

MongoDate::__construct — Crea una nueva fecha

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\UTCDateTime::__construct()

Descripción

public MongoDate::__construct ( int $sec = time() , int $usec = 0 )

Crea una nueva fecha. Si no se proporciona ningún parámetro, se utilizará la hora actual.

Parámetros

sec

Número de segundos desde la época (es decir, 1 enero 1970 00:00:00.000 UTC).

usec

Microsegundos. Por favor, tenga en cuenta que la resolución de MongoDB es milisegundos y no microsegundos, lo que significa que este valor será truncado a la resolución de milisegundos.

Valores devueltos

Devuelve esta nueva fecha.

Ejemplos

Ejemplo #1 Ejemplo de MongoDate::__construct()

Este ejemplo muestra cómo crear una nueva fecha con la hora actual y una nueva fecha con la hora proporcionada.

<?php

$f = new MongoDate();
echo "$f\n";
$f = new MongoDate(1234567890);
echo "$f\n";
$f = new MongoDate(strtotime("2009-05-01 00:00:01"));
echo "$f\n";

?>

El resultado del ejemplo sería algo similar a:

0.23660600 1235685067
0.00000000 1234567890
0.00000000 1241150401

Ver también

  • MongoDate::__toString() - Devuelve una representación en forma de texto de esta fecha


Devuelve un objeto DateTime que representa esta fecha

  • « MongoDate::__construct
  • MongoDate::__toString »
  • PHP Manual
  • MongoDate
  • Devuelve un objeto DateTime que representa esta fecha

MongoDate::toDateTime

(PECL mongo >= 1.6.0)

MongoDate::toDateTime — Devuelve un objeto DateTime que representa esta fecha

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\UTCDateTime::toDateTime()

Descripción

public MongoDate::toDateTime ( ) : DateTime

Devuelve una representación de un objeto DateTime de esta fecha.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto DateTime con esta fecha.

Ejemplos

Ejemplo #1 Ejemplo de MongoDate::toDateTime()

Este ejemplo demuestra la creación de un objeto DateTime desde un objeto MongoDate.

<?php
$d = new MongoDate(strtotime("2014-11-18 11:01:25"));
var_dump( $d->toDateTime() );
?>

El resultado del ejemplo sería algo similar a:

class DateTime#2 (3) {
  public $date =>
  string(26) "2014-11-18 11:01:25.000000"
  public $timezone_type =>
  int(1)
  public $timezone =>
  string(6) "+00:00"
}


Devuelve una representación en forma de texto de esta fecha

  • « MongoDate::toDateTime
  • MongoRegex »
  • PHP Manual
  • MongoDate
  • Devuelve una representación en forma de texto de esta fecha

MongoDate::__toString

(PECL mongo >= 0.8.1)

MongoDate::__toString — Devuelve una representación en forma de texto de esta fecha

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\UTCDateTime::__toString()

Descripción

public MongoDate::__toString ( ) : string

Devuelve una representación en forma de texto de esta fecha, similar a la representación que devuelve microtime().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta fecha.


La clase MongoRegex

(PECL mongo >=0.8.1)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\Regex

Introducción

Esta clase se puede emplear para crear expresiones regulares. Normalmente, estas expresiones se usarán para consultar la base de datos y encontrar textos coincidentes. Con menos frecuencia, se pueden almacenar en la base de datos para su posterior obtención.

Las expresiones regulares consisten en cuatro partes. La primera, un / como delimitiador de inicio, después el patrón, otro / y, por último, un string que contiene indicadores.

Ejemplo #1 Patrón de una expresión regular

/patrón/banderas

MongoDB reconoce seis indicadores para expresiones regulares:

  • i: No considerar mayúsculas/minúsculas

  • m: Multilínea

  • x: Puede contener comentarios

  • l: configuración regional

  • s: "." coincidirá con todo, incluyendo nuevas líneas

  • u: coincidir con unicode

Sinopsis de la Clase

MongoRegex {
/* Campos */
public string $regex ;
public string $flags ;
/* Métodos */
public __construct ( string $regex )
public __toString ( ) : string
}

Tabla de contenidos

  • MongoRegex::__construct — Crea una nueva expresión regular
  • MongoRegex::__toString — Representación en forma de texto de esta expresión regular


Crea una nueva expresión regular

  • « MongoRegex
  • MongoRegex::__toString »
  • PHP Manual
  • MongoRegex
  • Crea una nueva expresión regular

MongoRegex::__construct

(PECL mongo >= 0.8.1)

MongoRegex::__construct — Crea una nueva expresión regular

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Regex::__construct()

Descripción

public MongoRegex::__construct ( string $regex )

Crea una nueva expresión regular.

Parámetros

regex

Texto de la expresión regular, con la forma /expresión/banderas.

Valores devueltos

Devuelve una nueva expresión regular.

Ejemplos

Ejemplo #1 Ejemplo de MongoRegex::__construct()

Este ejemplo usa una expresión regular para consultar todos los documentos con un campo de nombre de usuario que empieza con (^) con una l y una vocal ([aeiouy]), insensible a mayúsculas/minúsculas (/i).

<?php
$buscar_luis = new MongoRegex("/^l[aeiouy]/i");
$cursor = $collection->find(array("usuario" => $buscar_luis));
?>

Ver también

  • MongoRegex::__toString() - Representación en forma de texto de esta expresión regular


Representación en forma de texto de esta expresión regular

  • « MongoRegex::__construct
  • MongoBinData »
  • PHP Manual
  • MongoRegex
  • Representación en forma de texto de esta expresión regular

MongoRegex::__toString

(PECL mongo >= 0.8.1)

MongoRegex::__toString — Representación en forma de texto de esta expresión regular

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Regex::__toString()

Descripción

public MongoRegex::__toString ( ) : string

Devuelve la representación en forma de texto de esta expresión regular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta expresión regular en la forma "/expresión/banderas".

Ejemplos

Ejemplo #1 Ejemplo de MongoRegex::__toString()

<?php

$r = new MongoRegex( "/[a-fA-F0-9]{16}/g" );
echo $r->regex . "\n";
echo $r->flags . "\n";
echo "$r\n";

?>

El resultado del ejemplo sería algo similar a:

[a-fA-F0-9]{16}
g
/[a-fA-F0-9]{16}/g


La clase MongoBinData

(PECL mongo >= 0.8.1)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\Binary

Introducción

Un objeto que se puede usar para almacenar y obtener datos binarios de la base de datos.

El tamaño máximo de un objeto que puede insertarse en la base de datos es de 16 MB. Para datos mayores (películas, música, la autobiografía de Henry Kissinger), utilice MongoGridFS. Para datos menores a 16 MB, sería más sencillo embeberlos en el documento utilizando MongoBinData.

Por ejemplo, para embeber una imagen en un documento, se podría escribir:

<?php

$profile = array(
    "username" => "foobity",
    "pic" => new MongoBinData(file_get_contents("gravatar.jpg"), MongoBinData::GENERIC),
);

$users->save($profile);

?>

Esta clase contiene un campo type, que actualmente no proporciona ninguna funcionalidad al controlador de PHP o a la base de datos. Hay 7 tipos predefinidos, los cuales están definidos más abajo como constantes de clase. Para respetar la retrocompatibilidad, el controlador de PHP utiliza MongoBinData::BYTE_ARRAY como el predeterminado; sin embargo, podría cambiar a MongoBinData::GENERIC en el futuro. Se anima a los usuarios a especificar un tipo en MongoBinData::__construct().

Sinopsis de la Clase

MongoBinData {
/* Constantes */
const int GENERIC = 0 ;
const int FUNC = 1 ;
const int BYTE_ARRAY = 2 ;
const int UUID = 3 ;
const int UUID_RFC4122 = 4 ;
const int MD5 = 5 ;
const int CUSTOM = 128 ;
/* Fields */
public string $bin ;
public int $type = 2 ;
/* Métodos */
public __construct ( string $data , int $type = 0 )
public __toString ( ) : string
}

Constantes predefinidas

Tipos de datos binarios

MongoBinData::GENERIC
0x00
Datos binarios genéricos.
MongoBinData::FUNC
0x01
Función.
MongoBinData::BYTE_ARRAY
0x02
Datos binarios genéricos (obsoleta a favor de MongoBinData::GENERIC).
MongoBinData::UUID
0x03
Identificador único universal (obsoleta en favor de MongoBinData::UUID_RFC4122).
MongoBinData::UUID_RFC4122
0x04
Identificador único universal (de acuerdo a la » RFC 4122).
MongoBinData::MD5
0x05
MD5.
MongoBinData::CUSTOM
0x80
Tipo definido por el usuario.

Historial de cambios

Versión | Descripción
1.5.0 | Se añadieron las constantes MongoBinData::GENERIC y MongoBinData::UUID_RFC4122.

Tabla de contenidos

  • MongoBinData::__construct — Crea un nuevo objeto de datos binarios
  • MongoBinData::__toString — Representación en forma de string de este objeto de datos binarios


Crea un nuevo objeto de datos binarios

  • « MongoBinData
  • MongoBinData::__toString »
  • PHP Manual
  • MongoBinData
  • Crea un nuevo objeto de datos binarios

MongoBinData::__construct

(PECL mongo >= 0.8.1)

MongoBinData::__construct — Crea un nuevo objeto de datos binarios

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Binary::__construct()

Descripción

public MongoBinData::__construct ( string $data , int $type = 0 )

Crea un nuevo objeto de datos binarios.

Existen siete tipos de datos binarios que acutalmente están reconocidos por la especificación BSON, los cuales están definidos como constantes de clase. Para respetar la retrocompatibilidad, el controlador de PHP utiliza MongoBinData::BYTE_ARRAY como la predeterminada; sin embargo, podría cambiar a MongoBinData::GENERIC en el futuro. Se anima a los usuarios a especificar un tipo en lugar de confiar en el predeterminado.

Parámetros

data

Datos binarios.

type

Tipo de datos.

Valores devueltos

Devuelve un nuevo objeto de datos binarios.

Historial de cambios

Versión | Descripción
1.5.0 | Se cambió el valor predeterminado de 2 (MongoBinData::BYTE_ARRAY) a 0 (MongoBinData::GENERIC).
1.2.11 | Emite un error de nivel E_DEPRECATED cuando no se utiliza el segundo argumento. El valor predeterminado de type podría cambiar en un futuro próximo.


Representación en forma de string de este objeto de datos binarios

  • « MongoBinData::__construct
  • MongoInt32 »
  • PHP Manual
  • MongoBinData
  • Representación en forma de string de este objeto de datos binarios

MongoBinData::__toString

(PECL mongo >= 0.8.1)

MongoBinData::__toString — Representación en forma de string de este objeto de datos binarios

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Binary::getData()

Descripción

public MongoBinData::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el string "<Mongo Binary Data>". Para acceder al contenido de un MongoBinData, utilice el campo bin.


La clase MongoInt32

(PECL mongo >=1.0.9)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado dependiendo del valor del entero.

Introducción

Esta clase se puede usar para guardar enteros de 32 bits en bases de datos de sistemas a 64 bits.

Sinopsis de la Clase

MongoInt32 {
/* Campos */
public string $value ;
/* Métodos */
public __construct ( string $value )
public __toString ( ) : string
}

Campos

value
Este es el valor en forma de texto del número de 32 bits. Por ejemplo, el valor de 123 sería "123".

Tabla de contenidos

  • MongoInt32::__construct — Crea un nuevo entero de 32 bits
  • MongoInt32::__toString — Devuelve al representación en forma de string de este entero de 32 bits


Crea un nuevo entero de 32 bits

  • « MongoInt32
  • MongoInt32::__toString »
  • PHP Manual
  • MongoInt32
  • Crea un nuevo entero de 32 bits

MongoInt32::__construct

(PECL mongo >= 1.0.9)

MongoInt32::__construct — Crea un nuevo entero de 32 bits

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado según el valor del entero.

Descripción

public MongoInt32::__construct ( string $value )

Crea un nuevo número de 32 bits con el valor proporcionado.

Parámetros

value

Un número.

Valores devueltos

Devuelve un nuevo entero.


Devuelve al representación en forma de string de este entero de 32 bits

  • « MongoInt32::__construct
  • MongoInt64 »
  • PHP Manual
  • MongoInt32
  • Devuelve al representación en forma de string de este entero de 32 bits

MongoInt32::__toString

(PECL mongo >= 1.0.9)

MongoInt32::__toString — Devuelve al representación en forma de string de este entero de 32 bits

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado según el valor del entero.

Descripción

public MongoInt32::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación en forma de string de este entero.


La clase MongoInt64

(PECL mongo >=1.0.9)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado dependiendo del valor del entero.

Introducción

Esta clase se puede usar para guardar enteros de 64 bits en bases de datos en sistemas de 32 bits.

Sinopsis de la Clase

MongoInt64 {
/* Campos */
public string $value ;
/* Métodos */
public __construct ( string $value )
public __toString ( ) : string
}

Campos

value
Este es el valor en forma de texto del número de 64 bits. Por ejemplo, el valor de 123 sería "123".

Tabla de contenidos

  • MongoInt64::__construct — Crea un nuevo entero de 64 bits
  • MongoInt64::__toString — Devuelve la representación en forma de texto de este entero de 64 bits


Crea un nuevo entero de 64 bits

  • « MongoInt64
  • MongoInt64::__toString »
  • PHP Manual
  • MongoInt64
  • Crea un nuevo entero de 64 bits

MongoInt64::__construct

(PECL mongo >= 1.0.9)

MongoInt64::__construct — Crea un nuevo entero de 64 bits

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado según el valor del entero.

Descripción

public MongoInt64::__construct ( string $value )

Crea un nuevo número de 64 bits con el valor proporcionado.

Parámetros

value

Un número.

Valores devueltos

Devuelve un nuevo entero.


Devuelve la representación en forma de texto de este entero de 64 bits

  • « MongoInt64::__construct
  • MongoDBRef »
  • PHP Manual
  • MongoInt64
  • Devuelve la representación en forma de texto de este entero de 64 bits

MongoInt64::__toString

(PECL mongo >= 1.0.9)

MongoInt64::__toString — Devuelve la representación en forma de texto de este entero de 64 bits

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

En su lugar, la nueva extensión elige el tipo de base de datos apropiado según el valor del entero.

Descripción

public MongoInt64::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la representación en forma de texto de este entero.


La clase MongoDBRef

(PECL mongo >=0.9.0)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

El concepto de referencias de bases de datos, y por consiguiente esta clase, están obsoletos en la base de datos.

Introducción

Esta clase puede usarse para crear enlaces ligeros entre objetos de diferencias colecciones.

Motivación: Supongamos que necesitamos referirnos a un documento en otra colección. La forma más fácil es crear un nuevo campo en el documento actual. Por ejemplo, si tenemos una colección "personas" y una colección "direcciones", quizás queramos crear un enlace entre cada documento de persona y un documento de dirección:

Ejemplo #1 Vincular documentos

<?php

$personas = $db->personas;
$direcciones = $db->direcciones;

$miDireccion = array("linea 1" => "Calle Mayor, 123",
    "linea 2" => null,
    "ciudad" => "Springfield",
    "estado" => "Vermont",
    "pais" => "USA");

// guardamos la direccion
$direcciones->insert($miDireccion);

// guardar una persona con una referencia a la direccion
$yo = array("nombre" => "Fred", "direccion" => $miDireccion['_id']);
$personas->insert($yo);

?>

Posteriormente podremos encontrar la dirección de la persona consultando la colección "direcciones" con el MongoId que almacenamos en la colección "personas".

Supongamos ahora que tenemos un caso más general, donde no sabemos qué colección (o incluso qué base de datos) contiene el documento referenciado. MongoDBRef es una buena elección para estos casos, ya que es un formato común que todos los drivers y bases de datos podrán interpretar.

Si cada persona tuviera una lista de cosas que les gusta, y éstas pudieran venir a partir de varias colecciones, como "hobbies", "deportes", "libros", etc., podríamos usar MongoDBRef para seguir la pista de con qué colección se asocia cada gusto:

Ejemplo #2 Crear vínculos MongoDBRef

<?php

$personas = $db->selectCollection("personas");

// modelismo ferroviario está en la colección "hobbies"
$ferroRef = MongoDBRef::create("hobbies", $modelismoFerroviario['_id']);
// fútbol está en la colección "deportes"
$futbolRef = MongoDBRef::create("deportes", $futbol['_id']);

// ahora, cuando consultemos el documento, sabremos a qué colección
// pertenecen cada ítem de "gustos"
$personas->insert(array("nombre" => "Fred", "gustos" => array($ferroRef, $futbolRef)));

?>

Las referencias a bases de datos se pueden concebir como hipervínculos: proporcionan una dirección única a otro documento, pero no cargan ni redirigen automáticamente al enlace/referencia.

Una referencia a una base de datos es un array asociativo, no una instancia de MongoDBRef, de modo que esta clase es ligeramente diferente al resto de clases de tipos de datos. Esta clase contiene únicamente métodos estáticos para poder manipular las referencias a bases de datos.

Sinopsis de la Clase

MongoDBRef {
/* Métodos */
public static create ( string $collection , mixed $id , string $database = ? ) : array
public static get ( MongoDB $db , array $ref ) : array
public static isRef ( mixed $ref ) : bool
}

Ver también

Documentación de MongoDB sobre » referencias a bases de datos.

Tabla de contenidos

  • MongoDBRef::create — Crea una nueva referencia de base de datos
  • MongoDBRef::get — Captura el objeto al que apunta la referencia
  • MongoDBRef::isRef — Comprueba si un array es una referencia en la base de datos


Crea una nueva referencia de base de datos

  • « MongoDBRef
  • MongoDBRef::get »
  • PHP Manual
  • MongoDBRef
  • Crea una nueva referencia de base de datos

MongoDBRef::create

(PECL mongo >= 0.9.0)

MongoDBRef::create — Crea una nueva referencia de base de datos

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

El concepto de referencia de base de dato, y por consiguiente esta clase, están obsoletos.

Descripción

public static MongoDBRef::create ( string $collection , mixed $id , string $database = ? ) : array

Si no se especifica ninguna base de datos, se utiliza la actual.

Parámetros

collection

Nombre de la colección (sin el nombre de la base de datos).

id

Campo _id del objeto al que enlazar.

database

Nombre de la base de datos.

Valores devueltos

Devuelve la referencia.

Ejemplos

Ejemplo #1 Ejemplo de MongoDBRef::create()

Crea una referencia de base de datos a un documento en la colección addresses. La función MongoCollection::getName() devuelve el nombre de la colección (sin incluir el nombre de la base de datos).

<?php
$addresses = $db->addresses;
$people = $db->people;

// guardar $address para que así tenga un _id
$addresses->insert($address);

// creamos una referencia
$ref = MongoDBRef::create($addresses->getName(), $address['_id']);

// asignamos el campo a $person
$person['address'] = $ref;
$people->save($person);
?>

Ver también

  • MongoDB::createDBRef() - Crea una referencia a base de datos
  • MongoCollection::createDBRef() - Crea una referencia a una base de datos


Captura el objeto al que apunta la referencia

  • « MongoDBRef::create
  • MongoDBRef::isRef »
  • PHP Manual
  • MongoDBRef
  • Captura el objeto al que apunta la referencia

MongoDBRef::get

(PECL mongo >= 0.9.0)

MongoDBRef::get — Captura el objeto al que apunta la referencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

El concepto de referencia de base de dato, y por consiguiente esta clase, están obsoletos.

Descripción

public static MongoDBRef::get ( MongoDB $db , array $ref ) : array

Parámetros

db

Base de datos a usar.

ref

Referencia a capturar.

Valores devueltos

Devuelve el documento al que referencia o null si el documento no existe (la referencia está rota).

Ejemplos

Ejemplo #1 Ejemplo de MongoCollection::createDBRef()

<?php

// extraemos $person de la base de datos
$persona = $gente->findOne();

// obtenemos la dirección
$direccion = MongoDBRef::get($gente->db, $persona['direccion']);

?>

Ver también

  • MongoDB::getDBRef() - Captura el documento que está siendo apuntado por una referencia de base de datos
  • MongoCollection::getDBRef() - Captura el documento al que apunta una referencia de base de datos


Comprueba si un array es una referencia en la base de datos

  • « MongoDBRef::get
  • MongoMinKey »
  • PHP Manual
  • MongoDBRef
  • Comprueba si un array es una referencia en la base de datos

MongoDBRef::isRef

(PECL mongo >= 0.9.0)

MongoDBRef::isRef — Comprueba si un array es una referencia en la base de datos

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. No existe un equivalente para esta clase en la nueva extensión.

El concepto de referencia de base de dato, y por consiguiente esta clase, están obsoletos.

Descripción

public static MongoDBRef::isRef ( mixed $ref ) : bool

Este método realmente no sigue las referencias, por lo que no sirve para determinar si una referencia está o no rota. Tan solo comprueba que ref está en el formato válido de referencias de bases de datos (objeto o array con los campos $ref y $id).

Parámetros

ref

Array u objeto a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


La clase MongoMinKey

(PECL mongo >= 1.0.2)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\MinKey

Introducción

MongoMinKey es un tipo especial empleado por la base de datos que se evalúa menor que todos los demás valores BSON posibles. Así, si una consulta está ordenada ascendentemente por un campo, cualquier documento con un MongoMinKey como su valor será devuelto el primero.

MongoMinKey no tiene campos asociados, métodos, o constantes. Es meramente el valor "más pequeño" que se puede representar en la base de datos.

Nota: MongoMinKey se utilizar internamente en MongoDB para indexar y fragmentar. Generalmente, no existe razón para utilizar esta clase en una aplicación.

Sinopsis de la Clase

MongoMinKey {
}

Usando MongoMinKey como valor

<?php

$collection->insert(array("task" => "lunch", "doBy" => new MongoMinKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

El cursor devolverá el documento 'lunch' seguido del documento 'staff meeting'. El documento 'lunch' siempre será devuelto el primero, independientemente de lo que se añada a la colección (a menos que otros documentos se añadan con MongoMinKey en su campo "doBy").

Ver también

  • MongoMaxKey


La clase MongoMaxKey

(PECL mongo >= 1.0.2)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\MaxKey

Introducción

MongoMaxKey es un tipo especial empleado por la base de datos que se evalúa mayor que todos los demás valores BSON posibles. Así, si una consulta está ordenada ascendentemente por un campo, cualquier documento con un MongoMinKey como su valor será devuelto el último.

MongoMaxKey no tiene campos asociados, métodos, o constantes. Es meramente el valor "más grande" que se puede representar en la base de datos.

Nota: MongoMaxKey se utilizar internamente en MongoDB para indexar y fragmentar. Generalmente, no existe razón para utilizar esta clase en una aplicación.

Sinopsis de la Clase

MongoMaxKey {
}

Usando MongoMaxKey como valor

<?php

$collection->insert(array("task" => "dishes", "doBy" => new MongoMaxKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

El cursor devolverá el documento 'staff meeting' seguido del documento 'dishes'. El documento 'dishes' siempre será devuelto el último, independientemente de lo que se añada a la colección (a menos que otros documentos se añadan con MongoMaxKey en su campo "doBy").

Ver también

  • MongoMinKey


La clase MongoTimestamp

(PECL mongo >=1.0.1)

Advertencia

Esta extensión que define esta clase está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a esta clase son:

  • MongoDB\BSON\Timestamp

Introducción

MongoTimestamp es un tipo interno empleado por MongoDB para la replicación y fragmentación. Consiste en una marca temporal (es decir, segundos desde la época) de 4 bytes y un incremento de 4 bytes. Este tipo no está pensado para almacenar valores de horas o fechas (p.ej., un campo "creadoEn" de un documento).

Nota: A menos que se esté escribiendo una aplicación que interactue con el registro de operaciones de replicación o con los componentes de fragmentación de MongoDB: pare, vaya directamente a MongoDate, sin pasar por la casilla de salida y sin cobrar 200 dólares. Esta no es la clase que está buscando.

Sinopsis de la Clase

MongoTimestamp {
/* Campos */
public int $sec = 0 ;
public int $inc = 0 ;
/* Métodos */
public __construct ( int $sec = time() , int $inc = ? )
public __toString ( ) : string
}

Tabla de contenidos

  • MongoTimestamp::__construct — Crea una nueva marca temporal
  • MongoTimestamp::__toString — Devuelve la representación en forma de texto de este timestamp


Crea una nueva marca temporal

  • « MongoTimestamp
  • MongoTimestamp::__toString »
  • PHP Manual
  • MongoTimestamp
  • Crea una nueva marca temporal

MongoTimestamp::__construct

(PECL mongo >= 1.0.1)

MongoTimestamp::__construct — Crea una nueva marca temporal

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Timestamp::__construct()

Descripción

public MongoTimestamp::__construct ( int $sec = time() , int $inc = ? )

Crea una nueva marca temporal. Si no se rellenan los parámetros, se usa la hora actual con incremento automático. El incremento se establece a 0 cuando se carga el módulo, y se incrementa cada vez que se invoca a este constructor (cuando no se rellene el parámetro $inc).

Parámetros

sec

Número de segundos desde la época (es decir, 1 enero 1970 00:00:00.000 UTC).

inc

Incremento.

Valores devueltos

Devuelve la nueva marca temporal.

Ver también

  • MongoTimestamp::__toString() - Devuelve la representación en forma de texto de este timestamp


Devuelve la representación en forma de texto de este timestamp

  • « MongoTimestamp::__construct
  • Clases de GridFS »
  • PHP Manual
  • MongoTimestamp
  • Devuelve la representación en forma de texto de este timestamp

MongoTimestamp::__toString

(PECL mongo >= 1.0.1)

MongoTimestamp::__toString — Devuelve la representación en forma de texto de este timestamp

Esta extenisón que define este método está obsoleta. En su lugar debe usarse la extensión MongoDB. Las alternativas a este método son:

  • MongoDB\BSON\Timestamp::__toString()

Descripción

public MongoTimestamp::__toString ( ) : string

Devuelve el campo "sec" del timestamp.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los segundos desde la fecha de referencia que rerpesenta este timestamp.


  • « MongoTimestamp::__toString
  • MongoGridFS »
  • PHP Manual
  • Mongo
  • Clases de GridFS

Clases de GridFS

Tabla de contenidos

  • MongoGridFS
  • MongoGridFSFile
  • MongoGridFSCursor


Clase MongoGridFS

(PECL mongo >=0.9.0)

Introducción

Utilidad para almacenar y extraer ficheros de la base de datos.

GridFS es una especificación de almacenamiento que implementan todos los drivers soportados. En resumen, define dos colecciones: files, para los metadatos del fichero, y chunks, para el contenido del fichero. Si el fichero fuera de gran tamaño, automáticamente se dividiría en porciones menores, y cada bloque se guardará como un documento en la colección de bloques.

Cada documento de la colección de ficheros contiene el nombre de fichero, fecha de subida, y un código hash md5. También contiene un campo único _id, que se puede utilizar para consultar el contenido del fichero en la colección de bloques. Cada documento de la colección de bloques contiene un bloque de datos binarios, un campo files_id que se corresponde con el _id de su fichero, y la posición de este bloque respecto a los demás.

Por ejemplo, el documento de ficheros podría ser algo tal que así:

<?php
array("_id" => 123456789, "filename" => "foo.txt", "chunkSize" => 3, "length" => 12);
?>
mientras que los documentos de bloques:
<?php
array("files_id" => 123456789, "n" => 0, "data" => new MongoBinData("abc"));
array("files_id" => 123456789, "n" => 1, "data" => new MongoBinData("def"));
array("files_id" => 123456789, "n" => 2, "data" => new MongoBinData("ghi"));
array("files_id" => 123456789, "n" => 3, "data" => new MongoBinData("jkl"));
?>
Por supuesto, el tamaño por omisión de los bloques es de miles de bytes, pero eso lo haría un ejemplo impracticable.

Compatibilidad Entre Lenguajes

Se puede usar cualquier fichero creado con MongoGridFS con cualquier otro driver y viceversa. Sin embargo, algunos drivers esperan que todos los metadatos asociados con un fichero se encuentren en el campo "metadata". Si se preve que se utilizará con otros lenguajes, es una buena idea empaquetar en un campo "metadata" toda la información que se desee que vean. Por ejemplo, en lugar de:

<?php

$grid->storeFile("algunfichero.txt", array("date" => new MongoDate()));

?>

utilice algo así:

<?php

$grid->storeFile("algunfichero.txt", array("metadata" => array("date" => new MongoDate())));

?>

La Familia MongoGridFS

MongoGridFS representa los ficheros y las colecciones de bloques. MongoGridFS hereda MongoCollection. Las instancias de MongoGridFS tienen acceso a todos los métodos de MongoCollection, que actúan sobre las colecciones de ficheros:

<?php

$grid = $db->getGridFS();
$grid->update(array("filename" => "foo"), $newObj); // actualización en la colección de ficheros

?>

Otro ejemplo de manipulación de metadatos:

<?php

// guardar un fichero
$id = $grid->storeFile("juego.tgz");
$juego = $grid->findOne();

// añadir un contador de descargas
$juego->file['descargas'] = 0;
$grid->save($juego->file);

// incrementar el contador
$grid->update(array("_id" => $id), array('$inc' => array("descargas" => 1)));

?>

Se puede también acceder a los bloques de una colección a partir de una instancia de MongoGridFS:

<?php

  $chunks = $grid->chunks; // $chunks es un MongoCollection normal
$chunks->insert(array("x" => 4));

?>

Hay algunos métodos de MongoGridFS que comparten nombres con métodos de MongoCollection, pero que se comportan de un modo ligeramente diferente. Por ejemplo, MongoGridFS::remove() eliminará cualquier objeto, junto con su contenido en la colección de bloques, cuando se cumplan los criterios de la colección de ficheros.

Para almacenar cualquier otra cosa en GridFS, hay varias opciones. Si se tuviera un nombre de fichero, se podría hacer:

<?php

$grid->storeFile($filename, array("cualquier" => "metadato", "que" => "desee"));

?>

Si se tuviera un string de bytes que no fuera un fichero, se podrá tambien almacenar usando MongoGridFS::storeBytes():

<?php

$grid->storeBytes($bytes, array("cualquier" => "metadato", "que" => "desee"));

?>

Al consultar a una colección MongoGridFS, se devolverá un MongoGridFSCursor, que se comporta como un MongoCursor convencional, excepto que devuelve un MongoGridFSFiles en lugar de una matriz asociativa.

MongoGridFSFiles puede volver a escribirse en disco usando MongoGridFSFile::write(), o en memoria usando MongoGridFSFile::getBytes(). Actualmente no existe ningún método que cree automáticamente un flujo de bloques, pero resulta muy sencillo hacer escrituras realizando consultas a la colección $grid->chunks.

El objeto MongoGridFSFile contiene un campo file (fichero) que contiene cualquier metadato del fichero.

Sinopsis de la Clase

extends MongoCollection {
/* Campos */
public MongoCollection $chunks = null ;
protected string $filesName = null ;
protected string $chunksName = null ;
/* Métodos */
public __construct ( MongoDB $db , string $prefix = "fs" , mixed $chunks = "fs" )
public delete ( mixed $id ) : bool|array
public drop ( ) : array
public find ( array $query = array() , array $fields = array() ) : MongoGridFSCursor
public findOne ( mixed $query = array() , mixed $fields = array() ) : MongoGridFSFile
public get ( mixed $id ) : MongoGridFSFile
public put ( string $filename , array $metadata = array() , array $options = array() ) : mixed
public remove ( array $criteria = array() , array $options = array() ) : bool|array
public storeBytes ( string $bytes , array $metadata = array() , array $options = array() ) : mixed
public storeFile ( string|resource $filename , array $metadata = array() , array $options = array() ) : mixed
public storeUpload ( string $name , array $metadata = ? ) : mixed
}

Ver también

  • Documentación del núcleo de MongoDB sobre » GridFS
  • Entrada del blog de LightCube Solutions sobre » guardar subidas de usuario
  • Entrada del blog de LightCube Solutions sobre » añadir metadatos a ficheros

Tabla de contenidos

  • MongoGridFS::__construct — Crea una nueva colección de ficheros
  • MongoGridFS::delete — Elimina un fichero y sus trozos de la base de datos
  • MongoGridFS::drop — Da de baja una colección de ficheros y de bloques
  • MongoGridFS::find — Selecciona ficheros
  • MongoGridFS::findOne — Devuelve el fichero que cumpla las condiciones
  • MongoGridFS::get — Obtiene un fichero de la base de datos
  • MongoGridFS::put — Almacena un fichero en la base de datos
  • MongoGridFS::remove — Eliminar ficheros y sus trozos de la base de datos
  • MongoGridFS::storeBytes — Almacena un string de bytes en la base de datos
  • MongoGridFS::storeFile — Almacena un fichero en la base de datos
  • MongoGridFS::storeUpload — Almacena un fichero subido en la base de datos


Crea una nueva colección de ficheros

  • « MongoGridFS
  • MongoGridFS::delete »
  • PHP Manual
  • MongoGridFS
  • Crea una nueva colección de ficheros

MongoGridFS::__construct

(PECL mongo >=0.9.0)

MongoGridFS::__construct — Crea una nueva colección de ficheros

Descripción

public MongoGridFS::__construct ( MongoDB $db , string $prefix = "fs" , mixed $chunks = "fs" )

Los ficheros se almacenan en dos colecciones. La primera contiene información descriptiva de los ficheros. La segunda contiene los bloques del contenido real del fichero. Por omisión, los nombres que se usan para las colecciones son fs.files y fs.chunks.

Mediante un argumento puede especificar un prefijo distinto a "fs":

$fs = new MongoGridFS($db, "misficheros");
esto utilizaría las colecciones misficheros.files y misficheros.chunks.

Parámetros

db

Base de datos.

files

Prefijo opcional para el nombre de la colección.


Elimina un fichero y sus trozos de la base de datos

  • « MongoGridFS::__construct
  • MongoGridFS::drop »
  • PHP Manual
  • MongoGridFS
  • Elimina un fichero y sus trozos de la base de datos

MongoGridFS::delete

(PECL mongo >=1.0.8)

MongoGridFS::delete — Elimina un fichero y sus trozos de la base de datos

Descripción

public MongoGridFS::delete ( mixed $id ) : bool|array

Nota:

MongoGridFS::delete() es un método conveniente para llamar a MongoGridFS::remove() con los criterios específicos dados por criteria y las opciones predeterminadas dadas por options.

Parámetros

id

_id del fichero a eliminar.

Valores devueltos

Devuelve un array que contiene el estado de la remoción (con respecto a la colección files) si se aplica un asunto de escritura. De lo contrario, devuelve true.

Los campos del array de estado están descritos en la documentación de MongoCollection::insert().

Errores/Excepciones

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.


Da de baja una colección de ficheros y de bloques

  • « MongoGridFS::delete
  • MongoGridFS::find »
  • PHP Manual
  • MongoGridFS
  • Da de baja una colección de ficheros y de bloques

MongoGridFS::drop

(PECL mongo >=0.9.0)

MongoGridFS::drop — Da de baja una colección de ficheros y de bloques

Descripción

public MongoGridFS::drop ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Respuesta de la base de datos.


Selecciona ficheros

  • « MongoGridFS::drop
  • MongoGridFS::findOne »
  • PHP Manual
  • MongoGridFS
  • Selecciona ficheros

MongoGridFS::find

(PECL mongo >=0.9.0)

MongoGridFS::find — Selecciona ficheros

Descripción

public MongoGridFS::find
 ( array $query = array()
, array $fields = array()
) : MongoGridFSCursor

Parámetros

query

La consulta

fields

Campos que devolverá.

Valores devueltos

Un objeto de la clase MongoGridFSCursor.


Devuelve el fichero que cumpla las condiciones

  • « MongoGridFS::find
  • MongoGridFS::get »
  • PHP Manual
  • MongoGridFS
  • Devuelve el fichero que cumpla las condiciones

MongoGridFS::findOne

(PECL mongo >=0.9.0)

MongoGridFS::findOne — Devuelve el fichero que cumpla las condiciones

Descripción

public MongoGridFS::findOne
 ( mixed $query = array()
, mixed $fields = array()
) : MongoGridFSFile

Parámetros

query

El nombre del fichero o las condiciones de búsqueda.

Valores devueltos

Devuelve un MongoGridFSFile o null.

Ejemplos

Ejemplo #1 Ejemplo de MongoGridFS::findOne()

Ejemplo que muestra cómo localizar un fichero de MongoGridFS.

<?php

$descargas = $mongo->my_db->getGridFS('descargas');

$descargas->storeFile('nombredefichero.tgz');

$descarga = $downloads->findOne('nombredefichero.tgz'); // instancia de MongoGridFSFile

print_r($descarga);
?>

Vea MongoGridFSFile para más información sobre cómo trabajar con ficheros.

El resultado del ejemplo sería algo similar a:

MongoGridFSFile Object
(
    [file] => Array
        (
            [_id] => MongoId Object
                (
                )

            [filename] => nombredefichero.tgz
            [uploadDate] => MongoDate Object
                (
                    [sec] => 1274288014
                    [usec] => 467000
                )

            [chunkSize] => 262144
            [md5] => d41d8cd98f00b204e9800998ecf8427e
        )

    [gridfs:protected] => MongoGridFS Object
        (
            [chunks] => MongoCollection Object
                (
                )

            [filesName:protected] => descargas.files
            [chunksName:protected] => descargas.chunks
        )

)


Obtiene un fichero de la base de datos

  • « MongoGridFS::findOne
  • MongoGridFS::put »
  • PHP Manual
  • MongoGridFS
  • Obtiene un fichero de la base de datos

MongoGridFS::get

(PECL mongo >=1.0.8)

MongoGridFS::get — Obtiene un fichero de la base de datos

Descripción

public MongoGridFS::get ( mixed $id ) : MongoGridFSFile

Parámetros

id

_id del fichero a localizar.

Valores devueltos

Devuelve el fichero si se le encuentra, o null.


Almacena un fichero en la base de datos

  • « MongoGridFS::get
  • MongoGridFS::remove »
  • PHP Manual
  • MongoGridFS
  • Almacena un fichero en la base de datos

MongoGridFS::put

(PECL mongo >=1.0.8)

MongoGridFS::put — Almacena un fichero en la base de datos

Descripción

public MongoGridFS::put ( string $filename , array $metadata = array() , array $options = array() ) : mixed

Nota:

MongoGridFS::put() es un alias de MongoGridFS::storeFile().

Parámetros

filename

El nombre del fichero a almacenar.

metadata

Otros campos de metadatos a incluir en el documento de fichero.

Nota:

Estos cambpos podrían sobrescribir aquellos que serían creados automáticamente por el controlador, tal como está descrito es la documentación del núcleo de MongoDB para las » colecciones de ficheros. Algunos casos prácticos para este comportamiento serían especificar un chunkSize o _id personalizados para un fichero.

options

Un array de opciones para las operaciones de inserción ejecutadas en las colecciones chunks y files. Véase MongoCollection::insert() para la documentación de estas opciones.

Valores devueltos

Devuelve el _id del documento de fichero guardado. Será un MongoId generado a menos que unless sea especificado explícitamente un _id en el parámetro metadata.

Errores/Excepciones

Lanza una MongoGridFSException si ocurre un error al leer filename o al realizar la inserción en las colecciones chunks o files.

Ver también

  • MongoGridFS::storeBytes() - Almacena un string de bytes en la base de datos
  • MongoGridFS::storeFile() - Almacena un fichero en la base de datos
  • MongoGridFS::storeUpload() - Almacena un fichero subido en la base de datos
  • Documentación del núcleo de MongoDB sobre » GridFS


Eliminar ficheros y sus trozos de la base de datos

  • « MongoGridFS::put
  • MongoGridFS::storeBytes »
  • PHP Manual
  • MongoGridFS
  • Eliminar ficheros y sus trozos de la base de datos

MongoGridFS::remove

(PECL mongo >=0.9.0)

MongoGridFS::remove — Eliminar ficheros y sus trozos de la base de datos

Descripción

public MongoGridFS::remove
 ( array $criteria = array()
, array $options = array()
) : bool|array

Parámetros

criteria

Nombre de fichero o criterios de búsqueda.

options

Un array de opciones para las operaciones de remoción ejecutadas en las colecciones chunks y files. Véase MongoCollection::remove() para la documentación de estas opciones.

Valores devueltos

Devuelve un array que contiene el estado de la remoción (con respecto a la colección files) si está establecida la opción "w". De lo contrario, devuelve true.

Los campos del array de estado están descritos en la documentación de MongoCollection::insert().

Errores/Excepciones

Lanza una MongoCursorException si la opción "w" está establecida y la escritura falla.

Lanza una MongoCursorTimeoutException si la opción "w" está establecida a un valor mayor que uno y la operación toma más de MongoCursor::$timeout milisegundos en completarse. Esto no pondrá fin a la operación en el servidor, es un tiempo límite del lado del cliente. La operación en MongoCollection::$wtimeout es milisegundos.


Almacena un string de bytes en la base de datos

  • « MongoGridFS::remove
  • MongoGridFS::storeFile »
  • PHP Manual
  • MongoGridFS
  • Almacena un string de bytes en la base de datos

MongoGridFS::storeBytes

(PECL mongo >=0.9.2)

MongoGridFS::storeBytes — Almacena un string de bytes en la base de datos

Descripción

public MongoGridFS::storeBytes ( string $bytes , array $metadata = array() , array $options = array() ) : mixed

Parámetros

bytes

Un string de bytes a almacenar.

metadata

Otros campos de metadatos a incluir en el documento de fichero.

Nota:

Estos cambpos podrían sobrescribir aquellos que serían creados automáticamente por el controlador, tal como está descrito es la documentación del núcleo de MongoDB para las » colecciones de ficheros. Algunos casos prácticos para este comportamiento serían especificar un chunkSize o _id personalizados para un fichero.

options

Un array de opciones para las operaciones de inserción ejecutadas en las colecciones chunks y files. Véase MongoCollection::insert() para la documentación de estas opciones.

Valores devueltos

Devuelve el _id del documento de fichero guardado. Será un MongoId generado a menos que unless sea especificado explícitamente un _id en el parámetro metadata.

Errores/Excepciones

Lanza una MongoGridFSException si ocurre un error en la inserción en las colecciones chunks o files.

Ejemplos

Ejemplo #1 MongoGridFS::storeBytes() com metadatos adicionales

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$bytes = 'abcdefghijklmnopqrstuvwxyz';
$id = $gridfs->storeBytes($bytes, array('_id' => 'alphabet'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

El resultado del ejemplo sería algo similar a:

array(7) {
  ["_id"]=>
  string(8) "alphabet"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

Ver también

  • MongoGridFS::put() - Almacena un fichero en la base de datos
  • MongoGridFS::storeFile() - Almacena un fichero en la base de datos
  • MongoGridFS::storeUpload() - Almacena un fichero subido en la base de datos
  • Documentación del núcleo de MongoDB sobre » GridFS


Almacena un fichero en la base de datos

  • « MongoGridFS::storeBytes
  • MongoGridFS::storeUpload »
  • PHP Manual
  • MongoGridFS
  • Almacena un fichero en la base de datos

MongoGridFS::storeFile

(PECL mongo >=0.9.0)

MongoGridFS::storeFile — Almacena un fichero en la base de datos

Descripción

public MongoGridFS::storeFile ( string|resource $filename , array $metadata = array() , array $options = array() ) : mixed

Parámetros

filename

Un nombre de fichero o un flujo legible a almacenar.

metadata

Otros campos de metadatos a incluir en el documento de fichero.

Nota:

Estos cambpos podrían sobrescribir aquellos que serían creados automáticamente por el controlador, tal como está descrito es la documentación del núcleo de MongoDB para las » colecciones de ficheros. Algunos casos prácticos para este comportamiento serían especificar un chunkSize o _id personalizados para un fichero.

options

Un array de opciones para las operaciones de inserción ejecutadas en las colecciones chunks y files. Véase MongoCollection::insert() para la documentación de estas opciones.

Valores devueltos

Devuelve el _id del documento de fichero guardado. Será un MongoId generado a menos que unless sea especificado explícitamente un _id en el parámetro metadata.

Errores/Excepciones

Lanza una MongoGridFSException si ocurre un error al leer filename o al realizar la inserción en las colecciones chunks o files.

Ejemplos

Ejemplo #1 MongoGridFS::storeFile() con metadatos adicionales

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$id = $gridfs->storeFile('example.txt', array('contentType' => 'plain/text'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

El resultado del ejemplo sería algo similar a:

array(7) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["contentType"]=>
  string(10) "plain/text"
  ["filename"]=>
  string(11) "example.txt"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

Ver también

  • MongoGridFS::put() - Almacena un fichero en la base de datos
  • MongoGridFS::storeBytes() - Almacena un string de bytes en la base de datos
  • MongoGridFS::storeUpload() - Almacena un fichero subido en la base de datos
  • Documentación del núcleo de MongoDB sobre » GridFS


Almacena un fichero subido en la base de datos

  • « MongoGridFS::storeFile
  • MongoGridFSFile »
  • PHP Manual
  • MongoGridFS
  • Almacena un fichero subido en la base de datos

MongoGridFS::storeUpload

(PECL mongo >=0.9.0)

MongoGridFS::storeUpload — Almacena un fichero subido en la base de datos

Descripción

public MongoGridFS::storeUpload ( string $name , array $metadata = ? ) : mixed

Parámetros

name

El nombre del fichero o ficheros subidos a almacenar. Debería corresponder con el atributo name del campo del fichero del formulario HTML.

metadata

Otros campos de metadatos a incluir en el documento de fichero.

Nota:

Estos cambpos podrían sobrescribir aquellos que serían creados automáticamente por el controlador, tal como está descrito es la documentación del núcleo de MongoDB para las » colecciones de ficheros. Algunos casos prácticos para este comportamiento serían especificar un chunkSize o _id personalizados para un fichero.

Nota:

El campo filename será rellenado con el nombre de fichero del cliente (p.ej., $_FILES['foo']['name']).

Valores devueltos

Devuelve el _id del documento de fichero guardado. Será un MongoId generado a menos que unless sea especificado explícitamente un _id en el parámetro metadata.

Nota:

Si se suben varios ficheros empleando el mismo nombre de campo, este método no devolverá nada; sin embargo, los ficheros en sí serán procesados.

Errores/Excepciones

Lanza una MongoGridFSException si ocurre un error al leer el fichero o ficheros subidos o al realizar la inserción en las colecciones chunks o files.

Historial de cambios

Versión | Descripción
1.2.5 | Se cambió el segundo parámetro a un array de metadatos. Antes de la versión 1.2.5, el segundo parámetro era un string opcional que reemplazaba el nombre de fichero.

Ejemplos

Ejemplo #1 Ejemplo de forumulario HTML con MongoGridFS::storeUpload()

Suponer que se tiene el siguiente formulario HTML:

<form method="POST" enctype="multipart/form-data">
    <label for="username">Username:</label>
    <input type="text" name="username" id="username" />

    <label for="pic">Please upload a profile picture:</label>
    <input type="file" name="pic" id="pic" />

    <input type="submit" />
</form>

Si se quiere almacenar la imagen subida en MongoDB, podría realizarse lo siguiente en el script manejando el envío del formulario:

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$gridfs->storeUpload('pic', array('username' => $_POST['username']));
?>

Ver también

  • MongoGridFS::put() - Almacena un fichero en la base de datos
  • MongoGridFS::storeBytes() - Almacena un string de bytes en la base de datos
  • MongoGridFS::storeFile() - Almacena un fichero en la base de datos
  • Documentación del núcleo de MongoDB sobre » GridFS


Clase MongoGridFSFile

(PECL mongo >=0.9.0)

Introducción

Objeto fichero de una base de datos.

Sinopsis de la Clase

MongoGridFSFile {
/* Campos */
public array $file = null ;
protected MongoGridFS $gridfs = null ;
/* Métodos */
public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )
public getBytes ( ) : string
public getFilename ( ) : string
public getResource ( ) : resource
public getSize ( ) : int
public write ( string $filename = null ) : int
}

Tabla de contenidos

  • MongoGridfsFile::__construct — Crea un nuevo fichero GridFS
  • MongoGridFSFile::getBytes — Devuelve el contenido de este fichero en forma de string de bytes
  • MongoGridFSFile::getFilename — Devuelve el nombre de este fichero
  • MongoGridFSFile::getResource — Devuelve un recurso que puede usarse para leer el fichero almacenado
  • MongoGridFSFile::getSize — Devuelve el tamaño de este fichero
  • MongoGridFSFile::write — Escribe este fichero en disco


Crea un nuevo fichero GridFS

  • « MongoGridFSFile
  • MongoGridFSFile::getBytes »
  • PHP Manual
  • MongoGridFSFile
  • Crea un nuevo fichero GridFS

MongoGridfsFile::__construct

(PECL mongo >=0.9.0)

MongoGridfsFile::__construct — Crea un nuevo fichero GridFS

Descripción

public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )

Parámetros

gridfs

La instancia padre de MongoGridFS.

file

Un fichero de la base de datos.

Valores devueltos

Devuelve un nuevo MongoGridFSFile.


Devuelve el contenido de este fichero en forma de string de bytes

  • « MongoGridfsFile::__construct
  • MongoGridFSFile::getFilename »
  • PHP Manual
  • MongoGridFSFile
  • Devuelve el contenido de este fichero en forma de string de bytes

MongoGridFSFile::getBytes

(PECL mongo >=0.9.0)

MongoGridFSFile::getBytes — Devuelve el contenido de este fichero en forma de string de bytes

Descripción

public MongoGridFSFile::getBytes ( ) : string

Aviso: se cargará el fichero en memoria. Si el fichero es de mayor tamaño que la memoria, provocará un problema.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string con los bytes del fichero.

Ejemplos

Ejemplo #1 Ejemplo de MongoGridFSFile::getBytes()

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');

header('Content-type: image/png;');
echo $image->getBytes();
?>


Devuelve el nombre de este fichero

  • « MongoGridFSFile::getBytes
  • MongoGridFSFile::getResource »
  • PHP Manual
  • MongoGridFSFile
  • Devuelve el nombre de este fichero

MongoGridFSFile::getFilename

(PECL mongo >=0.9.0)

MongoGridFSFile::getFilename — Devuelve el nombre de este fichero

Descripción

public MongoGridFSFile::getFilename ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de fichero.


Devuelve un recurso que puede usarse para leer el fichero almacenado

  • « MongoGridFSFile::getFilename
  • MongoGridFSFile::getSize »
  • PHP Manual
  • MongoGridFSFile
  • Devuelve un recurso que puede usarse para leer el fichero almacenado

MongoGridFSFile::getResource

(PECL mongo >=1.3.0)

MongoGridFSFile::getResource — Devuelve un recurso que puede usarse para leer el fichero almacenado

Descripción

public MongoGridFSFile::getResource ( ) : resource

Este método devuelve un recurso de flujo que puede usarse con todas las funciones de ficheros de PHP que traten con la lectura de ficheros. El contenido del fichero es extraído de MongoDB al vuelo, por lo que el fichero no tiene que ser cargado primero en memoria.

Se cargarán al menos dos trozos de GridFSFile en memoria.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un recurso que puede usarse para leer el fichero

Ejemplos

Ejemplo #1 Ejemplo de MongoGridFSFile::getResource()

<?php
$m = new Mongo;
$imágenes = $m->my_db->getGridFS('images');

$imagen = $imágenes->findOne('mongo.png');

header('Content-type: image/png;');
$flujo = $imagen->getResource();

while (!feof($flujo)) {
    echo fread($flujo, 8192);
}
?>


Devuelve el tamaño de este fichero

  • « MongoGridFSFile::getResource
  • MongoGridFSFile::write »
  • PHP Manual
  • MongoGridFSFile
  • Devuelve el tamaño de este fichero

MongoGridFSFile::getSize

(PECL mongo >=0.9.0)

MongoGridFSFile::getSize — Devuelve el tamaño de este fichero

Descripción

public MongoGridFSFile::getSize ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño de este fichero


Escribe este fichero en disco

  • « MongoGridFSFile::getSize
  • MongoGridFSCursor »
  • PHP Manual
  • MongoGridFSFile
  • Escribe este fichero en disco

MongoGridFSFile::write

(PECL mongo >=0.9.0)

MongoGridFSFile::write — Escribe este fichero en disco

Descripción

public MongoGridFSFile::write ( string $filename = null ) : int

Parámetros

filename

La ubicación en la que se escribirá el fichero. Si no se da ninguno, se usará el nombre del fichero almacenado.

Valores devueltos

Devuelve el número de bytes escritos.

Ejemplos

Ejemplo #1 Ejemplo de MongoGridFSFile::write()

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');
$image->write('/path/to/write/jwage.png');
?>


Clase MongoGridFSCursor

(PECL mongo >=0.9.0)

Introducción

Cursor para los resultados de ficheros de bases de datos.

Sinopsis de la Clase

extends MongoCursor {
/* Campos */
protected MongoGridFS $gridfs = null ;
/* Métodos */
public __construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )
public current ( ) : MongoGridFSFile
public getNext ( ) : MongoGridFSFile
public key ( ) : string
}

Tabla de contenidos

  • MongoGridFSCursor::__construct — Crea un nuevo cursor
  • MongoGridFSCursor::current — Devuelve el fichero actual
  • MongoGridFSCursor::getNext — Devuelve el siguiente fichero al que apunta este cursor, y avanza el cursor
  • MongoGridFSCursor::key — Devuelve el nombre de fichero del resultado actual


Crea un nuevo cursor

  • « MongoGridFSCursor
  • MongoGridFSCursor::current »
  • PHP Manual
  • MongoGridFSCursor
  • Crea un nuevo cursor

MongoGridFSCursor::__construct

(PECL mongo >=0.9.0)

MongoGridFSCursor::__construct — Crea un nuevo cursor

Descripción

public MongoGridFSCursor::__construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )

Parámetros

gridfs

Colección GridFS relacionada.

connection

Conexión a la base de datos.

ns

Nombre completo de la base de datos y de la colección.

query

Consulta a la base de datos.

fields

Campos que se desea obtener.

Valores devueltos

Devuelve el nuevo cursor.


Devuelve el fichero actual

  • « MongoGridFSCursor::__construct
  • MongoGridFSCursor::getNext »
  • PHP Manual
  • MongoGridFSCursor
  • Devuelve el fichero actual

MongoGridFSCursor::current

(PECL mongo >=0.9.0)

MongoGridFSCursor::current — Devuelve el fichero actual

Descripción

public MongoGridFSCursor::current ( ) : MongoGridFSFile

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Fichero actual.


Devuelve el siguiente fichero al que apunta este cursor, y avanza el cursor

  • « MongoGridFSCursor::current
  • MongoGridFSCursor::key »
  • PHP Manual
  • MongoGridFSCursor
  • Devuelve el siguiente fichero al que apunta este cursor, y avanza el cursor

MongoGridFSCursor::getNext

(PECL mongo >=0.9.0)

MongoGridFSCursor::getNext — Devuelve el siguiente fichero al que apunta este cursor, y avanza el cursor

Descripción

public MongoGridFSCursor::getNext ( ) : MongoGridFSFile

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el siguiente fichero.


Devuelve el nombre de fichero del resultado actual

  • « MongoGridFSCursor::getNext
  • Clases de procesamiento por lotes »
  • PHP Manual
  • MongoGridFSCursor
  • Devuelve el nombre de fichero del resultado actual

MongoGridFSCursor::key

(PECL mongo >=0.9.0)

MongoGridFSCursor::key — Devuelve el nombre de fichero del resultado actual

Descripción

public MongoGridFSCursor::key ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El _id del resultado actual como cadena.

Historial de cambios

Versión | Descripción
1.3.0 | El _id del documento es devuelto como un valor de tipo string, ya que la clave debería ser única. Antes de la versión 1.3.0, se devolvía filename.


Clases de procesamiento por lotes

Tabla de contenidos

  • MongoWriteBatch
  • MongoInsertBatch
  • MongoUpdateBatch
  • MongoDeleteBatch


La clase MongoWriteBatch

(PECL mongo >=1.5.0)

Introducción

MongoWriteBatch es la clase base para las clases MongoInsertBatch, MongoUpdateBatch y MongoDeleteBatch.

MongoWriteBatch permite crear lotes de varias operaciones (del mismo tipo) y enviarlos a MongoDB a la vez. Esto puede ser especialmente útil al operar sobre muchos documentos al mismo tiempo para reducir los viajes de ida y vuelta.

Antes de la versión 1.5.0 del controlador, era posible utilizar MongoCollection::batchInsert(), sin embargo, a partir de la versión 1.5.0 no se recomientda dicho método.

Nota: Esta clase solamente está disponible al conversar con servidores de MongoDB 2.6.0 (y posteriores). Se lanzará una MongoProtocolException si se intenta usarla con versiones de MongoDB más antiguas.

Sinopsis de la Clase

MongoWriteBatch {
/* Constantes */
const int COMMAND_INSERT = 1 ;
const int COMMAND_UPDATE = 2 ;
const int COMMAND_DELETE = 3 ;
/* Métodos */
protected __construct ( MongoCollection $collection , string $batch_type = ? , array $write_options = ? )
public add ( array $item ) : bool
final public execute ( array $write_options ) : array
}

MongoWriteBatch types

MongoWriteBatch::COMMAND_INSERT

Crear un lote de escritura de inserciones

MongoWriteBatch::COMMAND_UPDATE

Crear un lote de escritura de actualizaciones

MongoWriteBatch::COMMAND_DELETE

Crear un lote de escritura de eliminaciones

Descripción

Al ejecutar un lote, invocando a MongoWriteBatch::execute(), MongoWriteBatch enviará » maxWriteBatchSize (predeterminado a 1000) documentos o hasta » maxBsonObjectSize (predeterminado a 16777216 bytes), lo que ocurra primero.

Nota:

Los documentos nunca se transferirán parcialmente. Si se añade al lote un documento que sobrepase el límte, se creará un nuevo lote donde se colocará dicho documento.

Errores/Excepciones

  • Exception en fallos de análisis de parámetros
  • Exception en errores de validación de argumentos (p.ej., claves ausentes)
  • MongoProtocolException cuando se conversa con servidores de MongoDB más antiguos que 2.6.0.
  • MongoProtocolException en errores de socket.
  • MongoWriteConcernException cuando falla una escritura debido a WriteConcerns

Ejemplos

Ejemplo #1 Ejemplo de MongoWriteBatch

Añadir documentos a un lote de Insert y ejecutarlo

<?php
$mc = new MongoClient("localhost");

$colección = $mc->selectCollection("prueba", "prueba");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$lote = new MongoInsertBatch($colección);
foreach($docs as $documento) {
    $lote->add($documento);
}
$retval = $lote->execute(array("w" => 1));
var_dump($retval);
?>

El resultado del ejemplo sería:

array(2) {
  ["nInserted"]=>
  int(3)
  ["ok"]=>
  bool(true)
}

Tabla de contenidos

  • MongoWriteBatch::add — Añade una operación de escritura a un lote
  • MongoWriteBatch::__construct — Crea un nuevo lote de operaciones de escritura
  • MongoWriteBatch::execute — Ejecuta un lote de operaciones de escritura


Añade una operación de escritura a un lote

  • « MongoWriteBatch
  • MongoWriteBatch::__construct »
  • PHP Manual
  • MongoWriteBatch
  • Añade una operación de escritura a un lote

MongoWriteBatch::add

(PECL mongo >= 1.5.0)

MongoWriteBatch::add — Añade una operación de escritura a un lote

Descripción

public MongoWriteBatch::add ( array $item ) : bool

Añade una operación de escritura al lote.

Si $item hace que el lote exceda los límites » maxWriteBatchSize o » maxBsonObjectSize, el controlador dividirá internamente los lotes en varias órdenes de escritura en la llamada a MongoWriteBatch::execute().

Parámetros

item

Un array que describe una operación de escritura. La estructura de este valor depende del tipo de operación del lote.

Tipo de lote | Argumento previsto
MongoWriteBatch::COMMAND_INSERT | El documento a añadir.
MongoWriteBatch::COMMAND_UPDATE

Operación de acualización pura.

Las claves requeridas son "q" y "u", las cuales se corresponden a los parámetros $criteria y $new_object de MongoCollection::update(), respectivamente.

Las claves opcionales son "multi" y "upsert", las cuales se corresponden a las opciones "multiple" y "upsert" para MongoCollection::update(), respectivamente. Si no se especifican, ambas opciones se predeterminan a false.
MongoWriteBatch::COMMAND_DELETE

Operación de eliminación pura..

Las claves requeridas son: "q" y "limit", las cuales se corresponden al parámetro $criteria y a la opción "justOne" de MongoCollection::remove(), respectivamente.

La opción "limit" es un integer; sin embargo, MongoDB únicamente soporta 0 (es decir, eliminar todos los documentos coincidentes) y 1 (es decir, eliminar al menos un elemento coincidente) por ahora.

Valores devueltos

Devuelve true en caso de éxito y lanza una excepción en caso de fallo.

Errores/Excepciones

  • Exception en fallos de análisis de parámetros
  • Exception en errores de validación de argumentos (p.ej. claves ausentes)

Ejemplos

Ejemplo #1 Ejemplo de MongoWriteBatch::add()

Poner en lotes varias operaciones de inserción

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$lote = new MongoInsertBatch($colección);
foreach($docs as $documento) {
    $lote->add($documento);
}
$lote->execute(array("w" => 1));
?>

Ejemplo #2 Ejemplo de MongoWriteBatch::add()

Poner en lotes varias operaciones de actualización

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "u" => array('$set' => array("try" => 1)),
    "multi"  => false, /* valor predeterminado */
    "upsert" => false, /* valor predeterminado */
);
$item2 = array(
    "q" => array("is" => "working"),
    "u" => array('$set' => array("try" => 2)),
    "multi" => true,
);
$item3 = array(
    "q" => array("created" => "new-document"),
    "u" => array('$set' => array("try" => 3)),
    "upsert" => true,
);

$lote = new MongoUpdateBatch($colección);
$lote->add($item1);
$lote->add($item2);
$lote->add($item3);
$lote->execute(array("w" => 1));

?>

Ejemplo #3 Ejemplo de MongoWriteBatch::add()

Poner en lotes varias operaciones de eliminación

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "limit" => 1,
);
$item2 = array(
    "q" => array("try" => 3),
    "limit" => 1,
);

$lote = new MongoDeleteBatch($colección);
$lote->add($item1);
$lote->add($item2);
$lote->execute(array("w" => 1));
?>


Crea un nuevo lote de operaciones de escritura

  • « MongoWriteBatch::add
  • MongoWriteBatch::execute »
  • PHP Manual
  • MongoWriteBatch
  • Crea un nuevo lote de operaciones de escritura

MongoWriteBatch::__construct

(PECL mongo >= 1.5.0)

MongoWriteBatch::__construct — Crea un nuevo lote de operaciones de escritura

Descripción

protected MongoWriteBatch::__construct ( MongoCollection $collection , string $batch_type = ? , array $write_options = ? )

Construye un nuevo objeto MongoWriteBatch.

Nota:

Este es un constructor protegido. Use una de las clases que heredan de MongoWriteBatch.

Parámetros

collection

El objeto MongoCollection sobre el que ejecutar el lote. Su asunto de escritura se copiará y usará como el asunto de escritura predeterminado si no se proporciona ninguno en $write_options o durante MongoWriteBatch::execute().

batch_type

Uno de los siguientes tipos de lote:

  • 0 - hace un lote MongoWriteBatch::COMMAND_INSERT
  • 1 - hace un lote MongoWriteBatch::COMMAND_UPDATE
  • 2 - hace un lote MongoWriteBatch::COMMAND_DELETE

write_options

Un array de Opciones de Escritura.

Clave | Significado del valor
w (int|string) | Valor de Asunto de escritura
wtimeout (int) | Tiempo máximo a esperar para una réplica
ordered | Determina si MongoDB debe aplicar este lote en orden. Las escrituras ordenadas se ejecutan en serie (esto es, un elemento cada vez) y la ejecución se detendrá después del primer error. Las escrituras no ordenadas podrían ejecutarse en paralelo y la ejecución no se detendrá después del primer error. El valor predeterminado es true
j (bool) | Esperar a que el primario registre en el diario. Se desaconseja este valor, use WriteConcern en su lugar
fsync (bool) | Esperar para "fsync" en el primario. Se desaconseja este valor, use WriteConcern en su lugar

Valores devueltos

Un nuevo objeto MongoWriteBatch del tipo batch_type.

Ver también

  • MongoInsertBatch
  • MongoUpdateBatch
  • MongoDeleteBatch


Ejecuta un lote de operaciones de escritura

  • « MongoWriteBatch::__construct
  • MongoInsertBatch »
  • PHP Manual
  • MongoWriteBatch
  • Ejecuta un lote de operaciones de escritura

MongoWriteBatch::execute

(PECL mongo >= 1.5.0)

MongoWriteBatch::execute — Ejecuta un lote de operaciones de escritura

Descripción

final public MongoWriteBatch::execute ( array $write_options ) : array

Ejecuta el lote de operaciones de escritura.

Parámetros

write_options

Véase MongoWriteBatch::__construct.

Valores devueltos

Devuelve un array que contiene información estadística del lote completo. Si el lote tuvo que ser dividido en varios lotes, el valor devuelto acumulará los valores de los lotes individualtes y devolverá solamente el total.

Si el lote estuviera vacío, devuelve un array que contiene solamente el campo 'ok' (como true) aunque no se enviará nada sobre el cable (NOOP).

Clave del array | Significado del valor | Devuelto por el tipo de lote
nInserted | Número de documentos insertados | Lote de MongoWriteBatch::COMMAND_INSERT
nMatched | Número de documentos que coinciden con los criterios de consulta | Lote de MongoWriteBatch::COMMAND_UPDATE
nModified | Número de documentos que realmente es necesario modificar | Lote de MongoWriteBatch::COMMAND_UPDATE
nUpserted | Número de documentos "upsert"ados | Lote de MongoWriteBatch::COMMAND_UPDATE
nRemoved | Número de documentos eliminados | Lote de MongoWriteBatch::COMMAND_DELETE
ok | Indicador de éxito de comando | Todos

Errores/Excepciones

Se lanza una MongoWriteConcernException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de MongoWriteBatch::add()

Agrupar varias operaciones de inserción

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$lote = new MongoInsertBatch($colección);
foreach($docs as $documento) {
    $lote->add($documento);
}
$retval = $lote->execute(array("w" => 1));
var_dump($retval);
?>

El resultado del ejemplo sería:

array(2) {
  ["nInserted"]=>
  int(3)
  ["ok"]=>
  bool(true)
}

Ejemplo #2 Ejemplo de MongoWriteBatch::add()

Agrupar varias operaciones de actualización

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "u" => array('$set' => array("try" => 1)),
    "multi"  => false, /* default value */
    "upsert" => false, /* default value */
);
$item2 = array(
    "q" => array("is" => "working"),
    "u" => array('$set' => array("try" => 2)),
    "multi" => true,
);
$item3 = array(
    "q" => array("created" => "new-document"),
    "u" => array('$set' => array("try" => 3)),
    "upsert" => true,
);

$lote = new MongoUpdateBatch($colección);
$lote->add($item1);
$lote->add($item2);
$lote->add($item3);
$retval = $lote->execute(array("w" => 1));
var_dump($retval);

?>

El resultado del ejemplo sería:

array(4) {
  ["nMatched"]=>
  int(18)
  ["nModified"]=>
  int(2)
  ["nUpserted"]=>
  int(0)
  ["ok"]=>
  bool(true)
}

Ejemplo #3 Ejemplo de MongoWriteBatch::add()

Agrupar varias operaciones de eliminación

<?php
$mc = new MongoClient("localhost");
$colección = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "limit" => 1,
);
$item2 = array(
    "q" => array("try" => 3),
    "limit" => 1,
);

$lote = new MongoDeleteBatch($colección);
$lote->add($item1);
$lote->add($item2);
$retval = $lote->execute(array("w" => 1));
var_dump($retval);
?>

El resultado del ejemplo sería:

array(2) {
  ["nRemoved"]=>
  int(1)
  ["ok"]=>
  bool(true)
}


La clase MongoInsertBatch

(PECL mongo >=1.5.0)

Introducción

Construye un lote de operaciones INSERT. Véase MongoWriteBatch.

Sinopsis de la Clase

MongoInsertBatch extends MongoWriteBatch {
/* Métodos */
public __construct ( MongoCollection $collection , array $write_options = ? )
/* Métodos heredados */
public MongoWriteBatch::add ( array $item ) : bool
final public MongoWriteBatch::execute ( array $write_options ) : array
}

Tabla de contenidos

  • MongoInsertBatch::__construct — Descripción


Descripción

  • « MongoInsertBatch
  • MongoUpdateBatch »
  • PHP Manual
  • MongoInsertBatch
  • Descripción

MongoInsertBatch::__construct

(PECL mongo >= 1.5.0)

MongoInsertBatch::__construct — Descripción

Descripción

public MongoInsertBatch::__construct ( MongoCollection $collection , array $write_options = ? )

Construye un lote de operaciones INSERT. Véase MongoWriteBatch.

Parámetros

collection

El objeto MongoCollection sobre el que ejecutar el lote. Su asunto de escritura se copiará y usará como el asunto de escritura predeterminado si no se proporciona ninguno en $write_options o durante MongoWriteBatch::execute().

write_options

Un array de Opciones de Escritura.

Clave | Significado del valor
w (int|string) | Valor de Asunto de escritura
wtimeout (int) | Tiempo máximo a esperar para una réplica
ordered | Determina si MongoDB debe aplicar este lote en orden. Las escrituras ordenadas se ejecutan en serie (esto es, un elemento cada vez) y la ejecución se detendrá después del primer error. Las escrituras no ordenadas podrían ejecutarse en paralelo y la ejecución no se detendrá después del primer error. El valor predeterminado es true
j (bool) | Esperar a que el primario registre en el diario. Se desaconseja este valor, use WriteConcern en su lugar
fsync (bool) | Esperar para "fsync" en el primario. Se desaconseja este valor, use WriteConcern en su lugar

Valores devueltos

Un nuevo objeto MongoInsertBatch.


The MongoUpdateBatch class

(PECL mongo >=1.5.0)

Introducción

Construye un lote de operaciones UPDATE. Véase MongoWriteBatch.

Sinopsis de la Clase

MongoUpdateBatch extends MongoWriteBatch {
/* Métodos */
public __construct ( MongoCollection $collection , array $write_options = ? )
/* Métodos heredados */
public MongoWriteBatch::add ( array $item ) : bool
final public MongoWriteBatch::execute ( array $write_options ) : array
}

Tabla de contenidos

  • MongoUpdateBatch::__construct — Descripción


Descripción

  • « MongoUpdateBatch
  • MongoDeleteBatch »
  • PHP Manual
  • MongoUpdateBatch
  • Descripción

MongoUpdateBatch::__construct

(PECL mongo >= 1.5.0)

MongoUpdateBatch::__construct — Descripción

Descripción

public MongoUpdateBatch::__construct ( MongoCollection $collection , array $write_options = ? )

Construye un lote de operaciones UPDATE. Véase MongoWriteBatch.

Parámetros

collection

El objeto MongoCollection sobre el que ejecutar el lote. Su asunto de escritura se copiará y usará como el asunto de escritura predeterminado si no se proporciona ninguno en $write_options o durante MongoWriteBatch::execute().

write_options

Un array de Opciones de Escritura.

Clave | Significado del valor
w (int|string) | Valor de Asunto de escritura
wtimeout (int) | Tiempo máximo a esperar para una réplica
ordered | Determina si MongoDB debe aplicar este lote en orden. Las escrituras ordenadas se ejecutan en serie (esto es, un elemento cada vez) y la ejecución se detendrá después del primer error. Las escrituras no ordenadas podrían ejecutarse en paralelo y la ejecución no se detendrá después del primer error. El valor predeterminado es true
j (bool) | Esperar a que el primario registre en el diario. Se desaconseja este valor, use WriteConcern en su lugar
fsync (bool) | Esperar para "fsync" en el primario. Se desaconseja este valor, use WriteConcern en su lugar

Valores devueltos

Un nuevo objeto MongoUpdateBatch.


La clase MongoDeleteBatch

(PECL mongo >=1.5.0)

Introducción

Construye un lote de operaciones DELETE. Véase MongoWriteBatch.

Sinopsis de la Clase

MongoDeleteBatch extends MongoWriteBatch {
/* Métodos */
public __construct ( MongoCollection $collection , array $write_options = ? )
/* Métodos heredados */
public MongoWriteBatch::add ( array $item ) : bool
final public MongoWriteBatch::execute ( array $write_options ) : array
}

Tabla de contenidos

  • MongoDeleteBatch::__construct — Descripción


Descripción

  • « MongoDeleteBatch
  • Miscelánea »
  • PHP Manual
  • MongoDeleteBatch
  • Descripción

MongoDeleteBatch::__construct

(PECL mongo >= 1.5.0)

MongoDeleteBatch::__construct — Descripción

Descripción

public MongoDeleteBatch::__construct ( MongoCollection $collection , array $write_options = ? )

Construye un lote de operaciones DELETE. Véase MongoWriteBatch.

Parámetros

collection

El objeto MongoCollection sobre el que ejecutar el lote. Su asunto de escritura se copiará y usará como el asunto de escritura predeterminado si no se proporciona ninguno en $write_options o durante MongoWriteBatch::execute().

write_options

Un array de Opciones de Escritura.

Clave | Significado del valor
w (int|string) | Valor de Asunto de escritura
wtimeout (int) | Tiempo máximo a esperar para una réplica
ordered | Determina si MongoDB debe aplicar este lote en orden. Las escrituras ordenadas se ejecutan en serie (esto es, un elemento cada vez) y la ejecución se detendrá después del primer error. Las escrituras no ordenadas podrían ejecutarse en paralelo y la ejecución no se detendrá después del primer error. El valor predeterminado es true
j (bool) | Esperar a que el primario registre en el diario. Se desaconseja este valor, use WriteConcern en su lugar
fsync (bool) | Esperar para "fsync" en el primario. Se desaconseja este valor, use WriteConcern en su lugar

Valores devueltos

Un nuevo objeto MongoDeleteBatch.


  • « MongoDeleteBatch::__construct
  • MongoLog »
  • PHP Manual
  • Mongo
  • Miscelánea

Miscelánea

Tabla de contenidos

  • MongoLog
  • MongoPool
  • Mongo


La clase MongoLog

(PECL mongo >=1.2.3)

Introducción

El registro se puede usar para obtener información detallada de lo que está haciendo el controlador. El registro está desactivado de forma predeterminada, aunque esta clase permite activar niveles de registro específicos para determinadas áreas del controlador. Algunos ejemplos:los:

<?php

// muestra todos los mensajes posibles
MongoLog::setLevel(MongoLog::ALL); // todos los niveles de registros
MongoLog::setModule(MongoLog::ALL); // todas las partes del driver

// muestra eventos significativos sobre fallos en conjuntos de réplicas
MongoLog::setLevel(MongoLog::INFO);
MongoLog::setModule(MongoLog::RS);

// muestra registros de nivel de información y diagnóstico para conjuntos de réplicas y conexiones
MongoLog::setLevel(MongoLog::INFO|MongoLog::FINE);
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

?>

Nota:

Por omisión, MongoLog emite todos los mensajes de registro como avisos de PHP. Dependiendo de la SAPI que se use, los mensajes podrían enviarse a stderr (para CLI) o al registro de errores del servidor web. Si, después de configurar MongoLog, los mensajes de registro no aparecen como se esperaba, asegúrese de que el bit de E_NOTICE está incluido den error_reporting y de que display_errors esté activado.

Sinopsis de la Clase

MongoLog {
/* Constantes */
const int NONE = 0 ;
const int ALL = 31 ;
constantes de niveles {
const int WARNING = 1 ;
const int INFO = 2 ;
const int FINE = 4 ;
constantes de módulos {
const int RS = 1 ;
const int POOL = 1 ;
const int CON = 2 ;
const int IO = 4 ;
const int SERVER = 8 ;
const int PARSE = 16 ;
/* Campos */
private static int $callback ;
private static int $level ;
private static int $module ;
/* Métodos */
public static getCallback ( ) : callable
public static getLevel ( ) : int
public static getModule ( ) : int
public static setCallback ( callable $log_function ) : void
public static setLevel ( int $level ) : void
public static setModule ( int $module ) : void
}

Constantes predefinidas

Constantes de MongoLog

Estas constantes pueden usarse tanto por MongoLog::setLevel() como por MongoLog::setModule().

MongoLog::NONE
No registrar nada.
MongoLog::ALL
Registrar todo.

Constantes de Nivel de MongoLog

Estas constantes pueden usarse por MongoLog::setLevel().

MongoLog::WARNING
Registrar eventos que son excepcionales de algún modo, aunque no lo suficiente como las excepciones reales (p.ej. errores de conexión recuperables).
MongoLog::INFO
Registrar eventos que podrían ser de interés para el administrador, aunque no particularmente notables (p.ej. análisis de opciones, pasos de autentiación).
MongoLog::FINE
Registrar la mayoría de los eventos que realiza el controlador (p.ej. selección de un servidor, comunicación con socket). Dependiendo del módulo a registrar, esto puede ser extremadamente ruidoso, por lo que es principalmente útil para depuración.

Constantes de módulos de MongoLog

Estas constantes pueden usarse por MongoLog::setModule().

MongoLog::CON
Registrar actividades de conexión. Crear nuevas conexiones, autenticación, ping tiempos límite, etc.
MongoLog::IO
Registrar el tráfico generado de y desde la base de datos. A no ser que se trate de un programa trivial, esto creará un gran volumen de registros.
MongoLog::PARSE
Registrar el análisis de string de conexiones y opciones cuando se construye MongoClient.
MongoLog::POOL
Anteriormente usada para registrar la actividad de agrupaciones de conexiones. Esta opción ahora es un alias obsoleto de MongoLog::RS.
MongoLog::RS
Registrar la actividad de conjuntos de réplicas. Tolerancia a fallos, selección de preferencias de lectura, etc.
MongoLog::SERVER
Anteriormente usada para registrar cambios de estado del servidor. Esta opción está obsoleta en favor de MongoLog::RS.

Historial de cambios

Versión | Descripción
1.3.0 | Se añadió MongoLog::CON y está obsoletas MongoLog::POOL y MongoLog::SERVER.

Tabla de contenidos

  • MongoLog::getCallback — Obtiene la función de retrollamada establecida anteriormente
  • MongoLog::getLevel — Obtiene el nivel o niveles que están siendo registrados
  • MongoLog::getModule — Devuelve el módulo o módulos que se están registrando actualmente
  • MongoLog::setCallback — Establece una función de retrollamada para ser invocada por eventos
  • MongoLog::setLevel — Establece el nivel o niveles a registrar
  • MongoLog::setModule — Establece el módulo o módulos a registrar


Obtiene la función de retrollamada establecida anteriormente

  • « MongoLog
  • MongoLog::getLevel »
  • PHP Manual
  • MongoLog
  • Obtiene la función de retrollamada establecida anteriormente

MongoLog::getCallback

(PECL mongo >= 1.3.0)

MongoLog::getCallback — Obtiene la función de retrollamada establecida anteriormente

Descripción

public static MongoLog::getCallback ( ) : callable

Recupera la función de retrollamada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la función de retrollamada, o false si aún no se ha establecido.

Notas

Precaución

Esta función solamente está disponible con PHP 5.3.0 y posterior.


Obtiene el nivel o niveles que están siendo registrados

  • « MongoLog::getCallback
  • MongoLog::getModule »
  • PHP Manual
  • MongoLog
  • Obtiene el nivel o niveles que están siendo registrados

MongoLog::getLevel

(PECL mongo >= 1.2.3)

MongoLog::getLevel — Obtiene el nivel o niveles que están siendo registrados

Descripción

public static MongoLog::getLevel ( ) : int

Esta función se puede usar para conocer qué niveles de registro están habilitados actualmente. El valor de tipo integer devuelto puede ser comparado con las constantes de nivel de MongoLog empleando operadores a nivel de bit para comprobar niveles de registro específicos.

<?php

if (MongoLog::getLevel() & MongoLog::FINE) {
    echo "un montón de logs\n";
}

if (MongoLog::getLevel() ^ MongoLog::NONE) {
    echo "logging, al menos un poco\n";
}

if (MongoLog::getLevel() == MongoLog::ALL) {
    echo "logging al más alto nivel\n";
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nivel o niveles que están siendo registrados acutalemente.


Devuelve el módulo o módulos que se están registrando actualmente

  • « MongoLog::getLevel
  • MongoLog::setCallback »
  • PHP Manual
  • MongoLog
  • Devuelve el módulo o módulos que se están registrando actualmente

MongoLog::getModule

(PECL mongo >= 1.2.3)

MongoLog::getModule — Devuelve el módulo o módulos que se están registrando actualmente

Descripción

public static MongoLog::getModule ( ) : int

Esta función se puede usar para ver qué módulos del controlador están siendo registrados actualmente. El valor de tipo integer devuelto puede ser comparado con las constantes de módulos de MongoLog empleando operadores a nivel de bit para comprobar qué módulos están siendo registrados.

<?php

if (MongoLog::getModule() & MongoLog::RS) {
    echo "registrando conjuntos de réplicas\n";
}

if (MongoLog::getModule() ^ MongoLog::NONE) {
    echo "registrando algo\n";
}

if ((MongoLog::getModule() & MongoLog::IO) == 0) {
    echo "no se están registrando entradas/salidas\n";
}

?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el módulo o los módulos que se están registrando actualmente.


Establece una función de retrollamada para ser invocada por eventos

  • « MongoLog::getModule
  • MongoLog::setLevel »
  • PHP Manual
  • MongoLog
  • Establece una función de retrollamada para ser invocada por eventos

MongoLog::setCallback

(PECL mongo >= 1.3.0)

MongoLog::setCallback — Establece una función de retrollamada para ser invocada por eventos

Descripción

public static MongoLog::setCallback ( callable $log_function ) : void

Esta función establecerá una función de retrollamada par ser invocada por eventos en lugar de emitir avisos de PHP.

Parámetros

log_function

La función de retrollamada a invocar por eventos. Debería tener el siguiente prototipo:

log_function ( int $module , int $level , string $message )
module
Una de las constantes de módulo de MongoLog.
level
Una de las constantes de nivel de MongoLog.
message
El mensaje de registro mismo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de MongoLog::setCallback()

<?php

function module2string($module)
{
    switch ($module) {
        case MongoLog::RS: return "REPLSET";
        case MongoLog::CON: return "CON";
        case MongoLog::IO: return "IO";
        case MongoLog::SERVER: return "SERVER";
        case MongoLog::PARSE: return "PARSE";
        default: return "UNKNOWN";
    }
}

function level2string($level)
{
    switch ($level) {
        case MongoLog::WARNING: return "WARN";
        case MongoLog::INFO: return "INFO";
        case MongoLog::FINE: return "FINE";
        default: return "UNKNOWN";
    }
}

function callback($module, $level, $message)
{
    echo date("Y-m-d H:i:s - ");
    printf("%s (%s): %s\n", module2string($module), level2string($level), $message);
}

MongoLog::setLevel(MongoLog::ALL);
MongoLog::setModule(MongoLog::ALL);

// Especificamos la el nombre de la función aquí, aunque cualquier callable funcionará (p.ej. una función anónima) will work
MongoLog::setCallback("callback");

new MongoClient();
?>

El resultado del ejemplo sería algo similar a:

2013-07-09 09:41:42 - PARSE (INFO): Parsing localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Found node: localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Connection type: STANDALONE
2013-07-09 09:41:42 - CON (INFO): mongo_get_read_write_connection: finding a STANDALONE connection
2013-07-09 09:41:42 - CON (INFO): connection_create: creating new connection for localhost:27017
2013-07-09 09:41:42 - CON (INFO): stream_connect: Not establishing SSL for localhost:27017
2013-07-09 09:41:42 - CON (INFO): get_server_flags: start
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 95
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxBsonObjectSize to 16777216
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxMessageSizeBytes to 48000000
2013-07-09 09:41:42 - CON (INFO): is_ping: pinging localhost:27017;-;.;1543
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 17
2013-07-09 09:41:42 - CON (INFO): is_ping: last pinged at 1373359302; time: 0ms
2013-07-09 09:41:42 - REPLSET (FINE): finding candidate servers
2013-07-09 09:41:42 - REPLSET (FINE): - all servers
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: adding connections:
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials: done
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers by priority and ping time
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers: done
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers: nearest is 0ms
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): selecting near server: done
2013-07-09 09:41:42 - REPLSET (INFO): pick server: random element 0
2013-07-09 09:41:42 - REPLSET (INFO): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543

Notas

Precaución

Esta función solamente está disponible con PHP 5.3.0 y posterior.


Establece el nivel o niveles a registrar

  • « MongoLog::setCallback
  • MongoLog::setModule »
  • PHP Manual
  • MongoLog
  • Establece el nivel o niveles a registrar

MongoLog::setLevel

(PECL mongo >= 1.2.3)

MongoLog::setLevel — Establece el nivel o niveles a registrar

Descripción

public static MongoLog::setLevel ( int $level ) : void

Esta función se puede usar para controlar la verbosidad del registro y los tipos de actividades que deberían registrarse. Las constantes de nivel de MongoLog se pueden emplear con operadores a nivel de bit para especificar múltiples niveles.

<?php

// primero, especificar un módulo de registro
MongoLog::setModule(MongoLog::CON);

// registrar mensajes de cada nivel
MongoLog::setLevel(MongoLog::ALL);

// registrar mensajes de advertencias e información solamente
MongoLog::setLevel(MongoLog::WARNING|MongoLog::INFO);

// registrar todo excepto actividades de grano fino
MongoLog::setLevel(MongoLog::ALL & (~MongoLog::FINE));

?>

Tenga presente que también puede llamar a MongoLog::setModule() para especificar qué módulo o módulos del controlador se deberían registrar.

Parámetros

level

Nivel o niveles que se desean registrar.


Establece el módulo o módulos a registrar

  • « MongoLog::setLevel
  • MongoPool »
  • PHP Manual
  • MongoLog
  • Establece el módulo o módulos a registrar

MongoLog::setModule

(PECL mongo >= 1.2.3)

MongoLog::setModule — Establece el módulo o módulos a registrar

Descripción

public static MongoLog::setModule ( int $module ) : void

Esta función se puede usar para establecer qué módulos deberían registrarse. Las constantes de módulos de MongoLog se pueden emplear con operadores a nivel de bit para especificar múltiples módulos.

<?php

// primero, especificar un nivel de registro
MongoLog::setLevel(MongoLog::ALL);

// registrar las actividades de conjuntos de réplicas
MongoLog::setModule(MongoLog::RS);

// registrar las actividades de conjuntos de réplicas y conexiones
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

// registramos todo excepto actividades de E/S
MongoLog::setModule(MongoLog::ALL & (~MongoLog::IO));

?>

Tenga presente que también se puede invocar a MongoLog::setLevel() para habilitar el registro.

Parámetros

module

El/los módulo/s que desea registrar.


La clase MongoPool

(PECL mongo >= 1.2.3)

Introducción

Advertencia

Las versioines actuales (1.3.0+) del controlador ya no implementan el agrupamiento. Esta clase y sus métodos están, por lo tanto, obsoletos y no deberían usarse.

Sinopsis de la Clase

MongoPool {
/* Métodos */
public static getSize ( ) : int
public info ( ) : array
public static setSize ( int $size ) : bool
}

Historial de cambios

Versión | Descripción
1.3.0 | Esta funcionalidad ha sido eliminada y ya no hace otra cosa que emitir advertencias de obsolescencia. Esta clase solamente se mantiene por retrocompatibilidad y será eliminada en el futuro.
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Tabla de contenidos

  • MongoPool::getSize — Devuelve el tamaño actual de un agrupamiento de conexiones
  • MongoPool::info — Devuelve información sobre todos los agrupamientos de conexiones
  • MongoPool::setSize — Establece el tamaño de los nuevos agrupamientos de conexiones


Devuelve el tamaño actual de un agrupamiento de conexiones

  • « MongoPool
  • MongoPool::info »
  • PHP Manual
  • MongoPool
  • Devuelve el tamaño actual de un agrupamiento de conexiones

MongoPool::getSize

(PECL mongo >= 1.2.3)

MongoPool::getSize — Devuelve el tamaño actual de un agrupamiento de conexiones

Descripción

public static MongoPool::getSize ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño del agrupamiento actual.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ejemplos

Ejemplo #1 Cambiar el tamaño de un agrupamiento

Devuelve el tamaño predeterminado del agrupamiento, esatblece un nuevo tamaño, y muestra el nuevo tamaño junto con información de depuración. Nótese que el cambio del tamaño del agrupamiento sólo afecta a los nuevos agrupamientos de conexiones; no modifica las anteriores.

<?php

$conexión = new Mongo("host1");

// el tamaño del agrupamiento es -1
echo "el tamaño del agrupamiento es: ".MongoPool::getSize()."\n";

echo "establecer el tamaño del agrupamiento a 200\n";

MongoPool::setSize(200);

// el tamaño del agrupamiento es 200
echo "es tamaño del agrupamiento es: ".MongoPool::getSize()."\n";

$conexión2 = new Mongo("host2");

// conexiones disponibles en host1: -2
// conexiones disponibles en host2: 199
var_dump(Mongo::poolDebug());

?>

Ver también

  • MongoPool::setSize() - Establece el tamaño de los nuevos agrupamientos de conexiones
  • MongoPool::info() - Devuelve información sobre todos los agrupamientos de conexiones
  • La documentación sobre conexiones.


Devuelve información sobre todos los agrupamientos de conexiones

  • « MongoPool::getSize
  • MongoPool::setSize »
  • PHP Manual
  • MongoPool
  • Devuelve información sobre todos los agrupamientos de conexiones

MongoPool::info

(PECL mongo >= 1.2.3)

MongoPool::info — Devuelve información sobre todos los agrupamientos de conexiones

Descripción

public MongoPool::info ( ) : array

Devuelve un array con información sobre todos los agrupamientos de conexiones.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Cada agrupamiento de conexiones tiene un identificador que comienza con el nombre de host. Esta función muestra los siguientes campos para cada agrupamiento:

in use

El número de conexiones actualmente usadas por instancias de Mongo.

in pool

El número de conexiones que hay actualmente en el agrupamiento (sin usar).

remaining

El número de conexiones que podrían crearse en este agrupamiento. Por ejemplo, supongamos que un agrupamiento tenía 5 conexiones pendientes y 3 conexiones en el agrupamiento. Podríamos crear 8 nuevas instancias de MongoClient antes de agotar este agrupamiento (asumiendo que ninguna instancia de MongoClient quedó fuera de ámbito, devolviendo sus conexiones al agrupamiento).

Un número negativo indica que este agrupamiento generará conexiones ilimitadas.

Antes de crear un agrupamiento, se puede cambiar el número máximo de conexiones invocando a Mongo::setPoolSize(). Una vez que se ha llamado a esta función, no se podrá modificar su tamaño.

total

El número total de conexiones permitidas en este agrupamiento. Debería ser mayor o igual a la suma de "in use" + "in pool" (o -1).

timeout

El tiempo máximo de espera del socket para las conexiones de este agrupamiento. Indica por cuánto tiempo la agrupación intentará conectarse con un servidor antes de darse por vencidas.

waiting

Si se ha restringido el tamaño del agrupamiento, los procesos que soliciten conexiones de este agrupamiento podrán quedarse bloqueados hasta que otros procesos devuelvan sus conexiones. Este campo indica por cuántos milisegundos quedarán bloqueados esperando a que se libere una conexión. Si este número creciera demasiado, quizás sea conveniente usar MongoPool::setSize() para añadir más conexiones al agrupamiento.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.


Establece el tamaño de los nuevos agrupamientos de conexiones

  • « MongoPool::info
  • Mongo »
  • PHP Manual
  • MongoPool
  • Establece el tamaño de los nuevos agrupamientos de conexiones

MongoPool::setSize

(PECL mongo >= 1.2.3)

MongoPool::setSize — Establece el tamaño de los nuevos agrupamientos de conexiones

Descripción

public static MongoPool::setSize ( int $size ) : bool

Establece el número máximo de conexiones que podrán crear los nuevos agrupamientos.

Parámetros

size

El número máximo de conexiones que podrán crear los nuevos agrupamientos. Un número negativo indica que el agrupamiento podrá generar un número infinito de conexiones.

Valores devueltos

Devuelve el valor del tamaño anterior del agrupamiento.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ejemplos

Ejemplo #1 Ejemplo de Mongo::setPoolSize()

Si se establece un tamaño de agrupamiento de n y se crean n conexiones, al intentar crear la conexión n+1 se lanzará una excepción de tipo MongoConnectionException.

<?php

// permitir solamente una conexión al servidor
MongoPool::setSize(1);

// crear una conexión a localhost:27017
$m1 = new Mongo();

// intentar crear una segunda conexión a localhost:27017
// puesto que sólo se permite una, se lanzará una excepción
$m2 = new Mongo();

?>

El resultado del ejemplo sería algo similar a:

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

Ver también

  • MongoPool::getSize() - Devuelve el tamaño actual de un agrupamiento de conexiones
  • MongoPool::info() - Devuelve información sobre todos los agrupamientos de conexiones
  • La documentación sobre conexiones.


La clase Mongo [obsoleta]

(PECL mongo >=0.9.0)

Introducción

Una conexión entre PHP y MongoDB.

Esta clase extiende a MongoClient y proporciona acceso a varios métodos obsoletos.

Por retrocompatibilidad, el valor predeterminado de la opción "w" del argumento de su constructor es 0, el cual no requiere que el servidor reconozca operaciones de escritura. Véase MongoClient::__construct() para más información.

Advertencia

Esta clase ha sido declarada OBSOLETA a partir de la versión 1.3.0. No se recomienda confiar en esta característica. Por favor, use MongoClient en su lugar.

Sinopsis de la Clase

Mongo extends MongoClient {
/* Métodos */
protected connectUtil ( ) : bool
public static getPoolSize ( ) : int
public getSlave ( ) : string
public getSlaveOkay ( ) : bool
public poolDebug ( ) : array
public static setPoolSize ( int $size ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public switchSlave ( ) : string
/* Métodos heredados */
public MongoClient::close ( boolean|string $connection = ? ) : bool
public MongoClient::connect ( ) : bool
public MongoClient::dropDB ( mixed $db ) : array
public MongoClient::__get ( string $dbname ) : MongoDB
public static MongoClient::getConnections ( ) : array
public MongoClient::getHosts ( ) : array
public MongoClient::getReadPreference ( ) : array
public MongoClient::getWriteConcern ( ) : array
public MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id ) : bool
public MongoClient::listDBs ( ) : array
public MongoClient::selectCollection ( string $db , string $collection ) : MongoCollection
public MongoClient::selectDB ( string $name ) : MongoDB
public MongoClient::setReadPreference ( string $read_preference , array $tags = ? ) : bool
public MongoClient::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public MongoClient::__toString ( ) : string
}

Tabla de contenidos

  • Mongo::connectUtil — Conecta con un servidor de bases de datos
  • Mongo::__construct — El propósito de __construct
  • Mongo::getPoolSize — Obtener el tamaño de las agrupaciones de conexiones
  • Mongo::getSlave — Devuelve la dirección usada por las lecturas de slaveOkay
  • Mongo::getSlaveOkay — Obtiene el valor de slaveOkay de esta conexión
  • Mongo::poolDebug — Devuelve información sobre todas las agrupaciones de conexiones
  • Mongo::setPoolSize — Establecer el tamaño para futuras agrupaciones de conexiones
  • Mongo::setSlaveOkay — Cambia el valor de slaveOkay para esta conexión
  • Mongo::switchSlave — Elije un nuevo secundario para lecturas slaveOkay


Conecta con un servidor de bases de datos

  • « Mongo
  • Mongo::__construct »
  • PHP Manual
  • Mongo
  • Conecta con un servidor de bases de datos

Mongo::connectUtil

(PECL mongo >=0.9.0)

Mongo::connectUtil — Conecta con un servidor de bases de datos

Descripción

protected Mongo::connectUtil ( ) : bool
Advertencia

Esta es una función interna que nunca debería ser invocada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Indica si la conexión tuvo éxito.

Errores/Excepciones

Emite MongoConnectionException si falla la conexión a la base de datos.


El propósito de __construct

  • « Mongo::connectUtil
  • Mongo::getPoolSize »
  • PHP Manual
  • Mongo
  • El propósito de __construct

Mongo::__construct

(PECL mongo >=0.9.0)

Mongo::__construct — El propósito de __construct

Descripción

public Mongo::__construct ( string $server = ? , array $options = ? )

Este método sobrescribe al constructor de MongoClient y desactiva la aceptación de escrituras.

Por favor, véase MongoClient::__construct() para la descripción de los parámetros.

Valores devueltos

Advertencia

La instanciación de esta clase emitirá una advertencia de tipo E_DEPRECATED, y desactivará la aceptación de escrituras.

Por favor, use MongoClient en su lugar.


Obtener el tamaño de las agrupaciones de conexiones

  • « Mongo::__construct
  • Mongo::getSlave »
  • PHP Manual
  • Mongo
  • Obtener el tamaño de las agrupaciones de conexiones

Mongo::getPoolSize

(PECL mongo >=1.2.0)

Mongo::getPoolSize — Obtener el tamaño de las agrupaciones de conexiones

Descripción

public static Mongo::getPoolSize ( ) : int
Advertencia

Esta característica ha sido declarada OBSOLETA a partir de la versión 1.2.3. Se recomienda encarecidamente no confiar en ella. Por favor, use MongoPool::getSize() en su lugar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño de la agrupación actual.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED al usarla.

Ejemplos

Ejemplo #1 Cambiar el tamaño de la agrupación

Devuelve el tamaño de la agrupación predeterminada, establece un nuevo tamaño, imprime ese nuevo tamaño y la información de depuración de la agrupación. Observe que cambiar el tamaño de la agrupación únicamente afecta a agrupaciones conexiones nuevas, no cambia las antiguas.

<?php

$conexión = new Mongo("host1");

// el tamaño de la agrupación es -1
echo "el tamaño de la agrupación es: ".Mongo::getPoolSize()."\n";

echo "establecer el tamaño de la agrupación a 200\n";

Mongo::setPoolSize(200);

// el tamaño de la agrupación es 200
echo "el tamaño de la agrupación es: ".Mongo::getPoolSize()."\n";

$conexión2 = new Mongo("host2");

// lo que queda para host1 es -2
// lo que queda para host2 es 199
var_dump(Mongo::poolDebug());

?>

Ver también

  • Mongo::setPoolSize() - Establecer el tamaño para futuras agrupaciones de conexiones
  • Mongo::poolDebug() - Devuelve información sobre todas las agrupaciones de conexiones
  • La documentación de conexión.


Devuelve la dirección usada por las lecturas de slaveOkay

  • « Mongo::getPoolSize
  • Mongo::getSlaveOkay »
  • PHP Manual
  • Mongo
  • Devuelve la dirección usada por las lecturas de slaveOkay

Mongo::getSlave

(PECL mongo >=1.1.0)

Mongo::getSlave — Devuelve la dirección usada por las lecturas de slaveOkay

Descripción

public Mongo::getSlave ( ) : string

Busca la dirección del secundario que está siendo usado para lecturas. Es un método de solo lectura: no cambia nada del estado interno del objeto.

Cuando se crea una conexión a la base de datos, el controlador no decide inmediatamente el secundario a usar. Así, después de la conexión, esta función devolverá null incluso si hay secundarios disponibles. Cuando se realice una primera consulta con slaveOkay establecido el controlador eligirá un secundario para dicha conexión. En ese punto, esta función devolverá el secundario elegido.

Véase la sección de consultas de este manual para información sobre la distribución de lecturas en secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La dirección del secundario que está usando esta conexión para las lecturas.

Devuelve null si no se está conectado a un conjunto réplica o aún no se ha inicializado.

Errores/Excepciones

Emite una advertencia E_DEPRECATED

Los resultados devueltos realmente no son útiles, ya que el proceso de selección del secundario se realiza en cada consulta y cada ejecución de un comando de base de datos.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED al utilizarlo.

Ver también

  • MongoCursor::info() - Obtiene la información sobre la creación e iteración del cursor


Obtiene el valor de slaveOkay de esta conexión

  • « Mongo::getSlave
  • Mongo::poolDebug »
  • PHP Manual
  • Mongo
  • Obtiene el valor de slaveOkay de esta conexión

Mongo::getSlaveOkay

(PECL mongo >=1.1.0)

Mongo::getSlaveOkay — Obtiene el valor de slaveOkay de esta conexión

Descripción

public Mongo::getSlaveOkay ( ) : bool

Véase la sección de consultas de este manual para obtener información sobre lecturas distribuidas en secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor de slaveOkay de esta instancia.

Errores/Excepciones

Emite una advertencia E_DEPRECATED

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoClient::getReadPreference() - Obtener la preferencia de lectura para esta conexión


Devuelve información sobre todas las agrupaciones de conexiones

  • « Mongo::getSlaveOkay
  • Mongo::setPoolSize »
  • PHP Manual
  • Mongo
  • Devuelve información sobre todas las agrupaciones de conexiones

Mongo::poolDebug

(PECL mongo >=1.2.0)

Mongo::poolDebug — Devuelve información sobre todas las agrupaciones de conexiones

Descripción

public Mongo::poolDebug ( ) : array
Advertencia

Esta característica ha sido declarada OBSOLETA a partir de la versión 1.2.3. Se desaconseja confiar en esta característica. Por favor, use MongoPool::info() en su lugar.

Devuelve un array con información sobre todas las agrupaciones de conexiones.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Cada agrupación de conexiones tiene un identificador que comienza con el host. Para cada agrupación, esta función muestra los siguientes campos:

in use

El número de conexiones usadas actualmente por instancias de MongoClient.

in pool

El número de conexiones que hay en la agrupación actualmente (no siendo usadas).

remaining

El número de conexiones que podría crear esta agrupación. Por ejemplo, supongamos que una agrupación tiene 5 conexiones restantes y 3 en la agrupación. Se podrían crear 8 nuevas instancias de MongoClient antes de agotar esta agrupación (asumiendo que no hay ninguna instancia de MongoClient fuera de ámbito, devolviendo sus conexiones a la agrupación).

Un número negativo significa que esta agrupación generará conexiones ilimitadas.

Antes de crear una agrupación, se puede elegir el número máximo de conexiones llamando a Mongo::setPoolSize(). Una vez que la agrupación aparzca en la salida de esta función, no se podrá cambiar su tamaño.

timeout

El tiempo de espera del socket para las conexiones de esta agrupación. Es por cuánto tiempo las conexiones de esta agrupación intentarán conectarse a un servidor antes de desistir.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED al utilizarlo.


Establecer el tamaño para futuras agrupaciones de conexiones

  • « Mongo::poolDebug
  • Mongo::setSlaveOkay »
  • PHP Manual
  • Mongo
  • Establecer el tamaño para futuras agrupaciones de conexiones

Mongo::setPoolSize

(PECL mongo >=1.2.0)

Mongo::setPoolSize — Establecer el tamaño para futuras agrupaciones de conexiones

Descripción

public static Mongo::setPoolSize ( int $size ) : bool
Advertencia

Este método ha sido declarado OBSOLETO a partir de la versión 1.2.3. Se desaconseja confiar en esta característica. Por favor, use MongoPool::setSize() en su lugar.

Establece el numero máximo de conexiones que podrán crear las nuevas agrupaciones.

Parámetros

size

El número máximo de conexiones que podrán crear las futuras agrupaciones. Los valores negativos indican que la agrupación generará un número infinito de conexiones.

Valores devueltos

Devuelve el valor antiguo del tamaño de agrupación.

Ejemplos

Ejemplo #1 Ejemplo de Mongo::setPoolSize()

Si se establece el tamaño de la agrupación a n y luego se crean n conexiones, el intento de crear una conexión n+1ésitma lanzará una excepción de tipo MongoConnectionException.

<?php

// permitir solamente una conexión al servidor
Mongo::setPoolSize(1);

// crear una conexión a localhost:27017
$m1 = new Mongo();

// intentar crear una segunda conexión a localhost:27017
// solamente está permitida una conexión, por lo que se lanzará una excepción
$m2 = new Mongo();

?>

El resultado del ejemplo sería algo similar a:

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

Ver también

  • Mongo::getPoolSize() - Obtener el tamaño de las agrupaciones de conexiones
  • Mongo::poolDebug() - Devuelve información sobre todas las agrupaciones de conexiones
  • La documentación de conexiones.


Cambia el valor de slaveOkay para esta conexión

  • « Mongo::setPoolSize
  • Mongo::switchSlave »
  • PHP Manual
  • Mongo
  • Cambia el valor de slaveOkay para esta conexión

Mongo::setSlaveOkay

(PECL mongo >=1.1.0)

Mongo::setSlaveOkay — Cambia el valor de slaveOkay para esta conexión

Descripción

public Mongo::setSlaveOkay ( bool $ok = true ) : bool

Véase la sección de consultas de este manual para obtener información sobre lecturas distribuidas en secundarios.

Parámetros

ok

Indica si las lecturas deberían o no enviarse a los miembros secundarios del conjunto de réplicas, para todas aquellas consultas que se realicen con esta instancia de MongoClient.

Valores devueltos

Devuelve el valor anterior de slaveOkay que tenía esta instancia.

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura
  • MongoClient::setReadPreference() - Establece la preferencia de lectura para esta conexión


Elije un nuevo secundario para lecturas slaveOkay

  • « Mongo::setSlaveOkay
  • Funciones de Mongo »
  • PHP Manual
  • Mongo
  • Elije un nuevo secundario para lecturas slaveOkay

Mongo::switchSlave

(PECL mongo >=1.1.0)

Mongo::switchSlave — Elije un nuevo secundario para lecturas slaveOkay

Descripción

public Mongo::switchSlave ( ) : string

Elije un secundario aleatorio para una conexión desde la cual realizar las lecturas. Este método es invocado automáticamente por el controlador, por lo que no es necesesario utilizarlo. Realiza una llamada a MongoClient::getHosts() (para recargar el estado de los hosts) y a MongoClient::getSlave() (para obtener el valor devuelto).

Véase la sección de consultas de este manual para obtener información sobre lecturas distribuidas en secundarios.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La dirección del secundario que está usando esta conexió para realizar lecturas. Podría ser la misma que la anterior, ya que se eligen aleatoriamente. Si sólo hubiera un secundario (o sólo el primario) únicamente se devolvería una dirección.

Por ejemplo, si tuviéramos un conjunto de réplicas de tres miembros, con un primario, secundario, y un árbitro, este método siempre devolvería la dirección del secundario. Si éste no estvuiera disponible, este método devolvería la dirección del primario. Si éste tampoco estuviera disponible, se emitiría una excepción, ya que un árbitro no puede realizar operaciones de lectura.

Errores/Excepciones

Si se le llama desde una conexión sin conjuntos de réplicas, emite MongoException (código de error 15). También emite MongoException si no pudiera encontrar ningún elemento (primario o secundario) del que leer (código de error 16).

Historial de cambios

Versión | Descripción
1.2.11 | Emite un error de nivel E_DEPRECATED cuando se usa.

Ver también

  • Preferencias de lectura


Funciones de Mongo

Tabla de contenidos

  • bson_decode — Decodifica un objecto BSON a un array PHP
  • bson_encode — Serializa una variable PHP a un string BSON


Decodifica un objecto BSON a un array PHP

  • « Funciones de Mongo
  • bson_encode »
  • PHP Manual
  • Funciones de Mongo
  • Decodifica un objecto BSON a un array PHP

bson_decode

(PECL mongo >=1.0.1)

bson_decode — Decodifica un objecto BSON a un array PHP

Descripción

bson_decode ( string $bson ) : array

Esta función es muy beta todavía y es inútil para el 99% de usuarios. Solo es útil en casos especiales, como cuando se necesita escribir tu propio driver encima del driver de PHP.

Parámetros

bson

El BSON a ser decodificado.

Valores devueltos

Devuelve un objecto BSON decodificado.


Serializa una variable PHP a un string BSON

  • « bson_decode
  • Excepciones »
  • PHP Manual
  • Funciones de Mongo
  • Serializa una variable PHP a un string BSON

bson_encode

(PECL mongo >=1.0.1)

bson_encode — Serializa una variable PHP a un string BSON

Descripción

bson_encode ( mixed $anything ) : string

Esta función es muy beta todavía y es inútil para el 99% de usuarios. Solo es útil en casos especiales, como cuando se necesita escribir tu propio driver encima del driver de PHP.

Parámetros

anything

La variable ha serializar.

Valores devueltos

Devuelve un string serializado.


Excepciones

Tabla de contenidos

  • MongoException
  • MongoResultException
  • MongoCursorException
  • MongoCursorTimeoutException
  • MongoConnectionException
  • MongoGridFSException
  • MongoDuplicateKeyException
  • MongoProtocolException
  • MongoExecutionTimeoutException
  • MongoWriteConcernException

Peculiaridades de VMWare

Si se está ejecutando VMWare en Windows y se usa CIFS, al pausar la máquina virtual se desincronizará CIFS, causando errores inesperados al reanudarla ("El objeto Mongo no ha sido inicializado correctamente por su constructor"). Si se monta de forma permanente los compartidos de Windows, se corregirá este problema y ya se podrá pausar y reanudar.

Para montar permanentemente los compartidos de Windows, ejecute:

$ sudo update-rc.d -f umountnfs.sh remove
$ sudo update-rc.d umountnfs.sh stop 15 0 6 .

Consulte » la documentación de Ubuntu para ver las instrucciones más actualizadas.


Clase MongoException

(PECL mongo >= 1.0.0)

Introducción

Excepción Mongo predeterminada.

Abarca un gran número de condiciones de error que, eventualmente, podrán moverse a excepciones más específicas, pero que en cualquier caso siempre extenderán MongoException.

  • The MongoSomething object has not been correctly initialized by its constructor

    Código: 0

    Probablemente tu objeto Mongo no esté conectado al servidor de bases de datos.

  • zero-length keys are not allowed, did you use $ with double quotes?

    Código: 1

    Se ha intentado guardar el valor "" como clave. En general, no se debe hacer esto. "" podría provocar errores al acceder a subobjetos, además de que es usado internamente por MongoDB. Sin embargo, si realmente quiere, puede asignar en su fichero php.ini el valor true a mongo.allow_empty_keys para sobrescribir esta comprobación. Si se sobrescribe, se recomienda encarecidamente establecer la comprobación estricta de errores para evitar errores de interpolación de textos.

  • '.' not allowed in key: <key>

    Código: 2

    Se ha intentado escribir una clave que contiene un ".", lo cual está prohibido.

  • insert too large: <size>, max: <max>

    Código: 3

    Se ha intentado enviar demasiada información de una vez a la base de datos: la base de datos sólo acepta inserciones de hasta un determinado tamaño (actualmente 16 MB).

  • no elements in doc

    Código: 4

    Se ha intentado guardar un documento que no contiene ningún campo.

  • size of BSON doc is <size> bytes, max <max>MB

    Código: 5

    Se ha intentado guardar un documento con un tamaño superior al que MongoDB puede guardar.

  • no documents given

    Código: 6

    Se ha intentado insertar por lotes un array vacío de documentos.

  • MongoCollection::group takes an array, object, or MongoCode key

    Código: 7

    Se han enviado a MongoCollection::group() parámetros del tipo equivocado

  • field names must be strings

    Código: 8

    Deben formatearse los selectores de la siguiente forma: array("field1" => 1, "field2" => 1, ..., "fieldN" => 1).

  • invalid regex

    Código: 9

    La expresión regular pasada a MongoRegex no cumple la forma correcta.

  • MongoDBRef::get: $ref field must be a string

    Código: 10

  • MongoDBRef::get: $db field must be a string

    Código: 11

  • non-utf8 string: <str>

    Código: 12

    Sucede cuando se intenta enviar un texto que no es utf8 a la base de datos. Todos los textos que se envíen a la base de datos deben estar en UTF8. Revise las opciones de php.ini para conocer la opción de transición que evita esta excepción.

  • mutex error: <err>

    Código: 13

    En entornos multihebra, el driver utiliza mutex para sincronizar las peticiones y las respuestas. Este es un error crítico que no se puede trazar. Es poco usual y debe notificarse a los mantenedores junto con cualquier información del sistema y los pasos que se han seguido para reproducir el error.

  • index name too long: <len>, max <max> characters

    Código: 14

    No se crearán índices con nombres superiores a 128 caracteres. Si se obtuviera este error, se debería usar la opción "name" de MongoCollection::ensureIndex() para crear un nombre más corto para el índice.

Sinopsis de la Clase

MongoException extends Exception {
}


La clase MongoResultException

(PECL mongo >=1.3.0)

Introducción

Una MongoResultException es lanzada por varios ayudantes de comandos (como MongoCollection::findAndModify()) en caso de que ocurra un error. El documento resultante original está disponible a través de MongoResultException::getDocument().

Sinopsis de la Clase

MongoResultException extends MongoException {
/* Propiedades */
public $document ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public getDocument ( ) : array
}

Propiedades

document

Un array con el documento resultante sin tratar.

Tabla de contenidos

  • MongoResultException::getDocument — Recupera el documento resultante completo


Recupera el documento resultante completo

  • « MongoResultException
  • MongoCursorException »
  • PHP Manual
  • MongoResultException
  • Recupera el documento resultante completo

MongoResultException::getDocument

(PECL mongo >=1.3.0)

MongoResultException::getDocument — Recupera el documento resultante completo

Descripción

public MongoResultException::getDocument ( ) : array

Recupera el documento resultante de errores completo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El documento resultante completo es un array, incluyendo datos parciales si están disponibles y claves adicionales.

Ejemplos

Ejemplo #1 Ejemplo de MongoResultException::getDocument()

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

$c->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => true)
);

try {
    $retval = $c->findAndModify(
         array("inprogress" => false, "name" => "Biz report"),
         array('$set' => array('$set' => array('inprogress' => true, "started" => new MongoDate()))),
         null,
         array(
            "sort" => array("priority" => -1),
            "new" => true,
        )
    );
} catch(MongoResultException $e) {
    echo $e->getMessage(), "\n";
    $res = $e->getDocument();
    var_dump($res);
}
?>

El resultado de los ejemplos sería algo similar a:

$set is not valid for storage.
array(3) {
  ["lastErrorObject"]=>
  array(5) {
    ["connectionId"]=>
    int(6)
    ["err"]=>
    string(30) "$set is not valid for storage."
    ["code"]=>
    int(52)
    ["n"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["ok"]=>
  float(0)
  ["errmsg"]=>
  string(30) "$set is not valid for storage."
}


La clase MongoCursorException

(PECL mongo >= 1.0.0)

Introducción

Esta exceptción es causada por el acceso a un cursor de forma incorrecta o en un error al recibir una réplica. Obsérvese que esta excepción puede ser lanzada por cualquier petición a la base de datos que reciba una réplica, no solamente consultas. Las escrituras, comandos y cualquier otra operación que envie información a la base de datos y espere una respuesta, puede lanzar una MongoCursorException. La única excepción es new MongoClient() (crear una nueva conexión), la cual solamente lanzará MongoConnectionExceptions.

Devuelve un mensaje de error específico para ayudar a diagnosticar el problema, y un código de error numérico asociado con la causa de la excepción.

Por ejemplo, suponga que se intentan insertar dos documentos con el mimo _id:

<?php

try {
    $collection->insert(array("_id" => 1), array("w" => 1));
    $collection->insert(array("_id" => 1), array("w" => 1));
}
catch (MongoCursorException $e) {
    echo "error message: ".$e->getMessage()."\n";
    echo "error code: ".$e->getCode()."\n";
}

?>
This would produce output like:
mensaje de error: E11000 duplicate key error index: foo.bar.$_id_  dup key: { : 1 }
código del error: 11000
Obsérvese que el código de error de MongoDB (11000) se usa para el código de error de PHP. El controlador de PHP utiliza el código de error "nativo" siempre que sea posible.

La lista siguietne contiene errores comunes y sus causas. Los mensajes de error exactos están en cursiva; los errores donde el mensaje puede variar están descritos entre barras oblicuas.

  • cannot modify cursor after beginning iteration (no se puede modificar el cursor después de iniciar una iteración)

    Código: 0

    Se está invocando a un método que configura la consulta después de ejecutarla. Reinice el cursor y vuelva a intentarlo.

    Un ejemplo:

    <?php

    try {
            $cursor = $colección->find();
            var_dump($cursor->getNext());

            // getNext() consulta a la base de datos, es demasiado tarde para establecer un límite
            $cursor->limit(1);
    }
    catch (    MongoCursorException $e) {
        echo     "mensaje de error: ".$e->getMessage()."\n";
        echo     "código del error: ".$e->getCode()."\n";
    }

    // si bien, esto funcionará:
    $cursor->getNext();
    $cursor->reset();
    $cursor->limit(1);

    ?>

  • La obtención del siguiente lote envía errores

    Código: 1

    Podría no enviarse la consulta a la base de datos. Asegúrese de que la base de datos aún está activa y la red funciona bien.

  • cursor not found (cursor no encontrado)

    Código: 2

    El controlador estuvo intentando obtener más resultados de la base de datos, pero ésta no tiene un registro de la consulta. Esto usualmente significa que el cursor a expirado en el lado del servidor: después de unos pocos minutos de inactividad, la base de datos destruirá un cursor (véase MongoCursor::immortal() para información sobre cómo prevenir esto).

    Un ejemplo:

    <?php

    try {
            $cursor = $colección->find();
            $cursor->getNext();

            // dormir durante 15 minutos
            sleep(60*15);

        while (    $cursor->hasNext()) {
                $cursor->getNext();
        }
    }
    catch (    MongoCursorException $e) {
        echo     "mensaje de error: ".$e->getMessage()."\n";
        echo     "código del error: ".$e->getCode()."\n";
    }

    ?>

  • cursor->buf.pos is null (cursor->buf.pos es null)

    Código: 3

    Esto podría indicar que se ha quedado sin RAM o alguna otra circunstancia extraordinaria.

  • couldn't get response header (no se pudo obtener la cabecera de respuesta)

    Código: 4

    Un error común si la base de datos o la red se caen. Esto significa que el controlador podría no obtener una respuesta de la conexión.

  • no db response (sin resupesta de la base de datos)

    Código: 5

    Esto podría incluso no ser un error, por ejemplo, el comando de base de datos "shutdown" no devuelve respuesta alguna. Sin embargo, si se espera una respuesta, esto significa que la base de datos no proporcionó ninguna.

  • bad response length: %d, did the db assert? (longitud de respuesta errónea: %d, ¿se declaró la bd?

    Código: 6

    Esto significa que la base de datos indica que su respuesta fue menor que 0. Este error probablemente indica un error de red o corrupción de la base de datos.

  • incomplete header (cabecera incompleta)

    Código: 7

    Muy poco usual. Ocurre si la respuesta de la base de datos se inicia correctamente, pero se interrumpe a la mitad. Probablemente indica un problema de red.

  • incomplete response (respuesta incompleta)

    Código: 8

    Muy poco usual. Ocurre si la respuesta de la base de datos se inicia correctamente, pero se interrumpe a la mitad. Probablemente indica un problema de red.

  • couldn't find a response (no se pudo encontrar una respuesta)

    Código: 9

    Si la respuesta fue almacenada en caché y ahora no se puede localizar.

  • error getting socket (error al obtener el socket)

    Código: 10

    El socket fue cerrado o se encontró con un error. El controlador debería reconectar automáticamente (si es posible) en la siguiente operación.

  • couldn't find reply, please try again (no se pudo encontrar la réplica, inténtelo de nuevo)

    Código: 11

    El controlador guarda cualquier respuesta de la base de datos que no pudo hacer coincidir inmediatamente con una petición. Esta excepción ocurre si el controlador ya ha pasado la respuestta de la petición y no puede encontrarla en su caché.

  • error getting database response: errstr (error al obtener una respuesta de la base de datos: errstr)

    WSA error getting database response: errstr (error WSA al obtener una respuesta de la base de datos: errstr)

    "errstr" es un error de E7S reportado directamente desde el subsistema de sockets de C. En Windows, el mensaje de error está prefijado con "WSA".

  • Timeout error (Error de tiempo de espera)

    Código: 13

    Si hubo un error mientras se esperaba a que se completase una consulta.

  • couldn't send query: <various> (no se pudo enviar la consulta: <variado>)

    Código: 14

    Error del socket de C en el envío.

  • max number of retries exhausted, couldn't send query (número máximo de reintentos agotados, no se pudo enviar la consulta)

    Código: 19

    El controlador automáticamente reintentará realizar consultas "planas" (no comandos) un par de veces si el primer intento falló por ciertas razones. Esto es para causar menos excepciones durante la tolerancia a fallos del conjunto de réplicas (aunque probablemente aún tendrá que tratar con alguna) y pasar por alto asuntos de red transitorios.

    Esto también puede ser causado porque el controlador no es capaz de reconectar de ningún modo a la base de datos (si, por ejemplo, la base de datos está ilocalizable).

    Versión 1.2.2+.

Errores pasados a través de la base de datos

Los errores de la base de datos deberían siempre desencadenar MongoCursorExceptions en consultas. Los mensajes y los códigos de error son enviados directamente desde la base de datos, por lo que se deberían poder ver los errores coincidentes en el registro (log) de la base de datos.

A continuación se enumeran algunos errores de base de datos comunes:

  • E11000 duplicate key error index: foo.bar.$X dup key: { /* ... */ }

    Código: 11000

    Error de base de datos para claves duplicadas.

  • not master

    Códigos: 10107, 13435, y 10058

    Errores de no haber maestro, conducidos a través de la base de datos. Cada uno de estos errores causará que el controlador se desconecte e intente encontrar un nuevo primario. El error real que se obtiene en la tolerancia a fallos podría no ser un error "not master", dependiendo de cuando ocurra el cambio en el primario.

Sinopsis de la Clase

MongoCursorException extends MongoException {
}

Tabla de contenidos

  • MongoCursorException::getHost — El nombre de host del servidor que encontró el error


El nombre de host del servidor que encontró el error

  • « MongoCursorException
  • MongoCursorTimeoutException »
  • PHP Manual
  • MongoCursorException
  • El nombre de host del servidor que encontró el error

MongoCursorException::getHost

(PECL mongo >= 1.0.0)

MongoCursorException::getHost — El nombre de host del servidor que encontró el error

Descripción

public MongoCursorException::getHost ( ) : string

Devuelve el nombre de host del sevidor al que se le envió la consulta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de host, o NULL si este es desconocido.


La clase MongoCursorTimeoutException

(PECL mongo >= 1.0.0)

Introducción

Lanzado cuando se excede el tiempo máximo de espera de una consulta. Puede establecer el tiempo de espera que se usará antes de lanzar esta excepción, llamando a MongoCursor::timeout() en el cursor, o mediante MongoCursor::$timeout. Esta variable estática resulta útil para consultas tales como comandos de la base de datos o en MongoCollection::findOne(), las cuales utilizan implícitamente cursores.

Sinopsis de la Clase

MongoCursorTimeoutException extends MongoCursorException {
}


Clase MongoConnectionException

(PECL mongo >= 1.0.0)

Introducción

Lanzado cuando falla el driver al conectar a la base de datos.

Existen varios mensajes de error posibles para ayudar a diagnosticar el problema de conexión:

  • No candidate servers found

    Lanzado cuando el controlador no puede establecer una conexión con MongoDB (satisfaciendo las ReadPreferences, si se especifican).

  • No server name given.

    Este error ocurre al pasar "" como nombre de servidor, probablemente por error tipográfico con interpolación de strings, p.ej., "$servr" en lugar de "$server".

  • failed to get host [hostname] or port [portnum] from [server].

    Indica que el nombre del servidor está malformado. "[hostname"] y "[portnum]" serán lo que el driver haya descifrado que sean.

  • Operation in progress

    Superado el tiempo de espera de conexión a la base de datos.

  • Transport endpoint is not connected

    Generalmente indica que la cadena de conexión no es correcta. De hecho, el driver no puede ni encontrar el servidor de bases de datos.

  • couldn't determine master

    Ningún servidor de una conexión a un conjunto de réplicas fue identificado como el primario.

  • couldn't get host info for [server]

    Indica que el DNS no puede resolver la dirección de servidor proporcionada. Posiblemente se trate de un error tipográfico, por ejemplo, "server" en lugar de "$server".

  • Invalid Argument

    Puede provocarse al intentar conectar a una máquina que está funcionando pero la base de datos no está funcionando. Asegúrese de que ha iniciado la base de datos antes de conectar.

  • Permission denied

    Significa que el socket no pudo ser abierto debido a los permisos. En las variantes de Red hat, puede ser debido a que la configuración por defecto no permite a Apache crear conexiones de red. Puede modificarse esto ejecutando:

    $ /usr/sbin/setsebool -P httpd_can_network_connect 1
    y reiniciando Apache.

Si el mensaje de error no se encuentra en la lista de arriba, probablemente sea un error del socket C, y podrá buscar en la web la causa del mismo.

Sinopsis de la Clase

MongoConnectionException extends MongoException {
}


Clase MongoGridFSException

(PECL mongo >= 1.0.0)

Introducción

Lanzada cuando hay errores al leer o escribir ficheros hacia o desde la base de datos.

Sinopsis de la Clase

MongoGridFSException extends MongoException {
}

Códigos de error

Códigos de error de MongoGridFSException
Código | Mensaje | Motivo
3 | Could not open file $filename | Intento de almacenar un fichero no válido, como un directori
4 | File $filename is too large: $filesize bytes | El tamaño máximo de ficheros en GridFS es de 4GB
5 | could not find filehandle | El recurso no posee un gestor de fichero
6 | no file is associate with this filehandle | El recurso no es un recurso de fichero
7 | error setting up file: $filenames | No se pudo abrir el fichero para lectura
9 | error reading file $filenames | Error al leer el fichero
10 | error reading filehandle | Error al leer desde un recurso
11 | could not find uploaded file %s | El nombre del fichero no parece ser un fichero subido
12 | Couldn't find tmp_name in the $_FILES array. Are you sure the upload worked? | Probablemente falló el nombre de fichero subido
13 | tmp_name was not a string or an array | Se proporcionó un nombre de fichero no válido
14 | couldn't find file size | Falta la propiedad length
15 | Cannot find filename | No se proporcionó un nombre de fichero, y no estaba establecida la propiedad filename
16 | could not open destination file %s | El nombre de fichero destino no es modificable
17 | error reading chunk of file | Trozo corrupto
18 | couldn't create a php_stream | No se pudo crear un recurso de flujo
19 | couldn't find property | Trozo corrupto
20 | chunk number has wrong size (size) when the max is maxchunksize | El trozo era más grande del esperado
21 | chunk has wrong format | Trozo corrupto


La clase MongoDuplicateKeyException

(PECL mongo >= 1.5.0)

Introducción

Lanzada al intentar insertar un documento en una collección que ya contiene los mismos valores para las claves únicas.

Sinopsis de la Clase

MongoDuplicateKeyException extends MongoWriteConcernException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public MongoWriteConcernException::getDocument ( ) : array
}

Ejemplos

Ejemplo #1 Capturar una MongoDuplicateKeyException

<?php
$mc = new MongoClient("localhost");

$c = $mc->selectCollection("test", "test");

$c->insert(array('_id' => 1));
try {
    $c->insert(array('_id' => 1));
} catch (MongoWriteConcernException $e) {
    echo $e->getMessage(), "\n";
}
?>

El resultado de los ejemplos sería algo similar a:

localhost:27017: insertDocument :: caused by :: 11000 E11000 duplicate key error index: test.test.$_id_  dup key: { : 1 }


La clase MongoProtocolException

(PECL mongo >= 1.5.0)

Introducción

Al conversar con MongoDB 2.6.0, y posterior, ciertas operaciones (como las escrituras) pueden lanzar una MongoProtocolException cuando la respuesta del servidor no tiene sentido - por ejemplo durante un fallo de red (podríamos leer la respuesta completa) o corrupción de datos.

Esta excepción también es lanzada al intentar conversar con protocolos más recientes de los que soporta el servidor, por ejemplo, usando MongoWriteBatch al conversar con un servidor de MongoDB anterior a la versión 2.6.0.

Sinopsis de la Clase

MongoProtocolException extends MongoException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

Ejemplos

Ejemplo #1 Capturar una MongoProtocolException

Ejecutar el siguiente ejemplo con MongoDB anterior a 2.6.0 lanzará una MongoProtocolException

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

try {
    $batch = new MongoInsertBatch($c);
} catch(MongoProtocolException $e) {
    echo $e->getMessage();
}
?>

El resultado de los ejemplos sería algo similar a:

Current primary does not have a Write API


La clase MongoExecutionTimeoutException

(PECL mongo >= 1.5.0)

Introducción

Lanzada cuando una operación expira en el lado del servidor (es decir, en MongoDB).

Para configurar el umbral de expiración de la operación, use MongoCursor::maxTimeMS() o la opción de comando "maxTimeMS".

Sinopsis de la Clase

MongoExecutionTimeoutException extends MongoException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


La clase MongoWriteConcernException

(PECL mongo >= 1.5.0)

Introducción

MongoWriteConcernException es lanzada cuando falla una escritura. Véase Asuntos de Escritura (Write Concerns) para cómo establecer el umbral de fallo.

Antes de MongoDB 2.6.0 » GLE determinaba cuándo fallaba una escritura.

Sinopsis de la Clase

MongoWriteConcernException extends MongoCursorException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public getDocument ( ) : array
/* Métodos heredados */
public MongoCursorException::getHost ( ) : string
}

Tabla de contenidos

  • MongoWriteConcernException::getDocument — Obtener el documento del error


Obtener el documento del error

  • « MongoWriteConcernException
  • Registro de cambios »
  • PHP Manual
  • MongoWriteConcernException
  • Obtener el documento del error

MongoWriteConcernException::getDocument

(PECL mongo >= 1.5.0)

MongoWriteConcernException::getDocument — Obtener el documento del error

Descripción

public MongoWriteConcernException::getDocument ( ) : array

Devuelve la respuesta real del servidor que fue interpretada como un error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un documento de MongoDB, si está disponible, como un array.


Registro de cambios

A las clases/funciones/métodos de esta extensión se han realizado los siguientes cambios.

Controlador de MongoDB para 1.5.0

Tiene soporte para todas las nuevas características de MongoDB 2.6, incluyendo:

  • Aggregate ahora puede devolver un cursor
  • Las tuberías de agregación ahora se pueden explicar
  • Posibilidad de establecer maxTimeMS para comandos y consultas
  • Soporte transparente para la nueva API de escritura de MongoDB basada en comandos
  • Nuevas clases MongoWriteBatch (usando la nueva API de escritura de MongoDB)
  • Soporte para las características de MongoDB Enterprise (p.ej. Kerberos, LDAP, X509)
  • Opción para mejorar la latencia del servidor para lecturas de secundarios (secondaryAcceptableLatencyMS)

Con esta versión, alguna funcionalidad del controlador que estaba anteriormente documentada como obsoleta ahora emitirá formalmente avisos de obsolescencia. Esto incluye:

  • Instanciar la clase Mongo
  • Invocar a MongoCursor::slaveOkay()
  • Las opciones "wtimeout" y "safe" para operaciones de escritura de MongoCollection
  • Manipular propiedades públicas en clases del núcleo (como $collection->w)

Nota:

No se ha eliminado características anteriormente obsoletas.

Cambios en el comportamiento:

  • Ahora, establecer el ajuste INI mongo.native_long emite un error en plataformas de 32 bit, y es true como valor predeterminado en platarformas de 64 bit.

Controlador de MongoDB para 1.4.0

La serie 1.4 introdujo cambios fundamentales en cómo se crean las conexiones a servidores de MongoDB. El controlados ahora utiliza flujos nativos de PHP, aplicándose así todas las opciones de flujos de PHP. Además, se añadió soporte experimental para Contexto de Flujos.

La serie 1.4.x también añadió soporte para MongoDB 2.4.x.

Sin embargo, las mejoras más importantes se ocupan del manejo de conjuntos de réplica, especialmente de los nodos que expiran el tiempo límite y de nodos que son inalcanzables por varias razones. A parte de las mejoras al manejo de conjuntos de réplica, esta versión aborda problemas con preferencias de lectura a través de nodos de mongos. También añade soporte para conexiones habilitadas con SSL, así como para las opciones de string de conexión journal y fsync.

Controlador de MongoDB para 1.3.0

La serie 1.3 introdujo varios cambios mayores a la extensión, tales como reescribir completamente el manejo de conexiones (y eliminar el mecanismo de agrupamiento), dar soporte para ReadPreferences y cambiar los WriteConcerns predeterminados para que sean reconocidos mediante la introducción de la nueva clase MongoClient, que sirve como una clase sustituta para la ahora obsoleta Mongo.

El controlador ahora también admite la conexión a múltiples instancias de mongos (el enrutador Mongo Shard) para el equilibrado de carga.

Otras mejoras incluyen la identificación para una depuración más sencilla de manejo de conexiones con MongoLog, y el soporte para el » Framework Aggregation mediante el método MongoCollection::aggregate().

Cambios en los métodos existentes

La siguiente lista muestra todas las mejoras a los métodos existentes desde su implantación.

Version | Function | Description
1.7.0 | MongoDB::execute | Este método ha sido declarado obsoleto como resultado de estar también obsoleta en MongoDB 3.0+ la orden eval.
1.6.0 | MongoCollection::count | El segundo parámetro ahora es el array de opciones options. Pasar limit y skip como segundo y tercer parámetros, respectivamente, ahora está obsoleto.
 | MongoDB::getCollectionNames | Se cambió el primer parámetro para que sea un array de opciones. Antes de la versión 1.6.0, el primer parámetro era un booleano que indicaba la opción "includeSystemCollections".
 | MongoDB::listCollections | Se cambió el primer parámetro para que sea un array de opciones. Antes de la versión 1.6.0, el primer parámetro era un booleano que indicaba la opción "includeSystemCollections".
1.5.0 | log_cmd_delete | Solamente disponible al conectarse a MongoDB 2.6.0+
 | log_cmd_insert | Solamente disponible al conectarse a MongoDB 2.6.0+
 | log_cmd_update | Solamente disponible al conectarse a MongoDB 2.6.0+
 | log_write_batch | Solamente disponible al conectarse a MongoDB 2.6.0+
 | MongoBinData::__construct | Se cambió el valor predeterminado de 2 (MongoBinData::BYTE_ARRAY) a 0 (MongoBinData::GENERIC).
 | MongoClient::__construct | Se añadieron "authMechanism", "gssapiServiceName", y "secondaryAcceptableLatencyMS".
 | MongoClient::__construct | Se añadió "authSource".
 | MongoCollection::aggregate | Se añadió el parámetro opcional options
 | MongoCollection::batchInsert | Se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout". Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout". Emite un error de nivel E_DEPRECATED al usar "safe".
 | MongoCollection::ensureIndex | Se renombró la opción "wtimeout" a "wTimeoutMS". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout". Se renombró la opción "wtimeout" a "socketTimeoutMS". Emite un error de nivel E_DEPRECATED cuando se usa "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "safe".
 | MongoCollection::findOne | Se añadió el parámetro opcional options.
 | MongoCollection::group | Se añadió la opción "maxTimeMS".
 | MongoCollection::insert | Se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout". Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout". Emite un error de nivel E_DEPRECATED al usar "safe".
 | MongoCollection::remove | se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout". Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout". Emite un error de nivel E_DEPRECATED al usar "safe".
 | MongoCollection::save | Se añadió la opción "wTimeoutMS", la cual reemplaza a "wtimeout". Emite un error E_DEPRECATED al utilizar "wtimeout". Se añadió la opción "socketTimeoutMS", la cual reemplaza a "timeout". Emite un error E_DEPRECATED al utilizar "wtimeout". Emite un error E_DEPRECATED al utilizar "safe".
 | MongoCollection::toIndexString | Este método está obsoleto.
 | MongoCollection::update | se añadió la opción "wTimeoutMS", la cual remplaza a "wtimeout". Emite un error de nivel E_DEPRECATED cuando se usa "wtimeout". Se añadió la opción "socketTimeoutMS", la cual remplza a "timeout". Emite un error de nivel E_DEPRECATED cuando se usa "timeout". Emite un error de nivel E_DEPRECATED al usar "safe".
 | MongoCursor::slaveOkay | Este método está obsoleto en favor de MongoCursor::setReadPreference y .
 | MongoDB::command | Se renombró la opción "timeout" a "socketTimeoutMS". Emite un error E_DEPRECATED al utilizar "timeout". Se añadió el parámetro por referencia hash.
1.4.5 | MongoCursor::batchSize | Antes de la versión 1.4.5, este método lanzaba una MongoCursorException si el cursor ya había comenzado a iterar.
1.4.0 | MongoClient::__construct | Se añadió la opción "ssl" y el soporte para conexiones sobre SSL. Se añadió la opción "wTimeoutMS", que remplaza a "wTimeout". Emite un error de nivel E_DEPRECATED al usar "slaveOkay" o "timeout".
 | MongoCursor::hint | El argumento index ahora admite nombres de índices como valores de tipo string. En versiones anteriores a la 1.4.0, solamente eran aceptados valores de array u objeto.
 | MongoCursor::setFlag | Se añadió el soporte para la bandera 3 (OPLOG_REPLAY). Las versiones anteriorea a la 1.4.0 lanzarán una advertencia diciendo que la bandera no está soportada.
 | MongoDB::createCollection | En versiones anteriores a la 1.4.0, las opciones eran todas argumentos del método. La sinopsis de la función en esas versiones antiguas es: public MongoCollectionMongoDB::createCollection stringname boolcappedfalse intsize0 intmax0 El significado de las opciones es el mismo que el descrito bajo el argumento options de arriba.
 | MongoId::__construct | Se lanza una excepción al proporcionar un string no válido
1.3.4 | MongoClient::__construct | Se añadieron las opciones "connectTimeoutMS" y "socketTimeoutMS".
 | MongoCollection::batchInsert | Se añadió la opción "wtimeout".
 | MongoCollection::ensureIndex | Se añadió la opción "wtimeout".
 | MongoCollection::insert | Se añadió la opción "wtimeout".
 | MongoCollection::remove | Se añadió la opción "wtimeout".
 | MongoCollection::update | Se añadió la opción "wtimeout".
1.3.3 | MongoClient::getReadPreference | El valor devuelto ha cambiado para ser consistente con MongoClient::setReadPreference. El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa etiquetas como pares clave/valor en lugar de string delimitados por dos puntos.
 | MongoCollection::getReadPreference | El valor devuelto ha cambiado para ser consistente con MongoCollection::setReadPreference. El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa las etiquetas como pares calve/valor en lugar de cadenas delimitadas por dos puntos.
 | MongoDB::getReadPreference | El valor devuelto ha cambiado para ser consistente con MongoDB::setReadPreference. El valor type cambia de ser un número a un string, type_string fue eliminado, y tagsets ahora expresa etiquetas como pares clave/valor en lugar de cadenas delimitadas por dos puntos.
1.3.0 | MongoClient::close | El parámetro connection de esta función fue añadido en la versión 1.3.0. Anteriormente, solamente se podía cerra la conexión de escritura mediante este método.
 | MongoClient::__construct | Se añadieron las opciones "readPreference", "readPreferenceTags", "w" y "wTimeout".
 | MongoCollection::batchInsert | Se añadió la opción "w".
 | MongoCollection::ensureIndex | Se añadió la opción "w". El parámetro options ya no acepta un booleano para identificar un índice único. En su lugar, ahora debe hacerse con array('unique' => true).
 | MongoCollection::insert | Se añadió la opción "w". El parámetro options ya no acepta un booleano para indicar una escritura aceptada. En su lugar, ahora esto tiene que realizarse con array('w' => 1) (El comportamiento predeterminado de MongoClient).
 | MongoCollection::remove | Se añadió la opción "w". El parámetro options ya no acepta un valor booleano que indique "justOne". En su lugar, ahora se debe hacer con array('justOne' => true).
 | MongoCollection::update | Se añadió la opción "w". El parámetro options ya no acepta un valor booleano para indicar un 'upsert'. En su lugar, esto ahora se tiene que hacer con array('upsert' => true).
 | MongoDB::listCollections | Se añadió el parámetro includeSystemCollections.
 | MongoGridFSCursor::key | El _id del documento es devuelto como un valor de tipo string, ya que la clave debería ser única. Antes de la versión 1.3.0, se devolvía filename.
1.2.11 | Mongo::getPoolSize | Emite un error de nivel E_DEPRECATED al usarla.
 | Mongo::getSlave | Emite un error de nivel E_DEPRECATED al utilizarlo.
 | Mongo::getSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | Mongo::poolDebug | Emite un error de nivel E_DEPRECATED al utilizarlo.
 | Mongo::setSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | Mongo::switchSlave | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoBinData::__construct | Emite un error de nivel E_DEPRECATED cuando no se utiliza el segundo argumento. El valor predeterminado de type podría cambiar en un futuro próximo.
 | MongoCollection::ensureIndex | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.
 | MongoCollection::getSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoCollection::group | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.
 | MongoCollection::remove | Emite un error de nivel E_DEPRECATED cuando options es de tipo scalar.
 | MongoCollection::setSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoCollection::update | Emite E_DEPRECATED cuando options es de tipo scalar.
 | MongoCursor::doQuery | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoDB::authenticate | Emite un error de nivel E_DEPRECATED cuando se usa. Por favor, pase los detalles de autenticación al constructor.
 | MongoDB::forceError | Emite E_DEPRECATED cuando es usada.
 | MongoDB::getSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoDB::prevError | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoDB::resetError | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoDB::setSlaveOkay | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoPool::getSize | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoPool::info | Emite un error de nivel E_DEPRECATED cuando se usa.
 | MongoPool::setSize | Emite un error de nivel E_DEPRECATED cuando se usa.
1.2.10 | MongoClient::getHosts | Se añadió el soporte para hosts que no pertenecen a un conjunto de réplica. Los elementos del array devuelto ahora también incluyen hostname y port.
1.2.7 | MongoCollection::batchInsert | Se añadió la opción "continueOnError".
1.2.5 | MongoGridFS::storeUpload | Se cambió el segundo parámetro a un array de metadatos. Antes de la versión 1.2.5, el segundo parámetro era un string opcional que reemplazaba el nombre de fichero.
1.2.0 | MongoClient::close | Antes de la versión 1.2.0, el controlador no utilizaba conexiones persistentes de forma predeterminada, por lo que todas las conexiones se cerraban tan pronto como una conexión de MongoDB estuviera fuera de ámbito. Desde la versión 1.2.0, este ya no es el caso, y es una mala idea invocar a close, ya que se podría terminar por sobrecargar el servidor con conexiones bajo una alta carga.
 | MongoClient::__construct | Se añadieron las opciones "username" y "password". Eliminada la opción "persist", ya que ahora todas las conexiones son persistentes. Aún se puede usar, pero no afecta a nada. "persist" Si la conexión debiera ser persistente. Si se establece, la conexión será persistente. La representación de tipo string del valor se usa como un ID para la conexión, por lo que dos instancias de MongoClient que hayan sido inicializadas con array("persist" => "foobar") compartirán la misma conexión a la base de datos, mientras que una instancia inicializada con array("persist" => "barbaz") usará una conexión diferente a la base de datos. La opción "replicaSet" ahora toma un string, no un booleano.
 | MongoCollection::ensureIndex | Se añadió la opción "timeout".
 | MongoCollection::insert | Se añadió el parámetro "timeout".
 | MongoCollection::remove | Se añadió la opción "timeout".
 | MongoCollection::save | Añadida la opción "timeout".
 | MongoCollection::update | Se añadió la opción "timeout".
 | MongoDB::command | Se añadió el parámetro options con una única opción: timeout.
1.1.0 | MongoCursor::info | Se añadieron varios campos, incluyendo id (el id del cursor), at (la cuenta del contador de cual es el documento actual), numReturned (el número devuelto por el servidor del lote actual), y server (el servidor al que se le envió la consulta; útil junto con .
1.0.11 | MongoCollection::ensureIndex | La opción "safe" desencadenará una tolerancia a fallos en el primario, si fuera necesario. Se lanzará una MongoException si el nombre del índice (generado o establecido) es mayor que 128 bytes.
 | MongoCollection::insert | Se desconecta en errores "not master" si "safe" está establecido.
 | MongoCollection::remove | Se desconcecta cuando ocurren errores "not master" si "safe" está establecido.
 | MongoCollection::save | Se desconecta en errores "not master" si "safe" está establecido.
 | MongoCollection::update | Se desconecta en errores "not master" si "safe" está establecido.
1.0.10 | MongoCursor::info | Se añadió el campo started_iterating, un booleano que indica si el cursor es preconsulta o postconsulta.
1.0.9 | MongoClient::__construct | Se añadió la opción "replicaSet".
 | MongoCollection::batchInsert | Se añadió la capacidad de pasar números enteros a la opción "safe", que anteriormente sólo aceptaba booleanos. Se añadió la opción "fsync".
 | MongoCollection::insert | Añadida la capacidad de pasar enteros a la opción "safe", la cual anteriormente únicamente aceptaba booleanos. Añadida la opción "fsync". Cambiado el tipo devuelto por un array que contiene información si se utiliza la opción "safe". De otro modo, se devuelve un booleano como antes.
 | MongoCollection::remove | Se añadió la capacidad de pasar números enteros a la opción "safe", la cual anteriomente sólo aceptaba valores booleanos. Se añadío la opción "fsync". Es tipo devuelto se cambio para que fuera un array que contuviera la información del error si se usaba la opción "safe". De otro modo, se devolvía un valor booleano como antes.
 | MongoCollection::save | Añadida la opción "fsync".
 | MongoCollection::update | Añadida la capacidad de pasar enteros a la opción "safe", la cual anteriormente únicamente aceptaba booleanos. Añadida la opción "fsync". Cambiado el tipo devuelto por un array que contiene información si se utiliza la opción "safe". De otro modo, se devuelve un booleano como antes.
1.0.7 | MongoCollection::count | Se añadieron los parámetros limit y skip como segundo y tercer parámetros, respectivamente.
1.0.5 | MongoCollection::batchInsert | Se añadió el parámetro options.
 | MongoCollection::ensureIndex | Se añadió la opción "name" para sobrescribir la creación del nombre del índice.
 | MongoCollection::remove | Cambiado el segundo parámetro a un array de opciones. Antes de 1.0.5, el segundo parámetro era un booleano indicando la opción "safe".
 | MongoCollection::save | Añadido el parámetro options.
 | MongoCollection::update | Se añadió la opción "safe".
1.0.2 | MongoClient::__construct | Se cambió el constructor para que tome un array de opciones. Antes de la versión 1.0.2, el constructor tomaba los siguientes parámetros: server El nombre del servidor. connect Parámetro booleano opcional que especifica si el constructor debe conectarse a la base de datos antes de devolver. El valor predeterminado es true. persistent Si la conexión debería se persistente. paired Si la conexión debería estar emparejada.
 | MongoCollection::ensureIndex | Se cambió el parámetro options de booleano a array. Antes de la versión 1.0.2, el segundo parámetro era un valor booleano opcional que especificaba si era o no un índice único.
 | MongoCollection::insert | Cambiado el segundo parámetro a un array de opciones. Antes de la versión 1.0.2, el segundo parámetro era un booleano indicando la opción "safe".
1.0.1 | MongoCollection::insert | Lanza una MongoCursorException si la opción "safe" está establecida y la inserción falla.
 | MongoCollection::update | Cambiado el parámetro "opciones" de un booleano a un array. Antes de la versión 1.0.1, el segundo parámetro era valor booleano opcional especificando un upsert.


Controlador de MongoDB

A diferencia de la extensión mongo, esta extensión da soporte a PHP y HHVM y está desarrollada sobre las bibliotecas » libmongoc y » libbson. Proporcina una API mínima para la funcionalidad principal del controlador: comandos, consultas, escrituras, gestión de conexiones y serialización BSON.

Las bibliotecas de usuario de PHP que dependan de esta extensión podrían proporcionar APIs de más alto nivel, como constructores de consultas, métodos ayudantes de comandos individuales, y GridFS. Los desrrolladores de aplicaciones deberían considerar usar esta extensión junto con la » biblioteca de PHP MongoDB, la cual implementa las mismas API de más alto nivel que se encuentra en los controladores de MongoDB para otros lenguajes. Esta separación de materias permite al controlador centrarse en características esenciales para las cuales una implementación de la extensión es primordial el rendimiento.

  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Constantes predefinidas
  • Tutoriales
    • Empleo de la biblioteca de PHP para MongoDB (PHPLIB)
    • Application Performance Monitoring (APM)
  • Arquitectura del controlador y sus entresijos — Explicación de la arquitectura del controlador y de características especiales
    • Arquitectura — Vista general de la arquitectura
    • Connections — Connection handling and persistence
    • Persistencia de datos — Serialización y deserialización de variables de PHP en MongoDB
  • Security
    • Request Injection Attacks
    • Script Injection Attacks
  • MongoDB\Controlador — Clases del controlador de MongoDB
    • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
  • MongoDB\BSON — Clases de tipo BSON y funciones de serialización
    • Funciones
    • MongoDB\BSON\Binary — La clase MongoDB\BSON\Binary
    • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Javascript — La clase MongoDB\BSON\Javascript
    • MongoDB\BSON\MaxKey — La clase MongoDB\BSON\MaxKey
    • MongoDB\BSON\MinKey — La clase MongoDB\BSON\MinKey
    • MongoDB\BSON\ObjectID — La clase MongoDB\BSON\ObjectID
    • MongoDB\BSON\Regex — La clase MongoDB\BSON\Regex
    • MongoDB\BSON\Timestamp — La clase MongoDB\BSON\Timestamp
    • MongoDB\BSON\UTCDateTime — La clase MongoDB\BSON\UTCDatetime
    • MongoDB\BSON\Type — La interfaz MongoDB\BSON\Type
    • MongoDB\BSON\Persistable — La interfaz MongoDB\BSON\Persistable
    • MongoDB\BSON\Serializable — La interfaz MongoDB\BSON\Serializable
    • MongoDB\BSON\Unserializable — La interfaz MongoDB\BSON\Unserializable
    • MongoDB\BSON\BinaryInterface — The MongoDB\BSON\BinaryInterface interface
    • MongoDB\BSON\Decimal128Interface — The MongoDB\BSON\Decimal128Interface interface
    • MongoDB\BSON\JavascriptInterface — The MongoDB\BSON\JavascriptInterface interface
    • MongoDB\BSON\MaxKeyInterface — The MongoDB\BSON\MaxKeyInterface interface
    • MongoDB\BSON\MinKeyInterface — The MongoDB\BSON\MinKeyInterface interface
    • MongoDB\BSON\ObjectIdInterface — The MongoDB\BSON\ObjectIdInterface interface
    • MongoDB\BSON\RegexInterface — The MongoDB\BSON\RegexInterface interface
    • MongoDB\BSON\TimestampInterface — The MongoDB\BSON\TimestampInterface interface
    • MongoDB\BSON\UTCDateTimeInterface — The MongoDB\BSON\UTCDateTimeInterface interface
  • MongoDB\Controlador\Excepciones — Clases de excepcines
    • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
    • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
    • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
    • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
    • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
    • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
    • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
    • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
    • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
    • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)
    • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
    • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class


Instalación/Configuración

  • Requerimientos
  • Instalación
    • Instalación del Controlador de MongoDB para PHP con PECL
    • Instalación del Controlador de MongoDB para PHP en OSX con Homebrew
    • Instalación del Controlador de MongoDB para PHP en Windows
    • Instalación manual del Controlador de MongoDB para PHP
    • Instalación manual de Controlador de MongoDB para HHVM
  • Configuración en tiempo de ejecución
  • Constantes predefinidas


Requerimientos

La variante de PHP del controlador requiere PHP 5.4 o superior.

La variante de HHVM del controlador requiere HHVM 3.9 o superior.


Instalación

Tabla de contenidos

  • Instalación del Controlador de MongoDB para PHP con PECL
  • Instalación del Controlador de MongoDB para PHP en OSX con Homebrew
  • Instalación del Controlador de MongoDB para PHP en Windows
  • Instalación manual del Controlador de MongoDB para PHP
  • Instalación manual de Controlador de MongoDB para HHVM


Instalación del Controlador de MongoDB para PHP con PECL

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mongodb

Los usuarios de Linux, Unix, y OS X pueden ejecutar el siguiente comando para instalar el controlador:

$ sudo pecl install mongodb

Añada la siguiente línea al fichero php.ini:

extension=mongodb.so


Instalación del Controlador de MongoDB para PHP en OSX con Homebrew

Si se utiliza » Homebrew, el tap de PHP incluye fórmulas para instalar el controlador en varias versiones de PHP.

  • php54-mongodb
  • php55-mongodb
  • php56-mongodb
  • php70-mongodb

Por ejemplo, se podría instalar el controlador para PHP 7.0 con el siguiente comando:

$ brew install php70-mongodb


Instalación del Controlador de MongoDB para PHP en Windows

Hay disponibles binarios precompilados para cada versión en » PECL para una variedad de combinaciones de versiones, seguridad con hilos, y bibliotecas VC. Extraiga el archivo y coloque php_mongo.dll en el directorio de extensiones de PHP ("ext" predeterminadamente).

Añada la siguiente línea al fichero php.ini:

extension=php_mongo.dll


Instalación manual del Controlador de MongoDB para PHP

Para los desarrolladores de controladores y gente interesada en las últimas correcciones de errores, se puede compilar el controlador desde el último código fuente en » Github. Ejecute los siguientes comandos para clonar y construir el proyecto:

$ git clone https://github.com/mongodb/mongo-php-driver.git
$ cd mongo-php-driver
$ git submodule sync && git submodule update --init
$ phpize
$ ./configure
$ make all -j 5
$ sudo make install

El último paso informará sobre dónde ha sido instalado mongodb.so, similar a:

Installing shared extensions:     /usr/lib/php/extensions/debug-non-zts-20151012/

Asegúreser de que la opción extension_dir de php.ini apunta al directorio donde se instaló mongodb.so. Se puede verificar la opción ejecutando:

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/debug-non-zts-20151012 =>
                   /usr/lib/php/extensions/debug-non-zts-20151012

Si los directorios difieren, cambie extension_dir de php.ini o mueva manualmente mongodb.so al directorio correcto.

Añada la siguiente línea al fichero php.ini:

extension=mongodb.so


Instalación manual de Controlador de MongoDB para HHVM

En el momento de escribir esto, HHVM no posee un gestor de paquetes para extensiones. Descargue el último controlador desde » GitHub. De forma alternativa, se puede clonar el repositorio para construir el último código fuente:

$ git clone https://github.com/mongodb/mongo-hhvm-driver.git
$ cd mongo-hhvm-driver
$ git submodule sync && git submodule update --init --recursive

Configurar los ficheros make ejecutando:

$ hphpize
$ cmake .

Genere los ficheros configure para las bibliotecas incluidas. Para que esto funcione, es necesario tener instalados los paquetes automake, autoconf, y libtool (p.ej. mediante apt-get).

$ make configlib

Construya e instale el controlador ejecutando:

$ make -j 5
$ sudo make install

Nota:

Si el comando hphpize no está disponible, será necesario compilar HHVM desde el código fuente o instalar el paquete hhvm-dev (p.ej. mediante apt-get).

El último paso informará sobre dónde ha sido instalado mongodb.so, similar a:

Installing:     /usr/local/hhvm/3.9.1/lib/hhvm/extensions/20150212/mongodb.so

Añada la siguiente línea al fichero php.ini (normalmente se encuentra en "/etc/hhvm"):

hhvm.dynamic_extension_path=/usr/local/hhvm/3.9.1/lib/hhvm/extensions/20150212
hhvm.dynamic_extensions[mongodb]=mongodb.so


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de mongodb
Nombre | Por defecto | Cambiable | Historial de cambios | Comentarios
mongodb.debug | "" | PHP_INI_ALL |  | Solo disponible para el controlador de PHP, no para el de HHVM

He aquí una breve explicación de las directivas de configuración.

mongodb.debug string

Almacenar el registro de depuración de actividad completo en este directorio o flujo. Se puede proporcionar el valor especial "stderr" para escribir en STDERR.

Nota:

No disponible para HHVM


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

MONGODB_VERSION (string)
Número de versión estilo x.y.z de la extensión
MONGODB_STABILITY (string)
Estabilidad actual (alpha/beta/stable)


Tutoriales

En esta sección se encuentran varios tutoriales sobre cómo utilizar el controlador de MongoDB para PHP.

  • Empleo de la biblioteca de PHP para MongoDB (PHPLIB)
  • Application Performance Monitoring (APM)


Empleo de la biblioteca de PHP para MongoDB (PHPLIB)

Después de la configuración inicial del controlador, continuaremos explicando cómo empezar con el controlador de MongoDB y la correspondiente biblioteca de usuario para escribir nuestro primer proyecto.

Instalación de la Biblioteca de PHP con Composer

Lo último que necesitamos instalar para empezar con la apliación en sí, es la biblioteca de PHP.

La bibilioteca necesita ser instalada con » Composer, un gestor de paquetes para PHP. Las instrucciones para instalar Composer en varias plataformas se pueden encontrar en su sitio web.

Instale la biblioteca ejecutando:

$ composer require "mongodb/mongodb=^1.0.0"

Muestra algo parecido a esto:

./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Installing mongodb/mongodb (1.0.0)
    Downloading: 100%

Writing lock file
Generating autoload files

Composer creará varios ficheros: composer.json, composer.lock, y un directorio vendor que contendrá la biblioteca y cualquier otra dependencia que requiera el proyecto.

Utilizar la Biblioteca de PHP

Además de gestionar las dependencias, Composer también proporciona un autocargador (para las clases de las dependencias). Asegúrese que se incluye al inicio del script o en el código de arranque de la aplicación:

<?php
// Esta ruta debe apuntar al autocargador de Composer
require 'vendor/autoload.php';

Con esto hecho, ahora se puede emplear cualquier funcionalidad de la descrita en la » documentación de la biblioteca y en su » API.

Si ha empleado anteriormente el controlador antiguo (esto es, la extensión mongo), la API de la biblioteca debería serle familiar. Contiene una clase » Client para conectar a MongoDB, una clase » Database para operaciones a nivel de la base de datos (p.ej. comandos , gestión de colecciones) y una clase » Collection para operaciones a nivel de colección (p.ej. métodos » CRUD, gestión de índices). Se han renombrado varios métodos de Collection para mayor claridad y para estar en concordancia con una nueva » specification independiente del lenguaje.

Como ejemplo, así es como se inserta un documento en la colección beers de la base de datos demo:

<?php
require 'vendor/autoload.php'; // incluir lo bueno de Composer

$cliente = new MongoDB\Client("mongodb://localhost:27017");
$colección = $cliente->demo->beers;

$resultado = $colección->insertOne( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

echo "Inserted with Object ID '{$resultado->getInsertedId()}'";
?>

En lugar de inyectar el campo _id generado en el documento de entrada (tal como se hacía en el antiguo controlador), ahora se pone a disposición mediante el objeto de resultados devuelto por el método insertOne.

Por supuesto, después de la inserción también se pueden consultar los datos que se acaban de insertar. Para ello se utiliza el método find, el cual devuelve un cursor iterable:

<?php
require 'vendor/autoload.php'; // include Composer goodies

$cliente = new MongoDB\DriverMongoDB\Client("mongodb://localhost:27017");\Client("mongodb://localhost:27017");
$colección = $cliente->demo->beers;

$resultado = $colección->find( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

foreach ($resultado as $entry) {
    echo $entry['_id'], ': ', $entry['name'], "\n";
}
?>

Anuque pueda no ser evidente en los ejemplos, los documentos BSON y los arrays son deserializados como clases de tipo en la biblioteca de forma predeterminada. Estas clases aseguran que los valores preservan sus tipos cuando son serializados de nuevo a BSON, lo cual evita una advertencia del antiguo controlador cuando un array podía convertise a un documento, y viceversa. Además, las clases extienden ArrayObject para mejorar la usabilidad. Se puede encontrar más información sobre cómo el controlador y la biblioteca manejan la serialización y deserialización entre variablies de PHP y BSON leyendo la especificicación de Persistencia de datos.


Application Performance Monitoring (APM)

Since version 1.3, the MongoDB driver contains an API for performance monitoring. This API allows you to find out how long specific operations take by setting up subscribers. Each subscriber is required to implement one or more interfaces under the MongoDB\Driver\Monitoring namespace. Currently, only the MongoDB\Driver\Monitoring\CommandSubscriber interface is available.

The MongoDB\Driver\Monitoring\CommandSubscriber interface defines three methods: commandStarted, commandSucceeded, and commandFailed. Each of these three methods accept a single event argument of a specific class for the respective event. For example, the commandSucceeded's $event argument is a MongoDB\Driver\Monitoring\CommandSucceededEvent object.

In this tutorial we will implement a subscriber that creates a list of all the query profiles and the average time they took.

Subscriber Class Scaffolding

We start with the framework for our subscriber:

<?php

class QueryTimeCollector implements \MongoDB\Driver\Monitoring\CommandSubscriber
{
    public function commandStarted( \MongoDB\Driver\Monitoring\CommandStartedEvent $event )
    {
    }

    public function commandSucceeded( \MongoDB\Driver\Monitoring\CommandSucceededEvent $event )
    {
    }

    public function commandFailed( \MongoDB\Driver\Monitoring\CommandFailedEvent $event )
    {
    }
}

?>

Registering the Subscriber

Once a subscriber object is instantiated, it needs to be registered with the driver's monitoring system. This is done by calling MongoDB\Driver\Monitoring\addSubscriber().

<?php

\MongoDB\Driver\Monitoring\addSubscriber( new QueryTimeCollector() );

?>

Implementing the Logic

With the object registered, the only thing left is to implement the logic in the subscriber class. To correlate the two events that make up a successfully executed command (commandStarted and commandSucceeded), each event object exposes a requestId field.

To record the average time per query shape, we will start by checking for a find command in the commandStarted event. We will then add an item to the pendingCommands property indexed by its requestId and with its value representing the query shape.

If we receive a corresponding commandSucceeded event with the same requestId, we add the duration of the event (from durationMicros) to the total time and increment the operation count.

If a corresponding commandFailed event is encountered, we just remove the entry from the pendingCommands property.

<?php

class QueryTimeCollector implements \MongoDB\Driver\Monitoring\CommandSubscriber
{
    private $pendingCommands = [];
    private $queryShapeStats = [];

    /* Creates a query shape out of the filter argument. Right now it only
     * takes the top level fields into account */
    private function createQueryShape( array $filter )
    {
        return json_encode( array_keys( $filter ) );
    }

    public function commandStarted( \MongoDB\Driver\Monitoring\CommandStartedEvent $event )
    {
        if ( array_key_exists( 'find', (array) $event->getCommand() ) )
        {
            $queryShape = $this->createQueryShape( (array) $event->getCommand()->filter );
            $this->pendingCommands[$event->getRequestId()] = $queryShape;
        }
    }

    public function commandSucceeded( \MongoDB\Driver\Monitoring\CommandSucceededEvent $event )
    {
        $requestId = $event->getRequestId();
        if ( array_key_exists( $requestId, $this->pendingCommands ) )
        {
            $this->queryShapeStats[$this->pendingCommands[$requestId]]['count']++;
            $this->queryShapeStats[$this->pendingCommands[$requestId]]['duration'] += $event->getDurationMicros();
            unset( $this->pendingCommands[$requestId] );
        }
    }

    public function commandFailed( \MongoDB\Driver\Monitoring\CommandFailedEvent $event )
    {
        if ( array_key_exists( $event->getRequestId(), $this->pendingCommands ) )
        {
            unset( $this->pendingCommands[$event->getRequestId()] );
        }
    }

    public function __destruct()
    {
        foreach( $this->queryShapeStats as $shape => $stats )
        {
            echo "Shape: ", $shape, " (", $stats['count'], ")\n  ",
                $stats['duration'] / $stats['count'], "µs\n\n";
        }
    }
}

$m = new \MongoDB\Driver\Manager( 'mongodb://localhost:27016' );

/* Add the subscriber */
\MongoDB\Driver\Monitoring\addSubscriber( new QueryTimeCollector() );

/* Do a bunch of queries */
$query = new \MongoDB\Driver\Query( [
    'region_slug' => 'scotland-highlands', 'age' => [ '$gte' => 20 ]
] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

$query = new \MongoDB\Driver\Query( [
    'region_slug' => 'scotland-lowlands', 'age' => [ '$gte' => 15 ]
] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

$query = new \MongoDB\Driver\Query( [ 'region_slug' => 'scotland-lowlands' ] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

?>


Explicación de la arquitectura del controlador y de características especiales

  • Arquitectura — Vista general de la arquitectura
  • Connections — Connection handling and persistence
  • Persistencia de datos — Serialización y deserialización de variables de PHP en MongoDB
    • Serialización a BSON
    • Deserialización desde BSON


Vista general de la arquitectura

Esta sección explica cómo todas las diferentes partes del controlador encajan entre sí, desde tiempos de ejecución de lenguaje diferentes, a través de extensiones y hacia las bibliotecas de PHP por último. Esta nueva arquitectura ha reemplazado a la antigua extensión mongo. Nos referiremos a la nueva como la extensión mongodb.

Diagrama de la arquitectura

En lo más alto de esta pila se sitúa una » biblioteca de PHP pura, la cual distribuimos como um paquete de Composer. Esta biblioteca proporcionará una API similar a la que los usuarios llevan esperando desde el controlador de mongo antiguo (p.ej. métodos CRUD, objetos de bases de datos y colecciones, ayudantes de comandos), por lo que esperamos que sea una dependencia común para la mayoría de las aplicaciones construidas con MongoDB. Esta biblioteca también implementa » especificaciones comunes, por el interés de mejorar la consistencia de la API a través de todos los » controladores mantenidos por MongoDB (y con suerte, también algunos controladores de la comunidad).

Justo debajo de la biblioteca tenemos los controladores de nivel más bajo: uno por plataforma. Estas extensiones formarán de forma efectiva el «pegamento» entre PHP y HHVM y nuestras bibliotecas del sistema (» libmongoc y » libbson). Estas extensiones expondrán una API pública idéntica para la funcionalidad más esencial y sensible al rendimiento:

  • Administración de conexiones
  • Codificación y decodificación de BSON
  • Serializacón documentos de objetos (para dar soporte a bibliotecas ODM)
  • Ejecución de comandos y escritura de operaciones
  • Manejo de consultas y cursores

Al separar los entresijos del contrlador y la API de alto nivel en extensiones y bibliotecas de PHP, respectivamente, esperamos reducir nuestra carga de manteminiento y permitir una iteración más rápida en nuevas características. Como efecto secundario de agradecer, esto también hace más sencillo que cualquiera pueda contribuir al controlador. Además, una API pública idéntica para estas extensiones hará mucho más fácil portar una aplicación durante tiempos de ejecución de PHP, si la aplicación usa directamente el controlador de bajo nivel o una biblioteca de alto nivel.

» GridFS es un buen ejemplo de por qué elegimos esta dirección. Aunque implementamos GridFS en C para nuestro controlador antiguo de mongo, realmente es una especificación de alto nivel. Su API es una abstracción para acceder a dos colecciones: ficheros (esto es, metadatos) y trozos (esto es, bloques de datos). Asimismo, todo el añadido sintáctico encontrado en el controlador antiguo de mongo, como el procesamiento de ficheros subidos o la exposición de ficheros de GridFS como flujos de PHP, se puede implementar en PHP puro. Siempre que poseamos métodos rendidores para leer desde y escribir en colecciones de GridFS (y gracias a nuestras extensiones de bajo nivel), lo haremos: al mover esta API a PHP todos ganamos.

Antes mencionamos que esperamos que la biblioteca de PHP sea una dependencia común para la mayoría de las aplicaciones, pero no para todas. Algunos usuarios podrían prefereir adherirse a la API sin florituras ofrecida por las extensiones, o crear su propia abstracción de alto nivel (parecida a » Doctrine MongoDB para el controlador antiguo de mongo). Las futuras bibliotecas podrían incluir una biblioteca de PHP dirigida a la administración de MongoDB con una API para la gestión de varios usuarios y comandos de operaciones. La siguiente versión mayor de » Doctrine MongoDB ODM probablemente también se sitúe directamente el lo alto de esta extensiones.

Aunque continuaremos manteniendo y dando soporte al controlador antiguo de mongo y a sus usuarios para el futuro próximo, invitamos a todo el mundo a utilizar el controlador de nueva generación y considerarlo para cualquier proyecto nuevo por venir. Los componentes esenciales se pueden encontrar a través de GitHub y JIRA:

Ubicaciones del código fuente del controlador y JIRA
Proyecto | GitHub | JIRA
Biblioteca de PHP | » mongodb/mongo-php-library | » PHPLIB
Controlador de PHP 5 y PHP 7 (phongo) | » mongodb/mongo-php-driver | » PHPC
Controlador de HHVM (hippo) | » mongodb/mongo-hhvm-driver | » HHVM

El proyecto » PHP existente en JIRA permanecerá abierto para la notificación de errores del controlador antiguo de mongo, aunque solicitaremos que utilice los nuevos proyectos de antes para cualquier cosa concerniente a nuestros controladores de la siguiente generación.


Connection handling and persistence

Nota: En plataformas Unix, el controlador de MongoDB es susceptible a scripts que utilizan la llamada al sistema fork() sin llamar también a exec(). Los usuarios están advertidos de no reusar instancias de MongoDB\Driver\Manager en un proceso hijo bifurcado («forked»).

Persistencia de conexión y topología (PHP y HHVM desde versión 1.2.0)

Todas las versiones del controlador desde la 1.2.0 hacen persistente el objeto cliente » libmongoc del proceso trabajador de PHP, lo que le permite reutilizar conexiones a bases de datos, estadod de autenticación, e información de topología entre varias peticiiones.

Cuando MongoDB\Driver\Manager::__construct() se invoca, se crea un hash con sus argumentos (esto es, cadena de URI y opciones de array). El controlador intentará encontrar un objeto cliente » libmongoc persistente anterior par tal hash. Si no se puede encontrar un cliente existente para el hash, se creará un nuevo cliente (y se hará persistente para un uso futuro).

Cada cliente contiene su propia conexión a una base de datos y una vista de la topología del servidor (p.ej., independiente, conjunto réplica, 'clúster' fragmentado). Haciendo persistente el cliente entre peticiones de PHP, el controlador es capaz de reutilizar conexiones de bases de datos establecidas y eliminar la necesidad de » descubrir la topología del servidor en cada petición.

Considere el siguiente ejemplo:

<?php

$managers = [
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1:27017'),
    new MongoDB\Driver\Manager('mongodb://rs1.example.com,rs2.example.com/', ['replicaSet' => 'myReplicaSet']),
];

foreach ($managers as $manager) {
    $manager->executeCommand('test', new MongoDB\Driver\Command(['ping' => 1]));
}

?>

Los primeros dos objetos Manager compartirán el mismo cliente » libmongoc ya que los argumentos de sus constructores son idénticos. El tercer y cuarto objetos utilizarán cada un su propio cliente. En total, se crearán tres clientes y el trabajador de PHP que ejecute este script abrirá dos conexiones a 127.0.0.1 y una conexión a rs1.example.com y otra a rs2.example.com. Si el controlador descubre miembros adicionales de un conjunto réplica después de emitir comandos isMaster, abrirá conexiones adicionales también para esos servidores.

Si el mismo trabajador ejecuta el script de nuevo en una segunda petición, los tres clientes serán reutilizados y no deberían hacerse nuevas conexiones. Dependiendo del hace cuánto tiempo se sirvió la petición anteriior, el controlador podría necesitar emitir comandos isMaster adicionales para actualizar su vista de las topologías.

Persistencia de socket (PHP versiones anteriores a la 1.2.0)

Las versiones del controlador de PHP anteriores a la 1.2.0 utilizan la API de Flujos de PHP para conexiones a bases de datos, empleando una API dentro de » libmongoc para designar manejadores propios para la comunicación de sockets. Sin embargo, se crea un nuevo cliente libmongoc para cada MongoDB\Driver\Manager. Como resultado, el controlador hace persistir conexiones a bases de datos individuales, aunque no el estado de autenticación o la información de la topología. Esto sifgnifica que el controlador necesita emitir comandos al inicio de cada petición para autenticar y » descubrir la topología del servidor.

Las conexiones a bases de datos son persistentes mediante un hash derivador del puerto, host y cadena URI del servidor empleados para construit el MongoDB\Driver\Manager. Las opciones de array del constructor no estan incluidas en este hash.

Nota: Las versiones del controlador >= 1.1.8 y < 1.2.0 no hacen persistentes sockets para conexinoes SSL. Véase » PHPC-720 para más información.

A pesar de sus deficiencias con conexiones SSL persistentes e información de topología, esta versioón del controlador admite todas las opciones de contexto SSL debido a que utiliza la API de Flujos de PHP.

Sin persistencia (versiones de HHVM anteriores a la 1.2.0)

Las versiones del controlador HHVM anteriores a la 1.2.0 no hacen persistentes sockets, estados de autenticación o información de topología, La comunicación de socket emplea » libmongoc completamente.


Serialización y deserialización de variables de PHP en MongoDB

Tabla de contenidos

  • Serialización a BSON
  • Deserialización desde BSON

Este documento trata sobre los métodos de cómo las estructuras compuestas (documentos, arrays, objetos) se hacen persistentes a través de los controladores y de cómo son llevadas de vuelta a PHP.


Serialización a BSON

Arrays

Si un array es un array compacto, esto es, las claves empiezan en 0 y están en secuencia sin huecos: array BSON.

Si el array no es compacto, esto es, tiene claves asociativas (string), las claves no comienzan en 0, o cuando hay huecos: objeto BSON

Un documento del más alto nivel (raíz), siempre se serializa como un documento BSON.

Ejemplos

Los siguientes arrays se serializan como arrays BSON:

[ 8, 5, 2, 3 ] => [ 8, 5, 2, 3 ]
[ 0 => 4, 1 => 9 ] => [ 4, 9 ]

Estos se serializan como documentos BSON:

[ 0 => 1, 2 => 8, 3 => 12 ] => { "0" : 1, "2" : 8, "3" : 12 }
[ "foo" => 42 ] => { "foo" : 42 }
[ 1 => 9, 0 => 10 ] => { "1" : 9, "0" : 10 }

Observe que los cinco ejemplos son fragmentos de un documento completo que representan solamente un valor dentro de un documento.

Objetos

Si un objeto es de la clase stdClass se serializa como un documento BSON.

Si un objeto es de una clase admitida que implementa MongoDB\BSON\Tipo, se utiliza la lógica de serialización BSON para un tipo específico. Las instancias de MongoDB\BSON\Tipo (excluyendo MongoDB\BSON\Serializable solo podrían ser serializadas como un valor de campo de documento. Intentar serializar tales objetos como un documento raíz lanzará una MongoDB\Driver\Exception\UnexpectedValueException

Si un objeto se de una clase desconocida que implementa la interfaz MongoDB\BSON\Tipo, lanza una MongoDB\Driver\Exception\UnexpectedValueException

Si un objeto es de cualquier otra clase que no implemente ninguna interfaz especial, se serializa como un documento BSON. Se mantienen solo las propiedades public y se ignoran las propiedades protected y private.

Si un objeto es de una clase que implementa la interfaz MongoDB\BSON\Serializable, se llama a MongoDB\BSON\Serializable::bsonSerialize() y se utiliza el array u objeto stdClass devuelto para serilizarlo como un documento BSON o array. El tipo BSON será determinado como sigue:

  1. Los documentos raíz deben ser serializados como un documento BSON.

  2. Los objetos MongoDB\BSON\Persistable deben ser serializados como un documento BSON.

  3. Si MongoDB\BSON\Serializable::bsonSerialize() devuelve un array compacto, se serializa como un array BSON.

  4. Si MongoDB\BSON\Serializable::bsonSerialize() devuelve un array no compacto o un objeto stdClass, se serializa como un documento BSON.

  5. Si MongoDB\BSON\Serializable::bsonSerialize() no devuelve un array u objeto stdClass, se lanza una excepción de tipo MongoDB\Driver\Exception\UnexpectedValueException.

Si un objeto es de una clase que implementa la interfaz MongoDB\BSON\Persistable (lo que implica que MongoDB\BSON\Serializable obtiene las propiedades de una forma similar a los párrafos anteriores, aunque también añade una propiedad adicional __pclass como un valor Binary, con subtipo 0x80 y datos soportando el nombre de la clase completamente cualificado del objeto que se está serializando.

La propiedad __pclass se añade al array u objeto devuelto por MongoDB\BSON\Serializable::bsonSerialize(), lo que significa que se sobrescribirá cualquier clave/propiedad __pclass en el valor devuelto de MongoDB\BSON\Serializable::bsonSerialize(). Para evitar este funcionamiento y establecer un valor de __pclass propio, no se debe implementar MongoDB\BSON\Persistable y, en su lugar, se deería implementar MongoDB\BSON\Serializable directamente.

Ejemplos

<?php

stdClass {
  public $foo = 42;
} => { "foo" : 42 }

MyClass {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
} => { "foo" : 42 }

AnotherClass1 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} => { "foo" : 42, "prot" : "wine" }

AnotherClass2 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  function bsonSerialize() {
      return $this;
  }
} => MongoDB\Driver\Exception\UnexpectedValueException("bsonSerialize() did not return an array or stdClass")

AnotherClass3 implements MongoDB\BSON\Serializable {
  private $elements = [ 'foo', 'bar' ];
  function bsonSerialize() {
      return $this->elements;
  }
} => { "0" : "foo", "1" : "bar" }

ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass4 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} => { "things" : { "0" : "foo", "2" : "bar" } }

ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass5 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return array_values($this->elements);
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} => { "things" : [ "foo", "bar" ] }

ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass6 implements MongoDB\BSON\Serializable {
    private $elements = [ 'foo', 'bar' ];
    function bsonSerialize() {
      return (object) $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} => { "things" : { "0" : "foo", "1" : "bar" } }

UpperClass implements MongoDB\BSON\Persistable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} // => { "foo" : 42, "prot" : "wine", "__pclass" : { "$type" : "80", "$binary" : "VXBwZXJDbGFzcw==" } }


Deserialización desde BSON

Para tipos compuestos, existen tres tipos de datos:

root

se refiere al documento BSON de más alto nivel solamente

document

se refiere a docuemtnos BSON embebidos solamente

array

se refiere a un array BSON

Cada uno de estos tres tipos de datos se pueden hacer corresponder con diferentes tipos de PHP. Los posibles valores de correspondencia son:

no establecido o NULL (es el predeterminado)

  • Un array BSON será deserializado como un array de PHP.

  • Un documento BSON (raíz o embebido) sin una propiedad __pclass [1] se convierte en un objeto stdClass de PHP, con cada clave de documento BSON establecida a propiedad stdClass pública.

  • Un documento BSON (raíz o embebido) con una propiedad __pclass [1] se convierte en un objeto de PHP del nombre de la clase definida por la propiedad __pclass.

    Si la clase con nombre implementa la intefaz MongoDB\BSON\Persistable, las propiedades del documento BSON, incluyendo la propiedad __pclass, son enviadas como un array asociativo a la función bsonUnserialize() para inicializar la propiedades del objeto.

    Si la clase con nombre no existe o no implementa la interfaz MongoDB\BSON\Persistable, se empleará stdClass y cada clave del documento BSON (incluyendo __pclass) será establecida a una propiedad stdClass pública.

"array"

Convierte un array BSON o documento BSON en un array de PHP. No habrá ningún tratamiento especial de una propiedad __pclass [1], aunque se podría establecer como un elemento del array devuelto si estaba presente el el documento BSON.

"object" o "stdClass"

Convierte un array BSON o documento BSON a un objeto stdClass. No habrá ningún tratamiento especial de una propiedad __pclass [1], aunque se podría establecer como propiedad pública del objeto devuelto si estaba presente en el documento BSON.

cualquier otro string

Define el nombre de la clase a la que debe ser deserializado el array BSON u objeto BSON. Para objetos BSON que incluyan propiedades __pclass, esta clase tomará prioridad.

Si la clase citada no existe, no es concreta (esto es, es abstracta o es una interfaz), o no implementa MongoDB\BSON\Unserializable, se lanzará una excepción MongoDB\Driver\Exception\InvalidArgumentException.

Si el objeto BSON posee una propiedad __pclass y esa clase existe e implementa MongoDB\BSON\Persistable, sustituirá a la clase proporcionada en el mapa de tipo.

Las propiedades del documento BSON, incluyendo la propiedad __pclass si existiera, será enviada como un array asociativo a la función bsonUnserialize() para inicializar las propiedades del objeto.

TypeMaps

TypeMaps se puede establecer a través del método MongoDB\Driver\Cursor::setTypeMap() en un objeto MongoDB\Driver\Cursor o del argumento $typeMap de MongoDB\BSON\toPHP(). Cada una de las tres clases (root, document and array) se pueden establecer individualmente.

Si el valor del mapa es NULL, significa lo mismo que el valor predeterminado para ese elemento.

Ejemplo

Estos ejemplos utilizan las siguientes clases:

MiClase

la cual no implementa ninguna interfaz

TuClase

que implementa MongoDB\BSON\Unserializable

NuestraClase

que implementa MongoDB\BSON\Persistable

SuClase

que extiende NuestraClase

El método bsonUnserialize() de TuClase, NuestraClase, SuClase recorre el array y establece las propiedades sin modificaciones. También establece la propiedad $no_serializada a true:

<?php

function bsonUnserialize( array $map )
{
    foreach ( $map as $k => $value )
    {
        $this->$k = $value;
    }
    $this->unserialized = true;
}

/* typemap: [] (all defaults) */
{ "foo": "yes", "bar" : false }
  -> stdClass { $foo => 'yes', $bar => false }

{ "foo": "no", "array" : [ 5, 6 ] }
  -> stdClass { $foo => 'no', $array => [ 5, 6 ] }

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> stdClass { $foo => 'no', $obj => stdClass { $embedded => 3.14 } }

{ "foo": "yes", "__pclass": "MyClass" }
  -> stdClass { $foo => 'yes', $__pclass => 'MyClass' }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "MyClass" } }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'MyClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "YourClass") }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "OurClass") }
  -> OurClass { $foo => 'yes', $__pclass => Binary(0x80, 'OurClass'), $unserialized => true }

{ "foo": "yes", "__pclass": { "$type" : "44", "$binary" : "YourClass") }
 -> stdClass { $foo => 'yes', $__pclass => Binary(0x44, 'YourClass') }

/* typemap: [ "root" => "MissingClass" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MissingClass does not exist")

/* typemap: [ "root" => "MyClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MyClass does not implement Unserializable interface")

/* typemap: [ "root" => "MongoDB\BSON\Unserializable" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("Unserializable is not a concrete class")

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MongoDB\BSON\Unserializable" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MongoDB\BSON\Unserializable"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MyClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> OurClass { $foo => "yes", $__pclass => Binary(0x80, "OurClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ "root" => "OurClass" ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ 'root' => 'YourClass' ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "YourClass" } }
  -> YourClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass'), $unserialized => true }

/* typemap: [ 'root' => 'array', 'document' => 'array' ] */
{ "foo": "yes", "bar" : false }
  -> [ "foo" => "yes", "bar" => false ]

{ "foo": "no", "array" : [ 5, 6 ] }
  -> [ "foo" => "no", "array" => [ 5, 6 ] ]

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> [ "foo" => "no", "obj" => [ "embedded => 3.14 ] ]

{ "foo": "yes", "__pclass": "MyClass" }
  -> [ "foo" => "yes", "__pclass" => "MyClass" ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "MyClass") ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "OurClass") ]

/* typemap: [ 'root' => 'object', 'document' => 'object' ] */
{ "foo": "yes", "__pclass": { "$type": "80", "$binary": "MyClass" } }
  -> stdClass { $foo => "yes", "__pclass" => Binary(0x80, "MyClass") }


  • « Deserialización desde BSON
  • Request Injection Attacks »
  • PHP Manual
  • MongoDB
  • Security

Security

  • Request Injection Attacks
  • Script Injection Attacks


Request Injection Attacks

If you are passing $_GET (or $_POST) parameters to your queries, make sure that they are cast to strings first. Users can insert associative arrays in GET and POST requests, which could then become unwanted $-queries.

A fairly innocuous example: suppose you are looking up a user's information with the request http://www.example.com?username=bob. Your application creates the query $q = new \MongoDB\Driver\Query( [ 'username' => $_GET['username'] ]).

Someone could subvert this by getting http://www.example.com?username[$ne]=foo, which PHP will magically turn into an associative array, turning your query into $q = new \MongoDB\Driver\Query( [ 'username' => [ '$ne' => 'foo' ] ] ), which will return all users not named "foo" (all of your users, probably).

This is a fairly easy attack to defend against: make sure $_GET and $_POST parameters are the type you expect before you send them to the database. PHP has the filter_var() function to assist with this.

Note that this type of attack can be used with any database interaction that locates a document, including updates, upserts, deletes, and findAndModify commands.

See » the main documentation for more information about SQL-injection-like issues with MongoDB.


Script Injection Attacks

If you are using JavaScript, make sure that any variables that cross the PHP- to-JavaScript boundry are passed in the scope field of MongoDB\BSON\Javascript, not interpolated into the JavaScript string. This can come up when using $where clauses in queries, mapReduce and group commands, and any other time you may pass JavaScript into the database.

For example, suppose we have some JavaScript to greet a user in the database logs. We could do:

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

However, what if a malicious user passes in some JavaScript?

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];
// $username is set to "'); db.users.drop(); print('"

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

Now MongoDB executes the JavaScript string "print('Hello, '); db.users.drop(); print('!');". This attack is easy to avoid: use args to pass variables from PHP to JavaScript:

<?php
$m = new MongoDB\Driver\Manager;

$_GET['field'] = 'derick';
$args = [ $_GET['field'] ];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "function greet(username) { print('Hello, ' + username + '!'); }",
    'args' => $args,
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

This adds an argument to the JavaScript scope, which gets used as argument for the greet function. Now if someone tries to send malicious code, MongoDB will harmlessly print Hello, '); db.dropDatabase(); print('!.

Using arguments helps to prevent malicious input from being executed by the database. However, you must make sure that your code does not turn around and execute the input anyway! It is best to avoid executing any JavaScript on the server in the first place.

You are strongly recommended to stay clear of the » $where clause with queries, as it impacts performance significantly. Where possible, use either normal query operators, or the » Aggregation Framework.

As alternative to » MapReduce, which uses JavaScript, consider using the » Aggregation Framework. Unlike Map/Reduce, it uses an idiomatic language to construct queries, without having to write, and use, the slower JavaScript approach that Map/Reduce requires.

The » eval command has been deprecated since MongoDB 3.0, and should also be avoided.


Clases del controlador de MongoDB

  • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
    • MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object
    • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand — Execute a database command
    • MongoDB\Driver\Manager::executeQuery — Execute a database query
    • MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads
    • MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes
    • MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes
    • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
    • MongoDB\Driver\Manager::startSession — Start a new client session for use with this client
  • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Command::__construct — Create a new Command
  • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\Query::__construct — Create a new Query
  • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
    • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk
  • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern
    • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
    • MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern
    • MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern
    • MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern
  • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference
    • MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string
    • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
    • MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference
    • MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference
  • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern
    • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
    • MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern
    • MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern
    • MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern
  • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
    • MongoDB\Driver\Cursor::current — Returns the current element
    • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results
    • MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor
    • MongoDB\Driver\Cursor::next — Advances the cursor to the next result
    • MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result
    • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
    • MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid
  • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::serialize — Serialize a CursorId
    • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
    • MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId
  • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\Server::__construct — Create a new Server (not used)
    • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
    • MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server
    • MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server
    • MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server
    • MongoDB\Driver\Server::getHost — Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency — Returns the latency of this server
    • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set
  • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message
  • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError
    • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message
  • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
    • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged


The MongoDB\Driver\Manager class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\Manager is the main entry point to the extension. It is responsible for maintaining connections to MongoDB (be it standalone server, replica set, or sharded cluster).

No connection to MongoDB is made upon instantiating the Manager. This means the MongoDB\Driver\Manager can always be constructed, even though one or more MongoDB servers are down.

Any write or query can throw connection exceptions as connections are created lazily. A MongoDB server may also become unavailable during the life time of the script. It is therefore important that all actions on the Manager to be wrapped in try/catch statements.

Sinopsis de la Clase

final MongoDB\Driver\Manager {
/* Métodos */
final public __construct
 ( string $uri = "mongodb://127.0.0.1/"
, array $uriOptions = array()
, array $driverOptions = array()
)
final public createClientEncryption ( array $options ) : MongoDB\Driver\ClientEncryption
final public executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult
final public executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public getReadConcern ( ) : MongoDB\Driver\ReadConcern
final public getReadPreference ( ) : MongoDB\Driver\ReadPreference
final public getServers ( ) : array
final public getWriteConcern ( ) : MongoDB\Driver\WriteConcern
final public selectServer ( MongoDB\Driver\ReadPreference $readPreference ) : MongoDB\Driver\Server
final public startSession ( array $options = ? ) : MongoDB\Driver\Session
}

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::__construct() basic example

var_dump()ing a MongoDB\Driver\Manager will print out various details about the manager that are otherwise not normally exposed. This can be useful to debug how the driver views your MongoDB setup, and which options are used.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
var_dump($manager);

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\Manager)#1 (3) {
  ["request_id"]=>
  int(1714636915)
  ["uri"]=>
  string(25) "mongodb://localhost:27017"
  ["cluster"]=>
  array(13) {
    ["mode"]=>
    string(6) "direct"
    ["state"]=>
    string(4) "born"
    ["request_id"]=>
    int(0)
    ["sockettimeoutms"]=>
    int(300000)
    ["last_reconnect"]=>
    int(0)
    ["uri"]=>
    string(25) "mongodb://localhost:27017"
    ["requires_auth"]=>
    int(0)
    ["nodes"]=>
    array(...)
    ["max_bson_size"]=>
    int(16777216)
    ["max_msg_size"]=>
    int(50331648)
    ["sec_latency_ms"]=>
    int(15)
    ["peers"]=>
    array(0) {
    }
    ["replSet"]=>
    NULL
  }
}

Tabla de contenidos

  • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
  • MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object
  • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
  • MongoDB\Driver\Manager::executeCommand — Execute a database command
  • MongoDB\Driver\Manager::executeQuery — Execute a database query
  • MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes
  • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
  • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
  • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
  • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
  • MongoDB\Driver\Manager::startSession — Start a new client session for use with this client


Create new MongoDB Manager

  • « MongoDB\Driver\Manager
  • MongoDB\Driver\Manager::createClientEncryption »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Create new MongoDB Manager

MongoDB\Driver\Manager::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Manager::__construct — Create new MongoDB Manager

Descripción

final public MongoDB\Driver\Manager::__construct
 ( string $uri = "mongodb://127.0.0.1/"
, array $uriOptions = array()
, array $driverOptions = array()
)

Constructs a new MongoDB\Driver\Manager object with the specified options.

Nota: Per the » Server Discovery and Monitoring Specification, this constructor performs no I/O. Connections will be initialized on demand, when the first operation is executed.

Nota: When specifying any SSL or TLS URI options via the connection string or uriOptions parameter, the driver will implicitly enable TLS for its connections. To avoid this, either explicitly disable the tls option or don't specify any TLS options.

Nota: En plataformas Unix, el controlador de MongoDB es susceptible a scripts que utilizan la llamada al sistema fork() sin llamar también a exec(). Los usuarios están advertidos de no reusar instancias de MongoDB\Driver\Manager en un proceso hijo bifurcado («forked»).

Parámetros

uri

A » mongodb:// connection URI:

mongodb://[username:password@]host1[:port1][,host2[:port2],...[,hostN[:portN]]][/[defaultAuthDb][?options]]

For details on supported URI options, see » Connection String Options in the MongoDB manual. » Connection pool options are not supported, as the PHP driver does not implement connection pools.

The uri is a URL, hence any special characters in its components need to be URL encoded according to » RFC 3986. This is particularly relevant to the username and password, which can often include special characters such as @, :, or %. When connecting via a Unix domain socket, the socket path may contain special characters such as slashes and must be encoded. The rawurlencode() function may be used to encode constituent parts of the URI.

The defaultAuthDb component may be used to specify the database name associated with the user's credentials; however the authSource URI option will take priority if specified. If neither defaultAuthDb nor authSource are specified, the admin database will be used by default. The defaultAuthDb component has no effect in the absence of user credentials.

uriOptions

Additional » connection string options, which will overwrite any options with the same name in the uri parameter.

uriOptions
Option | Type | Description
appname string

MongoDB 3.4+ has the ability to annotate connections with metadata provided by the connecting client. This metadata is included in the server's logs upon establishing a connection and also recorded in slow query logs when database profiling is enabled.

This option may be used to specify an application name, which will be included in the metadata. The value cannot exceed 128 characters in length.

authMechanism string

The authentication mechanism that MongoDB will use to authenticate the connection. For additional details and a list of supported values, see » Authentication Options in the MongoDB manual.

authMechanismProperties array

Properties for the selected authentication mechanism. For additional details and a list of supported properties, see the » Driver Authentication Specification.

Nota: When not specified in the URI string, this option is expressed as an array of key/value pairs. The keys and values in this array should be strings.

authSource string

The database name associated with the user's credentials. Defaults to the database component of the connection URI, or the admin database if both are unspecified.

For authentication mechanisms that delegate credential storage to other services (e.g. GSSAPI), this should be "$external".

canonicalizeHostname bool

If true, the driver will resolve the real hostname for the server IP address before authenticating via SASL. Some underlying GSSAPI layers already do this, but the functionality may be disabled in their config (e.g. krb.conf). Defaults to false.

This option is a deprecated alias for the "CANONICALIZE_HOST_NAME" property of the "authMechanismProperties" URI option.

compressors string

A prioritized, comma-delimited list of compressors that the client wants to use. Messages are only compressed if the client and server share any compressors in common, and the compressor used in each direction will depend on the individual configuration of the server or driver. See the » Driver Compression Specification for more information.

connectTimeoutMS int

The time in milliseconds to attempt a connection before timing out. Defaults to 10,000 milliseconds.

directConnection bool

This option can be used to control replica set discovery behavior when only a single host is provided in the connection string. By default, providing a single member in the connection string will establish a direct connection or discover additional members depending on whether the "replicaSet" URI option is omitted or present, respectively. Specify false to force discovery to occur (if "replicaSet" is omitted) or specify true to force a direct connection (if "replicaSet" is present).

gssapiServiceName string

Set the Kerberos service name when connecting to Kerberized MongoDB instances. This value must match the service name set on MongoDB instances (i.e. » saslServiceName server parameter). Defaults to "mongodb".

This option is a deprecated alias for the "SERVICE_NAME" property of the "authMechanismProperties" URI option.

heartbeatFrequencyMS int

Specifies the interval in milliseconds between the driver's checks of the MongoDB topology, counted from the end of the previous check until the beginning of the next one. Defaults to 60,000 milliseconds.

Per the » Server Discovery and Monitoring Specification, this value cannot be less than 500 milliseconds.

journal bool

Corresponds to the default write concern's journal parameter. If true, writes will require acknowledgement from MongoDB that the operation has been written to the journal. For details, see MongoDB\Driver\WriteConcern.

localThresholdMS int

The size in milliseconds of the latency window for selecting among multiple suitable MongoDB instances while resolving a read preference. Defaults to 15 milliseconds.

maxStalenessSeconds int

Corresponds to the read preference's "maxStalenessSeconds". Specifies, in seconds, how stale a secondary can be before the client stops using it for read operations. By default, there is no maximum staleness and clients will not consider a secondary’s lag when choosing where to direct a read operation. For details, see MongoDB\Driver\ReadPreference.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS (i.e. 90 seconds).

password | string | The password for the user being authenticated. This option is useful if the password contains special characters, which would otherwise need to be URL encoded for the connection URI.
readConcernLevel | string | Corresponds to the read concern's level parameter. Specifies the level of read isolation. For details, see MongoDB\Driver\ReadConcern.
readPreference string

Corresponds to the read preference's mode parameter. Defaults to "primary". For details, see MongoDB\Driver\ReadPreference.

readPreferenceTags array

Corresponds to the read preference's tagSets parameter. Tag sets allow you to target read operations to specific members of a replica set. For details, see MongoDB\Driver\ReadPreference.

Nota: When not specified in the URI string, this option is expressed as an array consistent with the format expected by MongoDB\Driver\ReadPreference::__construct().

replicaSet string

Specifies the name of the replica set.

retryReads bool

Specifies whether or not the driver should automatically retry certain read operations that fail due to transient network errors or replica set elections. This functionality requires MongoDB 3.6+. Defaults to true.

See the » Retryable Reads Specification for more information.

retryWrites bool

Specifies whether or not the driver should automatically retry certain write operations that fail due to transient network errors or replica set elections. This functionality requires MongoDB 3.6+. Defaults to true.

See » Retryable Writes in the MongoDB manual for more information.

safe bool

If true, specifies 1 for the default write concern's w parameter. If false, 0 is specified. For details, see MongoDB\Driver\WriteConcern.

This option is deprecated and should not be used.

serverSelectionTimeoutMS int

Specifies how long in milliseconds to block for server selection before throwing an exception. Defaults to 30,000 milliseconds.

serverSelectionTryOnce bool

When true, instructs the driver to scan the MongoDB deployment exactly once after server selection fails and then either select a server or raise an error. When false, the driver blocks and searches for a server up to the "serverSelectionTimeoutMS" value. Defaults to true.

slaveOk bool

Specifies "secondaryPreferred" for the read preference mode if true. For details, see MongoDB\Driver\ReadPreference.

This option is deprecated and should not be used.

socketCheckIntervalMS int

If a socket has not been used recently, the driver must check it via an isMaster command before using it for any operation. Defaults to 5,000 milliseconds.

socketTimeoutMS int

The time in milliseconds to attempt a send or receive on a socket before timing out. Defaults to 300,000 milliseconds (i.e. five minutes).

ssl bool

Initiates the connection with TLS/SSL if true. Defaults to false.

This option is a deprecated alias for the "tls" URI option.

tls bool

Initiates the connection with TLS/SSL if true. Defaults to false.

tlsAllowInvalidCertificates bool

Specifies whether or not the driver should error when the server's TLS certificate is invalid. Defaults to false.

Advertencia

Disabling certificate validation creates a vulnerability.

tlsAllowInvalidHostnames bool

Specifies whether or not the driver should error when there is a mismatch between the server's hostname and the hostname specified by the TLS certificate. Defaults to false.

Advertencia

Disabling certificate validation creates a vulnerability. Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

tlsCAFile string

Path to file with either a single or bundle of certificate authorities to be considered trusted when making a TLS connection. The system certificate store will be used by default.

tlsCertificateKeyFile string

Path to the client certificate file or the client private key file; in the case that they both are needed, the files should be concatenated.

tlsCertificateKeyFilePassword string

Password to decrypt the client private key (i.e. "tlsCertificateKeyFile" URI option) to be used for TLS connections.

tlsDisableCertificateRevocationCheck bool

If true, the driver will not attempt to check certificate revocation status (e.g. OCSP, CRL). Defaults to false.

tlsDisableOCSPEndpointCheck bool

If true, the driver will not attempt to contact an OCSP responder endpoint if needed (i.e. an OCSP response is not stapled). Defaults to false.

tlsInsecure bool

Relax TLS constraints as much as possible. Specifying true for this option has the same effect as specifying true for both the "tlsAllowInvalidCertificates" and "tlsAllowInvalidHostnames" URI options. Defaults to false.

Advertencia

Disabling certificate validation creates a vulnerability. Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

username | string | The username for the user being authenticated. This option is useful if the username contains special characters, which would otherwise need to be URL encoded for the connection URI.
w int|string

Corresponds to the default write concern's w parameter. For details, see MongoDB\Driver\WriteConcern.

wTimeoutMS int|string

Corresponds to the default write concern's wtimeout parameter. Specifies a time limit, in milliseconds, for the write concern. For details, see MongoDB\Driver\WriteConcern.

If specified, wTimeoutMS must be a signed 32-bit integer greater than or equal to zero.

zlibCompressionLevel int

Specifies the compression level to use for the zlib compressor. This option has no effect if zlib is not included in the "compressors" URI option. See the » Driver Compression Specification for more information.

driverOptions

driverOptions
Option | Type | Description
allow_invalid_hostname bool

Disables hostname validation if true. Defaults to false.

Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

This option is a deprecated alias for the "tlsAllowInvalidHostnames" URI option.

autoEncryption array

Provides options to enable automatic client-side field level encryption. The following options are supported:

Options for automatic encryption
Option | Type | Description
keyVaultClient | MongoDB\Driver\Manager | The Manager used to route data key queries to a separate MongoDB cluster. By default, the current Manager and cluster is used.
keyVaultNamespace | string | A fully qualified namespace (e.g. "databaseName.collectionName") denoting the collection that contains all data keys used for encryption and decryption.
kmsProviders array

A document containing the configuration for one or more KMS providers, which are used to encrypt data keys. Currently aws or local are supported and at least one must be specified.

The format for aws is as follows:

aws: {
    accessKeyId: <string>,
    secretAccessKey: <string>
}

The format for local is as follows:

local: {
    // The master key used to encrypt/decrypt data keys
    key: <96-byte MongoDB\BSON\Binary with subtype 0>
}
schemaMap array

Allows specifying a local JSON schema that is used to configure encryption.

Nota: Supplying a schemaMap provides more security than relying on JSON schemas obtained from the server. It protects against a malicious server advertising a false JSON schema, which could trick the client into sending unencrypted data that should be encrypted.

Nota: Schemas supplied in the schemaMap only apply to configuring automatic encryption for client side encryption. Other validation rules in the JSON schema will not be enforced by the driver and will result in an error.

bypassAutoEncryption | bool | With this option set to true, mongocryptd will not be spawned automatically. This is used to disable automatic encryption.
extraOptions | array | The extraOptions relate to the mongocryptd process. See the » Client-Side Encryption Specification for more information.

Nota: Automatic encryption is an enterprise only feature that only applies to operations on a collection. Automatic encryption is not supported for operations on a database or view, and operations that are not bypassed will result in error. To bypass automatic encryption for all operations, set bypassAutoEncryption=true in autoEncryption. For more information on whitelisted operations, see the » Client-Side Encryption Specification.

ca_dir string

Path to a correctly hashed certificate directory. The system certificate store will be used by default.

ca_file string

Path to file with either a single or bundle of certificate authorities to be considered trusted when making a TLS connection. The system certificate store will be used by default.

This option is a deprecated alias for the "tlsCAFile" URI option.

context resource

SSL context options to be used as fallbacks if a driver option or its equivalent URI option, if any, is not specified. Note that the driver does not consult the default stream context (i.e. stream_context_get_default()). The following context options are supported:

SSL context option fallbacks
Driver option | Context option (fallback)
ca_dir | capath
ca_file | cafile
pem_file | local_cert
pem_pwd | passphrase
weak_cert_validation | allow_self_signed

This option is supported for backwards compatibility, but should be considered deprecated.

crl_file | string | Path to a certificate revocation list file.
driver array

Allows custom drivers to append their own metadata to the server handshake. By default, the driver submits its own name, version, and platform (i.e. PHP version) in the handshake. Custom drivers can specify strings for the "name", "version", and "platform" keys of this array, which will be appended to the respective field(s) in the handshake document.

Nota: Handshake information is limited to 512 bytes. The driver will truncate handshake data to fit within this 512-byte string. Drivers and ODMs are encouraged to keep their own metadata concise.

pem_file string

Path to a PEM encoded certificate to use for client authentication.

This option is a deprecated alias for the "tlsCertificateKeyFile" URI option.

pem_pwd string

Passphrase for the PEM encoded certificate (if applicable).

This option is a deprecated alias for the "tlsCertificateKeyFilePassword" URI option.

weak_cert_validation bool

Disables certificate validation if true. Defaults to false

This option is a deprecated alias for the "tlsAllowInvalidHostnames" URI option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\RuntimeException if the uri format is invalid

Historial de cambios

Versión Descripción
PECL mongodb 1.8.0

Added the "directConnection", "tlsDisableCertificateRevocationCheck", and "tlsDisableOCSPEndpointCheck" URI options.

Added the "driver" driver option.

PECL mongodb 1.7.0

Added the "autoEncryption" driver option.

Specifying any SSL or TLS option via the driverOptions parameter will now implicitly enable TLS, as is done for the corresponding URI options.

PECL mongodb 1.6.0

Added the "retryReads", "tls", "tlsAllowInvalidCertificates", "tlsAllowInvalidHostnames", "tlsCAFile", "tlsCertificateKeyFile", "tlsCertificateKeyFilePassword", and "tlsInsecure" URI options.

The "retryWrites" URI option defaults to true.

Specifying any SSL or TLS URI option via the connection string or uriOptions parameter will now implicitly enable TLS unless ssl or tls is false. TLS is not implicitly enabled for any options in the driverOptions parameter, which is unchanged from previous versions.

PECL mongodb 1.5.0

"wtimeoutMS" is now always validated and applied to the write concern. Previously, the option was ignored if "w" was <= 1, since the timeout only applies to replication.

PECL mongodb 1.4.0

Added the "compressors", "retryWrites", and "zlibCompressionLevel" URI options.

PECL mongodb 1.3.0

The uriOptions argument now accepts "authMechanism" and "authMechanismProperties" options. Previously, these options were only supported in the uri argument.

PECL mongodb 1.2.0

The uri argument defaults to "mongodb://127.0.0.1/". The default port remains 27017.

Added the "appname" URI option.

Added the "allow_invalid_hostname", "ca_file", "ca_dir", "clr_file", "pem_file", "pem_pwd", and "weak_cert_validation" driver options.

The PHP Streams API is no longer used for socket communication. The "connectTimeoutMS" URI option now defaults to 10 seconds instead of default_socket_timeout in previous versions. Additionally, the driver no longer supports all SSL context options via the "context" driver option.

PECL mongodb 1.1.0

The uri argument is optional and defaults to "mongodb://localhost:27017/".

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::__construct() basic examples

Connecting to standalone MongoDB node:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://example.com:27017");

?>

Connecting to standalone MongoDB node via a Unix domain socket. The socket path may include special characters such as slashes and should be encoded with rawurlencode().

<?php

$manager = new MongoDB\Driver\Manager("mongodb://" . rawurlencode("/tmp/mongodb-27017.sock"));

?>

Connecting to a replica set:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

?>

Connecting to a sharded cluster (i.e. one or more mongos instances):

<?php

$manager = new MongoDB\Driver\Manager("mongodb://mongos1.example.com,mongos2.example.com/");

?>

Connecting to MongoDB with authentication credentials for a particular user and database:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:mypassword@example.com/?authSource=databaseName");

?>

Connecting to MongoDB with authentication credentials for a particular user and database, where the username or password includes special characters (e.g. @, :, %). In the following example, the password string myp@ss:w%rd has been manually escaped; however, rawurlencode() may also be used to escape URI components that may contain special characters.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:myp%40ss%3Aw%25rd@example.com/?authSource=databaseName");

?>

Connecting to MongoDB with X509 authentication:

<?php

$manager = new MongoDB\Driver\Manager(
    "mongodb://example.com/?ssl=true&authMechanism=MONGODB-X509",
    [],
    [
        "pem_file" => "/path/to/client.pem",
    ]
);
?>

Ver también

  • Connection handling and persistence
  • » MongoDB Connection String Format


Create a new ClientEncryption object

  • « MongoDB\Driver\Manager::__construct
  • MongoDB\Driver\Manager::executeBulkWrite »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Create a new ClientEncryption object

MongoDB\Driver\Manager::createClientEncryption

(mongodb >=1.7.0)

MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object

Descripción

final public MongoDB\Driver\Manager::createClientEncryption ( array $options ) : MongoDB\Driver\ClientEncryption

Constructs a new MongoDB\Driver\ClientEncryption object with the specified options.

Parámetros

options

options
Option | Type | Description
keyVaultClient | MongoDB\Driver\Manager | The Manager used to route data key queries to a separate MongoDB cluster. By default, the current Manager and cluster is used.
keyVaultNamespace | string | A fully qualified namespace (e.g. "databaseName.collectionName") denoting the collection that contains all data keys used for encryption and decryption.
kmsProviders array

A document containing the configuration for one or more KMS providers, which are used to encrypt data keys. Currently aws or local are supported and at least one must be specified.

The format for aws is as follows:

aws: {
    accessKeyId: <string>,
    secretAccessKey: <string>
}

The format for local is as follows:

local: {
    // The master key used to encrypt/decrypt data keys
    key: <96-byte MongoDB\BSON\Binary with subtype 0>
}

Valores devueltos

Returns a new MongoDB\Driver\ClientEncryption instance.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\RuntimeException if the extension was compiled without libmongocrypt support

Ver también

  • MongoDB\Driver\ClientEncryption
  • » Explicit (Manual) Client-Side Field Level Encryption in the MongoDB manual


Execute one or more write operations

  • « MongoDB\Driver\Manager::createClientEncryption
  • MongoDB\Driver\Manager::executeCommand »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute one or more write operations

MongoDB\Driver\Manager::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations

Descripción

final public MongoDB\Driver\Manager::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult

Executes one or more write operations on the primary server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

Parámetros

namespace (string)

Un espacio de nombres completamente cualificado (p. ej. "nombreBaseDatos.nombreColección").

bulk (MongoDB\Driver\BulkWrite)

La/s escritura/s a ejecutar.

options

options
Option Type Description
session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Valores devueltos

Devuelve un MongoDB\Driver\WriteResult en caso de éxito.

Errores/Excepciones

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk does not contain any write operations.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk has already been executed. MongoDB\Driver\BulkWrite objects may not be executed multiple times.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Lanza una MongoDB\Driver\Exception\BulkWriteException al fallar cualquier escritura (p.ej. error de escritura, fallo al aplicar un asunto de escritura)
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\WriteConcern object.
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is now thrown if bulk does not contain any write operations. Previously, a MongoDB\Driver\Exception\BulkWriteException was thrown.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::executeBulkWrite() example

<?php

$bulk = new MongoDB\Driver\BulkWrite();

$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);

$bulk->update(['x' => 2], ['$set' => ['x' => 1]], ['multi' => false, 'upsert' => false]);
$bulk->update(['x' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);
$bulk->update(['_id' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);

$bulk->insert(['_id' => 4, 'x' => 2]);

$bulk->delete(['x' => 1], ['limit' => 1]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 100);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Matched  %d document(s)\n", $result->getMatchedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

foreach ($result->getUpsertedIds() as $index => $id) {
    printf('upsertedId[%d]: ', $index);
    var_dump($id);
}

/* If the WriteConcern could not be fulfilled */
if ($writeConcernError = $result->getWriteConcernError()) {
    printf("%s (%d): %s\n", $writeConcernError->getMessage(), $writeConcernError->getCode(), var_export($writeConcernError->getInfo(), true));
}

/* If a write could not happen at all */
foreach ($result->getWriteErrors() as $writeError) {
    printf("Operation#%d: %s (%d)\n", $writeError->getIndex(), $writeError->getMessage(), $writeError->getCode());
}
?>

El resultado del ejemplo sería algo similar a:

Inserted 3 document(s)
Matched  1 document(s)
Updated  1 document(s)
Upserted 2 document(s)
Deleted  1 document(s)
upsertedId[3]: object(MongoDB\BSON\ObjectId)#5 (1) {
  ["oid"]=>
  string(24) "54d3adc3ce7a792f4d703756"
}
upsertedId[4]: int(3)

Ver también

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Server::executeBulkWrite() - Execute one or more write operations on this server


Execute a database command

  • « MongoDB\Driver\Manager::executeBulkWrite
  • MongoDB\Driver\Manager::executeQuery »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command

MongoDB\Driver\Manager::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeCommand — Execute a database command

Descripción

final public MongoDB\Driver\Manager::executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the command on that server. By default, the read preference from the MongoDB Connection URI will be used.

This method applies no special logic to the command. Although this method accepts "readConcern" and "writeConcern" options, which will be incorporated into the command document, those options will not default to corresponding values from the MongoDB Connection URI nor will the MongoDB server version be taken into account. Users are therefore encouraged to use specific read and/or write command methods if possible.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::executeCommand() with a command returning a single result document

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$command = new MongoDB\Driver\Command(['ping' => 1]);

try {
    $cursor = $manager->executeCommand('admin', $command);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

/* The ping command returns a single result document, so we need to access the
 * first result in the cursor. */
$response = $cursor->toArray()[0];

var_dump($response);

?>

El resultado del ejemplo sería:

array(1) {
  ["ok"]=>
  float(1)
}

Ejemplo #2 MongoDB\Driver\Manager::executeCommand() with a command returning a cursor

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1, 'y' => 'foo']);
$bulk->insert(['x' => 2, 'y' => 'bar']);
$bulk->insert(['x' => 3, 'y' => 'bar']);
$manager->executeBulkWrite('db.collection', $bulk);

$command = new MongoDB\Driver\Command([
    'aggregate' => 'collection',
    'pipeline' => [
        ['$group' => ['_id' => '$y', 'sum' => ['$sum' => '$x']]],
    ],
    'cursor' => new stdClass,
]);
$cursor = $manager->executeCommand('db', $command);

/* The aggregate command can optionally return its results in a cursor instead
 * of a single result document. In this case, we can iterate on the cursor
 * directly to access those results. */
foreach ($cursor as $document) {
    var_dump($document);
}

?>

El resultado del ejemplo sería:

object(stdClass)#6 (2) {
  ["_id"]=>
  string(3) "bar"
  ["sum"]=>
  int(10)
}
object(stdClass)#7 (2) {
  ["_id"]=>
  string(3) "foo"
  ["sum"]=>
  int(2)
}

Ejemplo #3 Limiting execution time for a command

The execution time of a command may be limited by specifying a value for "maxTimeMS" in the MongoDB\Driver\Command document. Note that this time limit is enforced on the server side and does not take network latency into account. See » Terminate Running Operations in the MongoDB manual for more information.

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');

$command = new MongoDB\Driver\Command([
    'count' => 'collection',
    'query' => ['x' => ['$gt' => 1]],
    'maxTimeMS' => 1000,
]);

$cursor = $manager->executeCommand('db', $command);

var_dump($cursor->toArray()[0]);

?>

If the command fails to complete after one second of execution time on the server, a MongoDB\Driver\Exception\ExecutionTimeoutException will be thrown.

Notas

Nota: If a secondary readPreference is used, it is the caller's responsibility to ensure that the command can be executed on a secondary. No validation is done by the driver.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server


Execute a database query

  • « MongoDB\Driver\Manager::executeCommand
  • MongoDB\Driver\Manager::executeReadCommand »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database query

MongoDB\Driver\Manager::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeQuery — Execute a database query

Descripción

final public MongoDB\Driver\Manager::executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the query on that server. By default, the read preference from the MongoDB Connection URI will be used.

Parámetros

namespace (string)

Un espacio de nombres completamente cualificado (p. ej. "nombreBaseDatos.nombreColección").

query (MongoDB\Driver\Query)

La consulta a ejecutar.

options

options
Option Type Description
readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::executeQuery() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$filter = ['x' => ['$gt' => 1]];
$options = [
    'projection' => ['_id' => 0],
    'sort' => ['x' => -1],
];

$query = new MongoDB\Driver\Query($filter, $options);
$cursor = $manager->executeQuery('db.collection', $query);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

El resultado del ejemplo sería:

object(stdClass)#6 (1) {
  ["x"]=>
  int(3)
}
object(stdClass)#7 (1) {
  ["x"]=>
  int(2)
}

Ejemplo #2 Limiting execution time for a query

The "maxTimeMS" MongoDB\Driver\Query option may be used to limit the execution time of a query. Note that this time limit is enforced on the server side and does not take network latency into account. See » Terminate Running Operations in the MongoDB manual for more information.

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');

$filter = ['x' => ['$gt' => 1]];
$options = [
    'maxTimeMS' => 1000,
];

$query = new MongoDB\Driver\Query($filter, $options);
$cursor = $manager->executeQuery('db.collection', $query);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

If the query fails to complete after one second of execution time on the server, a MongoDB\Driver\Exception\ExecutionTimeoutException will be thrown.

Ver también

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server


Execute a database command that reads

  • « MongoDB\Driver\Manager::executeQuery
  • MongoDB\Driver\Manager::executeReadWriteCommand »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that reads

MongoDB\Driver\Manager::executeReadCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads

Descripción

final public MongoDB\Driver\Manager::executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the command on that server. By default, the read preference from the MongoDB Connection URI will be used.

This method will apply logic that is specific to commands that read (e.g. » count) and take the MongoDB server version into account. The "readConcern" option will default to the corresponding value from the MongoDB Connection URI.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server


Execute a database command that reads and writes

  • « MongoDB\Driver\Manager::executeReadCommand
  • MongoDB\Driver\Manager::executeWriteCommand »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that reads and writes

MongoDB\Driver\Manager::executeReadWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes

Descripción

final public MongoDB\Driver\Manager::executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on the primary server.

This method will apply logic that is specific to commands that read and write (e.g. » aggregate) and take the MongoDB server version into account. The "readConcern" and "writeConcern" options will default to the corresponding values from the MongoDB Connection URI.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server


Execute a database command that writes

  • « MongoDB\Driver\Manager::executeReadWriteCommand
  • MongoDB\Driver\Manager::getReadConcern »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that writes

MongoDB\Driver\Manager::executeWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes

Descripción

final public MongoDB\Driver\Manager::executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on the primary server.

This method will apply logic that is specific to commands that write (e.g. » drop) and take the MongoDB server version into account. The "writeConcern" option will default to the corresponding value from the MongoDB Connection URI.

Nota: This method is not intended to be used to execute » insert, » update, or » delete commands. Users are encouraged to use MongoDB\Driver\Manager::executeBulkWrite() for those commands.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server


Return the ReadConcern for the Manager

  • « MongoDB\Driver\Manager::executeWriteCommand
  • MongoDB\Driver\Manager::getReadPreference »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the ReadConcern for the Manager

MongoDB\Driver\Manager::getReadConcern

(mongodb >=1.1.0)

MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager

Descripción

final public MongoDB\Driver\Manager::getReadConcern ( ) : MongoDB\Driver\ReadConcern

Returns the MongoDB\Driver\ReadConcern for the Manager, which is derived from its URI options. This is the default read concern for queries and commands executed on the Manager.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The MongoDB\Driver\ReadConcern for the Manager.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::getReadConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readConcernLevel=local');
var_dump($manager->getReadConcern());

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\ReadConcern)#2 (0) {
}
object(MongoDB\Driver\ReadConcern)#1 (1) {
  ["level"]=>
  string(5) "local"
}

Ver también

  • MongoDB\Driver\ReadConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Return the ReadPreference for the Manager

  • « MongoDB\Driver\Manager::getReadConcern
  • MongoDB\Driver\Manager::getServers »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the ReadPreference for the Manager

MongoDB\Driver\Manager::getReadPreference

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager

Descripción

final public MongoDB\Driver\Manager::getReadPreference ( ) : MongoDB\Driver\ReadPreference

Returns the MongoDB\Driver\ReadPreference for the Manager, which is derived from its URI options. This is the default read preference for queries and commands executed on the Manager.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The MongoDB\Driver\ReadPreference for the Manager.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::getReadPreference() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadPreference());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readPreference=secondaryPreferred&readPreferenceTags=dc:ny,rack:1&readPreferenceTags=dc:ny&readPreferenceTags=');
var_dump($manager->getReadPreference());

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\ReadPreference)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(18) "secondaryPreferred"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#3 (2) {
      ["dc"]=>
      string(2) "ny"
      ["rack"]=>
      string(1) "1"
    }
    [1]=>
    object(stdClass)#4 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [2]=>
    object(stdClass)#5 (0) {
    }
  }
}

Ver también

  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Return the servers to which this manager is connected

  • « MongoDB\Driver\Manager::getReadPreference
  • MongoDB\Driver\Manager::getWriteConcern »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the servers to which this manager is connected

MongoDB\Driver\Manager::getServers

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected

Descripción

final public MongoDB\Driver\Manager::getServers ( ) : array

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

Nota: Since the driver connects to the database lazily, this method may return an empty array if called before executing an operation on the MongoDB\Driver\Manager.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::getServers() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

/* The driver connects to the database server lazily, so Manager::getServers()
 * may initially return an empty array. */
var_dump($manager->getServers());

$command = new MongoDB\Driver\Command(['ping' => 1]);
$manager->executeCommand('db', $command);

var_dump($manager->getServers());

?>

El resultado del ejemplo sería algo similar a:

array(0) {
}
array(1) {
  [0]=>
  object(MongoDB\Driver\Server)#3 (10) {
    ["host"]=>
    string(9) "localhost"
    ["port"]=>
    int(27017)
    ["type"]=>
    int(1)
    ["is_primary"]=>
    bool(false)
    ["is_secondary"]=>
    bool(false)
    ["is_arbiter"]=>
    bool(false)
    ["is_hidden"]=>
    bool(false)
    ["is_passive"]=>
    bool(false)
    ["last_is_master"]=>
    array(8) {
      ["ismaster"]=>
      bool(true)
      ["maxBsonObjectSize"]=>
      int(16777216)
      ["maxMessageSizeBytes"]=>
      int(48000000)
      ["maxWriteBatchSize"]=>
      int(1000)
      ["localTime"]=>
      object(MongoDB\BSON\UTCDateTime)#4 (1) {
        ["milliseconds"]=>
        int(1447267964517)
      }
      ["maxWireVersion"]=>
      int(3)
      ["minWireVersion"]=>
      int(0)
      ["ok"]=>
      float(1)
    }
    ["round_trip_time"]=>
    int(554)
  }
}

Ver también

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference


Return the WriteConcern for the Manager

  • « MongoDB\Driver\Manager::getServers
  • MongoDB\Driver\Manager::selectServer »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the WriteConcern for the Manager

MongoDB\Driver\Manager::getWriteConcern

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager

Descripción

final public MongoDB\Driver\Manager::getWriteConcern ( ) : MongoDB\Driver\WriteConcern

Returns the MongoDB\Driver\WriteConcern for the Manager, which is derived from its URI options. This is the default write concern for writes and commands executed on the Manager.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The MongoDB\Driver\WriteConcern for the Manager.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Manager::getWriteConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getWriteConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?w=majority&wtimeoutMS=2000');
var_dump($manager->getWriteConcern());

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\WriteConcern)#2 (0) {
}
object(MongoDB\Driver\WriteConcern)#1 (2) {
  ["w"]=>
  string(8) "majority"
  ["wtimeout"]=>
  int(2000)
}

Ver también

  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Select a server matching a read preference

  • « MongoDB\Driver\Manager::getWriteConcern
  • MongoDB\Driver\Manager::startSession »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Select a server matching a read preference

MongoDB\Driver\Manager::selectServer

(mongodb >=1.0.0)

MongoDB\Driver\Manager::selectServer — Select a server matching a read preference

Descripción

final public MongoDB\Driver\Manager::selectServer ( MongoDB\Driver\ReadPreference $readPreference ) : MongoDB\Driver\Server

Selects a MongoDB\Driver\Server matching readPreference. This may be used to preselect a server in order to perform version checking before executing an operation.

Nota: Unlike MongoDB\Driver\Manager::getServers(), this method will initialize database connections and perform server discovery if necessary. See the » Server Selection Specification for additional information.

Parámetros

readPreference (MongoDB\Driver\ReadPreference)

The read preference to use for selecting a server.

Valores devueltos

Returns a MongoDB\Driver\Server matching the read preference.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException if a server matching the read preference could not be found.

Ver también

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • » Server Selection Specification


Start a new client session for use with this client

  • « MongoDB\Driver\Manager::selectServer
  • MongoDB\Driver\Command »
  • PHP Manual
  • MongoDB\Driver\Manager
  • Start a new client session for use with this client

MongoDB\Driver\Manager::startSession

(mongodb >=1.4.0)

MongoDB\Driver\Manager::startSession — Start a new client session for use with this client

Descripción

final public MongoDB\Driver\Manager::startSession ( array $options = ? ) : MongoDB\Driver\Session

Creates a MongoDB\Driver\Session for the given options. The session may then be specified when executing commands, queries, and write operations.

Nota: A MongoDB\Driver\Session can only be used with the MongoDB\Driver\Manager from which it was created.

Parámetros

options

options
Option Type Description Default
causalConsistency bool

Configure causal consistency in a session. If true, each operation in the session will be causally ordered after the previous read or write operation. Set to false to disable causal consistency.

See » Casual Consistency in the MongoDB manual for more information.

true
defaultTransactionOptions array

Default options to apply to newly created transactions. These options are used unless they are overridden when a transaction is started with different value for each option.

options
Option Type Description
maxCommitTimeMS integer

The maximum amount of time in milliseconds to allow a single commitTransaction command to run.

If specified, maxCommitTimeMS must be a signed 32-bit integer greater than or equal to zero.

readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

This option is available in MongoDB 4.0+.

[]

Valores devueltos

Returns a MongoDB\Driver\Session.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\RuntimeException if the session could not be created (e.g. libmongoc does not support crypto).

Historial de cambios

Versión | Descripción
PECL mongodb 1.6.0 | The "maxCommitTimeMS" option was added to "defaultTransactionOptions".
PECL mongodb 1.5.0 | The "defaultTransactionOptions" option was added.

Ver también

  • MongoDB\Driver\Session
  • » Casual Consistency in the MongoDB manual


The MongoDB\Driver\Command class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\Command class is a value object that represents a database command.

To provide Command Helpers the MongoDB\Driver\Command object should be composed.

Sinopsis de la Clase

final MongoDB\Driver\Command {
/* Métodos */
final public __construct ( array|object $document , array $commandOptions = ? )
}

Ejemplos

Ejemplo #1 Composing MongoDB\Driver\Command to provide a helper to create collections

<?php
class CreateCollection {
    protected $cmd = array();

    function __construct($collectionName) {
        $this->cmd["create"] = (string)$collectionName;
    }
    function setCappedCollection($maxBytes, $maxDocuments = false) {
        $this->cmd["capped"] = true;
        $this->cmd["size"]   = (int)$maxBytes;

        if ($maxDocuments) {
            $this->cmd["max"] = (int)$maxDocuments;
        }
    }
    function usePowerOf2Sizes($bool) {
        if ($bool) {
            $this->cmd["flags"] = 1;
        } else {
            $this->cmd["flags"] = 0;
        }
    }
    function setFlags($flags) {
        $this->cmd["flags"] = (int)$flags;
    }
    function getCommand() {
        return new MongoDB\Driver\Command($this->cmd);
    }
    function getCollectionName() {
        return $this->cmd["create"];
    }
}

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$createCollection = new CreateCollection("cappedCollection");
$createCollection->setCappedCollection(64 * 1024);

try {
    $command = $createCollection->getCommand();
    $cursor = $manager->executeCommand("databaseName", $command);
    $response = $cursor->toArray()[0];
    var_dump($response);

    $collstats = ["collstats" => $createCollection->getCollectionName()];
    $cursor = $manager->executeCommand("databaseName", new MongoDB\Driver\Command($collstats));
    $response = $cursor->toArray()[0];
    var_dump($response);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

?>

El resultado del ejemplo sería:

object(MongoDB\Driver\Command)#3 (1) {
  ["command"]=>
  array(3) {
    ["create"]=>
    string(16) "cappedCollection"
    ["capped"]=>
    bool(true)
    ["size"]=>
    int(65536)
  }
}
array(1) {
  ["ok"]=>
  float(1)
}
array(16) {
  ["ns"]=>
  string(29) "databaseName.cappedCollection"
  ["count"]=>
  int(0)
  ["size"]=>
  int(0)
  ["numExtents"]=>
  int(1)
  ["storageSize"]=>
  int(65536)
  ["nindexes"]=>
  int(1)
  ["lastExtentSize"]=>
  float(65536)
  ["paddingFactor"]=>
  float(1)
  ["paddingFactorNote"]=>
  string(101) "paddingFactor is unused and unmaintained in 2.8. It remains hard coded to 1.0 for compatibility only."
  ["userFlags"]=>
  int(0)
  ["capped"]=>
  bool(true)
  ["max"]=>
  int(9223372036854775807)
  ["maxSize"]=>
  int(65536)
  ["totalIndexSize"]=>
  int(8176)
  ["indexSizes"]=>
  object(stdClass)#4 (1) {
    ["_id_"]=>
    int(8176)
  }
  ["ok"]=>
  float(1)
}

Tabla de contenidos

  • MongoDB\Driver\Command::__construct — Create a new Command


Create a new Command

  • « MongoDB\Driver\Command
  • MongoDB\Driver\Query »
  • PHP Manual
  • MongoDB\Driver\Command
  • Create a new Command

MongoDB\Driver\Command::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Command::__construct — Create a new Command

Descripción

final public MongoDB\Driver\Command::__construct ( array|object $document , array $commandOptions = ? )

Constructs a new MongoDB\Driver\Command, which is an immutable value object that represents a database command. The command may then be executed with MongoDB\Driver\Manager::executeCommand().

The complete command document, which includes the command name and its options, should be expressed in the document parameter. The commandOptions parameter is only used to specify options related to the execution of the command and the resulting MongoDB\Driver\Cursor.

Parámetros

document

The complete command document, which will be sent to the server.

commandOptions

Nota: Do not use this parameter to specify options described in the command's reference in the MongoDB manual. This parameter should only be used for the options explicitly listed below.

commandOptions
Option Type Description
maxAwaitTimeMS int

Positive integer denoting the time limit in milliseconds for the server to block a getMore operation if no data is available. This option should only be used in conjunction with commands that return a tailable cursor (e.g. » Change Streams).

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.0 | Added a second commandOptions argument, which supports the "maxAwaitTimeMS" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\Command::__construct() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$command = new MongoDB\Driver\Command(array("buildinfo" => 1));

try {
    $cursor = $manager->executeCommand("admin", $command);
    $response = $cursor->toArray()[0];
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}
var_dump($response);

?>

El resultado del ejemplo sería algo similar a:

array(13) {
  ["version"]=>
  string(14) "2.8.0-rc2-pre-"
  ["gitVersion"]=>
  string(62) "b743d7158f7642f4da6b7eac8320374b3b88dc2e modules: subscription"
  ["OpenSSLVersion"]=>
  string(25) "OpenSSL 1.0.1f 6 Jan 2014"
  ["sysInfo"]=>
  string(104) "Linux infant 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49"
  ["loaderFlags"]=>
  string(91) "-fPIC -pthread -Wl,-z,now -rdynamic -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -Wl,-E"
  ["compilerFlags"]=>
  string(301) "-Wnon-virtual-dtor -Woverloaded-virtual -std=c++11 -fPIC -fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -pipe -Werror -O3 -Wno-unused-local-typedefs -Wno-unused-function -Wno-deprecated-declarations -Wno-unused-but-set-variable -fno-builtin-memcmp -std=c99"
  ["allocator"]=>
  string(8) "tcmalloc"
  ["versionArray"]=>
  array(4) {
    [0]=>
    int(2)
    [1]=>
    int(8)
    [2]=>
    int(0)
    [3]=>
    int(-8)
  }
  ["javascriptEngine"]=>
  string(2) "V8"
  ["bits"]=>
  int(64)
  ["debug"]=>
  bool(false)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["ok"]=>
  float(1)
}

Ejemplo #2 MongoDB\Driver\Command::__construct() example

Commands can accept options as well, as part of the normal structure that you create to send to the server. For example, the maxTimeMS option can be passed with most commands to restrict the amount of time a specific command can run for on the server.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$command = new MongoDB\Driver\Command(
    array(
        "distinct" => "beer",
        "key" => "beer_name",
        "maxTimeMS" => 10,
    )
);

try {
    $cursor = $manager->executeCommand("beerdb", $command);
    $response = $cursor->toArray()[0];
} catch(MongoDB\Driver\Exception\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}
var_dump($response);

?>

El resultado del ejemplo sería algo similar a:

operation exceeded time limit

Ver también

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Cursor


The MongoDB\Driver\Query class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\Query class is a value object that represents a database query.

Sinopsis de la Clase

final MongoDB\Driver\Query {
/* Métodos */
final public __construct ( array|object $filter , array $queryOptions = ? )
}

Tabla de contenidos

  • MongoDB\Driver\Query::__construct — Create a new Query


Create a new Query

  • « MongoDB\Driver\Query
  • MongoDB\Driver\BulkWrite »
  • PHP Manual
  • MongoDB\Driver\Query
  • Create a new Query

MongoDB\Driver\Query::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Query::__construct — Create a new Query

Descripción

final public MongoDB\Driver\Query::__construct ( array|object $filter , array $queryOptions = ? )

Constructs a new MongoDB\Driver\Query, which is an immutable value object that represents a database query. The query may then be executed with MongoDB\Driver\Manager::executeQuery().

Parámetros

filter (array|object)

El » predicado de la consulta. Un predicado vacío coincidirá con todos los documentos de una colección.

Nota: Al evaluar criterios de consulta, MongoDB compara tipos y valores según sus propias » reglas de comparación para tipos BSON, lo cual difiere de las reglas de comparación y manejo de tipos de PHP. Al encontrar un tipo BSON especial, los criterios de consulta deben utilizar la clase BSON respectiva (p.ej. usar MongoDB\BSON\ObjectID al encontrar un » ObjectID).

queryOptions

queryOptions
Option | Type | Description
allowDiskUse bool

Allows MongoDB to use temporary disk files to store data exceeding the 100 megabyte system memory limit while processing a blocking sort operation.

allowPartialResults bool

For queries against a sharded collection, returns partial results from the mongos if some shards are unavailable instead of throwing an error.

Falls back to the deprecated "partial" option if not specified.

awaitData | bool | Use in conjunction with the "tailable" option to block a getMore operation on the cursor temporarily if at the end of data rather than returning no data. After a timeout period, the query returns as normal.
batchSize int

The number of documents to return in the first batch. Defaults to 101. A batch size of 0 means that the cursor will be established, but no documents will be returned in the first batch.

In versions of MongoDB before 3.2, where queries use the legacy wire protocol OP_QUERY, a batch size of 1 will close the cursor irrespective of the number of matched documents.

collation array|object

» Collation, o cotejamiento, permite a los usuarios especificar reglas específcas del lenguaje para comparar cadenas, tales como reglas para mayúsculas/minúsculas y marcas de acento. Cuando se especifica el cotejamiento, el cambpo "locale" es obligatorio; todos los demás campos de cotejamiento son opcionales. Para la descripción de los campos, véase la » Documentación de Collation.

Si no se especifica el cotejamiento y la colección tiene un cotejamiento predeterminado, la operación usará el cotejamiento especificado por la colección. Si no se especifica el cotejamiento para la colección o para la operación, MongoDB usará la comparación binaria simple utilizada en versiones anteriores para comparar cadenas.

Esta opción está disponible en MongoDB 3.4+ y resultará en una excepción durante la ejecución si se especifica para una versión más antigua del servidor.

comment string

A comment to attach to the query to help interpret and trace query profile data.

Falls back to the deprecated "$comment" modifier if not specified.

exhaust bool

Stream the data down full blast in multiple "more" packages, on the assumption that the client will fully read all data queried. Faster when you are pulling a lot of data and know you want to pull it all down. Note: the client is not allowed to not read all the data unless it closes the connection.

This option is not supported by the find command in MongoDB 3.2+ and will force the driver to use the legacy wire protocol version (i.e. OP_QUERY).

explain bool

If true, the returned MongoDB\Driver\Cursor will contain a single document that describes the process and indexes used to return the query.

Falls back to the deprecated "$explain" modifier if not specified.

This option is not supported by the find command in MongoDB 3.2+ and will only be respected when using the legacy wire protocol version (i.e. OP_QUERY). The » explain command should be used on MongoDB 3.0+.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

Falls back to the deprecated "hint" option if not specified.

limit int

The maximum number of documents to return. If unspecified, then defaults to no limit. A limit of 0 is equivalent to setting no limit.

A negative limit is will be interpreted as a positive limit with the "singleBatch" option set to true. This behavior is supported for backwards compatibility, but should be considered deprecated.

max array|object

The exclusive upper bound for a specific index.

Falls back to the deprecated "$max" modifier if not specified.

maxAwaitTimeMS int

Positive integer denoting the time limit in milliseconds for the server to block a getMore operation if no data is available. This option should only be used in conjunction with the "tailable" and "awaitData" options.

maxScan int
Advertencia

This option is deprecated and should not be used.

Positive integer denoting the maximum number of documents or index keys to scan when executing the query.

Falls back to the deprecated "$maxScan" modifier if not specified.

maxTimeMS int

The cumulative time limit in milliseconds for processing operations on the cursor. MongoDB aborts the operation at the earliest following interrupt point.

Falls back to the deprecated "$maxTimeMS" modifier if not specified.

min array|object

The inclusive lower bound for a specific index.

Falls back to the deprecated "$min" modifier if not specified.

modifiers | array | » Meta operators modifying the output or behavior of a query. Use of these operators is deprecated in favor of named options.
noCursorTimeout | bool | Prevents the server from timing out idle cursors after an inactivity period (10 minutes).
oplogReplay bool

Internal use for replica sets. To use oplogReplay, you must include the following condition in the filter:

[ 'ts' => [ '$gte' => <timestamp> ] ]

Nota: This option is deprecated as of the 1.8.0 release.
projection array|object

The » projection specification to determine which fields to include in the returned documents.

If you are using the ODM functionality to deserialise documents as their original PHP class, make sure that you include the __pclass field in the projection. This is required for the deserialization to work and without it, the driver will return (by default) a stdClass object instead.

readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation. By default, the read concern from the MongoDB Connection URI will be used.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

returnKey bool

If true, returns only the index keys in the resulting documents. Default value is false. If true and the find command does not use an index, the returned documents will be empty.

Falls back to the deprecated "$returnKey" modifier if not specified.

showRecordId bool

Determines whether to return the record identifier for each document. If true, adds a top-level "$recordId" field to the returned documents.

Falls back to the deprecated "$showDiskLoc" modifier if not specified.

singleBatch | bool | Determines whether to close the cursor after the first batch. Defaults to false.
skip | int | Number of documents to skip. Defaults to 0.
slaveOk | bool | Allow query of replica set secondaries
snapshot bool
Advertencia

This option is deprecated and should not be used.

Prevents the cursor from returning a document more than once because of an intervening write operation.

Falls back to the deprecated "$snapshot" modifier if not specified.

sort array|object

The sort specification for the ordering of the results.

Falls back to the deprecated "$orderby" modifier if not specified.

tailable | bool | Returns a tailable cursor for a capped collection.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.8.0

Added the "allowDiskUse" option.

The "oplogReplay" option is deprecated.

PECL mongodb 1.5.0

The "maxScan" and "snapshot" options are deprecated.

PECL mongodb 1.3.0

Added the "maxAwaitTimeMS" option.

PECL mongodb 1.2.0

Added the "allowPartialResults", "collation", "comment", "hint", "max", "maxScan", "maxTimeMS", "min", "returnKey", "showRecordId", and "snapshot" options.

Renamed the "partial" option to "allowPartialResults". For backwards compatibility, "partial" will still be read if "allowPartialResults" is not specified.

Removed the "slaveOk" option, which is obsolete. For queries using the legacy wire protocol OP_QUERY, the driver will set the slaveOk bit as needed in accordance with the » Server Selection Specification.

PECL mongodb 1.1.0 | Added the "readConcern" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\Query::__construct() example

<?php
/* Select only documents authord by "bjori" with at least 100 views */
$filter = [
    'author' => 'bjori',
    'views' => [
        '$gte' => 100,
    ],
];

$options = [
    /* Only return the following fields in the matching documents */
    'projection' => [
        'title' => 1,
        'article' => 1,
    ],
    /* Return the documents in descending order of views */
    'sort' => [
        'views' => -1
    ],
];

$query = new MongoDB\Driver\Query($filter, $options);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$readPreference = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$cursor = $manager->executeQuery('databaseName.collectionName', $query, $readPreference);

foreach($cursor as $document) {
    var_dump($document);
}

?>

Ver también

  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Cursor


The MongoDB\Driver\BulkWrite class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\BulkWrite collects one or more write operations that should be sent to the server. After adding any number of insert, update, and delete operations, the collection may be executed via MongoDB\Driver\Manager::executeBulkWrite().

Write operations may either be ordered (default) or unordered. Ordered write operations are sent to the server, in the order provided, for serial execution. If a write fails, any remaining operations will be aborted. Unordered operations are sent to the server in an arbitrary order where they may be executed in parallel. Any errors that occur are reported after all operations have been attempted.

Sinopsis de la Clase

final MongoDB\Driver\BulkWrite implements Countable {
/* Métodos */
public __construct ( array $options = ? )
public count ( ) : int
public delete ( array|object $filter , array $deleteOptions = ? ) : void
public insert ( array|object $document ) : mixed
public update ( array|object $filter , array|object $newObj , array $updateOptions = ? ) : void
}

Ejemplos

Ejemplo #1 Mixed write operations are grouped by type

Mixed write operations (i.e. inserts, updates, and deletes) will be assembled into typed write commands to be sent sequentially to the server.

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->insert(['_id' => 3, 'x' => 3]);
$bulk->delete(['x' => 1]);

?>

Will result in four write commands (i.e. roundtrips) being executed. Since the operations are ordered, the third insertion cannot be sent until the preceding update is executed.

Ejemplo #2 Ordered write operations causing an error

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3, 'hello' => 'world']);
$bulk->update(['_id' => 3], ['$set' => ['hello' => 'earth']]);
$bulk->insert(['_id' => 4, 'hello' => 'pluto']);
$bulk->update(['_id' => 4], ['$set' => ['hello' => 'moon']]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 5]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());

?>

El resultado del ejemplo sería:

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If the write concern could not be fullfilled, the example above would output something like:

waiting for replication timed out (64): array (
  'wtimeout' => true,
)
Operation#7: E11000 duplicate key error index: databaseName.collectionName.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If we execute the example above, but allow for unordered writes:

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
/* ... */

?>

El resultado del ejemplo sería:

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Operation#8: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 4 } (11000)
Inserted 5 document(s)
Updated  2 document(s)

Ver también

  • MongoDB\Driver\Manager::executeBulkWrite()
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\WriteConcernError
  • MongoDB\Driver\WriteError

Tabla de contenidos

  • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
  • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
  • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
  • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
  • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk


Create a new BulkWrite

  • « MongoDB\Driver\BulkWrite
  • MongoDB\Driver\BulkWrite::count »
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Create a new BulkWrite

MongoDB\Driver\BulkWrite::__construct

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite

Descripción

public MongoDB\Driver\BulkWrite::__construct ( array $options = ? )

Constructs a new MongoDB\Driver\BulkWrite, which is a mutable object to which one or more write operations may be added. The write(s) may then be executed with MongoDB\Driver\Manager::executeBulkWrite().

Parámetros

options (array)

options
Option | Type | Description | Default
bypassDocumentValidation bool

If true, allows insert and update operations to circumvent document level validation.

This option is available in MongoDB 3.2+ and is ignored for older server versions, which do not support document level validation.

false
ordered | bool | Ordered operations (true) are executed serially on the MongoDB server, while unordered operations (false) are sent to the server in an arbitrary order and may be executed in parallel. | true

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.1.0 | Added the "bypassDocumentValidation" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\BulkWrite::__construct() example

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(
    ['x' => 2],
    ['$set' => ['x' => 1]],
    ['limit' => 1, 'upsert' => false]
);
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->update(
    ['_id' => 3],
    ['$set' => ['x' => 3]],
    ['limit' => 1, 'upsert' => true]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(1);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

?>

El resultado del ejemplo sería:

Inserted 2 document(s)
Updated  1 document(s)
Upserted 1 document(s)
Deleted  1 document(s)

Ver también

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


Count number of write operations in the bulk

  • « MongoDB\Driver\BulkWrite::__construct
  • MongoDB\Driver\BulkWrite::delete »
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Count number of write operations in the bulk

MongoDB\Driver\BulkWrite::count

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk

Descripción

public MongoDB\Driver\BulkWrite::count ( ) : int

Returns the number of write operations added to the MongoDB\Driver\BulkWrite object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns number of write operations added to the MongoDB\Driver\BulkWrite object.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.2.0 | Returns the number of write operations added to the MongoDB\Driver\BulkWrite object. Earlier versions returned the expected number of client-to-server roundtrips required to execute all write operations.

Ejemplos

Ejemplo #1 MongoDB\Driver\BulkWrite::count() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->delete(['x' => 1]);

var_dump(count($bulk));

?>

El resultado del ejemplo sería:

int(4)


Add a delete operation to the bulk

  • « MongoDB\Driver\BulkWrite::count
  • MongoDB\Driver\BulkWrite::insert »
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add a delete operation to the bulk

MongoDB\Driver\BulkWrite::delete

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk

Descripción

public MongoDB\Driver\BulkWrite::delete ( array|object $filter , array $deleteOptions = ? ) : void

Adds a delete operation to the MongoDB\Driver\BulkWrite.

Parámetros

filter (array|object)

El » predicado de la consulta. Un predicado vacío coincidirá con todos los documentos de una colección.

Nota: Al evaluar criterios de consulta, MongoDB compara tipos y valores según sus propias » reglas de comparación para tipos BSON, lo cual difiere de las reglas de comparación y manejo de tipos de PHP. Al encontrar un tipo BSON especial, los criterios de consulta deben utilizar la clase BSON respectiva (p.ej. usar MongoDB\BSON\ObjectID al encontrar un » ObjectID).

deleteOptions

deleteOptions
Option | Type | Description | Default
collation array|object

» Collation, o cotejamiento, permite a los usuarios especificar reglas específcas del lenguaje para comparar cadenas, tales como reglas para mayúsculas/minúsculas y marcas de acento. Cuando se especifica el cotejamiento, el cambpo "locale" es obligatorio; todos los demás campos de cotejamiento son opcionales. Para la descripción de los campos, véase la » Documentación de Collation.

Si no se especifica el cotejamiento y la colección tiene un cotejamiento predeterminado, la operación usará el cotejamiento especificado por la colección. Si no se especifica el cotejamiento para la colección o para la operación, MongoDB usará la comparación binaria simple utilizada en versiones anteriores para comparar cadenas.

Esta opción está disponible en MongoDB 3.4+ y resultará en una excepción durante la ejecución si se especifica para una versión más antigua del servidor.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

This option is available in MongoDB 4.4+ and will result in an exception at execution time if specified for an older server version.

limit | bool | Delete all matching documents (false), or only the first matching document (true) | false

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.8.0 | Added the "hint" option.
PECL mongodb 1.2.0 | Added the "collation" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\BulkWrite::delete() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->delete(['x' => 2], ['limit' => 0]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

Ver también

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


Add an insert operation to the bulk

  • « MongoDB\Driver\BulkWrite::delete
  • MongoDB\Driver\BulkWrite::update »
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add an insert operation to the bulk

MongoDB\Driver\BulkWrite::insert

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk

Descripción

public MongoDB\Driver\BulkWrite::insert ( array|object $document ) : mixed

Adds an insert operation to the MongoDB\Driver\BulkWrite.

Parámetros

document (array|object)

A document to insert.

Valores devueltos

Returns the _id of the inserted document. If the document did not have an _id, the MongoDB\BSON\ObjectId generated for the insert will be returned.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.3.0 | The _id of the inserted document is always returned. Previously, the method only returned a value if a MongoDB\BSON\ObjectId was generated.

Ejemplos

Ejemplo #1 MongoDB\Driver\BulkWrite::insert() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;

$document1 = ['title' => 'one'];
$document2 = ['_id' => 'custom ID', 'title' => 'two'];
$document3 = ['_id' => new MongoDB\BSON\ObjectId, 'title' => 'three'];

$_id1 = $bulk->insert($document1);
$_id2 = $bulk->insert($document2);
$_id3 = $bulk->insert($document3);

var_dump($_id1, $_id2, $_id3);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\BSON\ObjectId)#3 (1) {
  ["oid"]=>
  string(24) "54d51146bd21b91405401d92"
}
NULL
NULL

Ver también

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
  • MongoDB\BSON\ObjectId
  • MongoDB\BSON\Persistable


Add an update operation to the bulk

  • « MongoDB\Driver\BulkWrite::insert
  • MongoDB\Driver\WriteConcern »
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add an update operation to the bulk

MongoDB\Driver\BulkWrite::update

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk

Descripción

public MongoDB\Driver\BulkWrite::update ( array|object $filter , array|object $newObj , array $updateOptions = ? ) : void

Adds an update operation to the MongoDB\Driver\BulkWrite.

Parámetros

filter (array|object)

El » predicado de la consulta. Un predicado vacío coincidirá con todos los documentos de una colección.

Nota: Al evaluar criterios de consulta, MongoDB compara tipos y valores según sus propias » reglas de comparación para tipos BSON, lo cual difiere de las reglas de comparación y manejo de tipos de PHP. Al encontrar un tipo BSON especial, los criterios de consulta deben utilizar la clase BSON respectiva (p.ej. usar MongoDB\BSON\ObjectID al encontrar un » ObjectID).

newObj (array|object)

A document containing either update operators (e.g. $set), a replacement document (i.e. only field:value expressions), or an » aggregation pipeline.

updateOptions

updateOptions
Option | Type | Description | Default
arrayFilters array

An array of filter documents that determines which array elements to modify for an update operation on an array field. See » Specify arrayFilters for Array Update Operations in the MongoDB manual for more information.

This option is available in MongoDB 3.6+ and will result in an exception at execution time if specified for an older server version.

collation array|object

» Collation, o cotejamiento, permite a los usuarios especificar reglas específcas del lenguaje para comparar cadenas, tales como reglas para mayúsculas/minúsculas y marcas de acento. Cuando se especifica el cotejamiento, el cambpo "locale" es obligatorio; todos los demás campos de cotejamiento son opcionales. Para la descripción de los campos, véase la » Documentación de Collation.

Si no se especifica el cotejamiento y la colección tiene un cotejamiento predeterminado, la operación usará el cotejamiento especificado por la colección. Si no se especifica el cotejamiento para la colección o para la operación, MongoDB usará la comparación binaria simple utilizada en versiones anteriores para comparar cadenas.

Esta opción está disponible en MongoDB 3.4+ y resultará en una excepción durante la ejecución si se especifica para una versión más antigua del servidor.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

This option is available in MongoDB 4.2+ and will result in an exception at execution time if specified for an older server version.

multi | bool | Update only the first matching document if false, or all matching documents true. This option cannot be true if newObj is a replacement document. | false
upsert | bool | If filter does not match an existing document, insert a single document. The document will be created from newObj if it is a replacement document (i.e. no update operators); otherwise, the operators in newObj will be applied to filter to create the new document. | false

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | Added the "hint" option.
PECL mongodb 1.6.0 | The newObj parameter now accepts an aggregation pipeline. This feature requires MongoDB 4.2+ and will result in an exception at execution time if specified for an older server version.
PECL mongodb 1.5.0 | Using the "arrayFilters" option will result in an exception at execution time if unsupported by the server. Previously, no exception would be thrown and the option may have been ignored.
PECL mongodb 1.4.0 | Added the "arrayFilters" option.
PECL mongodb 1.2.0 | Added the "collation" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\BulkWrite::update() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->update(
    ['x' => 2],
    ['$set' => ['y' => 3]],
    ['multi' => false, 'upsert' => false]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

Ver también

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


The MongoDB\Driver\WriteConcern class

(mongodb >=1.0.0)

Introducción

MongoDB\Driver\WriteConcern describes the level of acknowledgement requested from MongoDB for write operations to a standalone mongod or to replica sets or to sharded clusters. In sharded clusters, mongos instances will pass the write concern on to the shards.

Sinopsis de la Clase

final MongoDB\Driver\WriteConcern implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const string MAJORITY = "majority" ;
/* Métodos */
final public bsonSerialize ( ) : object
final public __construct ( string|int $w , int $wtimeout = ? , bool $journal = ? )
final public getJournal ( ) : bool|null
final public getW ( ) : string|int|null
final public getWtimeout ( ) : int|MongoDB\BSON\Int64
final public isDefault ( ) : bool
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

Constantes predefinidas

MongoDB\Driver\WriteConcern::MAJORITY

Majority of all the members in the set; arbiters, non-voting members, passive members, hidden members and delayed members are all included in the definition of majority write concern.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | Implements Serializable.
PECL mongodb 1.2.0 | Implements MongoDB\BSON\Serializable.

Tabla de contenidos

  • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern
  • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
  • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
  • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
  • MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern
  • MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern
  • MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern


Returns an object for BSON serialization

  • « MongoDB\Driver\WriteConcern
  • MongoDB\Driver\WriteConcern::__construct »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns an object for BSON serialization

MongoDB\Driver\WriteConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization

Descripción

final public MongoDB\Driver\WriteConcern::bsonSerialize ( ) : object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an object for serializing the WriteConcern as BSON.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::bsonSerialize() with majority write concern

<?php

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (1) {
  ["w"]=>
  string(8) "majority"
}

{ "w" : "majority" }

Ejemplo #2 MongoDB\Driver\WriteConcern::bsonSerialize() with wtimeout and journal

<?php

$wc = new MongoDB\Driver\WriteConcern(2, 1000, true);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (3) {
  ["w"]=>
  int(2)
  ["j"]=>
  bool(true)
  ["wtimeout"]=>
  int(1000)
}

{ "w" : 2, "j" : true, "wtimeout" : 1000 }

Ver también

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Write Concern reference


Create a new WriteConcern

  • « MongoDB\Driver\WriteConcern::bsonSerialize
  • MongoDB\Driver\WriteConcern::getJournal »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Create a new WriteConcern

MongoDB\Driver\WriteConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern

Descripción

final public MongoDB\Driver\WriteConcern::__construct ( string|int $w , int $wtimeout = ? , bool $journal = ? )

Constructs a new MongoDB\Driver\WriteConcern, which is an immutable value object.

Parámetros

w

Write concern
Value | Description
1 | Requests acknowledgement that the write operation has propagated to the standalone mongod or the primary in a replica set. This is the default write concern for MongoDB.
0 | Requests no acknowledgment of the write operation. However, this may return information about socket exceptions and networking errors to the application.
<integer greater than 1> | Numbers greater than 1 are valid only for replica sets to request acknowledgement from specified number of members, including the primary.
MongoDB\Driver\WriteConcern::MAJORITY

Requests acknowledgment that write operations have propagated to the majority of voting nodes, including the primary, and have been written to the on-disk journal for these nodes.

Prior to MongoDB 3.0, this refers to the majority of replica set members (not just voting nodes).

string | A string value is interpereted as a tag set. Requests acknowledgement that the write operations have propagated to a replica set member with the specified tag.

wtimeout

How long to wait (in milliseconds) for secondaries before failing.

wtimeout causes write operations to return with an error (WriteConcernError) after the specified limit, even if the required write concern will eventually succeed. When these write operations return, MongoDB does not undo successful data modifications performed before the write concern exceeded the wtimeout time limit.

If specified, wtimeout must be a signed 64-bit integer greater than or equal to zero.

Write concern timeout
Value | Description
0 | Block indefinitely. This is the default.
<integer greater than 0> | Milliseconds to wait until returning.

journal

Wait until mongod has applied the write to the journal.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if w is invalid or wtimeout is either negative or greater than the bounds of a signed 32-bit integer.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | The wTimeout parameter now accepts 64-bit values.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::__construct() example

<?php

/* Request write acknowledgement from the majority of the replica set nodes */
$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 500);

/* Request write acknowledgement from a node configured with the "MultipleDC" tag */
$wc = new MongoDB\Driver\WriteConcern("MultipleDC", 500);

?>

Ver también

  • » Write Concern reference


Returns the WriteConcern's "journal" option

  • « MongoDB\Driver\WriteConcern::__construct
  • MongoDB\Driver\WriteConcern::getW »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "journal" option

MongoDB\Driver\WriteConcern::getJournal

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option

Descripción

final public MongoDB\Driver\WriteConcern::getJournal ( ) : bool|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteConcern's "journal" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::getJournal() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, true);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, false);
var_dump($wc->getJournal());

?>

El resultado del ejemplo sería:

NULL
bool(true)
bool(false)

Ver también

  • » Write Concern reference


Returns the WriteConcern's "w" option

  • « MongoDB\Driver\WriteConcern::getJournal
  • MongoDB\Driver\WriteConcern::getWtimeout »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "w" option

MongoDB\Driver\WriteConcern::getW

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option

Descripción

final public MongoDB\Driver\WriteConcern::getW ( ) : string|int|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteConcern's "w" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::getW() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getW());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->getW());

?>

El resultado del ejemplo sería:

int(1)
string(8) "majority"

Ver también

  • » Write Concern reference


Returns the WriteConcern's "wtimeout" option

  • « MongoDB\Driver\WriteConcern::getW
  • MongoDB\Driver\WriteConcern::isDefault »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "wtimeout" option

MongoDB\Driver\WriteConcern::getWtimeout

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option

Descripción

final public MongoDB\Driver\WriteConcern::getWtimeout ( ) : int|MongoDB\BSON\Int64

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteConcern's "wtimeout" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | On 32-bit systems, this method will return a MongoDB\BSON\Int64 instance if the WriteConcern object was created with a wTimeout that exceeds the 32-bit range. On 64-bit systems, this method will always return an integer value.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::getWtimeout() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getWtimeout());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 3000);
var_dump($wc->getWtimeout());

?>

El resultado del ejemplo sería:

int(0)
int(3000)

Ver también

  • » Write Concern reference


Checks if this is the default write concern

  • « MongoDB\Driver\WriteConcern::getWtimeout
  • MongoDB\Driver\WriteConcern::serialize »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Checks if this is the default write concern

MongoDB\Driver\WriteConcern::isDefault

(mongodb >=1.3.0)

MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern

Descripción

final public MongoDB\Driver\WriteConcern::isDefault ( ) : bool

Returns whether this is the default write concern (i.e. no options are specified). This method is primarily intended to be used in conjunction with MongoDB\Driver\Manager::getWriteConcern() to determine whether the Manager has been constructed without any write concern options.

The driver will not include a default write concern in its write operations (e.g. MongoDB\Driver\Manager::executeBulkWrite()) in order to allow the server to apply its own default, which may have been » modified. Libraries that access the Manager's write concern to include it in their own write commands should use this method to ensure that default write concerns are left unset.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this is the default write concern and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcern::isDefault() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/?w=majority');
$wc = $manager->getWriteConcern();
var_dump($wc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/');
$wc = $manager->getWriteConcern();
var_dump($wc->isDefault());

?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(true)

Ver también

  • MongoDB\Driver\Manager::getWriteConcern() - Return the WriteConcern for the Manager
  • » Modify Default Write Concern in the MongoDB manual
  • » Write Concern reference


Serialize a WriteConcern

  • « MongoDB\Driver\WriteConcern::isDefault
  • MongoDB\Driver\WriteConcern::unserialize »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Serialize a WriteConcern

MongoDB\Driver\WriteConcern::serialize

(mongodb >=1.7.0)

MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern

Descripción

final public MongoDB\Driver\WriteConcern::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\Driver\WriteConcern.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\WriteConcern::unserialize() - Unserialize a WriteConcern
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Unserialize a WriteConcern

  • « MongoDB\Driver\WriteConcern::serialize
  • MongoDB\Driver\ReadPreference »
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Unserialize a WriteConcern

MongoDB\Driver\WriteConcern::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern

Descripción

final public MongoDB\Driver\WriteConcern::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\Driver\WriteConcern.

Valores devueltos

Returns the unserialized MongoDB\Driver\WriteConcern.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\Driver\WriteConcern::serialize() - Serialize a WriteConcern
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


The MongoDB\Driver\ReadPreference class

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

final MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const int RP_PRIMARY = 1 ;
const int RP_PRIMARY_PREFERRED = 5 ;
const int RP_SECONDARY = 2 ;
const int RP_SECONDARY_PREFERRED = 6 ;
const int RP_NEAREST = 10 ;
const string PRIMARY = primary ;
const string PRIMARY_PREFERRED = primaryPreferred ;
const string SECONDARY = secondary ;
const string SECONDARY_PREFERRED = secondaryPreferred ;
const string NEAREST = nearest ;
const int NO_MAX_STALENESS = -1 ;
const int SMALLEST_MAX_STALENESS_SECONDS = 90 ;
/* Métodos */
final public bsonSerialize ( ) : object
final public __construct ( string|int $mode , array $tagSets = null , array $options = array() )
final public getHedge ( ) : object|null
final public getMaxStalenessSeconds ( ) : int
final public getMode ( ) : int
final public getModeString ( ) : string
final public getTagSets ( ) : array
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

Constantes predefinidas

MongoDB\Driver\ReadPreference::RP_PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

MongoDB\Driver\ReadPreference::PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

MongoDB\Driver\ReadPreference::NO_MAX_STALENESS

The default value for the "maxStalenessSeconds" option is to specify no limit on maximum staleness, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS

The minimum value for the "maxStalenessSeconds" option is 90 seconds. The driver estimates secondaries' staleness by periodically checking the latest write date of each replica set member. Since these checks are infrequent, the staleness estimate is coarse. Thus, the driver cannot enforce a max staleness value of less than 90 seconds.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | Added the MongoDB\Driver\ReadPreference::PRIMARY, MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED, MongoDB\Driver\ReadPreference::SECONDARY, MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED, MongoDB\Driver\ReadPreference::NEAREST constants. Implements Serializable.
PECL mongodb 1.2.0 | Added the MongoDB\Driver\ReadPreference::NO_MAX_STALENESS and MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS constants. Implements MongoDB\BSON\Serializable.

Tabla de contenidos

  • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference
  • MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option
  • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
  • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
  • MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string
  • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
  • MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference
  • MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference


Returns an object for BSON serialization

  • « MongoDB\Driver\ReadPreference
  • MongoDB\Driver\ReadPreference::__construct »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns an object for BSON serialization

MongoDB\Driver\ReadPreference::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization

Descripción

final public MongoDB\Driver\ReadPreference::bsonSerialize ( ) : object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an object for serializing the ReadPreference as BSON.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::bsonSerialize() with primary read preference

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}

{ "mode" : "primary" }

Ejemplo #2 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and tag sets

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    [
        ['dc' => 'ny'],
        ['dc' => 'sf', 'use' => 'reporting'],
        []
    ]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#1 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [1]=>
    object(stdClass)#5 (2) {
      ["dc"]=>
      string(2) "sf"
      ["use"]=>
      string(9) "reporting"
    }
    [2]=>
    object(stdClass)#4 (0) {
    }
  }
}

{ "mode" : "secondary", "tags" : [ { "dc" : "ny" }, { "dc" : "sf", "use" : "reporting" }, {  } ] }

Ejemplo #3 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and max staleness

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    null,
    ['maxStalenessSeconds' => 120]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}

{ "mode" : "secondary", "maxStalenessSeconds" : 120 }

Ver también

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Preference reference


Create a new ReadPreference

  • « MongoDB\Driver\ReadPreference::bsonSerialize
  • MongoDB\Driver\ReadPreference::getHedge »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Create a new ReadPreference

MongoDB\Driver\ReadPreference::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference

Descripción

final public MongoDB\Driver\ReadPreference::__construct ( string|int $mode , array $tagSets = null , array $options = array() )

Constructs a new MongoDB\Driver\ReadPreference, which is an immutable value object.

Parámetros

mode

Read preference mode
Value Description
MongoDB\Driver\ReadPreference::RP_PRIMARY or "primary"

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED or "primaryPreferred"

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY or "secondary"

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED or "secondaryPreferred"

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST or "nearest"

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

tagSets

Tag sets allow you to target read operations to specific members of a replica set. This parameter should be an array of associative arrays, each of which contain zero or more key/value pairs. When selecting a server for a read operation, the driver attempt to select a node having all tags in a set (i.e. the associative array of key/value pairs). If selection fails, the driver will attempt subsequent sets. An empty tag set (array()) will match any node and may be used as a fallback.

Tags are not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode and, in general, only apply when selecting a secondary member of a set for a read operation. However, the MongoDB\Driver\ReadPreference::RP_NEAREST mode, when combined with a tag set, selects the matching member with the lowest network latency. This member may be a primary or secondary.

options

options
Option Type Description
hedge object|array

Specifies whether to use » hedged reads, which are supported by MongoDB 4.4+ for sharded queries.

Server hedged reads are available for all non-primary read preferences and are enabled by default when using the "nearest" mode. This option allows explicitly enabling server hedged reads for non-primary read preferences by specifying ['enabled' => true], or explicitly disabling server hedged reads for the "nearest" read preference by specifying ['enabled' => false].

maxStalenessSeconds int

Specifies a maximum replication lag, or "staleness", for reads from secondaries. When a secondary's estimated staleness exceeds this value, the driver stops using it for read operations.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS.

Defaults to MongoDB\Driver\ReadPreference::NO_MAX_STALENESS, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

This option is not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode. Specifying a max staleness also requires all MongoDB instances in the deployment to be using MongoDB 3.4+. An exception will be thrown at execution time if any MongoDB instances in the deployment are of an older server version.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if mode is invalid.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if tagSets is provided for a primary read preference or is malformed (i.e. not an array of zero or more documents).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "maxStalenessSeconds" option is provided for a primary read preference or is out of range.

Historial de cambios

Versión | Descripción
PECL mongodb 1.8.0 | Added the "hedge" option.
PECL mongodb 1.3.0 | The mode argument now accepts a string value, which is consistent with the "readPreference" URI option for MongoDB\Driver\Manager::__construct().
PECL mongodb 1.2.0 | Added a third options argument, which supports the "maxStalenessSeconds" option.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::__construct() example

<?php

/* Prefer a secondary node but fall back to a primary. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED));

/* Prefer a node in the New York data center with lowest latency. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST, [['dc' => 'ny']]));

/* Require a secondary node whose replication lag is within two minutes of the primary */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, ['maxStalenessSeconds' => 120]));

/* Explicitly enable server hedged reads */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, ['hedge' => ['enabled' => true]]));

?>

El resultado del ejemplo sería:

object(MongoDB\Driver\ReadPreference)#1 (1) {
  ["mode"]=>
  string(18) "secondaryPreferred"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(7) "nearest"
  ["tags"]=>
  array(1) {
    [0]=>
    object(stdClass)#2 (1) {
      ["dc"]=>
      string(2) "ny"
    }
  }
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["hedge"]=>
  object(stdClass)#1 (1) {
    ["enabled"]=>
    bool(true)
  }
}

Ver también

  • » Read Preference reference


Returns the ReadPreference's "hedge" option

  • « MongoDB\Driver\ReadPreference::__construct
  • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "hedge" option

MongoDB\Driver\ReadPreference::getHedge

(mongodb >=1.8.0)

MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option

Descripción

final public MongoDB\Driver\ReadPreference::getHedge ( ) : object|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadPreference's "hedge" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • » Read Preference reference


Returns the ReadPreference's "maxStalenessSeconds" option

  • « MongoDB\Driver\ReadPreference::getHedge
  • MongoDB\Driver\ReadPreference::getMode »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "maxStalenessSeconds" option

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option

Descripción

final public MongoDB\Driver\ReadPreference::getMaxStalenessSeconds ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadPreference's "maxStalenessSeconds" option. If no max staleness has been specified, MongoDB\Driver\ReadPreference::NO_MAX_STALENESS will be returned.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::getMaxStalenessSeconds() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::NO_MAX_STALENESS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => 1000,
]);
var_dump($rp->getMaxStalenessSeconds());

?>

El resultado del ejemplo sería:

int(-1)
int(-1)
int(90)
int(1000)

Ver también

  • » Read Preference reference


Returns the ReadPreference's "mode" option

  • « MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
  • MongoDB\Driver\ReadPreference::getModeString »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "mode" option

MongoDB\Driver\ReadPreference::getMode

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option

Descripción

final public MongoDB\Driver\ReadPreference::getMode ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadPreference's "mode" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::getMode() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST);
var_dump($rp->getMode());

?>

El resultado del ejemplo sería:

int(1)
int(5)
int(2)
int(6)
int(10)

Ver también

  • MongoDB\Driver\ReadPreference::getModeString() - Returns the ReadPreference's "mode" option as a string
  • » Read Preference reference


Returns the ReadPreference's "mode" option as a string

  • « MongoDB\Driver\ReadPreference::getMode
  • MongoDB\Driver\ReadPreference::getTagSets »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "mode" option as a string

MongoDB\Driver\ReadPreference::getModeString

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string

Descripción

final public MongoDB\Driver\ReadPreference::getModeString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadPreference's "mode" option as a string.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::getModeString() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::PRIMARY);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::SECONDARY);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::NEAREST);
var_dump($rp->getModeString());

?>

El resultado del ejemplo sería:

string(7) "primary"
string(16) "primaryPreferred"
string(9) "secondary"
string(18) "secondaryPreferred"
string(7) "nearest"

Ver también

  • MongoDB\Driver\ReadPreference::getMode() - Returns the ReadPreference's "mode" option
  • » Read Preference reference


Returns the ReadPreference's "tagSets" option

  • « MongoDB\Driver\ReadPreference::getModeString
  • MongoDB\Driver\ReadPreference::serialize »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "tagSets" option

MongoDB\Driver\ReadPreference::getTagSets

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option

Descripción

final public MongoDB\Driver\ReadPreference::getTagSets ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadPreference's "tagSets" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadPreference::getTagSets() example

<?php

$mode = MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED;

/* Null and an empty array both denote no tag set preference. */
$rp = new MongoDB\Driver\ReadPreference($mode, null);
var_dump($rp->getTagSets());

$rp = new MongoDB\Driver\ReadPreference($mode, []);
var_dump($rp->getTagSets());

/* Prefer a node in New York, but fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [['dc' => 'ny']]);
var_dump($rp->getTagSets());

/* Prefer a node in the New York, followed by a node in San Francisco that is
   labeled for reporting usage, and finally fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [
  ['dc' => 'ny'],
  ['dc' => 'sf', 'use' => 'reporting'],
  [],
]);
var_dump($rp->getTagSets());

?>

El resultado del ejemplo sería:

array(0) {
}
array(0) {
}
array(2) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(0) {
  }
}
array(3) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(2) {
    ["dc"]=>
    string(2) "sf"
    ["use"]=>
    string(9) "reporting"
  }
  [2]=>
  array(0) {
  }
}

Ver también

  • » Read Preference reference


Serialize a ReadPreference

  • « MongoDB\Driver\ReadPreference::getTagSets
  • MongoDB\Driver\ReadPreference::unserialize »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Serialize a ReadPreference

MongoDB\Driver\ReadPreference::serialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference

Descripción

final public MongoDB\Driver\ReadPreference::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\Driver\ReadPreference.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\ReadPreference::unserialize() - Unserialize a ReadPreference
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Unserialize a ReadPreference

  • « MongoDB\Driver\ReadPreference::serialize
  • MongoDB\Driver\ReadConcern »
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Unserialize a ReadPreference

MongoDB\Driver\ReadPreference::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference

Descripción

final public MongoDB\Driver\ReadPreference::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\Driver\ReadPreference.

Valores devueltos

Returns the unserialized MongoDB\Driver\ReadPreference.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\Driver\ReadPreference::serialize() - Serialize a ReadPreference
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


The MongoDB\Driver\ReadConcern class

(mongodb >=1.1.0)

Introducción

MongoDB\Driver\ReadConcern controls the level of isolation for read operations for replica sets and replica set shards. This option requires MongoDB 3.2 or later.

Sinopsis de la Clase

final MongoDB\Driver\ReadConcern implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const string AVAILABLE = "available" ;
const string LINEARIZABLE = "linearizable" ;
const string LOCAL = "local" ;
const string MAJORITY = "majority" ;
/* Métodos */
final public bsonSerialize ( ) : object
final public __construct ( string $level = ? )
final public getLevel ( ) : string|null
final public isDefault ( ) : bool
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

Constantes predefinidas

MongoDB\Driver\ReadConcern::AVAILABLE

Default for reads against secondaries when afterClusterTimeand level are unspecified.

The query returns the instance's most recent data. Provides no guarantee that the data has been written to a majority of the replica set members (i.e. may be rolled back).

For unsharded collections (including collections in a standalone deployment or a replica set deployment), "local" and "available" read concerns behave identically.

For a sharded cluster, "available" read concern provides greater tolerance for partitions since it does not wait to ensure consistency guarantees. However, a query with "available" read concern may return orphan documents if the shard is undergoing chunk migrations since the "available" read concern, unlike "local" read concern, does not contact the shard's primary nor the config servers for updated metadata.

MongoDB\Driver\ReadConcern::LINEARIZABLE

The query returns data that reflects all successful writes issued with a write concern of "majority" and acknowledged prior to the start of the read operation. For replica sets that run with writeConcernMajorityJournalDefault set to true, linearizable read concern returns data that will never be rolled back.

With writeConcernMajorityJournalDefault set to false, MongoDB will not wait for w: "majority" writes to be durable before acknowledging the writes. As such, "majority" write operations could possibly roll back in the event of a loss of a replica set member.

You can specify linearizable read concern for read operations on the primary only.

Linearizable read concern guarantees only apply if read operations specify a query filter that uniquely identifies a single document.

Sugerencia

Always use maxTimeMS with linearizable read concern in case a majority of data bearing members are unavailable. maxTimeMS ensures that the operation does not block indefinitely and instead ensures that the operation returns an error if the read concern cannot be fulfilled.

Linearizable read concern requires MongoDB 3.4.

MongoDB\Driver\ReadConcern::LOCAL

Default for reads against primary if level is unspecified and for reads against secondaries if level is unspecified but afterClusterTime is specified.

The query returns the instance's most recent data. Provides no guarantee that the data has been written to a majority of the replica set members (i.e. may be rolled back).

MongoDB\Driver\ReadConcern::MAJORITY

The query returns the instance's most recent data acknowledged as having been written to a majority of members in the replica set.

To use read concern level of "majority", replica sets must use WiredTiger storage engine and election protocol version 1.

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | Implements Serializable.
PECL mongodb 1.4.0 | Added the MongoDB\Driver\ReadConcern::AVAILABLE constant.
PECL mongodb 1.2.0 | Added the MongoDB\Driver\ReadConcern::LINEARIZABLE constant. Implements MongoDB\BSON\Serializable.

Ver también

  • » Read Concern reference

Tabla de contenidos

  • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern
  • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
  • MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern
  • MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern
  • MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern


Returns an object for BSON serialization

  • « MongoDB\Driver\ReadConcern
  • MongoDB\Driver\ReadConcern::__construct »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Returns an object for BSON serialization

MongoDB\Driver\ReadConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization

Descripción

final public MongoDB\Driver\ReadConcern::bsonSerialize ( ) : object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an object for serializing the ReadConcern as BSON.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadConcern::bsonSerialize() with empty read concern

<?php

$rc = new MongoDB\Driver\ReadConcern;
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (0) {
}

{ }

Ejemplo #2 MongoDB\Driver\ReadConcern::bsonSerialize() with local read concern

<?php

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (1) {
  ["level"]=>
  string(5) "local"
}

{ "level" : "local" }

Ver también

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Concern reference


Create a new ReadConcern

  • « MongoDB\Driver\ReadConcern::bsonSerialize
  • MongoDB\Driver\ReadConcern::getLevel »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Create a new ReadConcern

MongoDB\Driver\ReadConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern

Descripción

final public MongoDB\Driver\ReadConcern::__construct ( string $level = ? )

Constructs a new MongoDB\Driver\ReadConcern, which is an immutable value object.

Parámetros

level

The » read concern level. You may use, but are not limited to, one of the class constants.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadConcern::__construct() example

<?php

/* Unspecified read isolation level (uses the server's default behavior) */
$rc = new MongoDB\Driver\ReadConcern();

/* Request read isolation from a single replica set node */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);

/* Request read isolation from a majority of the replica set nodes */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);

?>

Ver también

  • » Read Concern reference


Returns the ReadConcern's "level" option

  • « MongoDB\Driver\ReadConcern::__construct
  • MongoDB\Driver\ReadConcern::isDefault »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Returns the ReadConcern's "level" option

MongoDB\Driver\ReadConcern::getLevel

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option

Descripción

final public MongoDB\Driver\ReadConcern::getLevel ( ) : string|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the ReadConcern's "level" option.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadConcern::getLevel() example

<?php

$rc = new MongoDB\Driver\ReadConcern();
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);
var_dump($rc->getLevel());

?>

El resultado del ejemplo sería:

NULL
string(5) "local"
string(8) "majority"

Ver también

  • » Read Concern reference


Checks if this is the default read concern

  • « MongoDB\Driver\ReadConcern::getLevel
  • MongoDB\Driver\ReadConcern::serialize »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Checks if this is the default read concern

MongoDB\Driver\ReadConcern::isDefault

(mongodb >=1.3.0)

MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern

Descripción

final public MongoDB\Driver\ReadConcern::isDefault ( ) : bool

Returns whether this is the default read concern (i.e. no options are specified). This method is primarily intended to be used in conjunction with MongoDB\Driver\Manager::getReadConcern() to determine whether the Manager has been constructed without any read concern options.

The driver will not include a default read concern in its read operations (e.g. MongoDB\Driver\Manager::executeQuery()) in order order to allow the server to apply its own default. Libraries that access the Manager's read concern to include it in their own read commands should use this method to ensure that default read concerns are left unset.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this is the default read concern and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\ReadConcern::isDefault() example

<?php

$rc = new MongoDB\Driver\ReadConcern(null);
var_dump($rc->isDefault());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);
var_dump($rc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/?readConcernLevel=majority');
$rc = $manager->getReadConcern();
var_dump($rc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/');
$rc = $manager->getReadConcern();
var_dump($rc->isDefault());

?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)
bool(true)

Ver también

  • MongoDB\Driver\Manager::getReadConcern() - Return the ReadConcern for the Manager
  • » Read Concern reference


Serialize a ReadConcern

  • « MongoDB\Driver\ReadConcern::isDefault
  • MongoDB\Driver\ReadConcern::unserialize »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Serialize a ReadConcern

MongoDB\Driver\ReadConcern::serialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern

Descripción

final public MongoDB\Driver\ReadConcern::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\Driver\ReadConcern.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\ReadConcern::unserialize() - Unserialize a ReadConcern
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Unserialize a ReadConcern

  • « MongoDB\Driver\ReadConcern::serialize
  • MongoDB\Driver\Cursor »
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Unserialize a ReadConcern

MongoDB\Driver\ReadConcern::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern

Descripción

final public MongoDB\Driver\ReadConcern::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\Driver\ReadConcern.

Valores devueltos

Returns the unserialized MongoDB\Driver\ReadConcern.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\Driver\ReadConcern::serialize() - Serialize a ReadConcern
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


The MongoDB\Driver\Cursor class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\Cursor class encapsulates the results of a MongoDB command or query and may be returned by MongoDB\Driver\Manager::executeCommand() or MongoDB\Driver\Manager::executeQuery(), respectively.

Sinopsis de la Clase

final MongoDB\Driver\Cursor implements MongoDB\Driver\CursorInterface , Iterator {
/* Métodos */
final private __construct ( )
public current ( ) : array|object
final public getId ( ) : MongoDB\Driver\CursorId
final public getServer ( ) : MongoDB\Driver\Server
final public isDead ( ) : bool
public key ( ) : int
public next ( ) : void
public rewind ( ) : void
final public setTypeMap ( array $typemap ) : void
final public toArray ( ) : array
public valid ( ) : bool
}

Historial de cambios

Versión | Descripción
PECL mongodb 1.9.0 | Implements Iterator.
PECL mongodb 1.6.0 | Implements MongoDB\Driver\CursorInterface, which extends Traversable.

Ejemplos

Ejemplo #1 Reading a result set

MongoDB\Driver\Manager::executeCommand() and MongoDB\Driver\Manager::executeQuery() both return their result(s) as a MongoDB\Driver\Cursor object. This object can be used to iterate over the result set of the command or query.

Because MongoDB\Driver\Cursor implements the Traversable interface, you can simply iterate over the result set with foreach.

<?php

$manager = new MongoDB\Driver\Manager();

/* Insert some documents so that our query returns information */
$bulkWrite = new MongoDB\Driver\BulkWrite;
$bulkWrite->insert(['name' => 'Ceres', 'size' => 946, 'distance' => 2.766]);
$bulkWrite->insert(['name' => 'Vesta', 'size' => 525, 'distance' => 2.362]);
$manager->executeBulkWrite("test.asteroids", $bulkWrite);

/* Query for all the items in the collection */
$query = new MongoDB\Driver\Query( [] );

/* Query the "asteroids" collection of the "test" database */
$cursor = $manager->executeQuery("test.asteroids", $query);

/* $cursor now contains an object that wraps around the result set. Use
 * foreach() to iterate over all the result */
foreach($cursor as $document) {
    print_r($document);
}

?>

El resultado del ejemplo sería algo similar a:

stdClass Object
(
    [_id] => MongoDB\BSON\ObjectId Object
        (
            [oid] => 5a4cff2f122d3321565d8cc2
        )

    [name] => Ceres
    [size] => 946
    [distance] => 2.766
)
stdClass Object
(
    [_id] => MongoDB\BSON\ObjectId Object
        (
            [oid] => 5a4cff2f122d3321565d8cc3
        )

    [name] => Vesta
    [size] => 525
    [distance] => 2.362
}

Ejemplo #2 Reading a result set for a tailable cursor

» Tailable cursors are a special type of MongoDB cursor that allows the client to read some results and then wait until more documents become available. These cursors are primarily used with » Capped Collections and » Change Streams.

While normal cursors can be iterated once with foreach, that approach will not work with tailable cursors. When foreach is used with a tailable cursor, the loop will stop upon reaching the end of the initial result set. Attempting to continue iteration on the cursor with a second foreach would throw an exception, since PHP attempts to rewind the cursor. Similar to result objects in other database drivers, cursors in MongoDB only support forward iteration, which means they cannot be rewound.

In order to continuously read from a tailable cursor, the Cursor object must be wrapped with an IteratorIterator. This allows the application to directly control the cursor's iteration, avoid inadvertently rewinding the cursor, and decide when to wait for new results or stop iteration entirely.

In order to demonstrate a tailable cursor in action, two scripts will be used: a "producer" and a "consumer". The producer script will create a new capped collection using the » create command and proceed to insert a new document into that collection each second.

<?php

$manager = new MongoDB\Driver\Manager;

$manager->executeCommand('test', new MongoDB\Driver\Command([
    'create' => 'asteroids',
    'capped' => true,
    'size' => 1048576,
]));

while (true) {
    $bulkWrite = new MongoDB\Driver\BulkWrite;
    $bulkWrite->insert(['createdAt' => new MongoDB\BSON\UTCDateTime]);
    $manager->executeBulkWrite('test.asteroids', $bulkWrite);

    sleep(1);
}

?>

With the producer script still running, a second consumer script may be executed to read the inserted documents using a tailable cursor, indicated by the tailable and awaitData options to MongoDB\Driver\Query::__construct().

<?php

$manager = new MongoDB\Driver\Manager;

$query = new MongoDB\Driver\Query([], [
    'tailable' => true,
    'awaitData' => true,
]);

$cursor = $manager->executeQuery('test.asteroids', $query);

$iterator = new IteratorIterator($cursor);

$iterator->rewind();

while (true) {
    if ($iterator->valid()) {
        $document = $iterator->current();
        printf("Consumed document created at: %s\n", $document->createdAt);
    }

    $iterator->next();
}

?>

The consumer script will start by quickly printing all available documents in the capped collection (as if foreach had been used); however, it will not terminate upon reaching the end of the initial result set. Since the cursor is tailable, calling IteratorIterator::next() will block and wait for additional results. IteratorIterator::valid() is also used to check if there is actually data available to read at each step.

Nota: This example uses the awaitData query option to instruct the server to block for a short period (e.g. one second) at the end of the result set before returning a response to the driver. This is used to prevent the driver from aggressively polling the server when there are no results available. The maxAwaitTimeMS option may be used in conjunction with tailable and awaitData to specify the amount of time that the server should block when it reaches the end of the result set.

Errores/Excepciones

When iterating over the cursor object, BSON data is converted into PHP variables. This iteration can cause the following Exceptions:

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.
  • Lanza una MongoDB\Driver\Exception\UnexpectedValueException si la entrada no contiene exactamente un documento BSON. Las posibles razones incluyen, pero no están limitadas a, BSON no válido, datos extra (tras leer el documento BSON), o un error » libbson no esperado.

Tabla de contenidos

  • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
  • MongoDB\Driver\Cursor::current — Returns the current element
  • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
  • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
  • MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results
  • MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor
  • MongoDB\Driver\Cursor::next — Advances the cursor to the next result
  • MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result
  • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
  • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
  • MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid


Create a new Cursor (not used)

  • « MongoDB\Driver\Cursor
  • MongoDB\Driver\Cursor::current »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Create a new Cursor (not used)

MongoDB\Driver\Cursor::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)

Descripción

final private MongoDB\Driver\Cursor::__construct ( )

MongoDB\Driver\Cursor objects are returned as the result of an executed command or query and cannot be constructed directly.

Parámetros

Esta función no tiene parámetros.

Ver también

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server


Returns the current element

  • « MongoDB\Driver\Cursor::__construct
  • MongoDB\Driver\Cursor::getId »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the current element

MongoDB\Driver\Cursor::current

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::current — Returns the current element

Descripción

public MongoDB\Driver\Cursor::current ( ) : array|object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current result document as an array or object, depending on the cursor's type map. If iteration has not started or the current position is not valid, null will be returned.

Ver también

  • Iterator::current() - Devuelve el elemento actual


Returns the ID for this cursor

  • « MongoDB\Driver\Cursor::current
  • MongoDB\Driver\Cursor::getServer »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the ID for this cursor

MongoDB\Driver\Cursor::getId

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getId — Returns the ID for this cursor

Descripción

final public MongoDB\Driver\Cursor::getId ( ) : MongoDB\Driver\CursorId

Returns the MongoDB\Driver\CursorId associated with this cursor. A cursor ID uniquely identifies the cursor on the server.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the MongoDB\Driver\CursorId for this cursor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Cursor::getId() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getId());

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\CursorId)#5 (1) {
  ["id"]=>
  int(94810124093)
}

Ver también

  • MongoDB\Driver\CursorId
  • MongoDB\Driver\CursorId::__toString() - String representation of the cursor ID


Returns the server associated with this cursor

  • « MongoDB\Driver\Cursor::getId
  • MongoDB\Driver\Cursor::isDead »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the server associated with this cursor

MongoDB\Driver\Cursor::getServer

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor

Descripción

final public MongoDB\Driver\Cursor::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server associated with this cursor. This is the server that executed the MongoDB\Driver\Query or MongoDB\Driver\Command.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the MongoDB\Driver\Server associated with this cursor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Cursor::getServer() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getServer());

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\Server)#5 (10) {
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["type"]=>
  int(1)
  ["is_primary"]=>
  bool(false)
  ["is_secondary"]=>
  bool(false)
  ["is_arbiter"]=>
  bool(false)
  ["is_hidden"]=>
  bool(false)
  ["is_passive"]=>
  bool(false)
  ["last_is_master"]=>
  array(8) {
    ["ismaster"]=>
    bool(true)
    ["maxBsonObjectSize"]=>
    int(16777216)
    ["maxMessageSizeBytes"]=>
    int(48000000)
    ["maxWriteBatchSize"]=>
    int(1000)
    ["localTime"]=>
    object(MongoDB\BSON\UTCDateTime)#6 (1) {
      ["milliseconds"]=>
      int(1446505367907)
    }
    ["maxWireVersion"]=>
    int(3)
    ["minWireVersion"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["round_trip_time"]=>
  int(584)
}

Ver también

  • MongoDB\Driver\Server


Checks if the cursor is exhausted or may have additional results

  • « MongoDB\Driver\Cursor::getServer
  • MongoDB\Driver\Cursor::key »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Checks if the cursor is exhausted or may have additional results

MongoDB\Driver\Cursor::isDead

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results

Descripción

final public MongoDB\Driver\Cursor::isDead ( ) : bool

Checks whether there are definitely no additional results available on the cursor. This method is similar to the » cursor.isExhausted() method in the MongoDB shell and is primarily useful when iterating » tailable cursors.

A cursor has no additional results and is considered "dead" when one of the following is true:

  • The current batch has been fully iterated and the cursor ID is zero (i.e. a » getMore cannot be issued).
  • An error was encountered while iterating the cursor.
  • The cursor reached its configured limit.

By design, it is not possible to always determine whether a cursor has additional results. The cases where a cursor may have more data available is as follows:

  • There are additional documents in the current batch, which are buffered on the client side. Iterating will fetch a document from the local buffer.
  • There are no additional documents in the current batch (i.e. local buffer), but the cursor ID is non-zero. Iterating will request more documents from the server via a » getMore operation, which may or may not return additional results and/or indicate that the cursor has been closed on the server by returning zero for its ID.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if there are definitely no additional results available on the cursor, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Cursor::isDead() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);

$iterator = new IteratorIterator($cursor);

$iterator->rewind();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(false)
bool(true)

Ver también

  • » Tailable Cursors in the MongoDB manual
  • » cursor.isExhausted() in the MongoDB manual


Returns the current result's index within the cursor

  • « MongoDB\Driver\Cursor::isDead
  • MongoDB\Driver\Cursor::next »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the current result's index within the cursor

MongoDB\Driver\Cursor::key

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor

Descripción

public MongoDB\Driver\Cursor::key ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current result's numeric index within the cursor.

Ver también

  • Iterator::key() - Devuelve la clave del elemento actual


Advances the cursor to the next result

  • « MongoDB\Driver\Cursor::key
  • MongoDB\Driver\Cursor::rewind »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Advances the cursor to the next result

MongoDB\Driver\Cursor::next

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::next — Advances the cursor to the next result

Descripción

public MongoDB\Driver\Cursor::next ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Moves the current position to the next element in the cursor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.

Ver también

  • Iterator::next() - Avanza al siguiente elemento


Rewind the cursor to the first result

  • « MongoDB\Driver\Cursor::next
  • MongoDB\Driver\Cursor::setTypeMap »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Rewind the cursor to the first result

MongoDB\Driver\Cursor::rewind

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result

Descripción

public MongoDB\Driver\Cursor::rewind ( ) : void

If the cursor has advanced beyond its first position, it can no longer be rewound.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

null.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\LogicException if this method is called after the cursor has advanced beyond its first position.

Ver también

  • Iterator::rewind() - Rebobine la Iterator al primer elemento


Sets a type map to use for BSON unserialization

  • « MongoDB\Driver\Cursor::rewind
  • MongoDB\Driver\Cursor::toArray »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Sets a type map to use for BSON unserialization

MongoDB\Driver\Cursor::setTypeMap

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization

Descripción

final public MongoDB\Driver\Cursor::setTypeMap ( array $typemap ) : void

Sets the type map configuration to use when unserializing the BSON results into PHP values.

Parámetros

typeMap (array)

Configuración del mapa de tipos.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

When iterating over the cursor, the following exceptions can also be thrown due to an incorrect type map configuration:

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.

Ejemplos

Ejemplo #1 MongoDB\Driver\Cursor::setTypeMap() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$id = $bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query(['_id' => $id]);
$cursor = $manager->executeQuery('db.collection', $query);
$cursor->setTypeMap(['root' => 'array']);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectId)#6 (1) {
    ["oid"]=>
    string(24) "56424fb76118fd3267180741"
  }
  ["x"]=>
  int(1)
}

Ver también

  • Persistencia de datos


Returns an array containing all results for this cursor

  • « MongoDB\Driver\Cursor::setTypeMap
  • MongoDB\Driver\Cursor::valid »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns an array containing all results for this cursor

MongoDB\Driver\Cursor::toArray

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor

Descripción

final public MongoDB\Driver\Cursor::toArray ( ) : array

Iterates the cursor and returns its results in an array. MongoDB\Driver\Cursor::setTypeMap() may be used to control how documents are unserialized into PHP values.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array containing all results for this cursor.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Cursor::toArray() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query([]);
$cursor = $manager->executeQuery('db.collection', $query);

var_dump($cursor->toArray());

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  object(stdClass)#6 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#5 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf61"
    }
    ["x"]=>
    int(1)
  }
  [1]=>
  object(stdClass)#8 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#7 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf62"
    }
    ["x"]=>
    int(2)
  }
  [2]=>
  object(stdClass)#10 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#9 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf63"
    }
    ["x"]=>
    int(3)
  }
}

Ver también

  • MongoDB\Driver\Cursor::setTypeMap() - Sets a type map to use for BSON unserialization


Checks if the current position in the cursor is valid

  • « MongoDB\Driver\Cursor::toArray
  • MongoDB\Driver\CursorId »
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Checks if the current position in the cursor is valid

MongoDB\Driver\Cursor::valid

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid

Descripción

public MongoDB\Driver\Cursor::valid ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if the current cursor position is valid, false otherwise.

Ver también

  • Iterator::valid() - Comprueba si la posición actual es válido


The MongoDB\Driver\CursorId class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\CursorID class is a value object that represents a cursor ID. Instances of this class are returned by MongoDB\Driver\Cursor::getId().

Sinopsis de la Clase

final MongoDB\Driver\CursorId implements Serializable {
/* Métodos */
final private __construct ( )
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Historial de cambios

Versión | Descripción
PECL mongodb 1.7.0 | Implements Serializable.

Tabla de contenidos

  • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
  • MongoDB\Driver\CursorId::serialize — Serialize a CursorId
  • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
  • MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId


Create a new CursorId (not used)

  • « MongoDB\Driver\CursorId
  • MongoDB\Driver\CursorId::serialize »
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Create a new CursorId (not used)

MongoDB\Driver\CursorId::__construct

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)

Descripción

final private MongoDB\Driver\CursorId::__construct ( )

MongoDB\Driver\CursorId objects are returned from MongoDB\Driver\Cursor::getId() and cannot be constructed directly.

Parámetros

Esta función no tiene parámetros.

Ver también

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor


Serialize a CursorId

  • « MongoDB\Driver\CursorId::__construct
  • MongoDB\Driver\CursorId::__toString »
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Serialize a CursorId

MongoDB\Driver\CursorId::serialize

(mongodb >=1.7.0)

MongoDB\Driver\CursorId::serialize — Serialize a CursorId

Descripción

final public MongoDB\Driver\CursorId::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\Driver\CursorId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\CursorId::unserialize() - Unserialize a CursorId
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


String representation of the cursor ID

  • « MongoDB\Driver\CursorId::serialize
  • MongoDB\Driver\CursorId::unserialize »
  • PHP Manual
  • MongoDB\Driver\CursorId
  • String representation of the cursor ID

MongoDB\Driver\CursorId::__toString

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__toString — String representation of the cursor ID

Descripción

final public MongoDB\Driver\CursorId::__toString ( ) : string

Returns the string representation of the cursor ID.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of the cursor ID.

Ejemplos

Ejemplo #1 MongoDB\Driver\CursorId::__toString() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump((string) $cursor->getId());

?>

El resultado del ejemplo sería algo similar a:

string(11) "98061641158"

Ver también

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor


Unserialize a CursorId

  • « MongoDB\Driver\CursorId::__toString
  • MongoDB\Driver\Server »
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Unserialize a CursorId

MongoDB\Driver\CursorId::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId

Descripción

final public MongoDB\Driver\CursorId::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\Driver\CursorId.

Valores devueltos

Returns the unserialized MongoDB\Driver\CursorId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\Driver\CursorId::serialize() - Serialize a CursorId
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


The MongoDB\Driver\Server class

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

final MongoDB\Driver\Server {
/* Constants */
const int TYPE_UNKNOWN = 0 ;
const int TYPE_STANDALONE = 1 ;
const int TYPE_MONGOS = 2 ;
const int TYPE_POSSIBLE_PRIMARY = 3 ;
const int TYPE_RS_PRIMARY = 4 ;
const int TYPE_RS_SECONDARY = 5 ;
const int TYPE_RS_ARBITER = 6 ;
const int TYPE_RS_OTHER = 7 ;
const int TYPE_RS_GHOST = 8 ;
/* Métodos */
final private __construct ( )
final public executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult
final public executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public getHost ( ) : string
final public getInfo ( ) : array
final public getLatency ( ) : string
final public getPort ( ) : int
final public getTags ( ) : array
final public getType ( ) : int
final public isArbiter ( ) : bool
final public isHidden ( ) : bool
final public isPassive ( ) : bool
final public isPrimary ( ) : bool
final public isSecondary ( ) : bool
}

Constantes predefinidas

MongoDB\Driver\Server::TYPE_UNKNOWN

Unknown server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_STANDALONE

Standalone server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_MONGOS

Mongos server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_POSSIBLE_PRIMARY

Replica set possible primary server type, returned by MongoDB\Driver\Server::getType().

A server may be identified as a possible primary if it has not yet been checked but another memory of the replica set thinks it is the primary.

MongoDB\Driver\Server::TYPE_RS_PRIMARY

Replica set primary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_SECONDARY

Replica set secondary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_ARBITER

Replica set arbiter server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_OTHER

Replica set other server type, returned by MongoDB\Driver\Server::getType().

Such servers may be hidden, starting up, or recovering. They cannot be queried, but their hosts lists are useful for discovering the current replica set configuration.

MongoDB\Driver\Server::TYPE_RS_GHOST

Replica set ghost server type, returned by MongoDB\Driver\Server::getType().

Servers may be identified as such in at least three situations: briefly during server startup; in an uninitialized replica set; or when the server is shunned (i.e. removed from the replica set config). They cannot be queried, nor can their host list be used to discover the current replica set configuration; however, the client may monitor this server in hope that it transitions to a more useful state.

Tabla de contenidos

  • MongoDB\Driver\Server::__construct — Create a new Server (not used)
  • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
  • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
  • MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server
  • MongoDB\Driver\Server::getHost — Returns the hostname of this server
  • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
  • MongoDB\Driver\Server::getLatency — Returns the latency of this server
  • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
  • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
  • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
  • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
  • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
  • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
  • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
  • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set


Create a new Server (not used)

  • « MongoDB\Driver\Server
  • MongoDB\Driver\Server::executeBulkWrite »
  • PHP Manual
  • MongoDB\Driver\Server
  • Create a new Server (not used)

MongoDB\Driver\Server::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Server::__construct — Create a new Server (not used)

Descripción

final private MongoDB\Driver\Server::__construct ( )

MongoDB\Driver\Server objects are created internally by MongoDB\Driver\Manager when a database connection is established and may be returned by MongoDB\Driver\Manager::getServers() and MongoDB\Driver\Manager::selectServer().

Parámetros

Esta función no tiene parámetros.

Ver también

  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference


Execute one or more write operations on this server

  • « MongoDB\Driver\Server::__construct
  • MongoDB\Driver\Server::executeCommand »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute one or more write operations on this server

MongoDB\Driver\Server::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server

Descripción

final public MongoDB\Driver\Server::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult

Executes one or more write operations on this server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

Parámetros

namespace (string)

Un espacio de nombres completamente cualificado (p. ej. "nombreBaseDatos.nombreColección").

bulk (MongoDB\Driver\BulkWrite)

La/s escritura/s a ejecutar.

options

options
Option Type Description
session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Valores devueltos

Devuelve un MongoDB\Driver\WriteResult en caso de éxito.

Errores/Excepciones

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk does not contain any write operations.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk has already been executed. MongoDB\Driver\BulkWrite objects may not be executed multiple times.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Lanza una MongoDB\Driver\Exception\BulkWriteException al fallar cualquier escritura (p.ej. error de escritura, fallo al aplicar un asunto de escritura)
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\WriteConcern object.
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is now thrown if bulk does not contain any write operations. Previously, a MongoDB\Driver\Exception\BulkWriteException was thrown.

Notas

Nota: Es responsabilidad del llamador asegurarse de que el servidor es capaz de ejecutar la operación de escritura. Por ejemplo, ejecutar un operación de escritura en un secundario (excluyendo su base de datos "local"), fallará.

Ver también

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations


Execute a database command on this server

  • « MongoDB\Driver\Server::executeBulkWrite
  • MongoDB\Driver\Server::executeQuery »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command on this server

MongoDB\Driver\Server::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeCommand — Execute a database command on this server

Descripción

final public MongoDB\Driver\Server::executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method applies no special logic to the command. Although this method accepts "readConcern" and "writeConcern" options, which will be incorporated into the command document, those options will not default to corresponding values from the MongoDB Connection URI nor will the MongoDB server version be taken into account. Users are therefore encouraged to use specific read and/or write command methods if possible.

Nota: La opción "readPreference" no controla el servidor al cual el controlador emite la opración; siempre se ejecutará en este objeto de servidor. En su lugar, podría usarse al emitir una operación a un secundario (desde una conexión de cojunto réplica, no solo) o a un nodo de mongo para asegurarse de que el controlador establece el protocolo de escritura en consecuencia, o añade la preferencia de lectura a la operación, respectivamente.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

Notas

Nota: Es responsabilidad del llamador asegurarse de que el servidor es capaz de ejecutar la operación de escritura. Por ejemplo, ejecutar un operación de escritura en un secundario (excluyendo su base de datos "local"), fallará.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command


Execute a database query on this server

  • « MongoDB\Driver\Server::executeCommand
  • MongoDB\Driver\Server::executeReadCommand »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database query on this server

MongoDB\Driver\Server::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeQuery — Execute a database query on this server

Descripción

final public MongoDB\Driver\Server::executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor

Executes the query on this server.

Nota: The "readPreference" option does not control the server to which the driver issues the operation; it will always be executed on this server object. Instead, it may be used when issuing the operation to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the operation, respectively.

Parámetros

namespace (string)

Un espacio de nombres completamente cualificado (p. ej. "nombreBaseDatos.nombreColección").

query (MongoDB\Driver\Query)

La consulta a ejecutar.

options

options
Option Type Description
readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

Ver también

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query


Execute a database command that reads on this server

  • « MongoDB\Driver\Server::executeQuery
  • MongoDB\Driver\Server::executeReadWriteCommand »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that reads on this server

MongoDB\Driver\Server::executeReadCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server

Descripción

final public MongoDB\Driver\Server::executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that read (e.g. » count) and take the MongoDB server version into account. The "readConcern" option will default to the corresponding value from the MongoDB Connection URI.

Nota: La opción "readPreference" no controla el servidor al cual el controlador emite la opración; siempre se ejecutará en este objeto de servidor. En su lugar, podría usarse al emitir una operación a un secundario (desde una conexión de cojunto réplica, no solo) o a un nodo de mongo para asegurarse de que el controlador establece el protocolo de escritura en consecuencia, o añade la preferencia de lectura a la operación, respectivamente.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

readPreference MongoDB\Driver\ReadPreference

Una preferencia de lectura a usar para seleccionar un servidor para la operación.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads


Execute a database command that reads and writes on this server

  • « MongoDB\Driver\Server::executeReadCommand
  • MongoDB\Driver\Server::executeWriteCommand »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that reads and writes on this server

MongoDB\Driver\Server::executeReadWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server

Descripción

final public MongoDB\Driver\Server::executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that read and write (e.g. » aggregate) and take the MongoDB server version into account. The "readConcern" and "writeConcern" options will default to the corresponding values from the MongoDB Connection URI.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

Un asunto de escritura a aplicar a la operación.

Esta opción está disponible en MongoDB 3.2+ y resultará en una excepción en tiempo de ejecución si es especificada para una versión de servidor más antigua.

session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

Notas

Nota: Es responsabilidad del llamador asegurarse de que el servidor es capaz de ejecutar la operación de escritura. Por ejemplo, ejecutar un operación de escritura en un secundario (excluyendo su base de datos "local"), fallará.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes


Execute a database command that writes on this server

  • « MongoDB\Driver\Server::executeReadWriteCommand
  • MongoDB\Driver\Server::getHost »
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that writes on this server

MongoDB\Driver\Server::executeWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server

Descripción

final public MongoDB\Driver\Server::executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that write (e.g. » drop) and take the MongoDB server version into account. The "writeConcern" option will default to the corresponding value from the MongoDB Connection URI.

Nota: This method is not intended to be used to execute » insert, » update, or » delete commands. Users are encouraged to use MongoDB\Driver\Server::executeBulkWrite() for those commands.

Parámetros

db (string)

El nombre de la base de datos en la que ejecutar el comando.

command (MongoDB\Driver\Command)

El comando a ejecutar.

options

options
Option Type Description
session MongoDB\Driver\Session

Una sesión a asociar con la operación.

writeConcern MongoDB\Driver\WriteConcern

Un asunto de escritura a aplicar a la operación.

Advertencia

Si se usa la opción "session" con sesión que tenga una transacción en progreso, no se puede especificar una opción "readConcern" o "writeConcern". Esto resultarña en una MongoDB\Driver\Exception\InvalidArgumentException. En su lugar se debería establecer estas dos opciones al crear la transacción con MongoDB\Driver\Session::startTransaction().

Valores devueltos

Devuelve un MongoDB\Driver\Cursor en caso de éxito.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa con una transacción asociada junto a la opción "readConcern" o "writeConcern" option.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException si la opción "session" se usa junto a un asunto de escritura no reconocido.
  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Lanza una MongoDB\Driver\Exception\ConnectionException si la conexión al servidor falla (por razones diferentes a la autenticación).
  • Lanza una MongoDB\Driver\Exception\AuthenticationException si la autenticación es necesaria y falla.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

Notas

Nota: Es responsabilidad del llamador asegurarse de que el servidor es capaz de ejecutar la operación de escritura. Por ejemplo, ejecutar un operación de escritura en un secundario (excluyendo su base de datos "local"), fallará.

Ver también

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes


Returns the hostname of this server

  • « MongoDB\Driver\Server::executeWriteCommand
  • MongoDB\Driver\Server::getInfo »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the hostname of this server

MongoDB\Driver\Server::getHost

(mongodb >=1.0.0)

MongoDB\Driver\Server::getHost — Returns the hostname of this server

Descripción

final public MongoDB\Driver\Server::getHost ( ) : string

Returns the hostname of this server.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the hostname of this server.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Server::getHost() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getHost());

?>

El resultado del ejemplo sería:

string(9) "localhost"

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an array of information about this server

  • « MongoDB\Driver\Server::getHost
  • MongoDB\Driver\Server::getLatency »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an array of information about this server

MongoDB\Driver\Server::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\Server::getInfo — Returns an array of information about this server

Descripción

final public MongoDB\Driver\Server::getInfo ( ) : array

Returns an array of information about this server.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of information about this server.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Server::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getInfo());

?>

El resultado del ejemplo sería algo similar a:

array(8) {
  ["ismaster"]=>
  bool(true)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["maxMessageSizeBytes"]=>
  int(48000000)
  ["maxWriteBatchSize"]=>
  int(1000)
  ["localTime"]=>
  object(MongoDB\BSON\UTCDateTime)#4 (1) {
    ["milliseconds"]=>
    int(1447276242774)
  }
  ["maxWireVersion"]=>
  int(3)
  ["minWireVersion"]=>
  int(0)
  ["ok"]=>
  float(1)
}


Returns the latency of this server

  • « MongoDB\Driver\Server::getInfo
  • MongoDB\Driver\Server::getPort »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the latency of this server

MongoDB\Driver\Server::getLatency

(mongodb >=1.0.0)

MongoDB\Driver\Server::getLatency — Returns the latency of this server

Descripción

final public MongoDB\Driver\Server::getLatency ( ) : string

Returns the latency of this server (i.e. the client's measured » round trip time of an ismaster command).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the latency of this server.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Server::getLatency() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getLatency());

?>

El resultado del ejemplo sería algo similar a:

int(592)

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
  • » Server Discovery and Monitoring Specification


Returns the port on which this server is listening

  • « MongoDB\Driver\Server::getLatency
  • MongoDB\Driver\Server::getTags »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the port on which this server is listening

MongoDB\Driver\Server::getPort

(mongodb >=1.0.0)

MongoDB\Driver\Server::getPort — Returns the port on which this server is listening

Descripción

final public MongoDB\Driver\Server::getPort ( ) : int

Returns the port on which this server is listening.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the port on which this server is listening.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\Server::getPort() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getPort());

?>

El resultado del ejemplo sería:

int(27017)

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an array of tags describing this server in a replica set

  • « MongoDB\Driver\Server::getPort
  • MongoDB\Driver\Server::getType »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an array of tags describing this server in a replica set

MongoDB\Driver\Server::getTags

(mongodb >=1.0.0)

MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set

Descripción

final public MongoDB\Driver\Server::getTags ( ) : array

Returns an array of » tags used to describe this server in a replica set. The array will contain zero or more string key and value pairs.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of tags used to describe this server in a replica set.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an integer denoting the type of this server

  • « MongoDB\Driver\Server::getTags
  • MongoDB\Driver\Server::isArbiter »
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an integer denoting the type of this server

MongoDB\Driver\Server::getType

(mongodb >=1.0.0)

MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server

Descripción

final public MongoDB\Driver\Server::getType ( ) : int

Returns an int denoting the type of this server. The value will correlate with a MongoDB\Driver\Server constant.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an int denoting the type of this server.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is an arbiter member of a replica set

  • « MongoDB\Driver\Server::getType
  • MongoDB\Driver\Server::isHidden »
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is an arbiter member of a replica set

MongoDB\Driver\Server::isArbiter

(mongodb >=1.0.0)

MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set

Descripción

final public MongoDB\Driver\Server::isArbiter ( ) : bool

Returns whether this server is an » arbiter member of a replica set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this server is an arbiter member of a replica set, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a hidden member of a replica set

  • « MongoDB\Driver\Server::isArbiter
  • MongoDB\Driver\Server::isPassive »
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a hidden member of a replica set

MongoDB\Driver\Server::isHidden

(mongodb >=1.0.0)

MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set

Descripción

final public MongoDB\Driver\Server::isHidden ( ) : bool

Returns whether this server is a » hidden member of a replica set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this server is a hidden member of a replica set, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a passive member of a replica set

  • « MongoDB\Driver\Server::isHidden
  • MongoDB\Driver\Server::isPrimary »
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a passive member of a replica set

MongoDB\Driver\Server::isPassive

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set

Descripción

final public MongoDB\Driver\Server::isPassive ( ) : bool

Returns whether this server is a » passive member of a replica set (i.e. its priority is 0).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this server is a passive member of a replica set, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a primary member of a replica set

  • « MongoDB\Driver\Server::isPassive
  • MongoDB\Driver\Server::isSecondary »
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a primary member of a replica set

MongoDB\Driver\Server::isPrimary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set

Descripción

final public MongoDB\Driver\Server::isPrimary ( ) : bool

Returns whether this server is a » primary member of a replica set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this server is a primary member of a replica set, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a secondary member of a replica set

  • « MongoDB\Driver\Server::isPrimary
  • MongoDB\Driver\WriteConcernError »
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a secondary member of a replica set

MongoDB\Driver\Server::isSecondary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set

Descripción

final public MongoDB\Driver\Server::isSecondary ( ) : bool

Returns whether this server is a » secondary member of a replica set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if this server is a secondary member of a replica set, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


The MongoDB\Driver\WriteConcernError class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\WriteConcernError class encapsulates information about a write concern error and may be returned by MongoDB\Driver\WriteResult::getWriteConcernError().

Sinopsis de la Clase

final MongoDB\Driver\WriteConcernError {
/* Métodos */
final public getCode ( ) : int
final public getInfo ( ) : object|null
final public getMessage ( ) : string
}

Tabla de contenidos

  • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
  • MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError
  • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message


Returns the WriteConcernError's error code

  • « MongoDB\Driver\WriteConcernError
  • MongoDB\Driver\WriteConcernError::getInfo »
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns the WriteConcernError's error code

MongoDB\Driver\WriteConcernError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code

Descripción

final public MongoDB\Driver\WriteConcernError::getCode ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteConcernError's error code.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcernError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getCode());
}

?>

El resultado del ejemplo sería algo similar a:

int(64)

Ver también

  • » Write Concern reference


Returns metadata document for the WriteConcernError

  • « MongoDB\Driver\WriteConcernError::getCode
  • MongoDB\Driver\WriteConcernError::getMessage »
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns metadata document for the WriteConcernError

MongoDB\Driver\WriteConcernError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError

Descripción

final public MongoDB\Driver\WriteConcernError::getInfo ( ) : object|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the metadata document for the WriteConcernError, or null if no metadata is available.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcernError::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getInfo());
}

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#1 (1) {
  ["wtimeout"]=>
  bool(true)
}

Ver también

  • » Write Concern reference


Returns the WriteConcernError's error message

  • « MongoDB\Driver\WriteConcernError::getInfo
  • MongoDB\Driver\WriteError »
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns the WriteConcernError's error message

MongoDB\Driver\WriteConcernError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message

Descripción

final public MongoDB\Driver\WriteConcernError::getMessage ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteConcernError's error message.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteConcernError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getMessage());
}

?>

El resultado del ejemplo sería algo similar a:

string(33) "waiting for replication timed out"

Ver también

  • » Write Concern reference


The MongoDB\Driver\WriteError class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\WriteError class encapsulates information about a write error and may be returned as an array element from MongoDB\Driver\WriteResult::getWriteErrors().

Sinopsis de la Clase

final MongoDB\Driver\WriteError {
/* Métodos */
final public getCode ( ) : int
final public getIndex ( ) : int
final public getInfo ( ) : object|null
final public getMessage ( ) : string
}

Tabla de contenidos

  • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
  • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
  • MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError
  • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message


Returns the WriteError's error code

  • « MongoDB\Driver\WriteError
  • MongoDB\Driver\WriteError::getIndex »
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the WriteError's error code

MongoDB\Driver\WriteError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code

Descripción

final public MongoDB\Driver\WriteError::getCode ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteError's error code.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getCode());
}

?>

El resultado del ejemplo sería algo similar a:

int(11000)


Returns the index of the write operation corresponding to this WriteError

  • « MongoDB\Driver\WriteError::getCode
  • MongoDB\Driver\WriteError::getInfo »
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the index of the write operation corresponding to this WriteError

MongoDB\Driver\WriteError::getIndex

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError

Descripción

final public MongoDB\Driver\WriteError::getIndex ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the index of the write operation (from MongoDB\Driver\BulkWrite) corresponding to this WriteError.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteError::getIndex() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getIndex());
}

?>

El resultado del ejemplo sería algo similar a:

int(1)

Ver también

  • MongoDB\Driver\BulkWrite


Returns metadata document for the WriteError

  • « MongoDB\Driver\WriteError::getIndex
  • MongoDB\Driver\WriteError::getMessage »
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns metadata document for the WriteError

MongoDB\Driver\WriteError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError

Descripción

final public MongoDB\Driver\WriteError::getInfo ( ) : object|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the metadata document for the WriteError, or null if no metadata is available.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.


Returns the WriteError's error message

  • « MongoDB\Driver\WriteError::getInfo
  • MongoDB\Driver\WriteResult »
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the WriteError's error message

MongoDB\Driver\WriteError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message

Descripción

final public MongoDB\Driver\WriteError::getMessage ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the WriteError's error message.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getMessage());
}

?>

El resultado del ejemplo sería algo similar a:

string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"


The MongoDB\Driver\WriteResult class

(mongodb >=1.0.0)

Introducción

The MongoDB\Driver\WriteResult class encapsulates information about an executed MongoDB\Driver\BulkWrite and may be returned by MongoDB\Driver\Manager::executeBulkWrite().

Sinopsis de la Clase

final MongoDB\Driver\WriteResult {
/* Métodos */
final public getDeletedCount ( ) : int|null
final public getInsertedCount ( ) : int|null
final public getMatchedCount ( ) : int|null
final public getModifiedCount ( ) : int|null
final public getServer ( ) : MongoDB\Driver\Server
final public getUpsertedCount ( ) : int|null
final public getUpsertedIds ( ) : array
final public getWriteConcernError ( ) : MongoDB\Driver\WriteConcernError|null
final public getWriteErrors ( ) : array
final public isAcknowledged ( ) : bool
}

Tabla de contenidos

  • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
  • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
  • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
  • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
  • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
  • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged


Returns the number of documents deleted

  • « MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteResult::getInsertedCount »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents deleted

MongoDB\Driver\WriteResult::getDeletedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted

Descripción

final public MongoDB\Driver\WriteResult::getDeletedCount ( ) : int|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of documents deleted, or null if the write was not acknowledged.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getDeletedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getDeletedCount());

?>

El resultado del ejemplo sería:

int(1)

Ver también

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of documents inserted (excluding upserts)

  • « MongoDB\Driver\WriteResult::getDeletedCount
  • MongoDB\Driver\WriteResult::getMatchedCount »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents inserted (excluding upserts)

MongoDB\Driver\WriteResult::getInsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)

Descripción

final public MongoDB\Driver\WriteResult::getInsertedCount ( ) : int|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of documents inserted (excluding upserts), or null if the write was not acknowledged.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getInsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getInsertedCount());

?>

El resultado del ejemplo sería:

int(1)

Ver también

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of documents selected for update

  • « MongoDB\Driver\WriteResult::getInsertedCount
  • MongoDB\Driver\WriteResult::getModifiedCount »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents selected for update

MongoDB\Driver\WriteResult::getMatchedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update

Descripción

final public MongoDB\Driver\WriteResult::getMatchedCount ( ) : int|null

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the matched count may be greater than the value returned by MongoDB\Driver\WriteResult::getModifiedCount().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of documents selected for update, or null if the write was not acknowledged.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getMatchedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getMatchedCount());

?>

El resultado del ejemplo sería:

int(1)

Ver también

  • MongoDB\Driver\WriteResult::getModifiedCount() - Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of existing documents updated

  • « MongoDB\Driver\WriteResult::getMatchedCount
  • MongoDB\Driver\WriteResult::getServer »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of existing documents updated

MongoDB\Driver\WriteResult::getModifiedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated

Descripción

final public MongoDB\Driver\WriteResult::getModifiedCount ( ) : int|null

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the modified count may be less than the value returned by MongoDB\Driver\WriteResult::getMatchedCount().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of existing documents updated, or null if the write was not acknowledged.

The modified count is not available on versions of MongoDB before 2.6, which used the legacy wire protocol version (i.e. OP_UPDATE). If this is the case, the modified count will also be null.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getModifiedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getModifiedCount());

?>

El resultado del ejemplo sería:

int(1)

Ver también

  • MongoDB\Driver\WriteResult::getMatchedCount() - Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the server associated with this write result

  • « MongoDB\Driver\WriteResult::getModifiedCount
  • MongoDB\Driver\WriteResult::getUpsertedCount »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the server associated with this write result

MongoDB\Driver\WriteResult::getServer

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result

Descripción

final public MongoDB\Driver\WriteResult::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server associated with this write result. This is the server that executed the MongoDB\Driver\BulkWrite.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the MongoDB\Driver\Server associated with this write result.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getServer() example

<?php

$manager = new MongoDB\Driver\Manager;
$server = $manager->selectServer(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY));

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $server->executeBulkWrite('db.collection', $bulk);

var_dump($result->getServer() == $server);

?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • MongoDB\Driver\Server


Returns the number of documents inserted by an upsert

  • « MongoDB\Driver\WriteResult::getServer
  • MongoDB\Driver\WriteResult::getUpsertedIds »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents inserted by an upsert

MongoDB\Driver\WriteResult::getUpsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert

Descripción

final public MongoDB\Driver\WriteResult::getUpsertedCount ( ) : int|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of documents inserted by an upsert.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getUpsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedCount());

?>

El resultado del ejemplo sería:

int(2)

Ver también

  • MongoDB\Driver\WriteResult::getUpsertedIds() - Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns an array of identifiers for upserted documents

  • « MongoDB\Driver\WriteResult::getUpsertedCount
  • MongoDB\Driver\WriteResult::getWriteConcernError »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns an array of identifiers for upserted documents

MongoDB\Driver\WriteResult::getUpsertedIds

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents

Descripción

final public MongoDB\Driver\WriteResult::getUpsertedIds ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of identifiers (i.e. "_id" field values) for upserted documents. The array keys will correspond to the index of the write operation (from MongoDB\Driver\BulkWrite) responsible for the upsert.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getUpsertedIds() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedIds());

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  [2]=>
  object(MongoDB\BSON\ObjectId)#4 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880b"
  }
  [3]=>
  object(MongoDB\BSON\ObjectId)#5 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880c"
  }
}

Ver también

  • MongoDB\Driver\WriteResult::getUpsertedCount() - Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns any write concern error that occurred

  • « MongoDB\Driver\WriteResult::getUpsertedIds
  • MongoDB\Driver\WriteResult::getWriteErrors »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns any write concern error that occurred

MongoDB\Driver\WriteResult::getWriteConcernError

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred

Descripción

final public MongoDB\Driver\WriteResult::getWriteConcernError ( ) : MongoDB\Driver\WriteConcernError|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a MongoDB\Driver\WriteConcernError if a write concern error was encountered during the write operation, and null otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getWriteConcernError() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError());
}

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\Driver\WriteConcernError)#6 (3) {
  ["message"]=>
  string(33) "waiting for replication timed out"
  ["code"]=>
  int(64)
  ["info"]=>
  object(stdClass)#7 (1) {
    ["wtimeout"]=>
    bool(true)
  }
}

Ver también

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference


Returns any write errors that occurred

  • « MongoDB\Driver\WriteResult::getWriteConcernError
  • MongoDB\Driver\WriteResult::isAcknowledged »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns any write errors that occurred

MongoDB\Driver\WriteResult::getWriteErrors

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred

Descripción

final public MongoDB\Driver\WriteResult::getWriteErrors ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of MongoDB\Driver\WriteError objects for any write errors encountered during the write operation. The array will be empty if no write errors occurred.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::getWriteErrors() with a single error

<?php

$manager = new MongoDB\Driver\Manager;

/* By default, bulk write operations are executed serially in order and
 * execution will stop after the first error.
 */
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
}

Ejemplo #2 MongoDB\Driver\WriteResult::getWriteErrors() with multiple errors

<?php

$manager = new MongoDB\Driver\Manager;

/* The "ordered" option may be used to allow bulk write operations to continue
 * executing after the first error is encountered.
 */
$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
  [1]=>
  object(MongoDB\Driver\WriteError)#6 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 4 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(5)
    ["info"]=>
    NULL
  }
}

Ver también

  • MongoDB\Driver\WriteError


Returns whether the write was acknowledged

  • « MongoDB\Driver\WriteResult::getWriteErrors
  • MongoDB\BSON »
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns whether the write was acknowledged

MongoDB\Driver\WriteResult::isAcknowledged

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged

Descripción

final public MongoDB\Driver\WriteResult::isAcknowledged ( ) : bool

If the write is acknowledged, other count fields will be available on the MongoDB\Driver\WriteResult object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the write was acknowledged, and false otherwise.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\Driver\WriteResult::isAcknowledged() with acknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->isAcknowledged());

?>

El resultado del ejemplo sería:

bool(true)

Ejemplo #2 MongoDB\Driver\WriteResult::isAcknowledged() with unacknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk, new MongoDB\Driver\WriteConcern(0));

var_dump($result->isAcknowledged());

?>

El resultado del ejemplo sería:

bool(false)

Ver también

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference


Clases de tipo BSON y funciones de serialización

  • Funciones
    • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
    • MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value
    • MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value
    • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
    • MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value
  • MongoDB\BSON\Binary — La clase MongoDB\BSON\Binary
    • MongoDB\BSON\Binary::__construct — Construct a new Binary
    • MongoDB\BSON\Binary::getData — Returns the Binary's data
    • MongoDB\BSON\Binary::getType — Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize — Serialize a Binary
    • MongoDB\BSON\Binary::__toString — Returns the Binary's data
    • MongoDB\BSON\Binary::unserialize — Unserialize a Binary
  • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
    • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
    • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
    • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128
  • MongoDB\BSON\Javascript — La clase MongoDB\BSON\Javascript
    • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
    • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
    • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
    • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript
  • MongoDB\BSON\MaxKey — La clase MongoDB\BSON\MaxKey
    • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
    • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey
  • MongoDB\BSON\MinKey — La clase MongoDB\BSON\MinKey
    • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
    • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey
  • MongoDB\BSON\ObjectID — La clase MongoDB\BSON\ObjectID
    • MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId
    • MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId
    • MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId
    • MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId
    • MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId
  • MongoDB\BSON\Regex — La clase MongoDB\BSON\Regex
    • MongoDB\BSON\Regex::__construct — Construct a new Regex
    • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize — Serialize a Regex
    • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
    • MongoDB\BSON\Regex::unserialize — Unserialize a Regex
  • MongoDB\BSON\Timestamp — La clase MongoDB\BSON\Timestamp
    • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
    • MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp
    • MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp
    • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
    • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
    • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp
  • MongoDB\BSON\UTCDateTime — La clase MongoDB\BSON\UTCDatetime
    • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime
  • MongoDB\BSON\Type — La interfaz MongoDB\BSON\Type
  • MongoDB\BSON\Persistable — La interfaz MongoDB\BSON\Persistable
  • MongoDB\BSON\Serializable — La interfaz MongoDB\BSON\Serializable
    • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON
  • MongoDB\BSON\Unserializable — La interfaz MongoDB\BSON\Unserializable
    • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document
  • MongoDB\BSON\BinaryInterface — The MongoDB\BSON\BinaryInterface interface
    • MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data
    • MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type
    • MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data
  • MongoDB\BSON\Decimal128Interface — The MongoDB\BSON\Decimal128Interface interface
    • MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface
  • MongoDB\BSON\JavascriptInterface — The MongoDB\BSON\JavascriptInterface interface
    • MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code
    • MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document
    • MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code
  • MongoDB\BSON\MaxKeyInterface — The MongoDB\BSON\MaxKeyInterface interface
  • MongoDB\BSON\MinKeyInterface — The MongoDB\BSON\MinKeyInterface interface
  • MongoDB\BSON\ObjectIdInterface — The MongoDB\BSON\ObjectIdInterface interface
    • MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface
    • MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface
  • MongoDB\BSON\RegexInterface — The MongoDB\BSON\RegexInterface interface
    • MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags
    • MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern
    • MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface
  • MongoDB\BSON\TimestampInterface — The MongoDB\BSON\TimestampInterface interface
    • MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface
  • MongoDB\BSON\UTCDateTimeInterface — The MongoDB\BSON\UTCDateTimeInterface interface
    • MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface
    • MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface


Funciones

Tabla de contenidos

  • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
  • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
  • MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value
  • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value


Returns the BSON representation of a JSON value

  • « Funciones
  • MongoDB\BSON\fromPHP »
  • PHP Manual
  • Funciones
  • Returns the BSON representation of a JSON value

MongoDB\BSON\fromJSON

(mongodb >=1.0.0)

MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value

Descripción

MongoDB\BSON\fromJSON ( string $json ) : string

Converts an » extended JSON string to its BSON representation.

Parámetros

json (string)

JSON value to be converted.

Valores devueltos

The serialized BSON document as a binary string.

Errores/Excepciones

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the JSON value cannot be converted to BSON (e.g. due to a syntax error).

Ejemplos

Ejemplo #1 MongoDB\BSON\fromJSON() example

<?php

$json = '{ "_id": { "$oid": "563143b280d2387c91807965" } }';
$bson = MongoDB\BSON\fromJSON($json);
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

El resultado del ejemplo sería:

object(stdClass)#2 (1) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectId)#1 (1) {
    ["oid"]=>
    string(24) "563143b280d2387c91807965"
  }
}

Ver también

  • MongoDB\BSON\toJSON() - Returns the Legacy Extended JSON representation of a BSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON


Returns the BSON representation of a PHP value

  • « MongoDB\BSON\fromJSON
  • MongoDB\BSON\toCanonicalExtendedJSON »
  • PHP Manual
  • Funciones
  • Returns the BSON representation of a PHP value

MongoDB\BSON\fromPHP

(mongodb >=1.0.0)

MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value

Descripción

MongoDB\BSON\fromPHP ( array|object $value ) : string

Serializes a PHP array or object (e.g. document) to its » BSON representation. The returned binary string will describe a BSON document.

Parámetros

value (array|object)

PHP value to be serialized.

Valores devueltos

The serialized BSON document as a binary string.

Errores/Excepciones

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the PHP value cannot be converted to BSON. Possible reasons include, but are not limited to, encountering an unexpected MongoDB\BSON\Type instance or MongoDB\BSON\Serializable::bsonSerialize() failing to return an array or stdClass.

Ejemplos

Ejemplo #1 MongoDB\BSON\fromPHP() example

<?php

$bson = MongoDB\BSON\fromPHP(['foo' => 1]);
echo bin2hex($bson), "\n";

?>

El resultado del ejemplo sería:

0e00000010666f6f000100000000cat

Ver también

  • MongoDB\BSON\toPHP() - Returns the PHP representation of a BSON value
  • » MongoDB BSON
  • Persistencia de datos


Returns the Canonical Extended JSON representation of a BSON value

  • « MongoDB\BSON\fromPHP
  • MongoDB\BSON\toJSON »
  • PHP Manual
  • Funciones
  • Returns the Canonical Extended JSON representation of a BSON value

MongoDB\BSON\toCanonicalExtendedJSON

(mongodb >=1.3.0)

MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value

Descripción

MongoDB\BSON\toCanonicalExtendedJSON ( string $bson ) : string

Converts a BSON string to its » Canonical Extended JSON representation. The canonical format prefers type fidelity at the expense of concise output and is most suited for producing output that can be converted back to BSON without any loss of type information (e.g. numeric types will remain differentiated).

Parámetros

bson (string)

BSON value to be converted.

Valores devueltos

The converted JSON value.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\UnexpectedValueException si la entrada no contiene exactamente un documento BSON. Las posibles razones incluyen, pero no están limitadas a, BSON no válido, datos extra (tras leer el documento BSON), o un error » libbson no esperado.

Ejemplos

Ejemplo #1 MongoDB\BSON\toCanonicalExtendedJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toCanonicalExtendedJSON($bson), "\n";
}

?>

El resultado del ejemplo sería:

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : { "$numberInt" : "123" } }
{ "int64" : { "$numberLong" : "4294967295"} }
{ "double" : { "$numberDouble" : "1.0" } }
{ "nan" : { "$numberDouble" : "NaN" } }
{ "pos_inf" : { "$numberDouble" : "Infinity" } }
{ "neg_inf" : { "$numberDouble" : "-Infinity" } }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : { "base64": "Zm9v", "subType" : "00" } } }
{ "date" : { "$date" : { "$numberLong" : "1445990400000" } } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regularExpression" : { "pattern" : "pattern", "options" : "i" } } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : { "$numberInt" : "1" } } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

Ver también

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » Extended JSON Specification
  • » MongoDB BSON


Returns the Legacy Extended JSON representation of a BSON value

  • « MongoDB\BSON\toCanonicalExtendedJSON
  • MongoDB\BSON\toPHP »
  • PHP Manual
  • Funciones
  • Returns the Legacy Extended JSON representation of a BSON value

MongoDB\BSON\toJSON

(mongodb >=1.0.0)

MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value

Descripción

MongoDB\BSON\toJSON ( string $bson ) : string

Converts a BSON string to its » Legacy Extended JSON representation.

Nota: There exist several JSON formats for representing BSON. This function implements the "strict mode" defined in » MongoDB Extended JSON, which has been superseded by the canonical and relaxed formats defined in the » Extended JSON Specification and implemented by MongoDB\BSON\toCanonicalExtendedJSON() and MongoDB\BSON\toRelaxedExtendedJSON(), respectively.

Advertencia

» JSON does not support NAN and INF and MongoDB's Legacy Extended JSON format does not define an alternative representation for these values (» libbson will output nan and inf literals, which may not be parsed as valid JSON). If you are working with BSON that may contain non-finite numbers, please use MongoDB\BSON\toCanonicalExtendedJSON() or MongoDB\BSON\toRelaxedExtendedJSON().

Parámetros

bson (string)

BSON value to be converted.

Valores devueltos

The converted JSON value.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\UnexpectedValueException si la entrada no contiene exactamente un documento BSON. Las posibles razones incluyen, pero no están limitadas a, BSON no válido, datos extra (tras leer el documento BSON), o un error » libbson no esperado.

Ejemplos

Ejemplo #1 MongoDB\BSON\toJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toJSON($bson), "\n";
}

?>

El resultado del ejemplo sería:

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : 123 }
{ "int64" : 4294967295 }
{ "double" : 1.0 }
{ "nan" : nan }
{ "pos_inf" : inf }
{ "neg_inf" : -inf }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : "Zm9v", "$type" : "00" } }
{ "date" : { "$date" : 1445990400000 } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regex" : "pattern", "$options" : "i" } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : 1 } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

Ver también

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON


Returns the PHP representation of a BSON value

  • « MongoDB\BSON\toJSON
  • MongoDB\BSON\toRelaxedExtendedJSON »
  • PHP Manual
  • Funciones
  • Returns the PHP representation of a BSON value

MongoDB\BSON\toPHP

(mongodb >=1.0.0)

MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value

Descripción

MongoDB\BSON\toPHP ( string $bson , array $typeMap = array() ) : array|object

Unserializes a BSON document (i.e. binary string) to its PHP representation. The typeMap paramater may be used to control the PHP types used for converting BSON arrays and documents (both root and embedded).

Advertencia

Fields containing deprecated BSON types (i.e. undefined, symbol, DBPointer) are represented only by bare-bones objects of the classes MongoDB\BSON\Undefined, MongoDB\BSON\Symbol, and MongoDB\BSON\DBPointer, when converting BSON to PHP. These objects are created from BSON data and used for storing these types back into the database, but can not be instantiated as they have a private constructor.

Parámetros

bson (string)

BSON value to be unserialized.

typeMap (array)

Configuración del mapa de tipos.

Valores devueltos

The unserialized PHP value.

Errores/Excepciones

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.
  • Lanza una MongoDB\Driver\Exception\UnexpectedValueException si la entrada no contiene exactamente un documento BSON. Las posibles razones incluyen, pero no están limitadas a, BSON no válido, datos extra (tras leer el documento BSON), o un error » libbson no esperado.

Historial de cambios

Versión | Descripción
PECL mongodb 1.4.0 | If the input contains an unsupported, deprecated BSON type, the driver will now no longer log a warning to the debug log, but instead will create an object representing this type.
PECL mongodb 1.3.2 | MongoDB\Driver\Exception\UnexpectedValueException is no longer thrown if the input contains an unsupported, deprecated BSON type. Such types will be ignored (as they were in versions before 1.3.0), although the driver will now log a warning to the debug log (see: mongodb.debug).
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\UnexpectedValueException is thrown if the input contains an unsupported, deprecated BSON type. Previously, such types were ignored.

Ejemplos

Ejemplo #1 MongoDB\BSON\toPHP() example

<?php

$bson = hex2bin('0e00000010666f6f000100000000');
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

El resultado del ejemplo sería:

object(stdClass)#1 (1) {
  ["foo"]=>
  int(1)
}

Ver también

  • MongoDB\BSON\fromPHP() - Returns the BSON representation of a PHP value
  • » MongoDB BSON
  • Persistencia de datos


Returns the Relaxed Extended JSON representation of a BSON value

  • « MongoDB\BSON\toPHP
  • MongoDB\BSON\Binary »
  • PHP Manual
  • Funciones
  • Returns the Relaxed Extended JSON representation of a BSON value

MongoDB\BSON\toRelaxedExtendedJSON

(mongodb >=1.3.0)

MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value

Descripción

MongoDB\BSON\toRelaxedExtendedJSON ( string $bson ) : string

Converts a BSON string to its » Relaxed Extended JSON representation. The relaxed format prefers use of JSON type primitives at the expense of type fidelity and is most suited for producing output that can be easily consumed by web APIs and humans.

Parámetros

bson (string)

BSON value to be converted.

Valores devueltos

The converted JSON value.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\UnexpectedValueException si la entrada no contiene exactamente un documento BSON. Las posibles razones incluyen, pero no están limitadas a, BSON no válido, datos extra (tras leer el documento BSON), o un error » libbson no esperado.

Ejemplos

Ejemplo #1 MongoDB\BSON\toRelaxedExtendedJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toRelaxedExtendedJSON($bson), "\n";
}

?>

El resultado del ejemplo sería:

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : 123 }
{ "int64" : 4294967295 }
{ "double" : 1.0 }
{ "nan" : { "$numberDouble" : "NaN" } }
{ "pos_inf" : { "$numberDouble" : "Infinity" } }
{ "neg_inf" : { "$numberDouble" : "-Infinity" } }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : { "base64": "Zm9v", "subType" : "00" } } }
{ "date" : { "$date" : "2015-10-28T00:00:00Z" } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regularExpression" : { "pattern" : "pattern", "options" : "i" } } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : 1 } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

Ver también

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • » Extended JSON
  • » MongoDB BSON


La clase MongoDB\BSON\Binary

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\Binary implements MongoDB\BSON\Type {
/* Constantes */
const integer TYPE_GENERIC = 0 ;
const integer TYPE_FUNCTION = 1 ;
const integer TYPE_OLD_BINARY = 2 ;
const integer TYPE_OLD_UUID = 3 ;
const integer TYPE_UUID = 4 ;
const integer TYPE_MD5 = 5 ;
const integer TYPE_USER_DEFINED = 128 ;
/* Métodos */
final public __construct ( string $data , int $type )
final public getData ( ) : string
final public getType ( ) : int
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Constantes predefinidas

MongoDB\BSON\Binary::TYPE_GENERIC

MongoDB\BSON\Binary::TYPE_FUNCTION

MongoDB\BSON\Binary::TYPE_OLD_BINARY

MongoDB\BSON\Binary::TYPE_OLD_UUID

MongoDB\BSON\Binary::TYPE_UUID

MongoDB\BSON\Binary::TYPE_MD5

MongoDB\BSON\Binary::TYPE_USER_DEFINED

Tabla de contenidos

  • MongoDB\BSON\Binary::__construct — Construct a new Binary
  • MongoDB\BSON\Binary::getData — Returns the Binary's data
  • MongoDB\BSON\Binary::getType — Returns the Binary's type
  • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Binary::serialize — Serialize a Binary
  • MongoDB\BSON\Binary::__toString — Returns the Binary's data
  • MongoDB\BSON\Binary::unserialize — Unserialize a Binary


Construct a new Binary

  • « MongoDB\BSON\Binary
  • MongoDB\BSON\Binary::getData »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Construct a new Binary

MongoDB\BSON\Binary::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Binary::__construct — Construct a new Binary

Descripción

final public MongoDB\BSON\Binary::__construct ( string $data , int $type )

Parámetros

data (string)

Binary data.

type (int)

Unsigned 8-bit integer denoting the data's type.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if type is not an unsigned 8-bit integer.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if type is MongoDB\BSON\Binary::TYPE_UUID or MongoDB\BSON\Binary::TYPE_OLD_UUID and data is not exactly 16 bytes in length.

Historial de cambios

Versión | Descripción
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if type is MongoDB\BSON\Binary::TYPE_UUID or MongoDB\BSON\Binary::TYPE_OLD_UUID and data is not exactly 16 bytes in length.
PECL mongodb 1.1.3 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if type is not an unsigned 8-bit integer.

Ejemplos

Ejemplo #1 MongoDB\BSON\Binary::__construct() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary);

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\Binary)#1 (2) {
  ["data"]=>
  string(3) "foo"
  ["type"]=>
  int(0)
}

Ver también

  • » BSON Types


Returns the Binary's data

  • « MongoDB\BSON\Binary::__construct
  • MongoDB\BSON\Binary::getType »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's data

MongoDB\BSON\Binary::getData

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getData — Returns the Binary's data

Descripción

final public MongoDB\BSON\Binary::getData ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Binary's data.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Binary::getData() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getData());

?>

El resultado del ejemplo sería:

string(3) "foo"

Ver también

  • » BSON Types


Returns the Binary's type

  • « MongoDB\BSON\Binary::getData
  • MongoDB\BSON\Binary::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's type

MongoDB\BSON\Binary::getType

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getType — Returns the Binary's type

Descripción

final public MongoDB\BSON\Binary::getType ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Binary's type.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Binary::getType() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getType());

?>

El resultado del ejemplo sería:

int(0)

Ver también

  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\Binary::getType
  • MongoDB\BSON\Binary::serialize »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Binary::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\Binary::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Binary.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Binary

  • « MongoDB\BSON\Binary::jsonSerialize
  • MongoDB\BSON\Binary::__toString »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Serialize a Binary

MongoDB\BSON\Binary::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::serialize — Serialize a Binary

Descripción

final public MongoDB\BSON\Binary::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\Binary.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\Binary::unserialize() - Unserialize a Binary
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the Binary's data

  • « MongoDB\BSON\Binary::serialize
  • MongoDB\BSON\Binary::unserialize »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's data

MongoDB\BSON\Binary::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Binary::__toString — Returns the Binary's data

Descripción

final public MongoDB\BSON\Binary::__toString ( ) : string

Este método es un alias de: MongoDB\BSON\Binary::getData().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Binary's data.

Ejemplos

Ejemplo #1 MongoDB\BSON\Binary::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC));

?>

El resultado del ejemplo sería:

string(3) "foo"

Ver también

  • MongoDB\BSON\Binary::getData() - Returns the Binary's data
  • » BSON Types


Unserialize a Binary

  • « MongoDB\BSON\Binary::__toString
  • MongoDB\BSON\Decimal128 »
  • PHP Manual
  • MongoDB\BSON\Binary
  • Unserialize a Binary

MongoDB\BSON\Binary::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::unserialize — Unserialize a Binary

Descripción

final public MongoDB\BSON\Binary::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\Binary.

Valores devueltos

Returns the unserialized MongoDB\BSON\Binary.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\Binary::serialize() - Serialize a Binary
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


The MongoDB\BSON\Decimal128 class

(mongodb >=1.2.0)

Introducción

BSON type for the » Decimal128 floating-point format, which supports numbers with up to 34 decimal digits (i.e. significant digits) and an exponent range of -6143 to +6144.

Unlike the double BSON type (i.e. float in PHP), which only stores an approximation of the decimal values, the decimal data type stores the exact value. For example, MongoDB\BSON\Decimal128('9.99') has a precise value of 9.99 where as a double 9.99 would have an approximate value of 9.9900000000000002131628….

Nota: MongoDB\BSON\Decimal128 solamente es compatible con MongoDB 3.4+. Intentar usar el tipo BSON con una versión anterior de MongoDB resultará en un error.

Sinopsis de la Clase

final MongoDB\BSON\Decimal128 implements MongoDB\BSON\Decimal128Interface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Métodos */
final public __construct ( string $value = ? )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Historial de cambios

Versión | Descripción
PECL mongodb 1.3.0 | Implements MongoDB\BSON\Decimal128Interface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Tabla de contenidos

  • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
  • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
  • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
  • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128


Construct a new Decimal128

  • « MongoDB\BSON\Decimal128
  • MongoDB\BSON\Decimal128::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Construct a new Decimal128

MongoDB\BSON\Decimal128::__construct

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128

Descripción

final public MongoDB\BSON\Decimal128::__construct ( string $value = ? )

Nota: MongoDB\BSON\Decimal128 solamente es compatible con MongoDB 3.4+. Intentar usar el tipo BSON con una versión anterior de MongoDB resultará en un error.

Parámetros

value (string)

A decimal string.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if value is not a valid decimal string.

Ejemplos

Ejemplo #1 MongoDB\BSON\Decimal128::__construct() example

<?php

var_dump(new MongoDB\BSON\Decimal128(1234.5678));
var_dump(new MongoDB\BSON\Decimal128(NAN));
var_dump(new MongoDB\BSON\Decimal128(INF));

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(9) "1234.5678"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(3) "NaN"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(8) "Infinity"
}

Ver también

  • » Decimal128 floating-point format
  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\Decimal128::__construct
  • MongoDB\BSON\Decimal128::serialize »
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Decimal128::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\Decimal128::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Decimal128.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Decimal128

  • « MongoDB\BSON\Decimal128::jsonSerialize
  • MongoDB\BSON\Decimal128::__toString »
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Serialize a Decimal128

MongoDB\BSON\Decimal128::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128

Descripción

final public MongoDB\BSON\Decimal128::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\Decimal128.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\Decimal128::unserialize() - Unserialize a Decimal128
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the string representation of this Decimal128

  • « MongoDB\BSON\Decimal128::serialize
  • MongoDB\BSON\Decimal128::unserialize »
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Returns the string representation of this Decimal128

MongoDB\BSON\Decimal128::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128

Descripción

final public MongoDB\BSON\Decimal128::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this Decimal128.

Ejemplos

Ejemplo #1 MongoDB\BSON\Decimal128::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Decimal128(1234.5678));
var_dump((string) new MongoDB\BSON\Decimal128(NAN));
var_dump((string) new MongoDB\BSON\Decimal128(INF));

?>

El resultado del ejemplo sería algo similar a:

string(9) "1234.5678"
string(3) "NaN"
string(8) "Infinity"

Ver también

  • » Decimal128 floating-point format
  • » BSON Types


Unserialize a Decimal128

  • « MongoDB\BSON\Decimal128::__toString
  • MongoDB\BSON\Javascript »
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Unserialize a Decimal128

MongoDB\BSON\Decimal128::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128

Descripción

final public MongoDB\BSON\Decimal128::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\Decimal128.

Valores devueltos

Returns the unserialized MongoDB\BSON\Decimal128.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\Decimal128::serialize() - Serialize a Decimal128
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\Javascript

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\Javascript implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( string $code , array|object $scope = ? )
final public getCode ( ) : string
final public getScope ( ) : object|null
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
  • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
  • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
  • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
  • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
  • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript


Construct a new Javascript

  • « MongoDB\BSON\Javascript
  • MongoDB\BSON\Javascript::getCode »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Construct a new Javascript

MongoDB\BSON\Javascript::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Javascript::__construct — Construct a new Javascript

Descripción

final public MongoDB\BSON\Javascript::__construct ( string $code , array|object $scope = ? )

Parámetros

code (string)

Javascript code.

scope (array|object)

Javascript scope.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if code contains null bytes.

Historial de cambios

Versión | Descripción
PECL mongodb 1.2.0 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if code contains null bytes. Previously, values would be truncated at the first null byte.

Ejemplos

Ejemplo #1 MongoDB\BSON\Javascript::__construct() example

<?php

$code = new MongoDB\BSON\Javascript('function() { return 1; }');
var_dump($code);

$codews = new MongoDB\BSON\Javascript('function() { return foo; }', ['foo' => 'bar']);
var_dump($codews);

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\Javascript)#1 (2) {
  ["javascript"]=>
  string(24) "function() { return 1; }"
  ["scope"]=>
  object(stdClass)#2 (0) {
  }
}
object(MongoDB\BSON\Javascript)#2 (2) {
  ["javascript"]=>
  string(26) "function() { return foo; }"
  ["scope"]=>
  object(stdClass)#1 (1) {
    ["foo"]=>
    string(3) "bar"
  }
}

Ver también

  • » BSON Types


Returns the Javascript's code

  • « MongoDB\BSON\Javascript::__construct
  • MongoDB\BSON\Javascript::getScope »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's code

MongoDB\BSON\Javascript::getCode

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getCode — Returns the Javascript's code

Descripción

final public MongoDB\BSON\Javascript::getCode ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Javascript's code.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Javascript::getCode() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getCode());

?>

El resultado del ejemplo sería:

string(33) "function foo(bar) { return bar; }"

Ver también

  • » BSON Types


Returns the Javascript's scope document

  • « MongoDB\BSON\Javascript::getCode
  • MongoDB\BSON\Javascript::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's scope document

MongoDB\BSON\Javascript::getScope

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document

Descripción

final public MongoDB\BSON\Javascript::getScope ( ) : object|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Javascript's scope document, or null if the is no scope.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Javascript::getScope() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getScope());

$js = new MongoDB\BSON\Javascript('function foo() { return foo; }', ['foo' => 42]);
var_dump($js->getScope());

?>

El resultado del ejemplo sería:

NULL
object(stdClass)#1 (1) {
  ["foo"]=>
  int(42)
}

Ver también

  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\Javascript::getScope
  • MongoDB\BSON\Javascript::serialize »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Javascript::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\Javascript::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Javascript.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Javascript

  • « MongoDB\BSON\Javascript::jsonSerialize
  • MongoDB\BSON\Javascript::__toString »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Serialize a Javascript

MongoDB\BSON\Javascript::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::serialize — Serialize a Javascript

Descripción

final public MongoDB\BSON\Javascript::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\Javascript.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\Javascript::unserialize() - Unserialize a Javascript
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the Javascript's code

  • « MongoDB\BSON\Javascript::serialize
  • MongoDB\BSON\Javascript::unserialize »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's code

MongoDB\BSON\Javascript::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::__toString — Returns the Javascript's code

Descripción

final public MongoDB\BSON\Javascript::__toString ( ) : string

Este método es un alias de: MongoDB\BSON\Javascript::getCode().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Javascript's code.

Ejemplos

Ejemplo #1 MongoDB\BSON\Javascript::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Javascript('function foo(bar) { return bar; }'));

?>

El resultado del ejemplo sería:

string(33) "function foo(bar) { return bar; }"

Ver también

  • MongoDB\BSON\Javascript::getCode() - Returns the Javascript's code
  • » BSON Types


Unserialize a Javascript

  • « MongoDB\BSON\Javascript::__toString
  • MongoDB\BSON\MaxKey »
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Unserialize a Javascript

MongoDB\BSON\Javascript::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript

Descripción

final public MongoDB\BSON\Javascript::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\Javascript.

Valores devueltos

Returns the unserialized MongoDB\BSON\Javascript.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\Javascript::serialize() - Serialize a Javascript
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\MaxKey

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\MaxKey implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
  • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
  • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey


Construct a new MaxKey

  • « MongoDB\BSON\MaxKey
  • MongoDB\BSON\MaxKey::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Construct a new MaxKey

MongoDB\BSON\MaxKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey

Descripción

final public MongoDB\BSON\MaxKey::__construct ( )

Parámetros

Esta función no tiene parámetros.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\MaxKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MaxKey());

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\MaxKey)#1 (0) {
}

Ver también

  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\MaxKey::__construct
  • MongoDB\BSON\MaxKey::serialize »
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Returns a representation that can be converted to JSON

MongoDB\BSON\MaxKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\MaxKey::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\MaxKey.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a MaxKey

  • « MongoDB\BSON\MaxKey::jsonSerialize
  • MongoDB\BSON\MaxKey::unserialize »
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Serialize a MaxKey

MongoDB\BSON\MaxKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey

Descripción

final public MongoDB\BSON\MaxKey::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\MaxKey.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\MaxKey::unserialize() - Unserialize a MaxKey
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Unserialize a MaxKey

  • « MongoDB\BSON\MaxKey::serialize
  • MongoDB\BSON\MinKey »
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Unserialize a MaxKey

MongoDB\BSON\MaxKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey

Descripción

final public MongoDB\BSON\MaxKey::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\MaxKey.

Valores devueltos

Returns the unserialized MongoDB\BSON\MaxKey.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\MaxKey::serialize() - Serialize a MaxKey
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\MinKey

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\MinKey implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
  • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
  • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey


Construct a new MinKey

  • « MongoDB\BSON\MinKey
  • MongoDB\BSON\MinKey::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Construct a new MinKey

MongoDB\BSON\MinKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MinKey::__construct — Construct a new MinKey

Descripción

final public MongoDB\BSON\MinKey::__construct ( )

Parámetros

Esta función no tiene parámetros.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\MinKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MinKey());

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\MinKey)#1 (0) {
}

Ver también

  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\MinKey::__construct
  • MongoDB\BSON\MinKey::serialize »
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Returns a representation that can be converted to JSON

MongoDB\BSON\MinKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\MinKey::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\MinKey.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a MinKey

  • « MongoDB\BSON\MinKey::jsonSerialize
  • MongoDB\BSON\MinKey::unserialize »
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Serialize a MinKey

MongoDB\BSON\MinKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::serialize — Serialize a MinKey

Descripción

final public MongoDB\BSON\MinKey::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\MinKey.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\MinKey::unserialize() - Unserialize a MinKey
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Unserialize a MinKey

  • « MongoDB\BSON\MinKey::serialize
  • MongoDB\BSON\ObjectID »
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Unserialize a MinKey

MongoDB\BSON\MinKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey

Descripción

final public MongoDB\BSON\MinKey::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\MinKey.

Valores devueltos

Returns the unserialized MongoDB\BSON\MinKey.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\MinKey::serialize() - Serialize a MinKey
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\ObjectID

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\ObjectID implements MongoDB\BSON\Type {
/* Métodos */
final public MongoDB\BSON\ObjectId::__construct ( string $id = ? )
final public MongoDB\BSON\ObjectId::getTimestamp ( ) : int
final public MongoDB\BSON\ObjectId::jsonSerialize ( ) : mixed
final public MongoDB\BSON\ObjectId::serialize ( ) : string
final public MongoDB\BSON\ObjectId::__toString ( ) : string
final public MongoDB\BSON\ObjectId::unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId
  • MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId
  • MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId
  • MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId
  • MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId


Construct a new ObjectId

  • « MongoDB\BSON\ObjectID
  • MongoDB\BSON\ObjectId::getTimestamp »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Construct a new ObjectId

MongoDB\BSON\ObjectId::__construct

(mongodb >=1.0.0)

MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId

Descripción

final public MongoDB\BSON\ObjectId::__construct ( string $id = ? )

Parámetros

id (string)

A 24-character hexadecimal string. If not provided, the driver will generate an ObjectId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if id is not a 24-character hexadecimal string.

Ejemplos

Ejemplo #1 MongoDB\BSON\ObjectId::__construct() example

<?php

var_dump(new MongoDB\BSON\ObjectId());

var_dump(new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\BSON\ObjectId)#1 (1) {
  ["oid"]=>
  string(24) "56732d3dda14d81214634921"
}
object(MongoDB\BSON\ObjectId)#1 (1) {
  ["oid"]=>
  string(24) "000000000000000000000001"
}

Ver también

  • » ObjectId Reference
  • » BSON Types: ObjectId


Returns the timestamp component of this ObjectId

  • « MongoDB\BSON\ObjectId::__construct
  • MongoDB\BSON\ObjectId::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Returns the timestamp component of this ObjectId

MongoDB\BSON\ObjectId::getTimestamp

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId

Descripción

final public MongoDB\BSON\ObjectId::getTimestamp ( ) : int

The timestamp component of an ObjectId is its most significant 32 bits, which denotes the number of seconds since the Unix epoch. This value is read as an unsigned 32-bit integer with big-endian byte order.

Nota: Debido a que le tipo de entero de PHP es con signo, algunos valores devueltos por este método podrían aparecer como enteros negativos en plataformas de 32 bits. El formateador "%u" de sprintf() se puede usar para obtener una representación de string del valor decimal sin signo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the timestamp component of this ObjectId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\ObjectId::getTimestamp() example

<?php

var_dump((new MongoDB\BSON\ObjectId())->getTimestamp());

var_dump((new MongoDB\BSON\ObjectId('0000002a0000000000000000'))->getTimestamp());

?>

El resultado del ejemplo sería algo similar a:

integer(1484854719)
integer(42)

Ver también

  • » ObjectId Reference
  • » BSON Types: ObjectId


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\ObjectId::getTimestamp
  • MongoDB\BSON\ObjectId::serialize »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Returns a representation that can be converted to JSON

MongoDB\BSON\ObjectId::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\ObjectId::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\ObjectId.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize an ObjectId

  • « MongoDB\BSON\ObjectId::jsonSerialize
  • MongoDB\BSON\ObjectId::__toString »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Serialize an ObjectId

MongoDB\BSON\ObjectId::serialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId

Descripción

final public MongoDB\BSON\ObjectId::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\ObjectId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\ObjectId::unserialize() - Unserialize an ObjectId
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the hexidecimal representation of this ObjectId

  • « MongoDB\BSON\ObjectId::serialize
  • MongoDB\BSON\ObjectId::unserialize »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Returns the hexidecimal representation of this ObjectId

MongoDB\BSON\ObjectId::__toString

(mongodb >=1.0.0)

MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId

Descripción

final public MongoDB\BSON\ObjectId::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the hexidecimal representation of this ObjectId.

Ejemplos

Ejemplo #1 MongoDB\BSON\ObjectId::__toString() example

<?php

var_dump((string) new MongoDB\BSON\ObjectId());
var_dump((string) new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

El resultado del ejemplo sería algo similar a:

string(24) "56731b49da14d8747d701211"
string(24) "000000000000000000000001"

Ver también

  • » ObjectId Reference
  • » BSON Types: ObjectId


Unserialize an ObjectId

  • « MongoDB\BSON\ObjectId::__toString
  • MongoDB\BSON\Regex »
  • PHP Manual
  • MongoDB\BSON\ObjectID
  • Unserialize an ObjectId

MongoDB\BSON\ObjectId::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId

Descripción

final public MongoDB\BSON\ObjectId::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\ObjectId.

Valores devueltos

Returns the unserialized MongoDB\BSON\ObjectId.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\ObjectId::serialize() - Serialize an ObjectId
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\Regex

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\Regex implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( string $pattern , string $flags = "" )
final public getFlags ( ) : string
final public getPattern ( ) : string
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\Regex::__construct — Construct a new Regex
  • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
  • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
  • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Regex::serialize — Serialize a Regex
  • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
  • MongoDB\BSON\Regex::unserialize — Unserialize a Regex


Construct a new Regex

  • « MongoDB\BSON\Regex
  • MongoDB\BSON\Regex::getFlags »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Construct a new Regex

MongoDB\BSON\Regex::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__construct — Construct a new Regex

Descripción

final public MongoDB\BSON\Regex::__construct ( string $pattern , string $flags = "" )

Parámetros

pattern (string)

The regular expression pattern.

Nota: The pattern should not be wrapped with delimiter characters.

flags (string)

The » regular expression flags. Characters in this argument will be sorted alphabetically.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if pattern or flags contain null bytes.

Historial de cambios

Versión Descripción
PECL mongodb 1.2.0

The flags argument is optional and defaults to an empty string.

Characters in the flags argument will be sorted alphabetically when a Regex is constructed. Previously, the characters were stored in the order provided.

MongoDB\Driver\Exception\InvalidArgumentException is thrown if pattern or flags contain null bytes. Previously, values would be truncated at the first null byte.

Ejemplos

Ejemplo #1 MongoDB\BSON\Regex::__construct() example

<?php

$regex = new MongoDB\BSON\Regex('^foo', 'i');
var_dump($regex);

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\Regex)#1 (2) {
  ["pattern"]=>
  string(4) "^foo"
  ["flags"]=>
  string(1) "i"
}

Ver también

  • » BSON Types
  • » Supported regular expression flags


Returns the Regex's flags

  • « MongoDB\BSON\Regex::__construct
  • MongoDB\BSON\Regex::getPattern »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the Regex's flags

MongoDB\BSON\Regex::getFlags

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getFlags — Returns the Regex's flags

Descripción

final public MongoDB\BSON\Regex::getFlags ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Regex's flags.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Regex::getFlags() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getFlags());

?>

El resultado del ejemplo sería algo similar a:

string(1) "i"

Ver también

  • » BSON Types
  • » Supported regular expression flags


Returns the Regex's pattern

  • « MongoDB\BSON\Regex::getFlags
  • MongoDB\BSON\Regex::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the Regex's pattern

MongoDB\BSON\Regex::getPattern

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern

Descripción

final public MongoDB\BSON\Regex::getPattern ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the Regex's pattern.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Regex::getPattern() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getPattern());

?>

El resultado del ejemplo sería algo similar a:

string(5) "regex"

Ver también

  • » BSON Types


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\Regex::getPattern
  • MongoDB\BSON\Regex::serialize »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Regex::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\Regex::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Regex.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Regex

  • « MongoDB\BSON\Regex::jsonSerialize
  • MongoDB\BSON\Regex::__toString »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Serialize a Regex

MongoDB\BSON\Regex::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::serialize — Serialize a Regex

Descripción

final public MongoDB\BSON\Regex::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\Regex.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\Regex::unserialize() - Unserialize a Regex
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the string representation of this Regex

  • « MongoDB\BSON\Regex::serialize
  • MongoDB\BSON\Regex::unserialize »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the string representation of this Regex

MongoDB\BSON\Regex::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex

Descripción

final public MongoDB\BSON\Regex::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this Regex.

Ejemplos

Ejemplo #1 MongoDB\BSON\Regex::__toString() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump((string) $regex);

?>

El resultado del ejemplo sería:

string(8) "/regex/i"

Ver también

  • » BSON Types


Unserialize a Regex

  • « MongoDB\BSON\Regex::__toString
  • MongoDB\BSON\Timestamp »
  • PHP Manual
  • MongoDB\BSON\Regex
  • Unserialize a Regex

MongoDB\BSON\Regex::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::unserialize — Unserialize a Regex

Descripción

final public MongoDB\BSON\Regex::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\Regex.

Valores devueltos

Returns the unserialized MongoDB\BSON\Regex.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\Regex::serialize() - Serialize a Regex
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\Timestamp

(mongodb >=1.0.0)

Introducción

Represents a » BSON timestamp, which is an internal MongoDB type not intended for general date storage.

Sinopsis de la Clase

MongoDB\BSON\Timestamp implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( int $increment , int $timestamp )
final public getIncrement ( ) : int
final public getTimestamp ( ) : int
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
  • MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp
  • MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp
  • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
  • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
  • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp


Construct a new Timestamp

  • « MongoDB\BSON\Timestamp
  • MongoDB\BSON\Timestamp::getIncrement »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Construct a new Timestamp

MongoDB\BSON\Timestamp::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp

Descripción

final public MongoDB\BSON\Timestamp::__construct ( int $increment , int $timestamp )

Parámetros

increment (int)

32-bit integer denoting the incrementing ordinal for operations within a given second.

timestamp (int)

32-bit integer denoting seconds since the Unix epoch.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\Timestamp::__construct() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);

?>

El resultado del ejemplo sería:

object(MongoDB\BSON\Timestamp)#1 (2) {
  ["increment"]=>
  int(1234)
  ["timestamp"]=>
  int(5678)
}

Ver también

  • » BSON Types: Timestamps


Returns the increment component of this Timestamp

  • « MongoDB\BSON\Timestamp::__construct
  • MongoDB\BSON\Timestamp::getTimestamp »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the increment component of this Timestamp

MongoDB\BSON\Timestamp::getIncrement

(mongodb >=1.3.0)

MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp

Descripción

final public MongoDB\BSON\Timestamp::getIncrement ( ) : int

The increment component of a Timestamp is its least significant 32 bits, whichs denotes the incrementing ordinal for operations within a given second. This value is read as an unsigned 32-bit integer with big-endian byte order.

Nota: Debido a que le tipo de entero de PHP es con signo, algunos valores devueltos por este método podrían aparecer como enteros negativos en plataformas de 32 bits. El formateador "%u" de sprintf() se puede usar para obtener una representación de string del valor decimal sin signo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the increment component of this Timestamp.

Advertencia

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • » BSON Types: Timestamps


Returns the timestamp component of this Timestamp

  • « MongoDB\BSON\Timestamp::getIncrement
  • MongoDB\BSON\Timestamp::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the timestamp component of this Timestamp

MongoDB\BSON\Timestamp::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp

Descripción

final public MongoDB\BSON\Timestamp::getTimestamp ( ) : int

The timestamp component of a Timestamp is its most significant 32 bits, which denotes the number of seconds since the Unix epoch. This value is read as an unsigned 32-bit integer with big-endian byte order.

Nota: Debido a que le tipo de entero de PHP es con signo, algunos valores devueltos por este método podrían aparecer como enteros negativos en plataformas de 32 bits. El formateador "%u" de sprintf() se puede usar para obtener una representación de string del valor decimal sin signo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the timestamp component of this Timestamp.

Advertencia

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • » BSON Types: Timestamps


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\Timestamp::getTimestamp
  • MongoDB\BSON\Timestamp::serialize »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Timestamp::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\Timestamp::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Timestamp.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Timestamp

  • « MongoDB\BSON\Timestamp::jsonSerialize
  • MongoDB\BSON\Timestamp::__toString »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Serialize a Timestamp

MongoDB\BSON\Timestamp::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp

Descripción

final public MongoDB\BSON\Timestamp::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\Timestamp.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\Timestamp::unserialize() - Unserialize a Timestamp
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the string representation of this Timestamp

  • « MongoDB\BSON\Timestamp::serialize
  • MongoDB\BSON\Timestamp::unserialize »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the string representation of this Timestamp

MongoDB\BSON\Timestamp::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp

Descripción

final public MongoDB\BSON\Timestamp::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this Timestamp.

Ejemplos

Ejemplo #1 MongoDB\BSON\Timestamp::__toString() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);
var_dump((string) $timestamp);

?>

El resultado del ejemplo sería algo similar a:

string(11) "[1234:5678]"

Ver también

  • » BSON Types: Timestamps


Unserialize a Timestamp

  • « MongoDB\BSON\Timestamp::__toString
  • MongoDB\BSON\UTCDateTime »
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Unserialize a Timestamp

MongoDB\BSON\Timestamp::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp

Descripción

final public MongoDB\BSON\Timestamp::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\Timestamp.

Valores devueltos

Returns the unserialized MongoDB\BSON\Timestamp.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\Timestamp::serialize() - Serialize a Timestamp
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


La clase MongoDB\BSON\UTCDatetime

(mongodb >=1.0.0)

Introducción

Represents a » BSON date.

Sinopsis de la Clase

MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type {
/* Métodos */
final public __construct ( int|float|string|DateTimeInterface $milliseconds = null )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public toDateTime ( ) : DateTime
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
  • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
  • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime


Construct a new UTCDateTime

  • « MongoDB\BSON\UTCDateTime
  • MongoDB\BSON\UTCDateTime::jsonSerialize »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Construct a new UTCDateTime

MongoDB\BSON\UTCDateTime::__construct

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime

Descripción

final public MongoDB\BSON\UTCDateTime::__construct ( int|float|string|DateTimeInterface $milliseconds = null )

Parámetros

milliseconds (int|float|string|DateTimeInterface)

Number of milliseconds since the Unix epoch (Jan 1, 1970). Negative values represent dates before 1970. This value may be provided as a 64-bit int. For compatibility on 32-bit systems, this parameter may also be provided as a float or string.

If the argument is a DateTimeInterface, the number of milliseconds since the Unix epoch will be derived from that value. Note that in versions of PHP versions before 7.1.0, DateTime and DateTimeImmutable objects constructed from the current time did not incorporate sub-second precision.

If this argument is null, the current time will be used by default.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Historial de cambios

Versión | Descripción
PECL mongodb 1.2.0 | The milliseconds argument is optional and defaults to null (i.e. current time). The argument also accepts a DateTimeInterface, which may be used to derive the number of milliseconds since the Unix epoch. Previously, only int, float, and string types were accepted.

Ejemplos

Ejemplo #1 MongoDB\BSON\UTCDateTime::__construct() example

<?php

var_dump(new MongoDB\BSON\UTCDateTime);

var_dump(new MongoDB\BSON\UTCDateTime(new DateTime));

var_dump(new MongoDB\BSON\UTCDateTime(1416445411987));

?>

El resultado del ejemplo sería algo similar a:

object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1416445411987"
}

Ver también

  • » BSON Types: Date


Returns a representation that can be converted to JSON

  • « MongoDB\BSON\UTCDateTime::__construct
  • MongoDB\BSON\UTCDateTime::serialize »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns a representation that can be converted to JSON

MongoDB\BSON\UTCDateTime::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON

Descripción

final public MongoDB\BSON\UTCDateTime::jsonSerialize ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\UTCDateTime.

Nota: La salida es consitente con la función MongoDB\BSON\toJSON(), la cual usa el formato JSON extendido antiguo específico del controlador. Esto no necesariamente coincide con las represntaciones extendidas JSON » relajada o » canónica usadas por MongoDB\BSON\toRelaxedExtendedJSON() y MongoDB\BSON\toCanonicalExtendedJSON(), respectivamente.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • JsonSerializable::jsonSerialize() - Especifica los datos que deberían serializarse para JSON
  • json_encode() - Retorna la representación JSON del valor dado
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a UTCDateTime

  • « MongoDB\BSON\UTCDateTime::jsonSerialize
  • MongoDB\BSON\UTCDateTime::toDateTime »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Serialize a UTCDateTime

MongoDB\BSON\UTCDateTime::serialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime

Descripción

final public MongoDB\BSON\UTCDateTime::serialize ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the serialized representation of the MongoDB\BSON\UTCDateTime.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ver también

  • MongoDB\BSON\UTCDateTime::unserialize() - Unserialize a UTCDateTime
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serializing Objects


Returns the DateTime representation of this UTCDateTime

  • « MongoDB\BSON\UTCDateTime::serialize
  • MongoDB\BSON\UTCDateTime::__toString »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns the DateTime representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::toDateTime

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime

Descripción

final public MongoDB\BSON\UTCDateTime::toDateTime ( ) : DateTime

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the DateTime representation of this UTCDateTime. The returned DateTime will use the UTC time zone.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.

Ejemplos

Ejemplo #1 MongoDB\BSON\UTCDatetime::toDateTime() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
$datetime = $utcdatetime->toDateTime();
var_dump($datetime->format('r'));
var_dump($datetime->format('U.u'));
var_dump($datetime->getTimezone());

?>

El resultado del ejemplo sería algo similar a:

string(31) "Thu, 20 Nov 2014 01:03:31 +0000"
string(17) "1416445411.987000"
object(DateTimeZone)#3 (2) {
  ["timezone_type"]=>
  int(1)
  ["timezone"]=>
  string(6) "+00:00"
}

Ver también

  • » BSON Types: Date


Returns the string representation of this UTCDateTime

  • « MongoDB\BSON\UTCDateTime::toDateTime
  • MongoDB\BSON\UTCDateTime::unserialize »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns the string representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::__toString

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime

Descripción

final public MongoDB\BSON\UTCDateTime::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this UTCDateTime.

Ejemplos

Ejemplo #1 MongoDB\BSON\UTCDateTime::__toString() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
var_dump((string) $utcdatetime);

?>

El resultado del ejemplo sería:

string(13) "1416445411987"

Ver también

  • » BSON Types: Date


Unserialize a UTCDateTime

  • « MongoDB\BSON\UTCDateTime::__toString
  • MongoDB\BSON\Type »
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Unserialize a UTCDateTime

MongoDB\BSON\UTCDateTime::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime

Descripción

final public MongoDB\BSON\UTCDateTime::unserialize ( string $serialized ) : void

Parámetros

serialized

The serialized MongoDB\BSON\UTCDateTime.

Valores devueltos

Returns the unserialized MongoDB\BSON\UTCDateTime.

Errores/Excepciones

  • Lanza una MongoDB\Driver\Exception\InvalidArgumentException en errores de análisis de argumentos.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ver también

  • MongoDB\BSON\UTCDateTime::serialize() - Serialize a UTCDateTime
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serializing Objects


  • « MongoDB\BSON\UTCDateTime::unserialize
  • MongoDB\BSON\Persistable »
  • PHP Manual
  • MongoDB\BSON
  • La interfaz MongoDB\BSON\Type

La interfaz MongoDB\BSON\Type

(mongodb >=1.0.0)

Introducción

Sinopsis de la Clase

MongoDB\BSON\Type {
}


La interfaz MongoDB\BSON\Persistable

(mongodb >=1.0.0)

Introducción

Las clases podrían implementar esta interfaz para tomar ventaja de comportamiento del ODM («object document mapping») automático del controlador. Durante la serialización, el controlador inyectará una propiedad __pclass que contiene el nombre de la clase de PHP dentro de los datos devueltos por MongoDB\BSON\Serializable::bsonSerialize(). Durante la deserialización, se utilizará la misma propiedad __pclass para inferir la clase de PHP (ndependientemente de cualquier configuración type map) a construir antes de que MongoDB\BSON\Unserializable::bsonUnserialize() sea invocado. Véase Persistencia de datos para información adicional.

Nota:

Incluso si MongoDB\BSON\Serializable::bsonSerialize() devuelve un array secuencial, las inyecciones de la propiedad __pclass causarán que el objeto sea serializado como un documento BSON.

Sinopsis de la Clase

MongoDB\BSON\Persistable implements MongoDB\BSON\Unserializable , MongoDB\BSON\Serializable {
/* Métodos heredados */
abstract public MongoDB\BSON\Serializable::bsonSerialize ( ) : array|object
abstract public MongoDB\BSON\Unserializable::bsonUnserialize ( array $data ) : void
}


La interfaz MongoDB\BSON\Serializable

(mongodb >=1.0.0)

Introducción

Las clases que implementan esta interfaz podrían devolver datos para ser serializados como un array o documento BSON en lugar de las propiedades públicas del objeto.

Sinopsis de la Clase

MongoDB\BSON\Serializable implements MongoDB\BSON\Type {
/* Métodos */
abstract public bsonSerialize ( ) : array|object
}

Tabla de contenidos

  • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON


Provides an array or document to serialize as BSON

  • « MongoDB\BSON\Serializable
  • MongoDB\BSON\Unserializable »
  • PHP Manual
  • MongoDB\BSON\Serializable
  • Provides an array or document to serialize as BSON

MongoDB\BSON\Serializable::bsonSerialize

(mongodb >=1.0.0)

MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON

Descripción

abstract public MongoDB\BSON\Serializable::bsonSerialize ( ) : array|object

Called during serialization of the object to BSON. The method must return an array or stdClass.

Root documents (e.g. a MongoDB\BSON\Serializable passed to MongoDB\BSON\fromPHP()) will always be serialized as a BSON document. For field values, associative arrays and stdClass instances will be serialized as a BSON document and sequential arrays (i.e. sequential, numeric indexes starting at 0) will be serialized as a BSON array.

Users are encouraged to include an _id property (e.g. a MongoDB\BSON\ObjectId initialized in your constructor) when returning data for a BSON root document; otherwise, the driver or database will need to generate a MongoDB\BSON\ObjectId when inserting or upserting the document, respectively.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array or stdClass to be serialized as a BSON array or document.

Ejemplos

Ejemplo #1 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for root document

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    private $id;

    function __construct()
    {
        $this->id = new MongoDB\BSON\ObjectId;
    }

    function bsonSerialize()
    {
        return ['_id' => $this->id, 'foo' => 'bar'];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyDocument);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

El resultado del ejemplo sería algo similar a:

{ "_id" : { "$oid" : "56cccdcada14d8755a58c591" }, "foo" : "bar" }

Ejemplo #2 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for root document

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyArray);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

El resultado del ejemplo sería:

{ "0" : 1, "1" : 2, "2" : 3 }

Ejemplo #3 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for document field

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return ['foo' => 'bar'];
    }
}

$value = ['document' => new MyDocument];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

El resultado del ejemplo sería:

{ "document" : { "foo" : "bar" } }

Ejemplo #4 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for document field

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$value = ['array' => new MyArray];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

El resultado del ejemplo sería:

{ "array" : [ 1, 2, 3 ] }

Ver también

  • MongoDB\BSON\Unserializable::bsonUnserialize() - Constructs the object from a BSON array or document
  • MongoDB\BSON\Persistable
  • Persistencia de datos


La interfaz MongoDB\BSON\Unserializable

(mongodb >=1.0.0)

Introducción

Las clases que implementen esta interfaz podrían ser especificadas en un mapa de tipos para arrays y documentos de BSON (ambos raíz y embebidos).

Sinopsis de la Clase

MongoDB\BSON\Unserializable {
/* Métodos */
abstract public bsonUnserialize ( array $data ) : void
}

Tabla de contenidos

  • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document


Constructs the object from a BSON array or document

  • « MongoDB\BSON\Unserializable
  • MongoDB\BSON\BinaryInterface »
  • PHP Manual
  • MongoDB\BSON\Unserializable
  • Constructs the object from a BSON array or document

MongoDB\BSON\Unserializable::bsonUnserialize

(mongodb >=1.0.0)

MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document

Descripción

abstract public MongoDB\BSON\Unserializable::bsonUnserialize ( array $data ) : void

Called during unserialization of the object from BSON. The properties of the BSON array or document will be passed to the method as an array.

Remember to check for an _id property when handling data from a BSON document.

Nota: This method acts as the constructor of the object. The __construct() method will not be called after this method.

Parámetros

data (array)

Properties within the BSON array or document.

Valores devueltos

The return value from this method is ignored.

Ejemplos

Ejemplo #1 MongoDB\BSON\Unserializable::bsonUnserialize() example

<?php

class MyDocument implements MongoDB\BSON\Unserializable
{
    private $data = [];

    function bsonUnserialize(array $data)
    {
        $this->data = $data;
    }
}

$bson = MongoDB\BSON\fromJSON('{ "foo": "bar" }');
$value = MongoDB\BSON\toPHP($bson, ['root' => 'MyDocument']);
var_dump($value);

?>

El resultado del ejemplo sería:

object(MyDocument)#1 (1) {
  ["data":"MyDocument":private]=>
  array(1) {
    ["foo"]=>
    string(3) "bar"
  }
}

Ver también

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • MongoDB\BSON\Persistable
  • Persistencia de datos


The MongoDB\BSON\BinaryInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\Binary but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\BinaryInterface {
/* Métodos */
abstract public getData ( ) : string
abstract public getType ( ) : int
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data
  • MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type
  • MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data


Returns the BinaryInterface's data

  • « MongoDB\BSON\BinaryInterface
  • MongoDB\BSON\BinaryInterface::getType »
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's data

MongoDB\BSON\BinaryInterface::getData

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data

Descripción

abstract public MongoDB\BSON\BinaryInterface::getData ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the BinaryInterface's data.

Ver también

  • MongoDB\BSON\Binary::getData() - Returns the Binary's data


Returns the BinaryInterface's type

  • « MongoDB\BSON\BinaryInterface::getData
  • MongoDB\BSON\BinaryInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's type

MongoDB\BSON\BinaryInterface::getType

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type

Descripción

abstract public MongoDB\BSON\BinaryInterface::getType ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the BinaryInterface's type.

Ver también

  • MongoDB\BSON\Binary::getType() - Returns the Binary's type


Returns the BinaryInterface's data

  • « MongoDB\BSON\BinaryInterface::getType
  • MongoDB\BSON\Decimal128Interface »
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's data

MongoDB\BSON\BinaryInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data

Descripción

abstract public MongoDB\BSON\BinaryInterface::__toString ( ) : string

Este método es un alias de: MongoDB\BSON\BinaryInterface::getData().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the BinaryInterface's data.

Ver también

  • MongoDB\BSON\BinaryInterface::getData() - Returns the BinaryInterface's data
  • MongoDB\BSON\Binary::__toString() - Returns the Binary's data


The MongoDB\BSON\Decimal128Interface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\Decimal128 but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\Decimal128Interface {
/* Métodos */
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface


Returns the string representation of this Decimal128Interface

  • « MongoDB\BSON\Decimal128Interface
  • MongoDB\BSON\JavascriptInterface »
  • PHP Manual
  • MongoDB\BSON\Decimal128Interface
  • Returns the string representation of this Decimal128Interface

MongoDB\BSON\Decimal128Interface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface

Descripción

abstract public MongoDB\BSON\Decimal128Interface::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this Decimal128Interface.

Ver también

  • MongoDB\BSON\Decimal128::__toString() - Returns the string representation of this Decimal128


The MongoDB\BSON\JavascriptInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\Javascript but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\JavascriptInterface {
/* Métodos */
abstract public getCode ( ) : string
abstract public getScope ( ) : object|null
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code
  • MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document
  • MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code


Returns the JavascriptInterface's code

  • « MongoDB\BSON\JavascriptInterface
  • MongoDB\BSON\JavascriptInterface::getScope »
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's code

MongoDB\BSON\JavascriptInterface::getCode

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code

Descripción

abstract public MongoDB\BSON\JavascriptInterface::getCode ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the JavascriptInterface's code.

Ver también

  • MongoDB\BSON\Javascript::getCode() - Returns the Javascript's code


Returns the JavascriptInterface's scope document

  • « MongoDB\BSON\JavascriptInterface::getCode
  • MongoDB\BSON\JavascriptInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's scope document

MongoDB\BSON\JavascriptInterface::getScope

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document

Descripción

abstract public MongoDB\BSON\JavascriptInterface::getScope ( ) : object|null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the JavascriptInterface's scope document.

Ver también

  • MongoDB\BSON\Javascript::getScope() - Returns the Javascript's scope document


Returns the JavascriptInterface's code

  • « MongoDB\BSON\JavascriptInterface::getScope
  • MongoDB\BSON\MaxKeyInterface »
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's code

MongoDB\BSON\JavascriptInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code

Descripción

abstract public MongoDB\BSON\JavascriptInterface::__toString ( ) : string

Este método es un alias de: MongoDB\BSON\JavascriptInterface::getCode().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the JavascriptInterface's code.

Ver también

  • MongoDB\BSON\JavascriptInterface::getCode() - Returns the JavascriptInterface's code
  • MongoDB\BSON\Javascript::__toString() - Returns the Javascript's code


The MongoDB\BSON\MaxKeyInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\MaxKey but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\MaxKeyInterface {
}

This interface has no methods.


The MongoDB\BSON\MinKeyInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\MinKey but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\MinKeyInterface {
}

This interface has no methods.


The MongoDB\BSON\ObjectIdInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\ObjectId but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\ObjectIdInterface {
/* Métodos */
abstract public getTimestamp ( ) : int
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface
  • MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface


Returns the timestamp component of this ObjectIdInterface

  • « MongoDB\BSON\ObjectIdInterface
  • MongoDB\BSON\ObjectIdInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\ObjectIdInterface
  • Returns the timestamp component of this ObjectIdInterface

MongoDB\BSON\ObjectIdInterface::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface

Descripción

abstract public MongoDB\BSON\ObjectIdInterface::getTimestamp ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the timestamp component of this ObjectIdInterface.

Ver también

  • MongoDB\BSON\ObjectId::getTimestamp() - Returns the timestamp component of this ObjectId


Returns the hexidecimal representation of this ObjectIdInterface

  • « MongoDB\BSON\ObjectIdInterface::getTimestamp
  • MongoDB\BSON\RegexInterface »
  • PHP Manual
  • MongoDB\BSON\ObjectIdInterface
  • Returns the hexidecimal representation of this ObjectIdInterface

MongoDB\BSON\ObjectIdInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface

Descripción

abstract public MongoDB\BSON\ObjectIdInterface::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the hexidecimal representation of this ObjectIdInterface.

Ver también

  • MongoDB\BSON\ObjectId::__toString() - Returns the hexidecimal representation of this ObjectId


The MongoDB\BSON\RegexInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\Regex but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\RegexInterface {
/* Métodos */
abstract public getFlags ( ) : string
abstract public getPattern ( ) : string
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags
  • MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern
  • MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface


Returns the RegexInterface's flags

  • « MongoDB\BSON\RegexInterface
  • MongoDB\BSON\RegexInterface::getPattern »
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the RegexInterface's flags

MongoDB\BSON\RegexInterface::getFlags

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags

Descripción

abstract public MongoDB\BSON\RegexInterface::getFlags ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the RegexInterface's flags.

Ver también

  • MongoDB\BSON\Regex::getFlags() - Returns the Regex's flags


Returns the RegexInterface's pattern

  • « MongoDB\BSON\RegexInterface::getFlags
  • MongoDB\BSON\RegexInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the RegexInterface's pattern

MongoDB\BSON\RegexInterface::getPattern

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern

Descripción

abstract public MongoDB\BSON\RegexInterface::getPattern ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the RegexInterface's pattern.

Ver también

  • MongoDB\BSON\Regex::getPattern() - Returns the Regex's pattern


Returns the string representation of this RegexInterface

  • « MongoDB\BSON\RegexInterface::getPattern
  • MongoDB\BSON\TimestampInterface »
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the string representation of this RegexInterface

MongoDB\BSON\RegexInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface

Descripción

abstract public MongoDB\BSON\RegexInterface::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this RegexInterface.

Ver también

  • MongoDB\BSON\Regex::__toString() - Returns the string representation of this Regex


The MongoDB\BSON\TimestampInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\Timestamp but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\TimestampInterface {
/* Métodos */
abstract public getIncrement ( ) : int
abstract public getTimestamp ( ) : int
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface
  • MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface
  • MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface


Returns the increment component of this TimestampInterface

  • « MongoDB\BSON\TimestampInterface
  • MongoDB\BSON\TimestampInterface::getTimestamp »
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the increment component of this TimestampInterface

MongoDB\BSON\TimestampInterface::getIncrement

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface

Descripción

abstract public MongoDB\BSON\TimestampInterface::getIncrement ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the increment component of this TimestampInterface.

Advertencia

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

Ver también

  • MongoDB\BSON\Timestamp::getIncrement() - Returns the increment component of this Timestamp


Returns the timestamp component of this TimestampInterface

  • « MongoDB\BSON\TimestampInterface::getIncrement
  • MongoDB\BSON\TimestampInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the timestamp component of this TimestampInterface

MongoDB\BSON\TimestampInterface::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface

Descripción

abstract public MongoDB\BSON\TimestampInterface::getTimestamp ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the timestamp component of this TimestampInterface.

Advertencia

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

Ver también

  • MongoDB\BSON\Timestamp::getTimestamp() - Returns the timestamp component of this Timestamp


Returns the string representation of this TimestampInterface

  • « MongoDB\BSON\TimestampInterface::getTimestamp
  • MongoDB\BSON\UTCDateTimeInterface »
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the string representation of this TimestampInterface

MongoDB\BSON\TimestampInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface

Descripción

abstract public MongoDB\BSON\TimestampInterface::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this TimestampInterface.

Ver también

  • MongoDB\BSON\Timestamp::__toString() - Returns the string representation of this Timestamp


The MongoDB\BSON\UTCDateTimeInterface interface

(mongodb >=1.3.0)

Introducción

This interface is implemented by MongoDB\BSON\UTCDateTime but may also be used for type-hinting and userland classes.

Sinopsis de la Clase

MongoDB\BSON\UTCDateTimeInterface {
/* Métodos */
abstract public toDateTime ( ) : DateTime
abstract public __toString ( ) : string
}

Tabla de contenidos

  • MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface
  • MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface


Returns the DateTime representation of this UTCDateTimeInterface

  • « MongoDB\BSON\UTCDateTimeInterface
  • MongoDB\BSON\UTCDateTimeInterface::__toString »
  • PHP Manual
  • MongoDB\BSON\UTCDateTimeInterface
  • Returns the DateTime representation of this UTCDateTimeInterface

MongoDB\BSON\UTCDateTimeInterface::toDateTime

(mongodb >=1.3.0)

MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface

Descripción

abstract public MongoDB\BSON\UTCDateTimeInterface::toDateTime ( ) : DateTime

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the DateTime representation of this UTCDateTimeInterface. The returned DateTime should use the UTC time zone.

Ver también

  • MongoDB\BSON\UTCDateTime::toDateTime() - Returns the DateTime representation of this UTCDateTime


Returns the string representation of this UTCDateTimeInterface

  • « MongoDB\BSON\UTCDateTimeInterface::toDateTime
  • MongoDB\Controlador\Excepciones »
  • PHP Manual
  • MongoDB\BSON\UTCDateTimeInterface
  • Returns the string representation of this UTCDateTimeInterface

MongoDB\BSON\UTCDateTimeInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface

Descripción

abstract public MongoDB\BSON\UTCDateTimeInterface::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string representation of this UTCDateTimeInterface.

Ver también

  • MongoDB\BSON\UTCDateTime::__toString() - Returns the string representation of this UTCDateTime


Clases de excepcines

  • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
  • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
  • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
  • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
  • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
  • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
  • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
  • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
  • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
    • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception
  • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)
  • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
  • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class
    • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation


The MongoDB\Driver\Exception\AuthenticationException class

(mongodb >= 1.0.0)

Introducción

Thrown when the driver fails to authenticate with the server.

Sinopsis de la Clase

MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\BulkWriteException class

(mongodb >= 1.0.0)

Introducción

Thrown when a bulk write operation fails.

Sinopsis de la Clase

MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected MongoDB\Driver\WriteResult $writeResult ;
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\WriteException::getWriteResult ( ) : MongoDB\Driver\WriteResult
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\ConnectionException class

(mongodb >= 1.0.0)

Introducción

Base class for exceptions thrown when the driver fails to establish a database connection.

Sinopsis de la Clase

MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\ConnectionTimeoutException class

(mongodb >= 1.0.0)

Introducción

Thrown when the driver fails to establish a database connection within a specified time limit (connectTimeoutMS) or server selection fails (serverSelectionTimeoutMS).

Sinopsis de la Clase

final MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\Exception interface

(mongodb >= 1.0.0)

Introducción

Common interface for all driver exceptions. This may be used to catch only exceptions originating from the driver itself.

Sinopsis de la Clase

MongoDB\Driver\Exception\Exception {
}


The MongoDB\Driver\Exception\ExecutionTimeoutException class

(mongodb >= 1.0.0)

Introducción

Thrown when a query or command fails to complete within a specified time limit (e.g. » maxTimeMS).

Sinopsis de la Clase

final MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\ServerException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Historial de cambios

Versión | Descripción
PECL mongodb 1.5.0 | This class now extends MongoDB\Driver\Exception\ServerException instead of MongoDB\Driver\Exception\RuntimeException.


The MongoDB\Driver\Exception\InvalidArgumentException class

(mongodb >= 1.0.0)

Introducción

Thrown when a driver method is given invalid arguments (e.g. invalid option types).

Sinopsis de la Clase

MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\LogicException class

(mongodb >= 1.0.0)

Introducción

Thrown when the driver is incorrectly used (e.g. rewinding a cursor).

Sinopsis de la Clase

MongoDB\Driver\Exception\LogicException extends LogicException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\RuntimeException class

(mongodb >= 1.0.0)

Introducción

Thrown when the driver encounters a runtime error (e.g. internal error from » libmongoc).

Sinopsis de la Clase

MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Propiedades */
protected array|null $errorLabels ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
final public hasErrorLabel ( string $errorLabel ) : bool
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

errorLabels

Contains an array of error labels to go with an exception. For example, error labels can be used to detect whether a transaction can be retried safely if the TransientTransactionError label is present. The existence of a specific error label should be tested for with the MongoDB\Driver\Exception\RuntimeException::hasErrorLabel(), instead of interpreting this errorLabels property manually.

Historial de cambios

Versión | Descripción
PECL mongodb 1.6.0 | The MongoDB\Driver\Exception\RuntimeException::hasErrorLabel() method and MongoDB\Driver\Exception\RuntimeException::errorLabels property have been added.

Tabla de contenidos

  • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception


Returns whether an error label is associated with an exception

  • « MongoDB\Driver\Exception\RuntimeException
  • MongoDB\Driver\Exception\SSLConnectionException »
  • PHP Manual
  • MongoDB\Driver\Exception\RuntimeException
  • Returns whether an error label is associated with an exception

MongoDB\Driver\Exception\RuntimeException::hasErrorLabel

(mongodb >= 1.6.0)

MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception

Descripción

final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool

Returns whether the errorLabel has been set for this exception. Error labels are set by either the server or the driver to indicated specific situations on which you might want to decide on how you want to handle a specific exception. A common situation might be to find out whether you can safely retry a transaction that failed due to a transient error (like a networking issue, or a transaction conflict). Examples of error labels are TransientTransactionError and UnknownTransactionCommitResult.

Parámetros

errorLabel

The name of the errorLabel to test for.

Valores devueltos

Whether the given errorLabel is associated with this exception.

Ver también

  • MongoDB\Driver\Session::commitTransaction()
  • » MongoDB documentation on transactions


The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)

(mongodb >= 1.0.0)

Advertencia

This exception class is deprecated and may be removed in a future major version. The driver has never thrown this exception.

Introducción

Thrown when the driver fails to establish an SSL connection with the server.

Sinopsis de la Clase

final MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\UnexpectedValueException class

(mongodb >= 1.0.0)

Introducción

Thrown when the driver encounters an unexpected value (e.g. during BSON serialization or deserialization).

Sinopsis de la Clase

MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception\Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\WriteException class

(mongodb >= 1.0.0)

Introducción

Base class for exceptions thrown by a failed write operation. The exception encapsulates a MongoDB\Driver\WriteResult object.

Sinopsis de la Clase

abstract MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\ServerException implements MongoDB\Driver\Exception\Exception {
/* Propiedades */
protected MongoDB\Driver\WriteResult $writeResult ;
/* Propiedades heredadas */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
final public getWriteResult ( ) : MongoDB\Driver\WriteResult
/* Métodos heredados */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

writeResult

The MongoDB\Driver\WriteResult associated with the failed write operation.

Historial de cambios

Versión | Descripción
PECL mongodb 1.5.0 | This class now extends MongoDB\Driver\Exception\ServerException instead of MongoDB\Driver\Exception\RuntimeException.

Tabla de contenidos

  • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation


Returns the WriteResult for the failed write operation

  • « MongoDB\Driver\Exception\WriteException
  • MySQL »
  • PHP Manual
  • MongoDB\Driver\Exception\WriteException
  • Returns the WriteResult for the failed write operation

MongoDB\Driver\Exception\WriteException::getWriteResult

(mongodb >= 1.0.0)

MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation

Descripción

final public MongoDB\Driver\Exception\WriteException::getWriteResult ( ) : MongoDB\Driver\WriteResult

Returns the MongoDB\Driver\WriteResult for the failed write operation. The MongoDB\Driver\WriteResult::getWriteErrors() and MongoDB\Driver\WriteResult::getWriteConcernError() methods may be used to get more details about the failure.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The MongoDB\Driver\WriteResult for the failed write operation.

Ejemplos

Ejemplo #1 MongoDB\Driver\Exception\WriteException::getWriteResult() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost');
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\WriteException $e) {
    $writeResult = $e->getWriteResult();

    if ($writeConcernError = $writeResult->getWriteConcernError()) {
        var_dump($writeConcernError);
    }

    if ($writeErrors = $writeResult->getWriteErrors()) {
        var_dump($writeErrors);
    }
}

?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(1)
    ["info"]=>
    NULL
  }
}

Ver también

  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations


Controladores y complementos de MySQL

PHP ofrece varios controladores y complementos de MySQL para acceder y manejar MySQL.

Las diferencias y la funcionalidad de las extensiones de MySQL están descritas dentro de la información general de esta sección.

  • Información general de los controladores de MySQL para PHP
    • Información general de la terminología
    • Elegir una API
    • Elegir una biblioteca
    • Conceptos
  • MySQLi — Extensión MySQL mejorada
    • Introducción
    • Información general
    • Guía rápida
    • Instalación/Configuración
    • La extensión mysqli y conexiones persistentes
    • Constantes predefinidas
    • Notas
    • Resumen de las funciones de la extensión MySQLi
    • Ejemplos
    • mysqli — La clase mysqli
    • mysqli_stmt — La clase mysqli_stmt
    • mysqli_result — La clase mysqli_result
    • mysqli_driver — La clase mysqli_driver
    • mysqli_warning — La clase mysqli_warning
    • mysqli_sql_exception — La clase mysqli_sql_exception
    • Alias y Funciones de MySQLi obsoletos
    • Registro de cambios
  • MySQL (Original) — API original de MySQL
    • Introducción
    • Instalación/Configuración
    • Registro de cambios
    • Constantes predefinidas
    • Ejemplos
    • Funciones de MySQL
  • Mysqlnd — Controlador Nativo de MySQL
    • Introducción
    • Información General
    • Instalación
    • Configuración en tiempo de ejecución
    • Incompatibilidades
    • Conexiones persistentes
    • Estadísticas
    • Notas
    • Gestión de la memoria
    • API de Complementos del Controlador Nativo de MySQL
  • mysqlnd_ms — Complemento de equilibrado de carga y replicación de mysqlnd
    • Introducción
    • Guía rápida y ejemplos
    • Conceptos
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de mysqlnd_ms
    • Historial de cambios
  • mysqlnd_qc — Complemento de caché de resultados de consultas de mysqlnd
    • Introducción
    • Guia rápida y ejemplos
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de mysqlnd_qc
    • Historal de cambios
  • mysqlnd_uh — Complemento de gestión del usuario de mysqlnd
    • Introducción
    • Guía rápida y ejemplos
    • Instalación/Configuración
    • Constantes predefinidas
    • MysqlndUhConnection — La clase MysqlndUhConnection
    • MysqlndUhPreparedStatement — La clase MysqlndUhPreparedStatement
    • Funciones de Mysqlnd_uh
    • Historial de cambios
  • mysqlnd_mux — Complemento de multiplexación de conexiones de mysqlnd
    • Introducción
    • Conceptos
    • Instalación/Configuración
    • Constantes predefinidas
    • Historial de cambios
  • mysqlnd_memcache — Complemento de Memcache de Mysqlnd
    • Introducción
    • Guía rápida y ejemplos
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de mysqlnd_memcache
    • Historial de cambios


Información general de los controladores de MySQL para PHP

Introducción

Dependiendo de la versión de PHP, existen dos o tres API de PHP para acceder a las bases dedatos de MySQL. Los usuarios de PHP 5 pueden elegir entre la extensión mysql obsoleta, mysqli, o PDO_MySQL. PHP 7 elimina la extensión mysql, dejando solamente las últimas dos opciones.

Esta guía explica la terminología empleada para describir cada API, información sobre qué API elegir, y también información para ayudar a elegir qué biblioteca de MySQL usar con la API.

  • Información general de la terminología
  • Elegir una API
  • Elegir una biblioteca
  • Conceptos
    • Consultas almacenadas y no almacenadas en buffer
    • Conjuntos de caracteres


Información general de la terminología

Esta sección proporciona una introducción de las opciones disponibles al desarrollar una aplicación de PHP que necesite interactuar con una base de datos de MySQL.

¿Qué es una API?

Una Interfaz de Programación de Aplicaciones (o API de sus siglas en inglés), define las clases, métodos, funciones y variables que una aplicación necesita llamar para realizar una tarea. En el caso de aplicaciones de PHP que necesiten comunicarse con bases de datos, las API necesarias normalmente son expuestas mediante extensiones de PHP.

Las API pueden ser procedimentales u orientadas a objetos. Con una API procedimental se llaman a funciones para realizar tareas, con una API orientada a objetos se instancian clases y luego se llaman a métodos de los objetos resultantes. De las dos, la última normalmente es la interfaz preferida debido a que es más moderna y conduce a un código mejor organizado.

Al escribir aplicaciones de PHP que necesitan conectarse a un servidor de MySQL, existen varias opciones de API disponibles. Este documento trata sobre lo que está disponible y cómo elegir la mejor solución para una aplicación.

¿Qué es un conector?

En la documentación de MySQL, el término conector se refiere a una pieza de software que permite a las aplicaciones conectarse con el servidor de bases de datos de MySQL. MySQL proporciona conectores para muchos lenguajes, incluido PHP.

Si una aplicación de PHP necesita comunicarse con un servidor de bases de datos, será necesario escribir código de PHP para llevar a cabo actividades como conectarse al servidor de la base de datos, consultar la base de datos y otras funciones relacionas con la base de datos. Se requiere software para proporcionar la API que utilizará la aplicacion de PHP, y también manejar la comunicación entre la aplicación y el servidor de la base de datos, posiblemente empleando otras bibliotecas intermediarias cuando sea necesario. Este software se conoce generalmente como conector, ya que permite a la aplicación conectarse al servidor de la base de datos.

¿Qué es un controlador?

Un controlador (o driver) es una pieza de software diseñada para la comunicación con un tipo específico de servidor de bases de datos. El controlador también llama a una biblioteca, como la Biblioteca Cliente de MySQL o el Controlador Nativo de MySQL. Estas bibliotecas implementan el protocolo de bajo nivel usado para comunicarse con el servidor de bases de datos de MySQL.

Por poner un ejemplo, la capa de abstracción de bases de datos Objetos de Datos de PHP (PDO) pueden usar uno de los varios controladores específicos de bases de datos. Uno de los controladores disponibles es el controlador de MySQL de PDO, que permite hacer de interfaz con el servidor MySQL.

A veces se emplean los términos conector y controlador intercambiablemente, y esto puede ser confuso. El la documentación relacionada con MySQL, el término controlador está reservado para el software que proporciona la parte específica de bases de datos de un paquete conector.

¿Qué es una extensión?

En la documentación de PHP se encontrará con otro término: extensión. El código de PHP consiste en un núcleo, con extensiones opcionales para la funcionalidad del núcleo. Las extensiones relacionadas con MySQL de PHP, como la extensión mysqli, y la extensión mysql, están implementadas con el marco de extensiones de PHP.

Una extensión típicamente expone una API al programador de PHP para así utilizar sus prestaciones programáticamente. Sin embargo, algunas extensiones que usan el marco de extensiones de PHP no exponen una API al programador de PHP.

La extensión del controlador de MySQL de PDO, por ejemplo, no expone una API al programador de PHP, pero proporciona una interfaz para la capa superior a PDO.

Los términos API y extensión no deberían tomarse como si fuesen la misma cosa; una extensión puede no exponer necesariamente una API al programador.


Elegir una API

PHP ofrece tres API diferentes para conectarse a MySQL. Abajo se muestran las API proporcionadas por las extensiones mysql, mysqli, y PDO. Cada trozo de código crea una conexión al servidor de MySQL que se está ejecutando en "ejemplo.com" con el nombre de usuario "usuario" y la contraseña "contraseña". También se ejecuta una consulta para saludar al usuario.

Ejemplo #1 Comparación de las tres API de MySQL

<?php
// mysqli
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
$resultado = $mysqli->query("SELECT '¡Hola, querido usuario de MySQL!' AS _message FROM DUAL");
$fila = $resultado->fetch_assoc();
echo htmlentities($fila['_message']);

// PDO
$pdo = new PDO('mysql:host=ejemplo.com;dbname=basedatos', 'usuario', 'contraseña');
$sentencia = $pdo->query("SELECT '¡Hola, querido usuario de MySQL!' AS _message FROM DUAL");
$fila = $sentencia->fetch(PDO::FETCH_ASSOC);
echo htmlentities($fila['_message']);

// mysql
$c = mysql_connect("ejemplo.com", "usuario", "contraseña");
mysql_select_db("basedatos");
$resultado = mysql_query("SELECT '¡Hola, querido usuario de MySQL!' AS _message FROM DUAL");
$fila = mysql_fetch_assoc($resultado);
echo htmlentities($fila['_message']);
?>

API recomendada

Se recomienda usar las extensiones mysqli o PDO_MySQL. No se recomienda usar la extensión mysql antigua para nuevos desarrollos, ya que ha sido declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7. Se proporciona una matriz detallada de comparación de características más abajo. El rendimiento global de las tres extensiones se considera que sea aproximadamente el mismo. Aunque el rendimiento de la extensión aporta solamente una fracción del total del tiempo de ejecución de una consulta web de PHP. A menudo, el impacto es tan bajo como 0.1%.

Comparación de características

 | ext/mysqli | PDO_MySQL | ext/mysql
Versión de PHP donde se introdujo | 5.0 | 5.1 | 2.0
Incluida con PHP 5.x | Sí | Sí | Sí
Incluida con PHP 7.x | Sí | Sí | No
Estado de desarrollo | Activo | Activo | Mantenimiento solamente en 5.x; eliminada en 7.x
Ciclo de vida | Activo | Activo | Obsoleto en 5.x; eliminado en 7.x
Recomendada para nuevos proyectos | Sí | Sí | No
Interfaz de POO | Sí | Sí | No
Interfaz procedimental | Sí | No | Sí
La API admite la no espera, consultas asíncronas con mysqlnd | Sí | No | No
Conexiones persistentes | Sí | Sí | Sí
La API admite conjunto de caracteres | Sí | Sí | Sí
La API admite sentencias preparadas del lado del servidor | Sí | Sí | No
La API admite sentencias preparadas del lado del cliente | No | Sí | No
La API admite procedimientos almacenados | Sí | Sí | No
API admite sentencias múltiples | Sí | La mayoría | No
La API admite transacciones | Sí | Sí | No
Las transacciones se pueden controlar con SQL | Sí | Sí | Sí
Admite toda la funcionalidad de MySQL 5.1+ | Sí | La mayoría | No


Elegir una biblioteca

Las extensiones de PHP mysqli, PDO_MySQL y mysql son envolturas ligeras sobre una biblioteca cliente en C. Las extensiones pueden usar la biblioteca mysqlnd o la biblioteca libmysqlclient. Elegir una biblioteca es una decisión que se ha de tomar durante la compilación.

La biblioteca mysqlnd es parte de la distribrución de PHP desde la versión 5.3.0. Ofrece características como conexiones inactivas y caché de consultas, características que no están disponibles con libmysqlclient, por lo que se recomienda encarecedamente usar la biblioteca mysqlnd interna. Véase la documentación de mysqlnd para detalles adicionales y una lista de las características y funcionalidades que ofrece.

Ejemplo #1 Comandos de configuración para usar mysqlnd o libmysqlclient

// Recomendado, compila con mysqlnd
$ ./configure --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-mysql=mysqlnd

// Recomendado como alternativa, compila con mysqlnd a partir de PHP 5.4
$ ./configure --with-mysqli --with-pdo-mysql --with-mysql

// No recomendado, compila con libmysqlclient
$ ./configure --with-mysqli=/ruta/a/mysql_config --with-pdo-mysql=/ruta/a/mysql_config --with-mysql=/ruta/a/mysql_config

Comparación de las características de las bibliotecas

Se recomienda usar la biblioteca mysqlnd en lugar de la biblioteca Cliente Servidor de MySQL (libmysqlclient). Ambas bibliotecas están soportadas y se mejoran constantemente.

 | Controlador Nativo de MySQL (mysqlnd) | Biblioteca Cliente Servidor de MySQL (libmysqlclient)
Parte de la distribución de PHP | Sí | No
Versión de PHP donde se introdujo | 5.3.0 | N/A
Licencia | Licencia PHP 3.01 | Licencia Dual
Estado de desarrollo | Activo | Activo
Ciclo de vida | Fin no anunciado | Fin no anunciado
PHP 5.4 y superior; compilación predeterminada (para todas las extensiones de MySQL) | Sí | No
PHP 5.3; compilación predeterminada (para todas las extensiones de MySQL) | No | Sí
Soporte para el protocolo de compresión | Sí (5.3.1+) | Sí
Soporte para SSL | Sí (5.3.3+) | Sí
Soporte para tubería con nombre | Sí (5.3.4+) | Sí
No bloqueo, consultas asíncronas | Sí | No
Estadísticas de rendimiento | Sí | No
LOAD LOCAL INFILE respecto a la directiva open_basedir | Sí | No
Usa el sistema de gestión de memoria nativo de PHP (p.ej., cumple con los límites de memoria de PHP) | Sí | No
Devuelve columnas numéricas como valores de tipo double (COM_QUERY) | Sí | No
Devuelve columnas númericas como valores de tipo string (COM_QUERY) | Sí | Sí
API de complementos | Sí | Limitada
Separación de lectura/escritura para la Replicación de MySQL | Sí, con complemento | No
Equilibrado de carga | Sí, con complemento | No
Tolerancia a fallos | Sí, con complemento | No
Conexiones inactivas | Sí, con complemento | No
Caché de consultas | Sí, con complemento | No
Manipulación transparente de consultas (p.ej., auto-EXPLAIN o monitorización) | Sí, con complemento | No


Conceptos

Tabla de contenidos

  • Consultas almacenadas y no almacenadas en buffer
  • Conjuntos de caracteres

Estos conceptos son específicos para los controladores de MYSQL para PHP.


Consultas almacenadas y no almacenadas en buffer

Las consultas usan el modo de almacenamiento en buffer por omisión. Esto significa que los resultados de las consultas son transferidos inmediatamente del Servidor MySQL a PHP donde luego se mantienen en la memoria del proceso de PHP. Esto permite operaciones adicionales como la cuenta del número de filas y mover (buscar) el puntero actual del resultado. También permite emitir más consultas en la misma conexión mientras se trabaja con el conjunto de resultados. El lado negativo del modo de almacenamiento en buffer es que los conjuntos de resultados grandes requieren bastante más memoria. La memoria se mantendrá ocupada hasta que todas las referencias al conjunto de resultados sean desestablecidas o se libere explícitamente el conjunto de resultados, lo que automáticamente ocurrirá durante la finalización de la última petición. La terminología "resultado almacenado" también se usa para el modo de almacenamiento en buffer, ya que el conjunto de resultados completo se almacena de una vez.

Nota:

Cuando se usa libmysqlclient como biblioteca, el límite de memoria de PHP no contará la memoria usada por los conjuntos de resultados a menos que los datos sean puestos en variables de PHP. Con mysqlnd, la memoria tenida en cuenta incluirá el conjunto de resultados completo.

Las consultas de MySQL no almacenadas en buffer ejecutan la consulta y luego devuelven un resource mientras los datos aún siguen esperado en el servidor MySQL a que sean extraidos. Esto utiliza menos memoria por parte de PHP, pero puede incrementar la carga del servidor. A menos que se obtenga el conjunto de resultados completo del servidor no se podrán enviar más consultas en la misma conexión. Las consultas no almacenada en buffer también pueden ser descritas como "resultados de uso".

Siguiendo estas características, las consultas almacenadas en buffer deberían usarse en casos donde se espera solamente un conjunto de resultados limitado o se necesite conocer la cantidad de filas devueltas antes de leer todas las filas. El modo de no almacenamiento en buffer debería usarse cuando se esperesn resultados grandes.

Ya que las consultas almacenadas en buffer son las predeterminadas, los ejemplos de abajo demuestran cómo ejecutar consultas no almacenadas en buffer con cada API.

Ejemplo #1 Ejemplo de consulta no almacenada en buffer: mysqli

<?php
$mysqli  = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");
$res_sin_buffer = $mysqli->query("SELECT Name FROM City", MYSQLI_USE_RESULT);

if ($res_sin_buffer) {
   while ($fila = $res_sin_buffer->fetch_assoc()) {
       echo $fila['Name'] . PHP_EOL;
   }
}
$res_sin_buffer->close();
?>

Ejemplo #2 Ejemplo de consulta no almacenada en buffer: pdo_mysql

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world", 'mi_usuario', 'mi_contraseña');
$pdo->setAttribute(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY, false);

$res_sin_buffer = $pdo->query("SELECT Name FROM City");
if ($res_sin_buffer) {
   while ($fila = $res_sin_buffer->fetch(PDO::FETCH_ASSOC)) {
       echo $fila['Name'] . PHP_EOL;
   }
}
?>

Ejemplo #3 Ejemplo de consulta no almacenada en buffer: mysql

<?php
$conexión = mysql_connect("localhost", "mi_usuario", "mi_contraseña");
$bd = mysql_select_db("world");

$res_sin_buffer = mysql_unbuffered_query("SELECT Name FROM City");
if ($res_sin_buffer) {
   while ($fila = mysql_fetch_assoc($res_sin_buffer)) {
       echo $fila['Name'] . PHP_EOL;
   }
}
?>


Conjuntos de caracteres

De forma ideal, un conjunto de caracteres apropiado será establecido a nivel del servidor, que está descrito dentro de la sección » Configuración del conjunto de caracteres del manual del Servidor MySQL. De forma alternativa, cada API de MySQL ofrece métodos para establecer el conjunto de caracteres en tiempo de ejecución.

Precaución

El conjunto de caracteres y el escape de caracteres

El conjunto de caracteres debería entenderse y ser definido, ya que afecta a cada acción, e incluye implicaciones de seguridad. Por ejemplo, el mecanismo de escape (p.ej., mysqli_real_escape_string() para mysqli, mysql_real_escape_string() para mysql, y PDO::quote() para PDO_MySQL) cumplirá con esta configuración. Es importante darse cuenta que estas funciones no usarán el conjunto de caracteres que está definido en una consulta, por lo que, por ejemplo, lo siguiente no tendrá efecto sobre ellas:

Ejemplo #1 Problemas al establecer el conjunto de caracteres con SQL

<?php

$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

// NO afectará a $mysqli->real_escape_string();
$mysqli->query("SET NAMES utf8");

// NO afectará a $mysqli->real_escape_string();
$mysqli->query("SET CHARACTER SET utf8");

// Pero esto sí afectará a $mysqli->real_escape_string();
$mysqli->set_charset('utf8'));

// Y esto NO le afectará (utf-8 frente a utf8) -- no emplee guiones aquí
$mysqli->set_charset('utf-8');
?>

Abajo hay ejemplos que demuestran cómo alterar adecuadamente el conjunto de caracteres en tiempo de ejecución usando cada API.

Nota: Posible confusión con UTF-8

Debido a que los nombres de los conjuntos de caracteres no contienen guiones, la cadena "utf8" es válida en MySQL para establecer el conjunto de caracteres a UTF-8. La cadena "utf-8" no es válida para cambiar el conjunto de caracteres.

Ejemplo #2 Ejemplo para establecer el conjunto de caracteres: mysqli

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

printf("Conjunto de caracteres inicial: %s\n", $mysqli->character_set_name());

if (!$mysqli->set_charset('utf8')) {
    printf("Error cargando el conjunto de caracteres utf8: %s\n", $mysqli->error);
    exit;
}

echo "Información del nuevo conjunto de caracteres:\n";
print_r( $mysqli->get_charset() );

?>

Ejemplo #3 Ejemplo para establecer el conjunto de caracteres: pdo_mysql

Nota: Sólo funciona a partir de PHP 5.3.6.

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world;charset=utf8", 'mi_usuario', 'mi_contraseña');
?>

Ejemplo #4 Ejemplo para establecer el conjunto de caracteres: mysql

<?php
$conexión = mysql_connect("localhost", "mi_usuario", "mi_contraseña");
$bd   = mysql_select_db("world");

echo 'Conuunto de caracteres inicial: ' .  mysql_client_encoding($conexión) . "\n";

if (!mysql_set_charset('utf8', $conexión)) {
    echo "Error: No se pudo establecer el conjunto de caracteres.\n";
    exit;
}

echo 'El conjunto de caracteres actual es: ' .  mysql_client_encoding($conexión);
?>


Extensión MySQL mejorada

  • Introducción
  • Información general
  • Guía rápida
    • Interfaz dual: procedimental y orientada a objetos
    • Conexiones
    • Ejecutar sentencias
    • Sentencias Preparadas
    • Procedimientos almacenados
    • Sentencias Múltiples
    • Soporte de la API para transacciones
    • Metadatos
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • La extensión mysqli y conexiones persistentes
  • Constantes predefinidas
  • Notas
  • Resumen de las funciones de la extensión MySQLi
  • Ejemplos
    • Ejemplos básicos de la extensión MySQLi
  • mysqli — La clase mysqli
    • mysqli::$affected_rows — Obtiene el número de filas afectadas en la última operación MySQL
    • mysqli::autocommit — Activa o desactiva las modificaciones de la base de datos autoconsignadas
    • mysqli::begin_transaction — Inicia una transacción
    • mysqli::change_user — Cambia el usuario de la conexión de bases de datos especificada
    • mysqli::character_set_name — Devuelve el juego de caracteres predeterminado para la conexión a la base de datos
    • mysqli::close — Cierra una conexión previamente abierta a una base de datos
    • mysqli::commit — Consigna la transacción actual
    • mysqli::$connect_errno — Devuelve el código de error de la última llamada
    • mysqli::$connect_error — Devuelve una cadena con la descripción del último error de conexión
    • mysqli::__construct — Abre una nueva conexión al servidor de MySQL
    • mysqli::debug — Realiza operaciones de depuración
    • mysqli::dump_debug_info — Volcado de información de depuración en el registro
    • mysqli::$errno — Devuelve el código del error de la última función llamada
    • mysqli::$error_list — Devuelve una lista de errores desde el último comando ejecutado
    • mysqli::$error — Devuelve una cadena que describe el último error
    • mysqli::$field_count — Devuelve el número de columnas para la consulta más reciente
    • mysqli::get_charset — Devuelve un objeto que contiene el conjunto de caracteres
    • mysqli::get_client_info — Obtiene información de la biblioteca cliente de MySQL
    • mysqli_get_client_version — Devuelve la versión clientes de MySQL como valor de tipo integer
    • mysqli::get_connection_stats — Devuelve estadísticas sobre la conexión del cliente
    • mysqli::$host_info — Devuelve una cadena que representa el tipo de conexión usada
    • mysqli::$protocol_version — Devuelve la versión del protocolo MySQL utilizada
    • mysqli::$server_info — Devuelve la versión del servidor MySQL
    • mysqli::$server_version — Devuelve la versión del servidor MySQL como un valor entero
    • mysqli::get_warnings — Obtiene el resultado de SHOW WARNINGS
    • mysqli::$info — Obtiene la información de la última consulta ejecutada
    • mysqli::init — Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
    • mysqli::$insert_id — Devuelve el id autogenerado que se utilizó en la última consulta
    • mysqli::kill — Pide al servidor poner fin a un hilo de MySQL
    • mysqli::more_results — Comprueba si hay más resultados de una multi consulta
    • mysqli::multi_query — Realiza una consulta a la base de datos
    • mysqli::next_result — Prepara el siguiente resultado de multi_query
    • mysqli::options — Establecer opciones
    • mysqli::ping — Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión
    • mysqli::poll — Almacena en caché conexiones
    • mysqli::prepare — Prepara una sentencia SQL para su ejecución
    • mysqli::query — Realiza una consulta a la base de datos
    • mysqli::real_connect — Abre una conexión a un servidor mysql
    • mysqli::real_escape_string — Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
    • mysqli::real_query — Ejecuta una consulta SQL
    • mysqli::reap_async_query — Obtener el resultado de una consulta asincrónica
    • mysqli::refresh — Refresca
    • mysqli::release_savepoint — Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual
    • mysqli::rollback — Revierte la transacción actual
    • mysqli::savepoint — Define el nombre de un punto de salvaguarda de la transacción
    • mysqli::select_db — Selecciona la base de datos por defecto para realizar las consultas
    • mysqli::set_charset — Establece el conjunto de caracteres predeterminado del cliente
    • mysqli::$sqlstate — Devuelve el error SQLSTATE de la operación de MySQL previa
    • mysqli::ssl_set — Usada para establece conexiones seguras usando SSL
    • mysqli::stat — Obtiene el estado actual del sistema
    • mysqli::stmt_init — Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare
    • mysqli::store_result — Transfiere un conjunto de resultados de la última consulta
    • mysqli::$thread_id — Deveulve el ID del hilo de la conexión actual
    • mysqli::thread_safe — Devuelve si la seguridad a nivel de hilos está dada o no
    • mysqli::use_result — Inicia la recuperación de un conjunto de resultados
    • mysqli::$warning_count — Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado
  • mysqli_stmt — La clase mysqli_stmt
    • mysqli_stmt::$affected_rows — Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada
    • mysqli_stmt::attr_get — Se utiliza para obtener el valor actual de un atributo de la sentencia
    • mysqli_stmt::attr_set — Se utiliza para modificar el comportamiento de una sentencia preparada
    • mysqli_stmt::bind_param — Agrega variables a una sentencia preparada como parámetros
    • mysqli_stmt::bind_result — Vincula variables a una sentencia preparada para el almacenamiento de resultados
    • mysqli_stmt::close — Cierra una sentencia preparada
    • mysqli_stmt::__construct — Construye un nuevo objeto mysqli_stmt
    • mysqli_stmt::data_seek — Busca una fila arbitraria en un conjunto de resultados de una sentencia
    • mysqli_stmt::$errno — Devuelve el código de error de la llamada de la sentencia más reciente
    • mysqli_stmt::$error_list — Devuelve una lista de errores de la última sentencia ejecutada
    • mysqli_stmt::$error — Devuelve una descripción en forma de string del último error de una sentencia
    • mysqli_stmt::execute — Ejecuta una consulta preparada
    • mysqli_stmt::fetch — Obtiene los resultados de una sentencia preparadas en las variables vinculadas
    • mysqli_stmt::$field_count — Devuelve el número de campos de la sentencia dada
    • mysqli_stmt::free_result — Libera la memoria de los resultados almacenados del gestor de sentencia dado
    • mysqli_stmt::get_result — Obtiene un conjunto de resultados de una sentencia preparada
    • mysqli_stmt::get_warnings — Obtener los resultados de SHOW WARNINGS
    • mysqli_stmt::$insert_id — Obtener el ID generado en la operación INSERT anterior
    • mysqli_stmt::more_results — Comprobar si existen más resultados de una consulta de consultas múltiples
    • mysqli_stmt::next_result — Lee el siguiente resultado de una consulta múltiple
    • mysqli_stmt::$num_rows — Devuelve el número de filas de un conjunto de resultados de una sentencia
    • mysqli_stmt::$param_count — Devuelve el número de parámetros de la sentencia dada
    • mysqli_stmt::prepare — Preparar una sentencia SQL para su ejecución
    • mysqli_stmt::reset — Reinicia una sentencia preparada
    • mysqli_stmt::result_metadata — Devuelve los metadatos del conjunto de resultados de una sentencia preparada
    • mysqli_stmt::send_long_data — Enviar datos en bloques
    • mysqli_stmt::$sqlstate — Devuelve el error SQLSTATE de la operación de sentencia previa
    • mysqli_stmt::store_result — Transfiere un conjunto de resultados desde una sentencia preparada
  • mysqli_result — La clase mysqli_result
    • mysqli_result::$current_field — Obtener posición del campo actual de un puntero a un resultado
    • mysqli_result::data_seek — Ajustar el puntero de resultado a una fila arbitraria del resultado
    • mysqli_result::fetch_all — Obtener todas las filas en un array asociativo, numérico, o en ambos
    • mysqli_result::fetch_array — Obtiene una fila de resultados como un array asociativo, numérico, o ambos
    • mysqli_result::fetch_assoc — Obtener una fila de resultado como un array asociativo
    • mysqli_result::fetch_field_direct — Obtener los metadatos de un único campo
    • mysqli_result::fetch_field — Retorna el próximo campo del resultset
    • mysqli_result::fetch_fields — Devuelve un array de objetos que representan los campos de un conjunto de resultados
    • mysqli_result::fetch_object — Devuelve la fila actual de un conjunto de resultados como un objeto
    • mysqli_result::fetch_row — Obtener una fila de resultados como un array enumerado
    • mysqli_result::$field_count — Obtiene el número de campos de un resultado
    • mysqli_result::field_seek — Establecer el puntero del resultado al índice del campo especificado
    • mysqli_result::free — Libera la memoria asociada a un resultado
    • mysqli_result::$lengths — Retorna los largos de las columnas de la fila actual en el resultset
    • mysqli_result::$num_rows — Obtiene el número de filas de un resultado
  • mysqli_driver — La clase mysqli_driver
    • mysqli_driver::embedded_server_end — Detener el servidor incrustado
    • mysqli_driver::embedded_server_start — Inicializa e inicia el servidor embebido
    • mysqli_driver::$report_mode — Habilita o desabilita las funciones internas de notificación
  • mysqli_warning — La clase mysqli_warning
    • mysqli_warning::next — El propósito next
  • mysqli_sql_exception — La clase mysqli_sql_exception
  • Alias y Funciones de MySQLi obsoletos
    • mysqli_connect — Alias de mysqli::__construct
    • mysqli_escape_string — Alias de mysqli_real_escape_string
    • mysqli_execute — Alias para mysqli_stmt_execute
    • mysqli_get_client_stats — Returns client per-process statistics
    • mysqli_get_links_stats — Devolver información sobre enlaces abiertos y almacenados en caché
    • mysqli_report — Alias de mysqli_driver->report_mode
    • mysqli::set_opt — Alias de mysqli_options
  • Registro de cambios


Introducción

La extensión mysqli (mysql improved) permite acceder a la funcionalidad proporcionada por MySQL 4.1 y posterior. Se puede encontrar más información sobre el servidor de base de datos MySQL en » http://www.mysql.com/

Se puede encontrar información general del software disponible para usar MySQL desde PHP en la Información general

La documentación de MySQL se puede encontrar en » http://dev.mysql.com/doc/.

Esta documentación incluye partes del manual de MySQL con permiso de Oracle Corporation.

Los ejemplos emplean las bases de datos » world o » sakila, las cuales están a libre disposición.


Información general

Esta sección proporciona una introducción de las opciones disponibles a la hora de desarrollar una aplicación PHP que necesite interactuar con una base de datos MySQL.

¿Qué es una API?

Una Interfaz de Programación de Aplicaciones, o API, define las clases, métodos, funciones y variables que necesitará llamar una aplicación para llevar a cabo una tarea determinada. En el caso de las aplicaciones de PHP que necesitan comunicarse con un servidor de bases de datos, las APIs necesarias se ofrecen generalmente en forma de extensiones de PHP.

Las APIs pueden ser procedimentales u orientadas a objetos. Con una API procedimental invocan funciones para llevar a cabo las tareas, mientras con con una API orientada a objetos se instancian clases, y entonces se invocan a métodos de los objetos creados. Entre ambas opciones, la segunda es generalmente la vía recomendada, puesto que está más actualizada y conlleva una mejor organización de código.

Cuando se escriben aplicaciones PHP que necesitan conectar a un servidor MySQL, existen varias opciones disponibles respecto a API. Este documento abarca esas opciones, y ayuda a elegir la mejor solución para cada aplicación.

¿Qué es un Conector?

En la documentación de MySQL, el término conector hace referencia al software que permite a una aplicación conectarse a un servidor de bases de datos MySQL. MySQL proporciona conectores para ciertos lenguajes, entre ellos PHP.

Si una aplicación de PHP necesita comunicarse con un servidor de bases de datos, necesitará escribir el código PHP que realice tareas tales como conectar al servidor de bases de datos, realizar consultas y otras funciones relacionadas con bases de datos. Es necesario tener un software instalado en el sistema que proporcione a la aplicación en PHP la API, que manejará la comunicación entre el servidor de bases de datos y la aplicación, posiblemente empleando en caso necesario otras bibliotecas. A este software generalmente se le conoce como conector, dado que permite a una aplicación conectar con un servidor de bases de datos.

¿Qué es un Driver?

Un driver es un software diseñado para comunicarse con un tipo específico de servidor de bases de datos. Podría también invocar a una biblioteca, como por ejemplo la Biblioteca Cliente de MySQL o el Driver Nativo de MySQL. Estas bibliotecas implementan el protocolo de bajo nivel que se utiliza para comunicarse con el servidor de bases de datos.

A modo de ejemplo, la capa de abstracción de bases de datos Objetos de Datos de PHP (PDO) utilizará alguno de los drivers para bases de datos disponibles. Uno de ellos es el driver PDO MYSQL, que permite comunicarse con un servidor MySQL.

A menudo la gente utiliza los términos conector y driver indistintamente. Esto puede dar lugar a confusión. En la documentación de MySQL, el término driver queda reservado para el software que proporciona la parte específica de una base de datos dentro de un conector.

¿Qué es una Extensión?

En la documentación de PHP aparece otro término - extensión. El código fuente de PHP consiste por un lado de un núcleo, y por otro de extensiones opcionales para el núcleo. Las extensiones de PHP relacionadas con MySQL, tales como mysqli, y mysql, están implementadas utilizando el framework de extensiones de PHP.

Típicamente, una extensión ofrece una API al programador de PHP para permitirle hacer uso de sus utilidades mediante código. Sin embargo, algunas de las extensiones que utilizan el framework de extensiones de PHP no ofrecen ninguna API al programador.

La extensión del driver PDO MySQL, por ejemplo, no proporciona ninguna API al programador PHP, pero en su lugar ofrece una interfaz a la capa de PDO que tiene por encima.

No deben confundirse los términos API y extensión, dado que una extensión no debe necesariamente proporcionar una API al programador.

¿Cuáles son las principales APIs que PHP ofrece para utilizar MySQL?

Hay tres APIs principales a la hora de considerar conectar a un servidor de bases de datos MySQL:

  • Extensión MySQL de PHP

  • Extensión mysqli de PHP

  • Objetos de Datos de PHP (PDO)

Cada una tiene sus ventajas e inconvenientes. El siguiente apartado trata de dar una breve introducción a los aspectos clave de cada API.

¿Qué es la Extensión MySQL de PHP?

Esta es la extensión original diseñada que permite desarrollar aplicaciones PHP que interactúan con bases de datos MySQL. La extensión mysql proporciona una interfaz procedural, y está pensada para usar sólo con versiones de MySQL anteriores a la 4.1.3. Si bien esta extensión se puede utilizar con versiones de MySQL 4.1.3 o posteriores, no estarán disponibles todas las nuevas funcionalidades del servidor MySQL.

Nota:

Si se utiliza una versión de MySQL 4.1.3 o posterior, se recomienda encarecidamente utilizar la extensión mysqli en su lugar.

El código fuente de la extensión mysql se encuentra en el directorio de extensiones de PHP ext/mysql.

Para más información sobre la extensiónmysql, revise MySQL (Original).

¿Qué es la extensión mysqli de PHP?

La extensión mysqli, o como a veces se le conoce, la extensión de MySQL mejorada, se desarrolló para aprovechar las nuevas funcionalidades encontradas en los sistemas MySQL con versión 4.1.3 o posterior. La extensión mysqli viene incluida en las versiones PHP 5 y posteriores.

La extensión mysqli contiene numerosos beneficios, siendo estas las mejoras principales respecto a la extensión mysql:

  • Interfaz orientada a objetos

  • Soporte para Declaraciones Preparadas

  • Soporte para Múltiples Declaraciones

  • Soporte para Transacciones

  • Mejoradas las opciones de depuración

  • Soporte para servidor empotrado

Nota:

Si utiliza MySQL versión 4.1.3 o superior, se recomienda encarecidamente utilizar esta extensión.

Además de la interfaz orientada a objetos, esta extensión también proporciona una interfaz procedural.

La extensión mysqli está desarrollada mediante el framework de extensiones de PHP. Su código fuente se ubica en el directorio ext/mysqli.

Para más información sobre la extensión mysqli, revise MySQLi.

¿Qué es PDO?

Los Objetos de Datos de PHP, o PDO, son una capa de abstracción de bases de datos específicas para aplicaciones PHP. PDO ofrece una API homogénea para las aplicaciones PHP, independientemente del tipo de servidor de bases de datos con el que se vaya a conectar la aplicación. En teoría, si se utiliza la API PDO, se podría cambiar el servidor de bases de datos en uso, por ejemplo de Firebird a MySQL, y sólo se necesitarían algunos cambios menores en el código PHP.

Otros ejemplos de capas de abstracción de bases de datos son JDBC para aplicaciones Java o DBI para Perl.

A pesar de que PDO tiene sus ventajas, tales como una API limpia, sencilla y portable, su mayor inconveniente es que no permite utilizar todas las funcionalidades avanzadas en la última versión del servidor MySQL. Por ejemplo, PDO no permite hacer uso de las Declaraciones Múltiples de MySQL.

PDO está desarrollado utilizando el framework de extensiones de PHP. Su código fuente se ubica en el directorio ext/pdo.

Para más información de PDO, revise PDO.

¿Qué es el driver PDO MYSQL?

El driver PDO MYSQL no es una API en sí, al menos desde el punto de vista del programador de PHP. En realidad, el driver PDO MYSQL se encuentra una capa por debajo del propio PDO, y ofrece funcionalidades específicas de MySQL. Si bien el programador realiza las llamadas a la API de PDO, PDO utiliza el driver PDO MYSQL para llevara a cabo la comunicación con el servidor MySQL.

El driver PDO MYSQL es uno de los muchos drivers PDO disponibles. Otros de los drivers disponibles son los de los servidores de bases de datos Firebird y PostgreSQL.

El driver MYSQL PDO está desarrollado utilizando el framework de extensiones de PHP. Su código fuente está ubicado en el directorio ext/pdo_mysql. No ofrece ninguna API al programador PHP.

Para más información sobre el driver PDO MYSQL, revise MySQL (PDO).

¿Qué es el Driver Nativo de MySQL?

Tanto la extensión mysql, como mysqli, y el driver PDO MYSQL, utilizan para llevar a cabo las comunicaciones con el servidor de bases de datos MySQL una biblioteca de bajo nivel que genera el protocolo necesario. Hace un tiempo, la única biblioteca disponible era libmysqlclient.

Sin embargo, la interfaz que ofrece libmysqlclient no estaba optimizada para comunicarse con aplicaciones PHP, dado que libmysqlclient se desarrolló originalmente teniendo en mente aplicaciónes hechas en C. Por esta razón, se desarrolló el Driver Nativo de MySQL, mysqlnd, como una alternativa a libmysqlclient para las aplicaciones en PHP.

Tanto la extensión mysql, como la extensión mysqli y el driver PDO MySQL, se pueden configurar por separado para utilizar o bien libmysqlclient o bien mysqlnd. Dado que mysqlnd fue desarrollado específicamente para ser utilizado en sistemas PHP, tiene numerosas mejoras en cuanto a uso de memoria y velocidad respecto a libmysqlclient. Se recomienda encarecidamente hacer uso de dichas mejoras.

Nota:

El Controlador Nativo de MySQL sólo puede usarse con servidores de MySQL versiones 4.1.3 y posteriores.

El Driver Nativo de MySQL está desarrollado utilizando el framework de extensiones de PHP. El código fuente se ubica en ext/mysqlnd. No ofrece ninguna API al programador de PHP.

Comparación de Funcionalidades

La siguiente tabla compara las funcionalidades de los tres principales métodos para conectar a MySQL desde PHP:

Comparación de las opciones de la API de MySQL para PHP
 | Extensión mysqli de PHP | PDO (Usando el driver PDO MySQL y el Driver Nativo MySQL) | Extensión MySQL de PHP
Versión de PHP en que se introdujo | 5.0 | 5.0 | Antes de 3.0
Incluído con PHP 5.x | Sí | Sí | Sí
Estado de desarrollo de MySQL | Desarrollo activo | Desarrollo activo, desde PHP 5.3 | Sólo se le mantiene
Recomendado por MySQL para nuevos proyectos | Sí - opción recomendada | Sí | No
Soporte para juegos de caracteres | Sí | Sí | No
Soporte para Declaraciones Preparadas en el lado del servidor | Sí | Sí | No
Soporte para Declaraciones Preparadas en el lado del cliente | No | Sí | No
Soporte para Procedimientos Almacenados | Sí | Sí | No
Soporte para Declaraciones Múltiples | Sí | Mayormente | No
Soporte para todas las funcionalidades de MySQL 4.1+ | Sí | Mayormente | No


Guía rápida

Tabla de contenidos

  • Interfaz dual: procedimental y orientada a objetos
  • Conexiones
  • Ejecutar sentencias
  • Sentencias Preparadas
  • Procedimientos almacenados
  • Sentencias Múltiples
  • Soporte de la API para transacciones
  • Metadatos

Esta guía rápida le ayudará a elegir y obtener familiaridad con la API MySQL de PHP.

Esta guía rápida ofrece información general sobre la extensión mysqli. Se proporcionan ejemplos de código para los aspectos más importantes de la API. Los conceptos de la base de datos se explican con el grado necesario para presentar conceptos específicos de MySQL.

Se requiere: Familiaridad con el lenguaje de programación PHP, con el lenguaje SQL, y conociemientos básicos del servidor MySQL.


Interfaz dual: procedimental y orientada a objetos

La extensión mysqli ofrece una interfaz dual. Soporta el paradigma de programación procedimental y el orientado a objetos.

Los usuarios que migren desde la extensión mysql antigua pueden preferir la interfaz procedimental. Esta interfaz es similar a la de la extensión antigua de mysql. En la mayoría de los casos, los nombres de funciones difieren únicamente por el prefijo. Algunas funciones de mysqli toman como primer argumento un gestor de conexión, mientras que las funciones similares de la antigua interfaz de mysql lo toman como el último argumento opcional.

Ejemplo #1 Migración sencilla desde la antigua extensión mysql

<?php
$mysqli = mysqli_connect("ejemplo.com", "usuario", "contraseña", "basedatos");
$resultado = mysqli_query($mysqli, "SELECT 'Por favor, no use ' AS _msg FROM DUAL");
$fila = mysqli_fetch_assoc($resultado);
echo $fila['_msg'];

$mysql = mysql_connect("ejemplo.com", "usuario", "contraseña");
mysql_select_db("test");
$resultado = mysql_query("SELECT 'la extensión mysql para nuevos desarrollos.' AS _msg FROM DUAL", $mysql);
$fila = mysql_fetch_assoc($resultado);
echo $fila['_msg'];
?>

El resultado del ejemplo sería:

Por favor, no use la extensión mysql para nuevos desarrollos.

La interfaz orientada a objetos

Además de la clásica interfaz procedimental, los usuarios pueden optar por usar la interfaz orientada a objetos. La documentación está organizada según la interfaz orientada a objetos. Esta interfaz muestra las funciones agrupadas por su propósito, haciendo más fácil los comienzos. La sección de referencia proporciona ejemplos para ambas variantes de sintaxis.

No existen diferencias significativas de rendimiento entre las dos interfaces. Los usuarios puede basar su elección en sus preferencias personales.

Ejemplo #2 Interfaz orientada a objetos y procedimental

<?php
$mysqli = mysqli_connect("ejemplo.com", "usuario", "contraseña", "basedatos");
if (mysqli_connect_errno($mysqli)) {
    echo "Fallo al conectar a MySQL: " . mysqli_connect_error();
}

$resultado = mysqli_query($mysqli, "SELECT 'Un mundo lleno de ' AS _msg FROM DUAL");
$fila = mysqli_fetch_assoc($resultado);
echo $fila['_msg'];

$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Fallo al conectar a MySQL: " . $mysqli->connect_error;
}

$resultado = $mysqli->query("SELECT 'elecciones para complacer a todos.' AS _msg FROM DUAL");
$fila = $resultado->fetch_assoc();
echo $fila['_msg'];
?>

El resultado del ejemplo sería:

Un mundo lleno de elecciones para complacer a todos.

Se usa la interfaz orientada a objetos en el inicio rápido porque la sección de referencia está organizada de esta manera.

Mezclar estilos

Es posible cambiar entre los estilos en cualquier momento. No se recomienda mezclar los dos estilos por razones de claridad y estilo de código.

Ejemplo #3 Estilo de codificación malo

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Fallo al conectar a MySQL: " . $mysqli->connect_error;
}

$resultado = mysqli_query($mysqli, "SELECT 'Estilo malo pero posible.' AS _msg FROM DUAL");
if (!$resultado) {
    echo "Fallo al ejecutar la consulta: (" . $mysqli->errno . ") " . $mysqli->error;
}

if ($fila = $resultado->fetch_assoc()) {
    echo $fila['_msg'];
}
?>

El resultado del ejemplo sería:

Estilo malo pero posible.

Véase también

  • mysqli::__construct()
  • mysqli::query()
  • mysqli_result::fetch_assoc()
  • $mysqli::connect_errno
  • $mysqli::connect_error
  • $mysqli::errno
  • $mysqli::error
  • El resumen de funciones de la extensión MySQLi


Conexiones

El servidor MySQL soporta el uso de diferentes capas de transporte para conexiones. Las conexiones usan TCP/IP, sockets de dominio Unix o tuberías con nombre de Windows.

El nombre del host localhost tiene un significado especial. Está vinculado al uso de sockets de dominio Unix. No es posible abrir una conexión TCP/IP usando como nombre de host localhost, se debe usar 127.0.0.1 en su lugar.

Ejemplo #1 Significado especial de localhost

<?php
$mysqli = new mysqli("localhost", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Fallo al conectar a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}
echo $mysqli->host_info . "\n";

$mysqli = new mysqli("127.0.0.1", "usuario", "contraseña", "basedatos", 3306);
if ($mysqli->connect_errno) {
    echo "Fallo al conectar a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

echo $mysqli->host_info . "\n";
?>

El resultado del ejemplo sería:

Localhost via UNIX socket
127.0.0.1 via TCP/IP

Valores predeterminados de los parámetros de conexión

Dependiendo de la función de conexión usada se pueden omitir varios parámetros. Si no se proporciona un parámetro, la extensión intentará usar los valores predeterminados que están establecidos en el fichero de configuración de PHP.

Ejemplo #2 Configuración predeterminada

mysqli.default_host=192.168.2.27
mysqli.default_user=root
mysqli.default_pw=""
mysqli.default_port=3306
mysqli.default_socket=/tmp/mysql.sock

Los valores resultantes de los parámetros son pasados a la biblioteca cliente que esté usando esta extensión. Si la biblioteca cliente detecta parámetros vacíos o no establecidos, puede usar los valores internos predeterminados de la biblioteca.

Valores predeterminados internos de conexión de la biblioteca

Si el valor del host no está establecido o está vacío, la biblioteca cliente usará una conexión de socket Unix sobre localhost. Si el socket no está establecido o está vacío, y es solicitada una conexión de socket Unix, se intentará una conexiónal socket predeterminado de /tmp/mysql.sock.

En sistemas Windows, el nombre de host . es interpretado por la biblioteca cliente como un intento de abrir una conexión basada en una tubería con nombre de Windows. En este caso el parámetro del socket se interpreta como el nombre de la tubería. Si no se proporciona o está vacío, se usará como socket (nombre de la tubería) \\.\pipe\MySQL.

Si no está establecida una conexión basada en un socket de dominio Unix ni en una tubería con nombre de Windows y el valor del parámetro del puerto no está establecido, la biblioteca usuará como puerto predeterminado el 3306.

La biblioteca mysqlnd y la Biblioteca Cliente de MySQL (libmysqlclient) implementan la misma lógica para determinados valores predeterminados.

Opciones de conexión

Las opciones de conexión están disponibles para, por ejemplo, establecer comando iniciales que son ejecutados sobre la conexión, o para solicitar el uso de ciertos conjuntos de caracteres. Las opciones de conexión deben ser establecidas antes de que se establezcla una conexión de red.

Para configurar una opción de conexión, la operación de conexión ha de ser realizada en tres pasos: crear un gestor de conexión con mysqli_init(), establecer las opciones solicitadas usando mysqli_options(), y establecer la conexión de red con mysqli_real_connect().

Caché de conexiones

La extensión mysqli soporta conexiones persistentes a bases de datos, las cuales son un tipo especial de conexiones almacenadas en caché. Por defecto, cada conexión a una base de datos abierta por un script es cerrada explícitamente por el usuario durante el tiempo de ejecución o liberada automáticamente al finalizar el script. Una conexión persistente no. En su lugar, se coloca en una caché para su reutilización posterior, si una conexión es abierta al mismo servidor usando el mismo nombre de usuario, contraseña, socket, puerto y base de datos predeterminada. La reutilización ahorra gastos de conexion.

Cada procesos de PHP utiliza su propia caché de conexiones mysqli. Dependiendo de modelo de distribución del servidor web, un proceso PHP puede servir una o múltiples peticiones. Por lo tanto, una conexión almacenada en caché puede ser utilizada posteriormente por uno o más scripts.

Conexiones persistentes

Si una conexión persistente no usada con una combiación dada de host, nombre de usuario, contraseña, socket, puerto y base de datos predeterminada no se puede encontrar en la caché de conexiones, mysqli abrirá una nueva conexión. El uso de conexiones persistentes se puede habilitar y deshabilitar usando la directiva de PHP mysqli.allow_persistent. El número total de conexiones abiertas por un script puede ser limitado con mysqli.max_links. El número máximo de conexiones persistentes por proceso de PHP puede restringirse con mysqli.max_persistent. Observe que el servidor web puede engendrar muchos procesos de PHP.

Una queja común sobre las conexiones persistentes qes que su estado no es reiniciado antes de su uso. Por ejemplo, las transacciones abiertas y no finalizadas no son automéáticamente reanudadas. También, los cambios de autorización que ocurran durante la colocación de la conexión en la caché y su reutilización no están reflejados. Esto puede verse como un efecto secundario no deseado. Al contrario, el nombre persistente puede entenderse como una promesa de que el estado persiste.

La extensión mysqli soporta ambas interpretaciones de una conexión persistente: el estado persiste, y el estado se reinicia antes de la reutilización. Lo predeterminado es la reiniciación. Antes de que una conexión sea reutilizada, la extensión llama implicitamente a mysqli_change_user() para reiniciar el estado. La conexión persistente aparece al usuario como si estuviera recién abierta. No son visibles ningún artefacto de los usos previos.

La función mysqli_change_user() es una operación cara. Para un mejor rendimiento, los usuarios pueden recompilar la extensión con la bandera de compilación MYSQLI_NO_CHANGE_USER_ON_PCONNECT establecida.

Corresponde al usuario elegir entre comportamiento seguro o mejor rendimiento. Ambas son metas de optimización válidas. Para facilitar el uso, el comportamiento seguro es el predeterminado a expensas de un rendimiento máximo.

See also

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::change_user()
  • $mysqli::host_info
  • Opciones de configuración de MySQLi
  • Conexiones persistentes a bases de datos


Ejecutar sentencias

Las sentencias se pueden ejecutar con las funciones
mysqli_query(), mysqli_real_query()
y mysqli_multi_query().
La función mysqli_query() es la más
común, y combina la sentencia de ejecucución con su
conjunto de resultados obtenido de un buffer, si lo hubiera, en una llamada.
Llamar a mysqli_query() es idéntico que
llamar a mysqli_real_query()
seguido de mysqli_store_result().

Ejemplo #1 Conectando a MySQL

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión con MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Conjuntos de resultados almacenados en buffer

Después de la ejecución de sentencias, los resultados pueden recuperarse de una sola vez para que sean almacenados en buffer por el cliente o leyendo fila a fila. El almacenamieno en buffer de conjuntos de resultados en el lado del cliente permite al servidor liberar recursos asociados con los resultados de la sentencia tan pronto como sea posible. Generalmente hablando, los clientes son lentos consumiendo conjuntos de resultados. Por lo tanto, se recomienda usar conjuntos de resultados almacenados en buffer. mysqli_query() combina la ejecución de sentencias y el almacenamiento en buffer de conjuntos de resultados.

Las aplicaciones de PHP pueden navegar libremente a través de resultados almacenados en buffer. La navegación es más rápida debido a que los conjuntos de resultados se mantienen en la memoria del cliente. Tenga en cuenta que a menudo es más fácil procesar datos en el cliente que hacerlo el servidor.

Ejemplo #2 Navegación a través de resultados almacenados en buffer

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

$resultado = $mysqli->query("SELECT id FROM test ORDER BY id ASC");

echo "Orden inverso...\n";
for ($num_fila = $resultado->num_rows - 1; $num_fila >= 0; $num_fila--) {
    $resultado->data_seek($num_fila);
    $fila = $resultado->fetch_assoc();
    echo " id = " . $fila['id'] . "\n";
}

echo "Orden del conjunto de resultados...\n";
$resultado->data_seek(0);
while ($fila = $resultado->fetch_assoc()) {
    echo " id = " . $fila['id'] . "\n";
}
?>

El resultado del ejemplo sería:

Orden inverso...
 id = 3
 id = 2
 id = 1
Orden del conjunto de resultados...
 id = 1
 id = 2
 id = 3

Conjuntos de resultados no almacenados en buffer

Si la memoria del cliente es un recurso escaso y no es necesaria la liberación de recursos del servidor tan pronto como sea posible para mantener la carga del servidor baja, se pueden usar conjuntos de resultados no almacenados en buffer. Recorrer resultados no almacenados en buffer no es posible antes de que todas las filas hayan sido leídas.

Ejemplo #3 Navegación a través de resultados no almacenados en buffer

<?php
$mysqli->real_query("SELECT id FROM test ORDER BY id ASC");
$resultado = $mysqli->use_result();

echo "Orden del conjunto de resultados...\n";
while ($fila = $resultado->fetch_assoc()) {
    echo " id = " . $fila['id'] . "\n";
}
?>

Tipos de datos de los valores del conjunto de resultados

Las funciones mysqli_query(), mysqli_real_query() y mysqli_multi_query() se usan para ejecutar sentencias no preparadas. Al nivel del Protocolo Cliente Servidor de MySQL, el comando COM_QUERY y el protocolo de texto se usan para la ejecución de sentencias. Con el protocolo texto, el servidor MySQL convierte todos los datos de los conjuntos de resultados en cadenas antes de enviarlos. Esta conversión se realiza sin considerar el tipo de datos de las columnas del conjunto de resultados SQL. Las bibliotecas cliente de mysql reciben todos los valores de las columnas como cadenas. No se realiza ninguna conversión del lado del cliente pava volver a convertir las columnas a susu tipos nativos. En su lugar, todos los valores son proporcionados como cadenas de PHP.

Ejemplo #4 El protocolo de texto devuelve cadenas de manera predeterminado

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

$resultado = $mysqli->query("SELECT id, etiqueta FROM test WHERE id = 1");
$fila = $resultado->fetch_assoc();

printf("id = %s (%s)\n", $fila['id'], gettype($fila['id']));
printf("etiqueta = %s (%s)\n", $fila['etiqueta'], gettype($fila['etiqueta']));
?>

El resultado del ejemplo sería:

id = 1 (string)
etiqueta = a (string)

Es posible convertir valores de columnas de tipo integer y float a números de PHP estableciendo la opción de conexión MYSQLI_OPT_INT_AND_FLOAT_NATIVE, si se esta´utilizando la biblioteca mysqlnd. Si se establece, la biblioteca mysqlnd comprobará los tipos de columna de los metadatos del conjunto de resultados y convertirá las columnas númerocas de SQL a números de PHP, si el rango de valores del tipo de datos de PHP lo permite. De esta forma, por ejemplo, las columnas INT de SQL son devueltas como enteros.

Ejemplo #5 Tipos de datos nativos con mysqlnd y la opción de conexión

<?php
$mysqli = mysqli_init();
$mysqli->options(MYSQLI_OPT_INT_AND_FLOAT_NATIVE, 1);
$mysqli->real_connect("ejemplo.com", "user", "contraseña", "basedatos");

if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

$resultado = $mysqli->query("SELECT id, etiqueta FROM test WHERE id = 1");
$fila = $resultado->fetch_assoc();

printf("id = %s (%s)\n", $fila['id'], gettype($fila['id']));
printf("etiqueta = %s (%s)\n", $fila['etiqueta'], gettype($fila['etiqueta']));
?>

El resultado del ejemplo sería:

id = 1 (integer)
etiqueta = a (string)

Véase también

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::query()
  • mysqli::multi_query()
  • mysqli::use_result()
  • mysqli::store_result()
  • mysqli_result::free()


Sentencias Preparadas

Las bases de datos MySQL soportan sentencias preparadas. Una sentencia preparada o una sentencia parametrizada se usa para ejecutar la misma sentencia repetidamente con gran eficiencia.

Flujo de trabajo básico

La ejecución de sentencias preparadas consiste en dos etapas: la preparación y la ejecución. En la etapa de preparación se envía una plantilla de sentencia al servidor de bases de datos. El servidor realiza una comprobación de sintaxis e inicializa los recursos internos del servidor para su uso posterior.

El servidor de MySQL soporta el uso de parámetros de sustitución posicionales anónimos con ?.

Ejemplo #1 Primera etapa: prepación

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Sentencia no preparada */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Sentencia preparada, etapa 1: preparación */
if (!($sentencia = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

La preparación es seguida de la ejecución. Durante la ejecución el cliente vincula los valores de los parámetros y los envía al servidor. El servidor crea una sentencia desde la plantilla de la sentencia y los valores vinculados para ejecutarla usando los recursos internos previamente creados.

Ejemplo #2 Segunda etapa: vincular y ejecutar

<?php
/* Sentencia preparada, etapa 2: vincular y ejecutar */
$id = 1;
if (!$sentencia->bind_param("i", $id)) {
    echo "Falló la vinculación de parámetros: (" . $sentencia->errno . ") " . $sentencia->error;
}

if (!$sentencia->execute()) {
    echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}
?>

Ejecución repetida

Una sentencia preparada se puede ejecutar repetidamente. En cada ejecución el valor actual de la variable vinculada se evalúa y se envía al servidor. La sentencia no se analiza de nuevo. La plantilla de la sentencia no es transferida otra vez al servidor.

Ejemplo #3 INSERT preparada una vez, ejecutada múltiples veces

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Sentencia no preparada */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Sentencia preparada, etapa 1: preparación */
if (!($sentencia = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
     echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Sentencia preparada, etapa 2: vinculación y ejecución */
$id = 1;
if (!$sentencia->bind_param("i", $id)) {
    echo "Falló la vinculación de parámetros: (" . $sentencia->errno . ") " . $sentencia->error;
}

if (!$sentencia->execute()) {
    echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}

/* Sentencia preparada: ejecución repetida, sólo datos transferidos desde el cliente al servidor */
for ($id = 2; $id < 5; $id++) {
    if (!$sentencia->execute()) {
        echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
    }
}

/* se recomienda el cierre explícito */
$sentencia->close();

/* Sentencia no preparada */
$resultado = $mysqli->query("SELECT id FROM test");
var_dump($resultado->fetch_all());
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [3]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Cada sentencia preparada ocupa recursos del servidor. Las sentencias deberían cerrarse explícitamente inmediatamente después de su uso. Si no se realiza explícitamente, la sentencia será cerrada cuando el gestor de la sentencia sea liberado por PHP.

Usar una sentencia preparada no es siempre la manera más eficiente de ejecutar una sentencia. Una sentencia preparada ejecutada una sola vez causa más viajes de ida y vuelta desde el cliente al servidor que una sentencia no preparada. Es por esta razón por lo que SELECT no se ejecuta arriba como una sentencia preparada.

También se ha de considerar el uso de la sintaxis SQL multi-INSERT de MySQL para sentencias INSERT. Por ejemplo, multi-INSERT requiere menos viajes de ida y vuelta entre el servidor y el cliente que la sentencia preparada mostrada arriba.

Ejemplo #4 Menos viajes de ida y vuelta usando SQL multi-INSERT

<?php
if (!$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3), (4)")) {
    echo "Falló multi-INSERT: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Tipos de datos de los valores del conjunto de resultados

El Protocolo Cliente Servidor de MySQL define un protocolo de transporte de datos diferente para sentencias preparadas y no preparadas. Las sentencias preparadas usan el llamado protocolo binario. El servidor de MySQL envía los datos del conjunto de resultados "tal cual" en formato binario. Los resultados no son serializados en cadenas antes del envío. Las bibliotecas cliente no reciben cadenas solamente. En su lugar, recibirán datos binarios e intentarán convertir los valores a los tipos de datos de PHP apropiados. Por ejemplo, los resultados de una columna de SQL INT serán proporcionados como variables de tipo integer de PHP.

Ejemplo #5 Tipos de datos nativos

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

$sentencia = $mysqli->prepare("SELECT id, etiqueta FROM test WHERE id = 1");
$sentencia->execute();
$resultado = $sentencia->get_result();
$fila = $resultado->fetch_assoc();

printf("id = %s (%s)\n", $fila['id'], gettype($fila['id']));
printf("etiqueta = %s (%s)\n", $fila['etiqueta'], gettype($fila['etiqueta']));
?>

El resultado del ejemplo sería:

id = 1 (integer)
etiqueta = a (string)

Este comportamiento difiere de las sentencias no preparadas. Por defecto, las sentencias no preparadas devolverán todos los resultados como cadenas. Este comportamiento predeterminado se puede cambiar usand una opción de conexión. Si se utiliza la opción de conexión no existirán diferencias.

Obtener resultados usando variables vinculadas

Los resultados de las sentencias preparadas pueden ser recuperados mediante varibles de salida vinculadas, o por la petición de un objeto mysqli_result.

Las variables de salida deben ser vinculadas después de la ejecución de la sentencia. Una variable debe estar vinculada para cada columna del conjunto de resultados de las sentencias.

Ejemplo #6 Vinculación de variables de salida

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($sentencia = $mysqli->prepare("SELECT id, etiqueta FROM test"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$sentencia->execute()) {
    echo "Falló la ejecución: (" . $mysqli->errno . ") " . $mysqli->error;
}

$id_salida       = NULL;
$etiqueta_salida = NULL;
if (!$sentencia->bind_result($id_salida, $etiqueta_salida)) {
    echo "Falló la vinculación de los parámetros de salida: (" . $sentencia->errno . ") " . $sentencia->error;
}

while ($sentencia->fetch()) {
    printf("id = %s (%s), etiqueta = %s (%s)\n", $id_salida, gettype($id_salida), $etiqueta_salida, gettype($etiqueta_salida));
}
?>

El resultado del ejemplo sería:

id = 1 (integer), etiqueta = a (string)

Las sentencias preparadas devuelven de manera predeterminada conjuntos de resultados no almacenados en buffer. Los resultados de la sentencia no son obtenidas y transferidas implícitamente desde el servidor al cliente para el almacenamiento en buffer de lado del cliente. El conjunto de resultados toma recursos del servidor hasta que todos los resultados hayan sido obtenidos por el cliente. Por lo que se recomienda consumir resultados cuando sea oportuno. Si un cliente falla al obtener todos los resultados o el cliente cierra la consulta antes de haber obtenido todos los datos, los datos han de ser obtenidos implícitamente por mysqli.

También es posible almacenar en buffer los resutados de una sentencia preparada usando mysqli_stmt_store_result().

Obtener los resultados usando la interfaz mysqli_result

En lugar de usar resultados vinculados, los resultados también se pueden recuperar a través de la interfaz mysqli_result. mysqli_stmt_get_result() devuelve un conjunto de resultados almacenado en buffer.

Ejemplo #7 Usar mysqli_result para obtener los resultados

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($sentencia = $mysqli->prepare("SELECT id, etiqueta FROM test ORDER BY id ASC"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$sentencia->execute()) {
     echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}

if (!($resultado = $sentencia->get_result())) {
    echo "Falló la obtención del conjunto de resultados: (" . $sentencia->errno . ") " . $sentencia->error;
}

var_dump($resultado->fetch_all());
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  array(2) {
    [0]=>
    int(1)
    [1]=>
    string(1) "a"
  }
}

Usar la interfaz mysqli_result ofrece el beneficio adicional de la navegación flexible del conjunto de resultados en el lado del cliente.

Ejemplo #8 Conjunto de resultados almacenado en buffer para la lectura flexible

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, etiqueta CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, etiqueta) VALUES (1, 'a'), (2, 'b'), (3, 'c')")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($sentencia = $mysqli->prepare("SELECT id, etiqueta FROM test"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$sentencia->execute()) {
     echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}

if (!($resultado = $sentencia->get_result())) {
    echo "Falló la obtención del conjunto de resultados: (" . $sentencia->errno . ") " . $sentencia->error;
}

for ($num_fila = ($resultado->num_rows - 1); $num_fila >= 0; $num_fila--) {
    $resultado->data_seek($num_fila);
    var_dump($resultado->fetch_assoc());
}
$resultado->close();
?>

El resultado del ejemplo sería:

array(2) {
  ["id"]=>
  int(3)
  ["etiqueta"]=>
  string(1) "c"
}
array(2) {
  ["id"]=>
  int(2)
  ["etiqueta"]=>
  string(1) "b"
}
array(2) {
  ["id"]=>
  int(1)
  ["etiqueta"]=>
  string(1) "a"
}

Escape de valores e inyección SQL

Las variables vinculadas son enviadas desde la consulta al servidor por separado, por lo que no se puede interferir. El servidor usa estos valores directamente en el momento de la ejecución, después de haber analizado la plantilla de la sentencia. Los parámetros vinculados no necesitan ser escapados porque nunca son sustituidos directamente dentro del string de consulta. Se puede proporcionar una sugerencia al servidor para el tipo de variable vinculada, para crear una conversión apropiada. Véase la función mysqli_stmt_bind_param() para más información.

A veces, tal separación es considerada como la única característica de seguridad para evitar inyecciones SQL, pero se puede alcanzar el mismo grado de seguridad con sentencias no preparadas, si todos los valores están formateados correctamente. Debería observarse que el formateo correcto no es lo mismo que usar escapes, y que involucra más lógica que simplemente usar escapes. Por lo tanto, las sentencias preparadas son sencillamente una estrategia más conveniente y menos propensa a errores para este elemetno de seguridad de bases de datos.

Emulación de sentencias preparadas en el lado del cliente

La API no inclye la emulación para sentencias preparadas en el lado del cliente.

Comparación entre sentencias preparadas y no preparadas

La tabla de abajo compara las sentencias preparadas y no preparadas del lado del servidor.

Comparación entre sentencias preparadas y no preparadas
 | Sentencia preparada | Sentencia no preparada
Viajes de ida y vuelta desde el cliente al servidor, SELECT, ejecución única | 2 | 1
Cadenas de sentencias tranferidas desde el cliente al servidor | 1 | 1
Viajes de ida y vuelta desde el cliente al servidor, SELECT, ejecución repetida (n) | 1 + n | n
Cadenas de sentencias tranferidas desde el cliente al servidor | 1 plantilla, n veces parametro vinculado, si existe | n veces junto con el parámetro, si existe
API de vinculación de parámetros de entrada | Sí, escape de entradas automático | No, escape de entradas manual
API de vinculación de variables de salida | Sí | No
Soporte para el uso de la API mysqli_result | Sí, use mysqli_stmt_get_result() | Sí
Conjuntos de resultados almacenados en buffer | Sí, use mysqli_stmt_get_result() o la vinculación con mysqli_stmt_store_result() | Sí, lo predeterminado de mysqli_query()
Conjuntos de resultados no almacenados en buffer | Sí, use la API de vinculación de salida | Sí, use mysqli_real_query() con mysqli_use_result()
"Sabor" de la transferencia de datos del protocolo Cliente Servidor de MySQL | Protocolo binario | Protocolo de texto
Tipos de datos SQL de los valores del conjunto de resultados | Preservados al obtenerlos | Convertidos a cadena o preservados al obetenerlos
Soporta todas las sentencia SQL | Versiones reciente de MySQL soportan muchas pero no todas | Sí

Véase también

  • mysqli::__construct()
  • mysqli::query()
  • mysqli::prepare()
  • mysqli_stmt::prepare()
  • mysqli_stmt::execute()
  • mysqli_stmt::bind_param()
  • mysqli_stmt::bind_result()


Procedimientos almacenados

Las bases de datos de MySQL soportan procedimientos almacenados. Un procedimiento almacenado es una subrutina almacenada en el catálogo de la base de datos. Las aplicaciones pueden llamar y ejecutar el procedimiento almacenado. La sentencia de SQL CALL se usa para ejecutar un procedimiento almacenado.

Parámetros

Los procedimientos almacenados pueden tener parámetros IN, INOUT y OUT, dependiendo de la versión de MySQL. La interfaz mysqli no tiene una noción especial de los diferentes tipos de parámetros.

Parámetro IN

Los parámetros de entrada son proporcionados con la sentencia CALL. Asegúrese de que los valores están escapados correctamente.

Ejemplo #1 Llamar a un procedimiento almacenado

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query("CREATE PROCEDURE p(IN id_val INT) BEGIN INSERT INTO test(id) VALUES(id_val); END;")) {
    echo "Falló la creación del procedimiento almacenado: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("CALL p(1)")) {
    echo "Falló CALL: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($resultado = $mysqli->query("SELECT id FROM test"))) {
    echo "Falló SELECT: (" . $mysqli->errno . ") " . $mysqli->error;
}

var_dump($resultado->fetch_assoc());
?>

El resultado del ejemplo sería:

array(1) {
  ["id"]=>
  string(1) "1"
}

Parámetro INOUT/OUT

A los valores de los parámetros INOUT/OUT se acceden usando variables de sesión.

Ejemplo #2 Usar variables de sesión

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p(OUT msg VARCHAR(50)) BEGIN SELECT "¡Hola!" INTO msg; END;')) {
    echo "Falló la creación del procedimiento almacenado: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("SET @msg = ''") || !$mysqli->query("CALL p(@msg)")) {
    echo "Falló CALL: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($resultado = $mysqli->query("SELECT @msg as _p_out"))) {
    echo "Falló la obtención: (" . $mysqli->errno . ") " . $mysqli->error;
}

$fila = $resultado->fetch_assoc();
echo $fila['_p_out'];
?>

El resultado del ejemplo sería:

¡Hola!

Los desarrolladores de aplicaciones y framework pueden proporcionar una API más conveniente usando una mezcla de variables de sesiones e inspección del catálogo de la base de datos. Sin embargo, observe el posible impacto de rendimiento de una solución personalizada basada en la inspección del catálogo.

Manejar conjuntos de resultados

Los procedimientos almacenados pueden devolver conjuntos de resultados. Los conjuntos de resultados devueltos desde un procedimiento almacenado no se pueden obtener correctamente usando mysqli_query(). La función mysqli_query() combina la ejecución de la sentencia y la obtención del primer conjunto de resultados dentro de un conjunto de resultados almacenado en buffer, si existe. Sin embargo, existen unos conjuntos de resultados del procedimiento almacenado ocultos para el usuario que hacen que mysqli_query() falle al devolver los conjuntos de resultados esperados por el usuario.

Los conjuntos de resultados devueltos desde un procedimiento almacenado son obtenidos usando mysqli_real_query() o mysqli_multi_query(). Ambas funciones permiten la obtención de cualquier número de conjuntos de resultados devueltos por una sentencia, como CALL. El fallo de la obtención de todos los conjuntos de resultados devueltos por un procedimiento almacenado causa un error.

Ejemplo #3 Obtener los resultados de procedimientos almacenados

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Falló la creación del procedimiento almacenado: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->multi_query("CALL p()")) {
    echo "Falló CALL: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($resultado = $mysqli->store_result()) {
        printf("---\n");
        var_dump($resultado->fetch_all());
        $resultado->free();
    } else {
        if ($mysqli->errno) {
            echo "Store failed: (" . $mysqli->errno . ") " . $mysqli->error;
        }
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

El resultado del ejemplo sería:

---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
}
---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Uso de sentencias preparadas

No es necesario un trato especial al usar la interfaz de sentencias preparadas para obtener los resultados del mismo procedimiento almacenado de arriba. Las interfaces de sentencias preparadas y no preparadas son similares. Obserque que no todas las versioines del servidor de MYSQL pueden soportar la preparación de la sentencia SQL CALL.

Ejemplo #4 Procedimientos Almacenados y Sentencias Preparadas

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Falló la creación del procedimiento almacenado: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($sentencia = $mysqli->prepare("CALL p()"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$sentencia->execute()) {
    echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}

do {
    if ($resultado = $sentencia->get_result()) {
        printf("---\n");
        var_dump(mysqli_fetch_all($resultado));
        mysqli_free_result($resultado);
    } else {
        if ($sentencia->errno) {
            echo "Store failed: (" . $sentencia->errno . ") " . $sentencia->error;
        }
    }
} while ($sentencia->more_results() && $sentencia->next_result());
?>

Por supuesto, tamibién está soportado el uso de la API de vinculación para la obtención.

Ejemplo #5 Procedimientos Almacenados y Sentencias Preparadas usando la API de vinculación

<?php
if (!($sentencia = $mysqli->prepare("CALL p()"))) {
    echo "Falló la preparación: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$sentencia->execute()) {
    echo "Falló la ejecución: (" . $sentencia->errno . ") " . $sentencia->error;
}

do {

    $id_out = NULL;
    if (!$sentencia->bind_result($id_out)) {
        echo "Falló la vinculiación: (" . $sentencia->errno . ") " . $sentencia->error;
    }

    while ($sentencia->fetch()) {
        echo "id = $id_out\n";
    }
} while ($sentencia->more_results() && $sentencia->next_result());
?>

Véase también

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()


Sentencias Múltiples

MySQL permite opcionalmente tener múltiples sentencias en una cadena de sentencias. El envío de múltiples sentencias de una sola vez reduce los viajes de ida y vuelta desde el cliente al servidor, pero requiere un manejo especial.

Las sentencias múltiples o multiconsultas deben ser ejecutadas con mysqli_multi_query(). Las sentencias individuales de la cadena de sentencias están serparadas por un punto y coma. Entonces, todos los conjuntos de resultados devueltos por las sentencias ejecutadas deben ser obtenidos.

El servidor MySQL permite tener sentencias que devuelven conjuntos de resultados y sentencias que no devuelve conjuntos de resultados en una sentencia múltiple.

Ejemplo #1 Sentencias múltiples

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Falló la creación de la tabla: (" . $mysqli->errno . ") " . $mysqli->error;
}

$sql = "SELECT COUNT(*) AS _num FROM test; ";
$sql.= "INSERT INTO test(id) VALUES (1); ";
$sql.= "SELECT COUNT(*) AS _num FROM test; ";

if (!$mysqli->multi_query($sql)) {
    echo "Falló la multiconsulta: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($resultado = $mysqli->store_result()) {
        var_dump($resultado->fetch_all(MYSQLI_ASSOC));
        $resultado->free();
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "0"
  }
}
array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "1"
  }
}

Consideraciones de seguridad

Las funciones de la API mysqli_query() y mysqli_real_query() no establecen una bandera de conexión necesaria para activar las multiconsultas en el servidor. Se usa una llamada extra a la API para las sentencias múltiples para reducir la verosimilitud de los ataques de inyecciones SQL accidentales. Un atacante puede intentar añadir sentencias como ; DROP DATABASE mysql o ; SELECT SLEEP(999). Si el atacante tiene éxito al añadir SQL a la cadena de sentencias pero no se usa mysqli_multi_query, el servidor no ejecutará la segunda sentencia SQL inyectada y maliciosa.

Ejemplo #2 Inyección SQL

<?php
$mysqli    = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
$resultado = $mysqli->query("SELECT 1; DROP TABLE mysql.user");
if (!$resultado) {
    echo "Error al ejecutar la consulta: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

El resultado del ejemplo sería:

Error al ejecutar la consulta: (1064) You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the right syntax
to use near 'DROP TABLE mysql.user' at line 1

Sentencias preparadas

El uso de sentencias múltiples con sentencias preparadas no está soportado.

See also

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()


Soporte de la API para transacciones

El servidor MySQL soporta transacciones dependiendo de del motor de almacenamiento usado. Desde MySQL 5.5, el motor de almacenamiento predeterminado es InnoDB. InnoDB tiene soporte completo para transacciones ACID.

Las transacciones se pueden controlar usando SQL o llamadas a la API. Se recomienda usar llamadas a la API para habilitar y deshabilitar el modo de autoconsignación (auto commit) y para consignar y reiniciar transacciones.

Ejemplo #1 Establecer el modo de autoconsignación con SQL y a través de la API

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Recomendado: usar la API para cotrolar las configuraciones transaccionales */
$mysqli->autocommit(false);

/* No serán monitorizadas y reconocidas por la aplicación y el complemento de balance de carga */
if (!$mysqli->query('SET AUTOCOMMIT = 0')) {
    echo "Falló la consulta: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Los paquetes de características opcionales, como los comlementos de replicación y el de balance de carga, pueden fácilmente monitorizar llamadas a la API. El complemento de replicación transacciones conscientes del balance de carga, si las transacciones están controladas con llamadas a la API. Las transacciones conscientes del balance de carga no están disponibles si las sentencias SQL se usan para establecer el modo de autoconsignación, consignación y reinicio de una transacción.

Ejemplo #2 Consignación y reinicio

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
$mysqli->autocommit(false);

$mysqli->query("INSERT INTO test(id) VALUES (1)");
$mysqli->rollback();

$mysqli->query("INSERT INTO test(id) VALUES (2)");
$mysqli->commit();
?>

Observe que el servidor MySQL no puede reiniciar todas las sentencias. Algunoas sentencias causan una consignación implícia.

Véase también

  • mysqli::autocommit()
  • mysqli_result::commit()
  • mysqli_result::rollback()


Metadatos

Un conjunto de resultados de MySQL contiene metadatos. Los metadatos describen las columnas encontradas en el conjunto de resultados. Todos los metadatos enviados por MySQL son accesibles a travbés de la interfaz de mysqli. La extensión realiza cambios insignificantes o no realiza ninguno a la información que recibe. La diferencias entre versiones del servidor MySQL no están alineadas.

A los metadatos se puede acceder a través de la interfaz mysqli_result.

Ejemplo #1 Acceder a los metadatos de un conjunto de resultados

<?php
$mysqli = new mysqli("ejemplo.com", "usuario", "contraseña", "basedatos");
if ($mysqli->connect_errno) {
    echo "Falló la conexión a MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

$resultado = $mysqli->query("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
var_dump($resultado->fetch_fields());
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  object(stdClass)#3 (13) {
    ["name"]=>
    string(4) "_one"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(1)
    ["length"]=>
    int(1)
    ["charsetnr"]=>
    int(63)
    ["flags"]=>
    int(32897)
    ["type"]=>
    int(8)
    ["decimals"]=>
    int(0)
  }
  [1]=>
  object(stdClass)#4 (13) {
    ["name"]=>
    string(4) "_two"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(5)
    ["length"]=>
    int(5)
    ["charsetnr"]=>
    int(8)
    ["flags"]=>
    int(1)
    ["type"]=>
    int(253)
    ["decimals"]=>
    int(31)
  }
}

Sentencias preparadas

A los metadatos de un conjunto de resultados creado usando sentencias preparadas se accede de la misma manera. Un gestor de mysqli_result apropiado es devuelto por mysqli_stmt_result_metadata().

Ejemplo #2 Metadatos de sentencias preparadas

<?php
$sentencia = $mysqli->prepare("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
$sentencia->execute();
$resultado = $sentencia->result_metadata();
var_dump($resultado->fetch_fields());
?>

Véase también

  • mysqli::query()
  • mysqli_result::fetch_fields()


Requerimientos

Para contar con éstas funciones, debe compilar PHP con soporte de la extensión mysqli.

Nota:

La extensión mysqli está diseñado para funcionar con la versión de MySQL 4.1.13 o posterior, o 5.0.7 o posterior. Para versiones previas, por favor consulte la documentación de la extensión MySQL.


Instalación

La extensión mysqli se introdujo en la versión 5.0.0 de PHP. El Controlador Nativo de MySQL se introdujo en la versión 5.3.0 de PHP.

Instalación en Linux

Las distribuciones comunes de Unix incluyen versiones binarias de PHP que se pueden instalar. Aunque estas versiones binarias son típicamente construidas con soporte para las extensiones de MySQL, podría ser necesario instarlar las bibliotecas de extensiones en sí utilizando un paquete adicional. Compruebe el gestor de paquetes que viene con la distribución elegida para su disponibilidad.

Por ejemplo, en Ubuntu el paquete php5-mysql instala las extensiones de PHP ext/mysql, ext/mysqli, y pdo_mysql. En CentOS, el paquete php-mysql también instala estas tres extensiones de PHP.

De forma alternativa, esta extensión la puede compilar uno mismo. Construir PHP desde la fuente permite especificar las extensiones de MySQL que se quieren usar, así como elegir la biblioteca cliente para cada extensión.

La opción de la biblioteca cliente recomendada es el Controlador Nativio de MySQL, ya que sus resultados mejoran el rendimiento y dan acceso a características no disponibles cuando se utiliza la Biblioteca Cliente de MySQL. Consúlte ¿Qué es el Controlador Nativo de MySQL para PHP?, que contiene un breve resumen de las ventajas del Controlador Nativo de MySQL.

ruta/a/mysql_config representa la ubicación del programa mysql_config que viene con el Servidor de MySQL.

Matriz de soporte en tiempo de compilación de mysqli
PHP Versión | Por defecto | Opciones de configuración: mysqlnd | Opciones de configuración: libmysqlclient | Historial de cambios
5.4.x | mysqlnd | --with-mysqli | --with-mysqli=ruta/a/mysql_config | mysqlnd ahora es el predeterminado
5.3.x | libmysqlclient | --with-mysqli=mysqlnd | --with-mysqli=ruta/a/mysql_config | mysqlnd tiene soporte
5.0.x, 5.1.x, 5.2.x | libmysqlclient | No Disponible | --with-mysqli=ruta/a/mysql_config | mysqlnd no tiene soporte

Observe que es posible mezclar libremente extensiones de MySQL y bibliotecas cliente. Por ejemplo, es posible habilitar la extensión de MySQL para que emplee la Biblioteca Cliente de MySQL (libmysqlclient), mientras se configura la extensión mysqli para que utilice el Controlador Nativo de MySQL. No obstante, son posibles todas las permutaciones de extensiones y bibliotecas cliente.

Instalación en sistemas Windows

En Windows es más común instalar PHP con el instalador binario.

PHP 5.3.0 y posterior

En Windows, con las versiones 5.3 o superiores de PHP, la extensión mysqli viene habilitada y utiliza por omisión el Controlador Nativo de MySQL, lo que significa que no es necesario configurar el acceso a libmysql.dll.

PHP 5.0, 5.1, 5.2

En estas versiones antiguas de PHP sin soporte (PHP 5.2 alcanzó su final de vida útil el 6 de enero de 2011), son necesarios procedimientos adicionales de configuración para habilitar mysqli y especificar la biblioteca cliente que se va a utilizar.

La extensión mysqli no está habilitada por defecto, por lo que la DLL php_mysqli.dll debe habilitarse en php.ini. Para esto, es necesario encontrar el fichero php.ini (normalmente se encuentra en c:\php), y asegurarse de eliminar el comentario (punto y coma) al inicio de la línea extension=php_mysqli.dll, en la sección marcada como [PHP_MYSQLI].

Además, para utilizar la biblioteca cliente de MySQL con mysqli, debe asegurarse de que PHP puede acceder al fichero de la biblioteca cliente. La biblioteca cliente MySQL se incluye como un fichero de nombre libmysql.dll en la distribución de PHP en Windows. Este fichero debe estar disponible en la variable de entorno de sistema de Windows PATH, de modo que puede ser cargado con éxito. Véase la FAQ titulada "Cómo agrego mi directorio PHP a la variable PATH en Windows" para obtener información sobre cómo hacer esto. Copiar libmysql.dll al directorio de sistema de Windows (normalmente C:\Windows\System) funciona, pues el directorio de sistema esta por defecto en el PATH del sistema. Sin embargo, esta práctica está totalmente desaconsejada.

Al igual que con cualquier otra extensión de PHP (como php_mysqli.dll), la directiva de PHP extension_dir se debe establecer en el directorio donde están ubicadas las extensiones de PHP. Consulte tambien el Manual de instalación de Windows. Un ejemplo de valor de extension_dir para PHP 5 es c:\php\ext.

Nota:

Si al iniciar el servidor web un error similar al siguiente ocurre: "Unable to load dynamic library './php_mysqli.dll'", esto es porque php_mysqli.dll y/o libmysql.dll no pudo ser encontrado por el sistema.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de MySQLi
Nombre | Por defecto | Cambiable | Historial de cambios
mysqli.allow_local_infile | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.2.4.
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqli.max_links | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_host | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.reconnect | "0" | PHP_INI_SYSTEM | Disponible desde PHP 4.3.5.
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | Disponible desde PHP 5.6.0.

Para más detalles y definiciones de las constantes de PHP_INI_* , véase el capítulo sobre los cambios de configuración.

He aquí una breve explicación de las directivas de configuración.

mysqli.allow_local_infile integer

Permite el acceso, desde la perspectiva de PHP, de los archivos locales con sentencias LOAD DATA

mysqli.allow_persistent integer

Habilitar la capacidad de crear conexiones persistentes usando mysqli_connect().

mysqli.max_persistent integer

Máximo de conexiones persistentes que se pueden hacer. Se establece en 0 para ilimitado.

mysqli.max_links integer

Número máximo de conexiones con MySQL por proceso.

mysqli.default_port integer

El número de puerto TCP predeterminado a utilizar cuando se conecta a el servidor de base de datos si no se especifica ningún otro puerto. Si no se especifica el valor predeterminado, el puerto se obtendrá de MYSQL_TCP_PORT variable de entorno, la entrada mysql-tcp en /etc/services o en la constante en tiempo de compilación MYSQL_PORT constante, en ese orden. Win32 sólo utilizará la constante MYSQL_PORT.

mysqli.default_socket string

El nombre de socket predeterminado a usar cuando se conecta a un servidor de bases de datos local si no se especifica ningún otro nombre de socket.

mysqli.default_host string

Servidor host predeterminado a usar cuando se conecta al servidor de base de datos si no se indica otro.

mysqli.default_user string

El nombre de usuario predeterminado a usar cuando se conecta a la base de datos servidor si no se indica otra.

mysqli.default_pw string

La contraseña predeterminada a usar cuando se conecta a la base de datos servidor si no se indica otra.

mysqli.reconnect integer

Vuelve a conectar automáticamente si se pierde la conexión.

Nota: Este ajuste php.ini es ignorado por el controlador de mysqlnd.

mysqli.rollback_on_cached_plink bool

Empleado para revertir conexiones puesta de nuevo la provisión de conexiones persistentes.

El usuario no puede modificar MYSQL_OPT_READ_TIMEOUT mediante una llamada a la API o con ajustes de configuración en tiempo de ejecución. Tenga en cuenta que si fuera posible habría diferencias entre cómo interpretarían libmysqlclient y los flujos el valor de MYSQL_OPT_READ_TIMEOUT.


  • « Configuración en tiempo de ejecución
  • La extensión mysqli y conexiones persistentes »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


La extensión mysqli y conexiones persistentes

EL soporte para conexiones persistentes fue introducido en PHP 5.3 para el extensión mysqli. El soporte ya estaba presente en PDO MYSQL y ext/mysql. La idea detrás de las conexiones persistentes es que una conexión entre un proceso cliente y una base de datos puede ser reutilizados por un proceso cliente, en lugar de ser creado y destruido varias veces. Esto reduce la sobrecarga de la creación de conexiones nuevas cada vez que es requerido, como las conexiones no utilizadas se almacenan en caché y están lista para ser reutilizadas.

A diferencia de la extensión mysql, mysqli no proporciona una función separada para la apertura de conexiones persistentes. Para abrir una conexión persistente debe de colocar p: al nombre del host cuando se conecta.

El problema con las conexiones persistentes es que se pueden dejar en estados impredecibles por los clientes. Por ejemplo, un bloqueo de tabla puede ser activado antes de que un cliente termina de forma inesperada. Un nuevo proceso cliente reusando esta conexión persistente tendrá la conexión tal cual. Toda la limpieza tendría que ser realizada por el nuevo proceso cliente antes de que pudiera hacer buen uso de la conexión persistente, aumentando la carga sobre el programador.

La conexión persistente de la extensión mysqli no obstante incorpora manejo para limpieza de código. La limpieza llevada a cabo por mysqli incluye:

  • Rollback de transacciones activas

  • Cierre y borrado de tablas temporales

  • Desbloque de tablas

  • Reestablece variables de sesión

  • Cerrar consultas preparadas (siempre pasa con PHP)

  • Cerrar controlador

  • Quitar bloqueos adquiridos con GET_LOCK()

Esto asegura que las conexiones persistentes se encuentran en un estado limpio para el retorno del conjunto de conexiones, antes de que el proceso cliente los use.

La extensión mysqli hace la limpieza automáticamente llamando a la función mysql_change_user() de C-API.

La característica de limpieza automática tiene sus ventajas y desventajas aunque. La ventaja es que el programador no necesita preocuparse por estar añadiendo el código de limpieza, ya que es llamdo automáticamente. Asi mismo, la desventaja es que el código podría volverse potencialmente un poco más lento, pues el código para realizar la limpieza necesita ejecutarse cada vez que una conexión es devuelta por el conjunto de conexiones.

Es posible desactivar el código de limpieza automática, mediante la compilación de PHP si se define MYSQLI_NO_CHANGE_USER_ON_PCONNECT.

Nota:

La extensión mysqli soporta conexiones persistentes utilizando ya sea el driver nativo de MySQL o la libreria cliente de MySQL.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

MYSQLI_READ_DEFAULT_GROUP

Lee las opciones del grupo mencionado de my.cnf o del archivo especificado con MYSQLI_READ_DEFAULT_FILE

MYSQLI_READ_DEFAULT_FILE

Lee las opciones de la opcion llamada archivo en lugar de my.cnf

MYSQLI_OPT_CONNECT_TIMEOUT

Tiempo de espera de conexión en segundos

MYSQLI_OPT_LOCAL_INFILE

Permite comando LOAD LOCAL INFILE

MYSQLI_INIT_COMMAND

Comando a ejecutar cuando se conecta al servidor MySQL. Puede ser re-ejecutado automáticamente cuando se reconecta.

MYSQLI_CLIENT_SSL

Usar SSL (protocolo de cifrado). Esta opción no debe ser fijado por los programas de aplicación; se establece internamente en la biblioteca cliente de MySQL

MYSQLI_CLIENT_COMPRESS

Usar protocolo de compresión

MYSQLI_CLIENT_INTERACTIVE

Permite interactive_timeout segundos (en lugar de wait_timeout segundos) de inactividad antes de cerrar la conexión. La variable sesión del cliente wait_timeout se establecerá en el valor de la variable de sesión interactive_timeout.

MYSQLI_CLIENT_IGNORE_SPACE

Permite espacios después de nombres de función. Hace que todos los nombres de las funciones sean palabras reservadas.

MYSQLI_CLIENT_NO_SCHEMA

No permite la sistaxisdb_name.tbl_name.col_name.

MYSQLI_CLIENT_MULTI_QUERIES

Permite consultas con multiples punto y coma en una sola llamada a mysqli_query().

MYSQLI_STORE_RESULT

Utilizar conjuntos de resultados almacenado temporalmente

MYSQLI_USE_RESULT

Utilizar conjuntos de resultados sin almacenado temporal

MYSQLI_ASSOC

Las columnas son devueltas en el array teniendo el nombre del campo como índice del array.

MYSQLI_NUM

Las columnas son devueltas en el array teniendo un índice enumerado.

MYSQLI_BOTH

Las columnas son devueltas en el array teniendo tanto un índice numérico y el nombre del campo como el índice asociativo.

MYSQLI_NOT_NULL_FLAG

Indica que un campo ha sido definido como NOT NULL

MYSQLI_PRI_KEY_FLAG

El campo es parte de un índice primario.

MYSQLI_UNIQUE_KEY_FLAG

El campo es parte de un índice único.

MYSQLI_MULTIPLE_KEY_FLAG

El campo es parte de un índice.

MYSQLI_BLOB_FLAG

El campo es definido como BLOB

MYSQLI_UNSIGNED_FLAG

El campo es definido como UNSIGNED

MYSQLI_ZEROFILL_FLAG

El campo es definido como ZEROFILL

MYSQLI_AUTO_INCREMENT_FLAG

El campo es definido como AUTO_INCREMENT

MYSQLI_TIMESTAMP_FLAG

El campo es definido como TIMESTAMP

MYSQLI_SET_FLAG

El campo es definido como SET

MYSQLI_NUM_FLAG

El campo es definido como NUMERIC

MYSQLI_PART_KEY_FLAG

El campo es parte de un multi-índice

MYSQLI_GROUP_FLAG

El campo es parte GROUP BY

MYSQLI_TYPE_DECIMAL

El campo es definido como DECIMAL

MYSQLI_TYPE_NEWDECIMAL

La precisión matemática del campo DECIMAL o NUMERIC (MySQL 5.0.3 y posteriores)

MYSQLI_TYPE_BIT

El campo es definido como BIT (MySQL 5.0.3 y posteriores)

MYSQLI_TYPE_TINY

El campo es definido como TINYINT

MYSQLI_TYPE_SHORT

El campo es definido como SMALLINT

MYSQLI_TYPE_LONG

El campo es definido como INT

MYSQLI_TYPE_FLOAT

El campo es definido como FLOAT

MYSQLI_TYPE_DOUBLE

El campo es definido como DOUBLE

MYSQLI_TYPE_NULL

El campo es definido como DEFAULT NULL

MYSQLI_TYPE_TIMESTAMP

El campo es definido como TIMESTAMP

MYSQLI_TYPE_LONGLONG

El campo es definido como BIGINT

MYSQLI_TYPE_INT24

El campo es definido como MEDIUMINT

MYSQLI_TYPE_DATE

El campo es definido como DATE

MYSQLI_TYPE_TIME

El campo es definido como TIME

MYSQLI_TYPE_DATETIME

El campo es definido como DATETIME

MYSQLI_TYPE_YEAR

El campo es definido como YEAR

MYSQLI_TYPE_NEWDATE

El campo es definido como DATE

MYSQLI_TYPE_INTERVAL

El campo es definido como INTERVAL

MYSQLI_TYPE_ENUM

El campo es definido como ENUM

MYSQLI_TYPE_SET

El campo es definido como SET

MYSQLI_TYPE_TINY_BLOB

El campo es definido como TINYBLOB

MYSQLI_TYPE_MEDIUM_BLOB

El campo es definido como MEDIUMBLOB

MYSQLI_TYPE_LONG_BLOB

El campo es definido como LONGBLOB

MYSQLI_TYPE_BLOB

El campo es definido como BLOB

MYSQLI_TYPE_VAR_STRING

El campo es definido como VARCHAR

MYSQLI_TYPE_STRING

El campo es definido como CHAR o BINARY

MYSQLI_TYPE_CHAR

El campo es definido como TINYINT. Para CHAR, ver MYSQLI_TYPE_STRING

MYSQLI_TYPE_GEOMETRY

El campo es definido como GEOMETRY

MYSQLI_NEED_DATA

Más datos disponibles para enlazar la variable

MYSQLI_NO_DATA

No más datos disponibles para enlazar la variable

MYSQLI_DATA_TRUNCATED

Ocurrio truncado de datos. Disponible desde PHP 5.1.0 y MySQL 5.0.5.

MYSQLI_ENUM_FLAG

El campo es definido como ENUM. Disponible desde PHP 5.3.0.

MYSQLI_BINARY_FLAG

El campo es definido como BINARY. Disponible desde PHP 5.3.0.

MYSQLI_CURSOR_TYPE_FOR_UPDATE

MYSQLI_CURSOR_TYPE_NO_CURSOR

MYSQLI_CURSOR_TYPE_READ_ONLY

MYSQLI_CURSOR_TYPE_SCROLLABLE

MYSQLI_STMT_ATTR_CURSOR_TYPE

MYSQLI_STMT_ATTR_PREFETCH_ROWS

MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH

MYSQLI_SET_CHARSET_NAME

MYSQLI_REPORT_INDEX

Informar de si no se utilizó un índice o si se utilizó uno erróneo en una conuslta.

MYSQLI_REPORT_ERROR

Informar de los errores de las llamadas a las funciones de mysqli.

MYSQLI_REPORT_STRICT

Lanza una excepción de tipo mysqli_sql_exception para errores en vez de para advertencias.

MYSQLI_REPORT_ALL

Activar todas las opciones (informar de todo).

MYSQLI_REPORT_OFF

Desactivar la información.

MYSQLI_DEBUG_TRACE_ENABLED

Se establece a 1 si la funcionalidad mysqli_debug() está activada.

MYSQLI_SERVER_QUERY_NO_GOOD_INDEX_USED

MYSQLI_SERVER_QUERY_NO_INDEX_USED

MYSQLI_REFRESH_GRANT

Refresca las tablas grant.

MYSQLI_REFRESH_LOG

Vuelca los logs, como al ejecutar la sentencia SQL FLUSH LOGS.

MYSQLI_REFRESH_TABLES

Vuelca la cache de tablas, como al ejecutar la sentencia SQL FLUSH TABLES.

MYSQLI_REFRESH_HOSTS

Vuelca la cache de hosts, como al ejecutar la sentencia SQL FLUSH HOSTS.

MYSQLI_REFRESH_STATUS

Reinicia las variables de estado, como al ejecutar la sentencia SQL FLUSH STATUS.

MYSQLI_REFRESH_THREADS

Vuelca la cache de hilos.

MYSQLI_REFRESH_SLAVE

En un servidor esclavo de réplica: reinicia la información maestra del servidor, y reanuda el servidor. Como al ejecutar la sentencia SQL RESET SLAVE.

MYSQLI_REFRESH_MASTER

En un servidor esclavo de réplica: elimna los ficheros log binarios listados en el índice log binario, y trunca el fichero índice. Como al ejecutar la sentencia SQL RESET MASTER.

MYSQLI_TRANS_COR_AND_CHAIN

Añade "AND CHAIN" a mysqli_commit() o mysqli_rollback().

MYSQLI_TRANS_COR_AND_NO_CHAIN

Añade "AND NO CHAIN" a mysqli_commit() o mysqli_rollback().

MYSQLI_TRANS_COR_RELEASE

Añade "RELEASE" a mysqli_commit() o mysqli_rollback().

MYSQLI_TRANS_COR_NO_RELEASE

Añade "NO RELEASE" a mysqli_commit() o mysqli_rollback().

MYSQLI_TRANS_START_READ_ONLY

Iniciar la transacción como "START TRANSACTION READ ONLY" con mysqli_begin_transaction().

MYSQLI_TRANS_START_READ_WRITE

Iniciar la transacción como "START TRANSACTION READ WRITE" com mysqli_begin_transaction().

MYSQLI_TRANS_START_CONSISTENT_SNAPSHOT

Iniciar la transacción como "START TRANSACTION WITH CONSISTENT SNAPSHOT" con mysqli_begin_transaction().


Notas

Algunas notas sobre la implementación:

  1. El soporte para MYSQL_TYPE_GEOMETRY fue agregado a la extensión MySQLi en PHP 5.3.

  2. Nótese que existen diferentes implementaciones internas en libmysqlclient y mysqlnd para manejar columnas del tipo MYSQL_TYPE_GEOMETRY. En términos generales, mysqlnd asignará significativamente menos memoria. Por ejemplo, si hay una columna POINT en un set de resultado, libmysqlclient puede pre-asignar hasta 4GB de RAM aunque se necesitan menos de 50 bytes para mantener una comuna POINT en memoria. La asignación de memoria es mucho menor, menos de 50 bytes, si se utiliza mysqlnd.


Resumen de las funciones de la extensión MySQLi

Resumen de los métodos de mysqli
Clase mysqli
Interfaz POO | Interfaz de procedimiento | Alias (no usar) | Descripción
Propiedades
$mysqli::affected_rows | mysqli_affected_rows() | N/A | Obtiene el número de filas afectadas en una operación previa de MySQL
$mysqli::client_info | mysqli_get_client_info() | N/A | Devuelve la versión del cliente de MySQL como una cadena
$mysqli::client_version | mysqli_get_client_version() | N/A | Devuelve la versión del cliente de MySQL como un entero
$mysqli::connect_errno | mysqli_connect_errno() | N/A | Devuelve el código de error de la última llamada de conexión
$mysqli::connect_error | mysqli_connect_error() | N/A | Devuelve una cadena descriptiva del último error de conexión
$mysqli::errno | mysqli_errno() | N/A | Devuelve el código de error para la función invocada más reciente
$mysqli::error | mysqli_error() | N/A | Devulve una cadena descriptiva del último error
$mysqli::field_count | mysqli_field_count() | N/A | Devuelve el número de columnas de la consulta más reciente
$mysqli::host_info | mysqli_get_host_info() | N/A | Devuelve una cadena que representa el tipo de conexión utilizado
$mysqli::protocol_version | mysqli_get_proto_info() | N/A | Devuelve la versión del protocolo de MySQL usada
$mysqli::server_info | mysqli_get_server_info() | N/A | Devuelve la versión del servidor MySQL
$mysqli::server_version | mysqli_get_server_version() | N/A | Devuelve la versión del servidor MySQL como un entero
$mysqli::info | mysqli_info() | N/A | Recupera información sobre la última consulta ejecutada
$mysqli::insert_id | mysqli_insert_id() | N/A | Devuelve el identificador (ID) autogenerado usado en la última consulta
$mysqli::sqlstate | mysqli_sqlstate() | N/A | Devuelve el error SQLSTATE de la operación previa de MySQL
$mysqli::warning_count | mysqli_warning_count() | N/A | Devuelve el número de advertencias de la última consulta para el enlace dado
Methods
mysqli::autocommit() | mysqli_autocommit() | N/A | Activa o desactiva la autoconsigna de modificaciones de la base de datos
mysqli::change_user() | mysqli_change_user() | N/A | Cambia el usuario de la conexión de base de datos especificada
mysqli::character_set_name(), mysqli::client_encoding | mysqli_character_set_name() | mysqli_client_encoding() | Devuelve el juego de caracteres predeterminado para la conexión de base de datos
mysqli::close() | mysqli_close() | N/A | Cierra una conexión de base de datos previamente abierta
mysqli::commit() | mysqli_commit() | N/A | Ejecuta la transacción actual
mysqli::__construct() | mysqli_connect() | N/A | Abrir una nueva conexión al servidor MySQL [Nota: método estático (es decir, de clase)]
mysqli::debug() | mysqli_debug() | N/A | Realiza operaciones de depuración
mysqli::dump_debug_info() | mysqli_dump_debug_info() | N/A | Volcado de la información de depuración en el registro
mysqli::get_charset() | mysqli_get_charset() | N/A | Devuelve un conjunto de caracteres objeto
mysqli::get_connection_stats() | mysqli_get_connection_stats() | N/A | Devuelve las estadísticas de conexión de cliente. Disponible sólo con mysqlnd.
mysqli::get_client_info() | mysqli_get_client_info() | N/A | Devuelve la versión de cliente de MySQL como una cadena
mysqli::get_client_stats() | mysqli_get_client_stats() | N/A | Devuelve las estadísticas del cliente por proceso. Disponible sólo con mysqlnd.
mysqli::get_cache_stats() | mysqli_get_cache_stats() | N/A | Devuelve las estadísticas de clientes Zval caché. Disponible sólo con mysqlnd.
mysqli::get_server_info() | mysqli_get_server_info() | N/A | Devuelve un string que representa la versión del servidor de MySQL a la que está conectada la extensión MySQLi
mysqli::get_warnings() | mysqli_get_warnings() | N/A | NO DOCUMENTADA
mysqli::init() | mysqli_init() | N/A | Inicializa MySQLi y devuelve un recurso para su uso con mysqli_real_connect. [No invocado dentro de un objeto, ya que devuelve un objeto $ mysqli.]
mysqli::kill() | mysqli_kill() | N/A | Pide al servidor matar un hilo de MySQL
mysqli::more_results() | mysqli_more_results() | N/A | Compruebe si hay más resultados para una consulta de múltiple
mysqli::multi_query() | mysqli_multi_query() | N/A | Ejecuta una consulta en la base de datos
mysqli::next_result() | mysqli_next_result() | N/A | Prepara próximo resultado de multi_query
mysqli::options() | mysqli_options() | mysqli_set_opt() | Establecer opciones
mysqli::ping() | mysqli_ping() | N/A | Hace ping una conexión de servidor, o intenta volver a conectar si la conexión se ha caído
mysqli::prepare() | mysqli_prepare() | N/A | Prepara una sentencia SQL para su ejecución
mysqli::query() | mysqli_query() | N/A | Ejecuta una consulta en la base de datos
mysqli::real_connect() | mysqli_real_connect() | N/A | Abre una conexión a un servidor MySQL
mysqli::real_escape_string(), mysqli::escape_string() | mysqli_real_escape_string() | mysqli_escape_string() | Escapa caracteres especiales de una cadena en una sentencia SQL, teniendo en cuenta el conjunto de caracteres actual de la conexión
mysqli::real_query() | mysqli_real_query() | N/A | Ejecutar una consulta SQL
mysqli::refresh() | mysqli_refresh() | N/A | Vuelca tablas o caches, o reinicia la información del servidor réplica
mysqli::rollback() | mysqli_rollback() | N/A | Deshace la transacción actual
mysqli::select_db() | mysqli_select_db() | N/A | Selecciona la base de datos predeterminada para las consultas de la base de datos
mysqli::set_charset() | mysqli_set_charset() | N/A | Establece el conjunto de carácteres predeterminado del cliente
mysqli::set_local_infile_default() | mysqli_set_local_infile_default() | N/A | Quita el controlador de usuario definidos para la carga de comandos infile locales
mysqli::set_local_infile_handler() | mysqli_set_local_infile_handler() | N/A | establece la funcion callback para el comando LOAD DATA LOCAL INFILE
mysqli::ssl_set() | mysqli_ssl_set() | N/A | Utilizada para establecer conexiones seguras usando SSL
mysqli::stat() | mysqli_stat() | N/A | Obtiene el estado actual del sistema
mysqli::stmt_init() | mysqli_stmt_init() | N/A | Inicializa una sentencia y devuelve un objeto para su uso con mysqli_stmt_prepare
mysqli::store_result() | mysqli_store_result() | N/A | Transfier un conjunto de resultados de la última consulta
mysqli::thread_id() | mysqli_thread_id() | N/A | Retorna el ID del hilo para la conexión actual
mysqli::thread_safe() | mysqli_thread_safe() | N/A | Retorna si la seguridad del hilo enlace se da o no
mysqli::use_result() | mysqli_use_result() | N/A | Inicia un conjunto de resultados de recuperación
Resumen de los métodos de mysqli_stmt
MySQL_STMT
Interfaz POO | Interfaz de procedimiento | Alias (no usar) | Descripción
Propiedades
$mysqli_stmt::affected_rows | mysqli_stmt_affected_rows() | N/A | Devuelve el número total de registros actualizados, eliminados o insertados por la última sentencia ejecutada
$mysqli_stmt::errno | mysqli_stmt_errno() | N/A | Devuelve el código de error para la sentencia recientemente llamada
$mysqli_stmt::error | mysqli_stmt_error() | N/A | Devuelve una cadena de descripción de la última sentencia de error
$mysqli_stmt::field_count | mysqli_stmt_field_count() | N/A | Devuelve el número de campo en la sentencia dada - no ducumentada
$mysqli_stmt::insert_id | mysqli_stmt_insert_id() | N/A | Obtener el Identificador (ID) generado en la operación de INSERT anterior
$mysqli_stmt::num_rows | mysqli_stmt_num_rows() | N/A | Devuelve el número de filas en las sentencias del conjunto de resultados
$mysqli_stmt::param_count | mysqli_stmt_param_count() | mysqli_param_count() | Devuelve el número de parámetros para la sentencia dada
$mysqli_stmt::sqlstate | mysqli_stmt_sqlstate() | N/A | Devuelve el error SQLSTATE de la operación de la declaración anterior
Métodos
mysqli_stmt::attr_get() | mysqli_stmt_attr_get() | N/A | Usado para obtener el valor actual de un atributo de una setencia
mysqli_stmt::attr_set() | mysqli_stmt_attr_set() | N/A | Usado para modificar el comportamiento de una sentencia preparada
mysqli_stmt::bind_param() | mysqli_stmt_bind_param() | mysqli_bind_param() | Agrega variables a una sentencia preparada como parámetros
mysqli_stmt::bind_result() | mysqli_stmt_bind_result() | mysqli_bind_result() | Agrega variables a una sentencia prepearada para el almacenamiento de resultado
mysqli_stmt::close() | mysqli_stmt_close() | N/A | Cierra una sentencia preparada
mysqli_stmt::data_seek() | mysqli_stmt_data_seek() | N/A | Busca a una fila arbitraria en el conjunto de resultados de una sentencia
mysqli_stmt::execute() | mysqli_stmt_execute() | mysqli_execute() | Ejecuta una consulta preparada
mysqli_stmt::fetch() | mysqli_stmt_fetch() | mysqli_fetch() | Recuperar los resultados de una sentencia preparada en las variables ligadas
mysqli_stmt::free_result() | mysqli_stmt_free_result() | N/A | Libera la memoria almacenada resultado del manejar de sentencia
mysqli_stmt::get_result() | mysqli_stmt_get_result() | N/A | Obtiene un conjunto de resultados de una sentencia preparada Disponible sólo con mysqlnd.
mysqli_stmt::get_warnings() | mysqli_stmt_get_warnings() | N/A | NO DOCUMENTADA
mysqli_stmt::more_results() | mysqli_stmt_more_results() | N/A | Comprueba si existen más resultados de consultas de una consulta múltiple
mysqli_stmt::next_result() | mysqli_stmt_next_result() | N/A | Lee el siguiente resultado de una consulta múltiple
mysqli_stmt::num_rows() | mysqli_stmt_num_rows() | N/A | Véase también la propiedad $mysqli_stmt::num_rows
mysqli_stmt::prepare() | mysqli_stmt_prepare() | N/A | Preparar una sentencia SQL para su ejecución
mysqli_stmt::reset() | mysqli_stmt_reset() | N/A | Restablece una sentencia preparada
mysqli_stmt::result_metadata() | mysqli_stmt_result_metadata() | mysqli_get_metadata() | Devuelve un conjunto de resultados de metadatos de una setencia preparada
mysqli_stmt::send_long_data() | mysqli_stmt_send_long_data() | mysqli_send_long_data() | Envia los datos en bloques
mysqli_stmt::store_result() | mysqli_stmt_store_result() | N/A | Transfiere un conjunto de resultados de una sentencia preparada
Resumen de los métodos de mysqli_result
mysqli_result
Interfaz POO | Interfaz de procedimiento | Alias (No usar) | Descripcíon
Propiedades
$mysqli_result::current_field | mysqli_field_tell() | N/A | Obtener el campo de desplazamiento actual de un puntero de resultado
$mysqli_result::field_count | mysqli_num_fields() | N/A | Obtiene el número de campos de un resultado
$mysqli_result::lengths | mysqli_fetch_lengths() | N/A | Devuelve la longitud de las columnas de la fila actual en el conjunto de resultados
$mysqli_result::num_rows | mysqli_num_rows() | N/A | Obtiene el número de filas de un resultado
Métodos
mysqli_result::data_seek() | mysqli_data_seek() | N/A | Ajusta el puntero del resultado a una fila arbitraria en el resultado
mysqli_result::fetch_all() | mysqli_fetch_all() | N/A | Obtiene todas las filas de resultados y devuelve el resultado como un array asociativo, una array numérico, o ambos. Disponible sólo con mysqlnd.
mysqli_result::fetch_array() | mysqli_fetch_array() | N/A | Extrae la fila de deresultados como asociativo, un array numérico, o ambas
mysqli_result::fetch_assoc() | mysqli_fetch_assoc() | N/A | Extrae la fila de resultados como un array asociativo
mysqli_result::fetch_field_direct() | mysqli_fetch_field_direct() | N/A | Extrae metadatos para un solo campo
mysqli_result::fetch_field() | mysqli_fetch_field() | N/A | Devuelve el siguiente campo en el conjunto de resultados
mysqli_result::fetch_fields() | mysqli_fetch_fields() | N/A | Devuelve un array de objetos que representan los campos de un conjunto de resultados
mysqli_result::fetch_object() | mysqli_fetch_object() | N/A | Devuelve la fila actual del resultado en forma de un objeto
mysqli_result::fetch_row() | mysqli_fetch_row() | N/A | Obtiene una fila de resultados como un array enumerado
mysqli_result::field_seek() | mysqli_field_seek() | N/A | Establece el puntero del resultado a un determinado campo de desplazamiento
mysqli_result::free(), mysqli_result::close, mysqli_result::free_result | mysqli_free_result() | N/A | Libera la memoria asociada con un resultado
Resumen de los métodos de mysqli_driver
MySQL_Driver
Interfaz POO | Interfaz de procedimiento | Alias (no usar) | Descripción
Propiedades
N/A
Métodos
mysqli_driver::embedded_server_end() | mysqli_embedded_server_end() | N/A | NO DOCUMENTADA
mysqli_driver::embedded_server_start() | mysqli_embedded_server_start() | N/A | NO DOCUMENTADA

Nota:

Las funciones alias se proporcionan para compatibilidad con versiones anteriores solamente. No los use en nuevos proyectos.


  • « Resumen de las funciones de la extensión MySQLi
  • Ejemplos básicos de la extensión MySQLi »
  • PHP Manual
  • MySQLi
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplos básicos de la extensión MySQLi


Ejemplos básicos de la extensión MySQLi

Este ejemplo muestra cómo conectarse, ejecutar una consulta, utilizar un manejo de errores básico, imprimir filas de resultados, y desconectarse de una base de datos de MySQL.

Este ejemplo emplea la base de datos de libre disposición Sakila, la cual puede descargarse desde » dev.mysql.com, tal como se describe aquí. Para que este ejemplo funcione, (a) instalar sakila y (b) modificar las variables de conexión (host, tu_usuario, tu_contraseña).

Ejemplo #1 Ejemplo resumen de la extensión MySQLi

<?php
// Vamos a pasar una variable $_GET a nuestro ejemplo, en este caso es
// 'aid' para 'actor_id' de nuestra base de datos Sakila. Le vamos a asignar un
// valor predeterminado de 1, y a amoldarla a un integer para evitar inyecciones
// de SQL y/o problemas de seguridad relacionados. El manejo de todo esto va más
// allá del alcance de este sencillo ejemplo:
//   http://example.org/script.php?aid=42
if (isset($_GET['aid']) && is_numeric($_GET['aid'])) {
    $aid = (int) $_GET['aid'];
} else {
    $aid = 1;
}

// Conectarse a y seleccionar una base de datos de MySQL llamada sakila
// Nombre de host: 127.0.0.1, nombre de usuario: tu_usuario, contraseña: tu_contraseña, bd: sakila
$mysqli = new mysqli('127.0.0.1', 'tu_usuario', 'tu_contraseña', 'sakila');

// ¡Oh, no! Existe un error 'connect_errno', fallando así el intento de conexión
if ($mysqli->connect_errno) {
    // La conexión falló. ¿Que vamos a hacer?
    // Se podría contactar con uno mismo (¿email?), registrar el error, mostrar una bonita página, etc.
    // No se debe revelar información delicada

    // Probemos esto:
    echo "Lo sentimos, este sitio web está experimentando problemas.";

    // Algo que no se debería de hacer en un sitio público, aunque este ejemplo lo mostrará
    // de todas formas, es imprimir información relacionada con errores de MySQL -- se podría registrar
    echo "Error: Fallo al conectarse a MySQL debido a: \n";
    echo "Errno: " . $mysqli->connect_errno . "\n";
    echo "Error: " . $mysqli->connect_error . "\n";

    // Podría ser conveniente mostrar algo interesante, aunque nosotros simplemente saldremos
    exit;
}

// Realizar una consulta SQL
$sql = "SELECT actor_id, first_name, last_name FROM actor WHERE actor_id = $aid";
if (!$resultado = $mysqli->query($sql)) {
    // ¡Oh, no! La consulta falló.
    echo "Lo sentimos, este sitio web está experimentando problemas.";

    // De nuevo, no hacer esto en un sitio público, aunque nosotros mostraremos
    // cómo obtener información del error
    echo "Error: La ejecución de la consulta falló debido a: \n";
    echo "Query: " . $sql . "\n";
    echo "Errno: " . $mysqli->errno . "\n";
    echo "Error: " . $mysqli->error . "\n";
    exit;
}

// ¡Uf, lo conseguimos!. Sabemos que nuestra conexión a MySQL y nuestra consulta
// tuvieron éxito, pero ¿tenemos un resultado?
if ($resultado->num_rows === 0) {
    // ¡Oh, no ha filas! Unas veces es lo previsto, pero otras
    // no. Nosotros decidimos. En este caso, ¿podría haber sido
    // actor_id demasiado grande?
    echo "Lo sentimos. No se pudo encontrar una coincidencia para el ID $aid. Inténtelo de nuevo.";
    exit;
}

// Ahora, sabemos que existe solamente un único resultado en este ejemplo, por lo
// que vamos a colocarlo en un array asociativo donde las claves del mismo son los
// nombres de las columnas de la tabla
$actor = $resultado->fetch_assoc();
echo "A veces veo a " . $actor['first_name'] . " " . $actor['last_name'] . " en la TV.";

// Ahora, vamor a obtener cinco actores aleatorios y a imprimir sus nombres en una lista.
// El manejo de errores va a ser menor aquí, aunque ya sabemos como hacerlo
$sql = "SELECT actor_id, first_name, last_name FROM actor ORDER BY rand() LIMIT 5";
if (!$resultado = $mysqli->query($sql)) {
    echo "Lo sentimos, este sitio web está experimentando problemas.";
    exit;
}

// Imprimir nuestros cinco actores aleatorios en una lista, y enlazar cada uno
echo "<ul>\n";
while ($actor = $resultado->fetch_assoc()) {
    echo "<li><a href='" . $_SERVER['SCRIPT_FILENAME'] . "?aid=" . $actor['actor_id'] . "'>\n";
    echo $actor['first_name'] . ' ' . $actor['last_name'];
    echo "</a></li>\n";
}
echo "</ul>\n";

// El script automáticamente liberará el resultado y cerrará la conexión
// a MySQL cuando finalice, aunque aquí lo vamos a hacer nostros mismos
$resultado->free();
$mysqli->close();
?>


La clase mysqli

(PHP 5, PHP 7)

Introducción

Representa una conexión entre PHP y una base de datos MySQL.

Sinopsis de la Clase

mysqli {
/* Propiedades */
int $affected_rows;
int $connect_errno;
string $connect_error;
int $errno;
array $error_list;
string $error;
int $field_count;
int $client_version;
string $host_info;
string $protocol_version;
string $server_info;
int $server_version;
string $info;
mixed $insert_id;
string $sqlstate;
int $thread_id;
int $warning_count;
/* Métodos */
__construct
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
)
autocommit ( bool $mode ) : bool
change_user ( string $user , string $password , string $database ) : bool
character_set_name ( ) : string
close ( ) : bool
commit ( int $flags = ? , string $name = ? ) : bool
debug ( string $message ) : bool
dump_debug_info ( ) : bool
get_charset ( ) : object
get_client_info ( ) : string
get_connection_stats ( ) : bool
mysqli_stmt::get_server_info ( ) : string
get_warnings ( ) : mysqli_warning
init ( ) : mysqli
kill ( int $processid ) : bool
more_results ( ) : bool
multi_query ( string $query ) : bool
next_result ( ) : bool
options ( int $option , mixed $value ) : bool
ping ( ) : bool
public static poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = ? ) : int
prepare ( string $query ) : mysqli_stmt
query ( string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed
real_connect ( string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool
escape_string ( string $escapestr ) : string
real_query ( string $query ) : bool
public reap_async_query ( ) : mysqli_result
public refresh ( int $options ) : bool
rollback ( int $flags = ? , string $name = ? ) : bool
select_db ( string $dbname ) : bool
set_charset ( string $charset ) : bool
ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher ) : bool
stat ( ) : string
stmt_init ( ) : mysqli_stmt
store_result ( int $option = ? ) : mysqli_result
use_result ( ) : mysqli_result
}

Tabla de contenidos

  • mysqli::$affected_rows — Obtiene el número de filas afectadas en la última operación MySQL
  • mysqli::autocommit — Activa o desactiva las modificaciones de la base de datos autoconsignadas
  • mysqli::begin_transaction — Inicia una transacción
  • mysqli::change_user — Cambia el usuario de la conexión de bases de datos especificada
  • mysqli::character_set_name — Devuelve el juego de caracteres predeterminado para la conexión a la base de datos
  • mysqli::close — Cierra una conexión previamente abierta a una base de datos
  • mysqli::commit — Consigna la transacción actual
  • mysqli::$connect_errno — Devuelve el código de error de la última llamada
  • mysqli::$connect_error — Devuelve una cadena con la descripción del último error de conexión
  • mysqli::__construct — Abre una nueva conexión al servidor de MySQL
  • mysqli::debug — Realiza operaciones de depuración
  • mysqli::dump_debug_info — Volcado de información de depuración en el registro
  • mysqli::$errno — Devuelve el código del error de la última función llamada
  • mysqli::$error_list — Devuelve una lista de errores desde el último comando ejecutado
  • mysqli::$error — Devuelve una cadena que describe el último error
  • mysqli::$field_count — Devuelve el número de columnas para la consulta más reciente
  • mysqli::get_charset — Devuelve un objeto que contiene el conjunto de caracteres
  • mysqli::get_client_info — Obtiene información de la biblioteca cliente de MySQL
  • mysqli_get_client_version — Devuelve la versión clientes de MySQL como valor de tipo integer
  • mysqli::get_connection_stats — Devuelve estadísticas sobre la conexión del cliente
  • mysqli::$host_info — Devuelve una cadena que representa el tipo de conexión usada
  • mysqli::$protocol_version — Devuelve la versión del protocolo MySQL utilizada
  • mysqli::$server_info — Devuelve la versión del servidor MySQL
  • mysqli::$server_version — Devuelve la versión del servidor MySQL como un valor entero
  • mysqli::get_warnings — Obtiene el resultado de SHOW WARNINGS
  • mysqli::$info — Obtiene la información de la última consulta ejecutada
  • mysqli::init — Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
  • mysqli::$insert_id — Devuelve el id autogenerado que se utilizó en la última consulta
  • mysqli::kill — Pide al servidor poner fin a un hilo de MySQL
  • mysqli::more_results — Comprueba si hay más resultados de una multi consulta
  • mysqli::multi_query — Realiza una consulta a la base de datos
  • mysqli::next_result — Prepara el siguiente resultado de multi_query
  • mysqli::options — Establecer opciones
  • mysqli::ping — Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión
  • mysqli::poll — Almacena en caché conexiones
  • mysqli::prepare — Prepara una sentencia SQL para su ejecución
  • mysqli::query — Realiza una consulta a la base de datos
  • mysqli::real_connect — Abre una conexión a un servidor mysql
  • mysqli::real_escape_string — Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
  • mysqli::real_query — Ejecuta una consulta SQL
  • mysqli::reap_async_query — Obtener el resultado de una consulta asincrónica
  • mysqli::refresh — Refresca
  • mysqli::release_savepoint — Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual
  • mysqli::rollback — Revierte la transacción actual
  • mysqli::savepoint — Define el nombre de un punto de salvaguarda de la transacción
  • mysqli::select_db — Selecciona la base de datos por defecto para realizar las consultas
  • mysqli::set_charset — Establece el conjunto de caracteres predeterminado del cliente
  • mysqli::$sqlstate — Devuelve el error SQLSTATE de la operación de MySQL previa
  • mysqli::ssl_set — Usada para establece conexiones seguras usando SSL
  • mysqli::stat — Obtiene el estado actual del sistema
  • mysqli::stmt_init — Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare
  • mysqli::store_result — Transfiere un conjunto de resultados de la última consulta
  • mysqli::$thread_id — Deveulve el ID del hilo de la conexión actual
  • mysqli::thread_safe — Devuelve si la seguridad a nivel de hilos está dada o no
  • mysqli::use_result — Inicia la recuperación de un conjunto de resultados
  • mysqli::$warning_count — Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado


Obtiene el número de filas afectadas en la última operación MySQL

  • « mysqli
  • mysqli::autocommit »
  • PHP Manual
  • mysqli
  • Obtiene el número de filas afectadas en la última operación MySQL

mysqli::$affected_rows

mysqli_affected_rows

(PHP 5, PHP 7)

mysqli::$affected_rows -- mysqli_affected_rows — Obtiene el número de filas afectadas en la última operación MySQL

Descripción

Estilo orientado a objetos

int $mysqli->affected_rows;

Estilo por procedimientos

mysqli_affected_rows ( mysqli $link ) : int

Devuelve el numero de filas afectadas por la última consulta INSERT, UPDATE, REPLACE or DELETE.

Para instrucciones SELECT mysqli_affected_rows() es equivalente a mysqli_num_rows().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Un entero mayor que cero indica el número de filas afectadas o recuperadas. El cero indica que no hay registros en una actualización con una sentencia UPDATE, que no hay filas que cumplan la cláusula WHERE de la sentencia o que ninguna consulta ha sido ejecutada todavía. -1 indica que la consulta devolvió un error.

Nota:

Si el número de filas afectadas es mayor de el máximo valor entero ( PHP_INT_MAX ), dicho número será devuelto como una cadena (string).

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->affected_rows

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* Comprueba la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Inserta filas */
$mysqli->query("CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", $mysqli->affected_rows);

$mysqli->query("ALTER TABLE Language ADD Status int default 0");

/* Actualiza filas */
$mysqli->query("UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", $mysqli->affected_rows);

/* Elimina filas */
$mysqli->query("DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", $mysqli->affected_rows);

/* Selecciona todas las filas */
$result = $mysqli->query("SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", $mysqli->affected_rows);

$result->close();

/* Elimina la tabla "Language" */
$mysqli->query("DROP TABLE Language");

/* Cierra la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* Inserta filas */
mysqli_query($link, "CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", mysqli_affected_rows($link));

mysqli_query($link, "ALTER TABLE Language ADD Status int default 0");

/* Actualiza filas */
mysqli_query($link, "UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", mysqli_affected_rows($link));

/* Elimina filas */
mysqli_query($link, "DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", mysqli_affected_rows($link));

/* Selecciona todas las filas */
$result = mysqli_query($link, "SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", mysqli_affected_rows($link));

mysqli_free_result($result);

/* Elimina la tabla "Language" */
mysqli_query($link, "DROP TABLE Language");

/* Cierra la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Affected rows (INSERT): 984
Affected rows (UPDATE): 168
Affected rows (DELETE): 815
Affected rows (SELECT): 169

Ver también

  • mysqli_num_rows() - Obtiene el número de filas de un resultado
  • mysqli_info() - Obtiene la información de la última consulta ejecutada


Activa o desactiva las modificaciones de la base de datos autoconsignadas

  • « mysqli::$affected_rows
  • mysqli::begin_transaction »
  • PHP Manual
  • mysqli
  • Activa o desactiva las modificaciones de la base de datos autoconsignadas

mysqli::autocommit

mysqli_autocommit

(PHP 5, PHP 7)

mysqli::autocommit -- mysqli_autocommit — Activa o desactiva las modificaciones de la base de datos autoconsignadas

Descripción

Estilo orientado a objetos

mysqli::autocommit ( bool $mode ) : bool

Estilo por procedimientos

mysqli_autocommit ( mysqli $link , bool $mode ) : bool

Activa o desactiva el modo 'auto-commit' en consultas para la conexión a la base de datos.

Para determinar el estado actual de la autoconsigna se ha de utilzar el comando SQL SELECT @@autocommit.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

mode

Si activar o no el modo 'auto-commit'.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función no puede aplicarse a tipos de tablas no transaccionales (como MyISAM o ISAM).

Ejemplos

Ejemplo #1 Ejemplo de mysqli::autocommit()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

if (mysqli_connect_errno()) {
    printf("Fallo la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* activar la autoconsigna */
$mysqli->autocommit(TRUE);

if ($resultado = $mysqli->query("SELECT @@autocommit")) {
    $fila = $resultado->fetch_row();
    printf("El estado de la autoconsigna es %s\n", $fila[0]);
    $resultado->free();
}

/* Cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

if (!$enlace) {
    printf("Imposible conectar a localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* activar la autoconsigna */
mysqli_autocommit($enlace, TRUE);

if ($resultado = mysqli_query($enlace, "SELECT @@autocommit")) {
    $fila = mysqli_fetch_row($resultado);
    printf("El estado de la autoconsigna es %s\n", $fila[0]);
    mysqli_free_result($resultado);
}

/* close connection */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

El estado de la autoconsigna es 1

Ver también

  • mysqli_begin_transaction() - Inicia una transacción
  • mysqli_commit() - Consigna la transacción actual
  • mysqli_rollback() - Revierte la transacción actual


Inicia una transacción

  • « mysqli::autocommit
  • mysqli::change_user »
  • PHP Manual
  • mysqli
  • Inicia una transacción

mysqli::begin_transaction

mysqli_begin_transaction

(PHP 5 >= 5.5.0, PHP 7)

mysqli::begin_transaction -- mysqli_begin_transaction — Inicia una transacción

Descripción

Estilo orientado a objetos (método):

public mysqli::begin_transaction ( int $flags = ? , string $name = ? ) : bool

Estilo por procedimientos:

mysqli_begin_transaction ( mysqli $link , int $flags = ? , string $name = ? ) : bool

Comienza una transacción. Requiere MySQL 5.6 y superior, y el motor InnoDB (está habilitado por defecto). Para detalles adicionales sobre cómo funcionan las transacciones de MySQL, véase » http://dev.mysql.com/doc/mysql/en/commit.html.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

flags

Banderas. Las válidas son:

  • MYSQLI_TRANS_START_READ_ONLY: Inicia la transacción como "START TRANSACTION READ ONLY".

  • MYSQLI_TRANS_START_READ_WRITE: Inicia la transacción como "START TRANSACTION READ WRITE".

  • MYSQLI_TRANS_START_WITH_CONSISTENT_SNAPSHOT: Inicia la transacción como "START TRANSACTION WITH CONSISTENT SNAPSHOT".

name

Nombre del punto de prevención de la transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->begin_transaction()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("127.0.0.1", "mi_usuario", "mi_contraseña", "sakila");

if ($mysqli->connect_errno) {
    printf("Conexión fallida: %s\n", $mysqli->connect_error);
    exit();
}

$mysqli->begin_transaction(MYSQLI_TRANS_START_READ_ONLY);

$mysqli->query("SELECT first_name, last_name FROM actor");
$mysqli->commit();

$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("127.0.0.1", "mi_usuario", "mi_contraseña", "sakila");

if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

mysqli_begin_transaction($enlace, MYSQLI_TRANS_START_READ_ONLY);

mysqli_query($enlace, "SELECT first_name, last_name FROM actor LIMIT 1");
mysqli_commit($enlace);

mysqli_close($enlace);
?>

Ver también

  • mysqli_autocommit() - Activa o desactiva las modificaciones de la base de datos autoconsignadas
  • mysqli_commit() - Consigna la transacción actual
  • mysqli_rollback() - Revierte la transacción actual


Cambia el usuario de la conexión de bases de datos especificada

  • « mysqli::begin_transaction
  • mysqli::character_set_name »
  • PHP Manual
  • mysqli
  • Cambia el usuario de la conexión de bases de datos especificada

mysqli::change_user

mysqli_change_user

(PHP 5, PHP 7)

mysqli::change_user -- mysqli_change_user — Cambia el usuario de la conexión de bases de datos especificada

Descripción

Estilo orientado a objetos

mysqli::change_user ( string $user , string $password , string $database ) : bool

Estilo por procedimientos

mysqli_change_user ( mysqli $link , string $user , string $password , string $database ) : bool

Cambia el usuario de la conexión de base de datos especificada y establece la base de datos actual.

Para realizar con éxito el cambio de usuarios, un username y password válidos deben ser indicados y ese usuario debe tener suficientes permisos para acceder a la base de datos deseada. Si por cualquier razón la autorización falla, se mantendrá la autenticación de usuario existente.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

user

Nombre de usuario de MySQL.

password

Contraseña de MySQL.

database

La base de datos a la que quiero cambiar.

Si se desea, se puede parar el valor null de modo que solo cambiará el usuario y no se seleccionará una base de datos. Para seleccionar una base de datos en este caso, utilice la función mysqli_select_db().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

El uso de este comando siempre causará que la conexión a la base de datos actual se comporte como una conexión completamente nueva, independientemente de si la operación se ha completado con éxito. Este reinicio incluye la realización de un "rollback" a cualquier transacción activa, cerrando todas las tablas temporales, y desbloqueando todas las tablas bloqueadas.

Ejemplos

Ejemplo #1 Ejemplo del método mysqli::change_user()

Estilo orientado a objetos

<?php

/* connect database test */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
$mysqli->query("SET @a:=1");

/* reiniciando todo, y realizando una nueva conexión a base de datos */
$mysqli->change_user("my_user", "my_password", "world");

if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Base de datos predeterminada: %s\n", $row[0]);
    $result->close();
}

if ($result = $mysqli->query("SELECT @a")) {
    $row = $result->fetch_row();
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
/* connect database test */
$link = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "test");

/* check connection */
if (!$link) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
mysqli_query($link, "SET @a:=1");

/* reinciando todo y realizando una nueva conexión a base de datos. */
mysqli_change_user($link, "my_user", "my_password", "world");

if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database: %s\n", $row[0]);
    mysqli_free_result($result);
}

if ($result = mysqli_query($link, "SELECT @a")) {
    $row = mysqli_fetch_row($result);
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    mysqli_free_result($result);
}

/* Cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Default database: world
Value of variable a is NULL

Ver también

  • mysqli_connect() - Alias de mysqli::__construct
  • mysqli_select_db() - Selecciona la base de datos por defecto para realizar las consultas


Devuelve el juego de caracteres predeterminado para la conexión a la base de datos

  • « mysqli::change_user
  • mysqli::close »
  • PHP Manual
  • mysqli
  • Devuelve el juego de caracteres predeterminado para la conexión a la base de datos

mysqli::character_set_name

mysqli_character_set_name

(PHP 5, PHP 7)

mysqli::character_set_name -- mysqli_character_set_name — Devuelve el juego de caracteres predeterminado para la conexión a la base de datos

Descripción

Estilo orientado a objetos

mysqli::character_set_name ( ) : string

Estilo por procedimientos

mysqli_character_set_name ( mysqli $link ) : string

Devuelve el juego de caracteres actual para la conexión a la base de datos.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

El juego de caracteres predeterminado para la conexión actual

Ejemplos

Ejemplo #1 Ejemplo de mysqli::character_set_name()

Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("La conexión falló: %s\n", mysqli_connect_error());
    exit();
}

/* Imprimir el juego de caracteres en uso */
$charset = $mysqli->character_set_name();
printf ("El juego de caracteres en uso es %s\n", $charset);

$mysqli->close();
?>

Estilo por procedimientos

<?php
/* Abrir una conexión */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* comprobar la conexión */
if (!$link) {
    printf("La conexión falló: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = mysqli_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

El juego de caracteres en uso es latin1_swedish_ci

Ver también

  • mysqli_set_charset() - Establece el conjunto de caracteres predeterminado del cliente
  • mysqli_client_encoding()
  • mysqli_real_escape_string() - Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión


Cierra una conexión previamente abierta a una base de datos

  • « mysqli::character_set_name
  • mysqli::commit »
  • PHP Manual
  • mysqli
  • Cierra una conexión previamente abierta a una base de datos

mysqli::close

mysqli_close

(PHP 5, PHP 7)

mysqli::close -- mysqli_close — Cierra una conexión previamente abierta a una base de datos

Descripción

Estilo orientado a objetos

mysqli::close ( ) : bool

Estilo por procedimientos

mysqli_close ( mysqli $link ) : bool

Cierra una conexión abierta previamente a base de datos.

Las conexiones de MySQL no persistentes y los conjuntos de resultados son automáticamente destruidos cuando un script de PHP finaliza su ejecución. Por tanto, aunque el cierre explícito de conexiones abiertas y la liberación de conjuntos de resultados sean opcionales, se recomienda hacerlos. Así, se devolverán inmediatamente los recursos a PHP y a MySQL, lo que puede mejorar el rendimiento. Para información detalla, véase la liberación de recursos

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Veasé mysqli_connect().

Notas

Nota:

mysqli_close() no cerrará las conexiones persistentes. Para más detalles, véase la página del manual sobre conexiones persistentes.

Ver también

  • mysqli::__construct() - Abre una nueva conexión al servidor de MySQL
  • mysqli_init() - Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
  • mysqli_real_connect() - Abre una conexión a un servidor mysql
  • mysqli_free_result() - Libera la memoria asociada a un resultado


Consigna la transacción actual

  • « mysqli::close
  • mysqli::$connect_errno »
  • PHP Manual
  • mysqli
  • Consigna la transacción actual

mysqli::commit

mysqli_commit

(PHP 5, PHP 7)

mysqli::commit -- mysqli_commit — Consigna la transacción actual

Descripción

Estilo orientado a objetos

mysqli::commit ( int $flags = ? , string $name = ? ) : bool

Estilo por procedimientos

mysqli_commit ( mysqli $link , int $flags = ? , string $name = ? ) : bool

Consigna la transacción actual para la conexión a la base de datos.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

flags

Una máscara de bits de constantes MYSQLI_TRANS_COR_*.

name

Si se proporciona, se ejecuta COMMIT/*name*/.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Se añadieron los parámetros flags y name.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::commit()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* Comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE Language LIKE CountryLanguage");

/* Desactivar la autoconsigna */
$mysqli->autocommit(FALSE);

/* Inserta algunos valores */
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* Consignar la transacción */
if (!$mysqli->commit()) {
    print("Falló la consignación de la transacción\n");
    exit();
}

/* Eliminar la tabla */
$mysqli->query("DROP TABLE Language");

/* Cerrar la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "my_user", "my_password", "test");

/* Comprobar la conexión */
if (!$enlace) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* Desactivar la autoconsignación */
mysqli_autocommit($enlace, FALSE);

mysqli_query($enlace, "CREATE TABLE Language LIKE CountryLanguage");

/* Insertar algunos valores */
mysqli_query($enlace, "INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
mysqli_query($enlace, "INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* Consignar la transación */
if (!mysqli_commit($enlace)) {
    print("Falló la consignación de la transacción\n");
    exit();
}

/* Cerrar la conexión */
mysqli_close($enlace);
?>

Ver también

  • mysqli_autocommit() - Activa o desactiva las modificaciones de la base de datos autoconsignadas
  • mysqli_begin_transaction() - Inicia una transacción
  • mysqli_rollback() - Revierte la transacción actual
  • mysqli_savepoint() - Define el nombre de un punto de salvaguarda de la transacción


Devuelve el código de error de la última llamada

  • « mysqli::commit
  • mysqli::$connect_error »
  • PHP Manual
  • mysqli
  • Devuelve el código de error de la última llamada

mysqli::$connect_errno

mysqli_connect_errno

(PHP 5, PHP 7)

mysqli::$connect_errno -- mysqli_connect_errno — Devuelve el código de error de la última llamada

Descripción

Estilo orientado a objetos

int $mysqli->connect_errno;

Estilo por procedimientos

mysqli_connect_errno ( ) : int

Devuelve el ultimo código de error de la última llamada mysqli_connect().

Nota:

Los números de los mensajes de error están listados en el fichero de cabeceras de MySQL errmsg.h, los números de los mensajes de error del servidor están listados en mysqld_error.h. En la distribución de código fuente puede encontrar una lista completa de los mensajes de error y sus números en el fichero Docs/mysqld_error.txt.

Valores devueltos

Un código de error para la ultima llamada a mysqli_connect(), si ha fallado. cero significa que no ha ocurrido ningún error.

Ejemplos

Ejemplo #1 $mysqli->connect_errno example

Estilo orientado a objetos

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

if ($mysqli->connect_errno) {
    die('Connect Error: ' . $mysqli->connect_errno);
}
?>

Estilo por procedimientos

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error: ' . mysqli_connect_errno());
}
?>

El resultado de los ejemplos sería:

Connect Error: 1045

Ver también

  • mysqli_connect() - Alias de mysqli::__construct
  • mysqli_connect_error() - Devuelve una cadena con la descripción del último error de conexión
  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


Devuelve una cadena con la descripción del último error de conexión

  • « mysqli::$connect_errno
  • mysqli::__construct »
  • PHP Manual
  • mysqli
  • Devuelve una cadena con la descripción del último error de conexión

mysqli::$connect_error

mysqli_connect_error

(PHP 5, PHP 7)

mysqli::$connect_error -- mysqli_connect_error — Devuelve una cadena con la descripción del último error de conexión

Descripción

Estilo orientado a objetos

string $mysqli->connect_error;

Estilo por procedimientos

mysqli_connect_error ( ) : string

Devuelve el último mensaje de error de la ultima llamada mysqli_connect().

Valores devueltos

Una cadena que describe el error. Devuelve null si no ha ocurrido ningún error.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->connect_error

Estilo orientado a objetos

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

// Works as of PHP 5.2.9 and 5.3.0.
if ($mysqli->connect_error) {
    die('Error de conexión: ' . $mysqli->connect_error);
}
?>

Estilo por procedimientos

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Error de conexión: ' . mysqli_connect_error());
}
?>

El resultado de los ejemplos sería:

Connect Error: Access denied for user 'fake_user'@'localhost' (using password: YES)

Notas

Advertencia

La propiedad mysqli->connect_error solo funciona correctamente en las versiones 5.2.9 y 5.3.0 de PHP. Usa la funciónmysqli_connect_error() si es necesaria la compatibilidad con versiones anteriores de PHP.

Ver también

  • mysqli_connect() - Alias de mysqli::__construct
  • mysqli_connect_errno() - Devuelve el código de error de la última llamada
  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


Abre una nueva conexión al servidor de MySQL

  • « mysqli::$connect_error
  • mysqli::debug »
  • PHP Manual
  • mysqli
  • Abre una nueva conexión al servidor de MySQL

mysqli::__construct

mysqli_connect

(PHP 5, PHP 7)

mysqli::__construct -- mysqli_connect — Abre una nueva conexión al servidor de MySQL

Descripción

Estilo orientado a objetos

mysqli::__construct
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
)

Estilo por procedimientos

mysqli_connect
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
) : mysqli

Abre una conexión al Servidor de MySQL que está en ejecución.

Parámetros

host

Puede ser o un nombre de host o una dirección IP. Pasando el valor null o la cadena "localhost" a este parámetro, se asumirá el host local. Cuando es posible, se usarán tuberías en lugar del protocolo TCP/IP.

Anteponer p: al host, abre una conexión persistente. mysqli_change_user() es automáticamente llamado en conexiones abiertas desde la caché de conexiones.

username

El nombre de usuario de MySQL.

passwd

Si no se proporciona o es null, el servidor MySQL intentará autentificar el usuario solo con aquellos registros de usuarios que no tienen contraseña. Esto permite que un nombre de usuario ser usado con diferentes permisos (dependiendo de si se proporciona una contraseña o no).

dbname

Si se proporcioina, especificará la base de datos prederminada a usar cuando se realizan consultas.

port

Especifica el número al que intentar conectar al servidor de MySQL.

socket

Especifica el socket o la tubería con nombre que debería usarse.

Nota:

Especificar el parámetro socket no determinará explicitamente el tipo de conexión a utilizar cuando se conecte al servidor MySQL. El modo de realizar la conexión a la base de datos MySQL es determinado por el parámetro host.

Valores devueltos

Devuelve un objeto que representa la conexión al servidor MySQL.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió la capacidad de conexiones persistentes.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::__construct()

Estilo orientado a objetos

<?php
$mysqli = new mysqli('localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd');

/*
 * Esta es la forma OO "oficial" de hacerlo,
 * AUNQUE $connect_error estaba averiado hasta PHP 5.2.9 y 5.3.0.
 */
if ($mysqli->connect_error) {
    die('Error de Conexión (' . $mysqli->connect_errno . ') '
            . $mysqli->connect_error);
}

/*
 * Use esto en lugar de $connect_error si necesita asegurarse
 * de la compatibilidad con versiones de PHP anteriores a 5.2.9 y 5.3.0.
 */
if (mysqli_connect_error()) {
    die('Error de Conexión (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Éxito... ' . $mysqli->host_info . "\n";

$mysqli->close();
?>

Estilo orientado a objetos cuando se extiende la clase mysqli

<?php

class foo_mysqli extends mysqli {
    public function __construct($host, $usuario, $contraseña, $bd) {
        parent::__construct($host, $usuario, $contraseña, $bd);

        if (mysqli_connect_error()) {
            die('Error de Conexión (' . mysqli_connect_errno() . ') '
                    . mysqli_connect_error());
        }
    }
}

$bd = new foo_mysqli('localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd');

echo 'Éxito... ' . $bd->host_info . "\n";

$bd->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect('localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd');

if (!$enlace) {
    die('Error de Conexión (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Éxito... ' . mysqli_get_host_info($enlace) . "\n";

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Éxito... MySQL host info: localhost via TCP/IP

Notas

Nota:

MySQLnd siempre utiliza el juego de caracteres de idioma predeterminado. El juego de caracteres se envía en la autentificación/acuerdo que se produce durante la conexión, que utilizará mysqlnd.

Libmysqlclient utiliza el juego de caracteres predeterminado definido en my.cnf o se puede establecer llamando mysqli_options() antes de user mysqli_real_connect(), pero después de mysqli_init().

Nota:

Sólo para la sintaxis OO: Si una conexión falla se devuelve un objeto. Para comprobar si la conexión falló, use la función mysqli_connect_error() o la propiedad mysqli->connect_error como en los ejemplos anteriores.

Nota:

Si es necesario establecer las opciones, tales como el tiempo de espera de conexión, se debe utilizar mysqli_real_connect() en su lugar.

Nota:

Llamar al constructor sin parámetros es lo mismo que llamar a la función mysqli_init().

Nota:

El error "Can't create TCP/IP socket (10106)" normalmente significa que la directiva de configuración variables_order no contiene el carácter E. En Windows, si el entorno no es copiado, la variable de entorno SYSTEMROOT no estará disponible y PHP tendrá problemas al cargar Winsock.

Ver también

  • mysqli_real_connect() - Abre una conexión a un servidor mysql
  • mysqli_options() - Establecer opciones
  • mysqli_connect_errno() - Devuelve el código de error de la última llamada
  • mysqli_connect_error() - Devuelve una cadena con la descripción del último error de conexión
  • mysqli_close() - Cierra una conexión previamente abierta a una base de datos


Realiza operaciones de depuración

  • « mysqli::__construct
  • mysqli::dump_debug_info »
  • PHP Manual
  • mysqli
  • Realiza operaciones de depuración

mysqli::debug

mysqli_debug

(PHP 5, PHP 7)

mysqli::debug -- mysqli_debug — Realiza operaciones de depuración

Descripción

Estilo orientado a objetos

mysqli::debug ( string $message ) : bool

Estilo por procedimientos

mysqli_debug ( string $message ) : bool

Realiza operaciones de depuración usando la librería Fred Fish.

Parámetros

message

Una cadena que representa la operación de depuración a realizar

Valores devueltos

Devuelve true.

Notas

Nota:

Para usar la función mysqli_debug() debes compilar la librería del cliente MySQL para que soporte depuración.

Ejemplos

Ejemplo #1 Generando un fichero de prueba (traza)

<?php

/* Create a trace file in '/tmp/client.trace' on the local (client) machine: */
mysqli_debug("d:t:o,/tmp/client.trace");

?>

Ver también

  • mysqli_dump_debug_info() - Volcado de información de depuración en el registro
  • mysqli_report() - Alias de mysqli_driver->report_mode


Volcado de información de depuración en el registro

  • « mysqli::debug
  • mysqli::$errno »
  • PHP Manual
  • mysqli
  • Volcado de información de depuración en el registro

mysqli::dump_debug_info

mysqli_dump_debug_info

(PHP 5, PHP 7)

mysqli::dump_debug_info -- mysqli_dump_debug_info — Volcado de información de depuración en el registro

Descripción

Estilo orientado a objetos

mysqli::dump_debug_info ( ) : bool

Estilo por procedimientos

mysqli_dump_debug_info ( mysqli $link ) : bool

Esta función está diseñada para ser ejecutada por un usuario con el privilegio SUPER y se utiliza para volcar la información de depuración en el registro para el servidor MySQL relacionado con la conexión.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_debug() - Realiza operaciones de depuración


Devuelve el código del error de la última función llamada

  • « mysqli::dump_debug_info
  • mysqli::$error_list »
  • PHP Manual
  • mysqli
  • Devuelve el código del error de la última función llamada

mysqli::$errno

mysqli_errno

(PHP 5, PHP 7)

mysqli::$errno -- mysqli_errno — Devuelve el código del error de la última función llamada

Descripción

Estilo orientado a objetos

int $mysqli->errno;

Estilo por procedimientos

mysqli_errno ( mysqli $link ) : int

Devuelve el último código de error de la llamada más reciente a una función MySQLi que podrá haberse ejecutado con éxito o haber fallado.

Los números de los errores de cliente, están indicados en el fichero de cabecera errmsg.h, los números de mensajes de error del servidor están indicados en mysqld_error.h. En la documentación de MySQL puedes encontrar una lista de mensajes de error y su numeración en el fichero Docs/mysqld_error.txt.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Un código de error de la última llamada, si ésta ha fallado. Si devuelve cero significa que no ha ocurrido ningún error.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->errno

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* comprobar la conexión */
if ($mysqli->connect_errno) {
    printf("Falló la conexión: %s\n", $mysqli->connect_error);
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Código de error: %d\n", $mysqli->errno);
}

/* cerrar la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errorcode: %d\n", mysqli_errno($link));
}

/* close connection */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Errorcode: 1193

Ver también

  • mysqli_connect_errno() - Devuelve el código de error de la última llamada
  • mysqli_connect_error() - Devuelve una cadena con la descripción del último error de conexión
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


Devuelve una lista de errores desde el último comando ejecutado

  • « mysqli::$errno
  • mysqli::$error »
  • PHP Manual
  • mysqli
  • Devuelve una lista de errores desde el último comando ejecutado

mysqli::$error_list

mysqli_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli::$error_list -- mysqli_error_list — Devuelve una lista de errores desde el último comando ejecutado

Descripción

Estilo orientado a objetos

array $mysqli->error_list;

Estilo por procedimientos

mysqli_error_list ( mysqli $link ) : array

Devuelve una array de errores de la llamada a la función de MySQLi más reciente que puede tener éxito o no.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una lista de errores, cada uno como un array asociativo que contiene el errno, el error, y el sqlstate.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->error_list

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "nadie", "");

/* verficar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    print_r($mysqli->error_list);
}

/* cerrar la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* verficar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($enlace, "SET a=1")) {
    print_r(mysqli_error_list($enlace));
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Array
(
    [0] => Array
        (
            [errno] => 1193
            [sqlstate] => HY000
            [error] => Unknown system variable 'a'
        )

)

Ver también

  • mysqli_connect_errno() - Devuelve el código de error de la última llamada
  • mysqli_connect_error() - Devuelve una cadena con la descripción del último error de conexión
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


Devuelve una cadena que describe el último error

  • « mysqli::$error_list
  • mysqli::$field_count »
  • PHP Manual
  • mysqli
  • Devuelve una cadena que describe el último error

mysqli::$error

mysqli_error

(PHP 5, PHP 7)

mysqli::$error -- mysqli_error — Devuelve una cadena que describe el último error

Descripción

Estilo orientado a objetos

string $mysqli->error;

Estilo por procedimientos

mysqli_error ( mysqli $link ) : string

Devuelve el últmo mensaje de error para la llamada más reciente a una función de MySQLi que puede haberse ejecutado correctamente o haber fallado.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una cadena que describe el error. Una cadena vacía si no ha ocurrido error alguno.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->error

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* Comprueba la conexión */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errormessage: %s\n", $mysqli->error);
}

/* Cierra la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* Comprueba la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errormessage: %s\n", mysqli_error($link));
}

/* Cierra la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Errormessage: Unknown system variable 'a'

Ver también

  • mysqli_connect_errno() - Devuelve el código de error de la última llamada
  • mysqli_connect_error() - Devuelve una cadena con la descripción del último error de conexión
  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


Devuelve el número de columnas para la consulta más reciente

  • « mysqli::$error
  • mysqli::get_charset »
  • PHP Manual
  • mysqli
  • Devuelve el número de columnas para la consulta más reciente

mysqli::$field_count

mysqli_field_count

(PHP 5, PHP 7)

mysqli::$field_count -- mysqli_field_count — Devuelve el número de columnas para la consulta más reciente

Descripción

Estilo orientado a objetos

int $mysqli->field_count;

Estilo por procedimientos

mysqli_field_count ( mysqli $link ) : int

Devuelve el numero de columnas para la consulta más reciente en la conexión representada por el parámetro link. Esta función puede ser útil cuando se utiliza la función mysqli_store_result() para determinar si la consulta ha producido un resultado no vacío o no, sin saber la naturaleza de la consulta.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Un entero que representa el número de campos en un set de resultado. An integer representing the number of fields in a result set.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->field_count

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query( "DROP TABLE IF EXISTS friends");
$mysqli->query( "CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query( "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$mysqli->real_query("SELECT * FROM friends");

if ($mysqli->field_count) {
    /* this was a select/show or describe query */
    $result = $mysqli->store_result();

    /* process resultset */
    $row = $result->fetch_row();

    /* free resultset */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

mysqli_real_query($link, "SELECT * FROM friends");

if (mysqli_field_count($link)) {
    /* this was a select/show or describe query */
    $result = mysqli_store_result($link);

    /* process resultset */
    $row = mysqli_fetch_row($result);

    /* free resultset */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>


Devuelve un objeto que contiene el conjunto de caracteres

  • « mysqli::$field_count
  • mysqli::get_client_info »
  • PHP Manual
  • mysqli
  • Devuelve un objeto que contiene el conjunto de caracteres

mysqli::get_charset

mysqli_get_charset

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_charset -- mysqli_get_charset — Devuelve un objeto que contiene el conjunto de caracteres

Descripción

Estilo orientado a objetos

mysqli::get_charset ( ) : object

Estilo por procedimientos

mysqli_get_charset ( mysqli $link ) : object

Devuelve un conjunto de caracteres objeto que proporciona varias propiedades del conjunto de caracteres activo actual.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

La función devuelve un conjunto de caracteres objeto con las siguientes propiedades:

charset

Nombre del conjunto de caracteres

collation

Nombre de la colación

dir

Directory the charset description was fetched from (?) or "" for built-in character sets

min_length

Tamaño mínimo de carácter en bytes

max_length

Tamaño máximo de carácter en bytes

number

Número interno del conjunto de caracteres

state

Estado del conjunto de caracteres (?)

Ejemplos

Ejemplo #1 mysqli::get_charset() example

Estilo orientado a objetos

<?php
  $db = mysqli_init();
  $db->real_connect("localhost","root","","test");
  var_dump($db->get_charset());
?>

Estilo por procedimientos

<?php
  $db = mysqli_init();
  mysqli_real_connect($db, "localhost","root","","test");
  var_dump(mysqli_get_charset($db));
?>

El resultado de los ejemplos sería:

object(stdClass)#2 (7) {
  ["charset"]=>
  string(6) "latin1"
  ["collation"]=>
  string(17) "latin1_swedish_ci"
  ["dir"]=>
  string(0) ""
  ["min_length"]=>
  int(1)
  ["max_length"]=>
  int(1)
  ["number"]=>
  int(8)
  ["state"]=>
  int(801)
}

Ver también

  • mysqli_character_set_name() - Devuelve el juego de caracteres predeterminado para la conexión a la base de datos
  • mysqli_set_charset() - Establece el conjunto de caracteres predeterminado del cliente


Obtiene información de la biblioteca cliente de MySQL

  • « mysqli::get_charset
  • mysqli_get_client_version »
  • PHP Manual
  • mysqli
  • Obtiene información de la biblioteca cliente de MySQL

mysqli::get_client_info

mysqli_get_client_info

(PHP 5, PHP 7)

mysqli::get_client_info -- mysqli_get_client_info — Obtiene información de la biblioteca cliente de MySQL

Descripción

Estilo orientado a objetos

mysqli::get_client_info ( ) : string

Estilo por procedimientos

mysqli_get_client_info ( mysqli $link ) : string

Devuelve una cadena que representa la versión de la biblioteca cliente MySQL.

Valores devueltos

Una cadena que representa la versión de la biblioteca cliente de MySQL

Ejemplos

Ejemplo #1 mysqli_get_client_info

<?php

/* No es necesaria una conexión para determinar
   la versión de la biblioteca cliente MySQL */

printf("Versión de la biblioteca cliente: %s\n", mysqli_get_client_info());
?>

Ver también

  • mysqli_get_client_version() - Devuelve la versión clientes de MySQL como valor de tipo integer
  • mysqli_get_server_info() - Devuelve la versión del servidor MySQL
  • mysqli_get_server_version() - Devuelve la versión del servidor MySQL como un valor entero


Devuelve la versión clientes de MySQL como valor de tipo integer

  • « mysqli::get_client_info
  • mysqli::get_connection_stats »
  • PHP Manual
  • mysqli
  • Devuelve la versión clientes de MySQL como valor de tipo integer

mysqli_get_client_version

mysqli::$client_version

(PHP 5, PHP 7)

mysqli_get_client_version -- mysqli::$client_version — Devuelve la versión clientes de MySQL como valor de tipo integer

Descripción

Estilo orientado a objetos

int $mysqli->client_version;

Estilo por procedimientos

mysqli_get_client_version ( mysqli $link ) : int

Devolver la versión de cliente como un valor entero.

Valores devueltos

Un número que representa la versión de la librería del cliente MySQL en formato: main_version*10000 + minor_version *100 + sub_version. Por ejemplo, 4.1.0 será devuelto como 40100.

Esto es útil para determinar rápidamente la versión de la librería del cliente para saber si alguna funcionalidad existe.

Ejemplos

Ejemplo #1 mysqli_get_client_version

<?php

/* No se necesita una conexión para determinar
   la versión de la librería del cliente */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

Ver también

  • mysqli_get_client_info() - Obtiene información de la biblioteca cliente de MySQL
  • mysqli_get_server_info() - Devuelve la versión del servidor MySQL
  • mysqli_get_server_version() - Devuelve la versión del servidor MySQL como un valor entero


Devuelve estadísticas sobre la conexión del cliente

  • « mysqli_get_client_version
  • mysqli::$host_info »
  • PHP Manual
  • mysqli
  • Devuelve estadísticas sobre la conexión del cliente

mysqli::get_connection_stats

mysqli_get_connection_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli::get_connection_stats -- mysqli_get_connection_stats — Devuelve estadísticas sobre la conexión del cliente

Descripción

Estilo orientado a objetos

mysqli::get_connection_stats ( ) : bool

Estilo por procedimientos

mysqli_get_connection_stats ( mysqli $link ) : array

Devuelve estadísticas sobre la conexión del cliente. Disponible sólo con mysqlnd.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve un array con las estadísticas de la conexión si tiene éxito, en otro caso false.

Ejemplos

Ejemplo #1 Un ejemplo de mysqli_get_connection_stats()

<?php
$link = mysqli_connect();
print_r(mysqli_get_connection_stats($link));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

Ver también

  • Stats description


Devuelve una cadena que representa el tipo de conexión usada

  • « mysqli::get_connection_stats
  • mysqli::$protocol_version »
  • PHP Manual
  • mysqli
  • Devuelve una cadena que representa el tipo de conexión usada

mysqli::$host_info

mysqli_get_host_info

(PHP 5, PHP 7)

mysqli::$host_info -- mysqli_get_host_info — Devuelve una cadena que representa el tipo de conexión usada

Descripción

Estilo orientado a objetos

string $mysqli->host_info;

Estilo por procedimientos

mysqli_get_host_info ( mysqli $link ) : string

Devuelve una cadena que describiendo la conexión representada por el parámetro link (incluyendo el nombre del servidor anfitrión).

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una cadena de caracteres que representa el nombre del servidor anfitrión y el tipo de conexión.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->host_info

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar información del host */
printf("Host info: %s\n", $mysqli->host_info);

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar información del host */
printf("Host info: %s\n", mysqli_get_host_info($link));

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Host info: Localhost via UNIX socket

Ver también

  • mysqli_get_proto_info() - Devuelve la versión del protocolo MySQL utilizada


Devuelve la versión del protocolo MySQL utilizada

  • « mysqli::$host_info
  • mysqli::$server_info »
  • PHP Manual
  • mysqli
  • Devuelve la versión del protocolo MySQL utilizada

mysqli::$protocol_version

mysqli_get_proto_info

(PHP 5, PHP 7)

mysqli::$protocol_version -- mysqli_get_proto_info — Devuelve la versión del protocolo MySQL utilizada

Descripción

Estilo orientado a objetos

string $mysqli->protocol_version;

Estilo por procedimientos

mysqli_get_proto_info ( mysqli $link ) : int

Devuelve un valor entero que que representa la versión del protocolo de MySQL utilizada por la conexión representada por el parámetrolink.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve un valor entero que representa la versión del protocolo

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->protocol_version

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del protocolo */
printf("Protocol version: %d\n", $mysqli->protocol_version);

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del protocolo */
printf("Protocol version: %d\n", mysqli_get_proto_info($link));

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Protocol version: 10

Ver también

  • mysqli_get_host_info() - Devuelve una cadena que representa el tipo de conexión usada


Devuelve la versión del servidor MySQL

  • « mysqli::$protocol_version
  • mysqli::$server_version »
  • PHP Manual
  • mysqli
  • Devuelve la versión del servidor MySQL

mysqli::$server_info

mysqli::get_server_info

mysqli_get_server_info

(PHP 5, PHP 7)

mysqli::$server_info -- mysqli::get_server_info -- mysqli_get_server_info — Devuelve la versión del servidor MySQL

Descripción

Estilo orientado a objetos

string $mysqli->server_info;
mysqli_stmt::get_server_info ( ) : string

Estilo por procedimientos

mysqli_get_server_info ( mysqli $link ) : string

Devuelve una cadena que representa la versión del servidor MySQL al que está conectada la extensión MySQLi.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una cadena de caracteres que representa la versión del servidor.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->server_info

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del servidor */
printf("Server version: %s\n", $mysqli->server_info);

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del servidor */
printf("Server version: %s\n", mysqli_get_server_info($link));

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Server version: 4.1.2-alpha-debug

Ver también

  • mysqli_get_client_info() - Obtiene información de la biblioteca cliente de MySQL
  • mysqli_get_client_version() - Devuelve la versión clientes de MySQL como valor de tipo integer
  • mysqli_get_server_version() - Devuelve la versión del servidor MySQL como un valor entero


Devuelve la versión del servidor MySQL como un valor entero

  • « mysqli::$server_info
  • mysqli::get_warnings »
  • PHP Manual
  • mysqli
  • Devuelve la versión del servidor MySQL como un valor entero

mysqli::$server_version

mysqli_get_server_version

(PHP 5, PHP 7)

mysqli::$server_version -- mysqli_get_server_version — Devuelve la versión del servidor MySQL como un valor entero

Descripción

Estilo orientado a objetos

int $mysqli->server_version;

Estilo por procedimientos

mysqli_get_server_version ( mysqli $link ) : int

La función mysqli_get_server_version() devuelve la versión del servidor al que está conectado (representado por el parámetro link ) como un valor entero.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Un entero que representa la versión del servidor.

El patrón de este número de versión es main_version * 10000 + minor_version * 100 + sub_version (p.ej. versión 4.1.0 es 40100).

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->server_version

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del servidor */
printf("Server version: %d\n", $mysqli->server_version);

/* verificar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* mostrar versión del servidor */
printf("Server version: %d\n", mysqli_get_server_version($link));

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Server version: 40102

Ver también

  • mysqli_get_client_info() - Obtiene información de la biblioteca cliente de MySQL
  • mysqli_get_client_version() - Devuelve la versión clientes de MySQL como valor de tipo integer
  • mysqli_get_server_info() - Devuelve la versión del servidor MySQL


Obtiene el resultado de SHOW WARNINGS

  • « mysqli::$server_version
  • mysqli::$info »
  • PHP Manual
  • mysqli
  • Obtiene el resultado de SHOW WARNINGS

mysqli::get_warnings

mysqli_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_warnings -- mysqli_get_warnings — Obtiene el resultado de SHOW WARNINGS

Descripción

Estilo orientado a objetos

mysqli::get_warnings ( ) : mysqli_warning

Estilo por procedimientos

mysqli_get_warnings ( mysqli $link ) : mysqli_warning
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Obtiene la información de la última consulta ejecutada

  • « mysqli::get_warnings
  • mysqli::init »
  • PHP Manual
  • mysqli
  • Obtiene la información de la última consulta ejecutada

mysqli::$info

mysqli_info

(PHP 5, PHP 7)

mysqli::$info -- mysqli_info — Obtiene la información de la última consulta ejecutada

Descripción

Estilo orientado a objetos

string $mysqli->info;

Estilo por procedimientos

mysqli_info ( mysqli $link ) : string

La función mysqli_info() devuelve una cadena facilitando información sobre la última consulta ejecutada. La naturaleza de esta cadena está indicada abajo:

Posibles valores de retorno de mysqli_info
Tipo de consulta | Ejemplo de cadena devuelta
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Nota:

Las consultas que no estén incluidas en uno de los formatos anteriores no están soportadas. En estas situaciones, mysqli_info() devolverá una cadena vacía.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una cadena de caracteres representando información adicional sobre la última consulta ejecutrada.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->info

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
$mysqli->query("INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", $mysqli->info);

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
mysqli_query($link, "INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", mysqli_info($link));

/* close connection */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Records: 150  Duplicates: 0  Warnings: 0

Ver también

  • mysqli_affected_rows() - Obtiene el número de filas afectadas en la última operación MySQL
  • mysqli_warning_count() - Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado
  • mysqli_num_rows() - Obtiene el número de filas de un resultado


Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()

  • « mysqli::$info
  • mysqli::$insert_id »
  • PHP Manual
  • mysqli
  • Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()

mysqli::init

mysqli_init

(PHP 5, PHP 7)

mysqli::init -- mysqli_init — Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()

Descripción

Estilo orientado a objetos

mysqli::init ( ) : mysqli

Estilo por procedimientos

mysqli_init ( ) : mysqli

Asigna o inicializa un objecto MySQL adecuado para mysqli_options() y mysqli_real_connect().

Nota:

Cualquier llamada a cualquier función de mysqli (excepto mysqli_options()) fallará hasta que mysqli_real_connect() sea llamada.

Valores devueltos

Devuelve un objeto.

Ejemplos

Veasé mysqli_real_connect().

Ver también

  • mysqli_options() - Establecer opciones
  • mysqli_close() - Cierra una conexión previamente abierta a una base de datos
  • mysqli_real_connect() - Abre una conexión a un servidor mysql
  • mysqli_connect() - Alias de mysqli::__construct


Devuelve el id autogenerado que se utilizó en la última consulta

  • « mysqli::init
  • mysqli::kill »
  • PHP Manual
  • mysqli
  • Devuelve el id autogenerado que se utilizó en la última consulta

mysqli::$insert_id

mysqli_insert_id

(PHP 5, PHP 7)

mysqli::$insert_id -- mysqli_insert_id — Devuelve el id autogenerado que se utilizó en la última consulta

Descripción

Estilo orientado a objetos

mixed $mysqli->insert_id;

Estilo por procedimientos

mysqli_insert_id ( mysqli $link ) : mixed

La función mysqli_insert_id() devuelve el ID generado por una query (normalmente INSERT) en una tabla con una columna que tenga el atributo AUTO_INCREMENT. Si no se enviaron declaraciones INSERT o UPDATE a través de esta conexión, o si la tabla modificada no tiene una columna con el atributo AUTO_INCREMENT, esta función devolverá cero.

Nota:

Realizar una sentencia INSERT o UPDATE usando la función LAST_INSERT_ID() modificará el valor retornado por la función mysqli_insert_id().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

El valor de el campo AUTO_INCREMENT que fué actualizado por la consulta anterior. Devuelve cero si no hubo una consulta previa en la conexión o si la consulta no actualiza un valor AUTO_INCREMENT.

Nota:

Si el número es mayor que el valor máximo int, mysqli_insert_id() devolverá un string.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->insert_id

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_password", "world");

/* comprobar la conexión. */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
$mysqli->query($query);

printf ("Nuevo registro con el id %d.\n", $mysqli->insert_id);

/* drop table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "mi_usuario", "mi_password", "world");

/* comprobar la conexión. */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
mysqli_query($link, $query);

printf ("Nuevo registro con el id %d.\n", mysqli_insert_id($link));

/* drop table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Nuevo registro con el id 1.


Pide al servidor poner fin a un hilo de MySQL

  • « mysqli::$insert_id
  • mysqli::more_results »
  • PHP Manual
  • mysqli
  • Pide al servidor poner fin a un hilo de MySQL

mysqli::kill

mysqli_kill

(PHP 5, PHP 7)

mysqli::kill -- mysqli_kill — Pide al servidor poner fin a un hilo de MySQL

Descripción

Estilo orientado a objetos

mysqli::kill ( int $processid ) : bool

Estilo por procedimientos

mysqli_kill ( mysqli $link , int $processid ) : bool

Esta función se usa para pedir al servidor que ponga fin a un hilo MySQL especificado por el parámetro processid. Este valor tiene que ser obtenido llamando a la función mysqli_thread_id().

Para detener una consulta en ejecución debe usarse el comando SQL KILL QUERY processid.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::kill()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

/* determinar el id de nuestro hilo */
$thread_id = $mysqli->thread_id;

/* Poner fin a la conexión */
$mysqli->kill($thread_id);

/* Esto debería producir un error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

/* determinar el id de nuestro hilo */
$thread_id = mysqli_thread_id($link);

/* Poner fin a la conexión */
mysqli_kill($link, $thread_id);

/* Esto debería producir un error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Error: MySQL server has gone away

Ver también

  • mysqli_thread_id() - Deveulve el ID del hilo de la conexión actual


Comprueba si hay más resultados de una multi consulta

  • « mysqli::kill
  • mysqli::multi_query »
  • PHP Manual
  • mysqli
  • Comprueba si hay más resultados de una multi consulta

mysqli::more_results

mysqli_more_results

(PHP 5, PHP 7)

mysqli::more_results -- mysqli_more_results — Comprueba si hay más resultados de una multi consulta

Descripción

Estilo orientado a objetos

mysqli::more_results ( ) : bool

Estilo por procedimientos

mysqli_more_results ( mysqli $link ) : bool

Indica si hay disponibles algún juego de resultados de alguna llamada previa a mysqli_multi_query().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true si uno o más conjuntos de resultados están disponibles desde una llamada anterior a mysqli_multi_query(), o de lo contrario devuelve false.

Ejemplos

See mysqli_multi_query().

Ver también

  • mysqli_multi_query() - Realiza una consulta a la base de datos
  • mysqli_next_result() - Prepara el siguiente resultado de multi_query
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados


Realiza una consulta a la base de datos

  • « mysqli::more_results
  • mysqli::next_result »
  • PHP Manual
  • mysqli
  • Realiza una consulta a la base de datos

mysqli::multi_query

mysqli_multi_query

(PHP 5, PHP 7)

mysqli::multi_query -- mysqli_multi_query — Realiza una consulta a la base de datos

Descripción

Estilo orientado a objetos

mysqli::multi_query ( string $query ) : bool

Estilo por procedimientos

mysqli_multi_query ( mysqli $link , string $query ) : bool

Ejecuta una o múltiples consultas concatenadas por puntos y comas.

Para obtener el juego de resultados de la primera consulta se puede usar mysqli_use_result() o mysqli_store_result(). El resto de resultados de consultas se pueden obtener usando mysqli_more_results() y mysqli_next_result().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

query

Consulta, en forma de string.

Los datos dentro de la consulta debe estar correctamente escapados.

Valores devueltos

Devuelve false si la primera sentencia falló. Para obtener el resto de errores de otras sentencias debe llamarse antes a mysqli_next_result().

Ejemplos

Ejemplo #1 Ejemplo de mysqli::multi_query()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* ejecutar multi consulta */
if ($mysqli->multi_query($query)) {
    do {
        /* almacenar primer juego de resultados */
        if ($result = $mysqli->store_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->free();
        }
        /* mostrar divisor */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* ejecutar multi consulta */
if (mysqli_multi_query($link, $query)) {
    do {
        /* almacenar primer juego de resultados */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* mostrar divisor */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería algo similar a:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Ver también

  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_next_result() - Prepara el siguiente resultado de multi_query
  • mysqli_more_results() - Comprueba si hay más resultados de una multi consulta


Prepara el siguiente resultado de multi_query

  • « mysqli::multi_query
  • mysqli::options »
  • PHP Manual
  • mysqli
  • Prepara el siguiente resultado de multi_query

mysqli::next_result

mysqli_next_result

(PHP 5, PHP 7)

mysqli::next_result -- mysqli_next_result — Prepara el siguiente resultado de multi_query

Descripción

Estilo orientado a objetos

mysqli::next_result ( ) : bool

Estilo por procedimientos

mysqli_next_result ( mysqli $link ) : bool

Prepara el siguiente juego de resultados de una llamada a
mysqli_multi_query() que puede obtenerse con
mysqli_store_result() o con
mysqli_use_result().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

See mysqli_multi_query().

Ver también

  • mysqli_multi_query() - Realiza una consulta a la base de datos
  • mysqli_more_results() - Comprueba si hay más resultados de una multi consulta
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados


Establecer opciones

  • « mysqli::next_result
  • mysqli::ping »
  • PHP Manual
  • mysqli
  • Establecer opciones

mysqli::options

mysqli_options

(PHP 5, PHP 7)

mysqli::options -- mysqli_options — Establecer opciones

Descripción

Estilo orientado a objetos

mysqli::options ( int $option , mixed $value ) : bool

Estilo por procedimientos

mysqli_options ( mysqli $link , int $option , mixed $value ) : bool

Se usa para establecer opciones extra y para modificar al comportamiento de una conexión.

Se puede llamar varias veces a esta función para establecer varias opciones.

mysqli_options() debería invocarse después de
mysqli_init() y antes de
mysqli_real_connect().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

opción

Opción que se desea establecer. Puede ser una de las siguientes.

Opciones válidas
Nombre | Descripción
MYSQLI_OPT_CONNECT_TIMEOUT | tiempo de expiración en segundos de la conexión (soportado en Windows con TCP/IP desde PHP 5.3.1)
MYSQLI_OPT_LOCAL_INFILE | habilitar/deshabilitar el uso de LOAD LOCAL INFILE
MYSQLI_INIT_COMMAND | comando a ejecutar tras conectar al servidor MySQL
MYSQLI_READ_DEFAULT_FILE | Leer las opciones del fichero nombrado de opciones en lugar de my.cnf
MYSQLI_READ_DEFAULT_GROUP | Leer opciones del grupo nombrado de my.cnf o del fichero especificado con MYSQL_READ_DEFAULT_FILE.
MYSQLI_SERVER_PUBLIC_KEY | Fichero de clave pública RSA usado con la autenticación basada en SHA-256.
MYSQLI_OPT_NET_CMD_BUFFER_SIZE | El tamaño del búfer interno de órdenes/red. Solo válido para mysqlnd.
MYSQLI_OPT_NET_READ_BUFFER_SIZE | Tamaño de trozo de lectura máximo en bytes al leer el cuerpo de un paquete de órdenes de MySQL. Solo válido para mysqlnd.
MYSQLI_OPT_INT_AND_FLOAT_NATIVE | Convertir columnas integer y float a números de PHP. Únicamente válido para mysqlnd.
MYSQLI_OPT_SSL_VERIFY_SERVER_CERT

value

Valor de la opción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Se añadieron las opciones MYSQLI_SERVER_PUBLIC_KEY y MYSQLI_SERVER_PUBLIC_KEY.
5.3.0 | Se añadierons las opciones MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, y MYSQLI_OPT_SSL_VERIFY_SERVER_CERT.

Ejemplos

Vea mysqli_real_connect().

Notas

Nota:

MySQLnd siempre utiliza el juego de caracteres de idioma predeterminado. El juego de caracteres se envía en la autentificación/acuerdo que se produce durante la conexión, que utilizará mysqlnd.

Libmysqlclient utiliza el juego de caracteres predeterminado definido en my.cnf o se puede establecer llamando mysqli_options() antes de user mysqli_real_connect(), pero después de mysqli_init().

Ver también

  • mysqli_init() - Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
  • mysqli_real_connect() - Abre una conexión a un servidor mysql


Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión

  • « mysqli::options
  • mysqli::poll »
  • PHP Manual
  • mysqli
  • Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión

mysqli::ping

mysqli_ping

(PHP 5, PHP 7)

mysqli::ping -- mysqli_ping — Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión

Descripción

Estilo orientado a objetos

mysqli::ping ( ) : bool

Estilo por procedimientos

mysqli_ping ( mysqli $link ) : bool

Comprueba si la conexión al servidor funciona. Si se ha perdido, y la opción global mysqli.reconnect está habilitada, se intenta realizar una reconexión automática.

Esta función la pueden utilizar clientes que permanecen inactivos por mucho tiempo para comprobar si el servidor ha cerrado la conexión y reconectar si fuera necesario.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::ping()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if ($mysqli->connect_errno) {
    printf("Conexión fallida: %s\n", $mysqli->connect_error);
    exit();
}

/* comprobar si el servidor sigue vivo */
if ($mysqli->ping()) {
    printf ("¡La conexión está bien!\n");
} else {
    printf ("Error: %s\n", $mysqli->error);
}

/* cerrar la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

/* comprobar si el servidor sigue funcionando */
if (mysqli_ping($enlace)) {
    printf ("¡La conexión está bien!\n");
} else {
    printf ("Error: %s\n", mysqli_error($enlace));
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

¡La conexión está bien!


Almacena en caché conexiones

  • « mysqli::ping
  • mysqli::prepare »
  • PHP Manual
  • mysqli
  • Almacena en caché conexiones

mysqli::poll

mysqli_poll

(PHP 5 >= 5.3.0, PHP 7)

mysqli::poll -- mysqli_poll — Almacena en caché conexiones

Descripción

Estilo orientado a objetos

public static mysqli::poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = ? ) : int

Estilo por procedimientos

mysqli_poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = ? ) : int

Almacena en caché conexiones. Disponible sólo con mysqlnd. Este método puede usarse como estático.

Parámetros

read

Lista de conexiones a comprobar para resultados pendientes que se pueden leer.

error

Lista de conexiones en las que ocurrió un error, por ejemplo, fallo de consulta o conexión perdida.

reject

Lista de conexiones rechazadas debido a que no se ha ejecutado ninguna consulta asíncrona para la que la función podría almacenar en caché resultados.

sec

El número de segundos a esperar, debe ser no negativo.

usec

El número de microsegundos a esperar, debe ser no negativo.

Valores devueltos

Devuelve el número de conexiones si tiene éxito, false de otro modo.

Ejemplos

Ejemplo #1 Un ejemplo de mysqli_poll()

<?php
$enlace1 = mysqli_connect();
$enlace1->query("SELECT 'test'", MYSQLI_ASYNC);
$todos_los_enlaces = array($enlace1);
$procesado = 0;
do {
    $enlaces = $errores = $rechazados = array();
    foreach ($todos_los_enlaces as $enlace) {
        $enlaces[] = $errores[] = $rechazados[] = $enlace;
    }
    if (!mysqli_poll($enlaces, $errores, $rechazados, 1)) {
        continue;
    }
    foreach ($enlaces as $enlace) {
        if ($resultado = $enlace->reap_async_query()) {
            print_r($resultado->fetch_row());
            if (is_object($resultado))
                mysqli_free_result($resultado);
        } else die(sprintf("MySQLi Error: %s", mysqli_error($enlace1)));
        $procesado++;
    }
} while ($procesado < count($todos_los_enlaces));
?>

El resultado del ejemplo sería:

Array
(
    [0] => test
)

Ver también

  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_reap_async_query() - Obtener el resultado de una consulta asincrónica


Prepara una sentencia SQL para su ejecución

  • « mysqli::poll
  • mysqli::query »
  • PHP Manual
  • mysqli
  • Prepara una sentencia SQL para su ejecución

mysqli::prepare

mysqli_prepare

(PHP 5, PHP 7)

mysqli::prepare -- mysqli_prepare — Prepara una sentencia SQL para su ejecución

Descripción

Estilo orientado a objetos

mysqli::prepare ( string $query ) : mysqli_stmt

Estilo por procedimientos

mysqli_prepare ( mysqli $link , string $query ) : mysqli_stmt

Prepara la consulta SQL y devuelve un manejador de sentencia para ser utilizado por operaciones adicionales sobre la sentencia. La consulta debe constar de una única sentencia SQL.

Los marcadores de parámetros deben estar ligados a variables de aplicación utilizando mysqli_stmt_bind_param() y/o mysqli_stmt_bind_result() antes de ejecutar la sentencia u obtener las filas.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

query

La consulta, como un string.

Nota:

No se debe agregar un punto y coma o \g a la sentencia.

Este parámetro puede incluir uno o más marcadores de parámetros en la sentencia SQL mediante la incorporación de caracteres de signo de interrogación (?) en las posiciones correctas.

Nota:

Los marcadores son legales solo en ciertos lugares en las sentencias SQL. Por ejemplo, se les permite en la lista VALUES() de una sentencia INSERT (para especificar valores de columna para una fila), o en una comparación con una columna en una cláusula WHERE para especificar un valor de comparación.

Sin embargo, no se les permite para identificadores (como nombres de tabla o columna), en la lista de selección que nombra las columnas que se devuelven mediante una sentencia SELECT, o para especificar ambos operandos de un operador binario como el signo de igualdad =. Esta última restricción es necesaria debido a que sería imposible determinar el tipo de parámetro. Tampoco está permitido comparar un marcador con NULL mediante ? IS NULL. En general, los parámetros son legales solamente en sentencias del Lenguaje de Manipulación de Datos (DML) y no en sentencias del Lenguaje de Definición de Datos (DDL).

Valores devueltos

mysqli_prepare() devuelve un objeto de sentencia o false si ocurre un error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::prepare()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* crear una sentencia preparada */
if ($stmt = $mysqli->prepare("SELECT District FROM City WHERE Name=?")) {

    /* ligar parámetros para marcadores */
    $stmt->bind_param("s", $city);

    /* ejecutar la consulta */
    $stmt->execute();

    /* ligar variables de resultado */
    $stmt->bind_result($district);

    /* obtener valor */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* cerrar sentencia */
    $stmt->close();
}

/* cerrar conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* crear una sentencia preparada */
if ($stmt = mysqli_prepare($link, "SELECT District FROM City WHERE Name=?")) {

    /* ligar parámetros para marcadores */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* ejecutar la consulta */
    mysqli_stmt_execute($stmt);

    /* ligar variables de resultado */
    mysqli_stmt_bind_result($stmt, $district);

    /* obtener valor */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* cerrar sentencia */
    mysqli_stmt_close($stmt);
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Amersfoort is in district Utrecht

Ver también

  • mysqli_stmt_execute() - Ejecuta una consulta preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_stmt_bind_param() - Agrega variables a una sentencia preparada como parámetros
  • mysqli_stmt_bind_result() - Vincula variables a una sentencia preparada para el almacenamiento de resultados
  • mysqli_stmt_close() - Cierra una sentencia preparada


Realiza una consulta a la base de datos

  • « mysqli::prepare
  • mysqli::real_connect »
  • PHP Manual
  • mysqli
  • Realiza una consulta a la base de datos

mysqli::query

mysqli_query

(PHP 5, PHP 7)

mysqli::query -- mysqli_query — Realiza una consulta a la base de datos

Descripción

Estilo orientado a objetos

mysqli::query ( string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed

Estilo por procedimientos

mysqli_query ( mysqli $link , string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed

Realiza una consulta dada por query a la base de datos.

Para consultas que no sean DML (distintas de INSERT, UPDATE o DELETE),
esta funcion es similar a invocar a
mysqli_real_query() seguida de
mysqli_use_result() o
mysqli_store_result().

Nota:

En el caso de pasarle una sentencia a mysqli_query() que sea mayor del valor de max_allowed_packet del servidor, los códigos de error retornados diferirán dependiendo de si se está usando el Controlador Nativo de MySQL (mysqlnd) o la Biblioteca Cliente de MySQL (libmysqlclient). El comportamiento es el siguiente:

  • mysqlnd en Linux retorna un código de error 1153. Este mensaje de error significa que se tiene un paquete mayor que max_allowed_packet bytes.

  • mysqlnd en Windows retorna un código de error 2006. Este mensaje de error significa que el servidor no está disponible.

  • libmysqlclient en toda las plataformas retorna el código de error 2006. Este mensaje de error significa que el servidor no está disponible.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

query

La string de la consulta.

Los datos dentro de la consulta deberían estar adecuadamente escapados.

resultmode

La constante MYSQLI_USE_RESULT o MYSQLI_STORE_RESULT dependiendo del compotamiento deseado. Por defecto, se usa la constante MYSQLI_STORE_RESULT.

Si se usa MYSQLI_USE_RESULT todas la llamadas posteriores retornarán con un error Commands out of sync a menos que se llame a mysqli_free_result()

Con MYSQLI_ASYNC (disponible con mysqlnd), es posible hacer consulta de manera asíncrona. mysqli_poll() se utiliza para obtener los resultados de dichas consultas.

Valores devueltos

Retorna false en caso de error. Si una consulta del tipo SELECT, SHOW, DESCRIBE o EXPLAIN es exitosa, mysqli_query() retornará un objeto mysqli_result. Para otras consultas exitosas de mysqli_query() retornará true.

Historial de cambios

Versión | Descripción
5.3.0 | Se agregó la posibilidad de realizar consultas asíncronas.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::query()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* comprobar la conexión */
if ($mysqli->connect_errno) {
    printf("Falló la conexión: %s\n", $mysqli->connect_error);
    exit();
}

/* Crear una tabla que no devuelve un conjunto de resultados */
if ($mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Se creó con éxtio la tabla myCity.\n");
}

/* Consultas de selección que devuelven un conjunto de resultados */
if ($resultado = $mysqli->query("SELECT Name FROM City LIMIT 10")) {
    printf("La selección devolvió %d filas.\n", $resultado->num_rows);

    /* liberar el conjunto de resultados */
    $resultado->close();
}

/* Si se ha de recuperar una gran cantidad de datos se emplea MYSQLI_USE_RESULT */
if ($resultado = $mysqli->query("SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Observar que no se puede ejecutar ninguna función que interactue con el
       servidor hasta que el conjunto de resultados se haya cerrado. Todas las llamadas devolverán un
       error 'out of sync' */
    if (!$mysqli->query("SET @a:='esto no funcionará'")) {
        printf("Error: %s\n", $mysqli->error);
    }
    $resultado->close();
}

$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* Crear una tabla que no devuelve un conjunto de resultados */
if (mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Se creó con éxtio la tabla myCity.\n");
}

/* Consultas de selección que devuelven un conjunto de resultados */
if ($resultado = mysqli_query($link, "SELECT Name FROM City LIMIT 10")) {
    printf("La selección devolvió %d filas.\n", mysqli_num_rows($resultado));

    /* liberar el conjunto de resultados */
    mysqli_free_result($resultado);
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($resultado = mysqli_query($link, "SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Observar que no se puede ejecutar ninguna función que interactue con el
       servidor hasta que el conjunto de resultados se haya cerrado. Todas las llamadas devolverán un
       error 'out of sync' */
    if (!mysqli_query($link, "SET @a:='esto no funcionará'")) {
        printf("Error: %s\n", mysqli_error($link));
    }
    mysqli_free_result($resultado);
}

mysqli_close($link);
?>

El resultado de los ejemplos sería:

Se creó con éxtio la tabla myCity.
La selección devolvió 10 filas.
Error: Commands out of sync;  You can't run this command now

Ver también

  • mysqli_real_query() - Ejecuta una consulta SQL
  • mysqli_multi_query() - Realiza una consulta a la base de datos
  • mysqli_free_result() - Libera la memoria asociada a un resultado


Abre una conexión a un servidor mysql

  • « mysqli::query
  • mysqli::real_escape_string »
  • PHP Manual
  • mysqli
  • Abre una conexión a un servidor mysql

mysqli::real_connect

mysqli_real_connect

(PHP 5, PHP 7)

mysqli::real_connect -- mysqli_real_connect — Abre una conexión a un servidor mysql

Descripción

Estilo orientado a objetos

mysqli::real_connect ( string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool

Estilo por procedimientos

mysqli_real_connect ( mysqli $link , string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool

Establece una conexión a un motor de bases de datos MySQL.

Esta función difiere de mysqli_connect() en:

  • mysqli_real_connect() necesita un objeto válido que haya sido creado por la función mysqli_init().

  • Con la función mysqli_options() se pueden establecer varias opciones de conexión.

  • Existe un parámetro flags.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

host

Puede ser un nombre de host o una dirección IP. Si se pasa el valor null o la cadena "localhost" a este parámetro, se asume el host local. Cuando sea posible se usarán tuberías en lugar del protocolo TCP/IP.

username

El nombre de usuario de MySQL.

passwd

Si se proporciona o es null, el servidor MySQL intentará autenticar al usuario con los registros de usuarios que solamente no tengan contraseña. Esto permite a un nombre de usuario que sea usado con diferentes permisos (dependiendo de si se proporciona una contraseña o no).

dbname

Si se proporciona, especificará la base de datos predeterminada a ser usada para realizar consultas.

port

Especifica el número de puerto con el que intentar conectarse al servidor MySQL.

socket

Especifica el socket o la tubería con nombre que debería usarse.

Nota:

Especificar el parámetro socket no determinará explícitamente el tipo de conexión a usar al conectarse al servidor MySQL. El modo de realizar la conexión a la base de datos de MySQL está determinado por el parámetro host.

flags

Con el parámetro flags se pueden establecer diferentes opciones de conexión:

Banderas soportadas
Nobre | Descripción
MYSQLI_CLIENT_COMPRESS | Usar el protocolo de compresión
MYSQLI_CLIENT_FOUND_ROWS | Devolver el número de filas coincidentes, no el número de filas afectadas
MYSQLI_CLIENT_IGNORE_SPACE | Permitir espacios después de los nombres de funciones. Hace que todos los nombres de funciones sean palabras reservadas.
MYSQLI_CLIENT_INTERACTIVE | Permite interactive_timeout segundos (en vez de wait_timeout segundos) de inactividad antes de cerrar la conexión
MYSQLI_CLIENT_SSL | Usar SSL (encriptación)
MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT | Igual que MYSQLI_CLIENT_SSL, pero deshabilita la validación del certificado SSL proporcionado. Esto solamente es para instalaciones que usan el Controlador Nativo de MySQL y MySQL 5.6 o superior.

Nota:

Por razones de seguridad la bandera MULTI_STATEMENT no está soportada en PHP. Si quiere ejecutar múltiples consultas use la función mysqli_multi_query().

Historial de cambios

Versión | Descripción
5.6.16 | Se añadió la bandera MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT para el Controlador Nativo de MySQL

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::real_connect()

Estilo orientado a objetos

<?php

$mysqli = mysqli_init();
if (!$mysqli) {
    die('Falló mysqli_init');
}

if (!$mysqli->options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Falló la configuración de MYSQLI_INIT_COMMAND');
}

if (!$mysqli->options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Falló la configuración de MYSQLI_OPT_CONNECT_TIMEOUT');
}

if (!$mysqli->real_connect('localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd')) {
    die('Error de conexión (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Éxito... ' . $mysqli->host_info . "\n";

$mysqli->close();
?>

Estilo orientado a objetos al extender la clase mysqli

<?php

class foo_mysqli extends mysqli {
    public function __construct($host, $usuario, $contraseña, $bd) {
        parent::init();

        if (!parent::options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
            die('Falló la configuración de MYSQLI_INIT_COMMAND');
        }

        if (!parent::options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
            die('Falló la configuración de MYSQLI_OPT_CONNECT_TIMEOUT');
        }

        if (!parent::real_connect($host, $usuario, $contraseña, $bd)) {
            die('Error de conexión (' . mysqli_connect_errno() . ') '
                    . mysqli_connect_error());
        }
    }
}

$bd = new foo_mysqli('localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd');

echo 'Éxito... ' . $bd->host_info . "\n";

$bd->close();
?>

Estilo por procedimientos

<?php

$enlace = mysqli_init();
if (!$enlace) {
    die('Falló mysqli_init');
}

if (!mysqli_options($enlace, MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Falló la configuración de MYSQLI_INIT_COMMAND');
}

if (!mysqli_options($enlace, MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Falló la configuración de MYSQLI_OPT_CONNECT_TIMEOUT');
}

if (!mysqli_real_connect($enlace, 'localhost', 'mi_usuario', 'mi_contraseña', 'mi_bd')) {
    die('Error de conexión (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Éxito... ' . mysqli_get_host_info($enlace) . "\n";

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Éxito... MySQL host info: localhost via TCP/IP

Notas

Nota:

MySQLnd siempre utiliza el juego de caracteres de idioma predeterminado. El juego de caracteres se envía en la autentificación/acuerdo que se produce durante la conexión, que utilizará mysqlnd.

Libmysqlclient utiliza el juego de caracteres predeterminado definido en my.cnf o se puede establecer llamando mysqli_options() antes de user mysqli_real_connect(), pero después de mysqli_init().

Ver también

  • mysqli_connect() - Alias de mysqli::__construct
  • mysqli_init() - Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
  • mysqli_options() - Establecer opciones
  • mysqli_ssl_set() - Usada para establece conexiones seguras usando SSL
  • mysqli_close() - Cierra una conexión previamente abierta a una base de datos


Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

  • « mysqli::real_connect
  • mysqli::real_query »
  • PHP Manual
  • mysqli
  • Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

mysqli::real_escape_string

mysqli_real_escape_string

(PHP 5, PHP 7)

mysqli::real_escape_string -- mysqli_real_escape_string — Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

Descripción

Estilo orientado a objetos

mysqli::escape_string ( string $escapestr ) : string
mysqli::real_escape_string ( string $escapestr ) : string

Estilo por procedimientos

mysqli_real_escape_string ( mysqli $link , string $escapestr ) : string

Esta función se usa para crear una cadena SQL legal que se puede usar en una sentencia SQL. La cadena dada es codificada a una cadena SQL escapada, tomando en cuenta el conjunto de caracteres actual de la conexión.

Precaución

Seguridad: el conjunto de caracteres predeterminado

El conjunto de caracteres debe ser establecido a nivel del servidor, o con la función mysqli_set_charset() de la API para que afecte a mysqli_real_escape_string(). Véase la sección de conceptos sobre conjuntos de caracteres para más información.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

escapestr

La cadena a escapar.

Los caracteres codificados son NUL (ASCII 0), \n, \r, \, ', ", y Control-Z.

Valores devueltos

Devuelve una cadena escapada.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::real_escape_string()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE miCiudad LIKE City");

$ciudad = "'s Hertogenbosch";

/* esta consulta fallará debido a que no escapa $ciudad */
if (!$mysqli->query("INSERT into miCiudad (Name) VALUES ('$ciudad')")) {
    printf("Error: %s\n", $mysqli->sqlstate);
}

$ciudad = $mysqli->real_escape_string($ciudad);

/* esta consulta con $ciudad escapada funcionará */
if ($mysqli->query("INSERT into miCiudad (Name) VALUES ('$ciudad')")) {
    printf("%d fila insertada.\n", $mysqli->affected_rows);
}

$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TEMPORARY TABLE miCiudad LIKE City");

$ciudad = "'s Hertogenbosch";

/* esta consulta fallará debido a que no escapa $ciudad */
if (!mysqli_query($enlace, "INSERT into miCiudad (Name) VALUES ('$ciudad')")) {
    printf("Error: %s\n", mysqli_sqlstate($enlace));
}

$ciudad = mysqli_real_escape_string($enlace, $ciudad);

/* esta consulta con $ciudad escapada funcionará */
if (mysqli_query($enlace, "INSERT into miCiudad (Name) VALUES ('$ciudad')")) {
    printf("%d fila insertada.\n", mysqli_affected_rows($enlace));
}

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error: 42000
1 fila insertada.

Notas

Nota:

Para quienes estén acostumbrados a usar mysql_real_escape_string(), se ha de observar que el argumento de mysqli_real_escape_string() difiere de lo que espera mysql_real_escape_string(). El identificador enlace va primero en mysqli_real_escape_string(), mientras que la cadena a escapar va primero en mysql_real_escape_string().

Ver también

  • mysqli_set_charset() - Establece el conjunto de caracteres predeterminado del cliente
  • mysqli_character_set_name() - Devuelve el juego de caracteres predeterminado para la conexión a la base de datos


Ejecuta una consulta SQL

  • « mysqli::real_escape_string
  • mysqli::reap_async_query »
  • PHP Manual
  • mysqli
  • Ejecuta una consulta SQL

mysqli::real_query

mysqli_real_query

(PHP 5, PHP 7)

mysqli::real_query -- mysqli_real_query — Ejecuta una consulta SQL

Descripción

Estilo orientado a objetos

mysqli::real_query ( string $query ) : bool

Estilo por procedimientos

mysqli_real_query ( mysqli $link , string $query ) : bool

Ejecuta una sola consulta contra la base de datos cuyo resultado puede ser recuperado o almacenado mediante las funciones mysqli_store_result() o mysqli_use_result().

Con el fin de determinar si una consulta dada debe devolver un conjunto de resultados o no, ver mysqli_field_count().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

query

La consulta como un string.

Los datos dentro de la consulta deben estar apropiadamente escapados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados


Obtener el resultado de una consulta asincrónica

  • « mysqli::real_query
  • mysqli::refresh »
  • PHP Manual
  • mysqli
  • Obtener el resultado de una consulta asincrónica

mysqli::reap_async_query

mysqli_reap_async_query

(PHP 5 >= 5.3.0, PHP 7)

mysqli::reap_async_query -- mysqli_reap_async_query — Obtener el resultado de una consulta asincrónica

Descripción

Estilo orientado a objetos

public mysqli::reap_async_query ( ) : mysqli_result

Estilo por procedimientos

mysqli_reap_async_query ( mysqli $link ) : mysqli_result

Obtiene el resultado de una consulta asincrónica. Disponible sólo con mysqlnd.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve un objeto mysqli_result en caso de éxito, false en caso contrario.

Ver también

  • mysqli_poll() - Almacena en caché conexiones


Refresca

  • « mysqli::reap_async_query
  • mysqli::release_savepoint »
  • PHP Manual
  • mysqli
  • Refresca

mysqli::refresh

mysqli_refresh

(PHP 5 >= 5.3.0, PHP 7)

mysqli::refresh -- mysqli_refresh — Refresca

Descripción

Estilo orientado a objetos

public mysqli::refresh ( int $options ) : bool

Estilo por procedimientos

mysqli_refresh ( resource $link , int $options ) : bool

Vacía las tablas o caches, o restablece la información de replicación de servidores.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

options

Las opciones para refrescar, utilizando las constantes MYSQLI_REFRESH_* tal como se documenta en las constantes MySQLi.

Ver también la documentiación oficial de » MySQL Refresh

Valores devueltos

true si el refresh fue exitoso, false en caso contrario.

Ver también

  • mysqli_poll() - Almacena en caché conexiones


Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual

  • « mysqli::refresh
  • mysqli::rollback »
  • PHP Manual
  • mysqli
  • Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual

mysqli::release_savepoint

mysqli_release_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::release_savepoint -- mysqli_release_savepoint — Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual

Descripción

Estilo orientado a objetos (method):

public mysqli::release_savepoint ( string $name ) : bool

Estilo por procedimientos:

mysqli_release_savepoint ( mysqli $link , string $name ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

name

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_rollback() - Revierte la transacción actual


Revierte la transacción actual

  • « mysqli::release_savepoint
  • mysqli::savepoint »
  • PHP Manual
  • mysqli
  • Revierte la transacción actual

mysqli::rollback

mysqli_rollback

(PHP 5, PHP 7)

mysqli::rollback -- mysqli_rollback — Revierte la transacción actual

Descripción

Estilo orientado a objetos

mysqli::rollback ( int $flags = ? , string $name = ? ) : bool

Estilo por procedimientos

mysqli_rollback ( mysqli $link , int $flags = ? , string $name = ? ) : bool

Revierte la transacción actual de la base de datos.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

flags

Una máscara de bits de constantes MYSQLI_TRANS_COR_*.

name

Si se proporciona, se ejecuta ROLLBACK/*name*/.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Se añadieron los parámetros flags y name.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::rollback()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* deshabilitar autocommit */
$mysqli->autocommit(FALSE);

$mysqli->query("CREATE TABLE myCity LIKE City");
$mysqli->query("ALTER TABLE myCity Type=InnoDB");
$mysqli->query("INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* insertar commit */
$mysqli->commit();

/* borrar todas las filas */
$mysqli->query("DELETE FROM myCity");

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity.\n", $row[0]);
    /* Liberar resultado */
    $result->close();
}

/* Revertir */
$mysqli->rollback();

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Liberar resultado */
    $result->close();
}

/* Eliminar la tabla myCity */
$mysqli->query("DROP TABLE myCity");

$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* deshabilitar autocommit */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE myCity LIKE City");
mysqli_query($link, "ALTER TABLE myCity Type=InnoDB");
mysqli_query($link, "INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* insertar commit */
mysqli_commit($link);

/* borrar todas las filas */
mysqli_query($link, "DELETE FROM myCity");

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity.\n", $row[0]);
    /* Liberar resultado */
    mysqli_free_result($result);
}

/* Revertir */
mysqli_rollback($link);

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Liberar resultado */
    mysqli_free_result($result);
}

/* Eliminar la tabla myCity */
mysqli_query($link, "DROP TABLE myCity");

mysqli_close($link);
?>

El resultado de los ejemplos sería:

0 rows in table myCity.
50 rows in table myCity (after rollback).

Ver también

  • mysqli_begin_transaction() - Inicia una transacción
  • mysqli_commit() - Consigna la transacción actual
  • mysqli_autocommit() - Activa o desactiva las modificaciones de la base de datos autoconsignadas
  • mysqli_release_savepoint() - Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual


Define el nombre de un punto de salvaguarda de la transacción

  • « mysqli::rollback
  • mysqli::select_db »
  • PHP Manual
  • mysqli
  • Define el nombre de un punto de salvaguarda de la transacción

mysqli::savepoint

mysqli_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::savepoint -- mysqli_savepoint — Define el nombre de un punto de salvaguarda de la transacción

Descripción

Estilo orientado a objetos (method):

public mysqli::savepoint ( string $name ) : bool

Estilo por procedimientos:

mysqli_savepoint ( mysqli $link , string $name ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

name

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_commit() - Consigna la transacción actual


Selecciona la base de datos por defecto para realizar las consultas

  • « mysqli::savepoint
  • mysqli::set_charset »
  • PHP Manual
  • mysqli
  • Selecciona la base de datos por defecto para realizar las consultas

mysqli::select_db

mysqli_select_db

(PHP 5, PHP 7)

mysqli::select_db -- mysqli_select_db — Selecciona la base de datos por defecto para realizar las consultas

Descripción

Estilo orientado a objetos

mysqli::select_db ( string $dbname ) : bool

Estilo por procedimientos

mysqli_select_db ( mysqli $link , string $dbname ) : bool

Selecciona la base de datos por defecto que se utilizará para realizar las consultas, en la conexión activa.

Nota:

Esta función debería ser usada solo para cambiar la base de datos por defecto para la conexión. Se puede seleccionar la base de datos por defecto en el cuarto parámetro de la función mysqli_connect().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

dbname

El nombre de la base de datos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::select_db()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* comprueba la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* devuelve el nombre de la base de datos actualmente seleccionada */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

/* cambia de test bd a world bd */
$mysqli->select_db("world");

/* devuelve el nombre de la base de datos actualmente seleccionadae */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* comprueba la conexión */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* devuelve el nombre de la base de datos actualmente seleccionada */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

/* cambia de test bd a world bd */
mysqli_select_db($link, "world");

/* devuelve el nombre de la base de datos actualmente seleccionada */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

mysqli_close($link);
?>

El resultado de los ejemplos sería:

Default database is test.
Default database is world.

Ver también

  • mysqli_connect() - Alias de mysqli::__construct
  • mysqli_real_connect() - Abre una conexión a un servidor mysql


Establece el conjunto de caracteres predeterminado del cliente

  • « mysqli::select_db
  • mysqli::$sqlstate »
  • PHP Manual
  • mysqli
  • Establece el conjunto de caracteres predeterminado del cliente

mysqli::set_charset

mysqli_set_charset

(PHP 5 >= 5.0.5, PHP 7)

mysqli::set_charset -- mysqli_set_charset — Establece el conjunto de caracteres predeterminado del cliente

Descripción

Estilo orientado a objetos

mysqli::set_charset ( string $charset ) : bool

Estilo por procedimientos

mysqli_set_charset ( mysqli $link , string $charset ) : bool

Establece el conjunto de caracteres predeterminado a usar cuando se envían datos desde y hacia el servidor de la base de datos.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

charset

El conjunto de caracteres a establecer como predeterminado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Para usar esta función en una plataforma Windows se necesita la biblioteca cliente de MySQL version 4.1.11 o superior (para MySQL 5.0 se necesita 5.0.6 o superior).

Nota:

Esta es la mejor forma de cambiar el conjunto de caracteres. No se recomienda usar mysqli_query() para establecerlo (como SET NAMES utf8). Véase la sección Conceptos del conjunto de caracteres de MySQL para más información.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::set_charset()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "test");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

printf("Conjunto de caracteres inicial: %s\n", $mysqli->character_set_name());

/* cambiar el conjunto de caracteres a utf8 */
if (!$mysqli->set_charset("utf8")) {
    printf("Error cargando el conjunto de caracteres utf8: %s\n", $mysqli->error);
    exit();
} else {
    printf("Conjunto de caracteres actual: %s\n", $mysqli->character_set_name());
}

$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect('localhost', 'mi_usuario', 'mi_contraseña', 'test');

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

printf("Conjunto de caracteres inicial: %s\n", mysqli_character_set_name($enlace));

/* cambiar el conjunto de caracteres a utf8 */
if (!mysqli_set_charset($enlace, "utf8")) {
    printf("Error cargando el conjunto de caracteres utf8: %s\n", mysqli_error($enlace));
    exit();
} else {
    printf("Conjunto de caracteres actual: %s\n", mysqli_character_set_name($enlace));
}

mysqli_close($enlace);
?>

El resultado de los ejemplos sería algo similar a:

Conjunto de caracteres inicial: latin1
Conjunto de caracteres actual: utf8

Ver también

  • mysqli_character_set_name() - Devuelve el juego de caracteres predeterminado para la conexión a la base de datos
  • mysqli_real_escape_string() - Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
  • Conceptos sobre conjuntos de caracteres de MySQL
  • » Listado de los conjuntos de caracteres admitidos por MySQL


Devuelve el error SQLSTATE de la operación de MySQL previa

  • « mysqli::set_charset
  • mysqli::ssl_set »
  • PHP Manual
  • mysqli
  • Devuelve el error SQLSTATE de la operación de MySQL previa

mysqli::$sqlstate

mysqli_sqlstate

(PHP 5, PHP 7)

mysqli::$sqlstate -- mysqli_sqlstate — Devuelve el error SQLSTATE de la operación de MySQL previa

Descripción

Estilo orientado a objetos

string $mysqli->sqlstate;

Estilo por procedimientos

mysqli_sqlstate ( mysqli $link ) : string

Devuelve una cadena que contiene el código de error SQLSTATE del último error. El código de error consiste en cinco caracteres. '00000' significa sin error. Los valores son especificados por ANSI SQL y ODBC. Para una lista de los posibles valores, véase » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Nota:

Observe que no todos los errores de MySQL están aún referenciados a SQLSTATE. El valor HY000 (error general error) se utiliza para error no referenciados.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve una cadena que contiene el código de error SQLSTATE del último error. El código de error consiste en cinco caracteres. '00000' significa sin error.

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->sqlstate

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* Comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* La tabla City ya existe, por lo que deberíamos obtener un error */
if (!$mysqli->query("CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", $mysqli->sqlstate);
}

$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* Comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* La tabla City ya existe, por lo que deberíamos obtener un error */
if (!mysqli_query($enlace, "CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", mysqli_sqlstate($enlace));
}

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error - SQLSTATE 42S01.

Ver también

  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysqli_error() - Devuelve una cadena que describe el último error


Usada para establece conexiones seguras usando SSL

  • « mysqli::$sqlstate
  • mysqli::stat »
  • PHP Manual
  • mysqli
  • Usada para establece conexiones seguras usando SSL

mysqli::ssl_set

mysqli_ssl_set

(PHP 5, PHP 7)

mysqli::ssl_set -- mysqli_ssl_set — Usada para establece conexiones seguras usando SSL

Descripción

Estilo orientado a objetos

mysqli::ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

Estilo por procedimientos

mysqli_ssl_set ( mysqli $link , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

Usada para establece conexiones seguras usando SSL. Se debe llamar antes a mysqli_real_connect(). Esta función no hará nada a menos que esté habilitado el soporte para OpenSSL.

Observe que el Controlador Nativo de MySQL no soporta SSL antes de PHP 5.3.3, por lo que llamar a esta función cuando se utiliza el Controlador Nativo de MySQL resultará en un error. El Controlador Nativo de MySQL está habilitado de forma predeterminada en Microsoft Windows desde la versión 5.3 de PHP en adelante.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

key

El nombre de la ruta al fichero de clave.

cert

El nombre de la ruta al fichero de certificado.

ca

El nombre de la ruta al fichero de autoridad certificadora.

capath

El nombre de la ruta al directorio que contiene los certificados AC SSL de confiaza en formato PEM.

cipher

Una lista de cifradores permisibles a usar para la encriptación SSL.

Cualquier parámetro SSL sin usar puede darse como null

Valores devueltos

Esta función siempres devuelve el valor true. Si la configuración de SSL no es correcta, mysqli_real_connect() devolverá un error al intentar conectarse.

Ver también

  • mysqli_options() - Establecer opciones
  • mysqli_real_connect() - Abre una conexión a un servidor mysql


Obtiene el estado actual del sistema

  • « mysqli::ssl_set
  • mysqli::stmt_init »
  • PHP Manual
  • mysqli
  • Obtiene el estado actual del sistema

mysqli::stat

mysqli_stat

(PHP 5, PHP 7)

mysqli::stat -- mysqli_stat — Obtiene el estado actual del sistema

Descripción

Estilo orientado a objetos

mysqli::stat ( ) : string

Estilo por procedimientos

mysqli_stat ( mysqli $link ) : string

mysqli_stat() devuelve una cadena que contiene información similar a la proporcionada por el comando 'mysqladmin status'. Incluye el tiempo en funcionamiento en segundos y el número de hilos en ejecución, de preguntas, de recargas y de tablas abiertas.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Una cadena que describe el estado del servidor. false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::stat()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

printf ("Estado del sistema: %s\n", $mysqli->stat());

$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

printf("Estado del sistema: %s\n", mysqli_stat($enlace));

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Estado del sistema: Uptime: 272  Threads: 1  Questions: 5340  Slow queries: 0
Opens: 13  Flush tables: 1  Open tables: 0  Queries per second avg: 19.632
Memory in use: 8496K  Max memory used: 8560K

Ver también

  • mysqli_get_server_info() - Devuelve la versión del servidor MySQL


Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare

  • « mysqli::stat
  • mysqli::store_result »
  • PHP Manual
  • mysqli
  • Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare

mysqli::stmt_init

mysqli_stmt_init

(PHP 5, PHP 7)

mysqli::stmt_init -- mysqli_stmt_init — Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare

Descripción

Estilo orientado a objetos

mysqli::stmt_init ( ) : mysqli_stmt

Estilo por procedimientos

mysqli_stmt_init ( mysqli $link ) : mysqli_stmt

Asigna e inicializa un objeto de sentencia apropiado para mysqli_stmt_prepare().

Nota:

Cualquier llamada subsiguiente a cualquier función de mysqli_stmt fallará a menos que se llame antes a mysqli_stmt_prepare().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Returns an object.

Ver también

  • mysqli_stmt_prepare() - Preparar una sentencia SQL para su ejecución


Transfiere un conjunto de resultados de la última consulta

  • « mysqli::stmt_init
  • mysqli::$thread_id »
  • PHP Manual
  • mysqli
  • Transfiere un conjunto de resultados de la última consulta

mysqli::store_result

mysqli_store_result

(PHP 5, PHP 7)

mysqli::store_result -- mysqli_store_result — Transfiere un conjunto de resultados de la última consulta

Descripción

Estilo orientado a objetos

mysqli::store_result ( int $option = ? ) : mysqli_result

Estilo por procedimientos

mysqli_store_result ( mysqli $link , int $option = ? ) : mysqli_result

Transfiere el conjunto de resultados de la última consulta de la conexión a la base de datos representada por el parámetro link a ser usado con la función mysqli_data_seek().

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

option

La opción a establecer. Puede ser uno de los siguientes valores:

Opciones válidas
Nombre | Descripción
MYSQLI_STORE_RESULT_COPY_DATA | Copiar los resultados desde el búfer interno de mysqlnd a variables de PHP. Por defecto, mysqlnd usará un lógica de referencia para evitar copiar y duplicar resultados contenidos en memoria. Para ciertos conjuntos de resultados con filas muy pequeñas, por ejemplo, la estrategia de copia puede reducir el uso total de memoria debido a que las variables de PHP de contienen resultados podrían ser liberadas antes (disponible con mysqlnd solamente, desde PHP 5.6.0)

Valores devueltos

Devuelve un objeto de resultados almacenado en buffer o false si ocurrió un error.

Nota:

mysqli_store_result() devuelve false en caso de que la consulta no devuelve un conjunto de resultados (si la consulta era, por ejemplo, una sentencia INSERT). Esta función también devuelve false si la lectura del conjunto de resultados falla. Se puede comprobar si se ha obtenido un error comprobando si mysqli_error() no devuelve una cadena vacía, si mysqli_errno() devuelve un valor distinto de cero, o si mysqli_field_count() devuelve un valor distinto de cero. Otra posible razón para que esta función devuelva false después de una llamada con éxito a mysqli_query() puede ser un conjunto de resultados demasiado grande (no es posible asignarle memoria). Si mysqli_field_count() devuelve un valor distinto de cero, la sentencia debería haber producido un conjunto de resultados no vacío.

Notas

Nota:

Aunque es una buena práctica liberar la memoria usada por los resultados de una consulta usando la función mysqli_free_result(), al transferir conjuntos de resultados grandes usando la función mysqli_store_result() esto se convierte en particularmente importante.

Ejemplos

Véase mysqli_multi_query().

Ver también

  • mysqli_real_query() - Ejecuta una consulta SQL
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados


Deveulve el ID del hilo de la conexión actual

  • « mysqli::store_result
  • mysqli::thread_safe »
  • PHP Manual
  • mysqli
  • Deveulve el ID del hilo de la conexión actual

mysqli::$thread_id

mysqli_thread_id

(PHP 5, PHP 7)

mysqli::$thread_id -- mysqli_thread_id — Deveulve el ID del hilo de la conexión actual

Descripción

Estilo orientado a objetos

int $mysqli->thread_id;

Estilo por procedimientos

mysqli_thread_id ( mysqli $link ) : int

La función mysqli_thread_id() devuelve el ID del hilo de la conexión actual, el cual puede ser destruido usando la función mysqli_kill(). Si se pierde la conexión y se reconecta con mysqli_ping(), el ID del hilo será otro. Por lo tanto se debería obtener el ID del hilo únicamente cuando se necesite.

Nota:

El ID del hilo es asignado basándose en una conexión-por-conexión. Por lo tanto, si la conexión se pierde y se restablece se asignará un nuevo ID de hio.

Para destruir una consulta en ejecución se puede usar el comando SQL KILL QUERY id_proceso.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Devuelve el ID del hilo de la conexión actual.

Ejemplos

Ejemplo #1 Ejemplo $mysqli->thread_id

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* determinar el id del hilo */
$id_hilo = $mysqli->thread_id;

/* Destruir la conexión */
$mysqli->kill($id_hilo);

/* Esto debería producir un error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* cerrar la conexión */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* determinar el id del hilo */
$id_hilo = mysqli_thread_id($enlace);

/* Destruir la conexión */
mysqli_kill($enlace, $id_hilo);

/* Esto debería producir un error */
if (!mysqli_query($enlace, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($enlace));
    exit;
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error: MySQL server has gone away

Ver también

  • mysqli_kill() - Pide al servidor poner fin a un hilo de MySQL


Devuelve si la seguridad a nivel de hilos está dada o no

  • « mysqli::$thread_id
  • mysqli::use_result »
  • PHP Manual
  • mysqli
  • Devuelve si la seguridad a nivel de hilos está dada o no

mysqli::thread_safe

mysqli_thread_safe

(PHP 5, PHP 7)

mysqli::thread_safe -- mysqli_thread_safe — Devuelve si la seguridad a nivel de hilos está dada o no

Descripción

Estilo por procedimientos

mysqli_thread_safe ( ) : bool

Indica si la biblioteca cliente está compilada con segurdid a nivel de hilos.

Valores devueltos

true si la biblioteca cliente es segura a nivel de hilos, false si no.


Inicia la recuperación de un conjunto de resultados

  • « mysqli::thread_safe
  • mysqli::$warning_count »
  • PHP Manual
  • mysqli
  • Inicia la recuperación de un conjunto de resultados

mysqli::use_result

mysqli_use_result

(PHP 5, PHP 7)

mysqli::use_result -- mysqli_use_result — Inicia la recuperación de un conjunto de resultados

Descripción

Estilo orientado a objetos

mysqli::use_result ( ) : mysqli_result

Estilo por procedimientos

mysqli_use_result ( mysqli $link ) : mysqli_result

Usada par iniciar la recuperación de un conjunto de resultados de la última consulta ejecutada usando la función mysqli_real_query() sobre la conexión a la base de datos.

Se debe llamar a esta función o a mysqli_store_result() antes de que los resultados de una consulta puedan ser recuperados, y una o la otra debe llamarse para prevenir que falle la siguiente consulta en esa conexión a la base de datos.

Nota:

La función mysqli_use_result() no transfiere el conjunto de resultados por completo desde la base de datos y por lo tanto no se pueden usar funciones como mysqli_data_seek() para mover una fila en particular dentro del conjunto. Para usar esta funcionalidad, el conjunto de resultados debe ser almacenado usando mysqli_store_result(). No se debería usar mysqli_use_result() si se realizan muchos procesos en el lado del cliente, ya que ocupará el servidor e impedirá que otros hilos actualicen cualquier table desde la cuales se están obteniendo los datos.

Valores devueltos

Devuelve un objeto de resultados no almacenado en buffer o false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de mysqli::use_result()

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* Comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta  = "SELECT CURRENT_USER();";
$consulta .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* ejecutar una multi consulta */
if ($mysqli->multi_query($consulta)) {
    do {
        /* primero almacenar el conjunto de resultados */
        if ($resultado = $mysqli->use_result()) {
            while ($fila = $resultado->fetch_row()) {
                printf("%s\n", $fila[0]);
            }
            $resultado->close();
        }
        /* imprimir un separador */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* Comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta  = "SELECT CURRENT_USER();";
$consulta .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* ejecutar una multi consulta */
if (mysqli_multi_query($enlace, $consulta)) {
    do {
        /* primero almacenar el conjunto de resultados */
        if ($resultado = mysqli_use_result($enlace)) {
            while ($fila = mysqli_fetch_row($resultado)) {
                printf("%s\n", $fila[0]);
            }
            mysqli_free_result($resultado);
        }
        /* imprimir un separador */
        if (mysqli_more_results($enlace)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($enlace));
}

/* close connection */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

mi_usuario@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Ver también

  • mysqli_real_query() - Ejecuta una consulta SQL
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta


Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado

  • « mysqli::use_result
  • mysqli_stmt »
  • PHP Manual
  • mysqli
  • Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado

mysqli::$warning_count

mysqli_warning_count

(PHP 5, PHP 7)

mysqli::$warning_count -- mysqli_warning_count — Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado

Descripción

Estilo orientado a objetos

int $mysqli->warning_count;

Estilo por procedimientos

mysqli_warning_count ( mysqli $link ) : int

Devuelve el número de mensajes de advertencia de la última consulta en la conexión a la base de datos.

Nota:

Para recuperar los mensajes de advertencia que puede utilizar el comando SQL SHOW WARNINGS [limit row_count].

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

Valores devueltos

Cantidad de mensajes de advertencia o cero si no hubo mensajes de advertencia

Ejemplos

Ejemplo #1 Ejemplo de $mysqli->warning_count

Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* a remarkable city in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$mysqli->query($query);

if ($mysqli->warning_count) {
    if ($result = $mysqli->query("SHOW WARNINGS")) {
        $row = $result->fetch_row();
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        $result->close();
    }
}

/* close connection */
$mysqli->close();
?>

Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* a remarkable long city name in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

mysqli_query($link, $query);

if (mysqli_warning_count($link)) {
    if ($result = mysqli_query($link, "SHOW WARNINGS")) {
        $row = mysqli_fetch_row($result);
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        mysqli_free_result($result);
    }
}

/* close connection */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Warning (1264): Data truncated for column 'Name' at row 1

Ver también

  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysqli_sqlstate() - Devuelve el error SQLSTATE de la operación de MySQL previa


La clase mysqli_stmt

(PHP 5, PHP 7)

Introducción

Representa una consulta preparada.

Sinopsis de la Clase

mysqli_stmt {
/* Propiedades */
int $affected_rows;
int $errno;
array $error_list;
string $error;
int $field_count;
int $insert_id;
int $num_rows;
int $param_count;
string $sqlstate;
/* Métodos */
__construct ( mysqli $link , string $query = ? )
attr_get ( int $attr ) : int
attr_set ( int $attr , int $mode ) : bool
bind_param ( string $types , mixed &$var1 , mixed &$... = ? ) : bool
bind_result ( mixed &$var1 , mixed &$... = ? ) : bool
close ( ) : bool
data_seek ( int $offset ) : void
execute ( ) : bool
fetch ( ) : bool
free_result ( ) : void
get_result ( ) : mysqli_result
get_warnings ( mysqli_stmt $stmt ) : object
prepare ( string $query ) : mixed
reset ( ) : bool
result_metadata ( ) : mysqli_result
send_long_data ( int $param_nr , string $data ) : bool
store_result ( ) : bool
}

Tabla de contenidos

  • mysqli_stmt::$affected_rows — Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada
  • mysqli_stmt::attr_get — Se utiliza para obtener el valor actual de un atributo de la sentencia
  • mysqli_stmt::attr_set — Se utiliza para modificar el comportamiento de una sentencia preparada
  • mysqli_stmt::bind_param — Agrega variables a una sentencia preparada como parámetros
  • mysqli_stmt::bind_result — Vincula variables a una sentencia preparada para el almacenamiento de resultados
  • mysqli_stmt::close — Cierra una sentencia preparada
  • mysqli_stmt::__construct — Construye un nuevo objeto mysqli_stmt
  • mysqli_stmt::data_seek — Busca una fila arbitraria en un conjunto de resultados de una sentencia
  • mysqli_stmt::$errno — Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt::$error_list — Devuelve una lista de errores de la última sentencia ejecutada
  • mysqli_stmt::$error — Devuelve una descripción en forma de string del último error de una sentencia
  • mysqli_stmt::execute — Ejecuta una consulta preparada
  • mysqli_stmt::fetch — Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_stmt::$field_count — Devuelve el número de campos de la sentencia dada
  • mysqli_stmt::free_result — Libera la memoria de los resultados almacenados del gestor de sentencia dado
  • mysqli_stmt::get_result — Obtiene un conjunto de resultados de una sentencia preparada
  • mysqli_stmt::get_warnings — Obtener los resultados de SHOW WARNINGS
  • mysqli_stmt::$insert_id — Obtener el ID generado en la operación INSERT anterior
  • mysqli_stmt::more_results — Comprobar si existen más resultados de una consulta de consultas múltiples
  • mysqli_stmt::next_result — Lee el siguiente resultado de una consulta múltiple
  • mysqli_stmt::$num_rows — Devuelve el número de filas de un conjunto de resultados de una sentencia
  • mysqli_stmt::$param_count — Devuelve el número de parámetros de la sentencia dada
  • mysqli_stmt::prepare — Preparar una sentencia SQL para su ejecución
  • mysqli_stmt::reset — Reinicia una sentencia preparada
  • mysqli_stmt::result_metadata — Devuelve los metadatos del conjunto de resultados de una sentencia preparada
  • mysqli_stmt::send_long_data — Enviar datos en bloques
  • mysqli_stmt::$sqlstate — Devuelve el error SQLSTATE de la operación de sentencia previa
  • mysqli_stmt::store_result — Transfiere un conjunto de resultados desde una sentencia preparada


Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada

  • « mysqli_stmt
  • mysqli_stmt::attr_get »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada

mysqli_stmt::$affected_rows

mysqli_stmt_affected_rows

(PHP 5, PHP 7)

mysqli_stmt::$affected_rows -- mysqli_stmt_affected_rows — Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada

Descripción

Estilo orientado a objetos

int $mysqli_stmt->affected_rows;

Estilo por procedimientos

mysqli_stmt_affected_rows ( mysqli_stmt $stmt ) : int

Devuelve el número de filas afectadas por una consulta INSERT, UPDATE, o DELETE.

Esta función sólo funciona con las consultas que actualizan una tabla. Con el fin de obtener el número de filas de una consulta SELECT, usar mysqli_stmt_num_rows() en su lugar.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Un entero mayor que cero indica el número de filas afectadas o recuperadas. Cero indica que no hubo registros actualizados para un sentencia UPDATE/DELETE, ninguna fila coincidio con la cláusula WHERE en la consulta o que ninguna consulta ha sido ejecutado. -1 Indica que la consulta ha devuelto un error. NULL indica un argumento no válido fue enviada a la función.

Nota:

Si el número de filas afectadas es mayor que el valor entero maximo de PHP, el número de filas afectadas se obtiene como una cadena.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_clave", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

/* crear tabla temporal */
$mysqli->query("CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* preparar sentencia */
if ($stmt = $mysqli->prepare($query)) {

    /* Agrega variable para marcador de posición */
    $code = 'A%';
    $stmt->bind_param("s", $code);

    /* ejecutar sentencia */
    $stmt->execute();

    printf("filas insertadas: %d\n", $stmt->affected_rows);

    /* cerrar sentencia */
    $stmt->close();
}

/* cerrar conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "mi_usuario", "my_clave", "world");

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

/* crear tabla temporal*/
mysqli_query($link, "CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* preparar sentencia */
if ($stmt = mysqli_prepare($link, $query)) {

    /* Agrega variable para marcador de posición */
    $code = 'A%';
    mysqli_stmt_bind_param($stmt, "s", $code);

    /* ejecutar sentencia */
    mysqli_stmt_execute($stmt);

    printf("filas insertadas: %d\n", mysqli_stmt_affected_rows($stmt));

    /* cerrar sentencia */
    mysqli_stmt_close($stmt);
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado del ejemplo sería:

filas insertadas: 17

Ver también

  • mysqli_stmt_num_rows() - Devuelve el número de filas de un conjunto de resultados de una sentencia
  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Se utiliza para obtener el valor actual de un atributo de la sentencia

  • « mysqli_stmt::$affected_rows
  • mysqli_stmt::attr_set »
  • PHP Manual
  • mysqli_stmt
  • Se utiliza para obtener el valor actual de un atributo de la sentencia

mysqli_stmt::attr_get

mysqli_stmt_attr_get

(PHP 5, PHP 7)

mysqli_stmt::attr_get -- mysqli_stmt_attr_get — Se utiliza para obtener el valor actual de un atributo de la sentencia

Descripción

Estilo orientado a objetos

mysqli_stmt::attr_get ( int $attr ) : int

Estilo por procedimientos

mysqli_stmt_attr_get ( mysqli_stmt $stmt , int $attr ) : int

Obtiene el valor actual de un atributo de la sentencia.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

attr

El atributo que desea obtener.

Valores devueltos

Devuelve false si el atributo no se encuentra, en caso contrario devuelve el valor del atributo.


Se utiliza para modificar el comportamiento de una sentencia preparada

  • « mysqli_stmt::attr_get
  • mysqli_stmt::bind_param »
  • PHP Manual
  • mysqli_stmt
  • Se utiliza para modificar el comportamiento de una sentencia preparada

mysqli_stmt::attr_set

mysqli_stmt_attr_set

(PHP 5, PHP 7)

mysqli_stmt::attr_set -- mysqli_stmt_attr_set — Se utiliza para modificar el comportamiento de una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::attr_set ( int $attr , int $mode ) : bool

Estilo por procedimientos

mysqli_stmt_attr_set ( mysqli_stmt $stmt , int $attr , int $mode ) : bool

Se utiliza para modificar el comportamiento de una sentencia preparada. Esta función puede ser llamada varias veces para establecer varios atributos.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

attr

El atributo que desea establecer. Puede tener uno de los siguientes valores:

Valores de atributos
Carácter | Descripción
MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH | Si se establece a true, mysqli_stmt_store_result() actualizará el valor de metadato de MYSQL_FIELD->max_length.
MYSQLI_STMT_ATTR_CURSOR_TYPE | Tipo de cursor para abrir la sentencia cuando mysqli_stmt_execute() se invoca. mode puede ser MYSQLI_CURSOR_TYPE_NO_CURSOR (por defecto) o MYSQLI_CURSOR_TYPE_READ_ONLY.
MYSQLI_STMT_ATTR_PREFETCH_ROWS | Número de filas a obtener de un servidor en un momento cuando se utiliza un cursor. mode puede estar en el rango de 1 al máximo valor de un entero sin signo. El valor predeterminado es 1.

Si usa la opción MYSQLI_STMT_ATTR_CURSOR_TYPE con MYSQLI_CURSOR_TYPE_READ_ONLY, un cursor es abierto para la sentencia cuando se invoca mysqli_stmt_execute(). Si ya hay un cursor abierto desde la llamada anterior de mysqli_stmt_execute(), se cierra el cursor antes de abrir uno nuevo. mysqli_stmt_reset() también cierra cualquier cursor abierto antes de preparar la sentencia para su re-ejecución. mysqli_stmt_free_result() cierra cualquier cursor abierto.

Si abre un cursor para una sentencia preparada, mysqli_stmt_store_result() es innecesario.

mode

El valor a asignar a este atributo.

Ver también

  • » Connector/MySQL mysql_stmt_attr_set()


Agrega variables a una sentencia preparada como parámetros

  • « mysqli_stmt::attr_set
  • mysqli_stmt::bind_result »
  • PHP Manual
  • mysqli_stmt
  • Agrega variables a una sentencia preparada como parámetros

mysqli_stmt::bind_param

mysqli_stmt_bind_param

(PHP 5, PHP 7)

mysqli_stmt::bind_param -- mysqli_stmt_bind_param — Agrega variables a una sentencia preparada como parámetros

Descripción

Estilo orientado a objetos

mysqli_stmt::bind_param ( string $types , mixed &$var1 , mixed &$... = ? ) : bool

Estilo por procedimientos

mysqli_stmt_bind_param ( mysqli_stmt $stmt , string $types , mixed &$var1 , mixed &$... = ? ) : bool

Enlaza variables para los marcadores de parámetros en la instrucción SQL que se envía a mysqli_prepare().

Nota:

Si el tamaño de los datos de una variable excede el tamaño máximo del paquete permitido (max_allowed_packet), usted tiene que especificar b en types y usar mysqli_stmt_send_long_data() para enviar los datos en paquetes.

Nota:

Debe de tener cuidado cuando use mysqli_stmt_bind_param() en conjunción con call_user_func_array(). Tenga en cuenta que mysqli_stmt_bind_param() requiere de parámetros que se pasan por referencia, mientras que call_user_func_array() puede aceptar como parámetro una lista de variables que pueden representar referencias o valores.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

types

Una cadena que contiene uno o más caracteres que especifican los tipos para el correspondiente enlazado de variables:

Especificación del tipo de caracteres
Carácter | Descripción
i | la variable correspondiente es de tipo entero
d | la variable correspondiente es de tipo double
s | la variable correspondiente es de tipo string
b | la variable correspondiente es un blob y se envía en paquetes

var1

El número de variables y la longitud de la cadena types debe coincidir con los parámetros en la sentencia.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'world');

/* verificar conexión */
if (mysqli_connect_errno()) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

$stmt = $mysqli->prepare("INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
$stmt->bind_param('sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* ejecuta sentencias prepradas */
$stmt->execute();

printf("%d Fila insertada.\n", $stmt->affected_rows);

/* cierra sentencia y conexión */
$stmt->close();

/* Limpia la tabla CountryLanguage */
$mysqli->query("DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Fila borrada.\n", $mysqli->affected_rows);

/* cierra la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'world');

/* verificar conexión */
if (!$link) {
    printf("Error de conexión: %s\n", mysqli_connect_error());
    exit();
}

$stmt = mysqli_prepare($link, "INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
mysqli_stmt_bind_param($stmt, 'sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* ejecuta sentencias preparadas */
mysqli_stmt_execute($stmt);

printf("%d Fila insertada.\n", mysqli_stmt_affected_rows($stmt));

/* cierra sentencia y conexión */
mysqli_stmt_close($stmt);

/* Limpia la tabla CountryLanguage */
mysqli_query($link, "DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Fila borrada.\n", mysqli_affected_rows($link));

/* cierra la conexión */
mysqli_close($link);
?>

El resultado del ejemplo sería:

1 Fila insertada.
1 Fila borrada.

Ver también

  • mysqli_stmt_bind_result() - Vincula variables a una sentencia preparada para el almacenamiento de resultados
  • mysqli_stmt_execute() - Ejecuta una consulta preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_send_long_data() - Enviar datos en bloques
  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia


Vincula variables a una sentencia preparada para el almacenamiento de resultados

  • « mysqli_stmt::bind_param
  • mysqli_stmt::close »
  • PHP Manual
  • mysqli_stmt
  • Vincula variables a una sentencia preparada para el almacenamiento de resultados

mysqli_stmt::bind_result

mysqli_stmt_bind_result

(PHP 5, PHP 7)

mysqli_stmt::bind_result -- mysqli_stmt_bind_result — Vincula variables a una sentencia preparada para el almacenamiento de resultados

Descripción

Estilo orientado a objetos

mysqli_stmt::bind_result ( mixed &$var1 , mixed &$... = ? ) : bool

Estilo por procedimientos

mysqli_stmt_bind_result ( mysqli_stmt $stmt , mixed &$var1 , mixed &$... = ? ) : bool

Vincula columnas del conjunto de resultados a variables.

Cuando se llama a mysqli_stmt_fetch() para obtener datos, el protocolo cliente/servidor de MySQL coloca los datos de las columnas vinculads en las variables especificadas por var1, ....

Nota:

Observe que todas las columnas deben ser vinculadas después de llamar a mysqli_stmt_execute() y antes de llamar a mysqli_stmt_fetch(). Dependiendo de los tipos de columna las variables pueden cambiar silenciosamente al tipo de PHP correspondiente.

Una columna puede ser vinculada o revinculada en cualquier momento, incluso después de que un conjunto de resultados haya sido parcialmente recuperado. La nueva vinculación toma efecto la siguiente vez que se llame a mysqli_stmt_fetch().

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

var1

La variable a vincular.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* sentencia preparada */
if ($sentencia = $mysqli->prepare("SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    $sentencia->execute();

    /* vincular variables a la sentencia preparada */
    $sentencia->bind_result($col1, $col2);

    /* obtener valores */
    while ($sentencia->fetch()) {
        printf("%s %s\n", $col1, $col2);
    }

    /* cerrar la sentencia */
    $sentencia->close();
}
/* cerrar la conexión */
$mysqli->close();

?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (!$enlace) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* sentencia preparada */
if ($sentencia = mysqli_prepare($enlace, "SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    mysqli_stmt_execute($sentencia);

    /* vincular variables a la sentencia preparada */
    mysqli_stmt_bind_result($sentencia, $col1, $col2);

    /* obtener valores */
    while (mysqli_stmt_fetch($sentencia)) {
        printf("%s %s\n", $col1, $col2);
    }

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

AFG Afghanistan
ALB Albania
DZA Algeria
ASM American Samoa
AND Andorra

Ver también

  • mysqli_stmt_get_result() - Obtiene un conjunto de resultados de una sentencia preparada
  • mysqli_stmt_bind_param() - Agrega variables a una sentencia preparada como parámetros
  • mysqli_stmt_execute() - Ejecuta una consulta preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_prepare() - Preparar una sentencia SQL para su ejecución
  • mysqli_stmt_init() - Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare
  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia


Cierra una sentencia preparada

  • « mysqli_stmt::bind_result
  • mysqli_stmt::__construct »
  • PHP Manual
  • mysqli_stmt
  • Cierra una sentencia preparada

mysqli_stmt::close

mysqli_stmt_close

(PHP 5, PHP 7)

mysqli_stmt::close -- mysqli_stmt_close — Cierra una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::close ( ) : bool

Estilo por procedimientos

mysqli_stmt_close ( mysqli_stmt $stmt ) : bool

Cierra una sentencia preparada. mysqli_stmt_close() también desasigna el gestor de sentencias. Si la sentencia actual tiene resultados pendientes o no leídos, esta función los cancelará, por lo que se podrá ejecutar la siguiente consulta.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Construye un nuevo objeto mysqli_stmt

  • « mysqli_stmt::close
  • mysqli_stmt::data_seek »
  • PHP Manual
  • mysqli_stmt
  • Construye un nuevo objeto mysqli_stmt

mysqli_stmt::__construct

(PHP 5, PHP 7)

mysqli_stmt::__construct — Construye un nuevo objeto mysqli_stmt

Descripción

mysqli_stmt::__construct ( mysqli $link , string $query = ? )

Este método construye un nuevo objeto mysqli_stmt.

Nota:

En general, se debería utilizar mysqli_prepare() o mysqli_stmt_init() para crear un objeto mysqli_stmt, en lugar de instanciar directamente el objeto con new mysqli_stmt. Este método (y la capacidad de instanciar directamente objetos mysqli_stmt) podrían quedar obsoletos y ser eliminados en el futuro.

Parámetros

link

Sólo estilo por procediminetos: Un identificador de enlace devuelto por mysqli_connect() o mysqli_init()

query

La consulta, como un string. Si se omite este parámetro, el constructor se comporta de forma idéntica a mysqli_stmt_init(); si se proporciona, se comporta como mysqli_prepare().

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_init() - Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare


Busca una fila arbitraria en un conjunto de resultados de una sentencia

  • « mysqli_stmt::__construct
  • mysqli_stmt::$errno »
  • PHP Manual
  • mysqli_stmt
  • Busca una fila arbitraria en un conjunto de resultados de una sentencia

mysqli_stmt::data_seek

mysqli_stmt_data_seek

(PHP 5, PHP 7)

mysqli_stmt::data_seek -- mysqli_stmt_data_seek — Busca una fila arbitraria en un conjunto de resultados de una sentencia

Descripción

Estilo orientado a objetos

mysqli_stmt::data_seek ( int $offset ) : void

Estilo por procedimientos

mysqli_stmt_data_seek ( mysqli_stmt $stmt , int $offset ) : void

Busca un puntero de resultados arbitrario en un conjunto de resultados de una sentencia.

mysqli_stmt_store_result() debe llamarse antes de mysqli_stmt_data_seek().

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

offset

Debe estar entre cero y el número total de filas menos 1 (0.. mysqli_stmt_num_rows() - 1).

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* execute consulta */
    $sentencia->execute();

    /* vincular las varilbes al resultado */
    $sentencia->bind_result($nombre, $código);

    /* almacenar el resultado */
    $sentencia->store_result();

    /* buscar la fila nº 400 */
    $sentencia->data_seek(399);

    /* obtener los valores */
    $sentencia->fetch();

    printf ("Ciudad: %s  Countrycode: %s\n", $nombre, $código);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* execute consulta */
    mysqli_stmt_execute($sentencia);

    /* vincular las varilbes al resultado */
    mysqli_stmt_bind_result($sentencia, $nombre, $código);

    /* almacenar el resultado */
    mysqli_stmt_store_result($sentencia);

    /* buscar la fila nº 400 */
    mysqli_stmt_data_seek($sentencia, 399);

    /* obtener los valores */
    mysqli_stmt_fetch($sentencia);

    printf ("Ciudad: %s  Countrycode: %s\n", $nombre, $código);

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Ciudad: Benin City  Countrycode: NGA

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Devuelve el código de error de la llamada de la sentencia más reciente

  • « mysqli_stmt::data_seek
  • mysqli_stmt::$error_list »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el código de error de la llamada de la sentencia más reciente

mysqli_stmt::$errno

mysqli_stmt_errno

(PHP 5, PHP 7)

mysqli_stmt::$errno -- mysqli_stmt_errno — Devuelve el código de error de la llamada de la sentencia más reciente

Descripción

Estilo orientado a objetos

int $mysqli_stmt->errno;

Estilo por procedimientos

mysqli_stmt_errno ( mysqli_stmt $stmt ) : int

Devuelve el código de error de la función de la sentencia invocada más recientemente que tuvo éxito o falló.

Los números de los mensajes de error del cliente están listados en el fichero de cabecera errmsg.h de MySQL, los números de los mensajes de error del servidor están listados en mysqld_error.h. En la distribución original de MySQL se puede encontrar una lista completa de los mensajes de error y los números de los errores en el fichero Docs/mysqld_error.txt.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Un valor de código de error. Cero significa que no se encontraron errores.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* eliminar la tabla */
    $mysqli->query("DROP TABLE myCountry");

    /* ejecutar la consulta */
    $sentencia->execute();

    printf("Error: %d.\n", $sentencia->errno);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TABLE myCountry LIKE Country");
mysqli_query($enlace, "INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* eliminar la tabla */
    mysqli_query($enlace, "DROP TABLE myCountry");

    /* ejecutar la consulta */
    mysqli_stmt_execute($sentencia);

    printf("Error: %d.\n", mysqli_stmt_errno($sentencia));

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error: 1146.

Ver también

  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia
  • mysqli_stmt_sqlstate() - Devuelve el error SQLSTATE de la operación de sentencia previa


Devuelve una lista de errores de la última sentencia ejecutada

  • « mysqli_stmt::$errno
  • mysqli_stmt::$error »
  • PHP Manual
  • mysqli_stmt
  • Devuelve una lista de errores de la última sentencia ejecutada

mysqli_stmt::$error_list

mysqli_stmt_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli_stmt::$error_list -- mysqli_stmt_error_list — Devuelve una lista de errores de la última sentencia ejecutada

Descripción

Estilo orientado a objetos

array $mysqli_stmt->error_list;

Estilo por procedimientos

mysqli_stmt_error_list ( mysqli_stmt $stmt ) : array

Devuelve un array de errores de la función de la sentencia invocada más receientemente que tuvo éxito o falló.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Una lista de errores, cada uno como un array asociativo que contiene el errno, error, y sqlstate.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* eliminar la tabla */
    $mysqli->query("DROP TABLE myCountry");

    /* ejecutar la consulta */
    $sentencia->execute();

    echo "Error:\n";
    print_r($sentencia->error_list);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TABLE myCountry LIKE Country");
mysqli_query($enlace, "INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* eliminar la tabla */
    mysqli_query($enlace, "DROP TABLE myCountry");

    /* ejecutar la consulta */
    mysqli_stmt_execute($sentencia);

    echo "Error:\n";
    print_r(mysql_stmt_error_list($sentencia));

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Array
(
    [0] => Array
        (
            [errno] => 1146
            [sqlstate] => 42S02
            [error] => Table 'world.myCountry' doesn't exist
        )

)

Ver también

  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia
  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_sqlstate() - Devuelve el error SQLSTATE de la operación de sentencia previa


Devuelve una descripción en forma de string del último error de una sentencia

  • « mysqli_stmt::$error_list
  • mysqli_stmt::execute »
  • PHP Manual
  • mysqli_stmt
  • Devuelve una descripción en forma de string del último error de una sentencia

mysqli_stmt::$error

mysqli_stmt_error

(PHP 5, PHP 7)

mysqli_stmt::$error -- mysqli_stmt_error — Devuelve una descripción en forma de string del último error de una sentencia

Descripción

Estilo orientado a objetos

string $mysqli_stmt->error;

Estilo por procedimientos

mysqli_stmt_error ( mysqli_stmt $stmt ) : string

Devuelve un string que contiene el mensaje de error de la función de la sentencia invocada más receientemente que tuvo éxito o falló.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Un string que describe el error. Un string vacío si no ocurrió ningún error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* eliminar la tabla */
    $mysqli->query("DROP TABLE myCountry");

    /* ejecutar la sentencia */
    $sentencia->execute();

    printf("Error: %s.\n", $sentencia->error);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TABLE myCountry LIKE Country");
mysqli_query($enlace, "INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* eliminar la tabla */
    mysqli_query($enlace, "DROP TABLE myCountry");

    /* ejecutar la sentencia */
    mysqli_stmt_execute($sentencia);

    printf("Error: %s.\n", mysqli_stmt_error($sentencia));

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error: Table 'world.myCountry' doesn't exist.

Ver también

  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_sqlstate() - Devuelve el error SQLSTATE de la operación de sentencia previa


Ejecuta una consulta preparada

  • « mysqli_stmt::$error
  • mysqli_stmt::fetch »
  • PHP Manual
  • mysqli_stmt
  • Ejecuta una consulta preparada

mysqli_stmt::execute

mysqli_stmt_execute

(PHP 5, PHP 7)

mysqli_stmt::execute -- mysqli_stmt_execute — Ejecuta una consulta preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::execute ( ) : bool

Estilo por procedimientos

mysqli_stmt_execute ( mysqli_stmt $stmt ) : bool

Ejecuta una consulta que ha sido previamente preparada usando la función mysqli_prepare(). Cuando se ejecutó cualquier marcador de parámetro que existe, será automáticamente reemplazado con los datos apropiados.

Si la sentencia es UPDATE, DELETE, o INSERT, se puede determinar el número total de filas afectadas usando le función mysqli_stmt_affected_rows(). Asimismo, si la consulta produce un conjunto de resultados se usa la función mysqli_stmt_fetch().

Nota:

Al usar mysqli_stmt_execute(), se debe usar la función mysqli_stmt_fetch() para obtener los datos antes de realizar cualquier consulta adicional.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* Preparar una sentencia INSERT */
$consulta = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$sentencia = $mysqli->prepare($consulta);

$sentencia->bind_param("sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Ejecutar la sentencia */
$sentencia->execute();

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Ejecutar la sentencia */
$sentencia->execute();

/* cerrar la sentencia */
$sentencia->close();

/* recuperar todas las filas de myCity */
$consulta = "SELECT Name, CountryCode, District FROM myCity";
if ($resultado = $mysqli->query($consulta)) {
    while ($fila = $resultado->fetch_row()) {
        printf("%s (%s,%s)\n", $fila[0], $fila[1], $fila[2]);
    }
    /* liberar el conjunto de resultados */
    $resultado->close();
}

/* eliminar la tabla */
$mysqli->query("DROP TABLE myCity");

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TABLE myCity LIKE City");

/* Preparar una sentencia INSERT */
$consulta = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$sentencia = mysqli_prepare($enlace, $consulta);

mysqli_stmt_bind_param($sentencia, "sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Ejecutar la sentencia */
mysqli_stmt_execute($sentencia);

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Ejecutar la sentencia */
mysqli_stmt_execute($sentencia);

/* cerrar la sentencia */
mysqli_stmt_close($sentencia);

/* recuperar todas las filas de myCity */
$consulta = "SELECT Name, CountryCode, District FROM myCity";
if ($resultado = mysqli_query($enlace, $consulta)) {
    while ($fila = mysqli_fetch_row($resultado)) {
        printf("%s (%s,%s)\n", $fila[0], $fila[1], $fila[2]);
    }
    /* liberar el conjunto de resultados */
    mysqli_free_result($resultado);
}

/* eliminar la tabla */
mysqli_query($enlace, "DROP TABLE myCity");

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Stuttgart (DEU,Baden-Wuerttemberg)
Bordeaux (FRA,Aquitaine)

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_bind_param() - Agrega variables a una sentencia preparada como parámetros
  • mysqli_stmt_get_result() - Obtiene un conjunto de resultados de una sentencia preparada


Obtiene los resultados de una sentencia preparadas en las variables vinculadas

  • « mysqli_stmt::execute
  • mysqli_stmt::$field_count »
  • PHP Manual
  • mysqli_stmt
  • Obtiene los resultados de una sentencia preparadas en las variables vinculadas

mysqli_stmt::fetch

mysqli_stmt_fetch

(PHP 5, PHP 7)

mysqli_stmt::fetch -- mysqli_stmt_fetch — Obtiene los resultados de una sentencia preparadas en las variables vinculadas

Descripción

Estilo orientado a objetos

mysqli_stmt::fetch ( ) : bool

Estilo por procedimientos

mysqli_stmt_fetch ( mysqli_stmt $stmt ) : bool

Obtiene los resultados de una sentencia preparadas en las variables vinculadas mediante mysqli_stmt_bind_result().

Nota:

Observe que todas las columnas deben estar vinculadas por la aplicación antes de llamar a mysqli_stmt_fetch().

Nota:

Los datos son transferidos sin almacenarlos en buffer sin llamar a mysqli_stmt_store_result(), la cual puede disminuir el rendimiento (pero reduce el coste de memoria).

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Valores devueltos
Valor | Descripción
true | Éxito. Los datos se han obtenido
false | Ocurrió un error
null | No existen más filas/datos u ocurrió un truncamiento de los datos

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($sentencia = $mysqli->prepare($consulta)) {

    /* ejecutar la sentencia */
    $sentencia->execute();

    /* vincular las variables de resultados */
    $sentencia->bind_result($nombre, $código);

    /* obtener los valores */
    while ($sentencia->fetch()) {
        printf ("%s (%s)\n", $nombre, $código);
    }

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($sentencia = mysqli_prepare($link, $consulta)) {

    /* ejecutar la sentencia */
    mysqli_stmt_execute($sentencia);

    /* vincular las variables de resultados */
    mysqli_stmt_bind_result($sentencia, $nombre, $código);

    /* obtener los valores */
    while (mysqli_stmt_fetch($sentencia)) {
        printf ("%s (%s)\n", $nombre, $código);
    }

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Rockford (USA)
Tallahassee (USA)
Salinas (USA)
Santa Clarita (USA)
Springfield (USA)

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia
  • mysqli_stmt_bind_result() - Vincula variables a una sentencia preparada para el almacenamiento de resultados


Devuelve el número de campos de la sentencia dada

  • « mysqli_stmt::fetch
  • mysqli_stmt::free_result »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el número de campos de la sentencia dada

mysqli_stmt::$field_count

mysqli_stmt_field_count

(PHP 5, PHP 7)

mysqli_stmt::$field_count -- mysqli_stmt_field_count — Devuelve el número de campos de la sentencia dada

Descripción

Estilo orientado a objetos

int $mysqli_stmt->field_count;

Estilo por procedimientos

mysqli_stmt_field_count ( mysqli_stmt $stmt ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Libera la memoria de los resultados almacenados del gestor de sentencia dado

  • « mysqli_stmt::$field_count
  • mysqli_stmt::get_result »
  • PHP Manual
  • mysqli_stmt
  • Libera la memoria de los resultados almacenados del gestor de sentencia dado

mysqli_stmt::free_result

mysqli_stmt_free_result

(PHP 5, PHP 7)

mysqli_stmt::free_result -- mysqli_stmt_free_result — Libera la memoria de los resultados almacenados del gestor de sentencia dado

Descripción

Estilo orientado a objetos

mysqli_stmt::free_result ( ) : void

Estilo por procedimientos

mysqli_stmt_free_result ( mysqli_stmt $stmt ) : void

Libera la memoria de los resultados asociados con la sentencia, la cual fue asignada por mysqli_stmt_store_result().

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

No devuelve ningún valor.

Ver también

  • mysqli_stmt_store_result() - Transfiere un conjunto de resultados desde una sentencia preparada


Obtiene un conjunto de resultados de una sentencia preparada

  • « mysqli_stmt::free_result
  • mysqli_stmt::get_warnings »
  • PHP Manual
  • mysqli_stmt
  • Obtiene un conjunto de resultados de una sentencia preparada

mysqli_stmt::get_result

mysqli_stmt_get_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::get_result -- mysqli_stmt_get_result — Obtiene un conjunto de resultados de una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::get_result ( ) : mysqli_result

Estilo por procedimientos

mysqli_stmt_get_result ( mysqli_stmt $stmt ) : mysqli_result

Es llamada para devolver un conjunto de resultados de una consulta de sentencia preparada.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve un conjunto de resultados para consultas SELECT select, o false para otras consultas DML o en caso de fallo. La función mysqli_errno() se puede emplear para distinguir entre dos tipos de fallo.

Solo Controlador Nativo de MySQL

Disponible sólo con mysqlnd.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

$mysqli = new mysqli("127.0.0.1", "usuario", "contraseña", "world");

if($mysqli->connect_error)
{
    die("$mysqli->connect_errno: $mysqli->connect_error");
}

$consulta = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$sentencia = $mysqli->stmt_init();
if(!$sentencia->prepare($consulta))
{
    print "Falló la preparación de la sentencia\n";
}
else
{
    $sentencia->bind_param("s", $continente);

    $array_continentes = array('Europe','Africa','Asia','North America');

    foreach($array_continentes as $continente)
    {
        $sentencia->execute();
        $resultado = $sentencia->get_result();
        while ($fila = $resultado->fetch_array(MYSQLI_NUM))
        {
            foreach ($fila as $f)
            {
                print "$f ";
            }
            print "\n";
        }
    }
}

$sentencia->close();
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php

$enlace = mysqli_connect("127.0.0.1", "usuario", "contraseña", "world");

if (!$enlace)
{
    $error = mysqli_connect_error();
    $errno = mysqli_connect_errno();
    print "$errno: $error\n";
    exit();
}

$consulta = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$sentencia = mysqli_stmt_init($enlace);
if(!mysqli_stmt_prepare($sentencia, $consulta))
{
    print "Falló la preparación de la sentencia\n";
}
else
{
    mysqli_stmt_bind_param($stmt, "s", $continente);

    $array_continentes = array('Europe','Africa','Asia','North America');

    foreach($array_continentes as $continente)
    {
        mysqli_stmt_execute($sentencia);
        $resultado = mysqli_stmt_get_result($sentencia);
        while ($fila = mysqli_fetch_array($resultado, MYSQLI_NUM))
        {
            foreach ($fila as $f)
            {
                print "$f ";
            }
            print "\n";
        }
    }
}
mysqli_stmt_close($sentencia);
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Albania 3401200 Europe
Algeria 31471000 Africa
Afghanistan 22720000 Asia
Anguilla 8000 North America

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_result_metadata() - Devuelve los metadatos del conjunto de resultados de una sentencia preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_stmt_store_result() - Transfiere un conjunto de resultados desde una sentencia preparada
  • mysqli_errno() - Devuelve el código del error de la última función llamada


Obtener los resultados de SHOW WARNINGS

  • « mysqli_stmt::get_result
  • mysqli_stmt::$insert_id »
  • PHP Manual
  • mysqli_stmt
  • Obtener los resultados de SHOW WARNINGS

mysqli_stmt::get_warnings

mysqli_stmt_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli_stmt::get_warnings -- mysqli_stmt_get_warnings — Obtener los resultados de SHOW WARNINGS

Descripción

Estilo orientado a objetos

mysqli_stmt::get_warnings ( mysqli_stmt $stmt ) : object

Estilo por procedimientos

mysqli_stmt_get_warnings ( mysqli_stmt $stmt ) : object
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Obtener el ID generado en la operación INSERT anterior

  • « mysqli_stmt::get_warnings
  • mysqli_stmt::more_results »
  • PHP Manual
  • mysqli_stmt
  • Obtener el ID generado en la operación INSERT anterior

mysqli_stmt::$insert_id

mysqli_stmt_insert_id

(PHP 5, PHP 7)

mysqli_stmt::$insert_id -- mysqli_stmt_insert_id — Obtener el ID generado en la operación INSERT anterior

Descripción

Estilo orientado a objetos

int $mysqli_stmt->insert_id;

Estilo por procedimientos

mysqli_stmt_insert_id ( mysqli_stmt $stmt ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Comprobar si existen más resultados de una consulta de consultas múltiples

  • « mysqli_stmt::$insert_id
  • mysqli_stmt::next_result »
  • PHP Manual
  • mysqli_stmt
  • Comprobar si existen más resultados de una consulta de consultas múltiples

mysqli_stmt::more_results

mysqli_stmt_more_results

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::more_results -- mysqli_stmt_more_results — Comprobar si existen más resultados de una consulta de consultas múltiples

Descripción

Estilo orientado a objetos (method):

public mysqli_stmt::more_results ( ) : bool

Estilo por procedimientos:

mysqli_stmt_more_results ( mysql_stmt $stmt ) : bool

Comprueba si existen más resultados de una consulta de múltiples consultas.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true si existen más resultados, de lo contrario false.

Solo Controlador Nativo de MySQL

Disponible sólo con mysqlnd.

Ver también

  • mysqli_stmt::next_result() - Lee el siguiente resultado de una consulta múltiple
  • mysqli::multi_query() - Realiza una consulta a la base de datos


Lee el siguiente resultado de una consulta múltiple

  • « mysqli_stmt::more_results
  • mysqli_stmt::$num_rows »
  • PHP Manual
  • mysqli_stmt
  • Lee el siguiente resultado de una consulta múltiple

mysqli_stmt::next_result

mysqli_stmt_next_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::next_result -- mysqli_stmt_next_result — Lee el siguiente resultado de una consulta múltiple

Descripción

Estilo orientado a objetos (method):

public mysqli_stmt::next_result ( ) : bool

Estilo por procedimientos:

mysqli_stmt_next_result ( mysql_stmt $stmt ) : bool

Lee el siguiente resultado de una consulta múltiple.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_STRICT si no existe un conjunto de resultados, y sugiere el uso de mysqli_stmt::more_results() en estos casos, antes de llamar a mysqli_stmt::next_result().

Solo Controlador Nativo de MySQL

Disponible sólo con mysqlnd.

Ver también

  • mysqli_stmt::more_results() - Comprobar si existen más resultados de una consulta de consultas múltiples
  • mysqli::multi_query() - Realiza una consulta a la base de datos


Devuelve el número de filas de un conjunto de resultados de una sentencia

  • « mysqli_stmt::next_result
  • mysqli_stmt::$param_count »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el número de filas de un conjunto de resultados de una sentencia

mysqli_stmt::$num_rows

mysqli_stmt_num_rows

(PHP 5, PHP 7)

mysqli_stmt::$num_rows -- mysqli_stmt_num_rows — Devuelve el número de filas de un conjunto de resultados de una sentencia

Descripción

Estilo orientado a objetos

int $mysqli_stmt->num_rows;

Estilo por procedimientos

mysqli_stmt_num_rows ( mysqli_stmt $stmt ) : int

Devuelve el número de filas de un conjunto de resultados. El uso de mysqli_stmt_num_rows() depende de si se utiliza mysqli_stmt_store_result() para almacenar en buffer el conjunto de resultados completo en el gestor de sentencia.

Si se usa mysqli_stmt_store_result(), mysqli_stmt_num_rows() puede llamarse inmediatamente.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Un valor integer que representa el número de filas del conjunto de resultados.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* ejecutar la consulta */
    $sentencia->execute();

    /* almacenar el resultado */
    $sentencia->store_result();

    printf("Número de filas: %d.\n", $sentencia->num_rows);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* ejecutar la consulta */
    mysqli_stmt_execute($sentencia);

    /* almacenar el resultado */
    mysqli_stmt_store_result($sentencia);

    printf("Número de filas: %d.\n", mysqli_stmt_num_rows($sentencia));

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Número de filas: 20.

Ver también

  • mysqli_stmt_affected_rows() - Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada
  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_store_result() - Transfiere un conjunto de resultados desde una sentencia preparada


Devuelve el número de parámetros de la sentencia dada

  • « mysqli_stmt::$num_rows
  • mysqli_stmt::prepare »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el número de parámetros de la sentencia dada

mysqli_stmt::$param_count

mysqli_stmt_param_count

(PHP 5, PHP 7)

mysqli_stmt::$param_count -- mysqli_stmt_param_count — Devuelve el número de parámetros de la sentencia dada

Descripción

Estilo orientado a objetos

int $mysqli_stmt->param_count;

Estilo por procedimientos

mysqli_stmt_param_count ( mysqli_stmt $stmt ) : int

Devuelve el número de marcadores de parámetros presentes en la sentencia preparada.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve un valor integer que represetna el número de parámetros.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

if ($sentencia = $mysqli->prepare("SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marcador = $sentencia->param_count;
    printf("La sentencia tiene %d marcadores.\n", $marcador);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

if ($sentencia = mysqli_prepare($enlace, "SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marcador = mysqli_stmt_param_count($sentencia);
    printf("La sentencia tiene %d marcadores.\n", $marcador);

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

La setencia tiene 2 marcadores.

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Preparar una sentencia SQL para su ejecución

  • « mysqli_stmt::$param_count
  • mysqli_stmt::reset »
  • PHP Manual
  • mysqli_stmt
  • Preparar una sentencia SQL para su ejecución

mysqli_stmt::prepare

mysqli_stmt_prepare

(PHP 5, PHP 7)

mysqli_stmt::prepare -- mysqli_stmt_prepare — Preparar una sentencia SQL para su ejecución

Descripción

Estilo orientado a objetos

mysqli_stmt::prepare ( string $query ) : mixed

Estilo por procedimientos

mysqli_stmt_prepare ( mysqli_stmt $stmt , string $query ) : bool

Prepara una consulta the SQL apuntada por la consulta de cadena terminada en null.

Los marcadores de parámetros deben estar vinculados a las variables de la apliación usando mysqli_stmt_bind_param() y/o mysqli_stmt_bind_result() antes de ejecutar la sentencia u obtener filas.

Nota:

En el caso de que se pase una sentencia a mysqli_stmt_prepare() que sea más grande que max_allowed_packet del servidor, los códigos de error devueltos serán diferentes, dependiendo de si se usa el Controlador Nativo de MysQL (mysqlnd) o la biblioteca Cliente de MySQL (libmysqlclient). El comportamiento es como sigue:

  • mysqlnd en Linux devuelve un código de error 1153. El mensaje de error significa obtenido un paquete mas grande que max_allowed_packet bytes.

  • mysqlnd en Windows devuelve un código de error 2006. Este mensaje de error significa el servidor se ha ido.

  • libmysqlclient en todas las plataformas devuelve un código de error 2006. Este mensaje de error significa el servidor se ha ido.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

query

La consulta, como una cadena. Debe consistir en una sentencia SQL única.

Se puede incluir uno o más marcadores de parámetros en la senetencia SQL embebiendo el carácter de signo de interrogación (?) en la posición apropiada.

Nota:

No se debería añadir un punto y coma terminal o \g a la sentencia.

Nota:

Los marcadores únicamente son legales en ciertos lugares de las sentencias SQL. Por ejemplo, están permitidos en la lista de VALUES() de una sentencia INSERT (para especificar los valores de las columnas de una fila), o en una comparación en una cláusula WHERE para especificar un valor de comparación.

Sin embargo, no están permitidos en identificadores (como nombres de tablas o columnas), en la lista de selección que nombra a las columnas a ser devueltas por una sentencia SELECT), o para especificar ambos operandos de un operador binario como signo igual =. La última restricción es necesaria debido a que sería imposible determinar el tipo de parámetro. En general, los parámetros son legales únicamente en sentencias de Lenguaje de Manipulación de Datos (DML), y no en sentencias de Lenguaje de Definición de Datos (DDL).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$ciudad = "Amersfoort";

/* crear una sentencia preparada */
$sentencia =  $mysqli->stmt_init();
if ($sentencia->prepare("SELECT District FROM City WHERE Name=?")) {

    /* vincular los parámetros para los marcadores */
    $sentencia->bind_param("s", $ciudad);

    /* ejecutar la consulta */
    $sentencia->execute();

    /* vincular las variables de resultados */
    $sentencia->bind_result($distrito);

    /* obtener el valor */
    $sentencia->fetch();

    printf("%s está en el distrito de %s\n", $ciudad, $distrito);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "my_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$ciudad = "Amersfoort";

/* crear una sentencia preparada */
$sentencia = mysqli_stmt_init($enlace);
if (mysqli_stmt_prepare($sentencia, 'SELECT District FROM City WHERE Name=?')) {

    /* vincular los parámetros para los marcadores */
    mysqli_stmt_bind_param($sentencia, "s", $ciudad);

    /* ejecutar la consulta */
    mysqli_stmt_execute($sentencia);

    /* vincular las variables de resultados */
    mysqli_stmt_bind_result($sentencia, $distrito);

    /* obtener el valor */
    mysqli_stmt_fetch($sentencia);

    printf("%s está en el distrito de %s\n", $ciudad, $distrito);

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Amersfoort está en el distrito de Utrecht

Ver también

  • mysqli_stmt_init() - Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare
  • mysqli_stmt_execute() - Ejecuta una consulta preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
  • mysqli_stmt_bind_param() - Agrega variables a una sentencia preparada como parámetros
  • mysqli_stmt_bind_result() - Vincula variables a una sentencia preparada para el almacenamiento de resultados
  • mysqli_stmt_get_result() - Obtiene un conjunto de resultados de una sentencia preparada
  • mysqli_stmt_close() - Cierra una sentencia preparada


Reinicia una sentencia preparada

  • « mysqli_stmt::prepare
  • mysqli_stmt::result_metadata »
  • PHP Manual
  • mysqli_stmt
  • Reinicia una sentencia preparada

mysqli_stmt::reset

mysqli_stmt_reset

(PHP 5, PHP 7)

mysqli_stmt::reset -- mysqli_stmt_reset — Reinicia una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::reset ( ) : bool

Estilo por procedimientos

mysqli_stmt_reset ( mysqli_stmt $stmt ) : bool

Reinicia una sentencia preparada en el cliente y servidor para consignarla después de prepararla.

Reinicia la sentencia en el servidor, los datos enviados usando mysqli_stmt_send_long_data(), los conjuntos de resultados no almacenados en buffer, y los errores actuales. No limpia los vínculos o los conjuntos de resultados. Los conjunto de resultados alacenados en buffer serían limpiados al ejecutar la sentencia preparada (o al cerrarla).

Para preparar una sentencia con otra consulta use la función mysqli_stmt_prepare().

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Devuelve los metadatos del conjunto de resultados de una sentencia preparada

  • « mysqli_stmt::reset
  • mysqli_stmt::send_long_data »
  • PHP Manual
  • mysqli_stmt
  • Devuelve los metadatos del conjunto de resultados de una sentencia preparada

mysqli_stmt::result_metadata

mysqli_stmt_result_metadata

(PHP 5, PHP 7)

mysqli_stmt::result_metadata -- mysqli_stmt_result_metadata — Devuelve los metadatos del conjunto de resultados de una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::result_metadata ( ) : mysqli_result

Estilo por procedimientos

mysqli_stmt_result_metadata ( mysqli_stmt $stmt ) : mysqli_result

Si una sentencia pasada a mysqli_prepare() produce un conjunto de resultados, mysqli_stmt_result_metadata() devolverá un objeto de resultados que puede usarse para procesar metainformación como el número total de campos e información de campo individual.

Nota:

Este puntero del conjunto de resultados puede ser pasado como parámetro a cualquier función basada en campos que procese los metadatos del conjunto de resultados, tales como:

  • mysqli_num_fields()

  • mysqli_fetch_field()

  • mysqli_fetch_field_direct()

  • mysqli_fetch_fields()

  • mysqli_field_count()

  • mysqli_field_seek()

  • mysqli_field_tell()

  • mysqli_free_result()

La estructura del conjunto de resultados debería ser liberada cuando se termine con ella, lo que se puede hacer pasándose la a mysqli_free_result()

Nota:

El cojunto de resultados devuelto por mysqli_stmt_result_metadata() contiene únicamente metadatos. No contiene ningún resultado de filas. Las filas se obtienen usando el gestor de sentencias con mysqli_stmt_fetch().

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve un objeto de resultados o false si ocurrió un error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "test");

$mysqli->query("DROP TABLE IF EXISTS friends");
$mysqli->query("CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query("INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$sentencia = $mysqli->prepare("SELECT id, name FROM friends");
$sentencia->execute();

/* obtener el conjunto de resultados para los metadatos */
$resultado = $sentencia->result_metadata();

/* recuperar la información de campo de los metadatos del conjunto de resultados */
$campo = $resultado->fetch_field();

printf("Nombre del campo: %s\n", $campo->name);

/* cerrar el conjunto de resultados */
$resultado->close();

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "test");

mysqli_query($enlace, "DROP TABLE IF EXISTS friends");
mysqli_query($enlace, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($enlace, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$sentencia = mysqli_prepare($enlace, "SELECT id, name FROM friends");
mysqli_stmt_execute($sentencia);

/* obtener el conjunto de resultados para los metadatos */
$resultado = mysqli_stmt_result_metadata($sentencia);

/* recuperar la información de campo de los metadatos del conjunto de resultados */
$campo = mysqli_fetch_field($resultado);

printf("Nombre del campo: %s\n", $campo->name);

/* cerrar el conjunto de resultados */
mysqli_free_result($resultado);

/* cerrar la conexión */
mysqli_close($enlace);
?>

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_free_result() - Libera la memoria asociada a un resultado


Enviar datos en bloques

  • « mysqli_stmt::result_metadata
  • mysqli_stmt::$sqlstate »
  • PHP Manual
  • mysqli_stmt
  • Enviar datos en bloques

mysqli_stmt::send_long_data

mysqli_stmt_send_long_data

(PHP 5, PHP 7)

mysqli_stmt::send_long_data -- mysqli_stmt_send_long_data — Enviar datos en bloques

Descripción

Estilo orientado a objetos

mysqli_stmt::send_long_data ( int $param_nr , string $data ) : bool

Estilo por procedimientos

mysqli_stmt_send_long_data ( mysqli_stmt $stmt , int $param_nr , string $data ) : bool

Permite el envío de datos de parámetros en piezas al servidor (o trozos), p.ej. si el tamaño de un blob excede el tamaño de max_allowed_packet. Esta función puede llamarse múltiples veces para enviar las partes de un valor de datos de carácter o binarios de una columna, la cual debe ser del tipo de datos TEXT o BLOB.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

param_nr

Indica qué parámetro asociar con los datos. Los parámetros son numerados comenzando por el 0.

data

Una cadena que contiene los datos a enviar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$sentencia = $mysqli->prepare("INSERT INTO messages (message) VALUES (?)");
$null = NULL;
$sentencia->bind_param("b", $null);
$fp = fopen("messages.txt", "r");
while (!feof($fp)) {
    $sentencia->send_long_data(0, fread($fp, 8192));
}
fclose($fp);
$sentencia->execute();
?>

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_bind_param() - Agrega variables a una sentencia preparada como parámetros


Devuelve el error SQLSTATE de la operación de sentencia previa

  • « mysqli_stmt::send_long_data
  • mysqli_stmt::store_result »
  • PHP Manual
  • mysqli_stmt
  • Devuelve el error SQLSTATE de la operación de sentencia previa

mysqli_stmt::$sqlstate

mysqli_stmt_sqlstate

(PHP 5, PHP 7)

mysqli_stmt::$sqlstate -- mysqli_stmt_sqlstate — Devuelve el error SQLSTATE de la operación de sentencia previa

Descripción

Estilo orientado a objetos

string $mysqli_stmt->sqlstate;

Estilo por procedimientos

mysqli_stmt_sqlstate ( mysqli_stmt $stmt ) : string

Devuelve una cadena que contiene el código de error SQLSTATE de la función más recientemente invocada de sentencia preparada que tuvo éxito o falló. El código de error consiste en cinco caracteres. '00000' significa sin error. Los valores están especificados por ANSI SQL y ODBC. Para una lista de valores posibles, véase » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve una cadena que contiene el código de error SQLSTATE del último error. El código de error consiste en cinco caracteres. '00000' significa sin error.

Notas

Nota:

Observe que aún no están referenciados todos los errores de MySQL a SQLSTATE. El valor HY000 (error general) se utiliza para errores no referenciados.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* eliminar la tabla */
    $mysqli->query("DROP TABLE myCountry");

    /* ejecutar la sentencia */
    $sentencia->execute();

    printf("Error: %s.\n", $sentencia->sqlstate);

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($enlace, "CREATE TABLE myCountry LIKE Country");
mysqli_query($enlace, "INSERT INTO myCountry SELECT * FROM Country");

$consulta = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* eliminar la tabla */
    mysqli_query($enlace, "DROP TABLE myCountry");

    /* ejecutar la sentencia */
    mysqli_stmt_execute($sentencia);

    printf("Error: %s.\n", mysqli_stmt_sqlstate($sentencia));

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Error: 42S02.

Ver también

  • mysqli_stmt_errno() - Devuelve el código de error de la llamada de la sentencia más reciente
  • mysqli_stmt_error() - Devuelve una descripción en forma de string del último error de una sentencia


Transfiere un conjunto de resultados desde una sentencia preparada

  • « mysqli_stmt::$sqlstate
  • mysqli_result »
  • PHP Manual
  • mysqli_stmt
  • Transfiere un conjunto de resultados desde una sentencia preparada

mysqli_stmt::store_result

mysqli_stmt_store_result

(PHP 5, PHP 7)

mysqli_stmt::store_result -- mysqli_stmt_store_result — Transfiere un conjunto de resultados desde una sentencia preparada

Descripción

Estilo orientado a objetos

mysqli_stmt::store_result ( ) : bool

Estilo por procedimientos

mysqli_stmt_store_result ( mysqli_stmt $stmt ) : bool

Se debe llamar a mysqli_stmt_store_result() para cada consulta que produzca con éxito un conjunto de resultados (SELECT, SHOW, DESCRIBE, EXPLAIN), y únicamente si se quiere almacenar en buffer el conjunto de resultados completo en el cliente, por lo que las llamadas subsuguientes a mysqli_stmt_fetch() devolverán datos almacenados en buffer.

Nota:

No es necesario llamar a mysqli_stmt_store_result() para otras consultas, pero si se hace, no perjudicará al rendimiento en ningún caso. Se puede detectar si la consulta produjo un conjunto de resultados comprobando si mysqli_stmt_result_metadata() devolvió NULL.

Parámetros

stmt

Sólo estilo por procediminetos: Un identificador de declaraciones devuelto por mysqli_stmt_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($sentencia = $mysqli->prepare($consulta)) {

    /* ejecutar la consulta */
    $sentencia->execute();

    /* almacenar el resultado */
    $sentencia->store_result();

    printf("Número de filas: %d.\n", $sentencia->num_rows);

    /* liberar el resultado */
    $sentencia->free_result();

    /* cerrar la sentencia */
    $sentencia->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Open a connection */
/* Abrir una conexión */
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($sentencia = mysqli_prepare($enlace, $consulta)) {

    /* ejecutar la consulta */
    mysqli_stmt_execute($sentencia);

    /* almacenar el resultado */
    mysqli_stmt_store_result($sentencia);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($sentencia));

    /* liberar el resultado */
    mysqli_stmt_free_result($sentencia);

    /* cerrar la sentencia */
    mysqli_stmt_close($sentencia);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Número de filas: 20.

Ver también

  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución
  • mysqli_stmt_result_metadata() - Devuelve los metadatos del conjunto de resultados de una sentencia preparada
  • mysqli_stmt_fetch() - Obtiene los resultados de una sentencia preparadas en las variables vinculadas


La clase mysqli_result

(PHP 5, PHP 7)

Introducción

Representa el conjunto de resultados obtenidos a partir de una consulta en la base de datos.

Historial de cambios

Historial de cambios
Versión | Descripción
5.4.0 | Se añadió el soporte para Iterator, y mysqli_result ahora implementa Traversable.

Sinopsis de la Clase

mysqli_result implements Traversable {
/* Propiedades */
int $current_field ;
int $field_count;
array $lengths;
int $num_rows;
/* Métodos */
data_seek ( int $offset ) : bool
fetch_all ( int $resulttype = MYSQLI_NUM ) : mixed
fetch_array ( int $resulttype = MYSQLI_BOTH ) : mixed
fetch_assoc ( ) : array
fetch_field_direct ( int $fieldnr ) : object
fetch_field ( ) : object
fetch_fields ( ) : array
fetch_object ( string $class_name = "stdClass" , array $params = ? ) : object
fetch_row ( ) : mixed
field_seek ( int $fieldnr ) : bool
free ( ) : void
}

Tabla de contenidos

  • mysqli_result::$current_field — Obtener posición del campo actual de un puntero a un resultado
  • mysqli_result::data_seek — Ajustar el puntero de resultado a una fila arbitraria del resultado
  • mysqli_result::fetch_all — Obtener todas las filas en un array asociativo, numérico, o en ambos
  • mysqli_result::fetch_array — Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_result::fetch_assoc — Obtener una fila de resultado como un array asociativo
  • mysqli_result::fetch_field_direct — Obtener los metadatos de un único campo
  • mysqli_result::fetch_field — Retorna el próximo campo del resultset
  • mysqli_result::fetch_fields — Devuelve un array de objetos que representan los campos de un conjunto de resultados
  • mysqli_result::fetch_object — Devuelve la fila actual de un conjunto de resultados como un objeto
  • mysqli_result::fetch_row — Obtener una fila de resultados como un array enumerado
  • mysqli_result::$field_count — Obtiene el número de campos de un resultado
  • mysqli_result::field_seek — Establecer el puntero del resultado al índice del campo especificado
  • mysqli_result::free — Libera la memoria asociada a un resultado
  • mysqli_result::$lengths — Retorna los largos de las columnas de la fila actual en el resultset
  • mysqli_result::$num_rows — Obtiene el número de filas de un resultado


Obtener posición del campo actual de un puntero a un resultado

  • « mysqli_result
  • mysqli_result::data_seek »
  • PHP Manual
  • mysqli_result
  • Obtener posición del campo actual de un puntero a un resultado

mysqli_result::$current_field

mysqli_field_tell

(PHP 5, PHP 7)

mysqli_result::$current_field -- mysqli_field_tell — Obtener posición del campo actual de un puntero a un resultado

Descripción

Estilo orientado a objetos

int $mysqli_result->current_field ;

Estilo por procedimientos

mysqli_field_tell ( mysqli_result $result ) : int

Devuelve la posición del cursor de campos utilizado en la última llamada de mysqli_fetch_field(). Se puede utilizar este valor como argumento para mysqli_field_seek().

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Devuelve la posición actual del cursor de campos.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_ususario", "mi_contraseña", "mundo");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Obtener información de los campos en todas las columnas */
    while ($finfo = $result->fetch_field()) {

        /* obtener posición del puntero de campo */
        $currentfield = $result->current_field;

        printf("Columna %d:\n", $currentfield);
        printf("Nombre:    %s\n", $finfo->name);
        printf("Tabla:     %s\n", $finfo->table);
        printf("max. Long: %d\n", $finfo->max_length);
        printf("Banderas:  %d\n", $finfo->flags);
        printf("Ttipo:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* ccerrar conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Obtener información de campo para cada campo */
    while ($finfo = mysqli_fetch_field($result)) {

        /* obtener posición del puntero de campo */
        $currentfield = mysqli_field_tell($result);

        printf("Columna %d:\n", $currentfield);
        printf("Nombre:    %s\n", $finfo->name);
        printf("Tabla:     %s\n", $finfo->table);
        printf("max. Long: %d\n", $finfo->max_length);
        printf("Banderas:  %d\n", $finfo->flags);
        printf("Tipo:      %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Columna 1:
Nombre:    Name
Tabla:     Country
max. Long: 11
Banderas:  1
Tipo:      254

Columna 2:
Nombre:    SurfaceArea
Tabla:     Country
max. Long: 10
Banderas:  32769
Tipo:      4

Ver también

  • mysqli_fetch_field() - Retorna el próximo campo del resultset
  • mysqli_field_seek() - Establecer el puntero del resultado al índice del campo especificado


Ajustar el puntero de resultado a una fila arbitraria del resultado

  • « mysqli_result::$current_field
  • mysqli_result::fetch_all »
  • PHP Manual
  • mysqli_result
  • Ajustar el puntero de resultado a una fila arbitraria del resultado

mysqli_result::data_seek

mysqli_data_seek

(PHP 5, PHP 7)

mysqli_result::data_seek -- mysqli_data_seek — Ajustar el puntero de resultado a una fila arbitraria del resultado

Descripción

Estilo orientado a objetos

mysqli_result::data_seek ( int $offset ) : bool

Estilo por procedimientos

mysqli_data_seek ( mysqli_result $result , int $offset ) : bool

La función mysqli_data_seek() salta a la posición offset de un puntero de resultado.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

offset

Posición del campo. Debe estar comprendido entre cero y el número total de filas menos uno (0..mysqli_num_rows() - 1).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Sólo se puede usar esta función con resultados almacenados que se obtengan mediante el uso de mysqli_store_result() o de mysqli_query().

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
/* Abrir una conexión */
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "mundo");

/* comprobar conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($result = $mysqli->query($query)) {

    /* saltar a la fila numero 400 */
    $result->data_seek(399);

    /* obtener fila */
    $row = $result->fetch_row();

    printf ("Ciudad: %s  Código de país: %s\n", $row[0], $row[1]);

    /* librar resultados */
    $result->close();
}

/* cerrar conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* Abrir conexión */
$link = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "mundo");

/* comprobar conexión */
if (!$link) {
    printf("Conexión faillida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";

if ($result = mysqli_query($link, $query)) {

    /* saltar a la fila número 400 */
    mysqli_data_seek($result, 399);

    /* obtener fila */
    $row = mysqli_fetch_row($result);

    printf ("Ciudad: %s  Código de país: %s\n", $row[0], $row[1]);

    /* liberar resultado */
    mysqli_free_result($result);
}

/* cerrar conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Ciudad: Benin City  Código de país: NGA

Ver también

  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_fetch_row() - Obtener una fila de resultados como un array enumerado
  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_fetch_assoc() - Obtener una fila de resultado como un array asociativo
  • mysqli_fetch_object() - Devuelve la fila actual de un conjunto de resultados como un objeto
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_num_rows() - Obtiene el número de filas de un resultado


Obtener todas las filas en un array asociativo, numérico, o en ambos

  • « mysqli_result::data_seek
  • mysqli_result::fetch_array »
  • PHP Manual
  • mysqli_result
  • Obtener todas las filas en un array asociativo, numérico, o en ambos

mysqli_result::fetch_all

mysqli_fetch_all

(PHP 5 >= 5.3.0, PHP 7)

mysqli_result::fetch_all -- mysqli_fetch_all — Obtener todas las filas en un array asociativo, numérico, o en ambos

Descripción

Estilo orientado a objetos

mysqli_result::fetch_all ( int $resulttype = MYSQLI_NUM ) : mixed

Estilo por procedimientos

mysqli_fetch_all ( mysqli_result $result , int $resulttype = MYSQLI_NUM ) : mixed

mysqli_fetch_all() consulta todas las filas y devuelve el resultado en un array asociativo, numérico, o ambos.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

resulttype

Este parámetro opcional define mediante una constante qué tipo de array debe producirse a partir de los datos actuales. Los valores posibles para este parámetro son las constantes MYSQLI_ASSOC, MYSQLI_NUM, o MYSQLI_BOTH.

Valores devueltos

Devuelve un array asociativo o numérico que almacena el resultado.

Solo Controlador Nativo de MySQL

Disponible sólo con mysqlnd.

Dado que mysqli_fetch_all() devuelve todas las filas en un array en un solo paso, puede consumir más memoria que otras funciones similares tales como mysqli_fetch_array(), que sólo devuelve una fila cada vez a partir del resultado. Por tanto, si se necesita recorrer un resultado, será necesario un bucle que minimice el impacto en rendimiento. Por esta razón, se aconseja que sólo se use mysqli_fetch_all() en aquellas situaciones en que el resultado se tenga que enviar a otra capa o nivel para que lo procese.

Ver también

  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_query() - Realiza una consulta a la base de datos


Obtiene una fila de resultados como un array asociativo, numérico, o ambos

  • « mysqli_result::fetch_all
  • mysqli_result::fetch_assoc »
  • PHP Manual
  • mysqli_result
  • Obtiene una fila de resultados como un array asociativo, numérico, o ambos

mysqli_result::fetch_array

mysqli_fetch_array

(PHP 5, PHP 7)

mysqli_result::fetch_array -- mysqli_fetch_array — Obtiene una fila de resultados como un array asociativo, numérico, o ambos

Descripción

Estilo orientado a objetos

mysqli_result::fetch_array ( int $resulttype = MYSQLI_BOTH ) : mixed

Estilo por procedimientos

mysqli_fetch_array ( mysqli_result $result , int $resulttype = MYSQLI_BOTH ) : mixed

Retorna un array que corresponde a la fila obtenida o null si es que no hay más filas en el resultset representado por el parámetro result.

mysqli_fetch_array() es una versión extendida de la función mysqli_fetch_row(). Además de guardar la información en los índices numéricos del array resultante, la función mysqli_fetch_array() también puede guardar la información en índices asociativos, utilizando los nombres de los campos del resultado como claves.

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Si dos o más columnas del resultado tienen el mismo nombre de campo, la última columna tomará precedencia y sobrescribirá la información anterior. Para acceder a múltiples columnas con el mismo nombre, hay que usar la versión numéricamente indexada de la fila.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

resulttype

Este parámetro opcional es una constante que indica qué tipo de array debiera generarse con la información de la fila actual. Los valores posibles para este parámetro son las constantes MYSQLI_ASSOC, MYSQLI_NUM, o MYSQLI_BOTH.

Al emplear la constante MYSQLI_ASSOC esta función se comportará de manera idéntica a mysqli_fetch_assoc(), mientras que con MYSQLI_NUM se comportará exactamente igual que la función mysqli_fetch_row(). La última opción MYSQLI_BOTH creará un único array con los atributos de ambas dos.

Valores devueltos

Retorna un array de strings que corresponde a la fila obtenida o null si no hay más filas en el resultset.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión failed: %s\n", $mysqli->connect_error);
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = $mysqli->query($query);

/* array numérico */
$row = $result->fetch_array(MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* array asociativo */
$row = $result->fetch_array(MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* array numérico y asociativo */
$row = $result->fetch_array(MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* liberar la serie de resultados */
$result->free();

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = mysqli_query($link, $query);

/* array numérico */
$row = mysqli_fetch_array($result, MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* array asociativo */
$row = mysqli_fetch_array($result, MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* array numérico y asociativo */
$row = mysqli_fetch_array($result, MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* liberar la serie de resultados */
mysqli_free_result($result);

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Kabul (AFG)
Qandahar (AFG)
Herat (AFG)

Ver también

  • mysqli_fetch_assoc() - Obtener una fila de resultado como un array asociativo
  • mysqli_fetch_row() - Obtener una fila de resultados como un array enumerado
  • mysqli_fetch_object() - Devuelve la fila actual de un conjunto de resultados como un objeto
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_data_seek() - Ajustar el puntero de resultado a una fila arbitraria del resultado


Obtener una fila de resultado como un array asociativo

  • « mysqli_result::fetch_array
  • mysqli_result::fetch_field_direct »
  • PHP Manual
  • mysqli_result
  • Obtener una fila de resultado como un array asociativo

mysqli_result::fetch_assoc

mysqli_fetch_assoc

(PHP 5, PHP 7)

mysqli_result::fetch_assoc -- mysqli_fetch_assoc — Obtener una fila de resultado como un array asociativo

Descripción

Estilo orientado a objetos

mysqli_result::fetch_assoc ( ) : array

Estilo por procedimientos

mysqli_fetch_assoc ( mysqli_result $result ) : array

Retorna un array asociativo correspondiente a la fila obtenida o null si no hubiera más filas.

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Devuelve un array asociativo de strings que representa a la fila obtenida del conjunto de resultados, donde cada clave del array representa el nombre de una de las columnas de éste; o null si no hubieran más filas en dicho conjunto de resultados.

Si dos o más columnas del resultado tienen el mismo nombre de campo, la última columna tomará precedencia. Para acceder a la/s otra/s columna/s con el mismo nombre, es necesario acceder al resultado ya sea usando los índices numéricos mediante mysqli_fetch_row(), ya sea añadiéndole alias a los campos.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if ($mysqli->connect_errno) {
    printf("Conexión fallida: %s\n", $mysqli->connect_error);
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = $mysqli->query($consulta)) {

    /* obtener un array asociativo */
    while ($fila = $resultado->fetch_assoc()) {
        printf ("%s (%s)\n", $fila["Name"], $fila["CountryCode"]);
    }

    /* liberar el conjunto de resultados */
    $resultado->free();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = mysqli_query($enlace, $consulta)) {

    /* obtener array asociativo */
    while ($row = mysqli_fetch_assoc($resultado)) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* liberar el conjunto de resultados */
    mysqli_free_result($resultado);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Ejemplo #3 Un ejemplo de mysqli_result comparando el uso de iterator

<?php
$c = mysqli_connect('127.0.0.1','user', 'pass');

// Usando iteradores (el soporte fue añadido con PHP 5.4)
foreach ( $c->query('SELECT user,host FROM mysql.user') as $fila ) {
    printf("'%s'@'%s'\n", $fila['user'], $fila['host']);
}

echo "\n==================\n";

// Sin usar iteradores
$result = $c->query('SELECT user,host FROM mysql.user');
while ($fila = $result->fetch_assoc()) {
    printf("'%s'@'%s'\n", $fila['user'], $fila['host']);
}

?>

El resultado del ejemplo sería algo similar a:

'root'@'192.168.1.1'
'root'@'127.0.0.1'
'dude'@'localhost'
'lebowski'@'localhost'

==================

'root'@'192.168.1.1'
'root'@'127.0.0.1'
'dude'@'localhost'
'lebowski'@'localhost'

Ver también

  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_fetch_row() - Obtener una fila de resultados como un array enumerado
  • mysqli_fetch_object() - Devuelve la fila actual de un conjunto de resultados como un objeto
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_data_seek() - Ajustar el puntero de resultado a una fila arbitraria del resultado


Obtener los metadatos de un único campo

  • « mysqli_result::fetch_assoc
  • mysqli_result::fetch_field »
  • PHP Manual
  • mysqli_result
  • Obtener los metadatos de un único campo

mysqli_result::fetch_field_direct

mysqli_fetch_field_direct

(PHP 5, PHP 7)

mysqli_result::fetch_field_direct -- mysqli_fetch_field_direct — Obtener los metadatos de un único campo

Descripción

Estilo orientado a objetos

mysqli_result::fetch_field_direct ( int $fieldnr ) : object

Estilo por procedimientos

mysqli_fetch_field_direct ( mysqli_result $result , int $fieldnr ) : object

Devuelve un objeto que contiene la información de definición de un campo del conjunto de resultados especificado.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

fieldnr

El número de campo. Este valor debe estar en un rango desde 0 a número de campos - 1.

Valores devueltos

Devuelve un objeto que contiene la información de definición del campo o false si no está disponible la información del campo especificada por fieldnr.

Atributos del objeto
Atributo | Descripción
name | El nombre de la columna
orgname | El nombre original de la columna si se especificó un alias
table | El nombre de la tabla al que pertenece el campo (si no es calculado)
orgtable | El nombre original de la tabla si se especificó un alias
def | El valor predeterminado de este campo, representado como una cadena
max_length | El ancho máximo del campo del conjunto de resultados.
length | El ancho del campo, como fue especificado en la definición de la tabla.
charsetnr | El número del conjunto de caracteres del campo.
flags | Un entero que representa las banderas de bits del campo.
type | El tipo de datos usado por el campo
decimals | El número de decimales empleados (para campos numéricos)

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($resultado = $mysqli->query($consulta)) {

    /* Obtener la información del campo para la columna 'SurfaceArea' */
    $info_campo = $resultado->fetch_field_direct(1);

    printf("Nombre:        %s\n", $info_campo->name);
    printf("Tabla:         %s\n", $info_campo->table);
    printf("Longitud máx.: %d\n", $info_campo->max_length);
    printf("Banderas:      %d\n", $info_campo->flags);
    printf("Tipo:          %d\n", $info_campo->type);

    $resultado->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($resultado = mysqli_query($enlace, $consulta)) {

    /* Obtener la información del campo para la columna 'SurfaceArea' */
    $info_campo = mysqli_fetch_field_direct($resultado, 1);

    printf("Nombre:     %s\n", $info_campo->name);
    printf("Tabla:    %s\n", $info_campo->table);
    printf("Longitud máx.: %d\n", $info_campo->max_length);
    printf("Banderas:    %d\n", $info_campo->flags);
    printf("Tipo:     %d\n", $info_campo->type);

    mysqli_free_result($resultado);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Nombre:        SurfaceArea
Tabla:         Country
Longitud máx.: 10
Banderas:      32769
Tipo:          4

Ver también

  • mysqli_num_fields() - Obtiene el número de campos de un resultado
  • mysqli_fetch_field() - Retorna el próximo campo del resultset
  • mysqli_fetch_fields() - Devuelve un array de objetos que representan los campos de un conjunto de resultados


Retorna el próximo campo del resultset

  • « mysqli_result::fetch_field_direct
  • mysqli_result::fetch_fields »
  • PHP Manual
  • mysqli_result
  • Retorna el próximo campo del resultset

mysqli_result::fetch_field

mysqli_fetch_field

(PHP 5, PHP 7)

mysqli_result::fetch_field -- mysqli_fetch_field — Retorna el próximo campo del resultset

Descripción

Estilo orientado a objetos

mysqli_result::fetch_field ( ) : object

Estilo por procedimientos

mysqli_fetch_field ( mysqli_result $result ) : object

Retorna la definición de una columna del resultset como un objeto. Para obtener la información de todas las columnas del resultset hay que llamar esta función reiterativamente.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Retorna un objeto que contiene la información de la columna o false en el caso de que la información no esté disponible.

Propiedades del objeto
Propiedad | Descripción
name | El nombre de la columna
orgname | El nombre original de la columna en caso que se haya especificado un alias
table | El nombre de la tabla al que este campo pertenece (si no es calculado)
orgtable | El nombre original de la tabla en caso que se haya especificado un alias
def | Reservado para el valor por omisión, por ahora es siempre ""
db | Base de datos (desde PHP 5.3.6)
catalog | El nombre del catálogo, siempre "def" (desde PHP 5.3.6)
max_length | El largo máximo del campo en el resultset
length | El largo del campo, tal como se especifica en la definición de la tabla.
charsetnr | El número del juego de caracteres del campo.
flags | Un entero que representa las banderas de bits del campo.
type | El tipo de datos que se usa en este campo
decimals | El número de decimales utilizado (para campos de tipo integer)

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Obtener la información del campo de cada columna */
    while ($finfo = $result->fetch_field()) {

        printf("Nombre:     %s\n", $finfo->name);
        printf("Tabla:    %s\n", $finfo->table);
        printf("Largo max: %d\n", $finfo->max_length);
        printf("Banderas:    %d\n", $finfo->flags);
        printf("Tipo:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión *
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Obtener la información del campo de cada columna */
    while ($finfo = mysqli_fetch_field($result)) {

        printf("Nombre:     %s\n", $finfo->name);
        printf("Tabla:      %s\n", $finfo->table);
        printf("Largo max:  %d\n", $finfo->max_length);
        printf("Banderas:   %d\n", $finfo->flags);
        printf("Tipo:       %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

Nombre:     Name
Tabla:      Country
Largo max:  11
Banderas:   1
Tipo:       254

Nombre:     SurfaceArea
Tabla:      Country
Largo max:  10
Banderas:   32769
Tipo:       4

Ver también

  • mysqli_num_fields() - Obtiene el número de campos de un resultado
  • mysqli_fetch_field_direct() - Obtener los metadatos de un único campo
  • mysqli_fetch_fields() - Devuelve un array de objetos que representan los campos de un conjunto de resultados
  • mysqli_field_seek() - Establecer el puntero del resultado al índice del campo especificado


Devuelve un array de objetos que representan los campos de un conjunto de resultados

  • « mysqli_result::fetch_field
  • mysqli_result::fetch_object »
  • PHP Manual
  • mysqli_result
  • Devuelve un array de objetos que representan los campos de un conjunto de resultados

mysqli_result::fetch_fields

mysqli_fetch_fields

(PHP 5, PHP 7)

mysqli_result::fetch_fields -- mysqli_fetch_fields — Devuelve un array de objetos que representan los campos de un conjunto de resultados

Descripción

Estilo orientado a objetos

mysqli_result::fetch_fields ( ) : array

Estilo por procedimientos

mysqli_fetch_fields ( mysqli_result $result ) : array

Esta función sirve de propósito idéntico a la función mysqli_fetch_field() con la única diferencia de que, en lugar de devolver un objeto por cada campo, las columnas son devueltas en un array de objetos.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Devuelve un array de objetos que contiene la información de definición de los campos o false si no hay información de campo disponible.

Propiedades del objeto
Propiedad | Descripción
name | El nombre de la columna
orgname | El nombre original de la columna si se especificó un alias
table | El nombre de la tabla al que pertenece el campo (si no es calculado)
orgtable | El nombre original de la tabla si se especificó un alias
max_length | El ancho máximo del campo del conjunto de resultados.
length | El ancho del campo, en bytes, como se especificó en la definición de la tabla. Observe que este número (bytes) podría diferir del valor de la definición de la tabla (caracteres), dependiendo del conjunto de caracteres que se emplee. Por ejemplo, el conjunto de caracteres utf8 tiene 3 bytes por carácter, por lo que varchar(10) devolverá una longitud de 30 para utf8 (10*3), aunque devuelve 10 para latin1 (10*1).
charsetnr | El número del conjunto de caracteres (id) del campo.
flags | Un entero que representa las banderas de bits del campo.
type | El tipo de datos usado por el campo
decimals | El número de decimales usado (para campos integer)

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("127.0.0.1", "root", "foofoo", "sakila");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", $mysqli->connect_error);
    exit();
}

foreach (array('latin1', 'utf8') as $conj_caract) {

    // Establecer el conjunto de caracteres para mostrar su impacto en algunos valores (p.ej., longitud en bytes)
    $mysqli->set_charset($conj_caract);

    $consulta = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "======================\n";
    echo "Conjunto de caracteres: $conj_caract\n";
    echo "======================\n";

    if ($resultado = $mysqli->query($consulta)) {

        /* Obtener la información del campo para todas las columnas */
        $info_campo = $resultado->fetch_fields();

        foreach ($info_campo as $valor) {
            printf("Nombre:           %s\n",   $valor->name);
            printf("Tabla:            %s\n",   $valor->table);
            printf("Longitud máx.:    %d\n",   $valor->max_length);
            printf("Longitud:         %d\n",   $valor->length);
            printf("Nº conj. caract.: %d\n",   $valor->charsetnr);
            printf("Banderas:         %d\n",   $valor->flags);
            printf("Tipo:             %d\n\n", $valor->type);
        }
        $resultado->free();
    }
}
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("127.0.0.1", "mi_usuario", "mi_contraseña", "sakila");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

foreach (array('latin1', 'utf8') as $conj_caract) {

    // Establecer el conjunto de caracteres para mostrar su impacto en algunos valores (p.ej., longitud en bytes)
    mysqli_set_charset($enlace, $conj_caract);

    $consulta = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "===============================\n";
    echo "Conjunto de caracteres: $conj_caract\n";
    echo "===============================\n";

    if ($resultado = mysqli_query($enlace, $consulta)) {

        /* Obtener la información del campo para todas las columnas */
        $info_campo = mysqli_fetch_fields($resultado);

        foreach ($info_campo as $valor) {
            printf("Nombre:           %s\n",   $valor->name);
            printf("Tabla:            %s\n",   $valor->table);
            printf("Longitud máx.:    %d\n",   $valor->max_length);
            printf("Longitud:         %d\n",   $valor->length);
            printf("Nº conj. caract.: %d\n",   $valor->charsetnr);
            printf("Banderas:         %d\n",   $valor->flags);
            printf("Tipo:             %d\n\n", $valor->type);
        }
        mysqli_free_result($resultado);
    }
}

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

===============================
Conjunto de caracteres: latin1
===============================
Nombre:           actor_id
Tabla:            actor
Longitud máx.:    3
Longitud:         5
Nº conj. caract.: 63
Banderas:         49699
Tipo:             2

Nombre:           last_name
Tabla:            actor
Longitud máx.:    12
Longitud:         45
Nº conj. caract.: 8
Banderas:         20489
Tipo:             253

===============================
Conjunto de caracteres: utf8
===============================
Nombre:           actor_id
Tabla:            actor
Longitud máx.:    3
Longitud:         5
Nº conj. caract.: 63
Banderas:         49699
Tipo:             2

Nombre:           last_name
Tabla:            actor
Longitud máx.:    12
Longitud:         135
Nº conj. caract.: 33
Banderas:         20489

Ver también

  • mysqli_num_fields() - Obtiene el número de campos de un resultado
  • mysqli_fetch_field_direct() - Obtener los metadatos de un único campo
  • mysqli_fetch_field() - Retorna el próximo campo del resultset


Devuelve la fila actual de un conjunto de resultados como un objeto

  • « mysqli_result::fetch_fields
  • mysqli_result::fetch_row »
  • PHP Manual
  • mysqli_result
  • Devuelve la fila actual de un conjunto de resultados como un objeto

mysqli_result::fetch_object

mysqli_fetch_object

(PHP 5, PHP 7)

mysqli_result::fetch_object -- mysqli_fetch_object — Devuelve la fila actual de un conjunto de resultados como un objeto

Descripción

Estilo orientado a objetos

mysqli_result::fetch_object ( string $class_name = "stdClass" , array $params = ? ) : object

Estilo por procedimientos

mysqli_fetch_object ( mysqli_result $result , string $class_name = "stdClass" , array $params = ? ) : object

mysqli_fetch_object() devolverá la fila actual del conjunto de resultados como un objeto, donde los atributos del objeto representan los nombres de los campos encontrados en el conjunto de resultados.

Observe que mysqli_fetch_object() establece las propiedades del objeto antes de llamar al constructor del objeto.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

class_name

El nombre de la clase a instanciar, establecer las propiedades y devolver. Si no se especifica se devuelve un objeto stdClass.

params

Un array opcional de parámetros para pasar al constructor de los objetos de class_name.

Valores devueltos

Devuelve un objeto con las propiedades de cadena que corresponden a la fila obtenida o null si no hay más filas en el conjunto de resultados.

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = $mysqli->query($consulta)) {

    /* obtener el array de objetos */
    while ($obj = $resultado->fetch_object()) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* liberar el conjunto de resultados */
    $resultado->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = mysqli_query($enlace, $consulta)) {

    /* obtener el array asociativo */
    while ($obj = mysqli_fetch_object($resultado)) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* liberar el conjunto de resultados */
    mysqli_free_result($resultado);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Ver también

  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_fetch_assoc() - Obtener una fila de resultado como un array asociativo
  • mysqli_fetch_row() - Obtener una fila de resultados como un array enumerado
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_data_seek() - Ajustar el puntero de resultado a una fila arbitraria del resultado


Obtener una fila de resultados como un array enumerado

  • « mysqli_result::fetch_object
  • mysqli_result::$field_count »
  • PHP Manual
  • mysqli_result
  • Obtener una fila de resultados como un array enumerado

mysqli_result::fetch_row

mysqli_fetch_row

(PHP 5, PHP 7)

mysqli_result::fetch_row -- mysqli_fetch_row — Obtener una fila de resultados como un array enumerado

Descripción

Estilo orientado a objetos

mysqli_result::fetch_row ( ) : mixed

Estilo por procedimientos

mysqli_fetch_row ( mysqli_result $result ) : mixed

Obtiene una fila de datos del conjunto de resultados y la devuelve como un array enumerado, donde cada columna es almacenada en un índice del array comenzando por 0 (cero). Cada llamada subsiguiente a esta función devolverá la siguiente fila del conjunto de resultados, o null si no hay más filas.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

mysqli_fetch_row() devuelve un array de cadenas que se corresponde con la fila obtenida o null si no hay más filas en el conjunto de resultados.

Nota: Esta función define campos NULOS al valor null de PHP.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = $mysqli->query($consulta)) {

    /* obtener el array de objetos */
    while ($fila = $resultado->fetch_row()) {
        printf ("%s (%s)\n", $fila[0], $fila[1]);
    }

    /* liberar el conjunto de resultados */
    $resultado->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($resultado = mysqli_query($enlace, $consulta)) {

    /* obtener el array asociativo */
    while ($fila = mysqli_fetch_row($resultado)) {
        printf ("%s (%s)\n", $fila[0], $fila[1]);
    }

    /* liberar el conjunto de resultados */
    mysqli_free_result($resultado);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Ver también

  • mysqli_fetch_array() - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
  • mysqli_fetch_assoc() - Obtener una fila de resultado como un array asociativo
  • mysqli_fetch_object() - Devuelve la fila actual de un conjunto de resultados como un objeto
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_data_seek() - Ajustar el puntero de resultado a una fila arbitraria del resultado


Obtiene el número de campos de un resultado

  • « mysqli_result::fetch_row
  • mysqli_result::field_seek »
  • PHP Manual
  • mysqli_result
  • Obtiene el número de campos de un resultado

mysqli_result::$field_count

mysqli_num_fields

(PHP 5, PHP 7)

mysqli_result::$field_count -- mysqli_num_fields — Obtiene el número de campos de un resultado

Descripción

Estilo orientado a objetos

int $mysqli_result->field_count;

Estilo por procedimientos

mysqli_num_fields ( mysqli_result $result ) : int

Retorna el número de campos del resultset especificado.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

El número de campos de un resultset.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determinar el número de campos del resultset */
    $field_cnt = $result->field_count;

    printf("El resultset tiene %d campos.\n", $field_cnt);

    /* cerrar el resultset */
    $result->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determinar el número de campos del resultset */
    $field_cnt = mysqli_num_fields($result);

    printf("El resultset tiene %d campos.\n", $field_cnt);

    /* cerrar el resultset */
    mysqli_free_result($result);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

El resultset tiene 5 campos.

Ver también

  • mysqli_fetch_field() - Retorna el próximo campo del resultset


Establecer el puntero del resultado al índice del campo especificado

  • « mysqli_result::$field_count
  • mysqli_result::free »
  • PHP Manual
  • mysqli_result
  • Establecer el puntero del resultado al índice del campo especificado

mysqli_result::field_seek

mysqli_field_seek

(PHP 5, PHP 7)

mysqli_result::field_seek -- mysqli_field_seek — Establecer el puntero del resultado al índice del campo especificado

Descripción

Estilo orientado a objetos

mysqli_result::field_seek ( int $fieldnr ) : bool

Estilo por procedimientos

mysqli_field_seek ( mysqli_result $result , int $fieldnr ) : bool

Establece el cursor del campo al índice dado. La siguiente llamada a mysqli_fetch_field() recuperará la definicion del campo de la columna asociada con ese índice.

Nota:

Para buscar al principio de una fila, pase un valor de índice de cero.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

fieldnr

El número de campo. Este valor debe estar en el rango de 0 a número de campos - 1.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($resultado = $mysqli->query($consulta)) {

    /* Obtener la información de campo de la 2ª columna */
    $resultado->field_seek(1);
    $info_campo = $resultado->fetch_field();

    printf("Nombre:        %s\n", $info_campo->name);
    printf("Tabla:         %s\n", $info_campo->table);
    printf("Longitud máx.: %d\n", $info_campo->max_length);
    printf("Banderas:      %d\n", $info_campo->flags);
    printf("Tipo:          %d\n\n", $info_campo->type);

    $resultado->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* comprobar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

$consulta = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($resultado = mysqli_query($enlace, $consulta)) {

    /* Obtener la información de campo de la 2ª columna */
    mysqli_field_seek($resultado, 1);
    $info_campo = mysqli_fetch_field($resultado);

    printf("Nombre:        %s\n", $info_campo->name);
    printf("Tabla:         %s\n", $info_campo->table);
    printf("Longitud máx.: %d\n", $info_campo->max_length);
    printf("Banderas:      %d\n", $info_campo->flags);
    printf("Tipo:          %d\n\n", $info_campo->type);

    mysqli_free_result($resultado);
}

/* cerrar la conexión */
mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Nombre:        SurfaceArea
Tabla:         Country
Longitud máx.: 10
Banderas:      32769
Tipo:          4

Ver también

  • mysqli_fetch_field() - Retorna el próximo campo del resultset


Libera la memoria asociada a un resultado

  • « mysqli_result::field_seek
  • mysqli_result::$lengths »
  • PHP Manual
  • mysqli_result
  • Libera la memoria asociada a un resultado

mysqli_result::free

mysqli_result::close

mysqli_result::free_result

mysqli_free_result

(PHP 5, PHP 7)

mysqli_result::free -- mysqli_result::close -- mysqli_result::free_result -- mysqli_free_result — Libera la memoria asociada a un resultado

Descripción

Estilo orientado a objetos

mysqli_result::free ( ) : void
mysqli_result::close ( ) : void
mysqli_result::free_result ( ) : void

Estilo por procedimientos

mysqli_free_result ( mysqli_result $result ) : void

Libera la memoria asociada al resultado.

Nota:

Siempre se debe liberar el resultado con mysqli_free_result(), cuando el objeto del resultado ya no es necesario.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

No devuelve ningún valor.

Ver también

  • mysqli_query() - Realiza una consulta a la base de datos
  • mysqli_stmt_store_result() - Transfiere un conjunto de resultados desde una sentencia preparada
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados


Retorna los largos de las columnas de la fila actual en el resultset

  • « mysqli_result::free
  • mysqli_result::$num_rows »
  • PHP Manual
  • mysqli_result
  • Retorna los largos de las columnas de la fila actual en el resultset

mysqli_result::$lengths

mysqli_fetch_lengths

(PHP 5, PHP 7)

mysqli_result::$lengths -- mysqli_fetch_lengths — Retorna los largos de las columnas de la fila actual en el resultset

Descripción

Estilo orientado a objetos

array $mysqli_result->lengths;

Estilo por procedimientos

mysqli_fetch_lengths ( mysqli_result $result ) : array

La función mysqli_fetch_lengths() retorna un array que contiene los largos de cada columna de la fila actual dentro del resultset·

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Un array de integers que representan el tamaño de cada columna (sin incluir los caracteres null al final de éstas) . false en caso de error.

mysqli_fetch_lengths() sólo es válida para la fila actual del resultset. Retorna false si se invoca antes de llamar a mysqli_fetch_row/array/object o después de sacar todas las filas del resultado.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = $mysqli->query($query)) {

    $row = $result->fetch_row();

    /* mostrar los largos de las columnas */
    foreach ($result->lengths as $i => $val) {
        printf("El campo %2d tiene por Largo %2d\n", $i+1, $val);
    }
    $result->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = mysqli_query($link, $query)) {

    $row = mysqli_fetch_row($result);

    /* mostrar los largos de las columnas */
    foreach (mysqli_fetch_lengths($result) as $i => $val) {
        printf("El camp %2d tiene por Largo %2d\n", $i+1, $val);
    }
    mysqli_free_result($result);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

El campo  1 tiene por Largo  3
El campo  2 tiene por Largo  5
El campo  3 tiene por Largo 13
El campo  4 tiene por Largo  9
El campo  5 tiene por Largo  6
El campo  6 tiene por Largo  1
El campo  7 tiene por Largo  6
El campo  8 tiene por Largo  4
El campo  9 tiene por Largo  6
El campo 10 tiene por Largo  6
El campo 11 tiene por Largo  5
El campo 12 tiene por Largo 44
El campo 13 tiene por Largo  7
El campo 14 tiene por Largo  3
El campo 15 tiene por Largo  2


Obtiene el número de filas de un resultado

  • « mysqli_result::$lengths
  • mysqli_driver »
  • PHP Manual
  • mysqli_result
  • Obtiene el número de filas de un resultado

mysqli_result::$num_rows

mysqli_num_rows

(PHP 5, PHP 7)

mysqli_result::$num_rows -- mysqli_num_rows — Obtiene el número de filas de un resultado

Descripción

Estilo orientado a objetos

int $mysqli_result->num_rows;

Estilo por procedimientos

mysqli_num_rows ( mysqli_result $result ) : int

Retorna el número de filas del resultado.

El comportamiento de mysqli_num_rows() depende de si es que se utilizan resultsets con o sin buffer. En caso de emplearlos sin buffer mysqli_num_rows() no retornará el número de filas correcto hasta que todas las filas del resultado hayan sido recuperadas.

Parámetros

result

Sólo estilo por procedimientos: Un conjunto de identificadores de resultados devuelto por mysqli_query(), mysqli_store_result() o mysqli_use_result().

Valores devueltos

Retorna el número de filas del resultado.

Nota:

Si el número de filas es mayor al máximo valor de PHP_INT_MAX, el número será retornado como un string.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determinar el número de filas del resultado */
    $row_cnt = $result->num_rows;

    printf("Result set has %d rows.\n", $row_cnt);

    /* cerrar el resultset */
    $result->close();
}

/* cerrar la conexión */
$mysqli->close();
?>

Ejemplo #2 Estilo por procedimientos

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Conexión fallida: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determinar el número de filas del resultado */
    $row_cnt = mysqli_num_rows($result);

    printf("El resultado tiene %d filas.\n", $row_cnt);

    /* cerrar el resulset */
    mysqli_free_result($result);
}

/* cerrar la conexión */
mysqli_close($link);
?>

El resultado de los ejemplos sería:

El resultado tiene 239 filas.

Ver también

  • mysqli_affected_rows() - Obtiene el número de filas afectadas en la última operación MySQL
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados
  • mysqli_query() - Realiza una consulta a la base de datos


La clase mysqli_driver

(PHP 5, PHP 7)

Introducción

MySQLi Driver.

Sinopsis de la Clase

mysqli_driver {
/* Propiedades */
public readonly string $client_info ;
public readonly string $client_version ;
public readonly string $driver_version ;
public readonly string $embedded ;
public bool $reconnect ;
public int $report_mode ;
/* Métodos */
embedded_server_end ( ) : void
embedded_server_start ( bool $start , array $arguments , array $groups ) : bool
}

Propiedades

client_info

El encabezado de la versión de la API Cliente

client_version

La versión de Cliente

driver_version

La versión del controlador MySQLi

embedded

Si el soporte para MySQLi Embebido está habilitado

reconnect

Permitir o evitar que vuelva a conectar (véase la Directiva INI mysqli.reconnect)

report_mode

Establecer MYSQLI_REPORT_OFF, MYSQLI_REPORT_ALL o cualquier combinación de MYSQLI_REPORT_STRICT (lanzar excepciones para los errores), MYSQLI_REPORT_ERROR (informe de errores) y MYSQLI_REPORT_INDEX (errores con respecto a índices). Ver también mysqli_report().

Tabla de contenidos

  • mysqli_driver::embedded_server_end — Detener el servidor incrustado
  • mysqli_driver::embedded_server_start — Inicializa e inicia el servidor embebido
  • mysqli_driver::$report_mode — Habilita o desabilita las funciones internas de notificación


Detener el servidor incrustado

  • « mysqli_driver
  • mysqli_driver::embedded_server_start »
  • PHP Manual
  • mysqli_driver
  • Detener el servidor incrustado

mysqli_driver::embedded_server_end

mysqli_embedded_server_end

(PHP 5 >= 5.1.0, PHP 7 < 7.4.0)

mysqli_driver::embedded_server_end -- mysqli_embedded_server_end — Detener el servidor incrustado

Descripción

Estilo orientado a objetos

mysqli_driver::embedded_server_end ( ) : void

Estilo por procedimientos

mysqli_embedded_server_end ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Inicializa e inicia el servidor embebido

  • « mysqli_driver::embedded_server_end
  • mysqli_driver::$report_mode »
  • PHP Manual
  • mysqli_driver
  • Inicializa e inicia el servidor embebido

mysqli_driver::embedded_server_start

mysqli_embedded_server_start

(PHP 5 >= 5.1.0, PHP 7 < 7.4.0)

mysqli_driver::embedded_server_start -- mysqli_embedded_server_start — Inicializa e inicia el servidor embebido

Descripción

Estilo orientado a objetos

mysqli_driver::embedded_server_start ( bool $start , array $arguments , array $groups ) : bool

Estilo orientado a objetos

mysqli_embedded_server_start ( bool $start , array $arguments , array $groups ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Habilita o desabilita las funciones internas de notificación

  • « mysqli_driver::embedded_server_start
  • mysqli_warning »
  • PHP Manual
  • mysqli_driver
  • Habilita o desabilita las funciones internas de notificación

mysqli_driver::$report_mode

mysqli_report

(PHP 5, PHP 7)

mysqli_driver::$report_mode -- mysqli_report — Habilita o desabilita las funciones internas de notificación

Descripción

Estilo orientado a objetos

int $mysqli_driver->report_mode ;

Estilo por procedimientos

mysqli_report ( int $flags ) : bool

Una función útil para mejorar consultas durante el desarrollo de código y pruebas. Dependiendo de las banderas, notifica errores desde llamadas a funciones de mysqli o consultas que no usan un índice (o usan uno erróneo).

Parámetros

flags

Banderas admitidas
Nombre | Descripción
MYSQLI_REPORT_OFF | Desactiva la notificación
MYSQLI_REPORT_ERROR | Notifica errores desde llamadas a funciones de mysqli
MYSQLI_REPORT_STRICT | Lanza una mysqli_sql_exception para errors en lugar de para advertencias
MYSQLI_REPORT_INDEX | Notifica si no se usó un índice o si era erróneo en una consulta
MYSQLI_REPORT_ALL | Establece todas las opciones (notifica todo)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.4 | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.
5.2.15 | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

$mysqli = new mysqli("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* activar la notificación */
$controlador = new mysqli_driver();
$controlador->report_mode = MYSQLI_REPORT_ALL;

try {

    /* esta consulta debería notificar un error */
    $resultado = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

    /* esta consulta debería notificar un índice erróneo */
    $resultado = $mysqli->query("SELECT Name FROM City WHERE population > 50000");

    $resultado->close();

    $mysqli->close();

} catch (mysqli_sql_exception $e) {

    echo $e->__toString();
}
?>

Ejemplo #2 Estilo por procedimientos

<?php
/* activar la notificación */
mysqli_report(MYSQLI_REPORT_ALL);

$enlace = mysqli_connect("localhost", "mi_usuario", "mi_contraseña", "world");

/* verificar la conexión */
if (mysqli_connect_errno()) {
    printf("Falló la conexión: %s\n", mysqli_connect_error());
    exit();
}

/* esta consulta debería notificar un error */
$resultado = mysqli_query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

/* esta consulta debería notificar un índice erróneo */
$resultado = mysqli_query("SELECT Name FROM City WHERE population > 50000");

mysqli_free_result($resultado);

mysqli_close($enlace);
?>

Ver también

  • mysqli_debug() - Realiza operaciones de depuración
  • mysqli_dump_debug_info() - Volcado de información de depuración en el registro
  • mysqli_sql_exception
  • set_exception_handler() - Establece una función de gestión de excepciones definida por el usuario
  • error_reporting() - Establece cuáles errores de PHP son notificados


La clase mysqli_warning

(PHP 5, PHP 7)

Introducción

Representa una advertencia de MySQL.

Sinopsis de la Clase

mysqli_warning {
/* Propiedades */
public $message ;
public $sqlstate ;
public $errno ;
/* Métodos */
public next ( ) : void
}

Propiedades

message

Cadena de mensaje

sqlstate

Estado de SQL

errno

Número de error

Tabla de contenidos

  • mysqli_warning::next — El propósito next


El propósito next

  • « mysqli_warning
  • mysqli_sql_exception »
  • PHP Manual
  • mysqli_warning
  • El propósito next

mysqli_warning::next

(PHP 5, PHP 7)

mysqli_warning::next — El propósito next

Descripción

public mysqli_warning::next ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase mysqli_sql_exception

(PHP 5, PHP 7)

Introducción

La clase que gestiona las excepciones mysqli.

Sinopsis de la Clase

mysqli_sql_exception extends RuntimeException {
/* Propiedades */
protected string $sqlstate ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

Propiedades

sqlstate

El estado sql con el error.


Alias y Funciones de MySQLi obsoletos

Tabla de contenidos

  • mysqli_connect — Alias de mysqli::__construct
  • mysqli_escape_string — Alias de mysqli_real_escape_string
  • mysqli_execute — Alias para mysqli_stmt_execute
  • mysqli_get_client_stats — Returns client per-process statistics
  • mysqli_get_links_stats — Devolver información sobre enlaces abiertos y almacenados en caché
  • mysqli_report — Alias de mysqli_driver->report_mode
  • mysqli::set_opt — Alias de mysqli_options


Alias de mysqli::__construct

  • « Alias y Funciones de MySQLi obsoletos
  • mysqli_escape_string »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Alias de mysqli::__construct

mysqli_connect

(PHP 5, PHP 7)

mysqli_connect — Alias de mysqli::__construct()

Descripción

Esta función es un alias de: mysqli::__construct()

Aunque la documentación de mysqli::__construct() también incluye ejemplos procedimentales que emplean la función mysqli_connect(), aquí se muestra un breve ejemplo:

Ejemplos

Ejemplo #1 Ejemplo de mysqli_connect()

<?php
$enlace = mysqli_connect("127.0.0.1", "mi_usuario", "mi_contraseña", "mi_bd");

if (!$enlace) {
    echo "Error: No se pudo conectar a MySQL." . PHP_EOL;
    echo "errno de depuración: " . mysqli_connect_errno() . PHP_EOL;
    echo "error de depuración: " . mysqli_connect_error() . PHP_EOL;
    exit;
}

echo "Éxito: Se realizó una conexión apropiada a MySQL! La base de datos mi_bd es genial." . PHP_EOL;
echo "Información del host: " . mysqli_get_host_info($enlace) . PHP_EOL;

mysqli_close($enlace);
?>

El resultado de los ejemplos sería:

Éxito: Se realizó una conexión apropiada a MySQL! La base de datos mi_bd es genial.
Información del host: localhost via TCP/IP


Alias de mysqli_real_escape_string

  • « mysqli_connect
  • mysqli_execute »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Alias de mysqli_real_escape_string

mysqli_escape_string

(PHP 5, PHP 7)

mysqli_escape_string — Alias de mysqli_real_escape_string()

Descripción

Esta función es un alias de: mysqli_real_escape_string().


Alias para mysqli_stmt_execute

  • « mysqli_escape_string
  • mysqli_get_client_stats »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Alias para mysqli_stmt_execute

mysqli_execute

(PHP 5, PHP 7)

mysqli_execute — Alias para mysqli_stmt_execute()

Descripción

Esta función es un alias de mysqli_stmt_execute().

Notas

Nota:

mysqli_execute() es obsoleto y será removido.

Ver también

  • mysqli_stmt_execute() - Ejecuta una consulta preparada


Returns client per-process statistics

  • « mysqli_execute
  • mysqli_get_links_stats »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Returns client per-process statistics

mysqli_get_client_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli_get_client_stats — Returns client per-process statistics

Descripción

mysqli_get_client_stats ( ) : array

Returns client per-process statistics. Disponible sólo con mysqlnd.

Parámetros

Valores devueltos

Returns an array with client stats if success, false otherwise.

Ejemplos

Ejemplo #1 A mysqli_get_client_stats() example

<?php
$link = mysqli_connect();
print_r(mysqli_get_client_stats());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

Ver también

  • Stats description


Devolver información sobre enlaces abiertos y almacenados en caché

  • « mysqli_get_client_stats
  • mysqli_report »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Devolver información sobre enlaces abiertos y almacenados en caché

mysqli_get_links_stats

(PHP 5 >= 5.6.0, PHP 7)

mysqli_get_links_stats — Devolver información sobre enlaces abiertos y almacenados en caché

Descripción

mysqli_get_links_stats ( ) : array

mysqli_get_links_stats() devuelve información sobre enlaces de MySQL abiertos y almacenados en caché.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

mysqli_get_links_stats() devuelve un array asociativo con tres elementos, indicados a continuación:

total

Un integer que indica el número total de enlaces abiertos en cualquier estado.

active_plinks

Un integer que representa el número de conexiones persistentes activas.

cached_plinks

Un integer que representa el número de conexiones persistentes inactivas.


Alias de mysqli_driver->report_mode

  • « mysqli_get_links_stats
  • mysqli::set_opt »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Alias de mysqli_driver->report_mode

mysqli_report

(PHP 5, PHP 7)

mysqli_report — Alias de mysqli_driver->report_mode

Descripción

Esta función es un alias de: mysqli_driver->report_mode


Alias de mysqli_options

  • « mysqli_report
  • Registro de cambios »
  • PHP Manual
  • Alias y Funciones de MySQLi obsoletos
  • Alias de mysqli_options

mysqli::set_opt

mysqli_set_opt

(PHP 5, PHP 7)

mysqli::set_opt -- mysqli_set_opt — Alias de mysqli_options()

Descripción

Esta función es un alias de mysqli_options().


Registro de cambios

A las clases/funciones/métodos de esta extensión se han realizado los siguientes cambios.

Version | Function | Description
5.6.16 | mysqli::real_connect | Se añadió la bandera MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT para el Controlador Nativo de MySQL
5.5.0 | mysqli::commit | Se añadieron los parámetros flags y name.
 | mysqli::options | Se añadieron las opciones MYSQLI_SERVER_PUBLIC_KEY y MYSQLI_SERVER_PUBLIC_KEY.
 | mysqli::rollback | Se añadieron los parámetros flags y name.
5.3.4 | mysqli_driver::$report_mode | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.
5.3.0 | mysqli::__construct | Se añadió la capacidad de conexiones persistentes.
 | mysqli::options | Se añadierons las opciones MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, y MYSQLI_OPT_SSL_VERIFY_SERVER_CERT.
 | mysqli::query | Se agregó la posibilidad de realizar consultas asíncronas.
5.2.15 | mysqli_driver::$report_mode | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.


API original de MySQL

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Registro de cambios
  • Constantes predefinidas
  • Ejemplos
    • Ejemplo general de la extensión MySQL
  • Funciones de MySQL
    • mysql_affected_rows — Obtiene el número de filas afectadas en la anterior operación de MySQL
    • mysql_client_encoding — Devuelve el nombre del conjunto de caracteres
    • mysql_close — Cerrar una conexión de MySQL
    • mysql_connect — Abre una conexión al servidor MySQL
    • mysql_create_db — Crea una base de datos MySQL
    • mysql_data_seek — Mueve el puntero de resultados interno
    • mysql_db_name — Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs
    • mysql_db_query — Selecciona una base de datos y ejecuta una consulta sobre la misma
    • mysql_drop_db — Elimina (DROP) una base de datos MySQL
    • mysql_errno — Devuelve el valor numérico del mensaje de error de la última operación MySQL
    • mysql_error — Devuelve el texto del mensaje de error de la operación MySQL anterior
    • mysql_escape_string — Escapa una cadena para ser usada en mysql_query
    • mysql_fetch_array — Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
    • mysql_fetch_assoc — Recupera una fila de resultados como un array asociativo
    • mysql_fetch_field — Obtiene la información de una columna de un resultado y la devuelve como un objeto
    • mysql_fetch_lengths — Obtiene la longitud de cada salida en un resultado
    • mysql_fetch_object — Recupera una fila de resultados como un objeto
    • mysql_fetch_row — Obtiene una fila de resultados como un array numérico
    • mysql_field_flags — Obtiene las banderas asociadas al campo especificado de un resultado
    • mysql_field_len — Devuelve la longitud del campo especificado
    • mysql_field_name — Obtiene el nombre del campo especificado de un resultado
    • mysql_field_seek — Establece el puntero del resultado en un índice de campo específicado
    • mysql_field_table — Obtiene el nombre de la tabla en la que está el campo especificado
    • mysql_field_type — Obtiene el tipo del campo especificado de un resultado
    • mysql_free_result — Libera la memoria del resultado
    • mysql_get_client_info — Obtiene información del cliente MySQL
    • mysql_get_host_info — Obtener información del anfitrión de MySQL
    • mysql_get_proto_info — Obtener información del protocolo MySQL
    • mysql_get_server_info — Obtiene información del servidor MySQL
    • mysql_info — Obtiene información sobre la consulta más reciente
    • mysql_insert_id — Obtiene el ID generado en la última consulta
    • mysql_list_dbs — Lista las bases de datos disponibles en un servidor MySQL
    • mysql_list_fields — Lista los campos de una tabla de MySQL
    • mysql_list_processes — Lista los procesos de MySQL
    • mysql_list_tables — Enumerar las tablas de una base de datos MySQL
    • mysql_num_fields — Obtiene el número de campos de un resultado
    • mysql_num_rows — Obtener el número de filas de un conjunto de resultados
    • mysql_pconnect — Abre una conexión persistente a un servidor MySQL
    • mysql_ping — Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión
    • mysql_query — Enviar una consulta MySQL
    • mysql_real_escape_string — Escapa caracteres especiales en una cadena para su uso en una sentencia SQL
    • mysql_result — Obtener datos de resultado
    • mysql_select_db — Seleccionar una base de datos MySQL
    • mysql_set_charset — Establece el conjunto de caracteres del cliente
    • mysql_stat — Obtiene el estado actual del sistema
    • mysql_tablename — Obtiene el nombre de la tabla de un campo
    • mysql_thread_id — Devuelve el ID del hilo actual
    • mysql_unbuffered_query — Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados


Introducción

Esta extensión está obsoleta a partir de PHP 5.5.0, por lo que ha sido eliminada a partir de PHP 7.0.0. En su lugar, se debería utilizar la extensión mysqli o PDO_MySQL. Véase también la Información general de la API de MySQL para obtener ayuda al elegir una API de MySQL.

Con estas funciones se puede acceder a servidores de bases de datos de MySQL. Se puede encontrar más información sobre MySQL en » http://www.mysql.com/.

La documentación de MySQL puede encontrarse en » http://dev.mysql.com/doc/.


Requerimientos

Para poder contar con estas funciones, debe compilar PHP con el soporte para MySQL.

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:


Instalación

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

Para compilar, simplemente usar la opción de configuración --with-mysql[=DIR] donde opcionalmente [DIR] apunta al directorio de instalación de MySQL.

Aunque esta extensión de MySQL es compatible con MySQL 4.1.0 y superior, no da soporte a las funcionalidades extra que estas versiones proveen. Para ello usar la extensión MySQLi.

Si se quisiera instalar la extensión de MySQL junto con la extensión MySQLi se debe usar la misma libreria de cliente para evitar cualquier conflicto.

Instalación en Sistemas Linux

Nota: [DIR] es la ruta a los ficheros de la biblioteca cliente de MySQL (cabeceras y bibliotecas), los cuales se pueden descargar desde » MySQL.

Matriz de soporte en tiempo de compilación de ext/mysql
Versión de PHP | Por defecto | Opciones de configuración: mysqlnd | Opciones de configuración: libmysqlclient | Historial de cambios
4.x.x | libmysqlclient | No Disponible | --without-mysql to disable | MySQL habilitada por omisión, las bibliotecas cliente de MySQL están incluidas
5.0.x, 5.1.x, 5.2.x | libmysqlclient | No Disponible | --with-mysql=[DIR] | MySQL ya no está habilitada de forma predeterminada, y las bibliotecas cliente de MySQL ya no están integradas
5.3.x | libmysqlclient | --with-mysql=mysqlnd | --with-mysql=[DIR] | mysqlnd ahora está disponible
5.4.x | mysqlnd | --with-mysql | --with-mysql=[DIR] | mysqlnd ahora es el predeterminado

Instalación en sistemas Windows

PHP 5.0.x, 5.1.x, 5.2.x

MySQL ya no está activado por defecto, así la DLL php_mysql.dll debe ser habilitada dentro de php.ini. Además, PHP necesita acceso a la libreria de cliente de MySQL. Un archivo llamado libmysql.dll que está incluido en la distribución de PHP de Windows, y así PHP se comunica con MySQL, este fichero necesita estar disponible en el PATH de los sistemas Windows. Para información sobre como hacerlo ver el FAQ titulado "Cómo agrego mi directorio de PHP a PATH en Windows". Aunque copiando libmysql.dll al directorio del sistema de Windows también funcionará (ya que el directorio del sistema está por defecto en el PATH del sistema), pero no está recomendado.

Como ocurre con cualquier otra extensión de PHP (tal como php_mysql.dll), la directiva de PHP extension_dir, debe establecer el directorio donde estan localizada las extensiones de PHP. Ver también el Manual de instrucciónes de instalación en Windows. Un ejemplo de valor de extension_dir para PHP 5 es c:\php\ext

Nota:

Si al iniciar el servidor web se produce un error similar al siguiente: "Unable to load dynamic library './php_mysql.dll'", esto se debe a que php_mysql.dll y/o libmysql.dll no puede ser encontrado por el sistema.

PHP 5.3.0+

El Controlador Nativo de MySQL está habilitado por omisión. Incluya php_mysql.dll, pero libmysql.dll ya no es necesario o usado.

Notas de la instalación de MySQL

Advertencia

Se pueden encontrar errores y problemas de inicio de PHP al cargar esta extensión en conjunción con la extensión recode. Para más información ver la extension recode.

Nota:

Si fueran necesarios otro juego de caracteres distinto de latin (predeterminado), se ha de instalar externamente (no incluido) libmysqlclient con el soporte para el juego de caracteres compilado.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de MySQL
Nombre | Por defecto | Cambiable | Historial de cambios
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | Disponible desde PHP 4.0.1.
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP <= 4.3.2. Disponible desde PHP 4.3.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mysql.allow_local_infile integer

Permite acceder, desde la perspectiva de PHP, a archivos locales con la sentencia LOAD DATA

mysql.allow_persistent boolean

Si se permiten conexiones persistentes para MySQL.

mysql.max_persistent integer

El número máximo de conexiones persistentes de MySQL por proceso.

mysql.max_links integer

El número máximo de conexiones MySQL por proceso, incluyendo las conexiones persistentes.

mysql.trace_mode boolean

Modo de rastreo. Cuando mysql.trace_mode está habilitada, los warnings para exploraciones de tablas/índices, o conjuntos de resultados no libres y errores de SQL serán mostrados. (Introducido en PHP 4.3.0)

mysql.default_port string

El número de puerto TCP predeterminado para usar cuando se conecta con el servidor de la base de datos si no hay otro puerto especificado. Si no se especifica un puerto predeterminado, este será obtenido desde la variable de entorno MYSQL_TCP_PORT, la entrada mysql-tcp en /etc/services o la constante en tiempo de compilación MYSQL_PORT, en ese orden. Win32 solo usará la constante MYSQL_PORT.

mysql.default_socket string

El nombre predeterminado del socket para usar cuando se conecta a un servidor local de base de datos, si no hay otro nombre de socket especificado.

mysql.default_host string

El host del servidor predeterminado para usar cuando se conecta al servidor de la base de datos, si no hay otro host especificado. No se aplica en modo seguro de SQL.

mysql.default_user string

El nombre de usuario predeterminado para usar cuando se conecta al servidor de la base de datos, si no hay otro nombre especificado. No se aplica en modo seguro de SQL.

mysql.default_password string

La contraseña predeterminada para usar cuando se conecta al servidor de la base de datos, si no hay otra contraseña especificada. No se aplica en modo seguro de SQL.

mysql.connect_timeout integer

Tiempo de espera de conexión en segundos. En GNU Linux este tiempo de espera es también usado para esperar la primera respuesta del servidor.


Tipos de recursos

Hay dos tipos de recursos usados en el módulo de MySQL. El primero es el identificador del enlace para una conexión con la base de datos. El segundo es un recurso que contiene el resultado de una consulta.


Registro de cambios

A las clases/funciones/métodos de esta extensión se han realizado los siguientes cambios.

Registro de cambios general para la extensión ext/mysql

Este registro de cambios hace referencia a la extensión ext/mysql.

Cambios globales ext/mysql

La lista siguiente recoge los cambios realizados sobre las funciones de la extensión ext/mysql.

Versión Descripción
7.0.0

Esta extensión ha sido eliminada de PHP. Para más detalles, véase Elegir una API.

5.5.0

Esta extensión es obsoleta. Conectar a una base de datos MySQL vía mysql_connect(), mysql_pconnect() o una conexión implícita a través de alguna otra mysql_* función devolverá un error E_DEPRECATED .

5.5.0

Todas las funciones antiguas y alias obsoletos, ahora devolverán errores E_DEPRECATED . Estas funciones son:

mysql(), mysql_fieldname(), mysql_fieldtable(), mysql_fieldlen(), mysql_fieldtype(), mysql_fieldflags(), mysql_selectdb(), mysql_createdb(), mysql_dropdb(), mysql_freeresult(), mysql_numfields(), mysql_numrows(), mysql_listdbs(), mysql_listtables(), mysql_listfields(), mysql_db_name(), mysql_dbname(), mysql_tablename(), and mysql_table_name().

Cambios sobre las funciones existentes

La siguiente lista es una compilación de las entradas del registro de cambios de las funciones ext/mysql.

Version | Function | Description
5.5.0 | mysql_connect | Esta función generará un error de nivel E_DEPRECATED.
 | mysql_db_name | La función mysql_list_dbs es obsoleta, por lo que emite un error de nivel E_DEPRECATED.
 | mysql_pconnect | Esta función generará un error de nivel E_DEPRECATED.
 | mysql_tablename | La función mysql_tablename es obsoleta, por lo que emite un error de nivel E_DEPRECATED.
5.3.0 | mysql_db_query | Ésta función ahora lanza ahora un aviso E_DEPRECATED.
 | mysql_escape_string | Ahora, esta función lanza un aviso E_DEPRECATED.
4.3.7 | mysql_list_tables | Esta función quedó obsoleta.
4.3.0 | mysql_escape_string | Esta función será eliminada, no la utilice. En su lugar utilice mysql_real_escape_string.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Es posible especificar flags adicionales para el cliente en las funciones mysql_connect() y mysql_pconnect(). Están definidas las siguientes constantes:

Constantes del cliente MySQL
Constante | Descripción
MYSQL_CLIENT_COMPRESS | Usar el procolo de compresión
MYSQL_CLIENT_IGNORE_SPACE | Permitir espacios despues de los nombres de función
MYSQL_CLIENT_INTERACTIVE | Permitir unos segundos interactive_timeout seconds (en vez de wait_timeout) de inactividad antes del cierre de la conexión.
MYSQL_CLIENT_SSL | Usar encriptación SSL. Este flag solo esta disponible con la versión de la libreria de cliente de MySQL 4.x o superior. La versión 3.23.x se incluye tanto con PHP 4 como con los binarios para Windows de PHP 5.

La función mysql_fetch_array() utiliza una constante para los diferentes tipos de arrays resultantes. Estan definidas las siguientes constantes:

MySQL fetch constantes
Constante | Descripción
MYSQL_ASSOC | Las columnas son devueltas en un array que tiene los nombres de los campos como los índices del array.
MYSQL_BOTH | Las columnas son devueltas en un array que tiene tanto índice numérico como un índice con los nombres de los campos.
MYSQL_NUM | Las columnas son devueltas en un array que tiene un índice numérico para los campos. Este índice empieza con 0, con el primer campo en el resultado.


  • « Constantes predefinidas
  • Ejemplo general de la extensión MySQL »
  • PHP Manual
  • MySQL (Original)
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplo general de la extensión MySQL


Ejemplo general de la extensión MySQL

Este simple ejemplo muestra como conectar, ejecutar una consulta, imprimir las filas resultantes y desconectar a una base de datos MySQL.

Ejemplo #1 Ejemplo general de la extensión MySQL

<?php
// Conectando, seleccionando la base de datos
$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')
    or die('No se pudo conectar: ' . mysql_error());
echo 'Connected successfully';
mysql_select_db('my_database') or die('No se pudo seleccionar la base de datos');

// Realizar una consulta MySQL
$query = 'SELECT * FROM my_table';
$result = mysql_query($query) or die('Consulta fallida: ' . mysql_error());

// Imprimir los resultados en HTML
echo "<table>\n";
while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Liberar resultados
mysql_free_result($result);

// Cerrar la conexión
mysql_close($link);
?>


Funciones de MySQL

Notas

Nota:

Muchas funciones de MySQL aceptan link_identifier como último parámetro. Si no se proviene, se utilizará la última conexión abierta. Si esta no existe, se intentará establecer conexión con el parámetro predeterminado definido en php.ini. Si no hay éxito, las funciones devuelven false

Tabla de contenidos

  • mysql_affected_rows — Obtiene el número de filas afectadas en la anterior operación de MySQL
  • mysql_client_encoding — Devuelve el nombre del conjunto de caracteres
  • mysql_close — Cerrar una conexión de MySQL
  • mysql_connect — Abre una conexión al servidor MySQL
  • mysql_create_db — Crea una base de datos MySQL
  • mysql_data_seek — Mueve el puntero de resultados interno
  • mysql_db_name — Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs
  • mysql_db_query — Selecciona una base de datos y ejecuta una consulta sobre la misma
  • mysql_drop_db — Elimina (DROP) una base de datos MySQL
  • mysql_errno — Devuelve el valor numérico del mensaje de error de la última operación MySQL
  • mysql_error — Devuelve el texto del mensaje de error de la operación MySQL anterior
  • mysql_escape_string — Escapa una cadena para ser usada en mysql_query
  • mysql_fetch_array — Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_fetch_assoc — Recupera una fila de resultados como un array asociativo
  • mysql_fetch_field — Obtiene la información de una columna de un resultado y la devuelve como un objeto
  • mysql_fetch_lengths — Obtiene la longitud de cada salida en un resultado
  • mysql_fetch_object — Recupera una fila de resultados como un objeto
  • mysql_fetch_row — Obtiene una fila de resultados como un array numérico
  • mysql_field_flags — Obtiene las banderas asociadas al campo especificado de un resultado
  • mysql_field_len — Devuelve la longitud del campo especificado
  • mysql_field_name — Obtiene el nombre del campo especificado de un resultado
  • mysql_field_seek — Establece el puntero del resultado en un índice de campo específicado
  • mysql_field_table — Obtiene el nombre de la tabla en la que está el campo especificado
  • mysql_field_type — Obtiene el tipo del campo especificado de un resultado
  • mysql_free_result — Libera la memoria del resultado
  • mysql_get_client_info — Obtiene información del cliente MySQL
  • mysql_get_host_info — Obtener información del anfitrión de MySQL
  • mysql_get_proto_info — Obtener información del protocolo MySQL
  • mysql_get_server_info — Obtiene información del servidor MySQL
  • mysql_info — Obtiene información sobre la consulta más reciente
  • mysql_insert_id — Obtiene el ID generado en la última consulta
  • mysql_list_dbs — Lista las bases de datos disponibles en un servidor MySQL
  • mysql_list_fields — Lista los campos de una tabla de MySQL
  • mysql_list_processes — Lista los procesos de MySQL
  • mysql_list_tables — Enumerar las tablas de una base de datos MySQL
  • mysql_num_fields — Obtiene el número de campos de un resultado
  • mysql_num_rows — Obtener el número de filas de un conjunto de resultados
  • mysql_pconnect — Abre una conexión persistente a un servidor MySQL
  • mysql_ping — Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión
  • mysql_query — Enviar una consulta MySQL
  • mysql_real_escape_string — Escapa caracteres especiales en una cadena para su uso en una sentencia SQL
  • mysql_result — Obtener datos de resultado
  • mysql_select_db — Seleccionar una base de datos MySQL
  • mysql_set_charset — Establece el conjunto de caracteres del cliente
  • mysql_stat — Obtiene el estado actual del sistema
  • mysql_tablename — Obtiene el nombre de la tabla de un campo
  • mysql_thread_id — Devuelve el ID del hilo actual
  • mysql_unbuffered_query — Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados


Obtiene el número de filas afectadas en la anterior operación de MySQL

  • « Funciones de MySQL
  • mysql_client_encoding »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el número de filas afectadas en la anterior operación de MySQL

mysql_affected_rows

(PHP 4, PHP 5)

mysql_affected_rows — Obtiene el número de filas afectadas en la anterior operación de MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_affected_rows()
  • PDOStatement::rowCount()

Descripción

mysql_affected_rows ( resource $link_identifier = NULL ) : int

Obtiene el número de filas afectadas por la última consulta INSERT, UPDATE, REPLACE o DELETE asociada con link_identifier.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve el número de filas afectadas en caso de éxito, y -1 si la última consulta falló.

Si la consulta anterior fue DELETE con ninguna cláusula WHERE, todos los registros habrán sido borrados de la tabla, aunque ésta función devolverá cero con una versión anterior a MySQL 4.1.2.

Al utilizar UPDATE, MySQL no actualiza las columnas donde el nuevo valor es el mismo que el anterior. Esto crea la posibilidad de que mysql_affected_rows() no pueda equivaler en realidad al número de filas encontradas, solamente el número de filas que estuvieron literalmente afectadas por la consulta.

La sentencia REPLACE primero borra el registro con la misma clave primaria y luego inserta el nuevo registro. Esta función devuelve el número de registros borrados más el número de registros insertados.

En el caso de consultas "INSERT ... ON DUPLICATE KEY UPDATE", el valor devuelto será 1 si se realizó una inserción, o 2 para una actualización de una fila existente.

Ejemplos

Ejemplo #1 Ejemplo de mysql_affected_rows()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar: ' . mysql_error());
}
mysql_select_db('mibd');

/* Esto debería devolver el número correcto de registros borrados */
mysql_query('DELETE FROM mitabla WHERE id < 10');
printf("Registros borrados: %d\n", mysql_affected_rows());

/* con una clausula WHERE que nunca es verdad, debería devolver 0 */
mysql_query('DELETE FROM mitabla WHERE 0');
printf("Registros borrados: %d\n", mysql_affected_rows());
?>

El resultado del ejemplo sería algo similar a:

Registros borrados: 10
Registros borrados: 0

Ejemplo #2 Ejemplo de mysql_affected_rows() al utilizar transacciones

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar: ' . mysql_error());
}
mysql_select_db('mibd');

/* Actualizar registros */
mysql_query("UPDATE mitabla SET usado=1 WHERE id < 10");
printf ("Registros actualizados: %d\n", mysql_affected_rows());
mysql_query("COMMIT");
?>

El resultado del ejemplo sería algo similar a:

Registros actualizados: 10

Notas

Nota: Transacciones

Si se usan transacciones, es necesario llamar a mysql_affected_rows() después de una consulta INSERT, UPDATE, o DELETE, no después del COMMIT.

Nota: Sentencias SELECT

Para conocer el número de filas devueltas por un SELECT, es posible usar mysql_num_rows().

Nota: Claves Foráneas en Cascada

mysql_affected_rows() no cuenta la filas afectadas implícitamente a través del uso de ON DELETE CASCADE y/o ON UPDATE CASCADE en las restricciones de las claves foráneas.

Ver también

  • mysql_num_rows() - Obtener el número de filas de un conjunto de resultados
  • mysql_info() - Obtiene información sobre la consulta más reciente


Devuelve el nombre del conjunto de caracteres

  • « mysql_affected_rows
  • mysql_close »
  • PHP Manual
  • Funciones de MySQL
  • Devuelve el nombre del conjunto de caracteres

mysql_client_encoding

(PHP 4 >= 4.3.0, PHP 5)

mysql_client_encoding — Devuelve el nombre del conjunto de caracteres

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_character_set_name()

Descripción

mysql_client_encoding ( resource $link_identifier = NULL ) : string

Recupera la variable character_set de MySQL.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve el nombre del conjunto de caracteres predeterminado de la conexión actual.

Ejemplos

Ejemplo #1 Ejemplo de mysql_client_encoding()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$conjunto_caracteres = mysql_client_encoding($enlace);

echo "El conjunto de caracteres actual es: $conjunto_caracteres\n";
?>

El resultado del ejemplo sería algo similar a:

El conjunto de caracteres actual es: latin1

Ver también

  • mysql_set_charset() - Establece el conjunto de caracteres del cliente
  • mysql_real_escape_string() - Escapa caracteres especiales en una cadena para su uso en una sentencia SQL


Cerrar una conexión de MySQL

  • « mysql_client_encoding
  • mysql_connect »
  • PHP Manual
  • Funciones de MySQL
  • Cerrar una conexión de MySQL

mysql_close

(PHP 4, PHP 5)

mysql_close — Cerrar una conexión de MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_close()
  • PDO: Asignar el valor de null al objeto PDO

Descripción

mysql_close ( resource $link_identifier = NULL ) : bool

mysql_close() cierra la conexión no persistente al servidor de MySQL que está asociada con el identificador de enlace especificado. Si link_identifier no se especifica, se usará el último enlace abierto.

Las conexiones de MySQL no persistentes y los conjuntos de resultados son automáticamente destruidos cuando un script de PHP finaliza su ejecución. Por tanto, aunque el cierre explícito de conexiones abiertas y la liberación de conjuntos de resultados sean opcionales, se recomienda hacerlos. Así, se devolverán inmediatamente los recursos a PHP y a MySQL, lo que puede mejorar el rendimiento. Para información detalla, véase la liberación de recursos

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el enlace, se asumirá el último enlace abierto por mysql_connect(). Si no se encuentra o no se puede establecer la conexión se producirá un error del nivel E_WARNING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_close()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar: ' . mysql_error());
}
echo 'Conectado con éxito';
mysql_close($enlace);
?>

El resultado del ejemplo sería:

Conectado con éxito

Notas

Nota:

mysql_close() no cerrará los enlaces persistentes creados por mysql_pconnect(). Para más detalles, véase la página del manual sobre conexiones persistentes.

Ver también

  • mysql_connect() - Abre una conexión al servidor MySQL
  • mysql_free_result() - Libera la memoria del resultado


Abre una conexión al servidor MySQL

  • « mysql_close
  • mysql_create_db »
  • PHP Manual
  • Funciones de MySQL
  • Abre una conexión al servidor MySQL

mysql_connect

(PHP 4, PHP 5)

mysql_connect — Abre una conexión al servidor MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_connect()
  • PDO::__construct()

Descripción

mysql_connect ( string $server = ini_get("mysql.default_host") , string $username = ini_get("mysql.default_user") , string $password = ini_get("mysql.default_password") , bool $new_link = false , int $client_flags = 0 ) : resource

Abre o reutiliza una conexión a un servidor MySQL.

Parámetros

server

El servidor MySQL. También se puede incluir un número de puerto. P.ej. "nombre_anfitrión:puerto" o una ruta a un socket local, p.ej. ":/ruta/al/socket" para el servidor local.

Si la directiva PHP mysql.default_host no está definida (por defecto), el valor por defecto es 'localhost:3306'. En modo seguro de SQL, éste parámetro es ignorado y siempre se usa el valor 'localhost:3306'.

username

El nombre de usuario. El valor por defecto está definido por mysql.default_user. En modo seguro de SQL, éste parámetro es ignorado y se usa el nombre de usuario que posee el proceso del servidor.

password

La contraseña. El valor por defecto está definido por mysql.default_password. En modo seguro de SQL, éste parámetro es ignorado y se usa la contraseña vacía.

new_link

Si se realiza una segunda llamada a mysql_connect() con los mismos argumentos, un nuevo enlace no será establecido, pero en su lugar, será devuelto el identificador de enlace del enlace ya abierto. El parámetro new_link modifica éste comportamiento y hace que mysql_connect() siempre abra un nuevo enlace, aun si mysql_connect() fue llamada antes con los mismos parámetros. En modo seguro de SQL, éste parámetro es ignorado.

client_flags

El parámetro client_flags puede ser una combinación de las siguientes constantes: 128 (habilita el manejo de LOAD DATA LOCAL), MYSQL_CLIENT_SSL, MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE o MYSQL_CLIENT_INTERACTIVE. Lea la sección sobre Constantes del cliente MySQL para más información. En modo seguro de SQL, éste parámetro es ignorado.

Valores devueltos

Devuelve un identificador de enlace de MySQL en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Esta función generará un error de nivel E_DEPRECATED.

Ejemplos

Ejemplo #1 Ejemplo de mysql_connect()

<?php
$enlace =  mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
echo 'Conectado satisfactoriamente';
mysql_close($enlace);
?>

Ejemplo #2 Ejemplo de mysql_connect() usando la sintaxis nombre_anfitrión:puerto

<?php
// nos  conectamos a ejemplo.com y al puerto 3307
$enlace = mysql_connect('ejemplo.com:3307',  'usuario_mysql', 'contraseña_mysql');
if  (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
echo 'Conectado satisfactoriamente';
mysql_close($enlace);

// nos conectamos a ejemplo.com y al puerto 3307
$enlace = mysql_connect('127.0.0.1:3307', 'usuario_mysql',  'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
echo 'Conectado satisfactoriamente';
mysql_close($enlace);
?>

Ejemplo #3 Ejemplo de mysql_connect() usando la sintaxis ":/rota/al/socket"

<?php
// nos  conectamos a localhost y a la toma ej. /tmp/mysql.sock

// variante 1: omitir el localhost
$enlace = mysql_connect(':/tmp/mysql', 'usuario_mysql',  'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
echo 'Conectado satisfactoriamente';
mysql_close($enlace);

// variante 2: con localhost
$enlace = mysql_connect('localhost:/tmp/mysql.sock',  'usuario_mysql', 'contraseña_mysql');
if  (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
echo 'Conectado  satisfactoriamente';
mysql_close($enlace);
?>

Notas

Nota:

Siempre que se especifique "localhost" o "localhost:puerto" como servidor, la biblioteca cliente de MySQL invalidará esto e intentará conectarse a un socket local (llamada tubería en Windows). Si se quiere usar TCP/IP, se ha de utilizar "127.0.0.1" en lugar de "localhost". Si la biblioteca cliente de MySQL intenta conectarse al socket local erróneo, se debería establecer el ruta correcta como en la configuración de PHP y dejar el campo del servidor en blanco.

Nota:

El enlace al servidor se cerrará tan pronto finalice la ejecución del script, a menos que se cierre antes por una llamada explícita a mysql_close().

Nota:

Se pPuede suprimir el mensaje de error en caso de fallo anteponiendo un @ al nombre de la función.

Nota:

El error "Can't create TCP/IP socket (10106)" normalmente significa que la directiva de configuración variables_order no contiene el carácter E. En Windows, si el entorno no es copiadola variable de entorno SYSTEMROOT no estará disponible y PHP tendrá problemas al cargar Winsock.

Ver también

  • mysql_pconnect() - Abre una conexión persistente a un servidor MySQL
  • mysql_close() - Cerrar una conexión de MySQL


Crea una base de datos MySQL

  • « mysql_connect
  • mysql_data_seek »
  • PHP Manual
  • Funciones de MySQL
  • Crea una base de datos MySQL

mysql_create_db

(PHP 4, PHP 5)

mysql_create_db — Crea una base de datos MySQL

Advertencia

Esta función está obsoleta en PHP 4.3.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • mysqli_query()
  • PDO::query()

Descripción

mysql_create_db ( string $database_name , resource $link_identifier = NULL ) : bool

mysql_create_db() intenta crear una nueva base de datos en el servidor asociado con el identificador de enlace especificado.

Parámetros

database_name

El nombre de la base de datos a crear.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo alternativo de mysql_create_db()

La función mysql_create_db() está obsoleta. Es preferible el uso de mysql_query() para emitir una sentencia CREATE DATABASE de sql en su lugar.

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}

$sql = 'CREATE DATABASE mi_bd';
if (mysql_query($sql, $enlace)) {
    echo "La base de datos mi_bd se creó correctamente\n";
} else {
    echo 'Error al crear la base de datos: ' . mysql_error() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

La base de datos mi_bd se creó correctamente

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_createdb()

Nota:

Ésta función no estará disponible si la extensión MySQL fue construida con una biblioteca cliente MySQL 4.x.

Ver también

  • mysql_query() - Enviar una consulta MySQL
  • mysql_select_db() - Seleccionar una base de datos MySQL


Mueve el puntero de resultados interno

  • « mysql_create_db
  • mysql_db_name »
  • PHP Manual
  • Funciones de MySQL
  • Mueve el puntero de resultados interno

mysql_data_seek

(PHP 4, PHP 5)

mysql_data_seek — Mueve el puntero de resultados interno

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_data_seek()
  • PDO::FETCH_ORI_ABS

Descripción

mysql_data_seek ( resource $result , int $row_number ) : bool

mysql_data_seek() mueve el puntero de filas interno del resultado de MySQL asociado con el identificador de resultado especificado para apuntar al número de fila especificada. La siguiente llamada a una función de obtención de MySQL, tal como mysql_fetch_assoc(), devolverá esa fila.

row_number empieza en 0. row_number debería ser un valor en el rango de 0 a mysql_num_rows() -1. Sin embargo, si el conjunto de resultados esta vacío (mysql_num_rows() == 0), una búsqueda a 0 fallará con un E_WARNING y mysql_data_seek() devolverá false.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

row_number

Número de la fila deseada del puntero de resultados nuevo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_data_seek()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}
$bd_seleccionada = mysql_select_db('bd_muestra');
if (!$bd_seleccionada) {
    die('La base de datos no pudo seleccionarse: ' . mysql_error());
}
$consulta = 'SELECT apellido, nombre FROM amigos';
$resultado = mysql_query($consulta);
if (!$resultado) {
    die('La consulta falló: ' . mysql_error());
}
/* obtención de filas en orden inverso */
for ($i = mysql_num_rows($resultado) - 1; $i >= 0; $i--) {
    if (!mysql_data_seek($resultado, $i)) {
        echo "No se encuenta la fila $i: " . mysql_error() . "\n";
        continue;
    }

    if (!($fila = mysql_fetch_assoc($resultado))) {
        continue;
    }

    echo $fila['apellido'] . ' ' . $fila['nombre'] . "<br />\n";
}

mysql_free_result($resultado);
?>

Notas

Nota:

La función mysql_data_seek() puede ser usada solamente junto con mysql_query(), y no con mysql_unbuffered_query().

Ver también

  • mysql_query() - Enviar una consulta MySQL
  • mysql_num_rows() - Obtener el número de filas de un conjunto de resultados
  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_fetch_array() - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_fetch_object() - Recupera una fila de resultados como un objeto


Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs

  • « mysql_data_seek
  • mysql_db_query »
  • PHP Manual
  • Funciones de MySQL
  • Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs

mysql_db_name

(PHP 4, PHP 5)

mysql_db_name — Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs()

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • Consulta: SELECT DATABASE()

Descripción

mysql_db_name ( resource $result , int $row , mixed $field = NULL ) : string

Recupera el nombre de la base de datos de una llamada a mysql_list_dbs().

Parámetros

result

El puntero de resultados desde una llamada a mysql_list_dbs().

row

El índice dentro del conjunto de resultados.

field

El nombre del campo.

Valores devueltos

Devuelve el nombre de la base de datos en caso de éxito, y false en caso de error. Si se devuelve false, se usa mysql_error() para determinar la naturaleza del error.

Historial de cambios

Versión | Descripción
5.5.0 | La función mysql_list_dbs() es obsoleta, por lo que emite un error de nivel E_DEPRECATED.

Ejemplos

Ejemplo #1 Ejemplo de mysql_db_name()

<?php
error_reporting(E_ALL);

$enlace = mysql_connect('anfitrión_bd', 'nombre_usuario', 'contraseña');
$lista_bd = mysql_list_dbs($enlace);

$i = 0;
$cuenta = mysql_num_rows($lista_bd);
while ($i < $cuenta) {
    echo mysql_db_name($lista_bd, $i) . "\n";
    $i++;
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_dbname()

Ver también

  • mysql_list_dbs() - Lista las bases de datos disponibles en un servidor MySQL
  • mysql_tablename() - Obtiene el nombre de la tabla de un campo


Selecciona una base de datos y ejecuta una consulta sobre la misma

  • « mysql_db_name
  • mysql_drop_db »
  • PHP Manual
  • Funciones de MySQL
  • Selecciona una base de datos y ejecuta una consulta sobre la misma

mysql_db_query

(PHP 4, PHP 5)

mysql_db_query — Selecciona una base de datos y ejecuta una consulta sobre la misma

Advertencia

Esta función está obsoleta en PHP 5.3.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • mysqli_select_db() y luego la consulta
  • PDO::__construct()

Descripción

mysql_db_query ( string $database , string $query , resource $link_identifier = NULL ) : resource

mysql_db_query() selecciona una base de datos y ejecuta una consulta en ella.

Parámetros

database

El nombre de la base de datos que va a ser seleccionada.

query

La consulta MySQL.

Los datos dentro de la consulta deben ser escapados apropiadamente.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve un recurso de resultados de MySQL positivo al resultado de la consulta, o false en caso de error. La función también retorna true/false para las consultas INSERT/UPDATE/DELETE indicando éxito/fallo.

Historial de cambios

Versión | Descripción
5.3.0 | Ésta función ahora lanza ahora un aviso E_DEPRECATED.

Ejemplos

Ejemplo #1 Ejemplo alternativo de mysql_db_query()

<?php

if (!$enlace = mysql_connect('anfitrión_mysql', 'usuario_mysql', 'contraseña_mysql')) {
    echo 'No pudo conectarse a mysql';
    exit;
}

if (!mysql_select_db('nombre_bd_mysql', $enlace)) {
    echo 'No pudo seleccionar la base de datos';
    exit;
}

$sql       = 'SELECT foo FROM bar WHERE id = 42';
$resultado = mysql_query($sql, $enlace);

if (!$resultado) {
    echo "Error de BD, no se pudo consultar la base de datos\n";
    echo "Error MySQL: ' . mysql_error();
    exit;
}

while ($fila = mysql_fetch_assoc($resultado)) {
    echo $fila['foo'];
}

mysql_free_result($resultado);

?>

Notas

Nota:

Se ha de tener en cuenta que ésta función NO vuelve a la base de datos a la que se estaba conectado anteriormente. En otras palabras, no se puede utilizar ésta función para ejecutar temporalmente una consulta SQL en otra base de datos; se tendría que hacer el cambio manualmente. Se recomienda encarecidamente usar la sintaxis basedatos.tabla en las consultas SQL o mysql_select_db() en lugar de esta función.

Ver también

  • mysql_query() - Enviar una consulta MySQL
  • mysql_select_db() - Seleccionar una base de datos MySQL


Elimina (DROP) una base de datos MySQL

  • « mysql_db_query
  • mysql_errno »
  • PHP Manual
  • Funciones de MySQL
  • Elimina (DROP) una base de datos MySQL

mysql_drop_db

(PHP 4, PHP 5)

mysql_drop_db — Elimina (DROP) una base de datos MySQL

Advertencia

Esta función está obsoleta en PHP 4.3.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • Ejecutar una consulta DROP DATABASE

Descripción

mysql_drop_db ( string $database_name , resource $link_identifier = NULL ) : bool

mysql_drop_db() intenta eliminar (remover) una base de datos entera del servidor asociado con el identificador de enlace especificado. Esta función es obsoleta; es preferible usar mysql_query() para ejecutar una sentencia SQL DROP DATABASE en su lugar.

Parámetros

database_name

El nombre de la base de datos que va a ser eliminada.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo alternativo de mysql_drop_db()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No pudo conectarse: ' . mysql_error());
}

$sql = 'DROP DATABASE mi_bd';
if (mysql_query($sql, $enlace)) {
    echo "La base de datos mi_bd fue eliminada con éxito\n";
} else {
    echo 'Error al eliminar la base de datos: ' . mysql_error() . "\n";
}
?>

Notas

Advertencia

Ésta función no estará disponible si la extensión MySQL fue construida con una biblioteca cliente MySQL 4.x.

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_dropdb()

Ver también

  • mysql_query() - Enviar una consulta MySQL


Devuelve el valor numérico del mensaje de error de la última operación MySQL

  • « mysql_drop_db
  • mysql_error »
  • PHP Manual
  • Funciones de MySQL
  • Devuelve el valor numérico del mensaje de error de la última operación MySQL

mysql_errno

(PHP 4, PHP 5)

mysql_errno — Devuelve el valor numérico del mensaje de error de la última operación MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_errno()
  • PDO::errorCode()

Descripción

mysql_errno ( resource $link_identifier = NULL ) : int

Devuelve el número de error de la última función MySQL.

Los errores que provienen del procesamiento de la base de datos MySQL ya no emiten advertencias. En su lugar, utilice mysql_errno() para recuperar el código de error. Tenga en cuenta que ésta función solamente devolverá el código de error de la función MySQL ejecutada mas recientemente (sin incluir a mysql_error() y mysql_errno()), por lo que, si se quiere usar, hay que asegurarse de revisar el valor antes de llamar otra función MySQL.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve el número de error de la última función de MySQL, o 0 (cero) si no ha ocurrido ningún error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_errno()

<?php
$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");

if (!mysql_select_db("bd_inexistente", $enlace)) {
    echo mysql_errno($enlace) . ": " . mysql_error($enlace). "\n";
}

mysql_select_db("kossu", $enlace);
if (!mysql_query("SELECT * FROM tabla_inexistente", $enlace)) {
    echo mysql_errno($enlace) . ": " . mysql_error($enlace) . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

1049: Unknown database 'bd_inexistente'
1146: Table 'kossu.tabla_inexistente' doesn't exist

Ver también

  • mysql_error() - Devuelve el texto del mensaje de error de la operación MySQL anterior
  • » Códigos de error de MySQL


Devuelve el texto del mensaje de error de la operación MySQL anterior

  • « mysql_errno
  • mysql_escape_string »
  • PHP Manual
  • Funciones de MySQL
  • Devuelve el texto del mensaje de error de la operación MySQL anterior

mysql_error

(PHP 4, PHP 5)

mysql_error — Devuelve el texto del mensaje de error de la operación MySQL anterior

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_error()
  • PDO::errorInfo()

Descripción

mysql_error ( resource $link_identifier = NULL ) : string

Devuelve el texto del error de la última función MySQL. Los errores que provienen del procesamiento de la base de datos MySQL ya no emiten advertencias. En su lugar, utilice mysql_errno() para recuperar el código de error. Tenga en cuenta que ésta función solamente devolverá el código de error de la función MySQL ejecutada mas recientemente (sin incluir a mysql_error() y mysql_errno()), por lo que, si se quiere usar, hay que asegurarse de revisar el valor antes de llamar otra función MySQL.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve el texto del error de la última función MySQL, o '' (una cadena vacía) si no ha ocurrido ningún error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_error()

<?php
$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");

mysql_select_db("bd_inexistente", $enlace);
echo mysql_errno($enlace) . ": " . mysql_error($enlace). "\n";

mysql_select_db("kossu", $enlace);
mysql_query("SELECT * FROM tabla_inexistente", $enlace);
echo mysql_errno($enlace) . ": " . mysql_error($enlace) . "\n";
?>

El resultado del ejemplo sería algo similar a:

1049: Unknown database 'bd_inexistente'
1146: Table 'kossu.tabla_inexistente' doesn't exist

Ver también

  • mysql_errno() - Devuelve el valor numérico del mensaje de error de la última operación MySQL
  • » Códigos de error de MySQL


Escapa una cadena para ser usada en mysql_query

  • « mysql_error
  • mysql_fetch_array »
  • PHP Manual
  • Funciones de MySQL
  • Escapa una cadena para ser usada en mysql_query

mysql_escape_string

(PHP 4 >= 4.0.3, PHP 5)

mysql_escape_string — Escapa una cadena para ser usada en mysql_query

Advertencia

Esta función está obsoleta en PHP 4.3.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • mysqli_escape_string()
  • PDO::quote()

Descripción

mysql_escape_string ( string $unescaped_string ) : string

Esta función escapará unescaped_string, para que sea segura ponerla en una mysql_query(). Esta función está obsoleta.

Esta función es idéntica a mysql_real_escape_string() excepto que mysql_real_escape_string() toma un gestor de conexión y escapa la cadena de acuerdo con el juego de carácteres actual. mysql_escape_string() no toma un argumento de conexión y no respeta la configuración del juego de caracteres actual.

Parámetros

unescaped_string

La cadena que va a ser escapada.

Valores devueltos

Devuelve la cadena escapada.

Historial de cambios

Versión | Descripción
5.3.0 | Ahora, esta función lanza un aviso E_DEPRECATED.
4.3.0 | Esta función será eliminada, no la utilice. En su lugar utilice mysql_real_escape_string().

Ejemplos

Ejemplo #1 Ejemplo de mysql_escape_string()

<?php
$elemento = "Zak's Laptop";
$elemento_escapado = mysql_escape_string($elemento);
printf("Cadena escapada: %s\n", $elemento_escapado);
?>

El resultado del ejemplo sería:

Cadena escapada: Zak\'s Laptop

Notas

Nota:

mysql_escape_string() no escapa los caracteres % y _.

Ver también

  • mysql_real_escape_string() - Escapa caracteres especiales en una cadena para su uso en una sentencia SQL
  • addslashes() - Escapa un string con barras invertidas
  • La directiva magic_quotes_gpc.


Recupera una fila de resultados como un array asociativo, un array numérico o como ambos

  • « mysql_escape_string
  • mysql_fetch_assoc »
  • PHP Manual
  • Funciones de MySQL
  • Recupera una fila de resultados como un array asociativo, un array numérico o como ambos

mysql_fetch_array

(PHP 4, PHP 5)

mysql_fetch_array — Recupera una fila de resultados como un array asociativo, un array numérico o como ambos

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_array()
  • PDOStatement::fetch()

Descripción

mysql_fetch_array ( resource $result , int $result_type = MYSQL_BOTH ) : array

Devuelve un array que corresponde a la fila recuperada y mueve el puntero de datos interno hacia delante.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

result_type

El tipo de array que va a ser devuelto. Es una constante y puede tomar los siguientes valores: MYSQL_ASSOC, MYSQL_NUM, y MYSQL_BOTH.

Valores devueltos

Devuelve un array de cadenas que corresponde a la fila recuperada, o false si no hay más filas. El tipo del array retornado depende de como esté definido result_type. Al utilizar MYSQL_BOTH (predeterminado), se obtendrá un array con ambos índices: asociativos y numéricos. Al utilizar MYSQL_ASSOC, se obtienen solo los índices asociativos (tal como funciona mysql_fetch_assoc()). Al utilizar MYSQL_NUM, se obtienen solo los índices numéricos (tal como funciona mysql_fetch_row()).

Si dos o más columnas del resultado tienen el mismo nombre de campo, la última columna tomará precedencia. Para acceder a la/s otra/s columna/s con el mismo nombre, se deberá usar el índice numérico de la columna o crear un alias para la columna. Para las columnas con alias, no se puede acceder al contenido con el nombre de la columna original.

Ejemplos

Ejemplo #1 Consulta con nombres de campos duplicados con alias

SELECT tabla1.campo AS foo, tabla2.campo AS bar FROM tabla1, tabla2

Ejemplo #2 mysql_fetch_array() con MYSQL_NUM

<?php
mysql_connect("localhost", "usuario_mysql", "contraseña_mysql") or
    die("No se pudo conectar: " . mysql_error());
mysql_select_db("mibd");

$resultado = mysql_query("SELECT id, nombre FROM mitabla");

while ($fila = mysql_fetch_array($resultado, MYSQL_NUM)) {
    printf("ID: %s  Nombre: %s", $fila[0], $fila[1]);
}

mysql_free_result($resultado);
?>

Ejemplo #3 mysql_fetch_array() con MYSQL_ASSOC

<?php
mysql_connect("localhost", "usuario_mysql", "contraseña_mysql") or
    die("No se pudo conectar: " . mysql_error());
mysql_select_db("mibd");

$resultado = mysql_query("SELECT id, nombre FROM mitabla");

while ($fila = mysql_fetch_array($resultado, MYSQL_ASSOC)) {
    printf("ID: %s  Nombre: %s", $fila["id"], $fila["nombre"]);
}

mysql_free_result($resultado);
?>

Ejemplo #4 mysql_fetch_array() con MYSQL_BOTH

<?php
mysql_connect("localhost", "usuario_mysql", "contraseña_mysql") or
    die("No se pudo conectar: " . mysql_error());
mysql_select_db("mibd");

$resultado = mysql_query("SELECT id, nombre FROM mitabla");

while ($fila = mysql_fetch_array($resultado, MYSQL_BOTH)) {
    printf ("ID: %s  Nombre: %s", $fila[0], $fila["nombre"]);
}

mysql_free_result($resultado);
?>

Notas

Nota: Rendimiento

Una cosa importante a tener en cuenta es que el uso de mysql_fetch_array() no es significativamente más lento que el uso de mysql_fetch_row(), aunque provee un valor añadido considerable.

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Ver también

  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_data_seek() - Mueve el puntero de resultados interno
  • mysql_query() - Enviar una consulta MySQL


Recupera una fila de resultados como un array asociativo

  • « mysql_fetch_array
  • mysql_fetch_field »
  • PHP Manual
  • Funciones de MySQL
  • Recupera una fila de resultados como un array asociativo

mysql_fetch_assoc

(PHP 4 >= 4.0.3, PHP 5)

mysql_fetch_assoc — Recupera una fila de resultados como un array asociativo

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_assoc()
  • PDOStatement::fetch(PDO::FETCH_ASSOC)

Descripción

mysql_fetch_assoc ( resource $result ) : array

Devuelve un array asociativo que corresponde a la fila recuperada y mueve el puntero de datos interno hacia adelante. mysql_fetch_assoc() es equivalente a llamar a mysql_fetch_array() con MYSQL_ASSOC como segundo parámetro opcional. Únicamente devuelve un array asociativo.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

Devuelve un array asociativo de strings que corresponde a la fila recuperada, o false si no hay más filas disponibles.

Si dos o más columnas del resultado tienen los mismos nombres de campo, la última columna tomará precedencia. Para acceder a la/s otra/s columna/s con el mismo nombre, se tendrá que acceder al resultado con índices numéricos mediante el uso de mysql_fetch_row() o agregando sobrenombres. Véase el ejemplo en la descripción de mysql_fetch_array() respecto a los sobrenombres.

Ejemplos

Ejemplo #1 Un ejemplo desarrolado de mysql_fetch_assoc()

<?php

$conexión = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");

if (!$conexión) {
    echo "No pudo conectarse a la BD: " . mysql_error();
    exit;
}

if (!mysql_select_db("nombre_de_la_bd")) {
    echo "No ha sido posible seleccionar la BD: " . mysql_error();
    exit;
}

$sql = "SELECT id as id_usuario, nombre_completo, estatus_usuario
        FROM   alguna_tabla
        WHERE  estatus_usuario = 1";

$resultado = mysql_query($sql);

if (!$resultado) {
    echo "No se pudo ejecutar con exito la consulta ($sql) en la BD: " . mysql_error();
    exit;
}

if (mysql_num_rows($resultado) == 0) {
    echo "No se han encontrado filas, nada a imprimir, asi que voy a detenerme.";
    exit;
}

// Mientras exista una fila de datos, colocar esa fila en $fila como un array asociativo
// Nota: Si solo espera una fila, no hay necesidad de usar un bucle
// Nota: Si coloca extract($fila); dentro del siguiente bucle,
//       estará creando $id_usuario, $nombre_completo, y $estatus_usuario
while ($fila = mysql_fetch_assoc($resultado)) {
    echo $fila["id_usuario"];
    echo $fila["nombre_completo"];
    echo $fila["estatus_usuario"];
}

mysql_free_result($resultado);

?>

Notas

Nota: Rendimiento

Algo importante a observar es que el uso de mysql_fetch_assoc() no es significativamente más lento que el uso de mysql_fetch_row(), aunque provee un valor añadido considerable.

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Ver también

  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • mysql_fetch_array() - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_data_seek() - Mueve el puntero de resultados interno
  • mysql_query() - Enviar una consulta MySQL
  • mysql_error() - Devuelve el texto del mensaje de error de la operación MySQL anterior


Obtiene la información de una columna de un resultado y la devuelve como un objeto

  • « mysql_fetch_assoc
  • mysql_fetch_lengths »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene la información de una columna de un resultado y la devuelve como un objeto

mysql_fetch_field

(PHP 4, PHP 5)

mysql_fetch_field — Obtiene la información de una columna de un resultado y la devuelve como un objeto

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field()
  • PDOStatement::getColumnMeta()

Descripción

mysql_fetch_field ( resource $result , int $field_offset = 0 ) : object

Devuelve un objeto que contiene la información de los campos. Esta función puede ser usada para obtener información sobre campos en el resultado de la consulta proporcionada.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El índice numérico del campo. Si el índice del campo no se especifica, se recuperará el siguiente campo que aún no haya recuperado esta función. Los índices de field_offset comienzan en 0.

Valores devueltos

Devuelve un object que contiene la información del campo. Las propiedades del objeto son:

  • name - nombre de la columna
  • table - nombre de la tabla a la que pertenece la columna, el cual es el sobrenombre si alguno está definido
  • max_length - longitud máxima de la columna
  • not_null - 1 si la columna no puede ser null
  • primary_key - 1 si la columna es una clave primaria
  • unique_key - 1 si la columna es una clave única
  • multiple_key - 1 si la colmuna es una clave no única
  • numeric - 1 si la columna es numérica
  • blob - 1 si la columna es un BLOB
  • type - el tipo de la columna
  • unsigned - 1 si la columna es sin signo
  • zerofill - 1 si la columna es rellena de ceros

Ejemplos

Ejemplo #1 Ejemplo de mysql_fetch_field()

<?php
$conexión = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$conexión) {
    die('No se pudo conectar: ' . mysql_error());
}
mysql_select_db('basedatos');
$resultado = mysql_query('select * from table');
if (!$resultado) {
    die('Falló la consulta: ' . mysql_error());
}
/* obtener los metadatos de la columna */
$i = 0;
while ($i < mysql_num_fields($resultado)) {
    echo "Información de la columna $i:<br />\n";
    $metadatos = mysql_fetch_field($resultado, $i);
    if (!$metadatos) {
        echo "No hay información disponible<br />\n";
    }
    echo "<pre>
blob:         $metadatos->blob
max_length:   $metadatos->max_length
multiple_key: $metadatos->multiple_key
name:         $metadatos->name
not_null:     $metadatos->not_null
numeric:      $metadatos->numeric
primary_key:  $metadatos->primary_key
table:        $metadatos->table
type:         $metadatos->type
unique_key:   $metadatos->unique_key
unsigned:     $metadatos->unsigned
zerofill:     $metadatos->zerofill
</pre>";
    $i++;
}
mysql_free_result($resultado);
?>

Notas

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota:

Si se usa un alias para los campos o los nombres de tablas en la consulta SQL se devolverá el nombre del alias. El nombre original se puede recuperar, por ejemplo, usando mysqli_result::fetch_field().

Ver también

  • mysql_field_seek() - Establece el puntero del resultado en un índice de campo específicado


Obtiene la longitud de cada salida en un resultado

  • « mysql_fetch_field
  • mysql_fetch_object »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene la longitud de cada salida en un resultado

mysql_fetch_lengths

(PHP 4, PHP 5)

mysql_fetch_lengths — Obtiene la longitud de cada salida en un resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_lengths()
  • PDOStatement::getColumnMeta()

Descripción

mysql_fetch_lengths ( resource $result ) : array

Devuelve un array que corresponde a las longitudes de cada campo de la última fila recuperada por MySQL.

mysql_fetch_lengths() almacena las longitudes de cada columna del resultado en la última fila devuelta mediante mysql_fetch_row(), mysql_fetch_assoc(), mysql_fetch_array(), y mysql_fetch_object() en un array, comenzando desde el índice 0.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

Un array de longitudes en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de mysql_fetch_lengths()

<?php
$resultado = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}
$fila       = mysql_fetch_assoc($resultado);
$longitudes = mysql_fetch_lengths($resultado);

print_r($fila);
print_r($longitudes);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [id] => 42
    [email] => user@example.com
)
Array
(
    [0] => 2
    [1] => 16
 )

Ver también

  • mysql_field_len() - Devuelve la longitud del campo especificado
  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • strlen() - Obtiene la longitud de un string


Recupera una fila de resultados como un objeto

  • « mysql_fetch_lengths
  • mysql_fetch_row »
  • PHP Manual
  • Funciones de MySQL
  • Recupera una fila de resultados como un objeto

mysql_fetch_object

(PHP 4, PHP 5)

mysql_fetch_object — Recupera una fila de resultados como un objeto

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_object()
  • PDOStatement::fetch(PDO::FETCH_OBJ)

Descripción

mysql_fetch_object ( resource $result , string $class_name = ? , array $params = ? ) : object

Devuelve un objeto con propiedades que corresponden a la fila recuperada y mueve el puntero interno hacia delante.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

class_name

El nombre de la clase donde instanciar, configurar las propiedades y devolver. Si no se especifica, se devuelve un objeto stdClass.

params

Un array opcional de parámetros para pasar al constructor de los objetos class_name.

Valores devueltos

Devuelve un object con propiedades de tipo string que se corresponden con la fila recuperada, o false si no quedan más filas.

Ejemplos

Ejemplo #1 Ejemplo de mysql_fetch_object()

<?php
mysql_connect("nombre_anfitrión", "usuario", "contraseña");
mysql_select_db("mibd");
$resultado = mysql_query("select * from mitabla");
while ($fila = mysql_fetch_object($resultado)) {
    echo $fila->id_usuario;
    echo $fila->nombre_completo;
}
mysql_free_result($resultado);
?>

Ejemplo #2 Ejemplo de mysql_fetch_object()

<?php
class foo {
    public $nombre;
}

mysql_connect("nombre_anfitrión", "usuario", "contraseña");
mysql_select_db("mibd");

$resultado = mysql_query("select nombre from mitabla limit 1");
$objeto = mysql_fetch_object($resultado, 'foo');
var_dump($objeto);
?>

Notas

Nota: Rendimiento

En cuestión de velocidad, la función es idéntica a mysql_fetch_array(), y casi tan rápida como mysql_fetch_row() (la diferencia es insignificante).

Nota:

mysql_fetch_object() es similar a mysql_fetch_array(), con una diferencia: se devuelve un objeto, en lugar de un array. Indirectamente, esto significa que se puede acceder a los datos únicamente mediante los nombres de los campos, y no mediante sus índices (los números son ilegales como nombres de propiedades).

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota: Esta función define campos NULOS al valor null de PHP.

Ver también

  • mysql_fetch_array() - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • mysql_data_seek() - Mueve el puntero de resultados interno
  • mysql_query() - Enviar una consulta MySQL


Obtiene una fila de resultados como un array numérico

  • « mysql_fetch_object
  • mysql_field_flags »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene una fila de resultados como un array numérico

mysql_fetch_row

(PHP 4, PHP 5)

mysql_fetch_row — Obtiene una fila de resultados como un array numérico

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_row()
  • PDOStatement::fetch(PDO::FETCH_NUM)

Descripción

mysql_fetch_row ( resource $result ) : array

Devuelve un array numérico que corresponde a la fila recuperada y mueve el puntero de datos interno hacia delante.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

Devuelve un array numérico que corresponde a la fila recuperada, o false si no quedan más filas.

mysql_fetch_row() recupera una fila de datos del resultado asociado al identificador de resultados especificado. La fila es devuelta como un array. Cada columna del resultado es almacenada en un índice del array, empezando desde 0.

Ejemplos

Ejemplo #1 Recuperar una fila con mysql_fetch_row()

<?php
$resultado = mysql_query("SELECT id, email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}
$fila = mysql_fetch_row($resultado);

echo $fila[0]; // 42
echo $fila[1]; // el valor de email
?>

Notas

Nota: Esta función define campos NULOS al valor null de PHP.

Ver también

  • mysql_fetch_array() - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_fetch_object() - Recupera una fila de resultados como un objeto
  • mysql_data_seek() - Mueve el puntero de resultados interno
  • mysql_fetch_lengths() - Obtiene la longitud de cada salida en un resultado
  • mysql_result() - Obtener datos de resultado


Obtiene las banderas asociadas al campo especificado de un resultado

  • « mysql_fetch_row
  • mysql_field_len »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene las banderas asociadas al campo especificado de un resultado

mysql_field_flags

(PHP 4, PHP 5)

mysql_field_flags — Obtiene las banderas asociadas al campo especificado de un resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field_direct() [flags]
  • PDOStatement::getColumnMeta() [flags]

Descripción

mysql_field_flags ( resource $result , int $field_offset ) : string

mysql_field_flags() devuelve las banderas del campo especificado. Las banderas son reportadas como una sola palabra por bandera, separada por un solo espacio, por lo que se puede dividir el valor devuelto usando explode().

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

Devuelve un string de banderas asociadas con el resultado o false en caso de error.

Las siguientes banderas son reportadas si la versión de MySQL es suficientemente actual para soportarlas: "not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment" y "timestamp".

Ejemplos

Ejemplo #1 Un ejemplo de mysql_field_flags()

<?php
$resultado = mysql_query("SELECT id, email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}
$banderas = mysql_field_flags($resultado, 0);

echo $banderas;
print_r(explode(' ', $banderas));
?>

El resultado del ejemplo sería algo similar a:

not_null primary_key auto_increment
Array
(
    [0] => not_null
    [1] => primary_key
    [2] => auto_increment
)

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_fieldflags()

Ver también

  • mysql_field_type() - Obtiene el tipo del campo especificado de un resultado
  • mysql_field_len() - Devuelve la longitud del campo especificado


Devuelve la longitud del campo especificado

  • « mysql_field_flags
  • mysql_field_name »
  • PHP Manual
  • Funciones de MySQL
  • Devuelve la longitud del campo especificado

mysql_field_len

(PHP 4, PHP 5)

mysql_field_len — Devuelve la longitud del campo especificado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field_direct() [length]
  • PDOStatement::getColumnMeta() [len]

Descripción

mysql_field_len ( resource $result , int $field_offset ) : int

mysql_field_len() devuelve la longitud del campo especificado.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

La longitud del índice del campo especificado en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_field_len()

<?php
$resultado = mysql_query("SELECT id, email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}

// Se obtendrá la longitud del campo id tal como está especificado en el esquema
// de la base de datos.
$longitud = mysql_field_len($resultado, 0);
echo $longitud;
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_fieldlen()

Ver también

  • mysql_fetch_lengths() - Obtiene la longitud de cada salida en un resultado
  • strlen() - Obtiene la longitud de un string


Obtiene el nombre del campo especificado de un resultado

  • « mysql_field_len
  • mysql_field_seek »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el nombre del campo especificado de un resultado

mysql_field_name

(PHP 4, PHP 5)

mysql_field_name — Obtiene el nombre del campo especificado de un resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field_direct() [name] o [orgname]
  • PDOStatement::getColumnMeta() [name]

Descripción

mysql_field_name ( resource $result , int $field_offset ) : string

mysql_field_name() devuelve el nombre del índice del campo especificado.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

El nombre del índice del campo especificado en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_field_name()

<?php
/* La tabla usuarios consiste de tres campos:
 *   user_id
 *   username
 *   password.
 */
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar al servidor MySQL: ' . mysql_error());
}
$nombre_bd = 'mibd';
$bd_seleccionada = mysql_select_db($nombre_bd, $enlace);
if (!$bd_seleccionada) {
    die("No se pudo establecer $nombre_bd: " . mysql_error());
}
$resultado = mysql_query('select * from usuarios', $enlace);

echo mysql_field_name($resultado, 0) . "\n";
echo mysql_field_name($resultado, 2);
?>

El resultado del ejemplo sería:

user_id
password

Notas

Nota: Los nombres de los campos devueltos por esta función son sensibles a mayúsculas y minúsculas.

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_fieldname()

Ver también

  • mysql_field_type() - Obtiene el tipo del campo especificado de un resultado
  • mysql_field_len() - Devuelve la longitud del campo especificado


Establece el puntero del resultado en un índice de campo específicado

  • « mysql_field_name
  • mysql_field_table »
  • PHP Manual
  • Funciones de MySQL
  • Establece el puntero del resultado en un índice de campo específicado

mysql_field_seek

(PHP 4, PHP 5)

mysql_field_seek — Establece el puntero del resultado en un índice de campo específicado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_field_seek()
  • PDOStatement::fetch() empleando los parámetros cursor_orientation y offset

Descripción

mysql_field_seek ( resource $result , int $field_offset ) : bool

Busca el índice del campo especificado. Si la siguiente llamada a mysql_fetch_field() no incluye un índice de campo, será devuelto el índice del campo especificado en mysql_field_seek().

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mysql_fetch_field() - Obtiene la información de una columna de un resultado y la devuelve como un objeto


Obtiene el nombre de la tabla en la que está el campo especificado

  • « mysql_field_seek
  • mysql_field_type »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el nombre de la tabla en la que está el campo especificado

mysql_field_table

(PHP 4, PHP 5)

mysql_field_table — Obtiene el nombre de la tabla en la que está el campo especificado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field_direct() [table] o [orgtable]
  • PDOStatement::getColumnMeta() [table]

Descripción

mysql_field_table ( resource $result , int $field_offset ) : string

Devuelve el nombre de la tabla en la que está el campo especificado.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

El nombre de la tabla en caso de éxito.

Ejemplos

Ejemplo #1 Un ejemplo de mysql_field_table()

<?php

$consulta = "SELECT account.*, country.* FROM account, country WHERE country.name = 'Portugal' AND account.country_id = country.id";

// obtener el resultado desde la BD
$resultado = mysql_query($consulta);

// Lista el nombre de la tabla y luego el nombre del campo
for ($i = 0; $i < mysql_num_fields($resultado); ++$i) {
    $tabla = mysql_field_table($resultado, $i);
    $campo = mysql_field_name($resultado, $i);

    echo  "$tabla: $campo\n";
}

?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_fieldtable()

Ver también

  • mysql_list_tables() - Enumerar las tablas de una base de datos MySQL


Obtiene el tipo del campo especificado de un resultado

  • « mysql_field_table
  • mysql_free_result »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el tipo del campo especificado de un resultado

mysql_field_type

(PHP 4, PHP 5)

mysql_field_type — Obtiene el tipo del campo especificado de un resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_fetch_field_direct() [type]
  • PDOStatement::getColumnMeta() [driver:decl_type] o [pdo_type]

Descripción

mysql_field_type ( resource $result , int $field_offset ) : string

mysql_field_type() es similar a la función mysql_field_name(). Los argumentos son idénticos, pero se devuelve en su lugar el tipo de campo.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

field_offset

El número del campo a buscar. El valor de field_offset comienza en 0. Si field_offset no existe, un error de nivel E_WARNING es emitido.

Valores devueltos

El tipo de campo devuelto será uno de los siguientes: "int", "real", "string", "blob", y otros tal como se detalla en » la documentación de MySQL.

Ejemplos

Ejemplo #1 Ejemplo de mysql_field_type()

<?php
mysql_connect("localhost", "nombre_usuario_mysql", "cotraseña_mysql");
mysql_select_db("mysql");
$resultado = mysql_query("SELECT * FROM func");
$campos    = mysql_num_fields($resultado);
$filas     = mysql_num_rows($resultado);
$tabla     = mysql_field_table($resultado, 0);
echo "Su tabla '" . $tabla . "' tiene " . $campos . " campos y " . $filas . " registro/s\n";
echo "La tabla tiene los siguientes campos:\n";
for ($i=0; $i < $campos; $i++) {
    $tipo     = mysql_field_type($resultado, $i);
    $nombre   = mysql_field_name($resultado, $i);
    $longitud = mysql_field_len($resultado, $i);
    $banderas = mysql_field_flags($resultado, $i);
    echo $tipo . " " . $nombre . " " . $longitud . " " . $banderas . "\n";
}
mysql_free_result($resultado);
mysql_close();
?>

El resultado del ejemplo sería algo similar a:

Su tabla 'func' tiene 4 campos y 1 registro/s
La tabla tiene los siguientes campos:
string name 64 not_null primary_key binary
int ret 1 not_null
string dl 128 not_null
string type 9 not_null enum

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_fieldtype()

Ver también

  • mysql_field_name() - Obtiene el nombre del campo especificado de un resultado
  • mysql_field_len() - Devuelve la longitud del campo especificado


Libera la memoria del resultado

  • « mysql_field_type
  • mysql_get_client_info »
  • PHP Manual
  • Funciones de MySQL
  • Libera la memoria del resultado

mysql_free_result

(PHP 4, PHP 5)

mysql_free_result — Libera la memoria del resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_free_result()
  • Asignar el valor de null al objeto PDO, o PDOStatement::closeCursor()

Descripción

mysql_free_result ( resource $result ) : bool

mysql_free_result() liberará toda la memoria asociada con el identificador del resultado result.

mysql_free_result() solo necesita ser llamado si se está preocupado por la cantidad de memoria que está siendo usada por las consultas que devuelven conjuntos de resultados grandes. Toda la memoria de resultados asociada se liberará automaticamente al finalizar la ejecución del script.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Si se utiliza un recurso no válido para result, se emitirá un error de nivel E_WARNING. Vale la pena señalar que mysql_query() solo devuelve un recurso para las consultas SELECT, SHOW, EXPLAIN, y DESCRIBE.

Ejemplos

Ejemplo #1 Un ejemplo de mysql_free_result()

<?php
$resultado = mysql_query("SELECT id, email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}
/* Usamos el resultado, asumiendo que, acto seguido, hemos terminado con él */
$fila = mysql_fetch_assoc($resultado);

/* Ahora liberamos el resultado y continuamos con nuestro script */
mysql_free_result($resultado);

echo $fila['id'];
echo $fila['email'];
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_freeresult()

Ver también

  • mysql_query() - Enviar una consulta MySQL
  • is_resource() - Comprueba si una variable es un recurso


Obtiene información del cliente MySQL

  • « mysql_free_result
  • mysql_get_host_info »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene información del cliente MySQL

mysql_get_client_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_client_info — Obtiene información del cliente MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_get_client_info()
  • PDO::getAttribute(PDO::ATTR_CLIENT_VERSION)

Descripción

mysql_get_client_info ( ) : string

mysql_get_client_info() devuelve un string que representa la versión de la biblioteca cliente.

Valores devueltos

La versión del cliente MySQL.

Ejemplos

Ejemplo #1 Ejemplo de mysql_get_client_info()

<?php
printf("Información del cliente MySQL: %s\n", mysql_get_client_info());
?>

El resultado del ejemplo sería algo similar a:

Información del cliente MySQL: 3.23.39

Ver también

  • mysql_get_host_info() - Obtener información del anfitrión de MySQL
  • mysql_get_proto_info() - Obtener información del protocolo MySQL
  • mysql_get_server_info() - Obtiene información del servidor MySQL


Obtener información del anfitrión de MySQL

  • « mysql_get_client_info
  • mysql_get_proto_info »
  • PHP Manual
  • Funciones de MySQL
  • Obtener información del anfitrión de MySQL

mysql_get_host_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_host_info — Obtener información del anfitrión de MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_get_host_info()
  • PDO::getAttribute(PDO::ATTR_CONNECTION_STATUS)

Descripción

mysql_get_host_info ( resource $link_identifier = NULL ) : string

Describe el tipo de conexión en uso, incluyendo el nombre del servidor anfitrión.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve un string que describe el tipo de conexión MySQL en uso, o o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_get_host_info()

<?php
$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");
if (!$enlace) {
    die("No pudo conectarse: " . mysql_error());
}
printf("Información del anfitrión de MySQL: %s\n", mysql_get_host_info());
?>

El resultado del ejemplo sería algo similar a:

Información del anfitrión de MySQL: Localhost via UNIX socket

Ver también

  • mysql_get_client_info() - Obtiene información del cliente MySQL
  • mysql_get_proto_info() - Obtener información del protocolo MySQL
  • mysql_get_server_info() - Obtiene información del servidor MySQL


Obtener información del protocolo MySQL

  • « mysql_get_host_info
  • mysql_get_server_info »
  • PHP Manual
  • Funciones de MySQL
  • Obtener información del protocolo MySQL

mysql_get_proto_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_proto_info — Obtener información del protocolo MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_get_proto_info()

Descripción

mysql_get_proto_info ( resource $link_identifier = NULL ) : int

Recupera el protocolo MySQL.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve el protocolo MySQL en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_get_proto_info()

<?php
$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");
if (!$enlace) {
    die("No pudo conectarse: " . mysql_error());
}
printf("Versión del protocolo MySQL: %s\n", mysql_get_proto_info());
?>

El resultado del ejemplo sería algo similar a:

Versión del protocolo MySQL: 10

Ver también

  • mysql_get_client_info() - Obtiene información del cliente MySQL
  • mysql_get_host_info() - Obtener información del anfitrión de MySQL
  • mysql_get_server_info() - Obtiene información del servidor MySQL


Obtiene información del servidor MySQL

  • « mysql_get_proto_info
  • mysql_info »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene información del servidor MySQL

mysql_get_server_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_server_info — Obtiene información del servidor MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_get_server_info()
  • PDO::getAttribute(PDO::ATTR_SERVER_VERSION)

Descripción

mysql_get_server_info ( resource $link_identifier = NULL ) : string

Recupera la versión del servidor MySQL.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve la versión del servidor MySQL en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_get_server_info()

<?php
$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");
if (!$enlace) {
    die("No pudo conectarse: " . mysql_error());
}
printf("Versión del servidor MySQL: %s\n", mysql_get_server_info());
?>

El resultado del ejemplo sería algo similar a:

Versión del servidor MySQL: 4.0.1-alpha

Ver también

  • mysql_get_client_info() - Obtiene información del cliente MySQL
  • mysql_get_host_info() - Obtener información del anfitrión de MySQL
  • mysql_get_proto_info() - Obtener información del protocolo MySQL
  • phpversion() - Obtiene la versión de PHP


Obtiene información sobre la consulta más reciente

  • « mysql_get_server_info
  • mysql_insert_id »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene información sobre la consulta más reciente

mysql_info

(PHP 4 >= 4.3.0, PHP 5)

mysql_info — Obtiene información sobre la consulta más reciente

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_info()

Descripción

mysql_info ( resource $link_identifier = NULL ) : string

Devuelve información detallada sobre la última consulta.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuele información sobre la sentencia en caso de éxito, o false en caso de error. Vea el ejemplo siguiente para conocer qué sentencias proveen información, y cuál puede ser la apariencia del valor devuelto. Las sentencias que no están en la lista devolverán false.

Ejemplos

Ejemplo #1 Sentencias MySQL Relevantes

Sentencias que devuelven valores de tipo cadena. Los números están únicamente por propósitos ilustrativos; sus valores corresponderán con la consulta.

INSERT INTO ... SELECT ...
String format: Records: 23 Duplicates: 0 Warnings: 0
INSERT INTO ... VALUES (...),(...),(...)...
String format: Records: 37 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ...
String format: Records: 42 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE
String format: Records: 60 Duplicates: 0 Warnings: 0
UPDATE
String format: Rows matched: 65 Changed: 65 Warnings: 0

Notas

Nota:

mysql_info() devuelve un valor diferente a false para la sentencia INSERT ... VALUES sólo si se indican múltiples listas de valores en la sentencia.

Ver también

  • mysql_affected_rows() - Obtiene el número de filas afectadas en la anterior operación de MySQL
  • mysql_insert_id() - Obtiene el ID generado en la última consulta
  • mysql_stat() - Obtiene el estado actual del sistema


Obtiene el ID generado en la última consulta

  • « mysql_info
  • mysql_list_dbs »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el ID generado en la última consulta

mysql_insert_id

(PHP 4, PHP 5)

mysql_insert_id — Obtiene el ID generado en la última consulta

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_insert_id()
  • PDO::lastInsertId()

Descripción

mysql_insert_id ( resource $link_identifier = NULL ) : int

Recupera el ID generado por la consulta anterior (normalmente INSERT) para una columna AUTO_INCREMENT.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

El ID generado por la consulta anterior para una columna AUTO_INCREMENT en caso de éxito, 0 si la consulta anterior no genera un valor AUTO_INCREMENT, o false si no se estableció una conexión MySQL.

Ejemplos

Ejemplo #1 Ejemplo de mysql_insert_id()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar: ' . mysql_error());
}
mysql_select_db('mibd');

mysql_query("INSERT INTO mitabla (producto) values ('kossu')");
printf("El último registro insertado tiene el id %d\n", mysql_insert_id());
?>

Notas

Precaución

mysql_insert_id() convertirá el tipo devuelto de la función nativa mysql_insert_id() de la API de C de MySQL a un tipo long (llamado int en PHP). Si la columna AUTO_INCREMENT tiene un tipo BIGINT (64 bits) la conversión puede resultar en un valor incorrecto. En su lugar, use la función de SQL interna LAST_INSERT_ID() de MySQL en una consulta SQL. Para más información sobre los valores máximos de tipo integer, por favor vea la documentación de integer.

Nota:

Como mysql_insert_id() actúa en la última consulta realizada, asegúrese de llamar a mysql_insert_id() inmediatamente después de la consulta que genera el valor.

Nota:

El valor de la función de SQL LAST_INSERT_ID() de MySQL siempre contiene el valor AUTO_INCREMENT generado más recientientemente, y no se restablece entre consultas.

Ver también

  • mysql_query() - Enviar una consulta MySQL
  • mysql_info() - Obtiene información sobre la consulta más reciente


Lista las bases de datos disponibles en un servidor MySQL

  • « mysql_insert_id
  • mysql_list_fields »
  • PHP Manual
  • Funciones de MySQL
  • Lista las bases de datos disponibles en un servidor MySQL

mysql_list_dbs

(PHP 4, PHP 5)

mysql_list_dbs — Lista las bases de datos disponibles en un servidor MySQL

Advertencia

Esta función está obsoleta en PHP 5.4.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • Consulta SQL: SHOW DATABASES

Descripción

mysql_list_dbs ( resource $link_identifier = NULL ) : resource

Devuelve un puntero de resultados que contiene las bases de datos disponibles en el demonio de mysql actual.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve un resource de puntero de resultados en caso de éxito, o false en caso de error. Use la función mysql_tablename() para atravesar este puntero de resultado, o cualquier función para obtener tablas, tal como mysql_fetch_array().

Ejemplos

Ejemplo #1 Ejemplo de mysql_list_dbs()

<?php
// Uso sin mysql_list_dbs()
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$resultado = mysql_query("SHOW DATABASES");

while ($fila = mysql_fetch_assoc($res)) {
    echo $fila['Database'] . "\n";
}

// Obsoleto a partir de PHP 5.4.0
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$lista_bd = mysql_list_dbs($enlace);

while ($fila = mysql_fetch_object($lista_bd)) {
     echo $fila->Database . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

basedatos1
basedatos2
basedatos3

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_listdbs()

Ver también

  • mysql_db_name() - Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs
  • mysql_select_db() - Seleccionar una base de datos MySQL


Lista los campos de una tabla de MySQL

  • « mysql_list_dbs
  • mysql_list_processes »
  • PHP Manual
  • Funciones de MySQL
  • Lista los campos de una tabla de MySQL

mysql_list_fields

(PHP 4, PHP 5)

mysql_list_fields — Lista los campos de una tabla de MySQL

Advertencia

Esta función está obsoleta en PHP 5.4.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • Consulta SQL: SHOW COLUMNS FROM alguna_tabla

Descripción

mysql_list_fields ( string $database_name , string $table_name , resource $link_identifier = NULL ) : resource

Devuelve información sobre el nombre de la tabla dado.

Esta función está obsoleta. Es preferible usar mysql_query() para ejecutar una consulta SQL SHOW COLUMNS FROM tabla [LIKE 'nombre'] en su lugar.

Parámetros

database_name

El nombre de la base de la base de datos que está siendo consultada.

table_name

El nombre de la tabla que está siendo consultada.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Un resource del puntero del resultado en caso de éxito, o false en caso de error.

El resultado devuelto puede ser usado con mysql_field_flags(),
mysql_field_len(),
mysql_field_name() y
mysql_field_type().

Ejemplos

Ejemplo #1 Alternativa para la obsoleta mysql_list_fields()

<?php
$resultado = mysql_query("SHOW COLUMNS FROM alguna_tabla");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}
if (mysql_num_rows($resultado) > 0) {
    while ($fila = mysql_fetch_assoc($resultado)) {
        print_r($fila);
    }
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [Field] => id
    [Type] => int(7)
    [Null] =>
    [Key] => PRI
    [Default] =>
    [Extra] => auto_increment
)
Array
(
    [Field] => email
    [Type] => varchar(100)
    [Null] =>
    [Key] =>
    [Default] =>
    [Extra] =>
)

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_listfields()

Ver también

  • mysql_field_flags() - Obtiene las banderas asociadas al campo especificado de un resultado
  • mysql_info() - Obtiene información sobre la consulta más reciente


Lista los procesos de MySQL

  • « mysql_list_fields
  • mysql_list_tables »
  • PHP Manual
  • Funciones de MySQL
  • Lista los procesos de MySQL

mysql_list_processes

(PHP 4 >= 4.3.0, PHP 5)

mysql_list_processes — Lista los procesos de MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_thread_id()

Descripción

mysql_list_processes ( resource $link_identifier = NULL ) : resource

Recupera los hilos del servidor MySQL actuales.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Un puntero de resultados de tipo resource en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_list_processes()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');

$resultado = mysql_list_processes($enlace);

while ($fila = mysql_fetch_assoc($resultado)){
    printf("%s %s %s %s %s\n", $fila["Id"], $fila["Host"], $fila["db"],
        $fila["Command"], $fila["Time"]);
}
mysql_free_result($resultado);
?>

El resultado del ejemplo sería algo similar a:

1 localhost test Processlist 0
4 localhost mysql sleep 5

Ver también

  • mysql_thread_id() - Devuelve el ID del hilo actual
  • mysql_stat() - Obtiene el estado actual del sistema


Enumerar las tablas de una base de datos MySQL

  • « mysql_list_processes
  • mysql_num_fields »
  • PHP Manual
  • Funciones de MySQL
  • Enumerar las tablas de una base de datos MySQL

mysql_list_tables

(PHP 4, PHP 5)

mysql_list_tables — Enumerar las tablas de una base de datos MySQL

Advertencia

Esta función está obsoleta en PHP 4.3.0, por lo que ha sido eliminada, junto a la totalidad de la extensión original de MySQL, en PHP 7.0.0. En su lugar, utilice las extensiones MySQLi o PDO_MySQL activamente desarrolladas. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Las alternativas a esta función son:

  • SQL Query: SHOW TABLES FROM nombre_bd

Descripción

mysql_list_tables ( string $database , resource $link_identifier = NULL ) : resource

Devuelve una lista con el nombre de las tablas de una base de datos MySQL.

Esta función está obsoleta. Es preferible usar mysql_query() para ejecutar la sentencia SQL SHOW TABLES [FROM nombre_bd] [LIKE 'patrón'] en su lugar.

Parámetros

database

El nombre de la base de datos

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

El puntero de resultados de tipo resource en caso de éxito o false en caso de error.

Use la función mysql_tablename() para atravesar este puntero de resultados, o cualquier otra función para mostrar tablas, como mysql_fetch_array().

Historial de cambios

Versión | Descripción
4.3.7 | Esta función quedó obsoleta.

Ejemplos

Ejemplo #1 Ejemplo alternativo de mysql_list_tables()

<?php
$nombre_bd = 'nombre_bd_mysql';

if (!mysql_connect('anfitrión_mysql', 'usuario_mysql', 'contraseña_mysql')) {
    echo 'No se pudo conectar a mysql';
    exit;
}

$sql = "SHOW TABLES FROM $nombre_bd";
$resultado = mysql_query($sql);

if (!$resultado) {
    echo "Error de BD, no se pudieron listar las tablas\n";
    echo 'Error MySQL: ' . mysql_error();
    exit;
}

while ($fila = mysql_fetch_row($resultado)) {
    echo "Tabla: {$fila[0]}\n";
}

mysql_free_result($resultado);
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_listtables()

Ver también

  • mysql_list_dbs() - Lista las bases de datos disponibles en un servidor MySQL
  • mysql_tablename() - Obtiene el nombre de la tabla de un campo


Obtiene el número de campos de un resultado

  • « mysql_list_tables
  • mysql_num_rows »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el número de campos de un resultado

mysql_num_fields

(PHP 4, PHP 5)

mysql_num_fields — Obtiene el número de campos de un resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_num_fields()
  • PDOStatement::columnCount()

Descripción

mysql_num_fields ( resource $result ) : int

Obtiene el número de campos de una consulta.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

Devuelve el número de campos del resource de conjunto de resultados en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de mysql_num_fields()

<?php
$resultado = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$resultado) {
    echo 'No se pudo ejecutar la consulta: ' . mysql_error();
    exit;
}

/* devuelve 2 ya que id,email === dos campos */
echo mysql_num_fields($resultado);
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_numfields()

Ver también

  • mysql_select_db() - Seleccionar una base de datos MySQL
  • mysql_query() - Enviar una consulta MySQL
  • mysql_fetch_field() - Obtiene la información de una columna de un resultado y la devuelve como un objeto
  • mysql_num_rows() - Obtener el número de filas de un conjunto de resultados


Obtener el número de filas de un conjunto de resultados

  • « mysql_num_fields
  • mysql_pconnect »
  • PHP Manual
  • Funciones de MySQL
  • Obtener el número de filas de un conjunto de resultados

mysql_num_rows

(PHP 4, PHP 5)

mysql_num_rows — Obtener el número de filas de un conjunto de resultados

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_num_rows()
  • mysqli_stmt_num_rows()
  • PDOStatement::rowCount()

Descripción

mysql_num_rows ( resource $result ) : int

Recupera el número de filas de un conjunto de resultados. Este comando es únicamente válido para sentencias como SELECT o SHOW que retornan un conjunto de resultados real. Para recuperar el número de filas afectadas por una consulta INSERT, UPDATE, REPLACE o DELETE, use mysql_affected_rows().

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

Valores devueltos

El número de filas de un conjunto de resultados en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_num_rows()

<?php

$enlace = mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");
mysql_select_db("basedatos", $enlace);

$resultado = mysql_query("SELECT * FROM tabla1", $enlace);
$número_filas = mysql_num_rows($resultado);

echo "$número_filas Filas\n";

?>

Notas

Nota:

Si se utiliza mysql_unbuffered_query(), mysql_num_rows() no retornará el valor correcto hasta que se hayan recuperado todas las filas del conjunto de resultados.

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_numrows()

Ver también

  • mysql_affected_rows() - Obtiene el número de filas afectadas en la anterior operación de MySQL
  • mysql_connect() - Abre una conexión al servidor MySQL
  • mysql_data_seek() - Mueve el puntero de resultados interno
  • mysql_select_db() - Seleccionar una base de datos MySQL
  • mysql_query() - Enviar una consulta MySQL


Abre una conexión persistente a un servidor MySQL

  • « mysql_num_rows
  • mysql_ping »
  • PHP Manual
  • Funciones de MySQL
  • Abre una conexión persistente a un servidor MySQL

mysql_pconnect

(PHP 4, PHP 5)

mysql_pconnect — Abre una conexión persistente a un servidor MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_connect() con p: host prefix
  • PDO::__construct() con PDO::ATTR_PERSISTENT como una opción de controlador

Descripción

mysql_pconnect ( string $server = ini_get("mysql.default_host") , string $username = ini_get("mysql.default_user") , string $password = ini_get("mysql.default_password") , int $client_flags = 0 ) : resource

Establece una conexión persistente a un servidor MySQL.

mysql_pconnect() se parece mucho a mysql_connect() con dos grandes diferencias.

En primer lugar, cuando se conecta, la función primero intenta encontrar un enlace (persistente) que ya esté abierto con el mismo anfitrión, nombre de usuario y contraseña. Si se encuentra uno, se devolverá un identificador para él, en lugar de abrir una nueva conexión.

Segundo, la conexión al servidor SQL no será cerrada cuando la ejecución del script finalice. En su lugar, el enlace permanecerá abierto para su uso futuro (mysql_close() no cerrará los enlaces establecidos mediante mysql_pconnect()).

Por eso a este tipo de enlace se le llama 'persistente'.

Parámetros

server

El servidor de MySQL. También puede incluir un número de puerto. P.ej. "nombre_anfitrión:puerto" o una ruta a un socket local, p.ej. ":/ruta/al/socket" para el localhost.

Si la directiva de PHP mysql.default_host no se ha definido (predeterminado), entonces el valor por defecto es 'localhost:3306'

username

El nombre de usuario. El valor por defecto es el nombre del usuario al que pertenece el proceso del servidor.

password

La contraseña. El valor por defecto es una contraseña vacia.

client_flags

El parámetro client_flags puede ser una combinación de las siguientes constantes: 128 (habilita el manejo de LOAD DATA LOCAL), MYSQL_CLIENT_SSL, MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE o MYSQL_CLIENT_INTERACTIVE.

Valores devueltos

Devuelve un identificador de enlace persistente a MySQL en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Esta función generará un error de nivel E_DEPRECATED.

Notas

Nota:

Tenga en cuenta que este tipo de enlaces solo funcionan si se está usando una versión de módulo de PHP. Véase la sección Conexiones persistentes a bases de datos para más información.

Advertencia

El uso de conexiones persistentes puede requerir ajustar un poco las configuraciones de Apache y de MySQL para asegurarse de que no se excede el número de conexiones permitidas por MySQL.

Nota:

En caso de error, se puede suprimir el mensaje de error anteponiendo una @ al nombre de la función.

Ver también

  • mysql_connect() - Abre una conexión al servidor MySQL
  • Conexiones persistentes a bases de datos


Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión

  • « mysql_pconnect
  • mysql_query »
  • PHP Manual
  • Funciones de MySQL
  • Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión

mysql_ping

(PHP 4 >= 4.3.0, PHP 5)

mysql_ping — Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_ping()

Descripción

mysql_ping ( resource $link_identifier = NULL ) : bool

Chequea si está activa o no la conexión con el servidor. Si ésta se ha caído, se intenta una reconexión automática. Esta función puede ser usada por scripts que permanecen pasivos durante largos espacios de tiempo, para chequear si el servidor ha cerrado la conexión y reconectarse de ser necesario.

Nota:

La reconexión automática está deshabilitada de forma predeterminada en versiones de MySQL >= 5.0.3.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve true si la conexión con el servidor MySQL está funcionando, o false si no.

Ejemplos

Ejemplo #1 Un ejemplo de mysql_ping()

<?php
set_time_limit(0);

$conexión = mysql_connect('localhost', 'usuario_mysql', 'contraseña');
$bd  = mysql_select_db('mi_bd');

/* Se asume que esta consulta toma mucho tiempo */
$resultado = mysql_query($sql);
if (!$resultado) {
    echo 'La consulta #1 falló; Saliendo.';
    exit;
}

/* Asegurarse de que la conexión sigue viva, si no, intentar una reconexión */
if (!mysql_ping($conexión)) {
    echo 'Se ha perdido la conexión, saliendo después de la consulta #1';
    exit;
}
mysql_free_result($resultado);

/* Ya que la conexión sigue viva, ejecutemos otra consulta */
$resultado2 = mysql_query($sql2);
?>

Ver también

  • mysql_thread_id() - Devuelve el ID del hilo actual
  • mysql_list_processes() - Lista los procesos de MySQL


Enviar una consulta MySQL

  • « mysql_ping
  • mysql_real_escape_string »
  • PHP Manual
  • Funciones de MySQL
  • Enviar una consulta MySQL

mysql_query

(PHP 4, PHP 5)

mysql_query — Enviar una consulta MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_query()
  • PDO::query()

Descripción

mysql_query ( string $query , resource $link_identifier = NULL ) : mixed

mysql_query() envía una única consulta (no hay soporte para múltiples consultas) a la base de datos actualmente activa en el servidor asociado con el identificador de enlace especificado por link_identifier.

Parámetros

query

Una consulta SQL

El string de la consulta no debería terminar con un punto y coma. Los datos insertados en la consulta deberían estar correctamente escapados.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Para SELECT, SHOW, DESCRIBE, EXPLAIN y otras sentencias que retornan un conjunto de resultados, mysql_query() devuelve un resource en caso de éxito, o false en caso de error.

Para otros tipos de sentencias SQL, tales como INSERT, UPDATE, DELETE, DROP, etc, mysql_query() devuelve true en caso de éxito o false en caso de error.

El conjunto de resultados devuelto debería ser pasado a mysql_fetch_array(), y otras funciones para manejar las tablas del resultado, para acceder a los datos retornados.

Use mysql_num_rows() para averiguar cuántas filas fueron devueltas por la sentencia SELECT, o mysql_affected_rows() para averiguar cuántas filas fueron afectadas por las sentencias DELETE, INSERT, REPLACE, o UPDATE.

mysql_query() también fallará y retornará false si el usuario no está autorizado para acceder a la/s tabla/s a la/s que hace referencia la consulta.

Ejemplos

Ejemplo #1 Consulta inválida

La siguiente consulta no es sintácticamente válida, por lo que mysql_query() fallará y retornará false.

<?php
$resultado = mysql_query('SELECT * WHERE 1=1');
if (!$resultado) {
    die('Consulta no válida: ' . mysql_error());
}

?>

Ejemplo #2 Consulta válida

La siguiente consulta es válida, por lo que mysql_query() retornará un resource.

<?php
// Lo siguiente podría ser proporcionado por un usuario, como por ejemplo
$nombre = 'fred';
$apellido  = 'fox';

// Formular la consulta
// Este es el mejor método para formular una consulta SQL
// Para más ejemplos, consulte mysql_real_escape_string()
$consulta = sprintf("SELECT nombre, apellido, direccion, edad FROM amigos
    WHERE nombre='%s' AND apellido='%s'",
    mysql_real_escape_string($nombre),
    mysql_real_escape_string($apellido));

// Ejecutar la consulta
$resultado = mysql_query($consulta);

// Comprobar el resultado
// Lo siguiente muestra la consulta real enviada a MySQL, y el error ocurrido. Útil para depuración.
if (!$resultado) {
    $mensaje  = 'Consulta no válida: ' . mysql_error() . "\n";
    $mensaje .= 'Consulta completa: ' . $consulta;
    die($mensaje);
}

// Usar el resultado
// Si se intenta imprimir $resultado no será posible acceder a la información del recurso
// Se debe usar una de las funciones de resultados de mysql
// Consulte también mysql_result(), mysql_fetch_array(), mysql_fetch_row(), etc.
while ($fila = mysql_fetch_assoc($resultado)) {
    echo $fila['nombre'];
    echo $fila['apellido'];
    echo $fila['direccion'];
    echo $fila['edad'];
}

// Liberar los recursos asociados con el conjunto de resultados
// Esto se ejecutado automáticamente al finalizar el script.
mysql_free_result($resultado);
?>

Ver también

  • mysql_connect() - Abre una conexión al servidor MySQL
  • mysql_error() - Devuelve el texto del mensaje de error de la operación MySQL anterior
  • mysql_real_escape_string() - Escapa caracteres especiales en una cadena para su uso en una sentencia SQL
  • mysql_result() - Obtener datos de resultado
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_unbuffered_query() - Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados


Escapa caracteres especiales en una cadena para su uso en una sentencia SQL

  • « mysql_query
  • mysql_result »
  • PHP Manual
  • Funciones de MySQL
  • Escapa caracteres especiales en una cadena para su uso en una sentencia SQL

mysql_real_escape_string

(PHP 4 >= 4.3.0, PHP 5)

mysql_real_escape_string — Escapa caracteres especiales en una cadena para su uso en una sentencia SQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_real_escape_string()
  • PDO::quote()

Descripción

mysql_real_escape_string ( string $unescaped_string , resource $link_identifier = NULL ) : string

Escapa caracteres especiales en la cadena dada por unescaped_string, teniendo en cuenta el conjunto de caracteres en uso de la conexión, para que sea seguro usarla en mysql_query(). Si se van a insertar datos binarios, se ha de usar esta función.

mysql_real_escape_string() llama a la función mysql_real_escape_string de la biblioteca de MySQL, la cual antepone barras invertidas a los siguientes caracteres: \x00, \n, \r, \, ', " y \x1a.

Esta función siempre debe usarse (con pocas excepciones) para hacer seguros los datos antes de enviar una consulta a MySQL.

Precaución

Seguridad: el conjunto de caracters predeterminado

El conjunto de caracteres debe ser establecido o bien a nivel del servidor, o bien con la función mysql_set_charset() de la API para que afecte a mysql_real_escape_string(). Véase la sección sobre los conceptos de conjuntos de caracters para más información.

Parámetros

unescaped_string

La cadena a escapar.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve la cadena escapada, o false en caso de error.

Errores/Excepciones

Ejecutar esta función sin una conexión de MySQL presente también emitirá errores de nivel E_WARNING de PHP. Solo se ha de ejecutar con una conexión de MySQL válida presente.

Ejemplos

Ejemplo #1 Ejemplo sencillo de mysql_real_escape_string()

<?php
// Conexión
$enlace = mysql_connect('anfitrión_mysql', 'usuario_mysql', 'contraseña_mysql')
    OR die(mysql_error());

// Consulta
$consulta = sprintf("SELECT * FROM users WHERE user='%s' AND password='%s'",
            mysql_real_escape_string($usuario),
            mysql_real_escape_string($contraseña));
?>

Ejemplo #2 mysql_real_escape_string() requiere una conexión

Este ejemplo muestra lo que sucede si no hay presente una conexión de MySQL al invocar a esta función.

<?php
// No nos hemos conectado a MySQL

$apellido  = "O'Reilly";
$_apellido = mysql_real_escape_string($apellido);

$consulta = "SELECT * FROM actors WHERE last_name = '$_apellido'";

var_dump($_apellido);
var_dump($consulta);
?>

El resultado del ejemplo sería algo similar a:

Warning: mysql_real_escape_string(): No such file or directory in /this/test/script.php on line 5
Warning: mysql_real_escape_string(): A link to the server could not be established in /this/test/script.php on line 5

bool(false)
string(41) "SELECT * FROM actors WHERE last_name = ''"

Ejemplo #3 Un ejemplo de ataque de inyección de SQL

<?php
// No hemos comprobado $_POST['password'], ¡podría ser cualquier cosa que el usuario quisiera! Por ejemplo:
$_POST['username'] = 'aidan';
$_POST['password'] = "' OR ''='";

// Consultar la base de datos para comprobar si existe algún usuario que coincida
$consulta = "SELECT * FROM users WHERE user='{$_POST['username']}' AND password='{$_POST['password']}'";
mysql_query($consulta);

// Esto significa que la consulta enviada a MySQL sería:
echo $consulta;
?>

La consulta enviada a MySQL:

SELECT * FROM users WHERE user='aidan' AND password='' OR ''=''

Esto permitiría a alguien acceder a una sesión sin una contraseña válida.

Notas

Nota:

Se requiere una conexión a MySQL antes de usar mysql_real_escape_string(), si no, se generará un error de nivel E_WARNING, y se devolverá false. Si link_identifier no está definido, se usará la última conexión a MySQL.

Nota:

Si magic_quotes_gpc está habilitado, primero se ha de aplicar stripslashes() a los datos. Si se usa esta función en datos que ya han sido escapados, se escaparán dos veces.

Nota:

Si esta función no se utiliza para escapar los datos, la consulta es vulnerable a Ataques de inyección SQL.

Nota: mysql_real_escape_string() no escapa % ni _. Estos son comodines en MySQL si se combinan con LIKE, GRANT, o REVOKE.

Ver también

  • mysql_set_charset() - Establece el conjunto de caracteres del cliente
  • mysql_client_encoding() - Devuelve el nombre del conjunto de caracteres
  • addslashes() - Escapa un string con barras invertidas
  • stripslashes() - Quita las barras de un string con comillas escapadas
  • La directiva magic_quotes_gpc
  • La directiva magic_quotes_runtime


Obtener datos de resultado

  • « mysql_real_escape_string
  • mysql_select_db »
  • PHP Manual
  • Funciones de MySQL
  • Obtener datos de resultado

mysql_result

(PHP 4, PHP 5)

mysql_result — Obtener datos de resultado

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_data_seek() junto con
mysqli_field_seek() y
mysqli_fetch_field()
  • PDOStatement::fetchColumn()

Descripción

mysql_result ( resource $result , int $row , mixed $field = 0 ) : string

Recupera el contenido de una celda de un conjunto de resultados de MySQL.

Cuando se esté trabajando con conjuntos de resultados grandes, se debería considerar usar una de las funciones que obtienen una fila completa (especificadas más abajo). Debido a que estas funciones retornan el contenido de múltiples celdas en una única llamada a función, son MUCHO MÁS rápidas que mysql_result(). Además, se ha de tener en cuenta que la especificación de un índice numérico para el campo pasado como argumento es mucho más rápido que especificar un nombre de campo o el argumento nombre_tabla.nombre_campo.

Parámetros

result

El resultado resource que está siendo evaluado. Este resultado proviene de una llamada a mysql_query().

row

El número de fila del conjunto de resultados que está siendo recuperado. El número de filas empieza a partir de 0.

field

El nombre o el índice del campo que está siendo recuperado.

Puede ser el índice del campo, el nombre del campo, o el nombre de la tabla punto nombre del campo (nombre_tabla.nombre_campo). Si se ha utilizado un alias para el nombre de la columna ('select foo as bar from...'), utilice el alias en lugar del nombre del campo. Si no está definido, se recuperará el primer campo.

Valores devueltos

El contenido de una celda de un conjunto de resultados de MySQL en caso de éxito, o false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de mysql_result()

<?php
$enlace = mysql_connect('anfitrión_mysql', 'usuario_mysql', 'contraseña_mysql');
if (!$enlace) {
    die('No se pudo conectar: ' . mysql_error());
}
if (!mysql_select_db('nombre_base_datos')) {
    die('No se pudo seleccionar la base de datos: ' . mysql_error());
}
$resultado = mysql_query('SELECT name FROM work.employee');
if (!$resultado) {
    die('No se pudo consultar:' . mysql_error());
}
echo mysql_result($resultado, 2); // imprime el nombre del tercer empleado

mysql_close($enlace);
?>

Notas

Nota:

Las llamadas a mysql_result() no deberían ser mezcladas con llamadas a otras funciones que manejen conjuntos de resultados.

Ver también

  • mysql_fetch_row() - Obtiene una fila de resultados como un array numérico
  • mysql_fetch_array() - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
  • mysql_fetch_assoc() - Recupera una fila de resultados como un array asociativo
  • mysql_fetch_object() - Recupera una fila de resultados como un objeto


Seleccionar una base de datos MySQL

  • « mysql_result
  • mysql_set_charset »
  • PHP Manual
  • Funciones de MySQL
  • Seleccionar una base de datos MySQL

mysql_select_db

(PHP 4, PHP 5)

mysql_select_db — Seleccionar una base de datos MySQL

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_select_db()
  • PDO::__construct() (parte de dsn)

Descripción

mysql_select_db ( string $database_name , resource $link_identifier = NULL ) : bool

Establece la base de datos activa actual en el servidor asociado con el identificador de enlace especificado. Cada llamada posterior a mysql_query() será ejecutada en la base de datos activa.

Parámetros

database_name

El nombre de la base de datos que va a ser seleccionada.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo mysql_select_db()

<?php

$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_myql');
if (!$enlace) {
    die('No se pudo conectar : ' . mysql_error());
}

// Hacer que foo sea la base de datos actual
$bd_seleccionada = mysql_select_db('foo', $enlace);
if (!$bd_seleccionada) {
    die ('No se puede usar foo : ' . mysql_error());
}
?>

Notas

Nota:

Por razones de compatibilidad con versiones anteriores, los siguientes alias obsoletos podrían usarse: mysql_selectdb()

Ver también

  • mysql_connect() - Abre una conexión al servidor MySQL
  • mysql_pconnect() - Abre una conexión persistente a un servidor MySQL
  • mysql_query() - Enviar una consulta MySQL


Establece el conjunto de caracteres del cliente

  • « mysql_select_db
  • mysql_stat »
  • PHP Manual
  • Funciones de MySQL
  • Establece el conjunto de caracteres del cliente

mysql_set_charset

(PHP 5 >= 5.2.3)

mysql_set_charset — Establece el conjunto de caracteres del cliente

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_set_charset()
  • PDO: Añadir charset al string de conexión, tal como charset=utf8

Descripción

mysql_set_charset ( string $charset , resource $link_identifier = NULL ) : bool

Establece el conjunto de caracteres predeterminado para la conexión actual.

Parámetros

charset

Un nombre válido de un conjunto de caracteres.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función requiere MySQL 5.0.7 o posterior.

Nota:

Esta es la mejor forma de cambiar el conjunto de caracteres. El uso de mysql_query() para establecerlo (como SET NAMES utf8) no es recomendable. Véase la sección conceptos de conjuntos de caracteres de MySQL para más información.

Ver también

  • Establecer conjuntos de caracteres en MySQL
  • » Listado de los conjuntos de caracteres admitidos por MySQL
  • mysql_client_encoding() - Devuelve el nombre del conjunto de caracteres


Obtiene el estado actual del sistema

  • « mysql_set_charset
  • mysql_tablename »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el estado actual del sistema

mysql_stat

(PHP 4 >= 4.3.0, PHP 5)

mysql_stat — Obtiene el estado actual del sistema

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_stat()
  • PDO::getAttribute(PDO::ATTR_SERVER_INFO)

Descripción

mysql_stat ( resource $link_identifier = NULL ) : string

mysql_stat() devuelve el estado actual del servidor.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Devuelve un string con el estado del tiempo de funcionamiento, hilos, consultas, tablas abiertas, tablas de volcado y consultas por segundo. Para obtener una lista completa de variables de estado, es necesario usar el comando SQL SHOW STATUS. Si link_identifier no es válido, se devuelve null.

Ejemplos

Ejemplo #1 Ejemplo de mysql_stat()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$estado = explode('  ', mysql_stat($enlace));
print_r($estado);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Uptime: 5380
    [1] => Threads: 2
    [2] => Questions: 1321299
    [3] => Slow queries: 0
    [4] => Opens: 26
    [5] => Flush tables: 1
    [6] => Open tables: 17
    [7] => Queries per second avg: 245.595
)

Ejemplo #2 Ejemplo alternativo de mysql_stat()

<?php
$enlace    = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$resultado = mysql_query('SHOW STATUS', $enlace);
while ($fila = mysql_fetch_assoc($resultado)) {
    echo $fila['Nombre_variable'] . ' = ' . $fila['Valor'] . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

back_log = 50
basedir = /usr/local/
bdb_cache_size = 8388600
bdb_log_buffer_size = 32768
bdb_home = /var/db/mysql/
bdb_max_lock = 10000
bdb_logdir =
bdb_shared_data = OFF
bdb_tmpdir = /var/tmp/
...

Ver también

  • mysql_get_server_info() - Obtiene información del servidor MySQL
  • mysql_list_processes() - Lista los procesos de MySQL


Obtiene el nombre de la tabla de un campo

  • « mysql_stat
  • mysql_thread_id »
  • PHP Manual
  • Funciones de MySQL
  • Obtiene el nombre de la tabla de un campo

mysql_tablename

(PHP 4, PHP 5)

mysql_tablename — Obtiene el nombre de la tabla de un campo

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • Consulta SQL: SHOW TABLES

Descripción

mysql_tablename ( resource $result , int $i ) : string

Recupera el nombre de tabla desde un resultado dado por result.

Esta función está obsoleta. Es preferible usar mysql_query() para ejecutar una consulta SQL SHOW TABLES [FROM nombre_bd] [LIKE 'patrón'] en su lugar.

Parámetros

result

Un resource de puntero de resultados que se devuelve desde mysql_list_tables().

i

El índice de tipo integer (número de fila/tabla)

Valores devueltos

El nombre de la tabla en caso de éxito o false en caso de error.

Use la función mysql_tablename() para atravesar este puntero de resultados, o cualquier función para obtener tablas, tal como mysql_fetch_array().

Historial de cambios

Versión | Descripción
5.5.0 | La función mysql_tablename() es obsoleta, por lo que emite un error de nivel E_DEPRECATED.

Ejemplos

Ejemplo #1 Ejemplo de mysql_tablename()

<?php
mysql_connect("localhost", "usuario_mysql", "contraseña_mysql");
$resultado = mysql_list_tables("mibd");
$número_filas = mysql_num_rows($resultado);
for ($i = 0; $i < $número_filas; $i++) {
    echo "Tabla: ", mysql_tablename($resultado, $i), "\n";
}

mysql_free_result($resultado);
?>

Notas

Nota:

La función mysql_num_rows() puede ser usada para determinar el número de tablas del puntero de resultados.

Ver también

  • mysql_list_tables() - Enumerar las tablas de una base de datos MySQL
  • mysql_field_table() - Obtiene el nombre de la tabla en la que está el campo especificado
  • mysql_db_name() - Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs


Devuelve el ID del hilo actual

  • « mysql_tablename
  • mysql_unbuffered_query »
  • PHP Manual
  • Funciones de MySQL
  • Devuelve el ID del hilo actual

mysql_thread_id

(PHP 4 >= 4.3.0, PHP 5)

mysql_thread_id — Devuelve el ID del hilo actual

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • mysqli_thread_id()

Descripción

mysql_thread_id ( resource $link_identifier = NULL ) : int

Recupera el ID del hilo actual. Si la conexión se ha perdido, y se ejecuta una reconexión con mysql_ping(), el ID del hilo cambiará. Esto quiere decir que sólo se ha de recuperar el ID del hilo cuando sea necesario.

Parámetros

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

El ID del hilo en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysql_thread_id()

<?php
$enlace = mysql_connect('localhost', 'usuario_mysql', 'contraseña_mysql');
$id_hilo = mysql_thread_id($enlace);
if ($id_hilo){
    printf("El ID del hilo actual es %d\n", $id_hilo);
}
?>

El resultado del ejemplo sería algo similar a:

El ID del hilo actual es 73

Ver también

  • mysql_ping() - Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión
  • mysql_list_processes() - Lista los procesos de MySQL


Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados

  • « mysql_thread_id
  • Mysqlnd »
  • PHP Manual
  • Funciones de MySQL
  • Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados

mysql_unbuffered_query

(PHP 4 >= 4.0.6, PHP 5)

mysql_unbuffered_query — Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados

Advertencia

Esta extensión fue declarada obsoleta en PHP 5.5.0 y eliminada en PHP 7.0.0. En su lugar debería utilzarse las extensiones MySQLi o PDO_MySQL. Véase también la guía MySQL: elegir una API y sus P+F relacionadas para más información. Alternatives to this function include:

  • See: Consultas almacenadas y no almacenadas en buffer

Descripción

mysql_unbuffered_query ( string $query , resource $link_identifier = NULL ) : resource

mysql_unbuffered_query() envía la consulta SQL query a MySQL, sin recuperar ni almacenar automáticamente en búfer las filas de resultados, como mysql_query() lo hace. Esto ahorra una considerable cantidad de memoria con las consultas SQL que producen conjuntos de resultados grandes, y se puede empezar a trabajar con el conjunto de resultados inmediatamente después de que la primera fila haya sido recuperada, ya que no es necesario esperar hasta que la consulta SQL completa haya sido ejecutada. Para usar mysql_unbuffered_query() mientras están abiertas múltiples conexiones a la base de datos, se debe especificar el parámetro opcional link_identifier para identificar qué conexión se desea utilizar.

Parámetros

query

La consulta SQL a ejecutar.

Los datos dentro de la consulta deben estar propiamente escapados.

link_identifier

La conexión MySQL. Si no se especifica el identificador de enlace, se asume el último enlace abierto por mysql_connect(). Si no se encuentra este enlace, se intentará crear un nuevo enlace como si mysql_connect() hubiese sido invocada sin argumentos. Si no se encuentra o establece ninguna conexión, se genera un error de nivel E_WARNING.

Valores devueltos

Para sentencias SELECT, SHOW, DESCRIBE o EXPLAIN, mysql_unbuffered_query() devuelve un resource en caso de éxito, o false en caso de error.

Para otro tipo de sentencias SQL, UPDATE, DELETE, DROP, etc, mysql_unbuffered_query() devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Los beneficios de mysql_unbuffered_query() tienen un precio: no se puede usar mysql_num_rows() ni mysql_data_seek() en un conjunto de resultados devuelto por mysql_unbuffered_query(), hasta que todas las filas sean recuperadas. También se tendrán que recuperar todas las filas de resultados de una consulta SQL no almacenada en búfer antes de poder enviar una nueva consulta SQL a MySQL, usando el mismo link_identifier.

Ver también

  • mysql_query() - Enviar una consulta MySQL


Controlador Nativo de MySQL

  • Introducción
  • Información General
  • Instalación
  • Configuración en tiempo de ejecución
  • Incompatibilidades
  • Conexiones persistentes
  • Estadísticas
  • Notas
  • Gestión de la memoria
  • API de Complementos del Controlador Nativo de MySQL
    • Una comparación de los complementos de mysqlnd y el Proxy de MySQL
    • Obtener la API de complementos de mysqlnd
    • Arquitectura de los Complementos del Controlador Nativo de MySQL
    • La API de complementos de mysqlnd
    • Empezar a construir un complemento de mysqlnd


Introducción

El Controlador Nativo de MySQL (MySQL Native Driver en inglés) es un sustituto para la Biblioteca Cliente de MySQL (libmysqlclient). El Controlador Nativo de MySQL es parte de las fuentes oficiales de PHP a partir de PHP 5.3.0.

Las extensiones de base de datos de MySQL (la extensión MySQL, mysqli y PDO MYSQL), se comunican con el servidor de MySQL. En el pasado, esto lo realizaba la extensión utilizando los servicios prestados por la Biblioteca Cliente de MySQL. Las extensiones eran compiladas con la Biblioteca Cliente de MySQL con el fin de utilizar su protocolo cliente-servidor.

Ahora existe una alternativa con el Controlador Nativo de MySQL, ya que las extensiones de bases de datos MySQL puede ser compiladas para utilizar el Controlador Nativo de MySQL en lugar de la Biblioteca Cliente de MySQL.

El Controlador Nativo de MySQL está escrito en C, como una extensión de PHP.


Información General

Lo que no es

Aunque el Controlador Nativo de MySQL está escrito como una extensión de PHP, es importanete observar que no proporciona una nueva API al programador de PHP. Las APIs de programador para conectividad de bases de datos MySQL están proporcionadas por las extensiones, mysqli y PDO MYSQL. Estas extensiones ahora pueden utilizar servicios del Controlador Nativo de MySQL para comunicarse con el Servidor MySQL. Por lo tanto, no se debería pensar en el Controlador Nativo de MySQL como una API.

¿Por qué usarlo?

El uso del Controlador Nativo de MySQL ofrece varias ventajas sobre el uso de la Biblioteca Cliente de MySQL.

La antigua Biblioteca Cliente de MySQL fue escrita por MySQL AB (ahora Oracle Corporation) y por lo tanto fue liberada bajo la licencia de MySQL. Esto, a la larga, condujo a que el soporte para MySQL fuera deshabilitado de forma predeterminada en PHP. Sin embargo, el Controlador Nativo de MySQL ha sido desarrollado como parte del proyecto de PHP, y, por lo tanto, es liberado bajo la licencia de PHP. Esto elimina las cuestiones sobre licencias que han sido problemáticas en el pasado.

También, en el pasado, se necesitaba construir las extensiones de bases de datos MySQL con una copia de la Biblioteca Cliente de MySQL. Esto, normalmente, significaba que se necesitaba tener instalado MySQL en una máquina donde se construyera el código fuente de PHP. También, cuando una aplicación de PHP era ejecutada, las extensiones de bases de datos de MySQL llamarían al fichero de la Biblioteca Cliente de MySQL en tiempo de ejecución, por lo que el fichero era necesario instalarlo en el sistema. Con el Controlador Nativo de MySQL ese ya no es el caso debido a que está incluido como parte de la distribución estándar. Así, no se necesita tener instalado MySQL para construir PHP o ejecutar aplicaciones de bases de datos de PHP.

Ya que el Controlador Nativo de MySQL está escrito como una extensión de PHP, está íntimamente asociado con el funcionamiento de PHP. Esto conduce a obtener ganancias en eficiencia, especialmente en lo que se refiere al uso de memeria, ya que el controlador utiliza el sistema de administración de memoria de PHP. También soporta el límite de memoria de PHP. El uso del Controlador Nativo de PHP conduce a un rendimiento comparable o mejor que el uso de la Biblioteca Cliente de MySQL; siempre se asegura del uso de memoria más eficiente. Un ejemplo de la eficiencia de memoria es el hecho de que cuando se usa la Biblioteca Cliente de MySQL, cada columna es almacenada en memoria dos veces, mientras que con el Controlador Nativo de MySQL cada columna solamente se almacena una vez en memoria.

Nota: Informe del uso de memoria

Ya que el Controlador Nativo de MySQL utiliza el sistema de administración de memoria de PHP, su uso de memoria se puede seguir con memory_get_usage(). Esto no es posible con libmysqlclient porque utiliza la función de C malloc() en su lugar.

Características especiales

El Controlador Nativo de MySQL también proporciona algunas características especiales no disponibles cuando las extensiones de bases de datos de MySQL utilizan la Biblioteca Cliente de MySQL. Estas características especiales están listadas abajo:

  • Conexiones persistentes mejoradas

  • La función especial mysqli_fetch_all()

  • Llamadas para obtener estadísticas de rendimiento:
mysqli_get_cache_stats(),
mysqli_get_client_stats(),
mysqli_get_connection_stats()

Se puede demostrar que la capacidad de obtener estadísticas de rendimiento es muy útil en la identificación de cuellos de botella de rendimiento.

El Controlador Nativo de MySQL también permite conexiones persistentes cuando se usa junto con la extensión mysqli.

Soporte para SSL

El Controlador Nativo de MySQL tiene soporte para SSL desde la versión 5.3.3 de PHP.

Soporte para el Protocolo de Compresión

A partir de PHP 5.3.2, el Controlador Nativo de MySQL soporta el protocolo de compresión cliente-servidor. El Controlador Nativo de MySQL no lo soportaba en 5.3.0 y 5.3.1. Las extensiones como ext/mysql, ext/mysqli, que están configuradas para usar el Controlador Nativo de MySQL, también puede tomar ventaja de esta característica. Observe que PDO_MYSQL NO soporta compresión al usarla junto con mysqlnd.

Soporte para Tuberías con Nombre

El soporte para las tuberías con nombre para Windows fue añadido en la versión 5.4.0 de PHP.


Instalación

Historial de cambios

Historial de cambios
Versión | Descripción
5.3.0 | Se añadió el Controlador Nativo de MySQL, con soporte para todas las extensiones de MySQL (es decir, mysql, mysqli y PDO_MYSQL). Pasar mysqlnd al ajuste de configuración apropiado habilita este soporte.
5.4.0 | El Controlador Nativo de MySQL ahora es el predeterminado para todas las extensiones de MySQL (es decir, mysql, mysqli y PDO_MYSQL). Pasar mysqlnd a la configuración ahora es opcional.
5.5.0 | Fue agregado el soporte para el Complemento de Autenticación SHA-256

Instalación sobre Unix

Las extensiones de bases de datos MySQL deben estar configuradas para utilizar la Biblioteca Cliente de MySQL. Con el fin de utilizar el Controlador Nativo de MySQL, PHP necesita ser compilado especificando que las extensiones de bases de datos MySQL están compiladas con el soporte para el Controlador Nativo de MySQL. Esto se hace a través de opciones de configuración antes de compilar el código fuente de PHP.

Por ejemplo, para compilar la extensión MySQL, mysqli y PDO MySQL utilizando el Controlador Nativo de MySQL, se daría el siguiente comando:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
[other options]

Instalación sobre Windows

En las distribuciones oficiales para Windows de PHP 5.3 en adelante, el Controlador Nativo de MySQL está habilitado por defecto, por lo que no se requiere configuración adicional para utilizarlo. En este caso, todas las extensiones de bases de datos MySQL utilizarán el Controlador Nativo de MySQL.

Soporte para el Complemento de Autenticación SHA-256

El Controlador Nativo de MySQL requiere la funcionalidad de OpenSSL de PHP para que sea cargado y habilitado para conectarse a MySQL a través de cuentas que utilicen el Complemento de Autenticación SHA-256 de MySQL. Por ejemplo, PHP se podría configurara usando:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-openssl
[other options]


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración del Controlador Nativo de MySQL
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd.collect_statistics | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqlnd.collect_memory_statistics | "0" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.debug | "" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqlnd.log_mask | 0 | PHP_INI_ALL | Disponible desde PHP 5.3.0
mysqlnd.mempool_default_size | 16000 | PHP_INI_ALL | Disponible desde PHP 5.3.3
mysqlnd.net_read_timeout | "31536000" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqlnd.net_cmd_buffer_size | 5.3.0 - "2048", 5.3.1 - "4096" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqlnd.net_read_buffer_size | "32768" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqlnd.sha256_server_public_key | "" | PHP_INI_PERDIR | Disponible desde PHP 5.5.0.
mysqlnd.fetch_data_copy | 0 | PHP_INI_ALL | Disponible desde PHP 5.6.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mysqlnd.collect_statistics boolean

Habilita la recopilación de estadísticas de diversos clientes a las cuales se puede acceder a través de mysqli_get_client_stats(), mysqli_get_connection_stats(), mysqli_get_cache_stats(), y que también se muestran en la sección mysqlnd de la salida de la función phpinfo().

Este ajuste de configuración habilita todas las estadísticas del Controlador Nativo de MySQL excepto aquellas relacionadas con la gestión de memoria.

mysqlnd.collect_memory_statistics boolean

Habilita la recopilación de diversas estadísticas de memoria a las que se puede acceder a través de mysqli_get_client_stats(), mysqli_get_connection_stats(), mysqli_get_cache_stats(), y que también se muestran en la sección mysqlnd de la salida de la función phpinfo().

Este ajuste de configuración habilita las estadísticas de gestión de memoria dentro del conjunto total de estadísticas del Controlador Nativo de MySQL.

mysqlnd.debug string

Registra las comunicaciones de todas las extensiones que usan mysqlnd al fichero de registros especificado.

El formato de la directiva es mysqlnd.debug = "opción1[,parámetro_opción1][:opción2[,parámetro_opción2]]".

Las opciones para la cadena de formato son las siguientes:

  • A[,fichero] - Añade salidas de seguimiento al fichero especificado. También se asegura de que los datos son escritos después de cada escritura. Esto se lleva a cabo cerrando y reabriento el fichero de seguimiento (esto es lento). Ayuda a asegurarse de tener un fichero de seguimiento completo cuando la aplicación falla.

  • a[,fichero] - Añade salidas de seguimiento al fichero especificado.

  • d - Habilita la salida desde las macros DBUG_<N> para el estado actual. Se le puede añadir una lista de palabras clave las cuales seleccionarán la salida solamente para las macros DBUG con esa palabra clave. Una lista vacía de palabras clave implica la salida de todas las macros.

  • f[,funciones] - Limita las acciones del depurador para la lista especificada de funciones. Una lista de funciones vacía implica que se seleccionarán todas las funciones.

  • F - Marca cada línea de salida del depurador con el nombre del fichero fuente que contiene la macro que causa la salida.

  • i - Marca cada línea de salida del depurador con el PID del proceso actual.

  • L - Marca cada línea de salida de depurador con el número de línea del fichero fuente de la macro que causa la salida.

  • n - Marca caa línea de salida del depurador con el nivel de anidamiento de la función actual

  • o[,fichero] - Similar a a[,fichero] excepto que sobrescribe el fichero antiguo, por lo que no realiza la agregación.

  • O[,fichero] - Similar a A[,fichero] excepto que sobrescribe el fichero antiguo, por lo que no realiza la agregación.

  • t[,N] - Habilita el seguimiento del flujo de control de la función. El nivel de anidamiento máximo está especificado por N, y el valor predeterminado es 200.

  • x - Esta opción activa el perfilamiento.

  • m - Seguimiento de llamadas relacionadas con la asignación y desasignación de memoria.

Ejemplo:

d:t:x:O,/tmp/mysqlnd.trace

Nota:

Esta característica solamente está disponible con una construcción de depuración de PHP. Funciona en Microsoft Windows si se utiliza una construcción de depuración de PHP y PHP se ha construido usando la verseión 9 de Microsoft Visual C o superior.

mysqlnd.log_mask integer

Define qué consultas serán registradas. El valor predeterminado es 0, el cual deshabilita el registro. Se define usando un entero, y no una constante de PHP. Por ejemplo, un valor de 48 (16 + 32) registrará las consultas lentas que usan un 'índice no bueno' (SERVER_QUERY_NO_GOOD_INDEX_USED = 16) o no usan ningún índice en absoluto (SERVER_QUERY_NO_INDEX_USED = 32). Un valor de 2043 (1 + 2 + 8 + ... + 1024) registrará todos los tipos de consultas lentas.

Los tipos son los siguientes: SERVER_STATUS_IN_TRANS=1, SERVER_STATUS_AUTOCOMMIT=2,
SERVER_MORE_RESULTS_EXISTS=8, SERVER_QUERY_NO_GOOD_INDEX_USED=16, SERVER_QUERY_NO_INDEX_USED=32,
SERVER_STATUS_CURSOR_EXISTS=64, SERVER_STATUS_LAST_ROW_SENT=128, SERVER_STATUS_DB_DROPPED=256,
SERVER_STATUS_NO_BACKSLASH_ESCAPES=512, and SERVER_QUERY_WAS_SLOW=1024.

mysqlnd.mempool_default_size integer

Tamaño predeterminado de la caché de memoria de mysqlnd, el cual es usado por los conjuntos de resultados.

mysqlnd.net_read_timeout integer

mysqlnd y la Biblioteca Cliente de MySQL, libmysqlclient, utilizan diferentes APIs de red. mysqlnd utiliza flujos de PHP, mientras que libmysqlclient utiliza su propia envoltura sobre las llamadas a la red a nivel de operación. PHP, por defecto, establece un tiempo de espera de lectura de 60s para los flujos. Esto se establece mediante php.ini, default_socket_timeout. Este valor predeterminado se aplica a todos los flujos que no establecen otro valor de tiempo de espera. mysqlnd no establece ningún otro valor y por lo tanto las conexiones de consultas que se ejecutan durante mucho tiempo pueden ser desconectadas después de default_socket_timeout segundos, resultando en un mensaje de error 2006 - MySQL Server has gone away. La Biblioteca Cliente de MySQL establece un tiempo de espera predeterminado de 365 * 24 * 3600 segundos (1 año) y espera a que sucedan otros tiempos de espera, como los tiempos de espera de TCP/IP. Ahora mysqlnd utiliza el mismo tiempo de espera. El valor se puede configurar a través de un nuevo ajuste de php.ini: mysqlnd.net_read_timeout. mysqlnd.net_read_timeout es utilizado por cualquier extensión (ext/mysql, ext/mysqli, PDO_MySQL) que use mysqlnd. mysqlnd le indica a los flujos de PHP que utilicen mysqlnd.net_read_timeout. Observe que puede haber sútiles diferencias entre MYSQL_OPT_READ_TIMEOUT de la Biblioteca Cliente de MySQL y los flujos de PHP, por ejemplo MYSQL_OPT_READ_TIMEOUT está documentado para funcionar sólo con conexiones TCP/IP y, antes de MySQL 5.1.2, sólo con Windows. Los flujos de PHP pueden no tener esta limitación. Compruebe la documentación sobre los flujos si tiene alguna duda.

mysqlnd.net_cmd_buffer_size long

mysqlnd asigna un buffer de comandos/red interno de mysqlnd.net_cmd_buffer_size (en php.ini) bytes para cada conexión. Si un comando del protocolo Cliente Servidor de MySQL, por ejemplo, COM_QUERY (consulta normal), no se ajusta al buffer, mysqlnd aumentará el buffer lo que sea necesario para enviar el comando. Siempre que el buffer se extienda para una conexión, command_buffer_too_small será incrementado en uno.

Si mysqlnd tiene que aumentar el buffer más allá de su tamaño inicial de mysqlnd.net_cmd_buffer_size bytes para casi todas las conexiones, se debería considerar aumentar el tamaño predeterminado para evitar reasignaciones.

El tamaño predeterminado del buffer es de 2048 bytes en PHP 5.3.0. En versiones posteriores, el tamaño predeterminado es de 4096.

Se recomienda establecer el tamaño de buffer a no menos de 4096 bytes debido a que mysqlnd también lo utiliza al leer ciertos paquetes de comunicación desde MySQL. En PHP 5.3.0, mysqlnd no aumentará el buffer si MySQL envía un paquete que es más grande que el tamaño actual del buffer. Como consecuencia, mysqlnd no es capaz de decodificar el paquete y la aplicación cliente obtendrá un error. Solamente hay dos situacioines en las que un paquete es más grande que los 2048 bytes predeterminados de mysqlnd.net_cmd_buffer_size en PHP 5.3.0: el paquete transporta un mensaje de error muy grande, o el paquete contiene los metadatos de columnas de COM_LIST_FIELD (mysql_list_fields()) y los metadatos provienen de una columna de cadena con un valor predeterminado muy grande (>1900 bytes).

A partir de PHP 5.3.2, mysqlnd no permite establecer buffers menores que 4096 bytes.

El valor también se puede establecer usando mysqli_options(enlace, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, tamaño).

mysqlnd.net_read_buffer_size long

Tamaño máximo del trozo de lectura en bytes cuando se lee el cuerpo de un paqute de comando de MySQL. El protocolo cliente servidor de MySQL encapsulta todos sus comandos en paquetes. Los paquetes consisten en una pequeña cabecera y un cuerpo con la carga útil real. El tamaño del cuerpo es codificado en la cabecera. mysqlnd lee el cuerpo en trozos de MIN(tamaño.cabecera, mysqlnd.net_read_buffer_size) bytes. Si un cuerpo de un paquete es mayor que mysqlnd.net_read_buffer_size bytes, mysqlnd tiene que llamar a read() varias veces.

El valor también se puede establecer usando mysqli_options(enlace, MYSQLI_OPT_NET_READ_BUFFER_SIZE, tamaño).

mysqlnd.sha256_server_public_key string

Relacionada con el Complemento de Autenticación SHA-256. El fichero con la clave pública RSA del servidor de MySQL.

Los clientes pueden omitir la configuración de una clave pública RSA, especificar la clave a través de este ajuste de configuración de PHP, o establecer la clave en tiempo de ejecución usando mysqli_options(). Si el cliente no proporciona un fichero de clave pública RSA, entonces la clave será intercambiada como parte del procedimiento de autenticación del Complemento de Autenticación SHA-256.

mysqlnd.fetch_data_copy long

Fuerza la copia de conjuntos de resultados desde los búferes de conjuntos de resultados interno a variables de PHP en lugar de usar la referencia predeterminada y la lógica de Copiar al escribir. Vea las notas de implementación de gestión de memoria para más detalles.

Copiar conjuntos de resultados en lugar de tener variables de PHP que hagan referencia a ellos permite la liberación de la memoria ocupada anteriomente por las variables de PHP. Dependiendo del código de la API de usuario, de las consultas reales de la base de datos y del tamaño de sus conjuntos de resultados, se podría reducir la huella de memoria de mysqlnd.

No se ha de establecer si se usa PDO_MySQL. PDO_MySQL aún no ha sido actualizado para tener soporte par el nuevo modo de obtención.


Incompatibilidades

El Driver MySQL Native es compatible en muchos casos con la librería MySQL Client (libmysql). Esta sección documenta las incompatibilidades entre estas librerías.

  • Los valores de tipo bit son devueltos como strings binarios (p.e. "\0" o "\x1F") con libmysql y como strings decimales (p.e. "0" o "31") con mysqlnd. Si se desea que el código sea compatible con ambas librerías entonces siempre se deberá devolver campos de tipo bit como números desde MySQL con una consulta como la siguiente: SELECT bit + 0 FROM table.


Conexiones persistentes

Utilizar conexiones persistentes

Si mysqli se utiliza con mysqlnd, cuando se crea una conexión persistente, se genera una llamada COM_CHANGE_USER (mysql_change_user()) en el servidor. Esto asegura que la re-autenticación de la conexión se lleva a cabo.

Dado que hay una cierta sobrecarga asociada con la llamada COM_CHANGE_USER, es posible apagar esto en el tiempo de compilado. La reutilización de una conexión persistente entonces generará una llamada COM_PING (mysql_ping) para simplemente probar si la conexión es reusable.

La generación de COM_CHANGE_USER se puede apagar con el marcador de compilación MYSQLI_NO_CHANGE_USER_ON_PCONNECT. Por ejemplo:

shell# CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT" ./configure --with-mysql=/usr/local/mysql/ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-pdo-mysql=/usr/local/mysql/bin/mysql_config --enable-debug && make clean && make -j6

O, alternativamente:

shell# export CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT"
shell# configure --whatever-option
shell# make clean
shell# make

Observe que solamente mysqli sobre mysqlnd utiliza COM_CHANGE_USER. Otra combinación de extensión-controlador emplea COM_PING en el uso inicial de una conexión persistente.


Estadísticas

Usar datos estadísticos

El Controlador Nativo de MySQL soporta la obtención de estadísticas sobre la comunicación entre el cliente y el servidor. Las estadísticas obtenidas son de dos tipos principales:

  • Estadísticas del cliente

  • Estadísticas de conexión

Si se está usando la extensión mysqli, estas estadísticas se pueden obtener a través de dos llamadas a la API:

  • mysqli_get_client_stats()

  • mysqli_get_connection_stats()

Nota:

Las estadísticas son acumuladas entre todas las extensiones que usan el Controlador Nativo de MySQL. Por ejemplo, al compilar ext/mysql y ext/mysqli con el Controlador Nativo de MySQL, las llamadas a las funciones de ext/mysql y ext/mysqli cambiarán las estadísticas. No existe ninguna forma de averiguar cuanto ha impactado una cierta llamada a la API de una extensión que ha sido compilada con el Controlador Nativo de MySQL en una cierta estadística. Se puede configurar el Controlador PDO MySQL, ext/mysql y ext/mysqli para que opcionalmente usen el Controlador Nativo de MySQL. Cuando se hace esto, las tres extensiones cambiarán las estadísticas.

Acceder a las estadísticas del cliente

Para acceder a las estadísticas del cliente se necesita llamar a mysqli_get_client_stats(). La llamada a la función no necesita ningún parámetro.

La función devuelve un array asociativo que contiene el nombre de la estadística como clave y los datos de la estadística como valor.

A las estadísticas del cliente también se pueden acceder llamando a la función phpinfo().

Acceder a las estadísticas de conexión

Para acceder a las estadísticas de conexión se ha de llamar a mysqli_get_connection_stats(). Esta toma el gestor de conexión de la base de datos como parámetro.

La función devuelve un array asociativo que contiene el nombre de la estadística como clave y los datos de la estadística como valor.

Conjuntos de resultados almacenados y no almacenados en buffer

Los conjuntos de resultados puede ser almacenados o no almacenados en buffer. Al usar la configuración predeterminada, ext/mysql y ext/mysqli trabajan con conjuntos de resultados almacenados en buffer para consultas normales (sentencia no preparada). Los conjuntos de resultados almacenados en buffer son almacenados en la caché del cliente. Después de la ejecución de una consulta, todos los resultados son traidos desde el Servidor MySQL y almacenados en una caché del cliente. La gran ventaja de los conjuntos de resultados almacenados en buffer es que permiten al servidor liberar todos los recursos asignados a un conjunto de resultados, una vez que los resultados han sido obtenidos por el cliente.

Por otra parte, los conjuntos de resultados no almacenados en buffer se mantienen mucho más tiempo en el servidor. server. Si se quiere reducir el consumo de memoria del cliente, aunque incrementando la carga del servidor, se han de usar conjunto de resultados no almacenados en buffer. Si se experimenta una alta carga del servidor y las cigras de los conjuntos de resultados no almacenados en buffer son altas, se debería considerar trasladar la carga a los cliente. Estos normalmente escalan mejor que los servidores. La carga no solamente se refiere a los buffers de memoria - el servidor también necesita mantener otros recursos abiertos, como por ejemplo, gestores de ficheros e hilos, antes de que un conjunto de resultados sea liberado.

Las Sentencias Preparadas usan conjuntos de resultados no almacenados en buffer de manera predeterminada. Sin embargo, se puede usar mysqli_stmt_store_result() para habilitar los conjuntos de resultados almacenados en buffer.

Estadísticas devueltas por el Controlador Nativo de MySQL

Las siguientes tablas muestran una lista de las estadísticas devueltas por las funciones mysqli_get_client_stats() y mysqli_get_connection_stats().

Estadísticas devueltas de mysqlnd: Red
Estadística | Ámbito | Descrpción | Notas
bytes_sent | Conexión | Número de bytes enviados desde PHP al servidor MySQL | Se puede usar para comprobar la eficiencia del protocolo de compresión
bytes_received | Conexión | Número de bytes recibidos desde el servidor MySQL | Se puede usar para comprobar la eficiencia del protocolo de compresión
packets_sent | Conexión | Número de paquetes enviados del protocolo Cliente Servidor de MySQL | Usado para la depuración de la implementación del protoclo Cliente Servidor
packets_received | Conexión | Número de paquetes recividos del protocolo Cliente Servidor de MySQL | Usado para la depuración de la implementación del protoclo Cliente Servidor
protocol_overhead_in | Conexión | MySQL Client Server protocol overhead in bytes for incoming traffic. Currently only the Packet Header (4 bytes) is considered as overhead. protocol_overhead_in = packets_received * 4 | Used for debugging Client Server protocol implementation
protocol_overhead_out | Conexión | Carga adicional de protocolo Cliente Servidor de MySQL en bytes para el tráfico saliente. Actualmente, sólo el Paquete de Cabecera (4 bytes) se considera como carga adicional. protocol_overhead_out = packets_sent * 4 | Usado para la depuración de la implementación del protoclo Cliente Servidor
bytes_received_ok_packet | Conexión | Tamaño total en bytes de los paquetes OK recibidos del protocolo Cliente Servidor de MySQL. Los paquetes OK pueden contener un mensaje de estado. La longitud del mensaje de estado puede variar y, por lo tanto, el tamaño del paquete OK no es fijo. | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_ok | Conexión | Número de paquetes OK recibidos del protocolo Cliente Servidor de MySQL. | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_eof_packet | Conexión | Tamaño total en bytes de los paquetes OEF recibidos del protocolo Cliente Servidor de MySQL. EOF puede variar de tamaño dependiendo de la versión del servidor. También, EOF puede transportar un mensaje de error. | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_eof | Conexión | Número de paquetes EOF del del protocolo Cliente Servidor de MySQL. Al igual que otras estadísticias de paquetes, el número de paquetes se incrementará incluso si PHP no recibe el paquete esperado, sino, por ejemplo, un mensaje de error. | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_rset_header_packet | Conexión | Tamaño total en bytes de los paquetes de cabecera de conjuntos de resultados del protocolo Cliente Servidor de MySQL. El tamaño de los paquetes varía dependiendo de la carga útil (LOAD LOCAL INFILE, INSERT, UPDATE, SELECT, mensaje de error). | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_rset_header | Conexión | Número de paquetes de cabecera de conjuntos de resultados del protocolo Cliente Servidor de MySQL. | Usado para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_rset_field_meta_packet | Conexión | Tamaño total en bytes de los paquetes de metadatos (información de campos) de conjuntos de resultados del protocolo Cliente Servidor de MySQL. Por supuesto, el tamaño total vaía con los campos del conjunto de resultados. El paquete también puede transportar un error o un paquete EOF en el caso de COM_LIST_FIELDS. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_rset_field_meta | Conexión | Número de paquetes de metadatos (información de campos) de conjuntos de resultados del protocolo Cliente Servidor de MySQL. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_rset_row_packet | Conexión | Tamaño total en bytes de los paquetes de datos de fila de conjuntos de resultados del protocolo Cliente Servidor de MySQL. El paquete también puede transportar un error o un paquete EOF. Se puede obtener el número de error y los paquetes EOF restando rows_fetched_from_server_normal y rows_fetched_from_server_ps de bytes_received_rset_row_packet. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_rset_row | Conexión | Número de paquetes de datos de fila de conjuntos de datos del protocolo Cliente Servidor de MySQL y su tamaño total en bytes. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_prepare_response_packet | Conexión | Tamaño total de los paquetes OK para la Inicialización de Sentencias Preparadas del protocolo Cliente Servidor de MySQL (paquetes init de sentencias preparadas). El paquete también puede transportar un error. El tamaño del paquete depende de la versión de: 9 bytes con MySQL 4.1 y 12 bytes desde MySQL 5.0. No existe una manera segura de conocer cuántos errores han sucedido. Se puede suponer que ha sucedido un error si, por ejemplo, si siempre se conecta a MySQL 5.0 o superior y bytes_received_prepare_response_packet != packets_received_prepare_response * 12. Véase también ps_prepared_never_executed, ps_prepared_once_executed. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_prepare_response | Conexión | Número de paquetes OK para la Inicialización de Sentencias Preparadas del protocolo Cliente Servidor de MySQL (paquetes init de sentencias preparadas). | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
bytes_received_change_user_packet | Conexión | Tamaño total en bytes de los paquetes COM_CHANGE_USER del protocolo Cliente Servidor de MySQL. El paquete también puede transportar un error o EOF. | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_received_change_user | Conexión | Número de paquetes COM_CHANGE_USER del protocolo Cliente Servidor de MySQL | Solamente útil para la implementación de protocolo CS. Observe que el tamaño total en bytes incluye el tamaño del paquete de cabecera (4 bytes, véase la carga adicional del protocolo - protocol_overhead_*).
packets_sent_command | Conexión | Número de comandos enviados del protocolo Cliente Servidor de MySQL desde PHP a MySQL. No hay forma de conocer los comandos específicos ni cuántos han sido enviados. En el mejor de los casos, se puede usar para comprobar si PHP ha enviado cualquier comando a MySQL para saber si se puede considerar deshabilitar el soporte para MySQL en el binario de PHP. Tampoco hay forma de obtener el número de errores que pueden haber ocurrido mientras se envían datos a MySQL. El único error que se registra es command_buffer_too_small (véase abajo). | Solamente útil para la implementación de protocolo CS.
bytes_received_real_data_normal Conexión Número de bytes de carga útil obtenidos por el cliente de PHP desde mysqlnd usando el protocolo de texto. Es el tamaño de los datos reales contenidos en conjuntos de resultados que no son originados desde sentencias preparadas y que han sido obtenidos por el cliente de PHP. Observe que aunque un conjunto de resultados completo puede haber sido obtenido desde MySQL por mysqlnd, esta estadística únicamente cuenta los datos reales obtenidos desde mysqlnd por el cliente de PHP. Un ejemplo de una secuencia de código que incrementará el valor es el siguiente:
$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->fetch_assoc();
$res->close();

Cada operación de obtención incrementará el valor.

La estadística no se incrementará si el conjunto de resultados sólo se almancena en buffer en el cliente, pero no se obtiene, como en el siguiente ejemplo:

$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->close();

Esta estadística está disponible a partir de la versión 5.3.4 de PHP.

bytes_received_real_data_ps | Conexión | Número de bytes de la carga útil obtenida por el cliente de PHP desde mysqlnd usando el protocolo de sentencias preparadas. | Es el tamaño de los datos reales contenidos en conjuntos de resultados que no son originados desde sentencias preparadas y que han sido obtenidos por el cliente de PHP. El valor no será incrementado si el conjunto de resultados no es leído subsiguientemente por el cliente de PHP. Observe que aunque un un conjunto de resultados completo puede haber sido obtenido desde MySQL por mysqlnd, esta estadística únicamente cuenta los datos reales obtenidos desde mysqlnd por el cliente de PHP. Véase también bytes_received_real_data_normal. Esta estadística está disponible a partir de la versión 5.3.4 de PHP.

Conjuntos de Resultados

Estadísticas devueltas de mysqlnd: Conjunto de Resultados
Estadística | Ámbito | Descrpción | Notas
result_set_queries | Conexión | Número de consultas que han generado un conjunto de resultados. Ejemplos de consultas que generan un conjunto de resultados: SELECT, SHOW. La estadística no será incrementada si hay un error al leer el paquete de cabecera del conjunto de resultados desde la línea. | Se puede usar como una medida indirecta del número de consultas que PHP ha enviado a MySQL, por ejemplo, para identificar un cliente que causa una carga alta de base de datos.
non_result_set_queries | Conexión | Número de consultas que no generan un conjunto de resultados. Ejemplos de consultas que no generan un conjunto de resultados: INSERT, UPDATE, LOAD DATA, SHOW. La estadística no será incrementada si hay un error al leer el paquete de cabecera del conjunto de resultados desde la línea. | Se puede usar como una medida indirecta del número de consultas que PHP ha enviado a MySQL, por ejemplo, para identificar un cliente que causa una carga alta de base de datos.
no_index_used | Conexión | Número de consultas que ha generado un conjunto de resultados pero que no usan un índice (véase también la opción de inicio de mysqld –log-queries-not-using-indexes). Si se desea que estas consultas sean reportadas, se puede usar mysqli_report(MYSQLI_REPORT_INDEX) para hacer que ext/mysqli lance una excepción. Si se prefiere una advertencia en lugar de una excepción, use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT).
bad_index_used | Conexión | Número de consultas que han generado un conjunto de resultados y que no usan un índice bueno (véase también la opción de inicio de mysqld –log-slow-queries). | Si se desea que estas consultas sean reportadas, se puede usar mysqli_report(MYSQLI_REPORT_INDEX) para hacer que ext/mysqli lance una excepción. Si se prefiere que se emita una advertencia en lugar de una excepción, use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT)
slow_queries | Conexión | Senetencias SQL que toman más de long_query_time segundos para ejecutarse y que requieren al menos min_examined_row_limit filas para ser examinadas. | No reportadas a través de mysqli_report()
buffered_sets | Conexión | Número de conjuntos de resultados almacenados en buffer mediante consultas normales. Normal significa sentencia no preparada en las siguientes notas. | Ejemplos de llamada a la API que almacenarán en buffer conjuntos de resultados en el cliente: mysql_query(), mysqli_query(), mysqli_store_result(), mysqli_stmt_get_result(). Al almacenar en buffer conjuntos de resultados en el cliente se asegura que los recursos del servidor sean liberados tan pronto como sea posible y hace que el desplazamiento del conjunto de resultados sea más sencillo. El inconveniente es el consumo adicional de memoria en el cliente para almacenar en buffer datos. Observe que mysqlnd (a diferencia de la Biblioteca Cliente de MySQL) respeta el límite de memoria de PHP debido a que utiliza las funciones de gestión de memoria internas de PHP para asignar memoria. Ésta también es la razón de por qué memory_get_usage() informa de un consumo de memoria al usar mysqlnd en lugar de la Bliblioteca Cliente de MySQL. memory_get_usage() no mide en absoluto el consumo de memoria de la Bliblioteca Cliente de MySQL debido a que ¡la Biblioteca Cliente de MySQL no usa las funciones de gestión de memoria internas de PHP monitorizadas por la función!
unbuffered_sets | Conexión | Número de conjuntos de resultados no almacenados en buffer devueltos por consultas normales (sentencia no preparada). | Ejemplos de llamadas a la API que no almacenan en buffer conjuntos de resultados en el clilente: mysqli_use_result()
ps_buffered_sets | Conexión | Número de conjuntos de resultados almacenados en buffer devueltos por sentencias preparadas. Por defecto, las sentencias preparadas no se almacenan en buffer. | Ejemplos de llamadas a la API que no almacenarán en buffer conjuntos de resultados en el cliente: mysqli_stmt_store_result
ps_unbuffered_sets | Conexión | Número de conjuntos de resultados no almacenados en buffer devueltos por sentencias preparadas. | Por defecto, las sentencias preparadas no se almacenan en buffer.
flushed_normal_sets Conexión Número de conjuntos de resultados de consultas normales (sentencia no preparada) con datos no leídos que han sido volcados de manera silenciosa. El volcado sucede solamente con conjuntos de resultados no almacenados en buffer. Los conjuntos de resultados no almacenados en buffer deben ser obtenidos completamente antes de que una nueva consulta pueda ser ejecutada en la conexión, si no, MySQL lanzará un error. Si la aplicación no obtiene todas las filas de un conjunto de resultados no almacenado en buffer, mysqlnd obtendrá implícitamente el conjunto de resultados para limpiar la línea. Véase también rows_skipped_normal, rows_skipped_ps. Algunas posibles causas de un volcado implícito:

  • Aplicación cliente defectuosa

  • El cliente para de leer después de que encuentre que lo que estaba buscando, pero ha hecho que MySQL calcule más registros que los necesarios

  • La aplicación cliente se ha detenido de improviso

flushed_ps_sets Conexión Número de conjuntos de resultados de sentencias preparadas con datos no leídos que han sido volcados de forma silenciosa. El volcado sucede solamente con conjuntos de resultados no almacenados en buffer. Los conjuntos de resultados no almacenados en buffer deben ser obtenidos completamente antes de que una nueva consulta pueda ser ejecutada en la conexión, si no, MySQL lanzará un error. Si la aplicación no obtiene todas las filas de un conjunto de resultados no almacenado en buffer, mysqlnd obtendrá implícitamente el conjunto de resultados para limpiar la línea. Véase también rows_skipped_normal, rows_skipped_ps. Algunas posibles causas de un volcado implícito:

  • Aplicación cliente defectuosa

  • El cliente para de leer después de que encuentre que lo que estaba buscando, pero ha hecho que MySQL calcule más registros que los necesarios

  • La aplicación cliente se ha detenido de improviso

ps_prepared_never_executed | Conexión | Número de sentencias preparadas pero nunca ejecutadas. | Las sentencias preparadas ocupan recursos del servidor. No se debería preparar una sentencia si no se planea ejecutarla.
ps_prepared_once_executed | Conexión | Número de sentencias preparadas ejecutadas una única vez. | Una de las ideas detrás de las sentencias preparadas es que la misma consulta se ejecuta una y otra vez (con diferentes parámetros) y así se puede ahorrar algo de análisis y otros trabajos de preparación, si la ejecución de la sentencia se divide en diferentes fases de preparación y ejecución. La idea es preparar una vez y almacenar en caché los resultados, por ejemplo, el árbol de análisis a ser reutilizado durante la ejecución de sentencias múltiples. Si se ejecuta una sentencia prearada una sola vez, los dos procesamientos de las fases pueden ser ineficientes comparados con consultas normales, ya que todo el almacenamiento en caché significa trabajo extra y toma recursos (limitados) del servidor para mantener la información almacenada en caché. Consecuentemente, las sentencias preparadas que son ejecutadas una sola vez pueden causar daños al rendimiento.
rows_fetched_from_server_normal, rows_fetched_from_server_ps | Conexión | Número total de conjuntos de resultados obtenidos con éxito de MySQL sin considerar si la aplicación cliente los ha consumido o no. Algunas filas pueden no haber sido obtenidas por la aplicación cliente aunque hayan sido volcadas implícitamente. | Véase también packets_received_rset_row
rows_buffered_from_client_normal, rows_buffered_from_client_ps | Conexión | Número total de filas almacenadas en buffer con éxito originadas desde una consulta "normal" o una sentencia preparada. Este es el número de filas que han sido obtenidas de MySQL y almacenadas en buffer en el cliente. Observe que existen dos estadísticas distintas de filas que has sido almacenadas en buffer (MySQL al buffer internto de mysqlnd) y filas almacenadas en buffer que han sido obtenidas por la aplicación cliente (buffer interno de mysqlnd a la aplicación cliente). Si el número de filas almacenadas en buffer es mayor que el número de filas almacenadas en buffer obtenidas, puede significar que la aplicación cliente ejecuta consultas que originan conjuntos de resultados grandes que necesitan resultar en filas no leídas por el cliente. | Ejemplos de consultas que almacenarán en buffer resultados: mysqli_query(), mysqli_store_result()
rows_fetched_from_client_normal_buffered, rows_fetched_from_client_ps_buffered | Conexión | Número total de filas obtenidas por el cliente desde un conjunto de resultados almacenado en buffer creado por una consulta normal o una sentencia preparada.
rows_fetched_from_client_normal_unbuffered, rows_fetched_from_client_ps_unbuffered | Conexión | Número total de filas obtenidas por el cliente desde un conjunto de resultados no almacenado en buffer creado por una consulta "normal" o una sentencia no preparada.
rows_fetched_from_client_ps_cursor | Conexión | Número total de filas obtenidas por el cliente desde un cursor creado por una sentencia preparada.
rows_skipped_normal, rows_skipped_ps | Conexión | Reservado para un uso futuro (actualmente no soportado)
copy_on_write_saved, copy_on_write_performed | Proceso | Con mysqlnd, las variables devueltas por las extensiones apuntan a los buffers de resultados de red internos de mysqlnd. Si no se cambian las variables, los datos obtenidos serán conservados en memoria una sola vez. Si se cambian las variables, mysqlnd tiene que realizar una copia mientras se escribe para proteger los buffers de resultados de red internos de ser cambiados. Con la Biblioteca Clientes de MySQL siempre se conservan dos veces en memoria los datos obtenidos. Una en los buffers internos de la Biblioteca Cliente de MySQL y otra en las variables devueltas por las extensiones. En teoría, mysqlnd puede ahorrar hasta un 40% de memoria, Sin embargo, observe que el ahorro de memoria no puede ser medido usando memory_get_usage().
explicit_free_result, implicit_free_result | Conexión, Processo (sólo durante la limpieza de sentencias preparadas) | Número de total de conjuntos de resultados liberados. | La liberación es considerada siempres explícita excepto para conjuntos de resultados creados por un comando init, por ejemplo, mysqli_options(MYSQLI_INIT_COMMAND , ...)
proto_text_fetched_null, proto_text_fetched_bit, proto_text_fetched_tinyint proto_text_fetched_short, proto_text_fetched_int24, proto_text_fetched_int proto_text_fetched_bigint, proto_text_fetched_decimal, proto_text_fetched_float proto_text_fetched_double, proto_text_fetched_date, proto_text_fetched_year proto_text_fetched_time, proto_text_fetched_datetime, proto_text_fetched_timestamp proto_text_fetched_string, proto_text_fetched_blob, proto_text_fetched_enum proto_text_fetched_set, proto_text_fetched_geometry, proto_text_fetched_other Conexión Número total de columnas de un cierto tipo obtenidas de una consulta normal (protocolo de texto de MySQL). Referencia de los tipos de metadatos de la API de C / MySQL para el nombre de la estadística:

  • MYSQL_TYPE_NULL - proto_text_fetched_null

  • MYSQL_TYPE_BIT - proto_text_fetched_bit

  • MYSQL_TYPE_TINY - proto_text_fetched_tinyint

  • MYSQL_TYPE_SHORT - proto_text_fetched_short

  • MYSQL_TYPE_INT24 - proto_text_fetched_int24

  • MYSQL_TYPE_LONG - proto_text_fetched_int

  • MYSQL_TYPE_LONGLONG - proto_text_fetched_bigint

  • MYSQL_TYPE_DECIMAL, MYSQL_TYPE_NEWDECIMAL - proto_text_fetched_decimal

  • MYSQL_TYPE_FLOAT - proto_text_fetched_float

  • MYSQL_TYPE_DOUBLE - proto_text_fetched_double

  • MYSQL_TYPE_DATE, MYSQL_TYPE_NEWDATE - proto_text_fetched_date

  • MYSQL_TYPE_YEAR - proto_text_fetched_year

  • MYSQL_TYPE_TIME - proto_text_fetched_time

  • MYSQL_TYPE_DATETIME - proto_text_fetched_datetime

  • MYSQL_TYPE_TIMESTAMP - proto_text_fetched_timestamp

  • MYSQL_TYPE_STRING, MYSQL_TYPE_VARSTRING, MYSQL_TYPE_VARCHAR - proto_text_fetched_string

  • MYSQL_TYPE_TINY_BLOB, MYSQL_TYPE_MEDIUM_BLOB, MYSQL_TYPE_LONG_BLOB, MYSQL_TYPE_BLOB - proto_text_fetched_blob

  • MYSQL_TYPE_ENUM - proto_text_fetched_enum

  • MYSQL_TYPE_SET - proto_text_fetched_set

  • MYSQL_TYPE_GEOMETRY - proto_text_fetched_geometry

  • Any MYSQL_TYPE_* no listado antes (no debería ser ninguno) - proto_text_fetched_other

Observe que las constantes MYSQL_*-type pueden no estar asociadas con los mismos tipos de columnas SQL en cada versión de MySQL.

proto_binary_fetched_null, proto_binary_fetched_bit, proto_binary_fetched_tinyint proto_binary_fetched_short, proto_binary_fetched_int24, proto_binary_fetched_int, proto_binary_fetched_bigint, proto_binary_fetched_decimal, proto_binary_fetched_float, proto_binary_fetched_double, proto_binary_fetched_date, proto_binary_fetched_year, proto_binary_fetched_time, proto_binary_fetched_datetime, proto_binary_fetched_timestamp, proto_binary_fetched_string, proto_binary_fetched_blob, proto_binary_fetched_enum, proto_binary_fetched_set, proto_binary_fetched_geometry, proto_binary_fetched_other | Conexión | Número total de columnas de un cierto tipo obtenidas desde una sentencia preparada (protocolo binario de MySQL). | Para la referenciacición de tipos, véase proto_text_* descrito en el texto anterior.
Estadísticas devueltas de mysqlnd: Conexión
Estadística | Ámbito | Descrpción | Notas
connect_success, connect_failure | Conexión | Número total de intentos de conexión con éxito/falladas. | Están incluidas las conexiones rechazadas y los demás tipos de conexiones.
reconnect | Proceso | Número total de intentos de conexión verdadera (real_) hechas sobre un gestor de conexión ya abierto. | La secuencia de código $enlace = new mysqli(...); $enlace->real_connect(...) ocasionará una reconexión. Pero $link = new mysqli(...); $enlace->connect(...) no lo hará ya que $enlca->connect(...) cerrará explícitamente la conexión existente antes de que se establezca una nueva conexión.
pconnect_success | Conexión | Número total de intentos de conexión persistente realizados con éxito. | Observe que connect_success contiene la suma de intentos de conexión persistente y no persistente realizados con éxito. El número de intentos de conexión no persistente realizados con éxito es connect_success - pconnect_success.
active_connections | Conexión | Número total de conexiones persistentes y no persistentes activas.
active_persistent_connections | Conexión | Número de conexiones persistentes activas. | El número total de conexiones no persistentes activas es active_connections - active_persistent_connections.
explicit_close Conexión Número total de conexiones cerradas explícitamente (sólo ext/mysqli). Ejemplos de trozos de código que causan un cierre explícito :
$enlace = new mysqli(...); $enlace->close(...)
$enlace = new mysqli(...); $enlace->connect(...)
implicit_close Conexión Número total de conexiones cerradas implícitamente (sólo ext/mysqli). Ejemplos de trozos de código que causan un cierre implícito :

  • $enlace = new mysqli(...); $enlace->real_connect(...)

  • unset($enlace)

  • Conexión persistente: conexión almacenada en caché que ha sido creada con real_connect y que puede poseer un conjunto de opciones desconocidas - cerrar implícitamente para evitar devolver una conexión con opciones desconocidas

  • Conexión persistente: ping/change_user falla y ext/mysqli cierra la conexión

  • fin de la ejecución de un script: cierra la conexiones que no han sido cerradas por el usuario

disconnect_close | Conexión | Fallos de conexión indicados por la llamada a la API en C de mysql_real_connect() durante un intento de establecer una conexión. | Es llamada disconnect_close porque el gestor de conexión pasado a la llamada a la API en C será cerrado.
in_middle_of_command_close | Proceso | Una conexión ha sido cerrada en mitad de la ejecución de un comando (conjuntos de resultados pendientes no obtenidos, después de enviar una consulta y antes de obtener una respuesta, mientras se obtienen los datos, mientras se transfieren datos con LOAD DATA). | A menos que se usen consultas asíncronas, esto únicamente debería ocurrir si el script se detiene inesperadamente y PHP cierra las conexiones por sí solo.
init_command_executed_count | Conexión | Número totas de ejecuciones de comandos init, por ejemplo, mysqli_options(MYSQLI_INIT_COMMAND , ...). | El número de ejecuciones realizadas con éxito es init_command_executed_count - init_command_failed_count.
init_command_failed_count | Conexión | Número total de comnados init fallados.
Estadísticas devueltas de mysqlnd: Comando COM_*
Estadística Ámbito Descrpción Notas
com_quit, com_init_db, com_query, com_field_list, com_create_db, com_drop_db, com_refresh, com_shutdown, com_statistics, com_process_info, com_connect, com_process_kill, com_debug, com_ping, com_time, com_delayed_insert, com_change_user, com_binlog_dump, com_table_dump, com_connect_out, com_register_slave, com_stmt_prepare, com_stmt_execute, com_stmt_send_long_data, com_stmt_close, com_stmt_reset, com_stmt_set_option, com_stmt_fetch, com_daemon Conexión Número total de intentos de enviar un cierto comando COM_* desde PHP a MySQL.

Las estadísticas son incrementadas después de comprobar la línea e inmediatamente antes de enviar el paquete de protocolo cliente-servidor de MySQL correspondiente. Si mysqlnd falla al enviar el paquete sobre el cable, las estadísticas no serán incrementadas. En case de fallo, mysqlnd emite una advertencia de PHP Error while sending %s packet. PID=%d.

Ejemplos de uso:

  • Comprobar si PHP eviía ciertos comandos a MySQL, por ejemplo, comprobar si un cliente envía COM_PROCESS_KILL

  • Calcuar el promedio de ejecuciones de sentencias preparadas comparando COM_EXECUTE con COM_PREPARE

  • Comprobar si PHP ha ejecuato cualquier sentencia SQL no preparada comprobando si COM_QUERY es cero

  • Identificar los scripts de PHP que ejecutan un número excesivo de sentencias SQL comprobando COM_QUERY y COM_EXECUTE

Miscelánea

Estadísticas devueltas de mysqlnd: Miscelánea
Estadística | Ámbito | Descrpción | Notas
explicit_stmt_close, implicit_stmt_close | Proceso | Número total de sentencias preparadas cerradas. | Un cierre siempre es considerado explícito excepto para una preparación fallida.
mem_emalloc_count, mem_emalloc_ammount, mem_ecalloc_count, mem_ecalloc_ammount, mem_erealloc_count, mem_erealloc_ammount, mem_efree_count, mem_malloc_count, mem_malloc_ammount, mem_calloc_count, mem_calloc_ammount, mem_realloc_count, mem_realloc_ammount, mem_free_count | Proceso | Llamadas de gestión de memoria. | Solamente desarrollo.
command_buffer_too_small Conexión Número de extensiones de buffer de comandos de red mientras se envían comando desde PHP a MySQL.

mysqlnd asigna un buffer de comandos/red interno de mysqlnd.net_cmd_buffer_size (php.ini) bytes para cada conexión. Si un comando del protocolo Cliente Servidor de MySQL, por ejemplo, COM_QUERY (consulta normal), no se ajusta al buffer, mysqlnd will aumentará el buffer lo que sea necesario para enviar el comando. Siempre que el buffer se extienda para una conexión, command_buffer_too_small será incrementado en uno.

Si mysqlnd tiene que aumentar el buffer más allá de su tamaño inicial de mysqlnd.net_cmd_buffer_size (php.ini) bytes para casi todas las conexiones, se debería considerar aumentar el tamaño predeterminado para evitar reasignaciones.

El tamaño predeterminado del buffer es de 2048 bytes en PHP 5.3.0. En futuras versiones, el tamaño predeterminado serán de 4kB o más. Se puede cambiar el valor predeterminado a través de php.ini estableciendo mysqlnd.net_cmd_buffer_size o usando mysqli_options(MYSQLI_OPT_NET_CMD_BUFFER_SIZE, int tamaño).

Se recomienda establecer el tamaño de buffer a no menos de 4096 bytes debido a que mysqlnd también lo utiliza al leer ciertos paquete de comunicación desde MySQL. En PHP 5.3.0, mysqlnd no aumentará el buffer si MySQL envía un paquete que es más grande que el tamaño actual del buffer. Como consecuencia, mysqlnd no es capaz de decodificar el paquete y la aplicación cliente obtendrá un error. Solamente hay dos situacioines en las que un paquete es más grande que los 2048 bytes predeterminados de mysqlnd.net_cmd_buffer_size en PHP 5.3.0: el paquete transporta un mensaje de error muy grande, o el paquete contiene los metadatos de columnas de COM_LIST_FIELD (mysql_list_fields()) y los metadatos provienen de una columna de cadena con un valor predeterminado muy grande (>1900 bytes). No existe reporte de errores sobre esto - debería ocurrir raramente.

A partir de PHP 5.3.2, mysqlnd no permite establecer buffers menores que 4096 bytes.

connection_reused


Notas

En esta sección se ofrece una colección de diversas notas sobre el uso del Controlador Nativo de MySQL.

  • Utilizar mysqlnd significa que se están utilizando flujos PHP para la conectividad subyacente. Para mysqlnd, se debe consultar la documentación de flujos de PHP (Flujos) para detalles como la configuración del tiempo de espera, y no la documentación para la Biblioteca Cliente de MySQL.


Gestión de la memoria

Introducción

El Controlador Nativo de MySQL gestiona la memoria de forma diferente que la Biblioteca Cliente de MySQL. Las bibliotecas difieren en la manera en que asigan y liberan memoria, en cómo la memoria se asigna en trozos mientras se leen los resultados desde MySQL, en las opciones de depuración y desarrollo que existen, y en cómo los resultados leídos desde MySQL son vinculados a variables de usuario de PHP.

Las siguientes notas tienen por objeto sre una introducción y resumen a los usuarios interesados en comprender el Controlador Nativo de MySQL al nivel de código en C.

Funciones de gesitón de memoria usadas

Toda la asignación y desasignación de memoria se realiza usando las funciones de gestión de memoria de PHP. Por lo tanto, el consumo de memoria de mysqlnd se puede monitorizar usando llamadas a la API de PHP, tales como memory_get_usage(). Ya que la memoria es asignada y desasignada usando el gestor de memoira de PHP, los cambios podrían no ser visibles de inmediato al nivel del sistema operativo. El gestor de memoria de PHP actúa como un proxy que podría demorar la liberación de memoria con respecto al sistema. Debido a esto, la comparación de la memoria usada por el Controlador Nativo de MySQL y la Biblioteca Cliente de MySQL es difícil. La Biblioteca Cliente de MySQL usa directamente llamadas al gestor de memoria del sistema operativo, por lo que los efectos se pueden observar inmediatamente al nivel del sistema operativo.

Cualquier límite de memoria dictado por PHP también afecta al Controlador Nativo de MySQL. Esto podría causar errores de agotamiento de memoria al obtener conjuntos de resultados grandes que excedan el tamaño de la memoria restante que ha dispuesto PHP. Ya que la Biblioteca Cliente de MySQL no utiliza las funciones de gestión de memoria de PHP, no obedece a ningún límite de memoria establecido por PHP. Si se usa la Biblioteca Cliente de MySQL, dependiendo del modelos de distribución, la huella de memoria del proceso de PHP podría crecer más alla del límite de memoria de PHP. Aunque también, los scripts de PHP que podrían procesar conjuntos de resultados más grandes, ya que las partes de la memoria asignada para mantener los conjuntos de resultados están más allá del control del motor de PHP.

Las funciones de gestión de memoria de PHP son invocadas por el Controlador Nativo de MySQL a través de una envoltura ligera. Entre otras cosas, la envoltura hace la depuración más sencilla.

Manejo de conjuntos de resultados

Los diferentes servidores de MySQL y las diferentes API de cliente distinguen entre conjuntos de resultados almacenados y no almacenados en búfer. Los conjuntos de resultados no almacenados en búfer son transferidos fila a fila desde MySQL al cliente, mientras que este recorre los resultados. Los resultados almacenados en búfer se obtienen en su totalidad mediante la biblioteca cliente antes de pasarlos al cliente.

El Controlador Nativo de MySQL utiliza Flujos de PHP para la comunicación en red con el Servidor de MySQL. Los resultados enviados por MySQL se obtienen desde los búferes de red de los Flujos de PHP al búfer de resultados de mysqlnd. El búfer de resultados está hecho de zvals. En un segundo paso, los resultados ya están disponibles para el script de PHP. Esta transferencia final desde el búfer de resultados a variables de PHP impacta sobre el consumo de memoria y, lo más notable, al usar conjuntos de resultados almacenados en búfer.

Por defecto, el Controlador Nativo de MySQL intenta evitar mantener dos veces en memoria resultados almacenados en búfer. Los resultados se guardan una sola vez en los búferes de resultados internos y en sus zvals. Cuando los resultados son alojados en variables de PHP por el script de PHP, las variables harán referencia a los búferes de resultados internos. Los resultados de consultas de la base de datos no se copian y se guardan en memoria una sola vez. If el usuario modificase el contenido de una variable que contiene resultados de la base de datos, se debe realizar una Copia al escribir ('copy-on-write') para evitar que se cambie el búfer de resultados interno referenciado. El contenido del búfer no debe ser modificado porque el usuario podría decidir leer el conjunto de resultados una segunda vez. El mecanismo de Copia al escribir está implementado usando una lista de gestores de referencias adicional y el uso de contadores de referencias zval estándar. 'Copy-on-write' también se debe realizar si el usuario lee un conjunto de resultados y lo pasa a variables de PHP, y luego libera el conjunto de resultados antes de que las variables se destruyan.

De forma general, este patrón funciona bien con scripts que lean un conunto de resultados una vez y no modifiquen las variables que contienen los resultados. Su mayor desventaja es la carga adicional de memoria causada por la gestión adicional de referencias que viene primariamente por el hecho de que las variables de usuario que contienen los resultados no se pueden liberar completamente hasta que el gestor de referencias de mysqlnd deje de hacer referencia a ellas. El Controlador Nativo de MySQL elimina las referencias de las variables de usuario cuando el conjunto de resultados es liberado o se realiza una Copia al escribir. Un observador verá el consumo total de memoria crecer hasta que el conjunto de resultados sea liberado. Use las estadísticas para verificar si un script libera el conjunto de resultados explícitamente o el controlador lo hace implícitamente, y por lo tanto, la memoria es utilizada por un periodo de tiempo mayor que el necesario. Las estadísticas también ayudan a ver cómo ocurren las operaciones de Copiar al escribir.

Un script que lea muchas filas pequeñas de un conjunto de resultados almacenado en búfer usando un trozo de código igual o equivalente a while ($fila = $res->fetch_assoc()) { ... } podría optimizar el consumo de memoria solitando copias en lugar de referencias. Aunque, solicitar copias significa mantener los resultados dos veces en memoria, permite a PHP liberar la copia contenida en $fila mientras el conjunto de resultados está siendo recorrido y antes de liberarlo. Un servidor cargado que optimice el uso de picos de memoria, podría ayudar a mejorar el rendimiento total del sistema aunque, para un script solo, la estrategia de copia podría ser más lenta debido a las operaciones de asignación y copia de memoria adicionales.

Se puede forzar el modo copia estableciendo mysqlnd.fetch_data_copy=1.

Monitorización y depuración

Hay muchas maneras de monitorizar el uso de memoria del Controlador Nativo de MySQL. Si el objetivo es obtener un resumen de alto nivel o verificar la eficiendia de memoria de scripts de PHP, compruebe las estadísticas recopiladas por la biblioteca. Las estadísticas permiten, por ejemplo, capturar sentencias SQL que generen más resultados que los procesados por un script de PHP.

El registro de seguimiento debug puede configurarse para grabar llamadas al gestor de memoria. Esto ayuda a ver cuándo la memoria es asignada o liberada. Sin embargo, el tamaño de los trozos de memoria solicitados podrían no mostrarse en la lista.

Algunas versiones recientes del Controlador Nativo de MySQL introducen la emulación de situaciones aleatorias de agotamiento de memoria. Se pretende que esta característica sea usada solamente por los desarroladores en C de la biblioteca los autores del complemento de mysqlnd. Busque el código fuente para los ajuestes de configuración de PHP correspondientes y para más detalles. La característica está considerada privada y podría ser modificada en cualquier momento sin previo aviso.


API de Complementos del Controlador Nativo de MySQL

Tabla de contenidos

  • Una comparación de los complementos de mysqlnd y el Proxy de MySQL
  • Obtener la API de complementos de mysqlnd
  • Arquitectura de los Complementos del Controlador Nativo de MySQL
  • La API de complementos de mysqlnd
  • Empezar a construir un complemento de mysqlnd

La API de Complementos del Controlador Nativo de MySQL es una característica del Controlador Nativo de MySQL, o mysqlnd. Los complementos de mysqlnd operan en la capa que hay entre las aplicaciones de PHP y el servidor MySQL. Es comparable al Proxy de MySQL. El Proxy de MySQL opera sobre una capa entre cualquier aplicación cliente de MySQL, por ejemplo, una aplicación de PHP, y el servidor de MySQL. Los complementos de mysqlnd can undertake typical MySQL Proxy tasks such as load balancing, monitorizan y optimizan el rendimiento. A causa de la arquitectura y ubicación diferentes, los complementos de mysqlnd no tienen algunas de las desventajas del Proxy de MySQL. Por ejemplo, con los complementos no existe un único punto de fallo, ni un servidor proxy para el despliegue, y no hace falta aprender un nuevo lenguaje de programación (Lua).

Se puede pensar en un complemento de mysqlnd como una extensión de mysqlnd. Los complementos pueden interceptar la mayoría de las funciones de mysqlnd. Las funciones de mysqlnd son llamadas por las extensiones de MySQl de PHP, como ext/mysql, ext/mysqli, y PDO_MYSQL. Como resultado, es posible que un complemento de mysqlnd intercepte todas las llamadas hechas a estas extensiones desde la apliacación cliente.

Las llamadas a funciones internas de mysqlnd también pueden ser interceptadas o reemplazadas. No existen restricciones en la manipulación de tablas de funciones internas de mysqlnd. Es posible configurar cosas, y así cuando ciertas funciones de mysqlnd son llamadas por extensiones que utilizan mysqlnd, la llamada es dirigida a la función apropiada del complemento de mysqlnd. La capacidad de manipular tablas de funciones internas de mysqlnd de esta manera permite una flexibilidad máxima para los complementos.

Los complementos de mysqlnd son de hecho Extensiones de PHP, escritos en C, que utilizan la API de complementos de mysqlnd (la cual está construida dentro del Controlador Nativo de MySQL, mysqlnd). Los complementos se pueden hacer 100% transparentes a las aplicaciones de PHP. No es necesario hacer ningún cambio a las aplicaciones ya que los complementos operan en una capa diferente. Se puede pensar en los complementos de mysqlnd como en una operación en una capa por debajo de mysqlnd.

La siguiente lista representa algunas aplicaciones posibles de los complementos de mysqlnd.

  • Equilibrio de Carga

    • División de Lectura/Escritura. Un ejemplo de esto es la extensión PECL/mysqlnd_ms (Maestro Esclavo). Esta extensión divide las consultas de lectura/escritura para una configuración de réplica.

    • Tolerancia a fallos

    • Rotación de servidores para evitar la sobrecarga ("Round-Robin")

  • Monitorización

    • Registro de Consultas

    • Análisis de Consultas

    • Audición de Consultas. Un ejemplo de esto es la extensión PECL/mysqlnd_sip (Protección contra la Inyección SQL). Esta extensión inspecciona las consultas y ejecuta únicamente aquellas que están permitidas según un cojunto de reglas.

  • Rendimiento

    • Almacenamiento en Caché. Un ejemplo de esto es la extenión PECL/mysqlnd_qc (Caché de Consultas).

    • Estrangulamiento ("Throttling")

    • Fragmentación. Un ejemplo de esto es la extensión PECL/mysqlnd_mc (Multiconexión). Esta extensión intentará dividir una sentencia SELECT en n partes, usando SELECT ... LIMIT parte_1, SELECT LIMIT parte_n. Envía las consultas a diferentes servidores MySQL y combina el resultado en el cliente.

Complementos del Controlador Nativo de MySQL disponibles

Hay varios complementos de mysqlnd ya disponibles. Estos incluyen:

  • PECL/mysqlnd_mc - Complemento de Multiconexión.

  • PECL/mysqlnd_ms - Complemento Maestro Esclavo.

  • PECL/mysqlnd_qc - Complemento de Caché de Consultas.

  • PECL/mysqlnd_pscache - Complemento de Caché de Gestores de Sentencias Preparadas.

  • PECL/mysqlnd_sip - Complemento de Protección contra Inyección SQL.

  • PECL/mysqlnd_uh - Complemento de Gestor de Usuarios.


Una comparación de los complementos de mysqlnd y el Proxy de MySQL

Los complementos de mysqlnd y el Proxy de MySQL son diferentes tecnologías que utilizan diferentes enfoques. Ambos son herramientas válidas para resolver una variedad de tareas comunes tales como el equilibrio de carga, monitorización, y mejoras en el rendimiento. Una diferencia importante es que el Proxy de MySQL funciona con todos los clientes de MySQL, mientras que los complementos de mysqlnd son específicos de aplicaciones de PHP.

Al igual que una Extensión de PHP, un complemento de mysqlnd se instala en el servidor de aplicaciones de PHP, junto con el resto de PHP. El Proxy de MySQL puede ejecutarse sobre el servidor de aplicaciones de PHP o ser instalado en una máquina dedicada para manejar múltiples servidores de aplicaciones de PHP.

El despliegue del Proxy de MySQL sobre un servidor de aplicaciones tiene dos ventajas:

  1. No tiene un único punto de fallo

  2. Fácil escalabilidad (escalabilidad horizontal, escalabilidad por cliente)

El Proxy de MySQL (y los complementos de mysqlnd) pueden resolver problemas fácilmente que de otro modo requerirían cambios en las aplicaciones existentes.

Sin embargo, el Proxy de MySQL tiene algunas desventajas:

  • El Proxy de MySQL es un componente y una tecnología nuevos que son necesarios llegar a dominar y desplegar.

  • El Proxy de MySQL requiere conocimientos del lenguaje de scripts Lua.

El Proxy de MySQL puede ser personalizado con programación en C y Lua. Lua es el lenguaje de scripts preferido del Proxy de MySQL. Para la mayoría de los expertos en PHP, Lua es un nuevo lenguaje que aprender. Un complemento de mysqlnd puede ser escrito en C. También es posible escribir complementos en PHP usando » PECL/mysqlnd_uh.

El Proxy de MySQL se ejecuta como un demonio - un proceso en segundo plano. El Proxy de MySQL puede recordar decisiones anteriores, ya que todos los estados pueden ser guardados. Sin embargo, un complemento de mysqlnd está vinculado al ciclo de vida basado en peticiones de PHP. El Proxy de MySQL también comparte resultados computados una única vez entre múltiples servidores de aplicaciones. Un complemento de mysqlnd necesitaría almacenar los datos en un medio persistente para poder hacer esto. Sería necesario otro demonio para este propósito, tal como Memcache. Esto otorga al Proxy de MySQL una ventaja en este caso.

El Proxy de MySQL funciona en lo más alto del protocolo de cable. Con el Proxy de MySQL se ha de analizar y usar ingenierá inversa con el Protocolo Cliente Servidor de MySQL. Las acciones están limitadas a aquellas que pueden realizarse manipulando el protocolo de comunicación. Si el protocolo de calbe cambia (lo que ocurre muy raramente), los scripts del Proxy de MySQL necesitarían cambiarse también.

Los complementos de Mysqlnd funcionan en lo más alto de la API en C, la cual refleja el cliente libmysqlclient y las APIs Connector/C. ESta API en C es básicamente una envoltura sobre el protocolo Cliente Servidor de MySQL, o protocolo de cable, como es llamado a veces. Se pueden interceptar todas las llamadas a la API en C. PHP hace uso de la API en C, por lo que se pueden enganchar todas las llamadas de PHP, sin necesidad de programar en el nivel del protocolo de cable.

Mysqlnd implementa el protocolo de cable. Los complementos pueden, por lo tanto, analizar, usar ingeniería inversa, manipular e incluso reemplazar el protocolo de comunicación. Sin embargo, esto normalmente no es necesario.

Ya que los complementos permiten crear implementaciones que utilizan dos niveles (la API en C y el protocolo de cable), tienen más flexibilidad que el Proxy de MySQL. Si un complemento de mysqlnd es implementado usando la API en C, cualquier cambio subsiguiente al protocolo de cable no requerirá cambios en el complemento en sí.


Obtener la API de complementos de mysqlnd

La API de complementos de mysqlnd es sencillamente parte de la extensión del Controlador Nativo de MySQL de PHP, ext/mysqlnd. El desarrollo de la API de complementos de mysqlnd comenzó en diciembre de 2009. Está desarrollado como parte del repositorio fuente de PHP, y como tal está disponible al público vía Git, o a través de las descargas de instantáneas del código fuente.

La siguiente tabla muestra las versiones de PHP y la versión correspondiente de mysqlnd contenida dentro.

La versión incluída de mysqlnd por versión de PHP
Versión de PHP | Versión del Controlador Nativo de MySQL
5.3.0 | 5.0.5
5.3.1 | 5.0.5
5.3.2 | 5.0.7
5.3.3 | 5.0.7
5.3.4 | 5.0.7

Los desarrolladores de complementos pueden determinar la versión de mysqlnd accediendo a MYSQLND_VERSION, que es una cadena en el formato mysqlnd 5.0.7-dev - 091210 - $Revision: 300535, o a través de MYSQLND_VERSION_ID, que es un valor integer tal como 50007. Los desarrolladores pueden calcular el número de versión como sigue:

Tabla de cálculo de MYSQLND_VERSION_ID
Versión (parte) | Ejemplo
Mayor*10000 | 5*10000 = 50000
Menor*100 | 0*100 = 0
Parche | 7 = 7
MYSQLND_VERSION_ID | 50007

Durante el desarrollo, los desarroladores deberían consultar el número de versión de mysqlnd por compatibilidad y pruebas de versión, ya que varias iteraciones de mysqlnd podrían ocurrir durante el ciclo de vida de una rama de desarrollo de PHP con un número de versión de PHP único.


Arquitectura de los Complementos del Controlador Nativo de MySQL

Esta sección proporciona información general de la arquitectura de los complementos de mysqlnd.

Información general del Controlador Nativo de MySQL

Antes de desarrollar complementos de mysqlnd, es útil conocer un poco cómo mysqlnd está organizado. Mysqlnd consiste en los siguientes módulos:

La gráfica de organización de mysqlnd, por módulo
Módulos de estadísticas | mysqlnd_statistics.c
Conexión | mysqlnd.c
Conjunto de resultados | mysqlnd_result.c
Metadatos de conjuntos de resultados | mysqlnd_result_meta.c
Sentencia | mysqlnd_ps.c
Red | mysqlnd_net.c
Protocolo de cable | mysqlnd_wireprotocol.c

Paradigma de la orientación a objetos de C

A nivel de código, mysqlnd utiliza un patrón de C para implementar la orientación a objetos.

En C se utiliza una estrucutra (struct) para representar un objeto. Los miembros de la estructura representan las propiedades del objeto. Los miembros de la estrucutra que apuntan a funciones representan los métodos.

A diferencia de otros lenguajes como C++ o Java, no existen reglas fijas sobre herencia en el paradigma de la orientación a objetos de C. Sin embargo, existen algunas convenciones que se han de seguir y serán discutidas más tarde.

El ciclo de vida de PHP

Al considerar el ciclo de vida de PHP existen dos ciclos básicos:

  • El ciclo de inicio y cierre del motor de PHP

  • El ciclo de peticiones

Cuando se inicia el motor de PHP, éste llamará a la función de inicialización de módulos (MINIT) para cada extensión registrada. Esto permite a cada módulo establecer variables y asignar recursos que existirán durante el tiempo de vida del proceso del motor de PHP. Al cerrar el motor de PHP, éste llamará a las funciones de cierre de módulos (MSHUTDOWN) para cada extensión.

Durante el tiempo de vida del motor de PHP, éste recibirá varias peticiones. Cada petición constituye otro ciclo de vida. En cada petición, el motor de PHP llamará a la función de inicialización de peticiones para cada extensión. La extensión puede realizar cualquier establecimiento de variables y asignación de recursos necesarios para el proceso de petición. Al finalizar el ciclo de peticiones, el motor llama a la función de cierre de peticiones (RSHUTDOWN) de cada extensión, por lo que la extensión puede realizar cualquier limpieza necesaria.

Cómo funciona un complemento

Un complemento de mysqlnd funciona interceptando llamada realizadas a mysqlnd por extensiones que utilizan mysqlnd. Esto se lleva a cabo obteniendo la tabla de funciones de mysqlnd, haciendo una copia de seguridad de ella, y reemplazándola por una tabla de funciones personalizada, la cual llamará a las funciones del complemento cuando sea necesario.

El siguiente código muestra cómo se reemplaza la tabla de funciones de mysqlnd:

/* un lugar para almacenar la tabla de funciones original */
struct st_mysqlnd_conn_methods org_methods;

void minit_register_hooks(TSRMLS_D) {
  /* activar la tabla de funciones */
  struct st_mysqlnd_conn_methods * current_methods
    = mysqlnd_conn_get_methods();

  /* copiar la tabla de funciones original */
  memcpy(&org_methods, current_methods,
    sizeof(struct st_mysqlnd_conn_methods);

  /* instalar nuevos métodos */
  current_methods->query = MYSQLND_METHOD(my_conn_class, query);
}

La manipulación de la tabla de funciones de conexión debe hacerse durante la Inicialización de Módulos (MINIT). La tabla de funciones es un recurso global compartido. En un entorno multihilo, con un TSRM construido, la manipulación de un recurso global compartido durante el proceso de peticiones resultará en conflictos casi con toda seguridad.

Nota:

No utilice cualquier lógica de tamaña fijo al manipular la tablas de funciones de mysqlnd: los métodos nuevos se pueden añadir al final de la tabla de funciones. La tabla de funciones puede cambiar en cualquier momento en el futuro.

Llamar a métodos padre

Si las entradas de la tabla de funciones original está copiada, aún es posible llamar a las entradas de la tabla de funciones original - los métodos padre.

En algunos casos, como en Connection::stmt_init(), es vital llamar al método padre antes de realizar cualquier otra actividad en el método derivado.

MYSQLND_METHOD(my_conn_class, query)(MYSQLND *conn,
  const char *query, unsigned int query_len TSRMLS_DC) {

  php_printf("my_conn_class::query(query = %s)\n", query);

  query = "SELECT 'query rewritten' FROM DUAL";
  query_len = strlen(query);

  return org_methods.query(conn, query, query_len); /* retorno con llamada al padre */
}

Extender propiedades

Un objeto mysqlnd está representado por una estrucutra de C. No es posible añadir un miembro a una estructura de C en tiempo de ejecución. Los usuarios de objetos mysqlnd no pueden simplemente añadir propiedades a los objetos.

Se pueden añadir datos arbitrarios (propiedades) a objetos mysqlnd usando la función apropiada de la familia de mysqlnd_plugin_get_plugin_<object>_data(). Cuando se asigna un objeto, mysqlnd reserva espacio al final del objeto para que contenga un puntero void * a datos arbitrarios. mysqlnd reserva espacio para un puntero void * por complemento.

La siguiente tabla muestra cómo calcular la posición del puntero para un complemento específico:

Cálculos de puntero para mysqlnd
Dirección de memoria | Contenido
0 | Inicio de la estructura de C del objeto mysqlnd
n | Fin de la estructura de C del objeto mysqlnd
n + (m x sizeof(void*)) | void* a los datos del objeot del complemento m-ésimo

Si se planea usar cualquier constructor de objetos mysqlnd en subclases, lo cual está permitido, ¡se debe tener esto en cuenta!

El siguiente código muestra la extensión de propiedades:

/* cualquier dato que queramos asociar */
typedef struct my_conn_properties {
  unsigned long query_counter;
} MY_CONN_PROPERTIES;

/* id del complemento */
unsigned int my_plugin_id;

void minit_register_hooks(TSRMLS_D) {
  /* obtener un ID único para el complemento */
  my_plugin_id = mysqlnd_plugin_register();
  /* recorte - véase Extender conexiones: métodos */
}

static MY_CONN_PROPERTIES** get_conn_properties(const MYSQLND *conn TSRMLS_DC) {
  MY_CONN_PROPERTIES** props;
  props = (MY_CONN_PROPERTIES**)mysqlnd_plugin_get_plugin_connection_data(
    conn, my_plugin_id);
  if (!props || !(*props)) {
    *props = mnd_pecalloc(1, sizeof(MY_CONN_PROPERTIES), conn->persistent);
    (*props)->query_counter = 0;
  }
  return props;
}

El desarrollador del complemento es responsable de la gestión de memoria de lo datos del complemento.

Se recomienda el uso del asignador de memoria de mysqlnd para los datos del complemento. Estas funciones son nombradas usando la convención: mnd_*loc(). El asignador de mysqlnd tiene algunas características útiles, como la capacidad de usar un asignador de depuración en una construcción de no depuración.

Cuándo y cómo usar subclases
 | ¿Cuándo usar subclases? | ¿Cada instancia tiene su propia tabla de funciones privada? | ¿Cómo usar subclases?
Conexión (MYSQLND) | MINIT | No | mysqlnd_conn_get_methods()
Conjunto de resultados (MYSQLND_RES) | MINIT o después | Sí | mysqlnd_result_get_methods() o manipulación de la tabla de funciones de métodos de objetos
Metadatos de conjunto de resultados (MYSQLND_RES_METADATA) | MINIT | No | mysqlnd_result_metadata_get_methods()
Sentencia (MYSQLND_STMT) | MINIT | No | mysqlnd_stmt_get_methods()
Red (MYSQLND_NET) | MINIT o después | Sí | mysqlnd_net_get_methods() o manipulación de la tabla de funciones de métodos de objetos
Protocolo de cable (MYSQLND_PROTOCOL) | MINIT o después | Sí | mysqlnd_protocol_get_methods() o manipulación de la tabla de funciones de métodos de objetos

No se deben manipular las tablas de funciones en ningún momento posterior a MINIT si no está permitido según la tabla de arriba.

Algunas clases contienen un puntero a la tabla de funciones de métodos. Todas las instancias de esas clases compartirán la misma tabla de funciones. Para evitar el caos, en particular en entornos de hilos, tales tablas de funciones deben ser manipuladas solamente durante MINIT.

Otras clases usan copias de una tabla de funciones compartida globalmente. La copia de la tabla de funciones de la clase se crea junto con el objeto. Cada objeto usa su propia tabla de funciones. Esto proporciona dos opciones: se puede manipular la tabla de funciones predetermiada de un objeto durante MINIT, y además se pueden perfeccionar métodos de un objeto sin impactar otras instancias de la misma clase.

La ventaja del enfoque de la tabla de funciones compartida es el rendimiento. No hay necesidad de copiar una tabla de funciones para cada objeto.

Estado del constructor
Asignación, construcción, reinicio | ¿Se puede modificar? | Llamador
Conexión (MYSQLND) | mysqlnd_init() | No | mysqlnd_connect()
Conjunto de resultados (MYSQLND_RES)

Asignación:

  • Connection::result_init()

Reinicio y reinicialización durante:

  • Result::use_result()

  • Result::store_result

Sí, ¡pero se ha de llamar al padre!

  • Connection::list_fields()

  • Statement::get_result()

  • Statement::prepare() (Solamente metadatos)

  • Statement::resultMetaData()

Metadatos de conjunto de resultados (MYSQLND_RES_METADATA) | Connection::result_meta_init() | Sí, ¡pero se ha de llamar al padre! | Result::read_result_metadata()
Sentecia (MYSQLND_STMT) | Connection::stmt_init() | Sí, ¡pero se ha de llamar al padre! | Connection::stmt_init()
Red (MYSQLND_NET) | mysqlnd_net_init() | No | Connection::init()
Protocolo de cable (MYSQLND_PROTOCOL) | mysqlnd_protocol_init() | No | Connection::init()

Se recomienda encarecidamente que no se reemplace completamente un constructor. Los constructores realizan asignaciones de memoria. Las asignaciones de memoria son vitales para la API de complementos de mysqlnd y la lógida de objetos de mysqlnd. Si no se tiene cuidado con las advertencias y se insiste en enganchar los constructores, se debería, al menos, llamar al constructor padre antes de hacer nada en el constructor derivado.

A pesar de todas las advertencias, puede ser útil usar subclases para los constructores. Éstos son el lugar perfecto para modificar las tablas de funciones de objetos con tablas de objetos no compartidas, como Conjunto de resultados, Red, Protocolo de cable.

Estado de la destrucción
 | ¿Debe el método derivado llamar al padre? | Destructor
Conexión | sí, después de la ejecución del método | free_contents(), end_psession()
Conjunto de resultados | sí, después de la ejecución del método | free_result()
Metadatos del conjunto de resultados | sí, después de la ejecución del método | free()
Sentencia | sí, después de la ejecución del método | dtor(), free_stmt_content()
Red | sí, después de la ejecución del método | free()
Protocolo de cable | sí, después de la ejecución del método | free()

Los destructores son los lugares apropiados para liberar propiedades mysqlnd_plugin_get_plugin_<objeto>_data().

Los destructores listados podrían no ser equivalentes a los métodos reales de mysqlnd que liberan el objeto en sí. Sin embargo, son el mejor lugar posible para enganchar y liberar los datos de los complementos. Como sucede con los constructores se pueden reemplazar los métodos completamente, pero no se recomienda. Si se listan múltiles métodos en la tabla de arriba, se necesitará enganchar todos esos métodos y liberar los datos del complemento en el método correspondiente que sea llamado primero por mysqlnd.

El método recomendado para los complementos es simplemente enganchar los métodos, liberar la memoria y llamar a la implementación padre inmediatamente después de esto.

Precaución

Debido a un error en las versiones de PHP 5.3.0 hasta 5.3.3, los complementos no asocian los datos de los complementos con una conexión persistente. Esto es debido a que ext/mysql y ext/mysqli no desencadenan las llamadas necesarias al método end_psession() de mysqlnd, y el complemento podría, por lo tanto, perder memoria. Esto ha sido corregido en PHP 5.3.4.


La API de complementos de mysqlnd

La siguiente es una lista de funciones proporcionadas en la API de complementos de mysqlnd:

  • mysqlnd_plugin_register()

  • mysqlnd_plugin_count()

  • mysqlnd_plugin_get_plugin_connection_data()

  • mysqlnd_plugin_get_plugin_result_data()

  • mysqlnd_plugin_get_plugin_stmt_data()

  • mysqlnd_plugin_get_plugin_net_data()

  • mysqlnd_plugin_get_plugin_protocol_data()

  • mysqlnd_conn_get_methods()

  • mysqlnd_result_get_methods()

  • mysqlnd_result_meta_get_methods()

  • mysqlnd_stmt_get_methods()

  • mysqlnd_net_get_methods()

  • mysqlnd_protocol_get_methods()

No existe una definción formal de lo que es un complemento y cómo funciona el mecanismo de un complemento.

Los componentes que se encuentran a menudo en los mecanismos de los complementos son:

  • Un gestor de complemento

  • Una API de complemento

  • Servicios de aplicación (o módulos)

  • APIs de servicios de aplicación (o APIs de módulos)

El concepto de complemento de mysqlnd emplea estas características, y además disgruta de una arquitectura abierta.

Sin restricciones

Un complemento tiene acceso completo al funcionamiento interno de mysqlnd. No existen límites de seguridad o restricciones. Todo puede ser sobrescrito para implementar algoritmos amistosos u hostiles. Se recomienda que se desplieguen complementos desde una fuente de confianza.

Como se discutió anteriormente, los complementos puede usar punteros libremente. Estos punteros no están restringidos de ninguna manera, y pueden apuntar a los datos de otros complementos. Se puede usar una sencilla aritmética de índices para leer los datos de otros complementos.

Se recomienda que se escriban complementos cooperativos, y que siempre se llame al método padre. Los complemento deberían siempre cooperar con mysqlnd.

Cuestiones: un ejemplo de encadenamiento y cooperación
Extensión | puntero de mysqlnd.query() | pila de llamdas si se llama al padre
ext/mysqlnd | mysqlnd.query() | mysqlnd.query
ext/mysqlnd_cache mysqlnd_cache.query()

  1. mysqlnd_cache.query()

  2. mysqlnd.query

ext/mysqlnd_monitor mysqlnd_monitor.query()

  1. mysqlnd_monitor.query()

  2. mysqlnd_cache.query()

  3. mysqlnd.query

En este escenario, se cargan una caché (ext/mysqlnd_cache) y un complemento monitor (ext/mysqlnd_monitor). Ambos subclases de Connection::query(). El registro del complemento sucede en MINIT usando la lógica mostrada anteriormente. PHP llama a las extensiones en orden alfabético de manera predeterminada. Los complementos no son conscientes de los demás complementos y no establecen dependencias de extensiones.

Por omisión, los complementos llaman a la implementación padre del método de consulta en sus versiones derivadas del método.

Resumen de las extensiones de PHP

Este es un resumen de lo que sucede cuando se usa un complemento de ejemplo, ext/mysqlnd_plugin, el cual expone la API de complementos en C de mysqlnd a PHP:

  • Cualquier apliacación de MySQL de PHP intenta establecer una conexión con 192.168.2.29

  • La aplicación de PHP usará ext/mysql, ext/mysqli o PDO_MYSQL. Estas tres extensiones de MySQL de PHP utilizan mysqlnd para establecer la conexión con 192.168.2.29.

  • Mysqlnd llama a sus método de conexión, los cuales han sido derivados por ext/mysqlnd_plugin.

  • ext/mysqlnd_plugin llama al gancho del espacio de usuario proxy::connect() registrado por el usuario.

  • El gancho del espacio de usuario cambia la IP de conexión del anfitrión de 192.168.2.29 a 127.0.0.1 y devuelve la conexión establecida por parent::connect().

  • ext/mysqlnd_plugin realiza el equivalente de parent::connect(127.0.0.1) llamando al método original de mysqlnd para establecer una conexión.

  • ext/mysqlnd establece una conexión y devuelve a ext/mysqlnd_plugin. ext/mysqlnd_plugin devuelve también.

  • Cualquiera que sea la extensión de MySQL de PHP que haya sido usada por la aplicación, ésta recibe una conexión a 127.0.0.1. La extensión de MySQL de PHP en sí devuelve a la aplicación de PHP. El círculo se cierra.


Empezar a construir un complemento de mysqlnd

Es importante recordar que un complemento de mysqlnd es una extensión de PHP en sí mismo.

El siguiente código muestra la estructura básica de la función MINIT que se usará en el típico complemento de mysqlnd:

/* my_php_mysqlnd_plugin.c */

 static PHP_MINIT_FUNCTION(mysqlnd_plugin) {
  /* globales, entradas ini, recursos, clases */

  /* registrar el complemento mysqlnd */
  mysqlnd_plugin_id = mysqlnd_plugin_register();

  conn_m = mysqlnd_get_conn_methods();
  memcpy(org_conn_m, conn_m,
    sizeof(struct st_mysqlnd_conn_methods));

  conn_m->query = MYSQLND_METHOD(mysqlnd_plugin_conn, query);
  conn_m->connect = MYSQLND_METHOD(mysqlnd_plugin_conn, connect);
}

/* my_mysqlnd_plugin.c */

 enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, query)(/* ... */) {
  /* ... */
}
enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, connect)(/* ... */) {
  /* ... */
}

Análisis de tareas: de C al espacio de usuario

 class proxy extends mysqlnd_plugin_connection {
  public function connect($host, ...) { .. }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

Proceso:

  1. PHP: el usuario registra la llamada de retorno del complemento

  2. PHP: el usuario llama a cualquier API de MySQL de PHP para conectarse a MySQL

  3. C: ext/*mysql* llama al método de mysqlnd

  4. C: mysqlnd finaliza en ext/mysqlnd_plugin

  5. C: ext/mysqlnd_plugin

    1. Llama a la llamada de retorno del espacio de usuario

    2. O al método original de mysqlnd, si la llamada de retorno del espacio de usuario no está establecida

Es necesario realizar lo siguiente:

  1. Escribir una clase "mysqlnd_plugin_connection" en C

  2. Aceptar y registrar el objeto proxy a través de "mysqlnd_plugin_set_conn_proxy()"

  3. Llamar a los métodos del proxy del espacio de usuario desde C (optimización - zend_interfaces.h)

Se pueden llamar a los métodos del objeto del espacio de usuario usando call_user_function() o se puede operar a nivel cercano al Motor Zend y usar zend_call_method().

Optimización: llamar a los métodos desde C usando zend_call_method

El siguiente trozo de código muestra el prototipo para la función zend_call_method, tomado de zend_interfaces.h.

 ZEND_API zval* zend_call_method(
  zval **object_pp, zend_class_entry *obj_ce,
  zend_function **fn_proxy, char *function_name,
  int function_name_len, zval **retval_ptr_ptr,
  int param_count, zval* arg1, zval* arg2 TSRMLS_DC
);

La API Zend solamente soporta dos argumentos. Se pueden necesitar más, por ejemplo:

 enum_func_status (*func_mysqlnd_conn__connect)(
  MYSQLND *conn, const char *host,
  const char * user, const char * passwd,
  unsigned int passwd_len, const char * db,
  unsigned int db_len, unsigned int port,
  const char * socket, unsigned int mysql_flags TSRMLS_DC
);

Para evitar este problema se necesitará realizar una copia de zend_call_method() y añadir la facilidad para parámetros adicionales. Se puede hacer esto creando un conjunto de macros MY_ZEND_CALL_METHOD_WRAPPER.

Llamar al espacio de usuario de PHP

Este trozo de código muestra el método optimizado para llamar a una función del espacio de usuario desde C:

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class,connect)(
  MYSQLND *conn, const char *host /* ... */ TSRMLS_DC) {
  enum_func_status ret = FAIL;
  zval * global_user_conn_proxy = fetch_userspace_proxy();
  if (global_user_conn_proxy) {
    /* llamar al proxy del espacio de usuario */
    ret = MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, host, /*...*/);
  } else {
    /* o al método original de mysqlnd = no hagas nada, sé transparente */
    ret = org_methods.connect(conn, host, user, passwd,
          passwd_len, db, db_len, port,
          socket, mysql_flags TSRMLS_CC);
  }
  return ret;
}

Llamar al espacio de usuario: argumentos simples

/* my_mysqlnd_plugin.c */

 MYSQLND_METHOD(my_conn_class,connect)(
  /* ... */, const char *host, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_host;
    MAKE_STD_ZVAL(zv_host);
    ZVAL_STRING(zv_host, host, 1);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_host);
    /* ... */
  }
  /* ... */
}

Llamar al espacio de usuario: estrucutras como argumentos

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class, connect)(
  MYSQLND *conn, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_conn;
    ZEND_REGISTER_RESOURCE(zv_conn, (void *)conn, le_mysqlnd_plugin_conn);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_conn, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_conn);
    /* ... */
  }
  /* ... */
}

El primer argumento de la mayoría de los métodos de mysqlnd es un "objeto" de C. Por ejemplo, el primer argumento del método connect() es un puntero a MYSQLND. La estructura MYSQLND representa un objeto de conexión de mysqlnd.

El puntero del objeto de conexión de mysqlnd puede ser comparado con un gestor de ficheros de E/S estándar. Al igual que un gestor de ficheros de E/S estándar, un objeto de conexión de mysqlnd será vinculado al espacio de usuario usando el tipo de variable de recurso de PHP.

Desde C al espacio de usuario y volver

 class proxy extends mysqlnd_plugin_connection {
  public function connect($conn, $host, ...) {
    /* "pre" enganche */
    printf("Connecting to host = '%s'\n", $host);
    debug_print_backtrace();
    return parent::connect($conn);
  }

  public function query($conn, $query) {
    /* "post" enganche */
    $ret = parent::query($conn, $query);
    printf("Query = '%s'\n", $query);
    return $ret;
  }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

Los usuario de PHP pueden llamar a la implementación padre de un método sobrescrito.

Como resultado de la derivación, es posible refinar solamente los métodos seleccionados, y se puede optar por tener "pre" o "post" enganches.

Contruir la clase: mysqlnd_plugin_connection::connect()

/*  my_mysqlnd_plugin_classes.c */

 PHP_METHOD("mysqlnd_plugin_connection", connect) {
  /* ... ¡simplificado! ... */
  zval* mysqlnd_rsrc;
  MYSQLND* conn;
  char* host; int host_len;
  if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rs",
    &mysqlnd_rsrc, &host, &host_len) == FAILURE) {
    RETURN_NULL();
  }
  ZEND_FETCH_RESOURCE(conn, MYSQLND* conn, &mysqlnd_rsrc, -1,
    "Mysqlnd Connection", le_mysqlnd_plugin_conn);
  if (PASS == org_methods.connect(conn, host, /* simplified! */ TSRMLS_CC))
    RETVAL_TRUE;
  else
    RETVAL_FALSE;
}


Complemento de equilibrado de carga y replicación de mysqlnd

  • Introducción
  • Guía rápida y ejemplos
    • Puesta en marcha
    • Ejecutar sentencias
    • Estado de la conexión
    • Sugerencias SQL
    • Transacciones locales
    • Transacciones XA/Distribuidas
    • Nivel de servicio y consistencia
    • ID de transacción globales
    • Integración de una caché
    • Tolerancia a fallos
    • Particionamiento y fragmentación
    • MySQL Fabric
  • Conceptos
    • Arquitectura
    • Agrupación e intercambio de conexiones
    • Manejo de transacciones locales
    • Manejo de errores
    • Errores transitorios
    • Tolerancia a fallos
    • Equilibrado de carga
    • División de lectura-escritura
    • Filtro
    • Nivel de servicio y consistencia
    • IDs de transacciones globales
    • Integración de una caché
    • Clústeres admitidos
    • Transacciones XA/distribuidas
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Fichero de configuración del complemento (>=1.1.x)
  • Constantes predefinidas
  • Funciones de mysqlnd_ms
    • mysqlnd_ms_dump_servers — Devuelve una lista con los servidores actualmente configurados
    • mysqlnd_ms_fabric_select_global — Cambiar al servidor de fragmentación global para una tabla dada
    • mysqlnd_ms_fabric_select_shard — Cambiar a los fragmentos
    • mysqlnd_ms_get_last_gtid — Devuelve el último ID de transacciones global
    • mysqlnd_ms_get_last_used_connection — Devuelve un array que describe la última conexión usada
    • mysqlnd_ms_get_stats — Devuelve la distribución consultas y las estadísticas de conexión
    • mysqlnd_ms_match_wild — Comprueba si el nombre de una tabla coincide con un patrón comodín
    • mysqlnd_ms_query_is_select — Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado
    • mysqlnd_ms_set_qos — Establece la calidad de servicio necesaria de un clúster
    • mysqlnd_ms_set_user_pick_server — Establece una llamada de retorno para la división de lectura/escritura definida por el usuario
    • mysqlnd_ms_xa_begin — Inicia una transacción distribuida/XA entre servidores de MySQL
    • mysqlnd_ms_xa_commit — Consigna una transacción distribuida/XA entre servidores de MySQL
    • mysqlnd_ms_xa_gc — Recolecta basura de transacciones XA no finalizadas después de algún error del servidor
    • mysqlnd_ms_xa_rollback — Revierte una transacción distribuida/XA entre servidores de MySQL
  • Historial de cambios
    • Serie PECL/mysqlnd_ms 1.6
    • Serie PECL/mysqlnd_ms 1.5
    • Serie PECL/mysqlnd_ms 1.4
    • Serie PECL/mysqlnd_ms 1.3
    • Serie PECL/mysqlnd_ms 1.2
    • Serie PECL/mysqlnd_ms 1.1
    • Serie PECL/mysqlnd_ms 1.0


Introducción

El complemento de equilibrado de carga y replicación de mysqlnd (mysqlnd_ms) añade soporte de uso sencillo para la replicación MySQL a todas las extensiones de MySQL para PHP que utilizan mysqlnd.

A partir de la versión 5.3.3 de PHP, el controlador nativo de MySQL para PHP (mysqlnd) ofrece una API en C de complementos internos. Los complementos en C, como el complemento de replicación y equilibrado de carga, pueden extender la funcionalidad de mysqlnd.

El controlador nativo de MySQL para PHP es una biblioteca en C que acompaña a PHP a partir de PHP 5.3.0. Sirve como un sustituto a corto plazo de la Biblioteca Cliente de MySQL (libmysqlclient). El uso de mysqlnd tiene varias ventajas: no son necesarias descargas extra debido a que está incluido con PHP, está bajo la licencia de PHP, hay menor consumo de memoria en ciertos casos, y contiene nueva funcionalidad, como consultas asíncronas.

Los complementos de mysqlnd como mysqlnd_ms operan, en mayor parte, de forma transparente desde la perspectiva del usuario. El complemento de replicación y equilibrado de carga admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP. No cambia las APIs existentes. Por lo tanto, se puede usar fácilmente con las aplicaciones de PHP existentes.

Características principales

Las características principales de PECL/mysqlnd_ms son las siguientes:

  • Es transparente y, por lo tanto, fácil de usar.

    • Admite todas las extensiones de MySQL para PHP.

    • Admite SSL.

    • Es una API consistente.

    • Se requieren pocos cambios o ningún cambio en la aplicación, dependiendo del escenario de uso requerido.

    • Conexiones retardadas: las conexiones a servidores maestros y esclavos no se abren antes de que se ejecute una sentencia SQL.

    • Opcional: uso automático del maestro después de la primera escritura en una petición web, para disminuir el posible impacto de la demora de la replicación.

  • Se puede usar con cualquier solución de clúster MySQL.

    • Replicación MySQL: La división de lectura-escritura la realiza el complemento. Es el foco primario del complemento.

    • Clúster MySQL: La división de lectura-escritura se puede deshabilitar. Es posible la configuración de múltiples maestros.

    • Soluciones de terceros: el complemento está optimizado para la Replicación MySQL, pero se puede usar con cualquier otro tipo de solución de clúster MySQL.

  • Estrategias destacadas de la división de lectura-escritura.

    • Detección automática de SELECT.

    • Admite sugerencias SQL para invalidar el automatismo.

    • Definido por el usuario.

    • Se puede deshabilitar, por ejemplo, al usar un clúster sincrónico, como el Clúster MySQL.

  • Estrategias destacadas del equilibrado de carga.

    • Rotación: elegir un esclavo diferente, de un modo 'round bobin', en cada petición a los esclavos.

    • Aleatorio: elegir un esclavo aleatorio en cada petición a los esclavos.

    • Aleatoiro una vez (adhesión): elegir un esclavo aleatorio una vez para ejecutar todas las peticiones a los esclavos durante toda una petición web.

    • Definido por el usuario. La aplicación puede registrar llamadas de retorno con mysqlnd_ms.

    • PHP 5.4.0 o superior: consideración de transacciones al usar solamente llamadas a la API para controlar transacciones.

    • Equilibrado de carga ponderado: a los servidores se les pueden asignar diferentes propiedades, por ejemplo, para dirigir más peticiones a una máquina potente que a otra menos potente. O para elegir máquinas cercanas para reducir la latencia.

  • ID de transacciones global.

    • Emulación en el lado del cliente. Hace más sencilla la tolerancia a fallos manual del servidor maestro y la promoción de esclavos con clústeres asíncronos, como la Repliación MySQL.

    • Soporte para la característica del identificador de transacciones global interno de MySQL 5.6.5 o superior.

    • Soporte del uso de IDs de transacciones para identificar esclavos asíncronos actualizados para lectura cuando se necesite consistencia de sesión. Observe las restricciones mencionadas en el manual.

    • Estrangulamiento: opcionalmente, el complemento puede esperar a que un esclavo se convierta en "sincrónico" antes de continuar.

  • Niveles de servicio y de consistencia.

    • Las aplicaciones puede solicitar para las conexiones niveles de servicios de consistencia final, de sesión y fuerte. Los nodos adecuados de clústeres se buscarán automáticamente.

    • Los accesos a un esclavo de Replicación MySQL de consistencia final pueden ser reemplazados por accesos rápidos a la caché local de forma transparente para reducir la carga del servidor.

  • Particionamiento y fragmentación

    • Los servidores de un clúster de réplica pueden estar organizados en grupos. Se pueden usar las sugerencias SQL para dirigir manualmente consultas a un grupo específico. La agrupación se puede usar para particionar (fragmentar) los datos, o para paliar problemas de hotspots con actualizaciones.

    • Los filtros de Replicación de MySQL están soportados a través del filtro de tabla.

  • MySQL Fabric

    • Se incluye soporte experimental para MySQL Fabric.

Limitaciones

El mecanismo interno de división de lectura-escritura es muy básico. Cada consulta que comience con SELECT es considerada una petición de lectura para enviarla a un servidor esclavo de MySQL. Todas las demás consultas (como las sentencias SHOW) son consideradas como peticiones de escritura que son enviadas al servidor maestro de MySQL. El comportamiento interno se puede invalidar usando las sugerencias SQL, o una función de llamada de retorno definida por el usuario.

El divisor de lectura-escritura no considera las sentencias múltiples. Éstas son consideradas como una única sentencia. La decisión de dónde ejecutar la sentencia se basará en el comienzo de la dicha sentencia. Por ejemplo, si se usa mysqli_multi_query() para ejecutar la sentencia múltiple SELECT id FROM test ; INSERT INTO test(id) VALUES (1), ésta será redirigida a un servidor esclavo debido a que comienza con SELECT. La sentencia INSERT, la cual es también parte de la sentencia múltiple, no será redirigida a un servidor maestro.

Nota:

Las aplicaciones deben considerar las consecuencias de los intercambios de conexión que se realizan para el equilibrado de carga. Revise la documentación sobre intercambio y agrupación de conexiones, manejo de transacciones, tolerancia a fallos equilibrado de carga y división de lectura-escritura.

Sobre el nombre

La abreviatura mysqlnd_ms significa complemento maestro esclavo de mysqlnd. El nombre fue elegido por una rápida y desordenada prueba de conceptos. Al principio, los desarrolladores no esperaban que se continuase usando el código base.


Guía rápida y ejemplos

Tabla de contenidos

  • Puesta en marcha
  • Ejecutar sentencias
  • Estado de la conexión
  • Sugerencias SQL
  • Transacciones locales
  • Transacciones XA/Distribuidas
  • Nivel de servicio y consistencia
  • ID de transacción globales
  • Integración de una caché
  • Tolerancia a fallos
  • Particionamiento y fragmentación
  • MySQL Fabric

El complemento de equilibrado de carga y replicación de mysqlnd es fácil de usar. Esta guía rápida mostrará los casos de uso típicos, y proporcionará consejos sobre cómo empezar a utilizarlo.

Se recomienda leer las secciones de referencia además de esta guía rápida. Aquí se intenta evitar tratar con conceptos teóricos y limitaciones. En su lugar, se enlazará con las secciones de referencia. Es seguro comenzar con esta guía rápida. Sin embargo, antes de usar el complemento en entornos de objetivos críticos, le animamos a que lea también la información de fondo de las secciones de referencia.

El enfoque es usar mysqlnd_ms de PECL para trabajar con clústeres MySQL asíncronos, a saber, la replicación MySQL. Generalmente hablando, un clúster asíncrono es más difícil de usar que uno sincrónico. Por lo tanto, los usuarios de, por ejemplo, el Clúster MySQL, encontrarán más información de la necesaria.


Puesta en marcha

El complemento está implementado como una extensión de PHP. Vea también las instrucciones de instalación para instalar la extenxión » PECL/mysqlnd_ms.

Compile o configure la extensión (API) de MySQL para PHP (mysqli, PDO_MYSQL, mysql) que planee usar con soporte para la biblioteca mysqlnd. PECL/mysqlnd_ms es un complemento para la biblioteca mysqlnd. Para utilizar el complemento con cualqier extensión de MySQL para PHP, la extensión ha de utilizar la biblioteca mysqlnd.

Después carque la extensión en PHP y active el complemento en el fichero de confuguración de PHP con la directiva de configuración llamada mysqlnd_ms.enable.

Ejemplo #1 Habilitar el complemento (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/ruta/al/complemento_mysqlnd_ms.ini

El complemento utiliza su propio fichero de configuración. Use la directiva de configuración de PHP mysqlnd_ms.config_file para establecer la ruta completa al fichero de configuración específico del complemento. Este fichero debe ser legible por PHP (p.ej., el usuario del servidor web). Por favor, observe que la directiva de configuración mysqlnd_ms.config_file sustituye a mysqlnd_ms.ini_file desde la versión 1.4.0. Es un error común usar la directiva de configuración antigua, la cual ya no está disponible.

Cree un fichero de configuración específico del complemento. Guarde el fichero en la ruta establecida por la directiva de configuración de PHP mysqlnd_ms.config_file.

El fichero de configuración del complemento está basado en JSON. Está dividido en una o más secciones. Cada sección tiene un nombre, por ejemplo, myapp. Cada sección contiene su propio conjunto de ajustes de configuración.

Una sección debe incluir, como mínimo, el servidor maestro de replicación MySQL y establecer una lista de esclavos. El complemento admite únicamente un servidor maestro por sección. La configuración de replicación MySQL de múltiples maestros aún no está totalemnte soportada. Use el ajuste de configuración master para establecer el nombre del anfitrión y el puerto o socket del servidor maestro de MySQL. Los servidores esclavos de MySQL se configuran usando la palabra clave slave.

Ejemplo #2 Fichero de configuración mínima específico del complemento (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": [

        ]
    }
}

Es necesario configurar una lista de servidores esclavos de MySQL, aunque puede contener una lista vacía. Se recomienda que siempre se configure al menos un servidor esclavo.

Las listas de servidores pueden usar la sintaxis anónima o no anónima. Las listas no anónimas incluyen sobrenombres para los servidores, tales como master_0 para el maestro del ejemplo de arriba. Esta guía rápida utiliza la sintaxis no anónima más prolija.

Ejemplo #3 Configuración mínima recomendada específica del complemento (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Si al menos existen dos servidores en total, el complemento puede empezar a equilibrar la carga e intercambiar conexiones. El intercambio de conexiones no siempre es transparente y puede ocasionar problemas en ciertos casos. Las secciones de referencia sobre intercambio y agrupación de conexiones, manejo de transacciones, tolerancia a fallos equilibrado de carga y división de lectura-escritura proporcionan más detalles. Los problemas potenciales están descritos más tarde en esta guía.

Es responsabilidad de la aplicación manejar los problemas potenciales causados por el intercambio de conexiones, configurando un servidor maestro con al menos un servidor esclavo, lo cual permite el intercambio para trabajar con los problemas relacionados que se puedan encontrar.

Los servidores maestros y esclavos de MySQL que se configuren no necesitan ser parte de la configuración de replicación MySQL. Para realizar pruebas, se puede usar un único servidor MySQL y hacerle saber al complemento que se trata de un servidor maestro y esclavo, como se muestra abajo. Esto podría ser de ayuda para detectar muchos problemas potenciales con los intercambios de conexión. Sin embargo, tal configuración no será propensa a los problemas causados por la demora de replicación.

Ejemplo #4 Usar un servidor como maestro y esclavo (¡solamente para pruebas!)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

El complemento intenta notificarle de configuraciones inválidas. Desde 1.5.0, lanzará una advertencia durante el arranque de PHP si no se puede leer el fichero de configuración, está vacío, o falló el análisis de JSON. Según la configuración de PHP, estos errores podrían aparecer únicamente en algunos ficheros log. Se hace una validación extra cuando se establece una conexión y se buscan secciones válidas en el fichero de configuración. Establecer mysqlnd_ms.force_config_usage podría ayudar a depurar una configuración incorrecta. Véanse también las notas de depuración del fichero de configuración.


Ejecutar sentencias

El complemento se puede usar con cualquier extensión de MySQL para PHP (mysqli, mysql, y PDO_MYSQL) que esté compilada para utilizar la biblioteca mysqlnd. PECL/mysqlnd_ms se acopla a la biblioteca mysqlnd. No cambia la API o el comportamiento de estas extensiones.

Siempre que se esté abriendo una conexión a MySQL, el complemento compara el valor del parámetro 'host' de la llamada de conexión con los nombres de las secciones del fichero de configuración específico del complemento. Si, por ejemplo, el fichero de configuración específico del complemento tiene una sección myapp , se ha de hacer referencia a ésta para abrir una conexión a MySQL para el anfitrión myapp

Ejemplo #1 Fichero de configuración específico del complemento (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Ejemplo #2 Abrir una conexión con equilibrado de carga

<?php
/* El equilibrado de carga sigue las reglas de la sección "myapp" del fichero de configuración del complemento */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
$pdo = new PDO('mysql:host=myapp;dbname=base_datos', 'nombre_usuario', 'contraseña');
$mysql = mysql_connect("myapp", "nombre_usuario", "contraseña");
?>

Los ejemplos de conexión de arriba tendrán equilibrio de carga. El complemento enviará sentencias de sólo lectura al servidor esclavo de MySQL con la IP 192.168.2.27 y escuchará el puerto 3306 para la conexión cliente de MySQL. Todas las demás sentencias serán dirigidas al servidor maestro de MySQL que se ejecuta en el anfitrión localhost. Si se ejecuta en sistemas operativos de tipo Unix, el maestro sobre localhost aceptará conexiones cliente de MySQL en el socket de dominio Unix /tmp/mysql.sock, mientras que TCP/IP es el puerto predeterminado en Windows. El complemento usará el nombre de usuario nombre_usuario y la contraseña contraseña para conectarse a cualquier servidor de MySQL incluido en la sección myapp del fichero de configuración del complemento. Una vez realizada la conexión, el complemento seleccionará base_datos como el esquema actual.

El nombre de usuario, la contraseña y el nombre del esquema son tomados de las llamadas a la API de conexión y usados por todos los servidores. En otras palabras: se deben usar los mismos nombre de usuario y contraseña para cada servidor MySQL incluido en una sección del fichero de configuración del comlemento. No es una limitación generalizada. A partir de PECL/mysqlnd_ms 1.1.0, es posible establecer username y password para cualquier servidor del fichero de configuración del complemento, para utilizarlos en lugar de las credenciales pasadas a la llamada a la API.

El complemento no cambia la API para ejecutar sentencias. La división de lectura-escritura se desarrolla aparte. El siguiente ejemplo asume que no existe una demora de replicación significante entre el maestro y el esclavo.

Ejemplo #3 Ejecutar sentencias

<?php
/* El equilibrado de carga sigue las reglas de la sección "myapp" del fichero de configuración del complemento */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (mysqli_connect_errno()) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Las sentencias se ejcutarán en el maestro */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* solo lectura: la sentencia se ejecutará en un esclavo */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
    $fila = $res->fetch_assoc();
    $res->close();
    printf("El esclavó devuelve el ID = '%s'\n", $fila['id'];
}
$mysqli->close();
?>

El resultado del ejemplo sería algo similar a:

El esclavó devuelve el ID = '1'


Estado de la conexión

El complemento cambia la semántica de un gestor de conexión de MySQL para PHP. Un gestor de conexión representa una agrupación de conexiones, en lugar de una única conexión de red cliente-servidor de MySQL. La agrupación de conexiones consiste en una conexión maestra, y opcionalmente cualquier número de conexiones esclavas.

Cada conexión de la agrupación de conexiones tiene su propio estado. Por ejemplo, las variables SQL de usuario, las tablas temporales y las transacciones, son parte del estado. Se puede encontrar un listado completo con los elementos que pertenecen al estado de una conexión en los conceptos de la documentación de agrupación e intercambio de conexiones. Si el complemento decide intercambiar conexiones para equilibrar la carga, a la aplicación se le podría proporcionar una conexión que tuviera un estado diferente. Las aplicaciones deben considerar esto.

Ejemplo #1 Configuración del complemento con un esclavo y un maestro

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Ejemplo #2 Problema: estado de conexión y variables SQL de usuario

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Conexión 1, la conexión vincula una variable SQL de usuario, no se ejecuta ningún SELECT en el maestro */
if (!$mysqli->query("SET @myrole='master'")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Conexión 2, se ejecuta en el esclavo a causa de SELECT */
if (!($res = $mysqli->query("SELECT @myrole AS _role"))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
    $fila = $res->fetch_assoc();
    $res->close();
    printf("@myrole = '%s'\n", $fila['_role']);
}
$mysqli->close();
?>

El resultado del ejemplo sería:

@myrole = ''

El ejemplo abre una conexión con equilibrio de carga y ejecuta dos sentencias. La primera sentencia SET @myrole='master' no comienza con la cadena SELECT. Por lo tanto, el complemento no la reconoce como una consulta de solo lectura que se ejecutaría en un esclavo. El complemento ejecuta la sentencia en una conexión al maestro. La sentencia establece una variable SQL de usuario que está vinculada a la conexión con el maestro. El estado de la conexión maestra ha sido cambiado.

La siguiente sentencia es SELECT @myrole AS _role. El complemento la reconoce como una consulta de solo lectura y la envía al esclavo. La sentencia se ejecuta en una conexión al esclavo. Esta segunda conexión no tiene ninguna variable SQL de usuario vinculada a ella. Tiene un estado diferente a la primera conexión al maestro. La variable SQL de usuario no está establecida. El script del ejemplo imprime @myrole = ''.

Es responsabilidad del desarrollador de la apliación ocuparse del estado de la conexión. El complemento no monitoriza todas las actividades de cambio de estado. La monitorización de todos los casos posibles sería una tarea intensiva de la CPU, si es que esta tarea pudiera ser realizada.

Los problemas se pueden evitar fácilmente usando sugerencias SQL.


Sugerencias SQL

Las sugerencias SQL pueden forzar a una consulta a elegir un servidor específico de la agrupación de conexiones. Proporcionan al complemento una recomendación para utilizar un servidor indicado, lo que puede resolver problemas causados por intercambios de conexión y estados de conexión.

Las sugerencias SQL son comentarios que siguen el estándar. Ya que los comentarios SQL son ignorados por sistemas de procesamiento SQL, no interfieren con otros programas como el Servidor MySQL, el Proxy MySQL, o un cortafuegos.

El complemento admite tres sugerencias SQL: La sugerencia MYSQLND_MS_MASTER_SWITCH hace que el complemento ejecute una sentencia en el maestro, MYSQLND_MS_SLAVE_SWITCH fuerza el uso del esclavo, y MYSQLND_MS_LAST_USED_SWITCH ejecutará una sentencia en el mismo servidor que se utilizó con la sentencia anterior.

El complemento examina el comienzo de una sentencia para la existencia de una sugerencia SQL. Las sugerencias SQL solo son reconocidas si aparecen al comienzo de la sentencia.

Ejemplo #1 Configuración del complemento con un esclavo y un maestro

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Ejemplo #2 Sugerencias SQL para evitar el intercambio de conexión

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (mysqli_connect_errno()) {
  /* Por supuesto, su manejo de errores es mejor... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Conexión 1, la conexión vincula una variable SQL de usuario, no se ejecuta ningún SELECT en el maestro */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Conexión 1, se ejecuta en el maestro debido a la sugerencia SQL */
if (!($res = $mysqli->query(sprintf("/*%s*/SELECT @myrole AS _role", MYSQLND_MS_LAST_USED_SWITCH)))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $fila = $res->fetch_assoc();
 $res->close();
 printf("@myrole = '%s'\n", $fila['_role']);
}
$mysqli->close();
?>

El resultado del ejemplo sería:

@myrole = 'master'

En el ejemplo de arriba, el uso de MYSQLND_MS_LAST_USED_SWITCH evita el intercambio de sesión desde el maestro al esclavo al ejecutar la sentencia SELECT.

Las sugerencias SQL también se pueden usar para ejecutar sentencias SELECT en el servidor maestro de MySQL. Esto podría ser necesario si los servidores esclavos de MySQL están normalmente detrás del maestro, pero no se necesitan datos actuales del clúster.

En la versión 1.2.0, el concepto de nivel de servicio ha sido introducido para dirigir casos en los que no son necesarios datos actuales. El uso de un nivel de servicio requiere menos atención y elimina la necesidad de usar sugerencias SQL para este caso. Se puede encontrar más información más abajo en la sección de nivel de servicio y consistencia.

Ejemplo #3 Enfrentarse a la demora de replicación

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Forzar el uso del maestro, el maestro siempre tiene datos recientes y actuales */
if (!$mysqli->query(sprintf("/*%s*/SELECT critical_data FROM important_table", MYSQLND_MS_MASTER_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

Un caso de uso puede incluir la creación de tablas en un esclavo. Si no se proporciona una sugenrencia SQL, el complemento enviará las sentencias CREATE e INSERT al maestro. Utilice la sugerencia SQL MYSQLND_MS_SLAVE_SWITCH si quiere ejecutar tales sentencias en un esclavo, por ejemplo, para construir tablas de informes temporales.

Ejemplo #4 Creación de una tabla en un esclavo

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Forzar el uso del esclavo */
if (!$mysqli->query(sprintf("/*%s*/CREATE TABLE informes_esclavo(id INT)", MYSQLND_MS_SLAVE_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* Continuar usando esta conexión esclava en particular */
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO informes_esclavo(id) VALUES (1), (2), (3)", MYSQLND_MS_LAST_USED_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* ¡No usar MYSQLND_MS_SLAVE_SWITCH, ya que permitiría el intercambio con otro esclavo! */
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM informes_esclavo", MYSQLND_MS_LAST_USED_SWITCH))) {
    $fila = $res->fetch_assoc();
    $res->close();
    printf("Hay %d filas en la tabla 'informes_esclavo'", $fila['_num']);
} else {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
$mysqli->close();
?>

La sugerencia SQL MYSQLND_MS_LAST_USED prohíbe el intercambio de una conexión, por lo que fuerza el uso de la conexión utilizada anteriormente.


Transacciones locales

La versión actual del complemento no es segura con transacciones de forma predeterminada, ya que no considera su ejecución en ningún caso. Las transacciones SQL son unidades de trabajo para ejecutarlas en un único servidor. El complemento no siempre sabe cuándo comienza y cuándo finaliza una unidad de trabajo. Por lo tanto, el complemento podría decidir intercambiar conexiones en mitad de una transacción.

Ningún tipo de equilibrador de carga de MySQL puede detectar los límites de una transacción sin ningún tipo de sugerencia por parte de la aplicación.

Se pueden usar sugerencias SQL para superar esta limitación. De forma alternativa, se puede activar la monitorización de llamadas a la API de transacciones. En el último caso, de deben usar llamadas a la API solamente para controlar transacciones. Véase más abajo.

Ejemplo #1 Configuración del complemento con un esclavo y un maestro

[myapp]
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Ejemplo #2 Usar sugerencias SQL para transacciones

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* No es un SELECT, se usará el maestro */
if (!$mysqli->query("START TRANSACTION")) {
    /* Por favor, use un manejo de errores mejor en su código */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* ¡Evitar el intercambio de conexión! */
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO test(id) VALUES (1)", MYSQLND_MS_LAST_USED_SWITCH))) {
    /* Por favor, realice el ROLLBACK apropiado en su código, y no use simplemente 'die' */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM test", MYSQLND_MS_LAST_USED_SWITCH))) {
    $fila = $res->fetch_assoc();
    $res->close();
    if ($fila['_num'] > 1000) {
        if (!$mysqli->query(sprintf("/*%s*/INSERT INTO events(task) VALUES ('cleanup')", MYSQLND_MS_LAST_USED_SWITCH))) {
            die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
        }
    }
} else {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/UPDATE log SET last_update = NOW()", MYSQLND_MS_LAST_USED_SWITCH))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/COMMIT", MYSQLND_MS_LAST_USED_SWITCH))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

$mysqli->close();
?>

Desde PHP 5.4.0, la biblioteca mysqlnd permite al complemento monitorizar el estado del modo autocommit, si el modo está establecido por llamadas a la API en lugar de usar sentencias SQL como SET AUTOCOMMIT=0. Esto permite que el complemento considere las transacciones. En este caso, es necesario usar sugerencias SQL.

Si se está utlizando PHP 5.4.0 o superior, con las llamadas a la API que habilitan el modo autocommit, y cuando se establece la opción de configuración del complemento trx_stickiness=master, éste puede deshabilitar automáticamente el equilibrado de carga y el intercambio de conexiones para transacciones SQL. Con esta configuración, el complemento detiene el equilibrado de carga si autocommit está deshabilitado, y dirige todas las sentencias al maestro. Esto evita el intercambio de conexiones en mitad de una transacción. Una vez que autocommit es rehabilitado, el complemento inicia de nuevo las sentencias con equilibrado de carga.

La detección de los límites de transacciones basada en API ha sido mejorada con PHP 5.5.0 y PECL/mysqlnd_ms 1.5.0 para cubirir no solo llamadas a mysqli_autocommit(), sino también a mysqli_begin(), mysqli_commit() y mysqli_rollback().

Ejemplo #3 Equilibrado de carga considerando transacciones: el ajuste trx_stickiness

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Ejemplo #4 Consideración de transacciones

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Deshabilitar autocommit, el complemento ejecutará todas las sentencias en el maestro */
$mysqli->autocommit(FALSE);

if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    /* Por favor, realice el ROLLBACK apropiado en su código, y no use simplemente 'die' */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query("SELECT COUNT(*) AS _num FROM test")) {
    $fila = $res->fetch_assoc();
    $res->close();
    if ($fila['_num'] > 1000) {
        if (!$mysqli->query("INSERT INTO events(task) VALUES ('cleanup')")) {
            die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
        }
    }
} else {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query("UPDATE log SET last_update = NOW()")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->commit()) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* El complemento asume que la transacción ha finalizado e inicia el equilibrado de carga de nuevo */
$mysqli->autocommit(true);
$mysqli->close();
?>

Nota: Requisitos de versión

La opción de configuración del complemento trx_stickiness=master requiere PHP 5.4.0 o superior.

Por favor, observe las restricciones descritas en la sección de conceptos sobre manejo de transacciones.


Transacciones XA/Distribuidas

Nota: Requisitos de versión

Las funciones relacionadas con XA han sido introducidas en la verisón 1.6.0-alpha de PECL mysqlnd_ms.

Nota: Se buscan los primeros adaptadores

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción, aunque las primeras pruebas indican una calidad razonable.

Por favor, contacte con el equipo de desarrollo si está interesado en esta característica. Estamos buscando comentarios de la vida real para completar esta característica.

Las transacciones XA son un método estandarizado para ejecutar transacciones a través de varios recursos. Estos recursos pueden ser bases de datos u otros sistemas transaccionales. El servidor de MySQL admite sentencias SQL de XA, las cuales permiten a los usuarios llevar a cabo una transacción SQL distribuida que genera varios servidores de bases de datos, o cualquier otro tipo siempre y cuando admita también las sentencias SQL. En este tipo de escenario, es responsabilidad del usuario coordinar los servidores participantes.

PECL/mysqlnd_ms puede actuar como un coordinador de transacciones para una transacción global (distribuida, XA) se lleve a cabo solamente en servidores de MySQL. Como coordinador transacciones, el complemento rastrea todos los servidores involucrados en una transacción global y envía de forma transparente las sentencias SQL apropiadas a los participantes. Las transacción globales son controladas con mysqlnd_ms_xa_begin(), mysqlnd_ms_xa_commit() y mysqlnd_ms_xa_rollback(). Los detalles SQL mayormente están ocultos a la aplicación, ya que es necesario rastrear y coordinar a los participantes.

Ejemplo #1 Patrón general para transacciones XA

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* iniciar una transacción global */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* ejecutar las consultas como siempre: XA BEGIN será inyectada en cuanto se ejecute una consulta */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
    /* Tanto si falla INSERT o falla la inyección de XA BEGIN */
    if ('XA' == substr($mysqli->sqlstate, 0, 2)) {
        printf("Fallo relacionado con una transacción/XA global, [%d] %s\n", $mysqli->errno, $mysqli->error);
    } else {
        printf("Fallo de INSERT, [%d] %s\n", $mysqli->errno, $mysqli->error);
    }
    /* revertir la transacción global */
    mysqlnd_ms_xa_rollback($mysqli, $xid);
    die("Deteniendo.");
}

/* continuar con la realización de consultas en otros servidores, p.ej. otros fragmentos */

/* consignar la transacción global */
if (!mysqlnd_ms_xa_commit($mysqli, $xa_id)) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

A diferencia de las transacciones locales, la cuales se llevan a cabo en un único servidor, las transacciones XA tienen un identificador (xid) asociado a ellas. El identificador de transacción de XA está compuesto por un identificador de transacción global (gtrid), un identificador de ramificación (bqual), y un identificador de formato (formatID). Solamente el identificador de transacción global puede y debe proporcionarse al invocar a cualquier función de XA del complemento.

Una vez que ha sido iniciada una transacción global, el complemento comienza a rastrear servidores hsata que la transacción global finaliza. Cuando un servidor se escoge para la ejecución de una consulta, el complemento inyecta la sentencia SQL XA BEGIN antes de ejecutar la sentencia SQL real en el servidor. XA BEGIN hace que el servidor participe en la transacción global. Si falla la inyección de la sentencia SQL, el complemento informará del problema en réplica a la función de ejecución de consultas que se empleó. En el ejemplo de arriba, $mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')") indicaría tal error. Se podría comprobar el código de estado SQL de los errores para determinar la consulta real (aquí: INSERT) que ha fallado o el error relacionado con la transacción global. Depende de usted ignorar el fallo de iniciar la transacción global en un servidor y continuar la ejecución sin tener al servidor participando en la transacción global.

Ejemplo #2 Las transacciones locales y globales son mutuamente exclusivas

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
  /* Por supuesto, su manejo de errores es mejor... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* iniciar una transacción local */
if (!$mysqli->begin_transaction()) {
    die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));
}

/* anora no se puede iniciar la transición global - primero debe finalizar la local */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
    die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));
}
?>

El resultado del ejemplo sería:

Warning: mysqlnd_ms_xa_begin(): (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first in ... on line ...
[1400/XAE09] (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first

Una transacción global no se puede iniciar cuando una transacción local está activa. El complelento intenta detectar esta situación tan pronto como sea posible, que es cuando se llama a mysqlnd_ms_xa_begin(). Si solamente se emplean llamadas a la API para controlar transacciones, el complemento sabrá qué transacción local está abierta, devolviendo un error para mysqlnd_ms_xa_begin(). Sin embargo, observe que las limitaciones para detectar límites de transacciones del complemento. En el peor de los casos, si se emplea SQL directo para transacciones locales (BEGIN, COMMIT, ...), podría suceder que un error de demorara hasta que se ejecute alguna sentencia SQL en el servidor.

Para finalizar una transacción global se ha de invocar a mysqlnd_ms_xa_commit() o a mysqlnd_ms_xa_rollback(). Cuando finaliza una transacción global, todos los participantes deben ser informados de dicha finalización. Por lo tando, PECL/mysqlnd_ms enviará de forma transparente las sentencias SQL relacionadas apropiadas a alguno o todos ellos. Cualquier fallo durante esta fase ocasionará una reversión implícita. La API relacionada con XA se mantiene aquí intencionadamente simple. Una API más compleja que proporcionara más control dejaría al descubierto pocas ventajas, si las hubiera, sobre una implementación de usuario que enviara todas las sentencias SQL de XA de bajo nivel por sí misma.

Las transacciones XA emplean el protocolo de consignación de dos fases. El protocolo de consignación de dos fases es un protocolo de bloqueo. Hay casos en los que no se puede hacer ningún progreso, incluso al emplear tiempos de espera. Los coordinadores de transaccionesbe made, not even when using timeouts. Transaction coordinators deberían sobrevivir a sus propios fallos, ser capaces de detectar bloqueos y deshacer empates. PECL/mysqlnd_ms toma el papel de un coordinador de transacciones y puede ser configurado para sobrevivir a su propia caída para evitar problemas con servidores de MySQL bloqueados. Por tanto, el complemento puede y debería ser configurado para utilizar un estado persistente y seguro ante caídas para permitir la recolección de basura de transacciones globales abortadas y no finalizadas. Una transacción global puede ser abortada en un estado abierto si el complemento falla (se cae) o falla una conexión desde el complemento a un participante de una transacción global.

Ejemplo #3 Almacenamiento del estado del coordinador de transacciones

{
    "myapp": {
        "xa": {
            "state_store": {
                "participant_localhost_ip": "192.168.2.12",
                "mysql": {
                    "host": "192.168.2.13",
                    "user": "root",
                    "password": "",
                    "db": "test",
                    "port": "3312",
                    "socket": null
                }
            }
        },
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.14",
                "port": "3306"
            }
        }
    }
}

Actualmente, PECL/mysqlnd_ms admite solamente el uso de tablas de bases de datos de MySQL como almacenamiento de estados. Las definiciones de SQL de las tablas se proporcionan en la sección de configuración del complemento. Asegúrese de utilizar un motor de almacenamiento transaccional y seguro ante caídas para las tablas, como InnoDB. InnoDB es el motor de tablas predeterminado en versiones recientes del servidor de MySQL. Asegúrese también de que el servidor de bases de datos sea altamente disponible.

Si se ha configurado un almacén de estado, el complemento puede realizar una recolección de basura. Durante dicha recolección, podría ser necesario conectarse a un participante de una transacción global fallida. Así, el almacén de estado mantiene una lista de participantes y, entre otras cosas, sus nombres de host. Si la recolección de basura se ejecuta en otro host que no sea el que haya escrito una entrada de participación con el el nombre de host localhost, entonces localhost se resolverá a máquinas diferentes. Hay dos soluciones al problema. O no se configura ningún servidor con el nombre de host localhost y se configura una dirección IP (y puerto), o se indica la recolección de basura. En el ejemplo anterior, localhost se usa para master_0, de ahí que podría no resolverse al host correcto durante la recolección de basura. Sin embargo, participant_localhost_ip también está establecido para indicar la recolección de basura que localhost representa para la IP 192.168.2.12.


Nivel de servicio y consistencia

Nota: Requisitos de versión

Los niveles de servicios han sido introducidos en la versión 1.2.0-alpha de PECL mysqlnd_ms. mysqlnd_ms_set_qos() está disponible con PHP 5.4.0 o superior.

Las diferentes soluciones de clúster MySQL ofrecen diferentes niveles de servicios y de consistencia de datos para sus usuarios. Un clúster de replicación MySQL asíncrono ofrece la consistencia final de forma predeterminada. Una lectura ejecutada en un esclavo asíncrono puede devolver datos actuales, antiguos, o ningún dato, dependiendo de si el esclavo ha replicado todos los conjuntos de cambios del maestro.

Las aplicaciones que utilizan un clúster de replicación MySQL necesitan ser diseñadas para que funcionen correctamente con datos de consistencia final. En algunos casos, sin embargo, los datos antiguos no son aceptables. En estos casos solamente son permitidos ciertos accesos a esclavos o incluso a un maestro para realizar la calidad de servicio requerida del clúster.

A partir de PECL mysqlnd_ms 1.2.0, el complemento puede seleccionar automáticamente nodos de replicación de MySQL que proporcionen consistencia de sesión o consistencia fuerte. La consistencia de sesión significa que un cliente puede leer sus escrituras. Otros clientes pueden ver o no la escritura del cliente. La consistencia fuerte significa que todos los clientes verán todas las escrituras del cliente.

Ejemplo #1 Consistencia de sesión: lectura de sus escrituras

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Ejemplo #2 Solicitud de consistencia de sesión

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* división de lecutura-escritura: se usa el maestro */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
    /* Por favor, use un manejo de errores mejor en su código */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Solicitud de consistencia de sesión: lectura de sus escrituras */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* El complemento selecciona un nodo que posee los cambios, aquí: el maestro */
if (!$res = $mysqli->query("SELECT item FROM orders WHERE order_id = 1")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());

/* Volver a la consistencia final: se permiten datos antiguos */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* El complemento seleccina cualquier esclavo, se permiten datos antiguos */
if (!$res = $mysqli->query("SELECT item, price FROM specials")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

Los niveles de servicios se pueden establecer en el fichero de configuración del complemento y en tiempo de ejecución usando mysqlnd_ms_set_qos(). En el ejemplo, la función se usa para forzar la consistencia de sesión (lectura de sus escrituras) para todas las sentencias futuras hasta próximo aviso. La sentencia SELECT de la tabla orders se ejecuta en el maestro para asegurarse de que las escrituras anteriores puedan ser vistas por el cliente. La lógica de la división de lectura-escritura ha sido adaptada para satisfacer el nivel de servicio.

Después de que una aplicación haya leído sus cambios desde la tabla orders, vuelve al nivel de servicio predeterminado, que es la consistencia final. Ésta no pone restricciones al elegir un nodo para la ejecución de sentencias. Por lo tanto, la sentencia SELECT de la tabla specials se ejecuta en un esclavo.

La nueva funcionalidad sustituye el uso de sugerencias SQL y la opción de configuración master_on_write. En muchos casos, mysqlnd_ms_set_qos() es más fácil de usar, más potente y mejora la portabilidad.

Ejemplo #3 Edad máxima/demora del esclavo

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "failover" : "master"
    }
}

Ejemplo #4 Limitar la demora del esclavo

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Demora de la lectura desde los esclavos de no más de cuatro segundos */
$ret = mysqlnd_ms_set_qos(
    $mysqli,
    MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
    MYSQLND_MS_QOS_OPTION_AGE,
    4
);

if (!$ret) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* El comlemento elige cualquier esclavo, el cual puede o no poseer los cambios */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Volver a lo predeterminado: usar todos los esclavos y maestros permitidos */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

El nivel de servicio de consistencia final se puede usar con un parámetro opcional para establecer la demora máxima de los esclavos elegidos. Si se establece, el complemento comprueba SHOW SLAVE STATUS para todos los esclavos configurados. En el caso del ejemplo, solamente los esclavos para los que Slave_IO_Running=Yes, Slave_SQL_Running=Yes y Seconds_Behind_Master <= 4 sea verdadero, son tenidos en cuenta para la ejecución de la sentencia SELECT item, price FROM daytrade.

La comprobacion de SHOW SLAVE STATUS se realiza de manera transparente desde la perspectiva de las aplicaciones. Los errores, si los hubiera, son notificados como advertencias. No se establecerá ningún error en el gestor de conexión. Incluso si todas las sentencias SQL SHOW SLAVE STATUS ejecutadas por el complemento fallan, la ejecución de las sentencias del usuario no se detienen, dado que la toleracia a fallos del maestro está habilitada. Por lo tanto, no se requieren cambios en la aplicación.

Nota: Operaciones caras y lentas

La comprobación de SHOW SLAVE STATUS para todos los esclavos añade carga adicional a la aplicación. Es una operación en segundo plano cara y lenta. Intente minimizar su uso. Desafortunadamente, un clúster de replicación MySQL no proporciona a los clientes la posibilidad de solicitar una lista de candidatos desde una instancia central. En consecuencia, no existe una manera más eficiente de comprobar la demora de los esclavos.

Por favor, observe las limitaciones y propiedades de SHOW SLAVE STATUS tal y como están explicadas en el manual de referencia de MySQL.

Para evitar que mysqlnd_ms emita una advertencia si no se pudieron encontrar esclavos que se demoren no más que el número de segundos definido con respecto al maestro, es necesario habilitar la tolerancia a fallos del maestro en el fichero de configuración del complemento. Si no se pudieron encontrar esclavos y la tolerancia a fallos está habilitada, el complemento eligirá un maestro para ejecutar la setencia.

Si no se pudieron encontrar esclavos y la tolerancia a fallos está deshabilitada, el complemento emitirá una advertencia, no ejecutará la sentencia y establecerá un error sobre la conexión.

Ejemplo #5 La tolerancia a fallos no está establecida

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Ejemplo #6 No hay esclavos dentro del límite de tiempo

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Demora de la lectura desde los esclavos de no más de cuatro segundos */
$ret = mysqlnd_ms_set_qos(
    $mysqli,
    MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
    MYSQLND_MS_QOS_OPTION_AGE,
    4
);

if (!$ret) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* El comlemento elige cualquier esclavo, el cual puede o no poseer los cambios */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Volver a lo predeterminado: usar todos los esclavos y maestros permitidos */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

El resultado del ejemplo sería:

PHP Warning:  mysqli::query(): (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d
PHP Warning:  mysqli::query(): (mysqlnd_ms) No connection selected by the last filter in %s on line %d
[2000] (mysqlnd_ms) No connection selected by the last filter


ID de transacción globales

Nota: Requisitos de versión

Se ha introducido una inyección de ID de transacciones global en el lado del cliente en la versión 1.2.0-alpha de mysqlnd_ms. Esta característica no es necesaria para clústeres sincrónicos, tales como el Clúster MySQL. Utilícela con clústeres asíncronos tales como la replicación MySQL clásica.

A partir de la versión candidata MySQL 5.6.5-m8, el servidor MySQL introduce los identificadores de transacciones globales internos. La característica del ID de transacciones global interno está soportada por PECL/mysqlnd_ms 1.3.0-alpha o posterior. Sin embargo, el conjunto final de características encontrado en las versiones de producción de MySQL 5.6 hasta la fecha, no es suficiente para soportar las ideas tratadas abajo en todos los casos. Véase también la sección de conceptos.

PECL/mysqlnd_ms puede usar tanto su propia emulación del ID de transacciones global como la característica del ID de transacciones global interna de MySQL 5.6.5-m8 o posterior. Desde la perspectiva del desarrolador, los enfoques del lado del cliente y del lado del servidor ofrecen las mismas características en cuanto a niveles de servicios proporcionados por PECL/mysqlnd_ms. Las diferencias son tratadas en la sección de conceptos.

Esta guía rápida primero demuestra el uso de la emulación interna del ID de transacciones global en el lado del cliente en PECL/mysqlnd_ms antes de mostrar cómo usar su homólogo en el lado del servidor. Este orden asegura que la idea subyacente se trata primero.

La idea y la emulación en el lado del cliente

En su forma más básica, un ID de Transacciones Global (GTID de sus siglas en inglés) es un contador de una tabla del maestro. El contador se incrementa siempre que se consigne una transacción en el maestro. Los esclavos replican la tabla. El contador sirve para dos propósitos. En caso de un fallo del maestro, ayuda al administrador de la base de datos a identificar al esclavo que fue promovido más recientemente como nuevo maestro. Este esclavo es aquel con el valor de contador más alto. Las aplicaciones pueden usar el ID de transacciones global para buscar los esclavos que ya han replicado una escritura en particular (identificada por un ID de transacciones global).

PECL/mysqlnd_ms puede inyectar SQL para cada transacción consignada para incrementar un contador GTID. El ID creado es accesible por la aplicación para poder identificar una operación de escritura de una aplicación. Esto habilita al complemento para proporcionar el nivel de servicio de consistencia de sesión (lectura de sus escrituras) mediante no solamente la consulta a los maestros, sino también a los esclavos que ya han replicado el cambio. La carga de lectura se le quita al maestro.

La emulación del ID de transacciones global en el lado del cliente tiene algunas limitaciones. Por favor, lea la sección de conceptos detenidamente para comprender completamente los principios y las ideas subyacentes antes de usarla en entornos de producción. No es necesario un conocimiento profundo para continuar con esta guía rápida.

Primero, cree una tabla contador en su servidor maestro e inserte un registro en ella. El complemento no asiste en la creación de la tabla. Los administradores de la base de datos deben asegurarse de que existe. Dependiendo del modo de notificación de errores, el complemento ignorará de forma silenciosa la ausencia de la tabla o abandonará.

Ejemplo #1 Crear una tabla contador en el maestro

CREATE TABLE `trx` (
  `trx_id` int(11) DEFAULT NULL,
  `last_update` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP
) ENGINE=InnoDB DEFAULT CHARSET=latin1
INSERT INTO `trx`(`trx_id`) VALUES (1);

En el fichero de configuración del complemento establezca el SQL para actualizar la tabla del ID de transacciones global usando on_commit en la sección global_transaction_id_injection. Asegúrese de que el nombre de la tabla usado para la sentencia UPDATE está completamente cualificado. En el ejemplo, test.trx se usa para referirse a la tabla trx del esquema (base de datos) test. Use la tabla que se creó en el paso anterior. Es importante establecer el nombre de la tabla completamente cualificado, ya que la conexión donde se realiza la inyección puede usar una base de datos predeterminada diferente. Asegúrese de que al usuario que abra la conexión se le permita ejecutar la sentencia UPDATE.

Habilite la notificación de los errores que pudieran ocurrir cuando mysqlnd_ms realice inyecciones de ID de transacciones global.

Ejemplo #2 Configuración del complemento: SQL para la inyección del GTID en el lado del cliente

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "report_error":true
        }
    }
}

Ejemplo #3 Inyección transparente del ID de transacciones global

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* modo autoconsigna, lectura en el esclavo, sin incremento */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());
?>

El resultado del ejemplo sería:

array(1) {
  ["id"]=>
  string(1) "1"
}

El ejemplo ejecuta tres sentencias en el modo autoconsigna en el maestro, causando tres transacciones en el maestro. Para cada sentencia, el complemento inyectará el UPDATE configurado de forma transparente antes de ejecutar las sentencias SQL del usuario. Cuando finaliza el script, el contador de IDs de transacciones globales en el maestro ha sido incrementado en tres.

La cuarta sentencia SQL ejecutada en el ejemplo, un SELECT, no desencadena un incremento. Solamente las transacciones (escrituras) ejecutadas en un maestro incrementarán el contador GTID.

Nota: SQL para el ID de transacciones global: ¡se busca una solución eficiente!

El SQL usado para la emulación del ID de transacciones global es ineficiente. Está optimizado para la trasnparencia, no para el rendimiento. No lo use para entornos de producción. Por favor, ayude a encontrar una solución eficiente para su inclusión en el manual. Apreciamos su aportación.

Ejemplo #4 Configuración del complemento: SQL para obtener el GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "report_error":true
        }
    }
}

Ejemplo #5 Obtener el GTID después de la ejecución

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

printf("GTID después de la transacción %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

printf("GTID después de la transacción %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

El resultado del ejemplo sería:

GTID después de la transacción 7
GTID después de la transacción 8

Las aplicaciones pueden preguntar a PECL mysqlnd_ms por un ID de transacciones global que pertenezca a la última operación de escritura realizada por la aplicación. La función mysqlnd_ms_get_last_gtid() devuelve el GTID obtenido cuando se ejecuta la sentencia SQL desde la entrada fetch_last_gtid de la sección global_transaction_id_injection del fichero de configuración del complemento. La función puede ser invocada después de que el GTID haya sido incrementado.

Se aconseja que las aplicaciones no ejecuten la sentencia SQL por sí mismas ya que aumenta el riesgo de que accidentalmente se ocasione un incremento implícito del GTID. También, si se usa la función, es más fácil migrar una aplicación desde una sentencia SQL para obtener un ID de transacciones a otra, por ejemplo, si ningún servidor MySQL incluye el soporte interno para IDs de transacciones globales.

Esta guía rápida muestra una sentencia SQL que devolverá un GTID igual o mayor que el creado por la sentencia anterior. Éste es exactamente el GTID creado por la sentencia anterior si ningún cliente ha incrementado el GTID en el tiempo transcurrido entre la ejecución de la sentencia y el SELECT para obtener el GTID. De otro modo, será mayor.

Ejemplo #6 Configuración del complemento: comprobar un GTID en particular

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "check_for_gtid" : "SELECT trx_id FROM test.trx WHERE trx_id >= #GTID",
            "report_error":true
        }
    }
}

Ejemplo #7 Nivel de servicio de consistencia de sesión y GTID combinados

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* GTID es un identificador para la última escritura */
$gtid = mysqlnd_ms_get_last_gtid($mysqli);

/* Consistencia de sesión (lectura de sus escrituras): intentar leer de los esclavos, no sólo del maestro */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION, MYSQLND_MS_QOS_OPTION_GTID, $gtid)) {
    die(sprintf("[006] [%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Ejecutar en el maestro o en el esclavo que ha replicado el INSERT */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());
?>

Un GTID devuelto por mysqlnd_ms_get_last_gtid() se puede usar como una opción para el nivel de servicio de consistencia de sesión. La consistencia de sesión proporciona la lectura de sus escrituras. La consistencia de sesión puede ser solicitada llamando a mysqlnd_ms_set_qos(). En el ejemplo, el complemento ejecutará la sentencia SELECT en el maestro o en un esclavo que ya ha repliacdo el INSERT anterior.

PECL mysqlnd_ms comprobará de forma transparente cada esclavo configurado, si éste ha replicado el INSERT, mediante la comprobación de la tabla GTID de esclavos. La comprobación se realiza ejecutando la sentencia SQL establecida con la opción check_for_gtid de la sección global_transaction_id_injection del fichero de configuración del complemento. Por favor, observe que este es un procedimiento lento y caro. Las aplicaciones deberían intentar usarlo poco y únicamente si la carga de lectura en el maestro es alta.

Uso de la característica del ID de transacciones global en el lado del servidor

Nota: Soporte del servidor insuficiente en MySQL 5.6

El complemento ha sido derarrollado usando una versión de preproducción de MySQL 5.6. Resulta de que todas las versiones de producción de MySQL 5.6 no proporcionan clientes con suficiente información para forzar la consistencia de sesión basándose en GTID. Por favor, lea la sección de conceptos para más detalles.

Desde MySQL 5.6.5-m8, el sistema de Replicación MySQL introduce los IDs de transacciones globales. Los identificadores de transacciones son automáticamente generados y mantenidos por el servidor. Los usuarios no necesitan ocuparse de ellos. No hay necesidad de configurar ninguna tabla de antemano, ni de configurar on_commit. Ya no es necesaria la emulación en el lado del cliente.

Los clientes puede seguir usando los identificadores de transacciones globales para conseguir la consistencia de sesión al leer desde esclavos de la Replicación MySQL en algunos casos, ¡pero no en todos!. El algoritmo funciona como está descrito arriba. Se deben configurar diferentes sentencias SQL para fetch_last_gtid y check_for_gtid. Estas sentencias se proporcionan más abajo. Por favor, observe que MySQL 5.6.5-m8 es una versión en desarrollo. Los detalles de la implementación del servidor pueden cambiar en el futuro y requerir la adopción de las sentencias SQL mostradas.

Al utilizar la siguiente configuración, cualquier funcionalidad descrita arriba puede usarse junto con la característica del ID de transacciones global en el lado del servidor. mysqlnd_ms_get_last_gtid() y mysqlnd_ms_set_qos() siguen funcionando como se describió arriba. La única diferencia es que el servidor no utiliza un número de secuencia simple, sino un string que contiene un identificador del servidor y un número de secuencia. Por lo tanto, los usuarios no podrán obtener fáciltmente un orden desde los GTIDs devueltos por mysqlnd_ms_get_last_gtid().

Ejemplo #8 Configuración de complemento: usar la característica del GTID interna de MySQL 5.6.5-m8

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "fetch_last_gtid" : "SELECT @@GLOBAL.GTID_DONE AS trx_id FROM DUAL",
            "check_for_gtid" : "SELECT GTID_SUBSET('#GTID', @@GLOBAL.GTID_DONE) AS trx_id FROM DUAL",
            "report_error":true
        }
    }
}


Integración de una caché

Nota: Requisitos de versión, dependencias y estado

Se puede encontrar más sobre los requisitos de la versión, las dependencias del orden de carga de las extensiones y el estado actual en la sección de conceptos.

Los clústeres de bases de datos pueden proporcionar diferentes niveles de consistencia. A partir de PECL/mysqlnd_ms 1.2.0 es posible acosejar al complemento para que cosidere solamente los nodos del clúster que puedan proporcionar el nivel de consistencia requerido. Por ejemplo, si se usa la Replicación MySQL con su consistencia final a lo ancho del clúster, es posible solicitar la consistencia de sesión (lectura de sus escrituras) en cualquier momento usando mysqlnd_ms_set_quos(). Por favor, vea también la introducción de nivel de servicio y consistencia.

Ejemplo #1 Resumen: calidad del servicio para solicitar la lectura de sus escrituras

/* Solicitud de consistencia de sesión: lectura de sus escrituras */
     if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION))
     die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

Asumiendo que a PECL/mysqlnd se le ha indicado explícitamente que proporcione un nivel de consistencia no mayor que la consistencia final, es posible reemplazar un acceso de lectura de un nodo de la base de datos por una caché en el lado del cliente usando el tiempo de vida (TTL) como estrategia de invalidación. El nodo de la base de datos y la caché pueden o no servir datos actuales, ya que esto es lo que la consistencia final define.

El reemplazo de un acceso de lectura de un nodo de la base de datos por un acceso a la caché local puede mejorar el redimiento general y disminuir la carga de la base de datos. Si la entrada de la caché es reutilizada por otro cliente que no sea el que creó dicha entrada, se guaradará un acceso a la base de datos, por lo que se disminuye la carga de la base de datos. Además, el rendimiento del sistema se puede mejorar si el cálculo y la entrega de una consulta a la base de datos es más baja que un acceso a la caché local.

Ejemplo #2 Configuración del complemento: sin entradas especiales para la caché

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
    }
}

Ejemplo #3 Almacenar en caché una petición a un servidor

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Explícitamente permite la consistencia final y el almacenamiento en caché (TTL <= 60 segundos) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Para que este ejemplo funcione, debemos esperar a que el esclavo se ponga al día. Estilo de fuerza bruta. */
$intentos = 0;
do {
    /* comprobar si el esclavo posee la tabla */
    if ($res = $mysqli->query("SELECT id FROM test")) {
        break;
    } else if ($mysqli->errno) {
        die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
    }
    /* esperar a que el esclavo se ponga al día */
    usleep(200000);
} while ($intentos++ < 10);

/* La consulta ha sido ejecutada en un esclavo, el resultado está en la caché */
assert($res);
var_dump($res->fetch_assoc());

/* Servido desde la caché */
$res = $mysqli->query("SELECT id FROM test");
?>

El ejemplo muestra cómo usar la caché. Primero, se ha de establecer la calidad del servicio al de consistencia final y tener en cuenta explícitamente el almacenamiento en la caché. Esto se lleva a cabo llamando a mysqlnd_ms_set_qos(). Luego, el conjunto de resultados de cada sentencia de solo lectura se almacena en la caché hasta un máximo de segundos según lo permitido por mysqlnd_ms_set_qos().

El TTL real es menor o igual al valor establecido con mysqlnd_ms_set_qos(). El valor pasado a la función establece la edad máxima (en segundos) de los datos proporcionados. Para calcular el valor real del TTL, se comprueba la demora de replicación de un servidor y se resta del valor dado. Si, por ejemplo, la edad máxima es de 60 segundos y el esclavo notifica una demora de 10 segundos, el TTL resultante es de 50 segundos. El TTL se calcula de forma individual para cada consulta de la caché.

Ejemplo #4 Lectura de sus escrituras y almacenamiento en la caché combinados

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Explícitamente permite la consistencia final y el almacenamiento en caché (TTL <= 60 segundos) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Para que este ejemplo funcione, debemos esperar a que el esclavo se ponga al día. Estilo de fuerza bruta. */
$intentos = 0;
do {
    /* comprobar si el esclavo posee la tabla */
    if ($res = $mysqli->query("SELECT id FROM test")) {
        break;
    } else if ($mysqli->errno) {
        die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
    }
    /* esperar a que el esclavo se ponga al día */
    usleep(200000);
} while ($intentos++ < 10);

assert($res);

/* La consulta ha sido ejecutada en un esclavo, el resultado está en la caché */
var_dump($res->fetch_assoc());

/* Servido desde la caché */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
var_dump($res->fetch_assoc());

/* Actualización en el maestro */
if (!$mysqli->query("UPDATE test SET id = 2")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Lectura de sus escrituras */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Obtener los últimos datos */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
var_dump($res->fetch_assoc());
?>

La calidad del servicio se puede cambiar en cualquier momento para evitar el uso de la caché. Si fuera necesario, se podría cambiar para leer sus escrituras (consistencia de sesión). En este caso, la caché no se usará y se leerán datos actuales.


Tolerancia a fallos

Por omisión, el complemento no intenta la tolerancia a fallos si falla al conectarse a un equipo anfitrión. Esto evita los problemas relacionados con el estado de la conexión. Se recomienda tratar de forma manual los errores de conexión de una manera similar a una transacción fallida. Se debería capturar el error, reconstruir el estado de la conexión y volver a ejecutar la consulta tal como se muestra abajo.

Si el estado de la conexión no es la cuestión, de forma alternativa se puede habilitar la tolerancia a fallos automática y silenciosa. Dependiendo de la configuración, la tolerancia a fallos automática y silenciosa se intentará en el maestro antes de emitir un error, o se intentará conectar a otros esclavos, dada la consulta permitida para ello, antes de intentar conectarse a un maestro. Ya que la tolerancia a fallos automática no es infalible, no se trata en esta guía rápida. En su lugar, los detalles se proporcionan en la sección de conceptos posterior.

Ejemplo #1 Tolerancia a fallos manual, opcional automática

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
       "filters": { "roundrobin": [] }
    }
 }

Ejemplo #2 Tolerancia a fallos manual

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

$sql = "SELECT 1 FROM DUAL";

/* el manejo de errores debería realizarse sin tener en cuenta el complemento */
if (!($res = $enlace->query($sql))) {
    /* específico del complemento: comprobar errores de conexión */
    switch ($enlace->errno) {
    case 2002:
    case 2003:
    case 2005:
        printf("Error de conexión - ¡intentando con el siguiente esclavo!\n");
        /* el equilibrador de carga elegirá el siguiente esclavo */
        $res = $enlace->query($sql);
        break;
    default:
        /* no hay errores de conexión, la tolerancia a fallos es poco probable que ayude */
        die(sprintf("SQL error: [%d] %s", $enlace->errno, $enlace->error));
        break;
    }
}
if ($res) {
  var_dump($res->fetch_assoc());
}
?>


Particionamiento y fragmentación

La agrupación (clustering) de bases de datos se realiza por varias razones. Los clúster pueden mejorar la disponibilidad, la tolerancia a fallos, e incrementar el rendimiento aplicando un enfoque de "divide y vencerás", ya que el trabajo se distribuye en varias máquinas. La agrupación (clustering) a veces se combina con particionamiento y fragmentación para dividir aún más una tarea compleja grande en unidades más pequeñas y manejables.

El complemento mysqlnd_ms pretende dar soporte a una gran variedad de clústeres de bases de datos de MySQL. Algunos sabores de clúster de bases de datos de MySQL poseen métodos internos para el particionamiento y la fragmentacion, los cuales podrían ser transparentes de usar. El complemetno admite los dos enfoques más comunes: filtración de tabla de Replicación de MySQL, y la fragmentación (particionamiento basada en aplicación).

La Replicación de MySQL admite el particionamiento como filtros que permiten crear esclavos que replican todas las bases de datos o específicas del maestro, o tablas. Es entonces responsabilidad de la aplicación elegir un esclavo según las reglas de los filtros. Se puede usar el filtro node_groups de mysqlnd_ms para dar soporte manual a esto, o usar el filtro de tablas experimental.

El particionamiento manual o fragmentación está soportado a través del filtro de agrupación de nodos, y de las sugerencias SQL a partir de 1.5.0. El filtro node_groups permite asignar un nombre simbólico a un grupo de servidores maestros y esclavos. En el ejemplo, el maestro master_0 y slave_0 forman un grupo con el nombre de Partition_A. Es su responsabilidad decidir lo que haga un grupo. Por ejemplo, se podrían usar grupos de nodos para la fragmentación, y usar los nombres de grupos para direccionar fragmentos como Shard_A_Range_0_100.

Ejemplo #1 Clúster de grupos de nodos

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Ejemplo #2 Particionamiento manual usando sugerencias SQL

<?php
function select($mysqli, $msj, $sugerencia = '')
{
    /* Nota: prueba débil, dos conexiones a dos servidores podrían tener el mismo id de hilo */
    $sql = sprintf("SELECT CONNECTION_ID() AS _thread, '%s' AS _hint FROM DUAL", $msj);
    if ($sugerencia) {
        $sql = $sugerencia . $sql;
    }
    if (!($res = $mysqli->query($sql))) {
        printf("[%d] %s", $mysqli->errno, $mysqli->error);
        return false;
    }
    $fila =  $res->fetch_assoc();
    printf("%d - %s - %s\n", $fila['_thread'], $fila['_hint'], $sql);
    return true;
}

$mysqli = new mysqli("myapp", "usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Permitir siempre esclavos */
select($mysqli, "slave_0");
select($mysqli, "slave_1");

/* solamente permtir los servidores del grupo de nodos "Partition_A" */
select($mysqli, "slave_1", "/*Partition_A*/");
select($mysqli, "slave_1", "/*Partition_A*/");
?>
6804 - slave_0 - SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
2442 - slave_1 - SELECT CONNECTION_ID() AS _thread, 'slave2' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL

Por omisión, el complemento usará todos los servidores maestros y esclavos configurados para la ejecución de consultas. Pero si una consulta comienza con una sugerencia SQL como /*node_group*/, el complemento considerará únicamente los servidores enumerados en node_group para la ejecución de consultas. Así, las consultas SELECT prefijadas con /*Partition_A*/ úncamente serán ejecutadas en slave_0.


MySQL Fabric

Nota: Requisitos de versión y estado

Se comenzó a trabajar en el soporte para MySQL Fabricen la versión 1.6. Considere el soporte con una calidad prealfa. El manual podría no enumerar todas las limitaciones de la/s característica/s. Aún se está trabajand en ello.

La fragmentación es el único caso de uso soportado por el complemento hasta la fecha.

Nota: Conceptos de MySQL Fabric

Por favor, verfique el manual de referencia de MySQL para más información sobre MySQL Fabric y cómo configurarlo. El manual de PHP asumen que se es familiar con los conceptos e ideas básicos de MySQL Fabric.

MySQL Fabric es un sistema para gestionar granjas de servidores MySQL para lograr una Alta Disponibilidad y opcionalmente soporte para fragmentación. Técnicamente, es un middleware para gestionar y monitorizar servidores MySQL.

Los clientes consultan a MySQL Fabric para obtener listas de servidores MySQL, sus estados y sus roles. Por ejemplo, los clientes pueden solicitar una lista de esclavos para un grupo de Replicacion MySQL y para ver si están listos para manejar peticiones SQL. Otro ejemplo es un clúster de servidores de MySQL fragmentados donde el cliente busca conocer a qué fragmento consultar para una tabla y clave de de fragmentación dados. Si se configura para utilizar Fabric, el complemento usa XML RCP sobre HTTP para obtener la lista en tiempo de ejecución desde un host deto MySQL Fabric. La llamada XML a un procedimiento remoto se realiza en segundo plano y de forma transparente desde el punto de vista de los desarrolladores.

En lugar de enumerar los servidores MySQL directamente en el fichero de configuración del complemento, este contiene una lista de uno o más host de MySQL Fabric.

Ejemplo #1 Configuración del complemento: hosts de Fabric en lugar de servidores MySQL

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Los usuarios utilizan las nuevas funciones mysqlnd_ms_fabric_select_shard() y mysqlnd_ms_fabric_select_global() para cambiar al conjunto de servidores responsables de una clave de fragmento dada. Luego, el complemento elige un servidor apropiado para ejecutar las consultas. Al hacer esto, el complemento se encarga del conjunto de reglas adicionales de equilibrado de carga.

El ejemplo de abajo asume que MySQL Fabric ha sido configurado al fragmento de tabla test.fabrictest usando la columna id de la tabla como clave de fragmento.

Ejemplo #2 Particionameinto manual usando sugerencias SQL

<?php
$mysqli = new mysqli("myapp", "usuario", "contraseña", "base_datos");
if (!$mysqli) {
    /* Por supuesto, su manejo de errores es mejor... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Crear una tabla global - una tabla disponible en todos los fragmentos */
mysqlnd_ms_fabric_select_global($mysqli, "test.fabrictest");
if (!$mysqli->query("CREATE TABLE test.fabrictest(id INT NOT NULL PRIMARY KEY)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Cambiar la conexión al fragmento apropiado e insertar un registro */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("INSERT INTO fabrictest(id) VALUES (10)"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Intentar leer el recién insertado registro */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("SELECT id FROM test WHERE id = 10"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

El ejemplo crea una tabla fragmentada, inserta un registro y lo lee después. Todas las operaciones de lenguaje de definición de datos (DDL) sobre una tabla fragmentada deben aplicarse a lo que se llama el grupo de servidores global. Antes de crear o alterar una tabla fragmentada, se llama a mysqlnd_ms_fabric_select_global() para cambiar la conexión dada a los servidores correspondientes del grupo global. Las senetencias SQL de manipulación de datos (DML) deben ser enviadas a los fragmentos directamente. La función mysqlnd_ms_fabric_select_shard() cambia una conexión para manejar el fragmento de una cierta clave de fragmento.


Conceptos

Tabla de contenidos

  • Arquitectura
  • Agrupación e intercambio de conexiones
  • Manejo de transacciones locales
  • Manejo de errores
  • Errores transitorios
  • Tolerancia a fallos
  • Equilibrado de carga
  • División de lectura-escritura
  • Filtro
  • Nivel de servicio y consistencia
  • IDs de transacciones globales
  • Integración de una caché
  • Clústeres admitidos
  • Transacciones XA/distribuidas

Aquí se explican la arquitectura y los conceptos relacionados con este complemento, y se describe el impacto que la replicación MySQL y este complemento tienen en tareas de desarrollo al usar un clúster de bases de datos. Es necesario leer y comprender estos conceptos para poder utilizar este complemento satisfactoriamente.


Arquitectura

El complemento de replicación y equilibrado de carga de mysqlnd está implementado como una extensión de PHP. Está escrito en C y opera bajo PHP. Durante el arranque del intérprete de PHP, en la fase de inicialización de módulos del motor de PHP, es registrado como un complemento de mysqlnd para reemplazar los métodos en C de mysqlnd seleccionados.

Durante la ejecución de PHP, inspecciona las consultas enviadas desde mysqlnd (PHP) al servidor MySQL. Si una consulta se reconoce como de solo lectura, será enviada a uno de los servidores esclavos configurados. Una sentencia es considerada de solo lectura si comienza con SELECT, con la sugerencia SQL /*ms=slave*/, o se ha elegido un esclavo para ejecutar la consulta anterior y la consulta comienza con la sugerencia SQL /*ms=last_used*/. En los demás casos, la consulta será enviada al servidor maestro de replicación MySQL.

Para una mejor portabilidad, las aplicacioines deberían usar las constantes predefinidas de mysqlnd_ms MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, y MYSQLND_MS_LAST_USED_SWITCH en lugar de sus valores literales, tales como /*ms=slave*/.

El complemento maneja la apertura y el cerre de conexiones de bases de datos a los servidores maestros y esclavos. Desde el punto de vista de la aplicación, continua existiendo solamente un gestor de conexión. Sin embargo, internamente, este gestor de conexión público representa una agrupación de conexiones de red que son gestionadas por el complemento. Éste delega las consultas al sevidor maestro y a los esclavos usando múltiples conexiones.

Las conexiones a la bases de datos tienen un estado que consiste en, por ejemplo, el estado de las transacciones, configuración de las transacciones, configuración del conjunto de caracters, y tablas temporales. El complemento intentará mantener el mismo estado entre todas las conexiones internas, siempre que se pueda realizar de una forma automática y transparente. En los casos donde sencillamente no es posible mantener el estado entre conexiones, como al usar BEGIN TRANSACTION, el complemento lo deja en manos del usuario.


Agrupación e intercambio de conexiones

El complemento de replicación y equilibrado de carga cambia la semántica de un gestor de conexión de MySQL para PHP. Las APIs existentes de las extensiones de MySQL para PHP (mysqli, mysql, y PDO_MYSQL) no son cambiadas en la manera de que no son añadidas ni eliminadas funciones. Pero su comportamiento cambia al utilizar el complemento. Las aplicaciones existentes no necesitan ser adaptadas a la nueva API, aunque podrían requerir ser modificadas a causa de los cambios de comportamiento.

El complemento rompe la relación uno-a-uno entre un gestor de conexión de mysqli, mysql, y PDO_MYSQL y una conexión de red MySQL. Un gestor de conexión de mysqli, mysql, y PDO_MYSQL representa una agrupación local de conexiones para los servidores maestros de replicación MySQL y esclavos de replicación MySQL configurados. El complemento redirige las consultas a los servidores maestros y esclavos. En algún momento, el mismo gestor de conexión de PHP podría apuntar al servidor maestro de MySQL. Después, podría apuntar a uno de los servidores esclavos o todavía al maestro. La manipulación y el reemplazamiento de la conexión de red referida por un gestor de conexión de MySQL para PHP no es una operación transparente.

Cada conexión MySQL tiene un estado. El estado de la conexión en la agrupación de conexiones del complemento puede diferir. Siempre que el complemento cambie de una conexión de cable a otra, el estado actual de la conexión del usuario puede cambiar. Las aplicaciones deben considerar esto.

La siguiente lista muestra en qué consiste el estado de conexión. La lista podría no ser completa.

  • Estado de transacción
  • Tablas temporales
  • Bloqueos de tablas
  • Variables de sistema de sesión y variables de usuario de sesión
  • La base de datos actual establecida mediante USE y otros estados de comandos SQL encadenados
  • Sentencias preparadas
  • Variables HANDLER
  • Bloqueos adquiridos con GET_LOCK()

EL intercambio de conexiones ocurre justo antes de la ejecución de las consultas. El complemento no intercambia la conexión actual hasata que sea ejecutada la siguiente sentencia.

Nota: Sobre la replicación

Véase también el capítulo sobre las » características de la replicación y temas relacionados del manual de referencia de MySQL. Algunas restricciones pueden no estar relacionadas con el complemento de PHP, pero son propiedades del sistema de replicación de MySQL.

Mensajes de difusión

La filosofía de complemento es alinear el estado de las conexiones en la agrupación solamente si el estado está bajo el control total del complemento, o si fuera necesario por razones de seguridad. Solamente una pocas acciones que cambian el estado de la conexión caen en esta categoría.

La siguiente es una lista de las llamadas a la biblioteca cliente de conexiones que cambian el estado, y son difundidas a todas las conexiones abiertas en la agrupación de conexiones.

Si va a ejecutar cualquier llamada enumerada abajo, el complemento iterará a través de todas las conexiones maestras y esclavas abiertas. El bucle continua hasta que todos los servidores hayan sido contactados, y no se detiene si un servidor indica un fallo. Si es posible, el fallo se propagará a la función de la API de usuario llamada, la cual puede ser detectada dependiendo de la función de la biblioteca subyacente que fue desencadenda.

Llamada a la bliblioteca | Notas | Versión
change_user() | Invocada por la llamda a la API de usuario de mysqli_change_user(). También es desencadenada una vez que se reutiliza una conexión persistente de mysqli. | Desde 1.0.0.
select_db | Invocada por las sigientes llamadas a la API de usuario: mysql_select_db(), mysql_list_tables(), mysql_db_query(), mysql_list_fields(), mysqli_select_db(). Observe que USE de SQL no se monitoriza. | Desde 1.0.0.
set_charset() | Invocada por las sigientes llamadas a la API de usuario: mysql_set_charset(). mysqli_set_charset(). Observe que SET NAMES de SQL no se monitoriza. | Desde 1.0.0.
set_server_option() | Invocada por las sigientes llamadas a la API de usuario: mysqli_multi_query(), mysqli_real_query(), mysqli_query(), mysql_query(). | Desde 1.0.0.
set_client_option() | Invocada por las sigientes llamadas a la API de usuario: mysqli_options(), mysqli_ssl_set(), mysqli_connect(), mysql_connect(), mysql_pconnect(). | Desde 1.0.0.
set_autocommit() | Invocada por las sigientes llamadas a la API de usuario: mysqli_autocommit(), PDO::setAttribute(PDO::ATTR_AUTOCOMMIT). | Desde 1.0.0. PHP >= 5.4.0.
ssl_set() | Invocada por las sigientes llamadas a la API de usuario: mysqli_ssl_set(). | Desde 1.1.0.

Difusión y conexiones retardadas

El complemento no delega o recuerda todas las configuraciones para aplicarlas a conexiones abiertas en el futuro. Es importante recordar esto si se usan conexiones retardadas. Las conexiones retardadas son conexiones que no se abren antes de que el cliente envíe la primera conexión. El uso de conexiones retardadas es la acción predeterminada del complemento.

Cada una de las siguientes llamadas a la biblioteca de conexiones cambia el estado, y su ejecución es recordada para un uso posterior cuando se abren las conexiones retardadas. Esto ayuda a asegurarse de que los estados de conexión de todas las conexiones de la agrupación de conexiones sean equiparables.

Llamada a la biblioteca | Notas | Versión
change_user() | Usuario, contraseña y base de datos recordados para un uso posterior. | Desde 1.1.0.
select_db | Bases de datos recordada par un uso posterior. | Desde 1.1.0.
set_charset() | Las llamadas a set_client_option(MYSQL_SET_CHARSET_NAME, charset) sobre conexiones retardadas aseguran que charset será utilizado una vez abierta la conexión retardada. | Desde 1.1.0.
set_autocommit() | Añade SET AUTOCOMMIT=0|1 a la lista de comandos 'init' en una conexión retardada usando set_client_option(MYSQL_INIT_COMMAND, "SET AUTOCOMMIT=...%quot;). | Desde 1.1.0. PHP >= 5.4.0.
Precaución

Estado de la conexión

El estado de la conexión no sólo se cambia mediante las llamadas a la API. Incluso si PECL mysqlnd_ms monitoriza todas las llamadas a la API, la aplicación aún deben considerarlo. En última instancia, es responsabilidad de las aplicaciones guardar el estado de la conexión, si fuera necesario.

Conjunto de caracteres y escape de cadenas

Debido al uso de conexiones retardadas, las cuales se emplean predeterminadamente, puede ocurrir que una aplicación intente escapar una cadena para usarla dentro de sentencias SQL antes de que una conexión haya sido establecida. En este caso, no es posible escapar la cadena. La función de escapado de cadenas no conoce el conjunto de caracteres a usar antes de que una conexión haya sido establecida.

Para superar este problema, el nuevo ajuste de configuración server_charset se introdujo en la versión 1.4.0.

Se debe prestar atención al escapar cadenas con ciertos conjuntos de caracteres si no es usando el resultado en una conexión que utilice un conjunto de caracteres diferente. Observe que PECL/mysqlnd_ms manipula las conexiones y que una conexión a nivel de aplicación representa una agrupación de múltiples conexiones donde todas pueden tener diferentes conjuntos de caracteres predeterminados. Se recomienda configurar los servidores involucrados para que utilicen el mismo conjunto de caracteres predeterminado. El ajuste de configuración server_charset también ayuda con esta situación. Si se usa server_charset, el complemento establecerá el conjunto de caracteres dado en todas las conexiones recientemente abiertas.


Manejo de transacciones locales

El manejo de transacciones ha cambiado de manera fundamental. Una transacción SQL es una unidad de trabajo que se ejecuta en un servidor de bases de datos. La unidad de trabajo consiste en una o más sentencias SQL.

De manera predeterminada, el complemento no considera las transacciones SQL. El complemento podría intercambiar conexiones para equilibrar la carga en cualquier momento. Los intercambios de conexión puede ocurrir en mitad de una transacción. Esto va contra la naturaleza de una transacción SQL. De manera predeterminada, el complemento no es seguro con transacciones.

A cualquier tipo de equilibrador de carga de MySQL se le debe indicar el comienzo y el final de una transacción. Esto se puede realizar implícitamente monitorizando las llamadas a la API o usando sugerencias SQL. El complemento admite ambas opciones, dependiendo de la versión de PHP. La monitorización de la API requiere PHP 5.4.0 o posterior. El complemento, al igual que cualquier otro equilibrador de carga de MySQL, no puede detectar los límites de una transacción basada en el Protocolo Cliente Servidor de MySQL. Por lo tanto, la consideración del equilibrado de carga de transacciones totalmente transparente no es posible. La opción menos invasiva es la monitorización de la API, que requiere pocos o ningún cambio en la aplicación, dependiendo de la misma.

Se pueden encontrar ejemplos del uso de sugerencias SQL o de la monitorización de la API en la sección de ejemplos. Los detalles trás la monitorización de la API, la cual hace que el complemento considere las transacciones, están descritos abajo.

Desde PHP 5.4.0, la biblioteca mysqlnd permite al complemento sobrescribir la llamada a set_autocommit() de la API en C de la biblioteca, para detectar el estado del modo autocommit.

Las extensiones de MySQL para PHP emiten una consulta (como SET AUTOCOMMIT=0|1), o usan la llamada a la biblioteca mysqlnd set_autocommit() para controlar el ajuste autocommit. Si una extensión hace uso de set_autocommit(), el complemento puede considerar las transacciones. Hacer que el complemento considere transacciones no se puede realizar si se usa SQL para establecer el modo 'autocommit'. La función set_autocommit() de la biblioteca es invocada por las llamadas a la API de mysqli_autocommit() y PDO::setAttribute(PDO::ATTR_AUTOCOMMIT).

La opción de configuración del complemento trx_stickiness=master se puede usar para hacer que el complemento considere las transacciones. De este modo, el complemento detiene el equilibrado de cara si 'autocommit' se deshabilita, y dirige todas las sentencias al maestro hasta que 'autocommit' se habilite.

Una aplicación que no requiera establecer las sugerencias SQL para las transacciones pero que requiera el uso de una monitorización transparente de la API para evitar cambios en la aplicación debe asegurarse de que los ajustes del modo autocommit son cambiados exclusivamente a través de las llamadas a la API enumeradas.

La detección de los límites de transacciones basada en API ha sido mejorada con PHP 5.5.0 y PECL/mysqlnd_ms 1.5.0 para cubirir no solo llamadas a mysqli_autocommit(), sino también a mysqli_begin(), mysqli_commit() y mysqli_rollback().


Manejo de errores

Las aplicaciones que usan PECL/mysqlnd_ms deberían implementar el manejo de errores apropiado para todas las llamadas a la API del usuario. Ya que el complemento cambia la semántica de un gestor de conexión, las llamadas a la API pueden devolver errores inesperados. Si se usa el complemento sobre un gestor de conexión que ya no represeta una conexión de red individual, sino una agrupación de conexiones, se establecerá un código de error y un mensaje de error en el gestor de conexión siempre que ocurra un error en cualquier conexión de red subyacente.

Si se usan conexiones retardadas, que es lo predeterminado, las conexiones no son abiertas hasta que sean necesarias para ejecutar consultas. Por lo tanto, una llamada a la API para la ejecución de una senetencia puede devolver un error de conexion. En el ejemplo de abajo, se provoca un error al intentar ejecutar una sentencia en un esclavo. La apertura de la conexión esclava fallará debido a que el fichero de configuración del complemento incluye un nombre de anfitrión no válido para el esclavo.

Ejemplo #1 Provocar un error de conexión

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "nombre_host_inváido",
            }
        },
        "lazy_connections": 1
    }
}

La activación explícita de conexiones retardadas sólo es con propósito de demostración.

Ejemplo #2 Error de conexión en la ejecución de una consulta

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (mysqli_connect_errno())
  /* Por supuesto, su manejo de errores es más agradable... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Conexión 1, la conexión vincula una variable SQL de usuario, no se ejecuta ningún SELECT en el maestro */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Conexión 2, se ejecuta en el esclavo a causa de SELECT, provoca un error de conexión */
if (!($resultado = $mysqli->query("SELECT @myrole AS _role"))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $fila = $resultado->fetch_assoc();
 $resultado->close();
 printf("@myrole = '%s'\n", $fila['_role']);
}
$mysqli->close();
?>

El resultado del ejemplo sería algo similar a:

PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
[2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

Se espera que la aplicaciones manejen los posibles errores de conexión mediante la implementación del manejo de errores apropiado.

Dependiendo del caso en uso, las aplicaciones pueden optar por manejar errores de conexión de forma diferente a otros errores. Los errores de conexión típicos son 2002 (CR_CONNECTION_ERROR) - Can't connect to local MySQL server through socket '%s' (%d), 2003 (CR_CONN_HOST_ERROR) - Can't connect to MySQL server on '%s' (%d) y 2005 (CR_UNKNOWN_HOST) - Unknown MySQL server host '%s' (%d). Por ejemplo, la aplicación podría comprobar los códigos de error y realizar una tolerancia a fallos manual. La filosofía del complemento no ofrece la tolerancia a fallos automática, más allá de la tolerancia a fallos del maestro, ya que no es una operación transaparente.

Ejemplo #3 Provocar un error de conexión

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "invalid_host_name"
            },
            "slave_1": {
                "host": "192.168.78.136"
            }
        },
        "lazy_connections": 1,
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

La activación explícita de conexiones retardadas sólo es con propósito de demostración, ya que el equilibrado de carga es de rotación en oposición al tipo predeterminado aleatorio una vez.

Ejemplo #4 Tolerancia a fallos más básica

<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (mysqli_connect_errno())
  /* Por supuesto, su manejo de errores es más agradable... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Conexión 1, la conexión vincula una variable SQL de usuario, no se ejecuta ningún SELECT en el maestro */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Conexión 2, primer esclavo */
$resultado = $mysqli->query("SELECT VERSION() AS _version");
/* Tolerancia a fallos manual */
if (2002 == $mysqli->errno || 2003 == $mysqli->errno || 2004 == $mysqli->errno) {
  /* Conexión 3, falló la conexión al primer esclavo, se intenta con el siguiente */
  $resultado = $mysqli->query("SELECT VERSION() AS _version");
}

if (!$resultado) {
  printf("ERROR, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
} else {
 /* Los mensajes de error se toman de la conexión 3, por lo que no hay errores */
 printf("SUCCESS, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
 $fila = $resultado->fetch_assoc();
 $resultado->close();
 printf("version = %s\n", $fila['_version']);
}
$mysqli->close();
?>

El resultado del ejemplo sería algo similar a:

[1045] Access denied for user 'nombre_usuario'@'localhost' (using password: YES)
PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
SUCCESS, [0] ''
version = 5.6.2-m5-log

En algunos casos, puede no ser posible la recuperación de forma sencilla de todos los errores que ocurran en todas las conexiones de red a través de un gestor de conexión. Por ejemplo, se asume que un gestor de conexión representa una agrupación de tres conexiones abiertas. Una conexión a un maestro y dos conexiones a los esclavos. La aplicación cambia la base de datos actual usando la llamada a la API de usuario mysqli_select_db(), la cual luego llama a la función de la biblioteca mysqlnd para cambiar el esquema. mysqlnd_ms monitoriza la función e intenta cambiar la base de datos ctual en todas las conexiones para armonizar sus estados. Ahora, se asume que el maestro tiene éxito al cambiar la base de datos, y ambos esclavos fallan. Durante el error inicial del primer esclavo, el complemento establecerá un error apropiado sobre en el gestor de conexión. Y lo mismo se hace cuando falla el segundo esclavo al cambiar la base de datos. El mensaje de error del primer esclavo se pierde.

Tales casos pueden ser depurados comprobando los errores de tipo E_WARNING (véase arriba) o, si no queda otra opción, investigar el registro de depuración y rastreo de mysqlnd_ms.


Errores transitorios

Algunos clústeres de bases de datos distribuidas hacen usan errores transitorios. Un error transitorio es un error temporal que es probable que dessaparezca pronto. Por definición, es seguro para un cliente el ignorar un error transitorio y reintentar la operación fallida en el mismo servidor de bases de datos. El reintento está libre de efectos segundarios. Los clientes no están forzados a abortar su trabajo o recurrir a otro servidor de bases de datos de forma inmediata. Podrían entrar en un bucle de reintentos antes de esperar a que el error desaparezca antes de dejar el servidor de bases de datos. Los errores transitorios pueden ser vistos, por ejemplo, al usar MySQL Cluster. Aunque no están limitados a ninguan solución de clústeres específica per se.

PECL/mysqlnd_ms puede realizar un bucle de reintentos automático en caso de darse un error transitorio. Esto aumento la transparencia de la distribución y, por lo tanto, hace más sencillo migrar una aplicación ejecutando en un único servidor de bases de datos para ejecutar un clúster de servidores de bases de datos sin tener que cambiar el origen de la aplicación.

El bucle de reintentos automáticos repetirá la operación solicitada hasta un número de veces configurable por el usuario y hará una pausa entre intentos por una cantidad de tiempo configurable. Si el error desaparece durante el bucle, la aplicación nunca lo verá. Si no, el error es reenviado a al aplicación para su manejo.

En el ejemplo de abajo se provoca un error de clave duplicada para hacer que el complemento reintente la consulta fallida dos vedes antes de que el error sea pasado a la aplicación. Entre los dos intentos, el complemento duerme durante 100 milisegundos.

Ejemplo #1 Provocar un error transitorio

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1062
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Ejemplo #2 Bucle de reintentos del error transitorio

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Por supuesto, su manejo de errores es mejor... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT PRIMARY KEY)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* El bucle de reintentos es completamente transaparente. Verificar las estadísticas es
 la única manera de conocer algo sobre los reintentos implícitos */
$stats = mysqlnd_ms_get_stats();
printf("Intentos del error transitorio antes del error: %d\n", $stats['transient_error_retries']);

/* Provocar un error de clave duplicada para ver el cambio en las estadísticas */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

$stats = mysqlnd_ms_get_stats();
printf("Intentos del error transitorio después del error: %d\n", $stats['transient_error_retries']);

$mysqli->close();
?>

El resultado del ejemplo sería algo similar a:

Intentos del error transitorio antes del error: 0
[1062] Duplicate entry '1' for key 'PRIMARY'
Intentos del error transitorio después del error: 2

Ya que la ejecución del bucle de reintentos es transparente desde el punt de vista de los usuarios, el ejemplo comprueba las estadísticas proporcionadas por el complemento para aprender de ellas.

Como muetra el ejemplo, el complemento puede ser instruido para considerar cualquier error transitorio a pesar de la semámtica de los errores de los servidores de bases de datos. El único error que cosidera temporal un stock de servidor MySQL tiene el código de error 1297. Al configurar otror códigos de errores excepto el 1297, asegúrese de que la configuración refleja la semántica de los códigos de error del clúster.

Las siguientes llamadas a las API en C de mysqlnd están monitorizadas por el complemento para
comprobar errores transitorios: query(),
change_user(), select_db(),
set_charset(), set_server_option()
prepare(), execute(),
set_autocommit(),
tx_begin(), tx_commit(),
tx_rollback(), tx_commit_or_rollback().
Las llamadas a la API de usuario correspondientes tienen nombres similares.

El tiemp máximo que el complemento puede dormir durante el bucle de reintentos depende de la función en cuestión. Un bucle de reintentos para query(), prepare() o execute() dormirá hasta max_retries * usleep_retry milisegundos.

Sin embargo, las funciones que controlan el estado de conexión son despachadas para todas las conexiones. Los ajustes del bucle de reintentos están aplicados a cada conexión sobre la cual el comando se está ejecutando. Así, tales funciones podrían interrumpir la ejecución del programa durante más tiempo que una función que se ejecute sobre únicamente un servidor. Por ejemplo, set_autocommit() es despachada para conexiones y podría dormir hasta (max_retries * usleep_retry) * number_of_open_connections) milisegundos. Por favor, mantenga esto en mento al configurar tiempos de dormir largos y números de reintentos grandes. Con los ajustes preestablecidos de max_retries=1, usleep_retry=100 y lazy_connections=1 es improbable que vea un retarno de más de un segundo.


Tolerancia a fallos

De forma predeterminada, el manejo de la toleracia a fallos de conexiones se le deja al usuario. La aplicación es responsable de comprobar los valores devueltos de las funciones de bases de datos a las que llama y reaccionar a posibles errores. Si, por ejemplo, el complemento reconoce una consulta como de solo lectura para ser enviada a los servidores esclavos, y el servidor esclavo seleccionado por el complemento no está disponible, el complemento emitirá un error después de no ejecutar la sentencia.

Predeterminado: tolerancia a fallos manual

Es responsabilidad de la aplicación manejar el error y, si fuera necesario, reemitir la consulta para desencadenar la selección de otro servidor esclavo para la ejecución de la sentencia. El complemento no intentará la tolerancia a fallos automáticamente, ya que no puede estar seguro de que una tolerancia a fallos automática cambie el estado de la conexión. Por ejemplo, la aplicación podría haber emitido una consulta que depende de variables SQL del usuario, las cuales están vinculadas a una conexión específica. Tal conexión podría devolver resultados incorrectos si el complemento intercambia la conexión implícitamente como parte de la tolerancia a fallos automática. Para asegurase de obtener resultados correctos, la aplicación debe ocuparse de la tolerancia a fallos, y reconstruir el estado de conexión requerido. Por lo tanto, de forma predeterminada, el complemento no realiza la tolerancia a fallos automática.

Un usuario que no cambie el estado de la conexión después de abrir una conexión puede activar la tolerancia a fallos automática. Observe que la lógica de la tolerancia a fallos automática está limitada a intentos de conexión. La tolerancia a fallos automática no se utiliza para conexiones ya establecidas. No hay manera de ordenar al complemento que intente la toleranca a fallos con una conexión que ya ha sido establecida con MySQL anteriormente.

Tolerancia a fallos automática

La política de la tolerancia a fallos se configura en el fichero de configuración del complemento, usando la directiva de configuración failover.

La tolerancia a fallos automática y silenciosa se puede habilitar a través de la directiva de configuración failover. La tolerancia a fallos automática se puede configurar para intentarla en exactamente un maestro después del fallo de un esclavo, o, alternativamente, iterando sobre los esclavos y maestros antes de devolver un error al usuario. El número de intentos de conexión se puede limitar, y los equipos anfitriones fallidos se pueden excluir de los intentos de equilibrado de carga futuros. La limitación del número de reintentos y el recuerdo de los equipos anfitriones fallidos son considerados características experimentales, aunque son razonablemente estables. La sintaxis y la semántica puede cambiar en versiones futuras.

Observe que desde la versión 1.5.0 la tolerancia a fallos automática está deshabilitada durante una transacción si está habilitada la adhesión de transacciones y se han detectado los límites de la transacción. El complento no intercambiará conexiones durante una transacción. Tampoco realizará la tolerancia a fallos automática ni silenciosa. En su lugar se lanzará un error. Es entoces responsabilidad del usuario el manejo del fallo de una transacción. Por favor, consulte la documetación de trx_stickiness para saber cómo hacer esto.

Se proporciona un ejemplo básico de tolerancia a fallos manual en la sección manejo de errores.

Servidores de emergencia

Al usar el equilibrado de carga ponderado, introducido en PECL/mysqlnd 1.4.0, es posible configurar servidores de emergencia que son utilizados escasamente durante operaciones normales. A un servidor de emergencia que se usa principalmente como objetivo en el peor de los casos de tolerancia a fallos de emergencia se le puede asignar un peso o prioridad muy bajos en relación a los demás servidores. Siempre y cuando todos los servidores estén activos y la ejecución de la mayoría del trabajo sea asignada a los servidores que tienen valores de peso altos. Pocas peticiones serán redirigidas a un sistema de emergencia que tenga un valor de peso muy bajo.

Cuando ocurre un fallo en los servidores con una prioridad alta, aún se puede realizar la tolerancia a fallos en el sistema de emergencia, al cual se le ha dado una prioridad baja de equilibrado de carga asignándole un peso bajo. La tolerancia a fallos puede ser manual o automática. Si se realiza automáticamente se puede combinar con la opción remember_failed.

En este punto, no es posible ordenar al equilibrador de carga que no dirija ninguna petición al sistema de emergencia. Esto podría no ser una limitación dado que el mayor peso que se puede asignar a un servidor es 65535. Dados dos esclavos, uno de los cuales actuaría como de emergencia y al que se le ha asignado un peso de 1, el sistema de emergencia tendrá que manejar mucho menos del 1 por ciento del total del trabajo.

Tolerancia a fallos y copia primaria

Observe que si se utiliza un clúster de copia primario, tal como la Replicación MySQL, es difícil realizar la tolerancia a fallos de conexión en caso de que falle un maestro. En cualquier momento, sólo hay un maestro en el clúster para un conjunto de datos dado. El maestro es un único punto de fallo. Si el maestro falla, los clientes no tienen un objetivo donde realizar la tolerancia a fallos en peticiones de escritura. En caso de que un maestro apague la base de datos, el administrador debe ocuparse de la situación y actualizar la configuración del cliente, si fuera necesario.


Equilibrado de carga

Se admiten cuatro estrategias de equilibrado de carga para distribuir sentencias sobre los servidores esclavos de MySQL configurados:

aleatorio

Se elige un servidor aleatorio cada vez que se ejecute una sentencia.

aleatorio una vez (predeterminado)

Se elige un servidor aleatorio después de ejecutar la primera sentencia, y se utiliza la decisión tomada para el resto de las peticiones de PHP.

Es lo predeterminado, y de menor impacto para el estado de conexión.

rotación

Se itera sobre la lista de servidores configurados.

definido por el usuario mediante una llamada de retorno

Se utiliza para implementar cualquier otra estrategia.

La política del equilibrado de carga se configura en el fichero de cofiguración de los complementos usando random, roundrobin, y user como filtro.

Los servidores se pueden priorizar asignándoles un peso. Un servidor al que se le haya dado un peso de dos obtendrá el doble de peticiones que un servidor que se le haya dado el peso predeterminado de uno. La prioridad puede ser muy útil en entornos heterogéneos. Por ejemplo, si se quiere asignar más peticiones a una máquina potente que una menos potente. O se pueden tener configurados servidores que están cerca o lejos del cliente, y así exponer diferentes latencias.


División de lectura-escritura

El complemento ejecuta las senteciss de solo lectura en los esclavos MySQL cofigurados, y las demás consultas en el maestro MySQL. Una sentencia se considera de solo lectura si empieza con SELECT, con la sugerencia SQL /*ms=slave*/, o si un esclavo ha sido elegido para ejecutar la consulta anterior y la consulta empiza con la sugerencia SQL /*ms=last_used*/. El los demás casos, la consulta será enviada al servidor maestro de replicación MySQL. Se recomienda usar las constantes MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_MASTER_SWITCH y MYSQLND_MS_LAST_USED_SWITCH en lugar de /*ms=slave*/. Véase también la lista de constantes de mysqlnd_ms.

Las sugerencias SQL son un tipo especial de comentarios que cumplen el estándar SQL. El complemento revisa cada sentencia en busca de ciertas sugerencias SQL. Las sugerencias SQL están descritas en la documentación de las constantes de mysqlnd_ms, constantes que son exportadas por la extensión. Otros sistemas involucrados en el procesamiento de sentencias, como el servidor MySQL, los cortafuegos SQL, y los proxys SQL, no se ven afectados por las sugerencias SQL, ya que estos sistemas están diseñados para ignorar los comentarios SQL.

El divisor de lectura-escritura interno puede ser reemplazado por un filtro definido por el usuario. Véase también la documentación de filtros de usuario.

Un divisor de lectura-escritura definido por el usuario puede solicitar la lógica interna para enviar una sentencia a una ubicación específica invocando a mysqlnd_ms_is_select().

Nota:

El divisor de lectura-escritura interno no considera las sentencias múltiples. Éstas se ven como una sola sentencia. El divisor comprobará el comienzo de una sentencia para decidir dónde ejecutarla. Si, por ejemplo, una sentencia múltiple comienza con SELECT 1 FROM DUAL; INSERT INTO test(id) VALUES (1); ... el complemento la ejecutará en un esclavo aunque la sentencia no sea de solo lectura.


Filtro

Nota: Requisitos de versión

Los filtros existen a partir de la versión 1.1.0-beta de mysqlnd_ms.

filtros. Las aplicaciones de PHP que implementen un clúster de replicación MySQL deben identificar primero un grupo de servidores en el clúster que podrían ejecutar una sentencia antes de que ésta sea ejecutada por uno de los candidatos. En otras palabras: se debe filtrar una lista de servidores definidos hasta que esté disponible solamente un servidor.

El proceso de filtrado puede incluir el uso de uno o más filtros, los cuales pueden estar encadenados. Son ejecutados en el orden en el que están definidos en el fichero de configuración del complemento.

Nota: Aclaración: comparación entre cadena de filtros y tuberías

El concepto de filtros encadenados puede ser comparado con el uso de tuberías para conectar utilidades de línea de comandos en un sistema operativo intérprete de comandos. Por ejemplo, un flujo de entrada se pasa al procesador, se filtra, y luego se transfiere para su salida. Entonces, la salida se pasa al siguiente comando, el cual está conectado al anterior mediante el operador de tubería.

Filtros disponibles:

  • Filtros de equilibrado de carga: random y roundrobin.
  • Filtros de selección: user, user_multi, quality_of_service.

El filtro random implementa las políticas de equilibrado de carga 'aleatoria' y 'aleatorio una vez'. El equilibrado de carga 'rotacional' se puede configurar a través del filtro roundrobin. Estblecer una 'llamada de retorno definida por el usuario' para la selección del servidor es posible con filtro user. El filtro quality_of_service busca nodos del clúster capaces de cumplir con un cierto servicio, por ejemplo, la lectura de sus escrituras, o no demorar más segundos de lo permitido con respecto al maestro.

Los filtros puede aceptar parámetros para cambiar su comportamiento. El filtro random acepta el parámetro opcional sticky. Si se establece a 'true', el filtro cambia el equilibrado de carga de 'aleatorio' a 'aleatorio una vez'. 'Aleatorio' escoge un servidor aleatorio cada vez qeu se vaya a ejecutar una sentencia. 'Aleatorio una vez' escoge un servidor aleatorio cuando la primera sentencia va a ser ejecutada y utiliza el mismo servidor para el resto de peticiones de PHP.

Una de los puntos fuertes del concepto de filtro es la posibilidad de encadenar filtros. Este punto fuerte no se hace inmediatamente visible debido a que los filtros random, roundrobin y user deben de producir no más de un servidor. Si un filtro reduce la lista de candidatos para la ejecución de una sentencia a un único servidor, tiene poco sentido usar ese servidor como entrada de otro filtro para reducir aún más la lista de candidatos.

Un ejemplo de una secuencia de filtros que fallará:

  • Sentencia a ejecutar: SELECT 1 FROM DUAL. Pasada a todos los filtros.
  • Todos los nodos configurados son pasados como entrada al primer filtro. Nodos maestro: master_0. Nodos esclavo:slave_0, slave_1
  • Filtro: random, argumento sticky=1. Elige un esclavo aleatorio una vez para utilizarlo para el resto de peticiones de PHP. Salida: slave_0.
  • La salida de slave_0 y la sentencia a ejecutar son pasadas como entradas al siguiente filtro. Aquí: roundrobin, la lista de servidores pasada para filtrar es: slave_0.
  • Filtro: roundrobin. La lista de servidores consisten en un solo servidor, la rotación siempre devolverá el mismo servidor.
Si se intenta usar esta secuencia de filtros, el complemento puede emitir una advertencia como (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d. Además, se puede establecer un error apropiado para el gestor de conexión.

Existe un segundo tipo de filtro: el filtro múltiple. Un filtro múltiple emite cero, uno o múltiples servidores después del procesamiento. El filtro quality_of_service es un ejemplo. Si la calidad de servicio solicitada establece un límite superior para la demora del esclavo y más de un esclavo se demora menos que el número de segundos permitido, el filtro devuelve más de un nodo del clúster. Un filtro múltiple debe ser seguido de otro para reducir aún más la lista de candidatos para la ejecución de sentencias hasta que se encuentre un candidato.

Una secuencia de filtros con el filtro múltiple quality_of_service seguido por un filtro de equilibrado de carga.

  • Sentencia a ejecutar: SELECT sum(price) FROM orders WHERE order_id = 1. Pasada a todos los filtros.
  • Todos los nodos configurados son pasados como entrada para el primer filtro. Nodos maestro: master_0. Nodos esclavo: slave_0, slave_1, slave_2, slave_3
  • Filtro: quality_of_service, conjunto de reglas: session_consistency (lectura de sus escrituras) Salida: master_0
  • La salida de master_0 y la sentencia a ejecutar son pasadas como entrada al siguiente filtro, el cual es roundrobin.
  • Filtro: roundrobin. La lista de servidores consiste en un servidor. La rotación selecciona master_0.

Una secuencia de filtros no debe finalizar con un filtro múltiple. Si se intenta usar una sencuencia de filtros que finaliza con un filtro múltiple, el complemento puede emitir una advertencias como (mysqlnd_ms) Error in configuration. Last filter is multi filter. Needs to be non-multi one. Stopping in %s on line %d. Además, se puede establecer un error apropiado para el gestor de conexión.

Nota: Especulación sobre el futuro: filtrado de replicación MySQL

En futuras versiones, pueden existir filtros múltiples adicionales. Por ejemplo podría existir un filtro table para soportar el filtrado de replicación MySQL. Esto podría permitir la definición de reglas para qué base de datos o tabla van a ser replicadas a cual nodo de un clúster de replicación. Se asume que el clúster de replicación consiste en cuatro esclavos (slave_0, slave_1, slave_2, slave_3), dos de los cuales replican una base de datos llamada ventas (slave_0, slave_1). Si la aplicación pregunta a la base de datos esclavos, el hipotético filtro table reduciría la lista de posibles servidores a slave_0 y slave_1. Ya que la salida y la lista de candidatos consiste en más de un servidor, es posible y necesario añadir filtros adicionales a la lista de candidatos, por ejemplo, usando un filtro de equilibrado de carga para identificar un servidor para la ejecución de sentencias.


Nivel de servicio y consistencia

Nota: Requisitos de versión

Los niveles de servicio han sido introducidos en la versión 1.2.0-alpha de mysqlnd_ms. mysqlnd_ms_set_qos() requiere PHP 5.4.0 o posterior.

El complemento se puede usar con diferentes tipos de clústeres de bases de datos MySQL. Los diferentes clústeres pueden proporcionar diferentes niveles de servicios a las aplicaciones. Los niveles de servicios pueden ser agrupados por los niveles de consistencia de datos que se puedan alcanzar. El complemento está al tanto de la:

  • consistencia final
  • consistencia de sesión
  • consistencia fuerte

Dependiendo de cómo se use un clúster, puede ser posbile alcanzar niveles de servicios más altos que el predeterminado. Por ejemplo, una lectura desde un esclavo de replicación MySQL asíncrono es consistencia final. Así, uno podría decir que el nivel de consistencia predeterminado de un clúster de replicación MySQL es consistencia final. Sin embargo, si el maestro solamente es utilizado por un cliente para lectura y escritura durante una sesión, entonces se da la consistencia de sesión (lectura de sus escrituras). PECL mysqlnd 1.2.0 abstrae al usuario los detalles de la elección de un nodo apropiado para cualquiera de los niveles de servicios de arriba mencionados.

Los niveles de servicios se pueden establecer a través del filtro 'qualify-of-service' en el fichero de configuración del complemento y en tiempo de ejecución utilizando la función mysqlnd_ms_set_qos().

El complemento define los diferentes niveles de servicios como sigue:

La consistencia final es el servicio predeterminado proporcionado por un clúster asíncrono, como la clásica replicación MySQL. Una operación de lectura ejecutada en un nodo arbitrario puede o no devolver datos antiguos. El punto de vista de las aplicaciones de los datos es consistente final.

La consistencia de sesión se da si un cliente siempre puede leer sus propias escrituras. Un clúster de replicación MySQL asíncrona puede proporcionar consistencia de sesión si los clientes siempre usan el maestro después del la primera escritura, o nunca consultan un esclavo que aún no ha replicado la operación de escritura de los clientes.

La interpretación del complemento de la consistencia fuerte es que todos los cliente siempre ven las escrituras consignadas de todos los demás clientes. Esto es lo predeterminado cuando se usa el Clúster MySQL o cualquier otro clúster que ofrezca distribución de datos asíncrona.

Parámetros de los niveles de servicios

Los niveles de servicos de consistencia final y consistencia de sesión aceptan parámetros.

La consistencia final es el servicio proporcionado por la replicación MySQL clásica. De forma predeterminada, todos los nodos tienen derecho a peticiones de lectura. El parámetro opcional age puede ser proporcionado para filtrar nodos que se demoren más que un cierto número de segundos con respecto al maestro. El complemento utiliza SHOW SLAVE STATUS para medir la demora. Vea el manual de referencia de MySQL para aprender sobre la precición y fiabilidad del comando SHOW SLAVE STATUS.

La consistencia de sesión (lectura de sus escritura) acepta el parámetro opcional GTID para considerar la lectura no sólo desde el maestro, sino también desde los esclavos que ya han replicado una escritura en particular descrita por su identificador de transacciones. De esta forma, cuando se utiliza la replicación MySQL asíncrona, las peticiones de lectura pueden uar el equilibrado de carga sobre los esclavos mientras todavía se asegura la consistencia de sesión.

Lo último requiere el uso de la inyección de IDs de transacciones globales en el lado del cliente.

Ventajas de este nuevo enfoque

El nuevo enfoque sustituye el uso de sugerencias SQL y de la opción de configuración master_on_write en varios sentidos. Si una aplicicón se ejecuta en lo más alto de un clúster de replicación MySQL asíncrono, no puede acceptar datos antiguos para ciertas lecturas, es más sencillo indicarle al complemento que elija los nodos apropiados que prefijar todas las sentencias de lectura en cuestión con sugerencias SQL para forzar el uso del maestro. Además, el comlemento puede ser capaz de utilizar esclavos seleccionados para la lectura.

La opción de configuración master_on_write hace que el complemento use el maestro después de la primera escritura (consistencia de sesión, lectura de sus escrituras). En algunos casos, la consistencia de sesión puede no ser necesaria para el resto de la sesión, sólo para unas pocas operaciones de lectura. Así, master_on_write puede resultar en más carga de lectura en el maestro de la necesaria. En estos casos, es mejor solicitar un nivel de servicios superior al predeterminado solamente para aquellas lecturas que realmente lo necesiten. Una vez que las lecturas se han realizado, la apliacion puede vovler al nivel de servicios predetereminado. El cambio entre niveles de servicio solo es posible con el uso de mysqlnd_ms_set_qos().

Consideraciones de rendimiento

Un clúster de replicación MySQL no puede indicarle a los clientes qué esclavos son capaces de proporcionar cuales niveles de servicios. Por lo tanto, en algunos casos, los clientes necesitan consultar a los esclavos para comprobar sus estados. PECL mysqlnd_ms ejecuta de forma transparente el SQL necesario en segundo plano. Sin embargo, es una operación cara y lenta. Las sentencias SQL se ejecutan si se combina la consistencia final con una edad (demora del esclavo) límite y si la consistencia de sesión se combina con un ID de transacciones global.

Si la consistencia final se combina con una edad (demora del esclavo) máxima, el complemento seleccionará candidatos para la ejecución de sentencias y equilibrará la carga para cada sentencia como sigue. Si la sentencia es una escritura, todos los maestros son considerados como candidato. Los esclavos no se comprueban y no son considerados como candidatos. Si la sentencia es una lectura, el complemento ejecuta de forma transparente SHOW SLAVE STATUS en cada conexión esclava. Iterará sobre todas las conexiones, enviará la sentencia y luego iniciará la comprobación de los resultados. Normalmente, esto es ligeramente más rápido qe iterar sobre todas las conexiones en las que se envía una consulta para cada conexión y que el complemento espere sus resultados. Un esclavo es considerado un candidato si SHOW SLAVE STATUS notifica que Slave_IO_Running=Yes, Slave_SQL_Running=Yes y Seconds_Behind_Master es menor o igual que la edad máxima permitida. En caso de que ocurra un error SQL, el complemento emite una advertencia, aunque no establece un error en la conexión. Éste no se establece para que el complemento se pueda usar como sustituto.

Si la consistencia de sesión se combina con un ID de transacciones global, el complemento ejecutará la sentencia establecida con la entrada fetch_last_gtid de la sección global_transaction_id_injection del fichero de configuración del complemento. Los demás detalles son idénticos a los descritos arriba.

En la versión 1.2.0 no se realizan optimizaciones adicionales para ejecutar consultas en segundo plano. Futuras versiones pueden contener optimizaciones, dependiendo de la demanda de los usuarios.

Si no se establece ningún parámetro ni ninguna opción, no es necesaria ninguna sentencia SQL. En este caso, el complemento considera que todos los nodos son del tipo mostrado abajo.

  • consistencia final, no se establecen opciones adicionales: todos los maestros, todos los esclavos
  • consistencia de sesión, no se establecen opciones adicionales: todos los maestros
  • consistencia fuerte (no se permiten opcioines): todos los maestros

Estrangulamiento

El filtro de calidad de servicio se puede combinar con IDs de transacciones globales para estrangular clientes. El estrangulamiento reduce la carga de escritura en el maestro desacelerando los clientes. Si se solicita la consistencia de sesión y se usa el identificador de transacciones global para comprobar el estado de un esclavo, esta comprobación se puede hacer de dos maneras. Por omisión, un esclavo se comprueba y se salta inmediatamente si no concuerda con el criterio de la consistencia de sesión. De forma alternativa, el complemento puede esperar a que un esclavo se ponga al día con el maestro hasta que la consistencia de sesión sea posible. Para habilitar el estrangulamiento se debe establecer la opción de configuración wait_for_gtid_timeout.


IDs de transacciones globales

Nota: Requisitos de versión

La inyección de IDs de transacciones globales en el lado del cliente existe a partir de la versión 1.2.0-alpha de mysqlnd_ms. Los límites de una transacción son detectados monitorizando las llamadas a la API. Esto es posible a partir de PHP 5.4.0. Por favor, vea también Manejo de transacciones.

A partir de MySQL 5.6.5-m8, el servidor MySQL introduce los identificadores de transacciones globales internos. La característica del ID de transacciones global interno de MySQL es soportada por PECL/mysqlnd_ms 1.3.0-alpha o posterior. No es necesario la monitorización de los límites de transacciones en el lado del cliente ni ninguna configuración si se utiliza la característica del servidor.

Observe que todas las versiones de producción de MySQL 5.6 no proporcionan clientes con suficiente información para usar GTID para forzar la consistencia de sesión. En el peor de los casos, el complemento eligirá solamente el maestro.

Idea y emulación en el lado del cliente

PECL/mysqlnd_ms también realiza la inyección transparente de IDs de transacciones globales en el lado del cliente. En su forma más básica, un identificador de transacciones global es un contador que se incrementa en cada transacción ejecutada en el maestro. El contador se guarda en una tabla del maestro. Los esclavos replican la tabla del contador.

En caso de que falle un maestro, el adminstrador de la base de datos puede identificar fácilmente el esclavo más reciente para promoverlo como nuevo maestro. El esclavo más reciente tiene el identificador de transacciones más alto.

Los desarrolladores de aplicaciones pueden solicitar al complemento el identificador de transacciones global (GTID) para su última operación de escritura que tuvo éxito. El complemento devolverá un identificador que hace referencia a una transacción no más antigua que la última operación de escritura del cliente. Entonces, el GTID puede ser pasado como parámetro al filtro de calidad de servicio (QoS) como una opción para la consistencia de sesión. La consistencia de sesión se asegura de la lectura de sus escrituras. El filtro se asegura de que todas las lecturas son dirigidas al maestro o a un esclavo que haya replicado la escritura referida por el GTID.

Cuándo se realiza la inyección

El complemento mantiene de forma transparente la tabla del GTID del maestro. En el modo 'autocommit', el complemento inyecta una sentencia UPDATE antes de ejecutar las sentencias del usuario por cada uso del maestro. En el modo de transacción manual, la inyección se realiza antes de que la aplicación llame a commit() para cerrar la transacción. La opción de configuración report_error de la sección del GTID del fichero de configuración del complemento se utiliza para controlar si una inyección fallida debería abortar la operación actual o ser ignorada de forma silenciosa (lo predeterminado).

Por favor, observe los requisitos de versión de PHP para la monitorización de los límites de transacciones y sus limitaciones.

Limitaciones

La inyección de IDs de transacciones globales en el lado del cliente tiene defectos. Los problemas potenciales no son específicos de PECL/mysqlnd_ms, sino que son de naturaleza general.

  • Las tablas de IDs de transacciones globales deben ser desplegadas en todos los maestros y en todas las réplicas.
  • El GTID puede tener agujeros. Únicamente los clientes de PHP que utilicen el complemento mantendrán la tabla. Los demás clientes no lo harán.
  • La detección de los límites de las transacciones en el lado del cliente solamente está basada en llamadas a la API.
  • La detección de los límites de las transacciones en el lado del cliente no toma en cuenta la consigna implícita. Algunas setnencias SQL de MySQL causan una consignación implícita, por lo que no pueden ser revertidas.

Utilizar el identificador de transacciones global en el lado del servidor

Desde PECL/mysqlnd_ms 1.3.0-alpha se admite la característica del identificador de transacciones global interno de MySQL 5.6.5-m8 o posterior. El uso de esta característica del servidor elimna todas las limitaciones enumeradas arriba. Por favor, lea el Manual de Referencia de MySQL para conocer las limitaciones y las precondiciones del uso de identificadores de transacciones globales internos.

Si se utiliza la emulación del lado del cliente o la funcionalidad interna del servidor, es una cuestión que no está directamente relacionada con el complemento, por lo que no se trata en profundidad. No hay planes para eliminar la emulación del lado del cliente, por lo que se puede continuar usándola, si la solución del lado del servidor no es una opción. Éste podría ser el caso de entornos heterogéneos con un servidor MySQL antiguo, o si cualquiera de las limitaciones de la solución del lado del servidor no son acpetables.

Desde la perspectiva de las aplicaciones casi no hay diferencia en el uso de una estrategia u otra. Difieren las siguientes propiedades.

  • La emulación en el lado del cliente, como se muestra en el manual, utiliza un número de secuencia de transacciones global fácil de comparar. Los maestros múltiples no se tratan para no complicar los ejemplos del manual. La característica interna del lado del servidor utiliza una combinación de un identificador de servidor y un número de secuencia como identificador de transacciones global. La comparación no puede hacerse mediante álgebra numérica. En su lugar, se debe usar una función SQL. Por favor, lea el Manual de referencia de MySQL para más detalles. No se puede usar la característica interna del lado del servidor de MySQL 5.6 para asegurar la consistencia de sesión bajo ninguna circunstancia. No la utilice para la característica de calidad de servicio. Aquí se expone un ejemplo sencillo de por qué no proporcionará resultado fiables. Hay más casos límites que no se pueden cubrir con la funcionalidad limitada exportada por el servidor. Actualmente, los clientes solamente pueden preguntar al maestro de replicación de MySQL por una lista de todos los ID de transacciones globales ejecutadas. Si un esclavo está configurado para no replicar todas las transacciones, por ejemplo, porque están establecidos los filtros de replicación, el esclavo nunca mostrará el mismo conjunto de ID de transacciones globales ejecutadas. Aunque el esclavo podría haber replicado las escrituras de un cliente y podría ser un candidato para una lectura consistente, nunca será considerado por el complemento. En cuanto a la escritura, el complemento aprende del maestro que el historial de transacciones de servidores completo consiste en GTID=1..3. No hay forma de que el complemento pregunte por el GTID de la transacción de escritura en sí, digamos GTID=3. Se asume que el esclavo no replica la transacciones GTID=1..2, sino solamente GTID=3 debido a una característica de replicación. Entonces, el historial de transacciones de esclavos es GTID=3. Sin embargo, el complemento intenta encontrar un nodo que tenga un historial de transacción de GITD=1...3. Aunque el esclavo haya replicado la escritura del cliente y la consistencia de sesión podría alcanzarse al leer desde el esclavo, el complemento no lo considerará. Esto no es un fallo de la implementación del complemento, sino una laguna de la característica del lado del servidor. Observe que es este es un caso trivial para ilustrar el problema; existen otros más. En resumen, se sugiere no intentar usar los GTID internos de MySQL 5.6 para forzar la consistencia de sesión. Tarde o temprano, el equilibrado de carga dejará de funcionar de manera apropiada y el complemento dirigirá todas las peticiones de consistencia de sesión al maestro.
  • Las estadísticas de los IDs de transacciones globales están disponibles únicamente con la emulación en el lado del cliente debido a que monitorizan dicha emulación.

Nota: Identificadores de transacciones globales en sistemas distribuidos

Los identificadores de transacciones globales pueden servir para múltiples propósitos en el contexto de sistemas distribuidos, como un clúster de bases de datos. Los identificadores de transacciones globales se pueden usar para, por ejemplo, la identificación de transacciones en todo el sistema, el ordenameiento global de transacciones, el mecanismo de pulso, y la comprobación del estado de replicación de las réplicas. PECL/mysqlnd_ms, un software basado en un controlador del lado del cliente, enfoca el uso de GTIDs para tareas que puedan ser tratadas en el cliente, como la comprobación del estado de replicación de las réplicas para configuraciones de replicación asíncronas.


Integración de una caché

Nota: Requisitos de versión

Esta característica requiere el uso de PECL/mysqlnd_ms 1.3.0-beta o posterior y de PECL/mysqlnd_qc 1.1.0-alpha o posterior. PECL/mysqlnd_ms debe ser compilado para soportar esta característica. Se requiere PHP 5.4.0 o posterior.

Nota: Configuración: orden de caraga de las extensiones

PECL/mysqlnd_ms debe cargarse antes que PECL/mysqlnd_qc, cuando se utilizan extensiones compartidas.

Nota: Estabilidad de la característica

La integración de la caché es de calidad beta.

Nota: Clústeres de MySQL adecuados

Esta característica está pensada para usarla con la Repliación MySQL (copia primaria). Actualmente, no se admiten otros tipos de clústeres MySQL. Los usuarios de tales clústeres deben controlar PECL/mysqlnd_qc manualmente si están insteresados en el almacenamiento en caché de consultas en el lado del servidor.

El enfoque principal de PECL/mysqlnd_ms es el soporte para los clústeres de replicación MySQL (copia primaria asíncrona). Los esclavos de un clúster de replicación MySQL pueden o no reflejar las últimas actualizaciones del servidor. Los esclavos son asíncronos y pueden demorarse con respecto al maestro. Una lectura desde un esclavo se considera que es consistencia final desde una perspectiva total del clúster.

El mismo nivel de consistencia es ofrecido por el almacenamiento en caché, usando la estrategia de invalidación de tiempo de vida (TTL). Se pueden servir datos actuales o antiguos. Finalmente, los datos buscados en la caché no estarán disponibles, por lo que es necesario acceder al origen de la caché.

Dado que un esclavo de Replicación MySQL (secundario asíncrono) y una caché local que maneja TTL proporcionan el mismo nivel de servicio, es posible reemplzar de forma transparente un acceso a una base de datos remota con un acceso a la caché local para obtener mejores posibilidades.

A partir de PECL/mysqlnd_ms 1.3.0-beta, el complemento puede controlar de forma transparente PECL/mysqlnd_ms 1.1.0-alpha o posterior para almacenar en caché una consulta de solo lectura, si está explícitamente permitido, configurando una calidad de servicio apropiada a través de mysqlnd_ms_set_qos(). Por favor, lea la guía rápida para ver un ejemplo de código. Ambos complementos deben estar instalados, PECL/mysqlnd_ms debe ser compilado para soportar la característica de la caché y se ha de utilizar PHP 5.4.0 o posterior.

Las aplicaciones tienen control total sobre el uso de la caché y pueden solicitar datos actuales en cualquier momento si fuera necesario. Se puede habilitar y deshabilitar el uso de la caché durante la ejecución de un script. La caché se usará si mysqlnd_ms_set_qos() establece la calidad del servicio a consistencia final y habilita el uso de la caché. El uso de la caché se deshabilita solicitando niveles de consistencia superiores, por ejemplo, consistencia de sesión (lectura de sus datos). Una vez que la calidad del servicio ha vuelto a consistencia final, la caché se podrá usar de nuevo.

Si la caché está habilitada para sentencias de solo lectura, PECL/mysqlnd_ms podrá inyectar sugerencias SQL para controlar la caché mediante PECL/mysqlnd_qc. Se puede modificar la sentencia SQL si se obtiene de la aplicación. Se supone que los tratamientos de SQL subsiguientes ignorarán las sugerencias SQL. Una sugerencia SQL es un comentario SQL. Los comentarios no deben ser ignorados, por ejemplo, por el servidor de la base de datos.

El TTL de una entrada de la caché se calcula en función de cada sentencia. Las aplicaciones pueden establecer un máximo de edad para los datos que quieren recuperar mediante mysqlnd_ms_set_qos(). La edad establece un límite superior aproximado de los segundos que los datos devueltos pueden demorarse con respecto al maestro.

La siguietne lógica se utiliza para calcular el TTL real si la caché está habilitada. La lógica toma en cuenta la demora del esclavo aproximada para elegit un TTL. Si, por ejemplo, hay dos esclavos que se retrasan 5 y 10 y la edad máxima permitida es 60 segundos, el TTL se establece a 50 segundos. Observe que el establecimiento de la edad no es más que una aproximación.

  • Se comprueba si la sentencia es de solo lectura. Si no lo es, no se almacenará en caché.
  • Si la caché está habilitada, se comprueba la demora de todos los esclavos configurados. Se establecen las conexiones esclavas si no existieran hasta ahora y se utilizan conexiones retardadas.
  • Se envía la sentencia SHOW SLAVE STATUS a todos los esclavos. No se espera a que el primer esclavo replique antes de enviarla al segundo esclavo. Los clientes a menudo esperan bastante tiempo para las réplicas, por lo que se envían todas las peticiones de una vez antes obtenerlas en un segudo escenario.
  • Se itera sobre todos los esclavos. Para cada esclavo se espera su réplica. No se inicia la comprobación de otro esclavo antes de que el esclavo actual haya replicado. Se comprueba si Slave_IO_Running=Yes y Slave_SQL_Running=Yes. Si ambas condiciones son verdaderas, se obtiene el valor de Seconds_Behind_Master. En caso de cualquier error o de que las condiciones fallen, se establece un error en la conexión esclava. Se salta cualquier conexión esclava para el resto del filtrado de conexiones.
  • Se busca el valor máximo de Seconds_Behind_Master de todos los esclavos que hayan pasado las condiciones previas. Se resta el valor de la edad máxima de mysqlnd_ms_set_qos() proporcionada por el usuario. Se utiliza el resultado como un TTL.
  • El filtrado puede ordenar todos los esclavos. Si se hace, se usa la edad máxima como TTL, ya que la demora máxima encontrada es igual a cero. Es perfectamente válido ordenar todos los esclavos. En adelante, depende de filtro subsiguiente decidir qué hacer. El filtro de equilibrado de carga interno eligirá al maestro.
  • Se inyectan las sugerencias SQL apropiadas para habilitar el almacenamiento en caché por patre de PECL/mysqlnd_qc.
  • Se procede con el filtrado de conexiones, p.ej., se aplican las reglas del equilibrado de carga para escoger un esclavo.
  • PHP carga PECL/mysqlnd_qc después de PECL/mysqlnd_ms. Así, verá todas las modificaciones de consultas hechas por PECL/mysqlnd_ms y almacenará en caché la consulta, si se le ordenó hacerlo.

El algoritmo puede parecer costoso. SHOW SLAVE STATUS es una operación muy rápida. Dado un número suficiente de peticiones y de usos de la caché por segundo, el coste de comprobar la demora de los esclavos puede superar fácilmente el coste de la decisiones de la caché.

Las sugerencias sobre un algoritmo mejor siempre son bienvenidas.


Clústeres admitidos

Cualquier aplicación que utilice cualquier tipo de clúster MySQL tiene que enfrentarse con las mismas tareas:

  • Identificar los nodos que pueden ejecutar una sentencia dada con el nivel de servicio requerido
  • Equilibrar la carga de peticiones dentro de la lista de candidatos
  • Usar la tolerancia a fallos automática dentro de los candidatos, si fuera necesario

El complemento está optimizado para realizar estas tareas en el contexto de un clúster de replicación MySQL asíncrono clásico que consiste en un único maestro y varios esclavos (copiar primaria). Al utilizar la replicación MySQL asíncrona clásica todas las tareas enumeradas arriba deben ser controladas en el lado del cliente.

Otros tipos de clústeres MySQL pueden cluster may have lower requirements on the application side. Po ejemplo, si todos los nodos del clúster pueden responder a peticiones de lectura y de escritura, no es necesario que se realice la división de lectura-escritura (multi-maestro, todos actualizan). Si todos los nodos del clúster son sincrónicos, proporcionarán autmáticamente la mayor calidad de servcio posible, lo que se hace eligiendo un nodo más sencillo. En este caso, el complemento puede servir a la aplicación después de una reconfiguración para deshabilitar ciertas características, como la división de lectura-escritura interna.

Nota: El enfoque de la documentación

El enfoque de la documentación describe el uso del complemento con los clústeres de replicación MySQL asíncronos clásicos (copia primaria). El soporte para este tipo de clústeres ha sido el objetivo de desarrollo original. El uso de otros clústeres se describe brevemente abajo. Por favor, observe que aún está en desarrollo.

Copia primaria (Replicación de MySQL)

Este es el caso de uso primario del complemento. Siga las indicaciones dadas en la descripción de cada característica.

  • Configurar un maestro y uno o más esclavos. Los detalles de configuraicón del servidor se dan en la sección de configuración.
  • Utilizar la política de equilibrado de carga aleatorio junto con la bandera sticky.
  • Si no se planea usar las llamadas a la API de niveles de servicio, añada la bandera master on write.
  • Por favor, concienciese de las propiedades de la tolerancia de fallos automática antes de añadir una directiva failover.
  • Considere el uso de trx_stickiness para ejecutar transacciones solamente en el primario. Lea cuidadosamente cómo funciona antes de confiar en él.

Ejemplo #1 Habilitar el complemento (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini

Ejemplo #2 Configuración básica del complemento (mysqlnd_ms_plugin.ini) para la Replicación de MySQL

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
    },
    "slave": {
      "slave_0": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_1": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "random": {
        "sticky": "1"
      }
    }
  }
}

Copia primaria con multiprimarios (MMM - MySQL Multi Master)

La Replicación de MySQL permite crear topologías de clústeres con múltiples maestros (primarios). Los conflictos escritura-escritura no los maneja el sistema de replicación. No es una configuración de actualización en cualquier sitio. Por tanto, los datos deben ser particionados manualmente y los clientes deben ser redirigidos de acuerdo a las reglas de particionamiento. La configuración recomendada es igual a la de fragmentación de más abajo.

Fragmentación manual, posiblemente combinada con copia primaria y múltiples primarios

Use sugerencias SQL y el filtro de grupos de nodos para clústeres que usen particionamiento de datos pero que dejen la redirección de consultas al cliente. La configuración del ejemplo muestra una configuración multimaestro con dos fragmentos.

Ejemplo #3 Múltiples primarios - multimaestro (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1

Ejemplo #4 Copia primaria con múltiples primarios y particionamiento

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
      "master_2": {
        "host": "192.168.2.27",
        "socket": "3306"
      }
    },
    "slave": {
      "slave_1": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "node_groups": {
        "Partition_A" : {
          "master": ["master_1"],
          "slave": ["slave_1"]
        },
        "Partition_B" : {
          "master": ["master_2"],
          "slave": ["slave_2"]
        }
      },
      "roundrobin": []
    }
  }
}

El complemento también se puede usar con una colección suelta de fragmentos no relacionados. Para tal clúster, configure solamente maestros y deshabilite la división de lectura-escritura. Los nodos de tal clúster son llamados maestros en la configuración del complemento ya que aceptan tanto lecturas como escrituras para su particionamiento.

Usar clústeres de actualización en cualquier sitio sincrónicos tales como el Clúster de MySQL

El Clúster de MySQL es una solución de clúster sincrónico. Todos los nodos del clúster aceptan peticiones de lectura y escritura. En el contexto del complemento, todos los nodos son considerados maestros.

Use únicamente el equilibrado de carga y la tolerancia a fallos.

  • Deshabilite la división interna de lectura-esritura.
  • Configure maestros solamente.
  • Considere la estrategia del equilibrado de carga aleatorio una vez, que es la predeterminada del complemento. Si se usa esta estrategia, solamente se configuran los maestros y no se usan sugerencias SQL para forzar el uso de un nodo en particular, no ocurriran intercambios de conexiones durante una petición web. Por tanto, no se requiere un trato especial para las transacciones. El complemento eligirá un maestro al inicio del script de PHP y lo usará hasta que finalice dicho script.
  • No establezca la calidad de servicio. Todos los nodos tienen todos los datos. Esto proporciona automáticamente la mejor calidad de servicio posible (consistencia fuerte).
  • No habilite la inyección de transacciones global en el lado del cliente. Ni es necesario para ayudar con la tolerancia a fallos del lado del servidor ni para asistir al filtro de calidad de servicio a elegir un nodo apropiado.

Deshabilitar la división interna de lectura-escritura

  • Establezca mysqlnd_ms.disable_rw_split=1
  • No use sugerencias SQL para forzar el uso de esclavos

Configure únicamente maestros.

  • Establezca mysqlnd_ms.multi_master=1.
  • No configure ningún esclavo.
  • Establezca failover=loop_before_master en el fichero de configuración del complemento para evitar advertencias sobre listas de esclavos vacías y para hacer que la lógica de tolerancia a fallos itere sobre todos los maestros configurados antes de emitir un error. Observe las advetencias sobre la tolerancia a fallos automática dadas en las secciones anteriores.

Ejemplo #5 Múltiples primarios - multimaestro (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1
mysqlnd_ms.disable_rw_split=1

Ejemplo #6 Clúster de actualización en cualquier sitio sincrónico

"myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      },
      "master_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "slave": {
    },
    "filters": {
      "roundrobin": {
      }
    },
    "failover": {
      "strategy": "loop_before_master",
      "remember_failed": true
    }
  }
}

Si se ejecuta un clúster de actualización en cualquier sitio que no tenga particionamiento interno para evitar hot spots y altas tasas de colisiones, considere usar el filtro de grupos de nodos para seguir las actualizaciones en una tabla de acceso frecuente en uno de los nodos. Esto podría ayudar a reducir las tasas de colisión y proporcionar así una mejora del rendimiento.


Transacciones XA/distribuidas

Nota: Requerimientos de versión

Las funciones relacionadas con XA han sido introducidas en la versión 1.6.0-alpha de PECL/mysqlnd_ms.

Nota: Se buscan los primeros adaptadores

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción, aunque las primeras pruebas indican una calidad razonable.

Por favor, contacte con el equipo de desarrollo si está interesado en esta característica. Estamos buscando comentarios de la vida real para completar esta característica.

Abajo se muestra una lista de algunas restricciones de la característica.

  • La característica aún no es compatible con el soporte para MySQL Fabric. Aún es pronto para resolver esta limitación.

    El identificador de transacción de XA actualmente está restrigido a números. Esta limitación se resolverá a petición, es una simplificación empleada durante la implementación inicial.

Nota: Restricciones del servidor de MySQL

El soporte para XA mediante el servidor de MySQL tiene algunas restricciones. Aún más, el registro binario de servidores podría podría carecer de los cambios realizados por transacciones XS en caso de ciertos errores. Véase el manual de MySQL para más detalles.

Las transacciones XA/distribuidas pueden generar múltiples servidores de MySQL. Por lo tanto, podrían parecer la herramienta perfecta para clústeres de MySQL framentados, por ejemplo, los clústeres administrados por MySQL Fabric. PECL/mysqlnd_ms oculta la mayoría de los comandos de SQL para controlar las transacciones XA y realiza tareas administrativas automáticas en caso de error, proveyendo así al usuario de una API completa. Los usuarios deberían configurar el complemento cuidadosamente y ser conscientes de las restricciones del servidor antes de utilizar la característica.

Ejemplo #1 Patrón general para transacciones XA

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");

/* BEGIN */
mysqlnd_ms_xa_begin($mysqli, 1 /* xa id */);

/* ejecutar consultas en varios servidores */
$mysqli->query("UPDATE some_table SET col_a = 1");
...

/* COMMIT */
mysqlnd_ms_xa_commit($link, 1);
?>

Las transacciones XA emplean el protocolo de consignación de dos fases. El protocolo de consignación de dos fases es un protocolo de bloqueo. Durante la primera fase, los servidores participantes comienzan una transacción y el cliente lleva a cabo su trabajo. A esta fase le sigue una segunda fase de votación. Durante la votación, los servidores hacen primero una promesa firme de que están listos para consignar el trabajo incluso en caso de fallos inesperados propios. Si un servidor falla en esta fase, aún recordará la transacción abortada después de recobrarse y esperar a que el cliente decida si será consignada o revertida.

Si un cliente que ha iniciado una transacción global falla después de que todos los servidores participantes dieron su promesa de estar listos para consignar, dichos servidores deben esperar a una decisión. A los servidores no se les permite decidir unilateralmente sobre la transacción.

Si un cliente que falla o se desconecta de un participante, un servidor que falla u ocurre un error de servidor durante la primera fase del protocolo no es crítico. En la mayoría de los casos, el servidor se olvidará de la transacción XA y su trabajo será revertirla. Además, el complemento intenta alcanzar tantos participantes como pueda para ordenar al servidor a revertir el trabajo inmediatamente. No es posible deshabilitar esta reversión implícita llevada a cabo por PECL/mysqlnd_ms en caso de error durante la primera fase del protocolo. Esta decisión del diseño se ha hecho para mantener la implementación simple.

Un error durante la segunda fase del protocolo de consignación puede desembocar en una situación más grave. Los servidores no olvidarán en ningún caso las transacciones preparadas no finalizadas. El complemento no intentará resolver estos casos inmediatamente, sino que esperará a la recolección de basura opcional en sengundo plano para asegurar el progreso del protocolo de consignación. Se asume que una solución tomará bastante tiempo ya que podría incluir la espera de la recuperación de un fallo de un servidor participante. Este intervalo de tiempo podría ser mayor que el esperado por un desarrollador y un usuario final cuando se intenta consignar una transacción global con mysqlnd_ms_xa_commit(). Por tanto, que la función devuelva con la transacción global sin finalizar aún requiere atención. Se ha de advertir en este punto que aún no está claro si la transacción global será consignada o revertida más adelante.

Los errores durante la segunda fase se pueden ignorar, manejándolos por uno mismo o resolviéndolos la lógica de la recolección de basura interna. No se recomineda ignorarlos debido a que se podrían experimentar transacciones globales no finalizadas en los servidores que bloqueen recursos virtualmente de forma indefinida. El manejo de los errores requiere conocer los participantes, comprobar su estado y enviarles los conmandos SQL apropiados. No existe una llamada a la API de usuario que exponga esta información. Se tendrá que configurar un almacén de estado y hacer que el complemento registre sus acciones en él para recibir la información deseada.

Véase la guía rápida y los ajustes del fichero de configuración del complemento relacionados para un ejemplo de cómo configurar un estado. Además de configurar un almacén de estados, se han de crear algunas tablas SQL. Las definiciones de las tablas se dan en la descripción de los ajustes de configuración del complemento.

Establecer y configurar un almacén de estados también es una precondición para utilizar la recolección de basura interna para transacciones XA que fallen durante la segunda fase de consignación. Registrar información sobre transacciones XA en curso es una tarea extra inevitable. La tarea extra consiste en actualizar el almacén de estados después de cada operación que cambie el estado de una transacción global en sí (iniciada, consignada, revertida, errores y abortos), la adición de participantes (host, opcionalmente el usuario y contraseña requeridos para conectarse) y cualquier cambio del estado de un participante. Observar que, dependiendo de la configuración y las politicas de seguridad, estos registros podrían considerarse delicados. Por tanto, se recomienda restringir el acceso al almacén de estados. A menos que el almancén de estados mismo esté sobrecargado, la escritura de la información de estado podría contribuir notablemente al tiempo de ejecución, pero debería ser por lo demás solamente un factor menor.

Es posible que el esfuerzo que toma la implementación de rutinas propias para manejar transacciones XA que fallen durante la segunda fase de consignación exceda los beneficios del uso de la característica de XA de PECL/mysqlnd_ms desde un comienzo. Por tanto, el manual se centra solamente en el empleo de la recolección de basura interna.

Se puede provocar la recolección de basura manual o automáticamente en sengundo plano. Se puede llamar a mysqlnd_ms_xa_gc() inmediatamente después de que una consignación falle un intento de resolver cualquier transacción global fallida aunque aún abierta tan pronto como sea posible. También se podría decidir deshabilitar la recolección de basura automática en segundo plano, implementar un conjunto de reglas propio para invocar a la recolección de basura interna y ejecutarla cuando se desee.

Por omisión, el complemento iniciará la recolección de basura con una cierta probabilidad en las extensiones del método interno RSHUTDOWN. La petición de apagado es invocada después de finalizar el script. La realización de la recolección de basura está determinara por el cálculo de un valor aleatorio en el rango 1...1000 y comparándolo con el ajuste de configuracion probability (predeterminado: 5). Si el ajuste es mayor o igual que el valor aleatorio, se llevará a cabo la recolección de basura.

Una vez iniciada, la recolección de basura actúa sobre hasta max_transactions_per_run (predeterminado: 100) transacciones globales registradas. Los registros incluyen transaccines XA finalizadas con éxito y también no finalizadas. Los registros para transacciones exitosas se eliminan y las no finalizadas se intentan resolver. No hay estadísticas que ayuden a encontrar el equilibrio exacto entre mantener una ejecución corta de la recolección de basura limitando el número de transacciones consideradas por ejecución y prevenir que la recolección de basura se quede retrasada, resultando en muchos registros.

Por cada transacción XA fallida, la recolección de basura realiza max_retries (predeterminado: 5) intentos para finalizarla. Después de esto, PECL/mysqlnd_ms se rinde. Hay dos posibles razones para esto. O un servidor participante falla y ya no está accesible dentro de max_retries invocaciones de la recolección de basura, o hay una situación que la recolección de basura interna no puede manejar. Problemente, lo último sería considerado como un error. Sin embargo, se puede forzar manualmente más ejecuciones de recolección de basura llamando a mysqlnd_ms_xa_gc() con el parámetro apropiado establecido. Si incluso la ejecución de esta función no resuelve la situación, el problema debe resolverse mediante un operador.

La función mysqlnd_ms_get_stats() proporciona algunas estadísticas sobre cuántas transacciones XA han sido iniciadas, consignadas, han fallado o han sido revertidas.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución
  • Fichero de configuración del complemento (>=1.1.x)


Requerimientos

PHP 5.3.6 o posterior. Alguna funcionalidad avanzada requiere PHP 5.4.0 o posterior.

El complemento de replicación y equilibrado de carga mysqlnd_ms admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP disponibles (mysqli, mysql, PDO_MYSQL). La extensión de MySQL para PHP debe ser configurada para que utilice mysqlnd para poder usar el complemento mysqlnd_ms para mysqlnd.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mysqlnd_ms

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de mysqlnd_ms
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

mysqlnd_ms.enable integer

Habilita o deshabilita el complemento. Si se deshabilita, la extensión no se conectará a mysqlnd para delegar las llamadas internas a la API en C mysqlnd.

mysqlnd_ms.force_config_usage integer

Si está habilitado, el complemento comprueba si el el valor del parámetro 'host' (servidor) de cualquier intento de conexión MySQL coincide con un nombre de sección del fichero de configuración del complemento. En caso contrario, el intento de conexión es bloqueado.

Este ajuste no es solamente útil para restringir PHP a ciertos servidores, sino también para depurar problemas con el fichero de configuración. La validez de este se comprueba en dos etapas diferentes. La primera comprobación se realiza cuando PHP comienza a manejar una petición web. En este punto, el complemento lee y decodifica el fichero de configuración. Los errores lanzados en esta primera etapa en el ciclo de vida de las extensiones podrían no ser mostrados apropiadamente al usuario. Por tanto, el complemento almacena en búfer los errores, si los hubiera, y los muestra además al establecer una conexión a MySQL. Por omisión, un error de arranque almacenado en búfer emitira un error de tipo E_WARNING. Si force_config_usage está habilitado, el tipo de error usado es E_RECOVERABLE_ERROR.

Por favor, véanse también las notas de depuración del fichero de configuración.

mysqlnd_ms.ini_file string

Fichero de configuración específico del complemento. Este ajuste ha sido renombrado a mysqlnd_ms.config_file en la versión 1.4.0.

mysqlnd_ms.config_file string

Fichero de configuración específico del complemento. Este ajuste reemplaza a mysqlnd_ms.ini_file desde la versión 1.4.0.

mysqlnd_ms.collect_statistics integer

Habilita o deshabilita la recopilación de estadísticas. La recopilación de estadísticas está deshabilita por defecto por razones de rendimiento. Las estadísticas son devueltas por la función mysqlnd_ms_get_stats().

mysqlnd_ms.multi_master integer

Habilita o deshabilita el soporte de sistemas de replicación multimaestro. Véanse también los clústeres admintidos.

mysqlnd_ms.disable_rw_split integer

Habilita o deshabilita la división de lectura-escritura interna.

Controla si la funcionalidad de equilibrado de carga y de conexiones retardadas se pueden usar independientemente de la división de lectura-escritura. Si la división de lectura-escritura está deshabilitada, sólo los servidores de la lista de maestros serán usados para la ejecución de sentencias. Todos los servidores esclavos configurados serán ignorados.

La sugerencia SQL MYSQLND_MS_USE_SLAVE no será reconocida. Si se encuentra, la sentencia será redirigida al maestro.

La deshabilitación de la división de lectura-escritura impacta sobre el valor devuelto de mysqlnd_ms_query_is_select(). La función ya no propondrá la ejecución de consultas en servidores esclavos.

Nota: Múltiples servidores maestros

Establecer mysqlnd_ms.multi_master=1 permite al complemento usar múltiples servidores maestros, en lugar de sólo el primer servidor maestro de la lista de maestros.

Véanse también los clústeres admitidos.


Fichero de configuración del complemento (>=1.1.x)

La siguiente documentación se aplica a PECL/mysqlnd_ms >= 1.1.0-beta. No es válida para versiones anteriores. Para la documentación que cubre versiones anterires, ver la documentación de configuración para mysqlnd_ms 1.0.x y anteriores.

Introdución

Nota: Registro de cambios: Característica añadida en PECL/mysqlnd_ms 1.1.0-beta

La descripción de abajo se aplica a PECL/mysqlnd_ms >= 1.1.0-beta. No es válida para versiones anteriores.

El complemento usa su propio fichero de configuración. Este guarda información sobre el servidor maestro de replicación MySQL, los servidores esclavos de replicación MySQL, la política de elección (equilibrado de carga), la estrategia de tolerancia a fallos, y el uso de conexiones retardadas.

El complemento carga su fichero de configuración al comienzo de una petición web. Entonces, es almacenado en la memoria caché y utilizado durante el resto de la petición web. De esta forma, no hay necesidad de reiniciar PHP después de utilizar el fichero de configuración. Los cambios de éste estarán activos casi instantáneamente.

La directiva de configuración de PHP mysqlnd_ms.config_file se utiliza para establecer el fichero de configuración del complemento. Observe que dicha direcitiva no puede ser evaluada para cada petición web. Por lo tanto, el cambio del nombre del fichero de configuración del complemento o de su ubicación puede requerir el reinicio de PHP. Sin embargo, no es necesario tal reinicio para leer los cambios si se actualiza un fichero de configuración del complemento ya existente.

El uso y el análisis de JSON es eficiente, ya que con JSON es más sencillo expresar estructuras de datos jerárquicas que con el formato estándar de php.ini.

Ejemplo #1 Convertir un array de PHP (hash) al formato JSON

O alternativamente, un desarrollador puede preferir la sintaxis de arrays por estar más familiarizado con ella. Este ejemplo demuestra cómo un desarrolador podría convertir un array de PHP a JSON.

<?php
$config = array(
  "myapp" => array(
    "master" => array(
      "master_0" => array(
        "host"   => "localhost",
        "socket" => "/tmp/mysql.sock",
      ),
    ),
    "slave" => array(),
  ),
);

file_put_contents("mysqlnd_ms.ini", json_encode($config, JSON_PRETTY_PRINT));
printf("mysqlnd_ms.ini file created...\n");
printf("Dumping file contents...\n");
printf("%s\n", str_repeat("-", 80));
echo file_get_contents("mysqlnd_ms.ini");
printf("\n%s\n", str_repeat("-", 80));
?>

El resultado del ejemplo sería:

mysqlnd_ms.ini file created...
Dumping file contents...
--------------------------------------------------------------------------------
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": [

        ]
    }
}
--------------------------------------------------------------------------------

Un fichero de configuración del complemento consta de una o más secciones. Éstas están representadas por las propiedades de nivel superior del objeto codificado en el fichero JSON. Las secciones también podrían llamarse nombres de configuración.

Las aplicciones hacen referencia a las secciones por su nombre. Las aplicaciones usan los nombres de las secciones como el parámetro 'host' (servidor) de los distintos métodos de conexión de las extensiones mysqli, mysql y PDO_MYSQL. Durante la conexión, el complemento de mysqlnd compara el nombre del equipo anfitrión con todos los nombres de las secciones del fichero de configuración del complemento. Si el nombre del equipo anfitrión y el nombre de la sección coinciden, el complemento cargará la configuración de esa sección.

Ejemplo #2 Ejemplo del uso de nombres de sección

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27"
            },
            "slave_1": {
                "host": "192.168.2.27",
                "port": 3306
            }
        }
    },
    "localhost": {
        "master": [
            {
                "host": "localhost",
                "socket": "\/path\/to\/mysql.sock"
            }
        ],
        "slave": [
            {
                "host": "192.168.3.24",
                "port": "3305"
            },
            {
                "host": "192.168.3.65",
                "port": "3309"
            }
        ]
    }
}
<?php
/* Todas las conexiones siguientes tendrán equilibrado de carga */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
$pdo = new PDO('mysql:host=myapp;dbname=base_datos', 'nombre_usuario', 'contraseña');
$mysql = mysql_connect("myapp", "nombre_usuario", "contraseña");

$mysqli = new mysqli("localhost", "nombre_usuario", "contraseña", "base_datos");
?>

Los nombres de sección son cadenas de texto. Es válido usar nombres de sección como 192.168.2.1, 127.0.0.1 o localhost. Si, por ejemplo, una aplicación se conexta a localhost y existe una sección de configuración del complemento llamada localhost, la semántica de la operación de conexión se cambia. La aplicación ya no usará únicamente el servidor MySQL que se ejecuta en el equipo anfitrión localhost, sino que el complemento iniciará el equilibrado de carga de las consultas MySQL siguiendo las reglas de la sección de configuración localhost. De esta manera se puede realizar el equilibrado de carga de consultas desde una aplicación sin cambiar el código fuente de la misma. Recuerde que tal configuración puede no contribuir a la legibilidad global del código fuente de las aplicaciones. El uso de nombres de sección combinado con nombres de equipos anfitriones debería ser el último recurso.

Cada sección de configuración contiene, como mínimo, una lista de sevidores maestros y una lista de servidores esclavos. La lista de maestros se configura con la palabra clave master, mientras que la lista de esclavos se configura con la palabra clave slave. El no proporcionar una lista de esclavos resultará en un error fatal de nivel E_ERROR, aunque la lista de esclavos puede estar vacía. Es posible prohibir esclavos. Sin embargo, esto solo se recomienda para clústeres sincrónicos. Véanse también los clústeres admitidos. La parte principal de esta documentación se centra en el uso de clústeres de replicación MySQL asincrónicos.

Las listas de servidores maestros y esclavos se pueden indexar opcionalmente mediante nombres simbólicos para los servidores que describen. De forma alternativa, se puede utlizar un array con descripciones de los servidores esclavos y maestros.

Ejemplo #3 Lista de esclavos anónimos

"slave": [
    {
        "host": "192.168.3.24",
        "port": "3305"
    },
    {
        "host": "192.168.3.65",
        "port": "3309"
    }
]

Una lista de servidores anónimos está codificada por el tipo array de JSON. Opcionalmente, se pueden usar los nombres simbólicos para indexar los servidores esclavos o maestros de una lista de servidores, realizándolo mediante el tipo objeto de JSON.

Ejemplo #4 Lista de maestros usando nombres simbólicos

"master": {
    "master_0": {
        "host": "localhost"
    }
}

Se recomienda indexar las listas de servidores con nombres de servidores simbólicos. Los sobrenombres se mostrarán en los mensajes de error.

mysqlnd_ms preserva el orden de los servidores y lo toma en cuenta. Si, por ejemplo, se configura una estrategia de equilibrado de carga de rotación, la primera sentencia SELECT será ejecutada en el esclavo que aparece en primer lugar en la lista de servidores esclavos.

Un servidor configurado puede ser descrito con host, port, socket, db, user, password y connect_flags. Es obligatorio establecer el equipo anfitrión del servidor de la base de datos mediante la palabra clave host. Todos los demás ajustes son opcionales.

Ejemplo #5 Palabras clave para configurar un servidor

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket",
                "db": "database_resp_schema",
                "user": "user",
                "password": "password",
                "connect_flags": 0
            }
        },
        "slave": {
            "slave_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket"
            }
        }
    }
}

Si se omite un ajuste, el complemento usará el valor proporcionado por la llamada a la API hecha por el usuario utilizada para abrir la conexión. Véase el ejemplo de uso de nombres de sección de arriba.

El formato del fichero de configuración ha sido cambiado en la versión 1.1.0-beta para tener en cuenta los filtros encadencados. Los filtros son los responsables de filtrar la lista de servidores configurados para identificar un servidor para que ejecute una sentencia dada. Los filtros se configuran con la palabra clave filter. Éstos son ejecutados por mysqlnd_ms en el orden en que aparecen. La definción de filtros es opcional. Una sección de configuración del fichero de configuración del complemento no necesita tener una entrada filters.

Los filtros reemplazan al ajuste pick[] de versiones anteriores. Los nuevos filtros random y roundrobin proporcionan la misma funcionalidad.

Ejemplo #6 El nuevo filtro roundrobin, funcionalidad antigua

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

La función mysqlnd_ms_set_user_pick_server() ha sido eliminada. El establecimiento de una llamada de retorno ahora se realiza con el filtro user. Algunos filtros aceptan parámetros. El filtro user requiere y acepta el parámetro obligatorio callback para establecer la llamada de retorno que antes se establecía a través de la función mysqlnd_ms_set_user_pick_server().

Ejemplo #7 El filtro user reemplaza a mysqlnd_ms_set_user_pick_server()

"filters": {
    "user": {
        "callback": "pick_server"
    }
}

La validez del fichero de configuración se realiza tanto al leerlo como cuando más tarde se establece una conexión. El fichero de configuración se lee durante la petición de arranque de PHP. En esta primera etapa, una extensión de PHP podría no mostrar mensajes de error apropiadamente. En el peor de los casos, no se mostrará ningún error y un intento de conexión fallará sin un mensaje de error adecuado. Este problema ha sido solventado en la versión 1.5.0.

Ejemplo #8 Mensaje de error común en caso de problemas con el fichero de configuración (hasta la versión 1.5.0)

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

El resultado del ejemplo sería:

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code

Warning: mysqli::mysqli(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in Command line code on line 1

Warning: mysqli::query(): Couldn't fetch mysqli in Command line code on line 1

Fatal error: Call to a member function fetch_assoc() on a non-object in Command line code on line 1

Desde la versión 1.5.0, los errores al arrancar son además almacenados en búfer y emitidos cuando se realiza un intento de conexión. Use la directiva de configuración mysqlnd_ms.force_config_usage para establecer el tipo de error usado para mostrar errores almacenados en búfer. Por omisión, se emitirá un error de tipo E_WARNING.

Ejemplo #9 Validación mejorada del fichero de configuración desde 1.5.0

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

El resultado del ejemplo sería:

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code on line 1

Puede ser útil establecer mysqlnd_ms.force_config_usage = 1 al depurar errores potenciales del fichero de configuración. Esto no solo convertirá el tipo de errores del arranque almacenados en búfer a E_RECOVERABLE_ERROR, sino que también ayudará a detectar nombres de seccones mal escritas.

Ejemplo #10 Error posiblemente más preciso debido a mysqlnd_ms.force_config_usage=1

mysqlnd_ms.force_config_usage=1
<?php
$mysqli = new mysqli("invalid_section", "username", "password", "database");
?>

El resultado del ejemplo sería:

Warning: mysqli::mysqli(): (mysqlnd_ms) Exclusive usage of configuration enforced but did not find the correct INI file section (invalid_section) in Command line code on line 1 line 1

Directivas de configuración

He aquí una breve explicación de las directivas de configuración que se pueden usar.

master array o object

Lista de los servidores maestros de replicación MySQL. La lista es del tipo array de JSON, para declarar una lista anónima de servidores, o del tipo objeto de JSON. Por favor, véanse los ejemplos de arriba.

Es obligatorio establecer al menos un servidor maestro. El complemento emitirá un error de tipo E_ERROR si el usuario no ha proporcionado una lista de servidores maestros en una sección de configuración. El error fatal puede ser (mysqlnd_ms) Section [master] doesn't exist for host [name_of_a_config_section] in %s on line %d ((mysqlnd_ms) La sección [master] no existe para el equipo anfitrión [nombre_de_una_sección_de_configurción] en %s en la línea %d).

Un servidor se describe con las palabras clave host, port, socket, db, user, password y connect_flags. Es obligatorio proporcionar al menos un valor para host. Si no se proporcionan cualesquiera de los otros valores, se tomarán de la llamada de conexión del usuario a la API, véase también: ejemplo de uso de nombres de sección.

Tabla de las palabras clave de configuración del servidor.

Palabra clave Descripción Versión
host

El equipo anfitrión servidor de las bases de datos. Es un ajuste obligatorio. Si no se proporcina causará un error de tipo E_RECOVERABLE_ERROR cuando el complemento intente conectarse al servidor. El mensaje de error puede ser (mysqlnd_ms) Cannot find [host] in [%s] section in config in %s on line %d ((mysqlnd_ms) No se pudo encontrar [host] en la sección [%s] de configuración en %s en la línea %d).

Desde 1.1.0.
port

El puerto TCP/IP del servidor de las bases de datos.

Desde 1.1.0.
socket

El socket de dominio Unix del servidor de las bases de datos.

Desde 1.1.0.
db

La base de datos (esquema).

Desde 1.1.0.
user

El usuario de la base de datos MySQL.

Desde 1.1.0.
password

La constraseña del usuario de la base de datos MySQL.

Desde 1.1.0.
connect_flags

Banderas de conexión.

Desde 1.1.0.

El complemento únicamente admite el uso de un servidor maestro. Existe un ajuste experimental para habilitar el soporte de múltiples maestros. Los detalles no están documentados. El ajuste sólo se menciona para desarrollo.

slave array o object

Lista de uno o más servidores esclavos de replicación MySQL. La sintaxis es idéntica a la de lo servidores maestros, véase master más arriba para más detalles.

El complemento admite el uso de uno o más servidores esclavos.

Es obligatorio establecer una lista de servidores esclavos. El complemento notificará un error de tipo E_ERROR si no se proporciona slave para una sección de configuración. El mensaje de error fatal puede ser (mysqlnd_ms) Section [slave] doesn't exist for host [%s] in %s on line %d ((mysqlnd_ms) La sección [slave] no existe para el equipo anfitrión [%s] en %s en la línea %d). Observe que es válido usar una lista de servidores esclavos vacía. Este error ha sido introducido para evitar que no se establezcan esclavos de forma accidental si se olvida el ajuste slave. Es posible configurar un único maestro si se utiliza una lista de servidores esclavos vacía.

Si se configura una lista de esclavos vacía y se intenta ejecutar una sentencia en un esclavo, el complemento podría emitir una advertencia como (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. ((mysqlnd_ms) No se pudo encontrar la conexión esclava apropiada. 0 esclavos de donde elegir) durante la ejecución de la sentencia. Es posible que le siga otra advertencia, como (mysqlnd_ms) No connection selected by the last filter ((mysqlnd_ms) El último filtro no seleccionó ninguna conexión).

global_transaction_id_injection array o object

La configuración del identificador de transacciones global está relacionada tanto con el uso de la característica del ID de transacciones global interno del servidor como con la emulación en el lado del cliente.

Palabra clave Descripción Versión
fetch_last_gtid

Senetencia SQL para acceder al último identificador de transaccioens global. La sentencia SQL se ejecuta si el complemento necesita conocer el identificador de transacciones global más reciente. Este puede ser el caso cuando, por ejemplo, se comprueba el estado de un esclavo de Replicación MySQL. También se usa con mysqlnd_ms_get_last_gtid().

Desde 1.2.0.
check_for_gtid

Sentencia SQL para comprobar si una réplica ha replicado todas las transacciones hasta, e incluyendo a, la buscada. La sentencia SQL se ejecuta cuando se buscan réplicas que pueden ofrecer un nivel mayor de consistencia que la consistencia final. La sentencia puede contener el parámetro de sustitución #GTID, el cual es reemplazado con el identificador de transacciones global buscado por el complemento. Por favor, revise los ejemplos de la guía rápica.

Desde 1.2.0.
report_errors

Si se ha de emitir un error de tipo 'warning' si ocurriera un problema mientras se ejecuta cualquiera de las sentencias SQL configuradas.

Desde 1.2.0.
on_commit

(Solamente para la emulación del ID de transacciones global en el lado del cliente). Sentencia SQL a ejecutar cuando una transacción finaliza y acutaliza el número de secuencia del identificador de transacciones global en el maestro. Por favor, vea los ejemplo de la guía rápida.

Desde 1.2.0.
wait_for_gtid_timeout

Ordena al complemento que espere hasta wait_for_gtid_timeout segundos para que un esclavo se ponga al día cuando se busquen esclavos que puedan proporcionar la consistencia de sesión. Este ajuste limita el tiempo empleado en obtener el estados de los esclavos. Si dicha obtención toma mucho tiempo, el tiempo de espera total empleado puede exceder wait_for_gtid_timeout. El complemento llama a sleep(1) para dormir un segundo entre cada dos obtenciones.

El ajuste se puede usar junto con la emulación en el lado del cliente del complemento y la característica del identificador de transacciones global del lado del servidore de MySQL 5.6.

La espera de que un esclavo replique un GTID en particular necesario para la consistencia de sesión también signifiva estrangular el cliente. El estrangulamiento del cliente reduce indirectamente la carga de escrigura del maestro. A un sistema de replicación basado en copia primaria,, como la Replicación MySQL, se le da más tiempo para alcanzar un estado consistente. Esto puede ser útil, por ejemplo, para aumentar el número de copias de datos para consideraciones de alta disponibilidad, o para prevenir que el maestro sea sobrecargado.

Desde 1.4.0.
fabric object

Ajustes relacionados con MySQL Fabric. Si el complemento se usa junto con MySQL Fabric, el fichero de configuración del complemento no contendrá las listas de servidores de MySQL. En su lugar, el complemento preguntará a MySQL Fabric sobre qué listas de servidores usar para realizar cierta tarea.

Una configuración mínima del complemento para usar con MySQL Fabric contendrá una lista de uno o más hosts de MySQL Fabric que el complemento puede consultar. Si se configura más de un host de MySQL Fabric, el complemento usará una estrategia de rotación para elegir entre ellos. No está disponible ninguna otra estrategia actualmente.

Ejemplo #11 Configuración mínima del complemento para usar con MySQL Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Cada host de MySQL Fabric está descrito usando un objeto de JSON con los siguientes miembros.

Palabra clave Descripción Versión
host

Nombre del host de MySQL Fabric.

Desde 1.6.0.
port

El puerto TCP/IP en el que el host de MySQL Fabric escucha para llamadas de procedimientos remotos enviados por clientes como el complemento.

Desde 1.6.0.

El complemento utiliza flujos de PHP para comunicarse con MySQL Fabric a través de XML RPC sobre HTTP. Por omisión, no se establecen tiempos de espera para la comunicación en red. Así, el valor predeterminado del complemento es el tiempo de espera predeterminado del flujo de PHP. Dichos valores predeterminados están fuera del alcance del complemento.

Se puede establecer un tiempo de espera opcional para sobrescribir el predeterminado del flujo de PHP. Establecer el tiempo de espera en el fichero de configuración del complemento tiene el mismo efecto que establecer un tiempo de espera para la conexión HTTP del espacio de usuario de PHP establecida a través de flujos de PHP.

La unidad del valor del tiempo de espera de Fabric del complemento es el segundo. El rango de valores permitidos es de 0 a 65535. Este ajuste existe desde la versión 1.6.

Ejemplo #12 Tiempo de espera opcional para la comunicación con Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "timeout": 2
        }
    }
}

La adhesión de transacciones y la lógica de MySQL Fabric puden entrar en conflicto. La opción de adhesión deshabilita el cambio entre srevidores durante una transacción. Al usar Fabric y fragmentación, el usuario podría (erróneamente) iniciar una transacción local en un fragmento y luego intentar cambiar a un fragmento diferente usando mysqlnd_ms_fabric_select_shard() o mysqlnd_ms_fabric_select_global(). En este caso, el complemento no rechazará la petición de cambiar de servidor en mitad de una transacción, sino que permitirá al usuario cambiar a otro servidor independientemente de la configuración de adhesión de transacciones usada. Obviamente, es un error de usuario escribir tal código.

Si la adhesión de transacciones está habilitada y se obtiene un error de tipo advertencia al llamar a mysqlnd_ms_fabric_select_shard() o mysqlnd_ms_fabric_select_global(), estblezca la bandera booleana trx_warn_server_list_changes.

Ejemplo #13 Advertencias sobre la violación de límites de transacciones

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "trx_warn_serverlist_changes": 1
        },
        "trx_stickiness": "on"
    }
}
<?php
$enlace = new mysqli("myapp", "root", "", "test");
/*
  Para la demostración, la llamada posría fallar.
  Si falla o no, nos introduciremos en el estado
  necesario para el ejemplo.
*/
@mysqlnd_ms_fabric_select_global($enlace, 1);
$enlace->begin_transaction();
@$enlace->query("DROP TABLE IF EXISTS test");
/*
  ¡Cambiar de servidor/fragmento es un error debido a la
  transacción local abierta!
*/
mysqlnd_ms_select_global($enlace, 1);
?>

El resultado del ejemplo sería:

PHP Warning: mysqlnd_ms_fabric_select_global(): (mysqlnd_ms) Fabric server exchange in the middle of a transaction in %s on line %d

Por favor, considere la característica como experimental. Podrían cambiarse la sintaxis y la semántica.

filters object

Lista de filtros. Un filtro es el responsable de filtrar la lista de servidores disponibles que puedan ejecutar una setentcia dada. Los filtros se pueden encadenar. Los filtros random y roundrobin reemplazan a la directiva pick[] usada en versiones anteriores para seleccionar una política de equilibrado de carga. El filtro user reemplaza a la función mysqlnd_ms_set_user_pick_server().

Los filtros pueden aceptar parámetros para refinar sus acciones.

Si no está establecida una política de equilibrado de carga, el complemento asumirá el valor predeterminado random_once. La política random_once elige un servidor aleatorio al ejecutar la primera sentencia de solo lectura. Este servidor esclavo se usará para todas las sentencias de solo lectura hasta que finalice la ejecución del script de PHP. No se establece ninguna política de equilibrado de carga y, por lo tanto, toma lugar el valor predeterminado si ni random ni roundrobin son parte de la sección de configuración.

Si una cadena de filtros es configurada de modo que la salida de un filtro que no produzca más de un servidor sea usada como entrada para otro filtro al que se le debería proporcionar más de un servidor, el complemento podría emitir una advertencia sobre una conexión abierta. La advertencia podría ser: (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d ((mysqlnd_ms) Error al crear el filtro '%s' . No se ha creado aún el filtro múltiple '%s'. Detenido en %s en la línea %d). Además, se puede establecer un error de código 2000, el estado sql HY000, y un mensaje de error similar a la advertencia, sobre el gestor de conexión.

Ejemplo #14 Secuencia de filtros inválida

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin",
            "random"
        ]
    }
}
<?php
$enlace = new mysqli("myapp", "root", "", "test");
printf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error());
$enlace->query("SELECT 1 FROM DUAL");
?>

El resultado del ejemplo sería:

PHP Warning:  mysqli::mysqli(): (HY000/2000): (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping in filter_warning.php on line 1
[2000] (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping
PHP Warning:  mysqli::query(): Couldn't fetch mysqli in filter_warning.php on line 3

Filtro: random object

El filtro random introduce las políticas de equilibrado de carga "aleatoria" y "aleatoria una vez", establecidas a través de la directiva pick[] en versiones anteriores.

La política "aleatoria" eligirá un servidor aleatorio siempre que se vaya a ejecutar una sentencia de solo lectura. La estrategia "aleatoria una vez" elige un servidor esclavo aleatorio una vez y continuará usándolo para el resto de la petición web. "Aleatoria una vez" es la predeterminada, si el equilibrado de carga no está configurado a través de un filtro.

Si al filtro random no se le proporciona ningún argumento, permanecerá la política de equilibrado de carga aleatoria.

Ejemplo #15 Equilibrado de carga aleatorio con el filtro random

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": [
            "random"
        ]
    }
}

Opcionalmente, se puede pasar el argumento sticky al filtro. Si se establece el parámetro sticky al string 1, el filtro seguirá la estrategia de equilibrado de carga "aleatoria una vez".

Ejemplo #16 Equilibrado de carga "aleatoria una vez" con el filtro random

{
    "filters": {
        "random": {
            "sticky": "1"
        }
    }
}

Los filtros random y roundrobin admiten el establecimiento de una prioridad, un peso para un servidor, desde PECL/mysqlnd_ms 1.4.0. Si se pasa el argumento weight al filtro, debe asginar un peso para todos los servidores. A los servidores se les debe proporcionar un sobrenombre en las listas de servidores slave y master respectivamente. El alias debe usarse para hacer referencia a servidores para asignarles una prioridad con weight.

Ejemplo #17 Error de referencia

[E_RECOVERABLE_ERROR] mysqli_real_connect(): (mysqlnd_ms) Unknown server 'slave3' in 'random' filter configuration. Stopping in %s on line %d

Usar un sobrenombre erróneo con weight podría resultar en un error similar al mostrado arriba.

Si se omite weight, el peso predeterminado de todos los servidores es uno.

Ejemplo #18 Asignar weight para el equilibrado de carga

{
   "myapp": {
       "master": {
           "master1":{
               "host":"localhost",
               "socket":"\/var\/run\/mysql\/mysql.sock"
           }
       },
       "slave": {
           "slave1": {
               "host":"192.168.2.28",
               "port":3306
           },
           "slave2": {
               "host":"192.168.2.29",
               "port":3306
           },
           "slave3": {
               "host":"192.0.43.10",
               "port":3306
           },
       },
       "filters": {
           "random": {
               "weights": {
                   "slave1":8,
                   "slave2":4,
                   "slave3":1,
                   "master1":1
               }
           }
       }
   }
}

Como promedio, un servidor al que se le asigne un peso de dos será seleccionado el doble que un servidor al que se la haya asignado un peso de uno. Se pueden asignar diferentes pesos para reflejar diferentes tipos de máquinas, para preferir coubicar esclavos que tienen una latencia de red baja o para configurar un servidor de tolerancia a fallos de emergencia. En este último caso, se podría asignar al servidor de emergencia un peso muy bajo en relación con los demás servidores. Por ejemplo, dada la configuración de arriba, slave3 obtendrá solamente el ocho por ciento de las peticiones como media. Mientras que slave1 y slave2 estén ejecutándose, se usarán con poca frecuencia, de forma similar a un servidor de tolerancia a fallos de emergencia. Si ocurre un fallo de slave1 y de slave2, el uso de slave3 aumenta. Por favor, revise las notas sobre la tolerancia a fallos antes de usar weight de esta manera.

El rango de valores válidos del peso es de 1 a 65535.

Los argumentos desconocidos son ingnorados. No se dan advertencias ni errores.

Espera uno o más servidores como entrada. Produce un servidor. Una secuencia de filtros como random, roundrobin, puede causar una advertencia y establecer un mensaje de error sobre el gestor de conexión cuando se ejecute una sentencia.

Listado de los argumentos del filtro.

Palabra clave Descripción Versión
sticky

Habilita o deshabilita la política de equilibrado de carga "aleatoria una vez". Véase más arriba.

Desde 1.2.0.
weight

Asigna un peso o prioridad de equilibrado de carga a un servidor. Por favor, véase la descripción de arriba.

Desde 1.4.0.
Filtro: roundrobin object

Si se utiliza el filtro roundrobin, el complemento iterará sobre la lista de servidores esclavos configurados para elegir un servidor para que ejecute una sentencia. Si el complemento alcanza el final de la lista, volverá al inicio de la misma y eligirá el primer servidor esclavo configurado.

Ejemplo #19 Filtro roundrobin

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin"
        ]
    }
}

Espera uno o más servidores como entrada. Produce un servidor. Una secuencia de filtros como roundrobin, random, puede causar una advertencia y establecer un mensaje de error sobre el gestor de conexión cuando se ejecute una sentencia.

Listado de los argumentos del filtro.

Palabra clave Descripción Versión
weight

Asigna un peso o prioridad de equilibrado de carga a un servidor. Por favor, véase la descipción de arriba.

Desde 1.4.0.
Filtro: user object

El filtro user reemplaza a la función mysqlnd_ms_set_user_pick_server(), la cual ha sido eliminada en la versión 1.1.0-beta. El filtro establece una llamada de retorno para la división de lectura-escritura y la selección del servidor definidas por el usuario.

Las decisiones del mecanismo interno de división de consultas de lecura-escritura pueden ser sobrescritas de dos maneras. La más sencilla es anteponer a una consulta las sugerentecias SQL MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH o MYSQLND_MS_LAST_USED_SWITCH. Al utilizar sugerencias SQL se puede controlar, por ejemplo, si una consulta debería ser enviada al servidor maestro de replicación MySQL o a uno de los servidores esclavos. Mediante la ayuda de sugenrencias SQL no es posible elegir un esclavo en particular para que ejecute una consulta.

Se puede obtener control total en la selección del servidor usando una función de llamada de retorno. Solamente se recomienda el uso de una llamada de retorno para usuarios expertos, ya que ésta ha de cubrir todos los casos que de otro modo manejaría el complemento.

El complemento invorcará a la función de llamada de retorno para seleccionar un servidor de las listas de servidores maestros y esclavos configurados. La función de llamada de retorno inspeccionará la consulta a ejecutar y eligirá un servidor para que ejecute dicha consulta, devolviendo el URI del equipo anfitrión, tal como lo encontró en la lista de maestros y esclavos.

Si las conexiones retardadas están habilitadas y la llamada de retorno elige un servidor esclavo para el que hasta ahora no se ha establecido una conexión, y el establecimiento de la conexión al esclavo falla, el complemento devolverá un error sobre la siguiente acción en la conexión fallida, por ejemplo, al ejecutar una consulta. Es responsabilidad del desarrollador de la aplicación manejar el error. Por ejemplo, la aplicación podría re-ejecutar la consulta para desencadenar una nueva selección de un servidor y una nueva invocación a la llamada de retorno. Si lo hace, la llamada de retorno debe asegurarse de seleccionar un esclavo diferente, o comprobar la disponibilidad del esclavo, antes de devolver el resultado al complemento para evitar un bucle infinito.

Ejemplo #20 Establecer una llamada de retorno

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}

Se espera que la llamada devuelva un equipo anfitrión donde ejecutar la consulta. El URI del equipo anfitrión se tomará de las listas de conexión maestras y esclavas pasadas a la función de llamada de retorno. Si ésta devuelve un valor que no se encuentra el las listas de conexión maestras ni en las esclavas, el complemento emitirá un error de tipo E_RECOVERABLE_ERROR. El error puede ser (mysqlnd_ms) User filter callback has returned an unknown server. The server 'server that is not in master or slave list' can neither be found in the master list nor in the slave list ((mysqlnd_ms) La llamada de retorno del filtro de usuario ha devuelto un servidor desconocido. El servidor 'servidor que no está en la lista de maestros o esclavos' no se puede encontrar en ni en la lista de maestros ni en la de esclavos). Si la aplicación captura el error para ignorarlo, los errores siguientes pueden ser establecidos en el gestor de conexión, por ejemplo, (mysqlnd_ms) No connection selected by the last filter ((mysqlnd_ms) El último filtro no seleccionó ninguna conexión) con el código de error 2000 y el estado sql HY000. Además se puede emitir una advertencia.

Si se hace referencia a una función inexistente como llamada de retorno, resultará en cualquier error de tipo E_RECOVERABLE_ERROR siempre que el complemento intente invocar a dicha función. El mensaje de error puede ser como: (mysqlnd_ms) Specified callback (pick_server) is not a valid callback ((mysqlnd_ms) La llamada de retorno (pick_server) no es una llamada de retorno válida). Si la aplicación captura el error para ignorarlo, los errores siguientes pueden ser establecidos en el gestor de conexión, por ejemplo, (mysqlnd_ms) Specified callback (pick_server) is not a valid callback con el código de error 2000 y el estado sql HY000. Admás se puede emitir una advertencia.

Los siguientes parámetros son pasados desde el complemento a la llamada de retorno.

Parámetro Descripción Versión
connected_host

El URI del servidor de las bases de datos conectado actualmente.

Desde 1.1.0.
query

La consulta de la sentencia para la cual un servidor necesita ser elegido.

Desde 1.1.0.
masters

La lista de servidores maestros de donde elegir. Observe que la lista de servidores maestros puede no ser idéntica a la lista de servidores maestros configurados si el filtro no es el primero en la cadena de filtros. Los filtros ejecutados anteriormente puede haber reducido la lista de maestros.

Desde 1.1.0.
slaves

La lista de servidores esclavos de donde elegir. Observe que la lista de servidores maestros puede no ser idéntica a la lista de servidores maestros configurados si el filtro no es el primero en la cadena de filtros. Los filtros ejecutados anteriormente puede haber reducido la lista de maestros.

Desde 1.1.0.
last_used_connection

El URI del servidor de la conexión usada donde ejecutar la sentencia anterior.

Desde 1.1.0.
in_transaction

Bandera booleana que indica si la sentencia es parte de una transacción abierta. Si el modo 'autocommit' está desactivado, se establecerá a true. Si no, se establecerá a false.

La detección de transacciones está basada en la monitorización de la llamada a set_autocommit de la biblioteca mysqlnd . La monitorización no era posible antes de PHP 5.4.0. Por favor, vea la argumentación de los conceptos sobre agrupación e intercambio de conexiones para más detalles.

Desde 1.1.0.

Ejemplo #21 Utilizar una llamada de retorno

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}
<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* predeterminado: volver a la lógica interna del comlemento */
 $ret = NULL;

 printf("El usuario se ha conectado a '%s'...\n", $connected);
 printf("... decidiendo dónde ejecutar '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... usando el maestro\n");
   $ret = $masters[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* una tabla que está únicamente en el primer esclavo configurado  */
    printf("... detectado un acceso a la tabla únicamente disponible en el esclavo A\n");
    $ret = $slaves[0];
   }
   else
   {
    /* rotativo */
    printf("... alguna consulta de solo lectura para un esclavo\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... usando el último esclavo utilizado\n");
   $ret = $last_used_connection;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

$mysqli = new mysqli("myapp", "root", "", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

El resultado del ejemplo sería:

El usuario se ha conectado a 'myapp'...
... decidiendo dónde ejecutar 'SELECT 1 FROM DUAL'
... alguna consulta de solo lectura para un esclavo
... ret = 'tcp://192.168.2.27:3306'
El usuario se ha conectado a 'myapp'...
... decidiendo dónde ejecutar 'SELECT 2 FROM DUAL'
... alguna consulta de solo lectura para un esclavo
... ret = 'tcp://192.168.78.136:3306'
El usuario se ha conectado a 'myapp'...
... decidiendo dónde ejecutar 'SELECT * FROM table_on_slave_a_only'
... detectado un acceso a la tabla únicamente disponible en el esclavo A
... ret = 'tcp://192.168.2.27:3306'

Filtro: user_multi object

El filtro user_multi se diferencia de user en un único aspecto. De otro modo su sintaxix sería idéntica. El filtro user debe elegir y devolver exactamente un nodo para la ejecución de sentecias. Una cadena de filtros normalmente finaliza con un filtro que emite un único nodo. La cadena de filtros reduciría la lista de candidatos para la ejecución de sentencias a uno. Este es el caso, sólo queda un nodo, después de haber ejecutado el filtro user.

El filtro user_multi es un filtro múltiple. Devuelve una lista de servidors esclavos y una lista de servidores maestros. La lista necesita más filtración para identificar exactamente un nodo para la ejecución de sentencias. Un filtro múltiple normalmente se coloca al principio de la cadenda de filtros. El filtro quality_of_service es otro ejemplo de filtro múltiple.

El valor devuelto por la llamada de retorno establecido por user_multi debe ser un array con dos elementos. El primero contiene una lista de los servidores maestros seleccionados. El segundo contiene una lista de los servidores esclavos seleccionados. Las listas contendrán las claves de los servidores maestros y esclavos tal como se encontraron en las listas de esclavos y maestros pasadas a la llamada de retorno. El ejemplo de abajo devuelve listas de maestros y esclavos aleatorios extraídas de la entrada de la función.

Ejemplo #22 Devolver maestros y esclavos aleatorios

<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
  $maestros_elegidos = array()
  foreach ($masters as $clave => $valor) {
    if (mt_rand(0, 2) > 1)
      $maestros_elegidos[] = $key;
  }
  $esclavos_elegidos = array()
  foreach ($slaves as $clave => $valor) {
    if (mt_rand(0, 2) > 1)
      $esclavos_elegidos[] = $clave;
  }
  return array($maestros_elegidos, $esclavos_elegidos);
}
?>

El complemento emitirá un error de tipo E_RECOVERABLE si la llamada de retorno falla al devolver la lista de servidores. El error puede ser (mysqlnd_ms) User multi filter callback has not returned a list of servers to use. The callback must return an array in %s on line %d ((mysqlnd_ms) La llamada de retorno del filtro de usuario no ha devuelto una lista de servidores a usar. La llamada de retorno debe devolver un array en %s en la línea %d). En caso de que la lista de servidores no esté vacía pero contenga claves/ids de servidores no válidos, e lanzaráun error de tipo E_RECOVERABLE con un mensaje de error como (mysqlnd_ms) User multi filter callback has returned an invalid list of servers to use. Server id is negative in %s on line %d ((mysqlnd_ms) La llamada de retorno del filtro de usuario ha devuelto una lista de servidores a usar no válida. El id del servidor es negativo en %s en la línea %d), o similar.

La emisión de un error en caso de que la lista de esclavos o de maestros esté vacía depende de la configuración. Si se devuelve una lista de maestros vacía para una operación de escritura, es probable que el complemento emita una advertencia como (mysqlnd_ms) Couldn't find the appropriate master connection. 0 masters to choose from. Something is wrong in %s on line %d ((mysqlnd_ms) No se pudo encontrar la conexión maestra apropiada. 0 maestros donde elegir. Algo está mal en %s en la línea %d). Normalmente también es seguida de un error de tipo E_ERROR. En el caso de una operación de lectura con una lista de servidores vacía, el comportamiento depende de la configuración de la tolerancia a fallos. Si ésta está habilitada en el maestro, no debería aparecer ningún error. Si está desactivada en el maestro, el complemento emitirá una advertencia como (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d ((mysqlnd_ms) No se pudo encontrar la conexión esclava apropiada. 0 esclavos donde elegir. Algo está mal en %s en la línea %d).

Filtro: node_groups object

El filtro node_groups permite agrupas nodos de clúster y consultar grupos seleccionados, por ejemplo, para dar soporte al particionamiento de datos. El particionamiento de datos puede ser neceario para la fragmentación manual, copia primaria basada el clústeres ejecutándose en múltiples maestros, o para evitar puntos calientes en actualizaciones de cualquier clúster que no posea particionamiento interno. El filtro es un filtro múltiple que devuelve cero, uno o múltiples servidores de su entrada. Así, le deben seguir otros filtros para reducir el número de candidatos a uno por ejecución de sentencia.

Palabra clave Descripción Versión
nombre del grupo de nodos definido por el usuario

Se debe definir uno o más grupos de nodos. Un grupos de nodos puede tener un nombre arbitrario definido por el usuario. El nombre se usa junto con una sugerencia SQL para restringir la ejecución de consultas a los nodos enumerados para el grupo de nodos. Para ejecutar una consulta en cualquier servidor de un grupo de nodos, esta debe comenzar con la sugerencia SQL /*user defined node group name*/. Observe que no están permitidos espacios en blanco en user defined node group name. Ya que user defined node group name se usa tal cual como parte de una sugerencia SQL, debería elegirse el nombre que siga las normas del lenguaje SQL.

Cada entrada del grupo de nodos debe contener una lista de servidores master. Están permitidos servidores slave adicionales. El no proporcionar una lista de master a un grupos de nodos name_of_group podría causar un error de tipo E_RECOVERABLE_ERROR como (mysqlnd_ms) No masters configured in node group 'name_of_group' for 'node_groups' filter.

La lista de servidores maestros y esclavos debe hacer referencia a las entradas correspondientes en la lista de servidores global de maestros y esclavos respectivamente. Hacer referencia a un servidor desconocido en ambas listas de servidores podría causar un error E_RECOVERABLE_ERROR como (mysqlnd_ms) Unknown master 'server_alias_name' (section 'name_of_group') in 'node_groups' filter configuration.

Ejemplo #23 Particionamiento manual

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.28",
                "port": 3306
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Observe que si una cadena de filtros genera una lista de esclavos vacía y la directiva de configuración de PHP mysqlnd_ms.multi_master=0 se usa, el complemento podría emitiri una advertencia.

Desde 1.5.0.
Filtro: quality_of_service object

El filtro quality_of_service identifica nodos del clúster capaces de proporcionar una calidad de servicio en particular. Es un filtro múltiple que devuelve cero, uno o múltiples de los servidores que se le proporcionen. Por lo tanto, deben seguirle otros filtros para reducir el número de candidatos a uno para la ejecución de sentecnias.

El filtro quality_of_service ha sido introducido en la versión 1.2.0-alpha. En las serires 1.2, el filtro se centra en el aspecto de la consistencia de la calidad del servicio. Diferentes tipos de clústeres ofrecen diferentes consistencias de datos predeterminadas. Por ejemplo, un esclavo de replicación MySQL asíncrono ofrece consistencia final. El esclavo podría no proporcionar los datos solicitados debido a que no ha replicado la escritura, podría servir una base de datos antigua debido a su demora, o podría servir información actual. A menudo, esto es aceptable. En algunos casos son necesarios niveles de consistencia mayor para que la aplicación funcione correctamente. En tales casos, quality_of_service puede ignorar los nodos del clúster que no proporcionen la calidad de servicio necesaria.

El filtro quality_of_service puede ser reemplazado o creado en tiempo de ejecución. Una llamada exitosa a mysqlnd_ms_set_qos() elimina todas las entradas de los filtros qos existentes de la lista de filtros e instala uno nuevo al principo de la misma. Todas los ajustes que se pueden hacer a través de mysqlnd_ms_set_qos() también pueden realizarse en el fichero de configuración del complemento. Sin embargo, el uso de la función es de lejos el caso más común. En lugar de establecer los niveles de servicios de consistencia de sesión y de consistencia fuerte en el fichero de configuración del complemento, se recomienda definir solamente maestros, y no esclavos. Ambos niveles de servicio forzarán el uso de maestros solamente. Usar una lista de esclavos vacía abrevia el fichero de configuración, y así se mejora su legibilidad. El único nivel de servicio en el que existe un caso para la definición en el fichero de configuración del complemento es la combinación de consistencia final y demora máxima de esclavos.

Palabra clave Descripción Versión
eventual_consistency

Solicita la consistencia final. Permite el uso de todos los servidores maestros y esclavos. Los datos devueltos pueden o no ser actuales.

La consistencia final acepta el parámetro opcional age. Si se proporciona age, el complemento considerará para la lectura solamente los esclavos que la replicación MySQL notifique que tengan una demora menor o igual a age. La demora de replicación se mide usando SHOW SLAVE STATUS. Si el complemento falla al recuperar la demora de replicación, saltará el esclavo comprobado. Los detalles de implementación y algunos consejos se proporcionan en la sección de conceptos de calidad de servicio.

Por favor, observe que si una cadena de filtros genera un lista vacía de esclavos y se usa la directiva de configuración de PHP mysqlnd_ms.multi_master=0, el complemento podría emitir una advertencia.

Ejemplo #24 Límite global de la demora de los esclavos

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "quality_of_service": {
                "eventual_consistency": {
                    "age":123
                }
            }
        }
    }
}

 Desde 1.2.0.
session_consistency

Solicita la consistencia de sesión (lectura de sus escrituras). Permite el uso de todos los maestros y todos los esclavos que están sincronizados con el maestro. Si no se proporcionan más parámetros, los esclavos son filtrados debido a que no existe una manera fiable de comprobar si un esclavo se a puesto al día con respecto al maestro o si está retrasado. Por favor, observe que si una cadena de filtros genera una lista de esclavos vacía y se usa la directiva de configuración de PHP mysqlnd_ms.multi_master=0, el complemento podría emitir una advertencia.

La solicitud temporal de la consistencia de sesión usando mysqlnd_ms_set_qos() es una alternativa a usar master_on_write. master_on_write probablemente envía más sentencias al maestro de las necesarias. La aplicación puede continuar la operación en un nivel de consistencia más bajo después de haber realizado algunas lecturas críticas.

Desde 1.1.0.
strong_consistency

Solitica la consistencia fuerte. Solamente serán usados los maestros.

Desde 1.2.0.
failover Hasta, e incluyendo 1.3.x: string. Desde 1.4.0: object.

Política de la tolerancia a fallos. Políticas admitidas: disabled (predeterminada), master, loop_before_master (desde 1.4.0).

Si no se establece ninguna política de tolerancia a fallos, el complemento no realizará ninguna tolerancia a fallos automática (failover=disabled). Siempre que el complemento falle al conectarse a un servidor, emitirá una advertencia y establecerá el código y el mensaje del error de conexión. A partir de entonces, es responsabilidad de la aplicación manejar el error y, por ejemplo, reenviar la última sentencia para provocar la selección de otro servidor.

Observe que la lógica de tolerancia a fallos automática se aplica al abrir conexiones solamente. Una vez que una conexión ha sido abierta, no se realizan intentos automáticos para reabrirla en caso de error. Si, por ejemplo, si la conexión a un servidor se cierra y el usuario intenta ejecutar una sentencia sobre dicha conexión, no se intentará la tolerancia a fallos automática. En su lugar se notificará un error.

Si se usa failover=master, el complemento implícitamente usará la tolerancia a fallos del maestro. Por favor, revise la documentación de conceptos para informarse sobre los problemas y riesgos potenciales del uso de failover=master.

Ejemplo #25 Tolerancia a fallos opcional en el maestro al fallar una conexión a un esclavo

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": "master"
    }
}

Desde PECL/mysqlnd_ms 1.4.0 la palabra clave de la configuración de la tolerancia a fallos se refiere a un objeto.

Ejemplo #26 Nueva sintaxis desde 1.4.0

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": {"strategy": "master" }
    }
}

Palabra clave Descripción Versión
strategy

Política de tolerancia a fallos. Valores posibles: disabled (predeterminado), master, loop_before_master

El valor disabled deshabilita la tolerancia a fallos automática.

Establecer master ordena al complemento a intentar conectarse a un maestro en caso de un error de conexión esclava. Si el intento de conexión maestra falla, el comlemento se saldrá del bucle de tolerancia a fallos y devolverá un error al usuario.

Si se usa loop_before_master y se realiza una petición a un esclavo, el complemento intentará conectarse a otro esclavo antes realizar la tolerancia a fallos en un maestro. Si se dan múltiples maestros y está habilitado el multimaestro, el complemento también iterará sobre la lista de maestros e intentará conectarse antes de devolver un error al usuario.

Desde 1.4.0.
remember_failed

Recuerda los fallos durante una petición web. Predeterminado: false.

Si se establece a true el complemento recordará los equipos anfitriones fallidos y los saltará en todos los equilibrados de carga futuros realizados para la duración de la petición web actual.

Desde 1.4.0. La característica solamente está disponible junto con con los filtros de equilibrado de carga random y roundrobin. Se recomienda el uso del ajuste.
max_retries

Número máximo de intentos de conexión antes de saltarse un equipo anfitrión. Predeterminado: 0 (sin límite).

Este ajuste se usa para prevenir que los equipos anfitriones sean elegidos de la lista host si ocurre un primer fallo. Si se establece a n > 0, el complemento guardará el nodo en la lista de nodos incluso después de un intento de conexión fallido. El nodo no será eliminado inmediatamente de las lista de esclavos y maestros respectivamente después del primer fallo de conexión, pero en su lugar se intentará conectar hasta n veces en las rondas de equilibrado de carga futuras antes de ser eliminado.

Desde 1.4.0. La característica solamente está disponible junto con con los filtros de equilibrado de carga random y roundrobin.

Establecer failover a cualquier valor distinto de disabled, master o loop_before_master no emitirá ninguna advertencia o error.

lazy_connections bool

Controla el uso de conexiones retardadas. Las conexiones retardadas son conexiones que no se abren antes de que un cliente envíe la primera conexión. Las conexiones retardadas son las predeterminadas.

Se recomeinda encarecidamente usar conexiones retardadas. Éstas ayudan a mantener bajo el número de conexiones abiertas. Si se desabilitan las conexiones retardas y, por ejemplo, se configura un servidor maestro de replicación MySQL y dos esclavos de replicación MySQL, el complemento abrirá tres conexiones en la primera llamada a la función de conexión, aunque la aplicación podría usar solamente la conexión maestra.

Las conexiones retardadas revelan un riesgo si se realizan un gran uso de acciones que cambian el estado de una conexión. El complemento no resolverá todas las acciones de cambio de estado de todas las conexiones de la agrupación de conexiones. Las pocas acciones resueltas son aplicadas solamente a conexiones ya abiertas. Las conexiones retardadas abiertas en el futuro no son afectadas. Solamente algunos ajustes son "recordados" y aplicados cuando las conexiones retardadas son abiertas.

Ejemplo #27 Deshabilitar las conexiones retardadas

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 0
    }
}

Por favor, véase también server_charset para superar problemas potenciales con el escapado de cadenas de texto y con servidores que utilicen conjuntos de caracteres diferentes del predeterminado.

server_charset string

Este ajuste ha sido introducido en la versión 1.4.0. Se recomienda establecerlo si se van a usar conexiones retardadas.

El ajuste server_charset sirve para dos propósitos. Actúa como conjunto de caracteres alternativo para su uso con el escapado de cadenas de texo realizado antes de que se haya establecido una conexión, y ayuda a evitar problemas de escapado en entornos heterogéneos con servidores que utilizan diferentes conjuntos de caracteres predeterminados.

El escapado de cadenas de texto toma en cuenta el conjunto de caracteres de una conexión. El escapado de cadenas de texto no es posible antes de que una conexión haya sido abierta y se conozca el conjunto de caracteres de de la conexión. El uso de conexiones retardadas demora la apertura real de conexiones hasta que se envíe una sentencia.

Una aplicación que utilice conexiones retardadas puede intentar escapar una cadena de texto antes de nviar una setencia. De hecho, esto debería ser un caso común, ya que la sentencia podría contener la cadena de texto que va a ser escapada. Sin embargo, debido a la característica de conexiones retardadas, aún no se ha abierto ninguna conexión y el escapado falla. El complemento podría notificar un error de tipo E_WARNING y un mensaje como (mysqlnd_ms) string escaping doesn't work without established connection. Possible solution is to add server_charset to your configuration ((mysqlnd_ms) el escapado de cadenas de texto no funciona sin establecer una conexión. Una posible solución es añadir server_charset a la configuración) para informar del problema.

Establecer server_charset hace que el complemento use el conjunto de caracteres dado para el escapado de cadenas de texto realizado sobre gestores de conexines retardadas antes de establecer una conexión de red a MySQL. Además, el complemento forzará el uso del conjunto de caracteres cuando la conexión sea establecida.

El forzado del uso del conjunto de caracteres utilizado para el escapado se realiza para prevenir los problemas de usar un conjunto de caracteres diferente para el escapado que el usado después para la conexión. Esto tiene el benificio adicional de eliminar la necesidad de ajustar la configuración del conjunto de caracteres de todos los servidores usados. No importa cuál sea el conjunto de caracteres predeterminado de cualquier servidor, el complemento establecerá el configurado como el predeterminado.

El complemento no impide al usuario cambiar el conjunto de caracteres en cualquier momento mediante la llamada a set_charset() o las setencias SQL correspondientes. Por favor, observe que el uso de SQL no se recomienda ya que no puede ser monitorizado por el complemento. El usuario puede, por ejemplo, cambiar el conjunto de caracteres sobre un gestor de conexiones retaradadas después de escapar una cadena de texto y antes de abrir la conexión real. El conjunto de caracteres establecido por el usuario será usado para cualquier escapado subsiguiente antes de que se establezca la conexión. Ésta será establecida usando el conjunto de caracteres configurado, sin importar cuál es el conjunto de caracteres del servidor ni cuál ha establecido el usuario antes. Una vez que una conexión ha sido abierta, set_charset ya no tiene sentido.

Ejemplo #28 Escapado de cadenas de texto sobre un gestor de conexiones retardadas

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 1,
        "server_charset" : "utf8"
    }
}
<?php
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
$mysqli->real_escape("esto será escapado usando el ajuste server_charset - utf8");
$mysqli->set_charset("latin1");
$mysqli->real_escape("esto será escapado usando latin1");
/* conjunto de caracteres del servidor implícitamente establecido - conexión utf8 */
$mysqli->query("SELECT 'Esta conexión será fijada a server_charset durante su establecimiento' AS _msg FROM DUAL");
/* latin1 se usará de aquí en adelante */
$mysqli->set_charset("latin1");
?>

master_on_write bool

Si se establece, el complemento usará únicamente el servidor maestro después de que se haya ejecutado la primera sentencia en el maestro. Las aplicaciones aún pueden enviar sentencias a los esclavos usando sugerencias SQL para invalidar la decisión automática.

Este ajuste puede ser útil con la demora de replicación. Si una aplicación ejecuta un INSERT, el complemento usará, de manera predeterminada, el maestro para ejecutar todas las sentencias siguientes, incluidas las sentencias SELECT. Esto ayuda a evitar problemas con las lecturas desde los esclavos que no hayan replicado aún el INSERT.

Ejemplo #29 master_on_write para lecturas consistentes

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "master_on_write": 1
    }
}

Por favor, observe que el filtro quality_of_service fue introducido en la versión 1.2.0-alpha. Proporciona mayor control sobre, por ejemplo, la realización de la lectura se sus escrituras y ofrece funcionalidad adicional introduciendo los niveles de servicio.

Todos los ajustes de adhesión de transacciones, incluyendo trx_stickiness=on, son invalidados por master_on_write=1.

trx_stickiness string

Política de adhesión de transacciones. Las políticas admitidas son: disabled (predeterminada), master.

Este ajuste requiere la versión 5.4.0 o posterior. Si se usa con una versión de PHP anterior a la 5.4.0, el complemetno emitirá una advertencia como (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99 ((mysqlnd_ms) La estrategia trx_stickiness no está soportada antes de PHP 5.3.99).

Si no se establece ningun política de adhesión de transacciones o si se establece trx_stickiness=disabled, el complemento no considerará las transacciones. Por lo tanto, el complemento podrá realizar el equilibrado de carga de conexiones y el intercambio de conexiones en mitad de una trasacción. El complemento no es seguro con las transacciones. Se deben usar sugerencias SQL para evitar el intercambio de conexiones durante una transacción.

A partir de PHP 5.4.0, la bibliteca mysqlnd permite al complemento monitorizar el modo autocommit mediante las llamadas a la función set_autocommit() de la biblioteca. Si se establece set_stickiness=master y se deshabilita autocommit mediante una extensión de MySQL para PHP que invoque la llamada a la función interna set_autocommit() de la biblioteca mysqlnd, hará que el complemento considere el comienzo de una transacción. Luego, el complemento detiene el equilibrado de carga y dirige todas las setencias al servidor maestro hasta que autocommit sea habilitado. Por lo tanto, no son necesarias las sugerencias SQL.

Un ejemplo de una función de la API de MySQL para PHP que llama a la función interna set_autocommit() de la biblioteca mysqlnd es mysqli_autocommit().

Aunque se establezca trx_stickiness=master, el complemento no puede considerar los cambios del modo autocommit causados por sentencias SQL como SET AUTOCOMMIT=0 o BEGIN.

A partir de PHP 5.5.0, la biblioteca mysqlnd introduce llamadas adicionales a la API en C para controlar transacciones. El nivel de control coincide con el ofrecido por sentencias SQL. La API mysqli ha sido modificada para usar dichas llamadas. Desde la versión 1.5.0, PECL/mysqlnd_ms puede monitorizar no solo mysqli_autocommit(), sino también mysqli_begin(), mysqli_commit() y mysqli_rollback() para detectar los límites de transacciones y detener el equilibrado de carga durante una transacción.

Ejemplo #30 Utilizar el maestro para ejecutar transacciones

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Desde la versión 1.5.0, la tolerancia a fallos automática y silenciosa está deshabilitada durante una transacción. Si los límites de una transacción han sido detectados apropiadamente, la adhesión de transacciones está habilitada y un servidor falla, el complemento no intentará realizar la tolerancia a fallos en el siguiente servidor, si lo hubiera, sin importar la configuración de la política de tolerancia a fallos. El usuario debe manejar el error de forma manual. Dependiendo de la configuración, el complemento podría emitir un error de tipo E_WARNING como (mysqlnd_ms) Automatic failover is not permitted in the middle of a transaction. Este error podría ser sobrescrito por errores siguientes como (mysqlnd_ms) No connection selected by the last filter. Esos errores serán generados por la función de consulta que falló.

Ejemplo #31 Sin tolerancia a fallos automáticia, inconveniente al manejar errores

<?php
/* supuesto: configurada la tolerancia a fallos automática */
$mysqli = new mysqli("myapp", "username", "password", "database");

/* establece el estado interno del complemento a in_trx = 1 */
$mysqli->autocommit(false);

/* supuesto: el servidor falla */
if (!($res = $mysqli->query("SELECT 'Assume this query fails' AS _msg FROM DUAL"))) {
 /* manejar el fallo de la transacción, el estado interno del complemento aún es in_trx = 1 */
 printf("[%d] %s", $mysqli->errno, $mysqli->error);
 /*
  Si se usa autocommit() basado en la detección de transacciones, es un
  DEBER llamar a autocommit(true). De lo contrario el complemento asume
  que la transacción actual continua y los cambios de
  la conexión permanecen prohibidos.
 */
 $mysqli->autocommit(true);
 /* Igualmente, querrá iniciar una nueva transacción */
 $mysqli->autocommit(false);
}
/* latin1 de ahora en adelante */
$mysqli->set_charset("latin1");
?>

Si un servidor falla en mitad de una transacción, el complemento continua rechazando el intercambio de conexiones hasta que haya finalizado la transacción en curso. Recuerde que el complemento monitoriza las llamadas a la API para detectar los límites de las transacciones. Por tanto, se ha de, por ejemplo, habilitar el modo auto commit para finalizar la transacción actual antes de que el complemento continue equilibrando la carga e intercambiando el servidor. De igual modo, querrá iniciar una nueva transacción inmediantamente a partir de aquí y deshabilitar de nuevo el modo auto commit.

El no manejar las consultas fallidas y no finalizar una transacción fallida usando las llamadas a la API, podría causar que todos los comandos siguientes emitan errores como Commands out of sync; you can't run this command now. Por lo tanto, es importante manejar todos los errores.

transient_error object

El ajuste ha sido introducido en la versión 1.6.0.

Un nodo de un clúster de una base de datos podría replicar un error transitorio a un cliente. El cliente puede entonces repetir la operación sobre el mismo nodo, recurrir a otro nodo diferente o abortar la operación. Por definición, es seguro que un cliente reintente la misma operación sobre el mismo nodo antes de rendirse.

PECL/mysqlnd_ms puede realizar el bucle de reintento en nombre de la aplicación. Configurando transient_error, el complemento puede ser instruido para que repita las operaciones que fallen con ciertos códigos de error para un número máximo de veces con una pausa entre cada reintento. Si el error transitorio desaparece durante la ejecución del bucle, se oculta a la aplicación. De lo contrario, el error es reenviado a la aplicación al finalizar el bucle.

Ejemplo #32 Bucle de reintentos para errores transitorios

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1297
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Palabra clave Descripción Versión
mysql_error_codes

La lista de los códigos de errores transitorios. Se podría añadir cualquier código de error de MySQL a la lista. Es posible considerar cualquier error como transitorio, no únicamente el 1297 (HY000 (ER_GET_TEMPORARY_ERRMSG), Message: Got temporary error %d '%s' from %s). Antes de añadir otros códigos, excepto el 1297, a la lista, asegúrese de que el clúster admite un nuevo intento sin impactar sobre el estado de la aplicación.

Desde 1.6.0.
max_retries

Cuántas veces reintentar una operación que falla con un error transitorio antes de reenviar el fallo al usuario.

Predeterminado: 1

Desde 1.6.0.
usleep_retry

Milisegundos a dormir antes de reintentar el error transitorio. El valor es pasado a la función usleep() en C, de ahí el nombre.

Predeterminado: 100

Desde 1.6.0.
xa object

Este ajuste ha sido introducido en la versión 1.6.0.

Nota: Experimental

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción.

state_store
record_participant_credentials

Si almacenar el nombre de usuario y la contraseña de un participante de una transacción global en la tabla de participantes. Si está desacivado, la recolección de basura utilizará el nombre de usuario y contraseña predeterminados al conectarse a los participantes. A menos que se esté utilizando un nombre de usuario y contraseña diferentes para cada servidor de MySQL, se pueden emplear los predeterminados y evitar el almacenamiento de información sensible en el almacén de estado.

Observe que el nombre de usuario y la contraseña se almacenan en texto claro al usar el almacén de estado de MySQL, el cual es el único disponible. Es su responsabilidad proteger esta información sensible.

Predeterminado: false

participant_localhost_ip

Durante la recolección de basura de XA, el complemento podría encontrar un servidor participante para el cual haya sido anotado el host localhost. Si la recolección de basura toma lugar en otro host que no sea que haya escrito el registro de participantes en el almacén de estado, el nombre de host localhost ahora se resuelve a un host diferente. Por tanto, al anotar un nombre de host de un servidor participante en el almacén de estado, un valor de localhost debe ser reemplazado con la dirección IP real de localhost.

El establecimiento de participant_localhost_ip solamente debería ser considerado si el empleo localhost no se puede evitar. Solamente desde el punto de vista de la recolección de basura, es preferible no configurar ninguna conexión de socket, sino porprocionar una dirección IP y un puerto para un nodo.

mysql

El almacén de estado de MySQL es el único almacén de estado disponible.

global_trx_table

Nombre de la tabla de MySQL empleada para almacenar el estado de una transacción global en curso o abortada. Use la sentencia SQL de abajo para para crear la tabla. Asegúrese de editar el nombre de la tabla para que coincida con su configuración.

Predeterminado: mysqlnd_ms_xa_trx

Ejemplo #33 Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL

CREATE TABLE mysqlnd_ms_xa_trx (
  store_trx_id int(11) NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') NOT NULL DEFAULT 'XA_NON_EXISTING',
  intend enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') DEFAULT 'XA_NON_EXISTING',
  finished enum('NO','SUCCESS','FAILURE') NOT NULL DEFAULT 'NO',
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  started datetime DEFAULT NULL,
  timeout datetime DEFAULT NULL,
  PRIMARY KEY (store_trx_id),
  KEY idx_xa_id (gtrid,format_id,finished),
  KEY idx_state (state)
) ENGINE=InnoDB

participant_table

Nombre de la tabla de MySQL empleada para almacenar los participantes de una transacción global en curso o abortada. Use la sentencia SQL de abajo para para crear la tabla. Asegúrese de editar el nombre de la tabla para que coincida con su configuración.

Se pueden habilitar y deshabilitar el almacenamiento de credenciales con record_participant_credentials

Predeterminado: mysqlnd_ms_xa_participants

Ejemplo #34 Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL

CREATE TABLE mysqlnd_ms_xa_participants (
  fk_store_trx_id int(11) NOT NULL,
  bqual varbinary(64) NOT NULL DEFAULT '',
  participant_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  server_uuid varchar(127) DEFAULT NULL,
  scheme varchar(1024) NOT NULL,
  host varchar(127) DEFAULT NULL,
  port smallint(5) unsigned DEFAULT NULL,
  socket varchar(127) DEFAULT NULL,
  user varchar(127) DEFAULT NULL,
  password varchar(127) DEFAULT NULL,
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK')
   NOT NULL DEFAULT 'XA_NON_EXISTING',
  health enum('OK','GC_DONE','CLIENT ERROR','SERVER ERROR') NOT NULL DEFAULT 'OK',
  connection_id int(10) unsigned DEFAULT NULL,
  client_errno smallint(5) unsigned DEFAULT NULL,
  client_error varchar(1024) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (participant_id),
  KEY idx_xa_bqual (bqual),
  KEY idx_store_trx (fk_store_trx_id),
  CONSTRAINT mysqlnd_ms_xa_participants_ibfk_1 FOREIGN KEY (fk_store_trx_id)
    REFERENCES mysqlnd_ms_xa_trx (store_trx_id) ON DELETE CASCADE ON UPDATE CASCADE
) ENGINE=InnoDB
garbage_collection_table

Nombre de la tabla de MySQL empleada para rastrear y sincronizar ejecuciones de recolección de basura. en curso o abortada. Use la sentencia SQL de abajo para para crear la tabla. Asegúrese de editar el nombre de la tabla para que coincida con su configuración.

Predeterminado: mysqlnd_ms_xa_gc

Ejemplo #35 Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL

CREATE TABLE mysqlnd_ms_xa_gc (
  gc_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  fk_store_trx_id int(11) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  attempts smallint(5) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (gc_id),
  KEY idx_store_trx (gtrid,format_id,fk_store_trx_id)
) ENGINE=InnoDB
host

Nombre de host del servidor de MySQL.

user

Nombre del usuario empleado para conectarse al servidor de MySQL.

password

Contraseña para el usuario del servidor de MySQL.

db

Base de datos que guarda las tablas de recolección de basura. Observe que se han de crear las tablas de recolección de basura antes de utilzar el complemento. Las tablas no serán creadas implícitamente durante el tiempo de ejecución, por lo que la recolección de basura fallará si las tablas no existen.

port

Puerto del servidor de MySQL.

socket

Socket de dominio Unix del servidor de MySQL. Observe que si se tiene variaor servidores de PHP, cada uno intentará realizar la recolección de basura, siendo necesario que sean capces de conectarse al almacén de estado. En este caso, podría ser preferible configurar una dirección IP y un puerto para el servidor de almancen de estado de MySQL para asegurarse de que los servidores de PHP se pueden conectar a él.

rollback_on_close

Si revertir automáticamente una transacción global abierta cuando se cierre una conexión. Si está habilitado, imita el comportamiento predeterminado de las transacciones locales. Si un cliente se desconecta, el servidor revertirá cualquier transacción abierta y no finalizada.

Predeterminado: true

garbage_collection
max_retries

Número máximo de ejecuciones de la recolección de basura antes de rendirse. Los valores permitidos van de 0 hasta 100. Un valor de 0 significa sin límite, a menos que el almacén de estado fuerce uno. Si el almacén fuerza un límite, se suponeque podría ser significativamente mayor de 100. Disponible desde 1.6.0.

Obsérvese que es importante finalizar las transacciones XA fallidas dentro de un tiempo razonable para que los servidores participantes liberen recursos vinculados a la transacción. Es poco probable que la recolección de basura falle por un período grande siempre y cuando los servidores caídos estén disponibles de nuevo rápidamente. Todavía podría darse una situación donde se requiera la intervención humana debido a que la recolección de basura interna se detuvo o falló. En este caso, se podría comprobar primero si la transacción no se puede arreglar aún forzando a mysqlnd_ms_xa_gc() para que ignore el ajuste, antes de tratarlo manualmente.

Predeterminado: 5

probability

Probabilidad de la recolección de basura. Los valores permitidos van desde 0 a 1000. Un valor de 0 deshabilita la recolección de basura automática en segundo plano. Aún estableciendo un valor de 0, es posible ocasionar la recolección de basura llamando a mysqlnd_ms_gc(). Disponible desde 1.6.0.

La recolección de basura de transacciones XA obsoletas solamente está disponible si se ha configurado un almacén de estados. El almacén de estados es responsable de seguir la pista a las transacciones XA. Basándose en sus registros, puede encontrar transacciones XA bloqueadas a causa de la desconexión del cliente, conectarse a los participantes y revertir las transacciones no finalizadas.

La recolección de basura se desencadena como parte de un procedimiento de apagado de solicitud de PHP al final de una petición web. Esto es, después de haber finalizado el script de PHP. Para decidir si se ejecuta la recolección de basura se computa un valor aleatorio entre 0 y 1000. Si el valor de probability es mayor o igual al valor aleatorio, se invocan a las rutinas de la recolección de basura del almacén de estados.

Predeterminado: 5

max_transactions_per_run

Número máximo de transacciones XA no finalizadas consideradas por la recolección de basura durante una ejecución. Los valores permitidos van desde 1 hasta 32768. Dsiponible desde 1.6.0.

Limpiar una transacción XA no finalizada toma una cantidad de tiempo y recursos considerables. La rutina de recolección de basura podría tener que conectarse a varios participantes de una transacción global fallida para enviar los comandos SQL necesarios para revertir la transacción no finalizada.

Predeterminado: 100

Fichero de configuración del complemento (<= 1.0.x)

Nota:

La descripción de abajo se aplica a PECL/mysqlnd_ms < 1.1.0-beta. No es válida para versiones posteriores.

El complemento usa su propio fichero de configuración. Éste guarda información sobre el servidor maestro de replicación MySQL, los servidores esclavos de replicación MySQL, la política de elección (equilibrado de carga), la estrategia de tolerancia a fallos, y el uso de conexiones retardadas.

La directiva de configuración de PHP mysqlnd_ms.ini_file se usa para establecer el fichero de configuración del complemento.

El fichero de configuración imita el estándar del formato de php.ini. Consiste en una o más secciones. Cada sección define su propia unidad de ajustes. No existe una sección global para ajustes globales.

Las aplicciones hacen referencia a las secciones por su nombre. Las aplicaciones usan los nombres de las secciones como el parámetro 'host' (servidor) de los distintos métodos de conexión de las extensiones mysqli, mysql y PDO_MYSQL. Durante la conexión, el complemento de mysqlnd compara el nombre del equipo anfitrión con todos los nombres de las secciones del fichero de configuración del complemento. Si el nombre del equipo anfitrión y el nombre de la sección coinciden, el complemento cargará la configuración de esa sección.

Ejemplo #36 Ejemplo del uso de nombres de sección

[myapp]
master[] = localhost
slave[] = 192.168.2.27
slave[] = 192.168.2.28:3306
[localhost]
master[] = localhost:/tmp/mysql/mysql.sock
slave[] = 192.168.3.24:3305
slave[] = 192.168.3.65:3309
<?php
/* Todas las conexiones siguientes tendrán equilibrado de carga */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
$pdo = new PDO('mysql:host=myapp;dbname=base_datos', 'nombre_usuario', 'contraseña');
$mysql = mysql_connect("myapp", "nombre_usuario", "contraseña");

$mysqli = new mysqli("localhost", "nombre_usuario", "contraseña", "base_datos");
?>

Los nombres de sección son cadenas de texto. Es válido usar nombres de sección como 192.168.2.1, 127.0.0.1 o localhost. Si, por ejemplo, una aplicación se conexta a localhost y existe una sección de configuración del complemento llamada [localhost], la semántica de la operación de conexión se cambia. La aplicación ya no usará únicamente el servidor MySQL que se ejecuta en el equipo anfitrión localhost, sino que el complemento iniciará el equilibrado de carga de las consultas MySQL siguiendo las reglas de la sección de configuración [localhost]. De esta manera se puede realizar el equilibrado de carga de consultas desde una aplicación sin cambiar el código fuente de la misma.

Las directivas de configuración master[], slave[] y pick[] usan una sintaxis similar a una lista. Las directivas de configuración que admiten la sintaxis de lista pueden aparecer varias veces en la sección de configuración. El complemento mantiene el orden en el que aparecen las entradas cuando las interpreta. Por ejemplo, el ejemplo de abajo muestra dos directivas de configuración slave[] en la sección de configuración [myapp]. Si se realiza el equilibrado de carga rotativo para consultas de solo lectura, el complemento enviará la primera consulta de solo lectura al servidor MySQL mysql_slave_1 ya que es el primero de la lista. La segunda consulta de solo lectura será enviada al servidor MySQL mysql_slave_2 ya que es el segundo de la lista. Los resultados de las directivas de configuración que admiten la sintaxis de lista están ordenados de arriba a abajo según su aparación dentro de la sección de configuración.

Ejemplo #37 Sintaxis de lista

[myapp]
master[] = mysql_master_server
slave[] = mysql_slave_1
slave[] = mysql_slave_2

He aquí una breve explicación de las directivas de configuración que se pueden usar.

master[] string

URI de un servidor maestro de replicación MySQL. El URI sigue la sintaxis hostname[:port|unix_domain_socket].

El complemento admite el uso de un único servidor maestro.

Es obligatorio establece un servidor esclavo. El complemento notificará una advertencia sobre la conexión si el usuario ha fallado al proporcionar un servidor esclavo en la sección de configuración. La advertencia podría ser (mysqlnd_ms) Cannot find master section in config ((mysqlnd_ms) No se pudo encontrar una sección de maestros en la configuración). Además, el complemento puede establecer un código de error para el gestor de conexión tal como HY000/2000 (CR_UNKNOWN_ERROR). El mensaje de error correspondiente depende de la configuración del lenguaje.

slave[] string

URI de uno o más servidores esclavos de replicación MySQL. El URI sigue la sintaxis hostname[:port|unix_domain_socket].

El complemento admite el uso de uno o más servidores esclavos.

Es oblligatorio establecer un servidor esclavo. El complemento notificará una advertencia sobre la conexión si el usuario ha fallado al proporcionar al menos un servidor esclavo en la sección de configuración. La advertencia podría ser (mysqlnd_ms) Cannot find slaves section in config ((mysqlnd_ms) No se pudo encontrar una sección de esclavos en la configuración). Además, el complemento puede establecer un código de error para el gestor de conexión tal como HY000/2000 (CR_UNKNOWN_ERROR). El mensaje de error correspondiente depende de la configuración del lenguaje.

pick[] string

La política de equilibrado de carga (selección de servidores). Políticas soportadas: random, random_once (predeterminada), roundrobin, user.

Si no se establece ninguna política de equilibrado de carga, el complemento usará como predeterminada random_once. La política random_once elige un servidor esclavo aleatorio al ejecutar la primera sentencia de solo lectura. Este servidor esclavo será utilizado para todas las sentencias de solo lectura hasta que finalice la ejecución del script de PHP.

La política random eligirá un servidor aleatorio siempre que se ejecute una sentencia de solo lectura.

Si se usa roundrobin el complemento iterará sobre la lista de servidores esclavos configurados para elegir uno para la ejecución de sentencias. Si el complemento alcanza el final de la lista, volverá al comienzo de la misma y eligirá el primer servidor esclavo configurado.

El establecimiento de más de una política de equilibrado de carga en una sección de configuración solamente tiene sentido si se usa user y mysqlnd_ms_set_user_pick_server() juntos. Si la llamada de retorno del usuario falla al elegir un servidor, el complemento volverá a la segunda política de equilibrado de carga cofigurada.

failover string

Política de tolerancia de fallos. Políticas admitidas: disabled (predeterminada), master.

Si no se establece ninguna política de tolerancia a fallos, el complemento no realizará ninguna tolerancia a fallos automática (failover=disabled). Siempre que el complemento falle al conectarse a un servidor, emitirá una advertencia y establecerá el código y el mensaje del error de conexión. A partir de entonces, es responsabilidad de la aplicación manejar el error y, por ejemplo, reenviar la última sentencia para provocar la selección de otro servidor.

Si se usa failover=master, el complemento implícitamente usará la tolerancia a fallos de un esclavo. Por favor, revise la documentación de conceptos para informarse sobre los problemas y riesgos potenciales del uso de failover=master.

lazy_connections bool

Controla el uso de conexiones retardadas. Las conexiones retardadas son conexiones que no se abren antes de que un cliente envíe la primera conexión. Las conexiones retardadas son las predeterminadas.

Se recomeinda encarecidamente usar conexiones retardadas. Éstas ayudan a mantener bajo el número de conexiones abiertas. Si se desabilitan las conexiones retardas y, por ejemplo, se configura un servidor maestro de replicación MySQL y dos esclavos de replicación MySQL, el complemento abrirá tres conexiones en la primera llamada a la función de conexión, aunque la aplicación podría usar solamente la conexión maestra.

Las conexiones retardadas revelan un riesgo si se realizan un gran uso de acciones que cambian el estado de una conexión. El complemento no resolverá todas las acciones de cambio de estado de todas las conexiones de la agrupación de conexiones. Las pocas acciones resueltas son aplicadas solamente a conexiones ya abiertas. Las conexiones retardadas abiertas en el futuro no son afectadas. Si, por ejemplo, se cambia el conjunto de caracteres de la conexión usando una llamada a la API de MySQL para PHP, el complemento cambiará el conjunto de caracteres de todas las conexiones abiertas en uso. No recordraá el cambio del conjunto de caracteres para aplicarlo en las conexiones retardadas abiertas en el futuro. Como resultado, la agrupación de conexiones interna guardaría conexiones que usarían diferencites conjuntos de caracteres. Esto no es lo deseado. Recuerde que los conuntos de caracteres se toman en cuenta para el escapado.

master_on_write bool

Si se establece, el complemento usará únicamente el servidor maestro después de que se haya ejecutado la primera sentencia en el maestro. Las aplicaciones aún pueden enviar sentencias a los esclavos usando sugerencias SQL para invalidar la decisión automática.

Este ajuste puede ser útil con la demora de replicación. Si una aplicación ejecuta un INSERT, el complemento usará, de manera predeterminada, el maestro para ejecutar todas las sentencias siguientes, incluidas las sentencias SELECT. Esto ayuda a evitar problemas con las lecturas desde los esclavos que no hayan replicado aún el INSERT.

trx_stickiness string

Política de adhesión de transacciones. Las políticas admitidas son: disabled (predeterminada), master.

Característica experimental.

Este ajuste requiere la versión 5.4.0 o posterior. Si se usa con una versión de PHP anterior a la 5.4.0, el complemetno emitirá una advertencia como (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99 ((mysqlnd_ms) La estrategia trx_stickiness no está soportada antes de PHP 5.3.99).

Si no se establece ningun política de adhesión de transacciones o si se establece trx_stickiness=disabled, el complemento no considerará las transacciones. Por lo tanto, el complemento podrá realizar el equilibrado de carga de conexiones y el intercambio de conexiones en mitad de una trasacción. El complemento no es seguro con las transacciones. Se deben usar sugerencias SQL para evitar el intercambio de conexiones durante una transacción.

A partir de PHP 5.4.0, la bibliteca mysqlnd permite al complemento monitorizar el modo autocommit mediante las llamadas a la función set_autocommit() de la biblioteca. Si se establece set_stickiness=master y se deshabilita autocommit mediante una extensión de MySQL para PHP que invoque la llamada a la función interna set_autocommit() de la biblioteca mysqlnd, hará que el complemento considere el comienzo de una transacción. Luego, el complemento detiene el equilibrado de carga y dirige todas las setencias al servidor maestro hasta que autocommit sea habilitado. Por lo tanto, no son necesarias las sugerencias SQL.

Un ejemplo de una función de la API de MySQL para PHP que llama a la función interna trx_autocommit() de la biblioteca mysqlnd es mysqli_autocommit().

Aunque se establezca ser_stickiness=master, el complemento no puede considerar los cambios del modo autocommit causados por setnencias SQL como SET AUTOCOMMIT=0.

Probar el complemento

Nota:

Esta sección se aplica a la versión mysqlnd_ms 1.1.0 o posterior, no a la serie 1.0.

El conjunto de pruebas de PECL/mysqlnd_ms se encuentra en el directorio tests/ de la distribución del código fuente. El conjunto de pruebas consiste en unas pruebas phpt estándar, que están descriptas en la página web de PHP Quality Assurance Teams.

La ejecución de las pruebas requiere configurar de uno a cuatro servidores MySQL. Algunas pruebas no se conectan a MySQL de ningún mofo. Otras requieren un servidor. Algunas requieren dos servidores distintos. En algunos casos se usan dos servidores para emular una configuración de replicación. En otros casos se requieren un maestro y un esclavo existentes de una configuración de replicación MySQL. Las pruebas intentarán detectar cuántos servidores y qué tipo de servidores se dan. Si no se encuentran los servidores requeridos, la prueba será saltada automáticamente.

Antes de ejecutar las pruebas, edite tests/config.inc para configurar los servidores MySQL a usar durante las mismas.

La configuracion más básica es como sigue.

 putenv("MYSQL_TEST_HOST=localhost");
 putenv("MYSQL_TEST_PORT=3306");
 putenv("MYSQL_TEST_USER=root");
 putenv("MYSQL_TEST_PASSWD=");
 putenv("MYSQL_TEST_DB=test");
 putenv("MYSQL_TEST_ENGINE=MyISAM");
 putenv("MYSQL_TEST_SOCKET=");

 putenv("MYSQL_TEST_SKIP_CONNECT_FAILURE=1");
 putenv("MYSQL_TEST_CONNECT_FLAGS=0");
 putenv("MYSQL_TEST_EXPERIMENTAL=0");

 /* replication cluster emulation */
 putenv("MYSQL_TEST_EMULATED_MASTER_HOST=". getenv("MYSQL_TEST_HOST"));
 putenv("MYSQL_TEST_EMULATED_SLAVE_HOST=". getenv("MYSQL_TEST_HOST"));

 /* real replication cluster */
 putenv("MYSQL_TEST_MASTER_HOST=". getenv("MYSQL_TEST_EMULATED_MASTER_HOST"));
 putenv("MYSQL_TEST_SLAVE_HOST=". getenv("MYSQL_TEST_EMULATED_SLAVE_HOST"));

MYSQL_TEST_HOST, MYSQL_TEST_PORT y MYSQL_TEST_SOCKET definen el nombre del equipo anfitrión, el puerto TCP/IP y el socket de dominio Unix del servidor de la base de datos predeterminado. MYSQL_TEST_USER y MYSQL_TEST_PASSWD contienen el usuario y la contraseña necesarios para conectarse a la base de datos o esquema configurado con MYSQL_TEST_DB. Todos los servidores configurados han de tener el mismo usuario de base de datos configurado para proporcionar el acceso a la base de datos de prueba.

Con la sintaxis host, host:puerto o host:/ruta/al/socket se puede establecer un equipo anfitrión, un equipo anfitrión y un puerto o un equipo anfitrión y un socket suplentes para cualquier servidor.

putenv("MYSQL_TEST_SLAVE_HOST=192.168.78.136:3307"));
putenv("MYSQL_TEST_MASTER_HOST=myserver_hostname:/path/to/socket"));

Depuración y rastreo

El registro de depuración de mysqlnd se puede usar para depurar y rastrear las actividades de PECL/mysqlnd_ms. Al igual que mysqlnd, PECL/mysqlnd_ms añade información de rastreo al fichero de depuración de la bibliteca mysqlnd. Por favor, lea la directiva de configuración mysqlnd.debug de PHP para una descripción detallada de cómo configurar el registro de depuración.

Ejemplo de ajuste de configuración para activar el registro de depuración:

mysqlnd.debug=d:t:x:O,/tmp/mysqlnd.trace

Nota:

Esta característica solamente está disponible con una construcción de depuración de PHP. Funciona en Microsoft Windows si se usa una construcción de depuración de PHP y PHP fue compilado usando Microsoft Visual C versión 9 y superior.

El registro de depuración muestra las llamadas a las funciones de la biblioteca mysqlnd y del complemento PECL/mysqlnd_ms, similar a un registro de rastreo. Las llamadas de la biblioteca mysqlnd normalmente están prefijadas con mysqlnd_. Las llamadas internas a PECL/mysqlnd comienzan con mysqlnd_ms.

Extracto de ejemplo del registro de depuración (conectar):

[...]
>mysqlnd_connect
| info : host=myapp user=root db=test port=3306 flags=131072
| >mysqlnd_ms::connect
| | >mysqlnd_ms_config_json_section_exists
| | | info : section=[myapp] len=[5]
| | | >mysqlnd_ms_config_json_sub_section_exists
| | | | info : section=[myapp] len=[5]
| | | | info : ret=1
| | | <mysqlnd_ms_config_json_sub_section_exists
| | | info : ret=1
| | <mysqlnd_ms_config_json_section_exists
[...]

El registro de depuración no sólo es útila para los desarrolladores del complemento, sino también para encontrar la causa de los errores ocurridos. Por ejemplo, si una aplicación no maneja apropiadamente los errores y falla al registrar mensajes de error, la revisión del registro de depuración y rastreo podría ayudar a encontrar la causa. El uso del registro de depuración para depurar problemas de una aplicación debería considerarse solamente si no está disponible ninguna otra opción. Escribir el registro de depuración en el disco es una operación lenta y podría tener un impacto negativo sobre el rendimiento de la aplicación.

Extracto de ejemplo del registro de depuración (fallo de conexión):

[...]
| | | | | | | info : adding error [Access denied for user 'root'@'localhost' (using password: YES)] to the list
| | | | | | | info : PACKET_FREE(0)
| | | | | | | info : PACKET_FREE(0x7f3ef6323f50)
| | | | | | | info : PACKET_FREE(0x7f3ef6324080)
| | | | | | <mysqlnd_auth_handshake
| | | | | | info : switch_to_auth_protocol=n/a
| | | | | | info : conn->error_info.error_no = 1045
| | | | | <mysqlnd_connect_run_authentication
| | | | | info : PACKET_FREE(0x7f3ef63236d8)
| | | | | >mysqlnd_conn::free_contents
| | | | | | >mysqlnd_net::free_contents
| | | | | | <mysqlnd_net::free_contents
| | | | | | info : Freeing memory of members
| | | | | | info : scheme=unix:///tmp/mysql.sock
| | | | | | >mysqlnd_error_list_pdtor
| | | | | | <mysqlnd_error_list_pdtor
| | | | | <mysqlnd_conn::free_contents
| | | | <mysqlnd_conn::connect
[...]

El registro de rastreo también se puede usar para verificar el comportamiento correcto del mismo PECL/mysqlnd_ms, por ejemplo, para comprobar qué servidor ha sido seleccionado para la ejecución de una consulta y por qué.

Extracto de ejemplo del registro de depuración (decisión del complemento):

[...]
>mysqlnd_ms::query
| info : query=DROP TABLE IF EXISTS test
| >_mysqlnd_plugin_get_plugin_connection_data
| | info : plugin_id=5
| <_mysqlnd_plugin_get_plugin_connection_data
| >mysqlnd_ms_pick_server_ex
| | info : conn_data=0x7fb6a7d3e5a0 *conn_data=0x7fb6a7d410d0
| | >mysqlnd_ms_select_servers_all
| | <mysqlnd_ms_select_servers_all
| | >mysqlnd_ms_choose_connection_rr
| | | >mysqlnd_ms_query_is_select
[...]
| | | <mysqlnd_ms_query_is_select
[...]
| | | info : Init the master context
| | | info : list(0x7fb6a7d3f598) has 1
| | | info : Using master connection
| | | >mysqlnd_ms_advanced_connect
| | | | >mysqlnd_conn::connect
| | | | | info : host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0

En este caso, la sentencia DROP TABLE IF EXISTS test ha sido ejecutada. Observe que el string de la sentencia se muestra en el fichero de registro. Se podrían tomar medidas para restringir el acceso al registro por consideraciones de seguridad.

La sentencia ha sido equilibrada en carga usando la política de rotación ('round robin'), como se puede adivinar fácilmente del nombre de la función >mysqlnd_ms_choose_connection_rr. Ha sido enviada a un servidor maestro que se ejecuta en host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0.

Monitorización

La actividad del complemento se puede monitorizar usando el registro de rastreo de mysqlnd, las estadísticas de mysqlnd, las estadísticas del complemento mysqlnd_ms y herramientas de depuración externas de PHP. El uso del registro de rastreo debería limitarse a la depuración. Se recomienda usar las estadísticas del complemento para la monitorización.

La escritura de un registro de rastreo es una operación lenta. Si se usa una herramiento de depuración externa de PHP, consulte el manual del proveedor para el impacto de rendimiento y el tipo de información recopilada. En la mayoría de los casos, las herramientas de depuración externas proporcionarán pilas de llamadas. A menudo, es más difícil interpretar una pila de llamadas o un registro de rastreo que las estadísticas proporcionadas por el complemento.

Las estadísticas del complemento indican con qué frecuencia se ha usado un tipo de clúster (esclavo o maestro), por qué se ha usado el nodo, si se han usado conexiones retardadas y si se ha realizado una inyección de ID de transacciones global. La información de la monitorización proporcionada permite al usuario verificar las decisiones del complemento y planear los recursos del clúster basándose en el patrón de uso. La función mysqlnd_ms_get_stats() se usa para acceder a las estadísticas. Por favor, vea las descripciones de las funciones para obtener una lista de las estadísticas disponibles.

Las estadísticas se recopilan en función de cada proceso de PHP. Su alcance es un proceso de PHP. Dependiendo del modelo de desarrollo de PHP, un proceso puede servir una o múltiples peticiones web. Si se usa el modelo CGI, un proceso de PHP sirve una petición web. Si se usa FastCGI o modelos de servidores web prebifurcados, un modelo de PHP normalmente servirá múltiples peticiones web. Lo mismo ocurre en el caso de un servidor web con subprocesos. Observe que los hilos ejecutados en paralelo podrían actualizar las estadísticas en paralelo. Por lo tanto, si se usa un modelo de desarrolo de PHP con hilos, las estadísticas podrían ser modificadas por más de un script al mismo tiempo. Un script no puede depender del hecho de que vea solamente sus propios cambios realizados a las estadísticas.

Ejemplo #38 Comprobar la actividad del complemento en un modelo de desarrollo sin hilos

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
<?php
/* Equilibrado de carga siguiendo las reglas de la sección "myapp" del fichero de configuración del complemento (no se muestra) */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (mysqli_connect_errno())
  /* Por supuesto, su manejo de errores es más agradable... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

$stats_before = mysqlnd_ms_get_stats();
if ($res = $mysqli->query("SELECT 'Read request' FROM DUAL")) {
  var_dump($res->fetch_all());
}
$stats_after = mysqlnd_ms_get_stats();
if ($stats_after['use_slave'] <= $stats_before['use_slave']) {
  echo "Según las estadísticas, ¡la petición de lectura no se ha ejecutado en un esclavo!";
}
?>

Las estadísticas se agregan para todas las actividades del complemento y todas las conexión manejadas por el mismo. No es posible indicar cuánto contribuye un gestor de conexión en particular para el total de las estadísticas.

Utilizar la función de PHP register_shutdown_function() o la directiva de configuración de PHP auto_append_file es posiblemente más sencillo para volcar las estadísticas, por ejemplo, a un fichero de registro cuando un script finaliza. En lugar de usar un fichero de registro, también es posible enviar las estadísticas a una herramienta externa de monitorización para su registro y visualización.

Ejemplo #39 Registrar las estadístcias durante el cierre

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
error_log=/tmp/php_errors.log
<?php
function check_stats() {
  $msg = str_repeat("-", 80) . "\n";
  $msg .= var_export(mysqlnd_ms_get_stats(), true) . "\n";
  $msg .= str_repeat("-", 80) . "\n";
  error_log($msg);
}
register_shutdown_function("check_stats");
?>


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Relacionadas con sugerencias SQL

Ejemplo #1 Ejemplo demostrando el uso de constantes de mysqlnd_ms

El complemento de replicación y equilibrado de carga de mysqlnd (mysqlnd_ms) realiza la división de lectura/escritura. Esta división dirige las consultas de escritura a u servidor maestro de MySQL, y las consultas de solo lectura a servidores esclavos de MySQL. El complemento posee una lógica interna de división de lectura/escritura. Todas las consultas que empiecen con SELECT son consideradas consultas de solo lectura, las cuales son enviadas a un servidor esclavo de MySQL que esté enumerado en el fichero de configuración del complmento. Todas las demás consultas son dirigidas al servidor maestro de MySQL que también está especifcado en el fichero de configuración del complemento.

Las sugerencias SQL proporcionadas por un usuario se pueden usar para invalidar la división automática de lectura/escritura, para poder obtener control total sobre el proceso. Las sugerencias SQL siguen el estándar de los comentarios SQL. El complemento examinará el comienzo de un string de consulta para buscar un comentario SQL para ciertos comandos, los cuales luego controlarán la redirección de la consulta. Otros sistemas involucrados en el procesamiento de la consulta no se ven afectados por las sugerencias SQL, ya que dichos sistemas ignorarán los comentarios SQL.

El complemento admite tres sugerencias SQL para dirigir consultas a los servidores esclavos de MySQL, al servidor maestro de MySQL, o al último servidor MySQL usado. Las sugerencias SQL se deben colocar al comienzo de una consulta para que puedan ser reconocidas por el complemento.

Para una mejor portabilidad, se recomienda usar las constantes como string ( MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH y MYSQLND_MS_LAST_USED_SWITCH) en lugar de sus valores literales.

<?php
/* Usar constantes para una portabilidad máxima */
$master_query = "/*" . MYSQLND_MS_MASTER_SWITCH . "*/SELECT id FROM test";

/* Válido pero menos portable: usar literales en lugar de constantes */
$slave_query = "/*ms=slave*/SHOW TABLES";

printf("master_query = '%s'\n", $master_query);
printf("slave_query = '%s'\n", $slave_query);
?>

El resultado de los ejemplos sería:

master_query = /*ms=master*/SELECT id FROM test
slave_query = /*ms=slave*/SHOW TABLES

MYSQLND_MS_MASTER_SWITCH (string)
Sugerencia SQL usada para enviar una consulta al servidor maestro de replicación MySQL.
MYSQLND_MS_SLAVE_SWITCH (string)
Sugerencia SQL usada para enviar una consulta a uno de los servidores esclavos de replicación MySQL.
MYSQLND_MS_LAST_USED_SWITCH (string)
Sugerencia SQL usada para enviar una consulta al último servidor MySQL usado. Este servidor puede ser un servidor maestro o esclavo en una configuración de replicación MySQL.

Relacionadas con mysqlnd_ms_query_is_select()

MYSQLND_MS_QUERY_USE_MASTER (integer)
Si mysqlnd_ms_is_select() devuelve MYSQLND_MS_QUERY_USE_MASTER para una consulta dada, el mecanismo interno de división de lectura/escritura recomienda enviar la consulta a un servidor maestro de replicación MySQL.
MYSQLND_MS_QUERY_USE_SLAVE (integer)
Si mysqlnd_ms_is_select() devuelve MYSQLND_MS_QUERY_USE_SLAVE para una consulta dada, el mecanismo interno de división de lectura/escritura recomienda enviar la consulta a un servidor esclavo de replicación MySQL.
MYSQLND_MS_QUERY_USE_LAST_USED (integer)
Si mysqlnd_ms_is_select() devuelve MYSQLND_MS_QUERY_USE_LAST_USED para una consulta dada, el mecanismo interno de división de lectura/escritura recomienda enviar la consulta al último servidor usado.

Relacionadas con mysqlnd_ms_set_qos(), con el filtro de calidad de servicio y con el nivel de servicio

MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL (integer)
Se usa para solicitar el nivel de servicio de consistencia final desde la función mysqlnd_ms_set_qos(). La consistencia final es la calidad de servicio predeterminada cuando se lee desde un esclavo de replicación MySQL asíncrono. Los datos devueltos en este nivel de servicio puede ser antiguos o no, dependiendo de si los esclavos seleccionados han replicado los últimos cambios realizados desde el maestro de replicación MySQL.
MYSQLND_MS_QOS_CONSISTENCY_SESSION (integer)
Se usa para solicitar el nivel de servicio de consistencia de sesión desde la función mysqlnd_ms_set_qos(). La consistencia de sesción está definida como la lectura de sus escrituras. Al cliente se le garantiza que podrá ver sus últimos cambios.
MYSQLND_MS_QOS_CONSISTENCY_STRONG (integer)
Se usa para la solicitude del nivel de servicio de consistencia fuerte desde la función mysqlnd_ms_set_qos(). La consistencia fuerte se usa para asegurarse de que todos los clientes vean los cambios de los demás.
MYSQLND_MS_QOS_OPTION_GTID (integer)
Se usa como una opción de nivel de servicio con mysqlnd_ms_set_qos() para parametrizar la consistencia de sesión.
MYSQLND_MS_QOS_OPTION_AGE (integer)
Se usa como una opción de nivel de servicio con mysqlnd_ms_set_qos() para parametrizar la consistencia final.

Otras

Se puede obtener el número de versión del complemento usando MYSQLND_MS_VERSION o MYSQLND_MS_VERSION_ID. MYSQLND_MS_VERSION es el string que representa el número de versión de MYSQLND_MS_VERSION_ID, que es un entero como 10000. Los desarrolladores pueden calcular el número de versión como sigue.

Versión (parte) | Ejemplo
Mayor*10000 | 1*10000 = 10000
Menor*100 | 0*100 = 0
Parche | 0 = 0
MYSQLND_MS_VERSION_ID | 10000

MYSQLND_MS_VERSION (string)
Un string con la versión del complemento, por ejemplo, 1.0.0-prototype.
MYSQLND_MS_VERSION_ID (integer)
Número de versión del complemento, por ejemplo, 10000.


Funciones de mysqlnd_ms

Tabla de contenidos

  • mysqlnd_ms_dump_servers — Devuelve una lista con los servidores actualmente configurados
  • mysqlnd_ms_fabric_select_global — Cambiar al servidor de fragmentación global para una tabla dada
  • mysqlnd_ms_fabric_select_shard — Cambiar a los fragmentos
  • mysqlnd_ms_get_last_gtid — Devuelve el último ID de transacciones global
  • mysqlnd_ms_get_last_used_connection — Devuelve un array que describe la última conexión usada
  • mysqlnd_ms_get_stats — Devuelve la distribución consultas y las estadísticas de conexión
  • mysqlnd_ms_match_wild — Comprueba si el nombre de una tabla coincide con un patrón comodín
  • mysqlnd_ms_query_is_select — Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado
  • mysqlnd_ms_set_qos — Establece la calidad de servicio necesaria de un clúster
  • mysqlnd_ms_set_user_pick_server — Establece una llamada de retorno para la división de lectura/escritura definida por el usuario
  • mysqlnd_ms_xa_begin — Inicia una transacción distribuida/XA entre servidores de MySQL
  • mysqlnd_ms_xa_commit — Consigna una transacción distribuida/XA entre servidores de MySQL
  • mysqlnd_ms_xa_gc — Recolecta basura de transacciones XA no finalizadas después de algún error del servidor
  • mysqlnd_ms_xa_rollback — Revierte una transacción distribuida/XA entre servidores de MySQL


Devuelve una lista con los servidores actualmente configurados

  • « Funciones de mysqlnd_ms
  • mysqlnd_ms_fabric_select_global »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Devuelve una lista con los servidores actualmente configurados

mysqlnd_ms_dump_servers

(No hay información de versión disponible, podría estar únicamente en Git)

mysqlnd_ms_dump_servers — Devuelve una lista con los servidores actualmente configurados

Descripción

mysqlnd_ms_dump_servers ( mixed $connection ) : array

Devuelve una lista con los servidores actualmente configurados.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualquier función de conexión de las extensiones mysqli, mysql o PDO_MYSQL.

Valores devueltos

false en caso de error. De lo contrario, devuelve un array con dos entradas, masters y slaves, conteniendo cada una un array que enumera todos los servidores correspondientes.

La función se puede usar para comprobar y depurar la lista de servidores actualmente usados por el complemento. Es generalmente útil cuando la lista de serviodores cambia en tiempo de ejecución, por ejemplo, al usar MySQL Fabric.

Entradas de los servidores masters y slaves

Clave | Descripción | Versión
name_from_config | El nombre de la entrada de servidor desde config, si fuera aplicable. NULL si no está disponible un nombre de configuración. | Desde 1.6.0.
hostname | Nombre de host del servidor. | Desde 1.6.0.
user | Usuario de la base de datos usado para la autenticación en el servidor. | Desde 1.6.0.
port | Puerto TCP/IP del servidor. | Desde 1.6.0.
socket | Socket de domino Unix del server. | Desde 1.6.0.

Notas

Nota:

mysqlnd_ms_dump_servers() requiere mysqlnd_ms >> 1.6.0 de PECL.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_dump_servers()

{
    "myapp": {
        "master": {
            "master1": {
                "host":"master1_host",
                "port":"master1_port",
                "socket":"master1_socket",
                "db":"master1_db",
                "user":"master1_user",
                "password":"master1_pw"
            }
        },
        "slave": {
             "slave_0": {
                 "host":"slave0_host",
                 "port":"slave0_port",
                 "socket":"slave0_socket",
                 "db":"slave0_db",
                 "user":"slave0_user",
                 "password":"slave0_pw"
             },
             "slave_1": {
                 "host":"slave1_host"
             }
        }
    }
}
<?php
$link = mysqli_connect("myapp", "global_user", "global_pass", "global_db", 1234, "global_socket");
var_dump(mysqlnd_ms_dump_servers($link);
?>

El resultado del ejemplo sería:

array(2) {
  ["masters"]=>
  array(1) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "master1"
      ["hostname"]=>
      string(12) "master1_host"
      ["user"]=>
      string(12) "master1_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(14) "master1_socket"
    }
  }
  ["slaves"]=>
  array(2) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_0"
      ["hostname"]=>
      string(11) "slave0_host"
      ["user"]=>
      string(11) "slave0_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(13) "slave0_socket"
    }
    [1]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_1"
      ["hostname"]=>
      string(11) "slave1_host"
      ["user"]=>
      string(12) "gloabal_user"
      ["port"]=>
      int(1234)
      ["socket"]=>
      string(13) "global_socket"
    }
  }
}


Cambiar al servidor de fragmentación global para una tabla dada

  • « mysqlnd_ms_dump_servers
  • mysqlnd_ms_fabric_select_shard »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Cambiar al servidor de fragmentación global para una tabla dada

mysqlnd_ms_fabric_select_global

(No hay información de versión disponible, podría estar únicamente en Git)

mysqlnd_ms_fabric_select_global — Cambiar al servidor de fragmentación global para una tabla dada

Descripción

mysqlnd_ms_fabric_select_global ( mixed $connection , mixed $table_name ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Relacionada con MySQL Fabric.

Cambia la conexión a los nodos que manejas las consultas de fragmentación global para el nombre de tabla dado.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualquier función de conexión de las extensiones mysqli, mysql o PDO_MYSQL.

table_name

El nombre de la tabla sobre la que preguntar a Fabric.

Valores devueltos

false en caso de error. De lo contrario, true

Notas

Nota:

mysqlnd_ms_fabric_select_global() requiere mysqlnd_ms >> 1.6.0 de PECL.


Cambiar a los fragmentos

  • « mysqlnd_ms_fabric_select_global
  • mysqlnd_ms_get_last_gtid »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Cambiar a los fragmentos

mysqlnd_ms_fabric_select_shard

(No hay información de versión disponible, podría estar únicamente en Git)

mysqlnd_ms_fabric_select_shard — Cambiar a los fragmentos

Descripción

mysqlnd_ms_fabric_select_shard ( mixed $connection , mixed $table_name , mixed $shard_key ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Relacionada con MySQL Fabric.

Cambia la conexión a los fragmentos responsables del nombre de tabla y de la clave de fragmento dados.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualquier función de conexión de las extensiones mysqli, mysql o PDO_MYSQL.

table_name

El nombre de la tabla sobre la que preguntar a Fabric.

shard_key

La clave de fragmento sobre el que preguntar a Fabric.

Valores devueltos

false en caso de error. De lo contrario, true

Notas

Nota:

mysqlnd_ms_fabric_select_shard() requiere mysqlnd_ms >> 1.6.0 de PECL.


Devuelve el último ID de transacciones global

  • « mysqlnd_ms_fabric_select_shard
  • mysqlnd_ms_get_last_used_connection »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Devuelve el último ID de transacciones global

mysqlnd_ms_get_last_gtid

(PECL mysqlnd_ms >= 1.2.0)

mysqlnd_ms_get_last_gtid — Devuelve el último ID de transacciones global

Descripción

mysqlnd_ms_get_last_gtid ( mixed $connection ) : string

Devuelve un identificador de transacciones global que pertenece a una operación de escritura no más antigua que la última escritura realizada por el cliente. No se garantiza que el identificadro de transacciones global sea idéntico al creado por la transacción de escritura realizada por el cliente.

Parámetros

connection

Un gestor de conexión de PECL/mysqlnd_ms hacia un servidor MySQL del tipo PDO_MYSQL, mysqli> o ext/mysql. Este gestor de conexión se obtiene al abrir una conexión con un nombre de equipo anfitrión que coincide con la entrada del fichero de configuración de mysqlnd_ms usando cualquier de las tres extensiones del controlador de MySQL anteoriores.

Valores devueltos

Devuelve un ID de transacciones global (GTID) en caso de éxito. De otro modo, devuelve false.

La función mysqlnd_ms_get_last_gtid() devuelve el GTID obtenido al ejecutar una sentencia SQL desde la entrada fetch_last_gtid de la sección global_transaction_id_injection del fichero de configuración delcomplemento.

La función puede ser invocada después de que el GTID haya sido incrementado.

Notas

Nota:

mysqlnd_ms_get_last_gtid() requiere PHP >= 5.4.0 y PECL mysqlnd_ms >= 1.2.0. Internamente, se utiliza una funcionalidad en C de la biblioteca mysqlnd no disponble en PHP 5.3.

Observe que todas las versiones de producción de MySQL 5.6 no proporcionan clientes con suficiente información para usar GTID para forzar la consistencia de sesión. En el peor de los casos, el complemento eligirá solamente el maestro.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_get_last_gtid()

<?php
/* Abrir una conexión mysqlnd_ms usando la extensión mysqli, PDO_MySQL o mysql */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli)
  /* Por supuesto, su manejo de errores es mejor... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("DROP TABLE IF EXISTS test"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID después de la transacción %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* modo autoconsigna, transacción en el maestro, el GTID debe ser incrementado */
if (!$mysqli->query("CREATE TABLE test(id INT)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID después de la transacción %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

Ver también

  • IDs de Transacciones Globales


Devuelve un array que describe la última conexión usada

  • « mysqlnd_ms_get_last_gtid
  • mysqlnd_ms_get_stats »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Devuelve un array que describe la última conexión usada

mysqlnd_ms_get_last_used_connection

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_get_last_used_connection — Devuelve un array que describe la última conexión usada

Descripción

mysqlnd_ms_get_last_used_connection ( mixed $connection ) : array

Devuelve un array que describe la última conexión usada desde la agrupación de conexiones del complemento apuntada por el gestro de conexión del usuario. Si se usa el complemento, un gestor de conexión de usuario representa una agrupación de conexiones a bases de datos. No es posible indicar, desde las propiedades del gestor de conexión de usuario, a qué servidor de bases de datos de la agrupación apunta el gestor de conexión de usuario.

La función se puede usar para depurar o monitorizar PECL mysqlnd_ms.

Parámetros

connection

Un gestor de conexión MySQL obtenido desde cualquiera de las funciones de conexión de las extensiones mysqli, mysql o PDO_MYSQL.

Valores devueltos

false en caso de error. De otro modo, un array que describe la conexión usada para ejecutar la última sentencia.

El array que describe la conexión.

Propiedad | Descripción | Versión
scheme | El esquema de la conexión. Puede ser tcp://host:port o unix://host:socket. Si se han de distinguir las conexiones unas de otras se ha de usar una combinación de scheme y thread_id como clave única. Ni scheme ni thread_id por sí solos son suficientes para distinguir dos conexiones entre sí. Dos servidores puede asignar el mismo thread_id a dos conexiones diferentes. Por lo tanto, las conexiones de la agrupación podrían tener el mismo thread_id. También, no se debe depender de la unicidad de scheme de una agrupación. Los ingenieros de controlo de calidad podrían usar la misma instancia del servidor MySQL para dos roles lógicos distintos y añadirla múltiples veces a la agrupación. Esta técnica se usa, por ejemplo, en la batería de pruebas. | Desde 1.1.0.
host | El equipo anfitrión servidor de las bases de datos usado para la conexión. Este equipo solamente se establece con conexiones TCP/IP. Está vacío con conexiones de dominio Unix o tuberías con nombre de Windows. | Desde 1.1.0.
host_info | Una cadena de caracteres que representa el nombre del equipo anfitrión servidor y el tipo de conexión. | Desde 1.1.2.
port | El puerto del servidor de las bases de datos usado con la conexión. | Desde 1.1.0.
socket_or_pipe | El socket de dominio Unix o la tubería con nombre de Windows usados con la conexión. Este valor está vacío para conexiones TCP/IP. | Desde 1.1.2.
thread_id | El id del subproceso de conexión. | Desde 1.1.0.
last_message | Un mensaje de información obtenido desde la función mysql_info() de la API en C de MySQL. Véase mysqli_info() para una descripción. | Desde 1.1.0.
errno | El código del error. | Desde 1.1.0.
error | El mensaje de error. | Desde 1.1.0.
sqlstate | El códgio SQLstate del error. | Desde 1.1.0.

Notas

Nota:

mysqlnd_ms_get_last_used_connection() requiere PHP >= 5.4.0 y PECL mysqlnd_ms >= 1.2.0. Internamente, se utiliza una funcionalidad en C de la biblioteca mysqlnd no disponble en PHP 5.3.

Ejemplos

Este ejemplo asume que myapp se refiere a una sección del fichero de configuración del complemento y que representa una agrupación de conexiones.

Ejemplo #1 Ejemplo de mysqlnd_ms_get_last_used_connection()

<?php
$enlace = new mysqli("myapp", "usuario", "contraseña", "base_datos");
$resultado = $enlace->query("SELECT 1 FROM DUAL");
var_dump(mysqlnd_ms_get_last_used_connection($enlace));
?>

El resultado del ejemplo sería:

array(10) {
  ["scheme"]=>
  string(22) "unix:///tmp/mysql.sock"
  ["host_info"]=>
  string(25) "Localhost via UNIX socket"
  ["host"]=>
  string(0) ""
  ["port"]=>
  int(3306)
  ["socket_or_pipe"]=>
  string(15) "/tmp/mysql.sock"
  ["thread_id"]=>
  int(46253)
  ["last_message"]=>
  string(0) ""
  ["errno"]=>
  int(0)
  ["error"]=>
  string(0) ""
  ["sqlstate"]=>
  string(5) "00000"
}


Devuelve la distribución consultas y las estadísticas de conexión

  • « mysqlnd_ms_get_last_used_connection
  • mysqlnd_ms_match_wild »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Devuelve la distribución consultas y las estadísticas de conexión

mysqlnd_ms_get_stats

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_get_stats — Devuelve la distribución consultas y las estadísticas de conexión

Descripción

mysqlnd_ms_get_stats ( ) : array

Devuelve un array con las estadísticas recopiladas por el complemento de replicación y equilibrado de carga.

El ajuste de configuración de PHP mysqlnd_ms.collect_statistics controla la recopilación de estadísticas. Dicha recopilación está deshabilitada de forma predeterminada por motivos de rendimiento.

El ámbito de la estadísticas es el proceso de PHP. Dependiendo de modelo de desarrollo, un proceso de PHP puede manejar una o múltiples peticiones.

Las estadísticas se agregan para todas las conexiones y todos los gestores de almacenamiento. No es posible indicar cuántas consultas que se originan desde las llamadas a la API de mysqli, PDO_MySQL o mysql han contribuido a los valores de los datos agregados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve null si la directiva de configuración de PHP mysqlnd_ms.enable ha deshabilitado el complemento. De otro modo, devuelve un array de estadísticas.

El array de estadísticas.

Estadística | Descripción | Versión
use_slave

La semántica de esta estadística ha cambiado entre las versiones 1.0.1 - 1.1.0.

El significado para la versión 1.0.1 es como sigue. Número de sentencias consideradas de solo lectura por el analizador de consultas interno. No están incluidas ni las sentencias que comienzan con una sugerencia SQL para forzar el uso de esclavos, ni las sentencias dirigidas a un esclavos mediante una llamada de retorno definida por el usuario. El número total de sentencias enviadas a los esclavos es use_slave + use_slave_sql_hint + use_slave_callback.

PECL/mysqlnd_ms 1.1.0 introduce el nuevo concepto de filtros encadenados. Las estadísticas ahora son establecidas por el filtro de equilibrado de carga interno. Con la versión 1.1.0, dicho filtro siempre está en el último lugar de la cadena de filtros, si se usa. En futuras versiones un filtro de equilibrado de carga podrían seguirle otros filtros, ocasionando otro cambio en el significado de la estadísica. Si, en un futuro, un a filtro de equilibrado de carga le sigue otro filtro, ya no se garantizará que la sentencia, la cual incrementa use_slave, sea ejecutada en los esclavos.

El significado para la versión 1.1.0 es como sigue. Número de sentencias enviadas a los esclavos. No están incluidas las sentencias dirigidas a un esclavo mediante el filtro 'user' (una llamada de retorno definida por el usuario). Lo último se cuenta mediante use_slave_callback.

Desde 1.0.0.
use_master

La semántica de esta estadística ha cambiado entre las versiones 1.0.1 - 1.1.0.

El significado para la versión 1.0.1 es como sigue. Número de sentencias no consideradas de solo lectura por el analizador de consultas interno. No están incluidas mi las sentencias que comienzan con una sugerencia SQL para forzar el uso del maestro, ni las sentencias dirigidas a un maestro mediante una llamada de retorno definida por el usuario. El número total de sentencias enviadas al maestro es use_master + use_master_sql_hint + use_master_callback.

PECL/mysqlnd_ms 1.1.0 introduce el nuevo concepto de filtros encadenados. Las estadísticas ahora son establecidas por el filtro de equilibrado de carga interno. Con la versión 1.1.0, dicho filtro siempre está en el último lugar de la cadena de filtros, si se usa. En futuras versiones un filtro de equilibrado de carga podrían seguirle otros filtros, ocasionando otro cambio en el significado de la estadísica. Si, en un futuro, un a filtro de equilibrado de carga le sigue otro filtro, ya no se garantizará que la sentencia, la cual incrementa use_master, sea ejecutada en los esclavos.

El significado para la versión 1.1.0 es como sigue. Número de sentencias enviadas a los maestros. No están incluidas las sentencias dirigidas a un maestro mediante el filtro 'user' (una llamada de retorno definida por el usuario). Lo último se cuenta mediante use_master_callback.

Desde 1.0.0.
use_slave_guess | Número de sentencias que el analizador de consultas interno recomienda enviar a un esclavo debido a que no contienen una sugerencia SQL para forzar el uso de un servidor en particular. Dicha recomendación podría ser invalidada en la siguiente. No se garantiza que la sentencia sea ejecutada en un esclavo. Este número es las veces que la función interno is_select ha supuesto que un esclavo será usado. Véase también la función del espacio de usuario mysqlnd_ms_query_is_select(). | Desde 1.1.0.
use_master_guess | Número de sentencias que el analizador de consultas interno recomienda enviar a un maestro debido a que no contienen una sugerencia SQL para forzar el uso de un servidor en particular. Dicha recomendación podría ser invalidada en la siguiente. No se garantiza que la sentencia sea ejecutada en un esclavo. Este número es las veces que la función interno is_select ha supuesto que un maestro será usado. Véase también la función del espacio de usuario mysqlnd_ms_query_is_select(). | Desde 1.1.0.
use_slave_sql_hint | Número de sentencias enviadas a un esclavo debido a que la sentencia comienza con la sugerencia SQL para forzar el uso del esclavo. | Desde 1.0.0.
use_master_sql_hint | Número de sentencias enviadas a un maestro debido a que la sentencia comienza con la sugerencia SQL para forzar el uso del maestro. | Desde 1.0.0.
use_last_used_sql_hint | Número de sentencias enviadas al servidor que ejecutó la sentencia anterior, debido a que la sentencia comienza con la sugerencia SQL para forzar el uso del servidor usado anteriormente. | Desde 1.0.0.
use_slave_callback | Número de sentencias enviadas a un esclavo debido a que una llamada de retorno definida por el usuario ha elegido un servidor esclavo para la ejecución de sentencias. | Desde 1.0.0.
use_master_callback | Número de sentencias enviadas a un maestro debido a que una llamada de retorno definida por el usuario ha elegido un servidor maestro para la ejecución de sentencias. | Desde 1.0.0.
non_lazy_connections_slave_success | Número de conexiones a esclavos abiertas con éxito desde configuraciones que no usan conexiones retardadas. El número total de conexiones a esclavos abiertas con éxito es non_lazy_connections_slave_success + lazy_connections_slave_success | Desde 1.0.0.
non_lazy_connections_slave_failure | Número de intentos fallidos de conexión a esclavos desde configuraciones que no usan conexiones retardadas. El número total de intento fallidos de conexión a esclavos es non_lazy_connections_slave_failure + lazy_connections_slave_failure | Desde 1.0.0.
non_lazy_connections_master_success | Número de conexiones a maestros abiertas con éxito desde configuraciones que no usan conexiones retardadas. El número total de conexiones a maestros abiertas con éxito es non_lazy_connections_master_success + lazy_connections_master_success | Desde 1.0.0.
non_lazy_connections_master_failure | Número de intentos fallidos de conexión a maestros desde configuraciones que no usan conexiones retardadas. El número total de intento fallidos de conexión a maestros es non_lazy_connections_master_failure + lazy_connections_master_failure | Desde 1.0.0.
lazy_connections_slave_success | Número de conexiones a esclavos abiertas con éxito desde configuraciones que usan lazy connections. | Desde 1.0.0.
lazy_connections_slave_failure | Número de intentos fallidos de conexión a esclavos desde configuraciones que usan conexiones retardadas. | Desde 1.0.0.
lazy_connections_master_success | Número de conexiones a maestros abiertas con éxito desde configuraciones que usan conexiones retardadas. | Desde 1.0.0.
lazy_connections_master_failure | Número de intentos fallidos de conexión a maestros desde configuraciones que usan conexiones retardadas. | Desde 1.0.0.
trx_autocommit_on | Número de activaciones del modo autocommit mediante llamadas a la API. Este número se puede usar para monitorizar la actividad relacionada con el ajuste de configuración del complemento trx_stickiness. Si, por ejemplo, se quiere conocer si una cierta llamada a la API invoca a la función trx_autocommit() de la biblioteca mysqlnd, la cual es un requisito para trx_stickiness, se podría llamar a la función de la API de usuario en cuestión y comprobar si la estadística ha cambiado. La estadística es modificada solamente por el método trx_autocommit() interno de complemento. | Desde 1.0.0.
trx_autocommit_off | Número de desactivaciones del modo autocommit mediante llamadas a la API. | Desde 1.0.0.
trx_master_forced | Número de sentencias redirigidas al maestro mientras trx_stickiness=master y el modo autocommit están deshabilitados. | Desde 1.0.0.
gtid_autocommit_injections_success | Número de inyeccioines SQL realizadas con éxito en el modo 'autocommit' como parte de la emulación del id de transacciones global en el lado del cliente del complemento. | Desde 1.2.0.
gtid_autocommit_injections_failure | Número de inyeccioines SQL fallidas en el modo 'autocommit' como parte de la emulación del id de transacciones global en el lado del cliente del complemento. | Desde 1.2.0.
gtid_commit_injections_success | Número de inyeccioines SQL realizadas con éxito en el modo 'commit' como parte de la emulación del id de transacciones global en el lado del cliente del complemento. | Desde 1.2.0.
gtid_commit_injections_failure | Número de inyeccioines SQL fallidas en el modo 'commit' como parte de la emulación del id de transacciones global en el lado del cliente del complemento. | Desde 1.2.0.
gtid_implicit_commit_injections_success | Número de inyecciones SQL realizadas con éxito cuando la consignación implícita es detectada como parte de la emulación del id de transacciones global en el lado del cliente del complemento. La consignación implícita sucede, por ejemplo, cuando el modo 'autocommit' se ha desactivado, se ejecuta una consulta y se habilita el modo 'autocommit' de nuevo. En este caso, la sentencia será consignada por el servidor y el SQL a mantener es inyectado antes de que el modo 'autocommit' sea rehabilitado. Otra secuencia que causa una consignación implícita es begin(), query(), begin(). La segunda llamada a begin() consignará implícitamente la transacción iniciada por la primera llamada a begin(). begin() hace referencia llamadas a una biblioteca interna, no a llamadas a la API de usuario de PHP. | Desde 1.2.0.
gtid_implicit_commit_injections_failure | Número de inyecciones SQL fallidas cuando la consignación implícita es detectada como parte de la emulación del id de transacciones global en el lado del cliente del complemento. La consignación implícita sucede, por ejemplo, cuando el modo 'autocommit' se ha desactivado, se ejecuta una consulta y se habilita el modo 'autocommit' de nuevo. En este caso, la sentencia será consignada por el servidor y el SQL a mantener es inyectado antes de que el modo 'autocommit' sea rehabilitado. | Desde 1.2.0.
transient_error_retries | Cuántas veces ha sido reintentada una operación cuando se detectó un error transitorio. Véase también el ajuste transient_error del fichero de configuración del complemento. | Desde 1.6.0.
fabric_sharding_lookup_servers_success | Número de llamadas exitosas a procedimientos remotos de sharding.lookup_servers a MySQL Fabric. Se considera que una llamada tiene éxito si el complemento pudo conectar con MySQL Fabric y obtener cualquier respuesta. Esta respuesta podría o no ser comprendida por el complemento. El éxito se refiere solamente al transporte en red. Si la respuesta no fuera comprendida o indicara una condición de error, fabric_sharding_lookup_servers_xml_failure se incrementará. | Desde 1.6.0.
fabric_sharding_lookup_servers_failure | Número de llamadas fallidas a procedimientos remotos de sharding.lookup_servers a MySQL Fabric. Se considera que una llamada a un procedimiento remoto es fallida si existió un error de red al conectarse a, al escribir en o al leer de MySQL Fabric. | Desde 1.6.0.
fabric_sharding_lookup_servers_time_total | Tiempo usado en conectarse a, escribir en y leer de MySQL Fabric durante la llamada a procedimientos remotos de sharding.lookup_servers. El valor se totaliza para todas las llamadas. El tiempo se mide en microsegundos. | Desde 1.6.0.
fabric_sharding_lookup_servers_bytes_total | Número total de bytes recibidos de MySQL Fabric en respuesta a llamadas de sharding.lookup_servers. | Desde 1.6.0.
fabric_sharding_lookup_servers_xml_failure | Frecuencia con que no se entendió una respuesta de MySQL Fabric a llamadas de sharding.lookup_servers. Observe que la implementación experimental actual no distingue entre errores válidos devueltos y réplicas malformadas. | Desde 1.6.0.
xa_begin | Cuántas transacciones XA/distribuidas han sido iniciadas empleando mysqlnd_ms_xa_begin(). | Desde 1.6.0.
xa_commit_success | Cuántas transacciones XA/distribuidas han sido consignadas con éxito empleando mysqlnd_ms_xa_commit(). | Desde 1.6.0.
xa_commit_failure | Cuántas transacciones XA/distribuidas fallaron al consignarlas durante mysqlnd_ms_xa_commit(). | Desde 1.6.0.
xa_rollback_success | Cuántas transacciones XA/distribuidas han sido revertidas con éxito empleando mysqlnd_ms_xa_rollback(). La cifra no incluye las reversiones implícitas realizadas como resultado de un fallo de mysqlnd_ms_xa_commit(). | Desde 1.6.0.
xa_rollback_failure | Cuántas transacciones XA/distribuidas no se pudieron revertir. Esto incluye fallos de mysqlnd_ms_xa_rollback(), aunque también fallos durante la reversión al cerrar la conexión, si rollback_on_close está establecido. Véase también xa_rollback_on_close más abajo. | Desde 1.6.0.
xa_participants | Número total de participantes en cualquier transacción XA iniciada con mysqlnd_ms_xa_begin(). | Desde 1.6.0.
xa_rollback_on_close | Cuántas transacciones XA han sido revertidas implítamente cuando una conexión se cerró y rollback_on_close está establecido. Dependiendo de las políticas de código, esto podría indicar un defecto en el código, por lo que podría ser preferible limpiar recursos explícitamente. | Desde 1.6.0.
pool_masters_total | Número de servidores maestros (conexiones) de la agrupación de conexiones interna. | Desde 1.6.0.
pool_slaves_total | Número de servidores esclavos (conexiones) de la agrupación de conexiones interna. | Desde 1.6.0.
pool_masters_active | Número de servidores maestros (conexiones) de la agrupación de conexiones interna que se emplean actualmente para elegir una conexión. | Desde 1.6.0.
pool_slaves_active | Número de servidores esclavos (conexiones) de la agrupación de conexiones interna que se emplean actualmente para elegir una conexión. | Desde 1.6.0.
pool_updates | Con qué frecuencia ha sido reemplazada una lista de conexiones activas y ha sido instalado un nuevo conjunto de servidores maestros y esclavos. | Desde 1.6.0.
pool_master_reactivated | Con qué frecuencia ha sido reutilzada una conexión maestra después de ser eliminada de la lista activa. | Desde 1.6.0.
pool_slave_reactivated | Con qué frecuencia ha sido reutilzada una conexión esclava después de ser eliminada de la lista activa. | Desde 1.6.0.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_get_stats()

<?php
printf("mysqlnd_ms.enable = %d\n", ini_get("mysqlnd_ms.enable"));
printf("mysqlnd_ms.collect_statistics = %d\n", ini_get("mysqlnd_ms.collect_statistics"));
var_dump(mysqlnd_ms_get_stats());
?>

El resultado del ejemplo sería:

mysqlnd_ms.enable = 1
mysqlnd_ms.collect_statistics = 1
array(26) {
  ["use_slave"]=>
  string(1) "0"
  ["use_master"]=>
  string(1) "0"
  ["use_slave_guess"]=>
  string(1) "0"
  ["use_master_guess"]=>
  string(1) "0"
  ["use_slave_sql_hint"]=>
  string(1) "0"
  ["use_master_sql_hint"]=>
  string(1) "0"
  ["use_last_used_sql_hint"]=>
  string(1) "0"
  ["use_slave_callback"]=>
  string(1) "0"
  ["use_master_callback"]=>
  string(1) "0"
  ["non_lazy_connections_slave_success"]=>
  string(1) "0"
  ["non_lazy_connections_slave_failure"]=>
  string(1) "0"
  ["non_lazy_connections_master_success"]=>
  string(1) "0"
  ["non_lazy_connections_master_failure"]=>
  string(1) "0"
  ["lazy_connections_slave_success"]=>
  string(1) "0"
  ["lazy_connections_slave_failure"]=>
  string(1) "0"
  ["lazy_connections_master_success"]=>
  string(1) "0"
  ["lazy_connections_master_failure"]=>
  string(1) "0"
  ["trx_autocommit_on"]=>
  string(1) "0"
  ["trx_autocommit_off"]=>
  string(1) "0"
  ["trx_master_forced"]=>
  string(1) "0"
  ["gtid_autocommit_injections_success"]=>
  string(1) "0"
  ["gtid_autocommit_injections_failure"]=>
  string(1) "0"
  ["gtid_commit_injections_success"]=>
  string(1) "0"
  ["gtid_commit_injections_failure"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_success"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_failure"]=>
  string(1) "0"
  ["transient_error_retries"]=>
  string(1) "0"
}

Ver también

  • Configuración en tiempo de ejecución
  • mysqlnd_ms.collect_statistics
  • mysqlnd_ms.enable
  • Monitorización


Comprueba si el nombre de una tabla coincide con un patrón comodín

  • « mysqlnd_ms_get_stats
  • mysqlnd_ms_query_is_select »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Comprueba si el nombre de una tabla coincide con un patrón comodín

mysqlnd_ms_match_wild

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_match_wild — Comprueba si el nombre de una tabla coincide con un patrón comodín

Descripción

mysqlnd_ms_match_wild ( string $table_name , string $wildcard ) : bool

Comprueba si el nombre de una tabla coincide con un patrón comodín.

Esta función no tiene mucha relevancia práctica con PECL mysqlnd_ms 1.1.0 debido a que el complemento no admite añun el filtrado de tablas de replicación MySQL.

Parámetros

table_name

El nombre de la tabla para comprobar si coincide con el patrón comodín.

wildcard

El patrón comodín a comprobar con el nombre nombre de la tabla. El patrón admite los mismos parámetros de sustición que los filtros de replicación MySQL.

Los filtros de replicación MySQL se pueden configurar usando las opciones de configuración del Servidor MySQL --replicate-wild-do-table y --replicate-wild-do-db. Por favor, consulte el Manual de referencia de MySQL para aprender más sobre esta característica del Servidor MySQL.

Los parámetros de sustición admitidos son:

  • % - cero o más literales
  • _ - un literal

Los parámetros de sustitución se pueden escapar con \.

Valores devueltos

Devuelve true si table_name coincide con wildcard. Si no, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_match_wild()

<?php
var_dump(mysqlnd_ms_match_wild("schema_name.table_name", "schema%"));
var_dump(mysqlnd_ms_match_wild("abc", "_"));
var_dump(mysqlnd_ms_match_wild("table1", "table_"));
var_dump(mysqlnd_ms_match_wild("asia_customers", "%customers"));
var_dump(mysqlnd_ms_match_wild("funny%table","funny\%table"));
var_dump(mysqlnd_ms_match_wild("funnytable", "funny%table"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)


Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado

  • « mysqlnd_ms_match_wild
  • mysqlnd_ms_set_qos »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado

mysqlnd_ms_query_is_select

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_query_is_select — Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado

Descripción

mysqlnd_ms_query_is_select ( string $query ) : int

Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado

El mecanismo interno de división de lectura/escritura del complemento se usará para analizar el string de la consulta para recomendar dónde enviar la misma. El mecanismo interno de división de lectura/escritura es muy básico y simple. El complemento recomendará enviar todas las consultas al servidor maestro de replicación MySQL excepto aquellas que comienzan con SELECT, o con una sugerencia SQL que fuerce el envío de la consulta a un servidor esclavo. Debido al algoritmo básico, aunque rápido, el complemento podría proponer ejecutar algunas sentencias de solo lectura tal como SHOW TABLES en el maestro de replicación.

Parámetros

query

El string de la consulta a probar.

Valores devueltos

Un valor de retorno de MYSQLND_MS_QUERY_USE_MASTER indica que la consulta debería enviarse al servidor maestro de replicación MySQL. La función devuelve un valor de MYSQLND_MS_QUERY_USE_SLAVE si la consulta puede ejecutarse en un esclavo debido a que la considera de solo lectura. Un valor de retorno de MYSQLND_MS_QUERY_USE_LAST_USED recomienda la ejecución de la consulta en el último servidor utilizado. Éste puede ser un servidor maestro de replicación MySQL o un servidor esclavo de replicación MySQL.

Si la división de lecutra/escritura está deshabilitada por el ajuste mysqlnd_ms.disable_rw_split, la función siempre devolverá MYSQLND_MS_QUERY_USE_MASTER o MYSQLND_MS_QUERY_USE_LAST_USED.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_query_is_select()

<?php
function is_select($consulta)
{
 switch (mysqlnd_ms_query_is_select($consulta))
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("'%s' debería ejecutarse en el maestro.\n", $consulta);
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   printf("'%s' debería ejecutarse en un esclavo.\n", $consulta);
   break;
  case MYSQLND_MS_QUERY_USE_LAST_USED:
   printf("'%s' debería ejecutarse en el servidor que ejecutó la consulta anterior\n", $consulta);
   break;
  default:
   printf("No hay sugerencias donde ejecutar '%s', se recomienda volver al maestro\n", $consulta);
   break;
 }
}

is_select("INSERT INTO test(id) VALUES (1)");
is_select("SELECT 1 FROM DUAL");
is_select("/*" . MYSQLND_MS_LAST_USED_SWITCH . "*/SELECT 2 FROM DUAL");
?>

El resultado del ejemplo sería:

INSERT INTO test(id) VALUES (1) debería ejecutarse en el maestro.
SELECT 1 FROM DUAL debería ejecutarse en un esclavo.
/*ms=last_used*/SELECT 2 FROM DUAL debería ejecutarse en el servidor que ejecutó la consulta anterior

Ver también

  • Constantes predefinidas
  • El filtro user
  • Configuración en tiempo de ejecución
  • mysqlnd_ms.disable_rw_split
  • mysqlnd_ms.enable


Establece la calidad de servicio necesaria de un clúster

  • « mysqlnd_ms_query_is_select
  • mysqlnd_ms_set_user_pick_server »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Establece la calidad de servicio necesaria de un clúster

mysqlnd_ms_set_qos

(PECL mysqlnd_ms < 1.2.0)

mysqlnd_ms_set_qos — Establece la calidad de servicio necesaria de un clúster

Descripción

mysqlnd_ms_set_qos ( mixed $connection , int $service_level , int $service_level_option = ? , mixed $option_value = ? ) : bool

Establece la calidad de servicio necesaria de un clúster. Un clúster de bases de datos proporciona una cierta calidad de servicio al usuario dependiendo de su arquitectura. Un aspecto muy importante de la calidad de servicio es el nivel de consistencia que el clúster puede ofrece. La consistencia predeterminada de un clúster de replicación MySQL asíncrono es la final para lecturas de esclavos: un esclavo puede servir datos antiguos, datos actuales, o podría no poseer la petición de datos, debido a que no está sincronizado con el maestro. En un clúster de replicación MySQL, únicamente los accesos al maestro pueden proporcionar consistencia fuerte, la cual promete que todos los clientes ven los cambios de los demás clientes.

PECL/mysqlnd_ms oculta la complejidad de la elección de los nodos apropiados para llevar a cabo un cierto nivel de servicio de un clúster. El filtro "Calidad de Servicio" implementa la lógica necesaria. El filtro puede configurarse tanto en el fichero de configuración del comlemento como en tiempo de ejecución usando mysqlnd_ms_set_qos().

Se pueden lograr resultados similares con PECL mysqlnd_ms < 1.2.0, si se usan sugerencias SQL para forzar el uso de un tipo de nodo en particular, o usando la opción de configuración master_on_write del complemento. El primer método requiere más código y causa más trabajo en el lado de la aplicación. El segundo método es menos refinado que usar el filtro de calidad de servicio. Los ajustes realizados a través de la llamada a la función se puden revertir, como se muestra en el ejemplo de abajo. Éste cabia temporalmente a un nivel de servicio superior (consistencia de sesión, lectura de sus escrituras) y vuelve al predeterminado del clúster después de haber realizado todas las operaciones que requieren el servicio mejor. De esta forma, la carga de lectura en el maestro se puede minimizar en comparación con el uso de master_on_write, el cual continuaría usando el maestro después de la primera escritura.

Desde 1.5.0, las llamadas fallarán cuando se realizan en mitad de una transacción si la adhesión de transacciones está habilitada y se han detecetado límites en la transacción. properly.

Parámetros

connection

Un gestor de conexión de PECL/mysqlnd_ms hacia un servidor MySQL del tipo PDO_MYSQL, mysqli> o ext/mysql para el cual establecer un nivel de servicio. Este gestor de conexión se obtiene al abrir una conexión con un nombre de equipo anfitrión que coincide con la entrada del fichero de configuración de mysqlnd_ms usando cualquier de las tres extensiones del controlador de MySQL anteoriores.

service_level

El nivel de servicio solicitado: MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_CONSISTENCY_SESSION o MYSQLND_MS_QOS_CONSISTENCY_STRONG.

service_level_option

Una opción para parametrizar el nivel de servicio solicitado. Esta opción puede ser MYSQLND_MS_QOS_OPTION_GTID o MYSQLND_MS_QOS_OPTION_AGE.

La opción MYSQLND_MS_QOS_OPTION_GTID se puede usar para refinar el nivel de servcicio MYSQLND_MS_QOS_CONSISTENCY_SESSION. Se debe combinar con un cuarto parámetro, option_value. Éste debería ser un ID de transacciones global obtenido desde mysqlnd_ms_get_last_gtid(). Si se establece, el complemento considerará los servidores maestros y los esclavos asíncronos para la consistencia de sesión (lectura de sus escrituras). Si no, solamente se usarán los maestros para conseguir la consistencia de sesión. Un esclavo se considera acutalizado y comprobado si ya ha replicado el ID de transacciones global de option_value. Observe que la búsqueda de esclavos apropiados es una operación cara y lenta. Use con moderación esta característica, si el maestro no puede manejar solo la carga de lectura.

La opción MYSQLND_MS_QOS_OPTION_AGE se puede combinar con el nivel de servicio MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, para filtrar esclavos asíncronos que se demoren respecto al maestro más segundos que option_value. Si se establece, el complemento solamente considerará a los esclavos para la lectura si SHOW SLAVE STATUS notifica que Slave_IO_Running=Yes, Slave_SQL_Running=Yes y Seconds_Behind_Master <= option_value. Observe que la búsqueda de esclavos apropiados es una operación cara y lenta. Use con moderación esta característica en la versión 1.2.0. En versiones futuras se podría mejorar el algoritmo usado para identificar candidatos. Véase el manual de referencia de MySQL para la precisión, exactitud y limitaciones del comando administrativo SHOW SLAVE STATUS de MySQL.

option_value

El valor del parámetro de la opción del nivel de servicio. Véase también el parámetro service_level_option.

Valores devueltos

Devuelve true si el nivel de servicio de la conexión ha sido cambiado en la solicitud. De otro modo, devuelve false

Notas

Nota:

mysqlnd_ms_set_qos() requiere PHP >= 5.4.0 y PECL mysqlnd_ms >= 1.2.0. Internamente, se utiliza una funcionalidad en C de la biblioteca mysqlnd no disponble en PHP 5.3.

Observe que todas las versiones de producción de MySQL 5.6 no proporcionan clientes con suficiente información para usar GTID para forzar la consistencia de sesión. En el peor de los casos, el complemento eligirá solamente el maestro.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_set_qos()

<?php
/* Abrir una conexión mysqlnd_ms usando la extensión mysqli, PDO_MySQL o mysql */
$mysqli = new mysqli("myapp", "nombre_usuario", "contraseña", "base_datos");
if (!$mysqli)
  /* Por supuesto, su manejo de errores es mejor... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Consistencia de sesión: lectura de sus escrituras */
$ret = mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION);
if (!$ret)
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Se usará el maestro y se devolverán datos actuales, el cliente puede ver su última escritura */
if (!$res = $mysqli->query("SELECT item, price FROM orders WHERE order_id = 1"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Volver a lo predeterminado: usar todos los esclavos y maestros permitidos, se pueden obtener datos antiguos */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

Ver también

  • mysqlnd_ms_get_last_gtid() - Devuelve el último ID de transacciones global
  • Concepto de nivel de servicio y consitencia
  • Concepto de filtro


Establece una llamada de retorno para la división de lectura/escritura definida por el usuario

  • « mysqlnd_ms_set_qos
  • mysqlnd_ms_xa_begin »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Establece una llamada de retorno para la división de lectura/escritura definida por el usuario

mysqlnd_ms_set_user_pick_server

(PECL mysqlnd_ms < 1.1.0)

mysqlnd_ms_set_user_pick_server — Establece una llamada de retorno para la división de lectura/escritura definida por el usuario

Descripción

mysqlnd_ms_set_user_pick_server ( string $function ) : bool

Establece una llamada de retorno para la división de lectura/escritura definida por el usuario. El complemento invocará a la llamada de retorno solamente si pick[]=user el la regla predeterminada para elegir servidores en la sección relevante del fichero de configuración del complemento.

Las decisiones del mecanismo interno de división de consultas de lecura-escritura pueden ser sobrescritas de dos maneras. La más sencilla es anteponer a una consulta las sugerentecias SQL MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH o MYSQLND_MS_LAST_USED_SWITCH. Al utilizar sugerencias SQL se puede controlar, por ejemplo, si una consulta debería ser enviada al servidor maestro de replicación MySQL o a uno de los servidores esclavos. Mediante la ayuda de sugenrencias SQL no es posible elegir un esclavo en particular para que ejecute una consulta.

Se puede obtener control total en la selección del servidor usando una función de llamada de retorno. Solamente se recomienda el uso de una llamada de retorno para usuarios expertos, ya que ésta ha de cubrir todos los casos que de otro modo manejaría el complemento.

El complemento invorcará a la función de llamada de retorno para seleccionar un servidor de las listas de servidores maestros y esclavos configurados. La función de llamada de retorno inspeccionará la consulta a ejecutar y eligirá un servidor para que ejecute dicha consulta, devolviendo el URI del equipo anfitrión, tal como lo encontró en la lista de maestros y esclavos.

Si las conexiones retardadas están habilitadas y la llamada de retorno elige un servidor esclavo para el que hasta ahora no se ha establecido una conexión, y el establecimiento de la conexión al esclavo falla, el complemento devolverá un error sobre la siguiente acción en la conexión fallida, por ejemplo, al ejecutar una consulta. Es responsabilidad del desarrollador de la aplicación manejar el error. Por ejemplo, la aplicación podría re-ejecutar la consulta para desencadenar una nueva selección de un servidor y una nueva invocación a la llamada de retorno. Si lo hace, la llamada de retorno debe asegurarse de seleccionar un esclavo diferente, o comprobar la disponibilidad del esclavo, antes de devolver el resultado al complemento para evitar un bucle infinito.

Parámetros

function

La función a llamar. Se pueden invocar también métodos de clases de forma estática usando esta función pasando array($nombre_clase, $nombre_método) a este parámetro. Además, los métodos de clases de una instancia de objeto se pueden llamar pasando array($instancia_objeto, $nombre_método) a este parámetro.

Valores devueltos

El equipo anfitrión donde ejecutar la consulta. El URI del equipo anfigrión se toma de las listas de maestros y esclavos configurados pasadas a la función de llamada de retorno. Si la llamada de retorno devuelve un valor que no se encuentra ni en las listas de conexión a maestros ni en la de esclavos, el complemento usará el segundo método de elección configurado mediante el ajuste pick[] del fichero de configuración del complemento. Si no se proporciona un segundo método de elección, el complemento usará el método interno predeterminado de seleccionar un servidor.

Notas

Nota:

mysqlnd_ms_set_user_pick_server() está disponible con PECL mysqlnd_ms < 1.1.0. Ha sido reemplazado por el filtro user. Por favor, revise el Historial de cambios para las notas sobre actualizaciones.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_ms_set_user_pick_server()

[myapp]
master[] = localhost
slave[] = 192.168.2.27:3306
slave[] = 192.168.78.136:3306
pick[] = user
<?php

function pick_server($connected, $query, $master, $slaves, $last_used)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* predeterminado: volver a la lógica interna del comlemento */
 $ret = NULL;

 printf("El usuario se ha conectado a '%s'...\n", $connected);
 printf("... decidiendo dónde ejecutar '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... usando el maestro\n");
   $ret = $masters[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* una tabla que está únicamente en el primer esclavo configurado  */
    printf("... detectado un acceso a la tabla únicamente disponible en el esclavo A\n");
    $ret = $slaves[0];
   }
   else
   {
    /* rotativo */
    printf("... alguna consulta de solo lectura para un esclavo\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... usando el último esclavo utilizado\n");
   $ret = $last_used;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

mysqlnd_ms_set_user_pick_server("pick_server");

$mysqli = new mysqli("myapp", "root", "", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

El resultado del ejemplo sería:

User has connected to 'myapp'...
... deciding where to run 'SELECT 1 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.2.27:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT 2 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.78.136:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT * FROM table_on_slave_a_only'
... access to table available only on slave A detected
... ret = 'tcp://192.168.2.27:3306'

Ver también

  • mysqlnd_ms_query_is_select() - Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado
  • Concepto de filtro
  • El filtro user


Inicia una transacción distribuida/XA entre servidores de MySQL

  • « mysqlnd_ms_set_user_pick_server
  • mysqlnd_ms_xa_commit »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Inicia una transacción distribuida/XA entre servidores de MySQL

mysqlnd_ms_xa_begin

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_begin — Inicia una transacción distribuida/XA entre servidores de MySQL

Descripción

mysqlnd_ms_xa_begin ( mixed $connection , string $gtrid , int $timeout = ? ) : int

Inicia una transacción XA entre servidores de MySQL. PECL/mysqlnd_ms actúa como un coordinador de transacciones distribuidas.

Una vez que ha sido iniciada una transacción global, el complemento inyecta las sentencias SQL XA BEGIN apropiadas en todos los servidores de MySQL emleados en la siguiente. La transacción global finaliza llamando a mysqlnd_ms_xa_commit(), mysqlnd_ms_xa_rollback() o mediante una reversión implícita en caso de error.

Durante una transacción global, el complemento rastrea todos los cambios de servidores, por ejemplo, al cambiar de un fragmento de MySQL a otro fragmento de MySQL. Justo antes de que una consulta se ejecute en un servidor que no haya participado aún en la transacción global, XA BEGIN se ejecuta en el servidor. Desde la perspectiva del usuario, la inyección sucede durante una llamada a una función de ejecución de consultas como mysqli_query(). Si la inyección falla, se informa de un error al llamador de la función de ejecución de consultas. El servidor fallido no se convierte en participante de la transacción global. El usuario podría reintentar ejecutar una consulta en el servidor y, por lo tanto, se reintentaría la inyección de XA BEGIN, abortar la transacción global debido a que no todos los servidores requeridos pueden participar, o ignorar y continuar la transacción global sin el servidor fallido.

Las razones para que falle la ejecución de XA BEGIN incluyen, aunque no están limitadas a, un servidor inalcanzable o el servidor que tiene una transacción XA concurrente abierta empleando el mismo xid.

Observe que las transacciones globales y locales son mutuamente exclusivas. No se puede inicar una transacción XA cuando se tiene una transacción local abierta. La transacción local debe finalizar primero. El complemento intenta detectar este conflicto lo más pronto posible. Monitoriza las llamadas a la API para controlar las transacciones locales para aprender sobre el estado actual. Sin embargo, si se emplean sentencias SQL para transacciones locales, como BEGIN, el complemento podría no conocer el estado actual y no detectar el conficto antes de inyectar y ejecutar XA BEGIN.

El empleo de otros recursos de XA que no sean servidores de MySQL no está soportado por la función. Para llevar a cabo una transacción global entre, por ejemplo, un servidor de MySQL y otros sistemas de bases de datos propietarios, los comandos SQL del sistema deberían ser enviados por uno mismo.

Nota: Experimental

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción.

Parámetros

connection

Un gestor de conexión de MySQL obtenido desde cualquier función de conexión de las extensiones mysqli, mysql o PDO_MYSQL.

gtrid

El identificador de transacción global (gtrid). El gtrid es un string binario de hasta 64 de longitud. Observe que, dependiendo de la configuración del juego de caracteres, 64 caracteres podrían requerir más de 64 bytes de almacenamiento.

De acuerdo con la sintaxis de SQL de MySQL, las transacciones XA emplean identificadores que constan de tres partes. Un xid que consiste en un identificador de transacción global (gtrid), un cualificador de ramificación (bqual), y un identificador de formato (formatID). Solamente se puede, y es necesario establecer el identificador de transacción global.

El identificador de ramificación y el identificador de formato se establecen automáticamente. Los detalles deberían ser considerados dependientes de la implementación, lo cual podría cambiar sin previo aviso. En la versión 1.6, el cualificador de ramificación es un número consecutivo que se incrementa siempre que un participante se une a la transacción global.

timeout

Tiempo límite en segundos. El valor predeterminado es 60 segundos.

El tiempo límite es un indicador para la recorección de basura. Si una transacción es anotada para tomar más de lo esperado, la recolección de basura comienza comprobando el estado de la transacción.

Establecer un valor bajo podría hacer que la recolección de basura compruebe el progreso demasiado a menudo. Observe que la comprobación del estado de una transacción global podría involucrar la conexión a todos los participantes registrados y posiblemente la emisión de consultas a los servidores.

Valores devueltos

Devuelve true si no hay ninguna transacción local o global abiertas y se puede iniciar una nueva transacción global. De lo contrario, devuelve false

Ver también

  • Guía rápida de transacciones XA/distribuidas
  • Configuración en tiempo de ejecución
  • mysqlnd_ms_get_stats() - Devuelve la distribución consultas y las estadísticas de conexión


Consigna una transacción distribuida/XA entre servidores de MySQL

  • « mysqlnd_ms_xa_begin
  • mysqlnd_ms_xa_gc »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Consigna una transacción distribuida/XA entre servidores de MySQL

mysqlnd_ms_xa_commit

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_commit — Consigna una transacción distribuida/XA entre servidores de MySQL

Descripción

mysqlnd_ms_xa_commit ( mixed $connection , string $gtrid ) : int

Consigna una transacción global entre servidores de MySQL iniciada por mysqlnd_ms_xa_begin().

Si cualquier participante de la transacción global falla en la consignación, se realizará una reversión implícita. Podría ocurrir que no todos los casos puedan ser manejados durante la reversión. Por ejemplo, no se intentará realizar una conexión a un participante después de que la conexión al participante se haya perdido. La resolución de casos que no pueden ser revertidos con facilidad se deja a la recolección de basura.

Nota: Experimental

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualesquiera de las extensiones connect functions of the mysqli, mysql o PDO_MYSQL.

gtrid

El identificador de transacción global (gtrid).

Valores devueltos

Devuelve true si la transacción global ha sido consignada. De lo contrario, devuelve false

Ver también

  • Guía rápida de transacciones XA/distribuidas
  • Configuración en tiempo de ejecución
  • mysqlnd_ms_get_stats() - Devuelve la distribución consultas y las estadísticas de conexión


Recolecta basura de transacciones XA no finalizadas después de algún error del servidor

  • « mysqlnd_ms_xa_commit
  • mysqlnd_ms_xa_rollback »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Recolecta basura de transacciones XA no finalizadas después de algún error del servidor

mysqlnd_ms_xa_gc

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_gc — Recolecta basura de transacciones XA no finalizadas después de algún error del servidor

Descripción

mysqlnd_ms_xa_gc ( mixed $connection , string $gtrid = ? , boolean $ignore_max_retries = ? ) : int

Recolecta basura de transacciones XA no finalizadas.

El protoclo XA es un protocolo de bloqueo. Hay casos en los que los servidores participantes en una transacción global no pueden progresar cuando el coodinador de transacciones falla o se desconecta. En tal caso, los servidores de MySQL se mantienen esperando instrucciones para finalizar la transacción XA en cuestión. Ya que las transacciones ocupan recursos, estas deberían siempre finalizarse de la manera apropiada.

La recolección de basura requiere configurar un almacén de estados para rastrear transacicones globales. Si un cliente de PHP se cae en mitad de una transacción y se inicia un nuevo cliente de PHP, el recolector de basura interno podrá enterarse de la transacción global abortada y finalizarla. Si no se configura un almacén de estado, el recolector de basura no podrá realizar ningunta tarea de limpieza.

El almacén de estados debería ser seguro ante caídas y ser de alta disponibilidad para sobrevivir a su propia caída. Actualmente, solamente se admite MySQL como almacén de estados.

La recolección de basura también se puede realizar de forma automática en segundo plano. Ver la directiva de configuración garbage_collection del complemento para más detalles.

Nota: Experimental

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualesquiera de las extensiones connect functions of the mysqli, mysql o PDO_MYSQL.

gtrid

Un identificador de transacción global (gtrid). Si se proporciona, el recolector de basura considerará únicamente la transacción. De lo contrario, se explorará el almacén de datos para cualquier transacción no finalizada.

ignore_max_retries

Indica si ignorar el ajuste de configuración max_retries del complemento. Si la recolección de basura falla de forma continuada y se alcanza el límite max_retries antes de finalizar la transacción global fallida, se pueden intentar más ejecuciones antes de investigar la causa y resolver el probelma manualmente enviando sentencias SQL a los participantes. Esteblecer el parámetro tiene el mismo efecto que establecer max_retries = 0 temporalmente.

Valores devueltos

Devuelve true si la transacción global ha sido revertida. De lo contrario, devuelve false.

Ver también

  • Guía rápida de transacciones XA/distribuidas
  • Configuración en tiempo de ejecución
  • Configuración del almacén de estados
  • mysqlnd_ms_get_stats() - Devuelve la distribución consultas y las estadísticas de conexión


Revierte una transacción distribuida/XA entre servidores de MySQL

  • « mysqlnd_ms_xa_gc
  • Historial de cambios »
  • PHP Manual
  • Funciones de mysqlnd_ms
  • Revierte una transacción distribuida/XA entre servidores de MySQL

mysqlnd_ms_xa_rollback

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_rollback — Revierte una transacción distribuida/XA entre servidores de MySQL

Descripción

mysqlnd_ms_xa_rollback ( mixed $connection , string $gtrid ) : int

Revierte una transacción global entre servidores de MySQL iniciada por mysqlnd_ms_xa_begin().

Si cualquier participante de la transacción global falla en la reversión, se deja que la situación la resuelva el recolecotr de basura.

Nota: Experimental

Esta característica está actualmente en desarrollo. Podrían existir problemas y/o limitaciones. No la use en entornos de producción.

Parámetros

connection

Un gestor de conexión de MySQL obtenido de cualesquiera de las extensiones connect functions of the mysqli, mysql o PDO_MYSQL.

gtrid

El identificador de transacción global (gtrid).

Valores devueltos

Devuelve true si la transacción global ha sido revertida. De lo contrario, devuelve false

Ver también

  • Guía rápida de transacciones XA/distribuidas
  • Configuración en tiempo de ejecución
  • mysqlnd_ms_get_stats() - Devuelve la distribución consultas y las estadísticas de conexión


Historial de cambios

Tabla de contenidos

  • Serie PECL/mysqlnd_ms 1.6
  • Serie PECL/mysqlnd_ms 1.5
  • Serie PECL/mysqlnd_ms 1.4
  • Serie PECL/mysqlnd_ms 1.3
  • Serie PECL/mysqlnd_ms 1.2
  • Serie PECL/mysqlnd_ms 1.1
  • Serie PECL/mysqlnd_ms 1.0

Este historial de cambios es un resumen de alto nivel de los cambios seleccionados que pueden tener un impacto sobre las aplicaciones y/o romper la retrocompatibilidad (RC).

Véase también el fichero CHANGES en la distribución del código fuente para una lista completa de los cambios.


Serie PECL/mysqlnd_ms 1.6

1.6.0-alpha

  • Fecha de publicación: TBD
  • Motivo/tema: Mantenimiento y soporte inicial para MySQL Fabric

Nota:

Esta es la serie actualmente en desarrollo. Todas las características están en una etapa primitiva. Los cambios podrían ocurrir en cualquier momento sin previo aviso. Por favor, no use esta versión en entornos de producción.

La documentación podría no reflejar aún todos los cambios.

Corrección de errores

  • No se podrá corregir: #66616 Falla la división de lectura/escritura: QOS con mysqlnd_get_last_gtid con GTID internos de MySQL

    Esto no es un error en la implementación del complemento, sino una limitación de una característica del lado del servidor no considerada ni documentada antes. Los GTID internos de MySQL 5.6 no pueden usarse para asegurar la consistencia de sesión al leer desde los esclavos en cualquier caso. En el peor de los casos, el complemento no considerará el uso de esclavos y recurrirá al uso del maestro. No habrá resultados erróneos, excepto que no habrá el beneficio de realizar la comprobación del GTID.

  • Corregido #66064 - Equilibrio de carga aleatorio una vez ignora los pesos

    Debido a un error de análisis de configuración, el equilibrio de carga ha ignorado el nodo de pesos si, y solo si, la bandera 'sticky' estaba establecida (aleatorio una vez).

  • Corregido #65496 - Comprobación errónea de la demora de esclavos

    El filtro de calidad de servicio ha ignorado de forma errónea a los esclavos que demoraban cero (0) segundos si se hubo establecido cualquier máximo de demora. Aunque un esclavo no se demorara, era excluido de la lista de equilibrio de carga si el filtro QoS estableció un máximo de edad. Esto era debido al uso de un operador de comparación erróneo en el código fuente del filtro.

  • Corregido #65408 - Fallo de compilación con -Werror=format-security

Cambio en las características

  • Se introdujo una agrupación de conexiónes interna. Al usar Fabric y cambiar de un grupo de fragmentos A a un grupo de fragmentos B, se remplaza la lista entera de maestros y esclavos. Esto obstaculiza a la lógica de alineamiento de estados de conexiones y a algunos filtros. Algunos filtros almacenan información en cacé en las listas de maestros y esclavos. La nueva abstracción de la agrupación de conexiones interna permite informar de los filtros de cambios, de ahí que puedan actualizar sus cachés.

    Más adelante, la agrupación puede también emplearse para reducir la sobrecarga de conexiones. Se asume que se está cambiando de un grupo de fragmentos a otro y se vuelve otra vez. Siempre que se realice un cambio, las listas de los servidores activos (y conexiones) de la agrupación son remplazadas. Sin embargo, la conexiones que ya no se utilizan no se cierran necesariamente de inmediato, por lo que se pueden permanecer en la agrupación para una reutilización posterior.

    Obsérvese que la agrupación de conexiones es interna en este momento. Hay algunas estadísticas nuevas para monitorizarla. Sin embargo, no se puede configurar aún el comportamiento del tamaño de la agrupación.

  • Se añadió una abstracción básica para transacciones distribuidas. Las transacciones XA están soportadas desde el empleo de llamads SQL estándar. Esto es inadecuado debido a que los participantes de XA deben ser administrador manualmente. PECL/mysqlnd_ms introduce llamadas a la API para controlar transacciones XA entre servidores de MySQL. Al utilizar las nuevas funciones, PECL/mysqlnd_ms actúa como un coordinador de transacciones. Después de iniciar una transacción distribuida, el complemento rastrea todos los servidores involucrados hasta que la transacción finaliza y se envían las sentencias SQL apropiadas a los participantes de XA.

    Esto es útil, por ejemplo, al utilizar Fabric y la fragmentación. Cuando se emplea Fabric, los servidores de fragmentación reales involucrados en una transacción de negocio podrían no ser conocidos de antemano. Así, el control manual de una transacción que genere varios fragmentos sería dificultoso. Por favor, tenga en cuenta las limitaciones actuales.

  • Se introdujo un bucle de reintentos automático para errores transitorios y las estadísticas correspondientes para contar el número de intentos implícitos. Algunos clústeres de bases de datos distribuidas usan erroes transitorios para sugeriri a un cliente que reintente su operación en un momento. Muy amenudo, el cliente se supone que para la ejecución (duerme) por un coroto momento antes del reintentar la operación deseada. No es necesario recurrir inmediatamente a otro nodo en respuesta al error. En su lugar, se puede realizar un blucle de reintentos. Una situación común al usar un Clúster de MySQL.

  • Se introdujo un bucle de reintentos automático para errores transitorios y las estadísticas correspondientes para contar el número de intentos implícitos. Algunos clústeres de bases de datos distribuidas usan erroes transitorios para sugeriri a un cliente que reintente su operación en un momento. Muy amenudo, el cliente se supone que para la ejecución (duerme) por un coroto momento antes del reintentar la operación deseada. No es necesario recurrir inmediatamente a otro nodo en respuesta al error. En su lugar, se puede realizar un blucle de reintentos. Una situación común al usar un Clúster de MySQL.

  • Se introdujo el soporte más básico para MySQL Fabric High Availability y el marco de trabajo de fragmentación.

    Considere este como calidad prealfa. El código del marco de trabajo del lado del servidor y del cliente client debe funcionar de forma precisa considerando solamente los ejemplos del inicio rápido de MySQL Fabric. Sin embargo, no se han realizado pruebas al nivel de versiones del complemento anteriores a alfa. Ambos lados son objetivos móviles, los cambios en la API podrían ocurrir en cualquier momento sin previo aviso.

    Ya que se está trabajando aún en ello, el manual podría no reflejar las limitaciones de las características permitidas y los errores conocidos.

  • Nuevas estadísticas para monitorizar la llamada XML RPC de Fabric sharding.lookup_servers: fabric_sharding_lookup_servers_success, fabric_sharding_lookup_servers_failure, fabric_sharding_lookup_servers_time_total, fabric_sharding_lookup_servers_bytes_total, fabric_sharding_lookup_servers_xml_failure.

  • Nuevas funciones relacionadas con MySQL Fabric:
mysqlnd_ms_fabric_select_shard(),
mysqlnd_ms_fabric_select_global(),
mysqlnd_ms_dump_servers().


Serie PECL/mysqlnd_ms 1.5

1.5.1-stable

  • Fecha de publicación: 06/2013
  • Motivo/tema: Soporte para fragmentación, soporte mejorado para transacciones

Nota:

Esta es la serie estble actual. Use esta versión en entornos de producción.

La documentación está completa.

1.5.0-alpha

  • Fecha de publicación: 03/2013
  • Motivo/tema: Soporte para fragmentación, soporte mejorado para transacciones

Corrección de errores

  • Corregida la violación de acceso #60605 de PHP cuando mysqlnd_ms está habilitado.

  • Establecer la adhesión de transacciones deshabilita todo el equilibrado de carga, incluyendo lla tolerancia a fallos automática, durante una transacción. Por lo que podrían ocurrir intercambios de conexiones en mitad de una transacción en configuraciones multimaestro y durante la tolerancia a fallos automática aunque la monitorización de transacciones haya detectado los límites de la transacción apropiadamente.

  • Rotura de RC y error corregido. Las sugerencias SQL que fuerzan a un tipo específico de servidor (MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_LAST_USED_SWITCH) son ignoradas durante una transacción si la adhesión de transacciones está habilitada y se han detectado apropiadamente los límites de la transacción.

    Este es un cambio de comportamiento. Sin embargo, también es una corrección de error y un paso para alinear comportamiento. Si, en versiones anteriores, con adhesión de transacciones, se combinaba una de las sugerencias SQL enumeradas el filtro de calidad de servicio, podía ocurrir que dichas sugerencias fueran ignoradas. En algún caso, las sugerencias SQL funcionaban, en otros no. El nuevo comportamiento es más consistente. Las sugerencias SQL siempre serán ignoradas durante una transacción si la adhesión de transacciones está habilitado.

    Observe que la detección de los límites de transaccoines continua basándose en la monitorización de llamadas a la API. Los comandos SQL que controlan transacciones no son monitorizados.

  • Rotura de RC y error corregido. Las llamadas a mysqlnd_ms_set_qos() fallarán cuando se hacen en mitad de una transacción si la adhesión de transacciones está habilitada. Los intercambios de conexión no están permitidos durante una transacción. El cambio de la calidad de servicio probablemente resulta en un conjunto diferente de servidores elegidos para la ejecución de consultas, posiblemente haciendo necesario intercambiar conexiones. Así, la llamada no está permitida durante una transacción activa. La calidad de servicio puede ser, sin embargo, cambiada entre transacciones.

Cambios en las características

  • Se introdujo el filtro node_group. El filtro permite organizar servidores (maestro y esclavos) en grupos. Las consultas se pueden dirigir a ciertos grupos de servidores prefijando la sentencia de consulta con una sugerencia/comentario de SQL que contenga el nombre de configuración de grupos. La agrupación se puede usar para particionar y fragmentar, aunque también para optimizar la caché local. En el caso de la fragmentación, se ha de pensar en un nombre grupo como una clave fragmentada. Todas las consultas para una clave fragmentada dada serán ejecutadas en el fragmento configurado. Nota: tanto el cliente como el servidor deben sorportar la fragmentación para usar la misma con mysqlnd_ms.

  • Validación del fichero de configuración extendida durante el arranque de PHP (RINIT). Se lanzará un error de nivel E_WARNING si no se puede leer el fichero de configuración (permisos), si está vacío, o si el fichero (JSON) no se pudo analizar. Las advertencias podrían aparecer el ficheros log, lo que depende de cómo esté configurado PHP.

    Las distribuciones que pretenden proporcionar una configuración precofigurada, incluyendo una rutina auxiliar de fichero de configuración, se les interroga para colocar {} en el fichero de configuración para evitar esta advertencia sobre un fichero de configuración inválido.

    Se realiza una validación extra del fichero de configuración cuando se analizan secciones que abran una conexión. Por favor, observe que aún podrían haber situaciones en las que un fichero de configuración del complemento inválido no conduzca a mensajes de error apropiados, sino a un fallo de conexión.

  • A partir de PHP 5.5.0, se añadió la mejora de la detección de límites de transacciones para mysqli. La extensión mysqli ha sido modificada para usar las nuevas llamadas a la API en C de la biblioteca mysqlnd para comenzar, consolidar y revertir una transacción o un punto de prevención. Si se usa trx_stickiness para habilitar transacciones que consideran equilibrado de carga, las funciones mysqli_begin(), mysqli_commit() and mysqli_rollback() ahora serán monitorizadas por el complemento, para aceptar la función mysqli_autocommit() que ya estaba admitida. Todas las características de SQL para controlar transacciones también están disponibles a través de las funciones mejoradas relacionadas con el control de transacciones de mysqli. Esto significa que no es necesario para emitir sentencias SQL en lugar de usar llamadas a la API. Las aplicaciones que utilicen las llamadas apropiadas a la API pueden ser equilibradas en carga por PECL/mysqlnd_ms de una manera completamente consciente de transacciones.

    Observe que PDO_MySQL no ha sido actualizada aún para usar las nuevas llamadas a la API de mysqlnd. Por lo tanto, la detección de límites de transacciones con PDO_MySQL continua estando limitada a la monitorización pasando PDO::ATTR_AUTOCOMMIT a PDO::setAttribute().

  • Se introdujo trx_stickiness=on. Esta opción de trx_stickiness difiere de trx_stickiness=master en que intenta ejecutar una transacción de solo lectura en un esclavo, si la calidad de servicio (nivel de consistencia) permite el uso de un esclavo. Las transacciones de solo lectura fueron introducidas en MySQL 5.6 y ofrecen ganancias de rendimiento.

  • El soporte para la caché de consultas se considera beta si se usa con la API de mysqli. Debería funcionar bien con clústeres basados en copia primaria. Para las demás API, este rasgo continua siendo experimental.

  • Los ejemplos de código del fichero fuente de mysqlnd_ms se actualizaron.


Serie PECL/mysqlnd_ms 1.4

1.4.2-stable

  • Fecha de publicación: 08/2012
  • Motivo/tema: Modificaciones menores basadas en comentarios de usuarios

1.4.1-beta

  • Fecha de publicación: 08/2012
  • Motivo/tema: Modificaciones menores basadas en comentarios de usuarios

Errores corregidos

  • Corregida la construcción con PHP 5.5

1.4.0-alpha

  • Fecha de publicación: 07/2012
  • Motivo/tema: Modificaciones menores basadas en comentarios de usuarios

Cambios en las características

  • Rotura RC: Se renombró el ajuste de configuración del complemento ini_file a config_file. En versiones anteriores el fichero de configuración del complemento usaba el estilo ini. Así, el ajuste de configuración se llamó en consecuencia. Ahora se ha renombrado para reflechar el formato de fichero nuevo y para distinguirlo del propio fichero ini de PHP (fichero de directivas de configuración).

  • Se introdujo el ajuste de conjunto de caracteres predeterminado server_charset para permitir el escapado apropiado antes de abrir una conexión. Esto es lo más útil al usar conexiones retardadas, las cuales son las predeterminadas.

  • Se introdujo el ajuste wait_for_gtid_timeout para estrangular las lecturas de esclavos que necesitan consistencia de sesión. Si se usan identificadores de transacciones globales y el nivel de servicio está establecido a consistencia de sesión, el complemento intentará encontrar esclavos actualizados. La comprobación del estado de un esclavo se realiza mediante una sentencia SQL. Si no se establece nada más, dicho estado se comprobará y a partir de entonces solamente se puede continuar la búsqueda de más esclavos actualizados. Establecer wait_for_gtid_timeout ordena al complemento que sondee los estados de los esclavos durante wait_for_gtid_timeout segundos si la primera ejecución de la sentencia SQL ha mostrado que el esclavo aún no está actualizado. El sondeo se realizará una vez por segundo. De este modo, el complemento esperará a que los esclavos se pongan al día y estrangulará al cliente.

  • La nueva estrategia de tolerancia a fallos loop_before_master. De manera predeterminada, el complemento no realiza la tolerancia a fallos. Es posible habilitar la tolerancia a fallos automática si falla un intento de conexión. Hasta la versión 1.3 solamente existía la estrategia master para realizar la tolerancia a fallos en un maestro si fallaba una conexión a un esclavo. loop_before_master es similar, pero realiza intentos sobre los demás esclavos antes de intentar conectarse al maestro si una conexión a un esclavo falla.

    El número de intentos se puede limitar usando la opción max_retries. Los equipos anfitriones fallidos se pueden recordar y ser saltados en el equilibrado de carga para el resto de la petición web. max_retries y remember_failed son considerados experimentales, aunque se proporciona una estabilidad decente. La sintaxis y la semántica podrían cambiar en el futuro sin previo aviso.


Serie PECL/mysqlnd_ms 1.3

1.3.2-stable

  • Fecha de publicación: 04/2012
  • Motivo/tema: véase 1.3.0-alpha

Corrección de errores

  • Corregido el problema con multimaestros en donde una transacción las consultas al maestro no se adherían y eran difundidas por todos los demás maestros (RR). Aún no se adhiere para Random. Random_once no se ve afectada.

1.3.1-beta

  • Fecha de publicación: 04/2012
  • Motivo/tema: véase 1.3.0-alpha

Corrección de errores

  • Corregido el problema de la construcción junto con QC.

1.3.0-alpha

  • Fecha de publicación: 04/2012
  • Motivo/tema: Almacenamiento en caché de consultas a través del concepto de calidad de servicio

La seria 1.3 aspira a mejorar el rendimiento de las aplicaciones y el total de la carga de un clúster MySQL asíncrono, por ejemplo, un clúster MySQL que utiliza la Replicación MySQL. Esto se lleva a cabo de forma transparaente reemplazando el acceso a un esclavo con un acceso a la caché local, si la aplicación lo permite estableciendo una bandera de calidad de servicio apropiada. Cuando se usa la replicación MySQL un esclavo puede servir datos antiguos. Una aplicación que use la replicación MySQL debe continuar funcionando correctamente con datos antiguos. Dado que se sabe que la aplicación funciona correctamente con datos antiguos, el acceso al esclavo se puede reemplazar de forma transparente con un acceso a la caché local.

PECL/mysqlnd_qc sirve como una caché en el lado del procesamiento. PECL/mysqlnd_qc admite el uso de varias ubicaciones de almacenamiento, entre otras la memoria principal, APC y MEMCACHE.

Cambios en las características

  • Se añadió la opción de caché al filtro de calidad de servicio (QoS).

    • La nueva opción de configuración enable-mysqlnd-ms-cache-support
    • La nueva constante MYSQLND_MS_HAVE_CACHE_SUPPORT.
    • La nueva constante MYSQLND_MS_QOS_OPTION_CACHE para usarla con mysqlnd_ms_set_qos().

  • Soporte para la característica del identificador de transacciones global interno de MySQL 5.6.5-m8 o posterior.


Serie PECL/mysqlnd_ms 1.2

1.2.1-beta

  • Fecha de publicación: 01/2012
  • Motivo/tema: véase 1.2.0-alpha

Cambios de pruebas menores.

1.2.0-alpha

  • Fecha de publicación: 11/2011
  • Motivo/tema: Inyección de ID de Transacciones Global y concepto de calidad de servicio

El la versión 1.2, el foco continua siendo el soporte de clústeres de bases de datos MySQL con replicación asíncrona. El complemento intenta hacer uso del clúster introduciendo un filtro de calidad de servicio que pueden usar las aplicaciones para definir la calidad de servicio que necesitan del clúster. Los niveles de servicio proporcionados son la consistencia final con la edad máxima/demora del esclavo opcional, la consistencia de sesión y la consistencia fuerte.

Además, el complemento puede realizar una inyección de id de transacciones global en el lado del cliente para hacer más sencilla la tolerancia a fallos manual en el maestro.

Cambios en las características

  • Se introdujo el filtro de calidad de servicio (QoS). Los niveles de servicio proporcionados por el filtro QoS son:

    • consistenia finak, con opción de demora de esclavos
    • consistencia de sesión, con GTID opcional
    • consistencia fuerte

  • Se añadió la función mysqlnd_ms_set_qos() para establecer la calidad de conexión requierida en tiempo de ejecución. Las nuevas constantes relacionadas con mysqlnd_ms_set_qos() son:

    • MYSQLND_MS_QOS_CONSISTENCY_STRONG
    • MYSQLND_MS_QOS_CONSISTENCY_SESSION
    • MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL
    • MYSQLND_MS_QOS_OPTION_GTID
    • MYSQLND_MS_QOS_OPTION_AGE

  • Se añadió la inyección de id de transacciones global (GTID) en el lado del cliente.

  • Las nuevas estadísticas relacionadas con el GTID:

    • gtid_autocommit_injections_success
    • gtid_autocommit_injections_failure
    • gtid_commit_injections_success
    • gtid_commit_injections_failure
    • gtid_implicit_commit_injections_success
    • gtid_implicit_commit_injections_failure

  • Se añadió mysqlnd_ms_get_last_gtid() para obtener el último id de transacción global.

  • Se habilitó el soporte para multimaestros sin esclavos.


Serie PECL/mysqlnd_ms 1.1

1.1.0

  • Fecha de publicación: 09/2011
  • Motivo/tema: Cubrir lo básico de la replicación con calidad de producción

Las series 1.1 y 1.0 exponen un conjunto de características similar. Internamente, la serie 1.1 ha sido reestructurada para planificar la incorporación de futuras características. Se ha introducido un nuevo formato del fichero de configuración, y se han eliminado las limitaciones. Además, se ha mejorado la calidad del código y la seguridad de la calidad.

Cambios en las características

  • Se añadió el (encadenable) concepto de filtro:

    • Rotura RC: La función mysqlnd_ms_set_user_pick_server() ha sido eliminada. Se ha introducido el filtro user para reemplazarla. El filtro ofrece una funcionalidad similar, aunque existen diferencias que se explican más abajo.

  • Nueva sintaxis de configuración más potente basada en JSON.
  • Merjora de conexiones retardadas: está cubierta la seguridad relevante y los comandos de cambio de estado.
  • Soporte para sentencias preparadas (nativo).

  • Nuevas estadísticas: use_master_guess, use_slave_guess.

    • Rotura RC: Cambio en la semántica de las estadísticas use_slave, use_master. Son posibles cambios futuros. Véase mysqlnd_ms_get_stats().

  • La lista de mensajes de difusión está extendida por ssl_set.
  • Ahora, las llamadas a la biblioteca se monitorizan para recordar los ajustes de conexiones retaradadas: change_user, select_db, set_charset, set_autocommit.
  • Se introdujo mysqlnd_ms.disable_rw_split. Este ajuste de configuración permite el uso de la funcionalidad del equilibrado de carga y de las conexiones retardadas independientemente de la división de lecutra-escritura.

Corrección de errores

  • Corregido PECL #22724 - Intercambio de servidor (mysqlnd_ms_query_is_select() sensible a mayúsculas/minúsculas)
  • Corregido PECL #22784 - No funcionaba mysql_connect y mysql_select_db
  • Corregido PECL #59982 - Extensión inusable con with --enable-mysqlnd-ms-table-filter. El uso de la opción NO está soportado. No se debe usar. Se añadió una nota a m4.
  • Corregido el error #60119 - host="localhost" se perdía en mysqlnd_ms_get_last_used_connection()

Se ha eliminado la función mysqlnd_ms_set_user_pick_server(), y ha sido reemplazada por el nuevo filtro user. Ya no se puede establecer una función de llamada de retorno usando mysqlnd_ms_set_user_pick_server() en tiempo de ejecución, sino que se ha de configurarla en su lugar en el fichero de configuración del complemento. El filtro user pasará los mismos argumentos que antes a la llamada de retorno. Por lo tanto, se puede seguir usando la misma función procedimental como una llamada de retorno. Ya no es posible usar métodos estáticos de clases, o métodos de clases de una instancia, como una llamada de retorno. Hacerlo supondrá que la función ejecutará una sentencia manejada por el complemento para emitir un error de nivel E_RECOVERABLE_ERROR, el cual podría ser: "(mysqlnd_ms) Specified callback (picker) is not a valid callback." ((mysqlnd_ms) La llamada de retorno (picker) especificada no es una llamada de retorno válida). Nota: esto podría detener la aplicación.


Serie PECL/mysqlnd_ms 1.0

1.0.1-alpha

  • Fecha de publicación: 04/2011
  • Motivo/tema: versión de corrección de errores

1.0.0-alpha

  • Fecha de publicación: 04/2011
  • Motivo/tema: Cubrir lo básico de la replicación para probar los comentarios de los usuarios

La primera versión de uso práctico. Introduce una división básica automática de lectura-escritura, sugerencias SQL para invalidar la redirección automática, el equilibrado de carga de peticiones a esclavos, conexiones retardadas, y uso opcional automático del maestro después de la primera escritura.

El conjunto público de características es similar al de la versión 1.1.

1.0.0-pre-alpha

  • Fecha de publicación: 09/2010
  • Motivo/tema: Pruebas de conceptos

Comprobación inicial. Esencialmente una demo de la API de complementos mysqlnd.


Complemento de caché de resultados de consultas de mysqlnd

  • Introducción
  • Guia rápida y ejemplos
    • Arquitectura y conceptos
    • Puesta en marcha
    • Almacenar consultas en la caché
    • Establecer el tiempo de vida (TTL)
    • Almacenamiento en caché basado en patrones
    • Defensa de cierre
    • Buscar candidatas a la caché
    • Medir la eficiencia de la caché
    • Más allá del TTL: almacenamiento definido por el usuario
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Funciones de mysqlnd_qc
    • mysqlnd_qc_clear_cache — Vacía todo el contenido de la caché
    • mysqlnd_qc_get_available_handlers — Devuelve una lista de los gestores de almacenamiento disponibles
    • mysqlnd_qc_get_cache_info — Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible
    • mysqlnd_qc_get_core_stats — Estadísticas recopiladas por el núcleo de la caché de consultas
    • mysqlnd_qc_get_normalized_query_trace_log — Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas
    • mysqlnd_qc_get_query_trace_log — Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas
    • mysqlnd_qc_set_cache_condition — Establece las condiciones para el almacenamiento en caché automático
    • mysqlnd_qc_set_is_select — Instala una llamada de retorno que decide si una sentencia es almacenada en caché
    • mysqlnd_qc_set_storage_handler — Cambia el gestor de almacenamiento en uso
    • mysqlnd_qc_set_user_handlers — Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario
  • Historal de cambios
    • Serie PECL/mysqlnd_qc 1.2
    • Serie PECL/mysqlnd_qc 1.1
    • Serie PECL/mysqlnd_qc 1.0


Introducción

El complemento de caché de resultados de consultas de mysqlnd facilita el uso del almacenamiento en caché de consultas en el lado del cliente para todas las extensiones de MySQL para PHP que utilicen mysqlnd.

A partir de la versión 5.3.3 de PHP, el controlador nativo de MySQL para PHP (mysqlnd) introduce una API en C de complementos internos. Los complementos en C, tales como el complemento de caché de consultas, pueden ampliar la funcionalidad de mysqlnd.

Los complementos de mysqlnd, tales como el complemento de caché de consultas, operan de forma transparente desde la perspectiva del usuario. El complemento de caché admite todas las apliaciones de PHP y todas las extensiones de MySQL para PHP ( mysqli, mysql, PDO_MYSQL). No cambia ninguna API existente.

No es necesario hacer cambios significativos en una aplicación para almacenar en caché una consulta. La caché tiene dos modos de operar. Almacenará en caché todas las consultas (no recomendado), o simplemente aquellas consultas marcadas con una sugerencia SQL en particular (recomendado).

Características principales

  • Es transparente y por lo tanto fácil de usar

    • admite todas las extensiones de MySQL para PHP

    • sin cambios en la API

    • son necesarios muy pocos cambios en la aplicación

  • Estrategia de invalidación flexible

    • tiempo de vida (TTL)

    • definida por el usuario

  • Almacenamiento con diferentes ámbitos y periodos de vida

    • Default (Hash, procesa la memoria)

    • APC

    • MEMCACHE

    • sqlite

    • definido por el usuario

  • Defensa de cierre interna para prevenir la estampida de la caché.

Limitaciones

La versión 1.0.1 actual de PECL mysqlnd_qc no admite PHP 5.4. La versión 1.1.0-alpha elimina esta limitación.

Las setencias preparadas y las consultas no almacenadas en búfer están totalmente soportadas. Por lo tanto, el complemento puede almacenar en caché todas las sentencias emitidas con mysqli o PDO_MySQL, la cuales son las únicas dos APIs de MySQL para PHP que ofrecen soporte para sentencias preparadas.

Sobre el nombre

La abreviatura mysqlnd_qc significa complemento de caché de consultas de mysqlnd. El nombre fue elegido por una rápida y desordenada prueba de conceptos. Al principio, los desarrolladores no esperaban que se continuase usando el código base. Algunas veces, a PECL/mysqlnd_qc también se le ha llamado caché de conjuntos de resultados de consultas del lado del cliente.


Guia rápida y ejemplos

Tabla de contenidos

  • Arquitectura y conceptos
  • Puesta en marcha
  • Almacenar consultas en la caché
  • Establecer el tiempo de vida (TTL)
  • Almacenamiento en caché basado en patrones
  • Defensa de cierre
  • Buscar candidatas a la caché
  • Medir la eficiencia de la caché
  • Más allá del TTL: almacenamiento definido por el usuario

El complemento de caché de consultas de mysqlnd es fácil de usar. Esta guía rápida muestra los casos de uso típicos y proporciona consejos prácticos para poder empezar a usarlo.

Se recomienda encarecidamente leer las secciones de referencia además de esta guía rápida. Es seguro comenzar con esta guía. Sin embargo, antes de usar el complemento en entornos de misiones críticas, se urge que se lea además la información de fondo de las secciones de referencia.

La mayoría de los ejemplos usan la extensión mysqli, ya que es la extensión de MySQL para PHP más completa. Sin embargo, el complemento se puede usar con cualesquiera de las extensiones de MySQL para PHP que utilicen la biblioteca mysqlnd.


Arquitectura y conceptos

El complemento de caché de consultas está implementado como una extensión de PHP. Está escrita en C y opera bajo el manto de PHP. Durante el arraque del intérprete de PHP, se registra como un complemento de mysqlnd para reemplazar a los métodos en C de mysqlnd seleccionados. Por lo tanto, se puede cambiar el comportamiento de cualquier extensión de MySQL para PHP (mysqli, PDO_MYSQL, mysql) compilada para usar la biblioteca mysqlnd sin cambiar la API de la extensión. Esto hace que el complemento sea compatible con cada una de las aplicaciones de MySQL para PHP. Ya que las APIs existentes no se cambian, es casi transparente de usar. Por favor, véase la descripción de la API de complementos de mysqlnd para una discusión sobre las ventajas de la arquitectura del complemento y una comparación con soluciones basadas en proxy.

Transparente de usar

En tiempo de ejecución de PHP, PECL/mysqlnd_qc puede representar a consultas enviadas desde PHP (mysqlnd) al servidor MySQL. Luego inspecciona la sentencia para buscar si puede almacenar en caché sus resultados. Si puede, el conjunto de resultados se almacena en caché usando un gestor de almacenamiento, por lo que ejecuciones posteriores de la sentencia se servirán desde la caché por un periodo definido por el usuario. El tiempo de vida (TTL) de una entrada de la caché se puede establecer globalmente o en función de cada sentencia.

Una sentencia será almacena en caché si al complemento se le indica que almacene todas las sentencias globalmente, o si la consulta comienza con la sugerencia SQL (/*qc=on*/). El complemento puede almacenar en caché cualquier consulta emitida invocando a las llamadas apropiadas a la API de cualquier extensión existente de MySQL para PHP.

Almacenamiento flexible: distintos gestores de almacenamiento

Se admiten distintos gestores de almacenamiento para ofrecer diferentes ámbitos para las entradas de la caché. Los diferentes ámbitos tienen en cuenta diferentes grados de compartir las entradas de la caché entre clientes.

  • default (interno): memoria del proceso, ámbito: proceso, una o más peticiones web dependiendo del modelo de desarrollo de PHP usado

  • APC: memoria compartida, ámbito: servidor único, múltiples peticiones web

  • SQLite: memoria o fichero, ámbito: servidor único, múltiples peticiones web

  • MEMCACHE: memoria principal, ámbito: servidor único o varios, múltiples peticiones web

  • user (interno): definido por el usuario - cualquiera, ámbito: definido por el usuario - cualquiera

El soporte para los gestores de almacenamiento APC, SQLite y MEMCACHE ha de estar habilitado en tiempo de compilación. Los gestores default y user son internos. Es posible intercambiar entre gestores de almacenamiento compilados en función a cada consulta en tiempo de ejecución. Sin embargo, se recomienda elegir un gestor de almacenamiento y usarlo para todas las entradas de la caché.

Defensa de cierre interna para evitar la sobrecarga

Para evitar situaciones de sobrecarga, el complemento de caché posee un mecanismo de defensa de cierre interna. Si una entrada de la caché expira, muchos cliente que usen las entradas de la caché intentarán refrescar dicha entrada. Durante el refresco, muchos clientes podrían acceder al servidor de bases de datos de forma concurrente. En el peor caso, el servidor de bases de datos se sobrecargará y le llevará cada vez más tiempo refrescar la entradas de la caché, las cuales, de una en una, permiten que más y más clientes intenten refrescar dichas entradas. Para evitar que ocurra esto, el complemento posee un mecanismo de defensa de cierre interna. Si se habilita dicha defensa y el complemento detecta que una entrada de la caché ha expirado, ampliará el tiempo de vida de dicha entrada antes de refrescar las entradas de la caché. De esta manera, otros accesos concurrentes a la entrada de la caché expirada aún los sirve la caché por un cierto tiempo. Los demás accesos concurrentes no desencadenan un refresco concurrente. Lo ideal sería que las entradas de la caché fueran refrescadas por el cliente, el cual ampliaría el periodo de vida de las entradas de la caché antes de que otros clientes intenten refrescar la caché y ocasionar potencialmente una situación de sobrecarga.

Enfoque único para el almacenamiento en caché

PECL/mysqlnd_qc posee un enfoque único para almacenar en caché conjuntos de resultados que es superior al de las soluciones de caché basadas en aplicaciones. Éstas primero introducen un conjunto de resultados en variables de PHP. Luego, dichas variables son serializadas para el almacenamiento en una caché persistente, y luego deserializadas cuando se obtienen. La caché de consultas de mysqlnd almacena los datos sin tratar del protocolo de conexión enviados desde MySQL a PHP en su caché y los reproduce, si aún son válidos, para una búsqueda coincidente en la caché. De esta forma se ahorra un paso extra de serialización ya que todas las soluciones basadas en aplicaciones deben hacerlo. Puede almacenar los datos sin tratar del protocolo de conexión en la caché sin tener que serializarlos primero para una variable de PHP y deserializar dicha variable para almacenarlos de nuevo en la caché.


Puesta en marcha

El complemento está imlementado como una extensión de PHP. Véanse también las instrucciones de instalación para instalar la extensión » PECL/mysqlnd_qc.

Se ha de compilar o configurar la extensión (mysqli, PDO_MYSQL, mysql) que se planee utilizar con soporte para la biblioteca mysqlnd. PECL/mysqlnd_qc es un complemento para la biblioteca mysqlnd. Para usar el complemento con cualquier extensión de MySQL para PHP existente (APIs), la extensión ha de utilizar la biblioteca mysqlnd.

Luego, se ha de cargar la extensión en PHP y activar el complemento en el fichero de configuración de PHP usando la directiva de configuración de PHP llamada mysqlnd_qc.enable_qc.

Ejemplo #1 Habilitar el complemento (php.ini)

mysqlnd_qc.enable_qc=1


Almacenar consultas en la caché

Hay cuatro maneras de desencadenar el almacenamiento en caché de una consulta.

  • Usar sugerencias SQL en función de cada consulta
  • Llamadas de retorno porporcionadas por el usuario para decidir en función de cada consulta, por ejemplo, usando mysqlnd_qc_is_select()
  • mysqlnd_set_cache_condition() para reglas basadas en decisiones automáticas en cada consulta
  • mysqlnd_qc.cache_by_default = 1 para almacenar en caché todas las consultas a ciegas

El uso de las sugerencias SQL y de mysqlnd_qc.cache_by_default = 1 se expilca más abajo. Por vafor, consulte la referenca de la función mysqlnd_qc_is_select() para una descripción del uso de una llamada de retorno, y de mysqlnd_qc_set_cache_condition() sobre cómo establecer reglas para el almacenamiento automático en caché.

Una sugerencia SQL es un comentario que sigue los estándares. Como comentario de SQL, es ignorado por la base de datos. Una consulta es considerada candidata para su almacenamiento en caché si comienza con la sugerencia SQL que habilita dicho almacenamiento o si es una sentencia SELECT.

Una consulta individual que debiera ser almacenada debe comenzar con la sugerencia SQL /*qc=on*/. Se recomienda usar la constante de PHP MYSQLND_QC_ENABLE_SWITCH en lugar del valor de cadena.

  • no candidata para su almacenamiento en caché y no almacenada: INSERT INTO test(id) VALUES (1)

  • no candidata para su almacenamiento en caché y no almacenada: SHOW ENGINES

  • candidata para su almacenamiento en caché pero no almacenada: SELECT id FROM test

  • candidata para su almacenamiento y almacenada: /*qc=on*/SELECT id FROM test

Las sentencias SELECT del ejemplo están prefijadas con la sugerencia SQL MYSQLND_QC_ENABLE_SWITCH para habilitar su almacenamiento en caché. La sugerencia SQL debe colocarse al comienzo de la cadena de consulta para habilitar el almacenamiento en caché.

Ejemplo #1 Usar la sugerencia SQL MYSQLND_QC_ENABLE_SWITCH

mysqlnd_qc.enable_qc=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Será almacenada en caché debido a la sugerencia SQL */
$inicio = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Tiempo total de consulta no almacenada: %.6fs\n", microtime(true) - $inicio);

/* Coincidencia con la caché */
$inicio = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Tiempo total de consulta almacenada: %.6fs\n", microtime(true) - $inicio);
?>

El resultado de los ejemplos sería algo similar a:

array(1) {
  ["id"]=>
  string(1) "1"
}
Tiempo total de consulta no almacenada: 0.000740s
array(1) {
  ["id"]=>
  string(1) "1"
}
Tiempo total de consulta almacenada: 0.000098s

Si no se configura nada más, como es el caso del ejemplo de esta guía rápida, el complemento usará en gestor de almacenamiento interno default. El gestor de almacenamiento default utiliza la memoria del proceso para mantener una entrada de la caché. Dependiendo del modelo de desarrollo de PHP, un proceso de PHP podría servir una o más peticiones web. Por favor, consulte el manual del servidor web para más detalles. Los detalles son irrelevantes para los ejemplos dados en esta guía rápida.

El complemento de caché de consultas almacenará todas las consultas sin considerar si la cadena de consulta comienza con la sugerencia SQL que habilita dicho almacenamiento, si la directiva de configuración de PHP mysqlnd_qc.cache_by_default está establecida a 1. El ajuste mysqlnd_qc.cache_by_default es evaluado por el núcleo del complemento de caché de consultas. Ni el gestor de almacenamiento interno ni uno definido por el usuario pueden sobrescribir el ajuste.

La sugerencia SQL /*qc=off*/ se puede usar para deshabilitar el almacenamiento en caché de consultas individuales si mysqlnd_qc.cache_by_default = 1. Se recomienda usar la constante de PHP MYSQLND_QC_DISABLE_SWITCH en lugar del valor de cadena.

Ejemplo #2 Usar la sugerencia SQL MYSQLND_QC_DISABLE_SWITCH

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Será almacenada aunque no esté presente ninguna sugerencia SQL ya que mysqlnd_qc.cache_by_default = 1*/
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");

/* Coincidencia con la caché - ¡sin invalidación automática y aún válida! */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* No coincide con la caché - la consulta no debe almacenarse debido a la sugerencia SQL */
$res = $mysqli->query("/*" . MYSQLND_QC_DISABLE_SWITCH . "*/SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

El resultado de los ejemplos sería:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL

PECL/mysqlnd_qc prohíbe el almacenamiento en la caché de sentencias donde al menos una columna del conjunto de resultados de dichas sentencias no muestren el nombre de la tabla en sus metadatos de forma predeterminada. Éste normalmente es el caso para las columnas originadas desde funciones SQL tales como NOW() o LAST_INSERT_ID(). La política se dirige a prevenir fallos si se usa el almacenamiento por omisión.

Ejemplo #3 Ejemplo que muestra qué tipos de sentencias no son almacenadas en la caché

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $inicio = microtime(true);

    /* Nota: la sentencia no será almacenada debido al uso de NOW() */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $fila = $res->fetch_assoc();

    /* volcar resultados */
    var_dump($fila);

    printf("Tiempo total: %.6fs\n", microtime(true) - $inicio);

    /* pausar durante un segundo */
    sleep(1);
}
?>

El resultado de los ejemplos sería algo similar a:

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:10"
}
Tiempo total: 0.000540s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:11"
}
Tiempo total: 0.000555s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:12"
}
Tiempo total: 0.000549s

Es posible habilitar el almacenamiento en caché para todas las sentecias incluyendo aquellas que tienen columnas en su conjunto de resultados para las cuales MySQL no notifica una tabla, como la sentencia del ejemplo. Se ha de establecer mysqlnd_qc.cache_no_table = 1 para habilitar el almacenamiento en caché de tales sentencias. Por favor, observe la diferencia en los tiempos medidos para los ejemplos de arriba y de abajo.

Ejemplo #4 Habilitar el almacenamiento en caché de todas las sentencias usando el ajuste ini mysqlnd_qc.cache_no_table

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
mysqlnd_qc.cache_no_table=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $inicio = microtime(true);

    /* Nota: la sentencia no será almacenada debido al uso de NOW() */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $fila = $res->fetch_assoc();

    /* volcar resultados */
    var_dump($fila);

    printf("Tiempo total: %.6fs\n", microtime(true) - $inicio);

    /* pausar durante un segundo */
    sleep(1);
}
?>

El resultado de los ejemplos sería algo similar a:

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Tiempo total: 0.000546s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Tiempo total: 0.000187s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Tiempo total: 0.000167s

Nota:

Aunque mysqlnd_qc.cache_no_table = 1 haya sido creado para usarlo con mysqlnd_qc.cache_by_default = 1 está vilculado a él. El complemento evaluará mysqlnd_qc.cache_no_table siempre que se vaya a almacenar una consulta, sin importar si el almacenameinto en caché ha sido habilitado usando una sugerencia SQL o cualquier otra medida.


Establecer el tiempo de vida (TTL)

La estrategia de invalidación predeterminada del complemento de caché de consultas es el Tiempo de Vida (TTL de 'Time To Live' en inglés). Los gestores de almacenamiento internos usarán el TTL predeterminado definido por el valor de configuración de PHP mysqlnd_qc.ttl a menos que la cadena de consulta contenga una sugerencia para establecer un TTL diferente. El TTL se especifica en segundos. Por omisión, las entradas de la caché expirarán tras 30 segundos.

El ejemplo establece mysqlnd_qc.ttl=3 para almacenar en caché sentencias durante tres segundos por omisión. Cada segundo se actualiza un registro de la tabla de la base de datos para mantener el tiempo actual, y se ejecuta una sentencia SELECT para obtener el registro desde la base de datos. La sentencia SELECT se almacena en caché durante tres segundos debido a que está prefijada con la sugerencia SQL que habilita el almacenamiento en caché. La salida verifica que los resultados de la consulta son tomados desde la caché durante tres segundos antes de que sean refrescados.

Ejemplo #1 Establecer el TTL con el ajuste ini mysqlnd_qc.ttl

mysqlnd_qc.enable_qc=1
mysqlnd_qc.ttl=3
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id VARCHAR(255))");

for ($i = 0; $i < 7; $i++) {

    /* actualizar la fila de la BD  */
    if (!$mysqli->query("DELETE FROM test") ||
        !$mysqli->query("INSERT INTO test(id) VALUES (NOW())"))
      /* Por supuesto, un script de la vida real debería realizar un manejo de errores mejor */
      die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

    /* seleccionar la última fila pero almacenando en caché los resultados */
    $consulta  = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/";
    $consulta .= "SELECT id AS _time FROM test";
    if (!($res = $mysqli->query($consulta)) ||
        !($fila = $res->fetch_assoc()))
    {
      printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
    }
    $res->free();
    printf("Hora actual %s - Hora de la fila de la BD %s\n", date("H:i:s"), $fila['_time']);

    /* pausar durante un segundo */
    sleep(1);
}
?>

El resultado de los ejemplos sería algo similar a:

Hora actual 14:55:59 - Hora de la fila de la BD 2012-01-11 14:55:59
Hora actual 14:56:00 - Hora de la fila de la BD 2012-01-11 14:55:59
Hora actual 14:56:01 - Hora de la fila de la BD 2012-01-11 14:55:59
Hora actual 14:56:02 - Hora de la fila de la BD 2012-01-11 14:56:02
Hora actual 14:56:03 - Hora de la fila de la BD 2012-01-11 14:56:02
Hora actual 14:56:04 - Hora de la fila de la BD 2012-01-11 14:56:02
Hora actual 14:56:05 - Hora de la fila de la BD 2012-01-11 14:56:05

Como se puede ver en el ejemplo, cualquier caché basada en TTL puede servir datos antiguos. Las entradas de la caché no son automáticamente invalidadas si cambian los datos subyacentes. Las aplicaciones que usen la estragegia de invalidacón de TTL predeterminada deben poder funcionar correctamente con datos antiguos.

Un gestor de almacenamiento definido por el usuario puede implementar cualquier estrategia de invalidación para evitar esta limitación.

El TTL predeterminado se puede sobrescribir usando la sugerencia SQL /*qc_tt=seconds*/. Esta sugerencia SQL debe aparecer inmediatamente después de la sugerencia SQL que habilita el almacenamiento en caché. Se recomienda usar la constante de PHP MYSQLND_QC_TTL_SWITCH en lugar del valor de cadena.

Ejemplo #2 Establecer el TTL con sugerencias SQL

<?php
$inicio = microtime(true);

/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("TTL predeterminado\t: %d segundos\n", ini_get("mysqlnd_qc.ttl"));

/* Será almacenada en caché durante 2 segundos */
$sql = sprintf("/*%s*//*%s%d*/SELECT id FROM test WHERE id = 1", MYSQLND_QC_ENABLE_SWITCH, MYSQLND_QC_TTL_SWITCH, 2);
$res = $mysqli->query($sql);

var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");
sleep(1);

/* Coincidencia con la caché - ¡sin invalidación automática y aún válida! */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

sleep(2);

/* No coincide con la caché - la entrada de la caché ha expirado */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

printf("Tiempo de ejecución del script\t: %d segundos\n", microtime(true) - $inicio);
?>

El resultado de los ejemplos sería algo similar a:

TTL predeterminado      : 30 segundos
array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL
Tiempo de ejecución del script  : 3 segundos


Almacenamiento en caché basado en patrones

Una aplicación tiene tres opciones para indicarle a PECL/mysqlnd_qc si será usada una sentencia en particular. El enfoque más básico es almacenar en caché todas las sentencias estableciendo mysqlnd_qc.cache_by_default = 1. Este enfoque a menudo es poco práctico, aunque habilita a los usuarios realizar una estimación rápida sobre las ganancias de rendimiento máximas de la caché. Una aplicación diseñada para usar una caché podría prefijar las sentencias seleccionadas con las sugerencias SQL apropiadas. Sin embargo, alterar el código fuente de una aplicación podría no ser siempre posible o deseado, por ejemplo, para evitar problemas con actualizaciones de software. Por ello, PECL/mysqlnd_qc permite establecer una llamada de retorno que decida si una consulta será almacenada en caché.

La llamada de retorno se instala con la función mysqlnd_qc_set_is_select(). A la llamada de retorno se le proporciona una cadena de sentencia de cada sentencia inspeccionada por el complemento. Luego, la llamada de retorno puede decidir si almacenará en caché la función. La llamada de retonro debe devolver false si la sentencia no será almacenada en caché. Un valor de retorno de true hace que el complemento intente añadir la sentencia a la caché. A la entrada de la caché se le dará el TTL predeterminado ( mysqlnd_qc.ttl). Si la llamada de retorno devuelve un valor numérico se usará éste como el TTL en lugar del predeterminado global.

Ejemplo #1 Establecer una llamada de retorno con mysqlnd_qc_set_is_select()

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* llamada de retorno que decice si una consulta se almacena en caché */
function is_select($consulta) {
    static $patrones = array(
      /* true - usar lo predetermiando por mysqlnd_qc.ttl */
      "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
      /* 3 - usar TTL = 3 segundos */
      "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
    );

    /* comprobar si la consulta coincide con el patrón */
    foreach ($patrones as $patrón => $ttl) {
        if (preg_match($patrón, $consulta)) {
            printf("is_select(%45s): almacenada\n", $consulta);
            return $ttl;
        }
    }
    printf("is_select(%45s): no almacenada\n", $consulta);
    return false;
}
/* instalar la llamada de retorno */
mysqlnd_qc_set_is_select("is_select");

/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* colocada en la caché */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* coincidencia con la caché */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* colocada en la caché */
$mysqli->query("SELECT * FROM test");

$estadísticas = mysqlnd_qc_get_core_stats();
printf("Colocada en caché: %d\n", $estadísticas['cache_put']);
printf("Coincidencia con la caché: %d\n", $estadísticas['cache_hit']);
?>

El resultado de los ejemplos sería algo similar a:

is_select(                    DROP TABLE IF EXISTS test): no almacenada
is_select(                    CREATE TABLE test(id INT)): no almacenada
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): no almacenada
is_select(             SELECT id FROM test WHERE id = 1): almacenada
is_select(             SELECT id FROM test WHERE id = 1): almacenada
is_select(                           SELECT * FROM test): almacenada
Colocada en caché: 2
Coincidencia con la caché: 1

La llamada de retorno del ejemplo comprueba si una cadena de sentencia coincide con un patrón. Si éste es el caso, devuelve true para almacenar en caché la consulta usando el TTL global o un TTL alternativo.

Para minimizar los cambios en la aplicación, la llamada de retorno puede colocarse y registrarse en un fichero autoantepuesto.


Defensa de cierre

Una caché mal diseñada puede hacer más daño que bien. En el peor de los casos, una caché puede aumentar la carga del servidor de bases de datos en lugar de minimizarla. Una situación de sobrecarga puede ocurrir si una entrada de la caché altamente compartida expira (estampida de la caché).

Las entradas de la caché son compartidas y reutilizadas en diferentes grados, dependiendo del almacenamiento usado. El gestor de almacenamiento predeterminado almacena entradas en la memoria del proceso. Así, una entrada de la caché puede ser reutilzada durante el periodo de vida de un proceso. Otros procesos de PHP no puede acceder a ella. Si se usa Memcache, una entrada de la caché puede ser compartida entre múltiples procesos de PHP e incluso entre múltiples máquinas, dependiendo de la configuración que se use.

Si una entrada de la caché altamente compartida almacenada en, por ejemplo, Memcache expira, muchos clientes no obtendrán una coincidencia con la caché. Muchas peticiones de clientes ya no son servidas desde la caché, sino que se intenta ejecutar la consulta subyacente en el servidor de bases de datos. Hasta que la entrada de la caché sea refrescada, más y más clientes contactarán con el servidor de bases de datos. En el peor de los casos, el resultado será la pérdida total del servicio.

La sobrecarga se puede evitar usando un gestor de almacenamiento que limite la reutilización de entradas de la caché a unos pocos clientes. Entonces, como media, es probable que sólo un número limitado de clientes intenten refrescar una entrada de la caché de forma concurrente.

Adicionalmente, el mecanismo interno de defensa de cierre puede y debería usarse. Si está activada la defensa de cierre, a una entrada expirada se le amplía el tiempo de vida. El primer cliente que no obtenga una coincidencia con la caché para la entrada expirada intentará refrescar dicha entrada dentro del tiempo de vida ampliado. Todos los demás clientes que soliciten la entrada de la caché son servidos temporalmente desde la caché aunque el TTL original de dicha entrada haya expirado. Los demás clientes no experimentarán una no coincidencia con la caché antes de que se agote el tiempo de vida.

Ejemplo #1 Habilitar el mecanismo de defensa de cierre

mysqlnd_qc.slam_defense=1
mysqlnd_qc.slam_defense_ttl=1

El mecanismo de defensa de cierre se habilita con la directiva de configuración mysqlnd_qc.slam_defense. El tiempo de vida ampliado de una entrada de la caché se establece con mysqlnd_qc.slam_defense_ttl.

La función mysqlnd_qc_get_core_stats() devuelve un array de estadísticas. Las estadísticas slam_stale_refresh y slam_stale_hit son incrementadas si la defensa de cierre tiene lugar.

No es posible establecer una recomendación universal en la configuración de la defensa de cierre. Se advierte a los usuarios que monitoricen y prueben sus configuraciones y que deduzcan los ajustes en consecuencia.


Buscar candidatas a la caché

Una sentencia debería ser considerada para ser almacenada en la caché si se ejecuta a menudo y tiene un tiempo de ejecución largo. Las candidatas se buscan creando una lista de sentencias ordenadas por el producto del número de ejecuciones multiplicado por el tiempo de ejecución de la sentencia. La función mysqlnd_qc_get_query_trace_log() devuelve un registro de consultas que ayudan con la tarea.

Recopilar el rastreo de una consulta es una operación lenta. Por lo tanto, está deshabilitada de forma predeterminada. La directiva de configuración de PHP mysqlnd_qc.collect_query_trace se usa para habilitarla. El rastreo de la función contiene una entrada para cada consulta emitida antes de llamar a la función.

Ejemplo #1 Recopilar un rastreo de consulta

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* conectarse a MySQL */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");

/* consultas varias para rellenar el rastreo de consultas */
for ($i = 0; $i < 2; $i++) {
    $res = $mysqli->query("SELECT 1 AS _one FROM DUAL");
    $res->free();
}

/* volcar el rastreo */
var_dump(mysqlnd_qc_get_query_trace_log());
?>

El resultado de los ejemplos sería:

array(2) {
  [0]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
}

El rastreo se da con información desordenada. También se dan los tiempos y el origen de la llamada de la consulta. La propiedad 'origin' contiene un código de búsqueda de rastros para identificar el origen de la consulta. La profundidad de la búsqueda de rastros se puede limitar con la directiva de configuración de PHP mysqlnd_qc.query_trace_bt_depth. La profundidad predeterminada es 3.

Ejemplo #2 Establecer la profundidad de la búsqueda de rastros con el ajuste ini mysqlnd_qc.query_trace_bt_depth

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* conectarse a MySQL */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* consultas varias para rellenar el rastreo de consultas */
for ($i = 0; $i < 3; $i++) {
    $res = $mysqli->query("SELECT id FROM test WHERE id = " . $mysqli->real_escape_string($i));
    $res->free();
}

$rastreo = mysqlnd_qc_get_query_trace_log();
$resumen = array();
foreach ($rastreo as $entrada) {
    if (!isset($resumen[$entrada['query']])) {
        $resumen[$entrada['query']] = array(
            "executions" => 1,
            "time"       => $entrada['run_time'] + $entrada['store_time'],
        );
    } else {
        $resumen[$entrada['query']]['executions']++;
        $resumen[$entrada['query']]['time'] += $entrada['run_time'] + $entrada['store_time'];
    }
}

foreach ($resumen as $consulta => $detalles) {
    printf("%45s: %5dms (%dx)\n",
    $consulta, $detalles['time'], $detalles['executions']);
}
?>

El resultado de los ejemplos sería algo similar a:

                    DROP TABLE IF EXISTS test:     0ms (1x)
                    CREATE TABLE test(id INT):     0ms (1x)
    INSERT INTO test(id) VALUES (1), (2), (3):     0ms (1x)
             SELECT id FROM test WHERE id = 0:    25ms (1x)
             SELECT id FROM test WHERE id = 1:    10ms (1x)
             SELECT id FROM test WHERE id = 2:     9ms (1x)


Medir la eficiencia de la caché

PECL/mysqlnd_qc ofrece tres maneras de medir la eficiencia de la caché. La función mysqlnd_qc_get_normalized_query_trace_log() devuelve estadísticas acumuladas por la cadena de consulta normalizada, mysqlnd_qc_get_cache_info() proporciona información específica del gestor de almacenamiento que incluye una lista de todos los elementos almacenados en la caché, dependiendo de dicho gestor. Adicionalmente, el núcleo de PECL/mysqlnd_qc recopila estadísticas de resumen de alto nivel acumuladas por cada proceso de PHP. Las estadísticas de alto nivel son devueltas por mysqlnd_qc_get_core_stats().

Las funciones mysqlnd_qc_get_normalized_query_trace_log() y mysqlnd_qc_get_core_stats() no recopilarán datos a menos que dicha recopilación haya sido habilitada a través de sus directivas de configuración de PHP correspondientes. La recopilación de datos está deshabilitada de forma predeterminada por consideraciones de rendimiento. Se puede configurar con la opción mysqlnd_qc.time_statistics, la cual determina si se debería recopilar la información de los tiempos. La recopilación de las estadísticas de tiempo está habiltada de forma predeterminada, pero únicamente se lleva cabo si está habilitada la recopilación de datos en sí. El registro de estadísticas de tiempo ocasiona llamadas extra al sistema. En la mayoría de los casos, el beneficio de la monitorización es mayor que cualquier penalización de rendimiento potencial causado por las llamadas adicionales al sistema.

Ejemplo #1 Recopilar datos de estadísticas con el ajuste ini mysqlnd_qc.time_statistics

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* conectarse a MySQL */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* consultas varias */
for ($i = 1; $i <= 4; $i++) {
    $consulta = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($consulta);

    $res->free();
}

var_dump(mysqlnd_qc_get_core_stats());
?>

El resultado de los ejemplos sería algo similar a:

array(26) {
  ["cache_hit"]=>
  string(1) "2"
  ["cache_miss"]=>
  string(1) "2"
  ["cache_put"]=>
  string(1) "2"
  ["query_should_cache"]=>
  string(1) "4"
  ["query_should_not_cache"]=>
  string(1) "3"
  ["query_not_cached"]=>
  string(1) "3"
  ["query_could_cache"]=>
  string(1) "4"
  ["query_found_in_cache"]=>
  string(1) "2"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(2) "28"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "900"
  ["query_aggr_run_time_total"]=>
  string(3) "928"
  ["query_aggr_store_time_cache_hit"]=>
  string(2) "14"
  ["query_aggr_store_time_cache_put"]=>
  string(2) "40"
  ["query_aggr_store_time_total"]=>
  string(2) "54"
  ["receive_bytes_recorded"]=>
  string(3) "136"
  ["receive_bytes_replayed"]=>
  string(3) "136"
  ["send_bytes_recorded"]=>
  string(2) "84"
  ["send_bytes_replayed"]=>
  string(2) "84"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(1929695233)
}

Para una visión general se llama a mysqlnd_qc_get_core_stats(), que emite estadísticas relacionadas con el uso de la caché, los tiempos de caché y el tráfico. Los valores se acumulan en función de cada proceso para todas las consultas emitidas por cualquier llamada a la API de MySQL para PHP.

Algunos gestores de almacenamiento, como el gestor predetermindo, pueden informar de las entradas de la caché, de las estadísticas relacionadas con las entradas y de los metadatos de las consultas subyacentes a través de la función mysqlnd_qc_get_cache_info(). Por favor, observe que la información devuelta depende del gestor de almacenmiento. Los valores se acumulan en función de cada proceso.

Ejemplo #2 Ejemplo del uso de mysqlnd_qc_get_cache_info()

mysqlnd_qc.enable_qc=1
<?php
/* conectarse a MySQL */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* consultas varias para rellenar el rastreo de consultas */
for ($i = 1; $i <= 4; $i++) {
    $consulta = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($consulta);

    $res->free();
}

var_dump(mysqlnd_qc_get_cache_info());
?>

El resultado de los ejemplos sería algo similar a:

array(4) {
  ["num_entries"]=>
  int(2)
  ["handler"]=>
  string(7) "default"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(2) {
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 1"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(1)
        ["stored_size"]=>
        int(71)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(391)
        ["store_time"]=>
        int(27)
        ["min_run_time"]=>
        int(16)
        ["max_run_time"]=>
        int(16)
        ["min_store_time"]=>
        int(8)
        ["max_store_time"]=>
        int(8)
        ["avg_run_time"]=>
        int(8)
        ["avg_store_time"]=>
        int(4)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(1)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 0"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(0)
        ["stored_size"]=>
        int(65)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(299)
        ["store_time"]=>
        int(13)
        ["min_run_time"]=>
        int(11)
        ["max_run_time"]=>
        int(11)
        ["min_store_time"]=>
        int(6)
        ["max_store_time"]=>
        int(6)
        ["avg_run_time"]=>
        int(5)
        ["avg_store_time"]=>
        int(3)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(0)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
  }
}

Es posible disminuir más la granularidad de las estadísticas al nivel de la cadena de sentencia normalizada. Ésta es la cadena de sentencia con todos los parámetros reemplazados con signos de interrogación. Por ejemplo, las dos sentencias SELECT id FROM test WHERE id = 0 y SELECT id FROM test WHERE id = 1 se normalizan a SELECT id FROM test WHERE id = ?. Sus estadísticas se acumulan en una entrada para SELECT id FROM test WHERE id = ?.

Ejemplo #3 Ejemplo del uso de mysqlnd_qc_get_normalized_query_trace_log()

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* conectarse a MySQL */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* consultas varias para rellenar el rastreo de consultas */
for ($i = 1; $i <= 4; $i++) {
    $consulta = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($consulta);

    $res->free();
}

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

El resultado de los ejemplos sería algo similar a:

array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(46) "INSERT INTO test (id ) VALUES (? ), (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(4)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(179)
    ["min_run_time"]=>
    int(11)
    ["max_run_time"]=>
    int(393)
    ["avg_store_time"]=>
    int(12)
    ["min_store_time"]=>
    int(7)
    ["max_store_time"]=>
    int(25)
  }
}

La distribución del código fuente de PECL/mysqlnd_qc contiene el directorio web/ en el que se pueden encontrar scripts basados en monitorización que proporcionan un ejemplo de cómo escribir un monitor de caché. Por favor, siga las instrucciones proporcionadas en el código fuente.

Desde PECL/mysqlnd_qc 1.1.0 es posible escribir estadísticas en un fichero de registro. Véase mysqlnd_qc.collect_statistics_log_file.


Más allá del TTL: almacenamiento definido por el usuario

El complemento de caché de consultas admite el uso de gestores de almacenamiento definidos por el usuario. Éstos pueden usar algoritmos de invalidacion complejos de forma arbitraria y admitir medios de almacenamiento arbitrarios.

Todos los gestores de almacenamiento definidos por el usuario deben proporcionar una cierta interfaz. Las funciones del gestor de almacenamiento definido por el usuario serán llamadas por el núcleo del complemento de caché. La interfaz necesaria consiste en siete funciones públicas. El gestor de almacenamiento definido por el usuario, tanto procedimental como el orientado a objetos, debe implementar el mismo conjunto de funciones.

Ejemplo #1 Utilizar un gestor de almacenamiento definido por el usuario

<?php
/* Habilitar el almacenamiento en la caché predeterminado para todas las sentencas */
ini_set("mysqlnd_qc.cache_by_default", 1);

/* Funciones del gestor de almacenamiento procedimental definido por el usuario */

$__cache = array();

function get_hash($host_info, $port, $user, $db, $query) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    return md5(sprintf("%s%s%s%s%s", $host_info, $port, $user, $db, $query));
}

function find_query_in_cache($key) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $tmp = $__cache[$key];
        if ($tmp["valid_until"] < time()) {
            unset($__cache[$key]);
            $ret = NULL;
        } else {
            $ret = $__cache[$key]["data"];
        }
    } else {
        $ret = NULL;
    }

    return $ret;
}

function return_to_cache($key) {
    /*
     Invocada en una búsqueda coincidente en la caché después de haber procesado el
     almacenamiento de los datos, podría usarse como cuenta de referencia
    */
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());
}

function add_query_to_cache_if_not_exists($key, $data, $ttl, $run_time, $store_time, $row_count) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache[$key] = array(
        "data"               => $data,
        "row_count"          => $row_count,
        "valid_until"        => time() + $ttl,
        "hits"               => 0,
        "run_time"           => $run_time,
        "store_time"         => $store_time,
        "cached_run_times"   => array(),
        "cached_store_times" => array(),
    );

    return TRUE;
}

function query_is_select($query) {
    printf("\t%s('%s'): ", __FUNCTION__, $query);

    $ret = FALSE;
    if (stristr($query, "SELECT") !== FALSE) {
        /* almacenar en caché durante 5 segundos */
        $ret = 5;
    }

    printf("%s\n", (FALSE === $ret) ? "FALSE" : $ret);
    return $ret;
}

function update_query_run_time_stats($key, $run_time, $store_time) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $__cache[$key]['hits']++;
        $__cache[$key]["cached_run_times"][] = $run_time;
        $__cache[$key]["cached_store_times"][] = $store_time;
    }
}

function get_stats($key = NULL) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if ($key && isset($__cache[$key])) {
        $stats = $__cache[$key];
    } else {
        $stats = array();
        foreach ($__cache as $key => $details) {
            $stats[$key] = array(
               'hits'              => $details['hits'],
               'bytes'             => strlen($details['data']),
               'uncached_run_time' => $details['run_time'],
               'cached_run_time'   => (count($details['cached_run_times']))
                                      ? array_sum($details['cached_run_times']) / count($details['cached_run_times'])
                                      : 0,
            );
        }
    }

    return $stats;
}

function clear_cache() {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache = array();
    return TRUE;
}

/* Instalar el gestor de almacenamiento procedimental definido por el usuario */
if (!mysqlnd_qc_set_user_handlers("get_hash", "find_query_in_cache",
    "return_to_cache", "add_query_to_cache_if_not_exists",
    "query_is_select", "update_query_run_time_stats", "get_stats", "clear_cache")) {

        printf("Fallo al instalar el gestor de almacenmiento definido por el usuario\n");
}

/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("\nColocada en caché/sin coincidencia en la caché\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* Borrar el registro para verificar que obtenemos los datos desde la caché */
$mysqli->query("DELETE FROM test WHERE id = 1");

printf("\nCoincidencia con la caché\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

printf("\nMostrar las estadísticas de la caché\n");
var_dump(mysqlnd_qc_get_cache_info());

printf("\nVolcado de la caché, colocada en la caché/sin coincidencia en la caché");
var_dump(mysqlnd_qc_clear_cache());

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

El resultado de los ejemplos sería algo similar a:

        query_is_select('DROP TABLE IF EXISTS test'): FALSE
        query_is_select('CREATE TABLE test(id INT)'): FALSE
        query_is_select('INSERT INTO test(id) VALUES (1), (2)'): FALSE

Colocada en caché/sin coincidencia en la caché
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
array(1) {
  ["id"]=>
  string(1) "1"
}
        query_is_select('DELETE FROM test WHERE id = 1'): FALSE

Coincidencia con la caché
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        return_to_cache(1)
        update_query_run_time_stats(3)
array(1) {
  ["id"]=>
  string(1) "1"
}

Mostrar las estadísticas de la caché
        get_stats(0)
array(4) {
  ["num_entries"]=>
  int(1)
  ["handler"]=>
  string(4) "user"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(1) {
    ["18683c177dc89bb352b29965d112fdaa"]=>
    array(4) {
      ["hits"]=>
      int(1)
      ["bytes"]=>
      int(71)
      ["uncached_run_time"]=>
      int(398)
      ["cached_run_time"]=>
      int(4)
    }
  }
}

Volcado de la caché, colocada en la caché/sin coincidencia en la caché    clear_cache(0)
bool(true)
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
NULL


  • « Más allá del TTL: almacenamiento definido por el usuario
  • Requerimientos »
  • PHP Manual
  • mysqlnd_qc
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución


Requerimientos

PHP 5.3.3 o una versión más reciente de PHP.

PECL/mysqlnd_qc es un complemento de mysqlnd_qc. Se conecta a la biblioteca mysqlnd. Para usar este complemento con una extensión de MySQL para PHP, debe estar habilitada la extensión de mysqlnd (mysqli, mysql, o PDO_MYSQL).

Para usar el gestor de almacenamiento MEMCACHE: Use libmemcache 0.38 o superior. PECL/mysqlnd_qc 1.2 ha sido probada con libmemcache 1.4.0.

Para usar el gestor de almacenamiento sqlite: Use la extensión sqlite3 que se incluye con PHP.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mysqlnd_qc

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

mysqlnd_qc Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

mysqlnd_qc.enable_qc integer

Habilita o deshabilita el complemento. Si se deshabilita, la extensión no se acoplará a mysqlnd para servir como representante de las llamadas a la API en C de mysqlnd.

mysqlnd_qc.ttl integer

Tiempo de vida (TTL) predeterminado para las entradas de la caché, en segundos.

mysqlnd_qc.cache_by_default integer

Almacena en caché todas las consultas sin considerar si comienzan con la sugerencia SQL que habilita el uso de la caché de una consulta. El gestor de almacenamiento no puede sobrescribir el ajuste. Es evaluado por el núcleo del complemento.

mysqlnd_qc.cache_no_table integer

Si almacenar en caché consultas sin nombre de tabla en cualesquiera metadatos de columna de sus conjuntos de resultados, por ejemplo, SELECT SLEEP(1), SELECT NOW(), SELECT SUBSTRING().

mysqlnd_qc.use_request_time integer

¿Usar el tiempo de petición global de PHP para evitar llamadas a gettimeofday() del sistema? Si se usa el gestor de almacenamiento APC debería establecerse el valor de apc.use_request_time, si no, se generarán advertencias.

mysqlnd_qc.time_statistics integer

¿Recopilar el tiempo de ejecución y almacenar estadísticas de tiempo usando la llamada gettimeofday() del sistema? Los datos serán recopilados solamente si también se establece mysqlnd_qc.collect_statistics = 1.

mysqlnd_qc.collect_statistics integer

¿Recopilar estadísticas para mysqlnd_qc_get_core_stats()? ¡No influye a las estadísticas del gestor de almacenamiento! Las estadísticas del gestor pueden ser una parte integral del formato de almacenamiento interno del gestor. Por lo tanto, la recopilación de algunas estadísticas del gestor no se pueden deshabilitar.

mysqlnd_qc.collect_statistics-log-file integer

Si mysqlnd_qc.collect_statistics y mysqlnd_qc.collect_statistics_log_file están establecidos, el complemento copiará las estadísticas en el fichero de registro especificado cada 10 peticiones web durante el cierre de peticiones de PHP. Es necesario que el fichero de registro sea modificable por el usuario del servidor web.

Desde 1.1.0.

mysqlnd_qc.collect_query_trace integer

¿Recopilar el rastreo de consultas?

mysqlnd_qc.query_trace_bt_depth integer

Profundidad/nivel máximo de la búsqueda de rastros de código de consultas.

mysqlnd_qc.ignore_sql_comments integer

Si eliminar los comentarios de SQL de una cadena de consulta antes de usar el algoritmo hash para generar una clave de caché. Se ha de deshabilitar si no se desea que dos sentencias tales como SELECT /*my_source_ip=123*/ id FROM test y SELECT /*my_source_ip=456*/ id FROM test se refieran a la misma entrada de la caché.

Desde 1.1.0.

mysqlnd_qc.slam_defense integer

Activa la defensa de cierre basada en gestores (protección de la estampida de la caché) si está disponible. Soportado por los gestores de almacenamiento Default y APC.

mysqlnd_qc.slam_defense_ttl integer

TTL para las entradas antiguas de la caché que son servidas mientras otro cliente actualiza las entradas. Soportado por el gestor de almacenamiento APC.

mysqlnd_qc.collect_normalized_query_trace integer

¿Recopilar los rastreos de consultas normalizadas acumuladas? El ajuste no tiene efecto de forma predeterminada. Se ha de compilar la extensión usando NORM_QUERY_TRACE_LOG para poder usar el ajuste.

mysqlnd_qc.std_data_copy integer

Gestor de almacenamiento predeterminado: ¿copiar datos conectados a la caché? EXPERIMENTAL – ¡utilice la configuración predterminada!

mysqlnd_qc.apc_prefix string

El gestor de almancenamiento APC almacena datos en la caché de usuario de APC. El ajuste establece un prefijo para las entradas de la caché.

mysqlnd_qc.memc_server string

Gestor de almacenamiento MEMCACHE: host del servidor de memcache.

mysqlnd_qc.memc_port integer

Gestor de almacenamiento MEMCACHE: puerto del servidor de memcache.

mysqlnd_qc.sqlite_data_file string

Gestor de almacenamiento sqlite: fichero de datos. Cualquier configuración excepto :memory: podría ser un valor poco práctico.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Relacionadas con sugerencias SQL

Ejemplo #1 Usar constantes de sugerencias SQL

La caché de consultas está constrolada por sugerencias SQL. Las sugerencias SQL se usan para habilitar y deshabilitar el almacenamiento en la caché. Las sugerencias SQL se pueden usar para establecer el TTL de una consulta.

Las sugerencias SQL reconocidas por la caché de consultas se pueden cambiar manualmente en tiempo de compilación. Esto hace posible usar mysqlnd_qc en entornos en los cuales las sugerencias SQL predeterminadas ya son tomadas e interpretadas por otros sistemas. Por lo tanto, se recomienda usar constantes de cadena de sugerencias SQL en lugar de añadir manualmente las sugerencias SQL predeterminadas a las cadenas de consulta.

<?php
/* Usar constantes para una portabilidad máxima */
$consulta = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test";

/* Válido pero menos portable: TTL predeterminado */
$consulta = "/*qc=on*/SELECT id FROM test";

/* Válido pero menos portable: TTL por sentencia */
$consulta = "/*qc=on*//*qc_ttl=5*/SELECT id FROM test";

printf("MYSQLND_QC_ENABLE_SWITCH: %s\n", MYSQLND_QC_ENABLE_SWITCH);
printf("MYSQLND_QC_DISABLE_SWITCH: %s\n", MYSQLND_QC_DISABLE_SWITCH);
printf("MYSQLND_QC_TTL_SWITCH: %s\n", MYSQLND_QC_TTL_SWITCH);
?>

El resultado de los ejemplos sería:

MYSQLND_QC_ENABLE_SWITCH: qc=on
MYSQLND_QC_DISABLE_SWITCH: qc=off
MYSQLND_QC_TTL_SWITCH: qc_ttl=

MYSQLND_QC_ENABLE_SWITCH (string)
Sugerencia SQL usada para habilitar el almacenamiento en caché de una consulta.
MYSQLND_QC_DISABLE_SWITCH (string)
Sugerencia SQL usada para deshabilitar el almacenamiento en caché de una consulta si mysqlnd_qc.cache_by_default = 1.
MYSQLND_QC_TTL_SWITCH (string)
Sugerencia SQL usada para establecer el TTL de un conjunto de resultados.
MYSQLND_QC_SERVER_ID_SWITCH (string)
Esta sugerencia SQL no debería usarse en general. Es necesaria para PECL/mysqlnd_ms para agrupar entradas de la caché para una sentencia, excepto que originándose desde diferentes conexiones físicas. Si se usa esta sugerencia, las configuraciones de la conexión como el usuario, el nombre del host y el conjunto de caracteres, no son consideradas para generar una clave de caché de una consulta. En su lugar, se usan el valor dado y la cadena de consulta como entrada para la función de hash que genera la clave. PECL/mysqlnd_ms podría, si se le indica, almacenar en la caché resultados de los esclavos de Replicación MySQL. Ya que puede contener muchas conexiones al esclavo, la clave de la caché no será formada a partir de las configuraciones de usuario, nombre de host u otras configuraciones que podrían variar para las diferentes conexiones esclavas. En su lugar, PECL/mysqlnd_ms proporciona un identificador que hace referencia al grupo de conexiones esclavas que serán habilitadas para compartir las entradas en la caché sin importar cual era la conexión física esclava para generar la entrada en la caché. No se recomienda el uso de esta característica fuera de PECL/mysqlnd_ms.

Relacionadas con mysqlnd_qc_set_cache_condition()

Ejemplo #2 Ejemplo del uso de mysqlnd_qc_set_cache_condition()

La función mysqlnd_qc_set_cache_condition() permite establecer las condiciones para el almacenamiento en caché de sentencias que no comienzan con las sugerencias SQL necesarias para habilitar el almacenamiento en caché manual.

<?php
/* Almacenar en caché todos los accesos a tablas con nombre "new%" en el esquema/base de datos "bd_ejemplo" durante 1 segundo */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "bd_ejemplo.new%", 1)) {
  die("¡Error al establecer la condición de la caché!");
}

$mysqli = new mysqli("host", "usuario", "contraseña", "bd_ejemplo", "puerto");
/* almacenada en caché aunque no se proporcionó una sugerencia SQL  */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=bd_ejemplo;port=puerto", "usuario", "contraseña");
/* no almacenada en caché: sin sugerencia SQL, el patrón no coincide */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* almacenado en caché: TTL 1 segundo, el patrón coincide */
$pdo_mysql->query("SELECT id, title FROM news");
?>

MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN (int)
Usada como parámetro de mysqlnd_qc_set_cache_condition() para establecer las condiciones del almacenamiento en caché automático basado en esquemas.

Otras

El número de versión del complemento se puede obtener usando MYSQLND_QC_VERSION, que es la representación de tipo string del número de verisón numérica, o MYSQLND_QC_VERSION_ID, que es un integer como 10000. Los desarrolladores puede calcular el número de versión como sigue:

Versión (parte) | Ejemplo
Mayor*10000 | 1*10000 = 10000
Menor*100 | 0*100 = 0
Parche | 0 = 0
MYSQLND_QC_VERSION_ID | 10000

MYSQLND_QC_VERSION (string)
String con la versión del complemento, por ejemplo, 1.0.0-prototype.

MYSQLND_QC_VERSION_ID (int)
Número de versión del complemento, por ejemplo, 10000.


Funciones de mysqlnd_qc

Tabla de contenidos

  • mysqlnd_qc_clear_cache — Vacía todo el contenido de la caché
  • mysqlnd_qc_get_available_handlers — Devuelve una lista de los gestores de almacenamiento disponibles
  • mysqlnd_qc_get_cache_info — Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible
  • mysqlnd_qc_get_core_stats — Estadísticas recopiladas por el núcleo de la caché de consultas
  • mysqlnd_qc_get_normalized_query_trace_log — Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas
  • mysqlnd_qc_get_query_trace_log — Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas
  • mysqlnd_qc_set_cache_condition — Establece las condiciones para el almacenamiento en caché automático
  • mysqlnd_qc_set_is_select — Instala una llamada de retorno que decide si una sentencia es almacenada en caché
  • mysqlnd_qc_set_storage_handler — Cambia el gestor de almacenamiento en uso
  • mysqlnd_qc_set_user_handlers — Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario


Vacía todo el contenido de la caché

  • « Funciones de mysqlnd_qc
  • mysqlnd_qc_get_available_handlers »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Vacía todo el contenido de la caché

mysqlnd_qc_clear_cache

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_clear_cache — Vacía todo el contenido de la caché

Descripción

mysqlnd_qc_clear_cache ( ) : bool

Vacía el contenido de la caché.

El vaciado de la caché es responsabilidad del gestor de almacenamiento. Todos los gestores de almacenamiento internos excpeto memcache admiten el vaciado de la caché. El gestor de almacenamiento memcache no puede vaciar el contenido de su propia caché.

Los gestores de almacenamiento definidos por el usuario podrían o no soportar la operación.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Un valor de retorno de false indica que el vaciado de todo el contenido de la caché ha fallado o que la operación no está soportada por el gestor de almacenamiento activo. Las aplicaciones no deben esperar que al llamar a la función se vacíe siempre la caché.


Devuelve una lista de los gestores de almacenamiento disponibles

  • « mysqlnd_qc_clear_cache
  • mysqlnd_qc_get_cache_info »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Devuelve una lista de los gestores de almacenamiento disponibles

mysqlnd_qc_get_available_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_available_handlers — Devuelve una lista de los gestores de almacenamiento disponibles

Descripción

mysqlnd_qc_get_available_handlers ( ) : array

Los gestores de almacenamiento que están disponibles depende de la configuración en tiempo de compilación del complemento de caché de consultas. El gestor de almacenamiento predeterminado (default) siempre está disponible. Todos los demás gestores de almacenamiento deben habilitarse explícitamente al contruir la extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una rray de los gestores de almacenamiento internos disponibles. Para cada gestor de almacenamiento se proporcinan el número de versión y la cadena de versión.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_get_available_handlers()

<?php
var_dump(mysqlnd_qc_get_available_handlers());
?>

El resultado de los ejemplos sería:

array(5) {
  ["default"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["user"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["APC"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["MEMCACHE"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["sqlite"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
}

Ver también

  • Instalación
  • mysqlnd_qc_set_storage_handler() - Cambia el gestor de almacenamiento en uso


Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible

  • « mysqlnd_qc_get_available_handlers
  • mysqlnd_qc_get_core_stats »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible

mysqlnd_qc_get_cache_info

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_cache_info — Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible

Descripción

mysqlnd_qc_get_cache_info ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible. Si lo está, los datos serán devueltos para las entradas de la caché sujetos al gestor de almacenamiento activo. Los gestores de almacenamiento son libres de devolver cualquier datos. Se recomienda que los gestores de almacenamiento devuelvan al menos los datos proporcionados por el gestor predeterminado, si fuera téctinamente posible.

El ámbito de la información es el proceso de PHP. Dependiendo del modelo de desarrollo de PHP, un proceso podría servir una o más peticiones.

Los valores se acumulan para todas las actividades de la caché en función de cada gestor de almacenamiento. No es posible indicar cuántas consultas se orinigan desde mysqli, PDO_MySQL o mysql. Las llamadas a al API contribuyen a los valores de los datos acumulados. Use mysqlnd_qc_get_core_stats() para obtener los tiempos de los datos acumulados para todos los gestores de almacenamiento.

Array de información de la caché

handler string

El gestor de almacenamiento activo.

Todos los gestores de almacenamiento. Desde 1.0.0.

handler_version string

La versión del gestor de almacenamiento activo.

Todos los gestores de almacenamiento. Desde 1.0.0.

num_entries int

El número de entradas de la caché. El valor depende del gestor de almacenamiento en uso.

Los gestores de almacenamiento default, APC y SQLite proporcinan el número real de entradas de la caché.

El gestor de almacenamiento MEMCACHE siempre devuelve 0. MEMCACHE no admite el conteo del número de entradas de la caché.

Si se utiliza un gestor definido por el usuario, se informará del número de entradas de la propiedad data.

Desde 1.0.0.

data array

La versión del gestor de almacenamiento activo.

Datos adicionales dependientes del gestor de almacenamiento sobre las entradas de la caché. A los gestores de almacenamiento se les solicita que proporcionen información similar y comparable. Un gestor de almacenamiento definido por el usuario es libre de devolver cualesquiera datos.

Desde 1.0.0.

El gestor de almacenamiento default proporciona la siguiente información para la propiedad data.

La propiedad data contiene un hash. El hash es indexado por el identificador interno de entradas de la caché del gestor de almacenamiento. El identificador de entradas de la caché es legible por los humanos y contiene la cadena de consulta que dirige la entrada de la caché. Por favor, véase también el ejemplo de abajo. Se proporcionan los siguientes datos para cada entrada de la caché.

statistics array

Estadísticas de la entrada de la caché.

Desde 1.0.0.

Propiedad | Descripción | Versión
rows | Número de filas del conjunto de resultados almacenado en caché. | Desde 1.0.0.
stored_size | El tamaño del conjunto de resultados almacenado en caché en bytes. Éste es el tamaño de la carga útil. El valor no es conveniente para calcular el consumo total de memoria de todas las entradas de la caché incluyendo la carga adicional de las entradas de la caché. | Desde 1.0.0.
cache_hits | Cuantas veces se ha devuelto una entrada de la caché. | Desde 1.0.0.
run_time | Tiempo de ejecución de la sentencia a la que pertence la entrada de la caché. Éste es el tiempo de ejecución de la sentencia sin almacenar en la caché. Es el tiempo transcurrido entre el envío de la sentencia y la recepción de MySQL de una réplica desde MySQL. El tiempo ahorrado usando el complemento de caché de consultas se puede calcular de esta manera: cache_hits * ((run_time - avg_run_time) + (store_time - avg_store_time)). | Desde 1.0.0.
store_time | Tiempò de almacenamiento del conjunto de resultados de la sentencia a la que pertenece la entrada de la caché. Éste es el tiempo que se toma en obtener y almacenar los resultados de una sentencia no almacenada en caché. | Desde 1.0.0.
min_run_time | Tiempo mínimo de ejecución de la sentencia almacenada en caché. Cuánto tiempo se tarda en buscar la sentencia en la caché. | Desde 1.0.0.
min_store_time | Tiempo mínimo de almacenamiento de la sentencia almacenada en la caché. El tiempo que toma la obtención del conjunto de resultados almacenado en caché desde el medio de almacenamiento y decoficación. | Desde 1.0.0.
avg_run_time | Tiempo de ejecución medio de la sentencia almacenada en caché. | Desde 1.0.0.
avg_store_time | Tiempo de almacenamiento medio de la sentencia almacenada en caché. | Desde 1.0.0.
max_run_time | Tiempo de ejecución medio de la sentencia almacenada en caché. | Desde 1.0.0.
max_store_time | Tiempo de almacenamiento medio de la sentencia almacenada en caché. | Desde 1.0.0.
valid_until | Marca de tiempo del momento en que la entrada de la caché expira. | Desde 1.1.0.
metadata array

Metadatos de la entrada de la caché. Éstos son los metadatos proporcionados por MySQL junto con el conjunto de resultados de la sentencia en cuestión. Diferentes versiones del servidor MySQL podrían devolver diferentes metadatos. A diferencia de algunas extensiones de MySQL para PHP, no se intentan ocultar las dependencias de la versión del servidor MySQL y los detalles de la versión desde el llamador. Por favor, consulte la documentación de la API en C de MySQL del servidor de MySQL en uso para más detalles.

La lista de metadatos contiene una entrada por cada columna.

Desde 1.0.0.

Propiedad | Descripción | Versión
name | El nombre del campo. Dependiendo de la versión de MySQL, podría ser el nombre del alias del campo. | Desde 1.0.0.
org_name | El nombre del campo. | Desde 1.0.0.
table | El nombre de la tabla. Si se usó un alias para la tabla, esta propiedad normalmente contendrá dicho alias. | Desde 1.0.0.
org_table | El nombre de la tabla. | Desde 1.0.0.
db | El nombre de la base de datos/esquema. | Desde 1.0.0.
max_length | El ancho máximo del campo. Los detalles podrían variar según la versión del servidor MySQL. | Desde 1.0.0.
length | El ancho del campo. Los detalles podrían variar según la versión del servidor MySQL. | Desde 1.0.0.
type | El tipo de datos del campo. Los detalles podrían variar según el servidor MySQL en uso. Éste es el valor constante del tipo de la API en C de MySQL. Se recomienda usar las constantes de tipo proporcionadas por la extensión mysqli para comprobar su significado. No se deberían probar ciertos valores de tipos comparandos con ciertos números. | Desde 1.0.0.

El gestor de almacenamiento APC devuelve la misma información para la propiedad data, excepto sin metadata. Los metadata de una entrada de la caché se establecen a NULL.

El gestor de almacenamiento MEMCACHE no rellena la propiedad data. Las estadísticas no están disponibles en base cada entrada de la caché con el gestor de almacenamiento MEMCACHE.

Un gestor de almacenamiento definido por el usuario es libre de proporcionar cualquier dato.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_get_cache_info()

El ejemplo muestra la salida desde el gestor de almacenamiento interno predeterminado (default). Los demás gestores de almacenamiento podría notificar datos diferentes.

<?php
/* Rellenar la caché, p.ej. usando mysqli */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema");
$mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test");

/* Mostrar la información de la caché */
var_dump(mysqlnd_qc_get_cache_info());
?>

El resultado de los ejemplos sería:

array(4) {
 ["num_entries"]=>
 int(1)
 ["handler"]=>
 string(7) "default"
 ["handler_version"]=>
 string(5) "1.0.0"
 ["data"]=>
 array(1) {
   ["Localhost via UNIX socket 3306 user schema|/*qc=on*/SELECT id FROM test"]=>
   array(2) {
     ["statistics"]=>
     array(11) {
       ["rows"]=>
       int(6)
       ["stored_size"]=>
       int(101)
       ["cache_hits"]=>
       int(0)
       ["run_time"]=>
       int(471)
       ["store_time"]=>
       int(27)
       ["min_run_time"]=>
       int(0)
       ["max_run_time"]=>
       int(0)
       ["min_store_time"]=>
       int(0)
       ["max_store_time"]=>
       int(0)
       ["avg_run_time"]=>
       int(0)
       ["avg_store_time"]=>
       int(0)
     }
     ["metadata"]=>
     array(1) {
       [0]=>
       array(8) {
         ["name"]=>
         string(2) "id"
         ["orig_name"]=>
         string(2) "id"
         ["table"]=>
         string(4) "test"
         ["orig_table"]=>
         string(4) "test"
         ["db"]=>
         string(4) "schema"
         ["max_length"]=>
         int(1)
         ["length"]=>
         int(11)
         ["type"]=>
         int(3)
       }
     }
   }
 }
}

Ver también

  • mysqlnd_qc_get_core_stats() - Estadísticas recopiladas por el núcleo de la caché de consultas


Estadísticas recopiladas por el núcleo de la caché de consultas

  • « mysqlnd_qc_get_cache_info
  • mysqlnd_qc_get_normalized_query_trace_log »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Estadísticas recopiladas por el núcleo de la caché de consultas

mysqlnd_qc_get_core_stats

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_core_stats — Estadísticas recopiladas por el núcleo de la caché de consultas

Descripción

mysqlnd_qc_get_core_stats ( ) : array

Devuelve un array con las estadísticas recopiladas por el núcleo del complemento de caché. Se notificarán los mismos campos de datos para cualquier gestor de almacenamiento ya que los datos son recopilados por el núcleo.

El ajuste de configuraión de PHP mysqlnd_qc.collect_statistics controla la recopilación de estadísticas. Dicha recopilación está deshabilitada de forma predeterminada por motivos de rendimiento. La deshabilitación de la recopilación de estadísticas también deshabilitará la recopilación de las estadísticas relacionadas con los tiempos.

El ajuste de configuración de PHP mysqlnd_qc.collect_time_statistics controla la recopilación de estadísticas relacionadas con los tiempos.

El ámbito de las estadísticas del núcleo es el proceso de PHP. Dependiendo del modelo de desarrollo un proceso de PHP podría manejar una o múltiples peticiones.

Las estadísticas se acumulan para todas las entradas de la caché y para todos los gestores de almacenamiento. No es posible indicar cuántas consultas originadas desde las llamadas a las APIs de mysqli, PDO_MySQL o mysql han contribuido a los valores de los datos acumulados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array de estadísticas del núcleo

Estadística | Descripción | Versión
cache_hit | La sentencia se considera almacenable en caché y los datos almacenados en caché han sido reutilizados. La sentencia se considera almacenable en caché y ocurrió una no coincidencia con la caché, aunque alguien almacenó en caché dicha sentencia mientras se procesaba y por lo tanto se puuede obtener el resultado desde la caché refrescada. | Desde 1.0.0.
cache_miss La sentencia es considerada almacenable en caché...

  • ... y se ha añadido a la caché.

  • ... pero la directiva de configuración de PHP mysqlnd_qc.cache_no_table = 1 ha impedido su almacenamiento.

  • ... pero se solicita un conjunto de resultados no almacenado en búfer.

  • ... pero un conjunto de resultados almacenado en búfer estaba vacío.

Desde 1.0.0.
cache_put | La sentencia se considera almacenable en caché y ha sido añadida a la caché. Se ha de tener cuidado al calcular las estadísticas derivadas. Los gestores de almacenamiento con un tiempo de vida de almacenamiento más allá del ámbito del proceso podría notificar que cache_put = 0 junto con cache_hit > 0, si otro proceso ha rellenado la caché. Se podría usar num_entries desde mysqlnd_qc_get_cache_info() si el gestor lo admite (default, APC). | Desde 1.0.0.
query_should_cache | La sentencia se considera almacenable en caché basándose en el análisis de la cadena de consulta. La sentencia podría o no añadirse a la caché. Véase también cache_put. | Desde 1.0.0.
query_should_not_cache | La sentencia se considera no almacenable en caché basándose en el análisis de la cadena de consulta. | Desde 1.0.0.
query_not_cached | La sentencia se considera no almacenable en caché o sí se considera pero el gestor de almacenamiento no ha devuelto una clave hash para ella. | Desde 1.0.0.
query_could_cache La sentencia se considera almacenable en caché...

  • ... y ha sido ejecutada sin errores.

  • ... y los metadatos muestras al menos una columna del conjunto de resultados.

La sentencia podría o no estar ya en la caché. Podría ser o no añadida a la caché después. 		Desde 1.0.0.
query_found_in_cache | La sentencia se considera almacenable en caché y se ha encontrado en la misma, pero no se han reproducido los datos de la caché aún y no se ha enviado el conjunto de resultados al cliente todavía. Esto no se considera una coincidencia con la caché ya que el cliente no habría obtenido el resultado o los datos almacenados en la caché podrían ser defectuosos. | Desde 1.0.0.
query_uncached_other | La sentencia es considerada almacenable en caché y podría o no encontrarse ya en la misma, pero la reproducción de los datos almacenados en caché ha fallado, no hay ningún conjunto de resultados disponible, u ocurrió algún otro error.
query_uncached_no_table | Statement has not been cached because the result set has at least one column which has no table name in its meta data. An example of such a query is SELECT SLEEP(1). To cache those statements you have to change default value of the PHP configuration directive mysqlnd_qc.cache_no_table and set mysqlnd_qc.cache_no_table = 1. Often, it is not desired to cache such statements. | Desde 1.0.0.
query_uncached_use_result | La sentencia habría sido almacenada en caché si se hubiera usado un conjunto de resultados almacenado en búfer. La situación se considera también como una no coincidencia con la caché, por lo que cache_miss tambén serán incrementado. | Desde 1.0.0.
query_aggr_run_time_cache_hit | Tiempo de ejecución (ms) acumulado de todas las consultas almacenadas en caché. Las consultas almacenadas en caché son aquellas que han incrementado cache_hit. | Desde 1.0.0.
query_aggr_run_time_cache_put | Tiempo de ejecución (ms) acumulado de todas las consultas no almacenadas en caché que han sido colocadas en la misma. Véase también cache_put. | Desde 1.0.0.
query_aggr_run_time_total | Tiempo de ejecución (ms) acumulado de todas las consultas no almacenadas en caché que han sido inspeccionadas y ejecutadas por la caché de consultas. | Desde 1.0.0.
query_aggr_store_time_cache_hit | Tiempo de almacenamiento (ms) acumulado de todas las consultas almacenadas en caché. Las consultas almacenadas en caché son aquellas que han incrementado cache_hit. | Desde 1.0.0.
query_aggr_store_time_cache_put | Tiempo de almacenamiento (ms) acumulado de todas las consultas no almacenadas en caché que han sido colocadas en la misma. Véase también cache_put. | Desde 1.0.0.
query_aggr_store_time_total | Tiempo de almacenamiento (ms) acumulado de todas las consultas no almacenadas en caché que han sido inspeccionadas y ejecutadas por la caché de consultas. | Desde 1.0.0.
receive_bytes_recorded | El tráfico de red entrante registrado (bytes) enviado desde MySQL a PHP. El tráfico podría o no haber sido añadido a la caché. El tráfico es el total de todas las consultas sin tener en cuenta si se almacenaron o no en caché. | Desde 1.0.0.
receive_bytes_replayed | El tráfico de red reproducido durante el almacenamiento de la caché. Es la cantidad total de tráfico entrante ahorrado debido al uso del complemento de caché de consultas. | Desde 1.0.0.
send_bytes_recorded | El tráfico de red saliente registrado (bytes) enviado desde MySQL a PHP. El tráfico podría o no haber sido añadido a la caché. El tráfico es el total de todas las consultas sin tener en cuenta si se almacenaron o no en caché. | Desde 1.0.0.
send_bytes_replayed | El tráfico de red reproducido durante el almacenamiento de la caché. Es la cantidad total de tráfico saliente ahorrado debido al uso del complemento de caché de consultas. | Desde 1.0.0.
slam_stale_refresh | El número de no coincidencias con la caché que desencadenaron el servicio de datos antiguos hasta que el cliente ocasionó que la no coincidencia con la caché refrescara la entrada de la caché. | Desde 1.0.0.
slam_stale_hit | El número de coincidencias con la caché mientras se refrescaba una entrada antigua de la misma. | Desde 1.0.0.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_get_core_stats()

<?php
/* Habilitar la recopilación de estadísticas - predeterminado: deshabilitada */
ini_set("mysqlnd_qc.collect_statistics", 1);

/* Habilitar la recopilación de todos los tiempos relacionados con estadísticas -
predeterminado: habilitado pero invalidado por mysqlnd_qc.collect_statistics = 0 */
ini_set("mysqlnd_qc.collect_time_statistics", 1);

/* Rellenar la cacé, p.ej. usando mysqli */
$mysqli = new mysqli('host', 'usuario', 'contraseña', 'esquema');

/* No coincide con la caché y se coloca en la misma */
$mysqli->query("/*qc=on*/SELECT id FROM test");
/* Coincide con la caché */
$mysqli->query("/*qc=on*/SELECT id FROM test");

/* Mostrar las estadísticas del núcleo */
var_dump(mysqlnd_qc_get_core_stats());
?>

El resultado de los ejemplos sería:

array(26) {
  ["cache_hit"]=>
  string(1) "1"
  ["cache_miss"]=>
  string(1) "1"
  ["cache_put"]=>
  string(1) "1"
  ["query_should_cache"]=>
  string(1) "2"
  ["query_should_not_cache"]=>
  string(1) "0"
  ["query_not_cached"]=>
  string(1) "0"
  ["query_could_cache"]=>
  string(1) "2"
  ["query_found_in_cache"]=>
  string(1) "1"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(1) "4"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "395"
  ["query_aggr_run_time_total"]=>
  string(3) "399"
  ["query_aggr_store_time_cache_hit"]=>
  string(1) "2"
  ["query_aggr_store_time_cache_put"]=>
  string(1) "8"
  ["query_aggr_store_time_total"]=>
  string(2) "10"
  ["receive_bytes_recorded"]=>
  string(2) "65"
  ["receive_bytes_replayed"]=>
  string(2) "65"
  ["send_bytes_recorded"]=>
  string(2) "29"
  ["send_bytes_replayed"]=>
  string(2) "29"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(3547549858)
}

Ver también

  • Configuración en tiempo de ejecución
  • mysqlnd_qc.collect_statistics
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_cache_info() - Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible


Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas

  • « mysqlnd_qc_get_core_stats
  • mysqlnd_qc_get_query_trace_log »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas

mysqlnd_qc_get_normalized_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_normalized_query_trace_log — Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas

Descripción

mysqlnd_qc_get_normalized_query_trace_log ( ) : array

Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas. La recopilación del registro de rastreo está deshabilitada de forma predeterminada. Para recopilar el registro de rastreo se ha de establecer la directiva de configuración de PHP mysqlnd_qc.collect_normalized_query_trace a 1

Las entradas en el registro de rastreo están agrupadas por la sentencia de consulta normalizada. Dicha sentencia es la sentencia de consulta en donde todos los valores de sus parámetros han sido reemplazados por un signo de interrogación. Por ejemplo, Las dos sentencias SELECT id FROM test WHERE id = 1 y SELECT id FROM test WHERE id = 2 son normalizadas como SELECT id FROM test WHERE id = ?. Siempre que una sentencia sea inspeccionada por la caché de consultas y coincida con el patrón de sentencia normalizado, sus estadísticas son agrupadas por la cadena de sentencia normalizada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con el registro de consutas. Cada entrada de la lista contiene la cadena de consulta normalizada en información detallada.

Clave | Descripción
query | La cadena de sentencia normalizada.
occurences | Cuántas sentencias han coincidido con la cadena de sentencia normalizada además de la que creó la entrada en el registro. Este valor es cero si una sentencia ha sido normalizada, su representación normalizada ha sido añadida al registro y ninguna consulta inspeccionada por PECL/mysqlnd_qc tiene la misma cadena de sentencia normalizada.
eligible_for_caching | Si una sentencia podría ser almacenada en caché. Una sentencia candidata para ser almacenada en caché no tiene que ser almacenada necesariamente. No es posible indicar con certeza cuántas sentencias almacenadas en caché han contribuido a la entrada del registro de la sentencia normalizada acumulada. Sin embargo, comparando el tiempo de ejecución mínimo y medio se puede hacer una estimación fundamentada.
avg_run_time | El tiempo de ejecución medio de todas las consultas que contribuyen a la entrada del registro. El tiempo de ejcución es el intervalo entre el envío de la sentencia de consulta a MySQL y el recibimiento de la respuesta desde MySQL.
avg_store_time | El tiempo de almacenamiento medio de todas las consultas que contribuyen a la entrada del registro. El tiempo de almacenamiento es el tiempo necesario para obtener un conjunto de resultados de una sentencia desde el sevidor al cliente, y almacenarlo en el cliente.
min_run_time | El tiempo de ejecución mínimo de todas las consultas que contribuyen a la entrada del registro.
min_store_time | El tiempo de almacenamiento mínimo de todas las consultas que contribuyen a la entrada del registro.
max_run_time | El tiempo de ejecución máximo de todas las consultas que contribuyen a la entrada del registro.
max_store_time | El tiempo de almacenamiento máximo de todas las consultas que contribuyen a la entrada del registro.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_get_normalized_query_trace_log()

mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* no almacenanda en caché */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* colocada en caché */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* coincidencia en la caché */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

El resultado de los ejemplos sería:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(40) "INSERT INTO test (id ) VALUES (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(2)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(159)
    ["min_run_time"]=>
    int(12)
    ["max_run_time"]=>
    int(307)
    ["avg_store_time"]=>
    int(10)
    ["min_store_time"]=>
    int(8)
    ["max_store_time"]=>
    int(13)
  }
}

Ver también

  • Configuración en tiempo de ejecución
  • mysqlnd_qc.collect_normalized_query_trace
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_query_trace_log() - Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas


Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas

  • « mysqlnd_qc_get_normalized_query_trace_log
  • mysqlnd_qc_set_cache_condition »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas

mysqlnd_qc_get_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_query_trace_log — Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas

Descripción

mysqlnd_qc_get_query_trace_log ( ) : array

Devuelve un informe de rastreo para cada consulta inspeccionada por la caché de consultas. La recopilación de información de rastreo está deshabilitada de forma predeterminada. Para recopilar de información de rastreo se ha de establecer la directiva de configuración de PHP mysqlnd_qc.collect_query_trace a 1

La profundidad máxima de la búsqueda de rastreo está limitada por la profundidad establecida con la directiva de configuración de PHP mysqlnd_qc.query_trace_bt_depth.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de información de rastreo de consultas. Cada entrada de la lista contiene la cadena de consulta, información de rastreo y más información detallada.

Clave | Descripción
query | La cadena de consulta.
origin | El código de la información de rastreo.
run_time | El tiempo de ejecución de la consulta en milisegundos. La recopilación de todos los tiempos y las llamadas al sistema de gettimeofday necesarias se pueden deshabilitar estableciendo la directiva de configuración de PHP mysqlnd_qc.time_statistics a 0
store_time | El tiempo de almacenamiento del conjunto de resultados de la consultas en milisegundos. La recopilación de todos los tiempos y las llamadas al sistema de gettimeofday necesarias se pueden deshabilitar estableciendo la directiva de configuración de PHP mysqlnd_qc.time_statistics a 0
eligible_for_caching | true si la consulta es almacenable en caché, false si no.
no_table | true si la consulta ha generado un conjunto de resultados y al menos una columna del mismo no tiene un nombre de tabla establecido en sus metadatos. Éste normalmente es el caso de las consultas que no probablemente no se quieran almacenar en caché, tales como SELECT SLEEP(1). Por omisión, tales consultas no serán añadidas a la caché. Véase también la directiva de configuración de PHP mysqlnd_qc.cache_no_table.
was_added | true si el resultado de la consulta se ha colocado en la caché, false si no.
was_already_in_cache | true si el resultado de la consulta habría sido añadido a la caché si ya no estuviera en ella (coincidencia con la caché). De lo contrario false.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_get_query_trace_log()

mysqlnd_qc.collect_query_trace=1
<?php
/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema", "puerto", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* no almacenada en caché */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* colocada en la caché */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* coincidencia con la caché */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_query_trace_log());
?>

El resultado de los ejemplos sería:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(6) {
  [0]=>
  array(8) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["origin"]=>
    string(102) "#0 qc.php(4): mysqli->query('DROP TABLE IF E...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(25) "CREATE TABLE test(id INT)"
    ["origin"]=>
    string(102) "#0 qc.php(5): mysqli->query('CREATE TABLE te...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [2]=>
  array(8) {
    ["query"]=>
    string(36) "INSERT INTO test(id) VALUES (1), (2)"
    ["origin"]=>
    string(102) "#0 qc.php(6): mysqli->query('INSERT INTO tes...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [3]=>
  array(8) {
    ["query"]=>
    string(32) "SELECT id FROM test WHERE id = 1"
    ["origin"]=>
    string(102) "#0 qc.php(9): mysqli->query('SELECT id FROM ...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [4]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(14): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(311)
    ["store_time"]=>
    int(13)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(true)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [5]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(19): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(13)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(true)
  }
}

Ver también

  • Confiuguración en tiempo de ejecución
  • mysqlnd_qc.collect_query_trace
  • mysqlnd_qc.query_trace_bt_depth
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc.cache_no_table
  • mysqlnd_qc_get_normalized_query_trace_log() - Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas


Establece las condiciones para el almacenamiento en caché automático

  • « mysqlnd_qc_get_query_trace_log
  • mysqlnd_qc_set_is_select »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Establece las condiciones para el almacenamiento en caché automático

mysqlnd_qc_set_cache_condition

(PECL mysqlnd_qc >= 1.1.0)

mysqlnd_qc_set_cache_condition — Establece las condiciones para el almacenamiento en caché automático

Descripción

mysqlnd_qc_set_cache_condition ( int $condition_type , mixed $condition , mixed $condition_option ) : bool

Establece una condición para el almacenamiento en caché automático de sentencias que no contienen las sugerencias SQL necesarias para habilitar su almacenamiento en dicha caché.

Parámetros

condition_type

El tipo de condición. El único valor permitido es MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN.

condition

Parámetro para la condición establecida con condition_type. El tipo y la estructura del parámetro depende de condition_type

Si condition_type es igual a MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, condition debe ser una cadena. Ésta establece el patrón. Las setencias son almacenadas en caché si la tabla y la entrada de los metadatos de la base de datos de sus conjuntos de resultados coinceiden con el patrón. Dicho patrón se comprueba para ver si coincide con las entradas de los metadatos db y org_table proporcionadas por la biblioteca cliente-servidor de MySQL subyacente. Por favor, revise el manual de referencias de MySQL para los detalles de las dos entradas. Los valores de db y org_table son concatenados con un punto (.) antes de compararlos con condition. La comparación de patrones admite los comodines % y _. El comodín % coincidirá con uno o varios caracteres arbitrarios. _ coincidirá con un carácter arbitrario. El símbolo de escape es la barra invertida.

condition_option

Opción para condition. El tipo y la estructura dependen de condition_type.

Si condition_type es igual a MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, condition_options es el TTL a usar.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_set_cache_condition()

<?php
/* Almacenar en caché todos los accesos a las tablas con el nombre "new%" en el esquema/base de datos "ejemplo_db" durante 1 segundo */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "ejemplo_db.new%", 1)) {
  die("¡Fallo al establecer la condición de la caché!");
}

$mysqli = new mysqli("host", "usuario", "contraseña", "ejemplo_db", "puerto");
/* almacenada en caché aunque no se proporcione una sugerencia SQL */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=ejemplo_db;port=puerto", "usuario", "contraseña");
/* no almacenada en caché: sin sugerencia SQL, sin coincidencia con el patrón */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* almacenada en caché: TTL 1 segundo, coincide con el patrón */
$pdo_mysql->query("SELECT id, title FROM news");
?>

Valores devueltos

Devuelve TRUE en caso de éxito o FALSE en caso de error.

Ver también

  • Guía rápida: almacenamiento en caché basado en patrones


Instala una llamada de retorno que decide si una sentencia es almacenada en caché

  • « mysqlnd_qc_set_cache_condition
  • mysqlnd_qc_set_storage_handler »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Instala una llamada de retorno que decide si una sentencia es almacenada en caché

mysqlnd_qc_set_is_select

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_is_select — Instala una llamada de retorno que decide si una sentencia es almacenada en caché

Descripción

mysqlnd_qc_set_is_select ( string $callback ) : mixed

Instala una llamada de retorno que decide si una sentencia es almacenada en caché.

Hay varias maneras de indicarle a PELC/mysqlnd_qc que almacene en caché una consulta. Por omisión, PECL/mysqlnd_qc intenta almacenar en caché un a consulta si está habilitado el almacenamiento de todas las consultas o si la cadena de consulta comienza con una sugerencia SQL en particular. El complemento invoca internamente a una función llamada is_select() para averiguarlo. Esta función interna puede ser reemplazada con una llamada de retorno definida por el usuario. Entonces, dicha llamada de retorno definida por el usuario es responsable de decidir si el complemento intentará almacenar en caché una consulta. Debido a que la función interna es reemplazada por la llamada de retorno, ésta obtiene control total. La llamada de retorno es libre de ignorar el ajuste de configuración mysqlnd_qc.cache_by_default y las sugerencias SQL.

La llamada de retorno se invoca para cada sentencia inspeccionada por el complemento. Se le proporciona la cadena de sentencia como parámetro. La llamada de retorno devuelve false si la sentencia no fuera almacenada en caché. Devuelve true para hacer que el complemento intente almacenar en caché el conjunto de resultados de la sentencia, si exite. A una entrada de la caché creada de tal manera se le da el TTL predeterminado establecido con la directiva de configuración de PHP mysqlnd_qc.ttl. Si se usara un TTL diferente, la llamada de retorno devuelve un valor numérico que se usará como TTL.

La función interna is_select es parte de la interfaz interna del gestor de almacenamiento en caché. Por lo tanto, un gestor de almacenamiento definido por el usuario ofrece las mismas capacidades.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_set_is_select()

<?php
/* llamada de retorno que decide si una consulta es almacenada en caché */
function is_select($query) {
  static $patterns = array(
   /* true - usar lo predeterminado por mysqlnd_qc.ttl */
   "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
   /* 3 - usar TTL = 3 segundos */
   "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
  );
  /* comprobar si la consulta coincide con el patrón */
  foreach ($patterns as $pattern => $ttl) {
    if (preg_match($pattern, $query)) {
      printf("is_select(%45s): almacenada en caché\n", $query);
      return $ttl;
    }
  }
  printf("is_select(%45s): no almacenada en caché\n", $query);
  return false;
}
mysqlnd_qc_set_is_select("is_select");

/* Conectar, crear y rellenar la tabla test */
$mysqli = new mysqli("host", "usuario", "contraseña", "esquema");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* colocada en la caché */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* coincidencia con la caché */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* colocada en la caché */
$mysqli->query("SELECT * FROM test");
?>

El resultado de los ejemplos sería:

is_select(                    DROP TABLE IF EXISTS test): no almacenada en caché
is_select(                    CREATE TABLE test(id INT)): no almacenada en caché
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): no almacenada en caché
is_select(             SELECT id FROM test WHERE id = 1): almacenada en caché
is_select(             SELECT id FROM test WHERE id = 1): almacenada en caché
is_select(                           SELECT * FROM test): almacenada en caché

Ver también

  • Configuración en tiempo de ejecución
  • mysqlnd_qc.ttl
  • mysqlnd_qc.cache_by_default
  • mysqlnd_qc_set_user_handlers() - Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario


Cambia el gestor de almacenamiento en uso

  • « mysqlnd_qc_set_is_select
  • mysqlnd_qc_set_user_handlers »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Cambia el gestor de almacenamiento en uso

mysqlnd_qc_set_storage_handler

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_storage_handler — Cambia el gestor de almacenamiento en uso

Descripción

mysqlnd_qc_set_storage_handler ( string $handler ) : bool

Establece el gestor de almacenamiento usado por la caché de consultas. Se puede obtener una de los gestores de almacenamiento disponibles con mysqlnd_qc_get_available_handlers(). Los gestores que están disponibles dependen de la configuración en tiempo de compilación del complemento de caché de consultas. El gestor de almacenamiento default siempre está disponible. Todos los demás gestores de almacenmiento deben habilitarse explícitamente al construir la extensión.

Parámetros

handler

El gestor puede ser una cadena que representa el nombre de un gestor de almacenamiento interno, o un objeto de tipo mysqlnd_qc_handler_default. Los nombres de los gestores de almacenamiento internos son default, APC, MEMCACHE, sqlite.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Si el cambio del gestor de almacenamiento falla se lanzará un error fatal capturable. La caché de consultas no puede operar si el gestor de almacenamiento anterior ha sido cerrado y no se ha instalado un nuevo gestor de almacenamiento.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_qc_set_storage_handler()

El ejemplo muestra la salida desde el gestor de almacenamiento interno predeterminado (default). Los demás gestores de almacenamiento podrían mostrar datos diferentes.

<?php
var_dump(mysqlnd_qc_set_storage_handler("memcache"));

if (true === mysqlnd_qc_set_storage_handler("default"))
  printf("Activado el gestor de almacenamiento predeterminado");

/* Error fatal capturable */
var_dump(mysqlnd_qc_set_storage_handler("desconocido"));
?>

El resultado de los ejemplos sería:

bool(true)
Activado el gestor de almacenamiento predeterminado
Catchable fatal error: mysqlnd_qc_set_storage_handler(): Unknown handler 'desconocido' in (file) on line (line)

Ver también

  • Instalación
  • mysqlnd_qc_get_available_handlers() - Devuelve una lista de los gestores de almacenamiento disponibles


Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario

  • « mysqlnd_qc_set_storage_handler
  • Historal de cambios »
  • PHP Manual
  • Funciones de mysqlnd_qc
  • Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario

mysqlnd_qc_set_user_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_user_handlers — Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario

Descripción

mysqlnd_qc_set_user_handlers ( string $get_hash , string $find_query_in_cache , string $return_to_cache , string $add_query_to_cache_if_not_exists , string $query_is_select , string $update_query_run_time_stats , string $get_stats , string $clear_cache ) : bool

Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario.

Parámetros

get_hash

Nombre de la función de usuario que implementa la funcionalidad de get_hash del gestor de almacenamiento.

find_query_in_cache

Nombre de la función de usuario que implementa la funcionalidad de find_query_in_cache del gestor de almacenamiento.

return_to_cache

Nombre de la función de usuario que implementa la funcionalidad de return_to_cache del gestor de almacenamiento.

add_query_to_cache_if_not_exists

Nombre de la función de usuario que implementa la funcionalidad de add_query_to_cache_if_not_exists del gestor de almacenamiento.

query_is_select

Nombre de la función de usuario que implementa la funcionalidad de query_is_select del gestor de almacenamiento.

update_query_run_time_stats

Nombre de la función de usuario que implementa la funcionalidad de update_query_run_time_stats del gestor de almacenamiento.

get_stats

Nombre de la función de usuario que implementa la funcionalidad de get_stats del gestor de almacenamiento.

clear_cache

Nombre de la función de usuario que implementa la funcionalidad de clear_cache del gestor de almacenamiento.

Valores devueltos

Devuelve TRUE en caso de éxito o FALSE en caso de error.

Ver también

  • Ejemplo de un gestor de almacenamiento procedimental definido por el usuario


Historal de cambios

Tabla de contenidos

  • Serie PECL/mysqlnd_qc 1.2
  • Serie PECL/mysqlnd_qc 1.1
  • Serie PECL/mysqlnd_qc 1.0

Este historial de cambios es un resumen de alto nivel de los cambios seleccionados que pordrían tener un impacto sobre las aplicaciones y/o romper la retrocompatiblidad.

Véase también el fichero CHANGES en la distribución del código fuente para una lista completa de los cambios.


Serie PECL/mysqlnd_qc 1.2

1.2.0 - alpha

  • Fecha de publiacación: 03/2013
  • Motivo/tema: Compatibilidad con PHP 5.5

Cambios en las características

  • Actualización contruida para PHP 5.5 (Créditos: Remi Collet)

  • Actualización del gestor de almacenamiento de APC

    • Construcción corregida para APC 3.1.13-beta y tronco

  • Introducido MYSQLND_QC_VERSION y MYSQLND_QC_VERSION_ID.


Serie PECL/mysqlnd_qc 1.1

1.1.0 - stable

  • Fecha de publicación: 04/2012
  • Motivo/tema: Compatibilidad con PHP 5.4, soporte para uso de caché basado en patrones de esquema y mysqlnd_ms

1.1.0 - beta

  • Fecha de publicación: 04/2012
  • Motivo/tema: Compatibilidad con PHP 5.4, almacenamiento en caché basado en patrones y soporte para mysqlnd_ms

1.1.0 - alpha

  • Fecha de publicación: 04/2012
  • Motivo/tema: Compatibilidad con PHP 5.4, soporte para uso de caché basado en patrones de esquema y mysqlnd_ms

Cambios en las características

  • Actualización del gestor de almacenamiento APC

    • Construcción corregida para APC 3.1.9+
    • Nota: El uso del gestor de almacenamiento APC actualmente no está recomendado debido a problemas de estabilidad del mismo APC.

  • Nuevas directivas de configuración de PHP

    • mysqlnd_qc.collect_statistics_log_file. Se agregó el fichero de registro de estadísticas de la caché escrito después de cada 10 peticiones servidas por el proceso de PHP.
    • mysqlnd_qc.ignore_sql_comments. Controlar si los comentarios SQL son ignorados para la generación hash de claves de la caché.

  • Nuevas constantes y sugerencias SQL

    • MYSQLND_QC_SERVER_ID_SWITCH permite el agrupamiento de entradas de la caché desde diferentes conexiones físicas. Esto es necesario para PECL/mysqlnd_ms.
    • MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN para usarla con mysqlnd_qc_set_cache_condition().

  • La nueva función mysqlnd_qc_set_cache_condition() para el almacenamiento en caché basado en patrones de esquemas internos. Probablemente para dar soporte a un rango más amplio de condiciones en el futuro.

  • Informar de la marca de tiempo valid_until para entradas de la caché del gestor predeterminado a través de mysqlnd_qc_get_cache_info().

  • Incluir el número de conjuntos de caracteres para el uso de hash con las entradas de la caché. Esto debería evitar el servicio de conjuntos de resultados que tienen un conjunto de caracters erróneo.

    Cambio en la API: get_hash_key espera el nuevo parámetro "charsetnr" (int) después de "port".

  • Cambio en la API: cambiar la firma de is_select() de bool is_select() a mixed is_select(). Mixed puede ser o bien un valor booleano o un array(long ttl, string server_id). Esto es necesario para PECL/mysqlnd_ms.

Otros

  • Soporte para actuar como un sistema de caché para PECL/mysqlnd_ms 1.3.0-beta o superior para reemplazar de forma transparente las lecturas de esclavos de la Replicación MySQL con accesos a la caché, si el usuario lo permite explícitamente.

Errores corregidos

  • Error #59959 corregido (config.m4, biblioteca errónea - construcción del gestor de memcache de 64 bit) (Créditos: Remi Collet)


Serie PECL/mysqlnd_qc 1.0

1.0.1-stable

  • Fecha de publicación: 12/2010
  • Motivo/tema: Soporte para sentencias preparadas

Se añadió el soporte para sentencias preparadas y consultas no almacenadas en búfer.

1.0.0-beta

  • Fecha de publicación: 07/2010
  • Motivo/tema: Almacenamiento en caché basado en TTL con varias opciones de almacenamiento (Memcache, APC, SQLite, definido por el usuario)

Versión pública inicial del almacenamiento en caché transparente de resultados de consultas basado en TTL. Almacenamiento flexible de los resultados de la caché. Varios medios de almacenamiento admitidos.


Complemento de gestión del usuario de mysqlnd

  • Introducción
  • Guía rápida y ejemplos
    • Puesta en marcha
    • Cómo funciona
    • Instalar un proxy
    • Monitorización básica de consultas
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • MysqlndUhConnection — La clase MysqlndUhConnection
    • MysqlndUhConnection::changeUser — Cambia el usuario de la conexión de la base de datos de mysqlnd especificada
    • MysqlndUhConnection::charsetName — Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos
    • MysqlndUhConnection::close — Cierra una conexión a una base de datos abierta previamente
    • MysqlndUhConnection::connect — Abre una nueva conexión al servidor MySQL
    • MysqlndUhConnection::__construct — The __construct purpose
    • MysqlndUhConnection::endPSession — Finaliza una conexión persistente
    • MysqlndUhConnection::escapeString — Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
    • MysqlndUhConnection::getAffectedRows — Obtiene el número de filas afectadas en una operación de MySQL anterior
    • MysqlndUhConnection::getErrorNumber — Devuelve el código de error de la llamada más reciente a una función
    • MysqlndUhConnection::getErrorString — Devuelve una descripción del último error
    • MysqlndUhConnection::getFieldCount — Devuelve el número de columnas de la consulta más reciente
    • MysqlndUhConnection::getHostInformation — Devuelve una representación de tipo string del tipo de conexión usada
    • MysqlndUhConnection::getLastInsertId — Devuelve el id autogenerado en la última consulta
    • MysqlndUhConnection::getLastMessage — Recupera información sobre la consulta ejecutadamás recientemente
    • MysqlndUhConnection::getProtocolInformation — Devuelve la versión del protocolo de MySQL usado
    • MysqlndUhConnection::getServerInformation — Devuelve la versión del servidor MySQL
    • MysqlndUhConnection::getServerStatistics — Obtiene el estado actual del sistema
    • MysqlndUhConnection::getServerVersion — Devuelve la versión del servidor MySQL en forma de entero
    • MysqlndUhConnection::getSqlstate — Devuelve el error SQLSTATE de la operación anterior de MySQL
    • MysqlndUhConnection::getStatistics — Devuelve estadísticas sobre la conexión cliente
    • MysqlndUhConnection::getThreadId — Devuelve el ID del hilo de la conexión en uso
    • MysqlndUhConnection::getWarningCount — Devuelve el número de advertencias de la última consulta para el enlace dado
    • MysqlndUhConnection::init — Iniciliza una conexión de mysqlnd
    • MysqlndUhConnection::killConnection — Pregunta al servidor para matar un subproceso de MySQL
    • MysqlndUhConnection::listFields — Enumera los campos de una tabla de MySQL
    • MysqlndUhConnection::listMethod — Envoltura para comandos de listas desordenadas
    • MysqlndUhConnection::moreResults — Comprueba si existen más resultados de consultas en una multiconsulta
    • MysqlndUhConnection::nextResult — Prepara el siguiente resultado de multi_query
    • MysqlndUhConnection::ping — Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído
    • MysqlndUhConnection::query — Realiza una consulta en la base de datos
    • MysqlndUhConnection::queryReadResultsetHeader — Lee una cabecera del conjunto de resultados
    • MysqlndUhConnection::reapQuery — Obtiene el resultado de una consulta asicrónica
    • MysqlndUhConnection::refreshServer — Vacía o reinicia las tablas y las cachés
    • MysqlndUhConnection::restartPSession — Reinicializa una conexión persistente a mysqlnd
    • MysqlndUhConnection::selectDb — Selecciona la base de datos predeterminada para su consulta
    • MysqlndUhConnection::sendClose — Envía un comando de cierre a MySQL
    • MysqlndUhConnection::sendQuery — Envía una consulta a MySQL
    • MysqlndUhConnection::serverDumpDebugInformation — Vierte la información de depuración en el registro para el servidor MySQL
    • MysqlndUhConnection::setAutocommit — Activa o desactiva la autoconsigna de las modificaciones de la base de datos
    • MysqlndUhConnection::setCharset — Establece el conjunto de caracteres predeterminado del cliente
    • MysqlndUhConnection::setClientOption — Establece una opción del cliente
    • MysqlndUhConnection::setServerOption — Establece una opción del servidor
    • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand — Envía un comando COM_* básico
    • MysqlndUhConnection::simpleCommandHandleResponse — Procesa una respuesta para un comando COM_* básico enviado al cliente
    • MysqlndUhConnection::sslSet — Usado para establecer conexiones seguras con SSL
    • MysqlndUhConnection::stmtInit — Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare
    • MysqlndUhConnection::storeResult — Transfiere un conjunto de resultados de la última consulta
    • MysqlndUhConnection::txCommit — Consigna la transacción en uso
    • MysqlndUhConnection::txRollback — Revierte la transacción en uso
    • MysqlndUhConnection::useResult — Inicia una recuperación de un conjunto de resultados
  • MysqlndUhPreparedStatement — La clase MysqlndUhPreparedStatement
    • MysqlndUhPreparedStatement::__construct — The __construct purpose
    • MysqlndUhPreparedStatement::execute — Ejecuta una consulta preparada
    • MysqlndUhPreparedStatement::prepare — Prepara una sentencia SQL para su ejecución
  • Funciones de Mysqlnd_uh
    • mysqlnd_uh_convert_to_mysqlnd — Convierte un gestor de conexión de MySQL a uno de mysqlnd
    • mysqlnd_uh_set_connection_proxy — Instala un proxy para las conexiones de mysqlnd
    • mysqlnd_uh_set_statement_proxy — Instala un proxy para sentencias de mysqlnd
  • Historial de cambios
    • Serie PECL/mysqlnd_uh 1.0


Introducción

El complemento de gestión del usuario de mysqlnd (mysqlnd_uh) permite a los usuarios establecer ganchos para la mayoría de las llamadas internas del controlador nativo de MySQL para PHP (mysqlnd). Mysqlnd y sus complementos, incluido PECL/mysqlnd_uh, operan en una capa por debajo de las extensiones de MySQL para PHP. Un complemento de mysqlnd puede considerarse como un delegado (proxy) entre las extensiones de MySQL para PHP y el servidor MySQL como parte del ejecutable de PHP en el lado del cliente. Ya que los complementos operan en sus propias capas bajo las extensiones de MySQL para PHP, pueden monitorizar y cambiar las acciones de una aplicación sin la necesidad de efectuar cambios en la misma. Si las extensiones de MySQL para PHP (mysqli, mysql, PDO_MYSQL) están compiladas para usar mysqlnd, este comlemento puede utilizarse para:

  • Monitorizar

    • consultas ejecutas por cualquier extensión de MySQL para PHP

    • sentencias preparadas que son ejecutadas por cualquier extensión de MySQL para PHP

  • Auditar

    • la detección del uso de una base de datos

    • la protección contra inyecciones SQL usando listas negras y blancas

  • Varios

    • Conexiones con equilibrado de carga

El controlador nativo de MySQL para PHP (mysqlnd) introduce una API en C de complementos internos. Estos complementos, como el complemento de gestión del usuario, pueden ampliar la funcionalidad de mysqlnd. PECL/mysqlnd_uh es parte de la API en C de complementos internos disponibles para el usuario desarrollador con PHP.

Nota: Estado

El complemento de gestión del usuario de mysqlnd está en un estado alfa. Se han de tomar las precauciones pertinentes para usarlo en entornos de producción.

Consideraciones de seguridad

PECL/mysqlnd_uh proporciona a los usuarios el acceso a los nombres de usuario y contraseñas de MySQL usados por cualquier extensión de MySQL para PHP que se conecte a MySQL. Permite la monitorización de todas las consultas y sentencias preparadas exponiéndolas al usuario. Por lo tanto, la extensión debería ser instalada con precaución. El ajuste de configuración de PHP_INI_SYSTEM mysqlnd_uh.enable se puede usar para evitar que los usuarios capturen las llamadas a mysqlnd.

Los ofuscadores de código y tecnologías similares no son adecuados para evitar la monitorización de las actividades de la biblioteca mysqlnd si PECL/mysqlnd_uh está disponible y el usuario puede instalar un proxy, por ejemplo, usando auto_prepend_file.

Nota sobre la documentación

Muchas de las funciones de mysqlnd_uh están descritas brevemente debido a que la extensión mysqli es una fina capa de abstracción en lo alto de la API en C de MySQL que proporciona la biblioteca mysqlnd. Por lo tanto, se puede consultar la documentación correspondiente a mysqli (junto con el manual de referencia de MySQL manual) para recibir más información sobre una función en particular.

Sobre el nombre

La abreviatura mysqlnd_uh significa en español gestión del usuario de mysqlnd, y ha sido el nombre desde el desarrollo inicial del complemento.


Guía rápida y ejemplos

Tabla de contenidos

  • Puesta en marcha
  • Cómo funciona
  • Instalar un proxy
  • Monitorización básica de consultas

El complemento gestor del usuario de mysqlnd puede ser interpretado como un delegado (proxy) en la parte del cliente para todas las extensiones de MySQL para PHP (mysqli, mysql, PDO_MYSQL), si éstas están compiladas para utilizar la biblioteca mysqlnd. Dichas extensiones usan la biblioteca mysqlnd internamente, a nivel de C, para comunicarse con el servidor MySQL. PECL/mysqlnd_uh permite capturar muchas llamadas a mysqlnd. Por lo tanto, la mayoría de las actividades de las extensiones de MySQL para PHP pueden ser monitorizadas.

Ya que la monitorización sucede al nivel de la biblioteca, en una capa bajo la aplicación, es posible monitorizar aplicaciones sin tener que modificarlas.

En el nivel de C, la biblioteca mysqlnd está estructurada en módulos o clases. La extensión captura casi todos los métodos de la clase interna connection de mysqlnd y los expone a través de la clase del espacio de usuario MysqlndUhConnection. Unos pocos métodos de la clase interna statement de mysqlnd están disponibles para el usuario de PHP con la clase MysqlndUhPreparedStatement. Mediante la derivación de las clases MysqlndUhConnection y MysqlndUhPreparedStatement, los ususarios obtienen acceso a las llamadas a las funciones internas de mysqlnd.

Nota:

Las llamadas a las funciones internas de mysqlnd no estás diseñadas para ser expuestas al usuario de PHP. La manipulación de sus actividades podría causar que PHP falle o que se pierda memoria. A menudo, esto no se considera un fallo. Por favor, recuerde que se está accediendo a funciones de la biblioteca en C a través de PHP de las que se espera que realicen ciertas acciones, la cuales podrían no emularse en el espacio de usuario. Por lo tanto, se recomienda encarecidamente invocar siempre a la implementación del método padre cuando se derive de MysqlndUhConnection o de MysqlndUhPreparedStatement. Para prevenir el peor de los casos, la extensión lleva a cabo algunas comprobaciones sensatas. Por favor, véanse también las Opciones de configuración de Mysqlnd_uh.


Puesta en marcha

El complemento está implementado como una extensión de PHP. Véanse las instrucciones de instalación para instalar la extensión » PECL/mysqlnd_uh. Luego, se ha de cargar la estensión en PHP y activar el complemento en el fichero de configuración de PHP usando la directiva de configuración de PHP llamada mysqlnd_uh.enable. El ejemplo de abajo muestra la configuración predeterminada de la extensión.

Ejemplo #1 Habilitar el complemento (php.ini)

mysqlnd_uh.enable=1
mysqlnd_uh.report_wrong_types=1


Cómo funciona

Aquí se describe el funcionamiento de fondo e interno de la extensión mysqlnd_uh.

Se proporcionan dos clases con la extensión: MysqlndUhConnection y MysqlndUhPreparedStatement. MysqlndUhConnection permite acceder a casi todos los métodos de la clase interna connection de mysqlnd. La última expone algunos métodos seleccionados de la clase interna statement de mysqlnd. Por ejemplo, MysqlndUhConnection::connect() hace referencia a la función mysqlnd_conn__connect en C de la biblioteca mysqlnd.

Como complemento de mysqlnd, la extensión PECL/mysqlnd_uh reemplaza las funciones de la biblioteca en C mysqlnd con sus propias funciones. Siempre que una extensión de MySQL para PHP compilada para usar mysqlnd llame a una función de mysqlnd, se ejecutarán las funciones instaladas por el complemento en lugar de las originales de mysqlnd. Por ejemplo, mysqli_connect() invoca a mysqlnd_conn__connect, por lo que será llamada la función de conexión instaladas por PECL/mysqlnd_uh. Las funciones instaladas por PECL/mysqlnd_uh son métodos de clases internas.

Las clases de PHP internas y sus métodos no hacen sino llamar a sus homólogos de la biblioteca en C mysqlnd, para comportarse exactamente como la función original de mysqlnd que sustituyen. El código de abajo ilustra en pseudocódigo lo que hace la extensión.

Ejemplo #1 Pseudocódigo: qué hace la clase interna

class MysqlndUhConnection {
  public function connect(($conn, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
    MYSQLND* c_mysqlnd_connection = convert_from_php_to_c($conn);
    ...
    return call_c_function(mysqlnd_conn__connect(c_mysqlnd_connection, ...));
  }
}

Las clases internas se comportan como un procy transparente. Es posible reemplazar dicho procy con uno propio. Esto se lleva a cabo derivando MysqlndUhConnection o MysqlndUhPreparedStatement para extender la funcionalidad del procy, y después registrando un nuevo objeto procy. Los objetos proxy se instalan con mysqlnd_uh_set_connection_proxy() y mysqlnd_uh_set_statement_proxy().

Ejemplo #2 Instalar un proxy

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

El resultado del ejemplo sería:

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true


Instalar un proxy

La extensión proporciona dos clases internas: MysqlndUhConnection y MysqlndUhPreparedStatement. Estas clases se usan para capturar las llamadas a la biblioteca mysqlnd. Sus métodos se corresponden con las funciones internas de mysqlnd. Por omisión, actúan como un proxy transparente y no hacen nada sino llamar a sus homólogos de mysqlnd. Al derivar estas clases se puede instalar un proxy propio para monitorizar mysqlnd.

Véase también la guía Cómo funciona para aprender sobre el funcionamiento interno de esta extensión.

Los delegados (proxy) de conexiones son objetos de tipo MysqlndUhConnection. Dichos objetos se instalan con mysqlnd_uh_set_connection_proxy(). Si se instala la clase interna MysqlndUhConnection como un proxy, no ocurre nada; se comporta como un delegado transparente.

Ejemplo #1 Registro del proxy, mysqlnd_uh.enable=1

<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

La directiva de configuración de PHP_INI_SYSTEM mysqlnd_uh.enable controla si se puede establecer un proxy. Si está deshabilitada, la extensión lanzará errores de tipo E_WARNING

Ejemplo #2 La instalación del proxy deshabilitada

mysqlnd_uh.enable=0
<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

El resultado del ejemplo sería:

PHP Warning:  MysqlndUhConnection::__construct(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enabled = false.  You must not use any of the base classes in %s on line %d
PHP Warning:  mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed  in %s on line %d

Para monitorizar mysqlnd, se ha de escribir un objeto proxy propio derivando MysqlndUhConnection. Por favor, véase la referencia de la función para la lista de métodos que que se pueden derivar. De forma alternativa, se puede usar la reflexión para inspeccionar la clase interna MysqlndUhConnection.

Crear una nueva clase proxy. Derivarla de la clase interna MysqlndUhConnection. Reemplazar el método MysqlndUhConnection::connect(). Imprimir el valor del parámetro 'host' pasado al método. Asegurarse de que se llama a la implementación madre del método connect. No hacer todo esto podría proporcionar resultados inesperados y no deseados, incluyendo pérdidas de memoria y fallos.

Registrar el proxy y abrir tres conexiones usando las extensiones de MySQL para PHP mysqli, mysql, PDO_MYSQL. Si las extensiones han sido compiladas para usar la biblioteca mysqlnd, el método proxy::connect será llamado tres veces, una por cada conexión abierta.

Ejemplo #3 Proxy de conexión

<?php
class proxy extends MysqlndUhConnection {
  public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("Conexión abierta con '%s'\n", $host);
   /* ¡Llame siempre a la implementación madre! */
   return parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
  }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysql = mysql_connect("localhost", "root", "");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
?>

El resultado del ejemplo sería:

Conexión abierta con 'localhost'
Conexión abierta con 'localhost'
Conexión abierta con 'localhost'

El uso de delegados (proxy) de sentencias preparadas sigue el mismo patrón: crear un objeto proxy del tipo MysqlndUhPreparedStatement e instalar el proxy usando mysqlnd_uh_set_statement_proxy().

Ejemplo #4 Proxy de sentencia preparada

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, $query);
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL");
?>

El resultado del ejemplo sería:

stmt_proxy::prepare(SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL)


Monitorización básica de consultas

La monitorización básica de una sentencia de consulta es sencilla con PECL/mysqlnd_uh. Combinada con debug_print_backtrace() puede convertirse en una poderosa herramienta, por ejemplo, para buscar el origen de ciertas sentencias. Esto podría ser necesario cuando se buscan consultas lentas y también después de la refactoriazación de una base de datos para buscar código que aún accede a bases de datos o tablas obsoletas. Esto último podría ser un asunto complicado, especialmente si la aplicación utiliza consultas autogeneradas.

Ejemplo #1 Monitorización básica

<?php
class conn_proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  debug_print_backtrace();
  return parent::query($res, $query);
 }
}
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  debug_print_backtrace();
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_connection_proxy(new conn_proxy());
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

printf("Delegados instalados...\n");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
var_dump($pdo->query("SELECT 1 AS _one FROM DUAL")->fetchAll(PDO::FETCH_ASSOC));

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->prepare("SELECT 1 AS _two FROM DUAL");
?>

El resultado del ejemplo sería:

#0  conn_proxy->query(Resource id #19, SELECT 1 AS _one FROM DUAL)
#1  PDO->query(SELECT 1 AS _one FROM DUAL) called at [example.php:19]
array(1) {
  [0]=>
  array(1) {
    ["_one"]=>
    string(1) "1"
  }
}
#0  stmt_proxy->prepare(Resource id #753, SELECT 1 AS _two FROM DUAL)
#1  mysqli->prepare(SELECT 1 AS _two FROM DUAL) called at [example.php:22]

Para la monitorización básica de consultas se debería instalar un proxy de conexión y otro de sentencias preparadas. El primero debería derivar de MysqlndUhConnection::query(). Todas las consultas de una base de datos que no utilicen sentencias preparadas nativas llamarán a este método. En el ejemplo, la función query es invocada por una llamada a PDO. Por omisión, PDO_MySQL utiliza la emulación de sentencias preparadas.

Todas las sentencias preparadas nativas se preparan con con el método prepare de mysqlnd exportado a través de MysqlndUhPreparedStatement::prepare(). Se ha de derivar MysqlndUhPreparedStatement y sobrescribir prepare para monitorizar sentencias preparadas nativas.


Requerimientos

PHP 5.3.3 o posterior. Se recomienda usar PHP 5.4.0 o posterior para poder acceder a las últimas características de mysqlnd.

El complemento de gestión del usuario de mysqlnd_uh admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP disponibles (mysqli, mysql, PDO_MYSQL). Se debe configurar la extensión de MySQL para usar mysqlnd y poder utilizar el complemento mysqlnd_uh para mysqlnd.

La versión alfa utiilza algunas de las características de mysqli. Se ha de habilitar mysqli para compilar el complemento. Este requerimiento podría ser eliminado en el futuro. Observe que dicho requisito no restringe el uso del complemento solamente con mysqli. Se puede usar el complemento para monitorizar mysql, mysqli y PDO_MYSQL.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mysqlnd-uh

PECL/mysqlnd_uh actualmente no está disponible en Windows. El código fuente de la extensión utiliza los constructores C99 que no están permitidos en construcciones de PHP para Windows.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Mysqlnd_uh
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

mysqlnd_uh.enable integer

Habilita o deshabilita el complemento. Si se desbilita, la extensión no permitirá a los usuarios conectarse a mysqlnd para capturar las llamadas de mysqlnd.

mysqlnd_uh.report_wrong_types integer

Si se notifican los tipos de valores de retorno erróneos de los ganchos del usuario, como los niveles de error E_WARNING. Se recomienda para la detección de errores.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

La mayoría de estas constantes se refieren a los detalles del Protocolo Cliente Servidor de MySQL. Por favor, consulte el manual de referencia de MySQL para aprender sobre sus significados. Para evitar duplicación de contenido, solamente se proporcionan descriptciones breves.

Relacionadas con MysqlndUhConnection::simpleCommand()

Las siguientes constantes se puede usar para detectar el comando que se va a enviar a través de MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_COM_SLEEP (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_SLEEP.
MYSQLND_UH_MYSQLND_COM_QUIT (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_QUIT.
MYSQLND_UH_MYSQLND_COM_INIT_DB (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_INIT_DB.
MYSQLND_UH_MYSQLND_COM_QUERY (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_QUERY.
MYSQLND_UH_MYSQLND_COM_FIELD_LIST (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_FIELD_LIST.
MYSQLND_UH_MYSQLND_COM_CREATE_DB (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_CREATE_DB.
MYSQLND_UH_MYSQLND_COM_DROP_DB (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_DROP_DB.
MYSQLND_UH_MYSQLND_COM_REFRESH (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_REFRESH.
MYSQLND_UH_MYSQLND_COM_SHUTDOWN (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_SHUTDOWN.
MYSQLND_UH_MYSQLND_COM_STATISTICS (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STATISTICS.
MYSQLND_UH_MYSQLND_COM_PROCESS_INFO (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_PROCESS_INFO.
MYSQLND_UH_MYSQLND_COM_CONNECT (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_CONNECT.
MYSQLND_UH_MYSQLND_COM_PROCESS_KILL (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_PROCESS_KILL.
MYSQLND_UH_MYSQLND_COM_DEBUG (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_DEBUG.
MYSQLND_UH_MYSQLND_COM_PING (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_PING.
MYSQLND_UH_MYSQLND_COM_TIME (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_TIME.
MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_DELAYED_INSERT.
MYSQLND_UH_MYSQLND_COM_CHANGE_USER (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_CHANGE_USER.
MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_BINLOG_DUMP.
MYSQLND_UH_MYSQLND_COM_TABLE_DUMP (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_TABLE_DUMP.
MYSQLND_UH_MYSQLND_COM_CONNECT_OUT (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_CONNECT_OUT.
MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_REGISTER_SLAVED.
MYSQLND_UH_MYSQLND_COM_STMT_PREPARE (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_PREPARE.
MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_EXECUTE.
MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_SEND_LONG_DATA.
MYSQLND_UH_MYSQLND_COM_STMT_CLOSE (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_CLOSE.
MYSQLND_UH_MYSQLND_COM_STMT_RESET (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_RESET.
MYSQLND_UH_MYSQLND_COM_SET_OPTION (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_SET_OPTION.
MYSQLND_UH_MYSQLND_COM_STMT_FETCH (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_STMT_FETCH.
MYSQLND_UH_MYSQLND_COM_DAEMON (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_DAEMON.
MYSQLND_UH_MYSQLND_COM_END (integer)
Comando del protocolo Cliente Servidor de MySQL: COM_END.

Las siguientes constantes se pueden usar para analizar el argumento ok_packet de MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_PROT_GREET_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: greeting.
MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: authentication.
MYSQLND_UH_MYSQLND_PROT_OK_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: OK.
MYSQLND_UH_MYSQLND_PROT_EOF_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: EOF.
MYSQLND_UH_MYSQLND_PROT_CMD_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: command.
MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: result set header.
MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: resultset field.
MYSQLND_UH_MYSQLND_PROT_ROW_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: row.
MYSQLND_UH_MYSQLND_PROT_STATS_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: stats.
MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: prepare response.
MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET (integer)
Paquete del protocolo Cliente Servidor de MySQL: change user response.
MYSQLND_UH_MYSQLND_PROT_LAST (integer)
Sin significado práctico. El último marcador de entrada de la lista de estructura de datos de C interna.

Relacionadas con MysqlndUhConnection::close()

Las siguientes constantes se pueden usar para detectar por qué una conexión ha sido cerrada a través de MysqlndUhConnection::close().

MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT (integer)
El usuario ha llamado a mysqlnd para cerrar la conexión.
MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT (integer)
Cierre implícito, por ejemplo, durante una conexión basura.
MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED (integer)
Error de conexión.
MYSQLND_UH_MYSQLND_CLOSE_LAST (integer)
Sin significado práctico. El último marcador de entrada de la lista de estructura de datos de C interna.

Relacionadas con MysqlndUhConnection::setServerOption()

Las siguientes constantes se pueden usar para detectar qué opción está establecida a través de MysqlndUhConnection::setServerOption().

MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON (integer)
Opción: habilita el soporte para multisentencias.
MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF (integer)
Opción: deshabilita el soporte para multisentnecias.

Relacionadas con MysqlndUhConnection::setClientOption()

Las siguientes constantes se pueden usar para detectar qué opción esta seleccionada a través de MysqlndUhConnection::setClientOption().

MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT (integer)
Opción: tiempo de espera de la conexión.
MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS (integer)
Opción: si se va a usar el protocolo comprimido de MySQL.
MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE (integer)
Opción: tubería con nombre a usar para la conexións (Windows).
MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND (integer)
Opción: comando init para ejecutar sobre la conexión.
MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE (integer)
Opción: fichero predeterminado del servidor MySQL para la lectura sobre la conexión.
MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP (integer)
Opción: grupo de ficheros predeterminado del servidor MySQL para la lectura sobre la conexión.
MYSQLND_UH_MYSQLND_SET_CHARSET_DIR (integer)
Opción: directorio de ficheros de descripción de conjuntos de caracteres.
MYSQLND_UH_MYSQLND_SET_CHARSET_NAME (integer)
Opción: nombre del conjunto de caracteres.
MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE (integer)
Opción: Si permitir el uso de LOAD DATA LOCAL INFILE.
MYSQLND_UH_MYSQLND_OPT_PROTOCOL (integer)
Opción: versión del protocolo admitido.
MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME (integer)
Opción: nombre base de memoria compartida para las conexiones de memoria compartida.
MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT (integer)
Opción: tiempo de espera de lectura de la conexión.
MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT (integer)
Opción: tiempo de espera de escritura de la conexión.
MYSQLND_UH_MYSQLND_OPT_USE_RESULT (integer)
Opción: conjuntos de resultados no almacenados en búfer.
MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION (integer)
Relacionada con el servidor embebido.
MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION (integer)
Relacionada con el servidor embebido.
MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION (integer)
TODO
MYSQLND_UH_MYSQLND_SET_CLIENT_IP (integer)
TODO
MYSQLND_UH_MYSQLND_SECURE_AUTH (integer)
TODO
MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION (integer)
Opción: Si notificar el truncamiento de datos.
MYSQLND_UH_MYSQLND_OPT_RECONNECT (integer)
Opción: Si reconectar automáticamente.
MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT (integer)
Opción: TODO
MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE (integer)
Opción: tamaño del búfer de red de mysqlnd para comandos.
MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE (integer)
Opción: tamaño del búfer de red de mysqlnd para la lectura desde el servidor.
MYSQLND_UH_MYSQLND_OPT_SSL_KEY (integer)
Opción: clave SSL.
MYSQLND_UH_MYSQLND_OPT_SSL_CERT (integer)
Opción: certificado SSL.
MYSQLND_UH_MYSQLND_OPT_SSL_CA (integer)
Opción: AC SSL.
MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH (integer)
Opción: Ruta a la AC SSL.
MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER (integer)
Opción: cifra SSL.
MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE (integer)
Opción: frase secreta SSL.
MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR (integer)
Opción: directorio del complemento del servidor.
MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH (integer)
Opción: método de autenticación predeterminado.
MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP (integer)
TODO
MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET (integer)
Opción: tamaño de paquete máximo permitido. Disponible a partir de PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL (integer)
Opción: TODO. Disponible a partir de PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE (integer)
Opción: hacer que mysqlnd devuelva columnas de tipo integer y float como long incluso al usar el protocolo de texto del Cliente Servidor MySQL. Solamente disponible con una construcción personalizada de mysqlnd.

Otras

El número de versión del complemento se puede obtener usando MYSQLND_UH_VERSION o MYSQLND_UH_VERSION_ID. MYSQLND_UH_VERSION es la representación de cadena del número de versión MYSQLND_UH_VERSION_ID, el cual es un entero como 10000. Los desarrolladores pueden calcular el número de versión como sigue.

Versión (parte) | Ejemplo
Mayor*10000 | 1*10000 = 10000
Menor*100 | 0*100 = 0
Parche | 0 = 0
MYSQLND_UH_VERSION_ID | 10000

MYSQLND_UH_VERSION (string)
Cadena de la versión del complemento, por ejemplo, 1.0.0-alpha.
MYSQLND_UH_VERSION_ID (integer)
Número de versión del complemento, por ejemplo, 10000.


La clase MysqlndUhConnection

(PECL mysqlnd-uh >= 1.0.0-alpha)

Introducción

Sinopsis de la Clase

MysqlndUhConnection {
/* Métodos */
public changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len ) : bool
public charsetName ( mysqlnd_connection $connection ) : string
public close ( mysqlnd_connection $connection , int $close_type ) : bool
public connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags ) : bool
public __construct ( )
public endPSession ( mysqlnd_connection $connection ) : bool
public escapeString ( mysqlnd_connection $connection , string $escape_string ) : string
public getAffectedRows ( mysqlnd_connection $connection ) : int
public getErrorNumber ( mysqlnd_connection $connection ) : int
public getErrorString ( mysqlnd_connection $connection ) : string
public getFieldCount ( mysqlnd_connection $connection ) : int
public getHostInformation ( mysqlnd_connection $connection ) : string
public getLastInsertId ( mysqlnd_connection $connection ) : int
public getLastMessage ( mysqlnd_connection $connection ) : void
public getProtocolInformation ( mysqlnd_connection $connection ) : string
public getServerInformation ( mysqlnd_connection $connection ) : string
public getServerStatistics ( mysqlnd_connection $connection ) : string
public getServerVersion ( mysqlnd_connection $connection ) : int
public getSqlstate ( mysqlnd_connection $connection ) : string
public getStatistics ( mysqlnd_connection $connection ) : array
public getThreadId ( mysqlnd_connection $connection ) : int
public getWarningCount ( mysqlnd_connection $connection ) : int
public init ( mysqlnd_connection $connection ) : bool
public killConnection ( mysqlnd_connection $connection , int $pid ) : bool
public listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild ) : array
public listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 ) : void
public moreResults ( mysqlnd_connection $connection ) : bool
public nextResult ( mysqlnd_connection $connection ) : bool
public ping ( mysqlnd_connection $connection ) : bool
public query ( mysqlnd_connection $connection , string $query ) : bool
public queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt ) : bool
public reapQuery ( mysqlnd_connection $connection ) : bool
public refreshServer ( mysqlnd_connection $connection , int $options ) : bool
public restartPSession ( mysqlnd_connection $connection ) : bool
public selectDb ( mysqlnd_connection $connection , string $database ) : bool
public sendClose ( mysqlnd_connection $connection ) : bool
public sendQuery ( mysqlnd_connection $connection , string $query ) : bool
public serverDumpDebugInformation ( mysqlnd_connection $connection ) : bool
public setAutocommit ( mysqlnd_connection $connection , int $mode ) : bool
public setCharset ( mysqlnd_connection $connection , string $charset ) : bool
public setClientOption ( mysqlnd_connection $connection , int $option , int $value ) : bool
public setServerOption ( mysqlnd_connection $connection , int $option ) : void
public shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $"level" ) : void
public simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status ) : bool
public simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status ) : bool
public sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool
public stmtInit ( mysqlnd_connection $connection ) : resource
public storeResult ( mysqlnd_connection $connection ) : resource
public txCommit ( mysqlnd_connection $connection ) : bool
public txRollback ( mysqlnd_connection $connection ) : bool
public useResult ( mysqlnd_connection $connection ) : resource
}

Tabla de contenidos

  • MysqlndUhConnection::changeUser — Cambia el usuario de la conexión de la base de datos de mysqlnd especificada
  • MysqlndUhConnection::charsetName — Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos
  • MysqlndUhConnection::close — Cierra una conexión a una base de datos abierta previamente
  • MysqlndUhConnection::connect — Abre una nueva conexión al servidor MySQL
  • MysqlndUhConnection::__construct — The __construct purpose
  • MysqlndUhConnection::endPSession — Finaliza una conexión persistente
  • MysqlndUhConnection::escapeString — Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
  • MysqlndUhConnection::getAffectedRows — Obtiene el número de filas afectadas en una operación de MySQL anterior
  • MysqlndUhConnection::getErrorNumber — Devuelve el código de error de la llamada más reciente a una función
  • MysqlndUhConnection::getErrorString — Devuelve una descripción del último error
  • MysqlndUhConnection::getFieldCount — Devuelve el número de columnas de la consulta más reciente
  • MysqlndUhConnection::getHostInformation — Devuelve una representación de tipo string del tipo de conexión usada
  • MysqlndUhConnection::getLastInsertId — Devuelve el id autogenerado en la última consulta
  • MysqlndUhConnection::getLastMessage — Recupera información sobre la consulta ejecutadamás recientemente
  • MysqlndUhConnection::getProtocolInformation — Devuelve la versión del protocolo de MySQL usado
  • MysqlndUhConnection::getServerInformation — Devuelve la versión del servidor MySQL
  • MysqlndUhConnection::getServerStatistics — Obtiene el estado actual del sistema
  • MysqlndUhConnection::getServerVersion — Devuelve la versión del servidor MySQL en forma de entero
  • MysqlndUhConnection::getSqlstate — Devuelve el error SQLSTATE de la operación anterior de MySQL
  • MysqlndUhConnection::getStatistics — Devuelve estadísticas sobre la conexión cliente
  • MysqlndUhConnection::getThreadId — Devuelve el ID del hilo de la conexión en uso
  • MysqlndUhConnection::getWarningCount — Devuelve el número de advertencias de la última consulta para el enlace dado
  • MysqlndUhConnection::init — Iniciliza una conexión de mysqlnd
  • MysqlndUhConnection::killConnection — Pregunta al servidor para matar un subproceso de MySQL
  • MysqlndUhConnection::listFields — Enumera los campos de una tabla de MySQL
  • MysqlndUhConnection::listMethod — Envoltura para comandos de listas desordenadas
  • MysqlndUhConnection::moreResults — Comprueba si existen más resultados de consultas en una multiconsulta
  • MysqlndUhConnection::nextResult — Prepara el siguiente resultado de multi_query
  • MysqlndUhConnection::ping — Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído
  • MysqlndUhConnection::query — Realiza una consulta en la base de datos
  • MysqlndUhConnection::queryReadResultsetHeader — Lee una cabecera del conjunto de resultados
  • MysqlndUhConnection::reapQuery — Obtiene el resultado de una consulta asicrónica
  • MysqlndUhConnection::refreshServer — Vacía o reinicia las tablas y las cachés
  • MysqlndUhConnection::restartPSession — Reinicializa una conexión persistente a mysqlnd
  • MysqlndUhConnection::selectDb — Selecciona la base de datos predeterminada para su consulta
  • MysqlndUhConnection::sendClose — Envía un comando de cierre a MySQL
  • MysqlndUhConnection::sendQuery — Envía una consulta a MySQL
  • MysqlndUhConnection::serverDumpDebugInformation — Vierte la información de depuración en el registro para el servidor MySQL
  • MysqlndUhConnection::setAutocommit — Activa o desactiva la autoconsigna de las modificaciones de la base de datos
  • MysqlndUhConnection::setCharset — Establece el conjunto de caracteres predeterminado del cliente
  • MysqlndUhConnection::setClientOption — Establece una opción del cliente
  • MysqlndUhConnection::setServerOption — Establece una opción del servidor
  • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
  • MysqlndUhConnection::simpleCommand — Envía un comando COM_* básico
  • MysqlndUhConnection::simpleCommandHandleResponse — Procesa una respuesta para un comando COM_* básico enviado al cliente
  • MysqlndUhConnection::sslSet — Usado para establecer conexiones seguras con SSL
  • MysqlndUhConnection::stmtInit — Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare
  • MysqlndUhConnection::storeResult — Transfiere un conjunto de resultados de la última consulta
  • MysqlndUhConnection::txCommit — Consigna la transacción en uso
  • MysqlndUhConnection::txRollback — Revierte la transacción en uso
  • MysqlndUhConnection::useResult — Inicia una recuperación de un conjunto de resultados


Cambia el usuario de la conexión de la base de datos de mysqlnd especificada

  • « MysqlndUhConnection
  • MysqlndUhConnection::charsetName »
  • PHP Manual
  • MysqlndUhConnection
  • Cambia el usuario de la conexión de la base de datos de mysqlnd especificada

MysqlndUhConnection::changeUser

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::changeUser — Cambia el usuario de la conexión de la base de datos de mysqlnd especificada

Descripción

public MysqlndUhConnection::changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len ) : bool

Cambia el usuario de la conexión de la base de datos de mysqlnd especificada.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

user

El nombre de usuario de MySQL.

password

La contraseña de MySQL.

database

La base de datos de MySQL a la que cambiar.

silent

Controla si a mysqlnd le está permitido emitir errores o no.

passwd_len

La longitud de la contraseña de MySQL.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::changeUser()

<?php
class proxy extends MysqlndUhConnection {
 /* Enganchar la llamada a connection::change_user de  mysqlnd */
 public function changeUser($res, $user, $passwd, $db, $silent, $passwd_len) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::changeUser($res, $user, $passwd, $db, $silent, $passwd_len);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
/* Instalar los proxys/ganchos a usar con todas las futuras conexiones de mysqlnd */
mysqlnd_uh_set_connection_proxy(new proxy());

/* Crear una conexión mysqli que esté usando la biblioteca mysqlnd */
$mysqli = new mysqli("localhost", "root", "", "test");

/* Ejemplo de una llamada de la API de usuario que desencadena la llamada a mysqlnd enganchada */
var_dump($mysqli->change_user("root", "bar", "test"));
?>

El resultado del ejemplo sería:

proxy::changeUser(array (
  0 => NULL,
  1 => 'root',
  2 => 'bar',
  3 => 'test',
  4 => false,
  5 => 3,
))
proxy::changeUser returns false
bool(false)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_change_user() - Cambia el usuario de la conexión de bases de datos especificada


Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos

  • « MysqlndUhConnection::changeUser
  • MysqlndUhConnection::close »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos

MysqlndUhConnection::charsetName

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::charsetName — Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos

Descripción

public MysqlndUhConnection::charsetName ( mysqlnd_connection $connection ) : string

Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El conjunto de caracteres predeterminado.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::charsetName()

<?php
class proxy extends MysqlndUhConnection {
  public function charsetName($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::charsetName($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_character_set_name($mysqli));
?>

El resultado del ejemplo sería:

proxy::charsetName(array (
  0 => NULL,
))
proxy::charsetName returns 'latin1'
string(6) "latin1"

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_character_set_name() - Devuelve el juego de caracteres predeterminado para la conexión a la base de datos


Cierra una conexión a una base de datos abierta previamente

  • « MysqlndUhConnection::charsetName
  • MysqlndUhConnection::connect »
  • PHP Manual
  • MysqlndUhConnection
  • Cierra una conexión a una base de datos abierta previamente

MysqlndUhConnection::close

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::close — Cierra una conexión a una base de datos abierta previamente

Descripción

public MysqlndUhConnection::close ( mysqlnd_connection $connection , int $close_type ) : bool

Cierra una conexión a una base de datos abierta previamente.

Nota:

El no llamar a la implmentación made podría ocasionar pérdidas de memoria o que PHP falle. Esto no se considera un error. Por favor, recuerde que las funciones de la biblioteca mysqlnd no han sido diseñadas para ser expuestas al espacio de usuario.

Parámetros

connection

La conexión a cerrar. ¡No modificar!

close_type

Por qué la conexión se va a cerrar. El valor de close_type es una de la consntantes MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT, MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT, MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED o MYSQLND_UH_MYSQLND_CLOSE_LAST. Esta última no debería usarse, a menos que el comportamiento predeterminado de la biblioteca mysqlnd haya sido cambiado por un complemento.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::close()

<?php
function close_type_to_string($close_type) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED => "MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED",
  MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_LAST => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT"
 );
 return (isset($mapping[$close_type])) ? $mapping[$close_type] : 'unknown';
}

class proxy extends MysqlndUhConnection {
  public function close($res, $close_type) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   printf("close_type = %s\n", close_type_to_string($close_type));
   /* ADVERTENCIA: se debe llamar al padre */
   $ret = parent::close($res, $close_type);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

El resultado del ejemplo sería:

proxy::close(array (
  0 => NULL,
  1 => 0,
))
close_type = MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT
proxy::close returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_close() - Cierra una conexión previamente abierta a una base de datos
  • mysql_close() - Cerrar una conexión de MySQL


Abre una nueva conexión al servidor MySQL

  • « MysqlndUhConnection::close
  • MysqlndUhConnection::__construct »
  • PHP Manual
  • MysqlndUhConnection
  • Abre una nueva conexión al servidor MySQL

MysqlndUhConnection::connect

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::connect — Abre una nueva conexión al servidor MySQL

Descripción

public MysqlndUhConnection::connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags ) : bool

Abre una nueva conexión al servidor MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

host

Puede ser un nombre de host o una dirección IP. Si se pasa el valor NULL o la cadena "localhost" a este parámetro, se asume el host local. Cuando sea posible, se usará tuberías en lugar del protocolo TCP/IP.

user

El nombre del usuario de MySQL.

password

Si no se proporciona o es null, el servidor MySQL intentará autenticar al usuario únicamente con aquellos registro de usuarios que no tengan contraseña. Esto permite que el un nombre de usuario sea utlizado con diferentes permisos (dependiendo de si se proporcionó o no una contraseña).

database

If provided will specify the default database to be used when performing queries.

port

Especifica el número de puerto al que intentar conectarse al servidor MySQL.

socket

Especifica el socked o la tubería con nombre que debería usarse. Si es null, mysqlnd usará de forma predeterminada /tmp/mysql.sock.

mysql_flags

Opciones de conexión.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::connect()

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

El resultado del ejemplo sería:

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_connect() - Alias de mysqli::__construct
  • mysql_connect() - Abre una conexión al servidor MySQL


The __construct purpose

  • « MysqlndUhConnection::connect
  • MysqlndUhConnection::endPSession »
  • PHP Manual
  • MysqlndUhConnection
  • The __construct purpose

MysqlndUhConnection::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::__construct — The __construct purpose

Descripción

public MysqlndUhConnection::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Finaliza una conexión persistente

  • « MysqlndUhConnection::__construct
  • MysqlndUhConnection::escapeString »
  • PHP Manual
  • MysqlndUhConnection
  • Finaliza una conexión persistente

MysqlndUhConnection::endPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::endPSession — Finaliza una conexión persistente

Descripción

public MysqlndUhConnection::endPSession ( mysqlnd_connection $connection ) : bool

Finaliza una conexión persistente.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::endPSession()

<?php
class proxy extends MysqlndUhConnection {
 public function endPSession($conn) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::endPSession($conn);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("p:localhost", "root", "", "test");
$mysqli->close();
?>

El resultado del ejemplo sería:

proxy::endPSession(array (
  0 => NULL,
))
proxy::endPSession returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

  • « MysqlndUhConnection::endPSession
  • MysqlndUhConnection::getAffectedRows »
  • PHP Manual
  • MysqlndUhConnection
  • Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

MysqlndUhConnection::escapeString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::escapeString — Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión

Descripción

public MysqlndUhConnection::escapeString ( mysqlnd_connection $connection , string $escape_string ) : string

Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión.

Parámetros

MYSQLND_UH_RES_MYSQLND_NAME

Gestor de conexión de mysqlnd. ¡No modificar!

escape_string

La cadena a escapar.

Valores devueltos

La cadena escapada.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::escapeString()

<?php
class proxy extends MysqlndUhConnection {
 public function escapeString($res, $string) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::escapeString($res, $string);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
$mysqli->real_escape_string("test0'test");
?>

El resultado del ejemplo sería:

proxy::escapeString(array (
  0 => NULL,
  1 => 'test0\'test',
))
proxy::escapeString returns 'test0\\\'test'

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_real_escape_string() - Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
  • mysql_real_escape_string() - Escapa caracteres especiales en una cadena para su uso en una sentencia SQL


Obtiene el número de filas afectadas en una operación de MySQL anterior

  • « MysqlndUhConnection::escapeString
  • MysqlndUhConnection::getErrorNumber »
  • PHP Manual
  • MysqlndUhConnection
  • Obtiene el número de filas afectadas en una operación de MySQL anterior

MysqlndUhConnection::getAffectedRows

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getAffectedRows — Obtiene el número de filas afectadas en una operación de MySQL anterior

Descripción

public MysqlndUhConnection::getAffectedRows ( mysqlnd_connection $connection ) : int

Obtiene el número de filas afectadas en una operación de MySQL anterior.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El número de filas afectadas.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getAffectedRows()

<?php
class proxy extends MysqlndUhConnection {
 public function getAffectedRows($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getAffectedRows($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");
var_dump($mysqli->affected_rows);
?>

El resultado del ejemplo sería:

proxy::getAffectedRows(array (
  0 => NULL,
))
proxy::getAffectedRows returns 1
int(1)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_affected_rows() - Obtiene el número de filas afectadas en la última operación MySQL
  • mysql_affected_rows() - Obtiene el número de filas afectadas en la anterior operación de MySQL


Devuelve el código de error de la llamada más reciente a una función

  • « MysqlndUhConnection::getAffectedRows
  • MysqlndUhConnection::getErrorString »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el código de error de la llamada más reciente a una función

MysqlndUhConnection::getErrorNumber

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorNumber — Devuelve el código de error de la llamada más reciente a una función

Descripción

public MysqlndUhConnection::getErrorNumber ( mysqlnd_connection $connection ) : int

Devuelve el código de error de la llamada más reciente a una función.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El código de error de la llamada más reciente a una función.

Ejemplos

MysqlndUhConnection::getErrorNumber() no solo se ejecuta después de invocar a una llamada de la API del espacio de usuario, la cual hace referencia a ella directamente, sino que también es llamda internamente.

Ejemplo #1 Ejemplo de MysqlndUhConnection::getErrorNumber()

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorNumber($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorNumber($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("PLEASE_LET_THIS_BE_INVALID_SQL");
printf("errno...\n");
var_dump($mysqli->errno);
printf("close...\n");
$mysqli->close();
?>

El resultado del ejemplo sería:

connect...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 0
query...
errno...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 1064
int(1064)
close...

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • MysqlndUhConnection::getErrorString() - Devuelve una descripción del último error
  • mysqli_errno() - Devuelve el código del error de la última función llamada
  • mysql_errno() - Devuelve el valor numérico del mensaje de error de la última operación MySQL


Devuelve una descripción del último error

  • « MysqlndUhConnection::getErrorNumber
  • MysqlndUhConnection::getFieldCount »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve una descripción del último error

MysqlndUhConnection::getErrorString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorString — Devuelve una descripción del último error

Descripción

public MysqlndUhConnection::getErrorString ( mysqlnd_connection $connection ) : string

Devuelve una descripción del último error.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Un string con el error de la llamada más reciente a una función.

Ejemplos

MysqlndUhConnection::getErrorString() no solo se ejecuta después de invocar a una llamada de la API del espacio de usuario, la cual hace referencia a ella directamente, sino que también es llamda internamente.

Ejemplo #1 Ejemplo de MysqlndUhConnection::getErrorString()

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorString($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorString($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
printf("errno...\n");
var_dump($mysqli->error);
printf("close...\n");
$mysqli->close();
?>

El resultado del ejemplo sería:

connect...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns ''
query...
errno...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns 'You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'WILL_I_EVER_LEARN_SQL?\' at line 1'
string(168) "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WILL_I_EVER_LEARN_SQL?' at line 1"
close...

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • MysqlndUhConnection::getErrorNumber() - Devuelve el código de error de la llamada más reciente a una función
  • mysqli_error() - Devuelve una cadena que describe el último error
  • mysql_error() - Devuelve el texto del mensaje de error de la operación MySQL anterior


Devuelve el número de columnas de la consulta más reciente

  • « MysqlndUhConnection::getErrorString
  • MysqlndUhConnection::getHostInformation »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el número de columnas de la consulta más reciente

MysqlndUhConnection::getFieldCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getFieldCount — Devuelve el número de columnas de la consulta más reciente

Descripción

public MysqlndUhConnection::getFieldCount ( mysqlnd_connection $connection ) : int

Devuelve el número de columnas de la consulta más reciente.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El número de columnas.

Ejemplos

MysqlndUhConnection::getFieldCount() no solo se ejecuta después de invocar a una llamada de la API del espacio de usuario, la cual hace referencia a ella directamente, sino que también es llamda internamente.

Ejemplo #1 Ejemplo de MysqlndUhConnection::getFieldCount()

<?php
class proxy extends MysqlndUhConnection {
 public function getFieldCount($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getFieldCount($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
var_dump($mysqli->field_count);
$mysqli->query("SELECT 1, 2, 3 FROM DUAL");
var_dump($mysqli->field_count);
?>

El resultado del ejemplo sería:

proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 0
int(0)
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
int(3)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_field_count() - Devuelve el número de columnas para la consulta más reciente


Devuelve una representación de tipo string del tipo de conexión usada

  • « MysqlndUhConnection::getFieldCount
  • MysqlndUhConnection::getLastInsertId »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve una representación de tipo string del tipo de conexión usada

MysqlndUhConnection::getHostInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getHostInformation — Devuelve una representación de tipo string del tipo de conexión usada

Descripción

public MysqlndUhConnection::getHostInformation ( mysqlnd_connection $connection ) : string

Devuelve una representación de tipo string del tipo de conexión usada.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

La descripción de la conexión.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getHostInformation()

<?php
class proxy extends MysqlndUhConnection {
 public function getHostInformation($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getHostInformation($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->host_info);
?>

El resultado del ejemplo sería:

proxy::getHostInformation(array (
  0 => NULL,
))
proxy::getHostInformation returns 'Localhost via UNIX socket'
string(25) "Localhost via UNIX socket"

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_get_host_info() - Devuelve una cadena que representa el tipo de conexión usada
  • mysql_get_host_info() - Obtener información del anfitrión de MySQL


Devuelve el id autogenerado en la última consulta

  • « MysqlndUhConnection::getHostInformation
  • MysqlndUhConnection::getLastMessage »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el id autogenerado en la última consulta

MysqlndUhConnection::getLastInsertId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastInsertId — Devuelve el id autogenerado en la última consulta

Descripción

public MysqlndUhConnection::getLastInsertId ( mysqlnd_connection $connection ) : int

Devuelve el id autogenerado en la última consulta

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El último id insertado.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getLastInsertId()

<?php
class proxy extends MysqlndUhConnection {
 public function getLastInsertId($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastInsertId($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT AUTO_INCREMENT PRIMARY KEY, col VARCHAR(255))");
$mysqli->query("INSERT INTO test(col) VALUES ('a')");
var_dump($mysqli->insert_id);
?>

El resultado del ejemplo sería:

proxy::getLastInsertId(array (
  0 => NULL,
))
proxy::getLastInsertId returns 1
int(1)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_insert_id() - Devuelve el id autogenerado que se utilizó en la última consulta
  • mysql_insert_id() - Obtiene el ID generado en la última consulta


Recupera información sobre la consulta ejecutadamás recientemente

  • « MysqlndUhConnection::getLastInsertId
  • MysqlndUhConnection::getProtocolInformation »
  • PHP Manual
  • MysqlndUhConnection
  • Recupera información sobre la consulta ejecutadamás recientemente

MysqlndUhConnection::getLastMessage

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastMessage — Recupera información sobre la consulta ejecutadamás recientemente

Descripción

public MysqlndUhConnection::getLastMessage ( mysqlnd_connection $connection ) : void

Recupera información sobre la consulta ejecutadamás recientemente.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El último mensaje. Intentar devolver una cadena mayor que 511 bytes causará un error de tipo E_WARNING y resultará en el truncamiento de la cadena.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getLastMessage()

<?php
class proxy extends MysqlndUhConnection {
 public function getLastMessage($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastMessage($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->info);
$mysqli->query("DROP TABLE IF EXISTS test");
var_dump($mysqli->info);
?>

El resultado del ejemplo sería:

proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""
proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_info() - Obtiene la información de la última consulta ejecutada
  • mysql_info() - Obtiene información sobre la consulta más reciente


Devuelve la versión del protocolo de MySQL usado

  • « MysqlndUhConnection::getLastMessage
  • MysqlndUhConnection::getServerInformation »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve la versión del protocolo de MySQL usado

MysqlndUhConnection::getProtocolInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getProtocolInformation — Devuelve la versión del protocolo de MySQL usado

Descripción

public MysqlndUhConnection::getProtocolInformation ( mysqlnd_connection $connection ) : string

Devuelve la versión del protocolo de MySQL usado.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

The protocol version.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getProtocolInformation()

<?php
class proxy extends MysqlndUhConnection {
 public function getProtocolInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getProtocolInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->protocol_version);
?>

El resultado del ejemplo sería:

proxy::getProtocolInformation(array (
  0 => NULL,
))
proxy::getProtocolInformation returns 10
int(10)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_get_proto_info() - Devuelve la versión del protocolo MySQL utilizada
  • mysql_get_proto_info() - Obtener información del protocolo MySQL


Devuelve la versión del servidor MySQL

  • « MysqlndUhConnection::getProtocolInformation
  • MysqlndUhConnection::getServerStatistics »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve la versión del servidor MySQL

MysqlndUhConnection::getServerInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerInformation — Devuelve la versión del servidor MySQL

Descripción

public MysqlndUhConnection::getServerInformation ( mysqlnd_connection $connection ) : string

Devuelve la versión del servidor MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

The server version.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getServerInformation()

<?php
class proxy extends MysqlndUhConnection {
 public function getServerInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_info);
?>

El resultado del ejemplo sería:

proxy::getServerInformation(array (
  0 => NULL,
))
proxy::getServerInformation returns '5.1.45-debug-log'
string(16) "5.1.45-debug-log"

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_get_server_info() - Devuelve la versión del servidor MySQL
  • mysql_get_server_info() - Obtiene información del servidor MySQL


Obtiene el estado actual del sistema

  • « MysqlndUhConnection::getServerInformation
  • MysqlndUhConnection::getServerVersion »
  • PHP Manual
  • MysqlndUhConnection
  • Obtiene el estado actual del sistema

MysqlndUhConnection::getServerStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerStatistics — Obtiene el estado actual del sistema

Descripción

public MysqlndUhConnection::getServerStatistics ( mysqlnd_connection $connection ) : string

Obtiene el estado actual del sistema.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El mensaje con el estado del sistema.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getServerStatistics()

<?php
class proxy extends MysqlndUhConnection {
 public function getServerStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_stat($mysqli));
?>

El resultado del ejemplo sería:

proxy::getServerStatistics(array (
  0 => NULL,
))
proxy::getServerStatistics returns 'Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61'
string(140) "Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61"

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_stat() - Obtiene el estado actual del sistema
  • mysql_stat() - Obtiene el estado actual del sistema


Devuelve la versión del servidor MySQL en forma de entero

  • « MysqlndUhConnection::getServerStatistics
  • MysqlndUhConnection::getSqlstate »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve la versión del servidor MySQL en forma de entero

MysqlndUhConnection::getServerVersion

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerVersion — Devuelve la versión del servidor MySQL en forma de entero

Descripción

public MysqlndUhConnection::getServerVersion ( mysqlnd_connection $connection ) : int

Devuelve la versión del servidor MySQL en forma de entero

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

La versión de MySQL.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getServerVersion()

<?php
class proxy extends MysqlndUhConnection {
 public function getServerVersion($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerVersion($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_version);
?>

El resultado del ejemplo sería:

proxy::getServerVersion(array (
  0 => NULL,
))
proxy::getServerVersion returns 50145
int(50145)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_get_server_version() - Devuelve la versión del servidor MySQL como un valor entero
  • mysql_get_server_version()


Devuelve el error SQLSTATE de la operación anterior de MySQL

  • « MysqlndUhConnection::getServerVersion
  • MysqlndUhConnection::getStatistics »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el error SQLSTATE de la operación anterior de MySQL

MysqlndUhConnection::getSqlstate

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getSqlstate — Devuelve el error SQLSTATE de la operación anterior de MySQL

Descripción

public MysqlndUhConnection::getSqlstate ( mysqlnd_connection $connection ) : string

Devuelve el error SQLSTATE de la operación anterior de MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El código de SQLSTATE.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getSqlstate()

<?php
class proxy extends MysqlndUhConnection {
 public function getSqlstate($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getSqlstate($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->sqlstate);
$mysqli->query("AN_INVALID_REQUEST_TO_PROVOKE_AN_ERROR");
var_dump($mysqli->sqlstate);
?>

El resultado del ejemplo sería:

proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '00000'
string(5) "00000"
proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '42000'
string(5) "42000"

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_sql_state()


Devuelve estadísticas sobre la conexión cliente

  • « MysqlndUhConnection::getSqlstate
  • MysqlndUhConnection::getThreadId »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve estadísticas sobre la conexión cliente

MysqlndUhConnection::getStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getStatistics — Devuelve estadísticas sobre la conexión cliente

Descripción

public MysqlndUhConnection::getStatistics ( mysqlnd_connection $connection ) : array

Devuelve estadísticas sobre la conexión cliente.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Estadísticas de conexión recopiladas por mysqlnd.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getStatistics()

<?php
class proxy extends MysqlndUhConnection {
 public function getStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->get_connection_stats());
?>

El resultado del ejemplo sería:

proxy::getStatistics(array (
  0 => NULL,
))
proxy::getStatistics returns array (
  'bytes_sent' => '73',
  'bytes_received' => '77',
  'packets_sent' => '2',
  'packets_received' => '2',
  'protocol_overhead_in' => '8',
  'protocol_overhead_out' => '8',
  'bytes_received_ok_packet' => '0',
  'bytes_received_eof_packet' => '0',
  'bytes_received_rset_header_packet' => '0',
  'bytes_received_rset_field_meta_packet' => '0',
  'bytes_received_rset_row_packet' => '0',
  'bytes_received_prepare_response_packet' => '0',
  'bytes_received_change_user_packet' => '0',
  'packets_sent_command' => '0',
  'packets_received_ok' => '0',
  'packets_received_eof' => '0',
  'packets_received_rset_header' => '0',
  'packets_received_rset_field_meta' => '0',
  'packets_received_rset_row' => '0',
  'packets_received_prepare_response' => '0',
  'packets_received_change_user' => '0',
  'result_set_queries' => '0',
  'non_result_set_queries' => '0',
  'no_index_used' => '0',
  'bad_index_used' => '0',
  'slow_queries' => '0',
  'buffered_sets' => '0',
  'unbuffered_sets' => '0',
  'ps_buffered_sets' => '0',
  'ps_unbuffered_sets' => '0',
  'flushed_normal_sets' => '0',
  'flushed_ps_sets' => '0',
  'ps_prepared_never_executed' => '0',
  'ps_prepared_once_executed' => '0',
  'rows_fetched_from_server_normal' => '0',
  'rows_fetched_from_server_ps' => '0',
  'rows_buffered_from_client_normal' => '0',
  'rows_buffered_from_client_ps' => '0',
  'rows_fetched_from_client_normal_buffered' => '0',
  'rows_fetched_from_client_normal_unbuffered' => '0',
  'rows_fetched_from_client_ps_buffered' => '0',
  'rows_fetched_from_client_ps_unbuffered' => '0',
  'rows_fetched_from_client_ps_cursor' => '0',
  'rows_affected_normal' => '0',
  'rows_affected_ps' => '0',
  'rows_skipped_normal' => '0',
  'rows_skipped_ps' => '0',
  'copy_on_write_saved' => '0',
  'copy_on_write_performed' => '0',
  'command_buffer_too_small' => '0',
  'connect_success' => '1',
  'connect_failure' => '0',
  'connection_reused' => '0',
  'reconnect' => '0',
  'pconnect_success' => '0',
  'active_connections' => '1',
  'active_persistent_connections' => '0',
  'explicit_close' => '0',
  'implicit_close' => '0',
  'disconnect_close' => '0',
  'in_middle_of_command_close' => '0',
  'explicit_free_result' => '0',
  'implicit_free_result' => '0',
  'explicit_stmt_close' => '0',
  'implicit_stmt_close' => '0',
  'mem_emalloc_count' => '0',
  'mem_emalloc_amount' => '0',
  'mem_ecalloc_count' => '0',
  'mem_ecalloc_amount' => '0',
  'mem_erealloc_count' => '0',
  'mem_erealloc_amount' => '0',
  'mem_efree_count' => '0',
  'mem_efree_amount' => '0',
  'mem_malloc_count' => '0',
  'mem_malloc_amount' => '0',
  'mem_calloc_count' => '0',
  'mem_calloc_amount' => '0',
  'mem_realloc_count' => '0',
  'mem_realloc_amount' => '0',
  'mem_free_count' => '0',
  'mem_free_amount' => '0',
  'mem_estrndup_count' => '0',
  'mem_strndup_count' => '0',
  'mem_estndup_count' => '0',
  'mem_strdup_count' => '0',
  'proto_text_fetched_null' => '0',
  'proto_text_fetched_bit' => '0',
  'proto_text_fetched_tinyint' => '0',
  'proto_text_fetched_short' => '0',
  'proto_text_fetched_int24' => '0',
  'proto_text_fetched_int' => '0',
  'proto_text_fetched_bigint' => '0',
  'proto_text_fetched_decimal' => '0',
  'proto_text_fetched_float' => '0',
  'proto_text_fetched_double' => '0',
  'proto_text_fetched_date' => '0',
  'proto_text_fetched_year' => '0',
  'proto_text_fetched_time' => '0',
  'proto_text_fetched_datetime' => '0',
  'proto_text_fetched_timestamp' => '0',
  'proto_text_fetched_string' => '0',
  'proto_text_fetched_blob' => '0',
  'proto_text_fetched_enum' => '0',
  'proto_text_fetched_set' => '0',
  'proto_text_fetched_geometry' => '0',
  'proto_text_fetched_other' => '0',
  'proto_binary_fetched_null' => '0',
  'proto_binary_fetched_bit' => '0',
  'proto_binary_fetched_tinyint' => '0',
  'proto_binary_fetched_short' => '0',
  'proto_binary_fetched_int24' => '0',
  'proto_binary_fetched_int' => '0',
  'proto_binary_fetched_bigint' => '0',
  'proto_binary_fetched_decimal' => '0',
  'proto_binary_fetched_float' => '0',
  'proto_binary_fetched_double' => '0',
  'proto_binary_fetched_date' => '0',
  'proto_binary_fetched_year' => '0',
  'proto_binary_fetched_time' => '0',
  'proto_binary_fetched_datetime' => '0',
  'proto_binary_fetched_timestamp' => '0',
  'proto_binary_fetched_string' => '0',
  'proto_binary_fetched_blob' => '0',
  'proto_binary_fetched_enum' => '0',
  'proto_binary_fetched_set' => '0',
  'proto_binary_fetched_geometry' => '0',
  'proto_binary_fetched_other' => '0',
  'init_command_executed_count' => '0',
  'init_command_failed_count' => '0',
  'com_quit' => '0',
  'com_init_db' => '0',
  'com_query' => '0',
  'com_field_list' => '0',
  'com_create_db' => '0',
  'com_drop_db' => '0',
  'com_refresh' => '0',
  'com_shutdown' => '0',
  'com_statistics' => '0',
  'com_process_info' => '0',
  'com_connect' => '0',
  'com_process_kill' => '0',
  'com_debug' => '0',
  'com_ping' => '0',
  'com_time' => '0',
  'com_delayed_insert' => '0',
  'com_change_user' => '0',
  'com_binlog_dump' => '0',
  'com_table_dump' => '0',
  'com_connect_out' => '0',
  'com_register_slave' => '0',
  'com_stmt_prepare' => '0',
  'com_stmt_execute' => '0',
  'com_stmt_send_long_data' => '0',
  'com_stmt_close' => '0',
  'com_stmt_reset' => '0',
  'com_stmt_set_option' => '0',
  'com_stmt_fetch' => '0',
  'com_deamon' => '0',
  'bytes_received_real_data_normal' => '0',
  'bytes_received_real_data_ps' => '0',
)
array(160) {
  ["bytes_sent"]=>
  string(2) "73"
  ["bytes_received"]=>
  string(2) "77"
  ["packets_sent"]=>
  string(1) "2"
  ["packets_received"]=>
  string(1) "2"
  ["protocol_overhead_in"]=>
  string(1) "8"
  ["protocol_overhead_out"]=>
  string(1) "8"
  ["bytes_received_ok_packet"]=>
  string(1) "0"
  ["bytes_received_eof_packet"]=>
  string(1) "0"
  ["bytes_received_rset_header_packet"]=>
  string(1) "0"
  ["bytes_received_rset_field_meta_packet"]=>
  string(1) "0"
  ["bytes_received_rset_row_packet"]=>
  string(1) "0"
  ["bytes_received_prepare_response_packet"]=>
  string(1) "0"
  ["bytes_received_change_user_packet"]=>
  string(1) "0"
  ["packets_sent_command"]=>
  string(1) "0"
  ["packets_received_ok"]=>
  string(1) "0"
  ["packets_received_eof"]=>
  string(1) "0"
  ["packets_received_rset_header"]=>
  string(1) "0"
  ["packets_received_rset_field_meta"]=>
  string(1) "0"
  ["packets_received_rset_row"]=>
  string(1) "0"
  ["packets_received_prepare_response"]=>
  string(1) "0"
  ["packets_received_change_user"]=>
  string(1) "0"
  ["result_set_queries"]=>
  string(1) "0"
  ["non_result_set_queries"]=>
  string(1) "0"
  ["no_index_used"]=>
  string(1) "0"
  ["bad_index_used"]=>
  string(1) "0"
  ["slow_queries"]=>
  string(1) "0"
  ["buffered_sets"]=>
  string(1) "0"
  ["unbuffered_sets"]=>
  string(1) "0"
  ["ps_buffered_sets"]=>
  string(1) "0"
  ["ps_unbuffered_sets"]=>
  string(1) "0"
  ["flushed_normal_sets"]=>
  string(1) "0"
  ["flushed_ps_sets"]=>
  string(1) "0"
  ["ps_prepared_never_executed"]=>
  string(1) "0"
  ["ps_prepared_once_executed"]=>
  string(1) "0"
  ["rows_fetched_from_server_normal"]=>
  string(1) "0"
  ["rows_fetched_from_server_ps"]=>
  string(1) "0"
  ["rows_buffered_from_client_normal"]=>
  string(1) "0"
  ["rows_buffered_from_client_ps"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_cursor"]=>
  string(1) "0"
  ["rows_affected_normal"]=>
  string(1) "0"
  ["rows_affected_ps"]=>
  string(1) "0"
  ["rows_skipped_normal"]=>
  string(1) "0"
  ["rows_skipped_ps"]=>
  string(1) "0"
  ["copy_on_write_saved"]=>
  string(1) "0"
  ["copy_on_write_performed"]=>
  string(1) "0"
  ["command_buffer_too_small"]=>
  string(1) "0"
  ["connect_success"]=>
  string(1) "1"
  ["connect_failure"]=>
  string(1) "0"
  ["connection_reused"]=>
  string(1) "0"
  ["reconnect"]=>
  string(1) "0"
  ["pconnect_success"]=>
  string(1) "0"
  ["active_connections"]=>
  string(1) "1"
  ["active_persistent_connections"]=>
  string(1) "0"
  ["explicit_close"]=>
  string(1) "0"
  ["implicit_close"]=>
  string(1) "0"
  ["disconnect_close"]=>
  string(1) "0"
  ["in_middle_of_command_close"]=>
  string(1) "0"
  ["explicit_free_result"]=>
  string(1) "0"
  ["implicit_free_result"]=>
  string(1) "0"
  ["explicit_stmt_close"]=>
  string(1) "0"
  ["implicit_stmt_close"]=>
  string(1) "0"
  ["mem_emalloc_count"]=>
  string(1) "0"
  ["mem_emalloc_amount"]=>
  string(1) "0"
  ["mem_ecalloc_count"]=>
  string(1) "0"
  ["mem_ecalloc_amount"]=>
  string(1) "0"
  ["mem_erealloc_count"]=>
  string(1) "0"
  ["mem_erealloc_amount"]=>
  string(1) "0"
  ["mem_efree_count"]=>
  string(1) "0"
  ["mem_efree_amount"]=>
  string(1) "0"
  ["mem_malloc_count"]=>
  string(1) "0"
  ["mem_malloc_amount"]=>
  string(1) "0"
  ["mem_calloc_count"]=>
  string(1) "0"
  ["mem_calloc_amount"]=>
  string(1) "0"
  ["mem_realloc_count"]=>
  string(1) "0"
  ["mem_realloc_amount"]=>
  string(1) "0"
  ["mem_free_count"]=>
  string(1) "0"
  ["mem_free_amount"]=>
  string(1) "0"
  ["mem_estrndup_count"]=>
  string(1) "0"
  ["mem_strndup_count"]=>
  string(1) "0"
  ["mem_estndup_count"]=>
  string(1) "0"
  ["mem_strdup_count"]=>
  string(1) "0"
  ["proto_text_fetched_null"]=>
  string(1) "0"
  ["proto_text_fetched_bit"]=>
  string(1) "0"
  ["proto_text_fetched_tinyint"]=>
  string(1) "0"
  ["proto_text_fetched_short"]=>
  string(1) "0"
  ["proto_text_fetched_int24"]=>
  string(1) "0"
  ["proto_text_fetched_int"]=>
  string(1) "0"
  ["proto_text_fetched_bigint"]=>
  string(1) "0"
  ["proto_text_fetched_decimal"]=>
  string(1) "0"
  ["proto_text_fetched_float"]=>
  string(1) "0"
  ["proto_text_fetched_double"]=>
  string(1) "0"
  ["proto_text_fetched_date"]=>
  string(1) "0"
  ["proto_text_fetched_year"]=>
  string(1) "0"
  ["proto_text_fetched_time"]=>
  string(1) "0"
  ["proto_text_fetched_datetime"]=>
  string(1) "0"
  ["proto_text_fetched_timestamp"]=>
  string(1) "0"
  ["proto_text_fetched_string"]=>
  string(1) "0"
  ["proto_text_fetched_blob"]=>
  string(1) "0"
  ["proto_text_fetched_enum"]=>
  string(1) "0"
  ["proto_text_fetched_set"]=>
  string(1) "0"
  ["proto_text_fetched_geometry"]=>
  string(1) "0"
  ["proto_text_fetched_other"]=>
  string(1) "0"
  ["proto_binary_fetched_null"]=>
  string(1) "0"
  ["proto_binary_fetched_bit"]=>
  string(1) "0"
  ["proto_binary_fetched_tinyint"]=>
  string(1) "0"
  ["proto_binary_fetched_short"]=>
  string(1) "0"
  ["proto_binary_fetched_int24"]=>
  string(1) "0"
  ["proto_binary_fetched_int"]=>
  string(1) "0"
  ["proto_binary_fetched_bigint"]=>
  string(1) "0"
  ["proto_binary_fetched_decimal"]=>
  string(1) "0"
  ["proto_binary_fetched_float"]=>
  string(1) "0"
  ["proto_binary_fetched_double"]=>
  string(1) "0"
  ["proto_binary_fetched_date"]=>
  string(1) "0"
  ["proto_binary_fetched_year"]=>
  string(1) "0"
  ["proto_binary_fetched_time"]=>
  string(1) "0"
  ["proto_binary_fetched_datetime"]=>
  string(1) "0"
  ["proto_binary_fetched_timestamp"]=>
  string(1) "0"
  ["proto_binary_fetched_string"]=>
  string(1) "0"
  ["proto_binary_fetched_blob"]=>
  string(1) "0"
  ["proto_binary_fetched_enum"]=>
  string(1) "0"
  ["proto_binary_fetched_set"]=>
  string(1) "0"
  ["proto_binary_fetched_geometry"]=>
  string(1) "0"
  ["proto_binary_fetched_other"]=>
  string(1) "0"
  ["init_command_executed_count"]=>
  string(1) "0"
  ["init_command_failed_count"]=>
  string(1) "0"
  ["com_quit"]=>
  string(1) "0"
  ["com_init_db"]=>
  string(1) "0"
  ["com_query"]=>
  string(1) "0"
  ["com_field_list"]=>
  string(1) "0"
  ["com_create_db"]=>
  string(1) "0"
  ["com_drop_db"]=>
  string(1) "0"
  ["com_refresh"]=>
  string(1) "0"
  ["com_shutdown"]=>
  string(1) "0"
  ["com_statistics"]=>
  string(1) "0"
  ["com_process_info"]=>
  string(1) "0"
  ["com_connect"]=>
  string(1) "0"
  ["com_process_kill"]=>
  string(1) "0"
  ["com_debug"]=>
  string(1) "0"
  ["com_ping"]=>
  string(1) "0"
  ["com_time"]=>
  string(1) "0"
  ["com_delayed_insert"]=>
  string(1) "0"
  ["com_change_user"]=>
  string(1) "0"
  ["com_binlog_dump"]=>
  string(1) "0"
  ["com_table_dump"]=>
  string(1) "0"
  ["com_connect_out"]=>
  string(1) "0"
  ["com_register_slave"]=>
  string(1) "0"
  ["com_stmt_prepare"]=>
  string(1) "0"
  ["com_stmt_execute"]=>
  string(1) "0"
  ["com_stmt_send_long_data"]=>
  string(1) "0"
  ["com_stmt_close"]=>
  string(1) "0"
  ["com_stmt_reset"]=>
  string(1) "0"
  ["com_stmt_set_option"]=>
  string(1) "0"
  ["com_stmt_fetch"]=>
  string(1) "0"
  ["com_deamon"]=>
  string(1) "0"
  ["bytes_received_real_data_normal"]=>
  string(1) "0"
  ["bytes_received_real_data_ps"]=>
  string(1) "0"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_get_connection_stats() - Devuelve estadísticas sobre la conexión del cliente


Devuelve el ID del hilo de la conexión en uso

  • « MysqlndUhConnection::getStatistics
  • MysqlndUhConnection::getWarningCount »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el ID del hilo de la conexión en uso

MysqlndUhConnection::getThreadId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getThreadId — Devuelve el ID del hilo de la conexión en uso

Descripción

public MysqlndUhConnection::getThreadId ( mysqlnd_connection $connection ) : int

Devuelve el ID del hilo de la conexión en uso.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El id del hilo de la conexión.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getThreadId()

<?php
class proxy extends MysqlndUhConnection {
 public function getThreadId($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getThreadId($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->thread_id);
?>

El resultado del ejemplo sería:

proxy::getThreadId(array (
  0 => NULL,
))
proxy::getThreadId returns 27646
int(27646)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_thread_id() - Deveulve el ID del hilo de la conexión actual
  • mysql_thread_id() - Devuelve el ID del hilo actual


Devuelve el número de advertencias de la última consulta para el enlace dado

  • « MysqlndUhConnection::getThreadId
  • MysqlndUhConnection::init »
  • PHP Manual
  • MysqlndUhConnection
  • Devuelve el número de advertencias de la última consulta para el enlace dado

MysqlndUhConnection::getWarningCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getWarningCount — Devuelve el número de advertencias de la última consulta para el enlace dado

Descripción

public MysqlndUhConnection::getWarningCount ( mysqlnd_connection $connection ) : int

Devuelve el número de advertencias de la última consulta para el enlace dado.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

El número de advertencias.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::getWarningCount()

<?php
class proxy extends MysqlndUhConnection {
 public function getWarningCount($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getWarningCount($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->warning_count);
?>

El resultado del ejemplo sería:

proxy::getWarningCount(array (
  0 => NULL,
))
proxy::getWarningCount returns 0
int(0)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_warning_count() - Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado


Iniciliza una conexión de mysqlnd

  • « MysqlndUhConnection::getWarningCount
  • MysqlndUhConnection::killConnection »
  • PHP Manual
  • MysqlndUhConnection
  • Iniciliza una conexión de mysqlnd

MysqlndUhConnection::init

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::init — Iniciliza una conexión de mysqlnd

Descripción

public MysqlndUhConnection::init ( mysqlnd_connection $connection ) : bool

Iniciliza una conexión de mysqlnd. Ésta es una llamada interna de mysqlnd para inicializar el objeto de conexión.

Nota:

El no llamar a la implmentación made podría ocasionar pérdidas de memoria o que PHP falle. Esto no se considera un error. Por favor, recuerde que las funciones de la biblioteca mysqlnd no han sido diseñadas para ser expuestas al espacio de usuario.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::init()

<?php
class proxy extends MysqlndUhConnection {
 public function init($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::init($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

El resultado del ejemplo sería:

proxy::init(array (
  0 => NULL,
))
proxy::init returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Pregunta al servidor para matar un subproceso de MySQL

  • « MysqlndUhConnection::init
  • MysqlndUhConnection::listFields »
  • PHP Manual
  • MysqlndUhConnection
  • Pregunta al servidor para matar un subproceso de MySQL

MysqlndUhConnection::killConnection

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::killConnection — Pregunta al servidor para matar un subproceso de MySQL

Descripción

public MysqlndUhConnection::killConnection ( mysqlnd_connection $connection , int $pid ) : bool

Pregunta al servidor para matar un subproceso de MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

pid

El id del hilo de la conexión a matar.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::kill()

<?php
class proxy extends MysqlndUhConnection {
 public function killConnection($res, $pid) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::killConnection($res, $pid);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->kill($mysqli->thread_id);
?>

El resultado del ejemplo sería:

proxy::killConnection(array (
  0 => NULL,
  1 => 27650,
))
proxy::killConnection returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_kill() - Pide al servidor poner fin a un hilo de MySQL


Enumera los campos de una tabla de MySQL

  • « MysqlndUhConnection::killConnection
  • MysqlndUhConnection::listMethod »
  • PHP Manual
  • MysqlndUhConnection
  • Enumera los campos de una tabla de MySQL

MysqlndUhConnection::listFields

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listFields — Enumera los campos de una tabla de MySQL

Descripción

public MysqlndUhConnection::listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild ) : array

Enumera los campos de una tabla de MySQL.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

table

El nombre de la tabla que va a ser consultada.

pattern

Patrón de nombre.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::listFields()

<?php
class proxy extends MysqlndUhConnection {
 public function listFields($res, $table, $pattern) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listFields($res, $table, $pattern);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
mysql_select_db("test", $mysql);
mysql_query("DROP TABLE IF EXISTS test_a", $mysql);
mysql_query("CREATE TABLE test_a(id INT, col1 VARCHAR(255))", $mysql);
$res = mysql_list_fields("test", "test_a", $mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

El resultado del ejemplo sería:

proxy::listFields(array (
  0 => NULL,
  1 => 'test_a',
  2 => '',
))
proxy::listFields returns NULL
num_rows = 0

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysql_list_fields() - Lista los campos de una tabla de MySQL


Envoltura para comandos de listas desordenadas

  • « MysqlndUhConnection::listFields
  • MysqlndUhConnection::moreResults »
  • PHP Manual
  • MysqlndUhConnection
  • Envoltura para comandos de listas desordenadas

MysqlndUhConnection::listMethod

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listMethod — Envoltura para comandos de listas desordenadas

Descripción

public MysqlndUhConnection::listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 ) : void

Envoltura para comandos de listas desordenadas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

query

El comando SHOW a ejecutar.

achtung_wild

par1

Valores devueltos

Valores devueltos

TODO

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::listMethod()

<?php
class proxy extends MysqlndUhConnection {
 public function listMethod($res, $query, $pattern, $par1) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listMethod($res, $query, $pattern, $par1);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
$res = mysql_list_dbs($mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

El resultado del ejemplo sería:

proxy::listMethod(array (
  0 => NULL,
  1 => 'SHOW DATABASES',
  2 => '',
  3 => '',
))
proxy::listMethod returns NULL
num_rows = 6
array(1) {
  ["Database"]=>
  string(18) "information_schema"
}
array(1) {
  ["Database"]=>
  string(5) "mysql"
}
array(1) {
  ["Database"]=>
  string(8) "oxid_new"
}
array(1) {
  ["Database"]=>
  string(7) "phptest"
}
array(1) {
  ["Database"]=>
  string(7) "pushphp"
}
array(1) {
  ["Database"]=>
  string(4) "test"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysql_list_dbs() - Lista las bases de datos disponibles en un servidor MySQL


Comprueba si existen más resultados de consultas en una multiconsulta

  • « MysqlndUhConnection::listMethod
  • MysqlndUhConnection::nextResult »
  • PHP Manual
  • MysqlndUhConnection
  • Comprueba si existen más resultados de consultas en una multiconsulta

MysqlndUhConnection::moreResults

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::moreResults — Comprueba si existen más resultados de consultas en una multiconsulta

Descripción

public MysqlndUhConnection::moreResults ( mysqlnd_connection $connection ) : bool

Comprueba si existen más resultados de consultas en una multiconsulta.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::moreResults()

<?php
class proxy extends MysqlndUhConnection {
 public function moreResults($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::moreResults($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

El resultado del ejemplo sería:

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns false

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_more_results() - Comprueba si hay más resultados de una multi consulta


Prepara el siguiente resultado de multi_query

  • « MysqlndUhConnection::moreResults
  • MysqlndUhConnection::ping »
  • PHP Manual
  • MysqlndUhConnection
  • Prepara el siguiente resultado de multi_query

MysqlndUhConnection::nextResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::nextResult — Prepara el siguiente resultado de multi_query

Descripción

public MysqlndUhConnection::nextResult ( mysqlnd_connection $connection ) : bool

Prepara el siguiente resultado de multi_query.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::nextResult()

<?php
class proxy extends MysqlndUhConnection {
 public function nextResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::nextResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

El resultado del ejemplo sería:

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::nextResult(array (
  0 => NULL,
))
proxy::nextResult returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_next_result() - Prepara el siguiente resultado de multi_query


Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído

  • « MysqlndUhConnection::nextResult
  • MysqlndUhConnection::query »
  • PHP Manual
  • MysqlndUhConnection
  • Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído

MysqlndUhConnection::ping

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::ping — Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído

Descripción

public MysqlndUhConnection::ping ( mysqlnd_connection $connection ) : bool

Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::ping()

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

El resultado del ejemplo sería:

proxy::ping(array (
  0 => NULL,
))
proxy::ping returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_ping() - Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión
  • mysql_ping() - Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión


Realiza una consulta en la base de datos

  • « MysqlndUhConnection::ping
  • MysqlndUhConnection::queryReadResultsetHeader »
  • PHP Manual
  • MysqlndUhConnection
  • Realiza una consulta en la base de datos

MysqlndUhConnection::query

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::query — Realiza una consulta en la base de datos

Descripción

public MysqlndUhConnection::query ( mysqlnd_connection $connection , string $query ) : bool

Realiza una consulta en la base de datos (COM_QUERY).

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

query

La cadena de consulta.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::query()

<?php
class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'How about query rewriting?'";
  $ret = parent::query($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

El resultado del ejemplo sería:

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Welcome mysqlnd_uh!\' FROM DUAL',
))
proxy::query returns true
array(1) {
  ["How about query rewriting?"]=>
  string(26) "How about query rewriting?"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_query() - Realiza una consulta a la base de datos
  • mysql_query() - Enviar una consulta MySQL


Lee una cabecera del conjunto de resultados

  • « MysqlndUhConnection::query
  • MysqlndUhConnection::reapQuery »
  • PHP Manual
  • MysqlndUhConnection
  • Lee una cabecera del conjunto de resultados

MysqlndUhConnection::queryReadResultsetHeader

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::queryReadResultsetHeader — Lee una cabecera del conjunto de resultados

Descripción

public MysqlndUhConnection::queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt ) : bool

Lee una cabecera del conjunto de resultados.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

mysqlnd_stmt

Gestor de sentencias de mysqlnd. ¡No modificar! Se ha de establecer a null si la función no se utiliza en el contexto de sentencias preparadas.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::queryReadResultsetHeader()

<?php
class proxy extends MysqlndUhConnection {
 public function queryReadResultsetHeader($res, $stmt) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::queryReadResultsetHeader($res, $stmt);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

El resultado del ejemplo sería:

proxy::queryReadResultsetHeader(array (
  0 => NULL,
  1 => NULL,
))
proxy::queryReadResultsetHeader returns true
array(1) {
  ["Welcome mysqlnd_uh!"]=>
  string(19) "Welcome mysqlnd_uh!"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Obtiene el resultado de una consulta asicrónica

  • « MysqlndUhConnection::queryReadResultsetHeader
  • MysqlndUhConnection::refreshServer »
  • PHP Manual
  • MysqlndUhConnection
  • Obtiene el resultado de una consulta asicrónica

MysqlndUhConnection::reapQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::reapQuery — Obtiene el resultado de una consulta asicrónica

Descripción

public MysqlndUhConnection::reapQuery ( mysqlnd_connection $connection ) : bool

Obtiene el resultado de una consulta asicrónica.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Returns true on success. Otherwise, returns false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::reapQuery()

<?php
class proxy extends MysqlndUhConnection {
 public function reapQuery($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::reapQuery($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$conn1 = new mysqli("localhost", "root", "", "test");
$conn2 = new mysqli("localhost", "root", "", "test");

$conn1->query("SELECT 1 as 'one', SLEEP(1) AS _sleep FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);
$conn2->query("SELECT 1.1 as 'one dot one' FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);

$links = array(
 $conn1->thread_id => array('link' => $conn1, 'processed' => false),
 $conn2->thread_id => array('link' => $conn2, 'processed' => false)
);

$saved_errors = array();
do {
 $poll_links = $poll_errors = $poll_reject = array();
 foreach ($links as $thread_id => $link) {
  if (!$link['processed']) {
   $poll_links[] = $link['link'];
   $poll_errors[] = $link['link'];
   $poll_reject[] = $link['link'];
  }
 }
 if (0 == count($poll_links))
  break;

 if (0 == ($num_ready = mysqli_poll($poll_links, $poll_errors, $poll_reject, 0, 200000)))
  continue;

 if (!empty($poll_errors)) {
  die(var_dump($poll_errors));
 }

 foreach ($poll_links as $link) {
  $thread_id = mysqli_thread_id($link);
  $links[$thread_id]['processed'] = true;

  if (is_object($res = mysqli_reap_async_query($link))) {
   // result set object
   while ($row = mysqli_fetch_assoc($res)) {
    // eat up all results
    var_dump($row);
   }
   mysqli_free_result($res);
  } else {
   // either there is no result (no SELECT) or there is an error
   if (mysqli_errno($link) > 0) {
    $saved_errors[$thread_id] = mysqli_errno($link);
    printf("'%s' caused %d\n", $links[$thread_id]['query'],     mysqli_errno($link));
   }
  }
 }
} while (true);
?>

El resultado del ejemplo sería:

proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(1) {
  ["one dot one"]=>
  string(3) "1.1"
}
proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(2) {
  ["one"]=>
  string(1) "1"
  ["_sleep"]=>
  string(1) "0"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_real_async_query()


Vacía o reinicia las tablas y las cachés

  • « MysqlndUhConnection::reapQuery
  • MysqlndUhConnection::restartPSession »
  • PHP Manual
  • MysqlndUhConnection
  • Vacía o reinicia las tablas y las cachés

MysqlndUhConnection::refreshServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::refreshServer — Vacía o reinicia las tablas y las cachés

Descripción

public MysqlndUhConnection::refreshServer ( mysqlnd_connection $connection , int $options ) : bool

Vacía o reinicia las tablas y las cachés.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

options

Lo que refrescar.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::refreshServer()

<?php
class proxy extends MysqlndUhConnection {
 public function refreshServer($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::refreshServer($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
mysqli_refresh($mysqli, 1);
?>

El resultado del ejemplo sería:

proxy::refreshServer(array (
  0 => NULL,
  1 => 1,
))
proxy::refreshServer returns false

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Reinicializa una conexión persistente a mysqlnd

  • « MysqlndUhConnection::refreshServer
  • MysqlndUhConnection::selectDb »
  • PHP Manual
  • MysqlndUhConnection
  • Reinicializa una conexión persistente a mysqlnd

MysqlndUhConnection::restartPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::restartPSession — Reinicializa una conexión persistente a mysqlnd

Descripción

public MysqlndUhConnection::restartPSession ( mysqlnd_connection $connection ) : bool

Reinicializa una conexión persistente a mysqlnd.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::restartPSession()

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

El resultado del ejemplo sería:

proxy::restartPSession(array (
  0 => NULL,
))
proxy::restartPSession returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Selecciona la base de datos predeterminada para su consulta

  • « MysqlndUhConnection::restartPSession
  • MysqlndUhConnection::sendClose »
  • PHP Manual
  • MysqlndUhConnection
  • Selecciona la base de datos predeterminada para su consulta

MysqlndUhConnection::selectDb

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::selectDb — Selecciona la base de datos predeterminada para su consulta

Descripción

public MysqlndUhConnection::selectDb ( mysqlnd_connection $connection , string $database ) : bool

Selecciona la base de datos predeterminada para su consulta.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

database

El nombre de la base de datos.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::selectDb()

<?php
class proxy extends MysqlndUhConnection {
 public function selectDb($res, $database) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::selectDb($res, $database);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->select_db("mysql");
?>

El resultado del ejemplo sería:

proxy::selectDb(array (
  0 => NULL,
  1 => 'mysql',
))
proxy::selectDb returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_select_db() - Selecciona la base de datos por defecto para realizar las consultas
  • mysql_select_db() - Seleccionar una base de datos MySQL


Envía un comando de cierre a MySQL

  • « MysqlndUhConnection::selectDb
  • MysqlndUhConnection::sendQuery »
  • PHP Manual
  • MysqlndUhConnection
  • Envía un comando de cierre a MySQL

MysqlndUhConnection::sendClose

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendClose — Envía un comando de cierre a MySQL

Descripción

public MysqlndUhConnection::sendClose ( mysqlnd_connection $connection ) : bool

Envía un comando de cierre a MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::sendClose()

<?php
class proxy extends MysqlndUhConnection {
 public function sendClose($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendClose($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

El resultado del ejemplo sería:

proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true
proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Envía una consulta a MySQL

  • « MysqlndUhConnection::sendClose
  • MysqlndUhConnection::serverDumpDebugInformation »
  • PHP Manual
  • MysqlndUhConnection
  • Envía una consulta a MySQL

MysqlndUhConnection::sendQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendQuery — Envía una consulta a MySQL

Descripción

public MysqlndUhConnection::sendQuery ( mysqlnd_connection $connection , string $query ) : bool

Envía una consulta a MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

query

La cadena de consulta.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::sendQuery()

<?php
class proxy extends MysqlndUhConnection {
 public function sendQuery($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendQuery($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

El resultado del ejemplo sería:

proxy::sendQuery(array (
  0 => NULL,
  1 => 'SELECT 1',
))
proxy::sendQuery returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Vierte la información de depuración en el registro para el servidor MySQL

  • « MysqlndUhConnection::sendQuery
  • MysqlndUhConnection::setAutocommit »
  • PHP Manual
  • MysqlndUhConnection
  • Vierte la información de depuración en el registro para el servidor MySQL

MysqlndUhConnection::serverDumpDebugInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::serverDumpDebugInformation — Vierte la información de depuración en el registro para el servidor MySQL

Descripción

public MysqlndUhConnection::serverDumpDebugInformation ( mysqlnd_connection $connection ) : bool

Vierte la información de depuración en el registro para el servidor MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::serverDumpDebugInformation()

<?php
class proxy extends MysqlndUhConnection {
 public function serverDumpDebugInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::serverDumpDebugInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->dump_debug_info();
?>

El resultado del ejemplo sería:

proxy::serverDumpDebugInformation(array (
  0 => NULL,
))
proxy::serverDumpDebugInformation returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_dump_debug_info() - Volcado de información de depuración en el registro


Activa o desactiva la autoconsigna de las modificaciones de la base de datos

  • « MysqlndUhConnection::serverDumpDebugInformation
  • MysqlndUhConnection::setCharset »
  • PHP Manual
  • MysqlndUhConnection
  • Activa o desactiva la autoconsigna de las modificaciones de la base de datos

MysqlndUhConnection::setAutocommit

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::setAutocommit — Activa o desactiva la autoconsigna de las modificaciones de la base de datos

Descripción

public MysqlndUhConnection::setAutocommit ( mysqlnd_connection $connection , int $mode ) : bool

Activa o desactiva la autoconsigna de las modificaciones de la base de datos.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

mode

Si activar o no la autoconsigna.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::setAutocommit()

<?php
class proxy extends MysqlndUhConnection {
 public function setAutocommit($res, $mode) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setAutocommit($res, $mode);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->autocommit(false);
$mysqli->autocommit(true);
?>

El resultado del ejemplo sería:

proxy::setAutocommit(array (
  0 => NULL,
  1 => 0,
))
proxy::setAutocommit returns true
proxy::setAutocommit(array (
  0 => NULL,
  1 => 1,
))
proxy::setAutocommit returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_autocommit() - Activa o desactiva las modificaciones de la base de datos autoconsignadas


Establece el conjunto de caracteres predeterminado del cliente

  • « MysqlndUhConnection::setAutocommit
  • MysqlndUhConnection::setClientOption »
  • PHP Manual
  • MysqlndUhConnection
  • Establece el conjunto de caracteres predeterminado del cliente

MysqlndUhConnection::setCharset

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setCharset — Establece el conjunto de caracteres predeterminado del cliente

Descripción

public MysqlndUhConnection::setCharset ( mysqlnd_connection $connection , string $charset ) : bool

Establece el conjunto de caracteres predeterminado del cliente.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

charset

El conjunto de caracters a establecer como predeterminado.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::setCharset()

<?php
class proxy extends MysqlndUhConnection {
 public function setCharset($res, $charset) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setCharset($res, $charset);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
?>

El resultado del ejemplo sería:

proxy::setCharset(array (
  0 => NULL,
  1 => 'latin1',
))
proxy::setCharset returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_set_charset() - Establece el conjunto de caracteres predeterminado del cliente


Establece una opción del cliente

  • « MysqlndUhConnection::setCharset
  • MysqlndUhConnection::setServerOption »
  • PHP Manual
  • MysqlndUhConnection
  • Establece una opción del cliente

MysqlndUhConnection::setClientOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setClientOption — Establece una opción del cliente

Descripción

public MysqlndUhConnection::setClientOption ( mysqlnd_connection $connection , int $option , int $value ) : bool

Establece una opción del cliente.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

option

La opción a establecer.

value

Valor la opción, si fuera necesario.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::setClientOption()

<?php
function client_option_to_string($option) {
 static $mapping = array(
  MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT => "MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS => "MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS",
  MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE => "MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE",
  MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND => "MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE => "MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP => "MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP",
  MYSQLND_UH_MYSQLND_SET_CHARSET_DIR => "MYSQLND_UH_MYSQLND_SET_CHARSET_DIR",
  MYSQLND_UH_MYSQLND_SET_CHARSET_NAME => "MYSQLND_UH_MYSQLND_SET_CHARSET_NAME",
  MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE => "MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE",
  MYSQLND_UH_MYSQLND_OPT_PROTOCOL => "MYSQLND_UH_MYSQLND_OPT_PROTOCOL",
  MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME => "MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME",
  MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_USE_RESULT => "MYSQLND_UH_MYSQLND_OPT_USE_RESULT",
  MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION",
  MYSQLND_UH_MYSQLND_SET_CLIENT_IP => "MYSQLND_UH_MYSQLND_SET_CLIENT_IP",
  MYSQLND_UH_MYSQLND_SECURE_AUTH => "MYSQLND_UH_MYSQLND_SECURE_AUTH",
  MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION => "MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION",
  MYSQLND_UH_MYSQLND_OPT_RECONNECT => "MYSQLND_UH_MYSQLND_OPT_RECONNECT",
  MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT",
  MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_SSL_KEY => "MYSQLND_UH_MYSQLND_OPT_SSL_KEY",
  MYSQLND_UH_MYSQLND_OPT_SSL_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_CERT",
  MYSQLND_UH_MYSQLND_OPT_SSL_CA => "MYSQLND_UH_MYSQLND_OPT_SSL_CA",
  MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH => "MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH",
  MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER => "MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER",
  MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE => "MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE",
  MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR => "MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR",
  MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH => "MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH",
  MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP => "MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP"
 );
 if (version_compare(PHP_VERSION, '5.3.99-dev', '>')) {
  $mapping[MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET] = "MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET";
  $mapping[MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL] = "MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL";
 }
 if (defined("MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE")) {
  /* special mysqlnd build */
  $mapping["MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE"] = "MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE";
 }
 return (isset($mapping[$option])) ? $mapping[$option] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function setClientOption($res, $option, $value) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set to %s\n", client_option_to_string($option), var_export($value, true));
  $ret = parent::setClientOption($res, $option, $value);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

El resultado del ejemplo sería:

proxy::setClientOption(array (
  0 => NULL,
  1 => 210,
  2 => 3221225472,
))
Option 'MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET' set to 3221225472
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 211,
  2 => 'mysql_native_password',
))
Option 'MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL' set to 'mysql_native_password'
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 8,
  2 => 1,
))
Option 'MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE' set to 1
proxy::setClientOption returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_real_connect() - Abre una conexión a un servidor mysql
  • mysqli_options() - Establecer opciones


Establece una opción del servidor

  • « MysqlndUhConnection::setClientOption
  • MysqlndUhConnection::shutdownServer »
  • PHP Manual
  • MysqlndUhConnection
  • Establece una opción del servidor

MysqlndUhConnection::setServerOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setServerOption — Establece una opción del servidor

Descripción

public MysqlndUhConnection::setServerOption ( mysqlnd_connection $connection , int $option ) : void

Establece una opción del servidor.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

option

La opción a establecer.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::setServerOption()

<?php
function server_option_to_string($option) {
 $ret = 'unknown';
 switch ($option) {
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
 }
 return $ret;
}

class proxy extends MysqlndUhConnection {
 public function setServerOption($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set\n", server_option_to_string($option));
  $ret = parent::setServerOption($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1; SELECT 2");
?>

El resultado del ejemplo sería:

proxy::setServerOption(array (
  0 => NULL,
  1 => 0,
))
Option 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON' set
proxy::setServerOption returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_real_connect() - Abre una conexión a un servidor mysql
  • mysqli_options() - Establecer opciones
  • mysqli_multi_query() - Realiza una consulta a la base de datos


The shutdownServer purpose

  • « MysqlndUhConnection::setServerOption
  • MysqlndUhConnection::simpleCommand »
  • PHP Manual
  • MysqlndUhConnection
  • The shutdownServer purpose

MysqlndUhConnection::shutdownServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::shutdownServer — The shutdownServer purpose

Descripción

public MysqlndUhConnection::shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $"level" ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

MYSQLND_UH_RES_MYSQLND_NAME

"level"

Valores devueltos


Envía un comando COM_* básico

  • « MysqlndUhConnection::shutdownServer
  • MysqlndUhConnection::simpleCommandHandleResponse »
  • PHP Manual
  • MysqlndUhConnection
  • Envía un comando COM_* básico

MysqlndUhConnection::simpleCommand

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommand — Envía un comando COM_* básico

Descripción

public MysqlndUhConnection::simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status ) : bool

Envía un comando COM_* básico a MySQL.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

command

El comando COM a enviar.

arg

Argumentos opcionales del comando COM.

ok_packet

El tipo de paquete OK.

silent

Si mysqlnd podría emitir errores.

ignore_upsert_status

Si ignorar el estado UPDATE/INSERT.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::simpleCommand()

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

El resultado del ejemplo sería:

proxy::simpleCommand(array (
  0 => NULL,
  1 => 3,
  2 => 'SELECT 1',
  3 => 13,
  4 => false,
  5 => false,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUERY'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true
:)proxy::simpleCommand(array (
  0 => NULL,
  1 => 1,
  2 => '',
  3 => 13,
  4 => true,
  5 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUIT'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Procesa una respuesta para un comando COM_* básico enviado al cliente

  • « MysqlndUhConnection::simpleCommand
  • MysqlndUhConnection::sslSet »
  • PHP Manual
  • MysqlndUhConnection
  • Procesa una respuesta para un comando COM_* básico enviado al cliente

MysqlndUhConnection::simpleCommandHandleResponse

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommandHandleResponse — Procesa una respuesta para un comando COM_* básico enviado al cliente

Descripción

public MysqlndUhConnection::simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status ) : bool

Procesa una respuesta para un comando COM_* básico enviado al cliente

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

ok_packet

El tipo de paquete OK.

silent

Si mysqlnd podría emitir errores.

command

El comando COM del que procesar los resultados.

ignore_upsert_status

Si ignorar el estado UPDATE/INSERT.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::simpleCommandHandleResponse()

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysql = mysql_connect("localhost", "root", "");
mysql_query("SELECT 1 FROM DUAL", $mysql);
?>

El resultado del ejemplo sería:

proxy::simpleCommandHandleResponse(array (
  0 => NULL,
  1 => 5,
  2 => false,
  3 => 27,
  4 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_SET_OPTION'
OK packet 'MYSQLND_UH_MYSQLND_PROT_EOF_PACKET'
proxy::simpleCommandHandleResponse returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd


Usado para establecer conexiones seguras con SSL

  • « MysqlndUhConnection::simpleCommandHandleResponse
  • MysqlndUhConnection::stmtInit »
  • PHP Manual
  • MysqlndUhConnection
  • Usado para establecer conexiones seguras con SSL

MysqlndUhConnection::sslSet

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sslSet — Usado para establecer conexiones seguras con SSL

Descripción

public MysqlndUhConnection::sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

Usado para establecer conexiones seguras con SSL

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

key

El nombre de la ruta al fichero de claves.

cert

El nombre de la ruta al fichero de certificados.

ca

El nombre de la ruta al fichero de autoridad certificadora.

capath

El nombre de la ruta al directoria que contiene certificados de AC de confianza de SSL en formato PEM.

cipher

Una lista de los cifradores disponibles para usar la encriptación de SSL.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::sslSet()

<?php
class proxy extends MysqlndUhConnection {
 public function sslSet($conn, $key, $cert, $ca, $capath, $cipher) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sslSet($conn, $key, $cert, $ca, $capath, $cipher);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ssl_set("key", "cert", "ca", "capath", "cipher");
?>

El resultado del ejemplo sería:

proxy::sslSet(array (
  0 => NULL,
  1 => 'key',
  2 => 'cert',
  3 => 'ca',
  4 => 'capath',
  5 => 'cipher',
))
proxy::sslSet returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_ssl_set() - Usada para establece conexiones seguras usando SSL


Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare

  • « MysqlndUhConnection::sslSet
  • MysqlndUhConnection::storeResult »
  • PHP Manual
  • MysqlndUhConnection
  • Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare

MysqlndUhConnection::stmtInit

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::stmtInit — Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare

Descripción

public MysqlndUhConnection::stmtInit ( mysqlnd_connection $connection ) : resource

Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Recurso de tipo Sentencia Preparada de Mysqlnd (únicamente interno - ¡no se debe modificar!). La documentación también podría referirse a dichos recursos usando el sobrenombre de mysqlnd_prepared_statement.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::stmtInit()

<?php
class proxy extends MysqlndUhConnection {
 public function stmtInit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  var_dump($res);
  $ret = parent::stmtInit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 1 AS _one FROM DUAL");
$stmt->execute();
$one = NULL;
$stmt->bind_result($one);
$stmt->fetch();
var_dump($one);
?>

El resultado del ejemplo sería:

proxy::stmtInit(array (
  0 => NULL,
))
resource(19) of type (Mysqlnd Connection)
proxy::stmtInit returns NULL
resource(246) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
int(1)

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_stmt_init() - Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare


Transfiere un conjunto de resultados de la última consulta

  • « MysqlndUhConnection::stmtInit
  • MysqlndUhConnection::txCommit »
  • PHP Manual
  • MysqlndUhConnection
  • Transfiere un conjunto de resultados de la última consulta

MysqlndUhConnection::storeResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::storeResult — Transfiere un conjunto de resultados de la última consulta

Descripción

public MysqlndUhConnection::storeResult ( mysqlnd_connection $connection ) : resource

Transfiere un conjunto de resultados de la última consulta.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Recurso de tipo Conjunto de Resultados de Mysqlnd (únicamente interno - ¡no se debe modificar!). La documentación también podría referirse a dichos recursos usando el sobrenombre de mysqlnd_resultset.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::storeResult()

<?php
class proxy extends MysqlndUhConnection {
 public function storeResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::storeResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Also called buffered result' AS _msg FROM DUAL");
var_dump($res->fetch_assoc());

$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->store_result();
var_dump($res->fetch_assoc());
?>

El resultado del ejemplo sería:

proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(475) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(27) "Also called buffered result"
}
proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(730) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_store_result() - Transfiere un conjunto de resultados de la última consulta
  • mysqli_real_query() - Ejecuta una consulta SQL


Consigna la transacción en uso

  • « MysqlndUhConnection::storeResult
  • MysqlndUhConnection::txRollback »
  • PHP Manual
  • MysqlndUhConnection
  • Consigna la transacción en uso

MysqlndUhConnection::txCommit

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::txCommit — Consigna la transacción en uso

Descripción

public MysqlndUhConnection::txCommit ( mysqlnd_connection $connection ) : bool

Consigna la transacción en uso.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::txCommit()

<?php
class proxy extends MysqlndUhConnection {
 public function txCommit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txCommit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->commit();
?>

El resultado del ejemplo sería:

proxy::txCommit(array (
  0 => NULL,
))
proxy::txCommit returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_commit() - Consigna la transacción actual


Revierte la transacción en uso

  • « MysqlndUhConnection::txCommit
  • MysqlndUhConnection::useResult »
  • PHP Manual
  • MysqlndUhConnection
  • Revierte la transacción en uso

MysqlndUhConnection::txRollback

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::txRollback — Revierte la transacción en uso

Descripción

public MysqlndUhConnection::txRollback ( mysqlnd_connection $connection ) : bool

Revierte la transacción en uso.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::txRollback()

<?php
class proxy extends MysqlndUhConnection {
 public function txRollback($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txRollback($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->rollback();
?>

El resultado del ejemplo sería:

proxy::txRollback(array (
  0 => NULL,
))
proxy::txRollback returns true

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_commit() - Consigna la transacción actual


Inicia una recuperación de un conjunto de resultados

  • « MysqlndUhConnection::txRollback
  • MysqlndUhPreparedStatement »
  • PHP Manual
  • MysqlndUhConnection
  • Inicia una recuperación de un conjunto de resultados

MysqlndUhConnection::useResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::useResult — Inicia una recuperación de un conjunto de resultados

Descripción

public MysqlndUhConnection::useResult ( mysqlnd_connection $connection ) : resource

Inicia una recuperación de un conjunto de resultados.

Parámetros

connection

Gestor de conexión de mysqlnd. ¡No modificar!

Valores devueltos

Recurso de tipo Conjunto de Resultados de Mysqlnd (únicamente interno - ¡no se debe modificar!). La documentación también podría referirse a dichos recursos usando el sobrenombre de mysqlnd_resultset.

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhConnection::useResult()

<?php
class proxy extends MysqlndUhConnection {
 public function useResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::useResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->use_result();
var_dump($res->fetch_assoc());
?>

El resultado del ejemplo sería:

proxy::useResult(array (
  0 => NULL,
))
proxy::useResult returns NULL
resource(425) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqli_use_result() - Inicia la recuperación de un conjunto de resultados
  • mysqli_real_query() - Ejecuta una consulta SQL


La clase MysqlndUhPreparedStatement

(PECL mysqlnd-uh >= 1.0.0-alpha)

Introducción

Sinopsis de la Clase

MysqlndUhPreparedStatement {
/* Métodos */
public __construct ( )
public execute ( mysqlnd_prepared_statement $statement ) : bool
public prepare ( mysqlnd_prepared_statement $statement , string $query ) : bool
}

Tabla de contenidos

  • MysqlndUhPreparedStatement::__construct — The __construct purpose
  • MysqlndUhPreparedStatement::execute — Ejecuta una consulta preparada
  • MysqlndUhPreparedStatement::prepare — Prepara una sentencia SQL para su ejecución


The __construct purpose

  • « MysqlndUhPreparedStatement
  • MysqlndUhPreparedStatement::execute »
  • PHP Manual
  • MysqlndUhPreparedStatement
  • The __construct purpose

MysqlndUhPreparedStatement::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::__construct — The __construct purpose

Descripción

public MysqlndUhPreparedStatement::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Ejecuta una consulta preparada

  • « MysqlndUhPreparedStatement::__construct
  • MysqlndUhPreparedStatement::prepare »
  • PHP Manual
  • MysqlndUhPreparedStatement
  • Ejecuta una consulta preparada

MysqlndUhPreparedStatement::execute

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::execute — Ejecuta una consulta preparada

Descripción

public MysqlndUhPreparedStatement::execute ( mysqlnd_prepared_statement $statement ) : bool

Ejecuta una consulta preparada.

Parámetros

statement

Gestor de sentencias preparadas de mysqlnd. ¡No modificar! Recurso de tipo Mysqlnd Prepared Statement (solamente interno - ¡no se debe modificar!).

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhPreparedStatement::execute()

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function execute($res) {
  printf("%s(", __METHOD__);
  var_dump($res);
  printf(")\n");
  $ret = parent::execute($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

El resultado del ejemplo sería:

stmt_proxy::execute(resource(256) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
)
stmt_proxy::execute returns true
bool(true)
string(8) "Labskaus"

Ver también

  • mysqlnd_uh_set_statement_proxy() - Instala un proxy para sentencias de mysqlnd
  • mysqli_stmt_execute() - Ejecuta una consulta preparada


Prepara una sentencia SQL para su ejecución

  • « MysqlndUhPreparedStatement::execute
  • Funciones de Mysqlnd_uh »
  • PHP Manual
  • MysqlndUhPreparedStatement
  • Prepara una sentencia SQL para su ejecución

MysqlndUhPreparedStatement::prepare

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::prepare — Prepara una sentencia SQL para su ejecución

Descripción

public MysqlndUhPreparedStatement::prepare ( mysqlnd_prepared_statement $statement , string $query ) : bool

Prepara una sentencia SQL para su ejecución.

Parámetros

statement

Gestor de sentencias preparadas de mysqlnd. ¡No modificar! Recurso de tipo Mysqlnd Prepared Statement (solamente interno - ¡no se debe modificar!).

query

The query to be prepared.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de MysqlndUhPreparedStatement::prepare()

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'No more you-know-what-I-mean for lunch, please' AS _msg FROM DUAL";
  $ret = parent::prepare($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

El resultado del ejemplo sería:

stmt_proxy::prepare(array (
  0 => NULL,
  1 => 'SELECT \'Labskaus\' AS _msg FROM DUAL',
))
stmt_proxy::prepare returns true
bool(true)
string(46) "No more you-know-what-I-mean for lunch, please"

Ver también

  • mysqlnd_uh_set_statement_proxy() - Instala un proxy para sentencias de mysqlnd
  • mysqli_stmt_prepare() - Preparar una sentencia SQL para su ejecución
  • mysqli_prepare() - Prepara una sentencia SQL para su ejecución


Funciones de Mysqlnd_uh

Tabla de contenidos

  • mysqlnd_uh_convert_to_mysqlnd — Convierte un gestor de conexión de MySQL a uno de mysqlnd
  • mysqlnd_uh_set_connection_proxy — Instala un proxy para las conexiones de mysqlnd
  • mysqlnd_uh_set_statement_proxy — Instala un proxy para sentencias de mysqlnd


Convierte un gestor de conexión de MySQL a uno de mysqlnd

  • « Funciones de Mysqlnd_uh
  • mysqlnd_uh_set_connection_proxy »
  • PHP Manual
  • Funciones de Mysqlnd_uh
  • Convierte un gestor de conexión de MySQL a uno de mysqlnd

mysqlnd_uh_convert_to_mysqlnd

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_convert_to_mysqlnd — Convierte un gestor de conexión de MySQL a uno de mysqlnd

Descripción

mysqlnd_uh_convert_to_mysqlnd ( mysqli &$mysql_connection ) : resource

Convierte un gestor de conexión de MySQL a uno de mysqlnd. Después de la conversión, se pueden ejecutar las llamadas a la biblioteca mysqlnd sobre el gestor de conexión. Esto se puede utilizar para acceder a la funcionalidad de mysqlnd que no está disponible a través de las llamadas de la API del espacio de usuario.

Esta función se puede deshabilitar con mysqlnd_uh.enable. Si mysqlnd_uh.enable se establece a false la función no instalará el proxy y siempre devolverá true. Además, se emitirá un error de tipo E_WARNING. Este mensaje de error podría leerse como PHP Warning: mysqlnd_uh_convert_to_mysqlnd(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. You are not allowed to call this function [...].

Parámetros

MySQL connection handle

Un gestor de conexión de MySQL del tipo mysql, mysqli o PDO_MySQL.

Valores devueltos

Un gestor de conexión de mysqlnd.

Historial de cambios

Versión | Descripción
5.4.0 | El parámetro mysql_connection ahora puede ser de tipo mysql, PDO_MySQL, o mysqli. Antes, solo estaba permitido el tipo mysqli.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_uh_convert_to_mysqlnd()

<?php
/* La API de usuario de PDO no proporciona acceso al id del hilo de conexión */
$mysql_connection = new PDO("mysql:host=localhost;dbname=test", "root", "");

/* Convertir el gestor de MySQL de PDO a uno de mysqlnd */
$mysqlnd = mysqlnd_uh_convert_to_mysqlnd($mysql_connection);

/* Crear un Proxy para llamar a los métodos de la clase de conexión de mysqlnd */
$obj = new MySQLndUHConnection();
/* Llamar a mysqlnd_conn::get_thread_id */
var_dump($obj->getThreadId($mysqlnd));

/* Usar SQL para obtener el id del hilo de conexión */
var_dump($mysql_connection->query("SELECT CONNECTION_ID()")->fetchAll());
?>

El resultado del ejemplo sería:

int(27054)
array(1) {
  [0]=>
  array(2) {
    ["CONNECTION_ID()"]=>
    string(5) "27054"
    [0]=>
    string(5) "27054"
  }
}

Ver también

  • mysqlnd_uh.enable


Instala un proxy para las conexiones de mysqlnd

  • « mysqlnd_uh_convert_to_mysqlnd
  • mysqlnd_uh_set_statement_proxy »
  • PHP Manual
  • Funciones de Mysqlnd_uh
  • Instala un proxy para las conexiones de mysqlnd

mysqlnd_uh_set_connection_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_connection_proxy — Instala un proxy para las conexiones de mysqlnd

Descripción

mysqlnd_uh_set_connection_proxy ( MysqlndUhConnection &$connection_proxy , mysqli &$mysqli_connection = ? ) : bool

Instala un objeto proxy para enganchar los métodos de los objetos de conexión de mysqlnd. Una vez instalado, el proxy se usará para todas las conexiones de MySQL abiertas con mysqli, mysql o PDO_MYSQL, asumiendo que las extensiones enumeradas están compiladas para usar la biblioteca mysqlnd.

Esta función se puede deshabilitar con mysqlnd_uh.enable. Si mysqlnd_uh.enable se establece a false la función no instalará el proxy y siempre devolverá true. Además, se emitirá un error de tipo E_WARNING. Este mensaje de error podría leerse como PHP Warning: mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

Parámetros

connection_proxy

Un objeto proxy de tipo MysqlndUhConnection.

mysqli_connection

Un objeto de tipo mysqli. Si se proporciona, el proxy se establecerá únicamente para esta conexión en particular.

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_uh_set_connection_proxy()

<?php
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 'No proxy installed, yet'");

class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::query($res, $query);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli->query("SELECT 'mysqlnd rocks!'");

$mysql = mysql_connect("localhost", "root", "", "test");
mysql_query("SELECT 'Ahoy Andrey!'", $mysql);

$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
$pdo->query("SELECT 'Moin Johannes!'");
?>

El resultado del ejemplo sería:

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'mysqlnd rocks!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Ahoy Andrey!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Moin Johannes!\'',
))
proxy::query returns true

Ver también

  • mysqlnd_uh_set_statement_proxy() - Instala un proxy para sentencias de mysqlnd
  • mysqlnd_uh.enable


Instala un proxy para sentencias de mysqlnd

  • « mysqlnd_uh_set_connection_proxy
  • Historial de cambios »
  • PHP Manual
  • Funciones de Mysqlnd_uh
  • Instala un proxy para sentencias de mysqlnd

mysqlnd_uh_set_statement_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_statement_proxy — Instala un proxy para sentencias de mysqlnd

Descripción

mysqlnd_uh_set_statement_proxy ( MysqlndUhStatement &$statement_proxy ) : bool

Instala un proxy para las sentencias de mysqlnd. El objeto proxy se usará para todos los objetos de sentencias preparadas de mysqlnd, sin tener en cuenta la extensión de MySQL para PHP (mysqli, mysql, PDO_MYSQL) que las haya creado siempre que dicha extensión esté compilada para usar la biblioteca mysqlnd.

Esta función se puede deshabilitar con mysqlnd_uh.enable. Si mysqlnd_uh.enable se establece a false la función no instalará el proxy y siempre devolverá true. Además, se emitirá un error de tipo E_WARNING. Este mensaje de error podría leerse como PHP Warning: mysqlnd_uh_set_statement_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

Parámetros

statement_proxy

El objeto proxy de sentencias de mysqlnd de tipo MysqlndUhStatement

Valores devueltos

Devuelve true en caso de éxito. De lo contrario, devuelve false

Ver también

  • mysqlnd_uh_set_connection_proxy() - Instala un proxy para las conexiones de mysqlnd
  • mysqlnd_uh.enable


Historial de cambios

Tabla de contenidos

  • Serie PECL/mysqlnd_uh 1.0

Este historial de cambios enumera los cambios mayores que los usuarios necesitan considerar al actualizar desde una versión a otra. Es un resume de alto nivel de cambios seleccionados que podrían tener impacto sobre las aplicaciones o incluso romper la retrocompatibilidad (RC). Véase también el fichero CHANGES contenido en la distribución original para informaicón adicional sobre el registro de cambios. El historial de commit también está disponible.


Serie PECL/mysqlnd_uh 1.0

1.0.1-alpha

  • Fecha de publiacación: A determinar
  • Motivo/tema: versión de corrección de errores

Cambios en las características

  • Soporte para PHP 5.4.0 o posterior.
  • Rotura de RC: MysqlndUhConnection::changeUser() requiere el parámetro adicional passwd_len.
  • Rotura de RC: MYSQLND_UH_VERSION_STR se renombró a MYSQLND_UH_VERSION. MYSQLND_UH_VERSION se renombró a MYSQLND_UH_VERSION_ID.
  • Rotura de RC: El ajuste de configuración mysqlnd_uh.enabled se renombró a mysqlnd_uh.enable.

1.0.0-alpha

  • Fecha de publicación: 08/2010
  • Motivo/tema: Versión inicial


Complemento de multiplexación de conexiones de mysqlnd

  • Introducción
  • Conceptos
    • Arquitectura
    • Agrupamiento de conexiones
    • Compartir conexiones
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Historial de cambios
    • Serie PECL/mysqlnd_mux 1.0


Introducción

El complemento de multiplexación de mysqlnd (mysqlnd_mux) multiplexa las conexiones de MySQL establecidas por todas las extensiones de MySQL para PHP que utilizan el controlador nativo de MySQL (mysqlnd) para PHP.

El controlador nativo de MySQL para PHP introduce una API en C interna para complementos, tales como el complemento de multiplexación de conexiones, la cual puede ampliar la funcionalidad de mysqlnd. Véase mysqlnd para detalles adicionales sobre sus beneficios sobre la Bliblioteca Cliente de MySQL libmysqlclient.

Los complementos de mysqlnd como mysqlnd_mux operan, en la mayor parte, de forma transparente desde la perspectiva del usuario. El complemento de multiplexación de conexiones admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP. No cambia las APIs existentes. Por lo tanto, puede usarse fácilmente con las aplicaciones de PHP existentes.

Nota:

Este complemento es una pruebas de conceptos. Todas las características están en un estado primario. El complemento aún no gestiona todos los tipos de consultas. Por lo tanto, por el momento no se puede usar como susutituto.

Por favor, no use esta versión en entornos de producción.

Características principales

Las características principales de mysqlnd_mux son las siguientes:

  • Transparente y por lo tanto fácil de usar:

    • Admite todas las extensiones de MySQL para PHP.

    • Se necesitan pocos o ninún cambio en las aplicaciones, dependiendo del escenario de uso requerido.

  • Reduce la carga del servidor y la latencia del establecimiento de conexiones:

    • Abre menos conexiones al servidor MySQL.

    • Menos conexiones a MySQL significa menos trabajo para el servidor MySQL. En un entorno cliente-servidor, a menudo es más difícil mejorar el rendimiento del servidor que el del cliente. La multiplexación ayuda con la mejora del rendimiento horizontal (por cliente).

    • El agrupamiento ahorra tiempo de conexión.

    • Conexión multiplexada: múltiples gestores de usuario comparten la misma conexión de red. Una vez abierta, una conexión de red es almacenada en caché y compartida entre múltiples gestores de usuario. Hay una relación 1:n entre la conexión interna de red y los gestores de conexión de usuario.

    • Conexión persistente: una conexión de red se mantiene abierta hasta el final de una petición web, si el modelo de desarrollo de PHP lo permite. Así, peticioines web subsiguientes pueden reutilizar una conexión previamente abierta. Al igual que otros recursos, las conexiones de red están limitadas al ámbito de un proceso. Por lo tanto, pueden ser reutilizadas para todas las peticiones web servidas por un proceso.

Limitaciones

La prueba de conceptos no admite consultas no almacenadas en búfer, sentencias preparadas, ni consultas asíncronas.

El agrupamiento de conexiones utiliza una combinación de método de transporte y nombre de host como claves. Como consecuencia, dos conexiones al mismo host que usen el mismo método de transporte (TCP/IP, socket Unix, tubería con nombre de Windows) serán vinculadas a la misma conexión agrupada incluso si el nombre de usuario y la contraseña difieren. Se han de tener las posibles implicaciones de segurirdad.

La prueba de conceptos es incrédula respecto a transacciones. No sabe nada de transacciones SQL.

Nota:

Las aplicaciones debería tener en cuenta de las consecuencias de compartir conexiones.

Sobre el nombre mysqlnd_mux

La abreviatura mysqlnd_mux singnifica complemento de multiplexación de conexiones de mysqlnd.


Conceptos

Tabla de contenidos

  • Arquitectura
  • Agrupamiento de conexiones
  • Compartir conexiones

Esta sección explica la arquitectura y los conceptos relacionados con este complemento. Es necesario leer y entender dichos conceptos para usar de forma satisfactoria este complemento.


Arquitectura

El complemento de multiplexación de conexiones de mysqlnd está implementado como una extensión de PHP. Está estcrito en C y opera bajo el manto de PHP. Durante el arranque del intérprete de PHP, en la fase de inicialización de módulos del motor de PHP, se registra como un complemento de mysqlnd para reemplazar a los métodos en C específicos de mysqlnd.

La biblioteca mysqlnd utiliza los flujos de PHP para comunicarse con el servidor MySQL. A los flujos de PHP se acceden mediante la biblioteca mysqlnd a través de su módulo de red. El complemento de multiplexación de conexiones de mysqlnd actúa como delegado de los métodos del módulo de red de la biblioteca mysqlnd para controlar la apertura y el cierre de flujos de red.

Cuando se abre una conexión de usuario a MySQL utlizando las funciones de conexión apropiadas de mysqli, PDO_MYSQL o ext/mysql, el complemento busca en su agrupamiento de conexiones una conexión de red abierta. Si el agrupamiento contiene una conexión de red al host especificado por la función de conexión que use el método de transporte solicitado (TCP/IP, socket de dominio Unix, tuberías con nombre de Windows), la conexión del agrupamiento se vincula al gestor de usuario. De lo contrario, se abre una nueva conexión de red, se coloca en el agrupamiento y se asocia con el gestor de conexión de usuario. De esta manera, múltiples gestores de usuario pueden ser vinculados a la misma conexión de red.


Agrupamiento de conexiones

La agrupación de conexiones del complemento se crea cuando PHP inicializa sus módulos (MINIT), y se libera cuando PHP cierra los módulos (MSHUTDOWN). Lo mismo sucede con las conexiones persistentes de MySQL.

Según el modelo de desarrollo, la agrupación se usa durante la vida de una o múltiples peticiones web. Las conexiones de red están limitadas al tiempo de vida de un proceso al nivel del sistema operativo. Si el proceso de PHP sirve múltiples peticiones web, como es el caso de Fast-CGI o despliegues de servidor web con hilos, las conexiones de la agrupación pueden ser reutilizadas sobre conexiones múltiples. Ya que la multiplexación significa compartir conexiones, podría incluso acontecer con un despliegue de subprocesos donde dos hilos o dos peticiones web distintas estén vinculadas a una conexión de red de la agrupación.

Una conexión de la agrupación se cierra explícitamente una vez que la última referencia a ella sea liberada. Un cierre implícito ocurre cuando PHP cierra sus módulos.


Compartir conexiones

El complemento de multiplexación de conexiontes de mysqlnd de PHP cambia la relación existente entre getores de conexión de usuario y la conexión de MySQL subyacente. Sin el complemento, cada conexión de MySQL pertenece exactamente a una conexión de usuario cada vez. El complemento de multiplexación cambia este comportamiento. Una conexión de MySQL es compartida entre múltiples gestores de usuario. No existe una relación uno-a-uno si se utiliza el complemento.

Compartir conexiones agrupadas tiene un impacto sobre el estado de la conexión. Las operaciones de cambio de estado de múltiples gestores de usuario que apuntan a una conexión de MySQL no están aisladas unas de otras. Si, por ejemplo, una variable de sesión se establece a través de un gestor de conexión de usuario, dicha variable se hará visible a todos los demás gestores de usuario que hagan referencia a la misma conexión de MySQL subyacente.

Este concepto es similar al estado de conexión relacionado con los fenómenos descritos para el complemento de la replicación y equilibrado de carga de mysqlnd para PHP. Por favor, revise la documentación de PECL/mysqlnd_ms para más detalles sobre el estado de una conexión.

La prueba de conceptos no toma medidas para aislar unas conexioines multiplexadas de otras.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución


Requerimientos

PHP 5.5.0 o superior. Algunas funcionalidades avanzadas requieren PHP 5.5.0 o superior.

El complemento de replicación y equilibrado de carga mysqlnd_mux admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP disponibles (mysqli, mysql, PDO_MYSQL). La extensión de MySQL para PHP debe configurarse para utilizar mysqlnd para poder usar el complemento mysqlnd_mux para mysqlnd.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mysqlnd_mux


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de mysqlnd_mux
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

mysqlnd_mux.enable integer

Habilita o deshabilita el complemento. Si se deshabilita, la extensión no se conectará a mysqlnd para representar a las llamadas internas de la API en C de mysqlnd.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Otras

El número de la versión del complemento se puede obtener usando MYSQLND_MUX_VERSION o MYSQLND_MUX_VERSION_ID. MYSQLND_MUX_VERSION es la representación de tipo string del número de versión numérica de MYSQLND_MUX_VERSION_ID, la cual es un entero como 10000. Los desarrolladores pueden calcular el número de verisón como sigue:

Versión (parte) | Ejemplo
Mayor*10000 | 1*10000 = 10000
Menor*100 | 0*100 = 0
Parche | 0 = 0
MYSQLND_MUX_VERSION_ID | 10000

MYSQLND_MUX_VERSION (string)
Cadena con la versión del complemento, por ejemplo, 1.0.0-prototype.
MYSQLND_MUX_VERSION_ID (integer)
Número de la versión del complemento, por ejemplo, 10000.


Historial de cambios

Tabla de contenidos

  • Serie PECL/mysqlnd_mux 1.0

Este historial de cambios es un resumen de alto nivel de los cambios seleccionados que podrían tener impacto sobre las aplicaciones y/o romper la retrocompatibilidad.

Véase también el fichero CHANGES de la distribución del código fuente para una lista completa de cambios.


Serie PECL/mysqlnd_mux 1.0

1.0.0-pre-alpha

  • Fecha de publicación: ne se publicó ningún paquete, registro inicial 09/2012
  • Motivo/tema: Prueba de conceptos

Registro inicial. Esencialmente una demo de la API del complemento de mysqlnd.

Nota:

Ésta es la serie actual en desarrollo. Todas las características están en un estado primario. Los cambios podrían darse en cualquier momento sin previo aviso. Por favor, no use esta versión en entornos de producción.

La documentación aún no refleja todos los cambios.


Complemento de Memcache de Mysqlnd

  • Introducción
  • Guía rápida y ejemplos
    • Configuración
    • Uso
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Funciones de mysqlnd_memcache
    • mysqlnd_memcache_get_config — Devuelve información acerca de la configuración del complemento
    • mysqlnd_memcache_set — Asociar una conexión de MySQL con una conexión de Memcache
  • Historial de cambios
    • Serie PECL/mysqlnd_memcache 1.0


Introducción

El complemento memcache de mysqlnd (mysqlnd_memcache) es una extensión de PHP para traducir de forma transparente SQL en peticiones para el Complemento InnoDB Memcached Daemon de MySQL (complemento de servidor). Incluye soporte experimental para el Cluster Memcached Daemon de MySQL. El complemento del servidor proporciona acceso a datos almancenados en tablas InnoDB de MySQL (respectivamente MySQL Cluster NDB) empleando el protocolo Memcache. Esta extensión de PHP, la cual admite todas las extensiones de MySQL para PHP que utilicen mysqlnd, identificarán tablas exportadas de esta manera y traducirá consultas SELECT específicas a peticiones de Memcache.

Flujo de datos de mysqlnd_memcache

Nota:

Este complemento depende del Complemento InnoDB Memcached Daemon de MySQL. No está provisto para utilizarlo con una Memcached independiente. Para una caché de consultas genérico que emplee Memcached vea el complemento de caché de consultas de. Para un acceso directo a Memcache vea las extensiones memcache y memcached.

El controlador nativo de MySQL para PHP es una biblioteca en C que acompaña a PHP a partir de PHP 5.3.0. Sirve como un sustituto a corto plazo de la Biblioteca Cliente de MySQL (libmysqlclient). El uso de mysqlnd tiene varias ventajas: no son necesarias descargas extra debido a que está incluido con PHP, está bajo la licencia de PHP, hay menor consumo de memoria en ciertos casos, y contiene nueva funcionalidad, como consultas asíncronas.

mysqlnd_mmemcache opera, en mayor parte, de forma transparente desde la perspectiva del usuario. El complento memcache de mysqlnd admite todas las aplicaciones de PHP y todas las extensiones de MySQL para PHP. No cambia las APIs existentes. Por lo tanto, se puede usar fácilmente con las aplicaciones de PHP existentes.

Los complementos de Memcache para MySQL añaden un método de acceso tipo clave-valor para datos almacenados en tablas InnoDB (respectivamente MySQL Cluster NDB) a través del protocolo Memcache. Este acceso tipo clave-valor a menudo es más rápido que el uso de SQL.

Características principales

Las características principales de PECL/mysqlnd_memcache son las siguientes.

  • Posible beneficio en el rendimiento

    • Lado del cliente: protocolo ligero.

    • Lado del servidor: sin análisis de SQL, acceso directo al almacenamiento.

    • Por favor, ejecute su propia aplicación comparativa. Los resultados de rendimiento reales dependen altamente de la configuración y el hardware empleados.

Limitaciones

La versión inicial no es segura a nivel binario. Debido a la manera en que trabajan los complementos de Memcache para MySQL, existen restricciones relacionadas con separadores.

No hay soprte para sentencias preparadas y consultas asíncronas. El soporte para metadatos de conjuntos de resultados está limitado.

La información de correspondencia para tablas accesible mediante Memcache no se almacena en la caché del complemento entre peticiones, sino que se obtiene desde el servidor de MySQL cada vez una conexión de MySQL se asocie con una conexión de Memcache. Ver mysqlnd_memcache_set() para más detalles.

Sobre el nombre

La abreviatura mysqlnd_memcache significa complemento de memcache para mysqlnd. Memcache se refiere al soporte de los complementos de Memcache para MySQL para InnoDB y NDB (MySQL Cluster). El complemento no tiene relación con el servidor de caché de Memcached.


Guía rápida y ejemplos

Tabla de contenidos

  • Configuración
  • Uso

El complemento de memcache para mysqlnd es fácil de usar. Esta guía rápida mostrará los casos de uso típicos, y proporcionará consejos sobre cómo empezar a utilizarlo.

Se recomienda leer las secciones de referencia además de esta guía rápida. Aquí se intenta evitar tratar con conceptos teóricos y limitaciones. En su lugar, se enlazará con las secciones de referencia. Es seguro comenzar con esta guía rápida. Sin embargo, antes de usar el complemento en entornos de objetivos críticos, le animamos a que lea también la información de fondo de las secciones de referencia.


Configuración

El complemento está implementado como una extensión de PHP. Ver también las instrucciones de instalación para instalar esta extensión.

Compile o configure la extensión (API) de MySQL para PHP (mysqli, PDO_MYSQL, mysql) Esta extensión debe utilizar la biblioteca mysqlnd debido a que mysqlnd_memcache es un complemento para la biblioteca mysqlnd. Para información adicional, consulte las instrucciones de instalación de mysqlnd_memcache.

Después carque la extensión en PHP y active el complemento en el fichero de confuguración de PHP con la directiva de configuración llamada mysqlnd_memcache.enable.

Ejemplo #1 Habilitar el complemento (php.ini)

; En Windows, el nombre del fichero es php_mysqnd_memcache.dll
; Cargar la extensión
extension=mysqlnd_memcache.so
; Habilitarla
mysqlnd_memcache.enable=1

Siga las instrucciones dadas en el » Manual de referencia de MySQL para la instalación de los comlementos de Memcache para el servidor de MySQL. Active los complementos y configure el acceso a Memcache para tablas SQL.

En los ejemplos de esta guía rápida se asume que existen las sibguientes tablas, y que Memcache está configurado con acceso al mismo.

Ejemplo #2 Tabla SQL empleada para la Guía rápida

CREATE TABLE test(
  id CHAR(16),
  f1 VARCHAR(255),
  f2 VARCHAR(255),
  f3 VARCHAR(255),
  flags INT NOT NULL,
  cas_column INT,
  expire_time_column INT,
  PRIMARY KEY(id)
  ) ENGINE=InnoDB;

INSERT INTO test (id, f1, f2, f3) VALUES (1, 'Hello', 'World', '!');
INSERT INTO test (id, f1, f2, f3) VALUES (2, 'Lady', 'and', 'the tramp');

INSERT INTO innodb_memcache.containers(
  name, db_schema, db_table, key_columns, value_columns,
  flags, cas_column, expire_time_column, unique_idx_name_on_key)
VALUES (
  'plugin_test', 'test', 'test', 'id', 'f1,f2,f3',
  'flags', 'cas_column', 'expire_time_column', 'PRIMARY KEY');


Uso

Después de asociar una conexión de MySQL con una conexión de Memcache utilizando mysqnd_memcache_set(), el complemento intentará reemplazar de forma transparente las sentencias SELECT de SQL por un acceso a memcache. Para este propósito, el complemento monitoriza todas las sentencias SQL ejecutadas e intenta hacer coincidir el string de la sentencia con MYSQLND_MEMCACHE_DEFAULT_REGEXP. En caso de coincidir, el complemento de memcache para mysqlnd comprueba si la SELECT está accediendo solamente a columnas de una tabla de correspondencias y la cláusula WHERE está limitada a una búsqueda de clave única.

En el caso de la tabla tabla SQL de ejemplo, el complemento usrá la intefaz de Memcache del servidor de MySQL para obtener los resultados de una consulta SQL como SELECT f1, f2, f3 WHERE id = n.

Ejemplo #1 Ejemplo básico

<?php
$mysqli = new mysqli("host", "usuario", "contraseña", "base_de_datos");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

/*
   Esta es una consulta a la tabla test que emplea id como clave de la cláusula WHERE
   y que accede a los campos f1, f2 y f3. Por tanto, mysqlnd_memcache
   la interceptará y la redirigirá mediante memcache.
*/
$resultado = $mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");
while ($fila = $resultado->fetch_row()) {
    print_r($fila);
}

/*
   Esta es una consulta a la tabla test pero empleando f1 en la cláusula WHERE.
   Por tanto, mysqlnd_memcache no la interceptará. Se ejecutará
   empleando el protocolo de MySQL.
*/
$mysqli->query("SELECT id FROM test WHERE f1 = 'Lady'");
while ($fila = $resultado->fetch_row()) {
    print_r($fila);
}
?>

El resultado del ejemplo sería:

array(
    [f1] => Hello
    [f2] => World
    [f3] => !
)
array(
    [id] => 2
)


Requerimientos

PHP: esta extensión requiere PHP 5.4+, la versión 5.4.4 o posterior de PHP. Las extensiones de PHP requeridas son PCRE (habilitada de forma predeterminada), y la verisón 2.0.x de la extensión memcached.

El complemento de Memcache mysqlnd_memcache admite todas las aplicaciones de PHP y todas las extensión de MySQL para PHP disponibles (mysqli, mysql, PDO_MYSQL). La extensión de MySQL para PHP debe cofigurarse con soporte para mysqlnd.

Para acceder a tablas InnoDB, esta extensión de PHP requiere MySQL Server 5.6.6 o posterior con el Complemento InnoDB Memcache Daemon habilitado.

Para acceder a tablas MySQL Cluster NDB, esta extensión de PHP requiere MySQL Cluster 7.2 o posterior con los nodos de la API NDB Memcache habilitados.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mysqlnd_memcache

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de mysqlnd_memcache
Nombre | Por defecto | Cambiable | Historial de cambios
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Disponible desde 1.0.0

He aquí una breve explicación de las directivas de configuración.

mysqlnd_memcache.enable integer

Habilita o deshabilita el complemento. Si se deshabilita, la extensión no se conectará a mysqlnd para representar a las llamadas internas a la API mysqlnd en C.

Nota:

Esta opción es empleada principalmente por desarrolladores para construir esta extensión de forma estática en PHP. A los demás usuarios se les recomienda construir esta extensión como un objeto compartido, y no cargarla en absoluto cuando no sea necesaria.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Relacionadas con el Complemento de Memcache para MySQL

MYSQLND_MEMCACHE_DEFAULT_REGEXP (string)
Expresión regular predeterminada (estilo PCRE) empleada para hacer coincidir sentencias SELECT que se corresponderán con un punto de acceso al Complemento Memcache de MySQL, si es posible. También es posible emplear mysqlnd_memcache_set(), pero la estrategia predeterminada es emplear esta expresión regular para coincidencias de patrones.

Varias

El número de versión de este comlemento se puede obtener utilizando MYSQLND_MEMCACHE_VERSION o MYSQLND_MEMCACHE_VERSION_ID. MYSQLND_MEMCACHE_VERSION es la representación de tipo string de la versión numérica de MYSQLND_MEMCACHE_VERSION_ID, el cual es un integer como 10000. Los desarrolladores pueden calcular el número de versión como sigue:

Versión (parte) | Ejemplo
Mayor*10000 | 1*10000 = 10000
Menor*100 | 0*100 = 0
Parche | 0 = 0
MYSQLND_MEMCACHE_VERSION_ID | 10000

MYSQLND_MEMCACHE_VERSION (string)
String con la versión del complemento, por ejemplo, 1.0.0-alpha.
MYSQLND_MEMCACHE_VERSION_ID (integer)
Número de la versión del complemento, por ejemplo, 10000.


Funciones de mysqlnd_memcache

Tabla de contenidos

  • mysqlnd_memcache_get_config — Devuelve información acerca de la configuración del complemento
  • mysqlnd_memcache_set — Asociar una conexión de MySQL con una conexión de Memcache


Devuelve información acerca de la configuración del complemento

  • « Funciones de mysqlnd_memcache
  • mysqlnd_memcache_set »
  • PHP Manual
  • Funciones de mysqlnd_memcache
  • Devuelve información acerca de la configuración del complemento

mysqlnd_memcache_get_config

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_get_config — Devuelve información acerca de la configuración del complemento

Descripción

mysqlnd_memcache_get_config ( mixed $connection ) : array

Esta función devuelve un array con toda la información de configuración relacionada con mysqlnd_memcache que ha sido adjuntada a la conexión de MySQL. Esto incluye a MySQL, el objeto Memcache proporcionado por mysqlnd_memcache_set(), y la configuración de la correspondencia de tablas que fue recogida de forma automática desde el servidor de MySQL.

Parámetros

connection

Un gestor a un Servidor de MySQL empleando una de las extensiones de la API de MySQL para PHP, las cuales son PDO_MYSQL, mysqli o ext/mysql.

Valores devueltos

Un array con información de la configuración de mysqlnd_memcache en caso de éxito, de lo contrario, false.

El array devuelto contiene estos elementos:

Estructura del array de mysqlnd_memcache_get_config()
Clave del array | Descripción
memcached | Una instancia de Memcached asociada a esta conexión de MySQL mediante mysqlnd_memcache_set(). Se puede emplear esta clave para cambiar los ajustes de la conexión de memcache, o directamente consultando al servdor sobre esta conexión.
pattern | La expresión regular PCRE empleada para hacer coincidir la consulta SQL enviada al servidor. Las consultas que coincidan con este patrón serán analizadas para decidri si la consulta puede ser interceptada y enviada mediante la interfaz de memcache o si la consulta se envía al servidor empleado el protocolo general de MySQL. El patrón puede ser el patrón predeterminado (MYSQLND_MEMCACHE_DEFAULT_REGEXP) o el establecido por mysqlnd_memcache_set().
mappings | Un array asociativo con una lista de todos los contenedores configurados tal y como fueron descubiertos por este comlemento. La clave para esto elementos es el nombre del contenedor de la configuración de MySQL. El valor está descrito más abajo. El contenido de este campo se crea consultando al Servidor de MySQL durante la asociación de MySQL y una conexión de memcache empleando mysqlnd_memcache_set().
mapping_query | Una consulta SQL empleada durante mysqlnd_memcache_set() para identificar los contenedores disponibles y correspondecias. El resultado de esta consulta está provisto en el elemento de correspondencia.
Estructura de entradas de correspondencia
Clave del array | Descripción
prefix | Un prefijo empleado mientras se accede a datos mediante memcache. Con el complemento InnoDB Memcache Deamon de MySQL, este normalmente comienza con @@ y termina con un separador configurable. Este prefijo se coloca delante del valor de la clave mientras se utiliza el protocolo memcache.
schema_name | Nombre del esquema (base de datos) que contiene la tabla a acceder.
table_name | Nombre de la tabla que contiene los datos accesibles mediante el protocolo memcache.
id_field_name | Nombre del campo (columna) de la base de datos con el id empleado como clave al acceder a la tabla mediante memcache. A menudo este es el campo de la base de datos que tiene la clave primaria.
separator El separador empeado para dividir los diferentes valores de campos. Es necesario debido a que memcache solamente provee acceso a un único valor, mientras que MySQL puede hacer corresponder varias columnas a este valor.

Nota:

El separador, el cual se puede establecer en la configuración del Servidor de MySQL, no debería ser parte de ningún valor recuperado mediante memcache, ya que no se puede garantizar la correspondecia apropiada.

fields | Un array con el nombre de todos los campo disponibles para esta correspondencia.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_memcache_get_config()

<?php
$mysqli = new mysqli("host", "usuario", "contraseña", "base_de_datos");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

var_dump(mysqlnd_memcache_get_config($mysqli));
?>

El resultado del ejemplo sería:

array(4) {
  ["memcached"]=>
  object(Memcached)#2 (0) {
  }
  ["pattern"]=>
  string(125) "/^\s*SELECT\s*(.+?)\s*FROM\s*`?([a-z0-9_]+)`?\s*WHERE\s*`?([a-z0-9_]+)`?\s*=\s*(?(?=["'])["']([^"']*)["']|([0-9e\.]*))\s*$/is"
  ["mappings"]=>
  array(1) {
    ["mymem_test"]=>
    array(6) {
      ["prefix"]=>
      string(13) "@@mymem_test."
      ["schema_name"]=>
      string(4) "test"
      ["table_name"]=>
      string(10) "mymem_test"
      ["id_field_name"]=>
      string(2) "id"
      ["separator"]=>
      string(1) "|"
      ["fields"]=>
      array(3) {
        [0]=>
        string(2) "f1"
        [1]=>
        string(2) "f2"
        [2]=>
        string(2) "f3"
      }
    }
  }
  ["mapping_query"]=>
  string(209) "    SELECT c.name,
                          CONCAT('@@', c.name, (SELECT value FROM innodb_memcache.config_options WHERE name = 'table_map_delimiter')) AS key_prefix,
                          c.db_schema,
                          c.db_table,
                          c.key_columns,
                          c.value_columns,
                          (SELECT value FROM innodb_memcache.config_options WHERE name = 'separator') AS sep
                     FROM innodb_memcache.containers c"
}

Ver también

  • mysqlnd_memcache_set() - Asociar una conexión de MySQL con una conexión de Memcache


Asociar una conexión de MySQL con una conexión de Memcache

  • « mysqlnd_memcache_get_config
  • Historial de cambios »
  • PHP Manual
  • Funciones de mysqlnd_memcache
  • Asociar una conexión de MySQL con una conexión de Memcache

mysqlnd_memcache_set

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_set — Asociar una conexión de MySQL con una conexión de Memcache

Descripción

mysqlnd_memcache_set ( mixed $mysql_connection , Memcached $memcache_connection = ? , string $pattern = ? , callback $callback = ? ) : bool

Asocia mysql_connection con memcache_connection empleando pattern como una expresión regular PCRE, y callback como una retrollamada de notificación o para desestablecer la asociación de mysql_connection.

Al tiempo que asocia una conexión de MySQL con una conexión de Memcache, esta función consultará al servidor de MySQL por su configuración. Detectará automáticamente si el servidor está configurado para utilizar el Complemento InnoDB Memcache Daemon o el soporte para Cluster NDB Memcache de MySQL. También consultará al servidor para identificar automáticamente tablas exportadas y otras opciones de configuración. El resultado de esta configuración automática se puede recuperar con mysqlnd_memcache_get_config().

Parámetros

mysql_connection

Un gestor a un Servidor de MySQL empleando una de las extensiones de la API de MySQL para PHP, las cuales son PDO_MYSQL, mysqli o ext/mysql.

memcache_connection

Una instancia de Memcached con una conexión al complemento Memcache Daemon de MySQL. Si se omite este parámetro, mysql_connection estará disociado de cualquier conexión de memcache. Y existe una asociación previa será reemplazada.

pattern

Una expresión regular con la sintaxis de Expresiones regulares compatibles con Perl empleada para identificar consultas de Memcache potenciales. La consulta debería tener tres subpatrones. El primer subpatrón contiene la lista de campos solicitados; el segundo, el nombre de la columna ID de la consulta; y el tercero, el valor solicitado. Si se omite este parámetro o se establece a null, se utilizará un patrón predeterminado.

callback

Una retrollamada que será empleada siempre que se comience el envío de una consulta a MySQL. La retrollamada recibirá un único parámetro de tipo bool indicando si una consulta fue enviada mediante Memcache.

Valores devueltos

true si la asociación o disociación tiene éxito, o de lo contrario false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de mysqlnd_memcache_set() con var_dump() como una retrollama de depuración simple.

<?php
$mysqli = new mysqli("host", "usuario", "contraseña", "base_de_datos");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc, NULL, 'var_dump');

/* Esta consulta será interceptada y ejecutada por el protocolo Memcache */
echo "Enviando la consulta para id mediante Memcache: ";
$mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");

/* f1 no está configurado como un campo de clave válido, por lo que esta no se enviará a Memcache */
echo "Enviando la consulta para f1 mediante Memcache: ";
$mysqli->query("SELECT id FROM test WHERE f1 = 1");

mysqlnd_memcache_set($mysqli);

/* Ahora se empleará el protocolo regular de MySQL */
echo "var_dump no será invocado: ";
$mysqli->query("SELECT f1, f2, f3 WHERE id = 1");

?>

El resultado del ejemplo sería:

Enviando la consulta para id mediante Memcache: bool(true)
Enviando la consulta para f1 mediante Memcache: bool(false)
var_dump no será invocado:

Ver también

  • mysqlnd_memcache_get_config() - Devuelve información acerca de la configuración del complemento


Historial de cambios

Tabla de contenidos

  • Serie PECL/mysqlnd_memcache 1.0

Este historial de cambios es un resumen de alto nivel de los cambios seleccionados que podrían tener impacto en aplicaciones y/o romper la retrocompatibilidad.

Ver también el fichero CHANGES en la distribución fuente para una lista completa de cambios.


Serie PECL/mysqlnd_memcache 1.0

1.0.0-alpha

  • Fecha de publicación: TBD
  • Motivo/tema: Correspondencia básica de la SELECT de SQL a un acceso del complemento de Memcache para MySQL.

La versión inicial realiza una correspondencia de sentencias SELECT básicas de SQL con accesos al complemento de Memcache para MySQL. Esto pone al descubierto beneficios de rendimiento potenciales debido a que el acceso directo de un par clave-valor al almacén de MySQL empleando el protocolo Memcache es normalmente más rápido que emplear el acceso por SQL.


Oracle OCI8

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Pruebas
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Ejemplos
  • Manejo de conexiones de OCI8 y agrupamiento de conexiones
  • OCI8 Fast Application Notification (FAN) Support
  • Soporte para 'Transparent Application Failover' (TAF) de OCI8
  • OCI8 y rastreo dinámico de DTrace
  • Tipos de datos admitidos
  • Funciones de OCI8
    • oci_bind_array_by_name — Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL
    • oci_bind_by_name — Vincula una variable de PHP a un parámetro de sustitución de Oracle
    • oci_cancel — Cancela la lectura del cursor
    • oci_client_version — Devuelve la versión de la biblioteca cliente de Oracle
    • oci_close — Cierra una conexión a Oracle
    • oci_commit — Consigna la transacción pendiente de la base de datos
    • oci_connect — Conecta a una base de datos de Oracle
    • oci_define_by_name — Asocia una variable de PHP con una columna para la obtención de consultas
    • oci_error — Devuelve el último error encontrado
    • oci_execute — Ejecuta una sentencia
    • oci_fetch_all — Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
    • oci_fetch_array — Devuelve la siguiente fila de una consulta como un array asociativo o numérico
    • oci_fetch_assoc — Devuelve la siguiente fila de una consulta como un array asociativo
    • oci_fetch_object — Devuelve la siguiente fila de una consulta como un objeto
    • oci_fetch_row — Devuelve la siguiente fila de una consulta como un array numérico
    • oci_fetch — Coloca la siguiente fila de una consulta en los búferes internos
    • oci_field_is_null — Comprueba si un campo de la fila actualmente obtenida es null
    • oci_field_name — Devuelve el nombre de un campo de una sentencia
    • oci_field_precision — Indica la precisión de un campo
    • oci_field_scale — Indica la escala de un campo
    • oci_field_size — Devuelve el tamaño de un campo
    • oci_field_type_raw — Indica el tipo de datos sin tratar de Oracle de un campo
    • oci_field_type — Devuelve el nombre del tipo de datos de un campo
    • oci_free_descriptor — Libera un descriptor
    • oci_free_statement — Libera todos los recursos asociados con una sentencia o cursor
    • oci_get_implicit_resultset — Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c
    • oci_lob_copy — Copia objetos grandes
    • oci_lob_is_equal — Compara dos localizadores LOB/FILE
    • oci_new_collection — Asigna un nuevo objeto colección
    • oci_new_connect — Conectar al servidor de Oracle usando una conexión única
    • oci_new_cursor — Asigna y devuelve un nuevo cursor (gestor de sentencia)
    • oci_new_descriptor — Inicializa un nuevo descriptor LOB o FILE vacío
    • oci_num_fields — Devuelve el número de columnas del resultado de una sentencia
    • oci_num_rows — Devuelve el número de filas afectadas durante la ejecución de una sentencia
    • oci_parse — Prepara una sentencia de Oracle para su ejecución
    • oci_password_change — Cambia la contraseña de un usuario de Oracle
    • oci_pconnect — Conectar a una base de datos de Oracle usando una conexión persistente
    • oci_register_taf_callback — Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database
    • oci_result — Devuelve el valor de un campo de la fila obtenida
    • oci_rollback — Revierte la transacción pendiente de la base de datos
    • oci_server_version — Devuelve la versión de Oracle Database
    • oci_set_action — Establece el nombre de una acción
    • oci_set_call_timeout — Sets a millisecond timeout for database calls
    • oci_set_client_identifier — Establece el identificador del cliente
    • oci_set_client_info — Establece la información del cliente
    • oci_set_db_operation — Sets the database operation
    • oci_set_edition — Establece la edición de la base de datos
    • oci_set_module_name — Establece el nombre de un módulo
    • oci_set_prefetch — Establece el número de filas a precargar mediante consultas
    • oci_statement_type — Devuelve el tipo de una sentencia
    • oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF
  • OCI-Collection — La clase OCI-Collection
    • OCI-Collection::append — Añade un elemento a la colección
    • OCI-Collection::assign — Asigna un valor a la colección desde otra colección existente
    • OCI-Collection::assignElem — Asigna un valor a un elemento de la colección
    • OCI-Collection::free — Libera los recursos asociados con el objeto colección
    • OCI-Collection::getElem — Devuelve el valor de un elemento
    • OCI-Collection::max — Devuelve el número máximo de elementos de la colección
    • OCI-Collection::size — Devuelve el tamaño de la colección
    • OCI-Collection::trim — Elimina elementos del final de la colección
  • OCI-Lob — La clase OCI-Lob
    • OCI-Lob::append — Añade datos a un objeto grande (LOB) desde otro
    • OCI-Lob::close — Cierra un descriptor de LOB
    • OCI-Lob::eof — Comprueba la marca de final de fichero en un descriptor de objetos grandes
    • OCI-Lob::erase — Borra la porción especificada de los datos internos de un LOB
    • OCI-Lob::export — Exporta el contenido de un LOB a un fichero
    • OCI-Lob::flush — Vacía/escribe el búfer de un LOB al servidor
    • OCI-Lob::free — Libera los recursos asociados con el descriptor del LOB
    • OCI-Lob::getBuffering — Devuelve el estado actual del uso del búfer para un objeto grande
    • OCI-Lob::import — Importa datos de un fichero a un LOB
    • OCI-Lob::load — Devuelve el contenido de un objeto grande
    • OCI-Lob::read — Lee parte del objeto grande
    • OCI-Lob::rewind — Mueve el puntero interno al comienzo de un objeto grande
    • OCI-Lob::save — Guarda datos en un objeto grande
    • OCI-Lob::saveFile — Alias de OCI-Lob::import
    • OCI-Lob::seek — Ubica el puntero interno de un objeto grande
    • OCI-Lob::setBuffering — Cambia el estado actual del uso del búfer para objetos grandes
    • OCI-Lob::size — Devuelve el tamaño de un objeto grande
    • OCI-Lob::tell — Devuelve la posición actual del puntero interno de un objeto grande
    • OCI-Lob::truncate — Trunca un objeto grande
    • OCI-Lob::write — Escribe datos en un objeto grande
    • OCI-Lob::writeTemporary — Escribe un objeto grande temporal
    • OCI-Lob::writeToFile — Alias de OCI-Lob::export
  • Funciones y alias de OCI8 obsoletos
    • oci_internal_debug — Enables or disables internal debug output
    • ocibindbyname — Alias de oci_bind_by_name
    • ocicancel — Alias de oci_cancel
    • ocicloselob — Alias de OCI-Lob::close
    • ocicollappend — Alias de OCI-Collection::append
    • ocicollassign — Alias de OCI-Collection::assign
    • ocicollassignelem — Alias de OCI-Collection::assignElem
    • ocicollgetelem — Alias de OCI-Collection::getElem
    • ocicollmax — Alias de OCI-Collection::max
    • ocicollsize — Alias de OCI-Collection::size
    • ocicolltrim — Alias de OCI-Collection::trim
    • ocicolumnisnull — Alias de oci_field_is_null
    • ocicolumnname — Alias de oci_field_name
    • ocicolumnprecision — Alias de oci_field_precision
    • ocicolumnscale — Alias de oci_field_scale
    • ocicolumnsize — Alias de oci_field_size
    • ocicolumntype — Alias de oci_field_type
    • ocicolumntyperaw — Alias de oci_field_type_raw
    • ocicommit — Alias de oci_commit
    • ocidefinebyname — Alias de oci_define_by_name
    • ocierror — Alias de oci_error
    • ociexecute — Alias de oci_execute
    • ocifetch — Alias de oci_fetch
    • ocifetchinto — Variante obsoleta de oci_fetch_array, oci_fetch_object, oci_fetch_assoc y oci_fetch_row
    • ocifetchstatement — Alias de oci_fetch_all
    • ocifreecollection — Alias de OCI-Collection::free
    • ocifreecursor — Alias de oci_free_statement
    • ocifreedesc — Alias de OCI-Lob::free
    • ocifreestatement — Alias de oci_free_statement
    • ociinternaldebug — Alias de oci_internal_debug
    • ociloadlob — Alias de OCI-Lob::load
    • ocilogoff — Alias de oci_close
    • ocilogon — Alias de oci_connect
    • ocinewcollection — Alias de oci_new_collection
    • ocinewcursor — Alias de oci_new_cursor
    • ocinewdescriptor — Alias de oci_new_descriptor
    • ocinlogon — Alias de oci_new_connect
    • ocinumcols — Alias de oci_num_fields
    • ociparse — Alias de oci_parse
    • ociplogon — Alias de oci_pconnect
    • ociresult — Alias de oci_result
    • ocirollback — Alias de oci_rollback
    • ocirowcount — Alias de oci_num_rows
    • ocisavelob — Alias de OCI-Lob::save
    • ocisavelobfile — Alias de OCI-Lob::import
    • ociserverversion — Alias de oci_server_version
    • ocisetprefetch — Alias de oci_set_prefetch
    • ocistatementtype — Alias de oci_statement_type
    • ociwritelobtofile — Alias de OCI-Lob::export
    • ociwritetemporarylob — Alias de OCI-Lob::writeTemporary


Introducción

Estas funciones permiten acceder a Oracle Database 12c, 11g, 10g, 9i y 8i. Admiten sentencias SQL y PL/SQL. Sus características básicas incluyen el control de transacciones, la vinculación de variables de PHP a parámetros de sustitución de Oracle, y la admisión de tipos de objetos grandes (LOB) y colecciones. Las características de escalabilidad de Oracle, como el Agrupamiento de Conexiones Residentes de Bases de Datos (DRCP por sus siglás en inglés), también tienen soporte.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Pruebas
  • Configuración en tiempo de ejecución


Requerimientos

La extensión OCI8 1.4 está incluida con PHP 5.3, PHP 5.4 y PHP 5.5. También está disponible desde » PECL.Una nueva versión, OCI8 2.0, está disponible solamente desde » PECL. OCI8 1.4 requiere las bibliotecas cliente de Oracle 12c, 11g, 10g o 9iR2 y la instalación en PHP 4.3.9 o superior. OCI8 2.0 requiere las bibliotecas cliente de Oracle 12c, 11g o 10g y la instalalción en PHP 5.2 o superior.

Si Oracle Database está en la misma máquina que PHP, el software de bases de datos ya contiene las bibliotecas necesarias. Cuando PHP está en una máquina diferente, use las bibliotecas gratuitas de » Oracle Instant Client.

Para usar Oracle Instant Client, instale el fichero ZIP de Oracle Instant Client basic o basiclite o el paquete RPM. Al construir PHP desde el código fuente, también instale el fichero ZIP sdk o el paquete RPM devel.

Se ha de ejecutar PHP con la misma versión, o una más reciente, de las bibliotecas de Oracle con las que OCI8 fue construid.

En Windows, la DLL php_oci8 DLL necesita las bibliotecas cliente de Oracle desde la versión 10gR2 o superior. En PHP 5.3 hasta e incluyendo PHP 5.3.5, la DLL php_oci8_11g requiere las bibliotecas cliente de Oracle 11gR1 o superior. Desde PHP 5.3.6, la DLL php_oci8_11g requiere las bibliotecas cliente de Oracle 11gR2 o superior. La DLL php_oci8_12c de PECL requiere las bibliotecas cliente de Oracle 12cR1. Con algunas versiones de Instant Client se podrían necesitar además las bibliotecas mfc71.dll y msvcr71.dll.

Nota:

Si OCI8 usa las bibliotecas cliente 9iR2, PHP se puede conectar a Oracle Database 8i, 9iR2, 10g o 11g. Si OCI8 usa las bilbiotecas cliente 10gR2, la base de datos puede ser 9iR2, 10g, 11g o 12c. Si OCI8 usa las bibliotecas cliente 11g, la base de datos puede ser 9iR2, 10g, 11g o 12c. Si OCI8 usa las bibliotecas cliente 12c, la base de datos puede ser 10gR2, 11g o 12c.

Nota:

El soporte completo para las características de OCI8 solamente está disponible al usar la versión más reciente de las bibliotecas cliente y base de datos de Oracle.


Instalación

Configurar PHP con OCI8

Revise la sección previa Requerimientos antes de configurar OCI8.

Para habilitar la extensión OCI8 se ha de configurar PHP con la opción --with-oci8.

Antes de iniciar el servidor web, OCI8 normalmente necesita diversas variables de entorno de Oracle (véase abajo) para localizar bibliotecas, apuntar a ficheros de configuración, y establecer algunas propiedades básicas como el conjunto de caracteres usado por las bibliotecas de Oracle. Las variables deben ser establecidas antes de que se inicie cualquier proceso de PHP.

El binario de PHP debe vincularse con la misma, o más reciente, versión mayor de las bibliotecas de Oracle con las que se configuró. Por ejemplo, si se construyó OCI8 con las bibliotecas de Oracle 11.2, entonces PHP debería también PHP usarse y ejecutarse con la bibliotecas de Oracle 11.2. Las aplicaciones de PHP pueden conectarse a otras versiones Oracle Database, ya que Oracle posee compatibilidad cliente-servidor entre versiones.

Instalar OCI8 con una extensión compartida

La opciones de configuración shared construye OCI8 como una biblioteca compartida que puede ser cargada dinámicamente en PHP. La construcción de una extensión compartida permite que OCI8 sea actualizada fácilmente sin que tenga impacto sobre el resto de PHP.

Se ha de configurar OCI8 usando una de las siguientes opciones de configuración:

  • Si se usan las bibliotecas » Oracle Instant Client gratuitas, se ha de hacer lo siguiente:

    ./configure --with-oci8=shared,instantclient,/ruta/a/instant/client/lib

    Si Instant Client está instalado desde ficheros ZIP, asegúrese de crear el enlace simbólico de la biblioteca primero, por ejemplo ln -s libclntsh.so.12.1 libclntsh.so.

    Si se usa una instalación de Oracle Instant Client basada en RPM, la línea de confiugraicón se parecerá a esta:

    ./configure --with-oci8=shared,instantclient,/usr/lib/oracle/<version>/client/lib

    Por ejemplo, --with-oci8=shared,instantclient,/usr/lib/oracle/12.1/client/lib

    Nótese que el soporte para Oracle Instant Client apareció primero en PHP 4.3.11 y 5.0.4 y que originalmente se utilizaba la opción --with-oci8-instant-client para configurar PHP.

  • Si se usa una base de datos de Oracle o una instalación completa de Oracle Client, la línea ha de ser:

    ./configure --with-oci8=shared,$ORACLE_HOME

    Asegúrese de que el usuario del servidor web (nobody, www) tiene acceso a las biblitecas, a los ficheros de inicialización y a tnsnames.ora (si se utiliza) bajo el directorio $ORACLE_HOME. Con Oracle 10gR2 podría ser necesario ejecutar la utilidad $ORACLE_HOME/install/changePerm.sh para proporcionar acceso al directorio.

Después de la configuración, siga los procedimientos habituales de construcción de PHP, p.ej., make install. Se creará la extensión compartida oci8.so. Podría ser necesario moverla manualmente al directorio de extensiones de PHP, especificado por la opción extension_dir del fichero php.ini.

Para completar la instalación de OCI8, edite php.ini y añada la línea:

extension=oci8.so

Instalar OCI8 como una extensión compilada estáticamente

Se ha de configurar PHP para incluir OCI8 usando una de las siguientes opciones de configuración:

  • Si se usa Oracle Instant Client, se ha de utilizar lo siguiente:

    ./configure --with-oci8=instantclient,/path/to/instant/client/lib

  • Si se usa una base de datos de Oracle o una instalación completa de Oracle Client, la línea ha de ser:

    ./configure --with-oci8=$ORACLE_HOME

Después de la configuración, siga los procedimientos habituales de construcción de PHP, p.ej., make install. Después de una compilación satisfactoria no es necesario añadir oci8.so a php.ini. No se requieren pasos adicionales para la construcción.

Instalar OCI8 desde PECL

La extensión OCI8 se puede añadir a una instalación de PHP existente, automática o manualmente, desde » PECL.

Para una instalación automática, siga estos pasos:

  • Si está detrás de un cortafuegos, establezca el proxy de PEAR, por ejemplo:

    pear config-set http_proxy http://mi-proxy.example.com:80/

  • Ejecute

    pecl install oci8

    Cuando se le pregunte, introduzca el valor de $ORACLE_HOME, o instantclient,/path/to/instant/client/lib.

    Nota: No introduzca la variable $ORACLE_HOME ya que no será expandida. En su lugar, introduzca la ruta real del directorio inicial de Oracle.

Para una instalación manual cuando el comando pecl no esté disponible, descargue el paquete OCI8 de PECL, p.ej. oci8-1.4.10.tgz.

  • Extraiga el paquete:

    tar -zxf oci8-1.4.10.tgz
cd oci8-1.4.10

  • Prepare el paquete:

    phpize

  • Configure el paquete, usando $ORACLE_HOME o Instant Client

    ./configure -with-oci8=shared,$ORACLE_HOME

    o

    ./configure -with-oci8=shared,instantclient,/path/to/instant/client/lib

  • Instale el paquete:

    make install

Después de la instalación manual o automática, edite el fichero php.ini y añada la línea:

extension=oci8.so

Asegúrese de que la directiva de php.ini extension_dir está establecida al directorio donde oci8.so fue instalado.

Instalar OCI8 en Windows

Al usar las bibiotecas cliente de Oracle 10gR2 en Windows, descomente la línea del php.ini extension=php_oci8.dll. Al usar las bibliotecas cliente de Oracle 11gR2 o posterior, descomente extension=php_oci8_11g.dll o extension=php_oci8.dll. Con las bibliotecas de Oracle 12c use extension=php_oci8_12c.dll o extension=php_oci8_11g.dll o extension=php_oci8.dll. Solamente puede estar habilitada una de estas DLLs al mismo tiempo. Las DLLs de versiones posteriores pueden contener más funcionalidad. No todas las DLLs pueden estar disponibles para todas las versiones PHP. Asegúrese de que extension_dir está establecido al directorio que contiene las DDLs de extensiones de PHP.

Si usa Instant Client, establezca la variable de entorno de sistema PATH al directorio de la biblioteca de Oracle.

Establecer el entorno de Oracle

Antes de usar esta extensión, asegúrese de que las variables de entorno de Oracle están establecidas apropiadamente para el usuario del demonio web. Si el servidor web se inicia automáticamente durante el arranque, asegúrese de que el entorno de tiempo de arranque está también configurado correctamente.

Nota:

No establezca las variables de entorno de Oracle usando putenv() en un script de PHP, ya que la bibliotecas de Oracle podrían ser cargadas e inicializadas antes de que el script se ejecute. Las variables establecidas con putenv() podrían ocasionar conflictos, fallas, o comportamientos impredecibles. Algunas funciones podrían funcionar, mientras que otras darían errores imperceptibles. Las variables deberían estar configuradas antes de que se inicie el servidor web.

En Red Hat Linux y sus variantes, exporte las variables al final de /etc/sysconfig/httpd. Otros sistemas con Apache 2 podrían usar un script envvars en el directorio bin de Apache. Una tercera opción, la directiva SetEnv de Apache en httpd.conf, podría funcionar en algunos sistemas, pero se sabe que es insuficiente en otros.

Para verificar que las variables de entorno están establecidas correctamente, use phpinfo() y compruebe la sección Environment (no la de Apache) que contiene las variables requeridas.

Las variables que podrían ser necesarias están incluidas en la siguiente tabla. Consulte la documentación de Oracle para más información sobre todas las variables disponibles.

Variables de entorno comunes de Oracle
Nombre | Propósito
ORACLE_HOME | Contiene el directorio del software completo de Oracle Database. No la establezca cuando use Oracle Instant Client ya que no es necesaria y podría causar problemas de instalación.
ORACLE_SID | Contiene el nombre de la base de datos de la máquina local a la que conectarse. Na hay necesidad de establecerla si se usa Oracle Instant Client, o si siempre se proporciona el parámetro de conexión a oci_connect().
LD_LIBRARY_PATH | Establézcala (o su equivalente de plataforma, como DYLD_LIBRARY_PATH, LIBPATH, o SHLIB_PATH) a la ubicación de las bibliotecas de Oracle, por ejemplo, $ORACLE_HOME/lib o /usr/lib/oracle/11.1/client/lib. Esta variable no es necesaria si las bibliotecas está localizadas mediante un mecanismo de búsqueda diferente, como con ldconfig o LD_PRELOAD.
NLS_LANG | Esta es la variable principal para configurar el conjunto de caracteres y la información de globalización usados por las bibliotecas de Oracle.
ORA_SDTZ | Establece la zona horaria de la sesión de Oracle.
TNS_ADMIN | Contiene el directorio donde residen los ficheros de configuración de Oracle Net Services, tales como tnsnames.ora y sqlnet.ora. No es necesaria si la cadena de conexión oci_connect() utiliza la sintaxis de nombramiento sencillo de conexiones, como localhost/XE. No es necesaria si los ficheros de configuración de red está en las ubicaciones predeterminadas, como $ORACLE_HOME/network/admin o /etc.
Las variables de entorno de Oracle que se usan con menos frecuencia incluyen TWO_TASK, ORA_TZFILE, y las diversas configuraciones de globalización de Oracle como NLS* y las variables ORA_NLS_*.

Resolución de problemas

El problema más común al instalar OCI8 es no tener el entorno de Oracle correctamente establecido. Esto, normalmente, aparece como un problema al utilizar oci_connect() o oci_pconnect(). El error podría ser un error de PHP tal como Call to undefined function oci_connect(), un error de Oracle como ORA-12705, o incluso que Apache falle. Compruebe los ficheros de registro de Apache para los errores de arranque y lea las secciones sobre la resolución de este problema.

Mientras que los errores de red como ORA-12154 u ORA-12514 indican un problema con el nombramiento de redes o de configuraicón de Oracle, la raíz de la causa podría ser debida a que el entorno de PHP no esté correctamente configurado, y por lo tanto, las bibliotecas de Oracle no son capaces de localizar el fichero de configuración tnsnames.ora.

En Windows, el tener múltiples versiones de Oracle en la misma máquina puede ocasionar fácilmente que las bibliotecas fallen, a menos que se asegure de que PHP utilice solamente la versión correcta de Oracle.

Una utilidad para examinar las bibliotecas que están siendo buscadas y cargadas puede ayudar a resolver problemas de bibliotecas ausentes o que fallen, particularmente en Windows.

Nota: Si el servidor web no se inicia o falla durante el arranque

Compruebe que Apache está vinculado con la biblioteca pthread:

# ldd /www/apache/bin/httpd
  libpthread.so.0 => /lib/libpthread.so.0 (0x4001c000)
  libm.so.6 => /lib/libm.so.6 (0x4002f000)
  libcrypt.so.1 => /lib/libcrypt.so.1 (0x4004c000)
  libdl.so.2 => /lib/libdl.so.2 (0x4007a000)
  libc.so.6 => /lib/libc.so.6 (0x4007e000)
  /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Si libpthread no se muestra, reinstale Apache:

# cd /usr/src/apache_1.3.xx
# make clean
# LIBS=-lpthread ./config.status
# make
# make install

Por favor, observe que en algunos sistemas como UnixWare, es libthread en lugar de libpthread. PHP y Apache tienen que estar configurados con EXTRA_LIBS=-lthread.


Pruebas

El conjunto de pruebas de OCI8 está en el directorio ext/oci8/tests. Después de ejecutar las pruebas de OCI8, este directorio también contendrá los registros de cualquier fallo.

Antes de ejecutar las pruebas de PHP, edite details.inc y establezca $user, $password y la cadena de conexión $dbase. El conjunto de pruebas de OCI8 ha sido desarrollado usando la cuenta SYSTEM. Algunas pruebas fallarán si el usuario de las mismas no tiene permisos equivalentes.

Si se está comprobando Oracle Database Resident Connection Pooling, establezca $test_drcp a true y asegúrese de que la cadena de conexión utiliza un servidor de la agrupación DRCP apropiado.

Una alternativa a editar details.inc es el establecimiento de variables de entorno, por ejemplo:

    $ export PHP_OCI8_TEST_USER=system
    $ export PHP_OCI8_TEST_PASS=oracle
    $ export PHP_OCI8_TEST_DB=localhost/XE
    $ export PHP_OCI8_TEST_DRCP=FALSE
Observe que en algunas shell, estas variables no se propagan correctamente por proceso de PHP y que las pruebas fallarán al conectar si se utiliza este método.

Lo siguiente es establecer cualquier entorno necesario para la base de datos de Oracle. Con Oracle 10gR2 XE, haga lo siguiente:

    $ . /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_env.sh

Con Oracle 11gR2 XE:

    $ . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

Para otras versiones de la base de datos de Oracle, haga:

    $ . /usr/local/bin/oraenv

Algunas shells requieren que php.ini contenga E en el parámetro variables_order, por ejemplo:

    variables_order = "EGPCS"

Ejecute todas las pruebas de PHP con:

    $ cd your_php_src_directory
    $ make test
o ejecute únicamente las pruebas de OCI8 con
    $ cd your_php_src_directory
    $ make test TESTS=ext/oci8

Cuando hayan finalizado las pruebas, revise cualquier fallo. En sistemas lentos, algunas pruebas podrían tomar más tiempo que el tiempo de espera de prueba predeterminado de run-tests.php. Para corregir esto, establezca la variable de entorno TEST_TIMEOUT a un número mayor de segundos.

En máquinas rápidas con una base de datos local configurada para una carga ligera (p.ej. Oracle 11gR2 XE), algunas pruebas podrían ocasionar los errores ORA-12516 u ORA-12520. Para evitarlo, aumente el parámetro PROCESSES de la base de datos siguiendo estos pasos:

Conéctese como propietario del software de Oracle:

    $ su - oracle

Establezca el entorno de Oracle necesario con oracle_env.sh u oraenv, tal como está descrito arriba.

Inicie la herramienta de línea de comandos SQL*Plus y aumente PROCESSES

    $ sqlplus / as sysdba
    SQL> alter system set processes=100 scope=spfile

Reinicie la base de datos:

    SQL> startup force


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de OCI8
Nombre | Por defecto | Cambiable | Historial de cambios
oci8.connection_class | "" | PHP_INI_ALL | Disponible desde PHP 5.3 (PECL OCI8 1.3).
oci8.default_prefetch | "100" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.events | Off | PHP_INI_SYSTEM | Disponible desde PHP 5.3 (PECL OCI8 1.3).
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.old_oci_close_semantics | Off | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.ping_interval | "60" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.privileged_connect | Off | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.2 (PECL OCI8 1.1).

He aquí una breve explicación de las directivas de configuración.

oci8.connection_class string

Este texto definido por el usuario es utilizado por las conexiones de Oracle 11g Database Resident Connection Pooling (DRCP) para subparticionar la agrupación de conexiones. Permite conexiones persistentes de OCI8 desde una aplicación para reutilizar las sesiones de la base de datos de un script anterior de PHP, proporcionando una mejor escalabilidad. Cuando una aplicación usa un proceso de una agrupación de una base de datos anteriormente usado con una clase de conexión diferente, las configuraciones de sesión, tales como el formato de fecha predeterminado de Oracle, son reiniciadas. Esto previene de la compartición accidental de información entre diferentes aplicaciones.

El valor puede establecerse en tiempo de ejecución con ini_set() entes de la conexión.

Para usar DRCP, OCI8 debe vincularse con las bibliotecas de Oracle 11g, y la base de datos debe ser Oracle 11g. La agrupación de conexiones debe habilitarse en la base de datos, oci8.connection_class debería establecerse a la misma cadena para todos los servidores web que ejecuten la misma aplicación, y la cadena de conexión de OCI8 debe especificar el suo de un servidor de la agrupación.

oci8.default_prefetch int

Esta opción establece el número predeterminado de filas extra que se obtendrán y almacenarán en caché automáticamente siempre que se haga una petición de bajo nivel para datos de la base de datos. Establecer un valor de 0 desactiva la precarga.

El valor de la precarga no altera el número de filas que son devueltas al usuario por funciones como oci_fetch_array(); la precarga y el almacenamiento en caché de filas son manejados internamente por OCI8.

El valor puede ser establecido para cada sentencia con oci_set_prefetch() antes de la ejecución de dicha sentencia.

En PHP 5.3 (PECL OCI8 1.3.4), el valor predeterminado estaba aumentado desde 10 hasta 100.

En PHP 5.3.2 (PECL OCI8 1.4), el valor mínimo establecible estaba reducido desde 1 hasta 0, permitiendo la que precarga se desactivara.

Al usar Oracle Database 12c, el valor de precarga establecido por PHP puede ser sobrescrito por el fichero de configuración del cliente oraaccess.xml de Oracle. Consulte la documentación de Oracle para más detalles.

Nota: Un valor de precarga más alto puede mejorar el rendimiento, con el coste del aumento del uso de memoria. Para consultas que devuelven gran cantidad de datos, el beneficio del rendimiento puede ser significativo.

oci8.events boolean

Usar On permite que PHP sea informado de los eventos Fast Application Notification (FAN) de la base de datos.

Sin FAN, cuando una instancia de una base de datos o un nodo de una máquina fallan de forma impredecible, las aplicaciones de PHP podrían bloquearse esperando una respuesta de la base de datos hasta que el tiempo de espera de TCP expire. Con los eventos FAN, las aplicaciones de PHP son informadas rápidamente de fallos que afectan a sus conexiones de bases de datos establecidas. La extensión OCI8 limpiará las conexiones inservibles de la caché de conexiones persistentes.

Cuando se usa On, la base de datos debe también estar configurada para enviar eventos FAN.

El soporte para FAN está disponible cuando OCI8 está vinculada con la biblioteca de Oracle 10gR2 (o posterior) y conectada con Oracle Database 10gR2 (o posterior).

oci8.max_persistent int

El número máximo de conexiones persistentes de OCI8 por proceso de PHP. Establecer esta opción a -1 significa que no existe límite.

oci8.old_oci_close_semantics boolean

Esta opción controla el comportamiento de oci_close(). Habilitarla significa que oci_close() no hará nada; la conexión no será cerrada hasta que finalice el script. Esto es debido únicamente por razones de retrocompatibilidad. Si fuera necesario habilitar esta opción, se recomienda encarecidamente ajustar las llamadas de oci_close() en la aplicación en lugar de habilitar esta opción.

oci8.persistent_timeout int

El número máximo de segundos que a un proceso de PHP se le permite mantener una conexión persistente inactiva abierta. Establecer esta opción a -1 significa que las conexiones persistentes inactivas serán retenidas hasta que el proceso de PHP finalice o la conexión sea explícitamente cerrada con oci_close().

Nota: En PHP, la caducidad de los recursos inactivos no está basada en alarmas. Esto ocurre cuando PHP termina de procesar un script y de comprobar la marca de tiempo del último recurso utilizado. Por lo tanto, existe una paradoja donde las conexiones inactivas solamente son cerradas cuando hay alguna actividad (aunque no necesariamente relacionada con OCI8) en el proceso de PHP. Si hay más de un proceso de PHP, cada uno debe ser activado individualmente para desencadenar la caducidad de sus recursos inactivos. La introducción de Database Resident Connection Pooling (DRCP) en Oracle 11g resuleve los problmas de memoria y de recursos que oci8.max_persistent y oci8.persistent_timeout intentaron superar anteriormente.

Nota: En PHP 5.3 (PECL OCI8 1.3), las conexiones persistentes pueden ser cerradas con oci_close().

oci8.ping_interval int

El número de segundos que deben transcurrir antes de emitir un ping durante la ejecución de oci_pconnect(). Un ping se asegura de que la conexión de la base de datos es válida. Cuando se establece a 0, las conexiones persistentes serán comprobadas cada vez que se llame a oci_pconnect(). Para deshabilitar estas comprobaciones completamente, se ha de establecer esta opción a -1.

Nota: La deshabilitación de las comprobaciones permite a oci_pconnect() operar con la mayor eficiencia, aunque PHP podría no ser capaz de detectar conexiones inutilizables, como las causadas por la caída de la red, o si la base de datos de Oracle se ha venido abajo mientras PHP sigue conectado, hasta que la conexión se use después en el script. Consulte la documentación de oci_pconnect() para más información.

oci8.privileged_connect boolean

Esta opción permite que las conexiones usen las credenciales privilegiadas externas OCI_SYSOPER u OCI_SYSDBA.

Nota: El establecerla a On puede permitir a los scripts de servidores web, ejecutados con los privilegios apropiados del SO, conectarse como usuarios privilegiados de la base de datos sin requerir una contraseña de la misma. Esto puede ser un riesgo para la seguridad.

oci8.statement_cache_size int

Esta opción habilita el almacenamiento en caché de sentencias, y especifica cuántas almacenar. Para deshabilitar dicho almacenamiento se ha de establecer esta opción a 0.

El almacenamiento en caché de sentencias elimina la necesidad de transmitir el texto de las mismas a la base de datos y la necesidad de volver a transmitir cualquier metadato sobre dichas sententencias a PHP. Esto puede mejorar significativamente el rendimiento global del sistema en aplicaciones que reutilicen sentencias durante el tiempo de vida de una conexión. Algunos "cursores" extra de la base de datos podrían manetenerse abiertos bajo el supuesto de que las sentencias serán reutilizadas.

Establezca este valor al tamaño del conjunto de trabajo de sentencias usadas por la aplicación. Establcer un valor demasiado pequeño puede causar que se vacíen de la caché dichas sentencias antes de que sean reutilizadas.

Esta opción se usa mayormente con conexiones persistentes.

Al usar Oracle Database 12c, este valor puede ser sobrescrito y ajustado automáticamente por el fichero de del cliente oraaccess.xml de Oracle. Consulte la documentación de Oracle para más detalles.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Modos de funciones y métodos de OCI8
Constante | Descripción
OCI_ASSOC | Usada con oci_fetch_all() y con oci_fetch_array() para obtener los resultados como un array asociativo.
OCI_BOTH | Usada con oci_fetch_all() y con oci_fetch_array() para obtener los resultados como un array con índeces tanto asociativos como numéricos.
OCI_COMMIT_ON_SUCCESS | El modo de ejecución de sentencias para oci_execute(). Automáticamente consolida los cambios cuando la sentencia ha tenido éxito.
OCI_CRED_EXT | Usada con oci_connect() para utilizar la autenticación externa de Oracle o la del SO. Introducida en PHP 5.3 y PECL OCI8 1.3.4.
OCI_DEFAULT | Véase OCI_NO_AUTO_COMMIT.
OCI_DESCRIBE_ONLY | Modo de ejecución de sentencias para oci_execute(). Se ha de usar este modo si se quieren obtener metadatos tales como los nombres de las columnas, pero no se desea obtener filas de la consulta.
OCI_EXACT_FETCH | Obsoleta. El modo de obtención de sentencias. Usada cuando la aplicación conoce de antemano exactamente cuántas filas se obtendrán. Este modo desactiva la precarga del modo de Oracle versión 8 o posterior. El cursor es cancelado después de obtener las filas deseadas, lo que puede reducir el uso de recursos por parte del servidor.
OCI_FETCHSTATEMENT_BY_COLUMN | Modo predetermiado de oci_fetch_all().
OCI_FETCHSTATEMENT_BY_ROW | Modo alternativo de oci_fetch_all().
OCI_LOB_BUFFER_FREE | Usada con OCI-Lob::flush para liberar los búferes utilzados.
OCI_NO_AUTO_COMMIT | Modo de ejecución de sentencias para oci_execute(). La transacción no se consolida automáticamente cuando se usa este modo. Para una mejor legibilidad en código nuevo, use este valor en lugar de la cosntante antigua y equivalente OCI_DEFAULT. Introducida en PHP 5.3.2 (PECL OCI8 1.4).
OCI_NUM | Usada con oci_fetch_all() y con oci_fetch_array() para obtener los resultados como un array enumerado.
OCI_RETURN_LOBS | Usada con oci_fetch_array() para obtener el valor de los datos del LOB en lugar del descriptor.
OCI_RETURN_NULLS | Usada con oci_fetch_array() para obtener elementos de array vacíos si el valor de los elementos de la fila es null.
OCI_SEEK_CUR | Usada con OCI-Lob::seek para establecer la posición de búsqueda.
OCI_SEEK_END | Usada con OCI-Lob::seek para establecer la posición de búsqueda.
OCI_SEEK_SET | Usada con OCI-Lob::seek para establecer la posición de búsqueda.
OCI_SYSDATE | Obsoleta.
OCI_SYSDBA | Usada con oci_connect() para conectarse con el privilegio SYSDBA. El ajuste de php.ini oci8.privileged_connect debería estar habilitado para poder usar esta constante.
OCI_SYSOPER | Usada con oci_connect() para conectarse con el privilegio SYSOPER. El ajuste de php.ini oci8.privileged_connect debería estar habilitado para poder usar esta constante.
OCI_TEMP_BLOB | Usada con OCI-Lob::writeTemporary para indicar que debería crearse un BLOB temporal.
OCI_TEMP_CLOB | Usada con OCI-Lob::writeTemporary para indicar que debería crearse un CLOB temporal.
Tipos vinculados y definidos de OCI8
Constante | Descripción
OCI_B_BFILE | Usada con oci_bind_by_name() cuando se vinculan BFILEs.
OCI_B_BIN | Usada con oci_bind_by_name() para vincular valores RAW.
OCI_B_BLOB | Usada con oci_bind_by_name() cuando se vinculan BLOBs.
OCI_B_BOL | Usada con oci_bind_by_name() para vincular una variable BOOLEAN de PL/SQL.
OCI_B_CFILEE | Usada con oci_bind_by_name() cuando se vinculan CFILEs.
OCI_B_CLOB | Usada con oci_bind_by_name() cuando se vinculan CLOBs.
OCI_B_CURSOR | Usada con oci_bind_by_name() cuando se vinculan cursores, previamente asignados con oci_new_descriptor().
OCI_B_INT | Usada con oci_bind_array_by_name() para vincular arrays de tipo INTEGER.
OCI_B_NTY | Usada con oci_bind_by_name() cuando se vinculan tipos de datos con nombre. Nota: en PHP < 5.0 se le denominaba OCI_B_SQLT_NTY.
OCI_B_NUM | Usada con oci_bind_array_by_name() para vincular arrays de tipo NUMBER.
OCI_B_ROWID | Usada con oci_bind_by_name() cuando se vinculan ROWIDs.
SQLT_AFC | Usada con oci_bind_array_by_name() para vincular arrays de tipo CHAR.
SQLT_AVC | Usada con oci_bind_array_by_name() para vincular arrays de tipo VARCHAR2.
SQLT_BDOUBLE | No soportada.
SQLT_BFILEE | Lo mismo que OCI_B_BFILE.
SQLT_BFLOAT | No soportada.
SQLT_BIN | Lo mismo que OCI_B_BIN.
SQLT_BLOB | Lo mismo que OCI_B_BLOB.
SQLT_BOL | Lo mismo que OCI_B_BOL.
SQLT_CFILEE | Lo mismo que OCI_B_CFILEE.
SQLT_CHR | Usada con oci_bind_array_by_name() para vincular arrays de tipo VARCHAR2. También se usa con oci_bind_by_name().
SQLT_CLOB | Lo mismo que OCI_B_CLOB.
SQLT_FLT | Usada con oci_bind_array_by_name() para vincular arrays de tipo FLOAT.
SQLT_INT | Lo mismo que OCI_B_INT.
SQLT_LBI | Usada con oci_bind_by_name() para vincular valores LONG RAW.
SQLT_LNG | Usada conoci_bind_by_name() para vincular valores LONG.
SQLT_LVC | Usada con oci_bind_array_by_name() para vincular arrays de tipo LONG VARCHAR.
SQLT_NTY | Lo mismo que OCI_B_NTY.
SQLT_NUM | Lo mismo que OCI_B_NUM.
SQLT_ODT | Usada con oci_bind_array_by_name() para vincular arrays de tipo LONG.
SQLT_RDD | Lo mismo que OCI_B_ROWID.
SQLT_RSET | Lo mismo que OCI_B_CURSOR.
SQLT_STR | Usada con oci_bind_array_by_name() para vincular arrays de tipo STRING.
SQLT_UIN | No soportada.
SQLT_VCS | Usada con oci_bind_array_by_name() para vincular arrays de tipo VARCHAR.
Tipos de descriptores de OCI8
Constante | Descripción
OCI_DTYPE_FILE | Esta bandera indica a oci_new_descriptor() que inicialice un nuevo descriptor FILE.
OCI_DTYPE_LOB | Esta bandera indica a oci_new_descriptor() que inicialice un nuevo descriptor LOB.
OCI_DTYPE_ROWID | Esta bandera indica a oci_new_descriptor() que inicialice un nuevo descriptor ROWID.
OCI_D_FILE | Lo mismo que OCI_DTYPE_FILE.
OCI_D_LOB | Lo mismo que OCI_DTYPE_LOB.
OCI_D_ROWID | Lo mismo que OCI_DTYPE_ROWID.


Ejemplos

En estos ejemplos se realiza la conexión con el usuario HR, que es el esquema de ejemplo "Human Resources" proporcionado con la base de datos Oracle. Podría ser necesario desbloquear la cuenta y reiniciar la contraseña antes de poder usarla.

Los ejemplos se conectan a la base de datos XE de su máquina. Cambie la cadena de conexión a su base de datos antes de ejecutar los ejemplos.

Ejemplo #1 Consulta básica

Este ejemplo muestra la realización de consultas y la visualización de resultados. Las sentencias en OCI8 usan la secuencia de pasos 'preparación-ejecución-obtención'.

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Preparar la sentencia
$stid = oci_parse($conexión, 'SELECT * FROM departments');
if (!$stid) {
    $e = oci_error($conexión);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Realizar la lógica de la consulta
$r = oci_execute($stid);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Obtener los resultados de la consulta
print "<table border='1'>\n";
while ($fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    print "<tr>\n";
    foreach ($fila as $elemento) {
        print "    <td>" . ($elemento !== null ? htmlentities($elemento, ENT_QUOTES) : "") . "</td>\n";
    }
    print "</tr>\n";
}
print "</table>\n";

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #2 Inserción con variables vinculadas

Las variables vinculadas mejoran el rendimiento permitiendo la reutilización de contextos ejecutados y cachés. Las variables vinculadas mejoran la seguridad previniendo algunos tipos de problemas de Inyecciones SQL.

<?php

// Antes de ejecutarlo, cree la tabla:
//   CREATE TABLE MYTABLE (mid NUMBER, myd VARCHAR2(20));

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conexión, 'INSERT INTO MYTABLE (mid, myd) VALUES(:myid, :mydata)');

$id = 60;
$datos = 'Algunos datos';

oci_bind_by_name($stid, ':myid', $id);
oci_bind_by_name($stid, ':mydata', $datos);

$r = oci_execute($stid);  // ejecuta y consigna

if ($r) {
    print "Una fila insertada";
}

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #3 Vincular la cláusula WHERE a una consulta

Lo siguiente muestra una vinculación escalar única.

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conn, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// La salida es
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #4 Insertar datos en una columna CLOB

Para datos grandes use los tipos objeto grande binario (BLOB) u objeto grande de caracteres (CLOB). Este ejemplo usa CLOB.

<?php

// Antes de ejecutarlo, cree la tabla:
//     CREATE TABLE MYTABLE (mykey NUMBER, myclob CLOB);

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$mykey = 12343;  // clave arbitraria para este ejemplo;

$sql = "INSERT INTO mytable (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conexión, $sql);
$clob = oci_new_descriptor($conexión, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_NO_AUTO_COMMIT); // utilice OCI_DEFAULT para PHP <= 5.3.1
$clob->save("Una cadena muy grande");

oci_commit($conexión);

// Obtener los datos CLOB

$consulta = 'SELECT myclob FROM mytable WHERE mykey = :mykey';

$stid = oci_parse ($conexión, $consulta);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$row['MYCLOB'].'</td></tr>';
    // En un bucle, liberar la variable grande antes de la 2ª obtención reduce el uso de memoria de picos de PHP
    unset($row);
}
print '</table>';

?>

Ejemplo #5 Usar una función almacenada de PL/SQL

Se debe vincular una variable para el valor de retorno y, opcionalmente, para cualquier argumento de la función de PL/SQL.

<?php

/*
  Antes de ejecutar el programa de PHP, cree una función almacenada en
  SQL*Plus o SQL Developer:

  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
  BEGIN
      RETURN p * 3;
  END;

*/

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conexión, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // imprime 24

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #6 Utilizar un procedimiento almacenado de PL/SQL

Con los procedimientos almacenados se deberían vincular variables para cualquier argumento.

<?php

/*
  Antes de ejecutar el programa de PHP, cree un procedimiento almacenado en
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
  BEGIN
      p2 := p1 * 2;
  END;

*/

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conexión, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // imprime 16

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #7 Llamar a una función de PL/SQL que devuelve un REF CURSOR

Cada valor devuelto por la consulta es un REF CURSOR desde el que se pueden obtener datos.

<?php
/*
  Cree una función almacenada de PL/SQL como:

  CREATE OR REPLACE FUNCTION myfunc(p1 IN NUMBER) RETURN SYS_REFCURSOR AS
      rc SYS_REFCURSOR;
  BEGIN
      OPEN rc FOR SELECT city FROM locations WHERE ROWNUM < p1;
      RETURN rc;
  END;
*/

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conexión, 'SELECT myfunc(5) AS mfrc FROM dual');
oci_execute($stid);

echo "<table border='1'>\n";
while (($fila = oci_fetch_array($stid, OCI_ASSOC))) {
    echo "<tr>\n";
    $rc = $fila['MFRC'];
    oci_execute($rc);  // el valor de la columna devuelta por la consulta es un ref cursor
    while (($fila_rc = oci_fetch_array($rc, OCI_ASSOC))) {
        echo "    <td>" . $fila_rc['CITY'] . "</td>\n";
    }
    oci_free_statement($rc);
    echo "</tr>\n";
}
echo "</table>\n";

// La salida es:
//   Beijing
//   Bern
//   Bombay
//   Geneva

oci_free_statement($stid);
oci_close($conexión);

?>


Manejo de conexiones de OCI8 y agrupamiento de conexiones

Funciones de conexión

La extenisón OCI8 proporciona tres funciones diferentes para conectarse a Oracle. La función de conexión estándar es oci_connect(). Esta crea una conexión a una base de datos de Oracle y devuelve un recurso utilizado por las llamadas subsiguientes a dicha base de datos.

Conectarse a un servidor Oracle es una operación razonablemente cara en términos del tiempo que toma en completarse. La función oci_pconnect() utiliza una caché de conexiones persistentes que puede ser reutilizada a través de diferentes peticiones de scripts. Esto significa que una conexión únicamente tendrá carga adicional normalmente una vez por cada proceso de PHP (o subproceso de Apache).

Si una aplicación se conecta a Oracle usando un conjunto diferente de credenciales para cada usuario de la web, la caché persistente empleada por oci_pconnect() no será muy útil ya que el número de usuarios concurrentes aumentará, hasta el punto donde podría empezar a afectar negativamente al rendimiendo global del servidor de Oracle debido a que mantiene demasiadas conexiones inactivas. Si la aplicación está estructurada de esta manera, se recomienda ajustarla a través de las opciones de configuración oci8.max_persistent y oci8.persistent_timeout (éstas otorgan control sobre el tamaño y el tiempo de vida de la caché de conexiones persistentes), usar Oracle Database Resident Connection Pooling (en Oracle Database 11g o posterior), o usar oci_connect() en su lugar.

oci_connect() y oci_pconnect() emplean una caché de conexiones; si mútiples llamadas a oci_connect() usan los mismos parámetros en un script dado, la segunda y subsiguientes llamadas devolverán el gestor de conexión existente. La caché usada por oci_connect() se limpia al final de la ejecución del script, o cuando se cierra explícitamente el gestor de conexión. La función oci_pconnect() tiene un comportamiento similar, aunque su caché se mantiene de forma separada y sobrevive entre peticiones HTTP.

Esta característica de almacenamiento en caché significa que dos gestores no están transaccionalmente aislados (de hecho, son el mismo gestor de conexión, por lo que no existe aislamiento alguno). Si la aplicación necesita dos conexiones transaccionalmente aisladas por separado, se ha de usar oci_new_connect().

La caché de oci_pconnect() es limpiada y cualquier conexión a bases de datos cerrada cuando finaliza el proceso de PHP, por lo que el uso efectivo de conexiones persistentes requiere que PHP sea un módulo de Apache o se use con FCGI, o similar. Las conexiones persistentes no tendrán ningún beneficio con oci_connect() cuando PHP se use con CGI o mediante la línea de comandos.

La función oci_new_connect() siempre crea una nueva conexión al servidor de Oracle, independientemente de que existan otras conexiones. Las aplicaciones web con mucho tráfico deberían evitar el uso de oci_new_connect(), especialmente las secciones más concurridas de la aplicación.

Agrupamiento de conexiones DRCP

PHP, desde 5.3 (PECL OCI8 1.3), posee soporte para Oracle Database Resident Connection Pooling (DRCP). DRCP permite el uso más eficiente de la memoria de la máquina donde reside la base de datos y proporciona una alta escalabilidad. Se requiren cambios mínimos, o ninguno, en la aplicación para usar DRCP.

DRCP es apropiado para aplicaciones que se conectan usando pocos esquemas de bases de datos y mantienen abiertas dichas conexiones durante un corto periodo de tiempo. Las demás aplicaciones deberían usar los procesos de servidor de bases de datos predeterminado Dedicado de Oracle, o usar servidores Compartidos.

DRCP beneficia a las tres funciones de conexión, pero proporciona la mayor escalabilidad cuando las conexiones se crean con oci_pconnect().

Para que DRCP esté disponible en OCI8, las bibliotecas cliente de Oracle usadas por PHP y la versión de Oracle Database deben ser 11g o superior.

La documentación de DRCP se encuentra en varios manuales de Oracle. Por ejemplo, véase » Configuring Database Resident Connection Pooling en la documentación de Oracle para obtner información de su uso. Un » Libro blanco de DRCP contiene información de antecedentes sobre DRCP.

Para usar DRCP, construya PHP con la extensión OCI8 1.3 (o posterior) y las bibliotecas de Oracle 11g (o posteriores), y luego siga estos pasos:

  • Como administrador de bases de datos privilegiado, use un programa como SQL*Plus para iniciar el agrupamiento de conexiones en la base de datos:

        SQL> execute dbms_connection_pool.start_pool;

  • Opcionalmente use dbms_connection_pool.alter_param() para configurar los ajustes de DRCP. La configuración de la agrupación actual se puede consultar desde la vista DBA_CPOOL_INFO.

  • Actualice las cadenas de conexión usadas. Para las aplicaciones de PHP que actualmente se conecten usando un Nombre de Conexión de Red como MYDB:

        $c = oci_pconnect("mi_usuario", "mi_contraseña", "MYDB");

    Modifique el fichero tnsnames.ora y añada una cláusula (SERVER=POOLED), por ejemplo:

        MYDB = (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp) (HOST=myhost.dom.com)
           (PORT=1521))(CONNECT_DATA=(SERVICE_NAME=sales)
           (SERVER=POOLED)))

    Alternativamente, modifique la sintaxis de Easy Connect en PHP y añada :POOLED después del nombre del servidor:

        $c = oci_pconnect("mi_usuario", "mi_contraseña", "mi_host.dom.com:1521/sales:POOLED");

  • Edite php.ini y elija un nombre de clase de conexión. Este nombre señala una división lógica de la agrupación de conexiones y se puede usar para aislar la agrupación para diferentes aplicaciones. Cualquier aplicación de PHP con el mismo nombre de usuario y valor de clase de conexión podrá compartir conexiones de la agrupación, proporcionando una mayor escalabilidad.

        oci8.connection_class = "NOMBRE_DE_MI_APLICACIÓN"

  • Ejecute la aplicación, conectándose a la base de datos 11g (o posterior).

Nota:

Las aplicaciones que usen Oracle 10g que requieran el rendimiento de conexiones persitentes, pueden reducir la cantidad de memoria que el servidor de bases de datos use utilizando sevidores Compartidos de Oracle (anteriormente conocidos como Servidores de Multisubprocesos). Consulte la documentación de Oracle para más información.

Recomendaciones para DRCP y limitaciones conocidas

El cambio de una contraseña con conexiones DRCP fallará con el error ORA-56609: Usage not supported with DRCP. Ésta es una restricción documentada de Oracle Database 11g.

Con la extensión OCI8 1.3, las conexiones persistentas pueden ser cerradas por el usuario, permitiendo mayor control sobre el uso de recursos de conexión. Las conexiones persistentes ahora también serán cerradas automáticamente cuando no haya variables de PHP que hagan referncia a ellas, como al final del ámbito de una función de usuario de PHP. Esto revertirá cualquier transacción no consignada. Estos cambios a las conexiones persistentes hacen que se comporten de forma similar a las conexiones no persistentes, simplificando la interfaz, permitiendo así mayor consistencia y predictabilidad a las aplicaciones. Use oci8.old_oci_close_semantics con el valor de On para conservar el comportamiento histórico.

Si Oracle Database es la versión 11.1.0.6, se deben aplicar los parches de las bases de datos de Oracle para el error 6474441 de Oracle para usar DRCP. Sin este parche, los errores como ORA-01000: maximum open cursors exceeded, ORA-01001 invalid cursor o ORA-01002 fetch out of sequence podrían ocurrir. Este error fue corregido en Oracle 11.1.0.7 en adelante.

Si no se puede aplicar el parche de las bases de datos de Oracle 11.1.0.6, se pueden seguir una de estas tres alternativas en su lugar:

  • Conectarse usando servidores de Oracle Dedicados o Compartidos en lugar de DRCP.
  • Establecer oci8.statement_cache_size de PHP a 0.
  • Establecer un evento en el fichero de parámetros de inicialización de bases de datos: event="56699 trace name context forever, level 128".

Los parches Oracle Database 11.1.0.7 y Oracle Database 11.1.0.6 para el error 6474441 de Oracle permiten a las aplicacinones de PHP con conexión DRCP usar el disparador LOGON de la base de datos para establecer las propiedades de una sesión en el momento de crearla. Ejemplo de tales configuraciones son el lenguaje NLS y el formato de fecha.

Si no se puede aplicar el parche para bases de datos Oracle 11.1.0.6, se pueden seguir las siguientes alternativas en lugar de usar los disparadores LOGON:

  • Después de la identificación, establecer explícitamente las propiedades de la sesión usando código de la aplicación de PHP.
  • Conectarse usando servidores de Oracle Dedicados o Compartidos en lugar de DRCP.

El reestableciemiento automático de las conexiones persistentes de PHP después de la regeneración de procesos de Apache o FCGI significa que únicamente se recomiendan los disparadores LOGON de PHP para establecer los atributos de sesiones y no para peticiones de conexiones de usuario por cada aplicación. Esto es incluso más recomendado con DRCP debido al ajuste automático de la agrupación y a la manera de desencadenar los disparadores LOGON con la autenticación de DRCP.


OCI8 Fast Application Notification (FAN) Support

Soporte para Fast Application Notification (FAN)

El soporte para FAN proporciona tolerancia a fallos rápida para conexiones, una característica de alta disponibilidad de Oracle Database. Permite que los scripts de OCI8 para PHP sean informados cuando una máquina o una instancia de una base de datos no esté disponible. Sin FAN, OCI8 puede suspenderse hasta que se agote el tiempo de espera de TCP, lo que devolvería un error que podría llevar varios minutos en emitirse. La habilitación de FAN en OCI8 puede hacer que las aplicaciones detecten errores y se reconecten a una instancia de bases de datos disponbile sin que el usuario web note ningún corte.

El soporte para FAN está disponible cuando las bibliotecas cliente de Oracle que PHP vincule con Oracle Database sean la versión 10gR2 o posterior.

FAN beneficia a los usuarios de la tecnología del uso de clúster de Oracle (RAC) debido a que se pueden realizar de forma inmediata conexiones a instancias de bases de datos supervivientes. Los usarios de Oracle's Data Guard con un agente verán los eventos de FAN generados cuando una base de datos en espera vuelva a estar en línea. Las bases de datos independientes enviarán eventos FAN cuando se reinicien.

Para conexiones activas, cuando una máquina o una instancia de bases de datos no esté disponible, la función de la extensión OCI8 que está siendo llamada devolverá un error de fallo de conexión. En una reconexión subsiguiente de un script de PHP, se establecerá una conexión a una instancia de una base de datos superviviente. La extensión OCI8 también limpia de forma transparente cualquier conexión inactiva afectafa por un fallo de una máquina o instancia de base de datos, por lo que la conexión de PHP establecerá una conexión fresca sin que el script note ninguna interrupción del servicio.

Cuando el valor de oci8.events es On, se sugiere establecer oci8.ping_interval a -1 para deshabilitar la comprobación de la conexión, ya que al habilitar los eventos de FAN se proporciona una gestión de conexiones proactivas de conexiones inactivas invalidadas por la interrupción de un servicio.

Para habilitar el soporte de FAN en PHP, construya PHP con las bibliotecas 10gR2 o posteriores de Oracle y siga estos pasos:

  • Como administrador de bases de datos con privilegios, use un programa como SQL*Plus para habilitar el servicio de bases de datos para enviar enventos FAN, por ejemplo:

        SQL> execute dbms_service.modify_service(
                   SERVICE_NAME        => 'sales',
                   AQ_HA_NOTIFICATIONS => TRUE);

  • Edite php.ini y agregue

        oci8.events = On

  • Si la aplicación aún no gestiona las condiciones de error de OCI8, modifíquela para que detecte fallos y tome las acciones apropiadas. Esto prodría incluir la reconexión y la reejecución de sentencias.
  • Ejecute la aplicación, conecte a una base de datos de Oracle 10gR2 o posterior.


Soporte para 'Transparent Application Failover' (TAF) de OCI8

TAF is an Oracle Database feature that provides high availability. It enables PHP OCI8 applications to automatically reconnect to a preconfigured database when database connectivity fails due to instance or network failure.

In a configured Oracle Database system, TAF occurs when the PHP application detects that the database instance is down or unreachable. It establishes a connection to another node in an Oracle » RAC configuration, a hot standby database, or the same database instance itself. See » Oracle Call Interface Programmer's Guide for more information about OCI TAF.

An application callback can be registered. During failover, normal application processing stops and the registered callback is invoked. The callback notifies the application of the failover events. If the failover succeeds, normal processing will be resumed. If the failover aborts, any following database operations in the application will fail due to no connection being available. See more details about TAF callbacks in Using TAF Callbacks in OCI8 section.

When a connection fails over to another database, the callback can reset any necessary connection state, for example replaying any necessary ALTER SESSION commands if the database service did not have -failover_restore enabled.

Configuring Transparent Application Failover

TAF can be configured on the PHP OCI8 side or in the database configuration. If both are configured, database-side settings take precedence.

Configure TAF in PHP OCI8 (the client side) by including the FAILOVER_MODE parameter in the CONNECT_DATA portion of a connect descriptor. See Configuring Transparent Application Failover in » Oracle Database Net Services Administrator's Guide for more information about client side configuration of TAF.

An example tnsnames.ora to configure TAF reconnecting to the same database instance:

    ORCL =
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
        (CONNECT_DATA =
          (SERVICE_NAME = orcl)
          (FAILOVER_MODE =
            (TYPE = SELECT)
            (METHOD = BASIC)
            (RETRIES = 20)
            (DELAY = 15))))

Alternatively configure TAF on the database side by modifying the target service with » srvctl (for RAC) or the » DBMS_SERVICE.MODIFY_SERVICE packaged procedure (for single instance databases).

Using TAF Callbacks in OCI8

A TAF callback is an application function that can be registered to be called during failover. It is called several times while re-establishing the application's connection.

Callback first occurs when a loss of connection is detected. This allows the application to act accordingly for the upcoming delay of the failover. If the failover is successful, the callback is invoked after connection is re-established and usable. At this time, the application can resynchronize session settings and take actions such as informing the user that failover occurred. If failover is unsuccessful, a callback occurs to inform the application that a failover did not take place and the connection is unusable.

The interface of a TAF user-defined callback function is as follows:

userCallbackFn ( resource $connection , int $event , int $type ) : int

connection

The Oracle connection on which the TAF callback was registered via oci_register_taf_callback(). The connection is not valid until the failover completes successfully.

event

The failover event indicates the current status of the failover.

  • OCI_FO_BEGIN indicates that failover has detected a lost connection and failover is starting.

  • OCI_FO_END indicates successful completion of failover.

  • OCI_FO_ABORT indicates that failover was unsuccessful, and there is no option of retrying.

  • OCI_FO_ERROR also indicates that failover was unsuccessful, but it gives the application the opportunity to handle the error and return OCI_FO_RETRY to retry failover.

  • OCI_FO_REAUTH indicates that an Oracle user has been re-authenticated.

type

The failover type. This lets the callback know what type of failover the application has requested. The usual values are as follows:

  • OCI_FO_SESSION indicates that the user has requested only session failover. For example, if a user's connection is lost, then a new session is automatically created for the user on the backup. This type of failover does not attempt to recover SELECTs.

  • OCI_FO_SELECT indicates that the user has requested SELECT failover as well. It allows users with open cursors to continue fetching from them after failure.

return value

  • 0 indicates the failover steps should continue normally.

  • OCI_FO_RETRY indicates that the failover should be attempted again by Oracle. In case of an error while failing over to a new connection, TAF is able to retry the failover. Typically, the application code should sleep for a while before returning OCI_FO_RETRY.

The following example registers a TAF callback

<?php

// Define userspace callback
class MyClass {
    public static $retry_count;
    public static function TAFCallback($conn, $event, $type)
    {
        switch ($event) {
            case OCI_FO_BEGIN:
                printf(" Failing Over ... Please stand by");
                printf(" Failover type was found to be %s \n",
                       (($type==OCI_FO_SESSION) ? "SESSION"
                        :($type==OCI_FO_SELECT) ? "SELECT"
                        : "UNKNOWN!"));
                self::$retry_count = 0;
                break;
            case OCI_FO_ABORT:
                // The application cannot continue using the database
                printf(" Failover aborted. Failover will not take place.\n");
                break;
            case OCI_FO_END:
                // Failover completes successfully. Inform users a failover occurs.
                printf(" Failover ended ... resuming services\n");
                break;
            case OCI_FO_REAUTH:
                printf(" Failed over user ... resuming services\n");
                // Replay any ALTER SESSION commands associated with this connection
                // eg. oci_parse($conn, ‘ALTER SESSION …’) ;
                break;
            case OCI_FO_ERROR:
                // Stop retrying if we have already attempted for 20 times.
                if (self::$retry_count >= 20)
                    return 0;
                printf(" Failover error received. Sleeping...\n");
                sleep(10);
                self::$retry_count++;
                return OCI_FO_RETRY; // retry failover
                break;
            default:
                printf("Bad Failover Event: %d.\n", $event);
                break;
        }
        return 0;
    }
}

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
$fn_name = 'MyClass::TAFCallback';

oci_register_taf_callback($conn, $fn_name); // Register TAFCallback to Oracle TAF

$sql = "SELECT col1 FROM mytab";
$stmt = oci_parse($conn, $sql);
oci_define_by_name($stmt, 'COL1', $col1);

// For example, if a connection loss occurs at this point, oci_execute() will
// detect the loss and failover begins. During failover, oci_execute() will
// invoke the TAF callback function several times. If the failover is successful,
// a new connection is transparently created and oci_execute() will continue as
// usual. The connection session settings can be reset in the TAF callback
// function. If the failover is aborted, oci_execute() will return an error
// because a valid connection is not available.

$e = oci_execute($stmt);
if ($e == false)
{
    // do error handling, if oci_execute() fails
    // var_dump(oci_error($stmt));
}
while (oci_fetch($stmt))
{
    echo "COL1 value is $col1<br>\n";
}

// do other SQL statements with the new connection, if it is valid
// $stmt = oci_parse($conn,  . . .);

?>

Also see the usage of oci_register_taf_callback() and oci_disable_taf_callback().


OCI8 y rastreo dinámico de DTrace

OCI8 2.0 sondeos de DTrace estáticos que se pueden usar en sistemas operativos que admiten DTrace. Véase Rastreo dinámico de DTrace para una visión general de PHP y DTrace.

Instalar OCI8 con soporte para DTrace

Para habilitar el soporte para DTrace en OCI8 para PHP, construya OCI8 como una extensión compartida después de establecer PHP_DTRACE.

$ export PHP_DTRACE=yes
$ pecl install oci8

Edite php.ini, establezca extension_dir al directorio con el oci8.so creado y también habilite la extensión añadiendo:

extension=oci8.so

Si instala PHP OCI8 2.0 desde PECL usando phpize y configure (en lugar de pecl), será necesario establecer PHP_DTRACE=yes. Esto es así debido a que la opción --enable-dtrace será ignorada por el script limitado configure de un PECL incluido.

Véase Instalación de extensiones PECL para las instrucciones generales de instalación de PECL.

Sondeos estáticos de DTrace en OCI8 para PHP

Los siguientes sondeos estáticos están disponibles en OCI8 para PHP
Nombre del sondeo | Descripción del sondeo | Argumentos del sondeo
oci8-connect-entry | Iniciado por oci_connect(), oci_pconnect() y oci_new_connect(). Lanzado antes de establecer una conexión con una base de datos. | char *username, char *dbname, char *charset, long session_mode, int persistent, int exclusive
oci8-connect-return | Lanzado al finallde una conexión. | void *connection
oci8-check-connection | Lanzado si un error de Oracle podría haber causado que la conexión sea inválida. | void *connection, char *client_id, int is_open, long errcode, unsigned long server_status
oci8-sqltext | Lanzado cuando oci_parse() se ejecuta. | void *connection, char *client_id, void *statement, char *sql
oci8-connection-close | Lanzado cuando la conexión a la base de datos está completamente destruida. | void *connection
oci8-error | Lanzado si ocurre un error de Oracle. | int status, long errcode
oci8-execute-mode | Lanzado en oci_execute() para mostrar el modo de ejecución. | void *connection, char *client_id, void *statement, unsigned int mode

Estos sondeos son útiles para rastrear scripts de OCI8.

connection y statement son los punteros a las estructuras internas usadas para rastrear conexiones de PHP y ejecutar sentencias.

client_id es el valor establecido por oci_set_client_identifier().

El núcleo de PHP también posee sondeos estáticos. Véase Sondeos estáticos de DTrace en el núcleo de PHP.

Sondeos de DTrace de depuración interna en OCI8
Nombre del sondeo
oci8-connect-expiry
oci8-connect-lookup
oci8-connect-p-dtor-close
oci8-connect-p-dtor-release
oci8-connect-type
oci8-sesspool-create
oci8-sesspool-stats
oci8-sesspool-type

Estos sondeos son útiles para mantenedores de OCI8. Consulte el código fuente de OCI8 para los argumentos y para ver cuando serán lanzados.

Enumerar los Sondeos estáticos de DTrace en OCI8 para PHP

Para enumerar los sondeos disponibles, inicie un proceso de PHP y ejecute:

# dtrace -l

La salida será similar a:

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
   17 phpoci22116           oci8.so   php_oci_dtrace_check_connection oci8-check-connection
   18 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-entry
   19 phpoci22116           oci8.so         php_oci_persistent_helper oci8-connect-expiry
   20 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-lookup
   21 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-close
   22 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-release
   23 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-return
   24 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-type
   25 phpoci22116           oci8.so          php_oci_connection_close oci8-connection-close
   26 phpoci22116           oci8.so                     php_oci_error oci8-error
   27 phpoci22116           oci8.so         php_oci_statement_execute oci8-execute-mode
   28 phpoci22116           oci8.so              php_oci_create_spool oci8-sesspool-create
   29 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-stats
   30 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-type
   31 phpoci22116           oci8.so          php_oci_statement_create oci8-sqltext

Los valores de la columna "Provider" (Proveedor) consisten en phpoci and el ID del proceso de PHP ejecutándose actualmente.

La columna "Function" (Función) se refiere a los nombres de funciones internas de la implementación en C de PHP donde cada proveedor está ubicado.

Si un proceso de PHP no se está ejecutando, no se mostrarán sondeos de PHP.

Ejemplo de DTrace con OCI8 para PHP

Este ejemplo muestra lo básico del lenguaje de script D de DTrace.

Ejemplo #1 user_oci8_probes.d para rasrear todos los Sondeos estáticos de OCI8 para PHP al nivel de usuario con DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::oci8-connect-entry
{
    printf("%lld: PHP connect-entry\n", walltimestamp);
    printf("  credentials=\"%s@%s\"\n", arg0 ? copyinstr(arg0) : "", arg1 ? copyinstr(arg1) : "");
    printf("  charset=\"%s\"\n", arg2 ? copyinstr(arg2) : "");
    printf("  session_mode=%ld\n", (long)arg3);
    printf("  persistent=%d\n", (int)arg4);
    printf("  exclusive=%d\n", (int)arg5);
}

php*:::oci8-connect-return
{
    printf("%lld: PHP oci8-connect-return\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-connection-close
{
    printf("%lld: PHP oci8-connect-close\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-error
{
    printf("%lld: PHP oci8-error\n", walltimestamp);
    printf("  status=%d\n", (int)arg0);
    printf("  errcode=%ld\n", (long)arg1);
}

php*:::oci8-check-connection
{
    printf("%lld: PHP oci8-check-connection\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  is_open=%d\n", arg2);
    printf("  errcode=%ld\n", (long)arg3);
    printf("  server_status=%lu\n", (unsigned long)arg4);
}

php*:::oci8-sqltext
{
    printf("%lld: PHP oci8-sqltext\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  sql=\"%s\"\n", arg3 ? copyinstr(arg3) : "");
}

php*:::oci8-execute-mode
{
    printf("%lld: PHP oci8-execute-mode\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  mode=0x%x\n", arg3);
}

Este script usa la opción -Z para dtrace, permitiéndole que sea ejecutado cuando no exista un procesode PHP en ejecución. Si esta opción fuera omitida, el script terminaría inmediatamente cuando no se ejecutara PHP porque no sabe de la existencia de sondeos a ser monitorizados.

En máquinas multi-CPU, el orden de los sondeos no parecerá ser sencuencial. Esto depende de cuál CPU estaba procesando los sondeos, y de cómo los hilos migran entre CPUs. Mostrar las marcas de tiempo de los sondeos atudará a reducir la confusión.

El script rastrea todos los sondeos estáticos de OCI8 para PHP a nivel de usuario que apuntan a lo largo de la duración de un script de PHP en ejecución. Ejecute el script D:

# ./user_oci8_probes.d

Ejecute un script o aplicación de PHP. El script D de monitorización generará cada argumento del sondeo mientras se lanza. Por ejemplo, un sencillo script de PHP que requiere una tabla podría producir la siguiente salida de rastreo:

1381794982092854582: PHP connect-entry
  credentials="hr@localhost/pdborcl"
  charset=""
  session_mode=0
  persistent=0
  exclusive=0
1381794982183158766: PHP oci8-connect-return
  connection=0x7f4a7907bfb8
1381794982183594576: PHP oci8-sqltext
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  sql="select * from employees"
1381794982183783706: PHP oci8-execute-mode
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  mode=0x20
1381794982444344390: PHP oci8-connect-close
  connection=0x7f4a7907bfb8

Cuando la monitorización está completa, el script D puede terminarse con un ^C.

Véase también

  • Rastreo dinámico de DTrace


Tipos de datos admitidos

El controlador admite los siguientes tipos cuando se vinculan parámetros usando la función oci_bind_by_name():
Tipo | Referencia
SQLT_NTY | Hace referencia a un tipo de colección nativo desde un objeto colección de PHP, tales como aquellos creados por oci_new_collection().
SQLT_BFILEE | Hace referencia a un descriptor nativo, tales como a aquellos creados por oci_new_descriptor().
SQLT_CFILEE | Hace referencia a un descriptor nativo, tales como a aquellos creados por oci_new_descriptor().
SQLT_CLOB | Hace referencia a un descriptor nativo, tales como a aquellos creados por oci_new_descriptor().
SQLT_BLOB | Hace referencia a un descriptor nativo, tales como a aquellos creados por oci_new_descriptor().
SQLT_RDD | Hace referencia a un descriptor nativo, tales como a aquellos creados por oci_new_descriptor().
SQLT_NUM | Convierte el parámetro de PHP al tipo long de 'C', y lo vincula a ese valor.
SQLT_RSET | Hace referencia a un gestor de sentencias nativo, tales como a aquellos creados por oci_parse() o aquellos recuperados desde otras consultas de OCI.
SQLT_BOL | Vincular el parámetro de PHP a un BOOLEAN de PL/SQL
SQLT_CHR y cualquier otro tipo | Convierte el parámetro de PHP al tipo string y lo vincula como string.
Los siguientes tipos son admitidos cuando se recuperan columnas desde un conjunto de resultados:
Tipo | Referencia
SQLT_RSET | Crea un recurso de sentencia de OCI para representar al cursor.
SQLT_RDD | Crea un objeto ROWID.
SQLT_BLOB | Crea un objeto LOB.
SQLT_CLOB | Crea un objeto LOB.
SQLT_BFILE | Crea un objeto LOB.
SQLT_LNG | Vinculado como SQLT_CHR, devuelto como string
SQLT_LBI | Vinculado como SQLT_BIN, devuelto como string
Cualquier otro tipo | Vinculado como SQLT_CHR, devuelto como string


Funciones de OCI8

Tabla de contenidos

  • oci_bind_array_by_name — Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL
  • oci_bind_by_name — Vincula una variable de PHP a un parámetro de sustitución de Oracle
  • oci_cancel — Cancela la lectura del cursor
  • oci_client_version — Devuelve la versión de la biblioteca cliente de Oracle
  • oci_close — Cierra una conexión a Oracle
  • oci_commit — Consigna la transacción pendiente de la base de datos
  • oci_connect — Conecta a una base de datos de Oracle
  • oci_define_by_name — Asocia una variable de PHP con una columna para la obtención de consultas
  • oci_error — Devuelve el último error encontrado
  • oci_execute — Ejecuta una sentencia
  • oci_fetch_all — Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_array — Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_assoc — Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object — Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row — Devuelve la siguiente fila de una consulta como un array numérico
  • oci_fetch — Coloca la siguiente fila de una consulta en los búferes internos
  • oci_field_is_null — Comprueba si un campo de la fila actualmente obtenida es null
  • oci_field_name — Devuelve el nombre de un campo de una sentencia
  • oci_field_precision — Indica la precisión de un campo
  • oci_field_scale — Indica la escala de un campo
  • oci_field_size — Devuelve el tamaño de un campo
  • oci_field_type_raw — Indica el tipo de datos sin tratar de Oracle de un campo
  • oci_field_type — Devuelve el nombre del tipo de datos de un campo
  • oci_free_descriptor — Libera un descriptor
  • oci_free_statement — Libera todos los recursos asociados con una sentencia o cursor
  • oci_get_implicit_resultset — Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c
  • oci_lob_copy — Copia objetos grandes
  • oci_lob_is_equal — Compara dos localizadores LOB/FILE
  • oci_new_collection — Asigna un nuevo objeto colección
  • oci_new_connect — Conectar al servidor de Oracle usando una conexión única
  • oci_new_cursor — Asigna y devuelve un nuevo cursor (gestor de sentencia)
  • oci_new_descriptor — Inicializa un nuevo descriptor LOB o FILE vacío
  • oci_num_fields — Devuelve el número de columnas del resultado de una sentencia
  • oci_num_rows — Devuelve el número de filas afectadas durante la ejecución de una sentencia
  • oci_parse — Prepara una sentencia de Oracle para su ejecución
  • oci_password_change — Cambia la contraseña de un usuario de Oracle
  • oci_pconnect — Conectar a una base de datos de Oracle usando una conexión persistente
  • oci_register_taf_callback — Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database
  • oci_result — Devuelve el valor de un campo de la fila obtenida
  • oci_rollback — Revierte la transacción pendiente de la base de datos
  • oci_server_version — Devuelve la versión de Oracle Database
  • oci_set_action — Establece el nombre de una acción
  • oci_set_call_timeout — Sets a millisecond timeout for database calls
  • oci_set_client_identifier — Establece el identificador del cliente
  • oci_set_client_info — Establece la información del cliente
  • oci_set_db_operation — Sets the database operation
  • oci_set_edition — Establece la edición de la base de datos
  • oci_set_module_name — Establece el nombre de un módulo
  • oci_set_prefetch — Establece el número de filas a precargar mediante consultas
  • oci_statement_type — Devuelve el tipo de una sentencia
  • oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF


Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL

  • « Funciones de OCI8
  • oci_bind_by_name »
  • PHP Manual
  • Funciones de OCI8
  • Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL

oci_bind_array_by_name

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL OCI8 >= 1.2.0)

oci_bind_array_by_name — Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL

Descripción

oci_bind_array_by_name ( resource $statement , string $name , array &$var_array , int $max_table_length , int $max_item_length = -1 , int $type = SQLT_AFC ) : bool

Vincular el array de PHP var_array al parámetro de sustitución de Oracle name, el cual apunta a un array de Oracle PL/SQL. Se determinará si será usado para entrada o salida en tiempo de ejecución.

Parámetros

statement

Un identificador de sentencia de OCI válido.

name

El parámetro de sustitución de Oracle.

var_array

Un array.

max_table_length

Establece la longitud máxima para los arrays entrantes y resultantes.

max_item_length

Establece la longitud máxima para los elementos del array. Si no se especifica o es igual a -1, oci_bind_array_by_name() buscará el elemento más largo en el array entrante y usará su longitud como valor.

type

Debería usarse para establecer el tipo de los elementos del arrary de PL/SQL. La lista siguiente muestra los tipos disponibles:

  • SQLT_NUM - para arrays de NUMBER.

  • SQLT_INT - para arrays de INTEGER (Nota: INTEGER es en realidad un sinónimo de NUMBER(38), pero el tipo SQLT_NUM no funcionará en este caso aunque sean sinónimos).

  • SQLT_FLT - para arrays de tipo FLOAT.

  • SQLT_AFC - para arrays de tipo CHAR.

  • SQLT_CHR - para arrays de tipo VARCHAR2.

  • SQLT_VCS - para arrays de tipo VARCHAR.

  • SQLT_AVC - para arrays de tipo CHARZ.

  • SQLT_STR - para arrays de tipo STRING.

  • SQLT_LVC - para arrays de tipo LONG VARCHAR.

  • SQLT_ODT - para arrays de tipo DATE.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_bind_array_by_name()

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$create = "CREATE TABLE bind_example(name VARCHAR(20))";
$stid = oci_parse($conn, $create);
oci_execute($stid);

$create_pkg = "
CREATE OR REPLACE PACKAGE ARRAYBINDPKG1 AS
  TYPE ARRTYPE IS TABLE OF VARCHAR(20) INDEX BY BINARY_INTEGER;
  PROCEDURE iobind(c1 IN OUT ARRTYPE);
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg);
oci_execute($stid);

$create_pkg_body = "
CREATE OR REPLACE PACKAGE BODY ARRAYBINDPKG1 AS
  CURSOR CUR IS SELECT name FROM bind_example;
  PROCEDURE iobind(c1 IN OUT ARRTYPE) IS
    BEGIN
    -- Bulk Insert
    FORALL i IN INDICES OF c1
      INSERT INTO bind_example VALUES (c1(i));

    -- Fetch and reverse
    IF NOT CUR%ISOPEN THEN
      OPEN CUR;
    END IF;
    FOR i IN REVERSE 1..5 LOOP
      FETCH CUR INTO c1(i);
      IF CUR%NOTFOUND THEN
        CLOSE CUR;
        EXIT;
      END IF;
    END LOOP;
  END iobind;
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg_body);
oci_execute($stid);

$stid = oci_parse($conn, "BEGIN arraybindpkg1.iobind(:c1); END;");
$array = array("one", "two", "three", "four", "five");
oci_bind_array_by_name($stid, ":c1", $array, 5, -1, SQLT_CHR);
oci_execute($stid);

var_dump($array);

?>


Vincula una variable de PHP a un parámetro de sustitución de Oracle

  • « oci_bind_array_by_name
  • oci_cancel »
  • PHP Manual
  • Funciones de OCI8
  • Vincula una variable de PHP a un parámetro de sustitución de Oracle

oci_bind_by_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_bind_by_name — Vincula una variable de PHP a un parámetro de sustitución de Oracle

Descripción

oci_bind_by_name ( resource $statement , string $bv_name , mixed &$variable , int $maxlength = -1 , int $type = SQLT_CHR ) : bool

Vincula la variable de PHP variable al parámetro de sustitución de variable vinculada de Oracle bv_name. La vinculación es importante para el rendimiento de la base de datos de Oracle y también como un forma de evitar problemas de seguridad de Inyecciones SQL.

La vinculación permite que la base de datos reutilice el contexto de la sentencia y use la caché desde ejecuciones previas de dicha sentencia, incluso si otro usuario o proceso la ejecutó inicialmente. La vinculación reduce las inquietudes con Inyecciones SQL ya que los datos asociados con una variable vinculada nunca son tratados como parte de la sentencia SQL. Hace que no sean necesarios la entrecomillación o el escape.

Las variables de PHP que han sido vinculadas se pueden cambiar, por lo que la sentencia se reejecutará sin necesidad de reanalizarla o revincularla.

En Oracle, la vinculaión de variables se divide normalmente en vínculos IN para valores que son pasados a la base de datos, y vínculos OUT para valores que son devueltos a PHP. Una variable vinculada podría ser tanto IN como OUT. Si una variable vinculada será usada para entrada o salida se determina en en tiempo de ejecución.

Se debe especificar maxlength al utilizar un vínculo OUT para que PHP asigne suficiente memoria para contener el valor devuelto.

Para los vínculos IN, se recomienda establecer la longitud maxlength si la sentencia es reejecutada múltiples veces con diferentes valores para la variable de PHP. Si no, Oracle podría truncar los datos a la longitud del valor inicial de la variable de PHP. Si no se conoce cuál será la longitud máxima, reinvoque a oci_bind_by_name() con el tamaño de los datos actuales antes de cada llamada a oci_execute(). Vincular una longitud grande innecesariamente tendrá un impacto en la memoria del proceso de la base de datos.

Una llamada vinculada le indica a Oracle desde qué dirección de memoria debe leer datos. Para vínculos IN, esta dirección necesita contener datos válidos cuando se invoque a oci_execute(). Esto significa que la variable vinculada debe permanecer en el ámbito hasta su ejecución. Si no se hace, pueden ocurrir errores inesperados como "ORA-01460: unimplemented or unreasonable conversion requested". Para vínculos OUT, un síntoma es que no se ha establecido un valor en la variable de PHP.

Para una sentencia que sea ejecutada repetidamente, los valores vinculados que nunca cambian podrían reducir la capacidad del optimizador de Oracle para elegir el mejor plan de ejecución de sentencias. Las sentencias que tarden en ejecutarse y que sean reejecutadas raramente podrían no beneficiarse de la vinculación. Sin embargo, en ambos casos, la vinculación podría ser más segura que unir cadenas en una sentencia SQL, ya que esto puede ser un riesgo para la seguridad si se concatena el texto no filtrado de un usuario.

Parámetros

statement

Un identificador de sentencia de OCI8 válido.

bv_name

El parámetro de sustitución de la variable vinculada prefijado por dos puntos (:) usado en la sentencia. Los dos puntos son opcionales en bv_name. Oracle no usa los signos de interrogación en los parámetros de sustitución.

variable

La variable de PHP que va a ser asociada con bv_name

maxlength

Establece la longitud máxima para los datos. Si se establece a -1, esta función utilizará la longitud actual de variable para establecer la longitud máxima. En este caso, el parámetro variable debe existir y contener datos cuando se invoque a oci_bind_by_name().

type

El tipo de datos con el que Oracle trartará los datos. El tipo usado predeterminado dado por type es SQLT_CHR. Oracle convertirá los datos entre este tipo y la columna de la base de datos (o un tipo de variable de PL/SQL), cuando sea posible.

Si fuera necesario vincular un tipo de datos abstractos (LOB/ROWID/BFILE), debe asignarlo primero usando la función oci_new_descriptor(). La longitud length no se usa para tipos de datos abstractos, por lo que debería establecerse a -1.

Los valores posibles para type son:

  • SQLT_BFILEE or OCI_B_BFILE - para BFILEs;

  • SQLT_CFILEE o OCI_B_CFILEE - para CFILEs;

  • SQLT_CLOB o OCI_B_CLOB - para CLOBs;

  • SQLT_BLOB o OCI_B_BLOB - para BLOBs;

  • SQLT_RDD o OCI_B_ROWID - para ROWIDs;

  • SQLT_NTY o OCI_B_NTY - para tipos de datos con nombre;

  • SQLT_INT o OCI_B_INT - para enteros;

  • SQLT_CHR - para VARCHARs;

  • SQLT_BIN o OCI_B_BIN - para columnas RAW;

  • SQLT_LNG - para columnas LONG;

  • SQLT_LBI - para columnas LONG RAW;

  • SQLT_RSET - para cursores creados con oci_new_cursor();

  • SQLT_BOL o OCI_B_BOL - para BOOLEAN de PL/SQL (Requiere OCI8 2.0.7 y Oracle Database 12c)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Insertar datos con oci_bind_by_name()

<?php

// Cree la tabla con:
//   CREATE TABLE mytab (id NUMBER, text VARCHAR2(40));

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conexión,"INSERT INTO mytab (id, text) VALUES(:id_bv, :text_bv)");

$id = 1;
$texto = "Datos a insertar     ";
oci_bind_by_name($stid, ":id_bv", $id);
oci_bind_by_name($stid, ":text_bv", $texto);
oci_execute($stid);

// La tabla ahora contiene: 1, 'Datos a insertar     '

?>

Ejemplo #2 Vincular una vez para múltiples ejecuciones

<?php

// Cree la tabla con:
//   CREATE TABLE mytab (id NUMBER);

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$a = array(1,3,5,7,11);  // datos a insertar

$stid = oci_parse($conexión, 'INSERT INTO mytab (id) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $v, 20);
foreach ($a as $v) {
    $r = oci_execute($stid, OCI_DEFAULT);  // no autoconsigna
}
oci_commit($conexión); // consigna todo una vez

// La tabla contiene cinco filas: 1, 3, 5, 7, 11

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #3 Vinculación con un bucle foreach()

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT * FROM departments WHERE department_name = :dname AND location_id = :loc';
$stid = oci_parse($conexión, $sql);

$ba = array(':dname' => 'IT Support', ':loc' => 1700);

foreach ($ba as $clave => $valor) {

    // oci_bind_by_name($stid, $clave, $valor) no funciona debido a
    // que vincula cada parámetro de sustitución a la misma ubicación: $valor
    // En su lugar, use la ubicación real de los datos: $ba[$clave]
    oci_bind_by_name($stid, $clave, $ba[$clave]);
}

oci_execute($stid);
$fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
foreach ($fila as $item) {
    print $item."<br>\n";
}

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #4 Vinculación en una cláusula WHERE

<?php

$conexión = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conexión, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// La salida es
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #5 Vinculación con una cláusula LIKE

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Busca todas las ciudades que empiecen por 'South'
$stid = oci_parse($conexión, "SELECT city FROM locations WHERE city LIKE :bv");
$ciudad = 'South%';  // '%' es un comodín en SQL
oci_bind_by_name($stid, ":bv", $ciudad);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// La salida es
//   South Brunswick
//   South San Francisco
//   Southlake

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #6 Vinculación con REGEXP_LIKE

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Busca todas las ciudades que contengan 'ing'
$stid = oci_parse($conexión, "SELECT city FROM locations WHERE REGEXP_LIKE(city, :bv)");
$ciudad = '.*ing.*';
oci_bind_by_name($stid, ":bv", $ciudad);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// La salida es
//   Beijing
//   Singapore

oci_free_statement($stid);
oci_close($conexión);

?>

Para un número fijo pequeño de condiciones de la cláusula IN, use variables vinculadas individuales. Los valores desconocidos en tiempo de ejecución pueden ser establecidos a NULL. Esto permite que una única sentencia sea usada por todos los usuarios de una aplicación, maximizando la enficiencia de la caché de la base de datos de Oracle.

Ejemplo #7 Vinculación de múltiples valores en una cláusula IN

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE employee_id in (:e1, :e2, :e3)';
$stid = oci_parse($conexión, $sql);
$mye1 = 103;
$mye2 = 104;
$mye3 = NULL; // se pretende que no se proporcione este valor
oci_bind_by_name($stid, ':e1', $mye1);
oci_bind_by_name($stid, ':e2', $mye2);
oci_bind_by_name($stid, ':e3', $mye3);
oci_execute($stid);
oci_fetch_all($stid, $res);
foreach ($res['LAST_NAME'] as $nombre) {
    print $nombre ."<br>\n";
}

// La salida es
//   Ernst
//   Hunold

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #8 Vinculación de un ROWID devuelto por una consulta

<?php

// Cree la tabla con:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//   INSERT INTO mytab (id, salary, name) VALUES (1, 100, 'Chris');
//   COMMIT;

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conexión, 'SELECT ROWID, name FROM mytab WHERE id = :id_bv FOR UPDATE');
$id = 1;
oci_bind_by_name($stid, ':id_bv', $id);
oci_execute($stid);
$fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
$rid = $fila['ROWID'];
$nombre = $fila['NAME'];

// Cambiar el nombre a mayúsculas y guardar los cambios
$nombre = strtoupper($nombre);
$stid = oci_parse($conexión, 'UPDATE mytab SET name = :n_bv WHERE ROWID = :r_bv');
oci_bind_by_name($stid, ':n_bv', $nombre);
oci_bind_by_name($stid, ':r_bv', $rid, -1, OCI_B_ROWID);
oci_execute($stid);

// La tabla contiene ahora 1, 100, CHRIS

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #9 Vinculación de un ROWID sobre INSERT

<?php

// Este ejemplo inserta un id y un nombre, y luego actualiza el salario
// Cree la tabla con:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//
// Basado en el ejemplo original de ROWID de thies at thieso dot net (980221)

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = "INSERT INTO mytab (id, name) VALUES(:id_bv, :name_bv)
        RETURNING ROWID INTO :rid";

$ins_stid = oci_parse($conexión, $sql);

$id_fila = oci_new_descriptor($conexión, OCI_D_ROWID);
oci_bind_by_name($ins_stid, ":id_bv",   $id,    10);
oci_bind_by_name($ins_stid, ":name_bv", $nombre,  32);
oci_bind_by_name($ins_stid, ":rid",     $id_fila, -1, OCI_B_ROWID);

$sql = "UPDATE mytab SET salary = :salary WHERE ROWID = :rid";
$upd_stid = oci_parse($conexión, $sql);
oci_bind_by_name($upd_stid, ":rid", $id_fila, -1, OCI_B_ROWID);
oci_bind_by_name($upd_stid, ":salary", $salario,   32);

// Los identificadores y los nombres a insertar
$datos = array(1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim");

// El salario para cada persona
$salario = 10000;

// Insertar e inmediatamente actualizar cada fila
foreach ($datos as $id => $nombre) {
    oci_execute($ins_stid);
    oci_execute($upd_stid);
}

$id_fila->free();
oci_free_statement($upd_stid);
oci_free_statement($ins_stid);

// Mostrar las nuevas filas
$stid = oci_parse($conexión, "SELECT * FROM mytab");
oci_execute($stid);
while ($fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    var_dump($fila);
}

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #10 Vinculación para una función almacenada de PL/SQL

<?php

//  Antes de ejecutar este programa de PHP, cree una función almacenada en
//  SQL*Plus o SQL Developer:
//
//  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
//  BEGIN
//      RETURN p * 3;
//  END;

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conexión, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);

// El valor devuelto es un vínculo OUT. El tipo predeterminado será una cadena,
// por lo que vincular 40 significa que serán devueltos 40 dígitos
// como máximo.
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // imprime 24

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #11 Vinculación de parámetros para un procedimiento almacenado de PL/SQL

<?php

//  Antes de ejecutar este programa de PHP, cree un procedemiento almacenado en
//  SQL*Plus o SQL Developer:
//
//  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
//  BEGIN
//      p2 := p1 * 2;
//  END;

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conexión, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);

// El segundo parámetro del procedimiento es un vínculo OUT. El tipo predeterminado
// será una cadena, por lo que vincular 40 significa que serán devueltos 40 dígitos
// como máximo.
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // imprime 16

oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #12 Vinculación de una columna CLOB

<?php

// Antes de ejecutarlo, cree la tabla:
//     CREATE TABLE mytab (mykey NUMBER, myclob CLOB);

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$mykey = 12343;  // clave arbitraria para este ejemplo;

$sql = "INSERT INTO mytab (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conexión, $sql);
$clob = oci_new_descriptor($conexión, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_DEFAULT);
$clob->save("A very long string");

oci_commit($conexión);

// Obtener los datos CLOB

$consulta = 'SELECT myclob FROM mytab WHERE mykey = :mykey';

$stid = oci_parse ($conexión, $consulta);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$fila['MYCLOB'].'</td></tr>';
    // En un bucle, liberar la variable grande de la 2ª obtención reduce en uso de memoria de picos de PHP
    unset($fila);
}
print '</table>';

?>

Ejemplo #13 Vincular un BOOLEAN de PL/SQL

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$plsql =
  "begin
    :output1 := true;
    :output2 := false;
   end;";

$s = oci_parse($c, $plsql);
oci_bind_by_name($s, ':output1', $output1, -1, OCI_B_BOL);
oci_bind_by_name($s, ':output2', $output2, -1, OCI_B_BOL);
oci_execute($s);
var_dump($output1);  // true
var_dump($output2);  // false

?>

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

No use magic_quotes_gpc o addslashes() y oci_bind_by_name() simultáneamente, ya que no es necesario el entrecomillado. Cualquier comilla aplicada mágicamente será escrita en la base de datos debido a que oci_bind_by_name() inserta los datos textualmente y no elimina las comillas o los caracteres de escape.

Nota:

Si vincula una cadena con una columna CHAR en una cláusula WHERE, recuerde que Oracle utiliza una semántica de comparación de relleno en blanco para columnas CHAR. La variable de PHP debería estar rellena con espacios en blanco a la misma longitud que la columna para que la cláusula WHERE tenga éxito.

Nota:

El argumento variable de PHP es una referencia. Algunas formas de bucles no funcionan como era de esperar:

<?php
foreach ($array as $clave => $valor)  {
    oci_bind_by_name($stid, $clave, $valor);
}
?>

Esto vincula cada clave a la ubicación de $valor, por lo que todas las variables vinculadas terminaran apuntando al valor de la última interación del bucle. En su lugar, se ha de utilizar lo siguiente:

<?php
foreach ($array as $clave => $valor) {
    oci_bind_by_name($stid, $clave, $array[$clave]);
}
?>

Ver también

  • oci_bind_array_by_name() - Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL
  • oci_parse() - Prepara una sentencia de Oracle para su ejecución


Cancela la lectura del cursor

  • « oci_bind_by_name
  • oci_client_version »
  • PHP Manual
  • Funciones de OCI8
  • Cancela la lectura del cursor

oci_cancel

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_cancel — Cancela la lectura del cursor

Descripción

oci_cancel ( resource $statement ) : bool

Invalida un cursor, liberando todos los recursos asociados y cancela la capacidad para leer desde él.

Parámetros

statement

Una sentencia de OCI.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve la versión de la biblioteca cliente de Oracle

  • « oci_cancel
  • oci_close »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la versión de la biblioteca cliente de Oracle

oci_client_version

(PHP 5 >= 5.3.7, PHP 7, PHP 8, PECL OCI8 >= 1.4.6)

oci_client_version — Devuelve la versión de la biblioteca cliente de Oracle

Descripción

oci_client_version ( ) : string

Devuelve un string que contiene el número de la versión de la biblioteca cliente en C de Oracle a la que está vinculada PHP.

Parámetros

Ninguno

Valores devueltos

Devuelve el número de la versión como un string.

Ejemplos

Ejemplo #1 Ejemplo de oci_client_version()

<?php
    echo "Versión cliente: " . oci_client_version(); // Versión cliente: 11.2.0.2
?>

Notas

Nota:

Las bibliotecas de Oracle anteriores a 10gR2 no tienen la funcionalidad subyacente para obtener el número de la versión de la biblioteca cliente. En este caso será devuelto la cadena "Unknown".

Ver también

  • oci_server_version() - Devuelve la versión de Oracle Database


Cierra una conexión a Oracle

  • « oci_client_version
  • oci_commit »
  • PHP Manual
  • Funciones de OCI8
  • Cierra una conexión a Oracle

oci_close

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_close — Cierra una conexión a Oracle

Descripción

oci_close ( resource $connection ) : bool

Desestablece connection. La conexión subyacentte a la base de datos se cierra si otros recursos no la están utilizando y si fue creada con oci_connect() o oci_new_connect().

Se recomienda cerrar las conexiones que no sean necesarias ya que esto hace que los recursos de la base de datos estén disponbles para otros usuarios.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect(), oci_pconnect() o oci_new_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cerrar una conexión

Los recursos asociados con una conexión deberían cerrarse para asegurarse de que la conexión subyacente a la base de datos sea finalizada apropiadamente y sean liberados los recursos de la base de datos.

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conexión, 'SELECT * FROM departments');
$r = oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

// Liberar el identificador de sentencia al cerrar la conexión
oci_free_statement($stid);
oci_close($conexión);

?>

Ejemplo #2 Las conexiones a bases de datos no se cierran hasta que todas las referencias sean cerradas

La cuenta de referencias interna de un identificador de conexión debe ser cero antes de que sea cerrada la conexión subyacente a la base de datos.

<?php

$conexión = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conexión) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conexión, 'SELECT * FROM departments');  // esto incrementa la cuenta de referencias de $conn
oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

oci_close($conexión);

// $conexión ya no puede ser utilizada en el script, pero la conexión subyacente
// a la base de datos aún se mantiene abierta, hasta que $stid sea liberado.
var_dump($conexión);  // imprime NULL

// Mientras PHP duerme, consultar la vista V$SESSION de Oracle en una
// ventana terminal mostrará que el ususario de la base de datos que aún está conectado.
sleep(10);

// Cuando $stid es liberado, la conexión a la base de datos se cierra físicamente
oci_free_statement($stid);

// Mientras PHP duerme, consultar la vista V$SESSION de Oracle en una
// ventana terminal mostrará que el ususario de la base de datos se ha desconectado.
sleep(10);

?>

Ejemplo #3 Cerrar una conexión abierta más de una vez

Cuando se reutilizan las credenciales de la base de datos, ambas conexiones deben cerrarse antes de que se cierre la conexión subyacente a la base de datos.

<?php

$conexión1 = oci_connect('hr', 'welcome', 'localhost/XE');

// Al usar las mismas credenciales se reutiliza la misma conexión subyacente a la base de datos
// Cualquier cambio no consignado realizado a $conexión1 será visible en $conexión2
$conexión2 = oci_connect('hr', 'welcome', 'localhost/XE');

// Mientras PHP duerme, consultar la vista V$SESSION de Oracle en una
// ventana terminal mostrará que solamente está conectado un ususario de la base de datos.
sleep(10);

oci_close($conexión1); // no cierra la conexión subyacente a la base de datos
var_dump($conexión1);  // imprime NULL debido a que la variable $conexión1 ya no se puede utilizar
var_dump($conexión2);  // muestra que $conexión2 aún es un recurso de conexión válido

?>

Ejemplo #4 Las conexsiones se cierran cuando las variables salen de su ámbito

Cuando todas las variables que hacen referencia a una conexión salen de su ámbito y son liberadas por PHP, se produce una reversión (rollback), si fuera necesaria, y la conexión subyacente a la base de datos se cierra.

<?php

function myfunc() {
    $conexión = oci_connect('hr', 'hrpwd', 'localhost/XE');
    if (!$conexión) {
        $e = oci_error();
        trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
    }

    $stid = oci_parse($conexión, 'UPDATE mytab SET id = 100');
    oci_execute($stid, OCI_NO_AUTO_COMMIT);
    return "Finalizado";
}

$r = myfunc();
// En este punto sucede la reversión y la conexión subyacente a la base de datos queda cerrada.

print $r;  // muestra el valor de retorno "Finalizado" de la función.

?>

Notas

Nota:

Las variables que poseen una dependencia sobre el identificador de conexión, tales como los identificadores de sentencias devueltos por oci_parse(), también deben ser liberadas antes de cerra la conexión subyacente a la base de datos.

Nota:

Antes de la versión 5.1.2 de PHP (PECL OCI8 1.1) oci_close() no operaba. En versiones más recientes cierra correctamente la conexión a Oracle. Use la opción oci8.old_oci_close_semantics para restablecer el comportamento antiguo de esta función.

Nota:

La función oci_close() no cierra las conexiones subyacentes de la bases de datos creadas con oci_pconnect().

Ver también

  • oci_connect() - Conecta a una base de datos de Oracle
  • oci_free_statement() - Libera todos los recursos asociados con una sentencia o cursor


Consigna la transacción pendiente de la base de datos

  • « oci_close
  • oci_connect »
  • PHP Manual
  • Funciones de OCI8
  • Consigna la transacción pendiente de la base de datos

oci_commit

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_commit — Consigna la transacción pendiente de la base de datos

Descripción

oci_commit ( resource $connection ) : bool

Consigna la transacción pendiente de la conexión de Oracle dada por connection. Una consignación finaliza la transacción actual y hace permanente todos los cambios. Libera todos los bloqueos que hubiera.

Una transacción comienza cuando la primera sentencia SQL que modifica datos es ejecutada con oci_execute() usando la bandera OCI_NO_AUTO_COMMIT. Las modificaciones posteriores de datos realizados por otra sentencia serán parte de la misma transacción. Las modificaciones hechas en una transacción son temporales hasta que sea consignada o revertida. Los demás usuarios de la base de datos no verán dichos cambios hasta que sean consignados.

Cuando se insertan datos, se recomienda usar transacciones para mantener la consistencia de datos relacionales y por motivos de rendimiento.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_commit()

<?php

// Insertar en varias tablas, y revertir los cambios si ocurrió un error

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// La bandera OCI_NO_AUTO_COMMIT indica a Oracle que no consigne el INSERT inmediatamente
// Use OCI_DEFAULT como bandera para PHP <= 5.3.1. Las dos banderas son equivalentes
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // revertir los cambios en ambas tablas
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Consignar los cambios de ambas tablas
$r = oci_commit($conn);
if (!$r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

Notas

Nota:

Las transacciones son revertidas automáticamente cuando se cierra la conexión, o cuando el script finaliza, lo que suceda antes. Es necesario llamar a oci_commit() para consignar la transacción.

Cualquier llamada a oci_execute() que utilice el modo OCI_COMMIT_ON_SUCCESS, de forma explícita o por omisión, consignará cualquier transacción no consignada previamente.

Cualquier sentencia DDL de Oracle, como CREATE o DROP, consignará automáticamente cualquier transacción no consignada.

Ver también

  • oci_execute() - Ejecuta una sentencia
  • oci_rollback() - Revierte la transacción pendiente de la base de datos


Conecta a una base de datos de Oracle

  • « oci_commit
  • oci_define_by_name »
  • PHP Manual
  • Funciones de OCI8
  • Conecta a una base de datos de Oracle

oci_connect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_connect — Conecta a una base de datos de Oracle

Descripción

oci_connect ( string $username , string $password , string $connection_string = ? , string $character_set = ? , int $session_mode = ? ) : resource

Devuelve un identificador de conexión necesario para la mayoría de las operaciones de OCI8.

Véase Manejo de conexiones para obtener información general sobre la gestión y agrupamiento de conexiones.

Desde PHP 5.1.2 (PECL OCI8 1.1), se puede usar oci_close() para cerrar conexiones.

La segunda y subsiguientes llamadas a oci_connect() con los mismos parámetros devolverán el gestor de conexión devuelto desde la primera llamada. Esto significa que las transacciones de un gestor también son las de los demás gestores, ya que usan la misma conexión subyacente a la base de datos. Si dos gestores necesitan ser aislados transaccionalmente uno de otro, use oci_new_connect() en su lugar.

Parámetros

username

El nombre de usuario de Oracle.

password

La contraseña para username.

connection_string

Contiene la instancia de Oracle a la que conectarse. Puede ser una » cadena de Conexión Sencilla (Easy Connect), o un Nombre de Conexión del fichero tnsnames.ora, o el nombre de una instancia local de Oracle.

Si no se especifica, PHP utiliza variables de entorno como TWO_TASK (en Linux) o LOCAL (en Windows) y ORACLE_SID para determinar la instancia de Oracle a la que conectarse.

Para utilizar el método de nomenclatura de Conexión Sencila, PHP debe estar vinculado con las bibliotecas cliente de Oracle 10g o superiores. La cadena de Conexión Sencilla para Oracle 10g se utiliza de la siguiente forma: [//]nombre_host[:puerto][/nombre_servicio]. Desde Oracle 11g, la sintaxis es: [//]nombre_host[:puerto][/nombre_servicio][:tipo_servicio][/nombre_instancia]. Los nombres de servicio pueden encontrarse ejecuntado la utilidad de Oracle lsnrctl status en el servidor donde se encuentra la base de datos.

El fichero tnsnames.ora puede estar en la ruta de búsqueda de Oracle Net, la cual incluye $ORACLE_HOME/network/admin y /etc. De forma alternativa, establezca TNS_ADMIN para que $TNS_ADMIN/tnsnames.ora sea leído. Asegúrse que el demonio web tiene acceso de lectura al fichero.

character_set

Determina el juego de caracteres usado por las bibliotecas cliente de Oracle. El juego de caracteres no tiene por que coinicidir con el utilizado en la base de datos. Si no coinicide, Oracle intentará hacer lo posible para convertir los datos entre los dos juegos de caracteres. Dependiendo del juego de caracteres que se esté usando, podría no proporcionarse resultados útiles. La conversión también añade algo de carga extra de tiempo.

Si no se especifica, las bibliotacas cliente de Oracle determinarán el juego de caracteres desde la variable de entorno NLS_LANG.

Pasar este parámetro puede reducir el tiempo que toma en conectarse.

session_mode

Este parámetro está disponible desde la versión 5 de PHP (PECL OCI8 1.1) y acepta los siguientes valores: OCI_DEFAULT, OCI_SYSOPER y OCI_SYSDBA. Si se especifica OCI_SYSOPER o OCI_SYSDBA, esta función intentará establecer una conexión privilegiada con las credenciales externas. Las conexiones privilegiadas están desactivadas por omisión. Para activarlas hay que establecer oci8.privileged_connect a On.

En PHP 5.3 (PECL OCI8 1.3.4) se introdujo el valor de modo OCI_CRED_EXT. Esto indica a Oracle que utilice la autenticación Externa o del SO, la cual debe estar configurada en la base de datos. La bandera OCI_CRED_EXT sólo puede usarse con el nombre de usuario "/" y la contraseña en blanco. oci8.privileged_connect podría ser On o Off.

OCI_CRED_EXT podría estar en combinación con los modos OCI_SYSOPER o OCI_SYSDBA.

OCI_CRED_EXT no se admite en Windows por razones de seguridad.

Valores devueltos

Devuelve un identificador de conexión, o false en caso de error.

Ejemplos

Ejemplo #1 Uso básico de oci_connect() utilizando la sintaxis de Easy Connect

<?php

// Conectar al servicio XE (es deicr, la base de datos) en la máquina "localhost"
$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Ejemplo #2 Uso básico de oci_connect() utilizando un nombre de Network Connect

<?php

// Conectar a la base de datos MYDB descrita en el fichero tnsnames.ora,
// Un ejemplo de una entrada de tnsnames.ora para MYDB podría ser:
//   MYDB =
//     (DESCRIPTION =
//       (ADDRESS = (PROTOCOL = TCP)(HOST = mymachine.oracle.com)(PORT = 1521))
//       (CONNECT_DATA =
//         (SERVER = DEDICATED)
//         (SERVICE_NAME = XE)
//       )
//     )

$conn = oci_connect('hr', 'welcome', 'MYDB');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Ejemplo #3 oci_connect() con un conjunto de caracteres explícito

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE', 'AL32UTF8');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Ejemplo #4 Usar múltiples llamadas a oci_connect()

<?php

$c1 = oci_connect("hr", "welcome", 'localhost/XE');
$c2 = oci_connect("hr", "welcome", 'localhost/XE');

// $c1 y $c2 muestran el mismo id de recurso de PHP, ya que usan la
// misma conexión subyacente a la base de datos
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

function create_table($conn)
{
    $stmt = oci_parse($conn, "create table hallo (test varchar2(64))");
    oci_execute($stmt);
    echo "Created table<br>\n";
}

function drop_table($conn)
{
    $stmt = oci_parse($conn, "drop table hallo");
    oci_execute($stmt);
    echo "Dropped table<br>\n";
}

function insert_data($connname, $conn)
{
    $stmt = oci_parse($conn, "insert into hallo
              values(to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname inserted row without committing<br>\n";
}

function rollback($connname, $conn)
{
    oci_rollback($conn);
    echo "$connname rollback<br>\n";
}

function select_data($connname, $conn)
{
    $stmt = oci_parse($conn, "select * from hallo");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname ----selecting<br>\n";
    while (oci_fetch($stmt)) {
        echo "    " . oci_result($stmt, "TEST") . "<br>\n";
    }
    echo "$connname ----done<br>\n";
}

create_table($c1);

insert_data('c1', $c1);   // Insertar una fila usando c1
sleep(2);                 // Dormir para mostrar una marca de tiempo diferente en la 2ª fila
insert_data('c2', $c2);   // Insertar una fila usando c2

select_data('c1', $c1);   // Son devueltas ambas inserciones
select_data('c2', $c2);   // Son devueltas ambas inserciones

rollback('c1', $c1);      // Revertir usando c1

select_data('c1', $c1);   // Ambas inserciones han sido revertidas
select_data('c2', $c2);

drop_table($c1);

// El cierre de una de las conexiones hace que la variable de PHP sea inutilizable, aunque
// se podría utilizar la otra
oci_close($c1);
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

// La salida es:
//    c1 is Resource id #5
//    c2 is Resource id #5
//    Created table
//    c1 inserted row without committing
//    c2 inserted row without committing
//    c1 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c1 ----done
//    c2 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c2 ----done
//    c1 rollback
//    c1 ----selecting
//    c1 ----done
//    c2 ----selecting
//    c2 ----done
//    Dropped table
//    c1 is
//    c2 is Resource id #5

?>

Notas

Nota:

Una instalación o configuración incorrecta de la extensión OCI8 a menudo se manifestará como un problema o error de conexión. Véase la sección Instalación/Configuración para obtener información sobre la solución de problemas.

Ver también

  • oci_pconnect() - Conectar a una base de datos de Oracle usando una conexión persistente
  • oci_new_connect() - Conectar al servidor de Oracle usando una conexión única
  • oci_close() - Cierra una conexión a Oracle


Asocia una variable de PHP con una columna para la obtención de consultas

  • « oci_connect
  • oci_error »
  • PHP Manual
  • Funciones de OCI8
  • Asocia una variable de PHP con una columna para la obtención de consultas

oci_define_by_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_define_by_name — Asocia una variable de PHP con una columna para la obtención de consultas

Descripción

oci_define_by_name ( resource $statement , string $column_name , mixed &$variable , int $type = SQLT_CHR ) : bool

Asocia una variable de PHP con una columna para la obtención de consultas usando oci_fetch().

La llamada a oci_define_by_name() debe ocurrir antes que la ejecución de oci_execute().

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

column_name

El nombre de la columna usada en la consulta.

Use los nombres de columnas predeterminados de Oracle, en mayúsculas e insensibles al uso de mayúsculas/minúsculas. Use los nombres de columna exactos para nombres de columnas sensibles al uso de mayúsculas/minúsculas.

variable

La variable de PHP que contendrá el valor de la columna devuelta.

type

El tipo de dato a devolver. Generalmente no es necesario. Observe que no se lleva a cabo la conversión de datos estilo Oracle. Por ejemplo, SQLT_INT será ignorado, y el tipo de dato devuelto continuará siendo SQLT_CHR.

Opcionalmente se puede usar oci_new_descriptor() para asignar descriptores LOB/ROWID/BFILE.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_define_by_name()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);

// Las definiciones DEBEN hacerse antes de la ejecución
oci_define_by_name($stid, 'LOCATION_ID', $locid);
oci_define_by_name($stid, 'CITY', $city);

oci_execute($stid);

// Cada obtención rellena las variables anteriormente definidas con los datos de la siguiente fila
while (oci_fetch($stid)) {
    echo "La ubicación del id $locid es $city<br>\n";
}

// Se muestra:
//   La ubicación del id 1000 es Roma
//   La ubicación del id 1100 es Venice

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 oci_define_by_name() con nombres de columna sensibles al uso de mayúsculas/minúsculas

<?php

/*
  Antes de ejecutarlo, cree la tabla con un nombre de columna sensible al uso de mayúsculas/minúsculas
    CREATE TABLE mytab (id NUMBER, "MyDescription" VARCHAR2(30));
    INSERT INTO mytab (id, "MyDescription") values (1, 'Iced Coffee');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// Use mayúsculas para nombres de columnas insensible al uso de mayúsculas/minúsculas
oci_define_by_name($stid, 'ID', $id);

// Use el nombre exacto para nombres de columnas sensible al uso de mayúsculas/minúsculas
oci_define_by_name($stid, 'MyDescription', $mydesc);

oci_execute($stid);

while (oci_fetch($stid)) {
    echo "El id $id es $mydesc<br>\n";
}

// Se muestra:
//   El id 1 es Iced Coffee

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #3 oci_define_by_name() con columnas de tipo LOB

<?php

/*
  Antes de ejecutarlo, cree la tabla:
    CREATE TABLE mytab (id NUMBER, fruit CLOB);
    INSERT INTO mytab (id, fruit) values (1, 'manzana');
    INSERT INTO mytab (id, fruit) values (2, 'naranaja');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// Las definiciones DEBEN hacerse antes de la ejecución
oci_define_by_name($stid, 'ID', $id);
oci_define_by_name($stid, 'FRUIT', $fruta);  // $fruta será un descriptor LOB

oci_execute($stid);

while (oci_fetch($stid)) {
    echo $id . " es " . $fruta->load(100) . "<br>\n";
}

// Se muestra:
//   1 es manzana
//   2 es naranaja

$fruta->free();
oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #4 oci_define_by_name() con un tipo explícito

<?php

/*
  Antes de ejecutarlo, cree la tabla:
    CREATE TABLE mytab (id NUMBER, fruit CLOB);
    INSERT INTO mytab (id, fruit) values (1, 'manzana');
    INSERT INTO mytab (id, fruit) values (2, 'naranaja');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// Las definiciones DEBEN hacerse antes de la ejecución
oci_define_by_name($stid, 'ID', $id);

$fruta = oci_new_descriptor($conn, OCI_D_LOB);
oci_define_by_name($stid, 'FRUIT', $fruta, OCI_D_CLOB);

oci_execute($stid);

while (oci_fetch($stid)) {
    echo $id . " es " . $fruta->load(100) . "<br>\n";
}

// Se muestra:
//   1 es manzana
//   2 es naranaja

$fruta->free();
oci_free_statement($stid);
oci_close($conn);

?>

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_new_descriptor() - Inicializa un nuevo descriptor LOB o FILE vacío


Devuelve el último error encontrado

  • « oci_define_by_name
  • oci_execute »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el último error encontrado

oci_error

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_error — Devuelve el último error encontrado

Descripción

oci_error ( resource $resource = ? ) : array

Devuelve el último error encontrado.

La función debería ser invocada inmediatamente después de que ocurra un error. Los errores son limpiados por una sentencia que tenga éxito.

Parámetros

resource

Para la mayoría de errores, resource es el
gestor de recurso que fue pasado a la función que falló.
Para errores de conexión con oci_connect(),
oci_new_connect() o
oci_pconnect(), no pase resource.

Valores devueltos

Si no se encontró ningún error, oci_error() devuelve false. De lo contrario, oci_error() devuelve la información del error como un array asociativo.

Descripción del array de oci_error()
Clave del array | Tipo | Descripción
code | integer | El número de error de Oracle.
message | string | El texto del error de Oracle.
offset | integer | La posición del byte de un error en una sentencia SQL. Si no existiera tal sentencia, este valor será 0
sqltext | string | El texto de la sentencia SQL. Si no existiera tal sentencia, este valor será una cadena vacía.

Ejemplos

Ejemplo #1 Mostrar el mensaje de error de Oracle después de un error de conexión

<?php
$conn = oci_connect("hr", "welcome", "localhost/XE");
if (!$conn) {
    $e = oci_error();   // Para errores de oci_connect errors, no pase un gestor
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}
?>

Ejemplo #2 Mostrar el mensaje de error de Oracle después de un error de análisis

<?php
$stid = oci_parse($conn, "select ' from dual");  // observe la comilla simple dispareja
if (!$stid) {
    $e = oci_error($conn);  // Para errores de oci_parse, pase el gestor de conexión
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}
?>

Ejemplo #3 Mostrar el mensaje de error de Oracle, la sentencia problemática, y la posición del problema en un error de ejecución

<?php
$stid = oci_parse($conn, "select does_not_exist from dual");
$r = oci_execute($stid);
if (!$r) {
    $e = oci_error($stid);  // Para errores de oci_execute, pase el gestor de sentencia
    print htmlentities($e['message']);
    print "\n<pre>\n";
    print htmlentities($e['sqltext']);
    printf("\n%".($e['offset']+1)."s", "^");
    print  "\n</pre>\n";
}
?>


Ejecuta una sentencia

  • « oci_error
  • oci_fetch_all »
  • PHP Manual
  • Funciones de OCI8
  • Ejecuta una sentencia

oci_execute

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_execute — Ejecuta una sentencia

Descripción

oci_execute ( resource $statement , int $mode = OCI_COMMIT_ON_SUCCESS ) : bool

Ejecuta la sentencia dada por statement anteriormente devuelta desde oci_parse().

Después de la ejecución, las sentencias como INSERT, por omisión, contendrán datos consolidados en la base de datos. Para sentencias como SELECT, la ejecución realiza la lógica de la consulta. Los resultados de las consultas pueden obtenerse posteriormente en PHP con funciones como oci_fetch_array().

Cada sentencia analizada podría ser ejecutada múltiples veces, ahorrando el coste de un reanálisis. Esto se utlilza comúnmente para sentencias INSERT cuando los datos están vinculados con oci_bind_by_name().

Parámetros

statement

Un identificador de sentencia de OCI válido.

mode

Este segundo parámetro opcional puede ser una de las siguietnes constantes:

Modos de ejecución
Constante | Descripción
OCI_COMMIT_ON_SUCCESS | Consolida automáticamente todos los cambios pendientes de esta conexión cuando la sentencia ha tenido éxito. Es la predetermianda.
OCI_DESCRIBE_ONLY | Dispone los metadatos de la consulta a funciones como oci_field_name(), pero no crea un conjunto de resultados. Cualquier llamada de obtención subsiguiente, como con oci_fetch_array(), fallará.
OCI_NO_AUTO_COMMIT | No consolida automáticamete los cambios. Antes de PHP 5.3.2 (PECL OCI8 1.4) use OCI_DEFAULT, la cual es equivalente a OCI_NO_AUTO_COMMIT.

Al usar el modo OCI_NO_AUTO_COMMIT se inicia o continua una transacción. Las transacciones son automáticamente revertidas cuando la conexión se cierra, o cuando el script finaliza. Para consolidar explícitamente una trasacción, invoque a oci_commit(), o a oci_rollback() para abortarla.

Cuando se insertar o actualizan datos, se recomienda usar transacciones para mantener la consistencia de datos relacionales y por razones de rendimiento.

Si se usa el modo OCI_NO_AUTO_COMMIT para cualquier sentencia, incluyendo consultas, y no se llama posteriormente a oci_commit() o oci_rollback(), OCI8 realizará una reversión al final del script incluso si no se modificó ningún dato. Para evitar reversiones innecesarias, muchos scripts no usan el modo OCI_NO_AUTO_COMMIT para consultas o PL/SQL. Tenga cuidado de asegurar la consistencia transaccional apropiada para la aplicación cuando use oci_execute() con diferentes modos en el mismo script.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 oci_execute() para consultas

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($fila = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($fila as $elemento) {
        echo "    <td>" . ($elemento !== null ? htmlentities($elemento, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Ejemplo #2 Ejemplo de oci_execute() sin especificar un modo

<?php

// Antes de ejecutarlo, cree la tabla:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');

oci_execute($stid); // La fila se consolida y es visible inmediatamente a otros usuarios

?>

Ejemplo #3 Ejemplo de oci_execute() con OCI_NO_AUTO_COMMIT

<?php

// Antes de ejecutarlo, cree la tabla:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $i, 10);
for ($i = 1; $i <= 5; ++$i) {
    oci_execute($stid, OCI_NO_AUTO_COMMIT);  // use OCI_DEFAULT para PHP <= 5.3.1
}
oci_commit($conn);  // consolida todos los nuevos valores: 1, 2, 3, 4, 5

?>

Ejemplo #4 Ejemplo de oci_execute() con diferentes modos de consolidación

<?php

// Antes de ejecutarlo, cree la tabla:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');
oci_execute($stid, OCI_NO_AUTO_COMMIT);  // datos no consolidados

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (456)');
oci_execute($stid);  // consolida tanto el valor 123 como 456

?>

Ejemplo #5 Ejemplo de oci_execute() con OCI_DESCRIBE_ONLY

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM locations');
oci_execute($s, OCI_DESCRIBE_ONLY);
for ($i = 1; $i <= oci_num_fields($stid); ++$i) {
    echo oci_field_name($stid, $i) . "<br>\n";
}

?>

Notas

Nota:

Las transacciones son automáticamente revertidas cuando se cierran las conexiones, o cuando el script finaliza, lo que ocurra antes. Para consolidar explícitamente una transacción, invoque a oci_commit().

Cualquier llamada a oci_execute() que use el modo OCI_COMMIT_ON_SUCCESS, explícitamente o por omisión, consolidará cualquier transacción no consolidada anterioremente.

Cualquier sentencia DDL de Oracle, como CREATE o DROP, consolidará automáticamente cualquier transacción no consolidada.

Nota:

Debido a que la función oci_execute() generalmente envía la sentencia a la base de datos, oci_execute() puede identificar algunos errores de sintaxis que no identifica la función ligera local oci_parse().

Ver también

  • oci_parse() - Prepara una sentencia de Oracle para su ejecución


Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional

  • « oci_execute
  • oci_fetch_array »
  • PHP Manual
  • Funciones de OCI8
  • Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional

oci_fetch_all

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_all — Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional

Descripción

oci_fetch_all ( resource $statement , array &$output , int $skip = 0 , int $maxrows = -1 , int $flags = OCI_FETCHSTATEMENT_BY_COLUMN + OCI_ASSOC ) : int

Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional. Por omisión, se devuelven todas las filas.

Esta función puede ser llamada únicamente una vez por cada consulta ejecutada con oci_execute().

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

output

La variable que contiene las filas devueltas.

Las columnas LOB son devueltas como cadenas, donde Oracle admite la conversión.

Véase oci_fetch_array() para más información sobre cómo se obtienen los datos y los tipos.

skip

El número de filas iniciales a descartar cuando se obtiene el resultado. El valor predeterminado es 0, por lo que se devuelve la primera fila en adelante.

maxrows

El número de filas a devolver. El valor predeterminado es -1, lo que significa que se devuelven todas las filas desde skip + 1 en adelante.

flags

El parámetro flags indica la estructura del array y si se deberían usar arrays asociativos.

Modos de estructura del array de oci_fetch_all()
Constante | Descripción
OCI_FETCHSTATEMENT_BY_ROW | El array externo contendrá un subarray por cada fila de la consulta.
OCI_FETCHSTATEMENT_BY_COLUMN | El array externo contendrá un subarray por cada columna de la consulta. Esto es lo predeterminado.

Los arrays se pueden indexar por encabezado de columna o numéricamente. Solamente será devuelto un modo de indexación.

Modos de indexación del array de oci_fetch_all()
Constante | Descripción
OCI_NUM | Se utilizan índices numéricos por cada array de columna.
OCI_ASSOC | Se utilizan índices asociativos por cada array de columna. Esto es lo predeterminado.

Utilice el operador de adición "+" para elegir una combinación de modos de estructura e índice del array.

Los nombres de columna predeterminados de Oracle insensibles al uso de mayúsculas/minúsculas tendrán claves de array en mayúsculas. Los nombres de columnas sensibles al uso de mayúsculs/minúsculas tendrán claves de array que usan el nombre exacto de la columna. Use var_dump() en output para verificar el uso apropiado de mayúsculas/minúsculas en cada consulta.

Las consultas que tienen más de una columna con el mismo nombre deberían usar un alias de columna. Si no, aparecerá únicamente una de las columnas en el array asociativo.

Valores devueltos

Devuelve el número de filas de output, el cual podría ser cero o más, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_fetch_all()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res);

echo "$nrows filas obtenidas<br>\n";
var_dump($res);

// la salida de var_dump es:
//    2 filas obtenidas
//    array(2) {
//      ["POSTAL_CODE"]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(6) "10934x"
//      }
//      ["CITY"]=>
//      array(2) {
//        [0]=>
//        string(4) "Roma"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

// Imprimir los resultados de forma legible
echo "<table border='1'>\n";
foreach ($res as $col) {
    echo "<tr>\n";
    foreach ($col as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 Ejemplo de oci_fetch_all() con OCI_FETCHSTATEMENT_BY_ROW

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW);

echo "$nrows filas obtenidas<br>\n";
var_dump($res);

// La salida es:
//    2 filas obtenidas
//    array(2) {
//      [0]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "00989x"
//        ["CITY"]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "10934x"
//        ["CITY"]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #3 oci_fetch_all() con OCI_NUM

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW + OCI_NUM);

echo "$nrows filas obtenidas<br>\n";
var_dump($res);

// La salida es:
//    2 filas obtenidas
//    array(2) {
//      [0]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        [0]=>
//        string(6) "10934x"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Usar skip es muy ineficiente. Todas las filas que van a omitirse están incluidas en el conjunto de resultados que es devuelto desde la base de datos a PHP. Luego son excluidas. Es más eficiente usar SQL para restringir el índice y el rango de filas de las consultas. Véase oci_fetch_array() para un ejemplo.

Nota:

Las consultas que devuelven un número grande de filas pueden usar la memoria de forma más eficiente si se utiliza una función que obtiene una sola fila, como oci_fetch_array().

Nota:

Para consultas que devuelven un gran número de filas, se puede mejorar el rendimiento significativamente incrementando oci8.default_prefetch o utilizando oci_set_prefetch().

Nota:

No se devolverán filas desde Conjuntos de Resultados Implícitos de Oracle Database 12c. Use oci_fetch_array() en su lugar.

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico
  • oci_set_prefetch() - Establece el número de filas a precargar mediante consultas


Devuelve la siguiente fila de una consulta como un array asociativo o numérico

  • « oci_fetch_all
  • oci_fetch_assoc »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la siguiente fila de una consulta como un array asociativo o numérico

oci_fetch_array

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_array — Devuelve la siguiente fila de una consulta como un array asociativo o numérico

Descripción

oci_fetch_array ( resource $statement , int $mode = ? ) : array

Devuelve un array que contiene la siguiente fila del conjunto de resultados de una consulta. Cada entrada del array corresponde a una columna de la fila. Esta función se invoca normamente en un bucle hasta que devuelva false, indicando que no existen más filas.

Si statement se corresponde con un bloque de PL/SQL devuelto por Conjuntos de Resultados Implícitos de Oracle Database 12c, entonces las filas de todos los conjuntos se obtienen consecutivamente. Si statement es devuelto por oci_get_implicit_resultset(), solamente son devueltos los subconjuntos de filas para una consulta hija.

Para más detalles sobre cómo la extensión OCI8 realiza la correspondencia entre tipos de datos, véasen los tipos de datos admitidos por el controlador

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

También puede ser un identificador de sentencia devuelto por oci_get_implicit_resultset().

mode

Este segundo parámetro opcional puede ser cualquier combinación de las siguientes contantes:

Modos de oci_fetch_array()
Constante | Descripción
OCI_BOTH | Devuelve un array con índices tanto asociativos como numéricos. Es lo mismo que con OCI_ASSOC + OCI_NUM. Es el comportamiento predeterminado.
OCI_ASSOC | Devuelve un array asociativo.
OCI_NUM | Devuelve un array numérico.
OCI_RETURN_NULLS | Crea elementos para campos null. Los valores de los elementos serán null de PHP.
OCI_RETURN_LOBS | Devuelve el contenido de los LOB en lugar de los descriptores de los mismos.

El valor predeterminado de mode es OCI_BOTH.

Use el operador de adición "+" para especificar más de un modo a la vez.

Valores devueltos

Devuelve un array con los índices asociativos y/o numéricos. Si no existen más filas en statement, devolverá false.

Por omisión, las columnas LOB son devueltas como descriptores LOB.

Las columnas DATE son devueltas como string con el formato de fecha actual. El formato predeterminado se puede cambiar con las variables de entorno de Oracle, como NLS_LANG, o ejecutando previamente un comando ALTER SESSION SET NLS_DATE_FORMAT.

Los nombres de columna predeterminados de Oracle que no consideran mayúsculas/minúsculas tendrán claves de array en mayúsculas. Los nombres de columnas sensibles al uso de mayúsculas/minúsculas tendrán claves de array que usan el nombre exacto de la columna. Use var_dump() en el array resultante para verificar el uso apropiado de mayúsculas/minúsculas en cada consulta.

El nombre de la tabla no está incluído en el índice del array. Si la consulta contiene dos columnas diferentes con el mismo nombre, use OCI_NUM o añada un alias de columna a la consulta para asegurarse de la unicidad de los nombres (véase el ejemplo #7). De lo contrario, solamente será devuelta una columna mediante PHP.

Ejemplos

Ejemplo #1 oci_fetch_array() con OCI_BOTH

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_BOTH)) != false) {
    // Usar nombres de columna en mayúsculas para los índices del array asociativo
    echo $row[0] . " y " . $row['DEPARTMENT_ID']   . " son lo mismo<br>\n";
    echo $row[1] . " y " . $row['DEPARTMENT_NAME'] . " son lo mismo<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 oci_fetch_array() con OCI_NUM

<?php

/*
  Antes de ejecutarlo, cree la tabla:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'Un string muy largo');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_NUM)) != false) {
    echo $row[0] . "<br>\n";
    echo $row[1]->read(11) . "<br>\n"; // esto imprimirá los primeros 11 bytes de DESCRIPTION
}

// La salida es:
//    1
//    Un string m

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #3 oci_fetch_array() con OCI_ASSOC

<?php

/*
  Antes de ejecutarlo, cree la tabla:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'Un string muy largo');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION']->read(11) . "<br>\n"; // esto imprimirá los primeros 11 bytes de DESCRIPTION
}

// La salida es:
//    1
//    Un string m

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #4 oci_fetch_array() con OCI_RETURN_NULLS

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC)) != false) { // Ignorar los NULL
    var_dump($row);
}

/*
El código de arriba imprime:
  array(1) {
    [1]=>
    string(1) "1"
  }
*/

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) { // Obtener los NULL
    var_dump($row);
}

/*
El código de arriba imprime:
  array(2) {
    [1]=>
    string(1) "1"
    ["NULL"]=>
    NULL
  }
*/

?>

Ejemplo #5 oci_fetch_array() con OCI_RETURN_LOBS

<?php

/*
  Antes de ejecutarlo, cree la tabla:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'Un string muy largo');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION'] . "<br>\n"; // contiene todo lo de DESCRIPTION
    // En un bucle, liberar la variable grande de la 2ª obtención reduce en uso de memoria de picos de PHP
    unset($row);
}

// La salida es:
//    1
//    Un string muy largo

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #6 oci_fetch_array() con nombres de columna sensibles al uso de mayúsculas/minúsculas

<?php

/*
  Antes de ejecutarlo, cree la tabla:
      CREATE TABLE mytab ("Name" VARCHAR2(20), city VARCHAR2(20));
      INSERT INTO mytab ("Name", city) values ('Chris', 'Melbourne');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'select * from mytab');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);

// Ya que 'Name' fue creado como columna sensible al uso de mayúsculas/minúsculas,
// se usa lo mismo para el índice del array. Sin embargo, debe usarse 'CITY' en
// mayúsculas para los índices de columna insensibles al uso de mayúsculas/minúsculas
print $row['Name'] . "<br>\n";   //  imprime Chris
print $row['CITY'] . "<br>\n";   //  imprime Melbourne

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #7 oci_fetch_array() con columnas que tienen nombres duplicados

<?php

/*
  Antes de ejecutarlo, cree la tabla:
      CREATE TABLE mycity (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycity (id, name) values (1, 'Melbourne');
      CREATE TABLE mycountry (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycountry (id, name) values (1, 'Australia');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT mycity.name, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// La salida únicamente contiene la entrada "NAME":
//    array(1) {
//      ["NAME"]=>
//      string(9) "Australia"
//    }

// En consultas con nombres de columnas repetidos use un alias de columna de SQL, como "AS ctnm":
$sql = 'SELECT mycity.name AS ctnm, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// La salida ahora contiene ambas columnas seleccionadas:
//    array(2) {
//      ["CTNM"]=>
//      string(9) "Melbourne"
//      ["NAME"]=>
//      string(9) "Australia"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #8 oci_fetch_array() con columnas DATE

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Establecer el formato de fecha para esta conexión.
// Por razones de rendimiento, considere cambiar el formato
// en un disparador o con variables de entorno en su lugar
$stid = oci_parse($conn, "ALTER SESSION SET NLS_DATE_FORMAT = 'YYYY-MM-DD'");
oci_execute($stid);

$stid = oci_parse($conn, 'SELECT hire_date FROM employees WHERE employee_id = 188');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
echo $row['HIRE_DATE'] . "<br>\n";  // imprime 1997-06-14

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #9 oci_fetch_array() con REF CURSOR

<?php
/*
  Cree el procedimiento almacenado PL/SQL:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Ejecutar el REF CURSOR devuelto y obtenerlo como un identificador de sentencia
oci_execute($refcur);
echo "<table border='1'>\n";
while ($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #10 Paginación con oci_fetch_array() usando una consulta como LIMIT

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Buscar la versión de la base de datos
preg_match('/Release ([0-9]+)\./', oci_server_version($conn), $matches);
$oracleversion = $matches[1];

// Esta es la consulta que se quiere "paginar"
$sql = 'SELECT city, postal_code FROM locations ORDER BY city';

if ($oracleversion >= 12) {
    // Usar la sintaxis de Oracle 12c de OFFSET / FETCH NEXT
    $sql = $sql . ' OFFSET :offset ROWS FETCH NEXT :numrows ROWS ONLY';
} else {
    // Versiones antiguas de Oracle necesitaban una consulta anidada para
    // seleccionar un subconjunto de $sql. O, si la sentencia SQL es conocida
    // durante el desarrollo, considere usar una función row_number() en lugar
    // de esta solución anidada. En entornos de producción, tenga cuidado para
    // evitar problemas con inyecciones SQL con concatenaciones.
    $sql = "SELECT * FROM (SELECT a.*, ROWNUM AS my_rnum
                           FROM ($sql) a
                           WHERE ROWNUM <= :offset + :numrows)
            WHERE my_rnum > :offset";
}

$offset  = 0;  // saltar estas filas
$numrows = 5;  // devolver 5 filas
$stid = oci_parse($conn, $sql);
oci_bind_by_name($stid, ':numrows', $numrows);
oci_bind_by_name($stid, ':offset', $offset);
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC + OCI_RETURN_NULLS)) != false) {
    echo $row['CITY'] . " " . $row['POSTAL_CODE'] . "<br>\n";
}

// La salida es:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    Geneva 1730
//    Hiroshima 6823

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #11 oci_fetch_array() con Conjuntos de Resultados Implícitos de Oracle Database 12c

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Requiere OCI8 2.0 y Oracle Database 12c
// Véase también oci_get_implicit_resultset()
$sql = 'DECLARE
           c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Nota: oci_fetch_all y oci_fetch() no se pueden usar de esta manera
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// La salida es:
//    Beijing 190518
//    Bern    3095
//    Bombay  490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Los índices de arrays asociativos tienen que estar en mayúsculas para las columnas estándar de Oracle que fueron creadas con nombres insensibles al uso de mayúsculas/minúsculas.

Nota:

Para consultas que devuelven un gran número de filas, se puede mejorar el rendimiento significativamente incrementando oci8.default_prefetch o utilizando oci_set_prefetch().

Nota:

La función oci_fetch_array() es insignificativamente más lenta que oci_fetch_assoc() o oci_fetch_row(), pero es más flexible.

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico
  • oci_set_prefetch() - Establece el número de filas a precargar mediante consultas


Devuelve la siguiente fila de una consulta como un array asociativo

  • « oci_fetch_array
  • oci_fetch_object »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la siguiente fila de una consulta como un array asociativo

oci_fetch_assoc

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_assoc — Devuelve la siguiente fila de una consulta como un array asociativo

Descripción

oci_fetch_assoc ( resource $statement ) : array

Devuelve un array asociativo que contiene la siguiente fila del conjunto de resultados de una consulta. Cada entrada del array corresponde a una columna de la fila. Esta función se invoca normalmante en un bucle hasta que devuelve false, indicando que no existen más filas.

Llamar a oci_fetch_assoc() es idéntico a llamar a oci_fetch_array() con OCI_ASSOC + OCI_RETURN_NULLS.

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

Valores devueltos

Devuelve un array asociativo. Si no existen más filas en el parámetro statement, entonces devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de oci_fetch_assoc()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_assoc($stid)) != false) {
    echo $row['DEPARTMENT_ID'] . " " . $row['DEPARTMENT_NAME'] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Véase oci_fetch_array() para más ejemplos de obtención de filas.

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico


Devuelve la siguiente fila de una consulta como un objeto

  • « oci_fetch_assoc
  • oci_fetch_row »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la siguiente fila de una consulta como un objeto

oci_fetch_object

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_object — Devuelve la siguiente fila de una consulta como un objeto

Descripción

oci_fetch_object ( resource $statement ) : object

Devuelve un objeto que contiene la siguiente fila del conjunto de resultados de una consulta. Cada atributo del objeto corresponde a una columna de la fila. Esta función normalmente es invocada en un bucle hasta que devuelve false, indicando que no existen más filas.

Para más detalles sobre cómo la extensión OCI8 realiza la correspondencia entre tipos de datos, véasen los tipos de datos admitidos por el controlador

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

Valores devueltos

Devuelve un objeto. Cada atributo del mismo corresponde a una columna de la fila. Si no existen más filas en el parámetro statement, entonces devuelve false.

Cualquier columna LOB es devuelta como un descriptor de LOB.

Las columnas DATE son devueltas como string con el formato de fecha actual. El formato predeterminado se puede cambiar con las variables de entorno de Oracle, como NLS_LANG, o ejecutando previamente un comando ALTER SESSION SET NLS_DATE_FORMAT.

Los nombres de columna predeterminados de Oracle que insensibles al uso de mayúsculas/minúsculas tendrán nombres de atributos en mayúsculas. Los nombres de columnas sensibles al uso de mayúsculas/minúsculas tendrán nombres de atributos que usan el nombre exacto de la columna. Use var_dump() en el array resultante para verificar el uso apropiado de mayúsculas/minúsculas en cada acceso al atributo.

Los valores de los atributos serán null para cualquier campo de datos NULL.

Ejemplos

Ejemplo #1 Ejemplo de oci_fetch_object()

<?php

/*
  Antes de ejecutarlo, cree la tabla:
    CREATE TABLE mytab (id NUMBER, description VARCHAR2(30));
    INSERT INTO mytab (id, description) values (1, 'Fish and Chips');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use nombres de atributo en mayúsculas para cada columna estándar de Oracle
    echo $row->ID . "<br>\n";
    echo $row->DESCRIPTION . "<br>\n";
}

// La salida es:
//    1
//    Fish and Chips

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 oci_fetch_object() con nombres de columnas sensibles al uso de mayúsculas/minúsculas

<?php

/*
  Antes de ejecutarlo, cree la tablas con un nombre de columna sensible al uso de mayúsculas/minúsculas:
    CREATE TABLE mytab (id NUMBER, "MyDescription" VARCHAR2(30));
    INSERT INTO mytab (id, "MyDescription") values (1, 'Iced Coffee');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, "MyDescription" FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use nombres de atributo en mayúsculas para cada columna estándar de Oracle
    echo $row->ID . "<br>\n";
    // Use el nombre exacto para nombres de columnas sensibles al uso de mayúsculas/minúsculas
    echo $row->MyDescription . "<br>\n";
}

// La salida es:
//    1
//    Iced Coffee

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #3 oci_fetch_object() con LOBs

<?php

/*
  Antes de ejecutarlo, cree la tabla:
    CREATE TABLE mytab (id NUMBER, description CLOB);
    INSERT INTO mytab (id, description) values (1, 'Un string muy largo');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    echo $row->ID . "<br>\n";
    // Lo siguiente imprimirá los primeros 11 bytes de DESCRIPTION
    echo $row->DESCRIPTION->read(11) . "<br>\n";
}

// La salida es:
//    1
//    Un string m

oci_free_statement($stid);
oci_close($conn);

?>

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico


Devuelve la siguiente fila de una consulta como un array numérico

  • « oci_fetch_object
  • oci_fetch »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la siguiente fila de una consulta como un array numérico

oci_fetch_row

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_row — Devuelve la siguiente fila de una consulta como un array numérico

Descripción

oci_fetch_row ( resource $statement ) : array

Devuelve un array con índices numéricos que contiene la siguiente fila del conjunto de resultados de una consulta. Cada entrada del array corresponde con una columna de la fila. Esta función normalmente se invoca en un bucle hasta que devuelve false, indicando que no existen más filas.

Llamar a oci_fetch_row() es idéntico que llamar a oci_fetch_array() con OCI_NUM + OCI_RETURN_NULLS.

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

Valores devueltos

Devuelve un array con índices numéricos. Si no existen más filas en el parámetro statement, entonces devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de oci_fetch_row()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_row($stid)) != false) {
    echo $row[0] . " " . $row[1] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Véase oci_fetch_array() para más ejemplos de obtención de filas.

Ver también

  • oci_fetch() - Coloca la siguiente fila de una consulta en los búferes internos
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto


Coloca la siguiente fila de una consulta en los búferes internos

  • « oci_fetch_row
  • oci_field_is_null »
  • PHP Manual
  • Funciones de OCI8
  • Coloca la siguiente fila de una consulta en los búferes internos

oci_fetch

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch — Coloca la siguiente fila de una consulta en los búferes internos

Descripción

oci_fetch ( resource $statement ) : bool

Coloca la siguiente fila de una consulta en los búferes internos, accesibles mediante oci_result(), o usando varibles previamente definidas con oci_define_by_name().

Véase oci_fetch_array() para información general sobre la obtención de datos.

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

Valores devueltos

Devuelve true en caso de éxito, o false si no existen más filas en el parámetro statement.

Ejemplos

Ejemplo #1 oci_fetch() con variables definidas

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);

// Las definiciones DEBEN realizarse antes de la ejecución
oci_define_by_name($stid, 'LOCATION_ID', $locid);
oci_define_by_name($stid, 'CITY', $city);

oci_execute($stid);

// Cada obtención rellena las variables anteriormente definidas con los datos de la siguiente fila
while (oci_fetch($stid)) {
    echo "El id de ubicacion $locid es $city<br>\n";
}

// Se muestra:
//   El id de ubicacion 1000 es Roma
//   El id de ubicacion 1100 es Venice

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 oci_fetch() con oci_result()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (oci_fetch($stid)) {
    echo oci_result($stid, 'LOCATION_ID') . " es ";
    echo oci_result($stid, 'CITY') . "<br>\n";
}

// Se muestra:
//   1000 es Roma
//   1100 es Venice

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

No se devolverán filas desde Conjuntos de Resultados Implícitos de Oracle Database 12c. Use oci_fetch_array() en su lugar.

Ver también

  • oci_define_by_name() - Asocia una variable de PHP con una columna para la obtención de consultas
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico
  • oci_result() - Devuelve el valor de un campo de la fila obtenida


Comprueba si un campo de la fila actualmente obtenida es null

  • « oci_fetch
  • oci_field_name »
  • PHP Manual
  • Funciones de OCI8
  • Comprueba si un campo de la fila actualmente obtenida es null

oci_field_is_null

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_is_null — Comprueba si un campo de la fila actualmente obtenida es null

Descripción

oci_field_is_null ( resource $statement , mixed $field ) : bool

Comprueba si el campo especificado por field de de la fila actual de la sentencia dada por statement es null.

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser el índice de campo (basado en 1) o el nombre.

Valores devueltos

Devuelve true si field es null, false si no.

Ejemplos

Ejemplo #1 Ejemplo de oci_field_name()

<?php

// Crear una tabla con:
//   CREATE TABLE mytab (c1 NUMBER);
//   INSERT INTO mytab VALUES (1);
//   INSERT INTO mytab VALUES (NULL);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_RETURN_NULLS)) != false) {
    $ncols = oci_num_fields($stid);
    for ($col = 1; $col <= $ncols; $col++) {
        var_dump(oci_field_is_null($stid, $col));
    }
}

// Salidas:
//    bool(false)
//    bool(true)

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumnisnull() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_is_null() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Devuelve el nombre de un campo de una sentencia

  • « oci_field_is_null
  • oci_field_precision »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el nombre de un campo de una sentencia

oci_field_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_name — Devuelve el nombre de un campo de una sentencia

Descripción

oci_field_name ( resource $statement , mixed $field ) : string

Devuelve el nombre del campo dado por field.

Parámetros

statement

Un identifidacor de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devuelve el nombre como una cadena, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_field_name()

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Salidas:
//    Name           Type
//    NUMBER_COL    NUMBER
//    VARCHAR2_COL  VARCHAR2
//    CLOB_COL      CLOB
//    DATE_COL      DATE

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumnname() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_name() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_num_fields() - Devuelve el número de columnas del resultado de una sentencia
  • oci_field_type() - Devuelve el nombre del tipo de datos de un campo
  • oci_field_size() - Devuelve el tamaño de un campo


Indica la precisión de un campo

  • « oci_field_name
  • oci_field_scale »
  • PHP Manual
  • Funciones de OCI8
  • Indica la precisión de un campo

oci_field_precision

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_precision — Indica la precisión de un campo

Descripción

oci_field_precision ( resource $statement , mixed $field ) : int

Devuelve la precisión del campo dado por field.

Para columnas FLOAT, la precisión no es cero y la escala es -127. Si la precisión es cero, entonces la columna es NUMBER. Otro número indica NUMBER(precisión, precisión).

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devuelve la precisión como un entero, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_field_precision()

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (c1 NUMBER, c2 FLOAT, c3 NUMBER(4), c4 NUMBER(5,3));

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " "
        . oci_field_precision($stid, $i) . " "
        . oci_field_scale($stid, $i) . "<br>\n";
}

// Salidas:
//   C1    0 -127
//   C2  126 -127
//   C3    4    0
//   C4    5    3

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumnprecision() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_precision() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_field_scale() - Indica la escala de un campo
  • oci_field_type() - Devuelve el nombre del tipo de datos de un campo


Indica la escala de un campo

  • « oci_field_precision
  • oci_field_size »
  • PHP Manual
  • Funciones de OCI8
  • Indica la escala de un campo

oci_field_scale

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_scale — Indica la escala de un campo

Descripción

oci_field_scale ( resource $statement , mixed $field ) : int

Devuelve la escala de la columna con índice field.

Para columnas FLOAT, la precisión no es cero y la escala es -127. Si la precisión es cero, entonces la columna es NUMBER. Otro número indica NUMBER(precisión, precisión).

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devuelve la escala como un entero, o false en caso de error.

Ejemplos

Ejemplo #1 oci_field_scale() Example

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (c1 NUMBER, c2 FLOAT, c3 NUMBER(4), c4 NUMBER(5,3));

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " "
        . oci_field_precision($stid, $i) . " "
        . oci_field_scale($stid, $i) . "<br>\n";
}

// Salidas:
//   C1    0 -127
//   C2  126 -127
//   C3    4    0
//   C4    5    3

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumnscale() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_scale() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_field_precision() - Indica la precisión de un campo
  • oci_field_type() - Devuelve el nombre del tipo de datos de un campo


Devuelve el tamaño de un campo

  • « oci_field_scale
  • oci_field_type_raw »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el tamaño de un campo

oci_field_size

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_size — Devuelve el tamaño de un campo

Descripción

oci_field_size ( resource $statement , mixed $field ) : int

Devuelve el tamaño del campo dado por field.

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devuelve el tamaño de field en bytes, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_field_size()

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);
    $column_size  = oci_field_size($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Salidas:
//    Name           Type       Length
//    NUMBER_COL    NUMBER        22
//    VARCHAR2_COL  VARCHAR2       1
//    CLOB_COL      CLOB        4000
//    DATE_COL      DATE           7

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumnsize() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_size() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_num_fields() - Devuelve el número de columnas del resultado de una sentencia
  • oci_field_name() - Devuelve el nombre de un campo de una sentencia


Indica el tipo de datos sin tratar de Oracle de un campo

  • « oci_field_size
  • oci_field_type »
  • PHP Manual
  • Funciones de OCI8
  • Indica el tipo de datos sin tratar de Oracle de un campo

oci_field_type_raw

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_type_raw — Indica el tipo de datos sin tratar de Oracle de un campo

Descripción

oci_field_type_raw ( resource $statement , mixed $field ) : int

Devuelve el tipo de datos "SQLT" sin tratar de Oracle del campo dado por field.

Si se quiere obtener el nombre de tipo del campo, es mejor usar oci_field_type().

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devueleve el tipo de datos sin tratar de Oracle como un número, o false en caso de error.

Ejemplos

Ejemplo #1 oci_field_type_raw() Example

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1), clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'select * from mytab');
oci_execute($stid, OCI_DESCRIBE_ONLY);  // Use OCI_DESCRIBE_ONLY if not fetching rows
$n = oci_num_fields($stid);
for ($i = 1; $i <= $n; ++$i) {
    echo oci_field_name($stid, $i) . " is raw type: " . oci_field_type_raw($stid, $i) . "<br>\n";
}

// La salida es:
//    NUMBER_COL is raw type: 2
//    VARCHAR2_COL is raw type: 1
//    CLOB_COL is raw type: 112
//    DATE_COL is raw type: 12

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumntyperaw() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_type_raw() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Devuelve el nombre del tipo de datos de un campo

  • « oci_field_type_raw
  • oci_free_descriptor »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el nombre del tipo de datos de un campo

oci_field_type

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_type — Devuelve el nombre del tipo de datos de un campo

Descripción

oci_field_type ( resource $statement , mixed $field ) : mixed

Devuelve el nombre del tipo de datos de un campo.

Parámetros

statement

Un identificador de sentencia de OCI válido.

field

Puede ser un índice de campo (basado en 1) o un nombre.

Valores devueltos

Devuelve el tipo de datos de un campo como una cadena, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_field_type()

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY si no se obtienen filas

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);
    $column_size  = oci_field_size($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Salidas:
//    Name           Type       Length
//    NUMBER_COL    NUMBER        22
//    VARCHAR2_COL  VARCHAR2       1
//    CLOB_COL      CLOB        4000
//    DATE_COL      DATE           7

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocicolumntype() en su lugar. Este nombre aún se puede usar; se dejó como un alias de oci_field_type() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_num_fields() - Devuelve el número de columnas del resultado de una sentencia
  • oci_field_name() - Devuelve el nombre de un campo de una sentencia
  • oci_field_size() - Devuelve el tamaño de un campo


Libera un descriptor

  • « oci_field_type
  • oci_free_statement »
  • PHP Manual
  • Funciones de OCI8
  • Libera un descriptor

oci_free_descriptor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_free_descriptor — Libera un descriptor

Descripción

oci_free_descriptor ( resource $descriptor ) : bool

Libera un descriptor asignado por oci_new_descriptor().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función se utiliza comúnmente como un método OCI-LOB::free.

Ver también

  • OCI-LOB::free


Libera todos los recursos asociados con una sentencia o cursor

  • « oci_free_descriptor
  • oci_get_implicit_resultset »
  • PHP Manual
  • Funciones de OCI8
  • Libera todos los recursos asociados con una sentencia o cursor

oci_free_statement

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_free_statement — Libera todos los recursos asociados con una sentencia o cursor

Descripción

oci_free_statement ( resource $statement ) : bool

Libera los recursos asociados con un cursor o sentencia de Oracle, el cual fue recibido desde una resultado de oci_parse() u obtenido desde Oracle.

Parámetros

statement

Un identificador de sentecia válido de OCI.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c

  • « oci_free_statement
  • oci_lob_copy »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c

oci_get_implicit_resultset

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL OCI8 >= 2.0.0)

oci_get_implicit_resultset — Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c

Descripción

oci_get_implicit_resultset ( resource $statement ) : resource

Usado para obtener conjuntos consecutivos de resultados de consultas destpués de la ejecución de un bloque almacenado o anónimo de PL/SQL de Oracle cuando dicho bloque devuelve resultados de consultas con la función de PL/SQL DBMS_SQL.RETURN_RESULT de Oracle. Esto permite a los bloques de PL/SQL devolver fácilmente resultados de consultas.

La sentencia hija puede usarse con cualquier función de obtención
de OCI8: oci_fetch(), oci_fetch_all(),
oci_fetch_array(), oci_fetch_object(),
oci_fetch_assoc() or oci_fetch_row()

Las sentencias hijas heredan el valor de precarga de sus sentencias padres, o se puede establecer explícitamente con oci_set_prefetch().

Parámetros

statement

Un identificador de sentencia OCI8 válido creado mediante oci_parse() y ejecutada por oci_execute(). El identificador de sentencia podría o no estar asociado con una sentencia SQL que devuelva Conjuntos de resultados implícitos.

Valores devueltos

Devuelve un gestor de sentencia para la siguiente sentencia hija disponible en statement. Devuelve false cuando no existan sentencias hijas, o todas las sentencia hijas han sido devueltas por llamadas anteriores a oci_get_implicit_resultset().

Ejemplos

Ejemplo #1 Obtener Conjuntos de resultados implícitos en un blucle

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (($stid_c = oci_get_implicit_resultset($stid))) {
    echo "<h2>Nuevo Conjunto de resultados implícitos:</h2>\n";
    echo "<table>\n";
    while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
        echo "<tr>\n";
        foreach ($row as $item) {
            echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"")."</td>\n";
        }
        echo "</tr>\n";
    }
    echo "</table>\n";
}

// La salida es:
//    Nuevo Conjunto de resultados implícitos:
//     Beijing 190518
//     Bern    3095
//     Bombay  490231
//    Nuevo Conjunto de resultados implícitos:
//     CN
//     CH
//     IN

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 Obtener gestores de sentencias hijas individualemente

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_1 = oci_get_implicit_resultset($stid);
$stid_2 = oci_get_implicit_resultset($stid);

$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);

// La salida es:
//    array(2) {
//      ["CITY"]=>
//      string(7) "Beijing"
//      ["POSTAL_CODE"]=>
//      string(6) "190518"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CN"
//    }
//    array(2) {
//      ["CITY"]=>
//      string(4) "Bern"
//      ["POSTAL_CODE"]=>
//      string(4) "3095"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CH"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #3 Establecer explícitamente la Cuenta de precarga

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_c = oci_get_implicit_resultset($stid);
oci_set_prefetch($stid_c, 200);   // Set the prefetch before fetching from the child statement
echo "<table>\n";
while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #4 Ejemplo de Conjunto de resultados implícitos sin usar oci_get_implicit_resultset()

Todos los resultados de todas las consultas son devueltas consecutivamente.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Note: oci_fetch_all y oci_fetch() no se pueden usar de esta manera
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// La salida es:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Para consultas que devuelven un gran número de filas, se puede mejorar el rendimiento significativamente incrementando oci8.default_prefetch o utilizando oci_set_prefetch().


Copia objetos grandes

  • « oci_get_implicit_resultset
  • oci_lob_is_equal »
  • PHP Manual
  • Funciones de OCI8
  • Copia objetos grandes

oci_lob_copy

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_lob_copy — Copia objetos grandes

Descripción

oci_lob_copy ( OCI-Lob $lob_to , OCI-Lob $lob_from , int $length = 0 ) : bool

Copia un objeto grande, o una parte del mismo, a otro objeto grande. Los datos de recipientes LOB antiguos serán sobrescritos.

Si fuera necesario copiar una parte en particular de un LOB a una posición en particular de otro LOB, use OCI-Lob::seek() para mover el puntero interno del LOB.

Parámetros

lob_to

El LOB de destino.

lob_from

El LOB copiado.

length

Indica la longitud de los datos a copiar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Compara dos localizadores LOB/FILE

  • « oci_lob_copy
  • oci_new_collection »
  • PHP Manual
  • Funciones de OCI8
  • Compara dos localizadores LOB/FILE

oci_lob_is_equal

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_lob_is_equal — Compara dos localizadores LOB/FILE

Descripción

oci_lob_is_equal ( OCI-Lob $lob1 , OCI-Lob $lob2 ) : bool

Compara dos localizadores LOB/FILE.

Parámetros

lob1

Un identificador LOB.

lob2

Un identificador LOB.

Valores devueltos

Devuelve true si los objetos son iguales, false si no.


Asigna un nuevo objeto colección

  • « oci_lob_is_equal
  • oci_new_connect »
  • PHP Manual
  • Funciones de OCI8
  • Asigna un nuevo objeto colección

oci_new_collection

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_collection — Asigna un nuevo objeto colección

Descripción

oci_new_collection ( resource $connection , string $tdo , string $schema = null ) : OCI-Collection

Asigna un nuevo objeto colección.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect() o oci_pconnect().

tdo

Debería ser un tipo con nombre válido (en mayúsculas).

schema

Debería apuntar al esquema donde fue creado el tipo con nombre. El nombre del usuario actual es el valor predeterminado.

Valores devueltos

Devuelve un nuevo objeto OCICollection o false en caso de error.

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocinewcollection() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_new_collection() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Conectar al servidor de Oracle usando una conexión única

  • « oci_new_collection
  • oci_new_cursor »
  • PHP Manual
  • Funciones de OCI8
  • Conectar al servidor de Oracle usando una conexión única

oci_new_connect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_connect — Conectar al servidor de Oracle usando una conexión única

Descripción

oci_new_connect ( string $username , string $password , string $connection_string = ? , string $character_set = ? , int $session_mode = ? ) : resource

Establece una nueva conexión a un servidor de Oracle y se identifica.

A diferencia de oci_connect() y oci_pconnect(), oci_new_connect() no almacena en caché conexiones y siempre devolverá un gestor de conexión recién abierto. Esto es útil si la aplicación necesita aislamiento transaccional entre dos conjuntos de consultas.

Parámetros

username

El nombre de usuario de Oracle.

password

La contraseña para username.

connection_string

Contiene la instancia de Oracle a la que conectarse. Puede ser una » cadena de Conexión Sencilla (Easy Connect), o un Nombre de Conexión del fichero tnsnames.ora, o el nombre de una instancia local de Oracle.

Si no se especifica, PHP utiliza variables de entorno como TWO_TASK (en Linux) o LOCAL (en Windows) y ORACLE_SID para determinar la instancia de Oracle a la que conectarse.

Para utilizar el método de nomenclatura de Conexión Sencila, PHP debe estar vinculado con las bibliotecas cliente de Oracle 10g o superiores. La cadena de Conexión Sencilla para Oracle 10g se utiliza de la siguiente forma: [//]nombre_host[:puerto][/nombre_servicio]. Desde Oracle 11g, la sintaxis es: [//]nombre_host[:puerto][/nombre_servicio][:tipo_servicio][/nombre_instancia]. Los nombres de servicio pueden encontrarse ejecuntado la utilidad de Oracle lsnrctl status en el servidor donde se encuentra la base de datos.

El fichero tnsnames.ora puede estar en la ruta de búsqueda de Oracle Net, la cual incluye $ORACLE_HOME/network/admin y /etc. De forma alternativa, establezca TNS_ADMIN para que $TNS_ADMIN/tnsnames.ora sea leído. Asegúrse que el demonio web tiene acceso de lectura al fichero.

character_set

Determina el juego de caracteres usado por las bibliotecas cliente de Oracle. El juego de caracteres no tiene por que coinicidir con el utilizado en la base de datos. Si no coinicide, Oracle intentará hacer lo posible para convertir los datos entre los dos juegos de caracteres. Dependiendo del juego de caracteres que se esté usando, podría no proporcionarse resultados útiles. La conversión también añade algo de carga extra de tiempo.

Si no se especifica, las bibliotacas cliente de Oracle determinarán el juego de caracteres desde la variable de entorno NLS_LANG.

Pasar este parámetro puede reducir el tiempo que toma en conectarse.

session_mode

Este parámetro está disponible desde la versión 5 de PHP (PECL OCI8 1.1) y acepta los siguientes valores: OCI_DEFAULT, OCI_SYSOPER y OCI_SYSDBA. Si se especifica OCI_SYSOPER o OCI_SYSDBA, esta función intentará establecer una conexión privilegiada con las credenciales externas. Las conexiones privilegiadas están desactivadas por omisión. Para activarlas hay que establecer oci8.privileged_connect a On.

En PHP 5.3 (PECL OCI8 1.3.4) se introdujo el valor de modo OCI_CRED_EXT. Esto indica a Oracle que utilice la autenticación Externa o del SO, la cual debe estar configurada en la base de datos. La bandera OCI_CRED_EXT sólo puede usarse con el nombre de usuario "/" y la contraseña en blanco. oci8.privileged_connect podría ser On o Off.

OCI_CRED_EXT podría estar en combinación con los modos OCI_SYSOPER o OCI_SYSDBA.

OCI_CRED_EXT no se admite en Windows por razones de seguridad.

Valores devueltos

Devuelve un identificador de conexión, o false en caso de error.

Ejemplos

Lo siguiente demuestra cómo se pueden separar conexiones.

Ejemplo #1 Ejemplo de oci_new_connect()

<?php

// crear la tabla mytab (mycol number);

function query($name, $c)
{
    echo "Consultando $name\n";
    $s = oci_parse($c, "select * from mytab");
    oci_execute($s, OCI_NO_AUTO_COMMIT);
    $row = oci_fetch_array($s, OCI_ASSOC);
    if (!$row) {
        echo "No hay filas\n";
    } else {
        do {
            foreach ($row as $item)
                echo $item . " ";
            echo "\n";
        } while (($row = oci_fetch_array($s, OCI_ASSOC)) != false);
    }
}

$c1 = oci_connect("hr", "welcome", "localhost/orcl");
$c2 = oci_new_connect("hr", "welcome", "localhost/orcl");

$s = oci_parse($c1, "insert into mytab values(1234)");
oci_execute($s, OCI_NO_AUTO_COMMIT);

query("conexión básica", $c1);
query("nueva conexión", $c2);
oci_commit($c1);
query("nueva conexión después de consignar", $c2);

// Output is:
//   Consultando conexión básica
//   1234
//   Consultando nueva conexión
//   No hay filas
//   Consultando nueva conexión después de consignar
//   1234

?>

Véase oci_connect() para más ejemplos de uso de parámetros.

Ver también

  • oci_connect() - Conecta a una base de datos de Oracle
  • oci_pconnect() - Conectar a una base de datos de Oracle usando una conexión persistente


Asigna y devuelve un nuevo cursor (gestor de sentencia)

  • « oci_new_connect
  • oci_new_descriptor »
  • PHP Manual
  • Funciones de OCI8
  • Asigna y devuelve un nuevo cursor (gestor de sentencia)

oci_new_cursor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_cursor — Asigna y devuelve un nuevo cursor (gestor de sentencia)

Descripción

oci_new_cursor ( resource $connection ) : resource

Asigna un nuevo gestor de sentencia para la conexión especificada.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect() o oci_pconnect().

Valores devueltos

Devuelve un nuevo gestor de sentencia, o false en caso de error.

Ejemplos

Ejemplo #1 Vincular un REF CURSOR en una llamada a un procedimiento almacenado de Oracle

// Precreación:
//   create or replace procedure myproc(myrc out sys_refcursor) as
//   begin
//     open myrc for select first_name from employees;
//   end;

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$curs = oci_new_cursor($conn);
$stid = oci_parse($conn, "begin myproc(:cursbv); end;");
oci_bind_by_name($stid, ":cursbv", $curs, -1, OCI_B_CURSOR);
oci_execute($stid);

oci_execute($curs);  // Ejecutar el REF CURSOR como un ide de sentencia normal
while (($row = oci_fetch_array($curs, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo $row['FIRST_NAME'] . "<br />\n";
}

oci_free_statement($stid);
oci_free_statement($curs);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocinewcursor() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_new_cursor() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Inicializa un nuevo descriptor LOB o FILE vacío

  • « oci_new_cursor
  • oci_num_fields »
  • PHP Manual
  • Funciones de OCI8
  • Inicializa un nuevo descriptor LOB o FILE vacío

oci_new_descriptor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_descriptor — Inicializa un nuevo descriptor LOB o FILE vacío

Descripción

oci_new_descriptor ( resource $connection , int $type = OCI_DTYPE_LOB ) : OCI-Lob

Asigna recursos para almacenar un descriptor o un localizador LOB.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect() o oci_pconnect().

type

Los valores válidos para type son: OCI_DTYPE_FILE, OCI_DTYPE_LOB y OCI_DTYPE_ROWID.

Valores devueltos

Devuelve un nuevo descriptor de LOB o FILE en caso de éxito, false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_new_descriptor()

<?php
/* Este script está diseñado para ser invocado desde un formulario HTML.
 * Se le ha de proporcionar $user, $password, $table, $where, y $commitsize
 * desde el formulario. Entonces, el script elimina
 * las filas seleccionadas usando el ROWID y consigna después de cada
 * conjunto de filas $commitsize. (Úselo con cuidado, no hay reversión)
 */
$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "select rowid from $table $where");
$rowid = oci_new_descriptor($conn, OCI_D_ROWID);
oci_define_by_name($stmt, "ROWID", $rowid);
oci_execute($stmt);
while (oci_fetch($stmt)) {
    $nrows = oci_num_rows($stmt);
    $delete = oci_parse($conn, "delete from $table where ROWID = :rid");
    oci_bind_by_name($delete, ":rid", $rowid, -1, OCI_B_ROWID);
    oci_execute($delete);
    echo "$nrows\n";
    if (($nrows % $commitsize) == 0) {
        oci_commit($conn);
    }
}
$nrows = oci_num_rows($stmt);
echo "$nrows eliminada...\n";
oci_free_statement($stmt);
oci_close($conn);
?>
<?php
    /* Este script demuestra la subida de ficheros a columnas LOB.
     * El campo de formulario usado para este ejemplo es como este:
     * <form action="upload.php" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload" />
     * ...
     */
  if (!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload" /><br />
<input type="submit" value="Upload" /> - <input type="reset" value="Reset" />
</form>
<?php
  } else {

     // $lob_upload contiene el nombre temporal del fichero subido

     // véase también la sección de características sobre la subida de ficheros,
     // si le gustaría usar subidas seguras

     $conn = oci_connect($user, $password);
     $lob = oci_new_descriptor($conn, OCI_D_LOB);
     $stmt = oci_parse($conn, "insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     oci_bind_by_name($stmt, ':the_blob', $lob, -1, OCI_B_BLOB);
     oci_execute($stmt, OCI_DEFAULT);
     if ($lob->savefile($lob_upload)){
        oci_commit($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     $lob->free();
     oci_free_statement($stmt);
     oci_close($conn);
  }
?>

Ejemplo #2 Ejemplo de oci_new_descriptor()

<?php
/* Llamar a procedimientos almacenados de PL/SQL que contienen CLOBs como parámetros
 * de entrada.
 * Ejemplo de firma de procedimiento almacenado de PL/SQL:
 *
 * PROCEDURE save_data
 *   Argument Name                  Type                    In/Out Default?
 *   ------------------------------ ----------------------- ------ --------
 *   KEY                            NUMBER(38)              IN
 *   DATA                           CLOB                    IN
 *
 */

$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "begin save_data(:key, :data); end;");
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stmt, ':key', $key);
oci_bind_by_name($stmt, ':data', $clob, -1, OCI_B_CLOB);
$clob->write($data);
oci_execute($stmt, OCI_DEFAULT);
oci_commit($conn);
$clob->free();
oci_free_statement($stmt);
?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocinewdescriptor() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_new_descriptor() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_bind_by_name() - Vincula una variable de PHP a un parámetro de sustitución de Oracle


Devuelve el número de columnas del resultado de una sentencia

  • « oci_new_descriptor
  • oci_num_rows »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el número de columnas del resultado de una sentencia

oci_num_fields

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_num_fields — Devuelve el número de columnas del resultado de una sentencia

Descripción

oci_num_fields ( resource $statement ) : int

Obtiene el número de columnas de la sentencia dada por statement.

Parámetros

statement

Un identificador de sentencia de OCI válido.

Valores devueltos

Devuelve el número de columnas como un entero, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_num_fields()

<?php

// Crear la tabla con:
//   CREATE TABLE mytab (id NUMBER, quantity NUMBER);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " " . oci_field_type($stid, $i) . "<br>\n";
}

// Salidas:
//    ID NUMBER
//    QUANTITY NUMBER

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocinumcols() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_num_fields() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Devuelve el número de filas afectadas durante la ejecución de una sentencia

  • « oci_num_fields
  • oci_parse »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el número de filas afectadas durante la ejecución de una sentencia

oci_num_rows

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_num_rows — Devuelve el número de filas afectadas durante la ejecución de una sentencia

Descripción

oci_num_rows ( resource $statement ) : int

Obtiene el número de filas afectadas durante la ejecución de una sentencia.

Parámetros

statement

Un identificador de sentencia de OCI válido.

Valores devueltos

Devuelve el número de filas afectadas como un entero, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_num_rows()

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "create table emp2 as select * from employees");
oci_execute($stid);
echo oci_num_rows($stid) . " rows inserted.<br />\n";
oci_free_statement($stid);

$stid = oci_parse($conn, "delete from emp2");
oci_execute($stid, OCI_DEFAULT);
echo oci_num_rows($stid) . " rows deleted.<br />\n";
oci_commit($conn);
oci_free_statement($stid);

$stid = oci_parse($conn, "drop table emp2");
oci_execute($stid);
oci_free_statement($stid);

oci_close($conn);

?>

Notas

Nota:

Esta función no devuelve el número de filas seleccionadas. Para sentencias SELECT, esta función devolverá el número de filas que fueron obtenidas desde el búfer con funciones de tipo oci_fetch*().

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocirowcount() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_num_rows() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Prepara una sentencia de Oracle para su ejecución

  • « oci_num_rows
  • oci_password_change »
  • PHP Manual
  • Funciones de OCI8
  • Prepara una sentencia de Oracle para su ejecución

oci_parse

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_parse — Prepara una sentencia de Oracle para su ejecución

Descripción

oci_parse ( resource $connection , string $sql_text ) : resource

Prepara la sentencia dada por sql_text usando la conexión connection y devuelve el identificador de sentencia, el cual puede usarse con oci_bind_by_name(), oci_execute() y demás funciones.

Los identificadores de sentencia pueden liberarse con oci_free_statement() o estableciendo la variable a null.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

sql_text

La sentencia SQL o PL/SQL.

Las sentencias SQL no deberían finalizar con un punto y coma (";"). Las sentencias PL/SQL sí deberían finalizar con un punto y coma (";").

Valores devueltos

Devuelve el gestor de sentencia en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_parse() para sentencias SQL

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

// Analizar la sentencia. Observe que no hay punto y coma final en la sentencia SQL
$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Ejemplo #2 Ejemplo de oci_parse() para sentencias PL/SQL

<?php

/*
  Antes de ejecutar el programa de PHP, cree un procedimiento almacenado en
  SQL*Plus o SQL Developer:

  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
  BEGIN
      p2 := p1 * 2;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p1 = 8;

// Cuando se analizan programas PL/SQL, debería existir un punto y coma final de la cadena
$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // imprime 16

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

Esta función no valida sql_text. La única manera de averiguar si sql_text es una sentencia SQL o PL/SQL válida es ejecutarla.

Ver también

  • oci_execute() - Ejecuta una sentencia
  • oci_free_statement() - Libera todos los recursos asociados con una sentencia o cursor


Cambia la contraseña de un usuario de Oracle

  • « oci_parse
  • oci_pconnect »
  • PHP Manual
  • Funciones de OCI8
  • Cambia la contraseña de un usuario de Oracle

oci_password_change

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_password_change — Cambia la contraseña de un usuario de Oracle

Descripción

oci_password_change ( resource $connection , string $username , string $old_password , string $new_password ) : bool
oci_password_change ( string $dbname , string $username , string $old_password , string $new_password ) : resource

Cambia la contraseña del usuario dado por username.

La función oci_password_change() es más útil para scripts de línea de comandos de PHP, o cuando se usan conexiones no persistentes a través de una aplicación de PHP.

Parámetros

connection

Un identificador de conexión de Oracle devuelto por oci_connect() o oci_pconnect().

username

El nombre del usuario de Oracle.

old_password

La contraseña antigua.

new_password

La nueva contraseña a establecer.

dbname

El nombre de la base de datos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_password_change() cambiando la contraseña de un usuario ya conectado

<?php

$bd                = 'localhost/orcl';
$usuario           = 'cj';
$contraseña_actual = 'welcome';
$contraseña_nueva  = 'geelong';

$c = oci_pconnect($usuario, $contraseña_actual, $bd);
oci_password_change($c, $usuario, $contraseña_actual, $contraseña_nueva);
echo "La nueva contraseña es : " . $contraseña_nueva . "\n";

?>

Ejemplo #2 Ejemplo de oci_password_change() conectando y cambiando la contraseña en un solo paso

<?php

$bd                = 'localhost/orcl';
$usuario           = 'cj';
$contraseña_actual = 'welcome';
$contraseña_nueva  = 'geelong';

$c = oci_pconnect($usuario, $contraseña_actual, $bd);
if (!$c) {
    $m = oci_error();
    if ($m['code'] == 28001) { // "ORA-28001: the password has expired"
        // Identinficarse y reiniciar la contraseña al mismo tiempo
        $c = oci_password_change($bd, $usuario, $contraseña_actual, $contraseña_nueva);
        if ($c) {
            echo "La nueva contraseña es : " . $contraseña_nueva . "\n";
        }
    }
}

if (!$c) {  // El error original era 28001, o que el cambio de contraseña falló
    $m = oci_error();
    trigger_error('No se pudo conectar a la base de datos: '. $m['message'], E_USER_ERROR);
}

// Usar la conexión $c
...

?>

Notas

Nota:

El cambio de la contraseña mediante esta función o directamente en Oracle debería hacerse con cuidado. Esto es debido a que las aplicaciones de PHP podrían seguir reutilizando con éxito conexiones persistentes mediante la autenticación con contraseñas antiguas. La mejor práctica es reinicializar todos los servidores web siempre que se cambie una contraseña de usuario.

Nota:

Si se actualizan las bibliotecas cliente o la base de datos de Oracle desde una versión anterior a la 11.2.0.3 hasta esta misma versión o superior, oci_password_change() pordría generar el error "ORA-1017: invalid username/password" a menos que las versiones del cliente y del servidor se actualicen a la vez.

Nota:

Está disponible la segunda sintaxis de oci_password_change() desde la versión 1.1 de OCI8.

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ocipasswordchange() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_password_change() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.


Conectar a una base de datos de Oracle usando una conexión persistente

  • « oci_password_change
  • oci_register_taf_callback »
  • PHP Manual
  • Funciones de OCI8
  • Conectar a una base de datos de Oracle usando una conexión persistente

oci_pconnect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_pconnect — Conectar a una base de datos de Oracle usando una conexión persistente

Descripción

oci_pconnect ( string $username , string $password , string $connection_string = ? , string $character_set = ? , int $session_mode = ? ) : resource

Crea una conexión persistente al servidor de Oracle y se identifica.

Las conexiones persistentes son almacenadas en caché y reutilizadas entre peticiones, resultando en la reducción de carga adicional en cada página; una aplicación típica de PHP tendrá una única conexión persistente abierta a un servidor de Oracle por cada proceso hijo de Apache (o proceso FastCGI/CGI de PHP). Véase la sección Conexiones persistentes a bases de datos para más información.

Parámetros

username

El nombre de usuario de Oracle.

password

La contraseña de username.

connection_string

Contiene la instancia de Oracle a la que conectarse. Puede ser una » cadena de Conexión Sencilla (Easy Connect), o un Nombre de Conexión del fichero tnsnames.ora, o el nombre de una instancia local de Oracle.

Si no se especifica, PHP utiliza variables de entorno como TWO_TASK (en Linux) o LOCAL (en Windows) y ORACLE_SID para determinar la instancia de Oracle a la que conectarse.

Para utilizar el método de nomenclatura de Conexión Sencila, PHP debe estar vinculado con las bibliotecas cliente de Oracle 10g o superiores. La cadena de Conexión Sencilla para Oracle 10g se utiliza de la siguiente forma: [//]nombre_host[:puerto][/nombre_servicio]. Desde Oracle 11g, la sintaxis es: [//]nombre_host[:puerto][/nombre_servicio][:tipo_servicio][/nombre_instancia]. Los nombres de servicio pueden encontrarse ejecuntado la utilidad de Oracle lsnrctl status en el servidor donde se encuentra la base de datos.

El fichero tnsnames.ora puede estar en la ruta de búsqueda de Oracle Net, la cual incluye $ORACLE_HOME/network/admin y /etc. De forma alternativa, establezca TNS_ADMIN para que $TNS_ADMIN/tnsnames.ora sea leído. Asegúrse que el demonio web tiene acceso de lectura al fichero.

character_set

Determina el juego de caracteres usado por las bibliotecas cliente de Oracle. El juego de caracteres no tiene por que coinicidir con el utilizado en la base de datos. Si no coinicide, Oracle intentará hacer lo posible para convertir los datos entre los dos juegos de caracteres. Dependiendo del juego de caracteres que se esté usando, podría no proporcionarse resultados útiles. La conversión también añade algo de carga extra de tiempo.

Si no se especifica, las bibliotacas cliente de Oracle determinarán el juego de caracteres desde la variable de entorno NLS_LANG.

Pasar este parámetro puede reducir el tiempo que toma en conectarse.

session_mode

Este parámetro está disponible desde la versión 5 de PHP (PECL OCI8 1.1) y acepta los siguientes valores: OCI_DEFAULT, OCI_SYSOPER y OCI_SYSDBA. Si se especifica OCI_SYSOPER o OCI_SYSDBA, esta función intentará establecer una conexión privilegiada con las credenciales externas. Las conexiones privilegiadas están desactivadas por omisión. Para activarlas hay que establecer oci8.privileged_connect a On.

En PHP 5.3 (PECL OCI8 1.3.4) se introdujo el valor de modo OCI_CRED_EXT. Esto indica a Oracle que utilice la autenticación Externa o del SO, la cual debe estar configurada en la base de datos. La bandera OCI_CRED_EXT sólo puede usarse con el nombre de usuario "/" y la contraseña en blanco. oci8.privileged_connect podría ser On o Off.

OCI_CRED_EXT podría estar en combinación con los modos OCI_SYSOPER o OCI_SYSDBA.

OCI_CRED_EXT no se admite en Windows por razones de seguridad.

Valores devueltos

Devuelve un identificador de conexión, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo básico de oci_pconnect() usando la sintaxis de Easy Connect

<?php

// Conecta al servicio XE (esto es, una base de datos) en la máquina "localhost"
$conn = oci_pconnect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Véase oci_connect() para más ejemplos de uso de parámetros.

Notas

Nota: Desde PHP 5.1.2 y PECL OCI8 1.1, el tiempo de vida y el número máximo de conexiones persistentes a Oracle por proceso de PHP se puede ajustar estableciendo los siguientes valores de configuración: oci8.persistent_timeout, oci8.ping_interval y oci8.max_persistent.

Ver también

  • oci_connect() - Conecta a una base de datos de Oracle
  • oci_new_connect() - Conectar al servidor de Oracle usando una conexión única


Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database

  • « oci_pconnect
  • oci_result »
  • PHP Manual
  • Funciones de OCI8
  • Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database

oci_register_taf_callback

(PHP 7.0 >= 7.0.21, PHP 8, PHP 7 >= 7.1.7, PHP 8, PECL OCI8 >= 2.1.7)

oci_register_taf_callback — Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database

Descripción

oci_register_taf_callback ( resource $connection , mixed $callbackFn ) : bool

Registra una función de retrollamada definida por el usuario al parmátro connection. Si connection falla debido a un fallo de instancia o de red, la función de retrollamada registrada será invocada varias veces durante el fallo. Véase Soporte para 'Transparent Application Failover' (TAF) de OCI8 para más información sobre el soporte para TAF de OCI8.

Al llamar a oci_register_taf_callback() varias veces, cada registro sobreescribe al anterior.

Use oci_disable_taf_callback() para desregistrar explícitamente una retrollada definida por el usuario.

El registro de retrollamda de TAF NO se guardará a través conexiones persistentes, por lo que la retrollamada necesita ser registrada de nuevo para una nueva conexión persistente.

Parámetros

connection

Un identificador de conexión de Oracle.

calllbackFn

Una retrollamada definida por el usuario para registrar TAF de Oracle. Puede ser una cadena del nombre de una función o un cierre (función anónima).

La interfaz de una función de retrollamada definida por el usuario de TAF es como sigue:

userCallbackFn ( resource $connection , int $event , int $type ) : int

Véase la descripción del parámetro y el ejemplo en la página Soporte para 'Transparent Application Failover' (TAF) de OCI8.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • oci_unregister_taf_callback() - Unregister a user-defined callback function for Oracle Database TAF


Devuelve el valor de un campo de la fila obtenida

  • « oci_register_taf_callback
  • oci_rollback »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el valor de un campo de la fila obtenida

oci_result

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_result — Devuelve el valor de un campo de la fila obtenida

Descripción

oci_result ( resource $statement , mixed $field ) : mixed

Devuelve los datos del campo dado por field de la fila actual, obtenida mediante oci_fetch().

Para más detalles sobre cómo la extensión OCI8 realiza la correspondencia entre tipos de datos, véasen los tipos de datos admitidos por el controlador

Parámetros

statement

field

Puede ser el número de columna (basado en 1) o el nombre de columna. El uso de mayúsculas/minúsculas del nombre de columna debe ser el mismo que el de los metadatos de Oracle que describen la columna, que es en mayúsculas para columnas creadas con uso insensible a mayúsculas/minúsculas.

Valores devueltos

Devuelve todo como un string excepto para tipos abstractos (ROWID, LOB y FILE). Devuelve false en caso de error.

Ejemplos

Ejemplo #1 oci_fetch() con oci_result()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (oci_fetch($stid)) {
    echo oci_result($stid, 'LOCATION_ID') . " es ";
    echo oci_result($stid, 'CITY') . "<br>\n";
}

// Muestra:
//   1000 es Roma
//   1100 es Venice

oci_free_statement($stid);
oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ociresult() en su lugar. Este nombre aún puede usarse; se dejó como alias de oci_result() por razones de retrocompatibilidad. Sin embargo, este nombre es obsoleto y no se recomienda.

Ver también

  • oci_fetch_array() - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
  • oci_fetch_assoc() - Devuelve la siguiente fila de una consulta como un array asociativo
  • oci_fetch_object() - Devuelve la siguiente fila de una consulta como un objeto
  • oci_fetch_row() - Devuelve la siguiente fila de una consulta como un array numérico
  • oci_fetch_all() - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional


Revierte la transacción pendiente de la base de datos

  • « oci_result
  • oci_server_version »
  • PHP Manual
  • Funciones de OCI8
  • Revierte la transacción pendiente de la base de datos

oci_rollback

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_rollback — Revierte la transacción pendiente de la base de datos

Descripción

oci_rollback ( resource $connection ) : bool

Revierte todos los cambios no consignados para la conexión de Oracle dada por connection y finaliza la transacción. Libera todos los bloqueos existentes. Todos los SAVEPOINT de Oracle se eliminan.

Una transacción comienza cuando la primera sentencia SQL que modifica datos es ejecutada con oci_execute() usando la bandera OCI_NO_AUTO_COMMIT. Las modificaciones posteriores a datos realizadas por otras sentencias se convierten en parte de la misma transacción. Las modificaciones a datos hechas en una transacción son temporales hasta que ésta se consigna o revierte. Los demás usuarios de la base de datos no verán los cambios hasta que sean consignados.

Cuando se insertan o actualizan datos, se recomienda usar transacciones para mantener la consistencia de datos relacional y por razones rendimiento.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect() o oci_new_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_rollback()

<?php

// Insertar en varias tablas, revirtiendo los cambios si ocurriera un error

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// La bandera OCI_NO_AUTO_COMMIT le indica a Oracle que no consigne el INSERT inmediatamente
// Use OCI_DEFAULT como bandera para PHP <= 5.3.1. Las dos banderas son equivalentes
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // revertir los cambios de ambas tablas
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Consignar los cambios de ambas tablas
$r = oci_commit($conn);
if (!r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

Ejemplo #2 Ejemplo de reversión a un SAVEPOINT

<?php
$stid = oci_parse($conn, 'UPDATE mytab SET id = 1111');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Crear el punto de prevención
$stid = oci_parse($conn, 'SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

$stid = oci_parse($conn, 'UPDATE mytab SET id = 2222');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Usar una sentencia SQL explícita para volver al punto de prevención
$stid = oci_parse($conn, 'ROLLBACK TO SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

oci_commit($conn);  // mytab ahora tiene el id 1111
?>

Notas

Nota:

Las transacciones son automáticamente revertidas cuando se cierra la conexión o cuando finaliza el script, lo que ocurra antes. Es necesario llamar explícitamente a oci_commit() para consignar la transacción.

Cualquier llamada a oci_execute() que use el modo OCI_COMMIT_ON_SUCCESS, explícitamente o por omisión, consignará cualquier transacción no consignada anteriormente.

Cualquier sentencia DDL de Oracle como CREATE o DROP consignará automáticamente cualquier transacción no consignada.

Ver también

  • oci_commit() - Consigna la transacción pendiente de la base de datos
  • oci_execute() - Ejecuta una sentencia


Devuelve la versión de Oracle Database

  • « oci_rollback
  • oci_set_action »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve la versión de Oracle Database

oci_server_version

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_server_version — Devuelve la versión de Oracle Database

Descripción

oci_server_version ( resource $connection ) : string

Devuelve una cadena con la verisón de Oracle Database y las opciones disponibles.

Parámetros

connection

Valores devueltos

Devuelve la información de la versión como una cadena, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_server_version()

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
echo "Server Version: " . oci_server_version($conn);

// Muestra:
// Server Version: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
// With the Partitioning, OLAP, Data Mining and Real Application Testing option

oci_close($conn);

?>

Notas

Nota:

En versiones de PHP anteriores a la 5.0.0 se debe usar ociserverversion() en su luagar. El nombre antiguo aún se puede utilizar. Sin embargo es obsoleto y no se recomienda.

Ver también

  • oci_client_version() - Devuelve la versión de la biblioteca cliente de Oracle


Establece el nombre de una acción

  • « oci_server_version
  • oci_set_call_timeout »
  • PHP Manual
  • Funciones de OCI8
  • Establece el nombre de una acción

oci_set_action

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_action — Establece el nombre de una acción

Descripción

oci_set_action ( resource $connection , string $action_name ) : bool

Establece el nombre de una acción para el rastreo de Oracle.

El nombre de la acción se registra con la base de datos cuando ocurra el siguiente "viaje de ida y vuelta" desde PHP a la base de datos, normalemnte cuando una sentencia SQL es ejecutada.

El nombre de la acción puede ser consultado posteriormente desde una vista de administración de la base de datos como V$SESSION. Se puede usar para rastrear y monitorizar como con V$SQLAREA y DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

El valor podría manterse entre conexiones persistentes.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

action_name

La cadena elegida por el usuario, hasta 32 bytes de longitud.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer la acción

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Grabar la acción
oci_set_action($c, 'Friend Lookup');

// Código que causa un viaje de ida y vuelta, por ejemplo una consulta:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// Mientras el script se esté ejecutando, el administrador puede ver las acciones
// que se están realizando:

sqlplus system/welcome
SQL> select action from v$session;

Notas

Nota: Requisito de versión de Oracle

Esta función esta disponible cuando PHP está vinculado con bibliotecas de Oracle Database de la versión 10g en adelante.

Sugerencia

Rendimiento

Con versiones antiguas de OCI8 o de Oracle Database, se puede establecer la información del cliente usando el paquete DBMS_APPLICATION_INFO de Oracle. Esto es menos eficiente que utilizar oci_set_client_info().

Precaución

Problema con los viajes de ida y vuelta

Algunas, pero no todas, las funciones de OCI8 causan viajes de ida y vuelta. Estos podrían no ocurrir con las consultas cuando está habilitado el almacenamiento en caché de resultados.

Ver también

  • oci_set_module_name() - Establece el nombre de un módulo
  • oci_set_client_info() - Establece la información del cliente
  • oci_set_client_identifier() - Establece el identificador del cliente


Sets a millisecond timeout for database calls

  • « oci_set_action
  • oci_set_client_identifier »
  • PHP Manual
  • Funciones de OCI8
  • Sets a millisecond timeout for database calls

oci_set_call_timeout

(PHP 7.2 >= 7.2.14, PHP 8, PHP 7 >= 7.3.1, PHP 8, PECL OCI8 >= 2.2.0)

oci_set_call_timeout — Sets a millisecond timeout for database calls

Descripción

oci_set_call_timeout ( resource $connection , int $time_out ) : bool

Sets a timeout limiting the maxium time a database round-trip using this connection may take.

Each OCI8 operation may make zero or more calls to Oracle's client library. These internal calls may then may make zero or more round-trips to Oracle Database. If any one of those round-trips takes more than time_out milliseconds, then the operation is cancelled and an error is returned to the application.

The time_out value applies to each round-trip individually, not to the sum of all round-trips. Time spent processing in PHP OCI8 before or after the completion of each round-trip is not counted.

When a call is interrupted, Oracle will attempt to clean up the connection for reuse. This operation is allowed to run for another time_out period. Depending on the outcome of the cleanup, the connection may or may not be reusable.

When persistent connections are used, the timeout value will be retained across PHP requests.

The oci_set_call_timeout() function is available when OCI8 uses Oracle 18 (or later) Client libraries.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

time_out

The maximum time in milliseconds that any single round-trip between PHP and Oracle Database may take.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Setting the timeout

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
oci_set_call_timeout($conn, 5000);

?>


Establece el identificador del cliente

  • « oci_set_call_timeout
  • oci_set_client_info »
  • PHP Manual
  • Funciones de OCI8
  • Establece el identificador del cliente

oci_set_client_identifier

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_client_identifier — Establece el identificador del cliente

Descripción

oci_set_client_identifier ( resource $connection , string $client_identifier ) : bool

Establece el identificador del cliente usado por varios componentes de la base de datos para identificar usuarios de aplicaciones ligeras que se identificaron con el mismo usuario de base de datos.

El identificador del cliente se registra con la base de datos cuando ocurra el siguiente "viaje de ida y vuelta" desde PHP a la base de datos, normalemnte cuando una sentencia SQL es ejecutada.

El identificador puede ser consultado subsiguientemente, por ejemplo, con SELECT SYS_CONTEXT('USERENV','CLIENT_IDENTIFIER') FROM DUAL. Las vistas de administración de la base de datos como V$SESSION también contendrán el valor. Se puede usar con DBMS_MONITOR.CLIENT_ID_TRACE_ENABLE para rastreo y también para auditoría.

El valor podría mantenerse entre peticiones de páginas que usen la misma conexión persistente.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

client_identifier

La cadena elegida por el usuario, hasta 64 bytes de longitud.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer el identificador del cliente para el usuario de la aplicación

<?php

// Buscar el nombre de identificación de usuario de la aplicación
session_start();
$un = my_validate_session($_SESSION['username']);
$c = oci_connect('myschema', 'welcome', 'localhost/XE');

// Indicar a Oracle qué usuario es
oci_set_client_identifier($c, $un);

// El siguiente viaje de ida y vuelta a la base de datos adjuntará el identificador
$s = oci_parse($c, 'select mydata from mytable');
oci_execute($s);

// ...

?>

Notas

Precaución

Problema con los viajes de ida y vuelta

Algunas, pero no todas, las funciones de OCI8 causan viajes de ida y vuelta. Estos podrían no ocurrir con las consultas cuando está habilitado el almacenamiento en caché de resultados.

Ver también

  • oci_set_module_name() - Establece el nombre de un módulo
  • oci_set_action() - Establece el nombre de una acción
  • oci_set_client_info() - Establece la información del cliente


Establece la información del cliente

  • « oci_set_client_identifier
  • oci_set_db_operation »
  • PHP Manual
  • Funciones de OCI8
  • Establece la información del cliente

oci_set_client_info

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_client_info — Establece la información del cliente

Descripción

oci_set_client_info ( resource $connection , string $client_info ) : bool

Establece la información del cliente para el rastreo de Oracle.

La información del cliente se registra con la base de datos cuando ocurra el siguiente "viaje de ida y vuelta" desde PHP a la base de datos, normalemnte cuando una sentencia SQL es ejecutada.

La información del cliente puede ser consultado posteriormente desde una vista de administración de la base de datos como V$SESSION.

El valor podría manterse entre conexiones persistentes.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

client_info

La cadena elegida por el usuario, hasta 64 bytes de longitud.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer la información del cliente

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Grabar la información del cliente
oci_set_client_info($c, 'My Application Version 2');

// Código que causa un viaje de ida y vuelta, por ejemplo una consulta:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// Mientras el script se esté ejecutando, el administrador puede ver la informaicón
// del cliente:

sqlplus system/welcome
SQL> select client_info from v$session;

Notas

Nota: Requisito de versión de Oracle

Esta función esta disponible cuando PHP está vinculado con bibliotecas de Oracle Database de la versión 10g en adelante.

Sugerencia

Rendimiento

Con versiones antiguas de OCI8 o de Oracle Database, se puede establecer la información del cliente usando el paquete DBMS_APPLICATION_INFO de Oracle. Esto es menos eficiente que utilizar oci_set_client_info().

Precaución

Problema con los viajes de ida y vuelta

Algunas, pero no todas, las funciones de OCI8 causan viajes de ida y vuelta. Estos podrían no ocurrir con las consultas cuando está habilitado el almacenamiento en caché de resultados.

Ver también

  • oci_set_module_name() - Establece el nombre de un módulo
  • oci_set_action() - Establece el nombre de una acción
  • oci_set_client_identifier() - Establece el identificador del cliente


Sets the database operation

  • « oci_set_client_info
  • oci_set_edition »
  • PHP Manual
  • Funciones de OCI8
  • Sets the database operation

oci_set_db_operation

(PHP 7 >= 7.2.14, PHP 8, PHP 7 >= 7.3.1, PHP 8, PECL OCI8 >= 2.2.0)

oci_set_db_operation — Sets the database operation

Descripción

oci_set_db_operation ( resource $connection , string $dbop ) : bool

Sets the DBOP for Oracle tracing.

The database operation name is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when a SQL statement is executed.

The database operation can subsequently be queried from database administration views such as V$SQL_MONITOR.

The oci_set_db_operation() function is available when OCI8 uses Oracle 12 (or later) Client libraries and Oracle Database 12 (or later).

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

dbop

User chosen string.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Setting the DBOP

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the operation
oci_set_db_operation($c, 'main query');

// Code that causes a round-trip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the database operations
// being performed:

sqlplus system/welcome
SQL> select dbop_name from v$sql_monitor;

Notas

Precaución

Problema con los viajes de ida y vuelta

Algunas, pero no todas, las funciones de OCI8 causan viajes de ida y vuelta. Estos podrían no ocurrir con las consultas cuando está habilitado el almacenamiento en caché de resultados.

Ver también

  • oci_set_action() - Establece el nombre de una acción
  • oci_set_module_name() - Establece el nombre de un módulo
  • oci_set_client_info() - Establece la información del cliente
  • oci_set_client_identifier() - Establece el identificador del cliente


Establece la edición de la base de datos

  • « oci_set_db_operation
  • oci_set_module_name »
  • PHP Manual
  • Funciones de OCI8
  • Establece la edición de la base de datos

oci_set_edition

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_edition — Establece la edición de la base de datos

Descripción

oci_set_edition ( string $edition ) : bool

Establece la "edición" de la base de datos de objetos que van a se utilizada por conexiones subsiguientes.

Las ediciones de Oracle permiten la ejecución de aplicaciones de versiones concurrentes usando el mismo esquema y nombres de objetos. Esto es útil para actualizar sistemas en vivo.

Se ha de llamar a oci_set_edition() antes de invocar a oci_connect(), oci_pconnect() o oci_new_connect().

Si se establece en la base de datos una edición que no es válida, la conexión fallará incluso si oci_set_edition() tiene éxito.

Cuando se usan conexiones persistentes, si una conexión con la edición establecida solicitada ya existe, será reutilizada. De lo contrario, se creará una conexión persistente diferente.

Parámetros

edition

El nombre de la edición de Oracle Database anteriormente creada con el comando SQL "CREATE EDITION".

Notas

Nota: Requisitos de la versión de Oracle

Esta función está disponible desde Oracle 11gR2 en adelante.

Precaución

Conexiones persistentes

Para evitar inconsistencias y errores inesperados, no use ALTER SESSION SET EDITION para cambiar la edición en conexiones persistentes.

Precaución

Agrupamiento de conexiones DRCP

Para evitar inconsistencias y errores inesperados cuando se utilizan ediciones y DRCP con Oracle 11.2.0.1, mantenga una correspondencia uno-a-uno entre oci8.connection_class y el nombre de la edición usado por las aplicaciones. Cada servidor de la agrupación de una clase de conexión dada debería ser usado únicamente con una edición. Esta restricción se ha eliminado con Oracle 11.2.0.2.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Dos scripts pueden usar diferentes versiones de myfunc() a la vez

<?php

// Fichero 1

echo "Versión 1 de la aplicación\n";

oci_set_edition('ORA$BASE');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "El resultado es $r\n";

?>
<?php

// Fichero 2

echo "Versión 2 de la aplicación\n";

oci_set_edition('E1');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "El resultado es $r\n";

?>


Establece el nombre de un módulo

  • « oci_set_edition
  • oci_set_prefetch »
  • PHP Manual
  • Funciones de OCI8
  • Establece el nombre de un módulo

oci_set_module_name

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_module_name — Establece el nombre de un módulo

Descripción

oci_set_module_name ( resource $connection , string $module_name ) : bool

Establece el nombre de un módulo para el rastreo de Oracle.

El nombre del módulo se registra con la base de datos cuando ocurra el siguiente "viaje de ida y vuelta" desde PHP a la base de datos, normalemnte cuando una sentencia SQL es ejecutada.

El nombre del módulo puede ser consultado posteriormente desde una vista de administración de la base de datos como V$SESSION. Se puede usar para rastrear y monitorizar como con V$SQLAREA y DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

El valor podría manterse entre conexiones persistentes.

Parámetros

connection

Un identificador de conexión de Oracle, devuelto por oci_connect(), oci_pconnect(), o oci_new_connect().

module_name

El string elegido por el usuario, hasta 48 bytes de longitud.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Requisito de versión de Oracle

Esta función esta disponible cuando PHP está vinculado con bibliotecas de Oracle Database de la versión 10g en adelante.

Sugerencia

Rendimiento

Con versiones antiguas de OCI8 o de Oracle Database, se puede establecer la información del cliente usando el paquete DBMS_APPLICATION_INFO de Oracle. Esto es menos eficiente que utilizar oci_set_client_info().

Precaución

Problema con los viajes de ida y vuelta

Algunas, pero no todas, las funciones de OCI8 causan viajes de ida y vuelta. Estos podrían no ocurrir con las consultas cuando está habilitado el almacenamiento en caché de resultados.

Ejemplos

Ejemplo #1 Establecer el nombre del módulo

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Grabar el módulo
oci_set_module_name($c, 'Home Page');

// Código que causa un viaje de ida y vuelta, por ejemplo una consulta:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);
?>
// Mientras el script se esté ejecutando, el administrador puede ver el
// módulo en uso:

sqlplus system/welcome
SQL> select module from v$session;

Ver también

  • oci_set_action() - Establece el nombre de una acción
  • oci_set_client_info() - Establece la información del cliente
  • oci_set_client_identifier() - Establece el identificador del cliente


Establece el número de filas a precargar mediante consultas

  • « oci_set_module_name
  • oci_statement_type »
  • PHP Manual
  • Funciones de OCI8
  • Establece el número de filas a precargar mediante consultas

oci_set_prefetch

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_set_prefetch — Establece el número de filas a precargar mediante consultas

Descripción

oci_set_prefetch ( resource $statement , int $rows ) : bool

Establece el número de filas que las bibliotecas de Oracle Client almacenará en búfer después de una llamada exitosa a oci_execute() y por cada petición de obtención interna subsigiente a la base de datos. Para consultas que devuelven un gran número de filas, se puede mejorar significativamente el rendimiento aumentando el número de precarga sobre el valor predeterminado de oci8.default_prefetch.

La precarga es la forma eficiente de Oracle de devolver más de una fila de datos desde la base de datos en cada petición de red. Esto puede resultar en un uso mejor de la red y la CPU. El almacenamiento en búder de filas es interno a OCI8 y el comportamiento de las funciones de obtención de OCI8 no se modifica a pesar del número de precargas. Por ejemplo, oci_fetch_row() siempre devolverá una fila. El almancenamiento en búfer de las precargas se realiza en función de cada sentencia y no es utilizado por sentencias reejecutadas o por otras conexiones.

Se ha de llamar a oci_set_prefetch() antes de invocar a oci_execute().

Un objetivo para el ajuste es establecer el valor de precarga a un tamaño razonable que pueda manejar la red y la base de datos. Para consultas que devuelven un número de filas muy grande, se podría mejorar la eficiencia total del sistema si las filas son obtenidas de la base de datos en varios trozos (esto es, establecer el valor de precarga menor que el número de filas). Esto permite que la base de datos maneje otras sentencias de usuarios mientras que el script de PHP está procesando el conjunto de filas actual.

La precarga de consultas se introdujo en Oracle 8i. La precarga de REF CURSOR se introdujo en Oracle 11gR2 y sucede cuando PHP está vinculado con las bibliotecas cliente de Oracle 11gR2 (o posterior). La precarga de cursores anidados fue introducida en Oracle 11gR2 y requiere que las bibliotecas de Oracle Client y las bases de datos sean la versión 11gR2 o posterior.

La precarga no está soportada cuando las consultas contienen columnas LONG o LOB. El valor de la precarga será ignorado y se usará la obtención de una única fila en todas las situaciones donde no esté soportada la precarga.

Al usar Oracle Database 12c, el valor precargado establecido por PHP puede ser sobrescrito por el fichero de configuración de del cliente oraaccess.xml de Oracle. Consulte la documentación de Oracle para más detalles.

Parámetros

statement

Un identificador de sentencia de OCI8 válido creado por oci_parse() y ejecutado por oci_execute(), o un identificador de sentencia de REF CURSOR.

rows

El número de filas que van a se precargadas, >= 0

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.2 (PECL OCI8 1.4) | Antes de esta versión, rows debe ser >= 1.
5.3.0 (PECL OCI8 1.3.4) | Antes de esta versión, la precarga estaba limitada al menor valor de rows filas y 1024 * rows bytes. La restricción del tamaño de bytes ahora ha sido eliminada.

Ejemplos

Ejemplo #1 Cambiar el valor de precarga predeterminado para una consulta

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM myverybigtable');
oci_set_prefetch($stid, 300);  // Establecer antes de llamar a oci_execute()
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Ejemplo #2 Cambiar la precarga predeterminada para la obtención de un REF CURSOR

<?php
/*
  Crear el procedimiento almacenado PL/SQL:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Cambiar la precarga antes de ejecutar el cursor.
// La precarga de REF CURSOR funciona cuando PHP está vinculado con las bibliotecas cliente de Oracle 11gR2 o posteriores
oci_set_prefetch($refcur, 200);
oci_execute($refcur);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

Si OCI8 de PHP realiza la obtención desde un REF CURSOR y luego pasa el REF CURSOR a un segundo procedimiento de PL/SQL para su procesamiento posterior, establezca el número de precargas de REF CURSOR a 0 para evitar que las filas se "pierdan" en el conjunto de resultados. El valor de la precarga es el número de filas extra obtenidas en cada petición interna de OCI8 para la base de datos, por lo que establecerlo a 0 significa que únicamente se obtiene una fila cada vez.

Ejemplo #3 Establecer el valor de precarga cuando se vuelve a pasar un REF CURSOR a Oracle

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/orcl');

// obtener el REF CURSOR
$stid = oci_parse($conn, 'BEGIN myproc(:rc_out); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc_out', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Mostrar dos filas, pero no precargar ninguna fila extra, si no,
// esas filas extra no se pasarán de nuevo a myproc_use_rc().
// Un valor de precarga de 0 está permitido en PHP 5.3.2 y PECL OCI8 1.4
oci_set_prefetch($refcur, 0);
oci_execute($refcur);
$row = oci_fetch_array($refcur);
var_dump($row);
$row = oci_fetch_array($refcur);
var_dump($row);

// pasar el REF CURSOR a myproc_use_rc() para porcesar más datos
// con el conjunto de resultados
$stid = oci_parse($conn, 'begin myproc_use_rc(:rc_in); end;');
oci_bind_by_name($stid, ':rc_in', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

?>

Ver también

  • La opción ini oci8.default_prefetch


Devuelve el tipo de una sentencia

  • « oci_set_prefetch
  • oci_unregister_taf_callback »
  • PHP Manual
  • Funciones de OCI8
  • Devuelve el tipo de una sentencia

oci_statement_type

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_statement_type — Devuelve el tipo de una sentencia

Descripción

oci_statement_type ( resource $statement ) : string

Devuelve una palabra clave que identifica el tipo de la sentencia de OCI8 dada por statement.

Parámetros

statement

Un identificador de sentencia de OCI8 válido desde oci_parse().

Valores devueltos

Devuelve el tipo de statement como una de las siguientes cadenas.

Tipo de sentencia
Cadena devuelta | Notas
ALTER |
BEGIN |
CALL | Introducido en PHP 5.2.1 (PECL OCI8 1.2.3)
CREATE |
DECLARE |
DELETE |
DROP |
INSERT |
SELECT |
UPDATE |
UNKNOWN |

Devuelve false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de oci_statement_type()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'DELETE FROM departments WHERE department_id = 130;');
if (oci_statement_type($stid) == "DELETE") {
    trigger_error('You are not allowed to delete from this table', E_USER_ERROR);
}
else {
    oci_execute($stid);  // eliminar la fila
}

oci_free_statement($stid);
oci_close($conn);

?>


Unregister a user-defined callback function for Oracle Database TAF

  • « oci_statement_type
  • OCI-Collection »
  • PHP Manual
  • Funciones de OCI8
  • Unregister a user-defined callback function for Oracle Database TAF

oci_unregister_taf_callback

(PHP 7.0 >= 7.0.23, PHP 8, PHP 7 >= 7.1.9, PHP 8, PECL OCI8 >= 2.1.7)

oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF

Descripción

oci_unregister_taf_callback ( resource $connection ) : bool

Unregister the user-defined callback function registered to connection by oci_register_taf_callback(). See OCI8 Transparent Application Failover (TAF) Support for information.

Parámetros

connection

An Oracle connection identifier.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • oci_register_taf_callback() - Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database


La clase OCI-Collection

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Funcionalidad de OCI8 Collection.

Sinopsis de la Clase

OCI-Collection {
/* Métodos */
append ( mixed $value ) : bool
assign ( OCI-Collection $from ) : bool
assignElem ( int $index , mixed $value ) : bool
free ( ) : bool
getElem ( int $index ) : mixed
max ( ) : int
size ( ) : int
trim ( int $num ) : bool
}

Tabla de contenidos

  • OCI-Collection::append — Añade un elemento a la colección
  • OCI-Collection::assign — Asigna un valor a la colección desde otra colección existente
  • OCI-Collection::assignElem — Asigna un valor a un elemento de la colección
  • OCI-Collection::free — Libera los recursos asociados con el objeto colección
  • OCI-Collection::getElem — Devuelve el valor de un elemento
  • OCI-Collection::max — Devuelve el número máximo de elementos de la colección
  • OCI-Collection::size — Devuelve el tamaño de la colección
  • OCI-Collection::trim — Elimina elementos del final de la colección


Añade un elemento a la colección

  • « OCI-Collection
  • OCI-Collection::assign »
  • PHP Manual
  • OCI-Collection
  • Añade un elemento a la colección

OCI-Collection::append

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::append — Añade un elemento a la colección

Descripción

OCI-Collection::append ( mixed $value ) : bool

Añade un elemento al final de la colección.

Parámetros

value

El valor a añadir a la colexxión. Puede ser una cadena de caracters o un número.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Collection::assign


Asigna un valor a la colección desde otra colección existente

  • « OCI-Collection::append
  • OCI-Collection::assignElem »
  • PHP Manual
  • OCI-Collection
  • Asigna un valor a la colección desde otra colección existente

OCI-Collection::assign

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::assign — Asigna un valor a la colección desde otra colección existente

Descripción

OCI-Collection::assign ( OCI-Collection $from ) : bool

Asigna un valor a la colección desde otra colección previamente creada. Ambas colecciones deben crearse con oci_new_collection() antes de utilizarlas.

Parámetros

from

Una instancia de OCI-Collection.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Collection::append


Asigna un valor a un elemento de la colección

  • « OCI-Collection::assign
  • OCI-Collection::free »
  • PHP Manual
  • OCI-Collection
  • Asigna un valor a un elemento de la colección

OCI-Collection::assignElem

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::assignElem — Asigna un valor a un elemento de la colección

Descripción

OCI-Collection::assignElem ( int $index , mixed $value ) : bool

Asigna un valor al elemento con índice index.

Parámetros

index

El índice del elemento. El primer índice es 0.

value

Puede ser una cadena de caracteres o un número.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Collection::getElem


Libera los recursos asociados con el objeto colección

  • « OCI-Collection::assignElem
  • OCI-Collection::getElem »
  • PHP Manual
  • OCI-Collection
  • Libera los recursos asociados con el objeto colección

OCI-Collection::free

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::free — Libera los recursos asociados con el objeto colección

Descripción

OCI-Collection::free ( ) : bool

Libera los recursos asociados con el objeto colección.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • oci_new_collection


Devuelve el valor de un elemento

  • « OCI-Collection::free
  • OCI-Collection::max »
  • PHP Manual
  • OCI-Collection
  • Devuelve el valor de un elemento

OCI-Collection::getElem

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::getElem — Devuelve el valor de un elemento

Descripción

OCI-Collection::getElem ( int $index ) : mixed

Devuelve el valor del elemento cuyo índice es index (basado en 0).

Parámetros

index

El índice del elemento. El primer índice es 0.

Valores devueltos

Devuelve false si el elemento no existe; null si el elemento es null; un string si el elemento es una columna del tipo de datos string, o un número si es un campo numérico.

Ver también

  • OCI-Collection::assignElem


Devuelve el número máximo de elementos de la colección

  • « OCI-Collection::getElem
  • OCI-Collection::size »
  • PHP Manual
  • OCI-Collection
  • Devuelve el número máximo de elementos de la colección

OCI-Collection::max

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::max — Devuelve el número máximo de elementos de la colección

Descripción

OCI-Collection::max ( ) : int

Devuelve el número máximo de elementos de la colección.

Valores devueltos

Devuelve el número máximo como un entero, o false en caso de error.

Si el valor devuelto es 0, entonces el número de elementos no está limitado.

Ver también

  • OCI-Collection::size


Devuelve el tamaño de la colección

  • « OCI-Collection::max
  • OCI-Collection::trim »
  • PHP Manual
  • OCI-Collection
  • Devuelve el tamaño de la colección

OCI-Collection::size

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::size — Devuelve el tamaño de la colección

Descripción

OCI-Collection::size ( ) : int

Devuelve el tamaño de la colección.

Valores devueltos

Devuelve el número de elementos de la colección o false en caso de error.

Ver también

  • OCI-Collection::max


Elimina elementos del final de la colección

  • « OCI-Collection::size
  • OCI-Lob »
  • PHP Manual
  • OCI-Collection
  • Elimina elementos del final de la colección

OCI-Collection::trim

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Collection::trim — Elimina elementos del final de la colección

Descripción

OCI-Collection::trim ( int $num ) : bool

Elimina el número de elementos dado por num del final de la colección.

Parámetros

num

El número de elementos a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Collection::size


La clase OCI-Lob

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Funcionaliada de OCI8 LOB para objetos grandes binarios (BLOB) y de carácter (CLOB).

Sinopsis de la Clase

OCI-Lob {
/* Métodos */
append ( OCI-Lob $lob_from ) : bool
close ( ) : bool
eof ( ) : bool
erase ( int $offset = ? , int $length = ? ) : int
export ( string $filename , int $start = ? , int $length = ? ) : bool
flush ( int $flag = ? ) : bool
free ( ) : bool
getBuffering ( ) : bool
import ( string $filename ) : bool
load ( ) : string
rewind ( ) : bool
save ( string $data , int $offset = ? ) : bool
seek ( int $offset , int $whence = OCI_SEEK_SET ) : bool
setBuffering ( bool $on_off ) : bool
size ( ) : int
tell ( ) : int
truncate ( int $length = 0 ) : bool
write ( string $data , int $length = ? ) : int
writeTemporary ( string $data , int $lob_type = OCI_TEMP_CLOB ) : bool
}

Tabla de contenidos

  • OCI-Lob::append — Añade datos a un objeto grande (LOB) desde otro
  • OCI-Lob::close — Cierra un descriptor de LOB
  • OCI-Lob::eof — Comprueba la marca de final de fichero en un descriptor de objetos grandes
  • OCI-Lob::erase — Borra la porción especificada de los datos internos de un LOB
  • OCI-Lob::export — Exporta el contenido de un LOB a un fichero
  • OCI-Lob::flush — Vacía/escribe el búfer de un LOB al servidor
  • OCI-Lob::free — Libera los recursos asociados con el descriptor del LOB
  • OCI-Lob::getBuffering — Devuelve el estado actual del uso del búfer para un objeto grande
  • OCI-Lob::import — Importa datos de un fichero a un LOB
  • OCI-Lob::load — Devuelve el contenido de un objeto grande
  • OCI-Lob::read — Lee parte del objeto grande
  • OCI-Lob::rewind — Mueve el puntero interno al comienzo de un objeto grande
  • OCI-Lob::save — Guarda datos en un objeto grande
  • OCI-Lob::saveFile — Alias de OCI-Lob::import
  • OCI-Lob::seek — Ubica el puntero interno de un objeto grande
  • OCI-Lob::setBuffering — Cambia el estado actual del uso del búfer para objetos grandes
  • OCI-Lob::size — Devuelve el tamaño de un objeto grande
  • OCI-Lob::tell — Devuelve la posición actual del puntero interno de un objeto grande
  • OCI-Lob::truncate — Trunca un objeto grande
  • OCI-Lob::write — Escribe datos en un objeto grande
  • OCI-Lob::writeTemporary — Escribe un objeto grande temporal
  • OCI-Lob::writeToFile — Alias de OCI-Lob::export


Añade datos a un objeto grande (LOB) desde otro

  • « OCI-Lob
  • OCI-Lob::close »
  • PHP Manual
  • OCI-Lob
  • Añade datos a un objeto grande (LOB) desde otro

OCI-Lob::append

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::append — Añade datos a un objeto grande (LOB) desde otro

Descripción

OCI-Lob::append ( OCI-Lob $lob_from ) : bool

Añade datos de un objeto grande (LOB) al final de otro.

La escritura del objeto grande con este método fallará si el uso del búfer estaba previamente habilitado. Se debe deshabilitar el uso del búfer antes de la agregación. Podría ser necesario vaciar los búferes con OCI-Lob::flush antes de deahabilitarlos.

Parámetros

lob_from

El LOB copiado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::flush
  • OCI-Lob::setBuffering
  • OCI-Lob::getBuffering


Cierra un descriptor de LOB

  • « OCI-Lob::append
  • OCI-Lob::eof »
  • PHP Manual
  • OCI-Lob
  • Cierra un descriptor de LOB

OCI-Lob::close

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::close — Cierra un descriptor de LOB

Descripción

OCI-Lob::close ( ) : bool

Cierra un descriptor de LOB o FILE. Esta función debería usarse únicamente con OCI-Lob::writeTemporary.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::writeTemporary


Comprueba la marca de final de fichero en un descriptor de objetos grandes

  • « OCI-Lob::close
  • OCI-Lob::erase »
  • PHP Manual
  • OCI-Lob
  • Comprueba la marca de final de fichero en un descriptor de objetos grandes

OCI-Lob::eof

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::eof — Comprueba la marca de final de fichero en un descriptor de objetos grandes

Descripción

OCI-Lob::eof ( ) : bool

Indica si el puntero interno de objetos grandes está al final del LOB.

Valores devueltos

Devuelve true si el puntero interno de objetos grandes está al final del LOB. Otherwise returns false.

Notas

Nota:

Esta función devolverá un error de Oracle si OCI-Lob::setBuffering está habilitado en el LOB.

Ver también

  • OCI-Lob::size


Borra la porción especificada de los datos internos de un LOB

  • « OCI-Lob::eof
  • OCI-Lob::export »
  • PHP Manual
  • OCI-Lob
  • Borra la porción especificada de los datos internos de un LOB

OCI-Lob::erase

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::erase — Borra la porción especificada de los datos internos de un LOB

Descripción

OCI-Lob::erase ( int $offset = ? , int $length = ? ) : int

Borra una porción especificada de los datos internos de un LOB comenzando en el índice dado por offset. Si se invoca sin parámetros, borrará todos los datos del LOB.

Para BLOBs, el hecho de borrar significa que el valor del LOB existente se sobrescribe con bytes cero. Para CLOBs, el valor del LOB existente se sobrescribe con espacios.

Parámetros

offset

length

Valores devueltos

Devuelve el número real de caracteres/bytes borrados o false en caso de error.

Ver también

  • OCI-Lob::truncate


Exporta el contenido de un LOB a un fichero

  • « OCI-Lob::erase
  • OCI-Lob::flush »
  • PHP Manual
  • OCI-Lob
  • Exporta el contenido de un LOB a un fichero

OCI-Lob::export

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::export — Exporta el contenido de un LOB a un fichero

Descripción

OCI-Lob::export ( string $filename , int $start = ? , int $length = ? ) : bool

Exporta el contenido de un LOB a un fichero.

Parámetros

filename

La ruta del fichero.

start

Indica desde dónde se empieza a exportar.

length

Indica la longitud de los datos a exportar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::import


Vacía/escribe el búfer de un LOB al servidor

  • « OCI-Lob::export
  • OCI-Lob::free »
  • PHP Manual
  • OCI-Lob
  • Vacía/escribe el búfer de un LOB al servidor

OCI-Lob::flush

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::flush — Vacía/escribe el búfer de un LOB al servidor

Descripción

OCI-Lob::flush ( int $flag = ? ) : bool

OCI-Lob::flush() en realidad escribe datos en el servidor.

Parámetros

flag

Por omisión, los recursos no son liberados, aunque usando la bandera OCI_LOB_BUFFER_FREE se puede hacer explícitamente. Asegúrese de saber lo que está haciendo: la siguiente operación de lectura/escritura a la misma parte del LOB supondrá un viaje de ida y vuelta al servidor e inicilizará nuevos recursos de búfer. Se recomienda usar la bandera OCI_LOB_BUFFER_FREE solamente cuando no se vaya a trabajar más con el LOB.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Devuelve false si el uso del búfer no estaba habilitado u ocurrió un error.

Ver también

  • OCI-Lob::getBuffering
  • OCI-Lob::setBuffering


Libera los recursos asociados con el descriptor del LOB

  • « OCI-Lob::flush
  • OCI-Lob::getBuffering »
  • PHP Manual
  • OCI-Lob
  • Libera los recursos asociados con el descriptor del LOB

OCI-Lob::free

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::free — Libera los recursos asociados con el descriptor del LOB

Descripción

OCI-Lob::free ( ) : bool

Libera los recursos asociados con el descriptor, previamente asignados con oci_new_descriptor().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve el estado actual del uso del búfer para un objeto grande

  • « OCI-Lob::free
  • OCI-Lob::import »
  • PHP Manual
  • OCI-Lob
  • Devuelve el estado actual del uso del búfer para un objeto grande

OCI-Lob::getBuffering

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::getBuffering — Devuelve el estado actual del uso del búfer para un objeto grande

Descripción

OCI-Lob::getBuffering ( ) : bool

Indica si el almacenamiento en búfer para objetos grandes está activado o no.

Valores devueltos

Devuelve false si el almacenamiento en búfer de objetos grandes está desactivado, y true si se utiliza dicho almacenamiento.

Ver también

  • OCI-Lob::setBuffering


Importa datos de un fichero a un LOB

  • « OCI-Lob::getBuffering
  • OCI-Lob::load »
  • PHP Manual
  • OCI-Lob
  • Importa datos de un fichero a un LOB

OCI-Lob::import

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::import — Importa datos de un fichero a un LOB

Descripción

OCI-Lob::import ( string $filename ) : bool

Escribe datos desde el fichero dado por filename a la posición actual del objeto grande.

Parámetros

filename

La ruta del fichero.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::export
  • OCI-Lob::write


Devuelve el contenido de un objeto grande

  • « OCI-Lob::import
  • OCI-Lob::read »
  • PHP Manual
  • OCI-Lob
  • Devuelve el contenido de un objeto grande

OCI-Lob::load

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::load — Devuelve el contenido de un objeto grande

Descripción

OCI-Lob::load ( ) : string

Devuelve el contenido de un objeto grande. Ya que la ejecución de un script finaliza cuando se alcanza el valor de memory_limit, asegúrese de que el LOB no execede dicho límite. En la mayoría de los casos se recomienda usar en su lugar OCI-Lob::read.

Valores devueltos

Devuelve el contenido del objeto, o false en caso de error.

Ver también

  • OCI-Lob::read


Lee parte del objeto grande

  • « OCI-Lob::load
  • OCI-Lob::rewind »
  • PHP Manual
  • OCI-Lob
  • Lee parte del objeto grande

OCI-Lob::read

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::read — Lee parte del objeto grande

Descripción

OCI-Lob::read ( int $length ) : string

Lee length bytes desde la posición actual del puntero interno del LOB.

La lectura se detiene cuando se han leído length bytes o se alcance el final del objeto grande. El puntero interno del objeto grande será desplazado a la cantidad de bytes leídos.

Parámetros

length

La longitud de los datos a leer, en bytes. Los valores grandes serán redondeados a 1 MB.

Valores devueltos

Devuelve el contenido como un string, o false en caso de error.

Ver también

  • OCI-Lob::load
  • OCI-Lob::write


Mueve el puntero interno al comienzo de un objeto grande

  • « OCI-Lob::read
  • OCI-Lob::save »
  • PHP Manual
  • OCI-Lob
  • Mueve el puntero interno al comienzo de un objeto grande

OCI-Lob::rewind

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::rewind — Mueve el puntero interno al comienzo de un objeto grande

Descripción

OCI-Lob::rewind ( ) : bool

Establece el puntero interno al comienzo de un objeto grande.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::seek
  • OCI-Lob::tell


Guarda datos en un objeto grande

  • « OCI-Lob::rewind
  • OCI-Lob::saveFile »
  • PHP Manual
  • OCI-Lob
  • Guarda datos en un objeto grande

OCI-Lob::save

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::save — Guarda datos en un objeto grande

Descripción

OCI-Lob::save ( string $data , int $offset = ? ) : bool

Guarda los datos dados por data en un objeto grande.

Parámetros

data

Los datos a guardar.

offset

Se puede usar para señalar el índice desde el comienzo del objeto grande.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::write
  • OCI-Lob::import


Alias de OCI-Lob::import

  • « OCI-Lob::save
  • OCI-Lob::seek »
  • PHP Manual
  • OCI-Lob
  • Alias de OCI-Lob::import

OCI-Lob::saveFile

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::saveFile — Alias de OCI-Lob::import()

Descripción

Esta función es un alias de: OCI-Lob::import().


Ubica el puntero interno de un objeto grande

  • « OCI-Lob::saveFile
  • OCI-Lob::setBuffering »
  • PHP Manual
  • OCI-Lob
  • Ubica el puntero interno de un objeto grande

OCI-Lob::seek

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::seek — Ubica el puntero interno de un objeto grande

Descripción

OCI-Lob::seek ( int $offset , int $whence = OCI_SEEK_SET ) : bool

Ubica el puntero interno de un objeto grande.

Parámetros

offset

Indica la cantidad de bytes que se moverá el puntero interno según el modo dado por whence.

whence

Puede ser una de las siguientes constantes:

  • OCI_SEEK_SET - establece la posición igual a offset
  • OCI_SEEK_CUR - añade offset bytes a la posición actual
  • OCI_SEEK_END - añade offset bytes al final del objeto grande (use un valor negativo para moverse a una posición anterior del final del objeto grande)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::rewind
  • OCI-Lob::tell
  • OCI-Lob::eof


Cambia el estado actual del uso del búfer para objetos grandes

  • « OCI-Lob::seek
  • OCI-Lob::size »
  • PHP Manual
  • OCI-Lob
  • Cambia el estado actual del uso del búfer para objetos grandes

OCI-Lob::setBuffering

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::setBuffering — Cambia el estado actual del uso del búfer para objetos grandes

Descripción

OCI-Lob::setBuffering ( bool $on_off ) : bool

Establece el uso del búfer para objetos grandes, dependiendo del valor del parámetro on_off.

El uso de esta función podría proporcionar mejoras en el rendimiento mediante el almacenamiento en búfer de lecturas y escrituras pequeñas de LOBs, reduciendo del número de viajes de ida y vuelta de la red y las versiones del LOB. Debería usarse OCI-Lob::flush() para vaciar los búferes cuando se haya finalizado de trabajar con el objeto grande.

Parámetros

on_off

true para activarlo y false para desactivarlo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Repetidas llamadas a este método con la misma bandera devolverán true.

Ver también

  • OCI-Lob::getBuffering


Devuelve el tamaño de un objeto grande

  • « OCI-Lob::setBuffering
  • OCI-Lob::tell »
  • PHP Manual
  • OCI-Lob
  • Devuelve el tamaño de un objeto grande

OCI-Lob::size

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::size — Devuelve el tamaño de un objeto grande

Descripción

OCI-Lob::size ( ) : int

Obtiene el tamaño de un objeto grande.

Valores devueltos

Devuelve la longitud del valor del objeto grande o false en caso de error. Los objetos vacíos tienen una longitud de cero.


Devuelve la posición actual del puntero interno de un objeto grande

  • « OCI-Lob::size
  • OCI-Lob::truncate »
  • PHP Manual
  • OCI-Lob
  • Devuelve la posición actual del puntero interno de un objeto grande

OCI-Lob::tell

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::tell — Devuelve la posición actual del puntero interno de un objeto grande

Descripción

OCI-Lob::tell ( ) : int

Obtiene la posición actual del puntero interno de un LOB.

Valores devueltos

Devuelve la posición actual del puntero interno de un LOB o false si ocurrió algún error.

Ver también

  • OCI-Lob::rewind
  • OCI-Lob::size
  • OCI-Lob::eof


Trunca un objeto grande

  • « OCI-Lob::tell
  • OCI-Lob::write »
  • PHP Manual
  • OCI-Lob
  • Trunca un objeto grande

OCI-Lob::truncate

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::truncate — Trunca un objeto grande

Descripción

OCI-Lob::truncate ( int $length = 0 ) : bool

Trunca un LOB.

Parámetros

length

Si se proporciona, este método truncará el LOB en length bytes. De lo contrario, lo eliminará por completo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::erase


Escribe datos en un objeto grande

  • « OCI-Lob::truncate
  • OCI-Lob::writeTemporary »
  • PHP Manual
  • OCI-Lob
  • Escribe datos en un objeto grande

OCI-Lob::write

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::write — Escribe datos en un objeto grande

Descripción

OCI-Lob::write ( string $data , int $length = ? ) : int

Escribe los datos del parámetro data en la posición actual del puntero interno del LOB.

Parámetros

data

Los datos a escribir en el LOB.

length

Si se proporciona este parámetro, la escritura se dentendrá después de que se hayan escrito length bytes o se alcance el final de data, lo que suceda primero.

Valores devueltos

Devuelve el número de bytes escritos o false en caso de error.

Ver también

  • OCI-Lob::read


Escribe un objeto grande temporal

  • « OCI-Lob::write
  • OCI-Lob::writeToFile »
  • PHP Manual
  • OCI-Lob
  • Escribe un objeto grande temporal

OCI-Lob::writeTemporary

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::writeTemporary — Escribe un objeto grande temporal

Descripción

OCI-Lob::writeTemporary ( string $data , int $lob_type = OCI_TEMP_CLOB ) : bool

Crea un objeto grande temporal y escribe los datos dados por data en él.

Debería usarse OCI-Lob::close al finalizar de usar este objeto.

Parámetros

data

Los datos a escribir.

lob_type

Puede ser una de las siguientes constantes:

  • OCI_TEMP_BLOB se utiliza para crear BLOBs temporales
  • OCI_TEMP_CLOB se utiliza para crear CLOBs temporales

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OCI-Lob::close


Alias de OCI-Lob::export

  • « OCI-Lob::writeTemporary
  • Funciones y alias de OCI8 obsoletos »
  • PHP Manual
  • OCI-Lob
  • Alias de OCI-Lob::export

OCI-Lob::writeToFile

(No hay información de versión disponible, podría estar únicamente en Git)

OCI-Lob::writeToFile — Alias de OCI-Lob::export()

Descripción

Esta función es un alias de: OCI-Lob::export().


Funciones y alias de OCI8 obsoletos

Tabla de contenidos

  • oci_internal_debug — Enables or disables internal debug output
  • ocibindbyname — Alias de oci_bind_by_name
  • ocicancel — Alias de oci_cancel
  • ocicloselob — Alias de OCI-Lob::close
  • ocicollappend — Alias de OCI-Collection::append
  • ocicollassign — Alias de OCI-Collection::assign
  • ocicollassignelem — Alias de OCI-Collection::assignElem
  • ocicollgetelem — Alias de OCI-Collection::getElem
  • ocicollmax — Alias de OCI-Collection::max
  • ocicollsize — Alias de OCI-Collection::size
  • ocicolltrim — Alias de OCI-Collection::trim
  • ocicolumnisnull — Alias de oci_field_is_null
  • ocicolumnname — Alias de oci_field_name
  • ocicolumnprecision — Alias de oci_field_precision
  • ocicolumnscale — Alias de oci_field_scale
  • ocicolumnsize — Alias de oci_field_size
  • ocicolumntype — Alias de oci_field_type
  • ocicolumntyperaw — Alias de oci_field_type_raw
  • ocicommit — Alias de oci_commit
  • ocidefinebyname — Alias de oci_define_by_name
  • ocierror — Alias de oci_error
  • ociexecute — Alias de oci_execute
  • ocifetch — Alias de oci_fetch
  • ocifetchinto — Variante obsoleta de oci_fetch_array, oci_fetch_object, oci_fetch_assoc y oci_fetch_row
  • ocifetchstatement — Alias de oci_fetch_all
  • ocifreecollection — Alias de OCI-Collection::free
  • ocifreecursor — Alias de oci_free_statement
  • ocifreedesc — Alias de OCI-Lob::free
  • ocifreestatement — Alias de oci_free_statement
  • ociinternaldebug — Alias de oci_internal_debug
  • ociloadlob — Alias de OCI-Lob::load
  • ocilogoff — Alias de oci_close
  • ocilogon — Alias de oci_connect
  • ocinewcollection — Alias de oci_new_collection
  • ocinewcursor — Alias de oci_new_cursor
  • ocinewdescriptor — Alias de oci_new_descriptor
  • ocinlogon — Alias de oci_new_connect
  • ocinumcols — Alias de oci_num_fields
  • ociparse — Alias de oci_parse
  • ociplogon — Alias de oci_pconnect
  • ociresult — Alias de oci_result
  • ocirollback — Alias de oci_rollback
  • ocirowcount — Alias de oci_num_rows
  • ocisavelob — Alias de OCI-Lob::save
  • ocisavelobfile — Alias de OCI-Lob::import
  • ociserverversion — Alias de oci_server_version
  • ocisetprefetch — Alias de oci_set_prefetch
  • ocistatementtype — Alias de oci_statement_type
  • ociwritelobtofile — Alias de OCI-Lob::export
  • ociwritetemporarylob — Alias de OCI-Lob::writeTemporary


Enables or disables internal debug output

  • « Funciones y alias de OCI8 obsoletos
  • ocibindbyname »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Enables or disables internal debug output

oci_internal_debug

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0, PECL OCI8 <= 2.2.0)

oci_internal_debug — Enables or disables internal debug output

Descripción

oci_internal_debug ( bool $onoff ) : void

Enables or disables internal debug output.

Parámetros

onoff

Set this to false to turn debug output off or true to turn it on.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

This function was removed in PHP 8 and PECL OCI8 3.0.

Nota:

This function is a no-op in PHP 5.6 and PECL OCI8 2.0. Use DTrace instead.

Nota:

In PHP versions before 5.0.0 you must use ociinternaldebug() instead. This name still can be used, it was left as alias of oci_internal_debug() for downwards compatability. This, however, is deprecated and not recommended.


Alias de oci_bind_by_name

  • « oci_internal_debug
  • ocicancel »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_bind_by_name

ocibindbyname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocibindbyname — Alias de oci_bind_by_name()

Descripción

Alias de oci_bind_by_name()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_cancel

  • « ocibindbyname
  • ocicloselob »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_cancel

ocicancel

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicancel — Alias de oci_cancel()

Descripción

Alias de oci_cancel()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::close

  • « ocicancel
  • ocicollappend »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::close

ocicloselob

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 1.0)

ocicloselob — Alias de OCI-Lob::close()

Descripción

Alias de OCI-Lob::close()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::append

  • « ocicloselob
  • ocicollassign »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::append

ocicollappend

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollappend — Alias de OCI-Collection::append()

Descripción

Alias de OCI-Collection::append()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::assign

  • « ocicollappend
  • ocicollassignelem »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::assign

ocicollassign

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollassign — Alias de OCI-Collection::assign()

Descripción

Alias de OCI-Collection::assign()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::assignElem

  • « ocicollassign
  • ocicollgetelem »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::assignElem

ocicollassignelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollassignelem — Alias de OCI-Collection::assignElem()

Descripción

Alias de OCI-Collection::assignElem()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::getElem

  • « ocicollassignelem
  • ocicollmax »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::getElem

ocicollgetelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollgetelem — Alias de OCI-Collection::getElem()

Descripción

Alias de OCI-Collection::getElem()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::max

  • « ocicollgetelem
  • ocicollsize »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::max

ocicollmax

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollmax — Alias de OCI-Collection::max()

Descripción

Alias de OCI-Collection::max()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::size

  • « ocicollmax
  • ocicolltrim »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::size

ocicollsize

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollsize — Alias de OCI-Collection::size()

Descripción

Alias de OCI-Collection::size()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::trim

  • « ocicollsize
  • ocicolumnisnull »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::trim

ocicolltrim

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolltrim — Alias de OCI-Collection::trim()

Descripción

Alias de OCI-Collection::trim()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_is_null

  • « ocicolltrim
  • ocicolumnname »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_is_null

ocicolumnisnull

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnisnull — Alias de oci_field_is_null()

Descripción

Alias de oci_field_is_null()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_name

  • « ocicolumnisnull
  • ocicolumnprecision »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_name

ocicolumnname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnname — Alias de oci_field_name()

Descripción

Alias de oci_field_name()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_precision

  • « ocicolumnname
  • ocicolumnscale »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_precision

ocicolumnprecision

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnprecision — Alias de oci_field_precision()

Descripción

Alias de oci_field_precision()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_scale

  • « ocicolumnprecision
  • ocicolumnsize »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_scale

ocicolumnscale

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnscale — Alias de oci_field_scale()

Descripción

Alias de oci_field_scale()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_size

  • « ocicolumnscale
  • ocicolumntype »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_size

ocicolumnsize

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnsize — Alias de oci_field_size()

Descripción

Alias de oci_field_size()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_type

  • « ocicolumnsize
  • ocicolumntyperaw »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_type

ocicolumntype

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumntype — Alias de oci_field_type()

Descripción

Alias de oci_field_type()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_field_type_raw

  • « ocicolumntype
  • ocicommit »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_field_type_raw

ocicolumntyperaw

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumntyperaw — Alias de oci_field_type_raw()

Descripción

Alias de oci_field_type_raw()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_commit

  • « ocicolumntyperaw
  • ocidefinebyname »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_commit

ocicommit

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicommit — Alias de oci_commit()

Descripción

Alias de oci_commit()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_define_by_name

  • « ocicommit
  • ocierror »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_define_by_name

ocidefinebyname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocidefinebyname — Alias de oci_define_by_name()

Descripción

Alias de oci_define_by_name()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_error

  • « ocidefinebyname
  • ociexecute »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_error

ocierror

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocierror — Alias de oci_error()

Descripción

Alias de oci_error()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_execute

  • « ocierror
  • ocifetch »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_execute

ociexecute

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociexecute — Alias de oci_execute()

Descripción

Alias de oci_execute()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_fetch

  • « ociexecute
  • ocifetchinto »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_fetch

ocifetch

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetch — Alias de oci_fetch()

Descripción

Alias de oci_fetch()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Variante obsoleta de oci_fetch_array, oci_fetch_object, oci_fetch_assoc y oci_fetch_row

  • « ocifetch
  • ocifetchstatement »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Variante obsoleta de oci_fetch_array, oci_fetch_object, oci_fetch_assoc y oci_fetch_row

ocifetchinto

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetchinto — Variante obsoleta de oci_fetch_array(), oci_fetch_object(), oci_fetch_assoc() y oci_fetch_row()

Descripción

Variante absoleta de oci_fetch_array(), oci_fetch_object(),
  oci_fetch_assoc() y
  oci_fetch_row()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_fetch_all

  • « ocifetchinto
  • ocifreecollection »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_fetch_all

ocifetchstatement

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetchstatement — Alias de oci_fetch_all()

Descripción

Alias de oci_fetch_all()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Collection::free

  • « ocifetchstatement
  • ocifreecursor »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Collection::free

ocifreecollection

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreecollection — Alias de OCI-Collection::free()

Descripción

Alias de OCI-Collection::free()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_free_statement

  • « ocifreecollection
  • ocifreedesc »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_free_statement

ocifreecursor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreecursor — Alias de oci_free_statement()

Descripción

Alias de oci_free_statement()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::free

  • « ocifreecursor
  • ocifreestatement »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::free

ocifreedesc

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreedesc — Alias de OCI-Lob::free()

Descripción

Alias de OCI-Lob::free()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_free_statement

  • « ocifreedesc
  • ociinternaldebug »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_free_statement

ocifreestatement

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreestatement — Alias de oci_free_statement()

Descripción

Alias de oci_free_statement()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_internal_debug

  • « ocifreestatement
  • ociloadlob »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_internal_debug

ociinternaldebug

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0, PECL OCI8 <= 2.2.0)

ociinternaldebug — Alias de oci_internal_debug()

Descripción

Alias de oci_internal_debug()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::load

  • « ociinternaldebug
  • ocilogoff »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::load

ociloadlob

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociloadlob — Alias de OCI-Lob::load()

Descripción

Alias de OCI-Lob::load()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_close

  • « ociloadlob
  • ocilogon »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_close

ocilogoff

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocilogoff — Alias de oci_close()

Descripción

Alias de oci_close()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_connect

  • « ocilogoff
  • ocinewcollection »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_connect

ocilogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocilogon — Alias de oci_connect()

Descripción

Alias de oci_connect()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_new_collection

  • « ocilogon
  • ocinewcursor »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_new_collection

ocinewcollection

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewcollection — Alias de oci_new_collection()

Descripción

Alias de oci_new_collection()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_new_cursor

  • « ocinewcollection
  • ocinewdescriptor »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_new_cursor

ocinewcursor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewcursor — Alias de oci_new_cursor()

Descripción

Alias de oci_new_cursor()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_new_descriptor

  • « ocinewcursor
  • ocinlogon »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_new_descriptor

ocinewdescriptor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewdescriptor — Alias de oci_new_descriptor()

Descripción

Alias de oci_new_descriptor()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_new_connect

  • « ocinewdescriptor
  • ocinumcols »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_new_connect

ocinlogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinlogon — Alias de oci_new_connect()

Descripción

Alias de oci_new_connect()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_num_fields

  • « ocinlogon
  • ociparse »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_num_fields

ocinumcols

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinumcols — Alias de oci_num_fields()

Descripción

Alias de oci_num_fields()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_parse

  • « ocinumcols
  • ociplogon »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_parse

ociparse

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociparse — Alias de oci_parse()

Descripción

Alias de oci_parse()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_pconnect

  • « ociparse
  • ociresult »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_pconnect

ociplogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociplogon — Alias de oci_pconnect()

Descripción

Alias de oci_pconnect()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_result

  • « ociplogon
  • ocirollback »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_result

ociresult

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociresult — Alias de oci_result()

Descripción

Alias de oci_result()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_rollback

  • « ociresult
  • ocirowcount »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_rollback

ocirollback

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocirollback — Alias de oci_rollback()

Descripción

Alias de oci_rollback()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_num_rows

  • « ocirollback
  • ocisavelob »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_num_rows

ocirowcount

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocirowcount — Alias de oci_num_rows()

Descripción

Alias de oci_num_rows()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::save

  • « ocirowcount
  • ocisavelobfile »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::save

ocisavelob

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisavelob — Alias de OCI-Lob::save()

Descripción

Alias de OCI-Lob::save()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::import

  • « ocisavelob
  • ociserverversion »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::import

ocisavelobfile

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisavelobfile — Alias de OCI-Lob::import()

Descripción

Alias de OCI-Lob::import()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_server_version

  • « ocisavelobfile
  • ocisetprefetch »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_server_version

ociserverversion

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociserverversion — Alias de oci_server_version()

Descripción

Alias de oci_server_version()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_set_prefetch

  • « ociserverversion
  • ocistatementtype »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_set_prefetch

ocisetprefetch

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisetprefetch — Alias de oci_set_prefetch()

Descripción

Alias de oci_set_prefetch()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de oci_statement_type

  • « ocisetprefetch
  • ociwritelobtofile »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de oci_statement_type

ocistatementtype

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocistatementtype — Alias de oci_statement_type()

Descripción

Alias de oci_statement_type()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::export

  • « ocistatementtype
  • ociwritetemporarylob »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::export

ociwritelobtofile

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociwritelobtofile — Alias de OCI-Lob::export()

Descripción

Alias de OCI-Lob::export()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Alias de OCI-Lob::writeTemporary

  • « ociwritelobtofile
  • Paradox »
  • PHP Manual
  • Funciones y alias de OCI8 obsoletos
  • Alias de OCI-Lob::writeTemporary

ociwritetemporarylob

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 1.0)

ociwritetemporarylob — Alias de OCI-Lob::writeTemporary()

Descripción

Alias de OCI-Lob::writeTemporary()

Advertencia

Este alias ha sido declarado OBSOLETO desde PHP 5.4.0. Su uso está totalmente desaconsejado.


Acceso a archivos Paradox

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Paradox
    • px_close — Cerrar una base de datos paradox
    • px_create_fp — Crear una nueva base de datos paradox
    • px_date2string — Convierte una fecha en una cadena.
    • px_delete_record — Eliminar los registros de base de datos paradox
    • px_delete — Eliminar los recursos de la base de datos paradox
    • px_get_field — Devuelve la especificación de un solo campo
    • px_get_info — Devuelve una gran cantidad de información sobre un archivo paradox
    • px_get_parameter — Obtener un parámetro
    • px_get_record — Devuelve registro de base de datos paradox
    • px_get_schema — Devuelve la definición de la base de datos (schema)
    • px_get_value — Obtener un valor
    • px_insert_record — Inserta registro en base de datos paradox
    • px_new — Crear un nuevo objeto paradox
    • px_numfields — Devuelve el número de campos en una base de datos
    • px_numrecords — Devuelve el número de registros en una base de datos
    • px_open_fp — Abrir base de datos paradox
    • px_put_record — Almacenar registro en la base de datos paradox
    • px_retrieve_record — Devolver registro de base de datos paradox
    • px_set_blob_file — Establecer el archivo desde donde los blobs se van a leer
    • px_set_parameter — Establecer un parámetro
    • px_set_tablename — Establecer el nombre de una tabla (obsoleto)
    • px_set_targetencoding — Establecer la codificación de los campos de caracteres (obsoleto)
    • px_set_value — Establecer un valor
    • px_timestamp2string — Convertir la fecha y la hora en una cadena.
    • px_update_record — Actualizar el registro en la base de datos paradox


Introducción

Este módulo permite leer y escribir bases de datos Paradox, archivos primary index y archivos blob. El soporte de escritura ha demostrado ser muy fiable, aunque debido a la falta de documentación de los archivos producidos no podrán en ningún caso, ser leídos por otras aplicaciones. Las bases de datos cifradas pueden ser ser leídas sin especificar una contraseña si se utiliza pxlib >= 0.5.0.

Nota:

Este módulo también está en desarrollo y puede cambiar, aunque no se espera que haya cambios importantes en la API.

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.


Requerimientos

Se necesita por lo menos PHP 5.0.0 y pxlib >= 0.4.4 para el conjunto básico de funciones. Algunas de las funciones más recientes están disponibles sólo para pxlib >= 0.6.0. Leer y escribir de bases de datos encriptadas requieren por lo menos de pxlib >= 0.5.0. La librería paradox(pxlib) está disponible en » http://pxlib.sourceforge.net.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/paradox

Asegúrese de que tiene pxlib instalado antes. Si instala pxlib de un paquete RPM o Debian, no se olvide de instalar el paquete de desarrollo también.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

La función px_new() crea un nuevo objeto Paradox requerida por todas las funciones Paradox.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las dos siguientes tablas listan todas las constantes definido por la extensión paradox.

Contantes para tipos de campo
Nombre | Significado
PX_FIELD_ALPHA | Datos de tipo carácter de longitud fija
PX_FIELD_DATE | Fecha, el número de días desde el 1.1.0000
PX_FIELD_SHORT | Entero de tamaño corto (2 Bytes)
PX_FIELD_LONG | Entero de tamaño largo (4 Bytes)
PX_FIELD_CURRENCY | Igual que PX_FIELD_NUMBER
PX_FIELD_NUMBER | Double
PX_FIELD_LOGICAL | Booleano
PX_FIELD_MEMOBLOB | Objeto grande binario
PX_FIELD_BLOB | Objeto grande binario (No se admite)
PX_FIELD_FMTMEMOBLOB | Objeto grande binario
PX_FIELD_OLE | Objeto OLE (básicamente un blob, no se admite)
PX_FIELD_GRAPHIC | Gráfico (básicamente un blob, no se admite)
PX_FIELD_TIME | tiempo, número de milisegundos desde la medianoche
PX_FIELD_TIMESTAMP | fecha y hora, número de milisegundos desde el 1.1.0000
PX_FIELD_AUTOINC | Incremento automático de enteros (como PX_FIELD_LONG)
PX_FIELD_BCD | Número decimal almacenado en formato BCD (no se admite)
PX_FIELD_BYTES | Matriz de bytes con un máximo de 255 bytes (no se admite)
PX_KEYTOLOWER | Convertir todos los nombres de campo en minúsculas
PX_KEYTOUPPER | Convertir todos los nombres de campo en mayúsculas
Contantes para tipos de archivos
Nombre | Significado
PX_FILE_INDEX_DB | Base de datos indexada
PX_FILE_PRIM_INDEX | Índice primario
PX_FILE_NON_INDEX_DB | Ninguna base de datos indexada
PX_FILE_NON_INC_SEC_INDEX | Ningún índice secundario incremental
PX_FILE_SEC_INDEX | Índice secundario
PX_FILE_INC_SEC_INDEX | Índice secundario incremental
PX_FILE_NON_INC_SEC_INDEX_G | Índice secundario no incremental
PX_FILE_SEC_INDEX_G | Índice secundario
PX_FILE_INC_SEC_INDEX_G | Índice secundario no incremental


Funciones de Paradox

API orientada a objetos

La extensión paradox ofrece también una API orientada a objetos. Esta consta de una sola clase llamada paradox_db. Sus métodos sólo difieren de las funciones en su nombre y, por supuesto, el primer parámetro que falta. La siguiente tabla lista todos los métodos y sus funciones equivalentes.

Los métodos de la clase paradox_db
Nombre del método | Función equivalente
Constructor | px_new()
Destructor | px_delete()
open_fp() | px_open_fp()
create_fp() | px_create_fp()
close() | px_close()
numrecords() | px_numrecords()
numfields() | px_numfields()
get_record() | px_get_record()
put_record() | px_put_record()
retrieve_record() | px_retrieve_record()
delete_record() | px_delete_record()
insert_record() | px_insert_record()
update_record() | px_update_record()
get_field() | px_get_field()
get_schema() | px_get_schema()
get_info() | px_get_info()
set_parameter() | px_set_parameter()
get_parameter() | px_get_parameter()
set_value() | px_set_value()
get_value() | px_get_value()
get_info() | px_get_info()
set_targetencoding() | px_set_targetencoding()
set_tablename() | px_set_tablename()
set_blob_file() | px_set_blob_file()
date2string() | px_date2string()
timestamp2string() | px_timestamp2string()

Tabla de contenidos

  • px_close — Cerrar una base de datos paradox
  • px_create_fp — Crear una nueva base de datos paradox
  • px_date2string — Convierte una fecha en una cadena.
  • px_delete_record — Eliminar los registros de base de datos paradox
  • px_delete — Eliminar los recursos de la base de datos paradox
  • px_get_field — Devuelve la especificación de un solo campo
  • px_get_info — Devuelve una gran cantidad de información sobre un archivo paradox
  • px_get_parameter — Obtener un parámetro
  • px_get_record — Devuelve registro de base de datos paradox
  • px_get_schema — Devuelve la definición de la base de datos (schema)
  • px_get_value — Obtener un valor
  • px_insert_record — Inserta registro en base de datos paradox
  • px_new — Crear un nuevo objeto paradox
  • px_numfields — Devuelve el número de campos en una base de datos
  • px_numrecords — Devuelve el número de registros en una base de datos
  • px_open_fp — Abrir base de datos paradox
  • px_put_record — Almacenar registro en la base de datos paradox
  • px_retrieve_record — Devolver registro de base de datos paradox
  • px_set_blob_file — Establecer el archivo desde donde los blobs se van a leer
  • px_set_parameter — Establecer un parámetro
  • px_set_tablename — Establecer el nombre de una tabla (obsoleto)
  • px_set_targetencoding — Establecer la codificación de los campos de caracteres (obsoleto)
  • px_set_value — Establecer un valor
  • px_timestamp2string — Convertir la fecha y la hora en una cadena.
  • px_update_record — Actualizar el registro en la base de datos paradox


Cerrar una base de datos paradox

  • « Funciones de Paradox
  • px_create_fp »
  • PHP Manual
  • Funciones de Paradox
  • Cerrar una base de datos paradox

px_close

(PECL paradox >= 1.0.0)

px_close — Cerrar una base de datos paradox

Descripción

px_close ( resource $pxdoc ) : bool

Cierra la base de datos paradox. Esta función no cierra el archivo. Deberá llamar seguidamente a la función fclose().

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • px_open_fp() - Abrir base de datos paradox
  • Ejemplo de la función px_new() - Crear un nuevo objeto paradox


Crear una nueva base de datos paradox

  • « px_close
  • px_date2string »
  • PHP Manual
  • Funciones de Paradox
  • Crear una nueva base de datos paradox

px_create_fp

(PECL paradox >= 1.0.0)

px_create_fp — Crear una nueva base de datos paradox

Descripción

px_create_fp ( resource $pxdoc , resource $file , array $fielddesc ) : bool

Crea un nuevo archivo de base de datos paradox. El archivo actual deberá abrirse antes con la función fopen(). Asegúrese de que el archivo tiene permisos de escritura.

Nota:

Al llamar a estas funciones emite una advertencia acerca de un nombre de tabla vacía que se puede omitir con seguridad. Sólo tiene que configurar el nombre de tabla posteriormente con la función px_set_parameter().

Nota:

Esta función es muy experimental, debido a la insuficiente documentación del formato de archivo paradox. Los archivos de base de datos creados con esta función pueden ser abiertos con la función px_open_fp() y han sido abiertos con éxito por el software de Paradox, pero algunos puntos pueden variar.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devueltos por la función px_new().

file

Identificador de archivo devuelto por la función fopen().

fielddesc

La opción fielddesc es una matriz que contiene un elemento por cada campo especificado. Un campo especificado es una matriz propia con dos o tres elementos. El primer elemento es siempre un valor de cadena utilizado como el nombre del campo. Este no puede ser mayor de diez carácteres. El segundo elemento contiene el tipo de campo que es una de las constantes que figuran en la tabla.Las constantes para los tipos de campo. En el caso de un campo de caracteres o campo BCD, tendrá que proporcionar un tercer elemento especificando la longitud respectivamente a la precesión del campo. Si su especificación de campo contiene campos blob, tendrá que asegurarse de hacer el campo lo suficientemente grande para que se adapte a todos los valores de campo o especificar un archivo blob con la función px_set_blob_file() para almacenar los blobs. Si esto no se hace los datos del campo se truncarán.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Creación de una base de datos Paradox con dos campos

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "w+");
$fields = array(array("col1", "S"), array("col2", "I"));
if(!px_create_fp($pxdoc, $fp, $fields)) {
  /* Error handling */
}
px_set_parameter($pxdoc, "tablename", "testtable");
for($i=-50; $i<50; $i++) {
  $rec = array($i, -$i);
  px_put_record($pxdoc, $rec);
}
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

Ver también

  • px_new() - Crear un nuevo objeto paradox
  • px_put_record() - Almacenar registro en la base de datos paradox
  • fopen() - Abre un fichero o un URL


Convierte una fecha en una cadena.

  • « px_create_fp
  • px_delete_record »
  • PHP Manual
  • Funciones de Paradox
  • Convierte una fecha en una cadena.

px_date2string

(PECL paradox >= 1.4.0)

px_date2string — Convierte una fecha en una cadena.

Descripción

px_date2string ( resource $pxdoc , int $value , string $format ) : string

Convierte una fecha, ya almacenada en el archivo paradox en formato legible por humanos. Las fechas Paradox son el número de días desde el 1.1.0000. Esta función es sólo por conveniencia. Puede ser fácilmente reemplazada por algunas funciones matemáticas y de calendario como se demuestra en el siguiente ejemplo.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

value

Valor almacenado en la base de datos paradox del tipo de campo PX_FIELD_DATE.

format

Cadena de formato similar al formato utilizado por la función date(). Los marcadores de posición admitidos por esta función es un subconjunto de los admitidos por la función date() (Y, y, m, n, d, j, L).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Convierte una fecha en el archivo paradox en un formato legible por humanos

<?php
$px = px_new();

/* Construir una fecha y almacenarla en */
/* un campo fecha de una base de datos paradox. */
/* 700000 días desde el 1.1.0000. */
$days = 700000;

/* Usar las funciones de calendario para imprimir un */
/* formato de fecha legible por humanos */
echo jdtogregorian($days+1721425)."\n";
/* px_date2string() la misma salida */
echo px_date2string($px, $days, "n/d/Y")."\n";

px_delete($px);
?>

El resultado del ejemplo sería:

7/15/1917
7/15/1917

Ver también

  • px_timestamp2string() - Convertir la fecha y la hora en una cadena.
  • jdtogregorian() - Convierte una Fecha Juliana en una fecha Gregoriana


Eliminar los registros de base de datos paradox

  • « px_date2string
  • px_delete »
  • PHP Manual
  • Funciones de Paradox
  • Eliminar los registros de base de datos paradox

px_delete_record

(PECL paradox >= 1.4.0)

px_delete_record — Eliminar los registros de base de datos paradox

Descripción

px_delete_record ( resource $pxdoc , int $num ) : bool

Esta función elimina un registro de la base de datos. Esto no libera el espacio en el archivo de base de datos, solamente lo marca como eliminado. Insertando a continuación un nuevo registro se volverá a utilizar el espacio.

Nota:

Esta función sólo está disponible si se utiliza pxlib >= 0.6.0.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

num

El registro numérico es un número artificial que cuenta los registros a medida en que se almacenan en la base de datos. El primer registro tiene el número 0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Eliminar los recursos de la base de datos paradox

  • « px_delete_record
  • px_get_field »
  • PHP Manual
  • Funciones de Paradox
  • Eliminar los recursos de la base de datos paradox

px_delete

(PECL paradox >= 1.0.0)

px_delete — Eliminar los recursos de la base de datos paradox

Descripción

px_delete ( resource $pxdoc ) : bool

Elimina el recurso del archivo paradox y libera toda la memoria.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devueltos por la función px_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve la especificación de un solo campo

  • « px_delete
  • px_get_info »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve la especificación de un solo campo

px_get_field

(PECL paradox >= 1.0.0)

px_get_field — Devuelve la especificación de un solo campo

Descripción

px_get_field ( resource $pxdoc , int $fieldno ) : array

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

fieldno

Número del campo. El primer campo tiene el número 0. Especificando un número de campo menor que 0 y mayor o igual al número de campos provocará un error trigger.

Valores devueltos

Devuelve la específicación del fieldnoésimo campo de la base de datos como un array asociado. La matriz contiene tres campos denominados name, type, y size.


Devuelve una gran cantidad de información sobre un archivo paradox

  • « px_get_field
  • px_get_parameter »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve una gran cantidad de información sobre un archivo paradox

px_get_info

(PECL paradox >= 1.0.0)

px_get_info — Devuelve una gran cantidad de información sobre un archivo paradox

Descripción

px_get_info ( resource $pxdoc ) : array

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

Valores devueltos

Devuelve una matriz asociada con una gran cantidad de información sobre un archivo paradox. Esta matriz es probable que sea ampliada en el futuro.

fileversion

Versión del archivo multiplicado por 10, por ejemplo, 70.

tablename

Nombre de la tabla tal como fué almacenada en el archivo. Si la base de datos fue creada con pxlib, entonces este será el nombre del archivo sin la extensión.

numrecords

Número de registros en esta tabla.

numfields

Número de campos en esta tabla.

headersize

Número de bytes utilizados para la cabecera. Esto es por lo general 0x800.

recordsize

Número de bytes utilizados por cada registro. Esta es la suma de todos los tamaños de campo (disponible desde la versión 1.4.2).

maxtablesize

Este valor, multiplicado por 0x400 es el tamaño de un bloque de datos en bytes. El número máximo de registros en un bloque de datos es la parte entera de (maxtablesize * 0x400 - 8) / recordsize.

numdatablocks

El número de bloques de datos en el archivo. Cada bloque de datos contiene un cierto número de registros que dependen del tamaño del registro y del tamaño del bloque de datos (maxtablesize). Los bloques de datos pueden no necesariamente estar rellenados por completo.

numindexfields

Número de campos utilizados para el índice primario. Los campos siempre se inician con el campo número 1.

codepage

El sistema de codificación DOS que fue utilizado para la codificación de los campos con datos de caracteres. Si la codificación de destino no se ha establecido con la función px_set_targetencoding() esta será la codificación de los campos de caracteres cuando se accede a los registros con la función px_get_record() o px_retrieve_record().

Ver también

  • px_numfields() - Devuelve el número de campos en una base de datos
  • px_numrecords() - Devuelve el número de registros en una base de datos


Obtener un parámetro

  • « px_get_info
  • px_get_record »
  • PHP Manual
  • Funciones de Paradox
  • Obtener un parámetro

px_get_parameter

(PECL paradox >= 1.1.0)

px_get_parameter — Obtener un parámetro

Descripción

px_get_parameter ( resource $pxdoc , string $name ) : string

Obtiene varios parámetros.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

name

El parámetro name puede ser uno de los siguientes:

tablename

El nombre de la tabla, ya que será almacenado en el encabezado de base de datos.

targetencoding

La codificación de la salida. Los datos que son leidos desde los campos de caracteres con la función px_get_record() o con la función px_retrieve_record() se recodifican en la codificación de destino. Si no se establece, entonces los datos se entregarán como fueron almacenados en el archivo de base de datos.

inputencoding

La codificación de los datos de entrada que se va a guardar en la base de datos. Al almacenar los datos de los campos de caracteres en la base de datos, se espera que los datos sean entregados en esta codificación.

Valores devueltos

Devuelve el valor del parámetro o false en caso de error.


Devuelve registro de base de datos paradox

  • « px_get_parameter
  • px_get_schema »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve registro de base de datos paradox

px_get_record

(PECL paradox >= 1.0.0)

px_get_record — Devuelve registro de base de datos paradox

Descripción

px_get_record ( resource $pxdoc , int $num , int $mode = 0 ) : array

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

num

El registro numérico es un número artificial que cuenta los registros a medida en que se almacenan en la base de datos. El primer registro tiene el número 0.

mode

El parámetro opcional mode puede ser PX_KEYTOLOWER o PX_KEYTOUPPER con el fin de convertir las claves en mayúsculas o minúsculas. Si el parámetro mode no se pasa o es 0, entonces la clave será igual que el nombre del campo. El elemento de los valores contendrá los valores de campo. Los valores NULL se conservarán y son diferentes de 0.0, 0 o la cadena vacía. Los campos de tipo PX_FIELD_TIME serán devueltos como un entero contando el número de milisegundos a partir de la medianoche. Una marca de tiempo (PX_FIELD_TIMESTAMP) y fecha (PX_FIELD_DATE) are floating point respectively int values counting milliseconds respectively days starting desde el inicio del calendario juliano. Utilice las funciones px-timestamp2string() y px-date2string() para convertirlos en una representación de caracteres.

Valores devueltos

Devuelve numésimo registro de la base de datos. El registro es devuelto como una matriz asociada con sus claves siendo los nombres de campo.

Ver también

  • px_retrieve_record() - Devolver registro de base de datos paradox


Devuelve la definición de la base de datos (schema)

  • « px_get_record
  • px_get_value »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve la definición de la base de datos (schema)

px_get_schema

(PECL paradox >= 1.0.0)

px_get_schema — Devuelve la definición de la base de datos (schema)

Descripción

px_get_schema ( resource $pxdoc , int $mode = 0 ) : array

La función px_get_schema() devuelve la definición de la base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

mode

Si el parámetro opcional mode es PX_KEYTOLOWER o PX_KEYTOUPPER las claves de la matriz devuelta serán convertidas a minúsculas o mayúsculas. Si el parámetro mode es 0 o no pasado en todos, entonces el nombre de la clave será el mismo que el nombre del campo.

Valores devueltos

Devuelve la definición de un archivo de base de datos como una matriz asociada. El nombre de la clave es igual al nombre del campo. Cada elemento de la matriz en sí es una matriz asociada array que contiene los dos campos type y size. type es una de las constantes en la tabla Las constantes de los tipos de campo. size es el número de bytes que consume este campo campo en el registro. El total de todos los tamaños de campo es igual al tamaño del registro ya que pueden ser recuperados con la función px-get-info().


Obtener un valor

  • « px_get_schema
  • px_insert_record »
  • PHP Manual
  • Funciones de Paradox
  • Obtener un valor

px_get_value

(PECL paradox >= 1.1.0)

px_get_value — Obtener un valor

Descripción

px_get_value ( resource $pxdoc , string $name ) : float

Obtiene varios valores.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

name

El parámetro name puede ser uno de los siguientes.

numprimkeys

El número de índices primarios. Las bases de datos paradox utiliza siempre los primeros campos numprimkeys para el índice primario.

Valores devueltos

Devuelve el valor del parámetro o false en caso de error.


Inserta registro en base de datos paradox

  • « px_get_value
  • px_new »
  • PHP Manual
  • Funciones de Paradox
  • Inserta registro en base de datos paradox

px_insert_record

(PECL paradox >= 1.4.0)

px_insert_record — Inserta registro en base de datos paradox

Descripción

px_insert_record ( resource $pxdoc , array $data ) : int

Inserta un nuevo registro en la base de datos. El registro no será necesariamente insertado al final de la base de datos, puede ser insertado en cualquier posición dependiendo en donde se encuentre la primera ranura libre.

Los datos del registro se pasan como una matriz de valores de campo. Los elementos en la matriz debe corresponder a los campos de la base de datos. Si la matriz tiene menos elementos que los campos en la base de datos, los campos restantes se establecerán a null.

La mayoría de los valores de campo se puede pasar como su tipo php equivalente, por ejemplo, un valor long se utiliza para campos de tipo PX_FIELD_LONG, PX_FIELD_SHORT y PX_FIELD_AUTOINC, un valor double se utiliza para campos de tipo PX_FIELD_CURRENCY y PX_FIELD_NUMBER. Los valores de campo para los campos blob y alfa se pasan como cadenas.

Los campos de tipo PX_FIELD_TIME y PX_FIELD_DATE requieren ambos un valor long. En el primer caso este es el número de milisegundos desde la medianoche. En el segundo caso es el número de días desde el 1.1.0000. A continuación hay dos ejemplos para convertir la fecha actual o marca de tiempo en un valor adecuado para unos campos de fecha/hora en paradox.

Nota:

Esta función sólo está disponible si se utiliza pxlib >= 0.6.0.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

data

Matriz asociado o indexada que contiene los valores de campo como, por ejemplo, devuelto por la función px_retrieve_record().

Valores devueltos

Devuelve false en caso de fallo o el número de registro en caso de éxito.

Ejemplos

Ejemplo #1 Establece los campos fecha/hora en una base de datos paradox a la fecha/hora actual

<?php
$px = px_new();
$fp = fopen("test.db", "w+");
px_create_fp($px, $fp, array(array("timestamp", "@"), array("time", "T"), array("date", "D")));

$curdate = getdate();
$jd = gregoriantojd($curdate["mon"], $curdate["mday"], $curdate["year"]);
$days = $jd - 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
$secs = $curdate["hours"]*3600 + $curdate["minutes"]*60 + $curdate["seconds"];
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));

$curtimestamp = microtime(true);
$days = (int) ($curtimestamp/86400);
$secs = $curtimestamp - ($days * 86400.0);
$days += 2440588; /* Number of days between 1.1.4714 b.c. and 1.1.1970 */
$days -= 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));
for($i=0; $i<2; $i++) {
    $rec = px_retrieve_record($px, $i);
    echo px_timestamp2string($px, $rec["timestamp"], "n/d/Y H:i:s")."\n";
    echo px_date2string($px, $rec["date"], "n/d/Y")."\n";
}
px_close($px);
px_delete($px);
?>

El resultado del ejemplo sería:

2/21/2006 21:42:30
2/21/2006
2/21/2006 20:42:30
2/21/2006

La cuenta de la fecha juliana pasada a la función jdtogregorian() tiene una base diferente de 1.1.4714 a. C. y por lo tanto debe calcularse añadiendo 1721425 a la cuenta de días utilizados en el archivo paradox. En cuanto el número de días en una fecha y hora se hace fácilmente multiplicando por 86400000.0 para obtener milisegundos.

Ver también

px_update_record() - Actualizar el registro en la base de datos paradox


Crear un nuevo objeto paradox

  • « px_insert_record
  • px_numfields »
  • PHP Manual
  • Funciones de Paradox
  • Crear un nuevo objeto paradox

px_new

(PECL paradox >= 1.0.0)

px_new — Crear un nuevo objeto paradox

Descripción

px_new ( ) : resource

Crea un nuevo objeto paradox. Tendrá que llamar a esta función antes de cualquier otra función. La función px_new() no crea ningún archivo en el disco, simplemente crea una instancia de un objeto paradox. Esta función no debe ser llamada si la interfaz orientada a objetos es usada. Utilice en su lugar new paradox_db().

Valores devueltos

Devuelve false en caso de fallo.

Ejemplos

Ejemplo #1 Abrir una base de datos Paradox

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "r");
if(!px_open_fp($pxdoc, $fp)) {
  /* Error handling */
}
// ...
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

Si prefiere la API orientada a objetos, entonces el ejemplo anterior se verá como sigue.

Ejemplo #2 Abrir una base de datos Paradox

<?php
$fp = fopen("test.db", "r");
$pxdoc = new paradox_db();
if(!$pxdoc->open_fp($fp)) {
  /* Error handling */
}
// ...
$pxdoc->close();
fclose($fp);
?>

Ver también

  • px_delete() - Eliminar los recursos de la base de datos paradox
  • px_open_fp() - Abrir base de datos paradox


Devuelve el número de campos en una base de datos

  • « px_new
  • px_numrecords »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve el número de campos en una base de datos

px_numfields

(PECL paradox >= 1.0.0)

px_numfields — Devuelve el número de campos en una base de datos

Descripción

px_numfields ( resource $pxdoc ) : int

Obtener el número de campos en un archivo de base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

Valores devueltos

Devuelve el número de campos en un archivo de base de datos. El valor de retorno de esta función es idéntico al elemento numfields en la matriz devuelta por la función px_get_info().


Devuelve el número de registros en una base de datos

  • « px_numfields
  • px_open_fp »
  • PHP Manual
  • Funciones de Paradox
  • Devuelve el número de registros en una base de datos

px_numrecords

(PECL paradox >= 1.0.0)

px_numrecords — Devuelve el número de registros en una base de datos

Descripción

px_numrecords ( resource $pxdoc ) : int

Obtener el número de registros en un archivo de base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

Valores devueltos

Devuelve el número de registros en un archivo de base de datos. El valor de retorno de esta función es idéntico al elemento numrecords en la matriz devuelta por la función px_get_info().


Abrir base de datos paradox

  • « px_numrecords
  • px_put_record »
  • PHP Manual
  • Funciones de Paradox
  • Abrir base de datos paradox

px_open_fp

(PECL paradox >= 1.0.0)

px_open_fp — Abrir base de datos paradox

Descripción

px_open_fp ( resource $pxdoc , resource $file ) : bool

Abre un archivo de base de datos paradox existente. El archivo actual tiene que ser abierto antes con la función fopen(). Esta función también puede utilizarse para abrir el índice primario del archivo y pasar ellos como una base de datos paradox. Esto es aprobado para aquellos que quieran investigar un índice primario. Esto no se puede utilizar para acelerar el acceso a un archivo de base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

file

El parámetro file es el valor devuelto desde la función fopen() con el archivo de base de datos actual como parámetro. Asegúrese de que la base de datos se puede escribir si va a actualizar o insertar registros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fopen() - Abre un fichero o un URL
  • El ejemplo en la función px_new() - Crear un nuevo objeto paradox


Almacenar registro en la base de datos paradox

  • « px_open_fp
  • px_retrieve_record »
  • PHP Manual
  • Funciones de Paradox
  • Almacenar registro en la base de datos paradox

px_put_record

(PECL paradox >= 1.0.0)

px_put_record — Almacenar registro en la base de datos paradox

Descripción

px_put_record ( resource $pxdoc , array $record , int $recpos = -1 ) : bool

Almacena un registro en una base de datos Paradox. El registro se añade siempre al final de la base de datos, independientemente de las ranuras libres. Utilice la función px_insert_record() para agregar un nuevo registro en la primera ranura libre en la base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

record

Matriz asociado o indexada que contiene los valores de campo como, por ejemplo devuelto por la función px_retrieve_record().

recpos

Este parámetro opcional puede ser usado para especificar un número de registro mayor que el número actual de registros en la base de datos. La función añadirá tantos registros vacíos según sea necesario. There is hardly Apenas hay necesidad de utilizar este parámetro.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devolver registro de base de datos paradox

  • « px_put_record
  • px_set_blob_file »
  • PHP Manual
  • Funciones de Paradox
  • Devolver registro de base de datos paradox

px_retrieve_record

(PECL paradox >= 1.4.0)

px_retrieve_record — Devolver registro de base de datos paradox

Descripción

px_retrieve_record ( resource $pxdoc , int $num , int $mode = 0 ) : array

Esta función es muy similar a la función px_get_record() pero utiliza internamente un enfoque diferente para recuperar los datos. Se basa en pxlib para la lectura de cada valor único de campo, cuyo resultado general resulta en soportar un mayor número de tipos de campo.

Nota:

Esta función sólo está disponible si se utiliza pxlib >= 0.6.0.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

num

El registro numérico es un número artificial que cuenta los registros a medida en que se almacenan en la base de datos. El primer registro tiene el número 0.

mode

El parámetro opcional mode puede ser PX_KEYTOLOWER o PX_KEYTOUPPER con el fin de convertir las claves en mayúsculas o minúsculas. Si el parámetro mode no se pasa o es 0, entonces la clave será igual que el nombre del campo. El elemento de los valores contendrá los valores de campo. Los valores NULL se conservarán y son diferentes de 0.0, 0 o la cadena vacía. Los campos de tipo PX_FIELD_TIME serán devueltos como un entero contando el número de milisegundos a partir de la medianoche. Una marca de tiempo es un valor de punto flotante contando también los milisegundos desde el comienzo del calendario juliano.

Valores devueltos

Devuelve el parámetro numº del registro de la base de datos paradox. El registro es devuelto como una matriz asociada con sus claves siendo los nombres de campo.

Ver también

  • px_get_record() - Devuelve registro de base de datos paradox


Establecer el archivo desde donde los blobs se van a leer

  • « px_retrieve_record
  • px_set_parameter »
  • PHP Manual
  • Funciones de Paradox
  • Establecer el archivo desde donde los blobs se van a leer

px_set_blob_file

(PECL paradox >= 1.3.0)

px_set_blob_file — Establecer el archivo desde donde los blobs se van a leer

Descripción

px_set_blob_file ( resource $pxdoc , string $filename ) : bool

Establece el nombre del archivo desde donde los blobs se van a leer o escribir. Sin llamar a esta función, px_get_record() o px_retrieve_record() sólo devolverá datos en campos blob si los datos son parte del registro y no se almacenan en el archivo blob. Los datos blob se almacenan en el registro si es lo suficientemente pequeño para adaptarse al tamaño del campo blob.

Las llamadas a la función px_put_record(),
px_insert_record(), o
px_update_record() sin llamar a la función
px_set_blob_file() dará como resultados campos blob truncados
a menos que los datos encajen en el archivo de base de datos.

Llamando a esta función dos veces se cerrará el primer archivo blob y abrirá el nuevo.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

filename

El nombre del archivo. Su extensión debe ser .MB.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer un parámetro

  • « px_set_blob_file
  • px_set_tablename »
  • PHP Manual
  • Funciones de Paradox
  • Establecer un parámetro

px_set_parameter

(PECL paradox >= 1.1.0)

px_set_parameter — Establecer un parámetro

Descripción

px_set_parameter ( resource $pxdoc , string $name , string $value ) : bool

Establece varios parámetros.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

name

En función del parámetro que desee establecer, el parámetro name puede ser uno de los siguientes.

tablename

El nombre de la tabla que se almacenará en la cabecera de la base de datos.

targetencoding

La codificación de salida. Los datos que sean leidos desde los campos de caracteres se recodifican en la codificación de destino.

inputencoding

La codificación de los datos de entrada que se va a guardar en la base de datos.

value

El valor del parámetro a establecer. Para la codificación de entrada y codificación de destino este debe ser el nombre de la codificación tal como la entiende iconv o recodificada, por ejemplo iso-8859-1, utf-8, cp850.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • px_get_info() - Devuelve una gran cantidad de información sobre un archivo paradox para determinar la página de códigos DOS.


Establecer el nombre de una tabla (obsoleto)

  • « px_set_parameter
  • px_set_targetencoding »
  • PHP Manual
  • Funciones de Paradox
  • Establecer el nombre de una tabla (obsoleto)

px_set_tablename

(PECL paradox >= 1.0.0)

px_set_tablename — Establecer el nombre de una tabla (obsoleto)

Descripción

px_set_tablename ( resource $pxdoc , string $name ) : void

Establece el nombre de la tabla de una base de datos paradox, que se creó con la función px_create_fp(). Esta función es obsoleta, utilice en su lugar la función px_set_parameter().

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

tablename

El nombre de la tabla. Si no se establece explícitamente, se establecerá el nombre del archivo de la base de datos.

Valores devueltos

Devuelve null en caso de éxito o false en caso de error.

Ver también

px_set_parameter() - Establecer un parámetro


Establecer la codificación de los campos de caracteres (obsoleto)

  • « px_set_tablename
  • px_set_value »
  • PHP Manual
  • Funciones de Paradox
  • Establecer la codificación de los campos de caracteres (obsoleto)

px_set_targetencoding

(PECL paradox >= 1.0.0)

px_set_targetencoding — Establecer la codificación de los campos de caracteres (obsoleto)

Descripción

px_set_targetencoding ( resource $pxdoc , string $encoding ) : bool

Establece la codificación para los datos recuperados desde un campo de caracteres. Todos los campos de caracteres serán recodificados a la codificación establecida por esta función. Si la codificación no se ha establecido, los datos de carácter serán devueltos en el sistema de codificación DOS especificado en el archivo de base de datos. El parámetro encoding puede ser cualquier identificador de cadena conocido a iconv o recodificar. En los sistemas Unix, ejecutar iconv -l para obtener una lista de las codificaciones disponibles.

Esta función es obsoleta y debe sustituirse por llamadas a la función px_set_parameter().

Véase también la función px_get_info() para determinar el sistema de codificación DOS almacenado en el archivo de base de datos.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

encoding

La codificación de salida. Los datos que se están leyendo desde los campos de caracteres se recodifica en la codificación de destino.

Valores devueltos

Devuelve false si la codificación no se puede establecer, por ejemplo, la codificación es desconocida, o pxlib no aprueba la recodificación de todos. En el segundo caso una advertencia será emitida.

Ver también

px_set_parameter() - Establecer un parámetro


Establecer un valor

  • « px_set_targetencoding
  • px_timestamp2string »
  • PHP Manual
  • Funciones de Paradox
  • Establecer un valor

px_set_value

(PECL paradox >= 1.1.0)

px_set_value — Establecer un valor

Descripción

px_set_value ( resource $pxdoc , string $name , float $value ) : bool

Establece varios valores.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

name

El parámetro name puede ser uno de los siguientes.

numprimkeys

El número de claves primarias. Las bases de datos paradox utilizan siempre los primeros campos numprimkeys para el índice principal.

value

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

px_set_parameter() - Establecer un parámetro


Convertir la fecha y la hora en una cadena.

  • « px_set_value
  • px_update_record »
  • PHP Manual
  • Funciones de Paradox
  • Convertir la fecha y la hora en una cadena.

px_timestamp2string

(PECL paradox >= 1.4.0)

px_timestamp2string — Convertir la fecha y la hora en una cadena.

Descripción

px_timestamp2string ( resource $pxdoc , float $value , string $format ) : string

Convierte una fecha y hora tal como fué almenacenada en el archivo paradox, en un formato legible por humanos. Las marcas de tiempo paradox son el número de milisegundos transcurridos desde el 0001-01-02. Esta función es sólo por conveniencia. Esta puede ser fácilmente reemplazada por algunas funciones matemáticas y de calendario como se demuestra en el siguiente ejemplo.

Parámetros

pxdoc

Identificador de recursos de la base de datos paradox.

value

Valor almacenado en la base de datos paradox de tipo de campo PX_FIELD_TIME, o PX_FIELD_TIMESTAMP.

format

Formato de cadena similar al formato utilizado por la función date(). Los marcadores de posición soportados por esta función es un subconjunto de los soportados por la función date() (Y, y, m, n, d, j, H, h, G, g, i, s, A, a, L).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Conversión de una fecha y hora paradox en un formato legible por humanos

<?php
$px = px_new();

/* componer una fecha tal y como podría ser almacenada en */
/* un campo de fecha de una base de datos paradox */
/* 700000 días desde el 1.1.0000. */
$days = 700000;

/* Utilización de las funciones de calendario para imprimir una */
/* fecha en un formato legible por humanos */
echo jdtogregorian($days+1721425)."\n";

/* Convertirla en una marca de tiempo tal y como fue almacenada en la base de datos paradox */
/* Las marcas de tiempo se almacenan en milisegundos desde el 0001-01-02 */
$stamp = $days * 86400.0 * 1000.0;
/* Añadir una hora */
$stamp += 3600000.0;
/* La salida será la siguiente '7/15/1917 01:00:00'. */
echo px_timestamp2string($px, $stamp, "n/d/Y H:i:s")."\n";

px_delete($px);
?>

El resultado del ejemplo sería:

7/15/1917
7/15/1917 01:00:00

La cuenta de la fecha juliana pasada a la función jdtogregorian() tiene una base diferente de 1.1.4714 a. C. y por lo tanto debe calcularse añadiendo 1721425 a la cuenta de días utilizados en el archivo paradox. En cuanto el número de días en una fecha y hora se hace fácilmente multiplicando por 86400000.0 para obtener milisegundos.

Ver también

  • px_date2string() - Convierte una fecha en una cadena.
  • jdtogregorian() - Convierte una Fecha Juliana en una fecha Gregoriana


Actualizar el registro en la base de datos paradox

  • « px_timestamp2string
  • PostgreSQL »
  • PHP Manual
  • Funciones de Paradox
  • Actualizar el registro en la base de datos paradox

px_update_record

(PECL paradox >= 1.4.0)

px_update_record — Actualizar el registro en la base de datos paradox

Descripción

px_update_record ( resource $pxdoc , array $data , int $num ) : bool

Actualiza un registro existente en la base de datos. El registro comienza en 0.

Los datos del registro se pasan como una matriz de valores de campo. Los elementos de la matriz deben corresponder a los campos de la base de datos. Si la matriz tiene menos elementos que los campos en la base de datos, los campos restantes se establecerán a null.

Nota:

Esta función sólo está disponible si se utiliza pxlib >= 0.6.0.

Parámetros

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Identificador de recursos de la base de datos paradox devuelto por la función px_new().

num

El registro numérico es un número artificial que cuenta los registros a medida en que se almacenan en la base de datos. El primer registro tiene el número 0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

px_insert_record() - Inserta registro en base de datos paradox


PostgreSQL

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones de PostgreSQL
    • pg_affected_rows — Devuelve el número de registros afectados (filas)
    • pg_cancel_query — Cancelar una consulta asíncrona
    • pg_client_encoding — Obtiene la codificación del cliente
    • pg_close — Cierra una conexión PostgreSQL
    • pg_connect_poll — Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL
    • pg_connect — Abre una conexión a PostgreSQL
    • pg_connection_busy — Permite saber si la conexión esta ocupada o no
    • pg_connection_reset — Restablece conexión (reconectar)
    • pg_connection_status — Obtener estado de la conexión
    • pg_consume_input — Reads input on the connection
    • pg_convert — Conviertir valores de un array asociativo en valores adecuados para sentencias SQL
    • pg_copy_from — Insertar registros dentro de una tabla desde un array
    • pg_copy_to — Copiar una tabla a un array
    • pg_dbname — Obtiene el nombre de la base de datos
    • pg_delete — Borra registros
    • pg_end_copy — Sincronizar con PostgreSQL
    • pg_escape_bytea — Escapar un string para insertarlo en un campo bytea
    • pg_escape_identifier — Escape a identifier for insertion into a text field
    • pg_escape_literal — Escape a literal for insertion into a text field
    • pg_escape_string — Escape a string for query
    • pg_execute — Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
    • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
    • pg_fetch_all — Obtiene todas las filas de un resultado como un array
    • pg_fetch_array — Fetch a row as an array
    • pg_fetch_assoc — Fetch a row as an associative array
    • pg_fetch_object — Fetch a row as an object
    • pg_fetch_result — Returns values from a result resource
    • pg_fetch_row — Get a row as an enumerated array
    • pg_field_is_null — Test if a field is SQL NULL
    • pg_field_name — Returns the name of a field
    • pg_field_num — Returns the field number of the named field
    • pg_field_prtlen — Returns the printed length
    • pg_field_size — Returns the internal storage size of the named field
    • pg_field_table — Returns the name or oid of the tables field
    • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
    • pg_field_type — Devuelve el nombre de tipo para el número de campo correspondiente
    • pg_flush — Flush outbound query data on the connection
    • pg_free_result — Free result memory
    • pg_get_notify — Gets SQL NOTIFY message
    • pg_get_pid — Obtiene la ID del proceso del backend
    • pg_get_result — Get asynchronous query result
    • pg_host — Devuelve el nombre de host asociado a la conexión
    • pg_insert — Insert array into table
    • pg_last_error — Obtiene una cadena con el último mensaje de error de la conexión
    • pg_last_notice — Devuelve el último aviso del servidor PostgreSQL
    • pg_last_oid — Returns the last row's OID
    • pg_lo_close — Close a large object
    • pg_lo_create — Create a large object
    • pg_lo_export — Export a large object to file
    • pg_lo_import — Import a large object from file
    • pg_lo_open — Open a large object
    • pg_lo_read_all — Reads an entire large object and send straight to browser
    • pg_lo_read — Read a large object
    • pg_lo_seek — Seeks position within a large object
    • pg_lo_tell — Returns current seek position a of large object
    • pg_lo_truncate — Truncates a large object
    • pg_lo_unlink — Delete a large object
    • pg_lo_write — Write to a large object
    • pg_meta_data — Get meta data for table
    • pg_num_fields — Returns the number of fields in a result
    • pg_num_rows — Returns the number of rows in a result
    • pg_options — Obtener las opciones asociadas con la conexión
    • pg_parameter_status — Looks up a current parameter setting of the server
    • pg_pconnect — Abre una conexión persistente a PostgreSQL
    • pg_ping — Ping a conexión de base de datos
    • pg_port — Devuelve el número de puerto asociado con la conexión
    • pg_prepare — Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete
    • pg_put_line — Send a NULL-terminated string to PostgreSQL backend
    • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
    • pg_query — Ejecutar una consulta
    • pg_result_error_field — Returns an individual field of an error report
    • pg_result_error — Get error message associated with result
    • pg_result_seek — Set internal row offset in result resource
    • pg_result_status — Get status of query result
    • pg_select — Select records
    • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
    • pg_send_prepare — Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización
    • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)
    • pg_send_query — Sends asynchronous query
    • pg_set_client_encoding — Set the client encoding
    • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error
    • pg_socket — Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL
    • pg_trace — Enable tracing a PostgreSQL connection
    • pg_transaction_status — Devuelve el estado actual de la transaccion del servidor
    • pg_tty — Devolver el nombre TTY asociado con la conexión
    • pg_unescape_bytea — Unescape binary for bytea type
    • pg_untrace — Desactivar el rastreo de una conexión de PostgreSQL
    • pg_update — Actualizar tabla
    • pg_version — Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)


Introducción

La base de datos PostgreSQL es un producto de código abierto disponible sin costo alguno. Postgres, desarrollado originalmente en el Departamento de Informática de la Universidad de California, Berkeley, fue pionera en muchos de los conceptos objeto-relacionales que actualmente están disponibles en algunas bases de datos comerciales. Proporciona soporte para el lenguaje SQL92/SQL99, transacciones, integridad referencial, procedimientos almacenados y extensibilidad de tipos. PostgreSQL es un descendiente de código fuente abierto del código original de Berkeley.


Requerimientos

Para usar el soporte PostgreSQL, necesita PostgreSQL 6.5 o superior, PostgreSQL 8.0 o superior para habilitar todas las características del modulo PostgreSQL. PostgreSQL soporta muchas codificaciones de caracteres incluyendo codificación de caracteres multibyte. La versión actual y más información sobre PostgreSQL está disponible en » http://www.postgresql.org/ y la » Documentación de PostgreSQL.


Instalación

Con el fin de habilitar el soporte de PostgreSQL, --with-pgsql[=DIR] es requerido cuando se compila PHP. DIR es el directorio base donde está instalado PostgreSQL, por defecto generalmente es /usr/local/pgsql en sistemas linux. Si el módulo de objetos compartidos está disponible, el módulo PostgreSQL puede ser cargado usando la directiva extension en php.ini o la función dl().


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración PostgreSQL
Nombre | Por defecto | Cambiable | Historial de cambios
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | Disponible desde PHP 4.2.0.
pgsql.ignore_notice | "0" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
pgsql.log_notice | "0" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

pgsql.allow_persistent boolean

Si se permiten conexiones Postgres persistentes.

pgsql.max_persistent integer

El número máximo de conexiones Postgres persistentes por proceso.

pgsql.max_links integer

El número máximo de conexiones Postgres por proceso, incluyendo conexiones persistentes.

pgsql.auto_reset_persistent integer

Detectar conexiones persitentes rotas con pg_pconnect(). Necesita un breve tiempo adicional.

pgsql.ignore_notice integer

Hacer caso o no a los mensajes de avisos del backend PostgreSQL.

pgsql.log_notice integer

Registrar o no los mensajes de aviso del backend PostgreSQL. La directiva PHP pgsql.ignore_notice debe estar apagada para registrar los mensajes de aviso


Tipos de recursos

Hay dos tipos de recursos utilizados en el módulo de PostgreSQL. El primero es el identificador de enlace para una conexión de base de datos, el segundo recurso contiene el resultado de la consulta.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

PGSQL_LIBPQ_VERSION (string)
Versión corta de libpq que contiene solamente números y puntos.
PGSQL_LIBPQ_VERSION_STR (string)
Versión larga de libpq que incluye información del compilador.
PGSQL_ASSOC (integer)
Pasado a pg_fetch_array(). Devuelve un array asociativo de campos nombre y valor.
PGSQL_NUM (integer)
Pasado a pg_fetch_array(). Devuelve un array indexado numéricamente de campos numero y valor.
PGSQL_BOTH (integer)
Pasado a pg_fetch_array(). Devuelve un array de valores de campo que es numéricamente indexado (por número de campo) y asociado (por nombre de campo).
PGSQL_CONNECT_FORCE_NEW (integer)
Pasado a pg_connect() fuerza la creacion de una nueva conexión, en lugar de volver a utilizar una conexión idéntica existente.
PGSQL_CONNECT_ASYNC (integer)
Pasado a pg_connect() crea una conexión asíncrona. Añadido en PHP 5.6.0.
PGSQL_CONNECTION_BAD (integer)
Devuelto por pg_connection_status() indica que la conexión de la base de datos está en un estado no valido.
PGSQL_CONNECTION_OK (integer)
Devuelto por pg_connection_status() indica que la conexión de la base de datos está en un estado valido.
PGSQL_SEEK_SET (integer)
Pasado a pg_lo_seek(). La operación de busqueda empieza desde el inicio del objeto.
PGSQL_SEEK_CUR (integer)
Pasado a pg_lo_seek(). La operación de busqueda empieza desde la posición actual.
PGSQL_SEEK_END (integer)
Pasado a pg_lo_seek(). La operación de busqueda empieza desde el final del objeto.
PGSQL_EMPTY_QUERY (integer)
Devuelto por pg_result_status(). Indica que la cadena enviada al servidor estaba vacía.
PGSQL_COMMAND_OK (integer)
Devuelto por pg_result_status(). Indica la conclusión con éxito de un comando que no devuelve datos.
PGSQL_TUPLES_OK (integer)
Devuelto por pg_result_status(). Indica la conclusión con éxito de un comando que retorna datos (como un SELECT o un SHOW).
PGSQL_COPY_OUT (integer)
Devuelto por pg_result_status(). La transferencia de la copia de salida de datos (del servidor) ha empezado.
PGSQL_COPY_IN (integer)
Devuelto por pg_result_status(). La transferencia de la copia de la entrada de datos (al servidor) ha empezado.
PGSQL_BAD_RESPONSE (integer)
Devuelto por pg_result_status(). La respuesta del servidor no se entendió.
PGSQL_NONFATAL_ERROR (integer)
Devuelto por pg_result_status(). Un error fatal (un aviso o advertencia) se produjo.
PGSQL_FATAL_ERROR (integer)
Devuelto por pg_result_status(). Un error fatal ha ocurrido.
PGSQL_TRANSACTION_IDLE (integer)
Devuelto por pg_transaction_status(). La conexión esta libre actualmente, no es usada por una transacción.
PGSQL_TRANSACTION_ACTIVE (integer)
Devuelto por pg_transaction_status(). Un comando esta en progreso en la conexión. Una consulta ha sido enviada a través de la conexión y aún no concluido.
PGSQL_TRANSACTION_INTRANS (integer)
Devuelto por pg_transaction_status(). La conexión esta inactiva, en un bloque de transacción.
PGSQL_TRANSACTION_INERROR (integer)
Devuelto por pg_transaction_status(). La conexión esta inactiva, en un bloque de transacción fallida.
PGSQL_TRANSACTION_UNKNOWN (integer)
Devuelto por pg_transaction_status(). La conexion es mala.
PGSQL_DIAG_SEVERITY (integer)
Pasado a pg_result_error_field(). Según la gravedad; el contenido de los campos puede ser ERROR, FATAL, o PANIC (en un mensaje de error), o WARNING, NOTICE, DEBUG, INFO, o LOG (en un mensaje de aviso), o una traducción localizada de uno de ellos. Siempre esta presente.
PGSQL_DIAG_SQLSTATE (integer)
Pasado a pg_result_error_field(). El código SQLSTATE para el error. El codigo SQLSTATE identifica el tipo de error que ha ocurrido; esto puede ser utilizado por las aplicaciones de front-end para llevar a cabo operaciones específicas (tales como el control de errores) en respuesta a un error de base de datos concreto. Este campo no es localizable, y siempre esta presente.
PGSQL_DIAG_MESSAGE_PRIMARY (integer)
Pasado a pg_result_error_field(). El principal mensaje de error legible para un humano (generalmente una línea). Siempre esta presente.
PGSQL_DIAG_MESSAGE_DETAIL (integer)
Pasado a pg_result_error_field(). Detalle: un mensaje de error secundario opcional que transporta más detalles sobre el problema. Puede funcionar a varias líneas.
PGSQL_DIAG_MESSAGE_HINT (integer)
Pasado a pg_result_error_field(). Sugerencia: una sugerencia opcional qué hacer con el problema. Con esto se pretende diferir el detalle y ofrecer consejo (potencialmente inapropiados) en lugar de hechos concretos. Se puede ejecutar en varias lineas.
PGSQL_DIAG_STATEMENT_POSITION (integer)
Pasado a pg_result_error_field(). Una cadena que contiene un entero decimal que indica la posición del cursor como un índice de error en la cadena de la sentencia original. El primer carácter tiene el índice 1, y las posiciones se miden en caracteres no bytes.
PGSQL_DIAG_INTERNAL_POSITION (integer)
Pasado a pg_result_error_field(). Este se define como el campo PG_DIAG_STATEMENT_POSITION, Pero este es usado cuando la posición del cursor se refiere al comando generado internamente en lugar de la cadena enviada por el cliente. El campo PG_DIAG_INTERNAL_QUERY siempre aparece cuando este campo esta presente.
PGSQL_DIAG_INTERNAL_QUERY (integer)
Pasado a pg_result_error_field(). El texto de un comando generado internamente falla. Esto podria ser, por ejemplo, una consulta SQL emitida por una función PL/pgSQL.
PGSQL_DIAG_CONTEXT (integer)
Pasado a pg_result_error_field(). Una indicación del contexto en el que se produjo el error. Actualmente esto incluye una pila de llamadas de rastreo de funciones, procedimientos activos y consultas generados internamente. La traza es una entrada por línea, lo más reciente primero.
PGSQL_DIAG_SOURCE_FILE (integer)
Pasado a pg_result_error_field(). El nombre del archivo en la ubicación del código fuente de PostgreSQL. donde se reporto el error.
PGSQL_DIAG_SOURCE_LINE (integer)
Pasado a pg_result_error_field(). El numero de línea en la ubicación del código fuente PostgreSQL donde se reporto el error.
PGSQL_DIAG_SOURCE_FUNCTION (integer)
Pasado a pg_result_error_field(). El nombre de la función en el código fuente de PostgreSQL que informa del error.
PGSQL_ERRORS_TERSE (integer)
Pasado a pg_set_error_verbosity(). Especifica que los mensajes devueltos solo incluyen la severidad, el texto principal, y la posición; lo que normalmente cabe en una sola línea.
PGSQL_ERRORS_DEFAULT (integer)
Pasado a pg_set_error_verbosity(). El modo predeterminado produce mensajes que incluyen todo lo anterior además de los campos de detalle, sugerencia, o contexto (que puede abarcar varias líneas).
PGSQL_ERRORS_VERBOSE (integer)
Pasado a pg_set_error_verbosity(). El modo detallado incluye todos los campos disponibles.
PGSQL_NOTICE_LAST (integer)
Usado por pg_last_notice(). Disponible desde PHP 7.1.0.
PGSQL_NOTICE_ALL (integer)
Usado por pg_last_notice(). Disponible desde PHP 7.1.0.
PGSQL_NOTICE_CLEAR (integer)
Usado por pg_last_notice(). Disponible desde PHP 7.1.0.
PGSQL_STATUS_LONG (integer)
Pasado a pg_result_status(). Indica que se desea el codigo numerico del resultado.
PGSQL_STATUS_STRING (integer)
Pasado a pg_result_status(). Indica que se desea la etiqueta textual del resultado del comando.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Pasado a pg_convert(). No hacer caso de los valores por defecto en la tabla durante la conversión.
PGSQL_CONV_FORCE_NULL (integer)
Pasado a pg_convert(). Utilice SQL NULL en lugar de una string vacía.
PGSQL_CONV_IGNORE_NOT_NULL (integer)
Pasado a pg_convert(). Ignorar la conversión de null en las columnas SQL NOT NULL.
PGSQL_DML_NO_CONV (integer)
Pasado a pg_insert(), pg_select(), pg_update() y pg_delete(). Todos los parámetros pasados tal cual. Se requiere el escape manual si los parámetros contienen datos proporcionados por el usuario. Use pg_escape_string() para ello.
PGSQL_DML_EXEC (integer)
Pasado a pg_insert(), pg_select(), pg_update() y pg_delete(). Ejecutar consultas por estas funciones.
PGSQL_DML_ASYNC (integer)
Pasado a pg_insert(), pg_select(), pg_update() y pg_delete(). Ejecutar consultas asíncronas por estas funciones.
PGSQL_DML_STRING (integer)
Pasado a pg_insert(), pg_select(), pg_update() y pg_delete(). Devuelve el string de consulta ejecutado.
PGSQL_DML_ESCAPE (integer)
Pasado a pg_insert(), pg_select(), pg_update() y pg_delete(). Aplicar escape a todos los parámetros en lugar de llamar a pg_convert() internamente. Esta opción omite la búsqueda de metadatos. Las consultas podrían ser tan rápidas como pg_query() y pg_send_query().
PGSQL_POLLING_FAILED (integer)
Devuelto por pg_connect_poll() para indicar que el intento de conexión ha fallado.
PGSQL_POLLING_READING (integer)
Devuelto por pg_connect_poll() para indicar que la conexión está esperando que el socket de PostgreSQL pueda leerse.
PGSQL_POLLING_WRITING (integer)
Devuelto por pg_connect_poll() para indicar que la conexión está esperando que el socket de PostgreSQL pueda escribirse.
PGSQL_POLLING_OK (integer)
Devuelto por pg_connect_poll() para indicar que la conexión esta lista para ser usada.
PGSQL_POLLING_ACTIVE (integer)
Devuelto por pg_connect_poll() para indicar que la conexión está actualmente activa.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • PostgreSQL
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Este sencillo ejemplo muestra cómo conectarse, ejecutar una consulta, imprimir filas resultantes y desconectarse de una base de datos PostgreSQL.

Ejemplo #1 Ejemplo resumido de la extensión PostgreSQL

<?php
// Conectando y seleccionado la base de datos
$dbconn = pg_connect("host=localhost dbname=publishing user=www password=foo")
    or die('No se ha podido conectar: ' . pg_last_error());

// Realizando una consulta SQL
$query = 'SELECT * FROM authors';
$result = pg_query($query) or die('La consulta fallo: ' . pg_last_error());

// Imprimiendo los resultados en HTML
echo "<table>\n";
while ($line = pg_fetch_array($result, null, PGSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Liberando el conjunto de resultados
pg_free_result($result);

// Cerrando la conexión
pg_close($dbconn);
?>


Funciones de PostgreSQL

Notas

Nota:

No todas las funciones son compatibles con todas las versiones. Eso depende de la versión de libpq (librería cliente C de PostgreSQL) y cómo ha sido compilado libpq. Si las extensiones de PHP PostgreSQL faltan, entonces es porque su versión de libpq no los admite.

Nota:

La mayoría de las funciones PostgreSQL aceptan connection como primer parámetro opcional. Si no está siempre se usa la última conexión abierta. Si esta no existe las funciones retornarán false.

Nota:

PostgreSQL cambia automáticamente todos los identificadores (ejm. tablas/nombres de columnas) a minúsculas en el momento de la creación y al hacer las consultas. Para forzar el uso de mayúsculas se debe escapar el identificador usando comillas dobles ("").

Nota:

PostgresSQL no tiene comandos especiales para mostrar la información del esquema de la base de datos (ejm. todas las tablas de la actual base de datos). En cambio, hay un esquema estándar llamado information_schema en PostgreSQL 7.4 o superior que contiene las vistas del sistema con toda la información necesaria, es facilmente consultable. Vea la » Documentación de PostgreSQL para más detalles.

Tabla de contenidos

  • pg_affected_rows — Devuelve el número de registros afectados (filas)
  • pg_cancel_query — Cancelar una consulta asíncrona
  • pg_client_encoding — Obtiene la codificación del cliente
  • pg_close — Cierra una conexión PostgreSQL
  • pg_connect_poll — Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL
  • pg_connect — Abre una conexión a PostgreSQL
  • pg_connection_busy — Permite saber si la conexión esta ocupada o no
  • pg_connection_reset — Restablece conexión (reconectar)
  • pg_connection_status — Obtener estado de la conexión
  • pg_consume_input — Reads input on the connection
  • pg_convert — Conviertir valores de un array asociativo en valores adecuados para sentencias SQL
  • pg_copy_from — Insertar registros dentro de una tabla desde un array
  • pg_copy_to — Copiar una tabla a un array
  • pg_dbname — Obtiene el nombre de la base de datos
  • pg_delete — Borra registros
  • pg_end_copy — Sincronizar con PostgreSQL
  • pg_escape_bytea — Escapar un string para insertarlo en un campo bytea
  • pg_escape_identifier — Escape a identifier for insertion into a text field
  • pg_escape_literal — Escape a literal for insertion into a text field
  • pg_escape_string — Escape a string for query
  • pg_execute — Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
  • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
  • pg_fetch_all — Obtiene todas las filas de un resultado como un array
  • pg_fetch_array — Fetch a row as an array
  • pg_fetch_assoc — Fetch a row as an associative array
  • pg_fetch_object — Fetch a row as an object
  • pg_fetch_result — Returns values from a result resource
  • pg_fetch_row — Get a row as an enumerated array
  • pg_field_is_null — Test if a field is SQL NULL
  • pg_field_name — Returns the name of a field
  • pg_field_num — Returns the field number of the named field
  • pg_field_prtlen — Returns the printed length
  • pg_field_size — Returns the internal storage size of the named field
  • pg_field_table — Returns the name or oid of the tables field
  • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
  • pg_field_type — Devuelve el nombre de tipo para el número de campo correspondiente
  • pg_flush — Flush outbound query data on the connection
  • pg_free_result — Free result memory
  • pg_get_notify — Gets SQL NOTIFY message
  • pg_get_pid — Obtiene la ID del proceso del backend
  • pg_get_result — Get asynchronous query result
  • pg_host — Devuelve el nombre de host asociado a la conexión
  • pg_insert — Insert array into table
  • pg_last_error — Obtiene una cadena con el último mensaje de error de la conexión
  • pg_last_notice — Devuelve el último aviso del servidor PostgreSQL
  • pg_last_oid — Returns the last row's OID
  • pg_lo_close — Close a large object
  • pg_lo_create — Create a large object
  • pg_lo_export — Export a large object to file
  • pg_lo_import — Import a large object from file
  • pg_lo_open — Open a large object
  • pg_lo_read_all — Reads an entire large object and send straight to browser
  • pg_lo_read — Read a large object
  • pg_lo_seek — Seeks position within a large object
  • pg_lo_tell — Returns current seek position a of large object
  • pg_lo_truncate — Truncates a large object
  • pg_lo_unlink — Delete a large object
  • pg_lo_write — Write to a large object
  • pg_meta_data — Get meta data for table
  • pg_num_fields — Returns the number of fields in a result
  • pg_num_rows — Returns the number of rows in a result
  • pg_options — Obtener las opciones asociadas con la conexión
  • pg_parameter_status — Looks up a current parameter setting of the server
  • pg_pconnect — Abre una conexión persistente a PostgreSQL
  • pg_ping — Ping a conexión de base de datos
  • pg_port — Devuelve el número de puerto asociado con la conexión
  • pg_prepare — Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete
  • pg_put_line — Send a NULL-terminated string to PostgreSQL backend
  • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
  • pg_query — Ejecutar una consulta
  • pg_result_error_field — Returns an individual field of an error report
  • pg_result_error — Get error message associated with result
  • pg_result_seek — Set internal row offset in result resource
  • pg_result_status — Get status of query result
  • pg_select — Select records
  • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
  • pg_send_prepare — Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización
  • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)
  • pg_send_query — Sends asynchronous query
  • pg_set_client_encoding — Set the client encoding
  • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error
  • pg_socket — Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL
  • pg_trace — Enable tracing a PostgreSQL connection
  • pg_transaction_status — Devuelve el estado actual de la transaccion del servidor
  • pg_tty — Devolver el nombre TTY asociado con la conexión
  • pg_unescape_bytea — Unescape binary for bytea type
  • pg_untrace — Desactivar el rastreo de una conexión de PostgreSQL
  • pg_update — Actualizar tabla
  • pg_version — Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)


Devuelve el número de registros afectados (filas)

  • « Funciones de PostgreSQL
  • pg_cancel_query »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el número de registros afectados (filas)

pg_affected_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_affected_rows — Devuelve el número de registros afectados (filas)

Descripción

pg_affected_rows ( resource $result ) : int

pg_affected_rows() Devuelve el número de filas (casos/registros/filas) afectadas por consultas de tipo INSERT, UPDATE, y DELETE.

Desde PostgreSQL 9.0 y superior, el servidor devuelve el número de filas seleccionadas. Las versiones más antiguas de PostgreSQL devuelven 0 para SELECT.

Nota:

Esta función se llamaba pg_cmdtuples().

Parámetros

result

El recurso de resultados de la consulta PostgreSQL o PostgreSQL query result resource, es devuelto por pg_query(), pg_query_params() o pg_execute() (entre otros).

Valores devueltos

El número de filas afectadas por la consulta. Si no hay filas afectadas devolverá 0 (cero).

Ejemplos

Ejemplo #1 Ejemplo de pg_affected_rows()

<?php
$result = pg_query($conn, "INSERT INTO authors VALUES ('Orwell', 2002, 'Animal Farm')");

$cmdtuples = pg_affected_rows($result);

echo "filas que han sido afectadas: " . $cmdtuples ;
?>

El resultado del ejemplo sería:

filas que han sido afectadas: 1.

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
  • pg_execute() - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
  • pg_num_rows() - Returns the number of rows in a result


Cancelar una consulta asíncrona

  • « pg_affected_rows
  • pg_client_encoding »
  • PHP Manual
  • Funciones de PostgreSQL
  • Cancelar una consulta asíncrona

pg_cancel_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_cancel_query — Cancelar una consulta asíncrona

Descripción

pg_cancel_query ( resource $connection ) : bool

pg_cancel_query() cancela una consulta asíncrona enviada con pg_send_query(), pg_send_query_params() o pg_send_execute(). No se puede cancelar una consulta ejecutada con pg_query().

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_cancel_query()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("No se ha podido conectar");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "Primera llamada a pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 tiene $rows1 registros\n\n";

  // Cancelar la consulta que esta ejecutandose actualmente. Será la segunda consulta,
  // si aun se esta ejecutando.

  pg_cancel_query($dbconn);
?>

El resultado del ejemplo sería:

Primera llamada a pg_get_result(): id del Recurso #3
id del Recurso #3 tiene 3 registros

Ver también

  • pg_send_query() - Sends asynchronous query
  • pg_connection_busy() - Permite saber si la conexión esta ocupada o no


Obtiene la codificación del cliente

  • « pg_cancel_query
  • pg_close »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtiene la codificación del cliente

pg_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_client_encoding — Obtiene la codificación del cliente

Descripción

pg_client_encoding ( resource $connection = ? ) : string

PostgreSQL soporta la conversión automática de caracteres entre servidor y el cliente para conjuntos de caracteres determinados. pg_client_encoding() Devuelve la codificación del cliente como una cadena. La cadena devuelta sera una de los estandar de codificación de los identificadores de PostgreSQL.

Nota:

Esta función requiere PHP 4.0.3 o superior y PostgreSQL 7.0 o superior. Si libpq se compila sin soporte de codificación multibyte, pg_client_encoding() siempre devuelve SQL_ASCII. La codificación que soporta depende de la versión de PostgreSQL. Consulte la documentación de PostgreSQL para ver las codificaciones soportadas.

La función antes se llamaba pg_clientencoding().

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. Cuando connection no esta presente, la conexión por defecto es usada. La conexión por defecto es la última conexión realizada por pg_connect() ó pg_pconnect().

Valores devueltos

La codificación del cliente, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_client_encoding()

<?php
// Supongamos que $conn es una conexión a una base de datos ISO-8859-1
$encoding = pg_client_encoding($conn);

echo "La codificación del cliente es: ", $encoding, "\n";
?>

El resultado del ejemplo sería:

La codificación del cliente es: ISO-8859-1

Ver también

  • pg_set_client_encoding() - Set the client encoding


Cierra una conexión PostgreSQL

  • « pg_client_encoding
  • pg_connect_poll »
  • PHP Manual
  • Funciones de PostgreSQL
  • Cierra una conexión PostgreSQL

pg_close

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_close — Cierra una conexión PostgreSQL

Descripción

pg_close ( resource $connection = ? ) : bool

pg_close() Cierra una conexión no persistente a una base de datos PostgreSQL asociada con el recurso de la connection.

Nota:

Usar pg_close() generalmente no es necesario, cuando se abren conexiones no persitentes estas se cierran automaticamente al terminar el script.

Si hay objetos grandes abiertos en el recurso de la conexión, no cierre la conexión, antes cierre todos los objetos grandes en el recurso.

Parámetros

connection

Es el recurso de conexión de base de datos PostgreSQL. Cuando el parametro connection no está presente, se usa la conexión por defecto. La conexión por defecto es la última conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_close()

<?php
$dbconn = pg_connect("host=localhost port=5432 dbname=mary")
   or die("No se pudo conectar");
echo "Conectado con éxito";
pg_close($dbconn);
?>

El resultado del ejemplo sería:

Conectado con exito

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL


Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL

  • « pg_close
  • pg_connect »
  • PHP Manual
  • Funciones de PostgreSQL
  • Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL

pg_connect_poll

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_connect_poll — Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL

Descripción

pg_connect_poll ( resource $connection ) : int

pg_connect_poll() Verifica el estado de una conexión a PostgreSQL creada llamando a pg_connect() con la opción PGSQL_CONNECT_ASYNC.

Parámetros

connection

Recurso de conexión a base de datos PostgreSQL.

Valores devueltos

Retorna PGSQL_POLLING_FAILED, PGSQL_POLLING_READING, PGSQL_POLLING_WRITING, PGSQL_POLLING_OK, o PGSQL_POLLING_ACTIVE.


Abre una conexión a PostgreSQL

  • « pg_connect_poll
  • pg_connection_busy »
  • PHP Manual
  • Funciones de PostgreSQL
  • Abre una conexión a PostgreSQL

pg_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_connect — Abre una conexión a PostgreSQL

Descripción

pg_connect ( string $connection_string , int $connect_type = ? ) : resource

pg_connect() abre una conexión con una base de datos PostgreSQL especificada por el connection_string.

Si una segunda llamada se hace a pg_connect() con la misma connection_string existiendo la conexión, la conexión existente será devuelta a menos que pase la constante PGSQL_CONNECT_FORCE_NEW como parámetro connect_type.

La sintaxis antigua con múltiples parámetros $conn = pg_connect("host", "port", "options", "tty", "dbname") ha quedado obsoleta.

Parámetros

connection_string

El connection_string puede estar vacío para usar todos los parámetros por defecto o este puede contener uno o más parámetros separados por espacios en blanco. Cada parámetro debe asignarse de esta forma keyword = value. Los espacios alrededor del signo igual son opcionales. Para escribir un valor vacío o un valor conteniendo espacios utilice las comillas simples, por ejemplo. keyword = 'a value'. Las comillas simples y barras invertidas en el valor se pueden agregar con una barra invertida es decir \' y \\.

Las palabras clave de parámetros que están reconocidos son: host, hostaddr, port, dbname (por defecto el valor de user), user, password, connect_timeout, options, tty (ignorado), sslmode, requiressl (en desuso en favor de sslmode), y service. Cuál de estos argumentos existen depende de su versión de PostgreSQL.

El parámetro options se puede utilizar para establecer los parámetros de la línea de comandos para ser invocado por el servidor.

connect_type

Si PGSQL_CONNECT_FORCE_NEW es pasado, entonces una nueva conexión se crea, incluso si el parámetroconnection_string es idéntico a la conexión existente.

Si PGSQL_CONNECT_ASYNC es dado, entonces la conexión es establecida asincrónicamente. El estado de la conexión puede comprobarse a través de pg_connect_poll() o pg_connection_status().

Valores devueltos

El recurso de conexión PostgreSQL en caso de éxito, false en caso de fallo.

Historial de cambios

Versión | Descripción
5.6.0 | El soporte para la constante PGSQL_CONNECT_ASYNC se ha añadido con el parametro connect_type.

Ejemplos

Ejemplo #1 Usando pg_connect()

<?php
$dbconn = pg_connect("dbname=mary");
//conectarse a una base de datos llamada "mary"

$dbconn2 = pg_connect("host=localhost port=5432 dbname=mary");
// conectarse a una base de datos llamada "mary" en "localhost" por el puerto "5432"

$dbconn3 = pg_connect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//conectarse a una base de datos llamada "mary" en el host "sheep" con el nombre de usuario y password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_connect($conn_string);
//conectarse por el puerto 5432 a una base de datos llamada "test" en el host "sheep" con el nombre de usuario y password

$dbconn5 = pg_connect("host=localhost options='--client_encoding=UTF8'");
//conectarse a una base de datos en "localhost" y establece el parámetro de línea de comandos que indica la codificación en UTF8
?>

Ver también

  • pg_pconnect() - Abre una conexión persistente a PostgreSQL
  • pg_close() - Cierra una conexión PostgreSQL
  • pg_host() - Devuelve el nombre de host asociado a la conexión
  • pg_port() - Devuelve el número de puerto asociado con la conexión
  • pg_tty() - Devolver el nombre TTY asociado con la conexión
  • pg_options() - Obtener las opciones asociadas con la conexión
  • pg_dbname() - Obtiene el nombre de la base de datos


Permite saber si la conexión esta ocupada o no

  • « pg_connect
  • pg_connection_reset »
  • PHP Manual
  • Funciones de PostgreSQL
  • Permite saber si la conexión esta ocupada o no

pg_connection_busy

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_busy — Permite saber si la conexión esta ocupada o no

Descripción

pg_connection_busy ( resource $connection ) : bool

pg_connection_busy() determina si una conexión está ocupada. Si está ocupada, una consulta anterior todavía se está ejecutando. Si pg_get_result() es usada en la conexión, esta sera bloqueada.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

Valores devueltos

Devuelve true si la conexión está ocupada, de lo contrario false.

Ejemplos

Ejemplo #1 Ejemplo de pg_connection_busy()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("No se ha podido conectar");
  $bs = pg_connection_busy($dbconn);
  if ($bs) {
      echo 'la conexión está ocupada';
  } else {
     echo 'la conexión no está ocupada';
  }
?>

Ver también

  • pg_connection_status() - Obtener estado de la conexión
  • pg_get_result() - Get asynchronous query result


Restablece conexión (reconectar)

  • « pg_connection_busy
  • pg_connection_status »
  • PHP Manual
  • Funciones de PostgreSQL
  • Restablece conexión (reconectar)

pg_connection_reset

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_reset — Restablece conexión (reconectar)

Descripción

pg_connection_reset ( resource $connection ) : bool

pg_connection_reset() restablece la conexión. Es útil para la recuperación de errores.

Parámetros

connection

Recurso de conexión de Base de Datos PostgreSQL.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_connection_reset()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("No se ha podido conectar");
  $dbconn2 = pg_connection_reset($dbconn);
  if ($dbconn2) {
      echo "restablecimiento con exito\n";
  } else {
      echo "restablecimiento fallo\n";
  }
?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL
  • pg_pconnect() - Abre una conexión persistente a PostgreSQL
  • pg_connection_status() - Obtener estado de la conexión


Obtener estado de la conexión

  • « pg_connection_reset
  • pg_consume_input »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtener estado de la conexión

pg_connection_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_status — Obtener estado de la conexión

Descripción

pg_connection_status ( resource $connection ) : int

pg_connection_status() devuelve el estado específico de la connection.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

Valores devueltos

PGSQL_CONNECTION_OK o PGSQL_CONNECTION_BAD.

Ejemplos

Ejemplo #1 Ejemplo de pg_connection_status()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("No se ha podido conectar");
  $stat = pg_connection_status($dbconn);
  if ($stat === PGSQL_CONNECTION_OK) {
      echo 'Estado de la conexión ok';
  } else {
      echo 'No se ha podido conectar';
  }
?>

Ver también

  • pg_connection_busy() - Permite saber si la conexión esta ocupada o no


Reads input on the connection

  • « pg_connection_status
  • pg_convert »
  • PHP Manual
  • Funciones de PostgreSQL
  • Reads input on the connection

pg_consume_input

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_consume_input — Reads input on the connection

Descripción

pg_consume_input ( resource $connection ) : bool

pg_consume_input() consumes any input waiting to be read from the database server.

Parámetros

connection

PostgreSQL database connection resource.

Valores devueltos

true if no error occurred, or false if there was an error. Note that true does not necessarily indicate that input was waiting to be read.


Conviertir valores de un array asociativo en valores adecuados para sentencias SQL

  • « pg_consume_input
  • pg_copy_from »
  • PHP Manual
  • Funciones de PostgreSQL
  • Conviertir valores de un array asociativo en valores adecuados para sentencias SQL

pg_convert

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_convert — Conviertir valores de un array asociativo en valores adecuados para sentencias SQL

Descripción

pg_convert ( resource $connection , string $table_name , array $assoc_array , int $options = 0 ) : array

pg_convert() evalua y convierte los valores de un assoc_array en valores adecuados para su uso en una sentencia SQL. La condición previa para la función pg_convert() es la existencia de una tabla con nombre igual al parametro table_name que tiene por lo menos tantas columnas como elementos tiene el assoc_array. Los nombres de campos en table_name deben coincidir con los índices de assoc_array y los tipos de datos correspondientes deben ser compatibles. Devuelve un array con los valores convertidos en caso de éxito, false de lo contrario.

Nota:

Desde PHP 5.6.0, acepta valores booleanos. Se convierten a booleanos de PostgreSQL. También se admiten representaciones de string de valores booleanos. null se convierte al NULL de PostgreSQL.

Antes de PHP 5.6.0, si existen campos booleanos en table_name, no use la constante true en assoc_array. Será convertida al string 'TRUE', el cual no es una entrada válida para campos booleanos en PostgreSQL. Use t, true, 1, y, yes en su lugar.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

table_name

Nombre de la tabla contra la que convertir los tipos.

assoc_array

Los datos que desea convertir.

options

Cualquier número de PGSQL_CONV_IGNORE_DEFAULT, PGSQL_CONV_FORCE_NULL ó PGSQL_CONV_IGNORE_NOT_NULL, ó una combinación de estos.

Valores devueltos

Un array de valores convertidos, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_convert()

<?php
  $dbconn = pg_connect('dbname=foo');

  $tmp = array(
      'author' => 'Joe Thackery',
      'year' => 2005,
      'title' => 'My Life, by Joe Thackery'
  );

  $vals = pg_convert($dbconn, 'authors', $tmp);
?>

Historial de cambios

Versión | Descripción
5.6.0 | Ya no es experimental. Se admiten los tipos de datos boolean/NULL. Los tipos de datos desconocidos/no soportados son escapados sin validación. Se podría emplear pg_convert() con cualquier tipo de dato.

Ver también

  • pg_meta_data() - Get meta data for table
  • pg_insert() - Insert array into table
  • pg_select() - Select records
  • pg_update() - Actualizar tabla
  • pg_delete() - Borra registros


Insertar registros dentro de una tabla desde un array

  • « pg_convert
  • pg_copy_to »
  • PHP Manual
  • Funciones de PostgreSQL
  • Insertar registros dentro de una tabla desde un array

pg_copy_from

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_copy_from — Insertar registros dentro de una tabla desde un array

Descripción

pg_copy_from ( resource $connection , string $table_name , array $rows , string $delimiter = ? , string $null_as = ? ) : bool

La función pg_copy_from() inserta registros dentro de una tabla desde el parámetro rows. Esta realiza internamente un comando SQL COPY FROM para insertar registros.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL.

table_name

Nombre de la tabla en la cual se copiará lo que provenga de rows.

rows

Un array de datos a ser copiados dentro de table_name. Cada valor en el parámetro rows se convierte en una fila en table_name. Cada valor en el parámetro rows debe ser una cadena delimitada de los valores a insertar en cada campo. Los valores deben ser terminados con un salto de línea.

delimiter

Símbolo que serpara valores por cada campo en cada elemento del parámetro rows. El predeterminado es TAB.

null_as

Es como SQL NULL (anula) los valores que son representados en el parámetro rows. El predeterminado es \N ("\\N").

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de la función pg_copy_from()

<?php
   $db = pg_connect("dbname=publisher") or die("No se pudo conectar");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Ver también

  • pg_copy_to() - Copiar una tabla a un array


Copiar una tabla a un array

  • « pg_copy_from
  • pg_dbname »
  • PHP Manual
  • Funciones de PostgreSQL
  • Copiar una tabla a un array

pg_copy_to

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_copy_to — Copiar una tabla a un array

Descripción

pg_copy_to ( resource $connection , string $table_name , string $delimiter = ? , string $null_as = ? ) : array

pg_copy_to() Copia una tabla a un array. COPY TO hace comandos SQL internamente para recurperar los registros.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

table_name

Nombre de la tabla de la que se copia los datos en rows.

delimiter

El símbolo que separa los valores para cada campo en cada elemento de las rows. Por defecto es un TAB.

null_as

Como se representan los valores NULL en las rows. Por defecto es \N ("\\N").

Valores devueltos

Un array con un elemento por cada linea de datos COPY. Este devuelve false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de pg_copy_to()

<?php
   $db = pg_connect("dbname=publisher") or die("No se ha podido conectar");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Ver también

  • pg_copy_from() - Insertar registros dentro de una tabla desde un array


Obtiene el nombre de la base de datos

  • « pg_copy_to
  • pg_delete »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtiene el nombre de la base de datos

pg_dbname

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_dbname — Obtiene el nombre de la base de datos

Descripción

pg_dbname ( resource $connection = ? ) : string

pg_dbname() devuelve el nombre de la base de datos que ha dado el recurso de la connection PostgreSQL.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. Cuando la connection no esta presente, se usa la conexión por defecto. La conexión por defecto es la última conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Un string que contiene el nombre de la base de datos de la connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_dbname()

<?php
  error_reporting(E_ALL);

  pg_connect("host=localhost port=5432 dbname=mary");
  echo pg_dbname(); // mary
?>


Borra registros

  • « pg_dbname
  • pg_end_copy »
  • PHP Manual
  • Funciones de PostgreSQL
  • Borra registros

pg_delete

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_delete — Borra registros

Descripción

pg_delete ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC ) : mixed

pg_delete() Borra los registros de una tabla especificada por las claves y los valores en assoc_array. Si options se especifica, se aplica pg_convert() a assoc_array con las opciones especificadas.

Parámetros

connection

Recurso de conección a la base de datos PostgreSQL.

table_name

Nombre de la tabla de la cual se va a borrar las filas.

assoc_array

Un tipo array en los cuales están los nombres de los campos en la tabla table_name, y cuyos valores son los valores de esos campos que están por ser borrados.

options

Cualquier número de PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC o PGSQL_DML_STRING combinadas. Si PGSQL_DML_STRING es parte de options, se devuelve el string de consulta. Cuando PGSQL_DML_NO_CONV o PGSQL_DML_ESCAPE están establecidas, no se llama a pg_convert() internamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Devuelve string si PGSQL_DML_STRING es pasada por medio de options.

Ejemplos

Ejemplo #1 Ejemplo de la función pg_delete()

<?php
  $db = pg_connect('dbname=foo');
  // Esta forma es segura, ya que $_POST se convierte automaticamente
  $res = pg_delete($db, 'post_log', $_POST);
  if ($res) {
      echo "El dato POST será borrado: $res\n";
  } else {
      echo "El usuario debe haber enviado entradas incorrectas\n";
  }
?>

Historial de cambios

Versión | Descripción
5.6.0 | Ya no es experimental. Se añadió la constante PGSQL_DML_ESCAPE, se admiten los tipos de datos true/false y null.
5.5.3/5.4.19 | La inyección SQL directa a table_name y la inyección SQL indirecta a identificadores son fijasinjection.

Ver también

  • pg_convert() - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL


Sincronizar con PostgreSQL

  • « pg_delete
  • pg_escape_bytea »
  • PHP Manual
  • Funciones de PostgreSQL
  • Sincronizar con PostgreSQL

pg_end_copy

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_end_copy — Sincronizar con PostgreSQL

Descripción

pg_end_copy ( resource $connection = ? ) : bool

pg_end_copy() sincroniza la parte visual de PostgreSQL (usualmente un proceso web) con el servidor PostgreSQL después de hacer una operación de copia realizado por la función pg_put_line(). pg_end_copy() debe ser invocado, de otra manera el servidor PostgreSQL podría perder sincronización con la parte visual y esto hará que reporte un error.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando el parámetro connection no está presente, se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_end_copy() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "crea la tabla bar (a int4, b char(16), d float8)");
  pg_query($conn, "copiar bar desde stdin");
  pg_put_line($conn, "3\thola mundo\t4.5\n");
  pg_put_line($conn, "4\tadios mundo\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Ver también

  • pg_put_line() - Send a NULL-terminated string to PostgreSQL backend


Escapar un string para insertarlo en un campo bytea

  • « pg_end_copy
  • pg_escape_identifier »
  • PHP Manual
  • Funciones de PostgreSQL
  • Escapar un string para insertarlo en un campo bytea

pg_escape_bytea

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_escape_bytea — Escapar un string para insertarlo en un campo bytea

Descripción

pg_escape_bytea ( resource $connection = ? , string $data ) : string

pg_escape_bytea() escapa un string para un tipo de dato bytea. Devuelve un string pasado por un proceso de escape.

Nota:

Cuando haces una consulta SELECT a un tipo bytea, PostgreSQL devuelve valores de byte octal con el prefijo '\' (ej. \032). Los usuarios están supuestos a convertirlo de regreso al formato binario manualmente.

Esta función requiere PostgreSQL versión 7.2 o posterior. Con la versión 7.2.0 y 7.2.1 de PostgreSQL, los valores bytea deben ser pasados por un casteo cuando se habilita soporte multi-byte. Ej. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 o una versión posterior no necesita un casteo. La excepción es cuando la codificación de caracteres del cliente y del servidor no coinciden, y podría haber un flujo de error multi-byte. Entonces el usuario debe castear a bytea para evitar este error.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando el parámetro connection no está presente, se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión hecha por pg_connect() o pg_pconnect().

data

Un tipo de dato string que contiene datos de texto o binarios para ser insertados dentro de una columna bytea.

Valores devueltos

Un tipo de dato string que contiene los datos que han sido escapados.

Historial de cambios

Versión | Descripción
5.2.0 | Se agregó el parámetro connection

Ejemplos

Ejemplo #1 Ejemplo de pg_escape_bytea()

<?php
  // Connectar a la base de datos
  $dbconn = pg_connect('dbname=foo');

  // Leer en un fichero binario
  $data = file_get_contents('image1.jpg');

  // Escapar el dato binario
  $escaped = pg_escape_bytea($data);

  // Insertarlo en la base de datos
  pg_query("INSERT INTO gallery (name, data) VALUES ('Pine trees', '{$escaped}')");
?>

Ver también

  • pg_unescape_bytea() - Unescape binary for bytea type
  • pg_escape_string() - Escape a string for query


Escape a identifier for insertion into a text field

  • « pg_escape_bytea
  • pg_escape_literal »
  • PHP Manual
  • Funciones de PostgreSQL
  • Escape a identifier for insertion into a text field

pg_escape_identifier

(PHP 5 >= 5.4.4, PHP 7, PHP 8)

pg_escape_identifier — Escape a identifier for insertion into a text field

Descripción

pg_escape_identifier ( resource $connection = ? , string $data ) : string

pg_escape_identifier() escapes a identifier (e.g. table, field names) for querying the database. It returns an escaped identifier string for PostgreSQL server. pg_escape_identifier() adds double quotes before and after data. Users should not add double quotes. Use of this function is recommended for identifier parameters in query. For SQL literals (i.e. parameters except bytea), pg_escape_literal() or pg_escape_string() must be used. For bytea type fields, pg_escape_bytea() must be used instead.

Nota:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

Valores devueltos

A string containing the escaped data.

Ejemplos

Ejemplo #1 pg_escape_identifier() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Escape the table name data
  $escaped = pg_escape_identifier($table_name);

  // Select rows from $table_name
  pg_query("SELECT * FROM {$escaped};");
?>

Ver también

  • pg_escape_literal() - Escape a literal for insertion into a text field
  • pg_escape_bytea() - Escapar un string para insertarlo en un campo bytea
  • pg_escape_string() - Escape a string for query


Escape a literal for insertion into a text field

  • « pg_escape_identifier
  • pg_escape_string »
  • PHP Manual
  • Funciones de PostgreSQL
  • Escape a literal for insertion into a text field

pg_escape_literal

(PHP 5 >= 5.4.4, PHP 7, PHP 8)

pg_escape_literal — Escape a literal for insertion into a text field

Descripción

pg_escape_literal ( resource $connection = ? , string $data ) : string

pg_escape_literal() escapes a literal for querying the PostgreSQL database. It returns an escaped literal in the PostgreSQL format. pg_escape_literal() adds quotes before and after data. Users should not add quotes. Use of this function is recommended instead of pg_escape_string(). If the type of the column is bytea, pg_escape_bytea() must be used instead. For escaping identifiers (e.g. table, field names), pg_escape_identifier() must be used.

Nota:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect(). When there is no default connection, it raises E_WARNING and returns false.

data

A string containing text to be escaped.

Valores devueltos

A string containing the escaped data.

Ejemplos

Ejemplo #1 pg_escape_literal() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_literal($data);

  // Insert it into the database. Note that no quotes around {$escaped}
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', {$escaped})");
?>

Ver también

  • pg_escape_identifier() - Escape a identifier for insertion into a text field
  • pg_escape_bytea() - Escapar un string para insertarlo en un campo bytea
  • pg_escape_string() - Escape a string for query


Escape a string for query

  • « pg_escape_literal
  • pg_execute »
  • PHP Manual
  • Funciones de PostgreSQL
  • Escape a string for query

pg_escape_string

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_escape_string — Escape a string for query

Descripción

pg_escape_string ( resource $connection = ? , string $data ) : string

pg_escape_string() escapes a string for querying the database. It returns an escaped string in the PostgreSQL format without quotes. pg_escape_literal() is more preferred way to escape SQL parameters for PostgreSQL. addslashes() must not be used with PostgreSQL. If the type of the column is bytea, pg_escape_bytea() must be used instead. pg_escape_identifier() must be used to escape identifiers (e.g. table names, field names)

Nota:

This function requires PostgreSQL 7.2 or later.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

Valores devueltos

A string containing the escaped data.

Ejemplos

Ejemplo #1 pg_escape_string() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_string($data);

  // Insert it into the database
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', '{$escaped}')");
?>

Ver también

  • pg_escape_bytea() - Escapar un string para insertarlo en un campo bytea


Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado

  • « pg_escape_string
  • pg_fetch_all_columns »
  • PHP Manual
  • Funciones de PostgreSQL
  • Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado

pg_execute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_execute — Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado

Descripción

pg_execute ( resource $connection = ? , string $stmtname , array $params ) : resource

Envía una solicitud para ejecutar una sentencia preparada con parámetros dados, y espera el resultado.

pg_execute() es como pg_query_params(), pero el comando a ejecutar se especifica nombrando una sentencia preparada previamente, en lugar de dar una cadena de consulta. Esta característica permite que los comandos que se utilizan varias veces puedan ser analizados y planificados una sola vez, en lugar de cada vez que se ejecutan. La sentencia debe haber sido preparada previamente en la sesión actual. pg_execute() sólo se admite en PostgreSQL 7.4 o versiones superiores, se producirá un error al usar las versiones anteriores.

Los parámetros son idénticos a pg_query_params(), salvo que el nombre de una sentencia preparada se da en lugar de una cadena de consulta.

Parámetros

connection

Recurso de conexión de Base de datos PostgreSQL. Cuando la connection no está presente, la conexión por defecto se utiliza. La conexión por defecto es la última conexión realizada por pg_connect() o pg_pconnect().

stmtname

El nombre de la sentencia preparada para ejecutar. Si "" se especifica, la instrucción se ejecuta sin nombre. El nombre debe haber sido previamente preparado con pg_prepare(), pg_send_prepare() o un comando SQL PREPARE.

params

Una serie de valores de los parámetros para sustituir a los $1, $2, etc. Marcadores de posición en la cadena de consulta preparada original. El número de elementos del array debe coincidir con el número de marcadores de posición.

Advertencia

Los elementos se convierten en cadenas llamando a esta función.

Valores devueltos

Un recurso en el éxito del resultado de la consulta o false en caso de error.

Ejemplos

Ejemplo #1 Usando pg_execute()

<?php
// Conectar a base de datos llamada "mary"
$dbconn = pg_connect("dbname=mary");

// Preparar consulta para ejecución
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Ejecutar consulta preparada. Tenga en cuenta que no es necesario escapar
// la cadena "Joe's Widgets" de ninguna manera
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Ejecutar la misma consulta preparada, esta vez con un parámetro diferente
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Ver también

  • pg_prepare() - Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete
  • pg_send_prepare() - Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text


Fetches all rows in a particular result column as an array

  • « pg_execute
  • pg_fetch_all »
  • PHP Manual
  • Funciones de PostgreSQL
  • Fetches all rows in a particular result column as an array

pg_fetch_all_columns

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_fetch_all_columns — Fetches all rows in a particular result column as an array

Descripción

pg_fetch_all_columns ( resource $result , int $column = 0 ) : array

pg_fetch_all_columns() returns an array that contains all rows (records) in a particular column of the result resource.

Nota: Esta función define campos NULOS al valor null de PHP.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

column

Column number, zero-based, to be retrieved from the result resource. Defaults to the first column if not specified.

Valores devueltos

An array with all values in the result column.

false is returned if column is larger than the number of columns in the result, or on any other error.

Ejemplos

Ejemplo #1 pg_fetch_all_columns() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT title, name, address FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

// Get an array of all author names
$arr = pg_fetch_all_columns($result, 1);

var_dump($arr);

?>

Ver también

  • pg_fetch_all() - Obtiene todas las filas de un resultado como un array


Obtiene todas las filas de un resultado como un array

  • « pg_fetch_all_columns
  • pg_fetch_array »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtiene todas las filas de un resultado como un array

pg_fetch_all

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_fetch_all — Obtiene todas las filas de un resultado como un array

Descripción

pg_fetch_all ( resource $result , int $result_type = PGSQL_ASSOC ) : array

pg_fetch_all() Devuelve un array que contiene todas las filas (registros) en el recurso resultado.

Nota: Esta función define campos NULOS al valor null de PHP.

Parámetros

result

Resultado de consulta de PostgreSQL, devuelto por pg_query(), pg_query_params() o pg_execute() (entre otros).

Valores devueltos

Un array con todas las filas en el resultado. Cada fila es un array de los valores de campo indexados por nombre de campo.

false Se devuelve si no hay filas en el resultado, o en cualquier otro error.

Ejemplos

Ejemplo #1 PostgreSQL fetch all

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occurred.\n";
    exit;
}

$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occurred.\n";
    exit;
}

$arr = pg_fetch_all($result);

print_r($arr);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [id] => 1
            [name] => Fred
        )

    [1] => Array
        (
            [id] => 2
            [name] => Bob
        )

)

Historial de cambios

Versión | Descripción
7.1.0 | El parametro result_type fue agregado.

Ver también

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource


Fetch a row as an array

  • « pg_fetch_all
  • pg_fetch_assoc »
  • PHP Manual
  • Funciones de PostgreSQL
  • Fetch a row as an array

pg_fetch_array

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_array — Fetch a row as an array

Descripción

pg_fetch_array ( resource $result , int $row = ? , int $result_type = PGSQL_BOTH ) : array

pg_fetch_array() returns an array that corresponds to the fetched row (record).

pg_fetch_array() is an extended version of pg_fetch_row(). In addition to storing the data in the numeric indices (field number) to the result array, it can also store the data using associative indices (field name). It stores both indices by default.

Nota: Esta función define campos NULOS al valor null de PHP.

pg_fetch_array() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or null, the next row is fetched.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_fetch_array() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Valores devueltos

An array indexed numerically (beginning with 0) or associatively (indexed by field name), or both. Each value in the array is represented as a string. Database NULL values are returned as null.

false is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error. Fetching from the result of a query other than SELECT will also return false.

Ejemplos

Ejemplo #1 pg_fetch_array() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

$arr = pg_fetch_array($result, 0, PGSQL_NUM);
echo $arr[0] . " <- Row 1 Author\n";
echo $arr[1] . " <- Row 1 E-mail\n";

// The row parameter is optional; NULL can be passed instead,
// to pass a result_type.  Successive calls to pg_fetch_array
// will return the next row.
$arr = pg_fetch_array($result, NULL, PGSQL_ASSOC);
echo $arr["author"] . " <- Row 2 Author\n";
echo $arr["email"] . " <- Row 2 E-mail\n";

$arr = pg_fetch_array($result);
echo $arr["author"] . " <- Row 3 Author\n";
echo $arr[1] . " <- Row 3 E-mail\n";

?>

Ver también

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource


Fetch a row as an associative array

  • « pg_fetch_array
  • pg_fetch_object »
  • PHP Manual
  • Funciones de PostgreSQL
  • Fetch a row as an associative array

pg_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_fetch_assoc — Fetch a row as an associative array

Descripción

pg_fetch_assoc ( resource $result , int $row = ? ) : array

pg_fetch_assoc() returns an associative array that corresponds to the fetched row (records).

pg_fetch_assoc() is equivalent to calling pg_fetch_array() with PGSQL_ASSOC as the optional third parameter. It only returns an associative array. If you need the numeric indices, use pg_fetch_row().

Nota: Esta función define campos NULOS al valor null de PHP.

pg_fetch_assoc() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or null, the next row is fetched.

Valores devueltos

An array indexed associatively (by field name). Each value in the array is represented as a string. Database NULL values are returned as null.

false is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Ejemplos

Ejemplo #1 pg_fetch_assoc() example

<?php
$conn = pg_connect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT id, author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

while ($row = pg_fetch_assoc($result)) {
  echo $row['id'];
  echo $row['author'];
  echo $row['email'];
}
?>

Ver también

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource


Fetch a row as an object

  • « pg_fetch_assoc
  • pg_fetch_result »
  • PHP Manual
  • Funciones de PostgreSQL
  • Fetch a row as an object

pg_fetch_object

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_object — Fetch a row as an object

Descripción

pg_fetch_object ( resource $result , int $row = ? , int $result_type = PGSQL_ASSOC ) : object
pg_fetch_object ( resource $result , int $row = ? , string $class_name = ? , array $params = ? ) : object

pg_fetch_object() returns an object with properties that correspond to the fetched row's field names. It can optionally instantiate an object of a specific class, and pass parameters to that class's constructor.

Nota: Esta función define campos NULOS al valor null de PHP.

Speed-wise, the function is identical to pg_fetch_array(), and almost as fast as pg_fetch_row() (the difference is insignificant).

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or null, the next row is fetched.

result_type

Ignored and deprecated.

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

Valores devueltos

An object with one attribute for each field name in the result. Database NULL values are returned as null.

false is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Ejemplos

Ejemplo #1 pg_fetch_object() example

<?php

$database = "store";

$db_conn = pg_connect("host=localhost port=5432 dbname=$database");
if (!$db_conn) {
  echo "Failed connecting to postgres database $database\n";
  exit;
}

$qu = pg_query($db_conn, "SELECT * FROM books ORDER BY author");

while ($data = pg_fetch_object($qu)) {
  echo $data->author . " (";
  echo $data->year . "): ";
  echo $data->title . "<br />";
}

pg_free_result($qu);
pg_close($db_conn);

?>

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_assoc() - Fetch a row as an associative array
  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_result() - Returns values from a result resource


Returns values from a result resource

  • « pg_fetch_object
  • pg_fetch_row »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns values from a result resource

pg_fetch_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_fetch_result — Returns values from a result resource

Descripción

pg_fetch_result ( resource $result , int $row , mixed $field ) : string|false|null
pg_fetch_result ( resource $result , mixed $field ) : string|false|null

pg_fetch_result() returns the value of a particular row and field (column) in a PostgreSQL result resource.

Nota:

This function used to be called pg_result().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

field

A string representing the name of the field (column) to fetch, otherwise an int representing the field number to fetch. Fields are numbered from 0 upwards.

Valores devueltos

Boolean is returned as "t" or "f". All other types, including arrays are returned as strings formatted in the same default PostgreSQL manner that you would see in the psql program. Database NULL values are returned as null.

false is returned if row exceeds the number of rows in the set, or on any other error.

Ejemplos

Ejemplo #1 pg_fetch_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";
?>

El resultado del ejemplo sería:

First field in the second row is: 2

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_fetch_array() - Fetch a row as an array


Get a row as an enumerated array

  • « pg_fetch_result
  • pg_field_is_null »
  • PHP Manual
  • Funciones de PostgreSQL
  • Get a row as an enumerated array

pg_fetch_row

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_row — Get a row as an enumerated array

Descripción

pg_fetch_row ( resource $result , int $row = ? ) : array

pg_fetch_row() fetches one row of data from the result associated with the specified result resource.

Nota: Esta función define campos NULOS al valor null de PHP.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or null, the next row is fetched.

Valores devueltos

An array, indexed from 0 upwards, with each value represented as a string. Database NULL values are returned as null.

false is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Ejemplos

Ejemplo #1 pg_fetch_row() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource


Test if a field is SQL NULL

  • « pg_fetch_row
  • pg_field_name »
  • PHP Manual
  • Funciones de PostgreSQL
  • Test if a field is SQL NULL

pg_field_is_null

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_is_null — Test if a field is SQL NULL

Descripción

pg_field_is_null ( resource $result , int $row , mixed $field ) : int
pg_field_is_null ( resource $result , mixed $field ) : int

pg_field_is_null() tests if a field in a PostgreSQL result resource is SQL NULL or not.

Nota:

This function used to be called pg_fieldisnull().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, current row is fetched.

field

Field number (starting from 0) as an int or the field name as a string.

Valores devueltos

Returns 1 if the field in the given row is SQL NULL, 0 if not. false is returned if the row is out of range, or upon any other error.

Ejemplos

Ejemplo #1 pg_field_is_null() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die ("Could not connect");
  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  if ($res) {
      if (pg_field_is_null($res, 0, "year") == 1) {
          echo "The value of the field year is null.\n";
      }
      if (pg_field_is_null($res, 0, "year") == 0) {
          echo "The value of the field year is not null.\n";
    }
 }
?>


Returns the name of a field

  • « pg_field_is_null
  • pg_field_num »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the name of a field

pg_field_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_name — Returns the name of a field

Descripción

pg_field_name ( resource $result , int $field_number ) : string

pg_field_name() returns the name of the field occupying the given field_number in the given PostgreSQL result resource. Field numbering starts from 0.

Nota:

This function used to be called pg_fieldname().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Valores devueltos

The field name, or false on error.

Ejemplos

Ejemplo #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

El resultado del ejemplo sería:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ver también

  • pg_field_num() - Returns the field number of the named field


Returns the field number of the named field

  • « pg_field_name
  • pg_field_prtlen »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the field number of the named field

pg_field_num

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_num — Returns the field number of the named field

Descripción

pg_field_num ( resource $result , string $field_name ) : int

pg_field_num() will return the number of the field number that corresponds to the field_name in the given PostgreSQL result resource.

Nota:

This function used to be called pg_fieldnum().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_name

The name of the field.

Valores devueltos

The field number (numbered from 0), or -1 on error.

Ejemplos

Ejemplo #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select author, year, title from authors where author = 'Orwell'");

  echo "Column 'title' is field number: ", pg_field_num($res, 'title');
?>

El resultado del ejemplo sería:

Column 'title' is field number: 2

Ver también

  • pg_field_name() - Returns the name of a field


Returns the printed length

  • « pg_field_num
  • pg_field_size »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the printed length

pg_field_prtlen

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_prtlen — Returns the printed length

Descripción

pg_field_prtlen ( resource $result , int $row_number , mixed $field_name_or_number ) : int
pg_field_prtlen ( resource $result , mixed $field_name_or_number ) : int

pg_field_prtlen() returns the actual printed length (number of characters) of a specific value in a PostgreSQL result. Row numbering starts at 0. This function will return false on an error.

field_name_or_number can be passed either as an int or as a string. If it is passed as an int, PHP recognises it as the field number, otherwise as field name.

See the example given at the pg_field_name() page.

Nota:

This function used to be called pg_fieldprtlen().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result. Rows are numbered from 0 upwards. If omitted, current row is fetched.

Valores devueltos

The field printed length, or false on error.

Ejemplos

Ejemplo #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

El resultado del ejemplo sería:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ver también

  • pg_field_size() - Returns the internal storage size of the named field


Returns the internal storage size of the named field

  • « pg_field_prtlen
  • pg_field_table »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the internal storage size of the named field

pg_field_size

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_size — Returns the internal storage size of the named field

Descripción

pg_field_size ( resource $result , int $field_number ) : int

pg_field_size() returns the internal storage size (in bytes) of the field number in the given PostgreSQL result.

Nota:

This function used to be called pg_fieldsize().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Valores devueltos

The internal field storage size (in bytes). -1 indicates a variable length field. false is returned on error.

Ejemplos

Ejemplo #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

El resultado del ejemplo sería:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ver también

  • pg_field_prtlen() - Returns the printed length
  • pg_field_type() - Devuelve el nombre de tipo para el número de campo correspondiente


Returns the name or oid of the tables field

  • « pg_field_size
  • pg_field_type_oid »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the name or oid of the tables field

pg_field_table

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

pg_field_table — Returns the name or oid of the tables field

Descripción

pg_field_table ( resource $result , int $field_number , bool $oid_only = false ) : mixed

pg_field_table() returns the name of the table that field belongs to, or the table's oid if oid_only is true.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

oid_only

By default the tables name that field belongs to is returned but if oid_only is set to true, then the oid will instead be returned.

Valores devueltos

On success either the fields table name or oid. Or, false on failure.

Ejemplos

Ejemplo #1 Getting table information about a field

<?php
$dbconn = pg_connect("dbname=publisher") or die("Could not connect");

$res = pg_query($dbconn, "SELECT bar FROM foo");

echo pg_field_table($res, 0);
echo pg_field_table($res, 0, true);

$res = pg_query($dbconn, "SELECT version()");
var_dump(pg_field_table($res, 0));
?>

El resultado del ejemplo sería algo similar a:

foo
14379580

bool(false)

Notas

Nota:

Returning the oid is much faster than returning the table name because fetching the table name requires a query to the database system table.

Ver también

  • pg_field_name() - Returns the name of a field
  • pg_field_type() - Devuelve el nombre de tipo para el número de campo correspondiente


Returns the type ID (OID) for the corresponding field number

  • « pg_field_table
  • pg_field_type »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the type ID (OID) for the corresponding field number

pg_field_type_oid

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_field_type_oid — Returns the type ID (OID) for the corresponding field number

Descripción

pg_field_type_oid ( resource $result , int $field_number ) : int

pg_field_type_oid() returns an integer containing the OID of the base type of the given field_number in the given PostgreSQL result resource.

You can get more information about the field type by querying PostgreSQL's pg_type system table using the OID obtained with this function. The PostgreSQL format_type() function will convert a type OID into an SQL standard type name.

Nota:

If the field uses a PostgreSQL domain (rather than a basic type), it is the OID of the domain's underlying type that is returned, rather than the OID of the domain itself.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Valores devueltos

The OID of the field's base type. false is returned on error.

Ejemplos

Ejemplo #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type OID: ", pg_field_type_oid($res, 0);
?>

El resultado del ejemplo sería:

Title field type OID: 1043

Ver también

  • pg_field_type() - Devuelve el nombre de tipo para el número de campo correspondiente
  • pg_field_prtlen() - Returns the printed length
  • pg_field_name() - Returns the name of a field


Devuelve el nombre de tipo para el número de campo correspondiente

  • « pg_field_type_oid
  • pg_flush »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el nombre de tipo para el número de campo correspondiente

pg_field_type

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_type — Devuelve el nombre de tipo para el número de campo correspondiente

Descripción

pg_field_type ( resource $result , int $field_number ) : string

pg_field_type() Devuelve un string que contiene el nombre del tipo base para el field_number en el resultado de consulta result dado de PostgreSQL.

Nota:

Si el campo utiliza un dominio PostgreSQL (en lugar de un tipo básico), es el nombre del tipo subyacente del dominio el que se devuelve, en lugar del nombre del propio dominio.

Nota:

Esta función solía llamarse pg_fieldtype().

Parámetros

result

Resultado de consulta de PostgreSQL, devuelto por pg_query(), pg_query_params() o pg_execute() (entre otros).

field_number

Número de campo, a partir de 0.

Valores devueltos

Un string que contiene el nombre base del tipo del campo, o false En caso de Fallo.

Ejemplos

Ejemplo #1 Obtención de información sobre los campos

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Campo title de tipo: ", pg_field_type($res, 0);
?>

El resultado del ejemplo sería:

Title field type: varchar

Ver también

  • pg_field_prtlen() - Returns the printed length
  • pg_field_name() - Returns the name of a field
  • pg_field_type_oid() - Returns the type ID (OID) for the corresponding field number


Flush outbound query data on the connection

  • « pg_field_type
  • pg_free_result »
  • PHP Manual
  • Funciones de PostgreSQL
  • Flush outbound query data on the connection

pg_flush

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_flush — Flush outbound query data on the connection

Descripción

pg_flush ( resource $connection ) : mixed

pg_flush() flushes any outbound query data waiting to be sent on the connection.

Parámetros

connection

PostgreSQL database connection resource.

Valores devueltos

Returns true if the flush was successful or no data was waiting to be flushed, 0 if part of the pending data was flushed but more remains o false en caso de error.


Free result memory

  • « pg_flush
  • pg_get_notify »
  • PHP Manual
  • Funciones de PostgreSQL
  • Free result memory

pg_free_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_free_result — Free result memory

Descripción

pg_free_result ( resource $result ) : bool

pg_free_result() frees the memory and data associated with the specified PostgreSQL query result resource.

This function need only be called if memory consumption during script execution is a problem. Otherwise, all result memory will be automatically freed when the script ends.

Nota:

This function used to be called pg_freeresult().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_free_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";

pg_free_result($res);
?>

El resultado del ejemplo sería:

First field in the second row is: 2

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
  • pg_execute() - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado


Gets SQL NOTIFY message

  • « pg_free_result
  • pg_get_pid »
  • PHP Manual
  • Funciones de PostgreSQL
  • Gets SQL NOTIFY message

pg_get_notify

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_get_notify — Gets SQL NOTIFY message

Descripción

pg_get_notify ( resource $connection , int $result_type = ? ) : array

pg_get_notify() gets notifications generated by a NOTIFY SQL command. To receive notifications, the LISTEN SQL command must be issued.

Parámetros

connection

PostgreSQL database connection resource.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_get_notify() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Valores devueltos

An array containing the NOTIFY message name and backend PID. As of PHP 5.4.0 and if supported by the server, the array also contains the server version and the payload. Otherwise if no NOTIFY is waiting, then false is returned.

Ejemplos

Ejemplo #1 PostgreSQL NOTIFY message

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Listen 'author_updated' message from other processes
pg_query($conn, 'LISTEN author_updated;');
$notify = pg_get_notify($conn);
if (!$notify) {
  echo "No messages\n";
} else {
  print_r($notify);
}
?>

Ver también

  • pg_get_pid() - Obtiene la ID del proceso del backend


Obtiene la ID del proceso del backend

  • « pg_get_notify
  • pg_get_result »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtiene la ID del proceso del backend

pg_get_pid

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_get_pid — Obtiene la ID del proceso del backend

Descripción

pg_get_pid ( resource $connection ) : int

pg_get_pid() Obtiene el backend (proceso de servidor de base de datos) PID. El PID es útil para determinar si un NOTIFY mensaje recibido a través de pg_get_notify() se envia desde otro proceso o no.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

Valores devueltos

La ID del proceso de la base de datos backend.

Ejemplos

Ejemplo #1 PostgreSQL backend PID

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Backend process PID. Use PID with pg_get_notify()
$pid = pg_get_pid($conn);
?>

Ver también

  • pg_get_notify() - Gets SQL NOTIFY message


Get asynchronous query result

  • « pg_get_pid
  • pg_host »
  • PHP Manual
  • Funciones de PostgreSQL
  • Get asynchronous query result

pg_get_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_get_result — Get asynchronous query result

Descripción

pg_get_result ( resource $connection = ? ) : resource

pg_get_result() gets the result resource from an asynchronous query executed by pg_send_query(), pg_send_query_params() or pg_send_execute().

pg_send_query() and the other asynchronous query functions can send multiple queries to a PostgreSQL server and pg_get_result() is used to get each query's results, one by one.

Parámetros

connection

PostgreSQL database connection resource.

Valores devueltos

The result resource, or false if no more results are available.

Ejemplos

Ejemplo #1 pg_get_result() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

El resultado del ejemplo sería:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Ver también

  • pg_send_query() - Sends asynchronous query


Devuelve el nombre de host asociado a la conexión

  • « pg_get_result
  • pg_insert »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el nombre de host asociado a la conexión

pg_host

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_host — Devuelve el nombre de host asociado a la conexión

Descripción

pg_host ( resource $connection = ? ) : string

pg_host() devuelve el nombre de host del recurso de connection PostgreSQL al que está conectado.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. cuando el parametro connection no está presente, se utiliza la conexión por defecto. La conexión por defecto es la última conexión realizada por pg_connect() o pg_pconnect().

Valores devueltos

Una string que contiene el nombre del host de la connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_host()

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Conectado correctamente a: " . pg_host($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL
  • pg_pconnect() - Abre una conexión persistente a PostgreSQL


Insert array into table

  • « pg_host
  • pg_last_error »
  • PHP Manual
  • Funciones de PostgreSQL
  • Insert array into table

pg_insert

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_insert — Insert array into table

Descripción

pg_insert ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC ) : mixed

pg_insert() inserts the values of assoc_array into the table specified by table_name. If options is specified, pg_convert() is applied to assoc_array with the specified options.

If options is specified, pg_convert() is applied to assoc_array with the specified flags.

By default pg_insert() passes raw values. Values must be escaped or PGSQL_DML_ESCAPE option must be specified. PGSQL_DML_ESCAPE quotes and escapes parameters/identifiers. Therefore, table/column names became case sensitive.

Note that neither escape nor prepared query can protect LIKE query, JSON, Array, Regex, etc. These parameters should be handled according to their contexts. i.e. Escape/validate values.

Parámetros

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to insert rows. The table table_name must at least have as many columns as assoc_array has elements.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be inserted.

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Valores devueltos

Returns the connection resource on success, o false en caso de error. Returns string if PGSQL_DML_STRING is passed via options.

Ejemplos

Ejemplo #1 pg_insert() example

<?php
  $dbconn = pg_connect('dbname=foo');
  // This is safe somewhat, since all values are escaped.
  // However PostgreSQL supports JSON/Array. These are not
  // safe by neither escape nor prepared query.
  $res = pg_insert($dbconn, 'post_log', $_POST, PG_DML_ESCAPE);
  if ($res) {
      echo "POST data is successfully logged\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Historial de cambios

Versión | Descripción
5.6.0 | Unless PGSQL_DML_STRING is passed, the function now returns the connection resource instead of true on success.
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, true/false and null data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ver también

  • pg_convert() - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL


Obtiene una cadena con el último mensaje de error de la conexión

  • « pg_insert
  • pg_last_notice »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtiene una cadena con el último mensaje de error de la conexión

pg_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_last_error — Obtiene una cadena con el último mensaje de error de la conexión

Descripción

pg_last_error ( resource $connection = ? ) : string

pg_last_error() devuelve el último mensaje de error para una connection determinada.

Los mensajes de error pueden ser sobrescritos por las llamadas de función internas de PostgreSQL (libpq). Puede no devolver un mensaje de error apropiado si se producen varios errores dentro de una función de módulo PostgreSQL.

Use pg_result_error(), pg_result_error_field(), pg_result_status() y pg_connection_status() Para un mejor manejo de errores.

Nota:

Esta función se llamaba pg_errormessage().

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. Cuando connection no esta presente, la conexión por defecto es usada. La conexión por defecto es la ultima conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Un string que contiene el último mensaje de error dado por connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo depg_last_error()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Consulta que falla
  $res = pg_query($dbconn, "select * from doesnotexist");

  echo pg_last_error($dbconn);
?>

Ver también

  • pg_result_error() - Get error message associated with result
  • pg_result_error_field() - Returns an individual field of an error report


Devuelve el último aviso del servidor PostgreSQL

  • « pg_last_error
  • pg_last_oid »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el último aviso del servidor PostgreSQL

pg_last_notice

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

pg_last_notice — Devuelve el último aviso del servidor PostgreSQL

Descripción

pg_last_notice ( resource $connection , int $option = PGSQL_NOTICE_LAST ) : mixed

pg_last_notice() devuelve el último aviso de notificación del servidor PostgreSQL en la connection especificada. El servidor PostgreSQL envía mensajes de aviso en varios casos, por ejemplo al crear una columna SERIAL en una tabla.

Con pg_last_notice(), puede evitar la emisión de consultas inútiles comprobando si la notificación está o no relacionada con su transacción.

El seguimiento de mensajes de aviso se puede establecer en opcional al establecer 1 para pgsql.ignore_notice en php.ini.

El registro de mensajes de aviso puede establecerse en opcional al establecer 0 para pgsql.log_notice en php.ini. A menos que se establezca pgsql.ignore_notice a 0, no se pueden registrar los mensajes de aviso.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL.

option

One of PGSQL_NOTICE_LAST (to return last notice), PGSQL_NOTICE_ALL (to return all notices), or PGSQL_NOTICE_CLEAR (to clear notices).

Valores devueltos

Un string conteniendo el ultimo mensaje de aviso dado por connection con PGSQL_NOTICE_LAST, Un array con PGSQL_NOTICE_ALL, un boolean con PGSQL_NOTICE_CLEAR, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_last_notice()

<?php
  $pgsql_conn = pg_connect("dbname=mark host=localhost");

  $res = pg_query("CREATE TABLE test (id SERIAL)");

  $notice = pg_last_notice($pgsql_conn);

  echo $notice;
?>

El resultado del ejemplo sería:

CREATE TABLE will create implicit sequence "test_id_seq" for "serial" column "test.id"

Historial de cambios

Versión | Descripción
7.1.0 | El parameto option fue agregado.

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_last_error() - Obtiene una cadena con el último mensaje de error de la conexión


Returns the last row's OID

  • « pg_last_notice
  • pg_lo_close »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the last row's OID

pg_last_oid

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_last_oid — Returns the last row's OID

Descripción

pg_last_oid ( resource $result ) : string

pg_last_oid() is used to retrieve the OID assigned to an inserted row.

OID field became an optional field from PostgreSQL 7.2 and will not be present by default in PostgreSQL 8.1. When the OID field is not present in a table, the programmer must use pg_result_status() to check for successful insertion.

To get the value of a SERIAL field in an inserted row, it is necessary to use the PostgreSQL CURRVAL function, naming the sequence whose last value is required. If the name of the sequence is unknown, the pg_get_serial_sequence PostgreSQL 8.0 function is necessary.

PostgreSQL 8.1 has a function LASTVAL that returns the value of the most recently used sequence in the session. This avoids the need for naming the sequence, table or column altogether.

Nota:

This function used to be called pg_getlastoid().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Valores devueltos

A string containing the OID assigned to the most recently inserted row in the specified connection, or false on error or no available OID.

Ejemplos

Ejemplo #1 pg_last_oid() example

<?php
  // Connect to the database
  pg_connect("dbname=mark host=localhost");

  // Create a sample table
  pg_query("CREATE TABLE test (a INTEGER) WITH OIDS");

  // Insert some data into it
  $res = pg_query("INSERT INTO test VALUES (1)");

  $oid = pg_last_oid($res);
?>

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_result_status() - Get status of query result


Close a large object

  • « pg_last_oid
  • pg_lo_create »
  • PHP Manual
  • Funciones de PostgreSQL
  • Close a large object

pg_lo_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_close — Close a large object

Descripción

pg_lo_close ( resource $large_object ) : bool

pg_lo_close() closes a large object. large_object is a resource for the large object from pg_lo_open().

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loclose().

Parámetros

result

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_lo_close() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_open() - Open a large object
  • pg_lo_create() - Create a large object
  • pg_lo_import() - Import a large object from file


Create a large object

  • « pg_lo_close
  • pg_lo_export »
  • PHP Manual
  • Funciones de PostgreSQL
  • Create a large object

pg_lo_create

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_create — Create a large object

Descripción

pg_lo_create ( resource $connection = ? , mixed $object_id = ? ) : int
pg_lo_create ( mixed $object_id ) : int

pg_lo_create() creates a large object and returns the OID of the large object. PostgreSQL access modes INV_READ, INV_WRITE, and INV_ARCHIVE are not supported, the object is created always with both read and write access. INV_ARCHIVE has been removed from PostgreSQL itself (version 6.3 and above).

To use the large object interface, it is necessary to enclose it within a transaction block.

Instead of using the large object interface (which has no access controls and is cumbersome to use), try PostgreSQL's bytea column type and pg_escape_bytea().

Nota:

This function used to be called pg_locreate().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

object_id

If an object_id is given the function will try to create a large object with this id, else a free object id is assigned by the server. The parameter was added in PHP 5.3 and relies on functionality that first appeared in PostgreSQL 8.1.

Valores devueltos

A large object OID or false on error.

Ejemplos

Ejemplo #1 pg_lo_create() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>


Export a large object to file

  • « pg_lo_create
  • pg_lo_import »
  • PHP Manual
  • Funciones de PostgreSQL
  • Export a large object to file

pg_lo_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_export — Export a large object to file

Descripción

pg_lo_export ( resource $connection = ? , int $oid , string $pathname ) : bool

pg_lo_export() takes a large object in a PostgreSQL database and saves its contents to a file on the local filesystem.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loexport().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

pathname

The full path and file name of the file in which to write the large object on the client filesystem.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_lo_export() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   $handle = pg_lo_open($database, $oid, "w");
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_lo_export($database, $oid, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_import() - Import a large object from file


Import a large object from file

  • « pg_lo_export
  • pg_lo_open »
  • PHP Manual
  • Funciones de PostgreSQL
  • Import a large object from file

pg_lo_import

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_import — Import a large object from file

Descripción

pg_lo_import ( resource $connection = ? , string $pathname , mixed $object_id = ? ) : int

pg_lo_import() creates a new large object in the database using a file on the filesystem as its data source.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loimport().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

pathname

The full path and file name of the file on the client filesystem from which to read the large object data.

object_id

If an object_id is given the function will try to create a large object with this id, else a free object id is assigned by the server. The parameter was added in PHP 5.3 and relies on functionality that first appeared in PostgreSQL 8.1.

Valores devueltos

The OID of the newly created large object, or false on failure.

Ejemplos

Ejemplo #1 pg_lo_import() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_import($database, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_export() - Export a large object to file
  • pg_lo_open() - Open a large object


Open a large object

  • « pg_lo_import
  • pg_lo_read_all »
  • PHP Manual
  • Funciones de PostgreSQL
  • Open a large object

pg_lo_open

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_open — Open a large object

Descripción

pg_lo_open ( resource $connection , int $oid , string $mode ) : resource

pg_lo_open() opens a large object in the database and returns large object resource so that it can be manipulated.

Advertencia

Do not close the database connection before closing the large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loopen().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

mode

Can be either "r" for read-only, "w" for write only or "rw" for read and write.

Valores devueltos

A large object resource or false on error.

Ejemplos

Ejemplo #1 pg_lo_open() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_close() - Close a large object
  • pg_lo_create() - Create a large object


Reads an entire large object and send straight to browser

  • « pg_lo_open
  • pg_lo_read »
  • PHP Manual
  • Funciones de PostgreSQL
  • Reads an entire large object and send straight to browser

pg_lo_read_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_read_all — Reads an entire large object and send straight to browser

Descripción

pg_lo_read_all ( resource $large_object ) : int

pg_lo_read_all() reads a large object and passes it straight through to the browser after sending all pending headers. Mainly intended for sending binary data like images or sound.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loreadall().

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Valores devueltos

Number of bytes read or false on error.

Ejemplos

Ejemplo #1 pg_lo_read_all() example

<?php
   header('Content-type: image/jpeg');
   $image_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $image_oid, "r");
   pg_lo_read_all($handle);
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_read() - Read a large object


Read a large object

  • « pg_lo_read_all
  • pg_lo_seek »
  • PHP Manual
  • Funciones de PostgreSQL
  • Read a large object

pg_lo_read

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_read — Read a large object

Descripción

pg_lo_read ( resource $large_object , int $len = 8192 ) : string

pg_lo_read() reads at most len bytes from a large object and returns it as a string.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_loread().

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

len

An optional maximum number of bytes to return.

Valores devueltos

A string containing len bytes from the large object, or false on error.

Ejemplos

Ejemplo #1 pg_lo_read() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   $data = pg_lo_read($handle, 50000);
   pg_query($database, "commit");
   echo $data;
?>

Ver también

  • pg_lo_read_all() - Reads an entire large object and send straight to browser


Seeks position within a large object

  • « pg_lo_read
  • pg_lo_tell »
  • PHP Manual
  • Funciones de PostgreSQL
  • Seeks position within a large object

pg_lo_seek

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_seek — Seeks position within a large object

Descripción

pg_lo_seek ( resource $large_object , int $offset , int $whence = PGSQL_SEEK_CUR ) : bool

pg_lo_seek() seeks a position within a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

offset

The number of bytes to seek.

whence

One of the constants PGSQL_SEEK_SET (seek from object start), PGSQL_SEEK_CUR (seek from current position) or PGSQL_SEEK_END (seek from object end) .

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_lo_seek() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // Read the next 10000 bytes
   $data = pg_lo_read($handle, 10000);
   pg_query($database, "commit");
   echo $data;
?>

Historial de cambios

Versión | Descripción
5.6.0 | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ver también

  • pg_lo_tell() - Returns current seek position a of large object


Returns current seek position a of large object

  • « pg_lo_seek
  • pg_lo_truncate »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns current seek position a of large object

pg_lo_tell

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_tell — Returns current seek position a of large object

Descripción

pg_lo_tell ( resource $large_object ) : int

pg_lo_tell() returns the current position (offset from the beginning) of a large object.

To use the large object interface, it is necessary to enclose it within a transaction block.

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Valores devueltos

The current seek offset (in number of bytes) from the beginning of the large object. If there is an error, the return value is negative.

Ejemplos

Ejemplo #1 pg_lo_tell() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // See how far we've skipped
   $offset = pg_lo_tell($handle);
   echo "Seek position is: $offset";
   pg_query($database, "commit");
?>

El resultado del ejemplo sería:

Seek position is: 50000

Historial de cambios

Versión | Descripción
5.6.0 | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ver también

  • pg_lo_seek() - Seeks position within a large object


Truncates a large object

  • « pg_lo_tell
  • pg_lo_unlink »
  • PHP Manual
  • Funciones de PostgreSQL
  • Truncates a large object

pg_lo_truncate

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_lo_truncate — Truncates a large object

Descripción

pg_lo_truncate ( resource $large_object , int $size ) : bool

pg_lo_truncate() truncates a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

size

The number of bytes to truncate.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_lo_truncate() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Truncate to 0
   pg_lo_truncate($handle, 0);
   pg_query($database, "commit");
   echo $data;
?>

Historial de cambios

Versión | Descripción
5.6.0 | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ver también

  • pg_lo_tell() - Returns current seek position a of large object


Delete a large object

  • « pg_lo_truncate
  • pg_lo_write »
  • PHP Manual
  • Funciones de PostgreSQL
  • Delete a large object

pg_lo_unlink

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_unlink — Delete a large object

Descripción

pg_lo_unlink ( resource $connection , int $oid ) : bool

pg_lo_unlink() deletes a large object with the oid. Devuelve true en caso de éxito o false en caso de error.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_lounlink().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_lo_unlink() example

<?php
   // OID of the large object to delete
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   pg_lo_unlink($database, $doc_oid);
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_create() - Create a large object
  • pg_lo_import() - Import a large object from file


Write to a large object

  • « pg_lo_unlink
  • pg_meta_data »
  • PHP Manual
  • Funciones de PostgreSQL
  • Write to a large object

pg_lo_write

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_write — Write to a large object

Descripción

pg_lo_write ( resource $large_object , string $data , int $len = ? ) : int

pg_lo_write() writes data into a large object at the current seek position.

To use the large object interface, it is necessary to enclose it within a transaction block.

Nota:

This function used to be called pg_lowrite().

Parámetros

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

data

The data to be written to the large object. If len is specified and is less than the length of data, only len bytes will be written.

len

An optional maximum number of bytes to write. Must be greater than zero and no greater than the length of data. Defaults to the length of data.

Valores devueltos

The number of bytes written to the large object, or false on error.

Ejemplos

Ejemplo #1 pg_lo_write() example

<?php
   $doc_oid = 189762345;
   $data = "This will overwrite the start of the large object.";
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "w");
   $data = pg_lo_write($handle, $data);
   pg_query($database, "commit");
?>

Ver también

  • pg_lo_create() - Create a large object
  • pg_lo_open() - Open a large object


Get meta data for table

  • « pg_lo_write
  • pg_num_fields »
  • PHP Manual
  • Funciones de PostgreSQL
  • Get meta data for table

pg_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_meta_data — Get meta data for table

Descripción

pg_meta_data ( resource $connection , string $table_name , bool $extended = false ) : array

pg_meta_data() returns table definition for table_name as an array.

Parámetros

connection

PostgreSQL database connection resource.

table_name

The name of the table.

extended

Flag for returning extended meta data. Default to false.

Valores devueltos

An array of the table definition, or false on error.

Ejemplos

Ejemplo #1 Getting table metadata

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $meta = pg_meta_data($dbconn, 'authors');
  if (is_array($meta)) {
      echo '<pre>';
      var_dump($meta);
      echo '</pre>';
  }
?>

El resultado del ejemplo sería:

array(3) {
["author"]=>
array(5) {
  ["num"]=>
  int(1)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["year"]=>
array(5) {
  ["num"]=>
  int(2)
  ["type"]=>
  string(4) "int2"
  ["len"]=>
  int(2)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["title"]=>
array(5) {
  ["num"]=>
  int(3)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
}

Historial de cambios

Versión | Descripción
5.6.0 | No longer experimental. Added "is enum" as default attribute. extended flag is added.

Ver también

  • pg_convert() - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL


Returns the number of fields in a result

  • « pg_meta_data
  • pg_num_rows »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the number of fields in a result

pg_num_fields

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_num_fields — Returns the number of fields in a result

Descripción

pg_num_fields ( resource $result ) : int

pg_num_fields() returns the number of fields (columns) in a PostgreSQL result resource.

Nota:

This function used to be called pg_numfields().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Valores devueltos

The number of fields (columns) in the result. On error, -1 is returned.

Ejemplos

Ejemplo #1 pg_num_fields() example

<?php
$result = pg_query($conn, "SELECT 1, 2");

$num = pg_num_fields($result);

echo $num . " field(s) returned.\n";
?>

El resultado del ejemplo sería:

2 field(s) returned.

Ver también

  • pg_num_rows() - Returns the number of rows in a result
  • pg_affected_rows() - Devuelve el número de registros afectados (filas)


Returns the number of rows in a result

  • « pg_num_fields
  • pg_options »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns the number of rows in a result

pg_num_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_num_rows — Returns the number of rows in a result

Descripción

pg_num_rows ( resource $result ) : int

pg_num_rows() will return the number of rows in a PostgreSQL result resource.

Nota:

This function used to be called pg_numrows().

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Valores devueltos

The number of rows in the result. On error, -1 is returned.

Ejemplos

Ejemplo #1 pg_num_rows() example

<?php
$result = pg_query($conn, "SELECT 1");

$rows = pg_num_rows($result);

echo $rows . " row(s) returned.\n";
?>

El resultado del ejemplo sería:

1 row(s) returned.

Ver también

  • pg_num_fields() - Returns the number of fields in a result
  • pg_affected_rows() - Devuelve el número de registros afectados (filas)


Obtener las opciones asociadas con la conexión

  • « pg_num_rows
  • pg_parameter_status »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtener las opciones asociadas con la conexión

pg_options

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_options — Obtener las opciones asociadas con la conexión

Descripción

pg_options ( resource $connection = ? ) : string

pg_options() Devolverá una cadena que contiene las opciones especificadas en el recurso de connection de PostgreSQL.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando connection no esta presente, Se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Un string que contiene las opciones de connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_options()

<?php
   $pgsql_conn = pg_connect("dbname=mark host=localhost");
   echo pg_options($pgsql_conn);
?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL


Looks up a current parameter setting of the server

  • « pg_options
  • pg_pconnect »
  • PHP Manual
  • Funciones de PostgreSQL
  • Looks up a current parameter setting of the server

pg_parameter_status

(PHP 5, PHP 7, PHP 8)

pg_parameter_status — Looks up a current parameter setting of the server

Descripción

pg_parameter_status ( resource $connection = ? , string $param_name ) : string

Looks up a current parameter setting of the server.

Certain parameter values are reported by the server automatically at connection startup or whenever their values change. pg_parameter_status() can be used to interrogate these settings. It returns the current value of a parameter if known, or false if the parameter is not known.

Parameters reported as of PostgreSQL 8.0 include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. (server_encoding, TimeZone, and integer_datetimes were not reported by releases before 8.0.) Note that server_version, server_encoding and integer_datetimes cannot change after PostgreSQL startup.

PostgreSQL 7.3 or lower servers do not report parameter settings, pg_parameter_status() includes logic to obtain values for server_version and client_encoding anyway. Applications are encouraged to use pg_parameter_status() rather than ad hoc code to determine these values.

Precaución

On a pre-7.4 PostgreSQL server, changing client_encoding via SET after connection startup will not be reflected by pg_parameter_status().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

param_name

Possible param_name values include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. Note that this value is case-sensitive.

Valores devueltos

A string containing the value of the parameter, false on failure or invalid param_name.

Ejemplos

Ejemplo #1 pg_parameter_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  echo "Server encoding: ", pg_parameter_status($dbconn, "server_encoding");
?>

El resultado del ejemplo sería:

Server encoding: SQL_ASCII


Abre una conexión persistente a PostgreSQL

  • « pg_parameter_status
  • pg_ping »
  • PHP Manual
  • Funciones de PostgreSQL
  • Abre una conexión persistente a PostgreSQL

pg_pconnect

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_pconnect — Abre una conexión persistente a PostgreSQL

Descripción

pg_pconnect ( string $connection_string , int $connect_type = ? ) : resource

pg_pconnect() Abre una conexión con una base de datos PostgreSQL. Devuelve un recurso de conexión que es necesario por otras funciones para PostgreSQL.

Si se hace una segunda llamada a la función pg_pconnect() con la misma connection_string y hay una conexión existente, la conexión existente será devuelta a menos que pase la constante PGSQL_CONNECT_FORCE_NEW como connect_type.

Para habilitar la conexión persistente, la directiva de php.ini pgsql.allow_persistent se debe establecer en "On" (que es el predeterminado). El número máximo de conexiones persistentes se pueden definir con la directiva de php.ini pgsql.max_persistent (por defecto es -1 para sin límite). El número total de conexiones se pueden establecer con la directiva de php.ini pgsql.max_links.

pg_close() no cerrará enlaces persistentes generados por pg_pconnect().

Parámetros

connection_string

El parametro connection_string puede estar vacío para usar todos los parámetros por defecto, o puede contener uno o más parámetros separados por espacios en blanco. Cada ajuste de parámetros se encuentra en la forma keyword = value. Los espacios alrededor del signo igual son opcionales. Para escribir un valor vacío o un valor que contiene espacios, hay que encerrarlo entre comillas simples, por ejemplo, keyword = 'a value'. Las comillas simples y barras invertidas en el valor se pueden colocar utilizando el caracter de escapado barra invertida, es decir, \'y \\.

Las palabras clave reconocidas actualmente como parámetros son: host, hostaddr, port, dbname, user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (obsoleto a favor de sslmode), y service. Cada uno de estos argumentos existen dependiendo de su versión de PostgreSQL.

connect_type

Si PGSQL_CONNECT_FORCE_NEW es pasado, entonces una nueva conexión es creada, inclusive si la connection_string es idéntica a la de la conexión existente.

Valores devueltos

Recurso de conexión PostgreSQL en caso de éxito, false en caso de fallo.

Ejemplos

Ejemplo #1 Usando pg_pconnect()

<?php
$dbconn = pg_pconnect("dbname=mary");
//conectar a la base de datos llamada "mary"

$dbconn2 = pg_pconnect("host=localhost port=5432 dbname=mary");
// conectar a la base de datos llamada "mary" en "localhost" en el puerto "5432"

$dbconn3 = pg_pconnect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//conectar a la base de datos llamada "mary" en el host "sheep" con usuario y password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_pconnect($conn_string);
//conectar a la base de datos llamada "test" en el host "sheep" con usuario y password
?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL
  • Conexiones Persistentes a Bases de Datos


Ping a conexión de base de datos

  • « pg_pconnect
  • pg_port »
  • PHP Manual
  • Funciones de PostgreSQL
  • Ping a conexión de base de datos

pg_ping

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_ping — Ping a conexión de base de datos

Descripción

pg_ping ( resource $connection = ? ) : bool

pg_ping()Hace pings a una conexión de base de datos y trata de conectarla de nuevo si está rota.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. Cuando el parametro connection no está presente, se utiliza la conexión por defecto. La conexión por defecto es la última conexión realizada por pg_connect() o pg_pconnect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_ping()

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "Ha ocurrido un error.\n";
  exit;
}

if (!pg_ping($conn))
  die("La conexión está rota\n");
?>

Ver también

  • pg_connection_status() - Obtener estado de la conexión
  • pg_connection_reset() - Restablece conexión (reconectar)


Devuelve el número de puerto asociado con la conexión

  • « pg_ping
  • pg_prepare »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el número de puerto asociado con la conexión

pg_port

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_port — Devuelve el número de puerto asociado con la conexión

Descripción

pg_port ( resource $connection = ? ) : int

pg_port() devuelve el número de puerto al que el recurso de connection PostgreSQL está conectado.

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL. Cuando la connection no está presente, se utiliza la conexión por defecto. La conexión por defecto es la última conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Un int que contiene el número de puerto del servidor de base de datos para la connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_port()

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Conectado correctamente al puerto: " . pg_port($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>


Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete

  • « pg_port
  • pg_put_line »
  • PHP Manual
  • Funciones de PostgreSQL
  • Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete

pg_prepare

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_prepare — Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete

Descripción

pg_prepare ( resource $connection = ? , string $stmtname , string $query ) : resource

pg_prepare() crea una sentencia preparada para la ejecución posterior con pg_execute() o pg_send_execute(). Esta característica permite que los comandos que se utilizarán repetidamente se analicen y se planifiquen sólo una vez, en lugar de cada vez que se ejecuten. pg_prepare() Está soportado sólo para conexiones de PostgreSQL 7.4 o superior; fallará al usar versiones anteriores.

La función crea una sentencia preparada denominada stmtname desde la cadena query, que debe contener un único comando SQL. stmtname puede ser "" para crear una sentencia sin nombre, en cuyo caso se sustituye automáticamente cualquier sentencia sin nombre preexistente; de lo contrario, es un error si el nombre de la sentencia ya está definido en la sesión actual. Si se utilizan parámetros, se refieren al query como $1, $2, etc.

Las sentencias preparadas para su uso con pg_prepare() también se pueden crear ejecutando sentencias SQL PREPARE. (Pero pg_prepare() es más flexible, ya que no requiere preespecificar los tipos de parámetros.) Además, aunque no existe ninguna función PHP para borrar una sentencia preparada, la sentencia SQL DEALLOCATE puede utilizarse para ese propósito.

Parámetros

connection

Recurso de conexión a una base de datos de PostgreSQL. Cuando connection no está presente, se utilizará la conexión predeterminada. Esta es la última conexión realizada por pg_connect() o pg_pconnect().

stmtname

El nombre para dar la declaración preparada. Debe ser una conexión única. Si se especifica como "", entonces se crea una declaración sin nombre, sobrescribiendo cualquier declaración sin nombre previamente definida.

query

La declaración SQL parametrizada. Debe contener una sola declaración. (No se permiten las declaraciones múltiples separadas por punto y coma). Si se utiliza algún parámetro, se denominan $1, $2, etc.

Valores devueltos

Un recurso de consulta en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Usando pg_prepare()

<?php
// Conéctese a una base de datos llamada "mary"
$dbconn = pg_connect("dbname=mary");

// Preparar una consulta para la ejecución
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Ejecute la consulta preparada. Tenga en cuenta que no es necesario escapar
// el string "Joe's Widgets" de cualquier manera
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Ejecutar la misma consulta preparada, esta vez con un parámetro diferente
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Ver también

  • pg_execute() - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)


Send a NULL-terminated string to PostgreSQL backend

  • « pg_prepare
  • pg_query_params »
  • PHP Manual
  • Funciones de PostgreSQL
  • Send a NULL-terminated string to PostgreSQL backend

pg_put_line

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_put_line — Send a NULL-terminated string to PostgreSQL backend

Descripción

pg_put_line ( resource $connection = ? , string $data ) : bool

pg_put_line() sends a NULL-terminated string to the PostgreSQL backend server. This is needed in conjunction with PostgreSQL's COPY FROM command.

COPY is a high-speed data loading interface supported by PostgreSQL. Data is passed in without being parsed, and in a single transaction.

An alternative to using raw pg_put_line() commands is to use pg_copy_from(). This is a far simpler interface.

Nota:

The application must explicitly send the two characters "\." on the last line to indicate to the backend that it has finished sending its data, before issuing pg_end_copy().

Advertencia

Use of the pg_put_line() causes most large object operations, including pg_lo_read() and pg_lo_tell(), to subsequently fail. You can use pg_copy_from() and pg_copy_to() instead.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A line of text to be sent directly to the PostgreSQL backend. A NULL terminator is added automatically.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_put_line() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Ver también

  • pg_end_copy() - Sincronizar con PostgreSQL


Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

  • « pg_put_line
  • pg_query »
  • PHP Manual
  • Funciones de PostgreSQL
  • Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

pg_query_params

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

Descripción

pg_query_params ( resource $connection = ? , string $query , array $params ) : resource|false

Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_query_params() is like pg_query(), but offers additional functionality: parameter values can be specified separately from the command string proper. pg_query_params() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

If parameters are used, they are referred to in the query string as $1, $2, etc. The same parameter may appear more than once in the query; the same value will be used in that case. params specifies the actual values of the parameters. A null value in this array means the corresponding parameter is SQL NULL.

The primary advantage of pg_query_params() over pg_query() is that parameter values may be separated from the query string, thus avoiding the need for tedious and error-prone quoting and escaping. Unlike pg_query(), pg_query_params() allows at most one SQL command in the given string. (There can be semicolons in it, but not more than one nonempty command.)

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

User-supplied values should always be passed as parameters, not interpolated into the query string, where they form possible SQL injection attack vectors and introduce bugs when handling data containing quotes. If for some reason you cannot use a parameter, ensure that interpolated values are properly escaped.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Values intended for bytea fields are not supported as parameters. Use pg_escape_bytea() instead, or use the large object functions.

Valores devueltos

A query result resource on success o false en caso de error.

Ejemplos

Ejemplo #1 Using pg_query_params()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Find all shops named Joe's Widgets.  Note that it is not necessary to
// escape "Joe's Widgets"
$result = pg_query_params($dbconn, 'SELECT * FROM shops WHERE name = $1', array("Joe's Widgets"));

// Compare against just using pg_query
$str = pg_escape_string("Joe's Widgets");
$result = pg_query($dbconn, "SELECT * FROM shops WHERE name = '{$str}'");

?>

Ver también

  • pg_query() - Ejecutar una consulta


Ejecutar una consulta

  • « pg_query_params
  • pg_result_error_field »
  • PHP Manual
  • Funciones de PostgreSQL
  • Ejecutar una consulta

pg_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_query — Ejecutar una consulta

Descripción

pg_query ( resource $connection = ? , string $query ) : resource

pg_query() ejecuta la consulta dada por query en la conexión a la base de datos especificada por connection. En la mayoría de los casos, es preferible utilizar pg_query_params().

Si ocurre un error y se devuelve false, se pueden recuperara los detalles de este error con la función pg_last_error() si la conexión es válida.

Nota: Aunque se puede omitir connection, no se recomienda debido a que puede ser difícil encontrar errores en scripts.

Nota:

Esta función se solía llamar pg_exec(). pg_exec() aún está disponible por compatibilidad, aunque se recomienda utilizar en nuevo nombre.

Parámetros

connection

Recurso de conexión a una base de datos de PostgreSQL. Cuando connection no está presente, se utilizará la conexión predeterminada. Esta es la última conexión realizada por pg_connect() o pg_pconnect().

query

La sentencia o sentencias SQL a ejecutar. Cuando se pasan varias sentencias a la función, automáticamente se ejecutan como una sola transacción, a menos que haya comandos BEGIN/COMMIT explícitos incluidos en la cadena de consulta. Sin embargo, no se recomiendo el uso de varias transacciones en una llamada a la función.

Advertencia

La interpolación de datos proporcionados por el usuario es extremadamente peligrosa y probablemente lleve a vulnerabilidades de inyecciones SQL. En la mayoría de los casos es preferible el uso de pg_query_params(), pasando los valores proporcionados por el usuario como parámetros en lugar de sustituirlos en la cadena de consulta.

Cualquier dato proporcionado por el usuario sustituido directamente en una cadena de consulta debe ser escapado adecuadamente.

Valores devueltos

Un recurso de resultados de consulta en caso de éxtio o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_query()

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "Ocurrió un error.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "Ocurrió un error.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Ejemplo #2 Uso de pg_query() con varias sentencias

<?php

$conn = pg_pconnect("dbname=publisher");

// estas sentencias se ejecutarán como una sola transacción

$query = "UPDATE authors SET author=UPPER(author) WHERE id=1;";
$query .= "UPDATE authors SET author=LOWER(author) WHERE id=2;";
$query .= "UPDATE authors SET author=NULL WHERE id=3;";

pg_query($conn, $query);

?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL
  • pg_pconnect() - Abre una conexión persistente a PostgreSQL
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_num_rows() - Returns the number of rows in a result
  • pg_affected_rows() - Devuelve el número de registros afectados (filas)


Returns an individual field of an error report

  • « pg_query
  • pg_result_error »
  • PHP Manual
  • Funciones de PostgreSQL
  • Returns an individual field of an error report

pg_result_error_field

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_result_error_field — Returns an individual field of an error report

Descripción

pg_result_error_field ( resource $result , int $fieldcode ) : string

pg_result_error_field() returns one of the detailed error message fields associated with result resource. It is only available against a PostgreSQL 7.4 or above server. The error field is specified by the fieldcode.

Because pg_query() and pg_query_params() return false if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

If you need to get additional error information from failed pg_query() queries, use pg_set_error_verbosity() and pg_last_error() and then parse the result.

Parámetros

result

A PostgreSQL query result resource from a previously executed statement.

fieldcode

Possible fieldcode values are: PGSQL_DIAG_SEVERITY, PGSQL_DIAG_SQLSTATE, PGSQL_DIAG_MESSAGE_PRIMARY, PGSQL_DIAG_MESSAGE_DETAIL, PGSQL_DIAG_MESSAGE_HINT, PGSQL_DIAG_STATEMENT_POSITION, PGSQL_DIAG_INTERNAL_POSITION (PostgreSQL 8.0+ only), PGSQL_DIAG_INTERNAL_QUERY (PostgreSQL 8.0+ only), PGSQL_DIAG_CONTEXT, PGSQL_DIAG_SOURCE_FILE, PGSQL_DIAG_SOURCE_LINE or PGSQL_DIAG_SOURCE_FUNCTION.

Valores devueltos

A string containing the contents of the error field, null if the field does not exist or false on failure.

Ejemplos

Ejemplo #1 pg_result_error_field() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error_field($res1, PGSQL_DIAG_SQLSTATE);
?>

Ver también

  • pg_result_error() - Get error message associated with result


Get error message associated with result

  • « pg_result_error_field
  • pg_result_seek »
  • PHP Manual
  • Funciones de PostgreSQL
  • Get error message associated with result

pg_result_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_result_error — Get error message associated with result

Descripción

pg_result_error ( resource $result ) : string

pg_result_error() returns any error message associated with the result resource. Therefore, the user has a better chance of getting the correct error message than with pg_last_error().

The function pg_result_error_field() can give much greater detail on result errors than pg_result_error().

Because pg_query() returns false if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Valores devueltos

Returns a string. Returns empty string if there is no error. If there is an error associated with the result parameter, returns false.

Ejemplos

Ejemplo #1 pg_result_error() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Ver también

  • pg_result_error_field() - Returns an individual field of an error report
  • pg_query() - Ejecutar una consulta
  • pg_send_query() - Sends asynchronous query
  • pg_get_result() - Get asynchronous query result
  • pg_last_error() - Obtiene una cadena con el último mensaje de error de la conexión
  • pg_last_notice() - Devuelve el último aviso del servidor PostgreSQL


Set internal row offset in result resource

  • « pg_result_error
  • pg_result_status »
  • PHP Manual
  • Funciones de PostgreSQL
  • Set internal row offset in result resource

pg_result_seek

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_result_seek — Set internal row offset in result resource

Descripción

pg_result_seek ( resource $result , int $offset ) : bool

pg_result_seek() sets the internal row offset in a result resource.

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

offset

Row to move the internal offset to in the result resource. Rows are numbered starting from zero.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_result_seek() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a query
$result = pg_query($conn, "SELECT author, email FROM authors");

// Seek to the 3rd row (assuming there are 3 rows)
pg_result_seek($result, 2);

// Fetch the 3rd row
$row = pg_fetch_row($result);

?>

Ver también

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_assoc() - Fetch a row as an associative array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource


Get status of query result

  • « pg_result_seek
  • pg_select »
  • PHP Manual
  • Funciones de PostgreSQL
  • Get status of query result

pg_result_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_result_status — Get status of query result

Descripción

pg_result_status ( resource $result , int $type = PGSQL_STATUS_LONG ) : mixed

pg_result_status() returns the status of a result resource, or the PostgreSQL command completion tag associated with the result

Parámetros

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

type

Either PGSQL_STATUS_LONG to return the numeric status of the result, or PGSQL_STATUS_STRING to return the command tag of the result. If not specified, PGSQL_STATUS_LONG is the default.

Valores devueltos

Possible return values are PGSQL_EMPTY_QUERY, PGSQL_COMMAND_OK, PGSQL_TUPLES_OK, PGSQL_COPY_OUT, PGSQL_COPY_IN, PGSQL_BAD_RESPONSE, PGSQL_NONFATAL_ERROR and PGSQL_FATAL_ERROR if PGSQL_STATUS_LONG is specified. Otherwise, a string containing the PostgreSQL command tag is returned.

Ejemplos

Ejemplo #1 pg_result_status() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a COPY
$result = pg_query($conn, "COPY authors FROM STDIN;");

// Get the result status
$status = pg_result_status($result);

// Determine status
if ($status == PGSQL_COPY_IN)
   echo "Copy began.";
else
   echo "Copy failed.";

?>

El resultado del ejemplo sería:

Copy began.

Ver también

  • pg_connection_status() - Obtener estado de la conexión


Select records

  • « pg_result_status
  • pg_send_execute »
  • PHP Manual
  • Funciones de PostgreSQL
  • Select records

pg_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_select — Select records

Descripción

pg_select ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC , int $result_type = PGSQL_ASSOC ) : mixed

pg_select() selects records specified by assoc_array which has field=>value. For a successful query, it returns an array containing all records and fields that match the condition specified by assoc_array.

If options is specified, pg_convert() is applied to assoc_array with the specified flags.

By default pg_select() passes raw values. Values must be escaped or PGSQL_DML_ESCAPE option must be specified. PGSQL_DML_ESCAPE quotes and escapes parameters/identifiers. Therefore, table/column names became case sensitive.

Note that neither escape nor prepared query can protect LIKE query, JSON, Array, Regex, etc. These parameters should be handled according to their contexts. i.e. Escape/validate values.

Parámetros

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to select rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be retrieved.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Returns string if PGSQL_DML_STRING is passed via options.

Ejemplos

Ejemplo #1 pg_select() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe somewhat, since all values are escaped.
  // However PostgreSQL supports JSON/Array. These are not
  // safe by neither escape nor prepared query.
  $rec = pg_select($db, 'post_log', $_POST, PG_DML_ESCAPE);
  if ($rec) {
      echo "Records selected\n";
      var_dump($rec);
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Historial de cambios

Versión | Descripción
7.1.0 | The result_type parameter was added.
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, true/false and null data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ver también

  • pg_convert() - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL


Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

  • « pg_select
  • pg_send_prepare »
  • PHP Manual
  • Funciones de PostgreSQL
  • Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

pg_send_execute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

Descripción

pg_send_execute ( resource $connection , string $stmtname , array $params ) : bool

Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

This is similar to pg_send_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. The function's parameters are handled identically to pg_execute(). Like pg_execute(), it will not work on pre-7.4 versions of PostgreSQL.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Valores devueltos

Returns true on success, false on failure. Use pg_get_result() to determine the query result.

Ejemplos

Ejemplo #1 Using pg_send_execute()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Ver también

  • pg_prepare() - Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete
  • pg_send_prepare() - Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización
  • pg_execute() - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado


Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización

  • « pg_send_execute
  • pg_send_query_params »
  • PHP Manual
  • Funciones de PostgreSQL
  • Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización

pg_send_prepare

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_prepare — Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización

Descripción

pg_send_prepare ( resource $connection , string $stmtname , string $query ) : bool

Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización.

Esta es una versión asincrónica de pg_prepare(): devuelve true si fue capaz de enviar la solicitud, y false si no. Después de una llamada exitosa, llame al pg_get_result() Para determinar si el servidor creó correctamente la instrucción preparada. Los parámetros de la función se manejan de forma idéntica a pg_prepare(). Al igual que pg_prepare(), no funcionará en versiones anteriores a 7.4 en PostgreSQL.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando no está presente connection, se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión realizada por pg_connect() o pg_pconnect().

stmtname

El nombre para dar la declaración preparada. Debe ser único por conexión. Si se especifica "", se crea una sentencia sin nombre, sobrescribiendo cualquier sentencia anónima previamente definida.

query

La sentencia SQL parametrizada. Debe contener sólo una sola sentencia. (No se permiten declaraciones múltiples separadas por punto y coma.) Si se utilizan parámetros, se les conoce como $1, $2, etc.

Valores devueltos

Devuelve true en caso de éxito, false en caso de error. Utilice pg_get_result() para determinar el resultado de la consulta.

Ejemplos

Ejemplo #1 Utilizando pg_send_prepare()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Preparar una consulta para su ejecución
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Ejecute la consulta preparada. Tenga en cuenta que no es necesario
  // escapar la cadena "Joe's Widgets" de ninguna manera
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Ejecute la misma consulta preparada, esta vez con un parámetro diferente
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Ver también

  • pg_connect() - Abre una conexión a PostgreSQL
  • pg_pconnect() - Abre una conexión persistente a PostgreSQL
  • pg_execute() - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
  • pg_send_query_params() - Submits a command and separate parameters to the server without waiting for the result(s)


Submits a command and separate parameters to the server without waiting for the result(s)

  • « pg_send_prepare
  • pg_send_query »
  • PHP Manual
  • Funciones de PostgreSQL
  • Submits a command and separate parameters to the server without waiting for the result(s)

pg_send_query_params

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)

Descripción

pg_send_query_params ( resource $connection , string $query , array $params ) : bool

Submits a command and separate parameters to the server without waiting for the result(s).

This is equivalent to pg_send_query() except that query parameters can be specified separately from the query string. The function's parameters are handled identically to pg_query_params(). Like pg_query_params(), it will not work on pre-7.4 PostgreSQL connections, and it allows only one command in the query string.

Parámetros

connection

PostgreSQL database connection resource.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Use pg_get_result() to determine the query result.

Ejemplos

Ejemplo #1 Using pg_send_query_params()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Using parameters.  Note that it is not necessary to quote or escape
  // the parameter.
  pg_send_query_params($dbconn, 'select count(*) from authors where city = $1', array('Perth'));

  // Compare against basic pg_send_query usage
  $str = pg_escape_string('Perth');
  pg_send_query($dbconn, "select count(*) from authors where city = '${str}'");
?>

Ver también

  • pg_send_query() - Sends asynchronous query


Sends asynchronous query

  • « pg_send_query_params
  • pg_set_client_encoding »
  • PHP Manual
  • Funciones de PostgreSQL
  • Sends asynchronous query

pg_send_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_send_query — Sends asynchronous query

Descripción

pg_send_query ( resource $connection , string $query ) : bool

pg_send_query() sends a query or queries asynchronously to the connection. Unlike pg_query(), it can send multiple queries at once to PostgreSQL and get the results one by one using pg_get_result().

Script execution is not blocked while the queries are executing. Use pg_connection_busy() to check if the connection is busy (i.e. the query is executing). Queries may be cancelled using pg_cancel_query().

Although the user can send multiple queries at once, multiple queries cannot be sent over a busy connection. If a query is sent while the connection is busy, it waits until the last query is finished and discards all its results.

Parámetros

connection

PostgreSQL database connection resource.

query

The SQL statement or statements to be executed.

Data inside the query should be properly escaped.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Use pg_get_result() to determine the query result.

Ejemplos

Ejemplo #1 pg_send_query() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

El resultado del ejemplo sería:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Ver también

  • pg_query() - Ejecutar una consulta
  • pg_cancel_query() - Cancelar una consulta asíncrona
  • pg_get_result() - Get asynchronous query result
  • pg_connection_busy() - Permite saber si la conexión esta ocupada o no


Set the client encoding

  • « pg_send_query
  • pg_set_error_verbosity »
  • PHP Manual
  • Funciones de PostgreSQL
  • Set the client encoding

pg_set_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_set_client_encoding — Set the client encoding

Descripción

pg_set_client_encoding ( resource $connection = ? , string $encoding ) : int

pg_set_client_encoding() sets the client encoding and returns 0 if success or -1 if error.

PostgreSQL will automatically convert data in the backend database encoding into the frontend encoding.

Nota:

The function used to be called pg_setclientencoding().

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

encoding

The required client encoding. One of SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL, LATINX (X=1...9), KOI8, WIN, ALT, SJIS, BIG5 or WIN1250.

The exact list of available encodings depends on your PostgreSQL version, so check your PostgreSQL manual for a more specific list.

Valores devueltos

Returns 0 on success or -1 on error.

Ejemplos

Ejemplo #1 pg_set_client_encoding() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Set the client encoding to UNICODE.  Data will be automatically
// converted from the backend encoding to the frontend.
pg_set_client_encoding($conn, "UNICODE");

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

// Write out UTF-8 data
while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Ver también

  • pg_client_encoding() - Obtiene la codificación del cliente


Determines the verbosity of messages returned by pg_last_error and pg_result_error

  • « pg_set_client_encoding
  • pg_socket »
  • PHP Manual
  • Funciones de PostgreSQL
  • Determines the verbosity of messages returned by pg_last_error and pg_result_error

pg_set_error_verbosity

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error() and pg_result_error()

Descripción

pg_set_error_verbosity ( resource $connection = ? , int $verbosity ) : int

Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

pg_set_error_verbosity() sets the verbosity mode, returning the connection's previous setting. In PGSQL_ERRORS_TERSE mode, returned messages include severity, primary text, and position only; this will normally fit on a single line. The default mode (PGSQL_ERRORS_DEFAULT) produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines). The PGSQL_ERRORS_VERBOSE mode includes all available fields. Changing the verbosity does not affect the messages available from already-existing result objects, only subsequently-created ones.

Parámetros

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

verbosity

The required verbosity: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Valores devueltos

The previous verbosity level: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Ejemplos

Ejemplo #1 pg_set_error_verbosity() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  pg_set_error_verbosity($dbconn, PGSQL_ERRORS_VERBOSE);
  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Ver también

  • pg_last_error() - Obtiene una cadena con el último mensaje de error de la conexión
  • pg_result_error() - Get error message associated with result


Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL

  • « pg_set_error_verbosity
  • pg_trace »
  • PHP Manual
  • Funciones de PostgreSQL
  • Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL

pg_socket

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_socket — Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL

Descripción

pg_socket ( resource $connection ) : resource

pg_socket() Devuelve un resource de sólo lectura que corresponde al socket subyacente a la conexión dada de PostgreSQL.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL.

Valores devueltos

Un recurso socket en caso de exito o o false en caso de error.


Enable tracing a PostgreSQL connection

  • « pg_socket
  • pg_transaction_status »
  • PHP Manual
  • Funciones de PostgreSQL
  • Enable tracing a PostgreSQL connection

pg_trace

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

pg_trace — Enable tracing a PostgreSQL connection

Descripción

pg_trace ( string $pathname , string $mode = "w" , resource $connection = ? ) : bool

pg_trace() enables tracing of the PostgreSQL frontend/backend communication to a file. To fully understand the results, one needs to be familiar with the internals of PostgreSQL communication protocol.

For those who are not, it can still be useful for tracing errors in queries sent to the server, you could do for example grep '^To backend' trace.log and see what queries actually were sent to the PostgreSQL server. For more information, refer to the » PostgreSQL Documentation.

Parámetros

pathname

The full path and file name of the file in which to write the trace log. Same as in fopen().

mode

An optional file access mode, same as for fopen().

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pg_trace() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Now /tmp/trace.log will contain backend communication
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ver también

  • fopen() - Abre un fichero o un URL
  • pg_untrace() - Desactivar el rastreo de una conexión de PostgreSQL


Devuelve el estado actual de la transaccion del servidor

  • « pg_trace
  • pg_tty »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve el estado actual de la transaccion del servidor

pg_transaction_status

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_transaction_status — Devuelve el estado actual de la transaccion del servidor

Descripción

pg_transaction_status ( resource $connection ) : int

Devuelve el estado actual de la transacción del servidor.

Precaución

pg_transaction_status() Dará resultados incorrectos al usar un servidor PostgreSQL 7.3 que tenga el parámetro autocommit establecido en off. La función de autocommit del lado del servidor esta obsoleta y no existe en las versiones posteriores del servidor.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL.

Valores devueltos

The status can be PGSQL_TRANSACTION_IDLE (currently idle), PGSQL_TRANSACTION_ACTIVE (a command is in progress), PGSQL_TRANSACTION_INTRANS (idle, in a valid transaction block), or PGSQL_TRANSACTION_INERROR (idle, in a failed transaction block). PGSQL_TRANSACTION_UNKNOWN is reported if the connection is bad. PGSQL_TRANSACTION_ACTIVE is reported only when a query has been sent to the server and not yet completed.

Ejemplos

Ejemplo #1 Ejemplo de pg_transaction_status()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_transaction_status($dbconn);
  if ($stat === PGSQL_TRANSACTION_UNKNOWN) {
      echo 'Connection is bad';
  } else if ($stat === PGSQL_TRANSACTION_IDLE) {
      echo 'Connection is currently idle';
  } else {
      echo 'Connection is in a transaction state';
  }
?>


Devolver el nombre TTY asociado con la conexión

  • « pg_transaction_status
  • pg_unescape_bytea »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devolver el nombre TTY asociado con la conexión

pg_tty

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_tty — Devolver el nombre TTY asociado con la conexión

Descripción

pg_tty ( resource $connection = ? ) : string

pg_tty() Devuelve el nombre TTY al que se envía la salida de depuración del servidor en el recurso de connection de PostgreSQL.

Nota:

pg_tty() Es obsoleto, ya que el servidor ya no presta atención a la configuración de TTY, pero la función aún se mantiene para la compatibilidad hacia atrás.

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando no hay connection, se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión realizada por pg_connect() o pg_pconnect().

Valores devueltos

Un string que contiene el TTY de depuración de la connection, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pg_tty()

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Server debug TTY is: " . pg_tty($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>


Unescape binary for bytea type

  • « pg_tty
  • pg_untrace »
  • PHP Manual
  • Funciones de PostgreSQL
  • Unescape binary for bytea type

pg_unescape_bytea

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_unescape_bytea — Unescape binary for bytea type

Descripción

pg_unescape_bytea ( string $data ) : string

pg_unescape_bytea() unescapes PostgreSQL bytea data values. It returns the unescaped string, possibly containing binary data.

Nota:

When you SELECT a bytea type, PostgreSQL returns octal byte values prefixed with '\' (e.g. \032). Users are supposed to convert back to binary format manually.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea values must be cast when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need a cast. The exception is when the client and backend character encoding does not match, and there may be multi-byte stream error. User must then cast to bytea to avoid this error.

Parámetros

data

A string containing PostgreSQL bytea data to be converted into a PHP binary string.

Valores devueltos

A string containing the unescaped data.

Ejemplos

Ejemplo #1 pg_unescape_bytea() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Get the bytea data
  $res = pg_query("SELECT data FROM gallery WHERE name='Pine trees'");
  $raw = pg_fetch_result($res, 'data');

  // Convert to binary and send to the browser
  header('Content-type: image/jpeg');
  echo pg_unescape_bytea($raw);
?>

Historial de cambios

Versión | Descripción
5.5.1 | A warning is thrown if the input string is invalid.

Ver también

  • pg_escape_bytea() - Escapar un string para insertarlo en un campo bytea
  • pg_escape_string() - Escape a string for query


Desactivar el rastreo de una conexión de PostgreSQL

  • « pg_unescape_bytea
  • pg_update »
  • PHP Manual
  • Funciones de PostgreSQL
  • Desactivar el rastreo de una conexión de PostgreSQL

pg_untrace

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

pg_untrace — Desactivar el rastreo de una conexión de PostgreSQL

Descripción

pg_untrace ( resource $connection = ? ) : bool

Detener el seguimiento iniciado porpg_trace().

Parámetros

connection

Recurso de conexión a la base de datos PostgreSQL. Cuando no hay connection, se utiliza la conexión predeterminada. La conexión predeterminada es la última conexión realizada por pg_connect() o pg_pconnect().

Valores devueltos

Siempre retorna true.

Ejemplos

Ejemplo #1 Ejemplo de pg_untrace()

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Ahora el seguimiento de la comunicación de back-end está deshabilitado
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ver también

  • pg_trace() - Enable tracing a PostgreSQL connection


Actualizar tabla

  • « pg_untrace
  • pg_version »
  • PHP Manual
  • Funciones de PostgreSQL
  • Actualizar tabla

pg_update

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_update — Actualizar tabla

Descripción

pg_update ( resource $connection , string $table_name , array $data , array $condition , int $options = PGSQL_DML_EXEC ) : mixed

pg_update() Actualiza los registros que coinciden condition con data. Si options es especificado, pg_convert() es aplicado a data con las opciones especificadas.

Parámetros

connection

Recurso de conexión a base de datos PostgreSQL.

table_name

Nombre de la tabla en la que actualizar filas.

data

Un array cuyas claves son nombres de campos en la tabla table_name, y cuyos valores son las que coinciden con las filas que deben ser actualizados.

condition

Un array cuyas claves son nombres de campos en la tabla table_name, y cuyos valores son las condiciones que una fila debe cumplir para ser actualizada.

options

Cualquier numero de PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC o PGSQL_DML_STRING combinado. Si PGSQL_DML_STRING es parte de options entonces se devuelve la cadena de consulta. Cuando PGSQL_DML_NO_CONV o PGSQL_DML_ESCAPE está establecido, Esto no llama a pg_convert() internamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Retorna string si PGSQL_DML_STRING es pasado vía options.

Ejemplos

Ejemplo #1 Ejemplo de pg_update()

<?php
  $db = pg_connect('dbname=foo');
  $data = array('field1'=>'AA', 'field2'=>'BB');

  // Esto es seguro, ya que $ _POST se convierte automáticamente
  $res = pg_update($db, 'post_log', $_POST, $data);
  if ($res) {
      echo "Data is updated: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Historial de cambios

Versión | Descripción
5.6.0 | Ya no es experimental. Se ha añadido la constante PGSQL_DML_ESCAPE, true/false y null son los tipo de datos soportados.
5.5.3/5.4.19 | La inyección directa SQL a table_name y la inyección indirecta SQL a los indetificadores a sido arreglada.

Ver también

  • pg_convert() - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL


Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)

  • « pg_update
  • SQLite3 »
  • PHP Manual
  • Funciones de PostgreSQL
  • Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)

pg_version

(PHP 5, PHP 7, PHP 8)

pg_version — Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)

Descripción

pg_version ( resource $connection = ? ) : array

pg_version() Devuelve un array con el cliente, protocolo y la versión del servidor. Las versiones del protocolo y el servidor sólo están disponibles si PHP se compiló con PostgreSQL 7.4 o posterior.

Para obtener información más detallada del servidor, utilice pg_parameter_status().

Parámetros

connection

Recurso de conexión de base de datos PostgreSQL o PostgreSQL database connection resource. Cuando el parametro connection no esta presente, se utiliza la conexión por defecto. La conexión por defecto es la ultima conexión hecha por pg_connect() o pg_pconnect().

Valores devueltos

Devuelve un array con el client, protocol y server con sus claves y valores (si está disponibles). Devuelve false en caso de error o una conexión no válida.

Ejemplos

Ejemplo #1 Ejemplo de pg_version()

<?php
  $dbconn = pg_connect("host=localhost port=5432 dbname=mary")
     or die("No e ha podido conectar");

  $v = pg_version($dbconn);

  echo $v['client'];
?>

El resultado del ejemplo sería:

7.4

Ver también

  • pg_parameter_status() - Looks up a current parameter setting of the server


SQLite3

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • SQLite3 — La clase de SQLite3
    • SQLite3::backup — Backup one database to another database
    • SQLite3::busyTimeout — Establecer el gestor de conexión ocupado
    • SQLite3::changes — Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente
    • SQLite3::close — Cerrar la conexión a la base de datos
    • SQLite3::__construct — Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3
    • SQLite3::createAggregate — Registrar una función de PHP para usarla como una función totalizadora de SQL
    • SQLite3::createCollation — Registra una función PHP para ser utilizada como una función SQL de ordenación específica
    • SQLite3::createFunction — Registrar una función de PHP para usarla como una función escalar de SQL
    • SQLite3::enableExceptions — Enable throwing exceptions
    • SQLite3::escapeString — Devolver una cadena que ha sido debidamente escapada
    • SQLite3::exec — Ejecutar una consulta que no devuelve resultados en una base de datos dada
    • SQLite3::lastErrorCode — Devolver el código numérico del resultado de la petición SQLite que falló más recientemente
    • SQLite3::lastErrorMsg — Devolver texto en inglés describiendo la petición SQLite que falló más recientemente
    • SQLite3::lastInsertRowID — Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos
    • SQLite3::loadExtension — Intentar cargar una biblioteca de extensiones de SQLite
    • SQLite3::open — Abrir una base de datos SQLite
    • SQLite3::openBlob — Opens a stream resource to read a BLOB
    • SQLite3::prepare — Preparar una sentencia SQL para su ejecución
    • SQLite3::query — Ejecutar una consulta SQL
    • SQLite3::querySingle — Ejecutar una consulta y devolver un único resultado
    • SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do
    • SQLite3::version — Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número
  • SQLite3Stmt — La clase SQLite3Stmt
    • SQLite3Stmt::bindParam — Vincular un parámetro a una variable de sentencia
    • SQLite3Stmt::bindValue — Vincular el valor de un parámetro a una variable de sentencia
    • SQLite3Stmt::clear — Limpiar todos los parámetros vinculados actuales
    • SQLite3Stmt::close — Cerrar una sentencia preparada
    • SQLite3Stmt::execute — Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados
    • SQLite3Stmt::getSQL — Get the SQL of the statement
    • SQLite3Stmt::paramCount — Devolver el número de parámetros dentro de la sentencia preparada
    • SQLite3Stmt::readOnly — Returns whether a statement is definitely read only
    • SQLite3Stmt::reset — Reiniciar la sentencia preparada
  • SQLite3Result — La clase SQLite3Result
    • SQLite3Result::columnName — Devolver el nombre de la columna n-ésima
    • SQLite3Result::columnType — Devolver el tipo de la columna n-ésima
    • SQLite3Result::fetchArray — Obtener una fila de resultados en forma de un array asociativo o indexado o ambos
    • SQLite3Result::finalize — Cerrar el conjunto de resultados
    • SQLite3Result::numColumns — Devolver el número de columnas del conjunto de resultados
    • SQLite3Result::reset — Reiniciar el conjunto de resultados a la primera fila


  • « SQLite3
  • Instalación/Configuración »
  • PHP Manual
  • SQLite3
  • Introducción

Introducción

Soporte para bases de datos SQLite versión 3.


Instalación

La extensión SQLite3 está activada por defecto desde PHP 5.3.0. Se puede desactivar usando --without-sqlite3 en tiempo de compilación.

Los usuarios de Windows deben activar php_sqlite3.dll para poder usar esta extensión. Esta DLL se incluye con las distribuciones de PHP para Windows desde la versión 5.3.0.

Nota:

Durante un corto período de tiempo esta extensión era PECL pero esta versión solo es recomendada para uso experimental.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de SQLite3
Nombre | Por defecto | Cambiable | Listado de cambios
sqlite3.extension_dir | NULL | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

sqlite3.extension_dir string

Ruta al directorio donde las extensiones de SQLite residen.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SQLITE3_ASSOC (integer)
Especifica que el método Sqlite3Result::fetchArray() deberá devolver un array indexado por el nombre de columna como el devuelto en el correspondiente conjunto de resultados.
SQLITE3_NUM (integer)
Especifica que el método Sqlite3Result::fetchArray() deberá devolver un array indexado por el número de columna como el devuelto en el correspondiente conjunto de resultados, comenzando por la columna 0.
SQLITE3_BOTH (integer)
Especifica que el método Sqlite3Result::fetchArray() deberá devolver un array indexado tanto por el nombre como por el número de columna como el devuelto en el correspondiente conjunto de resultados, comenzando por la columna 0.
SQLITE3_INTEGER (integer)
Representa la clase de almacenamiento INTEGER de SQLite3.
SQLITE3_FLOAT (integer)
Representa la clase de almacenamiento REAL (FLOAT) de SQLite3.
SQLITE3_TEXT (integer)
Representa la clase de almacenamiento TEXT de SQLite3.
SQLITE3_BLOB (integer)
Representa la clase de almacenamiento BLOB de SQLite3.
SQLITE3_NULL (integer)
Representa la clase de almacenamiento NULL de SQLite3.
SQLITE3_OPEN_READONLY (integer)
Especifica que la base de datos SQLite3 será abierta para sólo lectura.
SQLITE3_OPEN_READWRITE (integer)
Especifica que la base de datos SQLite3 será abierta para lectura y escritura.
SQLITE3_OPEN_CREATE (integer)
Especifica que la base de datos SQLite3 será creada si aún no existe.


La clase de SQLite3

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

Una clase que se usa como interfaz de bases de datos SQLite 3.

Sinopsis de la Clase

SQLite3 {
/* Métodos */
public backup ( SQLite3 $destination , string $sourceDatabase = "main" , string $destinationDatabase = "main" ) : bool
public busyTimeout ( int $msecs ) : bool
public changes ( ) : int
public close ( ) : bool
public __construct ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryption_key = null )
public createAggregate ( string $name , mixed $step_callback , mixed $final_callback , int $argument_count = -1 ) : bool
public createCollation ( string $name , callable $callback ) : bool
public createFunction ( string $name , mixed $callback , int $argument_count = -1 ) : bool
public enableExceptions ( bool $enable = false ) : bool
public static escapeString ( string $value ) : string
public exec ( string $query ) : bool
public lastErrorCode ( ) : int
public lastErrorMsg ( ) : string
public lastInsertRowID ( ) : int
public loadExtension ( string $shared_library ) : bool
public open ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryption_key = null ) : void
public openBlob ( string $table , string $column , int $rowid , string $database = "main" , int $flags = SQLITE3_OPEN_READONLY ) : resource|false
public prepare ( string $query ) : SQLite3Stmt
public query ( string $query ) : SQLite3Result
public querySingle ( string $query , bool $entire_row = false ) : mixed
public setAuthorizer ( callable|null $callback ) : bool
public static version ( ) : array
}

Tabla de contenidos

  • SQLite3::backup — Backup one database to another database
  • SQLite3::busyTimeout — Establecer el gestor de conexión ocupado
  • SQLite3::changes — Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente
  • SQLite3::close — Cerrar la conexión a la base de datos
  • SQLite3::__construct — Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3
  • SQLite3::createAggregate — Registrar una función de PHP para usarla como una función totalizadora de SQL
  • SQLite3::createCollation — Registra una función PHP para ser utilizada como una función SQL de ordenación específica
  • SQLite3::createFunction — Registrar una función de PHP para usarla como una función escalar de SQL
  • SQLite3::enableExceptions — Enable throwing exceptions
  • SQLite3::escapeString — Devolver una cadena que ha sido debidamente escapada
  • SQLite3::exec — Ejecutar una consulta que no devuelve resultados en una base de datos dada
  • SQLite3::lastErrorCode — Devolver el código numérico del resultado de la petición SQLite que falló más recientemente
  • SQLite3::lastErrorMsg — Devolver texto en inglés describiendo la petición SQLite que falló más recientemente
  • SQLite3::lastInsertRowID — Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos
  • SQLite3::loadExtension — Intentar cargar una biblioteca de extensiones de SQLite
  • SQLite3::open — Abrir una base de datos SQLite
  • SQLite3::openBlob — Opens a stream resource to read a BLOB
  • SQLite3::prepare — Preparar una sentencia SQL para su ejecución
  • SQLite3::query — Ejecutar una consulta SQL
  • SQLite3::querySingle — Ejecutar una consulta y devolver un único resultado
  • SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do
  • SQLite3::version — Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número


Backup one database to another database

  • « SQLite3
  • SQLite3::busyTimeout »
  • PHP Manual
  • SQLite3
  • Backup one database to another database

SQLite3::backup

(PHP 7 >= 7.4.0, PHP 8)

SQLite3::backup — Backup one database to another database

Descripción

public SQLite3::backup ( SQLite3 $destination , string $sourceDatabase = "main" , string $destinationDatabase = "main" ) : bool

SQLite3::backup() copies the contents of one database into another, overwriting the contents of the destination database. It is useful either for creating backups of databases or for copying in-memory databases to or from persistent files.

Parámetros

destination

A database connection opened with SQLite3::open().

sourceDatabase

The database name is "main" for the main database, "temp" for the temporary database, or the name specified after the AS keyword in an ATTACH statement for an attached database.

destinationDatabase

Analogous to sourceDatabase but for the destination.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Backup an existing database

<?php
// $conn is a connection to an already opened sqlite3 database

$backup = new SQLite3('backup.sqlite');
$conn->backup($backup);
?>


Establecer el gestor de conexión ocupado

  • « SQLite3::backup
  • SQLite3::changes »
  • PHP Manual
  • SQLite3
  • Establecer el gestor de conexión ocupado

SQLite3::busyTimeout

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

SQLite3::busyTimeout — Establecer el gestor de conexión ocupado

Descripción

public SQLite3::busyTimeout ( int $msecs ) : bool

Establece un gestor ocupado que estará dormido hasta que la base de datos no esté bloqueada o se alcance el tiempo de espera.

Parámetros

msecs

Los milisegundos a dormir. Establecer este valor a un valor menor o igual a cero desactivará un gestor de tiempo de espera ya establecido.

Valores devueltos

Devuelve true en caso de éxito,false en case de fallo.


Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente

  • « SQLite3::busyTimeout
  • SQLite3::close »
  • PHP Manual
  • SQLite3
  • Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente

SQLite3::changes

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::changes — Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente

Descripción

public SQLite3::changes ( ) : int

Devuelve el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo integer correspondiente al número de filas de la base de datos cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::changes()

<?php
$bd = new SQLite3('mibdsqlite.db');

$consulta = $bd->exec('UPDATE counter SET views=0 WHERE page="test"');
if ($consulta) {
    echo 'Número de filas modificadas: ', $bd->changes();
}
?>


Cerrar la conexión a la base de datos

  • « SQLite3::changes
  • SQLite3::__construct »
  • PHP Manual
  • SQLite3
  • Cerrar la conexión a la base de datos

SQLite3::close

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::close — Cerrar la conexión a la base de datos

Descripción

public SQLite3::close ( ) : bool

Cierra la conexión a la base de datos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito, false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::close()

<?php
$bd = new SQLite3('mibdsqlite.db');
$bd->close();
?>


Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3

  • « SQLite3::close
  • SQLite3::createAggregate »
  • PHP Manual
  • SQLite3
  • Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3

SQLite3::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::__construct — Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3

Descripción

public SQLite3::__construct ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryption_key = null )

Instancia un objeto de la clase SQLite3 y abre una conexión a una base de datos de SQLite. Si la construcción incluye encriptación, se intentará usar la clave.

Parámetros

filename

La ruta a la base de datos de SQLite, o :memory: para usar la base de datos que está en memoria.

flags

Banderas opcionales para determinar cómo abrir la base de datos SQLite. Por omisión, el método open utiliza SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE.

  • SQLITE3_OPEN_READONLY: Abrir la base de datos para sólo lectura.

  • SQLITE3_OPEN_READWRITE: Abrir la base de datos para lectura y escritura.

  • SQLITE3_OPEN_CREATE: Crear la base de datos si no existe.

encryption_key

Una clave de encriptación opcional usada cuando se encripta o desencripta una base de datos de SQLite. Si el módulo de encriptación de SQLite no está instalado, este parámetro no tendrá efecto.

Valores devueltos

Devuelve un objeto SQLite3 en caso de éxito.

Errores/Excepciones

Lanza una Exception cuando falla.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::__construct()

<?php
$bd = new SQLite3('mibdsqlite.db');

$bd->exec('CREATE TABLE foo (bar STRING)');
$bd->exec("INSERT INTO foo (bar) VALUES ('Esto es una prueba')");

$resultado = $bd->query('SELECT bar FROM foo');
var_dump($resultado->fetchArray());
?>


Registrar una función de PHP para usarla como una función totalizadora de SQL

  • « SQLite3::__construct
  • SQLite3::createCollation »
  • PHP Manual
  • SQLite3
  • Registrar una función de PHP para usarla como una función totalizadora de SQL

SQLite3::createAggregate

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::createAggregate — Registrar una función de PHP para usarla como una función totalizadora de SQL

Descripción

public SQLite3::createAggregate ( string $name , mixed $step_callback , mixed $final_callback , int $argument_count = -1 ) : bool

Registra una función de PHP o una definida por el usuario para usarla como una función totalizadora de SQL para utilizarla dentro de sentencias SQL.

Parámetros

name

El nombre de la función totalizadora de SQL a crear o redefinir.

step_callback

El nombre de una función de PHP o una definida por el usuario para aplicarla como una llamada de retorno para cada elemento del total.

final_callback

El nombre de una función de PHP o una definida por el usuario para aplicarla como una llamada de retorno al final de la información del total.

argument_count

El número de argumentos que toma la función de SQL. Si este parámetro es negativo, la función de SQL puede tomar cualquier número de argumentos.

Valores devueltos

Devuelve true si la creación de la función totalizadora tuvo éxito, false en case de error.


Registra una función PHP para ser utilizada como una función SQL de ordenación específica

  • « SQLite3::createAggregate
  • SQLite3::createFunction »
  • PHP Manual
  • SQLite3
  • Registra una función PHP para ser utilizada como una función SQL de ordenación específica

SQLite3::createCollation

(PHP 5 >= 5.3.11, PHP 7, PHP 8)

SQLite3::createCollation — Registra una función PHP para ser utilizada como una función SQL de ordenación específica

Descripción

public SQLite3::createCollation ( string $name , callable $callback ) : bool

Registra una función PHP o función definida por el usuario para ser utilizada como una función de ordenación específica dentro de sentencias SQL.

Parámetros

name

Nombre de la función SQL de ordenación específica a ser creada o redefinida

callback

El nombre de una función PHP o función definida por el usuario que se aplicará como retorno de llamada, definiendo el comportamiento de la ordenación. Debe aceptar dos strings y devolver el resultado del mismo modo que lo hace strcmp() , p.e. debe devolver -1, 1, o 0, si el primer string es menor que el segundo, es mayor que el segundo, o es igual al segundo respectivamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 SQLite3::createCollation()

Registra la función PHP strnatcmp() como una secuencia de ordenación en la base de datos SQLite3.

<?php

$db = new SQLite3(":memory:");
$db->exec("CREATE TABLE test (col1 string)");
$db->exec("INSERT INTO test VALUES ('a1')");
$db->exec("INSERT INTO test VALUES ('a10')");
$db->exec("INSERT INTO test VALUES ('a2')");

$db->createCollation('NATURAL_CMP', 'strnatcmp');

$defaultSort = $db->query("SELECT col1 FROM test ORDER BY col1");
$naturalSort = $db->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP");

echo "por defecto:\n";
while ($row = $defaultSort->fetchArray()){
    echo $row['col1'], "\n";
}

echo "\nnatural:\n";
while ($row = $naturalSort->fetchArray()){
    echo $row['col1'], "\n";
}

$db->close();

?>

El resultado del ejemplo sería:

default:
a1
a10
a2

natural:
a1
a2
a10

Ver también

  • La documentación SQLite: » http://sqlite.org/datatype3.html#collation


Registrar una función de PHP para usarla como una función escalar de SQL

  • « SQLite3::createCollation
  • SQLite3::enableExceptions »
  • PHP Manual
  • SQLite3
  • Registrar una función de PHP para usarla como una función escalar de SQL

SQLite3::createFunction

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::createFunction — Registrar una función de PHP para usarla como una función escalar de SQL

Descripción

public SQLite3::createFunction ( string $name , mixed $callback , int $argument_count = -1 ) : bool

Registra un función de PHP o una definida por el usuario para usarla como una función escalar de SQL para utilizarla dentro de sentencias SQL.

Parámetros

name

El nombre de la función de SQL a crear o redefinir.

callback

El nombre de una función de PHP o una definida por el usuario para aplicarla como una llamada de retorno, definiendo el comportamiento de la función de SQL.

argument_count

El número de argumentos que toma la función de SQL. Si este parámetro es negativo, la función de SQL puede tomar cualquier número de argumentos.

Valores devueltos

Devuelve true si la creación de la función tuvo éxito, false en case de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::createFunction()

<?php
function mi_fdu_md5($cadena) {
    return md5($cadena);
}

$bd = new SQLite3('mibdsqlite.db');
$bd->createFunction('mi_fdu_md5', 'mi_fdu_md5');

var_dump($db->querySingle('SELECT mi_fdu_md5("prueba")'));
?>

El resultado del ejemplo sería algo similar a:

string(32) "c893bad68927b457dbed39460e6afd62"


Enable throwing exceptions

  • « SQLite3::createFunction
  • SQLite3::escapeString »
  • PHP Manual
  • SQLite3
  • Enable throwing exceptions

SQLite3::enableExceptions

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::enableExceptions — Enable throwing exceptions

Descripción

public SQLite3::enableExceptions ( bool $enable = false ) : bool

Controls whether the SQLite3 instance will throw exceptions or warnings on error.

Parámetros

enable

When true, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will throw exceptions on error.

When false, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will raise warnings on error.

For either mode, the error code and message, if any, will be available via SQLite3::lastErrorCode() and SQLite3::lastErrorMsg() respectively.

Valores devueltos

Returns the old value; true if exceptions were enabled, false otherwise.

Ejemplos

Ejemplo #1 SQLite3::enableExceptions() example

<?php
$sqlite = new SQLite3(':memory:');
try {
    $sqlite->exec('create table foo');
    $sqlite->enableExceptions(true);
    $sqlite->exec('create table bar');
} catch (Exception $e) {
    echo 'Caught exception: ' . $e->getMessage();
}
?>

El resultado del ejemplo sería algo similar a:

Warning: SQLite3::exec(): near "foo": syntax error in example.php on line 4
Caught exception: near "bar": syntax error


Devolver una cadena que ha sido debidamente escapada

  • « SQLite3::enableExceptions
  • SQLite3::exec »
  • PHP Manual
  • SQLite3
  • Devolver una cadena que ha sido debidamente escapada

SQLite3::escapeString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::escapeString — Devolver una cadena que ha sido debidamente escapada

Descripción

public static SQLite3::escapeString ( string $value ) : string

Devuelve una cadena que ha sido debidamente escapada para una inclusión segura en una sentencia SQL.

Advertencia

Esta función no es (todavía) segura binariamente

Para manejar adecuadamente campos BLOB que puedan contener caracteres NUL, use SQLite3Stmt::bindParam() en su lugar.

Parámetros

value

La cadena a ser escapada.

Valores devueltos

Devuelve una cadena debidamente escapada que puede ser usada de forma segura en una sentencia SQL.

Notas

Advertencia

addslashes() NO debería usarse para entrecomillar las cadenas de consulta de SQLite; conducirá a resultados extraños al recuperar la información.


Ejecutar una consulta que no devuelve resultados en una base de datos dada

  • « SQLite3::escapeString
  • SQLite3::lastErrorCode »
  • PHP Manual
  • SQLite3
  • Ejecutar una consulta que no devuelve resultados en una base de datos dada

SQLite3::exec

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::exec — Ejecutar una consulta que no devuelve resultados en una base de datos dada

Descripción

public SQLite3::exec ( string $query ) : bool

Ejecuta una consulta que no devuelve resultados en una base de datos dada.

Parámetros

query

La consulta SQL a ejecutar (típicamente una consulta INSERT, UPDATE, o DELETE).

Valores devueltos

Devuelve true si la consulta tuvo éxito, false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::exec()

<?php
$bd = new SQLite3('mibdsqlite.db');

$bd->exec('CREATE TABLE bar (bar STRING)');
?>


Devolver el código numérico del resultado de la petición SQLite que falló más recientemente

  • « SQLite3::exec
  • SQLite3::lastErrorMsg »
  • PHP Manual
  • SQLite3
  • Devolver el código numérico del resultado de la petición SQLite que falló más recientemente

SQLite3::lastErrorCode

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastErrorCode — Devolver el código numérico del resultado de la petición SQLite que falló más recientemente

Descripción

public SQLite3::lastErrorCode ( ) : int

Devuelve el código numérico del resultado de la petición SQLite que falló más recientemente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo integer que representa el código numérico del resultado de la petición SQLite que falló más recientemente.


Devolver texto en inglés describiendo la petición SQLite que falló más recientemente

  • « SQLite3::lastErrorCode
  • SQLite3::lastInsertRowID »
  • PHP Manual
  • SQLite3
  • Devolver texto en inglés describiendo la petición SQLite que falló más recientemente

SQLite3::lastErrorMsg

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastErrorMsg — Devolver texto en inglés describiendo la petición SQLite que falló más recientemente

Descripción

public SQLite3::lastErrorMsg ( ) : string

Devuelve texto en inglés describiendo la petición SQLite que falló más recientemente

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve texto en inglés describiendo la petición SQLite que falló más recientemente


Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos

  • « SQLite3::lastErrorMsg
  • SQLite3::loadExtension »
  • PHP Manual
  • SQLite3
  • Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos

SQLite3::lastInsertRowID

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastInsertRowID — Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos

Descripción

public SQLite3::lastInsertRowID ( ) : int

Devuelve el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos


Intentar cargar una biblioteca de extensiones de SQLite

  • « SQLite3::lastInsertRowID
  • SQLite3::open »
  • PHP Manual
  • SQLite3
  • Intentar cargar una biblioteca de extensiones de SQLite

SQLite3::loadExtension

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::loadExtension — Intentar cargar una biblioteca de extensiones de SQLite

Descripción

public SQLite3::loadExtension ( string $shared_library ) : bool

Intenta cargar una biblioteca de extensiones de SQLite.

Parámetros

shared_library

El nombre de la biblioteca a cargar. La biblioteca debe estar ubicada en el directorio especificado con la opción de configuración sqlite3.extension_dir.

Valores devueltos

Devuelve true si la extensión es cargada con éxito, false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::loadExtension()

<?php
$bd = new SQLite3('mibdsqlite.db');
$bd->loadExtension('libagg.so');
?>


Abrir una base de datos SQLite

  • « SQLite3::loadExtension
  • SQLite3::openBlob »
  • PHP Manual
  • SQLite3
  • Abrir una base de datos SQLite

SQLite3::open

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::open — Abrir una base de datos SQLite

Descripción

public SQLite3::open ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryption_key = null ) : void

Abre una Base de Datos SQLite 3. Si la construcción incluye encriptación, intentará usar la clave.

Parámetros

filename

La ruta a la base de datos de SQLite, o :memory: para usar la base de datos que está en memoria.

flags

Banderas opcionales para determinar cómo abrir la base de datos SQLite. Por omisión, el método open utiliza SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE.

  • SQLITE3_OPEN_READONLY: Abrir la base de datos para sólo lectura.

  • SQLITE3_OPEN_READWRITE: Abrir la base de datos para lectura y escritura.

  • SQLITE3_OPEN_CREATE: Crear la base de datos si no existe.

encryption_key

Una clave de encriptación opcional usada cuando se encripta o desencripta una base de datos de SQLite. Si el módulo de encriptación de SQLite no está instalado, este parámetro no tendrá efecto.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::open()

<?php
/**
 * Ejemplo sencillo para extender la clase SQLite3 y cambiar los parámetros
 * de __construct, después usar el método open para inicializar la BD.
 */
class MiBD extends SQLite3
{
    function __construct()
    {
        $this->open('mibdsqlite.db');
    }
}

$bd = new MiBD();

$bd->exec('CREATE TABLE foo (bar STRING)');
$bd->exec("INSERT INTO foo (bar) VALUES ('Esto es una prueba')");

$resultado = $bd->query('SELECT bar FROM foo');
var_dump($resultado->fetchArray());
?>


Opens a stream resource to read a BLOB

  • « SQLite3::open
  • SQLite3::prepare »
  • PHP Manual
  • SQLite3
  • Opens a stream resource to read a BLOB

SQLite3::openBlob

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::openBlob — Opens a stream resource to read a BLOB

Descripción

public SQLite3::openBlob ( string $table , string $column , int $rowid , string $database = "main" , int $flags = SQLITE3_OPEN_READONLY ) : resource|false

Opens a stream resource to read or write a BLOB, which would be selected by:

SELECT column FROM database.table WHERE rowid = rowid

Nota: It is not possible to change the size of a BLOB by writing to the stream. Instead, an UPDATE statement has to be executed, possibly using SQLite's zeroblob() function to set the desired BLOB size.

Parámetros

table

The table name.

column

The column name.

rowid

The row ID.

database

The symbolic name of the DB

flags

Either SQLITE3_OPEN_READONLY or SQLITE3_OPEN_READWRITE to open the stream for reading only, or for reading and writing, respectively.

Valores devueltos

Returns a stream resource, o false en caso de error.

Historial de cambios

Versión | Descripción
7.2.0 | The flags parameter has been added, allowing to write BLOBs; formerly only reading was supported.

Ejemplos

Ejemplo #1 SQLite3::openBlob() example

<?php
$conn = new SQLite3(':memory:');
$conn->exec('CREATE TABLE test (text text)');
$conn->exec("INSERT INTO test VALUES ('Lorem ipsum')");
$stream = $conn->openBlob('test', 'text', 1);
echo stream_get_contents($stream);
fclose($stream); // mandatory, otherwise the next line would fail
$conn->close();
?>

El resultado del ejemplo sería:

Lorem ipsum

Ejemplo #2 Incrementally writing a BLOB

<?php
$conn = new SQLite3(':memory:');
$conn->exec('CREATE TABLE test (text text)');
$conn->exec("INSERT INTO test VALUES (zeroblob(36))");
$stream = $conn->openBlob('test', 'text', 1, 'main', SQLITE3_OPEN_READWRITE);
for ($i = 0; $i < 3; $i++) {
    fwrite($stream,  "Lorem ipsum\n");
}
fclose($stream);
echo $conn->querySingle("SELECT text FROM test");
$conn->close();
?>

El resultado del ejemplo sería:

Lorem ipsum
Lorem ipsum
Lorem ipsum


Preparar una sentencia SQL para su ejecución

  • « SQLite3::openBlob
  • SQLite3::query »
  • PHP Manual
  • SQLite3
  • Preparar una sentencia SQL para su ejecución

SQLite3::prepare

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::prepare — Preparar una sentencia SQL para su ejecución

Descripción

public SQLite3::prepare ( string $query ) : SQLite3Stmt

Prepara una sentencia SQL para su ejecución y devuelve un objeto de la clase SQLite3Stmt.

Parámetros

query

La consulta SQL a preparar.

Valores devueltos

Devuelve un objeto de la clase SQLite3Stmt en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::prepare()

<?php
unlink('mibdsqlite.db');
$bd = new SQLite3('mibdsqlite.db');

$bd->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$bd->exec("INSERT INTO foo (id, bar) VALUES (1, 'Esto es una prueba')");

$sentencia = $bd->prepare('SELECT bar FROM foo WHERE id=:id');
$sentencia->bindValue(':id', 1, SQLITE3_INTEGER);

$resultado = $sentencia->execute();
var_dump($resultado->fetchArray());
?>


Ejecutar una consulta SQL

  • « SQLite3::prepare
  • SQLite3::querySingle »
  • PHP Manual
  • SQLite3
  • Ejecutar una consulta SQL

SQLite3::query

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::query — Ejecutar una consulta SQL

Descripción

public SQLite3::query ( string $query ) : SQLite3Result

Ejecuta una consulta SQL, devolviendo un objeto de la clase SQLite3Result si la consulta devuelve resultados.

Parámetros

query

La consulta SQL a ejecutar.

Valores devueltos

Devuelve un objeto de la clase SQLite3Result si la consulta devuelve resultados. Si no, devuelve true si la consulta tuvo éxito, false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::query()

<?php
$bd = new SQLite3('mibdsqlite.db');

$results = $bd->query('SELECT bar FROM foo');
while ($row = $results->fetchArray()) {
    var_dump($row);
}
?>


Ejecutar una consulta y devolver un único resultado

  • « SQLite3::query
  • SQLite3::setAuthorizer »
  • PHP Manual
  • SQLite3
  • Ejecutar una consulta y devolver un único resultado

SQLite3::querySingle

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::querySingle — Ejecutar una consulta y devolver un único resultado

Descripción

public SQLite3::querySingle ( string $query , bool $entire_row = false ) : mixed

Ejecuta una consulta y devuelve un único resultado.

Parámetros

query

La consulta SQL a ejecutar.

entire_row

Por omisión, querySingle() devuelve el valor de la primera columna devuelta por la consulta. Si entire_row es true, devuelve un array con la primera fila completa.

Valores devueltos

Devuelve el valor de la primera columna de resultados o un array con la primera fila completa (si entire_row es true).

Si la consulta es válida pero no se devuelven resultados, se devolverá null si entire_row es false, de otro modo se devolverá un array vacío.

Las consultas no válidas o defectuosas devolverán false.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::querySingle()

<?php
$bd = new SQLite3('mibdsqlite.db');

var_dump($bd->querySingle('SELECT username FROM user WHERE userid=1'));
print_r($bd->querySingle('SELECT username, email FROM user WHERE userid=1', true));
?>

El resultado del ejemplo sería algo similar a:

string(5) "Scott"
Array
(
    [username] => Scott
    [email] => scott@example.com
)


Configures a callback to be used as an authorizer to limit what a statement can do

  • « SQLite3::querySingle
  • SQLite3::version »
  • PHP Manual
  • SQLite3
  • Configures a callback to be used as an authorizer to limit what a statement can do

SQLite3::setAuthorizer

(PHP 8)

SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do

Descripción

public SQLite3::setAuthorizer ( callable|null $callback ) : bool

Sets a callback that will be called by SQLite every time an action is performed (reading, deleting, updating, etc.). This is used when preparing a SQL statement from an untrusted source to ensure that the SQL statements do not try to access data they are not allowed to see, or that they do not try to execute malicious statements that damage the database. For example, an application may allow a user to enter arbitrary SQL queries for evaluation by a database. But the application does not want the user to be able to make arbitrary changes to the database. An authorizer could then be put in place while the user-entered SQL is being prepared that disallows everything except SELECT statements.

The authorizer callback may be called multiple times for each statement prepared by SQLite. A SELECT or UPDATE query will call the authorizer for every column that would be read or updated.

The authorizer is called with up to five parameters. The first parameter is always given, and is an int (action code) matching a constant from SQLite3. The other parameters are only passed for some actions. The following table describes the second and third parameters according to the action:

List of action codes and parameters
Action | Second parameter | Third parameter
SQLite3::CREATE_INDEX | Index Name | Table Name
SQLite3::CREATE_TABLE | Table Name | null
SQLite3::CREATE_TEMP_INDEX | Index Name | Table Name
SQLite3::CREATE_TEMP_TABLE | Table Name | null
SQLite3::CREATE_TEMP_TRIGGER | Trigger Name | Table Name
SQLite3::CREATE_TEMP_VIEW | View Name | null
SQLite3::CREATE_TRIGGER | Trigger Name | Table Name
SQLite3::CREATE_VIEW | View Name | null
SQLite3::DELETE | Table Name | null
SQLite3::DROP_INDEX | Index Name | Table Name
SQLite3::DROP_TABLE | Table Name | null
SQLite3::DROP_TEMP_INDEX | Index Name | Table Name
SQLite3::DROP_TEMP_TABLE | Table Name | null
SQLite3::DROP_TEMP_TRIGGER | Trigger Name | Table Name
SQLite3::DROP_TEMP_VIEW | View Name | null
SQLite3::DROP_TRIGGER | Trigger Name | Table Name
SQLite3::DROP_VIEW | View Name | null
SQLite3::INSERT | Table Name | null
SQLite3::PRAGMA | Pragma Name | First argument passed to the pragma, or null
SQLite3::READ | Table Name | Column Name
SQLite3::SELECT | null | null
SQLite3::TRANSACTION | Operation | null
SQLite3::UPDATE | Table Name | Column Name
SQLite3::ATTACH | Filename | null
SQLite3::DETACH | Database Name | null
SQLite3::ALTER_TABLE | Database Name | Table Name
SQLite3::REINDEX | Index Name | null
SQLite3::ANALYZE | Table Name | null
SQLite3::CREATE_VTABLE | Table Name | Module Name
SQLite3::DROP_VTABLE | Table Name | Module Name
SQLite3::FUNCTION | null | Function Name
SQLite3::SAVEPOINT | Operation | Savepoint Name
SQLite3::RECURSIVE | null | null

The 5th parameter will be the name of the database ("main", "temp", etc.) if applicable.

The 6th parameter to the authorizer callback is the name of the inner-most trigger or view that is responsible for the access attempt or null if this access attempt is directly from top-level SQL code.

When the callback returns SQLite3::OK, that means the operation requested is accepted. When the callback returns SQLite3::DENY, the call that triggered the authorizer will fail with an error message explaining that access is denied.

If the action code is SQLite3::READ and the callback returns SQLite3::IGNORE then the prepared statement statement is constructed to substitute a null value in place of the table column that would have been read if SQLite3::OK had been returned. The SQLite3::IGNORE return can be used to deny an untrusted user access to individual columns of a table.

When a table is referenced by a SELECT but no column values are extracted from that table (for example in a query like "SELECT count(*) FROM table") then the SQLite3::READ authorizer callback is invoked once for that table with a column name that is an empty string.

If the action code is SQLite3::DELETE and the callback returns SQLite3::IGNORE then the DELETE operation proceeds but the truncate optimization is disabled and all rows are deleted individually.

Only a single authorizer can be in place on a database connection at a time. Each call to SQLite3::setAuthorizer() overrides the previous call. Disable the authorizer by installing a null callback. The authorizer is disabled by default.

The authorizer callback must not do anything that will modify the database connection that invoked the authorizer callback.

Note that the authorizer is only called when a statement is prepared, not when it's executed.

More details can be found in the » SQLite3 documentation.

Parámetros

callback

The callable to be called.

If null is passed instead, this will disable the current authorizer callback.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method doesn't throw any error, but if an authorizer is enabled and returns an invalid value, the statement preparation will throw an error (or exception, depending on the use of the SQLite3::enableExceptions() method).

Ejemplos

Ejemplo #1 SQLite3::setAuthorizer() example

This only allows access to reading, and only some columns of the users table will be returned. Other columns will be replaced with null.

<?php
$db = new SQLite3('data.sqlite');
$db->exec('CREATE TABLE users (id, name, password);');
$db->exec('INSERT INTO users VALUES (1, \'Pauline\', \'Snails4eva\');');

$allowed_columns = ['id', 'name'];

$db->setAuthorizer(function (int $action, ...$args) use ($allowed_columns) {
    if ($action === SQLite3::READ) {
        list($table, $column) = $args;

        if ($table === 'users' && in_array($column, $allowed_columns) {
            return SQLite3::OK;
        }

        return SQLite3::IGNORE;
    }

    return SQLite3::DENY;
});

print_r($db->querySingle('SELECT * FROM users WHERE id = 1;'));

El resultado del ejemplo sería:

Array
(
    [id] => 1
    [name] => Pauline
    [password] =>
)


Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número

  • « SQLite3::setAuthorizer
  • SQLite3Stmt »
  • PHP Manual
  • SQLite3
  • Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número

SQLite3::version

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::version — Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número

Descripción

public static SQLite3::version ( ) : array

Devuelve la versión de la biblioteca SQLite3 como una constante de cadena y como un número.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array asociativo con las claves "versionString" y "versionNumber".

Ejemplos

Ejemplo #1 Ejemplo de SQLite3::version()

<?php
print_r(SQLite3::version());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [versionString] => 3.5.9
    [versionNumber] => 3005009
)


La clase SQLite3Stmt

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

La clase que maneja declaraciones preparadas para la extensión SQLite.

Sinopsis de la Clase

SQLite3Stmt {
/* Métodos */
public bindParam ( mixed $sql_param , mixed &$param , int $type = ? ) : bool
public bindValue ( mixed $sql_param , mixed $value , int $type = ? ) : bool
public clear ( ) : bool
public close ( ) : bool
public execute ( ) : SQLite3Result
public getSQL ( bool $expand = false ) : string|false
public paramCount ( ) : int
public readOnly ( ) : bool
public reset ( ) : bool
}

Tabla de contenidos

  • SQLite3Stmt::bindParam — Vincular un parámetro a una variable de sentencia
  • SQLite3Stmt::bindValue — Vincular el valor de un parámetro a una variable de sentencia
  • SQLite3Stmt::clear — Limpiar todos los parámetros vinculados actuales
  • SQLite3Stmt::close — Cerrar una sentencia preparada
  • SQLite3Stmt::execute — Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados
  • SQLite3Stmt::getSQL — Get the SQL of the statement
  • SQLite3Stmt::paramCount — Devolver el número de parámetros dentro de la sentencia preparada
  • SQLite3Stmt::readOnly — Returns whether a statement is definitely read only
  • SQLite3Stmt::reset — Reiniciar la sentencia preparada


Vincular un parámetro a una variable de sentencia

  • « SQLite3Stmt
  • SQLite3Stmt::bindValue »
  • PHP Manual
  • SQLite3Stmt
  • Vincular un parámetro a una variable de sentencia

SQLite3Stmt::bindParam

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::bindParam — Vincular un parámetro a una variable de sentencia

Descripción

public SQLite3Stmt::bindParam ( mixed $sql_param , mixed &$param , int $type = ? ) : bool

Vincula un parámetro a una variable de sentencia.

Parámetros

sql_param

Un string o un int que identifica la variable de sentencia que debe ser vinculada al parámetro.

param

El parámetro a vincular a la variable de sentencia.

type

El tipo de datos del parámetro a vincular.

  • SQLITE3_INTEGER: El valor es un entero con signo, almacenado en 1, 2, 3, 4, 6, u 8 bytes, dependiendo de la magnitud del valor.

  • SQLITE3_FLOAT: El valor es de tipo coma flotante, almacenado como un número de coma flotante IEEE de 8 bytes.

  • SQLITE3_TEXT: El valor es una cadena de texto, almacenado usando la codificación de la base de datos (UTF-8, UTF-16BE o UTF-16-LE).

  • SQLITE3_BLOB: El valor es de tipo blob, almacenado exactamente a como fue insertado.

  • SQLITE3_NULL: El valor es NULL.

Valores devueltos

Devuelve true si el parámetro es vinculado a la variable de sentencia, false en caso de fallo.


Vincular el valor de un parámetro a una variable de sentencia

  • « SQLite3Stmt::bindParam
  • SQLite3Stmt::clear »
  • PHP Manual
  • SQLite3Stmt
  • Vincular el valor de un parámetro a una variable de sentencia

SQLite3Stmt::bindValue

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::bindValue — Vincular el valor de un parámetro a una variable de sentencia

Descripción

public SQLite3Stmt::bindValue ( mixed $sql_param , mixed $value , int $type = ? ) : bool

Vincula el valor de un parámetro a una variable de sentencia.

Parámetros

sql_param

Un string o un int que identifica la variable de sentencia que debe ser vinculada al parámetro.

value

El valor a vincular a la variable de sentencia.

type

El tipo de dato de la variable a vincular.

  • SQLITE3_INTEGER: El valor es un entero con signo, almacenado en 1, 2, 3, 4, 6, u 8 bytes, dependiendo de la magnitud del valor.

  • SQLITE3_FLOAT: El valor es de tipo coma flotante, almacenado como un número de coma flotante IEEE de 8 bytes.

  • SQLITE3_TEXT: El valor es una cadena de texto, almacenado usando la codificación de la base de datos (UTF-8, UTF-16BE o UTF-16-LE).

  • SQLITE3_BLOB: El valor es de tipo blob, almacenado exactamente a como fue insertado.

  • SQLITE3_NULL: El valor es NULL.

Valores devueltos

Devuelve true si el valor es vinculado a la variable de sentencia, false en case de error.

Ejemplos

Ejemplo #1 Ejemplo de SQLite3Stmt::bindValue()

<?php
unlink('mibdsqlite.db');
$bd = new SQLite3('mibdsqlite.db');

$bd->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$bd->exec("INSERT INTO foo (id, bar) VALUES (1, 'Esto es una prueba')");

$sentencia = $bd->prepare('SELECT bar FROM foo WHERE id=:id');
$sentencia->bindValue(':id', 1, SQLITE3_INTEGER);

$resultado = $sentencia->execute();
var_dump($resultado->fetchArray());
?>


Limpiar todos los parámetros vinculados actuales

  • « SQLite3Stmt::bindValue
  • SQLite3Stmt::close »
  • PHP Manual
  • SQLite3Stmt
  • Limpiar todos los parámetros vinculados actuales

SQLite3Stmt::clear

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::clear — Limpiar todos los parámetros vinculados actuales

Descripción

public SQLite3Stmt::clear ( ) : bool

Limpia todos los parámetros vinculados actuales.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la limpiza de parámetros vinculados tuvo éxito, false en caso de fallo.


Cerrar una sentencia preparada

  • « SQLite3Stmt::clear
  • SQLite3Stmt::execute »
  • PHP Manual
  • SQLite3Stmt
  • Cerrar una sentencia preparada

SQLite3Stmt::close

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::close — Cerrar una sentencia preparada

Descripción

public SQLite3Stmt::close ( ) : bool

Cierra una sentencia preparada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true


Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados

  • « SQLite3Stmt::close
  • SQLite3Stmt::getSQL »
  • PHP Manual
  • SQLite3Stmt
  • Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados

SQLite3Stmt::execute

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::execute — Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados

Descripción

public SQLite3Stmt::execute ( ) : SQLite3Result

Ejecuta una sentencia preparada y devuelve un objeto de conjunto de resultados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto de la clase SQLite3Result si la ejecución de la sentencia preparada tuvo éxito, false en caso de fallo.


Get the SQL of the statement

  • « SQLite3Stmt::execute
  • SQLite3Stmt::paramCount »
  • PHP Manual
  • SQLite3Stmt
  • Get the SQL of the statement

SQLite3Stmt::getSQL

(PHP 7 >= 7.4.0, PHP 8)

SQLite3Stmt::getSQL — Get the SQL of the statement

Descripción

public SQLite3Stmt::getSQL ( bool $expand = false ) : string|false

Retrieves the SQL of the prepared statement. If expand is false, the unmodified SQL is retrieved. If expand is true, all query parameters are replaced with their bound values, or with an SQL NULL, if not already bound.

Parámetros

expand

Whether to retrieve the expanded SQL. Passing true is only supported as of libsqlite 3.14.

Valores devueltos

Returns the SQL of the prepared statement, o false en caso de error.

Errores/Excepciones

If expand is true, but the libsqlite version is less than 3.14, an error of level E_WARNING or an Exception is issued, according to SQLite3::enableExceptions().

Ejemplos

Ejemplo #1 Inspecting the expanded SQL

<?php
$db = new SQLite3(':memory:');
$stmt = $db->prepare("SELECT :a, ?, :c");
$stmt->bindValue(':a', 'foo');
$answer = 42;
$stmt->bindParam(2, $answer);
var_dump($stmt->getSQL(true));
?>

El resultado del ejemplo sería algo similar a:

string(24) "SELECT 'foo', '42', NULL"


Devolver el número de parámetros dentro de la sentencia preparada

  • « SQLite3Stmt::getSQL
  • SQLite3Stmt::readOnly »
  • PHP Manual
  • SQLite3Stmt
  • Devolver el número de parámetros dentro de la sentencia preparada

SQLite3Stmt::paramCount

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::paramCount — Devolver el número de parámetros dentro de la sentencia preparada

Descripción

public SQLite3Stmt::paramCount ( ) : int

Devuelve el número de parámetros dentro de la sentencia preparada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de parámetros dentro de la sentencia preparada.


Returns whether a statement is definitely read only

  • « SQLite3Stmt::paramCount
  • SQLite3Stmt::reset »
  • PHP Manual
  • SQLite3Stmt
  • Returns whether a statement is definitely read only

SQLite3Stmt::readOnly

(PHP 5 >= 5.3.6, PHP 7, PHP 8)

SQLite3Stmt::readOnly — Returns whether a statement is definitely read only

Descripción

public SQLite3Stmt::readOnly ( ) : bool

Returns whether a statement is definitely read only. A statement is considered read only, if it makes no direct changes to the content of the database file. Note that user defined SQL functions might change the database indirectly as a side effect.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if a statement is definitely read only, false otherwise.


Reiniciar la sentencia preparada

  • « SQLite3Stmt::readOnly
  • SQLite3Result »
  • PHP Manual
  • SQLite3Stmt
  • Reiniciar la sentencia preparada

SQLite3Stmt::reset

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::reset — Reiniciar la sentencia preparada

Descripción

public SQLite3Stmt::reset ( ) : bool

Reinica la sentencia preparada al estado previo a su ejecución. Todos los vínculos permanecen intactos después del reinicio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la sentencia es reiniciada con éxito, false en caso de error.


La clase SQLite3Result

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

La clase que controla los resultados establecidos para la extensión SQLite 3.

Sinopsis de la Clase

SQLite3Result {
/* Métodos */
public columnName ( int $column_number ) : string
public columnType ( int $column_number ) : int
public fetchArray ( int $mode = SQLITE3_BOTH ) : array
public finalize ( ) : bool
public numColumns ( ) : int
public reset ( ) : bool
}

Tabla de contenidos

  • SQLite3Result::columnName — Devolver el nombre de la columna n-ésima
  • SQLite3Result::columnType — Devolver el tipo de la columna n-ésima
  • SQLite3Result::fetchArray — Obtener una fila de resultados en forma de un array asociativo o indexado o ambos
  • SQLite3Result::finalize — Cerrar el conjunto de resultados
  • SQLite3Result::numColumns — Devolver el número de columnas del conjunto de resultados
  • SQLite3Result::reset — Reiniciar el conjunto de resultados a la primera fila


Devolver el nombre de la columna n-ésima

  • « SQLite3Result
  • SQLite3Result::columnType »
  • PHP Manual
  • SQLite3Result
  • Devolver el nombre de la columna n-ésima

SQLite3Result::columnName

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::columnName — Devolver el nombre de la columna n-ésima

Descripción

public SQLite3Result::columnName ( int $column_number ) : string

Devuelve el nombre de la columna especificada por el parámetro column_number.

Parámetros

column_number

El índice numérico basado en cero de la columna.

Valores devueltos

Devuelve un valor de tipo string son el nombre de la columna identificada por column_number.


Devolver el tipo de la columna n-ésima

  • « SQLite3Result::columnName
  • SQLite3Result::fetchArray »
  • PHP Manual
  • SQLite3Result
  • Devolver el tipo de la columna n-ésima

SQLite3Result::columnType

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::columnType — Devolver el tipo de la columna n-ésima

Descripción

public SQLite3Result::columnType ( int $column_number ) : int

Devuelve el tipo de la columna identificada por column_number.

Parámetros

column_number

El índice numérico basado en cero de la columna.

Valores devueltos

Devuelve el índice del tipo de información de la columna identificada por column_number (uno de los siguientes: SQLITE3_INTEGER, SQLITE3_FLOAT, SQLITE3_TEXT, SQLITE3_BLOB, o SQLITE3_NULL).


Obtener una fila de resultados en forma de un array asociativo o indexado o ambos

  • « SQLite3Result::columnType
  • SQLite3Result::finalize »
  • PHP Manual
  • SQLite3Result
  • Obtener una fila de resultados en forma de un array asociativo o indexado o ambos

SQLite3Result::fetchArray

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::fetchArray — Obtener una fila de resultados en forma de un array asociativo o indexado o ambos

Descripción

public SQLite3Result::fetchArray ( int $mode = SQLITE3_BOTH ) : array

Obtiene una fila de resultados en forma de un array asociativo o indexado o ambos. Por omisión, obtiene ambas formas.

Parámetros

mode

Controla cómo será devuelta al llamador la siguiente fila. Este valor debe ser uno de los siguientes: SQLITE3_ASSOC, SQLITE3_NUM, o SQLITE3_BOTH.

  • SQLITE3_ASSOC: devuelve un array indexado por el nombre de columna como devuelto en el conjunto de resultados correspondiente

  • SQLITE3_NUM: devuelve un array indexado por el número de columna como devuelto en el conjunto de resultados correspondiente, empezando por la columna 0

  • SQLITE3_BOTH: devuelve un array indexado tanto por el nombre como por el número de columna como devuelto en el conjunto de resultados correspondiente, empezando por la columna 0

Valores devueltos

Devuelve una fila de resultados en forma de un array asociativo o indexado o ambos. De forma alternativa devolverá false si no existen más filas.


Cerrar el conjunto de resultados

  • « SQLite3Result::fetchArray
  • SQLite3Result::numColumns »
  • PHP Manual
  • SQLite3Result
  • Cerrar el conjunto de resultados

SQLite3Result::finalize

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::finalize — Cerrar el conjunto de resultados

Descripción

public SQLite3Result::finalize ( ) : bool

Cierra el conjunto de resultados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true.


Devolver el número de columnas del conjunto de resultados

  • « SQLite3Result::finalize
  • SQLite3Result::reset »
  • PHP Manual
  • SQLite3Result
  • Devolver el número de columnas del conjunto de resultados

SQLite3Result::numColumns

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::numColumns — Devolver el número de columnas del conjunto de resultados

Descripción

public SQLite3Result::numColumns ( ) : int

Devuelve el número de columnas del conjunto de resultados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de columnas del conjunto de resultados.


Reiniciar el conjunto de resultados a la primera fila

  • « SQLite3Result::numColumns
  • SQLSRV »
  • PHP Manual
  • SQLite3Result
  • Reiniciar el conjunto de resultados a la primera fila

SQLite3Result::reset

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::reset — Reiniciar el conjunto de resultados a la primera fila

Descripción

public SQLite3Result::reset ( ) : bool

Reinicia el conjunto de resultados a la primera fila.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el conjunto de resultados es reiniciado con éxito a la primera fila, false en caso de error.


Driver de Microsoft SQL Server para PHP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • SQLSRV Funciones
    • sqlsrv_begin_transaction — Inicia una transacción de base de datos
    • sqlsrv_cancel — Cancela una sentencia de base de datos
    • sqlsrv_client_info — Devuelve información sobre el cliente y la conexión especificada
    • sqlsrv_close — Cierra una conexión abierta y libera los recursos asociados a la conexión
    • sqlsrv_commit — Consolida una transacción que se inició con sqlsrv_begin_transaction
    • sqlsrv_configure — Cambia la configuración de los drivers del gestionador de errores y de log
    • sqlsrv_connect — Abre una conexión a una base de datos Microsoft SQL Server
    • sqlsrv_errors — Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada
    • sqlsrv_execute — Ejecuta una sentencia preparada con sqlsrv_prepare
    • sqlsrv_fetch_array — Devuelve una fila como un array
    • sqlsrv_fetch_object — Devuelve la siguiente fila de datos de un conjunto resultado como un objeto
    • sqlsrv_fetch — Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
    • sqlsrv_field_metadata — Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query
    • sqlsrv_free_stmt — Frees all resources for the specified statement
    • sqlsrv_get_config — Returns the value of the specified configuration setting
    • sqlsrv_get_field — Gets field data from the currently selected row
    • sqlsrv_has_rows — Indicates whether the specified statement has rows
    • sqlsrv_next_result — Makes the next result of the specified statement active
    • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows — Retrieves the number of rows in a result set
    • sqlsrv_prepare — Prepares a query for execution
    • sqlsrv_query — Prepares and executes a query
    • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data — Sends data from parameter streams to the server
    • sqlsrv_server_info — Returns information about the server


Introducción

La extensión SQLSRV permite acceder a bases de datos de Microsoft SQL Server y SQL Azure cuando se ejecuta PHP sobre Windows. La versión 3.0 del controlador soporta SQL Server, empezando con SQL Server 2005, incluyendo SQL Server 2012 y SQL Server 2012 LocalDB. (Para más información sobre LocalDB, véase » Controlador de PHP para soporte de SQL Server para LocalDB y » SQL Server 2012 Express LocalDB.)

La extensión SQLSRV está soportada por Microsoft y está disponible para descargala aquí: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx. SQL Server 2012 LocalDB puede descargarse aquí: » http://go.microsoft.com/fwlink/?LinkID=237665.


Requerimientos

La extensión puede ser utilizada en los siguientes sistemas operativos:

  • Windows Vista Service Pack 2 o posterior
  • Windows Server 2008 Service Pack 2 o posterior
  • Windows Server 2008 R2
  • Windows 7

La extensión SQLSRV requiere que el Cliente Nativo de Microsoft SQL Server 2012 esté instalado en el mismo computador en que está corriendo PHP. Si el Microsoft SQL Server 2012 no está ya instalado, haga click en el enlace apropiado de abajo para descargarlo:

  • » Descargar el paquete x86
  • » Descargar el paquete x64

La descarga de SQLSRV viene con 8 ficheros controladores, cuatro de ellos son para el soporte de PDO. Si se está ejecutando PHP (PHP 5.3) no seguro a nivel de hilos se ha de utilizar el fichero php_sqlsrv_53_nts.dll. (Se debería usar una versión no segura a nivel de hilos si se utiliza IIS como servidor web). Si se está ejecutando PHP seguro a nivel de hilos se ha de utilizar el fichero php_sqlsrv_53_ts.dll De forma similar, para PHP 5.4, se ha de usar php_sqlsrv_54_nts.dll o php_sqlsrv_54_ts.dll, dependiendo de si la instanlación de PHP no es segura a nivel de hilos o sí lo es, respectivamente.

La versión más reciente del controlador se puede descargar aquí: » Descarga de SQLSRV 4.0. Si se necesita soporte para PHP 5.2 y/o PHP compilado con VC6, se ha de usar la versión 2.0 del controlador: » Descarga de SQLSRV 2.0.

Para más información sobre los requerimientos de SQLSRV, véase » Requerimientos del Sistema para SQLSRV.


Instalación

La extensión SQLSRV se activa añadiendo el fichero DLL apropiado al directorio de extensiones de PHP y la entrada correspondiente al fichero php.ini. La descarga de SQLSRV viene con 8 ficheros controladores, cuatro de ellos son para el soporte de PDO. Si se está ejecutando PHP (PHP 5.3) no seguro a nivel de hilos se ha de utilizar el fichero php_sqlsrv_53_nts.dll. (Se debería usar una versión no segura a nivel de hilos si se utiliza IIS como servidor web). Si se está ejecutando PHP seguro a nivel de hilos se ha de utilizar el fichero php_sqlsrv_53_ts.dll. De forma similar, para PHP 5.4, se ha de usar php_sqlsrv_54_nts.dll o php_sqlsrv_54_ts.dll, dependiendo de si la instalación de PHP no es segura a nivel de hilos o sí lo es, respectivamente.

La versión más reciente del controlador se puede descargar aquí: » Descarga de SQLSRV 4.0. Si se necesita soporte para PHP 5.2 y/o PHP compilado con VC6, se ha de usar la versión 2.0 del controlador: » Descarga de SQLSRV 2.0.

Para más información sobre los requerimientos de SQLSRV, ver » Requerimientos del Sistema para SQLSRV.

La extensión SQLSRV solamente es compatible con PHP corriendo sobre Windows. Desde la versión 4.0 la extensión SQLSRV solo es compatible con PHP 7.0 corriendo sobre Linux o Windows.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

La siguiente tabla lista las opciones de configuración disponibles en la extensión SQLSRV. Para más información, ver » Manejando advertencias y errores de SQLSRV.

SQLSRV Opciones de configuración
Nombre | Por defecto | Cambiable | Cambios
sqlsrv.WarningsReturnAsErrors | 1 (true) | PHP_INI_ALL | Disponible desde SQLSRV 1.0
sqlsrv.LogSubsystems | 0 | PHP_INI_ALL | Disponible desde SQLSRV 1.0
sqlsrv.LogSeverity | 1 | PHP_INI_ALL | Disponible desde SQLSRV 1.0


Tipos de recursos

Recurso de conexión

Un recurso de conexión devuelto por sqlsrv_connect().

Recurso de sentencia

Un recurso de sentencia devuelto por sqlsrv_query() o por sqlsrv_prepare().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SQLSRV_FETCH_ASSOC (integer)
Obliga a sqlsrv_fetch_array() a que devuelva un array asociativo cuando se pasa como un parámetro.
SQLSRV_FETCH_NUMERIC (integer)
Obliga a sqlsrv_fetch_array() a que devuelva un array con claves numéricas cuando se pasa como un parámetro.
SQLSRV_FETCH_BOTH (integer)
Obliga a sqlsrv_fetch_array() a que devuelva un array con ambas claves asociativas y numéricas cuando se pasa como un parámetro (el comportamiento por defecto).
SQLSRV_ERR_ALL (integer)
Obliga a sqlsrv_errors() a que devuelva tanto errores como advertencias cuando se pasa como un parámetro (el comportamiento por defecto).
SQLSRV_ERR_ERRORS (integer)
Obliga a sqlsrv_errors() a que devuleva sólo errores (no advernecias) cuando se pasa como un parámetro.
SQLSRV_ERR_WARNINGS (integer)
Obliga a sqlsrv_errors() a que devuleva sólo advertencias (no errores) cuando se pasa como un parámetro.
SQLSRV_LOG_SYSTEM_ALL (integer)
Activa el registro de todos los subsistemas cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SYSTEM_CONN (integer)
Activa el registro de actividad de conexión cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SYSTEM_INIT (integer)
Activa el registro de la actividad de inicialización cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SYSTEM_OFF (integer)
Desactiva el registro de todos los subsistemas cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SYSTEM_STMT (integer)
Activa el registro de la actividad de sentencias cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SYSTEM_UTIL (integer)
Activa el registro de la actividad de errores en funciones cuando se pasa a sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_ALL (integer)
Especifica que errores, advertencias y avisos serán registrados cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SEVERITY_ERROR (integer)
Especifica que errores serán registrados cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SEVERITY_NOTICE (integer)
Especifica que avisos serán registrados cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_LOG_SEVERITY_WARNING (integer)
Especifica que advertencias serán registradas cuando se pasa a sqlsrv_configure() como un parámetro.
SQLSRV_NULLABLE_YES (integer)
Indica que una columna es anulable.
SQLSRV_NULLABLE_NO (integer)
Indica que una columna no es anulable.
SQLSRV_NULLABLE_UNKNOWN (integer)
Indica que no se conoce si una columna es anulable.
SQLSRV_PARAM_IN (integer)
Indica un parámetro de entrada cuando se pasa a sqlsrv_query() o sqlsrv_prepare().
SQLSRV_PARAM_INOUT (integer)
Indica un parámetro bidireccional cuando se pasa a sqlsrv_query() o sqlsrv_prepare().
SQLSRV_PARAM_OUT (integer)
Indica un parámetro de salida cuando se pasa a sqlsrv_query() o sqlsrv_prepare().
SQLSRV_PHPTYPE_INT (integer)
Especifica un dato de tipo integer de PHP. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_PHPTYPE_DATETIME (integer)
Especifica un dato de tipo datetime de PHP. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_PHPTYPE_FLOAT (integer)
Especifica un dato de tipo float de PHP. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_PHPTYPE_STREAM (integer)
Especifica un flujo de datos de PHP. Esta constante trabaja como una función y acepta una constante de codificación. Ver las constantes SQLSRV_ENC_*. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_PHPTYPE_STRING (integer)
Especifica un dato de tipo string de PHP. Esta constante trabaja como una función y acepta una constante de codificación. Ver las constantes SQLSRV_ENC_*. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_ENC_BINARY (integer)
Especifica que datos se devuelven como un flujo de bytes sin tratar desde el servidor sin realizar codificación o traducción. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_ENC_CHAR (integer)
Los datos son devueltos en caracteres de 8 bits según se especifica en la página de códigos de la configuración regional de Windows que esté configurada en el sistema. Cualquier caracter multi-byte o caracter que no se mapee en esta página de códigos será sustituido con un caracter de signo de interrogación (?) de un solo byte. Esta es la codificación por defecto. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
UTF-8 (integer)
Especifica que los datos se devuelven con la codificación UTF-8. Para obtener información de uso, consulte » Como: Especificar tipos de PHP.
SQLSRV_SQLTYPE_BIGINT (integer)
Describe el tipo de datos bigint de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_BINARY (integer)
Describe el tipo de datos binary de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_BIT (integer)
Describe el tipo de datos bit de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_CHAR (integer)
Describe el tipo de datos char de SQL Server. Esta constante trabaja como una función y acepta un parámetro que indica el número de caracteres. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_DATE (integer)
Describe el tipo de datos date de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_DATETIME (integer)
Describe el tipo de datos datetime de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_DATETIME2 (integer)
Describe el tipo de datos datetime2 de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_DATETIMEOFFSET (integer)
Describe el tipo de datos datetimeoffset de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_DECIMAL (integer)
Describe el tipo de datos decimal de SQL Server. Esta constante trabaja como una función y acepta dos parámetros indicando (en orden) precisión y escala. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_FLOAT (integer)
Describe el tipo de datos float de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_IMAGE (integer)
Describe el tipo de datos image de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_INT (integer)
Describe el tipo de datos int de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_MONEY (integer)
Describe el tipo de datos money de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_NCHAR (integer)
Describe el tipo de datos nchar de SQL Server. Esta constante trabaja como una función y acepta un sólo parámetro que indica la cuenta de caracteres. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_NUMERIC (integer)
Describe el tipo de datos numeric de SQL Server. Esta constante trabaja como una función y acepta dos parámetros que indican (en orden) precisión y escala. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_NVARCHAR (integer)
Describe el tipo de datos nvarchar de SQL Server. Esta constante trabaja como una función y acepta un sólo parámetro que indica la cuenta de caracteres. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_NVARCHAR('max') (integer)
Describe el tipo de datos nvarchar(MAX) de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_NTEXT (integer)
Describe el tipo de datos ntext de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_REAL (integer)
Describe el tipo de datos real de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_SMALLDATETIME (integer)
Describe el tipo de datos smalldatetime de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_SMALLINT (integer)
Describe el tipo de datos smallint de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_SMALLMONEY (integer)
Describe el tipo de datos smallmoney de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_TEXT (integer)
Describe el tipo de datos text de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_TIME (integer)
Describe el tipo de datos time de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_TIMESTAMP (integer)
Describe el tipo de datos timestamp de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_TINYINT (integer)
Describe el tipo de datos tinyint de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_UNIQUEIDENTIFIER (integer)
Describe el tipo de datos uniqueidentifier de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_UDT (integer)
Describe el tipo de datos UDT de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_VARBINARY (integer)
Describe el tipo de datos varbinary de SQL Server. Esta constante trabaja como una función y acepta un sólo parámetro que indica la cuenta de bytes. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_VARBINARY('max') (integer)
Describe el tipo de datos varbinary(MAX) de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_VARCHAR (integer)
Describe el tipo de datos varchar de SQL Server. Esta constante trabaja como una función y acepta un sólo parámetro que indica la cuenta de caracteres. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_VARCHAR('max') (integer)
Describe el tipo de datos varchar(MAX) de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_SQLTYPE_XML (integer)
Describe el tipo de datos XML de SQL Server. Para obtener información de uso, consulte » Como: Especificar tipos de SQL.
SQLSRV_TXN_READ_UNCOMMITTED (integer)
Indica un nivel de aislamiento de transacción de READ UNCOMMITTED. Este valor se utiliza para establecer el nivel de TransactionIsolation en el array $connectionOptions pasado a sqlsrv_connect().
SQLSRV_TXN_READ_COMMITTED (integer)
Indica un nivel de aislamiento de transacción de READ COMMITTED. Este valor se utiliza para establecer el nivel de TransactionIsolation en el array $connectionOptions pasado a sqlsrv_connect().
SQLSRV_TXN_REPEATABLE_READ (integer)
Indica un nivel de aislamiento de transacción de REPEATABLE READ. Este valor se utiliza para establecer el nivel de TransactionIsolation en el array $connectionOptions pasado a sqlsrv_connect().
SQLSRV_TXN_SNAPSHOT (integer)
Indica un nivel de aislamiento de transacción de SNAPSHOT. Este valor se utiliza para establecer el nivel de TransactionIsolation en el array $connectionOptions pasado a sqlsrv_connect().
SQLSRV_TXN_READ_SERIALIZABLE (integer)
Indica un nivel de aislamiento de transacción de SERIALIZABLE. Este valor se utiliza para establecer el nivel de TransactionIsolation en el array $connectionOptions pasado a sqlsrv_connect().
SQLSRV_CURSOR_FORWARD (integer)
Indica un cursor sólo hacia delante. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_CURSOR_STATIC (integer)
Indica un cursor estático. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_CURSOR_DYNAMIC (integer)
Indica un cursor dinámico. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_CURSOR_KEYSET (integer)
Indica un cursor keyset. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_CURSOR_BUFFERED (integer)
Crea una consulta de cursor del lado cliente. Permite el acceso a líneas en cualquie orden. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_NEXT (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_PRIOR (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_FIRST (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_LAST (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_ABSOLUTE (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.
SQLSRV_SCROLL_RELATIVE (integer)
Especifica cual fila seleccionar en un set de resultado. Para obtener información de uso, consulte » Especificar un tipo de cursor y Seleccionar filas.


SQLSRV Funciones

Tabla de contenidos

  • sqlsrv_begin_transaction — Inicia una transacción de base de datos
  • sqlsrv_cancel — Cancela una sentencia de base de datos
  • sqlsrv_client_info — Devuelve información sobre el cliente y la conexión especificada
  • sqlsrv_close — Cierra una conexión abierta y libera los recursos asociados a la conexión
  • sqlsrv_commit — Consolida una transacción que se inició con sqlsrv_begin_transaction
  • sqlsrv_configure — Cambia la configuración de los drivers del gestionador de errores y de log
  • sqlsrv_connect — Abre una conexión a una base de datos Microsoft SQL Server
  • sqlsrv_errors — Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada
  • sqlsrv_execute — Ejecuta una sentencia preparada con sqlsrv_prepare
  • sqlsrv_fetch_array — Devuelve una fila como un array
  • sqlsrv_fetch_object — Devuelve la siguiente fila de datos de un conjunto resultado como un objeto
  • sqlsrv_fetch — Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
  • sqlsrv_field_metadata — Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query
  • sqlsrv_free_stmt — Frees all resources for the specified statement
  • sqlsrv_get_config — Returns the value of the specified configuration setting
  • sqlsrv_get_field — Gets field data from the currently selected row
  • sqlsrv_has_rows — Indicates whether the specified statement has rows
  • sqlsrv_next_result — Makes the next result of the specified statement active
  • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
  • sqlsrv_num_rows — Retrieves the number of rows in a result set
  • sqlsrv_prepare — Prepares a query for execution
  • sqlsrv_query — Prepares and executes a query
  • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
  • sqlsrv_send_stream_data — Sends data from parameter streams to the server
  • sqlsrv_server_info — Returns information about the server


Inicia una transacción de base de datos

  • « SQLSRV Funciones
  • sqlsrv_cancel »
  • PHP Manual
  • SQLSRV Funciones
  • Inicia una transacción de base de datos

sqlsrv_begin_transaction

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_begin_transaction — Inicia una transacción de base de datos

Descripción

sqlsrv_begin_transaction ( resource $conn ) : bool

La transacción iniciada por sqlsrv_begin_transaction() incluye todas las sentencias que fueron ejecutadas después de la llamada a sqlsrv_begin_transaction() y antes de llamar a sqlsrv_rollback() o sqlsrv_commit(). Las transacciones explícitas deben empezar y ser consolidadas (commit) o revertidas utilizando estas funciones en vez de ejecutar sentencias SQL que empiecen y consoliden/reviertan transacciones. Para más información, ver » SQLSRV Transactions.

Parámetros

conn

El recurso de la conexión devuelta por una llamada a sqlsrv_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de sqlsrv_begin_transaction()

El siguiente ejemplo demuestra cómo utilizar sqlsrv_begin_transaction() junto con sqlsrv_commit() y sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Iniciar la transacción. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Inicializar los parámetros. */
$orderId = 1; $qty = 10; $productId = 100;

/* Preprar y ejecutar la primera sentencia . */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
          VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Preparar y ejecutar la segunda sentencia. */
$sql2 = "UPDATE InventoryTable
          SET Quantity = (Quantity - ?)
          WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* Si ambas sentencias finalizaran con éxito, consolidar la transacción. */
/* En caso contrario, revertirla. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaccion consolidada.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaccion revertida.<br />";
}
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • sqlsrv_commit() - Consolida una transacción que se inició con sqlsrv_begin_transaction
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction


Cancela una sentencia de base de datos

  • « sqlsrv_begin_transaction
  • sqlsrv_client_info »
  • PHP Manual
  • SQLSRV Funciones
  • Cancela una sentencia de base de datos

sqlsrv_cancel

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_cancel — Cancela una sentencia de base de datos

Descripción

sqlsrv_cancel ( resource $stmt ) : bool

Cancela una sentencia de base de datos. Cualquier resultado asociado con la sentencia que no haya sido utilizado será eliminado. Después de llamar a sqlsrv_cancel() , la sentencia especificada puede ser reejecutada si fue creada con sqlsrv_prepare(). No es necesario llamar a sqlsrv_cancel() si todos los resultados asociados se han utilizado.

Parámetros

stmt

El recurso de la sentencia que se va a cancelar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de sqlsrv_cancel()

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Sales FROM Table_1";

$stmt = sqlsrv_prepare( $conn, $sql);

if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

if( sqlsrv_execute( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

$salesTotal = 0;
$count = 0;

while( ($row = sqlsrv_fetch_array( $stmt)) && $salesTotal <=100000)
{
     $qty = $row[0];
     $price = $row[1];
     $salesTotal += ( $price * $qty);
     $count++;
}

echo "$count sales accounted for the first $$salesTotal in revenue.<br />";

// Cancela los resultados pendientes. La sentencia se puede reutilizar.
sqlsrv_cancel( $stmt);
?>

Notas

La principal diferencia entre sqlsrv_cancel() y sqlsrv_free_stmt() es que una sentencia cancelada con sqlsrv_cancel() puede ser reejecutada si fue creada con sqlsrv_prepare(). Una sentencia cancelada con sqlsrv_free_statement() no puede ser reejecutada.

Ver también

  • sqlsrv_free_stmt() - Frees all resources for the specified statement
  • sqlsrv_prepare() - Prepares a query for execution


Devuelve información sobre el cliente y la conexión especificada

  • « sqlsrv_cancel
  • sqlsrv_close »
  • PHP Manual
  • SQLSRV Funciones
  • Devuelve información sobre el cliente y la conexión especificada

sqlsrv_client_info

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_client_info — Devuelve información sobre el cliente y la conexión especificada

Descripción

sqlsrv_client_info ( resource $conn ) : array

Devuelve información sobre el cliente y la conexión especificada

Parámetros

conn

La conexión sobre la que se va a retornar información.

Valores devueltos

Devuelve un array asociativo con las claves que se describen en la tabla siguiente. Devuelve false en caso constrario.

Array devuelto por sqlsrv_client_info
Clave | Descripción
DriverDllName | SQLNCLI10.DLL
DriverODBCVer | Versión ODBC (xx.yy)
DriverVer | Versión de la DLL del cliente nativo SQL Server (10.5.xxx)
ExtensionVer | Versión de la biblioteca php_sqlsrv.dll (2.0.xxx.x)

Ejemplos

Ejemplo #1 Ejemplo de sqlsrv_client_info()

<?php
$serverName = "serverName\sqlexpress";
$connOptions = array("UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connOptions );

if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

if( $client_info = sqlsrv_client_info( $conn)) {
    foreach( $client_info as $key => $value) {
        echo $key.": ".$value."<br />";
    }
} else {
    echo "Error al recuperar la información del cliente.<br />";
}
?>

Ver también

  • sqlsrv_server_info() - Returns information about the server


Cierra una conexión abierta y libera los recursos asociados a la conexión

  • « sqlsrv_client_info
  • sqlsrv_commit »
  • PHP Manual
  • SQLSRV Funciones
  • Cierra una conexión abierta y libera los recursos asociados a la conexión

sqlsrv_close

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_close — Cierra una conexión abierta y libera los recursos asociados a la conexión

Descripción

sqlsrv_close ( resource $conn ) : bool

Cierra una conexión abierta y libera los recursos asociados a la conexión.

Parámetros

conn

La conexión que se va a cerrar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de sqlsrv_close()

<?php
$serverName = "serverName\sqlexpres";
$connOptions = array("UID"=>"username", "PWD"=>"password", "Database"=>"dbname");
$conn = sqlsrv_connect( $serverName, $connOptions );
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

//-------------------------------------
// Realizar aquí las operaciones contra la base de datos.
//-------------------------------------

// Cerrar la conexión.
sqlsrv_close( $conn );
?>

Ver también

  • sqlsrv_connect() - Abre una conexión a una base de datos Microsoft SQL Server


Consolida una transacción que se inició con sqlsrv_begin_transaction

  • « sqlsrv_close
  • sqlsrv_configure »
  • PHP Manual
  • SQLSRV Funciones
  • Consolida una transacción que se inició con sqlsrv_begin_transaction

sqlsrv_commit

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_commit — Consolida una transacción que se inició con sqlsrv_begin_transaction()

Descripción

sqlsrv_commit ( resource $conn ) : bool

Consolida una transacción que se inició con sqlsrv_begin_transaction(). La conexión retorna al modo auto-commit después de que se llame a sqlsrv_commit(). La transacción que se consolida incluye todas las sentencias que fueron ejecutadas después de la llamada a sqlsrv_begin_transaction(). Las transacciones explícitas deben iniciarse y consolidarse o revertirse utilizando estas funciones en vez de ejecutar las sentencias SQL que empiezan y consolidan/revierten transacciones. Para más información, ver » SQLSRV Transactions.

Parámetros

conn

La conexión en la que se va a consolidar la transacción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de sqlsrv_commit()

El siguiente ejemplo demuestra cómo utilizar sqlsrv_commit() junto con sqlsrv_begin_transaction() y sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Empezar la transacción. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Inicializar los parámetros. */
$orderId = 1; $qty = 10; $productId = 100;

/* Preparar y ejecutar la primera sentencia. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Preparar y ejecutar la segunda sentencia. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* Si ambas sentencias finalizan con éxito, consolidar la transacción. */
/* En caso contrario, revertir la transacción. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transacción consolidada.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transacción revertida.<br />";
}
?>

Ver también

  • sqlsrv_begin_transaction() - Inicia una transacción de base de datos
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction


Cambia la configuración de los drivers del gestionador de errores y de log

  • « sqlsrv_commit
  • sqlsrv_connect »
  • PHP Manual
  • SQLSRV Funciones
  • Cambia la configuración de los drivers del gestionador de errores y de log

sqlsrv_configure

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_configure — Cambia la configuración de los drivers del gestionador de errores y de log

Descripción

sqlsrv_configure ( string $setting , mixed $value ) : bool

Cambia la configuración de los drivers del gestionador de errores y de log.

Parámetros

setting

El nombre de la propiedad a configurar. Los valores posibles son "WarningsReturnAsErrors", "LogSubsystems", and "LogSeverity".

value

El valor de la propiedad especificada. La tabla siguiente muestra los valores posibles:

Opciones de configuración de la gestión de errores y log
Propiedades | Opciones
WarningsReturnAsErrors | 1 (true) or 0 (false)
LogSubsystems | SQLSRV_LOG_SYSTEM_ALL (-1) SQLSRV_LOG_SYSTEM_CONN (2) SQLSRV_LOG_SYSTEM_INIT (1) SQLSRV_LOG_SYSTEM_OFF (0) SQLSRV_LOG_SYSTEM_STMT (4) SQLSRV_LOG_SYSTEM_UTIL (8)
LogSeverity | SQLSRV_LOG_SEVERITY_ALL (-1) SQLSRV_LOG_SEVERITY_ERROR (1) SQLSRV_LOG_SEVERITY_NOTICE (4) SQLSRV_LOG_SEVERITY_WARNING (2)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • » Gestionador de errores SQLSRV.
  • » Actividad de log de SQLSRV.


Abre una conexión a una base de datos Microsoft SQL Server

  • « sqlsrv_configure
  • sqlsrv_errors »
  • PHP Manual
  • SQLSRV Funciones
  • Abre una conexión a una base de datos Microsoft SQL Server

sqlsrv_connect

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_connect — Abre una conexión a una base de datos Microsoft SQL Server

Descripción

sqlsrv_connect ( string $serverName , array $connectionInfo = ? ) : resource

Abre una conexión a una base de datos Microsoft SQL Server. Por defecto, la conexión se intenta utilizando la autenticación Windows. Para conectar utilizando la autenticación SQL Server, incluir "UID" y "PWD" en el array de opciones de conexión.

Parámetros

serverName

El nombre del servidor en el que se ha establecido una conexión. Para conectar a una instancia específica, poner una barra invertida después del nombre de servidor e indicar el nombre de la instancia (e.g. NombreServidor\sqlexpress).

connectionInfo

Un array asociativo que especifica las opciones de conexión al servidor. Si no se ha especificado ningún valor para el UID y PWD, la conexión se intentará utilizando la autenticación Windows. Para una lista completa de claves soportadas, ver » Opciones de Conexión SQLSRV.

Valores devueltos

Un recurso de conexión. Si no se puede abrir la conexión, se retorna el valor false .

Ejemplos

Ejemplo #1 Conectar utilizando autenticación Windows.

<?php
$serverName = "serverName\sqlexpress"; //serverName\instanceName

// Puesto que no se han especificado UID ni PWD en el array  $connectionInfo,
// La conexión se intentará utilizando la autenticación Windows.
$connectionInfo = array( "Database"=>"dbName");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Conexión establecida.<br />";
}else{
     echo "Conexión no se pudo establecer.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Ejemplo #2 Conectar especificando nombre de usuario y contraseña.

<?php
$serverName = "serverName\sqlexpress"; //serverName\instanceName
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Conexión establecida.<br />";
}else{
     echo "Conexión no se pudo establecer.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Ejemplo #3 Conectar a un puerto específico.

<?php
$serverName = "serverName\sqlexpress, 1542"; //serverName\instanceName, portNumber (por defecto es 1433)
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Conexión establecida.<br />";
}else{
     echo "Conexión no se pudo establecer.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Notas

Por defecto, la función sqlsrv_connect() utiliza la conexión mediante agrupación para mejorar el funcionamiento de la conexión. Para desconectar el funcionamiento en modo grupo (p.ej. forzar una nueva conexión en cada llamada), configurar la opción "ConnectionPooling" en el array $connectionOptions a 0 (o false). Para más información, ver » Cola de conexión SQLSRV.

La extensión SQLSRV no tiene una función específica para cambiar a que base de datos se está conectado. La base de datos objetivo se especifica en el array de opciones $connectionOptions que se pasa a sqlsrv_connect. Para cambiar la base de datos en una conexión ya abierta, ejecutar la siguiente sentencia sql "USE dbName" (p.ej. sqlsrv_query($conn, "USE dbName")).

Ver también

  • sqlsrv_close() - Cierra una conexión abierta y libera los recursos asociados a la conexión
  • sqlsrv_errors() - Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada
  • sqlsrv_query() - Prepares and executes a query


Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada

  • « sqlsrv_connect
  • sqlsrv_execute »
  • PHP Manual
  • SQLSRV Funciones
  • Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada

sqlsrv_errors

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_errors — Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada

Descripción

sqlsrv_errors ( int $errorsOrWarnings = ? ) : mixed

Devuelve información de errores y alertas de la última operación SQLSRV realizada.

Parámetros

errorsOrWarnings

Determina si se ha de retornar información de error, alertas, o ambas. Si este parámetro no se informa, se devolverá tanto información de error como de alerta. Este parámetro puede tomar los siguientes valores: SQLSRV_ERR_ALL, SQLSRV_ERR_ERRORS, SQLSRV_ERR_WARNINGS.

Valores devueltos

Si se produjeron errores y/o warnings en la última operación sqlsrv, se devolverá un array de arrays conteniendo información de error. Si no se produjeron errores y/o alertas en la última operación sqlsrv, se devolverá null. La siguiente tabla describe la estructura de los arrays devueltos:

Array devuelto por sqlsrv_errors
Clave | Descripción
SQLSTATE | Para errores que se originan en el driver ODBC driver, el SQLSTATE devuelto por ODBC. Para errores que se originan en los drivers de Microsoft para PHP para SQL Server, un SQLSTATE de IMSSP. Para alertas que se originan en los drivers de Microsoft para PHP para SQL Server, un SQLSTATE de 01SSP.
code | Para errores que se originan en SQL Server, el código de error SQL Server nativo. Para errores que se originan en el driver ODBC, el código de error devuelto por ODBC. Para errores que se originan en los Drivers de Microsoft para PHP para SQL Server, los códigos de error de SQL Server para los Drivers de Microsoft para PHP.
message | Una descripción del error.

Ejemplos

Ejemplo #1 ejemplo de functionname()

<?php
$serverName = "serverName/sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/* Query que selecciona un nombre de columna inválida. */
$sql = "SELECT BadColumnName FROM Table_1";

/* Ejecución de la query que fallará debido al nombre de columna incorrecto. */
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false ) {
    if( ($errors = sqlsrv_errors() ) != null) {
        foreach( $errors as $error ) {
            echo "SQLSTATE: ".$error[ 'SQLSTATE']."<br />";
            echo "code: ".$error[ 'code']."<br />";
            echo "message: ".$error[ 'message']."<br />";
        }
    }
}
?>

Notas

Por defecto, las alertas generadas en una llamada a cualquier función SQLSRV se tratarán como errores. Esto significa que si una alerta ocurre en una llamada a una función SQLSRV, la función devolverá false. Sin embargo, las alertas correspondientes a los valores de SQLSTATE 01000, 01001, 01003, y 01S02 nunca se tratarán como errores. Para obtener información sobre cómo cambiar este comportamiento, ver sqlsrv_configure() y la configuración de WarningsReturnAsErrors.

Ver también

  • sqlsrv_configure() - Cambia la configuración de los drivers del gestionador de errores y de log


Ejecuta una sentencia preparada con sqlsrv_prepare

  • « sqlsrv_errors
  • sqlsrv_fetch_array »
  • PHP Manual
  • SQLSRV Funciones
  • Ejecuta una sentencia preparada con sqlsrv_prepare

sqlsrv_execute

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_execute — Ejecuta una sentencia preparada con sqlsrv_prepare()

Descripción

sqlsrv_execute ( resource $stmt ) : bool

Ejecuta una sentencia preparada con sqlsrv_prepare(). Esta función es ideal para ser ejecutar múltiples veces una sentencia preparada con diferentes valores de parámetros.

Parámetros

stmt

Un recurso de sentencia devuelto por sqlsrv_prepare().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ejemplo de sqlsrv_execute()

Este ejemplo muestra como preparar una sentencia con sqlsrv_prepare() y reejecutarla múltiples veces (con diferentes valores de parámetros) utilizando sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Inicializar los parámetros y preparar la sentencia.
// Las variables $qty y $id se pasan como parámetro a la sentencia $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Configurar la información de SalesOrderDetailID y OrderQty.
// Este array liga el orden ID al orden de cantidad en las parejas  key=>value.
$orders = array( 1=>10, 2=>20, 3=>30);

// Ejecuta la sentencia para cada orden.
foreach( $orders as $id => $qty) {
    // Como $id y $qty se pasan como parámetro a $stmt1, sus valores
    // actualizados se utilizan en cada ejecución de la sentencia.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

Notas

Cuando se prepara una sentencia que utiliza variables como parámetros, las variables se pasan como parámetros a la sentencia. Esto significa que si se actualizan los valores de las variables, la próxima vez que se ejecute la sentencia lo hará con los nuevos valores de los parámetros. Para las sentencias que se quieran ejecutar únicamente una vez, utilizar sqlsrv_query().

Ver también

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query


Devuelve una fila como un array

  • « sqlsrv_execute
  • sqlsrv_fetch_object »
  • PHP Manual
  • SQLSRV Funciones
  • Devuelve una fila como un array

sqlsrv_fetch_array

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_fetch_array — Devuelve una fila como un array

Descripción

sqlsrv_fetch_array ( resource $stmt , int $fetchType = ? , int $row = ? , int $offset = ? ) : array

Devuelve la siguiente fila de datos disponible como un array asociativo, un array numérico, o ambos (por defecto).

Parámetros

stmt

Un recurso de sentencia devuelta por sqlsrv_query o sqlsrv_prepare.

fetchType

Una constante predefinida con el tipo de array a devolver. Los valores posibles son SQLSRV_FETCH_ASSOC, SQLSRV_FETCH_NUMERIC, y SQLSRV_FETCH_BOTH (por defecto).

El tipo de objeto devuelto SQLSRV_FETCH_ASSOC no debe utilizarse cuando se trate un conjunto de resultados con múltiples columnas con el mismo nombre.

row

Especifica la fila para acceder a un conjunto de resultados que utiliza un cursor con scroll. Los valores posibles son SQLSRV_SCROLL_NEXT, SQLSRV_SCROLL_PRIOR, SQLSRV_SCROLL_FIRST, SQLSRV_SCROLL_LAST, SQLSRV_SCROLL_ABSOLUTE y, SQLSRV_SCROLL_RELATIVE (por defecto). Cuando se especifica este parámetro, el parámetro fetchType debe ser definido explícitamente.

offset

Especifica la fila a la que se desea acceder si el parámetro de fila se define como SQLSRV_SCROLL_ABSOLUTE o SQLSRV_SCROLL_RELATIVE. Notar que la primera fila en un conjunto de resultado tiene el índice 0.

Valores devueltos

Devuelve un array en caso de éxito, null si no hay más filas a devolver, y false si se produce un error.

Ejemplos

Ejemplo #1 Devolver un array asociativo.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC) ) {
      echo $row['LastName'].", ".$row['FirstName']."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

Ejemplo #2 Devolver un array numérico.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_NUMERIC) ) {
      echo $row[0].", ".$row[1]."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

Notas

Cuando no se especifica el parámetro fetchType o se utiliza explícitamente la constante SQLSRV_FETCH_TYPE en los ejemplos anteriores, se devolverá un array que tiene tanto claves asociativas como claves nuéricas.

Si se devuelve más de una columna con el mismo nombre, la última columna tendrá prioridad para tomar el nombre. Para evitar colisiones de nombre de campo, utilizar alias.

Si se devuelve una columna sin nombre, la clave asociativa para ese elemento del array será un string vacío ("").

Ver también

  • sqlsrv_connect() - Abre una conexión a una base de datos Microsoft SQL Server
  • sqlsrv_query() - Prepares and executes a query
  • sqlsrv_errors() - Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada
  • sqlsrv_fetch() - Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado


Devuelve la siguiente fila de datos de un conjunto resultado como un objeto

  • « sqlsrv_fetch_array
  • sqlsrv_fetch »
  • PHP Manual
  • SQLSRV Funciones
  • Devuelve la siguiente fila de datos de un conjunto resultado como un objeto

sqlsrv_fetch_object

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_fetch_object — Devuelve la siguiente fila de datos de un conjunto resultado como un objeto

Descripción

sqlsrv_fetch_object ( resource $stmt , string $className = ? , array $ctorParams = ? , int $row = ? , int $offset = ? ) : mixed

Devuelve la siguiente fila de datos de un conjunto resultado como una instancia de la clase especificada, donde las propiedades correspondientes a los nombres de los campos de la fila recuperada y los valores, se corresponden con los valores de la fila recuperada.

Parámetros

stmt

Un recurso de consulta creado por sqlsrv_query() o sqlsrv_execute().

className

El nombre de la clase a instanciar. Si no se especifica el nombre de la clase, se instanciará la clase stdClass.

ctorParams

Los valores pasados al constructor de la clase especificada. Si el constructor de la clase especificada tiene parámetros, se proporcionará el array ctorParams.

row

La fila a la que se accederá. Este parámetro únicamente puede utilizarse si la consulta especificada se preparó con un cursor con scroll. En ese caso, este parámetro puede tomar uno de los siguientes valores:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Especifica la fila a la que se accederá si el parámetro de fila se ha especificado como SQLSRV_SCROLL_ABSOLUTE o SQLSRV_SCROLL_RELATIVE. Notar que la primera fila en un conjunto de resultado tiene el índice 0.

Valores devueltos

Devuelve un objeto en caso de éxito, null si no hay más filas a devolver, y false si se produce un error o si la clase especificada no existe.

Ejemplos

Ejemplo #1 Ejemplo con sqlsrv_fetch_object()

El siguiente ejemplo demuestra cómo devolver una columna como un objeto stdClass.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT fName, lName FROM Table_1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Devolver cada fila como un objeto.
// Puesto que no se especifica ninguna clase, cada fila devolverá un objeto stdClass.
// Los nombres de propiedades corresponden a nombres de campo.
while( $obj = sqlsrv_fetch_object( $stmt)) {
      echo $obj->fName.", ".$obj->lName."<br />";
}
?>

Notas

Si se especifica un nombre de clase con el parámetro opcional $className y la clase tiene propiedades cuyos nombres coinciden con los nombres de campos del conjunto de resultado, los valores correspondientes del conjunto de resultado se aplicarán a las propiedades. Si un nombre de campo del conjunto resultado no coincide con ninguna propiedad de clase, una propiedad con el nombre de campo se añadirá al objeto del conjunto resultado y el valor del resultado se aplicará a la propiedad. Se aplican las reglas siguientes cuando se utiliza el parámetro $className:

  • El nombre de propiedad de campo coincidente es sensible al uso de mayúsculas y minúsculas (es case sensitive).
  • La coincidencia con la propiedad de campo se da aunque se utilicen modificadores de acceso.
  • Los tipos de datos de la propiedad de clase se ignoran cuando se aplica un valor de campo a la propiedad.
  • Si la clase no existe, la función devuelve false y añade un error a la colección de errores.
A pesar de que se defina el parámetro $className, si se devuelve un campo sin nombre, el valor de campo será ignorado y se añadirá una alerta a la colección de errores.

Cuando se trate un conjunto de resultado que tenga varias columnas con el mismo nombre, podría ser mejor utilizar sqlsrv_fetch_array() o la combinación de sqlsrv_fetch() y sqlsrv_get_field().

Ver también

  • sqlsrv_fetch() - Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
  • sqlsrv_fetch_array() - Devuelve una fila como un array


Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado

  • « sqlsrv_fetch_object
  • sqlsrv_field_metadata »
  • PHP Manual
  • SQLSRV Funciones
  • Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado

sqlsrv_fetch

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_fetch — Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado

Descripción

sqlsrv_fetch ( resource $stmt , int $row = ? , int $offset = ? ) : mixed

Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado. Utilizar sqlsrv_get_field() para leer los campos de la fila.

Parámetros

stmt

Un recurso de consulta creado por la ejecución de sqlsrv_query() o sqlsrv_execute().

row

La fila que será accedida. Este parámetro puede utilizarse si la consulta especificada se preparó con un cursor con scroll. En ese caso, el parámetro puede tomar uno de los siguientes valores:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Especifica la fila que será accedida si el parámetro de fila se configura como SQLSRV_SCROLL_ABSOLUTE o SQLSRV_SCROLL_RELATIVE. Notar que la primera fila en el conjunto resultado tiene el índice 0.

Valores devueltos

Devuelve true si la fila siguiente del conjunto de resultado se obtuvo satisfactoriamente, false si se produce un error, y null si no hay más filas en el conjunto de resultado.

Ejemplos

Ejemplo #1 Ejemplo con sqlsrv_fetch()

El ejemplo siguiente demuestra como obtener una fila con sqlsrv_fetch() y los campos de la fila con sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Hacer que sea disponible para su lectura la primera (y en este caso única) fila del conjunto resultado.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Obtener los campos de la fila. Los índices de campo empiezan desde 0 y se deben obtener en orden.
// Recuperar los nombres de campo por su nombre no está soportado por sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

Ver también

  • sqlsrv_get_field() - Gets field data from the currently selected row
  • sqlsrv_fetch_array() - Devuelve una fila como un array
  • sqlsrv_fetch_object() - Devuelve la siguiente fila de datos de un conjunto resultado como un objeto


Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query

  • « sqlsrv_fetch
  • sqlsrv_free_stmt »
  • PHP Manual
  • SQLSRV Funciones
  • Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query

sqlsrv_field_metadata

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_field_metadata — Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare() o sqlsrv_query()

Descripción

sqlsrv_field_metadata ( resource $stmt ) : mixed

Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare() o sqlsrv_query(). sqlsrv_field_metadata() puede llamarse en una consulta antes o despues de la ejecución de la consulta.

Parámetros

stmt

El recurso de la consulta de la que se obtendrá los metadatos.

Valores devueltos

Devuelve un array de arrays en caso de éxito. En caso contrario, false. Cada array devuelto se describe en la siguiente tabla:

Array devuelto por sqlsrv_field_metadata
Clave | Descripción
Name | El nombre del campo.
Type | El valor numérico del tipo SQL.
Size | El número de caracteres para los campos de tipo carácter, el número de bytes para los campos de tipo binario, o null para el resto de tipos.
Precision | La precisión para los tipos de precisión variable, nullpara el resto de tipos.
Scale | La escala para tipos de escala variable, null para el resto de tipos.
Nullable | Una enumeración que indica si la columna puede tener nulos, no puede tener nulos, o si se desconoce.
Para más información, ver » sqlsrv_field_metadata en la documentación de Microsoft SQLSRV.

Ejemplos

Ejemplo #1 Ejemplo con sqlsrv_field_metadata()

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"AdventureWorks", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_prepare( $conn, $sql );

foreach( sqlsrv_field_metadata( $stmt ) as $fieldMetadata ) {
    foreach( $fieldMetadata as $name => $value) {
       echo "$name: $value<br />";
    }
      echo "<br />";
}
?>

Ver también

  • sqlsrv_client_info() - Devuelve información sobre el cliente y la conexión especificada


Frees all resources for the specified statement

  • « sqlsrv_field_metadata
  • sqlsrv_get_config »
  • PHP Manual
  • SQLSRV Funciones
  • Frees all resources for the specified statement

sqlsrv_free_stmt

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_free_stmt — Frees all resources for the specified statement

Descripción

sqlsrv_free_stmt ( resource $stmt ) : bool

Frees all resources for the specified statement. The statement cannot be used after sqlsrv_free_stmt() has been called on it. If sqlsrv_free_stmt() is called on an in-progress statement that alters server state, statement execution is terminated and the statement is rolled back.

Parámetros

stmt

The statement for which resources are freed. Note that null is a valid parameter value. This allows the function to be called multiple times in a script.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 sqlsrv_free_stmt() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/*-------------------------------
     Process query results here.
-------------------------------*/

/* Free the statement resources. */
sqlsrv_free_stmt( $stmt);

?>

Notas

The main difference between sqlsrv_free_stmt() and sqlsrv_cancel() is that a statement resource cancelled with sqlsrv_cancel() can be re-executed if it was created with sqlsrv_prepare(). A statement resource cancelled with sqlsrv_free_statement() cannot be re-executed.

Ver también

  • sqlsrv_cancel() - Cancela una sentencia de base de datos


Returns the value of the specified configuration setting

  • « sqlsrv_free_stmt
  • sqlsrv_get_field »
  • PHP Manual
  • SQLSRV Funciones
  • Returns the value of the specified configuration setting

sqlsrv_get_config

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_get_config — Returns the value of the specified configuration setting

Descripción

sqlsrv_get_config ( string $setting ) : mixed

Returns the value of the specified configuration setting.

Parámetros

setting

The name of the setting for which the value is returned. For a list of configurable settings, see sqlsrv_configure().

Valores devueltos

Returns the value of the specified setting. If an invalid setting is specified, false is returned.

Ver también

  • sqlsrv_configure() - Cambia la configuración de los drivers del gestionador de errores y de log


Gets field data from the currently selected row

  • « sqlsrv_get_config
  • sqlsrv_has_rows »
  • PHP Manual
  • SQLSRV Funciones
  • Gets field data from the currently selected row

sqlsrv_get_field

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_get_field — Gets field data from the currently selected row

Descripción

sqlsrv_get_field ( resource $stmt , int $fieldIndex , int $getAsType = ? ) : mixed

Gets field data from the currently selected row. Fields must be accessed in order. Field indices start at 0.

Parámetros

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

fieldIndex

The index of the field to be retrieved. Field indices start at 0. Fields must be accessed in order. i.e. If you access field index 1, then field index 0 will not be available.

getAsType

The PHP data type for the returned field data. If this parameter is not set, the field data will be returned as its default PHP data type. For information about default PHP data types, see » Default PHP Data Types in the Microsoft SQLSRV documentation.

Valores devueltos

Returns data from the specified field on success. Returns false otherwise.

Ejemplos

Ejemplo #1 sqlsrv_get_field() example

The following example demonstrates how to retrieve a row with sqlsrv_fetch() and get the row fields with sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Make the first (and in this case, only) row of the result set available for reading.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Get the row fields. Field indices start at 0 and must be retrieved in order.
// Retrieving row fields by name is not supported by sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

Ver también

  • sqlsrv_fetch() - Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
  • sqlsrv_fetch_array() - Devuelve una fila como un array
  • sqlsrv_fetch_object() - Devuelve la siguiente fila de datos de un conjunto resultado como un objeto


Indicates whether the specified statement has rows

  • « sqlsrv_get_field
  • sqlsrv_next_result »
  • PHP Manual
  • SQLSRV Funciones
  • Indicates whether the specified statement has rows

sqlsrv_has_rows

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_has_rows — Indicates whether the specified statement has rows

Descripción

sqlsrv_has_rows ( resource $stmt ) : bool

Indicates whether the specified statement has rows.

Parámetros

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

Valores devueltos

Returns true if the specified statement has rows and false if the statement does not have rows or if an error occurred.

Ejemplos

Ejemplo #1 sqlsrv_has_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" )
$conn = sqlsrv_connect( $server, $connectionInfo );

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");

if ($stmt) {
   $rows = sqlsrv_has_rows( $stmt );
   if ($rows === true)
      echo "There are rows. <br />";
   else
      echo "There are no rows. <br />";
}
?>

Ver también

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set
  • sqlsrv_query() - Prepares and executes a query


Makes the next result of the specified statement active

  • « sqlsrv_has_rows
  • sqlsrv_num_fields »
  • PHP Manual
  • SQLSRV Funciones
  • Makes the next result of the specified statement active

sqlsrv_next_result

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_next_result — Makes the next result of the specified statement active

Descripción

sqlsrv_next_result ( resource $stmt ) : mixed

Makes the next result of the specified statement active. Results include result sets, row counts, and output parameters.

Parámetros

stmt

The statement on which the next result is being called.

Valores devueltos

Returns true if the next result was successfully retrieved, false if an error occurred, and null if there are no more results to retrieve.

Ejemplos

Ejemplo #1 sqlsrv_next_result() example

The following example executes a batch query that inserts into a table and then selects from the table. This produces two results on the statement: one for the rows affected by the INSERT and one for the rows returned by the SELECT. To get to the rows returned by the SELECT, sqlsrv_next_result() must be called to move past the first result.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array("Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

$query = "INSERT INTO Table_1 (id, data) VALUES (?,?); SELECT * FROM TABLE_1;";
$params = array(1, "some data");
$stmt = sqlsrv_query($conn, $query, $params);

// Consume the first result (rows affected by INSERT) without calling sqlsrv_next_result.
echo "Rows affected: ".sqlsrv_rows_affected($stmt)."<br />";

// Move to the next result and display results.
$next_result = sqlsrv_next_result($stmt);
if( $next_result ) {
   while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC)){
      echo $row['id'].": ".$row['data']."<br />";
   }
} elseif( is_null($next_result)) {
     echo "No more results.<br />";
} else {
     die(print_r(sqlsrv_errors(), true));
}
?>

Ver también

  • sqlsrv_query() - Prepares and executes a query
  • sqlsrv_fetch_array() - Devuelve una fila como un array
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed


Retrieves the number of fields (columns) on a statement

  • « sqlsrv_next_result
  • sqlsrv_num_rows »
  • PHP Manual
  • SQLSRV Funciones
  • Retrieves the number of fields (columns) on a statement

sqlsrv_num_fields

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement

Descripción

sqlsrv_num_fields ( resource $stmt ) : mixed

Retrieves the number of fields (columns) on a statement.

Parámetros

stmt

The statement for which the number of fields is returned. sqlsrv_num_fields() can be called on a statement before or after statement execution.

Valores devueltos

Returns the number of fields on success. Returns false otherwise.

Ejemplos

Ejemplo #1 sqlsrv_num_fields() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_query($conn, $sql);
if( $stmt === false) {
   die( print_r( sqlsrv_errors(), true));
}

$numFields = sqlsrv_num_fields( $stmt );

while( sqlsrv_fetch( $stmt )) {
   // Iterate through the fields of each row.
   for($i = 0; $i < $numFields; $i++) {
      echo sqlsrv_get_field($stmt, $i)." ";
   }
   echo "<br />";
}
?>

Ver también

  • sqlsrv_field_metadata() - Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query
  • sqlsrv_fetch() - Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
  • sqlsrv_get_field() - Gets field data from the currently selected row


Retrieves the number of rows in a result set

  • « sqlsrv_num_fields
  • sqlsrv_prepare »
  • PHP Manual
  • SQLSRV Funciones
  • Retrieves the number of rows in a result set

sqlsrv_num_rows

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_num_rows — Retrieves the number of rows in a result set

Descripción

sqlsrv_num_rows ( resource $stmt ) : mixed

Retrieves the number of rows in a result set. This function requires that the statement resource be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Parámetros

stmt

The statement for which the row count is returned. The statement resource must be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Valores devueltos

Returns the number of rows retrieved on success and false if an error occurred. If a forward cursor (the default) or dynamic cursor is used, false is returned.

Ejemplos

Ejemplo #1 sqlsrv_num_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $server, $connectionInfo );

$sql = "SELECT * FROM Table_1";
$params = array();
$options =  array( "Scrollable" => SQLSRV_CURSOR_KEYSET );
$stmt = sqlsrv_query( $conn, $sql , $params, $options );

$row_count = sqlsrv_num_rows( $stmt );

if ($row_count === false)
   echo "Error in retrieveing row count.";
else
   echo $row_count;
?>

Ver también

  • sqlsrv_has_rows() - Indicates whether the specified statement has rows
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed


Prepares a query for execution

  • « sqlsrv_num_rows
  • sqlsrv_query »
  • PHP Manual
  • SQLSRV Funciones
  • Prepares a query for execution

sqlsrv_prepare

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_prepare — Prepares a query for execution

Descripción

sqlsrv_prepare ( resource $conn , string $sql , array $params = ? , array $options = ? ) : mixed

Prepares a query for execution. This function is ideal for preparing a query that will be executed multiple times with different parameter values.

Parámetros

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifying query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | true or false (the default is true) | Configures the driver to send all stream data at execution (true), or to send stream data in chunks (false). By default, the value is set to true. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Valores devueltos

Returns a statement resource on success and false if an error occurred.

Ejemplos

Ejemplo #1 sqlsrv_prepare() example

This example demonstrates how to prepare a statement with sqlsrv_prepare() and re-execute it multiple times (with different parameter values) using sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Initialize parameters and prepare the statement.
// Variables $qty and $id are bound to the statement, $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Set up the SalesOrderDetailID and OrderQty information.
// This array maps the order ID to order quantity in key=>value pairs.
$orders = array( 1=>10, 2=>20, 3=>30);

// Execute the statement for each order.
foreach( $orders as $id => $qty) {
    // Because $id and $qty are bound to $stmt1, their updated
    // values are used with each execution of the statement.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

Notas

When you prepare a statement that uses variables as parameters, the variables are bound to the statement. This means that if you update the values of the variables, the next time you execute the statement it will run with updated parameter values. For statements that you plan to execute only once, use sqlsrv_query().

Ver también

  • sqlsrv_execute() - Ejecuta una sentencia preparada con sqlsrv_prepare
  • sqlsrv_query() - Prepares and executes a query


Prepares and executes a query

  • « sqlsrv_prepare
  • sqlsrv_rollback »
  • PHP Manual
  • SQLSRV Funciones
  • Prepares and executes a query

sqlsrv_query

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_query — Prepares and executes a query

Descripción

sqlsrv_query ( resource $conn , string $sql , array $params = ? , array $options = ? ) : mixed

Prepares and executes a query.

Parámetros

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifying query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | true or false (the default is true) | Configures the driver to send all stream data at execution (true), or to send stream data in chunks (false). By default, the value is set to true. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Valores devueltos

Returns a statement resource on success and false if an error occurred.

Ejemplos

Ejemplo #1 sqlsrv_query() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "INSERT INTO Table_1 (id, data) VALUES (?, ?)";
$params = array(1, "some data");

$stmt = sqlsrv_query( $conn, $sql, $params);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}
?>

Notas

For statements that you plan to execute only once, use sqlsrv_query(). If you intend to re-execute a statement with different parameter values, use the combination of sqlsrv_prepare() and sqlsrv_execute().

Ver también

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_execute() - Ejecuta una sentencia preparada con sqlsrv_prepare


Rolls back a transaction that was begun with sqlsrv_begin_transaction

  • « sqlsrv_query
  • sqlsrv_rows_affected »
  • PHP Manual
  • SQLSRV Funciones
  • Rolls back a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_rollback

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction()

Descripción

sqlsrv_rollback ( resource $conn ) : bool

Rolls back a transaction that was begun with sqlsrv_begin_transaction() and returns the connection to auto-commit mode.

Parámetros

conn

The connection resource returned by a call to sqlsrv_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 sqlsrv_rollback() example

The following example demonstrates how to use sqlsrv_begin_transaction() together with sqlsrv_commit() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

Ver también

  • sqlsrv_begin_transaction() - Inicia una transacción de base de datos
  • sqlsrv_commit() - Consolida una transacción que se inició con sqlsrv_begin_transaction


Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

  • « sqlsrv_rollback
  • sqlsrv_send_stream_data »
  • PHP Manual
  • SQLSRV Funciones
  • Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

sqlsrv_rows_affected

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

Descripción

sqlsrv_rows_affected ( resource $stmt ) : int

Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed. For information about the number of rows returned by a SELECT query, see sqlsrv_num_rows().

Parámetros

stmt

The executed statement resource for which the number of affected rows is returned.

Valores devueltos

Returns the number of rows affected by the last INSERT, UPDATE, or DELETE query. If no rows were affected, 0 is returned. If the number of affected rows cannot be determined, -1 is returned. If an error occurred, false is returned.

Ejemplos

Ejemplo #1 sqlsrv_rows_affected() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ? WHERE id = ?";

$params = array("updated data", 1);

$stmt = sqlsrv_query( $conn, $sql, $params);

$rows_affected = sqlsrv_rows_affected( $stmt);
if( $rows_affected === false) {
     die( print_r( sqlsrv_errors(), true));
} elseif( $rows_affected == -1) {
      echo "No information available.<br />";
} else {
      echo $rows_affected." rows were updated.<br />";
}
?>

Ver también

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set


Sends data from parameter streams to the server

  • « sqlsrv_rows_affected
  • sqlsrv_server_info »
  • PHP Manual
  • SQLSRV Funciones
  • Sends data from parameter streams to the server

sqlsrv_send_stream_data

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_send_stream_data — Sends data from parameter streams to the server

Descripción

sqlsrv_send_stream_data ( resource $stmt ) : bool

Send data from parameter streams to the server. Up to 8 KB of data is sent with each call.

Parámetros

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

Valores devueltos

Returns true if there is more data to send and false if there is not.

Ejemplos

Ejemplo #1 sqlsrv_send_stream_data() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ( ?) WHERE id = 100";

// Open parameter data as a stream and put it in the $params array.
$data = fopen( "data://text/plain,[ Lengthy content here. ]", "r");
$params = array( &$data);

// Prepare the statement. Use the $options array to turn off the
// default behavior, which is to send all stream data at the time of query
// execution.
$options = array("SendStreamParamsAtExec"=>0);
$stmt = sqlsrv_prepare( $conn, $sql, $params, $options);

sqlsrv_execute( $stmt);

// Send up to 8K of parameter data to the server
// with each call to sqlsrv_send_stream_data.
$i = 1;
while( sqlsrv_send_stream_data( $stmt)) {
      $i++;
}
echo "$i calls were made.";
?>

Ver también

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query


Returns information about the server

  • « sqlsrv_send_stream_data
  • tokyo_tyrant »
  • PHP Manual
  • SQLSRV Funciones
  • Returns information about the server

sqlsrv_server_info

(No hay información de versión disponible, podría estar únicamente en Git)

sqlsrv_server_info — Returns information about the server

Descripción

sqlsrv_server_info ( resource $conn ) : array

Returns information about the server.

Parámetros

conn

The connection resource that connects the client and the server.

Valores devueltos

Returns an array as described in the following table:

Returned Array
CurrentDatabase | The connected-to database.
SQLServerVersion | The SQL Server version.
SQLServerName | The name of the server.

Ejemplos

Ejemplo #1 sqlsrv_server_info() example

<?php
$serverName = "serverName\sqlexpress";
$conn = sqlsrv_connect( $serverName);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$server_info = sqlsrv_server_info( $conn);
if( $server_info )
{
    foreach( $server_info as $key => $value) {
       echo $key.": ".$value."<br />";
    }
} else {
      die( print_r( sqlsrv_errors(), true));
}
?>

Ver también

  • sqlsrv_client_info() - Devuelve información sobre el cliente y la conexión especificada


tokyo_tyrant

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrant::add — Adds to a numeric key
    • TokyoTyrant::connect — Connect to a database
    • TokyoTyrant::connectUri — Connects to a database
    • TokyoTyrant::__construct — Construct a new TokyoTyrant object
    • TokyoTyrant::copy — Copies the database
    • TokyoTyrant::ext — Execute a remote script
    • TokyoTyrant::fwmKeys — Returns the forward matching keys
    • TokyoTyrant::get — The get purpose
    • TokyoTyrant::getIterator — Get an iterator
    • TokyoTyrant::num — Number of records in the database
    • TokyoTyrant::out — Removes records
    • TokyoTyrant::put — Puts values
    • TokyoTyrant::putCat — Concatenates to a record
    • TokyoTyrant::putKeep — Puts a record
    • TokyoTyrant::putNr — Puts value
    • TokyoTyrant::putShl — Concatenates to a record
    • TokyoTyrant::restore — Restore the database
    • TokyoTyrant::setMaster — Set the replication master
    • TokyoTyrant::size — Returns the size of the value
    • TokyoTyrant::stat — Get statistics
    • TokyoTyrant::sync — Synchronize the database
    • TokyoTyrant::tune — Tunes connection values
    • TokyoTyrant::vanish — Empties the database
  • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantTable::add — Adds a record
    • TokyoTyrantTable::genUid — Generate unique id
    • TokyoTyrantTable::get — Get a row
    • TokyoTyrantTable::getIterator — Get an iterator
    • TokyoTyrantTable::getQuery — Get a query object
    • TokyoTyrantTable::out — Remove records
    • TokyoTyrantTable::put — Store a row
    • TokyoTyrantTable::putCat — Concatenates to a row
    • TokyoTyrantTable::putKeep — Put a new record
    • TokyoTyrantTable::putNr — Puts value
    • TokyoTyrantTable::putShl — Concatenates to a record
    • TokyoTyrantTable::setIndex — Sets index
  • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantQuery::addCond — Adds a condition to the query
    • TokyoTyrantQuery::__construct — Construct a new query
    • TokyoTyrantQuery::count — Counts records
    • TokyoTyrantQuery::current — Returns the current element
    • TokyoTyrantQuery::hint — Get the hint string of the query
    • TokyoTyrantQuery::key — Returns the current key
    • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
    • TokyoTyrantQuery::next — Moves the iterator to next entry
    • TokyoTyrantQuery::out — Removes records based on query
    • TokyoTyrantQuery::rewind — Rewinds the iterator
    • TokyoTyrantQuery::search — Searches records
    • TokyoTyrantQuery::setLimit — Limit results
    • TokyoTyrantQuery::setOrder — Orders results
    • TokyoTyrantQuery::valid — Checks the validity of current item
  • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantIterator::__construct — Construct an iterator
    • TokyoTyrantIterator::current — Get the current value
    • TokyoTyrantIterator::key — Returns the current key
    • TokyoTyrantIterator::next — Move to next key
    • TokyoTyrantIterator::rewind — Rewinds the iterator
    • TokyoTyrantIterator::valid — Rewinds the iterator
  • TokyoTyrantException — The TokyoTyrantException class


Introducción

tokyo_tyrant extension provides a wrapper for Tokyo Tyrant client libraries. The extension contains the normal key-value API and the table API.

"Tokyo Tyrant is a package of network interface to the DBM called Tokyo Cabinet. Though the DBM has high performance, you might bother in case that multiple processes share the same database, or remote processes access the database. Thus, Tokyo Tyrant is provided for concurrent and remote connections to Tokyo Cabinet. It is composed of the server process managing a database and its access library for client applications." --Tokyo Tyrant documentation

Tokyo Tyrant is written by Mikio Hirabayashi and is licensed under GNU Lesser General Public License.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Before using this extension Tokyo Cabinet and Tokyo Tyrant must be installed.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/tokyo_tyrant

Configure options

  • --with-tokyo-tyrant[=DIR] DIR is the prefix to the Tokyo Tyrant installation
  • --with-tokyo-cabinet-dir[=DIR] DIR is the prefix to the Tokyo Cabinet installation
  • --disable-tokyo-tyrant-session Disable Tokyo Tyrant session handler support

Enabling the extension

The extension can be enabled by adding extension=tokyo_tyrant.so to the INI-configuration

Running Tokyo Tyrant for the session handler

ttserver -port 2000 -ext /path/to/expire.lua -extpc expire 30.0 '/tmp/sessions.tct#idx=ts:dec'

Nota: expire.lua is included in the tokyo_tyrant extension source distribution

Configuring session handler

  • tokyo_tyrant.session_salt="randomlongstring"
  • session.save_handler=tokyo_tyrant
  • session.save_path="tcp://hostname1:2000,tcp://hostname2:2000"

Nota: It is important to make sure that tokyo_tyrant.session_salt matches on all servers.

How it works?

The session handler creates a session id like the following: 8b0e27a823fa4a6cf7246945b82c1d51-a5eadbbed1f2075952900628456bfd6830541629-0-5460

The parts from left to right:

  • Session id - Generated session id
  • Checksum - Checksum of session salt, session id, node id and primary key
  • Node id - The id of the node where the session maps to
  • Primary key - The primary key of the row where the session is stored

The checksum contains SHA1 sum of the node id, primary key, session id and the salt which is known only on the server side. This allows quick mapping of session id to node and primary key since there is no need to do an additional search. During session id regeneration only the parts 1 and 2 change but the mapping to the node and primary key stays constant.

In case some of the nodes fail tokyo_tyrant.allow_failover, tokyo_tyrant.fail_threshold and tokyo_tyrant.health_check_divisor INI-settings control the behavior during failover. If failover is allowed the session handler will map the session to a healthy node and creates a new empty session.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

tokyo_tyrant Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
tokyo_tyrant.default_timeout | 2.0 | PHP_INI_ALL |
tokyo_tyrant.session_salt | null | PHP_INI_ALL |
tokyo_tyrant.key_prefix | null | PHP_INI_ALL |
tokyo_tyrant.allow_failover | 1 | PHP_INI_ALL |
tokyo_tyrant.fail_threshold | 5 | PHP_INI_ALL |
tokyo_tyrant.health_check_divisor | 1000 | PHP_INI_ALL |
tokyo_tyrant.php_expiration | 0 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

tokyo_tyrant.default_timeout int

Default timeout when connecting to databases

tokyo_tyrant.session_salt string

The secret that is used to salt session id

tokyo_tyrant.key_prefix string

Prefix all keys with this string. The prefix is transparent to the developer but helps making sure that keys won't collide if multiple applications are using the same database.

tokyo_tyrant.allow_failover int

Whether to allow session failover in case a server dies.

tokyo_tyrant.fail_threshold int

How many read/write or connection failures is allowed before server is marked as failed.

tokyo_tyrant.health_check_divisor int

Defines the divisor for the health check probability. If there are failed servers and the probability matches, the servers are health checked and in case the server seems healthy, it will be added back to the pool.

tokyo_tyrant.php_expiration int

Whether to use built in session expiration mechanism or delegate the expiration to a lua-script on the server-side.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • tokyo_tyrant
  • Constantes predefinidas

Constantes predefinidas

TokyoTyrant constants


Ejemplos

Basic usage

Ejemplo #1 Putting and getting a key-value pair

<?php
$tt = new TokyoTyrant("localhost");
$tt->put("key", "value");
echo $tt->get("key");
?>

El resultado del ejemplo sería:

value


The TokyoTyrant class

(PECL tokyo_tyrant >= 0.1.0)

Introducción

The main Tokyo Tyrant class

Sinopsis de la Clase

TokyoTyrant {
/* Constantes */
const int RDBDEF_PORT = 1978 ;
const int RDBQC_STREQ = 0 ;
const int RDBQC_STRINC = 1 ;
const int RDBQC_STRBW = 2 ;
const int RDBQC_STREW = 3 ;
const int RDBQC_STRAND = 4 ;
const int RDBQC_STROR = 5 ;
const int RDBQC_STROREQ = 6 ;
const int RDBQC_STRRX = 7 ;
const int RDBQC_NUMEQ = 8 ;
const int RDBQC_NUMGT = 9 ;
const int RDBQC_NUMGE = 10 ;
const int RDBQC_NUMLT = 11 ;
const int RDBQC_NUMLE = 12 ;
const int RDBQC_NUMBT = 13 ;
const int RDBQC_NUMOREQ = 14 ;
const int RDBQC_NEGATE = 16777216 ;
const int RDBQC_NOIDX = 33554432 ;
const int RDBQO_STRASC = 0 ;
const int RDBQO_STRDESC = 1 ;
const int RDBQO_NUMASC = 2 ;
const int RDBQO_NUMDESC = 3 ;
const int RDBIT_LEXICAL = 0 ;
const int RDBIT_DECIMAL = 1 ;
const int RDBIT_TOKEN = 2 ;
const int RDBIT_QGRAM = 3 ;
const int RDBIT_OPT = 9998 ;
const int RDBIT_VOID = 9999 ;
const int RDBIT_KEEP = 16777216 ;
const int RDBQCFTS_PH = 15 ;
const int RDBQCFTS_AND = 16 ;
const int RDBQCFTS_OR = 17 ;
const int RDBQCFTS_EX = 18 ;
const int RDBXO_LCKREC = 1 ;
const int RDBXOLCK_GLB = 2 ;
const int RDBREC_INT = 1 ;
const int RDBREC_DBL = 2 ;
const int RDBMS_UNION = 0 ;
const int RDBMS_ISECT = 1 ;
const int RDBMS_DIFF = 2 ;
const int RDBT_RECON = 1 ;
/* Métodos */
public add ( string $key , int|float $increment , int $type = 0 ) : int|float
public connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public connectUri ( string $uri ) : TokyoTyrant
public __construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public copy ( string $path ) : TokyoTyrant
public ext ( string $name , int $options , string $key , string $value ) : string
public fwmKeys ( string $prefix , int $max_recs ) : array
public get ( mixed $keys ) : mixed
public getIterator ( ) : TokyoTyrantIterator
public num ( ) : int
public out ( mixed $keys ) : TokyoTyrant
public put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public putShl ( string $key , string $value , int $width ) : mixed
public restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public size ( string $key ) : int
public stat ( ) : array
public sync ( ) : mixed
public tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public vanish ( ) : mixed
}

Constantes predefinidas

TokyoTyrant Constants

TokyoTyrant::RDBDEF_PORT

The default port of the Tokyo Tyrant database

TokyoTyrant::RDBQC_STREQ

string is equal to

TokyoTyrant::RDBQC_STRINC

string is included in

TokyoTyrant::RDBQC_STRBW

string begins with

TokyoTyrant::RDBQC_STREW

string ends with

TokyoTyrant::RDBQC_STRAND

string includes all tokens in

TokyoTyrant::RDBQC_STROR

string includes at least one token in

TokyoTyrant::RDBQC_STROREQ

string is equal to at least one token in

TokyoTyrant::RDBQC_STRRX

string matches regular expressions of

TokyoTyrant::RDBQC_NUMEQ

number is equal to

TokyoTyrant::RDBQC_NUMGT

number is greater than

TokyoTyrant::RDBQC_NUMGE

number is greater than or equal to

TokyoTyrant::RDBQC_NUMLT

number is less than

TokyoTyrant::RDBQC_NUMLE

number is less than or equal to

TokyoTyrant::RDBQC_NUMBT

number is between two tokens of

TokyoTyrant::RDBQC_NUMOREQ

number is equal to at least one token in

TokyoTyrant::RDBQC_NEGATE

negation flag

TokyoTyrant::RDBQC_NOIDX

no index flag

TokyoTyrant::RDBQO_STRASC

string ascending

TokyoTyrant::RDBQO_STRDESC

string descending

TokyoTyrant::RDBQO_NUMASC

number ascending

TokyoTyrant::RDBQO_NUMDESC

number descending

TokyoTyrant::RDBIT_LEXICAL

lexical string

TokyoTyrant::RDBIT_DECIMAL

decimal string

TokyoTyrant::RDBIT_TOKEN

token inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_QGRAM

QGRAM inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_OPT

optimize

TokyoTyrant::RDBIT_VOID

void

TokyoTyrant::RDBIT_KEEP

keep existing index

TokyoTyrant::RDBQCFTS_PH

full-text search with the phrase of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

full-text search with all tokens in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_OR

full-text search with at least one token in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_EX

full-text search with the compound expression of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

Metasearch union between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_OR

Metasearch intersection between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_EX

Metasearch difference between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBT_RECON

Whether to reconnect on connection failure. It is recommended to have this parameter on for persistent connections

TokyoTyrant::RDBXOLCK_REC

record locking

TokyoTyrant::RDBXOLCK_GLB

global locking

TokyoTyrant::RDBREC_INT

record type int

TokyoTyrant::RDBREC_DBL

record type float (double)

TokyoTyrant::TTE_SUCCESS

success

TokyoTyrant::TTE_INVALID

invalid operation

TokyoTyrant::TTE_NOHOST

host not found

TokyoTyrant::TTE_REFUSED

connection refused

TokyoTyrant::TTE_SEND

send error

TokyoTyrant::TTE_RECV

recv error

TokyoTyrant::TTE_KEEP

record exist

TokyoTyrant::TTE_NOREC

no record found

TokyoTyrant::TTE_MISC

miscellaneous error

Tabla de contenidos

  • TokyoTyrant::add — Adds to a numeric key
  • TokyoTyrant::connect — Connect to a database
  • TokyoTyrant::connectUri — Connects to a database
  • TokyoTyrant::__construct — Construct a new TokyoTyrant object
  • TokyoTyrant::copy — Copies the database
  • TokyoTyrant::ext — Execute a remote script
  • TokyoTyrant::fwmKeys — Returns the forward matching keys
  • TokyoTyrant::get — The get purpose
  • TokyoTyrant::getIterator — Get an iterator
  • TokyoTyrant::num — Number of records in the database
  • TokyoTyrant::out — Removes records
  • TokyoTyrant::put — Puts values
  • TokyoTyrant::putCat — Concatenates to a record
  • TokyoTyrant::putKeep — Puts a record
  • TokyoTyrant::putNr — Puts value
  • TokyoTyrant::putShl — Concatenates to a record
  • TokyoTyrant::restore — Restore the database
  • TokyoTyrant::setMaster — Set the replication master
  • TokyoTyrant::size — Returns the size of the value
  • TokyoTyrant::stat — Get statistics
  • TokyoTyrant::sync — Synchronize the database
  • TokyoTyrant::tune — Tunes connection values
  • TokyoTyrant::vanish — Empties the database


Adds to a numeric key

  • « TokyoTyrant
  • TokyoTyrant::connect »
  • PHP Manual
  • TokyoTyrant
  • Adds to a numeric key

TokyoTyrant::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::add — Adds to a numeric key

Descripción

public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float

Adds to an int or double value. This increments the value by the given amount and returns the new value. If the key does not exist a new key is created with initial value of the increment parameter.

Parámetros

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDBREC_INT or TokyoTyrant::RDBREC_DBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

Valores devueltos

Returns the new value on success

Ejemplos

Ejemplo #1 TokyoTyrant::add() example

<?php
$tt = new TokyoTyrant("localhost", TokyoTyrant::RDBDEF_PORT);
/* Adds integer 3 to key and creates a new key */
$tt->add("test", 3);

/* String value is converted to double */
echo $tt->add("test", "3.5", TokyoTyrant::RDBREC_DBL);
?>

El resultado del ejemplo sería algo similar a:

6.5

Ver también

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putcat() - Concatenates to a record
  • TokyoTyrant::putkeep() - Puts a record


Connect to a database

  • « TokyoTyrant::add
  • TokyoTyrant::connectUri »
  • PHP Manual
  • TokyoTyrant
  • Connect to a database

TokyoTyrant::connect

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connect — Connect to a database

Descripción

public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant

Connects to a remote database

Parámetros

host

The hostname

port

The port. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: true) and persistent (default: true)

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::connect() example

<?php
$tt = new TokyoTyrant();
$tt->connect("localhost", TokyoTyrant::RDBDEF_PORT)->put("test", "value");
?>

Ver también

  • TokyoTyrant::connectUri() - Connects to a database


Connects to a database

  • « TokyoTyrant::connect
  • TokyoTyrant::__construct »
  • PHP Manual
  • TokyoTyrant
  • Connects to a database

TokyoTyrant::connectUri

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connectUri — Connects to a database

Descripción

public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant

Connects to a database using an uri

Parámetros

uri

An URI to the database. For example tcp://localhost:1979/

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::connectUri() example

<?php
$tt = new TokyoTyrant();
$tt->connectUri("tcp://localhost:1978/")->put("test", "hi");
?>

Ver también

  • TokyoTyrant::connect() - Connect to a database


Construct a new TokyoTyrant object

  • « TokyoTyrant::connectUri
  • TokyoTyrant::copy »
  • PHP Manual
  • TokyoTyrant
  • Construct a new TokyoTyrant object

TokyoTyrant::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::__construct — Construct a new TokyoTyrant object

Descripción

public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )

Constructs a new TokyoTyrant object and optionally connects to the database

Parámetros

host

The hostname. Default: null

port

port number. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: true) and persistent (default: true)

Valores devueltos

Throws TokyoTyrantException if connection to database fails

Ver también

  • TokyoTyrant::connect() - Connect to a database
  • TokyoTyrant::connectUri() - Connects to a database


Copies the database

  • « TokyoTyrant::__construct
  • TokyoTyrant::ext »
  • PHP Manual
  • TokyoTyrant
  • Copies the database

TokyoTyrant::copy

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::copy — Copies the database

Descripción

public TokyoTyrant::copy ( string $path ) : TokyoTyrant

Makes a copy of the current database

Parámetros

path

Path to where to copy the database. The user running the remote database must have a write access to the directory.

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::copy() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->copy("/tmp/foobar.tct");
?>

Ver también

  • TokyoTyrant::restore() - Restore the database


Execute a remote script

  • « TokyoTyrant::copy
  • TokyoTyrant::fwmKeys »
  • PHP Manual
  • TokyoTyrant
  • Execute a remote script

TokyoTyrant::ext

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::ext — Execute a remote script

Descripción

public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string

Executes a remote script extension.

Parámetros

name

Name of the function to execute

options

Either TokyoTyrant::RDBXO_LCKREC for record locking and TokyoTyrant::RDBXO_LCKGLB for global locking.

key

The key to pass to the function

value

The value to pass to the function

Valores devueltos

Returns the result of the script function

Ejemplos

Ejemplo #1 TokyoTyrant::ext() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
echo $tt->ext("somefunc", TokyoTyrant::RDBXO_LCKREC, "some_key", "some_value");
?>


Returns the forward matching keys

  • « TokyoTyrant::ext
  • TokyoTyrant::get »
  • PHP Manual
  • TokyoTyrant
  • Returns the forward matching keys

TokyoTyrant::fwmKeys

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::fwmKeys — Returns the forward matching keys

Descripción

public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array

Returns the forward matching keys from the database

Parámetros

prefix

Prefix of the keys

max_recs

Maximum records to return

Valores devueltos

Returns an array of matching keys. The values are not returned

Ejemplos

Ejemplo #1 TokyoTyrant::fwmKeys() example

<?php

$tt = new TokyoTyrant("localhost");

/* Create 20 macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("key_" . $i, "value_" . $i);
}

/* Create 20 non-macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("something_" . $i, "data_" . $i);
}

/* Get five matching keys */
var_dump($tt->fwmKeys("key_", 5));
?>

El resultado del ejemplo sería algo similar a:

array(5) {
  [0]=>
  string(5) "key_5"
  [1]=>
  string(6) "key_14"
  [2]=>
  string(5) "key_6"
  [3]=>
  string(6) "key_15"
  [4]=>
  string(5) "key_7"
}


The get purpose

  • « TokyoTyrant::fwmKeys
  • TokyoTyrant::getIterator »
  • PHP Manual
  • TokyoTyrant
  • The get purpose

TokyoTyrant::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::get — The get purpose

Descripción

public TokyoTyrant::get ( mixed $keys ) : mixed

This method is used to return a value or multiple values. This method accepts a string or an array as a value.

Parámetros

keys

A string key or an array of string keys

Valores devueltos

Returns a string or an array based on the given parameters. Throws a TokyoTyrantException on error. If string is passed null is returned if the key is not found. In case an array is given as an parameter only existing keys will be returned. It is not an error to pass a key that does not exist.

Ejemplos

Ejemplo #1 TokyoTyrant::get() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->put("key1", "value1");
$tt->put("key2", "value2");
var_dump($tt->get(array("key1", "key2")));
var_dump($tt->get("key1"));
?>

El resultado del ejemplo sería:

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key2"]=>
  string(6) "value2"
}
string(6) "value1"

Ver también

  • TokyoTyrant::put() - Puts values


Get an iterator

  • « TokyoTyrant::get
  • TokyoTyrant::num »
  • PHP Manual
  • TokyoTyrant
  • Get an iterator

TokyoTyrant::getIterator

(No hay información de versión disponible, podría estar únicamente en Git)

TokyoTyrant::getIterator — Get an iterator

Descripción

public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator

Gets an iterator for iterating all keys / values in the database.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::getIterator() example

<?php
$tt = new TokyoTyrant("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {

}
?>

Ver también

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrantTable::getIterator() - Get an iterator


Number of records in the database

  • « TokyoTyrant::getIterator
  • TokyoTyrant::out »
  • PHP Manual
  • TokyoTyrant
  • Number of records in the database

TokyoTyrant::num

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::num — Number of records in the database

Descripción

public TokyoTyrant::num ( ) : int

Returns the number of records in the database

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns number of records in the database

Ejemplos

Ejemplo #1 TokyoTyrant::num() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Echo the number of records */
echo $tt->num();
?>

El resultado del ejemplo sería algo similar a:

1234

Ver también

  • TokyoTyrant::stat() - Get statistics


Removes records

  • « TokyoTyrant::num
  • TokyoTyrant::put »
  • PHP Manual
  • TokyoTyrant
  • Removes records

TokyoTyrant::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::out — Removes records

Descripción

public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant

Removes a record or multiple records. This method accepts a string for a single key or an array of keys for multiple records.

Parámetros

keys

A string key or an array of string keys

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::out() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

$tt->put("test1", "value1");
$tt->put("test2", "value2");

$tt->out(array("test1", "test2"));
?>

Ver también

  • TokyoTyrant::put() - Puts values


Puts values

  • « TokyoTyrant::out
  • TokyoTyrant::putCat »
  • PHP Manual
  • TokyoTyrant
  • Puts values

TokyoTyrant::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::put — Puts values

Descripción

public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key exists the value will be replaced with new value.

Parámetros

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::put() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->put("key", "value");

/* Put key-value pairs, new value overwrites the old */
$tt->put(array("key1" => "value1", "key" => "value2"));

/* Get back one key */
echo $tt->get("key");
?>

El resultado del ejemplo sería:

value2

Ver también

  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • « TokyoTyrant::put
  • TokyoTyrant::putKeep »
  • PHP Manual
  • TokyoTyrant
  • Concatenates to a record

TokyoTyrant::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putCat — Concatenates to a record

Descripción

public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant

Appends a value into existing key or multiple values if keys is an array. The second parameter is mandatory if keys is a string. If the record does not exist a new record is created.

Parámetros

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::putCat() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

/* Concatenate single key-value pair */
$tt->putCat("key", " has more data");

/* Echo the key */
echo $tt->get("key");
?>

El resultado del ejemplo sería:

value has more data

Ver también

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record


Puts a record

  • « TokyoTyrant::putCat
  • TokyoTyrant::putNr »
  • PHP Manual
  • TokyoTyrant
  • Puts a record

TokyoTyrant::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putKeep — Puts a record

Descripción

public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key already exists this method throws an exception indicating that the records exists.

Parámetros

keys

A string key or an array of key-value pairs

value

The string value

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 tokyotyrant::putKeep() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

try {
    $tt->putKeep("key", "new value");
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}
echo $tt->get("key");
?>

El resultado del ejemplo sería:

Existing record! Not modified
value

Ver también

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putCat() - Concatenates to a record


Puts value

  • « TokyoTyrant::putKeep
  • TokyoTyrant::putShl »
  • PHP Manual
  • TokyoTyrant
  • Puts value

TokyoTyrant::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putNr — Puts value

Descripción

public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. This method does not wait for the response from the server.

Parámetros

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::putNr() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->putNr("key", "value");

/* Put key-value pairs */
$tt->putNr(array("key1" => "value1", "key2" => "value2"));

/* Get back one key */
echo $tt->get("key1");
?>

El resultado del ejemplo sería:

value1

Ver también

  • TokyoTyrant::putNr()
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • « TokyoTyrant::putNr
  • TokyoTyrant::restore »
  • PHP Manual
  • TokyoTyrant
  • Concatenates to a record

TokyoTyrant::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putShl — Concatenates to a record

Descripción

public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed

Concatenate to a record and shift to left.

Parámetros

key

A string key

value

The value to concatenate

width

The width of the record

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::putShl() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "just a long piece of data");

/* Concatenate and shift to left */
$tt->putShl("key", " and string", 15);

/* Echo the key */
echo $tt->get("key");
?>

El resultado del ejemplo sería:

data and string

Ver también

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Restore the database

  • « TokyoTyrant::putShl
  • TokyoTyrant::setMaster »
  • PHP Manual
  • TokyoTyrant
  • Restore the database

TokyoTyrant::restore

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::restore — Restore the database

Descripción

public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed

Restore the database from the update log.

Advertencia

This method is not supported on 32bit platforms.

Parámetros

log_dir

Directory where the log is

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency: Default: true

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.


Set the replication master

  • « TokyoTyrant::restore
  • TokyoTyrant::size »
  • PHP Manual
  • TokyoTyrant
  • Set the replication master

TokyoTyrant::setMaster

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::setMaster — Set the replication master

Descripción

public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed

Sets the replication master of the database

Advertencia

This method is not supported on 32bit platforms.

Parámetros

host

Hostname of the replication master. If null the replication is disabled.

port

Port of the replication master

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency.

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::setMaster() example

<?php
/* Connect to a database */
$tt = new TokyoTyrant("tokyotyrant.example.com");

/* Disable the replication */
$tt->setMaster(NULL, 0, 0);
?>

Ver también

  • Classname::Method()


Returns the size of the value

  • « TokyoTyrant::setMaster
  • TokyoTyrant::stat »
  • PHP Manual
  • TokyoTyrant
  • Returns the size of the value

TokyoTyrant::size

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::size — Returns the size of the value

Descripción

public TokyoTyrant::size ( string $key ) : int

Returns the size of a value by key

Parámetros

key

The key of which size to fetch

Valores devueltos

Returns the size of the key or throw TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrant::size() example

<?php
$tt = new TokyoTyrant("localhost");

$tt->put("test_key", "12345");

echo $tt->size("test_key");
?>

El resultado del ejemplo sería:

5


Get statistics

  • « TokyoTyrant::size
  • TokyoTyrant::sync »
  • PHP Manual
  • TokyoTyrant
  • Get statistics

TokyoTyrant::stat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::stat — Get statistics

Descripción

public TokyoTyrant::stat ( ) : array

Returns statistics of the remote database

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of key value pairs describing the statistics

Ejemplos

Ejemplo #1 TokyoTyrant::stat() example

<?php
$tt = new TokyoTyrant("localhost");

var_dump($tt->stat());
?>

El resultado del ejemplo sería algo similar a:

array(19) {
  ["version"]=>
  string(6) "1.1.28"
  ["libver"]=>
  string(3) "311"
  ["protver"]=>
  string(4) "0.91"
  ["os"]=>
  string(5) "Linux"
  ["time"]=>
  string(17) "1247358357.665630"
  ["pid"]=>
  string(5) "14348"
  ["sid"]=>
  string(8) "59025947"
  ["type"]=>
  string(9) "on-memory"
  ["path"]=>
  string(1) "*"
  ["rnum"]=>
  string(1) "4"
  ["size"]=>
  string(6) "262856"
  ["bigend"]=>
  string(1) "0"
  ["fd"]=>
  string(1) "5"
  ["loadavg"]=>
  string(8) "0.000000"
  ["memsize"]=>
  string(8) "77328384"
  ["memrss"]=>
  string(7) "1183744"
  ["ru_real"]=>
  string(13) "162776.042152"
  ["ru_user"]=>
  string(8) "0.476029"
  ["ru_sys"]=>
  string(8) "8.652540"
}

Ver también

  • Classname::Method()


Synchronize the database

  • « TokyoTyrant::stat
  • TokyoTyrant::tune »
  • PHP Manual
  • TokyoTyrant
  • Synchronize the database

TokyoTyrant::sync

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::sync — Synchronize the database

Descripción

public TokyoTyrant::sync ( ) : mixed

Synchronizes the database on to the physical device

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.


Tunes connection values

  • « TokyoTyrant::sync
  • TokyoTyrant::vanish »
  • PHP Manual
  • TokyoTyrant
  • Tunes connection values

TokyoTyrant::tune

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrant::tune — Tunes connection values

Descripción

public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant

Tunes database connection options.

Parámetros

timeout

The objects timeout value (default: 5.0)

options

Bitmask of options to tune. This can be either 0 or TokyoTyrant::RDBT_RECON. It is recommended not to change the second parameter.

Valores devueltos

This method returns a reference to the current object and throws TokyoTyrantException on failure.


Empties the database

  • « TokyoTyrant::tune
  • TokyoTyrantTable »
  • PHP Manual
  • TokyoTyrant
  • Empties the database

TokyoTyrant::vanish

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::vanish — Empties the database

Descripción

public TokyoTyrant::vanish ( ) : mixed

Empties a remote database

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrant::vanish() example

<?php
$tt = new TokyoTyrant("localhost");
$tt->vanish();
?>

Ver también

  • TokyoTyrant::out() - Removes records


The TokyoTyrantTable class

(PECL tokyo_tyrant >= 0.1.0)

Introducción

Provides an API to the table databases. A table database can be create using the following command: ttserver -port 1979 /tmp/tt_table.tct. In Tokyo Tyrant the table API is a schemaless database which can store arbitrary amount of key-value pairs under a single primary key.

Sinopsis de la Clase

TokyoTyrantTable extends TokyoTyrant {
/* Métodos */
public add ( string $key , mixed $increment , string $type = ? ) : void
public genUid ( ) : int
public get ( mixed $keys ) : array
public getIterator ( ) : TokyoTyrantIterator
public getQuery ( ) : TokyoTyrantQuery
public out ( mixed $keys ) : void
public put ( string $key , array $columns ) : int
public putCat ( string $key , array $columns ) : void
public putKeep ( string $key , array $columns ) : void
public putNr ( mixed $keys , string $value = ? ) : void
public putShl ( string $key , string $value , int $width ) : void
public setIndex ( string $column , int $type ) : mixed
/* Métodos heredados */
public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float
public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant
public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public TokyoTyrant::copy ( string $path ) : TokyoTyrant
public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string
public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array
public TokyoTyrant::get ( mixed $keys ) : mixed
public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator
public TokyoTyrant::num ( ) : int
public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant
public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed
public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::size ( string $key ) : int
public TokyoTyrant::stat ( ) : array
public TokyoTyrant::sync ( ) : mixed
public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public TokyoTyrant::vanish ( ) : mixed
}

Tabla de contenidos

  • TokyoTyrantTable::add — Adds a record
  • TokyoTyrantTable::genUid — Generate unique id
  • TokyoTyrantTable::get — Get a row
  • TokyoTyrantTable::getIterator — Get an iterator
  • TokyoTyrantTable::getQuery — Get a query object
  • TokyoTyrantTable::out — Remove records
  • TokyoTyrantTable::put — Store a row
  • TokyoTyrantTable::putCat — Concatenates to a row
  • TokyoTyrantTable::putKeep — Put a new record
  • TokyoTyrantTable::putNr — Puts value
  • TokyoTyrantTable::putShl — Concatenates to a record
  • TokyoTyrantTable::setIndex — Sets index


Adds a record

  • « TokyoTyrantTable
  • TokyoTyrantTable::genUid »
  • PHP Manual
  • TokyoTyrantTable
  • Adds a record

TokyoTyrantTable::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::add — Adds a record

Descripción

public TokyoTyrantTable::add ( string $key , mixed $increment , string $type = ? ) : void

This method is not supported with table databases.

Parámetros

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDB_RECINT or TokyoTyrant::RDB_RECDBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

Valores devueltos

This method throws an TokyoTyrantException if used through this class.

Ver también

  • TokyoTyrant::add() - Adds to a numeric key


Generate unique id

  • « TokyoTyrantTable::add
  • TokyoTyrantTable::get »
  • PHP Manual
  • TokyoTyrantTable
  • Generate unique id

TokyoTyrantTable::genUid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::genUid — Generate unique id

Descripción

public TokyoTyrantTable::genUid ( ) : int

Generates an unique id inside the table database. In table databases rows are referenced using a numeric primary key.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an unique id or throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantTable::genUid() example

<?php
$tt = new TokyoTyrantTable("localhost", 1122);

echo $tt->genUid();
?>

El resultado del ejemplo sería algo similar a:

4

Ver también

  • TokyoTyrantTable::put() - Store a row


Get a row

  • « TokyoTyrantTable::genUid
  • TokyoTyrantTable::getIterator »
  • PHP Manual
  • TokyoTyrantTable
  • Get a row

TokyoTyrantTable::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::get — Get a row

Descripción

public TokyoTyrantTable::get ( mixed $keys ) : array

Gets a row from table database. keys is a single integer for the primary key of the row or an array of integers for multiple rows.

Parámetros

keys

The primary key, can be a string or an integer

Valores devueltos

Returns the row as an array

Ejemplos

Ejemplo #1 TokyoTyrantTable::get() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));
?>

El resultado del ejemplo sería:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Notas

Nota:

Starting from version 0.3.0 this method accepts array as parameter. Please note that multi-get on tables is not binary-safe.

Ver también

  • TokyoTyrantTable::put() - Store a row


Get an iterator

  • « TokyoTyrantTable::get
  • TokyoTyrantTable::getQuery »
  • PHP Manual
  • TokyoTyrantTable
  • Get an iterator

TokyoTyrantTable::getIterator

(No hay información de versión disponible, podría estar únicamente en Git)

TokyoTyrantTable::getIterator — Get an iterator

Descripción

public TokyoTyrantTable::getIterator ( ) : TokyoTyrantIterator

Gets an iterator for iterating all keys / values in the database.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrantTable::getIterator() example

<?php
$tt = new TokyoTyrantTable("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {
  var_dump($k, $v);
}
?>

Ver también

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrant::getIterator() - Get an iterator


Get a query object

  • « TokyoTyrantTable::getIterator
  • TokyoTyrantTable::out »
  • PHP Manual
  • TokyoTyrantTable
  • Get a query object

TokyoTyrantTable::getQuery

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::getQuery — Get a query object

Descripción

public TokyoTyrantTable::getQuery ( ) : TokyoTyrantQuery

Get a query object to execute searches on the database

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns TokyoTyrantQuery on success and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantTable::getQuery() example

<?php
/* Connect to a table database */
$table = new TokyoTyrantTable("localhost", 1979);

/* Put a few rows */
$table->put(null, array("column1" => "some data", "column2" => "more data"));
$table->put(null, array("something" => "value", "data" => "good data"));

/* Get query object */
$query = $table->getQuery();

/* Add condition to query */
$query->addCond('data', TokyoTyrant::RDBQC_STREQ, 'good data');

/* Get matching rows */
var_dump($query->search());
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [11]=>
  array(2) {
    ["something"]=>
    string(5) "value"
    ["data"]=>
    string(9) "good data"
  }
}

Ver también

  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::out() - Removes records based on query


Remove records

  • « TokyoTyrantTable::getQuery
  • TokyoTyrantTable::put »
  • PHP Manual
  • TokyoTyrantTable
  • Remove records

TokyoTyrantTable::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::out — Remove records

Descripción

public TokyoTyrantTable::out ( mixed $keys ) : void

Removes records from a table database.

Parámetros

keys

A single integer key or an array of integers

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrantTable::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Delete the row */
$tt->out($index);
?>

Ver también

  • TokyoTyrantTable::put() - Store a row


Store a row

  • « TokyoTyrantTable::out
  • TokyoTyrantTable::putCat »
  • PHP Manual
  • TokyoTyrantTable
  • Store a row

TokyoTyrantTable::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::put — Store a row

Descripción

public TokyoTyrantTable::put ( string $key , array $columns ) : int

Puts a new row into the database. This method parameters are key which is the primary key of the row, passing null will generate a new unique id. value is an array containing the row contents which is usually key value pairs.

Parámetros

key

The primary key of the row

columns

The row contents

Valores devueltos

Returns the primary key on success and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantTable::put() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->put($index, array("column1" => "other data", "column2" => "better data"));

/* Get the row back */
var_dump($tt->get($index));
?>

El resultado del ejemplo sería:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(2) {
  ["column1"]=>
  string(10) "other data"
  ["column2"]=>
  string(11) "better data"
}

Ver también

  • TokyoTyrantTable::get() - Get a row


Concatenates to a row

  • « TokyoTyrantTable::put
  • TokyoTyrantTable::putKeep »
  • PHP Manual
  • TokyoTyrantTable
  • Concatenates to a row

TokyoTyrantTable::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putCat — Concatenates to a row

Descripción

public TokyoTyrantTable::putCat ( string $key , array $columns ) : void

This method can be used to add new columns to existing records. Existing keys will be left unmodified but any new columns will be appended to the row. Passing null as key will generate a new row.

Parámetros

key

The primary key of the row or null

columns

Array of row contents

Valores devueltos

Returns the primary key and throws TokyoTyrantException on error.

Ejemplos

Ejemplo #1 TokyoTyrantTable::putCat() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->putcat($index, array("column1" => "something new", "new_column" => "other data"));

/* Get the row back */
var_dump($tt->get($index));
?>

El resultado del ejemplo sería:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(3) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
  ["new_column"]=>
  string(10) "other data"
}

Ver también

  • TokyoTyrantTable::put() - Store a row


Put a new record

  • « TokyoTyrantTable::putCat
  • TokyoTyrantTable::putNr »
  • PHP Manual
  • TokyoTyrantTable
  • Put a new record

TokyoTyrantTable::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putKeep — Put a new record

Descripción

public TokyoTyrantTable::putKeep ( string $key , array $columns ) : void

Puts a new record into the database. If the key already exists this method throws an exception indicating that the records exists.

Parámetros

key

The primary key of the row or null

columns

Array of the row contents

Valores devueltos

Returns the primary key and throws TokyoTyrantException on error.

Ejemplos

Ejemplo #1 TokyoTyrantTable::putKeep() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

try {
    $tt->putKeep($index, array("column1" => "something new", "new_column" => "other data"));
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}

/* Get the row back */
var_dump($tt->get($index));
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
Existing record! Not modified
array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Ver también

  • TokyoTyrantTable::put() - Store a row


Puts value

  • « TokyoTyrantTable::putKeep
  • TokyoTyrantTable::putShl »
  • PHP Manual
  • TokyoTyrantTable
  • Puts value

TokyoTyrantTable::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putNr — Puts value

Descripción

public TokyoTyrantTable::putNr ( mixed $keys , string $value = ? ) : void

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Parámetros

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Valores devueltos

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Ver también

  • TokyoTyrant::putNr() - Puts value
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • « TokyoTyrantTable::putNr
  • TokyoTyrantTable::setIndex »
  • PHP Manual
  • TokyoTyrantTable
  • Concatenates to a record

TokyoTyrantTable::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putShl — Concatenates to a record

Descripción

public TokyoTyrantTable::putShl ( string $key , string $value , int $width ) : void

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Parámetros

key

A string key

value

The value to concatenate

width

The width of the record

Valores devueltos

This method is not supported on table databases.

Ver también

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record
  • TokyoTyrantTable::put() - Store a row
  • TokyoTyrantTable::putKeep() - Put a new record
  • TokyoTyrantTable::putCat() - Concatenates to a row


Sets index

  • « TokyoTyrantTable::putShl
  • TokyoTyrantQuery »
  • PHP Manual
  • TokyoTyrantTable
  • Sets index

TokyoTyrantTable::setIndex

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::setIndex — Sets index

Descripción

public TokyoTyrantTable::setIndex ( string $column , int $type ) : mixed

Sets an index on a specified column. The index type is one of the TokyoTyrant::RDBIT_* constants. Passing TokyoTyrant::RDBIT_VOID removes the index.

Parámetros

column

The name of the column

type

The index type

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.


The TokyoTyrantQuery class

(PECL tokyo_tyrant >= 0.1.0)

Introducción

This class is used to query the table databases

Sinopsis de la Clase

TokyoTyrantQuery implements Iterator {
/* Métodos */
public addCond ( string $name , int $op , string $expr ) : mixed
public __construct ( TokyoTyrantTable $table )
public count ( ) : int
public current ( ) : array
public hint ( ) : string
public key ( ) : string
public metaSearch ( array $queries , int $type ) : array
public next ( ) : array
public out ( ) : TokyoTyrantQuery
public rewind ( ) : bool
public search ( ) : array
public setLimit ( int $max = ? , int $skip = ? ) : mixed
public setOrder ( string $name , int $type ) : mixed
public valid ( ) : bool
}

Tabla de contenidos

  • TokyoTyrantQuery::addCond — Adds a condition to the query
  • TokyoTyrantQuery::__construct — Construct a new query
  • TokyoTyrantQuery::count — Counts records
  • TokyoTyrantQuery::current — Returns the current element
  • TokyoTyrantQuery::hint — Get the hint string of the query
  • TokyoTyrantQuery::key — Returns the current key
  • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
  • TokyoTyrantQuery::next — Moves the iterator to next entry
  • TokyoTyrantQuery::out — Removes records based on query
  • TokyoTyrantQuery::rewind — Rewinds the iterator
  • TokyoTyrantQuery::search — Searches records
  • TokyoTyrantQuery::setLimit — Limit results
  • TokyoTyrantQuery::setOrder — Orders results
  • TokyoTyrantQuery::valid — Checks the validity of current item


Adds a condition to the query

  • « TokyoTyrantQuery
  • TokyoTyrantQuery::__construct »
  • PHP Manual
  • TokyoTyrantQuery
  • Adds a condition to the query

TokyoTyrantQuery::addCond

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::addCond — Adds a condition to the query

Descripción

public TokyoTyrantQuery::addCond ( string $name , int $op , string $expr ) : mixed

Adds a condition to the query. Condition can be something like: get all keys which value matches expr.

Parámetros

name

Name of the column in the condition

op

The operator. One of the TokyoTyrant::RDBQC_* constants

expr

The expression

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrantQuery::addCond() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

El resultado del ejemplo sería:

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

Ver también

  • Classname::Method()


Construct a new query

  • « TokyoTyrantQuery::addCond
  • TokyoTyrantQuery::count »
  • PHP Manual
  • TokyoTyrantQuery
  • Construct a new query

TokyoTyrantQuery::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::__construct — Construct a new query

Descripción

public TokyoTyrantQuery::__construct ( TokyoTyrantTable $table )

Construct a new query object

Parámetros

table

TokyoTyrantTable object with active database connection

Valores devueltos

Returns a new TokyoTyrantQuery object and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantQuery::__construct() example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);

$query = new TokyoTyrantQuery($tt);

/* Work with $query */
?>

Ver también

  • TokyoTyrantTable::getQuery() - Get a query object


Counts records

  • « TokyoTyrantQuery::__construct
  • TokyoTyrantQuery::current »
  • PHP Manual
  • TokyoTyrantQuery
  • Counts records

TokyoTyrantQuery::count

(No hay información de versión disponible, podría estar únicamente en Git)

TokyoTyrantQuery::count — Counts records

Descripción

public TokyoTyrantQuery::count ( ) : int

Returns a count of how many records a query returns.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a count of matching rows and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantQuery::count() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Count the results */
var_dump($query->count());
?>

El resultado del ejemplo sería:

int(2)

Ver también

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries


Returns the current element

  • « TokyoTyrantQuery::count
  • TokyoTyrantQuery::hint »
  • PHP Manual
  • TokyoTyrantQuery
  • Returns the current element

TokyoTyrantQuery::current

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::current — Returns the current element

Descripción

public TokyoTyrantQuery::current ( ) : array

Returns the current element. Part of Iterator interface

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current row

Ejemplos

Ejemplo #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

El resultado del ejemplo sería algo similar a:

pk: 1, columns: 2
pk: 4, columns: 2

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Get the hint string of the query

  • « TokyoTyrantQuery::current
  • TokyoTyrantQuery::key »
  • PHP Manual
  • TokyoTyrantQuery
  • Get the hint string of the query

TokyoTyrantQuery::hint

(No hay información de versión disponible, podría estar únicamente en Git)

TokyoTyrantQuery::hint — Get the hint string of the query

Descripción

public TokyoTyrantQuery::hint ( ) : string

Get the hint string of the query. The hint string contains information about an executed query and it could be compared to for example MySQL EXPLAIN statement.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method always returns a string

Ejemplos

Ejemplo #1 TokyoTyrantQuery::hint example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);
$tt->vanish();

for ($i = 0; $i < 11; $i++) {
     $tt->put(null, array('a_col' => 'a' . $i, 'b_col' => 'b' . $i));
}

$query = $tt->getQuery();
$query->addCond('a_col', TokyoTyrant::RDBQC_STRBW, 'a');

$query->search();
var_dump($query->hint());
?>

El resultado del ejemplo sería algo similar a:

string(72) "
scanning the whole table
result set size: 11
leaving the natural order
"

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Returns the current key

  • « TokyoTyrantQuery::hint
  • TokyoTyrantQuery::metaSearch »
  • PHP Manual
  • TokyoTyrantQuery
  • Returns the current key

TokyoTyrantQuery::key

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::key — Returns the current key

Descripción

public TokyoTyrantQuery::key ( ) : string

Returns the current key. Part of the Iterator interface

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current key and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

El resultado del ejemplo sería algo similar a:

pk: 1, columns: 2
pk: 4, columns: 2

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Retrieve records with multiple queries

  • « TokyoTyrantQuery::key
  • TokyoTyrantQuery::next »
  • PHP Manual
  • TokyoTyrantQuery
  • Retrieve records with multiple queries

TokyoTyrantQuery::metaSearch

(No hay información de versión disponible, podría estar únicamente en Git)

TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries

Descripción

public TokyoTyrantQuery::metaSearch ( array $queries , int $type ) : array

Executes multiple queries on a database and returns matching records. The current object is always the left most object in the search.

Parámetros

queries

Array of TokyoTyrantQuery objects

type

One of the TokyoTyrant::RDBMS_* constants

Valores devueltos

Returns the matching rows and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantQuery::metaSearch() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add test data */
$tt->put('cherry',     array('color' => 'red'));
$tt->put('strawberry', array('color' => 'red'));
$tt->put('apple',      array('color' => 'green'));
$tt->put('lemon',      array('color' => 'yellow'));

/* First query */
$query = $tt->getQuery();
$query->addCond('color', TokyoTyrant::RDBQC_STREQ, 'red')->setOrder('color', TokyoTyrant::RDBQO_STRASC);

/* Second query */
$query1 = $tt->getQuery();
$query1->addCond('color', TokyoTyrant::RDBQC_STREQ, 'yellow');

/* Get union between the queries */
var_dump($query->metaSearch(array($query1), TokyoTyrant::RDBMS_UNION));
?>

El resultado del ejemplo sería:

array(3) {
  ["cherry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["strawberry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["lemon"]=>
  array(1) {
    ["color"]=>
    string(6) "yellow"
  }
}

Ver también

  • TokyoTyrantQuery::search() - Searches records


Moves the iterator to next entry

  • « TokyoTyrantQuery::metaSearch
  • TokyoTyrantQuery::out »
  • PHP Manual
  • TokyoTyrantQuery
  • Moves the iterator to next entry

TokyoTyrantQuery::next

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::next — Moves the iterator to next entry

Descripción

public TokyoTyrantQuery::next ( ) : array

Returns the next result in the resultset. Part of the Iterator interface.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the next row and throws TokyoTyrantException on error.

Ejemplos

Ejemplo #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

El resultado del ejemplo sería algo similar a:

pk: 1, columns: 2
pk: 4, columns: 2

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Removes records based on query

  • « TokyoTyrantQuery::next
  • TokyoTyrantQuery::rewind »
  • PHP Manual
  • TokyoTyrantQuery
  • Removes records based on query

TokyoTyrantQuery::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::out — Removes records based on query

Descripción

public TokyoTyrantQuery::out ( ) : TokyoTyrantQuery

Removes all records that match the query. Works exactly like search but removes the records instead of returning them.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.

Ejemplos

Ejemplo #1 TokyoTyrantQuery::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Remove matching records */
$query->out();
?>

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Rewinds the iterator

  • « TokyoTyrantQuery::out
  • TokyoTyrantQuery::search »
  • PHP Manual
  • TokyoTyrantQuery
  • Rewinds the iterator

TokyoTyrantQuery::rewind

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::rewind — Rewinds the iterator

Descripción

public TokyoTyrantQuery::rewind ( ) : bool

Rewind the resultset and executes the query if it has not been executed. Part of the Iterator interface.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true

Ejemplos

Ejemplo #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

El resultado del ejemplo sería algo similar a:

pk: 1, columns: 2
pk: 4, columns: 2

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Searches records

  • « TokyoTyrantQuery::rewind
  • TokyoTyrantQuery::setLimit »
  • PHP Manual
  • TokyoTyrantQuery
  • Searches records

TokyoTyrantQuery::search

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::search — Searches records

Descripción

public TokyoTyrantQuery::search ( ) : array

Executes a search on the table database. Returns an array of arrays containing the matching records. In the returned array the first level is the primary key of the data and the second level is the row data.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the matching rows and throws TokyoTyrantException on error

Ejemplos

Ejemplo #1 TokyoTyrantQuery::search() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

El resultado del ejemplo sería:

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

Ver también

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries


Limit results

  • « TokyoTyrantQuery::search
  • TokyoTyrantQuery::setOrder »
  • PHP Manual
  • TokyoTyrantQuery
  • Limit results

TokyoTyrantQuery::setLimit

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setLimit — Limit results

Descripción

public TokyoTyrantQuery::setLimit ( int $max = ? , int $skip = ? ) : mixed

Set the maximum amount of records to return on a query.

Parámetros

max

Maximum amount of records. Default: -1

skip

How many records to skip from the start. Default: -1

Valores devueltos

This method returns the current object and throws TokyoTyrantException on failure.


Orders results

  • « TokyoTyrantQuery::setLimit
  • TokyoTyrantQuery::valid »
  • PHP Manual
  • TokyoTyrantQuery
  • Orders results

TokyoTyrantQuery::setOrder

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setOrder — Orders results

Descripción

public TokyoTyrantQuery::setOrder ( string $name , int $type ) : mixed

Sets the order of a query

Parámetros

name

The column name to apply the ordering on.

type

The type can be one of the following constants:

  • TokyoTyrant::RDBQO_STRASC - String ascending
  • TokyoTyrant::RDBQO_STRDESC - String descending
  • TokyoTyrant::RDBQO_NUMASC - Numberic ascending
  • TokyoTyrant::RDBQO_NUMDESC - String descending

Valores devueltos

This method returns the current object.


Checks the validity of current item

  • « TokyoTyrantQuery::setOrder
  • TokyoTyrantIterator »
  • PHP Manual
  • TokyoTyrantQuery
  • Checks the validity of current item

TokyoTyrantQuery::valid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::valid — Checks the validity of current item

Descripción

public TokyoTyrantQuery::valid ( ) : bool

Checks if the current item is valid. Part of the Iterator interface

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the current item is valid and false if not.

Ejemplos

Ejemplo #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

El resultado del ejemplo sería algo similar a:

pk: 1, columns: 2
pk: 4, columns: 2

Ver también

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


The TokyoTyrantIterator class

(PECL tokyo_tyrant >= 0.2.0)

Introducción

Provides an iterator for TokyoTyrant and TokyoTyrantTable objects. The iterator iterates over all keys and values in the database. TokyoTyrantIterator was added in version 0.2.0.

Sinopsis de la Clase

TokyoTyrantIterator implements Iterator {
/* Methods */
public __construct ( mixed $object )
public current ( ) : mixed
public key ( ) : mixed
public next ( ) : mixed
public rewind ( ) : void
public valid ( ) : bool
/* Inherited methods */
public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float
public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant
public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public TokyoTyrant::copy ( string $path ) : TokyoTyrant
public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string
public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array
public TokyoTyrant::get ( mixed $keys ) : mixed
public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator
public TokyoTyrant::num ( ) : int
public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant
public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed
public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::size ( string $key ) : int
public TokyoTyrant::stat ( ) : array
public TokyoTyrant::sync ( ) : mixed
public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public TokyoTyrant::vanish ( ) : mixed
}

Tabla de contenidos

  • TokyoTyrantIterator::__construct — Construct an iterator
  • TokyoTyrantIterator::current — Get the current value
  • TokyoTyrantIterator::key — Returns the current key
  • TokyoTyrantIterator::next — Move to next key
  • TokyoTyrantIterator::rewind — Rewinds the iterator
  • TokyoTyrantIterator::valid — Rewinds the iterator


Construct an iterator

  • « TokyoTyrantIterator
  • TokyoTyrantIterator::current »
  • PHP Manual
  • TokyoTyrantIterator
  • Construct an iterator

TokyoTyrantIterator::__construct

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::__construct — Construct an iterator

Descripción

public TokyoTyrantIterator::__construct ( mixed $object )

Construct a new TokyoTyrantIterator object. One connection can have multiple iterators but it is not quaranteed that all items are traversed in that case. object parameter can be either an of instance TokyoTyrant or TokyoTyrantTable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Throws an exception if iterator initialization fails.

Ejemplos

Ejemplo #1 TokyoTyrantIterator::__construct() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Construct an iterator */
$it = new TokyoTyrantIterator($tt);

foreach ($it as $value) {
    var_dump($value);
}
?>

El resultado del ejemplo sería:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Ver también

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key


Get the current value

  • « TokyoTyrantIterator::__construct
  • TokyoTyrantIterator::key »
  • PHP Manual
  • TokyoTyrantIterator
  • Get the current value

TokyoTyrantIterator::current

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::current — Get the current value

Descripción

public TokyoTyrantIterator::current ( ) : mixed

Returns the current value during iteration.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current value on success and false on failure.

Ver también

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Returns the current key

  • « TokyoTyrantIterator::current
  • TokyoTyrantIterator::next »
  • PHP Manual
  • TokyoTyrantIterator
  • Returns the current key

TokyoTyrantIterator::key

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::key — Returns the current key

Descripción

public TokyoTyrantIterator::key ( ) : mixed

Returns the current key.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current key on success and false on failure.

Ver también

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Move to next key

  • « TokyoTyrantIterator::key
  • TokyoTyrantIterator::rewind »
  • PHP Manual
  • TokyoTyrantIterator
  • Move to next key

TokyoTyrantIterator::next

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::next — Move to next key

Descripción

public TokyoTyrantIterator::next ( ) : mixed

Move to next key during iteration and return it's value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the next value on success and false on failure.

Ver también

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Rewinds the iterator

  • « TokyoTyrantIterator::next
  • TokyoTyrantIterator::valid »
  • PHP Manual
  • TokyoTyrantIterator
  • Rewinds the iterator

TokyoTyrantIterator::rewind

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::rewind — Rewinds the iterator

Descripción

public TokyoTyrantIterator::rewind ( ) : void

Rewinds the iterator for new iteration. Called automatically at the beginning of foreach.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Throws TokyoTyrantException if iterator initialization fails.

Ver también

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind()


Rewinds the iterator

  • « TokyoTyrantIterator::rewind
  • TokyoTyrantException »
  • PHP Manual
  • TokyoTyrantIterator
  • Rewinds the iterator

TokyoTyrantIterator::valid

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::valid — Rewinds the iterator

Descripción

public TokyoTyrantIterator::valid ( ) : bool

Checks whether the internal pointer points to valid element.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the current item is valid and false if not.

Ver también

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


The TokyoTyrantException class

(PECL tokyo_tyrant >= 0.1.0)

Introducción

TokyoTyrantException

Sinopsis de la Clase

tokyotyrantexception extends Exception {
/* Propiedades */
protected int $code ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

code

The exception code. This can be compared to TokyoTyrant::TTE_* constants


Extensiones relacionadas con fecha y hora

  • Calendario
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Calendario
  • Fecha/Hora — Fecha y Hora
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • DateTime — La clase DateTime
    • DateTimeImmutable — La clase DateTimeImmutable
    • DateTimeInterface — La interfaz DateTimeInterface
    • DateTimeZone — La clase DateTimeZone
    • DateInterval — La clase DateInterval
    • DatePeriod — La clase DatePeriod
    • Funciones de Fecha/Hora
    • Formatos de fecha y hora admitidos
    • Listado de zonas horarias admitidas
  • HRTime — HRTime - Medición del tiempo en alta resolución
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • HRTime\PerformanceCounter — La clase HRTime\PerformanceCounter
    • HRTime\StopWatch — La clase HRTime\StopWatch
    • HRTime\Unit — La clase HRTime\Unit


Calendario

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Calendario
    • cal_days_in_month — Devolver el número de días de un mes para un año y un calendario dados
    • cal_from_jd — Convierte de una Fecha Juliana a un calendario soportado
    • cal_info — Devuelve información sobre un calendario en particular
    • cal_to_jd — Convertir un calendario soportado a la Fecha Juliana
    • easter_date — Obtener la fecha Unix para la medianoche de Pascua de un año dado
    • easter_days — Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado
    • frenchtojd — Convierte una fecha del Calendario Republicano Francés a una fecha Juliana
    • gregoriantojd — Convierte una fecha Gregoriana en Fecha Juliana
    • jddayofweek — Devuelve el día de la semana
    • jdmonthname — Devuelve el nombre de un mes
    • jdtofrench — Convierte una Fecha Juliana al Calendario Republicano Francés
    • jdtogregorian — Convierte una Fecha Juliana en una fecha Gregoriana
    • jdtojewish — Convierte una Fecha Juliana a una fecha del Calendario Judío
    • jdtojulian — Convierte una Fecha Juliana a una fecha del Calendario Juliano
    • jdtounix — Convierte una Fecha Juliana a una fecha Unix
    • jewishtojd — Convierte una fecha del Calendario Judío a una Fecha Juliana
    • juliantojd — Convierte una fecha del Calendario Juliano a una Fecha Juliana
    • unixtojd — Convertir una fecha Unix en una Fecha Juliana


Introducción

La extensión Calendario presenta una serie de funciones para simplificar la conversión entre diferentes formatos de calendario. El intermediario o estádar está basado en la Fecha Juliana. La Fecha Juliana es una cuenta de días comenzando desde el 1 de Enero del 4713 A.C. Para hacer la conversión entre sistemas de calendario, primero debe convertir a la Fecha Juliana, y después al sistema de calendario de su elección. ¡La Fecha Juliana es muy diferente del Calendario Juliano! Para más información sobre la Fecha Juliana, visite » http://www.hermetic.ch/cal_stud/jdn.htm. Para más información sobre sistemas de calendario visite » http://www.fourmilab.ch/documents/calendar/. Los extractos de esta página están incluidos en estas instrucciones, y están entrecomillados.


Instalación

Para que estas funciones estén disponibles tiene que compilar PHP con --enable-calendar.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

CAL_GREGORIAN (integer)
CAL_JULIAN (integer)
CAL_JEWISH (integer)
CAL_FRENCH (integer)
CAL_NUM_CALS (integer)
CAL_DOW_DAYNO (integer)
CAL_DOW_SHORT (integer)
CAL_DOW_LONG (integer)
CAL_MONTH_GREGORIAN_SHORT (integer)
CAL_MONTH_GREGORIAN_LONG (integer)
CAL_MONTH_JULIAN_SHORT (integer)
CAL_MONTH_JULIAN_LONG (integer)
CAL_MONTH_JEWISH (integer)
CAL_MONTH_FRENCH (integer)

Las siguientes constantes están disponibles desde PHP 4.3.0 :

CAL_EASTER_DEFAULT (integer)
CAL_EASTER_ROMAN (integer)
CAL_EASTER_ALWAYS_GREGORIAN (integer)
CAL_EASTER_ALWAYS_JULIAN (integer)

Las siguientes constantes están disponibles desde PHP 5.0.0 :

CAL_JEWISH_ADD_ALAFIM_GERESH (integer)
CAL_JEWISH_ADD_ALAFIM (integer)
CAL_JEWISH_ADD_GERESHAYIM (integer)


Funciones de Calendario

Tabla de contenidos

  • cal_days_in_month — Devolver el número de días de un mes para un año y un calendario dados
  • cal_from_jd — Convierte de una Fecha Juliana a un calendario soportado
  • cal_info — Devuelve información sobre un calendario en particular
  • cal_to_jd — Convertir un calendario soportado a la Fecha Juliana
  • easter_date — Obtener la fecha Unix para la medianoche de Pascua de un año dado
  • easter_days — Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado
  • frenchtojd — Convierte una fecha del Calendario Republicano Francés a una fecha Juliana
  • gregoriantojd — Convierte una fecha Gregoriana en Fecha Juliana
  • jddayofweek — Devuelve el día de la semana
  • jdmonthname — Devuelve el nombre de un mes
  • jdtofrench — Convierte una Fecha Juliana al Calendario Republicano Francés
  • jdtogregorian — Convierte una Fecha Juliana en una fecha Gregoriana
  • jdtojewish — Convierte una Fecha Juliana a una fecha del Calendario Judío
  • jdtojulian — Convierte una Fecha Juliana a una fecha del Calendario Juliano
  • jdtounix — Convierte una Fecha Juliana a una fecha Unix
  • jewishtojd — Convierte una fecha del Calendario Judío a una Fecha Juliana
  • juliantojd — Convierte una fecha del Calendario Juliano a una Fecha Juliana
  • unixtojd — Convertir una fecha Unix en una Fecha Juliana


Devolver el número de días de un mes para un año y un calendario dados

  • « Funciones de Calendario
  • cal_from_jd »
  • PHP Manual
  • Funciones de Calendario
  • Devolver el número de días de un mes para un año y un calendario dados

cal_days_in_month

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_days_in_month — Devolver el número de días de un mes para un año y un calendario dados

Descripción

cal_days_in_month ( int $calendar , int $month , int $year ) : int

Esta función devolverá el número de días del mes month del año year para el calendario calendar especificado.

Parámetros

calendar

El calendario que se va a usar para el cálculo

month

El mes del calendario seleccionado

year

El año del calendario seleccionado

Valores devueltos

La longitud en días del mes seleccionado en el calendario dado.

Ejemplos

Ejemplo #1 Ejemplo de cal_days_in_month()

<?php
$número = cal_days_in_month(CAL_GREGORIAN, 8, 2003); // 31
echo "Hubo {$número} días en agosto del 2003";
?>


Convierte de una Fecha Juliana a un calendario soportado

  • « cal_days_in_month
  • cal_info »
  • PHP Manual
  • Funciones de Calendario
  • Convierte de una Fecha Juliana a un calendario soportado

cal_from_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_from_jd — Convierte de una Fecha Juliana a un calendario soportado

Descripción

cal_from_jd ( int $jd , int $calendar ) : array

cal_from_jd() convierte el día juliano dado en jd a una fecha del calendario calendar. Los valores soportados por calendar son CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH y CAL_FRENCH.

Parámetros

jd

Un día juliano como un entero

calendar

El calendario al que se va a convertir

Valores devueltos

Devuelve una matriz que contiene información del calendario como el mes, día, año, día de la semana, nombres abreviados y completos del día de la semana y mes y la fecha como cadena de la forma "mes/día/año".

Ejemplos

Ejemplo #1 Ejemplo de cal_from_jd()

<?php
$hoy = unixtojd(mktime(0, 0, 0, 8, 16, 2003));
print_r(cal_from_jd($hoy, CAL_GREGORIAN));
?>

El resultado del ejemplo sería:

Array
(
    [date] => 8/16/2003
    [month] => 8
    [day] => 16
    [year] => 2003
    [dow] => 6
    [abbrevdayname] => Sat
    [dayname] => Saturday
    [abbrevmonth] => Aug
    [monthname] => August
)

Ver también

  • cal_to_jd() - Convertir un calendario soportado a la Fecha Juliana
  • jdtofrench() - Convierte una Fecha Juliana al Calendario Republicano Francés
  • jdtogregorian() - Convierte una Fecha Juliana en una fecha Gregoriana
  • jdtojewish() - Convierte una Fecha Juliana a una fecha del Calendario Judío
  • jdtojulian() - Convierte una Fecha Juliana a una fecha del Calendario Juliano
  • jdtounix() - Convierte una Fecha Juliana a una fecha Unix


Devuelve información sobre un calendario en particular

  • « cal_from_jd
  • cal_to_jd »
  • PHP Manual
  • Funciones de Calendario
  • Devuelve información sobre un calendario en particular

cal_info

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_info — Devuelve información sobre un calendario en particular

Descripción

cal_info ( int $calendar = -1 ) : array

cal_info() devuelve información sobre el calendario calendar especificado.

La información del calendario es devuelta como una matriz que contiene los elementos calname, calsymbol, month, abbrevmonth y maxdaysinmonth. Los nombre de los diferentes calendarios que se pueden usar en calendar son los siguientes:

  • 0 o CAL_GREGORIAN - Calendario Gregoriano
  • 1 o CAL_JULIAN - Calendario Juliano
  • 2 o CAL_JEWISH - Calendario Judío
  • 3 o CAL_FRENCH - Calendario Republicano Francés

Si no se especifica calendar la información de todos los calendarios soportados es devuelta como un matriz.

Parámetros

calendar

El calendario del que se va a devolver la información. Si no se especifica ningún calendario se devolverá la información sobre todos los calendarios.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de cal_info()

<?php
$info = cal_info(0);
print_r($info);
?>

El resultado del ejemplo sería:

Array
(
    [months] => Array
        (
            [1] => January
            [2] => February
            [3] => March
            [4] => April
            [5] => May
            [6] => June
            [7] => July
            [8] => August
            [9] => September
            [10] => October
            [11] => November
            [12] => December
        )

    [abbrevmonths] => Array
        (
            [1] => Jan
            [2] => Feb
            [3] => Mar
            [4] => Apr
            [5] => May
            [6] => Jun
            [7] => Jul
            [8] => Aug
            [9] => Sep
            [10] => Oct
            [11] => Nov
            [12] => Dec
        )

    [maxdaysinmonth] => 31
    [calname] => Gregorian
    [calsymbol] => CAL_GREGORIAN
)


Convertir un calendario soportado a la Fecha Juliana

  • « cal_info
  • easter_date »
  • PHP Manual
  • Funciones de Calendario
  • Convertir un calendario soportado a la Fecha Juliana

cal_to_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_to_jd — Convertir un calendario soportado a la Fecha Juliana

Descripción

cal_to_jd ( int $calendar , int $month , int $day , int $year ) : int

cal_to_jd() calcula la Fecha Juliana para una fecha en el calendario calendar especificado. Los calendarios calendar soportados son CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH y CAL_FRENCH.

Parámetros

calendar

El calendario desde el que se va a hacer la conversión, CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH o CAL_FRENCH.

month

El mes como número, el rango válido depende de calendar

day

El día como número, el rango válido depende de calendar

year

El año como número, el rango válido depende de calendar

Valores devueltos

Un número de día de la Fecha Juliana.

Ver también

  • cal_from_jd() - Convierte de una Fecha Juliana a un calendario soportado
  • frenchtojd() - Convierte una fecha del Calendario Republicano Francés a una fecha Juliana
  • gregoriantojd() - Convierte una fecha Gregoriana en Fecha Juliana
  • jewishtojd() - Convierte una fecha del Calendario Judío a una Fecha Juliana
  • juliantojd() - Convierte una fecha del Calendario Juliano a una Fecha Juliana
  • unixtojd() - Convertir una fecha Unix en una Fecha Juliana


Obtener la fecha Unix para la medianoche de Pascua de un año dado

  • « cal_to_jd
  • easter_days »
  • PHP Manual
  • Funciones de Calendario
  • Obtener la fecha Unix para la medianoche de Pascua de un año dado

easter_date

(PHP 4, PHP 5, PHP 7, PHP 8)

easter_date — Obtener la fecha Unix para la medianoche de Pascua de un año dado

Descripción

easter_date ( int $year = date("Y") , int $method = CAL_EASTER_DEFAULT ) : int

Devuelve la fecha Unix correspondiente a la medianoche de Pascua del año dado.

Advertencia

Esta función generará una advertencia si el año está fuera del rango de fechas Unix (es decir típicamente, antes de 1970 o después de 2037 en sistemas 32 bits).

La fecha del Domingo de Pascua fue definida por el Concilio de Nicea en el año 325 D.C. como el domingo después de la primera luna llena que cae en o después del Equinocio de Primavera. El equinocio se asume que cae en el 21 de marzo, por lo que el cálculo se reduce a determinar la fecha de la luna llena y la fecha del siguiente domingo. El algoritmo que se usa aquí fue introducido alrededor del año 532 por Dionisio el Exiguo. Bajo el Calendario Juliano (para años anteriores a 1753) se usa un simple ciclo de 19 años para rastrear las fases de la luna. Bajo el Calendario Gregoriano (para años posteriores a 1753 - concebido por Clavio y Lilio, e introducido por el papa Gregorio XIII en Octubre de 1582, e introducido en Gran Bretaña y sus colonias en Septiembre de 1752) se añadieron dos factores de corrección para hacer el ciclo más exacto.

Parámetros

year

El año como un número entre 1970 y 2037. Si se omite, el valor predeterminado será el del año actual según la hora local.

method

Permite que las fechas de Pascua se calculen en base al calendario Juliano cuando se establece para CAL_EASTER_ALWAYS_JULIAN. véase también constantes de calendario.

Valores devueltos

El Domingo de Pascua como fecha Unix.

Ejemplos

Ejemplo #1 Ejemplo de easter_date()

<?php

echo date("M-d-Y", easter_date(1999));        // Apr-04-1999
echo date("M-d-Y", easter_date(2000));        // Apr-23-2000
echo date("M-d-Y", easter_date(2001));        // Apr-15-2001

?>

Notas

Nota:

easter_date() depende de las función de hora en C de su sistema en vez de usar las funciones de fecha y hora internas de PHP. Como consecuencia, easter_date() utiliza la variable de entorno TZ para determinar la zona horaria en la que debería operar, en lugar de usar la zona horaria predeterminada de PHP, la cual podría resultar en un comportamiento inesperado al usar esta función junto con otras funciones de fecha de PHP.

Como atajo, se puede usar easter_days() con DateTime y DateInterval para calcular el inico de la Semana Santa en la zona horario de su PHP como sigue:

<?php
function get_easter_datetime($año) {
    $base = new DateTime("$año-03-21");
    $días = easter_days($año);

    return $base->add(new DateInterval("P{$días}D"));
}

foreach (range(2012, 2015) as $año) {
    printf("La Semana Santa del %d cae en %s\n",
           $año,
           get_easter_datetime($año)->format('F j'));
}
?>

El resultado del ejemplo sería:

La Semana Santa del 2012 cae en April 8
La Semana Santa del 2013 cae en March 31
La Semana Santa del 2014 cae en April 20
La Semana Santa del 2015 cae en April 5

Ver también

  • easter_days() - Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado para calcular la Pascua antes de 1970 o después de 2037


Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado

  • « easter_date
  • frenchtojd »
  • PHP Manual
  • Funciones de Calendario
  • Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado

easter_days

(PHP 4, PHP 5, PHP 7, PHP 8)

easter_days — Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado

Descripción

easter_days ( int $year = date("Y") , int $method = CAL_EASTER_DEFAULT ) : int

Obtiene el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado. Si no se especifica el año, se asume el año actual.

Esta función se puede usar en vez de easter_date() para calcular cuándo cae Pascua para años fuera del rango de fechas Unix (esto es, antes de 1970 o después de 2037).

La fecha del Domiongo de Pascua fue definida por el Concilio de Nicea en el año 325 D.C. como el domingo después de la primera luna llena que cae en o después del Equinocio de Primavera. El equinocio se asume que cae en el 21 de marzo, por lo que el cálculo se reduce a determinar la fecha de la luna llena y la fecha del siguiente domingo. El algoritmo que se usa aquí fue introducido alrededor del año 532 por Dionisio el Exiguo. Bajo el Calendario Juliano (para años anteriores a 1753) se usa un simple ciclo de 19 años para rastrear las fases de la luna. Bajo el Calendario Gregoriano (para años posteriores a 1753 - concebido por Clavio y Lilio, e introducido por el papa Gregorio XIII en Octubre de 1582, e introducido en Gran Bretaña y sus colonias en Septiembre de 1752) se añadieron dos factores de corrección para hacer el ciclo más exacto.

Parámetros

year

El año como un número positivo. Si se omite, el valor predeterminado será el del año actual según la hora local.

method

Permite calcular las fechas de Pascua basadas en el calendario Gregoriano durante los años 1582 - 1752 cuando se establece a CAL_EASTER_ROMAN. Vea las constantes de calendario para más constantes válidas.

Valores devueltos

El número de días después del 21 de marzo en el que cae el Domingo de Pascua para el año year dado.

Ejemplos

Ejemplo #1 Ejemplo de easter_days()

<?php

echo easter_days(1999);        // 14, esto es, 4 de abril
echo easter_days(1492);        // 32, esto es, 22 de abril
echo easter_days(1913);        //  2, esto es, 23 de marzo

?>

Ver también

  • easter_date() - Obtener la fecha Unix para la medianoche de Pascua de un año dado


Convierte una fecha del Calendario Republicano Francés a una fecha Juliana

  • « easter_days
  • gregoriantojd »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una fecha del Calendario Republicano Francés a una fecha Juliana

frenchtojd

(PHP 4, PHP 5, PHP 7, PHP 8)

frenchtojd — Convierte una fecha del Calendario Republicano Francés a una fecha Juliana

Descripción

frenchtojd ( int $month , int $day , int $year ) : int

Convierte una fecha del Calendario Republicano Francés a una fecha Juliana.

Estas rutinas sólamente convierten fechas de los años 1 al 14 (fechas gregorianas desde el 22 de septiembre de 1792 hasta el 22 de septiembre de 1806). Esto cubre con creces el periodo cuando el calendario estaba en uso.

Parámetros

month

El mes como un número desde 1 (para Vendémiaire) hasta 13 (para el periodo de 5-6 días al final de cada año)

day

El día como un número de 1 a 30

year

El año como un número entre 1 y 14

Valores devueltos

La fecha Juliana para la fecha de la Revolución Francesa dada como un entero.

Ver también

  • jdtofrench() - Convierte una Fecha Juliana al Calendario Republicano Francés
  • cal_to_jd() - Convertir un calendario soportado a la Fecha Juliana


Convierte una fecha Gregoriana en Fecha Juliana

  • « frenchtojd
  • jddayofweek »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una fecha Gregoriana en Fecha Juliana

gregoriantojd

(PHP 4, PHP 5, PHP 7, PHP 8)

gregoriantojd — Convierte una fecha Gregoriana en Fecha Juliana

Descripción

gregoriantojd ( int $month , int $day , int $year ) : int

El rango válido para el Calendario Gregoriano es de 4714 A.C. a 9999 D.C.

Aunque esta función puede manejar fechas que se remontan hasta 4714 A.C., tal uso puede no ser significativo. El calendario Gregoriano no fue establecido hasta el 15 de octubre de 1582 (o 5 de octubre de 1582 el el calendario Juliano). Algunos países no lo aceptaron hasta mucho más tarde. Por ejemplo, Gran Bretaña lo adoptó en 1752, la URSS en 1918 y Grecia en 1923. La mayoría de los países europeos usaban el calendario Juliano antes del Gregoriano.

Parámetros

month

El mes como un número desde 1 (para enero) hasta 12 (para diciembre)

day

El día como un número desde 1 a 31

year

El año como un número entre -4714 y 9999

Valores devueltos

La Fecha Juliana para la fecha gregoriana dada como un entero.

Ejemplos

Ejemplo #1 Funciones de calendario

<?php
$jd = GregorianToJD(10, 11, 1970);
echo "$jd\n";
$gregoriano = JDToGregorian($jd);
echo "$gregoriano\n";
?>

Ver también

  • jdtogregorian() - Convierte una Fecha Juliana en una fecha Gregoriana
  • cal_to_jd() - Convertir un calendario soportado a la Fecha Juliana


Devuelve el día de la semana

  • « gregoriantojd
  • jdmonthname »
  • PHP Manual
  • Funciones de Calendario
  • Devuelve el día de la semana

jddayofweek

(PHP 4, PHP 5, PHP 7, PHP 8)

jddayofweek — Devuelve el día de la semana

Descripción

jddayofweek ( int $julianday , int $mode = CAL_DOW_DAYNO ) : mixed

Devuelve el día de la semana. Puede devolver una cadena o un entero dependiendo del modo.

Parámetros

julianday

Un número de día juliano como un entero

mode
Modos de semana de calendario
Modo | Significado
0 (Por defecto) | Devuelve el número de día como un entero (0=domingo, 1=lunes, etc.)
1 | Devuelve una cadena que contiene el día de la semana (Inglés-Gregoriano)
2 | Devuelve una cadena que contiene el día de la semana abreviado (Inglés-Gregoriano)

Valores devueltos

El día de la semada gregoriana como un entero o cadena.


Devuelve el nombre de un mes

  • « jddayofweek
  • jdtofrench »
  • PHP Manual
  • Funciones de Calendario
  • Devuelve el nombre de un mes

jdmonthname

(PHP 4, PHP 5, PHP 7, PHP 8)

jdmonthname — Devuelve el nombre de un mes

Descripción

jdmonthname ( int $julianday , int $mode ) : string

Devuelve una cadena que contiene el nombre del mes. mode le indica a esta función a qué calendario va a ser convertido la Fecha Juliana, y qué tipo de nombres de meses son devueltos.

Calendar modes
Modo | Significado | Valores
0 | Gregoriano - abreviado | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
1 | Gregoriano | January, February, March, April, May, June, July, August, September, October, November, December
2 | Juliano - abreviado | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
3 | Juliano | January, February, March, April, May, June, July, August, September, October, November, December
4 | Judío | Tishri, Heshvan, Kislev, Tevet, Shevat, AdarI, AdarII, Nisan, Iyyar, Sivan, Tammuz, Av, Elul
5 | Republicano Francés | Vendemiaire, Brumaire, Frimaire, Nivose, Pluviose, Ventose, Germinal, Floreal, Prairial, Messidor, Thermidor, Fructidor, Extra

Parámetros

jday

La Fecha Juliana que se va a manejar

calendar

El calendario del que se va a tomar el nombre del mes

Valores devueltos

El nombre del mes de la Fecha Juliana y del calendario calendar dados.


Convierte una Fecha Juliana al Calendario Republicano Francés

  • « jdmonthname
  • jdtogregorian »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una Fecha Juliana al Calendario Republicano Francés

jdtofrench

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtofrench — Convierte una Fecha Juliana al Calendario Republicano Francés

Descripción

jdtofrench ( int $juliandaycount ) : string

Convierte una Fecha Juliana al Calendario Republicano Francés.

Parámetros

julianday

Una número de día juliano como un entero

Valores devueltos

La fecha de la Revolución Francesa como una cadena de la forma "mes/día/año"

Ver también

  • frenchtojd() - Convierte una fecha del Calendario Republicano Francés a una fecha Juliana
  • cal_from_jd() - Convierte de una Fecha Juliana a un calendario soportado


Convierte una Fecha Juliana en una fecha Gregoriana

  • « jdtofrench
  • jdtojewish »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una Fecha Juliana en una fecha Gregoriana

jdtogregorian

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtogregorian — Convierte una Fecha Juliana en una fecha Gregoriana

Descripción

jdtogregorian ( int $julianday ) : string

Convierte una Fecha Juliana a una cadena que contiene la fecha Gregoriana con el formato "mes/día/año".

Parámetros

julianday

Un número de día juliano como un entero

Valores devueltos

La fecha gregoriana como una cadena de la forma "mes/día/año"

Ver también

  • gregoriantojd() - Convierte una fecha Gregoriana en Fecha Juliana
  • cal_from_jd() - Convierte de una Fecha Juliana a un calendario soportado


Convierte una Fecha Juliana a una fecha del Calendario Judío

  • « jdtogregorian
  • jdtojulian »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una Fecha Juliana a una fecha del Calendario Judío

jdtojewish

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtojewish — Convierte una Fecha Juliana a una fecha del Calendario Judío

Descripción

jdtojewish ( int $juliandaycount , bool $hebrew = false , int $fl = 0 ) : string

Convierte una Fecha Juliana al Calendario Judío.

Parámetros

julianday

Un número de día juliano como un entero

hebrew

Si el parámetro hebrew está establecido a true, el parámetro fl se usa para el formato de salida, basado en cadena, Hebreo.

fl

Los formatos disponibles son: CAL_JEWISH_ADD_ALAFIM_GERESH, CAL_JEWISH_ADD_ALAFIM, CAL_JEWISH_ADD_GERESHAYIM.

Valores devueltos

La fecha judía como una cadena de la forma "mes/día/año"

Ejemplos

Ejemplo #1 Ejemplo de jdtojewish()

<?php
echo jdtojewish(gregoriantojd(10, 8, 2002), true,
       CAL_JEWISH_ADD_GERESHAYIM + CAL_JEWISH_ADD_ALAFIM + CAL_JEWISH_ADD_ALAFIM_GERESH);
?>

Ver también

  • jewishtojd() - Convierte una fecha del Calendario Judío a una Fecha Juliana
  • cal_from_jd() - Convierte de una Fecha Juliana a un calendario soportado


Convierte una Fecha Juliana a una fecha del Calendario Juliano

  • « jdtojewish
  • jdtounix »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una Fecha Juliana a una fecha del Calendario Juliano

jdtojulian

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtojulian — Convierte una Fecha Juliana a una fecha del Calendario Juliano

Descripción

jdtojulian ( int $julianday ) : string

Convierte una Fecha Juliana a una cadena que contiene la fecha del Calendario Juliano con el formato "mes/día/año".

Parámetros

julianday

Un número de día juliano como un entero

Valores devueltos

La fecha del calendario juliano como una cadena de la forma "mes/día/año"

Ver también

  • juliantojd() - Convierte una fecha del Calendario Juliano a una Fecha Juliana
  • cal_from_jd() - Convierte de una Fecha Juliana a un calendario soportado


Convierte una Fecha Juliana a una fecha Unix

  • « jdtojulian
  • jewishtojd »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una Fecha Juliana a una fecha Unix

jdtounix

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtounix — Convierte una Fecha Juliana a una fecha Unix

Descripción

jdtounix ( int $jday ) : int

Esta funcion devolverá una fecha Unix correspondiente a la Fecha Juliana dada en jday o false si jday no está dentro de la época Unix (años gregorianos entre 1970 y 2037 o 2440588 <= jday <= 2465342 ). El momento devuleto es como hora local (y no GMT).

Parámetros

jday

Un número de día juliano entre 2440588 y 2465342.

Valores devueltos

La fecha Unix para el comienzo de la Fecha Juliana dada.

Ver también

  • unixtojd() - Convertir una fecha Unix en una Fecha Juliana


Convierte una fecha del Calendario Judío a una Fecha Juliana

  • « jdtounix
  • juliantojd »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una fecha del Calendario Judío a una Fecha Juliana

jewishtojd

(PHP 4, PHP 5, PHP 7, PHP 8)

jewishtojd — Convierte una fecha del Calendario Judío a una Fecha Juliana

Descripción

jewishtojd ( int $month , int $day , int $year ) : int

Aunque esta función puede manejar fechas que se remontan hasta el año 1 (3761 A.C.), tal uso puede no ser significativo. El calendario judío ha estado en uso desde varios cientos de años, pero en los primeros días no había una fórmula para determinar el inicio del un mes. Un nuevo mes comenzaba cuando se observaba la primera luna nueva.

Parámetros

month

El mes como un número de 1 a 13

day

El día como un número de 1 a 30

year

El año como un número entre 1 y 9999

Valores devueltos

La Fecha Juliana para la fecha judía dada como un entero.

Ver también

  • jdtojewish() - Convierte una Fecha Juliana a una fecha del Calendario Judío
  • cal_to_jd() - Convertir un calendario soportado a la Fecha Juliana


Convierte una fecha del Calendario Juliano a una Fecha Juliana

  • « jewishtojd
  • unixtojd »
  • PHP Manual
  • Funciones de Calendario
  • Convierte una fecha del Calendario Juliano a una Fecha Juliana

juliantojd

(PHP 4, PHP 5, PHP 7, PHP 8)

juliantojd — Convierte una fecha del Calendario Juliano a una Fecha Juliana

Descripción

juliantojd ( int $month , int $day , int $year ) : int

El rango válido para el Calendario Juliano es desde 4713 A.C. a 9999 D.C.

Aunque esta función puede manejar fechas que se remontan hasta 4713 A.C., tal uso puede no ser significativo. El calendario fue creado en el 46 A.C., pero los detalles no se estabilizaron hasta al menos el 8 D.C., y quizás hasta el siglo IV tardío. También, el comienzo de un año variaba de una cultura a otra - no todas aceptaron enero como el primer mes.

Precaución

Recuerde, el sistema de calendario actual que se usa mundialmente es el Calendario Gregoriano. gregoriantojd() se puede usar para convertir tales fechas a sus Fechas Julianas.

Parámetros

month

El mes como un número de 1 (para enero) a 12 (para diecienbre)

day

El día como un número de 1 a 31

year

El año como un número entre -4713 y 9999

Valores devueltos

La Fecha Juliana para la fecha del Calendario Juliano dado como un entero.

Ver también

  • jdtojulian() - Convierte una Fecha Juliana a una fecha del Calendario Juliano
  • cal_to_jd() - Convertir un calendario soportado a la Fecha Juliana


Convertir una fecha Unix en una Fecha Juliana

  • « juliantojd
  • Fecha/Hora »
  • PHP Manual
  • Funciones de Calendario
  • Convertir una fecha Unix en una Fecha Juliana

unixtojd

(PHP 4, PHP 5, PHP 7, PHP 8)

unixtojd — Convertir una fecha Unix en una Fecha Juliana

Descripción

unixtojd ( int $timestamp = time() ) : int

Devuelve la Fecha Juliana para la fecha timestamp Unix (segundos desde 1.1.1970), o el día actual si timestamp no es dado.

Parámetros

timestamp

Una fecha unix a convertir.

Valores devueltos

Un número de día juliano como un entero.

Ver también

  • jdtounix() - Convierte una Fecha Juliana a una fecha Unix


Fecha y Hora

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Aritmética de DateTime
  • DateTime — La clase DateTime
    • DateTime::add — Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
    • DateTime::__construct — Devuelve un nuevo objeto DateTime
    • DateTime::createFromFormat — Analiza una cadena con un instante según un formato especificado
    • DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object
    • DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object
    • DateTime::getLastErrors — Devuelve las advertencias y los errores
    • DateTime::modify — Altera la marca temporal
    • DateTime::__set_state — El gestor __set_state
    • DateTime::setDate — Establece la fecha
    • DateTime::setISODate — Establece la fecha ISO
    • DateTime::setTime — Establece la hora
    • DateTime::setTimestamp — Establece la fecha y la hora basándose en una marca temporal de Unix
    • DateTime::setTimezone — Establece la zona horaria para el objeto DateTime
    • DateTime::sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime
  • DateTimeImmutable — La clase DateTimeImmutable
    • DateTimeImmutable::add — Añade una cantidad de días, meses, años, horas, minutos y segundos
    • DateTimeImmutable::__construct — Devuelve un nuevo objeto DateTimeImmutable
    • DateTimeImmutable::createFromFormat — Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado
    • DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
    • DateTimeImmutable::createFromMutable — Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado
    • DateTimeImmutable::getLastErrors — Devuelve las advertencias y errores
    • DateTimeImmutable::modify — Crea un nuevo objeto con la marca de tiempo modificada
    • DateTimeImmutable::__set_state — El gestor __set_state
    • DateTimeImmutable::setDate — Establece la fecha
    • DateTimeImmutable::setISODate — Establece la fecha ISO
    • DateTimeImmutable::setTime — Establece la hora
    • DateTimeImmutable::setTimestamp — Establece la fecha y hora basadas en una marca de tiempo Unix
    • DateTimeImmutable::setTimezone — Establece la zona horaria
    • DateTimeImmutable::sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos
  • DateTimeInterface — La interfaz DateTimeInterface
    • DateTime::diff — Devuelve la diferencia entre dos objetos DateTime
    • DateTime::format — Devuelve la fecha formateada según el formato dado
    • DateTime::getOffset — Devuelve el índice de la zona horaria
    • DateTime::getTimestamp — Obtiene la marca de tiempo Unix
    • DateTime::getTimezone — Develve la zona horaria relativa al objeto DateTime dado
    • DateTime::__wakeup — El gestor __wakeup
  • DateTimeZone — La clase DateTimeZone
    • DateTimeZone::__construct — Crea un nuevo objeto DateTimeZone
    • DateTimeZone::getLocation — Devuelve la información de la ubicación para una zona horaria
    • DateTimeZone::getName — Devuelve el nombre de la zona horaria
    • DateTimeZone::getOffset — Devuelve el índice de la zona horaria de GMT
    • DateTimeZone::getTransitions — Devuelve todas las transiciones para una zona horaria
    • DateTimeZone::listAbbreviations — Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria
    • DateTimeZone::listIdentifiers — Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos
  • DateInterval — La clase DateInterval
    • DateInterval::__construct — Crea un nuevo objeto DateInterval
    • DateInterval::createFromDateString — Establece un objeto DateInterval desde las partes relativas de una cadena
    • DateInterval::format — Formatea el intervalo
  • DatePeriod — La clase DatePeriod
    • DatePeriod::__construct — Crea un nuevo objeto DatePeriod
    • DatePeriod::getDateInterval — Obtener el intervalo
    • DatePeriod::getEndDate — Obtener la fecha final
    • DatePeriod::getRecurrences — Gets the number of recurrences
    • DatePeriod::getStartDate — Obtener la fecha inicial
  • Funciones de Fecha/Hora
    • checkdate — Validar una fecha gregoriana
    • date_add — Alias de DateTime::add
    • date_create_from_format — Alias de DateTime::createFromFormat
    • date_create_immutable_from_format — Alias de DateTimeImmutable::createFromFormat
    • date_create_immutable — Alias de DateTimeImmutable::__construct
    • date_create — Alias de DateTime::__construct
    • date_date_set — Alias de DateTime::setDate
    • date_default_timezone_get — Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
    • date_default_timezone_set — Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
    • date_diff — Alias de DateTime::diff
    • date_format — Alias de DateTime::format
    • date_get_last_errors — Alias de DateTime::getLastErrors
    • date_interval_create_from_date_string — Alias de DateInterval::createFromDateString
    • date_interval_format — Alias de DateInterval::format
    • date_isodate_set — Alias de DateTime::setISODate
    • date_modify — Alias de DateTime::modify
    • date_offset_get — Alias de DateTime::getOffset
    • date_parse_from_format — Obtiene información de una fecha dada formateada de acuerdo al formato especificado
    • date_parse — Devuelve un array asociativo con información detallada acerca de una fecha dada
    • date_sub — Alias de DateTime::sub
    • date_sun_info — Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo
    • date_sunrise — Devuelve la hora de la salida del sol de un día y ubicación dados
    • date_sunset — Devuelve la hora de la puesta de sol de un día y ubicación dados
    • date_time_set — Alias de DateTime::setTime
    • date_timestamp_get — Alias de DateTime::getTimestamp
    • date_timestamp_set — Alias de DateTime::setTimestamp
    • date_timezone_get — Alias de DateTime::getTimezone
    • date_timezone_set — Alias de DateTime::setTimezone
    • date — Dar formato a la fecha/hora local
    • getdate — Obtener información de la fecha/hora
    • gettimeofday — Obtener la hora actual
    • gmdate — Formatea una fecha/hora GMT/UTC
    • gmmktime — Obtener la marca temporal de Unix para una fecha GMT
    • gmstrftime — Formatear una fecha/hora GMT/UTC según la configuración local
    • idate — Formatea una fecha/hora local como un entero
    • localtime — Obtiene fecha y hora local
    • microtime — Devuelve la fecha Unix actual con microsegundos
    • mktime — Obtener la marca de tiempo Unix de una fecha
    • strftime — Formatea una fecha/hora local según una configuración local
    • strptime — Analiza una fecha/hora generada con strftime
    • strtotime — Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix
    • time — Devuelve la fecha Unix actual
    • timezone_abbreviations_list — Alias de DateTimeZone::listAbbreviations
    • timezone_identifiers_list — Alias de DateTimeZone::listIdentifiers
    • timezone_location_get — Alias de DateTimeZone::getLocation
    • timezone_name_from_abbr — Devuelve el nombre de la zona horaria desde su abreviatura
    • timezone_name_get — Alias de DateTimeZone::getName
    • timezone_offset_get — Alias de DateTimeZone::getOffset
    • timezone_open — Alias de DateTimeZone::__construct
    • timezone_transitions_get — Alias de DateTimeZone::getTransitions
    • timezone_version_get — Obtiene la versión de la base de datos timezonedb
  • Formatos de fecha y hora admitidos
    • Formatos de Hora
    • Formatos de fecha
    • Formatos compuestos
    • Formatos relativos
  • Listado de zonas horarias admitidas
    • África
    • América
    • Antártida
    • Ártico
    • Asia
    • Atlántico
    • Australia
    • Europa
    • India
    • Pacífico
    • Otros


Introducción

Estas funciones permiten obtener la fecha y la hora del servidor donde se están ejecutando los scripts de PHP. Estas funciones se pueden emplear parar dar formato a fechas y horas de muchas maneras diferentes.

La información de la fecha y de la hora se almacena internamente como un número de 64 bits, por lo que se admiten todas las fechas útiles posibles (incluyendo años negativos). El rango va aproximadamente de 292 mil millones de años en el pasado hasta lo mismo en el futuro.

Nota: Se ha de tener en cuenta que estas funciones dependen de los ajustes de la configuración regional del servidor. Asegúrese de tomar en consideración el horario de verano (use, p.ej., $fecha = strtotime('+7 days', $fecha), y no $fecha += 7*24*60*60) y los años bisiestos cuando trabaje con estas funciones.

Nota: Las zonas horarias a las que se refiere esta sección pueden encontrarse en el Listado de zonas horarias admitidas.


Instalación

No se requiere de ninguna instalación para utilizar estas funciones; forman parte del núcleo de PHP.

Nota: Obtener la última base de datos de zonas horarias

La última versión de la base de datos de zonas horarias se puede instalar mediante la base de datos » timezonedb de PECL.

Nota: Soporte experimental para DateTime en PHP 5.1.x

Aunque la clase DateTime (y sus funciones relacionadas) están habilitadas por defecto desde PHP 5.2.0, es posible añadir un soporte experimental en PHP 5.1.x usando la siguiente bandera antes de la configuración/compilación: CFLAGS=-DEXPERIMENTAL_DATE_SUPPORT=1


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Fecha/Hora
Nombre | Por defecto | Cambiable | Historial de cambios
date.default_latitude | "31.7667" | PHP_INI_ALL |
date.default_longitude | "35.2333" | PHP_INI_ALL |
date.sunrise_zenith | "90.583333" | PHP_INI_ALL |
date.sunset_zenith | "90.583333" | PHP_INI_ALL |
date.timezone | "" | PHP_INI_ALL | Disponible a partir de PHP 5.1.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

date.default_latitude float

La latitud por defecto.

date.default_longitude float

La longitud por defecto.

date.sunrise_zenith float

El cénit de la salida del sol por defecto.

date.sunset_zenith float

El cénit de la puesta de sol por defecto.

date.timezone string

La zona horaria predeterminada empleada por todas las funciones de fecha/hora. Antes de PHP 5.4.0, esto únicamente funcionaba si la variable de entorno TZ no estaba establecida. El orden de prioridad para la zona horaria que se utiliza cuando no se establece explícitamente se describe en la función date_default_timezone_get(). Véase Listado de zonas horarias admitidas para una lista de las zonas horarias admitidas.

Nota: Las cuatro primeras opciones de configuración actualmente son empleadas únicamente por date_sunrise() y date_sunset().


Constantes predefinidas

Las contantes DATE_ están definidas desde PHP 5.1.1 y ofrecen representaciones de fecha estándar que pueden ser empleadas por funciones de formato de fecha (como date()).

Las siguientes constantes existen desde PHP 5.1.2 y especifican un formato devuelto por las funciones date_sunrise() y date_sunset().

SUNFUNCS_RET_TIMESTAMP (integer)
Marca temporal
SUNFUNCS_RET_STRING (integer)
Horas:minutos (ejemplo: 08:02)
SUNFUNCS_RET_DOUBLE (integer)
Horas como número de coma flotante (ejemplo 8.75)


  • « Constantes predefinidas
  • Aritmética de DateTime »
  • PHP Manual
  • Fecha/Hora
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Aritmética de DateTime


Aritmética de DateTime

Los siguientes ejemplos muestran algunos inconvenientes de la artimética de DateTime con respeco a las transiciones de DST y a los meses que tengan diferente número de días.

Ejemplo #1 DateTime::add/sub, añadir intervalos que cubren el tiempo transcurrido

Al añadir PT24H a una transición de DST parecerá que se añaden 23/25 horas (para la mayoría de las zonas horarias).

<?php
$dt = new DateTime("2015-11-01 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->add(new DateInterval("PT3H"));
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

El resultado del ejemplo sería:

Inicio: 2015-11-01 00:00:00 -04:00
Fin:    2015-11-01 02:00:00 -05:00

Ejemplo #2 DateTime::modify y strtotime, aumentar o disminuir valores de componentes individuales

Al añadir +24 hours a una transición de DST se añadirán exactamente 24 horas como se ve en la cadena de fecha/hora (a menos que el inicio o el final esté en un punto de transición).

<?php
$dt = new DateTime("2015-11-01 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->modify("+24 hours");
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

El resultado del ejemplo sería:

Inicio: 2015-11-01 00:00:00 -04:00
Fin:    2015-11-02 00:00:00 -05:00

Ejemplo #3 Añadir o restar horas puede sobrepasar o subpasar fechas

January 31st + 1 month resultará en March 2nd (año bisiesto) o 3rd (año normal).

<?php
echo "Año normal:\n"; // February has 28 days
$dt = new DateTime("2015-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->modify("+1 month");
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;

echo "Año bisiesto:\n"; // February has 29 days
$dt = new DateTime("2016-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->modify("+1 month");
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

El resultado del ejemplo sería:

Año normal:
Inicio: 2015-01-31 00:00:00 -05:00
Fin:    2015-03-03 00:00:00 -05:00
Año bisiesto:
Inicio: 2016-01-31 00:00:00 -05:00
Fin:    2016-03-02 00:00:00 -05:00

Para obtener el último día del siguiente mes (esto es, para prevenir el desbordamiento), a partir de PHP 5.3.0 está disponible el formato last day of.

<?php
echo "Año normal:\n"; // February has 28 days
$dt = new DateTime("2015-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->modify("last day of next month");
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;

echo "Año bisiesto:\n"; // February has 29 days
$dt = new DateTime("2016-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Inicio: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt->modify("last day of next month");
echo "Fin:    ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

El resultado del ejemplo sería:

Año normal:
Inicio: 2015-01-31 00:00:00 -05:00
Fin:    2015-02-28 00:00:00 -05:00
Año bisiesto:
Inicio: 2016-01-31 00:00:00 -05:00
Fin:    2016-02-29 00:00:00 -05:00


La clase DateTime

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

Introducción

Representación de la fecha y la hora.

Sinopsis de la Clase

DateTime implements DateTimeInterface {
/* Constantaes heredadas constants */
const string DateTimeInterface::ATOM = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::COOKIE = "l, d-M-Y H:i:s T" ;
const string DateTimeInterface::ISO8601 = "Y-m-d\TH:i:sO" ;
const string DateTimeInterface::RFC822 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC850 = "l, d-M-y H:i:s T" ;
const string DateTimeInterface::RFC1036 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC1123 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC2822 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC3339 = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string DateTimeInterface::RSS = "D, d M Y H:i:s O" ;
const string DateTimeInterface::W3C = "Y-m-d\TH:i:sP" ;
/* Métodos */
public __construct ( string $time = "now" , DateTimeZone $timezone = null )
public add ( DateInterval $interval ) : DateTime
public static createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime
public static createFromImmutable ( DateTimeImmutable $object ) : DateTime
public static createFromInterface ( DateTimeInterface $object ) : DateTime
public static getLastErrors ( ) : array
public modify ( string $modify ) : DateTime
public static __set_state ( array $array ) : DateTime
public setDate ( int $year , int $month , int $day ) : DateTime
public setISODate ( int $year , int $week , int $day = 1 ) : DateTime
public setTime ( int $hour , int $minute , int $second = 0 ) : DateTime
public setTimestamp ( int $unixtimestamp ) : DateTime
public setTimezone ( DateTimeZone $timezone ) : DateTime
public sub ( DateInterval $interval ) : DateTime
public diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone
public __wakeup ( )
}

Historial de cambios

Versión | Descripción
7.2.0 | Las constantes de clase de DateTime ahora están definidas en DateTimeInterface.
7.0.0 | Constantes agregadas: DATE_RFC3339_EXTENDED y DateTime::RFC3339_EXTENDED.
5.5.0 | La clase ahora implementa DateTimeInterface.
5.4.24 | La constante COOKIE se cambió para reflejar el RFC 1036 usando un año de cuatro dígitos en lugar de un año de dos dígitos (RFC 850) como en versiones anteriores.
5.2.2 | La comparación de un objeto DateTime con los operadores de comparación se cambió para que funcionara correctamente. Anteriormente, todos los objetos DateTime eran considerados iguales (usando ==).

Tabla de contenidos

  • DateTime::add — Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
  • DateTime::__construct — Devuelve un nuevo objeto DateTime
  • DateTime::createFromFormat — Analiza una cadena con un instante según un formato especificado
  • DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object
  • DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object
  • DateTime::getLastErrors — Devuelve las advertencias y los errores
  • DateTime::modify — Altera la marca temporal
  • DateTime::__set_state — El gestor __set_state
  • DateTime::setDate — Establece la fecha
  • DateTime::setISODate — Establece la fecha ISO
  • DateTime::setTime — Establece la hora
  • DateTime::setTimestamp — Establece la fecha y la hora basándose en una marca temporal de Unix
  • DateTime::setTimezone — Establece la zona horaria para el objeto DateTime
  • DateTime::sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime


Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime

  • « DateTime
  • DateTime::__construct »
  • PHP Manual
  • DateTime
  • Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime

DateTime::add

date_add

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::add -- date_add — Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime

Descripción

Estilo orientado a objetos

public DateTime::add ( DateInterval $interval ) : DateTime

Estilo por procedimientos

date_add ( DateTime $object , DateInterval $interval ) : DateTime

Añade el objeto DateInterval especificado al objeto DateTime especificado.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

interval

Un objeto DateInterval

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::add()

Estilo orientado a objetos

<?php
$fecha = new DateTime('2000-01-01');
$fecha->add(new DateInterval('P10D'));
echo $fecha->format('Y-m-d') . "\n";
?>

Estilo por procedimientos

<?php
$fecha = date_create('2000-01-01');
date_add($fecha, date_interval_create_from_date_string('10 days'));
echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2000-01-11

Ejemplo #2 Más ejemplos de DateTime::add()

<?php
$fecha= new DateTime('2000-01-01');
$fecha->add(new DateInterval('PT10H30S'));
echo $date->format('Y-m-d H:i:s') . "\n";

$fecha = new DateTime('2000-01-01');
$fecha->add(new DateInterval('P7Y5M4DT4H3M2S'));
echo $fecha->format('Y-m-d H:i:s') . "\n";
?>

El resultado del ejemplo sería:

2000-01-01 10:00:30
2007-06-05 04:03:02

Ejemplo #3 Cuidado al añadir meses

<?php
$fecha = new DateTime('2000-12-31');
$intervalo = new DateInterval('P1M');

$fecha->add($intervalo);
echo $fecha->format('Y-m-d') . "\n";

$fecha->add($intervalo);
echo $fecha->format('Y-m-d') . "\n";
?>

El resultado del ejemplo sería:

2001-01-31
2001-03-03

Notas

DateTime::modify() es una alternativa cuando se utiliza PHP 5.2.

Ver también

  • DateTime::sub() - Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime
  • DateTime::diff() - Devuelve la diferencia entre dos objetos DateTime
  • DateTime::modify() - Altera la marca temporal


Devuelve un nuevo objeto DateTime

  • « DateTime::add
  • DateTime::createFromFormat »
  • PHP Manual
  • DateTime
  • Devuelve un nuevo objeto DateTime

DateTime::__construct

date_create

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::__construct -- date_create — Devuelve un nuevo objeto DateTime

Descripción

Estilo orientado a objetos

public DateTime::__construct ( string $time = "now" , DateTimeZone $timezone = null )

Estilo por procedimientos

date_create ( string $time = "now" , DateTimeZone $timezone = null ) : DateTime

Devuelve un nuevo objeto DateTime.

Parámetros

time

Una cadena de fecha/hora. Los formatos válidos se explican en Formatos de fecha y hora.

Introducir null aquí para obtener el instante actual cuando se emplee el parámetro $timezone.

timezone

Un objeto DateTimeZone que representa la zona horaria de $time.

Si se omite $timezone, se usará la zona horaria actual.

Nota:

El parámetro $timezone y la zona horaria actuales se ignoran cuando el parámetro $time es una marca temporal de UNIX (p.ej. @946684800) o especifica una zona horaria (p.ej. 2010-01-28T15:00:00+02:00).

Valores devueltos

Devuelve una nueva instancia de DateTime. Estilo por procedimientos devuelve false en caso de error.

Errores/Excepciones

Emite una Exception en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Si time contiene un formato de fecha/hora no válido, se lanzará una excepción. Anteriormente se emitía un error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::__construct()

Estilo orientado a objetos

<?php
try {
    $fecha = new DateTime('2000-01-01');
} catch (Exception $e) {
    echo $e->getMessage();
    exit(1);
}

echo $fecha->format('Y-m-d');
?>

Estilo por procedimientos

<?php
$fecha = date_create('2000-01-01');
if (!$fecha) {
    $e = date_get_last_errors();
    foreach ($e['errors'] as $error) {
        echo "$error\n";
    }
    exit(1);
}

echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2000-01-01

Ejemplo #2 Complejidades de DateTime::__construct()

<?php
// Fecha/hora especificadas en la zona horaria de su ordenador.
$fecha = new DateTime('2000-01-01');
echo $fecha->format('Y-m-d H:i:sP') . "\n";

// Fecha/hora especificadas en la zona horaria especificada.
$fecha = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $fecha->format('Y-m-d H:i:sP') . "\n";

// Fecha/hora actuales en la zona horaria de su ordenador.
$fecha = new DateTime();
echo $fecha->format('Y-m-d H:i:sP') . "\n";

// Fecha/hora actuales en la zona horaria especificada.
$fecha = new DateTime(null, new DateTimeZone('Pacific/Nauru'));
echo $fecha->format('Y-m-d H:i:sP') . "\n";

// Usar una fecha UNIX. Observe que el resultado está en la zona horaria UTC.
$fecha = new DateTime('@946684800');
echo $fecha->format('Y-m-d H:i:sP') . "\n";

// Desbordamiento de valores no existentes.
$fecha = new DateTime('2000-02-30');
echo $fecha->format('Y-m-d H:i:sP') . "\n";
?>

El resultado del ejemplo sería algo similar a:

2000-01-01 00:00:00-05:00
2000-01-01 00:00:00+12:00
2010-04-24 10:24:16-04:00
2010-04-25 02:24:16+12:00
2000-01-01 00:00:00+00:00
2000-03-01 00:00:00-05:00

Ver también

  • DateTime::createFromFormat() - Analiza una cadena con un instante según un formato especificado
  • DateTimeZone::__construct() - Crea un nuevo objeto DateTimeZone
  • Formatos de fecha y hora
  • Configuración ini de date.timezone
  • date_default_timezone_set() - Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
  • DateTime::getLastErrors() - Devuelve las advertencias y los errores
  • checkdate() - Validar una fecha gregoriana


Analiza una cadena con un instante según un formato especificado

  • « DateTime::__construct
  • DateTime::createFromImmutable »
  • PHP Manual
  • DateTime
  • Analiza una cadena con un instante según un formato especificado

DateTime::createFromFormat

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::createFromFormat -- date_create_from_format — Analiza una cadena con un instante según un formato especificado

Descripción

Estilo orientado a objetos

public static DateTime::createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime

Estilo por procedimientos

date_create_from_format ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime

Devuelve un nuevo objeto DateTime que representa la fecha y la hora especificadas por la cadena time, la cual fue formateada en el formato dado por format.

Parámetros

format

El formato en el que debe estar el string proporcionado. Véanse las opciones de formateo más abajo. En la mayoría de los casos se pueden usar las mismas letras que para date().

Se reconocen los siguientes caracteres en el string del parámetro format
Carácter de format | Descripción | Ejemplo de valores analizables
Día --- ---
d y j | Día del mes, 2 dígitos con o sin ceros iniciales | 01 a 31 o 1 a 31
D y l | Una representación textual de un día | Mon hasta Sun o Sunday hasta Saturday
S | Sufijo ordinal inglés para el día del mes; 2 caracteres. Se ignora mientras se procesa. | st, nd, rd o th.
z | El día del año (comenzando por 0) | 0 hasta 365
Mes --- ---
F y M | Una representación textual de un mes, como January o Sept | January hasta December o Jan hasta Dec
m y n | Representación numérica de un mes, con o sin ceros iniciales | 01 hasta 12 o 1 hasta 12
Año --- ---
Y | Una representación numérica completa de un año, 4 dígitos | Ejemplos: 1999 o 2003
y | Una representación de dos dígitos de un año (el cual se asume que esté en el rango 1970-2069, inclusive) | Ejemplos: 99 o 03 (que serán representados como 1999 y 2003, respectivamente)
Hora --- ---
a y A | Ante meridiem y Post meridiem | am o pm
g y h | Formato de 12 horas de una hora con o sin ceros iniciales | 1 hasta 12 o 01 hasta 12
G y H | Formato de 24 horas de una hora con o sin ceros iniciales | 0 hasta 23 o 00 hasta 23
i | Minutos con ceros iniciales | 00 hasta 59
s | Segundos, con ceros iniciales | 00 hasta 59
u | Microsegundos (hasta seis dígitos) | Ejemplo: 45, 654321
Zona horaria --- ---
e, O, P y T | Identificador de zona horaria, o diferencia con UTC en horas, o diferencia con UTC con dos puntos entre horas y minutos, o abreviatura de la zona horaria | Ejemplos: UTC, GMT, Atlantic/Azores o +0200 o +02:00 o EST, MDT
Fecha/Hora completas --- ---
U | Segundos desde la Época Unix (January 1 1970 00:00:00 GMT) | Ejemplo: 1292177455
Espacios en blanco y separadores --- ---
(espacio) | Un espacio o una tabulación | Ejemplo:
# Uno de los siguientes símbolos de separación: ;, :, /, ., ,, -, ( o ) Ejemplo: /
;, :, /, ., ,, -, ( o ) | El carácter especificado. | Ejemplo: -
? Un byte aleatorio Ejemplo: ^ (Observe que para los caracteres UTF-8 podría ser necesario más de un ?. En este caso es probable que quiera usar * en su lugar)
* Bytes aleatorios hasta el siguiente separador o dígito Ejemplo: * en Y-*-d con el string 2009-unaPalabra-08 coincidirá con unaPalabra
! Reinicia todos los campos (año, mes, día, hora, minuto, segundo, fracción e información de la zona horaria) a la Época Unix Sin !, todos los campos serán establecidos a la fecha y hora actuales.
| Reinicia todos los campos (año, mes, día, hora, minuto, segundo, fracción e información de la zona horaria) a la Época Unix si no han sido aún analizados Y-m-d| establecerá el año, mes y día a la información encontrada en el string a analizar, y establece la hora, minutos y segundos a 0.
+ Si este especificador de formato está presente, la información sobrante del string no causará un error, pero sí una advertencia. Use DateTime::getLastErrors() para averiguar si había presente información sobrante.

Los caracteres no reconocidos en el string de formato causarán que falle el análisis y se añadirá un mensaje de error a la esctructura devuelta. Puede consultar los mensajes de error con DateTime::getLastErrors().

Para incluir caracters literales en format, se han de escapar con una barra invertida (\).

Si format no contiene el carácter !, las partes del instante generado que no estén especificadas en format serán establecidas al instante actual del sistema.

Si format contiene el carácter !, las partes del instante generadas no proporcionadas en format, así como los valores más a la izquierda de !, serán establecidos a los valores correspondientes de la época Unix.

La época Unix es 1970-01-01 00:00:00 UTC.

time

Un string que representa la hora.

timezone

Un objeto DateTimeZone que representa la zona horaria deseada.

Si se omite timezone y time no contiene ninguna zona horaria, se usará la zona horaria en uso.

Nota:

El parámetro timezone y la zona horaria actual son ignoradas cuando el parámetro time contiene una marca temporal de UNIX (p.ej. 946684800) o especifica una zona horaria (p.ej. 2010-01-28T15:00:00+02:00).

Valores devueltos

Devuelve una nueva instancia de DateTime o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.9 | Se añadió el especficador + para format.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::createFromFormat()

Estilo orientado a objetos

<?php
$fecha = DateTime::createFromFormat('j-M-Y', '15-Feb-2009');
echo $fecha->format('Y-m-d');
?>

Estilo por procedimientos

<?php
$fecha = date_create_from_format('j-M-Y', '15-Feb-2009');
echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2009-02-15

Ejemplo #2 Complejidades de DateTime::createFromFormat()

<?php
echo 'Instante actual: ' . date('Y-m-d H:i:s') . "\n";

$formato = 'Y-m-d';
$fecha = DateTime::createFromFormat($formato, '2009-02-15');
echo "Formato: $formato; " . $fecha->format('Y-m-d H:i:s') . "\n";

$formato = 'Y-m-d H:i:s';
$fecha = DateTime::createFromFormat($formato, '2009-02-15 15:16:17');
echo "Formato: $formato; " . $fecha->format('Y-m-d H:i:s') . "\n";

$formato = 'Y-m-!d H:i:s';
$fecha = DateTime::createFromFormat($formato, '2009-02-15 15:16:17');
echo "Formato: $formato; " . $fecha->format('Y-m-d H:i:s') . "\n";

$formato = '!d';
$fecha = DateTime::createFromFormat($formato, '15');
echo "Formato: $formato; " . $fecha->format('Y-m-d H:i:s') . "\n";
?>

El resultado del ejemplo sería algo similar a:

Instante actual: 2010-04-23 10:29:35
Formato: Y-m-d; 2009-02-15 10:29:35
Formato: Y-m-d H:i:s; 2009-02-15 15:16:17
Formato: Y-m-!d H:i:s; 1970-01-15 15:16:17
Formato: !d; 1970-01-15 00:00:00

Ejemplo #3 Cadena de formato con caracteres literales

<?php
echo DateTime::createFromFormat('H\h i\m s\s','23h 15m 03s')->format('H:i:s');
?>

El resultado del ejemplo sería algo similar a:

23:15:03

Ver también

  • DateTime::__construct() - Devuelve un nuevo objeto DateTime
  • DateTime::getLastErrors() - Devuelve las advertencias y los errores
  • checkdate() - Validar una fecha gregoriana
  • strptime() - Analiza una fecha/hora generada con strftime


Returns new DateTime object encapsulating the given DateTimeImmutable object

  • « DateTime::createFromFormat
  • DateTime::createFromInterface »
  • PHP Manual
  • DateTime
  • Returns new DateTime object encapsulating the given DateTimeImmutable object

DateTime::createFromImmutable

(PHP 7 >= 7.3.0, PHP 8)

DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object

Descripción

public static DateTime::createFromImmutable ( DateTimeImmutable $object ) : DateTime

Parámetros

object

The immutable DateTimeImmutable object that needs to be converted to a mutable version. This object is not modified, but instead a new DateTime object is created containing the same date, time, and timezone information.

Ejemplos

Ejemplo #1 Creating a mutable date time object

<?php
$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");

$mutable = DateTime::createFromImmutable( $date );
?>

Valores devueltos

Returns a new DateTime instance.


Returns new DateTime object encapsulating the given DateTimeInterface object

  • « DateTime::createFromImmutable
  • DateTime::getLastErrors »
  • PHP Manual
  • DateTime
  • Returns new DateTime object encapsulating the given DateTimeInterface object

DateTime::createFromInterface

(PHP 8)

DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object

Descripción

public static DateTime::createFromInterface ( DateTimeInterface $object ) : DateTime

Parámetros

object

The DateTimeInterface object that needs to be converted to a mutable version. This object is not modified, but instead a new DateTime object is created containing the same date, time, and timezone information.

Valores devueltos

Returns a new DateTime instance.

Ejemplos

Ejemplo #1 Creating a mutable date time object

<?php
$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");

$mutable = DateTime::createFromInterface($date);

$date = new DateTime("2014-06-20 11:45 Europe/London");
$also_mutable = DateTime::createFromInterface($date);
?>


Devuelve las advertencias y los errores

  • « DateTime::createFromInterface
  • DateTime::modify »
  • PHP Manual
  • DateTime
  • Devuelve las advertencias y los errores

DateTime::getLastErrors

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::getLastErrors -- date_get_last_errors — Devuelve las advertencias y los errores

Descripción

Estilo orientado a objetos

public static DateTime::getLastErrors ( ) : array

Estilo por procedimientos

date_get_last_errors ( ) : array

Devuelve un array con las advertencias y los errores encontrados mientras se analizaba una cadena de fecha/hora.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array que contiene información acerca de las advertencias y los errores.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::getLastErrors()

Estilo orientado a objetos

<?php
try {
    $fecha = new DateTime('asdfasdf');
} catch (Exception $e) {
    // Sólo con propósitos de demostración...
    print_r(DateTime::getLastErrors());

    // La forma real orientada a objetos de hacer esto es
    // echo $e->getMessage();
}
?>

Estilo por procedimientos

<?php
$fecha = date_create('asdfasdf');
print_r(date_get_last_errors());
?>

El resultado de los ejemplos sería:

Array
(
   [warning_count] => 1
   [warnings] => Array
       (
           [6] => Double timezone specification
       )

   [error_count] => 1
   [errors] => Array
       (
           [0] => The timezone could not be found in the database
       )

)

Los índices 6 y 0 de la salida del ejemplo hacen referencia a la posición del carácter en la cadena donde ocurrió el error.


Altera la marca temporal

  • « DateTime::getLastErrors
  • DateTime::__set_state »
  • PHP Manual
  • DateTime
  • Altera la marca temporal

DateTime::modify

date_modify

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::modify -- date_modify — Altera la marca temporal

Descripción

Estilo orientado a objetos

public DateTime::modify ( string $modify ) : DateTime

Estilo por procedimientos

date_modify ( DateTime $object , string $modify ) : DateTime

Altera la marca temporal de un objeto DateTime aumentando o disminuyendo en un formato aceptado por strtotime().

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

modify

Una cadena de fecha/hora. Los formatos válidos se explican en Formatos de fecha y hora.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.6 | Las sentencias de fecha/hora absolutas ahora toman efecto. Anteriormente, sólo se utilizaban las partes relativas.
5.3.0 | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::modify()

Estilo orientado a objetos

<?php
$fecha = new DateTime('2006-12-12');
$fecha->modify('+1 day');
echo $fecha->format('Y-m-d');
?>

Estilo por procedimientos

<?php
$fecha= date_create('2006-12-12');
date_modify($fecha, '+1 day');
echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2006-12-13

Ejemplo #2 Cuidado al añadir o sustraer meses

<?php
$fecha = new DateTime('2000-12-31');

$fecha->modify('+1 month');
echo $fecha->format('Y-m-d') . "\n";

$fecha->modify('+1 month');
echo $fecha->format('Y-m-d') . "\n";
?>

El resultado del ejemplo sería:

2001-01-31
2001-03-03

Ver también

  • strtotime() - Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix
  • DateTime::add() - Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
  • DateTime::sub() - Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime
  • DateTime::setDate() - Establece la fecha
  • DateTime::setISODate() - Establece la fecha ISO
  • DateTime::setTime() - Establece la hora
  • DateTime::setTimestamp() - Establece la fecha y la hora basándose en una marca temporal de Unix


El gestor __set_state

  • « DateTime::modify
  • DateTime::setDate »
  • PHP Manual
  • DateTime
  • El gestor __set_state

DateTime::__set_state

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::__set_state — El gestor __set_state

Descripción

public static DateTime::__set_state ( array $array ) : DateTime

El gestor __set_state().

Parámetros

array

Array de inicialización.

Valores devueltos

Devuelve una nueva instancia de un objeto DateTime.


Establece la fecha

  • « DateTime::__set_state
  • DateTime::setISODate »
  • PHP Manual
  • DateTime
  • Establece la fecha

DateTime::setDate

date_date_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setDate -- date_date_set — Establece la fecha

Descripción

Estilo orientado a objetos

public DateTime::setDate ( int $year , int $month , int $day ) : DateTime

Estilo por procedimientos

date_date_set ( DateTime $object , int $year , int $month , int $day ) : DateTime

Reinicia la fecha actual del objeto DateTime a una fecha diferente.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

year

Año de la fecha.

month

Mes de la fecha.

day

Día de la fecha.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::setDate()

Estilo orientado a objetos

<?php
$fecha = new DateTime();
$fecha->setDate(2001, 2, 3);
echo $fecha->format('Y-m-d');
?>

Estilo por procedimientos

<?php
$fecha = date_create();
date_date_set($fecha, 2001, 2, 3);
echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2001-02-03

Ejemplo #2 Los valores que exceden rangos son añadidos a sus valores padre

<?php
$fecha = new DateTime();

$fecha->setDate(2001, 2, 28);
echo $fecha->format('Y-m-d') . "\n";

$fecha->setDate(2001, 2, 29);
echo $fecha->format('Y-m-d') . "\n";

$fecha->setDate(2001, 14, 3);
echo $fecha->format('Y-m-d') . "\n";
?>

El resultado del ejemplo sería:

2001-02-28
2001-03-01
2002-02-03

Ver también

  • DateTime::setISODate() - Establece la fecha ISO
  • DateTime::setTime() - Establece la hora


Establece la fecha ISO

  • « DateTime::setDate
  • DateTime::setTime »
  • PHP Manual
  • DateTime
  • Establece la fecha ISO

DateTime::setISODate

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setISODate -- date_isodate_set — Establece la fecha ISO

Descripción

Estilo orientado a objetos

public DateTime::setISODate ( int $year , int $week , int $day = 1 ) : DateTime

Estilo por procedimientos

date_isodate_set ( DateTime $object , int $year , int $week , int $day = 1 ) : DateTime

Establece una fecha según el estándar ISO 8601, empleando índices de semanas y días en vez de fechas específicas.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

year

Año de la fecha.

week

Semana de la fecha.

day

Índice del primer día de la semana.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::setISODate()

Estilo orientado a objetos

<?php
$fecha = new DateTime();

$fecha->setISODate(2008, 2);
echo $fecha->format('Y-m-d') . "\n";

$fecha->setISODate(2008, 2, 7);
echo $fecha->format('Y-m-d') . "\n";
?>

Estilo por procedimientos

<?php
$fecha = date_create();

date_isodate_set($fecha, 2008, 2);
echo date_format($fecha, 'Y-m-d') . "\n";

date_isodate_set($fecha, 2008, 2, 7);
echo date_format($fecha, 'Y-m-d') . "\n";
?>

El resultado de los ejemplos sería:

2008-01-07
2008-01-13

Ejemplo #2 Los valores que execen rangos son añadidos a sus valores padre

<?php
$fecha = new DateTime();

$fecha->setISODate(2008, 2, 7);
echo $fecha->format('Y-m-d') . "\n";

$fecha->setISODate(2008, 2, 8);
echo $fecha->format('Y-m-d') . "\n";

$fecha->setISODate(2008, 53, 7);
echo $fecha->format('Y-m-d') . "\n";
?>

El resultado del ejemplo sería:

2008-01-13
2008-01-14
2009-01-04

Ejemplo #3 Buscar el mes en el que se encuentra una semana

<?php
$fecha = new DateTime();
$fecha->setISODate(2008, 14);
echo $fecha->format('n');
?>

El resultado de los ejemplos sería:

3

Ver también

  • DateTime::setDate() - Establece la fecha
  • DateTime::setTime() - Establece la hora


Establece la hora

  • « DateTime::setISODate
  • DateTime::setTimestamp »
  • PHP Manual
  • DateTime
  • Establece la hora

DateTime::setTime

date_time_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setTime -- date_time_set — Establece la hora

Descripción

Estilo orientado a objetos

public DateTime::setTime ( int $hour , int $minute , int $second = 0 ) : DateTime

Estilo por procedimientos

date_time_set ( DateTime $object , int $hour , int $minute , int $second = 0 ) : DateTime

Reinicia la hora actual del objeto DateTime a una hora diferente.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

hour

Hora del instante.

minute

Minuto del instante.

second

Segundo del instante.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::setTime()

Estilo orientado a objetos

<?php
$fecha = new DateTime('2001-01-01');

$fecha->setTime(14, 55);
echo $fecha->format('Y-m-d H:i:s') . "\n";

$fecha->setTime(14, 55, 24);
echo $fecha->format('Y-m-d H:i:s') . "\n";
?>

Estilo por procedimientos

<?php
$fecha = date_create('2001-01-01');

date_time_set($fecha, 14, 55);
echo date_format($fecha, 'Y-m-d H:i:s') . "\n";

date_time_set($fecha, 14, 55, 24);
echo date_format($fecha, 'Y-m-d H:i:s') . "\n";
?>

El resultado de los ejemplos sería algo similar a:

2001-01-01 14:55:00
2001-01-01 14:55:24

Ejemplo #2 Los valores que exceden rangos son añadidos a sus valores padre

<?php
$fecha = new DateTime('2001-01-01');

$fecha->setTime(14, 55, 24);
echo $fecha->format('Y-m-d H:i:s') . "\n";

$fecha->setTime(14, 55, 65);
echo $fecha->format('Y-m-d H:i:s') . "\n";

$fecha->setTime(14, 65, 24);
echo $fecha->format('Y-m-d H:i:s') . "\n";

$fecha->setTime(25, 55, 24);
echo $fecha->format('Y-m-d H:i:s') . "\n";
?>

El resultado del ejemplo sería:

2001-01-01 14:55:24
2001-01-01 14:56:05
2001-01-01 15:05:24
2001-01-02 01:55:24

Ver también

  • DateTime::setDate() - Establece la fecha
  • DateTime::setISODate() - Establece la fecha ISO


Establece la fecha y la hora basándose en una marca temporal de Unix

  • « DateTime::setTime
  • DateTime::setTimezone »
  • PHP Manual
  • DateTime
  • Establece la fecha y la hora basándose en una marca temporal de Unix

DateTime::setTimestamp

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::setTimestamp -- date_timestamp_set — Establece la fecha y la hora basándose en una marca temporal de Unix

Descripción

Estilo orientado a objetos

public DateTime::setTimestamp ( int $unixtimestamp ) : DateTime

Estilo por procedimientos

date_timestamp_set ( DateTime $object , int $unixtimestamp ) : DateTime

Establece la fecha y la hora basándose en una marca temporal de Unix.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

unixtimestamp

La marca temporal de Unix que representa la fecha.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::setTimestamp()

Estilo orientado a objetos

<?php
$fecha = new DateTime();
echo $fecha->format('U = Y-m-d H:i:s') . "\n";

$fecha->setTimestamp(1171502725);
echo $fecha->format('U = Y-m-d H:i:s') . "\n";
?>

Estilo por procedimientos

<?php
$fecha = date_create();
echo date_format($fecha, 'U = Y-m-d H:i:s') . "\n";

date_timestamp_set($fecha, 1171502725);
echo date_format($fecha, 'U = Y-m-d H:i:s') . "\n";
?>

El resultado de los ejemplos sería algo similar a:

1272508903 = 2010-04-28 22:41:43
1171502725 = 2007-02-14 20:25:25

Notas

Utilizar el formato de marca temporal de Unix para construir un nuevo objeto DateTime es una alternativa al emplear PHP 5.2, como se muestra en el ejemplo de abajo.

Ejemplo #2 Alternativa de DateTime::setTimestamp() en PHP 5.2

<?php
$ts = 1171502725;
$fecha = new DateTime("@$ts");
echo $date->format('U = Y-m-d H:i:s') . "\n";
?>

El resultado del ejemplo sería algo similar a:

1171502725 = 2007-02-14 20:25:25

Ver también

  • DateTime::getTimestamp() - Obtiene la marca de tiempo Unix


Establece la zona horaria para el objeto DateTime

  • « DateTime::setTimestamp
  • DateTime::sub »
  • PHP Manual
  • DateTime
  • Establece la zona horaria para el objeto DateTime

DateTime::setTimezone

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setTimezone -- date_timezone_set — Establece la zona horaria para el objeto DateTime

Descripción

Estilo orientado a objetos

public DateTime::setTimezone ( DateTimeZone $timezone ) : DateTime

Estilo por procedimientos

date_timezone_set ( DateTime $object , DateTimeZone $timezone ) : DateTime

Establece una nueva zona horaria para un object de DateTime.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

timezone

Un objeto DateTimeZone que representa la zona horaria deseada.

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::setTimeZone()

Estilo orientado a objetos

<?php
$fecha = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $fecha->format('Y-m-d H:i:sP') . "\n";

$fecha->setTimezone(new DateTimeZone('Pacific/Chatham'));
echo $fecha->format('Y-m-d H:i:sP') . "\n";
?>

Estilo por procedimientos

<?php
$fecha= date_create('2000-01-01', timezone_open('Pacific/Nauru'));
echo date_format($fecha, 'Y-m-d H:i:sP') . "\n";

date_timezone_set($fecha, timezone_open('Pacific/Chatham'));
echo date_format($fecha, 'Y-m-d H:i:sP') . "\n";
?>

El resultado de los ejemplos sería:

2000-01-01 00:00:00+12:00
2000-01-01 01:45:00+13:45

Ver también

  • DateTime::getTimezone() - Develve la zona horaria relativa al objeto DateTime dado
  • DateTimeZone::__construct() - Crea un nuevo objeto DateTimeZone


Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime

  • « DateTime::setTimezone
  • DateTimeImmutable »
  • PHP Manual
  • DateTime
  • Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime

DateTime::sub

date_sub

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::sub -- date_sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime

Descripción

Estilo orientado a objetos

public DateTime::sub ( DateInterval $interval ) : DateTime

Estilo por procedimientos

date_sub ( DateTime $object , DateInterval $interval ) : DateTime

Sustrae el objeto DateInterval especificado del objeto DateTime especificado.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

interval

Un objeto DateInterval

Valores devueltos

Devuelve el objeto DateTime para la cadena de métodos o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::sub()

Estilo orientado a objetos

<?php
$fecha = new DateTime('2000-01-20');
$fecha->sub(new DateInterval('P10D'));
echo $fecha->format('Y-m-d') . "\n";
?>

Estilo por procedimientos

<?php
$fecha = date_create('2000-01-20');
date_sub($fecha, date_interval_create_from_date_string('10 days'));
echo date_format($fecha, 'Y-m-d');
?>

El resultado de los ejemplos sería:

2000-01-10

Ejemplo #2 Más ejemplos de DateTime::sub()

<?php
$fecha = new DateTime('2000-01-20');
$fecha->sub(new DateInterval('PT10H30S'));
echo $fecha->format('Y-m-d H:i:s') . "\n";

$fecha = new DateTime('2000-01-20');
$fecha->sub(new DateInterval('P7Y5M4DT4H3M2S'));
echo $fecha->format('Y-m-d H:i:s') . "\n";
?>

El resultado del ejemplo sería:

2000-01-19 13:59:30
1992-08-15 19:56:58

Ejemplo #3 Cuidado al sustraer meses

<?php
$fecha = new DateTime('2001-04-30');
$intervalo = new DateInterval('P1M');

$fecha->sub($intervalo);
echo $fecha->format('Y-m-d') . "\n";

$fecha->sub($intervalo);
echo $fecha->format('Y-m-d') . "\n";
?>

El resultado del ejemplo sería:

2001-03-30
2001-03-02

Notas

DateTime::modify() es una alternativa cuando se usa PHP 5.2.

Ver también

  • DateTime::add() - Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
  • DateTime::diff() - Devuelve la diferencia entre dos objetos DateTime
  • DateTime::modify() - Altera la marca temporal


La clase DateTimeImmutable

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Introducción

Esta clase se comporta igual que DateTime con la excepción de que nunca se modifica a sí misma, sino que devuelve un nuevo objeto en su lugar.

Sinopsis de la Clase

DateTimeImmutable implements DateTimeInterface {
/* Constantaes heredadas constants */
const string DateTimeInterface::ATOM = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::COOKIE = "l, d-M-Y H:i:s T" ;
const string DateTimeInterface::ISO8601 = "Y-m-d\TH:i:sO" ;
const string DateTimeInterface::RFC822 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC850 = "l, d-M-y H:i:s T" ;
const string DateTimeInterface::RFC1036 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC1123 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC2822 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC3339 = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string DateTimeInterface::RSS = "D, d M Y H:i:s O" ;
const string DateTimeInterface::W3C = "Y-m-d\TH:i:sP" ;
/* Métodos */
public __construct ( string $time = "now" , DateTimeZone $timezone = null )
public add ( DateInterval $interval ) : DateTimeImmutable
public static createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTimeImmutable
public static createFromInterface ( DateTimeInterface $object ) : DateTimeImmutable
public static createFromMutable ( DateTime $datetime ) : DateTimeImmutable
public static getLastErrors ( ) : array
public modify ( string $modify ) : DateTimeImmutable
public static __set_state ( array $array ) : DateTimeImmutable
public setDate ( int $year , int $month , int $day ) : DateTimeImmutable
public setISODate ( int $year , int $week , int $day = 1 ) : DateTimeImmutable
public setTime ( int $hour , int $minute , int $second = 0 , int $microseconds = 0 ) : DateTimeImmutable
public setTimestamp ( int $unixtimestamp ) : DateTimeImmutable
public setTimezone ( DateTimeZone $timezone ) : DateTimeImmutable
public sub ( DateInterval $interval ) : DateTimeImmutable
public diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone
public __wakeup ( )
}

Tabla de contenidos

  • DateTimeImmutable::add — Añade una cantidad de días, meses, años, horas, minutos y segundos
  • DateTimeImmutable::__construct — Devuelve un nuevo objeto DateTimeImmutable
  • DateTimeImmutable::createFromFormat — Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado
  • DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
  • DateTimeImmutable::createFromMutable — Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado
  • DateTimeImmutable::getLastErrors — Devuelve las advertencias y errores
  • DateTimeImmutable::modify — Crea un nuevo objeto con la marca de tiempo modificada
  • DateTimeImmutable::__set_state — El gestor __set_state
  • DateTimeImmutable::setDate — Establece la fecha
  • DateTimeImmutable::setISODate — Establece la fecha ISO
  • DateTimeImmutable::setTime — Establece la hora
  • DateTimeImmutable::setTimestamp — Establece la fecha y hora basadas en una marca de tiempo Unix
  • DateTimeImmutable::setTimezone — Establece la zona horaria
  • DateTimeImmutable::sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos


Añade una cantidad de días, meses, años, horas, minutos y segundos

  • « DateTimeImmutable
  • DateTimeImmutable::__construct »
  • PHP Manual
  • DateTimeImmutable
  • Añade una cantidad de días, meses, años, horas, minutos y segundos

DateTimeImmutable::add

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::add — Añade una cantidad de días, meses, años, horas, minutos y segundos

Descripción

public DateTimeImmutable::add ( DateInterval $interval ) : DateTimeImmutable

Igual que DateTime::add() excepto que trabaja con DateTimeImmutable.


Devuelve un nuevo objeto DateTimeImmutable

  • « DateTimeImmutable::add
  • DateTimeImmutable::createFromFormat »
  • PHP Manual
  • DateTimeImmutable
  • Devuelve un nuevo objeto DateTimeImmutable

DateTimeImmutable::__construct

date_create_immutable

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::__construct -- date_create_immutable — Devuelve un nuevo objeto DateTimeImmutable

Descripción

Estilo orientado a objetos

public DateTimeImmutable::__construct ( string $time = "now" , DateTimeZone $timezone = null )

Estilo por procedimientos

date_create_immutable ( string $time = "now" , DateTimeZone $timezone = null ) : DateTimeImmutable

Igual que DateTime::__construct() excepto que trabaja con DateTimeImmutable.


Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado

  • « DateTimeImmutable::__construct
  • DateTimeImmutable::createFromInterface »
  • PHP Manual
  • DateTimeImmutable
  • Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado

DateTimeImmutable::createFromFormat

date_create_immutable_from_format

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::createFromFormat -- date_create_immutable_from_format — Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado

Descripción

Estilo orientado a objetos

public static DateTimeImmutable::createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTimeImmutable

Estilo por procedimientos

date_create_immutable_from_format ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTimeImmutable

Igual que DateTime::createFromFormat() excepto que trabaja con DateTimeImmutable.


Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

  • « DateTimeImmutable::createFromFormat
  • DateTimeImmutable::createFromMutable »
  • PHP Manual
  • DateTimeImmutable
  • Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

DateTimeImmutable::createFromInterface

(PHP 8)

DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

Descripción

public static DateTimeImmutable::createFromInterface ( DateTimeInterface $object ) : DateTimeImmutable

Parámetros

object

The DateTimeInterface object that needs to be converted to an immutable version. This object is not modified, but instead a new DateTimeImmutable object is created containing the same date, time, and timezone information.

Valores devueltos

Returns a new DateTimeImmutable instance.

Ejemplos

Ejemplo #1 Creating an immutable date time object

<?php
$date = new DateTime("2014-06-20 11:45 Europe/London");

$immutable = DateTimeImmutable::createFromInterface($date);

$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");
$also_immutable = DateTimeImmutable::createFromInterface($date);
?>


Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado

  • « DateTimeImmutable::createFromInterface
  • DateTimeImmutable::getLastErrors »
  • PHP Manual
  • DateTimeImmutable
  • Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado

DateTimeImmutable::createFromMutable

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

DateTimeImmutable::createFromMutable — Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado

Descripción

public static DateTimeImmutable::createFromMutable ( DateTime $datetime ) : DateTimeImmutable

Parámetros

datetime

El objeto DateTime mutable para convertirlo en una versión mutable. Este objeto no se modifica, sino que en su lugar se crea un nuevo objeto DateTimeImmutable que contiene la misma información de fecha, hora y zona horaria.

Ejemplos

Ejemplo #1 Crear un objeto de fecha y hora inmutable

<?php
$date = new DateTime("2014-06-20 11:45 Europe/London");

$immutable = DateTimeImmutable::createFromMutable( $date );
?>

Valores devueltos

Devuelve una nueva instancia de DateTimeImmutable.


Devuelve las advertencias y errores

  • « DateTimeImmutable::createFromMutable
  • DateTimeImmutable::modify »
  • PHP Manual
  • DateTimeImmutable
  • Devuelve las advertencias y errores

DateTimeImmutable::getLastErrors

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::getLastErrors — Devuelve las advertencias y errores

Descripción

public static DateTimeImmutable::getLastErrors ( ) : array

Igual que DateTime::getLastErrors() excepto que trabaja con DateTimeImmutable.


Crea un nuevo objeto con la marca de tiempo modificada

  • « DateTimeImmutable::getLastErrors
  • DateTimeImmutable::__set_state »
  • PHP Manual
  • DateTimeImmutable
  • Crea un nuevo objeto con la marca de tiempo modificada

DateTimeImmutable::modify

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::modify — Crea un nuevo objeto con la marca de tiempo modificada

Descripción

public DateTimeImmutable::modify ( string $modify ) : DateTimeImmutable

Crea un nuevo objeto DateTimeImmutable con la marca de tiempo modificada. El objeto original no se modifica.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create(). La función modifica este objeto.

modify

Una cadena de fecha/hora. Los formatos válidos se explican en Formatos de fecha y hora.

Valores devueltos

Devuelve el objeto recién creado o false en caso de error.


El gestor __set_state

  • « DateTimeImmutable::modify
  • DateTimeImmutable::setDate »
  • PHP Manual
  • DateTimeImmutable
  • El gestor __set_state

DateTimeImmutable::__set_state

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::__set_state — El gestor __set_state

Descripción

public static DateTimeImmutable::__set_state ( array $array ) : DateTimeImmutable

Igual DateTime::__set_state() excepto que trabaja con DateTimeImmutable.


Establece la fecha

  • « DateTimeImmutable::__set_state
  • DateTimeImmutable::setISODate »
  • PHP Manual
  • DateTimeImmutable
  • Establece la fecha

DateTimeImmutable::setDate

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setDate — Establece la fecha

Descripción

public DateTimeImmutable::setDate ( int $year , int $month , int $day ) : DateTimeImmutable

Igual que DateTime::setDate() excepto que trabaja con DateTimeImmutable.


Establece la fecha ISO

  • « DateTimeImmutable::setDate
  • DateTimeImmutable::setTime »
  • PHP Manual
  • DateTimeImmutable
  • Establece la fecha ISO

DateTimeImmutable::setISODate

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setISODate — Establece la fecha ISO

Descripción

public DateTimeImmutable::setISODate ( int $year , int $week , int $day = 1 ) : DateTimeImmutable

Igual que DateTime::setISODate() excepto que trabaja con DateTimeImmutable.


Establece la hora

  • « DateTimeImmutable::setISODate
  • DateTimeImmutable::setTimestamp »
  • PHP Manual
  • DateTimeImmutable
  • Establece la hora

DateTimeImmutable::setTime

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTime — Establece la hora

Descripción

public DateTimeImmutable::setTime ( int $hour , int $minute , int $second = 0 , int $microseconds = 0 ) : DateTimeImmutable

Igual que DateTime::setTime() excepto que trabaja con DateTimeImmutable.


Establece la fecha y hora basadas en una marca de tiempo Unix

  • « DateTimeImmutable::setTime
  • DateTimeImmutable::setTimezone »
  • PHP Manual
  • DateTimeImmutable
  • Establece la fecha y hora basadas en una marca de tiempo Unix

DateTimeImmutable::setTimestamp

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTimestamp — Establece la fecha y hora basadas en una marca de tiempo Unix

Descripción

public DateTimeImmutable::setTimestamp ( int $unixtimestamp ) : DateTimeImmutable

Igual que DateTime::setTimestamp() excepto que trabaja con DateTimeImmutable.


Establece la zona horaria

  • « DateTimeImmutable::setTimestamp
  • DateTimeImmutable::sub »
  • PHP Manual
  • DateTimeImmutable
  • Establece la zona horaria

DateTimeImmutable::setTimezone

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTimezone — Establece la zona horaria

Descripción

public DateTimeImmutable::setTimezone ( DateTimeZone $timezone ) : DateTimeImmutable

Igualq que DateTime::setTimezone() excepto que trabaja con DateTimeImmutable.


Sustrae una cantidad de días, meses, años, horas, minutos y segundos

  • « DateTimeImmutable::setTimezone
  • DateTimeInterface »
  • PHP Manual
  • DateTimeImmutable
  • Sustrae una cantidad de días, meses, años, horas, minutos y segundos

DateTimeImmutable::sub

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::sub — Sustrae una cantidad de días, meses, años, horas, minutos y segundos

Descripción

public DateTimeImmutable::sub ( DateInterval $interval ) : DateTimeImmutable

Igual que DateTime::sub() excepto que trabaja con DateTimeImmutable.


La interfaz DateTimeInterface

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Introducción

El propósito de DateTimeInterface es actuar como declaración de tipo para DateTime y DateTimeImmutable. No es posible que el usuario implemente esta interfaz en sus propias clases.

Sinopsis de la Clase

DateTimeInterface {
/* Constantes */
const string ATOM = "Y-m-d\TH:i:sP" ;
const string COOKIE = "l, d-M-Y H:i:s T" ;
const string ISO8601 = "Y-m-d\TH:i:sO" ;
const string RFC822 = "D, d M y H:i:s O" ;
const string RFC850 = "l, d-M-y H:i:s T" ;
const string RFC1036 = "D, d M y H:i:s O" ;
const string RFC1123 = "D, d M Y H:i:s O" ;
const string RFC2822 = "D, d M Y H:i:s O" ;
const string RFC3339 = "Y-m-d\TH:i:sP" ;
const string RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string RSS = "D, d M Y H:i:s O" ;
const string W3C = "Y-m-d\TH:i:sP" ;
/* Métodos */
public diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone
public __wakeup ( )
}

Constantes predefinidas

DateTimeInterface::ATOM
DATE_ATOM
Atom (ejemplo: 2005-08-15T15:52:01+00:00)
DateTimeInterface::COOKIE
DATE_COOKIE
Cookies de HTTP (ejemplo: Monday, 15-Aug-2005 15:52:01 UTC)
DateTime::ISO8601
DATE_ISO8601
ISO-8601 (ejemplo: 2005-08-15T15:52:01+0000)

Nota: Este formato no es compatible con el ISO-8601, aunque se deja por razones de retrocompatibilidad. Use DateTime::ATOM o DATE_ATOM en su lugar para que sea compatible con el ISO-8601.

DateTimeInterface::RFC822
DATE_RFC822
RFC 822 (ejemplo: Mon, 15 Aug 05 15:52:01 +0000)
DateTimeInterface::RFC850
DATE_RFC850
RFC 850 (ejemplo: Monday, 15-Aug-05 15:52:01 UTC)
DateTimeInterface::RFC1036
DATE_RFC1036
RFC 1036 (ejemplo: Mon, 15 Aug 05 15:52:01 +0000)
DateTimeInterface::RFC1123
DATE_RFC1123
RFC 1123 (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000)
DateTimeInterface::RFC2822
DATE_RFC2822
RFC 2822 (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000)
DateTimeInterface::RFC3339
DATE_RFC3339
Lo mismo que DATE_ATOM (desde PHP 5.1.3)
DateTimeInterface::RFC3339_EXTENDED
DATE_RFC3339_EXTENDED
RFC 3339 EXTENDED format (desde PHP 7.0.0) (ejemplo: 2005-08-15T15:52:01.000+00:00)
DateTimeInterface::RSS
DATE_RSS
RSS (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000)
DateTimeInterface::W3C
DATE_W3C
World Wide Web Consortium (ejemplo: 2005-08-15T15:52:01+00:00)

Historial de cambios

Versión | Descripción
7.2.0 | Las constantes de clase de DateTime ahora están definidas en DateTimeInterface.
5.5.8 | Ahora, intentar implementar DateTimeInterface emite un error fatal. Anteriormente, la implementación de la interfaz no emitía un error, aunque este comportamiento era erróneo.

Tabla de contenidos

  • DateTime::diff — Devuelve la diferencia entre dos objetos DateTime
  • DateTime::format — Devuelve la fecha formateada según el formato dado
  • DateTime::getOffset — Devuelve el índice de la zona horaria
  • DateTime::getTimestamp — Obtiene la marca de tiempo Unix
  • DateTime::getTimezone — Develve la zona horaria relativa al objeto DateTime dado
  • DateTime::__wakeup — El gestor __wakeup


Devuelve la diferencia entre dos objetos DateTime

  • « DateTimeInterface
  • DateTime::format »
  • PHP Manual
  • DateTimeInterface
  • Devuelve la diferencia entre dos objetos DateTime

DateTime::diff

DateTimeImmutable::diff

DateTimeInterface::diff

date_diff

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::diff -- DateTimeImmutable::diff -- DateTimeInterface::diff -- date_diff — Devuelve la diferencia entre dos objetos DateTime

Descripción

Estilo orientado a objetos

public DateTime::diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval
public DateTimeImmutable::diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval
public DateTimeInterface::diff ( DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval

Estilo por procedimientos

date_diff ( DateTimeInterface $datetime1 , DateTimeInterface $datetime2 , bool $absolute = false ) : DateInterval

Devuelve la diferencia entre dos objetos DateTimeInterface.

Parámetros

datetime

La fecha a comparar.

absolute

¿Debería el intervalo ser forzado para ser positivo?

Valores devueltos

El objeto DateInterval que representa la diferencia entre dos fechas o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::diff()

Estilo orientado a objetos

<?php
$datetime1 = new DateTime('2009-10-11');
$datetime2 = new DateTime('2009-10-13');
$interval = $datetime1->diff($datetime2);
echo $interval->format('%R%a días');
?>

Estilo por procedimientos

<?php
$datetime1 = date_create('2009-10-11');
$datetime2 = date_create('2009-10-13');
$interval = date_diff($datetime1, $datetime2);
echo $interval->format('%R%a días');
?>

El resultado de los ejemplos sería:

+2 days

Ejemplo #2 Comparación de objetos DateTime

Nota:

A partir de PHP 5.2.2, los objetos DateTime se pueden comparar usando los operadores de comparación.

<?php
$date1 = new DateTime("now");
$date2 = new DateTime("tomorrow");

var_dump($date1 == $date2);
var_dump($date1 < $date2);
var_dump($date1 > $date2);
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)

Ver también

  • DateInterval::format() - Formatea el intervalo
  • DateTime::add() - Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
  • DateTime::sub() - Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime


Devuelve la fecha formateada según el formato dado

  • « DateTime::diff
  • DateTime::getOffset »
  • PHP Manual
  • DateTimeInterface
  • Devuelve la fecha formateada según el formato dado

DateTime::format

DateTimeImmutable::format

DateTimeInterface::format

date_format

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::format -- DateTimeImmutable::format -- DateTimeInterface::format -- date_format — Devuelve la fecha formateada según el formato dado

Descripción

Estilo orientado a objetos

public DateTime::format ( string $format ) : string
public DateTimeImmutable::format ( string $format ) : string
public DateTimeInterface::format ( string $format ) : string

Estilo por procedimientos

date_format ( DateTimeInterface $object , string $format ) : string

Devuelve la fecha formateada según el formato dado.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create()

format

Formato aceptado por date().

Valores devueltos

Devuelve la fecha formateada en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::format()

Estilo orientado a objetos

<?php
$date = new DateTime('2000-01-01');
echo $date->format('Y-m-d H:i:s');
?>

Estilo por procedimientos

<?php
$date = date_create('2000-01-01');
echo date_format($date, 'Y-m-d H:i:s');
?>

El resultado del ejemplo sería:

2000-01-01 00:00:00

Notas

Este método no usa configuraciones regionales. Todas las salidas están en inglés.

Ver también

  • date() - Dar formato a la fecha/hora local


Devuelve el índice de la zona horaria

  • « DateTime::format
  • DateTime::getTimestamp »
  • PHP Manual
  • DateTimeInterface
  • Devuelve el índice de la zona horaria

DateTime::getOffset

DateTimeImmutable::getOffset

DateTimeInterface::getOffset

date_offset_get

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::getOffset -- DateTimeImmutable::getOffset -- DateTimeInterface::getOffset -- date_offset_get — Devuelve el índice de la zona horaria

Descripción

Estilo orientado a objetos

public DateTime::getOffset ( ) : int
public DateTimeImmutable::getOffset ( ) : int
public DateTimeInterface::getOffset ( ) : int

Estilo por procedimientos

date_offset_get ( DateTimeInterface $object ) : int

Devuelve el índice de la zona horaria.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create()

Valores devueltos

Devuelve el índice de la zona horaria en segundos desde UTC en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::getOffset()

Estilo orientado a objetos

<?php
$invierno = new DateTime('2010-12-21', new DateTimeZone('America/New_York'));
$verano = new DateTime('2008-06-21', new DateTimeZone('America/New_York'));

echo $invierno->getOffset() . "\n";
echo $verano->getOffset() . "\n";
?>

Estilo por procedimientos

<?php
$invierno = date_create('2010-12-21', timezone_open('America/New_York'));
$verano = date_create('2008-06-21', timezone_open('America/New_York'));

echo date_offset_get($invierno) . "\n";
echo date_offset_get($verano) . "\n";
?>

El resultado de los ejemplos sería:

-18000
-14400

Nota: -18000 = -5 horas, -14400 = -4 horas.


Obtiene la marca de tiempo Unix

  • « DateTime::getOffset
  • DateTime::getTimezone »
  • PHP Manual
  • DateTimeInterface
  • Obtiene la marca de tiempo Unix

DateTime::getTimestamp

DateTimeImmutable::getTimestamp

DateTimeInterface::getTimestamp

date_timestamp_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::getTimestamp -- DateTimeImmutable::getTimestamp -- DateTimeInterface::getTimestamp -- date_timestamp_get — Obtiene la marca de tiempo Unix

Descripción

Estilo orientado a objetos

public DateTime::getTimestamp ( ) : int
public DateTimeImmutable::getTimestamp ( ) : int
public DateTimeInterface::getTimestamp ( ) : int

Estilo por procedimientos

date_timestamp_get ( DateTimeInterface $object ) : int

Obtiene la marca de tiempo Unix.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la marca de tiempo Unix que representa la fecha.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::getTimestamp()

Estilo orientado a objetos

<?php
$fecha = new DateTime();
echo $fecha->getTimestamp();
?>

Estilo por procedimientos

<?php
$fecha = date_create();
echo date_timestamp_get($fecha);
?>

El resultado de los ejemplos sería algo similar a:

1272509157

Notas

Usar U como parámetro de DateTime::format() es una alternativa cuando se utliza PHP 5.2.

Ver también

  • DateTime::setTimestamp() - Establece la fecha y la hora basándose en una marca temporal de Unix
  • DateTime::format() - Devuelve la fecha formateada según el formato dado


Develve la zona horaria relativa al objeto DateTime dado

  • « DateTime::getTimestamp
  • DateTime::__wakeup »
  • PHP Manual
  • DateTimeInterface
  • Develve la zona horaria relativa al objeto DateTime dado

DateTime::getTimezone

DateTimeImmutable::getTimezone

DateTimeInterface::getTimezone

date_timezone_get

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::getTimezone -- DateTimeImmutable::getTimezone -- DateTimeInterface::getTimezone -- date_timezone_get — Develve la zona horaria relativa al objeto DateTime dado

Descripción

Estilo orientado a objetos

public DateTime::getTimezone ( ) : DateTimeZone
public DateTimeImmutable::getTimezone ( ) : DateTimeZone
public DateTimeInterface::getTimezone ( ) : DateTimeZone

Estilo por procedimientos

date_timezone_get ( DateTimeInterface $object ) : DateTimeZone

Develve la zona horaria relativa al objeto DateTime dado.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTime devuelto por date_create()

Valores devueltos

Devuelve un objeto DateTimeZone en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTime::getTimezone()

Estilo orientado a objetos

<?php
$fecha = new DateTime(null, new DateTimeZone('Europe/London'));
$zh = $fecha->getTimezone();
echo $zh->getName();
?>

Estilo por procedimientos

<?php
$fecha = date_create(null, timezone_open('Europe/London'));
$zh = date_timezone_get($fecha);
echo timezone_name_get($zh);
?>

El resultado de los ejemplos sería:

Europe/London

Ver también

  • DateTime::setTimezone() - Establece la zona horaria para el objeto DateTime


El gestor __wakeup

  • « DateTime::getTimezone
  • DateTimeZone »
  • PHP Manual
  • DateTimeInterface
  • El gestor __wakeup

DateTime::__wakeup

DateTimeImmutable::__wakeup

DateTimeInterface::__wakeup

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::__wakeup -- DateTimeImmutable::__wakeup -- DateTimeInterface::__wakeup — El gestor __wakeup

Descripción

public DateTime::__wakeup ( )
public DateTimeImmutable::__wakeup ( )
public DateTimeInterface::__wakeup ( )

El gestor __wakeup().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Inicializa un objeto DateTime.


La clase DateTimeZone

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

Introducción

Representación de la zona horaria.

Sinopsis de la Clase

DateTimeZone {
/* Constantes */
const integer AFRICA = 1 ;
const integer AMERICA = 2 ;
const integer ANTARCTICA = 4 ;
const integer ARCTIC = 8 ;
const integer ASIA = 16 ;
const integer ATLANTIC = 32 ;
const integer AUSTRALIA = 64 ;
const integer EUROPE = 128 ;
const integer INDIAN = 256 ;
const integer PACIFIC = 512 ;
const integer UTC = 1024 ;
const integer ALL = 2047 ;
const integer ALL_WITH_BC = 4095 ;
const integer PER_COUNTRY = 4096 ;
/* Métodos */
public __construct ( string $timezone )
public getLocation ( ) : array
public getName ( ) : string
public getOffset ( DateTime $datetime ) : int
public getTransitions ( int $timestamp_begin = PHP_INT_MIN , int $timestamp_end = PHP_INT_MAX ) : array
public static listAbbreviations ( ) : array
public static listIdentifiers ( int $what = DateTimeZone::ALL , string $country = null ) : array
}

Constantes predefinidas

DateTimeZone::AFRICA

Zonas horarias de África.

DateTimeZone::AMERICA

Zonas horarias de América.

DateTimeZone::ANTARCTICA

Zonas horarias de la Antártida.

DateTimeZone::ARCTIC

Zonas horarias del Ártico.

DateTimeZone::ASIA

Zonas horarias de Asia.

DateTimeZone::ATLANTIC

Zonas horarias del Atlántico.

DateTimeZone::AUSTRALIA

Zonas horarias de Australia.

DateTimeZone::EUROPE

Zonas horarias de Europa.

DateTimeZone::INDIAN

Zonas horarias de la India.

DateTimeZone::PACIFIC

Zonas horarias del Pacífico.

DateTimeZone::UTC

Zonas horarias UTC.

DateTimeZone::ALL

Todas las zonas horarias.

DateTimeZone::ALL_WITH_BC

Todas las zonas horarias incluyendo las de versiones anteriores por compatibilidad.

DateTimeZone::PER_COUNTRY

Zonas horarias por país.

Tabla de contenidos

  • DateTimeZone::__construct — Crea un nuevo objeto DateTimeZone
  • DateTimeZone::getLocation — Devuelve la información de la ubicación para una zona horaria
  • DateTimeZone::getName — Devuelve el nombre de la zona horaria
  • DateTimeZone::getOffset — Devuelve el índice de la zona horaria de GMT
  • DateTimeZone::getTransitions — Devuelve todas las transiciones para una zona horaria
  • DateTimeZone::listAbbreviations — Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria
  • DateTimeZone::listIdentifiers — Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos


Crea un nuevo objeto DateTimeZone

  • « DateTimeZone
  • DateTimeZone::getLocation »
  • PHP Manual
  • DateTimeZone
  • Crea un nuevo objeto DateTimeZone

DateTimeZone::__construct

timezone_open

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::__construct -- timezone_open — Crea un nuevo objeto DateTimeZone

Descripción

Estilo orientado a objetos

public DateTimeZone::__construct ( string $timezone )

Estilo por procedimientos

timezone_open ( string $timezone ) : DateTimeZone

Crea un nuevo objeto DateTimeZone.

Parámetros

timezone

Uno de los nombres de zonas horarias admitidos o un índice válido (+0200).

Valores devueltos

Devuelve un objeto DateTimeZone si tuvo éxito. Estilo por procedimientos devuelve false en caso de error.

Errores/Excepciones

Este método lanza una Exception si la zona horaria suministrada no es reconocida como una zona horaria válida.

Historial de cambios

Versión | Descripción
5.5.10 | El parámetro timezone acepta valores de índice.

Ejemplos

Ejemplo #1 Atrapar errores cuando se instancia un DateTimeZone

<?php
// Manejo de errores atrapando excepciones
$zonas_horarias = array('Europe/London', 'Mars/Phobos', 'Jupiter/Europa');

foreach ($zonas_horarias as $zh) {
    try {
        $marte = new DateTimeZone($zh);
    } catch(Exception $e) {
        echo $e->getMessage() . '<br />';
    }
}
?>

El resultado del ejemplo sería:

DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Mars/Phobos)
DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Jupiter/Europa)


Devuelve la información de la ubicación para una zona horaria

  • « DateTimeZone::__construct
  • DateTimeZone::getName »
  • PHP Manual
  • DateTimeZone
  • Devuelve la información de la ubicación para una zona horaria

DateTimeZone::getLocation

timezone_location_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTimeZone::getLocation -- timezone_location_get — Devuelve la información de la ubicación para una zona horaria

Descripción

Estilo orientado a objetos

public DateTimeZone::getLocation ( ) : array

Estilo por procedimientos

timezone_location_get ( DateTimeZone $object ) : array

Devuelve la información de la ubicación para una zona horaria, incluyendo el código de país, latitud/longitud y comentarios.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTimeZone devuelto por timezone_open()

Valores devueltos

Una matriz que contiene la información de la ubicación acerca de una zona horaria o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTimeZone::getLocation()

<?php
$zh = new DateTimeZone("Europe/Prague");
print_r($zh->getLocation());
print_r(timezone_location_get($zh));
?>

El resultado del ejemplo sería:

Array
Array
(
    [country_code] => CZ
    [latitude] => 50.08333
    [longitude] => 14.43333
    [comments] =>
)
Array
(
    [country_code] => CZ
    [latitude] => 50.08333
    [longitude] => 14.43333
    [comments] =>
)


Devuelve el nombre de la zona horaria

  • « DateTimeZone::getLocation
  • DateTimeZone::getOffset »
  • PHP Manual
  • DateTimeZone
  • Devuelve el nombre de la zona horaria

DateTimeZone::getName

timezone_name_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getName -- timezone_name_get — Devuelve el nombre de la zona horaria

Descripción

Estilo orientado a objetos

public DateTimeZone::getName ( ) : string

Estilo por procedimientos

timezone_name_get ( DateTimeZone $object ) : string

Devuelve el nombre de la zona horaria.

Parámetros

object

El DateTimeZone del cual desera obtener el nombre.

Valores devueltos

Una de los nombres de zona horaria en la lista de zonas horarias.


Devuelve el índice de la zona horaria de GMT

  • « DateTimeZone::getName
  • DateTimeZone::getTransitions »
  • PHP Manual
  • DateTimeZone
  • Devuelve el índice de la zona horaria de GMT

DateTimeZone::getOffset

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getOffset -- timezone_offset_get — Devuelve el índice de la zona horaria de GMT

Descripción

Estilo orientado a objetos

public DateTimeZone::getOffset ( DateTime $datetime ) : int

Estilo por procedimientos

timezone_offset_get ( DateTimeZone $object , DateTime $datetime ) : int

Esta función devuelve el índice GMT para la fecha/hora especificada en el parámetro datetime. El índice GMT se calcula con la información de la zona horaria contenida en el objeto DateTimeZone que se va a utilizar.

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTimeZone devuelto por timezone_open()

datetime

El objeto DateTime que contiene la fecha/hora desde la que se va a computar el índice.

Valores devueltos

Devuelve el índice de la zona horaria en segundos si tiene éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DateTimeZone::getOffset()

<?php
// Crear dos objetos de zona horaria, uno para Taipéi (Taiwán) y otro para
// Tokyo (Japón)
$dateTimeZoneTaipei = new DateTimeZone("Asia/Taipei");
$dateTimeZoneJapan = new DateTimeZone("Asia/Tokyo");

// Crear dos objetos DateTime que contendrán la misma fecha Unix, pero
// tendrán diferentes zonas horarias adjuntas.
$dateTimeTaipei = new DateTime("now", $dateTimeZoneTaipei);
$dateTimeJapan = new DateTime("now", $dateTimeZoneJapan);

// Calcular el índice GMT para la fecha/hora contenida en el objeto $dateTimeTaipei,
// pero usando las normas de la zona horaria definidas en Tokyo
// ($dateTimeZoneJapan).
$timeOffset = $dateTimeZoneJapan->getOffset($dateTimeTaipei);

// Debería mostrar int(32400) (para fechas después de Sat Sep 8 01:00:00 1951 JST).
var_dump($timeOffset);
?>


Devuelve todas las transiciones para una zona horaria

  • « DateTimeZone::getOffset
  • DateTimeZone::listAbbreviations »
  • PHP Manual
  • DateTimeZone
  • Devuelve todas las transiciones para una zona horaria

DateTimeZone::getTransitions

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getTransitions -- timezone_transitions_get — Devuelve todas las transiciones para una zona horaria

Descripción

Estilo orientado a objetos

public DateTimeZone::getTransitions ( int $timestamp_begin = PHP_INT_MIN , int $timestamp_end = PHP_INT_MAX ) : array

Estilo por procedimientos

timezone_transitions_get ( DateTimeZone $object , int $timestamp_begin = PHP_INT_MIN , int $timestamp_end = PHP_INT_MAX ) : array

Parámetros

object

Solamente para el estilo por procedimientos: Un objeto DateTimeZone devuelto por timezone_open()

timestamp_begin

Marca de tiempo de inicio.

timestamp_end

Marca de tiempo final.

Valores devueltos

Deveulve una matriz numérica que contiene una matriz asociativa con todas las transiciones si se tuvo éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadieron los parámetros opcionales timestamp_begin y timestamp_end.

Ejemplos

Ejemplo #1 Un ejemplo de timezone_transitions_get()

<?php
$zona_horaria = new DateTimeZone("Europe/London");
$transiciones = $zona_horaria->getTransitions();
print_r(array_slice($transiciones, 0, 3));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [ts] => -2147483648
            [time] => 1901-12-13T20:45:52+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [1] => Array
        (
            [ts] => -1691964000
            [time] => 1916-05-21T02:00:00+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [2] => Array
        (
            [ts] => -1680472800
            [time] => 1916-10-01T02:00:00+0000
            [offset] => 0
            [isdst] =>
            [abbr] => GMT
        )

)


Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria

  • « DateTimeZone::getTransitions
  • DateTimeZone::listIdentifiers »
  • PHP Manual
  • DateTimeZone
  • Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria

DateTimeZone::listAbbreviations

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::listAbbreviations -- timezone_abbreviations_list — Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria

Descripción

Estilo orientado a objetos

public static DateTimeZone::listAbbreviations ( ) : array

Estilo por procedimientos

timezone_abbreviations_list ( ) : array

Valores devueltos

Devuelve una matriz si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de timezone_abbreviations_list()

<?php
$timezone_abbreviations = DateTimeZone::listAbbreviations();
print_r($timezone_abbreviations["acst"]);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Porto_Acre
        )

    [1] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Eirunepe
        )

    [2] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Rio_Branco
        )

    [3] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => Brazil/Acre
        )

)

Ver también

  • timezone_identifiers_list() - Alias de DateTimeZone::listIdentifiers


Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos

  • « DateTimeZone::listAbbreviations
  • DateInterval »
  • PHP Manual
  • DateTimeZone
  • Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos

DateTimeZone::listIdentifiers

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::listIdentifiers -- timezone_identifiers_list — Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos

Descripción

Estilo orientado a objetos

public static DateTimeZone::listIdentifiers ( int $what = DateTimeZone::ALL , string $country = null ) : array

Estilo por procedimientos

timezone_identifiers_list ( int $what = DateTimeZone::ALL , string $country = null ) : array

Parámetros

what

Una de las constantes de la clase DateTimeZone.

country

Un código de país de dos letras compatible con ISO 3166-1.

Nota: Esta opción sólo se usa cuando el parámetro what está establecido a DateTimeZone::PER_COUNTRY.

Valores devueltos

Devuelve una matriz si se tuvo éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Añadidos los parámteros opcionales what y country.

Ejemplos

Ejemplo #1 Un ejemplo de timezone_identifiers_list()

<?php
$timezone_identifiers = DateTimeZone::listIdentifiers();
for ($i=0; $i < 5; $i++) {
    echo "$timezone_identifiers[$i]\n";
}
?>

El resultado del ejemplo sería algo similar a:

Africa/Abidjan
Africa/Accra
Africa/Addis_Ababa
Africa/Algiers
Africa/Asmara

Ver también

  • timezone_abbreviations_list() - Alias de DateTimeZone::listAbbreviations


La clase DateInterval

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

Representa un intervalo de fechas.

Un intervalo de fechas almacena o bien una cantidad fija de instantes (en años, meses, días, horas, etc.) o bien una cadena con un instante relativo en el formato que admite el constructor de DateTime.

Sinopsis de la Clase

DateInterval {
/* Propiedades */
public integer $y ;
public integer $m ;
public integer $d ;
public integer $h ;
public integer $i ;
public integer $s ;
public integer $invert ;
public mixed $days ;
/* Métodos */
public __construct ( string $interval_spec )
public static createFromDateString ( string $time ) : DateInterval
public format ( string $format ) : string
}

Propiedades

y

Número de años.

m

Número de meses.

d

Número de días.

h

Número de horas.

i

Número de minutos.

s

Número de segundos.

invert

Es 1 si el intervalo representa un periodo de tiempo negativo y 0 si no. Véase DateInterval::format().

days

Si el objeto DateInterval se creó con DateTime::diff(), entonces es el número total de días entre las fechas de inicio y fin. Si no, days será false.

Antes de PHP 5.4.20/5.5.4, en lugar de false se recibía -99999 al acceder a la propiedad.

Tabla de contenidos

  • DateInterval::__construct — Crea un nuevo objeto DateInterval
  • DateInterval::createFromDateString — Establece un objeto DateInterval desde las partes relativas de una cadena
  • DateInterval::format — Formatea el intervalo


Crea un nuevo objeto DateInterval

  • « DateInterval
  • DateInterval::createFromDateString »
  • PHP Manual
  • DateInterval
  • Crea un nuevo objeto DateInterval

DateInterval::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::__construct — Crea un nuevo objeto DateInterval

Descripción

public DateInterval::__construct ( string $interval_spec )

Crea un nuevo objeto DateInterval.

Parámetros

interval_spec

Una especificación de intervalo.

El formato empieza con la letra P, de periodo. Cada periodo de duración está representado por un valor de tipo integer seguido de un indicador de periodo. Si la duración contiene elementos de hora, esa parte de la especificación estará precedida por una letra T.

Indicadores de periodo de interval_spec
Indicador de periodo | Descripción
Y | años
M | meses
D | días
W | semanas; estas se convierten a días, por lo que no se puede combinar con D.
H | horas
M | minutos
S | segundos

Algunos ejemplos sencillos: Dos días es P2D. Dos segundos es PT2S. Seis años y cinco minutos es P6YT5M.

Nota:

Los tipos de unidades deben ser escritos desde la unidad de escala más grande a la izquierda a la unidad de escala más pequeña a la derecha. Así los años van antes que los meses, meses antes que días, días antes que minutos, etc. Así un año y cuatro días debe representarse como P1Y4D, y no como P4D1Y.

La especificación también puede ser representada como una fecha/hora. Un ejemplo de un año y cuatro días sería P0001-00-04T00:00:00. Pero los valores en este formato no pueden exceder el punto de desbordamiento de un periodo (p.ej. 25 horas no es válido).

Estos formatos están basados en la » especificación de duración ISO 8601.

Errores/Excepciones

Lanza una Exception cuando el interval_spec no puede ser analizado como un intervalo.

Ejemplos

Ejemplo #1 Ejemplo de DateInterval

<?php

$intervalo = new DateInterval('P2Y4DT6H8M');
var_dump($intervalo);

?>

El resultado del ejemplo sería:

object(DateInterval)#1 (8) {
  ["y"]=>
  int(2)
  ["m"]=>
  int(0)
  ["d"]=>
  int(4)
  ["h"]=>
  int(6)
  ["i"]=>
  int(8)
  ["s"]=>
  int(0)
  ["invert"]=>
  int(0)
  ["days"]=>
  bool(false)
}

Ver también

  • DateInterval::format() - Formatea el intervalo
  • DateTime::add() - Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
  • DateTime::sub() - Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime
  • DateTime::diff() - Devuelve la diferencia entre dos objetos DateTime


Establece un objeto DateInterval desde las partes relativas de una cadena

  • « DateInterval::__construct
  • DateInterval::format »
  • PHP Manual
  • DateInterval
  • Establece un objeto DateInterval desde las partes relativas de una cadena

DateInterval::createFromDateString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::createFromDateString — Establece un objeto DateInterval desde las partes relativas de una cadena

Descripción

public static DateInterval::createFromDateString ( string $time ) : DateInterval

Emplea el analizador de fechas normal y establece un objeto DateInterval desde las partes relativas de la cadena analizada.

Parámetros

time

Una fecha con partes relativas. Específicamente, los formatos relativos admitidos por el analizador utilzados para strtotime() y DateTime serán los empleados para construir el objeto DateInterval.

Ejemplos

Ejemplo #1 Analizar intervalos de fechas válidos

<?php
// Cada conjunto de intervalos es igual.
$i = new DateInterval('P1D');
$i = DateInterval::createFromDateString('1 day');

$i = new DateInterval('P2W');
$i = DateInterval::createFromDateString('2 weeks');

$i = new DateInterval('P3M');
$i = DateInterval::createFromDateString('3 months');

$i = new DateInterval('P4Y');
$i = DateInterval::createFromDateString('4 years');

$i = new DateInterval('P1Y1D');
$i = DateInterval::createFromDateString('1 year + 1 day');

$i = new DateInterval('P1DT12H');
$i = DateInterval::createFromDateString('1 day + 12 hours');

$i = new DateInterval('PT3600S');
$i = DateInterval::createFromDateString('3600 seconds');
?>

Valores devueltos

Devuelve una nueva instancia de DateInterval.


Formatea el intervalo

  • « DateInterval::createFromDateString
  • DatePeriod »
  • PHP Manual
  • DateInterval
  • Formatea el intervalo

DateInterval::format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::format — Formatea el intervalo

Descripción

public DateInterval::format ( string $format ) : string

Formatea el intervalo.

Parámetros

format

Los siguietes caracteres están reconocidos en el parámetro de cadena format. Cada carácter de formato debe ser prefijado con un signo de porcentaje (%).
Carácter format | Descripción | Valores de ejemplo
% Literal % %
Y | Años, numérico, al menos 2 dígitos empezando con 0 | 01, 03
y | Años, numérico | 1, 3
M | Meses, numérico, al menos 2 dígitos empezando con 0 | 01, 03, 12
m | Meses, numérico | 1, 3, 12
D | Días, numérico, al menos 2 dígitos empezando con 0 | 01, 03, 31
d | Días, numérico | 1, 3, 31
a | Número total de días como resultado de una operación con DateTime::diff(), o de lo contrario (unknown) | 4, 18, 8123
H | Horas, numérico, al menos 2 dígitos empezando con 0 | 01, 03, 23
h | Horas, numérico | 1, 3, 23
I | Minutos, numérico, al menos 2 dígitos empezando con 0 | 01, 03, 59
i | Minutos, numérico | 1, 3, 59
S | Segundos, numérico, al menos 2 dígitos empezando con 0 | 01, 03, 57
s | Segundos, numérico | 1, 3, 57
R Signo "-" cuando es negativo, "+" cuando es positivo -, +
r Signo "-" cuando es negativo, vacío cuando es positivo -,

Valores devueltos

Devuelve el intervalo formateado.

Notas

Nota:

El método DateInterval::format() no recalcula los excesos en cadenas de hora ni en segmentos de fecha. Esto es así porque no es posible analizar valores como "32 días" el cual podría ser interpretado como cualquier cosa desde "1 mes y 4 días" hasta "1 mes y un día".

Ejemplos

Ejemplo #1 Ejemplo de DateInterval

<?php

$intervalo = new DateInterval('P2Y4DT6H8M');
echo $intervalo->format('%d días');

?>

El resultado del ejemplo sería:

4 días

Ejemplo #2 DateInterval y excesos

<?php

$intervalo = new DateInterval('P32D');
echo $intervalo->format('%d días');

?>

El resultado del ejemplo sería:

32 días

Ejemplo #3 DateInterval y DateTime::diff() con los modificadores %a y %d

<?php

$enero = new DateTime('2010-01-01');
$febrero = new DateTime('2010-02-01');
$intervalo = $febrero->diff($enero);

// %a imprimirá el múmero total de días.
echo $intervalo->format('%a total de días')."\n";

// Mientras que %d sólo imprimirá el múmero total de días no cubiertos por el
// mes.
echo $intervalo->format('%m mes, %d días');

?>

El resultado del ejemplo sería:

31 total days
1 month, 0 days

Ver también

  • DateTime::diff() - Devuelve la diferencia entre dos objetos DateTime


La clase DatePeriod

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Introducción

Representa un período de fechas.

Un período de fechas permite la iteración sobre un conjunto de fechas y horas, repitiéndose a intervalos regulares durante un período dado.

Sinopsis de la Clase

DatePeriod implements Traversable {
/* Constantes */
const integer EXCLUDE_START_DATE = 1 ;
/* Propiedades */
public integer $recurrences ;
public boolean $include_start_date ;
public DateTimeInterface $start ;
public DateTimeInterface $current ;
public DateTimeInterface $end ;
public DateInterval $interval ;
/* Métodos */
public __construct ( DateTimeInterface $start , DateInterval $interval , int $recurrences , int $options = ? )
public __construct ( DateTimeInterface $start , DateInterval $interval , DateTimeInterface $end , int $options = ? )
public __construct ( string $isostr , int $options = ? )
public getDateInterval ( ) : DateInterval
public getEndDate ( ) : DateTimeInterface
public getRecurrences ( ) : int|null
public getStartDate ( ) : DateTimeInterface
}

Constantes predefinidas

DatePeriod::EXCLUDE_START_DATE

Excluir la fecha inicial, usado en DatePeriod::__construct().

Propiedades

recurrences

include_start_date

start

current

end

interval

Tabla de contenidos

  • DatePeriod::__construct — Crea un nuevo objeto DatePeriod
  • DatePeriod::getDateInterval — Obtener el intervalo
  • DatePeriod::getEndDate — Obtener la fecha final
  • DatePeriod::getRecurrences — Gets the number of recurrences
  • DatePeriod::getStartDate — Obtener la fecha inicial


Crea un nuevo objeto DatePeriod

  • « DatePeriod
  • DatePeriod::getDateInterval »
  • PHP Manual
  • DatePeriod
  • Crea un nuevo objeto DatePeriod

DatePeriod::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DatePeriod::__construct — Crea un nuevo objeto DatePeriod

Descripción

public DatePeriod::__construct ( DateTimeInterface $start , DateInterval $interval , int $recurrences , int $options = ? )
public DatePeriod::__construct ( DateTimeInterface $start , DateInterval $interval , DateTimeInterface $end , int $options = ? )
public DatePeriod::__construct ( string $isostr , int $options = ? )

Crea un nuevo objeto DatePeriod.

Parámetros

start

La fecha de inicio del periodo.

interval

El intervalo entre repeticiones dentro del periodo.

recurrences

El número de repeticiones.

end

La fecha final del periodo.

isostr

Una especificación ISO 8601 del intervalo de repetición.

options

Se puede establecer a DatePeriod::EXCLUDE_START_DATE para excluir la fecha de inicio del conjunto de fechas de repetición dentro del periodo.

Historial de cambios

Versión | Descripción
5.5.8 | El tipo de end se cambió a DateTimeInterface. Anteriormente era DateTime.
5.5.0 | start se cambió a DateTimeImmutable. Anteriormente era DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DatePeriod

<?php
$inicio = new DateTime('2012-07-01');
$intervalo = new DateInterval('P7D');
$fin = new DateTime('2012-07-31');
$repeticiones = 4;
$iso = 'R4/2012-07-01T00:00:00Z/P7D';

// Todos estos periodos son equivalentes.
$periodo = new DatePeriod($inicio, $intervalo, $repeticiones);
$periodo = new DatePeriod($inicio, $intervalo, $fin);
$periodo = new DatePeriod($iso);

// Al recorrer el objeto DatePeriod, se imprimen todas
// las fechas de repetición dentro del periodo.
foreach ($periodo as $fecha) {
    echo $fecha->format('Y-m-d')."\n";
}
?>

El resultado del ejemplo sería:

2012-07-01
2012-07-08
2012-07-15
2012-07-22
2012-07-29

Ejemplo #2 Ejemplo de DatePeriod con DatePeriod::EXCLUDE_START_DATE

<?php
$inicio = new DateTime('2012-07-01');
$intervalo = new DateInterval('P7D');
$fin = new DateTime('2012-07-31');

$periodo = new DatePeriod($inicio, $intervalo, $fin,
                         DatePeriod::EXCLUDE_START_DATE);

// Al recorrer el objeto DatePeriod, se imprimen todas
// las fechas de repetición dentro del periodo.
// Observe que, en este caso, 2012-07-01 no se imprime.
foreach ($periodo as $fecha) {
    echo $fecha->format('Y-m-d')."\n";
}
?>

El resultado del ejemplo sería:

2012-07-08
2012-07-15
2012-07-22
2012-07-29

Notas

No se admiten repeticiones de números sin límite tal como se especifca en la sección 4.5 de la ISO 8601, "Recurring time interval", esto es, no funcionará el paso de "R/..." como isostr ni el paso de null como end.


Obtener el intervalo

  • « DatePeriod::__construct
  • DatePeriod::getEndDate »
  • PHP Manual
  • DatePeriod
  • Obtener el intervalo

DatePeriod::getDateInterval

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getDateInterval — Obtener el intervalo

Descripción

Estilo orientado a objetos

public DatePeriod::getDateInterval ( ) : DateInterval

Obtiene un objeto DateInterval representa el intervalo empleado para el periodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto DateInterval

Ejemplos

Ejemplo #1 Ejemplo de DatePeriod::getDateInterval()

<?php
$periodo = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$intervalo = $periodo->getDateInterval();
echo $intervalo->format('%d day');
?>

El resultado del ejemplo sería:

1 day

Ver también

  • DatePeriod::getStartDate() - Obtener la fecha inicial
  • DatePeriod::getEndDate() - Obtener la fecha final


Obtener la fecha final

  • « DatePeriod::getDateInterval
  • DatePeriod::getRecurrences »
  • PHP Manual
  • DatePeriod
  • Obtener la fecha final

DatePeriod::getEndDate

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getEndDate — Obtener la fecha final

Descripción

Estilo orientado a objetos

public DatePeriod::getEndDate ( ) : DateTimeInterface

Obtiene la fecha final del periodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve null si el objeto DatePeriod no posee una fecha final. Por ejemplo, cuando se inicializó con el parámetro recurrences, o el parámetro isostr sin una fecha final.

Devuelve un objeto DateTimeImmutable cuando el objeto DatePeriod se inicializó con un objeto DateTimeImmutable para el parámetro end.

De lo contrario, devuelve un objeto DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DatePeriod::getEndDate()

<?php
$periodo = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    new DateTime('2016-05-20T00:00:00Z')
);
$inicio = $periodo->getEndDate();
echo $inicio->format(DateTime::ISO8601);
?>

El resultado de los ejemplos sería:

2016-05-20T00:00:00+0000

Ejemplo #2 DatePeriod::getEndDate() sin una fecha final

<?php
$periodo = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    7
);
var_dump($periodo->getEndDate());
?>

El resultado del ejemplo sería:

NULL

Ver también

  • DatePeriod::getStartDate() - Obtener la fecha inicial
  • DatePeriod::getDateInterval() - Obtener el intervalo


Gets the number of recurrences

  • « DatePeriod::getEndDate
  • DatePeriod::getStartDate »
  • PHP Manual
  • DatePeriod
  • Gets the number of recurrences

DatePeriod::getRecurrences

(PHP 7 >= 7.2.17/7.3.4, PHP 8)

DatePeriod::getRecurrences — Gets the number of recurrences

Descripción

Estilo orientado a objetos

public DatePeriod::getRecurrences ( ) : int|null

Get the number of recurrences.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of recurrences.

Ver también

  • DatePeriod::$recurrences


Obtener la fecha inicial

  • « DatePeriod::getRecurrences
  • Funciones de Fecha/Hora »
  • PHP Manual
  • DatePeriod
  • Obtener la fecha inicial

DatePeriod::getStartDate

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getStartDate — Obtener la fecha inicial

Descripción

Estilo orientado a objetos

public DatePeriod::getStartDate ( ) : DateTimeInterface

Obtiene la fecha inicial del periodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto DateTimeImmutable cuando el objeto DatePeriod se inicializó con un objeto DateTimeImmutable para el parámetro start.

De lo contrario, devuelve un objeto DateTime.

Ejemplos

Ejemplo #1 Ejemplo de DatePeriod::getStartDate()

<?php
$periodo = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$inicio = $periodo->getStartDate();
echo $inicio->format(DateTime::ISO8601);
?>

El resultado del ejemplo sería:

2016-05-16T00:00:00+0000

Ver también

  • DatePeriod::getEndDate() - Obtener la fecha final
  • DatePeriod::getDateInterval() - Obtener el intervalo


Funciones de Fecha/Hora

Tabla de contenidos

  • checkdate — Validar una fecha gregoriana
  • date_add — Alias de DateTime::add
  • date_create_from_format — Alias de DateTime::createFromFormat
  • date_create_immutable_from_format — Alias de DateTimeImmutable::createFromFormat
  • date_create_immutable — Alias de DateTimeImmutable::__construct
  • date_create — Alias de DateTime::__construct
  • date_date_set — Alias de DateTime::setDate
  • date_default_timezone_get — Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
  • date_default_timezone_set — Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
  • date_diff — Alias de DateTime::diff
  • date_format — Alias de DateTime::format
  • date_get_last_errors — Alias de DateTime::getLastErrors
  • date_interval_create_from_date_string — Alias de DateInterval::createFromDateString
  • date_interval_format — Alias de DateInterval::format
  • date_isodate_set — Alias de DateTime::setISODate
  • date_modify — Alias de DateTime::modify
  • date_offset_get — Alias de DateTime::getOffset
  • date_parse_from_format — Obtiene información de una fecha dada formateada de acuerdo al formato especificado
  • date_parse — Devuelve un array asociativo con información detallada acerca de una fecha dada
  • date_sub — Alias de DateTime::sub
  • date_sun_info — Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo
  • date_sunrise — Devuelve la hora de la salida del sol de un día y ubicación dados
  • date_sunset — Devuelve la hora de la puesta de sol de un día y ubicación dados
  • date_time_set — Alias de DateTime::setTime
  • date_timestamp_get — Alias de DateTime::getTimestamp
  • date_timestamp_set — Alias de DateTime::setTimestamp
  • date_timezone_get — Alias de DateTime::getTimezone
  • date_timezone_set — Alias de DateTime::setTimezone
  • date — Dar formato a la fecha/hora local
  • getdate — Obtener información de la fecha/hora
  • gettimeofday — Obtener la hora actual
  • gmdate — Formatea una fecha/hora GMT/UTC
  • gmmktime — Obtener la marca temporal de Unix para una fecha GMT
  • gmstrftime — Formatear una fecha/hora GMT/UTC según la configuración local
  • idate — Formatea una fecha/hora local como un entero
  • localtime — Obtiene fecha y hora local
  • microtime — Devuelve la fecha Unix actual con microsegundos
  • mktime — Obtener la marca de tiempo Unix de una fecha
  • strftime — Formatea una fecha/hora local según una configuración local
  • strptime — Analiza una fecha/hora generada con strftime
  • strtotime — Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix
  • time — Devuelve la fecha Unix actual
  • timezone_abbreviations_list — Alias de DateTimeZone::listAbbreviations
  • timezone_identifiers_list — Alias de DateTimeZone::listIdentifiers
  • timezone_location_get — Alias de DateTimeZone::getLocation
  • timezone_name_from_abbr — Devuelve el nombre de la zona horaria desde su abreviatura
  • timezone_name_get — Alias de DateTimeZone::getName
  • timezone_offset_get — Alias de DateTimeZone::getOffset
  • timezone_open — Alias de DateTimeZone::__construct
  • timezone_transitions_get — Alias de DateTimeZone::getTransitions
  • timezone_version_get — Obtiene la versión de la base de datos timezonedb


Validar una fecha gregoriana

  • « Funciones de Fecha/Hora
  • date_add »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Validar una fecha gregoriana

checkdate

(PHP 4, PHP 5, PHP 7, PHP 8)

checkdate — Validar una fecha gregoriana

Descripción

checkdate ( int $month , int $day , int $year ) : bool

Comprueba la validez de una fecha formada por los argumentos. Una fecha se considera válida si cada parámetro está propiamente definido.

Parámetros

month

El mes entre 1 y 12 inclusive.

day

El día que está dentro del número de días del mes month dado. Los años year bisiestos son tomados en consideración.

year

El año entre 1 y 32767 inclusive.

Valores devueltos

Devuelve true si la fecha dada es válida, si no, devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de checkdate()

<?php
var_dump(checkdate(12, 31, 2000));
var_dump(checkdate(2, 29, 2001));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ver también

  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • strtotime() - Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix


Alias de DateTime::add

  • « checkdate
  • date_create_from_format »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::add

date_add

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_add — Alias de DateTime::add()

Descripción

Esta función es un alias de: DateTime::add()


Alias de DateTime::createFromFormat

  • « date_add
  • date_create_immutable_from_format »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::createFromFormat

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_create_from_format — Alias de DateTime::createFromFormat()

Descripción

Esta función es un alias de: DateTime::createFromFormat()


Alias de DateTimeImmutable::createFromFormat

  • « date_create_from_format
  • date_create_immutable »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeImmutable::createFromFormat

date_create_immutable_from_format

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

date_create_immutable_from_format — Alias de DateTimeImmutable::createFromFormat()

Descripción

Esta función es un alias de: DateTimeImmutable::createFromFormat()


Alias de DateTimeImmutable::__construct

  • « date_create_immutable_from_format
  • date_create »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeImmutable::__construct

date_create_immutable

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

date_create_immutable — Alias de DateTimeImmutable::__construct()

Descripción

Esta función es un alias de: DateTimeImmutable::__construct()


Alias de DateTime::__construct

  • « date_create_immutable
  • date_date_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::__construct

date_create

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_create — Alias de DateTime::__construct()

Descripción

Esta función es un alias de: DateTime::__construct()


Alias de DateTime::setDate

  • « date_create
  • date_default_timezone_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::setDate

date_date_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_date_set — Alias de DateTime::setDate()

Descripción

Esta función es un alias de: DateTime::setDate()


Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

  • « date_date_set
  • date_default_timezone_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

date_default_timezone_get

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

date_default_timezone_get — Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

Descripción

date_default_timezone_get ( ) : string

En orden de preferencia, esta función devuelve la zona horaria predeternimada mediante:

  • Leer la zona horaria usando la función date_default_timezone_set() (si hay alguna)

  • Sólo antes de PHP 5.4.0: Leer la variable de entorno TZ (si no está vacía)

  • Leer el valor de la opción ini date.timezone (si está establecida)

  • Sólo antes de PHP 5.4.0: Preguntar al sistema operativo (siempre que el SO lo soporte y lo permita). Utiliza un algoritmo que debe estimar la zona horaria. No funcionará de forma necesariamente correcta en todas las situaciones posibles. Si se diera este caso, se mostrará una alerta. No se aconseja depender de esta función. En su lugar, debe establecerse la zona horaria correcta con date.timezone

Si nada de lo de arriba sucedió, date_default_timezone_get() devolverá una zona horaria predeterminada de UTC.

Valores devueltos

Devuelve un string.

Historial de cambios

Versión | Descripción
5.4.0 | La variable de entorno TZ ya no se usa para adivinar la zona horaria.
5.4.0 | La zona horaria ya no se adivina de la información disponible a través del sistema operativo, la zona horaria adivinada no puede invocarse.

Ejemplos

Ejemplo #1 Obtener la zona horaria por defecto

<?php
date_default_timezone_set('Europe/London');

if (date_default_timezone_get()) {
    echo 'date_default_timezone_set: ' . date_default_timezone_get() . '<br />';
}

if (ini_get('date.timezone')) {
    echo 'date.timezone: ' . ini_get('date.timezone');
}

?>

El resultado del ejemplo sería algo similar a:

date_default_timezone_set: Europe/London
date.timezone: Europe/London

Ejemplo #2 Obtener la abreviatura de una zona horaria

<?php
date_default_timezone_set('America/Los_Angeles');
echo date_default_timezone_get() . ' => ' . date('e') . ' => ' . date('T');
?>

El resultado del ejemplo sería:

America/Los_Angeles => America/Los_Angeles => PST

Ver también

  • date_default_timezone_set() - Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
  • Listado de zonas horarias admitidas


Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

  • « date_default_timezone_get
  • date_diff »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

date_default_timezone_set

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

date_default_timezone_set — Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script

Descripción

date_default_timezone_set ( string $timezone_identifier ) : bool

date_default_timezone_set() establece la zona horaria predetermiada usada por todas las funciones de fecha/hora.

Nota:

A partir de PHP 5.1.0 (cuando las funciones de fecha/hora fueron reescritas), cada llamada a la función de fecha/hora generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_WARNING si se usa la configuración del sistema o la variable de entorno TZ.

En vez de usar esta función para establecer la zona horaria predeterminada en su script, puede usar también la configuración INI date.timezone para establecer la zona horaria predeterminada.

Parámetros

timezone_identifier

El indentificador de la zona horaria, como UTC o Europe/Lisbon. La lista de los identificadores válidos está disponible en la Listado de zonas horarias admitidas.

Valores devueltos

Esta función devuelve false si timezone_identifier no es válido, o true de otro modo.

Ejemplos

Ejemplo #1 Obtener la zona horaria por defecto

<?php
date_default_timezone_set('America/Los_Angeles');

$script_tz = date_default_timezone_get();

if (strcmp($script_tz, ini_get('date.timezone'))){
    echo 'La zona horaria del script difiere de la zona horaria de la configuracion ini.';
} else {
    echo 'La zona horaria del script y la zona horaria de la configuración ini coinciden.';
}
?>

Historial de cambios

Versión | Descripción
5.3.0 | Ahora se lanza un E_WARNING en vez de un E_STRICT.
5.1.2 | La función comenzo a validar el parámetro timezone_identifier.

Ver también

  • date_default_timezone_get() - Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
  • Listado de zonas horarias admitidas


Alias de DateTime::diff

  • « date_default_timezone_set
  • date_format »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::diff

date_diff

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_diff — Alias de DateTime::diff()

Descripción

Esta función es un alias de: DateTime::diff()


Alias de DateTime::format

  • « date_diff
  • date_get_last_errors »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::format

date_format

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_format — Alias de DateTime::format()

Descripción

Esta función es un alias de: DateTime::format()


Alias de DateTime::getLastErrors

  • « date_format
  • date_interval_create_from_date_string »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::getLastErrors

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_get_last_errors — Alias de DateTime::getLastErrors()

Descripción

Esta función es un alias de: DateTime::getLastErrors()


Alias de DateInterval::createFromDateString

  • « date_get_last_errors
  • date_interval_format »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateInterval::createFromDateString

date_interval_create_from_date_string

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_interval_create_from_date_string — Alias de DateInterval::createFromDateString()

Descripción

Esta función es un alias de: DateInterval::createFromDateString()


Alias de DateInterval::format

  • « date_interval_create_from_date_string
  • date_isodate_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateInterval::format

date_interval_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_interval_format — Alias de DateInterval::format()

Descripción

Esta función es un alias de: DateInterval::format()


Alias de DateTime::setISODate

  • « date_interval_format
  • date_modify »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::setISODate

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_isodate_set — Alias de DateTime::setISODate()

Descripción

Esta función es un alias de: DateTime::setISODate()


Alias de DateTime::modify

  • « date_isodate_set
  • date_offset_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::modify

date_modify

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_modify — Alias de DateTime::modify()

Descripción

Esta función es un alias de: DateTime::modify()


Alias de DateTime::getOffset

  • « date_modify
  • date_parse_from_format »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::getOffset

date_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_offset_get — Alias de DateTime::getOffset()

Descripción

Esta función es un alias de: DateTime::getOffset()


Obtiene información de una fecha dada formateada de acuerdo al formato especificado

  • « date_offset_get
  • date_parse »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtiene información de una fecha dada formateada de acuerdo al formato especificado

date_parse_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_parse_from_format — Obtiene información de una fecha dada formateada de acuerdo al formato especificado

Descripción

date_parse_from_format ( string $format , string $date ) : array

Devuelve una matriz asociativa con información detallada acerca de la fecha dada.

Parámetros

format

Un formato aceptado por DateTime::createFromFormat().

date

Una cadena que representa la fecha.

Valores devueltos

Devuelve una matriz asociativa con información detallada de la fecha dada.

Historial de cambios

Versión | Descripción
7.2.0 | El elemento de zone devuelto representa ahora segundos en lugar de minutos, y su signo está invertido. Por ejemplo -120 es ahora 7200.

Ejemplos

Ejemplo #1 Ejemplo de date_parse_from_format()

<?php
$fecha = "6.1.2009 13:00+01:00";
print_r(date_parse_from_format("j.n.Y H:iP", $fecha));
?>

El resultado del ejemplo sería:

Array
(
    [year] => 2009
    [month] => 1
    [day] => 6
    [hour] => 13
    [minute] => 0
    [second] => 0
    [fraction] =>
    [warning_count] => 0
    [warnings] => Array
        (
        )

    [error_count] => 0
    [errors] => Array
        (
        )

    [is_localtime] => 1
    [zone_type] => 1
    [zone] => 3600
    [is_dst] =>
)

Ver también

  • DateTime::createFromFormat() - Analiza una cadena con un instante según un formato especificado
  • checkdate() - Validar una fecha gregoriana


Devuelve un array asociativo con información detallada acerca de una fecha dada

  • « date_parse_from_format
  • date_sub »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve un array asociativo con información detallada acerca de una fecha dada

date_parse

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_parse — Devuelve un array asociativo con información detallada acerca de una fecha dada

Descripción

date_parse ( string $date ) : array

Parámetros

date

La fecha en un formato aceptado por strtotime().

Valores devueltos

Devuelve un array con información sobre la fecha analizada si tuvo éxito o false en caso de error.

Errores/Excepciones

En caso de que el formato de fecha tenga un error, el elemento 'errors' contendrá los mensajes de error.

Ejemplos

Ejemplo #1 Un ejemplo de date_parse()

<?php
print_r(date_parse("2006-12-12 10:00:00.5"));
?>

El resultado del ejemplo sería:

Array
(
    [year] => 2006
    [month] => 12
    [day] => 12
    [hour] => 10
    [minute] => 0
    [second] => 0
    [fraction] => 0.5
    [warning_count] => 0
    [warnings] => Array()
    [error_count] => 0
    [errors] => Array()
    [is_localtime] =>
)

Los formatos relativos no influyen en los valores de los formatos absolutos, aunque son convertidos en el elemento "relative".

Ejemplo #2 date_parse() con formatos relativos

<?php
print_r(date_parse("2006-12-12 10:00:00.5 +1 week +1 hour"));
?>

El resultado del ejemplo sería:

Array
(
    [year] => 2006
    [month] => 12
    [day] => 12
    [hour] => 10
    [minute] => 0
    [second] => 0
    [fraction] => 0.5
    [warning_count] => 0
    [warnings] => Array
        (
        )

    [error_count] => 0
    [errors] => Array
        (
        )

    [is_localtime] =>
    [relative] => Array
        (
            [year] => 0
            [month] => 0
            [day] => 7
            [hour] => 1
            [minute] => 0
            [second] => 0
        )

)

Ver también

  • checkdate() - Validar una fecha gregoriana
  • getdate() - Obtener información de la fecha/hora


Alias de DateTime::sub

  • « date_parse
  • date_sun_info »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::sub

date_sub

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_sub — Alias de DateTime::sub()

Descripción

Esta función es un alias de: DateTime::sub()


Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo

  • « date_sub
  • date_sunrise »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo

date_sun_info

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

date_sun_info — Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo

Descripción

date_sun_info ( int $time , float $latitude , float $longitude ) : array

Parámetros

time

Marca de tiempo.

latitude

Latitud en grados.

longitude

Longitud en grados.

Valores devueltos

Devuelve una matriz si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de date_sun_info()

<?php
$sun_info = date_sun_info(strtotime("2006-12-12"), 31.7667, 35.2333);
foreach ($sun_info as $clave => $valor) {
    echo "$clave: " . date("H:i:s", $valor) . "\n";
}
?>

El resultado del ejemplo sería:

sunrise: 05:52:11
sunset: 15:41:21
transit: 10:46:46
civil_twilight_begin: 05:24:08
civil_twilight_end: 16:09:24
nautical_twilight_begin: 04:52:25
nautical_twilight_end: 16:41:06
astronomical_twilight_begin: 04:21:32
astronomical_twilight_end: 17:12:00

Ver también

  • date_sunrise() - Devuelve la hora de la salida del sol de un día y ubicación dados
  • date_sunset() - Devuelve la hora de la puesta de sol de un día y ubicación dados


Devuelve la hora de la salida del sol de un día y ubicación dados

  • « date_sun_info
  • date_sunset »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve la hora de la salida del sol de un día y ubicación dados

date_sunrise

(PHP 5, PHP 7, PHP 8)

date_sunrise — Devuelve la hora de la salida del sol de un día y ubicación dados

Descripción

date_sunrise ( int $timestamp , int $format = SUNFUNCS_RET_STRING , float $latitude = ini_get("date.default_latitude") , float $longitude = ini_get("date.default_longitude") , float $zenith = ini_get("date.sunrise_zenith") , float $gmt_offset = 0 ) : mixed

date_sunrise() devuelve la hora de la salida del sol para un día (especificado como timestamp) y ubicación dados.

Parámetros

timestamp

La marca de tiempo timestamp del día del que se va a tomar la salida del sol.

format

Constantes format
constante | descripción | ejemplo
SUNFUNCS_RET_STRING | devuelve el resultado como string | 16:46
SUNFUNCS_RET_DOUBLE | devuelve el resultado como float | 16.78243132
SUNFUNCS_RET_TIMESTAMP | devuelve el resultado como integer (timestamp) | 1095034606

latitude

La latitud, por defecto a Norte, y como valor negativo a Sur. Vea también: date.default_latitude

longitude

La longitud, por defecto a Este, y como valor negativo a Oeste. Vea tambien: date.default_longitude

zenith

El cénit, por defecto: date.sunset_zenith

gmtoffset

El índice GMT especificado en horas.

Valores devueltos

Devuelve la hora de la salida del sol en un formato format especificado si se tuvo éxito o false en caso de error.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo de date_sunrise()

<?php

/* calcular la salida del sol para Lisboa, Portugal
Latitud: 38.4 Norte
Longitud: 9 Oeste
Cenit ~= 90
Índice: +1 GMT
*/

echo date("D M d Y"). ', hora de la salida del sol : ' .date_sunrise(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

El resultado del ejemplo sería algo similar a:

Mon Dec 20 2004, hora de la salida del sol : 08:54

Ver también

  • date_sunset() - Devuelve la hora de la puesta de sol de un día y ubicación dados


Devuelve la hora de la puesta de sol de un día y ubicación dados

  • « date_sunrise
  • date_time_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve la hora de la puesta de sol de un día y ubicación dados

date_sunset

(PHP 5, PHP 7, PHP 8)

date_sunset — Devuelve la hora de la puesta de sol de un día y ubicación dados

Descripción

date_sunset ( int $timestamp , int $format = SUNFUNCS_RET_STRING , float $latitude = ini_get("date.default_latitude") , float $longitude = ini_get("date.default_longitude") , float $zenith = ini_get("date.sunset_zenith") , float $gmt_offset = 0 ) : mixed

date_sunset() devuelve la hora de la puesta de sol para un día (especificado como timestamp) y ubicación dados.

Parámetros

timestamp

La marca de tiempo timestamp del día del que se va a tomar la puesta de sol.

format

Constantes format
constante | descripción | ejemplo
SUNFUNCS_RET_STRING | devuelve el resultado como string | 16:46
SUNFUNCS_RET_DOUBLE | devuelve el resultado como float | 16.78243132
SUNFUNCS_RET_TIMESTAMP | devuelve el resultado como integer (timestamp) | 1095034606

latitude

La latitud, por defecto a Norte, y como valor negativo a Sur. Vea también: date.default_latitude

longitude

La longitud, por defecto a Este, y como valor negativo a Oeste. Vea tambien: date.default_longitude

zenith

El cénit, por defecto: date.sunset_zenith

gmtoffset

El índice GMT especificado en horas.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Valores devueltos

Devuelve la hora de la puesta de sol en un formato format especificado si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de date_sunset()

<?php

/* calcular la puesta de sol para Lisboa, Portugal
Latitud: 38.4 Norte
Longitud: 9 Oeste
Cenit ~= 90
Índice: +1 GMT
*/

echo date("D M d Y"). ', hora de la puesta de sol : ' .date_sunset(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

El resultado del ejemplo sería algo similar a:

Mon Dec 20 2004, hora de la puesta de sol : 18:13

Ver también

  • date_sunrise() - Devuelve la hora de la salida del sol de un día y ubicación dados


Alias de DateTime::setTime

  • « date_sunset
  • date_timestamp_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::setTime

date_time_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_time_set — Alias de DateTime::setTime()

Descripción

Esta función es un alias de: DateTime::setTime()


Alias de DateTime::getTimestamp

  • « date_time_set
  • date_timestamp_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::getTimestamp

date_timestamp_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_timestamp_get — Alias de DateTime::getTimestamp()

Descripción

Esta función es un alias de: DateTime::getTimestamp()


Alias de DateTime::setTimestamp

  • « date_timestamp_get
  • date_timezone_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::setTimestamp

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_timestamp_set — Alias de DateTime::setTimestamp()

Descripción

Esta función es un alias de: DateTime::setTimestamp()


Alias de DateTime::getTimezone

  • « date_timestamp_set
  • date_timezone_set »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::getTimezone

date_timezone_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_timezone_get — Alias de DateTime::getTimezone()

Descripción

Esta función es un alias de: DateTime::getTimezone()


Alias de DateTime::setTimezone

  • « date_timezone_get
  • date »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTime::setTimezone

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_timezone_set — Alias de DateTime::setTimezone()

Descripción

Esta función es un alias de: DateTime::setTimezone()


Dar formato a la fecha/hora local

  • « date_timezone_set
  • getdate »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Dar formato a la fecha/hora local

date

(PHP 4, PHP 5, PHP 7, PHP 8)

date — Dar formato a la fecha/hora local

Descripción

date ( string $format , int $timestamp = time() ) : string

Devuelve una cadena formateada según el formato dado usando el parámetro de tipo integer timestamp dado o el momento actual si no se da una marca de tiempo. En otras palabras, timestamp es opcional y por defecto es el valor de time().

Parámetros

format

El formato de la fecha de salida tipo string. Vea las opciones de formato más abajo. También hay varias constantes de fecha predefinidas que pueden usarse en su lugar, así por ejemplo DATE_RSS contiene la cadena de formato 'D, d M Y H:i:s'.

Los siguientes caracteres están reconocidos en el parámetro de cadena format
Carácter de format | Descripción | Ejemplo de valores devueltos
Día --- ---
d | Día del mes, 2 dígitos con ceros iniciales | 01 a 31
D | Una representación textual de un día, tres letras | Mon hasta Sun
j | Día del mes sin ceros iniciales | 1 a 31
l ('L' minúscula) | Una representación textual completa del día de la semana | Sunday hasta Saturday
N | Representación numérica ISO-8601 del día de la semana (añadido en PHP 5.1.0) | 1 (para lunes) hasta 7 (para domingo)
S | Sufijo ordinal inglés para el día del mes, 2 caracteres | st, nd, rd o th. Funciona bien con j
w | Representación numérica del día de la semana | 0 (para domingo) hasta 6 (para sábado)
z | El día del año (comenzando por 0) | 0 hasta 365
Semana --- ---
W | Número de la semana del año ISO-8601, las semanas comienzan en lunes | Ejemplo: 42 (la 42ª semana del año)
Mes --- ---
F | Una representación textual completa de un mes, como January o March | January hasta December
m | Representación numérica de un mes, con ceros iniciales | 01 hasta 12
M | Una representación textual corta de un mes, tres letras | Jan hasta Dec
n | Representación numérica de un mes, sin ceros iniciales | 1 hasta 12
t | Número de días del mes dado | 28 hasta 31
Año --- ---
L | Si es un año bisiesto | 1 si es bisiesto, 0 si no.
o | Año según el número de la semana ISO-8601. Esto tiene el mismo valor que Y, excepto que si el número de la semana ISO (W) pertenece al año anterior o siguiente, se usa ese año en su lugar. (añadido en PHP 5.1.0) | Ejemplos: 1999 o 2003
Y | Una representación numérica completa de un año, 4 dígitos | Ejemplos: 1999 o 2003
y | Una representación de dos dígitos de un año | Ejemplos: 99 o 03
Hora --- ---
a | Ante meridiem y Post meridiem en minúsculas | am o pm
A | Ante meridiem y Post meridiem en mayúsculas | AM o PM
B | Hora Internet | 000 hasta 999
g | Formato de 12 horas de una hora sin ceros iniciales | 1 hasta 12
G | Formato de 24 horas de una hora sin ceros iniciales | 0 hasta 23
h | Formato de 12 horas de una hora con ceros iniciales | 01 hasta 12
H | Formato de 24 horas de una hora con ceros iniciales | 00 hasta 23
i | Minutos con ceros iniciales | 00 hasta 59
s | Segundos con ceros iniciales | 00 hasta 59
u | Microsegundos (añadido en PHP 5.2.2). Observe que date() siempre generará 000000 ya que toma un parámetro de tipo integer, mientras que DateTime::format() admite microsegundos si DateTime fue creado con microsegundos. | Ejemplo: 654321
v | Milisegundos (añadido en PHP 7.0.0). La misma observación se aplica para u. | Example: 654
Zona Horaria --- ---
e | Identificador de zona horaria (añadido en PHP 5.1.0) | Ejemplos: UTC, GMT, Atlantic/Azores
I (i mayúscula) | Si la fecha está en horario de verano o no | 1 si está en horario de verano, 0 si no.
O | Diferencia de la hora de Greenwich (GMT) sin colon entre horas y minutos | Ejemplo: +0200
P | Diferencia con la hora de Greenwich (GMT) con dos puntos entre horas y minutos (añadido en PHP 5.1.3) | Ejemplo: +02:00
T | Abreviatura de la zona horaria | Ejemplos: EST, MDT ...
Z | Índice de la zona horaria en segundos. El índice para zonas horarias al oeste de UTC siempre es negativo, y para aquellas al este de UTC es siempre positivo. | -43200 hasta 50400
Fecha/Hora Completa --- ---
c | Fecha ISO 8601 (añadido en PHP 5) | 2004-02-12T15:19:21+00:00
r | Fecha con formato » RFC 2822 | Ejemplo: Thu, 21 Dec 2000 16:01:07 +0200
U | Segundos desde la Época Unix (1 de Enero del 1970 00:00:00 GMT) | Vea también time()

Los caracteres no reconocidos en la cadena de formato serán impresos tal cual. El formato Z siempre devolverá 0 cuando se usa gmdate().

Nota:

Ya que esta función sólo acepta marcas de tiempo de tipo integer el carácter de formato u sólo es útil cuando se usa la función date_format() con marcas de tiempo basadas en usuario creadas con date_create().

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve una cadena de fecha formateada. Si se usa un valor no numérico para timestamp, se devuelve false y se emite un error de nivel E_WARNING.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.1.1 | Hay constantes útiles de los formatos estándar de fecha/hora que pueden utilizarse para especificar el parámetro format.
5.1.0 | El rango válido de una marca de tiempo es típicamente desde Fri, 13 Dec 1901 20:45:54 GMT a Tue, 19 Jan 2038 03:14:07 GMT. (Estas son las fechas que corresponden a los valores mínimo y máximo de un entero con signo de 32 bit). Sin embargo, antes de PHP 5.1.0 este rango estaba limitado desde 01-01-1970 a 19-01-2038 en algunos sistemas (p.ej. Windows).
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo de date()

<?php
// Establecer la zona horaria predeterminada a usar. Disponible desde PHP 5.1
date_default_timezone_set('UTC');

// Imprime algo como: Monday
echo date("l");

// Imprime algo como: Monday 8th of August 2005 03:12:46 PM
echo date('l jS \of F Y h:i:s A');

// Imprime: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

/* Usar las constantes en el parámetro de formato */
// Imprime algo como: Wed, 25 Sep 2013 15:28:57 -0700
echo date(DATE_RFC2822);

// Imprime algo como: 2000-07-01T00:00:00+00:00
echo date(DATE_ATOM, mktime(0, 0, 0, 7, 1, 2000));
?>

Puede prevenir que un carácter reconocido en la cadena de formato sea expandido escapándolo con una barra invertida precedente. Si el carácter con una barra invertida es ya una secuencia especial, necesitará escapar también la barra invertida.

Ejemplo #2 Escapar caracteres en date()

<?php
// imprime algo como: Wednesday the 15th
echo date('l \t\h\e jS');
?>

Es posible usar date() y mktime() juntos para buscar fechas en el futuro o en el pasado.

Ejemplo #3 Ejemplo de date() y mktime()

<?php
$mañana        = mktime(0, 0, 0, date("m")  , date("d")+1, date("Y"));
$mes_anterior  = mktime(0, 0, 0, date("m")-1, date("d"),   date("Y"));
$año_siguiente = mktime(0, 0, 0, date("m"),   date("d"),   date("Y")+1);
?>

Nota:

Esto puede ser más fiable que añadir o sustraer simplemente el número de segundos de un día o mes a una marca de tiempo debido al horario de verano.

Algunos ejemplos de formatear date(). Observe que debería escapar cualesquiera otros caracteres, ya que cualquiera que tenga actualmente un significado especial producirá resultados no deseados, y a otros caracteres se les pueden asignar significado en futuras versiones de PHP. Cuando se escapa un carácter, asegúrese de usar comillas simples para prevenir que caracteres como \n se conviertan en nuevas líneas.

Ejemplo #4 date() Formatting

<?php
// Se asume que hoy es March 10th, 2001, 5:16:18 pm, y que estamos en la
// zona horaria Mountain Standard Time (MST)

$hoy = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$hoy = date("m.d.y");                         // 03.10.01
$hoy = date("j, n, Y");                       // 10, 3, 2001
$hoy = date("Ymd");                           // 20010310
$hoy = date('h-i-s, j-m-y, it is w Day');     // 05-16-18, 10-03-01, 1631 1618 6 Satpm01
$hoy = date('\i\t \i\s \t\h\e jS \d\a\y.');   // it is the 10th day.
$hoy = date("D M j G:i:s T Y");               // Sat Mar 10 17:16:18 MST 2001
$hoy = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:18 m is month
$hoy = date("H:i:s");                         // 17:16:18
$hoy = date("Y-m-d H:i:s");                   // 2001-03-10 17:16:18 (el formato DATETIME de MySQL)
?>

Para formatear fechas en otros lenguajes debería usar las funciones setlocale() y strftime() en vez de date().

Notas

Nota:

Para generar una marca de tiempo desde una cadena que representa la fecha, puede usar strtotime(). Adicionalmente, algunas bases de datos tienen funciones para convertir formatos de fecha en marcas de tiempo (como la función » UNIX_TIMESTAMP de MySQL).

Sugerencia

La marca de tiempo del inicio de una petición está disponible en $_SERVER['REQUEST_TIME'] desde PHP 5.1.

Ver también

  • gmdate() - Formatea una fecha/hora GMT/UTC
  • idate() - Formatea una fecha/hora local como un entero
  • getdate() - Obtener información de la fecha/hora
  • getlastmod() - Obtiene la hora de la última modificación de la página
  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • strftime() - Formatea una fecha/hora local según una configuración local
  • time() - Devuelve la fecha Unix actual
  • strtotime() - Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix
  • Constantes Predefinidas de DateTime


Obtener información de la fecha/hora

  • « date
  • gettimeofday »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtener información de la fecha/hora

getdate

(PHP 4, PHP 5, PHP 7, PHP 8)

getdate — Obtener información de la fecha/hora

Descripción

getdate ( int $timestamp = time() ) : array

Devuelve un array asociativo que contiene la información de la fecha de timestamp, o el momento local actual si no se da timestamp.

Parámetros

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve un array asociativo con información relacionada con la marca de tiempo timestamp. Los elementos devueltos de la matriz asociativa son los siguientes:

Las claves de la matriz asociativa devuelta
Clave | Descripción | Ejemplo de valores devueltos
"seconds" | Representacion numérica de los segundos | 0 a 59
"minutes" | Representacion numérica de los minutos | 0 a 59
"hours" | Representacion numérica de las horas | 0 a 23
"mday" | Representacion numérica del día del mes | 1 a 31
"wday" | Representacion numérica del día de la semana | 0 (para Domingo) hasta 6 (para Sábado)
"mon" | Representacion numérica de un mes | 1 hasta 12
"year" | Una representacion numérica completa de una año, 4 dígitos | Ejemplos: 1999 o 2003
"yday" | Representacion numérica del día del año | 0 hasta 365
"weekday" | Una representación textual completa del día de la semana | Sunday hasta Saturday
"month" | Una representación textual completa de un mes, como January o March | January hasta December
0 | Los segundos desde la Época Unix, similar a los valores devueltos por time() y usados por date(). | Dependiente del Sistema, típicamente -2147483648 hasta 2147483647.

Ejemplos

Ejemplo #1 Ejemplo de getdate()

<?php
$hoy = getdate();
print_r($hoy);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [seconds] => 40
    [minutes] => 58
    [hours]   => 21
    [mday]    => 17
    [wday]    => 2
    [mon]     => 6
    [year]    => 2003
    [yday]    => 167
    [weekday] => Tuesday
    [month]   => June
    [0]       => 1055901520
)

Ver también

  • date() - Dar formato a la fecha/hora local
  • idate() - Formatea una fecha/hora local como un entero
  • localtime() - Obtiene fecha y hora local
  • time() - Devuelve la fecha Unix actual
  • setlocale() - Establecer la información del localismo


Obtener la hora actual

  • « getdate
  • gmdate »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtener la hora actual

gettimeofday

(PHP 4, PHP 5, PHP 7, PHP 8)

gettimeofday — Obtener la hora actual

Descripción

gettimeofday ( bool $return_float = false ) : mixed

Esta es una interfaz a gettimeofday(2). Devuelve una matriz asociativa que contiene la información devuelta por la llamada al sistema.

Parámetros

return_float

Cuando se establece a true, se devuelve un float en vez de un array.

Valores devueltos

Por defecto se devuelve un array. Si return_float está establecido, se devuelve un float.

Claves de la matriz:

  • "sec" - segundos desde la Época Unix
  • "usec" - microsegundos
  • "minuteswest" - minutos al oeste de Greenwich
  • "dsttime" - tipo de corrección del horario de verano (dst)

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro return_float.

Ejemplos

Ejemplo #1 Ejemplo de gettimeofday()

<?php
print_r(gettimeofday());

echo gettimeofday(true);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [sec] => 1073504408
    [usec] => 238215
    [minuteswest] => 0
    [dsttime] => 1
)

1073504408.23910


Formatea una fecha/hora GMT/UTC

  • « gettimeofday
  • gmmktime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Formatea una fecha/hora GMT/UTC

gmdate

(PHP 4, PHP 5, PHP 7, PHP 8)

gmdate — Formatea una fecha/hora GMT/UTC

Descripción

gmdate ( string $format , int $timestamp = time() ) : string

Idéntica a la función date() excepto que la fecha/hora devuelta es en Greenwich Mean Time (GMT).

Parámetros

format

El formato de la fecha (string) a mostrar. Ver las opciones de formato de la función date().

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve una fecha en formato GMT. Si se usa un valor no numérico en timestamp, devolverá false y se lanzará un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.1.0 | El rango válido de una marca de tiempo es típicamente desde Fri, 13 Dec 1901 20:45:54 GMT a Tue, 19 Jan 2038 03:14:07 GMT. (Estas son las fechas que corresponden a los valores mínimo y máximo de un entero con signo de 32-bit). Sin embargo, antes de PHP 5.1.0 este rango estaba limitado desde 01-01-1970 a 19-01-2038 en algunos sistemas (p.ej. Windows).
5.1.1 | Hay constantes útiles de formatos de fecha/hora estándar que se pueden usar para especificar el parámetro format.

Ejemplos

Ejemplo #1 Ejemplo de gmdate()

Cuando se ejecuta en Finlandia (GMT +0200), la primera línea de abajo imprimirá "Jan 01 1998 00:00:00", mientras que la segunda imprimirá "Dec 31 1997 22:00:00".

<?php
echo date("M d Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
echo gmdate("M d Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
?>

Ver también

  • date() - Dar formato a la fecha/hora local
  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • gmmktime() - Obtener la marca temporal de Unix para una fecha GMT
  • strftime() - Formatea una fecha/hora local según una configuración local


Obtener la marca temporal de Unix para una fecha GMT

  • « gmdate
  • gmstrftime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtener la marca temporal de Unix para una fecha GMT

gmmktime

(PHP 4, PHP 5, PHP 7, PHP 8)

gmmktime — Obtener la marca temporal de Unix para una fecha GMT

Descripción

gmmktime
 ( int $hour = gmdate("H")
, int $minute = gmdate("i")
, int $second = gmdate("s")
, int $month = gmdate("n")
, int $day = gmdate("j")
, int $year = gmdate("Y")
, int $is_dst = -1
) : int

Idéntica a mktime() excepto que los parámetros pasados representan una fecha GMT. gmmktime() internamente usa mktime() por lo que sólo los momento válidos derivados del momento local se pueden usar.

Como en mktime(), los argumentos pueden ser expuestos en orden de derecha a izquierda, con cualquier argumento que se omita establecido al valor GMT correspondiente actual.

Parámetros

hour

El número de la hora relativo al inicio del día determinado por month, day y year. Los valores negativos referencias la hora antes de la media noche del día en cuestión. Los valores mayores que 23 referencian la hora apropiada en el/los día/s siguiente/s.

minute

El número del minuto relativo al inicio de hour. Los valores negativos referencian el minuto en la hora previa. Los valores maayores que 59 referencian el minuto apropiado en la/s hora/s siguiente/s.

second

El número de segundos relativo al inicio de minute. Los valores negativos referencian el segundo en el minuto previo. Los valores mayores que 59 referencian el segundo apropiado en el/los minuto/s siguiente/s.

month

El número del mes relativo al inicio del año previo. Los valores de 1 a 12 referencian los meses del calendario normal del año en cuestión. Los valores menores que 1 (incluyendo valores negativos) referencian los meses del año previo en orden inverso, por lo que 0 es December, -1 es November, etc. Los valores mayores que 12 referencian el mes apropiado en el/los año/s siguiente/s.

day

El número del día relativo al final del mes previo. Los valores del 1 al 28, 29, 30 o 31 (dependiendo del mes) referenciacn los días normales del mes relevante.the normal days in the relevant month. Los valores menores que 1 (incluyendo valores negativos) referencian los días del mes previo por lo que 0 es el último día del mes previo, -1 es el día anterior a ese, etc. Los valores mayores que el número de días del mes relevante referencian el día apropiado en el/los mes/es siguiente/s.

year

El año

is_dst

Los parámetros siempre representan una fecha GMT por lo que is_dst no influye en el resultado.

Nota:

Este parámetro ha sido eliminado en PHP 7.0.0.

Valores devueltos

Devuelve una marca de tiempo Unix de tipo integer.

Historial de cambios

Versión | Descripción
7.0.0 | El parámetro is_dst ha sido eliminado.
5.1.0 | A partir de PHP 5.1.0, el parámetro is_dst se volvió obsoleto. Como resultado, se podría usar en su lugar las nuevas características de manejo de zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo básico de gmmktime()

<?php
// Imprime: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", gmmktime(0, 0, 0, 7, 1, 2000));
?>

Ver también

  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • date() - Dar formato a la fecha/hora local
  • time() - Devuelve la fecha Unix actual


Formatear una fecha/hora GMT/UTC según la configuración local

  • « gmmktime
  • idate »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Formatear una fecha/hora GMT/UTC según la configuración local

gmstrftime

(PHP 4, PHP 5, PHP 7, PHP 8)

gmstrftime — Formatear una fecha/hora GMT/UTC según la configuración local

Descripción

gmstrftime ( string $format , int $timestamp = time() ) : string

Se comporta como strftime(), excepto que el instante devuelto es Tiempo medio de Greenwich (GMT). Por ejemplo, cuando se ejecuta en Hora estándar oriental (GMT -0500), la primera línea de abajo imprime "Dec 31 1998 20:00:00", mientras que la segunda imprime "Jan 01 1999 01:00:00".

Parámetros

format

Véase la descripción de strftime().

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve una cadena formateada según la cadena de formato dada empleando la marca temporal timestamp dada o el instante local actual si no se da una marca temporal. Los nombres del mes y del día de la semana y otras cadenas dependientes del lenguaje respetan el localismo establecido con setlocale().

Ejemplos

Ejemplo #1 Ejemplo de gmstrftime()

<?php
setlocale(LC_TIME, 'en_US');
echo strftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
echo gmstrftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
?>

Ver también

  • strftime() - Formatea una fecha/hora local según una configuración local


Formatea una fecha/hora local como un entero

  • « gmstrftime
  • localtime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Formatea una fecha/hora local como un entero

idate

(PHP 5, PHP 7, PHP 8)

idate — Formatea una fecha/hora local como un entero

Descripción

idate ( string $format , int $timestamp = time() ) : int

Devuelve un número formateado según la cadena de formato dada usando la marca de tiempo timestamp de tipo entero dado o el momento local actual si no se da la marca de tiempo. En otras palabras, timestamp es opcional y su valor por defecto es el de time().

A diferencia de date(), idate() acepta un sólo carácter en el parámetro format.

Parámetros

format

Los siguientes caracteres son reconocidos por el parámetro de cadena format
Caracter format | Descripción
B | Swatch Beat/Hora Internet
d | Día del mes
h | Hora (formato de 12 horas)
H | Hora (formato de 24 horas)
i | Minutos
I (i mayúscula) | devuelve 1 si el horario de verano (DST) está activado, 0 si no
L (l mayúscula) | devuelve 1 para años bisiestos, 0 si no
m | Número de mes
s | Segundos
t | Días en el mes actual
U | Segundos desde la Época Unix - 1 de enero de 1970 00:00:00 UTC - esto es lo mismo que en time()
w | Día de la semana (0 para Domingo)
W | Número del mes del año ISO-8601, las semanas comienzan en Lunes
y | Año (1 ó 2 dígitos - comprobar la anotación de abajo)
Y | Año (4 dígitos)
z | Día del año
Z | Ínidce de la zona horaria en segundos

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve un integer.

Ya que idate() devuelve siempre un integer y como éste nunca puede empezar por un "0", idate() puede devolver menos dígitos de los que se esperarían. Vea el ejemplo de abajo.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo de idate()

<?php
$timestamp = strtotime('1st January 2004'); //1072915200

// esto imprime el año en un formato de dos dígitos
// sin embargo, ya que éste podría empezar con un "0",
// sólo se imprime "4"
echo idate('y', $timestamp);
?>

Ver también

  • date() - Dar formato a la fecha/hora local
  • getdate() - Obtener información de la fecha/hora
  • time() - Devuelve la fecha Unix actual


Obtiene fecha y hora local

  • « idate
  • microtime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtiene fecha y hora local

localtime

(PHP 4, PHP 5, PHP 7, PHP 8)

localtime — Obtiene fecha y hora local

Descripción

localtime ( int $timestamp = time() , bool $is_associative = false ) : array

La función localtime() devuelve un array con la estructura idéntica a la devuelta por la llamada a la función en C.

Parámetros

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

is_associative

Si está defindo como false o no se proporciona, el array es devuelto como un array indexado numéricamente. Si el argumento está definido como true, localtime() devuelve un array asociativo que contiene todos los diferentes elementos de la estructura devuelta por la llamada a la fucnión de C localtime. Los nombres de las diferentes claves del array asociativo son los siguientes:

  • "tm_sec" - segundos, 0 a 59
  • "tm_min" - minutos, 0 a 59
  • "tm_hour" - horas, 0 a 23
  • "tm_mday" - día del mes, 1 a 31
  • "tm_mon" - mes del año, 0 (Ene) a 11 (Dic)
  • "tm_year" - años desde 1900
  • "tm_wday" - día de la semana, 0 (Domingo) a 6 (Sábado)
  • "tm_yday" - día del año, 0 to 365
  • "tm_isdst" - ¿Está en horario de verano? Valor positivo si es que sí, 0 si es que no, negativo en caso que no se sepa.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo de localtime()

<?php
$localtime = localtime();
$localtime_assoc = localtime(time(), true);
print_r($localtime);
print_r($localtime_assoc);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 24
    [1] => 3
    [2] => 19
    [3] => 3
    [4] => 3
    [5] => 105
    [6] => 0
    [7] => 92
    [8] => 1
)

Array
(
    [tm_sec] => 24
    [tm_min] => 3
    [tm_hour] => 19
    [tm_mday] => 3
    [tm_mon] => 3
    [tm_year] => 105
    [tm_wday] => 0
    [tm_yday] => 92
    [tm_isdst] => 1
)

Ver también

  • getdate() - Obtener información de la fecha/hora


Devuelve la fecha Unix actual con microsegundos

  • « localtime
  • mktime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve la fecha Unix actual con microsegundos

microtime

(PHP 4, PHP 5, PHP 7, PHP 8)

microtime — Devuelve la fecha Unix actual con microsegundos

Descripción

microtime ( bool $get_as_float = false ) : mixed

microtime() devuelve la fecha Unix actual con microsegundos. Esta función sólo está disponible en sistemas operativos que soportan la llamada al sistema de gettimeofday().

Parámetros

get_as_float

Si se usa y se establece a true, microtime() devolverá un float en vez de un string, como está descrito en la sección de valores de retorno de abajo.

Valores devueltos

Por omisión, microtime() devuelve un string en la forma "mseg seg", donde seg es el número de segundos desde la época Unix (0:00:00 January 1, 1970 GMT), y msec es el número de microsegundos que han transcurrido desde sec, expresado en segundos.

Si get_as_float está establecido a true, microtime() devuelve un float, que representa el momento actual en segundos desde la época Unix con precisión al microsegundo más cercano.

Ejemplos

Ejemplo #1 Ejecución de un script de cronometraje con microtime()

<?php
/**
 * Función sencilla para repetir el comportamiento de PHP 5
 */
function microtime_float()
{
    list($usec, $sec) = explode(" ", microtime());
    return ((float)$usec + (float)$sec);
}

$time_start = microtime_float();

// Dormir por un momento
usleep(100);

$time_end = microtime_float();
$time = $time_end - $time_start;

echo "No se hizo nada en $time segundos\n";
?>

Ejemplo #2 Ejecución de un script de cronometraje en PHP 5

<?php
$time_start = microtime(true);

// Dormir por un momento
usleep(100);

$time_end = microtime(true);
$time = $time_end - $time_start;

echo "No se hizo nada en $time segundos\n";
?>

Ejemplo #3 microtime() y REQUEST_TIME_FLOAT (desde PHP 5.4.0)

<?php
// Tiempo de espera aleatorio
usleep(mt_rand(100, 10000));

// A partir de PHP 5.4.0, REQUEST_TIME_FLOAT está disponible en el array superglobal $_SERVER
// Contiene la fecha Unix en la que se realizó la petición con precisión de milisegundos.
$time = microtime(true) - $_SERVER["REQUEST_TIME_FLOAT"];

echo "No se hizo nada en $time segundos\n";
?>

Ver también

  • time() - Devuelve la fecha Unix actual


Obtener la marca de tiempo Unix de una fecha

  • « microtime
  • strftime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtener la marca de tiempo Unix de una fecha

mktime

(PHP 4, PHP 5, PHP 7, PHP 8)

mktime — Obtener la marca de tiempo Unix de una fecha

Descripción

mktime
 ( int $hour = date("H")
, int $minute = date("i")
, int $second = date("s")
, int $month = date("n")
, int $day = date("j")
, int $year = date("Y")
, int $is_dst = -1
) : int

Devuelve la marca de tiempo Unix correspondiente a los argumentos dados. Esta marca de tiempo es un entero que contiene el número de segundos entre la Época Unix (1 de Enero del 1970 00:00:00 GMT) y el instante especificado.

Los argumentos pueden omitirse de derecha a izquierda; cualquier argumento que se omita será establecido al valor actual según la fecha y hora locales.

Notas

Nota:

Desde PHP 5.1, cuando se hace la llamada sin argumentos, mktime() lanza un aviso de tipo E_STRICT: use la función time() en su lugar.

Parámetros

hour

El número de la hora relativa al inicio del día determinado por month, day y year. Los valores negativos referencian la hora antes de la media noche del día en cuestión. Los valores mayores que 23 referencian la hora apropiada en el/los día/s siguiente/s.

minute

El número de los minutos relativos al inicio de hour. Los valores negativos referencian el minuto en la hora previa. Los valores mayores que 59 referencian el minuto apropiado en la/s hora/s siguiente/s.

second

El número de segundos relativos al inicio de minute. Los valores negativos referencian el segundo en el minuto previo. Los valores mayores que 59 referencian el segundo apropiado en el/los minuto/s siguiente/s.

month

El número del mes relativo al final del año previo. Los valores de 1 a 12 referencian los meses del calendario normal del año en cuestión. Los valores menores que 1 (incluyendo valores negativos) referencian los meses del año previo en orden inverso, por lo que 0 es Diciembre, -1 es Noviembre, etc. Los valores mayores que 12 referencian el mes apropiado en el/los año/s siguiente/s.

day

El número del día relativo al final del mes previo. Los valores del 1 al 28, 29, 30 o 31 (dependiendo del mes) referencian los días normales del mes relevante. Los valores menores que 1 (incluyendo valores negativos) referencian los días del mes previo por lo que 0 es el último día del mes previo, -1 es el día anterior a ese, etc. Los valores mayores que el número de días del mes relevante referencian el día apropiado en el/los mes/es siguiente/s.

year

El número del año, puede ser un valor de dos o cuatro dígitos, con valores entre 0-69 mapeados a 2000-2069 y 70-100 a 1970-2000. En sistemas donde time_t es un entero con signo de 32 bits, como es lo más normal hoy en día, el rango válido para year es entre 1901 y 2038. Sin embargo, antes de PHP 5.1.0 este rango estaba limitado desde 1970 a 2038 en algunos sistemas (p.ej. Windows).

is_dst

Este parámetro se puede establecer a 1 si el instante está durante el horario de verano (DST), 0 si no, o -1 (por omisión) si no se sabe si el instante está durante el horario de verano. Si no se sabe, PHP lo intentará calcular por sí mismo. Esto puede causar resultados inesperados (pero no incorrectos). Algunas veces no son válidos si DST está habilitado en el sistema donde se ejecuta PHP o is_dst está establecido a 1. Si DST está habilitado a, p.ej. 2:00, todas las horas entre las 2:00 y las 3:00 no son válidas y mktime() devuelve un valor indefinido (normalmente negativo). Algunos sistemas (p.ej. Solaris 8) habilitan DST a la medianoche por lo que la hora 0:30 del día, cuando DST está habilitado, es evaluada como 23:30 del día anterior.

Nota:

A partir de PHP 5.1.0, este parámetro se volvió obsoleto. Como resultado, se pueden usar en su lugar las nuevas características de manejo de zonas horarias.

Nota:

Este parámetro ha sido eliminado en PHP 7.0.0.

Valores devueltos

mktime() devuelve la marca de tiempo Unix de los argumentos dados. Si los argumentos no son válidos, la función devuelve false (antes de PHP 5.1 devolvía -1).

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
7.0.0 | El parámetro is_dst ha sido eliminado.
5.3.0 | mktime() ahora lanza un aviso de tipo E_DEPRECATED si se usa el parámetro is_dst.
5.1.0 | El parámetro is_dst se volvió obsoleto. Hacía que la funcion devolviese false si se pruducía un error, en vez de -1. Arreglada la función para que acepte el año, mes y día pasados como cero.
5.1.0 | Cuando se hace la llamada sin argumento, mktime() lanza un aviso E_STRICT. Use la función time() en su lugar.
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Ejemplo #1 Ejemplo básico de mktime()

<?php
// Establecer la zona horaria predeterminada a usar. Disponible desde PHP 5.1
date_default_timezone_set('UTC');

// Imprime: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

// Imprime algo como: 2006-04-05T01:02:03+00:00
echo date('c', mktime(1, 2, 3, 4, 5, 2006));
?>

Ejemplo #2 Ejemplo de mktime()

mktime() es útil para hacer que las fechas sean aritméticas y válidas, ya que calculará automáticamente el valor correcto para las entradas que estén fuera de rango. Por ejemplo, cada una de las líneas siguientes producirá la cadena "Jan-01-1998".

<?php
echo date("M-d-Y", mktime(0, 0, 0, 12, 32, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 13, 1, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 1998));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 98));
?>

Ejemplo #3 El último día del mes

El último día de cualquier mes dado se puede expresar como el día "0" del mes siguiente, no el día -1. Los dos ejemplos siguientes producirán la cadena "El último día en Feb 2000 es: 29".

<?php
$último_día = mktime(0, 0, 0, 3, 0, 2000);
echo strftime("El último día en Feb 2000 es: %d", $último_día);
$último_día = mktime(0, 0, 0, 4, -31, 2000);
echo strftime("El último día en Feb 2000 es: %d", $último_día);
?>

Notas

Precaución

Antes de PHP 5.1.0, las marcas de tiempo negativas no estaban soportadas bajo ninguna versión de Windows conocida, y tampoco en otros sistemas. Por lo tanto el rango de años válidos estaba limitado desde 1970 hasta 2038.

Ver también

  • checkdate() - Validar una fecha gregoriana
  • gmmktime() - Obtener la marca temporal de Unix para una fecha GMT
  • date() - Dar formato a la fecha/hora local
  • time() - Devuelve la fecha Unix actual


Formatea una fecha/hora local según una configuración local

  • « mktime
  • strptime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Formatea una fecha/hora local según una configuración local

strftime

(PHP 4, PHP 5, PHP 7, PHP 8)

strftime — Formatea una fecha/hora local según una configuración local

Descripción

strftime ( string $format , int $timestamp = time() ) : string

Formatea una fecha/hora local según la configuración local. Los nombres del mes y del día de la semana y otras cadenas dependientes del lenguaje respetan el localismo establecido con setlocale().

No todos los especificadores de conversión pueden estar soportados por su biblioteca C, en cuyo caso no estarán soportados por la función strftime() de PHP. Además, no todas las plataformas soportan marcas temporales negativas, por lo que el rango de fechas puede estar limitado a fechas que no sean anteriores a la época Unix. Eso significa que %e, %T, %R y, %D (y posiblemente otros), así como las fechas anteriores al 1 de enero de 1970, no funcionarán en Windows, en algunas distribucioes de Linux, y en otros pocos sistemas operativos. Para los sistemas Windows, se puede encontrar un resumen de los especificadores de conversión soportados en » MSDN.

Parámetros

format

Los siguientes caracteres están reconocidos en el parámetro de cadena format
format | Descripción | Ejemplo de valores devueltos
Día --- ---
%a | Una representación textual abreviada del día | dom hasta sáb
%A | Una representación textual completa del día | domingo hasta sábado
%d | El día del mes con dos dígitos (con ceros iniciales) | 01 a 31
%e | El día del mes, con un espacio precediendo a los dígitos simples. No está implementado como está descrito en Windows. Véase más abajo para más información. | 1 a 31
%j | Día del año, tres dígitos con ceros iniciales | 001 a 366
%u | Representación numérica del día de la semana del ISO-8601 | 1 (para lunes) hasta 7 (para domingo)
%w | Representación numérica del día de la semana | 0 (para domingo) hasta 6 (para sábado)
Semana --- ---
%U | Número de semana del año dado, comenzando con el primer domingo como la primera semana | 13 (para la 13ª semana completa del año)
%V | Número de semana del año dado del ISO-8601:1988, comenzando con la primera semana del año con al menos 4 días de semana, con el lunes como principio de la semana | 01 hasta 53 (donde 53 cuenta para una semana traslapada)
%W | Una representación numérica de la semana del año, comenzando con el primer domingo como la primera semana | 46 (para la 46ª semana del año comenzando con un lunes)
Mes --- ---
%b | Nombre del mes abreviado, basado en el localismo | ene hasta dic
%B | Nombre del mes completo, basado en el localismo | enero hasta diciembre
%h | Nombre del mes abreviado, basado en el localismo (un alias de %b) | ene hasta dic
%m | Representación de dos dígitos del mes | 01 (para enero) hasta 12 (para diciembre)
Año --- ---
%C | Representación de dos dígitos del siglo (año dividido entre 100, truncado a un entero) | 19 para el Siglo XX
%g | Representación de dos dígitos del año por el estándar ISO-8601:1988 (véase %V) | Ejemplo: 09 para la semana del 6 de enero de 2009
%G | La versión completa de cuatro dígitos de %g | Ejemplo: 2008 para la semana del 3 de Enero de 2009
%y | Representación de dos dígitos del año | Ejemplo: 09 para 2009, 79 para 1979
%Y | Representación de cuatro dígitos del año | Ejemplo: 2038
Hora --- ---
%H | Representación de dos dígitos de la hora en formato de 24 horas | 00 hasta 23
%k | La hora en format de 24 horas, con un espacio precediendo a las horas de un dígito | 0 hasta 23
%I | Representación de dos dígitos de la hora en formato de 12 horas | 01 hasta 12
%l ('L' minúscula) | La hora en formato de 12 horas, con un espacio precediendo a los dígitos simples | 1 hasta 12
%M | Representación de dos dígitos de los minutos | 00 hasta 59
%p | "AM" o "PM" en MAYÚSCULAS basados en la hora dada | Ejemplo: AM para 00:31, PM para 22:23
%P | "am" o "pm" en minúsculas basados en la hora dada | Ejemplo: am para 00:31, pm para 22:23
%r | Lo mismo que "%I:%M:%S %p" | Ejemplo: 09:34:17 PM para 21:34:17
%R | Lo mismo que "%H:%M" | Ejemplo: 00:35 para 12:35 AM, 16:44 para 4:44 PM
%S | Representación de dos dígitos de los segundos | 00 hasta 59
%T | Lo mismo que "%H:%M:%S" | Ejemplo: 21:34:17 para 09:34:17 PM
%X | Representación preferida de la hora basda en el localismo, sin la fecha | Ejemplo: 03:59:16 o 15:59:16
%z | El índice de la zona horaria. No implementado como está descrito en Windows. Véase más abajo para más información. | Ejemplo: -0500 para Hora del Este de EEUU
%Z | La abreviatura de la zona horaria No implementado como está descrito en Windows. Véase más abajo para más información. | Ejemplo: EST para Hora del Este
Marcas de fecha y hora --- ---
%c | Marca preferida de la fecha y hora basadas en el localismo | Ejemplo: Tue Feb 5 00:45:10 2009 para el 5 de febrero de 2009 a las 12:45:10 AM
%D | Lo mismo que "%m/%d/%y" | Ejemplo: 02/05/09 para el 5 de febrero de 2009
%F | Lo mismo que "%Y-%m-%d" (normalmente usado en las marcas de fecha de bases de datos) | Ejemplo: 2009-02-05 para el 5 de febrero de 2009
%s | Marca temporal del instante de la Época Unix (lo mismo que la función time()) | Ejemplo: 305815200 para el 10 de septiembre de 1979 08:40:00 AM
%x | Representación preferida de la fecha basda en la configuración local, sin la hora | Ejemplo: 02/05/09 para el 5 de febrero de 2009
Miscelánea --- ---
%n Un carácter de nueva línea ("\n") ---
%t Un carácter de tabulación ("\t") ---
%% Un carácter de porcentaje literal ("%") ---

La longitud máxima de este parámetro es de 1023 caracteres.

Advertencia

A diferencia del ISO-9899:1999, Solaris de Sun comienza con el domingo como 1. Como resultado, %u podría no funcionar como está descrito en este manual.

Advertencia

Solamente para Windows:

El modificador %e no está soportado en la implementación para Windows de esta función. Para obtener este valor se puede usar en su lugar el modificador %#d. El ejemplo de abajo ilustra cómo escribir una función multiplataforma compatible.

Los modificadores %z y %Z devuelven el nombre de la zona horaria en lugar del índice o de la abreviatura.

Advertencia

Solamente para macOS: El modificador %P no está soportado en la implementación para macOS de esta función.

timestamp

El parámetro opcional timestamp es una marca temporal de Unix de tipo integer que por defecto es la hora local si no se proporciona ningún valor a timestamp. En otras palabras, es de forma predeterminada el valor de la función time().

Valores devueltos

Devuelve una cadena formateada según format empleando el parámetro timestamp dado o el instante local actual si no se da una marca temporal. Los nombres del mes y del día de la semana y otras cadenas dependientes del lenguaje respetan el localismo establecido con setlocale().

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Ya que la salida depende de la biblioteca C subyacente, algunos especificadores de conversión no están soportados. En Windows, proporcionar especificadores de conversión desconocidos resultará en 5 mensajes E_WARNING y devolverá false. En otros sistemas operativos podría no obtenerse ningún mensaje E_WARNING y la salida podría contener los especificadores de conversión no convertidos.

Historial de cambios

Versión | Descripción
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.

Ejemplos

Este ejemplo funcionará si se tienen instalados los localismos respectivos en el sistema.

Ejemplo #1 Ejemplos de localismos con strftime()

<?php
setlocale(LC_TIME, "C");
echo strftime("%A");
setlocale(LC_TIME, "fi_FI");
echo strftime(" en finlandés es %A,");
setlocale(LC_TIME, "fr_FR");
echo strftime(" en francés %A y");
setlocale(LC_TIME, "de_DE");
echo strftime(" en alemán %A.\n");
?>

Ejemplo #2 Ejemplo de número de semana del ISO 8601:1988

<?php
/*     Diciembre 2002 / Enero 2003
SemISO L   M   X   J   V   S   D
------ ----------------------------
51      16  17  18  19  20  21  22
52      23  24  25  26  27  28  29
1       30  31   1   2   3   4   5
2        6   7   8   9  10  11  12
3       13  14  15  16  17  18  19   */

// Muestra: 12/28/2002 - %V,%G,%Y = 52,2002,2002
echo "12/28/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/28/2002")) . "\n";

// Muestra: 12/30/2002 - %V,%G,%Y = 1,2003,2002
echo "12/30/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/30/2002")) . "\n";

// Muestra: 1/3/2003 - %V,%G,%Y = 1,2003,2003
echo "1/3/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2003")) . "\n";

// Muestra: 1/10/2003 - %V,%G,%Y = 2,2003,2003
echo "1/10/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/10/2003")) . "\n";

/*     Diciembre 2004 / Enero 2005
SemISO L   M   X   J   V   S   D
------ ----------------------------
51      13  14  15  16  17  18  19
52      20  21  22  23  24  25  26
53      27  28  29  30  31   1   2
1        3   4   5   6   7   8   9
2       10  11  12  13  14  15  16   */

// Muestra: 12/23/2004 - %V,%G,%Y = 52,2004,2004
echo "12/23/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/23/2004")) . "\n";

// Muestra: 12/31/2004 - %V,%G,%Y = 53,2004,2004
echo "12/31/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/31/2004")) . "\n";

// Muestra: 1/2/2005 - %V,%G,%Y = 53,2004,2005
echo "1/2/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/2/2005")) . "\n";

// Muestra: 1/3/2005 - %V,%G,%Y = 1,2005,2005
echo "1/3/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2005")) . "\n";

?>

Ejemplo #3 Ejemplo multiplataforma compatible del modificador %e

<?php

// Jan 1: resulta en: '%e%1%' (%%, e, %%, %e, %%)
$formato = '%%e%%%e%%';

// Comprobación para Windows para hallar y remplazar el
// modificador %e adecuadamente
if (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN') {
    $formato = preg_replace('#(?<!%)((?:%%)*)%e#', '\1%#d', $formato);
}

echo strftime($formato);
?>

Ejemplo #4 Mostrar todos los formatos conocidos y desconocidos.

<?php
// Describir los formatos.
$formatos_strftime = array(
    'A' => 'Una representación textual completa del día',
    'B' => 'Nombre del mes completo, basado en el localismo',
    'C' => 'Representación de dos dígitos del siglo (año dividido entre 100, truncado a un entero)',
    'D' => 'Lo mismo que "%m/%d/%y"',
    'E' => '',
    'F' => 'Lo mismo que "%Y-%m-%d"',
    'G' => 'La versión completa de cuatro dígitos de %g',
    'H' => 'Representación de dos dígitos de la hora en formato de 24 horas',
    'I' => 'Representación de dos dígitos de la hora en formato de 12 horas',
    'J' => '',
    'K' => '',
    'L' => '',
    'M' => 'Representación de dos dígitos de los minutos',
    'N' => '',
    'O' => '',
    'P' => '"am" o "pm" en minúsculas basados en la hora dada',
    'Q' => '',
    'R' => 'Lo mismo que "%H:%M"',
    'S' => 'Representación de dos dígitos de los segundos',
    'T' => 'Lo mismo que "%H:%M:%S"',
    'U' => 'Número de semana del año dado, comenzando con el primer domingo como la primera semana',
    'V' => 'Número de semana del año dado del ISO-8601:1988, comenzando con la primera semana del año con al menos 4 días de semana, con el lunes como principio de la semana',
    'W' => 'Una representación numérica de la semana del año, comenzando con el primer domingo como la primera semana',
    'X' => 'Representación preferida de la hora basda en el localismo, sin la fecha',
    'Y' => 'Representación de cuatro dígitos del año',
    'Z' => 'La opción de índice/abreviatura de la zona horaria NO dada por %z (depende del sistema operativo)',
    'a' => 'Una representación textual abreviada del día',
    'b' => 'Nombre del mes abreviado, basado en el localismo',
    'c' => 'Marca preferida de la fecha y hora basadas en el localismo',
    'd' => 'El día del mes con dos dígitos (con ceros iniciales)',
    'e' => 'El día del mes, con un espacio precediendo a los dígitos simples',
    'f' => '',
    'g' => 'Representación de dos dígitos del año por el estándar ISO-8601:1988 (véase %V)',
    'h' => 'Nombre del mes abreviado, basado en el localismo (un alias de %b)',
    'i' => '',
    'j' => 'Día del año, tres dígitos con ceros iniciales',
    'k' => 'La hora en formato de 24 horas, con un espacio precediendo a los dígitos simples',
    'l' => 'La hora en formato de 12 horas, con un espacio precediendo a los dígitos simples',
    'm' => 'Representación de dos dígitos del mes',
    'n' => 'Un carácter de nueva línea ("\n")',
    'o' => '',
    'p' => '"AM" o "PM" en MAYÚSCULAS basados en la hora dada',
    'q' => '',
    'r' => 'Lo mismo que "%I:%M:%S %p"',
    's' => 'Marca temporal del instante de la Época Unix',
    't' => 'Un carácter de tabulación ("\t")',
    'u' => 'Representación numérica del día de la semana del ISO-8601',
    'v' => '',
    'w' => 'Representación numérica del día de la semana',
    'x' => 'Representación preferida de la fecha basda en la configuración local, sin la hora',
    'y' => 'Representación de dos dígitos del año',
    'z' => 'El índice de la zona horaria UTC o la abreviatura (depende del sistema operativo)',
    '%' => 'Un carácter de porcentaje literal ("%")',
);

// Resultados.
$valores_strftime = array();

// Evaluar los formatos, mientras suprime cualquier error.
foreach($formatos_strftime as $formato => $descripción){
    if (False !== ($valor = @strftime("%{$formato}"))){
        $valores_strftime[$formato] = $valor;
    }
}

// Encontrar el valor más largo.
$longitudValorMáx = 2 + max(array_map('strlen', $valores_strftime));

// Notificar los formatos conocidos.
foreach($valores_strftime as $formato => $valor){
    echo "Formato conocido    : '{$formato}' = ", str_pad("'{$valor}'", $longitudValorMáx), " ( {$formatos_strftime[$formato]} )\n";
}

// Notificar los formatos desconocidos.
foreach(array_diff_key($formatos_strftime, $valores_strftime) as $formato => $descripción){
    echo "Formato desconocido : '{$formato}'   ", str_pad(' ', $longitudValorMáx), ($descripción ? " ( {$descripción} )" : ''), "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Formato conocido    : 'A' = 'Friday'            ( Una representación textual completa del día )
Formato conocido    : 'B' = 'December'          ( Nombre del mes completo, basado en el localismo )
Formato conocido    : 'H' = '11'                ( Representación de dos dígitos de la hora en formato de 24 horas )
Formato conocido    : 'I' = '11'                ( Representación de dos dígitos de la hora en formato de 12 horas )
Formato conocido    : 'M' = '24'                ( Representación de dos dígitos de los minutos )
Formato conocido    : 'S' = '44'                ( Representación de dos dígitos de los segundos )
Formato conocido    : 'U' = '48'                ( Número de semana del año dado, comenzando con el primer domingo como la primera semana )
Formato conocido    : 'W' = '48'                ( Una representación numérica de la semana del año, comenzando con el primer domingo como la primera semana )
Formato conocido    : 'X' = '11:24:44'          ( Representación preferida de la hora basda en el localismo, sin la fecha )
Formato conocido    : 'Y' = '2010'              ( Representación de cuatro dígitos del año )
Formato conocido    : 'Z' = 'GMT Standard Time' ( La opción de índice/abreviatura de la zona horaria NO dada por %z (depende del sistema operativo) )
Formato conocido    : 'a' = 'Fri'               ( Una representación textual abreviada del día )
Formato conocido    : 'b' = 'Dec'               ( Nombre del mes abreviado, basado en el localismo )
Formato conocido    : 'c' = '12/03/10 11:24:44' ( Marca preferida de la fecha y hora basadas en el localismo )
Formato conocido    : 'd' = '03'                ( El día del mes con dos dígitos (con ceros iniciales) )
Formato conocido    : 'j' = '337'               ( Día del año, tres dígitos con ceros iniciales )
Formato conocido    : 'm' = '12'                ( Representación de dos dígitos del mes )
Formato conocido    : 'p' = 'AM'                ( "AM" o "PM" en MAYÚSCULAS basados en la hora dada )
Formato conocido    : 'w' = '5'                 ( Representación numérica del día de la semana )
Formato conocido    : 'x' = '12/03/10'          ( Representación preferida de la fecha basda en la configuración local, sin la hora )
Formato conocido    : 'y' = '10'                ( Representación de dos dígitos del año )
Formato conocido    : 'z' = 'GMT Standard Time' ( El índice de la zona horaria UTC o la abreviatura (depende del sistema operativo) )
Formato conocido    : '%' = '%'                 ( Un carácter de porcentaje literal ("%") )
Formato desconocido : 'C'                       ( Representación de dos dígitos del siglo (año dividido entre 100, truncado a un entero) )
Formato desconocido : 'D'                       ( Lo mismo que "%m/%d/%y" )
Formato desconocido : 'E'
Formato desconocido : 'F'                       ( Lo mismo que "%Y-%m-%d" )
Formato desconocido : 'G'                       ( La versión completa de cuatro dígitos de %g )
Formato desconocido : 'J'
Formato desconocido : 'K'
Formato desconocido : 'L'
Formato desconocido : 'N'
Formato desconocido : 'O'
Formato desconocido : 'P'                       ( "am" o "pm" en minúsculas basados en la hora dada )
Formato desconocido : 'Q'
Formato desconocido : 'R'                       ( Lo mismo que "%H:%M" )
Formato desconocido : 'T'                       ( Lo mismo que "%H:%M:%S" )
Formato desconocido : 'V'                       ( Número de semana del año dado del ISO-8601:1988, comenzando con la primera semana del año con al menos 4 días de semana, con el lunes como principio de la semana )
Formato desconocido : 'e'                       ( El día del mes, con un espacio precediendo a los dígitos simples )
Formato desconocido : 'f'
Formato desconocido : 'g'                       ( Representación de dos dígitos del año por el estándar ISO-8601:1988 (véase %V) )
Formato desconocido : 'h'                       ( Nombre del mes abreviado, basado en el localismo (un alias de %b) )
Formato desconocido : 'i'
Formato desconocido : 'k'                       ( La hora en formato de 24 horas, con un espacio precediendo a los dígitos simples )
Formato desconocido : 'l'                       ( La hora en formato de 12 horas, con un espacio precediendo a los dígitos simples )
Formato desconocido : 'n'                       ( Un carácter de nueva línea ("\n") )
Formato desconocido : 'o'
Formato desconocido : 'q'
Formato desconocido : 'r'                       ( Lo mismo que "%I:%M:%S %p" )
Formato desconocido : 's'                       ( Marca temporal del instante de la Época Unix )
Formato desconocido : 't'                       ( Un carácter de tabulación ("\t") )
Formato desconocido : 'u'                       ( Representación numérica del día de la semana del ISO-8601 )
Formato desconocido : 'v'

Notas

Nota: %G y %V, los cuales están basados en el número de semana del ISO 8601:1988, pueden dar resultados inesperados (aunque correctos) si el sistema numérico no se entendió perfectamente. Véanse los ejemplos de %V en esta página del manual.

Ver también

  • » Herramienta de diseño del formato de strftime() en línea
  • setlocale() - Establecer la información del localismo
  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • strptime() - Analiza una fecha/hora generada con strftime
  • gmstrftime() - Formatear una fecha/hora GMT/UTC según la configuración local
  • » Especificación de strftime() del Open Group


Analiza una fecha/hora generada con strftime

  • « strftime
  • strtotime »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Analiza una fecha/hora generada con strftime

strptime

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

strptime — Analiza una fecha/hora generada con strftime()

Descripción

strptime ( string $date , string $format ) : array

strptime() devuelve una matriz con la fecha date analizada, o false si se produjo un error.

Los nombres del mes y del día de la semana y otras cadenas dependientes del lenguaje están subordinados a la configuración regional local establecida con setlocale() (LC_TIME).

Parámetros

date (string)

La cadena a analizar (p.ej. devuelta por strftime()).

format (string)

El formato usado en date (p.ej. el mismo que el usado en strftime()). Observe que algunas de las opciones de formato disponibles en strftime() pueden no tener ningún efecto en strptime(); el subconjunto exacto que está soportado variará según el sistema operativo y a la biblioteca de C que esté en uso.

Para más información sobre las opciones de formato, lea la página de strftime().

Valores devueltos

Devuelve una matriz o false en caso de error.

Los siguietens parámetros son devueltos en la matriz
parámetros | Descripción
"tm_sec" | Segundos después del minuto (0-61)
"tm_min" | Minutos después de la hora (0-59)
"tm_hour" | Hora desde la medianoche (0-23)
"tm_mday" | Día del mes (1-31)
"tm_mon" | Meses desde Enero (0-11)
"tm_year" | Años desde 1900
"tm_wday" | Días desde el Domingo (0-6)
"tm_yday" | Días desde el 1 de Enero (0-365)
"unparsed" | la parte de date que no fue reconocida usando el formato format especificado

Ejemplos

Ejemplo #1 Ejemplo de strptime()

<?php
$formato = '%d/%m/%Y %H:%M:%S';
$strf = strftime($formato);

echo "$strf\n";

print_r(strptime($strf, $formato));
?>

El resultado del ejemplo sería algo similar a:

03/10/2004 15:54:19

Array
(
    [tm_sec] => 19
    [tm_min] => 54
    [tm_hour] => 15
    [tm_mday] => 3
    [tm_mon] => 9
    [tm_year] => 104
    [tm_wday] => 0
    [tm_yday] => 276
    [unparsed] =>
)

Notas

Nota: Esta función no está implementada en plataformas Windows.

Nota:

Internamente, esta función llama a la función strptime() proporcionada por la biblioteca C del sistema. Esta función puede presentar diferencias notables de comportamiento en diferentes sistemas operativos. Se recomienda el uso de date_parse_from_format(), a la cuál no le afectan estas cosas, en PHP 5.3.0 y posterior.

Nota:

"tm_sec" incluye segundos intercalares (actualmente hasta 2 por año). Para más información acerca de los segundos intercalares, vea el » artículo de Wikipedia sobre segundos intercalares.

Nota:

Antes de PHP 5.2.0, esta función podía devolver un comportamiento indefinido. En particular, las entradas "tm_sec", "tm_min" y "tm_hour" devolverían valores indefinidos.

Ver también

  • checkdate() - Validar una fecha gregoriana
  • strftime() - Formatea una fecha/hora local según una configuración local
  • date_parse_from_format() - Obtiene información de una fecha dada formateada de acuerdo al formato especificado
  • DateTime::createFromFormat() - Analiza una cadena con un instante según un formato especificado


Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix

  • « strptime
  • time »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix

strtotime

(PHP 4, PHP 5, PHP 7, PHP 8)

strtotime — Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix

Descripción

strtotime ( string $time , int $now = time() ) : int

Esta función espera que se proporcione una cadena que contenga un formato de fecha en Inglés US e intentará convertir ese formato a una fecha Unix (el número de segundos desde el 1 de Enero del 1970 00:00:00 UTC), relativa a la marca de tiempo dada en now, o la marca de tiempo actual si now no se proporciona.

Cada parámetro de esta función utiliza la zona horaria predeterminada a menos que se especifique una en ese parámetro. Se ha de tener cuidado de no usar diferentes zonas horarias en cada parámetro a menos que sea esa la intención. Véase la función date_default_timezone_get() para las diferentes maneras de definir la zona horaria predeterminada.

Parámetros

time

Una cadena de fecha/hora. Los formatos válidos se explican en Formatos de fecha y hora.

now

La marca de tiempo que se usa como base para el cálculo de las fechas relativas.

Valores devueltos

Devuelve una marca de tiempo si se tuvo éxito, false si no. Antes de PHP 5.1.0, esta funcion devolvía -1 si fallaba.

Errores/Excepciones

Cada vez que se llame a una función de fecha/hora se generará un E_NOTICE si la zona horaria no es válida, y/o un mensaje E_STRICT o E_WARNING si se emplea la configuración del sistema o la variable global TZ. Véase también date_default_timezone_set()

Historial de cambios

Versión | Descripción
5.3.0 | Antes de PHP 5.3.0, formatos de tiempo relativo que se suministran al parámetro time de la función strtotime() como this week, previous week, last week, y next week se interpreta como un período de 7 días en relación con la fecha y hora actual, en lugar de un período de semana de Monday a Sunday.
5.3.0 | Antes de PHP 5.3.0, 24:00 no era un formato válido y strtotime() devolvía false.
5.2.7 | En PHP 5 anterior a 5.2.7, las peticiones de una incidencia de un día de la semana dado en un mes donde ese día de la semana era el primer día del mes, añadía incorrectamente una semana a la marca de tiempo devuelta. Esto ha sido corregido en 5.2.7 y versiones posteriores.
5.1.0 | Ahora devuelve false si falla, en vez de -1.
5.1.0 | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
5.0.2 | En PHP 5 hasta 5.0.2, "now" y otros momentos relativos son computados erróneamente como la medianoche de hoy. Esto difiere de otras versiones donde es computado como el momento actual.
5.0.0 | Los microsegundos comenzaron a estar permitidos, pero son ignorados.

Ejemplos

Ejemplo #1 Un ejemplo de strtotime()

<?php
echo strtotime("now"), "\n";
echo strtotime("10 September 2000"), "\n";
echo strtotime("+1 day"), "\n";
echo strtotime("+1 week"), "\n";
echo strtotime("+1 week 2 days 4 hours 2 seconds"), "\n";
echo strtotime("next Thursday"), "\n";
echo strtotime("last Monday"), "\n";
?>

Ejemplo #2 Comprobar si falla

<?php
$cadena = 'No Válida';

// antes de PHP 5.1.0 se debería de comparar con -1, en vez de con false
if (($timestamp = strtotime($cadena)) === false) {
    echo "La cadena ($cadena) es falsa";
} else {
    echo "$cadena == " . date('l dS \o\f F Y h:i:s A', $timestamp);
}
?>

Notas

Nota:

Si el número del año se especifica en un formato de dos dígitos, los valores entre 00-69 hacen referencia a 2000-2069 y 70-99 a 1970-1999. Vea las notas de abajo para las posibles diferencias en sistemas de 32 bit (las fechas posibles podrían terminar en 2038-01-19 03:14:07).

Nota:

El rango válido de una marca de tiempo es típicamente desde Fri, 13 Dec 1901 20:45:54 UTC a Tue, 19 Jan 2038 03:14:07 UTC. (Estas son las fechas que se corresponden con los valores máximo y mínimo de un entero con signo de 32 bit.)

Antes de PHP 5.1.0, no todas las plataformas admitían marcas de tiempo negativas, por lo que el rango de fechas puede estar limitado a no anteriores a la época Unix. Esto significa que, p.ej., las fechas anteriores al 1 de enero de 1970 no funcionarán en Windows, en algunas distribuciones de Linux, y en otros pocos sistemas operativos.

Para PHP versión 64-bit, el rángo válido de fechas es en la práctica infinito, ya que 64 bits pueden representar aproximadamente 293.000 millones de años en cualquier dirección.

Nota:

Las fechas en los formatos m/d/y o d-m-y no son ambiguas al observar el separador entre los distintos componentes: si el separador es una barra (/), se asume el formato norteamericano m/d/y; mientras que si el separador es un guion (-) o un punto (.), se asume el formato europeo d-m-y. Si, sin embargo, el año se proporciona en un formato de dos dígitos y el separador es un guion (-), la cadena de la fecha se analiza como y-m-d.

Para evitar esta ambigüedad potencial es mejor usar fechas ISO 8601 (YYYY-MM-DD) o DateTime::createFromFormat() cuando sea posible.

Nota:

No es aconsejable utililzar esta función para operaciones matemáticas. Es mejor usar los métodos DateTime::add() y DateTime::sub() de PHP 5.3 y posterior, o el método DateTime::modify() de PHP 5.2.

Ver también

  • Formatos de Fecha y Hora
  • DateTime::createFromFormat() - Analiza una cadena con un instante según un formato especificado
  • checkdate() - Validar una fecha gregoriana
  • strptime() - Analiza una fecha/hora generada con strftime


Devuelve la fecha Unix actual

  • « strtotime
  • timezone_abbreviations_list »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve la fecha Unix actual

time

(PHP 4, PHP 5, PHP 7, PHP 8)

time — Devuelve la fecha Unix actual

Descripción

time ( ) : int

Devuelve el momento actual medido como el número de segundos desde la Época Unix (1 de Enero de 1970 00:00:00 GMT).

Ejemplos

Ejemplo #1 Ejemplo de time()

<?php
$semanaSiguiente = time() + (7 * 24 * 60 * 60);
                   // 7 días; 24 horas; 60 minutos; 60 segundos
echo 'Ahora:            '. date('Y-m-d') ."\n";
echo 'Semana Siguiente: '. date('Y-m-d', $semanaSiguiente) ."\n";
// o usar strtotime():
echo 'Semana Siguiente: '. date('Y-m-d', strtotime('+1 week')) ."\n";
?>

El resultado del ejemplo sería algo similar a:

Ahora:            2005-03-30
Semana Siguiente: 2005-04-06
Semana Siguiente: 2005-04-06

Notas

Sugerencia

La marca de tiempo del inicio de la petición está disponible en $_SERVER['REQUEST_TIME'] desde PHP 5.1.

Ver también

  • date() - Dar formato a la fecha/hora local
  • microtime() - Devuelve la fecha Unix actual con microsegundos


Alias de DateTimeZone::listAbbreviations

  • « time
  • timezone_identifiers_list »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::listAbbreviations

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_abbreviations_list — Alias de DateTimeZone::listAbbreviations()

Descripción

Esta función es un alias de: DateTimeZone::listAbbreviations()


Alias de DateTimeZone::listIdentifiers

  • « timezone_abbreviations_list
  • timezone_location_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::listIdentifiers

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_identifiers_list — Alias de DateTimeZone::listIdentifiers()

Descripción

Esta función es un alias de: DateTimeZone::listIdentifiers()


Alias de DateTimeZone::getLocation

  • « timezone_identifiers_list
  • timezone_name_from_abbr »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::getLocation

timezone_location_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

timezone_location_get — Alias de DateTimeZone::getLocation()

Descripción

Esta función es un alias de: DateTimeZone::getLocation()


Devuelve el nombre de la zona horaria desde su abreviatura

  • « timezone_location_get
  • timezone_name_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Devuelve el nombre de la zona horaria desde su abreviatura

timezone_name_from_abbr

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

timezone_name_from_abbr — Devuelve el nombre de la zona horaria desde su abreviatura

Descripción

timezone_name_from_abbr ( string $abbr , int $gmtOffset = -1 , int $isdst = -1 ) : string

Parámetros

abbr

La abreviatura de la zona horaria.

gmtOffset

Índice de GMT en segundos. Por defecto es -1 lo que significa que la primera zona horaria buscada que se corresponda con abbr es devuelta. De otro modo se busca el índice exacto y, sólo si no se encuentra, se devuelve la priemra zona horaria con cualquier índice.

isdst

Indicador del horario de verano. Por defecto a -1, lo que significa que si la zona horaria tiene horario de verano no se toma encosideración en la búsqueda. Si está establecido a 1, entonces se asuma que el parámetro gmtOffset es un índice con el horario de verano en efecto; si es 0, entonces se asume que gmtOffset es un índice sin horario de verano en efecto. Si abbr no existe, la zona horaria se busca únicamente mediante gmtOffset y isdst.

Valores devueltos

Devuelve el nombre de la zona horaria si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de timezone_name_from_abbr()

<?php
echo timezone_name_from_abbr("CET") . "\n";
echo timezone_name_from_abbr("", 3600, 0) . "\n";
?>

El resultado del ejemplo sería algo similar a:

Europe/Berlin
Europe/Paris

Ver también

  • timezone_abbreviations_list() - Alias de DateTimeZone::listAbbreviations


Alias de DateTimeZone::getName

  • « timezone_name_from_abbr
  • timezone_offset_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::getName

timezone_name_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_name_get — Alias de DateTimeZone::getName()

Descripción

Esta función es un alias de: DateTimeZone::getName()


Alias de DateTimeZone::getOffset

  • « timezone_name_get
  • timezone_open »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::getOffset

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_offset_get — Alias de DateTimeZone::getOffset()

Descripción

Esta función es un alias de: DateTimeZone::getOffset()


Alias de DateTimeZone::__construct

  • « timezone_offset_get
  • timezone_transitions_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::__construct

timezone_open

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_open — Alias de DateTimeZone::__construct()

Descripción

Esta función es un alias de: DateTimeZone::__construct()


Alias de DateTimeZone::getTransitions

  • « timezone_open
  • timezone_version_get »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Alias de DateTimeZone::getTransitions

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_transitions_get — Alias de DateTimeZone::getTransitions()

Descripción

Esta función es un alias de: DateTimeZone::getTransitions()


Obtiene la versión de la base de datos timezonedb

  • « timezone_transitions_get
  • Formatos de fecha y hora admitidos »
  • PHP Manual
  • Funciones de Fecha/Hora
  • Obtiene la versión de la base de datos timezonedb

timezone_version_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

timezone_version_get — Obtiene la versión de la base de datos timezonedb

Descripción

timezone_version_get ( ) : string

Devuelve la versión actual de timezonedb.

Valores devueltos

Devuelve un string.

Ejemplos

Ejemplo #1 Obtener la versión de timezonedb

<?php
echo timezone_version_get();
?>

El resultado del ejemplo sería algo similar a:

2009.7

Ver también

  • Lista de la Zonas Horarias Soportadas


Formatos de fecha y hora admitidos

Tabla de contenidos

  • Formatos de Hora
  • Formatos de fecha
  • Formatos compuestos
  • Formatos relativos

Esta sección describe todos los formatos diferentes que entiende el analizador de strtotime(), de DateTime y de date_create(). Los formatos están agrupados por secciones. En la mayoría de los casos, se pueden emplear los formatos de secciones diferentes en la misma cadena de fecha/hora. Se proporcionan ejemplos para cada uno de los formatos admitidos, así como una descripción del formato. En los formatos, los caracteres entre comillas simples son insensibles a mayúsculas-minúsculas, ('t' podría ser t o T), y los caracteres entre comillas dobles son sensibles a mayúsculas-minúsculas ("T" es solamente T).


Formatos de Hora

Esta página describe los diferentes formatos de hora que entiende el analizador de strtotime(), DateTime y date_create().

Símbolos empleados
Descripción | Formatos | Ejemplos
fracción | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "07", "19"
meridiano | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
MM | [0-5][0-9] | "00", "12", "59"
II | [0-5][0-9] | "00", "12", "59"
espacio | [ \t] |
zona horaria (zh) | "("? [A-Za-z]{1,6} ")"? | [A-Z][a-z]+([_/][A-Z][a-z]+)+ | "CEST", "Europe/Amsterdam", "America/Indiana/Knox"
corrección de la zh | "GMT"? [+-] hh ":"? MM? | "+0400", "GMT-07:00", "-07:00"
Notación de 12 Horas
Descripción | Formato | Ejemplos
Solamente hora, con meridiano | hh espacio? meridiano | "4 am", "5PM"
Horas y minutos, con meridiano | hh [.:] MM espacio? meridiano | "4:08 am", "7:19P.M."
Horas, minutos y segundos, con meridiano | hh [.:] MM [.:] II espacio? meridiano | "4:08:37 am", "7:19:19P.M."
MS SQL (Horas, minutos, segundos y fracción con meridiano), únicamente PHP 5.3 y posterior | hh ":" MM ":" II [.:] [0-9]+ meridiano | "4:08:39:12313am"
Notación de 24 Horas
Descripción | Formato | Ejemplos
Horas y minutos | 't'? HH [.:] MM | "04:08", "19.19", "T23:43"
Horas y minutos, sin dos puntos | 't'? HH MM | "0408", "t1919", "T2343"
Horas, minutos y segundos | 't'? HH [.:] MM [.:] II | "04.08.37", "t19:19:19"
Horas, minutos y segundos, sin dos puntos | 't'? HH MM II | "040837", "T191919"
Horas, minutos, segundos y zona horaria | 't'? HH [.:] MM [.:] II espacio? ( corrección de la zh | zh ) | "040837CEST", "T191919-0700"
Horas, minutos, segundos y fracción | 't'? HH [.:] MM [.:] II fracción | "04.08.37.81412", "19:19:19.532453"
Información de la zona horaria | zh | corrección de la zh | "CEST", "Europe/Amsterdam", "+0430", "GMT-06:00"


Formatos de fecha

Esta página describe los diferentes formatos de fecha que entiende el analizador de strtotime(), DateTime y date_create().

Símbolos empleados
Descripción | Formato | Ejemplos
sufijos de día (en inglés) | "st" | "nd" | "rd" | "th" |
dd | ([0-2]?[0-9] | "3"[01]) sufijos de día? | "7th", "22nd", "31"
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "07", "31"
m | 'january' | 'february' | 'march' | 'april' | 'may' | 'june' | 'july' | 'august' | 'september' | 'october' | 'november' | 'december' | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' | "I" | "II" | "III" | "IV" | "V" | "VI" | "VII" | "VIII" | "IX" | "X" | "XI" | "XII" |
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
mm | "0"? [0-9] | "1"[0-2] | "0", "04", "7", "12"
MM | "0" [0-9] | "1"[0-2] | "00", "04", "07", "12"
y | [0-9]{1,4} | "00", "78", "08", "8", "2008"
yy | [0-9]{2} | "00", "08", "78"
YY | [0-9]{4} | "2000", "2008", "1978"
Notaciones regionales
Descripción | Formato | Ejemplos
Mes y día americanos | mm "/" dd | "5/12", "10/27"
Mes, día y año americanos | mm "/" dd "/" y | "12/22/78", "1/17/2006", "1/17/6"
Año de cuatro dígitos, mes y día con barras | YY "/" mm "/" dd | "2008/6/30", "1978/12/22"
Año de cuatro dígitos y mes (GNU) | YY "-" mm | "2008-6", "2008-06", "1978-12"
Año, mes y día con guiones | y "-" mm "-" dd | "2008-6-30", "78-12-22", "8-6-21"
Día, mes y año de cuatro dígitos, con puntos, tabulaciones o guiones | dd [.\t-] mm [.-] YY | "30-6-2008", "22.12.1978"
Día, mes y año de dos dígitos, con puntos o tabulaciones | dd [.\t] mm "." yy | "30.6.08", "22\t12.78"
Día, mes textual y año | dd ([ \t.-])* m ([ \t.-])* y | "30-June 2008", "22DEC78", "14 III 1879"
Mes textual y año de cuatro dígitos (el día se restablece a 1) | m ([ \t.-])* YY | "June 2008", "DEC1978", "March 1879"
Año de cuatro dígitos y mes textual (el día se restablece a 1) | YY ([ \t.-])* m | "2008 June", "1978-XII", "1879.MArCH"
Mes textual, día y año | m ([ .\t-])* dd [,.stndrh\t ]+ y | "July 1st, 2008", "April 17, 1790", "May.9,78"
Mes textual y día | m ([ .\t-])* dd [,.stndrh\t ]* | "July 1st,", "Apr 17", "May.9"
Día y mes textual | d ([ .\t-])* m | "1 July", "17 Apr", "9.May"
Abreviatura de mes, día y año | M "-" DD "-" y | "May-09-78", "Apr-17-1790"
Año, abreviatura de mes y día | y "-" M "-" DD | "78-Dec-22", "1814-MAY-17"
Año (y sólo el año) | YY | "1978", "2008"
Mes textual (y sólo el mes) | m | "March", "jun", "DEC"
Notaciones de la ISO 8601
Descripción | Formato | Ejemplos
Año, mes y día, de ocho dígitos | YY MM DD | "15810726", "19780417", "18140517"
Año de cuatro dígitos, mes y día con barras | YY "/" MM "/" DD | "2008/06/30", "1978/12/22"
Año de dos dígitos, mes y dís con guiones | yy "-" MM "-" DD | "08-06-30", "78-12-22"
Año de cuatro dígitos con signo opcional, mes y día | [+-]? YY "-" MM "-" DD | "-0002-07-26", "+1978-04-17", "1814-05-17"

Nota:

Para los formatos y e yy, los años por debajo de 100 son tratados de manera especial cuando se emplean los símbolos y o yy. Si el año cae en el rango de 0 (inclusive) a 69 (inclusive), se añade 2000. Si el año cae en el rango de 70 (inclusive) a 99 (inclusive) se añade 1900. Esto significa que "00-01-01" se interpreta como "2000-01-01".

Nota:

El formato "Día, mes y año de dos dígitos, con puntos o tabulaciones" (dd [.\t] mm "." yy) solamente funciona con valores de años de 61 (inclusive) a 99 (inclusive); fuera de esos años, el formato de hora "HH [.:] MM [.:] SS" tiene precedencia.

Nota:

El formato "Año (y sólo el año)" únicamente funciona si se ha encotrado una cadena de hora; de lo contrario, este formato es reconocido como HH MM.

Nota:

Es posible poner en exceso y en defecto los formatos dd y DD. Día 0 significa el último día del mes anterior, mientras que en exceso empieza a contar a partir del mes siguiente. Esto es, "2008-08-00" equivale a "2008-07-31", y "2008-06-31" equivale a "2008-07-01" (junio tiene sólo 30 días).

Obsérvese que a paritr de PHP 5.1.0 el rango del día está restringido a 0-31 tal como se indicó en la expresión regular anterior. Por tanto, "2008-06-32" por ejemplo, no es una cadena de fecha válida.

También es posible poner en defecto los formatos mm y MM con el valor 0. Un valor de mes de 0 significa diciemebre del año anterior. Por ejemplo, "2008-00-22" es equivalente a "2007-12-22".

Si se combinan los dos hechos anteriores y se ponen por defecto el día y el mes, sucede lo siguiente: "2008-00-00" primero se convierte a "2007-12-00" que después se convierte a "2007-11-30". Esto también sucede con la cadena "0000-00-00", que se transforma en "-0001-11-30" (el año -1 en el calendario ISO 8601, el cuál es 2 A.C. en el calendario gregoriano "proléptico").


Formatos compuestos

Esta página describe los diferentes formatos compuestos de fecha/hora que entiende el analizador de strtotime(), DateTime y date_create().

Símbolos empleados
Descripción | Formatos | Ejemplos
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "02", "12", "31"
día del año | "00"[1-9] | "0"[1-9][0-9] | [1-2][0-9][0-9] | "3"[0-5][0-9] | "36"[0-6] | "001", "012", "180", "350", "366"
fracción | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "7", "19"
meridiano | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
ii | [0-5][0-9] | "04", "8", "59"
II | [0-5][0-9] | "04", "08", "59"
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
MM | [0-5][0-9] | "00", "12"
espacio | [ \t] |
ss | [0-5][0-9] | "04", "8", "59"
SS | [0-5][0-9] | "04", "08", "59"
W | "0"[1-9] | [1-4][0-9] | "5"[0-3] | "05", "17", "53"
corrección de la zh | "GMT"? [+-] hh ":"? II? | "+0400", "GMT-07:00", "-07:00"
YY | [0-9]{4} | "2000", "2008", "1978"
Notaciones regionales
Descripción | Formato | Ejemplos
Formato de registro común | dd "/" M "/" YY : HH ":" II ":" SS espacio corrección de la zh | "10/Oct/2000:13:55:36 -0700"
EXIF | YY ":" MM ":" DD " " HH ":" II ":" SS | "2008:08:07 18:11:31"
Año ISO con semana ISO | YY "-"? "W" W | "2008W27", "2008-W28"
Año ISO con semana y día ISO | YY "-"? "W" W "-"? [0-7] | "2008W273", "2008-W28-3"
MySQL | YY "-" MM "-" DD " " HH ":" II ":" SS | "2008-08-07 18:11:31"
PostgreSQL: Año con día del año | YY "."? día del año | "2008.197", "2008197"
SOAP | YY "-" MM "-" DD "T" HH ":" II ":" SS fracción corrección de la zh? | "2008-07-01T22:35:17.02", "2008-07-01T22:35:17.03+08:00"
Marca temporal de Unix | "@" "-"? [0-9]+ | "@1215282385"
XMLRPC | YY MM DD "T" hh ":" II ":" SS | "20080701T22:38:07", "20080701T9:38:07"
XMLRPC (Compacto) | YY MM DD 't' hh II SS | "20080701t223807", "20080701T093807"
WDDX | YY "-" mm "-" dd "T" hh ":" ii ":" ss | "2008-7-1T9:3:37"

Nota:

La "W" en los formatos "Año ISO con semana ISO" y "Año ISO con semana y día ISO" es sensible a mayúsculas-minúsculas; sólo se puede usar la "W" mayúscula.

La "T" en los formatos SOAP, XMRPC y WDDX es sensible a mayúsculas-minúsculas; sólo se puede usar la "T" mayúscula.

El formato "Marca temporal de Unix" establece la zona horaria a UTC.


Formatos relativos

Esta página describe los diferentes formatos relativos de fecha/hora que entiende el analizador de strtotime(), DateTime y date_create().

Símbolos empleados
Descripción | Formato
nombre del día | 'sunday' | 'monday' | 'tuesday' | 'wednesday' | 'thursday' | 'friday' | 'saturday' | 'sun' | 'mon' | 'tue' | 'wed' | 'thu' | 'fri' | 'sat'
texto de día | 'weekday' | 'weekdays'
número | [+-]?[0-9]+
ordinal | 'first' | 'second' | 'third' | 'fourth' | 'fifth' | 'sixth' | 'seventh' | 'eighth' | 'ninth' | 'tenth' | 'eleventh' | 'twelfth' | 'next' | 'last' | 'previous' | 'this'
texto relativo | 'next' | 'last' | 'previous' | 'this'
espacio | [ \t]+
unidad | (('sec' | 'second' | 'min' | 'minute' | 'hour' | 'day' | 'fortnight' | 'forthnight' | 'month' | 'year') 's'?) | 'weeks' | texto de día
Notaciones basadas en el día
Formato | Descripción | Ejemplos
'yesterday' | Medianoche de ayer | "yesterday 14:00"
'midnight' | La hora es establecida a 00:00:00 |
'today' | La hora es establecida a 00:00:00 |
'now' | Ahora - esto es simplemente ignorado |
'noon' | La hora es establecida a 12:00:00 | "yesterday noon"
'tomorrow' | Medianoche de mañana |
'back of' hora | 15 minutos después de la hora especificada | "back of 7pm", "back of 15"
'front of' hora | 15 minutos antes de la hora especificada | "front of 5am", "front of 23"
'first day of' | Esteblece el día al primer día del mes en curso. Esta frase se utiliza mejor seguida de un nombre de mes. | "first day of January 2008"
'last day of' | Esteblece el día al último día del mes en curso. Esta frase se utiliza mejor seguida de un nombre de mes. | "last day of next month"
ordinal espacio nombre del día espacio 'of' | Calcula el x-ésimo día de la semana del mes en curso. | "first sat of July 2008"
'last' espacio nombre del día espacio 'of' | Calcula el último día de la semana del mes en curso. | "last sat of July 2008"
número espacio? (unidad | 'week') | Trata elementos de hora relativos donde el valor es un número. | "+5 weeks", "12 day", "-7 weekdays"
ordinal espacio unidad | Trata elementos de hora relativos donde el valor es texto. | "fifth day", "second month"
'ago' | Anula todos los valores de los elementos de hora relativos encontrados anteriormente. | "2 days ago", "8 days ago 14:00", "2 months 5 days ago", "2 months ago 5 days", "2 days ago"
nombre del día | Avanza al siguiente día con este nombre. | "Monday"
texto relativo espacio 'week' | Trata el formato especial "weekday + last/this/next week". | "Monday next week"

Nota:

Las declaraciones relativas son siempre procesadas después de las declaraciones no relativas. Esto es, "+1 week july 2008" y "july 2008 +1 week" son equivalentes.

Las excepciones a esta regla son: "yesterday", "midnight", "today", "noon" y "tomorrow". Téngase en cuenta que "tomorrow 11:00" y "11:00 tomorrow" son diferentes. Considerando la fecha de hoy como "July 23rd, 2008", el primero produce "2008-07-24 11:00", mientras que el segundo produce "2008-07-24 00:00". La razón de esto es que esas cinco declaraciones influyen directamente en el instante actual.

Nota:

Analice las siguiente observaciones cuando el día de la semana actual es el mismo que el día de la semana usado en la cadena de fecha/hora. Sin embargo, el día de la semana actual prodría haber sido (re)calculado mediante partes no relativas de la cadena de fecha/hora.

  1. "nombre del día" no avanza a otro día. (Ejemplo: "Wed July 23rd, 2008" significa "2008-07-23").
  2. "número nombre del día" no avanza a otro día. (Ejemplo: "1 wednesday july 23rd, 2008" significa "2008-07-23").
  3. "número week nombre del día" añadirá primero el número de semanas, pero no avanzará a otro día. En este caso "número week" y "nombre del día" son dos bloques distintos. (Ejemplo: "+1 week wednesday july 23rd, 2008" significa "2008-07-30").
  4. "ordinal nombre del día" sí avanza a otro día. (Ejemplo "first wednesday july 23rd, 2008" significa "2008-07-30").
  5. "número week ordinal nombre del día" primero añadíra el número de semanas, y después avanzará a otro día. En este caso "número week" y "ordinal nombre del día" son dos bloques distintos. (Ejemplo: "+1 week first wednesday july 23rd, 2008" significa "2008-08-06").
  6. "ordinal nombre del día 'of' " no avanza a otro día. (Ejemplo: "first wednesday of july 23rd, 2008" significa "2008-07-02" ya que la frase específica con 'of' restablece el día del mes a '1', por lo que el '23rd' aquí se ignora).

Observe también que el "of" en "ordinal espacio nombre del día espacio 'of' " y "'last' espacio nombre del día espacio 'of' " hace algo especial.

  1. Establece el día del mes a 1.
  2. "ordinal nombre del día 'of' " no avanza a otro día. (Ejemplo: "first tuesday of july 2008" significa "2008-07-01").
  3. "ordinal nombre del día " sí avanza otro día. (Ejemplo: "first tuesday july 2008" significa "2008-07-08", véase también el punto 4 en la lista de arriba).
  4. "'last' nombre del día 'of' " toma el último nombre del día del mes en curso. (Ejemplo: "last wed of july 2008" significa "2008-07-30")
  5. "'last' nombre del día" toma el último nombre del día desde el día actual. (Ejemplo: "last wed july 2008" significa "2008-06-25"; "july 2008" primero establece la fecha actual a "2008-07-01" y después "last wed" retrocede al miércoles anterior, que es "2008-06-25").

Nota:

Los valores relativos al mes se calculan basándose en la longitud de los meses por los que pasan. Un ejemplo sería "+2 month 2011-11-30", el cual produciría "2012-01-30". Esto es debido a que noviembre tiene 30 días de longitud, y diciembre tiene 31 días de longitud, produciendo un total de 61 días.

Historial de cambios

Versión | Descripción
5.6.23, 7.0.8 | Las semanas siempre empiezan en lunes. Antes, el domingo también se consideraba como inicio de semana.
5.3.3 | "first day" y "last day" se cambiaron para que se comporten como "+1 day" y "-1 day", respectivamente. Anteriormente, el comportamiento era "first day of" y "last day of".


Listado de zonas horarias admitidas

Tabla de contenidos

  • África
  • América
  • Antártida
  • Ártico
  • Asia
  • Atlántico
  • Australia
  • Europa
  • India
  • Pacífico
  • Otros

Aquí se puede encontrar una lista completa de las zonas horarias admitidas por PHP, las cuales están pensadas para utilizarlas con, p.ej., date_default_timezone_set().

Precaución

El comportamiento de las zonas horarias no enumeradas aquí es indefinido.

Nota: La última versión de la base de datos de zonas horarias se puede instalar mediante la base de datos » timezonedb de PECL.

Nota: Esta lista está basada en la versión de la base de datos de zonas horarias 2019.1.


África

África
Africa/Abidjan | Africa/Accra | Africa/Addis_Ababa | Africa/Algiers
Africa/Asmara | Africa/Bamako | Africa/Bangui | Africa/Banjul
Africa/Bissau | Africa/Blantyre | Africa/Brazzaville | Africa/Bujumbura
Africa/Cairo | Africa/Casablanca | Africa/Ceuta | Africa/Conakry
Africa/Dakar | Africa/Dar_es_Salaam | Africa/Djibouti | Africa/Douala
Africa/El_Aaiun | Africa/Freetown | Africa/Gaborone | Africa/Harare
Africa/Johannesburg | Africa/Juba | Africa/Kampala | Africa/Khartoum
Africa/Kigali | Africa/Kinshasa | Africa/Lagos | Africa/Libreville
Africa/Lome | Africa/Luanda | Africa/Lubumbashi | Africa/Lusaka
Africa/Malabo | Africa/Maputo | Africa/Maseru | Africa/Mbabane
Africa/Mogadishu | Africa/Monrovia | Africa/Nairobi | Africa/Ndjamena
Africa/Niamey | Africa/Nouakchott | Africa/Ouagadougou | Africa/Porto-Novo
Africa/Sao_Tome | Africa/Tripoli | Africa/Tunis | Africa/Windhoek


América

América
America/Adak | America/Anchorage | America/Anguilla | America/Antigua
America/Araguaina | America/Argentina/Buenos_Aires | America/Argentina/Catamarca | America/Argentina/Cordoba
America/Argentina/Jujuy | America/Argentina/La_Rioja | America/Argentina/Mendoza | America/Argentina/Rio_Gallegos
America/Argentina/Salta | America/Argentina/San_Juan | America/Argentina/San_Luis | America/Argentina/Tucuman
America/Argentina/Ushuaia | America/Aruba | America/Asuncion | America/Atikokan
America/Bahia | America/Bahia_Banderas | America/Barbados | America/Belem
America/Belize | America/Blanc-Sablon | America/Boa_Vista | America/Bogota
America/Boise | America/Cambridge_Bay | America/Campo_Grande | America/Cancun
America/Caracas | America/Cayenne | America/Cayman | America/Chicago
America/Chihuahua | America/Costa_Rica | America/Creston | America/Cuiaba
America/Curacao | America/Danmarkshavn | America/Dawson | America/Dawson_Creek
America/Denver | America/Detroit | America/Dominica | America/Edmonton
America/Eirunepe | America/El_Salvador | America/Fort_Nelson | America/Fortaleza
America/Glace_Bay | America/Godthab | America/Goose_Bay | America/Grand_Turk
America/Grenada | America/Guadeloupe | America/Guatemala | America/Guayaquil
America/Guyana | America/Halifax | America/Havana | America/Hermosillo
America/Indiana/Indianapolis | America/Indiana/Knox | America/Indiana/Marengo | America/Indiana/Petersburg
America/Indiana/Tell_City | America/Indiana/Vevay | America/Indiana/Vincennes | America/Indiana/Winamac
America/Inuvik | America/Iqaluit | America/Jamaica | America/Juneau
America/Kentucky/Louisville | America/Kentucky/Monticello | America/Kralendijk | America/La_Paz
America/Lima | America/Los_Angeles | America/Lower_Princes | America/Maceio
America/Managua | America/Manaus | America/Marigot | America/Martinique
America/Matamoros | America/Mazatlan | America/Menominee | America/Merida
America/Metlakatla | America/Mexico_City | America/Miquelon | America/Moncton
America/Monterrey | America/Montevideo | America/Montserrat | America/Nassau
America/New_York | America/Nipigon | America/Nome | America/Noronha
America/North_Dakota/Beulah | America/North_Dakota/Center | America/North_Dakota/New_Salem | America/Ojinaga
America/Panama | America/Pangnirtung | America/Paramaribo | America/Phoenix
America/Port-au-Prince | America/Port_of_Spain | America/Porto_Velho | America/Puerto_Rico
America/Punta_Arenas | America/Rainy_River | America/Rankin_Inlet | America/Recife
America/Regina | America/Resolute | America/Rio_Branco | America/Santarem
America/Santiago | America/Santo_Domingo | America/Sao_Paulo | America/Scoresbysund
America/Sitka | America/St_Barthelemy | America/St_Johns | America/St_Kitts
America/St_Lucia | America/St_Thomas | America/St_Vincent | America/Swift_Current
America/Tegucigalpa | America/Thule | America/Thunder_Bay | America/Tijuana
America/Toronto | America/Tortola | America/Vancouver | America/Whitehorse
America/Winnipeg | America/Yakutat | America/Yellowknife |


Antártida

Antártida
Antarctica/Casey | Antarctica/Davis | Antarctica/DumontDUrville | Antarctica/Macquarie
Antarctica/Mawson | Antarctica/McMurdo | Antarctica/Palmer | Antarctica/Rothera
Antarctica/Syowa | Antarctica/Troll | Antarctica/Vostok |


  • « Antártida
  • Asia »
  • PHP Manual
  • Listado de zonas horarias admitidas
  • Ártico

Ártico

Ártico
Arctic/Longyearbyen


Asia

Asia
Asia/Aden | Asia/Almaty | Asia/Amman | Asia/Anadyr
Asia/Aqtau | Asia/Aqtobe | Asia/Ashgabat | Asia/Atyrau
Asia/Baghdad | Asia/Bahrain | Asia/Baku | Asia/Bangkok
Asia/Barnaul | Asia/Beirut | Asia/Bishkek | Asia/Brunei
Asia/Chita | Asia/Choibalsan | Asia/Colombo | Asia/Damascus
Asia/Dhaka | Asia/Dili | Asia/Dubai | Asia/Dushanbe
Asia/Famagusta | Asia/Gaza | Asia/Hebron | Asia/Ho_Chi_Minh
Asia/Hong_Kong | Asia/Hovd | Asia/Irkutsk | Asia/Jakarta
Asia/Jayapura | Asia/Jerusalem | Asia/Kabul | Asia/Kamchatka
Asia/Karachi | Asia/Kathmandu | Asia/Khandyga | Asia/Kolkata
Asia/Krasnoyarsk | Asia/Kuala_Lumpur | Asia/Kuching | Asia/Kuwait
Asia/Macau | Asia/Magadan | Asia/Makassar | Asia/Manila
Asia/Muscat | Asia/Nicosia | Asia/Novokuznetsk | Asia/Novosibirsk
Asia/Omsk | Asia/Oral | Asia/Phnom_Penh | Asia/Pontianak
Asia/Pyongyang | Asia/Qatar | Asia/Qostanay | Asia/Qyzylorda
Asia/Riyadh | Asia/Sakhalin | Asia/Samarkand | Asia/Seoul
Asia/Shanghai | Asia/Singapore | Asia/Srednekolymsk | Asia/Taipei
Asia/Tashkent | Asia/Tbilisi | Asia/Tehran | Asia/Thimphu
Asia/Tokyo | Asia/Tomsk | Asia/Ulaanbaatar | Asia/Urumqi
Asia/Ust-Nera | Asia/Vientiane | Asia/Vladivostok | Asia/Yakutsk
Asia/Yangon | Asia/Yekaterinburg | Asia/Yerevan |


Atlántico

Atlántico
Atlantic/Azores | Atlantic/Bermuda | Atlantic/Canary | Atlantic/Cape_Verde
Atlantic/Faroe | Atlantic/Madeira | Atlantic/Reykjavik | Atlantic/South_Georgia
Atlantic/St_Helena | Atlantic/Stanley |  |


Australia

Australia
Australia/Adelaide | Australia/Brisbane | Australia/Broken_Hill | Australia/Currie
Australia/Darwin | Australia/Eucla | Australia/Hobart | Australia/Lindeman
Australia/Lord_Howe | Australia/Melbourne | Australia/Perth | Australia/Sydney


Europa

Europa
Europe/Amsterdam | Europe/Andorra | Europe/Astrakhan | Europe/Athens
Europe/Belgrade | Europe/Berlin | Europe/Bratislava | Europe/Brussels
Europe/Bucharest | Europe/Budapest | Europe/Busingen | Europe/Chisinau
Europe/Copenhagen | Europe/Dublin | Europe/Gibraltar | Europe/Guernsey
Europe/Helsinki | Europe/Isle_of_Man | Europe/Istanbul | Europe/Jersey
Europe/Kaliningrad | Europe/Kiev | Europe/Kirov | Europe/Lisbon
Europe/Ljubljana | Europe/London | Europe/Luxembourg | Europe/Madrid
Europe/Malta | Europe/Mariehamn | Europe/Minsk | Europe/Monaco
Europe/Moscow | Europe/Oslo | Europe/Paris | Europe/Podgorica
Europe/Prague | Europe/Riga | Europe/Rome | Europe/Samara
Europe/San_Marino | Europe/Sarajevo | Europe/Saratov | Europe/Simferopol
Europe/Skopje | Europe/Sofia | Europe/Stockholm | Europe/Tallinn
Europe/Tirane | Europe/Ulyanovsk | Europe/Uzhgorod | Europe/Vaduz
Europe/Vatican | Europe/Vienna | Europe/Vilnius | Europe/Volgograd
Europe/Warsaw | Europe/Zagreb | Europe/Zaporozhye | Europe/Zurich


India

India
Indian/Antananarivo | Indian/Chagos | Indian/Christmas | Indian/Cocos
Indian/Comoro | Indian/Kerguelen | Indian/Mahe | Indian/Maldives
Indian/Mauritius | Indian/Mayotte | Indian/Reunion |


Pacífico

Pacífico
Pacific/Apia | Pacific/Auckland | Pacific/Bougainville | Pacific/Chatham
Pacific/Chuuk | Pacific/Easter | Pacific/Efate | Pacific/Enderbury
Pacific/Fakaofo | Pacific/Fiji | Pacific/Funafuti | Pacific/Galapagos
Pacific/Gambier | Pacific/Guadalcanal | Pacific/Guam | Pacific/Honolulu
Pacific/Kiritimati | Pacific/Kosrae | Pacific/Kwajalein | Pacific/Majuro
Pacific/Marquesas | Pacific/Midway | Pacific/Nauru | Pacific/Niue
Pacific/Norfolk | Pacific/Noumea | Pacific/Pago_Pago | Pacific/Palau
Pacific/Pitcairn | Pacific/Pohnpei | Pacific/Port_Moresby | Pacific/Rarotonga
Pacific/Saipan | Pacific/Tahiti | Pacific/Tarawa | Pacific/Tongatapu
Pacific/Wake | Pacific/Wallis |  |


Otros

Advertencia

Por favor, no utilice ninguna de las zonas horarias enumeradas aquí (excepto UTC); sólo exiten por razones de retrocompatibilidad, por lo qur podrían exponen un funcionamiento erróneo.

Advertencia

Si se ignora la advertencia anterior, se debe observar también que la base de datos de zonas horarias IANA que proporciona el soporte de zonas horarias de PHP emplea signos del estilo POSIX, lo que resulta en que las zonas horarias Etc/GMT+n y Etc/GMT-n se reservan del uso común.

Por ejemplo, la zona horaria de 8 horas más que GMT que se emplea en China y en Australia occidental (entre otros lugares) es de hecho Etc/GMT-8 en la base de datos, no Etc/GMT+8 como se podría esperar.

Una vez más, se recomienda encarecidamente que se emplee la zona horaria correcta para la localización que se utilice, como Asia/Shanghai o Australia/Perth para los ejemplos anteriores.

Otros
Africa/Asmera | Africa/Timbuktu | America/Argentina/ComodRivadavia | America/Atka
America/Buenos_Aires | America/Catamarca | America/Coral_Harbour | America/Cordoba
America/Ensenada | America/Fort_Wayne | America/Indianapolis | America/Jujuy
America/Knox_IN | America/Louisville | America/Mendoza | America/Montreal
America/Porto_Acre | America/Rosario | America/Santa_Isabel | America/Shiprock
America/Virgin | Antarctica/South_Pole | Asia/Ashkhabad | Asia/Calcutta
Asia/Chongqing | Asia/Chungking | Asia/Dacca | Asia/Harbin
Asia/Istanbul | Asia/Kashgar | Asia/Katmandu | Asia/Macao
Asia/Rangoon | Asia/Saigon | Asia/Tel_Aviv | Asia/Thimbu
Asia/Ujung_Pandang | Asia/Ulan_Bator | Atlantic/Faeroe | Atlantic/Jan_Mayen
Australia/ACT | Australia/Canberra | Australia/LHI | Australia/North
Australia/NSW | Australia/Queensland | Australia/South | Australia/Tasmania
Australia/Victoria | Australia/West | Australia/Yancowinna | Brazil/Acre
Brazil/DeNoronha | Brazil/East | Brazil/West | Canada/Atlantic
Canada/Central | Canada/Eastern | Canada/Mountain | Canada/Newfoundland
Canada/Pacific | Canada/Saskatchewan | Canada/Yukon | CET
Chile/Continental | Chile/EasterIsland | CST6CDT | Cuba
EET | Egypt | Eire | EST
EST5EDT | Etc/GMT | Etc/GMT+0 | Etc/GMT+1
Etc/GMT+10 | Etc/GMT+11 | Etc/GMT+12 | Etc/GMT+2
Etc/GMT+3 | Etc/GMT+4 | Etc/GMT+5 | Etc/GMT+6
Etc/GMT+7 | Etc/GMT+8 | Etc/GMT+9 | Etc/GMT-0
Etc/GMT-1 | Etc/GMT-10 | Etc/GMT-11 | Etc/GMT-12
Etc/GMT-13 | Etc/GMT-14 | Etc/GMT-2 | Etc/GMT-3
Etc/GMT-4 | Etc/GMT-5 | Etc/GMT-6 | Etc/GMT-7
Etc/GMT-8 | Etc/GMT-9 | Etc/GMT0 | Etc/Greenwich
Etc/UCT | Etc/Universal | Etc/UTC | Etc/Zulu
Europe/Belfast | Europe/Nicosia | Europe/Tiraspol | Factory
GB | GB-Eire | GMT | GMT+0
GMT-0 | GMT0 | Greenwich | Hongkong
HST | Iceland | Iran | Israel
Jamaica | Japan | Kwajalein | Libya
MET | Mexico/BajaNorte | Mexico/BajaSur | Mexico/General
MST | MST7MDT | Navajo | NZ
NZ-CHAT | Pacific/Johnston | Pacific/Ponape | Pacific/Samoa
Pacific/Truk | Pacific/Yap | Poland | Portugal
PRC | PST8PDT | ROC | ROK
Singapore | Turkey | UCT | Universal
US/Alaska | US/Aleutian | US/Arizona | US/Central
US/East-Indiana | US/Eastern | US/Hawaii | US/Indiana-Starke
US/Michigan | US/Mountain | US/Pacific | US/Pacific-New
US/Samoa | UTC | W-SU | WET
Zulu |  |  |


HRTime - Medición del tiempo en alta resolución

  • Introducción
  • Instalación/Configuración
    • Instalación
  • Ejemplos
    • Uso básico
  • HRTime\PerformanceCounter — La clase HRTime\PerformanceCounter
    • HRTime\PerformanceCounter::getFrequency — La frecuencia del cronómetro en pulsos por segundo
    • HRTime\PerformanceCounter::getTicks — Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value
  • HRTime\StopWatch — La clase HRTime\StopWatch
    • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals
    • HRTime\StopWatch::getElapsedTime — Obtener el tiempo transcurrido para todos los intervalos
    • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval
    • HRTime\StopWatch::getLastElapsedTime — Obtener el tiempo transcurrido para el último intervalo
    • HRTime\StopWatch::isRunning — Whether the measurement is running
    • HRTime\StopWatch::start — Start time measurement
    • HRTime\StopWatch::stop — Stop time measurement
  • HRTime\Unit — La clase HRTime\Unit


Introducción

La extensión HRTime implementa una clase StopWatch de alta resolución. Utiliza las mejores API posibles de plataformas diferentes que tienen una resolución de hasta nanosegundos. También hace posible implementar un cronómetro personalizado empleando pulsos de bajo nivel emitidos por las API subyacentes.


  • « Introducción
  • Instalación »
  • PHP Manual
  • HRTime
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Instalación


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/hrtime.

Hay disponible una DLL para extensión PECL en » http://windows.php.net/downloads/pecl/releases/hrtime/.


  • « Instalación
  • Uso básico »
  • PHP Manual
  • HRTime
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

El ejemplo muestra el uso básico de la clase StopWatch

Ejemplo #1 Medir la ejecución de varios bloques de código y obtener el total

<?php

$c = new HRTime\StopWatch;

$c->start();
/* medir la ejecución de este bloque de código */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$transcurrido0 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

/* la medición no se ejecuta aquí */
for ($i = 0; $i < 1024*1024; $i++);

$c->start();
/* medir la ejecución de este bloque de código */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$transcurrido1 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

$total_transcurrido = $c->getElapsedTime(HRTime\Unit::NANOSECOND);

?>


La clase HRTime\PerformanceCounter

(PECL hrtime >= 0.4.3)

Introducción

Sinopsis de la Clase

HRTime\PerformanceCounter {
/* Métodos */
public getFrequency ( ) : int
public static getTicks ( ) : int
public static getTicksSince ( int $start ) : int
}

Tabla de contenidos

  • HRTime\PerformanceCounter::getFrequency — La frecuencia del cronómetro en pulsos por segundo
  • HRTime\PerformanceCounter::getTicks — Current ticks from the system
  • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value


La frecuencia del cronómetro en pulsos por segundo

  • « HRTime\PerformanceCounter
  • HRTime\PerformanceCounter::getTicks »
  • PHP Manual
  • HRTime\PerformanceCounter
  • La frecuencia del cronómetro en pulsos por segundo

HRTime\PerformanceCounter::getFrequency

(PECL hrtime >= 0.4.3)

HRTime\PerformanceCounter::getFrequency — La frecuencia del cronómetro en pulsos por segundo

Descripción

public HRTime\PerformanceCounter::getFrequency ( ) : int

Devuelve la frecuencia del cronómetro en pulsos por segundo. Este valor es constante después de que el sistema se inice en la mayoría de los sistemas operativos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo int indicando la frecuencia del cronómetro.


Current ticks from the system

  • « HRTime\PerformanceCounter::getFrequency
  • HRTime\PerformanceCounter::getTicksSince »
  • PHP Manual
  • HRTime\PerformanceCounter
  • Current ticks from the system

HRTime\PerformanceCounter::getTicks

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicks — Current ticks from the system

Descripción

public static HRTime\PerformanceCounter::getTicks ( ) : int

Returns the ticks count.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns int indicating the ticks count.


Ticks elapsed since the given value

  • « HRTime\PerformanceCounter::getTicks
  • HRTime\StopWatch »
  • PHP Manual
  • HRTime\PerformanceCounter
  • Ticks elapsed since the given value

HRTime\PerformanceCounter::getTicksSince

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value

Descripción

public static HRTime\PerformanceCounter::getTicksSince ( int $start ) : int

Returns the ticks count elapsed since the given start value.

Parámetros

start

Starting ticks value.

Valores devueltos

Returns int indicating the ticks count.


La clase HRTime\StopWatch

(PECL hrtime >= 0.4.3)

Introducción

Sinopsis de la Clase

HRTime\StopWatch extends HRTime\PerformanceCounter {
/* Métodos */
public getElapsedTicks ( ) : int
public getElapsedTime ( integer $unit = ? ) : float
public getLastElapsedTicks ( ) : int
public getLastElapsedTime ( integer $unit = ? ) : float
public isRunning ( ) : bool
public start ( ) : void
public stop ( ) : void
/* Métodos heredados */
public HRTime\PerformanceCounter::getFrequency ( ) : int
public static HRTime\PerformanceCounter::getTicks ( ) : int
public static HRTime\PerformanceCounter::getTicksSince ( int $start ) : int
}

Tabla de contenidos

  • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals
  • HRTime\StopWatch::getElapsedTime — Obtener el tiempo transcurrido para todos los intervalos
  • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval
  • HRTime\StopWatch::getLastElapsedTime — Obtener el tiempo transcurrido para el último intervalo
  • HRTime\StopWatch::isRunning — Whether the measurement is running
  • HRTime\StopWatch::start — Start time measurement
  • HRTime\StopWatch::stop — Stop time measurement


Get elapsed ticks for all intervals

  • « HRTime\StopWatch
  • HRTime\StopWatch::getElapsedTime »
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed ticks for all intervals

HRTime\StopWatch::getElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals

Descripción

public HRTime\StopWatch::getElapsedTicks ( ) : int

Get elapsed ticks for all the previously closed intervals.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns int indicating elapsed ticks.


Obtener el tiempo transcurrido para todos los intervalos

  • « HRTime\StopWatch::getElapsedTicks
  • HRTime\StopWatch::getLastElapsedTicks »
  • PHP Manual
  • HRTime\StopWatch
  • Obtener el tiempo transcurrido para todos los intervalos

HRTime\StopWatch::getElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTime — Obtener el tiempo transcurrido para todos los intervalos

Descripción

public HRTime\StopWatch::getElapsedTime ( integer $unit = ? ) : float

Obtener el tiempo transcurrido para todos los intervalos anteriormente cerrados.

Parámetros

unit

La unidad de tiempo representada por una constante HRTime\Unit. La predeterminada es HRTime\Unit::SECOND.

Valores devueltos

Devuelve un valor de tipo float indicando el tiempo transcurrido.


Get elapsed ticks for the last interval

  • « HRTime\StopWatch::getElapsedTime
  • HRTime\StopWatch::getLastElapsedTime »
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed ticks for the last interval

HRTime\StopWatch::getLastElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval

Descripción

public HRTime\StopWatch::getLastElapsedTicks ( ) : int

Get elapsed ticks for the previously closed interval.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns int indicating elapsed ticks.


Obtener el tiempo transcurrido para el último intervalo

  • « HRTime\StopWatch::getLastElapsedTicks
  • HRTime\StopWatch::isRunning »
  • PHP Manual
  • HRTime\StopWatch
  • Obtener el tiempo transcurrido para el último intervalo

HRTime\StopWatch::getLastElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTime — Obtener el tiempo transcurrido para el último intervalo

Descripción

public HRTime\StopWatch::getLastElapsedTime ( integer $unit = ? ) : float

Obtener el tiempo transcurrido para el intervalo anteriormente cerrado.

Parámetros

unit

La unidad de tiempo representada por una constante HRTime\Unit. La predeterminada es HRTime\Unit::SECOND.

Valores devueltos

Devuelve un valor de tipo float indicando el tiempo transcurrido.


Whether the measurement is running

  • « HRTime\StopWatch::getLastElapsedTime
  • HRTime\StopWatch::start »
  • PHP Manual
  • HRTime\StopWatch
  • Whether the measurement is running

HRTime\StopWatch::isRunning

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::isRunning — Whether the measurement is running

Descripción

public HRTime\StopWatch::isRunning ( ) : bool

Reveals whether the measurement was started.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns bool indicating whetehr the measurement is running.


Start time measurement

  • « HRTime\StopWatch::isRunning
  • HRTime\StopWatch::stop »
  • PHP Manual
  • HRTime\StopWatch
  • Start time measurement

HRTime\StopWatch::start

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::start — Start time measurement

Descripción

public HRTime\StopWatch::start ( ) : void

Starts the time measurement. It has no effect if the measurement was already started. The measurement will be continued if it was previously stopped.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns void.


Stop time measurement

  • « HRTime\StopWatch::start
  • HRTime\Unit »
  • PHP Manual
  • HRTime\StopWatch
  • Stop time measurement

HRTime\StopWatch::stop

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::stop — Stop time measurement

Descripción

public HRTime\StopWatch::stop ( ) : void

Stop the time measurement for the previously started interval.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns void.


La clase HRTime\Unit

(PECL hrtime >= 0.4.3)

Introducción

Sinopsis de la Clase

HRTime\Unit {
/* Constantes */
const integer SECOND = 0 ;
const integer MILLISECOND = 1 ;
const integer MICROSECOND = 2 ;
const integer NANOSECOND = 3 ;
/* Métodos */
}

Constantes predefinidas

HRTime\Unit::SECOND

HRTime\Unit::MILLISECOND

HRTime\Unit::MICROSECOND

HRTime\Unit::NANOSECOND


Extensiones relacionadas con el sistema de ficheros

  • Direct IO
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Direct IO
  • Directorios
    • Instalación/Configuración
    • Constantes predefinidas
    • Directorio — La clase Directorio
    • Funciones de directorio
  • Fileinfo — Información de un fichero
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Fileinfo
    • finfo — La clase finfo
  • Sistema de Ficheros
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones del Sistema de Archivos
  • Inotify
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones Inotify
  • Proctitle
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Proctitle Funciones
  • xattr
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de xattr
  • xdiff
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de xdiff


Direct IO

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Direct IO
    • dio_close — Cierra el descriptor de fichero fd
    • dio_fcntl — Lleva a cabo la función fcntl de la biblioteca C en el fichero fd
    • dio_open — Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C
    • dio_read — Leer bytes de un descriptor de fichero
    • dio_seek — Salta a una posición del descriptor de fichero desde donde proceda
    • dio_stat — Consulta información de estado del descriptor de fichero fd
    • dio_tcsetattr — Establece los atributos terminales y la tasa de baudios del puerto serie
    • dio_truncate — Trunca un descriptor de fichero fd a un determinado número de bytes
    • dio_write — Escribe datos en el descriptor de fichero con un truncado opcional


Introducción

PHP incorpora soporte para funciones de entrada/salida directa tal como se describe en el estándar Posix (Sección 6) para realizar funciones de E/S a un nivel más bajo bajo que los flujos de E/S de las funciones en C (fopen(), fread(),..). Sólo debe considerarse usar las funciones DIO cuando sea necesario tener control directo sobre un dispositivo. En cualquier otro caso, las funciónes estándar del sistema de ficheros son más que suficiente.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.1.0.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/dio.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un tipo de recurso: un descriptor de fichero devuelto por dio_open().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

F_DUPFD (integer)

F_GETFD (integer)

F_GETFL (integer)

F_GETLK (integer)

F_GETOWN (integer)

F_RDLCK (integer)

F_SETFL (integer)

F_SETLK (integer)

F_SETLKW (integer)

F_SETOWN (integer)

F_UNLCK (integer)

F_WRLCK (integer)

O_APPEND (integer)

O_ASYNC (integer)

O_CREAT (integer)

O_EXCL (integer)

O_NDELAY (integer)

O_NOCTTY (integer)

O_NONBLOCK (integer)

O_RDONLY (integer)

O_RDWR (integer)

O_SYNC (integer)

O_TRUNC (integer)

O_WRONLY (integer)

S_IRGRP (integer)

S_IROTH (integer)

S_IRUSR (integer)

S_IRWXG (integer)

S_IRWXO (integer)

S_IRWXU (integer)

S_IWGRP (integer)

S_IWOTH (integer)

S_IWUSR (integer)

S_IXGRP (integer)

S_IXOTH (integer)

S_IXUSR (integer)


Funciones de Direct IO

Tabla de contenidos

  • dio_close — Cierra el descriptor de fichero fd
  • dio_fcntl — Lleva a cabo la función fcntl de la biblioteca C en el fichero fd
  • dio_open — Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C
  • dio_read — Leer bytes de un descriptor de fichero
  • dio_seek — Salta a una posición del descriptor de fichero desde donde proceda
  • dio_stat — Consulta información de estado del descriptor de fichero fd
  • dio_tcsetattr — Establece los atributos terminales y la tasa de baudios del puerto serie
  • dio_truncate — Trunca un descriptor de fichero fd a un determinado número de bytes
  • dio_write — Escribe datos en el descriptor de fichero con un truncado opcional


Cierra el descriptor de fichero fd

  • « Funciones de Direct IO
  • dio_fcntl »
  • PHP Manual
  • Funciones de Direct IO
  • Cierra el descriptor de fichero fd

dio_close

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_close — Cierra el descriptor de fichero fd

Descripción

dio_close ( resource $fd ) : void

La función dio_close() cierra el descriptor de fichero fd.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Cerrando un descriptor de fichero

<?php
$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_close($fd);
?>

Ver también

  • dio_open() - Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C


Lleva a cabo la función fcntl de la biblioteca C en el fichero fd

  • « dio_close
  • dio_open »
  • PHP Manual
  • Funciones de Direct IO
  • Lleva a cabo la función fcntl de la biblioteca C en el fichero fd

dio_fcntl

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_fcntl — Lleva a cabo la función fcntl de la biblioteca C en el fichero fd

Descripción

dio_fcntl ( resource $fd , int $cmd , mixed $args = ? ) : mixed

La función dio_fcntl() realiza la operación especificada por cmd sobre el descriptor de fichero fd. Algunos comandos requieren que se proporcionen parámetros adicionales en args.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

cmd

Puede ser una de las siguientes operaciones:

  • F_SETLK - Se asigna o quita el bloqueo. Si está bloqueado por otro proceso, dio_fcntl() devuelve -1.

  • F_SETLKW - como F_SETLK, pero en caso de que esté bloqueado por otro proceso, dio_fcntl() espera a que éste se libere.

  • F_GETLK - dio_fcntl() devuelve un array asociativo (como se describe a continuación) si algún proceso previene el bloqueo. Si no hubiera impedimento, se asignará la clave "type" a F_UNLCK.

  • F_DUPFD - encuentra el número de descriptor más bajo disponible que sea igual o superior a args y lo devuelve.

  • F_SETFL - Establece al descriptor de fichero las banderas especificadas en args, de entre O_APPEND, O_NONBLOCK o O_ASYNC. Para usar O_ASYNC debe usarse la extensión PCNTL.

args

args es un array asociativo, cuando cmd sea F_SETLK o F_SETLLW, con las siguientes claves:

  • start - posición donde comienza el bloqueo

  • length - tamaño del area bloqueada. Cero significa hasta el final del fichero

  • whence - Desde dónde se contabiliza l_start: puede ser SEEK_SET, SEEK_END y SEEK_CUR

  • type - tipo de bloqueo: puede ser F_RDLCK (bloqueo de lectura), F_WRLCK (bloqueo de escritura) o F_UNLCK (desbloqueo)

Valores devueltos

Devuelve el resultado de la llamada a C.

Ejemplos

Ejemplo #1 Bloqueando y desbloqueando

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

if (dio_fcntl($fd, F_SETLK, Array("type"=>F_WRLCK)) == -1) {
   // parece el descriptor de fichero está bloqueado
   echo "No se puede desbloquear. Pertenece a algún otro proceso.";
} else {
   echo "Bloqueo/desbloqueo con éxito";
}

dio_close($fd);
?>

Notas

Nota: Esta función no está implementada en plataformas Windows.


Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C

  • « dio_fcntl
  • dio_read »
  • PHP Manual
  • Funciones de Direct IO
  • Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C

dio_open

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_open — Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C

Descripción

dio_open ( string $filename , int $flags , int $mode = 0 ) : resource

dio_open() abre un fichero y devuelve su descriptor de fichero.

Parámetros

filename

Ruta del fichero a abrir.

flags

El parámetro flags es una máscara OR de bits compuesta a partir de las siguientes banderas. Estos valores tienen que incluir alguno de entre O_RDONLY, O_WRONLY, o O_RDWR. Además, podría incluir cualquier combinación del resto de banderas de la lista.

  • O_RDONLY - abre el fichero con acceso de lectura.

  • O_WRONLY - abre el fichero con acceso de escritura.

  • O_RDWR - abre el fichero con acceso de lectura y de escritura.

  • O_CREAT - crea el fichero, si no existiera ya.

  • O_EXCL - si tanto O_CREAT como O_EXCL están habilitados, y el fichero existe, dio_open() fallará.

  • O_TRUNC - si el fichero existe, y está abierto con sólo escritura, se truncará a cero.

  • O_APPEND - las operaciones de escritura añaden los datos al final del fichero.

  • O_NONBLOCK - asigna el modo no bloqueante.

  • O_NOCTTY - previene que el SO asigne al fichero abierto como el terminal controlador del proceso cuando se abra un fichero de dispositivo TTY.

mode

Si flags contiene O_CREAT, mode establecerá los permisos del ficher (permisos de creación). mode es necesario para un correcto funcionamiento cuando O_CREAT se especifica en flags, y se ignorará en cualquier otro caso.

Los permisos que realmente se asignan al fichero creado se verán afectados por el umask del proceso, como suele suceder.

Valores devueltos

Descriptor de fichero o false en caso de error.

Ejemplos

Ejemplo #1 Abrir un descriptor de fichero

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_close($fd);
?>

Ver también

  • dio_close() - Cierra el descriptor de fichero fd


Leer bytes de un descriptor de fichero

  • « dio_open
  • dio_seek »
  • PHP Manual
  • Funciones de Direct IO
  • Leer bytes de un descriptor de fichero

dio_read

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_read — Leer bytes de un descriptor de fichero

Descripción

dio_read ( resource $fd , int $len = 1024 ) : string

La función dio_read() lee y devuelve len bytes de fichero con descriptor fd.

Parámetros

fd

El fichero descriptor devuelto pordio_open().

len

El número de bytes a leer. Si no se especifica la lectura es de bloques de 1K dio_read()

Valores devueltos

La bytes leídos desde fd.

Ver también

  • dio_write() - Escribe datos en el descriptor de fichero con un truncado opcional


Salta a una posición del descriptor de fichero desde donde proceda

  • « dio_read
  • dio_stat »
  • PHP Manual
  • Funciones de Direct IO
  • Salta a una posición del descriptor de fichero desde donde proceda

dio_seek

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_seek — Salta a una posición del descriptor de fichero desde donde proceda

Descripción

dio_seek ( resource $fd , int $pos , int $whence = SEEK_SET ) : int

dio_seek() se usa para cambiar la posición del fichero del descriptor de fichero proporcionado.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

pos

Nueva posición.

whence

Indica cómo interpretar la posición pos:

  • SEEK_SET (por omisión) - indica que pos se contabiliza a partir del comienzo del fichero.

  • SEEK_CUR - indica que pos se contabiliza a partir de la posición actual del fichero. Este valor puede ser positivo o negativo.

  • SEEK_END - Indica que pos contabiliza caracteres a partir del final del fichero. Un valor negativo especifica una posición perteneciente al contenido del fichero; un valor positivo especifica una posición que supera el final. Si éste fuera el caso, y se escribieran datos, se rellenaría el fichero con ceros hasta alcanzar la posición que proceda.

Valores devueltos

Ejemplos

Ejemplo #1 Posicionamiento de un fichero

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_seek($fd, 10, SEEK_SET);
// la posición está a 10 caracteres del comienzo

dio_seek($fd, -2, SEEK_CUR);
// la posición está a 8 caracteres del comienzo

dio_seek($fd, -5, SEEK_END);
// la posición está a 5 caracteres del final

dio_seek($fd, 10, SEEK_END);
// la posición supera ahora 10 caracteres del final del fichero.
// Los 10 caracteres intermedios entre el final y la posición actual
// se rellenan con ceros.

dio_close($fd);
?>


Consulta información de estado del descriptor de fichero fd

  • « dio_seek
  • dio_tcsetattr »
  • PHP Manual
  • Funciones de Direct IO
  • Consulta información de estado del descriptor de fichero fd

dio_stat

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_stat — Consulta información de estado del descriptor de fichero fd

Descripción

dio_stat ( resource $fd ) : array

dio_stat() devuelve información sobre el descriptor de fichero proporcionado.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

Valores devueltos

Devuelve un array asociativo con las siguientes claves:

  • "device" - dispositivo

  • "inode" - nodo-i

  • "mode" - modo

  • "nlink" - número de enlaces duros

  • "uid" - id de usuario

  • "gid" - id de grupo

  • "device_type" - tipo de dispositivo (si es un nodo-i de dispositivo)

  • "size" - tamaño total en bytes

  • "blocksize" - tamaño de bloque

  • "blocks" - número de bloques asignados

  • "atime" - fecha de último acceso

  • "mtime" - fecha de última modificación

  • "ctime" - fecha de último cambio

En caso de error, dio_stat() devuelve null.


Establece los atributos terminales y la tasa de baudios del puerto serie

  • « dio_stat
  • dio_truncate »
  • PHP Manual
  • Funciones de Direct IO
  • Establece los atributos terminales y la tasa de baudios del puerto serie

dio_tcsetattr

(PHP 4 >= 4.3.0, PHP 5 < 5.1.0)

dio_tcsetattr — Establece los atributos terminales y la tasa de baudios del puerto serie

Descripción

dio_tcsetattr ( resource $fd , array $options ) : bool

dio_tcsetattr() establece los atributos terminales y la tasa de baudios del fichero fd.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

options

Las siguientes opciones están disponibles:

  • 'baud' - tasa de baudios del puerto - puede ser 38400,19200,9600,4800,2400,1800, 1200,600,300,200,150,134,110,75 o 50, el valor por omisión es 9600.

  • 'bits' - bits de datos - puede ser 8,7,6 o 5. El valor por omisión es 8.

  • 'stop' - bits de parada - puede ser 1 o 2. El valor por omisión es 1.

  • 'parity' - paridad - puede ser 0,1 o 2. El valor por omisión es 0.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Asignando la tasa de baudios del puerto serie

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_fcntl($fd, F_SETFL, O_SYNC);

dio_tcsetattr($fd, array(
  'baud' => 9600,
  'bits' => 8,
  'stop'  => 1,
  'parity' => 0
));

while (1) {

  $data = dio_read($fd, 256);

  if ($data) {
      echo $data;
  }
}

?>

Notas

Nota: Esta función no está implementada en plataformas Windows.


Trunca un descriptor de fichero fd a un determinado número de bytes

  • « dio_tcsetattr
  • dio_write »
  • PHP Manual
  • Funciones de Direct IO
  • Trunca un descriptor de fichero fd a un determinado número de bytes

dio_truncate

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_truncate — Trunca un descriptor de fichero fd a un determinado número de bytes

Descripción

dio_truncate ( resource $fd , int $offset ) : bool

dio_truncate() trunca un fichero a, como mucho, un tamaño de offset bytes.

Si el fichero excediera este tamaño, el contenido extra se perdería. Si fuera inferior en tamaño, no se especifica si el fichero se mantiene sin cambios o si se completa. En este último caso, la parte completada se haría con ceros.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

offset

Tamaño en bytes.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Esta función no está implementada en plataformas Windows.


Escribe datos en el descriptor de fichero con un truncado opcional

  • « dio_truncate
  • Directorios »
  • PHP Manual
  • Funciones de Direct IO
  • Escribe datos en el descriptor de fichero con un truncado opcional

dio_write

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_write — Escribe datos en el descriptor de fichero con un truncado opcional

Descripción

dio_write ( resource $fd , string $data , int $len = 0 ) : int

dio_write() escriba hasta len bytes de data al fichero fd.

Parámetros

fd

Descriptor de fichero devuelto por dio_open().

data

Datos a escribir.

len

Longitud en bytes de los datos a escribir. Si no se especifica, la función escribe todos los datos al fichero especificado.

Valores devueltos

Devuelve el número de bytes escritos en fd.

Ver también

  • dio_read() - Leer bytes de un descriptor de fichero


Directorios

  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Directorio — La clase Directorio
    • Directory::close — Cierra un gestor de directorio
    • Directory::read — Lee una entrada desde el controlador de directorio
    • Directory::rewind — Rebobina el manejador de directorio
  • Funciones de directorio
    • chdir — Cambia de directorio
    • chroot — Cambia el directorio raíz
    • closedir — Cierra un gestor de directorio
    • dir — Devuelve una instancia de la clase Directory
    • getcwd — Obtiene el directorio actual en donde se esta trabajando
    • opendir — Abre un gestor de directorio
    • readdir — Lee una entrada desde un gestor de directorio
    • rewinddir — Regresar el gestor de directorio
    • scandir — Enumera los ficheros y directorios ubicados en la ruta especificada


Constantes predefinidas

DIRECTORY_SEPARATOR (string)
PATH_SEPARATOR (string)
Punto y coma en Windows, en caso contrario dos puntos.
SCANDIR_SORT_ASCENDING (integer)
Disponible desde PHP 5.4.0.
SCANDIR_SORT_DESCENDING (integer)
Disponible desde PHP 5.4.0.
SCANDIR_SORT_NONE (integer)
Disponible desde PHP 5.4.0.


La clase Directorio

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Las instancias de Directory se crean mediante una llamada a la funcion dir() , no por el operador new.

Sinopsis de la Clase

Directory {
/* Propiedades */
public string $path ;
public resource $handle ;
/* Métodos */
public close ( resource $dir_handle = ? ) : void
public read ( resource $dir_handle = ? ) : string
public rewind ( resource $dir_handle = ? ) : void
}

Propiedades

path

El directorio que se abrió.

handle

Se puede usar junto con otras funciones de directorio, como readdir(), rewinddir() y closedir().

Tabla de contenidos

  • Directory::close — Cierra un gestor de directorio
  • Directory::read — Lee una entrada desde el controlador de directorio
  • Directory::rewind — Rebobina el manejador de directorio


Cierra un gestor de directorio

  • « Directorio
  • Directory::read »
  • PHP Manual
  • Directorio
  • Cierra un gestor de directorio

Directory::close

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::close — Cierra un gestor de directorio

Descripción

public Directory::close ( resource $dir_handle = ? ) : void

Al igual que closedir(), solo que el valor predeterminado de dir_handle es $this->handle.


Lee una entrada desde el controlador de directorio

  • « Directory::close
  • Directory::rewind »
  • PHP Manual
  • Directorio
  • Lee una entrada desde el controlador de directorio

Directory::read

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::read — Lee una entrada desde el controlador de directorio

Descripción

public Directory::read ( resource $dir_handle = ? ) : string

Igual a readdir(), dir_handle por defecto $this->handle.


Rebobina el manejador de directorio

  • « Directory::read
  • Funciones de directorio »
  • PHP Manual
  • Directorio
  • Rebobina el manejador de directorio

Directory::rewind

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::rewind — Rebobina el manejador de directorio

Descripción

public Directory::rewind ( resource $dir_handle = ? ) : void

Igual a rewinddir(), dir_handle por defecto $this->handle.


Funciones de directorio

Ver también

Para funciones relacionadas, como dirname(),
is_dir(), mkdir(), y
rmdir(), visita
Filesystem sección.

Tabla de contenidos

  • chdir — Cambia de directorio
  • chroot — Cambia el directorio raíz
  • closedir — Cierra un gestor de directorio
  • dir — Devuelve una instancia de la clase Directory
  • getcwd — Obtiene el directorio actual en donde se esta trabajando
  • opendir — Abre un gestor de directorio
  • readdir — Lee una entrada desde un gestor de directorio
  • rewinddir — Regresar el gestor de directorio
  • scandir — Enumera los ficheros y directorios ubicados en la ruta especificada


Cambia de directorio

  • « Funciones de directorio
  • chroot »
  • PHP Manual
  • Funciones de directorio
  • Cambia de directorio

chdir

(PHP 4, PHP 5, PHP 7, PHP 8)

chdir — Cambia de directorio

Descripción

chdir ( string $directory ) : bool

Cambia el directorio actual de PHP a directorio.

Parámetros

directorio

El nuevo directorio actual.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING en caso de error.

Ejemplos

Ejemplo #1 chdir() ejemplo

<?php

// directorio actual
echo getcwd() . "\n";

chdir('public_html');

// directorio actual
echo getcwd() . "\n";

?>

El resultado del ejemplo sería algo similar a:

/home/vincent
/home/vincent/public_html

Notas

Ver también

  • getcwd() - Obtiene el directorio actual en donde se esta trabajando


Cambia el directorio raíz

  • « chdir
  • closedir »
  • PHP Manual
  • Funciones de directorio
  • Cambia el directorio raíz

chroot

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

chroot — Cambia el directorio raíz

Descripción

chroot ( string $directory ) : bool

Cambia el directorio raíz del proceso actual a directorio, y cambia el directorio de trabajo actual a "/".

Esta función sólo se encuentra disponible a sistemas GNU y BSD, y se encuentra usando un entorno CLI, CGI o SAPI embebido. Asimismo, esta función requiere privilegios de administrador (root).

Parámetros

directory

Directorio al que cambiar el raíz

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de chroot()

<?php
chroot("/ruta/al/chroot/");
echo getcwd();
?>

El resultado del ejemplo sería:

/

Notas

Nota: Esta función no está implementada en plataformas Windows.


Cierra un gestor de directorio

  • « chroot
  • dir »
  • PHP Manual
  • Funciones de directorio
  • Cierra un gestor de directorio

closedir

(PHP 4, PHP 5, PHP 7, PHP 8)

closedir — Cierra un gestor de directorio

Descripción

closedir ( resource $dir_handle = ? ) : void

Cierra la secuencia de directorio indicada por gestor_dir. La secuencia debe haber sido abierta previamente por opendir().

Parámetros

gestor_dir

El gestor de directorio tipo resource, previamente abierto con opendir(). Si el gestor de directorio no se especifica, la última conexión abierta por opendir() es asumida.

Ejemplos

Ejemplo #1 closedir() ejemplo

<?php
$dir = "/etc/php5/";

// Abrir un directorio conocido, lee el directorio en una variable y lo cierra.
if (is_dir($dir)) {
    if ($dh = opendir($dir)) {
        $directory = readdir($dh);
        closedir($dh);
    }
}
?>


Devuelve una instancia de la clase Directory

  • « closedir
  • getcwd »
  • PHP Manual
  • Funciones de directorio
  • Devuelve una instancia de la clase Directory

dir

(PHP 4, PHP 5, PHP 7, PHP 8)

dir — Devuelve una instancia de la clase Directory

Descripción

dir ( string $directory , resource $context = ? ) : Directory

Una forma pseudo orientada a objetos de leer un directorio. El directorio proporcionado en directory es abierto.

Parámetros

directory

Directorio a abrir

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve una instancia de la clase Directory, null cuando si los parámetros son incorrectos o false en caso de cualquier otro error.

Ejemplos

Ejemplo #1 Ejemplo de dir()

Atención a la forma en la que el valor de retorno de Directory::read() se comprueba en el siguiente ejemplo. Es necesario verificar si el valor de retorno es igual (tanto en valor como en tipo - ver Operadores de comparación para más información) a false, ya que de lo contrario, cualquier directorio cuyo nombre evaluase a false finalizaría el bucle.

<?php
$d = dir("/etc/php5");
echo "Handle: " . $d->handle . "\n";
echo "Path: " . $d->path . "\n";
while (false !== ($entry = $d->read())) {
   echo $entry."\n";
}
$d->close();
?>

El resultado del ejemplo sería algo similar a:

Handle: Resource id #2
Path: /etc/php5
.
..
apache
cgi
cli

Notas

Nota:

El orden en el que los archivos de un directorio son devueltos por el método de lectura depende del sistema.


Obtiene el directorio actual en donde se esta trabajando

  • « dir
  • opendir »
  • PHP Manual
  • Funciones de directorio
  • Obtiene el directorio actual en donde se esta trabajando

getcwd

(PHP 4, PHP 5, PHP 7, PHP 8)

getcwd — Obtiene el directorio actual en donde se esta trabajando

Descripción

getcwd ( ) : string

Obtiene el directorio actual.

Valores devueltos

Devuelve el directorio actual de trabajo en caso de éxito, o false si ocurre un error.

En algunas variantes de Unix, getcwd() devolverá false si alguno de los directorios padre no tiene definido el modo de lectura o búsqueda, incluso si el directorio actual lo tiene. Vea chmod() para más información sobre los modos y permisos.

Ejemplos

Ejemplo #1 getcwd() ejemplo

<?php

// directorio actual
echo getcwd() . "\n";

chdir('cvs');

// directorio actual
echo getcwd() . "\n";

?>

El resultado del ejemplo sería algo similar a:

/home/didou
/home/didou/cvs

Ver también

  • chdir() - Cambia de directorio
  • chmod() - Cambia el modo de un fichero


Abre un gestor de directorio

  • « getcwd
  • readdir »
  • PHP Manual
  • Funciones de directorio
  • Abre un gestor de directorio

opendir

(PHP 4, PHP 5, PHP 7, PHP 8)

opendir — Abre un gestor de directorio

Descripción

opendir ( string $path , resource $context = ? ) : resource

Abre un gestor de directorio para ser usado con llamadas posteriores como closedir(), readdir(), y rewinddir().

Parámetros

ruta

La ruta del directorio a ser abierta.

contexto

Para una descripción del parámetro contexto, refiérase a la sección de secuencias del manual.

Valores devueltos

Devuelve un gestor de directorio tipo resource en caso de éxito, o false si ocurre un error.

Si ruta no es un directorio válido o el directorio no puede ser abierto debido a restricciones de permisos o errores del sistema de archivos, opendir() devuelve false y genera un error de PHP de nivel E_WARNING. Es posible suprimir la salida del error de opendir() anteponiendo '@' al nombre de la función.

Historial de cambios

Versión | Descripción
5.0.0 | ruta soporta dentro de la URL la envoltura ftp://.
4.3.0 | ruta puede leer también cualquier URL que soporte el listado de directorios, sin embargo solo la envoltura de URL file:// tiene este soporte en PHP 4 .

Ejemplos

Ejemplo #1 opendir() ejemplo

<?php
$dir = "/etc/php5/";

// Abre un directorio conocido, y procede a leer el contenido
if (is_dir($dir)) {
    if ($dh = opendir($dir)) {
        while (($file = readdir($dh)) !== false) {
            echo "nombre archivo: $file : tipo archivo: " . filetype($dir . $file) . "\n";
        }
        closedir($dh);
    }
}
?>

El resultado del ejemplo sería algo similar a:

nombre archivo: . : tipo archivo: dir
nombre archivo: .. : tipo archivo: dir
nombre archivo: apache : tipo archivo: dir
nombre archivo: cgi : tipo archivo: dir
nombre archivo: cli : tipo archivo: dir

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • readdir() - Lee una entrada desde un gestor de directorio
  • dir() - Devuelve una instancia de la clase Directory


Lee una entrada desde un gestor de directorio

  • « opendir
  • rewinddir »
  • PHP Manual
  • Funciones de directorio
  • Lee una entrada desde un gestor de directorio

readdir

(PHP 4, PHP 5, PHP 7, PHP 8)

readdir — Lee una entrada desde un gestor de directorio

Descripción

readdir ( resource $dir_handle = ? ) : string

Devuelve el nombre de la siguiente entrada del directorio. Las entradas son devueltas en el orden en que fueron almacenadas por el sistema de ficheros.

Parámetros

gestor_dir

El gestor de directorio resource previamente abierto por opendir(). Si el gestor de directorio no se especifica, la ultima conexión abierta por opendir() es asumida.

Valores devueltos

Retorna el nombre de la entrada en caso de éxito o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Listar todas las entradas de un directorio

Por favor observe que la forma en que el valor de retorno de readdir() es chequeado en los siguientes ejemplos. Se está probando explícitamente si el valor de retorno es idéntico (igual y del mismo tipo, vea los Operadores de Comparación para más información) a false ya que de otra forma, cualquier entrada de directorio cuyo nombre evalúe a false detendrá el ciclo (p.ej. un directorio llamado "0").

<?php

if ($gestor = opendir('/path/to/files')) {
    echo "Gestor de directorio: $gestor\n";
    echo "Entradas:\n";

    /* Esta es la forma correcta de iterar sobre el directorio. */
    while (false !== ($entrada = readdir($gestor))) {
        echo "$entrada\n";
    }

    /* Esta es la forma errónea de iterar sobre el directorio. */
    while ($entrada = readdir($gestor)) {
        echo "$entrada\n";
    }

    closedir($gestor);
}
?>

Ejemplo #2 Listar todas las entradas del directorio actual y descartar . y ..

<?php
if ($gestor = opendir('.')) {
    while (false !== ($entrada = readdir($gestor))) {
        if ($entrada != "." && $entrada != "..") {
            echo "$entrada\n";
        }
    }
    closedir($gestor);
}
?>

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • glob() - Buscar coincidencias de nombres de ruta con un patrón
  • opendir() - Abre un gestor de directorio
  • scandir() - Enumera los ficheros y directorios ubicados en la ruta especificada


Regresar el gestor de directorio

  • « readdir
  • scandir »
  • PHP Manual
  • Funciones de directorio
  • Regresar el gestor de directorio

rewinddir

(PHP 4, PHP 5, PHP 7, PHP 8)

rewinddir — Regresar el gestor de directorio

Descripción

rewinddir ( resource $dir_handle = ? ) : void

Restablece la secuencia de directorio indicada por gestor_dir al comienzo del directorio.

Parámetros

gestor_dir

El gestor de directorio tipo resource abierto previamente con opendir(). Si el gestor de directorio no se especifica, la ultima conexión abierta por opendir() es asumida.

Valores devueltos

devuelve null en caso de éxito o false en caso de error.


Enumera los ficheros y directorios ubicados en la ruta especificada

  • « rewinddir
  • Fileinfo »
  • PHP Manual
  • Funciones de directorio
  • Enumera los ficheros y directorios ubicados en la ruta especificada

scandir

(PHP 5, PHP 7, PHP 8)

scandir — Enumera los ficheros y directorios ubicados en la ruta especificada

Descripción

scandir ( string $directory , int $sorting_order = SCANDIR_SORT_ASCENDING , resource $context = ? ) : array

Devuelve un array con los ficheros y los directorios que se encuentran bajo directory.

Parámetros

directory

El directorio que será examinado.

sorting_order

Por omisión, se ordena alfabéticamente en sentido ascendente. Si se utiliza el parámetro opcional sorting_order con el valor SCANDIR_SORT_DESCENDING, entonces se ordenará alfabéticamente en sentido descendente. Si se asigna SCANDIR_SORT_NONE entonces el resultado no se ordena.

context

Para una descripción del parámetro context, consulte la sección de flujos del manual.

Valores devueltos

Devuelve un array con los nombres de los ficheros en caso de éxito, o false en caso de error. Si directory no es un directorio, entonces se devuelve false, y se genera un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadieron las constantes de sorting_order. En versiones anteriores, cualquir valor distinto de cero ocasionaba un ordenamiento descendente. Por lo tanto, para todas las versiones de PHP, use 0 para el orden ascendente, y 1 para el orden descendente. No existía una opción para el comportamiento de SCANDIR_SORT_NONE antes de PHP 5.4.0.

Ejemplos

Ejemplo #1 Un simple ejemplo de scandir()

<?php
$directorio = '/tmp';
$ficheros1  = scandir($directorio);
$ficheros2  = scandir($directorio, 1);

print_r($ficheros1);
print_r($ficheros2);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Notas

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Ver también

  • opendir() - Abre un gestor de directorio
  • readdir() - Lee una entrada desde un gestor de directorio
  • glob() - Buscar coincidencias de nombres de ruta con un patrón
  • is_dir() - Indica si el nombre de archivo es un directorio
  • sort() - Ordena un array


Información de un fichero

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Fileinfo
    • finfo_buffer — Devuelve información sobre el búfer en formato string
    • finfo_close — Cierra el recurso fileinfo
    • finfo_file — Devuelve información sobre un fichero
    • finfo_open — Crea un nuevo recurso fileinfo
    • finfo_set_flags — Opciones de configuración de libmagic
    • mime_content_type — Detecta el MIME Content-type para un fichero
  • finfo — La clase finfo
    • finfo::buffer — Alias de finfo_buffer()
    • finfo::__construct — Alias de finfo_open
    • finfo::file — Alias de finfo_file()
    • finfo::set_flags — Alias de finfo_set_flags()


Introducción

Las funciones en este módulo tratan de averiguar el tipo de contenido y la codificación de un fichero buscando ciertas secuencias de bytes mágicas en una posición específica del mismo. Aunque no es una estrategia "a prueba de balas", la heurística empleada realiza un trabajo realmente bueno.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Antes de PHP 5.3.0, La librería magic_open se necesita para construir esta esta extensión.


Instalación

Esta extensión está activada por defecto desde PHP 5.3.0. Antes de esta versión, fileinfo era una extensión PECL pero ya no se sigue manteniendo. Sin embargo, en las versiones anteriores a 5.3+ se deben usar » La extensión PECL discontinuada.

Usuarios de Windows deben incluir el fichero DLL php_fileinfo.dll en php.ini para activar esta extensión.

La librería libmagic está incluida en PHP, pero incluye cambios específicos para PHP. Existe un parche para libmagic llamado libmagic.patch que es actualizado periódicamente y puede ser encontrado en las fuentes de las extensiones fileinfo para PHP.

Histórico de actualizaciones de la librería incluida libmagic
PHP Versión | Libmagic actualizado a Versión | Notas
5.3.2 | 5.03 |
5.3.0 | 5.02 |


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Hay un recurso usado por la extensión Fileinfo: magic database descriptor devuelto por finfo_open().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

FILEINFO_NONE (entero)
No special handling.
FILEINFO_SYMLINK (entero)
Seguir enlaces simbólicos.
FILEINFO_MIME_TYPE (entero)
Devuelve el tipo mime. Disponible desde PHP 5.3.0.
FILEINFO_MIME_ENCODING (entero)
Devuelve la codificación mime del fichero. Disponible desde PHP 5.3.0.
FILEINFO_MIME (entero)
Devuelve el tipo mime y la codificación definidas por RFC 2045.
FILEINFO_COMPRESS (entero)
Descomprimir ficheros comprimidos. Desactivado desde PHP 5.3.0 por razones de seguridad.
FILEINFO_DEVICES (entero)
Busca en el contenido por bloques o carácteres especiales de dispositivos.
FILEINFO_CONTINUE (entero)
Devuelve todos los resultados, no solo el primero.
FILEINFO_PRESERVE_ATIME (entero)
Es posible matener el tiempo de acceso original.
FILEINFO_RAW (entero)
No traducir carácteres no imprimibles como \ooo a representación octal.
FILEINFO_EXTENSION (integer)
Disponible desde PHP 7.2.0.


Funciones de Fileinfo

Tabla de contenidos

  • finfo_buffer — Devuelve información sobre el búfer en formato string
  • finfo_close — Cierra el recurso fileinfo
  • finfo_file — Devuelve información sobre un fichero
  • finfo_open — Crea un nuevo recurso fileinfo
  • finfo_set_flags — Opciones de configuración de libmagic
  • mime_content_type — Detecta el MIME Content-type para un fichero


Devuelve información sobre el búfer en formato string

  • « Funciones de Fileinfo
  • finfo_close »
  • PHP Manual
  • Funciones de Fileinfo
  • Devuelve información sobre el búfer en formato string

finfo_buffer

finfo::buffer

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_buffer -- finfo::buffer — Devuelve información sobre el búfer en formato string

Descripción

Estilo por procedimientos

finfo_buffer ( resource $finfo , string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Estilo orientado a objetos

public finfo::buffer ( string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Esta función se usa para obtener información sobre datos binarios en formato string.

Parámetros

finfo

Recurso Fileinfo devuelto por finfo_open().

string

Contenido del fichero a ser comprobado.

options

Una o más constantes Fileinfo .

context

Valores devueltos

Devuelve una descripción contextual del argumento string o false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de finfo_buffer()

<?php
$finfo = new finfo(FILEINFO_MIME);
echo $finfo->buffer($_POST["script"]) . "\n";
?>

El resultado del ejemplo sería algo similar a:

application/x-sh; charset=us-ascii

Ver también

  • finfo_file() - Alias de finfo_file()


Cierra el recurso fileinfo

  • « finfo_buffer
  • finfo_file »
  • PHP Manual
  • Funciones de Fileinfo
  • Cierra el recurso fileinfo

finfo_close

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_close — Cierra el recurso fileinfo

Descripción

finfo_close ( resource $finfo ) : bool

Esta función cierra el recurso abierto por finfo_open().

Parámetros

finfo

Devuelve el recurso Fileinfo devuelto por finfo_open().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve información sobre un fichero

  • « finfo_close
  • finfo_open »
  • PHP Manual
  • Funciones de Fileinfo
  • Devuelve información sobre un fichero

finfo_file

finfo::file

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_file -- finfo::file — Devuelve información sobre un fichero

Descripción

Estilo por procedimientos

finfo_file ( resource $finfo , string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Estilo orientado a objetos

public finfo::file ( string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Esta función se usa para obtener información de un fichero.

Parámetros

finfo

Devuelve recurso Fileinfo por finfo_open().

file_name

Nombre del fichero a ser comprobado.

options

Una o más constantes Fileinfo .

context

Para una descripción de contexts, dirígase a Funciones de Flujos.

Valores devueltos

Devuelve una descripción de texto del contenido del argumento file_name, o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de finfo_file()

<?php
$finfo = finfo_open(FILEINFO_MIME_TYPE); // devuelve el tipo mime de su extensión
foreach (glob("*") as $filename) {
    echo finfo_file($finfo, $filename) . "\n";
}
finfo_close($finfo);
?>

El resultado del ejemplo sería algo similar a:

text/html
image/gif
application/vnd.ms-excel

Ver también

  • finfo_buffer() - Alias de finfo_buffer()


Crea un nuevo recurso fileinfo

  • « finfo_file
  • finfo_set_flags »
  • PHP Manual
  • Funciones de Fileinfo
  • Crea un nuevo recurso fileinfo

finfo_open

finfo::__construct

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_open -- finfo::__construct — Crea un nuevo recurso fileinfo

Descripción

Estilo por procedimientos

finfo_open ( int $options = FILEINFO_NONE , string $magic_file = null ) : resource

Estilo orientado a objetos (constructor):

public finfo::__construct ( int $options = FILEINFO_NONE , string $magic_file = null )

Esta función abre una base de datos mágica y la devuelve a su recurso.

Parámetros

options

Una o más constantes Fileinfo .

magic_file

Nombre del fichero de la base de datos mágica, normalmente es algo como /path/to/magic.mime. Si no se especifica, se utilizará la variable de entorno MAGIC. Si esta variable no está establecida, se usará la base de datos mágica incluida en PHP.

Pasar null o un string vacío equivale al valor predeterminado.

Valores devueltos

(Sólo Estilo por procedimientos) Devuelve el recurso de la base de datos mágica si funciona o false en caso de error.

Notas

Advertencia

El formato esperado de la base de datos mágica cambió en PHP 5.3.11 y 5.4.1. Debido a esto, la base de datos mágica interna ha sido actualizada. Esto mayormente efectua código donde se use una base de datos mágica externa: leer un fichero mágico antiguo ahora fallará. Además, algunas representaciones textuales de los tipos mime han cambiado, por ejemplo, para PHP sería devuelto "PHP script, ASCII text" en lugar de "PHP script text".

Nota:

Generalmente, el uso de la base de datos mágica interna (dejando magic_file y las variables de entorno MAGIC sin establecer) es el mejor rumbo de acción a menos que sea necesaria especificamente una base de datos mágica personalizada.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php
$finfo = new finfo(FILEINFO_MIME, "/usr/share/misc/magic"); // Devuelve el tipo mime del tipo extensión

/* Obtiene el tipo mime para un fichero específico */
$filename = "/usr/local/something.txt";
echo $finfo->file($filename);

?>

Ejemplo #2 Estilo por procedimientos

<?php
$finfo = finfo_open(FILEINFO_MIME, "/usr/share/misc/magic"); // Devuelve el tipo mime del tipo extensión

if (!$finfo) {
    echo "Ocurrió un error al intentar abrir la base de datos de fileinfo";
    exit();
}

/* Obtiene el tipo mime para un fichero específico */
$filename = "/usr/local/something.txt";
echo finfo_file($finfo, $filename);

/* cerrar conexión */
finfo_close($finfo);
?>

El resultado del ejemplo sería:

text/plain; charset=us-ascii

Ver también

  • finfo_close() - Cierra el recurso fileinfo


Opciones de configuración de libmagic

  • « finfo_open
  • mime_content_type »
  • PHP Manual
  • Funciones de Fileinfo
  • Opciones de configuración de libmagic

finfo_set_flags

finfo::set_flags

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_set_flags -- finfo::set_flags — Opciones de configuración de libmagic

Descripción

Estilo por procedimientos

finfo_set_flags ( resource $finfo , int $options ) : bool

Estilo orientado a objetos

public finfo::set_flags ( int $options ) : bool

Esta función establece varias opcines Fileinfo. Las opciones pueden establecerse directamente en finfo_open() u otras funciones Fileinfo.

Parámetros

finfo

Recurso devuelto por finfo_open().

options

Una o más constantes Fileinfo .

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Detecta el MIME Content-type para un fichero

  • « finfo_set_flags
  • finfo »
  • PHP Manual
  • Funciones de Fileinfo
  • Detecta el MIME Content-type para un fichero

mime_content_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mime_content_type — Detecta el MIME Content-type para un fichero

Descripción

mime_content_type ( string $filename ) : string

Devuelve el MIME content type para un fichero determinado usando información desde el fichero magic.mime.

Parámetros

filename

Ruta para comprobar fichero.

Valores devueltos

Devuelve el contenido en formato MIME como, text/plain o application/octet-stream, o false en caso de error.

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Ejemplos

Ejemplo #1 Ejemplo mime_content_type()

<?php
echo mime_content_type('php.gif') . "\n";
echo mime_content_type('test.php');
?>

El resultado del ejemplo sería:

image/gif
text/plain

Ver también

  • finfo_file() - Alias de finfo_file()
  • finfo_buffer() - Alias de finfo_buffer()


La clase finfo

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

Introducción

Esta clase proporciona una interfaz orientada a objetos para las funciones de fileinfo.

Sinopsis de la Clase

finfo {
public __construct ( int $options = FILEINFO_NONE , string $magic_file = null )
public buffer ( string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string
public file ( string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string
public set_flags ( int $options ) : bool
}

Tabla de contenidos

  • finfo::buffer — Alias de finfo_buffer()
  • finfo::__construct — Alias de finfo_open
  • finfo::file — Alias de finfo_file()
  • finfo::set_flags — Alias de finfo_set_flags()


Alias de finfo_buffer()

  • « finfo
  • finfo::__construct »
  • PHP Manual
  • finfo
  • Alias de finfo_buffer()

finfo::buffer

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::buffer — Alias de finfo_buffer()

Descripción

public finfo::buffer ( string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Esta función es un alias de: finfo_buffer()


Alias de finfo_open

  • « finfo::buffer
  • finfo::file »
  • PHP Manual
  • finfo
  • Alias de finfo_open

finfo::__construct

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::__construct — Alias de finfo_open()

Descripción

public finfo::__construct ( int $options = FILEINFO_NONE , string $magic_file = null )

Esta función es un alias de: finfo_open()


Alias de finfo_file()

  • « finfo::__construct
  • finfo::set_flags »
  • PHP Manual
  • finfo
  • Alias de finfo_file()

finfo::file

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::file — Alias de finfo_file()

Descripción

public finfo::file ( string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string

Esta función es un alias de: finfo_file()


Alias de finfo_set_flags()

  • « finfo::file
  • Sistema de Ficheros »
  • PHP Manual
  • finfo
  • Alias de finfo_set_flags()

finfo::set_flags

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::set_flags — Alias de finfo_set_flags()

Descripción

public finfo::set_flags ( int $options ) : bool

Esta función es un alias de: finfo_set_flags()


Sistema de Ficheros

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones del Sistema de Archivos
    • basename — Devuelve el último componente de nombre de una ruta
    • chgrp — Cambia el grupo del archivo
    • chmod — Cambia el modo de un fichero
    • chown — Cambia el propietario del fichero
    • clearstatcache — Limpia la caché de estado de un archivo
    • copy — Copia un fichero
    • delete — Véase unlink o unset
    • dirname — Devuelve la ruta de un directorio padre
    • disk_free_space — Devuelve el espacio disponible de un sistema de archivos o partición de disco
    • disk_total_space — Devuelve el tamaño total de un sistema de archivos o partición de disco
    • diskfreespace — Alias de disk_free_space
    • fclose — Cierra un puntero a un archivo abierto
    • feof — Comprueba si el puntero a un archivo está al final del archivo
    • fflush — Vuelca la salida a un archivo
    • fgetc — Obtiene un carácter de un puntero a un archivo
    • fgetcsv — Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV
    • fgets — Obtiene una línea desde el puntero a un fichero
    • fgetss — Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
    • file_exists — Comprueba si existe un fichero o directorio
    • file_get_contents — Transmite un fichero completo a una cadena
    • file_put_contents — Escribir datos en un fichero
    • file — Transfiere un fichero completo a un array
    • fileatime — Obtiene el momento del último acceso a un archivo
    • filectime — Obtiene el momento del último cambio del i-nodo de un archivo
    • filegroup — Obtiene el grupo de un archivo
    • fileinode — Obtiene el i-nodo del archivo
    • filemtime — Obtiene el momento de la última modificación de un archivo
    • fileowner — Obtiene el propietario de un archivo
    • fileperms — Obtiene los permisos de un fichero
    • filesize — Obtiene el tamaño de un fichero
    • filetype — Obtiene el tipo de fichero
    • flock — Bloqueo de ficheros recomendado y portable
    • fnmatch — Compara un nombre de fichero con un patrón
    • fopen — Abre un fichero o un URL
    • fpassthru — Escribe toda la información restante de un puntero a un archivo
    • fputcsv — Dar formato CSV a una línea y escribirla en un puntero a un fichero
    • fputs — Alias de fwrite
    • fread — Lectura de un fichero en modo binario seguro
    • fscanf — Analiza la entrada desde un archivo de acuerdo a un formato
    • fseek — Busca sobre un puntero a un fichero
    • fstat — Obtiene información acerca de un archivo usando un puntero al archivo abierto
    • ftell — Devuelve la posición de lectura/escritura actual del puntero a un fichero
    • ftruncate — Trunca un archivo a una longitud dada
    • fwrite — Escritura de un archivo en modo binario seguro
    • glob — Buscar coincidencias de nombres de ruta con un patrón
    • is_dir — Indica si el nombre de archivo es un directorio
    • is_executable — Indica si el nombre de archivo es ejecutable
    • is_file — Indica si el nombre de fichero es un fichero normal
    • is_link — Indica si el nombre de archivo es un enlace simbólico
    • is_readable — Indica si un fichero existe y es legible
    • is_uploaded_file — Indica si el archivo fue subido mediante HTTP POST
    • is_writable — Indica si un archivo existe y es escribible
    • is_writeable — Alias de is_writable
    • lchgrp — Cambia el grupo de un enlace simbólico
    • lchown — Cambia el propietario de un enlace simbólico
    • link — Crea un enlace duro
    • linkinfo — Obtiene información acerca de un enlace
    • lstat — Da información acerca de un archivo o enlace simbólico
    • mkdir — Crea un directorio
    • move_uploaded_file — Mueve un archivo subido a una nueva ubicación
    • parse_ini_file — Analiza un fichero de configuración
    • parse_ini_string — Analiza una cadena de configuración
    • pathinfo — Devuelve información acerca de la ruta de un fichero
    • pclose — Cierra un proceso de un puntero a un fichero
    • popen — Abre un proceso de un puntero a un fichero
    • readfile — Realizar la salida de un fichero
    • readlink — Devuelve el objetivo de un enlace simbólico
    • realpath_cache_get — Obtiene las entradas de la caché de la ruta real
    • realpath_cache_size — Obtiene el tamaño de la caché de la ruta real
    • realpath — Devuelve el nombre de la ruta absoluta canonizado
    • rename — Renombra un fichero o directorio
    • rewind — Rebobina la posición de un puntero a un archivo
    • rmdir — Elimina un directorio
    • set_file_buffer — Alias de stream_set_write_buffer
    • stat — Da información acerca de un fichero
    • symlink — Crea un enlace simbólico
    • tempnam — Crea un fichero con un nombre de fichero único
    • tmpfile — Crea un archivo temporal
    • touch — Establece el momento de acceso y modificación de un archivo
    • umask — Cambia la máscara de usuario actual
    • unlink — Borra un fichero


Introducción

No es necesaria ninguna biblioteca externa para construir esta extensión, pero si quiere que PHP admita LFS (ficheros grandes) en Linux, necesita tener una versión reciente de glibc y compilar PHP con las siguientes banderas de compilación: -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración del sistema de ficheros y flujos
Nombre | Por defecto | Cambiable | Historial de cambios
allow_url_fopen | "1" | PHP_INI_SYSTEM |
allow_url_include | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 5.2.0.
user_agent | NULL | PHP_INI_ALL |
default_socket_timeout | "60" | PHP_INI_ALL |
from | "" | PHP_INI_ALL |
auto_detect_line_endings | "0" | PHP_INI_ALL |
sys_temp_dir | "" | PHP_INI_SYSTEM | Available a partir de PHP 5.5.0.

He aquí una breve explicación de las directivas de configuración.

allow_url_fopen boolean

Esta opción habilita las envolturas fopen de tipo URL que permiten el acceso a objetos URL como ficheros. Las envolturas predeterminadas están proporcionads para el acceso de ficheros remotos usando los protocolos ftp o http, algunas extensiones como zlib pueden registrar envolturas adicionales.

allow_url_include boolean

Esta opción permite es uso de envolturas fopen de tipo URL con las siguientes funciones: include, include_once, require, require_once.

Nota:

Esta opción requiere allow_url_fopen para ser activada.

user_agent string

Define el agente de usuario de PHP para el envío.

default_socket_timeout integer

Tiempo de espera predeterminado (en segundos) para sockets basados en flujos.

from string

La dirección de email a usar en conexiones FTP no autenticadas y como valor de la cabecera From de conexiones HTTP, al usar las envolturas ftp y http, respectivamente.

auto_detect_line_endings boolean

Cuando se activa, PHP examinará la información leída por fgets() y file() para ver si se está usando las convenciones de final de línea de Unix, MS-Dos o Macintosh.

Esto permite a PHP inter-operar con los sistemas Macintosh, pero por defecto está en Off, ya que hay una pérdida muy pequeña de rendimiento cuando se detectan las convenciones de EOL para la primera línea, y también porque la gente que usa retornos de carro como elementos serparadores bajo sistemas Unix podrían experimentar un comportamiento que no es compatible con versiones anteriores.

sys_temp_dir string


Tipos de recursos

El sistema de ficheros usa flujos como su tipo de recursos. Los flujos están documentados en su propio capítulo de referencia, Flujos.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SEEK_SET (integer)
SEEK_CUR (integer)
SEEK_END (integer)
LOCK_SH (integer)
LOCK_EX (integer)
LOCK_UN (integer)
LOCK_NB (integer)
GLOB_BRACE (integer)
GLOB_ONLYDIR (integer)
GLOB_MARK (integer)
GLOB_NOSORT (integer)
GLOB_NOCHECK (integer)
GLOB_NOESCAPE (integer)
GLOB_AVAILABLE_FLAGS (integer)
PATHINFO_DIRNAME (integer)
PATHINFO_BASENAME (integer)
PATHINFO_EXTENSION (integer)
PATHINFO_FILENAME (integer)
A partir de PHP 5.2.0.
FILE_USE_INCLUDE_PATH (integer)
Busca filename en include_path.
FILE_NO_DEFAULT_CONTEXT (integer)
FILE_APPEND (integer)
Añade contenido a un archivo existente.
FILE_IGNORE_NEW_LINES (integer)
Quita caracteres EOL.
FILE_SKIP_EMPTY_LINES (integer)
Salta líneas vacías.
FILE_BINARY (integer)

Modo binario (desde PHP 5.2.7).

Nota:

Esta constante no tiene efecto y sólo esta disponible por compatibiidad de versiones posteriores.

FILE_TEXT (integer)

Modo texto (desde PHP 5.2.7).

Nota:

Esta constante no tiene efecto y sólo esta disponible por compatibilidad de versiones posteriores.

INI_SCANNER_NORMAL (integer)
Modo de búsquda INI normal (desde PHP 5.3).
INI_SCANNER_RAW (integer)
Modo de búsqueda INI en bruto (desde PHP 5.3).
INI_SCANNER_TYPED (integer)
Modo de examen INI tipificado (desde PHP 5.6.1).
FNM_NOESCAPE (integer)
Deshabilita el escapado de la barra invertida.
FNM_PATHNAME (integer)
Una barra en una cadena sólo concide con otra en el patrón dado.
FNM_PERIOD (integer)
Un punto en una cadena debe coincidir exactamente con otro en el patrón dado.
FNM_CASEFOLD (integer)
Comparación insensible a mayúsculas-minúsculas. Parte de la extensión GNU.


Funciones del Sistema de Archivos

Ver también

Para funciones relacionadas, vea también las secciones Directorio y Ejecución de Programas.

Para una lista y explicación de las distintas envolturas URL que se pueden usar como archivos remotos, vea también Protocolos y Envolturas soportados.

Tabla de contenidos

  • basename — Devuelve el último componente de nombre de una ruta
  • chgrp — Cambia el grupo del archivo
  • chmod — Cambia el modo de un fichero
  • chown — Cambia el propietario del fichero
  • clearstatcache — Limpia la caché de estado de un archivo
  • copy — Copia un fichero
  • delete — Véase unlink o unset
  • dirname — Devuelve la ruta de un directorio padre
  • disk_free_space — Devuelve el espacio disponible de un sistema de archivos o partición de disco
  • disk_total_space — Devuelve el tamaño total de un sistema de archivos o partición de disco
  • diskfreespace — Alias de disk_free_space
  • fclose — Cierra un puntero a un archivo abierto
  • feof — Comprueba si el puntero a un archivo está al final del archivo
  • fflush — Vuelca la salida a un archivo
  • fgetc — Obtiene un carácter de un puntero a un archivo
  • fgetcsv — Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV
  • fgets — Obtiene una línea desde el puntero a un fichero
  • fgetss — Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • file_exists — Comprueba si existe un fichero o directorio
  • file_get_contents — Transmite un fichero completo a una cadena
  • file_put_contents — Escribir datos en un fichero
  • file — Transfiere un fichero completo a un array
  • fileatime — Obtiene el momento del último acceso a un archivo
  • filectime — Obtiene el momento del último cambio del i-nodo de un archivo
  • filegroup — Obtiene el grupo de un archivo
  • fileinode — Obtiene el i-nodo del archivo
  • filemtime — Obtiene el momento de la última modificación de un archivo
  • fileowner — Obtiene el propietario de un archivo
  • fileperms — Obtiene los permisos de un fichero
  • filesize — Obtiene el tamaño de un fichero
  • filetype — Obtiene el tipo de fichero
  • flock — Bloqueo de ficheros recomendado y portable
  • fnmatch — Compara un nombre de fichero con un patrón
  • fopen — Abre un fichero o un URL
  • fpassthru — Escribe toda la información restante de un puntero a un archivo
  • fputcsv — Dar formato CSV a una línea y escribirla en un puntero a un fichero
  • fputs — Alias de fwrite
  • fread — Lectura de un fichero en modo binario seguro
  • fscanf — Analiza la entrada desde un archivo de acuerdo a un formato
  • fseek — Busca sobre un puntero a un fichero
  • fstat — Obtiene información acerca de un archivo usando un puntero al archivo abierto
  • ftell — Devuelve la posición de lectura/escritura actual del puntero a un fichero
  • ftruncate — Trunca un archivo a una longitud dada
  • fwrite — Escritura de un archivo en modo binario seguro
  • glob — Buscar coincidencias de nombres de ruta con un patrón
  • is_dir — Indica si el nombre de archivo es un directorio
  • is_executable — Indica si el nombre de archivo es ejecutable
  • is_file — Indica si el nombre de fichero es un fichero normal
  • is_link — Indica si el nombre de archivo es un enlace simbólico
  • is_readable — Indica si un fichero existe y es legible
  • is_uploaded_file — Indica si el archivo fue subido mediante HTTP POST
  • is_writable — Indica si un archivo existe y es escribible
  • is_writeable — Alias de is_writable
  • lchgrp — Cambia el grupo de un enlace simbólico
  • lchown — Cambia el propietario de un enlace simbólico
  • link — Crea un enlace duro
  • linkinfo — Obtiene información acerca de un enlace
  • lstat — Da información acerca de un archivo o enlace simbólico
  • mkdir — Crea un directorio
  • move_uploaded_file — Mueve un archivo subido a una nueva ubicación
  • parse_ini_file — Analiza un fichero de configuración
  • parse_ini_string — Analiza una cadena de configuración
  • pathinfo — Devuelve información acerca de la ruta de un fichero
  • pclose — Cierra un proceso de un puntero a un fichero
  • popen — Abre un proceso de un puntero a un fichero
  • readfile — Realizar la salida de un fichero
  • readlink — Devuelve el objetivo de un enlace simbólico
  • realpath_cache_get — Obtiene las entradas de la caché de la ruta real
  • realpath_cache_size — Obtiene el tamaño de la caché de la ruta real
  • realpath — Devuelve el nombre de la ruta absoluta canonizado
  • rename — Renombra un fichero o directorio
  • rewind — Rebobina la posición de un puntero a un archivo
  • rmdir — Elimina un directorio
  • set_file_buffer — Alias de stream_set_write_buffer
  • stat — Da información acerca de un fichero
  • symlink — Crea un enlace simbólico
  • tempnam — Crea un fichero con un nombre de fichero único
  • tmpfile — Crea un archivo temporal
  • touch — Establece el momento de acceso y modificación de un archivo
  • umask — Cambia la máscara de usuario actual
  • unlink — Borra un fichero


Devuelve el último componente de nombre de una ruta

  • « Funciones del Sistema de Archivos
  • chgrp »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve el último componente de nombre de una ruta

basename

(PHP 4, PHP 5, PHP 7, PHP 8)

basename — Devuelve el último componente de nombre de una ruta

Descripción

basename ( string $path , string $suffix = ? ) : string

Dada una cadena que contiene una ruta a un archivo o directorio, esta función devolverá el último componente de nombre.

Nota:

basename() opera nativamente en la entrada de cadena, y no es consciente del actual sistema de archivos, o componentes de ruta como "..".

Precaución

basename() es consciente de su sistema de localidad, así que para ver el nombre base correcto con rutas de caracteres multibyte, la localidad debe coincidir con la establecida con la función setlocale().

Parámetros

path

Una ruta.

En Windows, la barra (/) y la barra invertida (\) se usan como carácter separador de directorio. En otros entornos se usa la barra hacia delante (/).

suffix

Si el nombre del componente termina en suffix éste será recortado también.

Valores devueltos

Devuelve el nombre base de path.

Ejemplos

Ejemplo #1 Ejemplo de basename()

<?php
echo "1) ".basename("/etc/sudoers.d", ".d").PHP_EOL;
echo "2) ".basename("/etc/sudoers.d").PHP_EOL;
echo "3) ".basename("/etc/passwd").PHP_EOL;
echo "4) ".basename("/etc/").PHP_EOL;
echo "5) ".basename(".").PHP_EOL;
echo "6) ".basename("/");
?>

El resultado del ejemplo sería:

1) sudoers
2) sudoers.d
3) passwd
4) etc
5) .
6)

Ver también

  • dirname() - Devuelve la ruta de un directorio padre
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Cambia el grupo del archivo

  • « basename
  • chmod »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia el grupo del archivo

chgrp

(PHP 4, PHP 5, PHP 7, PHP 8)

chgrp — Cambia el grupo del archivo

Descripción

chgrp ( string $filename , mixed $group ) : bool

Intenta cambiar el grupo del archivo filename a group.

Sólo el superusuario puede cambiar el grupo de un archivo arbitrariamente; los otros usuarios pueden cambiar el grupo de un archivo por cualquier grupo del que el usuario sea miembro.

Parámetros

filename

Ruta del archivo.

group

Un nombre o número de grupo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cambiar el grupo de un archivo

<?php
$nombre_fichero = 'shared_file.txt';
$formato = "%s's Group ID @ %s: %d\n";
printf($formato, $nombre_fichero, date('r'), filegroup($nombre_fichero));
chgrp($nombre_fichero, 8);
clearstatcache(); // no almacenar en caché los resultados de filegroup()
printf($formato, $nombre_fichero, date('r'), filegroup($nombre_archivo));
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Ver también

  • chown() - Cambia el propietario del fichero
  • chmod() - Cambia el modo de un fichero


Cambia el modo de un fichero

  • « chgrp
  • chown »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia el modo de un fichero

chmod

(PHP 4, PHP 5, PHP 7, PHP 8)

chmod — Cambia el modo de un fichero

Descripción

chmod ( string $filename , int $mode ) : bool

Intenta cambiar el modo de un fichero especificado por el dado en mode.

Parámetros

filename

Ruta del fichero.

mode

Observe que no se asume que mode sea automáticamente un valor octal, por lo que, para asegurarse de que la opración sea la esperada, es necesario prefijar mode con un cero (0). String tales como "g+w" no funcionarán adecuadamente.

<?php
chmod("/directorio/fichero", 755);   // decimal; probablemente incorrecto
chmod("/directorio/fichero", "u+rwx,go+rx"); // string; incorrecto
chmod("/directorio/fichero", 0755);  // octal; valor de modo correcto
?>

El parámetro mode consiste en tres componentes numéricos octales que especifican las restricciones de acceso para el propietario, el grupo de usuarios al que pertenece el propietario, y para todos los demás, en este orden. Un componente puede ser computado sumando los permisos necesarios para ese usuario objetivo base. El número 1 significa que se conceden derechos de ejecución, el número 2 significa que se puede escribir en el fichero, el número 4 significa que el fichero se puede leer. Sume estos números para especificar los derechos necesarios. Se puede leer más sobre los modos en sistemas Unix con 'man 1 chmod' y 'man 2 chmod'.

<?php
// Lectura y escritura para el propietario, nada para los demás
chmod("/directorio/fichero", 0600);

// Lectura y escritura para el propietario, lectura para los demás
chmod("/directorio/fichero", 0644);

// Todo para el propietario, lectura y ejecución para los otros
chmod("/directorio/fichero", 0755);

// Todo para el propietario, lectura y ejecución para el grupo del propietario
chmod("/directorio/fichero", 0750);
?>

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

El usuario actual es el usuario bajo el que se ejecuta PHP. Probablemente no sea el mismo usuario que se utilize para el intérprete de comandos normal o el acceso FTP. EL modo puede ser cambiado sólo por el usuario al que pertenece el fichero en la mayoría de sistemas.

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Ver también

  • chown() - Cambia el propietario del fichero
  • chgrp() - Cambia el grupo del archivo
  • fileperms() - Obtiene los permisos de un fichero
  • stat() - Da información acerca de un fichero


Cambia el propietario del fichero

  • « chmod
  • clearstatcache »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia el propietario del fichero

chown

(PHP 4, PHP 5, PHP 7, PHP 8)

chown — Cambia el propietario del fichero

Descripción

chown ( string $filename , mixed $user ) : bool

Intenta cambiar el propietario del fichero filename por el usuario user. Sólo el superusuario puede cambiar el propietario de un fichero.

Parámetros

filename

La ruta hacia el fichero.

user

Un nombre o número de usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso sencillo de chown()

<?php

// El nombre de fichero y el nombre de usuario a emplear
$nombre_fichero= "foo.php";
$ruta = "/home/sites/php.net/public_html/sandbox/" . $nombre_fichero ;
$nombre_usuario = "root";

// Establecer el usuario
chown($ruta, $nombre_usuario);

// Verificar el resultado
$stat = stat($ruta);
print_r(posix_getpwuid($stat['uid']));

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name] => root
    [passwd] => x
    [uid] => 0
    [gid] => 0
    [gecos] => root
    [dir] => /root
    [shell] => /bin/bash
)

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Ver también

  • chmod() - Cambia el modo de un fichero
  • chgrp() - Cambia el grupo del archivo


Limpia la caché de estado de un archivo

  • « chown
  • copy »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Limpia la caché de estado de un archivo

clearstatcache

(PHP 4, PHP 5, PHP 7, PHP 8)

clearstatcache — Limpia la caché de estado de un archivo

Descripción

clearstatcache ( bool $clear_realpath_cache = false , string $filename = ? ) : void

Cuando usa stat(), lstat(), o cualquier otra función enumerada en la lista de funciones afectadas (abajo), PHP examina la información que devuelven esas funciones para proporcionar un rendimiento más rápido. Sin embargo, en ciertos casos, puede querer borrar la información almacenada en caché. Por ejemplo, si el mismo archivo está siendo verificado múltiples veces dentro de un sólo script, y ese archivo corre el peligro de ser borrado o modificado durante la operación de ese script, puede optar por limpiar la caché de estado. En estos casos, puede usar la función clearstatcache() para borrar la información que PHP examina del archivo.

Debería observar también que PHP no examina información sobre archivos no existentes. Por lo que si llama a file_exists() con un archivo que no existe, se devolverá false a menos que cree el archivo. Si crea el archivo, se devolverá true incluso si después borra el archivo. Sin embargo unlink() limpia la caché automáticamente.

Nota:

Esta función examina la información sobre nombres de archivos específicos, por lo que sólo necesita llamar a clearstatcache() si está llevando a cabo múltiples operaciones sobre un mismo nombre de archivo y necesita que la información sobre ese archivo en particular no sea examinada.

Las funciones afectadas incluyen stat(),
lstat(),
file_exists(),
is_writable(),
is_readable(),
is_executable(),
is_file(),
is_dir(),
is_link(),
filectime(),
fileatime(),
filemtime(),
fileinode(),
filegroup(),
fileowner(),
filesize(),
filetype(), y
fileperms().

Parámetros

clear_realpath_cache

Si se limpia la caché de la ruta real o no.

filename

Limpia la ruta real y la caché de estadísticas para un nombre de fichero específico; solamente se usa si clear_realpath_cache es true.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadieron los parámetros opcionales clear_realpath_cache y filename.

Ejemplos

Ejemplo #1 Ejemplo de clearstatcache()

<?php
$archivo = 'output_log.txt';

function obtener_propietario($archivo)
{
    $estadísticas = stat($archivo);
    $usuario = posix_getpwuid($estadísticas['uid']);
    return $usuario['name'];
}

$formato = "UID @ %s: %s\n";

printf($formato, date('r'), obtener_propietario($archivo));

chown($archivo, 'ross');
printf($formato, date('r'), obtener_propietario($archivo));

clearstatcache();
printf($formato, date('r'), obtener_propietario($archivo));
?>

El resultado del ejemplo sería algo similar a:

UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: ross


Copia un fichero

  • « clearstatcache
  • delete »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Copia un fichero

copy

(PHP 4, PHP 5, PHP 7, PHP 8)

copy — Copia un fichero

Descripción

copy ( string $source , string $dest , resource $context = ? ) : bool

Realiza un copia del fichero source a dest.

Si se quiere mover un fichero, use la función rename().

Parámetros

source

Ruta al fichero de origen.

dest

La ruta de destino. Si dest es un URL, la operación de copiado puede fallar si la envoltura no admite la sobrescritura de ficheros existentes.

Advertencia

Si el fichero destino ya existe, será sobrescrito.

context

Un recurso de contexto válido creado con stream_context_create().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.4 | Se cambió el parámetro context para que realmente tenga efecto. Anteriormente, se ignoraba cualquier context.
5.3.0 | Se añadió el soporte para el contexto.

Ejemplos

Ejemplo #1 Ejemplo de copy()

<?php
$fichero = 'ejemplo.txt';
$nuevo_fichero = 'ejemplo.txt.bak';

if (!copy($fichero, $nuevo_fichero)) {
    echo "Error al copiar $fichero...\n";
}
?>

Ver también

  • move_uploaded_file() - Mueve un archivo subido a una nueva ubicación
  • rename() - Renombra un fichero o directorio
  • La sección del manual sobre el manejo de subida de ficheros


Véase unlink o unset

  • « copy
  • dirname »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Véase unlink o unset

delete

delete — Véase unlink() o unset()

Descripción

Esta es una entrada trivial del manual para satisfacer a aquéllos que están buscando unlink() o unset() en el lugar equivocado.

Ver también

  • unlink() - Borra un fichero
  • unset() - Destruye una variable especificada


Devuelve la ruta de un directorio padre

  • « delete
  • disk_free_space »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve la ruta de un directorio padre

dirname

(PHP 4, PHP 5, PHP 7, PHP 8)

dirname — Devuelve la ruta de un directorio padre

Descripción

dirname ( string $path , int $levels = 1 ) : string

Dada una cadena que contiene la ruta a un fichero o directorio, esta función devolverá la ruta del directorio padre que está a levels niveles del directorio actual.

Nota:

dirname() opera de forma ingénua con la cadena de entrada, y no es consciente del sistema de ficheros o los componentes de la ruta como "..".

Precaución

dirname() usa la configuración de idioma local, para poder ver de forma correcta el nombre de directorio con caracteres multibyte en la ruta, se definir la misma configuración local usando la función setlocale().

Parámetros

path

Una ruta.

En Windows, la barra (/) y la barra invertida (\) se usan como carácter separador de directorio. En otros entornos se usa la barra hacia delante (/).

levels

El número de directorios padre a subir.

Debe ser un número entero mayor que 0.

Valores devueltos

Devuelve la ruta de un directorio padre. Si no hay barras en path, será devuelto un punto ('.'), indicando el directorio actual. De otro modo, la cadena devuelta es path con cualquier /componente final eliminado.

Historial de cambios

Versión | Descripción
7.0.0 | Añadido el parámetro opcional levels.

Ejemplos

Ejemplo #1 Ejemplo de dirname()

<?php
echo dirname("/etc/passwd") . PHP_EOL;
echo dirname("/etc/") . PHP_EOL;
echo dirname(".") . PHP_EOL;
echo dirname("C:\\") . PHP_EOL;
echo dirname("/usr/local/lib", 2);

El resultado del ejemplo sería algo similar a:

/etc
/ (o \ en Windows)
.
C:\
/usr

Ver también

  • basename() - Devuelve el último componente de nombre de una ruta
  • pathinfo() - Devuelve información acerca de la ruta de un fichero
  • realpath() - Devuelve el nombre de la ruta absoluta canonizado


Devuelve el espacio disponible de un sistema de archivos o partición de disco

  • « dirname
  • disk_total_space »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve el espacio disponible de un sistema de archivos o partición de disco

disk_free_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

disk_free_space — Devuelve el espacio disponible de un sistema de archivos o partición de disco

Descripción

disk_free_space ( string $directory ) : float

Dada una cadena que contiene un directorio, esta función devolverá el número de bytes disponibles en el sistema de archivos o partición de disco correspondiente.

Parámetros

directory

Un directorio del sistema de archivos o partición de disco.

Nota:

Dado un nombre de archivo en vez de un directorio, el comportamiento de la función no está especificado y puede diferir entre sistemas operativos y versiones de PHP.

Valores devueltos

Devuelve el número de bytes disponibles como un float o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de disk_free_space()

<?php
// $df contiene el número de bytes disponibles en "/"
$df = disk_free_space("/");

// En Windows:
$df_c = disk_free_space("C:");
$df_d = disk_free_space("D:");
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Ver también

  • disk_total_space() - Devuelve el tamaño total de un sistema de archivos o partición de disco


Devuelve el tamaño total de un sistema de archivos o partición de disco

  • « disk_free_space
  • diskfreespace »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve el tamaño total de un sistema de archivos o partición de disco

disk_total_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

disk_total_space — Devuelve el tamaño total de un sistema de archivos o partición de disco

Descripción

disk_total_space ( string $directory ) : float

Dada una cadena que contiene un directorio, esta función devolverá el número total de bytes del sistema de archivos o partición de disco correspondiente.

Parámetros

directory

Un directorio del sistema de archivos o partición de disco.

Valores devueltos

Devuelve el número total de bytes como un float o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de disk_total_space()

<?php
// $ds contiene el número total de bytes disponibles en "/"
$ds = disk_total_space("/");

// En Windows:
$ds = disk_total_space("C:");
$ds = disk_total_space("D:");
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Ver también

  • disk_free_space() - Devuelve el espacio disponible de un sistema de archivos o partición de disco


Alias de disk_free_space

  • « disk_total_space
  • fclose »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Alias de disk_free_space

diskfreespace

(PHP 4, PHP 5, PHP 7, PHP 8)

diskfreespace — Alias de disk_free_space()

Descripción

Esta función es un alias de: disk_free_space().


Cierra un puntero a un archivo abierto

  • « diskfreespace
  • feof »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cierra un puntero a un archivo abierto

fclose

(PHP 4, PHP 5, PHP 7, PHP 8)

fclose — Cierra un puntero a un archivo abierto

Descripción

fclose ( resource $handle ) : bool

El archivo apuntado por handle es cerrado.

Parámetros

handle

El puntero al archivo debe ser válido, y debe apuntar al archivo abierto con éxito por fopen() o fsockopen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de fclose()

<?php

$gestor = fopen('archivo.txt', 'r');

fclose($gestor);

?>

Ver también

  • fopen() - Abre un fichero o un URL
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix


Comprueba si el puntero a un archivo está al final del archivo

  • « fclose
  • fflush »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Comprueba si el puntero a un archivo está al final del archivo

feof

(PHP 4, PHP 5, PHP 7, PHP 8)

feof — Comprueba si el puntero a un archivo está al final del archivo

Descripción

feof ( resource $handle ) : bool

Comprueba si el puntero a un archivo está al final del archivo.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

Valores devueltos

Devuelve true si el puntero al archivo está en EOF o produce un error (incluido el tiempo de espera del socket); de otro modo devuelve false.

Notas

Advertencia

Si una conexión abierta por fsockopen() no se cerró por el servidor, feof() se colgará. Para solucionar esto, vea el ejemplo siguiente:

Ejemplo #1 Manejar tiempos de espera con feof()

<?php
function feof_segura($fp, &$inicio = NULL) {
 $inicio = microtime(true);

 return feof($fp);
}

/* Asumir que $fp está previamente abierto por fsockopen() */

$inicio = NULL;
$timeout = ini_get('default_socket_timeout');

while(!feof_segura($fp, $inicio) && (microtime(true) - $inicio) < $timeout)
{
 /* Gestor */
}
?>

Advertencia

Si el puntero al archivo pasado a la función no es válido, se podría dar un bucle infinito, ya que feof() falla para devolver true.

Ejemplo #2 Ejemplo de feof() con un puntero a un archivo no válido

<?php
// si el archivo no se puede leer o no existe, la función fopen devuelve FALSE
$archivo = @fopen("ningún_archivo", "r");

// FALSE desde fopen emitirá una advertencia y resultará en un bucle infinito aquí
while (!feof($archivo)) {
}

fclose($archivo);
?>


Vuelca la salida a un archivo

  • « feof
  • fgetc »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Vuelca la salida a un archivo

fflush

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

fflush — Vuelca la salida a un archivo

Descripción

fflush ( resource $handle ) : bool

Esta función fuerza una escritura de todas las salidas del buffer a un recurso apuntado por el archivo handle.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de escritura de un archivo usando fflush()

<?php
$nombre_archivo = 'bar.txt';

$archivo = fopen($nombre_archivo, 'r+');
rewind($archivo);
fwrite($archivo, 'Foo');
fflush($archivo);
ftruncate($archivo, ftell($archivo));
fclose($archivo);
?>

Ver también

  • clearstatcache() - Limpia la caché de estado de un archivo
  • fwrite() - Escritura de un archivo en modo binario seguro


Obtiene un carácter de un puntero a un archivo

  • « fflush
  • fgetcsv »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene un carácter de un puntero a un archivo

fgetc

(PHP 4, PHP 5, PHP 7, PHP 8)

fgetc — Obtiene un carácter de un puntero a un archivo

Descripción

fgetc ( resource $handle ) : string

Obtiene un carácter desde un puntero a un archivo dado.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

Valores devueltos

Devuelve una cadena que contiene un sólo carácter leído desde el archivo apuntado por handle. Devuelve false sobre EOF.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Un ejemplo de fgetc()

<?php
$fp = fopen('archivo.txt', 'r');
if (!$fp) {
    echo 'No se pudo abrir archivo.txt';
}
while (false !== ($carácter = fgetc($fp))) {
    echo "$carácter\n";
}
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fopen() - Abre un fichero o un URL
  • popen() - Abre un proceso de un puntero a un fichero
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • fgets() - Obtiene una línea desde el puntero a un fichero


Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV

  • « fgetc
  • fgets »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV

fgetcsv

(PHP 4, PHP 5, PHP 7, PHP 8)

fgetcsv — Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV

Descripción

fgetcsv ( resource $handle , int $length = 0 , string $delimiter = "," , string $enclosure = '"' , string $escape = "\" ) : array

Similar a fgets() excepto que fgetcsv() analiza la línea que lee para buscar campos en formato CSV, devolviendo un array que contiene los campos leídos.

Parámetros

handle

Un puntero a un fichero abierto correctamente por fopen(), popen(), o fsockopen().

length

La longitud. Debe ser mayor que la línea más larga (en caracteres) encontrada en el fichero CSV (permitiendo caracteres fin de línea finales). Es opcional en PHP 5. Al omitir este parámetro (o estableciéndolo a 0 en PHP 5.1.0 y posterior), la longitud máxima de línea no está limitada, lo que es ligeramente más lento.

delimiter

El parámetro opcional delimiter establece el delimitador de campo (un sólo carácter).

enclosure

El parámetro opcional enclosure establece el carácter circundante de cada campo (un sólo carácter).

escape

El parámetro opcional escape establece el carácter de escape (un sólo carácter). Por defecto, es una barra invertida.

Valores devueltos

Devuelve un array indexado que contiene los campos leídos.

Nota:

Una línea en blanco en un fichero CSV será devuelta como un array que comprende un único campo null, por lo que no será tratada como un error.

Nota: Si sufre problemas con PHP no reconociendo los finales de línea cuando lee o crea ficheros en Macintosh, puede probar de activar la opción de configuración en tiempo de ejecución auto_detect_line_endings para intentar resolver el problema.

fgetcsv() devuelve null si se proporciona un handle no válido, o false en los demás errores, incluido el final de fichero.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el parámetro escape
5.1.0 | El parámetro length ahora es opcional. El valor predeterminado es 0, significando sin límite de longitud.
4.3.5 | fgetcsv() ahora es segura al trabajar con datos binarios

Ejemplos

Ejemplo #1 Leer e imprimir el contenido completo de un fichero CSV

<?php
$fila = 1;
if (($gestor = fopen("test.csv", "r")) !== FALSE) {
    while (($datos = fgetcsv($gestor, 1000, ",")) !== FALSE) {
        $numero = count($datos);
        echo "<p> $numero de campos en la línea $fila: <br /></p>\n";
        $fila++;
        for ($c=0; $c < $numero; $c++) {
            echo $datos[$c] . "<br />\n";
        }
    }
    fclose($gestor);
}
?>

Notas

Nota:

Esta función toma en cuenta los parámetros de configuraciones regionales. Si LANG es, p.ej., en_US.UTF-8, los ficheros codificados con un byte son leídos de forma errónea por esta función.

Ver también

  • str_getcsv() - Convierte un string con formato CSV a un array
  • explode() - Divide un string en varios string
  • file() - Transfiere un fichero completo a un array
  • pack() - Empaqueta información a una cadena binaria
  • fputcsv() - Dar formato CSV a una línea y escribirla en un puntero a un fichero


Obtiene una línea desde el puntero a un fichero

  • « fgetcsv
  • fgetss »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene una línea desde el puntero a un fichero

fgets

(PHP 4, PHP 5, PHP 7, PHP 8)

fgets — Obtiene una línea desde el puntero a un fichero

Descripción

fgets ( resource $handle , int $length = ? ) : string

Obtiene una línea desde el puntero al fichero.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

length

La lectura termina cuando se han leído length - 1 bytes, o una nueva línea (la cual está incluida en el valor de retorno), o un EOF (lo que suceda primero). Si no se especifica una longitud, se seguirá leyendo desde el flujo hasta que alcance el final de la línea.

Nota:

Hasta PHP 4.3.0, al omitirlo se asumía una longitud de línea de 1024. Si la mayoría de las lineas del fichero son todas mayores de 8KB, es más eficiente para el script en cuestión de recursos especificar la longitud máxima de línea.

Valores devueltos

Devuelve una cadena de hasta length - 1 bytes leídos desde el fichero apuntado por handle. Si no hay más datos que leer en el puntero al fichero, devuelve false.

Si se produjo un error, devuelve false.

Ejemplos

Ejemplo #1 Leer un fichero línea a línea

<?php
$gestor = @fopen("/tmp/inputfile.txt", "r");
if ($gestor) {
    while (($búfer = fgets($gestor, 4096)) !== false) {
        echo $búfer;
    }
    if (!feof($gestor)) {
        echo "Error: fallo inesperado de fgets()\n";
    }
    fclose($gestor);
}
?>

Notas

Nota: Si sufre problemas con PHP no reconociendo los finales de línea cuando lee o crea ficheros en Macintosh, puede probar de activar la opción de configuración en tiempo de ejecución auto_detect_line_endings para intentar resolver el problema.

Nota:

Las personas que suele usar la semántica tipo 'C' de fgets() deberían observar la diferencia de cómo se devuelve EOF.

Ver también

  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fread() - Lectura de un fichero en modo binario seguro
  • fgetc() - Obtiene un carácter de un puntero a un archivo
  • stream_get_line() - Obtiene una línea del recurso de flujo hasta un delimitador dado
  • fopen() - Abre un fichero o un URL
  • popen() - Abre un proceso de un puntero a un fichero
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo


Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML

  • « fgets
  • file_exists »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML

fgetss

(PHP 4, PHP 5, PHP 7)

fgetss — Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.3.0. Su uso está totalmente desaconsejado.

Descripción

fgetss ( resource $handle , int $length = ? , string $allowable_tags = ? ) : string

Idéntica a fgets(), excepto que fgetss() intenta eliminar cualesquiera bytes NULL, etiquetas HTML y PHP del texto que lee.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

length

Longitud de la información que va a ser recuperada.

allowable_tags

Puede usar el tercer parámetro opcional para especificar las etiquetas que no deberían ser eliminadas. Consulte strip_tags() para obtener más información sobre allowable_tags.

Valores devueltos

Devuelve una cadena de hasta length - 1 bytes leídos desde el archivo apuntado por handle, con todo el código HTML y PHP eliminado.

Si se produjo un error devuelve false.

Ejemplo #1 Leer un archivo PHP línea a línea

<?php
$cadena = <<<EOD
<html><body>
 <p>¡Bienvenido! Hoy es el <?php echo(date('jS')); ?> de <?= date('F'); ?>.</p>
</body></html>
Texto fuera del bloque HTML.
EOD;
file_put_contents('ejemplo.php', $cadena);

$gestor = @fopen("ejemplo.php", "r");
if ($gestor) {
    while (!feof($gestor)) {
        $buffer = fgetss($gestor, 4096);
        echo $buffer;
    }
    fclose($gestor);
}
?>

El resultado del ejemplo sería algo similar a:

 ¡Bienvenido! Hoy es el  de .

Texto fuera del bloque HTML.

Notas

Nota: Si sufre problemas con PHP no reconociendo los finales de línea cuando lee o crea ficheros en Macintosh, puede probar de activar la opción de configuración en tiempo de ejecución auto_detect_line_endings para intentar resolver el problema.

Ver también

  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fopen() - Abre un fichero o un URL
  • popen() - Abre un proceso de un puntero a un fichero
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • strip_tags() - Retira las etiquetas HTML y PHP de un string


Comprueba si existe un fichero o directorio

  • « fgetss
  • file_get_contents »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Comprueba si existe un fichero o directorio

file_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

file_exists — Comprueba si existe un fichero o directorio

Descripción

file_exists ( string $filename ) : bool

Comprueba si existe un fichero o directorio.

Parámetros

filename

Ruta del fichero o directorio.

En windows, use //nombre_equipo/recurso/nombre_fichero o \\nombre_equipo\recurso\nombre_fichero para comprobar ficheros en redes compartidas.

Valores devueltos

Devuelve true si el fichero o directorio especificado por filename existe; false si no.

Nota:

Esta función devolverá false para punteros de enlaces simbólicos hacia ficheros no existentes.

Nota:

La comprobación se realiza usando el UID/GID real en vez del oportuno.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Ejemplos

Ejemplo #1 Comprobar si existe un fichero

<?php
$nombre_fichero = '/path/to/foo.txt';

if (file_exists($nombre_fichero)) {
    echo "El fichero $nombre_fichero existe";
} else {
    echo "El fichero $nombre_fichero no existe";
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_readable() - Indica si un fichero existe y es legible
  • is_writable() - Indica si un archivo existe y es escribible
  • is_file() - Indica si el nombre de fichero es un fichero normal
  • file() - Transfiere un fichero completo a un array
  • SplFileInfo


Transmite un fichero completo a una cadena

  • « file_exists
  • file_put_contents »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Transmite un fichero completo a una cadena

file_get_contents

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

file_get_contents — Transmite un fichero completo a una cadena

Descripción

file_get_contents ( string $filename , bool $use_include_path = false , resource $context = ? , int $offset = 0 , int $maxlen = ? ) : string

Esta función es similar a file(), excepto que file_get_contents() devuelve el fichero a un string, comenzando por el offset especificado hasta maxlen bytes. Si falla, file_get_contents() devolverá false.

file_get_contents() es la manera preferida de transmitir el contenido de un fichero a una cadena. Para mejorar el rendimiento, utiliza técnicas de mapeado de memoria si sistema operativo lo admite..

Nota:

Si se está abriendo un URI con caracteres especiales, tales como espacios, se necesita codificar el URI con urlencode().

Parámetros

filename

Nombre del fichero a leer.

use_include_path

Nota:

A partir de PHP 5, se puede usar la constante FILE_USE_INCLUDE_PATH para lanzar la búsqueda en include_path. Esto no es posible si está habilitada la tipificación esctricta, ya que FILE_USE_INCLUDE_PATH es de tipo int. Utilice true en su lugar.

context

Un recurso de contexto válido creado con stream_context_create(). Si no se necesita usar un contexto a medida, se puede saltar este parámetro usando null.

offset

El índice donde comienza la lectura en el flujo original. Los índices negativos inician la cuenta desde el final del flujo.

La búsqueda de (offset) no está soportada con ficheros remotos. Intentar buscar un fichero no local puede funcionar con índices pequeños, pero es impredecible debido a que trabaja sobre el flujo almacenado en buffer.

maxlen

La longitud máxima de los datos leídos. De manera predeterminada se lee hasta que se alcance el final del fichero. Observe que este parámetro se aplica al flujo procesado por los filtros.

Valores devueltos

Esta función devuelve los datos leídos o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Errores/Excepciones

Se genera un error de nivel E_WARNING si filename no se pudo encontrar, maxlength es menor de cero, o si falla la búsqueda del offset especificado en el flujo.

Ejemplos

Ejemplo #1 Obtiene y muestra el código fuente de la página de inicio de un sitio web

<?php
$página_inicio = file_get_contents('http://www.example.com/');
echo $página_inicio;
?>

Ejemplo #2 Buscar dentro de include_path

<?php
// <= PHP 5
$fichero = file_get_contents('./gente.txt', true);
// > PHP 5
$fichero = file_get_contents('./gente.txt', FILE_USE_INCLUDE_PATH);
?>

Ejemplo #3 Leer una sección de un fichero

<?php
// Leer 14 caracteres comenzando desde el carácter número 21
$sección = file_get_contents('./people.txt', FALSE, NULL, 20, 14);
var_dump($sección);
?>

El resultado del ejemplo sería algo similar a:

string(14) "lle Bjori Ro"

Ejemplo #4 Usar contextos de flujo

<?php
// Crear un flujo
$opciones = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$contexto = stream_context_create($opciones);

// Abre el fichero usando las cabeceras HTTP establecidas arriba
$fichero = file_get_contents('http://www.example.com/', false, $contexto);
?>

Historial de cambios

Versión | Descripción
7.1.0 | Se añadió soporte para valores negativos de offset.
5.1.0 | Se añadieron los parámetros offset y maxlen.

Notas

Nota: Esta función es segura binariamente.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Advertencia

Cuando se usa SSL, Microsoft IIS violará el protocolo, cerrando la conexión sin mandar un indicador close_notify. PHP avisará de esto con este mensaje "SSL: Fatal Protocol Error", cuando llegue al final de los datos. Una solución a este problema es bajar el nivel de aviso de errores del sistema para que no incluya advertencias. PHP pueden detectar servidores IIS con este problema cuando se abre un flujo usando https:// y suprime la advertencia. Si usáis la función fsockopen() para crear un socket ssl://, tendréis que suprimir la advertencia explicitamente.

Ver también

  • file() - Transfiere un fichero completo a un array
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fread() - Lectura de un fichero en modo binario seguro
  • readfile() - Realizar la salida de un fichero
  • file_put_contents() - Escribir datos en un fichero
  • stream_get_contents() - Transfiere el resto de un flujo a una cadena
  • stream_context_create() - Crear un contexto de flujo
  • $http_response_header


Escribir datos en un fichero

  • « file_get_contents
  • file »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Escribir datos en un fichero

file_put_contents

(PHP 5, PHP 7, PHP 8)

file_put_contents — Escribir datos en un fichero

Descripción

file_put_contents ( string $filename , mixed $data , int $flags = 0 , resource $context = ? ) : int

Esta función es idéntica que llamar a fopen(), fwrite() y fclose() sucesivamente para escribir información en un fichero.

Si filename no existe, se crea el fichero. De otro modo, el fichero existente se sobrescribe, a menos que la bandera FILE_APPEND esté establecida.

Parámetros

filename

Ruta del fichero donde se escribe la información

data

La información a escribir. Puede ser tanto un recurso string, como array o stream.

Si data es un recurso stream, el buffer restante de ese flujo será copiado al fichero especificado. Esto es similar a usar stream_copy_to_stream().

También se puede especificar el parámetro data como un array de una sóla dimensión. Esto es equivalente a file_put_contents($nombre_fichero, implode('', $array)).

flags

El valor de flags puede ser cualquier combinación de las siguientes banderas, unidas con el operador binario OR (|).

Banderas disponibles
Bandera | Descripción
FILE_USE_INCLUDE_PATH | Buscar filename en el directorio incluido. Véase include_path para más información.
FILE_APPEND | Si el fichero filename ya existe, añade la información al fichero en vez de sobrescribirlo.
LOCK_EX | Adquirir acceso exclusivo al fichero mientras se está ejecutando la escritura. En otras palabras, ocurre una llamada a flock() entre la llamada a fopen() y la llamada a fwrite(). Esto no es indéntico a una llamada a fopen() con el modo "x".

context

Un recurso de contexto válido creado con stream_context_create().

Valores devueltos

Esta función devuelve el número de bytes que fueron escritos en el fichero, o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplo sencillo de uso

<?php
$fichero = 'gente.txt';
// Abre el fichero para obtener el contenido existente
$actual = file_get_contents($fichero);
// Añade una nueva persona al fichero
$actual .= "John Smith\n";
// Escribe el contenido al fichero
file_put_contents($fichero, $actual);
?>

Ejemplo #2 Usar banderas

<?php
$fichero = 'gente.txt';
// La nueva persona a añdir al fichero
$persona = "John Smith\n";
// Escribir los contenidos en el fichero,
// usando la bandera FILE_APPEND para añadir el contenido al final del fichero
// y la bandera LOCK_EX para evitar que cualquiera escriba en el fichero al mismo tiempo
file_put_contents($fichero, $persona, FILE_APPEND | LOCK_EX);
?>

Historial de cambios

Versión | Descripción
5.1.0 | Añadido el soporte para LOCK_EX y la capacidad de pasar un recurso de flujo al parámetro data

Notas

Nota: Esta función es segura binariamente.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Ver también

  • fopen() - Abre un fichero o un URL
  • fwrite() - Escritura de un archivo en modo binario seguro
  • file_get_contents() - Transmite un fichero completo a una cadena
  • stream_context_create() - Crear un contexto de flujo


Transfiere un fichero completo a un array

  • « file_put_contents
  • fileatime »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Transfiere un fichero completo a un array

file

(PHP 4, PHP 5, PHP 7, PHP 8)

file — Transfiere un fichero completo a un array

Descripción

file ( string $filename , int $flags = 0 , resource $context = ? ) : array

Transfiere un fichero completo a un array.

Nota:

Se puede usar file_get_contents() para devolver el contenido de un fichero como una cadena.

Parámetros

filename

Ruta al fichero.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

flags

El parámetro opcional flags puede ser una o más de las siguientes constantes:

FILE_USE_INCLUDE_PATH
Buscar el fichero en include_path.
FILE_IGNORE_NEW_LINES
Omitir nueva línea al final de cada elemento del array
FILE_SKIP_EMPTY_LINES
Saltar las líneas vacías

context

Un recurso de contexto válido creado con la función stream_context_create().

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve el fichero a un array. Cada elemento del array se corresponde con una línea del fichero, con la nueva línea aún adjunta. En caso de fallo, file() devuelve false.

Nota:

Cada línea del array resultante incuirá el final de línea, a menos que se use FILE_IGNORE_NEW_LINES.

Nota: Si sufre problemas con PHP no reconociendo los finales de línea cuando lee o crea ficheros en Macintosh, puede probar de activar la opción de configuración en tiempo de ejecución auto_detect_line_endings para intentar resolver el problema.

Errores/Excepciones

Emite un error de nivel E_WARNING si el fichero no existe.

Ejemplos

Ejemplo #1 Ejemplo de file()

<?php
// Escribir un fichero en un array. En este ejemplo iremos a través de HTTP para
// obtener el código fuente HTML de un URL.
$líneas = file('http://www.example.com/');

// Recorrer nuestro array, mostrar el código fuente HTML como tal y mostrar tambíen los números de línea.
foreach ($líneas as $num_línea => $línea) {
    echo "Línea #<b>{$num_línea}</b> : " . htmlspecialchars($línea) . "<br />\n";
}

// Otro ejemplo: vamos a escribir una página web en una cadena. Véase también file_get_contents().
$html = implode('', file('http://www.example.com/'));

// Utilizar el parámetro opcional flags a partir de PHP 5
$recortes = file('fichero.txt', FILE_IGNORE_NEW_LINES | FILE_SKIP_EMPTY_LINES);
?>

Notas

Advertencia

Cuando se usa SSL, Microsoft IIS violará el protocolo, cerrando la conexión sin mandar un indicador close_notify. PHP avisará de esto con este mensaje "SSL: Fatal Protocol Error", cuando llegue al final de los datos. Una solución a este problema es bajar el nivel de aviso de errores del sistema para que no incluya advertencias. PHP pueden detectar servidores IIS con este problema cuando se abre un flujo usando https:// y suprime la advertencia. Si usáis la función fsockopen() para crear un socket ssl://, tendréis que suprimir la advertencia explicitamente.

Ver también

  • readfile() - Realizar la salida de un fichero
  • fopen() - Abre un fichero o un URL
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • popen() - Abre un proceso de un puntero a un fichero
  • file_get_contents() - Transmite un fichero completo a una cadena
  • include - include
  • stream_context_create() - Crear un contexto de flujo


Obtiene el momento del último acceso a un archivo

  • « file
  • filectime »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el momento del último acceso a un archivo

fileatime

(PHP 4, PHP 5, PHP 7, PHP 8)

fileatime — Obtiene el momento del último acceso a un archivo

Descripción

fileatime ( string $filename ) : int

Obtiene el momento del último acceso a un archivo dado.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el momento en el que se acceció al archivo por última vez, o false en caso de error. El momento es devuelto como tiempo Unix.

Ejemplos

Ejemplo #1 Ejemplo de fileatime()

<?php

// muestra, p.ej.  El último acceso a archivo.txt fue: December 29 2002 22:16:23.

$nombre_archivo = 'archivo.txt';
if (file_exists($nombre_archivo)) {
    echo "El último acceso a $nombre_archivo fue: " . date("F d Y H:i:s.", fileatime($nombre_archivo));
}

?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota:

El atime de un archivo se supone que cambia siempre que los bloques de información de un archivo están siendo leídos. Esto puede costar rendimiento a la larga cuando una aplicación accede regularmente a un número muy grande de archivos o directorios.

Algunos sistemas de archivos Unix se pueden montar con las actualizaciones de atime deshabitiladas para incrementar el rendimiento de tales aplicaciones; las colas de noticias de USENET son un ejemplo común. En tales sistemas de archivos esta función será inservible.

Nota:

Observe que el tiempo de resolución quizá varia según el sistema de ficheros.

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • filemtime() - Obtiene el momento de la última modificación de un archivo
  • fileinode() - Obtiene el i-nodo del archivo
  • date() - Dar formato a la fecha/hora local


Obtiene el momento del último cambio del i-nodo de un archivo

  • « fileatime
  • filegroup »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el momento del último cambio del i-nodo de un archivo

filectime

(PHP 4, PHP 5, PHP 7, PHP 8)

filectime — Obtiene el momento del último cambio del i-nodo de un archivo

Descripción

filectime ( string $filename ) : int

Obtiene el momento del último cambio del i-nodo de un archivo.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el momento en que se modificó un archivo por última vez, o false en caso de error. El momento es devuelto como tiempo Unix.

Ejemplos

Ejemplo #1 Un ejemplo de filectime()

<?php

// muestra, p.ej.  La última modificación de archivo.txt fue: December 29 2002 22:16:23.

$nombre_archivo = 'archivo.txt';
if (file_exists($nombre_archivo)) {
    echo "La última modificación de $nombre_archivo fue: " . date("F d Y H:i:s.", filectime($nombre_archivo));
}

?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota:

Anotación: En la mayoría de los sistemas de archivos Unix, un archivo se considera modificado cuando su información de i-nodo se cambia; es decir, cuando los permisos, propietario, grupo, u otra meta-información del i-nodo es acualizada. Véase también filemtime() (la cual es la que se querrá usar cuando se desee crear pies de página como "Última Modificación" en páginas web) y fileatime().

Nota:

Observe también que en algunos textos Unix el ctime de un archivo se refiere al momento de creación del archivo. Esto es erróneo. No hay momento de creación de archivos Unix en la mayoría de sistemas de archivos Unix.

Nota:

Observe que el tiempo de resolución quizá varia según el sistema de ficheros.

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • filemtime() - Obtiene el momento de la última modificación de un archivo


Obtiene el grupo de un archivo

  • « filectime
  • fileinode »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el grupo de un archivo

filegroup

(PHP 4, PHP 5, PHP 7, PHP 8)

filegroup — Obtiene el grupo de un archivo

Descripción

filegroup ( string $filename ) : int

Obtiene el grupo del archivo. El ID de grupo es devuelto en formato numérico, use posix_getgrgid() para resolverlo a un nombre de grupo.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el ID de grupo del archivo, o false en caso de que se produzca un error. El ID de grupo es devuelto en formato numérico, use posix_getgrgid() para resolverlo a un nombre de grupo. Si falla, se devuelve false

Ejemplos

Ejemplo #1 Encontrar el grupo de un archivo

<?php
$nombre_archivo = 'index.php';
print_r(posix_getgrgid(filegroup($nombre_archivo)));
?>

Errores/Excepciones

Si falla, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • fileowner() - Obtiene el propietario de un archivo
  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo


Obtiene el i-nodo del archivo

  • « filegroup
  • filemtime »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el i-nodo del archivo

fileinode

(PHP 4, PHP 5, PHP 7, PHP 8)

fileinode — Obtiene el i-nodo del archivo

Descripción

fileinode ( string $filename ) : int

Obtiene el i-nodo del archivo.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el número del i-nodo del archivo, o false en caso de error.

Ejemplos

Ejemplo #1 Comparar el i-nodo de un archivo con el archivo actual

<?php
$nombre_archivo = 'index.php';
if (getmyinode() == fileinode($nombre_archivo)) {
    echo 'Está comprobando el archivo actual.';
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • getmyinode() - Obtiene el inode del script actual
  • stat() - Da información acerca de un fichero


Obtiene el momento de la última modificación de un archivo

  • « fileinode
  • fileowner »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el momento de la última modificación de un archivo

filemtime

(PHP 4, PHP 5, PHP 7, PHP 8)

filemtime — Obtiene el momento de la última modificación de un archivo

Descripción

filemtime ( string $filename ) : int

Esta función devuelve el momento de cuándo los bloques de información de un archivo fueron escritos, es decir, el momento de cuándo el contenido del archivo se modificó.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el momento de cuándo el archivo se modificó por última vez, o false en caso de error. El momento es devuelto como tiempo Unix, lo cual es apropiado para la función date().

Ejemplos

Ejemplo #1 Ejemplo de filemtime()

<?php
// muestra, p.ej.  La última modificación de archivo.txt fue: December 29 2002 22:16:23.

$nombre_archivo = 'archivo.txt';
if (file_exists($nombre_archivo)) {
    echo "La última modificación de $nombre_archivo fue: " . date ("F d Y H:i:s.", filemtime($nombre_archivo));
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota:

Observe que el tiempo de resolución quizá varia según el sistema de ficheros.

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • filectime() - Obtiene el momento del último cambio del i-nodo de un archivo
  • stat() - Da información acerca de un fichero
  • touch() - Establece el momento de acceso y modificación de un archivo
  • getlastmod() - Obtiene la hora de la última modificación de la página


Obtiene el propietario de un archivo

  • « filemtime
  • fileperms »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el propietario de un archivo

fileowner

(PHP 4, PHP 5, PHP 7, PHP 8)

fileowner — Obtiene el propietario de un archivo

Descripción

fileowner ( string $filename ) : int

Obtiene el propietario del archivo.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve el ID de usuario del propietario del archivo, o false en caso de error. El ID de usuario es devuelto en formato numérico, use posix_getpwuid() para resolverlo a un nombre de usuario.

Ejemplos

Ejemplo #1 Encontrar el propietario de un archivo

<?php
$nombre_archivo = 'index.php';
print_r(posix_getpwuid(fileowner($nombre_archivo)));
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • filegroup() - Obtiene el grupo de un archivo
  • stat() - Da información acerca de un fichero
  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario


Obtiene los permisos de un fichero

  • « fileowner
  • filesize »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene los permisos de un fichero

fileperms

(PHP 4, PHP 5, PHP 7, PHP 8)

fileperms — Obtiene los permisos de un fichero

Descripción

fileperms ( string $filename ) : int

Obtiene los permisos de un fichero dado.

Parámetros

filename

Ruta del fichero.

Valores devueltos

Devuelve los permisos de un fichero como un modo numérico del mismo formato en el que se espera por chmod(), sin embargo en la mayoría de plataformas el valor de retorno también incluirá información sobre el tipo de fichero dado como filename. Los siguientes ejemplos muestran como poner a prueba el valor de retorno para los permisos específicos y tipos de ficheros en sistemas POSIX, incluyendo Linux y macOS.

Para los ficheros locales, el valor de retorno específico es el del miembro st_mode de la estructura devuelta por la función stat() de la biblioteca de C. Exactamente lo que los bits que están establecidos pueden variar de una plataforma a otra, y mirando la documentación de su plataforma específica se recomienda si el análisis de los bits sin permiso del valor de retorno es necesario.

Ejemplos

Ejemplo #1 Muestra los permisos como un valor octal

<?php
echo substr(sprintf('%o', fileperms('/tmp')), -4);
echo substr(sprintf('%o', fileperms('/etc/passwd')), -4);
?>

El resultado del ejemplo sería:

1777
0644

Ejemplo #2 Muestra los permisos completos

<?php
$permisos = fileperms('/etc/passwd');

switch ($perms & 0xF000) {
    case 0xC000: // Socket
        $info = 's';
        break;
    case 0xA000: // Enlace simbólico
        $info = 'l';
        break;
    case 0x8000: // Normal
        $info = 'r';
        break;
    case 0x6000: // Bloque especial
        $info = 'b';
        break;
    case 0x4000: // Directorio
        $info = 'd';
        break;
    case 0x2000: // Carácter especial
        $info = 'c';
        break;
    case 0x1000: // Tubería FIFO pipe
        $info = 'p';
        break;
    default: // Desconocido
        $info = 'u';
}

// Propietario
$info .= (($permisos & 0x0100) ? 'r' : '-');
$info .= (($permisos & 0x0080) ? 'w' : '-');
$info .= (($permisos & 0x0040) ?
            (($permisos & 0x0800) ? 's' : 'x' ) :
            (($permisos & 0x0800) ? 'S' : '-'));

// Grupo
$info .= (($permisos & 0x0020) ? 'r' : '-');
$info .= (($permisos & 0x0010) ? 'w' : '-');
$info .= (($permisos & 0x0008) ?
            (($permisos & 0x0400) ? 's' : 'x' ) :
            (($permisos & 0x0400) ? 'S' : '-'));

// Mundo
$info .= (($permisos & 0x0004) ? 'r' : '-');
$info .= (($permisos & 0x0002) ? 'w' : '-');
$info .= (($permisos & 0x0001) ?
            (($permisos & 0x0200) ? 't' : 'x' ) :
            (($permisos & 0x0200) ? 'T' : '-'));

echo $info;
?>

El resultado del ejemplo sería:

-rw-r--r--

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • chmod() - Cambia el modo de un fichero
  • is_readable() - Indica si un fichero existe y es legible
  • stat() - Da información acerca de un fichero


Obtiene el tamaño de un fichero

  • « fileperms
  • filetype »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el tamaño de un fichero

filesize

(PHP 4, PHP 5, PHP 7, PHP 8)

filesize — Obtiene el tamaño de un fichero

Descripción

filesize ( string $filename ) : int

Obtiene el tamaño del fichero dado.

Parámetros

filename

La ruta del fichero.

Valores devueltos

Devuelve el tamaño del fichero en bytes, o false (y genera un error de nivel E_WARNING) en caso de que se produzca un error.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Ejemplos

Ejemplo #1 Ejemplo de filesize()

<?php

// Muestra, p.ej., fichero.txt: 1024 bytes

$nombre_fichero = 'fichero.txt';
echo $nombre_fichero . ': ' . filesize($nombre_fichero) . ' bytes';

?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • file_exists() - Comprueba si existe un fichero o directorio


Obtiene el tipo de fichero

  • « filesize
  • flock »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el tipo de fichero

filetype

(PHP 4, PHP 5, PHP 7, PHP 8)

filetype — Obtiene el tipo de fichero

Descripción

filetype ( string $filename ) : string

Devuelve el tipo del fichero dado.

Parámetros

filename

La ruta del fichero.

Valores devueltos

Devuelve el tipo del fichero. Los valores posibles son fifo, char, dir, block, link, file, socket y unknown.

Devuelve false si se produjo un error. filetype() también producirá un mensaje E_NOTICE si la llamada a las estadísticas falla o si el tipo de fichero es desconocido.

Ejemplos

Ejemplo #1 Ejemplo de filetype()

<?php

echo filetype('/etc/passwd');  // file
echo filetype('/etc/');        // dir

?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • is_file() - Indica si el nombre de fichero es un fichero normal
  • is_link() - Indica si el nombre de archivo es un enlace simbólico
  • file_exists() - Comprueba si existe un fichero o directorio
  • mime_content_type() - Detecta el MIME Content-type para un fichero
  • pathinfo() - Devuelve información acerca de la ruta de un fichero
  • stat() - Da información acerca de un fichero


Bloqueo de ficheros recomendado y portable

  • « filetype
  • fnmatch »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Bloqueo de ficheros recomendado y portable

flock

(PHP 4, PHP 5, PHP 7, PHP 8)

flock — Bloqueo de ficheros recomendado y portable

Descripción

flock ( resource $handle , int $operation , int &$wouldblock = ? ) : bool

flock() permite representar un modelo sencillo de lectura/escritura que puede emplearse virtualmente en cada plataforma (incluidas la mayoría de las derivadas de Unix e incluso Windows).

En versiones de PHP anteriores a la 5.3.2, el bloqueo es liberado también por fclose() (la cual es también llamada automáticamente cuando finaliza el script).

PHP soporta de manera portable el bloqueo de ficheros completos de una forma recomendada (lo cual significa que todos los programas que accedan tiene que utilizar la misma forma de bloqueo o este no funcionará). Por defecto, esta función estará en espera hasta adquirir el bloqueo solicitado; esto se puede controlar con la opción LOCK_NB documentada abajo.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

operation

operation es una operación de las siguientes:

  • LOCK_SH para adquirir un bloqueo compartido (lectura).
  • LOCK_EX para adquirir un bloqueo exclusivo (escritura).
  • LOCK_UN para liberar un bloqueo (compartido o exclusivo).

También es posible añadir LOCK_NB como una máscara de bit a una de las operaciones de arriba si no se desea que flock() quede esperando mientras obtiene el bloqueo.

wouldblock

El tercer argumento opcional se establece a 1 si el bloqueo hará que la función quede esperando (condición de errno EWOULDBLOCK).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.22, 5.6.6 | Se añadió soporte para el parámetro wouldblock en Windows.
5.3.2 | Se eliminó la liberación del bloqueo automática al cerrarse el manejador del recurso. La liberación del bloqueo ahora siempre tiene que realizarse manualmente.

Ejemplos

Ejemplo #1 Ejemplo de flock()

<?php

$fp = fopen("/tmp/lock.txt", "r+");

if (flock($fp, LOCK_EX)) {  // adquirir un bloqueo exclusivo
    ftruncate($fp, 0);      // truncar el fichero
    fwrite($fp, "Escribir algo aquí\n");
    fflush($fp);            // volcar la salida antes de liberar el bloqueo
    flock($fp, LOCK_UN);    // libera el bloqueo
} else {
    echo "¡No se pudo obtener el bloqueo!";
}

fclose($fp);

?>

Ejemplo #2 flock() usando la opción LOCK_NB

<?php
$fp = fopen('/tmp/lock.txt', 'r+');

/* Activar la opción LOCK_NB sobre una operación LOCK_EX */
if(!flock($fp, LOCK_EX | LOCK_NB)) {
    echo 'No se puede obtener el bloqueo';
    exit(-1);
}

/* ... */

fclose($fp);
?>

Notas

Nota:

En Windows, flock() usa el bloqueo obligado en lugar del bloqueo recomendado. El bloqueo obligado también está soportado en sistemas operativos basados en Linux y System V mediante el mecanismo habitual soportado por la llamada al sistema fcntl(): esto es, si el fichero en cuestión tiene el bit de permiso setgid establecido y el bit de ejecución de grupo despejado. Para que esto funcione en Linux, el sistema de ficheros también debe ser montado con la opción mand.

Nota:

Ya que flock() requiere un puntero a un fichero, puede ser necesario usar un fichero de bloqueo especial para proteger el acceso al fichero que se quiere truncar, abriéndolo en modo escritura (con un argumento "w" o "w+" de fopen()).

Nota:

Sólo se puede usar en punteros de ficheros devueltos por fopen() para ficheros locales, o punteros de ficheros que apuenten a flujos de espacios de usuario que implementen el método streamWrapper::stream_lock().

Advertencia

Asignar otro valor al argumento handle en el código subsiguiente liberará el bloqueo.

Advertencia

En algunos sistemas operativos flock() está implementado a nivel de proceso. Cuando se usa una API de servidor multihilo como ISAPI, no se podrá confiar en flock() para proteger ficheros contra otros scripts de PHP que se ejecuten en hilos paralelos en la misma instancia del servidor.

flock() no está soportado en sistemas de ficheros anticuados como FAT y sus derivados y por lo tanto siempre devuelve false bajo estos entornos.


Compara un nombre de fichero con un patrón

  • « flock
  • fopen »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Compara un nombre de fichero con un patrón

fnmatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

fnmatch — Compara un nombre de fichero con un patrón

Descripción

fnmatch ( string $pattern , string $string , int $flags = 0 ) : bool

fnmatch() comprueba si el string pasado coincide con el comodín tipo shell pattern.

Parámetros

pattern

El patrón comodín tipo shell.

string

La cadena comprobada. Esta función es especialmente útil con nombres de fichero, pero también se puede usar con cadenas normales.

El usuario medio puede estar familiarizado con patrones tipo shell, o por lo menos con sus formas más sencillas de los comodines '?' y '*' por lo que usar fnmatch() en vez de preg_match() para el proceso de entrada de expresiones de búsqueda puede ser una forma más convenienete para ususarios no programadores.

flags

El valor de flags puede ser una combinación de las siguientes banderas, unidas por el operador binario OR (|).

Un lista de las posibles banderas para fnmatch()
Flag | Descripción
FNM_NOESCAPE | Deshabilita el escape de la barra invertida.
FNM_PATHNAME | Una barra en la cadena sólo coincide con otra en el patrón dado.
FNM_PERIOD | Un punto en la cadena debe coincidir exactamente con otro en el patrón dado.
FNM_CASEFOLD | Comparación sensible a mayúsculas-minúsculas. Parte de la extensión GNU.

Valores devueltos

Devuelve true si hay coincidencia, false si no.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Ejemplos

Ejemplo #1 Comprobar un adjetivo con un patrón comodín tipo shell

<?php
if (fnmatch("*o[bs]curo", $cadena)) {
  echo "alguna forma de oscuro ...";
}
?>

Notas

Advertencia

Por ahora esta función no está disponible en sistemas que no admiten POSIX excepto Windows.

Ver también

  • glob() - Buscar coincidencias de nombres de ruta con un patrón
  • preg_match() - Realiza una comparación con una expresión regular
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado


Abre un fichero o un URL

  • « fnmatch
  • fpassthru »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Abre un fichero o un URL

fopen

(PHP 4, PHP 5, PHP 7, PHP 8)

fopen — Abre un fichero o un URL

Descripción

fopen ( string $filename , string $mode , bool $use_include_path = false , resource $context = ? ) : resource

fopen() asocia un recurso con nombre, especificado por filename, a un flujo.

Parámetros

filename

Si filename está en la forma "esquema://...", se asume que será un URL y PHP buscará un gestor de protocolos (también conocido como envoltura) para ese protocolo. Si no está registrada ninguna envoltura para ese protocolo, PHP emitirá un aviso para ayudar a rastrear problemas potenciales en el script y continuará como si filename especificara un fichero normal.

Si PHP ha decidido que filename especifica un fichero local, intentará abrir un flujo para ese fichero. El fichero debe ser accesible para PHP, por lo que es necesario asegurarse de que los permisos de acceso del fichero permiten este acceso. Si está habilitado open_basedir se pueden aplicar más restricciones.

Si PHP ha decidido que filename especifica un protocolo registrado, y ese protocolo está registrado como un URL de red, PHP se asegurará de que allow_url_fopen está habilitado. Si es desactivado, PHP emitirá un aviso y la llamada a fopen fallará.

Nota:

La lista de protocolos soportados se puede encontrar en Protocolos y Envolturas soportados. Algunos protocolos (también descritos como envolturas) soportan contexto y/u opciones de php.ini. Consulte la página específica del protocolo en uso para una lista de opciones que se pueden establecer. (p.ej. el valor user_agent en php.ini usado por la envoltura http).

En la plataforma Windows, asegúrese de escapar cualquier barra invertida usada en la ruta de fichero, o use barras hacia delante.

<?php
$gestor = fopen("c:\\folder\\resource.txt", "r");
?>

mode

El parámetro mode especifica el tipo de acceso que se necesita para el flujo. Puede ser cualquiera de los siguientes:

Una lista de los modos posibles de fopen() usando mode
mode | Descripción
'r' | Apertura para sólo lectura; coloca el puntero al fichero al principio del fichero.
'r+' | Apertura para lectura y escritura; coloca el puntero al fichero al principio del fichero.
'w' | Apertura para sólo escritura; coloca el puntero al fichero al principio del fichero y trunca el fichero a longitud cero. Si el fichero no existe se intenta crear.
'w+' | Apertura para lectura y escritura; coloca el puntero al fichero al principio del fichero y trunca el fichero a longitud cero. Si el fichero no existe se intenta crear.
'a' | Apertura para sólo escritura; coloca el puntero del fichero al final del mismo. Si el fichero no existe, se intenta crear. En este modo, fseek() solamente afecta a la posición de lectura; las lecturas siempre son pospuestas.
'a+' | Apertura para lectura y escritura; coloca el puntero del fichero al final del mismo. Si el fichero no existe, se intenta crear. En este modo, fseek() no tiene efecto, las escrituras siempre son pospuestas.
'x' | Creación y apertura para sólo escritura; coloca el puntero del fichero al principio del mismo. Si el fichero ya existe, la llamada a fopen() fallará devolviendo false y generando un error de nivel E_WARNING. Si el fichero no existe se intenta crear. Esto es equivalente a especificar las banderas O_EXCL|O_CREAT para la llamada al sistema de open(2) subyacente.
'x+' | Creación y apertura para lectura y escritura; de otro modo tiene el mismo comportamiento que 'x'.
'c' | Abrir el fichero para sólo escritura. Si el fichero no existe, se crea. Si existe no es truncado (a diferencia de 'w'), ni la llamada a esta función falla (como en el caso con 'x'). El puntero al fichero se posiciona en el principio del fichero. Esto puede ser útil si se desea obtener un bloqueo asistido (véase flock()) antes de intentar modificar el fichero, ya que al usar 'w' se podría truncar el fichero antes de haber obtenido el bloqueo (si se desea truncar el fichero, se puede usar ftruncate() después de solicitar el bloqueo).
'c+' | Abrir el fichero para lectura y escritura; de otro modo tiene el mismo comportamiento que 'c'.
'e' | Establecer la bandera 'close-on-exec' en el descriptor de fichero abierto. Disponible solamente en PHP compilado en sistemas que se ajustan a POSIX.1-2008.

Nota:

Diferentes familias de sistemas operativos tienen diferentes convenciones para el final de línea. Cuando escribe un fichero de texto y quiere insertar un salto de línea, necesita usar el carácter o caracteres correctos de final de línea para su sistema operativo. Los sistemas basados en Unix usan \n como el carácter de final de línea, los sistemas basados en Windows usan \r\n como caracteres de final de línea y los sistemas basados en Macintosh usan \r como carácter de final de línea.

Si usa los caracteres de final de línea erróneos cuando escribe sus ficheros, se podrá encontrar con que otras aplicaciones que abran esos ficheros "parecerán raras".

Windows ofrece una bandera de traducción en modo texto ('t') que traducirá de manera transparente \n a \r\n cuando se trabaja con el fichero. En contraste, puede usar 'b' para forzar el modo binario, lo cual no traducirá su información. Para usar estas banderas, especifique 'b' o 't' como el último carácter del parámetro mode.

El modo de traducción predeterminado depende de la SAPI y de la versión de PHP que esté usando, por lo que se le anima a especificar siempre la bandera apropiada por razones de portabilidad. Debería usar el modo 't' si está trabajando con ficheros de texto plano y usa \n para delimitar los finales de línea es su script, pero confíe que sus ficheros serán legibles por aplicaciones tales como notepad. Debería usar 'b' en los demás casos.

Si no especifica la bandera 'b' cuando está trabajando con ficheros binarios, puede experimentar problemas extraños con su información, incluidos ficheros imagen rotos o problemas extraños con los caracteres \r\n.

Nota:

Por portabilidad, se recomienda encarecidamente que siempre use la bandera 'b' cuando se abran ficheros con fopen().

Nota:

De nuevo, por portabilidad, también se recomienda encarecidamente que reescriba el código que usa o depende del modo 't' por lo que use los finales de línea correctos y el modo 'b' en su lugar.

use_include_path

El tercer parámetro opcional use_include_path puede ser establecido a '1' o true si se desea buscar un fichero en include_path también.

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve un recurso de puntero a fichero si tiene éxito, o false si se produjo un error.

Errores/Excepciones

Si la apertura falla, se generea un error de nivel E_WARNING. Se puede usar @ para suprimir esta advertencia.

Historial de cambios

Versión | Descripción
7.0.16, 7.1.2 | Se añadió la opción 'e'.
5.2.6 | Se añadieron las opciones 'c' y 'c+'

Ejemplos

Ejemplo #1 Ejemplos de fopen()

<?php
$gestor = fopen("/home/rasmus/fichero.txt", "r");
$gestor = fopen("/home/rasmus/fichero.gif", "wb");
$gestor = fopen("http://www.example.com/", "r");
$gestor = fopen("ftp://user:password@example.com/fichero.txt", "w");
?>

Notas

Advertencia

Cuando se usa SSL, Microsoft IIS violará el protocolo, cerrando la conexión sin mandar un indicador close_notify. PHP avisará de esto con este mensaje "SSL: Fatal Protocol Error", cuando llegue al final de los datos. Una solución a este problema es bajar el nivel de aviso de errores del sistema para que no incluya advertencias. PHP pueden detectar servidores IIS con este problema cuando se abre un flujo usando https:// y suprime la advertencia. Si usáis la función fsockopen() para crear un socket ssl://, tendréis que suprimir la advertencia explicitamente.

Nota:

Si está experimentando problemas al leer y escribir ficheros y está usando la versión de módulo de servidor de PHP, asegúrese de que los ficheros y directorios que está usando sean accesibles por el proceso del servidor.

Nota:

Esta función también podría tener éxito cuando filename es un directorio. Si no se está seguro de que filename sea un fichero o un directorio, podría ser necesario utilzar la función is_dir() antes de llamar a fopen().

Ver también

  • Protocolos y Envolturas soportados
  • fclose() - Cierra un puntero a un archivo abierto
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fread() - Lectura de un fichero en modo binario seguro
  • fwrite() - Escritura de un archivo en modo binario seguro
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • file() - Transfiere un fichero completo a un array
  • file_exists() - Comprueba si existe un fichero o directorio
  • is_readable() - Indica si un fichero existe y es legible
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • popen() - Abre un proceso de un puntero a un fichero
  • stream_context_create() - Crear un contexto de flujo
  • umask() - Cambia la máscara de usuario actual
  • SplFileObject


Escribe toda la información restante de un puntero a un archivo

  • « fopen
  • fputcsv »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Escribe toda la información restante de un puntero a un archivo

fpassthru

(PHP 4, PHP 5, PHP 7, PHP 8)

fpassthru — Escribe toda la información restante de un puntero a un archivo

Descripción

fpassthru ( resource $handle ) : int

Lee hasta EOF en el puntero al archivo dado desde la posición actual y escribe los resultados en el buffer de salida.

Puede necesitar llamar a rewind() para reiniciar el puntero al archivo al principio del archivo si ya se ha escrito información en el archivo.

Si sólo quiere verter los contenidos de un archivo en el buffer de salida, sin modificarlo primero o buscar un índice en particular, puede usar la función readfile(), la cual le libera de llamar a fopen().

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

Valores devueltos

Si se produjo un error, fpassthru() devuelve false. De otro modo, fpassthru() devuelve el número de caracteres leídos desde handle y pasados hacia la salida.

Ejemplos

Ejemplo #1 Usar fpassthru() con archivos binarios

<?php

// abre el archivo en modo binario
$nombre = './img/ok.png';
$fp = fopen($nombre, 'rb');

// envía las cabeceras correctas
header("Content-Type: image/png");
header("Content-Length: " . filesize($nombre));

// vuelca la imagen y detiene el script
fpassthru($fp);
exit;

?>

Notas

Nota:

Cuando se usa fpassthru() sobre un archivo binario en sistemas Windows, debería asegurarse de abrir el archivo en modo binario añadiendo b al modo usado en la llamada a fopen().

Se le anima a usar la bandera b cuando trata con archivos binarios, incluso si su sistema no lo requiere, por lo que sus scripts serán más portables.

Ver también

  • readfile() - Realizar la salida de un fichero
  • fopen() - Abre un fichero o un URL
  • popen() - Abre un proceso de un puntero a un fichero
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix


Dar formato CSV a una línea y escribirla en un puntero a un fichero

  • « fpassthru
  • fputs »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Dar formato CSV a una línea y escribirla en un puntero a un fichero

fputcsv

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

fputcsv — Dar formato CSV a una línea y escribirla en un puntero a un fichero

Descripción

fputcsv ( resource $handle , array $fields , string $delimiter = "," , string $enclosure = '"' , string $escape_char = "\" ) : int

fputcsv() da formato CSV a una línea (pasada como el array fields) y la escribe (terminada con una nueva línea) en el manejador dado por handle del fichero especificado.

Parámetros

handle

El fichero al que se apunta debe ser válido, y debe apuntar a un fichero abierto por fopen() o fsockopen() (y que todavía no esté cerrado por fclose()).

fields

Un array de valores.

delimiter

El parámetro opcional delimiter establece el delimitador de campos (un carácter sólamente).

enclosure

El parámetro opcional enclosure establece el carácter circundante de cada campo (un carácter sólmente).

escape_char

El parámetro opcional escape_char establece el carácter de escape (un carácter solamente).

Valores devueltos

Devuelve la longitud del string escrito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.4 | Se añadió el parámetro escape_char

Ejemplos

Ejemplo #1 Ejemplo de fputcsv()

<?php

$lista = array (
    array('aaa', 'bbb', 'ccc', 'dddd'),
    array('123', '456', '789'),
    array('"aaa"', '"bbb"')
);

$fp = fopen('fichero.csv', 'w');

foreach ($lista as $campos) {
    fputcsv($fp, $campos);
}

fclose($fp);
?>

El ejemplo de arriba escribirá lo siguiente en fichero.csv:

aaa,bbb,ccc,dddd
123,456,789
"""aaa""","""bbb"""

Notas

Nota: Si sufre problemas con PHP no reconociendo los finales de línea cuando lee o crea ficheros en Macintosh, puede probar de activar la opción de configuración en tiempo de ejecución auto_detect_line_endings para intentar resolver el problema.

Ver también

  • fgetcsv() - Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV


Alias de fwrite

  • « fputcsv
  • fread »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Alias de fwrite

fputs

(PHP 4, PHP 5, PHP 7, PHP 8)

fputs — Alias de fwrite()

Descripción

Esta función es un alias de: fwrite().


Lectura de un fichero en modo binario seguro

  • « fputs
  • fscanf »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Lectura de un fichero en modo binario seguro

fread

(PHP 4, PHP 5, PHP 7, PHP 8)

fread — Lectura de un fichero en modo binario seguro

Descripción

fread ( resource $handle , int $length ) : string

fread() lee hasta length bytes desde el puntero al fichero referenciado por handle. La lectura termina tan pronto como se encuentre una de las siguientes condiciones:

  • length bytes han sido leídos
  • EOF (fin de fichero) es alcanzado
  • un paquete se encuentra disponible o el tiempo límite del socket se agota (para flujos de red)
  • si el flujo es leído en buffer y no representa un fichero plano, se realiza al menos una lectura de hasta un número de bytes igual al tamaño del trozo (normalmente 8192); dependiendo del la información previamente almacenada en buffer, el tamaño de la información devuelta puede ser mayor que el tamaño del trozo.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

length

Lectura de hasta length número de bytes.

Valores devueltos

Devuelve la cadena leída o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de fread()

<?php
// poner el contenido de un fichero en una cadena
$nombre_fichero = "/usr/local/algo.txt";
$gestor = fopen($nombre_fichero, "r");
$contenido = fread($gestor, filesize($nombre_fichero));
fclose($gestor);
?>

Ejemplo #2 Ejemplo de lectura binaria de fread()

Advertencia

En sistemas en los que se diferencia entre archivos binarios y de texto (esto es, Windows) el fichero debe ser abierto con 'b' incluida en el parámetro modo de fopen().

<?php
$filename = "c:\\files\\imagen.gif";
$gestor = fopen($filename, "rb");
$contenido = fread($gestor, filesize($filename));
fclose($gestor);
?>

Ejemplo #3 Ejemplos de lectura remota con fread()

Advertencia

Cuando se lee desde algo que no es un fichero local normal, como los flujos devueltos cuando se leen ficheros remotos o desde popen() y fsockopen(), la lectura se detendrá después de que esté disponible un paquete. Esto significa que debería reuinir la información en trozos como se muestra en los ejemplos de abajo.

<?php
// Para PHP 5 y superior
$gestor = fopen("http://www.example.com/", "rb");
$contenido = stream_get_contents($gestor);
fclose($gestor);
?>
<?php
$gestor = fopen("http://www.example.com/", "rb");
f (FALSE === $gestor) {
    exit("Falló la apertura del flujo al URL");
}

$contenido = '';
while (!feof($gestor)) {
    $contenido .= fread($gestor, 8192);
}
fclose($gestor);
?>

Notas

Nota:

Si sólo quiere poner el contenido de un fichero en una cadena, use file_get_contents() ya que tiene mucho mejor rendimiento que el código de arriba.

Nota:

Observe que fread() lee desde la posción actual del puntero al fichero. Use ftell() para encontrar la posición actual del puntero y rewind() para rebobinar la posición del puntero.

Ver también

  • fwrite() - Escritura de un archivo en modo binario seguro
  • fopen() - Abre un fichero o un URL
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • popen() - Abre un proceso de un puntero a un fichero
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • file() - Transfiere un fichero completo a un array
  • fpassthru() - Escribe toda la información restante de un puntero a un archivo
  • ftell() - Devuelve la posición de lectura/escritura actual del puntero a un fichero
  • rewind() - Rebobina la posición de un puntero a un archivo
  • unpack() - Desempaqueta datos de una cadena binaria


Analiza la entrada desde un archivo de acuerdo a un formato

  • « fread
  • fseek »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Analiza la entrada desde un archivo de acuerdo a un formato

fscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

fscanf — Analiza la entrada desde un archivo de acuerdo a un formato

Descripción

fscanf ( resource $handle , string $format , mixed &$... = ? ) : mixed

La función fscanf() es similar a sscanf(), excepto que toma su entrada desde un archivo asociado con handle e interpreta la entrada de acuerdo al parámetro format especificado, que es descrito en la documentación de sprintf().

Cualquier espacio en blanco en la cadena de formato coincide con cualquier espacio en blanco en el flujo de entrada. Esto significa que incluso una tabulación \t en la cadena de formato puede coincidir con un simple caráter espacio en el flujo de entrada.

Cada llamada a fscanf() lee una línea del archivo.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

format

El formato especificado como se describe en la documentación de sprintf().

...

Los valores opcionales asignados.

Valores devueltos

Si sólo se pasaron dos parámetros a esta función, los valores analizados serán devueltos como una matriz. De otro modo, si se pasaron los parámetros opcionales, la función devolverá el número de valores asignados. Los parámetros opcionales pueden ser pasados por referencia.

Ejemplos

Ejemplo #1 Ejemplo de fscanf()

<?php
$gestor = fopen("usuarios.txt", "r");
while ($userinfo = fscanf($gestor, "%s\t%s\t%s\n")) {
    list ($nombre, $profesión, $código_país) = $userinfo;
    //... hacer algo con los valores
}
fclose($gestor);
?>

Ejemplo #2 Contenido de usuarios.txt

javier  argonaut        pe
hiroshi sculptor        jp
robert  slacker us
luigi   florist it

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado


Busca sobre un puntero a un fichero

  • « fscanf
  • fstat »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Busca sobre un puntero a un fichero

fseek

(PHP 4, PHP 5, PHP 7, PHP 8)

fseek — Busca sobre un puntero a un fichero

Descripción

fseek ( resource $handle , int $offset , int $whence = SEEK_SET ) : int

Establece el indicador de posición de fichero para el fichero referenciado por handle. La nueva posición, medida en bytes desde el inicio del fichero, se obtiene añadiendo offset a la posición especificada por whence.

En general, se permite la búsqueda pasada la marca de fin de fichero; si entonces se escribe información, las lecturas en cualquier región no escrita entre la marca de fin del fichero y la posición buscada producirán bytes con valor 0. Sin embargo, ciertos flujos no pueden soportar este comportamiento, especialmente cuando tienen un tamaño de almacenamiento fijo subyacente.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

offset

El índice.

Para moverse a una posición anterior a la marca de fin del fichero, necesita pasar un valor negativo a offset y establecer whence a SEEK_END.

whence

Los valores de whence son:

  • SEEK_SET - Establece la posición igual a offset bytes.
  • SEEK_CUR - Establece la posición a la ubicación actual más offset.
  • SEEK_END - Establece la posición a la marca de final de fichero más offset.

Valores devueltos

Si tiene éxito, devuelve 0; de otro modo, devuelve -1.

Ejemplos

Ejemplo #1 Ejemplo de fseek()

<?php

$fp = fopen('fichero.txt', 'r');

// leer alguna información
$data = fgets($fp, 4096);

// volver al principio del fichero
// igual que rewind($fp);
fseek($fp, 0);

?>

Notas

Nota:

Si se ha abierto un fichero en modo de adición (a o a+), cualquier información que se escriba en el fichero será siempre añadida, sin importar la posición, y el resutado de llamar a fseek() será indefinido.

Nota:

No todos los flujos soportan búsqueda. Para esos que no soportan búsqueda, la búsqueda hacia adelante desde la posición actual se lleva a cabo leyendo y descartando información; otras formas de búsqueda fallarán.

Ver también

  • ftell() - Devuelve la posición de lectura/escritura actual del puntero a un fichero
  • rewind() - Rebobina la posición de un puntero a un archivo


Obtiene información acerca de un archivo usando un puntero al archivo abierto

  • « fseek
  • ftell »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene información acerca de un archivo usando un puntero al archivo abierto

fstat

(PHP 4, PHP 5, PHP 7, PHP 8)

fstat — Obtiene información acerca de un archivo usando un puntero al archivo abierto

Descripción

fstat ( resource $handle ) : array

Reúne las estadísticas de un archivo abierto por el puntero al archivo referenciado por handle. Esta función es similar a la función stat() excepto que opera sobre un puntero a un archivo en vez de sobre un nombre de archivo.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

Valores devueltos

Devuelve un matriz con las estadísticas del archivo; el formato de la matriz está descrito en la página del manual de stat().

Ejemplos

Ejemplo #1 Ejemplo de fstat()

<?php

// abrir un archivo
$fp = fopen("/etc/passwd", "r");

// reunir estadísticas
$fstat = fstat($fp);

// cerrar el archivo
fclose($fp);

// imprimir sólo la parte asociativa
print_r(array_slice($fstat, 13));

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.


Devuelve la posición de lectura/escritura actual del puntero a un fichero

  • « fstat
  • ftruncate »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve la posición de lectura/escritura actual del puntero a un fichero

ftell

(PHP 4, PHP 5, PHP 7, PHP 8)

ftell — Devuelve la posición de lectura/escritura actual del puntero a un fichero

Descripción

ftell ( resource $handle ) : int

Devuelve la posición del puntero al fichero referido por handle.

Parámetros

handle

El puntero al fichero debe ser válido, y debe apuntar a un fichero abierto con éxito por fopen() o popen(). ftell() da resultados indefinidos para flujos de sólo agregado (abiertos con la bandera "a").

Valores devueltos

Devuelve la posición del puntero al fichero referido por handle como un entero; esto es, su índice dentro del flujo de fichero.

Si se produjo un error, devuelve false.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Ejemplos

Ejemplo #1 Ejemplo de ftell()

<?php

// abre un fichero y leer algunos datos
$fp = fopen("/etc/passwd", "r");
$información = fgets($fp, 12);

// ¿dónde estamos?
echo ftell($fp); // 11

fclose($fp);

?>

Ver también

  • fopen() - Abre un fichero o un URL
  • popen() - Abre un proceso de un puntero a un fichero
  • fseek() - Busca sobre un puntero a un fichero
  • rewind() - Rebobina la posición de un puntero a un archivo


Trunca un archivo a una longitud dada

  • « ftell
  • fwrite »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Trunca un archivo a una longitud dada

ftruncate

(PHP 4, PHP 5, PHP 7, PHP 8)

ftruncate — Trunca un archivo a una longitud dada

Descripción

ftruncate ( resource $handle , int $size ) : bool

Toma el puntero al archivo, handle, y trunca el archivo a la longitud size.

Parámetros

handle

El puntero al archivo.

Nota:

handle tiene que ser abierto para escritura.

size

El tamaño a truncar.

Nota:

Si size es mayor que el del archivo, éste se extiende con bytes null.

Si size es menor que el del archivo, éste será truncado a ese tamaño.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de truncar un archivo

<?php
$nombre_archivo = 'lorem_ipsum.txt';

$gestor = fopen($nombre_archivo, 'r+');
ftruncate($gestor, rand(1, filesize($nombre_archivo)));
rewind($gestor);
echo fread($gestor, filesize($nombre_archivo));
fclose($gestor);
?>

Notas

Nota:

El puntero al archivo no es cambiado.

Ver también

  • fopen() - Abre un fichero o un URL
  • fseek() - Busca sobre un puntero a un fichero


Escritura de un archivo en modo binario seguro

  • « ftruncate
  • glob »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Escritura de un archivo en modo binario seguro

fwrite

(PHP 4, PHP 5, PHP 7, PHP 8)

fwrite — Escritura de un archivo en modo binario seguro

Descripción

fwrite ( resource $handle , string $string , int $length = ? ) : int

fwrite() escribe el contenido de string al flujo de archivo apuntado por handle.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

string

La cadena que va a ser escrita.

length

Si se da el argumento length, la escritura se detendrá después de que length bytes hayan sido escritos o se alcance el final de string, lo que suceda primero.

Observe que si el argumento length se da, la opción de configuración magic_quotes_runtime será ignorada y no se eliminarán las barras de string.

Valores devueltos

fwrite() devuelve el número de bytes escritos, o false si se produjo un error.

Notas

Nota:

Escribir en un flujo de red puede terminar antes de que se haya escrito la cadena completa. El valor devuelto por fwrite() se puede verificar:

<?php
function flujo_fwrite($fp, $cadena) {
    for ($escrito = 0; $escrito < strlen($cadena); $escrito += $fwrite) {
        $fwrite = fwrite($fp, substr($cadena, $escrito));
        if ($fwrite === false) {
            return $escrito;
        }
    }
    return $escrito;
}
?>

Nota:

En sistemas en los que se diferencia entre archivos binarios y de texto (esto es, Windows) el archivo debe ser abierto con 'b' incluida en el parámetro modo de fopen().

Nota:

Si handle fue abierto por fopen() en modo de adición, las escrituras de fwrite() son atómicas (a menos que el tamaño de string exceda el tamaño de bloque del sistema de archivos, en algunas plataformas, siempre que el archivo esté en un sistema de archivos local). Es decir, no hay necesidad de bloquear un recurso con flock() antes de llamar a fwrite(); toda la información será escrita sin interrupciones.

Nota:

Si se escribe dos veces sobre el puntero al archivo la información será añadida al final del contenido del archivo:

<?php
$fp = fopen('data.txt', 'w');
fwrite($fp, '1');
fwrite($fp, '23');
fclose($fp);

// ¡el contenido de 'data.txt' ahora es 123 y no 23!
?>

Ejemplos

Ejemplo #1 Un ejemplo sencillo de fwrite()

<?php
$nombre_archivo = 'prueba.txt';
$contenido = "Añade esto al archivo\n";

// Primero vamos a asegurarnos de que el archivo existe y es escribible.
if (is_writable($nombre_archivo)) {

    // En nuestro ejemplo estamos abriendo $nombre_archivo en modo de adición.
    // El puntero al archivo está al final del archivo
    // donde irá $contenido cuando usemos fwrite() sobre él.
    if (!$gestor = fopen($nombre_archivo, 'a')) {
         echo "No se puede abrir el archivo ($nombre_archivo)";
         exit;
    }

    // Escribir $contenido a nuestro archivo abierto.
    if (fwrite($gestor, $contenido) === FALSE) {
        echo "No se puede escribir en el archivo ($nombre_archivo)";
        exit;
    }

    echo "Éxito, se escribió ($contenido) en el archivo ($nombre_archivo)";

    fclose($gestor);

} else {
    echo "El archivo $nombre_archivo no es escribible";
}
?>

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fopen() - Abre un fichero o un URL
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • popen() - Abre un proceso de un puntero a un fichero
  • file_get_contents() - Transmite un fichero completo a una cadena
  • pack() - Empaqueta información a una cadena binaria


Buscar coincidencias de nombres de ruta con un patrón

  • « fwrite
  • is_dir »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Buscar coincidencias de nombres de ruta con un patrón

glob

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

glob — Buscar coincidencias de nombres de ruta con un patrón

Descripción

glob ( string $pattern , int $flags = 0 ) : array

La función glob() busca todos los nombres de ruta que coinciden con pattern según las reglas usadas por la función glob() de la biblioteca estándar de C, las cuales son similares a las reglas usadas por intérpretes de comandos comunes.

Parámetros

pattern

El patrón. No se realiza la expansión de tilde o la sustitución de parámetro.

flags

Banderas válidas:

  • GLOB_MARK - Añade un barra a cada directorio devuelto
  • GLOB_NOSORT - Devuelve los ficheros tal como aparecen en el directorio (sin ordenar). Cuando no se emple este indicador, los parámetros se ordenan alfabéticamente
  • GLOB_NOCHECK - Devuelve el patrón de búsqueda si no se encontraron ficheros coincidentes
  • GLOB_NOESCAPE - Las barras invertidas no escapan meta-caracteres
  • GLOB_BRACE - Expande {a,b,c} para coincidir con 'a', 'b', o 'c'
  • GLOB_ONLYDIR - Devuelve sólo entradas de directorio que coinciden con el patrón
  • GLOB_ERR - Se detiene si se produjeron errores de lectura (como directorios ilegibles), por defecto los errores son ignorados.

Valores devueltos

Devuelve una matriz que contiene los ficheros/directorios coincidentes, una matriz vacía si no hubo ficheros coincidentes o false si se produjo un error.

Nota:

En algunos sistemas es imposible distinguir entre una coincidencia vacía y un error.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió GLOB_ERR

Ejemplos

Ejemplo #1 Manera conveniente de cómo glob() puede remplazar a opendir() y similares.

<?php
foreach (glob("*.txt") as $nombre_fichero) {
    echo "Tamaño de $nombre_fichero " . filesize($nombre_fichero) . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Tamaño de funclist.txt 44686
Tamaño de funcsummary.txt 267625
Tamaño de quickref.txt 137820

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Nota: Está función no está disponible en algunos sistemas (p.ej. antiguos sistemas operativos de Sun).

Nota: La bandera GLOB_BRACE no está disponible en algunos sistemas que no son GNU, como Solaris.

Ver también

  • opendir() - Abre un gestor de directorio
  • readdir() - Lee una entrada desde un gestor de directorio
  • closedir() - Cierra un gestor de directorio
  • fnmatch() - Compara un nombre de fichero con un patrón


Indica si el nombre de archivo es un directorio

  • « glob
  • is_executable »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si el nombre de archivo es un directorio

is_dir

(PHP 4, PHP 5, PHP 7, PHP 8)

is_dir — Indica si el nombre de archivo es un directorio

Descripción

is_dir ( string $filename ) : bool

Indica si el nombre de archivo dado es un directorio.

Parámetros

filename

Ruta al archivo. Si filename es un nombre de archivo relativo, será verificado relativo al directorio de trabajo actual. Si filename es un enlace simbólico o duro, el enlace será resuelto y comprobado. Si tiene activado open_basedir se pueden aplicar más restricciones.

Valores devueltos

Devuelve true si el nombre de archivo existe y es un directorio, false si no.

Ejemplos

Ejemplo #1 Ejemplo de is_dir()

<?php
var_dump(is_dir('archivo.txt'));
var_dump(is_dir('directorio/abc'));

var_dump(is_dir('..')); //un directorio arriba
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(true)

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • chdir() - Cambia de directorio
  • dir() - Devuelve una instancia de la clase Directory
  • opendir() - Abre un gestor de directorio
  • is_file() - Indica si el nombre de fichero es un fichero normal
  • is_link() - Indica si el nombre de archivo es un enlace simbólico


Indica si el nombre de archivo es ejecutable

  • « is_dir
  • is_file »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si el nombre de archivo es ejecutable

is_executable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_executable — Indica si el nombre de archivo es ejecutable

Descripción

is_executable ( string $filename ) : bool

Indica si el nombre de archivo es ejecutable.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve true si el nombre de archivo existe y es ejecutable, o false si se produjo un error.

Ejemplos

Ejemplo #1 Ejemplo de is_executable()

<?php

$archivo = '/home/vincent/archivo.sh';

if (is_executable($archivo)) {
    echo $archivo.' es ejecutable';
} else {
    echo $archivo.' no es ejecutable';
}

?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_file() - Indica si el nombre de fichero es un fichero normal
  • is_link() - Indica si el nombre de archivo es un enlace simbólico


Indica si el nombre de fichero es un fichero normal

  • « is_executable
  • is_link »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si el nombre de fichero es un fichero normal

is_file

(PHP 4, PHP 5, PHP 7, PHP 8)

is_file — Indica si el nombre de fichero es un fichero normal

Descripción

is_file ( string $filename ) : bool

Indica si el fichero dado es un fichero normal.

Parámetros

filename

Ruta del fichero.

Valores devueltos

Devuelve true si el nombre de fichero existe y es un fichero normal, false si no.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Ejemplos

Ejemplo #1 Ejemplo de is_file()

<?php
var_dump(is_file('un_fichero.txt')) . "\n";
var_dump(is_file('/usr/bin/')) . "\n";
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • is_link() - Indica si el nombre de archivo es un enlace simbólico


Indica si el nombre de archivo es un enlace simbólico

  • « is_file
  • is_readable »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si el nombre de archivo es un enlace simbólico

is_link

(PHP 4, PHP 5, PHP 7, PHP 8)

is_link — Indica si el nombre de archivo es un enlace simbólico

Descripción

is_link ( string $filename ) : bool

Indica si el archivo dado es un enlace simbólico.

Parámetros

filename

Ruta del archivo.

Valores devueltos

Devuelve true si el nombre de archivo existe y es un enlace simbólico, false si no.

Ejemplos

Ejemplo #1 Crear y confirmar si un archivo es un enlace simbólico

<?php
$vínvulo = 'subidas';

if(is_link($vínvulo)) {
    echo(readlink($vínvulo));
} else {
    symlink('subidas.php', $vínvulo);
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • is_file() - Indica si el nombre de fichero es un fichero normal
  • readlink() - Devuelve el objetivo de un enlace simbólico


Indica si un fichero existe y es legible

  • « is_link
  • is_uploaded_file »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si un fichero existe y es legible

is_readable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_readable — Indica si un fichero existe y es legible

Descripción

is_readable ( string $filename ) : bool

Indica si un fichero existe y es legible.

Parámetros

filename

La ruta del fichero.

Valores devueltos

Devuelve true si el fichero o directorio especificado por filename existe y es legible, false si no.

Ejemplos

Ejemplo #1 Ejemplo de is_readable()

<?php
$nombre_fichero = 'prueba.txt';
if (is_readable($nombre_fichero)) {
    echo 'El fichero es legible';
} else {
    echo 'El fichero no es legible';
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Tenga en cuenta que PHP puede estar accediendo al fichero bajo el id de ususario por el que se está ejecutando el servidor web (a menudo 'nobody'). Las limitaciones del modo seguro no se toman en cuenta antes de PHP 5.1.5.

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Nota:

La comprobación se realiza usando el UID/GID real en vez del efectivo.

Esta función podría devolver true si se le proporcina un directorio. Use is_dir() para distinguir entre ficheros y directorios.

Ver también

  • is_writable() - Indica si un archivo existe y es escribible
  • file_exists() - Comprueba si existe un fichero o directorio
  • fgets() - Obtiene una línea desde el puntero a un fichero


Indica si el archivo fue subido mediante HTTP POST

  • « is_readable
  • is_writable »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si el archivo fue subido mediante HTTP POST

is_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

is_uploaded_file — Indica si el archivo fue subido mediante HTTP POST

Descripción

is_uploaded_file ( string $filename ) : bool

Devuelve true si el archivo nombrado por filename fue subido mediante HTTP POST. Esto es útil para intentar asegurarse de que un usuario malicioso no ha intentado engañar al script haciéndole trabajar con archivos con los que no debiera de estar trabajando--por ejemplo, /etc/passwd.

Este tipo de comprobación es especialmente importante si hay alguna posibilidad de que nada hecho con los archivos subidos pueda revelar su contenido al usuario, o incluso a otros usuarios en el mismo sistema.

Para un funcionamiento apropiado, la función is_uploaded_file() necesita un argumento como $_FILES['archivo_usuario']['tmp_name'], - el nombre del archivo subido de la máquina del cliente $_FILES['archivo_usuario']['name'] no funciona.

Parámetros

filename

El nombre de archivo que se va a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de is_uploaded_file()

<?php

if (is_uploaded_file($_FILES['archivo_usuario']['tmp_name'])) {
   echo "Archivo ". $_FILES['archivo_usuario']['name'] ." subido con éxtio.\n";
   echo "Monstrar contenido\n";
   readfile($_FILES['archivo_usuario']['tmp_name']);
} else {
   echo "Posible ataque del archivo subido: ";
   echo "nombre del archivo '". $_FILES['archivo_usuario']['tmp_name'] . "'.";
}

?>

Ver también

  • move_uploaded_file() - Mueve un archivo subido a una nueva ubicación
  • $_FILES
  • Véase Manejo de subidas de archivos para un sencillo ejemplo de uso.


Indica si un archivo existe y es escribible

  • « is_uploaded_file
  • is_writeable »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Indica si un archivo existe y es escribible

is_writable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_writable — Indica si un archivo existe y es escribible

Descripción

is_writable ( string $filename ) : bool

Devuelve true si filename existe y es escribible. El argumento nombre_archivo puede ser el nombre de un directorio, permitiendo así comprobar si el directorio es escribible.

Tenga en cuenta que PHP puede estar accediendo al archivo bajo el id de ususario por el que se está ejecutando el servidor web (a menudo 'nobody'). Las limitaciones del modo seguro no se toman en cuenta.

Parámetros

filename

El nombre de archivo que va a ser comprobado.

Valores devueltos

Devuelve true si el parámetro filename existe y es escribible.

Ejemplos

Ejemplo #1 Ejemplo de is_writable()

<?php
$nombre_archivo = 'prueba.txt';
if (is_writable($nombre_archivo)) {
    echo 'El archivo es escribible';
} else {
    echo 'El archivo no es escribible';
}
?>

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • is_readable() - Indica si un fichero existe y es legible
  • file_exists() - Comprueba si existe un fichero o directorio
  • fwrite() - Escritura de un archivo en modo binario seguro


Alias de is_writable

  • « is_writable
  • lchgrp »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Alias de is_writable

is_writeable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_writeable — Alias de is_writable()

Descripción

Esta función es un alias de: is_writable().


Cambia el grupo de un enlace simbólico

  • « is_writeable
  • lchown »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia el grupo de un enlace simbólico

lchgrp

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

lchgrp — Cambia el grupo de un enlace simbólico

Descripción

lchgrp ( string $filename , mixed $group ) : bool

Intenta cambiar el grupo del enlace simbólico filename a group.

Sólo el superusuario puede cambiar el grupo de un enlace simbólico; otros usuarios pueden cambiar el grupo de un enlace simbólico a cualquier grupo de cual ese usuario es miembro.

Parámetros

filename

Ruta del enlace simbólico.

group

El grupo especificado por un nombre o un número.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cambiar el grupo de un enlace simbólico

<?php
$objetivo = 'salida.php';
$enlace = 'salida.html';
symlink($objetivo, $enlace);

lchgrp($enlace, 8);
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Nota: Esta función no está implementada en plataformas Windows.

Ver también

  • chgrp() - Cambia el grupo del archivo
  • lchown() - Cambia el propietario de un enlace simbólico
  • chown() - Cambia el propietario del fichero
  • chmod() - Cambia el modo de un fichero


Cambia el propietario de un enlace simbólico

  • « lchgrp
  • link »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia el propietario de un enlace simbólico

lchown

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

lchown — Cambia el propietario de un enlace simbólico

Descripción

lchown ( string $filename , mixed $user ) : bool

Intenta cambiar el propietario del enlace simbólico filename al usuario user.

Sólo el superusuario puede cambiar el propietario de un enlace simbólico.

Parámetros

filename

Ruta al archivo.

user

Nómbre o número de usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cambiar el propietario de un enlace simbólico

<?php
$objetivo = 'salida.php';
$enlace = 'salida.html';
symlink($objetivo, $enlace);

lchown($enlace, 8);
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Nota: Esta función no está implementada en plataformas Windows.

Ver también

  • chown() - Cambia el propietario del fichero
  • lchgrp() - Cambia el grupo de un enlace simbólico
  • chgrp() - Cambia el grupo del archivo
  • chmod() - Cambia el modo de un fichero


Crea un enlace duro

  • « lchown
  • linkinfo »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Crea un enlace duro

link

(PHP 4, PHP 5, PHP 7, PHP 8)

link — Crea un enlace duro

Descripción

link ( string $target , string $link ) : bool

link() crea un enlace duro.

Parámetros

target

El objetivo del enlace.

link

El nombre del enlace.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o superiores).

Ejemplos

Ejemplo #1 Crear un simple enlace duro

<?php
$objetivo = 'origen.ext';  // Este es el archivo que ya existe
$enlace = 'nuevo_fichero.ext'; // Este es el nombre de fichero que quiere enlazar

link($objetivo, $enlace);
?>

Notas

Nota: Esta función no funcionará en ficheros remotos ya que el fichero debe ser accesible vía el sistema de ficheros del servidor para poder ser examinado.

Nota: Sólo para Windows: Esta función requiere que PHP se ejecute en un modo elevado o con el UAC deshabilitado.

Ver también

  • symlink() - Crea un enlace simbólico
  • readlink() - Devuelve el objetivo de un enlace simbólico
  • linkinfo() - Obtiene información acerca de un enlace


Obtiene información acerca de un enlace

  • « link
  • lstat »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene información acerca de un enlace

linkinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

linkinfo — Obtiene información acerca de un enlace

Descripción

linkinfo ( string $path ) : int

Obtiene información acerca de un enlace.

Esta función se usa para verificar si un enlace (apuntado por path) existe realmente (usando el mismo método que la macro S_ISLNK definida en stat.h).

Parámetros

path

Ruta del enlce.

Valores devueltos

linkinfo() devuelve el campo st_dev de la estructura de estadísticas de C en Unix devuelta por la llamada al sistema de lstat. Devuelve 0 o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o mayores).

Ejemplos

Ejemplo #1 Ejmeplo de linkinfo()

<?php

echo linkinfo('/vmlinuz'); // 835

?>

Ver también

  • symlink() - Crea un enlace simbólico
  • link() - Crea un enlace duro
  • readlink() - Devuelve el objetivo de un enlace simbólico


Da información acerca de un archivo o enlace simbólico

  • « linkinfo
  • mkdir »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Da información acerca de un archivo o enlace simbólico

lstat

(PHP 4, PHP 5, PHP 7, PHP 8)

lstat — Da información acerca de un archivo o enlace simbólico

Descripción

lstat ( string $filename ) : array

Reúne las estadísticas del archivo o enlace simbólico nombrado por filename.

Parámetros

filename

Ruta de un archivo o enlace simbólico.

Valores devueltos

Vea la página del manual de stat() para información sobre la estructura de la matriz que devuelve lstat(). Esta función es idéntica a la función stat() excepto que si el parámetro filename es un enlace simbólico, se devuelve el estado del enlace simbólico, no el estado del archivo apuntado por el enlace simbólico.

Ejemplos

Ejemplo #1 Comparación de stat() y lstat()

<?php
symlink('subidas.php', 'subidas');

// Contrastar la información de subidas.php y subidas
array_diff(stat('subidas'), lstat('subidas'));
?>

El resultado del ejemplo sería algo similar a:

Información de difiere entre los dos archivos.

Array
(
    [ino] => 97236376
    [mode] => 33188
    [size] => 34
    [atime] => 1223580003
    [mtime] => 1223581848
    [ctime] => 1223581848
    [blocks] => 8
)

Errores/Excepciones

En caso de fallo, se emite un E_WARNING.

Notas

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • stat() - Da información acerca de un fichero


Crea un directorio

  • « lstat
  • move_uploaded_file »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Crea un directorio

mkdir

(PHP 4, PHP 5, PHP 7, PHP 8)

mkdir — Crea un directorio

Descripción

mkdir ( string $pathname , int $mode = 0777 , bool $recursive = false , resource $context = ? ) : bool

Intenta crear el directorio especificado por pathname.

Parámetros

pathname

La ruta del directorio.

mode

El modo predeterminado es 0777, lo que significa el acceso más amplio posible. Para más información sobre los modos, lea los detalles en la página de chmod().

Nota:

mode es ignorado en Windows.

Observe que probablemente se quiera especificar el modo como un número octal, lo que significa que debería de haber un cero inicial. El modo es modificado también por la actual máscara de usuario, la cual se puede cambiar usando umask().

recursive

Permite la creación de directorios anidados especificado en el parámetro pathname.

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejmplo de mkdir()

<?php
mkdir("/ruta/a/mi/directorio", 0700);
?>

Ejemplo #2 mkdir() usando el parámetro recursive

<?php
// Estructura de la carpeta deseada
$estructura = './nivel1/nivel2/nivel3/';

// Para crear una estructura anidada se debe especificar
// el parámetro $recursive en mkdir().

if(!mkdir($estructura, 0777, true)) {
    die('Fallo al crear las carpetas...');
}

// ...
?>

Errores/Excepciones

Emite un error de nivel E_WARNING si el directorio ya existe.

Emite un error de nivel E_WARNING si los permisos relevantes impiden crear el directorio.

Notas

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • rmdir() - Elimina un directorio


Mueve un archivo subido a una nueva ubicación

  • « mkdir
  • parse_ini_file »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Mueve un archivo subido a una nueva ubicación

move_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

move_uploaded_file — Mueve un archivo subido a una nueva ubicación

Descripción

move_uploaded_file ( string $filename , string $destination ) : bool

Esta función intenta asegurarse de que el archivo designado por filename es un archivo subido válido (lo que significa que fue subido mediante el mecanismo de subida HTTP POST de PHP). Si el archivo es válido, será movido al nombre de archivo dado por destination.

El orden de comprobación es especialmente importante si hay cualquier posibilidad de que cualquier cosa hecha con los archivos subidos pueda revelar su contenido al usuario, o incluso a otros usuarios en el mismo sistema.

Parámetros

filename

El nombre de archivo del archivo subido.

destination

El destino del archivo movido.

Valores devueltos

Devuelve true en caso de éxito.

Si filename no es un archivo válido subido, no sucederá ninguna acción, y move_uploaded_file() devolverá false.

Si filename es un archivo subido válido, pero no puede ser movido por algunas razones, no sucederá ninguna acción, y move_uploaded_file() devolverá false. Adicionalmente, se emitirá un aviso.

Ejemplos

Ejemplo #1 Subida de múltiples archivos

<?php
$uploads_dir = '/uploads';
foreach ($_FILES["pictures"]["error"] as $key => $error) {
    if ($error == UPLOAD_ERR_OK) {
        $tmp_name = $_FILES["pictures"]["tmp_name"][$key];
        // basename() puede evitar ataques de denegación de sistema de ficheros;
        // podría ser apropiada más validación/saneamiento del nombre del fichero
        $name = basename($_FILES["pictures"]["name"][$key]);
        move_uploaded_file($tmp_name, "$uploads_dir/$name");
    }
}
?>

Notas

Nota:

move_uploaded_file() es compatible con open_basedir. Sin embargo, las restricciones sólo están impuestas para la ruta dest para permitir mover los archivos subidos en los cuales filename pueda tener conflictos con tales restricciones. move_uploaded_file() garantiza la seguridad de esta operación permitiendo que sólo aquellos archivos subidos a través de PHP sean movidos.

Advertencia

Si el archivo destino ya existe se sobrescribirá.

Ver también

  • is_uploaded_file() - Indica si el archivo fue subido mediante HTTP POST
  • rename() - Renombra un fichero o directorio
  • Véase Manejo de subidas de archivos para un sencillo ejemplo de uso


Analiza un fichero de configuración

  • « move_uploaded_file
  • parse_ini_string »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Analiza un fichero de configuración

parse_ini_file

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_ini_file — Analiza un fichero de configuración

Descripción

parse_ini_file ( string $filename , bool $process_sections = false , int $scanner_mode = INI_SCANNER_NORMAL ) : array

parse_ini_file() carga el fichero ini especificado en filename, y devuelve las configuraciones que hay en él a un array asociativa.

La estructura del ficher0 ini es la misma que la de php.ini.

Parámetros

filename

El nombre del fichero ini que va a ser analizado.

process_sections

Al establecer el parámetro process_sections a true, se obtiene un array multidimesional, con los nombres de las secciones y las configuraciones incluidas. El valor por defecto de process_sections es false

scanner_mode

Puede ser o INI_SCANNER_NORMAL (por defecto) o INI_SCANNER_RAW. Si INI_SCANNER_RAW es proporcionado, los valores de las opciones no serán analizadas.

A partir de PHP 5.6.1 también se puede especificar como INI_SCANNER_TYPED. En este modo, los tipos boolean, null e integer se preservan siempre que sea posible. Los valores de string "true", "on" y "yes" son convertidos a true. "false", "off", "no" y "none" se consideran como false. "null" se convierte a null en el modo tipificado. También, todos los string numéricos son convertidos al tipo integer fuera es posible.

Valores devueltos

Las configuraciones son devueltas como un array asociativo si se tiene éxito, y false si falla.

Ejemplos

Ejemplo #1 Contenido de ejemplo.ini

; Este es un ejemplo de fichero de configuración
; Los comentarios empiezan con ';', como en php.ini

[primera_sección]
uno = 1
cinco = 5
animal = PÁJARO

[segunda_sección]
ruta = "/usr/local/bin"
URL = "http://www.example.com/~username"

[tercera_sección]
phpversion[] = "5.0"
phpversion[] = "5.1"
phpversion[] = "5.2"
phpversion[] = "5.3"

urls[svn] = "http://svn.php.net"
urls[git] = "http://git.php.net"

Ejemplo #2 Ejemplo de parse_ini_file()

Las Constantes también se pueden analizar en el fichero ini, por lo que si se define una constante como un valor ini antes de ejecutar parse_ini_file(), también será integrada dentro de los resultados. Sólo los valores ini son evaluados. Por ejemplo:

<?php

define('PÁJARO', 'Pájaro dodo');

// Analizar sin secciones
$array_ini = parse_ini_file("ejemplo.ini");
print_r($array_ini);

// Analizar con secciones
$array_ini = parse_ini_file("ejemplo.ini", true);
print_r($array_ini);

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [uno] => 1
    [cinco] => 5
    [animal] => Pájaro dodo
    [ruta] => /usr/local/bin
    [URL] => http://www.example.com/~username
    [phpversion] => Array
        (
            [0] => 5.0
            [1] => 5.1
            [2] => 5.2
            [3] => 5.3
        )

    [urls] => Array
        (
            [svn] => http://svn.php.net
            [git] => http://git.php.net
        )

)
Array
(
    [primera_sección] => Array
        (
            [uno] => 1
            [cinco] => 5
            [animal] => Pájaro dodo
        )

    [segunda_sección] => Array
        (
            [ruta] => /usr/local/bin
            [URL] => http://www.example.com/~username
        )

    [tercera_sección] => Array
        (
            [phpversion] => Array
                (
                    [0] => 5.0
                    [1] => 5.1
                    [2] => 5.2
                    [3] => 5.3
                )

            [urls] => Array
                (
                    [svn] => http://svn.php.net
                    [git] => http://git.php.net
                )

        )

)

Ejemplo #3 parse_ini_file() analizando un fichero de php.ini

<?php
// Una sencilla función usada para comparar los resultados de abajo
function síno($expresión)
{
    return($expresión ? 'Sí' : 'No');
}

// Obtiene la ruta de php.ini usando la función
// php_ini_loaded_file() disponible a partir de PHP 5.2.4
$ruta_ini = php_ini_loaded_file();

// Analizar php.ini
$ini = parse_ini_file($ruta_ini);

// Imprime y compara los valores, observe que al usar get_cfg_var()
// se obtendrán aquí los mismos resultados de análisis y carga
echo '(analizado) magic_quotes_gpc = ' . síno($ini['magic_quotes_gpc']) . PHP_EOL;
echo '(cargado) magic_quotes_gpc = ' . síno(get_cfg_var('magic_quotes_gpc')) . PHP_EOL;
?>

El resultado del ejemplo sería algo similar a:

(parsed) magic_quotes_gpc = Yes
(loaded) magic_quotes_gpc = Yes

Notas

Nota:

Esta función no tiene nada que ver con el fichero php.ini. Éste es procesado en el momento en el que se ejecuta el script. Esta función se puede usar para leer los ficheros de configuración de sus propias aplicaciones.

Nota:

Si un valor en el fichero ini contiene cualquier carácter no alfanumérico, se necesita encerrarlo entre comillas dobles (").

Nota: Hay palabras reservadas que no se deben usar como claves en los ficheros ini. Éstas incluyen: null, yes, no, true, false, on, off, none. Los valores null, off, no y false resultan en "", y los valores on, yes and true resultan en "1", a menos que se utilice el modo INI_SCANNER_TYPED (a partir de PHP 5.6.1). Los caracteres ?{}|&~!()^" no se deben usar en ningún lugar de la clave y tienen un significado especial en el valor.

Nota:

Las entradas sin un signo igual son ignoradas. Por ejemplo, "foo" es ignorado, mientras que "bar =" se analiza y se añade con un valor vacío. Por ejemplo, MySQL tiene un ajuste de "no auto-rehash" en my.cnf que no toma ningún valor, siendo así ignorado.

Ver también

  • parse_ini_string() - Analiza una cadena de configuración


Analiza una cadena de configuración

  • « parse_ini_file
  • pathinfo »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Analiza una cadena de configuración

parse_ini_string

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

parse_ini_string — Analiza una cadena de configuración

Descripción

parse_ini_string ( string $ini , bool $process_sections = false , int $scanner_mode = INI_SCANNER_NORMAL ) : array

parse_ini_string() devuelve las configuraciones de la cadena ini a una matriz asociativa.

La estructura de la cadena ini es la misma que la de php.ini.

Parámetros

ini

El contenido del archivo ini que va a ser analizado.

process_sections

Al establecer el parámetro process_sections a true, se obtiene una matriz multidimesional, con los nombres de las secciones y las configuraciones incluidas. El valor por defecto de process_sections es false

scanner_mode

Puede ser o INI_SCANNER_NORMAL (por defecto) o INI_SCANNER_RAW. Si INI_SCANNER_RAW es proporcionado, los valores de las opciones no serán analizadas.

A partir de PHP 5.6.1 también se puede especificar como INI_SCANNER_TYPED. En este modo, los tipos boolean, null e integer se preservan siempre que sea posible. Los valores de string "true", "on" y "yes" son convertidos a true. "false", "off", "no" y "none" se consideran como false. "null" se convierte a null en el modo tipificado. También, todos los string numéricos son convertidos al tipo integer fuera es posible.

Valores devueltos

Las configuraciones son devueltas como un array asociativo si se tiene éxito, y false si falla.

Notas

Nota: Hay palabras reservadas que no se deben usar como claves en los ficheros ini. Éstas incluyen: null, yes, no, true, false, on, off, none. Los valores null, off, no y false resultan en "", y los valores on, yes and true resultan en "1", a menos que se utilice el modo INI_SCANNER_TYPED. Los caracteres ?{}|&~![()^" no se deben usar en ningún lugar de la clave y tienen un significado especial en el valor.

Ver también

  • parse_ini_file() - Analiza un fichero de configuración


Devuelve información acerca de la ruta de un fichero

  • « parse_ini_string
  • pclose »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve información acerca de la ruta de un fichero

pathinfo

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pathinfo — Devuelve información acerca de la ruta de un fichero

Descripción

pathinfo ( string $path , int $options = PATHINFO_DIRNAME | PATHINFO_BASENAME | PATHINFO_EXTENSION | PATHINFO_FILENAME ) : mixed

pathinfo() devuelve información acerca de path: bien como un array asociativo, o bien como un string, en función del valor de options.

Nota:

Para infomación sobre la recuperación de la información de la ruta actual, lea la sección sobre variables reservadas predefinidas.

Precaución

pathinfo() tiene en cuenta la configuración regional, por lo que, para analizar una ruta que contiene caracteres multibyte correctamente, se debe establecer la configuración regional correspondiente usando la función setlocale().

Parámetros

path

La ruta a analizar.

options

Si está presente, indica qué elementos específicos se devuelven, de entre PATHINFO_DIRNAME, PATHINFO_BASENAME, PATHINFO_EXTENSION y PATHINFO_FILENAME.

Si no se especifica options, se devuelven todos los elementos disponibles.

Valores devueltos

Si no se proporciona el parámetro options, se devuelve un array asociativo que contiene los siguientes elementos: dirname, basename, extension (si tiene), y filename.

Nota:

Si path tiene más de una extensión, PATHINFO_EXTENSION devuelve solamente la última, y PATHINFO_FILENAME solamente quita la última. (véase el primer ejemplo de más abajo).

Nota:

Si path no tiene ninguna extensión, no se devolverá ningún elemento extension (véase el segundo ejemplo de más abajo).

Nota:

Si basename de path comienza con un punto, los siguientes caracteres serán interpretados como extension, y filename estará vacío (véase el tercer ejemplo más adelante).

Si options estuviera presente, se devolverá un string que contiene el elemento solicitado.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió la constante PATHINFO_FILENAME.

Ejemplos

Ejemplo #1 Ejemplo de pathinfo()

<?php
$partes_ruta = pathinfo('/www/htdocs/inc/lib.inc.php');

echo $partes_ruta['dirname'], "\n";
echo $partes_ruta['basename'], "\n";
echo $partes_ruta['extension'], "\n";
echo $partes_ruta['filename'], "\n"; // desde PHP 5.2.0
?>

El resultado del ejemplo sería:

/www/htdocs/inc
lib.inc.php
php
lib.inc

Ejemplo #2 Ejemplo de pathinfo() mostrando las diferencias entre null y no utilizar extensión

<?php
$partes_ruta = pathinfo('/path/emptyextension.');
var_dump($partes_ruta['extension']);

$partes_ruta = pathinfo('/path/noextension');
var_dump($partes_ruta['extension']);
?>

El resultado del ejemplo sería algo similar a:

string(0) ""

Notice: Undefined index: extension in test.php on line 6

Ejemplo #3 Ejemplo de pathinfo() para un fichero que comienza con punto

<?php
print_r(pathinfo('/una/ruta/.test'));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [dirname] => /una/ruta
    [basename] => .test
    [extension] => test
    [filename] =>
)

Ver también

  • dirname() - Devuelve la ruta de un directorio padre
  • basename() - Devuelve el último componente de nombre de una ruta
  • parse_url() - Analiza un URL y devuelve sus componentes
  • realpath() - Devuelve el nombre de la ruta absoluta canonizado


Cierra un proceso de un puntero a un fichero

  • « pathinfo
  • popen »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cierra un proceso de un puntero a un fichero

pclose

(PHP 4, PHP 5, PHP 7, PHP 8)

pclose — Cierra un proceso de un puntero a un fichero

Descripción

pclose ( resource $handle ) : int

Cierra un puntero a un fichero hacia una tubería abierta por popen().

Parámetros

handle

El puntero al fichero debe ser válido, y debe haber sido devuelto por una llamada exitosa a popen().

Valores devueltos

Devuelve el estado de terminación del proceso que se estaba ejecutando. En caso de error, se devuelve -1.

Nota:

Si PHP se compiló con --enable-sigchild, el valor devuelto por esta función es indefinido.

Ejemplos

Ejemplo #1 Ejemplo de pclose()

<?php
$gestor = popen('/bin/ls', 'r');
pclose($gestor);
?>

Notas

Nota: Solamente Unix:

pclose() está internamente implementada usando la llamada al sistema de waitpid(3). Para obtener el código de estado de salida real debería usarse la función pcntl_wexitstatus().

Ver también

  • popen() - Abre un proceso de un puntero a un fichero


Abre un proceso de un puntero a un fichero

  • « pclose
  • readfile »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Abre un proceso de un puntero a un fichero

popen

(PHP 4, PHP 5, PHP 7, PHP 8)

popen — Abre un proceso de un puntero a un fichero

Descripción

popen ( string $command , string $mode ) : resource

Abre una tubería hacia un proceso ejecutado bifurcando el comando dado por command.

Parámetros

command

El comando

mode

El modo

Valores devueltos

Devuelve un puntero al fichero idéntico al devuelto por fopen(), excepto que es uni-direccional (sólo se puede usar para lectura o escritura) y debe ser cerrado con pclose(). Este puntero se puede usar con fgets(), fgetss(), y fwrite(). Cuando el modo es 'r', el puntero al fichero devuelto iguala al STDOUT del comando, cuando el modo es 'w', el puntero al fichero devuelto iguala al STDIN del comando.

Si se produjo un error, devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de popen()

<?php
$gestor = popen("/bin/ls", "r");
?>

Si el comando a ejecutar no puede ser encontrado, se devuelve un recurso válido. Esto puede parecer extraño, pero tiene sentido; permite el acceso a cualquier mensaje de error devuelto por el intérprete de comandos:

Ejemplo #2 Ejemplo de popen()

<?php
error_reporting(E_ALL);

/* Añade redirección, por lo que podemos obtener stderr. */
$gestor = popen('/ruta/al/ejecutable 2>&1', 'r');
echo "'$gestor'; " . gettype($gestor) . "\n";
$leer = fread($gestor, 2096);
echo $leer;
pclose($gestor);
?>

Notas

Nota:

Si está buscando un soporte bi-direccional (dos-vías), use proc_open().

Ver también

  • pclose() - Cierra un proceso de un puntero a un fichero
  • fopen() - Abre un fichero o un URL
  • proc_open() - Ejecuta un comando y abre un puntero de fichero para entrada/salida


Realizar la salida de un fichero

  • « popen
  • readlink »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Realizar la salida de un fichero

readfile

(PHP 4, PHP 5, PHP 7, PHP 8)

readfile — Realizar la salida de un fichero

Descripción

readfile ( string $filename , bool $use_include_path = false , resource $context = ? ) : int

Lee un fichero y lo escribe en el búfer de salida.

Parámetros

filename

El nombre del fichero a leer.

use_include_path

Se puede emplear el segundo parámetro opcional y establecerlo a true si se desea buscar también el fichero en include_path.

context

Un resource de flujos de contexto.

Valores devueltos

Devuelve el número de bytes leídos del fichero. Si se produjo un error, devuelve false y, a menos que la función fuese llamada como @readfile(), se imprime un mensaje de error.

Ejemplos

Ejemplo #1 Forzar un descarga empleando readfile()

<?php
$fichero = 'mono.gif';

if (file_exists($fichero)) {
    header('Content-Description: File Transfer');
    header('Content-Type: application/octet-stream');
    header('Content-Disposition: attachment; filename="'.basename($fichero).'"');
    header('Expires: 0');
    header('Cache-Control: must-revalidate');
    header('Pragma: public');
    header('Content-Length: ' . filesize($fichero));
    readfile($fichero);
    exit;
}
?>

El resultado del ejemplo sería algo similar a:

Diálogo de Abrir / Guardar

Notas

Nota:

readfile() no presentará problemas de memoria, incluso al enviar ficheros grandes, por sí sola. Si se encuentra un error de memoria insuficiente asegúrese que el búfer de salida está desactivado con ob_get_level().

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Ver también

  • fpassthru() - Escribe toda la información restante de un puntero a un archivo
  • file() - Transfiere un fichero completo a un array
  • fopen() - Abre un fichero o un URL
  • include - include
  • require - require
  • virtual() - Realiza una sub-petición de Apache
  • file_get_contents() - Transmite un fichero completo a una cadena
  • Protocolos y Envolturas soportados


Devuelve el objetivo de un enlace simbólico

  • « readfile
  • realpath_cache_get »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve el objetivo de un enlace simbólico

readlink

(PHP 4, PHP 5, PHP 7, PHP 8)

readlink — Devuelve el objetivo de un enlace simbólico

Descripción

readlink ( string $path ) : string

readlink() hace lo mismo que la función readlink de C.

Parámetros

path

La ruta del enlace simbólico.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o mayores).

Valores devueltos

Devuelve el contenido de la ruta del enlace simbólico o false si se produjo un error.

Ejemplos

Ejemplo #1 Ejemplo de readlink()

<?php

// imprime p.ej. /boot/vmlinux-2.4.20-xfs
echo readlink('/vmlinuz');

?>

Ver también

  • is_link() - Indica si el nombre de archivo es un enlace simbólico
  • symlink() - Crea un enlace simbólico
  • linkinfo() - Obtiene información acerca de un enlace


Obtiene las entradas de la caché de la ruta real

  • « readlink
  • realpath_cache_size »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene las entradas de la caché de la ruta real

realpath_cache_get

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

realpath_cache_get — Obtiene las entradas de la caché de la ruta real

Descripción

realpath_cache_get ( ) : array

Obtiene el contenido de la caché de la ruta real.

Valores devueltos

Devuelve una matriz de las entradas de la caché de la ruta real. Las claves son entradas de la ruta real original, y los valores son matrices de elementos de información, conteniendo la ruta resuelta, fecha de caducidad y otras opciones guardadas en la caché.

Ejemplos

Ejemplo #1 Ejemplo de realpath_cache_get()

<?php
var_dump(realpath_cache_get());
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["/test"]=>
  array(4) {
    ["key"]=>
    int(123456789)
    ["is_dir"]=>
    bool(true)
    ["realpath"]=>
    string(5) "/test"
    ["expires"]=>
    int(1260318939)
  }
  ["/test/test.php"]=>
  array(4) {
    ["key"]=>
    int(987654321)
    ["is_dir"]=>
    bool(false)
    ["realpath"]=>
    string(12) "/root/test.php"
    ["expires"]=>
    int(1260318939)
  }
}

Ver también

  • realpath_cache_size() - Obtiene el tamaño de la caché de la ruta real


Obtiene el tamaño de la caché de la ruta real

  • « realpath_cache_get
  • realpath »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Obtiene el tamaño de la caché de la ruta real

realpath_cache_size

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

realpath_cache_size — Obtiene el tamaño de la caché de la ruta real

Descripción

realpath_cache_size ( ) : int

Obtiene la cantidad de memoria usada por la caché de la ruta real.

Valores devueltos

Devuelve la cantidad de memoria que la caché de la ruta real está usando.

Ejemplos

Ejemplo #1 Ejemplo de realpath_cache_size()

<?php
var_dump(realpath_cache_size());
?>

El resultado del ejemplo sería algo similar a:

int(412)

Ver también

  • realpath_cache_get() - Obtiene las entradas de la caché de la ruta real
  • La opción de configuración realpath_cache_size


Devuelve el nombre de la ruta absoluta canonizado

  • « realpath_cache_size
  • rename »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Devuelve el nombre de la ruta absoluta canonizado

realpath

(PHP 4, PHP 5, PHP 7, PHP 8)

realpath — Devuelve el nombre de la ruta absoluta canonizado

Descripción

realpath ( string $path ) : string

realpath() expande todos los enlaces simbólicos y resuelve las referencias de caracteres '/./', '/../' y '/' extra, en la ruta de entrada dada por path y devuelve el nombre de la ruta absoluta canonizado.

Parámetros

path

La ruta que va a ser comprobada.

Nota:

Aunque se debe proporcionar una ruta, el valor puede estar en blanco o ser null. En estos casos, el valor es interpretado como el directorio actual.

Valores devueltos

Devuelve el nombre de la ruta absoluta canonizado en caso de éxito. La ruta resultante no tendrá componentes de enlaces simbólicos, '/./' o '/../'. Los delimitadores finales, como \ y /, también son eliminados.

realpath() devuelve false en caso de error, p.ej. si el fichero no existe.

Nota:

El script en ejecución debe tener permisios de ejecución en todos los directorios de la jerarquía, de lo contrario realpath() devolverá false.

Nota:

Para sistema de ficheros que no tengan en cuenta las mayúsculas/minúsculas, realpath() podría o no normalizar las mayúsculas/minúsculas de cada carácter.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Historial de cambios

Versión | Descripción
5.3.0 | Antes de esta versión, si en sistemas *BSD el último componente de path no existía, realpath() no fallaba. Ahora realpath() también falla en este caso.
5.2.1 | Antes de esta versión, realpath() devolvía false si path era un string vacío o null.

Ejemplos

Ejemplo #1 Ejemplo de realpath()

<?php
chdir('/var/www/');
echo realpath('./../../etc/passwd') . PHP_EOL;

echo realpath('/tmp/') . PHP_EOL;
?>

El resultado del ejemplo sería:

/etc/passwd
/tmp

Ejemplo #2 realpath() en Windows

En windows realpath() cambiará las rutas del estilo unix al estilo windows.

<?php
echo realpath('/windows/system32');

echo realpath('C:\Archivos de programa\\');
?>

El resultado del ejemplo sería:

C:\WINDOWS\System32
C:\Archivos de programa

Ver también

  • basename() - Devuelve el último componente de nombre de una ruta
  • dirname() - Devuelve la ruta de un directorio padre
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Renombra un fichero o directorio

  • « realpath
  • rewind »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Renombra un fichero o directorio

rename

(PHP 4, PHP 5, PHP 7, PHP 8)

rename — Renombra un fichero o directorio

Descripción

rename ( string $oldname , string $newname , resource $context = ? ) : bool

Intenta renombrar oldname a newname, moviéndolo a otro directorio si fuera necesario. Si newname existe, lo sobrescribirá.

Parámetros

oldname

Nota:

El nombre antiguo. La envoltura usada en oldname debe coincidir con la envoltura usada en newname.

newname

El nuevo nombre.

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.1 | rename() ahora puede renombrar ficheros a través de controladores de Windows.
5.0.0 | rename() ahora también puede emplearse con algunas envolturas de URL. Consulte Protocolos y Envolturas soportados para un listado de las envolturas que admite rename().
4.3.3 | rename() ahora es capaz de renombrar ficheros a través de particiones en sistemas basados en *nix, proporcinando los permisos apropiados. Se pueden generar advertencias si el sistema de ficheros destino no permite llamadas al sistema de chown() o chmod() hechas sobre ficheros; por ejemplo, si el sistema de ficheros destino en un sistema de ficheros FAT.

Ejemplos

Ejemplo #1 Ejemplo con rename()

<?php
rename("/tmp/fichero_tmp.txt", "/home/user/login/docs/mi_fichero.txt");
?>

Ver también

  • copy() - Copia un fichero
  • unlink() - Borra un fichero
  • move_uploaded_file() - Mueve un archivo subido a una nueva ubicación


Rebobina la posición de un puntero a un archivo

  • « rename
  • rmdir »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Rebobina la posición de un puntero a un archivo

rewind

(PHP 4, PHP 5, PHP 7, PHP 8)

rewind — Rebobina la posición de un puntero a un archivo

Descripción

rewind ( resource $handle ) : bool

Establece el indicador de posición de archivo de handle al principio del flujo del archivo.

Nota:

Si ha abierto un archivo en modo de adición ("a" o "a+"), cualquier información que escriba en el archivo será siempre añadida, sin importar la posición del puntero del archivo.

Parámetros

handle

El puntero al archivo debe ser válido, y debe apuntar al archivo abierto con éxito por fopen().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de sobrescritura con rewind()

<?php
$gestor = fopen('salida.txt', 'r+');

fwrite($gestor, 'Una sentencia realmente larga.');
rewind($gestor);
fwrite($gestor, 'Foo');
rewind($gestor);

echo fread($gestor, filesize('salida.txt'));

fclose($gestor);
?>

El resultado del ejemplo sería algo similar a:

Foo sentencia realmente larga.

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fseek() - Busca sobre un puntero a un fichero
  • ftell() - Devuelve la posición de lectura/escritura actual del puntero a un fichero
  • fwrite() - Escritura de un archivo en modo binario seguro


Elimina un directorio

  • « rewind
  • set_file_buffer »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Elimina un directorio

rmdir

(PHP 4, PHP 5, PHP 7, PHP 8)

rmdir — Elimina un directorio

Descripción

rmdir ( string $dirname , resource $context = ? ) : bool

Intenta eliminar el directorio nombrado por dirname. El directorio debe estar vacío, y los permisos relevantes deben permitirlo. Un error de nivel E_WARNING será generado si se produce un error.

Parámetros

dirname

Ruta del directorio

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de rmdir()

<?php
if (!is_dir('ejemplos')) {
    mkdir('ejemplos');
}

rmdir('ejemplos');
?>

Notas

Ver también

  • is_dir() - Indica si el nombre de archivo es un directorio
  • mkdir() - Crea un directorio
  • unlink() - Borra un fichero


Alias de stream_set_write_buffer

  • « rmdir
  • stat »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Alias de stream_set_write_buffer

set_file_buffer

(PHP 4, PHP 5, PHP 7, PHP 8)

set_file_buffer — Alias de stream_set_write_buffer()

Descripción

Esta función es un alias de: stream_set_write_buffer().


Da información acerca de un fichero

  • « set_file_buffer
  • symlink »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Da información acerca de un fichero

stat

(PHP 4, PHP 5, PHP 7, PHP 8)

stat — Da información acerca de un fichero

Descripción

stat ( string $filename ) : array

Reúne las estadísticas del fichero nombrado por filename. Si filename es un enlace simbólico, las estadísticas son las del fichero mismo, no las del enlace simbólico.

lstat() es idéntica a stat() excepto que está basada en el estado de los enlaces simbólicos.

Parámetros

filename

Ruta del fichero.

Valores devueltos

Formato del resultado de stat() y fstat()
Numérico | Asociativo | Descripción
0 | dev | número de dispositivo
1 | ino | número de i-nodo *
2 | mode | modo de protección del i-nodo
3 | nlink | número de enlaces
4 | uid | ID de usuario del propietario *
5 | gid | ID de grupo del propietario *
6 | rdev | tipo de dispositivo, si es un dispositivo i-nodo
7 | size | tamaño en bytes
8 | atime | momento del último acceso (tiempo Unix)
9 | mtime | momento de la última modificación (tiempo Unix)
10 | ctime | momento de la última modificación del i-nodo (tiempo Unix)
11 | blksize | tamaño del bloque E/S del sistema de ficheros **
12 | blocks | número de bloques de 512 bytes asignados **
* en Windows esto siempre será 0.

** Sólo válido para sistemas que soportan el tipo st_blksize type - otros sistemas (p.ej. Windows) devuelven -1.

En caso de que se produzca un error, stat() devuelve false.

Nota: Debido a que el tipo integer de PHP es con signo y muchas plataformas usan enteros de 32 bits, algunas funciones de sistema de ficheros pueden devolver resultados inesperados para ficheros que son mayores de 2 GB.

Errores/Excepciones

Si falla, se emite un E_WARNING.

Ejemplos

Ejemplo #1 Ejemplo de stat()

<?php
/* Obtener las estadísticas de un fichero */
$estadísticas = stat('C:\php\php.exe');

/*
 * Imprime el momento de acceso del fichero,
 * esto es lo mismo que llamar a fileatime()
 */
echo 'Momento de acceso: ' . $estadísticas['atime'];

/*
 * Imprime el momento de modificación del fichero,
 * esto es lo mismo que llamar a filemtime()
 */
echo 'Momento de modificación: ' . $estadísticas['mtime'];

/* Imprime el número de dispositivo */
echo 'Número de dispositivo: ' . $estadísticas['dev'];
?>

Ejemplo #2 Usar la información de stat() junto con touch()

<?php
/* Obtener las estadísticas del fichero */
$estadísticas = @stat('C:\php\php.exe');

/* ¿Falló al obtener la información de stat? */
if(!$estadísticas) {
    echo 'La llamada a stat() falló...';
} else {
    /*
     * Queremos que el tiempo de acceso sea 1 semana
     * después que el tiempo de acceso actual.
     */
    $atime = $estadísticas['atime'] + 604800;

    /* Afectar el fichero */
    if(!@touch('fichero.txt', time(), $atime)) {
        echo 'Falló al afectar el fichero...';
    } else {
        echo 'touch() devolvió con éxito...';
    }
}
?>

Notas

Nota:

Observe que el tiempo de resolución quizá varia según el sistema de ficheros.

Nota: Los resultados de esta función son guardados en caché. Para más información ver clearstatcache().

Sugerencia

Desde PHP 5.0.0, esta función también puede usarse con algunos URL wrappers. Consultar Protocolos y Envolturas soportados para deter4minar qué envolturas soportan la familia de funcionalidad de stat().

Ver también

  • lstat() - Da información acerca de un archivo o enlace simbólico
  • fstat() - Obtiene información acerca de un archivo usando un puntero al archivo abierto
  • filemtime() - Obtiene el momento de la última modificación de un archivo
  • filegroup() - Obtiene el grupo de un archivo


Crea un enlace simbólico

  • « stat
  • tempnam »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Crea un enlace simbólico

symlink

(PHP 4, PHP 5, PHP 7, PHP 8)

symlink — Crea un enlace simbólico

Descripción

symlink ( string $target , string $link ) : bool

symlink() crea un enlace simbólico al objetivo target existente con el nombre especificado en link.

Parámetros

target

Objetivo del enlace.

link

El nombre del enlace.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora es compatible con las plataformas Windows (Vista, Server 2008 o superior).

Ejemplos

Ejemplo #1 Crear un enlace simbólico

<?php
$objetivo = 'subidas.php';
$enlace = 'subidas';
symlink($objetivo, $enlace);

echo readlink($enlace);
?>

Notas

Nota: Los usuarios de Windows deberían observar que esta función sólo funcionará si el sistema donde se ejecuta PHP es Windows Vista/Windows Server 2008 o superior. Las versiones anteriores de Windows no admiten enlaces simbólicos.

Ver también

  • link() - Crea un enlace duro
  • readlink() - Devuelve el objetivo de un enlace simbólico
  • linkinfo() - Obtiene información acerca de un enlace


Crea un fichero con un nombre de fichero único

  • « symlink
  • tmpfile »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Crea un fichero con un nombre de fichero único

tempnam

(PHP 4, PHP 5, PHP 7, PHP 8)

tempnam — Crea un fichero con un nombre de fichero único

Descripción

tempnam ( string $dir , string $prefix ) : string

Crea un fichero con un nombre de fichero único, cuyo permiso de acceso está establecido a 0600, en el directorio especificado. Si el directorio no existe o no es escribible, tempnam() puede generar un fichero en el directorio temporal del sistema, y devolver la ruta completa de este fichero, incluyendo su nombre.

Parámetros

dir

El directorio donde el nombre de fichero temporal será creado.

prefix

El prefijo del nombre de fichero temporal generado.

Nota: Windows usa sólo los tres primeros caracteres del prefijo.

Valores devueltos

Devuelve el nuevo nombre del fichero temporal, o false si falla.

Ejemplos

Ejemplo #1 Ejemplo de tempnam()

<?php
$nombre_fichero_tmp = tempnam("/tmp", "FOO");

$gestor = fopen($nombre_fichero_tmp, "w");
fwrite($gestor, "escribiendo en el fichero temporal");
fclose($gestor);

// hacer aquí algo

unlink($nombre_fichero_tmp);
?>

Notas

Nota: Si PHP no puede crear un fichero en el parámetro directory especificado, retrocede al predeterminado del sistema. En NTFS esto también ocurre si el parámetro directory contiene más de 65534 ficheros.

Ver también

  • tmpfile() - Crea un archivo temporal
  • sys_get_temp_dir() - Devuelve la ruta del directorio para archivos temporales
  • unlink() - Borra un fichero


Crea un archivo temporal

  • « tempnam
  • touch »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Crea un archivo temporal

tmpfile

(PHP 4, PHP 5, PHP 7, PHP 8)

tmpfile — Crea un archivo temporal

Descripción

tmpfile ( ) : resource

Crea un archivo temporal con un nombre único en modo lectura-escritura (w+) y devuelve un gestor de archivo.

El archivo es automáticamente eliminado cuando se cierra (por ejemplo, llamando a fclose(), o cuando no quedan referencias al gestor de ficheros devuelto por tmpfile()), o cuando el script finaliza.

Para más detalles, consulte la documentación de su sistema acerca de la función tmpfile(3), así como de la cabecera de archivo stdio.h.

Valores devueltos

Devuelve un gestor de archivo, similar al devuleto por fopen(), para un archivo nuevo o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de tmpfile()

<?php
$temp = tmpfile();
fwrite($temp, "escribiendo en el archivo temporal");
fseek($temp, 0);
echo fread($temp, 1024);
fclose($temp); // esto elimina el archivo
?>

El resultado del ejemplo sería:

writing to tempfile

Ver también

  • tempnam() - Crea un fichero con un nombre de fichero único
  • sys_get_temp_dir() - Devuelve la ruta del directorio para archivos temporales


Establece el momento de acceso y modificación de un archivo

  • « tmpfile
  • umask »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Establece el momento de acceso y modificación de un archivo

touch

(PHP 4, PHP 5, PHP 7, PHP 8)

touch — Establece el momento de acceso y modificación de un archivo

Descripción

touch ( string $filename , int $time = time() , int $atime = ? ) : bool

Intenta establecer los momentos de acceso y modificación del archivo nombrado por el parámetro filename al valor dado en time. Observe que el momento de acceso se modifica siempre, sin importar el número de parámetros.

Si el archivo no existe, será creado.

Parámetros

filename

El nombre del archivo que va a ser afectado.

time

El momento de afectación. Si time no es proporcionado, se usa la hora actual del sistema.

atime

Si está presente, el momento de acceso del nombre de archivo dado se establece al valor de atime. De otro modo, se establece al valor pasado al parámetro time. Si ninguno está presente, se usa el momento actual del sistema.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se hizo posible cambiar el momento de modificación de un directorio bajo Windows.

Ejemplos

Ejemplo #1 Ejemplo de touch()

<?php
if (touch($nombre_archivo)) {
    echo 'El momento de modificación de ' . $nombre_archivo . ' ha sido cambiada a la hora actual';
} else {
    echo 'Lo siento, no se pudo cambiar el momento de modificación de ' . $nombre_archivo;
}
?>

Ejemplo #2 touch() usando el parámetro time

<?php
// Este es el momento afectado, lo estableceremos a una hora antes
$momento = time() - 3600;

// Afectar el archivo
if(!touch('archivo.txt', $momento)) {
    echo 'Lo sieno, algo fue mal...';
} else {
    echo 'Archivo afectado con éxito';
}
?>

Notas

Nota:

Observe que el tiempo de resolución quizá varia según el sistema de ficheros.

Advertencia

Antes de PHP 5.3.0 no era posible cambiar el momento de modificación de un directorio con esta función bajo Windows.


Cambia la máscara de usuario actual

  • « touch
  • unlink »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Cambia la máscara de usuario actual

umask

(PHP 4, PHP 5, PHP 7, PHP 8)

umask — Cambia la máscara de usuario actual

Descripción

umask ( int $mask = ? ) : int

umask() establece la máscara de usuario de PHP a mask & 0777 y devuelve la anterior máscara de usuario. Cuando PHP está siendo usado como un módulo de servidor, la máscara de usuario es reestablecida al finalizar cada petición.

Parámetros

mask

La nueva máscara de usuario.

Valores devueltos

umask() sin argumentos devuelve simplemente la máscara de usuario actual; de lo contrario devuelve la máscara de usuario anterior.

Ejemplos

Ejemplo #1 Ejemplo de umask()

<?php
$antigua = umask(0);
chmod("/ruta/directorio/fichero.txt", 0755);
umask($antigua);

// Verificar
if ($antigua != umask()) {
    die('Ocurrió un error mientras se volvía a cambiar la máscara de usuario');
}
?>

Notas

Nota:

Evite usar esta función en servidores web multihilo. Es mejor cambiar los permisos de fichero con chmod() después de crear el fichero. Usar umask() puede llevar a comportamientos inesperados en los scripts que se ejecutan concurrentemente y en el servidor web mismo, ya que pueden usar la misma máscara de usuario.


Borra un fichero

  • « umask
  • Inotify »
  • PHP Manual
  • Funciones del Sistema de Archivos
  • Borra un fichero

unlink

(PHP 4, PHP 5, PHP 7, PHP 8)

unlink — Borra un fichero

Descripción

unlink ( string $filename , resource $context = ? ) : bool

Elimina filename. Es similar a la función unlink() de C en Unix. Se generará un error de nivel E_WARNING si se produce un error.

Parámetros

filename

Ruta del fichero.

context

Nota: Soporte para context fue añadido en PHP 5.0.0. Para una descripción de contexts, refiérase a Flujos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso básico de unlink()

<?php
$fh = fopen('prueba.html', 'a');
fwrite($fh, '<h1>¡Hola mundo!</h1>');
fclose($fh);

unlink('prueba.html');
?>

Ver también

  • rmdir() - Elimina un directorio


Inotify

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación/Configuración
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones Inotify
    • inotify_add_watch — Añade un seguimiento a una instancia inotify inicializada
    • inotify_init — Inicializa una instancia inotify
    • inotify_queue_len — Devuelve un número superior a cero si hay eventos pendientes
    • inotify_read — Lee eventos de una instancia inotify
    • inotify_rm_watch — Elimina un seguimiento existente de una instancia inotify


Introducción

La extensión inotify expone las funciones inotify inotify_init(), inotify_add_watch() e inotify_rm_watch().

Así como la función inotify_init() de C devuelve un file descriptor, inotify_init() de PHP devuelve un recurso de flujo, que puede ser usado con las funciones de flujo estándar, como stream_select(), stream_set_blocking() y fclose(). inotify_read() sustituye la manera C de leer eventos inotify.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación/Configuración
  • Configuración en tiempo de ejecución
  • Tipos de recursos


  • « Instalación/Configuración
  • Instalación/Configuración »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta extensión requiere de Linux 2.6.13 o superior, y una librería libC reciente.


Instalación/Configuración

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/inotify.


  • « Instalación/Configuración
  • Tipos de recursos »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un recurso de flujo devuelto por inotify_init().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes Inotify utilizables con inotify_add_watch() y/o devueltos por inotify_read()
IN_ACCESS (integer)
El fichero fue accedido (lectura) (*)
IN_MODIFY (integer)
El fichero fue modificado (*)
IN_ATTRIB (integer)
Metadatos cambiados (por ejemplo: permisos, mtime, etc) (*)
IN_CLOSE_WRITE (integer)
El fichero, previamente abierto para escritura, fue cerrado (*)
IN_CLOSE_NOWRITE (integer)
El fichero, no abierto para escritura, fue cerrado (*)
IN_OPEN (integer)
El fichero fue abierto (*)
IN_MOVED_TO (integer)
Un fichero fue movido dentro del directorio observado (*)
IN_MOVED_FROM (integer)
Un fichero fue movido fuera del directorio observado (*)
IN_CREATE (integer)
Un fichero o directorio fue creado en el directorio observado (*)
IN_DELETE (integer)
Fichero o directorio borrado en el directorio observado (*)
IN_DELETE_SELF (integer)
El fichero o directorio observado fue borrado
IN_MOVE_SELF (integer)
El fichero o directorio observado fue movido
IN_CLOSE (integer)
Similar a IN_CLOSE_WRITE | IN_CLOSE_NOWRITE
IN_MOVE (integer)
Similar a IN_MOVED_FROM | IN_MOVED_TO
IN_ALL_EVENTS (integer)
Máscara de bits de todas las constantes anteriores
IN_UNMOUNT (integer)
Sistema de ficheros que contiene objetos observados fue desmontado
IN_Q_OVERFLOW (integer)
Cola de eventos desbordada (wd es -1 para este evento)
IN_IGNORED (integer)
Seguimiento borrado (explicitamente indicado por inotify_rm_watch() o debido a que el fichero fue eliminado o el sistema de ficheros desmontado)
IN_ISDIR (integer)
El sujeto del evento es un directorio
IN_ONLYDIR (integer)
Observar la ruta solamente si se trata de un directorio (A partir de Linux 2.6.15)
IN_DONT_FOLLOW (integer)
No eliminar la ruta de referencia si es un enlace simbólico (A partir de Linux 2.6.15).
IN_MASK_ADD (integer)
Agregar eventos para observar la máscara de esta ruta de acceso si ya existe (en lugar de reemplazar la máscara).
IN_ONESHOT (integer)
Monitorea una ruta para un evento, a continuación elimina de la lista de vigilancia.

Nota: Los eventos más arriba marcados con un asterisco (*) pueden producirse para ficheros en directorios observados.


Funciones Inotify

Tabla de contenidos

  • inotify_add_watch — Añade un seguimiento a una instancia inotify inicializada
  • inotify_init — Inicializa una instancia inotify
  • inotify_queue_len — Devuelve un número superior a cero si hay eventos pendientes
  • inotify_read — Lee eventos de una instancia inotify
  • inotify_rm_watch — Elimina un seguimiento existente de una instancia inotify


Añade un seguimiento a una instancia inotify inicializada

  • « Funciones Inotify
  • inotify_init »
  • PHP Manual
  • Funciones Inotify
  • Añade un seguimiento a una instancia inotify inicializada

inotify_add_watch

(PECL inotify >= 0.1.2)

inotify_add_watch — Añade un seguimiento a una instancia inotify inicializada

Descripción

inotify_add_watch ( resource $inotify_instance , string $pathname , int $mask ) : int

inotify_add_watch() añade un nuevo seguimiento o modifica un seguimiento existente para el fichero o directorio especificado en pathname.

Usando inotify_add_watch() sobre un objeto observado reemplaza el seguimiento existente. Utilizando la constante IN_MASK_ADD añade eventos al seguimiento existente.

Parámetros

inotify_instance

Recurso devuelto por inotify_init()

pathname

Fichero o directorio a observar

mask

Eventos para observar. Ver Constantes predefinidas.

Valores devueltos

The return value is a unique (inotify instance wide) watch descriptor. El valor devuelto es un descriptor de seguimiento único.

Ver también

  • inotify_init() - Inicializa una instancia inotify


Inicializa una instancia inotify

  • « inotify_add_watch
  • inotify_queue_len »
  • PHP Manual
  • Funciones Inotify
  • Inicializa una instancia inotify

inotify_init

(PECL inotify >= 0.1.2)

inotify_init — Inicializa una instancia inotify

Descripción

inotify_init ( ) : resource

Inicializar una instancia inotify para usar con inotify_add_watch()

Valores devueltos

Un recurso de secuencia o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de uso de inotify

<?php
// Abrir una instancia inotify
$fd = inotify_init();

// Observar __FILE__ por cambios en los metadatos (por ejemplo: mtime)
$watch_descriptor = inotify_add_watch($fd, __FILE__, IN_ATTRIB);

// genera un evento
touch(__FILE__);

// Leer eventos
$eventos = inotify_read($fd);
print_r($eventos);

// Los siguientes métodos permiten utilizar funciones inotify sin bloqueo en inotify_read():

// - Usando stream_select() en $fd:
$read = array($fd);
$write = null;
$except = null;
stream_select($read,$write,$except,0);

// - Usando stream_set_blocking() en $fd
stream_set_blocking($fd, 0);
inotify_read($fd); // No hace ningún bloqueo, y devuelve false si no hay eventos pendientes

// - Usando inotify_queue_len() para comprobar si la lista de eventos no está vacía
$queue_len = inotify_queue_len($fd); // Si > 0, inotify_read() no bloqueará

// Dejar de observar __FILE__ por cambios en los metadatos
inotify_rm_watch($fd, $watch_descriptor);

// Cierra la instancia inotify
// This may have closed all watches if this was not already done
// Esto puede haber cerrado todos los seguimientos, si no se hizo ya
fclose($fd);

?>

El resultado del ejemplo sería algo similar a:

array(
  array(
    'wd' => 1,     // Equivale a $ watch_descriptor
    'mask' => 4,   // bit IN_ATTRIB establecido
    'cookie' => 0, // id único para conectar los eventos relacionados (por ejemplo:
                   // eventos IN_MOVE_FROM IN_MOVE_TO)
    'name' => '',  // el nombre de un fichero (por ejemplo: si se monitorean los
                   // cambios en un directorio)
  ),
);

Ver también

  • inotify_add_watch() - Añade un seguimiento a una instancia inotify inicializada
  • inotify_rm_watch() - Elimina un seguimiento existente de una instancia inotify
  • inotify_queue_len() - Devuelve un número superior a cero si hay eventos pendientes
  • inotify_read() - Lee eventos de una instancia inotify
  • fclose() - Cierra un puntero a un archivo abierto


Devuelve un número superior a cero si hay eventos pendientes

  • « inotify_init
  • inotify_read »
  • PHP Manual
  • Funciones Inotify
  • Devuelve un número superior a cero si hay eventos pendientes

inotify_queue_len

(PECL inotify >= 0.1.2)

inotify_queue_len — Devuelve un número superior a cero si hay eventos pendientes

Descripción

inotify_queue_len ( resource $inotify_instance ) : int

Esta función permite saber si inotify_read() bloqueará o no. Si un número superior a cero es devuelto, hay eventos pendientes e inotify_read() no bloqueará.

Parámetros

inotify_instance

Recurso devuelto por inotify_init()

Valores devueltos

Devuelve un número superior a cero si hay eventos pendientes.

Ver también

  • inotify_init() - Inicializa una instancia inotify
  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo


Lee eventos de una instancia inotify

  • « inotify_queue_len
  • inotify_rm_watch »
  • PHP Manual
  • Funciones Inotify
  • Lee eventos de una instancia inotify

inotify_read

(PECL inotify >= 0.1.2)

inotify_read — Lee eventos de una instancia inotify

Descripción

inotify_read ( resource $inotify_instance ) : array

Leer eventos inotify de una instancia inotify.

Parámetros

inotify_instance

Recurso devuelto por inotify_init()

Valores devueltos

Un array de eventos inotify o false si no hay eventos pendientes e inotify_instance no es de bloqueo. Cada evento es un array con las siguientes claves:

  • wd es un descriptor de seguimiento devuelto por inotify_add_watch()
  • mask es una máscara de bits de eventos
  • cookie es un identificador único para conectar los eventos relacionados (por ejemplo: IN_MOVE_FROM e IN_MOVE_TO)
  • name es el nombre de un fichero (por ejemplo: si un fichero se ha modificado en un directorio observado)

Ver también

  • inotify_init() - Inicializa una instancia inotify
  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • inotify_queue_len() - Devuelve un número superior a cero si hay eventos pendientes


Elimina un seguimiento existente de una instancia inotify

  • « inotify_read
  • Proctitle »
  • PHP Manual
  • Funciones Inotify
  • Elimina un seguimiento existente de una instancia inotify

inotify_rm_watch

(PECL inotify >= 0.1.2)

inotify_rm_watch — Elimina un seguimiento existente de una instancia inotify

Descripción

inotify_rm_watch ( resource $inotify_instance , int $watch_descriptor ) : bool

inotify_rm_watch() elimina el seguimiento watch_descriptor de la instancia inotify inotify_instance.

Parámetros

inotify_instance

Recurso devuelto por inotify_init()

watch_descriptor

Seguimiento a eliminar de la instancia

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • inotify_init() - Inicializa una instancia inotify


Proctitle

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Proctitle Funciones
    • setproctitle — Establecer el título de proceso
    • setthreadtitle — Set the thread title


Introducción

Esta extensión permite cambiar los procesos actuales, e hilos, nombre en linux y sistemas *BSD. Esto es útil cuando se usa pcntl_fork() para identificar This extension allows changing the current process', and thread, name on Linux and *BSD systems. This is useful when using pcntl_fork() los procesos en ejercución en la lista de procesos.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Nada especial.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/proctitle.


  • « Tipos de recursos
  • Proctitle Funciones »
  • PHP Manual
  • Proctitle
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Proctitle Funciones

Tabla de contenidos

  • setproctitle — Establecer el título de proceso
  • setthreadtitle — Set the thread title


Establecer el título de proceso

  • « Proctitle Funciones
  • setthreadtitle »
  • PHP Manual
  • Proctitle Funciones
  • Establecer el título de proceso

setproctitle

(PECL proctitle >= 0.1.0)

setproctitle — Establecer el título de proceso

Descripción

setproctitle ( string $title ) : void

Establece el título de proceso del proceso actual.

Parámetros

title

El título que se utilizará como título de proceso.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de setproctitle()

Ejecutar el siguiente ejemplo va a cambiar el título de proceso (visible con ps a, por ejemplo).

<?php
setproctitle("myscript");
?>

El resultado del ejemplo sería algo similar a:

$ ps a
  PID TTY      STAT   TIME COMMAND
 1168 pts/3    S      0:00 myscript

Ver también

  • cli_set_process_title() - Sets the process title
  • pcntl_fork() - Forks the currently running process
  • setthreadtitle() - Set the thread title


Set the thread title

  • « setproctitle
  • xattr »
  • PHP Manual
  • Proctitle Funciones
  • Set the thread title

setthreadtitle

(PECL proctitle >= 0.1.2)

setthreadtitle — Set the thread title

Descripción

setthreadtitle ( string $title ) : bool

Establece el título del hilo.

Parámetros

title

El título que se utilizará como título del hilo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 setthreadtitle() ejemplo

Ejecutar el siguiente ejemplo va a cambiar el título del hilo (visible con ps c, por ejemplo).

<?php
setthreadtitle("myscript");
?>

El resultado del ejemplo sería algo similar a:

$ ps c
  PID TTY      STAT   TIME COMMAND
 1178 pts/3    S      0:00 myscript

Ver también

  • pcntl_fork() - Forks the currently running process
  • setproctitle() - Establecer el título de proceso


xattr

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de xattr
    • xattr_get — Obtener un atributo extendido
    • xattr_list — Obtener una lista de atributos extendidos
    • xattr_remove — Elimina un atributo extendido
    • xattr_set — Establece un atributo extendido
    • xattr_supported — Comprueba si soporta los atributos extendidos del sistema de archivos


Introducción

La extensión xattr permite la manipulación de los atributos extendidos de un sistema de archivos.


Requerimientos

Para utilizar xattr, se necesita tener libattr instalado. Este está disponible en » http://savannah.nongnu.org/projects/attr/.

Nota:

Estas funciones sólo funcionan en sistemas de archivos que soportan atributos extendidos, y haya activado durante la instalación. Algunos sistemas de ficheros comunes que soportan atributos extendidos son ext2, ext3, reiserfs, jfs, and xfs.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/xattr.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

XATTR_ROOT (integer)
Establece atributos en la raíz (segura) de espacio de nombres. Requiere privilegios de administrador.
XATTR_DONTFOLLOW (integer)
No sigue el enlace simbólico pero se puede operar en este.
XATTR_CREATE (integer)
La función falla si el atributo extendido ya existe.
XATTR_REPLACE (integer)
La función falla si el atributo extendido no existe.


Funciones de xattr

Tabla de contenidos

  • xattr_get — Obtener un atributo extendido
  • xattr_list — Obtener una lista de atributos extendidos
  • xattr_remove — Elimina un atributo extendido
  • xattr_set — Establece un atributo extendido
  • xattr_supported — Comprueba si soporta los atributos extendidos del sistema de archivos


Obtener un atributo extendido

  • « Funciones de xattr
  • xattr_list »
  • PHP Manual
  • Funciones de xattr
  • Obtener un atributo extendido

xattr_get

(PECL xattr >= 0.9.0)

xattr_get — Obtener un atributo extendido

Descripción

xattr_get ( string $filename , string $name , int $flags = 0 ) : string

Esta función obtiene el valor de un atributo extendido del archivo.

Los atributos extendidos tienen dos espacios de nombres diferentes: de usuario y raíz. El de usuario está disponible para todos los usuarios, mientras que el espacio de nombres raíz está disponible sólo para usuarios con privilegios root. xattr opera en el espacio de nombres de usuario por defecto, pero esto puede ser cambiado con el parámetro flags.

Parámetros

filename

El archivo de la cual obtenemos el atributo.

name

El nombre del atributo.

flags

Banderas xattr soportadas
XATTR_DONTFOLLOW | No sigue el enlace simbólico pero se puede operar en este.
XATTR_ROOT | Establece atributos en la raíz (segura) de espacio de nombres. Requiere privilegios de administrador.

Valores devueltos

Devuelve un string que contiene el valor o false si el atributo no existe.

Ejemplos

Ejemplo #1 Comprueba si el administrador del sistema firmó el archivo

<?php
$file = '/usr/local/sbin/some_binary';
$firma = xattr_get($file, 'Root signature', XATTR_ROOT);

/* ... Comprobar si la $firma es válida ... */

?>

Ver también

  • xattr_list() - Obtener una lista de atributos extendidos
  • xattr_set() - Establece un atributo extendido
  • xattr_remove() - Elimina un atributo extendido


Obtener una lista de atributos extendidos

  • « xattr_get
  • xattr_remove »
  • PHP Manual
  • Funciones de xattr
  • Obtener una lista de atributos extendidos

xattr_list

(PECL xattr >= 0.9.0)

xattr_list — Obtener una lista de atributos extendidos

Descripción

xattr_list ( string $filename , int $flags = 0 ) : array

Esta función obtiene una lista de nombres de los atributos extendidos de un archivo.

Los atributos extendidos tienen dos espacios de nombres diferentes: de usuario y raíz. El de usuario está disponible para todos los usuarios, mientras que el espacio de nombres raíz está disponible sólo para usuarios con privilegios root. xattr opera en el espacio de nombres de usuario por defecto, pero esto puede ser cambiado con el parámetro flags.

Parámetros

filename

La ruta del archivo.

flags

Banderas xattr soportadas
XATTR_DONTFOLLOW | No sigue el enlace simbólico pero se puede operar en este.
XATTR_ROOT | Establece atributos en la raíz (segura) de espacio de nombres. Requiere privilegios de administrador.

Valores devueltos

Esta función devuelve un array con los nombres de los atributos extendidos.

Ejemplos

Ejemplo #1 Imprime los nombres de todos los atributos extendidos del archivo

<?php
$file = 'some_file';
$root_attributes = xattr_list($file, XATTR_ROOT);
$user_attributes = xattr_list($file);

echo "Atributos Root: \n";
foreach ($root_attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

echo "\n Atributos usuario: \n";
foreach ($attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

?>

Ver también

  • xattr_get() - Obtener un atributo extendido


Elimina un atributo extendido

  • « xattr_list
  • xattr_set »
  • PHP Manual
  • Funciones de xattr
  • Elimina un atributo extendido

xattr_remove

(PECL xattr >= 0.9.0)

xattr_remove — Elimina un atributo extendido

Descripción

xattr_remove ( string $filename , string $name , int $flags = 0 ) : bool

Esta función elimina un atributo extendido del archivo.

Los atributos extendidos tienen dos espacios de nombres diferentes: de usuario y raíz. El de usuario está disponible para todos los usuarios, mientras que el espacio de nombres raíz está disponible sólo para usuarios con privilegios root. xattr opera en el espacio de nombres de usuario por defecto, pero esto puede ser cambiado con el parámetro flags.

Parámetros

filename

El archivo del que se elimina el atributo.

name

El nombre del atributo a eliminar.

flags

Banderas xattr soportadas
XATTR_DONTFOLLOW | No sigue el enlace simbólico pero se puede operar en este.
XATTR_ROOT | Establece atributos en la raíz (segura) de espacio de nombres. Requiere privilegios de administrador.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Elimina todos los atributos extendidos de un archivo

<?php
$file = 'some_file';
$attributes = xattr_list($file);

foreach ($attributes as $attr_name) {
    xattr_remove($file, $attr_name);
}
?>

Ver también

  • xattr_list() - Obtener una lista de atributos extendidos
  • xattr_set() - Establece un atributo extendido
  • xattr_get() - Obtener un atributo extendido


Establece un atributo extendido

  • « xattr_remove
  • xattr_supported »
  • PHP Manual
  • Funciones de xattr
  • Establece un atributo extendido

xattr_set

(PECL xattr >= 0.9.0)

xattr_set — Establece un atributo extendido

Descripción

xattr_set ( string $filename , string $name , string $value , int $flags = 0 ) : bool

Esta función establece el valor de un atributo extendido del archivo.

Los atributos extendidos tienen dos espacios de nombres diferentes: de usuario y raíz. El de usuario está disponible para todos los usuarios, mientras que el espacio de nombres raíz está disponible sólo para usuarios con privilegios root. xattr opera en el espacio de nombres de usuario por defecto, pero esto puede ser cambiado con el parámetro flags.

Parámetros

filename

El archivo en el que se establece el atributo.

name

El nombre del atributo extendido. Este atributo se crea si no existe o reemplazado si ya existe. Puede cambiar este comportamiento mediante el uso de los parámetros flags.

value

El valor del atributo.

flags

Banderas xattr soportadas
XATTR_CREATE | La función falla si el atributo extendido ya existe.
XATTR_REPLACE | La función falla si el atributo extendido no existe.
XATTR_DONTFOLLOW | No sigue el enlace simbólico pero se puede operar en este.
XATTR_ROOT | Establece atributos en la raíz (segura) de espacio de nombres. Requiere privilegios de administrador.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establece atributos extendidos en archivo .wav

<?php
$file = 'my_favourite_song.wav';
xattr_set($file, 'Artist', 'Someone');
xattr_set($file, 'My ranking', 'Good');
xattr_set($file, 'Listen count', '34');

/* ... other code ... */

printf("You've played this song %d times", xattr_get($file, 'Listen count'));
?>

Ver también

  • xattr_get() - Obtener un atributo extendido
  • xattr_remove() - Elimina un atributo extendido


Comprueba si soporta los atributos extendidos del sistema de archivos

  • « xattr_set
  • xdiff »
  • PHP Manual
  • Funciones de xattr
  • Comprueba si soporta los atributos extendidos del sistema de archivos

xattr_supported

(PECL xattr >= 1.0.0)

xattr_supported — Comprueba si soporta los atributos extendidos del sistema de archivos

Descripción

xattr_supported ( string $filename , int $flags = 0 ) : bool

Esta función comprueba si el sistema de archivos que contenía el fichero dado soporta los atributos extendidos. Es necesario tener acceso de lectura al archivo.

Parámetros

filename

La ruta del archivo de prueba.

flags

Banderas xattr soportadas
XATTR_DONTFOLLOW No sigue el enlace simbólico pero se puede operar en este.

Valores devueltos

Esta función devuelve true si sistema de archivo soporta los atributos extendidos, false si no soporta y null si no se puede determinar (Por ejemplo ruta incorrecta o le faltan permisos al archivo).

Ejemplos

Ejemplo #1 Ejemplo de xattr_supported()

El siguiente código comprueba si se pueden utilizar los atributos extendidos.

<?php
$file = 'some_file';

if (xattr_supported($file)) {
    /* ... make use of some xattr_* functions ... */
}

?>

Ver también

  • xattr_get() - Obtener un atributo extendido
  • xattr_list() - Obtener una lista de atributos extendidos


xdiff

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de xdiff
    • xdiff_file_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
    • xdiff_file_bdiff — Realiza una diferencia binaria de dos archivos
    • xdiff_file_bpatch — Parchea un archivo con una diferencia binaria
    • xdiff_file_diff_binary — Alias de xdiff_file_bdiff
    • xdiff_file_diff — Hacer un diff unificado de dos archivos
    • xdiff_file_merge3 — Une 3 archivos en uno
    • xdiff_file_patch_binary — Alias de xdiff_file_bpatch
    • xdiff_file_patch — Parchea un archivo con un diff unificado
    • xdiff_file_rabdiff — Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
    • xdiff_string_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
    • xdiff_string_bdiff — Hacer una diferencia binaria de dos cadenas
    • xdiff_string_bpatch — Parchear una cadena con una diferencia binaria
    • xdiff_string_diff_binary — Alias de xdiff_string_bdiff
    • xdiff_string_diff — Hacer un diff unificado de dos strings
    • xdiff_string_merge3 — Unir tres cadenas en una
    • xdiff_string_patch_binary — Alias de xdiff_string_bpatch
    • xdiff_string_patch — Parchear una cadena con un diff unificado
    • xdiff_string_rabdiff — Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin


Introducción

La extensión xdiff permite crear y aplicar archivos parche que contienen diferencias entre diferentes revisiones de archivos.

Esta extensión soporta dos modos de funcionamiento - sobre cadenas y sobre archivos, así como dos formatos de parches diferentes - unificado y binario. Los parches unificados son excelentes para archivos de texto, ya que son legibles y fáciles de revisar. Para los archivos binarios como archivos o imágenes, los parches binarios serán la opción adecuada, ya que ellos son binary safe y manejan caracteres no imprimibles.

A partir de la versión 1.5.0 hay dos diferentes conjuntos de funciones para la generación de parches binarios. Las nuevas funciones - xdiff_string_rabdiff() xdiff_file_rabdiff() generan salidas compatibles con funciones más antiguas pero suelen ser más rápidas y generan resultados más pequeños. Para más detalles sobre los métodos de la generación de parches binarios y diferencias entre ellos, por favor consulte la website » libxdiff.

Esta extensión utiliza libxdiff para implementar estas funciones. Consulte » http://www.xmailserver.org/xdiff-lib.html para mayor información.


Requerimientos

Para usar xdiff, es necesario contar con libxdiff instalado, disponible en la web de libxdiff » http://www.xmailserver.org/xdiff-lib.html.

Nota:

Para que estas funciones tengan en cuenta la directiva memory_limit es necesario contar con, al menos, libxdiff 0.7.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/xdiff.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

XDIFF_PATCH_NORMAL (integer)
Este indicador indica que las funciones xdiff_string_patch() y xdiff_file_patch() deben crear el resultado de aplicar el parche al contenido original, creando así una versión más reciente del archivo. Este es el modo por defecto de funcionamiento.
XDIFF_PATCH_REVERSE (integer)
Este indicador indica que las funciones xdiff_string_patch() y xdiff_file_patch() deben crear el resultado de revertir el parche de modificación desde el nuevo contenido, creando así la versión original.


Funciones de xdiff

Tabla de contenidos

  • xdiff_file_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
  • xdiff_file_bdiff — Realiza una diferencia binaria de dos archivos
  • xdiff_file_bpatch — Parchea un archivo con una diferencia binaria
  • xdiff_file_diff_binary — Alias de xdiff_file_bdiff
  • xdiff_file_diff — Hacer un diff unificado de dos archivos
  • xdiff_file_merge3 — Une 3 archivos en uno
  • xdiff_file_patch_binary — Alias de xdiff_file_bpatch
  • xdiff_file_patch — Parchea un archivo con un diff unificado
  • xdiff_file_rabdiff — Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
  • xdiff_string_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
  • xdiff_string_bdiff — Hacer una diferencia binaria de dos cadenas
  • xdiff_string_bpatch — Parchear una cadena con una diferencia binaria
  • xdiff_string_diff_binary — Alias de xdiff_string_bdiff
  • xdiff_string_diff — Hacer un diff unificado de dos strings
  • xdiff_string_merge3 — Unir tres cadenas en una
  • xdiff_string_patch_binary — Alias de xdiff_string_bpatch
  • xdiff_string_patch — Parchear una cadena con un diff unificado
  • xdiff_string_rabdiff — Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin


Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

  • « Funciones de xdiff
  • xdiff_file_bdiff »
  • PHP Manual
  • Funciones de xdiff
  • Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

xdiff_file_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

Descripción

xdiff_file_bdiff_size ( string $file ) : int

Devuelve el tamaño de un archivo resultado que se creó después de aplicar el parche binario desde el archivo file a el archivo original.

Parámetros

file

La ruta al parche binario creado por la función xdiff_string_bdiff() o xdiff_string_rabdiff().

Valores devueltos

Devuelve el tamaño del archivo que se creará.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_bdiff_size()

El siguiente código lee el tamaño de un archivo que se creará tras realizar una diferencia binaria.

<?php
$length = xdiff_string_bdiff_size('file.bdiff');
echo "El archivo resultante tendrá $length bytes de longitud";
?>

Ver también

  • xdiff_file_bdiff() - Realiza una diferencia binaria de dos archivos
  • xdiff_file_rabdiff() - Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
  • xdiff_file_bpatch() - Parchea un archivo con una diferencia binaria


Realiza una diferencia binaria de dos archivos

  • « xdiff_file_bdiff_size
  • xdiff_file_bpatch »
  • PHP Manual
  • Funciones de xdiff
  • Realiza una diferencia binaria de dos archivos

xdiff_file_bdiff

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff — Realiza una diferencia binaria de dos archivos

Descripción

xdiff_file_bdiff ( string $old_file , string $new_file , string $dest ) : bool

Hace una diferencia binaria de dos archivos y almacena el resultado en un archivo de revisión. Esta función trabaja con archivos de texto y binarios. El archivo parche resultante puede ser aplicado posteriormente utilizando xdiff_file_bpatch()/xdiff_string_bpatch().

Parámetros

old_file

Ruta a el primer archivo. Este archivo actúa como "viejo" archivo.

new_file

Ruta a el segundo archivo. Este archivo actúa como "nuevo" archivo.

dest

Ruta de el archivo parche resultante. El archivo resultante contiene diferencias entre los archivos "viejo" y "nuevo". Este será en formato binario y no leible por humanos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_bdiff()

El siguiente código hace una diferencia binaria de dos archivos.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_bdiff($old_version, $new_version, 'my_script.bdiff');
?>

Notas

Nota:

Ambos archivos serán cargados en memoria así que asegúrese que el valor de memory_limit es lo suficientemente alto.

Ver también

  • xdiff_file_bpatch() - Parchea un archivo con una diferencia binaria


Parchea un archivo con una diferencia binaria

  • « xdiff_file_bdiff
  • xdiff_file_diff_binary »
  • PHP Manual
  • Funciones de xdiff
  • Parchea un archivo con una diferencia binaria

xdiff_file_bpatch

(PECL xdiff >= 1.5.0)

xdiff_file_bpatch — Parchea un archivo con una diferencia binaria

Descripción

xdiff_file_bpatch ( string $file , string $patch , string $dest ) : bool

Parchea un file con un patch binario y almacena el resultado en un archivo dest. Esta función acepta parches creados tanto a través de la funciones xdiff_file_bdiff() y xdiff_file_rabdiff() como de sus equivalentes de cadena.

Parámetros

file

El archivo original.

patch

El archivo parche binario.

dest

La ruta del archivo resultante.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 xdiff_file_bpatch() example

El siguiente código aplica una diferencia binaria a un archivo.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_bpatch($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "Archivo parcheado";
} else {
   echo "El archivo no pudo ser parcheado";
}

?>

Notas

Nota:

Ambos archivos (file y patch) serán cargados en memoria así que asegúrese que el valor de memory_limit es lo suficientemente alto.

Ver también

  • xdiff_file_bdiff() - Realiza una diferencia binaria de dos archivos
  • xdiff_file_rabdiff() - Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin


Alias de xdiff_file_bdiff

  • « xdiff_file_bpatch
  • xdiff_file_diff »
  • PHP Manual
  • Funciones de xdiff
  • Alias de xdiff_file_bdiff

xdiff_file_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_file_diff_binary — Alias de xdiff_file_bdiff

Descripción

xdiff_file_diff_binary ( string $old_file , string $new_file , string $dest ) : bool

Hace una diferencia binaria de dos archivos y almacena el resultado en un archivo de revisión. Esta función trabaja con archivos de texto y binarios. El archivo parche resultante puede ser posteriormente aplicado con xdiff_file_bpatch().

Desde la versión 1.5.0 de esta función es un alias de xdiff_file_bdiff().

Parámetros

old_file

Ruta a el primer archivo. Este archivo actúa como "viejo" archivo.

new_file

Ruta a el segundo archivo. Este archivo actúa como "nuevo" archivo.

dest

Ruta de el archivo parche resultante. El archivo resultante contiene diferencias entre los archivos "viejo" y "nuevo". Este será en formato binario y no legible por humanos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_diff_binary()

El siguiente código hace una diferencia binaria de dos archivos.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_diff_binary($old_version, $new_version, 'my_script.bdiff');
?>

Notas

Nota:

Ambos archivos serán cargados en memoria así que asegúrese que el valor de memory_limit es lo suficientemente alto.

Ver también

  • xdiff_file_bdiff() - Realiza una diferencia binaria de dos archivos
  • xdiff_file_bpatch() - Parchea un archivo con una diferencia binaria


Hacer un diff unificado de dos archivos

  • « xdiff_file_diff_binary
  • xdiff_file_merge3 »
  • PHP Manual
  • Funciones de xdiff
  • Hacer un diff unificado de dos archivos

xdiff_file_diff

(PECL xdiff >= 0.2.0)

xdiff_file_diff — Hacer un diff unificado de dos archivos

Descripción

xdiff_file_diff ( string $old_file , string $new_file , string $dest , int $context = 3 , bool $minimal = false ) : bool

Hace un diff unificado que contiene las diferencias entre old_file y new_file y almacena este en el archivo dest. El archivo resultante es legible. Un parámetro opcional context especifica el número de líneas de contexto que hay que añadir alrededor de cada cambio. Establecer el parámetro minimal a true dará como resultado de salida el archivo parche más corto posible (puede tomar algo de tiempo).

Parámetros

old_file

Ruta a el primer archivo. Este archivo actúa como "viejo" archivo.

new_file

Ruta a el segundo archivo. Este archivo actúa como "nuevo" archivo.

dest

Ruta del archivo parche resultante.

context

Indica el número de líneas de contexto que desea incluir en el resultado diff.

minimal

Establezca este parámetro a true si desea reducir el tamaño del resultado (puede tomar algo de tiempo).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_diff()

El siguiente código hace un diff unificado de dos archivos php con una longitud de contexto de 2.

<?php
$old_version = 'my_script.php';
$new_version = 'my_new_script.php';

xdiff_file_diff($old_version, $new_version, 'my_script.diff', 2);
?>

Notas

Nota:

Esta función no funciona bien con archivos binarios. Para hacer una diferencia binaria de archivos utilice la xdiff_file_bdiff()/xdiff_file_rabdiff().

Ver también

  • xdiff_file_patch() - Parchea un archivo con un diff unificado


Une 3 archivos en uno

  • « xdiff_file_diff
  • xdiff_file_patch_binary »
  • PHP Manual
  • Funciones de xdiff
  • Une 3 archivos en uno

xdiff_file_merge3

(PECL xdiff >= 0.2.0)

xdiff_file_merge3 — Une 3 archivos en uno

Descripción

xdiff_file_merge3 ( string $old_file , string $new_file1 , string $new_file2 , string $dest ) : mixed

Une tres archivos en uno y almacena el resultado en un archivo dest. El old_file es una versión original mientras new_file1 y new_file2 son versiones modificadas de un original.

Parámetros

old_file

Ruta a el primer archivo. Este archivo actúa como "viejo" archivo.

new_file1

Ruta a el segundo archivo. Este actúa como una versión modificada de old_file.

new_file2

Ruta a el tercer archivo. Este actúa como una versión modificada de old_file.

dest

La ruta del archivo resultante, contiene la unión modificada de new_file1 y new_file2.

Valores devueltos

Devuelve true si la unión fue satisfactoria, una cadena con fragmento erróneo si esta no lo fue o false si ocurrió un error interno.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_merge3()

El código siguiente combina tres archivos en uno.

<?php
$old_version = 'original_script.php';
$fix1 = 'script_with_fix1.php';
$fix2 = 'script_with_fix2.php';

$errors = xdiff_file_merge3($old_version, $fix1, $fix2, 'fixed_script.php');
if (is_string($errors)) {
    echo "Rejects:\n";
    echo $errors;
}
?>

Ver también

  • xdiff_string_merge3() - Unir tres cadenas en una


Alias de xdiff_file_bpatch

  • « xdiff_file_merge3
  • xdiff_file_patch »
  • PHP Manual
  • Funciones de xdiff
  • Alias de xdiff_file_bpatch

xdiff_file_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_file_patch_binary — Alias de xdiff_file_bpatch

Descripción

xdiff_file_patch_binary ( string $file , string $patch , string $dest ) : bool

Parchea un file con un patch binario y almacena el resultado en un archivo dest. Esta función acepta parches creados tanto a través de funciones xdiff_file_bdiff() o xdiff_file_rabdiff() como de sus equivalentes de cadena.

Desde la versión 1.5.0 esta función es un alias de xdiff_file_bpatch().

Parámetros

file

El archivo original.

patch

El archivo parche binario.

dest

La ruta de el archivo resultante.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_patch_binary()

El siguiente código aplica una diferencia binaria a un archivo.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_patch_binary($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "Archivo parcheado";
} else {
   echo "El archivo no pudo ser parcheado";
}

?>

Notas

Nota:

Ambos archivos (file y patch) serán cargados en memoria así que asegúrese que el valor de memory_limit es lo suficientemente alto.

Ver también

  • xdiff_string_patch_binary() - Alias de xdiff_string_bpatch


Parchea un archivo con un diff unificado

  • « xdiff_file_patch_binary
  • xdiff_file_rabdiff »
  • PHP Manual
  • Funciones de xdiff
  • Parchea un archivo con un diff unificado

xdiff_file_patch

(PECL xdiff >= 0.2.0)

xdiff_file_patch — Parchea un archivo con un diff unificado

Descripción

xdiff_file_patch ( string $file , string $patch , string $dest , int $flags = DIFF_PATCH_NORMAL ) : mixed

Parchea un file con un patch y almacena el resultado en un archivo. patch tiene que ser un diff unificado creado por la función xdiff_file_diff()/xdiff_string_diff(). Un parámetro opcional flags especifica el modo de operación.

Parámetros

file

El archivo original.

patch

El archivo de revisión unificado. Este tiene que ser creado con las funciones xdiff_string_diff(), xdiff_file_diff() o herramientas compatibles.

dest

Ruta de el archivo resultante.

flags

Puede ser XDIFF_PATCH_NORMAL (modo por defecto, parche normal) o XDIFF_PATCH_REVERSE (parche invertido).

A partir de la versión 1.5.0, también puede utilizar binario OR para habilitar el indicador XDIFF_PATCH_IGNORESPACE.

Valores devueltos

Devuelve false si ocurrió un error interno, una cadena con fragmento erróneo si el parche no pudo ser aplicado o true si el parche fue aplicado con éxito.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_patch()

El siguiente código aplica un diff unificado a un archivo.

<?php
$old_version = 'my_script-1.0.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($old_version, $patch, 'my_script-1.1.php');
if (is_string($errors)) {
   echo "Rejects:\n";
   echo $errors;
}

?>

Ejemplo #2 Ejemplo de parche invertido

El código siguiente invierte un parche.

<?php
$new_version = 'my_script-1.1.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($new_version, $patch, 'my_script-1.0.php', XDIFF_PATCH_REVERSE);
if (is_string($errors)) {
   echo "Fragmentos erróneos:\n";
   echo $errors;
}

?>

Ver también

  • xdiff_file_diff() - Hacer un diff unificado de dos archivos


Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

  • « xdiff_file_patch
  • xdiff_string_bdiff_size »
  • PHP Manual
  • Funciones de xdiff
  • Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

xdiff_file_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_file_rabdiff — Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

Descripción

xdiff_file_rabdiff ( string $old_file , string $new_file , string $dest ) : bool

Hace una diferencia binaria de dos archivos y almacena el resultado en un archivo de revisión. La diferencia entre esta función y xdiff_file_bdiff() es el diferente algoritmo que se utiliza que debería traducirse en una ejecución más rápida y un diff producido menor. Esta función trabaja con archivos de texto y binarios. El archivo parche resultante puede ser posteriormente aplicado utilizando xdiff_file_bpatch()/xdiff_string_bpatch().

Para obtener más información sobre las diferencias entre el algoritmo utilizado por favor vea el sitio web » libxdiff

Parámetros

old_file

Ruta a el primer archivo. Este archivo actúa como "viejo" archivo.

new_file

Ruta a el segundo archivo. Este archivo actúa como "nuevo" archivo.

dest

Ruta de el archivo parche resultante. El archivo resultante contiene diferencias entre los archivos "viejo" y "nuevo". Este será en formato binario y no legible por humanos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_file_rabdiff()

El siguiente código hace una diferencia binaria de dos archivos.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_rabdiff($old_version, $new_version, 'my_script.bdiff');
?>

Notas

Nota:

Ambos archivos serán cargados en memoria así que asegúrese que el valor de memory_limit es lo suficientemente alto.

Ver también

  • xdiff_file_bpatch() - Parchea un archivo con una diferencia binaria


Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

  • « xdiff_file_rabdiff
  • xdiff_string_bdiff »
  • PHP Manual
  • Funciones de xdiff
  • Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

xdiff_string_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff_size — Lee el tamaño de un archivo creado tras aplicar una diferencia binaria

Descripción

xdiff_string_bdiff_size ( string $patch ) : int

Devuelve el tamaño de un archivo resultante que será creado tras aplicar el patch binario a el archivo original.

Parámetros

patch

El parche binario creado por la función xdiff_string_bdiff() o xdiff_string_rabdiff().

Valores devueltos

Devuelve el tamaño del archivo que fue creado.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_string_bdiff_size()

El siguiente código lee el tamaño de un archivo que fue creado tras aplicar una diferencia binaria.

<?php
$binary_patch = file_get_contents('file.bdiff');
$length = xdiff_string_bdiff_size($binary_patch);
echo "El archivo resultante tendrá $length bytes de longitud";
?>

Ver también

  • xdiff_string_bdiff() - Hacer una diferencia binaria de dos cadenas
  • xdiff_string_rabdiff() - Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
  • xdiff_string_bpatch() - Parchear una cadena con una diferencia binaria


Hacer una diferencia binaria de dos cadenas

  • « xdiff_string_bdiff_size
  • xdiff_string_bpatch »
  • PHP Manual
  • Funciones de xdiff
  • Hacer una diferencia binaria de dos cadenas

xdiff_string_bdiff

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff — Hacer una diferencia binaria de dos cadenas

Descripción

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Hace una diferencia binaria de dos cadenas y devuelve el resultado. Esta función trabaja con texto y datos binarios. El parche resultante puede ser posteriormente aplicado utilizando xdiff_string_bpatch()/xdiff_file_bpatch().

Parámetros

old_data

Primera cadena con información binaria. Esta actúa como "vieja" información.

new_data

Segunda cadena con información binaria. Esta actúa como "nueva" información.

Valores devueltos

Devuelve la cadena con la diferencia binaria conteniendo las diferencias entre "vieja" y "nueva" información o false si se producido un error interno.

Ver también

  • xdiff_string_bpatch() - Parchear una cadena con una diferencia binaria


Parchear una cadena con una diferencia binaria

  • « xdiff_string_bdiff
  • xdiff_string_diff_binary »
  • PHP Manual
  • Funciones de xdiff
  • Parchear una cadena con una diferencia binaria

xdiff_string_bpatch

(PECL xdiff >= 1.5.0)

xdiff_string_bpatch — Parchear una cadena con una diferencia binaria

Descripción

xdiff_string_bpatch ( string $str , string $patch ) : string

Parchea una cadena str con un patch binario. Esta función acepta parches creados tanto a través de las funciones xdiff_string_bdiff() y xdiff_string_rabdiff() o su archivo homólogo equivalente.

Parámetros

str

La cadena binaria original.

patch

La cadena parche binaria.

Valores devueltos

Devuelve la cadena parcheada, o false en caso de error.

Ver también

  • xdiff_string_bdiff() - Hacer una diferencia binaria de dos cadenas
  • xdiff_string_rabdiff() - Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin


Alias de xdiff_string_bdiff

  • « xdiff_string_bpatch
  • xdiff_string_diff »
  • PHP Manual
  • Funciones de xdiff
  • Alias de xdiff_string_bdiff

xdiff_string_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_string_diff_binary — Alias de xdiff_string_bdiff

Descripción

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Hace una diferencia binaria de dos cadenas y devuelve el resultado. Esta función trabaja con texto y datos binarios. El parche resultante puede ser posteriormente aplicado utilizando xdiff_string_bpatch()/xdiff_file_bpatch().

Desde la versión 1.5.0 esta función es un alias de xdiff_string_bdiff().

Parámetros

old_data

Primera cadena con información binaria. Esta actúa como "vieja" información.

new_data

Segunda cadena con información binaria. Esta actúa como "nueva" información.

Valores devueltos

Devuelve cadena con resultado o false si se produce un error interno.

Ver también

  • xdiff_string_bdiff() - Hacer una diferencia binaria de dos cadenas
  • xdiff_string_bpatch() - Parchear una cadena con una diferencia binaria


Hacer un diff unificado de dos strings

  • « xdiff_string_diff_binary
  • xdiff_string_merge3 »
  • PHP Manual
  • Funciones de xdiff
  • Hacer un diff unificado de dos strings

xdiff_string_diff

(PECL xdiff >= 0.2.0)

xdiff_string_diff — Hacer un diff unificado de dos strings

Descripción

xdiff_string_diff ( string $old_data , string $new_data , int $context = 3 , bool $minimal = false ) : string

Hace un diff unificado que contiene diferencias entre el string old_data y el string new_data y devuelve este. El diff resultante es legible. Un parámetro opcional context especifica el número de líneas de contexto que hay que añadir alrededor de cada cambio. Establecer el parámetro minimal a true dará como resultado de salida el archivo parche más corto posible (puede tomar algo de tiempo).

Parámetros

old_data

Primera cadena con información. Esta actúa como "vieja" información.

new_data

Segundo string con información. Esta actúa como "nueva" información.

context

Indica el número de líneas de contexto que desea incluir en el diff resultado.

minimal

Establezca este parámetro a true si desea reducir el tamaño del resultado (puede tomar algo de tiempo).

Valores devueltos

Devuelve un string con el resultado diff o false si ocurriera un error interno.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_string_diff()

El siguiente código hace un diff unificado de dos artículos.

<?php
$old_article = file_get_contents('./old_article.txt');
$new_article = $_REQUEST['article']; /* Supongamos que alguien pega un nuevo artículo en formato html */

$diff = xdiff_string_diff($old_article, $new_article, 1);
if (is_string($diff)) {
    echo "Diferencias entre los dos artículos:\n";
    echo $diff;
}

?>

Notas

Nota:

Esta función no funciona bien con string binarios. Para hacer un diff de string binario utilice xdiff_string_bdiff()/xdiff_string_rabdiff().

Ver también

  • xdiff_string_patch() - Parchear una cadena con un diff unificado


Unir tres cadenas en una

  • « xdiff_string_diff
  • xdiff_string_patch_binary »
  • PHP Manual
  • Funciones de xdiff
  • Unir tres cadenas en una

xdiff_string_merge3

(PECL xdiff >= 0.2.0)

xdiff_string_merge3 — Unir tres cadenas en una

Descripción

xdiff_string_merge3 ( string $old_data , string $new_data1 , string $new_data2 , string &$error = ? ) : mixed

Une tres cadenas en una y devuelve el resultado. El parámetro old_data es una versión original de los datos mientras new_data1 y new_data2 son versiones modificadas de un original. El parámetro opcional error es utilizado para admitir cualquier fragmento erróneo durante el proceso de unión.

Parámetros

old_data

Primera cadena con información. Esta actúa como "vieja" información.

new_data1

Segunda cadena con información. Esta actúa como versión modificada del old_data.

new_data2

La tercera cadena con información. Esta actúa como versión modificada del old_data.

error

Si se produce algún fragmento erróneo entonces se almacenan dentro de esta variable.

Valores devueltos

Devuelve la cadena unida, false si se produce un error interno, o true si la cadena unida está vacía.

Ver también

  • xdiff_file_merge3() - Une 3 archivos en uno


Alias de xdiff_string_bpatch

  • « xdiff_string_merge3
  • xdiff_string_patch »
  • PHP Manual
  • Funciones de xdiff
  • Alias de xdiff_string_bpatch

xdiff_string_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_string_patch_binary — Alias de xdiff_string_bpatch

Descripción

xdiff_string_patch_binary ( string $str , string $patch ) : string

Parchea una cadena str con un patch binario. Esta función acepta parches creados tanto a través de las funciones xdiff_string_bdiff() y xdiff_string_rabdiff() o de su archivo homólogo equivalente.

Desde la versión 1.5.0 esta función es un alias de xdiff_string_bpatch().

Parámetros

str

La cadena binaria original.

patch

La cadena parche binaria.

Valores devueltos

Devuelve la cadena parcheada, o false en caso de error.

Ver también

  • xdiff_string_bpatch() - Parchear una cadena con una diferencia binaria
  • xdiff_string_bdiff() - Hacer una diferencia binaria de dos cadenas
  • xdiff_string_rabdiff() - Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin


Parchear una cadena con un diff unificado

  • « xdiff_string_patch_binary
  • xdiff_string_rabdiff »
  • PHP Manual
  • Funciones de xdiff
  • Parchear una cadena con un diff unificado

xdiff_string_patch

(PECL xdiff >= 0.2.0)

xdiff_string_patch — Parchear una cadena con un diff unificado

Descripción

xdiff_string_patch ( string $str , string $patch , int $flags = ? , string &$error = ? ) : string

Parchea una cadena str con un parche unificado en parámetro patch y devuelve el resultado. patch tiene que ser un diff unificado creado por la función xdiff_file_diff()/xdiff_string_diff(). Un parámetro opcional flags especifica el modo de operación. Cualquier fragmento erróneo del parche será almacenado en el interior de la variable error si si esta es proporcionada.

Parámetros

str

La cadena original.

patch

La cadena parche unificada. Esta tiene que ser creada utilizando las funciones xdiff_string_diff(), xdiff_file_diff() o herramientas compatibles.

flags

flags uede ser XDIFF_PATCH_NORMAL (modo por defecto, parche normal) o XDIFF_PATCH_REVERSE (parche invertido).

A partir de la versión 1.5.0, también se puede utilizar binario OR para habilitar el indicador XDIFF_PATCH_IGNORESPACE.

error

Si se proporciona entonces los fragmentos erróneos se almacenan dentro de esta variable.

Valores devueltos

Devuelve la cadena parcheada, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de xdiff_string_patch()

El siguiente código aplica cambios en algún artículo.

<?php
$old_article = file_get_contents('./old_article.txt');
$diff = $_SERVER['patch']; /* Supongamos que alguien pega un parche para un formulario html */

$errors = '';

$new_article = xdiff_string_patch($old_article, $diff, XDIFF_PATCH_NORMAL, $errors);
if (is_string($new_article)) {
    echo "Nuevo artículo:\n";
    echo $new_article;
}

if (strlen($errors)) {
    echo "Fragmentos erróneos: \n";
    echo $errors;
}

?>

Ver también

  • xdiff_string_diff() - Hacer un diff unificado de dos strings


Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

  • « xdiff_string_patch
  • Soporte para lenguaje humano y codificación de caracteres »
  • PHP Manual
  • Funciones de xdiff
  • Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

xdiff_string_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_string_rabdiff — Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin

Descripción

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Hace una diferencia binaria de dos cadenas y almacena el resultado. La diferencia entre esta función y xdiff_string_bdiff() es el diferente algoritmo que se utiliza que debería traducirse en una ejecución más rápida y un diff producido menor. Esta función trabaja con archivos de texto y binarios. El archivo parche resultante puede ser posteriormente aplicado utilizando xdiff_string_bpatch()/xdiff_file_bpatch().

Para obtener más información sobre las diferencias entre el algoritmo utilizado por favor vea el sitio web » libxdiff

Parámetros

old_data

Primera cadena con información binaria. Esta actúa como "vieja" información.

new_data

Segunda cadena con información binaria. Esta actúa como "nueva" información.

Valores devueltos

Devuelve la cadena con la diferencia binaria conteniendo las diferencias entre "vieja" y "nueva" información o false si se ha producido un error interno.

Ver también

  • xdiff_string_bpatch() - Parchear una cadena con una diferencia binaria


Soporte para lenguaje humano y codificación de caracteres

  • Enchant — Biblioteca de ortografía Enchant
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Enchant
  • Gender — Determinar el género de un nombre
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • Gender\Gender — La clase Gender\Gender
  • Gettext
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Gettext
  • iconv
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de iconv
  • intl — Funciones de internacionalización
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Collator — La clase Collator
    • NumberFormatter — La clase NumberFormatter
    • Locale — La clase Locale
    • Normalizer — La clase Normalizer
    • MessageFormatter — La clase MessageFormatter
    • IntlCalendar — La clase IntlCalendar
    • IntlTimeZone — La clase IntlTimeZone
    • IntlDateFormatter — La clase IntlDateFormatter
    • ResourceBundle — La clase ResourceBundle
    • Spoofchecker — La clase Spoofchecker
    • Transliterator — La clase Transliterator
    • IntlBreakIterator — La clase IntlBreakIterator
    • IntlRuleBasedBreakIterator — La clase IntlRuleBasedBreakIterator
    • IntlCodePointBreakIterator — La clase IntlCodePointBreakIterator
    • IntlPartsIterator — La clase IntlPartsIterator
    • UConverter — La clase UConverter
    • Funciones de Grapheme
    • Funciones de IDN
    • IntlChar
    • IntlException — Clase de excepciones para errores de intl
    • IntlIterator — La clase IntlIterator
    • Funciones de intl
  • Cadenas de caracteres multibyte
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Resumen de codificaciones soportadas
    • Lo básico sobre codificaciones multibytes del japonés
    • Entrada/Salida de HTTP
    • Codificaciones de caracteres admitidas
    • Sobrecarga de Funciones
    • Requerimientos para la codificación de caracteres en PHP
    • Funciones de cadenas de caracteres multibyte
  • Pspell
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Pspell
  • Recode — GNU Recode
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Recode


Biblioteca de ortografía Enchant

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Enchant
    • enchant_broker_describe — Enumera los proveedores de Enchant
    • enchant_broker_dict_exists — Si existe o no un diccionario. Usando una etiqueta no vacía
    • enchant_broker_free_dict — Liberar un recurso de diccionario
    • enchant_broker_free — Liberar el recurso de agente y sus diccionarios
    • enchant_broker_get_dict_path — Obtener la ruta del directorio para un 'backend' dado
    • enchant_broker_get_error — Devuelve el último error del agente
    • enchant_broker_init — Crear un nuevo objeto agente capaz de hacer peticiones
    • enchant_broker_list_dicts — Devuelve una lista de los diccionarios disponibles
    • enchant_broker_request_dict — Crear un diccionario usanto una etiqueta
    • enchant_broker_request_pwl_dict — Crea un diccionario usando un fichero PWL
    • enchant_broker_set_dict_path — Establecer la ruta del directorio para un 'backend' dado
    • enchant_broker_set_ordering — Declara una preferencia de diccionarios a usar para el lenguaje
    • enchant_dict_add_to_personal — Añadir una palabra a una lista personal de palabras
    • enchant_dict_add_to_session — Añadir una palabra a esta sesión ortográfica
    • enchant_dict_add — Add a word to personal word list
    • enchant_dict_check — Comprobar si una palabra está correctamente escrita o no
    • enchant_dict_describe — Describe un diccionario individual
    • enchant_dict_get_error — Devuelve el último error de la sesión ortográfica actual
    • enchant_dict_is_added — Whether or not 'word' exists in this spelling-session
    • enchant_dict_is_in_session — Si existe o no una palabra en esta sesión ortográfica
    • enchant_dict_quick_check — Verifica si la palabra está correctamente escrita y proporciona sugerencias
    • enchant_dict_store_replacement — Añadir una corrección a una palabra
    • enchant_dict_suggest — Devolverá una lista de valores si no se reúnen esas pre-condiciones


Introducción

Enchant es el vínculo de PHP para la » biblioteca Enchant. Enchant interviene para proporcinar uniformidad y conformidad sobre todas las bibliotecas de ortografía, e implementa ciertas características que pueden estar ausentes en cualquier biblioteca de proovedor individual. Todo debería "simplemente funcionar" para cualquier definición de "simplemente funciona."

Enchant soporta los siguientes entornos:

  • Aspell/Pspell (intenta reemplazar a Ispell)

  • Ispell (antiguo como el comer, podría ser interpretado como un estándar de hecho)

  • MySpell/Hunspell (unos proyectos OOo, también usados por Mozilla)

  • Uspell (principalmente yidish, Hebreo y lenguajes de Europa Oriental - alojado en el CVS de AbiWord bajo el módulo "uspell")

  • Hspell (hebreo)

  • AppleSpell (Mac OSX)


Requerimientos

Esta versión usa las funciones de la » librería Enchant por Dom Lachowicz. Se necesita Enchant 1.2.4 o posterior. Enchant 2.0.0 o posterior aún no está soportado.

Enchant también requiere » Glib 2.6 o posterior. Las bibliotecas precompiladas de Windows están disponibles en » http://ftp.gnome.org/pub/gnome/binaries/win32/glib/.


Instalación

Esta extensión está incluida con PHP a partir de PHP 5.3.0. Antes, enchant era una extensión PECL. Los usuarios de verisones anteriores a la 5.3.0 pueden usar la » extensión PECL.

Siempre que las bibliotecas requeridas estén instaladas, los usuarios de PHP 5.3.0 o posterior pueden habilitar enchant añadiendo la opción --with-enchant[=dir] al compilar PHP.


Tipos de recursos

Existen dos tipos de recursos en esta extensión. El primero es el agente (el administrador de entornos) y el segundo es para el diccionario.


Constantes predefinidas

ENCHANT_MYSPELL (integer)
Tipo de diccionario para MySpell. Utilizada con enchant_broker_get_dict_path() y enchant_broker_set_dict_path().
ENCHANT_ISPELL (integer)
Tipo de diccionario para Ispell. Utilizada con enchant_broker_get_dict_path() y enchant_broker_set_dict_path().


Ejemplos

Ejemplo #1 Ejemplos de Uso de Enchant

<?php
$etiqueta = 'en_US';
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "El agente actual proporciona los siguientes entornos:\n";
print_r($bprovides);

$diccionarios = enchant_broker_list_dicts($r);
print_r($diccionarios);
if (enchant_broker_dict_exists($r,$etiqueta)) {
    $d = enchant_broker_request_dict($r, $etiqueta);
    $dprovides = enchant_dict_describe($d);
    echo "el diccionario $etiqueta proporciona:\n";
    $palabra_correcta = enchant_dict_check($d, "soong");
    print_r($dprovides);
    if (!$palabra_correcta) {
        $sugerencias = enchant_dict_suggest($d, "soong");
        echo "Sugerencias para 'soong':";
        print_r($sugerencias);
    }
    enchant_broker_free_dict($d);
} else {
}
enchant_broker_free($r);
?>


Funciones de Enchant

Tabla de contenidos

  • enchant_broker_describe — Enumera los proveedores de Enchant
  • enchant_broker_dict_exists — Si existe o no un diccionario. Usando una etiqueta no vacía
  • enchant_broker_free_dict — Liberar un recurso de diccionario
  • enchant_broker_free — Liberar el recurso de agente y sus diccionarios
  • enchant_broker_get_dict_path — Obtener la ruta del directorio para un 'backend' dado
  • enchant_broker_get_error — Devuelve el último error del agente
  • enchant_broker_init — Crear un nuevo objeto agente capaz de hacer peticiones
  • enchant_broker_list_dicts — Devuelve una lista de los diccionarios disponibles
  • enchant_broker_request_dict — Crear un diccionario usanto una etiqueta
  • enchant_broker_request_pwl_dict — Crea un diccionario usando un fichero PWL
  • enchant_broker_set_dict_path — Establecer la ruta del directorio para un 'backend' dado
  • enchant_broker_set_ordering — Declara una preferencia de diccionarios a usar para el lenguaje
  • enchant_dict_add_to_personal — Añadir una palabra a una lista personal de palabras
  • enchant_dict_add_to_session — Añadir una palabra a esta sesión ortográfica
  • enchant_dict_add — Add a word to personal word list
  • enchant_dict_check — Comprobar si una palabra está correctamente escrita o no
  • enchant_dict_describe — Describe un diccionario individual
  • enchant_dict_get_error — Devuelve el último error de la sesión ortográfica actual
  • enchant_dict_is_added — Whether or not 'word' exists in this spelling-session
  • enchant_dict_is_in_session — Si existe o no una palabra en esta sesión ortográfica
  • enchant_dict_quick_check — Verifica si la palabra está correctamente escrita y proporciona sugerencias
  • enchant_dict_store_replacement — Añadir una corrección a una palabra
  • enchant_dict_suggest — Devolverá una lista de valores si no se reúnen esas pre-condiciones


Enumera los proveedores de Enchant

  • « Funciones de Enchant
  • enchant_broker_dict_exists »
  • PHP Manual
  • Funciones de Enchant
  • Enumera los proveedores de Enchant

enchant_broker_describe

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0)

enchant_broker_describe — Enumera los proveedores de Enchant

Descripción

enchant_broker_describe ( resource $broker ) : array

Enumera los proveedores de Enchant e indica alguna información rudimentaria sobre ellos. La misma información es proporcionada a través de phpinfo().

Parámetros

broker

Recurso de agente

Valores devueltos

Devuelve un array de los proveedores de Enchant disponibles con sus datos, o false en caso de error.

Ejemplos

Ejemplo #1 Listar los entornos proporcionados por el agente dado

<?php
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "El agente actual proporciona los siguientes entornos:\n";
print_r($bprovides);

?>

El resultado del ejemplo sería algo similar a:

El agente actual proporciona los siguientes entornos:
Array
(
    [0] => Array
        (
            [name] => aspell
            [desc] => Aspell Provider
            [file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [name] => hspell
            [desc] => Hspell Provider
            [file] => /usr/lib/enchant/libenchant_hspell.so
        )

    [2] => Array
        (
            [name] => ispell
            [desc] => Ispell Provider
            [file] => /usr/lib/enchant/libenchant_ispell.so
        )

    [3] => Array
        (
            [name] => myspell
            [desc] => Myspell Provider
            [file] => /usr/lib/enchant/libenchant_myspell.so
        )

)


Si existe o no un diccionario. Usando una etiqueta no vacía

  • « enchant_broker_describe
  • enchant_broker_free_dict »
  • PHP Manual
  • Funciones de Enchant
  • Si existe o no un diccionario. Usando una etiqueta no vacía

enchant_broker_dict_exists

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_dict_exists — Si existe o no un diccionario. Usando una etiqueta no vacía

Descripción

enchant_broker_dict_exists ( resource $broker , string $tag ) : bool

Indica si un diccionario existo o no, usando etiquetas no vacías

Parámetros

broker

Recurso de agente

tag

Etiqueta no vacía en el formato REGINAL, ej.: us_US, ch_DE, etc.

Valores devueltos

Devuelve true cuando existe la etiqueta o false cuando no.

Ejemplos

Ejemplo #1 Un ejemplo de enchant_broker_dict_exists()

<?php
$etiqueta = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$etiqueta)) {
    echo "Diccionario " . $etiqueta . " encontrado.\n";
}
?>

Ver también

  • enchant_broker_describe() - Enumera los proveedores de Enchant


Liberar un recurso de diccionario

  • « enchant_broker_dict_exists
  • enchant_broker_free »
  • PHP Manual
  • Funciones de Enchant
  • Liberar un recurso de diccionario

enchant_broker_free_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_free_dict — Liberar un recurso de diccionario

Descripción

enchant_broker_free_dict ( resource $dict ) : bool

Libera un recurso de diccionario.

Parámetros

dict

Recurso de diccionario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • enchant_broker_request_dict() - Crear un diccionario usanto una etiqueta
  • enchant_broker_request_pwl_dict() - Crea un diccionario usando un fichero PWL


Liberar el recurso de agente y sus diccionarios

  • « enchant_broker_free_dict
  • enchant_broker_get_dict_path »
  • PHP Manual
  • Funciones de Enchant
  • Liberar el recurso de agente y sus diccionarios

enchant_broker_free

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_free — Liberar el recurso de agente y sus diccionarios

Descripción

enchant_broker_free ( resource $broker ) : bool

Libera un recurso de agente con todos sus diccionarios.

Parámetros

broker

Recurso de agente

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • enchant_broker_init() - Crear un nuevo objeto agente capaz de hacer peticiones


Obtener la ruta del directorio para un 'backend' dado

  • « enchant_broker_free
  • enchant_broker_get_error »
  • PHP Manual
  • Funciones de Enchant
  • Obtener la ruta del directorio para un 'backend' dado

enchant_broker_get_dict_path

(PHP 5 >= 5.3.1, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_get_dict_path — Obtener la ruta del directorio para un 'backend' dado

Descripción

enchant_broker_get_dict_path ( resource $broker , int $dict_type ) : bool

Obtener la ruta del directorio para un 'backend' dado.

Parámetros

broker

El recurso de 'broker'.

dict_type

El tipo de diccionario, esto es, ENCHANT_MYSPELL o ENCHANT_ISPELL.

Valores devueltos

Devuelve la ruta del directorio del diccionario en caso de éxito o false en caso de error.

Ver también

  • enchant_broker_set_dict_path() - Establecer la ruta del directorio para un 'backend' dado


Devuelve el último error del agente

  • « enchant_broker_get_dict_path
  • enchant_broker_init »
  • PHP Manual
  • Funciones de Enchant
  • Devuelve el último error del agente

enchant_broker_get_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_get_error — Devuelve el último error del agente

Descripción

enchant_broker_get_error ( resource $broker ) : string

Devuelve el último error que ocurrión en este agente.

Parámetros

broker

Recurso de agente.

Valores devueltos

Devuelve la cadena de mensaje si se encontró un error o false


Crear un nuevo objeto agente capaz de hacer peticiones

  • « enchant_broker_get_error
  • enchant_broker_list_dicts »
  • PHP Manual
  • Funciones de Enchant
  • Crear un nuevo objeto agente capaz de hacer peticiones

enchant_broker_init

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_init — Crear un nuevo objeto agente capaz de hacer peticiones

Descripción

enchant_broker_init ( ) : resource

Parámetros

Valores devueltos

Devuelve un recurso de agente si se tuvo éxito o false.

Ver también

  • enchant_broker_free() - Liberar el recurso de agente y sus diccionarios


Devuelve una lista de los diccionarios disponibles

  • « enchant_broker_init
  • enchant_broker_request_dict »
  • PHP Manual
  • Funciones de Enchant
  • Devuelve una lista de los diccionarios disponibles

enchant_broker_list_dicts

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_list_dicts — Devuelve una lista de los diccionarios disponibles

Descripción

enchant_broker_list_dicts ( resource $broker ) : mixed

Devuelve una lista de los diccionarios disponibles con sus detalles.

Parámetros

broker

Recurso de agente

Valores devueltos

Devuelve un array de los diccionarios disponibles con sus detalles, o false en caso de error.

Ejemplos

Ejemplo #1 Listar todos los diccionarios disponibles para un agente

<?php
$r = enchant_broker_init();
$diccionarios = enchant_broker_list_dicts($r);
print_r($diccionarios);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [lang_tag] => de
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [lang_tag] => de_DE
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [3] => Array
        (
            [lang_tag] => en
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [4] => Array
        (
            [lang_tag] => en_GB
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [5] => Array
        (
            [lang_tag] => en_US
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [6] => Array
        (
            [lang_tag] => hi_IN
            [provider_name] => myspell
            [provider_desc] => Myspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

Ver también

  • enchant_broker_describe() - Enumera los proveedores de Enchant


Crear un diccionario usanto una etiqueta

  • « enchant_broker_list_dicts
  • enchant_broker_request_pwl_dict »
  • PHP Manual
  • Funciones de Enchant
  • Crear un diccionario usanto una etiqueta

enchant_broker_request_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_request_dict — Crear un diccionario usanto una etiqueta

Descripción

enchant_broker_request_dict ( resource $broker , string $tag ) : resource

Crea un diccionario usando una etiqueta no vacía que se desea para solicitar un diccionario ("en_US", "de_DE", ...)

Parámetros

broker

Recurso de agente

tag

Una etiqueta que describe la configuración regional, por ejemplo en_US, de_DE

Valores devueltos

Devuelve un recurso de diccionario si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de enchant_broker_request_dict()

Comprobar si existe un diccionario usando enchant_broker_dict_exists() y solicitarlo.

<?php
$etiqueta = 'en_US';
$agente = enchant_broker_init();
if (enchant_broker_dict_exists($agente,$etiqueta)) {
    $diccionario = enchant_broker_request_dict($r, $etiqueta);
}
?>

Ver también

  • enchant_dict_describe() - Describe un diccionario individual
  • enchant_broker_dict_exists() - Si existe o no un diccionario. Usando una etiqueta no vacía
  • enchant_broker_free_dict() - Liberar un recurso de diccionario


Crea un diccionario usando un fichero PWL

  • « enchant_broker_request_dict
  • enchant_broker_set_dict_path »
  • PHP Manual
  • Funciones de Enchant
  • Crea un diccionario usando un fichero PWL

enchant_broker_request_pwl_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_request_pwl_dict — Crea un diccionario usando un fichero PWL

Descripción

enchant_broker_request_pwl_dict ( resource $broker , string $filename ) : resource

Crea un diccionario usando un fichero PWL. Un fichero PWL es un fichero personal de palabras con una palabra por línea.

Parámetros

broker

Recurso de agente

filename

Ruta al fichero PWL. Si no existe tal fichero, se creará uno nuevo si es posible.

Valores devueltos

Devuelve un recurso de diccionario si se tuvo éxito o false en caso de error.

Ver también

  • enchant_dict_describe() - Describe un diccionario individual
  • enchant_broker_dict_exists() - Si existe o no un diccionario. Usando una etiqueta no vacía
  • enchant_broker_free_dict() - Liberar un recurso de diccionario


Establecer la ruta del directorio para un 'backend' dado

  • « enchant_broker_request_pwl_dict
  • enchant_broker_set_ordering »
  • PHP Manual
  • Funciones de Enchant
  • Establecer la ruta del directorio para un 'backend' dado

enchant_broker_set_dict_path

(PHP 5 >= 5.3.1, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_set_dict_path — Establecer la ruta del directorio para un 'backend' dado

Descripción

enchant_broker_set_dict_path ( resource $broker , int $dict_type , string $value ) : bool

Establecer la ruta del directorio para un 'backend' dado.

Parámetros

broker

El recurso de 'broker'.

dict_type

El tipo de diccionario, esto es, ENCHANT_MYSPELL o ENCHANT_ISPELL.

value

La ruta de directorio del diccionario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • enchant_broker_get_dict_path() - Obtener la ruta del directorio para un 'backend' dado


Declara una preferencia de diccionarios a usar para el lenguaje

  • « enchant_broker_set_dict_path
  • enchant_dict_add_to_personal »
  • PHP Manual
  • Funciones de Enchant
  • Declara una preferencia de diccionarios a usar para el lenguaje

enchant_broker_set_ordering

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_set_ordering — Declara una preferencia de diccionarios a usar para el lenguaje

Descripción

enchant_broker_set_ordering ( resource $broker , string $tag , string $ordering ) : bool

Declara una preferencia de diccionarios a usar para el lenguaje descrito/referido por 'tag'. El orden es una lista delimitada por comas de nombres de proveedores. Como excepción especial, la etiqueta (tag) "*" se puede usar como una etiqueta de lenguaje para declarar un orden predeterminado para cualquier lenguaje que no declare explícitamente un orden.

Parámetros

broker

Recurso de agente

tag

Etiqueta de lenguaje. La etiqueta especial "*" se puede usar como una etiqueta de lenguaje para declarar un orden predeterminado para cualquier lenguaje que no declare explícitamente un orden.

ordering

Lista delimitada por comas de nombres de proveedores

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Añadir una palabra a una lista personal de palabras

  • « enchant_broker_set_ordering
  • enchant_dict_add_to_session »
  • PHP Manual
  • Funciones de Enchant
  • Añadir una palabra a una lista personal de palabras

enchant_dict_add_to_personal

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_add_to_personal — Añadir una palabra a una lista personal de palabras

Descripción

enchant_dict_add_to_personal ( resource $dict , string $word ) : void

Añade una palabra a una lista personal de palabras del diccionario dado.

Parámetros

dict

Recurso de diccionario

word

La palabra a añadir

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplo #1 Añadir una palabra a un PWL

<?php

$filename = './my_word_list.pwl';
$word = 'Supercalifragilisticexpialidocious';

$broker = enchant_broker_init();
$dict = enchant_broker_request_pwl_dict($broker, $filename);

enchant_dict_add_to_personal($dict, $word);

enchant_broker_free($broker);

?>

Ver también

  • enchant_broker_request_pwl_dict() - Crea un diccionario usando un fichero PWL
  • enchant_broker_request_dict() - Crear un diccionario usanto una etiqueta


Añadir una palabra a esta sesión ortográfica

  • « enchant_dict_add_to_personal
  • enchant_dict_add »
  • PHP Manual
  • Funciones de Enchant
  • Añadir una palabra a esta sesión ortográfica

enchant_dict_add_to_session

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_add_to_session — Añadir una palabra a esta sesión ortográfica

Descripción

enchant_dict_add_to_session ( resource $dict , string $word ) : void

Añade una palabra al diccionario dado. Sólo será añadida para la sesión ortográfica activa.

Parámetros

dict

Recurso de diccionario

word

La palabra a añadir

Valores devueltos

No devuelve ningún valor.

Ver también

  • enchant_broker_request_dict() - Crear un diccionario usanto una etiqueta


Add a word to personal word list

  • « enchant_dict_add_to_session
  • enchant_dict_check »
  • PHP Manual
  • Funciones de Enchant
  • Add a word to personal word list

enchant_dict_add

(PHP 8)

enchant_dict_add — Add a word to personal word list

Descripción

enchant_dict_add ( EnchantDictionary $dictionary , string $word ) : void

Add a word to personal word list of the given dictionary.

Parámetros

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to add

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a recurso was expected.

Ejemplo #1 Adding a word to a PWL

<?php

$filename = './my_word_list.pwl';
$word = 'Supercalifragilisticexpialidocious';

$broker = enchant_broker_init();
$dict = enchant_broker_request_pwl_dict($broker, $filename);

enchant_dict_add($dict, $word);

enchant_broker_free($broker);

?>

Ver también

  • enchant_broker_request_pwl_dict() - Crea un diccionario usando un fichero PWL
  • enchant_broker_request_dict() - Crear un diccionario usanto una etiqueta


Comprobar si una palabra está correctamente escrita o no

  • « enchant_dict_add
  • enchant_dict_describe »
  • PHP Manual
  • Funciones de Enchant
  • Comprobar si una palabra está correctamente escrita o no

enchant_dict_check

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_check — Comprobar si una palabra está correctamente escrita o no

Descripción

enchant_dict_check ( resource $dict , string $word ) : bool

Si la palabra está correctamente escrita se devuelve true, de otro modo se devuelve false

Parámetros

dict

Recurso de diccionario

word

La palabra a comprobar

Valores devueltos

Devuelve true si la palabra está correctamente escrita, false si no.


Describe un diccionario individual

  • « enchant_dict_check
  • enchant_dict_get_error »
  • PHP Manual
  • Funciones de Enchant
  • Describe un diccionario individual

enchant_dict_describe

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_describe — Describe un diccionario individual

Descripción

enchant_dict_describe ( resource $dict ) : mixed

Devuelve los detalles del diccionario.

Parámetros

dict

Recurso de diccionario

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de enchant_dict_describe()

Comprobar si un diccionario existe usando enchant_broker_dict_exists() y mostrar los detalles de éste.

<?php
$etiqueta = 'en_US';
$agente = enchant_broker_init();
if (enchant_broker_dict_exists($agente,$etiqueta)) {
    $diccionario = enchant_broker_request_dict($r, $etiqueta);
    $detalles_dicc = enchant_dict_describe($diccionario);
    print_r($detalles_dicc);
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [lang] => en_US
    [name] => aspell
    [desc] => Aspell Provider
    [file] => /usr/lib/enchant/libenchant_aspell.so
)


Devuelve el último error de la sesión ortográfica actual

  • « enchant_dict_describe
  • enchant_dict_is_added »
  • PHP Manual
  • Funciones de Enchant
  • Devuelve el último error de la sesión ortográfica actual

enchant_dict_get_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_get_error — Devuelve el último error de la sesión ortográfica actual

Descripción

enchant_dict_get_error ( resource $dict ) : string

Devuelve el último error de la sesión ortográfica actual

Parámetros

dict

Recurso de diccionario

Valores devueltos

Devuelve un mensaje de error como cadena o false si no se produjo ningún error.


Whether or not 'word' exists in this spelling-session

  • « enchant_dict_get_error
  • enchant_dict_is_in_session »
  • PHP Manual
  • Funciones de Enchant
  • Whether or not 'word' exists in this spelling-session

enchant_dict_is_added

(PHP 8)

enchant_dict_is_added — Whether or not 'word' exists in this spelling-session

Descripción

enchant_dict_is_added ( EnchantDictionary $dictionary , string $word ) : bool

Tells whether or not a word already exists in the current session.

Parámetros

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to lookup

Valores devueltos

Returns true if the word exists or false

Historial de cambios

Versión | Descripción
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a recurso was expected.

Ver también

  • enchant_dict_add_to_session() - Añadir una palabra a esta sesión ortográfica


Si existe o no una palabra en esta sesión ortográfica

  • « enchant_dict_is_added
  • enchant_dict_quick_check »
  • PHP Manual
  • Funciones de Enchant
  • Si existe o no una palabra en esta sesión ortográfica

enchant_dict_is_in_session

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_is_in_session — Si existe o no una palabra en esta sesión ortográfica

Descripción

enchant_dict_is_in_session ( resource $dict , string $word ) : bool

Indica si una palabra ya existe en la sesión actual.

Parámetros

dict

Recurso de diccionario

word

La palabra a buscar

Valores devueltos

Devuelve true si la palabra exsite o false

Ver también

  • enchant_dict_add_to_session() - Añadir una palabra a esta sesión ortográfica


Verifica si la palabra está correctamente escrita y proporciona sugerencias

  • « enchant_dict_is_in_session
  • enchant_dict_store_replacement »
  • PHP Manual
  • Funciones de Enchant
  • Verifica si la palabra está correctamente escrita y proporciona sugerencias

enchant_dict_quick_check

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant:0.2.0-1.0.1)

enchant_dict_quick_check — Verifica si la palabra está correctamente escrita y proporciona sugerencias

Descripción

enchant_dict_quick_check ( resource $dict , string $word , array &$suggestions = ? ) : bool

Si la palabra está correctamente escrita devuelve true, de otro modo devuelve false, si la varialbe de sugerencias se proporciona, la rellena con alternativas ortográficas.

Parámetros

dict

Recurso de diccionario

word

La palabra a verificar

suggestions

Si la palabra no está correctamente escrita, está variable contendrá una matriz de sugerencias.

Valores devueltos

Devuelve true si la palabra está correctamente escrita o false

Ejemplos

Ejemplo #1 Un ejemplo de enchant_dict_quick_check()

<?php
$etiqueta = 'en_US';
$r = enchant_broker_init();

if (enchant_broker_dict_exists($r,$etiqueta)) {
    $d = enchant_broker_request_dict($r, $etiqueta);
    enchant_dict_quick_check($d, 'soong', $sugerencias);
    print_r($sugerencias);
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => song
    [1] => snog
    [2] => soon
    [3] => Sang
    [4] => Sung
    [5] => sang
    [6] => sung
    [7] => sponge
    [8] => spongy
    [9] => snag
    [10] => snug
    [11] => sonic
    [12] => sing
    [13] => songs
    [14] => Son
    [15] => Sonja
    [16] => Synge
    [17] => son
    [18] => Sejong
    [19] => sarong
    [20] => sooner
    [21] => Sony
    [22] => sown
    [23] => scone
    [24] => song's
)

Ver también

  • enchant_dict_check() - Comprobar si una palabra está correctamente escrita o no
  • enchant_dict_suggest() - Devolverá una lista de valores si no se reúnen esas pre-condiciones


Añadir una corrección a una palabra

  • « enchant_dict_quick_check
  • enchant_dict_suggest »
  • PHP Manual
  • Funciones de Enchant
  • Añadir una corrección a una palabra

enchant_dict_store_replacement

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_store_replacement — Añadir una corrección a una palabra

Descripción

enchant_dict_store_replacement ( resource $dict , string $mis , string $cor ) : void

Añade una corrección a 'mis' usando 'cor'. Observe que se reemplaza @mis por @cor, por lo que es posible que algunas incidencias futuras de @mis sean reemplazadas por @cor. Así se podría subir @cor en la lista de sugerencias.

Parámetros

dict

Recurso de diccionario

mis

La palabra a corregir

cor

La palabra corregida

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devolverá una lista de valores si no se reúnen esas pre-condiciones

  • « enchant_dict_store_replacement
  • Gender »
  • PHP Manual
  • Funciones de Enchant
  • Devolverá una lista de valores si no se reúnen esas pre-condiciones

enchant_dict_suggest

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_suggest — Devolverá una lista de valores si no se reúnen esas pre-condiciones

Descripción

enchant_dict_suggest ( resource $dict , string $word ) : array

Parámetros

dict

Recurso de diccionario

word

Palabra a usar para las sugerencias.

Valores devueltos

Devolverá una matriz de sugerencias si la palabra está mal escrita.

Ejemplos

Ejemplo #1 Un ejemplo de enchant_dict_suggest()

<?php
$etiqueta = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$etiqueta)) {
    $d = enchant_broker_request_dict($r, $etiqueta);

    $palabra_correcta = enchant_dict_check($d, "soong");
    if (!$palabra_correcta) {
        $sugerencias = enchant_dict_suggest($d, "soong");
        echo "Sugerencias para 'soong':";
        print_r($sugerencias);
    }
    enchant_broker_free_dict($d);
}
enchant_broker_free($r);
?>

Ver también

  • enchant_dict_check() - Comprobar si una palabra está correctamente escrita o no
  • enchant_dict_quick_check() - Verifica si la palabra está correctamente escrita y proporciona sugerencias


Determinar el género de un nombre

  • Introducción
  • Instalación/Configuración
    • Instalación
  • Ejemplos
    • Ejemplo de uso.
  • Gender\Gender — La clase Gender\Gender
    • Gender\Gender::connect — Conecta con un diccionario de nombres externo
    • Gender\Gender::__construct — Construye un objeto Gender
    • Gender\Gender::country — Obtener la representación textual de un país
    • Gender\Gender::get — Obtener el género de un nombre
    • Gender\Gender::isNick — Comprueba si name0 es un alias de name1
    • Gender\Gender::similarNames — Obtener nombres similares


Introducción

La extensión Gender de PHP es un port del programa gender.c escrito originalmente por Joerg Michael. El propósito principal es averiguar el género de un nombre de pila. La base de datos principal contiene >40000 nombres de 54 países.


  • « Introducción
  • Instalación »
  • PHP Manual
  • Gender
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Instalación


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/gender.

Está disponible un DLL para esta extensión de PECL en » http://windows.php.net/downloads/pecl/releases/gender/.


  • « Instalación
  • Ejemplo de uso. »
  • PHP Manual
  • Gender
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplo de uso.


Ejemplo de uso.

Ejemplo de uso de la clase Gender.

Ejemplo #1 Ejemplo de uso.

<?php

namespace Gender;

$género = new Gender;

$nombre = "Milene";
$país = Gender::FRANCE;

$resultado = $género->get($nombre, $país);

$datos = $género->country($país);

switch($resultado) {
    case Gender::IS_FEMALE:
        printf("El nombre %s es femenino en %s\n", $nombre, $datos['country']);
    break;

    case Gender::IS_MOSTLY_FEMALE:
        printf("El nombre %s es habitualmente femenino en %s\n", $nombre, $datos['country']);
    break;

    case Gender::IS_MALE:
        printf("El nombre %s es masculino en %s\n", $nombre, $datos['country']);
    break;

    case Gender::IS_MOSTLY_MALE:
        printf("El nombre %s es habitualmente masculino en %s\n", $nombre, $datos['country']);
    break;

    case Gender::IS_UNISEX_NAME:
        printf("El nombre %s es unisex en %s\n", $nombre, $datos['country']);
    break;

    case Gender::IS_A_COUPLE:
        printf("El nombre %s es masculino y femenino en %s\n", $nombre, $datos['country']);
    break;

    case Gender::NAME_NOT_FOUND:
        printf("El nombre %s no se encontró en %s\n", $nombre, $datos['country']);
    break;

    case Gender::ERROR_IN_NAME:
        echo "¡Hay un error con el nombre proporcionado!\n";
    break;

    default:
        echo "¡Ocurrió un error!\n";
    break;

}


La clase Gender\Gender

(PECL gender >= 0.6.0)

Introducción

Sinopsis de la Clase

Gender\Gender {
/* Constantes */
const integer IS_FEMALE = 70 ;
const integer IS_MOSTLY_FEMALE = 102 ;
const integer IS_MALE = 77 ;
const integer IS_MOSTLY_MALE = 109 ;
const integer IS_UNISEX_NAME = 63 ;
const integer IS_A_COUPLE = 67 ;
const integer NAME_NOT_FOUND = 32 ;
const integer ERROR_IN_NAME = 69 ;
const integer ANY_COUNTRY = 0 ;
const integer BRITAIN = 1 ;
const integer IRELAND = 2 ;
const integer USA = 3 ;
const integer SPAIN = 4 ;
const integer PORTUGAL = 5 ;
const integer ITALY = 6 ;
const integer MALTA = 7 ;
const integer FRANCE = 8 ;
const integer BELGIUM = 9 ;
const integer LUXEMBOURG = 10 ;
const integer NETHERLANDS = 11 ;
const integer GERMANY = 12 ;
const integer EAST_FRISIA = 13 ;
const integer AUSTRIA = 14 ;
const integer SWISS = 15 ;
const integer ICELAND = 16 ;
const integer DENMARK = 17 ;
const integer NORWAY = 18 ;
const integer SWEDEN = 19 ;
const integer FINLAND = 20 ;
const integer ESTONIA = 21 ;
const integer LATVIA = 22 ;
const integer LITHUANIA = 23 ;
const integer POLAND = 24 ;
const integer CZECH_REP = 25 ;
const integer SLOVAKIA = 26 ;
const integer HUNGARY = 27 ;
const integer ROMANIA = 28 ;
const integer BULGARIA = 29 ;
const integer BOSNIA = 30 ;
const integer CROATIA = 31 ;
const integer KOSOVO = 32 ;
const integer MACEDONIA = 33 ;
const integer MONTENEGRO = 34 ;
const integer SERBIA = 35 ;
const integer SLOVENIA = 36 ;
const integer ALBANIA = 37 ;
const integer GREECE = 38 ;
const integer RUSSIA = 39 ;
const integer BELARUS = 40 ;
const integer MOLDOVA = 41 ;
const integer UKRAINE = 42 ;
const integer ARMENIA = 43 ;
const integer AZERBAIJAN = 44 ;
const integer GEORGIA = 45 ;
const integer KAZAKH_UZBEK = 46 ;
const integer TURKEY = 47 ;
const integer ARABIA = 48 ;
const integer ISRAEL = 49 ;
const integer CHINA = 50 ;
const integer INDIA = 51 ;
const integer JAPAN = 52 ;
const integer KOREA = 53 ;
/* Métodos */
public connect ( string $dsn ) : boolean
public Gender\\Gender::__construct ( string $dsn = ? )
public country ( integer $country ) : array
public get ( string $name , integer $country = ? ) : integer
public isNick ( string $name0 , string $name1 , integer $country = ? ) : array
public similarNames ( string $name , integer $country = ? ) : array
}

Constantes predefinidas

Gender\Gender::IS_FEMALE

Gender\Gender::IS_MOSTLY_FEMALE

Gender\Gender::IS_MALE

Gender\Gender::IS_MOSTLY_MALE

Gender\Gender::IS_UNISEX_NAME

Gender\Gender::IS_A_COUPLE

Gender\Gender::NAME_NOT_FOUND

Gender\Gender::ERROR_IN_NAME

Gender\Gender::ANY_COUNTRY

Gender\Gender::BRITAIN

Gender\Gender::IRELAND

Gender\Gender::USA

Gender\Gender::SPAIN

Gender\Gender::PORTUGAL

Gender\Gender::ITALY

Gender\Gender::MALTA

Gender\Gender::FRANCE

Gender\Gender::BELGIUM

Gender\Gender::LUXEMBOURG

Gender\Gender::NETHERLANDS

Gender\Gender::GERMANY

Gender\Gender::EAST_FRISIA

Gender\Gender::AUSTRIA

Gender\Gender::SWISS

Gender\Gender::ICELAND

Gender\Gender::DENMARK

Gender\Gender::NORWAY

Gender\Gender::SWEDEN

Gender\Gender::FINLAND

Gender\Gender::ESTONIA

Gender\Gender::LATVIA

Gender\Gender::LITHUANIA

Gender\Gender::POLAND

Gender\Gender::CZECH_REP

Gender\Gender::SLOVAKIA

Gender\Gender::HUNGARY

Gender\Gender::ROMANIA

Gender\Gender::BULGARIA

Gender\Gender::BOSNIA

Gender\Gender::CROATIA

Gender\Gender::KOSOVO

Gender\Gender::MACEDONIA

Gender\Gender::MONTENEGRO

Gender\Gender::SERBIA

Gender\Gender::SLOVENIA

Gender\Gender::ALBANIA

Gender\Gender::GREECE

Gender\Gender::RUSSIA

Gender\Gender::BELARUS

Gender\Gender::MOLDOVA

Gender\Gender::UKRAINE

Gender\Gender::ARMENIA

Gender\Gender::AZERBAIJAN

Gender\Gender::GEORGIA

Gender\Gender::KAZAKH_UZBEK

Gender\Gender::TURKEY

Gender\Gender::ARABIA

Gender\Gender::ISRAEL

Gender\Gender::CHINA

Gender\Gender::INDIA

Gender\Gender::JAPAN

Gender\Gender::KOREA

Tabla de contenidos

  • Gender\Gender::connect — Conecta con un diccionario de nombres externo
  • Gender\Gender::__construct — Construye un objeto Gender
  • Gender\Gender::country — Obtener la representación textual de un país
  • Gender\Gender::get — Obtener el género de un nombre
  • Gender\Gender::isNick — Comprueba si name0 es un alias de name1
  • Gender\Gender::similarNames — Obtener nombres similares


Conecta con un diccionario de nombres externo

  • « Gender\Gender
  • Gender\Gender::__construct »
  • PHP Manual
  • Gender\Gender
  • Conecta con un diccionario de nombres externo

Gender\Gender::connect

(PECL gender >= 0.6.0)

Gender\Gender::connect — Conecta con un diccionario de nombres externo

Descripción

public Gender\Gender::connect ( string $dsn ) : boolean

Conectar con un diccionario de nombres externo. Actualmente sólo las streams están soportadas.

Parámetros

dsn

DSN (Data Source Name) a abrir.

Valores devueltos

Boolean que indica resultado correcto o fallo.


Construye un objeto Gender

  • « Gender\Gender::connect
  • Gender\Gender::country »
  • PHP Manual
  • Gender\Gender
  • Construye un objeto Gender

Gender\Gender::__construct

(PECL gender >= 0.6.0)

Gender\Gender::__construct — Construye un objeto Gender

Descripción

public Gender\\Gender::__construct ( string $dsn = ? )

Crea un objeto Gender conectando opcionalmente con un diccionario de nombres externo. Cuando no se indica una base de datos externa, los datos integrados serán utilizados.

Parámetros

dsn

DSN (Data Source Name) a abrir.

Valores devueltos


Obtener la representación textual de un país

  • « Gender\Gender::__construct
  • Gender\Gender::get »
  • PHP Manual
  • Gender\Gender
  • Obtener la representación textual de un país

Gender\Gender::country

(PECL gender >= 0.8.0)

Gender\Gender::country — Obtener la representación textual de un país

Descripción

public Gender\Gender::country ( integer $country ) : array

Devuelve la representación textual de un país a partir de una constante de la clase Gender.

Parámetros

country

La ID de un país especificada como constante de la clase Gender\Gender.

Valores devueltos

Devuelve un array con los nombres corto y largo de un país en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso de Gender\Gender::country()

$gender = new Gender\Gender;
var_dump($gender->country(Gender\Gender::BRITAIN));

El resultado del ejemplo sería:

array(2) {
  'country_short' =>
  string(2) "UK"
  'country' =>
  string(13) "Great Britain"
}


Obtener el género de un nombre

  • « Gender\Gender::country
  • Gender\Gender::isNick »
  • PHP Manual
  • Gender\Gender
  • Obtener el género de un nombre

Gender\Gender::get

(PECL gender >= 0.6.0)

Gender\Gender::get — Obtener el género de un nombre

Descripción

public Gender\Gender::get ( string $name , integer $country = ? ) : integer

Obtener el género de un nombre en un país concreto.

Parámetros

name

Nombre a comprobar.

country

ID del país como constante de la clase Gender.

Valores devueltos

Devuelve el género de un nombre.


Comprueba si name0 es un alias de name1

  • « Gender\Gender::get
  • Gender\Gender::similarNames »
  • PHP Manual
  • Gender\Gender
  • Comprueba si name0 es un alias de name1

Gender\Gender::isNick

(PECL gender >= 0.9.0)

Gender\Gender::isNick — Comprueba si name0 es un alias de name1

Descripción

public Gender\Gender::isNick ( string $name0 , string $name1 , integer $country = ? ) : array

Comprueba si name0 es un alias de name1.

Parámetros

name0

El nombre a comprobar.

name1

El nombre a comprobar.

country

El Id del país identificado por una constante la clase Gender. Si se omite, se usa ANY_COUNTRY.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener nombres similares

  • « Gender\Gender::isNick
  • Gettext »
  • PHP Manual
  • Gender\Gender
  • Obtener nombres similares

Gender\Gender::similarNames

(PECL gender >= 0.9.0)

Gender\Gender::similarNames — Obtener nombres similares

Descripción

public Gender\Gender::similarNames ( string $name , integer $country = ? ) : array

Obtiene nombres similares para el nombre y el país dado.

Parámetros

name

El nombre a comprobar.

country

El Id del país identificado por una constante la clase Gender. Si se omite, se usa ANY_COUNTRY.

Valores devueltos

Devuelve un array con los nombres similares encontrados.


Gettext

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Gettext
    • bind_textdomain_codeset — Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos
    • bindtextdomain — Establece la ruta del dominio
    • dcgettext — Sobrescribe el dominio de la búsqueda única del mensaje
    • dcngettext — Versión plural de dcgettext
    • dgettext — Sobrescribe el dominio actual
    • dngettext — Versión plural de dgettext
    • gettext — Consultar un mensaje en el dominio actual
    • ngettext — Versión plural de gettext
    • textdomain — Establece el dominio actual


Introducción

Las funciones de gettext implementan una API de Soporte de Lenguaje Nativo (NLS de las siglas en inglés Native Language Support) la cual se puede utilizar para internacionalizar las aplicaciones de PHP. Por favor, consulte la documentación de gettext para su sistema para obtener una explicación detallada de estas funciones o vea la documentación en » http://www.gnu.org/software/gettext/manual/gettext.html.


Requerimientos

Para utilizar las funciones debe descargar e instalar el paquete GNU gettext en » http://www.gnu.org/software/gettext/gettext.html


Instalación

Para incluir soporte para GNU gettext en su instalación de PHP, debe añadir la opción --with-gettext[=DIR] donde DIR es el directorio de la instalación de gettext, por omisión es /usr/local.


  • « Tipos de recursos
  • Funciones de Gettext »
  • PHP Manual
  • Gettext
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Gettext

Tabla de contenidos

  • bind_textdomain_codeset — Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos
  • bindtextdomain — Establece la ruta del dominio
  • dcgettext — Sobrescribe el dominio de la búsqueda única del mensaje
  • dcngettext — Versión plural de dcgettext
  • dgettext — Sobrescribe el dominio actual
  • dngettext — Versión plural de dgettext
  • gettext — Consultar un mensaje en el dominio actual
  • ngettext — Versión plural de gettext
  • textdomain — Establece el dominio actual


Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos

  • « Funciones de Gettext
  • bindtextdomain »
  • PHP Manual
  • Funciones de Gettext
  • Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos

bind_textdomain_codeset

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

bind_textdomain_codeset — Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos

Descripción

bind_textdomain_codeset ( string $domain , string $codeset ) : string

Con bind_textdomain_codeset(), se establece la codificación de los mensajes que serán devueltos desde el domain por gettext() y funciones similares.

Parámetros

domain

El dominio

codeset

El juego de caracteres

Valores devueltos

Un string si es correcto.


Establece la ruta del dominio

  • « bind_textdomain_codeset
  • dcgettext »
  • PHP Manual
  • Funciones de Gettext
  • Establece la ruta del dominio

bindtextdomain

(PHP 4, PHP 5, PHP 7, PHP 8)

bindtextdomain — Establece la ruta del dominio

Descripción

bindtextdomain ( string $domain , string $directory ) : string

La función bindtextdomain() establece la ruta para el dominio.

Parámetros

domain

El dominio

directory

La ruta del directorio

Valores devueltos

La ruta completa para el domain actual establecido.

Ejemplos

Ejemplo #1 Ejemplo de bindtextdomain()

<?php

$domain = 'myapp';
echo bindtextdomain($domain, '/usr/share/myapp/locale');

?>

El resultado del ejemplo sería:

/usr/share/myapp/locale


Sobrescribe el dominio de la búsqueda única del mensaje

  • « bindtextdomain
  • dcngettext »
  • PHP Manual
  • Funciones de Gettext
  • Sobrescribe el dominio de la búsqueda única del mensaje

dcgettext

(PHP 4, PHP 5, PHP 7, PHP 8)

dcgettext — Sobrescribe el dominio de la búsqueda única del mensaje

Descripción

dcgettext ( string $domain , string $message , int $category ) : string

Esta función le permite sobrescribir el dominio actual para una búsqueda unica del mensaje.

Parámetros

domain

El dominio

message

El mesanje

category

La categoría

Valores devueltos

Un string si es correcto.

Ver también

  • gettext() - Consultar un mensaje en el dominio actual


Versión plural de dcgettext

  • « dcgettext
  • dgettext »
  • PHP Manual
  • Funciones de Gettext
  • Versión plural de dcgettext

dcngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

dcngettext — Versión plural de dcgettext

Descripción

dcngettext ( string $domain , string $msgid1 , string $msgid2 , int $n , int $category ) : string

Esta función le permite sobrescribir el dominio actual en una búsqueda en un mensaje único.

Parámetros

domain

The domain

msgid1

msgid2

n

category

Valores devueltos

Un string si es correcto.

Ver también

  • ngettext() - Versión plural de gettext


Sobrescribe el dominio actual

  • « dcngettext
  • dngettext »
  • PHP Manual
  • Funciones de Gettext
  • Sobrescribe el dominio actual

dgettext

(PHP 4, PHP 5, PHP 7, PHP 8)

dgettext — Sobrescribe el dominio actual

Descripción

dgettext ( string $domain , string $message ) : string

La función dgettext() le permite sobrescribir el domain actual en una búsqueda en un mensaje único.

Parámetros

domain

El dominio

message

El mensaje

Valores devueltos

Un string si es correcto.

Ver también

  • gettext() - Consultar un mensaje en el dominio actual


Versión plural de dgettext

  • « dgettext
  • gettext »
  • PHP Manual
  • Funciones de Gettext
  • Versión plural de dgettext

dngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

dngettext — Versión plural de dgettext

Descripción

dngettext ( string $domain , string $msgid1 , string $msgid2 , int $n ) : string

La función dngettext() le permite sobrescribir el domain actual en una búsqueda en un mensaje único en plural.

Parámetros

domain

El dominio

msgid1

msgid2

n

Valores devueltos

Un string si es correcto.

Ver también

  • ngettext() - Versión plural de gettext


Consultar un mensaje en el dominio actual

  • « dngettext
  • ngettext »
  • PHP Manual
  • Funciones de Gettext
  • Consultar un mensaje en el dominio actual

gettext

(PHP 4, PHP 5, PHP 7, PHP 8)

gettext — Consultar un mensaje en el dominio actual

Descripción

gettext ( string $message ) : string

Busca un mensaje en el dominio actual.

Parámetros

message

El mensaje se está traduciendo.

Valores devueltos

Devuelve un string traducido si se encuentra en la tabla de traducciones, o envia el mensaje si no es encontrado.

Ejemplos

Ejemplo #1 gettext()-check

<?php
// Configurar idioma en Alemán
putenv('LC_ALL=de_DE');
setlocale(LC_ALL, 'de_DE');

// Especifica la ubicación de la tabla de traducciones
bindtextdomain("myPHPApp", "./locale");

// Seleccionar dominio
textdomain("myPHPApp");

// Ahora las traducciones se encuentran en ./locale/de_DE/LC_MESSAGES/myPHPApp.mo

// Imprimir un mensaje de prueba
echo gettext("Bienvenido a mi aplicación en PHP");

// O use un alias _() para gettext()
echo _("¡Qué tenga un buen día!");
?>

Notas

Nota:

Utilice el carácter de subrayado '_' como un alias en esta función.

Nota:

Configurar el idioma no es suficiente en algunos sistema y putenv() debe ser usado para establecer el idioma actual.

Ver también

  • setlocale() - Establecer la información del localismo


Versión plural de gettext

  • « gettext
  • textdomain »
  • PHP Manual
  • Funciones de Gettext
  • Versión plural de gettext

ngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ngettext — Versión plural de gettext

Descripción

ngettext ( string $msgid1 , string $msgid2 , int $n ) : string

La versión plural de gettext(). En algunos idiomas se tiene más de una forma para el mensaje en plural dependiendo de la cantidad.

Parámetros

msgid1

msgid2

n

Valores devueltos

Devuelve la correcta forma plural del mensaje identificados por mensaje1 y mensaje2 para el conteo en n.

Ejemplos

Ejemplo #1 Ejemplo de ngettext()

<?php

setlocale(LC_ALL, 'cs_CZ');
printf(ngettext("%d ventana", "%d ventanas", 1), 1); // 1 okno
printf(ngettext("%d ventana", "%d ventanas", 2), 2); // 2 okna
printf(ngettext("%d ventana", "%d ventanas", 5), 5); // 5 oken

?>


Establece el dominio actual

  • « ngettext
  • iconv »
  • PHP Manual
  • Funciones de Gettext
  • Establece el dominio actual

textdomain

(PHP 4, PHP 5, PHP 7, PHP 8)

textdomain — Establece el dominio actual

Descripción

textdomain ( string $text_domain ) : string

Esta función establece el dominio en el que se realizarán las búsquedas llamadas por gettext(), normalemente por el nombre de la aplicación.

Parámetros

text_domain

El nuevo mensaje del dominio, o null para obtener el valor actual y no cambiarlo

Valores devueltos

Si es correcto, esta función devuelve el dominio del mensaje actual, después de cambiarlo.


iconv

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de iconv
    • iconv_get_encoding — Recupera variables de configuración interna de la extensión iconv
    • iconv_mime_decode_headers — Decodifica varios campos de cabeceras MIME en la misma llamada
    • iconv_mime_decode — Decodifica un campo de la cabecera MIME
    • iconv_mime_encode — Compone un campo de cabecera MIME
    • iconv_set_encoding — Establece las opciones para la conversión de codificación de caracteres
    • iconv_strlen — Retorna el número de caracteres de un string
    • iconv_strpos — Encuentra la posición de la primera aparición de una aguja en un pajar
    • iconv_strrpos — Busca la última aparición de un string
    • iconv_substr — Elimina parte del string
    • iconv — Convierte un string a la codificación de caracteres indicada
    • ob_iconv_handler — Convierte la codificación de caracteres al manejador del buffer de salida


Introducción

Este módulo contiene de un interfaz a la utilidad de conversión de conjuntos de caracteres iconv. Con este módulo se puede convertir un string representado por un conjunto de caracteres local en uno representado por otro conjunto de caracteres, el cual puede ser el conjunto de caracteres Unicode. Los conjuntos de caracteres admitidos dependen de la implemtación de iconv del sistema. Observe que en algunos sistemas, la función iconv puede funcionar de forma inesperada. En este caso, es recomendable instalar la biblioteca » GNU libiconv con la que generalmente se suelen obtener mejores resultados finales.

Desde PHP 5.0.0, esta extensión tiene varias funciones de utilidad que ayudan a escribir scripts multilingües. En las siguientes secciones se exploran estas nuevas características.


Requerimientos

No es necesario realizar ninguna configuración si el sistema es uno de los sistemas recientes que cumplen POSIX porque las liberías de C estándar suministradas en ellos deben proveer de funcionalidades iconv. De lo contrario, es necesario tener las librerías » libiconv instaladas en el sistema.


Instalación

Esta extensión está activada por defecto, aunque puede desactivarse al compilar con --without-iconv

La directiva opcional --with-iconv-dir se usa para especificar la localización de iconv en los sistemas que PHP está siendo compilado. De otro modo, se busca en los directorios por defecto.

Nota: Nota para los usuario de PHP 4
Para activar esta extensión se requiere compilar con la opción --with-iconv=[DIR], o los usuarios de Windows pueden activarlo localizando iconv.dll en uno de los directorios dentro del PATH del sistema y activando php_iconv.dll en php.ini.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Iconv
Nombre | Por defecto | Cambiable | Historial de cambios
iconv.input_encoding | "ISO-8859-1" | PHP_INI_ALL | Obsoleta desde PHP 5.6.0.
iconv.output_encoding | "ISO-8859-1" | PHP_INI_ALL | Obsoleta desde PHP 5.6.0.
iconv.internal_encoding | "ISO-8859-1" | PHP_INI_ALL | Obsoleta desde PHP 5.6.0.

He aquí una breve explicación de las directivas de configuración.

Advertencia

Algunos sistemas (como IBM AIX) usan "ISO8859-1" en vez de "ISO-8859-1", por lo que este valor tiene que usarse en las opciones de configuración y en los parámetros de funciones.

iconv.input_encoding string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Los usuarios de PHP 5.6 y posteriores deberían dejarla vacía y establecer default_charset en su lugar.

iconv.output_encoding string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Los usuarios de PHP 5.6 y posteriores deberían dejarla vacía y establecer default_charset en su lugar.

iconv.internal_encoding string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Los usuarios de PHP 5.6 y posteriores deberían dejarla vacía y establecer default_charset en su lugar.


Constantes predefinidas

Desde PHP 4.3.0 es posible identificar en tiempo de ejecución cuál implementación de iconv es adoptada por esta extensión.

Constances de iconv
Nombre | Tipo | Descripción
ICONV_IMPL | string | Nombre de la implementación
ICONV_VERSION | string | Versión de la implementación

Nota:

Está completamente desaconsejado escribir scripts cuya implementación dependa de estas constantes.

Desde PHP 5.0.0 se dispone de las siguientes constantes:

Constantes de iconv disponibles desde PHP 5.0.0
Nombre | Tipo | Descripción
ICONV_MIME_DECODE_STRICT | integer | Máscara de bits usada para iconv_mime_decode()
ICONV_MIME_DECODE_CONTINUE_ON_ERROR | integer | Máscara de bits usada para iconv_mime_decode()


Funciones de iconv

Ver también

Ver también funciones de GNU Recode.

Tabla de contenidos

  • iconv_get_encoding — Recupera variables de configuración interna de la extensión iconv
  • iconv_mime_decode_headers — Decodifica varios campos de cabeceras MIME en la misma llamada
  • iconv_mime_decode — Decodifica un campo de la cabecera MIME
  • iconv_mime_encode — Compone un campo de cabecera MIME
  • iconv_set_encoding — Establece las opciones para la conversión de codificación de caracteres
  • iconv_strlen — Retorna el número de caracteres de un string
  • iconv_strpos — Encuentra la posición de la primera aparición de una aguja en un pajar
  • iconv_strrpos — Busca la última aparición de un string
  • iconv_substr — Elimina parte del string
  • iconv — Convierte un string a la codificación de caracteres indicada
  • ob_iconv_handler — Convierte la codificación de caracteres al manejador del buffer de salida


Recupera variables de configuración interna de la extensión iconv

  • « Funciones de iconv
  • iconv_mime_decode_headers »
  • PHP Manual
  • Funciones de iconv
  • Recupera variables de configuración interna de la extensión iconv

iconv_get_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv_get_encoding — Recupera variables de configuración interna de la extensión iconv

Descripción

iconv_get_encoding ( string $type = "all" ) : mixed

Recupera variables de configuración interna de la extensión iconv

Parámetros

type

El valor del parámetro opcional type puede ser:

  • all
  • input_encoding
  • output_encoding
  • internal_encoding

Valores devueltos

Retorna el valor actual de la variable de configuración interna si tiene éxito o o false en caso de error.

Si se omite type o se fija a "all", iconv_get_encoding() retorna un array que almacena todas las variables.

Ejemplos

Ejemplo #1 Ejemplo de iconv_get_encoding()

<pre>
<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
var_dump(iconv_get_encoding('all'));
?>
</pre>

El resultado del ejemplo sería:

Array
(
    [input_encoding] => ISO-8859-1
    [output_encoding] => ISO-8859-1
    [internal_encoding] => UTF-8
)

Ver también

  • iconv_set_encoding() - Establece las opciones para la conversión de codificación de caracteres
  • ob_iconv_handler() - Convierte la codificación de caracteres al manejador del buffer de salida


Decodifica varios campos de cabeceras MIME en la misma llamada

  • « iconv_get_encoding
  • iconv_mime_decode »
  • PHP Manual
  • Funciones de iconv
  • Decodifica varios campos de cabeceras MIME en la misma llamada

iconv_mime_decode_headers

(PHP 5, PHP 7, PHP 8)

iconv_mime_decode_headers — Decodifica varios campos de cabeceras MIME en la misma llamada

Descripción

iconv_mime_decode_headers ( string $encoded_headers , int $mode = 0 , string $charset = ini_get("iconv.internal_encoding") ) : array

Decodifica varios campos de cabeceras MIME en la misma llamada.

Parámetros

encoded_headers

La cabeceras a decodificar, indicarlas como string.

mode

mode determina el comportamiento cuando el evento iconv_mime_decode_headers() encuentra un campo de cabecera MIME mal formado. Puede indicarse una combinación de las siguientes máscaras.

Máscaras de bits aceptadas por iconv_mime_decode_headers()
Valor | Constante | Descripción
1 | ICONV_MIME_DECODE_STRICT | Si se indica, la cabecera dada se decodifica de acuerdo a los estándares definidos en » RFC2047. Esta opción se deshabilita por defecto porque hay muchos agentes de correo incorrectos que no siguen esta espeficicación y no producen cabeceras MIME correctas.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | Si se indica, iconv_mime_decode_headers() intenta ignorar errores gramaticales y continúa con el proceso en la cabecera.

charset

El parámetro opcional charset especifica el set de caracteres con el que representar el resultado. Si se omite, se usará iconv.internal_encoding.

Valores devueltos

Retorna un array asociativo que contiene el set completo de cabeceras MIME especificadas por encoded_headers en caso de éxito, o false si ocurre un error durante la decodificación.

Cada clave del array retornado representa un nombre de campo independiente y su correspondiente elemento representa el valor del campo. Si hay presente más de un campo del mismo nombre, iconv_mime_decode_headers() automáticamente los incorpora en un array indexado por enteros según orden de aparición.

Ejemplos

Ejemplo #1 Ejemplo de iconv_mime_decode_headers()

<?php
$string_cabeceras = <<<EOF
Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=
To: example@example.com
Date: Thu, 1 Jan 1970 00:00:00 +0000
Message-Id: <example@example.com>
Received: from localhost (localhost [127.0.0.1]) by localhost
    with SMTP id example for <example@example.com>;
    Thu, 1 Jan 1970 00:00:00 +0000 (UTC)
    (envelope-from example-return-0000-example=example.com@example.com)
Received: (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000

EOF;

$cabeceras = iconv_mime_decode_headers($string_cabeceras, 0, "ISO-8859-1");
print_r($cabeceras);
?>

El resultado del ejemplo sería:

Array
(
    [Subject] => Prüfung Prüfung
    [To] => example@example.com
    [Date] => Thu, 1 Jan 1970 00:00:00 +0000
    [Message-Id] => <example@example.com>
    [Received] => Array
        (
            [0] => from localhost (localhost [127.0.0.1]) by localhost with SMTP id example for <example@example.com>; Thu, 1 Jan 1970 00:00:00 +0000 (UTC) (envelope-from example-return-0000-example=example.com@example.com)
            [1] => (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000
        )

)

Ver también

  • iconv_mime_decode() - Decodifica un campo de la cabecera MIME
  • mb_decode_mimeheader() - Decodifica un string en el campo de cabecera MIME
  • imap_mime_header_decode() - Decodificar los elementos de la cabecera MIME
  • imap_base64() - Decodificar un texto cifrado con BASE64
  • imap_qprint() - Convertir una cadena imprimible entrecomillada a una cadena de 8 bits


Decodifica un campo de la cabecera MIME

  • « iconv_mime_decode_headers
  • iconv_mime_encode »
  • PHP Manual
  • Funciones de iconv
  • Decodifica un campo de la cabecera MIME

iconv_mime_decode

(PHP 5, PHP 7, PHP 8)

iconv_mime_decode — Decodifica un campo de la cabecera MIME

Descripción

iconv_mime_decode ( string $encoded_header , int $mode = 0 , string $charset = ini_get("iconv.internal_encoding") ) : string

Decodifica un campo de la cabecera MIME.

Parámetros

encoded_header

La cabecera codificada, como string.

mode

mode determina el comportamiento cuando el evento iconv_mime_decode() encuentra un campo de cabecera MIME mal formado. Puede especificarse cualquier combinación las siguientes máscaras de bits.

Máscaras de bits aceptadas por iconv_mime_decode()
Valor | Constante | Descripción
1 | ICONV_MIME_DECODE_STRICT | Si está definida, la cabecera indicada es decodificada de acuerdo con los estándares definidos en » RFC2047. Esta opción esta deshabilitada por defecto puesto que hay muchos agente de correo incorrectos que no siguen la especificación y no producen las cabeceras MIME correctas.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | Si está definida iconv_mime_decode_headers() intenta ignorar cualquier error gramaticar y continúa procesando la cabecera dada.

charset

El parámetro opcional charset especifica el set de caracteres a usar para representar el resultado. Si se omite, se usará iconv.internal_encoding.

Valores devueltos

En caso de éxito retorna un campo MIME decodificado o false si ocurre cualquier error durante la decodificación.

Ejemplos

Ejemplo #1 Ejemplo de la función iconv_mime_decode()

<?php
// Esto contiene "Subject: Prüfung Prüfung"
echo iconv_mime_decode("Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=",
                       0, "ISO-8859-1");
?>

Ver también

  • iconv_mime_decode_headers() - Decodifica varios campos de cabeceras MIME en la misma llamada
  • mb_decode_mimeheader() - Decodifica un string en el campo de cabecera MIME
  • imap_mime_header_decode() - Decodificar los elementos de la cabecera MIME
  • imap_base64() - Decodificar un texto cifrado con BASE64
  • imap_qprint() - Convertir una cadena imprimible entrecomillada a una cadena de 8 bits


Compone un campo de cabecera MIME

  • « iconv_mime_decode
  • iconv_set_encoding »
  • PHP Manual
  • Funciones de iconv
  • Compone un campo de cabecera MIME

iconv_mime_encode

(PHP 5, PHP 7, PHP 8)

iconv_mime_encode — Compone un campo de cabecera MIME

Descripción

iconv_mime_encode ( string $field_name , string $field_value , array $preferences = null ) : string

Compone y retorna un string que representa un campo de cabecera MIME válido que tiene una forma similar a:

Subject: =?ISO-8859-1?Q?Pr=FCfung_f=FCr?= Entwerfen von einer MIME kopfzeile
En el anterior ejemplo, "Subject" es el nombre del campo y la parte que empieza con "=?ISO-8859-1?..." es el valor del campo.

Parámetros

field_name

Nombre del campo.

field_value

Valor del campo.

preferences

Puede controlarse el comportamiento de iconv_mime_decode() especificando un array asociativo que contenga elementos de configuración al parámetro opcional preferences. Los elementos soportados por iconv_mime_encode() son listados seguidamente. Notar que en los nombres de los elementos se distinguen mayúsculas y minúsculas.

Elementos de configuración soportados por iconv_mime_encode()
Elemento | Tipo | Descripción | Valor por defecto | Ejemplo
scheme | string | Especifica el método con el que codificar el valor de un campo. El valor de este elemento puede ser tanto "B" como "Q", donde "B" se usa para un esquema de codificación base64 y "Q" para un esquema de codificación quoted-printable. | B | B
input-charset | string | Especifica el set de caracteres con el que se muestran el primer parámetro field_name y el segundo field_value. Si no se da, iconv_mime_encode() asume que esos parámetros se muestran según lo indicado en el parámetro de coonfiguración ini iconv.internal_encoding. | iconv.internal_encoding | ISO-8859-1
output-charset | string | Especifica el set de caracteres a usar para componer la cabecera MIME. | iconv.internal_encoding | UTF-8
line-length | integer | Especifica la longitud máxima de las líneas de la cabecera. La cabecera resultante se "desdobla" en varias líneas en caso de que el campo de la cabecera resultante sea más largo que el valor de este parámetro, de acuerdo con » RFC2822 - Internet Message Format. Si no se especifica, la longitud se limita a 76 caracteres. | 76 | 996
line-break-chars | string | Especifica la secuencia de caracteres a añadir a cada línea como signo de final de línea cuando ocurre el "desdoblamiento" de campos de cabeceras largos. Si no se da, por defecto es "\r\n" (CR LF). Notar que este parámetro siempre se trata como strings ASCII, sea cual sea el valor de input-charset. | \r\n | \n

Valores devueltos

En caso de éxito retorna un campo MIME codificado o false si ha ocurrido un error durante la codificación.

Ejemplos

Ejemplo #1 Ejemplo de iconv_mime_encode()

<?php
$preferences = array(
    "input-charset" => "ISO-8859-1",
    "output-charset" => "UTF-8",
    "line-length" => 76,
    "line-break-chars" => "\n"
);
$preferences["scheme"] = "Q";
// Esto contiene "Subject: =?UTF-8?Q?Pr=C3=BCfung=20Pr=C3=BCfung?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);

$preferences["scheme"] = "B";
// This yields "Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);
?>

Ver también

  • imap_binary() - Convertir una cadena 8bit a una cadena base64
  • mb_encode_mimeheader() - Codifica un string para la cabecera MIME
  • imap_8bit() - Convertir una cadena 8bit a una cadena quoted-printable
  • quoted_printable_encode() - Convierte un string de 8 bits en un string quoted-printable


Establece las opciones para la conversión de codificación de caracteres

  • « iconv_mime_encode
  • iconv_strlen »
  • PHP Manual
  • Funciones de iconv
  • Establece las opciones para la conversión de codificación de caracteres

iconv_set_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv_set_encoding — Establece las opciones para la conversión de codificación de caracteres

Descripción

iconv_set_encoding ( string $type , string $charset ) : bool

Cambia el valor de la variable de configuración interna especificada por type a charset.

Parámetros

type

El valor de type puede ser cualquiera de los siguientes:

  • input_encoding
  • output_encoding
  • internal_encoding

charset

La codificación de caracteres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de iconv_set_encoding()

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
?>

Ver también

  • iconv_get_encoding() - Recupera variables de configuración interna de la extensión iconv
  • ob_iconv_handler() - Convierte la codificación de caracteres al manejador del buffer de salida


Retorna el número de caracteres de un string

  • « iconv_set_encoding
  • iconv_strpos »
  • PHP Manual
  • Funciones de iconv
  • Retorna el número de caracteres de un string

iconv_strlen

(PHP 5, PHP 7, PHP 8)

iconv_strlen — Retorna el número de caracteres de un string

Descripción

iconv_strlen ( string $str , string $charset = ini_get("iconv.internal_encoding") ) : int

A diferencia de strlen(), iconv_strlen() cuenta el número de veces que aparece cierta secuencia de bytes str de acuerdo a la codificación de caraceters especificada, resultado que no es necesariamente igual a la longitud del string en bytes.

Parámetros

str

El string a contar.

charset

Si se omite el parametro charset, se asume que str se codificará en iconv.internal_encoding.

Valores devueltos

Retorna el número de caracteres de str, como un entero.

Ver también

  • grapheme_strlen() - Obtener la longitud de un string en unidades de grafema
  • mb_strlen() - Obtiene la longitud de una cadena de caracteres
  • strlen() - Obtiene la longitud de un string


Encuentra la posición de la primera aparición de una aguja en un pajar

  • « iconv_strlen
  • iconv_strrpos »
  • PHP Manual
  • Funciones de iconv
  • Encuentra la posición de la primera aparición de una aguja en un pajar

iconv_strpos

(PHP 5, PHP 7, PHP 8)

iconv_strpos — Encuentra la posición de la primera aparición de una aguja en un pajar

Descripción

iconv_strpos ( string $haystack , string $needle , int $offset = 0 , string $charset = ini_get("iconv.internal_encoding") ) : int

Encuentra la posición de la primera aparición de una aguja dentro de un pajar.

A diferencia de strpos(), el valor que retorna iconv_strpos() es el número de caracteres que aparecen antes del string buscado, en vez del offset en bytes a la posición donde se encuentra el string. Los caracteres se cuentan de acuerdo a la codificación de caracteres establecida en charset.

Parámetros

haystack

El string completo donde buscar.

needle

El string a buscar.

offset

El parámetro opcional offset especifica la posición respecto al inicio del string desde la que empezará la búsqueda. Si el parámetro offset es negativo, se cuenta desde el final del string.

charset

Si se omite el parámetro charset, se asume que string se codificará según iconv.internal_encoding.

Si haystack o needle no son un string, se convierten a string y se aplica como el valor ordinal del carácter.

Valores devueltos

Retorna la posición numérica de la primera vez que aparece needle en haystack.

Si no se encuentra needle, iconv_strpos() retornará false.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
7.1.0 | Añadido soporte para offsets negativos.

Ver también

  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • iconv_strrpos() - Busca la última aparición de un string
  • mb_strpos() - Busca la posición de la primera ocurrencia de un string en otro string


Busca la última aparición de un string

  • « iconv_strpos
  • iconv_substr »
  • PHP Manual
  • Funciones de iconv
  • Busca la última aparición de un string

iconv_strrpos

(PHP 5, PHP 7, PHP 8)

iconv_strrpos — Busca la última aparición de un string

Descripción

iconv_strrpos ( string $haystack , string $needle , string $charset = ini_get("iconv.internal_encoding") ) : int

Encuentra la última aparición de un needle dentro de un haystack.

A diferencia de strpos(), el valor que retorna iconv_strrpos() es el número de caracteres que aparecen antes de needle, en vez del offset en bytes a la posición donde se encuentra needle. Los caracteres son contados de acuerdo al charset especificado.

Parámetros

haystack

Todo el string.

needle

El substring a ser buscado.

charset

Si se omite el parámetro charset, se asume que string se codificará con iconv.internal_encoding.

Si haystack o needle no son un string, se convierten a string y se aplica como el valor ordinal del carácter.

Valores devueltos

Retorna la posición numérica de la última vez que aparece needle en haystack. Lo caracteres se cuentan de acuerdo a la codificacion establecida en charset.

Si needle no se encuentra, iconv_strrpos() retorna false.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ver también

  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • iconv_strpos() - Encuentra la posición de la primera aparición de una aguja en un pajar
  • mb_strrpos() - Busca la posicion de la última ocurrencia de un string en otro string


Elimina parte del string

  • « iconv_strrpos
  • iconv »
  • PHP Manual
  • Funciones de iconv
  • Elimina parte del string

iconv_substr

(PHP 5, PHP 7, PHP 8)

iconv_substr — Elimina parte del string

Descripción

iconv_substr ( string $str , int $offset , int $length = iconv_strlen($str, $charset) , string $charset = ini_get("iconv.internal_encoding") ) : string

Corta una parte de str especificada por los parámetros offset y length.

Parámetros

str

El string original.

offset

Si offset no es negativo, iconv_substr() elimina la porción de str que empieza en el caracter número offset, empezando de cero.

Si offset es negativo, iconv_substr() elimina la parte que empieza en esa posición, offset caracteres desde el final de str.

length

Si se da el parámetro length y es positivo, el valor retornado contendrá como mucho length caracteres de la porción que comienza en offset (dependiendo de la longitud de string).

Si se indica un valor negativo en length, iconv_substr() elimina la porción de str desde la posición offset hasta el caracter que está length caracteres desde el final del string. En caso de que offset sea también negativo, la posición de inicio se calcula de antemano de acuerdo con la regla explicada anteriormente.

charset

Si se omite el parámetro charset, se asume que string se codifica en iconv.internal_encoding.

Notar que se considera que los parámetros offset y length representan offsets que se calculan en base a la codificación de caracteres determinada en charset, mientras que por otro lado, substr() siempre los toma como offset de bytes.

Valores devueltos

Retorna la parte de str especificada por los parámetros offset y length

Si str tiene un tamaño más corto que offset, se retornará false. Si str tiene exactamente un número de caracteres igual a offset, entonces devolverá un string vacío.

Historial de cambios

Versión | Descripción
7.0.11 | Si la longitud de caracteres de str es igual a offset, devolverá un string vacío. Antes de ésta versión, un false era devuelto en éste caso.

Ver también

  • substr() - Devuelve parte de una cadena
  • mb_substr() - Obtiene parte de una cadena de caracteres
  • mb_strcut() - Obtener parte de un string


Convierte un string a la codificación de caracteres indicada

  • « iconv_substr
  • ob_iconv_handler »
  • PHP Manual
  • Funciones de iconv
  • Convierte un string a la codificación de caracteres indicada

iconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv — Convierte un string a la codificación de caracteres indicada

Descripción

iconv ( string $in_charset , string $out_charset , string $str ) : string

Realiza una conversión del set de caracteres en el string str desde in_charset a out_charset.

Parámetros

in_charset

Codificación inicial.

out_charset

Codificación final.

Si se añade el string //TRANSLIT a out_charset, se activa la transliteración. Esto significa que cuando un caracter no puede ser representado en el set de caracteres final, se puede aproximar a uno o varios caracteres parecidos. Si se añade el string //IGNORE, los caracteres que no puedan ser representados en el set de caracteres final son descartados sin generar error. De otro modo, str se corta desde el primer caracter ilegal y se genera un E_NOTICE.

str

El string a ser convertido.

Valores devueltos

Retorna el string convertido o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de iconv()

<?php
$text = "Este es el símbolo del euro: '€'.";

echo 'Original : ', $text, PHP_EOL;
echo 'TRANSLIT : ', iconv("UTF-8", "ISO-8859-1//TRANSLIT", $text), PHP_EOL;
echo 'IGNORE   : ', iconv("UTF-8", "ISO-8859-1//IGNORE", $text), PHP_EOL;
echo 'Plain    : ', iconv("UTF-8", "ISO-8859-1", $text), PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

Original : Este es el símbolo del euro: '€'.
TRANSLIT : Este es el símbolo del euro: 'EUR'.
IGNORE   : Este es el símbolo del euro: ''.
Plain    :
Notice: iconv(): Detected an illegal character in input string in .\iconv-example.php on line 7
Este es el símbolo del euro: '


Convierte la codificación de caracteres al manejador del buffer de salida

  • « iconv
  • intl »
  • PHP Manual
  • Funciones de iconv
  • Convierte la codificación de caracteres al manejador del buffer de salida

ob_iconv_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ob_iconv_handler — Convierte la codificación de caracteres al manejador del buffer de salida

Descripción

ob_iconv_handler ( string $contents , int $status ) : string

Convierte el string codificado en internal_encoding a output_encoding.

internal_encoding y output_encoding deberían estar definidos en el fichero php.ini o en iconv_set_encoding().

Parámetros

Ver ob_start() para más información sobre los parámetros del manejador.

Valores devueltos

Ver ob_start() para mas información sobre los valores de retorno del manejador.

Ejemplos

Ejemplo #1 Ejemplo de ob_iconv_handler()

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
ob_start("ob_iconv_handler"); // empieza a usarse el buffer de salida
?>

Ver también

  • iconv_get_encoding() - Recupera variables de configuración interna de la extensión iconv
  • iconv_set_encoding() - Establece las opciones para la conversión de codificación de caracteres
  • output-control functions


Funciones de internacionalización

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico de esta extensión
  • Collator — La clase Collator
    • Collator::asort — Ordenar un array manteniendo la relación de índices
    • Collator::compare — Comparar dos cadenas Unicode
    • Collator::__construct — Crear un objeto Collator
    • Collator::create — Crear un cotejador
    • Collator::getAttribute — Obtener el valor de un atributo de cotejo
    • Collator::getErrorCode — Obtener el último código de error del cotejeador
    • Collator::getErrorMessage — Obtener el texto del último código de error del cotejador
    • Collator::getLocale — Obtener el nombre de la configuración regional del cotejador
    • Collator::getSortKey — Obtener la clave de ordenación de una cadena
    • Collator::getStrength — Obtener la fuerza de cotejo actual
    • Collator::setAttribute — Establecer el atributo de cotejo
    • Collator::setStrength — Establecer la fuerza (strength) de un cotejo
    • Collator::sortWithSortKeys — Ordenar un array usando el cotejador y las claves de ordenación especificados
    • Collator::sort — Ordenar un array usando cotejador especificado
  • NumberFormatter — La clase NumberFormatter
    • NumberFormatter::create — Crear un formateador de números
    • NumberFormatter::formatCurrency — Dar formato a un valor monetario
    • NumberFormatter::format — Dar formato a un número
    • NumberFormatter::getAttribute — Obtener un atributo
    • NumberFormatter::getErrorCode — Obtener el último código de error del formateador
    • NumberFormatter::getErrorMessage — Obtener el último mensaje de error del formateador
    • NumberFormatter::getLocale — Obtener la configuración regional de un formateador
    • NumberFormatter::getPattern — Obtener el patrón del formateador
    • NumberFormatter::getSymbol — Obtener el valor de un símbolo
    • NumberFormatter::getTextAttribute — Obtiene un atributo de texto
    • NumberFormatter::parseCurrency — Procesa un número monetario
    • NumberFormatter::parse — Analiza un número
    • NumberFormatter::setAttribute — Establecer un atributo
    • NumberFormatter::setPattern — Establecer el patrón de un formateador
    • NumberFormatter::setSymbol — Establecer un valor de símbolo
    • NumberFormatter::setTextAttribute — Set a text attribute
  • Locale — La clase Locale
    • Locale::acceptFromHttp — Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP
    • Locale::canonicalize — Canonizar el string de configuración regional
    • Locale::composeLocale — Devolver un ID regional correctamente ordenado y delimitado
    • Locale::filterMatches — Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional
    • Locale::getAllVariants — Obtener las variantes de la configuración regional de entrada
    • Locale::getDefault — Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL
    • Locale::getDisplayLanguage — Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
    • Locale::getDisplayName — Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
    • Locale::getDisplayRegion — Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
    • Locale::getDisplayScript — Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
    • Locale::getDisplayVariant — Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada
    • Locale::getKeywords — Obtener las palabras clave de la configuración regional de entrada
    • Locale::getPrimaryLanguage — Obtener el lenguaje principal de la configuración regional de entrada
    • Locale::getRegion — Obtener la región de la configuración local de entrada
    • Locale::getScript — Obtener la escritura de la configuración regional de entrada
    • Locale::lookup — Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje
    • Locale::parseLocale — Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional
    • Locale::setDefault — Establecer la configuración regional predeterminada en tiempo de ejecución
  • Normalizer — La clase Normalizer
    • Normalizer::getRawDecomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
    • Normalizer::isNormalized — Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.
    • Normalizer::normalize — Normaliza la entrada provista y devuelve la cadena normalizada
  • MessageFormatter — La clase MessageFormatter
    • MessageFormatter::create — Construir un nuevo Formateador de Mensajes
    • MessageFormatter::formatMessage — Formateo rápido de un mensaje
    • MessageFormatter::format — Dar formato al mensaje
    • MessageFormatter::getErrorCode — Obtener el código de error de la última operación
    • MessageFormatter::getErrorMessage — Obtener el texto del error de la última operación
    • MessageFormatter::getLocale — Obtener la configuración regional desde la que se creó el formateador
    • MessageFormatter::getPattern — Obtener el patrón usado por el formateador
    • MessageFormatter::parseMessage — Procesar rápidamente una cadena de entrada
    • MessageFormatter::parse — Procesar la cadena de entrada según un patrón
    • MessageFormatter::setPattern — Establecer el patrón usado por el formateador
  • IntlCalendar — La clase IntlCalendar
    • IntlCalendar::add — Añadir una candidad (con signo) de tiempo al campo
    • IntlCalendar::after — Indica si el instante de este objeto es posterior al del proporcionado
    • IntlCalendar::before — Indica si el instante de este objeto es anterior al del proporcionado
    • IntlCalendar::clear — Limpiar uno o todos los campos
    • IntlCalendar::__construct — Constructor privado para no permitir la creación de instancias
    • IntlCalendar::createInstance — Crear un nuevo IntlCalendar
    • IntlCalendar::equals — Comparar el instante de dos objetos IntlCalendar
    • IntlCalendar::fieldDifference — Calcular la diferencia entre el instante dado y el de este objeto
    • IntlCalendar::fromDateTime — Crear un IntlCalendar desde un objeto DateTime o tring
    • IntlCalendar::get — Obtiene el valor de un campo
    • IntlCalendar::getActualMaximum — El valor máximo de un campo, considerando el instante actual del objeto
    • IntlCalendar::getActualMinimum — El valor mínimo de un campo, considerando el instante actual del objeto
    • IntlCalendar::getAvailableLocales — Obtener un array con las zonas para las que existen datos
    • IntlCalendar::getDayOfWeekType — Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos
    • IntlCalendar::getErrorCode — Obtener el código de error del objeto
    • IntlCalendar::getErrorMessage — Obtener el últime mensaje de error del objeto
    • IntlCalendar::getFirstDayOfWeek — Obtener el primer día de la semana de la región del calendario
    • IntlCalendar::getGreatestMinimum — Obtener el valor mínimo local más grande de un campo
    • IntlCalendar::getKeywordValuesForLocale — Obtener un conjunto de valores de palabras clave de zonas
    • IntlCalendar::getLeastMaximum — Obtener el máximo local más pequeño de un campo
    • IntlCalendar::getLocale — Obtener la configuración regional asociada al objeto
    • IntlCalendar::getMaximum — Obtener el valor máximo global de un campo
    • IntlCalendar::getMinimalDaysInFirstWeek — Obtener el número mínimo de días que puede tener la primera semana de un año o mes
    • IntlCalendar::getMinimum — Obtener el valor mínimo de un campo
    • IntlCalendar::getNow — Obtener el número que representa el instante actual
    • IntlCalendar::getRepeatedWallTimeOption — Obtener el comportamiento para tratar horas repetidas
    • IntlCalendar::getSkippedWallTimeOption — Obtener el comportamiento para tratar horas omitidas
    • IntlCalendar::getTime — Obtiene el tiempo representado por el objeto
    • IntlCalendar::getTimeZone — Obtener la zona horaria del objeto
    • IntlCalendar::getType — Obtener el tipo de calendario
    • IntlCalendar::getWeekendTransition — Obtener el instante del día en la que comienza o termina el fin de semana
    • IntlCalendar::inDaylightTime — Indicar si el instante del objeto está en el horario de verano
    • IntlCalendar::isEquivalentTo — Indicar si otro calendario es igual pero para un instante diferente
    • IntlCalendar::isLenient — Indicar si la interpretación de una fecha/hora está en modo tolerante
    • IntlCalendar::isSet — Determina si un campo está definido
    • IntlCalendar::isWeekend — Determina si una cierta fecha es fin de semana
    • IntlCalendar::roll — Añadir un valor a un campo si acarrear más campos significativos
    • IntlCalendar::set — Establecer un campo de instante o varios campos en común de una vez
    • IntlCalendar::setFirstDayOfWeek — Establecer el día en el que se estima que empieza la semana
    • IntlCalendar::setLenient — Establecer si la interpretación de la fecha/hora es tolerante
    • IntlCalendar::setMinimalDaysInFirstWeek — Establecer el número de días mínimo que puede tener la primera semana de un año o mes
    • IntlCalendar::setRepeatedWallTimeOption — Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias
    • IntlCalendar::setSkippedWallTimeOption — Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
    • IntlCalendar::setTime — Establecer el momento del calendario en milisegundos desde la época
    • IntlCalendar::setTimeZone — Establecer la zona horaria usada por este calendario
    • IntlCalendar::toDateTime — Convertir un objeto IntlCalendar a un objeto DateTime
  • IntlTimeZone — La clase IntlTimeZone
    • IntlTimeZone::countEquivalentIDs — Obtener el número de ID del grupo de equivalencias que incluye el ID dado
    • IntlTimeZone::createDefault — Crear una nueva copia de la zona horaria predeterminada para este host
    • IntlTimeZone::createEnumeration — Obtener una enumeración de ID de zonas horarias asociados al país o índice dado
    • IntlTimeZone::createTimeZone — Crear un objeto de zona horaria para el ID dado
    • IntlTimeZone::createTimeZoneIDEnumeration — Get an enumeration over system time zone IDs with the given filter conditions
    • IntlTimeZone::fromDateTimeZone — Crear un objeto de zona horaria desde DateTimeZone
    • IntlTimeZone::getCanonicalID — Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado
    • IntlTimeZone::getDisplayName — Obtener un nombre de esta zona horaria apto para la presentación al usuario
    • IntlTimeZone::getDSTSavings — Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual
    • IntlTimeZone::getEquivalentID — Obtener un ID del grupo de equivalencias que incluya el ID dado
    • IntlTimeZone::getErrorCode — Obtener el último código de error del objeto
    • IntlTimeZone::getErrorMessage — Obtener el último mensaje de error del objeto
    • IntlTimeZone::getGMT — Crear una zona horaria GMT (UTC)
    • IntlTimeZone::getID — Obtener el ID de la zona horaria
    • IntlTimeZone::getIDForWindowsID — Translate a Windows timezone into a system timezone
    • IntlTimeZone::getOffset — Obtener la zona horaria sin tratar y el índice GMT para el momento dado
    • IntlTimeZone::getRawOffset — Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)
    • IntlTimeZone::getRegion — Get the region code associated with the given system time zone ID
    • IntlTimeZone::getTZDataVersion — Obtener la versión de los datos de zonas horarias actualmente usada por ICU
    • IntlTimeZone::getUnknown — Get the "unknown" time zone
    • IntlTimeZone::getWindowsID — Translate a system timezone into a Windows timezone
    • IntlTimeZone::hasSameRules — Comprobar si esta zona horaria tiene las mismas reglas e índices que otra
    • IntlTimeZone::toDateTimeZone — Convertir a un objeto DateTimeZone
    • IntlTimeZone::useDaylightTime — Comprobar si esta zona horaria utiliza el horario de verano
  • IntlDateFormatter — La clase IntlDateFormatter
    • IntlDateFormatter::create — Crear un formateador de fechas
    • IntlDateFormatter::format — Formatear el valor fecha/hora como una cadena
    • IntlDateFormatter::formatObject — Formatea un objeto
    • IntlDateFormatter::getCalendar — Obtener el tipo de calendario usado por el objeto IntlDateFormatter
    • IntlDateFormatter::getDateType — Obtener el tipo de fecha usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::getErrorCode — Obtener el código del error de la última operación
    • IntlDateFormatter::getErrorMessage — Obtener el texto del error de la última operación
    • IntlDateFormatter::getLocale — Obtener la configuración regional usada por un formateador
    • IntlDateFormatter::getPattern — Obtener el patrón utilizado por un formateador de IntlDateFormatter
    • IntlDateFormatter::getTimeType — Obtener el tipo de hora usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::getTimeZoneId — Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::getCalendarObject — Obtener una copia del objeto calendario del formateador
    • IntlDateFormatter::getTimeZone — Obtener la zona horaria del formateador
    • IntlDateFormatter::isLenient — Obtener la tolerancia usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::localtime — Convertir una cadena en un valor de marca de tiempo basado en un campo
    • IntlDateFormatter::parse — Convertir una cadena en un valor de marca de tiempo
    • IntlDateFormatter::setCalendar — Establecer el tipo de calendario usado por el formateador
    • IntlDateFormatter::setLenient — Establecer la tolerancia del analizador
    • IntlDateFormatter::setPattern — Establecer el patrón utilizado por el formateador de IntlDateFormatter
    • IntlDateFormatter::setTimeZone — Establece la zona horaria del formateador
  • ResourceBundle — La clase ResourceBundle
    • ResourceBundle::count — Obtener el número de elementos de un paquete
    • ResourceBundle::create — Crear un paquete de recursos
    • ResourceBundle::getErrorCode — Obtener el códido del último error del paquete
    • ResourceBundle::getErrorMessage — Obtener el mensaje del último error del paquete
    • ResourceBundle::get — Obtener datos de un paquete
    • ResourceBundle::getLocales — Obtener las configuraciones regionales soportadas
  • Spoofchecker — La clase Spoofchecker
    • Spoofchecker::areConfusable — Comprobar si un texto dado contiene carateres que pueden ser confusos
    • Spoofchecker::__construct — Constructor
    • Spoofchecker::isSuspicious — Comprobar si un texto dad contiene caracteres sospechosos
    • Spoofchecker::setAllowedLocales — Las configuraciones regionales a usar cuando se ejecutan las comprobaciones
    • Spoofchecker::setChecks — Establecer las comprobaciones a ejecutar
  • Transliterator — La clase Transliterator
    • Transliterator::__construct — Constructor privado para denegar la instanciación
    • Transliterator::create — Crear un transliterador
    • Transliterator::createFromRules — Crear un transliterador desdes normas
    • Transliterator::createInverse — Cerar una transliteración inversa
    • Transliterator::getErrorCode — Obtener el código del último error
    • Transliterator::getErrorMessage — Obtener el mensaje del último error
    • Transliterator::listIDs — Obtener los IDs de los transliterardores
    • Transliterator::transliterate — Transliterar una cadena
  • IntlBreakIterator — La clase IntlBreakIterator
    • IntlBreakIterator::__construct — Constructor privado para denegar la instanciación
    • IntlBreakIterator::createCharacterInstance — Crear un iterador de ruptura para los límites de secuencias de caracters combinados
    • IntlBreakIterator::createCodePointInstance — Crear un iterador de ruptura para los límites de puntos de código
    • IntlBreakIterator::createLineInstance — Crear un iterador de ruptura para las lógicamente posibles saltos de línea
    • IntlBreakIterator::createSentenceInstance — Crear un iterador de ruptura para rupturas de sentencias
    • IntlBreakIterator::createTitleInstance — Crear un iterador de ruptura para rupturas de marcos de título
    • IntlBreakIterator::createWordInstance — Crear un iterador de ruptura para ruptura de palabras
    • IntlBreakIterator::current — Obtiene el índice de la posición actual
    • IntlBreakIterator::first — Coloca la posición al primer caracter en el texto
    • IntlBreakIterator::following — Avanza el iterador al primer límite siguiendo un offset específico
    • IntlBreakIterator::getErrorCode — Obtener el código del último error del objeto
    • IntlBreakIterator::getErrorMessage — Obtener el último mensaje de error del objeto
    • IntlBreakIterator::getLocale — Obtiene el locale asociado al objeto
    • IntlBreakIterator::getPartsIterator — Crear un iterador para fragmentos de navegación entre límites
    • IntlBreakIterator::getText — Obtiene el texto que está siendo escaneado
    • IntlBreakIterator::isBoundary — Indicar si un índice es un índice de límites
    • IntlBreakIterator::last — Establecer la posición del iterador al índice tras el último carácter
    • IntlBreakIterator::next — Avanzar el iterador al siguiente límite
    • IntlBreakIterator::preceding — Establecer la posición del iterador al primer límite antes de un índice
    • IntlBreakIterator::previous — Establecer la posición del iterador al límite inmediatamente anterior al actual
    • IntlBreakIterator::setText — Establecer el texto a escanear
  • IntlRuleBasedBreakIterator — La clase IntlRuleBasedBreakIterator
    • IntlRuleBasedBreakIterator::__construct — Crear un iterador desde un conjunto de reglas
    • IntlRuleBasedBreakIterator::getBinaryRules — Obtener la forma binaria de las reglas compiladas
    • IntlRuleBasedBreakIterator::getRules — Obtener el conjunto de reglas empleado para crear este objeto
    • IntlRuleBasedBreakIterator::getRuleStatus — Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual
    • IntlRuleBasedBreakIterator::getRuleStatusVec — Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal
  • IntlCodePointBreakIterator — La clase IntlCodePointBreakIterator
    • IntlCodePointBreakIterator::getLastCodePoint — Obtener el último punto de código ignorado después de que el iterdor avance o retroceda
  • IntlPartsIterator — La clase IntlPartsIterator
    • IntlPartsIterator::getBreakIterator — Obtener un IntlBreakIterator respaldando este iterador de partes
  • UConverter — La clase UConverter
    • UConverter::__construct — Crea un objeto UConverter
    • UConverter::convert — Convertir un string de un juego de caracteres a otro
    • UConverter::fromUCallback — Función de retrollamada "from" predeterminada
    • UConverter::getAliases — Obtener los alias del nombre dado
    • UConverter::getAvailable — Obtener los nombres canónicos de los convertidores disponibles
    • UConverter::getDestinationEncoding — Obtener la codificación de destino
    • UConverter::getDestinationType — Obtener el tipo del convertidor de destino
    • UConverter::getErrorCode — Obtener el código del último error del objeto
    • UConverter::getErrorMessage — Obtener el último mensaje de error del objeto
    • UConverter::getSourceEncoding — Obtener la codificación de origen
    • UConverter::getSourceType — Obtener el tipo de convertidor de origen
    • UConverter::getStandards — Obtener los estándares asociados a los nombres de los convertidores
    • UConverter::getSubstChars — Obtener los caracteres de sustitución
    • UConverter::reasonText — Obtener la representación de string de la razón de la retrollamada
    • UConverter::setDestinationEncoding — Establecer la codificación destino
    • UConverter::setSourceEncoding — Establecer la codificación origen
    • UConverter::setSubstChars — Establecer los caracteres de sustitución
    • UConverter::toUCallback — Función de retrollamada "to" predeterminada
    • UConverter::transcode — Convertir un string de un juego de caracteres a otro
  • Funciones de Grapheme
    • grapheme_extract — Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8
    • grapheme_stripos — Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
    • grapheme_stristr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
    • grapheme_strlen — Obtener la longitud de un string en unidades de grafema
    • grapheme_strpos — Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
    • grapheme_strripos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
    • grapheme_strrpos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
    • grapheme_strstr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
    • grapheme_substr — Devolver parte de una cadena
  • Funciones de IDN
    • idn_to_ascii — Convierte un nombre de dominio a formato IDNA ASCII
    • idn_to_utf8 — Convierte un nombre de dominio de IDNA ASCII a Unicode
  • IntlChar
    • IntlChar::charAge — Obtener la «edad» del punto de código
    • IntlChar::charDigitValue — Obtener el valor del dígito decimal de un carácter de dígito decimal
    • IntlChar::charDirection — Obtener el valor de la categoría bidireccional de un punto de código
    • IntlChar::charFromName — Buscar un carácter Unicode por su nombre y devolver su valor de punto de código
    • IntlChar::charMirror — Obtener el carácter de «imagen reflejada» de un punto de código
    • IntlChar::charName — Obtener el nombre de un carácter Unicode
    • IntlChar::charType — Obtener el valor de la categoría general de un punto de código
    • IntlChar::chr — Devolver el carácter Unicode mediante su valor de punto de código
    • IntlChar::digit — Obtener el valor del dígito decimal de un punto de código para una base dada
    • IntlChar::enumCharNames — Enumerar todos los caracteres de Unicode con asignación dentro de un rango
    • IntlChar::enumCharTypes — Enumerar todos los puntos de código con sus categorías generales de Unicode
    • IntlChar::foldCase — Realiza un «plegamiento» de un punto de código
    • IntlChar::forDigit — Obtener la representación de un carácter para un dígito y base dados
    • IntlChar::getBidiPairedBracket — Obtener la pareja del carácter parentético de un punto de código
    • IntlChar::getBlockCode — Obtener el bloque de asignación de Unicode que contiene a un punto de código
    • IntlChar::getCombiningClass — Obtener la clase de combinación de un punto de cógido
    • IntlChar::getFC_NFKC_Closure — Obtener la propiedad FC_NFKC_Closure de un punto de código
    • IntlChar::getIntPropertyMaxValue — Obtener el valor máximo de una propiedad de Unicode
    • IntlChar::getIntPropertyMinValue — Obtener el valor mínimo de una propiedad de Unicode
    • IntlChar::getIntPropertyValue — Obtener el valor de una propiedad de Unicode para un punto de código
    • IntlChar::getNumericValue — Obtener el valor numérico de un punto de código de Unicode
    • IntlChar::getPropertyEnum — Obtener el valor de la constante de una propiedad para un nombre de propiedad dado
    • IntlChar::getPropertyName — Obtener el nombre Unicode de una propiedad
    • IntlChar::getPropertyValueEnum — Obtener el valor de una propiedad para un nombre de valor dado
    • IntlChar::getPropertyValueName — Obtener el nombre Unicode para un valor de una propiedad
    • IntlChar::getUnicodeVersion — Obtener la versión de Unicode
    • IntlChar::hasBinaryProperty — Comprobar una propiedad de Unicode binaria para un punto de código
    • IntlChar::isalnum — Comporbar si un punto de código es un carácter alfanumérico
    • IntlChar::isalpha — Comprobar si un punto de código es un caracter de letra
    • IntlChar::isbase — Comprobar si un punto de código es un carácter base
    • IntlChar::isblank — Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»
    • IntlChar::iscntrl — Comprobar si un punto de código es un carácter de control
    • IntlChar::isdefined — Comprobar si un punto de código está definido
    • IntlChar::isdigit — Comprobar si un punto de código es un carácter de dígito
    • IntlChar::isgraph — Comprobar si un punto de código es un caráter gráfico
    • IntlChar::isIDIgnorable — Comprobar si un punto de código es un carácter ignorable
    • IntlChar::isIDPart — Comprobar si un punto de código es permisible en un identificador
    • IntlChar::isIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador
    • IntlChar::isISOControl — Comprobar si un punto de código es un código de control de ISO
    • IntlChar::isJavaIDPart — Comprobar si un punto de código es permisible en un identificador de Java
    • IntlChar::isJavaIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java
    • IntlChar::isJavaSpaceChar — Comprobar si un punto de código es un carácter de espacio según Java
    • IntlChar::islower — Comprobar si un punto de código es una letra minúscula
    • IntlChar::isMirrored — Comprobar si un punto de código posee la propiedad Bidi_Mirrored
    • IntlChar::isprint — Comprobar si un punto de código es un carácter imprimible
    • IntlChar::ispunct — Comprobar si un punto de código es un carácter de puntuación
    • IntlChar::isspace — Comprobar si un punto de código es un carácter de espacio
    • IntlChar::istitle — Comprobar si un punto de código es una letra titular
    • IntlChar::isUAlphabetic — Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic
    • IntlChar::isULowercase — Comprobar si un punto de código tiene la propiedad de Unicode Lowercase
    • IntlChar::isupper — Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
    • IntlChar::isUUppercase — Comprobar si un punto de código tiene la propiedad de Unicode Uppercase
    • IntlChar::isUWhiteSpace — Comprobar si un punto de código tiene la propiedad de Unicode White_Space
    • IntlChar::isWhitespace — Comprobar si un punto de código es un carácter de espacio en blanco según ICU
    • IntlChar::isxdigit — Comprobar si el punto de código es un dígito hexadecimal
    • IntlChar::ord — Devolver el valor del punto de código de Unicode de un carácter
    • IntlChar::tolower — Convertir a minúsculas un carácter Unicode
    • IntlChar::totitle — Convertir un carácter Unicode a letra titular
    • IntlChar::toupper — Convertir a mayúsculas un carácter Unicode
  • IntlException — Clase de excepciones para errores de intl
  • IntlIterator — La clase IntlIterator
    • IntlIterator::current — Obtiene el elemento actual
    • IntlIterator::key — Obtiene la clave actual
    • IntlIterator::next — Adelanta hasta el siguiente elemento
    • IntlIterator::rewind — Mueve el iterador al primer elemento
    • IntlIterator::valid — Comprueba si la posición actual es válida
  • Funciones de intl
    • intl_error_name — Obtiene un nombre simbólico a partir de un código de error dado
    • intl_get_error_code — Obtiene el último código de error
    • intl_get_error_message — Obtener una descripción del último error
    • intl_is_failure — Comprueba si el código de error dado indica un fallo


Introducción

La extensión para la internacionalización (más conocida como Intl) es una envoltura para la biblioteca » ICU, permitiendo a los programadores de PHP realizar varias operaciones que consideran los localismos, incluyendo, aunque no limitándose a, el formatero, transliteración, conversión de codificación, operaciones de calendario, cotejamiento que cumple con la » UCA, localización de límites de texto, y trabajar con identificadoes de localismos, zonas horarias y grafemas.

Tiende a seguir cuidadosamente las APIs de ICU, así que los que posean experiencia trabajando con ICU en C/C++ o en Java pueden fácilmente utilizar la API de PHP. Además, la documentación de ICU sería útil para entender varias funciones de ICU.

Intl consiste de varios módulos, donde cada uno de ellos expone la correspondiente API de ICU:

  • Collator: Proporciona la capacidad de comparar strings con soporte para una ordenación apropiada según la región.
  • Number Formatter: Permite mostrar números según el formato regional o a un patrón dado o a un grupo de reglas, y para convertir strings en números.
  • Message Formatter: Permite la creación de mensajes incorporando datos (tales como números o fechas) formateados según un patrón y reglas regionales dados, y procesa los mensajes extrayendo los datos que hay en ellos. Puede manejar plurales, números de localismos, monedas, condiciones y mucho más.
  • Normalizer: Proporciona una función para transformar texto a una de las formas de normalización de Unicode, y provee de una rutina para comprobar si un string dado ya está normalizado.
  • Locale: Proporciona interacción con identificadores regionales en la forma de funciones para obtener subetiquetas de un identificador regional; analiza, compone, busca y filtra identificadores regionales.
  • Calendar: proporciona una clase que puede emplearse para operaciones de calendarios que consideran localismos y obtener información variada, como la zona horaria para un localismo escogido, primer día de la semana o si se está en el horario de verano.
  • Timezone: proporciona una envoltura sobre la » base de datos "Olson", la cual posee información sobre todas las zonas horarias del mundo.
  • Date formatter: permite mostrar fechas y horas según el formato del localismo, o patrón dado, o conjunto de reglas, y convertir cadenas a fechas y horas.
  • Transliterator: permite obtener representaciones latinas de cadenas en varios lenguajes.
  • Transliterator: permite obtener representaciones latinas de cadenas en varios lenguajes.

Enlaces

  • » Miscelánea de documentos ICU

  • » Guía de usuario de ICU

  • » Algorítmo de Cotejamiento de Unicode (UCA)


Requerimientos

Para construir la extensión es necesario instalar la biblioteca » ICU, versión 4.0.0 o superior.

Desde PHP 5.3.0, esta extensión viene incorporada en PHP. Alternativamente, la versión PECL de esta extensión podría usarse con cualquier versión de PHP superior a 5.2.0 (se recomienda 5.2.4+).


Instalación

Esta extensión puede ser instalada con la versión que viene incorporada a partir de PHP 5.3.0, o como una extensión PECL disponible desde PHP 5.2.0. En otras palabras, existen dos métodos que permiten instalar la extensión intl.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/intl.

Alternativamente, --enable-intl habilitará la versión incorporada mientras se compila PHP.

Si su versión de ICU está instalada en un directorio no estándar, podrá especificar su ubicación en la variable de entorno LD_LIBRARY_PATH de manera que el enlazador dinámico pueda localizarlo:

$ export LD_LIBRARY_PATH=/opt/icu/lib

De otro modo, si PHP e ICU estuvieran instalados en sus ubicaciones predeterminadas, no haría falta utilizar ninguna opción de configuración adicional.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Intl
Nombre | Por defecto | Cambiable | Historial de cambios
intl.default_locale |  | PHP_INI_ALL |
intl.error_level | 0 | PHP_INI_ALL |
intl.use_exceptions | 0 | PHP_INI_ALL | Disponible desde PHP 5.5 y PECL 3.0.0a1

He aquí una breve explicación de las directivas de configuración.

intl.default_locale string

La configuración regional que se usará en funciones de intl cuando no se especifique ningua (omitiendo el argumento correspondiente o pasando NULL). Estas son configuraciones regionales de ICU, no de sistema. Las configuraciones regionales de ICU internas y sus datos pueden explorarse en » http://demo.icu-project.org/icu-bin/locexp.

El valor predeterminado es vacío, lo cual fuerza el uso de la configuración regional predeterminada de ICU. Una vez establecida, el ajuste ini no puede ser reiniciado a su valor predeterminado. No se recomienda confiar en este valor predeterminado, ya que su valor efectivo depende del entorno del servidor.

intl.error_level integer

El nivel de mensajes de error generados cuando ocurre un error en funciones de ICU. Es un nivel de error de PHP, tal como E_WARNING. Se puede establecer a 0 para inhabilitar los mensajes. Esto no afecta a los valores devueltos que indican error o a los valores devueltos por intl_get_error_code() o por los métodos específicos de clase para recuperar códigos de error y mensajes. Si se elige E_ERROR, se terminará el script siempre que se encuentre una condición de error en las clases de intl.

El valor predeterminado es 0.

intl.use_exceptions integer

Si se establece a true, se generará una excepción siempre que ocurra un error en una función de intl. La excepción será de tipo IntlException. Esto posiblemente ocurra además del mensaje de error generado debido a intl.error_level.

El valor predeterminado es false.


Constantes predefinidas

INTL_MAX_LOCALE_LEN (integer)
Limitar la longitud de los nombres de configuración regional, establecido a 80 en el código de PHP. Los nombres de configuración regional mayores que este límite no serán aceptados.
IDNA_DEFAULT (integer)
Prohibir el procesamiento de caracteres no asignados de una página de código en la entrada de las funciones de IDN, y no comprobar si la entrada cumple con las normas ASCII de nombres de dominio.
IDNA_ALLOW_UNASSIGNED (integer)
Permitir el procesamiento de caracteres no asignados de una página de código en la entrada de funciones IDN.
IDNA_USE_STD3_RULES (integer)
Comprobar si la entrada de funciones IDN cumple con las normas ASCII de nombres de dominios.
IDNA_CHECK_BIDI (integer)
Comprobar si la entrada cumple con las reglas BiDi. Ignorada por la implementación IDNA2003, la cual siempre realiza esta comporobación.
IDNA_CHECK_CONTEXTJ (integer)
Comprobar si la entrada cumple con las reglas CONTEXTJ. Ignorada por la implementación IDNA2003, ya que esta comprobación es nueva en IDNA2008.
IDNA_NONTRANSITIONAL_TO_ASCII (integer)
Opción para el procesamiento no transicional de idn_to_ascii(). El procesamiento transicional está activado por omisión. Esta opción es ignorada por la implementación IDNA2003.
IDNA_NONTRANSITIONAL_TO_UNICODE (integer)
Opción para el procesamiento no transicional de idn_to_utf8(). El procesamiento transicional está activado por omisión. Esta opción es ignorada por la implementación IDNA2003.
INTL_IDNA_VARIANT_2003 (integer)
Usar el algoritmo IDNA 2003 en idn_to_utf8() y en idn_to_ascii(). Es el valor predeterminado.
INTL_IDNA_VARIANT_UTS46 (integer)
Usar el algoritmo UTS #46 en idn_to_utf8() y en idn_to_ascii().
IDNA_ERROR_EMPTY_LABEL (integer)
IDNA_ERROR_LABEL_TOO_LONG (integer)
IDNA_ERROR_DOMAIN_NAME_TOO_LONG (integer)
IDNA_ERROR_LEADING_HYPHEN (integer)
IDNA_ERROR_TRAILING_HYPHEN (integer)
IDNA_ERROR_HYPHEN_3_4 (integer)
IDNA_ERROR_LEADING_COMBINING_MARK (integer)
IDNA_ERROR_DISALLOWED (integer)
IDNA_ERROR_PUNYCODE (integer)
IDNA_ERROR_LABEL_HAS_DOT (integer)
IDNA_ERROR_INVALID_ACE_LABEL (integer)
IDNA_ERROR_BIDI (integer)
IDNA_ERROR_CONTEXTJ (integer)
Los errores son reportados en un conjunto de bits devuelto por el algoritmo UTS #46 en idn_to_utf8() y en idn_to_ascii().


  • « Constantes predefinidas
  • Uso básico de esta extensión »
  • PHP Manual
  • intl
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico de esta extensión


Uso básico de esta extensión

Cada módulo proporciona dos tipos de APIs: una procedimental y otra orientada a objetos. En realidad, ambas son idénticas y están descritas en su correspondiente documentación.

Nota:

Todos los strings de entrada deben estar codificados en UTF-8. Del mismo modo, todos los strings de salida deberán estar también en UTF-8.

Ejemplo #1 Ejemplo usando la API procedimental

<?php
$cotejamiento  = collator_create('en_US');
$resultado = collator_compare($cotejamiento, "string#1", "string#2");
?>

Ejemplo #2 Ejemplo usando la API orientada a objetos

<?php
$cotejamiento = new Collator('en_US');
$al = $cotejamiento->getLocale(Locale::ACTUAL_LOCALE);
echo "Configuración regional real: $al\n";

$formateador = new NumberFormatter('en_US', NumberFormatter::DECIMAL);
echo $formateador->format(1234567);
?>


La clase Collator

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

Proporciona la capacidad de comparar strings, con soporte para una ordenación apropiada, según la región.

Sinopsis de la Clase

Collator {
/* Métodos */
public __construct ( string $locale )
public asort ( array &$arr , int $sort_flag = ? ) : bool
public compare ( string $str1 , string $str2 ) : int
public static create ( string $locale ) : Collator
public getAttribute ( int $attr ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( int $type ) : string
public getSortKey ( string $str ) : string
public getStrength ( ) : int
public setAttribute ( int $attr , int $val ) : bool
public setStrength ( int $strength ) : bool
public sortWithSortKeys ( array &$arr ) : bool
public sort ( array &$arr , int $sort_flag = ? ) : bool
}

Constantes predefinidas

Collator::FRENCH_COLLATION (integer)

Ordenar cadenas con diferentes acentos. Este atributo es establecido automáticamente a On para los identificadores regionales franceses y unos pocos más. Los usuarios normalmente no necesitarán establecer explicitamente este atributo. Existe un coste de rendimiento en la comparación de cadenas cuando se establece a On, excepto para la longitud de la clave de ordenación, que no se ve afectada. Los valores posibles son:

  • Collator::ON
  • Collator::OFF (predeterminado)
  • Collator::DEFAULT_VALUE

Ejemplo #1 Reglas de FRENCH_COLLATION

  • F=OFF cote < coté < côte < côté
  • F=ON cote < côte < coté < côté

Collator::ALTERNATE_HANDLING (integer)

El atributo Alternate se usa para controlar el manejo de los también llamados caracters variables en el UCA: los espacios en blanco, de puntuación y símbolos. Si Alternate se establece a NonIgnorable (N), las diferencias entre estos caracteres son de la misma importancia que las diferencias entre letras. Si Alternate se establece a Shifted (S), estos caracteres son de menor importancia. El valor Shifted a menudo se usa en combinación con Strength establecido a Quaternary. En tal caso, los espacios en blanco, de puntuación y símbolos se consideran cuando se comparan las cadenas, pero sólo si todos los demás aspectos de las cadenas (letras base, acentos y si son mayúsculas/minúsculas) son idénticos. Si Alternate no se establece a Shifted, no existe ninguna diferencia entre un Strength de 3 y un Strength de 4. Para más información y algunos ejemplos véase Variable_Weighting en el » UCA. La razoón de que los valores de Alternate no sean simplemente On y Off es que se pueden añadir valores adicionales a Alternate en el futuro. La opción del UCA, Blanked, se expresa con Strength establecido a 3, y Alternate establecido a Shifted. Lo predeterminado para la mayoría de las configuraciones regionales es NonIgnorable. Si se selecciona Shifted, puede ser más lento si existen muchas cadenas que son la misma excepto por la puntuación; la longitud de la clave de ordenación no se verá afectada a menos que el nivel de fuerza (Strength) también sea aumentado.

Los valores posibles son:

  • Collator::NON_IGNORABLE (predeterminado)
  • Collator::SHIFTED
  • Collator::DEFAULT_VALUE

Ejemplo #2 Reglas de ALTERNATE_HANDLING

  • S=3, A=N di Silva < Di Silva < diSilva < U.S.A. < USA
  • S=3, A=S di Silva = diSilva < Di Silva < U.S.A. = USA
  • S=4, A=S di Silva < diSilva < Di Silva < U.S.A. < USA

Collator::CASE_FIRST (integer)

El atributo Case_First se usa para controlar si las letras mayúsculas van antes que las minúsculas o viceversa, en ausencia de otras diferencias en las cadenas. Los valores posibles son Uppercase_First (U) y Lowercase_First (L), más el estándar Default y Off. No existe casi ninguna diferencia entre las opciones Off y Lowercase_First en términos de resultados, por lo que normalmente los usuarios no usarán Lowercase_First: solamente Off o Uppercase_First. (Los interesados en los detalles de las diferencias entre X y L deberían consultar la Personalización del Cotejo). Especificar L o U no afectará al rendimiento de la comparación de cadenas, pero afectará a la longitud de la clave de ordenación.

Los valores posibles son:

  • Collator::OFF (predeterminado)
  • Collator::LOWER_FIRST
  • Collator::UPPER_FIRST
  • Collator:DEFAULT

Ejemplo #3 Reglas de CASE_FIRST

  • C=X or C=L "china" < "China" < "denmark" < "Denmark"
  • C=U "China" < "china" < "Denmark" < "denmark"

Collator::CASE_LEVEL (integer)

El atributo Case_Level se usa para cuando en el texto se quieren ignorar los acentos pero no si son mayúsculas/minúsculas. En tal situación, se establece Strength a Primary, y Case_Level a On. En la mayoría de las configuraciones regionales, este ajuste está establecido a Off por omision. Existe un pequeño impacto en el rendimiento de comparación de cadenas y en la ordenación por clave si este atributo se establece a On.

Los valores posibles son:

  • Collator::OFF (predeterminado)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Ejemplo #4 Reglas de CASE_LEVEL

  • S=1, E=X role = Role = rôle
  • S=1, E=O role = rôle < Role

Collator::NORMALIZATION_MODE (integer)

El ajuste Normalization determina si el texto se normaliza por completo o no en la comparación. Incluso si el ajuste está desactivado (lo predeterminado en muchas configuraciones regionales), el texto representado en su uso común se comparará correctamente (para más detalles, véase UTN #5). Solamente si los acentos están en orden no canónico existirá un problema. Si el ajuste se establece a On, se garantizan los mejores resultados para todas las posibles entradas de texto. Existe un coste medio de rendimiento en la comparación de cadenas si este atributo se establece a On, dependiendo de la frecuencia de secuencias que requiera la normalización. No hay un efecto significativo en la longitud de la clave de ordenación. Si el texto de entrada se sabe que está en la forma de normalización NFD o NFKD, no hay necesidad de habilitar esta opción Normalization.

Los valores posibles son:

  • Collator::OFF (predeterminado)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::STRENGTH (integer)

El Servicio de Cotejo de ICU soporta muchos niveles de comparación (llamados "Levels", pero también conocidos como "Strengths"). Tener estas categorías habilita a ICU para ordenar cadenas de manera precisa según las convenciones regionales. Sin embargo, al permitir que los niveles sean empleados selectivamente, la búsqueda de una cadena en un texto se podrá realizar con varias condiciones de coincidencia. Para una información más detallada, véase el capítlo collator_set_strength().

Los valores posibles son:

  • Collator::PRIMARY
  • Collator::SECONDARY
  • Collator::TERTIARY (predeterminado)
  • Collator::QUATERNARY
  • Collator::IDENTICAL
  • Collator::DEFAULT_VALUE

Collator::HIRAGANA_QUATERNARY_MODE (integer)

La compatibilidad con JIS x 4061 requiere la introducción de un nivel adinional para poder distinguir entre caracteres Hiragana y Katakana. Si se necesita compatibilidad con el estándar, este atributo debería establecerse a On y la fuerza (strength) a Quaternary. Esto afectará a la longitud de la clave de ordenación y al rendimiento en la comparación de cadenas.

Los valores posibles son:

  • Collator::OFF (predeterminado)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::NUMERIC_COLLATION (integer)

Cuando se activa, este atributo genera una clave de cotejo para el valor numérico de subcadenas de dígitos. Es una manera de obtener '100' DESPUÉS de '2' en una ordenación

Los valores posibles son:

  • Collator::OFF (predeterminado)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::DEFAULT_VALUE (integer)
Collator::PRIMARY (integer)
Collator::SECONDARY (integer)
Collator::TERTIARY (integer)
Collator::DEFAULT_STRENGTH (integer)
Collator::QUATERNARY (integer)
Collator::IDENTICAL (integer)
Collator::OFF (integer)
Collator::ON (integer)
Collator::SHIFTED (integer)
Collator::NON_IGNORABLE (integer)
Collator::LOWER_FIRST (integer)
Collator::UPPER_FIRST (integer)

Tabla de contenidos

  • Collator::asort — Ordenar un array manteniendo la relación de índices
  • Collator::compare — Comparar dos cadenas Unicode
  • Collator::__construct — Crear un objeto Collator
  • Collator::create — Crear un cotejador
  • Collator::getAttribute — Obtener el valor de un atributo de cotejo
  • Collator::getErrorCode — Obtener el último código de error del cotejeador
  • Collator::getErrorMessage — Obtener el texto del último código de error del cotejador
  • Collator::getLocale — Obtener el nombre de la configuración regional del cotejador
  • Collator::getSortKey — Obtener la clave de ordenación de una cadena
  • Collator::getStrength — Obtener la fuerza de cotejo actual
  • Collator::setAttribute — Establecer el atributo de cotejo
  • Collator::setStrength — Establecer la fuerza (strength) de un cotejo
  • Collator::sortWithSortKeys — Ordenar un array usando el cotejador y las claves de ordenación especificados
  • Collator::sort — Ordenar un array usando cotejador especificado


Ordenar un array manteniendo la relación de índices

  • « Collator
  • Collator::compare »
  • PHP Manual
  • Collator
  • Ordenar un array manteniendo la relación de índices

Collator::asort

collator_asort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::asort -- collator_asort — Ordenar un array manteniendo la relación de índices

Descripción

Estilo orientado a objetos

public Collator::asort ( array &$arr , int $sort_flag = ? ) : bool

Estilo por procedimientos

collator_asort ( Collator $coll , array &$arr , int $sort_flag = ? ) : bool

Esta función ordena un array de forma que sus índices mantienen su correlación con los elementos del array a los que están asociados. Se usa principalmente en la ordenación de arrays asociativos donde el orden real de los elementos es significativo. Los elementos del array estarán ordenados según las normas actuales regionales.

Es equivalente al estándar de PHP asort().

Parámetros

coll

Un objeto Collator.

arr

El array de cadenas a ordenar.

sort_flag

El tipo de ordenación opcional, uno de los siguientes:

  • Collator::SORT_REGULAR - comparar los elementos de forma normal (no cambia los tipos)

  • Collator::SORT_NUMERIC - comparar los elementos de forma numérica

  • Collator::SORT_STRING - comparar los elementos como cadenas

El valor predeterminado de $sort_flag value es Collator::SORT_REGULAR. También se utiliza si se ha especificado un valor no válido para $sort_flag.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_asort()

<?php
$coll = collator_create( 'en_US' );
$arr = array(
     'a' => '100',
     'b' => '50',
     'c' => '7'
);
collator_asort( $coll, $arr, Collator::SORT_NUMERIC );
var_export( $arr );

collator_asort( $coll, $arr, Collator::SORT_STRING );
var_export( $arr );
?>

El resultado del ejemplo sería:

array (
  'c' => '7',
  'b' => '50',
  'a' => '100',
)array (
  'a' => '100',
  'b' => '50',
  'c' => '7',
)

Ver también

  • Las constantes de Collator
  • collator_sort() - Ordenar un array usando cotejador especificado
  • collator_sort_with_sort_keys() - Ordenar un array usando el cotejador y las claves de ordenación especificados


Comparar dos cadenas Unicode

  • « Collator::asort
  • Collator::__construct »
  • PHP Manual
  • Collator
  • Comparar dos cadenas Unicode

Collator::compare

collator_compare

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::compare -- collator_compare — Comparar dos cadenas Unicode

Descripción

Estilo orientado a objetos

public Collator::compare ( string $str1 , string $str2 ) : int

Estilo por procedimientos

collator_compare ( Collator $coll , string $str1 , string $str2 ) : int

Compara dos cadenas Unicode según las normas de cotejo.

Parámetros

coll

Un objeto Collator.

str1

La primera cadena a comparar.

str2

La segunda cadena a comparar.

Valores devueltos

Devuelve el resultado de la comparación:

  • 1 si str1 es mayor que str2 ;

  • 0 si str1 es igual a str2;

  • -1 si str1 es menor que str2 .

En caso de error es devuelto el valor false de tipo boolean.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplo de collator_compare()

<?php
$s1 = 'Hola';
$s2 = 'hola';

$coll = collator_create( 'en_US' );
$res  = collator_compare( $coll, $s1, $s2 );

if ($res === false) {
    echo collator_get_error_message( $coll );
} else if( $res > 0 ) {
    echo "s1 es mayor que s2\n";
} else if( $res < 0 ) {
    echo "s1 es menor que s2\n";
} else {
    echo "s1 es igual a s2\n";
}
?>

El resultado del ejemplo sería:

s1 es mayor que s2

Ver también

  • collator_sort() - Ordenar un array usando cotejador especificado


Crear un objeto Collator

  • « Collator::compare
  • Collator::create »
  • PHP Manual
  • Collator
  • Crear un objeto Collator

Collator::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::__construct — Crear un objeto Collator

Descripción

public Collator::__construct ( string $locale )

Crea una nueva instancia de Collator.

Parámetros

locale

La configuración regional cuyas normas de cotejo deberían usarse. Se pueden pasar valores especiales de configuraciones regionales - si se proporciona null, se usarán las normas de cotejo regionales predeterminadas. Si se proporciona "root", se usarán las normas del UCA.

Normalmente, el atributo Locale es el más importante para una ordenación y comparación correctas, de acuerdo a las expectativas de los usuarios de paises y regiones diferentes. La ordenación del » UCA predeterminada sólo ordenará unos pocos lenguajes, como el holandés y el portugués, de forma correcta ("de forma correcta" significa de acuerdo a las expectativas normales de los usuarios de dichos lenguajes). De otro modo, es necesario proporcionar la región al UCA para cotejar apropiadamente el texto de un lenguaje dado. Por lo tanto, es necesario proporcionar tanto una configuración regional como elegir un cotejador que se adapte correctamente a esa región. La elección de una configuración regional restablecerá automáticamente todos los atributos a valores que sean razonables para esa región. Por lo tanto, la mayoría de las veces no es necesario establecer los demás atributos de manera explícita. En algunos casos, la elección de una configuración regional creará diferencias en el rendimiento de la comparación de string y/o en la longitud de la clave de ordenación.

Valores devueltos

Devuelve un objeto Collator.

Errores/Excepciones

Devuelve un objeto "vacío" en caso de error. Se puede usar intl_get_error_code() y/o intl_get_error_message() para saber que suceció.

Ejemplos

Ejemplo #1 Ejemplo de Collator::__construct()

<?php
$coll = new Collator( 'en_CA' );
?>

Ver también

  • Collator::create() - Crear un cotejador
  • collator_create() - Crear un cotejador


Crear un cotejador

  • « Collator::__construct
  • Collator::getAttribute »
  • PHP Manual
  • Collator
  • Crear un cotejador

Collator::create

collator_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::create -- collator_create — Crear un cotejador

Descripción

Estilo orientado a objetos

public static Collator::create ( string $locale ) : Collator

Estilo por procedimientos

collator_create ( string $locale ) : Collator

Las cadenas serán comparadas usando las opciones ya especificadas.

Parámetros

locale

La configuración regional que contiene las normas de cotejo requeridas. Se pueden pasar valores especiales de configuraciones regionales - si se le pasa null, se usarán las normas de cotejo regionales predeterminadas. Si se le pasa una cadena vacía ("") o "root", se usarán las normas del » UCA.

Valores devueltos

Devuelve una nueva instancia de un objeto Collator, o null en case de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_create()

<?php
$coll = collator_create( 'en_US' );

if( !isset( $coll ) ) {
    printf( "Falló la creación del cotejador: %s\n", intl_get_error_message() );
    exit( 1 );
}
?>

Ver también

  • Collator::__construct() - Crear un objeto Collator


Obtener el valor de un atributo de cotejo

  • « Collator::create
  • Collator::getErrorCode »
  • PHP Manual
  • Collator
  • Obtener el valor de un atributo de cotejo

Collator::getAttribute

collator_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getAttribute -- collator_get_attribute — Obtener el valor de un atributo de cotejo

Descripción

Estilo orientado a objetos

public Collator::getAttribute ( int $attr ) : int

Estilo por procedimientos

collator_get_attribute ( Collator $coll , int $attr ) : int

Obtiene el valor de un atributo de cotejo de tipo integer.

Parámetros

coll

Collator object.

attr

El atributo del que obtener el valor.

Valores devueltos

El valor del atributo, o false de tipo boolean en case de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_get_attribute()

<?php
$coll = collator_create( 'en_CA' );
$val = collator_get_attribute( $coll, Collator::NUMERIC_COLLATION );
if( $val === false )
{
    // Manejar el error.
}
?>

Ver también

  • Collator constants
  • collator_set_attribute() - Establecer el atributo de cotejo
  • collator_get_strength() - Obtener la fuerza de cotejo actual


Obtener el último código de error del cotejeador

  • « Collator::getAttribute
  • Collator::getErrorMessage »
  • PHP Manual
  • Collator
  • Obtener el último código de error del cotejeador

Collator::getErrorCode

collator_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorCode -- collator_get_error_code — Obtener el último código de error del cotejeador

Descripción

Estilo orientado a objetos

public Collator::getErrorCode ( ) : int

Estilo por procedimientos

collator_get_error_code ( Collator $coll ) : int

Parámetros

coll

Un objeto de la clase Collator.

Valores devueltos

El código de error devuelto por la última llamada a una función de la API de Collator.

Ejemplos

Ejemplo #1 Ejemplo collator_get_error_code()

<?php
$coll = collator_create( 'en_US' );
if( collator_get_attribute( $coll, Collator::FRENCH_COLLATION ) === false )
        handle_error( collator_get_error_code() );
?>

Ver también

  • collator_get_error_message() - Obtener el texto del último código de error del cotejador


Obtener el texto del último código de error del cotejador

  • « Collator::getErrorCode
  • Collator::getLocale »
  • PHP Manual
  • Collator
  • Obtener el texto del último código de error del cotejador

Collator::getErrorMessage

collator_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorMessage -- collator_get_error_message — Obtener el texto del último código de error del cotejador

Descripción

Estilo orientado a objetos

public Collator::getErrorMessage ( ) : string

Estilo por procedimientos

collator_get_error_message ( Collator $coll ) : string

Recupera el mensaje del último error.

Parámetros

coll

Un objeto de la clase Collator.

Valores devueltos

La descripción de un error ocurrido en la última llamada a una función de la API de Collator.

Ejemplos

Ejemplo #1 Ejemplo de collator_get_error_message()

<?php
$coll = collator_create( 'lt' );
if( collator_compare( $coll, 'y', 'k' ) === false ) {
    echo collator_get_error_message( $coll );
}
?>

Ver también

  • collator_get_error_code() - Obtener el último código de error del cotejeador


Obtener el nombre de la configuración regional del cotejador

  • « Collator::getErrorMessage
  • Collator::getSortKey »
  • PHP Manual
  • Collator
  • Obtener el nombre de la configuración regional del cotejador

Collator::getLocale

collator_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getLocale -- collator_get_locale — Obtener el nombre de la configuración regional del cotejador

Descripción

Estilo orientado a objetos

public Collator::getLocale ( int $type ) : string

Estilo por procedimientos

collator_get_locale ( Collator $coll , int $type ) : string

Obtiene el nombre de la configuración regional del cotejador.

Parámetros

coll

Un objeto de la clase Collator.

type

Se puede escoger entre una configuración regional válida y real ( Locale::VALID_LOCALE y Locale::ACTUAL_LOCALE, respectivamente).

Valores devueltos

El nombre de la configuración regional real de donde viene la información del cotejador. Si el cotejador fue instanciado desde normas u ocurrió un error, devuelve false de tipo boolean.

Ejemplos

Ejemplo #1 Ejemplo collator_get_locale()

<?php
$coll    = collator_create( 'en_US_California' );
$res_val = collator_get_locale( $coll, Locale::VALID_LOCALE );
$res_act = collator_get_locale( $coll, Locale::ACTUAL_LOCALE );
printf( "Nombre regional válido: %s\nNombre regional real: %s\n",
         $res_val, $res_act );
?>

El resultado del ejemplo sería:

Requested locale name: en_US_California
Nombre regional válido: en_US
Nombre regional real: en

Ver también

  • collator_create() - Crear un cotejador


Obtener la clave de ordenación de una cadena

  • « Collator::getLocale
  • Collator::getStrength »
  • PHP Manual
  • Collator
  • Obtener la clave de ordenación de una cadena

Collator::getSortKey

collator_get_sort_key

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 1.0.3)

Collator::getSortKey -- collator_get_sort_key — Obtener la clave de ordenación de una cadena

Descripción

Estilo orientado a objetos

public Collator::getSortKey ( string $str ) : string

Estilo por procedimientos

collator_get_sort_key ( Collator $coll , string $str ) : string

Devuelve la clave de cotejo de una cadena.

Parámetros

coll

Un objeto de la clase Collator.

str

La cadena desde la que producir la clave.

Valores devueltos

Devuelve la calve de cotejo de una cadena. Las claves de cotejo se pueden comparar directamente en lugar de por cadenas.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplo de collator_get_sort_key()

<?php
$s1 = 'Hello';

$coll = collator_create( 'en_US' );
$res  = collator_get_sort_key( $coll, $s1);

echo urlencode($res);
?>

El resultado del ejemplo sería:

71%3F%3FE%01%09%01%8F%08%00

Ver también

  • collator_sort() - Ordenar un array usando cotejador especificado
  • collator_sort_with_sort_keys() - Ordenar un array usando el cotejador y las claves de ordenación especificados


Obtener la fuerza de cotejo actual

  • « Collator::getSortKey
  • Collator::setAttribute »
  • PHP Manual
  • Collator
  • Obtener la fuerza de cotejo actual

Collator::getStrength

collator_get_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getStrength -- collator_get_strength — Obtener la fuerza de cotejo actual

Descripción

Estilo orientado a objetos

public Collator::getStrength ( ) : int

Estilo por procedimientos

collator_get_strength ( Collator $coll ) : int

Parámetros

coll

Un objeto Collator.

Valores devueltos

Devuelve la fuerza de cotejo actual, o false de tipo boolean en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_get_strength()

<?php
$coll     = collator_create( 'en_US' );
$strength = collator_get_strength( $coll );
?>

Ver también

  • Las constantes de Collator
  • collator_set_strength() - Establecer la fuerza (strength) de un cotejo
  • collator_get_attribute() - Obtener el valor de un atributo de cotejo


Establecer el atributo de cotejo

  • « Collator::getStrength
  • Collator::setStrength »
  • PHP Manual
  • Collator
  • Establecer el atributo de cotejo

Collator::setAttribute

collator_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setAttribute -- collator_set_attribute — Establecer el atributo de cotejo

Descripción

Estilo orientado a objetos

public Collator::setAttribute ( int $attr , int $val ) : bool

Estilo por procedimientos

collator_set_attribute ( Collator $coll , int $attr , int $val ) : bool

Parámetros

coll

Collator object.

attr

Attribute.

val

El valor del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_set_attribute()

<?php
$coll = collator_create( 'en_CA' );
$val  = collator_set_attribute( $coll, Collator::NUMERIC_COLLATION, Collator::ON );
if ($val === false) {
    // Manejar el error.
} elseif ($val === Collator::ON) {
    // Hacer algo útil.
}
?>

Ver también

  • Las constantes de Collator
  • collator_get_attribute() - Obtener el valor de un atributo de cotejo
  • collator_set_strength() - Establecer la fuerza (strength) de un cotejo


Establecer la fuerza (strength) de un cotejo

  • « Collator::setAttribute
  • Collator::sortWithSortKeys »
  • PHP Manual
  • Collator
  • Establecer la fuerza (strength) de un cotejo

Collator::setStrength

collator_set_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setStrength -- collator_set_strength — Establecer la fuerza (strength) de un cotejo

Descripción

Estilo orientado a objetos

public Collator::setStrength ( int $strength ) : bool

Estilo por procedimientos

collator_set_strength ( Collator $coll , int $strength ) : bool

El Servicio de Cotejo de » ICU soporta muchos niveles de comparación (llamados "Levels", pero también conocidos como "Strengths"). Tener estas categorías habilita a ICU para ordenar cadenas de manera precisa según las convenciones regionales. Sin embargo, al permitir que los niveles sean empleados selectivamente, la búsqueda de una cadena en un texto se podrá realizar con varias condiciones de coincidencia.

  1. Nivel Primario (Primary): Se utiliza normalmente para denotar diferencias entre caracteres base (por ejemplo, "a" < "b"). Es la diferencia más fuerte. Por ejemplo, los diccionarios están divididos en diferentes secciones mediante caracteres base. También se le llama fuerza de nivel 1.

  2. Nivel Secundario (Secondary): Los acentos de los caracteres se consideran diferencias secundarias (por ejemplo, "as" < "às" < "at"). También se pueden considerar como secundarias otras diferencias entre letras, dependiendo del lenguaje. Una diferencia secundaria es ignorada cuando existe una diferencia primaria en cualquier lugar de las cadenas. También se le llama fuerza de nivel 2.

    Nota:

    Nota: En algunos lenguajes (como en el danés), algunas letras acentuadas están consideradas como caracteres base por separado. Sin embargo, en la mayoría de los lenguajes, una letra acentuada solamente tiene una diferencia secundaria con su versión no acentuada de esa misma letra.

  3. Nivel Terciario (Tertiary): Las diferencias entre caracteres mayúsculas y minúsculas se distinguen en el nivel terciario (por ejemplo, "ao" < "Ao" < "aò"). Además, una variante de una letra difiere de su forma base en este nivel (como "A" y " "). Otro ejemplo es la diferencia entre un Kana grande y uno pequeño. Una diferencia terciaria es ignorada cuando existe una diferencia primaria o secundaria en cualquier lugar de las cadenas. También se le llama fuerza de nivel 3.

  4. Nivel Cuaternario (Quaternary): Cuando se ignora la puntuación (véase Ignorar la Puntuación) en el nivel 13, se puede usar un nivel adicional para distinguir entre palabra con y sin puntuación (por ejemplo, "ab" < "a-b" < "aB"). Esta diferencia es ignorada cuando existe una diferencia primaria, secundaria o terciaria. También se le llama fuerza de nivel 4. El nivel cuaternario sólo debería usarse si es necesario ignorar la puntuación o al procesar texto japonés (véase el procesamiento de Hiragana).

  5. Nivel Idéntico (Identical): Cuando todos los demás niveles son iguales, el nivel idéntico se usa como "desempate". Los valores de los caracteres Unicode de la forma NFD de cada cadena se comparan en este nivel, como en el caso de que no existan diferencias en los niveles 14. Por ejemplo, las marcas de cantilación hebreas sólo son distinguibles en este nivel. Este nivel debería usarse poco, ya que las diferencias de los valores de los caracteres entre dos cadenas ocurre en raras ocasiones. Usar este nivel disminuye sustancialmente el rendimiento de la comparación incremental y la generación de claves de ordenación (así como también aumenta la longitud de las claves de ordenación). También es conocido como fuerza de nivel 5

Por ejemplo, se puede escoger ignorar los acentos o ignorara los acentos y si son mayúsculas/minúsculas en la búsqueda de un texto. La mayoría de los caracteres son distinguibles por los tres primeros niveles, y en la mayoría de las configuraciones regionales el valor predeterminado es por lo tanto Tertiary. Sin embargo, si Alternate se establece a Shifted, la fuerza Quaternary se podría usar para romper "empates" entre espacios en blanco, puntiaciones y símbolos que de otra manera serían ignorados. Si se necesita distinguir de manera precisa entre caracteres, se puede usar la fuerza Identical (por ejemplo, la Fuerza Identical distinque entre la A Matemática Pequeña Negrita y la A Matemática Pequeña Itálica). Sin embargo, al usar niveles mayores que el terciario la fuerza Identical resulta en claves de ordenación significativamente más grandes, y un rendimiento más lento en la comparación de cadenas iguales.

Parámetros

coll

Uh objeto Collator.

strength

La fuerza a establecer.

Los valores posibles son:

  • Collator::PRIMARY

  • Collator::SECONDARY

  • Collator::TERTIARY

  • Collator::QUATERNARY

  • Collator::IDENTICAL

  • Collator::DEFAULT_STRENGTH

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_set_strength()

<?php
$arr  = array( 'aò', 'Ao', 'ao' );
$coll = collator_create( 'en_US' );

// Ordenar el array usando la fuerza predeterminada.
collator_sort( $coll, $arr );
var_export( $arr );

// Ordenar el array usando la fuerza primaria.
collator_set_strength( $coll, Collator::PRIMARY );
collator_sort( $coll, $arr );
var_export( $arr );
?>

El resultado del ejemplo sería:

array (
  0 => 'ao',
  1 => 'Ao',
  2 => 'aò',
)
array (
  0 => 'aò',
  1 => 'Ao',
  2 => 'ao',
)

Ver también

  • Las constantes de Collator
  • collator_get_strength() - Obtener la fuerza de cotejo actual


Ordenar un array usando el cotejador y las claves de ordenación especificados

  • « Collator::setStrength
  • Collator::sort »
  • PHP Manual
  • Collator
  • Ordenar un array usando el cotejador y las claves de ordenación especificados

Collator::sortWithSortKeys

collator_sort_with_sort_keys

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sortWithSortKeys -- collator_sort_with_sort_keys — Ordenar un array usando el cotejador y las claves de ordenación especificados

Descripción

Estilo orientado a objetos

public Collator::sortWithSortKeys ( array &$arr ) : bool

Estilo por procedimientos

collator_sort_with_sort_keys ( Collator $coll , array &$arr ) : bool

Esta función es similar collator_sort() excepto que utiliza las claves de ordenación de ICU producidas por ucol_getSortKey() para conseguir más velocidad en arrays grandes.

Parámetros

coll

Un objeto Collator.

arr

El array de cadenas a ordenar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_sort_with_sort_keys()

<?php
$arr  = array( 'Köpfe', 'Kypper', 'Kopfe' );
$coll = collator_create( 'sv' );

collator_sort_with_sort_keys( $coll, $arr );
var_export( $arr );
?>

El resultado del ejemplo sería:

array (
  0 => 'Kopfe',
  1 => 'Kypper',
  2 => 'Köpfe',
)

Ver también

  • Las constantes de Collator
  • collator_sort() - Ordenar un array usando cotejador especificado
  • collator_asort() - Ordenar un array manteniendo la relación de índices


Ordenar un array usando cotejador especificado

  • « Collator::sortWithSortKeys
  • NumberFormatter »
  • PHP Manual
  • Collator
  • Ordenar un array usando cotejador especificado

Collator::sort

collator_sort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sort -- collator_sort — Ordenar un array usando cotejador especificado

Descripción

Estilo orientado a objetos

public Collator::sort ( array &$arr , int $sort_flag = ? ) : bool

Estilo por procedimientos

collator_sort ( Collator $coll , array &$arr , int $sort_flag = ? ) : bool

Esta función ordena un array según las normal regionales actuales.

Es equivalente al estándar de PHP sort().

Parámetros

coll

Un objeto Collator.

arr

El array de cadenas a ordenar.

sort_flag

El tipo de ordenación opcional, uno de los siguientes:

  • Collator::SORT_REGULAR - comparar los elementos de forma normal (no cambia los tipos)

  • Collator::SORT_NUMERIC - comparar los elementos de forma numérica

  • Collator::SORT_STRING - comparar los elementos como cadenas

El valor predeterminado de $sort_flag value es Collator::SORT_REGULAR. También se utiliza si se ha especificado un valor no válido para $sort_flag.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de collator_sort()

<?php
$coll = collator_create( 'en_US' );
$arr  = array( 'at', 'às', 'as' );

var_export( $arr );
collator_sort( $coll, $arr );
var_export( $arr );
?>

El resultado del ejemplo sería:

array (
  0 => 'at',
  1 => 'às',
  2 => 'as',
)array (
  0 => 'as',
  1 => 'às',
  2 => 'at',
)

Ver también

  • Las constantes de Collator
  • collator_asort() - Ordenar un array manteniendo la relación de índices
  • collator_sort_with_sort_keys() - Ordenar un array usando el cotejador y las claves de ordenación especificados


La clase NumberFormatter

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

Los programas almacenan y operan sobre números utilizando una representación binaria independiente de la configuración regional. Cuando se muestra o imprime un número, éste es convertido a una cadena específica regional. Por ejemplo, el número 12345.67 es "12,345.67" en los Estados Unidos, "12 345,67" en Francia y "12.345,67" en Alemania.

Al invocar a los métodos proporcionados por la clase NumberFormatter, se pueden formatear números, valores monetarios y porcentajes de acuerdo a la configuración regional especificada o predeterminada. NumberFormatter es sensible a la configuración regional, por lo que se necesita crear un nuevo objeto NumberFormatter para cada región. Los métodos de NumberFormatter dan formato a números de tipo primitivo, tales como los de tipo double, e imprimien el número como una cadena específica según la región.

Para los valores monetarios se puede utilizar el tipo de formato de moneda para crear un formateador que devuelva una cadena con el número formateado y el símbolo de moneda apropiada. Por supuesto, la clase NumberFormatter ignora los tipos de cambio monetarios, por lo que el número impreso es el mismo sin tener en cuenta la moneda especificada. Esto significa que el mismo número tiene diferentes valores monetarios dependiendo de la moneda regional. Si el numero fuese el 9988776.65, los resultados serían:

  • 9 988 776,65 € en Francia
  • 9.988.776,65 € en Alemania
  • $9,988,776.65 en los Estados Unidos

Para dar formato a los porcentajes, se debe crear un formateador específico de la región con el tipo de formato de porcentaje. Con este formateador, una fracción decimal como 0.75 será mostrada como 75%.

Para un formateo más complejo, como los números escritos con palabras, se usan los formateadores de números basados en reglas.

Sinopsis de la Clase

NumberFormatter {
/* Métodos */
public __construct ( string $locale , int $style , string $pattern = ? )
public static create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter
public formatCurrency ( float $value , string $currency ) : string
public format ( number $value , int $type = ? ) : string
public getAttribute ( int $attr ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( int $type = ? ) : string
public getPattern ( ) : string
public getSymbol ( int $attr ) : string
public getTextAttribute ( int $attr ) : string
public parseCurrency ( string $value , string &$currency , int &$position = ? ) : float
public parse ( string $value , int $type = ? , int &$position = ? ) : mixed
public setAttribute ( int $attr , int $value ) : bool
public setPattern ( string $pattern ) : bool
public setSymbol ( int $attr , string $value ) : bool
public setTextAttribute ( int $attr , string $value ) : bool
}

Constantes predefinidas

Estos estilos son utilzados por la función numfmt_create() para definir el tipo del formateador.

NumberFormatter::PATTERN_DECIMAL (integer)
Formato decimal definido por un patrón
NumberFormatter::DECIMAL (integer)
Formato decimal
NumberFormatter::CURRENCY (integer)
Formato de moneda
NumberFormatter::PERCENT (integer)
Formato de porcentaje
NumberFormatter::SCIENTIFIC (integer)
Formato científico
NumberFormatter::SPELLOUT (integer)
Formato basado en reglas de números escritos con palabras
NumberFormatter::ORDINAL (integer)
Formato basado en reglas de números ordinales
NumberFormatter::DURATION (integer)
Formato basado en reglas de duración
NumberFormatter::PATTERN_RULEBASED (integer)
Formato basado en reglas definido por un patrón
NumberFormatter::DEFAULT_STYLE (integer)
Formato predeterminado para la configuración regional
NumberFormatter::IGNORE (integer)
Alias de PATTERN_DECIMAL

Estas constantes definen cómo se procesan o formatean los números. Deberían usarse como argumentos de numfmt_format() y numfmt_parse().

NumberFormatter::TYPE_DEFAULT (integer)
Deriva el tipo de número del tipo de la variable
NumberFormatter::TYPE_INT32 (integer)
Formatear/procesar como un valor integer de 32 bits
NumberFormatter::TYPE_INT64 (integer)
Formatear/procesar como un valor integer de 64 bits
NumberFormatter::TYPE_DOUBLE (integer)
Formatear/procesar como un valor de coma flotante
NumberFormatter::TYPE_CURRENCY (integer)
FFormatear/procesar como un valor de moneda

Atributos de formato numérico usados por numfmt_get_attribute() y numfmt_set_attribute().

NumberFormatter::PARSE_INT_ONLY (integer)
Procesar sólo los enteros.
NumberFormatter::GROUPING_USED (integer)
Usar un separador de agrupación.
NumberFormatter::DECIMAL_ALWAYS_SHOWN (integer)
Mostrar siempre la coma (punto) decimal.
NumberFormatter::MAX_INTEGER_DIGITS (integer)
Número máximo de dígitos enteros.
NumberFormatter::MIN_INTEGER_DIGITS (integer)
Número mínimo de dígitos enteros.
NumberFormatter::INTEGER_DIGITS (integer)
Dígitos enteros.
NumberFormatter::MAX_FRACTION_DIGITS (integer)
Número máximo de dígitos fraccionarios.
NumberFormatter::MIN_FRACTION_DIGITS (integer)
Número mínimo de dígitos fraccionarios.
NumberFormatter::FRACTION_DIGITS (integer)
Dígitos fraccionarios.
NumberFormatter::MULTIPLIER (integer)
Multiplicador.
NumberFormatter::GROUPING_SIZE (integer)
Tamaño de la agrupación.
NumberFormatter::ROUNDING_MODE (integer)
Modo de redondeo.
NumberFormatter::ROUNDING_INCREMENT (integer)
Incremento del redondeo.
NumberFormatter::FORMAT_WIDTH (integer)
El ancho al que se ajusta la salida de format().
NumberFormatter::PADDING_POSITION (integer)
La posición en la que el relleno tendrá lugar. Véase las constantes de posición de relleno para los posibles valores de los argumentos.
NumberFormatter::SECONDARY_GROUPING_SIZE (integer)
Tamaño de agrupación secundario.
NumberFormatter::SIGNIFICANT_DIGITS_USED (integer)
Utilizar dígitos significativos.
NumberFormatter::MIN_SIGNIFICANT_DIGITS (integer)
Número mínimo de dígitos significativos.
NumberFormatter::MAX_SIGNIFICANT_DIGITS (integer)
Número máximo de dígitos significativos.
NumberFormatter::LENIENT_PARSE (integer)
Modo de proceso poco riguroso usado por los formatos basados en reglas.

Atributos de texto de formato numérico utilizados por numfmt_get_text_attribute() y numfmt_set_text_attribute().

NumberFormatter::POSITIVE_PREFIX (integer)
Prefijo positivo.
NumberFormatter::POSITIVE_SUFFIX (integer)
Sufijo positivo.
NumberFormatter::NEGATIVE_PREFIX (integer)
Prefijo negativo.
NumberFormatter::NEGATIVE_SUFFIX (integer)
Sufijo negativo.
NumberFormatter::PADDING_CHARACTER (integer)
El carácter usado para rellenar el ancho del formato.
NumberFormatter::CURRENCY_CODE (integer)
El código ISO de la moneda.
NumberFormatter::DEFAULT_RULESET (integer)
El conjunto de reglas predeterminadas. Sólo está disponible con formateadores basados en reglas.
NumberFormatter::PUBLIC_RULESETS (integer)
Los conjuntos de reglas públicas. Sólo está disponible con formateadores basados en reglas. Este atributo es de sólo lectura. Los conjuntos de reglas públicas son devueltos como una cadena simple, con cada conjunto de reglas deliminado por ';' (semicolon).

Símbolos de formato numérico utilizados por numfmt_get_symbol() y numfmt_set_symbol().

NumberFormatter::DECIMAL_SEPARATOR_SYMBOL (integer)
El separador decimal.
NumberFormatter::GROUPING_SEPARATOR_SYMBOL (integer)
El separador de agrupación.
NumberFormatter::PATTERN_SEPARATOR_SYMBOL (integer)
El separador de patrones.
NumberFormatter::PERCENT_SYMBOL (integer)
El signo de porcentaje.
NumberFormatter::ZERO_DIGIT_SYMBOL (integer)
Cero.
NumberFormatter::DIGIT_SYMBOL (integer)
Carácter que representa un dígito en el patrón.
NumberFormatter::MINUS_SIGN_SYMBOL (integer)
El símbolo menos.
NumberFormatter::PLUS_SIGN_SYMBOL (integer)
El símbolo más.
NumberFormatter::CURRENCY_SYMBOL (integer)
El símbolo de moneda.
NumberFormatter::INTL_CURRENCY_SYMBOL (integer)
El símbolo internacional de moneda.
NumberFormatter::MONETARY_SEPARATOR_SYMBOL (integer)
El separador monetario.
NumberFormatter::EXPONENTIAL_SYMBOL (integer)
El símbolo exponencial.
NumberFormatter::PERMILL_SYMBOL (integer)
El símbolo por millón.
NumberFormatter::PAD_ESCAPE_SYMBOL (integer)
El carácter de relleno de escape.
NumberFormatter::INFINITY_SYMBOL (integer)
Símbolo de infinito.
NumberFormatter::NAN_SYMBOL (integer)
Símbolo de no-es-un-número (NaN).
NumberFormatter::SIGNIFICANT_DIGIT_SYMBOL (integer)
Símbolo de dígito significativo.
NumberFormatter::MONETARY_GROUPING_SEPARATOR_SYMBOL (integer)
El separador de agrupación monetaria.

Los valores del modo de redondeo utilizados por numfmt_get_attribute() y numfmt_set_attribute() con el atributo NumberFormatter::ROUNDING_MODE.

NumberFormatter::ROUND_CEILING (integer)
Modo de redondeo para redondear hacia el infinito positivo.
NumberFormatter::ROUND_DOWN (integer)
Modo de redondeo para redondear hacia cero.
NumberFormatter::ROUND_FLOOR (integer)
Modo de redondeo para redondear hacia el infinito negativo.
NumberFormatter::ROUND_HALFDOWN (integer)
Modo de redondeo para redondear hacia el "vecino más cercano" a menos que ambos vecinos sean equidistantes, en cuyo caso se redondea hacia abajo.
NumberFormatter::ROUND_HALFEVEN (integer)
Modo de redondeo para redondear hacia el "vecino más cercano" a menos que ambos vecinos sean equidistantes, en cuyo caso se redondea hacia el vecino par.
NumberFormatter::ROUND_HALFUP (integer)
Modo de redondeo para redondear hacia el "vecino más cercano" a menos que ambos vecinos sean equidistantes, en cuyo caso se redondea hacia arriba.
NumberFormatter::ROUND_UP (integer)
Modo de redondeo para redondear lejos del cero.

Valores de posición de relleno utilizados por numfmt_get_attribute() y numfmt_set_attribute() con el atributo NumberFormatter::PADDING_POSITION.

NumberFormatter::PAD_AFTER_PREFIX (integer)
Los caracteres de relleno se insertan después del prefijo.
NumberFormatter::PAD_AFTER_SUFFIX (integer)
Los caracteres de relleno se insertan después del sufijo.
NumberFormatter::PAD_BEFORE_PREFIX (integer)
Los caracteres de relleno se insertan antes del prefijo.
NumberFormatter::PAD_BEFORE_SUFFIX (integer)
Los caracteres de relleno se insertan antes del sufijo.

Ver también

  • » Documentación de formateo de ICU
  • » Formateadores de números de ICU
  • » Formateadores decimales de ICU
  • » Formateadores de números basados en reglas de ICU

Tabla de contenidos

  • NumberFormatter::create — Crear un formateador de números
  • NumberFormatter::formatCurrency — Dar formato a un valor monetario
  • NumberFormatter::format — Dar formato a un número
  • NumberFormatter::getAttribute — Obtener un atributo
  • NumberFormatter::getErrorCode — Obtener el último código de error del formateador
  • NumberFormatter::getErrorMessage — Obtener el último mensaje de error del formateador
  • NumberFormatter::getLocale — Obtener la configuración regional de un formateador
  • NumberFormatter::getPattern — Obtener el patrón del formateador
  • NumberFormatter::getSymbol — Obtener el valor de un símbolo
  • NumberFormatter::getTextAttribute — Obtiene un atributo de texto
  • NumberFormatter::parseCurrency — Procesa un número monetario
  • NumberFormatter::parse — Analiza un número
  • NumberFormatter::setAttribute — Establecer un atributo
  • NumberFormatter::setPattern — Establecer el patrón de un formateador
  • NumberFormatter::setSymbol — Establecer un valor de símbolo
  • NumberFormatter::setTextAttribute — Set a text attribute


Crear un formateador de números

  • « NumberFormatter
  • NumberFormatter::formatCurrency »
  • PHP Manual
  • NumberFormatter
  • Crear un formateador de números

NumberFormatter::create

numfmt_create

NumberFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::create -- numfmt_create -- NumberFormatter::__construct — Crear un formateador de números

Descripción

Estilo orientado a objetos (método)

public static NumberFormatter::create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter

Estilo por procedimientos

numfmt_create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter

Estilo orientado a objetos (constructor)

public NumberFormatter::__construct ( string $locale , int $style , string $pattern = ? )

Crea un formateador de números.

Parámetros

locale

La configuración regional en la que el número deberá ser formateado (nombre de la configuración regional, p.ej. en_CA).

style

El estilo de formo, una de las constanes de estilo de formato. Si se le pasa NumberFormatter::PATTERN_DECIMAL o NumberFormatter::PATTERN_RULEBASED, el formato numérico es abierto usando el patrón dado, el cual debe ajustarse a la sintaxis descrita en la » documentación de DecimalFormat de ICU o en la » documentación de RuleBasedNumberFormat de ICU, respectivamente.

pattern

Una cadena con el patrón si el estilo elegido requiere de un patrón.

Valores devueltos

Devuelve un objeto de la clase NumberFormatter o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_create()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
$fmt = numfmt_create( 'it', NumberFormatter::SPELLOUT );
echo numfmt_format($fmt, 1142)."\n";
?>

Ejemplo #2 Ejemplo de NumberFormatter::create()

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo $fmt->format(1234567.891234567890000)."\n";
$fmt = new NumberFormatter( 'it', NumberFormatter::SPELLOUT );
echo $fmt->format(1142)."\n";
?>

El resultado del ejemplo sería:

1.234.567,891
millicentoquarantadue

Ver también

  • numfmt_format() - Dar formato a un número
  • numfmt_parse() - Analiza un número


Dar formato a un valor monetario

  • « NumberFormatter::create
  • NumberFormatter::format »
  • PHP Manual
  • NumberFormatter
  • Dar formato a un valor monetario

NumberFormatter::formatCurrency

numfmt_format_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::formatCurrency -- numfmt_format_currency — Dar formato a un valor monetario

Descripción

Estilo orientado a objetos

public NumberFormatter::formatCurrency ( float $value , string $currency ) : string

Estilo por procedimientos

numfmt_format_currency ( NumberFormatter $fmt , float $value , string $currency ) : string

Dar formato al valor monetario según las reglas del formateador.

Parámetros

fmt

Objeto NumberFormatter.

value

El valor numérico monetario.

currency

El código 3-letter ISO 4217 de moneda que indica la moneda a usar.

Valores devueltos

Un string representando el valor de moneda formateado, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_format_currency()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "RUR")."\n";
$fmt = numfmt_create( 'ru_RU', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "RUR")."\n";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "RUR")."\n";
$fmt = new NumberFormatter( 'ru_RU', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "RUR")."\n";
?>

El resultado del ejemplo sería:

1.234.567,89 €
1.234.567,89 RUR
1 234 567,89€
1 234 567,89?.

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_format() - Dar formato a un número
  • numfmt_parse_currency() - Procesa un número monetario


Dar formato a un número

  • « NumberFormatter::formatCurrency
  • NumberFormatter::getAttribute »
  • PHP Manual
  • NumberFormatter
  • Dar formato a un número

NumberFormatter::format

numfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::format -- numfmt_format — Dar formato a un número

Descripción

Estilo orientado a objetos

public NumberFormatter::format ( number $value , int $type = ? ) : string

Estilo por procedimientos

numfmt_format ( NumberFormatter $fmt , number $value , int $type = ? ) : string

Dar formato a un valor numérico según las reglas del formateador.

Parámetros

fmt

Objeto NumberFormatter.

value

El valor de formato. Puede ser integer o float, otros valores se convierten en un valor numérico.

type

The tipo de formato a usar.

Valores devueltos

Devuelve un string con el valor formateado, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_format()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_format($fmt))) {
    report_error("Formatter error");
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Formatter error");
}
?>

El resultado del ejemplo sería:

1.234.567,891

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_format_currency() - Dar formato a un valor monetario
  • numfmt_parse() - Analiza un número


Obtener un atributo

  • « NumberFormatter::format
  • NumberFormatter::getErrorCode »
  • PHP Manual
  • NumberFormatter
  • Obtener un atributo

NumberFormatter::getAttribute

numfmt_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getAttribute -- numfmt_get_attribute — Obtener un atributo

Descripción

Estilo orientado a objetos

public NumberFormatter::getAttribute ( int $attr ) : int

Estilo por procedimientos

numfmt_get_attribute ( NumberFormatter $fmt , int $attr ) : int

Obtener un atributo numérico asociado con el formateador. Un ejemplo de un atributo numérico es el número de dígitos enteros que el formateador producirá.

Parámetros

fmt

Objeto NumberFormatter.

attr

Especificador de atributo - una de las constantes numeric attribute.

Valores devueltos

Devuelve el valor de atributo en caso de éxito, o de lo contrario false.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_attribute()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Digits: 3
1.234.567,891
Digits: 2
1.234.567,89

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_get_text_attribute() - Obtiene un atributo de texto
  • numfmt_set_attribute() - Establecer un atributo


Obtener el último código de error del formateador

  • « NumberFormatter::getAttribute
  • NumberFormatter::getErrorMessage »
  • PHP Manual
  • NumberFormatter
  • Obtener el último código de error del formateador

NumberFormatter::getErrorCode

numfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorCode -- numfmt_get_error_code — Obtener el último código de error del formateador

Descripción

Estilo orientado a objetos

public NumberFormatter::getErrorCode ( ) : int

Estilo por procedimientos

numfmt_get_error_code ( NumberFormatter $fmt ) : int

Obtener el código de error de la última función realizada por el formateador.

Parámetros

fmt

Objeto NumberFormatter.

Valores devueltos

Devuelve el código de error de la última llamada al formateador.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_error_code()

<?php
$fmt  = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_get_error_code($fmt))) {
    report_error("Formatter error");
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Formatter error");
}
?>

Ver también

  • numfmt_get_error_message() - Obtener el último mensaje de error del formateador
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener el último mensaje de error del formateador

  • « NumberFormatter::getErrorCode
  • NumberFormatter::getLocale »
  • PHP Manual
  • NumberFormatter
  • Obtener el último mensaje de error del formateador

NumberFormatter::getErrorMessage

numfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorMessage -- numfmt_get_error_message — Obtener el último mensaje de error del formateador

Descripción

Estilo orientado a objetos

public NumberFormatter::getErrorMessage ( ) : string

Estilo por procedimientos

numfmt_get_error_message ( NumberFormatter $fmt ) : string

Obtener mensaje de error de la última función realizada por el formateador.

Parámetros

fmt

Objeto NumberFormatter.

Valores devueltos

Devuelve el mensaje de error de la última llamada al formateador.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_error_message()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$datos = numfmt_format($fmt, 1234567.891234567890000);
var_dump(numfmt_get_error_message($fmt));
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
var_dump(numfmt_get_error_message($fmt));
?>

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener la configuración regional de un formateador

  • « NumberFormatter::getErrorMessage
  • NumberFormatter::getPattern »
  • PHP Manual
  • NumberFormatter
  • Obtener la configuración regional de un formateador

NumberFormatter::getLocale

numfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getLocale -- numfmt_get_locale — Obtener la configuración regional de un formateador

Descripción

Estilo orientado a objetos

public NumberFormatter::getLocale ( int $type = ? ) : string

Estilo por procedimientos

numfmt_get_locale ( NumberFormatter $fmt , int $type = ? ) : string

Obtener el nombre de la configuración regional de un formateador.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

type

Se puede escoger entre una configuración regional válida y real ( Locale::VALID_LOCALE y Locale::ACTUAL_LOCALE, respectivamente). La configuración regional real es la predeterminada.

Valores devueltos

El nombre de la configuración regional usado para crear el formateador.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_locale()

<?php
$req     = 'fr_FR_PARIS';
$fmt     = numfmt_create( $req,  NumberFormatter::DECIMAL);
$res_val = numfmt_get_locale( $fmt, Locale::VALID_LOCALE );
$res_act = numfmt_get_locale( $fmt, Locale::ACTUAL_LOCALE );
printf( "Nombre regional pedido: %s\nNombre regional válido: %s\nNombre regional real: %s\n",
         $req, $res_val, $res_act );
?>

El resultado del ejemplo sería:

Nombre regional pedido: fr_FR_PARIS
Nombre regional válido: fr_FR
Nombre regional real: fr

Ver también

  • numfmt_create() - Crear un formateador de números
  • numfmt_get_error_code() - Obtener el último código de error del formateador


Obtener el patrón del formateador

  • « NumberFormatter::getLocale
  • NumberFormatter::getSymbol »
  • PHP Manual
  • NumberFormatter
  • Obtener el patrón del formateador

NumberFormatter::getPattern

numfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getPattern -- numfmt_get_pattern — Obtener el patrón del formateador

Descripción

Estilo orientado a objetos

public NumberFormatter::getPattern ( ) : string

Estilo por procedimientos

numfmt_get_pattern ( NumberFormatter $fmt ) : string

Extrae el patrón usado por el formateador.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

Valores devueltos

El string con el patroón que es usado por el formateador, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_pattern()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Patrón: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Patrón: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Patrón: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Patrón: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Patrón: #,##0.###
1.234.567,891
Patrón: #0.# kg
1234567,9 kg

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_set_pattern() - Establecer el patrón de un formateador
  • numfmt_create() - Crear un formateador de números


Obtener el valor de un símbolo

  • « NumberFormatter::getPattern
  • NumberFormatter::getTextAttribute »
  • PHP Manual
  • NumberFormatter
  • Obtener el valor de un símbolo

NumberFormatter::getSymbol

numfmt_get_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getSymbol -- numfmt_get_symbol — Obtener el valor de un símbolo

Descripción

Estilo orientado a objetos

public NumberFormatter::getSymbol ( int $attr ) : string

Estilo por procedimientos

numfmt_get_symbol ( NumberFormatter $fmt , int $attr ) : string

Obtiene el símbolo asociado con el formateador. El formateador utiliza símbolos para representar los caracteres especiales dependientes de la configuración regional en un número, por ejemplo el signo de porcentaje. Esta API no está soportada por formateadores basados en reglas.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

attr

El especificador del símbolo, una de las constantes de símbolo de formato.

Valores devueltos

La cadena con el símbolo o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_symbol()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Separador: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Separador: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Separador: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Separador: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Separador: .
1.234.567,891
Separador: *
1*234*567,891

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_set_symbol() - Establecer un valor de símbolo


Obtiene un atributo de texto

  • « NumberFormatter::getSymbol
  • NumberFormatter::parseCurrency »
  • PHP Manual
  • NumberFormatter
  • Obtiene un atributo de texto

NumberFormatter::getTextAttribute

numfmt_get_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getTextAttribute -- numfmt_get_text_attribute — Obtiene un atributo de texto

Descripción

Estilo orientado a objetos

public NumberFormatter::getTextAttribute ( int $attr ) : string

Estilo por procedimientos

numfmt_get_text_attribute ( NumberFormatter $fmt , int $attr ) : string

Obtiene un atributo de texto asociado al formateador. Un ejemplo de un atributo de texto es el sufijo de números positivos. Si el formateador no entiende el atributo, se producirá un error de tipo U_UNSUPPORTED_ERROR. Los formateadores basados en reglas sólo entienden NumberFormatter::DEFAULT_RULESET y NumberFormatter::PUBLIC_RULESETS.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

attr

El especificador del atributo - una de las constantes de atributo de texto.

Valores devueltos

Devuelve el valor del atributo en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_get_text_attribute()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefijo: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefijo: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefijo: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefijo: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Prefijo: -
-1.234.567,891
Prefijo: MINUS
MINUS1.234.567,891

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_get_attribute() - Obtener un atributo
  • numfmt_set_text_attribute() - Set a text attribute


Procesa un número monetario

  • « NumberFormatter::getTextAttribute
  • NumberFormatter::parse »
  • PHP Manual
  • NumberFormatter
  • Procesa un número monetario

NumberFormatter::parseCurrency

numfmt_parse_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parseCurrency -- numfmt_parse_currency — Procesa un número monetario

Descripción

Estilo orientado a objetos

public NumberFormatter::parseCurrency ( string $value , string &$currency , int &$position = ? ) : float

Estilo por procedimientos

numfmt_parse_currency ( NumberFormatter $fmt , string $value , string &$currency , int &$position = ? ) : float

Convierte una cadena en un valor de tipo double y en un valor monetario usando el formateador actual.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

currency

Parámetro que recibe el nombre de la moneda (código de moneda ISO 4217 de 3 letras).

position

Índice de la cadena en la que comenzar el proceso. Cuando el método devuelve, este valor contendrá el índice en el que finalizón el proceso.

Valores devueltos

El valor numérico procesado o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_parse_currency()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::CURRENCY );
$num = "1.234.567,89\xc2\xa0$";
echo "Tenemos ".numfmt_parse_currency($fmt, $num, $curr)." en $curr\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::CURRENCY );
$num = "1.234.567,89\xc2\xa0$";
echo "Tenemos ".$fmt->parseCurrency($num, $curr)." en $curr\n";
?>

El resultado del ejemplo sería:

We have 1234567.89 in USD

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_parse() - Analiza un número
  • numfmt_format_currency() - Dar formato a un valor monetario


Analiza un número

  • « NumberFormatter::parseCurrency
  • NumberFormatter::setAttribute »
  • PHP Manual
  • NumberFormatter
  • Analiza un número

NumberFormatter::parse

numfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parse -- numfmt_parse — Analiza un número

Descripción

Estilo orientado a objetos

public NumberFormatter::parse ( string $value , int $type = ? , int &$position = ? ) : mixed

Estilo por procedimientos

numfmt_parse ( NumberFormatter $fmt , string $value , int $type = ? , int &$position = ? ) : mixed

Pasar de un string a un número usando las reglas actuales de formateo.

Parámetros

fmt

NumberFormatter object.

type

El tipo de formateo a usar. Por defecto, se utiliza NumberFormatter::TYPE_DOUBLE.

position

Lugar del string a partir del cual se debe convertir. Al regresar, este valor contendrá el lugar en el que la conversión ha finalizado.

Valores devueltos

El valor del número convertido o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_parse()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo numfmt_parse($fmt, $num)."\n";
echo numfmt_parse($fmt, $num, NumberFormatter::TYPE_INT32)."\n";
?>

Ejemplo #2 Ejemplo O.O.

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo $fmt->parse($num)."\n";
echo $fmt->parse($num, NumberFormatter::TYPE_INT32)."\n";
?>

El resultado del ejemplo sería:

1234567.891
1234567

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_format() - Dar formato a un número
  • numfmt_parse_currency() - Procesa un número monetario


Establecer un atributo

  • « NumberFormatter::parse
  • NumberFormatter::setPattern »
  • PHP Manual
  • NumberFormatter
  • Establecer un atributo

NumberFormatter::setAttribute

numfmt_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setAttribute -- numfmt_set_attribute — Establecer un atributo

Descripción

Estilo orientado a objetos

public NumberFormatter::setAttribute ( int $attr , int $value ) : bool

Estilo por procedimientos

numfmt_set_attribute ( NumberFormatter $fmt , int $attr , int $value ) : bool

Establece un atributo numértico asociado con el formateador. Un ejemplo de un atributo numérico es el número de dígitos enteros que producirá el formateador.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

attr

El especificador del atributo - una de las constantes de atributo numérico.

value

El valor del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_set_attribute()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Dígitos: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Dígitos: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Dígitos: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Dígitos: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Dígitos: 3
1.234.567,891
Dígitos: 2
1.234.567,89

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_get_attribute() - Obtener un atributo
  • numfmt_set_text_attribute() - Set a text attribute


Establecer el patrón de un formateador

  • « NumberFormatter::setAttribute
  • NumberFormatter::setSymbol »
  • PHP Manual
  • NumberFormatter
  • Establecer el patrón de un formateador

NumberFormatter::setPattern

numfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setPattern -- numfmt_set_pattern — Establecer el patrón de un formateador

Descripción

Estilo orientado a objetos

public NumberFormatter::setPattern ( string $pattern ) : bool

Estilo por procedimientos

numfmt_set_pattern ( NumberFormatter $fmt , string $pattern ) : bool

Establece el patrón usado por el formateador. No se puede usar en formateadores basados en reglas.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

pattern

Un patrón con la sintaxis descrita en la » documentación de DecimalFormat de ICU.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_set_pattern()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Patrón: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Patrón: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Patrón: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Patrón: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Patrón: #,##0.###
1.234.567,891
Patrón: #0.# kg
1234567,9 kg

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_create() - Crear un formateador de números
  • numfmt_get_pattern() - Obtener el patrón del formateador


Establecer un valor de símbolo

  • « NumberFormatter::setPattern
  • NumberFormatter::setTextAttribute »
  • PHP Manual
  • NumberFormatter
  • Establecer un valor de símbolo

NumberFormatter::setSymbol

numfmt_set_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setSymbol -- numfmt_set_symbol — Establecer un valor de símbolo

Descripción

Estilo orientado a objetos

public NumberFormatter::setSymbol ( int $attr , string $value ) : bool

Estilo por procedimientos

numfmt_set_symbol ( NumberFormatter $fmt , int $attr , string $value ) : bool

Establece un símbolo asociado con el formateador. Los formateadores utilizan símbolos para representar los caracteres especiales dependientes de la configuración regional en un número, por ejemplo el signo de porcentaje. Esta API no está soportada por formateadores basados en reglas.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

attr

El especificador del símbolo, una de las constantes de símbolo de formato.

value

El texto para el símbolo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_set_symbol()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Separador: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Separador: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Separador: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Separador: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Separador: .
1.234.567,891
Separador: *
1*234*567,891

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_get_symbol() - Obtener el valor de un símbolo


Set a text attribute

  • « NumberFormatter::setSymbol
  • Locale »
  • PHP Manual
  • NumberFormatter
  • Set a text attribute

NumberFormatter::setTextAttribute

numfmt_set_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setTextAttribute -- numfmt_set_text_attribute — Set a text attribute

Descripción

Estilo orientado a objetos

public NumberFormatter::setTextAttribute ( int $attr , string $value ) : bool

Estilo por procedimientos

numfmt_set_text_attribute ( NumberFormatter $fmt , int $attr , string $value ) : bool

Establece un atributo de texto asociado al formateador. Un ejemplo de un atributo de texto es el sufijo de números positivos. Si el formateador no entiende el atributo, se producirá un error de tipo U_UNSUPPORTED_ERROR. Los formateadores basados en reglas sólo entienden NumberFormatter::DEFAULT_RULESET y NumberFormatter::PUBLIC_RULESETS.

Parámetros

fmt

Un objeto de la clase NumberFormatter.

attr

El especificador del atributo - una de las constanes de atributo de texto.

value

El texto para el valor del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de numfmt_set_text_attribute()

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefijo: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefijo: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Ejemplo #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefijo: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefijo: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

El resultado del ejemplo sería:

Prefijo: -
-1.234.567,891
Prefijo: MINUS
MINUS1.234.567,891

Ver también

  • numfmt_get_error_code() - Obtener el último código de error del formateador
  • numfmt_get_text_attribute() - Obtiene un atributo de texto
  • numfmt_set_attribute() - Establecer un atributo


La clase Locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

Un "Locale" (Configuración Regional) es un identificador utilizado para obtener el lenguaje, la cultura o el comportamiento de una región específica desde una API. Las configuraciones regionales de PHP están organizadas e identificadas de la misma manera que las conficuraciones regionales CLDR usadas por ICU (y que muchos vendedores de sistemas operativos similares a Unix, el Mac, Java, etc., usan). Las configuraciones regionales son identificadores que usan las etiquetas de lenguaje RFC 4646 (que usan guiones, no guiones de subrayado) además de los identificadores más tradiciones que usan guiones de subrayada. A menos que se indique lo contrario, las funciones de esta clase son tolerante con ambos formatos.

Algunos ejemplos de identificadores:

  • en-US (Inglés, Estados Unidos)
  • zh-Hant-TW (Chino, Tradicional, Taiwán)
  • fr-CA, fr-FR (Francés para Canadá y Francia respectivamente)

La clase Locale (y sus funciones procedimentales relacionadas) se usa para interactuar con los identificadores regionales (para verificar que un ID está bien formado, que es válido, etc.). Las extensiones usadas por CLDR en UAX #35 (y heredadas por ICU) son válidas y se utilizan dondequiera que estuvieran normalmente en ICU.

Las configuraciones regionales ("locale") no pueden ser instanciadas como objetos. Todas las funciones y los métodos proporcionados son estáticos.

La cadena nula o vacía obtiene la configuración regional "root". Ésta es equivalente a "en_US_POSIX" en CLDR. Las etiquetas de lenguaje (y por lo tanto los identificadores regionales) no son sensibles a mayúsculas-minúsculas. Existe una función de canonización para hacer que las mayúsculas-minúsculas coincidan con la especificación.

Sinopsis de la Clase

Locale {
/* Métodos */
public static acceptFromHttp ( string $header ) : string
public static canonicalize ( string $locale ) : string
public static composeLocale ( array $subtags ) : string
public static filterMatches ( string $langtag , string $locale , bool $canonicalize = false ) : bool
public static getAllVariants ( string $locale ) : array
public static getDefault ( ) : string
public static getDisplayLanguage ( string $locale , string $in_locale = ? ) : string
public static getDisplayName ( string $locale , string $in_locale = ? ) : string
public static getDisplayRegion ( string $locale , string $in_locale = ? ) : string
public static getDisplayScript ( string $locale , string $in_locale = ? ) : string
public static getDisplayVariant ( string $locale , string $in_locale = ? ) : string
public static getKeywords ( string $locale ) : array
public static getPrimaryLanguage ( string $locale ) : string
public static getRegion ( string $locale ) : string
public static getScript ( string $locale ) : string
public static lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string
public static parseLocale ( string $locale ) : array
public static setDefault ( string $locale ) : bool
}

Constantes predefinidas

Locale::DEFAULT_LOCALE (null)
Usada como parámetro regional con los métodos de varias clases de configuración regional afectadas, como NumberFormatter. Esta constante hace que los métodos usen la configuración regional predeterminada.

Estas constantes describen la elección de la configuración regional para el método getLocalte method de diferentes clases.

Locale::ACTUAL_LOCALE (string)
Esta es la configuración regional de donde realmente proviene la información.
Locale::VALID_LOCALE (string)
Esta es la configuración regional más específica soportada por ICU.

Estas constantes definen cómo se procesan o componen las Configuraciones Regionales. Deberían usarse como claves en el array de argumentos para locale_compose() y son devueltas por locale_parse() como claves del array asociativo devuelto.

Locale::LANG_TAG (string)
Subetiqueta de lenguaje
Locale::EXTLANG_TAG (string)
Subetiqueta de lenguaje extendido
Locale::SCRIPT_TAG (string)
Subetiqueta de script
Locale::REGION_TAG (string)
Subetiqueta de región
Locale::VARIANT_TAG (string)
Subetiqueta de variente
Locale::GRANDFATHERED_LANG_TAG (string)
Subetiqueta de lenguaje exento
Locale::PRIVATE_TAG (string)
Subetiqueta privada

Ver también

  • » RFC 4646 - Etiquetas para la Identificación de Lenguajes
  • » RFC 4647 - Concordancia de Etiquetas de Lenguaje
  • » Proyecto CLDR Unicode: Repositorio de Información de Configuraciones Regionales Común
  • » Registro de Subetiquetas de Lenguaje IANA
  • » Guía de Usuario ICU - Configuración Regional
  • » La API Locale de ICU

Tabla de contenidos

  • Locale::acceptFromHttp — Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP
  • Locale::canonicalize — Canonizar el string de configuración regional
  • Locale::composeLocale — Devolver un ID regional correctamente ordenado y delimitado
  • Locale::filterMatches — Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional
  • Locale::getAllVariants — Obtener las variantes de la configuración regional de entrada
  • Locale::getDefault — Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL
  • Locale::getDisplayLanguage — Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
  • Locale::getDisplayName — Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
  • Locale::getDisplayRegion — Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
  • Locale::getDisplayScript — Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
  • Locale::getDisplayVariant — Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada
  • Locale::getKeywords — Obtener las palabras clave de la configuración regional de entrada
  • Locale::getPrimaryLanguage — Obtener el lenguaje principal de la configuración regional de entrada
  • Locale::getRegion — Obtener la región de la configuración local de entrada
  • Locale::getScript — Obtener la escritura de la configuración regional de entrada
  • Locale::lookup — Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje
  • Locale::parseLocale — Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional
  • Locale::setDefault — Establecer la configuración regional predeterminada en tiempo de ejecución


Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP

  • « Locale
  • Locale::canonicalize »
  • PHP Manual
  • Locale
  • Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP

Locale::acceptFromHttp

locale_accept_from_http

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::acceptFromHttp -- locale_accept_from_http — Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP

Descripción

Estilo orientado a objetos

public static Locale::acceptFromHttp ( string $header ) : string

Estilo por procedimientos

locale_accept_from_http ( string $header ) : string

Intenta encontrar la configuración regional que pueda satisfacer la lista de lenguajes que es pedida por la cabecera "Accept-Language" de HTTP.

Parámetros

header

La cadena que contiene la cabecera "Accept-Language" de acuerdo al formato de RFC 2616.

Valores devueltos

El identificador regional correspondiente.

Ejemplos

Ejemplo #1 Ejemplo de locale_accept_from_http()

<?php
$locale = locale_accept_from_http($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$locale = Locale::acceptFromHttp($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

El resultado del ejemplo sería:

en_US

Ver también

  • locale_lookup() - Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje


Canonizar el string de configuración regional

  • « Locale::acceptFromHttp
  • Locale::composeLocale »
  • PHP Manual
  • Locale
  • Canonizar el string de configuración regional

Locale::canonicalize

locale_canonicalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::canonicalize -- locale_canonicalize — Canonizar el string de configuración regional

Descripción

public static Locale::canonicalize ( string $locale ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

locale

Valores devueltos


Devolver un ID regional correctamente ordenado y delimitado

  • « Locale::canonicalize
  • Locale::filterMatches »
  • PHP Manual
  • Locale
  • Devolver un ID regional correctamente ordenado y delimitado

Locale::composeLocale

locale_compose

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::composeLocale -- locale_compose — Devolver un ID regional correctamente ordenado y delimitado

Descripción

Estilo orientado a objetos

public static Locale::composeLocale ( array $subtags ) : string

Estilo por procedimientos

locale_compose ( array $subtags ) : string

Deveulve un ID regional correctamente ordenado y delimitado. Las claves identifican las subetiquetas del ID regional en particular, y los valores son los valores de las subetiquetas asociadas.

Parámetros

subtags

Un array que contiene una lista de pares clave-valor, donde las claves identifican las subetiquetas del ID regional en particular, y los valores son los valores de las subetiquetas asociadas.

Nota:

Las subetiquetas 'variant' y 'private' pueden tomar un máximo de 15 valores mientras que 'extlang' puede tomar un máximo de 3 valores. Está permitido que las variantes tengan un sufijo de 0-14. Por lo tanto, las claves para el array de entrada pueden ser variant0, variant1, ...,variant14. En el ID regional devuelto, las subetiquetas están ordenadas por sufijo, resultando en variant0 seguido de variant1 seguido de variant2, etc.

Los valores múltiples de 'variant', 'private' y 'extlang' se pueden especificar tanto como array bajo la clave específica (p.ej. 'variant') como claves numeradas múltiples (p.ej. 'variant0', 'variant1', etc.).

Valores devueltos

El identificador regional correspondiente.

Ejemplos

Ejemplo #1 Ejemplo de locale_compose()

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo locale_compose( $arr );
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo Locale::composeLocale( $arr );
?>

El resultado del ejemplo sería:

Locale: en_Hans_CN_nedis_rozaj_x_prv1_prv2

Ver también

  • locale_parse() - Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional


Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional

  • « Locale::composeLocale
  • Locale::getAllVariants »
  • PHP Manual
  • Locale
  • Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional

Locale::filterMatches

locale_filter_matches

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::filterMatches -- locale_filter_matches — Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional

Descripción

Estilo orientado a objetos

public static Locale::filterMatches ( string $langtag , string $locale , bool $canonicalize = false ) : bool

Estilo por procedimientos

locale_filter_matches ( string $langtag , string $locale , bool $canonicalize = false ) : bool

Comprobar si el filtro $langtag coincide con $locale de acuerdo al algoritmo de filtración básica de RFC 4647.

Parámetros

langtag

La etiqueta de lenguaje a comprobar

locale

El rango de lenguajes con el que se realiza la comprobación

canonicalize

Si es verdadero (true), los argumentos serán convertidos a su forma conónica antes de la comparación.

Valores devueltos

true si $locale coincide con $langtag false si no.

Ejemplos

Ejemplo #1 Ejemplo de locale_filter_matches()

<?php
echo (locale_filter_matches('de-DEVA','de-DE', false)) ? "Coincide" : "No coincide";
echo '; ';
echo (locale_filter_matches('de-DE_1996','de-DE', false)) ? "Coincide" : "No coincide";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo (Locale::filterMatches('de-DEVA','de-DE', false)) ? "Coincide" : "No coincide";
echo '; ';
echo (Locale::filterMatches('de-DE-1996','de-DE', false)) ? "Coincide" : "No coincide";
?>

El resultado del ejemplo sería:

No coincide; Coincide

Ver también

  • locale_lookup() - Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje


Obtener las variantes de la configuración regional de entrada

  • « Locale::filterMatches
  • Locale::getDefault »
  • PHP Manual
  • Locale
  • Obtener las variantes de la configuración regional de entrada

Locale::getAllVariants

locale_get_all_variants

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getAllVariants -- locale_get_all_variants — Obtener las variantes de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getAllVariants ( string $locale ) : array

Estilo por procedimientos

locale_get_all_variants ( string $locale ) : array

Obtiene las variantes de la configuración regional de entrada

Parámetros

locale

La configuración regional desde la que extraer las variantes

Valores devueltos

Un array que contienen la lista de todas las subetiquetas de variantes de la configuración regional o null si no están presentes

Ejemplos

Ejemplo #1 Ejepmplo de locale_get_all_variants()

<?php
$arr = locale_get_all_variants('sl_IT_NEDIS_ROJAZ_1901');
var_export( $arr );
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
 $arr = Locale::getAllVariants('sl_IT_NEDIS_ROJAZ_1901');
 var_export( $arr );
?>

El resultado del ejemplo sería:

array (
    0 => 'NEDIS',
    1 => 'ROJAZ',
    2 => '1901',
)

Ver también

  • locale_get_primary_language() - Obtener el lenguaje principal de la configuración regional de entrada
  • locale_get_script() - Obtener la escritura de la configuración regional de entrada
  • locale_get_region() - Obtener la región de la configuración local de entrada


Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL

  • « Locale::getAllVariants
  • Locale::getDisplayLanguage »
  • PHP Manual
  • Locale
  • Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL

Locale::getDefault

locale_get_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDefault -- locale_get_default — Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL

Descripción

Estilo orientado a objetos

public static Locale::getDefault ( ) : string

Estilo por procedimientos

locale_get_default ( ) : string

Obtiene el valor de la configuración regional predeterminada. Cuando se inicializa PHP, este valor se establece al valor 'intl.default_locale' en php.ini si tal valor existe, o desde la función uloc_getDefault() de ICU.

Parámetros

Valores devueltos

La configuración regional actual en tiempo de ejecución

Ejemplos

Ejemplo #1 Ejemplo de locale_get_default()

<?php
ini_set('intl.default_locale', 'de-DE');
echo locale_get_default();
echo '; ';
locale_set_default('fr');
echo locale_get_default();
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
ini_set('intl.default_locale', 'de-DE');
echo Locale::getDefault();
echo '; ';
Locale::setDefault('fr');
echo Locale::getDefault();
?>

El resultado del ejemplo sería:

de-DE; fr

Ver también

  • locale_set_default() - Establecer la configuración regional predeterminada en tiempo de ejecución


Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada

  • « Locale::getDefault
  • Locale::getDisplayName »
  • PHP Manual
  • Locale
  • Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada

Locale::getDisplayLanguage

locale_get_display_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayLanguage -- locale_get_display_language — Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getDisplayLanguage ( string $locale , string $in_locale = ? ) : string

Estilo por procedimientos

locale_get_display_language ( string $locale , string $in_locale = ? ) : string

Devuelve un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada. Si es null se utiliza la configuración regional predeterminada.

Parámetros

locale

La configuración regional de la que devolver un lenguaje manifiesto

in_locale

El formato regional opcional a usar para mostrar el nombre del lenguaje

Valores devueltos

El nombre manifiesto del lenguaje de la configuración regional dada por $locale en el formato apropiado dado por $in_locale.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_display_language()

<?php
echo locale_get_display_language('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'de');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'de');
?>

El resultado del ejemplo sería:

Slovenian;
slov\xc3\xa8ne;
Slowenisch

Ver también

  • locale_get_display_name() - Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
  • locale_get_display_script() - Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
  • locale_get_display_region() - Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
  • locale_get_display_variant() - Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada


Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada

  • « Locale::getDisplayLanguage
  • Locale::getDisplayRegion »
  • PHP Manual
  • Locale
  • Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada

Locale::getDisplayName

locale_get_display_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayName -- locale_get_display_name — Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getDisplayName ( string $locale , string $in_locale = ? ) : string

Estilo por procedimientos

locale_get_display_name ( string $locale , string $in_locale = ? ) : string

Devuelve un nombre manifiesto debidamente localizado de la configuración regional de entrada. Si es null se utiliza la configuración regional predeterminada.

Parámetros

locale

La configuración regional de la que devolver un nombre manifiesto.

in_locale

Formato regional opcional

Valores devueltos

El nombre manifiesto de la configuración regional con el formato apropiado dado por $in_locale.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_display_name()

<?php
echo locale_get_display_name('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'de');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'de');
?>

El resultado del ejemplo sería:

Slovenian (Latin, Italy, Natisone dialect);
slov\xc3\xa8ne (latin, Italie, dialecte de Natisone;
Slowenisch (Lateinisch, Italien, NEDIS)

Ver también

  • locale_get_display_language() - Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
  • locale_get_display_script() - Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
  • locale_get_display_region() - Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
  • locale_get_display_variant() - Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada


Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada

  • « Locale::getDisplayName
  • Locale::getDisplayScript »
  • PHP Manual
  • Locale
  • Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada

Locale::getDisplayRegion

locale_get_display_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayRegion -- locale_get_display_region — Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getDisplayRegion ( string $locale , string $in_locale = ? ) : string

Estilo por procedimientos

locale_get_display_region ( string $locale , string $in_locale = ? ) : string

Devuelve un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada. Si es null se utiliza la configuración regional predeterminada.

Parámetros

locale

La configuración regional de la que devolver una región manifiesta.

in_locale

El formato regional opcional a usar para mostrar el nombre de la región

Valores devueltos

El nombre manifiesto de la región de la configuración regional dada por $locale en el formato apropiado dado por $in_locale.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_display_region()

<?php
echo locale_get_display_region('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'de');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'de');
?>

El resultado del ejemplo sería:

Italy;
Italie;
Italien

Ver también

  • locale_get_display_name() - Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
  • locale_get_display_language() - Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
  • locale_get_display_script() - Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
  • locale_get_display_variant() - Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada


Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada

  • « Locale::getDisplayRegion
  • Locale::getDisplayVariant »
  • PHP Manual
  • Locale
  • Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada

Locale::getDisplayScript

locale_get_display_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayScript -- locale_get_display_script — Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getDisplayScript ( string $locale , string $in_locale = ? ) : string

Estilo por procedimientos

locale_get_display_script ( string $locale , string $in_locale = ? ) : string

Devuelve un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada. Si es null se utiliza la configuración regional predeterminada.

Parámetros

locale

La configuración regional de la que devolver una escritura manifiesta.

in_locale

El formato regional opcional a usar para mostrar el nombre de la escritura

Valores devueltos

El nombre manifiesto de la escritura de la configuración regional dada por $locale en el formato apropiado dado por $in_locale.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_display_script()

<?php
echo locale_get_display_script('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'de');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'de');
?>

El resultado del ejemplo sería:

Latin;
latin;
Lateinisch

Ver también

  • locale_get_display_name() - Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
  • locale_get_display_language() - Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
  • locale_get_display_region() - Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
  • locale_get_display_variant() - Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada


Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada

  • « Locale::getDisplayScript
  • Locale::getKeywords »
  • PHP Manual
  • Locale
  • Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada

Locale::getDisplayVariant

locale_get_display_variant

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayVariant -- locale_get_display_variant — Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getDisplayVariant ( string $locale , string $in_locale = ? ) : string

Estilo por procedimientos

locale_get_display_variant ( string $locale , string $in_locale = ? ) : string

Devuelve un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada. Si es null se utiliza la configuración regional predeterminada.

Parámetros

locale

La configuración regional de la que devolver una variante manifiesta.

in_locale

El formato regional opcional a usar para mostrar el nombre de la variante

Valores devueltos

El nombre manifiesto de la variante de la configuración regional dada por $locale en el formato apropiado dado por $in_locale.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_display_variant()

<?php
echo locale_get_display_variant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'de');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'de');
?>

El resultado del ejemplo sería:

Natisone dialect;
dialecte de Natisone;
NEDIS

Ver también

  • locale_get_display_name() - Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
  • locale_get_display_language() - Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
  • locale_get_display_script() - Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
  • locale_get_display_region() - Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada


Obtener las palabras clave de la configuración regional de entrada

  • « Locale::getDisplayVariant
  • Locale::getPrimaryLanguage »
  • PHP Manual
  • Locale
  • Obtener las palabras clave de la configuración regional de entrada

Locale::getKeywords

locale_get_keywords

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getKeywords -- locale_get_keywords — Obtener las palabras clave de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getKeywords ( string $locale ) : array

Estilo por procedimientos

locale_get_keywords ( string $locale ) : array

Obtiene las palabras clave de la configuración regional de entrada.

Parámetros

locale

La configuración regional de la que extraer las palabras clave.

Valores devueltos

Un array asociativo que contiene los pares palabras-clave/valor de esta configuración regional

Ejemplos

Ejemplo #1 Ejemplo de locale_get_keywords()

<?php
$array_palabras_clave = locale_get_keywords( 'de_DE@currency=EUR;collation=PHONEBOOK' );
if ($array_palabras_clave) {
    foreach ($array_palabras_clave as $clave => $valor) {
        echo "$clave = $valor\n";
    }
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$array_palabras_clave = Locale::getKeywords( 'de_DE@currency=EUR;collation=PHONEBOOK' );
if ($array_palabras_clave) {
    foreach( $array_palabras_clave as $clave => $valor){
        echo "$clave = $valor\n";
    }
}
?>

El resultado del ejemplo sería:

collation = PHONEBOOK
currency = EUR

Ver también

  • locale_get_all_variants() - Obtener las variantes de la configuración regional de entrada


Obtener el lenguaje principal de la configuración regional de entrada

  • « Locale::getKeywords
  • Locale::getRegion »
  • PHP Manual
  • Locale
  • Obtener el lenguaje principal de la configuración regional de entrada

Locale::getPrimaryLanguage

locale_get_primary_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getPrimaryLanguage -- locale_get_primary_language — Obtener el lenguaje principal de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getPrimaryLanguage ( string $locale ) : string

Estilo por procedimientos

locale_get_primary_language ( string $locale ) : string

Obtiene el lenguaje principal de la configuración regional de entrada

Parámetros

locale

La configuración regional desde la que extraer el código del lenguaje principal

Valores devueltos

El código de lenguaje asociado con el lenguaje o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de locale_get_primary_language()

<?php
echo locale_get_primary_language('zh-Hant');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getPrimaryLanguage('zh-Hant');
?>

El resultado del ejemplo sería:

zh

Ver también

  • locale_get_script() - Obtener la escritura de la configuración regional de entrada
  • locale_get_region() - Obtener la región de la configuración local de entrada
  • locale_get_all_variants() - Obtener las variantes de la configuración regional de entrada


Obtener la región de la configuración local de entrada

  • « Locale::getPrimaryLanguage
  • Locale::getScript »
  • PHP Manual
  • Locale
  • Obtener la región de la configuración local de entrada

Locale::getRegion

locale_get_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getRegion -- locale_get_region — Obtener la región de la configuración local de entrada

Descripción

Estilo orientado a objetos

public static Locale::getRegion ( string $locale ) : string

Estilo por procedimientos

locale_get_region ( string $locale ) : string

Obtiene la región de la configuración local de entrada.

Parámetros

locale

La configuración regional desde la que extraer el código de región

Valores devueltos

La subetiqueta de región de la configuración regional o null si no está presente

Ejemplos

Ejemplo #1 Ejemplo de locale_get_region()

<?php
echo locale_get_region('de-CH-1901');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getRegion('de-CH-1901');
?>

El resultado del ejemplo sería:

CH

Ver también

  • locale_get_primary_language() - Obtener el lenguaje principal de la configuración regional de entrada
  • locale_get_script() - Obtener la escritura de la configuración regional de entrada
  • locale_get_all_variants() - Obtener las variantes de la configuración regional de entrada


Obtener la escritura de la configuración regional de entrada

  • « Locale::getRegion
  • Locale::lookup »
  • PHP Manual
  • Locale
  • Obtener la escritura de la configuración regional de entrada

Locale::getScript

locale_get_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getScript -- locale_get_script — Obtener la escritura de la configuración regional de entrada

Descripción

Estilo orientado a objetos

public static Locale::getScript ( string $locale ) : string

Estilo por procedimientos

locale_get_script ( string $locale ) : string

Obtiene la escritura de la configuración regional de entrada.

Parámetros

locale

La configuración regional desde la que extraer el código de la escritura

Valores devueltos

La subetiqueta de la escritura de la configuración regional o null si no está presente

Ejemplos

Ejemplo #1 Ejemplo de locale_get_script()

<?php
echo locale_get_script('sr-Cyrl');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo Locale::getScript('sr-Cyrl');
?>

El resultado del ejemplo sería:

Cyrl

Ver también

  • locale_get_primary_language() - Obtener el lenguaje principal de la configuración regional de entrada
  • locale_get_region() - Obtener la región de la configuración local de entrada
  • locale_get_all_variants() - Obtener las variantes de la configuración regional de entrada


Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje

  • « Locale::getScript
  • Locale::parseLocale »
  • PHP Manual
  • Locale
  • Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje

Locale::lookup

locale_lookup

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::lookup -- locale_lookup — Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje

Descripción

Estilo orientado a objetos

public static Locale::lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string

Estilo por procedimientos

locale_lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string

Busca los elementos en langtag para la mejor coincidencia con el rango de lenguajes especificado en locale de acuerdo al algorítmo de búsqueda de RFC 4647.

Parámetros

langtag

Un array que contiene una lista de etiquetas de lenguaje para compararlas con locale. Se permiten 100 elementos máximo.

locale

La configuración regional a usar como rango de lenguajes en la comparación.

canonicalize

Si es verdadero (true), los argumentos serán convertidos a su forma canónica antes de la comparación.

default

La configuración regional a usar si no se encuentra ninguna coincidencia.

Valores devueltos

La etiqueta de lenguaje más parecida o el valor del parámetro default.

Ejemplos

Ejemplo #1 Ejemplo de locale_lookup()

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo locale_lookup($arr, 'de-DE-1996-x-prv1-prv2', true, 'en_US');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo Locale::lookup($arr, 'de-DE-1996-x-prv1-prv2', true, 'en_US');
?>

El resultado del ejemplo sería:

de_de_1996

Ver también

  • locale_filter_matches() - Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional


Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional

  • « Locale::lookup
  • Locale::setDefault »
  • PHP Manual
  • Locale
  • Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional

Locale::parseLocale

locale_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::parseLocale -- locale_parse — Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional

Descripción

Estilo orientado a objetos

public static Locale::parseLocale ( string $locale ) : array

Estilo por procedimientos

locale_parse ( string $locale ) : array

Devuelve un array de claves-valores de los elementos de las subetiquetas del ID regional.

Parámetros

locale

La configuración regional de donde extraer el array de subetiquetas. Nota: Las subetiquetas 'variant' y 'private' pueden tomar un máximo de 15 valores mientras que 'extlang' puede tomar un máximo de 3 valores.

Valores devueltos

Devuelve un array que contiene una lista pares clave-valor, donde las claves identifican las subetiquetas del ID regional en particular, y los valores son los valores de las subetiquetas asociadas. El array será ordenado de la misma forma que las subetiquetas del ID regional, p.ej. si las variantes del ID regional son '-varX-varY-varZ', el array devuelto contendrá variant0=>varX , variant1=>varY , variant2=>varZ

Ejemplos

Ejemplo #1 Ejemplo locale_parse()

<?php
$arr = locale_parse('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $clave => $valor) {
        echo "$clave : $valor , ";
    }
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$arr = Locale::parseLocale('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $clave => $valor) {
        echo "$clave : $valor , ";
    }
}
?>

El resultado del ejemplo sería:

language : sl , script : Latn , region : IT , variant0 : NEDIS ,

Ver también

  • locale_compose() - Devolver un ID regional correctamente ordenado y delimitado


Establecer la configuración regional predeterminada en tiempo de ejecución

  • « Locale::parseLocale
  • Normalizer »
  • PHP Manual
  • Locale
  • Establecer la configuración regional predeterminada en tiempo de ejecución

Locale::setDefault

locale_set_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::setDefault -- locale_set_default — Establecer la configuración regional predeterminada en tiempo de ejecución

Descripción

Estilo orientado a objetos

public static Locale::setDefault ( string $locale ) : bool

Estilo por procedimientos

locale_set_default ( string $locale ) : bool

Establece la configuración regional predeterminada en tiempo de ejecución a $locale. Esto cambia el valor del identificador regional global 'default_locale' de INTL. Se aceptan extensiones UAX #35.

Parámetros

locale

Es una etiqueta de lenguaje que satisface el estándar BCP 47.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de locale_set_default()

<?php
locale_set_default('de-DE');
echo locale_get_default();
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
Locale::setDefault('de-DE');
echo Locale::getDefault();
?>

El resultado del ejemplo sería:

de-DE

Ver también

  • locale_get_default() - Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL


La clase Normalizer

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

La normalización es un proceso que involucra la transformación de caracteres y secuencias de caracteres en una representación subyacente formalmente definida. Este proceso es más importante cuando el texto necesita ser comparado para propósitos de ordenación y búsqueda, pero también se usa al almacenar texto para asegurarse de que éste se almacena en una representación consistente.

El Consorcio Unicode ha definido varias formas de normalización que reflejan las diferentes necesidades de las aplicaciones:

  • Forma de Normalización D (NFD) - Descomposición Canónica
  • Forma de Normalización C (NFC) - Descomposición Canónica seguida de Composición Canónica
  • Forma de Normalización KD (NFKD) - Descomposición por Compatibilidad
  • Forma de Normalización KC (NFKC) - Descomposición por Compatibilidad seguida de Composición Canónica
Las diferentes formas están definidas en términos de un conjunto de transformaciones realizadas sobre el texto, tranformaciones que están expresadas por un algoritmo y un conjunto de ficheros de datos.

Sinopsis de la Clase

Normalizer {
/* Métodos */
public static getRawDecomposition ( string $input ) : string
public static isNormalized ( string $input , int $form = Normalizer::FORM_C ) : bool
public static normalize ( string $input , int $form = Normalizer::FORM_C ) : string
}

Constantes predefinidas

Las siguientes constantes definen la forma de normalización utilizada por el normalizador:

Normalizer::FORM_C (integer)
Forma de Normalización C (NFC) - Descomposición Canónica seguida de Composición Canónica
Normalizer::FORM_D (integer)
Forma de Normalización D (NFD) - Descomposición Canónica
Normalizer::FORM_KC (integer)
Forma de Normalización KC (NFKC) - Descomposición por Compatibilidad seguida de Composición Canónica
Normalizer::FORM_KD (integer)
Forma de Normalización KD (NFKD) - Descomposición por Compatibilidad
Normalizer::NONE (integer)
Sin descomposición/composición
Normalizer::OPTION_DEFAULT (integer)
Opciones de normalización predeterminadas

Ver también

  • » Normalización Unicode
  • » Normalización Unicode P+F
  • » Guía de usuario ICU - Normalización
  • » Referencia de la API de ICU - Normalización

Tabla de contenidos

  • Normalizer::getRawDecomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
  • Normalizer::isNormalized — Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.
  • Normalizer::normalize — Normaliza la entrada provista y devuelve la cadena normalizada


Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

  • « Normalizer
  • Normalizer::isNormalized »
  • PHP Manual
  • Normalizer
  • Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

Normalizer::getRawDecomposition

normalizer_get_raw_decomposition

(PHP 7 >= 7.3)

Normalizer::getRawDecomposition -- normalizer_get_raw_decomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

Descripción

Estilo orientado a objetos

public static Normalizer::getRawDecomposition ( string $input ) : string

Estilo por procedimientos

normalizer_get_raw_decomposition ( string $input ) : string

Gets the Decomposition_Mapping property, as specified in the Unicode Character Database (UCD), for the given UTF-8 encoded code point.

Parámetros

input

The input string, which should be a single, UTF-8 encoded, code point.

Valores devueltos

Returns a string containing the Decomposition_Mapping property, if present in the UCD.

Returns null if there is no Decomposition_Mapping property for the character.

Ejemplos

Ejemplo #1 Normalizer::getRawDecomposition() example

<?php

$result = "";
$strings = [
    "a",
    "\u{FFDA}",
    "\u{FDFA}",
    "",
    "aa",
    "\xF5",
];

foreach ($strings as $string) {
    $decomposition = Normalizer::getRawDecomposition($string);
    // $decomposition = normalizer_get_raw_decomposition($string); Procedural way

    $error_code = intl_get_error_code();
    $error_message = intl_get_error_message();

    $string_hex = bin2hex($string);
    $result .= "---------------------\n";

    if ($decomposition === null) {
        $result .= "'$string_hex' has no decomposition mapping\n" ;
    } else {
        $result .= "'$string_hex' has the decomposition mapping '" . bin2hex($decomposition) . "'\n" ;
    }

    $result .= "error info: '$error_message' ($error_code)\n";
}

echo $result;
?>

El resultado del ejemplo sería:

---------------------
'61' has no decomposition mapping
error info: 'U_ZERO_ERROR' (0)
---------------------
'efbf9a' has the decomposition mapping 'e385a1'
error info: 'U_ZERO_ERROR' (0)
---------------------
'efb7ba' has the decomposition mapping 'd8b5d984d98920d8a7d984d984d98720d8b9d984d98ad98720d988d8b3d984d985'
error info: 'U_ZERO_ERROR' (0)
---------------------
'' has no decomposition mapping
error info: 'Input string must be exactly one UTF-8 encoded code point long.: U_ILLEGAL_ARGUMENT_ERROR' (1)
---------------------
'6161' has no decomposition mapping
error info: 'Input string must be exactly one UTF-8 encoded code point long.: U_ILLEGAL_ARGUMENT_ERROR' (1)
---------------------
'f5' has no decomposition mapping
error info: 'Code point out of range: U_ILLEGAL_ARGUMENT_ERROR' (1)

Ver también

  • Normalizer::normalize() - Normaliza la entrada provista y devuelve la cadena normalizada
  • Normalizer::isNormalized() - Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.


Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.

  • « Normalizer::getRawDecomposition
  • Normalizer::normalize »
  • PHP Manual
  • Normalizer
  • Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.

Normalizer::isNormalized

normalizer_is_normalized

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::isNormalized -- normalizer_is_normalized — Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.

Descripción

Estilo orientado a objetos

public static Normalizer::isNormalized ( string $input , int $form = Normalizer::FORM_C ) : bool

Estilo por procedimientos

normalizer_is_normalized ( string $input , int $form = Normalizer::FORM_C ) : bool

Comprueba si la cadena proporcionada ya está en la forma de normalización especificada.

Parámetros

input

La cadena de entrada a normalizar

form

Una de las formas de normalización.

Valores devueltos

true si está normalizada, false si no o si hay un error

Ejemplos

Ejemplo #1 Ejemplo de normalizer_is_normalized()

<?php
$carácter_A_anillo = "\xC3\x85"; // 'LETRA LATINA MAYÚSCULA A CON ANILLO SUPERIOR' (U+00C5)
$carácter_anillo_superior_combinación = "\xCC\x8A";  // 'ANILLO SUPERIOR DE COMBINACIÓN' (U+030A)

$carácter_original = 'A' . $carácter_anillo_superior_combinación;
$carácter_normalizado = normalizer_normalize( 'A' . $carácter_anillo_superior_combinación, Normalizer::FORM_C );

echo ( normalizer_is_normalized($carácter_original, Normalizer::FORM_C) ) ? "normalizado" : "no normalizado";
echo '; ';
echo ( normalizer_is_normalized($carácter_normalizado, Normalizer::FORM_C) ) ? "normalizado" : "no normalizado";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$carácter_A_anillo = "\xC3\x85"; // 'LETRA LATINA MAYÚSCULA A CON ANILLO SUPERIOR' (U+00C5)
$carácter_anillo_superior_combinación = "\xCC\x8A";  // 'ANILLO SUPERIOR DE COMBINACIÓN' (U+030A)

$carácter_original = 'A' . $carácter_anillo_superior_combinación;
$carácter_normalizado = Normalizer::normalize( 'A' . $carácter_anillo_superior_combinación, Normalizer::FORM_C );

echo ( Normalizer::isNormalized($carácter_original, Normalizer::FORM_C) ) ? "normalizado" : "no normalizado";
echo '; ';
echo ( Normalizer::isNormalized($carácter_normalizado, Normalizer::FORM_C) ) ? "normalizado" : "no normalizado";
?>

El resultado del ejemplo sería:

no normalizado; normalizado

Ver también

  • normalizer_normalize() - Normaliza la entrada provista y devuelve la cadena normalizada


Normaliza la entrada provista y devuelve la cadena normalizada

  • « Normalizer::isNormalized
  • MessageFormatter »
  • PHP Manual
  • Normalizer
  • Normaliza la entrada provista y devuelve la cadena normalizada

Normalizer::normalize

normalizer_normalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::normalize -- normalizer_normalize — Normaliza la entrada provista y devuelve la cadena normalizada

Descripción

Estilo orientado a objetos

public static Normalizer::normalize ( string $input , int $form = Normalizer::FORM_C ) : string

Estilo por procedimientos

normalizer_normalize ( string $input , int $form = Normalizer::FORM_C ) : string

Normaliza la entrada provista y devuelve la cadena normalizada

Parámetros

input

La cadena de entrada a normalizar

form

Una de las formas de normalización.

Valores devueltos

La cadena normalizada o false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de normalizer_normalize()

<?php
$carácter_A_anillo = "\xC3\x85"; // 'LETRA LATINA MAYÚSCULA A CON ANILLO SUPERIOR' (U+00C5)
$carácter_anillo_superior_combinación = "\xCC\x8A";  // 'ANILLO SUPERIOR DE COMBINACIÓN' (U+030A)

$carácter_1 = normalizer_normalize( $carácter_A_anillo, Normalizer::FORM_C );
$carácter_2 = normalizer_normalize( 'A' . $carácter_anillo_superior_combinación, Normalizer::FORM_C );

echo urlencode($carácter_1);
echo ' ';
echo urlencode($carácter_2);
?>

Ejemplo #2 Ejemplo Orientado a Objetos

<?php
$carácter_A_anillo = "\xC3\x85"; // 'LETRA LATINA MAYÚSCULA A CON ANILLO SUPERIOR' (U+00C5)
$carácter_anillo_superior_combinación = "\xCC\x8A";  // 'ANILLO SUPERIOR DE COMBINACIÓN' (U+030A)

$carácter_1 = Normalizer::normalize( $carácter_A_anillo, Normalizer::FORM_C );
$carácter_2 = Normalizer::normalize( 'A' . $carácter_anillo_superior_combinación, Normalizer::FORM_C );

echo urlencode($carácter_1);
echo ' ';
echo urlencode($carácter_2);
?>

El resultado del ejemplo sería:

%C3%85 %C3%85

Ver también

  • normalizer_is_normalized() - Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.


La clase MessageFormatter

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

MessageFormatter es una clase concreta que permite a los usuarios producir mensajes concatenados neutrales al lenguaje. Los métodos proporcionados por esta clase se utilizan para construir todos los mensajes que son vistos por usuarios finales.

La clase MessageFormatter ensambla mensajes desde varios fragmentos (tales como framentos de texto, números y fechas) proporcionados por el programa. Gracias a la clase MessageFormatter, el programa no necesita conocer el orden de los fragmentos. La clase utiliza las especificaciones de formateo de los fragmentos para ensamblarlos en un mensaje que está contenido en una única cadena dentro de un paquete de recursos. Por ejemplo, MessageFormatter permite imprimir la frase "Finalizada la impresión de x de y ficheros..." de una manera que aún admite flexibilidad para traducciones.

Anteriormente, un mensaje de un usuario final era creado como una sentencia y tratado como una cadna. Este procedimiento creaba problemas para los regionalizadores ya que la estructura de la sentencia, el orden de las palabras, el formato de número, etc., son muy diferentes de un lenguaje a otro. La manera neutral de lenguaje para crear mensajes mantiene cada parte del mensaje separada y proporciona claves a la información. Al utilizar estas claves, la clase MessageFormatter puede concatenar las partes del mensaja, regionalizarlas, y mostrar al usuario final una cadena bien formada.

MessageFormatter toma un conjunto de objetos, les da formato e inserta las cadenas formateadas en un patrón en los lugares apropiados. Los formatos escogidos se pueden usar en conjunto con MessageFormatter para tratar prurales, comparar números, y seleccionarlos desde un array de elementos. Normalmente, el formato del mensaje se obtendrá desde recursos, y los argumentos se establecerán dinámicamente en tiempo de ejecución.

Sinopsis de la Clase

MessageFormatter {
/* Métodos */
public __construct ( string $locale , string $pattern )
public static create ( string $locale , string $pattern ) : MessageFormatter
public static formatMessage ( string $locale , string $pattern , array $args ) : string
public format ( array $args ) : string
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( ) : string
public getPattern ( ) : string
public static parseMessage ( string $locale , string $pattern , string $source ) : array
public parse ( string $value ) : array
public setPattern ( string $pattern ) : bool
}

Ver también

  • » Documentación de formateo de ICU
  • » Descripción del formateo de mensajes de ICU
  • » Formateadores de mensajes de ICU
  • » Formateadores escogidos de ICU

Tabla de contenidos

  • MessageFormatter::create — Construir un nuevo Formateador de Mensajes
  • MessageFormatter::formatMessage — Formateo rápido de un mensaje
  • MessageFormatter::format — Dar formato al mensaje
  • MessageFormatter::getErrorCode — Obtener el código de error de la última operación
  • MessageFormatter::getErrorMessage — Obtener el texto del error de la última operación
  • MessageFormatter::getLocale — Obtener la configuración regional desde la que se creó el formateador
  • MessageFormatter::getPattern — Obtener el patrón usado por el formateador
  • MessageFormatter::parseMessage — Procesar rápidamente una cadena de entrada
  • MessageFormatter::parse — Procesar la cadena de entrada según un patrón
  • MessageFormatter::setPattern — Establecer el patrón usado por el formateador


Construir un nuevo Formateador de Mensajes

  • « MessageFormatter
  • MessageFormatter::formatMessage »
  • PHP Manual
  • MessageFormatter
  • Construir un nuevo Formateador de Mensajes

MessageFormatter::create

MessageFormatter::__construct

msgfmt_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::create -- MessageFormatter::__construct -- msgfmt_create — Construir un nuevo Formateador de Mensajes

Descripción

Estilo orientado a objetos (método)

public static MessageFormatter::create ( string $locale , string $pattern ) : MessageFormatter

Estilo orientado a objetos (constructor):

public MessageFormatter::__construct ( string $locale , string $pattern )

Estilo por procedimientos

msgfmt_create ( string $locale , string $pattern ) : MessageFormatter

Construye un nuevo Formateador de Mensajes

Parámetros

locale

La configuración regional a usar al formatear los argumentos

pattern

La cadena patrón con la que pegar los argumentos. El patrón utiliza una sintaxis 'amigable con apóstrofes'; se ejecuta a través de » umsg_autoQuoteApostrophe antes de ser interpretado.

Valores devueltos

Un object formateador

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_create()

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("es", "{0,number,integer} monos en {1,number,integer} árboles haces {2,number} monos por árbol");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("es", "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol");
echo $fmt->format(array(4560, 123, 4560/123));
?>

El resultado del ejemplo sería:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 monos en 123 árboles hacen 37,073 monos por árbol

Ver también

  • msgfmt_format() - Dar formato al mensaje
  • msgfmt_parse() - Procesar la cadena de entrada según un patrón
  • msgfmt_get_error_code() - Obtener el código de error de la última operación
  • msgfmt_get_error_message() - Obtener el texto del error de la última operación


Formateo rápido de un mensaje

  • « MessageFormatter::create
  • MessageFormatter::format »
  • PHP Manual
  • MessageFormatter
  • Formateo rápido de un mensaje

MessageFormatter::formatMessage

msgfmt_format_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::formatMessage -- msgfmt_format_message — Formateo rápido de un mensaje

Descripción

Estilo orientado a objetos

public static MessageFormatter::formatMessage ( string $locale , string $pattern , array $args ) : string

Estilo por procedimientos

msgfmt_format_message ( string $locale , string $pattern , array $args ) : string

Función de formateo rápido que da formato al string sin tener que crear explícitamente el objeto formateador. Utilice esta función cuando la operación de formateo se realice únicamente una vez y no necesite parámetros o estados para que se mantenga.

Parámetros

locale

La configuración regional a usar para el formateo de partes dependientes de la región

pattern

El patrón de tipo string por el que insertar los elementos. El patrón utiliza una sintaxis 'amigable con apóstrofes'; se ejecuta a través de » umsg_autoQuoteApostrophe antes de ser interpretado.

args

El array de valores a insertar en el string de formato

Valores devueltos

El patrón de tipo string formateado, o false en caso de error

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_format_message()

<?php
echo msgfmt_format_message("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree\n", array(4560, 123, 4560/123));
echo msgfmt_format_message("de", "{0,number,integer} Affen auf {1,number,integer} Bäumen sind {2,number} Affen pro Baum\n", array(4560, 123, 4560/123));
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
echo MessageFormatter::formatMessage("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree\n", array(4560, 123, 4560/123));
echo MessageFormatter::formatMessage("de", "{0,number,integer} Affen auf {1,number,integer} Bäumen sind {2,number} Affen pro Baum\n", array(4560, 123, 4560/123));
?>

El resultado del ejemplo sería:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 monos en 123 árboles hacen 37,073 monos por árbol

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_parse() - Procesar la cadena de entrada según un patrón
  • msgfmt_get_error_code() - Obtener el código de error de la última operación
  • msgfmt_get_error_message() - Obtener el texto del error de la última operación


Dar formato al mensaje

  • « MessageFormatter::formatMessage
  • MessageFormatter::getErrorCode »
  • PHP Manual
  • MessageFormatter
  • Dar formato al mensaje

MessageFormatter::format

msgfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::format -- msgfmt_format — Dar formato al mensaje

Descripción

Estilo orientado a objetos

public MessageFormatter::format ( array $args ) : string

Estilo por procedimientos

msgfmt_format ( MessageFormatter $fmt , array $args ) : string

Da formato al mensaje mediante la sustitución de los datos en la cadena de formato de acuerdo con las normas de configuración regional

Parámetros

fmt

El formateador de mensajes

args

Los argumentos para insertar en la cadena de formato

Valores devueltos

La cadena de formato, o false si ocurre un error

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_format()

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("es", "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("es", "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol");
echo $fmt->format(array(4560, 123, 4560/123));
?>

El resultado del ejemplo sería:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 monos en 123 árboles hacen 37,073 monos por árbol

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_parse() - Procesar la cadena de entrada según un patrón
  • msgfmt_format_message() - Formateo rápido de un mensaje
  • msgfmt_get_error_code() - Obtener el código de error de la última operación
  • msgfmt_get_error_message() - Obtener el texto del error de la última operación


Obtener el código de error de la última operación

  • « MessageFormatter::format
  • MessageFormatter::getErrorMessage »
  • PHP Manual
  • MessageFormatter
  • Obtener el código de error de la última operación

MessageFormatter::getErrorCode

msgfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorCode -- msgfmt_get_error_code — Obtener el código de error de la última operación

Descripción

Estilo orientado a objetos

public MessageFormatter::getErrorCode ( ) : int

Estilo por procedimientos

msgfmt_get_error_code ( MessageFormatter $fmt ) : int

Obtiene el código de error de la última operación.

Parámetros

fmt

El formateador de mensajes

Valores devueltos

El código de error, uno del os valores UErrorCode. El valor inicial es U_ZERO_ERROR.

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_get_error_code()

<?php
$fmt = msgfmt_create("en_US", "{0, number} monkeys on {1, number} trees");
$str = msgfmt_format($fmt, array());
if(!$str) {
    echo "ERROR: ".msgfmt_get_error_message($fmt) . " (" . msgfmt_get_error_code($fmt) . ")\n";
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter("en_US", "{0, number} monkeys on {1, number} trees");
$str = $fmt->format(array());
if(!$str) {
    echo "ERROR: ".$fmt->getErrorMessage() . " (" . $fmt->getErrorCode() . ")\n";
}
?>

El resultado del ejemplo sería:

ERROR: msgfmt_format: not enough parameters: U_ILLEGAL_ARGUMENT_ERROR (1)

Ver también

  • msgfmt_get_error_message() - Obtener el texto del error de la última operación
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener el texto del error de la última operación

  • « MessageFormatter::getErrorCode
  • MessageFormatter::getLocale »
  • PHP Manual
  • MessageFormatter
  • Obtener el texto del error de la última operación

MessageFormatter::getErrorMessage

msgfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorMessage -- msgfmt_get_error_message — Obtener el texto del error de la última operación

Descripción

Estilo orientado a objetos

public MessageFormatter::getErrorMessage ( ) : string

Estilo por procedimientos

msgfmt_get_error_message ( MessageFormatter $fmt ) : string

Obtener el texto del error de la última operación.

Parámetros

fmt

El formateador de mensajes

Valores devueltos

La descripción del último error.

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_get_error_message()

<?php
$fmt = msgfmt_create("en_US", "{0, number} monkeys on {1, number} trees");
$str = msgfmt_format($fmt, array());
if(!$str) {
    echo "ERROR: ".msgfmt_get_error_message($fmt) . " (" . msgfmt_get_error_code($fmt) . ")\n";
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter("en_US", "{0, number} monkeys on {1, number} trees");
$str = $fmt->format(array());
if(!$str) {
    echo "ERROR: ".$fmt->getErrorMessage() . " (" . $fmt->getErrorCode() . ")\n";
}
?>

El resultado del ejemplo sería:

ERROR: msgfmt_format: not enough parameters: U_ILLEGAL_ARGUMENT_ERROR (1)

Ver también

  • msgfmt_get_error_code() - Obtener el código de error de la última operación
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener la configuración regional desde la que se creó el formateador

  • « MessageFormatter::getErrorMessage
  • MessageFormatter::getPattern »
  • PHP Manual
  • MessageFormatter
  • Obtener la configuración regional desde la que se creó el formateador

MessageFormatter::getLocale

msgfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getLocale -- msgfmt_get_locale — Obtener la configuración regional desde la que se creó el formateador

Descripción

Estilo orientado a objetos

public MessageFormatter::getLocale ( ) : string

Estilo por procedimientos

msgfmt_get_locale ( NumberFormatter $formatter ) : string

Obtiene la configuración regional desde la que se creó el formateador.

Parámetros

formatter

El recurso del formateador

Valores devueltos

El nombre de la configuración regional

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_get_locale()

<?php
$fmt = msgfmt_create('en_US', "Number {0,number}");
echo msgfmt_get_locale($fmt);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter('en_US', "Number {0,number}");
echo $fmt->getLocale();
?>

El resultado del ejemplo sería:

en_US

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes


Obtener el patrón usado por el formateador

  • « MessageFormatter::getLocale
  • MessageFormatter::parseMessage »
  • PHP Manual
  • MessageFormatter
  • Obtener el patrón usado por el formateador

MessageFormatter::getPattern

msgfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getPattern -- msgfmt_get_pattern — Obtener el patrón usado por el formateador

Descripción

Estilo orientado a objetos

public MessageFormatter::getPattern ( ) : string

Estilo por procedimientos

msgfmt_get_pattern ( MessageFormatter $fmt ) : string

Obtiene el patrón usado por el formateador

Parámetros

fmt

El formateador de mensajes

Valores devueltos

El string del patrón para este formateador

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_get_pattern()

<?php
$fmt = msgfmt_create( "es_ES", "{0, number} monos en {1, number} árboles" );
echo "Patrón predeterminado: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Resultado del formateo: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} árboles alojan {1, number} monos" );
echo "Patrón nuevo: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Número formateado: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter( "es_ES", "{0, number} monos en {1, number} árboles" );
echo "Patrón predeterminado: '" . $fmt->getPattern() . "'\n";
echo "Resultado del formateo: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern( "{0, number} árboles alojan {1, number} monos" );
echo "Patrón nuevo: '" . $fmt->getPattern() . "'\n";
echo "Número formateado: " . $fmt->format(array(123, 456)) . "\n";
?>

El resultado del ejemplo sería:

Patrón predeterminado: '{0, number} monos en {1, number} árboles'
Resultado del formateo: 123 monos en 456 árboles
Patrón nuevo: '{0, number} árboles alojan {1, number} monos'
Número formateado: 123 árboles alojan 456 monos

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_set_pattern() - Establecer el patrón usado por el formateador


Procesar rápidamente una cadena de entrada

  • « MessageFormatter::getPattern
  • MessageFormatter::parse »
  • PHP Manual
  • MessageFormatter
  • Procesar rápidamente una cadena de entrada

MessageFormatter::parseMessage

msgfmt_parse_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parseMessage -- msgfmt_parse_message — Procesar rápidamente una cadena de entrada

Descripción

Estilo orientado a objetos

public static MessageFormatter::parseMessage ( string $locale , string $pattern , string $source ) : array

Estilo por procedimientos

msgfmt_parse_message ( string $locale , string $pattern , string $value ) : array

Procesa una cadena de entrada sin crear explícitamente el objeto formateador. Utilice esta función cuando la operación de formateo se realice sólo una vez y no necesite parámetros o estados para que se mantenga.

Parámetros

locale

La configuración regional a usar para el procesamiento de las partes dependientes de la región

pattern

El patrón con el que procesar value.

source

El string a procesar, de acuerdo al patrón dado por pattern.

Valores devueltos

Un array que contiene los elementos extraídos, o false en caseo de error

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_parse_message()

<?php
$fmt = msgfmt_parse_message('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree",
                            "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($fmt);

$fmt = msgfmt_parse_message('es', "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol",
                            "4.560 monos en 123 árboles hacen 37,073 monos por árbol");
var_export($fmt);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = MessageFormatter::parseMessage('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree",
                            "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($fmt);

$fmt = MessageFormatter::parseMessage('es', "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol",
                            "4.560 monos en 123 árboles hacen 37,073 monos por árbol");
var_export($fmt);
?>

El resultado del ejemplo sería:

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)
array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_format_message() - Formateo rápido de un mensaje
  • msgfmt_parse() - Procesar la cadena de entrada según un patrón


Procesar la cadena de entrada según un patrón

  • « MessageFormatter::parseMessage
  • MessageFormatter::setPattern »
  • PHP Manual
  • MessageFormatter
  • Procesar la cadena de entrada según un patrón

MessageFormatter::parse

msgfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parse -- msgfmt_parse — Procesar la cadena de entrada según un patrón

Descripción

Estilo orientado a objetos

public MessageFormatter::parse ( string $value ) : array

Estilo por procedimientos

msgfmt_parse ( MessageFormatter $fmt , string $value ) : array

Procesa el string de entrada y devuelve cualquier elemento extraído en un array.

Parámetros

fmt

El formateador de mensajes

value

El string a procesar

Valores devueltos

Un array que contiene los elementos extraídos, o false en caso de error

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_parse()

<?php
$fmt = msgfmt_create('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
$res = msgfmt_parse($fmt, "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = msgfmt_create('es', "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol");
$res = msgfmt_parse($fmt, "4.560 monos en 123 árboles hacen 37,073 monos por árbol");
var_export($res);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
$res = $fmt->parse("4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = new MessageFormatter('es', "{0,number,integer} monos en {1,number,integer} árboles hacen {2,number} monos por árbol");
$res = $fmt->parse("4.560 monos en 123 árboles hacen 37,073 monos por árbol");
var_export($res);
?>

El resultado del ejemplo sería:

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)
array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_format() - Dar formato al mensaje
  • msgfmt_parse_message() - Procesar rápidamente una cadena de entrada


Establecer el patrón usado por el formateador

  • « MessageFormatter::parse
  • IntlCalendar »
  • PHP Manual
  • MessageFormatter
  • Establecer el patrón usado por el formateador

MessageFormatter::setPattern

msgfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::setPattern -- msgfmt_set_pattern — Establecer el patrón usado por el formateador

Descripción

Estilo orientado a objetos

public MessageFormatter::setPattern ( string $pattern ) : bool

Estilo por procedimientos

msgfmt_set_pattern ( MessageFormatter $fmt , string $pattern ) : bool

Establece el patrón usado por el formateador

Parámetros

fmt

El formateador de mensajes

pattern

El patrón de tipo string para utilizarlo en el formateador de mensajes. El patrón utiliza una sintaxis 'amigable con apóstrofes'; se ejecuta a través de » umsg_autoQuoteApostrophe antes de ser interpretado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de msgfmt_set_pattern()

<?php
$fmt = msgfmt_create( "es_ES", "{0, number} monos en {1, number} árboles" );
echo "Patrón predeterminado: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Resultado del formateo: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} árboles alojan {1, number} monos" );
echo "Patrón nuevo: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Número formateado: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new MessageFormatter( "es_ES", "{0, number} monos en {1, number} árboles" );
echo "Patrón predeterminado: '" . $fmt->getPattern() . "'\n";
echo "Resultado del formateo: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern( "{0, number} árboles alojan {1, number} monos" );
echo "Patrón nuevo: '" . $fmt->getPattern() . "'\n";
echo "Número formateado: " . $fmt->format(array(123, 456)) . "\n";
?>

El resultado del ejemplo sería:

Patrón predeterminado: '{0, number} monos en {1, number} árboles'
Resultado del formateo: 123 monos en 456 árboles
Patrón nuevo: '{0, number} árboles alojan {1, number} monos'
Número formateado: 123 árboles alojan 456 monos

Ver también

  • msgfmt_create() - Construir un nuevo Formateador de Mensajes
  • msgfmt_get_pattern() - Obtener el patrón usado por el formateador


La clase IntlCalendar

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

Introducción

Sinopsis de la Clase

IntlCalendar {
/* Constantes */
const integer FIELD_ERA = 0 ;
const integer FIELD_YEAR = 1 ;
const integer FIELD_MONTH = 2 ;
const integer FIELD_WEEK_OF_YEAR = 3 ;
const integer FIELD_WEEK_OF_MONTH = 4 ;
const integer FIELD_DATE = 5 ;
const integer FIELD_DAY_OF_YEAR = 6 ;
const integer FIELD_DAY_OF_WEEK = 7 ;
const integer FIELD_DAY_OF_WEEK_IN_MONTH = 8 ;
const integer FIELD_AM_PM = 9 ;
const integer FIELD_HOUR = 10 ;
const integer FIELD_HOUR_OF_DAY = 11 ;
const integer FIELD_MINUTE = 12 ;
const integer FIELD_SECOND = 13 ;
const integer FIELD_MILLISECOND = 14 ;
const integer FIELD_ZONE_OFFSET = 15 ;
const integer FIELD_DST_OFFSET = 16 ;
const integer FIELD_YEAR_WOY = 17 ;
const integer FIELD_DOW_LOCAL = 18 ;
const integer FIELD_EXTENDED_YEAR = 19 ;
const integer FIELD_JULIAN_DAY = 20 ;
const integer FIELD_MILLISECONDS_IN_DAY = 21 ;
const integer FIELD_IS_LEAP_MONTH = 22 ;
const integer FIELD_FIELD_COUNT = 23 ;
const integer FIELD_DAY_OF_MONTH = 5 ;
const integer DOW_SUNDAY = 1 ;
const integer DOW_MONDAY = 2 ;
const integer DOW_TUESDAY = 3 ;
const integer DOW_WEDNESDAY = 4 ;
const integer DOW_THURSDAY = 5 ;
const integer DOW_FRIDAY = 6 ;
const integer DOW_SATURDAY = 7 ;
const integer DOW_TYPE_WEEKDAY = 0 ;
const integer DOW_TYPE_WEEKEND = 1 ;
const integer DOW_TYPE_WEEKEND_OFFSET = 2 ;
const integer DOW_TYPE_WEEKEND_CEASE = 3 ;
const integer WALLTIME_FIRST = 1 ;
const integer WALLTIME_LAST = 0 ;
const integer WALLTIME_NEXT_VALID = 2 ;
/* Métodos */
public add ( int $field , int $amount ) : bool
intlcal_add ( IntlCalendar $cal , int $field , int $amount ) : bool
public after ( IntlCalendar $other ) : bool
intlcal_after ( IntlCalendar $cal , IntlCalendar $other ) : bool
public before ( IntlCalendar $other ) : bool
intlcal_before ( IntlCalendar $cal , IntlCalendar $other ) : bool
public clear ( int $field = NULL ) : bool
intlcal_clear ( IntlCalendar $cal , int $field = NULL ) : bool
private __construct ( )
public static createInstance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar
intlcal_create_instance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar
public equals ( IntlCalendar $other ) : bool
intlcal_equals ( IntlCalendar $cal , IntlCalendar $other ) : bool
public fieldDifference ( float $when , int $field ) : int
intlcal_field_difference ( IntlCalendar $cal , float $when , int $field ) : int
public static fromDateTime ( mixed $dateTime ) : IntlCalendar
intlcal_from_date_time ( mixed $dateTime ) : IntlCalendar
public get ( int $field ) : int
intlcal_get ( IntlCalendar> $cal , int $field ) : int
public getActualMaximum ( int $field ) : int
intlcal_get_actual_maximum ( IntlCalendar $cal , int $field ) : int
public getActualMinimum ( int $field ) : int
intlcal_get_actual_minimum ( IntlCalendar $cal , int $field ) : int
public static getAvailableLocales ( ) : array
intlcal_get_available_locales ( ) : array
public getDayOfWeekType ( int $dayOfWeek ) : int
intlcal_get_day_of_week_type ( IntlCalendar $cal , int $dayOfWeek ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getFirstDayOfWeek ( ) : int
intlcal_get_first_day_of_week ( IntlCalendar $cal ) : int
public getGreatestMinimum ( int $field ) : int
intlcal_get_greatest_minimum ( IntlCalendar $cal , int $field ) : int
public static getKeywordValuesForLocale ( string $key , string $locale , boolean $commonlyUsed ) : Iterator
intlcal_get_keyword_values_for_locale ( string $key , string $locale , boolean $commonlyUsed ) : Iterator
public getLeastMaximum ( int $field ) : int
intlcal_get_least_maximum ( IntlCalendar $cal , int $field ) : int
public getLocale ( int $localeType ) : string
intlcal_get_locale ( IntlCalendar $cal , int $localeType ) : string
public getMaximum ( int $field ) : int
intlcal_get_maximum ( IntlCalendar $cal , int $field ) : int
public getMinimalDaysInFirstWeek ( ) : int
intlcal_get_minimal_days_in_first_week ( IntlCalendar $cal ) : int
public getMinimum ( int $field ) : int
intlcal_get_minimum ( IntlCalendar $cal , int $field ) : int
public static getNow ( ) : float
intlcal_get_now ( ) : float
public getRepeatedWallTimeOption ( ) : int
intlcal_get_repeated_wall_time_option ( IntlCalendar $cal ) : int
public getSkippedWallTimeOption ( ) : int
intlcal_get_skipped_wall_time_option ( IntlCalendar $cal ) : int
public getTime ( ) : float
intlcal_get_time ( IntlCalendar $cal ) : float
public getTimeZone ( ) : IntlTimeZone
intlcal_get_time_zone ( IntlCalendar $cal ) : IntlTimeZone
public getType ( ) : string
intlcal_get_type ( IntlCalendar $cal ) : string
public getWeekendTransition ( string $dayOfWeek ) : int
intlcal_get_weekend_transition ( IntlCalendar $cal , string $dayOfWeek ) : int
public inDaylightTime ( ) : bool
intlcal_in_daylight_time ( IntlCalendar $cal ) : bool
public isEquivalentTo ( IntlCalendar $other ) : bool
intlcal_is_equivalent_to ( IntlCalendar $cal , IntlCalendar $other ) : bool
public isLenient ( ) : bool
intlcal_is_lenient ( IntlCalendar $cal ) : bool
public isSet ( int $field ) : bool
intlcal_is_set ( IntlCalendar $cal , int $field ) : bool
public isWeekend ( float $date = NULL ) : bool
intlcal_is_weekend ( IntlCalendar $cal , float $date = NULL ) : bool
public roll ( int $field , mixed $amountOrUpOrDown ) : bool
intlcal_roll ( IntlCalendar $cal , int $field , mixed $amountOrUpOrDown ) : bool
public set ( int $field , int $value ) : bool
public set ( int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool
intlcal_set ( IntlCalendar $cal , int $field , int $value ) : bool
intlcal_set ( IntlCalendar $cal , int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool
public setFirstDayOfWeek ( int $dayOfWeek ) : bool
intlcal_set_first_day_of_week ( IntlCalendar $cal , int $dayOfWeek ) : bool
public setLenient ( string $isLenient ) : ReturnType
intlcal_set_lenient ( IntlCalendar $cal , string $isLenient ) : ReturnType
public setMinimalDaysInFirstWeek ( int $minimalDays ) : bool
intlcal_get_minimal_days_in_first_week ( IntlCalendar $cal , int $minimalDays ) : bool
public setRepeatedWallTimeOption ( int $wallTimeOption ) : bool
intlcal_set_repeated_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool
public setSkippedWallTimeOption ( int $wallTimeOption ) : bool
intlcal_set_skipped_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool
public setTime ( float $date ) : bool
intlcal_set_time ( IntlCalendar $cal , float $date ) : bool
public setTimeZone ( mixed $timeZone ) : bool
intlcal_set_time_zone ( IntlCalendar $cal , mixed $timeZone ) : bool
public toDateTime ( ) : DateTime
intlcal_to_date_time ( IntlCalendar $cal ) : DateTime
}

Constantes predefinidas

IntlCalendar::FIELD_ERA

Campo de calendario que representa numéricamente una era, por ejemplo 1 para DC y 0 para AC en los calendarios Gregoriano/Juliano, y 235 para la era Heisei (??) en el calendario japonés. No todos los calendarios tienen más de una era.

IntlCalendar::FIELD_YEAR

Campo de calendario para el año. No es único a lo largo de las eras. Si el tipo de calendario tiene más de una era, generalmente el valor mínimo para este campo será 1.

IntlCalendar::FIELD_MONTH

Campo de calendario para el mes. La secuecia de meses está basada en cero, por lo que Enero (aquí suele significar el primer mes del calendario; este podría llamarse de otra manera, como Muharram en el calendario islámico) se representa por 0, Febrero por 1, …, Diciembre por 11 y, para calendarios que lo tengan, el 13º o mes bisiesto por 12.

IntlCalendar::FIELD_WEEK_OF_YEAR

Campo de calendario para el número de la semana del año. Depende de qué día de la semana se considera que inicia la semana y el número mínimo de días de una semana.

IntlCalendar::FIELD_WEEK_OF_MONTH

Campo de calendario para el número de la semana del mes. Depende de qué día de la semana se considra que inicia la semana y el número mínimo de días de una semana.

IntlCalendar::FIELD_DATE

Campo de calendario para el día del mes. Lo mismo que IntlCalendar::FIELD_DAY_OF_MONTH, el cual tiene un nombre más claro.

IntlCalendar::FIELD_DAY_OF_YEAR

Campo de calendario para el día del año. Para el calendario Gregoriano, comienza con 1 y finaliza con 365 o 366.

IntlCalendar::FIELD_DAY_OF_WEEK

Campo de calendario para el día de la semana. Su valor empiaza con 1 (Domingo, véase IntlCalendar::DOW_SUNDAY y constantes subsiguientes) y el último valor válido es 7 (Sábado).

IntlCalendar::FIELD_DAY_OF_WEEK_IN_MONTH

Dado un día de la semana (Domingo, Lunes, …), este campo de calendario asigna un ordinal para tal día de la semana de un mes específico. Así, si el valor de este campo es 1 y el valor del día de la semana es 2 (Lunes), el día establecido del mes es el 1er lunes del mes; el valor máximo es 5.

Además, el valor 0 y los valores negativos también están permitidos. El valor 0 abarca los siete días que acontecen inmediatamente antes de los primeros siete días de un mes (el cual tiene por lo tanto un ‘día de la semana del mes’ con valor 1). Los valores negativos inician la cuenta desde el final del mes – -1 apunta a la última aparición de un día de la semana en un mes, -2 al penúltimo, etc.

A diferencia de IntlCalendar::FIELD_WEEK_OF_MONTH y IntlCalendar::FIELD_WEEK_OF_YEAR, este valor no depende de IntlCalendar::getFirstDayOfWeek() o IntlCalendar::getMinimalDaysInFirstWeek(). El primer lunes es el primer lunes, incluso si sucede en una semana que pertenece al mes anterior.

IntlCalendar::FIELD_AM_PM

Campo de calendario que indica si una hora es anterior al mediodía (valor 0, AM) o posterior (1). Medianoche es AM, mediodía es PM.

IntlCalendar::FIELD_HOUR

Campo de calendario para la hora, sin especificar si es por la mañana o por la tarde. Los valores válidos son de 0 a 11.

IntlCalendar::FIELD_HOUR_OF_DAY

Campo de calendario para la hora completa (24h) de un día. Los valores válidos son de 0 a 23.

IntlCalendar::FIELD_MINUTE

Campo de calendario para el componente minutos de la hora.

IntlCalendar::FIELD_SECOND

Campo de calendario para el componente segundos de la hora.

IntlCalendar::FIELD_MILLISECOND

Campo de calendario para el componente milisegundos de la hora.

IntlCalendar::FIELD_ZONE_OFFSET

Campo de calendario que indica el índice puro de la zona horaria, en milisegundos. El índice puro es el índice de la zona horaria, excluyendo cualquier índice debido a las horas de horario de verano.

IntlCalendar::FIELD_DST_OFFSET

Campo de calendario para el índice del horario de verano de la zona horaria del calendario, en milisegundos, si está activo para la hora del calendario.

IntlCalendar::FIELD_YEAR_WOY

Campo de calendario que representa el año para propósitos de semana del año.

IntlCalendar::FIELD_DOW_LOCAL

Campo de calendario para el día localizado de la semana. Es un valor entre 1 y 7, siendo 1 usado para el día de la semana que coincide con el valor representado por IntlCalendar::getFirstDayOfWeek().

IntlCalendar::FIELD_EXTENDED_YEAR

Campo de calendario para una representación numérica del año que es continua a lo largo de las eras. Para el calendario Gregoriano, el valor de este campo coincide con el de IntlCalendar::FIELD_YEAR para años DC; un año AC a se reprenta por -a + 1.

IntlCalendar::FIELD_JULIAN_DAY

Campo de calendario para un número de día juliano modificado. Es diferente de un número de día juliano convencional en que su transción sucede a medianoche de la zona local en vez de a mediodía en UTC. Identifica una fecha de manera única.

IntlCalendar::FIELD_MILLISECONDS_IN_DAY

Campo de calendario que abarca la información de IntlCalendar::FIELD_HOUR_OF_DAY, IntlCalendar::FIELD_MINUTE, IntlCalendar::FIELD_SECOND y IntlCalendar::FIELD_MILLISECOND. El rango es desde 0 a 24 * 3600 * 1000 - 1. No es la cantidad de milisegundos transcurridos del día, ya que las transiciones DST tendrán discontinuidades análogas a aquellas de la hora real ('wall time').

IntlCalendar::FIELD_IS_LEAP_MONTH

Campo de calendario cuyo valor es 1 para indicar un mes bisiesto, y 0 para lo contrario.

IntlCalendar::FIELD_FIELD_COUNT

El número total de campos.

IntlCalendar::FIELD_DAY_OF_MONTH

Alias de IntlCalendar::FIELD_DATE.

IntlCalendar::DOW_SUNDAY

Domingo.

IntlCalendar::DOW_MONDAY

Lunes.

IntlCalendar::DOW_TUESDAY

Martes.

IntlCalendar::DOW_WEDNESDAY

Miércoles.

IntlCalendar::DOW_THURSDAY

Jueves.

IntlCalendar::DOW_FRIDAY

Viernes.

IntlCalendar::DOW_SATURDAY

Sábado.

IntlCalendar::DOW_TYPE_WEEKDAY

Salida generada por IntlCalendar::getDayOfWeekType() que indica que un día de la semana es un día entresemana.

IntlCalendar::DOW_TYPE_WEEKEND

Salida generada por IntlCalendar::getDayOfWeekType() que indica que un día de la semana pertenece al fin de semana.

IntlCalendar::DOW_TYPE_WEEKEND_OFFSET

Salida generada por IntlCalendar::getDayOfWeekType() que indica que el fin de semana comienza durante un día dado de una semana.

IntlCalendar::DOW_TYPE_WEEKEND_CEASE

Salida generada por IntlCalendar::getDayOfWeekType() que indica que el fin de semana finaliza durante un día dado de la semana.

IntlCalendar::WALLTIME_FIRST

Salida generada por IntlCalendar::getSkippedWallTimeOption() que indica que las horas reales del rango omitido deberían hacer referencia al mismo instante que las horas reales con una hora menos, y la generada por IntlCalendar::getRepeatedWallTimeOption() que indica que las horas reales del rango repetido deberían hacer referencia al instante de la primera aparición de tal hora real.

IntlCalendar::WALLTIME_LAST

Salida generada por IntlCalendar::getSkippedWallTimeOption() que indica que los "wall times" del rango omitido deberían hacer referencia al mismo instante que los "wall times" con una hora después, y la generada por IntlCalendar::getRepeatedWallTimeOption() que indica que las horas reales del rango repetido deberían hacer referencia al instante de la segunda aparición de tal hora real.

IntlCalendar::WALLTIME_NEXT_VALID

Salida generada por IntlCalendar::getSkippedWallTimeOption() que indica que las horea reales del rango omitido deberían hacer referencia al instante cuando sucede (comienza) la transición del horario de verano.

Tabla de contenidos

  • IntlCalendar::add — Añadir una candidad (con signo) de tiempo al campo
  • IntlCalendar::after — Indica si el instante de este objeto es posterior al del proporcionado
  • IntlCalendar::before — Indica si el instante de este objeto es anterior al del proporcionado
  • IntlCalendar::clear — Limpiar uno o todos los campos
  • IntlCalendar::__construct — Constructor privado para no permitir la creación de instancias
  • IntlCalendar::createInstance — Crear un nuevo IntlCalendar
  • IntlCalendar::equals — Comparar el instante de dos objetos IntlCalendar
  • IntlCalendar::fieldDifference — Calcular la diferencia entre el instante dado y el de este objeto
  • IntlCalendar::fromDateTime — Crear un IntlCalendar desde un objeto DateTime o tring
  • IntlCalendar::get — Obtiene el valor de un campo
  • IntlCalendar::getActualMaximum — El valor máximo de un campo, considerando el instante actual del objeto
  • IntlCalendar::getActualMinimum — El valor mínimo de un campo, considerando el instante actual del objeto
  • IntlCalendar::getAvailableLocales — Obtener un array con las zonas para las que existen datos
  • IntlCalendar::getDayOfWeekType — Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos
  • IntlCalendar::getErrorCode — Obtener el código de error del objeto
  • IntlCalendar::getErrorMessage — Obtener el últime mensaje de error del objeto
  • IntlCalendar::getFirstDayOfWeek — Obtener el primer día de la semana de la región del calendario
  • IntlCalendar::getGreatestMinimum — Obtener el valor mínimo local más grande de un campo
  • IntlCalendar::getKeywordValuesForLocale — Obtener un conjunto de valores de palabras clave de zonas
  • IntlCalendar::getLeastMaximum — Obtener el máximo local más pequeño de un campo
  • IntlCalendar::getLocale — Obtener la configuración regional asociada al objeto
  • IntlCalendar::getMaximum — Obtener el valor máximo global de un campo
  • IntlCalendar::getMinimalDaysInFirstWeek — Obtener el número mínimo de días que puede tener la primera semana de un año o mes
  • IntlCalendar::getMinimum — Obtener el valor mínimo de un campo
  • IntlCalendar::getNow — Obtener el número que representa el instante actual
  • IntlCalendar::getRepeatedWallTimeOption — Obtener el comportamiento para tratar horas repetidas
  • IntlCalendar::getSkippedWallTimeOption — Obtener el comportamiento para tratar horas omitidas
  • IntlCalendar::getTime — Obtiene el tiempo representado por el objeto
  • IntlCalendar::getTimeZone — Obtener la zona horaria del objeto
  • IntlCalendar::getType — Obtener el tipo de calendario
  • IntlCalendar::getWeekendTransition — Obtener el instante del día en la que comienza o termina el fin de semana
  • IntlCalendar::inDaylightTime — Indicar si el instante del objeto está en el horario de verano
  • IntlCalendar::isEquivalentTo — Indicar si otro calendario es igual pero para un instante diferente
  • IntlCalendar::isLenient — Indicar si la interpretación de una fecha/hora está en modo tolerante
  • IntlCalendar::isSet — Determina si un campo está definido
  • IntlCalendar::isWeekend — Determina si una cierta fecha es fin de semana
  • IntlCalendar::roll — Añadir un valor a un campo si acarrear más campos significativos
  • IntlCalendar::set — Establecer un campo de instante o varios campos en común de una vez
  • IntlCalendar::setFirstDayOfWeek — Establecer el día en el que se estima que empieza la semana
  • IntlCalendar::setLenient — Establecer si la interpretación de la fecha/hora es tolerante
  • IntlCalendar::setMinimalDaysInFirstWeek — Establecer el número de días mínimo que puede tener la primera semana de un año o mes
  • IntlCalendar::setRepeatedWallTimeOption — Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias
  • IntlCalendar::setSkippedWallTimeOption — Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
  • IntlCalendar::setTime — Establecer el momento del calendario en milisegundos desde la época
  • IntlCalendar::setTimeZone — Establecer la zona horaria usada por este calendario
  • IntlCalendar::toDateTime — Convertir un objeto IntlCalendar a un objeto DateTime


Añadir una candidad (con signo) de tiempo al campo

  • « IntlCalendar
  • IntlCalendar::after »
  • PHP Manual
  • IntlCalendar
  • Añadir una candidad (con signo) de tiempo al campo

IntlCalendar::add

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::add — Añadir una candidad (con signo) de tiempo al campo

Descripción

Estilo orientado a objetos

public IntlCalendar::add ( int $field , int $amount ) : bool

Estilo por procedimientos

intlcal_add ( IntlCalendar $cal , int $field , int $amount ) : bool

Añade una cantidad con signo a un campo. Una cantidad positiva permite avanzar el tiempo, incluso si el valor numérico del campo decrementa (p.ej., al trabajar con años en fechas AC).

Podría ser necesario ajustar otros campos – por ejemplo, añadir un mes al 31 de enero resultará en el 28 (o 29) de febrero. Al contrario que IntlCalendar::roll(), cuando un valor envuelve, podrían cambiar significativamente más campos. Por ejemplo, añadir un día al 31 de enero resultará en el 1 de febrero, no en el 1 de enero.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

amount

La cantidad con signo a añadir al campo actual. Si la cantidad es positiva, el instante avanzará; si es negativa, el instante retrocederá. La unidad está implícita en el tipo de campo. Por ejemplo, horas para IntlCalendar::FIELD_HOUR_OF_DAY.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::add()

<?php
ini_set('intl.default_locale', 'fr_FR');
ini_set('date.timezone', 'UTC');

$cal = new IntlGregorianCalendar(2012, 0 /* January */, 31);
echo IntlDateFormatter::formatObject($cal), "\n";

$cal->add(IntlCalendar::FIELD_MONTH, 1);
echo IntlDateFormatter::formatObject($cal), "\n";

$cal->add(IntlCalendar::FIELD_DAY_OF_MONTH, 1);
echo IntlDateFormatter::formatObject($cal), "\n";

El resultado del ejemplo sería:

31 janv. 2012 00:00:00
29 févr. 2012 00:00:00
1 mars 2012 00:00:00


Indica si el instante de este objeto es posterior al del proporcionado

  • « IntlCalendar::add
  • IntlCalendar::before »
  • PHP Manual
  • IntlCalendar
  • Indica si el instante de este objeto es posterior al del proporcionado

IntlCalendar::after

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::after — Indica si el instante de este objeto es posterior al del proporcionado

Descripción

Estilo orientado a objetos

public IntlCalendar::after ( IntlCalendar $other ) : bool

Estilo por procedimientos

intlcal_after ( IntlCalendar $cal , IntlCalendar $other ) : bool

Devuelve si el instante de este objeto es posterior al instante del argumento.

Parámetros

cal

El recurso IntlCalendar.

other

El calendario cuyo instante será comprobado con el instante del objeto primario.

Valores devueltos

Devuelve true si el instante de este objeto es posterior al instante del argumento calendar. Devuelve false en caso contrario. También devuelve false en caso de error. Se puede utilizar exceptions o intl_get_error_code() para detectar condiciones de error.

Ejemplos

Ejemplo #1 IntlCalendar::after()

<?php
$cal1 = IntlCalendar::createInstance();
$cal2 = clone $cal1;

var_dump($cal1->after($cal2), //false
        $cal2->after($cal1)); //false

$cal1->roll(IntlCalendar::FIELD_MILLISECOND, true);

var_dump($cal1->after($cal2), //true
        $cal2->after($cal1)); //false


Indica si el instante de este objeto es anterior al del proporcionado

  • « IntlCalendar::after
  • IntlCalendar::clear »
  • PHP Manual
  • IntlCalendar
  • Indica si el instante de este objeto es anterior al del proporcionado

IntlCalendar::before

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::before — Indica si el instante de este objeto es anterior al del proporcionado

Descripción

Estilo orientado a objetos

public IntlCalendar::before ( IntlCalendar $other ) : bool

Estilo por procedimientos

intlcal_before ( IntlCalendar $cal , IntlCalendar $other ) : bool

Devuelve si el instante de este objeto es anterior al instante del argumento.

Parámetros

cal

El recurso IntlCalendar.

other

El calendario cuyo instante será comprobado con el instante del objeto primario.

Valores devueltos

Devuelve true si el instante de este objeto es anterior al instante del argumento calendar. Devuelve false en caso contrario. También devuelve false en caso de error. Se puede utilizar exceptions o intl_get_error_code() para detectar condiciones de error.


Limpiar uno o todos los campos

  • « IntlCalendar::before
  • IntlCalendar::__construct »
  • PHP Manual
  • IntlCalendar
  • Limpiar uno o todos los campos

IntlCalendar::clear

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::clear — Limpiar uno o todos los campos

Descripción

Estilo orientado a objetos

public IntlCalendar::clear ( int $field = NULL ) : bool

Estilo por procedimientos

intlcal_clear ( IntlCalendar $cal , int $field = NULL ) : bool

Limpia todos los campos o uno específico. Un campo limpiado está marcado como desestablecido, dándole la prioridad más baja en campos traslapados o incluso en valores predeterminados al calcular el instante. Además, su valor se establece a 0, aunque dada la baja prioridad del campo, su valor podría haber sido establecido internamente a otro valor en el momento en que se ha terminado de consultar dicho campo.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Un error sólo puede ocurrir si se proporcionan argumentos no válidos.

Ejemplos

Ejemplo #1 Ejemplod de IntlCalendar::clear()

<?php
ini_set('intl.default_locale', 'es_ES');
ini_set('date.timezone', 'UTC');

$campos = array(
    'FIELD_ERA'                  => 0,
    'FIELD_YEAR'                 => 1,
    'FIELD_MONTH'                => 2,
    'FIELD_WEEK_OF_YEAR'         => 3,
    'FIELD_WEEK_OF_MONTH'        => 4,
    'FIELD_DATE'                 => 5,
    'FIELD_DAY_OF_YEAR'          => 6,
    'FIELD_DAY_OF_WEEK'          => 7,
    'FIELD_DAY_OF_WEEK_IN_MONTH' => 8,
    'FIELD_AM_PM'                => 9,
    'FIELD_HOUR'                 => 10,
    'FIELD_HOUR_OF_DAY'          => 11,
    'FIELD_MINUTE'               => 12,
    'FIELD_SECOND'               => 13,
    'FIELD_MILLISECOND'          => 14,
    'FIELD_ZONE_OFFSET'          => 15,
    'FIELD_DST_OFFSET'           => 16,
    'FIELD_YEAR_WOY'             => 17,
    'FIELD_DOW_LOCAL'            => 18,
    'FIELD_EXTENDED_YEAR'        => 19,
    'FIELD_JULIAN_DAY'           => 20,
    'FIELD_MILLISECONDS_IN_DAY'  => 21,
    'FIELD_IS_LEAP_MONTH'        => 22,
    'FIELD_FIELD_COUNT'          => 23,
);
function getSetFields(IntlCalendar $cal) {
    global $campos;
    $ret = array();
    foreach ($campos as $nombre => $valor) {
        if ($cal->isSet($valor)) {
            $ret[] = $nombre;
        }
    }
    return $ret;
}

$cal = new IntlGregorianCalendar(2013, 2 /* March */, 15);
echo "Después de la creación del GregorianCalendar\n";
print_r(getSetFields($cal));
echo "\n";

echo IntlDateFormatter::formatObject($cal), "\n";
echo "Después de que el formateador solicitó el año ampliado\n";
print_r(getSetFields($cal));
echo "\n";

$cal->clear(IntlCalendar::FIELD_YEAR);
echo "Después de que el año haya sido limpiado, la fecha permanece la misma\n";
echo IntlDateFormatter::formatObject($cal), "\n";
echo "puesto que FIELD_EXTENDED_YEAR aún está establecido\n";
print_r(getSetFields($cal));
echo "\n";

var_dump($cal->clear(IntlCalendar::FIELD_EXTENDED_YEAR));
echo "Después de haber limpiado el año ampliado\n";
print_r(getSetFields($cal));
echo IntlDateFormatter::formatObject($cal), "\n";
echo "\n";

echo "Después de recalcular los campos,\n"
        . " el año ampliado se establece de nuevo (a 1970)\n";
print_r(getSetFields($cal));
echo "\n";

$cal->clear();
echo "Después de invocar a una variante sin argumentos\n";
print_r(getSetFields($cal));
echo IntlDateFormatter::formatObject($cal), "\n";

El resultado del ejemplo sería:

Después de la creación del GregorianCalendar
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_YEAR
    [2] => FIELD_MONTH
    [3] => FIELD_DATE
)

15/03/2013 00:00:00
Después de que el formateador solicitó el año ampliado
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_YEAR
    [2] => FIELD_MONTH
    [3] => FIELD_DATE
    [4] => FIELD_EXTENDED_YEAR
)

Después de que el año haya sido limpiado, la fecha permanece la misma
15/03/2013 00:00:00
puesto que FIELD_EXTENDED_YEAR aún está establecido
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
    [3] => FIELD_EXTENDED_YEAR
)

bool(true)
Después de haber limpiado el año ampliado
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
)
15/03/1970 00:00:00

Después de recalcular los campos,
 el año ampliado se establece de nuevo (a 1970)
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
    [3] => FIELD_EXTENDED_YEAR
)

Después de invocar a una variante sin argumentos
Array
(
)
01/01/1970 00:00:00


Constructor privado para no permitir la creación de instancias

  • « IntlCalendar::clear
  • IntlCalendar::createInstance »
  • PHP Manual
  • IntlCalendar
  • Constructor privado para no permitir la creación de instancias

IntlCalendar::__construct

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::__construct — Constructor privado para no permitir la creación de instancias

Descripción

private IntlCalendar::__construct ( )

Constructor privado para no permitir la creación de instancias con el operador new.

En su lugar, llama a IntlCalendar::createInstance().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Crear un nuevo IntlCalendar

  • « IntlCalendar::__construct
  • IntlCalendar::equals »
  • PHP Manual
  • IntlCalendar
  • Crear un nuevo IntlCalendar

IntlCalendar::createInstance

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::createInstance — Crear un nuevo IntlCalendar

Descripción

Estilo orientado a objetos

public static IntlCalendar::createInstance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar

Estilo por procedimientos

intlcal_create_instance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar

Dados una zona horaria y configuración regional, este método creará un objeto IntlCalendar. Este método de fábrica podría devolver una subclase de IntlCalendar.

El calendario creado representará la instancia del instante en que fue creado, basándose en la hora del sistema. Todos los campos pueden ser limpiados llamando a IntCalendar::clear() sin argumentos. Véase también IntlGregorianCalendar::__construct().

Parámetros

timeZone

La zona horaria a emplear.

  • null, en cuyo caso se usará la zona horaria predeterminada, tal como está especificada en el ajuste ini date.timezone o a través de la función date_default_timezone_set() y como es devuelto por date_default_timezone_get().

  • Un IntlTimeZone, que se usará directamente.

  • Un DateTimeZone. Su identificador será extraido y se creará un objeto de zona horaria de ICU; la zona horaria será proporcionada por la base de datos de ICU, no por la de PHP.

  • Un string, que debería ser un identificador de zona horaria de ICU válido. Véase IntlTimeZone::createTimeZoneIDEnumeration(). Los índices puros como "GMT+08:30" también se aceptan.

locale

Una configurazión regional a usar o null para utilizar la configuración regional predeterminada.

Valores devueltos

La instancia de IntlCalendar creada o null en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::createInstance()

<?php
ini_set('intl.default_locale', 'es_ES');
ini_set('date.timezone', 'Europe/Madrid');

$cal = IntlCalendar::createInstance();
echo "Sin argumentos\n";
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));
echo "\n";

echo "Zona horaria explícita\n";
$cal = IntlCalendar::createInstance(IntlTimeZone::getGMT());
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));
echo "\n";

echo "Configuración regional explícita (con calendario)\n";
$cal = IntlCalendar::createInstance(NULL, 'es_ES@calendar=persian');
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));

El resultado del ejemplo sería:

Sin argumentos
string(21) "IntlGregorianCalendar"
string(68) "martes 18 de junio de 2013 14:11:02 Hora de verano de Europa Central"

Zona horaria explícita
string(21) "IntlGregorianCalendar"
string(45) "martes 18 de junio de 2013 12:11:02 GMT+00:00"

Configuración regional explícita (con calendario)
string(12) "IntlCalendar"
string(70) "martes 28 de Khordad de 1392 14:11:02 Hora de verano de Europa Central"

Ver también

  • IntlGregorianCalendar::__construct()


Comparar el instante de dos objetos IntlCalendar

  • « IntlCalendar::createInstance
  • IntlCalendar::fieldDifference »
  • PHP Manual
  • IntlCalendar
  • Comparar el instante de dos objetos IntlCalendar

IntlCalendar::equals

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::equals — Comparar el instante de dos objetos IntlCalendar

Descripción

Estilo orientado a objetos

public IntlCalendar::equals ( IntlCalendar $other ) : bool

Estilo por procedimientos

intlcal_equals ( IntlCalendar $cal , IntlCalendar $other ) : bool

Devuelve true si este calendario y el calendario dado tienen el mismo instante. La configuración, el tipo de calendario y los estados de los campos no tienen que ser los mismos.

Parámetros

cal

El recurso IntlCalendar.

other

El calendario con el que comparar el objeto primario.

Valores devueltos

Devuelve true si el instante actual de ambos objetos IntlCalendar son el mismo, false en caso contrario. El valor false puede ser devuelto también en caso de error. Esto solamente puede ocurrir si se proporcionan argumentos erróneos. En cualquier caso, los dos casos se pueden distinguir llamando a intl_get_error_code().

Ejemplos

Ejemplo #1 IntlCalendar::equals()

<?php
ini_set('date.timezone', 'UTC');

$cal1 = IntlCalendar::createInstance(NULL, 'es_ES');
$cal2 = clone $cal1;

var_dump($cal1->equals($cal2)); //TRUE

// La configuración regional no se incluye en la comparación
$cal2 = IntlCalendar::createInstance(NULL, 'pt_PT');
$cal2->setTime($cal1->getTime());
var_dump($cal1->equals($cal2)); //TRUE

// Y los estados de los campos establecidos tampoco
$cal2->clear(IntlCalendar::FIELD_YEAR);
var_dump($cal1->isSet(IntlCalendar::FIELD_YEAR) ==
        $cal2->isSet(IntlCalendar::FIELD_YEAR)); //FALSE
var_dump($cal1->equals($cal2)); //TRUE

// Ni el tipo de calendario
$cal2 = IntlCalendar::createInstance(NULL, 'es_ES@calendar=islamic');
$cal2->setTime($cal1->getTime());
var_dump($cal1->equals($cal2)); //TRUE

// Solamente el instante
$cal2 = clone $cal1;
$cal2->setTime($cal1->getTime() + 1.);
var_dump($cal1->equals($cal2)); //FALSE


Calcular la diferencia entre el instante dado y el de este objeto

  • « IntlCalendar::equals
  • IntlCalendar::fromDateTime »
  • PHP Manual
  • IntlCalendar
  • Calcular la diferencia entre el instante dado y el de este objeto

IntlCalendar::fieldDifference

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::fieldDifference — Calcular la diferencia entre el instante dado y el de este objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::fieldDifference ( float $when , int $field ) : int

Estilo por procedimientos

intlcal_field_difference ( IntlCalendar $cal , float $when , int $field ) : int

Devuelve la diferencia entre el instante dado y el instante al que está establecido este objeto, con respecto a la cantidad especificada por el parámetro field.

Se pretende que este método se llamado sucesivamente, primero con el campo de interés más significativo hasta el menos significativo. Para es propósito, y como efecto segundario, el valor del calendario para el campo especificado avanza la cantidad devuelta.

Parámetros

cal

El recurso IntlCalendar.

when

El instante con el que comparar la cantidad representada por field. Para que el resultado sea positivo, el instante dado a este parámetro debe estar por delante del instante del objeto que invocó al método.

field

El campo que representa la cantidad a comparar.

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Devuelve una diferencia de tiempo (con signo) en la unidad asociada al campo especificado o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::fieldDifference()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'fr_FR');

$cal1 = IntlCalendar::fromDateTime('2012-02-29 09:00:11');
$cal2 = IntlCalendar::fromDateTime('2013-03-01 09:19:29');
$time = $cal2->getTime();

echo "Instante antes: ", IntlDateFormatter::formatObject($cal1), "\n";

printf(
    "La diferencia es %d year(s), %d month(s), "
  . "%d day(s), %d hour(s) and %d minute(s)\n",
    $cal1->fieldDifference($time, IntlCalendar::FIELD_YEAR),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_MONTH),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_DAY_OF_MONTH),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_HOUR_OF_DAY),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_MINUTE)
);

// ahora avanzó el instante objetivo, con excepción de los segundos,
// para el cual no medimos la diferencia
echo "Instante después: ", IntlDateFormatter::formatObject($cal1), "\n";

El resultado del ejemplo sería:

Instante antes: 29 févr. 2012 09:00:11
La diferencia es 1 year(s), 0 month(s), 1 day(s), 0 hour(s) and 19 minute(s)
Instante después: 1 mars 2013 09:19:11


Crear un IntlCalendar desde un objeto DateTime o tring

  • « IntlCalendar::fieldDifference
  • IntlCalendar::get »
  • PHP Manual
  • IntlCalendar
  • Crear un IntlCalendar desde un objeto DateTime o tring

IntlCalendar::fromDateTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a2)

IntlCalendar::fromDateTime — Crear un IntlCalendar desde un objeto DateTime o tring

Descripción

Estilo orientado a objetos

public static IntlCalendar::fromDateTime ( mixed $dateTime ) : IntlCalendar

Estilo por procedimientos

intlcal_from_date_time ( mixed $dateTime ) : IntlCalendar

Crear un objeto IntlCalendar desde un objeto DateTime o desde un string desde el cual se pueda construir un objeto DateTime.

El nuevo calendario representara no sólo el mismo instante que el DateTime dado (sujeto a la pérdida de preceisión para fechas muy lejanas en el pasado o futuro), sino también la misma zona horaria (sujeta a la advertencia de que se emplearán diferentes bases de datos de zonas horarias, por lo que los resultados podrían diferir).

Parámetros

dateTime

Un objeto DateTime o un string que pueda proporcianrse a DateTime::__construct().

Valores devueltos

El objeto IntlCalendar creado o null en caso de error. Si se proporciona un string, cualquier excepción que ocurra dentro del constructor de DateTime se propagará.

Ejemplos

Ejemplo #1 IntlCalendar::fromDateTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

// lo mismo que IntlCalendar::fromDateTime(new DateTime(...))
$cal1 = IntlCalendar::fromDateTime('2013-02-28 00:01:02 Europe/Berlin');

// Observe que la zona horaria es Europe/Berlin, no la predeterminada Europe/Lisbon
echo IntlDateFormatter::formatObject($cal1, 'yyyy MMMM d HH:mm:ss VVVV', 'de_DE'), "\n";

El resultado del ejemplo sería:

2013 Februar 28 00:01:02 Deutschland Zeit


Obtiene el valor de un campo

  • « IntlCalendar::fromDateTime
  • IntlCalendar::getActualMaximum »
  • PHP Manual
  • IntlCalendar
  • Obtiene el valor de un campo

IntlCalendar::get

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::get — Obtiene el valor de un campo

Descripción

Estilo orientado a objetos

public IntlCalendar::get ( int $field ) : int

Estilo por procedimientos

intlcal_get ( IntlCalendar> $cal , int $field ) : int

Obtiene el valor de un campo específico.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un entero con el valor del campo fecha.

Ejemplos

Ejemplo #1 IntlCalendar::get()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$class = new ReflectionClass('IntlCalendar');
$fields = array();
foreach ($class->getConstants() as $name => $val) {
    if (strpos($name, 'FIELD_') !== 0 || $val > 22)
        continue;
    $fields[$val] = $name;
}

$cal = IntlCalendar::createInstance(); // current time
var_dump(IntlDateFormatter::formatObject($cal));
foreach ($fields as $val => $name) {
    echo "$val ($name)", "\n    ", $cal->get($val), "\n";
}

El resultado del ejemplo sería:

string(23) "Jul 1, 2013, 4:44:44 AM"
0 (FIELD_ERA)
    1
1 (FIELD_YEAR)
    2013
2 (FIELD_MONTH)
    6
3 (FIELD_WEEK_OF_YEAR)
    27
4 (FIELD_WEEK_OF_MONTH)
    1
5 (FIELD_DAY_OF_MONTH)
    1
6 (FIELD_DAY_OF_YEAR)
    182
7 (FIELD_DAY_OF_WEEK)
    2
8 (FIELD_DAY_OF_WEEK_IN_MONTH)
    1
9 (FIELD_AM_PM)
    0
10 (FIELD_HOUR)
    4
11 (FIELD_HOUR_OF_DAY)
    4
12 (FIELD_MINUTE)
    44
13 (FIELD_SECOND)
    44
14 (FIELD_MILLISECOND)
    551
15 (FIELD_ZONE_OFFSET)
    0
16 (FIELD_DST_OFFSET)
    3600000
17 (FIELD_YEAR_WOY)
    2013
18 (FIELD_DOW_LOCAL)
    2
19 (FIELD_EXTENDED_YEAR)
    2013
20 (FIELD_JULIAN_DAY)
    2456475
21 (FIELD_MILLISECONDS_IN_DAY)
    17084551
22 (FIELD_IS_LEAP_MONTH)
    0


El valor máximo de un campo, considerando el instante actual del objeto

  • « IntlCalendar::get
  • IntlCalendar::getActualMinimum »
  • PHP Manual
  • IntlCalendar
  • El valor máximo de un campo, considerando el instante actual del objeto

IntlCalendar::getActualMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getActualMaximum — El valor máximo de un campo, considerando el instante actual del objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::getActualMaximum ( int $field ) : int

Estilo por procedimientos

intlcal_get_actual_maximum ( IntlCalendar $cal , int $field ) : int

Devuelve un valor máximo relativo de un campo en torno al instante actual. La semántica exacta varía según cada campo, pero en general, será el valor que se obtendría si se estableciera el valor del campo al máximo relativo más pequeño y se incrementara hasta alcanzar el máximo global o sobrepasase, en donde el valor devuelto sería el máximo global o el valor antes de sobrepasar, respectivamente.

Por ejemplo, en el calendario gregoriano, el valor máximo real para el día del mes variará entre 28 y 31, dependiendo del mes y año del instante actual.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa el valor máximo en las unidades asociadas al campo dado por field o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getActualMaximum()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

$cal = IntlCalendar::fromDateTime('2013-02-15');
var_dump($cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)); //28

$cal->add(IntlCalendar::FIELD_EXTENDED_YEAR, -1);
var_dump($cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)); //29

El resultado del ejemplo sería:

int(28)
int(29)

Ver también

  • IntlCalendar::getMaximum() - Obtener el valor máximo global de un campo
  • IntlCalendar::getLeastMaximum() - Obtener el máximo local más pequeño de un campo
  • IntlCalendar::getActualMinimum() - El valor mínimo de un campo, considerando el instante actual del objeto


El valor mínimo de un campo, considerando el instante actual del objeto

  • « IntlCalendar::getActualMaximum
  • IntlCalendar::getAvailableLocales »
  • PHP Manual
  • IntlCalendar
  • El valor mínimo de un campo, considerando el instante actual del objeto

IntlCalendar::getActualMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getActualMinimum — El valor mínimo de un campo, considerando el instante actual del objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::getActualMinimum ( int $field ) : int

Estilo por procedimientos

intlcal_get_actual_minimum ( IntlCalendar $cal , int $field ) : int

Devuelve un valor mínimo relativo de un campo en torno al instante actual. La semántica exacta varía según cada campo, pero en general, será el valor que se obtendría si se estableciera el valor del campo al mínimo relativo más grande y se incrementara hasta alcanzar el mínimo global o sobrepasase, en donde el valor devuelto sería el mínimo global o el valor antes de sobrepasar, respectivamente.

Para el calendario gregoriano, este es siempre el mismo que IntlCalendar::getMinimum().

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa el valor mínimo en las del o false en caso de error.

Ver también

  • IntlCalendar::getMinimum() - Obtener el valor mínimo de un campo
  • IntlCalendar::getGreatestMinimum() - Obtener el valor mínimo local más grande de un campo
  • IntlCalendar::getActualMaximum() - El valor máximo de un campo, considerando el instante actual del objeto


Obtener un array con las zonas para las que existen datos

  • « IntlCalendar::getActualMinimum
  • IntlCalendar::getDayOfWeekType »
  • PHP Manual
  • IntlCalendar
  • Obtener un array con las zonas para las que existen datos

IntlCalendar::getAvailableLocales

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getAvailableLocales — Obtener un array con las zonas para las que existen datos

Descripción

Estilo orientado a objetos

public static IntlCalendar::getAvailableLocales ( ) : array

Estilo por procedimientos

intlcal_get_available_locales ( ) : array

Proporciona la lista de zona para las que están instaladas los calendarios. A partir de ICU 51, esta es la lista de todas las zonas instaladas de ICU.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de string, uno para cada zona.

Ejemplos

Ejemplo #1 IntlCalendar::getAvailableLocales()()

<?php
print_r(IntlCalendar::getAvailableLocales());

El resultado del ejemplo sería:

Array
(
    [0] => af
    [1] => af_NA
    [2] => af_ZA
    [3] => agq
    [4] => agq_CM
    [5] => ak
    [6] => ak_GH
    [7] => am
    [8] => am_ET
    [9] => ar
    [10] => ar_001
    [11] => ar_AE
    [12] => ar_BH
    [13] => ar_DJ
    … output abbreviated …
    [595] => zh_Hant_HK
    [596] => zh_Hant_MO
    [597] => zh_Hant_TW
    [598] => zu
    [599] => zu_ZA
)


Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos

  • « IntlCalendar::getAvailableLocales
  • IntlCalendar::getErrorCode »
  • PHP Manual
  • IntlCalendar
  • Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos

IntlCalendar::getDayOfWeekType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getDayOfWeekType — Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos

Descripción

Estilo orientado a objetos

public IntlCalendar::getDayOfWeekType ( int $dayOfWeek ) : int

Estilo por procedimientos

intlcal_get_day_of_week_type ( IntlCalendar $cal , int $dayOfWeek ) : int

Devuelve si el día proporcionado es un día de entresemana (IntlCalendar::DOW_TYPE_WEEKDAY), de fin de semana (IntlCalendar::DOW_TYPE_WEEKEND), un día durante el que ocurre una transición al fin de semana (IntlCalendar::DOW_TYPE_WEEKEND_OFFSET) o un día durante el cual cesa el fin de semana (IntlCalendar::DOW_TYPE_WEEKEND_CEASE).

Si devuelve
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET o
IntlCalendar::DOW_TYPE_WEEKEND_CEASE, se puede invocar a
IntlCalendar::getWeekendTransition() para
obtener la hora de la transición.

Esta función requiere ICU 4.4.

Parámetros

cal

El recurso IntlCalendar.

dayOfWeek

Una de las constantes IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, …,
IntlCalendar::DOW_SATURDAY.

Valores devueltos

Devuelve una de las constantes
IntlCalendar::DOW_TYPE_WEEKDAY,
IntlCalendar::DOW_TYPE_WEEKEND,
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET o
IntlCalendar::DOW_TYPE_WEEKEND_CEASE  o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getDayOfWeekType()

<?php

foreach (array('en_US', 'ar_SA') as $locale) {
    echo "Región: ", Locale::getDisplayName($locale, "en_US"), "\n";

    $cal = IntlCalendar::createInstance('UTC', $locale);

    for ($i = IntlCalendar::DOW_SUNDAY; $i <= IntlCalendar::DOW_SATURDAY; $i++) {
        echo $i, " ", $cal->getDayOfWeekType($i), " ",
                $cal->getDayOfWeekType($i) >= IntlCalendar::DOW_TYPE_WEEKEND_OFFSET
                        ? $cal->getWeekendTransition($i)
                        : '',
                "\n";
    }
    echo "\n";
}

El resultado del ejemplo sería:

Región: English (United States)
1 3 86400000
2 0
3 0
4 0
5 0
6 0
7 1

Región: Arabic (Saudi Arabia)
1 0
2 0
3 0
4 0
5 1
6 3 86400000
7 0


Obtener el código de error del objeto

  • « IntlCalendar::getDayOfWeekType
  • IntlCalendar::getErrorMessage »
  • PHP Manual
  • IntlCalendar
  • Obtener el código de error del objeto

IntlCalendar::getErrorCode

intlcal_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getErrorCode -- intlcal_get_error_code — Obtener el código de error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlCalendar::getErrorCode ( ) : int

Estilo por procedimientos:

intlcal_get_error_code ( IntlCalendar $calendar ) : int

Devuelve el código numérico del error de ICU de la última llamada sobre este objeto (incluyendo la clonación) o el IntlCalendar dado al parámetro calendar (en la versión procedimental). Esto podría indicar solamente una advertencia (código de error negativo) o ningún error en absoluto (U_ZERO_ERROR). La presencia real de un error puede ser comprobada con intl_is_failure().

Los argumentos no válidos detectados en el lado de PHP (antes de invocar a funciones de la biblioteca ICU) no se registran para los propósitos de esta función.

El último error que ocurrió en cualquier llamada a una función de la extensión intl, incluyendo errores de argumentos anteriores, se puede obtener con intl_get_error_code(). Esta función reinicia el código de errores global, pero no el código de error del objeto.

Parámetros

calendar

El objeto calendario, en la interfaz procedimental.

Valores devueltos

Un código de error de ICU que indica éxito, fallo o una advertencia.

Ejemplos

Ejemplo #1 IntlCalendar::getErrorCode() y IntlCalendar::getErrorMessage()

<?php
ini_set("intl.error_level", E_WARNING);
ini_set("intl.default_locale", "nl");

$intlcal = new IntlGregorianCalendar(2012, 1, 29);
var_dump(
    $intlcal->getErrorCode(),
    $intlcal->getErrorMessage()
);
$intlcal->fieldDifference(-1e100, IntlCalendar::FIELD_SECOND);

var_dump(
    $intlcal->getErrorCode(),
    $intlcal->getErrorMessage()
);

El resultado del ejemplo sería:

int(0)
string(12) "U_ZERO_ERROR"

Warning: IntlCalendar::fieldDifference(): intlcal_field_difference: Call to ICU method has failed in /home/glopes/php/ws/example.php on line 10
int(1)
string(81) "intlcal_field_difference: Call to ICU method has failed: U_ILLEGAL_ARGUMENT_ERROR"

Ver también

  • IntlCalendar::getErrorMessage() - Obtener el últime mensaje de error del objeto
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo
  • intl_error_name() - Obtiene un nombre simbólico a partir de un código de error dado
  • intl_get_error_code() - Obtiene el último código de error
  • intl_get_error_message() - Obtener una descripción del último error


Obtener el últime mensaje de error del objeto

  • « IntlCalendar::getErrorCode
  • IntlCalendar::getFirstDayOfWeek »
  • PHP Manual
  • IntlCalendar
  • Obtener el últime mensaje de error del objeto

IntlCalendar::getErrorMessage

intlcal_get_error_message

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getErrorMessage -- intlcal_get_error_message — Obtener el últime mensaje de error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlCalendar::getErrorMessage ( ) : string

Estilo por procedimientos:

intlcal_get_error_message ( IntlCalendar $calendar ) : string

Devuelve el mensaje de error (si lo hubiera) asociado al error reportado por IntlCalendar::getErrorCode() o intlcal_get_error_code(). Si no hubiera ningún mensaje de error asociado, solamente será devuelto el string con la representación del nombre de la constante de error. De lo contrario, el mensaje también incluye un mensaje establecido en el lado de la vinculación de PHP.

Parámetros

calendar

El objeto calendario, en la interfaz procedimental.

Valores devueltos

El mensaje de error asociado con el último error ocurrido en una llamada a una función sobre este objeto, o un string que indica la no existencia de errores.

Ejemplos

Ejemplo #1 IntlCalendar::getErrorMessage()

<?php
$cal = IntlCalendar::createInstance('UTC', 'en_US');
var_dump($cal->getErrorMessage());

$cal->getWeekendTransition(IntlCalendar::DOW_WEDNESDAY);
var_dump($cal->getErrorMessage());

El resultado del ejemplo sería:

string(12) "U_ZERO_ERROR"
string(82) "intlcal_get_weekend_transition: Error calling ICU method: U_ILLEGAL_ARGUMENT_ERROR"


Obtener el primer día de la semana de la región del calendario

  • « IntlCalendar::getErrorMessage
  • IntlCalendar::getGreatestMinimum »
  • PHP Manual
  • IntlCalendar
  • Obtener el primer día de la semana de la región del calendario

IntlCalendar::getFirstDayOfWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getFirstDayOfWeek — Obtener el primer día de la semana de la región del calendario

Descripción

Estilo orientado a objetos

public IntlCalendar::getFirstDayOfWeek ( ) : int

Estilo por procedimientos

intlcal_get_first_day_of_week ( IntlCalendar $cal ) : int

El día que se estima que empieza la semana, el valor predeterminado para esta región o el valor establecido con IntlCalendar::setFirstDayOfWeek().

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Una de las constnates IntlCalendar::DOW_SUNDAY, IntlCalendar::DOW_MONDAY, …, IntlCalendar::DOW_SATURDAY o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getFirstDayOfWeek()

<?php
ini_set('date.timezone', 'UTC');

$cal1 = IntlCalendar::createInstance(NULL, 'es_ES');
var_dump($cal1->getFirstDayOfWeek()); // Lunes
$cal1->set(2013, 1 /* February */, 3); // Un domingo
var_dump($cal1->get(IntlCalendar::FIELD_WEEK_OF_YEAR)); // 5

$cal2 = IntlCalendar::createInstance(NULL, 'en_US');
var_dump($cal2->getFirstDayOfWeek()); // Domingo
$cal2->set(2013, 1 /* February */, 3); // Un domingo
var_dump($cal2->get(IntlCalendar::FIELD_WEEK_OF_YEAR)); // 6

El resultado del ejemplo sería:

int(2)
int(5)
int(1)
int(6)

Ver también

  • IntlCalendar::setFirstDayOfWeek() - Establecer el día en el que se estima que empieza la semana


Obtener el valor mínimo local más grande de un campo

  • « IntlCalendar::getFirstDayOfWeek
  • IntlCalendar::getKeywordValuesForLocale »
  • PHP Manual
  • IntlCalendar
  • Obtener el valor mínimo local más grande de un campo

IntlCalendar::getGreatestMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getGreatestMinimum — Obtener el valor mínimo local más grande de un campo

Descripción

Estilo orientado a objetos

public IntlCalendar::getGreatestMinimum ( int $field ) : int

Estilo por procedimientos

intlcal_get_greatest_minimum ( IntlCalendar $cal , int $field ) : int

Devuelve el mínimo local más grande de un campo. Debería se un valor mayor o igual al devuelto por IntlCalendar::getActualMinimum(), el cual es a su vez mayor o igual que el devuelto por IntlCalendar::getMinimum(). Estas tres funciones devuelven el mismo valor para el calendario gregoriano.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa un valor de campo, en la unidad del campo, o false en caso de error.


Obtener un conjunto de valores de palabras clave de zonas

  • « IntlCalendar::getGreatestMinimum
  • IntlCalendar::getLeastMaximum »
  • PHP Manual
  • IntlCalendar
  • Obtener un conjunto de valores de palabras clave de zonas

IntlCalendar::getKeywordValuesForLocale

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getKeywordValuesForLocale — Obtener un conjunto de valores de palabras clave de zonas

Descripción

Estilo orientado a objetos

public static IntlCalendar::getKeywordValuesForLocale ( string $key , string $locale , boolean $commonlyUsed ) : Iterator

Estilo por procedimientos

intlcal_get_keyword_values_for_locale ( string $key , string $locale , boolean $commonlyUsed ) : Iterator

Para una clave de una configuración regional dada, obtiene el conjunto de valores que resultarían en un comoportamiento diferente. Por ahora, solamente está soportada la palabra clave 'calendar'.

Esta función requiere ICU 4.2 o posterior.

Parámetros

key

La palabra clave de la configuración regional de la que se quieren consultar valores relevantes. Solamente está soprtada 'calendar'.

locale

La configuración regional en la que adjuntar el par clave/valor.

commonlyUsed

Si mostrar solamente valores usados comúnmente para la configuración regional especificada.

Valores devueltos

Un iterador que genera string con los valores de la palabra clave de la configuración regional o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getKeyworkValuesForLocale()

<?php
print_r(
        iterator_to_array(
                IntlCalendar::getKeywordValuesForLocale(
                        'calendar', 'fa_IR', true)));
print_r(
        iterator_to_array(
                IntlCalendar::getKeywordValuesForLocale(
                        'calendar', 'fa_IR', false)));

El resultado del ejemplo sería:

Array
(
    [0] => persian
    [1] => gregorian
    [2] => islamic
    [3] => islamic-civil
)
Array
(
    [0] => persian
    [1] => gregorian
    [2] => islamic
    [3] => islamic-civil
    [4] => japanese
    [5] => buddhist
    [6] => roc
    [7] => hebrew
    [8] => chinese
    [9] => indian
    [10] => coptic
    [11] => ethiopic
    [12] => ethiopic-amete-alem
)


Obtener el máximo local más pequeño de un campo

  • « IntlCalendar::getKeywordValuesForLocale
  • IntlCalendar::getLocale »
  • PHP Manual
  • IntlCalendar
  • Obtener el máximo local más pequeño de un campo

IntlCalendar::getLeastMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getLeastMaximum — Obtener el máximo local más pequeño de un campo

Descripción

Estilo orientado a objetos

public IntlCalendar::getLeastMaximum ( int $field ) : int

Estilo por procedimientos

intlcal_get_least_maximum ( IntlCalendar $cal , int $field ) : int

Devuelve el máximo local más pequeño de un campo. Debería ser un valor menor o igual al devuelto por IntlCalendar::getActualMaxmimum(), el cual es a su vez menor o igual al devuelto por IntlCalendar::getMaximum().

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa un valor en la unidad del campo o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplos de máximos

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'it_IT');

$cal = new IntlGregorianCalendar(2013, 3 /* April */, 6);
var_dump(
    $cal->getLeastMaximum(IntlCalendar::FIELD_DAY_OF_MONTH),  // 28
    $cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH), // 30
    $cal->getMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)        // 31
);

El resultado del ejemplo sería:

int(28)
int(30)
int(31)

Ver también

  • IntlCalendar::getActualMaximum() - El valor máximo de un campo, considerando el instante actual del objeto
  • IntlCalendar::getMaximum() - Obtener el valor máximo global de un campo
  • IntlCalendar::getGreatestMinimum() - Obtener el valor mínimo local más grande de un campo


Obtener la configuración regional asociada al objeto

  • « IntlCalendar::getLeastMaximum
  • IntlCalendar::getMaximum »
  • PHP Manual
  • IntlCalendar
  • Obtener la configuración regional asociada al objeto

IntlCalendar::getLocale

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getLocale — Obtener la configuración regional asociada al objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::getLocale ( int $localeType ) : string

Estilo por procedimientos

intlcal_get_locale ( IntlCalendar $cal , int $localeType ) : string

Devuelve la configuración regional empleado por este objeto calendar.

Parámetros

cal

El recurso IntlCalendar.

localeType

Si obtener la configuración regional real (de la cual se originan los datos del calendario, con Locale::ACTUAL_LOCALE) o una válida, es decir, la configuración regional más específica admitida por ICU con relación a la configuración solicitada – véase Locale::VALID_LOCALE. Las configuraciones regionales se ordenan desde la más general a la más específica – real, válida y solicitada.

Valores devueltos

Un string con la configuración regional o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getLocale()

<?php
$cal = IntlCalendar::createInstance(IntlTimeZone::getGMT(), 'en_US_CALIFORNIA');
var_dump(
    $cal->getLocale(Locale::ACTUAL_LOCALE),
    $cal->getLocale(Locale::VALID_LOCALE)
);

El resultado del ejemplo sería:

string(2) "en"
string(5) "en_US"


Obtener el valor máximo global de un campo

  • « IntlCalendar::getLocale
  • IntlCalendar::getMinimalDaysInFirstWeek »
  • PHP Manual
  • IntlCalendar
  • Obtener el valor máximo global de un campo

IntlCalendar::getMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMaximum — Obtener el valor máximo global de un campo

Descripción

Estilo orientado a objetos

public IntlCalendar::getMaximum ( int $field ) : int

Estilo por procedimientos

intlcal_get_maximum ( IntlCalendar $cal , int $field ) : int

Obtiene el máximo global de un campo, es este calendario específico. Este valor es mayor o igual que el devuelto por IntlCalendar::getActualMaximum(), el cual es a su vez mayor o igual que el devuelto por IntlCalendar::getLeastMaximum().

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa un valor de campo en la unidad del campo o false en caso de error.

Ver también

  • IntlCalendar::getActualMaximum() - El valor máximo de un campo, considerando el instante actual del objeto
  • IntlCalendar::getLeastMaximum() - Obtener el máximo local más pequeño de un campo
  • IntlCalendar::getMinimum() - Obtener el valor mínimo de un campo


Obtener el número mínimo de días que puede tener la primera semana de un año o mes

  • « IntlCalendar::getMaximum
  • IntlCalendar::getMinimum »
  • PHP Manual
  • IntlCalendar
  • Obtener el número mínimo de días que puede tener la primera semana de un año o mes

IntlCalendar::getMinimalDaysInFirstWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMinimalDaysInFirstWeek — Obtener el número mínimo de días que puede tener la primera semana de un año o mes

Descripción

Estilo orientado a objetos

public IntlCalendar::getMinimalDaysInFirstWeek ( ) : int

Estilo por procedimientos

intlcal_get_minimal_days_in_first_week ( IntlCalendar $cal ) : int

Devuelve el número mínimo de días que debe tener la primera semana de un año o mes en el nuevo año o mes. Por ejemplo, en el calendario gregoriano, si este valor es 1, la primera semana de año incluirá necesariamente el 1 de enero, mientras que si este valor es 7, la semana con el 1 de enerio será la primera semana del año únicamente si el día de la semana para el 1 de enero coincide con el día de la semana devuelto por IntlCalendar::getFirstDayOfWeek(); de lo contrario será la última semana del año anterior.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un int que representa el número de días o false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::getMinimalDaysInFirstWeek()

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'en_US');

$cal = new IntlGregorianCalendar(2013, 0 /* January */, 2);
var_dump(IntlDateFormatter::formatObject($cal, 'cccc')); // Wednesday

var_dump($cal->getMinimalDaysInFirstWeek(), // 1
$cal->getFirstDayofWeek()); // 1 (Sunday)

// Semana 1 del 2013
var_dump(IntlDateFormatter::formatObject($cal, "'Semana 'w' del 'Y"));

$cal->setMinimalDaysInFirstWeek(4);
// Aún en la semana 1 del 2013 (1ª semana tiene 5 días en el nuevo año)
var_dump(IntlDateFormatter::formatObject($cal, "'Semana 'w' del 'Y"));

$cal->setMinimalDaysInFirstWeek(6);
// Semana 53 del 2012
var_dump(IntlDateFormatter::formatObject($cal, "'Semana 'w' del 'Y"));

El resultado del ejemplo sería:

string(9) "Wednesday"
int(1)
int(1)
string(14) "Semana 1 del 2013"
string(14) "Semana 1 del 2013"
string(15) "Semana 53 del 2012"


Obtener el valor mínimo de un campo

  • « IntlCalendar::getMinimalDaysInFirstWeek
  • IntlCalendar::getNow »
  • PHP Manual
  • IntlCalendar
  • Obtener el valor mínimo de un campo

IntlCalendar::getMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMinimum — Obtener el valor mínimo de un campo

Descripción

Estilo orientado a objetos

public IntlCalendar::getMinimum ( int $field ) : int

Estilo por procedimientos

intlcal_get_minimum ( IntlCalendar $cal , int $field ) : int

Obtiene el mínimo global de un campo, es este calendario específico. Este valor es menor o igual que el devuelto por IntlCalendar::getActualMinimum(), el cual es a su vez menor o igual que el devuelto por IntlCalendar::getGreatestMinimum(). Para el calendario gregoriano, estas tres funciones siempre devueven el mismo valor (para cada campo).

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Un int que representa un valor del campo dado en la unidad del campo o false en caso de error.


Obtener el número que representa el instante actual

  • « IntlCalendar::getMinimum
  • IntlCalendar::getRepeatedWallTimeOption »
  • PHP Manual
  • IntlCalendar
  • Obtener el número que representa el instante actual

IntlCalendar::getNow

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getNow — Obtener el número que representa el instante actual

Descripción

Estilo orientado a objetos

public static IntlCalendar::getNow ( ) : float

Estilo por procedimientos

intlcal_get_now ( ) : float

El número de milisegundos que han pasado desde la fecha de referencia. Este número es derivado del instante del sistema.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un valor de tipo float que representa el número de milisegundos desde la época, sin incluir los segundos intercalares.

Ejemplos

Ejemplo #1 IntlCalendar::getNow()

<?php
$formatter = IntlDateFormatter::create('es_ES',
        IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,
        'Europe/Madrid');

$val = IntlCalendar::getNow();

var_dump($val);
echo $formatter->format(IntlCalendar::getNow() / 1000.), "\n";

El resultado del ejemplo sería:

float(1371425814666)
lunes, 17 de junio de 2013 01:36:54 Hora de verano de Europa central


Obtener el comportamiento para tratar horas repetidas

  • « IntlCalendar::getNow
  • IntlCalendar::getSkippedWallTimeOption »
  • PHP Manual
  • IntlCalendar
  • Obtener el comportamiento para tratar horas repetidas

IntlCalendar::getRepeatedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getRepeatedWallTimeOption — Obtener el comportamiento para tratar horas repetidas

Descripción

Estilo orientado a objetos

public IntlCalendar::getRepeatedWallTimeOption ( ) : int

Estilo por procedimientos

intlcal_get_repeated_wall_time_option ( IntlCalendar $cal ) : int

Obtiene la estrategia actual para tratar con horas repetidas siempre que el reloj se atrase durante las transiciones del final del horario de verano (DST). El valor predeterminado es IntlCalendar::WALLTIME_LAST.

Esta función requiere ICU 4.9 o posterior.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Una de las constantes IntlCalendar::WALLTIME_FIRST o IntlCalendar::WALLTIME_LAST.

Ejemplos

Ejemplo #1 IntlCalendar::getRepeatedWallTimeOption()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');
ini_set('intl.error_level', E_WARNING);

// El 27 de octubre a las 0200, el reloj se atrasa 1 hora y de GMT+01 a GMT+00
$cal = new IntlGregorianCalendar(2013, 9 /* October */, 27, 1, 30);

var_dump($cal->getRepeatedWalltimeOption()); // 0 WALLTIME_LAST

$formateador = IntlDateFormatter::create(
    NULL,
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'UTC'
);
var_dump($formateador->format($cal->getTime() / 1000.));

$cal->setRepeatedWalltimeOption(IntlCalendar::WALLTIME_FIRST);
var_dump($cal->getRepeatedWalltimeOption()); // 1 WALLTIME_FIRST
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formateador->format($cal->getTime() / 1000.));

El resultado del ejemplo sería:

int(0)
string(42) "Sunday, October 27, 2013 at 1:30:00 AM GMT"
int(1)
string(43) "Sunday, October 27, 2013 at 12:30:00 AM GMT"

Ver también

  • IntlCalendar::getSkippedWallTimeOption() - Obtener el comportamiento para tratar horas omitidas
  • IntlCalendar::setSkippedWallTimeOption() - Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
  • IntlCalendar::setRepeatedWallTimeOption() - Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias


Obtener el comportamiento para tratar horas omitidas

  • « IntlCalendar::getRepeatedWallTimeOption
  • IntlCalendar::getTime »
  • PHP Manual
  • IntlCalendar
  • Obtener el comportamiento para tratar horas omitidas

IntlCalendar::getSkippedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getSkippedWallTimeOption — Obtener el comportamiento para tratar horas omitidas

Descripción

Estilo orientado a objetos

public IntlCalendar::getSkippedWallTimeOption ( ) : int

Estilo por procedimientos

intlcal_get_skipped_wall_time_option ( IntlCalendar $cal ) : int

Obtiene la estrategia actual para tratar con horas omitidassiempre que el reloj se adelante durante las transiciones del inicio del horario de verano (DST). El valor predeterminado es IntlCalendar::WALLTIME_LAST.

El calendario debe ser tolerante para que esta opción tenga efecto, si no, el intento de establecer un instante no existente provocará un error.

Esta función requiere ICU 4.9 o posterior.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Una de las constantes IntlCalendar::WALLTIME_FIRST,
IntlCalendar::WALLTIME_LAST o
IntlCalendar::WALLTIME_NEXT_VALID.

Ejemplos

Ejemplo #1 IntlCalendar::getSkippedWallTimeOption()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');
ini_set('intl.error_level', E_WARNING);

// El 31 de marzo a las 0100, el reloj se adelanta 1 hora y se cambia de GMT+00 a GMT+01
$cal = new IntlGregorianCalendar(2013, 2 /* March */, 31, 1, 30);

var_dump(
    $cal->isLenient(),               // true
    $cal->getSkippedWalltimeOption() // 0 WALLTIME_LAST
);

$formateador = IntlDateFormatter::create(
    NULL,
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'UTC'
);
var_dump($formateador->format($cal->getTime() / 1000));

$cal->setSkippedWallTimeOption(IntlCalendar::WALLTIME_FIRST);
var_dump($cal->getSkippedWalltimeOption()); // 1 WALLTIME_FIRST
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formateador->format($cal->getTime() / 1000));

$cal->setSkippedWallTimeOption(IntlCalendar::WALLTIME_NEXT_VALID);
var_dump($cal->getSkippedWalltimeOption()); // 2 WALLTIME_NEXT_VALID
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formateador->format($cal->getTime() / 1000));

El resultado del ejemplo sería:

bool(true)
int(0)
string(40) "Sunday, March 31, 2013 at 1:30:00 AM GMT"
int(1)
string(41) "Sunday, March 31, 2013 at 12:30:00 AM GMT"
int(2)
string(40) "Sunday, March 31, 2013 at 1:00:00 AM GMT"

Ver también

  • IntlCalendar::getRepeatedWallTimeOption() - Obtener el comportamiento para tratar horas repetidas
  • IntlCalendar::setSkippedWallTimeOption() - Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
  • IntlCalendar::setRepeatedWallTimeOption() - Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias


Obtiene el tiempo representado por el objeto

  • « IntlCalendar::getSkippedWallTimeOption
  • IntlCalendar::getTimeZone »
  • PHP Manual
  • IntlCalendar
  • Obtiene el tiempo representado por el objeto

IntlCalendar::getTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getTime — Obtiene el tiempo representado por el objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::getTime ( ) : float

Estilo por procedimientos

intlcal_get_time ( IntlCalendar $cal ) : float

Devuelve el tiempo en milisegundos asociado al objeto desde el tiempo Unix.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un float represendando el número de milisegundos transcurridos desde el tiempo de referencia (1 Jan 1970 00:00:00 UTC).

Ejemplos

Ejemplo #1 IntlCalendar::getTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = new IntlGregorianCalendar(2013, 4 /* May */, 1, 0, 0, 0);
$time = $cal->getTime();
var_dump($time, $time / 1000 == strtotime('2013-05-01 00:00:00')); //true

El resultado del ejemplo sería:

float(1367362800000)
bool(true)

Ver también

  • IntlCalendar::getNow() - Obtener el número que representa el instante actual


Obtener la zona horaria del objeto

  • « IntlCalendar::getTime
  • IntlCalendar::getType »
  • PHP Manual
  • IntlCalendar
  • Obtener la zona horaria del objeto

IntlCalendar::getTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getTimeZone — Obtener la zona horaria del objeto

Descripción

Estilo orientado a objetos

public IntlCalendar::getTimeZone ( ) : IntlTimeZone

Estilo por procedimientos

intlcal_get_time_zone ( IntlCalendar $cal ) : IntlTimeZone

Devuelve el objeto IntlTimeZone asociado a este calendario.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un objeto IntlTimeZone al correspondiente usado internamente por este objeto.

Ejemplos

Ejemplo #1 IntlCalendar::getTimeZone()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = IntlCalendar::createInstance();
print_r($cal->getTimeZone());

$cal->setTimeZone('UTC');
print_r($cal->getTimeZone());

$cal = IntlCalendar::fromDateTime('2012-01-01 00:00:00 GMT+03:33');
print_r($cal->getTimeZone());

El resultado del ejemplo sería:

IntlTimeZone Object
(
    [valid] => 1
    [id] => Europe/Lisbon
    [rawOffset] => 0
    [currentOffset] => 3600000
)
IntlTimeZone Object
(
    [valid] => 1
    [id] => UTC
    [rawOffset] => 0
    [currentOffset] => 0
)
IntlTimeZone Object
(
    [valid] => 1
    [id] => GMT+03:33
    [rawOffset] => 12780000
    [currentOffset] => 12780000
)

Ver también

  • IntlCalendar::setTimeZone() - Establecer la zona horaria usada por este calendario
  • IntlCalendar::createInstance() - Crear un nuevo IntlCalendar
  • IntlGregorianCalendar::__construct()


Obtener el tipo de calendario

  • « IntlCalendar::getTimeZone
  • IntlCalendar::getWeekendTransition »
  • PHP Manual
  • IntlCalendar
  • Obtener el tipo de calendario

IntlCalendar::getType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getType — Obtener el tipo de calendario

Descripción

Estilo orientado a objetos

public IntlCalendar::getType ( ) : string

Estilo por procedimientos

intlcal_get_type ( IntlCalendar $cal ) : string

Un string que describe el tipo de este calendario. Es uno de los valores válidos para el valor de la palabra clave de calendario 'calendar'.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un string que representa el tipo de calendario, como 'gregorian', 'islamic', etc.

Ejemplos

Ejemplo #1 IntlCalendar::getType()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = IntlCalendar::createInstance(NULL, '@calendar=ethiopic-amete-alem');
var_dump($cal->getType());

$cal = new IntlGregorianCalendar();
var_dump($cal->getType());

El resultado del ejemplo sería:

string(19) "ethiopic-amete-alem"
string(9) "gregorian"


Obtener el instante del día en la que comienza o termina el fin de semana

  • « IntlCalendar::getType
  • IntlCalendar::inDaylightTime »
  • PHP Manual
  • IntlCalendar
  • Obtener el instante del día en la que comienza o termina el fin de semana

IntlCalendar::getWeekendTransition

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getWeekendTransition — Obtener el instante del día en la que comienza o termina el fin de semana

Descripción

Estilo orientado a objetos

public IntlCalendar::getWeekendTransition ( string $dayOfWeek ) : int

Estilo por procedimientos

intlcal_get_weekend_transition ( IntlCalendar $cal , string $dayOfWeek ) : int

Devuelve el número de milisegundos después de medianoche en los que comienza o termina el fin de semana.

Esto es sólo aplicable a días de la semana para los que
IntlCalendar::getDayOfWeekType() devuelve
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET o
IntlCalendar::DOW_TYPE_WEEKEND_CEASE. Invocar a esta
función para otros días de la semana es una condición d error.

Esta función requiere ICU 4.4 o posterior.

Parámetros

cal

El recurso IntlCalendar.

dayOfWeek

Una de las constantes IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, …,
IntlCalendar::DOW_SATURDAY.

Valores devueltos

El número de milisegundos dentro el día en el que comienza o termina el fin de semana o false en caso de error.

Ejemplos

Véase el ejemplo de IntlCalendar::getDayOfWeekType().


Indicar si el instante del objeto está en el horario de verano

  • « IntlCalendar::getWeekendTransition
  • IntlCalendar::isEquivalentTo »
  • PHP Manual
  • IntlCalendar
  • Indicar si el instante del objeto está en el horario de verano

IntlCalendar::inDaylightTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::inDaylightTime — Indicar si el instante del objeto está en el horario de verano

Descripción

Estilo orientado a objetos

public IntlCalendar::inDaylightTime ( ) : bool

Estilo por procedimientos

intlcal_in_daylight_time ( IntlCalendar $cal ) : bool

Si, para el instante representado por este objeto y por esta configuración regional del mismo, toma lugar el horario de verano (DST).

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Devuelve true si la fecha está en el horario de verano, false de lo contrario. El valor false también podría ser devuelto en caso de error, por ejemplo, después de especificar valores de campo no válidos en modo no tolerante; emplee excepciones o consulte intl_get_error_code() para eliminar la ambigüedad.

Ejemplos

Ejemplo #1 IntlCalendar::inDaylightTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1, 4, 56, 31);
var_dump($cal->inDaylightTime()); // true
$cal->set(IntlCalendar::FIELD_MONTH, 11 /* December */);
var_dump($cal->inDaylightTime()); // false

// La transición de DST finaliza en 2013-10-27 a las 0200 (el reloj se atrasa 1 hora)
$cal = new IntlGregorianCalendar(2013, 9 /* October */, 27, 1, 30, 0);

var_dump($cal->inDaylightTime()); // false (default WALLTIME_LAST)

$cal->setRepeatedWallTimeOption(IntlCalendar::WALLTIME_FIRST);
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1); // force time recalculation
var_dump($cal->inDaylightTime()); // true


Indicar si otro calendario es igual pero para un instante diferente

  • « IntlCalendar::inDaylightTime
  • IntlCalendar::isLenient »
  • PHP Manual
  • IntlCalendar
  • Indicar si otro calendario es igual pero para un instante diferente

IntlCalendar::isEquivalentTo

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isEquivalentTo — Indicar si otro calendario es igual pero para un instante diferente

Descripción

Estilo orientado a objetos

public IntlCalendar::isEquivalentTo ( IntlCalendar $other ) : bool

Estilo por procedimientos

intlcal_is_equivalent_to ( IntlCalendar $cal , IntlCalendar $other ) : bool

Devuelve si este objeto y el dado son equivalentes para todos los propósitos excepto para el instante que tienen establecido. Las configuraciones regionales no tienen que coincidir, ya que no resultará un cambio en el comportamiento. Esto incluye la zona horaria, si está establecido el ?odo tolerante, los ajustes de reloj repetido y omitido, los días de la semana al empezar y cesar el fin de semana y el instante en el cual ocurren dichas transiciones. También se podrían incluir otros ajustes específicos de calendario, como el instante de transición del gregroriano/juliano.

Parámetros

cal

El recurso IntlCalendar.

other

El otro calendario con el que realizar la comparación.

Valores devueltos

Asumiendo que no existen errores de argumento, devuelve true si los calendarios son equivalentes excepto posiblemente por el instante establecido.

Ejemplos

Ejemplo #1 IntlCalendar::isEquivalentTo()

<?php
$cal1 = IntlCalendar::createInstance('Europe/Lisbon', 'pt_PT');
$cal2 = IntlCalendar::createInstance('Europe/Lisbon', 'es_ES');
$cal2->clear();

var_dump($cal1->isEquivalentTo($cal2)); // true

$cal3 = IntlCalendar::createInstance('Europe/Lisbon', 'en_US');
var_dump($cal1->isEquivalentTo($cal3)); // false
var_dump($cal1->getFirstDayOfWeek(),    // 2 (lunes)
$cal3->getFirstDayOfWeek());            // 1 (domingo)

El resultado del ejemplo sería:

bool(true)
bool(false)
int(2)
int(1)

Ver también

  • IntlCalendar::equals() - Comparar el instante de dos objetos IntlCalendar


Indicar si la interpretación de una fecha/hora está en modo tolerante

  • « IntlCalendar::isEquivalentTo
  • IntlCalendar::isSet »
  • PHP Manual
  • IntlCalendar
  • Indicar si la interpretación de una fecha/hora está en modo tolerante

IntlCalendar::isLenient

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isLenient — Indicar si la interpretación de una fecha/hora está en modo tolerante

Descripción

Estilo orientado a objetos

public IntlCalendar::isLenient ( ) : bool

Estilo por procedimientos

intlcal_is_lenient ( IntlCalendar $cal ) : bool

Devuelve si las interpretaciones de fecha/hora actuales son tolerantes (lo predeterminado). Si este fuera el caso, se aceptarán algunos valores fuera de rango, en lugar de emitir un error.

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un booleano que representa si el calendario está en modo tolerante.

Ejemplos

Ejemplo #1 IntlCalendar::isLenient()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');
ini_set('intl.use_exceptions', '1');

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
var_dump(IntlDateFormatter::formatObject($cal), // 01/07/2013, 00:00:00
$cal->isLenient()); // true

$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 33);
var_dump(IntlDateFormatter::formatObject($cal)); // 02/08/2013, 00:00:00

$cal->setLenient(false);
var_dump($cal->isLenient()); // false
$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 33);
var_dump(IntlDateFormatter::formatObject($cal)); // error

El resultado del ejemplo sería:

string(20) "01/07/2013, 00:00:00"
bool(true)
string(20) "02/08/2013, 00:00:00"
bool(false)

Fatal error: Uncaught exception 'IntlException' with message 'datefmt_format_object: error obtaining instant from IntlCalendar' in /home/foobar/example.php:16
Stack trace:
#0 /home/foobar/example.php(16): IntlDateFormatter::formatObject(Object(IntlGregorianCalendar))
#1 {main}
  thrown in /home/foobar/example.php on line 16


Determina si un campo está definido

  • « IntlCalendar::isLenient
  • IntlCalendar::isWeekend »
  • PHP Manual
  • IntlCalendar
  • Determina si un campo está definido

IntlCalendar::isSet

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isSet — Determina si un campo está definido

Descripción

Estilo orientado a objetos

public IntlCalendar::isSet ( int $field ) : bool

Estilo por procedimientos

intlcal_is_set ( IntlCalendar $cal , int $field ) : bool

Indica si un campo está definido (lo opuesto a clear). Los campos definidos tienen prioridad sobre los indefinidos y sus valores por defecto cuando la fecha/hora está siendo calculada. Los campos definidos con posterioridad tienen prioridad sobre los definidos con anterioridad.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

Valores devueltos

Asumiendo que no hay errores, devuelve true si el campo está definido.

Ejemplos

Vea el ejemplo en IntlCalendar::clear().

Ver también

  • IntlCalendar::clear() - Limpiar uno o todos los campos
  • IntlCalendar::set() - Establecer un campo de instante o varios campos en común de una vez


Determina si una cierta fecha es fin de semana

  • « IntlCalendar::isSet
  • IntlCalendar::roll »
  • PHP Manual
  • IntlCalendar
  • Determina si una cierta fecha es fin de semana

IntlCalendar::isWeekend

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isWeekend — Determina si una cierta fecha es fin de semana

Descripción

Estilo orientado a objetos

public IntlCalendar::isWeekend ( float $date = NULL ) : bool

Estilo por procedimientos

intlcal_is_weekend ( IntlCalendar $cal , float $date = NULL ) : bool

Devuelve si la fecha actual del objeto o el timestamp proporcionado ocurre durante un fin de semana en el sistema de calendario del objeto.

Esta función requiere ICU 4.4 o posterior.

Parámetros

cal

El recurso IntlCalendar.

date

Un timestamp opcional representa el número de milisegundos desde la fecha Unix, excluyendo segundos intercalares. Si es null, se usará la fecha actual del objeto.

Valores devueltos

Un bool indicando si la fecha del objeto dado ocurre en un fin de semana.

El valor false puede ser devuelvo en caso de fallo, por ejemplo después de dar una fecha fuera de los límites o de un modo inconsistente; use exceptions o consulte intl_get_error_code() en caso de ambigüedad.

Ejemplos

Ejemplo #1 IntlCalendar::isWeekend()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

$cal = new IntlGregorianCalendar(NULL, 'en_US');
$cal->set(2013, 6 /* July */, 7); // un Domingo

var_dump($cal->isWeekend()); // true
var_dump($cal->isWeekend(strtotime('2013-07-01 00:00:00'))); // false, Lunes

$cal = new IntlGregorianCalendar(NULL, 'ar_SA');
$cal->set(2013, 6 /* July */, 7); // un Domingo
var_dump($cal->isWeekend()); // false, Domingo no es fin de semana en este calendario

Ver también

  • IntlCalendar::getDayOfWeekType() - Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos
  • IntlCalendar::getWeekendTransition() - Obtener el instante del día en la que comienza o termina el fin de semana


Añadir un valor a un campo si acarrear más campos significativos

  • « IntlCalendar::isWeekend
  • IntlCalendar::set »
  • PHP Manual
  • IntlCalendar
  • Añadir un valor a un campo si acarrear más campos significativos

IntlCalendar::roll

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::roll — Añadir un valor a un campo si acarrear más campos significativos

Descripción

Estilo orientado a objetos

public IntlCalendar::roll ( int $field , mixed $amountOrUpOrDown ) : bool

Estilo por procedimientos

intlcal_roll ( IntlCalendar $cal , int $field , mixed $amountOrUpOrDown ) : bool

Añade una cantidad (con signo) a un campo. La diferencia con respecto a IntlCalendar::add() es que cuando el valor del campo se desborda, no acarrea más campos significativos.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

amountOrUpOrDown

La cantidad (con signo) a añadir al campo, true para subir (añadiendo 1), o false para bajar (sustrayendo 1).

Valores devueltos

Devuelve true en caso de éxito, false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::roll()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

$cal = new IntlGregorianCalendar(2013, 5 /* June */, 30);

$cal->add(IntlCalendar::FIELD_DAY_OF_MONTH, 1);
var_dump(IntlDateFormatter::formatObject($cal)); // "01/07/2013, 00:00:00"

$cal->set(2013, 5 /* June */, 30);
$cal->roll(IntlCalendar::FIELD_DAY_OF_MONTH, true); // subir, lo mismo que subir +1
var_dump(IntlDateFormatter::formatObject($cal)); // "01/06/2013, 00:00:00"

El resultado del ejemplo sería:

string(20) "01/07/2013, 00:00:00"
string(20) "01/06/2013, 00:00:00"

Ver también

  • IntlCalendar::add() - Añadir una candidad (con signo) de tiempo al campo
  • IntlCalendar::set() - Establecer un campo de instante o varios campos en común de una vez


Establecer un campo de instante o varios campos en común de una vez

  • « IntlCalendar::roll
  • IntlCalendar::setFirstDayOfWeek »
  • PHP Manual
  • IntlCalendar
  • Establecer un campo de instante o varios campos en común de una vez

IntlCalendar::set

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::set — Establecer un campo de instante o varios campos en común de una vez

Descripción

Estilo orientado a objetos

public IntlCalendar::set ( int $field , int $value ) : bool
public IntlCalendar::set ( int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool

Estilo por procedimientos

intlcal_set ( IntlCalendar $cal , int $field , int $value ) : bool
intlcal_set ( IntlCalendar $cal , int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool

Establece un campo al valor dado o varion campos en común de una vez. El rango de valores que se aceptan dependen de si el calendario está empleando el modo tolerante.

Para campos que entren en conflicto, los campos que se establezcan después tienen prioridad.

Este método no se puede invocar con exactamente cuatro argumentos.

Parámetros

cal

El recurso IntlCalendar.

field

Una de las constantes del campo fecha/hora de IntlCalendar. Son valores de tipo integer entre 0 y IntlCalendar::FIELD_COUNT.

value

El nuevo valor para el campo dado.

year

El nuevo valor para IntlCalendar::FIELD_YEAR.

month

El nuevo valor para IntlCalendar::FIELD_MONTH.

dayOfMonth

El nuevo valor para IntlCalendar::FIELD_DAY_OF_MONTH. La secuencia de meses empieza en cero, es decir, enero está representado por 0, febrero por 1, …, diciembre es 11 y undiciembre (si el calendario lo posee) es 12.

hour

El nuevo valor para IntlCalendar::FIELD_HOUR_OF_DAY.

minute

El nuevo valor para IntlCalendar::FIELD_MINUTE.

second

El nuevo valor para IntlCalendar::FIELD_SECOND.

Valores devueltos

Devuelve true en caso de éxito, false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::set()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

// Las llamadas realizadas después tienen prioridad
$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
$cal->set(IntlCalendar::FIELD_YEAR, 2012);
$cal->set(IntlCalendar::FIELD_EXTENDED_YEAR, 2011);
var_dump(IntlDateFormatter::formatObject($cal));

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
$cal->set(IntlCalendar::FIELD_YEAR, 2012);
$cal->set(IntlCalendar::FIELD_EXTENDED_YEAR, 2011);
// La hora aún no se ha recalculado. Si limpiamos el año ampliado,
// se empleará el año establecido antes
$cal->clear(IntlCalendar::FIELD_EXTENDED_YEAR);
var_dump(IntlDateFormatter::formatObject($cal));

El resultado del ejemplo sería:

string(20) "01/07/2011, 00:00:00"
string(20) "01/07/2012, 00:00:00"

Ver también

  • IntlCalendar::get() - Obtiene el valor de un campo
  • IntlCalendar::add() - Añadir una candidad (con signo) de tiempo al campo
  • IntlCalendar::roll() - Añadir un valor a un campo si acarrear más campos significativos


Establecer el día en el que se estima que empieza la semana

  • « IntlCalendar::set
  • IntlCalendar::setLenient »
  • PHP Manual
  • IntlCalendar
  • Establecer el día en el que se estima que empieza la semana

IntlCalendar::setFirstDayOfWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setFirstDayOfWeek — Establecer el día en el que se estima que empieza la semana

Descripción

Estilo orientado a objetos

public IntlCalendar::setFirstDayOfWeek ( int $dayOfWeek ) : bool

Estilo por procedimientos

intlcal_set_first_day_of_week ( IntlCalendar $cal , int $dayOfWeek ) : bool

Define el día en el que se estima que empieza la semana. Esto afecta al comportamiento de campos que dependen del concepto de inicio y final de semana, como IntlCalendar::FIELD_WEEK_OF_YEAR y IntlCalendar::FIELD_YEAR_WOY.

Parámetros

cal

El recurso IntlCalendar.

dayOfWeek

Una de las constantes IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, …,
IntlCalendar::DOW_SATURDAY.

Valores devueltos

Devuelve true en caso de éxito. Los errores solamente pueden ocurrir debido a parámetros no válidos.

Ejemplos

Ejemplo #1 IntlCalendar::setFirstDayOfWeek()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'es_ES');

$cal = IntlCalendar::createInstance();
$cal->set(2013, 5 /* June */, 30); // Un domingo

var_dump($cal->getFirstDayOfWeek()); // 2 (Lunes)

echo IntlDateFormatter::formatObject($cal, <<<EOD
'día local de la semana: 'cc'
semana del mes        : 'W'
semana del año        : 'ww
EOD
), "\n";

$cal->setFirstDayOfWeek(IntlCalendar::DOW_SUNDAY);

echo IntlDateFormatter::formatObject($cal, <<<EOD
'día local de la semana: 'cc'
semana del mes        : 'W'
semana del año        : 'ww
EOD
), "\n";

El resultado del ejemplo sería:

int(2)
día local de la semana: 7
semana del mes        : 4
semana del año        : 26
día local de la semana: 1
semana del mes        : 5
semana del año        : 27


Establecer si la interpretación de la fecha/hora es tolerante

  • « IntlCalendar::setFirstDayOfWeek
  • IntlCalendar::setMinimalDaysInFirstWeek »
  • PHP Manual
  • IntlCalendar
  • Establecer si la interpretación de la fecha/hora es tolerante

IntlCalendar::setLenient

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setLenient — Establecer si la interpretación de la fecha/hora es tolerante

Descripción

Estilo orientado a objetos

public IntlCalendar::setLenient ( string $isLenient ) : ReturnType

Estilo por procedimientos

intlcal_set_lenient ( IntlCalendar $cal , string $isLenient ) : ReturnType

Define si el calendario está en ‘modo tolerante’. En dicho modo, se aceptan algunos de valores fuera de rango para algunos campos, siendo el comportamiento similar al de IntlCalendar::add() (es decir, el valor sobrepasa, acarreando más campos significativos cada vez). Si el modo tolerante está desactivado, tales valores generarán un error.

Parámetros

cal

El recurso IntlCalendar.

isLenient

Use true para activar el modo tolerante; false de lo contrario.

Valores devueltos

Devuelve true en caso de éxito. Los errores solamente pueden ocurrir debido a parámetros no válidos.

Ejemplos

Véase el ejemplo de IntlCalendar::isLenient().


Establecer el número de días mínimo que puede tener la primera semana de un año o mes

  • « IntlCalendar::setLenient
  • IntlCalendar::setRepeatedWallTimeOption »
  • PHP Manual
  • IntlCalendar
  • Establecer el número de días mínimo que puede tener la primera semana de un año o mes

IntlCalendar::setMinimalDaysInFirstWeek

(PHP 5 >= 5.5.1, PHP 7)

IntlCalendar::setMinimalDaysInFirstWeek — Establecer el número de días mínimo que puede tener la primera semana de un año o mes

Descripción

Estilo orientado a objetos

public IntlCalendar::setMinimalDaysInFirstWeek ( int $minimalDays ) : bool

Estilo por procedimientos

intlcal_get_minimal_days_in_first_week ( IntlCalendar $cal , int $minimalDays ) : bool

Establece el número mínimo de días que debe tener la primera semana de un año o mes en el nuevo año o mes. Por ejemplo, en el calendario gregoriano, si este valor es 1, la primera semana de año incluirá necesariamente el 1 de enero, mientras que si este valor es 7, la semana con el 1 de enerio será la primera semana del año únicamente si el día de la semana para el 1 de enero coincide con el día de la semana devuelto por IntlCalendar::getFirstDayOfWeek(); de lo contrario será la última semana del año anterior.

Parámetros

cal

El recurso IntlCalendar.

minimalDays

El número mínimo de días a establecer.

Valores devueltos

true en caso de éxito, false en caso de error.


Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias

  • « IntlCalendar::setMinimalDaysInFirstWeek
  • IntlCalendar::setSkippedWallTimeOption »
  • PHP Manual
  • IntlCalendar
  • Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias

IntlCalendar::setRepeatedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setRepeatedWallTimeOption — Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias

Descripción

Estilo orientado a objetos

public IntlCalendar::setRepeatedWallTimeOption ( int $wallTimeOption ) : bool

Estilo por procedimientos

intlcal_set_repeated_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool

Establece la estrategia a usar para tratar con las horas repetidas siempre que el reloj se atrase durante las transiciones del final del horario de verano (DST). El valor predeterminado es IntlCalendar::WALLTIME_LAST (tomado como si fuera el instante pos-DST). El otro valor posible es IntlCalendar::WALLTIME_FIRST (tomando el mismo instante que ocurre durante el DST).

Esta función requiere ICU 4.9 o posterior.

Parámetros

cal

El recurso IntlCalendar.

wallTimeOption

Una de las constantes IntlCalendar::WALLTIME_FIRST o IntlCalendar::WALLTIME_LAST.

Valores devueltos

Devuelve true en caso de éxito. Los errores solamente pueden ocurrir debido a parámetros no válidos.

Ejemplos

Véase el ejemplo de IntlCalendar::getRepeatedWallTimeOption().

Ver también

  • intlCalendar::getRepeatedWallTimeOption() - Obtener el comportamiento para tratar horas repetidas
  • intlCalendar::setSkippedWallTimeOption() - Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
  • intlCalendar::getSkippedWallTimeOption() - Obtener el comportamiento para tratar horas omitidas


Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias

  • « IntlCalendar::setRepeatedWallTimeOption
  • IntlCalendar::setTime »
  • PHP Manual
  • IntlCalendar
  • Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias

IntlCalendar::setSkippedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setSkippedWallTimeOption — Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias

Descripción

Estilo orientado a objetos

public IntlCalendar::setSkippedWallTimeOption ( int $wallTimeOption ) : bool

Estilo por procedimientos

intlcal_set_skipped_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool

Establece la estrategia a usar para tratar con las horas omitidas siempre que el reloj se adelante durante las transiciones del inicio del horario de verano (DST). El valor predeterminado es IntlCalendar::WALLTIME_LAST (tomado como si fuera el mismo instante el de adelantar el reloj una hora). Los valores alternativos son IntlCalendar::WALLTIME_FIRST (mismo instante que el de atrasar el reloj una hora) y IntlCalendar::WALLTIME_NEXT_VALID (mismo instante que cuando comienza el DST).

Esto afecta solamente a los instantes representados por el calendario (como en IntlCalendar::getTime()); los valores de los campos no serán sobrescritos en consencuencia.

El calendario debe ser tolerante para que esta opción tenga efecto, si no, el intento de establecer un instante no existente provocará un error.

Esta función requiere ICU 4.9 o posterior.

Parámetros

cal

El recurso IntlCalendar.

wallTimeOption

Una de las constantes IntlCalendar::WALLTIME_FIRST,
IntlCalendar::WALLTIME_LAST o
IntlCalendar::WALLTIME_NEXT_VALID.

Valores devueltos

Devuelve true en caso de éxito. Los errores solamente pueden ocurrir debido a parámetros no válidos.

Ejemplos

Véase el ejemplo de IntlCalendar::getSkippedWallTimeOption().

Ver también

  • intlCalendar::getSkippedWallTimeOption() - Obtener el comportamiento para tratar horas omitidas
  • intlCalendar::setRepeatedWallTimeOption() - Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias
  • intlCalendar::getRepeatedWallTimeOption() - Obtener el comportamiento para tratar horas repetidas


Establecer el momento del calendario en milisegundos desde la época

  • « IntlCalendar::setSkippedWallTimeOption
  • IntlCalendar::setTimeZone »
  • PHP Manual
  • IntlCalendar
  • Establecer el momento del calendario en milisegundos desde la época

IntlCalendar::setTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setTime — Establecer el momento del calendario en milisegundos desde la época

Descripción

Estilo orientado a objetos

public IntlCalendar::setTime ( float $date ) : bool

Estilo por procedimientos

intlcal_set_time ( IntlCalendar $cal , float $date ) : bool

Establece el instante representado por este objeto. El instante está representado por un valor de tipo float que debería ser un número entero de milisegundos desde la época (1 Jan 1970 00:00:00.000 UTC), ignorando los segundos intercalares. seconds. Todos los valores de los campos se recalcularán en consecuencia.

Parámetros

cal

El recurso IntlCalendar.

date

Un instante representado por el número de milisegundos entre dicho instante y la época, ignorando los segundos intercalares.

Valores devueltos

Devuelve true en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::setTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'fr_FR');

$cal = new IntlGregorianCalendar(2013, 5 /* May */, 1, 12, 0, 0);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

/* En Europe/Lisbon, el 2013-10-27 a las 0200, el reloj se atrasa una hora
   y la zona horaria cambia de UTC+01 a UTC+00 */

$cal->setTime(strtotime('2013-10-27 00:30:00 UTC') * 1000.);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

$cal->setTime(strtotime('2013-10-27 01:30:00 UTC') * 1000.);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

El resultado del ejemplo sería:

samedi 1 juin 2013 12:00:00 heure avancée d’Europe de l’Ouest
dimanche 27 octobre 2013 01:30:00 heure avancée d’Europe de l’Ouest
dimanche 27 octobre 2013 01:30:00 heure normale d’Europe de l’Ouest


Establecer la zona horaria usada por este calendario

  • « IntlCalendar::setTime
  • IntlCalendar::toDateTime »
  • PHP Manual
  • IntlCalendar
  • Establecer la zona horaria usada por este calendario

IntlCalendar::setTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setTimeZone — Establecer la zona horaria usada por este calendario

Descripción

Estilo orientado a objetos

public IntlCalendar::setTimeZone ( mixed $timeZone ) : bool

Estilo por procedimientos

intlcal_set_time_zone ( IntlCalendar $cal , mixed $timeZone ) : bool

Define una nueva zona horaria para este calendario. El momento representado por el objeto se preserva en detrimento de los valores de los campos.

Parámetros

cal

El recurso IntlCalendar.

timeZone

La nueva zona horaria que usará este calendario. Se puede especificar de las siguientes maneras:

  • null, en cuyo caso se usará la zona horaria predeterminada, tal como está especificada en el ajuste ini date.timezone o a través de la función date_default_timezone_set() y como es devuelto por date_default_timezone_get().

  • Un IntlTimeZone, que se usará directamente.

  • Un DateTimeZone. Su identificador será extraido y se creará un objeto de zona horaria de ICU; la zona horaria será proporcionada por la base de datos de ICU, no por la de PHP.

  • Un string, que debería ser un identificador de zona horaria de ICU válido. Véase IntlTimeZone::createTimeZoneIDEnumeration(). Los índices puros como "GMT+08:30" también se aceptan.

Valores devueltos

Devuelve true en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::setTimeZone()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'es_ES');

$cal = new IntlGregorianCalendar(2013, 5 /* May */, 1, 12, 0, 0);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

$cal->setTimeZone(IntlTimeZone::getGMT());
echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

$cal->setTimeZone('GMT+03:33');
echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

El resultado del ejemplo sería:

sábado, 1 de junio de 2013 12:00:00 Hora de verano de Europa occidental
(instant 1370084400000)
sábado, 1 de junio de 2013 11:00:00 GMT
(instant 1370084400000)
sábado, 1 de junio de 2013 14:33:00 GMT+03:33
(instant 1370084400000)


Convertir un objeto IntlCalendar a un objeto DateTime

  • « IntlCalendar::setTimeZone
  • IntlTimeZone »
  • PHP Manual
  • IntlCalendar
  • Convertir un objeto IntlCalendar a un objeto DateTime

IntlCalendar::toDateTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a2)

IntlCalendar::toDateTime — Convertir un objeto IntlCalendar a un objeto DateTime

Descripción

Estilo orientado a objetos

public IntlCalendar::toDateTime ( ) : DateTime

Estilo por procedimientos

intlcal_to_date_time ( IntlCalendar $cal ) : DateTime

Crea un objeto DateTime que representa el mismo instante (con precisión de segundo, con un límite de error menor que 1 segundo) y que posee una zona horaria análoga a este objeto (siendo la diferencia que la zona horaria de DateTime será respaldada por las zonas horarias de PHP mientras que la zona horararia de IntlCalendar será respaldada por las de ICU).

Parámetros

cal

El recurso IntlCalendar.

Valores devueltos

Un objeto DateTime con la misma zona horaria que este objeto (aunque se emplea la base de datos de PHP en lugar de la de ICU) y el mismo instante, excepto por la preción más pequeña (precisión de segundos en lugar de milisegundos). Devuelve false en caso de error.

Ejemplos

Ejemplo #1 IntlCalendar::toDateTime()

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'pt_PT');

$cal = IntlCalendar::createInstance('Europe/Lisbon'); //current time

$dt = $cal->toDateTime();
print_r($dt);

El resultado del ejemplo sería:

DateTime Object
(
    [date] => 2013-07-02 00:29:13
    [timezone_type] => 3
    [timezone] => Europe/Lisbon
)

Ver también

  • IntlCalendar::fromDateTime() - Crear un IntlCalendar desde un objeto DateTime o tring
  • IntlCalendar::getTime() - Obtiene el tiempo representado por el objeto
  • IntlCalendar::createInstance() - Crear un nuevo IntlCalendar
  • DateTime:__construct()


La clase IntlTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

Introducción

Sinopsis de la Clase

IntlTimeZone {
/* Constantes */
const integer DISPLAY_SHORT = 1 ;
const integer DISPLAY_LONG = 2 ;
/* Métodos */
public static countEquivalentIDs ( string $zoneId ) : integer
public static createDefault ( ) : IntlTimeZone
public static createEnumeration ( mixed $countryOrRawOffset = ? ) : IntlIterator
public static createTimeZone ( string $zoneId ) : IntlTimeZone
public static createTimeZoneIDEnumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false
public static fromDateTimeZone ( DateTimeZone $zoneId ) : IntlTimeZone
public static getCanonicalID ( string $zoneId , bool &$isSystemID = ? ) : string
public getDisplayName ( bool $isDaylight = ? , integer $style = ? , string $locale = ? ) : string
public getDSTSavings ( ) : integer
public static getEquivalentID ( string $zoneId , integer $index ) : string
public getErrorCode ( ) : integer
public getErrorMessage ( ) : string
public static getGMT ( ) : IntlTimeZone
public getID ( ) : string
public static getIDForWindowsID ( string $timezone , string $region = ? ) : string|false
public getOffset ( float $date , bool $local , integer &$rawOffset , integer &$dstOffset ) : integer
public getRawOffset ( ) : integer
public static getRegion ( string $zoneId ) : string|false
public static getTZDataVersion ( ) : string
public static getUnknown ( ) : IntlTimeZone
public static getWindowsID ( string $timezone ) : string|false
public hasSameRules ( IntlTimeZone $otherTimeZone ) : bool
public toDateTimeZone ( ) : DateTimeZone
public useDaylightTime ( ) : bool
}

Constantes predefinidas

IntlTimeZone::DISPLAY_SHORT

IntlTimeZone::DISPLAY_LONG

Tabla de contenidos

  • IntlTimeZone::countEquivalentIDs — Obtener el número de ID del grupo de equivalencias que incluye el ID dado
  • IntlTimeZone::createDefault — Crear una nueva copia de la zona horaria predeterminada para este host
  • IntlTimeZone::createEnumeration — Obtener una enumeración de ID de zonas horarias asociados al país o índice dado
  • IntlTimeZone::createTimeZone — Crear un objeto de zona horaria para el ID dado
  • IntlTimeZone::createTimeZoneIDEnumeration — Get an enumeration over system time zone IDs with the given filter conditions
  • IntlTimeZone::fromDateTimeZone — Crear un objeto de zona horaria desde DateTimeZone
  • IntlTimeZone::getCanonicalID — Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado
  • IntlTimeZone::getDisplayName — Obtener un nombre de esta zona horaria apto para la presentación al usuario
  • IntlTimeZone::getDSTSavings — Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual
  • IntlTimeZone::getEquivalentID — Obtener un ID del grupo de equivalencias que incluya el ID dado
  • IntlTimeZone::getErrorCode — Obtener el último código de error del objeto
  • IntlTimeZone::getErrorMessage — Obtener el último mensaje de error del objeto
  • IntlTimeZone::getGMT — Crear una zona horaria GMT (UTC)
  • IntlTimeZone::getID — Obtener el ID de la zona horaria
  • IntlTimeZone::getIDForWindowsID — Translate a Windows timezone into a system timezone
  • IntlTimeZone::getOffset — Obtener la zona horaria sin tratar y el índice GMT para el momento dado
  • IntlTimeZone::getRawOffset — Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)
  • IntlTimeZone::getRegion — Get the region code associated with the given system time zone ID
  • IntlTimeZone::getTZDataVersion — Obtener la versión de los datos de zonas horarias actualmente usada por ICU
  • IntlTimeZone::getUnknown — Get the "unknown" time zone
  • IntlTimeZone::getWindowsID — Translate a system timezone into a Windows timezone
  • IntlTimeZone::hasSameRules — Comprobar si esta zona horaria tiene las mismas reglas e índices que otra
  • IntlTimeZone::toDateTimeZone — Convertir a un objeto DateTimeZone
  • IntlTimeZone::useDaylightTime — Comprobar si esta zona horaria utiliza el horario de verano


Obtener el número de ID del grupo de equivalencias que incluye el ID dado

  • « IntlTimeZone
  • IntlTimeZone::createDefault »
  • PHP Manual
  • IntlTimeZone
  • Obtener el número de ID del grupo de equivalencias que incluye el ID dado

IntlTimeZone::countEquivalentIDs

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::countEquivalentIDs — Obtener el número de ID del grupo de equivalencias que incluye el ID dado

Descripción

public static IntlTimeZone::countEquivalentIDs ( string $zoneId ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

Valores devueltos


Crear una nueva copia de la zona horaria predeterminada para este host

  • « IntlTimeZone::countEquivalentIDs
  • IntlTimeZone::createEnumeration »
  • PHP Manual
  • IntlTimeZone
  • Crear una nueva copia de la zona horaria predeterminada para este host

IntlTimeZone::createDefault

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createDefault — Crear una nueva copia de la zona horaria predeterminada para este host

Descripción

public static IntlTimeZone::createDefault ( ) : IntlTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener una enumeración de ID de zonas horarias asociados al país o índice dado

  • « IntlTimeZone::createDefault
  • IntlTimeZone::createTimeZone »
  • PHP Manual
  • IntlTimeZone
  • Obtener una enumeración de ID de zonas horarias asociados al país o índice dado

IntlTimeZone::createEnumeration

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createEnumeration — Obtener una enumeración de ID de zonas horarias asociados al país o índice dado

Descripción

public static IntlTimeZone::createEnumeration ( mixed $countryOrRawOffset = ? ) : IntlIterator

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

countryOrRawOffset

Valores devueltos


Crear un objeto de zona horaria para el ID dado

  • « IntlTimeZone::createEnumeration
  • IntlTimeZone::createTimeZoneIDEnumeration »
  • PHP Manual
  • IntlTimeZone
  • Crear un objeto de zona horaria para el ID dado

IntlTimeZone::createTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createTimeZone — Crear un objeto de zona horaria para el ID dado

Descripción

public static IntlTimeZone::createTimeZone ( string $zoneId ) : IntlTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

Valores devueltos


Get an enumeration over system time zone IDs with the given filter conditions

  • « IntlTimeZone::createTimeZone
  • IntlTimeZone::fromDateTimeZone »
  • PHP Manual
  • IntlTimeZone
  • Get an enumeration over system time zone IDs with the given filter conditions

IntlTimeZone::createTimeZoneIDEnumeration

intltz_create_time_zone_id_enumeration

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::createTimeZoneIDEnumeration -- intltz_create_time_zone_id_enumeration — Get an enumeration over system time zone IDs with the given filter conditions

Descripción

Estilo orientado a objetos (method):

public static IntlTimeZone::createTimeZoneIDEnumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false

Estilo por procedimientos:

intltz_create_time_zone_id_enumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneType

region

rawOffset

Valores devueltos

Returns IntlIterator o false en caso de error.


Crear un objeto de zona horaria desde DateTimeZone

  • « IntlTimeZone::createTimeZoneIDEnumeration
  • IntlTimeZone::getCanonicalID »
  • PHP Manual
  • IntlTimeZone
  • Crear un objeto de zona horaria desde DateTimeZone

IntlTimeZone::fromDateTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::fromDateTimeZone — Crear un objeto de zona horaria desde DateTimeZone

Descripción

public static IntlTimeZone::fromDateTimeZone ( DateTimeZone $zoneId ) : IntlTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

Valores devueltos


Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado

  • « IntlTimeZone::fromDateTimeZone
  • IntlTimeZone::getDisplayName »
  • PHP Manual
  • IntlTimeZone
  • Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado

IntlTimeZone::getCanonicalID

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getCanonicalID — Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado

Descripción

public static IntlTimeZone::getCanonicalID ( string $zoneId , bool &$isSystemID = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

isSystemID

Valores devueltos


Obtener un nombre de esta zona horaria apto para la presentación al usuario

  • « IntlTimeZone::getCanonicalID
  • IntlTimeZone::getDSTSavings »
  • PHP Manual
  • IntlTimeZone
  • Obtener un nombre de esta zona horaria apto para la presentación al usuario

IntlTimeZone::getDisplayName

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getDisplayName — Obtener un nombre de esta zona horaria apto para la presentación al usuario

Descripción

public IntlTimeZone::getDisplayName ( bool $isDaylight = ? , integer $style = ? , string $locale = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

isDaylight

style

locale

Valores devueltos


Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual

  • « IntlTimeZone::getDisplayName
  • IntlTimeZone::getEquivalentID »
  • PHP Manual
  • IntlTimeZone
  • Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual

IntlTimeZone::getDSTSavings

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getDSTSavings — Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual

Descripción

public IntlTimeZone::getDSTSavings ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener un ID del grupo de equivalencias que incluya el ID dado

  • « IntlTimeZone::getDSTSavings
  • IntlTimeZone::getErrorCode »
  • PHP Manual
  • IntlTimeZone
  • Obtener un ID del grupo de equivalencias que incluya el ID dado

IntlTimeZone::getEquivalentID

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getEquivalentID — Obtener un ID del grupo de equivalencias que incluya el ID dado

Descripción

public static IntlTimeZone::getEquivalentID ( string $zoneId , integer $index ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

index

Valores devueltos


Obtener el último código de error del objeto

  • « IntlTimeZone::getEquivalentID
  • IntlTimeZone::getErrorMessage »
  • PHP Manual
  • IntlTimeZone
  • Obtener el último código de error del objeto

IntlTimeZone::getErrorCode

intltz_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getErrorCode -- intltz_get_error_code — Obtener el último código de error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlTimeZone::getErrorCode ( ) : integer

Estilo por procedimientos:

intltz_get_error_code ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el último mensaje de error del objeto

  • « IntlTimeZone::getErrorCode
  • IntlTimeZone::getGMT »
  • PHP Manual
  • IntlTimeZone
  • Obtener el último mensaje de error del objeto

IntlTimeZone::getErrorMessage

intltz_get_error_message

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getErrorMessage -- intltz_get_error_message — Obtener el último mensaje de error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlTimeZone::getErrorMessage ( ) : string

Estilo por procedimientos:

intltz_get_error_message ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Crear una zona horaria GMT (UTC)

  • « IntlTimeZone::getErrorMessage
  • IntlTimeZone::getID »
  • PHP Manual
  • IntlTimeZone
  • Crear una zona horaria GMT (UTC)

IntlTimeZone::getGMT

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getGMT — Crear una zona horaria GMT (UTC)

Descripción

public static IntlTimeZone::getGMT ( ) : IntlTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el ID de la zona horaria

  • « IntlTimeZone::getGMT
  • IntlTimeZone::getIDForWindowsID »
  • PHP Manual
  • IntlTimeZone
  • Obtener el ID de la zona horaria

IntlTimeZone::getID

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getID — Obtener el ID de la zona horaria

Descripción

public IntlTimeZone::getID ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Translate a Windows timezone into a system timezone

  • « IntlTimeZone::getID
  • IntlTimeZone::getOffset »
  • PHP Manual
  • IntlTimeZone
  • Translate a Windows timezone into a system timezone

IntlTimeZone::getIDForWindowsID

intltz_get_id_for_windows_id

(PHP 7 >= 7.1.0)

IntlTimeZone::getIDForWindowsID -- intltz_get_id_for_windows_id — Translate a Windows timezone into a system timezone

Descripción

Estilo orientado a objetos (method):

public static IntlTimeZone::getIDForWindowsID ( string $timezone , string $region = ? ) : string|false

Estilo por procedimientos:

intltz_get_id_for_windows_id ( string $timezone , string $region = ? ) : string|false

Translates a Windows timezone (e.g. "Pacific Standard Time") into a system timezone (e.g. "America/Los_Angeles").

Nota: This function requires ICU version = 52.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

timezone

region

Valores devueltos

Returns the system timezone o false en caso de error.

Ver también

  • IntlTimeZone::getWindowsID() - Translate a system timezone into a Windows timezone


Obtener la zona horaria sin tratar y el índice GMT para el momento dado

  • « IntlTimeZone::getIDForWindowsID
  • IntlTimeZone::getRawOffset »
  • PHP Manual
  • IntlTimeZone
  • Obtener la zona horaria sin tratar y el índice GMT para el momento dado

IntlTimeZone::getOffset

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getOffset — Obtener la zona horaria sin tratar y el índice GMT para el momento dado

Descripción

public IntlTimeZone::getOffset ( float $date , bool $local , integer &$rawOffset , integer &$dstOffset ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

date

local

rawOffset

dstOffset

Valores devueltos


Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)

  • « IntlTimeZone::getOffset
  • IntlTimeZone::getRegion »
  • PHP Manual
  • IntlTimeZone
  • Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)

IntlTimeZone::getRawOffset

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getRawOffset — Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)

Descripción

public IntlTimeZone::getRawOffset ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the region code associated with the given system time zone ID

  • « IntlTimeZone::getRawOffset
  • IntlTimeZone::getTZDataVersion »
  • PHP Manual
  • IntlTimeZone
  • Get the region code associated with the given system time zone ID

IntlTimeZone::getRegion

intltz_get_region

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::getRegion -- intltz_get_region — Get the region code associated with the given system time zone ID

Descripción

Estilo orientado a objetos (method):

public static IntlTimeZone::getRegion ( string $zoneId ) : string|false

Estilo por procedimientos:

intltz_get_region ( string $zoneId ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

zoneId

Valores devueltos

Return region o false en caso de error.


Obtener la versión de los datos de zonas horarias actualmente usada por ICU

  • « IntlTimeZone::getRegion
  • IntlTimeZone::getUnknown »
  • PHP Manual
  • IntlTimeZone
  • Obtener la versión de los datos de zonas horarias actualmente usada por ICU

IntlTimeZone::getTZDataVersion

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getTZDataVersion — Obtener la versión de los datos de zonas horarias actualmente usada por ICU

Descripción

public static IntlTimeZone::getTZDataVersion ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the "unknown" time zone

  • « IntlTimeZone::getTZDataVersion
  • IntlTimeZone::getWindowsID »
  • PHP Manual
  • IntlTimeZone
  • Get the "unknown" time zone

IntlTimeZone::getUnknown

intltz_get_unknown

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::getUnknown -- intltz_get_unknown — Get the "unknown" time zone

Descripción

Estilo orientado a objetos (method):

public static IntlTimeZone::getUnknown ( ) : IntlTimeZone

Estilo por procedimientos:

intltz_get_unknown ( ) : IntlTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns IntlTimeZone or null on failure.


Translate a system timezone into a Windows timezone

  • « IntlTimeZone::getUnknown
  • IntlTimeZone::hasSameRules »
  • PHP Manual
  • IntlTimeZone
  • Translate a system timezone into a Windows timezone

IntlTimeZone::getWindowsID

intltz_get_windows_id

(PHP 7 >= 7.1.0)

IntlTimeZone::getWindowsID -- intltz_get_windows_id — Translate a system timezone into a Windows timezone

Descripción

Estilo orientado a objetos (method):

public static IntlTimeZone::getWindowsID ( string $timezone ) : string|false

Estilo por procedimientos:

intltz_get_windows_id ( string $timezone ) : string|false

Translates a system timezone (e.g. "America/Los_Angeles") into a Windows timezone (e.g. "Pacific Standard Time").

Nota: This function requires ICU version = 52.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

timezone

Valores devueltos

Returns the Windows timezone o false en caso de error.

Ver también

  • IntlTimeZone::getIDForWindowsID() - Translate a Windows timezone into a system timezone


Comprobar si esta zona horaria tiene las mismas reglas e índices que otra

  • « IntlTimeZone::getWindowsID
  • IntlTimeZone::toDateTimeZone »
  • PHP Manual
  • IntlTimeZone
  • Comprobar si esta zona horaria tiene las mismas reglas e índices que otra

IntlTimeZone::hasSameRules

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::hasSameRules — Comprobar si esta zona horaria tiene las mismas reglas e índices que otra

Descripción

public IntlTimeZone::hasSameRules ( IntlTimeZone $otherTimeZone ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

otherTimeZone

Valores devueltos


Convertir a un objeto DateTimeZone

  • « IntlTimeZone::hasSameRules
  • IntlTimeZone::useDaylightTime »
  • PHP Manual
  • IntlTimeZone
  • Convertir a un objeto DateTimeZone

IntlTimeZone::toDateTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::toDateTimeZone — Convertir a un objeto DateTimeZone

Descripción

public IntlTimeZone::toDateTimeZone ( ) : DateTimeZone

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Comprobar si esta zona horaria utiliza el horario de verano

  • « IntlTimeZone::toDateTimeZone
  • IntlDateFormatter »
  • PHP Manual
  • IntlTimeZone
  • Comprobar si esta zona horaria utiliza el horario de verano

IntlTimeZone::useDaylightTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::useDaylightTime — Comprobar si esta zona horaria utiliza el horario de verano

Descripción

public IntlTimeZone::useDaylightTime ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase IntlDateFormatter

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Introducción

Date Formatter es una clase concreta que permite el formateo/procesamiento dependiente de la configuración regional de fechas utilizando cadenas de patrones y/o patrones enlatados.

Esta clase representa la funcionalidad de formateo de fechas de ICU. Permite a los usuarios mostrar fechas en un formato regional o convertir cadenas a valores de fecha de PHP utilizando cadenas de patrones y/o patrones enlatados.

Sinopsis de la clase

IntlDateFormatter {
/* Métodos */
public __construct ( string $locale , int $datetype , int $timetype , mixed $timezone = NULL , mixed $calendar = NULL , string $pattern = "" )
public static create ( string $locale , int $datetype , int $timetype , mixed $timezone = NULL , mixed $calendar = NULL , string $pattern = "" ) : IntlDateFormatter
public format ( mixed $value ) : string
public static formatObject ( object $object , mixed $format = NULL , string $locale = NULL ) : string
getCalendar ( ) : int
public getDateType ( ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( int $which = ? ) : string
public getPattern ( ) : string
public getTimeType ( ) : int
public getTimeZoneId ( ) : string
public getCalendarObject ( ) : IntlCalendar
public getTimeZone ( ) : IntlTimeZone
public isLenient ( ) : bool
public localtime ( string $value , int &$position = ? ) : array
public parse ( string $value , int &$position = ? ) : int
setCalendar ( mixed $which ) : bool
public setLenient ( bool $lenient ) : bool
public setPattern ( string $pattern ) : bool
public setTimeZone ( mixed $zone ) : boolean
}

Ver también

  • » Formatedor de fechas ICU
  • » Formatos de fecha de ICU

Constantes predefinidas

Estas constantes se usan para especificar diferentes formatos en el constructor de DateType y TimeType.

IntlDateFormatter::NONE (integer)
No incluir este elemento
IntlDateFormatter::FULL (integer)
Estilo completamente especificado (Tuesday, April 12, 1952 AD o 3:30:42pm PST)
IntlDateFormatter::LONG (integer)
Estilo largo (January 12, 1952 o 3:30:32pm)
IntlDateFormatter::MEDIUM (integer)
Estilo medio (Jan 12, 1952)
IntlDateFormatter::SHORT (integer)
El estilo más abreviado, sólo información esencial (12/13/52 or 3:30pm)

Las siguientes constantes se usan para especificar el calendario. Todos estos calendarios están basados directamente en el calendario gregoriano. Es necesario especificar en la configuración local los calendarios no gregorianos. Los ejemplos incluirían locale="hi@calendar=BUDDHIST".

IntlDateFormatter::TRADITIONAL (integer)
Calendario no greoriano
IntlDateFormatter::GREGORIAN (integer)
Calendario gregoriano

Tabla de contenidos

  • IntlDateFormatter::create — Crear un formateador de fechas
  • IntlDateFormatter::format — Formatear el valor fecha/hora como una cadena
  • IntlDateFormatter::formatObject — Formatea un objeto
  • IntlDateFormatter::getCalendar — Obtener el tipo de calendario usado por el objeto IntlDateFormatter
  • IntlDateFormatter::getDateType — Obtener el tipo de fecha usada por un formateador de IntlDateFormatter
  • IntlDateFormatter::getErrorCode — Obtener el código del error de la última operación
  • IntlDateFormatter::getErrorMessage — Obtener el texto del error de la última operación
  • IntlDateFormatter::getLocale — Obtener la configuración regional usada por un formateador
  • IntlDateFormatter::getPattern — Obtener el patrón utilizado por un formateador de IntlDateFormatter
  • IntlDateFormatter::getTimeType — Obtener el tipo de hora usada por un formateador de IntlDateFormatter
  • IntlDateFormatter::getTimeZoneId — Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter
  • IntlDateFormatter::getCalendarObject — Obtener una copia del objeto calendario del formateador
  • IntlDateFormatter::getTimeZone — Obtener la zona horaria del formateador
  • IntlDateFormatter::isLenient — Obtener la tolerancia usada por un formateador de IntlDateFormatter
  • IntlDateFormatter::localtime — Convertir una cadena en un valor de marca de tiempo basado en un campo
  • IntlDateFormatter::parse — Convertir una cadena en un valor de marca de tiempo
  • IntlDateFormatter::setCalendar — Establecer el tipo de calendario usado por el formateador
  • IntlDateFormatter::setLenient — Establecer la tolerancia del analizador
  • IntlDateFormatter::setPattern — Establecer el patrón utilizado por el formateador de IntlDateFormatter
  • IntlDateFormatter::setTimeZone — Establece la zona horaria del formateador


Crear un formateador de fechas

  • « IntlDateFormatter
  • IntlDateFormatter::format »
  • PHP Manual
  • IntlDateFormatter
  • Crear un formateador de fechas

IntlDateFormatter::create

datefmt_create

IntlDateFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::create -- datefmt_create -- IntlDateFormatter::__construct — Crear un formateador de fechas

Descripción

Estilo orientado a objetos

public static IntlDateFormatter::create ( string $locale , int $datetype , int $timetype , mixed $timezone = NULL , mixed $calendar = NULL , string $pattern = "" ) : IntlDateFormatter

Estilo orientado a objetos (constructor)

public IntlDateFormatter::__construct ( string $locale , int $datetype , int $timetype , mixed $timezone = NULL , mixed $calendar = NULL , string $pattern = "" )

Estilo por procedimientos

datefmt_create ( string $locale , int $datetype , int $timetype , mixed $timezone = NULL , mixed $calendar = NULL , string $pattern = "" ) : IntlDateFormatter

Crear un formateador de fechas.

Parámetros

locale

Configuración regional a usar al formatear o procesar, o null para usar el valor especificado en el ajuste ini intl.default_locale.

datetype

Tipo de fecha a usar (none, short, medium, long, full). Es una de las contantes de IntlDateFormatter. También puede ser null, en cuyo caso se usará el tipo de fecha predeterminado de ICU.

timetype

Tipo de hora a usar (none, short, medium, long, full). Es una de las contantes de IntlDateFormatter. También puede ser null, en cuyo caso se usará el tipo de hora predeterminado de ICU.

timezone

ID de la zona horaria. El predeterminado (y el usado si se proporciona null) es el devuelto por date_default_timezone_get() o, si es aplicable, aquel del objeto IntlCalendar pasado al parámetro calendar. Este ID debe ser un identificador válido en la base de datos de ICU o un ID que represente un índice explícito, como GMT-05:30.

También puede ser un objeto IntlTimeZone o DateTimeZone.

calendar

Calendario a usar al formatear o procesar. El valor predeteminado es null, el cual corresponde a IntlDateFormatter::GREGORIAN. También puede ser una de las constantes de calendario de IntlDateFormatter o un IntlCalendar. Cualquier objeto IntlCalendar pasado será clonado; no será cambiado por IntlDateFormatter. Esto determinará el tipo de calendario usado (gregoriano, islámico, persa, etc.) y, si se proporciona null al parámetro timezone, también la zona horaria usada.

pattern

Patrón opcional a usar al formatear o procesar. Los posibles patrones están documentados en » https://unicode-org.github.io/icu/userguide/format_parse/datetime/.

Valores devueltos

El IntlDateFormatter creado o false en caso de error.

Historial de cambios

Versión Descripción
5.5.0/PECL 3.0.0

Se permite un objeto IntlCalendar para calendar.

Los objetos de tipo IntlTimeZone y DateTimeZone están permitidos para timezone.

Los identificadores de zonas horarias válidos (incluyendo string vacíos) ya no están permitidos para timezone.

Si se proporciona null a timezone, el identificador de la zona horaria dado por date_default_timezone_get() se usará en lugar del predeterminado de ICU.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_create()

<?php
$fmt = datefmt_create( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles', IntlDateFormatter::GREGORIAN );
echo "La primera salida formateada es ".datefmt_format( $fmt , 0);
$fmt = datefmt_create( "es-ES", IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles', IntlDateFormatter::GREGORIAN );
echo "La segunda salida formateada es ".datefmt_format( $fmt , 0);

$fmt = datefmt_create( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles',IntlDateFormatter::GREGORIAN  ,"MM/dd/yyyy");
echo "La primera salida formateada con patrón es ".datefmt_format( $fmt , 0);
$fmt = datefmt_create( "es-ES", IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles', IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "La segunda salida formateada con patrón es ".datefmt_format( $fmt , 0);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles',IntlDateFormatter::GREGORIAN );
echo "La primera salida formateada es ".$fmt->format(0);
$fmt = new IntlDateFormatter( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles', IntlDateFormatter::GREGORIAN );
echo "La segunda salida formateada es ".$fmt->format(0);

$fmt = new IntlDateFormatter( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles',IntlDateFormatter::GREGORIAN  ,"MM/dd/yyyy");
echo "La primera salida formateada con patrón es ".$fmt->format(0);
$fmt = new IntlDateFormatter( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles', IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "La segunda salida formateada con patrón es ".$fmt->format(0);
?>

El resultado del ejemplo sería:

La primera salida formateada es Wednesday, December 31, 1969 4:00:00 PM PT
La segunda salida formateada es Mittwoch, 31. Dezember 1969 16:00 Uhr GMT-08:00
La primera salida formateada con patrón es 12/31/1969
La segunda salida formateada con patrón es 12/31/1969

Ver también

  • datefmt_format() - Formatear el valor fecha/hora como una cadena
  • datefmt_parse() - Convertir una cadena en un valor de marca de tiempo
  • datefmt_get_error_code() - Obtener el código del error de la última operación
  • datefmt_get_error_message() - Obtener el texto del error de la última operación


Formatear el valor fecha/hora como una cadena

  • « IntlDateFormatter::create
  • IntlDateFormatter::formatObject »
  • PHP Manual
  • IntlDateFormatter
  • Formatear el valor fecha/hora como una cadena

IntlDateFormatter::format

datefmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::format -- datefmt_format — Formatear el valor fecha/hora como una cadena

Descripción

Estilo orientado a objetos

public IntlDateFormatter::format ( mixed $value ) : string

Estilo por procedimientos

datefmt_format ( IntlDateFormatter $fmt , mixed $value ) : string

Formatea el valor del instante como una cadena.

Parámetros

fmt

El recurso del formateador de fechas.

value

El valor a formatear. Puede ser un objeto DateTime, un objeto IntlCalendar, un tipo numeric que representa un número (posiblemente fraccionario) de segundos desde la época o un array en el formato generado por localtime().

Si se proporciona un objeto DateTime o IntlCalendar, su zona horaria no se considera. El objeto será formateado usando la zona horaria configurada del formateador. Si se quiere usar la zona horaria del objeto a formatear, IntlDateFormatter::setTimeZone() debe ser invocado antes con la zona horaria del objeto. Alternativamente, la función estática IntlDateFormatter::formatObject() podría usarse en su lugar.

Valores devueltos

La cadena formateada o, si ocurrión un error, false.

Historial de cambios

Versión | Descripción
5.5.0/PECL 3.0.0 | Se añadió el soporta para proporcionar objetos IntlCalendar al parámetro value.
5.3.4 | Se añadió el soporte para proporcionar objetos de la clase DateTime al parámetro value.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_format()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La primera salida formateada es ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La segunda salida formateada es ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'La primera salida formateada con patrón es ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'La segunda salida formateada con patrón es ' . datefmt_format($fmt, 0);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La primera salida formateada es ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La segunda salida formateada es ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'La primera salida formateada con patrón es ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'La segunda salida formateada con patrón es ' . $fmt->format(0);
?>

El resultado del ejemplo sería:

La primera salida formateada es Wednesday, December 31, 1969 4:00:00 PM PT
La segunda salida formateada es miércoles 31 de diciembre de 1969 16H00'00" PST
La primera salida formateada con patrón es 12/31/1969
La segunda salida formateada con patrón es 31/12/1969

Ejemplo #3 Con un objeto IntlCalendar

<?php
$tz = reset(iterator_to_array(IntlTimeZone::createEnumeration('FR')));
$formatter = IntlDateFormatter::create(
    'fr_FR',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    $tz,
    IntlDateFormatter::GREGORIAN
);

$cal = IntlCalendar::createInstance($tz, '@calendar=islamic-civil');
$cal->set(IntlCalendar::FIELD_MONTH, 8); //9th month, Ramadan
$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 1); //1st day
$cal->clear(IntlCalendar::FIELD_HOUR_OF_DAY);
$cal->clear(IntlCalendar::FIELD_MINUTE);
$cal->clear(IntlCalendar::FIELD_SECOND);
$cal->clear(IntlCalendar::FIELD_MILLISECOND);

echo "En este año islámico, el Ramadan empezó/empezará el:\n\t",
        $formatter->format($cal), "\n";

//Es la zona hiraria del formateador la que se usa:
$formatter->setTimeZone('Asia/Tokyo');
echo "Después de cambiar la zona horaria:\n\t",
        $formatter->format($cal), "\n";

El resultado del ejemplo sería:

En este año islámico, el Ramadan empezó/empezará el:
    mardi 9 juillet 2013 19:00:00 heure avancée d’Europe centrale
Después de cambiar la zona horaria:
    mercredi 10 juillet 2013 02:00:00 heure normale du Japon

Ver también

  • datefmt_create() - Crear un formateador de fechas
  • datefmt_parse() - Convertir una cadena en un valor de marca de tiempo
  • datefmt_get_error_code() - Obtener el código del error de la última operación
  • datefmt_get_error_message() - Obtener el texto del error de la última operación
  • datefmt_format_object() - Formatea un objeto


Formatea un objeto

  • « IntlDateFormatter::format
  • IntlDateFormatter::getCalendar »
  • PHP Manual
  • IntlDateFormatter
  • Formatea un objeto

IntlDateFormatter::formatObject

datefmt_format_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::formatObject -- datefmt_format_object — Formatea un objeto

Descripción

Estilo orientado a objetos

public static IntlDateFormatter::formatObject ( object $object , mixed $format = NULL , string $locale = NULL ) : string

Estilo por procedimientos

public static datefmt_format_object ( object $object , mixed $format = NULL , string $locale = NULL ) : string

Esta función permite formatear un objeto IntlCalendar o DateTime sin crear primero explícitamente un objeto IntlDateFormatter.

El objeto IntlDateFormatter temporal que se creará tomará la zona horaria del objeto pasado. La base de datos de zonas horarias incluida con PHP no se usara; se usará en su lugar la de ICU. El identificador de zona horaria usado en objetos DateTime debe, por lo tanto, existir también en la base de datos de ICU.

Parámetros

object

Un objeto de tipo IntlCalendar o DateTime. Se usrará la información de la zona horaria del objeto.

format

Cómo formatear la fecha/hora. Puede ser un array con dos elementos (el primero el estilo de fecha, y luego el estilo de la hora, siendo ambos una de las constantes IntlDateFormatter::NONE, IntlDateFormatter::SHORT, IntlDateFormatter::MEDIUM, IntlDateFormatter::LONG, IntlDateFormatter::FULL), un long con el valor de una de estas constantes (en cuyo caso se usará tanto para la hora como para la fecha) o un string con el formato descrito en » la documentación de ICU. Si es null, se utilizará el estilo predeterminado.

locale

La configuración regional a usar, o null para usar la predeterminada.

Valores devueltos

Un string con resultados o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplos de IntlDateFormatter::formatObject()

<?php
/* la zona horaria predeterminada es irrelevante; se toma del objeto */
ini_set('date.timezone', 'UTC');
/* la configuración regional predeterminada se toma de este ajuste ini */
ini_set('intl.default_locale', 'fr_FR');

$cal = IntlCalendar::fromDateTime("2013-06-06 17:05:06 Europe/Dublin");
echo "predeterminado:\n\t",
        IntlDateFormatter::formatObject($cal),
        "\n";

echo "long \$format (full):\n\t",
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL),
        "\n";

echo "array \$format (none, full):\n\t",
        IntlDateFormatter::formatObject($cal, array(
                IntlDateFormatter::NONE,
                IntlDateFormatter::FULL)),
        "\n";

echo "string \$format (d 'of' MMMM y):\n\t",
        IntlDateFormatter::formatObject($cal, "d 'of' MMMM y", 'en_US'),
        "\n";

echo "con DateTime:\n\t",
        IntlDateFormatter::formatObject(
                new DateTime("2013-09-09 09:09:09 Europe/Madrid"),
                IntlDateFormatter::FULL,
                'es_ES'),
        "\n";

El resultado del ejemplo sería:

predeterminado:
    6 juin 2013 17:05:06
long $format (full):
    jeudi 6 juin 2013 17:05:06 heure d’été irlandaise
array $format (none, full):
    17:05:06 heure d’été irlandaise
string $format (d 'of' MMMM y):
    6 of June 2013
con DateTime:
    lunes, 9 de septiembre de 2013 09:09:09 Hora de verano de Europa central


Obtener el tipo de calendario usado por el objeto IntlDateFormatter

  • « IntlDateFormatter::formatObject
  • IntlDateFormatter::getDateType »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el tipo de calendario usado por el objeto IntlDateFormatter

IntlDateFormatter::getCalendar

datefmt_get_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getCalendar -- datefmt_get_calendar — Obtener el tipo de calendario usado por el objeto IntlDateFormatter

Descripción

Estilo orientado a objetos

IntlDateFormatter::getCalendar ( ) : int

Estilo por procedimientos

datefmt_get_calendar ( IntlDateFormatter $fmt ) : int

Parámetros

fmt

El recurso del formatedor

Valores devueltos

El tipo de calendario a usar por el formateador. IntlDateFormatter::TRADITIONAL o IntlDateFormatter::GREGORIAN.

Ejemplos

Ejemplo #1 Ejemlo de datefmt_get_calendar()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El calendario del formateador es : ' . datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt,IntlDateFormatter::TRADITIONAL);
echo 'Ahora el calendario del formateador es : ' . datefmt_get_calendar($fmt);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El calendario del formateador es : ' . $fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo 'Ahora el calendario del formateador es : ' . $fmt->getCalendar();

?>

El resultado del ejemplo sería:

El calendario del formateador es : 1
Ahora el calendario del formateador es  : 0

Ver también

  • datefmt_get_calendar_object() - Obtener una copia del objeto calendario del formateador
  • datefmt_set_calendar() - Establecer el tipo de calendario usado por el formateador
  • datefmt_create() - Crear un formateador de fechas


Obtener el tipo de fecha usada por un formateador de IntlDateFormatter

  • « IntlDateFormatter::getCalendar
  • IntlDateFormatter::getErrorCode »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el tipo de fecha usada por un formateador de IntlDateFormatter

IntlDateFormatter::getDateType

datefmt_get_datetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getDateType -- datefmt_get_datetype — Obtener el tipo de fecha usada por un formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getDateType ( ) : int

Estilo por procedimientos

datefmt_get_datetype ( IntlDateFormatter $fmt ) : int

Devuelve el tipo de fecha usada por el formateador.

Parámetros

fmt

El recurso del formatedor.

Valores devueltos

El valor actual del tipo de fecha del formateador.

Ejemplos

Ejemplo #1 Ejemlo de datefmt_get_datetype()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El tipo de fecha del formateador es : ' . datefmt_get_datetype($fmt);
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::SHORT,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Ahora el tipo de fecha del formateador es : ' . datefmt_get_datetype($fmt);
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El tipo de fecha del formateador es : ' . $fmt->getDateType();
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::SHORT,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Ahora el tipo de fecha del formateador es : ' . $fmt->getDateType();
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

El resultado del ejemplo sería:

El tipo de fecha del formateador es : 0
La primera salida formateada es Wednesday, December 31, 1969 4:00:00 PM PT
Ahora el tipo de fecha del formateador es : 2
La segunda salida formateada es 12/31/69 4:00:00 PM PT

Ver también

  • datefmt_get_timetype() - Obtener el tipo de hora usada por un formateador de IntlDateFormatter
  • datefmt_create() - Crear un formateador de fechas


Obtener el código del error de la última operación

  • « IntlDateFormatter::getDateType
  • IntlDateFormatter::getErrorMessage »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el código del error de la última operación

IntlDateFormatter::getErrorCode

datefmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorCode -- datefmt_get_error_code — Obtener el código del error de la última operación

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getErrorCode ( ) : int

Estilo por procedimientos

datefmt_get_error_code ( IntlDateFormatter $fmt ) : int

Obtiene el código del error de la última operación. Devuelve el código del error de la última operación de formatero de números.

Parámetros

fmt

El recurso del formateador.

Valores devueltos

El código del error, uno de los valores de UErrorCode. El valor inicial es U_ZERO_ERROR.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_error_code()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = datefmt_format($fmt);
if (!$str) {
    printf(
        "ERROR: %s (%d)\n",
        datefmt_get_error_message($fmt),
        datefmt_get_error_code($fmt)
    );
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = $fmt->format();
if (!$str) {
    printf(
        "ERROR: %s (%d)\n",
        $fmt->getErrorMessage(),
        $fmt->getErrorCode()
    );
}
?>

El resultado del ejemplo sería:

ERROR: U_ZERO_ERROR (0)

Ver también

  • datefmt_get_error_message() - Obtener el texto del error de la última operación
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener el texto del error de la última operación

  • « IntlDateFormatter::getErrorCode
  • IntlDateFormatter::getLocale »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el texto del error de la última operación

IntlDateFormatter::getErrorMessage

datefmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorMessage -- datefmt_get_error_message — Obtener el texto del error de la última operación

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getErrorMessage ( ) : string

Estilo por procedimientos

datefmt_get_error_message ( IntlDateFormatter $fmt ) : string

Obtiene el texto del error de la última operación.

Parámetros

fmt

El recurso del formateador.

Valores devueltos

La descripción del último error.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_error_message()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = datefmt_format($fmt);
if (!$str) {
    prtinf(
        "ERROR: %s (%d)\n",
        datefmt_get_error_message($fmt),
        datefmt_get_error_code($fmt)
    );
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = $fmt->format();
if(!$str) {
    prtinf(
        "ERROR: %s (%d)\n",
        $fmt->getErrorMessage(),
        $fmt->getErrorCode()
    );
}

?>

El resultado del ejemplo sería:

ERROR: U_ZERO_ERROR (0)

Ver también

  • datefmt_get_error_code() - Obtener el código del error de la última operación
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener la configuración regional usada por un formateador

  • « IntlDateFormatter::getErrorMessage
  • IntlDateFormatter::getPattern »
  • PHP Manual
  • IntlDateFormatter
  • Obtener la configuración regional usada por un formateador

IntlDateFormatter::getLocale

datefmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getLocale -- datefmt_get_locale — Obtener la configuración regional usada por un formateador

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getLocale ( int $which = ? ) : string

Estilo por procedimientos

datefmt_get_locale ( IntlDateFormatter $fmt , int $which = ? ) : string

Obtiene la configuración regional usada por el formateador.

Parámetros

fmt

El recurso del formatedor.

hich

Se puede elegir entre una configuración regional válida o real ( Locale::VALID_LOCALE, Locale::ACTUAL_LOCALE, respectivamente). La predeterminada el la configuración regional real.

Valores devueltos

La configuración regional de este formateador o 'false' en caso de error

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_locale()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La configuración regional del formateador es : ' . datefmt_get_locale($fmt);
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La configuración regional del formateador es : ' . datefmt_get_locale($fmt);
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La configuración regional del formateador es : ' . $fmt->getLocale();
echo 'La primera salida formateada es ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La configuración regional del formateador es : ' . $fmt->getLocale();
echo 'La segunda salida formateada es ' . $fmt->format(0);

?>

El resultado del ejemplo sería:

La configuración regional del formateador es : en
La primera salida formateada es Wednesday, December 31, 1969 4:00:00 PM PT
La configuración regional del formateador es : de
La segunda salida formateada es Mittwoch, 31. Dezember 1969 16:00 Uhr GMT-08:00

Ver también

  • datefmt_create() - Crear un formateador de fechas


Obtener el patrón utilizado por un formateador de IntlDateFormatter

  • « IntlDateFormatter::getLocale
  • IntlDateFormatter::getTimeType »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el patrón utilizado por un formateador de IntlDateFormatter

IntlDateFormatter::getPattern

datefmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getPattern -- datefmt_get_pattern — Obtener el patrón utilizado por un formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getPattern ( ) : string

Estilo por procedimientos

datefmt_get_pattern ( IntlDateFormatter $fmt ) : string

Obtener el patrón utilizado por el formateador.

Parámetros

fmt

El recurso del formatedor.

Valores devueltos

La cadena del patrón que está siendo usada para formatear/procesar.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_pattern()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'El patrón del formateador es : ' . datefmt_get_pattern($fmt);
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);
datefmt_set_pattern($fmt,'yyyymmdd hh:mm:ss z');
echo 'Ahora el patrón del formateador es : ' . datefmt_get_pattern($fmt);
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'El patrón del formateador es : ' . $fmt->getPattern();
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);
$fmt->setPattern('yyyymmdd hh:mm:ss z');
echo 'Now pattern of the formatter is : ' . $fmt->getPattern();
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);
?>

El resultado del ejemplo sería:

El patrón del formateador es : MM/dd/yyyy
La primera salida formateada es 12/31/1969
Ahora el patrón del formateador es : yyyymmdd hh:mm:ss z
La segunda salida formateada es 19690031 04:00:00 PST

Ver también

  • datefmt_set_pattern() - Establecer el patrón utilizado por el formateador de IntlDateFormatter
  • datefmt_create() - Crear un formateador de fechas


Obtener el tipo de hora usada por un formateador de IntlDateFormatter

  • « IntlDateFormatter::getPattern
  • IntlDateFormatter::getTimeZoneId »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el tipo de hora usada por un formateador de IntlDateFormatter

IntlDateFormatter::getTimeType

datefmt_get_timetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeType -- datefmt_get_timetype — Obtener el tipo de hora usada por un formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getTimeType ( ) : int

Estilo por procedimientos

datefmt_get_timetype ( IntlDateFormatter $fmt ) : int

Devuelve el tipo de hora usada por el formateador.

Parámetros

fmt

El recurso del formatedor.

Valores devueltos

El valor actual del tipo de fecha del formateador.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_timetype()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El tipo de hora del formateador es : ' . datefmt_get_timetype($fmt);
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::SHORT,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Ahora el tipo de hora del formateador es : ' . datefmt_get_timetype($fmt);
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'timetype of the formatter is : ' . $fmt->getTimeType();
echo 'La primera salida formateada es ' . datefmt_format( $fmt , 0);

$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::SHORT,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Ahora el tipo de hora del formateador es : ' . $fmt->getTimeType();
echo 'La segunda salida formateada es ' . datefmt_format( $fmt , 0);

?>

El resultado del ejemplo sería:

El tipo de hora del formateador es : 0
La primera salida formateada es Wednesday, December 31, 1969 4:00:00 PM PT
Ahora el tipo de hora del formateador es : 3
La segunda salida formateada es Wednesday, December 31, 1969 4:00 PM

Ver también

  • datefmt_get_datetype() - Obtener el tipo de fecha usada por un formateador de IntlDateFormatter
  • datefmt_create() - Crear un formateador de fechas


Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter

  • « IntlDateFormatter::getTimeType
  • IntlDateFormatter::getCalendarObject »
  • PHP Manual
  • IntlDateFormatter
  • Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter

IntlDateFormatter::getTimeZoneId

datefmt_get_timezone_id

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeZoneId -- datefmt_get_timezone_id — Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getTimeZoneId ( ) : string

Estilo por procedimientos

datefmt_get_timezone_id ( IntlDateFormatter $fmt ) : string

Obtiene el ID de la zona horario usada por un formateador de IntlDateFormatter.

Parámetros

fmt

El recurso del formatedor.

Valores devueltos

Una cadena con el ID de la zona horaria usada por este formateador.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_get_timezone_id()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El ID de la zona horaria del formateador es : ' . datefmt_get_timezone_id($fmt);
datefmt_set_timezone_id($fmt,'CN');
echo 'Ahora el ID de la zona horaria del formateador es : ' . datefmt_get_timezone_id($fmt);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El ID de la zona horaria del formateador es : ' . $fmt->getTimezoneId();
$fmt->setTimezoneId('CN');
echo 'Ahora el ID de la zona horaria del formateador es : ' . $fmt->getTimezoneId();

?>

El resultado del ejemplo sería:

El ID de la zona horaria del formateador es : America/Los_Angeles
Ahora el ID de la zona horaria del formateador es : CN

Ver también

  • datefmt_set_timezone_id()
  • datefmt_create() - Crear un formateador de fechas


Obtener una copia del objeto calendario del formateador

  • « IntlDateFormatter::getTimeZoneId
  • IntlDateFormatter::getTimeZone »
  • PHP Manual
  • IntlDateFormatter
  • Obtener una copia del objeto calendario del formateador

IntlDateFormatter::getCalendarObject

datefmt_get_calendar_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getCalendarObject -- datefmt_get_calendar_object — Obtener una copia del objeto calendario del formateador

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getCalendarObject ( ) : IntlCalendar

Estilo por procedimientos

datefmt_get_calendar_object ( ) : IntlCalendar

Obtiene una copia del objeto calendario usado internamente por este formateador. Este calendario tendrá un tipo (como gregorian, japanese, buddhist, roc, persian, islamic, etc.) y una zona horaria que coincide con el tipo y la zona horaria usada por el formateador. La fecha/hora del objeto está sin especificar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una copia del calendario interno usado por este formateador.

Ejemplos

Ejemplo #1 Ejemplo IntlDateFormatter::getCalendarObject()

<?php
$formatter = IntlDateFormatter::create(
    "fr_FR@calendar=islamic",
    NULL,
    NULL,
    "GMT-01:00",
    IntlDateFormatter::TRADITIONAL
);

$cal = $formatter->getCalendarObject();

var_dump(
    $cal->getType(),
    $cal->getTimeZone(),
    $cal->getLocale(Locale::VALID_LOCALE)
);

El resultado del ejemplo sería:

string(7) "islamic"
object(IntlTimeZone)#3 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(9) "GMT-01:00"
  ["rawOffset"]=>
  int(-3600000)
  ["currentOffset"]=>
  int(-3600000)
}
string(5) "fr_FR"

Ver también

  • IntlDateFormatter::getCalendar() - Obtener el tipo de calendario usado por el objeto IntlDateFormatter
  • IntlDateFormatter::setCalendar() - Establecer el tipo de calendario usado por el formateador
  • IntlCalendar


Obtener la zona horaria del formateador

  • « IntlDateFormatter::getCalendarObject
  • IntlDateFormatter::isLenient »
  • PHP Manual
  • IntlDateFormatter
  • Obtener la zona horaria del formateador

IntlDateFormatter::getTimeZone

datefmt_get_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getTimeZone -- datefmt_get_timezone — Obtener la zona horaria del formateador

Descripción

Estilo orientado a objetos

public IntlDateFormatter::getTimeZone ( ) : IntlTimeZone

Estilo por procedimientos

datefmt_get_timezone ( ) : IntlTimeZone

Devuelve un objeto IntlTimeZone que representa la zona horaria que usará este objeto para formatear las fechas y las horas. Al formatear objetos IntlCalendar y DateTime con este IntlDateFormatter, la zona horaria usada será la devuelta por este método, no la asociada con los objetos que se están formateando.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto IntlTimeZone asociado o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplos de IntlDateFormatter::getTimeZone()

<?php

$madrid = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Madrid');
$lisboa = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Lisbon');

var_dump($madrid->getTimezone());
echo $madrid->getTimezone()->getDisplayName(
        false, IntlTimeZone::DISPLAY_GENERIC_LOCATION, "en_US"), "\n";
echo $lisboa->getTimeZone()->getId(), "\n";
//El id también puede ser recuperado con ->getTimezoneId()
echo $lisboa->getTimeZoneId(), "\n";

El resultado del ejemplo sería:

object(IntlTimeZone)#4 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(13) "Europe/Madrid"
  ["rawOffset"]=>
  int(3600000)
  ["currentOffset"]=>
  int(7200000)
}
Spain Time
Europe/Lisbon
Europe/Lisbon

Ver también

  • IntlDateFormatter::getTimeZoneId() - Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter
  • IntlDateFormatter::setTimeZone() - Establece la zona horaria del formateador
  • IntlTimeZone


Obtener la tolerancia usada por un formateador de IntlDateFormatter

  • « IntlDateFormatter::getTimeZone
  • IntlDateFormatter::localtime »
  • PHP Manual
  • IntlDateFormatter
  • Obtener la tolerancia usada por un formateador de IntlDateFormatter

IntlDateFormatter::isLenient

datefmt_is_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::isLenient -- datefmt_is_lenient — Obtener la tolerancia usada por un formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::isLenient ( ) : bool

Estilo por procedimientos

datefmt_is_lenient ( IntlDateFormatter $fmt ) : bool

Comprueba si el analizador es estricto o tolerante al interpretar las entradas que no coinciden exactamente con el patrón.

Parámetros

fmt

El recurso del formatedor.

Valores devueltos

true si el analizador es tolerante, false si es estricto. Por omisión, el analizador es tolerante.

Ejemplos

Ejemplo #1 Ejmplo de datefmt_is_lenient()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/mm/yyyy'
);
echo 'La tolerancia del formateador es : ';
if ($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
datefmt_parse($fmt, '35/13/1971');
echo "\n Intentar realizar parse('35/13/1971').\nEl resultado es : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}
datefmt_set_lenient($fmt,false);
echo 'Ahora la toleranca del formateador es : ';
if ($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
datefmt_parse($fmt, '35/13/1971');
echo "\n Intentar realizar parse('35/13/1971').\nEl resultado es : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    "dd/mm/yyyy"
);
echo "La tolerancia del formateador es : ";
if($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
$fmt->parse('35/13/1971');
echo "\n Intentar realizar parse('35/13/1971'). El resultado es : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "El mensaje del error es : ".intl_get_error_message();
    echo "El código del error es : ".intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo 'Ahora la toleranca del formateador es : ';
if($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
$fmt->parse('35/13/1971');
echo "\n Intentar realizar parse('35/13/1971'). El resultado es : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "El mensaje del error es : ".intl_get_error_message();
    echo "El código del error es : ".intl_get_error_code();
}

?>

El resultado del ejemplo sería:

La tolerancia del formateador es : TRUE
Intentar realizar parse('35/13/1971').
El resultado es : -2147483
Ahora la toleranca del formateador es : FALSE
Intentar realizar parse('35/13/1971').
El resultado es :
El mensaje del error es : Date parsing failed: U_PARSE_ERROR
El código del error es : 9

Ver también

  • datefmt_set_lenient() - Establecer la tolerancia del analizador
  • datefmt_create() - Crear un formateador de fechas


Convertir una cadena en un valor de marca de tiempo basado en un campo

  • « IntlDateFormatter::isLenient
  • IntlDateFormatter::parse »
  • PHP Manual
  • IntlDateFormatter
  • Convertir una cadena en un valor de marca de tiempo basado en un campo

IntlDateFormatter::localtime

datefmt_localtime

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::localtime -- datefmt_localtime — Convertir una cadena en un valor de marca de tiempo basado en un campo

Descripción

Estilo orientado a objetos

public IntlDateFormatter::localtime ( string $value , int &$position = ? ) : array

Estilo por procedimientos

datefmt_localtime ( IntlDateFormatter $fmt , string $value , int &$position = ? ) : array

Convierte la cadena $value a un valor de instante basado en un campo (un array de varios campos),, empezando en la posición dada por $parse_pos y consumiendo tanto del valor de entrada como sea posible.

Parámetros

fmt

El recurso del formateador.

value

La cadena que convertir a un instante

position

La posición a la cual empezar la conversión de $value (basado en cero). Si no ocurre ningún error antes de que $value sea consumido, $parse_pos contendrá -1, de otro modo contendrá la posición en la que finaliza la conversión (ocurrido el error). Si $parse_pos > strlen($value), la conversión falla automáticamente.

Valores devueltos

Un array Localtime compatible array of integers : contains 24 hour clock value in tm_hour field

Ejemplos

Ejemplo #1 Ejemplo de datefmt_localtime()

<?php

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$array = datefmt_localtime($fmt, 'Wednesday, December 31, 1969 4:00:00 PM PT', 0);
echo 'La primera salida convertida es ';
if ($array) {
    foreach ($array as $clave => $valor) {
        echo "$clave : $valor , ";
    }
}

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$array = $fmt->localtime('Wednesday, December 31, 1969 4:00:00 PM PT', 0);
echo 'La primera salida convertida es ';
if ($array) {
    foreach ($array as $clave => $valor) {
        echo "$clave : $valor , ";
    }
}

?>

El resultado del ejemplo sería:

La primera salida convertida es tm_sec : 0 , tm_min : 0 , tm_hour : 16 , tm_year : 1969 ,
tm_mday : 31 , tm_wday : 4 , tm_yday : 365 , tm_mon : 11 , tm_isdst : 0 ,

Ver también

  • datefmt_create() - Crear un formateador de fechas
  • datefmt_format() - Formatear el valor fecha/hora como una cadena
  • datefmt_parse() - Convertir una cadena en un valor de marca de tiempo
  • datefmt_get_error_code() - Obtener el código del error de la última operación
  • datefmt_get_error_message() - Obtener el texto del error de la última operación


Convertir una cadena en un valor de marca de tiempo

  • « IntlDateFormatter::localtime
  • IntlDateFormatter::setCalendar »
  • PHP Manual
  • IntlDateFormatter
  • Convertir una cadena en un valor de marca de tiempo

IntlDateFormatter::parse

datefmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::parse -- datefmt_parse — Convertir una cadena en un valor de marca de tiempo

Descripción

Estilo orientado a objetos

public IntlDateFormatter::parse ( string $value , int &$position = ? ) : int

Estilo por procedimientos

datefmt_parse ( IntlDateFormatter $fmt , string $value , int &$position = ? ) : int

Convierte la cadena $value a un valor de marca de tiempo incremental, empezando en la posición dada por $parse_pos y consumiendo tanto del valor de entrada como sea posible.

Parámetros

fmt

El recurso del formateador

value

La cadena que convertir a un instante

position

La posición a la cual empezar la conversión de $value (basado en cero). Si no ocurre ningún error antes de que $value sea consumido, $parse_pos contendrá -1, de otro modo contendrá la posición en la que finaliza la conversión (ocurrido el error). Esta variable contendrá la posición final si la converión falla. Si $parse_pos > strlen($value), la conversión falla automáticamente.

Valores devueltos

El valor de la marca de tiempo, o false si el valor no se puede analizar.

Ejemplos

Ejemplo #1 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La primera salida convertida es ' . $fmt->parse('Wednesday, December 20, 1989 4:00:00 PM PT');
$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La segunda salida convertida es ' . $fmt->parse('Mittwoch, 20. Dezember 1989 16:00 Uhr GMT-08:00');
?>

Ejemplo #2 Ejemplo de datefmt_parse()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La primera salida convertida es ' . datefmt_parse($fmt, 'Wednesday, December 20, 1989 4:00:00 PM PT');
$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'La segunda salida convertida es ' . datefmt_parse($fmt, 'Mittwoch, 20. Dezember 1989 16:00 Uhr GMT-08:00');
?>

El resultado del ejemplo sería:

La primera salida convertida es 630201600
La segunda salida convertida es 630201600

Ver también

  • datefmt_create() - Crear un formateador de fechas
  • datefmt_format() - Formatear el valor fecha/hora como una cadena
  • datefmt_localtime() - Convertir una cadena en un valor de marca de tiempo basado en un campo
  • datefmt_get_error_code() - Obtener el código del error de la última operación
  • datefmt_get_error_message() - Obtener el texto del error de la última operación


Establecer el tipo de calendario usado por el formateador

  • « IntlDateFormatter::parse
  • IntlDateFormatter::setLenient »
  • PHP Manual
  • IntlDateFormatter
  • Establecer el tipo de calendario usado por el formateador

IntlDateFormatter::setCalendar

datefmt_set_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setCalendar -- datefmt_set_calendar — Establecer el tipo de calendario usado por el formateador

Descripción

Estilo orientado a objetos

IntlDateFormatter::setCalendar ( mixed $which ) : bool

Estilo por procedimientos

datefmt_set_calendar ( IntlDateFormatter $fmt , mixed $which ) : bool

Establece el calendario o el tipo de calendario usado por el formateador.

Parámetros

fmt

El recurso del formatedor

which

Puede ser: el tipo de calendario a usar (el predeterminado es IntlDateFormatter::GREGORIAN, el cual también se usa si se especifica null) o un objeto IntlCalendar.

Cualquier objeto IntlCalendar pasado será clonado; no se realizará ninguna modificación al objeto del argumento.

La zona horaria del formateador se mantendrá únicamente si no se pasa un objeto IntlCalendar, de otro modo la nuevo zona horaria será aquella del objeto pasado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0/PECL 3.0.0 | Ahora es posible pasar un objeto IntlCalendar.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_set_calendar()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El calendario del formateador es : ' . datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt,IntlDateFormatter::TRADITIONAL);
echo 'Ahora el calendario del formateador es : ' . datefmt_get_calendar($fmt);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'El calendario del formateador es : ' . $fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo 'Ahora el calendario del formateador es : ' . $fmt->getCalendar();
?>

El resultado del ejemplo sería:

El calendario del formateador es : 1
Ahora el calendario del formateador es : 0

Ejemplo #3 Ejemplo con el argumento IntlCalendar

<?php
$time = strtotime("2013-03-03 00:00:00 UTC");
$formatter = IntlDateFormatter::create("en_US", NULL, NULL, "Europe/Amsterdam");

echo "antes:   ", $formatter->format($time), "\n";

/* note that the calendar's locale is not used! */
$formatter->setCalendar(IntlCalendar::createInstance(
               "America/New_York", "pt_PT@calendar=islamic"));

echo "después: ", $formatter->format($time), "\n";

El resultado del ejemplo sería:

antes:   Sunday, March 3, 2013 at 1:00:00 AM Central European Standard Time
después: Saturday, Rabi? II 20, 1434 at 7:00:00 PM Eastern Standard Time

Ver también

  • datefmt_get_calendar() - Obtener el tipo de calendario usado por el objeto IntlDateFormatter
  • datefmt_get_calendar_object() - Obtener una copia del objeto calendario del formateador
  • datefmt_create() - Crear un formateador de fechas


Establecer la tolerancia del analizador

  • « IntlDateFormatter::setCalendar
  • IntlDateFormatter::setPattern »
  • PHP Manual
  • IntlDateFormatter
  • Establecer la tolerancia del analizador

IntlDateFormatter::setLenient

datefmt_set_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setLenient -- datefmt_set_lenient — Establecer la tolerancia del analizador

Descripción

Estilo orientado a objetos

public IntlDateFormatter::setLenient ( bool $lenient ) : bool

Estilo por procedimientos

datefmt_set_lenient ( IntlDateFormatter $fmt , bool $lenient ) : bool

Define si el analizador es estricto o tolerante al interpretar salidas que no coinciden exactamente con el patrón. Habilitar el análisis tolerante permite al analizador aceptar patrones de fecha u hora defectuosos, procesando lo más posible para obtener un valor. No se aceptan los espacios extra, tokens no reconocidos, o valores no válidos ("30 de febrero").

Parámetros

fmt

El recurso del formatedor.

lenient

Establecer si el analizador es tolerante o no, por defecto es false (tolerante).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_set_lenient()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/MM/yyyy'
);
echo 'La tolerancia del formateador es : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
datefmt_parse($fmt, '35/13/1971');
echo '\n Intentar realizar parse('35/13/1971').\nEl resultado es : ' . datefmt_parse($fmt, '35/13/1971');
if( intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}
datefmt_set_lenient($fmt,false);
echo "\nAhora la toleranca del formateador es : ";
if ($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
datefmt_parse($fmt,"35/13/1971");
echo "\n Intentar realizar parse('35/13/1971').\nEl resultado es : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/MM/yyyy'
);
echo La tolerancia del formateador es : ';
if ($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
$fmt->parse("35/13/1971");
echo "\n Intentar realizar parse('35/13/1971').\nEl resultado es : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo '\nAhora la toleranca del formateador es : ';
if ($fmt->isLenient() ){
    echo('TRUE');
} else{
    echo('FALSE');
}
$fmt->parse("35/13/1971");
echo "\n Intentar realizar parse('35/13/1971').\nEl resultado es : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() !=0 ){
    echo "\nEl mensaje del error es : ".intl_get_error_message();
    echo "\nEl código del error es : ".intl_get_error_code();
}

?>

El resultado del ejemplo sería:

La tolerancia del formateador es : TRUE
Intentar realizar parse('35/13/1971').
El resultado es : 66038400
Ahora la toleranca del formateador es : FALSE
Intentar realizar parse('35/13/1971').
El resultado es :
El mensaje del error es : Date parsing failed: U_PARSE_ERROR
El código del error es : 9

Ver también

  • datefmt_is_lenient() - Obtener la tolerancia usada por un formateador de IntlDateFormatter
  • datefmt_create() - Crear un formateador de fechas


Establecer el patrón utilizado por el formateador de IntlDateFormatter

  • « IntlDateFormatter::setLenient
  • IntlDateFormatter::setTimeZone »
  • PHP Manual
  • IntlDateFormatter
  • Establecer el patrón utilizado por el formateador de IntlDateFormatter

IntlDateFormatter::setPattern

datefmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setPattern -- datefmt_set_pattern — Establecer el patrón utilizado por el formateador de IntlDateFormatter

Descripción

Estilo orientado a objetos

public IntlDateFormatter::setPattern ( string $pattern ) : bool

Estilo por procedimientos

datefmt_set_pattern ( IntlDateFormatter $fmt , string $pattern ) : bool

Establece el patrón utilizado por el formateador de IntlDateFormatter.

Parámetros

fmt

El recurso del formatedor.

pattern

La nueva cadena de patrón a usar. Los patrones posibles están documentados es » https://unicode-org.github.io/icu/userguide/format_parse/datetime/.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Las cadenas mal formateadas son normalmente la causa del fallo.

Ejemplos

Ejemplo #1 Ejemplo de datefmt_set_pattern()

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'El patrón del formateador es : ' . datefmt_get_pattern($fmt);
echo 'La primera salida con patrón es ' . datefmt_format( $fmt , 0);
datefmt_set_pattern($fmt,'yyyymmdd hh:mm:ss z');
echo 'Ahora el patrón del formateador es : ' . datefmt_get_pattern($fmt);
echo 'La segunda salida con patrón es ' . datefmt_format( $fmt , 0);

?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'El patrón del formateador es : ' . $fmt->getPattern();
echo 'La primera salida con patrón es ' .datefmt_format( $fmt , 0);
$fmt->setPattern('yyyymmdd hh:mm:ss z');
echo 'Ahora el patrón del formateador es : ' . $fmt->getPattern();
echo 'La segunda salida con patrón es ' . datefmt_format( $fmt , 0);

?>

El resultado del ejemplo sería:

El patrón del formateador es : MM/dd/yyyy
First Formatted output with pattern is 12/31/1969
Ahora el patrón del formateador es : yyyymmdd hh:mm:ss z
La segunda salida con patrón es 19690031 04:00:00 PST

Ver también

  • datefmt_get_pattern() - Obtener el patrón utilizado por un formateador de IntlDateFormatter
  • datefmt_create() - Crear un formateador de fechas


Establece la zona horaria del formateador

  • « IntlDateFormatter::setPattern
  • ResourceBundle »
  • PHP Manual
  • IntlDateFormatter
  • Establece la zona horaria del formateador

IntlDateFormatter::setTimeZone

datefmt_set_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::setTimeZone -- datefmt_set_timezone — Establece la zona horaria del formateador

Descripción

Estilo orientado a objetos

public IntlDateFormatter::setTimeZone ( mixed $zone ) : boolean

Estilo por procedimientos

datefmt_set_timezone ( mixed $zone ) : boolean

Establece la zona horaria que se usará al formatear fechas u horas con este objeto.

Parámetros

zone

La zona horaria a usar para este formateador. Puede ser especificada en las siguientes formas:

  • null, en cuyo caso se usará la zona horaria predeterminada, tal como está especificada en el ajuste ini date.timezone o a través de la función date_default_timezone_set() y como es devuelto por date_default_timezone_get().

  • Un IntlTimeZone, que se usará directamente.

  • Un DateTimeZone. Su identificador será extraido y se creará un objeto de zona horaria de ICU; la zona horaria será proporcionada por la base de datos de ICU, no por la de PHP.

  • Un string, que debería ser un identificador de zona horaria de ICU válido. Véase IntlTimeZone::createTimeZoneIDEnumeration(). Los índices puros como "GMT+08:30" también se aceptan.

Valores devueltos

Devuelve true en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplos de IntlDateFormatter::setTimeZone()

<?php
ini_set('date.timezone', 'Europe/Amsterdam');

$formatter = IntlDateFormatter::create(NULL, NULL, NULL, "UTC");

$formatter->setTimeZone(NULL);
echo "NULL\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(IntlTimeZone::createTimeZone('Europe/Lisbon'));
echo "IntlTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(new DateTimeZone('Europe/Paris'));
echo "DateTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('Europe/Rome');
echo "String\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('GMT+00:30');
print_r($formatter->getTimeZone());

El resultado del ejemplo sería:

NULL
    Europe/Amsterdam
IntlTimeZone
    Europe/Lisbon
DateTimeZone
    Europe/Paris
String
    Europe/Rome
IntlTimeZone Object
(
    [valid] => 1
    [id] => GMT+00:30
    [rawOffset] => 1800000
    [currentOffset] => 1800000
)

Ver también

  • IntlDateFormatter::getTimeZone() - Obtener la zona horaria del formateador


La clase ResourceBundle

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

Introducción

Los productos de software regionalizados a menudo requieren conjuntos de datos que necesitan ser personalizados dependiendo de la configuración regional actual, p.ej: mensajes, etiquetas, patrones de formateo. El mecanismo de recursos de ICU permite definir conjuntos de recursos que la aplicación puede cargar basándose en la configuración regional, mientras que accede a ellos de una manera unificada independiente de la configuración regional.

Esta clase implementa el acceso a los ficheros de datos de recursos de ICU. Estos ficheros son arrays de información binaria que ICU utiliza para almacenar la información regional.

El paquete de recursos de ICU puede contener recursos simples y recursos complejos. Los recursos complejos son contenedores que pueden tener sus índices de tipo into o string (al igual que los arrays de PHP). Los recursos simples pueden ser de los siguientes tipos: string, integer, campos de datos binarios o array de enteros

ResourceBundle soporta el acceso directo a la información a través de patrones de acceso al array, y la iteración mediante foreach, así como el acceso mediante métodos de clase. El resultado será un valor de PHP para recursos simples y un objeto ResourceBundle para los complejos. Todos los recursos son de sólo lectura.

Sinopsis de la Clase

ResourceBundle {
/* Métodos */
public __construct ( string $locale , string $bundlename , bool $fallback = ? )
public count ( ) : int
public static create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public get ( string|int $index ) : mixed
public getLocales ( string $bundlename ) : array
}

Ver también

  • » Gestor de recursos de ICU
  • » Datos de ICU

Tabla de contenidos

  • ResourceBundle::count — Obtener el número de elementos de un paquete
  • ResourceBundle::create — Crear un paquete de recursos
  • ResourceBundle::getErrorCode — Obtener el códido del último error del paquete
  • ResourceBundle::getErrorMessage — Obtener el mensaje del último error del paquete
  • ResourceBundle::get — Obtener datos de un paquete
  • ResourceBundle::getLocales — Obtener las configuraciones regionales soportadas


Obtener el número de elementos de un paquete

  • « ResourceBundle
  • ResourceBundle::create »
  • PHP Manual
  • ResourceBundle
  • Obtener el número de elementos de un paquete

ResourceBundle::count

resourcebundle_count

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::count -- resourcebundle_count — Obtener el número de elementos de un paquete

Descripción

Estilo orientado a objetos

public ResourceBundle::count ( ) : int

Estilo por procedimientos

resourcebundle_count ( ResourceBundle $r ) : int

Obtiene el número de elementos de un paquete.

Parámetros

r

Un objeto de la clase ResourceBundle.

Valores devueltos

Devuelve el número de elementos de un paquete.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_count()

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo resourcebundle_count($r);
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r->count();
?>

El resultado del ejemplo sería:

42

Ver también

  • resourcebundle_get() - Obtener datos de un paquete


Crear un paquete de recursos

  • « ResourceBundle::count
  • ResourceBundle::getErrorCode »
  • PHP Manual
  • ResourceBundle
  • Crear un paquete de recursos

ResourceBundle::create

resourcebundle_create

ResourceBundle::__construct

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::create -- resourcebundle_create -- ResourceBundle::__construct — Crear un paquete de recursos

Descripción

Estilo orientado a objetos (método)

public static ResourceBundle::create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle

Estilo por procedimientos

resourcebundle_create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle

Estilo orientado a objetos (constructor)

public ResourceBundle::__construct ( string $locale , string $bundlename , bool $fallback = ? )

Crea un paquete de recursos.

Parámetros

locale

La configuración regional para la cual los recursos deberían ser cargados (nombre de la configuración regional, p.ej. en_CA).

bundlename

El directorio donde es almacenada la información o el nombre del fichero .dat.

fallback

Si la configuración debería coincidir exactamente o si está permitido volver a la configuración regional madre.

Valores devueltos

Devuelve un objeto de la clase ResourceBundle o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_create()

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['teststring'];
?>

Ejemplo #2 Ejemplo de ResourceBundle::create()

<?php
$r = ResourceBundle::create( 'es', "/usr/share/data/myapp");
echo $r['teststring'];
?>

El resultado del ejemplo sería:

¡Hola, mundo!

Ver también

  • resourcebundle_get() - Obtener datos de un paquete


Obtener el códido del último error del paquete

  • « ResourceBundle::create
  • ResourceBundle::getErrorMessage »
  • PHP Manual
  • ResourceBundle
  • Obtener el códido del último error del paquete

ResourceBundle::getErrorCode

resourcebundle_get_error_code

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getErrorCode -- resourcebundle_get_error_code — Obtener el códido del último error del paquete

Descripción

Estilo orientado a objetos

public ResourceBundle::getErrorCode ( ) : int

Estilo por procedimientos

resourcebundle_get_error_code ( ResourceBundle $r ) : int

Obtiene el código del error de la última función realizada por el objeto paquete.

Parámetros

r

Un objeto de la clase ResourceBundle.

Valores devueltos

Devuelve el código del error de la última llamada del objeto paquete.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_get_error_code()

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(resourcebundle_get_error_code($r))) {
    report_error("Error de paquete");
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(ResourceBundle::getErrorCode($r))) {
    report_error("Error de paquete");
}
?>

Ver también

  • resourcebundle_get_error_message() - Obtener el mensaje del último error del paquete
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener el mensaje del último error del paquete

  • « ResourceBundle::getErrorCode
  • ResourceBundle::get »
  • PHP Manual
  • ResourceBundle
  • Obtener el mensaje del último error del paquete

ResourceBundle::getErrorMessage

resourcebundle_get_error_message

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getErrorMessage -- resourcebundle_get_error_message — Obtener el mensaje del último error del paquete

Descripción

Estilo orientado a objetos

public ResourceBundle::getErrorMessage ( ) : string

Estilo por procedimientos

resourcebundle_get_error_message ( ResourceBundle $r ) : string

Obtiene el mensaje del error de la última función realizada por el objeto paquete.

Parámetros

r

Un objeto de la clase ResourceBundle.

Valores devueltos

Devuelve el mensaje del error de la última llamada del objeto paquete.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_get_error_message()

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(resourcebundle_get_error_code($r))) {
    report_error("Error de paquete: ".resourcebundle_get_error_message($r));
}
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(ResourceBundle::getErrorCode($r))) {
    report_error("Error de paquete: ".ResourceBundle::getErrorMessage($r));
}
?>

Ver también

  • resourcebundle_get_error_code() - Obtener el códido del último error del paquete
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo


Obtener datos de un paquete

  • « ResourceBundle::getErrorMessage
  • ResourceBundle::getLocales »
  • PHP Manual
  • ResourceBundle
  • Obtener datos de un paquete

ResourceBundle::get

resourcebundle_get

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::get -- resourcebundle_get — Obtener datos de un paquete

Descripción

Estilo orientado a objetos

public ResourceBundle::get ( string|int $index ) : mixed

Estilo por procedimientos

resourcebundle_get ( ResourceBundle $r , string|int $index ) : mixed

Obtiene los datos de un paquete mediante claves de índice o cadena.

Parámetros

r

Un objeto de la clase ResourceBundle.

index

Índice del dato, debe ser de tipo string o integer.

Valores devueltos

Devuelve los datos ubicados en el índice o null en caso de error. Las cadenas, enteros y cadenas de datos binarios son devueltas como su tipo correspondiente en PHP, los array de enteros son devueltos como arrays de PHP. Los tipos complejos son devueltos como objetos de la clase ResourceBundle.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_get()

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo resourcebundle_get($r, 'somestring');
?>

Ejemplo #2 Ejemplo orientado a objetos

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r->get('somestring');
?>

El resultado del ejemplo sería:

?Hola, mundo!

Ver también

  • resourcebundle_count() - Obtener el número de elementos de un paquete


Obtener las configuraciones regionales soportadas

  • « ResourceBundle::get
  • Spoofchecker »
  • PHP Manual
  • ResourceBundle
  • Obtener las configuraciones regionales soportadas

ResourceBundle::getLocales

resourcebundle_locales

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getLocales -- resourcebundle_locales — Obtener las configuraciones regionales soportadas

Descripción

Estilo orientado a objetos

public ResourceBundle::getLocales ( string $bundlename ) : array

Estilo por procedimientos

resourcebundle_locales ( string $bundlename ) : array

Obtiene las configuraciones regionales disponibles desde el nombre de ResourceBundle.

Parámetros

bundlename

La ruta del ResourceBundle del que obtener las configuraciones regionales disponibles, o una cadena vacía para la lista de configuraciones regionales predeterminadas.

Valores devueltos

Devuelve la lista de las configuraciones regionales soportadas por el paquete.

Ejemplos

Ejemplo #1 Ejemplo de resourcebundle_locales()

<?php
$bundle = "/user/share/data/myapp";
echo join(PHP_EOL, resourcebundle_locales($bundle));
?>

El resultado del ejemplo sería algo similar a:

es
root

Ejemplo #2 Ejemplo orientado a objetos

<?php
$bundle = "/usr/share/data/myapp";
$r = new ResourceBundle( 'es', $bundle);
echo join("\n", $r->getLocales($bundle));
?>

El resultado del ejemplo sería algo similar a:

es
root

Ver también

  • resourcebundle_get() - Obtener datos de un paquete


La clase Spoofchecker

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Introducción

Sinopsis de la Clase

Spoofchecker {
/* Constantes */
const integer SINGLE_SCRIPT_CONFUSABLE = 1 ;
const integer MIXED_SCRIPT_CONFUSABLE = 2 ;
const integer WHOLE_SCRIPT_CONFUSABLE = 4 ;
const integer ANY_CASE = 8 ;
const integer SINGLE_SCRIPT = 16 ;
const integer INVISIBLE = 32 ;
const integer CHAR_LIMIT = 64 ;
/* Métodos */
public areConfusable ( string $s1 , string $s2 , string &$error = ? ) : bool
public __construct ( )
public isSuspicious ( string $text , string &$error = ? ) : bool
public setAllowedLocales ( string $locale_list ) : void
public setChecks ( long $checks ) : void
}

Constantes predefinidas

Spoofchecker::SINGLE_SCRIPT_CONFUSABLE

Spoofchecker::MIXED_SCRIPT_CONFUSABLE

Spoofchecker::WHOLE_SCRIPT_CONFUSABLE

Spoofchecker::ANY_CASE

Spoofchecker::SINGLE_SCRIPT

Spoofchecker::INVISIBLE

Spoofchecker::CHAR_LIMIT

Tabla de contenidos

  • Spoofchecker::areConfusable — Comprobar si un texto dado contiene carateres que pueden ser confusos
  • Spoofchecker::__construct — Constructor
  • Spoofchecker::isSuspicious — Comprobar si un texto dad contiene caracteres sospechosos
  • Spoofchecker::setAllowedLocales — Las configuraciones regionales a usar cuando se ejecutan las comprobaciones
  • Spoofchecker::setChecks — Establecer las comprobaciones a ejecutar


Comprobar si un texto dado contiene carateres que pueden ser confusos

  • « Spoofchecker
  • Spoofchecker::__construct »
  • PHP Manual
  • Spoofchecker
  • Comprobar si un texto dado contiene carateres que pueden ser confusos

Spoofchecker::areConfusable

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::areConfusable — Comprobar si un texto dado contiene carateres que pueden ser confusos

Descripción

public Spoofchecker::areConfusable ( string $s1 , string $s2 , string &$error = ? ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

s1

s2

error

Valores devueltos


Constructor

  • « Spoofchecker::areConfusable
  • Spoofchecker::isSuspicious »
  • PHP Manual
  • Spoofchecker
  • Constructor

Spoofchecker::__construct

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::__construct — Constructor

Descripción

public Spoofchecker::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Comprobar si un texto dad contiene caracteres sospechosos

  • « Spoofchecker::__construct
  • Spoofchecker::setAllowedLocales »
  • PHP Manual
  • Spoofchecker
  • Comprobar si un texto dad contiene caracteres sospechosos

Spoofchecker::isSuspicious

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::isSuspicious — Comprobar si un texto dad contiene caracteres sospechosos

Descripción

public Spoofchecker::isSuspicious ( string $text , string &$error = ? ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

text

error

Valores devueltos


Las configuraciones regionales a usar cuando se ejecutan las comprobaciones

  • « Spoofchecker::isSuspicious
  • Spoofchecker::setChecks »
  • PHP Manual
  • Spoofchecker
  • Las configuraciones regionales a usar cuando se ejecutan las comprobaciones

Spoofchecker::setAllowedLocales

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::setAllowedLocales — Las configuraciones regionales a usar cuando se ejecutan las comprobaciones

Descripción

public Spoofchecker::setAllowedLocales ( string $locale_list ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

locale_list

Valores devueltos


Establecer las comprobaciones a ejecutar

  • « Spoofchecker::setAllowedLocales
  • Transliterator »
  • PHP Manual
  • Spoofchecker
  • Establecer las comprobaciones a ejecutar

Spoofchecker::setChecks

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::setChecks — Establecer las comprobaciones a ejecutar

Descripción

public Spoofchecker::setChecks ( long $checks ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

checks

Valores devueltos


La clase Transliterator

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Introducción

La clase Transliterator proporciona transliteraciones de cadenas.

Sinopsis de la Clase

Transliterator {
/* Constantes */
const integer FORWARD = 0 ;
const integer REVERSE = 1 ;
/* Propiedades */
public $id ;
/* Métodos */
__construct ( )
public static create ( string $id , int $direction = ? ) : Transliterator
public static createFromRules ( string $rules , string $direction = ? ) : Transliterator
public createInverse ( ) : Transliterator
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public static listIDs ( ) : array
public transliterate ( string $subject , int $start = ? , int $end = ? ) : string
}

Propiedades

id

Constantes predefinidas

Transliterator::FORWARD

Transliterator::REVERSE

Tabla de contenidos

  • Transliterator::__construct — Constructor privado para denegar la instanciación
  • Transliterator::create — Crear un transliterador
  • Transliterator::createFromRules — Crear un transliterador desdes normas
  • Transliterator::createInverse — Cerar una transliteración inversa
  • Transliterator::getErrorCode — Obtener el código del último error
  • Transliterator::getErrorMessage — Obtener el mensaje del último error
  • Transliterator::listIDs — Obtener los IDs de los transliterardores
  • Transliterator::transliterate — Transliterar una cadena


Constructor privado para denegar la instanciación

  • « Transliterator
  • Transliterator::create »
  • PHP Manual
  • Transliterator
  • Constructor privado para denegar la instanciación

Transliterator::__construct

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::__construct — Constructor privado para denegar la instanciación

Descripción

Transliterator::__construct ( )

Este método no debería ser llamada. Su único propósito es denegar la instanciación con el operador new.

En su lugar use los métodos de fábrica Transliterator::create() o Transliterator::createFromRules().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este método no debería ser ejecutado. Si lo es (p.ej. a través de reflexión), devuelve un valor no especificado.

Ver también

  • Transliterator::create() - Crear un transliterador
  • Transliterator::createFromRules() - Crear un transliterador desdes normas


Crear un transliterador

  • « Transliterator::__construct
  • Transliterator::createFromRules »
  • PHP Manual
  • Transliterator
  • Crear un transliterador

Transliterator::create

transliterator_create

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::create -- transliterator_create — Crear un transliterador

Descripción

Estilo orientado a objetos

public static Transliterator::create ( string $id , int $direction = ? ) : Transliterator

Estilo por procedimientos

transliterator_create ( string $id , int $direction = ? ) : Transliterator

Abrir un transliterador mediante su ID.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

id

El identificador.

direction

La dirección, por defecto es >Transliterator::FORWARD. También se puede establecer a Transliterator::REVERSE.

Valores devueltos

Devuelve un objeto de la clase Transliterator en caso de éxito, o null en caso de error.

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::__construct() - Constructor privado para denegar la instanciación


Crear un transliterador desdes normas

  • « Transliterator::create
  • Transliterator::createInverse »
  • PHP Manual
  • Transliterator
  • Crear un transliterador desdes normas

Transliterator::createFromRules

transliterator_create_from_rules

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::createFromRules -- transliterator_create_from_rules — Crear un transliterador desdes normas

Descripción

Estilo orientado a objetos

public static Transliterator::createFromRules ( string $rules , string $direction = ? ) : Transliterator

Estilo por procedimientos

transliterator_create_from_rules ( string $id , int $direction = ? ) : Transliterator

Crea un transliterador desdes normas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

rules

Las normas.

direction

La dirección, por defecto es >Transliterator::FORWARD. También se puede establecer a Transliterator::REVERSE.

Valores devueltos

Devuelve un objeto de la clase Transliterator en caso de éxito, o null en caso de error.

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::create() - Crear un transliterador


Cerar una transliteración inversa

  • « Transliterator::createFromRules
  • Transliterator::getErrorCode »
  • PHP Manual
  • Transliterator
  • Cerar una transliteración inversa

Transliterator::createInverse

transliterator_create_inverse

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::createInverse -- transliterator_create_inverse — Cerar una transliteración inversa

Descripción

Estilo orientado a objetos

public Transliterator::createInverse ( ) : Transliterator

Estilo por procedimientos

transliterator_create_inverse ( ) : Transliterator

Abre el transliterador inverso.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto de la clase Transliterator en caso de éxito, o null en caso de error

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::create() - Crear un transliterador


Obtener el código del último error

  • « Transliterator::createInverse
  • Transliterator::getErrorMessage »
  • PHP Manual
  • Transliterator
  • Obtener el código del último error

Transliterator::getErrorCode

transliterator_get_error_code

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::getErrorCode -- transliterator_get_error_code — Obtener el código del último error

Descripción

Estilo orientado a objetos

public Transliterator::getErrorCode ( ) : int

Estilo por procedimientos

transliterator_get_error_code ( ) : int

Obtiene el código del último error de este transliterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El código del error en caso de éxito, o false si no existe o en caso de error.

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::listIDs() - Obtener los IDs de los transliterardores


Obtener el mensaje del último error

  • « Transliterator::getErrorCode
  • Transliterator::listIDs »
  • PHP Manual
  • Transliterator
  • Obtener el mensaje del último error

Transliterator::getErrorMessage

transliterator_get_error_message

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::getErrorMessage -- transliterator_get_error_message — Obtener el mensaje del último error

Descripción

Estilo orientado a objetos

public Transliterator::getErrorMessage ( ) : string

Estilo por procedimientos

transliterator_get_error_message ( ) : string

Obtiene el mensaje del último error para este transliterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El código del error en caso de éxito, o false si no existe o en caso de error.

Ver también

  • Transliterator::getErrorCode() - Obtener el código del último error
  • Transliterator::listIDs() - Obtener los IDs de los transliterardores


Obtener los IDs de los transliterardores

  • « Transliterator::getErrorMessage
  • Transliterator::transliterate »
  • PHP Manual
  • Transliterator
  • Obtener los IDs de los transliterardores

Transliterator::listIDs

transliterator_list_ids

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::listIDs -- transliterator_list_ids — Obtener los IDs de los transliterardores

Descripción

Estilo orientado a objetos

public static Transliterator::listIDs ( ) : array

Estilo por procedimientos

transliterator_list_ids ( ) : array

Devuelve un array con los IDs de los transliteradores registrados.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con los IDs de los transliteradores registrados en caso de éxito. o false en caso de error.

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::transliterate() - Transliterar una cadena


Transliterar una cadena

  • « Transliterator::listIDs
  • IntlBreakIterator »
  • PHP Manual
  • Transliterator
  • Transliterar una cadena

Transliterator::transliterate

transliterator_transliterate

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::transliterate -- transliterator_transliterate — Transliterar una cadena

Descripción

Estilo orientado a objetos

public Transliterator::transliterate ( string $subject , int $start = ? , int $end = ? ) : string

Estilo por procedimientos

transliterator_transliterate ( mixed $transliterator , string $subject , int $start = ? , int $end = ? )

Translitera una cadena o parte de la misma utilizando el transliterador de ICU.

Parámetros

transliterator

En la versión por procedimientos, un objeto de la clase Transliterator o un string desde el cual se puede construir un objeto de la clase Transliterator.

subject

La cadena a transformar.

start

El índice de inicio (en unidades de código UTF-16) desde el cual se empezará a transformar la cadena, inclusive. La indexación comienza en 0. El texto anterior a este índice se dejará tal cual.

end

El índice final (en unidades de código UTF-16) hasta el cual será transformala la cadena, exclusive. La indexación comienza en 0. El texto posterior a este índice se dejará tal cual.

Valores devueltos

La cadena transformada en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Converting escaped UTF-16 code units

<?php
$s = "\u304A\u65E9\u3046\u3054\u3056\u3044\u307E\u3059";
echo transliterator_transliterate("Hex-Any/Java", $s), "\n";

// ahora la operación inversa con un caráctar suplementario
$carácterSuplementario = html_entity_decode('&#x1D11E;');
echo mb_strlen($carácter_suplementario, "UTF-8"), "\n";
$carácterSuplementarioCodificado = transliterator_transliterate("Any-Hex/Java", $carácter_suplementario);
// imprime dos unidades de código UTF-16 codificadas
echo $carácterSuplementarioCodificado, "\n";
// y volver
echo transliterator_transliterate("Hex-Any/Java", $carácterSuplementario ), "\n";
?>

El resultado del ejemplo sería algo similar a:

????????
1
\uD834\uDD1E
??

Ver también

  • Transliterator::getErrorMessage() - Obtener el mensaje del último error
  • Transliterator::__construct() - Constructor privado para denegar la instanciación


La clase IntlBreakIterator

(PHP 5 >= 5.5.0, PHP 7)

Introducción

Un “iterador de ruptura” es un objeto ICU que expone métodos para localizar los límites de un texto (p.ej. límites de palabra o sentencia). La clase IntlBreakIterator de PHP sirve como la clase base para todos los tipos de iteradores de ruptura de ICU. Donde esté disponible funcionalidad extra, la extensión intl puede exponer el iterador de ruptura de ICU con subclases aptas, como IntlRuleBasedBreakIterator o IntlCodePointBreaIterator.

Esta clase implementa Traversable. Recorrer un IntlBreakIterator produce valores enteros no negativos que representan las ubicaciones sucesibas de los límites del texto, expresados como unidades de código UTF-8 (byte), tomados del inicio del texto (que tienen la ubicación 0). Las claves producidas pord el iterador simplemente forman la secuencia de números naturales {0, 1, 2, …}.

Sinopsis de la Clase

IntlBreakIterator implements Traversable {
/* Constantes */
const integer DONE = -1 ;
const integer WORD_NONE = 0 ;
const integer WORD_NONE_LIMIT = 100 ;
const integer WORD_NUMBER = 100 ;
const integer WORD_NUMBER_LIMIT = 200 ;
const integer WORD_LETTER = 200 ;
const integer WORD_LETTER_LIMIT = 300 ;
const integer WORD_KANA = 300 ;
const integer WORD_KANA_LIMIT = 400 ;
const integer WORD_IDEO = 400 ;
const integer WORD_IDEO_LIMIT = 500 ;
const integer LINE_SOFT = 0 ;
const integer LINE_SOFT_LIMIT = 100 ;
const integer LINE_HARD = 100 ;
const integer LINE_HARD_LIMIT = 200 ;
const integer SENTENCE_TERM = 0 ;
const integer SENTENCE_TERM_LIMIT = 100 ;
const integer SENTENCE_SEP = 100 ;
const integer SENTENCE_SEP_LIMIT = 200 ;
/* Métodos */
private __construct ( )
public static createCharacterInstance ( string $"locale" = ? ) : ReturnType
public static createCodePointInstance ( ) : ReturnType
public static createLineInstance ( string $"locale" = ? ) : ReturnType
public static createSentenceInstance ( string $"locale" = ? ) : ReturnType
public static createTitleInstance ( string $"locale" = ? ) : ReturnType
public static createWordInstance ( string $"locale" = ? ) : ReturnType
public current ( ) : ReturnType
public first ( ) : ReturnType
public following ( string $"offset" ) : ReturnType
public getErrorCode ( ) : ReturnType
intl_get_error_code ( ) : ReturnType
public getErrorMessage ( ) : ReturnType
intl_get_error_message ( ) : ReturnType
public getLocale ( string $"locale_type" ) : ReturnType
public getPartsIterator ( string $"key_type" = ? ) : ReturnType
public getText ( ) : ReturnType
public isBoundary ( string $"offset" ) : ReturnType
public last ( ) : ReturnType
public next ( string $"offset" = ? ) : ReturnType
public preceding ( string $"offset" ) : ReturnType
public previous ( ) : ReturnType
public setText ( string $"text" ) : ReturnType
}

Constantes predefinidas

IntlBreakIterator::DONE

IntlBreakIterator::WORD_NONE

IntlBreakIterator::WORD_NONE_LIMIT

IntlBreakIterator::WORD_NUMBER

IntlBreakIterator::WORD_NUMBER_LIMIT

IntlBreakIterator::WORD_LETTER

IntlBreakIterator::WORD_LETTER_LIMIT

IntlBreakIterator::WORD_KANA

IntlBreakIterator::WORD_KANA_LIMIT

IntlBreakIterator::WORD_IDEO

IntlBreakIterator::WORD_IDEO_LIMIT

IntlBreakIterator::LINE_SOFT

IntlBreakIterator::LINE_SOFT_LIMIT

IntlBreakIterator::LINE_HARD

IntlBreakIterator::LINE_HARD_LIMIT

IntlBreakIterator::SENTENCE_TERM

IntlBreakIterator::SENTENCE_TERM_LIMIT

IntlBreakIterator::SENTENCE_SEP

IntlBreakIterator::SENTENCE_SEP_LIMIT

Tabla de contenidos

  • IntlBreakIterator::__construct — Constructor privado para denegar la instanciación
  • IntlBreakIterator::createCharacterInstance — Crear un iterador de ruptura para los límites de secuencias de caracters combinados
  • IntlBreakIterator::createCodePointInstance — Crear un iterador de ruptura para los límites de puntos de código
  • IntlBreakIterator::createLineInstance — Crear un iterador de ruptura para las lógicamente posibles saltos de línea
  • IntlBreakIterator::createSentenceInstance — Crear un iterador de ruptura para rupturas de sentencias
  • IntlBreakIterator::createTitleInstance — Crear un iterador de ruptura para rupturas de marcos de título
  • IntlBreakIterator::createWordInstance — Crear un iterador de ruptura para ruptura de palabras
  • IntlBreakIterator::current — Obtiene el índice de la posición actual
  • IntlBreakIterator::first — Coloca la posición al primer caracter en el texto
  • IntlBreakIterator::following — Avanza el iterador al primer límite siguiendo un offset específico
  • IntlBreakIterator::getErrorCode — Obtener el código del último error del objeto
  • IntlBreakIterator::getErrorMessage — Obtener el último mensaje de error del objeto
  • IntlBreakIterator::getLocale — Obtiene el locale asociado al objeto
  • IntlBreakIterator::getPartsIterator — Crear un iterador para fragmentos de navegación entre límites
  • IntlBreakIterator::getText — Obtiene el texto que está siendo escaneado
  • IntlBreakIterator::isBoundary — Indicar si un índice es un índice de límites
  • IntlBreakIterator::last — Establecer la posición del iterador al índice tras el último carácter
  • IntlBreakIterator::next — Avanzar el iterador al siguiente límite
  • IntlBreakIterator::preceding — Establecer la posición del iterador al primer límite antes de un índice
  • IntlBreakIterator::previous — Establecer la posición del iterador al límite inmediatamente anterior al actual
  • IntlBreakIterator::setText — Establecer el texto a escanear


Constructor privado para denegar la instanciación

  • « IntlBreakIterator
  • IntlBreakIterator::createCharacterInstance »
  • PHP Manual
  • IntlBreakIterator
  • Constructor privado para denegar la instanciación

IntlBreakIterator::__construct

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::__construct — Constructor privado para denegar la instanciación

Descripción

private IntlBreakIterator::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Crear un iterador de ruptura para los límites de secuencias de caracters combinados

  • « IntlBreakIterator::__construct
  • IntlBreakIterator::createCodePointInstance »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para los límites de secuencias de caracters combinados

IntlBreakIterator::createCharacterInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createCharacterInstance — Crear un iterador de ruptura para los límites de secuencias de caracters combinados

Descripción

public static IntlBreakIterator::createCharacterInstance ( string $"locale" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale"

Valores devueltos


Crear un iterador de ruptura para los límites de puntos de código

  • « IntlBreakIterator::createCharacterInstance
  • IntlBreakIterator::createLineInstance »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para los límites de puntos de código

IntlBreakIterator::createCodePointInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createCodePointInstance — Crear un iterador de ruptura para los límites de puntos de código

Descripción

public static IntlBreakIterator::createCodePointInstance ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Crear un iterador de ruptura para las lógicamente posibles saltos de línea

  • « IntlBreakIterator::createCodePointInstance
  • IntlBreakIterator::createSentenceInstance »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para las lógicamente posibles saltos de línea

IntlBreakIterator::createLineInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createLineInstance — Crear un iterador de ruptura para las lógicamente posibles saltos de línea

Descripción

public static IntlBreakIterator::createLineInstance ( string $"locale" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale"

Valores devueltos


Crear un iterador de ruptura para rupturas de sentencias

  • « IntlBreakIterator::createLineInstance
  • IntlBreakIterator::createTitleInstance »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para rupturas de sentencias

IntlBreakIterator::createSentenceInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createSentenceInstance — Crear un iterador de ruptura para rupturas de sentencias

Descripción

public static IntlBreakIterator::createSentenceInstance ( string $"locale" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale"

Valores devueltos


Crear un iterador de ruptura para rupturas de marcos de título

  • « IntlBreakIterator::createSentenceInstance
  • IntlBreakIterator::createWordInstance »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para rupturas de marcos de título

IntlBreakIterator::createTitleInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createTitleInstance — Crear un iterador de ruptura para rupturas de marcos de título

Descripción

public static IntlBreakIterator::createTitleInstance ( string $"locale" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale"

Valores devueltos


Crear un iterador de ruptura para ruptura de palabras

  • « IntlBreakIterator::createTitleInstance
  • IntlBreakIterator::current »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador de ruptura para ruptura de palabras

IntlBreakIterator::createWordInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createWordInstance — Crear un iterador de ruptura para ruptura de palabras

Descripción

public static IntlBreakIterator::createWordInstance ( string $"locale" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale"

Valores devueltos


Obtiene el índice de la posición actual

  • « IntlBreakIterator::createWordInstance
  • IntlBreakIterator::first »
  • PHP Manual
  • IntlBreakIterator
  • Obtiene el índice de la posición actual

IntlBreakIterator::current

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::current — Obtiene el índice de la posición actual

Descripción

public IntlBreakIterator::current ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Coloca la posición al primer caracter en el texto

  • « IntlBreakIterator::current
  • IntlBreakIterator::following »
  • PHP Manual
  • IntlBreakIterator
  • Coloca la posición al primer caracter en el texto

IntlBreakIterator::first

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::first — Coloca la posición al primer caracter en el texto

Descripción

public IntlBreakIterator::first ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Avanza el iterador al primer límite siguiendo un offset específico

  • « IntlBreakIterator::first
  • IntlBreakIterator::getErrorCode »
  • PHP Manual
  • IntlBreakIterator
  • Avanza el iterador al primer límite siguiendo un offset específico

IntlBreakIterator::following

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::following — Avanza el iterador al primer límite siguiendo un offset específico

Descripción

public IntlBreakIterator::following ( string $"offset" ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"offset"

Valores devueltos


Obtener el código del último error del objeto

  • « IntlBreakIterator::following
  • IntlBreakIterator::getErrorMessage »
  • PHP Manual
  • IntlBreakIterator
  • Obtener el código del último error del objeto

IntlBreakIterator::getErrorCode

intl_get_error_code

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getErrorCode -- intl_get_error_code — Obtener el código del último error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlBreakIterator::getErrorCode ( ) : ReturnType

Estilo por procedimientos:

intl_get_error_code ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el último mensaje de error del objeto

  • « IntlBreakIterator::getErrorCode
  • IntlBreakIterator::getLocale »
  • PHP Manual
  • IntlBreakIterator
  • Obtener el último mensaje de error del objeto

IntlBreakIterator::getErrorMessage

intl_get_error_message

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getErrorMessage -- intl_get_error_message — Obtener el último mensaje de error del objeto

Descripción

Estilo orientado a objetos (method):

public IntlBreakIterator::getErrorMessage ( ) : ReturnType

Estilo por procedimientos:

intl_get_error_message ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene el locale asociado al objeto

  • « IntlBreakIterator::getErrorMessage
  • IntlBreakIterator::getPartsIterator »
  • PHP Manual
  • IntlBreakIterator
  • Obtiene el locale asociado al objeto

IntlBreakIterator::getLocale

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getLocale — Obtiene el locale asociado al objeto

Descripción

public IntlBreakIterator::getLocale ( string $"locale_type" ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"locale_type"

Valores devueltos


Crear un iterador para fragmentos de navegación entre límites

  • « IntlBreakIterator::getLocale
  • IntlBreakIterator::getText »
  • PHP Manual
  • IntlBreakIterator
  • Crear un iterador para fragmentos de navegación entre límites

IntlBreakIterator::getPartsIterator

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getPartsIterator — Crear un iterador para fragmentos de navegación entre límites

Descripción

public IntlBreakIterator::getPartsIterator ( string $"key_type" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"key_type"

Valores devueltos


Obtiene el texto que está siendo escaneado

  • « IntlBreakIterator::getPartsIterator
  • IntlBreakIterator::isBoundary »
  • PHP Manual
  • IntlBreakIterator
  • Obtiene el texto que está siendo escaneado

IntlBreakIterator::getText

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getText — Obtiene el texto que está siendo escaneado

Descripción

public IntlBreakIterator::getText ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Indicar si un índice es un índice de límites

  • « IntlBreakIterator::getText
  • IntlBreakIterator::last »
  • PHP Manual
  • IntlBreakIterator
  • Indicar si un índice es un índice de límites

IntlBreakIterator::isBoundary

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::isBoundary — Indicar si un índice es un índice de límites

Descripción

public IntlBreakIterator::isBoundary ( string $"offset" ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"offset"

Valores devueltos


Establecer la posición del iterador al índice tras el último carácter

  • « IntlBreakIterator::isBoundary
  • IntlBreakIterator::next »
  • PHP Manual
  • IntlBreakIterator
  • Establecer la posición del iterador al índice tras el último carácter

IntlBreakIterator::last

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::last — Establecer la posición del iterador al índice tras el último carácter

Descripción

public IntlBreakIterator::last ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Avanzar el iterador al siguiente límite

  • « IntlBreakIterator::last
  • IntlBreakIterator::preceding »
  • PHP Manual
  • IntlBreakIterator
  • Avanzar el iterador al siguiente límite

IntlBreakIterator::next

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::next — Avanzar el iterador al siguiente límite

Descripción

public IntlBreakIterator::next ( string $"offset" = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"offset"

Valores devueltos


Establecer la posición del iterador al primer límite antes de un índice

  • « IntlBreakIterator::next
  • IntlBreakIterator::previous »
  • PHP Manual
  • IntlBreakIterator
  • Establecer la posición del iterador al primer límite antes de un índice

IntlBreakIterator::preceding

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::preceding — Establecer la posición del iterador al primer límite antes de un índice

Descripción

public IntlBreakIterator::preceding ( string $"offset" ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"offset"

Valores devueltos


Establecer la posición del iterador al límite inmediatamente anterior al actual

  • « IntlBreakIterator::preceding
  • IntlBreakIterator::setText »
  • PHP Manual
  • IntlBreakIterator
  • Establecer la posición del iterador al límite inmediatamente anterior al actual

IntlBreakIterator::previous

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::previous — Establecer la posición del iterador al límite inmediatamente anterior al actual

Descripción

public IntlBreakIterator::previous ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Establecer el texto a escanear

  • « IntlBreakIterator::previous
  • IntlRuleBasedBreakIterator »
  • PHP Manual
  • IntlBreakIterator
  • Establecer el texto a escanear

IntlBreakIterator::setText

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::setText — Establecer el texto a escanear

Descripción

public IntlBreakIterator::setText ( string $"text" ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"text"

Valores devueltos


La clase IntlRuleBasedBreakIterator

(PHP 5 >= 5.5.0, PHP 7)

Introducción

Una subclase de IntlBreakIterator que encapsula iteradores de ruptura de ICU cuyo comportamiento se especifica usando un conjunto de reglas. Este es el tipo más común de iteradores de ruptura.

Estas reglas están descritas en la» Guía de usuario de análisis de límites de ICU.

Sinopsis de la Clase

IntlRuleBasedBreakIterator extends IntlBreakIterator implements Traversable {
/* Constantes */
const integer DONE = -1 ;
const integer WORD_NONE = 0 ;
const integer WORD_NONE_LIMIT = 100 ;
const integer WORD_NUMBER = 100 ;
const integer WORD_NUMBER_LIMIT = 200 ;
const integer WORD_LETTER = 200 ;
const integer WORD_LETTER_LIMIT = 300 ;
const integer WORD_KANA = 300 ;
const integer WORD_KANA_LIMIT = 400 ;
const integer WORD_IDEO = 400 ;
const integer WORD_IDEO_LIMIT = 500 ;
const integer LINE_SOFT = 0 ;
const integer LINE_SOFT_LIMIT = 100 ;
const integer LINE_HARD = 100 ;
const integer LINE_HARD_LIMIT = 200 ;
const integer SENTENCE_TERM = 0 ;
const integer SENTENCE_TERM_LIMIT = 100 ;
const integer SENTENCE_SEP = 100 ;
const integer SENTENCE_SEP_LIMIT = 200 ;
/* Métodos */
public __construct ( string $rules , string $areCompiled = ? )
public getBinaryRules ( ) : ReturnType
public getRules ( ) : ReturnType
public getRuleStatus ( ) : ReturnType
public getRuleStatusVec ( ) : ReturnType
/* Métodos heredados */
private IntlBreakIterator::__construct ( )
public static IntlBreakIterator::createCharacterInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createCodePointInstance ( ) : ReturnType
public static IntlBreakIterator::createLineInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createSentenceInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createTitleInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createWordInstance ( string $"locale" = ? ) : ReturnType
public IntlBreakIterator::current ( ) : ReturnType
public IntlBreakIterator::first ( ) : ReturnType
public IntlBreakIterator::following ( string $"offset" ) : ReturnType
public IntlBreakIterator::getErrorCode ( ) : ReturnType
intl_get_error_code ( ) : ReturnType
public IntlBreakIterator::getErrorMessage ( ) : ReturnType
intl_get_error_message ( ) : ReturnType
public IntlBreakIterator::getLocale ( string $"locale_type" ) : ReturnType
public IntlBreakIterator::getPartsIterator ( string $"key_type" = ? ) : ReturnType
public IntlBreakIterator::getText ( ) : ReturnType
public IntlBreakIterator::isBoundary ( string $"offset" ) : ReturnType
public IntlBreakIterator::last ( ) : ReturnType
public IntlBreakIterator::next ( string $"offset" = ? ) : ReturnType
public IntlBreakIterator::preceding ( string $"offset" ) : ReturnType
public IntlBreakIterator::previous ( ) : ReturnType
public IntlBreakIterator::setText ( string $"text" ) : ReturnType
}

Constantes predefinidas

IntlRuleBasedBreakIterator::DONE

IntlRuleBasedBreakIterator::WORD_NONE

IntlRuleBasedBreakIterator::WORD_NONE_LIMIT

IntlRuleBasedBreakIterator::WORD_NUMBER

IntlRuleBasedBreakIterator::WORD_NUMBER_LIMIT

IntlRuleBasedBreakIterator::WORD_LETTER

IntlRuleBasedBreakIterator::WORD_LETTER_LIMIT

IntlRuleBasedBreakIterator::WORD_KANA

IntlRuleBasedBreakIterator::WORD_KANA_LIMIT

IntlRuleBasedBreakIterator::WORD_IDEO

IntlRuleBasedBreakIterator::WORD_IDEO_LIMIT

IntlRuleBasedBreakIterator::LINE_SOFT

IntlRuleBasedBreakIterator::LINE_SOFT_LIMIT

IntlRuleBasedBreakIterator::LINE_HARD

IntlRuleBasedBreakIterator::LINE_HARD_LIMIT

IntlRuleBasedBreakIterator::SENTENCE_TERM

IntlRuleBasedBreakIterator::SENTENCE_TERM_LIMIT

IntlRuleBasedBreakIterator::SENTENCE_SEP

IntlRuleBasedBreakIterator::SENTENCE_SEP_LIMIT

Tabla de contenidos

  • IntlRuleBasedBreakIterator::__construct — Crear un iterador desde un conjunto de reglas
  • IntlRuleBasedBreakIterator::getBinaryRules — Obtener la forma binaria de las reglas compiladas
  • IntlRuleBasedBreakIterator::getRules — Obtener el conjunto de reglas empleado para crear este objeto
  • IntlRuleBasedBreakIterator::getRuleStatus — Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual
  • IntlRuleBasedBreakIterator::getRuleStatusVec — Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal


Crear un iterador desde un conjunto de reglas

  • « IntlRuleBasedBreakIterator
  • IntlRuleBasedBreakIterator::getBinaryRules »
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Crear un iterador desde un conjunto de reglas

IntlRuleBasedBreakIterator::__construct

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::__construct — Crear un iterador desde un conjunto de reglas

Descripción

public IntlRuleBasedBreakIterator::__construct ( string $rules , string $areCompiled = ? )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

"rules"

"areCompiled"

Valores devueltos


Obtener la forma binaria de las reglas compiladas

  • « IntlRuleBasedBreakIterator::__construct
  • IntlRuleBasedBreakIterator::getRules »
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Obtener la forma binaria de las reglas compiladas

IntlRuleBasedBreakIterator::getBinaryRules

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getBinaryRules — Obtener la forma binaria de las reglas compiladas

Descripción

public IntlRuleBasedBreakIterator::getBinaryRules ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el conjunto de reglas empleado para crear este objeto

  • « IntlRuleBasedBreakIterator::getBinaryRules
  • IntlRuleBasedBreakIterator::getRuleStatus »
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Obtener el conjunto de reglas empleado para crear este objeto

IntlRuleBasedBreakIterator::getRules

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRules — Obtener el conjunto de reglas empleado para crear este objeto

Descripción

public IntlRuleBasedBreakIterator::getRules ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual

  • « IntlRuleBasedBreakIterator::getRules
  • IntlRuleBasedBreakIterator::getRuleStatusVec »
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual

IntlRuleBasedBreakIterator::getRuleStatus

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRuleStatus — Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual

Descripción

public IntlRuleBasedBreakIterator::getRuleStatus ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal

  • « IntlRuleBasedBreakIterator::getRuleStatus
  • IntlCodePointBreakIterator »
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal

IntlRuleBasedBreakIterator::getRuleStatusVec

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRuleStatusVec — Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal

Descripción

public IntlRuleBasedBreakIterator::getRuleStatusVec ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase IntlCodePointBreakIterator

(PHP 5 >= 5.5.0, PHP 7)

Introducción

Este iterador de ruptura identifica los límites entre puntos de código de UTF-8.

Sinopsis de la Clase

IntlCodePointBreakIterator extends IntlBreakIterator implements Traversable {
/* Constantes */
const integer DONE = -1 ;
const integer WORD_NONE = 0 ;
const integer WORD_NONE_LIMIT = 100 ;
const integer WORD_NUMBER = 100 ;
const integer WORD_NUMBER_LIMIT = 200 ;
const integer WORD_LETTER = 200 ;
const integer WORD_LETTER_LIMIT = 300 ;
const integer WORD_KANA = 300 ;
const integer WORD_KANA_LIMIT = 400 ;
const integer WORD_IDEO = 400 ;
const integer WORD_IDEO_LIMIT = 500 ;
const integer LINE_SOFT = 0 ;
const integer LINE_SOFT_LIMIT = 100 ;
const integer LINE_HARD = 100 ;
const integer LINE_HARD_LIMIT = 200 ;
const integer SENTENCE_TERM = 0 ;
const integer SENTENCE_TERM_LIMIT = 100 ;
const integer SENTENCE_SEP = 100 ;
const integer SENTENCE_SEP_LIMIT = 200 ;
/* Métodos */
public getLastCodePoint ( ) : ReturnType
/* Métodos heredados */
private IntlBreakIterator::__construct ( )
public static IntlBreakIterator::createCharacterInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createCodePointInstance ( ) : ReturnType
public static IntlBreakIterator::createLineInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createSentenceInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createTitleInstance ( string $"locale" = ? ) : ReturnType
public static IntlBreakIterator::createWordInstance ( string $"locale" = ? ) : ReturnType
public IntlBreakIterator::current ( ) : ReturnType
public IntlBreakIterator::first ( ) : ReturnType
public IntlBreakIterator::following ( string $"offset" ) : ReturnType
public IntlBreakIterator::getErrorCode ( ) : ReturnType
intl_get_error_code ( ) : ReturnType
public IntlBreakIterator::getErrorMessage ( ) : ReturnType
intl_get_error_message ( ) : ReturnType
public IntlBreakIterator::getLocale ( string $"locale_type" ) : ReturnType
public IntlBreakIterator::getPartsIterator ( string $"key_type" = ? ) : ReturnType
public IntlBreakIterator::getText ( ) : ReturnType
public IntlBreakIterator::isBoundary ( string $"offset" ) : ReturnType
public IntlBreakIterator::last ( ) : ReturnType
public IntlBreakIterator::next ( string $"offset" = ? ) : ReturnType
public IntlBreakIterator::preceding ( string $"offset" ) : ReturnType
public IntlBreakIterator::previous ( ) : ReturnType
public IntlBreakIterator::setText ( string $"text" ) : ReturnType
}

Constantes predefinidas

IntlCodePointBreakIterator::DONE

IntlCodePointBreakIterator::WORD_NONE

IntlCodePointBreakIterator::WORD_NONE_LIMIT

IntlCodePointBreakIterator::WORD_NUMBER

IntlCodePointBreakIterator::WORD_NUMBER_LIMIT

IntlCodePointBreakIterator::WORD_LETTER

IntlCodePointBreakIterator::WORD_LETTER_LIMIT

IntlCodePointBreakIterator::WORD_KANA

IntlCodePointBreakIterator::WORD_KANA_LIMIT

IntlCodePointBreakIterator::WORD_IDEO

IntlCodePointBreakIterator::WORD_IDEO_LIMIT

IntlCodePointBreakIterator::LINE_SOFT

IntlCodePointBreakIterator::LINE_SOFT_LIMIT

IntlCodePointBreakIterator::LINE_HARD

IntlCodePointBreakIterator::LINE_HARD_LIMIT

IntlCodePointBreakIterator::SENTENCE_TERM

IntlCodePointBreakIterator::SENTENCE_TERM_LIMIT

IntlCodePointBreakIterator::SENTENCE_SEP

IntlCodePointBreakIterator::SENTENCE_SEP_LIMIT

Tabla de contenidos

  • IntlCodePointBreakIterator::getLastCodePoint — Obtener el último punto de código ignorado después de que el iterdor avance o retroceda


Obtener el último punto de código ignorado después de que el iterdor avance o retroceda

  • « IntlCodePointBreakIterator
  • IntlPartsIterator »
  • PHP Manual
  • IntlCodePointBreakIterator
  • Obtener el último punto de código ignorado después de que el iterdor avance o retroceda

IntlCodePointBreakIterator::getLastCodePoint

(PHP 5 >= 5.5.0, PHP 7)

IntlCodePointBreakIterator::getLastCodePoint — Obtener el último punto de código ignorado después de que el iterdor avance o retroceda

Descripción

public IntlCodePointBreakIterator::getLastCodePoint ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase IntlPartsIterator

(PHP 5 >= 5.5.0, PHP 7)

Introducción

Los objetos de esta clase se pueden obtener desde objetos IntlBreakIterator. Mientras que los iteradores de ruptura proporcionan una secuencia de posiciones límite cuando son recorridos, los objetos IntlPartsIterator proporcionan, como ventaja, los fragmentos de texto comprendidos entre dos límites sucesivos.

Las claves podrían representar el índice del límite izquierdo, límite derecho, o podrían simplemente representar la secuencia de enteros no negativos. Véase IntlBreakIterator::getPartsIterator().

Sinopsis de la Clase

IntlPartsIterator extends IntlIterator implements Iterator {
/* Constantes */
const integer KEY_SEQUENTIAL = 0 ;
const integer KEY_LEFT = 1 ;
const integer KEY_RIGHT = 2 ;
/* Métodos */
public getBreakIterator ( ) : ReturnType
/* Métodos heredados */
public IntlIterator::current ( ) : ReturnType
public IntlIterator::key ( ) : ReturnType
public IntlIterator::next ( ) : ReturnType
public IntlIterator::rewind ( ) : ReturnType
public IntlIterator::valid ( ) : ReturnType
}

Constantes predefinidas

IntlPartsIterator::KEY_SEQUENTIAL

IntlPartsIterator::KEY_LEFT

IntlPartsIterator::KEY_RIGHT

Tabla de contenidos

  • IntlPartsIterator::getBreakIterator — Obtener un IntlBreakIterator respaldando este iterador de partes


Obtener un IntlBreakIterator respaldando este iterador de partes

  • « IntlPartsIterator
  • UConverter »
  • PHP Manual
  • IntlPartsIterator
  • Obtener un IntlBreakIterator respaldando este iterador de partes

IntlPartsIterator::getBreakIterator

(PHP 5 >= 5.5.0, PHP 7)

IntlPartsIterator::getBreakIterator — Obtener un IntlBreakIterator respaldando este iterador de partes

Descripción

public IntlPartsIterator::getBreakIterator ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase UConverter

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

Introducción

Sinopsis de la Clase

UConverter {
/* Constantes */
const integer REASON_UNASSIGNED = 0 ;
const integer REASON_ILLEGAL = 1 ;
const integer REASON_IRREGULAR = 2 ;
const integer REASON_RESET = 3 ;
const integer REASON_CLOSE = 4 ;
const integer REASON_CLONE = 5 ;
const integer UNSUPPORTED_CONVERTER = -1 ;
const integer SBCS = 0 ;
const integer DBCS = 1 ;
const integer MBCS = 2 ;
const integer LATIN_1 = 3 ;
const integer UTF8 = 4 ;
const integer UTF16_BigEndian = 5 ;
const integer UTF16_LittleEndian = 6 ;
const integer UTF32_BigEndian = 7 ;
const integer UTF32_LittleEndian = 8 ;
const integer EBCDIC_STATEFUL = 9 ;
const integer ISO_2022 = 10 ;
const integer LMBCS_1 = 11 ;
const integer LMBCS_2 = 12 ;
const integer LMBCS_3 = 13 ;
const integer LMBCS_4 = 14 ;
const integer LMBCS_5 = 15 ;
const integer LMBCS_6 = 16 ;
const integer LMBCS_8 = 17 ;
const integer LMBCS_11 = 18 ;
const integer LMBCS_16 = 19 ;
const integer LMBCS_17 = 20 ;
const integer LMBCS_18 = 21 ;
const integer LMBCS_19 = 22 ;
const integer LMBCS_LAST = 22 ;
const integer HZ = 23 ;
const integer SCSU = 24 ;
const integer ISCII = 25 ;
const integer US_ASCII = 26 ;
const integer UTF7 = 27 ;
const integer BOCU1 = 28 ;
const integer UTF16 = 29 ;
const integer UTF32 = 30 ;
const integer CESU8 = 31 ;
const integer IMAP_MAILBOX = 32 ;
/* Métodos */
public __construct ( string $destination_encoding = ? , string $source_encoding = ? )
public convert ( string $str , bool $reverse = ? ) : string
public fromUCallback ( integer $reason , string $source , string $codePoint , integer &$error ) : mixed
public static getAliases ( string $name = ? ) : array
public static getAvailable ( ) : array
public getDestinationEncoding ( ) : string
public getDestinationType ( ) : integer
public getErrorCode ( ) : integer
public getErrorMessage ( ) : string
public getSourceEncoding ( ) : string
public getSourceType ( ) : integer
public static getStandards ( ) : array
public getSubstChars ( ) : string
public static reasonText ( integer $reason = ? ) : string
public setDestinationEncoding ( string $encoding ) : void
public setSourceEncoding ( string $encoding ) : void
public setSubstChars ( string $chars ) : void
public toUCallback ( integer $reason , string $source , string $codeUnits , integer &$error ) : mixed
public static transcode ( string $str , string $toEncoding , string $fromEncoding , array $options = ? ) : string
}

Constantes predefinidas

UConverter::REASON_UNASSIGNED

UConverter::REASON_ILLEGAL

UConverter::REASON_IRREGULAR

UConverter::REASON_RESET

UConverter::REASON_CLOSE

UConverter::REASON_CLONE

UConverter::UNSUPPORTED_CONVERTER

UConverter::SBCS

UConverter::DBCS

UConverter::MBCS

UConverter::LATIN_1

UConverter::UTF8

UConverter::UTF16_BigEndian

UConverter::UTF16_LittleEndian

UConverter::UTF32_BigEndian

UConverter::UTF32_LittleEndian

UConverter::EBCDIC_STATEFUL

UConverter::ISO_2022

UConverter::LMBCS_1

UConverter::LMBCS_2

UConverter::LMBCS_3

UConverter::LMBCS_4

UConverter::LMBCS_5

UConverter::LMBCS_6

UConverter::LMBCS_8

UConverter::LMBCS_11

UConverter::LMBCS_16

UConverter::LMBCS_17

UConverter::LMBCS_18

UConverter::LMBCS_19

UConverter::LMBCS_LAST

UConverter::HZ

UConverter::SCSU

UConverter::ISCII

UConverter::US_ASCII

UConverter::UTF7

UConverter::BOCU1

UConverter::UTF16

UConverter::UTF32

UConverter::CESU8

UConverter::IMAP_MAILBOX

Tabla de contenidos

  • UConverter::__construct — Crea un objeto UConverter
  • UConverter::convert — Convertir un string de un juego de caracteres a otro
  • UConverter::fromUCallback — Función de retrollamada "from" predeterminada
  • UConverter::getAliases — Obtener los alias del nombre dado
  • UConverter::getAvailable — Obtener los nombres canónicos de los convertidores disponibles
  • UConverter::getDestinationEncoding — Obtener la codificación de destino
  • UConverter::getDestinationType — Obtener el tipo del convertidor de destino
  • UConverter::getErrorCode — Obtener el código del último error del objeto
  • UConverter::getErrorMessage — Obtener el último mensaje de error del objeto
  • UConverter::getSourceEncoding — Obtener la codificación de origen
  • UConverter::getSourceType — Obtener el tipo de convertidor de origen
  • UConverter::getStandards — Obtener los estándares asociados a los nombres de los convertidores
  • UConverter::getSubstChars — Obtener los caracteres de sustitución
  • UConverter::reasonText — Obtener la representación de string de la razón de la retrollamada
  • UConverter::setDestinationEncoding — Establecer la codificación destino
  • UConverter::setSourceEncoding — Establecer la codificación origen
  • UConverter::setSubstChars — Establecer los caracteres de sustitución
  • UConverter::toUCallback — Función de retrollamada "to" predeterminada
  • UConverter::transcode — Convertir un string de un juego de caracteres a otro


Crea un objeto UConverter

  • « UConverter
  • UConverter::convert »
  • PHP Manual
  • UConverter
  • Crea un objeto UConverter

UConverter::__construct

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::__construct — Crea un objeto UConverter

Descripción

public UConverter::__construct ( string $destination_encoding = ? , string $source_encoding = ? )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

destination_encoding

source_encoding

Valores devueltos


Convertir un string de un juego de caracteres a otro

  • « UConverter::__construct
  • UConverter::fromUCallback »
  • PHP Manual
  • UConverter
  • Convertir un string de un juego de caracteres a otro

UConverter::convert

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::convert — Convertir un string de un juego de caracteres a otro

Descripción

public UConverter::convert ( string $str , bool $reverse = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

str

reverse

Valores devueltos


Función de retrollamada "from" predeterminada

  • « UConverter::convert
  • UConverter::getAliases »
  • PHP Manual
  • UConverter
  • Función de retrollamada "from" predeterminada

UConverter::fromUCallback

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::fromUCallback — Función de retrollamada "from" predeterminada

Descripción

public UConverter::fromUCallback ( integer $reason , string $source , string $codePoint , integer &$error ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

reason

source

codePoint

error

Valores devueltos


Obtener los alias del nombre dado

  • « UConverter::fromUCallback
  • UConverter::getAvailable »
  • PHP Manual
  • UConverter
  • Obtener los alias del nombre dado

UConverter::getAliases

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getAliases — Obtener los alias del nombre dado

Descripción

public static UConverter::getAliases ( string $name = ? ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


Obtener los nombres canónicos de los convertidores disponibles

  • « UConverter::getAliases
  • UConverter::getDestinationEncoding »
  • PHP Manual
  • UConverter
  • Obtener los nombres canónicos de los convertidores disponibles

UConverter::getAvailable

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getAvailable — Obtener los nombres canónicos de los convertidores disponibles

Descripción

public static UConverter::getAvailable ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener la codificación de destino

  • « UConverter::getAvailable
  • UConverter::getDestinationType »
  • PHP Manual
  • UConverter
  • Obtener la codificación de destino

UConverter::getDestinationEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getDestinationEncoding — Obtener la codificación de destino

Descripción

public UConverter::getDestinationEncoding ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el tipo del convertidor de destino

  • « UConverter::getDestinationEncoding
  • UConverter::getErrorCode »
  • PHP Manual
  • UConverter
  • Obtener el tipo del convertidor de destino

UConverter::getDestinationType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getDestinationType — Obtener el tipo del convertidor de destino

Descripción

public UConverter::getDestinationType ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el código del último error del objeto

  • « UConverter::getDestinationType
  • UConverter::getErrorMessage »
  • PHP Manual
  • UConverter
  • Obtener el código del último error del objeto

UConverter::getErrorCode

intl_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getErrorCode -- intl_get_error_code — Obtener el código del último error del objeto

Descripción

public UConverter::getErrorCode ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el último mensaje de error del objeto

  • « UConverter::getErrorCode
  • UConverter::getSourceEncoding »
  • PHP Manual
  • UConverter
  • Obtener el último mensaje de error del objeto

UConverter::getErrorMessage

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getErrorMessage — Obtener el último mensaje de error del objeto

Descripción

public UConverter::getErrorMessage ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener la codificación de origen

  • « UConverter::getErrorMessage
  • UConverter::getSourceType »
  • PHP Manual
  • UConverter
  • Obtener la codificación de origen

UConverter::getSourceEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSourceEncoding — Obtener la codificación de origen

Descripción

public UConverter::getSourceEncoding ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el tipo de convertidor de origen

  • « UConverter::getSourceEncoding
  • UConverter::getStandards »
  • PHP Manual
  • UConverter
  • Obtener el tipo de convertidor de origen

UConverter::getSourceType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSourceType — Obtener el tipo de convertidor de origen

Descripción

public UConverter::getSourceType ( ) : integer

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener los estándares asociados a los nombres de los convertidores

  • « UConverter::getSourceType
  • UConverter::getSubstChars »
  • PHP Manual
  • UConverter
  • Obtener los estándares asociados a los nombres de los convertidores

UConverter::getStandards

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getStandards — Obtener los estándares asociados a los nombres de los convertidores

Descripción

public static UConverter::getStandards ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener los caracteres de sustitución

  • « UConverter::getStandards
  • UConverter::reasonText »
  • PHP Manual
  • UConverter
  • Obtener los caracteres de sustitución

UConverter::getSubstChars

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSubstChars — Obtener los caracteres de sustitución

Descripción

public UConverter::getSubstChars ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener la representación de string de la razón de la retrollamada

  • « UConverter::getSubstChars
  • UConverter::setDestinationEncoding »
  • PHP Manual
  • UConverter
  • Obtener la representación de string de la razón de la retrollamada

UConverter::reasonText

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::reasonText — Obtener la representación de string de la razón de la retrollamada

Descripción

public static UConverter::reasonText ( integer $reason = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

reason

Valores devueltos


Establecer la codificación destino

  • « UConverter::reasonText
  • UConverter::setSourceEncoding »
  • PHP Manual
  • UConverter
  • Establecer la codificación destino

UConverter::setDestinationEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setDestinationEncoding — Establecer la codificación destino

Descripción

public UConverter::setDestinationEncoding ( string $encoding ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

encoding

Valores devueltos


Establecer la codificación origen

  • « UConverter::setDestinationEncoding
  • UConverter::setSubstChars »
  • PHP Manual
  • UConverter
  • Establecer la codificación origen

UConverter::setSourceEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setSourceEncoding — Establecer la codificación origen

Descripción

public UConverter::setSourceEncoding ( string $encoding ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

encoding

Valores devueltos


Establecer los caracteres de sustitución

  • « UConverter::setSourceEncoding
  • UConverter::toUCallback »
  • PHP Manual
  • UConverter
  • Establecer los caracteres de sustitución

UConverter::setSubstChars

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setSubstChars — Establecer los caracteres de sustitución

Descripción

public UConverter::setSubstChars ( string $chars ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

chars

Valores devueltos


Función de retrollamada "to" predeterminada

  • « UConverter::setSubstChars
  • UConverter::transcode »
  • PHP Manual
  • UConverter
  • Función de retrollamada "to" predeterminada

UConverter::toUCallback

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::toUCallback — Función de retrollamada "to" predeterminada

Descripción

public UConverter::toUCallback ( integer $reason , string $source , string $codeUnits , integer &$error ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

reason

source

codeUnits

error

Valores devueltos


Convertir un string de un juego de caracteres a otro

  • « UConverter::toUCallback
  • Funciones de Grapheme »
  • PHP Manual
  • UConverter
  • Convertir un string de un juego de caracteres a otro

UConverter::transcode

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::transcode — Convertir un string de un juego de caracteres a otro

Descripción

public static UConverter::transcode ( string $str , string $toEncoding , string $fromEncoding , array $options = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

str

toEncoding

fromEncoding

options

Valores devueltos


Funciones de Grapheme

Tabla de contenidos

  • grapheme_extract — Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8
  • grapheme_stripos — Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_stristr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_strlen — Obtener la longitud de un string en unidades de grafema
  • grapheme_strpos — Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strripos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strrpos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • grapheme_strstr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • grapheme_substr — Devolver parte de una cadena


Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8

  • « Funciones de Grapheme
  • grapheme_stripos »
  • PHP Manual
  • Funciones de Grapheme
  • Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8

grapheme_extract

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_extract — Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8

Descripción

Estilo por procedimientos

grapheme_extract ( string $haystack , int $size , int $extract_type = ? , int $start = 0 , int &$next = ? ) : string

Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8.

Parámetros

haystack

La cadena a buscar.

size

Número máximo de elementos -basado en el parámetro $extract_type- a devolver.

extract_type

Define el tipo de unidades mencionadas por el parámetro $size:

  • GRAPHEME_EXTR_COUNT (predeterminado) - $size es el número predeterminado de grupos de grafemas a extraer.
  • GRAPHEME_EXTR_MAXBYTES - $size es el número máximo de bytes devueltos.
  • GRAPHEME_EXTR_MAXCHARS - $size es el número máximo de caracteres UTF-8 devueltos.

start

Posición de inicio del parámetro $haystack en bytes -si se proporciona, debe ser cero o un valor positivo que sea menor o igual que la longitud del parámetro $haystack en bytes. Si $start no apunta al primer byte de un carácter UTF-8, la posición de inicio se mueve al límite del siguiente carácter.

next

Una referencia a un valor que será establecido a la posición de inicio siguiente. Cuando la funcion devuelve, este parámetro puede apuntar a la posición del primer byte después del final de la cadena.

Valores devueltos

Una cadena que empieza en el índice $start y termina en un límite de un grupo de grafemas predeterminado que se ajusta al $size y $extract_type especificados.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_extract()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print urlencode(grapheme_extract( $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd, 1, GRAPHEME_EXTR_COUNT, 2));

?>

El resultado del ejemplo sería:

o%CC%88

Ver también

  • grapheme_substr() - Devolver parte de una cadena
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas

  • « grapheme_extract
  • grapheme_stristr »
  • PHP Manual
  • Funciones de Grapheme
  • Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas

grapheme_stripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stripos — Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas

Descripción

Estilo por procedimientos

grapheme_stripos ( string $haystack , string $needle , int $offset = 0 ) : int

Busca la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

offset

El parámetro opcional $offset permite especificar dónde iniciar la búsqueda en haystack como un índice en unidades de grafema (no bytes o caracteres). La posición devuelta es aún relativa al comienzo del "pajar" sin tener en cuenta el valor de $offset.

Valores devueltos

Devuelve la posición como un entero. Si no encuentra la "aguja", grapheme_stripos() devolverá FALSE.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_stripos()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"
$carácter_O_diéresis_nfd = "O\xCC\x88"; // 'LETRA MAYÚSCULA LATINA O CON DIÉRESIS' (U+00D6) forma de normalización "D"

print grapheme_stripos( $carácter_a_anillo_nfd . $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd, $carácter_O_diéresis_nfd);

?>

El resultado del ejemplo sería:

2

Ver también

  • grapheme_stristr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_strpos() - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strripos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strrpos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • grapheme_strstr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"

  • « grapheme_stripos
  • grapheme_strlen »
  • PHP Manual
  • Funciones de Grapheme
  • Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"

grapheme_stristr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stristr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"

Descripción

Estilo por procedimientos

grapheme_stristr ( string $haystack , string $needle , bool $before_needle = false ) : string

Devuelve parte de la cadena "pajar" comenzando desde e incluyendo la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar".

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

before_needle

Si es true, grapheme_stristr() devuelve la parte de "pajar" anterior a la primera coincidencia de "aguja" (excluyendo "aguja").

Valores devueltos

Devuelve la porción de $haystack, o FALSE si $needle no se encontró.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_stristr()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"
$carácter_O_diéresis_nfd = "O\xCC\x88"; // 'LETRA MAYÚSCULA LATINA O CON DIÉRESIS' (U+00D6) forma de normalización "D"

print urlencode(grapheme_stristr( $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd . $carácter_a_anillo_nfd, $carácter_O_diéresis_nfd));

?>

El resultado del ejemplo sería:

o%CC%88a%CC%8A

Ver también

  • grapheme_stripos() - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strpos() - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strripos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strrpos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • grapheme_strstr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Obtener la longitud de un string en unidades de grafema

  • « grapheme_stristr
  • grapheme_strpos »
  • PHP Manual
  • Funciones de Grapheme
  • Obtener la longitud de un string en unidades de grafema

grapheme_strlen

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strlen — Obtener la longitud de un string en unidades de grafema

Descripción

Estilo por procedimientos

grapheme_strlen ( string $input ) : int

Obtiene la longitud de un string en unidades de grafema (no bytes o caracteres)

Parámetros

input

El string al que medir la longitud. Debe ser un string UTF-8 válida.

Valores devueltos

La longitud del string en caso de éxito, y 0 si el string está vacío.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_strlen()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print grapheme_strlen( 'abc' . $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd . $carácter_a_anillo_nfd);

?>

El resultado del ejemplo sería:

6

Ver también

  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas
  • iconv_strlen() - Retorna el número de caracteres de un string
  • mb_strlen() - Obtiene la longitud de una cadena de caracteres
  • strlen() - Obtiene la longitud de un string


Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena

  • « grapheme_strlen
  • grapheme_strripos »
  • PHP Manual
  • Funciones de Grapheme
  • Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena

grapheme_strpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strpos — Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena

Descripción

Estilo por procedimientos

grapheme_strpos ( string $haystack , string $needle , int $offset = 0 ) : int

Busca la posición (en unidades de grafema) de la primera ocurrencia de una cadena

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

offset

El parámetro opcional $offset permite especificar dónde iniciar la búsqueda en haystack como un índice en unidades de grafema (no bytes o caracteres). La posición devuelta es aún relativa al comienzo del "pajar" sin tener en cuenta el valor de $offset.

Valores devueltos

Devuelve la posición como un entero. Si no encuentra la "aguja", grapheme_strpos() devolverá FALSE.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_strpos()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print grapheme_strpos( $carácter_a_anillo_nfd . $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd, $carácter_o_diéresis_nfd);

?>

El resultado del ejemplo sería:

2

Ver también

  • grapheme_stripos() - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_stristr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_strripos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strrpos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • grapheme_strstr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas

  • « grapheme_strpos
  • grapheme_strrpos »
  • PHP Manual
  • Funciones de Grapheme
  • Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas

grapheme_strripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strripos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas

Descripción

Estilo por procedimientos

grapheme_strripos ( string $haystack , string $needle , int $offset = 0 ) : int

Busca la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

offset

El parámetro opcional $offset permite especificar dónde iniciar la búsqueda en haystack como un índice en unidades de grafema (no bytes o caracteres). La posición devuelta es aún relativa al comienzo del "pajar" sin tener en cuenta el valor de $offset.

Valores devueltos

Devuelve la posición como un entero. Si no encuentra la "aguja", grapheme_strripos() devolverá FALSE.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_strripos()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"
$carácter_O_diéresis_nfd = "O\xCC\x88"; // 'LETRA MAYÚSCULA LATINA O CON DIÉRESIS' (U+00D6) forma de normalización "D"

print grapheme_strripos( $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd . $carácter_o_diéresis_nfd, $carácter_O_diéresis_nfd);

?>

El resultado del ejemplo sería:

2

Ver también

  • grapheme_stripos() - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_stristr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_strpos() - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strrpos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • grapheme_strstr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena

  • « grapheme_strripos
  • grapheme_strstr »
  • PHP Manual
  • Funciones de Grapheme
  • Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena

grapheme_strrpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strrpos — Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena

Descripción

Estilo por procedimientos

grapheme_strrpos ( string $haystack , string $needle , int $offset = 0 ) : int

Busca la posición (en unidades de grafema) de la última coincidencia de una cadena

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

offset

El parámetro opcional $offset permite especificar dónde iniciar la búsqueda en haystack como un índice en unidades de grafema (no bytes o caracteres). La posición devuelta es aún relativa al comienzo del "pajar" sin tener en cuenta el valor de $offset.

Valores devueltos

Devuelve la posición como un entero. Si no encuentra la "aguja", grapheme_strrpos() devolverá FALSE.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_strrpos()

<?php
$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print grapheme_strrpos( $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd . $carácter_o_diéresis_nfd, $carácter_o_diéresis_nfd);
?>

El resultado del ejemplo sería:

2

Ver también

  • grapheme_stripos() - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_stristr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_strpos() - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strripos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strstr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"

  • « grapheme_strrpos
  • grapheme_substr »
  • PHP Manual
  • Funciones de Grapheme
  • Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"

grapheme_strstr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strstr — Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"

Descripción

Estilo por procedimientos

grapheme_strstr ( string $haystack , string $needle , bool $before_needle = false ) : string

Devuelve parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar" (incluyendo la "aguja").

Parámetros

haystack

La cadena en la que buscar (pajar). Debe ser válida en UTF-8.

needle

La cadena a buscar (aguja). Debe ser válida en UTF-8.

before_needle

Si es true, grapheme_stristr() devuelve la parte de "pajar" anterior a la primera coincidencia de "ajuja" (excluyendo la "aguja").

Valores devueltos

Devuelve la porción de $haystack, o FALSE si $needle no se encontró.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_strstr()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print urlencode(grapheme_strstr( $carácter_a_anillo_nfd . $carácter_o_diéresis_nfd . $carácter_a_anillo_nfd, $carácter_o_diéresis_nfd));

?>

El resultado del ejemplo sería:

o%CC%88a%CC%8A

Ver también

  • grapheme_stristr() - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
  • grapheme_stripos() - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strpos() - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
  • grapheme_strripos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
  • grapheme_strrpos() - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Devolver parte de una cadena

  • « grapheme_strstr
  • Funciones de IDN »
  • PHP Manual
  • Funciones de Grapheme
  • Devolver parte de una cadena

grapheme_substr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_substr — Devolver parte de una cadena

Descripción

Estilo por procedimientos

grapheme_substr ( string $string , int $start , int $length = ? ) : int

Devuelve parte de una cadena

Parámetros

string

La cadena de entrada. Debe ser válida en UTF-8.

start

Posición de inicio en unidades predeterminadas de grafema. Si $start es no negativo, la cadena devuelta comenzara en la posición $start-ésima de $string, contando desde cero. Si $start is negativo, la cadena devuelta comenzará en la unidad de grafema $start-ésima desde el final de la cadena.

length

La longitud en unidades de grafema. Si se propoiciona $length y es positivo, la cadena devuelta contendrá como máximo $length unidades de grafema comenzando desde $start (dependiendo de la longitud de la cadena). Si se proporciona $length y es negativo, esas tantas unidades de grafema serán omitidas desde el final de la cadena (después de que la posición inicial haya sido calculada cuando un inicio es negativo). Si $start denota una posición más allá de este truncamiento, se devolverá false.

Valores devueltos

Devuelve la parte extraída de $string.

Historial de cambios

Versión | Descripción
5.4 | Si se proporciona length y es positivo, y el argumento string es más corto que la longitud especificada, se devuelve el resto de la cadena de acuerdo al parámetro start. Anteriormente devolvía false.

Ejemplos

Ejemplo #1 Ejemplo de grapheme_substr()

<?php

$carácter_a_anillo_nfd = "a\xCC\x8A";  // 'LETRA MINÚSCULA LATINA A CON ANILLO SUPERIOR' (U+00E5) forma de normalización "D"
$carácter_o_diéresis_nfd = "o\xCC\x88"; // 'LETRA MINÚSCULA LATINA O CON DIÉRESIS' (U+00F6) forma de normalización "D"

print urlencode(grapheme_substr( "ao" . $carácter_a_anillo_nfd . "bc" . $carácter_o_diéresis_nfd . "O", 2, -1 ));
?>

El resultado del ejemplo sería:

a%CC%8Abco%CC%88

Ver también

  • grapheme_extract() - Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8
  • » Segementación de Texto Unicode: Límites de Grupos de Grafemas


Funciones de IDN

Tabla de contenidos

  • idn_to_ascii — Convierte un nombre de dominio a formato IDNA ASCII
  • idn_to_utf8 — Convierte un nombre de dominio de IDNA ASCII a Unicode


Convierte un nombre de dominio a formato IDNA ASCII

  • « Funciones de IDN
  • idn_to_utf8 »
  • PHP Manual
  • Funciones de IDN
  • Convierte un nombre de dominio a formato IDNA ASCII

idn_to_ascii

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PECL idn >= 0.1)

idn_to_ascii — Convierte un nombre de dominio a formato IDNA ASCII

Descripción

Estilo por procedimientos

idn_to_ascii ( string $domain , int $options = 0 , int $variant = INTL_IDNA_VARIANT_2003 , array &$idna_info = ? ) : string

Esta función convierte un dominio Unicode al formato IDNA ASCII-compatible.

Parámetros

domain

Dominio a convertir. En PHP 5 debe estar previamente codificado en UTF-8.

options

Opciones de conversión - combinación de constantes IDNA_* (excepto las constantes IDNA_ERROR_*).

variant

INTL_IDNA_VARIANT_2003 para IDNA 2003 o INTL_IDNA_VARIANT_UTS46 para UTS #46.

idna_info

Este parámetro sólo se puede usar si INTL_IDNA_VARIANT_UTS46 se utilizó para variant. En este caso, será llenado con un array con las claves 'result', la posibilidad de un resultado ilegal de la transformación, 'isTransitionalDifferent', un booleano indicando si el uso de los mecanismos de transición de UTS #46 ha cambiado o debería haber cambiado el resulado, y 'errors', que es de tipo int y representa un conjunto de bits de las constantes de error IDNA_ERROR_*.

Valores devueltos

Nombre del dominio codificado en formato ASCII-compatible. o false en caso de error

Historial de cambios

Versión | Descripción
5.4.0/PECL 2.0.0b1 | Se añadieron los parámetros variant y idna_info; y el soporte para UTS #46.

Ejemplos

Ejemplo #1 Ejemplo de idn_to_ascii()

<?php

echo idn_to_ascii('täst.de');

?>

El resultado del ejemplo sería:

xn--tst-qla.de

Ver también

  • idn_to_unicode()


Convierte un nombre de dominio de IDNA ASCII a Unicode

  • « idn_to_ascii
  • IntlChar »
  • PHP Manual
  • Funciones de IDN
  • Convierte un nombre de dominio de IDNA ASCII a Unicode

idn_to_utf8

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PECL idn >= 0.1)

idn_to_utf8 — Convierte un nombre de dominio de IDNA ASCII a Unicode

Descripción

Estilo por procedimientos

idn_to_utf8 ( string $domain , int $options = 0 , int $variant = INTL_IDNA_VARIANT_2003 , array &$idna_info = ? ) : string

Esta función convierte un nombre de dominio Unicode de un formato compatible con IDNA ASCII a Unicode plano, codificado en UTF.8.

Parámetros

domain

Dominio a convertir en formato IDNA ASCII-compatible.

options

Opciones de conversión - combinación de constantes IDNA_* (excepto las constantes IDNA_ERROR_*).

variant

INTL_IDNA_VARIANT_2003 para IDNA 2003 o INTL_IDNA_VARIANT_UTS46 para UTS #46.

idna_info

Este parámetro sólo se puede usar si INTL_IDNA_VARIANT_UTS46 se utilizó para variant. En este caso, será llenado con un array con las claves 'result', la posibilidad de un resultado ilegal de la transformación, 'isTransitionalDifferent', un booleano indicando si el uso de los mecanismos de transición de UTS #46 ha cambiado o debería haber cambiado el resulado, y 'errors', que es de tipo int y representa un conjunto de bits de las constantes de error IDNA_ERROR_*.

Valores devueltos

Un nombre de dominio en Uniconde, codificado en UTF-8. o false en caso de error

Historial de cambios

Versión | Descripción
5.4.0/PECL 2.0.0b1 | Se añadieron los parámetros variant y idna_info; y el soporte para UTS #46.

Ejemplos

Ejemplo #1 Ejemplo de idn_to_utf8()

<?php

echo idn_to_utf8('xn--tst-qla.de');

?>

El resultado del ejemplo sería:

täst.de

Ver también

  • idn_to_unicode()


IntlChar

(PHP 7)

Introducción

IntlChar proporciona acceso a varios métodos de utilidades que pueden emplearse para obtener información de caracteres Unicode.

Los métodos y las constantes cumplen estrechamente con los nombres y comportamientos empleados por la biblioteca ICU subyacente.

Sinopsis de la Clase

IntlChar {
/* Constants */
const string UNICODE_VERSION = 6.3 ;
const integer CODEPOINT_MIN = 0 ;
const integer CODEPOINT_MAX = 1114111 ;
const integer PROPERTY_ALPHABETIC = 0 ;
const integer PROPERTY_BINARY_START = 0 ;
const integer PROPERTY_ASCII_HEX_DIGIT = 1 ;
const integer PROPERTY_BIDI_CONTROL = 2 ;
const integer PROPERTY_BIDI_MIRRORED = 3 ;
const integer PROPERTY_DASH = 4 ;
const integer PROPERTY_DEFAULT_IGNORABLE_CODE_POINT = 5 ;
const integer PROPERTY_DEPRECATED = 6 ;
const integer PROPERTY_DIACRITIC = 7 ;
const integer PROPERTY_EXTENDER = 8 ;
const integer PROPERTY_FULL_COMPOSITION_EXCLUSION = 9 ;
const integer PROPERTY_GRAPHEME_BASE = 10 ;
const integer PROPERTY_GRAPHEME_EXTEND = 11 ;
const integer PROPERTY_GRAPHEME_LINK = 12 ;
const integer PROPERTY_HEX_DIGIT = 13 ;
const integer PROPERTY_HYPHEN = 14 ;
const integer PROPERTY_ID_CONTINUE = 15 ;
const integer PROPERTY_ID_START = 16 ;
const integer PROPERTY_IDEOGRAPHIC = 17 ;
const integer PROPERTY_IDS_BINARY_OPERATOR = 18 ;
const integer PROPERTY_IDS_TRINARY_OPERATOR = 19 ;
const integer PROPERTY_JOIN_CONTROL = 20 ;
const integer PROPERTY_LOGICAL_ORDER_EXCEPTION = 21 ;
const integer PROPERTY_LOWERCASE = 22 ;
const integer PROPERTY_MATH = 23 ;
const integer PROPERTY_NONCHARACTER_CODE_POINT = 24 ;
const integer PROPERTY_QUOTATION_MARK = 25 ;
const integer PROPERTY_RADICAL = 26 ;
const integer PROPERTY_SOFT_DOTTED = 27 ;
const integer PROPERTY_TERMINAL_PUNCTUATION = 28 ;
const integer PROPERTY_UNIFIED_IDEOGRAPH = 29 ;
const integer PROPERTY_UPPERCASE = 30 ;
const integer PROPERTY_WHITE_SPACE = 31 ;
const integer PROPERTY_XID_CONTINUE = 32 ;
const integer PROPERTY_XID_START = 33 ;
const integer PROPERTY_CASE_SENSITIVE = 34 ;
const integer PROPERTY_S_TERM = 35 ;
const integer PROPERTY_VARIATION_SELECTOR = 36 ;
const integer PROPERTY_NFD_INERT = 37 ;
const integer PROPERTY_NFKD_INERT = 38 ;
const integer PROPERTY_NFC_INERT = 39 ;
const integer PROPERTY_NFKC_INERT = 40 ;
const integer PROPERTY_SEGMENT_STARTER = 41 ;
const integer PROPERTY_PATTERN_SYNTAX = 42 ;
const integer PROPERTY_PATTERN_WHITE_SPACE = 43 ;
const integer PROPERTY_POSIX_ALNUM = 44 ;
const integer PROPERTY_POSIX_BLANK = 45 ;
const integer PROPERTY_POSIX_GRAPH = 46 ;
const integer PROPERTY_POSIX_PRINT = 47 ;
const integer PROPERTY_POSIX_XDIGIT = 48 ;
const integer PROPERTY_CASED = 49 ;
const integer PROPERTY_CASE_IGNORABLE = 50 ;
const integer PROPERTY_CHANGES_WHEN_LOWERCASED = 51 ;
const integer PROPERTY_CHANGES_WHEN_UPPERCASED = 52 ;
const integer PROPERTY_CHANGES_WHEN_TITLECASED = 53 ;
const integer PROPERTY_CHANGES_WHEN_CASEFOLDED = 54 ;
const integer PROPERTY_CHANGES_WHEN_CASEMAPPED = 55 ;
const integer PROPERTY_CHANGES_WHEN_NFKC_CASEFOLDED = 56 ;
const integer PROPERTY_BINARY_LIMIT = 57 ;
const integer PROPERTY_BIDI_CLASS = 4096 ;
const integer PROPERTY_INT_START = 4096 ;
const integer PROPERTY_BLOCK = 4097 ;
const integer PROPERTY_CANONICAL_COMBINING_CLASS = 4098 ;
const integer PROPERTY_DECOMPOSITION_TYPE = 4099 ;
const integer PROPERTY_EAST_ASIAN_WIDTH = 4100 ;
const integer PROPERTY_GENERAL_CATEGORY = 4101 ;
const integer PROPERTY_JOINING_GROUP = 4102 ;
const integer PROPERTY_JOINING_TYPE = 4103 ;
const integer PROPERTY_LINE_BREAK = 4104 ;
const integer PROPERTY_NUMERIC_TYPE = 4105 ;
const integer PROPERTY_SCRIPT = 4106 ;
const integer PROPERTY_HANGUL_SYLLABLE_TYPE = 4107 ;
const integer PROPERTY_NFD_QUICK_CHECK = 4108 ;
const integer PROPERTY_NFKD_QUICK_CHECK = 4109 ;
const integer PROPERTY_NFC_QUICK_CHECK = 4110 ;
const integer PROPERTY_NFKC_QUICK_CHECK = 4111 ;
const integer PROPERTY_LEAD_CANONICAL_COMBINING_CLASS = 4112 ;
const integer PROPERTY_TRAIL_CANONICAL_COMBINING_CLASS = 4113 ;
const integer PROPERTY_GRAPHEME_CLUSTER_BREAK = 4114 ;
const integer PROPERTY_SENTENCE_BREAK = 4115 ;
const integer PROPERTY_WORD_BREAK = 4116 ;
const integer PROPERTY_BIDI_PAIRED_BRACKET_TYPE = 4117 ;
const integer PROPERTY_INT_LIMIT = 4118 ;
const integer PROPERTY_GENERAL_CATEGORY_MASK = 8192 ;
const integer PROPERTY_MASK_START = 8192 ;
const integer PROPERTY_MASK_LIMIT = 8193 ;
const integer PROPERTY_NUMERIC_VALUE = 12288 ;
const integer PROPERTY_DOUBLE_START = 12288 ;
const integer PROPERTY_DOUBLE_LIMIT = 12289 ;
const integer PROPERTY_AGE = 16384 ;
const integer PROPERTY_STRING_START = 16384 ;
const integer PROPERTY_BIDI_MIRRORING_GLYPH = 16385 ;
const integer PROPERTY_CASE_FOLDING = 16386 ;
const integer PROPERTY_ISO_COMMENT = 16387 ;
const integer PROPERTY_LOWERCASE_MAPPING = 16388 ;
const integer PROPERTY_NAME = 16389 ;
const integer PROPERTY_SIMPLE_CASE_FOLDING = 16390 ;
const integer PROPERTY_SIMPLE_LOWERCASE_MAPPING = 16391 ;
const integer PROPERTY_SIMPLE_TITLECASE_MAPPING = 16392 ;
const integer PROPERTY_SIMPLE_UPPERCASE_MAPPING = 16393 ;
const integer PROPERTY_TITLECASE_MAPPING = 16394 ;
const integer PROPERTY_UNICODE_1_NAME = 16395 ;
const integer PROPERTY_UPPERCASE_MAPPING = 16396 ;
const integer PROPERTY_BIDI_PAIRED_BRACKET = 16397 ;
const integer PROPERTY_STRING_LIMIT = 16398 ;
const integer PROPERTY_SCRIPT_EXTENSIONS = 28672 ;
const integer PROPERTY_OTHER_PROPERTY_START = 28672 ;
const integer PROPERTY_OTHER_PROPERTY_LIMIT = 28673 ;
const integer PROPERTY_INVALID_CODE = -1 ;
const integer CHAR_CATEGORY_UNASSIGNED = 0 ;
const integer CHAR_CATEGORY_GENERAL_OTHER_TYPES = 0 ;
const integer CHAR_CATEGORY_UPPERCASE_LETTER = 1 ;
const integer CHAR_CATEGORY_LOWERCASE_LETTER = 2 ;
const integer CHAR_CATEGORY_TITLECASE_LETTER = 3 ;
const integer CHAR_CATEGORY_MODIFIER_LETTER = 4 ;
const integer CHAR_CATEGORY_OTHER_LETTER = 5 ;
const integer CHAR_CATEGORY_NON_SPACING_MARK = 6 ;
const integer CHAR_CATEGORY_ENCLOSING_MARK = 7 ;
const integer CHAR_CATEGORY_COMBINING_SPACING_MARK = 8 ;
const integer CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER = 9 ;
const integer CHAR_CATEGORY_LETTER_NUMBER = 10 ;
const integer CHAR_CATEGORY_OTHER_NUMBER = 11 ;
const integer CHAR_CATEGORY_SPACE_SEPARATOR = 12 ;
const integer CHAR_CATEGORY_LINE_SEPARATOR = 13 ;
const integer CHAR_CATEGORY_PARAGRAPH_SEPARATOR = 14 ;
const integer CHAR_CATEGORY_CONTROL_CHAR = 15 ;
const integer CHAR_CATEGORY_FORMAT_CHAR = 16 ;
const integer CHAR_CATEGORY_PRIVATE_USE_CHAR = 17 ;
const integer CHAR_CATEGORY_SURROGATE = 18 ;
const integer CHAR_CATEGORY_DASH_PUNCTUATION = 19 ;
const integer CHAR_CATEGORY_START_PUNCTUATION = 20 ;
const integer CHAR_CATEGORY_END_PUNCTUATION = 21 ;
const integer CHAR_CATEGORY_CONNECTOR_PUNCTUATION = 22 ;
const integer CHAR_CATEGORY_OTHER_PUNCTUATION = 23 ;
const integer CHAR_CATEGORY_MATH_SYMBOL = 24 ;
const integer CHAR_CATEGORY_CURRENCY_SYMBOL = 25 ;
const integer CHAR_CATEGORY_MODIFIER_SYMBOL = 26 ;
const integer CHAR_CATEGORY_OTHER_SYMBOL = 27 ;
const integer CHAR_CATEGORY_INITIAL_PUNCTUATION = 28 ;
const integer CHAR_CATEGORY_FINAL_PUNCTUATION = 29 ;
const integer CHAR_CATEGORY_CHAR_CATEGORY_COUNT = 30 ;
const integer CHAR_DIRECTION_LEFT_TO_RIGHT = 0 ;
const integer CHAR_DIRECTION_RIGHT_TO_LEFT = 1 ;
const integer CHAR_DIRECTION_EUROPEAN_NUMBER = 2 ;
const integer CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR = 3 ;
const integer CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR = 4 ;
const integer CHAR_DIRECTION_ARABIC_NUMBER = 5 ;
const integer CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR = 6 ;
const integer CHAR_DIRECTION_BLOCK_SEPARATOR = 7 ;
const integer CHAR_DIRECTION_SEGMENT_SEPARATOR = 8 ;
const integer CHAR_DIRECTION_WHITE_SPACE_NEUTRAL = 9 ;
const integer CHAR_DIRECTION_OTHER_NEUTRAL = 10 ;
const integer CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING = 11 ;
const integer CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE = 12 ;
const integer CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC = 13 ;
const integer CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING = 14 ;
const integer CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE = 15 ;
const integer CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT = 16 ;
const integer CHAR_DIRECTION_DIR_NON_SPACING_MARK = 17 ;
const integer CHAR_DIRECTION_BOUNDARY_NEUTRAL = 18 ;
const integer CHAR_DIRECTION_FIRST_STRONG_ISOLATE = 19 ;
const integer CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE = 20 ;
const integer CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE = 21 ;
const integer CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE = 22 ;
const integer CHAR_DIRECTION_CHAR_DIRECTION_COUNT = 23 ;
const integer BLOCK_CODE_NO_BLOCK = 0 ;
const integer BLOCK_CODE_BASIC_LATIN = 1 ;
const integer BLOCK_CODE_LATIN_1_SUPPLEMENT = 2 ;
const integer BLOCK_CODE_LATIN_EXTENDED_A = 3 ;
const integer BLOCK_CODE_LATIN_EXTENDED_B = 4 ;
const integer BLOCK_CODE_IPA_EXTENSIONS = 5 ;
const integer BLOCK_CODE_SPACING_MODIFIER_LETTERS = 6 ;
const integer BLOCK_CODE_COMBINING_DIACRITICAL_MARKS = 7 ;
const integer BLOCK_CODE_GREEK = 8 ;
const integer BLOCK_CODE_CYRILLIC = 9 ;
const integer BLOCK_CODE_ARMENIAN = 10 ;
const integer BLOCK_CODE_HEBREW = 11 ;
const integer BLOCK_CODE_ARABIC = 12 ;
const integer BLOCK_CODE_SYRIAC = 13 ;
const integer BLOCK_CODE_THAANA = 14 ;
const integer BLOCK_CODE_DEVANAGARI = 15 ;
const integer BLOCK_CODE_BENGALI = 16 ;
const integer BLOCK_CODE_GURMUKHI = 17 ;
const integer BLOCK_CODE_GUJARATI = 18 ;
const integer BLOCK_CODE_ORIYA = 19 ;
const integer BLOCK_CODE_TAMIL = 20 ;
const integer BLOCK_CODE_TELUGU = 21 ;
const integer BLOCK_CODE_KANNADA = 22 ;
const integer BLOCK_CODE_MALAYALAM = 23 ;
const integer BLOCK_CODE_SINHALA = 24 ;
const integer BLOCK_CODE_THAI = 25 ;
const integer BLOCK_CODE_LAO = 26 ;
const integer BLOCK_CODE_TIBETAN = 27 ;
const integer BLOCK_CODE_MYANMAR = 28 ;
const integer BLOCK_CODE_GEORGIAN = 29 ;
const integer BLOCK_CODE_HANGUL_JAMO = 30 ;
const integer BLOCK_CODE_ETHIOPIC = 31 ;
const integer BLOCK_CODE_CHEROKEE = 32 ;
const integer BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS = 33 ;
const integer BLOCK_CODE_OGHAM = 34 ;
const integer BLOCK_CODE_RUNIC = 35 ;
const integer BLOCK_CODE_KHMER = 36 ;
const integer BLOCK_CODE_MONGOLIAN = 37 ;
const integer BLOCK_CODE_LATIN_EXTENDED_ADDITIONAL = 38 ;
const integer BLOCK_CODE_GREEK_EXTENDED = 39 ;
const integer BLOCK_CODE_GENERAL_PUNCTUATION = 40 ;
const integer BLOCK_CODE_SUPERSCRIPTS_AND_SUBSCRIPTS = 41 ;
const integer BLOCK_CODE_CURRENCY_SYMBOLS = 42 ;
const integer BLOCK_CODE_COMBINING_MARKS_FOR_SYMBOLS = 43 ;
const integer BLOCK_CODE_LETTERLIKE_SYMBOLS = 44 ;
const integer BLOCK_CODE_NUMBER_FORMS = 45 ;
const integer BLOCK_CODE_ARROWS = 46 ;
const integer BLOCK_CODE_MATHEMATICAL_OPERATORS = 47 ;
const integer BLOCK_CODE_MISCELLANEOUS_TECHNICAL = 48 ;
const integer BLOCK_CODE_CONTROL_PICTURES = 49 ;
const integer BLOCK_CODE_OPTICAL_CHARACTER_RECOGNITION = 50 ;
const integer BLOCK_CODE_ENCLOSED_ALPHANUMERICS = 51 ;
const integer BLOCK_CODE_BOX_DRAWING = 52 ;
const integer BLOCK_CODE_BLOCK_ELEMENTS = 53 ;
const integer BLOCK_CODE_GEOMETRIC_SHAPES = 54 ;
const integer BLOCK_CODE_MISCELLANEOUS_SYMBOLS = 55 ;
const integer BLOCK_CODE_DINGBATS = 56 ;
const integer BLOCK_CODE_BRAILLE_PATTERNS = 57 ;
const integer BLOCK_CODE_CJK_RADICALS_SUPPLEMENT = 58 ;
const integer BLOCK_CODE_KANGXI_RADICALS = 59 ;
const integer BLOCK_CODE_IDEOGRAPHIC_DESCRIPTION_CHARACTERS = 60 ;
const integer BLOCK_CODE_CJK_SYMBOLS_AND_PUNCTUATION = 61 ;
const integer BLOCK_CODE_HIRAGANA = 62 ;
const integer BLOCK_CODE_KATAKANA = 63 ;
const integer BLOCK_CODE_BOPOMOFO = 64 ;
const integer BLOCK_CODE_HANGUL_COMPATIBILITY_JAMO = 65 ;
const integer BLOCK_CODE_KANBUN = 66 ;
const integer BLOCK_CODE_BOPOMOFO_EXTENDED = 67 ;
const integer BLOCK_CODE_ENCLOSED_CJK_LETTERS_AND_MONTHS = 68 ;
const integer BLOCK_CODE_CJK_COMPATIBILITY = 69 ;
const integer BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A = 70 ;
const integer BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS = 71 ;
const integer BLOCK_CODE_YI_SYLLABLES = 72 ;
const integer BLOCK_CODE_YI_RADICALS = 73 ;
const integer BLOCK_CODE_HANGUL_SYLLABLES = 74 ;
const integer BLOCK_CODE_HIGH_SURROGATES = 75 ;
const integer BLOCK_CODE_HIGH_PRIVATE_USE_SURROGATES = 76 ;
const integer BLOCK_CODE_LOW_SURROGATES = 77 ;
const integer BLOCK_CODE_PRIVATE_USE_AREA = 78 ;
const integer BLOCK_CODE_PRIVATE_USE = 78 ;
const integer BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS = 79 ;
const integer BLOCK_CODE_ALPHABETIC_PRESENTATION_FORMS = 80 ;
const integer BLOCK_CODE_ARABIC_PRESENTATION_FORMS_A = 81 ;
const integer BLOCK_CODE_COMBINING_HALF_MARKS = 82 ;
const integer BLOCK_CODE_CJK_COMPATIBILITY_FORMS = 83 ;
const integer BLOCK_CODE_SMALL_FORM_VARIANTS = 84 ;
const integer BLOCK_CODE_ARABIC_PRESENTATION_FORMS_B = 85 ;
const integer BLOCK_CODE_SPECIALS = 86 ;
const integer BLOCK_CODE_HALFWIDTH_AND_FULLWIDTH_FORMS = 87 ;
const integer BLOCK_CODE_OLD_ITALIC = 88 ;
const integer BLOCK_CODE_GOTHIC = 89 ;
const integer BLOCK_CODE_DESERET = 90 ;
const integer BLOCK_CODE_BYZANTINE_MUSICAL_SYMBOLS = 91 ;
const integer BLOCK_CODE_MUSICAL_SYMBOLS = 92 ;
const integer BLOCK_CODE_MATHEMATICAL_ALPHANUMERIC_SYMBOLS = 93 ;
const integer BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B = 94 ;
const integer BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT = 95 ;
const integer BLOCK_CODE_TAGS = 96 ;
const integer BLOCK_CODE_CYRILLIC_SUPPLEMENT = 97 ;
const integer BLOCK_CODE_CYRILLIC_SUPPLEMENTARY = 97 ;
const integer BLOCK_CODE_TAGALOG = 98 ;
const integer BLOCK_CODE_HANUNOO = 99 ;
const integer BLOCK_CODE_BUHID = 100 ;
const integer BLOCK_CODE_TAGBANWA = 101 ;
const integer BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A = 102 ;
const integer BLOCK_CODE_SUPPLEMENTAL_ARROWS_A = 103 ;
const integer BLOCK_CODE_SUPPLEMENTAL_ARROWS_B = 104 ;
const integer BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B = 105 ;
const integer BLOCK_CODE_SUPPLEMENTAL_MATHEMATICAL_OPERATORS = 106 ;
const integer BLOCK_CODE_KATAKANA_PHONETIC_EXTENSIONS = 107 ;
const integer BLOCK_CODE_VARIATION_SELECTORS = 108 ;
const integer BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_A = 109 ;
const integer BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_B = 110 ;
const integer BLOCK_CODE_LIMBU = 111 ;
const integer BLOCK_CODE_TAI_LE = 112 ;
const integer BLOCK_CODE_KHMER_SYMBOLS = 113 ;
const integer BLOCK_CODE_PHONETIC_EXTENSIONS = 114 ;
const integer BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_ARROWS = 115 ;
const integer BLOCK_CODE_YIJING_HEXAGRAM_SYMBOLS = 116 ;
const integer BLOCK_CODE_LINEAR_B_SYLLABARY = 117 ;
const integer BLOCK_CODE_LINEAR_B_IDEOGRAMS = 118 ;
const integer BLOCK_CODE_AEGEAN_NUMBERS = 119 ;
const integer BLOCK_CODE_UGARITIC = 120 ;
const integer BLOCK_CODE_SHAVIAN = 121 ;
const integer BLOCK_CODE_OSMANYA = 122 ;
const integer BLOCK_CODE_CYPRIOT_SYLLABARY = 123 ;
const integer BLOCK_CODE_TAI_XUAN_JING_SYMBOLS = 124 ;
const integer BLOCK_CODE_VARIATION_SELECTORS_SUPPLEMENT = 125 ;
const integer BLOCK_CODE_ANCIENT_GREEK_MUSICAL_NOTATION = 126 ;
const integer BLOCK_CODE_ANCIENT_GREEK_NUMBERS = 127 ;
const integer BLOCK_CODE_ARABIC_SUPPLEMENT = 128 ;
const integer BLOCK_CODE_BUGINESE = 129 ;
const integer BLOCK_CODE_CJK_STROKES = 130 ;
const integer BLOCK_CODE_COMBINING_DIACRITICAL_MARKS_SUPPLEMENT = 131 ;
const integer BLOCK_CODE_COPTIC = 132 ;
const integer BLOCK_CODE_ETHIOPIC_EXTENDED = 133 ;
const integer BLOCK_CODE_ETHIOPIC_SUPPLEMENT = 134 ;
const integer BLOCK_CODE_GEORGIAN_SUPPLEMENT = 135 ;
const integer BLOCK_CODE_GLAGOLITIC = 136 ;
const integer BLOCK_CODE_KHAROSHTHI = 137 ;
const integer BLOCK_CODE_MODIFIER_TONE_LETTERS = 138 ;
const integer BLOCK_CODE_NEW_TAI_LUE = 139 ;
const integer BLOCK_CODE_OLD_PERSIAN = 140 ;
const integer BLOCK_CODE_PHONETIC_EXTENSIONS_SUPPLEMENT = 141 ;
const integer BLOCK_CODE_SUPPLEMENTAL_PUNCTUATION = 142 ;
const integer BLOCK_CODE_SYLOTI_NAGRI = 143 ;
const integer BLOCK_CODE_TIFINAGH = 144 ;
const integer BLOCK_CODE_VERTICAL_FORMS = 145 ;
const integer BLOCK_CODE_NKO = 146 ;
const integer BLOCK_CODE_BALINESE = 147 ;
const integer BLOCK_CODE_LATIN_EXTENDED_C = 148 ;
const integer BLOCK_CODE_LATIN_EXTENDED_D = 149 ;
const integer BLOCK_CODE_PHAGS_PA = 150 ;
const integer BLOCK_CODE_PHOENICIAN = 151 ;
const integer BLOCK_CODE_CUNEIFORM = 152 ;
const integer BLOCK_CODE_CUNEIFORM_NUMBERS_AND_PUNCTUATION = 153 ;
const integer BLOCK_CODE_COUNTING_ROD_NUMERALS = 154 ;
const integer BLOCK_CODE_SUNDANESE = 155 ;
const integer BLOCK_CODE_LEPCHA = 156 ;
const integer BLOCK_CODE_OL_CHIKI = 157 ;
const integer BLOCK_CODE_CYRILLIC_EXTENDED_A = 158 ;
const integer BLOCK_CODE_VAI = 159 ;
const integer BLOCK_CODE_CYRILLIC_EXTENDED_B = 160 ;
const integer BLOCK_CODE_SAURASHTRA = 161 ;
const integer BLOCK_CODE_KAYAH_LI = 162 ;
const integer BLOCK_CODE_REJANG = 163 ;
const integer BLOCK_CODE_CHAM = 164 ;
const integer BLOCK_CODE_ANCIENT_SYMBOLS = 165 ;
const integer BLOCK_CODE_PHAISTOS_DISC = 166 ;
const integer BLOCK_CODE_LYCIAN = 167 ;
const integer BLOCK_CODE_CARIAN = 168 ;
const integer BLOCK_CODE_LYDIAN = 169 ;
const integer BLOCK_CODE_MAHJONG_TILES = 170 ;
const integer BLOCK_CODE_DOMINO_TILES = 171 ;
const integer BLOCK_CODE_SAMARITAN = 172 ;
const integer BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED = 173 ;
const integer BLOCK_CODE_TAI_THAM = 174 ;
const integer BLOCK_CODE_VEDIC_EXTENSIONS = 175 ;
const integer BLOCK_CODE_LISU = 176 ;
const integer BLOCK_CODE_BAMUM = 177 ;
const integer BLOCK_CODE_COMMON_INDIC_NUMBER_FORMS = 178 ;
const integer BLOCK_CODE_DEVANAGARI_EXTENDED = 179 ;
const integer BLOCK_CODE_HANGUL_JAMO_EXTENDED_A = 180 ;
const integer BLOCK_CODE_JAVANESE = 181 ;
const integer BLOCK_CODE_MYANMAR_EXTENDED_A = 182 ;
const integer BLOCK_CODE_TAI_VIET = 183 ;
const integer BLOCK_CODE_MEETEI_MAYEK = 184 ;
const integer BLOCK_CODE_HANGUL_JAMO_EXTENDED_B = 185 ;
const integer BLOCK_CODE_IMPERIAL_ARAMAIC = 186 ;
const integer BLOCK_CODE_OLD_SOUTH_ARABIAN = 187 ;
const integer BLOCK_CODE_AVESTAN = 188 ;
const integer BLOCK_CODE_INSCRIPTIONAL_PARTHIAN = 189 ;
const integer BLOCK_CODE_INSCRIPTIONAL_PAHLAVI = 190 ;
const integer BLOCK_CODE_OLD_TURKIC = 191 ;
const integer BLOCK_CODE_RUMI_NUMERAL_SYMBOLS = 192 ;
const integer BLOCK_CODE_KAITHI = 193 ;
const integer BLOCK_CODE_EGYPTIAN_HIEROGLYPHS = 194 ;
const integer BLOCK_CODE_ENCLOSED_ALPHANUMERIC_SUPPLEMENT = 195 ;
const integer BLOCK_CODE_ENCLOSED_IDEOGRAPHIC_SUPPLEMENT = 196 ;
const integer BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C = 197 ;
const integer BLOCK_CODE_MANDAIC = 198 ;
const integer BLOCK_CODE_BATAK = 199 ;
const integer BLOCK_CODE_ETHIOPIC_EXTENDED_A = 200 ;
const integer BLOCK_CODE_BRAHMI = 201 ;
const integer BLOCK_CODE_BAMUM_SUPPLEMENT = 202 ;
const integer BLOCK_CODE_KANA_SUPPLEMENT = 203 ;
const integer BLOCK_CODE_PLAYING_CARDS = 204 ;
const integer BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS = 205 ;
const integer BLOCK_CODE_EMOTICONS = 206 ;
const integer BLOCK_CODE_TRANSPORT_AND_MAP_SYMBOLS = 207 ;
const integer BLOCK_CODE_ALCHEMICAL_SYMBOLS = 208 ;
const integer BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D = 209 ;
const integer BLOCK_CODE_ARABIC_EXTENDED_A = 210 ;
const integer BLOCK_CODE_ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS = 211 ;
const integer BLOCK_CODE_CHAKMA = 212 ;
const integer BLOCK_CODE_MEETEI_MAYEK_EXTENSIONS = 213 ;
const integer BLOCK_CODE_MEROITIC_CURSIVE = 214 ;
const integer BLOCK_CODE_MEROITIC_HIEROGLYPHS = 215 ;
const integer BLOCK_CODE_MIAO = 216 ;
const integer BLOCK_CODE_SHARADA = 217 ;
const integer BLOCK_CODE_SORA_SOMPENG = 218 ;
const integer BLOCK_CODE_SUNDANESE_SUPPLEMENT = 219 ;
const integer BLOCK_CODE_TAKRI = 220 ;
const integer BLOCK_CODE_COUNT = 221 ;
const integer BLOCK_CODE_INVALID_CODE = -1 ;
const integer BPT_NONE = 0 ;
const integer BPT_OPEN = 1 ;
const integer BPT_CLOSE = 2 ;
const integer BPT_COUNT = 3 ;
const integer EA_NEUTRAL = 0 ;
const integer EA_AMBIGUOUS = 1 ;
const integer EA_HALFWIDTH = 2 ;
const integer EA_FULLWIDTH = 3 ;
const integer EA_NARROW = 4 ;
const integer EA_WIDE = 5 ;
const integer EA_COUNT = 6 ;
const integer UNICODE_CHAR_NAME = 0 ;
const integer UNICODE_10_CHAR_NAME = 1 ;
const integer EXTENDED_CHAR_NAME = 2 ;
const integer CHAR_NAME_ALIAS = 3 ;
const integer CHAR_NAME_CHOICE_COUNT = 4 ;
const integer SHORT_PROPERTY_NAME = 0 ;
const integer LONG_PROPERTY_NAME = 1 ;
const integer PROPERTY_NAME_CHOICE_COUNT = 2 ;
const integer DT_NONE = 0 ;
const integer DT_CANONICAL = 1 ;
const integer DT_COMPAT = 2 ;
const integer DT_CIRCLE = 3 ;
const integer DT_FINAL = 4 ;
const integer DT_FONT = 5 ;
const integer DT_FRACTION = 6 ;
const integer DT_INITIAL = 7 ;
const integer DT_ISOLATED = 8 ;
const integer DT_MEDIAL = 9 ;
const integer DT_NARROW = 10 ;
const integer DT_NOBREAK = 11 ;
const integer DT_SMALL = 12 ;
const integer DT_SQUARE = 13 ;
const integer DT_SUB = 14 ;
const integer DT_SUPER = 15 ;
const integer DT_VERTICAL = 16 ;
const integer DT_WIDE = 17 ;
const integer DT_COUNT = 18 ;
const integer JT_NON_JOINING = 0 ;
const integer JT_JOIN_CAUSING = 1 ;
const integer JT_DUAL_JOINING = 2 ;
const integer JT_LEFT_JOINING = 3 ;
const integer JT_RIGHT_JOINING = 4 ;
const integer JT_TRANSPARENT = 5 ;
const integer JT_COUNT = 6 ;
const integer JG_NO_JOINING_GROUP = 0 ;
const integer JG_AIN = 1 ;
const integer JG_ALAPH = 2 ;
const integer JG_ALEF = 3 ;
const integer JG_BEH = 4 ;
const integer JG_BETH = 5 ;
const integer JG_DAL = 6 ;
const integer JG_DALATH_RISH = 7 ;
const integer JG_E = 8 ;
const integer JG_FEH = 9 ;
const integer JG_FINAL_SEMKATH = 10 ;
const integer JG_GAF = 11 ;
const integer JG_GAMAL = 12 ;
const integer JG_HAH = 13 ;
const integer JG_TEH_MARBUTA_GOAL = 14 ;
const integer JG_HAMZA_ON_HEH_GOAL = 14 ;
const integer JG_HE = 15 ;
const integer JG_HEH = 16 ;
const integer JG_HEH_GOAL = 17 ;
const integer JG_HETH = 18 ;
const integer JG_KAF = 19 ;
const integer JG_KAPH = 20 ;
const integer JG_KNOTTED_HEH = 21 ;
const integer JG_LAM = 22 ;
const integer JG_LAMADH = 23 ;
const integer JG_MEEM = 24 ;
const integer JG_MIM = 25 ;
const integer JG_NOON = 26 ;
const integer JG_NUN = 27 ;
const integer JG_PE = 28 ;
const integer JG_QAF = 29 ;
const integer JG_QAPH = 30 ;
const integer JG_REH = 31 ;
const integer JG_REVERSED_PE = 32 ;
const integer JG_SAD = 33 ;
const integer JG_SADHE = 34 ;
const integer JG_SEEN = 35 ;
const integer JG_SEMKATH = 36 ;
const integer JG_SHIN = 37 ;
const integer JG_SWASH_KAF = 38 ;
const integer JG_SYRIAC_WAW = 39 ;
const integer JG_TAH = 40 ;
const integer JG_TAW = 41 ;
const integer JG_TEH_MARBUTA = 42 ;
const integer JG_TETH = 43 ;
const integer JG_WAW = 44 ;
const integer JG_YEH = 45 ;
const integer JG_YEH_BARREE = 46 ;
const integer JG_YEH_WITH_TAIL = 47 ;
const integer JG_YUDH = 48 ;
const integer JG_YUDH_HE = 49 ;
const integer JG_ZAIN = 50 ;
const integer JG_FE = 51 ;
const integer JG_KHAPH = 52 ;
const integer JG_ZHAIN = 53 ;
const integer JG_BURUSHASKI_YEH_BARREE = 54 ;
const integer JG_FARSI_YEH = 55 ;
const integer JG_NYA = 56 ;
const integer JG_ROHINGYA_YEH = 57 ;
const integer JG_COUNT = 58 ;
const integer GCB_OTHER = 0 ;
const integer GCB_CONTROL = 1 ;
const integer GCB_CR = 2 ;
const integer GCB_EXTEND = 3 ;
const integer GCB_L = 4 ;
const integer GCB_LF = 5 ;
const integer GCB_LV = 6 ;
const integer GCB_LVT = 7 ;
const integer GCB_T = 8 ;
const integer GCB_V = 9 ;
const integer GCB_SPACING_MARK = 10 ;
const integer GCB_PREPEND = 11 ;
const integer GCB_REGIONAL_INDICATOR = 12 ;
const integer GCB_COUNT = 13 ;
const integer WB_OTHER = 0 ;
const integer WB_ALETTER = 1 ;
const integer WB_FORMAT = 2 ;
const integer WB_KATAKANA = 3 ;
const integer WB_MIDLETTER = 4 ;
const integer WB_MIDNUM = 5 ;
const integer WB_NUMERIC = 6 ;
const integer WB_EXTENDNUMLET = 7 ;
const integer WB_CR = 8 ;
const integer WB_EXTEND = 9 ;
const integer WB_LF = 10 ;
const integer WB_MIDNUMLET = 11 ;
const integer WB_NEWLINE = 12 ;
const integer WB_REGIONAL_INDICATOR = 13 ;
const integer WB_HEBREW_LETTER = 14 ;
const integer WB_SINGLE_QUOTE = 15 ;
const integer WB_DOUBLE_QUOTE = 16 ;
const integer WB_COUNT = 17 ;
const integer SB_OTHER = 0 ;
const integer SB_ATERM = 1 ;
const integer SB_CLOSE = 2 ;
const integer SB_FORMAT = 3 ;
const integer SB_LOWER = 4 ;
const integer SB_NUMERIC = 5 ;
const integer SB_OLETTER = 6 ;
const integer SB_SEP = 7 ;
const integer SB_SP = 8 ;
const integer SB_STERM = 9 ;
const integer SB_UPPER = 10 ;
const integer SB_CR = 11 ;
const integer SB_EXTEND = 12 ;
const integer SB_LF = 13 ;
const integer SB_SCONTINUE = 14 ;
const integer SB_COUNT = 15 ;
const integer LB_UNKNOWN = 0 ;
const integer LB_AMBIGUOUS = 1 ;
const integer LB_ALPHABETIC = 2 ;
const integer LB_BREAK_BOTH = 3 ;
const integer LB_BREAK_AFTER = 4 ;
const integer LB_BREAK_BEFORE = 5 ;
const integer LB_MANDATORY_BREAK = 6 ;
const integer LB_CONTINGENT_BREAK = 7 ;
const integer LB_CLOSE_PUNCTUATION = 8 ;
const integer LB_COMBINING_MARK = 9 ;
const integer LB_CARRIAGE_RETURN = 10 ;
const integer LB_EXCLAMATION = 11 ;
const integer LB_GLUE = 12 ;
const integer LB_HYPHEN = 13 ;
const integer LB_IDEOGRAPHIC = 14 ;
const integer LB_INSEPARABLE = 15 ;
const integer LB_INSEPERABLE = 15 ;
const integer LB_INFIX_NUMERIC = 16 ;
const integer LB_LINE_FEED = 17 ;
const integer LB_NONSTARTER = 18 ;
const integer LB_NUMERIC = 19 ;
const integer LB_OPEN_PUNCTUATION = 20 ;
const integer LB_POSTFIX_NUMERIC = 21 ;
const integer LB_PREFIX_NUMERIC = 22 ;
const integer LB_QUOTATION = 23 ;
const integer LB_COMPLEX_CONTEXT = 24 ;
const integer LB_SURROGATE = 25 ;
const integer LB_SPACE = 26 ;
const integer LB_BREAK_SYMBOLS = 27 ;
const integer LB_ZWSPACE = 28 ;
const integer LB_NEXT_LINE = 29 ;
const integer LB_WORD_JOINER = 30 ;
const integer LB_H2 = 31 ;
const integer LB_H3 = 32 ;
const integer LB_JL = 33 ;
const integer LB_JT = 34 ;
const integer LB_JV = 35 ;
const integer LB_CLOSE_PARENTHESIS = 36 ;
const integer LB_CONDITIONAL_JAPANESE_STARTER = 37 ;
const integer LB_HEBREW_LETTER = 38 ;
const integer LB_REGIONAL_INDICATOR = 39 ;
const integer LB_COUNT = 40 ;
const integer NT_NONE = 0 ;
const integer NT_DECIMAL = 1 ;
const integer NT_DIGIT = 2 ;
const integer NT_NUMERIC = 3 ;
const integer NT_COUNT = 4 ;
const integer HST_NOT_APPLICABLE = 0 ;
const integer HST_LEADING_JAMO = 1 ;
const integer HST_VOWEL_JAMO = 2 ;
const integer HST_TRAILING_JAMO = 3 ;
const integer HST_LV_SYLLABLE = 4 ;
const integer HST_LVT_SYLLABLE = 5 ;
const integer HST_COUNT = 6 ;
/* Métodos */
public static charAge ( mixed $codepoint ) : array
public static charDigitValue ( mixed $codepoint ) : int
public static charDirection ( mixed $codepoint ) : int
public static charFromName ( string $characterName , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : int
public static charMirror ( mixed $codepoint ) : mixed
public static charName ( mixed $codepoint , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : string
public static charType ( mixed $codepoint ) : int
public static chr ( mixed $codepoint ) : string
public static digit ( string $codepoint , int $radix = 10 ) : int
public static enumCharNames ( mixed $start , mixed $limit , callable $callback , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : void
public static enumCharTypes ( callable $callback ) : void
public static foldCase ( mixed $codepoint , int $options = IntlChar::FOLD_CASE_DEFAULT ) : mixed
public static forDigit ( int $digit , int $radix = 10 ) : int
public static getBidiPairedBracket ( mixed $codepoint ) : mixed
public static getBlockCode ( mixed $codepoint ) : int
public static getCombiningClass ( mixed $codepoint ) : int
public static getFC_NFKC_Closure ( mixed $codepoint ) : string
public static getIntPropertyMaxValue ( int $property ) : int
public static getIntPropertyMinValue ( int $property ) : int
public static getIntPropertyValue ( mixed $codepoint , int $property ) : int
public static getNumericValue ( mixed $codepoint ) : float
public static getPropertyEnum ( string $alias ) : int
public static getPropertyName ( int $property , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string
public static getPropertyValueEnum ( int $property , string $name ) : int
public static getPropertyValueName ( int $property , int $value , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string
public static getUnicodeVersion ( ) : array
public static hasBinaryProperty ( mixed $codepoint , int $property ) : bool
public static isalnum ( mixed $codepoint ) : bool
public static isalpha ( mixed $codepoint ) : bool
public static isbase ( mixed $codepoint ) : bool
public static isblank ( mixed $codepoint ) : bool
public static iscntrl ( mixed $codepoint ) : bool
public static isdefined ( mixed $codepoint ) : bool
public static isdigit ( mixed $codepoint ) : bool
public static isgraph ( mixed $codepoint ) : bool
public static isIDIgnorable ( mixed $codepoint ) : bool
public static isIDPart ( mixed $codepoint ) : bool
public static isIDStart ( mixed $codepoint ) : bool
public static isISOControl ( mixed $codepoint ) : bool
public static isJavaIDPart ( mixed $codepoint ) : bool
public static isJavaIDStart ( mixed $codepoint ) : bool
public static isJavaSpaceChar ( mixed $codepoint ) : bool
public static islower ( mixed $codepoint ) : bool
public static isMirrored ( mixed $codepoint ) : bool
public static isprint ( mixed $codepoint ) : bool
public static ispunct ( mixed $codepoint ) : bool
public static isspace ( mixed $codepoint ) : bool
public static istitle ( mixed $codepoint ) : bool
public static isUAlphabetic ( mixed $codepoint ) : bool
public static isULowercase ( mixed $codepoint ) : bool
public static isupper ( mixed $codepoint ) : bool
public static isUUppercase ( mixed $codepoint ) : bool
public static isUWhiteSpace ( mixed $codepoint ) : bool
public static isWhitespace ( mixed $codepoint ) : bool
public static isxdigit ( mixed $codepoint ) : bool
public static ord ( mixed $character ) : int
public static tolower ( mixed $codepoint ) : mixed
public static totitle ( mixed $codepoint ) : mixed
public static toupper ( mixed $codepoint ) : mixed
}

Constantes predefinidas

IntlChar::UNICODE_VERSION

IntlChar::CODEPOINT_MIN

IntlChar::CODEPOINT_MAX

IntlChar::PROPERTY_ALPHABETIC

IntlChar::PROPERTY_BINARY_START

IntlChar::PROPERTY_ASCII_HEX_DIGIT

IntlChar::PROPERTY_BIDI_CONTROL

IntlChar::PROPERTY_BIDI_MIRRORED

IntlChar::PROPERTY_DASH

IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT

IntlChar::PROPERTY_DEPRECATED

IntlChar::PROPERTY_DIACRITIC

IntlChar::PROPERTY_EXTENDER

IntlChar::PROPERTY_FULL_COMPOSITION_EXCLUSION

IntlChar::PROPERTY_GRAPHEME_BASE

IntlChar::PROPERTY_GRAPHEME_EXTEND

IntlChar::PROPERTY_GRAPHEME_LINK

IntlChar::PROPERTY_HEX_DIGIT

IntlChar::PROPERTY_HYPHEN

IntlChar::PROPERTY_ID_CONTINUE

IntlChar::PROPERTY_ID_START

IntlChar::PROPERTY_IDEOGRAPHIC

IntlChar::PROPERTY_IDS_BINARY_OPERATOR

IntlChar::PROPERTY_IDS_TRINARY_OPERATOR

IntlChar::PROPERTY_JOIN_CONTROL

IntlChar::PROPERTY_LOGICAL_ORDER_EXCEPTION

IntlChar::PROPERTY_LOWERCASE

IntlChar::PROPERTY_MATH

IntlChar::PROPERTY_NONCHARACTER_CODE_POINT

IntlChar::PROPERTY_QUOTATION_MARK

IntlChar::PROPERTY_RADICAL

IntlChar::PROPERTY_SOFT_DOTTED

IntlChar::PROPERTY_TERMINAL_PUNCTUATION

IntlChar::PROPERTY_UNIFIED_IDEOGRAPH

IntlChar::PROPERTY_UPPERCASE

IntlChar::PROPERTY_WHITE_SPACE

IntlChar::PROPERTY_XID_CONTINUE

IntlChar::PROPERTY_XID_START

IntlChar::PROPERTY_CASE_SENSITIVE

IntlChar::PROPERTY_S_TERM

IntlChar::PROPERTY_VARIATION_SELECTOR

IntlChar::PROPERTY_NFD_INERT

IntlChar::PROPERTY_NFKD_INERT

IntlChar::PROPERTY_NFC_INERT

IntlChar::PROPERTY_NFKC_INERT

IntlChar::PROPERTY_SEGMENT_STARTER

IntlChar::PROPERTY_PATTERN_SYNTAX

IntlChar::PROPERTY_PATTERN_WHITE_SPACE

IntlChar::PROPERTY_POSIX_ALNUM

IntlChar::PROPERTY_POSIX_BLANK

IntlChar::PROPERTY_POSIX_GRAPH

IntlChar::PROPERTY_POSIX_PRINT

IntlChar::PROPERTY_POSIX_XDIGIT

IntlChar::PROPERTY_CASED

IntlChar::PROPERTY_CASE_IGNORABLE

IntlChar::PROPERTY_CHANGES_WHEN_LOWERCASED

IntlChar::PROPERTY_CHANGES_WHEN_UPPERCASED

IntlChar::PROPERTY_CHANGES_WHEN_TITLECASED

IntlChar::PROPERTY_CHANGES_WHEN_CASEFOLDED

IntlChar::PROPERTY_CHANGES_WHEN_CASEMAPPED

IntlChar::PROPERTY_CHANGES_WHEN_NFKC_CASEFOLDED

IntlChar::PROPERTY_BINARY_LIMIT

IntlChar::PROPERTY_BIDI_CLASS

IntlChar::PROPERTY_INT_START

IntlChar::PROPERTY_BLOCK

IntlChar::PROPERTY_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_DECOMPOSITION_TYPE

IntlChar::PROPERTY_EAST_ASIAN_WIDTH

IntlChar::PROPERTY_GENERAL_CATEGORY

IntlChar::PROPERTY_JOINING_GROUP

IntlChar::PROPERTY_JOINING_TYPE

IntlChar::PROPERTY_LINE_BREAK

IntlChar::PROPERTY_NUMERIC_TYPE

IntlChar::PROPERTY_SCRIPT

IntlChar::PROPERTY_HANGUL_SYLLABLE_TYPE

IntlChar::PROPERTY_NFD_QUICK_CHECK

IntlChar::PROPERTY_NFKD_QUICK_CHECK

IntlChar::PROPERTY_NFC_QUICK_CHECK

IntlChar::PROPERTY_NFKC_QUICK_CHECK

IntlChar::PROPERTY_LEAD_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_TRAIL_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_GRAPHEME_CLUSTER_BREAK

IntlChar::PROPERTY_SENTENCE_BREAK

IntlChar::PROPERTY_WORD_BREAK

IntlChar::PROPERTY_BIDI_PAIRED_BRACKET_TYPE

IntlChar::PROPERTY_INT_LIMIT

IntlChar::PROPERTY_GENERAL_CATEGORY_MASK

IntlChar::PROPERTY_MASK_START

IntlChar::PROPERTY_MASK_LIMIT

IntlChar::PROPERTY_NUMERIC_VALUE

IntlChar::PROPERTY_DOUBLE_START

IntlChar::PROPERTY_DOUBLE_LIMIT

IntlChar::PROPERTY_AGE

IntlChar::PROPERTY_STRING_START

IntlChar::PROPERTY_BIDI_MIRRORING_GLYPH

IntlChar::PROPERTY_CASE_FOLDING

IntlChar::PROPERTY_ISO_COMMENT

IntlChar::PROPERTY_LOWERCASE_MAPPING

IntlChar::PROPERTY_NAME

IntlChar::PROPERTY_SIMPLE_CASE_FOLDING

IntlChar::PROPERTY_SIMPLE_LOWERCASE_MAPPING

IntlChar::PROPERTY_SIMPLE_TITLECASE_MAPPING

IntlChar::PROPERTY_SIMPLE_UPPERCASE_MAPPING

IntlChar::PROPERTY_TITLECASE_MAPPING

IntlChar::PROPERTY_UNICODE_1_NAME

IntlChar::PROPERTY_UPPERCASE_MAPPING

IntlChar::PROPERTY_BIDI_PAIRED_BRACKET

IntlChar::PROPERTY_STRING_LIMIT

IntlChar::PROPERTY_SCRIPT_EXTENSIONS

IntlChar::PROPERTY_OTHER_PROPERTY_START

IntlChar::PROPERTY_OTHER_PROPERTY_LIMIT

IntlChar::PROPERTY_INVALID_CODE

IntlChar::CHAR_CATEGORY_UNASSIGNED

IntlChar::CHAR_CATEGORY_GENERAL_OTHER_TYPES

IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER

IntlChar::CHAR_CATEGORY_LOWERCASE_LETTER

IntlChar::CHAR_CATEGORY_TITLECASE_LETTER

IntlChar::CHAR_CATEGORY_MODIFIER_LETTER

IntlChar::CHAR_CATEGORY_OTHER_LETTER

IntlChar::CHAR_CATEGORY_NON_SPACING_MARK

IntlChar::CHAR_CATEGORY_ENCLOSING_MARK

IntlChar::CHAR_CATEGORY_COMBINING_SPACING_MARK

IntlChar::CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER

IntlChar::CHAR_CATEGORY_LETTER_NUMBER

IntlChar::CHAR_CATEGORY_OTHER_NUMBER

IntlChar::CHAR_CATEGORY_SPACE_SEPARATOR

IntlChar::CHAR_CATEGORY_LINE_SEPARATOR

IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR

IntlChar::CHAR_CATEGORY_CONTROL_CHAR

IntlChar::CHAR_CATEGORY_FORMAT_CHAR

IntlChar::CHAR_CATEGORY_PRIVATE_USE_CHAR

IntlChar::CHAR_CATEGORY_SURROGATE

IntlChar::CHAR_CATEGORY_DASH_PUNCTUATION

IntlChar::CHAR_CATEGORY_START_PUNCTUATION

IntlChar::CHAR_CATEGORY_END_PUNCTUATION

IntlChar::CHAR_CATEGORY_CONNECTOR_PUNCTUATION

IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION

IntlChar::CHAR_CATEGORY_MATH_SYMBOL

IntlChar::CHAR_CATEGORY_CURRENCY_SYMBOL

IntlChar::CHAR_CATEGORY_MODIFIER_SYMBOL

IntlChar::CHAR_CATEGORY_OTHER_SYMBOL

IntlChar::CHAR_CATEGORY_INITIAL_PUNCTUATION

IntlChar::CHAR_CATEGORY_FINAL_PUNCTUATION

IntlChar::CHAR_CATEGORY_CHAR_CATEGORY_COUNT

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR

IntlChar::CHAR_DIRECTION_ARABIC_NUMBER

IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR

IntlChar::CHAR_DIRECTION_BLOCK_SEPARATOR

IntlChar::CHAR_DIRECTION_SEGMENT_SEPARATOR

IntlChar::CHAR_DIRECTION_WHITE_SPACE_NEUTRAL

IntlChar::CHAR_DIRECTION_OTHER_NEUTRAL

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE

IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT

IntlChar::CHAR_DIRECTION_DIR_NON_SPACING_MARK

IntlChar::CHAR_DIRECTION_BOUNDARY_NEUTRAL

IntlChar::CHAR_DIRECTION_FIRST_STRONG_ISOLATE

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE

IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE

IntlChar::CHAR_DIRECTION_CHAR_DIRECTION_COUNT

IntlChar::BLOCK_CODE_NO_BLOCK

IntlChar::BLOCK_CODE_BASIC_LATIN

IntlChar::BLOCK_CODE_LATIN_1_SUPPLEMENT

IntlChar::BLOCK_CODE_LATIN_EXTENDED_A

IntlChar::BLOCK_CODE_LATIN_EXTENDED_B

IntlChar::BLOCK_CODE_IPA_EXTENSIONS

IntlChar::BLOCK_CODE_SPACING_MODIFIER_LETTERS

IntlChar::BLOCK_CODE_COMBINING_DIACRITICAL_MARKS

IntlChar::BLOCK_CODE_GREEK

IntlChar::BLOCK_CODE_CYRILLIC

IntlChar::BLOCK_CODE_ARMENIAN

IntlChar::BLOCK_CODE_HEBREW

IntlChar::BLOCK_CODE_ARABIC

IntlChar::BLOCK_CODE_SYRIAC

IntlChar::BLOCK_CODE_THAANA

IntlChar::BLOCK_CODE_DEVANAGARI

IntlChar::BLOCK_CODE_BENGALI

IntlChar::BLOCK_CODE_GURMUKHI

IntlChar::BLOCK_CODE_GUJARATI

IntlChar::BLOCK_CODE_ORIYA

IntlChar::BLOCK_CODE_TAMIL

IntlChar::BLOCK_CODE_TELUGU

IntlChar::BLOCK_CODE_KANNADA

IntlChar::BLOCK_CODE_MALAYALAM

IntlChar::BLOCK_CODE_SINHALA

IntlChar::BLOCK_CODE_THAI

IntlChar::BLOCK_CODE_LAO

IntlChar::BLOCK_CODE_TIBETAN

IntlChar::BLOCK_CODE_MYANMAR

IntlChar::BLOCK_CODE_GEORGIAN

IntlChar::BLOCK_CODE_HANGUL_JAMO

IntlChar::BLOCK_CODE_ETHIOPIC

IntlChar::BLOCK_CODE_CHEROKEE

IntlChar::BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS

IntlChar::BLOCK_CODE_OGHAM

IntlChar::BLOCK_CODE_RUNIC

IntlChar::BLOCK_CODE_KHMER

IntlChar::BLOCK_CODE_MONGOLIAN

IntlChar::BLOCK_CODE_LATIN_EXTENDED_ADDITIONAL

IntlChar::BLOCK_CODE_GREEK_EXTENDED

IntlChar::BLOCK_CODE_GENERAL_PUNCTUATION

IntlChar::BLOCK_CODE_SUPERSCRIPTS_AND_SUBSCRIPTS

IntlChar::BLOCK_CODE_CURRENCY_SYMBOLS

IntlChar::BLOCK_CODE_COMBINING_MARKS_FOR_SYMBOLS

IntlChar::BLOCK_CODE_LETTERLIKE_SYMBOLS

IntlChar::BLOCK_CODE_NUMBER_FORMS

IntlChar::BLOCK_CODE_ARROWS

IntlChar::BLOCK_CODE_MATHEMATICAL_OPERATORS

IntlChar::BLOCK_CODE_MISCELLANEOUS_TECHNICAL

IntlChar::BLOCK_CODE_CONTROL_PICTURES

IntlChar::BLOCK_CODE_OPTICAL_CHARACTER_RECOGNITION

IntlChar::BLOCK_CODE_ENCLOSED_ALPHANUMERICS

IntlChar::BLOCK_CODE_BOX_DRAWING

IntlChar::BLOCK_CODE_BLOCK_ELEMENTS

IntlChar::BLOCK_CODE_GEOMETRIC_SHAPES

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS

IntlChar::BLOCK_CODE_DINGBATS

IntlChar::BLOCK_CODE_BRAILLE_PATTERNS

IntlChar::BLOCK_CODE_CJK_RADICALS_SUPPLEMENT

IntlChar::BLOCK_CODE_KANGXI_RADICALS

IntlChar::BLOCK_CODE_IDEOGRAPHIC_DESCRIPTION_CHARACTERS

IntlChar::BLOCK_CODE_CJK_SYMBOLS_AND_PUNCTUATION

IntlChar::BLOCK_CODE_HIRAGANA

IntlChar::BLOCK_CODE_KATAKANA

IntlChar::BLOCK_CODE_BOPOMOFO

IntlChar::BLOCK_CODE_HANGUL_COMPATIBILITY_JAMO

IntlChar::BLOCK_CODE_KANBUN

IntlChar::BLOCK_CODE_BOPOMOFO_EXTENDED

IntlChar::BLOCK_CODE_ENCLOSED_CJK_LETTERS_AND_MONTHS

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS

IntlChar::BLOCK_CODE_YI_SYLLABLES

IntlChar::BLOCK_CODE_YI_RADICALS

IntlChar::BLOCK_CODE_HANGUL_SYLLABLES

IntlChar::BLOCK_CODE_HIGH_SURROGATES

IntlChar::BLOCK_CODE_HIGH_PRIVATE_USE_SURROGATES

IntlChar::BLOCK_CODE_LOW_SURROGATES

IntlChar::BLOCK_CODE_PRIVATE_USE_AREA

IntlChar::BLOCK_CODE_PRIVATE_USE

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS

IntlChar::BLOCK_CODE_ALPHABETIC_PRESENTATION_FORMS

IntlChar::BLOCK_CODE_ARABIC_PRESENTATION_FORMS_A

IntlChar::BLOCK_CODE_COMBINING_HALF_MARKS

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_FORMS

IntlChar::BLOCK_CODE_SMALL_FORM_VARIANTS

IntlChar::BLOCK_CODE_ARABIC_PRESENTATION_FORMS_B

IntlChar::BLOCK_CODE_SPECIALS

IntlChar::BLOCK_CODE_HALFWIDTH_AND_FULLWIDTH_FORMS

IntlChar::BLOCK_CODE_OLD_ITALIC

IntlChar::BLOCK_CODE_GOTHIC

IntlChar::BLOCK_CODE_DESERET

IntlChar::BLOCK_CODE_BYZANTINE_MUSICAL_SYMBOLS

IntlChar::BLOCK_CODE_MUSICAL_SYMBOLS

IntlChar::BLOCK_CODE_MATHEMATICAL_ALPHANUMERIC_SYMBOLS

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT

IntlChar::BLOCK_CODE_TAGS

IntlChar::BLOCK_CODE_CYRILLIC_SUPPLEMENT

IntlChar::BLOCK_CODE_CYRILLIC_SUPPLEMENTARY

IntlChar::BLOCK_CODE_TAGALOG

IntlChar::BLOCK_CODE_HANUNOO

IntlChar::BLOCK_CODE_BUHID

IntlChar::BLOCK_CODE_TAGBANWA

IntlChar::BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A

IntlChar::BLOCK_CODE_SUPPLEMENTAL_ARROWS_A

IntlChar::BLOCK_CODE_SUPPLEMENTAL_ARROWS_B

IntlChar::BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B

IntlChar::BLOCK_CODE_SUPPLEMENTAL_MATHEMATICAL_OPERATORS

IntlChar::BLOCK_CODE_KATAKANA_PHONETIC_EXTENSIONS

IntlChar::BLOCK_CODE_VARIATION_SELECTORS

IntlChar::BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_A

IntlChar::BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_B

IntlChar::BLOCK_CODE_LIMBU

IntlChar::BLOCK_CODE_TAI_LE

IntlChar::BLOCK_CODE_KHMER_SYMBOLS

IntlChar::BLOCK_CODE_PHONETIC_EXTENSIONS

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_ARROWS

IntlChar::BLOCK_CODE_YIJING_HEXAGRAM_SYMBOLS

IntlChar::BLOCK_CODE_LINEAR_B_SYLLABARY

IntlChar::BLOCK_CODE_LINEAR_B_IDEOGRAMS

IntlChar::BLOCK_CODE_AEGEAN_NUMBERS

IntlChar::BLOCK_CODE_UGARITIC

IntlChar::BLOCK_CODE_SHAVIAN

IntlChar::BLOCK_CODE_OSMANYA

IntlChar::BLOCK_CODE_CYPRIOT_SYLLABARY

IntlChar::BLOCK_CODE_TAI_XUAN_JING_SYMBOLS

IntlChar::BLOCK_CODE_VARIATION_SELECTORS_SUPPLEMENT

IntlChar::BLOCK_CODE_ANCIENT_GREEK_MUSICAL_NOTATION

IntlChar::BLOCK_CODE_ANCIENT_GREEK_NUMBERS

IntlChar::BLOCK_CODE_ARABIC_SUPPLEMENT

IntlChar::BLOCK_CODE_BUGINESE

IntlChar::BLOCK_CODE_CJK_STROKES

IntlChar::BLOCK_CODE_COMBINING_DIACRITICAL_MARKS_SUPPLEMENT

IntlChar::BLOCK_CODE_COPTIC

IntlChar::BLOCK_CODE_ETHIOPIC_EXTENDED

IntlChar::BLOCK_CODE_ETHIOPIC_SUPPLEMENT

IntlChar::BLOCK_CODE_GEORGIAN_SUPPLEMENT

IntlChar::BLOCK_CODE_GLAGOLITIC

IntlChar::BLOCK_CODE_KHAROSHTHI

IntlChar::BLOCK_CODE_MODIFIER_TONE_LETTERS

IntlChar::BLOCK_CODE_NEW_TAI_LUE

IntlChar::BLOCK_CODE_OLD_PERSIAN

IntlChar::BLOCK_CODE_PHONETIC_EXTENSIONS_SUPPLEMENT

IntlChar::BLOCK_CODE_SUPPLEMENTAL_PUNCTUATION

IntlChar::BLOCK_CODE_SYLOTI_NAGRI

IntlChar::BLOCK_CODE_TIFINAGH

IntlChar::BLOCK_CODE_VERTICAL_FORMS

IntlChar::BLOCK_CODE_NKO

IntlChar::BLOCK_CODE_BALINESE

IntlChar::BLOCK_CODE_LATIN_EXTENDED_C

IntlChar::BLOCK_CODE_LATIN_EXTENDED_D

IntlChar::BLOCK_CODE_PHAGS_PA

IntlChar::BLOCK_CODE_PHOENICIAN

IntlChar::BLOCK_CODE_CUNEIFORM

IntlChar::BLOCK_CODE_CUNEIFORM_NUMBERS_AND_PUNCTUATION

IntlChar::BLOCK_CODE_COUNTING_ROD_NUMERALS

IntlChar::BLOCK_CODE_SUNDANESE

IntlChar::BLOCK_CODE_LEPCHA

IntlChar::BLOCK_CODE_OL_CHIKI

IntlChar::BLOCK_CODE_CYRILLIC_EXTENDED_A

IntlChar::BLOCK_CODE_VAI

IntlChar::BLOCK_CODE_CYRILLIC_EXTENDED_B

IntlChar::BLOCK_CODE_SAURASHTRA

IntlChar::BLOCK_CODE_KAYAH_LI

IntlChar::BLOCK_CODE_REJANG

IntlChar::BLOCK_CODE_CHAM

IntlChar::BLOCK_CODE_ANCIENT_SYMBOLS

IntlChar::BLOCK_CODE_PHAISTOS_DISC

IntlChar::BLOCK_CODE_LYCIAN

IntlChar::BLOCK_CODE_CARIAN

IntlChar::BLOCK_CODE_LYDIAN

IntlChar::BLOCK_CODE_MAHJONG_TILES

IntlChar::BLOCK_CODE_DOMINO_TILES

IntlChar::BLOCK_CODE_SAMARITAN

IntlChar::BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED

IntlChar::BLOCK_CODE_TAI_THAM

IntlChar::BLOCK_CODE_VEDIC_EXTENSIONS

IntlChar::BLOCK_CODE_LISU

IntlChar::BLOCK_CODE_BAMUM

IntlChar::BLOCK_CODE_COMMON_INDIC_NUMBER_FORMS

IntlChar::BLOCK_CODE_DEVANAGARI_EXTENDED

IntlChar::BLOCK_CODE_HANGUL_JAMO_EXTENDED_A

IntlChar::BLOCK_CODE_JAVANESE

IntlChar::BLOCK_CODE_MYANMAR_EXTENDED_A

IntlChar::BLOCK_CODE_TAI_VIET

IntlChar::BLOCK_CODE_MEETEI_MAYEK

IntlChar::BLOCK_CODE_HANGUL_JAMO_EXTENDED_B

IntlChar::BLOCK_CODE_IMPERIAL_ARAMAIC

IntlChar::BLOCK_CODE_OLD_SOUTH_ARABIAN

IntlChar::BLOCK_CODE_AVESTAN

IntlChar::BLOCK_CODE_INSCRIPTIONAL_PARTHIAN

IntlChar::BLOCK_CODE_INSCRIPTIONAL_PAHLAVI

IntlChar::BLOCK_CODE_OLD_TURKIC

IntlChar::BLOCK_CODE_RUMI_NUMERAL_SYMBOLS

IntlChar::BLOCK_CODE_KAITHI

IntlChar::BLOCK_CODE_EGYPTIAN_HIEROGLYPHS

IntlChar::BLOCK_CODE_ENCLOSED_ALPHANUMERIC_SUPPLEMENT

IntlChar::BLOCK_CODE_ENCLOSED_IDEOGRAPHIC_SUPPLEMENT

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C

IntlChar::BLOCK_CODE_MANDAIC

IntlChar::BLOCK_CODE_BATAK

IntlChar::BLOCK_CODE_ETHIOPIC_EXTENDED_A

IntlChar::BLOCK_CODE_BRAHMI

IntlChar::BLOCK_CODE_BAMUM_SUPPLEMENT

IntlChar::BLOCK_CODE_KANA_SUPPLEMENT

IntlChar::BLOCK_CODE_PLAYING_CARDS

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS

IntlChar::BLOCK_CODE_EMOTICONS

IntlChar::BLOCK_CODE_TRANSPORT_AND_MAP_SYMBOLS

IntlChar::BLOCK_CODE_ALCHEMICAL_SYMBOLS

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D

IntlChar::BLOCK_CODE_ARABIC_EXTENDED_A

IntlChar::BLOCK_CODE_ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS

IntlChar::BLOCK_CODE_CHAKMA

IntlChar::BLOCK_CODE_MEETEI_MAYEK_EXTENSIONS

IntlChar::BLOCK_CODE_MEROITIC_CURSIVE

IntlChar::BLOCK_CODE_MEROITIC_HIEROGLYPHS

IntlChar::BLOCK_CODE_MIAO

IntlChar::BLOCK_CODE_SHARADA

IntlChar::BLOCK_CODE_SORA_SOMPENG

IntlChar::BLOCK_CODE_SUNDANESE_SUPPLEMENT

IntlChar::BLOCK_CODE_TAKRI

IntlChar::BLOCK_CODE_COUNT

IntlChar::BLOCK_CODE_INVALID_CODE

IntlChar::BPT_NONE

IntlChar::BPT_OPEN

IntlChar::BPT_CLOSE

IntlChar::BPT_COUNT

IntlChar::EA_NEUTRAL

IntlChar::EA_AMBIGUOUS

IntlChar::EA_HALFWIDTH

IntlChar::EA_FULLWIDTH

IntlChar::EA_NARROW

IntlChar::EA_WIDE

IntlChar::EA_COUNT

IntlChar::UNICODE_CHAR_NAME

IntlChar::UNICODE_10_CHAR_NAME

IntlChar::EXTENDED_CHAR_NAME

IntlChar::CHAR_NAME_ALIAS

IntlChar::CHAR_NAME_CHOICE_COUNT

IntlChar::SHORT_PROPERTY_NAME

IntlChar::LONG_PROPERTY_NAME

IntlChar::PROPERTY_NAME_CHOICE_COUNT

IntlChar::DT_NONE

IntlChar::DT_CANONICAL

IntlChar::DT_COMPAT

IntlChar::DT_CIRCLE

IntlChar::DT_FINAL

IntlChar::DT_FONT

IntlChar::DT_FRACTION

IntlChar::DT_INITIAL

IntlChar::DT_ISOLATED

IntlChar::DT_MEDIAL

IntlChar::DT_NARROW

IntlChar::DT_NOBREAK

IntlChar::DT_SMALL

IntlChar::DT_SQUARE

IntlChar::DT_SUB

IntlChar::DT_SUPER

IntlChar::DT_VERTICAL

IntlChar::DT_WIDE

IntlChar::DT_COUNT

IntlChar::JT_NON_JOINING

IntlChar::JT_JOIN_CAUSING

IntlChar::JT_DUAL_JOINING

IntlChar::JT_LEFT_JOINING

IntlChar::JT_RIGHT_JOINING

IntlChar::JT_TRANSPARENT

IntlChar::JT_COUNT

IntlChar::JG_NO_JOINING_GROUP

IntlChar::JG_AIN

IntlChar::JG_ALAPH

IntlChar::JG_ALEF

IntlChar::JG_BEH

IntlChar::JG_BETH

IntlChar::JG_DAL

IntlChar::JG_DALATH_RISH

IntlChar::JG_E

IntlChar::JG_FEH

IntlChar::JG_FINAL_SEMKATH

IntlChar::JG_GAF

IntlChar::JG_GAMAL

IntlChar::JG_HAH

IntlChar::JG_TEH_MARBUTA_GOAL

IntlChar::JG_HAMZA_ON_HEH_GOAL

IntlChar::JG_HE

IntlChar::JG_HEH

IntlChar::JG_HEH_GOAL

IntlChar::JG_HETH

IntlChar::JG_KAF

IntlChar::JG_KAPH

IntlChar::JG_KNOTTED_HEH

IntlChar::JG_LAM

IntlChar::JG_LAMADH

IntlChar::JG_MEEM

IntlChar::JG_MIM

IntlChar::JG_NOON

IntlChar::JG_NUN

IntlChar::JG_PE

IntlChar::JG_QAF

IntlChar::JG_QAPH

IntlChar::JG_REH

IntlChar::JG_REVERSED_PE

IntlChar::JG_SAD

IntlChar::JG_SADHE

IntlChar::JG_SEEN

IntlChar::JG_SEMKATH

IntlChar::JG_SHIN

IntlChar::JG_SWASH_KAF

IntlChar::JG_SYRIAC_WAW

IntlChar::JG_TAH

IntlChar::JG_TAW

IntlChar::JG_TEH_MARBUTA

IntlChar::JG_TETH

IntlChar::JG_WAW

IntlChar::JG_YEH

IntlChar::JG_YEH_BARREE

IntlChar::JG_YEH_WITH_TAIL

IntlChar::JG_YUDH

IntlChar::JG_YUDH_HE

IntlChar::JG_ZAIN

IntlChar::JG_FE

IntlChar::JG_KHAPH

IntlChar::JG_ZHAIN

IntlChar::JG_BURUSHASKI_YEH_BARREE

IntlChar::JG_FARSI_YEH

IntlChar::JG_NYA

IntlChar::JG_ROHINGYA_YEH

IntlChar::JG_COUNT

IntlChar::GCB_OTHER

IntlChar::GCB_CONTROL

IntlChar::GCB_CR

IntlChar::GCB_EXTEND

IntlChar::GCB_L

IntlChar::GCB_LF

IntlChar::GCB_LV

IntlChar::GCB_LVT

IntlChar::GCB_T

IntlChar::GCB_V

IntlChar::GCB_SPACING_MARK

IntlChar::GCB_PREPEND

IntlChar::GCB_REGIONAL_INDICATOR

IntlChar::GCB_COUNT

IntlChar::WB_OTHER

IntlChar::WB_ALETTER

IntlChar::WB_FORMAT

IntlChar::WB_KATAKANA

IntlChar::WB_MIDLETTER

IntlChar::WB_MIDNUM

IntlChar::WB_NUMERIC

IntlChar::WB_EXTENDNUMLET

IntlChar::WB_CR

IntlChar::WB_EXTEND

IntlChar::WB_LF

IntlChar::WB_MIDNUMLET

IntlChar::WB_NEWLINE

IntlChar::WB_REGIONAL_INDICATOR

IntlChar::WB_HEBREW_LETTER

IntlChar::WB_SINGLE_QUOTE

IntlChar::WB_DOUBLE_QUOTE

IntlChar::WB_COUNT

IntlChar::SB_OTHER

IntlChar::SB_ATERM

IntlChar::SB_CLOSE

IntlChar::SB_FORMAT

IntlChar::SB_LOWER

IntlChar::SB_NUMERIC

IntlChar::SB_OLETTER

IntlChar::SB_SEP

IntlChar::SB_SP

IntlChar::SB_STERM

IntlChar::SB_UPPER

IntlChar::SB_CR

IntlChar::SB_EXTEND

IntlChar::SB_LF

IntlChar::SB_SCONTINUE

IntlChar::SB_COUNT

IntlChar::LB_UNKNOWN

IntlChar::LB_AMBIGUOUS

IntlChar::LB_ALPHABETIC

IntlChar::LB_BREAK_BOTH

IntlChar::LB_BREAK_AFTER

IntlChar::LB_BREAK_BEFORE

IntlChar::LB_MANDATORY_BREAK

IntlChar::LB_CONTINGENT_BREAK

IntlChar::LB_CLOSE_PUNCTUATION

IntlChar::LB_COMBINING_MARK

IntlChar::LB_CARRIAGE_RETURN

IntlChar::LB_EXCLAMATION

IntlChar::LB_GLUE

IntlChar::LB_HYPHEN

IntlChar::LB_IDEOGRAPHIC

IntlChar::LB_INSEPARABLE

IntlChar::LB_INSEPERABLE

IntlChar::LB_INFIX_NUMERIC

IntlChar::LB_LINE_FEED

IntlChar::LB_NONSTARTER

IntlChar::LB_NUMERIC

IntlChar::LB_OPEN_PUNCTUATION

IntlChar::LB_POSTFIX_NUMERIC

IntlChar::LB_PREFIX_NUMERIC

IntlChar::LB_QUOTATION

IntlChar::LB_COMPLEX_CONTEXT

IntlChar::LB_SURROGATE

IntlChar::LB_SPACE

IntlChar::LB_BREAK_SYMBOLS

IntlChar::LB_ZWSPACE

IntlChar::LB_NEXT_LINE

IntlChar::LB_WORD_JOINER

IntlChar::LB_H2

IntlChar::LB_H3

IntlChar::LB_JL

IntlChar::LB_JT

IntlChar::LB_JV

IntlChar::LB_CLOSE_PARENTHESIS

IntlChar::LB_CONDITIONAL_JAPANESE_STARTER

IntlChar::LB_HEBREW_LETTER

IntlChar::LB_REGIONAL_INDICATOR

IntlChar::LB_COUNT

IntlChar::NT_NONE

IntlChar::NT_DECIMAL

IntlChar::NT_DIGIT

IntlChar::NT_NUMERIC

IntlChar::NT_COUNT

IntlChar::HST_NOT_APPLICABLE

IntlChar::HST_LEADING_JAMO

IntlChar::HST_VOWEL_JAMO

IntlChar::HST_TRAILING_JAMO

IntlChar::HST_LV_SYLLABLE

IntlChar::HST_LVT_SYLLABLE

IntlChar::HST_COUNT

IntlChar::FOLD_CASE_DEFAULT

IntlChar::FOLD_CASE_EXCLUDE_SPECIAL_I

Tabla de contenidos

  • IntlChar::charAge — Obtener la «edad» del punto de código
  • IntlChar::charDigitValue — Obtener el valor del dígito decimal de un carácter de dígito decimal
  • IntlChar::charDirection — Obtener el valor de la categoría bidireccional de un punto de código
  • IntlChar::charFromName — Buscar un carácter Unicode por su nombre y devolver su valor de punto de código
  • IntlChar::charMirror — Obtener el carácter de «imagen reflejada» de un punto de código
  • IntlChar::charName — Obtener el nombre de un carácter Unicode
  • IntlChar::charType — Obtener el valor de la categoría general de un punto de código
  • IntlChar::chr — Devolver el carácter Unicode mediante su valor de punto de código
  • IntlChar::digit — Obtener el valor del dígito decimal de un punto de código para una base dada
  • IntlChar::enumCharNames — Enumerar todos los caracteres de Unicode con asignación dentro de un rango
  • IntlChar::enumCharTypes — Enumerar todos los puntos de código con sus categorías generales de Unicode
  • IntlChar::foldCase — Realiza un «plegamiento» de un punto de código
  • IntlChar::forDigit — Obtener la representación de un carácter para un dígito y base dados
  • IntlChar::getBidiPairedBracket — Obtener la pareja del carácter parentético de un punto de código
  • IntlChar::getBlockCode — Obtener el bloque de asignación de Unicode que contiene a un punto de código
  • IntlChar::getCombiningClass — Obtener la clase de combinación de un punto de cógido
  • IntlChar::getFC_NFKC_Closure — Obtener la propiedad FC_NFKC_Closure de un punto de código
  • IntlChar::getIntPropertyMaxValue — Obtener el valor máximo de una propiedad de Unicode
  • IntlChar::getIntPropertyMinValue — Obtener el valor mínimo de una propiedad de Unicode
  • IntlChar::getIntPropertyValue — Obtener el valor de una propiedad de Unicode para un punto de código
  • IntlChar::getNumericValue — Obtener el valor numérico de un punto de código de Unicode
  • IntlChar::getPropertyEnum — Obtener el valor de la constante de una propiedad para un nombre de propiedad dado
  • IntlChar::getPropertyName — Obtener el nombre Unicode de una propiedad
  • IntlChar::getPropertyValueEnum — Obtener el valor de una propiedad para un nombre de valor dado
  • IntlChar::getPropertyValueName — Obtener el nombre Unicode para un valor de una propiedad
  • IntlChar::getUnicodeVersion — Obtener la versión de Unicode
  • IntlChar::hasBinaryProperty — Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::isalnum — Comporbar si un punto de código es un carácter alfanumérico
  • IntlChar::isalpha — Comprobar si un punto de código es un caracter de letra
  • IntlChar::isbase — Comprobar si un punto de código es un carácter base
  • IntlChar::isblank — Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»
  • IntlChar::iscntrl — Comprobar si un punto de código es un carácter de control
  • IntlChar::isdefined — Comprobar si un punto de código está definido
  • IntlChar::isdigit — Comprobar si un punto de código es un carácter de dígito
  • IntlChar::isgraph — Comprobar si un punto de código es un caráter gráfico
  • IntlChar::isIDIgnorable — Comprobar si un punto de código es un carácter ignorable
  • IntlChar::isIDPart — Comprobar si un punto de código es permisible en un identificador
  • IntlChar::isIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador
  • IntlChar::isISOControl — Comprobar si un punto de código es un código de control de ISO
  • IntlChar::isJavaIDPart — Comprobar si un punto de código es permisible en un identificador de Java
  • IntlChar::isJavaIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java
  • IntlChar::isJavaSpaceChar — Comprobar si un punto de código es un carácter de espacio según Java
  • IntlChar::islower — Comprobar si un punto de código es una letra minúscula
  • IntlChar::isMirrored — Comprobar si un punto de código posee la propiedad Bidi_Mirrored
  • IntlChar::isprint — Comprobar si un punto de código es un carácter imprimible
  • IntlChar::ispunct — Comprobar si un punto de código es un carácter de puntuación
  • IntlChar::isspace — Comprobar si un punto de código es un carácter de espacio
  • IntlChar::istitle — Comprobar si un punto de código es una letra titular
  • IntlChar::isUAlphabetic — Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic
  • IntlChar::isULowercase — Comprobar si un punto de código tiene la propiedad de Unicode Lowercase
  • IntlChar::isupper — Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
  • IntlChar::isUUppercase — Comprobar si un punto de código tiene la propiedad de Unicode Uppercase
  • IntlChar::isUWhiteSpace — Comprobar si un punto de código tiene la propiedad de Unicode White_Space
  • IntlChar::isWhitespace — Comprobar si un punto de código es un carácter de espacio en blanco según ICU
  • IntlChar::isxdigit — Comprobar si el punto de código es un dígito hexadecimal
  • IntlChar::ord — Devolver el valor del punto de código de Unicode de un carácter
  • IntlChar::tolower — Convertir a minúsculas un carácter Unicode
  • IntlChar::totitle — Convertir un carácter Unicode a letra titular
  • IntlChar::toupper — Convertir a mayúsculas un carácter Unicode


Obtener la «edad» del punto de código

  • « IntlChar
  • IntlChar::charDigitValue »
  • PHP Manual
  • IntlChar
  • Obtener la «edad» del punto de código

IntlChar::charAge

(PHP 7)

IntlChar::charAge — Obtener la «edad» del punto de código

Descripción

public static IntlChar::charAge ( mixed $codepoint ) : array

Obtiene la «edad» del punto de código.

La «edad» es la versión de Unicode cuando el punto de código fue diseñado por primera vez (como un no carácter o para Uso Privado) o se le asignó un carácter. Esta puede ser útil para evitar la emisión de puntos de código a procesos receptores que no aceptan nuevos caracteres.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

El número de versión de Unicode, como array. Por ejemplo, la versión 1.3.31.2 sería representada como [1, 3, 31, 2].

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charage("\u{2603}"));
var_dump(IntlChar::charage("\u{1F576}"));
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  int(1)
  [1]=>
  int(1)
  [2]=>
  int(0)
  [3]=>
  int(0)
}
array(4) {
  [0]=>
  int(7)
  [1]=>
  int(0)
  [2]=>
  int(0)
  [3]=>
  int(0)
}

Ver también

  • IntlChar::getUnicodeVersion() - Obtener la versión de Unicode
  • IntlChar::getIntPropertyMinValue() - Obtener el valor mínimo de una propiedad de Unicode
  • IntlChar::getIntPropertyValue() - Obtener el valor de una propiedad de Unicode para un punto de código


Obtener el valor del dígito decimal de un carácter de dígito decimal

  • « IntlChar::charAge
  • IntlChar::charDirection »
  • PHP Manual
  • IntlChar
  • Obtener el valor del dígito decimal de un carácter de dígito decimal

IntlChar::charDigitValue

(PHP 7)

IntlChar::charDigitValue — Obtener el valor del dígito decimal de un carácter de dígito decimal

Descripción

public static IntlChar::charDigitValue ( mixed $codepoint ) : int

Devuelve el valor del dígito decimal de un carácter de dígito decimal.

Estos caracteres tienen la categoría general "Nd" (número de dígito decimal) y un Numeric_Type de Decimal.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

El valor del dígito decimal de codepoint, o -1 si no es un carácter de dígito decimal.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charDigitValue("1"));
var_dump(IntlChar::charDigitValue("\u{0662}"));
var_dump(IntlChar::charDigitValue("\u{0E53}"));
?>

El resultado del ejemplo sería:

int(1)
int(2)
int(3)

Ver también

  • IntlChar::getNumericValue() - Obtener el valor numérico de un punto de código de Unicode


Obtener el valor de la categoría bidireccional de un punto de código

  • « IntlChar::charDigitValue
  • IntlChar::charFromName »
  • PHP Manual
  • IntlChar
  • Obtener el valor de la categoría bidireccional de un punto de código

IntlChar::charDirection

(PHP 7)

IntlChar::charDirection — Obtener el valor de la categoría bidireccional de un punto de código

Descripción

public static IntlChar::charDirection ( mixed $codepoint ) : int

Devuelve el valor de la categoría bidireccional del punto de código, que se emplea en el » algoritmo bidireccional de Unicode (UAX #9).

Nota:

Algunos puntos de código no asignados poseen valores «bidi» de R o AL debido a que están en bloques que están reservados para escrituras de derecha a izquierda.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

El valor de la categoría bidireccional; una de las siguietnes constantes:

  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR
  • IntlChar::CHAR_DIRECTION_ARABIC_NUMBER
  • IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR
  • IntlChar::CHAR_DIRECTION_BLOCK_SEPARATOR
  • IntlChar::CHAR_DIRECTION_SEGMENT_SEPARATOR
  • IntlChar::CHAR_DIRECTION_WHITE_SPACE_NEUTRAL
  • IntlChar::CHAR_DIRECTION_OTHER_NEUTRAL
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE
  • IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT
  • IntlChar::CHAR_DIRECTION_DIR_NON_SPACING_MARK
  • IntlChar::CHAR_DIRECTION_BOUNDARY_NEUTRAL
  • IntlChar::CHAR_DIRECTION_FIRST_STRONG_ISOLATE
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE
  • IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE
  • IntlChar::CHAR_DIRECTION_CHAR_DIRECTION_COUNT

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charDirection("A") === IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT);
var_dump(IntlChar::charDirection("\u{05E9}") === IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT);
var_dump(IntlChar::charDirection("+") === IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR);
var_dump(IntlChar::charDirection(".") === IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(true)


Buscar un carácter Unicode por su nombre y devolver su valor de punto de código

  • « IntlChar::charDirection
  • IntlChar::charMirror »
  • PHP Manual
  • IntlChar
  • Buscar un carácter Unicode por su nombre y devolver su valor de punto de código

IntlChar::charFromName

(PHP 7)

IntlChar::charFromName — Buscar un carácter Unicode por su nombre y devolver su valor de punto de código

Descripción

public static IntlChar::charFromName ( string $characterName , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : int

Busca un carácter Unicode por su nombre y devolver su valor de punto de código.

El nombre se compara de forma exacta y completa. Si el nombre no corresponde a un punto de código se devuelve false.

Un nombre de Unicode 1.0 es comparado solamente si difiere de su nombre moderno. Los nombres de Unicode están todos en mayúsculas. Los nombres ampliados están en minúculas y seguidos por un número hexadecimal en mayúsculas y entre comillas angulares.

Parámetros

characterName

El nombre completo del carácter Unicode.

nameChoice

El conjunto de nombres a utilizar para la consulta. Puede ser una de estas constantes:

  • IntlChar::UNICODE_CHAR_NAME (predeterminado)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

Valores devueltos

El valor Unicode del punto de código con el nombre dado (como integer), o false si no existe tal punto de código.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charFromName("LATIN CAPITAL LETTER A"));
var_dump(IntlChar::charFromName("SNOWMAN"));
var_dump(IntlChar::charFromName("RECYCLING SYMBOL FOR TYPE-1 PLASTICS"));
var_dump(IntlChar::charFromName("A RANDOM STRING WHICH DOESN'T CORRESPOND TO ANY UNICODE CHARACTER"));
?>

El resultado del ejemplo sería:

int(65)
int(9731)
int(9843)
bool(false)

Ver también

  • IntlChar::charName() - Obtener el nombre de un carácter Unicode
  • IntlChar::enumCharNames() - Enumerar todos los caracteres de Unicode con asignación dentro de un rango


Obtener el carácter de «imagen reflejada» de un punto de código

  • « IntlChar::charFromName
  • IntlChar::charName »
  • PHP Manual
  • IntlChar
  • Obtener el carácter de «imagen reflejada» de un punto de código

IntlChar::charMirror

(PHP 7)

IntlChar::charMirror — Obtener el carácter de «imagen reflejada» de un punto de código

Descripción

public static IntlChar::charMirror ( mixed $codepoint ) : mixed

Hace corresponder el carácter especificado con un carácter de «imagen reflejada».

Para caracteres con la propiedad Bidi_Mirrored, las implementaciones a veces necesitan una correspondencia «pobre» con otro carácter de Unicode (punto de código) tal que el glifo predeterminado podría servir como la imagen reflejada del glifo predeterminado del carácter especificado. Esto es útil en la conversión de textos hacia y desde páginas de código con orden visual y para pantallas sin la capacidad de selección de glifos.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve otro punto de código Unicode que podría servir como sustituto de imagen reflejada, o el mismo codepoint si no hay correspondencia o si codepoint no posee la propiedad Bidi_Mirrored.

El tipo devuelto será integer a menos que el punto de código se pase como un string UTF-8, en cuyo caso será devuelto un string.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charMirror("A"));
var_dump(IntlChar::charMirror("<"));
var_dump(IntlChar::charMirror("("));
?>

El resultado del ejemplo sería:

string(1) "E"
string(1) ">"
string(2) ")"

Ver también

  • IntlChar::isMirrored() - Comprobar si un punto de código posee la propiedad Bidi_Mirrored
  • IntlChar::PROPERTY_BIDI_MIRRORED


Obtener el nombre de un carácter Unicode

  • « IntlChar::charMirror
  • IntlChar::charType »
  • PHP Manual
  • IntlChar
  • Obtener el nombre de un carácter Unicode

IntlChar::charName

(PHP 7)

IntlChar::charName — Obtener el nombre de un carácter Unicode

Descripción

public static IntlChar::charName ( mixed $codepoint , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : string

Obtiene el nombre de un carácter unicode Unicode.

Dependiendo de nameChoice, el nombre del carácter resultante es el nombre «moderno» o el nombre que se definió en la versión 1.0 de Unicode. El nombre contiene solo caracteres «invariantes» como A-Z, 0-9, espacio y '-'. Solamente se obtiene un nombre de Unicode 1.0 si es diferente del nombre moderno y si ICU contiene datos sobre él.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

nameChoice

El conjunto de nombres a utilizar para la consulta. Puede ser una de estas constantes:

  • IntlChar::UNICODE_CHAR_NAME (predeterminado)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

Valores devueltos

El nombre correspondiente, o una cadena vacía si no existe un nombre para este carácter.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charName("."));
var_dump(IntlChar::charName(".", IntlChar::UNICODE_CHAR_NAME));
var_dump(IntlChar::charName("\u{2603}"));
var_dump(IntlChar::charName("\u{0000}"));
?>

El resultado del ejemplo sería:

string(9) "FULL STOP"
string(9) "FULL STOP"
string(7) "SNOWMAN"
string(0) ""

Ver también

  • IntlChar::charFromName() - Buscar un carácter Unicode por su nombre y devolver su valor de punto de código
  • IntlChar::enumCharNames() - Enumerar todos los caracteres de Unicode con asignación dentro de un rango


Obtener el valor de la categoría general de un punto de código

  • « IntlChar::charName
  • IntlChar::chr »
  • PHP Manual
  • IntlChar
  • Obtener el valor de la categoría general de un punto de código

IntlChar::charType

(PHP 7)

IntlChar::charType — Obtener el valor de la categoría general de un punto de código

Descripción

public static IntlChar::charType ( mixed $codepoint ) : int

Devuelve el valor de la categoría general de un punto de código.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el tipo de la categoría general, que puede ser una de las siguientes constantes:

  • IntlChar::CHAR_CATEGORY_UNASSIGNED
  • IntlChar::CHAR_CATEGORY_GENERAL_OTHER_TYPES
  • IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER
  • IntlChar::CHAR_CATEGORY_LOWERCASE_LETTER
  • IntlChar::CHAR_CATEGORY_TITLECASE_LETTER
  • IntlChar::CHAR_CATEGORY_MODIFIER_LETTER
  • IntlChar::CHAR_CATEGORY_OTHER_LETTER
  • IntlChar::CHAR_CATEGORY_NON_SPACING_MARK
  • IntlChar::CHAR_CATEGORY_ENCLOSING_MARK
  • IntlChar::CHAR_CATEGORY_COMBINING_SPACING_MARK
  • IntlChar::CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER
  • IntlChar::CHAR_CATEGORY_LETTER_NUMBER
  • IntlChar::CHAR_CATEGORY_OTHER_NUMBER
  • IntlChar::CHAR_CATEGORY_SPACE_SEPARATOR
  • IntlChar::CHAR_CATEGORY_LINE_SEPARATOR
  • IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR
  • IntlChar::CHAR_CATEGORY_CONTROL_CHAR
  • IntlChar::CHAR_CATEGORY_FORMAT_CHAR
  • IntlChar::CHAR_CATEGORY_PRIVATE_USE_CHAR
  • IntlChar::CHAR_CATEGORY_SURROGATE
  • IntlChar::CHAR_CATEGORY_DASH_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_START_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_END_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_CONNECTOR_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_MATH_SYMBOL
  • IntlChar::CHAR_CATEGORY_CURRENCY_SYMBOL
  • IntlChar::CHAR_CATEGORY_MODIFIER_SYMBOL
  • IntlChar::CHAR_CATEGORY_OTHER_SYMBOL
  • IntlChar::CHAR_CATEGORY_INITIAL_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_FINAL_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_CHAR_CATEGORY_COUNT

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::charType("A") === IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER);
var_dump(IntlChar::charType(".") === IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION);
var_dump(IntlChar::charType("\t") === IntlChar::CHAR_CATEGORY_CONTROL_CHAR);
var_dump(IntlChar::charType("\u{2603}") === IntlChar::CHAR_CATEGORY_OTHER_SYMBOL);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(true)


Devolver el carácter Unicode mediante su valor de punto de código

  • « IntlChar::charType
  • IntlChar::digit »
  • PHP Manual
  • IntlChar
  • Devolver el carácter Unicode mediante su valor de punto de código

IntlChar::chr

(PHP 7)

IntlChar::chr — Devolver el carácter Unicode mediante su valor de punto de código

Descripción

public static IntlChar::chr ( mixed $codepoint ) : string

Devuelve una cadena que contiene el carácter especificado por el valor del pundo de código de Unicode.

Esta función complementa a IntlChar::ord().

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Una cadena que contiene el carácter especificado por el valor del punto de código de Unicode.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
$valores = ["A", 63, 123, 9731];
foreach ($valores as $valor) {
    var_dump(IntlChar::chr($valor));
}
?>

El resultado del ejemplo sería:

string(1) "A"
string(1) "A"
string(1) "{"
string(3) "?"

Ver también

  • IntlChar::ord() - Devolver el valor del punto de código de Unicode de un carácter
  • chr() - Devuelve un caracter específico


Obtener el valor del dígito decimal de un punto de código para una base dada

  • « IntlChar::chr
  • IntlChar::enumCharNames »
  • PHP Manual
  • IntlChar
  • Obtener el valor del dígito decimal de un punto de código para una base dada

IntlChar::digit

(PHP 7)

IntlChar::digit — Obtener el valor del dígito decimal de un punto de código para una base dada

Descripción

public static IntlChar::digit ( string $codepoint , int $radix = 10 ) : int

Devuelve el valor del dígito decimal de un punto de código en la base especificada.

Si la base no está en el rango 2<=base<=36 o si el valor de codepoint no es un dígito válido en la base especificada, devuelve false. Un carácter es un dígito válido si al menos algo de lo siguiente es verdadero:

  • El carácter tienen un valor de dígito decimal. Tales caracteres posee la categoría general "Nd" (números de dígito decimal) y un Numeric_Type de Decimal. En este caso, el valor es el del dígito decimal del carácter.
  • El carácter es una de las letras latinas mayúsculas 'A' hasta 'Z'. En este caso, el valor es c-'A'+10.
  • El carácter es una de las letras latinas minúsculas 'a' hasta 'z'. En este caso, el valor es ch-'a'+10.
  • Son admitidas las letras latinas tanto del rango ASCII (0061..007A, 0041..005A) como del rango ASCII de Ancho Completo (FF41..FF5A, FF21..FF3A).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

radix

La base (valor predeterminado: 10).

Valores devueltos

Devuelve el valor numérico representado por el carácter de la base especificada, o false si no existe el valor o si el valor excede a la base.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::digit("0"));
var_dump(IntlChar::digit("3"));
var_dump(IntlChar::digit("A"));
var_dump(IntlChar::digit("A", 16));
?>

El resultado del ejemplo sería:

int(0)
int(3)
bool(false)
int(10)

Ver también

  • IntlChar::forDigit() - Obtener la representación de un carácter para un dígito y base dados
  • IntlChar::charDigitValue() - Obtener el valor del dígito decimal de un carácter de dígito decimal
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito
  • IntlChar::PROPERTY_NUMERIC_TYPE


Enumerar todos los caracteres de Unicode con asignación dentro de un rango

  • « IntlChar::digit
  • IntlChar::enumCharTypes »
  • PHP Manual
  • IntlChar
  • Enumerar todos los caracteres de Unicode con asignación dentro de un rango

IntlChar::enumCharNames

(PHP 7)

IntlChar::enumCharNames — Enumerar todos los caracteres de Unicode con asignación dentro de un rango

Descripción

public static IntlChar::enumCharNames ( mixed $start , mixed $limit , callable $callback , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : void

Enumera todos los caracteres de Unicode asignados entre los puntos de código de inicio y límite, (inclusive y exclusive, respectivamente) y se llama a una función para cada uno, pasando el valor del punto de código y el nombre del carácter.

Para los nombres de Unicode 1.0, solamente se enumeran aquellos que difieren de los nombres modernos.

Parámetros

start

El primer punto de código en el rango de la enumeración.

limit

Uno más del último punto de código en el rango de la enumeración (el primero después del rango).

callback

La función a invorcar para cada nombre de carácter. Se le pasarán los siguientes tres argumentos:

  • integer $codepoint - El valor numérico del punto de código
  • integer $nameChoice - El mismo valor que el del parámetro nameChoice de abajo
  • string $name - El nombre del carácter

nameChoice

El selector por cuyo tipo de nombres se va a enumerar. Puede ser cualquier de estas constantes:

  • IntlChar::UNICODE_CHAR_NAME (predeterminada)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Enumeración de un rango de muestra de puntos de código

<?php
IntlChar::enumCharNames(0x2600, 0x2610, function($codepoint, $nameChoice, $name) {
    printf("U+%04x %s\n", $codepoint, $name);
});
?>

El resultado del ejemplo sería:

U+2600 BLACK SUN WITH RAYS
U+2601 CLOUD
U+2602 UMBRELLA
U+2603 SNOWMAN
U+2604 COMET
U+2605 BLACK STAR
U+2606 WHITE STAR
U+2607 LIGHTNING
U+2608 THUNDERSTORM
U+2609 SUN
U+260a ASCENDING NODE
U+260b DESCENDING NODE
U+260c CONJUNCTION
U+260d OPPOSITION
U+260e BLACK TELEPHONE
U+260f WHITE TELEPHONE

Ver también

  • IntlChar::charName() - Obtener el nombre de un carácter Unicode
  • IntlChar::charFromName() - Buscar un carácter Unicode por su nombre y devolver su valor de punto de código


Enumerar todos los puntos de código con sus categorías generales de Unicode

  • « IntlChar::enumCharNames
  • IntlChar::foldCase »
  • PHP Manual
  • IntlChar
  • Enumerar todos los puntos de código con sus categorías generales de Unicode

IntlChar::enumCharTypes

(PHP 7)

IntlChar::enumCharTypes — Enumerar todos los puntos de código con sus categorías generales de Unicode

Descripción

public static IntlChar::enumCharTypes ( callable $callback ) : void

Enumera de manera eficiente todos los puntos de código con sus categorías generales de Unicode. Esto es útil para construir estructuras de datos, para enumerar todos los puntos de código con asignación, etc.

Para cada rango contiguo de puntos de código con una categoría general dada («tipo de carácter»), se invoca a la función callback. Rangos adyacentes poseen tipos diferentes. El Estándar de Unicode garantiza que el valor numérico del tipo está entre 0..31.

Parámetros

callback

La función a invocar para cada rango contiguo de puntos de código con la misma categoría general. Se le pasarán los siguientes tres argumentos:

  • integer $start - El punto de código de inicio del rango
  • integer $end - El punto de código final del rango
  • integer $name - El tipo de categoría (una de las constantes IntlChar::CHAR_CATEGORY_*)

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Enumeración de un rango de muestra de puntos de código

<?php
IntlChar::enumCharTypes(function($start, $end, $type) {
    printf("U+%04x hasta U+%04x están en la categoría %d\n", $start, $end, $type);
});
?>

El resultado del ejemplo sería:

U+0000 hasta U+0020 están en la categoría 15
U+0020 hasta U+0021 están en la categoría 12
U+0021 hasta U+0024 están en la categoría 23
U+0024 hasta U+0025 están en la categoría 25
U+0025 hasta U+0028 están en la categoría 23
U+0028 hasta U+0029 están en la categoría 20
U+0029 hasta U+002a están en la categoría 21
U+002a hasta U+002b están en la categoría 23
U+002b hasta U+002c están en la categoría 24
U+002c hasta U+002d están en la categoría 23
U+002d hasta U+002e están en la categoría 19
U+002e hasta U+0030 están en la categoría 23
U+0030 hasta U+003a están en la categoría 9
...


Realiza un «plegamiento» de un punto de código

  • « IntlChar::enumCharTypes
  • IntlChar::forDigit »
  • PHP Manual
  • IntlChar
  • Realiza un «plegamiento» de un punto de código

IntlChar::foldCase

(PHP 7)

IntlChar::foldCase — Realiza un «plegamiento» de un punto de código

Descripción

public static IntlChar::foldCase ( mixed $codepoint , int $options = IntlChar::FOLD_CASE_DEFAULT ) : mixed

El carácter dado se hace corresponder con un equivalente «plegado» ("case folding"); si el carácter no tiene dicho equivalente, se devuelve el carácter mismo.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

options

IntlChar::FOLD_CASE_DEFAULT (predeterminada) o IntlChar::FOLD_CASE_EXCLUDE_SPECIAL_I.

Valores devueltos

Devuelve el Simple_Case_Folding del punto de código, si lo hay; de lo contrario devuelve el punto de código en sí.


Obtener la representación de un carácter para un dígito y base dados

  • « IntlChar::foldCase
  • IntlChar::getBidiPairedBracket »
  • PHP Manual
  • IntlChar
  • Obtener la representación de un carácter para un dígito y base dados

IntlChar::forDigit

(PHP 7)

IntlChar::forDigit — Obtener la representación de un carácter para un dígito y base dados

Descripción

public static IntlChar::forDigit ( int $digit , int $radix = 10 ) : int

Determina la representación de un carácter para un dígito específico en la base especificada.

Si el valor de la base no es una base válida, o si el valor del dígito no es un dígito válido en la base especificada, devuelve el carácter null (U+0000).

El argumento 'radix' es válido si es mayor o igual que 2 y menor o igual que 36. El argumento 'digit' es válido si 0 <= dígito < base.

Si el dígito es menor que 10, devuelve '0' + dígito. De lo contrario, deuvleve el valor 'a' + dígito - 10.

Parámetros

digit

El número a convertir en un carácter.

radix

La base (valor predeterminado: 10).

Valores devueltos

La representación de un carácter (como string) del dígito especificado en la base especificada.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::forDigit(0));
var_dump(IntlChar::forDigit(3));
var_dump(IntlChar::forDigit(3, 10));
var_dump(IntlChar::forDigit(10));
var_dump(IntlChar::forDigit(10, 16));
?>

El resultado del ejemplo sería:

int(48)
int(51)
int(51)
int(0)
int(97)

Ver también

  • IntlChar::digit() - Obtener el valor del dígito decimal de un punto de código para una base dada
  • IntlChar::charDigitValue() - Obtener el valor del dígito decimal de un carácter de dígito decimal
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito
  • IntlChar::PROPERTY_NUMERIC_TYPE


Obtener la pareja del carácter parentético de un punto de código

  • « IntlChar::forDigit
  • IntlChar::getBlockCode »
  • PHP Manual
  • IntlChar
  • Obtener la pareja del carácter parentético de un punto de código

IntlChar::getBidiPairedBracket

(PHP 7)

IntlChar::getBidiPairedBracket — Obtener la pareja del carácter parentético de un punto de código

Descripción

public static IntlChar::getBidiPairedBracket ( mixed $codepoint ) : mixed

Hace corresponder el carácter especificado con su pareja parentética.

Para Bidi_Paired_Bracket_Type!=None, esto es lo mismo que IntlChar::charMirror(). De lo contrario se devuelve el mismo codepoint.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el punto de código de la pareja parentética, o el mismo codepoint si no existe tal correspondencia.

El tipo devuelto será integer a menos que el punto de código se pase como un string UTF-8, en cuyo caso será devuelto un string.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::getBidiPairedBracket(91));
var_dump(IntlChar::getBidiPairedBracket('['));
?>

El resultado del ejemplo sería:

int(93)
string(1) "]"

Ver también

  • IntlChar::charMirror() - Obtener el carácter de «imagen reflejada» de un punto de código
  • IntlChar::PROPERTY_BIDI_PAIRED_BRACKET
  • IntlChar::PROPERTY_BIDI_PAIRED_BRACKET_TYPE


Obtener el bloque de asignación de Unicode que contiene a un punto de código

  • « IntlChar::getBidiPairedBracket
  • IntlChar::getCombiningClass »
  • PHP Manual
  • IntlChar
  • Obtener el bloque de asignación de Unicode que contiene a un punto de código

IntlChar::getBlockCode

(PHP 7)

IntlChar::getBlockCode — Obtener el bloque de asignación de Unicode que contiene a un punto de código

Descripción

public static IntlChar::getBlockCode ( mixed $codepoint ) : int

Devuelve el bloque de asignación de Unicode que contiene al carácter.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el valor del bloque para codepoint. Véanse las constantes IntlChar::BLOCK_CODE_* para los posibles valores devueltos.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::getBlockCode("A") === IntlChar::BLOCK_CODE_BASIC_LATIN);
var_dump(IntlChar::getBlockCode("F") === IntlChar::BLOCK_CODE_GREEK);
var_dump(IntlChar::getBlockCode("\u{2603}") === IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)


Obtener la clase de combinación de un punto de cógido

  • « IntlChar::getBlockCode
  • IntlChar::getFC_NFKC_Closure »
  • PHP Manual
  • IntlChar
  • Obtener la clase de combinación de un punto de cógido

IntlChar::getCombiningClass

(PHP 7)

IntlChar::getCombiningClass — Obtener la clase de combinación de un punto de cógido

Descripción

public static IntlChar::getCombiningClass ( mixed $codepoint ) : int

Devuelve la clase de combinación de un punto de cógido.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve la clase de combinación del carácter.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::getCombiningClass("A"));
var_dump(IntlChar::getCombiningClass("\u{0334}"));
var_dump(IntlChar::getCombiningClass("\u{0358}"));
?>

El resultado del ejemplo sería:

int(0)
int(1)
int(232)


Obtener la propiedad FC_NFKC_Closure de un punto de código

  • « IntlChar::getCombiningClass
  • IntlChar::getIntPropertyMaxValue »
  • PHP Manual
  • IntlChar
  • Obtener la propiedad FC_NFKC_Closure de un punto de código

IntlChar::getFC_NFKC_Closure

(PHP 7)

IntlChar::getFC_NFKC_Closure — Obtener la propiedad FC_NFKC_Closure de un punto de código

Descripción

public static IntlChar::getFC_NFKC_Closure ( mixed $codepoint ) : string

Obtiene la cadena de la propiedad FC_NFKC_Closure de un carácter.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve la cadena de la propiedad FC_NFKC_Closure de codepoint, o una cadena vacía si no existe.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::getFC_NFKC_Closure("\u{2121}"));
var_dump(IntlChar::getFC_NFKC_Closure("\u{1D2D}"));
?>

El resultado del ejemplo sería:

string(3) "tel"
string(2) "æ"


Obtener el valor máximo de una propiedad de Unicode

  • « IntlChar::getFC_NFKC_Closure
  • IntlChar::getIntPropertyMinValue »
  • PHP Manual
  • IntlChar
  • Obtener el valor máximo de una propiedad de Unicode

IntlChar::getIntPropertyMaxValue

(PHP 7)

IntlChar::getIntPropertyMaxValue — Obtener el valor máximo de una propiedad de Unicode

Descripción

public static IntlChar::getIntPropertyMaxValue ( int $property ) : int

Obtiene el valor máximo de una propiedad de Unicode enumerada/entera/binaria.

Parámetros

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Valores devueltos

El valor máximo devuelto por IntlChar::getIntPropertyValue() para una propiedad de Unicode. <=0 si el selector de la propiedad está fuera de rango.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_SCRIPT));
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_IDEOGRAPHIC));
var_dump(IntlChar::getIntPropertyMaxValue(999999999)); // Un valor inventado
?>

El resultado del ejemplo sería:

int(22)
int(166)
int(1)
int(-1)

Ver también

  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::getIntPropertyMinValue() - Obtener el valor mínimo de una propiedad de Unicode
  • IntlChar::getIntPropertyValue() - Obtener el valor de una propiedad de Unicode para un punto de código
  • IntlChar::getUnicodeVersion() - Obtener la versión de Unicode


Obtener el valor mínimo de una propiedad de Unicode

  • « IntlChar::getIntPropertyMaxValue
  • IntlChar::getIntPropertyValue »
  • PHP Manual
  • IntlChar
  • Obtener el valor mínimo de una propiedad de Unicode

IntlChar::getIntPropertyMinValue

(PHP 7)

IntlChar::getIntPropertyMinValue — Obtener el valor mínimo de una propiedad de Unicode

Descripción

public static IntlChar::getIntPropertyMinValue ( int $property ) : int

Obtiene el valor mínimo de una propiedad de Unicode enumerada/entera/binaria.

Parámetros

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Valores devueltos

El valor máximo devuelto por IntlChar::getIntPropertyValue() para una propiedad de Unicode. 0 si el selector de la propiedad está fuera de rango.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_SCRIPT));
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_IDEOGRAPHIC));
var_dump(IntlChar::getIntPropertyMinValue(999999999)); // Un valor inventado
?>

El resultado del ejemplo sería:

int(0)
int(0)
int(0)
int(0)

Ver también

  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::getIntPropertyMaxValue() - Obtener el valor máximo de una propiedad de Unicode
  • IntlChar::getIntPropertyValue() - Obtener el valor de una propiedad de Unicode para un punto de código
  • IntlChar::getUnicodeVersion() - Obtener la versión de Unicode


Obtener el valor de una propiedad de Unicode para un punto de código

  • « IntlChar::getIntPropertyMinValue
  • IntlChar::getNumericValue »
  • PHP Manual
  • IntlChar
  • Obtener el valor de una propiedad de Unicode para un punto de código

IntlChar::getIntPropertyValue

(PHP 7)

IntlChar::getIntPropertyValue — Obtener el valor de una propiedad de Unicode para un punto de código

Descripción

public static IntlChar::getIntPropertyValue ( mixed $codepoint , int $property ) : int

Obtiene el valor de una propiedad enumerada o entera de Unicode para un punto de código. También devuelve valores de propiedades binarias y de máscara.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Valores devueltos

Devuelve el valor numérico que es directamente el valor de la propiedad o, para propiedades enumeradas, que corresponde al valor numérico de la constante enumerada del tipo de enumeración respectivo del valor de la propiedad.

Devuelve 0 o 1 (para false/true) para propiedades binarias de Unicode.

Devuelve una máscara de bits para propiedades de máscara.

Devuelve 0 si property está fuera de rango o si la versión de Unicode no posee datos para la propiedad o para este punto de código.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getIntPropertyValue("A", IntlChar::PROPERTY_ALPHABETIC) === 1);
var_dump(IntlChar::getIntPropertyValue("[", IntlChar::PROPERTY_BIDI_MIRRORED) === 1);
var_dump(IntlChar::getIntPropertyValue("F", IntlChar::PROPERTY_BLOCK) === IntlChar::BLOCK_CODE_GREEK);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)

Ver también

  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::getIntPropertyMinValue() - Obtener el valor mínimo de una propiedad de Unicode
  • IntlChar::getIntPropertyMaxValue() - Obtener el valor máximo de una propiedad de Unicode
  • IntlChar::getUnicodeVersion() - Obtener la versión de Unicode


Obtener el valor numérico de un punto de código de Unicode

  • « IntlChar::getIntPropertyValue
  • IntlChar::getPropertyEnum »
  • PHP Manual
  • IntlChar
  • Obtener el valor numérico de un punto de código de Unicode

IntlChar::getNumericValue

(PHP 7)

IntlChar::getNumericValue — Obtener el valor numérico de un punto de código de Unicode

Descripción

public static IntlChar::getNumericValue ( mixed $codepoint ) : float

Obtiene el valor numérico de un punto de código de Unicode tal como está definido la Base de Datos de Caracteres de Unicode.

Para caracteres sin un valor numérico en la Base de Datos de Caracteres de Unicode, esta función devolverá float(-123456789).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

El valor numérico de codepoint, o float(-123456789) si no hay definido ninguno.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::getNumericValue("4"));
var_dump(IntlChar::getNumericValue("x"));
var_dump(IntlChar::getNumericValue("\u{216C}"));
?>

El resultado del ejemplo sería:

float(4)
float(-123456789)
float(50)


Obtener el valor de la constante de una propiedad para un nombre de propiedad dado

  • « IntlChar::getNumericValue
  • IntlChar::getPropertyName »
  • PHP Manual
  • IntlChar
  • Obtener el valor de la constante de una propiedad para un nombre de propiedad dado

IntlChar::getPropertyEnum

(PHP 7)

IntlChar::getPropertyEnum — Obtener el valor de la constante de una propiedad para un nombre de propiedad dado

Descripción

public static IntlChar::getPropertyEnum ( string $alias ) : int

Devuelve el valor de la constante de una propiedad para un nombre de propiedad dado, tal como se especifica en el fichero de base de datos de Unicode PropertyAliases.txt. Se reconocen también las variantes cortas, largas y otras.

Además, esta función hace corresponder los nomres sintéticos "gcm" / "General_Category_Mask" con al propiedad IntlChar::PROPERTY_GENERAL_CATEGORY_MASK. Estos no mbres no se encuentran en PropertyAliases.txt.

Esta función complementa a IntlChar::getPropertyName().

Parámetros

alias

El nombre de la propiedad a comparar. El nombre se compara empleando la «comparación débil» ("loose matching"), como se describe en PropertyAliases.txt.

Valores devueltos

Devuelve un valor de una consntante IntlChar::PROPERTY_, o IntlChar::PROPERTY_INVALID_CODE si el nombre dado no coincide con ninguna propiedad.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getPropertyEnum('Bidi_Class') === IntlChar::PROPERTY_BIDI_CLASS);
var_dump(IntlChar::getPropertyEnum('script') === IntlChar::PROPERTY_SCRIPT);
var_dump(IntlChar::getPropertyEnum('IDEOGRAPHIC') === IntlChar::PROPERTY_IDEOGRAPHIC);
var_dump(IntlChar::getPropertyEnum('Some made-up string') === IntlChar::PROPERTY_INVALID_CODE);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(true)

Ver también

  • IntlChar::getPropertyName() - Obtener el nombre Unicode de una propiedad


Obtener el nombre Unicode de una propiedad

  • « IntlChar::getPropertyEnum
  • IntlChar::getPropertyValueEnum »
  • PHP Manual
  • IntlChar
  • Obtener el nombre Unicode de una propiedad

IntlChar::getPropertyName

(PHP 7)

IntlChar::getPropertyName — Obtener el nombre Unicode de una propiedad

Descripción

public static IntlChar::getPropertyName ( int $property , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string

Devuelve el nombre Unicode de una propiedad dada, tal como se da en el fichero de base de datos de Unicode PropertyAliases.txt.

Además, esta función hace corresponder la propiedad IntlChar::PROPERTY_GENERAL_CATEGORY_MASK con los nombres sintéticos "gcm" / "General_Category_Mask". Estos nombres no se encuentran en PropertyAliases.txt.

Esta función complementa a IntlChar::getPropertyEnum().

Parámetros

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

No se debería utilizar IntlChar::PROPERTY_INVALID_CODE. Tambíen, si property está fuera de rango, devuelve false.

nameChoice

El selector a obtener por su nombre. Si está fuera de rango, devuelve false.

Todas las propiedades tienen un nombre largo. La mayoría tienen un nombre corto, otras no. Unicode tiene en cuenta nombres adicionales; si están presentes, serán devueltos añadiendo 1, 2, etc., a IntlChar::LONG_PROPERTY_NAME.

Valores devueltos

Devuelve el nombre, o false si property o nameChoice están fuera de rango.

Si un nameChoice dado devuelve false, todos los valores mayores que nameChoice devolverán false, con una excepción: si se devuelve false para IntlChar::SHORT_PROPERTY_NAME, entonces IntlChar::LONG_PROPERTY_NAME (y mayores) podrían aún devolver un valor distinto de false.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::SHORT_PROPERTY_NAME));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::LONG_PROPERTY_NAME));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::LONG_PROPERTY_NAME + 1));
?>

El resultado del ejemplo sería:

string(10) "Bidi_Class"
string(2) "bc"
string(10) "Bidi_Class"
bool(false)

Ver también

  • IntlChar::getPropertyEnum() - Obtener el valor de la constante de una propiedad para un nombre de propiedad dado


Obtener el valor de una propiedad para un nombre de valor dado

  • « IntlChar::getPropertyName
  • IntlChar::getPropertyValueName »
  • PHP Manual
  • IntlChar
  • Obtener el valor de una propiedad para un nombre de valor dado

IntlChar::getPropertyValueEnum

(PHP 7)

IntlChar::getPropertyValueEnum — Obtener el valor de una propiedad para un nombre de valor dado

Descripción

public static IntlChar::getPropertyValueEnum ( int $property , string $name ) : int

Devuelve el entero del valor de la propiedad para un nombre de valor dado, tal como se especifica en el fichero de base de datos de Unicode PropertyValueAliases.txt. Se reconocen también las variantes cortas, largas y otras.

Nota:

Algunos de los nombres de PropertyValueAliases.txt solo serán reconocidos con IntlChar::PROPERTY_GENERAL_CATEGORY_MASK, no con IntlChar::PROPERTY_GENERAL_CATEGORY. Estos son:

  • "C" / "Other"
  • "L" / "Letter"
  • "LC" / "Cased_Letter"
  • "M" / "Mark"
  • "N" / "Number"
  • "P" / "Punctuation"
  • "S" / "Symbol"
  • "Z" / "Separator"

Parámetros

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Si está fuera de rango, o si este método no funciona con el valor dado, se devuelve IntlChar::PROPERTY_INVALID_CODE.

name

El nombre del valor a comparar. El nombre se compara empleando la «comparación débil» ("loose matching"), como se describe en PropertyValueAliases.txt.

Valores devueltos

Devuelve el entero del valor correspondiente, o IntlChar::PROPERTY_INVALID_CODE si el nombre dado no coincide con ningún valor de la propiedad dada, o si la propiedad es inválida.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BLOCK, 'greek') === IntlChar::BLOCK_CODE_GREEK);
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BIDI_CLASS, 'RIGHT_TO_LEFT') === IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT);
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BIDI_CLASS, 'some made-up string') === IntlChar::PROPERTY_INVALID_CODE);
var_dump(IntlChar::getPropertyValueEnum(123456789, 'RIGHT_TO_LEFT') === IntlChar::PROPERTY_INVALID_CODE);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(true)


Obtener el nombre Unicode para un valor de una propiedad

  • « IntlChar::getPropertyValueEnum
  • IntlChar::getUnicodeVersion »
  • PHP Manual
  • IntlChar
  • Obtener el nombre Unicode para un valor de una propiedad

IntlChar::getPropertyValueName

(PHP 7)

IntlChar::getPropertyValueName — Obtener el nombre Unicode para un valor de una propiedad

Descripción

public static IntlChar::getPropertyValueName ( int $property , int $value , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string

Devuelve el nombre Unicode para un valor de una propiedad dado, como se da en el fichero de la base de datos de Unicode PropertyValueAliases.txt.

Nota:

Algunos de los nombres en PropertyValueAliases.txt solamente se pueden obtener con IntlChar::PROPERTY_GENERAL_CATEGORY_MASK, no con IntlChar::PROPERTY_GENERAL_CATEGORY. Estos son:

  • "C" / "Other"
  • "L" / "Letter"
  • "LC" / "Cased_Letter"
  • "M" / "Mark"
  • "N" / "Number"
  • "P" / "Punctuation"
  • "S" / "Symbol"
  • "Z" / "Separator"

Parámetros

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Si está fuera de rango o si el método no funciona con el valor dado, devuelve false.

value

El selector para un valor de la propiedad dada. Si está fuera de rango, devuelve false.

En general, los valores válidos de rangos van de 0 a un máximo. Existen un par de excepciones:

  • Los valores IntlChar::PROPERTY_BLOCK comienzan en el valor IntlChar::BLOCK_CODE_BASIC_LATIN distinto de cero.
  • Los valores IntlChar::PROPERTY_CANONICAL_COMBINING_CLASS no son contiguos y su rango es 0..240.

nameChoice

El selector a obtener por su nombre. Si está fuera de rango, devuelve false.

Todas las propiedades tienen un nombre largo. La mayoría tienen un nombre corto, otras no. Unicode tiene en cuenta nombres adicionales; si están presentes, serán devueltos añadiendo 1, 2, etc., a IntlChar::LONG_PROPERTY_NAME.

Valores devueltos

Devuelve el nombre, o false si property o nameChoice están fuera de rango.

Si un nameChoice dado devuelve false, todos los valores mayores que nameChoice devolverán false, con una excepción: si se devuelve false para IntlChar::SHORT_PROPERTY_NAME, entonces IntlChar::LONG_PROPERTY_NAME (y mayores) podrían aún devolver un valor distinto de false.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::SHORT_PROPERTY_NAME));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::LONG_PROPERTY_NAME));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::LONG_PROPERTY_NAME + 1));
?>

El resultado del ejemplo sería:

string(16) "Greek_And_Coptic"
string(5) "Greek"
string(16) "Greek_And_Coptic"
bool(false)


Obtener la versión de Unicode

  • « IntlChar::getPropertyValueName
  • IntlChar::hasBinaryProperty »
  • PHP Manual
  • IntlChar
  • Obtener la versión de Unicode

IntlChar::getUnicodeVersion

(PHP 7)

IntlChar::getUnicodeVersion — Obtener la versión de Unicode

Descripción

public static IntlChar::getUnicodeVersion ( ) : array

Obtiene información de la versión de Unicode.

El array de la versión contiene la información de la versión del estándar de Unicode que está utilizando ICU actualmente. Por ejemplo, la versión 3.1.1 de Unicode se representa como un array con los valores [3, 1, 1, 0].

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array que contiene el número de versión de Unicode.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::getUnicodeVersion());
?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  int(7)
  [1]=>
  int(0)
  [2]=>
  int(0)
  [3]=>
  int(0)
}

Ver también

  • IntlChar::charAge() - Obtener la «edad» del punto de código


Comprobar una propiedad de Unicode binaria para un punto de código

  • « IntlChar::getUnicodeVersion
  • IntlChar::isalnum »
  • PHP Manual
  • IntlChar
  • Comprobar una propiedad de Unicode binaria para un punto de código

IntlChar::hasBinaryProperty

(PHP 7)

IntlChar::hasBinaryProperty — Comprobar una propiedad de Unicode binaria para un punto de código

Descripción

public static IntlChar::hasBinaryProperty ( mixed $codepoint , int $property ) : bool

Comprueba una propiedad de Unicode binaria para un punto de código.

Unicode, especialmente en la versión 3.2, define muchas más propiedades que el conjunto original de UnicodeData.txt.

Las API de propiedades tienen el objeto que reflejar las propiedades de Unicode tal como están definidas en la Base de Datos de Caracteres de Unicode (UCD - Unicode Character Database) y en los Informes Técnicos de (UTR - Unicode Technical Reports). Para detalles sobre las propiedades véase » http://www.unicode.org/ucd/. Para los nombres de las propiedades de Unicode véase el fichero PropertyAliases.txt de la UCD.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

property

La propiedad de Unicode a consultar (véanse las constantes IntlChar::PROPERTY_*).

Valores devueltos

Devuelve true o false según el valor de la propiedad binaria de Unicode para codepoint. También devuelve false si property está fuera de los límites o si la versión de Unicode no posee datos para para la propiedad o para este punto de código.

Ejemplos

Ejemplo #1 Probar diferentes propiedades

<?php
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_ALPHABETIC));
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_CASE_SENSITIVE));
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_BIDI_MIRRORED));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_ALPHABETIC));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_CASE_SENSITIVE));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_BIDI_MIRRORED));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(false)
bool(false)
bool(true)

Ver también

  • IntlChar::getIntPropertyValue() - Obtener el valor de una propiedad de Unicode para un punto de código
  • IntlChar::getUnicodeVersion() - Obtener la versión de Unicode


Comporbar si un punto de código es un carácter alfanumérico

  • « IntlChar::hasBinaryProperty
  • IntlChar::isalpha »
  • PHP Manual
  • IntlChar
  • Comporbar si un punto de código es un carácter alfanumérico

IntlChar::isalnum

(PHP 7)

IntlChar::isalnum — Comporbar si un punto de código es un carácter alfanumérico

Descripción

public static IntlChar::isalnum ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter alfanumérico (letra o dígito). true para caracteres con las categorías generales "L" (letras) y "Nd" (números de dígito decimal).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un caracter alfanumérico, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isalnum("A"));
var_dump(IntlChar::isalnum("1"));
var_dump(IntlChar::isalnum("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)

Ver también

  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito


Comprobar si un punto de código es un caracter de letra

  • « IntlChar::isalnum
  • IntlChar::isbase »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un caracter de letra

IntlChar::isalpha

(PHP 7)

IntlChar::isalpha — Comprobar si un punto de código es un caracter de letra

Descripción

public static IntlChar::isalpha ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter de letra. true para las categorías generales "L" (letras).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de letra, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isalpha("A"));
var_dump(IntlChar::isalpha("1"));
var_dump(IntlChar::isalpha("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::isalnum() - Comporbar si un punto de código es un carácter alfanumérico
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito


Comprobar si un punto de código es un carácter base

  • « IntlChar::isalpha
  • IntlChar::isblank »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter base

IntlChar::isbase

(PHP 7)

IntlChar::isbase — Comprobar si un punto de código es un carácter base

Descripción

public static IntlChar::isbase ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter base. true para las categorías generales "L" (letras), "N" (números), "Mc" (marcas de combinación de espaciado), y "Me" (marcas envolventes).

Nota:

Esto es diferente de la definición de Unicode del capítulo 3.5, cláusula de conformidad D13, que define a los caracteres base como todos los caracteres (no Cn) que no combinan con caracteres precedentes (M) y que tampoco son caracteres de control (Cc) o de formato (Cf).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un caracter base, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isbase("A"));
var_dump(IntlChar::isbase("1"));
var_dump(IntlChar::isbase("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)

Ver también

  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito


Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»

  • « IntlChar::isbase
  • IntlChar::iscntrl »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»

IntlChar::isblank

(PHP 7)

IntlChar::isblank — Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»

Descripción

public static IntlChar::isblank ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter «en blanco» o de «espacio horizontal» que separa visiblemente palabras en una línea.

Las definiciones siguientes son equivalentes:

  • true para caracteres de Unicode White_Space excepto para «controles de espaciado vertical», siendo estos últimos los siguientes caracteres: U+000A (LF) U+000B (VT) U+000C (FF) U+000D (CR) U+0085 (NEL) U+2028 (LS) U+2029 (PS)
  • true para U+0009 (TAB) y caracteres con categoría general "Zs" (separadores espaciales) excepto Zero Width Space (ZWSP, U+200B).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter «en blanco» o de «espacio horizontal», false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isblank("A"));
var_dump(IntlChar::isblank(" "));
var_dump(IntlChar::isblank("\t"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(true)

Ver también

  • IntlChar::isspace() - Comprobar si un punto de código es un carácter de espacio
  • IntlChar::isJavaSpaceChar() - Comprobar si un punto de código es un carácter de espacio según Java
  • IntlChar::isUWhiteSpace() - Comprobar si un punto de código tiene la propiedad de Unicode White_Space
  • IntlChar::isWhitespace() - Comprobar si un punto de código es un carácter de espacio en blanco según ICU


Comprobar si un punto de código es un carácter de control

  • « IntlChar::isblank
  • IntlChar::isdefined »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de control

IntlChar::iscntrl

(PHP 7)

IntlChar::iscntrl — Comprobar si un punto de código es un carácter de control

Descripción

public static IntlChar::iscntrl ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter de control.

Un carácter de control es uno de los siguientes:

  • Carácter de control de 8 bits de ISO (U+0000..U+001f and U+007f..U+009f)
  • IntlChar::CHAR_CATEGORY_CONTROL_CHAR (Cc)
  • IntlChar::CHAR_CATEGORY_FORMAT_CHAR (Cf)
  • IntlChar::CHAR_CATEGORY_LINE_SEPARATOR (Zl)
  • IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR (Zp)

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de control, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::iscntrl("A"));
var_dump(IntlChar::iscntrl(" "));
var_dump(IntlChar::iscntrl("\n"));
var_dump(IntlChar::iscntrl("\u{200e}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(true)
bool(true)

Ver también

  • IntlChar::isprint() - Comprobar si un punto de código es un carácter imprimible
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Comprobar si un punto de código está definido

  • « IntlChar::iscntrl
  • IntlChar::isdigit »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código está definido

IntlChar::isdefined

(PHP 7)

IntlChar::isdefined — Comprobar si un punto de código está definido

Descripción

public static IntlChar::isdefined ( mixed $codepoint ) : bool

Determina si el punto de código especificado está «definido», lo que normalmente significa que tiene asignado un caráter.

true para las catergorías generales distintas de "Cn" (otros, no asignado).

Nota:

Observe que los puntos de código que no son un carácter (p.ej., U+FDD0) no están «definidos» (son Cn), mientras que los puntos de código sustitutos están «definidos» (Cs).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter definido, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isdefined("A"));
var_dump(IntlChar::isdefined(" "));
var_dump(IntlChar::isdefined("\u{FDD0}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)

Ver también

  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito
  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isalnum() - Comporbar si un punto de código es un carácter alfanumérico
  • IntlChar::isupper() - Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
  • IntlChar::islower() - Comprobar si un punto de código es una letra minúscula
  • IntlChar::istitle() - Comprobar si un punto de código es una letra titular


Comprobar si un punto de código es un carácter de dígito

  • « IntlChar::isdefined
  • IntlChar::isgraph »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de dígito

IntlChar::isdigit

(PHP 7)

IntlChar::isdigit — Comprobar si un punto de código es un carácter de dígito

Descripción

public static IntlChar::isdigit ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter de dígito.

true para caracteres con categoría general "Nd" (números de dígito decimal). Desde Unicode 4, esto es lo mismo que probar el Numeric_Type de Decimal.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de dígito, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isdigit("A"));
var_dump(IntlChar::isdigit("1"));
var_dump(IntlChar::isdigit("\t"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)

Ver también

  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isalnum() - Comporbar si un punto de código es un carácter alfanumérico
  • IntlChar::isxdigit() - Comprobar si el punto de código es un dígito hexadecimal


Comprobar si un punto de código es un caráter gráfico

  • « IntlChar::isdigit
  • IntlChar::isIDIgnorable »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un caráter gráfico

IntlChar::isgraph

(PHP 7)

IntlChar::isgraph — Comprobar si un punto de código es un caráter gráfico

Descripción

public static IntlChar::isgraph ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter «graphic» (imprimible, excluyendo los espacios).

true para todos los caracteres excepto aquellos con categorías generales "Cc" (códigos de control), "Cf" (controles de formato), "Cs" (sustitutos), "Cn" (sin asignar), y "Z" (separadores).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un caráter «gráfico», false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isgraph("A"));
var_dump(IntlChar::isgraph("1"));
var_dump(IntlChar::isgraph("\u{2603}"));
var_dump(IntlChar::isgraph("\n"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(false)


Comprobar si un punto de código es un carácter ignorable

  • « IntlChar::isgraph
  • IntlChar::isIDPart »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter ignorable

IntlChar::isIDIgnorable

(PHP 7)

IntlChar::isIDIgnorable — Comprobar si un punto de código es un carácter ignorable

Descripción

public static IntlChar::isIDIgnorable ( mixed $codepoint ) : bool

Determina si el carácter especificado debería ser considerado como carácter ignorable en un identificador.

true para caracteres con categoría general "Cf" (controles de formato) así como con controles ISO que no pertenecen al espacio en blanco (U+0000..U+0008, U+000E..U+001B, U+007F..U+009F).

Nota:

Observe que Unicode recomienda simplemente ignorar Cf (controles de formato).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es ignorable en identificadores, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isIDIgnorable("A"));
var_dump(IntlChar::isIDIgnorable(" "));
var_dump(IntlChar::isIDIgnorable("\u{007F}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(false)
bool(true)

Ver también

  • IntlChar::isIDStart() - Comprobar si un punto de código es permisible como el primer carácter de un identificador
  • IntlChar::isIDPart() - Comprobar si un punto de código es permisible en un identificador
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Comprobar si un punto de código es permisible en un identificador

  • « IntlChar::isIDIgnorable
  • IntlChar::isIDStart »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es permisible en un identificador

IntlChar::isIDPart

(PHP 7)

IntlChar::isIDPart — Comprobar si un punto de código es permisible en un identificador

Descripción

public static IntlChar::isIDPart ( mixed $codepoint ) : bool

Determinar si el carácter especficiado es permisible en un identificador.

true para caracteres con categorías generales "L" (letras), "Nl" (números de letra), "Nd" (dígitos decimales), "Mc" y "Mn" (marcas de combinación), "Pc" (puntuación de conexión), y u_isIDIgnorable(c).

Nota:

Esto es casi lo mismo que ID_Continue de Unicode (IntlChar::PROPERTY_ID_CONTINUE) excepto que Unicode recomienda ignorar Cf, el cual es menor que IntlChar::isIDIgnorable().

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint podría darse en un identificador, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isIDPart("A"));
var_dump(IntlChar::isIDPart("$"));
var_dump(IntlChar::isIDPart("\n"));
var_dump(IntlChar::isIDPart("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)
bool(false)

Ver también

  • IntlChar::isIDIgnorable() - Comprobar si un punto de código es un carácter ignorable
  • IntlChar::isIDStart() - Comprobar si un punto de código es permisible como el primer carácter de un identificador
  • IntlChar::PROPERTY_ID_CONTINUE


Comprobar si un punto de código es permisible como el primer carácter de un identificador

  • « IntlChar::isIDPart
  • IntlChar::isISOControl »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es permisible como el primer carácter de un identificador

IntlChar::isIDStart

(PHP 7)

IntlChar::isIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador

Descripción

public static IntlChar::isIDStart ( mixed $codepoint ) : bool

Determna si el carácter especficado es permisible como el primer carácter de un identificador según Unicode (El Estándar de Unicode, Versión 3.0, capítulo 5.16 Identificadores).

true para caracteres con categorías generales "L" (letras) y "Nl" (números de letra).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint podría iniciar un identificador, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isIDStart("A"));
var_dump(IntlChar::isIDStart("$"));
var_dump(IntlChar::isIDStart("\n"));
var_dump(IntlChar::isIDStart("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)
bool(false)

Ver también

  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isIDPart() - Comprobar si un punto de código es permisible en un identificador
  • IntlChar::PROPERTY_ID_START


Comprobar si un punto de código es un código de control de ISO

  • « IntlChar::isIDStart
  • IntlChar::isJavaIDPart »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un código de control de ISO

IntlChar::isISOControl

(PHP 7)

IntlChar::isISOControl — Comprobar si un punto de código es un código de control de ISO

Descripción

public static IntlChar::isISOControl ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un código de control de ISO.

true para U+0000..U+001f y U+007f..U+009f (categoría general "Cc").

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devueve true si codepoint es un código de control de ISO, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isISOControl(" "));
var_dump(IntlChar::isISOControl("\n"));
var_dump(IntlChar::isISOControl("\u{200e}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)

Ver también

  • IntlChar::iscntrl() - Comprobar si un punto de código es un carácter de control


Comprobar si un punto de código es permisible en un identificador de Java

  • « IntlChar::isISOControl
  • IntlChar::isJavaIDStart »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es permisible en un identificador de Java

IntlChar::isJavaIDPart

(PHP 7)

IntlChar::isJavaIDPart — Comprobar si un punto de código es permisible en un identificador de Java

Descripción

public static IntlChar::isJavaIDPart ( mixed $codepoint ) : bool

Determina si el carácter especificado es permisible en un identificador de Java.

Además de IntlChar::isIDPart(), true para caracteres con categoría general "Sc" (símbolos de moneda).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint podría darse en un identificador de Java, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isJavaIDPart("A"));
var_dump(IntlChar::isJavaIDPart("$"));
var_dump(IntlChar::isJavaIDPart("\n"));
var_dump(IntlChar::isJavaIDPart("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::isIDIgnorable() - Comprobar si un punto de código es un carácter ignorable
  • IntlChar::isIDPart() - Comprobar si un punto de código es permisible en un identificador
  • IntlChar::isJavaIDStart() - Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java
  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito


Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java

  • « IntlChar::isJavaIDPart
  • IntlChar::isJavaSpaceChar »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java

IntlChar::isJavaIDStart

(PHP 7)

IntlChar::isJavaIDStart — Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java

Descripción

public static IntlChar::isJavaIDStart ( mixed $codepoint ) : bool

Determina si el carácter esepecficado es permisible como el incio de un identificador de Java.

Además de IntlChar::isIDStart(), true para caracteres con categorías generales "Sc" (símbolos de moneda) y "Pc" (puntuación de conexión).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint podría iniciar un identificador de Java, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isJavaIDStart("A"));
var_dump(IntlChar::isJavaIDStart("$"));
var_dump(IntlChar::isJavaIDStart("\n"));
var_dump(IntlChar::isJavaIDStart("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::isIDStart() - Comprobar si un punto de código es permisible como el primer carácter de un identificador
  • IntlChar::isJavaIDPart() - Comprobar si un punto de código es permisible en un identificador de Java
  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra


Comprobar si un punto de código es un carácter de espacio según Java

  • « IntlChar::isJavaIDStart
  • IntlChar::islower »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de espacio según Java

IntlChar::isJavaSpaceChar

(PHP 7)

IntlChar::isJavaSpaceChar — Comprobar si un punto de código es un carácter de espacio según Java

Descripción

public static IntlChar::isJavaSpaceChar ( mixed $codepoint ) : bool

Determina si es punto de código especificado es un carácter de espacio según Java.

true para caracterse con la categoría general "Z" (separadores), lo que no incluye códigos de control (p.ej., TAB o Line Feed).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de espacio según Java, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isJavaSpaceChar("A"));
var_dump(IntlChar::isJavaSpaceChar(" "));
var_dump(IntlChar::isJavaSpaceChar("\n"));
var_dump(IntlChar::isJavaSpaceChar("\t"));
var_dump(IntlChar::isJavaSpaceChar("\u{00A0}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)
bool(false)
bool(true)

Ver también

  • IntlChar::isspace() - Comprobar si un punto de código es un carácter de espacio
  • IntlChar::isWhitespace() - Comprobar si un punto de código es un carácter de espacio en blanco según ICU
  • IntlChar::isUWhiteSpace() - Comprobar si un punto de código tiene la propiedad de Unicode White_Space


Comprobar si un punto de código es una letra minúscula

  • « IntlChar::isJavaSpaceChar
  • IntlChar::isMirrored »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es una letra minúscula

IntlChar::islower

(PHP 7)

IntlChar::islower — Comprobar si un punto de código es una letra minúscula

Descripción

public static IntlChar::islower ( mixed $codepoint ) : bool

Determina si el punto de código especificado tiene la categoría general "Ll" (letra minúscula).

Nota:

Este método erra con algunos caracteres que tambíen son minúscula pero tienen un valor diferente de categoría general. Para incluirlos, use IntlChar::isULowercase().

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es una letra minúscula de Ll, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::islower("A"));
var_dump(IntlChar::islower("a"));
var_dump(IntlChar::islower("F"));
var_dump(IntlChar::islower("f"));
var_dump(IntlChar::islower("1"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

Ver también

  • IntlChar::isupper() - Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
  • IntlChar::istitle() - Comprobar si un punto de código es una letra titular
  • IntlChar::tolower() - Convertir a minúsculas un carácter Unicode
  • IntlChar::toupper() - Convertir a mayúsculas un carácter Unicode
  • IntlChar::PROPERTY_LOWERCASE


Comprobar si un punto de código posee la propiedad Bidi_Mirrored

  • « IntlChar::islower
  • IntlChar::isprint »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código posee la propiedad Bidi_Mirrored

IntlChar::isMirrored

(PHP 7)

IntlChar::isMirrored — Comprobar si un punto de código posee la propiedad Bidi_Mirrored

Descripción

public static IntlChar::isMirrored ( mixed $codepoint ) : bool

Determina si el punto de código posee la propiedad Bidi_Mirrored.

Esta propiedad se establece para caracteres que se utilizan normalmente en contextos Deracha-Izquierda, siendo necesario mostrarlos con un glifo «reflejado».

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint posee la propiedad Bidi_Mirrored, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isMirrored("A"));
var_dump(IntlChar::isMirrored("<"));
var_dump(IntlChar::isMirrored("("));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(true)

Ver también

  • IntlChar::charMirror() - Obtener el carácter de «imagen reflejada» de un punto de código
  • IntlChar::PROPERTY_BIDI_MIRRORED


Comprobar si un punto de código es un carácter imprimible

  • « IntlChar::isMirrored
  • IntlChar::ispunct »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter imprimible

IntlChar::isprint

(PHP 7)

IntlChar::isprint — Comprobar si un punto de código es un carácter imprimible

Descripción

public static IntlChar::isprint ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter imprimible.

true para categorías generales distintas de "C" (controles).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter imprimible, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isprint("A"));
var_dump(IntlChar::isprint(" "));
var_dump(IntlChar::isprint("\n"));
var_dump(IntlChar::isprint("\u{200e}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::iscntrl() - Comprobar si un punto de código es un carácter de control
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Comprobar si un punto de código es un carácter de puntuación

  • « IntlChar::isprint
  • IntlChar::isspace »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de puntuación

IntlChar::ispunct

(PHP 7)

IntlChar::ispunct — Comprobar si un punto de código es un carácter de puntuación

Descripción

public static IntlChar::ispunct ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un carácter de puntuación.

true para caracteres con categoría general "P" (puntuación).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de puntuación, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::ispunct("."));
var_dump(IntlChar::ispunct(","));
var_dump(IntlChar::ispunct("\n"));
var_dump(IntlChar::ispunct("$"));

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(false)


Comprobar si un punto de código es un carácter de espacio

  • « IntlChar::ispunct
  • IntlChar::istitle »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de espacio

IntlChar::isspace

(PHP 7)

IntlChar::isspace — Comprobar si un punto de código es un carácter de espacio

Descripción

public static IntlChar::isspace ( mixed $codepoint ) : bool

Determina si el carácter especificado es o no un carácter de espacio.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de espacio, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isspace("A"));
var_dump(IntlChar::isspace(" "));
var_dump(IntlChar::isspace("\n"));
var_dump(IntlChar::isspace("\t"));
var_dump(IntlChar::isspace("\u{00A0}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(true)
bool(true)
bool(true)

Ver también

  • IntlChar::isJavaSpaceChar() - Comprobar si un punto de código es un carácter de espacio según Java
  • IntlChar::isWhitespace() - Comprobar si un punto de código es un carácter de espacio en blanco según ICU
  • IntlChar::isUWhiteSpace() - Comprobar si un punto de código tiene la propiedad de Unicode White_Space


Comprobar si un punto de código es una letra titular

  • « IntlChar::isspace
  • IntlChar::isUAlphabetic »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es una letra titular

IntlChar::istitle

(PHP 7)

IntlChar::istitle — Comprobar si un punto de código es una letra titular

Descripción

public static IntlChar::istitle ( mixed $codepoint ) : bool

Determina si el punto de código especificado es una letra titular.

true para la categoría general "Lt" (letra titular).

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es una letra titular, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::istitle("A"));
var_dump(IntlChar::istitle("a"));
var_dump(IntlChar::istitle("F"));
var_dump(IntlChar::istitle("f"));
var_dump(IntlChar::istitle("1"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

Ver también

  • IntlChar::isupper() - Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
  • IntlChar::islower() - Comprobar si un punto de código es una letra minúscula
  • IntlChar::totitle() - Convertir un carácter Unicode a letra titular


Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic

  • « IntlChar::istitle
  • IntlChar::isULowercase »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic

IntlChar::isUAlphabetic

(PHP 7)

IntlChar::isUAlphabetic — Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic

Descripción

public static IntlChar::isUAlphabetic ( mixed $codepoint ) : bool

Comprueba si un punto de código tiene la propiedad de Unicode Alphabetic.

Esto es lo mismo que IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_ALPHABETIC)

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint tiene la propiedad de Unicode Alphabetic, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isUAlphabetic("A"));
var_dump(IntlChar::isUAlphabetic("1"));
var_dump(IntlChar::isUAlphabetic("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::isalpha() - Comprobar si un punto de código es un caracter de letra
  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::PROPERTY_ALPHABETIC


Comprobar si un punto de código tiene la propiedad de Unicode Lowercase

  • « IntlChar::isUAlphabetic
  • IntlChar::isupper »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código tiene la propiedad de Unicode Lowercase

IntlChar::isULowercase

(PHP 7)

IntlChar::isULowercase — Comprobar si un punto de código tiene la propiedad de Unicode Lowercase

Descripción

public static IntlChar::isULowercase ( mixed $codepoint ) : bool

Comprueba si un punto de código tiene la propiedad de Unicode Lowercase.

Esto es lo mismo que IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_LOWERCASE)

Nota:

Esto es diferente que IntlChar::islower() y devolverá true para más caracteres.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint tiene la propiedad de Unicode Lowercase, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isULowercase("A"));
var_dump(IntlChar::isULowercase("a"));
var_dump(IntlChar::isULowercase("F"));
var_dump(IntlChar::isULowercase("f"));
var_dump(IntlChar::isULowercase("1"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

Ver también

  • IntlChar::islower() - Comprobar si un punto de código es una letra minúscula
  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::PROPERTY_LOWERCASE


Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)

  • « IntlChar::isULowercase
  • IntlChar::isUUppercase »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)

IntlChar::isupper

(PHP 7)

IntlChar::isupper — Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)

Descripción

public static IntlChar::isupper ( mixed $codepoint ) : bool

Determina si el punto de código especificado tiene la categoría general "Lu" (letra mayúscula).

Nota:

Este método erra con algunos caracteres que tambíen son mayúscula pero tienen un valor diferente de categoría general. Para incluirlos, use IntlChar::isUUppercase().

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es una letra mayúscula de Lu, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isupper("A"));
var_dump(IntlChar::isupper("a"));
var_dump(IntlChar::isupper("F"));
var_dump(IntlChar::isupper("f"));
var_dump(IntlChar::isupper("1"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::islower() - Comprobar si un punto de código es una letra minúscula
  • IntlChar::istitle() - Comprobar si un punto de código es una letra titular
  • IntlChar::tolower() - Convertir a minúsculas un carácter Unicode
  • IntlChar::toupper() - Convertir a mayúsculas un carácter Unicode
  • IntlChar::PROPERTY_UPPERCASE


Comprobar si un punto de código tiene la propiedad de Unicode Uppercase

  • « IntlChar::isupper
  • IntlChar::isUWhiteSpace »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código tiene la propiedad de Unicode Uppercase

IntlChar::isUUppercase

(PHP 7)

IntlChar::isUUppercase — Comprobar si un punto de código tiene la propiedad de Unicode Uppercase

Descripción

public static IntlChar::isUUppercase ( mixed $codepoint ) : bool

Comprueba si un punto de código tiene la propiedad de Unicode Uppercase.

Esto es lo mismo que IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_UPPERCASE)

Nota:

Esto es diferente que IntlChar::isupper() y devolverá true para más caracteres.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint tiene la propiedad de Unicode Uppercase, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isUUppercase("A"));
var_dump(IntlChar::isUUppercase("a"));
var_dump(IntlChar::isUUppercase("F"));
var_dump(IntlChar::isUUppercase("f"));
var_dump(IntlChar::isUUppercase("1"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Ver también

  • IntlChar::isupper() - Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::PROPERTY_UPPERCASE


Comprobar si un punto de código tiene la propiedad de Unicode White_Space

  • « IntlChar::isUUppercase
  • IntlChar::isWhitespace »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código tiene la propiedad de Unicode White_Space

IntlChar::isUWhiteSpace

(PHP 7)

IntlChar::isUWhiteSpace — Comprobar si un punto de código tiene la propiedad de Unicode White_Space

Descripción

public static IntlChar::isUWhiteSpace ( mixed $codepoint ) : bool

Comprueba si un punto de código tiene la propiedad de Unicode White_Space.

Esto es lo mismo que IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_WHITE_SPACE)

Nota:

Esto es diferente de IntlChar::isspace() y de IntlChar::isWhitespace().

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint tiene la propiedad de Unicode White_Space, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isUWhiteSpace("A"));
var_dump(IntlChar::isUWhiteSpace(" "));
var_dump(IntlChar::isUWhiteSpace("\n"));
var_dump(IntlChar::isUWhiteSpace("\t"));
var_dump(IntlChar::isUWhiteSpace("\u{00A0}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(true)
bool(true)
bool(true)

Ver también

  • IntlChar::isspace() - Comprobar si un punto de código es un carácter de espacio
  • IntlChar::isWhitespace() - Comprobar si un punto de código es un carácter de espacio en blanco según ICU
  • IntlChar::isJavaSpaceChar() - Comprobar si un punto de código es un carácter de espacio según Java
  • IntlChar::hasBinaryProperty() - Comprobar una propiedad de Unicode binaria para un punto de código
  • IntlChar::PROPERTY_WHITE_SPACE


Comprobar si un punto de código es un carácter de espacio en blanco según ICU

  • « IntlChar::isUWhiteSpace
  • IntlChar::isxdigit »
  • PHP Manual
  • IntlChar
  • Comprobar si un punto de código es un carácter de espacio en blanco según ICU

IntlChar::isWhitespace

(PHP 7)

IntlChar::isWhitespace — Comprobar si un punto de código es un carácter de espacio en blanco según ICU

Descripción

public static IntlChar::isWhitespace ( mixed $codepoint ) : bool

Determina si el punto de código es un carácter de espacio en blanco según ICU.

Un carácter se considera un carácter de espacio en blanco de Java si satisface uno de los siguientes criterios:

  • Es un carácter Separador de Unicode (categorías "Z" = "Zs" o "Zl" o "Zp"), pero no es también un espacio de no ruptura (U+00A0 NBSP o U+2007 Figure Space o U+202F Narrow NBSP).
  • Es un U+0009 HORIZONTAL TABULATION.
  • Es un U+000A LINE FEED.
  • Es un U+000B VERTICAL TABULATION.
  • Es un U+000C FORM FEED.
  • Es un U+000D CARRIAGE RETURN.
  • Es un U+001C FILE SEPARATOR.
  • Es un U+001D GROUP SEPARATOR.
  • Es un U+001E RECORD SEPARATOR.
  • Es un U+001F UNIT SEPARATOR.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter de espacio en blanco según ICU, false si no.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::iswhitespace("A"));
var_dump(IntlChar::iswhitespace(" "));
var_dump(IntlChar::iswhitespace("\n"));
var_dump(IntlChar::iswhitespace("\t"));
var_dump(IntlChar::iswhitespace("\u{00A0}"));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
bool(true)
bool(true)
bool(false)

Ver también

  • IntlChar::isspace() - Comprobar si un punto de código es un carácter de espacio
  • IntlChar::isJavaSpaceChar() - Comprobar si un punto de código es un carácter de espacio según Java
  • IntlChar::isUWhiteSpace() - Comprobar si un punto de código tiene la propiedad de Unicode White_Space


Comprobar si el punto de código es un dígito hexadecimal

  • « IntlChar::isWhitespace
  • IntlChar::ord »
  • PHP Manual
  • IntlChar
  • Comprobar si el punto de código es un dígito hexadecimal

IntlChar::isxdigit

(PHP 7)

IntlChar::isxdigit — Comprobar si el punto de código es un dígito hexadecimal

Descripción

public static IntlChar::isxdigit ( mixed $codepoint ) : bool

Determina si el punto de código especificado es un dígito hexadecimal.

true para caracteres con la categoría general "Nd" (números de dígito decimal) así como con las letras latinas a-f y A-F tanto en ASCII como en ASCII de ancho completo. (Esto es, para letras con puntos de código 0041..0046, 0061..0066, FF21..FF26, FF41..FF46).

Esto equivale a IntlChar::digit($codepoint, 16) >= 0.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve true si codepoint es un carácter hexadecimal, false si no.

Notas

Nota:

Para limitar la definición de dígitos hexadecimales a caracteres ASCII solo, emplee:

<?php
$isASCIIHexadecimal = IntlChar::ord($codepoint) <= 0x7F && IntlChar::isxdigit($codepoint);
?>

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::isxdigit("A"));
var_dump(IntlChar::isxdigit("1"));
var_dump(IntlChar::isxdigit("\u{2603}"));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)

Ver también

  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito


Devolver el valor del punto de código de Unicode de un carácter

  • « IntlChar::isxdigit
  • IntlChar::tolower »
  • PHP Manual
  • IntlChar
  • Devolver el valor del punto de código de Unicode de un carácter

IntlChar::ord

(PHP 7)

IntlChar::ord — Devolver el valor del punto de código de Unicode de un carácter

Descripción

public static IntlChar::ord ( mixed $character ) : int

Devuelve el valor del punto de código de Unicode del carácter dado.

Esta función complementa a IntlChar::chr().

Parámetros

character

Un carácter Unicode.

Valores devueltos

Devuelve el valor del punto de código de Unicode, como integer.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::ord("A"));
var_dump(IntlChar::ord(" "));
var_dump(IntlChar::ord("\u{2603}"));
?>

El resultado del ejemplo sería:

int(65)
int(32)
int(9731)

Ver también

  • IntlChar::isalnum() - Comporbar si un punto de código es un carácter alfanumérico
  • IntlChar::isdigit() - Comprobar si un punto de código es un carácter de dígito
  • IntlChar::chr() - Devolver el carácter Unicode mediante su valor de punto de código
  • ord() - Convierte el primer byte de un string a un valor entre 0 y 255


Convertir a minúsculas un carácter Unicode

  • « IntlChar::ord
  • IntlChar::totitle »
  • PHP Manual
  • IntlChar
  • Convertir a minúsculas un carácter Unicode

IntlChar::tolower

(PHP 7)

IntlChar::tolower — Convertir a minúsculas un carácter Unicode

Descripción

public static IntlChar::tolower ( mixed $codepoint ) : mixed

Se hace corresponder el carácter dado con su equivalente en minúsculas. Si el carácter no tiene dicho equivalente, se devuelve el carácter en sí.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el Simple_Lowercase_Mapping del punto de código, si lo hubiera; de lo contrario devuelve el punto de código en sí.

El tipo devuelto será integer a menos que el punto de código se pase como un string UTF-8, en cuyo caso será devuelto un string.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::tolower("A"));
var_dump(IntlChar::tolower("a"));
var_dump(IntlChar::tolower("F"));
var_dump(IntlChar::tolower("f"));
var_dump(IntlChar::tolower("1"));
var_dump(IntlChar::tolower(ord("A")));
var_dump(IntlChar::tolower(ord("a")));
?>

El resultado del ejemplo sería:

string(1) "a"
string(1) "a"
string(2) "f"
string(2) "f"
string(1) "1"
int(97)
int(97)

Ver también

  • IntlChar::totitle() - Convertir un carácter Unicode a letra titular
  • IntlChar::toupper() - Convertir a mayúsculas un carácter Unicode
  • mb_strtolower() - Convierte una cadena de caracteres a minúsculas


Convertir un carácter Unicode a letra titular

  • « IntlChar::tolower
  • IntlChar::toupper »
  • PHP Manual
  • IntlChar
  • Convertir un carácter Unicode a letra titular

IntlChar::totitle

(PHP 7)

IntlChar::totitle — Convertir un carácter Unicode a letra titular

Descripción

public static IntlChar::totitle ( mixed $codepoint ) : mixed

Se hace corresponder el carácter dado con su equivalente de letra titular. Si el carácter no tiene dicho equivalente, se devuelve el carácter en sí.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el Simple_Titlecase_Mapping del punto de código, si lo hubiera; de lo contrario devuelve el punto de código en sí.

El tipo devuelto será integer a menos que el punto de código se pase como un string UTF-8, en cuyo caso será devuelto un string.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::totitle("A"));
var_dump(IntlChar::totitle("a"));
var_dump(IntlChar::totitle("F"));
var_dump(IntlChar::totitle("f"));
var_dump(IntlChar::totitle("1"));
var_dump(IntlChar::totitle(ord("A")));
var_dump(IntlChar::totitle(ord("a")));
?>

El resultado del ejemplo sería:

string(1) "A"
string(1) "A"
string(2) "F"
string(2) "F"
string(1) "1"
int(65)
int(65)

Ver también

  • IntlChar::tolower() - Convertir a minúsculas un carácter Unicode
  • IntlChar::toupper() - Convertir a mayúsculas un carácter Unicode
  • mb_convert_case() - Realiza una conversión a mayúsculas/minúsculas de un string


Convertir a mayúsculas un carácter Unicode

  • « IntlChar::totitle
  • IntlException »
  • PHP Manual
  • IntlChar
  • Convertir a mayúsculas un carácter Unicode

IntlChar::toupper

(PHP 7)

IntlChar::toupper — Convertir a mayúsculas un carácter Unicode

Descripción

public static IntlChar::toupper ( mixed $codepoint ) : mixed

Se hace corresponder el carácter dado con su equivalente en mayúsculas. Si el carácter no tiene dicho equivalente, se devuelve el carácter en sí.

Parámetros

codepoint

El valor de tipo integer del punto de código (p.ej. 0x2603 para U+2603 SNOWMAN), o el carácter codificado como un string UTF-8 (p.ej. "\u{2603}")

Valores devueltos

Devuelve el Simple_Uppercase_Mapping del punto de código, si lo hubiera; de lo contrario devuelve el punto de código en sí.

El tipo devuelto será integer a menos que el punto de código se pase como un string UTF-8, en cuyo caso será devuelto un string.

Ejemplos

Ejemplo #1 Probar diferentes puntos de código

<?php
var_dump(IntlChar::toupper("A"));
var_dump(IntlChar::toupper("a"));
var_dump(IntlChar::toupper("F"));
var_dump(IntlChar::toupper("f"));
var_dump(IntlChar::toupper("1"));
var_dump(IntlChar::toupper(ord("A")));
var_dump(IntlChar::toupper(ord("a")));
?>

El resultado del ejemplo sería:

string(1) "A"
string(1) "A"
string(2) "F"
string(2) "F"
string(1) "1"
int(65)
int(65)

Ver también

  • IntlChar::tolower() - Convertir a minúsculas un carácter Unicode
  • IntlChar::totitle() - Convertir un carácter Unicode a letra titular
  • mb_strtoupper() - Convierte un string en mayúsculas


Clase de excepciones para errores de intl

(PHP 5 > 5.5.0, PHP 7, PECL intl > 3.0.0a1)

Introducción

Esta clase se usa para generar excepciones ocurridos dentro de las funciones de intl. Tales excepciones se generan únicamente cuando intl.use_exceptions está habilitado.

Sinopsis de la Clase

IntlException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase IntlIterator

(PHP 5 >= 5.5.0, PHP 7)

Introducción

Esta clase representa objetos iteradores a lo largo de la extensión intl siempre que el iterador no pueda ser identificado con ningún otro objeto proporcionado por la extensión. El objeto iterador diferente usado internamente por el constructor foreach solamente se puede obtener (en lo que concierne aquí) desde objetos, por lo que los objetos de esta clase sirven al propósito de proporcionar el gancho a través del cual se puede obtener este objeto interno. Como ventaja, esta clase también implementa la interfaz Iterator, permitiendo que se pueda navegar a través de la colección de valores usando los métodos definidos en esa interfaz. Tanto estos métodos como los objetos iteradores internos proporcionados a foreach se apoyan en el mismo estado (p.ej. la posición del iterador y su valor actual).

Las subclases podrían proporcionar una funcionalidad más rica.

Sinopsis de la Clase

IntlIterator implements Iterator {
/* Métodos */
public current ( ) : ReturnType
public key ( ) : ReturnType
public next ( ) : ReturnType
public rewind ( ) : ReturnType
public valid ( ) : ReturnType
}

Tabla de contenidos

  • IntlIterator::current — Obtiene el elemento actual
  • IntlIterator::key — Obtiene la clave actual
  • IntlIterator::next — Adelanta hasta el siguiente elemento
  • IntlIterator::rewind — Mueve el iterador al primer elemento
  • IntlIterator::valid — Comprueba si la posición actual es válida


Obtiene el elemento actual

  • « IntlIterator
  • IntlIterator::key »
  • PHP Manual
  • IntlIterator
  • Obtiene el elemento actual

IntlIterator::current

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::current — Obtiene el elemento actual

Descripción

public IntlIterator::current ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene la clave actual

  • « IntlIterator::current
  • IntlIterator::next »
  • PHP Manual
  • IntlIterator
  • Obtiene la clave actual

IntlIterator::key

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::key — Obtiene la clave actual

Descripción

public IntlIterator::key ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Adelanta hasta el siguiente elemento

  • « IntlIterator::key
  • IntlIterator::rewind »
  • PHP Manual
  • IntlIterator
  • Adelanta hasta el siguiente elemento

IntlIterator::next

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::next — Adelanta hasta el siguiente elemento

Descripción

public IntlIterator::next ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Mueve el iterador al primer elemento

  • « IntlIterator::next
  • IntlIterator::valid »
  • PHP Manual
  • IntlIterator
  • Mueve el iterador al primer elemento

IntlIterator::rewind

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::rewind — Mueve el iterador al primer elemento

Descripción

public IntlIterator::rewind ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Comprueba si la posición actual es válida

  • « IntlIterator::rewind
  • Funciones de intl »
  • PHP Manual
  • IntlIterator
  • Comprueba si la posición actual es válida

IntlIterator::valid

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::valid — Comprueba si la posición actual es válida

Descripción

public IntlIterator::valid ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Funciones de intl

Tabla de contenidos

  • intl_error_name — Obtiene un nombre simbólico a partir de un código de error dado
  • intl_get_error_code — Obtiene el último código de error
  • intl_get_error_message — Obtener una descripción del último error
  • intl_is_failure — Comprueba si el código de error dado indica un fallo


Obtiene un nombre simbólico a partir de un código de error dado

  • « Funciones de intl
  • intl_get_error_code »
  • PHP Manual
  • Funciones de intl
  • Obtiene un nombre simbólico a partir de un código de error dado

intl_error_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_error_name — Obtiene un nombre simbólico a partir de un código de error dado

Descripción

intl_error_name ( int $error_code ) : string

Devuelve el nombre del código de error ICU.

Parámetros

error_code

Código de error ICU.

Valores devueltos

El string devuelto será el mismo que el nombre de la constante del código de error.

Ejemplos

Ejemplo #1 intl_error_name() ejemplo

<?php
$coll     = collator_create( 'en_RU' );
$err_code = collator_get_error_code( $coll );

printf( "Symbolic name for %d is %s\n.", $err_code, intl_error_name( $err_code ) );
?>

El resultado del ejemplo sería algo similar a:

Symbolic name for -128 is U_USING_FALLBACK_WARNING.

Ver también

  • intl_is_failure() - Comprueba si el código de error dado indica un fallo
  • intl_get_error_code() - Obtiene el último código de error
  • intl_get_error_message() - Obtener una descripción del último error


Obtiene el último código de error

  • « intl_error_name
  • intl_get_error_message »
  • PHP Manual
  • Funciones de intl
  • Obtiene el último código de error

intl_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_code — Obtiene el último código de error

Descripción

intl_get_error_code ( ) : int

Útil para controlar los errores acaecidos en los métodos estáticos cuando no hay un objeto para obtener el código de error de ellos.

Valores devueltos

Devolución del código de error por la última llamada a la función API.

Ejemplos

Ejemplo #1 intl_get_error_code() ejemplo

<?php
$coll = collator_create( '<bad_param>' );
if( !$coll ) {
    handle_error( intl_get_error_code() );
}
?>

Ver también

  • intl_is_failure() - Comprueba si el código de error dado indica un fallo
  • intl_error_name() - Obtiene un nombre simbólico a partir de un código de error dado
  • intl_get_error_message() - Obtener una descripción del último error
  • collator_get_error_code() - Obtener el último código de error del cotejeador
  • numfmt_get_error_code() - Obtener el último código de error del formateador


Obtener una descripción del último error

  • « intl_get_error_code
  • intl_is_failure »
  • PHP Manual
  • Funciones de intl
  • Obtener una descripción del último error

intl_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_message — Obtener una descripción del último error

Descripción

intl_get_error_message ( ) : string

Obtener el mensaje de error de la última llamada a la función internacionalizada.

Valores devueltos

Descripción de un error sucedido en la última llamada a la función API.

Ejemplos

Ejemplo #1 intl_get_error_message() ejemplo

<?php
if( Collator::getAvailableLocales() === false ) {
    show_error( intl_get_error_message() );
}
?>

Ver también

  • intl_error_name() - Obtiene un nombre simbólico a partir de un código de error dado
  • intl_get_error_code() - Obtiene el último código de error
  • intl_is_failure() - Comprueba si el código de error dado indica un fallo
  • collator_get_error_message() - Obtener el texto del último código de error del cotejador
  • numfmt_get_error_message() - Obtener el último mensaje de error del formateador


Comprueba si el código de error dado indica un fallo

  • « intl_get_error_message
  • Cadenas de caracteres multibyte »
  • PHP Manual
  • Funciones de intl
  • Comprueba si el código de error dado indica un fallo

intl_is_failure

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_is_failure — Comprueba si el código de error dado indica un fallo

Descripción

intl_is_failure ( int $error_code ) : bool

Parámetros

error_code

es un valor devuelto por las funciones: intl_get_error_code(), collator_get_error_code() .

Valores devueltos

true si el código indica algún fallo, y false en caso de éxito o de advertencia.

Ejemplos

Ejemplo #1 intl_is_failure() ejemplo

<?php
function check( $err_code )
{
    var_export( intl_is_failure( $err_code ) );
    echo "\n";
}

check( U_ZERO_ERROR );
check( U_USING_FALLBACK_WARNING );
check( U_ILLEGAL_ARGUMENT_ERROR );
?>

El resultado del ejemplo sería algo similar a:

false
false
true

Ver también

  • intl_get_error_code() - Obtiene el último código de error
  • collator_get_error_code() - Obtener el último código de error del cotejeador
  • Collator-getErrorCode() - Obtener el último código de error del cotejeador


Cadenas de caracteres multibyte

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Resumen de codificaciones soportadas
  • Lo básico sobre codificaciones multibytes del japonés
  • Entrada/Salida de HTTP
  • Codificaciones de caracteres admitidas
  • Sobrecarga de Funciones
  • Requerimientos para la codificación de caracteres en PHP
  • Funciones de cadenas de caracteres multibyte
    • mb_check_encoding — Comprueba si el string es válido para a la codificación especificada
    • mb_chr — Get a specific character
    • mb_convert_case — Realiza una conversión a mayúsculas/minúsculas de un string
    • mb_convert_encoding — Convierte una codificación de caracteres
    • mb_convert_kana — Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)
    • mb_convert_variables — Convierte códigos de caracteres a variable/s
    • mb_decode_mimeheader — Decodifica un string en el campo de cabecera MIME
    • mb_decode_numericentity — Decodifica referencias a string numéricas de HTML en caracteres
    • mb_detect_encoding — Detecta la codificación de caracteres
    • mb_detect_order — Establece/obtiene el orden de detección de codificaciones de caracteres
    • mb_encode_mimeheader — Codifica un string para la cabecera MIME
    • mb_encode_numericentity — Convierte caracteres a referencias de string numéricas de HTML
    • mb_encoding_aliases — Obtiene los alias de un tipo de codificación conocido
    • mb_ereg_match — Compararción de expresiones regulares para strings multibyte
    • mb_ereg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno
    • mb_ereg_replace — Reemplaza una expresión regular con soporte multibyte
    • mb_ereg_search_getpos — Devuelve la posición de inicio para la siguiente comparación de una expresión regular
    • mb_ereg_search_getregs — Recupera el resultado de la última comparación de expresión regular multibyte
    • mb_ereg_search_init — Configura el string y la expresión regular para una comparación de expresiones regulares multibyte
    • mb_ereg_search_pos — Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido
    • mb_ereg_search_regs — Devuelve la parte coincidente de una expresión regular multibyte
    • mb_ereg_search_setpos — Establece el punto de inicio de la siguiente comparación de una expresión regular
    • mb_ereg_search — Comparación de expresiones regulares multibyte para un string multibyte predefinido
    • mb_ereg — Comparación de expresiones regulares con soporte multibyte
    • mb_eregi_replace — Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas
    • mb_eregi — Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte
    • mb_get_info — Obtiene la configuración interna de mbstring
    • mb_http_input — Detecta la codificación de caracteres de entrada HTTP
    • mb_http_output — Establece/obtiene la codificación de caracteres de salida HTTP
    • mb_internal_encoding — Establece/obtiene la codificación de caracteres interna
    • mb_language — Establece/obtiene el idioma actual
    • mb_list_encodings — Devuelve un array con todos los tipos de codificaciones admitidas
    • mb_ord — Get code point of character
    • mb_output_handler — Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida
    • mb_parse_str — Analiza datos GET/POST/COOKIE y establece varialbes globales
    • mb_preferred_mime_name — Obtener un string del conjunto de caracteres del MIME
    • mb_regex_encoding — Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
    • mb_regex_set_options — Establece/obtiene las opciones predeterminadas para las funciones mbregex
    • mb_scrub — Description
    • mb_send_mail — Envía un correo codificado
    • mb_split — Divide cadenas de caracteres multibyte usando una expresión regular
    • mb_str_split — Given a multibyte string, return an array of its characters
    • mb_strcut — Obtener parte de un string
    • mb_strimwidth — Obtiene un string truncado con el ancho especificado
    • mb_stripos — Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_stristr — Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_strlen — Obtiene la longitud de una cadena de caracteres
    • mb_strpos — Busca la posición de la primera ocurrencia de un string en otro string
    • mb_strrchr — Busca la última ocurrencia de un carácter de un string dentro de otro
    • mb_strrichr — Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_strripos — Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas
    • mb_strrpos — Busca la posicion de la última ocurrencia de un string en otro string
    • mb_strstr — Busca la primera ocurrencia de un string dentro de otro
    • mb_strtolower — Convierte una cadena de caracteres a minúsculas
    • mb_strtoupper — Convierte un string en mayúsculas
    • mb_strwidth — Devuelve el ancho de un string
    • mb_substitute_character — Establece/obtiene un carácter de sustitución
    • mb_substr_count — Cuenta el número de ocurrencias de un substring
    • mb_substr — Obtiene parte de una cadena de caracteres


Introducción

Aunque exiten muchos idiomas en los cuales cada carácter necesario puede ser representado por una referencia uno a uno a un valor de 8 bits, existen también bastantes idiomas que requieren tantos caracteres para la comunicación escrita que no pueden ser representados dentro del rango que un mero byte puede codificar (un byte se compone de ocho bits. Cada bit puede contener solamente dos valores distintos, uno o cero. Debido a esto, con un byte solo se pueden representar 256 valores únicos (2 a la 8ª potencia)). Los esquemas de codificación multibyte fueron desarrollados precisamente para expresar más de 256 caracteres en el sistema de codificación regular a nivel de bits.

Cuando se manipulan cadenas de caracteres (trim, split, splice, etc.) en una codificación multibyte, es neceario utilizar funciones especiales, ya que dos o más bytes consecutivos pueden representar un único carácter en tal esquema de codificación. Si, de lo contrario, se usa una función que no considera caracteres multibyte con la cadena de caracteres, es probable que falle al detectar el comienzo o el final del carácter multibyte, y que se termine con una cadena de caracteres corrupta que probablemente pierda su significado original.

mbstring proporciona funciones específicas para cadenas de texto multibyte que ayudan a tratar codificaciones multibyte en PHP. Además, mbstring controla la conversión de la codificación de caracteres entre los posibles esquemas de codificación. mbstring está diseñada para manejar codificaciones basadas en Unicode, tales como UTF-8 y UCS-2, y, por conveniencia, varias codificaciones de un solo byte (enumeradas más adelante).


Instalación

mbstring es un extensión no predeterminada. Esto significa que no viene habilitada por defecto. Se debe habilitar específicamente el módulo con la opción configure durante la compilación. Véase la sección de Instalación para más información.

Las siguientes opciones de configuración se refieren al módulo mbstring.

  • --enable-mbstring: Habilita las funciones de mbstring. Esta opción es obligatoria para poder usar las funciones de mbstring.

    La biblioteca libmbfl es necesaria para mbstring. La biblioteca libmbfl está incluída con mbstring. Si libmbfl ya está instalada en el sistema, se puede especificar la ruta mediante la opción --with-libmbfl[=DIR].

    Desde PHP 4.3.0, la extensión mbstring provee soporte para chino simplificado, chino tradicional, coreano, ruso y japonés.

    En versiones PHP 4.3.3 o anteriores,
para habilitar esta característica, habrá que añadir una de las
siguientes opciones al parámetro LANG
de --enable-mbstring=LANG;
--enable-mbstring=cn para dar soporte a chino simplificado,
--enable-mbstring=tw para dar soporte a chino tradicional,
--enable-mbstring=kr para dar soporte a coreano,
--enable-mbstring=ru para dar Soporte a ruso, y
--enable-mbstring=ja para dar soporte a japonés (por defecto).
Para habilitar todas las codificaciones admitidas, se ha de usar --enable-mbstring=all.

    Nota:

    A Partir de PHP 4.3.4, todas las codificaciones admitidas por libmbfl se habilitan con --enable-mbstring.

  • --enable-mbstr-enc-trans : Habilita la conversión de codificaciones de caracteres introducidos a través de HTTP utilizando el motor de conversión de mbstring. Si se habilita esta característica, la codificación de los caracteres introducidos a través de HTTP puede ser convertida a mbstring.internal_encoding automáticamente.

    Nota:

    A partir de PHP 4.3.0, la opción --enable-mbstr-enc-trans fue eliminada y reemplazada con el ajuste en tiempo de ejecución mbstring.encoding_translation. La conversión de las codificaciones de caracteres vía HTTP se habilita cuando se establece a On (por defecto es Off).

  • --disable-mbregex: Deshabilita las funciones de expresiones regulares con soporte a caracteres multibyte.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de mbstring
Nombre | Por defecto | Cambiable | Historial de cambios
mbstring.language | "neutral" | PHP_INI_ALL | Disponible desde PHP 4.3.0. PHP_INI_PERDIR en PHP <= 5.2.6
mbstring.detect_order | NULL | PHP_INI_ALL | Disponible desde PHP 4.0.6.
mbstring.http_input | "pass" | PHP_INI_ALL | Disponible desde PHP 4.0.6. Obsoleta en PHP 5.6.0.
mbstring.http_output | "pass" | PHP_INI_ALL | Disponible desde PHP 4.0.6. Obsoleta en PHP 5.6.0.
mbstring.internal_encoding | NULL | PHP_INI_ALL | Disponible desde PHP 4.0.6. Obsoleta en PHP 5.6.0.
mbstring.script_encoding | NULL | PHP_INI_ALL | Disponible desde PHP 4.3.0. Eliminado en PHP 5.4.0. Use zend.script_encoding en su lugar.
mbstring.substitute_character | NULL | PHP_INI_ALL | Disponible desde PHP 4.0.6.
mbstring.func_overload | "0" | PHP_INI_SYSTEM | PHP_INI_PERDIR desde PHP 4.3 a 5.2.6, en versiones distintas PHP_INI_SYSTEM. Disponible desde PHP 4.2.0.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR | Disponible desde PHP 4.3.0.
mbstring.strict_detection | "0" | PHP_INI_ALL | Disponible desde PHP 5.1.2.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mbstring.language string

El ajuste de lenguaje nacional predeterminado (NLS) usado en mbstring. Se ha de observar que esta opción define automágicamente mbstring.internal_encoding, por lo que se debe colocar mbstring.internal_encoding tras mbstring.language en php.ini

mbstring.encoding_translation boolean

Habilita el filtro de codificación de caracteres transparente para las consultas HTTP entrantes, la cual lleva a cabo la detección y la conversión de la codificación de entrada a la codificación de caracteres interna.

mbstring.internal_encoding string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Define la codificación de caracteres interna.

Los usuarios de PHP 5.6 y posterior deberían dejarla vacía y establecer default_charset en su lugar.

mbstring.http_input string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Define la codificación de caracteres predeterminada de entrada de HTTP.

Los usuarios de PHP 5.6 y posterior deberían dejarla vacía y establecer default_charset en su lugar.

mbstring.http_output string
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.6.0. Su uso está totalmente desaconsejado.

Define la codificación de caracteres predeterminada de salida de HTTP (la salida será convertida de la codificación interna a la codificación de salida de HTTP).

Los usuarios de PHP 5.6 y posterior deberían dejarla vacía y establecer default_charset en su lugar.

mbstring.detect_order string

Define el orden de detección de códigos de caracteres predeterminado. Véase también mb_detect_order().

mbstring.substitute_character string

Define el caracter de sustitución para juegos de caracteres inválidos.

mbstring.func_overload string

Reemplaza determinadas funciones de único byte por sus equivalentes en mbstring. Véase la sección Sobrecarga de funciones para más información.

Este ajuste sólo puede ser cambiado en el archivo php.ini

mbstring.strict_detection boolean

Habilita la detección estricta de codificaciones.

De acuerdo a la » especificación de HTML 4.01, se permite que los navegadores envíen un formulario con una codificación diferente a la utilizada por la página. Véase mb_http_input() para consultar los juegos de caracteres utilizados por los navegadores.

Pese a que la mayoría de navegadores son capaces de averiguar la codificación de un determinado documento HTML, es aconsejable utilizar el parámetro charset en la cabecera Content-Type de HTTP con un valor apropiado, mediante header() o mediante el ajuste ini default_charset.

Ejemplo #1 Ejemplos de ajustes de php.ini

; Establecer el lenguaje predeterminado
mbstring.language        = Neutral; Establecer el lenguaje neutral(UTF-8) (predeterminado)
mbstring.language        = English; Establecer como lenguaje el inglés
mbstring.language        = Japanese; Establecer como lenguaje el japonés

;; Establecer la codificación interna predeterminada
;; Nota: Asegúrese de usar una codificación que funcione con PHP
mbstring.internal_encoding    = UTF-8  ; Establecer la codificación interna a UTF-8

;; Traducción de codificación HTTP entrante habilitada
mbstring.encoding_translation = On

;; Establecer la codificación de caracteres predeterminada de HTTP entrante
;; Nota: Un script no podrá cambiar el ajuste http_input.
mbstring.http_input           = pass    ; Sin conversión.
mbstring.http_input           = auto    ; Establecer la entrada HTTP en automático
                                ; "auto" se expande de acuerdo a mbstring.language
mbstring.http_input           = SJIS    ; Establecer la entrada HTTP a SJIS
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; Especificar el orden

;; Establecer la codificación de caracteres predeterminada de HTTP saliente
mbstring.http_output          = pass    ; Sin conversión
mbstring.http_output          = UTF-8   ; Establecer la codificación de salida HTTP a UTF-8

;; Establecer el orden predeterminado de la detección de juegos de caracteres
mbstring.detect_order         = auto    ; Orden de detección automático
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Especificar el orden

;; Establecer el carácter de sustitución predeterminado
mbstring.substitute_character = 12307   ; Especificar un valor Unicode
mbstring.substitute_character = none    ; No imprimir el carácter
mbstring.substitute_character = long    ; Ejemplo de long: U+3000,JIS+7E7E

Ejemplo #2 Ajustes de php.ini para usuarios de EUC-JP

;; Deshabilitar el almacenamiento en el búfer de salida
output_buffering      = Off

;; Establecer el juego de caracteres de las cabeceras HTTP
default_charset       = EUC-JP

;; Establecer como lenguaje predeterminado el japonés
mbstring.language = Japanese

;; Habilitar la traducción de la codificación del HTTP entrante.
mbstring.encoding_translation = On

;; Establecer en automática la conversión de la codificación de HTTP entrante
mbstring.http_input   = auto

;; Convertir la salida de HTTP a EUC-JP
mbstring.http_output  = EUC-JP

;; Establecer EUC-JP como codificación interna
mbstring.internal_encoding = EUC-JP

;; No imprimir caracteres inválidos
mbstring.substitute_character = none

Ejemplo #3 Ajustes de php.ini para usuarios de SJIS

;; Habilitar el almacenamiento en el búfer de salida
output_buffering     = On

;; Establecer mb_output_handler para habilitar la conversión de los datos de salida
output_handler       = mb_output_handler

;; Establecer el juego de caracteres de las cabeceras HTTP
default_charset      = Shift_JIS

;; Establecer como lenguaje predeterminado el japonés
mbstring.language = Japanese

;; Establecer en automático la conversión del juego de caracteres http entrante
mbstring.http_input  = auto

;; Convertir a SJIS
mbstring.http_output = SJIS

;; Establecer EUC-JP como codificación interna
mbstring.internal_encoding = EUC-JP

;; No imprimir caracteres inválidos
mbstring.substitute_character = none


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

MB_OVERLOAD_MAIL (integer)
MB_OVERLOAD_STRING (integer)
MB_OVERLOAD_REGEX (integer)
MB_CASE_UPPER (integer)
Realiza un doblaje completo de las mayúsculas. Esto puede cambiar la longitud del string. Este es el modo utilizado por mb_strtoupper().
MB_CASE_LOWER (integer)
Realiza un doblaje completo de las minúsculas. Esto puede cambiar la longitud del string. Este es el modo utilizado por mb_strtolower().
MB_CASE_TITLE (integer)
Realiza una conversión completa título-caso basada en las propiedades derivadas de Unicode Cased y CaseIgnorable. En particular, esto mejora el manejo de las comillas y los apóstrofes. Esto puede cambiar la longitud del string.
MB_CASE_FOLD (integer)
Realiza una conversión de doblaje de mayúsculas y minúsculas que elimina las distinciones de mayúsculas y minúsculas presentes en el string. Esto se utiliza para la comparación de los casos. Esto puede cambiar la longitud del string. Disponible desde PHP 7.3.
MB_CASE_LOWER_SIMPLE (integer)
Realiza una simple conversión de doblaje en minúsculas. Esto no cambia la longitud del string. Disponible a partir de PHP 7.3.
MB_CASE_UPPER_SIMPLE (integer)
Realiza una simple conversión de doblado de mayúsculas. Esto no cambia la longitud del string. Disponible a partir de PHP 7.3.
MB_CASE_TITLE_SIMPLE (integer)
Realiza una simple conversión de doblado de título-caso. Esto no cambia la longitud del string. Disponible a partir de PHP 7.3.
MB_CASE_FOLD_SIMPLE (integer)
Realiza una simple conversión de doblaje de mayúsculas y minúsculas que elimina las distinciones de mayúsculas y minúsculas presentes en el string. Esto se utiliza para la comparación de los casos. Esto no cambia la longitud del string. Utilizado por las operaciones insensibles a los casos internamente por la extensión MBString. Disponible a partir de PHP 7.3.
MB_ONIGURUMA_VERSION (string)
La versión de Oniguruma, p.e. 6.9.4. Disponible a partir de PHP 7.4.


Resumen de codificaciones soportadas

Resumen de codificaciones soportadas
Nombre en el registro de conjuntos de caracteres de la IANA | Conjunto de Caracteres | Descripción | Notas adicionales
ISO-10646-UCS-4 | ISO 10646 | Conjunto Universal de Caracteres con 31 bits de codificación, estandarizado como UCS-4 por ISO/IEC 10646. Se mantiene sincronizado con la última versión del mapa de códigos de Unicode. | Si se utiliza este nombre con la utilidad de conversión de codificación, el convertidor intentará identificar, mediante el byte de marca de orden (BOM) precedente, en qué formato (little-endian o big-endian) están representados los siguientes bytes.
ISO-10646-UCS-4 | UCS-4 | Véase más arriba. | A diferencia de UCS-4, las cadenas de caracteres siempre apareceran en formato big-endian.
ISO-10646-UCS-4 | UCS-4 | Véase más arriba. | A diferencia de UCS-4, las cadenas de caracteres siempre apareceran en formato little-endian.
ISO-10646-UCS-2 | UCS-2 | Conjunto Universal de Caracteres con 16 bits de codificación, estandarizado como UCS-2 por ISO/IEC 10646. Se mantiene sincronizado con la última versión del mapa de códigos de Unicode. | Si se utiliza este nombre con la utilidad de conversión de codificación, el convertidor intentará identificar, mediante el byte de marca de orden (BOM) precedente, en qué formato (little-endian o big-endian) están representados los siguientes bytes.
ISO-10646-UCS-2 | UCS-2 | Véase más arriba. | A diferencia de UCS-2, las cadenas de caracteres siempre apareceran en formato big-endian.
ISO-10646-UCS-2 | UCS-2 | Véase más arriba. | A diferencia de UCS-2, las cadenas de caracteres siempre apareceran en formato little-endian.
UTF-32 | Unicode | Formato de Transformación Unicode de un ancho de unidad de 32 bits, cuya espacio de codificación está incluido en el estándar de conjunto de código de Unicode. Esta esquema de codificación no es igual al UCS-4, porque el espacio de codificación de Unicode estaba limitado a un valor de 21 bits. | Si se utiliza este nombre con la utilidad de conversión de codificación, el convertidor intentará identificar, mediante el byte de marca de orden (BOM) precedente, en qué formato (little-endian o big-endian) están representados los siguientes bytes.
UTF-32BE | Unicode | Ver más arriba | A diferencia de UTF-32, las cadenas de caracteres siempre apareceran en formato big-endian.
UTF-32LE | Unicode | Ver más arriba | A diferencia de UTF-32, las cadenas de caracteres siempre apareceran en formato little-endian.
UTF-16 | Unicode | Formato de Transformación UCS de 16 bits de ancho. Hay que tener en cuenta que es muy parecido a UCS-2, gracias al mecanismo de subrogación introducido en Unicode 2.0 y UTF-16, por lo que se requiere un máximo de 21 bits para la representación de cualquier carácter. | Si se utiliza este nombre con la utilidad de conversión de codificación, el convertidor intentará identificar, mediante el byte de marca de orden (BOM) precedente, en qué formato (little-endian o big-endian) están representados los siguientes bytes.
UTF-16BE | Unicode | Véase más arriba. | A diferencia de UTF-16, las cadenas de caracteres siempre apareceran en formato big-endian.
UTF-16LE | Unicode | Véase más arriba. | A diferencia de UTF-16, las cadenas de caracteres siempre apareceran en formato little-endian.
UTF-8 | Unicode / UCS | Formato de Transformación UCS de 8 bits de ancho.. | Ninguna
UTF-7 | Unicode | Formato de transformación UCS para el envío de correo electrónico seguro, especificado en » RFC2152. | Ninguno
(Ninguno) | Unicode | Variante de UTF-7 recomendado para usar con el » protocolo IMAP. | Ninguno
US-ASCII (preferred MIME name) / iso-ir-6 / ANSI_X3.4-1986 / ISO_646.irv:1991 / ASCII / ISO646-US / us / IBM367 / CP367 / csASCII | ASCII / ISO 646 | Código Estándar Americano para el Intercambio de Información, de utilización muy extendida con una codifiación de 7 bits. Estandarizado a nivel Internacional, ISO 646. | (Ninguno)
EUC-JP (nombre preferido por MIME) / Extended_UNIX_Code_Packed_Format_for_Japanese / csEUCPkdFmtJapanese | Compuesto de US-ASCII / JIS X0201:1997 (hankaku kana part) / JIS X0208:1990 / JIS X0212:1990 | Como se puede ver, el nombre está derivado de la abreviación de Formato de Código UNIX Extendido para el Japonés. Esta codificación se usa principalmente en UNIX o plataformas afines. El esquema de codificación original, Código UNIX Extendido, se diseñó sobre la base de ISO 2022. | El conjunto de caracteres llamado EUC-JP es diferente a IBM932 / CP932, que son utilizados por OS/2® y Microsoft® Windows®. Para el intercambio de información con estas plataformas es mejor utilizar EUCJP-WIN.
Shift_JIS (nombre preferido por MIME) / MS_Kanji / csShift_JIS | Compuesto de JIS X0201:1997 / JIS X0208:1997 | Shift_JIS fue desarrollado a principios de los 80, al mismo tiempo que los procesadores de textos en Japonés llegaban al mercado para mantener la compatibilidad con los antiguos esquemas de codifiación JIS X 0201:1976. De acuerdo con la definición de la IANA, el conjunto de caracteres Shift_JIS es ligeramente diferente a IBM932 / CP932. Sin embargo, los nombres "SJIS" / "Shift_JIS" son utilizados de forma incorrecta para referirse a este conjunto de caracteres. | Para la codificación CP932, es recomendable utilizar SJIS-WIN.
(Ninguno) | Compuesto de JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions | Aunque esta "codificación" utiliza el mismo esquema de codificación que EUC-JP, el conjunto de caracteres es diferente. Esto es así porque algunos códigos del mapa apuntan a diferentes caracteres del conjunto de caracteres EUC-JP. | none
Windows-31J / csWindows31J | Compuesto de JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions | Aunque esta "codificación" utiliza el mismo esquema de codificación que Shift-JIS, el conjunto de caracteres es diferente. Esto es así porque algunos códigos del mapa apuntan a diferentes caracteres del conjunto de caracteres Shift-JIS. | (none)
ISO-2022-JP (nombre preferido por MIME) / csISO2022JP | US-ASCII / JIS X0201:1976 / JIS X0208:1978 / JIS X0208:1983 | » RFC1468 | (Ninguno)
JIS |  |  |
ISO-8859-1 |  |  |
ISO-8859-2 |  |  |
ISO-8859-3 |  |  |
ISO-8859-4 |  |  |
ISO-8859-5 |  |  |
ISO-8859-6 |  |  |
ISO-8859-7 |  |  |
ISO-8859-8 |  |  |
ISO-8859-9 |  |  |
ISO-8859-10 |  |  |
ISO-8859-13 |  |  |
ISO-8859-14 |  |  |
ISO-8859-15 |  |  |
ISO-8859-16 |  |  |
byte2be |  |  |
byte2le |  |  |
byte4be |  |  |
byte4le |  |  |
BASE64 |  |  |
HTML-ENTITIES |  |  |
7bit |  |  |
8bit |  |  |
EUC-CN |  |  |
CP936 |  |  |
HZ |  |  |
EUC-TW |  |  |
CP950 |  |  |
BIG-5 |  |  |
EUC-KR |  |  |
UHC (CP949) |  |  |
ISO-2022-KR |  |  |
Windows-1251 (CP1251) |  |  |
Windows-1252 (CP1252) |  |  |
CP866 (IBM866) |  |  |
KOI8-R |  |  |
KOI8-U |  |  |


Lo básico sobre codificaciones multibytes del japonés

Los caracteres japoneses sólo pueden ser representados por codificaciones multibytes y además se utilizan múltiples estándares de codificación dependiendo de la plataforma y el propósito del texto. Para colmo de males, estos estándares de codificación difieren ligeramente unos de otros. Con el fin de crear una aplicación web que pueda utilizarse en un entorno en japonés, un desarrollador ha de tener estas complejidades en mente para garantizar que se utilice la codificación de caracteres apropiada.

  • El almacenamiento de un carácter puede ser de hasta 6 bytes
  • La mayoría de los caracteres japoneses multibyte son el doble de ancho que los caracteres de un único byte. Estos caracteres se llaman "zen-kaku", que en japonés significa "de ancho total;". Otros caracteres más estrechos se llaman "han-kaku", que significa "de ancho medio". Las características gráficas de los caracteres, sin embargo, dependen de las tipografías usadas para mostrarlas.
  • Algunas codificaciones de caracteres usan las secuencias de cambio (escape) definidas en el ISO-2022 para cambiar el mapa de código del área de codigo específica (00h a 7fh).
  • Debería usarse el ISO-2022-JP con SMTP/NNTP, y las cabeceras y las entidades deberían recodificarse según los requisitos del RFC. Aunque éstos no sean requisitos , es una buena idea ya que varios agentes de usuario populares no pueden reconocer ningún otro método de codificación.
  • Las páginas web creadas para servicios de telefonía móvil, tales como » i-mode o » EZweb, deben utilizar Shift_JIS.
  • A partir de PHP 5.4.0, se admiten los caracteres pictograma utilizados para servicios de telefonía móvil, tales como » i-mode o » EZweb.


Entrada/Salida de HTTP

La conversión de una codificación de caracteres desde una entrada/salida HTTP también puede convertir datos binarios. Si se utilizan datos binarios para la entrada/salida de HTTP, los usuarios tienen el deber de controlar la conversión de la codificación de caracteres.

Nota:

En la versión de 4.3.2 de PHP o anteriores existe una limitación en esta funcionalidad de mbstring que consiste en que no se realiza la conversión de la condificación de caracteres de los datos enviados mediante POST si el atributo enctype del elemento form está establecido a multipart/form-data. En este caso, es el usuario el que ha de convertir los datos entrantes si fuera necesario.

Comenzando con PHP 4.3.3, si el atributo enctype de un formulario HTML se establece a multipart/form-data y mbstring.encoding_translation está establecido a 'On' en php.ini, las variables y los nombres de los ficheros subidos mediante POST serán convertidos también a la codificación de caracteres interna. Sin embargo, la conversión no se aplicará a las claves de las consultas.

  • Entrada HTTP

    No hay ninguna forma de controlar la conversión de caracteres de la entrada HTTP desde un script de PHP. Para desactivar dicha conversión, hay que realizarlo en php.ini.

    Ejemplo #1 Desactivar la conversión de caracteres de la entrada HTTP en php.ini

    ;; Deshabilitar la conversión de la entrada HTTP
mbstring.http_input = pass
;; Deshabilitar la conversión de la entrada HTTP (PHP 4.3.0 o posterior)
mbstring.encoding_translation = Off

    Cuando se utiliza PHP como un módulo de Apache, es posible anular esta configuración en cada directiva Host Virtual en el fichero httpd.confo por cada directorio, a través de un fichero .htaccess. Consulte la sección de Configuración y el Manual de Apache para más detalles.

  • Salida HTTP

    Hay varias formas de habilitar la conversión de caracteres de salida. Una es utilizando php.ini, otra es utilizando ob_start(), con mb_output_handler() como la función de llamada de retorno de ob_start.

Ejemplo #2 Ejemplo de configuración de php.ini

;; Habilitar la conversión de codificaciones de caracteres de salida para todas las páginas de PHP

;; Hablitar el almacenamiento en búfer de salida
output_buffering    = On

;; Establecer mb_output_handler para habilitar la conversión de salida
output_handler      = mb_output_handler

Ejemplo #3 Ejemplo de script

<?php

// Habilita la conversión de codificaciones de caracteres de salida sólo para esta página

// Establecer la codificación de caracteres de salida HTTP a SJIS
mb_http_output('SJIS');

// Iniciar el almacenamiento en búfer y especificar "mb_output_handler" como
// la función de llamada de retorno
ob_start('mb_output_handler');

?>


Codificaciones de caracteres admitidas

Actualmente, el módulo mbstring admite las siguientes condificaciones de caracteres. Cualesquiera de estas codificaciones de caracteres se pueden especificar en el parámetro encoding de las funciones de mbstring.

Esta extensión de PHP admite las siguientes codificaciones de caracteres:

  • UCS-4*
  • UCS-4BE
  • UCS-4LE*
  • UCS-2
  • UCS-2BE
  • UCS-2LE
  • UTF-32*
  • UTF-32BE*
  • UTF-32LE*
  • UTF-16*
  • UTF-16BE*
  • UTF-16LE*
  • UTF-7
  • UTF7-IMAP
  • UTF-8*
  • ASCII*
  • EUC-JP*
  • SJIS*
  • eucJP-win*
  • SJIS-win*
  • ISO-2022-JP
  • ISO-2022-JP-MS
  • CP932
  • CP51932
  • SJIS-mac** (alias: MacJapanese)
  • SJIS-Mobile#DOCOMO** (alias: SJIS-DOCOMO)
  • SJIS-Mobile#KDDI** (alias: SJIS-KDDI)
  • SJIS-Mobile#SOFTBANK** (alias: SJIS-SOFTBANK)
  • UTF-8-Mobile#DOCOMO** (alias: UTF-8-DOCOMO)
  • UTF-8-Mobile#KDDI-A**
  • UTF-8-Mobile#KDDI-B** (alias: UTF-8-KDDI)
  • UTF-8-Mobile#SOFTBANK** (alias: UTF-8-SOFTBANK)
  • ISO-2022-JP-MOBILE#KDDI** (alias: ISO-2022-JP-KDDI)
  • JIS
  • JIS-ms
  • CP50220
  • CP50220raw
  • CP50221
  • CP50222
  • ISO-8859-1*
  • ISO-8859-2*
  • ISO-8859-3*
  • ISO-8859-4*
  • ISO-8859-5*
  • ISO-8859-6*
  • ISO-8859-7*
  • ISO-8859-8*
  • ISO-8859-9*
  • ISO-8859-10*
  • ISO-8859-13*
  • ISO-8859-14*
  • ISO-8859-15*
  • ISO-8859-16*
  • byte2be
  • byte2le
  • byte4be
  • byte4le
  • BASE64
  • HTML-ENTITIES
  • 7bit
  • 8bit
  • EUC-CN*
  • CP936
  • GB18030**
  • HZ
  • EUC-TW*
  • CP950
  • BIG-5*
  • EUC-KR*
  • UHC (CP949)
  • ISO-2022-KR
  • Windows-1251 (CP1251)
  • Windows-1252 (CP1252)
  • CP866 (IBM866)
  • KOI8-R*
  • KOI8-U*
  • ArmSCII-8 (ArmSCII8)

* denota codificaciones que también pueden ser utilizadas en expresiones regulares.

** denota codificaciones que están disponibles desde PHP 5.4.0.

Cualquier entrada en php.ini que acepte un nombre de codificación también puede utilizar los valores "auto" y "pass". Las funciones de mbstring que aceptan un nombre de codificación también pueden utilizar el valor "auto".

Si se establece el valor "pass", no se realizará ninguna conversión de la codificación de caracteres.

Si se establece el valor "auto", se utilizará la lista de codificaciones definida por el NLS. Por ejemplo, si el NLS está configurado como Japanese, el valor que se asume será "ASCII,JIS,UTF-8,EUC-JP,SJIS".

Véase también mb_detect_order()


Sobrecarga de Funciones

Quizás resulte complicado obtener una aplicación de PHP que funcione en un determinado entorno multibyte. Esto sucede porque la mayor parte de las aplicaciones de PHP están escritas con las funciones estándar de cadenas de caracteres, como por ejemplo substr(), la cual se sabe que no maneja correctamente los strings codificados de forma multibyte.

mbstring admite la 'sobrecarga de funciones', característica que permite que tales aplicaciones consideren los multibyes sin necesidad de modificar el código, sobrecargando las funciones homólogas multibyes sobre las estándar de cadenas de caracteres. Por ejemplo, se invocaría a mb_substr() en lugar de a substr() si se habilitara la sobrecarga de funciones. En muchos casos, esta funcionalidad simplifica la portabilidad de las aplicaciones que tan solo admiten codificaciones de un único byte a entornos multibyte.

Para utilizar la sobrecarga de funciones, se ha de establecer mbstring.func_overload en php.ini a un valor positivo que represente una combinación de máscaras de bits que especifiquen las categorías de las funciones que se sobrecargarán. Para sobrecargar la función mail() debe etablecerse a 1. Para funciones de string, a 2. Para funciones de expresiones regulares, a 4. Por ejemplo, si se estableciera a 7, se sobrecargaría las funciones de mail, de string, y de expresiones regulares. A continuación se muestra la lista de funciones sobrecargadas.

Funciones sobrecargadas
valor de mbstring.func_overload | función original | función sobrecargada
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
2 | strtolower() | mb_strtolower()
2 | strtoupper() | mb_strtoupper()
2 | stripos() | mb_stripos()
2 | strripos() | mb_strripos()
2 | strstr() | mb_strstr()
2 | stristr() | mb_stristr()
2 | strrchr() | mb_strrchr()
2 | substr_count() | mb_substr_count()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

Nota:

No se recomienda habilitar la sobrecarga de funciones en un contexto de directorios, ya que todavía no se ha confirmado que su uso sea suficientemente estable en un entorno de producción, lo que podría conducir a comportamientos inesperados.


Requerimientos para la codificación de caracteres en PHP

Las codificaciones de los siguientes tipos se pueden utilizar con PHP de forma segura.

  • Codificaciones de un solo byte,

    • que tienen mapas de referencia compatibles con ASCII (ISO646) para los caracteres en el rango de 00h a 7fh.

  • Codificación multibyte,

    • que tienen mapas de referencia compatibles con ASCII para los caracteres en el rango de 00h a 7fh.
    • que no utilizan secuencias de escape ISO2022.
    • que no utilizan un valor en el rango de 00h a 7fh en cualquiera de los bytes compuestos que representan un carácter sencillo.

Estos son ejemplos de codificaciones de caracteres que es poco probable que funcionen con PHP.

JIS, SJIS, ISO-2022-JP, BIG-5

Aunque algunos scripts de PHP escritos en estas codificaciones podrían no funcionar, especialmente en el caso donde los strings codificados aparecen como identificadores o como literales en el propio script, se puede evitar el uso de estas codificaciones configurando la función de filtro de codificación transparente de mbstring para las consultas HTTP entrantes.

Nota:

Se desaconseja energicamente el uso de SJIS, BIG5, CP936, CP949 y GB18030 para la codificación interna, a menos que se esté familiarizado con el analizador, el explorador y la codificación de caracteres.

Nota:

Si se va a conectar a una base de datos con PHP, se recomienda utilizar la misma codificación de caracteres para la base de datos y la codificación interna para un uso más sencillo y un mejor rendimiento.

Si se utiliza PostgreSQL, la codificación utilizada en la base de datos y la utilizada en PHP puede ser distinta debido a que se admite la conversión automática del conjunto de caracteres entre la parte final y la inicial del proceso.


Funciones de cadenas de caracteres multibyte

Referencias

Los esquemas de codificación de caracteres multibyte y temas relacionados son muy complicados y están fuera del alcance de esta documentación. Se aconseja visitar los siguientes URLs y otros recursos para tener unos conocimientos más amplios que los escritos en estos temas.

  • Documentación de Unicode

    » http://www.unicode.org/

  • Información sobre los conjuntos de caracteres japonés/coreano/chino

    » https://resources.oreilly.com/examples/9781565922242/blob/master/doc/cjk.inf

Tabla de contenidos

  • mb_check_encoding — Comprueba si el string es válido para a la codificación especificada
  • mb_chr — Get a specific character
  • mb_convert_case — Realiza una conversión a mayúsculas/minúsculas de un string
  • mb_convert_encoding — Convierte una codificación de caracteres
  • mb_convert_kana — Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)
  • mb_convert_variables — Convierte códigos de caracteres a variable/s
  • mb_decode_mimeheader — Decodifica un string en el campo de cabecera MIME
  • mb_decode_numericentity — Decodifica referencias a string numéricas de HTML en caracteres
  • mb_detect_encoding — Detecta la codificación de caracteres
  • mb_detect_order — Establece/obtiene el orden de detección de codificaciones de caracteres
  • mb_encode_mimeheader — Codifica un string para la cabecera MIME
  • mb_encode_numericentity — Convierte caracteres a referencias de string numéricas de HTML
  • mb_encoding_aliases — Obtiene los alias de un tipo de codificación conocido
  • mb_ereg_match — Compararción de expresiones regulares para strings multibyte
  • mb_ereg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno
  • mb_ereg_replace — Reemplaza una expresión regular con soporte multibyte
  • mb_ereg_search_getpos — Devuelve la posición de inicio para la siguiente comparación de una expresión regular
  • mb_ereg_search_getregs — Recupera el resultado de la última comparación de expresión regular multibyte
  • mb_ereg_search_init — Configura el string y la expresión regular para una comparación de expresiones regulares multibyte
  • mb_ereg_search_pos — Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido
  • mb_ereg_search_regs — Devuelve la parte coincidente de una expresión regular multibyte
  • mb_ereg_search_setpos — Establece el punto de inicio de la siguiente comparación de una expresión regular
  • mb_ereg_search — Comparación de expresiones regulares multibyte para un string multibyte predefinido
  • mb_ereg — Comparación de expresiones regulares con soporte multibyte
  • mb_eregi_replace — Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas
  • mb_eregi — Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte
  • mb_get_info — Obtiene la configuración interna de mbstring
  • mb_http_input — Detecta la codificación de caracteres de entrada HTTP
  • mb_http_output — Establece/obtiene la codificación de caracteres de salida HTTP
  • mb_internal_encoding — Establece/obtiene la codificación de caracteres interna
  • mb_language — Establece/obtiene el idioma actual
  • mb_list_encodings — Devuelve un array con todos los tipos de codificaciones admitidas
  • mb_ord — Get code point of character
  • mb_output_handler — Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida
  • mb_parse_str — Analiza datos GET/POST/COOKIE y establece varialbes globales
  • mb_preferred_mime_name — Obtener un string del conjunto de caracteres del MIME
  • mb_regex_encoding — Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_regex_set_options — Establece/obtiene las opciones predeterminadas para las funciones mbregex
  • mb_scrub — Description
  • mb_send_mail — Envía un correo codificado
  • mb_split — Divide cadenas de caracteres multibyte usando una expresión regular
  • mb_str_split — Given a multibyte string, return an array of its characters
  • mb_strcut — Obtener parte de un string
  • mb_strimwidth — Obtiene un string truncado con el ancho especificado
  • mb_stripos — Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
  • mb_stristr — Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
  • mb_strlen — Obtiene la longitud de una cadena de caracteres
  • mb_strpos — Busca la posición de la primera ocurrencia de un string en otro string
  • mb_strrchr — Busca la última ocurrencia de un carácter de un string dentro de otro
  • mb_strrichr — Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas
  • mb_strripos — Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas
  • mb_strrpos — Busca la posicion de la última ocurrencia de un string en otro string
  • mb_strstr — Busca la primera ocurrencia de un string dentro de otro
  • mb_strtolower — Convierte una cadena de caracteres a minúsculas
  • mb_strtoupper — Convierte un string en mayúsculas
  • mb_strwidth — Devuelve el ancho de un string
  • mb_substitute_character — Establece/obtiene un carácter de sustitución
  • mb_substr_count — Cuenta el número de ocurrencias de un substring
  • mb_substr — Obtiene parte de una cadena de caracteres


Comprueba si el string es válido para a la codificación especificada

  • « Funciones de cadenas de caracteres multibyte
  • mb_chr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Comprueba si el string es válido para a la codificación especificada

mb_check_encoding

(PHP 4 >= 4.4.3, PHP 5 >= 5.1.3, PHP 7, PHP 8)

mb_check_encoding — Comprueba si el string es válido para a la codificación especificada

Descripción

mb_check_encoding ( string $var = null , string $encoding = mb_internal_encoding() ) : bool

Comprueba si el flujo de bytes especificado es válido para a la codificación especificada. Resulta de utilidad para prevenir el conocido "Ataque de Codificación Inválida".

Parámetros

var

El flujo de bytes a comprobar. Si se omite, esta función comprueba todos los datos de entrada desde el comienzo de la petición.

encoding

La codificación a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Get a specific character

  • « mb_check_encoding
  • mb_convert_case »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Get a specific character

mb_chr

(PHP 7 >= 7.2.0, PHP 8)

mb_chr — Get a specific character

Descripción

mb_chr ( int $codepoint , string|null $encoding = null ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

codepoint

encoding

Valores devueltos

Returns a specific character o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | encoding is nullable now.

Ver también

  • mb_ord() - Get code point of character
  • chr() - Devuelve un caracter específico


Realiza una conversión a mayúsculas/minúsculas de un string

  • « mb_chr
  • mb_convert_encoding »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Realiza una conversión a mayúsculas/minúsculas de un string

mb_convert_case

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_convert_case — Realiza una conversión a mayúsculas/minúsculas de un string

Descripción

mb_convert_case ( string $str , int $mode , string $encoding = mb_internal_encoding() ) : string

Realiza una conversión a mayúsculas/minúsculas en un string, de acuerdo al modo especificado por mode.

Parámetros

str

El string que se va a convertir.

mode

El modo de conversión. Puede ser MB_CASE_UPPER, MB_CASE_LOWER, o MB_CASE_TITLE.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

La versión convertida del string tal como se especificó en el parámetro mode.

Unicode

A diferencia de las funciones estándar de mayúsculas/minúsculas, como strtolower() y strtoupper(), la conversión se lleva a cabo según los fundamentos de las propiedades de los caracteres Unicode. De esta forma, esta función no se ve afectada por las configuraciones regionales, ya que puede convertir cualquier carácter que contenga la propiedad 'alfabética', como la A con diéresis (Ä).

Para más información sobre las propiedades Unicode, por favor, revise » http://www.unicode.org/reports/tr21/.

Ejemplos

Ejemplo #1 Ejemplo de mb_convert_case()

<?php
$str = "mary had a Little lamb and she loved it so";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // Muestra MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // Muestra Mary Had A Little Lamb And She Loved It So
?>

Ejemplo #2 Ejemplo de mb_convert_case() con texto no latino en UTF-8

<?php
$str = "????st? a??p?? ßaf?? ??µ??? ??, d?as?e???e? ?p?? ?????? ?????";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // Muestra ????S?? ?????? ??F?S ?????? G?, ???S??????? ???? ?OT??? ????S
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // Muestra ????st? ???p?? ?af?s ??µ??? G?, ??as?e???e? ?p?? ?????? ????s
?>

Ver también

  • mb_strtolower() - Convierte una cadena de caracteres a minúsculas
  • mb_strtoupper() - Convierte un string en mayúsculas
  • strtolower() - Convierte un string a minúsculas
  • strtoupper() - Convierte un string a mayúsculas
  • ucfirst() - Convierte el primer caracter de una cadena a mayúsculas
  • ucwords() - Convierte a mayúsculas el primer caracter de cada palabra de una cadena


Convierte una codificación de caracteres

  • « mb_convert_case
  • mb_convert_kana »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte una codificación de caracteres

mb_convert_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_encoding — Convierte una codificación de caracteres

Descripción

mb_convert_encoding ( string $str , string $to_encoding , mixed $from_encoding = mb_internal_encoding() ) : string

Convierte la codificación de caracteres del string str a la especificada por to_encoding, indicando opcionalmente la codificación de caracteres inicial en from_encoding.

Parámetros

str

El string a codificar.

to_encoding

El tipo de codificación a la que convertir str.

from_encoding

Se especifica por los nombres de los códigos de caracteres previos a la conversión. Se trata de, o bien un array, o bien de una lista separada por comas. Si no se especificara ningún valor para from_encoding, se utilizará la codificación interna.

Revise las codificaciones admitidas.

Valores devueltos

El string codificado.

Ejemplos

Ejemplo #1 Ejemplo de mb_convert_encoding()

<?php
/* Convierte de la codificación interna a SJIS */
$str = mb_convert_encoding($str, "SJIS");

/* Convierte EUC-JP a UTF-7 */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* Autodetecta la codificación, desde JIS, eucjp-win o sjis-win, y después convierte str a UCS-2LE */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" es un alias de "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
$str = mb_convert_encoding($str, "EUC-JP", "auto");
?>

Ver también

  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres


Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)

  • « mb_convert_encoding
  • mb_convert_variables »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)

mb_convert_kana

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_kana — Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)

Descripción

mb_convert_kana ( string $str , string $option = "KV" , string $encoding = mb_internal_encoding() ) : string

Realiza una conversión "han-kaku" - "zen-kaku" en el string str. Esta función solo es útil para el idioma japonés.

Parámetros

str

El string a convertir.

option

La opción de conversión.

Se especifica con una combinación de las siguientes opciones.

Opciones de conversión posibles
Opción | Significado
r | Convierte los alfabetos "zen-kaku" a "han-kaku"
R | Convierte los alfabetos "han-kaku" a "zen-kaku"
n | Convierte los números "zen-kaku" a "han-kaku"
N | Convierte los números "han-kaku" a "zen-kaku"
a | Convierte los alfabetos y los números "zen-kaku" a "han-kaku"
A | Convierte los alfabetos y los números "han-kaku" a "zen-kaku" (Los caracteres incluídos en las opciones "a" y "A" están en el rango U+0021 - U+007E excepto U+0022, U+0027, U+005C, U+007E)
s | Convierte del espacio de "zen-kaku" al de "han-kaku" (U+3000 -> U+0020)
S | Convierte del espacio de "han-kaku" al de "zen-kaku" (U+0020 -> U+3000)
k | Convierte "zen-kaku kata-kana" a "han-kaku kata-kana"
K | Convierte "han-kaku kata-kana" a "zen-kaku kata-kana"
h | Convierte "zen-kaku hira-gana" a "han-kaku kata-kana"
H | Convierte "han-kaku kata-kana" a "zen-kaku hira-gana"
c | Convierte "zen-kaku kata-kana" a "zen-kaku hira-gana"
C | Convierte "zen-kaku hira-gana" a "zen-kaku kata-kana"
V | Colapsa la notación de sonidos de voz, y la converte a caracteres. Usar con "K","H"

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

El string convertido.

Ejemplos

Ejemplo #1 Ejemplo de mb_convert_kana()

<?php
/* Convierte todos los "kana" a "zen-kaku" "kata-kana" */
$str = mb_convert_kana($str, "KVC");

/* Convierte "han-kaku" "kata-kana" a "zen-kaku" "kata-kana"
   y los alfanuméricos de "zen-kaku" a "han-kaku" */
$str = mb_convert_kana($str, "KVa");
?>


Convierte códigos de caracteres a variable/s

  • « mb_convert_kana
  • mb_decode_mimeheader »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte códigos de caracteres a variable/s

mb_convert_variables

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_variables — Convierte códigos de caracteres a variable/s

Descripción

mb_convert_variables ( string $to_encoding , mixed $from_encoding , mixed &$vars , mixed &$... = ? ) : string

Convierta codificaciones de caracteresa de vars variables de la codificación from_encoding a la codificación to_encoding.

mb_convert_variables() une cadenas de caracteres en un Array u Object para detectar la codificación, ya que la detección de codificaciones tiene a falla si las cadenas de caracteres son cortas. Por lo tanto, es imposible mezclar codificaciones en un único array u objeto.

Parámetros

to_encoding

La codificación a la que se va a convertir string.

from_encoding

from_encoding se especifica mediante un array o string separado por comas, e intenta detectar la codificación desde from-coding. Cuando from_encoding se omite, se utiliza detect_order.

vars

vars es la referencia a la variable que va a ser convertida. Se aceptan String, Array y Object. mb_convert_variables() asume que todos los parámetros tienen la misma codificación.

...

vars adicionales.

Valores devueltos

La codificación de caracteres antes de la conversión en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mb_convert_variables()

<?php
/* Convertir las variables $post1, $post2 a la codificación interna */
$interenc = mb_internal_encoding();
$inputenc = mb_convert_variables($interenc, "ASCII,UTF-8,SJIS-win", $post1, $post2);
?>


Decodifica un string en el campo de cabecera MIME

  • « mb_convert_variables
  • mb_decode_numericentity »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Decodifica un string en el campo de cabecera MIME

mb_decode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_decode_mimeheader — Decodifica un string en el campo de cabecera MIME

Descripción

mb_decode_mimeheader ( string $str ) : string

Decodifica el string codificado por palabras str en cabecera MIME.

Parámetros

str

El string a decodificar.

Valores devueltos

El string decodificado en la codificación de caracteres interna.

Ver también

  • mb_encode_mimeheader() - Codifica un string para la cabecera MIME


Decodifica referencias a string numéricas de HTML en caracteres

  • « mb_decode_mimeheader
  • mb_detect_encoding »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Decodifica referencias a string numéricas de HTML en caracteres

mb_decode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_decode_numericentity — Decodifica referencias a string numéricas de HTML en caracteres

Descripción

mb_decode_numericentity ( string $str , array $convmap , string $encoding = mb_internal_encoding() ) : string

Convierte las referencias a string numéricas del string str en un bloque de caracteres especificado.

Parámetros

str

El string a decodificar.

convmap

convmap es un array que especifica el área de código a convertir.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

El string convertido.

Ejemplos

Ejemplo #1 Ejemplo de convmap

<?php
$convmap = array (
   int start_code1, int end_code1, int offset1, int mask1,
   int start_code2, int end_code2, int offset2, int mask2,
   ........
   int start_codeN, int end_codeN, int offsetN, int maskN );
// Especificar el valor Unicode para start_codeN y end_codeN
// Añadir offsetN al valor y tomar el operador 'AND' con maskN,
// luego convertir el valor a una referencia de string numérica.
?>

Ejemplo #2 Ejemplo de convmap escapando cadenas de JavaScript

<?php
function escape_javascript_string($str) {
  $map = [
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,0,0, // 49
          0,0,0,0,0,0,0,0,1,1,
          1,1,1,1,1,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,1,1,1,1,1,1,0,0,0, // 99
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 149
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 199
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 249
          1,1,1,1,1,1,1, // 255
          ];
  // La codificación de caracteres es UTF-8
  $mblen = mb_strlen($str, 'UTF-8');
  $utf32 = bin2hex(mb_convert_encoding($str, 'UTF-32', 'UTF-8'));
  for ($i=0, $encoded=''; $i < $mblen; $i++) {
      $u = substr($utf32, $i*8, 8);
      $v = base_convert($u, 16, 10);
      if ($v < 256 && $map[$v]) {
        $encoded .= '\\x'.substr($u, 6,2);
      } else if ($v == 2028) {
        $encoded .= '\\u2028';
      } else if ($v == 2029) {
        $encoded .= '\\u2029';
      } else {
        $encoded .= mb_convert_encoding(hex2bin($u), 'UTF-8', 'UTF-32');
      }
   }
   return $encoded;
}

// Probar los datos
$convmap = [ 0x0, 0xffff, 0, 0xffff ];
$msg = '';
for ($i=0; $i < 1000; $i++) {
  // chr() no puede generar datos UTF-8 correctos con valores mayores de 128, use mb_decode_numericentity().
  $msg .= mb_decode_numericentity('&#'.$i.';', $convmap, 'UTF-8');
}

// var_dump($msg);
var_dump(escape_javascript_string($msg));

Ver también

  • mb_encode_numericentity() - Convierte caracteres a referencias de string numéricas de HTML


Detecta la codificación de caracteres

  • « mb_decode_numericentity
  • mb_detect_order »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Detecta la codificación de caracteres

mb_detect_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_detect_encoding — Detecta la codificación de caracteres

Descripción

mb_detect_encoding ( string $str , mixed $encoding_list = mb_detect_order() , bool $strict = false ) : string

Detecta la codificación de caracteres del string str.

Parámetros

str

El string en el que detectar la codificación.

encoding_list

encoding_list es una lista de codificaciones de caracteres. El orden de codificaciones puede ser especificado por un array o una lista de string separados por comas.

Si se omite encoding_list, se usará detect_order.

strict

strict especifica si usar la detección de codificación estricta o no. El valor predeterminado es false.

Valores devueltos

La codificación de caracteres detectada, o false si la codificación no se pudo detectar en el string dado.

Ejemplos

Ejemplo #1 Ejemplo de mb_detect_encoding()

<?php
/* Detectar la codificación de caracteres con el detect_order en uso */
echo mb_detect_encoding($str);

/* "auto" se desarrolla según mbstring.language */
echo mb_detect_encoding($str, "auto");

/* Especificar la codificación de caracteres encoding_list mediante una lista separada por comas */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* Usar un array para especificar encoding_list  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);
?>

Ver también

  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres


Establece/obtiene el orden de detección de codificaciones de caracteres

  • « mb_detect_encoding
  • mb_encode_mimeheader »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene el orden de detección de codificaciones de caracteres

mb_detect_order

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_detect_order — Establece/obtiene el orden de detección de codificaciones de caracteres

Descripción

mb_detect_order ( mixed $encoding_list = mb_detect_order() ) : mixed

Establece el orden de detección automática de la codificación de caracteres a encoding_list.

Parámetros

encoding_list

encoding_list es un array o una lista de codificaciones de caracteres separadas por comas. Véanse las codificaciones admitidas.

Si se omite encoding_list, devolverá el orden actual de detección de las codificaciones de caracteres como un array.

Este parámetro afecta a mb_detect_encoding() y a mb_send_mail().

mbstring actualmente implementa los siguientes filtros de detección de codificaciones. Si existiera una secuencia de bytes inválida para las siguientes codificaciones, la detección de la codificación fallará.

UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

Para ISO-8859-*, mbstring siempre lo detecta como ISO-8859-*.

Para UTF-16, UTF-32, UCS2 y UCS4, la detección de la codificación siempre fallará.

Valores devueltos

Al establecer el orden de detección de codificación, se devuelve true en caso de éxito o false en caso de fallo.

Al obtener el orden de detección de codificación, se devuelve un array ordenado con las codificaciones.

Ejemplos

Ejemplo #1 Ejemplo de mb_detect_order()

<?php
/* Establecer el orden de detección mediante una lista enumerada */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* Establecer el orden de detección mediante un array */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
mb_detect_order($ary);

/* Mostrar el orden de detección en uso */
echo implode(", ", mb_detect_order());
?>

Ejemplo #2 Ejemplo mostrando un orden de detección inútil

; Siempre es detectado como ISO-8859-1
detect_order = ISO-8859-1, UTF-8

; Siempre es detectado como UTF-8, ya que los valores ASCII/UTF-7 son
; válidos para UTF-8
detect_order = UTF-8, ASCII, UTF-7

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • mb_http_input() - Detecta la codificación de caracteres de entrada HTTP
  • mb_http_output() - Establece/obtiene la codificación de caracteres de salida HTTP
  • mb_send_mail() - Envía un correo codificado


Codifica un string para la cabecera MIME

  • « mb_detect_order
  • mb_encode_numericentity »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Codifica un string para la cabecera MIME

mb_encode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_encode_mimeheader — Codifica un string para la cabecera MIME

Descripción

mb_encode_mimeheader ( string $str , string $charset = determined by mb_language() , string $transfer_encoding = "B" , string $linefeed = "\r\n" , int $indent = 0 ) : string

Codifica el string str dado mediante el esquema de codificación de cabecera MIME.

Parámetros

str

El string que va a ser codificado. Su codificación debería ser la misma que mb_internal_encoding().

charset

charset especifica el nombre del conjunto de caracteres en el cual está representado str. El valor predeterminado está determinado por el ajuste NLS en uso (mbstring.language).

transfer_encoding

transfer_encoding especifica el esquema de la codifición MIME. Debería ser "B" (Base64) o "Q" (Quoted-Printable). Si no ser proporciona será "B".

linefeed

linefeed especifica la marca EOL (fin de línea) con la que mb_encode_mimeheader() realiza el pliegue de línea (un término de » RFC, que es el acto de dividir una línea mayor que una cierta longitud en varias líneas. La longitud actualmente es de 74 caracteres). Si no se proporciona será "\r\n" (CRLF).

indent

La indentación de la primera línea (número de caracteres en la cabecera antes de str).

Valores devueltos

Una versión convertida del string representado en ASCII.

Ejemplos

Ejemplo #1 Ejemplo de mb_encode_mimeheader()

<?php
$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;
?>

Notas

Nota:

Esta función no está diseñada para dividir líneas en puntos de rotura contextual de alto nivel (límites de palabras, etc.). Este comportamiento podría abarrotar el string original con espacios inesperados.

Ver también

  • mb_decode_mimeheader() - Decodifica un string en el campo de cabecera MIME


Convierte caracteres a referencias de string numéricas de HTML

  • « mb_encode_mimeheader
  • mb_encoding_aliases »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte caracteres a referencias de string numéricas de HTML

mb_encode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_encode_numericentity — Convierte caracteres a referencias de string numéricas de HTML

Descripción

mb_encode_numericentity ( string $str , array $convmap , string $encoding = mb_internal_encoding() , bool $is_hex = FALSE ) : string

Convierte los códigos de caracteres especificados en el string str desde un código de caracter a un referencia de carácter numérico de HTML.

Parámetros

str

El string a ser codificado.

convmap

convmap es un array que especifica el área de código a convertir.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

is_hex

Valores devueltos

El string convertido.

Historial de cambios

Versión | Descripción
5.4.0 | Añadido el parámetro is_hex.

Ejemplos

Ejemplo #1 Ejemplo de convmap

<?php
$convmap = array (
 int start_code1, int end_code1, int offset1, int mask1,
 int start_code2, int end_code2, int offset2, int mask2,
 ........
 int start_codeN, int end_codeN, int offsetN, int maskN );
// Especificar el valor Unicode para start_codeN y end_codeN
// Añadir offsetN al valor y tomar el operador 'AND' con maskN,
// luego convertir el valor a una referencia de string numérica.
?>

Ejemplos

Ejemplo #2 Ejemplo de mb_encode_numericentity()

<?php
/* Convertir la parte izquierda de ISO-8859-1 a referncias de caracteres numéricas de HTML */
$convmap = array(0x80, 0xff, 0, 0xff);
$str = mb_encode_numericentity($str, $convmap, "ISO-8859-1");

/* Convertir código SJIS-win definido por el usuario del bloque 95-104 to a referencias
   de string numéricas */
$convmap = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$str = mb_encode_numericentity($str, $convmap, "sjis-win");
?>

Ver también

  • mb_decode_numericentity() - Decodifica referencias a string numéricas de HTML en caracteres


Obtiene los alias de un tipo de codificación conocido

  • « mb_encode_numericentity
  • mb_ereg_match »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtiene los alias de un tipo de codificación conocido

mb_encoding_aliases

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

mb_encoding_aliases — Obtiene los alias de un tipo de codificación conocido

Descripción

mb_encoding_aliases ( string $encoding ) : array

Devuelve un array con los alias de un tipo de codificación conocido dado por encoding type.

Parámetros

encoding

El tipo de codificación del cual se quieren obtener los alias.

Valores devueltos

Devuelve un array indexado numéricamente con los alias de la condificación en caso de éxito, o false en caso de error

Errores/Excepciones

Emite un error de nivel E_WARNING si encoding es desconocido.

Ejemplos

Ejemplo #1 Ejemplo de mb_encoding_aliases()

<?php
$encoding        = 'ASCII';
$known_encodings = mb_list_encodings();

if (in_array($encoding, $known_encodings)) {

    $aliases = mb_encoding_aliases($encoding);
    print_r($aliases);

} else {

    echo "Codificación ($encoding) desconocida.\n";

}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => ANSI_X3.4-1968
    [1] => iso-ir-6
    [2] => ANSI_X3.4-1986
    [3] => ISO_646.irv:1991
    [4] => US-ASCII
    [5] => ISO646-US
    [6] => us
    [7] => IBM367
    [8] => cp367
    [9] => csASCII
)

Ver también

  • mb_list_encodings() - Devuelve un array con todos los tipos de codificaciones admitidas


Compararción de expresiones regulares para strings multibyte

  • « mb_encoding_aliases
  • mb_ereg_replace_callback »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Compararción de expresiones regulares para strings multibyte

mb_ereg_match

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_match — Compararción de expresiones regulares para strings multibyte

Descripción

mb_ereg_match ( string $pattern , string $string , string $option = "msr" ) : bool

Una compararción de expresiones regulares para strings multibyte.

Parámetros

pattern

El patrón de la expresión regular.

string

El string a ser evaluado.

option

Valores devueltos

Devuelve true si string coincide con la expresión regular pattern, false si no.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg() - Comparación de expresiones regulares con soporte multibyte


Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno

  • « mb_ereg_match
  • mb_ereg_replace »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno

mb_ereg_replace_callback

(PHP 5 >= 5.4.1, PHP 7, PHP 8)

mb_ereg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno

Descripción

mb_ereg_replace_callback ( string $pattern , callable $callback , string $string , string $option = "msr" ) : string

Examina string para buscar coincidencias con pattern, luego reemplaza el texto coincidente con la salida de la función callback.

El comportamiento de esta función es casi idéntico al de mb_ereg_replace(), excepto que en lugar del parámetro replacement, se debería especificar una llamada de retorno dada por callback.

Parámetros

pattern

El patrón de la expresión regular.

Se pueden usar caracteres multibyes en pattern.

callback

Una llamada de retorno que será invocada y se le proporcionará un array de elementos coincidentes en el string subject. La llamada de retorno debería devolver el string de sustitución.

A menudo será necearia la función callback para una mb_ereg_replace_callback() en un sólo lugar. En este caso se puede usar una función anónima para declarar una llamada de retorno dentro de la llamada a mb_ereg_replace_callback(). De esta manera se tendrá toda la información para la llamada en un lugar para no abarrotar el espacion de nombres de funciones con un nombre de de una función de llamada de retorno que no se usará.

string

El string a comprobar.

option

Las condiciones de comparación se pueden establecer por el parámetro option. Si se especifica i para este parámetro, no se tendrán en cuenta las mayúsculas/minúsculas. Si se especifica x, se ingorarán los espacios en blanco. Si se especifica m, la comparación se ejecutará en modo multilínea y se incluirán los saltos de línea en '.'. Si se especifica p, la comparación se ejecutará en modo POSIX, por lo que los saltos de línea se cosiderarán como caracteres normales. Observe que e no se puede usar en mb_ereg_replace_callback().

Valores devueltos

El string resultante en caso de éxito, o false en caso de error.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ejemplos

Ejemplo #1 Ejemplo de mb_ereg_replace_callback()

<?php
// este texto se uso en 2002
// queremos obtener esto para fechas hasta 2003
$texto = "El día de los Santos Inocentes es el 28/12/2002\n";
$texto.= "Las últimas navidades fueron el 24/12/2001\n";
// la función de llamada de retonro
function siguiente_año($coincidencias)
{
  // como siempre: $coincidencias[0] es la coincidencia completa
  // $coincidencias[1] la coincidencia para el primer subpatrón
  // encerrado entre '(...)', etc.
  return $coincidencias[1].($coincidencias[2]+1);
}
echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            "siguiente_año",
            $texto);

?>

El resultado del ejemplo sería:

El día de los Santos Inocentes es el 28/12/2003
Las últimas navidades fueron el 24/12/2002

Ejemplo #2 mb_ereg_replace_callback() usando una función anónima admitida en PHP 5.3.0 o posterior

<?php
// este texto se uso en 2002
// queremos obtener esto para fechas hasta 2003
$texto = "El día de los Santos Inocentes es el 28/12/2002\n";
$texto.= "Las últimas navidades fueron el 24/12/2001\n";

echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            function ($coincidencias) {
               return $coincidencias[1].($coincidencias[2]+1);
            },
            $texto);
?>

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_replace() - Reemplaza una expresión regular con soporte multibyte
  • Funciones anónimas


Reemplaza una expresión regular con soporte multibyte

  • « mb_ereg_replace_callback
  • mb_ereg_search_getpos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Reemplaza una expresión regular con soporte multibyte

mb_ereg_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_replace — Reemplaza una expresión regular con soporte multibyte

Descripción

mb_ereg_replace ( string $pattern , string $replacement , string $string , string $option = "msr" ) : string

Explora string para ver si hay coincidencias con pattern, luego reemplaza el texto coincidente con replacement.

Parámetros

pattern

El patrón de la expresión regular.

Se pueden usar caracteres multibyte en pattern.

replacement

El texto de sustitución.

string

El string que va a ser comprobado.

option
Las condiciones de comparación se pueden establecer con el parámetro option. Si se especifica i para este parámetro, no se diferenciará entre mayúsculas/minúsculas. Si se especifica x, se ignorarán los espacios en blanco. Si se especifica m, la comparación se ejecutará en modo multilínea y los saltos de línea estarán incluidos en '.'. Si se especifica p, la compararción se ejecutará en modo POSIX, los saltos de línea serán considerados como caracteres normales. Si se especifica e, el string replacement será evaluado como una expresión de PHP.

Valores devueltos

El string resultante en caso de éxito, o false en caso de error.

Historial de cambios

Versión | Descripción
7.1.0 | El modificador e está ahora obsoleto.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Advertencia

Nunca utilice el modificador e cuando trabaje con datos de entrada que no son de confianza. No se producirá ningún escape automático (como en preg_replace()). Si utiliza el modificador puede crear vulnerabilidades de ejecución remota de código en su aplicación.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_eregi_replace() - Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas


Devuelve la posición de inicio para la siguiente comparación de una expresión regular

  • « mb_ereg_replace
  • mb_ereg_search_getregs »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Devuelve la posición de inicio para la siguiente comparación de una expresión regular

mb_ereg_search_getpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_getpos — Devuelve la posición de inicio para la siguiente comparación de una expresión regular

Descripción

mb_ereg_search_getpos ( ) : int

Devuelve la posición de inicio para la siguiente coincidencia de una expresión regular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

mb_ereg_search_getpos() devuelve
el punto de inicio de la comparación de una expresión regular para
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs(). La posición está
representada mediante bytes desde la cabeza del string.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_setpos() - Establece el punto de inicio de la siguiente comparación de una expresión regular


Recupera el resultado de la última comparación de expresión regular multibyte

  • « mb_ereg_search_getpos
  • mb_ereg_search_init »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Recupera el resultado de la última comparación de expresión regular multibyte

mb_ereg_search_getregs

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_getregs — Recupera el resultado de la última comparación de expresión regular multibyte

Descripción

mb_ereg_search_getregs ( ) : array

Recupera el resultado de la última comparación de expresión regular multibyte.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array que incluye el substring de la parte coincidente mediante la última llamada a mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). Si existieran algunas coincidencias, el primer elemento contendrá el substring coincidente, el segundo elemento contendrá el primer agrupamiento entre paréntesis, el tercer elemento contendrá el segundo agrupamiento entre paréntesis, etc. Devuelve false en caso de error.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_init() - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte


Configura el string y la expresión regular para una comparación de expresiones regulares multibyte

  • « mb_ereg_search_getregs
  • mb_ereg_search_pos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Configura el string y la expresión regular para una comparación de expresiones regulares multibyte

mb_ereg_search_init

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_init — Configura el string y la expresión regular para una comparación de expresiones regulares multibyte

Descripción

mb_ereg_search_init ( string $string , string $pattern = ? , string $option = "msr" ) : bool

mb_ereg_search_init() establece
string y pattern
para una expresión regular multibyte. Estos valores se usan para
mb_ereg_search(),
mb_ereg_search_pos(), y
mb_ereg_search_regs().

Parámetros

string

El estring de búsquda.

pattern

El patrón de búsqueda.

option

La opción de búsqueda.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_regs() - Devuelve la parte coincidente de una expresión regular multibyte


Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido

  • « mb_ereg_search_init
  • mb_ereg_search_regs »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido

mb_ereg_search_pos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_pos — Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido

Descripción

mb_ereg_search_pos ( string $pattern = ? , string $option = "ms" ) : array

Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido.

El string para la comparación se especifica mediante mb_ereg_search_init(). Si no se especifica, se usará el utilizado anteriormente.

Parámetros

pattern

El patrón de búsqueda.

option

La opción de búsqueda.

Valores devueltos

Un array que contiene dos elementos. El primero es el índice, en bytes, donde la coincidencia es relativa al inicio del string de búsqueda, y el segundo elemento es la longitud de la coincidencia.

Si ocurre un error, devuelve false.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_init() - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte


Devuelve la parte coincidente de una expresión regular multibyte

  • « mb_ereg_search_pos
  • mb_ereg_search_setpos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Devuelve la parte coincidente de una expresión regular multibyte

mb_ereg_search_regs

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_regs — Devuelve la parte coincidente de una expresión regular multibyte

Descripción

mb_ereg_search_regs ( string $pattern = ? , string $option = "ms" ) : array

Devuelve la parte coincidente de una expresión regular multibyte.

Parámetros

pattern

El patrón de búsqueda.

option

La opción de búsqueda.

Valores devueltos

mb_ereg_search_regs() ejecuta la comparación de la expresión regular multibyte, y si existe alguna parte coincidente, devuelve un array que incluye el substring de la parte coincidente como primer elemento, la primera parte agrupada entre paréntesis como segundo elemento, la segunda parte agrupada entre paréntesis como tercer elemento, etc. Devuelve false en caso de error.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_init() - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte


Establece el punto de inicio de la siguiente comparación de una expresión regular

  • « mb_ereg_search_regs
  • mb_ereg_search »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece el punto de inicio de la siguiente comparación de una expresión regular

mb_ereg_search_setpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_setpos — Establece el punto de inicio de la siguiente comparación de una expresión regular

Descripción

mb_ereg_search_setpos ( int $position ) : bool

mb_ereg_search_setpos() establece el punto de inicio de una comparación con mb_ereg_search().

Parámetros

position

La posición a establecer.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_init() - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte


Comparación de expresiones regulares multibyte para un string multibyte predefinido

  • « mb_ereg_search_setpos
  • mb_ereg »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Comparación de expresiones regulares multibyte para un string multibyte predefinido

mb_ereg_search

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search — Comparación de expresiones regulares multibyte para un string multibyte predefinido

Descripción

mb_ereg_search ( string $pattern = ? , string $option = "ms" ) : bool

Realiza una compararción de una expresión regular multibyte para un string multibyte predefinido.

Parámetros

pattern

El patrón de búsqueda.

option

La opción de búsqueda.

Valores devueltos

mb_ereg_search() devuelve true si el string multibyte coinciden con la expresión regular, o false si no. El string para la comparación se establece mediante mb_ereg_search_init(). Si no se especifica pattern, se usará el patrón utilizado anteriormente.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_search_init() - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte


Comparación de expresiones regulares con soporte multibyte

  • « mb_ereg_search
  • mb_eregi_replace »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Comparación de expresiones regulares con soporte multibyte

mb_ereg

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg — Comparación de expresiones regulares con soporte multibyte

Descripción

mb_ereg ( string $pattern , string $string , array &$regs = ? ) : int

Ejecuta la comparación de expresiones regulares con soporte multibyte.

Parámetros

pattern

El patrón de búsqueda.

string

El string de búsqueda.

regs

Contiene un substring del string comparado.

Valores devueltos

Ejecuta la comparación de expresiones regulares con soporte multibyte, y devuelve 1 si se encontraron coincidencias. Si se especificó el parámetro opcional regs, la función devolverá la longitud en bytes de la parte comparada, y el array regs contendrá el substring del string comparado. La función devuelve 1 si coincide con el string vacío. Si no se encontraron coincidencias u ocurrió un error, devolverá false.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_eregi() - Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte


Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas

  • « mb_ereg
  • mb_eregi »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas

mb_eregi_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_eregi_replace — Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas

Descripción

mb_eregi_replace ( string $pattern , string $replace , string $string , string $option = "msri" ) : string

Explora string para ver si hay coincidencias con pattern, luego reemplaza el texto coincidente con replacement.

Parámetros

pattern

El patrón de la expresión regular. Se pueden usar caracteres multibyte. Se ignorará la distinción entre mayúsculas/minúsculas.

replace

El texto de sustitución.

string

El string buscado.

option
option tiene el mismo significado que en mb_ereg_replace().

Valores devueltos

El string resultante o false en caso de error.

Historial de cambios

Versión | Descripción
7.1.0 | El modificador e está ahora obsoleto.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Advertencia

Nunca utilice el modificador e cuando trabaje con datos de entrada que no son de confianza. No se producirá ningún escape automático (como en preg_replace()). Si utiliza el modificador puede crear vulnerabilidades de ejecución remota de código en su aplicación.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg_replace() - Reemplaza una expresión regular con soporte multibyte


Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte

  • « mb_eregi_replace
  • mb_get_info »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte

mb_eregi

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_eregi — Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte

Descripción

mb_eregi ( string $pattern , string $string , array &$regs = ? ) : int

Ejecuta la comparación de expresiones regulares insensible a mayúsculas/minúsculas con soporte multibyte.

Parámetros

pattern

El patrón de la expresión regular.

string

El string donde buscar.

regs

Contiene un substring del string comparado.

Valores devueltos

Ejecuta la comparación de expresiones regulares con soporte multibyte, y devuelve 1 si se encontraron coincidencias. Si se especificó el parámetro opcional regs, la función devolverá la longitud en bytes de la parte comparada, y el array regs contendrá el substring del string comparado. La función devuelve 1 si coincide con el string vacío. Si no se encontraron coincidencias u ocurrió un error, devolverá false.

Notas

Nota:

La codificación interna o la codificación especificada por mb_regex_encoding() será usada en esta función.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg() - Comparación de expresiones regulares con soporte multibyte


Obtiene la configuración interna de mbstring

  • « mb_eregi
  • mb_http_input »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtiene la configuración interna de mbstring

mb_get_info

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_get_info — Obtiene la configuración interna de mbstring

Descripción

mb_get_info ( string $type = "all" ) : mixed

mb_get_info() devuelve los parámetros de configuración interna de mbstring.

Parámetros

type

Si no se estecifica type o si se especifica como "all", será devuelto un array con los elementos "internal_encoding", "http_output", "http_input", "func_overload", "mail_charset", "mail_header_encoding", "mail_body_encoding".

Si type se especifica como "http_output", "http_input", "internal_encoding", "func_overload", será devuelto el parámetro de configuración especificado.

Valores devueltos

Un array con el tipo de información si type no se especifica, o de otro modo, el type especificado.

Historial de cambios

Versión | Descripción
5.1.3 | Están disponibles las entradas "mail_charset", "mail_header_encoding", y "mail_body_encoding".
5.3.0 | Está disponible la entrada "http_output_conv_mimetypes".

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_http_output() - Establece/obtiene la codificación de caracteres de salida HTTP


Detecta la codificación de caracteres de entrada HTTP

  • « mb_get_info
  • mb_http_output »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Detecta la codificación de caracteres de entrada HTTP

mb_http_input

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_http_input — Detecta la codificación de caracteres de entrada HTTP

Descripción

mb_http_input ( string $type = "" ) : mixed

Detecta la codificación de caracteres de entrada HTTP.

Parámetros

type

Un string de entrada que especifica el tipo de entrada. "G" para GET, "P" para POST, "C" para COOKIE, "S" para string, "L" para una lista, y "I" para una lista completa (devolverá un array). Si se omite el tipo, devolverá el último tipo de entrada procesado.

Valores devueltos

El nombre de la codificación de caracteres, según type. Si mb_http_input() no procesa la entrada HTTP especificada, devolverá false.

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • mb_http_output() - Establece/obtiene la codificación de caracteres de salida HTTP
  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres


Establece/obtiene la codificación de caracteres de salida HTTP

  • « mb_http_input
  • mb_internal_encoding »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene la codificación de caracteres de salida HTTP

mb_http_output

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_http_output — Establece/obtiene la codificación de caracteres de salida HTTP

Descripción

mb_http_output ( string $encoding = mb_http_output() ) : mixed

Establece/obtiene la codificación de caracteres de salida HTTP. La salida después de llamar a esta función será convertida de la codificación interna a encoding.

Parámetros

encoding

Si se establece encoding, mb_http_output() establece la codificación de caracteres de salida HTTP a encoding.

Si se omite encoding, mb_http_output() devolverá la codificación de caracteres de salida HTTP en uso.

Valores devueltos

Si encoding se omite, mb_http_output() devuelve la codificación de caracteres de salida HTTP en uso. De otro modo, Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • mb_http_input() - Detecta la codificación de caracteres de entrada HTTP
  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres


Establece/obtiene la codificación de caracteres interna

  • « mb_http_output
  • mb_language »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene la codificación de caracteres interna

mb_internal_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_internal_encoding — Establece/obtiene la codificación de caracteres interna

Descripción

mb_internal_encoding ( string $encoding = mb_internal_encoding() ) : mixed

Establece/obtiene la codificación de caracteres interna.

Parámetros

encoding

encoding es el nombre de la codificación de caracteres usada para la conversión de la codificación de caracteres de entrada HTTP, la conversión de la codificación de caracteres de salida HTTP , y la codificación de caracteres predeterminada para funciones de cadenas de caracteres definidas por el módulo mbstring. Debería observarse que la codificación interna es totalmente diferente de la de la expresión regular multibyte.

Valores devueltos

Si se establece encoding, entonces Devuelve true en caso de éxito o false en caso de error. En este caso, la codificación de caracteres para expresiones regulares multibyte NO se cambia. Si se omite encoding, entonces devolverá el nombre de la codificación de caracteres en uso.

Ejemplos

Ejemplo #1 Ejemplo de mb_internal_encoding()

<?php
/* Establecer la codificación de caracteres interna a UTF-8 */
mb_internal_encoding("UTF-8");

/* Mostrar la codificación de caracteres interna en uso */
echo mb_internal_encoding();
?>

Ver también

  • mb_http_input() - Detecta la codificación de caracteres de entrada HTTP
  • mb_http_output() - Establece/obtiene la codificación de caracteres de salida HTTP
  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres
  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte


Establece/obtiene el idioma actual

  • « mb_internal_encoding
  • mb_list_encodings »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene el idioma actual

mb_language

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_language — Establece/obtiene el idioma actual

Descripción

mb_language ( string $language = mb_language() ) : mixed

Establece/obtiene el idioma actual.

Parámetros

language

Se usa para codificar mensajes de correo electrónico. Los idiomas válidos son "Japanese", "ja","English","en" y "uni" (UTF-8). mb_send_mail() utiliza este ajuste para codificar correos electrónicos.

El idiomma y su configuración está en ISO-2022-JP/Base64 para Japanese, UTF-8/Base64 para uni, ISO-8859-1/quoted printable para English.

Valores devueltos

Si se establece language y language es válido, devuelve true. De lo contrario devuelve false. Cuando se omite language, devuelve el nombre del idioma como string. Si no se había establecido ningún idioma anteriormente, entonces devuelve false.

Ver también

  • mb_send_mail() - Envía un correo codificado


Devuelve un array con todos los tipos de codificaciones admitidas

  • « mb_language
  • mb_ord »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Devuelve un array con todos los tipos de codificaciones admitidas

mb_list_encodings

(PHP 5, PHP 7, PHP 8)

mb_list_encodings — Devuelve un array con todos los tipos de codificaciones admitidas

Descripción

mb_list_encodings ( ) : array

Devuelve un array con todos los tipos de codificaciones admitidas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array indexado numéricamente.

Errores/Excepciones

Esta función no emite ningún error.

Ejemplos

Ejemplo #1 Ejemplo de mb_list_encodings()

<?php

print_r(mb_list_encodings());

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => pass
    [1] => auto
    [2] => wchar
    [3] => byte2be
    [4] => byte2le
    [5] => byte4be
    [6] => byte4le
    [7] => BASE64
    [8] => UUENCODE
    [9] => HTML-ENTITIES
    [10] => Quoted-Printable
    [11] => 7bit
    [12] => 8bit
    [13] => UCS-4
    [14] => UCS-4BE
    [15] => UCS-4LE
    [16] => UCS-2
    [17] => UCS-2BE
    [18] => UCS-2LE
    [19] => UTF-32
    [20] => UTF-32BE
    [21] => UTF-32LE
    [22] => UTF-16
    [23] => UTF-16BE
    [24] => UTF-16LE
    [25] => UTF-8
    [26] => UTF-7
    [27] => UTF7-IMAP
    [28] => ASCII
    [29] => EUC-JP
    [30] => SJIS
    [31] => eucJP-win
    [32] => SJIS-win
    [33] => JIS
    [34] => ISO-2022-JP
    [35] => Windows-1252
    [36] => ISO-8859-1
    [37] => ISO-8859-2
    [38] => ISO-8859-3
    [39] => ISO-8859-4
    [40] => ISO-8859-5
    [41] => ISO-8859-6
    [42] => ISO-8859-7
    [43] => ISO-8859-8
    [44] => ISO-8859-9
    [45] => ISO-8859-10
    [46] => ISO-8859-13
    [47] => ISO-8859-14
    [48] => ISO-8859-15
    [49] => EUC-CN
    [50] => CP936
    [51] => HZ
    [52] => EUC-TW
    [53] => BIG-5
    [54] => EUC-KR
    [55] => UHC
    [56] => ISO-2022-KR
    [57] => Windows-1251
    [58] => CP866
    [59] => KOI8-R
)


Get code point of character

  • « mb_list_encodings
  • mb_output_handler »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Get code point of character

mb_ord

(PHP 7 >= 7.2.0, PHP 8)

mb_ord — Get code point of character

Descripción

mb_ord ( string $string , string|null $encoding = null ) : int|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

encoding

Valores devueltos

Returns a code point of character o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | encoding is nullable now.

Ver también

  • mb_chr() - Get a specific character
  • ord() - Convierte el primer byte de un string a un valor entre 0 y 255


Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida

  • « mb_ord
  • mb_parse_str »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida

mb_output_handler

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_output_handler — Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida

Descripción

mb_output_handler ( string $contents , int $status ) : string

mb_output_handler() es una función de llamada
de retorno de ob_start().
mb_output_handler() convierte
los carateres en el búfer de salida de la condificación de caracteres interna a
la codificación de caracteres de salida HTTP.

Parámetros

contents

El contenido del búfer de salida.

status

El estado del búfer de salida.

Valores devueltos

El string convertido.

Historial de cambios

Versión Descripción
4.1.0

Este gestor ahora añade la cabecera HTTP del conjunto de caracteres cuando se dan las siguientes condiciones:

  • Content-Type no está establecido, usando header().
  • El tipo MIME predeterminado comienza con text/.
  • El ajuste mbstring.http_input es distinto a pass.

Ejemplos

Ejemplo #1 Ejemplo de mb_output_handler()

<?php
mb_http_output("UTF-8");
ob_start("mb_output_handler");
?>

Notas

Nota:

Si se quiere que la salida sean datos binarios, como una imagen, la cabecera Content-Type: debe enviarse usando header() antes de enviar cualquier dato binario al cliente (p.ej. header("Content-Type: image/png")). Si se envió la cabecera Content-Type:, la conversión de la codificación de caracteres de salida no se realizará.

Observe que si se envía 'Content-Type: text/*' los datos enviados son considerados como texto; la conversión de la codificación se realizará.

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida


Analiza datos GET/POST/COOKIE y establece varialbes globales

  • « mb_output_handler
  • mb_preferred_mime_name »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Analiza datos GET/POST/COOKIE y establece varialbes globales

mb_parse_str

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_parse_str — Analiza datos GET/POST/COOKIE y establece varialbes globales

Descripción

mb_parse_str ( string $encoded_string , array &$result = ? ) : bool

Analiza datos GET/POST/COOKIE y establece variables globales. Ya que PHP no proporciona datos POST/COOKIE sin tratar, solamente se puede usar para datos GET por ahora. Analiza los datos del URL codificado, detecta la codificación, convierte la codificación a la codificación interna y establece los valores del array result o de las variables globales.

Parámetros

encoded_string

Los datos del URL codificado.

result

Un array que contiene la decodificación y los valores convertidos de la codificación de caracteres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mb_detect_order() - Establece/obtiene el orden de detección de codificaciones de caracteres
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna


Obtener un string del conjunto de caracteres del MIME

  • « mb_parse_str
  • mb_regex_encoding »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtener un string del conjunto de caracteres del MIME

mb_preferred_mime_name

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_preferred_mime_name — Obtener un string del conjunto de caracteres del MIME

Descripción

mb_preferred_mime_name ( string $encoding ) : string

Obtiene un string del conjunto de caracteres del MIME para una codificación específica.

Parámetros

encoding

La codificación que va a ser comprobada.

Valores devueltos

El string del conjunto de caracteres del MIME para la codificación de caracteres dada por encoding.

Ejemplos

Ejemplo #1 Ejemplo de mb_preferred_mime_name()

<?php
$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));
?>


Establecer/obtener la codificación de caracteres para expresiones regulares multibyte

  • « mb_preferred_mime_name
  • mb_regex_set_options »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establecer/obtener la codificación de caracteres para expresiones regulares multibyte

mb_regex_encoding

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_regex_encoding — Establecer/obtener la codificación de caracteres para expresiones regulares multibyte

Descripción

mb_regex_encoding ( string $encoding = mb_regex_encoding() ) : mixed

Establece/obtiene la codificación de caracteres para una expresión regular multibyte.

Parámetros

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

Si se establece encoding, entonces Devuelve true en caso de éxito o false en caso de error. En este caso, la codificación de caracteres interna NO se cambia. Si se omite encoding, entonces devolverá el nombre de la codificación de caracteres en uso para una expresión regular multibyte.

Historial de cambios

Versión | Descripción
5.6.0 | La codificación predeterminada se cambió a UTF-8. Anteriormente era EUC-JP.

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • mb_ereg() - Comparación de expresiones regulares con soporte multibyte


Establece/obtiene las opciones predeterminadas para las funciones mbregex

  • « mb_regex_encoding
  • mb_scrub »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene las opciones predeterminadas para las funciones mbregex

mb_regex_set_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_regex_set_options — Establece/obtiene las opciones predeterminadas para las funciones mbregex

Descripción

mb_regex_set_options ( string $options = mb_regex_set_options() ) : string

Establece las opciones predeterminadas descritas por options para las funciones de expresiones regulares multibyte.

Parámetros

options

Las opciones a establecer. Es un estring donde cada carácter es una opción. Para establecer un modo, el carácter de dicho modo debe ser el último en establecerse, ya que solamente puede ser establecdio un modo, aunque múltiples opciones.

Opciones de expresiones regulares
Opción | Significado
i | Comparación ambigua activada
x | Habilita la forma de patrones extendidos
m | '.' coincide con nuevas líneas
s | '^' -> '\A', '$' -> '\Z'
p | Lo mismo que las opciones m y s juntas
l | Busca las coincidencias más largas
n | Ignora las coincidencias vacías
e | Utiliza eval() con el código resultante
Modos de sintaxis de expresiones regulares
Modo | Significado
j | Java (Sun java.util.regex)
u | Expresión regular GNU
g | grep
c | Emacs
r | Ruby
z | Perl
b | Expresión regular POSIX Básica
d | Expresión regular POSIX Extendida

Valores devueltos

Las opciones anteriores. Si se omite options, devuelve el string que describe las opciones actuales.

Ver también

  • mb_split() - Divide cadenas de caracteres multibyte usando una expresión regular
  • mb_ereg() - Comparación de expresiones regulares con soporte multibyte
  • mb_eregi() - Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte


Description

  • « mb_regex_set_options
  • mb_send_mail »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Description

mb_scrub

(PHP 7 >= 7.2.0, PHP 8)

mb_scrub — Description

Descripción

mb_scrub ( string $string , string|null $encoding = null ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

string

encoding

Valores devueltos

Historial de cambios

Versión | Descripción
8.0.0 | encoding is nullable now.


Envía un correo codificado

  • « mb_scrub
  • mb_split »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Envía un correo codificado

mb_send_mail

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_send_mail — Envía un correo codificado

Descripción

mb_send_mail ( string $to , string $subject , string $message , string $additional_headers = null , string $additional_parameter = null ) : bool

Envía un correo. Las cabeceras y los mensajes se convierten y se codifican de acuerdo al ajuste mb_language(). Es una función de envoltura para mail(). Véase también mail() para más detalles.

Parámetros

to

La dirección de envío del correo. Se pueden especificar múltiples destinatarios poniendo una coma entre cada dirección de to. Este parámetro no se codifica de forma automática.

subject

El asunto del correo.

message

El mensaje del correo.

additional_headers (opcional)

El string a insertar al final de la cabecera del email.

Por lo común, se usa para añadir cabeceras extra (From, Cc, y Bcc). Múltiples cabeceras deberían separarse con un CRLF (\r\n). Se ha de validar este parámetro para evitar la inyección de cabeceras no deseadas.

Nota:

Al enviar un correo, éste debe contener una cabecera From. Ésta se puede estabelcer con el parámetro additional_headers, o se puede establecer una predeterminada en php.ini.

La omisión de dicha cabecera resultará en un mensaje de error similar a Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing. La cabecera From establece también Return-Path bajo Windows.

Nota:

Si los mensajes no se reciben, intente usar LF (\n) solamente. Algunos agengtes de transferencia de correo de Unix (más en concreto » qmail) reemplazan LF por CRLF automáticamente (lo que conduce a doblar CR si se usa CRLF). Esto debería ser el último recurso, ya que no cumple con la » RFC 2822.

additional_parameter

additional_parameter es un parámetro de línea de comandos MTA. Es útil al establecer la cabecera Return-Path correcta cuando se usa sendmail.

Este parámetro es escapado por escapeshellcmd() internamente para evitar la ejecución de comandos. escapeshellcmd() evita la ejecución de comandos, peros permite añadir parámetros adicionales. Por motivos de seguridad, este parámetro debería ser validado.

Ya que escapeshellcmd() se aplica automáticamente, no se pueden usar algunos caracteres que están permitidos como direcciones de email por las RFC. Los programas que necesiten usar estos caracters no podrán utilizar mail().

El usuario con el que se ejecute el servidor web debería añadirso como usuario de confianza a la configuración de sendmail para evitar que se añada una cabecera 'X-Warning' al mensaje cuando se establezca el remitente (-f) usando este método. Para usuarios de sendmail, este fichero es /etc/mail/trusted-users.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mail() - Enviar correo
  • mb_encode_mimeheader() - Codifica un string para la cabecera MIME
  • mb_language() - Establece/obtiene el idioma actual


Divide cadenas de caracteres multibyte usando una expresión regular

  • « mb_send_mail
  • mb_str_split »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Divide cadenas de caracteres multibyte usando una expresión regular

mb_split

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_split — Divide cadenas de caracteres multibyte usando una expresión regular

Descripción

mb_split ( string $pattern , string $string , int $limit = -1 ) : array

Divide un string multibyte usando la expresión regular pattern y devolviendo el resultado como un array.

Parámetros

pattern

El patrón de la expresión regular.

string

El string que va a ser dividido.

limit
Si se especifica el parámetro opcional limit, la división será de limit elementos como máximo.

Valores devueltos

El resultado como array.

Notas

Nota:

La codificación de caracteres especificada por mb_regex_encoding() se usará como codificación de caracteres para esta función de forma predeterminada.

Ver también

  • mb_regex_encoding() - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
  • mb_ereg() - Comparación de expresiones regulares con soporte multibyte


Given a multibyte string, return an array of its characters

  • « mb_split
  • mb_strcut »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Given a multibyte string, return an array of its characters

mb_str_split

(PHP 7 >= 7.4.0, PHP 8)

mb_str_split — Given a multibyte string, return an array of its characters

Descripción

mb_str_split ( string $string , int $length = 1 , string|null $encoding = null ) : array

This function will return an array of strings, it is a version of str_split() with support for encodings of variable character size as well as fixed-size encodings of 1,2 or 4 byte characters. If the length parameter is specified, the string is broken down into chunks of the specified length in characters (not bytes). The encoding parameter can be optionally specified and it is good practice to do so.

Parámetros

string

The string to split into characters or chunks.

length

If specified, each element of the returned array will be composed of multiple characters instead of a single character.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

A string specifying one of the supported encodings.

Valores devueltos

mb_str_split() returns an array of strings.

Historial de cambios

Versión | Descripción
8.0.0 | encoding is nullable now.
8.0.0 | This function no longer returns false on failure.

Ver también

  • str_split() - Convierte un string en un array


Obtener parte de un string

  • « mb_str_split
  • mb_strimwidth »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtener parte de un string

mb_strcut

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strcut — Obtener parte de un string

Descripción

mb_strcut ( string $str , int $start , int $length = NULL , string $encoding = mb_internal_encoding() ) : string

mb_strcut() extrae un substring de un string de forma similar a mb_substr(), pero opera sobre bytes en lugar de caracteres. Si la posición de corte ocurre entre dos bytes de un carácter multibyte, dicho corte se realiza empezando desde el primer byte del carácter. Esta es también la diferencia con la función substr(), la cual simplemente cortaría el string entre los bytes, resultando así una secuencia de bytes malformada.

Parámetros

str

El string a cortar.

start

Si start no es negativo, el string devuelto comenzará en la posición del byte start-ésima de string, empezando desde cero. Por ejemplo, en el string 'abcdef', el byte en la posición 0 es 'a', el byte en la posición 2 es 'c', etc.

Si start es negative, el string devuelto comenzará en el byte start-ésimo desde el final de string.

length

La longitud en bytes. Si se omite o se pasa NULL, extrae todos los bytes hasta el final del string.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

mb_strcut() devuelve la porción de str especificada por los parámetros start y length.

Historial de cambios

Versión | Descripción
5.4.8 | Pasar NULL al parámetro length extrae todos los bytes hasta el final de string. Antes de esta versión, NULL era tratado de igual modo que 0.

Ver también

  • mb_substr() - Obtiene parte de una cadena de caracteres
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna


Obtiene un string truncado con el ancho especificado

  • « mb_strcut
  • mb_stripos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtiene un string truncado con el ancho especificado

mb_strimwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strimwidth — Obtiene un string truncado con el ancho especificado

Descripción

mb_strimwidth ( string $str , int $start , int $width , string $trimmarker = "" , string $encoding = mb_internal_encoding() ) : string

Trunca el string str al ancho especificado por width.

Parámetros

str

El string a codificar.

start

El índice de la posición de inicio. El número de caracteres desde el comienzo del string. (El índice del primer carácter es 0)

width

El ancho del recorte deseado.

trimmarker

Un string que se añade al final del string cuando éste es truncado.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

El string truncado. Si se establece trimmarker, trimmarker reemplaza los últimos caracters que coincidan con width.

Ejemplos

Ejemplo #1 Ejemplo de mb_strimwidth()

<?php
echo mb_strimwidth("Hello World", 0, 10, "...");
// salida: "Hello W..."
?>

Ver también

  • mb_strwidth() - Devuelve el ancho de un string
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna


Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

  • « mb_strimwidth
  • mb_stristr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

mb_stripos

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_stripos — Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

Descripción

mb_stripos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

mb_stripos() devuelve la posición numérica de la primera ocurrencia de needle en el string haystack. A diferencia de mb_strpos(), mb_stripos() es insensible a mayúsculas/minúsculas. Si no se encuentra needle, devuelve false.

Parámetros

haystack

El string desde el que obtener la posición de la primera ocurrencia de needle

needle

El string a buscar en haystack

offset

La posición de haystack donde empezar la búsquda

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracteres interna.

Valores devueltos

Devuelve la posición numérica de la pirmera ocurrencia de needle en el string haystack, o false si no se encuentra needle.

Ver también

  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • mb_strpos() - Busca la posición de la primera ocurrencia de un string en otro string


Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

  • « mb_stripos
  • mb_strlen »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

mb_stristr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_stristr — Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas

Descripción

mb_stristr ( string $haystack , string $needle , bool $before_needle = false , string $encoding = mb_internal_encoding() ) : string

mb_stristr() busca la primera ocurrencia de needle en haystack y devuelve la porción de haystack. A diferencia de mb_strstr(), mb_stristr() es insensible a mayúsculas/minúsculas. Si no se encuentra needle, devuelve false.

Parámetros

haystack

El string desde el que obtener la primera ocurrencia de needle

needle

El string a buscar en haystack

before_needle

Determina qué porción de haystack devuelve esta función. Si se establece a true, devuelve todo el haystack desde el comienzo de la primera ocurrencia de needle (excluyendo needle). Si se establece a false, Devuelve todo el haystack desde la primera ocurrencia de needle hasta el final (incluyendo needle).

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracteres interna.

Valores devueltos

Devuelve la porción de haystack, o false si no se encuentra needle.

Ver también

  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strstr() - Encuentra la primera aparición de un string
  • mb_strstr() - Busca la primera ocurrencia de un string dentro de otro


Obtiene la longitud de una cadena de caracteres

  • « mb_stristr
  • mb_strpos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtiene la longitud de una cadena de caracteres

mb_strlen

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strlen — Obtiene la longitud de una cadena de caracteres

Descripción

mb_strlen ( string $str , string $encoding = mb_internal_encoding() ) : mixed

Obtiene la longitud de un string.

Parámetros

str

El string del que se va a obtener su longitud.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

Devuelve el número de caracteres del string str, teniendo éste una codificación de caracteres dada por encoding. Un carácter multibyte cuenta como 1.

Devuelve false si la codificación dada por encoding no es válida.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • grapheme_strlen() - Obtener la longitud de un string en unidades de grafema
  • iconv_strlen() - Retorna el número de caracteres de un string
  • strlen() - Obtiene la longitud de un string


Busca la posición de la primera ocurrencia de un string en otro string

  • « mb_strlen
  • mb_strrchr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la posición de la primera ocurrencia de un string en otro string

mb_strpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strpos — Busca la posición de la primera ocurrencia de un string en otro string

Descripción

mb_strpos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

Busca la posición de la primera ocurrencia de un string en otro string.

Realiza una operación strpos() segura multibyte basada en el número de caracteres. La posición del primer carácter es 0, la posición del segundo carácter es 1, etc.

Parámetros

haystack

El string a comprobar.

needle

El string a buscar en haystack. A diferencia de strpos(), los valores numéricos no se aplican como el valor ordinal de un carácter.

offset

El índice de búsqueda. Si no se especifica se usará 0.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

Devuelve la posición numéricia de la primera ocurrencia de needle en el string haystack. Si no se encuentra needle, devuelve false.

Ver también

  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string


Busca la última ocurrencia de un carácter de un string dentro de otro

  • « mb_strpos
  • mb_strrichr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la última ocurrencia de un carácter de un string dentro de otro

mb_strrchr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strrchr — Busca la última ocurrencia de un carácter de un string dentro de otro

Descripción

mb_strrchr ( string $haystack , string $needle , bool $part = false , string $encoding = mb_internal_encoding() ) : string

mb_strrchr() busca la última ocurrencia de needle en haystack y devuelve la porción de haystack. Si no se encuentra needle, devuelve false.

Parámetros

haystack

El string desde el que obtener la última ocurrencia de needle

needle

El string a buscar en haystack

part

Determina qué porción de haystack devuelve esta función. Si se establece a true, devuelve todo el haystack desde el comienzo de la última ocurrencia de needle. Si se establece a false, devuelve todo el haystack desde la última ocurrencia de needle hasta el final.

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracterse interna.

Valores devueltos

Devuelve la porción de haystack. o false si no se encuentra needle.

Ver también

  • strrchr() - Encuentra la última aparición de un caracter en un string
  • mb_strstr() - Busca la primera ocurrencia de un string dentro de otro
  • mb_strrichr() - Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas


Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas

  • « mb_strrchr
  • mb_strripos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas

mb_strrichr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strrichr — Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas

Descripción

mb_strrichr ( string $haystack , string $needle , bool $part = false , string $encoding = mb_internal_encoding() ) : string

mb_strrichr() busca la última ocurrencia de needle en haystack y devuelve la porción de haystack. A diferencia de mb_strrchr(), mb_strrichr() es insensible a mayúsculas/minúsculas. Si no se encuentra needle, devuelve false.

Parámetros

haystack

El string desde el que obtener la última ocurrencia de needle

needle

El string a buscar en haystack

part

Determina qué porción de haystack devuelve esta función. Si se establece a true, devuelve todo el haystack desde el comienzo de la última ocurrencia de needle. Si se establece a false, devuelve todo el haystack desde la última ocurrencia de needle hasta el final.

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracterse interna.

Valores devueltos

Devuelve la porción de haystack. o false si no se encuentra needle.

Ver también

  • mb_stristr() - Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
  • mb_strrchr() - Busca la última ocurrencia de un carácter de un string dentro de otro


Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas

  • « mb_strrichr
  • mb_strrpos »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas

mb_strripos

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strripos — Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas

Descripción

mb_strripos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

Realiza una operación strpos() segura multibyte basada en el número de caracteres. La posición de needle se cuenta desde el comienzo de haystack. La posición del primer carácter es 0. La posición del segundo carácter es 1. A diferencia de mb_strrpos(), mb_strripos() es insensible a mayúsculas/minúsculas.

Parámetros

haystack

El string a comprobar, para la última ocurrencia de needle

needle

El string a buscar en haystack.

offset

La posición de haystack donde iniciar la búsqueda

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracteres interna.

Valores devueltos

evuelve la posición numérica de la última ocurrencia de needle en el string haystack, o false si no se encuentra needle.

Ver también

  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • mb_strrpos() - Busca la posicion de la última ocurrencia de un string en otro string


Busca la posicion de la última ocurrencia de un string en otro string

  • « mb_strripos
  • mb_strstr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la posicion de la última ocurrencia de un string en otro string

mb_strrpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strrpos — Busca la posicion de la última ocurrencia de un string en otro string

Descripción

mb_strrpos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

Realiza una operación strpos() segura multibyte basada en el número de caracteres. La posición de needle se cuenta desde el comienzo de haystack. La posición del primer carácter es 0. La posición del segundo carácter es 1.

Parámetros

haystack

El string a comprobar, para la última ocurrencia de needle

needle

El string a buscar en haystack.

offset
Se podría especificar para comenzar la búsqueda de un número arbitrario de caracteres dentro del string. Los valores negativos detendrán la búsqueda en un punto arbitrario anterior al final del string.
encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

Devuelve la posición numérica de la última ocurrencia de needle en el string haystack. Si no se encuentra needle, devuelve false.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro opcional offset.

Notas

Nota: El parámetro encoding fue movido de la tercera posición a la cuarta en PHP 5.2.0. Para la retrocompatibilidad, encoding se puede especificar como tercer parámetro, pero hacerlo está obsoleto y será eliminado en el futuro.

Ver también

  • mb_strpos() - Busca la posición de la primera ocurrencia de un string en otro string
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string


Busca la primera ocurrencia de un string dentro de otro

  • « mb_strrpos
  • mb_strtolower »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Busca la primera ocurrencia de un string dentro de otro

mb_strstr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strstr — Busca la primera ocurrencia de un string dentro de otro

Descripción

mb_strstr ( string $haystack , string $needle , bool $before_needle = false , string $encoding = mb_internal_encoding() ) : string

mb_strstr() busca la primera ocurrencia de needle en haystack y devuelve la porción de haystack. Si no se encunetra needle, devuelve false.

Parámetros

haystack

El string desde el que obtener la primera ocurrencia de needle

needle

El string a buscar en haystack

before_needle

Determina qué porción de haystack devuelve esta función. Si se establece a true, devuelve todo el haystack desde el comienzo de la primera ocurrencia de needle (incluyendo needle). Si se establece a false, Devuelve todo el haystack desde la primera ocurrencia de needle hasta el final (excluyendo needle).

encoding

El nombre de la codificación de caracteres a usar. Si se omite, se usará la codificación de caracteres interna.

Valores devueltos

Devuelve la porción de haystack, o false si no se encuentra needle.

Ver también

  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strstr() - Encuentra la primera aparición de un string
  • mb_stristr() - Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas


Convierte una cadena de caracteres a minúsculas

  • « mb_strstr
  • mb_strtoupper »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte una cadena de caracteres a minúsculas

mb_strtolower

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_strtolower — Convierte una cadena de caracteres a minúsculas

Descripción

mb_strtolower ( string $str , string $encoding = mb_internal_encoding() ) : string

Devuelve str con todos los caracteres alfabéticos convertidos a minúscula.

Parámetros

str

El string a convertir.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

str con todos los caracteres alfabéticos convertidos a minúscula.

Unicode

Para más información sobre las propiedades Unicode, véase » http://www.unicode.org/reports/tr21/.

A diferencia de strtolower(), los 'caracteres alfabéticos' son determinados por las propiedades del carácter Unicode. Por tanto, el comportamiento de esta función no se ve afectada por la configuración regional, ya que puede convertir cualquier carácter que tenga la propiedad de 'alfabético', como la A con diéresis (Ä).

Ejemplos

Ejemplo #1 Ejemplo de mb_strtolower()

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtolower($str);
echo $str; // Muestra mary had a little lamb and she loved it so
?>

Ejemplo #2 Ejemplo de mb_strtolower() con texto no latino

<?php
$str = "????st? a??p?? ßaf?? ??µ??? ??, d?as?e???e? ?p?? ?????? ?????";
$str = mb_strtolower($str, 'UTF-8');
echo $str; // Muestra t???st? a??p?? ßaf?? ??µ??? ??, d?as?e???e? ?p?? ?????? ?????
?>

Ver también

  • mb_strtoupper() - Convierte un string en mayúsculas
  • mb_convert_case() - Realiza una conversión a mayúsculas/minúsculas de un string
  • strtolower() - Convierte un string a minúsculas


Convierte un string en mayúsculas

  • « mb_strtolower
  • mb_strwidth »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Convierte un string en mayúsculas

mb_strtoupper

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_strtoupper — Convierte un string en mayúsculas

Descripción

mb_strtoupper ( string $str , string $encoding = mb_internal_encoding() ) : string

Devuelve str con todos los caracteres alfabéticos convertidos a mayúsculas.

Parámetros

str

El string a convertir en mayúsculas.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

str con todos los caracteres alfabéticoas convertidos a mayúsculas.

Unicode

Para más información sobre la propiedades Unicode, véase » http://www.unicode.org/reports/tr21/.

A diferencia de strtoupper(), 'alphabetic' está determinado por las propiedades del carácter Unicode. Por lo tanto, el comportamiento de esta función no se ve afectado por la configuración regional, por lo que puede convertir cualquier carácter que tenga la propiedad 'alphabetic', como la a con diéresis (ä).

Ejemplos

Ejemplo #1 Ejemplo de mb_strtoupper()

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtoupper($str);
echo $str; // Imprime MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

Ejemplo #2 Ejemplo de mb_strtoupper() con texto UTF-8 no latino

<?php
$str = "????st? a??p?? ßaf?? ??µ??? ??, d?as?e???e? ?p?? ?????? ?????";
$str = mb_strtoupper($str, 'UTF-8');
echo $str; // Imprime ????S?? ?????? ??F?S ?????? G?, ???S??????? ???? ?OT??? ????S
?>

Ver también

  • mb_strtolower() - Convierte una cadena de caracteres a minúsculas
  • mb_convert_case() - Realiza una conversión a mayúsculas/minúsculas de un string
  • strtoupper() - Convierte un string a mayúsculas


Devuelve el ancho de un string

  • « mb_strtoupper
  • mb_substitute_character »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Devuelve el ancho de un string

mb_strwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strwidth — Devuelve el ancho de un string

Descripción

mb_strwidth ( string $str , string $encoding = mb_internal_encoding() ) : int

Devuelve el ancho del string str.

Los caracteres multibyte normalmente son el doble de anchos que los caracteres de un único byte.

Ancho de caracteres
Caracteres | Ancho
U+0000 - U+0019 | 0
U+0020 - U+1FFF | 1
U+2000 - U+FF60 | 2
U+FF61 - U+FF9F | 1
U+FFA0 - | 2

Parámetros

str

El string a decodificar.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

El ancho del string str.

Ver también

  • mb_strimwidth() - Obtiene un string truncado con el ancho especificado
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna


Establece/obtiene un carácter de sustitución

  • « mb_strwidth
  • mb_substr_count »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Establece/obtiene un carácter de sustitución

mb_substitute_character

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_substitute_character — Establece/obtiene un carácter de sustitución

Descripción

mb_substitute_character ( mixed $substrchar = mb_substitute_character() ) : mixed

Especifica un carácter de sustitución cuando la codificación de caracteres de entrada es inválida o el código del carácter no existe en la codificación de caracteres de salida. Los caracteres inválidos pueden ser sustituidos por valores null (sin salida), string o integer (valor del código del carácter Unicode).

Esta configuración afecta a mb_convert_encoding(),
mb_convert_variables(),
mb_output_handler(),
y mb_send_mail().

Parámetros

substrchar

Especifica el valor Unicode como un integer, o como uno de los siguientes strings:

  • "none": sin salida
  • "long" : Producir el valor del código del carácter (Ejemplo: U+3000, JIS+7E7E)
  • "entity" : Producir la entidad del carácter (Ejemplo: ?)

Valores devueltos

Si se establece substchar, devuelve true en caso de éxito, o en caso contrairo devuelve false. Si substchar no se establece, devuelve el ajuste actual.

Ejemplos

Ejemplo #1 Ejemplo de mb_substitute_character()

<?php
/* Establecer con Unicode U+3013 (GETA MARK) */
mb_substitute_character(0x3013);

/* Establecer el formato hexadecimal */
mb_substitute_character("long");

/* Mostrar la configuración en uso */
echo mb_substitute_character();
?>


Cuenta el número de ocurrencias de un substring

  • « mb_substitute_character
  • mb_substr »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Cuenta el número de ocurrencias de un substring

mb_substr_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_substr_count — Cuenta el número de ocurrencias de un substring

Descripción

mb_substr_count ( string $haystack , string $needle , string $encoding = mb_internal_encoding() ) : int

Cuenta el número de veces que el substring needle aparece en el string haystack.

Parámetros

haystack

El string a comprobar.

needle

El string a buscar.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

El número de veces que el substring needle aparece en el string haystack.

Ejemplos

Ejemplo #1 Ejemplo de mb_substr_count()

<?php
echo mb_substr_count("This is a test", "is"); // imprime 2
?>

Ver también

  • mb_strpos() - Busca la posición de la primera ocurrencia de un string en otro string
  • mb_substr() - Obtiene parte de una cadena de caracteres
  • substr_count() - Cuenta el número de apariciones del substring


Obtiene parte de una cadena de caracteres

  • « mb_substr_count
  • Pspell »
  • PHP Manual
  • Funciones de cadenas de caracteres multibyte
  • Obtiene parte de una cadena de caracteres

mb_substr

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_substr — Obtiene parte de una cadena de caracteres

Descripción

mb_substr ( string $str , int $start , int $length = NULL , string $encoding = mb_internal_encoding() ) : string

Realiza una operación substr() multibyte de forma segura basada en el número de caracteres. La posición se cuenta desde el principio de str. La posición del primer carácter es 0. La posición del segundo es 1, etc.

Parámetros

str

El string de donde extraer la parte deseada.

start

Si start no es negativo, el string devuelto comenzará en la posición start-ésima de str, empezando desde cero. Por ejemplo, en el string 'abcdef', el carácter en la posición 0 es 'a', el carácter en la posición 2 es 'c', etc.

Si start es negativo, el string devuelto comenzará en el start-ésimo carácter desde el final de str.

length

El número máximo de caracteres a usar de str. Si se omite o se pasa NULL, extrae todos los caracteres hasta el final del string.

encoding

El parámetro encoding es la codificación de caracteres. Si es omitido, será usado el valor de la codificación de caracteres interna.

Valores devueltos

mb_substr() devuelve una parte de str especificada por los parametros start y length.

Historial de cambios

Versión | Descripción
5.4.8 | Pasar NULL al parámetro length extrae todos los caracteres hasta el final de string. Antes de esta versión, NULL era tratado de igual modo que 0.

Ver también

  • mb_strcut() - Obtener parte de un string
  • mb_internal_encoding() - Establece/obtiene la codificación de caracteres interna


Pspell

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Pspell
    • pspell_add_to_personal — Añadir una palabra a la lista personal de palabras
    • pspell_add_to_session — Añadir la palabra a la lista de palabras en la sesión actual
    • pspell_check — Verificar una palabra
    • pspell_clear_session — Limpia la sesión actual
    • pspell_config_create — Crear una configuración usada para abrir un diccionario
    • pspell_config_data_dir — Ubicación de los ficheros de información de lenguaje
    • pspell_config_dict_dir — Ubicación de la lista principal de palabras
    • pspell_config_ignore — Ignorar palabras con menos de N caracteres
    • pspell_config_mode — Cambiar el modo de número de sugerencias devueltas
    • pspell_config_personal — Establecer un fichero que contiene una lista personal de palabras
    • pspell_config_repl — Establecer un fichero que contiene pares de sustitución
    • pspell_config_runtogether — Considerar las palabras unidas como compuestos válidos
    • pspell_config_save_repl — Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras
    • pspell_new_config — Cargar un nuevo diccionario con ajustes basados en una configuración dada
    • pspell_new_personal — Cargar un nuevo diccionario con una lista personal de palabras
    • pspell_new — Cargar un nuevo diccionario
    • pspell_save_wordlist — Guardar la lista de palabras personal a un fichero
    • pspell_store_replacement — Almacenar un par de sustitución de una palabra
    • pspell_suggest — Sugerir ortografías de una palabra


Introducción

Estas funciones permiten la comprobación de la ortografía de una palabra y ofrecer sugerencias.


Requerimientos

Para compilar PHP con soporte para pspell necesita la biblioteca aspell, disponible en » http://aspell.net/.


Instalación

Si tiene las bibliotecas necesarias añada la opción --with-pspell[=dir] al compilar PHP.

Nota: Nota para los usuarios de Win32

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: aspell-15.dll de la carpeta bin de la instalación de aspell.

El soporte para Win32 está disponible sólo en PHP 4.3.3 y versiones posteriores. También se requiere al menos la versión 0.50 de aspell.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

PSPELL_FAST (integer)
PSPELL_NORMAL (integer)
PSPELL_BAD_SPELLERS (integer)
PSPELL_RUN_TOGETHER (integer)


Funciones de Pspell

Tabla de contenidos

  • pspell_add_to_personal — Añadir una palabra a la lista personal de palabras
  • pspell_add_to_session — Añadir la palabra a la lista de palabras en la sesión actual
  • pspell_check — Verificar una palabra
  • pspell_clear_session — Limpia la sesión actual
  • pspell_config_create — Crear una configuración usada para abrir un diccionario
  • pspell_config_data_dir — Ubicación de los ficheros de información de lenguaje
  • pspell_config_dict_dir — Ubicación de la lista principal de palabras
  • pspell_config_ignore — Ignorar palabras con menos de N caracteres
  • pspell_config_mode — Cambiar el modo de número de sugerencias devueltas
  • pspell_config_personal — Establecer un fichero que contiene una lista personal de palabras
  • pspell_config_repl — Establecer un fichero que contiene pares de sustitución
  • pspell_config_runtogether — Considerar las palabras unidas como compuestos válidos
  • pspell_config_save_repl — Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras
  • pspell_new_config — Cargar un nuevo diccionario con ajustes basados en una configuración dada
  • pspell_new_personal — Cargar un nuevo diccionario con una lista personal de palabras
  • pspell_new — Cargar un nuevo diccionario
  • pspell_save_wordlist — Guardar la lista de palabras personal a un fichero
  • pspell_store_replacement — Almacenar un par de sustitución de una palabra
  • pspell_suggest — Sugerir ortografías de una palabra


Añadir una palabra a la lista personal de palabras

  • « Funciones de Pspell
  • pspell_add_to_session »
  • PHP Manual
  • Funciones de Pspell
  • Añadir una palabra a la lista personal de palabras

pspell_add_to_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_add_to_personal — Añadir una palabra a la lista personal de palabras

Descripción

pspell_add_to_personal ( int $dictionary_link , string $word ) : bool

pspell_add_to_personal() añade una palabra a la lista personal de palabras. Si se usó pspell_new_config() con pspell_config_personal() para abrir un diccionario, se puede guardar la lista de palabras más tarde con pspell_save_wordlist().

Parámetros

dictionary_link

word

La palabra añadida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Añadir la palabra a la lista de palabras en la sesión actual

  • « pspell_add_to_personal
  • pspell_check »
  • PHP Manual
  • Funciones de Pspell
  • Añadir la palabra a la lista de palabras en la sesión actual

pspell_add_to_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_add_to_session — Añadir la palabra a la lista de palabras en la sesión actual

Descripción

pspell_add_to_session ( int $dictionary_link , string $word ) : bool

pspell_add_to_session() añade una palabra a la lista de palabras asociadas con la sesión actual. Es muy parecida a pspell_add_to_personal()

Parámetros

dictionary_link

word

La palabra añadida.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Verificar una palabra

  • « pspell_add_to_session
  • pspell_clear_session »
  • PHP Manual
  • Funciones de Pspell
  • Verificar una palabra

pspell_check

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_check — Verificar una palabra

Descripción

pspell_check ( int $dictionary_link , string $word ) : bool

pspell_check() verifica la ortografía de una palabra.

Parámetros

dictionary_link

word

La palabra comprobada.

Valores devueltos

Devuelve true si la ortografía es correcta, false si no.

Ejemplos

Ejemplo #1 Ejemplo de pspell_check()

<?php
$pspell_link = pspell_new("en");

if (pspell_check($pspell_link, "testt")) {
    echo "Ésta es una ortografía correcta";
} else {
    echo "Lo siento, ortografía errónea";
}
?>


Limpia la sesión actual

  • « pspell_check
  • pspell_config_create »
  • PHP Manual
  • Funciones de Pspell
  • Limpia la sesión actual

pspell_clear_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_clear_session — Limpia la sesión actual

Descripción

pspell_clear_session ( int $dictionary_link ) : bool

pspell_clear_session() limpia la sesión actual. La lista de palabras actual se pone en blanco, y, por ejemplo, si se intenta guardarla con pspell_save_wordlist(), no sucederá nada.

Parámetros

dictionary_link

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_clear_session($pspell_link);
pspell_save_wordlist($pspell_link);    //"Vlad" no se guardará
?>


Crear una configuración usada para abrir un diccionario

  • « pspell_clear_session
  • pspell_config_data_dir »
  • PHP Manual
  • Funciones de Pspell
  • Crear una configuración usada para abrir un diccionario

pspell_config_create

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_create — Crear una configuración usada para abrir un diccionario

Descripción

pspell_config_create ( string $language , string $spelling = ? , string $jargon = ? , string $encoding = ? ) : int

Crea una configuración usada para abrir un diccionario.

pspell_config_create() tienen una sintaxis muy parecida a la de pspell_new(). De hecho, al usar pspell_config_create() seguido inmediatemante de pspell_new_config() producirá exactamente el mismo resultado. Sin embargo, después de crear una nueva configuración también se pueden usar las funciones pspell_config_*() antes de llamar a pspell_new_config() para tomar ventaja de algunas funcionalidades avanzadas.

Para más información y ejemplos, verifique el sitio web de pspell del manual en línea:» http://aspell.net/.

Parámetros

language

El parámetro language es el código de lenguaje que consiste en el código de lenguaje ISO 639 de dos letras y un código de país ISO 3166 de dos letras opcional después de un guión o guión de subrayado.

spelling

El parámetro spelling es la ortografía solicitada para lenguajes con más de una ortografía, como el inglés. Valores conocidos son 'american', 'british', y 'canadian'.

jargon

El parámetro jargon contiene información extra para distinguir dos listas de palabras diferentes que tienen el mismo lenguaje y parámetros de ortografía.

encoding

El parámetro encoding es la codificación que se espera que tengan esas palabras. Los valores válidos son 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. Este parámetro no está en gran parte comprobado, por lo que, tenga cuidado al usarlo.

Valores devueltos

Devuelve un identificador de configuración de ortografía, o false en caso de error.

Ejemplos

Ejemplo #1 pspell_config_create()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal($pspell_config, "en");
?>


Ubicación de los ficheros de información de lenguaje

  • « pspell_config_create
  • pspell_config_dict_dir »
  • PHP Manual
  • Funciones de Pspell
  • Ubicación de los ficheros de información de lenguaje

pspell_config_data_dir

(PHP 5, PHP 7, PHP 8)

pspell_config_data_dir — Ubicación de los ficheros de información de lenguaje

Descripción

pspell_config_data_dir ( int $conf , string $directory ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Ubicación de la lista principal de palabras

  • « pspell_config_data_dir
  • pspell_config_ignore »
  • PHP Manual
  • Funciones de Pspell
  • Ubicación de la lista principal de palabras

pspell_config_dict_dir

(PHP 5, PHP 7, PHP 8)

pspell_config_dict_dir — Ubicación de la lista principal de palabras

Descripción

pspell_config_dict_dir ( int $conf , string $directory ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Ignorar palabras con menos de N caracteres

  • « pspell_config_dict_dir
  • pspell_config_mode »
  • PHP Manual
  • Funciones de Pspell
  • Ignorar palabras con menos de N caracteres

pspell_config_ignore

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_ignore — Ignorar palabras con menos de N caracteres

Descripción

pspell_config_ignore ( int $dictionary_link , int $n ) : bool

pspell_config_ignore() debería usarse en una configuración antes de llamar a pspell_new_config(). Esta función permite al corrector de ortografía saltarse palabras cortas.

Parámetros

dictionary_link

n

Las palabras con menos de n caracteres serán saltadas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_config_ignore()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_ignore($pspell_config, 5);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "abcd");    //no resultará en un error
?>


Cambiar el modo de número de sugerencias devueltas

  • « pspell_config_ignore
  • pspell_config_personal »
  • PHP Manual
  • Funciones de Pspell
  • Cambiar el modo de número de sugerencias devueltas

pspell_config_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_mode — Cambiar el modo de número de sugerencias devueltas

Descripción

pspell_config_mode ( int $dictionary_link , int $mode ) : bool

pspell_config_mode() debería usarse en una configuración antes de llamar a pspell_new_config(). Esta función determina cuántas sugerencias serán devueltas por pspell_suggest().

Parámetros

dictionary_link

mode

El parámetro mode es el modo en el que trabajará el corrector ortográfico. Hay varios modos disponibles:

  • PSPELL_FAST - Modo rápido (menor númeo de sugerencias)
  • PSPELL_NORMAL - Modo normal (más sugerencias)
  • PSPELL_BAD_SPELLERS - Modo lento (un montón de sugerencias)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de pspell_config_mode()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_mode($pspell_config, PSPELL_FAST);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>


Establecer un fichero que contiene una lista personal de palabras

  • « pspell_config_mode
  • pspell_config_repl »
  • PHP Manual
  • Funciones de Pspell
  • Establecer un fichero que contiene una lista personal de palabras

pspell_config_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_personal — Establecer un fichero que contiene una lista personal de palabras

Descripción

pspell_config_personal ( int $dictionary_link , string $file ) : bool

Establece un fichero que contiene una lista personal de palabras. Además, ésta será cargada en la lista estándar después de llamar a pspell_new_config(). Es fichero también es el fichero donde pspell_save_wordlist() guardará la lista personal de palabras.

pspell_config_personal() debería usarse con una configuración antes de llamar a pspell_new_config().

Parámetros

dictionary_link

file

La lista personal de palabras. Si el fichero no existe, se creará. El fichero debería ser modificable por quienquiera que ejecute PHP (p.ej. nadie).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_config_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Establecer un fichero que contiene pares de sustitución

  • « pspell_config_personal
  • pspell_config_runtogether »
  • PHP Manual
  • Funciones de Pspell
  • Establecer un fichero que contiene pares de sustitución

pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_repl — Establecer un fichero que contiene pares de sustitución

Descripción

pspell_config_repl ( int $dictionary_link , string $file ) : bool

Establece un fichero que contiene pares de sustitución.

Los pares de sustitución mejoran la calidad del corrector ortográfico. Cuando una palabra está mal escrita y no se ha encontrado una sugerencia apropiada en la lista, se puede usar pspell_store_replacement() para almacenar un par de sustitución y después pspell_save_wordlist() para guardar la lista de palabras junto con los pares de sustitución.

pspell_config_repl() debería usarse con una configuración antes de llamar a pspell_new_config().

Parámetros

dictionary_link

file

El fichero debería ser modificable por quienquiera que ejecute PHP (p.ej. nadie).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_config_repl()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Considerar las palabras unidas como compuestos válidos

  • « pspell_config_repl
  • pspell_config_save_repl »
  • PHP Manual
  • Funciones de Pspell
  • Considerar las palabras unidas como compuestos válidos

pspell_config_runtogether

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_runtogether — Considerar las palabras unidas como compuestos válidos

Descripción

pspell_config_runtogether ( int $dictionary_link , bool $flag ) : bool

Esta función determina si las palabras unidas serán tratadas como compuestos legales. Es decir, "elgato" será un compuesto legal, aunque debería de haber un espacio entre las dos palabras. Cambiar esta configuración únicamente afecta a los resultados devueltos por pspell_check(); pspell_suggest() seguirá devolviendo sugerencias.

pspell_config_runtogether() debería usarse con una configuración antes de llamar a pspell_new_config().

Parámetros

dictionary_link

flag

true si las palabras unidas deberían ser tratadas como compuestos legales, false si no.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_config_runtogether()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_runtogether($pspell_config, true);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>


Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras

  • « pspell_config_runtogether
  • pspell_new_config »
  • PHP Manual
  • Funciones de Pspell
  • Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras

pspell_config_save_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_save_repl — Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras

Descripción

pspell_config_save_repl ( int $dictionary_link , bool $flag ) : bool

pspell_config_save_repl() determina si pspell_save_wordlist() guardará los pares de sustitución junto con la lista de palabras. Normalmente no hay necesidad de usar esta función ya que si se usa pspell_config_repl(), los pares de sustitución serán guardados por pspell_save_wordlist() de todos modos, y si no, los pares de sustitución no se guardarán.

pspell_config_save_repl() debería usarse con una configuración antes de llamar a pspell_new_config().

Parámetros

dictionary_link

flag

true si los pares de sustitución deberían guardarse, false si no.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Cargar un nuevo diccionario con ajustes basados en una configuración dada

  • « pspell_config_save_repl
  • pspell_new_personal »
  • PHP Manual
  • Funciones de Pspell
  • Cargar un nuevo diccionario con ajustes basados en una configuración dada

pspell_new_config

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new_config — Cargar un nuevo diccionario con ajustes basados en una configuración dada

Descripción

pspell_new_config ( int $config ) : int

pspell_new_config() abre un nuevo diccionario con los ajustes especificados en una configuración, creada con pspell_config_create() y modificada con las funciones pspell_config_*(). Este método proporciona la mayor flexibilidad y tiene todas las funcionalidades proporcionadas por pspell_new() y pspell_new_personal().

Parámetros

config

El parámetro config es una configuración devuelta por pspell_config_create() cuando se creó la configuración.

Valores devueltos

Devuelve un identificador de vínculo de diccionario en caso de éxito.

Ejemplos

Ejemplo #1 pspell_new_config()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
?>


Cargar un nuevo diccionario con una lista personal de palabras

  • « pspell_new_config
  • pspell_new »
  • PHP Manual
  • Funciones de Pspell
  • Cargar un nuevo diccionario con una lista personal de palabras

pspell_new_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new_personal — Cargar un nuevo diccionario con una lista personal de palabras

Descripción

pspell_new_personal ( string $personal , string $language , string $spelling = ? , string $jargon = ? , string $encoding = ? , int $mode = 0 ) : int

pspell_new_personal() abre un nuevo diccionario con una lista personal de palabras. Ésta puede ser modificada y guardada con pspell_save_wordlist(), si se desea. Sin embargo, los pares de sustitución no se guardan. Para guardarlos se debería crear una configuración usando pspell_config_create(), establecer el fichero de la lista personal de palabras con pspell_config_personal(), establecer el fichero de pares de sustitución con pspell_config_repl(), y abrir un nuevo diccionario con pspell_new_config().

Para más información y ejemplos, verifique el sitio web de pspell del manual en línea:» http://aspell.net/.

Parámetros

personal

El fichero donde se almacenarán las palabras añadidas a la lista personal. Debería ser un nombre de fichero absoluto comenzado con '/', ya que de otro modo será relativo a $HOME, el cual es "/root" para la mayoría de sistemas, y probablemente no es lo que quiere.

language

El parámetro language es el código de lenguaje que consiste en el código de lenguaje ISO 639 de dos letras y un código de país ISO 3166 de dos letras opcional después de un guión o guión de subrayado.

spelling

La ortografía solicitada para lenguajes con más de una ortografía, como el inglés. Valores conocidos son 'american', 'british', y 'canadian'.

jargon

Información extra para distinguir dos listas de palabras diferentes que tienen el mismo lenguaje y parámetros de ortografía.

encoding

La codificación que se espera que tengan esas palabras. Los valores válidos son utf-8, iso8859-*, koi8-r, viscii, cp1252, machine unsigned 16, machine unsigned 32.

mode

El modo en el que trabajará el corrector ortográfico. Hay varios modos disponibles:

  • PSPELL_FAST - Modo rápido (menor númeo de sugerencias)
  • PSPELL_NORMAL - Modo normal (más sugerencias)
  • PSPELL_BAD_SPELLERS - Modo lento (un montón de sugerencias)
  • PSPELL_RUN_TOGETHER - Considerar palabras unidas como compuestos legales. Es decir, "elgao" será un compuesto legal, aunque debería haber un espacio entre las dos palabras. Cambiar esta configuración solo afecta a los resultados devueltos por pspell_check(); pspell_suggest() seguirá devolviendo sugerencias.
El modo es una máscara de bits construida a partir de diferentes constantes listadas después. Sin embargo, PSPELL_FAST, PSPELL_NORMAL y PSPELL_BAD_SPELLERS son mutuamente exclusivas, por lo que debería seleccionar únicamente una de ellas.

Valores devueltos

Devuelve el identificador de vínculo de diccionario para usarlo en otras funciones pspell.

Ejemplos

Ejemplo #1 pspell_new_personal()

<?php
$pspell_link = pspell_new_personal ("/var/dictionaries/custom.pws",
        "en", "", "", "", PSPELL_FAST|PSPELL_RUN_TOGETHER);
?>


Cargar un nuevo diccionario

  • « pspell_new_personal
  • pspell_save_wordlist »
  • PHP Manual
  • Funciones de Pspell
  • Cargar un nuevo diccionario

pspell_new

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new — Cargar un nuevo diccionario

Descripción

pspell_new ( string $language , string $spelling = ? , string $jargon = ? , string $encoding = ? , int $mode = 0 ) : int

pspell_new() abre un nuevo diccionario y devuelve el identificador de vínculo de diccionario para usarlo en otras funciones pspell.

Para más información y ejemplos, verifique el sitio web de pspell del manual en línea:» http://aspell.net/.

Parámetros

language

El parámetro language es el código de lenguaje que consiste en el código de lenguaje ISO 639 de dos letras y un código de país ISO 3166 de dos letras opcional después de un guión o guión de subrayado.

spelling

El parámetro spelling es la ortografía solicitada para lenguajes con más de una ortografía, como el inglés. Valores conocidos son 'american', 'british', y 'canadian'.

jargon

El parámetro jargon contiene información extra para distinguir dos listas de palabras diferentes que tienen el mismo lenguaje y parámetros de ortografía.

encoding

El parámetro encoding es la codificación que se espera que tengan esas palabras. Los valores válidos son 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. Este parámetro no está en gran parte comprobado, por lo que, tenga cuidado al usarlo.

mode

El parámetro mode es el modo en el que trabajará el corrector ortográfico. Hay varios modos disponibles:

  • PSPELL_FAST - Modo rápido (menor númeo de sugerencias)
  • PSPELL_NORMAL - Modo normal (más sugerencias)
  • PSPELL_BAD_SPELLERS - Modo lento (un montón de sugerencias)
  • PSPELL_RUN_TOGETHER - Considerar palabras unidas como compuestos legales. Es decir, "elgao" será un compuesto legal, aunque debería haber un espacio entre las dos palabras. Cambiar esta configuración solo afecta a los resultados devueltos por pspell_check(); pspell_suggest() seguirá devolviendo sugerencias.
El modo es una máscara de bits construida a partir de diferentes constantes antes listadas. Sin embargo, PSPELL_FAST, PSPELL_NORMAL y PSPELL_BAD_SPELLERS son mutuamente exclusivas, por lo que debería seleccionar únicamente una de ellas.

Valores devueltos

Devuelve el identificador de vínculo de diccionario en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_new()

<?php
$pspell_link = pspell_new("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));
?>


Guardar la lista de palabras personal a un fichero

  • « pspell_new
  • pspell_store_replacement »
  • PHP Manual
  • Funciones de Pspell
  • Guardar la lista de palabras personal a un fichero

pspell_save_wordlist

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_save_wordlist — Guardar la lista de palabras personal a un fichero

Descripción

pspell_save_wordlist ( int $dictionary_link ) : bool

pspell_save_wordlist() guarda la lista personal de palabras de la sesión actual. La ubicación de ficheros a guardar se especifica con pspell_config_personal() y (opcionalmente) pspell_config_repl().

Parámetros

dictionary_link

Un identificador de vínculo a un diccionario abierto con pspell_new_personal().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/tmp/dicts/newdict");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Almacenar un par de sustitución de una palabra

  • « pspell_save_wordlist
  • pspell_suggest »
  • PHP Manual
  • Funciones de Pspell
  • Almacenar un par de sustitución de una palabra

pspell_store_replacement

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_store_replacement — Almacenar un par de sustitución de una palabra

Descripción

pspell_store_replacement ( int $dictionary_link , string $misspelled , string $correct ) : bool

pspell_store_replacement() almacena un par de sustitución de una palabra, por lo que esa sustitución puede ser devuelta más tarde por pspell_suggest(). Para ser capaz de tomar ventaja de esta función, se tiene que usar pspell_new_personal() para abrir el diccionario. Para guardar permanentemente el par de sustitución se tiene que usar pspell_config_personal() y pspell_config_repl() para establecer la ruta donde guardar las listas personalizadas de palabras, y después usar pspell_save_wordlist() para escribir los cambios al disco.

Parámetros

dictionary_link

Un idenficador de vínculo de diccionario, abierto con pspell_new_personal()

misspelled

La palabra mal escrita.

correct

La ortografía corregida para la palabra misspelled.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pspell_store_replacement()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);

pspell_store_replacement($pspell_link, $misspelled, $correct);
pspell_save_wordlist($pspell_link);
?>

Notas

Nota:

Esta función no funcionará a menos que tenga pspell .11.2 y aspell .32.5 o posterior.


Sugerir ortografías de una palabra

  • « pspell_store_replacement
  • Recode »
  • PHP Manual
  • Funciones de Pspell
  • Sugerir ortografías de una palabra

pspell_suggest

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_suggest — Sugerir ortografías de una palabra

Descripción

pspell_suggest ( int $dictionary_link , string $word ) : array

pspell_suggest() devuelve un array de posibles ortografías para la palabra dada.

Parámetros

dictionary_link

word

La palabra comprobada.

Valores devueltos

Devuelve un array de posibles ortografías.

Ejemplos

Ejemplo #1 Ejemplo de pspell_suggest()

<?php
$pspell_link = pspell_new("en");

if (!pspell_check($pspell_link, "testt")) {
    $sugerencias = pspell_suggest($pspell_link, "testt");

    foreach ($sugerencias as $sugerencia) {
        echo "Ortografía posible: $sugerencia<br />";
    }
}
?>


GNU Recode

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Recode
    • recode_file — Recodificar de fichero a fichero según la petición de recoficación
    • recode_string — Recodifica un string según una petición de recodificación
    • recode — Alias de recode_string


Introducción

Este módulo contiene un interfaz a la biblioteca GNU Recode. Esta biblioteca convierte ficheros entre varios juegos de caracteres y tipos de codificación. Cuando la conversión no se puede lograr con exactitud, puede que elimine caracteres problemáticos o recurrir a aproximaciones. La biblioteca reconoce o aporta cerca de 150 juegos de carácteres diferentes, y es capaz de convertir ficheros en casi cualquier formato. Están soportados la mayoría de juegos de caracteres » RFC 1345.

Nota: Esta extensión no está disponible en plataformas Windows.


Requerimientos

Se debe tener GNU Recode 3.5 o superior instalado en el sistema. SE puede descargar el paquete desde » http://directory.fsf.org/All_GNU_Packages/recode.html.

Advertencia

La Recode library versión 3.6 añade extraños caracteres detrás de la cadena convertida en ciertas circumstancias. Entonces es más seguro usar Recode v3.5 o alguna de las diferentes alternativas como las extensiones iconv o mbstring.


Instalación

Para poder usar las funciones definidas en este módulo se debe compilar el intérprete PHP usando la opción --with-recode[=DIR].

Advertencia

Quizá se encuentra con problemas en el arranque de PHP al trata de cargar la extensión recode después de cargar cualquier extensión de mysql o imap. Si carga la extensión recode antes de estas extensiones se solucionará el problema. Esto es debido a un problema técnico de que las dos librerias c-client son usadas por imap y recode tiene su propia función hash_lookup() y mysql y recode tienen las dos su propia función hash_insert.

Advertencia

Las extensiones IMAP, recode y YAZ no se pueden usar en conjunto, debido a que ambas utilizan el mismo símbolo interno. Anotación: Yaz 2.0 y versiones superiores no tienen este problema..


  • « Tipos de recursos
  • Funciones de Recode »
  • PHP Manual
  • Recode
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Recode

Tabla de contenidos

  • recode_file — Recodificar de fichero a fichero según la petición de recoficación
  • recode_string — Recodifica un string según una petición de recodificación
  • recode — Alias de recode_string


Recodificar de fichero a fichero según la petición de recoficación

  • « Funciones de Recode
  • recode_string »
  • PHP Manual
  • Funciones de Recode
  • Recodificar de fichero a fichero según la petición de recoficación

recode_file

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode_file — Recodificar de fichero a fichero según la petición de recoficación

Descripción

recode_file ( string $request , resource $input , resource $output ) : bool

Recodifica el fichero señalado por el gestor de ficheros input al fichero señalado por el gestor de ficheros output según la petición de recodificación dada por request.

Parámetros

request

El tipo de solicitud de recodificación deseada

input

Un resource gestor de ficheros local para input

output

Un resource gestor de ficheros local para output

Valores devueltos

Devuelve false, si no se puede cumplir, o de lo contrario true.

Ejemplos

Ejemplo #1 Ejemplo básico de recode_file()

<?php
$input = fopen('input.txt', 'r');
$output = fopen('output.txt', 'w');
recode_file("us..flat", $input, $output);
?>

Notas

Esta función actualmente no procesa gestores de ficheros que señalan a ficheros remotos (URLs). Ambos gestores de ficheros deben señalar a ficheros locales.

Ver también

  • fopen() - Abre un fichero o un URL


Recodifica un string según una petición de recodificación

  • « recode_file
  • recode »
  • PHP Manual
  • Funciones de Recode
  • Recodifica un string según una petición de recodificación

recode_string

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode_string — Recodifica un string según una petición de recodificación

Descripción

recode_string ( string $request , string $string ) : string

Recodifica el string string según la petición de recodificación request.

Parámetros

request

El tipo de solicitud de recodificación deseada

string

El string a recodificar

Valores devueltos

Devuelve el string recodificado o false, si no se pudo realizar la petición de recodificación.

Ejemplos

Ejemplo #1 Ejemplo básico de recode_string()

<?php
echo recode_string("us..flat", "The following character has a diacritical mark: á");
?>

Notas

Una petición de recodificación sencilla podría ser "lat1..iso646-de".

Ver también

  • La documentación de GNU Recode de la instalación para instrucciones detalladas sobre peticiones de recodificación.


Alias de recode_string

  • « recode_string
  • Procesamiento y generación de imágenes »
  • PHP Manual
  • Funciones de Recode
  • Alias de recode_string

recode

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode — Alias de recode_string()

Descripción

Esta función es un alias de: recode_string().


Procesamiento y generación de imágenes

  • Exif — Información de imagen intercambiable
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Exif
  • GD — Procesamiento de imágenes y GD
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de GD e Imágenes
  • Gmagick
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Gmagick — La clase Gmagick
    • GmagickDraw — La clase GmagickDraw
    • GmagickPixel — La clase GmagickPixel
  • ImageMagick — Procesamiento de imágenes (ImageMagick)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Imagick — La clase Imagick
    • ImagickDraw — La clase ImagickDraw
    • ImagickPixel — La clase ImagickPixel
    • ImagickPixelIterator — La clase ImagickPixelIterator
    • ImagickKernel — La clase ImagickKernel


Información de imagen intercambiable

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Exif
    • exif_imagetype — Determinar el tipo de una imagen
    • exif_read_data — Lee las cabeceras EXIF desde un JPEG o un TIFF
    • exif_tagname — Obtener el nombre de la cabecera de un índice
    • exif_thumbnail — Recuperar la miniatura embebida de una imagen TIFF o JPEG
    • read_exif_data — Alias de exif_read_data


Introducción

Con la extensión Exif (siglas en inglés de Exchangeable image information) se puede trabajar con metadatos de imágenes. Por ejemplo, se pueden usar las funciones de exif para leer los metadatos de fotografías tomadas con cámaras digitales, trabajando con la información almacenada en las cabeceras de imágenes JPEG y TIFF.


Requerimientos

PHP debe estar compilado con --enable-exif. PHP no necesita ninguna biblioteca adicional para el módulo exif. Los usuarios de Windows también deben tener la extensión mbstring habilitada.


Instalación

Para habilitar el soporte para exif configure PHP con --enable-exif

Los usuarios de Windows deben habilitar las DLL php_mbstring.dll y php_exif.dll en php.ini. La DLL php_mbstring.dll debe cargarse antes que la DLL php_exif.dll, así que ajuste su php.ini como corresponde.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Exif soporta automáticamente la conversión de codificaciones de caracteres Unicode y JIS de comentarios de usuario cuando el módulo mbstring está disponible. Ésto se realiza primero decodificando el comentario utilizando el conjunto de caracteres especificado. El resultado después es codificado con otro conjunto de caracteres que debería de coincidir con su salida HTTP.

Opciones de configuración de Exif
Nombre | Por defecto | Cambiable | Historial de cambios
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
exif.encode_jis | "" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
exif.decode_jis_intel | "JIS" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

exif.encode_unicode string

exif.encode_unicode define el conjunto de caracteres UNICODE de los comentarios de usuario que se están tratando. Por defecto es ISO-8859-15 lo que debería funcionar para la mayoría de los países no asiáticos. La configuración puede estar vacía o debe ser una codificacion soportada por mbstring. Si está vacía se usa la codificación interna actual de mbstring.

exif.decode_unicode_motorola string

exif.decode_unicode_motorola define el conjunto de caracteres interno de la imagen para comentarios de usuario codificados con Unicode si la imagen está con el orden de byte de motorola (big-endian). Esta configuración no puede estar vacía pero puede especificar una lista de codificaciones soportadas por mbstring. El valor por defecto es UCS-2BE.

exif.decode_unicode_intel string

exif.decode_unicode_intel define el conjunto de caracteres interno de la imagen para comentarios de usuario codificados con Unicode si la imagen está con el orden de byte de intel (little-endian). Esta configuración no puede estar vacía pero puede especificar una lista de codificaciones soportadas por mbstring. El valor por defecto es UCS-2LE.

exif.encode_jis string

exif.encode_jis define el conjunto de caracteres JIS de los comentarios de usuario que se están tratando. Por defecto está vacía lo que fuerza a las funciones a usar la codificación interna actual de mbstring.

exif.decode_jis_motorola string

exif.decode_jis_motorola define el conjunto de caracteres interno de la imagen para los comentarios de usuario codificados con JIS si la imagen está con el orden de byte de motorola (big-endian). Esta configuración no puede estar vacía pero puede especificar una lista de codificaciones soportadas por mbstring. El valor por defecto es JIS.

exif.decode_jis_intel string

exif.decode_jis_intel define el conjunto de caracteres interno de la imagen para los comentarios de usuario codificados con JIS si la imagen está con el orden de byte de intel (little-endian). Esta configuración no puede estar vacía pero puede especificar una lista de codificaciones soportadas por mbstring. El valor por defecto es JIS.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

EXIF_USE_MBSTRING (integer)

La función exif_imagetype() enumera varias constantes incluidas relacionadas.


Funciones de Exif

Tabla de contenidos

  • exif_imagetype — Determinar el tipo de una imagen
  • exif_read_data — Lee las cabeceras EXIF desde un JPEG o un TIFF
  • exif_tagname — Obtener el nombre de la cabecera de un índice
  • exif_thumbnail — Recuperar la miniatura embebida de una imagen TIFF o JPEG
  • read_exif_data — Alias de exif_read_data


Determinar el tipo de una imagen

  • « Funciones de Exif
  • exif_read_data »
  • PHP Manual
  • Funciones de Exif
  • Determinar el tipo de una imagen

exif_imagetype

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

exif_imagetype — Determinar el tipo de una imagen

Descripción

exif_imagetype ( string $filename ) : int

exif_imagetype() lee los primeros bytes de una imagen y comprueba su firma.

exif_imagetype() se puede usar para evitar llamar a otras funciones exif con tipos de archivos no soportados o junto con $_SERVER['HTTP_ACCEPT'] para verificar si el visionador es capaz o no de ver una imagen específica en el navegador.

Parámetros

filename
La imagen que va a ser comprobada.

Valores devueltos

Cuando se encuentra una firma correcta, se devolverá el valor de la constante apropiada o, de otro modo, el valor devuelto será false. El valor devuelto es el mismo valor que devuelve getimagesize() en el índice 2, pero exif_imagetype() es mucho más rápida.

Nota:

exif_imagetype() emitirá un mensaje E_NOTICE y devolverá false si no es capaz de leer suficientes bytes del archivo como para determinar el tipo de la imagen.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió soporte para iconos.

Constantes predefinidas

Las siguientes constantes están definidas y representan los valores posibles que devuelve exif_imagetype():

Imagetype Constants
Valor | Constante
1 | IMAGETYPE_GIF
2 | IMAGETYPE_JPEG
3 | IMAGETYPE_PNG
4 | IMAGETYPE_SWF
5 | IMAGETYPE_PSD
6 | IMAGETYPE_BMP
7 | IMAGETYPE_TIFF_II (orden de byte intel)
8 | IMAGETYPE_TIFF_MM (orden de byte motorola)
9 | IMAGETYPE_JPC
10 | IMAGETYPE_JP2
11 | IMAGETYPE_JPX
12 | IMAGETYPE_JB2
13 | IMAGETYPE_SWC
14 | IMAGETYPE_IFF
15 | IMAGETYPE_WBMP
16 | IMAGETYPE_XBM
17 | IMAGETYPE_ICO

Ejemplos

Ejemplo #1 Ejemplo de exif_imagetype()

<?php
if (exif_imagetype('imagen.gif') != IMAGETYPE_GIF) {
    echo 'La imagen no es gif';
}
?>

Ver también

  • image_type_to_mime_type() - Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
  • getimagesize() - Obtener el tamaño de una imagen


Lee las cabeceras EXIF desde un JPEG o un TIFF

  • « exif_imagetype
  • exif_tagname »
  • PHP Manual
  • Funciones de Exif
  • Lee las cabeceras EXIF desde un JPEG o un TIFF

exif_read_data

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_read_data — Lee las cabeceras EXIF desde un JPEG o un TIFF

Descripción

exif_read_data ( string $filename , string $sections = null , bool $arrays = false , bool $thumbnail = false ) : array

exif_read_data() lee las cabeceras EXIF desde un archivo de imagen JPEG o TIFF. De esta forma se puede leer los meta-datos generados por cámaras digitales.

Las cabeceras EXIF tienden a estar presentes en imágenes JPEG/TIFF generadas por cámaras digitales, pero desafortunadamente cada fabricante de cámaras digitales tiene una idea diferente de cómo etiquetar sus imágenes, por lo que no siempre se puede contar con que una cabecera Exif específica esté presente.

Height y Width son computados de la misma forma que lo hace getimagesize() por lo que sus valores no deben ser parte de ninguna cabecera devuelta. También, html es una cadena de texto de alto/ancho para usar dentro de un HTML normal.

Cuando una cabecera Exif contiene una nota de Copyright, puede contener ella misma dos valores. Como la solución es inconsistente en el estándar Exif 2.10, la sección COMPUTED devolverá las dos entradas Copyright.Photographer y Copyright.Editor mientras que las secciones IFD0 contienen la matriz de bytes con el carácter NULL que divide ambas entradas. O sólo la primera entrada si el tipo de información era erróneo (el comportamiento normal de Exif). COMPUTED también contendrá la entrada Copyright que es la cadena del copyright original, o una lista separada por comas del copyright de la fotografía y del editor.

La etiqueta UserComment tiene el mismo problema que la etiqueta Copyright. Puede almacenar dos valores. El primero es el que usa la codificación, y el segundo es el valor mismo. Por lo que si la sección IFD sólo contiene la codificación o una matriz de bytes, la sección COMPUTED almacenará la dos entradas UserCommentEncoding y UserComment. La entrada UserComment está disponible en ambos casos por lo que se debería usar con preferencia al valor de la sección IFD0.

exif_read_data() también valida las etiquetas de información EXIF según la especifiación EXIF (» http://exif.org/Exif2-2.PDF, página 20).

Nota:

Windows Me/XP pueden borrar las cabeceras Exif cuando se conecta una cámara.

Parámetros

filename

El nombre de la imagen que se va a leer. No puede ser una URL.

sections

Es una lista separada por comas de las secciones que necesitan estar presentes en el archivo para producir un array resultante. Si no se puede encontrar ninguna sección el valor devuelto es false.

FILE | FileName, FileSize, FileDateTime, SectionsFound
COMPUTED | html, Width, Height, IsColor, y más si están disponibles. Height y Width son computados de la misma forma que lo hace getimagesize() por lo que sus valores no deben ser parte de ninguna cabecera devuelta. También, html es una cadena de texto de alto/ancho para usar dentro de un HTML normal.
ANY_TAG | Cualquier información que tenga una Etiqueta, p.ej., IFD0, EXIF, ...
IFD0 | Toda la información etiquetada de IFD0. En archivos de imagen normales, ésto contiene el tamaño de la imagen y así sucesivamente.
THUMBNAIL | Se supone que un archivo contiene una miniatura si tiene un segundo IFD. Toda la información etiquetada acerca de la miniatura embebida es almacenada en esta sección.
COMMENT | Cabeceras de comentarios de imágenes JPEG.
EXIF | La sección EXIF es una subsección de IFD0. Contiene información más detallada sobre la imagen. La mayoría de estas entradas están relacionadas con la cámara digital.

arrays

Especifica si cada sección se convierte o no en una matriz. sections COMPUTED, THUMBNAIL, y COMMENT siempre se convierten en matrices ya que pueden contener valores cuyos nombres entran en conflicto con otras secciones.

thumbnail

Cuando se establece a true se lee la miniatura misma. Si no, sólo se lee la información etiquetada.

Valores devueltos

Devuelve un array asociativo donde los índices de la matriz son los nombres de las cabeceras y los valores de la matriz son los valores asociados con esas cabeceras. Si no se puede devolver información, exif_read_data() devolverá false.

Historial de cambios

Versión | Descripción
4.3.0 | Se puede leer toda la información IFD embebida incluidas matrices (devueltas como tales). También, el tamaño de una miniatura embebida es devuelto en una submatriz THUMBNAIL, y puede devolver miniaturas en formato TIFF. Además, ya no hay una longitud máxima para los valores devueltos (no mientras el límite de memoria haya sido alcanzado)
4.3.0 | Si PHP tiene soporte para mbstring, el comentario de usuario puede cambiar automáticamente de codificación. También, si el comentario de usuario utiliza la codificación Unicode o JIS, esta codificación será cambiada automáticamente según la configuración inicial de exif en php.ini
4.3.0 | Si la imagen contiene cualquier información IFD0, entonces COMPUTED contiene la entrada ByteOrderMotorola la cuál es 0 para el orden de byte little-endian (intel) y 1 para el orden de byte big-endian (motorola). También, COMPUTED y UserComment ya no contienen la primera entrada de copyright si el tipo de información era erróneo.

Ejemplos

Ejemplo #1 Ejemplo de exif_read_data()

<?php
echo "prueba1.jpg:<br />\n";
$exif = exif_read_data('pruebas/prueba1.jpg', 'IFD0');
echo $exif===false ? "No se encontró información de cabecera.<br />\n" : "La imagen contiene cabeceras<br />\n";

$exif = exif_read_data('pruebas/prueba2.jpg', 0, true);
echo "prueba2.jpg:<br />\n";
foreach ($exif as $clave => $sección) {
    foreach ($sección as $nombre => $valor) {
        echo "$clave.$nombre: $valor<br />\n";
    }
}
?>

La primera llamada falla ya que la imagen no tiene información de cabecera.

El resultado del ejemplo sería algo similar a:

test1.jpg:
No header data found.
test2.jpg:
FILE.FileName: test2.jpg
FILE.FileDateTime: 1017666176
FILE.FileSize: 1240
FILE.FileType: 2
FILE.SectionsFound: ANY_TAG, IFD0, THUMBNAIL, COMMENT
COMPUTED.html: width="1" height="1"
COMPUTED.Height: 1
COMPUTED.Width: 1
COMPUTED.IsColor: 1
COMPUTED.ByteOrderMotorola: 1
COMPUTED.UserComment: Exif test image.
COMPUTED.UserCommentEncoding: ASCII
COMPUTED.Copyright: Photo (c) M.Boerger, Edited by M.Boerger.
COMPUTED.Copyright.Photographer: Photo (c) M.Boerger
COMPUTED.Copyright.Editor: Edited by M.Boerger.
IFD0.Copyright: Photo (c) M.Boerger
IFD0.UserComment: ASCII
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.JPEGInterchangeFormatLength: 523
COMMENT.0: Comment #1.
COMMENT.1: Comment #2.
COMMENT.2: Comment #3end
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.Thumbnail.Height: 1
THUMBNAIL.Thumbnail.Height: 1

Ver también

  • exif_thumbnail() - Recuperar la miniatura embebida de una imagen TIFF o JPEG
  • getimagesize() - Obtener el tamaño de una imagen


Obtener el nombre de la cabecera de un índice

  • « exif_read_data
  • exif_thumbnail »
  • PHP Manual
  • Funciones de Exif
  • Obtener el nombre de la cabecera de un índice

exif_tagname

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_tagname — Obtener el nombre de la cabecera de un índice

Descripción

exif_tagname ( int $index ) : string

Parámetros

index

La etiqueta ID correspondiente a la etiqueta Name que examinará.

Valores devueltos

Devuelve el nombre de la cabecera, o false si index no está definido con un identificador de etiqueta EXIF.

Ejemplos

Ejemplo #1 Ejemplo exif_tagname()

<?php
echo "256: ".exif_tagname(256).PHP_EOL;
echo "257: ".exif_tagname(257).PHP_EOL;
?>

El resultado del ejemplo sería:

256: ImageWidth
257: ImageLength

Ver también

  • exif_imagetype() - Determinar el tipo de una imagen
  • » Especificación EXIF
  • » Etiquetas EXIF


Recuperar la miniatura embebida de una imagen TIFF o JPEG

  • « exif_tagname
  • read_exif_data »
  • PHP Manual
  • Funciones de Exif
  • Recuperar la miniatura embebida de una imagen TIFF o JPEG

exif_thumbnail

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_thumbnail — Recuperar la miniatura embebida de una imagen TIFF o JPEG

Descripción

exif_thumbnail ( string $filename , int &$width = ? , int &$height = ? , int &$imagetype = ? ) : string

exif_thumbnail() lee la miniatura embebida de una imagen TIFF o JPEG.

Si quiere implementar miniaturas mediante esta función, debería enviar la información del tipo mime usando la función header().

Es posible que exif_thumbnail() no pueda crear una imagen pero puede determinar su tamaño. En este caso, el valor devuelto es false pero width y height son establecidos.

Parámetros

filename

El nombre de la imagen que va a ser leída. Esta imagen contiene una miniatura embebida.

width

El ancho devuelto de la miniatura devuelta.

height

El alto devuelto de la miniatura devuelta.

imagetype

El tipo de imagen devuelto de la miniatura devuelta. Puede ser TIFF o JPEG.

Valores devueltos

Devuelve la miniatura embebida, o false si la imagen no contiene ninguna miniatura.

Ejemplos

Ejemplo #1 Ejemplo de exif_thumbnail()

<?php
if (array_key_exists('file', $_REQUEST)) {
    $imagen = exif_thumbnail($_REQUEST['file'], $width, $height, $type);
} else {
    $imagen = false;
}
if ($imagen!==false) {
    header('Content-type: ' .image_type_to_mime_type($type));
    echo $imagen;
    exit;
} else {
    // no está disponible la miniatura, tratar el error aquí
    echo 'No está disponible la miniatura';
}
?>

Ver también

  • exif_read_data() - Lee las cabeceras EXIF desde un JPEG o un TIFF
  • image_type_to_mime_type() - Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype


Alias de exif_read_data

  • « exif_thumbnail
  • GD »
  • PHP Manual
  • Funciones de Exif
  • Alias de exif_read_data

read_exif_data

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

read_exif_data — Alias de exif_read_data()

Descripción

Esta función es un alias de: exif_read_data().


Procesamiento de imágenes y GD

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Creación de un PNG con PHP
    • Añadir marcas de agua a imágenes usando canales alfa
    • Usar imagecopymerge para crear una marca de agua translúcida
  • Funciones de GD e Imágenes
    • gd_info — Reunir información acerca de la biblioteca GD instalada actualmente
    • getimagesize — Obtener el tamaño de una imagen
    • getimagesizefromstring — Obtener el tamaño de una imagen desde una cadena
    • image_type_to_extension — Obtiene la extensión de un tipo de imagen
    • image_type_to_mime_type — Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
    • image2wbmp — Exportar la imagen al navegador o a un fichero
    • imageaffine — Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional
    • imageaffinematrixconcat — Concatena dos matrices (como al hacer muchas opciones de una vez)
    • imageaffinematrixget — Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional
    • imagealphablending — Establece el modo de mezcla para una imagen
    • imageantialias — Permitir o no el uso de funciones antialias
    • imagearc — Dibujar un arco
    • imagebmp — Output a BMP image to browser or file
    • imagechar — Dibujar un carácter horizontalmente
    • imagecharup — Dibujar un carácter verticalmente
    • imagecolorallocate — Asigna un color para una imagen
    • imagecolorallocatealpha — Asignar un color para una imagen
    • imagecolorat — Obtener el índice del color de un píxel
    • imagecolorclosest — Obtener el índice del color más próximo al color especificado
    • imagecolorclosestalpha — Obtener el índice del color más próximo al color + alpha especificado
    • imagecolorclosesthwb — Obtener el índice del color que tiene el tono, blancura y negrura
    • imagecolordeallocate — Desasignar un color de una imagen
    • imagecolorexact — Obtener el índice del color especificado
    • imagecolorexactalpha — Obtener el índice del color + alpha especificado
    • imagecolormatch — Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero
    • imagecolorresolve — Obtener el índice del color especificado o su alternativa más próxima posible
    • imagecolorresolvealpha — Obtener el índice del color + alpha especificado o su alternativa más próxima posible
    • imagecolorset — Establecer el color para el índice de paleta especificada
    • imagecolorsforindex — Obtener los colores de un índice
    • imagecolorstotal — Averiguar el número de colores de la paleta de una imagen
    • imagecolortransparent — Definir un color como transparente
    • imageconvolution — Aplicar una matriz de convolución de 3x3, usando coeficiente e índice
    • imagecopy — Copiar parte de una imagen
    • imagecopymerge — Copiar y fusionar parte de una imagen
    • imagecopymergegray — Copiar y fusionar parte de una imagen con escala de grises
    • imagecopyresampled — Copia y cambia el tamaño de parte de una imagen redimensionándola
    • imagecopyresized — Copia y cambia el tamaño de parte de una imagen
    • imagecreate — Crea una nueva imagen basada en paleta
    • imagecreatefrombmp — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromgd2 — Crear una imagen nueva desde un fichero GD2 o un URL
    • imagecreatefromgd2part — Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL
    • imagecreatefromgd — Crear una imagen nueva desde un fichero GD o un URL
    • imagecreatefromgif — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromjpeg — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefrompng — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromstring — Crear una imagen nueva desde el flujo de imagen de la cadena
    • imagecreatefromwbmp — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromwebp — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromxbm — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromxpm — Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatetruecolor — Crear una nueva imagen de color verdadero
    • imagecrop — Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados
    • imagecropauto — Recorta una imagen automáticamente usando uno de los modos disponibles
    • imagedashedline — Dibujar una línea discontinua
    • imagedestroy — Destruir una imagen
    • imageellipse — Dibujar una elipse
    • imagefill — Rellenar
    • imagefilledarc — Dibujar un arco parcial y rellenarlo
    • imagefilledellipse — Dibujar una elipse con relleno
    • imagefilledpolygon — Dibujar un polígono con relleno
    • imagefilledrectangle — Dibujar un rectángulo con relleno
    • imagefilltoborder — Rellenar con un color específico
    • imagefilter — Aplica un filtro a una imagen
    • imageflip — Flips an image using a given mode
    • imagefontheight — Obtener el alto de la fuente
    • imagefontwidth — Obtener el ancho de la fuente
    • imageftbbox — Devolver la caja circundante de un texto usando fuentes mediante FreeType 2
    • imagefttext — Escribir texto en la imagen usando fuentes mediante FreeType 2
    • imagegammacorrect — Aplicar una corrección gamma a la imagen GD
    • imagegd2 — Imprime una imagen GD2 a un navegador o fichero
    • imagegd — Imprime una imagen GD2 a un navegador o archivo
    • imagegetclip — Get the clipping rectangle
    • imagegetinterpolation — Get the interpolation method
    • imagegif — Exportar la imagen al navegador o a un fichero
    • imagegrabscreen — Capturar la pantalla completa
    • imagegrabwindow — Capturar una ventana
    • imageinterlace — Habilitar o deshabilitar en entrelazamiento
    • imageistruecolor — Averiguar si una imagen es de color verdadero
    • imagejpeg — Exportar la imagen al navegador o a un fichero
    • imagelayereffect — Establecer la bandera de mezcla alfa para usar los efectos de capa
    • imageline — Dibujar una línea
    • imageloadfont — Cargar una nueva fuente
    • imageopenpolygon — Draws an open polygon
    • imagepalettecopy — Copiar la paleta de una imagen a otra
    • imagepalettetotruecolor — Convierte una imagen basada en paleta a color verdadero
    • imagepng — Imprimir una imagen PNG al navegador o a un archivo
    • imagepolygon — Dibujar un polígono
    • imagerectangle — Dibuja un rectángulo
    • imageresolution — Get or set the resolution of the image
    • imagerotate — Rotar una imagen con un ángulo dado
    • imagesavealpha — Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG
    • imagescale — Redimensiona una imagen usando un nuevo ancho y alto
    • imagesetbrush — Establecer la imagen de pincel para el dibujo de líneas
    • imagesetclip — Set the clipping rectangle
    • imagesetinterpolation — Establecer el método de interpolación
    • imagesetpixel — Establecer un simple píxel
    • imagesetstyle — Establecer el estilo para el dibujo de líneas
    • imagesetthickness — Establecer el grosor para el dibujo de líneas
    • imagesettile — Establecer la imagen de tesela para rellenos
    • imagestring — Dibujar una cadena horizontalmente
    • imagestringup — Dibujar una cadena verticalmente
    • imagesx — Obtener el ancho de una imagen
    • imagesy — Obtener el alto de una imagen
    • imagetruecolortopalette — Convertir una imagen de color verdadero en una imagen de paleta
    • imagettfbbox — Devuelve la caja circundante de un texto usando fuentes TrueType
    • imagettftext — Escribir texto en la imagen usando fuentes TrueType
    • imagetypes — Devolver los tipos de imagen soportados por la versión actual de PHP
    • imagewbmp — Exportar la imagen al navegador o a un fichero
    • imagewebp — Imprimir una imagen WebP al navegador o fichero
    • imagexbm — Imprimir una imagen XBM en el navegador o en un fichero
    • iptcembed — Incluir información IPTC binaria en una imagen JPEG
    • iptcparse — Conviertir un bloque IPTC binario en simples etiquetas
    • jpeg2wbmp — Convertir un archiov de imagen JPEG a un archivo de imagen WBMP
    • png2wbmp — Convertir un archivo de imagen PNG a un archivo de imagen WBMP


Introducción

PHP no está limitado a crear únicamente salidas HTML. También se puede usar para crear y manipular ficheros de imágenes en una variedad de diferentes formatos de imagen, incluyendo GIF, PNG, JPEG, WBMP y XPM. Aún más práctico es que PHP puede transferir flujos de imagen directamente al navegador. Necesitará compilar PHP con la biblioteca de funciones de imágenes GD para que esto funcione. GD y PHP también pueden requierir otras bibliotecas, dependiendo de los formatos de imagen con los que se quiera trabajar.

Se pueden usar las funciones de imagen de PHP para obtener el tamaño de imágenes JPEG, GIF, PNG, SWF, TIFF y JPEG2000.

Con la extensión exif, se puede trabajar con infomación almacenada en cabeceras de imágenes JPEG y TIFF. De esta manera se pueden leer metadatos generados por cámaras digitales. Las funciones de exif no requieren la biblioteca GD.

Nota: Lea la sección de requisitos sobre cómo expandir las capacidades para leer, escribir y modificar imágenes. Para leer metadatos de fotografías tomadas con cámaras digitales se necesita la extensión exif mencionada arriba.

Nota: La función getimagesize() no requiere la extensión GD.

GD admite variedad de formatos. Abajo se muestra una lista de los formatos soportados por GD y las observaciones sobre su disponibilidad incluyendo el soporte para lectura/escritura.

Formatos admitidos por GD
Formato | Soporte para lectura | Soporte para escritura | Observaciones
JPEG | true | true |
PNG | true | true |
GIF | true | true | Disponible a partir de GD 2.0.28 y PHP 5.0.1
XBM | true | true |
XPM | true | false | Soporte para lectura disponible en Windows a partir de PHP 5.3.19
WBMP | true | true |
WebP | true | true | PHP 5.5+

A pesar de que la mayoría de los formatos están disponibles tanto para lectura como para escritura en la tabla de arriba, esto no significa que PHP fuera compilado con soporta para ellos. Para averiguar qué formatos estaban disponibles al compilar GD, use la función gd_info(); para más información sobre el soporte de compilación para uno o más formatos, véase el capítulo de instalación.


Requerimientos

Si tiene la biblioteca GD (disponible en » http://www.libgd.org/) también será capaz de crear y manipular imágenes.

El formato de las imágenes que se pueden manipular depende de la versión de GD que se instale, y se podría necesitar otra biblioteca GD para acceder a esos formatos de imagen. El soporte para GIF está disponible a partir de gd-2.0.28.

Nota: A partir de PHP 5.0, se requiere libgd-2.0.4 o superior higher. A partir de PHP 5.5, se requiere libgd-2.1.0 o superior. Alternativamente se puede usar la bibiioteca GD intgegrada que viene con PHP.

Puede querer mejorar GD para tratar más formatos de imagen.

Formatos de imagen soportados
Formato de imagen | Biblioteca para descargar | Anotaciones
gif |  | Solamente admitido en versiones de GD superior a la gd-2.0.28. El soporte para escritura está disponible a paritr de PHP 5.0.1.
jpeg | » http://www.ijg.org/ | Cuando se construye la biblioteca jpeg (antes de construir PHP) se debe usar la opción --enable-shared en la fase de configuración. Si no se hace, se recibirá un error diciendo libjpeg.(a|so) not found cuando esté en la fase de configuración de la construcción de PHP.
png | » http://www.libpng.org/pub/png/libpng.html |
xpm | » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html | Lo más probable es que esta biblioteca esté ya disponible si su sistema tiene instalado un X-Environment.

Puede querer mejorar GD para tratar con diferentes fuentes. Las siguientes bibliotecas de fuentes están soportadas:

Bibliotecas de fuentes soportadas
Biblioteca de fuentes | Descarga | Anotaciones
FreeType 1.x | » http://www.freetype.org/ | Esta característica obsoleta será eliminada con certeza en el futuro.
FreeType 2 | » http://www.freetype.org/ |
T1lib | » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) | Soporte para fuentes Postscript Type 1. (Eliminada a partir de PHP 7.0.0).


Instalación

Para habilitar el soporte para GD configure PHP con --with-gd[=DIR], donde DIR es el directorio de instalación base de GD. Para usar la versión de la biblioteca GD integrada recomendada use la opción de configuración --with-gd. La biblioteca GD requiere libpng y libjpeg para compilarse.

En Windows, incluirá la DLL GD2 php_gd2.dll como una extensión en php.ini.

Mejore las capacidades de GD para manejar más formatos de imagen especificando la opción de configuración --with-XXXX en la línea de configuración de PHP.

Formatos de imagen soportados
Formato de Imagen | Opción de Configuración
jpeg | Para habilitar el suporte para jpeg añadir --with-jpeg-dir=DIR. Jpeg 6b, 7 o 8 están soportados.
png | Para habilitar el soporte para png añada --with-png-dir=DIR. Nota, libpng requiere la biblioteca zlib, por lo tanto añada --with-zlib-dir[=DIR] a la línea de configuración.
xpm | Para habilitar el soporte para xpm añada --with-xpm-dir=DIR. Si la configuración no es capaz de encontrar las bibliotecas requeridas, se puede añadir la ruta a las bibliotecas X11.
webp | Para habilitar el soorte para webp añada --with-vpx-dir=DIR. Disponible a partri de PHP 5.5. A partir de PHP 7.0.0 se ha añadido --with-webp-dir=DIR, es decir, el soporte para libvpx se ha eliminado en favor de libwebp.

Nota: Cuando se compila PHP con libpng, se debe usar la misma versión que fue enlazada con la biblioteca GD.

Mejore las capacidades de GD para tratar con difenrentes fuentes especificando la opción de configuración --with-XXXX en la línea de configuración de PHP.

Bibliotecas de fuentes soportadas
Biblioteca de fuentes | Opción de configuración
FreeType 2 | Para habilitar el soporte para FreeType 2 añada --with-freetype-dir=DIR.
T1lib | Para habilitar el soporte para T1lib (fuentes Postscript Type 1) añada --with-t1lib[=DIR]. (Eliminada a partir de PHP 7.0.0).
Función de cadena TrueType nativa | Para habilitar el soporte para la función de cadena TrueType nativa añada --enable-gd-native-ttf.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Imagen
Nombre | Por defecto | Cambiable | Registro de cambios
gd.jpeg_ignore_warning | "1" | PHP_INI_ALL | Disponible a partir de PHP 5.1.3.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

gd.jpeg_ignore_warning bool

Ignora las advertencias creadas por jpeg2wbmp() y por imagecreatefromjpeg()

Registro de cambios para gd.jpeg_ignore_warning
Versión | Descripción
7.1.0 | El valor predeterminado de gd.jpeg_ignore_warning ha cambiado de 0 a 1.

Vea también las directivas de configuración de exif.

Advertencia

Las funciones de imagen consumen mucha memoria. Asegúrese de establecer memory_limit con un valor bastante alto.


Tipos de recursos

Esta extensió define los siguientes tipos de recursos:

Lista de tipos de recursos en GD
Nombre | Descripción | Notas
gd | Recurso de imagen, empleado por funciones como imagecreatefrompng() |
gd font | Recurso de fuente devuelto por imageloadfont() |
gd PS font | Recurso de fuente de PostScript Tipo 1, devuelto por imagepsloadfont() | Eliminado a partir de PHP 7.0.0.
gd PS encoding | Recurso de codificación de PostScript Tipo 1, devuelto por imagepsencodefont() | Eliminado a partir de PHP 7.0.0.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

GD_VERSION (string)
La versión de GD que fue compilada en PHP. (Disponible a partir de PHP 5.2.4)
GD_MAJOR_VERSION (integer)
La versión mayor de GD que fue compilada en PHP. (Disponible a partir de PHP 5.2.4)
GD_MINOR_VERSION (integer)
La versión menor de GD que fue compilada en PHP. (Disponible a partir de PHP 5.2.4)
GD_RELEASE_VERSION (integer)
La versión de distribución de GD que fue compilada en PHP. (Disponible a partir de PHP 5.2.4)
GD_EXTRA_VERSION (string)
La versión "extra" (beta/rc..) de GD que fue compilada en PHP. (Disponible a partir de PHP 5.2.4)
GD_BUNDLED (integer)
Cuando se usa la versión incluida de GD, esto es 1, de otro modo se establece a 0.
IMG_BMP (integer)
Utilizada como valor devuelto por imagetypes()
IMG_GIF (integer)
Utilizada como valor devuelto por imagetypes()
IMG_JPG (integer)
Utilizada como valor devuelto por imagetypes()
IMG_JPEG (integer)
Utilizada como valor devuelto por imagetypes()

Nota:

Esta constante tiene el mismo valor que IMG_JPG

IMG_PNG (integer)
Utilizada como valor devuelto por imagetypes()
IMG_WBMP (integer)
Utilizada como valor devuelto por imagetypes()
IMG_XPM (integer)
Utilizada como valor devuelto por imagetypes()
IMG_WEBP (integer)
Utilizada como valor devuelto por imagetypes() Disponilbe a paritr de PHP 5.6.25 y PHP 7.0.10, respectivamente.
IMG_COLOR_TILED (integer)
Opción de color especial que se puede usar en lugar de un color asignado con imagecolorallocate() o imagecolorallocatealpha().
IMG_COLOR_STYLED (integer)
Opción de color especial que se puede usar en lugar de un color asignado con imagecolorallocate() o imagecolorallocatealpha().
IMG_COLOR_BRUSHED (integer)
Opción de color especial que se puede usar en lugar de un color asignado con imagecolorallocate() o imagecolorallocatealpha().
IMG_COLOR_STYLEDBRUSHED (integer)
Opción de color especial que se puede usar en lugar de un color asignado con imagecolorallocate() o imagecolorallocatealpha().
IMG_COLOR_TRANSPARENT (integer)
Opción de color especial que se puede usar en lugar de un color asignado con imagecolorallocate() o imagecolorallocatealpha().
IMG_AFFINE_TRANSLATE (integer)
Una constante de tipo de transformación afín usada por la función imageaffinematrixget().
IMG_AFFINE_SCALE (integer)
Una constante de tipo de transformación afín usada por la función imageaffinematrixget().
IMG_AFFINE_ROTATE (integer)
Una constante de tipo de transformación afín usada por la función imageaffinematrixget().
IMG_AFFINE_SHEAR_HORIZONTAL (integer)
Una constante de tipo de transformación afín usada por la función imageaffinematrixget().
IMG_AFFINE_SHEAR_VERTICAL (integer)
Una constante de tipo de transformación afín usada por la función imageaffinematrixget().
IMG_ARC_ROUNDED (integer)
Una constante de estilo usada por la función imagefilledarc().

Nota:

Esta constante tiene el mismo valor que IMG_ARC_PIE

IMG_ARC_PIE (integer)
Una constante de estilo usada por la función imagefilledarc().
IMG_ARC_CHORD (integer)
Una constante de estilo usada por la función imagefilledarc().
IMG_ARC_NOFILL (integer)
Una constante de estilo usada por la función imagefilledarc().
IMG_ARC_EDGED (integer)
Una constante de estilo usada por la función imagefilledarc().
IMG_GD2_RAW (integer)
Una constante de tipo usada por la función imagegd2().
IMG_GD2_COMPRESSED (integer)
Una constante de tipo usada por la función imagegd2().
IMG_EFFECT_REPLACE (integer)
Efecto de mezcla de alpahusada por la función imagelayereffect().
IMG_EFFECT_ALPHABLEND (integer)
Efecto de mezcla de alpahusada por la función imagelayereffect().
IMG_EFFECT_NORMAL (integer)
Efecto de mezcla de alpahusada por la función imagelayereffect().
IMG_EFFECT_OVERLAY (integer)
Efecto de mezcla de alpahusada por la función imagelayereffect().
IMG_EFFECT_MULTIPLY (integer)
Efecto de mezcla de alpahusada por la función imagelayereffect().
IMG_FILTER_NEGATE (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_GRAYSCALE (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_BRIGHTNESS (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_CONTRAST (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_COLORIZE (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_EDGEDETECT (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_GAUSSIAN_BLUR (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_SELECTIVE_BLUR (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_EMBOSS (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_MEAN_REMOVAL (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_SMOOTH (integer)
Filtro de GD especialusada por la función imagefilter().
IMG_FILTER_PIXELATE (integer)
Filtro de GD especialusada por la función imagefilter(). (Disponible a partir de PHP 5.3.0)
IMAGETYPE_GIF (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JPEG (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JPEG2000 (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_PNG (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_SWF (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_PSD (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_BMP (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_WBMP (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_XBM (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_TIFF_II (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_TIFF_MM (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_IFF (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JB2 (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JPC (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JP2 (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_JPX (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_SWC (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension().
IMAGETYPE_ICO (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension(). (Disponible a partir de PHP 5.3.0)
IMAGETYPE_WEBP (integer)
Constante de tipo de imagen usada por las funciones image_type_to_mime_type() y image_type_to_extension(). (Disponible a partir de PHP 7.1.0)
PNG_NO_FILTER (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_FILTER_NONE (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_FILTER_SUB (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_FILTER_UP (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_FILTER_AVG (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_FILTER_PAETH (integer)
Un filtro PNG especial usada por la función imagepng().
PNG_ALL_FILTERS (integer)
Un filtro PNG especial usada por la función imagepng().
IMG_FLIP_VERTICAL (int)
Utilizada junto con imageflip(), disponible a partir de PHP 5.5.0.
IMG_FLIP_HORIZONTAL (int)
Utilizada junto con imageflip(), disponible a partir de PHP 5.5.0.
IMG_FLIP_BOTH (int)
Utilizada junto con imageflip(), disponible a partir de PHP 5.5.0.
IMG_BELL (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BESSEL (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BILINEAR_FIXED (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BICUBIC (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BICUBIC_FIXED (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BLACKMAN (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BOX (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_BSPLINE (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_CATMULLROM (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_GAUSSIAN (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_GENERALIZED_CUBIC (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_HERMITE (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_HAMMING (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_HANNING (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_MITCHELL (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_POWER (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_QUADRATIC (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_SINC (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_NEAREST_NEIGHBOUR (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_WEIGHTED4 (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.
IMG_TRIANGLE (int)
Utilizada junto con imagesetinterpolation(), disponible a partir de PHP 5.5.0.


Ejemplos

Tabla de contenidos

  • Creación de un PNG con PHP
  • Añadir marcas de agua a imágenes usando canales alfa
  • Usar imagecopymerge para crear una marca de agua translúcida


Creación de un PNG con PHP

Ejemplo #1 Creación de un PNG con PHP

<?php

header("Content-type: image/png");
$cadena = $_GET['texto'];
$im     = imagecreatefrompng("images/boton1.png");
$naranja = imagecolorallocate($im, 220, 210, 60);
$px     = (imagesx($im) - 7.5 * strlen($cadena)) / 2;
imagestring($im, 3, $px, 9, $cadena, $naranja);
imagepng($im);
imagedestroy($im);

?>
Este ejemplo sería llamado desde una página con una etiqueta como: <img src="button.php?texto=texto">. El script boton.php de arriba toma esta cadena de "texto" y la sobrepone en la parte superior de una imagen, que en este caso es "images/boton1.png", e imprime la imagen resultante. Esta es una manera muy conveniente de evitar tener que dibujar nuevas imágenes de botones cada vez que se quiera cambiar el texto de un botón. Con este método las imágenes de botones se generan dinámicamente.


Añadir marcas de agua a imágenes usando canales alfa

Ejemplo #1 Añadir marcas de agua a imágenes usando canales alfa

<?php
// Cargar la estampa y la foto para aplicarle la marca de agua
$estampa = imagecreatefrompng('estampa.png');
$im = imagecreatefromjpeg('foto.jpeg');

// Establecer los márgenes para la estampa y obtener el alto/ancho de la imagen de la estampa
$margen_dcho = 10;
$margen_inf = 10;
$sx = imagesx($estampa);
$sy = imagesy($estampa);

// Copiar la imagen de la estampa sobre nuestra foto usando los índices de márgen y el
// ancho de la foto para calcular la posición de la estampa.
imagecopy($im, $estampa, imagesx($im) - $sx - $margen_dcho, imagesy($im) - $sy - $margen_inf, 0, 0, imagesx($estampa), imagesy($estampa));

// Imprimir y liberar memoria
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>
Añadir marcas de agua a imágenes usando canales alfa
Este ejemplo es una manera común de añadir marcas de agua y estampas a fotos y poner el copyright a imágenes. Observe que la presencia de un canal alfa en la imagen de la estampa como en el texto tiene anti-aliasing. Esto se conserva durante la copia.


Usar imagecopymerge para crear una marca de agua translúcida

  • « Añadir marcas de agua a imágenes usando canales alfa
  • Funciones de GD e Imágenes »
  • PHP Manual
  • Ejemplos
  • Usar imagecopymerge para crear una marca de agua translúcida

Usar imagecopymerge() para crear una marca de agua translúcida

Ejemplo #1 Usar imagecopymerge() para crear una marca de agua translúcida

<?php
// Cargar la estampa y la foto para aplicarle la marca de agua
$im = imagecreatefromjpeg('foto.jpeg');

// Primero crearemos nuestra imagen de la estampa manualmente desde GD
$estampa = imagecreatetruecolor(100, 70);
imagefilledrectangle($estampa, 0, 0, 99, 69, 0x0000FF);
imagefilledrectangle($estampa, 9, 9, 90, 60, 0xFFFFFF);
$im = imagecreatefromjpeg('foto.jpeg');
imagestring($estampa, 5, 20, 20, 'libGD', 0x0000FF);
imagestring($estampa, 3, 20, 40, '(c) 2007-9', 0x0000FF);

// Establecer los márgenes para la estampa y obtener el alto/ancho de la imagen de la estampa
$margen_dcho = 10;
$margen_inf = 10;
$sx = imagesx($estampa);
$sy = imagesy($estampa);

// Fusionar la estampa con nuestra foto con una opacidad del 50%
imagecopymerge($im, $estampa, imagesx($im) - $sx - $margen_dcho, imagesy($im) - $sy - $margen_inf, 0, 0, imagesx($estampa), imagesy($estampa), 50);

// Guardar la imagen en un archivo y liberar memoria
imagepng($im, 'foto_estampa.png');
imagedestroy($im);

?>
Usar imagecopymerge() para crear una marca de agua translúcida
Este ejemplo usa imagecopymerge() para fusionar la estampa con la imagen original. Al usar esto, se puede establecer la opacidad de la estampa; en nuestro ejemplo la establecimos al 50% de opacidad. En la práctica, esto sería útil para la protección del copyright como marcas de agua semitransparentes que son difíciles de eliminar, pero que aún permiten ver la imagen.


Funciones de GD e Imágenes

Tabla de contenidos

  • gd_info — Reunir información acerca de la biblioteca GD instalada actualmente
  • getimagesize — Obtener el tamaño de una imagen
  • getimagesizefromstring — Obtener el tamaño de una imagen desde una cadena
  • image_type_to_extension — Obtiene la extensión de un tipo de imagen
  • image_type_to_mime_type — Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
  • image2wbmp — Exportar la imagen al navegador o a un fichero
  • imageaffine — Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional
  • imageaffinematrixconcat — Concatena dos matrices (como al hacer muchas opciones de una vez)
  • imageaffinematrixget — Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional
  • imagealphablending — Establece el modo de mezcla para una imagen
  • imageantialias — Permitir o no el uso de funciones antialias
  • imagearc — Dibujar un arco
  • imagebmp — Output a BMP image to browser or file
  • imagechar — Dibujar un carácter horizontalmente
  • imagecharup — Dibujar un carácter verticalmente
  • imagecolorallocate — Asigna un color para una imagen
  • imagecolorallocatealpha — Asignar un color para una imagen
  • imagecolorat — Obtener el índice del color de un píxel
  • imagecolorclosest — Obtener el índice del color más próximo al color especificado
  • imagecolorclosestalpha — Obtener el índice del color más próximo al color + alpha especificado
  • imagecolorclosesthwb — Obtener el índice del color que tiene el tono, blancura y negrura
  • imagecolordeallocate — Desasignar un color de una imagen
  • imagecolorexact — Obtener el índice del color especificado
  • imagecolorexactalpha — Obtener el índice del color + alpha especificado
  • imagecolormatch — Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero
  • imagecolorresolve — Obtener el índice del color especificado o su alternativa más próxima posible
  • imagecolorresolvealpha — Obtener el índice del color + alpha especificado o su alternativa más próxima posible
  • imagecolorset — Establecer el color para el índice de paleta especificada
  • imagecolorsforindex — Obtener los colores de un índice
  • imagecolorstotal — Averiguar el número de colores de la paleta de una imagen
  • imagecolortransparent — Definir un color como transparente
  • imageconvolution — Aplicar una matriz de convolución de 3x3, usando coeficiente e índice
  • imagecopy — Copiar parte de una imagen
  • imagecopymerge — Copiar y fusionar parte de una imagen
  • imagecopymergegray — Copiar y fusionar parte de una imagen con escala de grises
  • imagecopyresampled — Copia y cambia el tamaño de parte de una imagen redimensionándola
  • imagecopyresized — Copia y cambia el tamaño de parte de una imagen
  • imagecreate — Crea una nueva imagen basada en paleta
  • imagecreatefrombmp — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromgd2 — Crear una imagen nueva desde un fichero GD2 o un URL
  • imagecreatefromgd2part — Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL
  • imagecreatefromgd — Crear una imagen nueva desde un fichero GD o un URL
  • imagecreatefromgif — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromjpeg — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefrompng — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromstring — Crear una imagen nueva desde el flujo de imagen de la cadena
  • imagecreatefromwbmp — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromwebp — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromxbm — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromxpm — Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatetruecolor — Crear una nueva imagen de color verdadero
  • imagecrop — Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados
  • imagecropauto — Recorta una imagen automáticamente usando uno de los modos disponibles
  • imagedashedline — Dibujar una línea discontinua
  • imagedestroy — Destruir una imagen
  • imageellipse — Dibujar una elipse
  • imagefill — Rellenar
  • imagefilledarc — Dibujar un arco parcial y rellenarlo
  • imagefilledellipse — Dibujar una elipse con relleno
  • imagefilledpolygon — Dibujar un polígono con relleno
  • imagefilledrectangle — Dibujar un rectángulo con relleno
  • imagefilltoborder — Rellenar con un color específico
  • imagefilter — Aplica un filtro a una imagen
  • imageflip — Flips an image using a given mode
  • imagefontheight — Obtener el alto de la fuente
  • imagefontwidth — Obtener el ancho de la fuente
  • imageftbbox — Devolver la caja circundante de un texto usando fuentes mediante FreeType 2
  • imagefttext — Escribir texto en la imagen usando fuentes mediante FreeType 2
  • imagegammacorrect — Aplicar una corrección gamma a la imagen GD
  • imagegd2 — Imprime una imagen GD2 a un navegador o fichero
  • imagegd — Imprime una imagen GD2 a un navegador o archivo
  • imagegetclip — Get the clipping rectangle
  • imagegetinterpolation — Get the interpolation method
  • imagegif — Exportar la imagen al navegador o a un fichero
  • imagegrabscreen — Capturar la pantalla completa
  • imagegrabwindow — Capturar una ventana
  • imageinterlace — Habilitar o deshabilitar en entrelazamiento
  • imageistruecolor — Averiguar si una imagen es de color verdadero
  • imagejpeg — Exportar la imagen al navegador o a un fichero
  • imagelayereffect — Establecer la bandera de mezcla alfa para usar los efectos de capa
  • imageline — Dibujar una línea
  • imageloadfont — Cargar una nueva fuente
  • imageopenpolygon — Draws an open polygon
  • imagepalettecopy — Copiar la paleta de una imagen a otra
  • imagepalettetotruecolor — Convierte una imagen basada en paleta a color verdadero
  • imagepng — Imprimir una imagen PNG al navegador o a un archivo
  • imagepolygon — Dibujar un polígono
  • imagerectangle — Dibuja un rectángulo
  • imageresolution — Get or set the resolution of the image
  • imagerotate — Rotar una imagen con un ángulo dado
  • imagesavealpha — Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG
  • imagescale — Redimensiona una imagen usando un nuevo ancho y alto
  • imagesetbrush — Establecer la imagen de pincel para el dibujo de líneas
  • imagesetclip — Set the clipping rectangle
  • imagesetinterpolation — Establecer el método de interpolación
  • imagesetpixel — Establecer un simple píxel
  • imagesetstyle — Establecer el estilo para el dibujo de líneas
  • imagesetthickness — Establecer el grosor para el dibujo de líneas
  • imagesettile — Establecer la imagen de tesela para rellenos
  • imagestring — Dibujar una cadena horizontalmente
  • imagestringup — Dibujar una cadena verticalmente
  • imagesx — Obtener el ancho de una imagen
  • imagesy — Obtener el alto de una imagen
  • imagetruecolortopalette — Convertir una imagen de color verdadero en una imagen de paleta
  • imagettfbbox — Devuelve la caja circundante de un texto usando fuentes TrueType
  • imagettftext — Escribir texto en la imagen usando fuentes TrueType
  • imagetypes — Devolver los tipos de imagen soportados por la versión actual de PHP
  • imagewbmp — Exportar la imagen al navegador o a un fichero
  • imagewebp — Imprimir una imagen WebP al navegador o fichero
  • imagexbm — Imprimir una imagen XBM en el navegador o en un fichero
  • iptcembed — Incluir información IPTC binaria en una imagen JPEG
  • iptcparse — Conviertir un bloque IPTC binario en simples etiquetas
  • jpeg2wbmp — Convertir un archiov de imagen JPEG a un archivo de imagen WBMP
  • png2wbmp — Convertir un archivo de imagen PNG a un archivo de imagen WBMP


Reunir información acerca de la biblioteca GD instalada actualmente

  • « Funciones de GD e Imágenes
  • getimagesize »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Reunir información acerca de la biblioteca GD instalada actualmente

gd_info

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

gd_info — Reunir información acerca de la biblioteca GD instalada actualmente

Descripción

gd_info ( ) : array

Obtiene información acerca de la versión y capacidades de la biblioteca GD instalada.

Valores devueltos

Devuelve un array asociativo.

Elementos del array devuelto por gd_info()
Atributo | Significado
GD Version | valor de tipo string que describe la versión de libgd instalada.
FreeType Support | valor de tipo boolean. true si está instalado el soporte para Freetype.
Freetype Linkage | valor de tipo string que describe la forma en la cual Freetype fue vinculado. Los valores esperados son: 'with freetype', 'with TTF library' y 'with unknown library'. Este elemento sólo estará definido si Freetype Support fue evaluado como true.
T1Lib Support | valor de tipo boolean. true si el soporte para T1Lib está incluido.
GIF Read Support | valor de tipo boolean. true si el soporte para la lectura de imágenes GIF está incluido.
GIF Create Support | valor de tipo boolean. true si el soporte para la creación de imágenes GIF está incluido.
JPEG Support | valor de tipo boolean. true si el soporte para JPEG está incluido.
PNG Support | valor de tipo boolean. true si el soporte para PNG está incluido.
WBMP Support | valor de tipo boolean. true si el soporte para WBMP está incluido.
XBM Support | valor de tipo boolean. true si el soporte para XBM está incluido.
WebP Support | Valor de tipo boolean. true si el soporte para WebP está incluido.

Nota:

Antes de PHP 5.3.0, el atributo JPEG Support se llamaba JPG Support.

Ejemplos

Ejemplo #1 Empleo de gd_info()

<?php
var_dump(gd_info());
?>

El resultado del ejemplo sería algo similar a:

array(10) {
  ["GD Version"]=>
  string(24) "bundled (2.1.0 compatible)"
  ["FreeType Support"]=>
  bool(false)
  ["T1Lib Support"]=>
  bool(false)
  ["GIF Read Support"]=>
  bool(true)
  ["GIF Create Support"]=>
  bool(false)
  ["JPEG Support"]=>
  bool(false)
  ["PNG Support"]=>
  bool(true)
  ["WBMP Support"]=>
  bool(true)
  ["XBM Support"]=>
  bool(false)
  ["WebP Support"]=>
  bool(false)
}

Historial de cambios

Versión | Descripción
5.6.12 | Se añadió WebP Support.
5.3.0 | El atributo JPG Support se renombró a JPEG Support.

Ver también

  • imagepng() - Imprimir una imagen PNG al navegador o a un archivo
  • imagejpeg() - Exportar la imagen al navegador o a un fichero
  • imagegif() - Exportar la imagen al navegador o a un fichero
  • imagewbmp() - Exportar la imagen al navegador o a un fichero
  • imagewebp() - Imprimir una imagen WebP al navegador o fichero
  • imagetypes() - Devolver los tipos de imagen soportados por la versión actual de PHP


Obtener el tamaño de una imagen

  • « gd_info
  • getimagesizefromstring »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el tamaño de una imagen

getimagesize

(PHP 4, PHP 5, PHP 7, PHP 8)

getimagesize — Obtener el tamaño de una imagen

Descripción

getimagesize ( string $filename , array &$imageinfo = ? ) : array

La función getimagesize() determinará el tamaño de un fichero de imagen dado y devolverá las dimensiones junto con el tipo de fichero, una cadena de texto con el alto/ancho para utilizarla dentro una etiqueta IMG de HTML, y el tipo de contenido HTTP correspondiente.

getimagesize() también puede devolver alguna información más con el parámetro imageinfo.

Nota: Observe que JPC y JP2 pueden tener componentes con diferente profundidad de bit. En tal caso, el valor para "bits" es la mayor profundidad de bit encontrada. También, los ficheros JP2 pueden contener múltiples flujos de código JPEG 2000. En este caso, getimagesize() devuelve los valores del primer flujo de código que encuentre en la raíz del fichero.

Nota: La información sobre iconos se recupera desde el icono con la mayor tasa de bit.

Parámetros

filename

Este parámetro especifica el fichero del cual recuperar información. Puede hacer referencia a un fichero local o (si la configuración lo permite) a un fichero remoto usando uno de los flujos soportados.

imageinfo

Este parámetro opcional permite extraer alguna información ampliada del fichero de imagen. Actualmente, devolverá los diferentes marcadores APP de JPG como un array asociativo. Algunos programas usan estos marcadores APP para incluir información de texto en imágenes. Un uso muy común es incluir información » IPTC en el marcador APP13. Se puede usar la función iptcparse() para convertir el marcador binario APP13 en algo que sea legible.

Valores devueltos

Devuelve un array de hasta 7 elementos. No todos los tipos de imagen incluirán los elementos channels y bits.

Los índices 0 y 1 contienen el ancho y el alto de la imagen, respectivamente.

Nota:

Algunos formatos podrían no contener imágenes o contener múltiples imágenes. En estos casos, getimagesize() no será capaz de determinar apropiadamente el tamaño de la imagen. getimagesize() devolverá cero para el ancho y el alto en estos casos.

El índice 2 es una de las constantes IMAGETYPE_XXX que indican el tipo de imagen.

El índice 3 es una cadena de texto con el string correcot height="yyy" width="xxx" que puede ser usada dierectamente en una etiqueta IMG.

mime es el tipo MIME correspondiente de la imagen. Esta información se puede usar para emitir imágenes con la cabecera HTTP Content-type correcta:

Ejemplo #1 getimagesize() y tipos MIME

<?php
$tamaño = getimagesize($nombre_fichero);
$fp = fopen($nombre_fichero, "rb");
if ($tamaño && $fp) {
    header("Content-type: {$tamaño['mime']}");
    fpassthru($fp);
    exit;
} else {
    // error
}
?>

Los channels serán 3 para ímagenes RGB y 4 para ímagenes CMYK.

bits es el número de bits de cada color.

Para algunos tipos de imagen, la presencia de los valores channels y bits pueden ser un poco confusos. Como ejemplo, GIF siempre usa 3 canales por píxel, pero el número de bits por pixel no puede ser calculado para un GIF animado con una tabla de colores global.

En caso de error devuelve false.

Errores/Excepciones

Si el acceso a la imagen filename es imposible, getimagesize() generará un error de nivel E_WARNING. Si se produce un error de lectura, getimagesize() generará un error de nivel E_NOTICE.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el soporte para iconos.
5.2.3 | Los errores de lectura generados por esta función se degradaron desde E_WARNING a E_NOTICE.
4.3.2 | Se añadió el soporte para JPC, JP2, JPX, JB2, XBM y WBMP.
4.3.2 | Se añadió el soporte para JPEG 2000 para el parámetro imageinfo.
4.3.0 | bits y channels están presentes para otro tipo de imágenes también.
4.3.0 | Se añadió el soporte para SWC y IFF.
4.2.0 | Se añadió el soporte para TIFF.
4.0.6 | Se añadió el soporte para BMP y PSD.

Ejemplos

Ejemplo #2 Ejemplo degetimagesize()

<?php
list($ancho, $alto, $tipo, $atributos) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $atributos alt=\"Ejemplo de getimagesize()\" />";
?>

Ejemplo #3 getimagesize (URL)

<?php
$tamaño = getimagesize("http://www.example.com/gifs/logo.gif");

// si el nombre de fichero contiene espacios, codifíquelo apropiadamente
$tamaño = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

Ejemplo #4 getimagesize() devolviendo IPTC

<?php
$tamaño = getimagesize("prueba.jpg", $info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

Notas

Nota:

Esta función no requiere la librería GD image.

Nota:

Esta función requiere que filename sea un fichero de imagen válido. Si se proporciona un fichero que no sea imagen, este podría ser detectado incorrectamente como una imagen y la función devolver como éxito.

No de debe usar getimagesize() para comprobar que una fichero dado es una imagen válida. Use una solución a propósito tal como la extensión Fileinfo en su lugar.

Ver también

  • image_type_to_mime_type() - Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
  • exif_imagetype() - Determinar el tipo de una imagen
  • exif_read_data() - Lee las cabeceras EXIF desde un JPEG o un TIFF
  • exif_thumbnail() - Recuperar la miniatura embebida de una imagen TIFF o JPEG


Obtener el tamaño de una imagen desde una cadena

  • « getimagesize
  • image_type_to_extension »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el tamaño de una imagen desde una cadena

getimagesizefromstring

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

getimagesizefromstring — Obtener el tamaño de una imagen desde una cadena

Descripción

getimagesizefromstring ( string $imagedata , array &$imageinfo = ? ) : array

Idéntica a getimagesize() excepto que getimagesizefromstring() acepta una cadena en vez de un nombre de fichero como primer parámetro.

Véase la documentación de getimagesize() para más detalles sobre cómo funciona esta función.

Parámetros

imagedata

La imformación de imagen, como cadena.

imageinfo

Véase getimagesize().

Valores devueltos

Véase getimagesize().

Ejemplos

Ejemplo #1 Ejemplo de getimagesizefromstring()

<?php
$img = '/path/to/test.png';

// Open as a file
$size_info1 = getimagesize($img);

// Or open as a string
$data       = file_get_contents($img);
$size_info2 = getimagesizefromstring($data);
?>

Ver también

  • getimagesize() - Obtener el tamaño de una imagen


Obtiene la extensión de un tipo de imagen

  • « getimagesizefromstring
  • image_type_to_mime_type »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtiene la extensión de un tipo de imagen

image_type_to_extension

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

image_type_to_extension — Obtiene la extensión de un tipo de imagen

Descripción

image_type_to_extension ( int $imagetype , bool $include_dot = true ) : string

Devuelve la extensión de la constante IMAGETYPE_XXX dada.

Parámetros

imagetype

Una de las constantes IMAGETYPE_XXX.

include_dot

Si le antecede un punto a la extensión. Por defecto es true.

Valores devueltos

Una cadena con la extensión correspondiente al tipo de imagen dado.

Ejemplos

Ejemplo #1 Ejemplo de image_type_to_extension()

<?php
// Crear una instancia de imagen
$im = imagecreatetruecolor(100, 100);

// Guardar imagen
imagepng($im, './prueba' . image_type_to_extension(IMAGETYPE_PNG));
imagedestroy($im);
?>

Notas

Nota:

Esta función no requiere la librería GD image.


Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype

  • « image_type_to_extension
  • image2wbmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype

image_type_to_mime_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

image_type_to_mime_type — Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype

Descripción

image_type_to_mime_type ( int $imagetype ) : string

La función image_type_to_mime_type() determinará el tipo Mime de una constante IMAGETYPE.

Parámetros

imagetype

Una de las constantes IMAGETYPE_XXX.

Valores devueltos

Los valores devueltos son los siguientes

Valores de Constantes Devueltos
imagetype | Valor devuelto
IMAGETYPE_GIF | image/gif
IMAGETYPE_JPEG | image/jpeg
IMAGETYPE_PNG | image/png
IMAGETYPE_SWF | application/x-shockwave-flash
IMAGETYPE_PSD | image/psd
IMAGETYPE_BMP | image/bmp
IMAGETYPE_TIFF_II (orden de byte intel) | image/tiff
IMAGETYPE_TIFF_MM (orden de byte motorola) | image/tiff
IMAGETYPE_JPC | application/octet-stream
IMAGETYPE_JP2 | image/jp2
IMAGETYPE_JPX | application/octet-stream
IMAGETYPE_JB2 | application/octet-stream
IMAGETYPE_SWC | application/x-shockwave-flash
IMAGETYPE_IFF | image/iff
IMAGETYPE_WBMP | image/vnd.wap.wbmp
IMAGETYPE_XBM | image/xbm
IMAGETYPE_ICO | image/vnd.microsoft.icon

Ejemplos

Ejemplo #1 Ejemplo de image_type_to_mime_type()

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

Notas

Nota:

Esta función no requiere la librería GD image.

Ver también

  • getimagesize() - Obtener el tamaño de una imagen
  • exif_imagetype() - Determinar el tipo de una imagen
  • exif_read_data() - Lee las cabeceras EXIF desde un JPEG o un TIFF
  • exif_thumbnail() - Recuperar la miniatura embebida de una imagen TIFF o JPEG


Exportar la imagen al navegador o a un fichero

  • « image_type_to_mime_type
  • imageaffine »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Exportar la imagen al navegador o a un fichero

image2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

image2wbmp — Exportar la imagen al navegador o a un fichero

Descripción

image2wbmp ( resource $image , string $filename = ? , int $threshold = ? ) : bool

image2wbmp() imprime o guarda una versión WBMP de image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

Ruta del fichero guardado. Si no se porporciona, el flujo de imagen sin tratar será impreso directamente.

threshold

El valor del umbral, entre 0 y 255 (inclusive).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de image2wbmp()

<?php
$fichero = 'php.png';
$imagen = imagecreatefrompng($fichero);

header('Content-Type: ' . image_type_to_mime_type(IMAGETYPE_WBMP));
image2wbmp($imagen); // imprime el flujo directamente
imagedestroy($imagen);
?>

Notas

Nota:

El soporte para WBMP está disponible sólamente si PHP se compiló con GD-1.8 o posterior.

Ver también

  • imagewbmp() - Exportar la imagen al navegador o a un fichero


Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional

  • « image2wbmp
  • imageaffinematrixconcat »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional

imageaffine

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffine — Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional

Descripción

imageaffine ( resource $image , array $affine , array $clip = ? ) : resource

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

affine

Array con las claves 0 a 5.

clip

Array con las claves "x", "y", "width" y "height".

Valores devueltos

Devuelve el recurso de imagen afín en caso de éxito o false en caso de error.


Concatena dos matrices (como al hacer muchas opciones de una vez)

  • « imageaffine
  • imageaffinematrixget »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Concatena dos matrices (como al hacer muchas opciones de una vez)

imageaffinematrixconcat

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffinematrixconcat — Concatena dos matrices (como al hacer muchas opciones de una vez)

Descripción

imageaffinematrixconcat ( array $m1 , array $m2 ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

m1

Array con las claves 0 a 5.

m2

Array con las claves 0 a 5.

Valores devueltos

Array con las claves 0 a 5 y valores de tipo float o false en caso de error.


Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional

  • « imageaffinematrixconcat
  • imagealphablending »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional

imageaffinematrixget

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffinematrixget — Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional

Descripción

imageaffinematrixget ( int $type , mixed $options = ? ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

type

Una de las consntates IMG_AFFINE_*.

options

Valores devueltos

Array con las claves 0 a 5 y valores de tipo float o false en caso de error.


Establece el modo de mezcla para una imagen

  • « imageaffinematrixget
  • imageantialias »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establece el modo de mezcla para una imagen

imagealphablending

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagealphablending — Establece el modo de mezcla para una imagen

Descripción

imagealphablending ( resource $image , bool $blendmode ) : bool

imagealphablending() permite dos modos diferentes de dibujar imágenes de color verdadero. En el modo de mezcla, el componente canal alfa del color proporcionado a todas las funciones de dibujo, como imagesetpixel(), determina cuánto se debe permitir que brille el color subyacente a través de los colores de la imagen. Como resultado, gd mezcla automáticamente el color existente en ese punto con el color de dibujo, y almacena el resultado en la imagen. El píxel resultante es opaco. En un modo que no sea de mezcla, el color de dibujo se copia literalmente con la información del canal alfa, remplazando el píxel destino. El modo de mezlca no está disponible cuando se dibuja con imágenes de paleta de color.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

blendmode

Si se habilita o no el modo mezcla. En imágenes de color verdadero el valor por defecto es true de otro modo el valor por defecto es false

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de uso de imagealphablending()

<?php
// Crear imagen
$im = imagecreatetruecolor(100, 100);

// Establecer la mezcla alfa
imagealphablending($im, true);

// Dibujar un cuadrado
imagefilledrectangle($im, 30, 30, 70, 70, imagecolorallocate($im, 255, 0, 0));

// Imprimir
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>


Permitir o no el uso de funciones antialias

  • « imagealphablending
  • imagearc »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Permitir o no el uso de funciones antialias

imageantialias

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imageantialias — Permitir o no el uso de funciones antialias

Descripción

imageantialias ( resource $image , bool $enabled ) : bool

Activa los métodos de dibujo rápido con antialias para líneas y polígonos segmentados. No admite componentes alfa. Funciona usando una operación de mezcla directa. Solamente funciona con imágenes de color verdadero.

No están soportados grosor ni estilo.

Usar primitivos antialias con color de fondo transparente puede acabar en algunos resultados inesperados. El método de mezcla usa el color de fondo como cualquier otro color. La ausencia de soporte del comoponente alfa no permite un método de antialias basado en alfa.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

enabled

Si se habilita el 'antialiasing' o no.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Una comparación de dos líneas, una con antialias activado

<?php
// Establece una imagen con antialias y una imagen normal
$aa = imagecreatetruecolor(400, 100);
$normal = imagecreatetruecolor(200, 100);

// Activar antialias para una imagen
imageantialias($aa, true);

// Asignar colores
$rojo = imagecolorallocate($normal, 255, 0, 0);
$rojo_aa = imagecolorallocate($aa, 255, 0, 0);

// Dibujar dos líneas, una con AA habilitado
imageline($normal, 0, 0, 200, 100, $rojo);
imageline($aa, 0, 0, 200, 100, $rojo_aa);

// Fusionar las dos imágenes, una al lado de la otra, para impresión (AA: izquierda, Normal: derecha)
imagecopymerge($aa, $normal, 200, 0, 0, 0, 200, 100, 100);

// Imprimir la imagen
header('Content-type: image/png');

imagepng($aa);
imagedestroy($aa);
imagedestroy($normal);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Una comparación de dos líneas, una con antialias activado

Notas

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero


Dibujar un arco

  • « imageantialias
  • imagebmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un arco

imagearc

(PHP 4, PHP 5, PHP 7, PHP 8)

imagearc — Dibujar un arco

Descripción

imagearc ( resource $image , int $cx , int $cy , int $width , int $height , int $start , int $end , int $color ) : bool

imagearc() dibuja un arco de circunferencia con centro en las coordenadas dadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

cx

Coordenada x del centro.

cy

Coordenada y del centro

width

El ancho del arco.

height

El alto del arco.

start

El ángulo de inicio del arco, en grados.

end

El ángulo de finalización del arco, en grados. 0° está localizado en la posición que marca la aguja horaria a las tres en punto, y el arco se dibuja en el sentido de las agujas del reloj.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Dibujar un círculo con imagearc()

<?php

// crear una imagen de 200*200
$img = imagecreatetruecolor(200, 200);

// asignar algunos colores
$blanco = imagecolorallocate($img, 255, 255, 255);
$rojo   = imagecolorallocate($img, 255,   0,   0);
$verde = imagecolorallocate($img,   0, 255,   0);
$azul  = imagecolorallocate($img,   0,   0, 255);

// dibujar la cabeza
imagearc($img, 100, 100, 200, 200,  0, 360, $blanco);
// la boca
imagearc($img, 100, 100, 150, 150, 25, 155, $rojo);
// el ojo izquierdo y después el ojo derecho
imagearc($img,  60,  75,  50,  50,  0, 360, $verde);
imagearc($img, 140,  75,  50,  50,  0, 360, $azul);

// imprimir la imagen en el navegador
header("Content-type: image/png");
imagepng($img);

// liberar memoria
imagedestroy($img);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Dibujar un círculo con imagearc()

Ver también

  • imagefilledarc() - Dibujar un arco parcial y rellenarlo
  • imageellipse() - Dibujar una elipse
  • imagefilledellipse() - Dibujar una elipse con relleno


Output a BMP image to browser or file

  • « imagearc
  • imagechar »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Output a BMP image to browser or file

imagebmp

(PHP 7 >= 7.2.0, PHP 8)

imagebmp — Output a BMP image to browser or file

Descripción

imagebmp ( resource $image , mixed $to = null , bool $compressed = true ) : bool

Outputs or saves a BMP version of the given image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

to

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

Nota:

null is invalid if the compressed arguments is not used.

compressed

Whether the BMP should be compressed with run-length encoding (RLE), or not.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Precaución

Sin embargo, si libgd falla al producir la imagen, esta función devuelve true.

Ejemplos

Ejemplo #1 Saving a BMP file

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'BMP with PHP', $text_color);

// Save the image
imagebmp($im, 'php.bmp');

// Free up memory
imagedestroy($im);
?>


Dibujar un carácter horizontalmente

  • « imagebmp
  • imagecharup »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un carácter horizontalmente

imagechar

(PHP 4, PHP 5, PHP 7, PHP 8)

imagechar — Dibujar un carácter horizontalmente

Descripción

imagechar ( resource $image , int $font , int $x , int $y , string $c , int $color ) : bool

imagechar() dibuja el primer carácter de c en la imagen identificada por image con su límite superior izquierdo en x,y (el límite superior izquierdo es 0, 0) con el color color.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

x

Coordenada x del inicio.

y

Coordenada y del inicio.

c

El carácter a dibujar.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagechar()

<?php

$im = imagecreate(100, 100);

$cadena = 'PHP';

$fondo = imagecolorallocate($im, 255, 255, 255);
$negro = imagecolorallocate($im, 0, 0, 0);

// imprime una "P" negra en la esquina superior izquierda
imagechar($im, 1, 0, 0, $cadena, $negro);

header('Content-type: image/png');
imagepng($im);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagechar()

Ver también

  • imagecharup() - Dibujar un carácter verticalmente
  • imageloadfont() - Cargar una nueva fuente


Dibujar un carácter verticalmente

  • « imagechar
  • imagecolorallocate »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un carácter verticalmente

imagecharup

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecharup — Dibujar un carácter verticalmente

Descripción

imagecharup ( resource $image , int $font , int $x , int $y , string $c , int $color ) : bool

Dibuja el carácter c verticalmente, en las coordenadas especificadas, en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

x

Coordenada x del inicio.

y

Coordenada y del inicio.

c

El carácter a dibujar.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagecharup()

<?php

$im = imagecreate(100, 100);

$cadena = 'Nótese que la primera letra es una N';

$fondo = imagecolorallocate($im, 255, 255, 255);
$negro = imagecolorallocate($im, 0, 0, 0);

// imprime una "Z" negra sobre un fondo blanco
imagecharup($im, 3, 10, 10, $cadena, $negro);

header('Content-type: image/png');
imagepng($im);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagecharup()

Ver también

  • imagechar() - Dibujar un carácter horizontalmente
  • imageloadfont() - Cargar una nueva fuente


Asigna un color para una imagen

  • « imagecharup
  • imagecolorallocatealpha »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Asigna un color para una imagen

imagecolorallocate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorallocate — Asigna un color para una imagen

Descripción

imagecolorallocate ( resource $image , int $red , int $green , int $blue ) : int

Devuelve un identificador de color representando el color compuesto por los componentes RGB dados.

imagecolorallocate() debe ser llamada para crear cada color que va a ser usado en la imagen representada por image.

Nota:

La primera llamada a imagecolorallocate() rellena el color de fondo en imágenes basadas en paleta de colores - imágenes creadas usando imagecreate().

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

Estos parámetros son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Un identificador de color o false si la asignación falló.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
5.1.3 | Devuelve false si falló la asignación. Anteriormente devolvía -1.

Ejemplos

Ejemplo #1 Ejemplo de imagecolorallocate()

<?php

$im = imagecreate(100, 100);

// establece el fondo a rojo
$fondo = imagecolorallocate($im, 255, 0, 0);

// establece más colores
$blanco = imagecolorallocate($im, 255, 255, 255);
$negro = imagecolorallocate($im, 0, 0, 0);

// forma hexadecimal
$blanco = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$negro = imagecolorallocate($im, 0x00, 0x00, 0x00);

?>

Ver también

  • imagecolorallocatealpha() - Asignar un color para una imagen
  • imagecolordeallocate() - Desasignar un color de una imagen


Asignar un color para una imagen

  • « imagecolorallocate
  • imagecolorat »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Asignar un color para una imagen

imagecolorallocatealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imagecolorallocatealpha — Asignar un color para una imagen

Descripción

imagecolorallocatealpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

imagecolorallocatealpha() se comporta de forma idéntica a imagecolorallocate() con la adición del parámetro de transparencia alpha.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

alpha

Un valor entre 0 y 127. 0 indica completamente opaco mientras que 127 indica completamente transparente.

Los parámetros red, green y blue son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Un identificador de color o false si la asignación falló.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
5.1.3 | Devuelve false si falló la asignación. Anteriormente devolvía -1.

Ejemplos

Ejemplo #1 Ejemplo usando imagecolorallocatealpha()

<?php
$tamaño = 300;
$imagen=imagecreatetruecolor($tamaño, $tamaño);

// para obtener un fondo blanco con borde negro
$fondo = imagecolorallocate($imagen, 255, 255, 255);
$borde = imagecolorallocate($imagen, 0, 0, 0);
imagefilledrectangle($imagen, 0, 0, $tamaño - 1, $tamaño - 1, $fondo);
imagerectangle($imagen, 0, 0, $tamaño - 1, $tamaño - 1, $borde);

$amarillo_x = 100;
$amarillo_y = 75;
$rojo_x     = 120;
$rojo_y     = 165;
$azul_x     = 187;
$azul_y     = 125;
$radio      = 150;

// asignar colores con valores alfa
$amarillo = imagecolorallocatealpha($imagen, 255, 255, 0, 75);
$rojo     = imagecolorallocatealpha($imagen, 255, 0, 0, 75);
$azul     = imagecolorallocatealpha($imagen, 0, 0, 255, 75);

// dibujar 3 círculos traslapados
imagefilledellipse($imagen, $amarillo_x, $amarillo_y, $radio, $radio, $amarillo);
imagefilledellipse($imagen, $rojo_x, $rojo_y, $radio, $radio, $rojo);
imagefilledellipse($imagen, $azul_x, $azul_y, $radio, $radio, $azul);

// ¡no olvide imprimir la cabecera correcta!
header('Content-Type: image/png');

// y finalmente, imprimir el resultado
imagepng($imagen);
imagedestroy($imagen);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Ejemplo usando imagecolorallocatealpha()

Ver también

  • imagecolorallocate() - Asigna un color para una imagen
  • imagecolordeallocate() - Desasignar un color de una imagen


Obtener el índice del color de un píxel

  • « imagecolorallocatealpha
  • imagecolorclosest »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color de un píxel

imagecolorat

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorat — Obtener el índice del color de un píxel

Descripción

imagecolorat ( resource $image , int $x , int $y ) : int

Devuelve el índice del color de un píxel en el lugar especificado en la imagen especificada por image.

Si PHP se compila con la librería GD 2.0 o superior y la imagen es una imagen de color verdadero, esta función devuelve los valores RGB de ese pixel como entero. Use desplazamiento de bits y máscara de bits para acceder a los distintos valores de de los componentes rojo, verde y azul:

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x

Coordenada x del punto.

y

Coordenada y del punto.

Valores devueltos

Devuelve el índice del color.

Ejemplos

Ejemplo #1 Acceder a los distintos valores RGB

<?php
$im = imagecreatefrompng("php.png");
$rgb = imagecolorat($im, 10, 15);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;

var_dump($r, $g, $b);
?>

El resultado del ejemplo sería algo similar a:

int(119)
int(123)
int(180)

Ejemplo #2 Valores RGB legibles para humanos usando imagecolorsforindex()

<?php
$im = imagecreatefrompng("php.png");
$rgb = imagecolorat($im, 10, 15);

$colores = imagecolorsforindex($im, $rgb);

var_dump($colores);
?>

El resultado del ejemplo sería algo similar a:

array(4) {
  ["red"]=>
  int(119)
  ["green"]=>
  int(123)
  ["blue"]=>
  int(180)
  ["alpha"]=>
  int(127)
}

Ver también

  • imagecolorset() - Establecer el color para el índice de paleta especificada
  • imagecolorsforindex() - Obtener los colores de un índice
  • imagesetpixel() - Establecer un simple píxel


Obtener el índice del color más próximo al color especificado

  • « imagecolorat
  • imagecolorclosestalpha »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color más próximo al color especificado

imagecolorclosest

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorclosest — Obtener el índice del color más próximo al color especificado

Descripción

imagecolorclosest ( resource $image , int $red , int $green , int $blue ) : int

Devuelve el índice del color en la paleta de la imagen que está "más próximo" al valor RGB especificado.

La "distancia" entre el color deseado y cada color en la paleta es calculado como si los valores RGB representaran puntos en un espacio tridimensional.

Si se ha creado la imagen a partir de un fichero, sólo se resolverán los colores utilizados en la imagen. No se resolverán los colores que sólo están presentes en la paleta.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

Los parámetros de colores son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Devuelve el indice del color más próximo, en la paleta de la imagen, al color especificado.

Ejemplos

Ejemplo #1 Buscar un conjunto de colores en una imagen

<?php
// Comenzar con una imagen y convertirla a una imagen basada en paleta de colores
$im = imagecreatefrompng('figures/imagecolorclosest.png');
imagetruecolortopalette($im, false, 255);

// Buscar colores (RGB)
$colores = array(
    array(254, 145, 154),
    array(153, 145, 188),
    array(153, 90, 145),
    array(255, 137, 92)
);

// Itera cada búsqueda y encuentra el color más próximo en la paleta.
// Devuelve el número de búsqueda, el RGB de búsqueda y la coincidencia RGB convertida
foreach($colores as $id => $rgb)
{
    $resultado = imagecolorclosest($im, $rgb[0], $rgb[1], $rgb[2]);
    $resultado = imagecolorsforindex($im, $resultado);
    $resultado = "({$resultado['red']}, {$resultado['green']}, {$resultado['blue']})";

    echo "#$id: Búsqueda ($rgb[0], $rgb[1], $rgb[2]); Coincidencia más próxima: $resultado.\n";
}

imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

#0: Búsqueda (254, 145, 154); Coincidencia más próxima: (252, 150, 148).
#1: Búsqueda (153, 145, 188); Coincidencia más próxima: (148, 150, 196).
#2: Búsqueda (153, 90, 145); Coincidencia más próxima: (148, 90, 156).
#3: Búsqueda (255, 137, 92); Coincidencia más próxima: (252, 150, 92).

Ver también

  • imagecolorexact() - Obtener el índice del color especificado
  • imagecolorclosestalpha() - Obtener el índice del color más próximo al color + alpha especificado
  • imagecolorclosesthwb() - Obtener el índice del color que tiene el tono, blancura y negrura


Obtener el índice del color más próximo al color + alpha especificado

  • « imagecolorclosest
  • imagecolorclosesthwb »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color más próximo al color + alpha especificado

imagecolorclosestalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorclosestalpha — Obtener el índice del color más próximo al color + alpha especificado

Descripción

imagecolorclosestalpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

Devuelve el índice del color en la paleta de la imagen que está "más próximo" al valor RGB especificado y al nivel alpha especificado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

alpha

Un valor entre 0 y 127. 0 indica completamente opaco mientras que 127 indica completamente transparente.

Los parámetros de colores son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Devuelve el índice del color más próximo en la paleta.

Ejemplos

Ejemplo #1 Buscar un conjunto de colores en una imagen

<?php
// Comenzar con una imagen y convertirla a una imagen basada en paleta de colores
$im = imagecreatefrompng('figures/imagecolorclosest.png');
imagetruecolortopalette($im, false, 255);

// Buscar colores (RGB)
$colores = array(
    array(254, 145, 154, 50),
    array(153, 145, 188, 127),
    array(153, 90, 145, 0),
    array(255, 137, 92, 84)
);

// Itera cada búsqueda y encuentra el color más próximo en la paleta.
// Devuelve el número de búsqueda, el RGB de búsqueda y la coincidencia RGB convertida
foreach($colores as $id => $rgb)
{
    $resultado = imagecolorclosestalpha($im, $rgb[0], $rgb[1], $rgb[2], $rgb[3]);
    $resultado = imagecolorsforindex($im, $resultado);
    $resultado = "({$resultado['red']}, {$resultado['green']}, {$resultado['blue']}, {$resultado['alpha']})";

    echo "#$id: Búsqueda ($rgb[0], $rgb[1], $rgb[2], $rgb[3]); Coincidencia más próxima: $resultado.\n";
}

imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

#0: Search (254, 145, 154, 50); Closest match: (252, 150, 148, 0).
#1: Search (153, 145, 188, 127); Closest match: (148, 150, 196, 0).
#2: Search (153, 90, 145, 0); Closest match: (148, 90, 156, 0).
#3: Search (255, 137, 92, 84); Closest match: (252, 150, 92, 0).

Ver también

  • imagecolorexactalpha() - Obtener el índice del color + alpha especificado
  • imagecolorclosest() - Obtener el índice del color más próximo al color especificado
  • imagecolorclosesthwb() - Obtener el índice del color que tiene el tono, blancura y negrura


Obtener el índice del color que tiene el tono, blancura y negrura

  • « imagecolorclosestalpha
  • imagecolordeallocate »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color que tiene el tono, blancura y negrura

imagecolorclosesthwb

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecolorclosesthwb — Obtener el índice del color que tiene el tono, blancura y negrura

Descripción

imagecolorclosesthwb ( resource $image , int $red , int $green , int $blue ) : int

Obtiene el índice del color que tiene el tono, blancura y negrura más próximos al color dado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

Valores devueltos

Devuelve un entero con el índice del color que tiene el tono, blancura y negrura más próximos al color dado.

Ejemplos

Ejemplo #1 Ejemplo usando imagecolorclosesthwb()

<?php
$im = imagecreatefromgif('php.gif');

echo 'TBN: ' . imagecolorclosesthwb($im, 116, 115, 152);

imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

HWB: 33

Historial de cambios

Versión | Descripción
5.3.0 | Está función ahora está disponible en Windows

Ver también

  • imagecolorclosest() - Obtener el índice del color más próximo al color especificado


Desasignar un color de una imagen

  • « imagecolorclosesthwb
  • imagecolorexact »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Desasignar un color de una imagen

imagecolordeallocate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolordeallocate — Desasignar un color de una imagen

Descripción

imagecolordeallocate ( resource $image , int $color ) : bool

Desasigna un color previamente asignado con imagecolorallocate() o imagecolorallocatealpha().

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

color

El identificador de color.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Usar imagecolordeallocate()

<?php
$blanco = imagecolorallocate($im, 255, 255, 255);
imagecolordeallocate($im, $blanco);
?>

Ver también

  • imagecolorallocate() - Asigna un color para una imagen
  • imagecolorallocatealpha() - Asignar un color para una imagen


Obtener el índice del color especificado

  • « imagecolordeallocate
  • imagecolorexactalpha »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color especificado

imagecolorexact

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorexact — Obtener el índice del color especificado

Descripción

imagecolorexact ( resource $image , int $red , int $green , int $blue ) : int

Devuelve el índice del color especificado en la paleta de la imagen.

Si se ha creado la imagen a partir de un fichero, sólo se resolverán los colores utilizados en la imagen. No se resolverán los colores que sólo están presentes en la paleta.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

Valores devueltos

Devuelve el índice del color especificado en la paleta, o -1 si el color no existe.

Ejemplos

Ejemplo #1 Obtener colores del logotipo de GD

<?php
// Establece una imagen
$im = imagecreatefrompng('./gdlogo.png');

$colores   = Array();
$colores[] = imagecolorexact($im, 255, 0, 0);
$colores[] = imagecolorexact($im, 0, 0, 0);
$colores[] = imagecolorexact($im, 255, 255, 255);
$colores[] = imagecolorexact($im, 100, 255, 52);

print_r($colores);

// Libera memoria
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 16711680
    [1] => 0
    [2] => 16777215
    [3] => 6618932
)

Ver también

  • imagecolorclosest() - Obtener el índice del color más próximo al color especificado


Obtener el índice del color + alpha especificado

  • « imagecolorexact
  • imagecolormatch »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color + alpha especificado

imagecolorexactalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorexactalpha — Obtener el índice del color + alpha especificado

Descripción

imagecolorexactalpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

Devuelve el índice del color+alpha especifivado en la paleta de una imagen.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

alpha

Un valor entre 0 y 127. 0 indica completamente opaco mientras que 127 indica completamente transparente.

Los parámetros de colores son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Devuelve el índice del color+alpha especificado en la paleta de la imagen, o -1 si el color no existe en la paleta de la imagen.

Ejemplos

Ejemplo #1 Obtener colores del logotipo de GD

<?php

// Establecer una imagen
$im = imagecreatefrompng('./gdlogo.png');

$colores   = Array();
$colores[] = imagecolorexactalpha($im, 255, 0, 0, 0);
$colores[] = imagecolorexactalpha($im, 0, 0, 0, 127);
$colores[] = imagecolorexactalpha($im, 255, 255, 255, 55);
$colores[] = imagecolorexactalpha($im, 100, 255, 52, 20);

print_r($colores);

// Liberar memorio
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 16711680
    [1] => 2130706432
    [2] => 939524095
    [3] => 342163252
)

Ver también

  • imagecolorclosestalpha() - Obtener el índice del color más próximo al color + alpha especificado


Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero

  • « imagecolorexactalpha
  • imagecolorresolve »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero

imagecolormatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagecolormatch — Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero

Descripción

imagecolormatch ( resource $image1 , resource $image2 ) : bool

Hace que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero.

Parámetros

image1

Un recurso de enlace a una imagen de color verdadero.

image2

Un recurso de enlace a una imagen de paleta que apunta a una imagen que tiene el mismo tamaño que image1.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagecolormatch()

<?php
// Establecer las imágenes de color verdadero y de paleta
$im1 = imagecreatefrompng('./gdlogo.png');
$im2 = imagecreate(imagesx($im1), imagesy($im1));

// Añadir algunos colores a $im2
$colores   = Array();
$colores[] = imagecolorallocate($im2, 255, 36, 74);
$colores[] = imagecolorallocate($im2, 40, 0, 240);
$colores[] = imagecolorallocate($im2, 82, 100, 255);
$colores[] = imagecolorallocate($im2, 84, 63, 44);

// Hacer coincidir estos colores con la imagen de color verdadero
imagecolormatch($im1, $im2);

// Liberar memoria
imagedestroy($im1);
imagedestroy($im2);
?>

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero


Obtener el índice del color especificado o su alternativa más próxima posible

  • « imagecolormatch
  • imagecolorresolvealpha »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color especificado o su alternativa más próxima posible

imagecolorresolve

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorresolve — Obtener el índice del color especificado o su alternativa más próxima posible

Descripción

imagecolorresolve ( resource $image , int $red , int $green , int $blue ) : int

Está función garantiza la devolución de un índice de color para un color requerido, el color exacto o la alternativa más próxima posible.

Si se ha creado la imagen a partir de un fichero, sólo se resolverán los colores utilizados en la imagen. No se resolverán los colores que sólo están presentes en la paleta.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

Valores devueltos

Devuelve un índice de color.

Ejemplos

Ejemplo #1 Usar imagecoloresolve() para obtener colores de una imagen

<?php
// Cargar un imagen
$im = imagecreatefromgif('phplogo.gif');

// Obtener los colores más próximos de la imagen
$colores = array();
$colores[] = imagecolorresolve($im, 255, 255, 255);
$colores[] = imagecolorresolve($im, 0, 0, 200);

// Imprimir
print_r($colores);

imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 89
    [1] => 85
)

Ver también

  • imagecolorclosest() - Obtener el índice del color más próximo al color especificado


Obtener el índice del color + alpha especificado o su alternativa más próxima posible

  • « imagecolorresolve
  • imagecolorset »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el índice del color + alpha especificado o su alternativa más próxima posible

imagecolorresolvealpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorresolvealpha — Obtener el índice del color + alpha especificado o su alternativa más próxima posible

Descripción

imagecolorresolvealpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

Está función garantiza la devolución de un índice de color para un color requerido, el color exacto o la alternativa más próxima posible.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

alpha

Un valor entre 0 y 127. 0 indica completamente opaco mientras que 127 indica completamente transparente.

Los parámetros de colores son enteros entre 0 y 255 o hexadecimales entre 0x00 y 0xFF.

Valores devueltos

Devuelve un índice de color.

Ejemplos

Ejemplo #1 Usar imagecoloresolvealpha() para obtener colores de una imagen

<?php
// Cargar la imagen
$im = imagecreatefromgif('phplogo.gif');

// Obtener los colores más próximos de la imagen
$colores = array();
$colores[] = imagecolorresolvealpha($im, 255, 255, 255, 0);
$colores[] = imagecolorresolvealpha($im, 0, 0, 200, 127);

// Imprimir
print_r($colores);

imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 89
    [1] => 85
)

Ver también

  • imagecolorclosestalpha() - Obtener el índice del color más próximo al color + alpha especificado


Establecer el color para el índice de paleta especificada

  • « imagecolorresolvealpha
  • imagecolorsforindex »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer el color para el índice de paleta especificada

imagecolorset

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorset — Establecer el color para el índice de paleta especificada

Descripción

imagecolorset ( resource $image , int $index , int $red , int $green , int $blue , int $alpha = 0 ) : void

Establece el índice especificado en la paleta para el color especificado. Esto es útil para crear efectos parecidos al relleno en imágenes con paleta sin el overhead de la ejecución del relleno actual.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

index

Un índice en la paleta.

red

Valor del componente rojo.

green

Valor del componente verde.

blue

Valor del componente azul.

alpha

Valor del componente alfa.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro alpha.

Ejemplos

Ejemplo #1 Ejemplo de imagecolorset()

<?php
// Crear una imagen de 300x100
$im = imagecreate(300, 100);

// Establecer el fondo a rojo
imagecolorallocate($im, 255, 0, 0);

// Obtener el índice de color del fondo
$fondo = imagecolorat($im, 0, 0);

// Establecer el fondo a azul
imagecolorset($im, $fondo, 0, 0, 255);

// Imprimir la imagen en el navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ver también

  • imagecolorat() - Obtener el índice del color de un píxel


Obtener los colores de un índice

  • « imagecolorset
  • imagecolorstotal »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener los colores de un índice

imagecolorsforindex

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorsforindex — Obtener los colores de un índice

Descripción

imagecolorsforindex ( resource $image , int $index ) : array

Obtiene los colores de un índice especificado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

index

El índice de color.

Valores devueltos

Devuelve una matriz asociativa con las claves red, green, blue y alpha que contienen los valores apropiados del índice de color especificado.

Ejemplos

Ejemplo #1 Ejemplo de imagecolorsforindex()

<?php

// abrir una imagen
$im = imagecreatefrompng('nexen.png');

// obtener un color
$inicio_x = 40;
$inicio_y = 50;
$índice_color = imagecolorat($im, $inicio_x, $inicio_y);

// hacerlo legible para humanos
$color_tran = imagecolorsforindex($im, $índice_color);

// ¿qué es?
print_r($color_tran);

?>

El resultado del ejemplo sería algo similar a:

Array
(
   [red] => 226
   [green] => 222
   [blue] => 252
   [alpha] => 0
)

Ver también

  • imagecolorat() - Obtener el índice del color de un píxel
  • imagecolorexact() - Obtener el índice del color especificado


Averiguar el número de colores de la paleta de una imagen

  • « imagecolorsforindex
  • imagecolortransparent »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Averiguar el número de colores de la paleta de una imagen

imagecolorstotal

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorstotal — Averiguar el número de colores de la paleta de una imagen

Descripción

imagecolorstotal ( resource $image ) : int

Devuelve el número de colores de la paleta de una imagen.

Parámetros

image

Un recurso de imagen, devuelto por una de las funciones de creación de imágenes, como imagecreatefromgif().

Valores devueltos

Devuelve el número de colores de la paleta de la imagen especificada o 0 para imágenes de color verdadero.

Ejemplos

Ejemplo #1 Obtener el número total de colores de una imagen usando imagecolorstotal()

<?php
// Crear una instancia de una imagen
$im = imagecreatefromgif('php.gif');

echo 'Total de colores en la imagen: ' . imagecolorstotal($im);

// Liberar memoria
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Total colors in image: 128

Ver también

  • imagecolorat() - Obtener el índice del color de un píxel
  • imagecolorsforindex() - Obtener los colores de un índice
  • imageistruecolor() - Averiguar si una imagen es de color verdadero


Definir un color como transparente

  • « imagecolorstotal
  • imageconvolution »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Definir un color como transparente

imagecolortransparent

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolortransparent — Definir un color como transparente

Descripción

imagecolortransparent ( resource $image , int $color = ? ) : int

Establece el color transparente en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

El identificador del nuevo (o actual, si no se especificó nada) color transparente es devuelto. Si color no se especifica y la imagen no tiene color transparente, el identificador devuelto será -1.

Ejemplos

Ejemplo #1 Ejemplo de imagecolortransparent()

<?php
// Crear una imagen de 55x30
$im = imagecreatetruecolor(55, 30);
$rojo = imagecolorallocate($im, 255, 0, 0);
$negro = imagecolorallocate($im, 0, 0, 0);

// Hacer el fondo transparente
imagecolortransparent($im, $negro);

// Dibujar un rectángulo rojo
imagefilledrectangle($im, 4, 4, 50, 25, $rojo);

// Guardar la imagen
imagepng($im, './imagecolortransparent.png');
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagecolortransparent()

Notas

Nota:

La transpariencia se copia sólo con imagecopymerge() y con imágenes de color verdadero, no con imagecopy() o con imágenes de paleta.

Nota:

El color transparente es una propiedad de la imagen, la transparencia no es una propiedad del color. Una vez que se ha establecido un color a color transparente, cualquier región de la imagen en ese color que se haya dibujado previamente será transparente.


Aplicar una matriz de convolución de 3x3, usando coeficiente e índice

  • « imagecolortransparent
  • imagecopy »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Aplicar una matriz de convolución de 3x3, usando coeficiente e índice

imageconvolution

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

imageconvolution — Aplicar una matriz de convolución de 3x3, usando coeficiente e índice

Descripción

imageconvolution ( resource $image , array $matrix , float $div , float $offset ) : bool

Aplica una matriz de convolución a la imagen, usando el coeficiente y el índice dados.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

matrix

Una matriz de 3x3: una matriz de tres matrices de tres valores float.

div

El divisor del resultado de la convolución, usado para normalización.

offset

Índice de color.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Poner en relieve el logotipo de PHP.net

<?php
$imagen = imagecreatefromgif('http://www.php.net/images/php.gif');

$relieve = array(array(2, 0, 0), array(0, -1, 0), array(0, 0, -1));
imageconvolution($imagen, $relieve, 1, 127);

header('Content-Type: image/png');
imagepng($imagen, null, 9);
?>

El resultado del ejemplo sería:

Salida del ejemplo : Poner en relieve el logotipo de PHP.net

Ejemplo #2 Borrosidad gaussiana

<?php
$imagen = imagecreatetruecolor(180,40);

// Escribe el texto y aplica una borrosidad gaussiana a la imagen
imagestring($imagen, 5, 10, 8, 'Gaussian Blur Text', 0x00ff00);
$gaussiana = array(array(1.0, 2.0, 1.0), array(2.0, 4.0, 2.0), array(1.0, 2.0, 1.0));
imageconvolution($imagen, $gaussiana, 16, 0);

// Reescribe el texto para compararlo
imagestring($imagen, 5, 10, 18, 'Gaussian Blur Text', 0x00ff00);

header('Content-Type: image/png');
imagepng($imagen, null, 9);
?>

El resultado del ejemplo sería:

Salida del ejemplo : Borrosidad gaussiana

Notas

Esta función requiere GD 2.1.0 o superior.

Ver también

  • imagefilter() - Aplica un filtro a una imagen


Copiar parte de una imagen

  • « imageconvolution
  • imagecopymerge »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copiar parte de una imagen

imagecopy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecopy — Copiar parte de una imagen

Descripción

imagecopy ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h ) : bool

Copia una parte de src_im en dst_im comenzando en las coodenadas (x,y) src_x, src_y con un ancho de src_w y un alto de src_h. La porción definida será copiada en las coordenadas (x,y) dst_x y dst_y.

Parámetros

dst_im

Recurso de tipo enlace a la imagen de destino.

src_im

Recurso de tipo enlace a la imagen original.

dst_x

Coordenada x del punto de destino.

dst_y

Coordenada y del punto de destino.

src_x

Coordenada x del punto de origen.

src_y

Coordenada y del punto de origen.

src_w

Ancho original.

src_h

Altura original.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Recortar el logotipo de PHP.net

<?php
// Crear instancias de imágenes
$origen = imagecreatefromgif('php.gif');
$destino = imagecreatetruecolor(80, 40);

// Copiar
imagecopy($destino, $origen, 0, 0, 20, 13, 80, 40);

// Imprimir y liberar memoria
header('Content-Type: image/gif');
imagegif($destino);

imagedestroy($destino);
imagedestroy($origen);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Recortar el logotipo de PHP.net


Copiar y fusionar parte de una imagen

  • « imagecopy
  • imagecopymergegray »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copiar y fusionar parte de una imagen

imagecopymerge

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecopymerge — Copiar y fusionar parte de una imagen

Descripción

imagecopymerge ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h , int $pct ) : bool

Copia una parte de src_im en dst_im comenzando en las coodenadas x,y src_x, src_y con un ancho de src_w y un alto de src_h. La porción definida será copiada en las coordenadas x,y dst_x y dst_y.

Parámetros

dst_im

Recurso de tipo enlace a la imagen de destino.

src_im

Recurso de tipo enlace a la imagen original.

dst_x

Coordenada x del punto de destino.

dst_y

Coordenada y del punto de destino.

src_x

Coordenada x del punto de origen.

src_y

Coordenada y del punto de origen.

src_w

Ancho original.

src_h

Altura original.

pct

Las dos imágenes serán fusionadas según pct, cuyo valor puede estar entre 0 y 100. Cuando pct = 0, no se realiza ninguna acción; cuando es 100, esta función se comportará de forma idéntica a imagecopy() para imágenes de paleta, excepto para ignorar componentes alfa, mientras que implementa transparencia alfa para imágenes de color verdadero.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Fusionar dos copias del logotipo de PHP.net con 75% de transparencia

<?php
// Crear instancias de imágenes
$destino = imagecreatefromgif('php.gif');
$origen = imagecreatefromgif('php.gif');

// Copiar y fusionar
imagecopymerge($destino, $origen, 10, 10, 0, 0, 100, 47, 75);

// Imprimir y liberar memoria
header('Content-Type: image/gif');
imagegif($destino);

imagedestroy($destino);
imagedestroy($origen);
?>


Copiar y fusionar parte de una imagen con escala de grises

  • « imagecopymerge
  • imagecopyresampled »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copiar y fusionar parte de una imagen con escala de grises

imagecopymergegray

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecopymergegray — Copiar y fusionar parte de una imagen con escala de grises

Descripción

imagecopymergegray ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h , int $pct ) : bool

imagecopymergegray() copia una parte de src_im en dst_im comenzando en las coodenadas x,y src_x, src_y con un ancho de src_w y un alto de src_h. La porción definida será copiada en las coordenadas x,y dst_x y dst_y.

Esta función es idéntica a imagecopymerge() excepto que en la fusión preserva el tono del origen convirtiendo los píxeles de destino en escala de grises antes de la operación de copia.

Parámetros

dst_im

Recurso de tipo enlace a la imagen de destino.

src_im

Recurso de tipo enlace a la imagen original.

dst_x

Coordenada x del punto de destino.

dst_y

Coordenada y del punto de destino.

src_x

Coordenada x del punto de origen.

src_y

Coordenada y del punto de origen.

src_w

Ancho original.

src_h

Altura original.

pct

src_im será cambiado a escala de grises según pct, donde 0 es totalmente escala de grises y 100 es sin cambios. Cuando pct = 100 esta función se comporta de forma idéntica a imagecopy() para imágenes de paleta, excepto para ignorar componentes alfa, mientras que implementa transparencia alfa para imágenes de color verdadero.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso de imagecopymergegray()

<?php
// Crear instancias de imágenes
$destino = imagecreatefromgif('php.gif');
$origen = imagecreatefromgif('php.gif');

// Copiar y fusionar - Gris = 20%
imagecopymergegray($destino, $origen, 10, 10, 0, 0, 100, 47, 20);

// Imprimir y liberar memoria
header('Content-Type: image/gif');
imagegif($destino);

imagedestroy($destino);
imagedestroy($origen);
?>


Copia y cambia el tamaño de parte de una imagen redimensionándola

  • « imagecopymergegray
  • imagecopyresized »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copia y cambia el tamaño de parte de una imagen redimensionándola

imagecopyresampled

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecopyresampled — Copia y cambia el tamaño de parte de una imagen redimensionándola

Descripción

imagecopyresampled ( resource $dst_image , resource $src_image , int $dst_x , int $dst_y , int $src_x , int $src_y , int $dst_w , int $dst_h , int $src_w , int $src_h ) : bool

imagecopyresampled() copia una porción rectangular de una imagen a otra imagen, interpolando de manera suave los valores de los píxeles por lo que, particularmete, al reducir el tamaño de una imagen, ésta todavía conserva mucha nitidez.

En otras palabras, imagecopyresampled() tomará un área rectangular de src_image de ancho src_w y alto src_h en la posición (src_x,src_y) y la coloca en un área rectangular de dst_image de ancho dst_w y alto dst_h en la posición (dst_x,dst_y).

Si las coordenadas del origen y destino y los anchos y altos difieren, se llevará a cabo la ampliación o reducción del fragmento de la imagen. Las coodernadas se refiren a la esquina superior izquierda. Esta función se puede usar para copiar regiones dentro de la misma imagen (si dst_image es el mismo que src_image) pero si las regiones se traslapan el resultado será impredecible.

Parámetros

dst_image

Recurso de tipo enlace a la imagen de destino.

src_image

Recurso de tipo enlace a la imagen original.

dst_x

Coordenada x del punto de destino.

dst_y

Coordenada y del punto de destino.

src_x

Coordenada x del punto de origen.

src_y

Coordenada y del punto de origen.

dst_w

Ancho del destino.

dst_h

Alto del destino.

src_w

Ancho original.

src_h

Altura original.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo sencillo

Este ejemplo redimensionará una imagen a la mitad de su tamaño original.

<?php
// El archivo
$nombre_archivo = 'prueba.jpg';
$porcentaje = 0.5;

// Tipo de contenido
header('Content-Type: image/jpeg');

// Obtener nuevas dimensiones
list($ancho, $alto) = getimagesize($nombre_archivo);
$nuevo_ancho = $ancho * $porcentaje;
$nuevo_alto = $alto * $porcentaje;

// Redimensionar
$imagen_p = imagecreatetruecolor($nuevo_ancho, $nuevo_alto);
$imagen = imagecreatefromjpeg($nombre_archivo);
imagecopyresampled($imagen_p, $imagen, 0, 0, 0, 0, $nuevo_ancho, $nuevo_alto, $ancho, $alto);

// Imprimir
imagejpeg($imagen_p, null, 100);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Ejemplo sencillo

Ejemplo #2 Redimensionar una imagen proporcionalmente

Este ejemplo mostrará una imagen con el ancho, o alto, máximo de 200 píxeles.

<?php
// El archivo
$nombre_archivo = 'prueba.jpg';

// Establecer un ancho y alto máximo
$ancho = 200;
$alto = 200;

// Tipo de contenido
header('Content-Type: image/jpeg');

// Obtener las nuevas dimensiones
list($ancho_orig, $alto_orig) = getimagesize($nombre_archivo);

$ratio_orig = $ancho_orig/$alto_orig;

if ($ancho/$alto > $ratio_orig) {
   $ancho = $alto*$ratio_orig;
} else {
   $alto = $ancho/$ratio_orig;
}

// Redimensionar
$image_p = imagecreatetruecolor($ancho, $alto);
$image = imagecreatefromjpeg($nombre_archivo);
imagecopyresampled($image_p, $image, 0, 0, 0, 0, $ancho, $alto, $ancho_orig, $alto_orig);

// Imprimir
imagejpeg($image_p, null, 100);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Redimensionar una imagen proporcionalmente

Notas

Nota:

Hay un problema debido a las limitaciones de la imagen de paleta (255+1 colores). Redimensionar o filtrar una imagen normalmente necesita más de 255 colores, se usa un tipo de aproximación para calcular el nuevo píxel redimensionado y su color. Con una imagen de paleta tratamos de asignar un color nuevo, si falló, escogemos el color computado más próximo (en teoría). Éste no es siempre el color visual más próximo. Puede producir un resultado extraño, como imágenes en blaco (o visualmente en blaco). Para saltarse este problema, por favor use una imagen de color verdadero como imagen de destino, como una creada por imagecreatetruecolor().

Ver también

imagecopyresized() - Copia y cambia el tamaño de parte de una imagen


Copia y cambia el tamaño de parte de una imagen

  • « imagecopyresampled
  • imagecreate »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copia y cambia el tamaño de parte de una imagen

imagecopyresized

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecopyresized — Copia y cambia el tamaño de parte de una imagen

Descripción

imagecopyresized ( resource $dst_image , resource $src_image , int $dst_x , int $dst_y , int $src_x , int $src_y , int $dst_w , int $dst_h , int $src_w , int $src_h ) : bool

imagecopyresized() copia una porción de una imagen a otra imagen. dst_image es la imagen de destino, src_image es el identificador de la imagen de origen.

En otras palabras, imagecopyresized() tomará un área rectangular de src_image de ancho src_w y alto src_h en la posición (src_x,src_y) y la colocará en un área rectangular de dst_image de ancho dst_w y alto dst_h en la posición (dst_x,dst_y).

Si las coordenadas de origen y destino y los anchos y altos difieren, se llevará a cabo la ampliación o reducción apropiadas del fragmento de la imagen. Las coodernadas se refiren a la esquina superior izquierda. Esta función se puede usar para copiar regiones dentro de la misma imagen (si dst_image es el mismo que src_image) pero si las regiones se traslapan el resultado será impredecible.

Parámetros

dst_image

Recurso de tipo enlace a la imagen de destino.

src_image

Recurso de tipo enlace a la imagen original.

dst_x

Coordenada x del punto de destino.

dst_y

Coordenada y del punto de destino.

src_x

Coordenada x del punto de origen.

src_y

Coordenada y del punto de origen.

dst_w

Ancho del destino.

dst_h

Alto del destino.

src_w

Ancho original.

src_h

Altura original.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cambiar el tamaño de una imagen

Este ejemplo mostrará la imagen a mitad de tamaño.

<?php
// Fichero y nuevo tamaño
$nombre_fichero = 'prueba.jpg';
$porcentaje = 0.5;

// Tipo de contenido
header('Content-Type: image/jpeg');

// Obtener los nuevos tamaños
list($ancho, $alto) = getimagesize($nombre_fichero);
$nuevo_ancho = $ancho * $porcentaje;
$nuevo_alto = $alto * $porcentaje;

// Cargar
$thumb = imagecreatetruecolor($nuevo_ancho, $nuevo_alto);
$origen = imagecreatefromjpeg($nombre_fichero);

// Cambiar el tamaño
imagecopyresized($thumb, $origen, 0, 0, 0, 0, $nuevo_ancho, $nuevo_alto, $ancho, $alto);

// Imprimir
imagejpeg($thumb);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Cambiar el tamaño de una imagen

La imagen se imprimirá a mitad de tamaño, aunque se puede obtener una mejor calidad usando imagecopyresampled().

Notas

Nota:

Hay un problema debido a las limitaciones de la imagen de paleta (255+1 colores). Redimensionar o filtrar una imagen normalmente necesita más de 255 colores, por lo que se usa un tipo de aproximación para calcular el nuevo píxel redimensionado y su color. Con una imagen de paleta se trata de asignar un color nuevo, y si falló, se escoge el color computado más próximo (en teoría). Éste no es siempre el color visual más próximo. Puede producir un resultado extraño, como imágenes en blanco (o visualmente en blaco). Para evitar este problema, por favor use una imagen de color verdadero como imagen de destino, como una creada por imagecreatetruecolor().

Ver también

imagecopyresampled() - Copia y cambia el tamaño de parte de una imagen redimensionándola


Crea una nueva imagen basada en paleta

  • « imagecopyresized
  • imagecreatefrombmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen basada en paleta

imagecreate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreate — Crea una nueva imagen basada en paleta

Descripción

imagecreate ( int $width , int $height ) : resource

imagecreate() devuelve un identificador de imagen que representa una imagen en blanco del tamaño especificado.

En general, se recomienda el uso de imagecreatetruecolor() en lugar de imagecreate() para que el procesamiento de la imagen suceda con la mayor calidad de imagen posible. Si se quiere generar una imagen de paleta, imagetruecolortopalette() debería ser invocada inmediatamente antes de guardar la imagen con imagepng() o imagegif().

Parámetros

width

El ancho de la imagen.

height

El alto de la imagen.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Crear un nuevo flujo de imagen GD e imprimir una imagen.

<?php
header("Content-Type: image/png");
$im = @imagecreate(110, 20)
    or die("Cannot Initialize new GD image stream");
$color_fondo = imagecolorallocate($im, 0, 0, 0);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $color_texto);
imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Crear un nuevo flujo de imagen GD e imprimir una imagen.

Ver también

  • imagedestroy() - Destruir una imagen
  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreate
  • imagecreatefromgd2 »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefrombmp

(PHP 7 >= 7.2.0, PHP 8)

imagecreatefrombmp — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefrombmp ( string $filename ) : resource

imagecreatefrombmp() returns an image identifier representing the image obtained from the given filename.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Path to the BMP image.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Convert an BMP image to a PNG image using imagecreatefrombmp()

<?php
// Load the BMP file
$im = imagecreatefrombmp('./example.bmp');

// Convert it to a PNG file with default settings
imagepng($im, './example.png');
imagedestroy($im);
?>


Crear una imagen nueva desde un fichero GD2 o un URL

  • « imagecreatefrombmp
  • imagecreatefromgd2part »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crear una imagen nueva desde un fichero GD2 o un URL

imagecreatefromgd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd2 — Crear una imagen nueva desde un fichero GD2 o un URL

Descripción

imagecreatefromgd2 ( string $filename ) : resource

Crea una imagen nueva desde un fichero GD2 o un URL.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta a la imagen GD2.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagecreatefromgd2()

<?php
// Cargar la imagen gd2
$im = imagecreatefromgd2('./prueba.gd2');

// Aplicar un efecto sobre la imagen, en este
// caso poner en negativo la imagen si PHP 5+
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_NEGATE);
}

// Guardar la imagen
imagegd2($im, './prueba_actualizada.gd2');
imagedestroy($im);
?>


Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL

  • « imagecreatefromgd2
  • imagecreatefromgd »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL

imagecreatefromgd2part

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd2part — Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL

Descripción

imagecreatefromgd2part ( string $filename , int $srcX , int $srcY , int $width , int $height ) : resource

Crea una nueva imagen desde una parte dada de un fichero GD2 o un URL.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta a la imagen GD2.

srcX

Coordenada x del punto de origen.

srcY

Coordenada y del punto de origen.

width

Ancho original.

height

Altura original.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagecreatefromgd2part()

<?php
// Para este ejemplo necesitamos el tamaño de la imagen antes
$imagen = getimagesize('./prueba.gd2');

// Crear la instancia de imagen, ahora obtenemos el tamaño de la
// imagen
$im = imagecreatefromgd2part('./prueba.gd2', 4, 4, ($imagen[0] / 2) - 6, ($imagen[1] / 2) - 6);

// Hacer una operación con la imagen, en este caso pondremos la imagen
// en relieve si PHP 5+
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_EMBOSS);
}

// Guardar la imagen optimizada
imagegd2($im, './prueba_relieve.gd2');
imagedestroy($im);
?>


Crear una imagen nueva desde un fichero GD o un URL

  • « imagecreatefromgd2part
  • imagecreatefromgif »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crear una imagen nueva desde un fichero GD o un URL

imagecreatefromgd

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd — Crear una imagen nueva desde un fichero GD o un URL

Descripción

imagecreatefromgd ( string $filename ) : resource

Crear una imagen nueva desde un fichero GD o una URL.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta al fichero GD.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagecreatefromgd()

<?php
// Cargar la imagen gd
$im = @imagecreatefromgd('./prueba.gd');

// Comprobar si la imagen fue cargada
if(!is_resource($im))
{
     die('¡No se puede cargar la imagen gd!');
}

// Operar con la imagen aquí

// Guardar la imagen
imagegd($im, './prueba_actualizada.gd');
imagedestroy($im);
?>


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromgd
  • imagecreatefromjpeg »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromgif

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefromgif — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromgif ( string $filename ) : resource

imagecreatefromgif() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen GIF.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de manejar un error durante la carga de un GIF

<?php
function CargarGif($imagen)
{
    /* Intentar abrir */
    $im = @imagecreatefromgif($imagen);

    /* Ver si falló */
    if(!$im)
    {
        /* Crear una imagen en blanco */
        $im = imagecreatetruecolor (150, 30);
        $fondo = imagecolorallocate ($im, 255, 255, 255);
        $ct = imagecolorallocate ($im, 0, 0, 0);

        imagefilledrectangle ($im, 0, 0, 150, 30, $fondo);

        /* Imprimir un mensaje de error */
        imagestring ($im, 1, 5, 5, 'Error cargando ' . $imagen, $ct);
    }

    return $im;
}

header('Content-Type: image/gif');

$img = CargarGif('falso.image');

imagegif($img);
imagedestroy($img);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Ejemplo de manejar un error durante la carga de un GIF

Notas

Nota:

El soporte para GIF se eliminó de la biblioteca GD en la Versión 1.6, y se volvió a añdir en la Versión 2.0.28. Esta función no está disponible entre estas versiones.

Nota:

Al leer ficheros GIF animados desde memoria, solamente es devuelto el primer fotograma de la imagen al puntero de recurso.


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromgif
  • imagecreatefrompng »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromjpeg

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefromjpeg — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromjpeg ( string $filename ) : resource

imagecreatefromjpeg() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen JPEG.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de manejar un error durante la carga de un JPEG

<?php
function CargarJpeg($imagen)
{
    /* Intentar abrir */
    $im = @imagecreatefromjpeg($imagen);

    /* Ver si falló */
    if(!$im)
    {
        /* Crear una imagen en blanco */
        $im  = imagecreatetruecolor(150, 30);
        $fondo = imagecolorallocate($im, 255, 255, 255);
        $ct  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $fondo);

        /* Imprimir un mensaje de error */
        imagestring($im, 1, 5, 5, 'Error cargando ' . $imagen, $ct);
    }

    return $im;
}

header('Content-Type: image/jpeg');

$img = CargarJpeg('falso.image');

imagejpeg($img);
imagedestroy($img);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Ejemplo de manejar un error durante la carga de un JPEG


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromjpeg
  • imagecreatefromstring »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefrompng

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefrompng — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefrompng ( string $filename ) : resource

imagecreatefrompng() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen PNG.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de manejar un error durante la carga de un PNG

<?php
function CargarPNG($imagen)
{
    /* Intentar abrir */
    $im = @imagecreatefrompng($imagen);

    /* Ver si falló */
    if(!$im)
    {
        /* Crear una imagen en blanco */
        $im  = imagecreatetruecolor(150, 30);
        $fondo = imagecolorallocate($im, 255, 255, 255);
        $ct  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $fondo);

        /* Imprimir un mensaje de error */
        imagestring($im, 1, 5, 5, 'Error cargando ' . $imagen, $ct);
    }

    return $im;
}

header('Content-Type: image/png');

$img = CargarPNG('falso.image');

imagepng($img);
imagedestroy($img);
?>

El resultado del ejemplo sería algo similar a:

Ejemplo de imagecreatefrompng()


Crear una imagen nueva desde el flujo de imagen de la cadena

  • « imagecreatefrompng
  • imagecreatefromwbmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crear una imagen nueva desde el flujo de imagen de la cadena

imagecreatefromstring

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

imagecreatefromstring — Crear una imagen nueva desde el flujo de imagen de la cadena

Descripción

imagecreatefromstring ( string $image ) : resource

imagecreatefromstring() devuelve un identificador de imagen que representa la imagen obtenida desde image. Estos tipos serán automáticamente detectados si se construye PHP para que los soporte: JPEG, PNG, GIF, WBMP y GD2.

Parámetros

image

Una cadena que contiene la información de la imagen.

Valores devueltos

Será devuelto un recurso de imagen. Se devuelve false si el tipo de imagen no está soportado, la información no está en un formato reconocido, o la imagen está corrupta y no se puede cargar.

Ejemplos

Ejemplo #1 Ejemplo de imagecreatefromstring()

<?php
$data = 'iVBORw0KGgoAAAANSUhEUgAAABwAAAASCAMAAAB/2U7WAAAABl'
       . 'BMVEUAAAD///+l2Z/dAAAASUlEQVR4XqWQUQoAIAxC2/0vXZDr'
       . 'EX4IJTRkb7lobNUStXsB0jIXIAMSsQnWlsV+wULF4Avk9fLq2r'
       . '8a5HSE35Q3eO2XP1A1wQkZSgETvDtKdQAAAABJRU5ErkJggg==';
$data = base64_decode($data);

$im = imagecreatefromstring($data);
if ($im !== false) {
    header('Content-Type: image/png');
    imagepng($im);
    imagedestroy($im);
}
else {
    echo 'Ocurrió un error.';
}
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagecreatefromstring()

Ver también

  • imagecreatefromjpeg() - Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefrompng() - Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatefromgif() - Crea una nueva imagen a partir de un fichero o de una URL
  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromstring
  • imagecreatefromwebp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromwbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromwbmp — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromwbmp ( string $filename ) : resource

imagecreatefromwbmp() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen WBMP.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de manejar un error durante la carga de un WBMP

<?php
function CargarWBMP($imagen)
{
    /* Intentar abrir */
    $im = @imagecreatefromwbmp($imagen);

    /* Ver si falló */
    if(!$im)
    {
        /* Crear una imagen en blanco */
        $im  = imagecreatetruecolor(150, 30);
        $fondo = imagecolorallocate($im, 255, 255, 255);
        $ct  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $fondo);

        /* Imprimir un mensaje de error */
        imagestring($im, 1, 5, 5, 'Error cargando ' . $imagen, $ct);
    }

    return $im;
}

header('Content-Type: image/vnd.wap.wbmp');

$img = CargarWBMP('falso.image');

imagewbmp($img);
imagedestroy($img);
?>


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromwbmp
  • imagecreatefromxbm »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromwebp

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

imagecreatefromwebp — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromwebp ( string $filename ) : resource

imagecreatefromwebp() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta a la imagen WebP.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Convertir una image WebP a una imagen jpeg usando imagecreatefromwebp()

<?php
// Load the WebP file
$im = imagecreatefromwebp('./example.webp');

// Convertirla a un fichero jpeg con la calidad al 100%
imagejpeg($im, './example.jpeg', 100);
imagedestroy($im);
?>


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromwebp
  • imagecreatefromxpm »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromxbm

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromxbm — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromxbm ( string $filename ) : resource

imagecreatefromxbm() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen XBM.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Convertir una imagen XBM en una imagen png usando imagecreatefromxbm()

<?php
// Cargar el archivo xbm
$xbm = imagecreatefromxbm('./ejemplo.xbm');

// Convertirla al archivo png
imagepng($xbm, './ejemplo.png');
imagedestroy($xbm);
?>


Crea una nueva imagen a partir de un fichero o de una URL

  • « imagecreatefromxbm
  • imagecreatetruecolor »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crea una nueva imagen a partir de un fichero o de una URL

imagecreatefromxpm

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromxpm — Crea una nueva imagen a partir de un fichero o de una URL

Descripción

imagecreatefromxpm ( string $filename ) : resource

imagecreatefromxpm() devuelve un identificador de imagen que representa la imagen obtenida desde el nombre de fichero dado.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

Parámetros

filename

Ruta de la imagen XPM.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Historial de cambios

Versión | Descripción
PHP 5.3.19 | imagecreatefromxpm() está disponible en Windows.

Ejemplos

Ejemplo #1 Crear una instancia de imagen usando imagecreatefromxpm()

<?php
// Comprobar el soporte para XPM
if(!(imagetypes() & IMG_XPM))
{
    die('¡No se encontró el soporte para xpm!');
}

// Crear una instancia de una imagen
$xpm = imagecreatefromxpm('./ejemplo.xpm');

// Hacer las operaciones con la imagen aquí

// PHP no tiene soporte para escribir imágenes xpm
// por lo que, en este caso, guardaremos la imagen como un
// fichero jpeg con el 100% de calidad
imagejpeg($xpm, './ejemplo.jpg', 100);
imagedestroy($xpm);
?>


Crear una nueva imagen de color verdadero

  • « imagecreatefromxpm
  • imagecrop »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Crear una nueva imagen de color verdadero

imagecreatetruecolor

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecreatetruecolor — Crear una nueva imagen de color verdadero

Descripción

imagecreatetruecolor ( int $width , int $height ) : resource

imagecreatetruecolor() devuelve un identificador de imagen que representa una imagen en negro del tamaño especificado.

Dependiendo de las versiones de PHP y GD esta función está definida o no. Con PHP 4.0.6 hasta 4.1.x esta función siempre existe si el módulo GD está cargado, pero al llamarla sin que GD2 esté instalado, PHP emitirá un error fatal y saldrá. Con PHP 4.2.x este comportamiento es diferente, al emitir una advertencia en vez de un error. Otras versiones sólo definen esta función, si la versión correcta de GD está instalada.

Parámetros

width

Ancho de la imagen.

height

Alto de la imagen.

Valores devueltos

En caso de éxito, devuelve un identificador de recurso de imagen, y false en caso de error.

Ejemplos

Ejemplo #1 Crear un nuevo flujo a una imagen GD e imprimir una imagen.

<?php
header ('Content-Type: image/png');
$im = @imagecreatetruecolor(120, 20)
      or die('No se puede Iniciar el nuevo flujo a la imagen GD');
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);
imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Crear una nuevo flujo de imagen GD e imprimir una imagen.

Ver también

  • imagedestroy() - Destruir una imagen
  • imagecreate() - Crea una nueva imagen basada en paleta


Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados

  • « imagecreatetruecolor
  • imagecropauto »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados

imagecrop

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagecrop — Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados

Descripción

imagecrop ( resource $image , array $rect ) : resource

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

rect

Array with keys "x", "y", "width" and "height".

Valores devueltos

Devuelve el recurso de la imagen recortada en caso de éxito o false en caso de error.


Recorta una imagen automáticamente usando uno de los modos disponibles

  • « imagecrop
  • imagedashedline »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Recorta una imagen automáticamente usando uno de los modos disponibles

imagecropauto

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagecropauto — Recorta una imagen automáticamente usando uno de los modos disponibles

Descripción

imagecropauto ( resource $image , int $mode = -1 , float $threshold = .5 , int $color = -1 ) : resource

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

mode

Una de las constantes IMG_CROP_*.

threshold

Usado en modo IMG_CROP_THRESHOLD.

color

Usado en modo IMG_CROP_THRESHOLD.

Valores devueltos

Devuelve el recurso de la imagen recortada en caso de éxito o false en caso de error.


Dibujar una línea discontinua

  • « imagecropauto
  • imagedestroy »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una línea discontinua

imagedashedline

(PHP 4, PHP 5, PHP 7, PHP 8)

imagedashedline — Dibujar una línea discontinua

Descripción

imagedashedline ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

Esta función esta obsoleta. Use una combinación de imagesetstyle() y imageline() en su lugar.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x1

Coordenada x superior izquierda.

y1

Coordenada y superior izquierda 0, 0 es la esquina superior izquierda de la imagen.

x2

Coordenada x inferior derecha.

y2

Coordenada y inferior derecha.

color

El color de relleno. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Siempre devuelve true

Ejemplos

Ejemplo #1 Ejemplo de imagedashedline()

<?php
// Crear una imagen de 100x100
$im = imagecreatetruecolor(100, 100);
$blanco = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);

// Dibujar una línea discontinua vertical
imagedashedline($im, 50, 25, 50, 75, $blanco);

// Guardar la imagen
imagepng($im, './linea_dis.png');
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagedashedline()

Ejemplo #2 Alternativa a imagedashedline()

<?php
// Crear una imagen de 100x100
$im = imagecreatetruecolor(100, 100);
$blanco = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);

// Definir nuestro estilo: Los primeros 4 píxeles son blancos y los
// 4 siguientes son transparentes. Esto crea el efecto de línea discontinua
$estilo = Array(
                $blanco,
                $blanco,
                $blanco,
                $blanco,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT
                );

imagesetstyle($im, $estilo);

// Dibujar la línea discontinua
imageline($im, 50, 25, 50, 75, IMG_COLOR_STYLED);

// Guardar la imagen
imagepng($im, './imageline.png');
imagedestroy($im);
?>

Ver también

  • imagesetstyle() - Establecer el estilo para el dibujo de líneas
  • imageline() - Dibujar una línea


Destruir una imagen

  • « imagedashedline
  • imageellipse »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Destruir una imagen

imagedestroy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagedestroy — Destruir una imagen

Descripción

imagedestroy ( resource $image ) : bool

imagedestroy() libera cualquier memoria asociada con la imagen image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de uso de imagedestroy()

<?php
// crear una imagen de 100 x 100
$im = imagecreatetruecolor(100, 100);

// modificar o guardar la imagen

// liberar la imagen de la memoria
imagedestroy($im);
?>


Dibujar una elipse

  • « imagedestroy
  • imagefill »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una elipse

imageellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imageellipse — Dibujar una elipse

Descripción

imageellipse ( resource $image , int $cx , int $cy , int $width , int $height , int $color ) : bool

Dibuja una elipse con centro en las coordenadas especificadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

cx

Coordenada x del centro.

cy

Coordenada y del centro.

width

El ancho de la elipse.

height

El alto de la elipse.

color

El color de la elipse. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imageellipse()

<?php

// Crear una imagen en blanco.
$imagen = imagecreatetruecolor(400, 300);

// Seleccionar el color de fondo.
$fondo = imagecolorallocate($imagen, 0, 0, 0);

// Rellenar el fondo con el color seleccionado arriba.
imagefill($imagen, 0, 0, $fondo);

// Escoger un color para la elipse.
$col_ellipse = imagecolorallocate($imagen, 255, 255, 255);

// Dibujar la elipse
imageellipse($imagen, 200, 150, 300, 200, $col_ellipse);

// Imprimir la imagen
header("Content-type: image/png");
imagepng($imagen);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imageellipse()

Notas

Nota:

Esta función requiere GD 2.0.2 o posterior.

Nota:

imageellipse() ignora imagesetthickness().

Ver también

  • imagefilledellipse() - Dibujar una elipse con relleno
  • imagearc() - Dibujar un arco


Rellenar

  • « imageellipse
  • imagefilledarc »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Rellenar

imagefill

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefill — Rellenar

Descripción

imagefill ( resource $image , int $x , int $y , int $color ) : bool

Lleva a cabo un relleno comenzando en la coordenada dada (superior izquierda es 0, 0), con el color dado, en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x

Coordenada x del punto de inicio.

y

Coordenada y del punto de inicio.

color

El color de relleno. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagefill()

<?php

$im = imagecreatetruecolor(100, 100);

// establece el fondo a rojo
$rojo = imagecolorallocate($im, 255, 0, 0);
imagefill($im, 0, 0, $rojo);

header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagefill()

Ver también

  • imagecolorallocate() - Asigna un color para una imagen


Dibujar un arco parcial y rellenarlo

  • « imagefill
  • imagefilledellipse »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un arco parcial y rellenarlo

imagefilledarc

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagefilledarc — Dibujar un arco parcial y rellenarlo

Descripción

imagefilledarc ( resource $image , int $cx , int $cy , int $width , int $height , int $start , int $end , int $color , int $style ) : bool

Dibuja un arco parcial con centro en las coordenadas especificadas en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

cx

Coordenada x del centro.

cy

Coordenada y del centro

width

El ancho del arco.

height

El alto del arco.

start

El ángulo de inicio del arco, en grados.

end

El ángulo de finalización del arco, en grados. 0º esta localizado en la posición que marca la aguja horaria a las tres en punto, y el arco se dibuja en el sentido de las agujas del reloj.

color

Un identificador de color creado con imagecolorallocate().

style

Un OR a nivel de bit de las siguientes posibilidades:

  1. IMG_ARC_PIE
  2. IMG_ARC_CHORD
  3. IMG_ARC_NOFILL
  4. IMG_ARC_EDGED
IMG_ARC_PIE y IMG_ARC_CHORD son mútuamente exclusivos; IMG_ARC_CHORD conecta los ángulos de inicio y de finalización con una línea recta, mientras que IMG_ARC_PIE produce un borde redondeado. IMG_ARC_NOFILL indica que el arco o cuerda deberían estar perfilados, no rellenados. IMG_ARC_EDGED, usado junto con IMG_ARC_NOFILL, indica que los ángulos de inicio y finalización deberían estar conectados con el centro - esta es una buena manera de perfilar (en vez de rellenar) un 'trozo de tarta'.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Crear una gráfico de tarta en 3D

<?php

// crear imagen
$imagen = imagecreatetruecolor(100, 100);

// asignar algunos colores
$blanco      = imagecolorallocate($imagen, 0xFF, 0xFF, 0xFF);
$gris        = imagecolorallocate($imagen, 0xC0, 0xC0, 0xC0);
$gris_oscuro = imagecolorallocate($imagen, 0x90, 0x90, 0x90);
$azul_marino = imagecolorallocate($imagen, 0x00, 0x00, 0x80);
$azul_marino_oscuro = imagecolorallocate($imagen, 0x00, 0x00, 0x50);
$rojo        = imagecolorallocate($imagen, 0xFF, 0x00, 0x00);
$rojo_oscuro = imagecolorallocate($imagen, 0x90, 0x00, 0x00);

// hacer el efecto 3D
for ($i = 60; $i > 50; $i--) {
   imagefilledarc($imagen, 50, $i, 100, 50, 0, 45, $azul_marino_oscuro, IMG_ARC_PIE);
   imagefilledarc($imagen, 50, $i, 100, 50, 45, 75 , $gris_oscuro, IMG_ARC_PIE);
   imagefilledarc($imagen, 50, $i, 100, 50, 75, 360 , $rojo_oscuro, IMG_ARC_PIE);
}

imagefilledarc($imagen, 50, 50, 100, 50, 0, 45, $azul_marino, IMG_ARC_PIE);
imagefilledarc($imagen, 50, 50, 100, 50, 45, 75 , $gris, IMG_ARC_PIE);
imagefilledarc($imagen, 50, 50, 100, 50, 75, 360 , $rojo, IMG_ARC_PIE);

// volcar imagen
header('Content-type: image/png');
imagepng($imagen);
imagedestroy($imagen);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Crear un gráfico de tarta en 3D


Dibujar una elipse con relleno

  • « imagefilledarc
  • imagefilledpolygon »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una elipse con relleno

imagefilledellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagefilledellipse — Dibujar una elipse con relleno

Descripción

imagefilledellipse ( resource $image , int $cx , int $cy , int $width , int $height , int $color ) : bool

Dibuja una elipse con centro en las coordenadas especificadas en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

cx

Coordenada x del centro.

cy

Coordenada y del centro.

width

El ancho de la elipse.

height

El alto de la elipse.

color

El color de la elipse. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagefilledellipse()

<?php

// crear una imagen en blanco
$imagen = imagecreatetruecolor(400, 300);

// rellenar el color de fondo
$fondo = imagecolorallocate($imagen, 0, 0, 0);

// elegir un color para la elipse
$col_elipse = imagecolorallocate($imagen, 255, 255, 255);

// dibujar la elipse blanca
imagefilledellipse($imagen, 200, 150, 300, 200, $col_elipse);

// imprimir la imagen
header("Content-type: image/png");
imagepng($imagen);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagefilledellipse()

Notas

Nota:

imagefilledellipse() ignora imagesetthickness().

Ver también

  • imageellipse() - Dibujar una elipse
  • imagefilledarc() - Dibujar un arco parcial y rellenarlo


Dibujar un polígono con relleno

  • « imagefilledellipse
  • imagefilledrectangle »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un polígono con relleno

imagefilledpolygon

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilledpolygon — Dibujar un polígono con relleno

Descripción

imagefilledpolygon ( resource $image , array $points , int $num_points , int $color ) : bool

imagefilledpolygon() crea un polígono relleno en image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

points

Una matriz que contiene las coordenadas x e y de los vértices del polígono consecutivamente.

num_points

Número total de vértices, lo que debe ser al menos 3.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagefilledpolygon()

<?php
// establecer una matriz de puntos para el polígono
$valores = array(
            40,  50,  // Point 1 (x, y)
            20,  240, // Point 2 (x, y)
            60,  60,  // Point 3 (x, y)
            240, 20,  // Point 4 (x, y)
            50,  40,  // Point 5 (x, y)
            10,  10   // Point 6 (x, y)
            );

// crear imagen
$imagen = imagecreatetruecolor(250, 250);

// asignar colores
$fondo   = imagecolorallocate($imagen, 0, 0, 0);
$azul = imagecolorallocate($imagen, 0, 0, 255);

// rellenar el fondo
imagefilledrectangle($imagen, 0, 0, 249, 249, $fondo);

// dibujar un polígono
imagefilledpolygon($imagen, $valores, 6, $azul);

// volcar imagen
header('Content-type: image/png');
imagepng($imagen);
imagedestroy($imagen);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagefilledpolygon()


Dibujar un rectángulo con relleno

  • « imagefilledpolygon
  • imagefilltoborder »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un rectángulo con relleno

imagefilledrectangle

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilledrectangle — Dibujar un rectángulo con relleno

Descripción

imagefilledrectangle ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

Crea un rectángulo relleno con color en image comenzando por el punto 1 y finalizando en el punto 2. 0, 0 es la esquina superior izquierda de la imagen.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x1

Coordenada x del punto 1.

y1

Coordenada y del punto 1.

x2

Coordenada x del punto 2.

y2

Coordenada y del punto 2.

color

El color del relleno. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso de imagefilledrectangle()

<?php
// Crear una imagen de 55x30
$im = imagecreatetruecolor(55, 30);
$blanco = imagecolorallocate($im, 255, 255, 255);

// Dibujar un rectángulo blanco
imagefilledrectangle($im, 4, 4, 50, 25, $blanco);

// Guardar la imagen
imagepng($im, './imagefilledrectangle.png');
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagefilledrectangle()


Rellenar con un color específico

  • « imagefilledrectangle
  • imagefilter »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Rellenar con un color específico

imagefilltoborder

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilltoborder — Rellenar con un color específico

Descripción

imagefilltoborder ( resource $image , int $x , int $y , int $border , int $color ) : bool

imagefilltoborder() realiza un relleno cuyo color de borde está definido por border. El punto de inicio para el relleno es x, y (superior izquierda es 0, 0) y la region es rellenada con el color color.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x

Coordenada x del inicio.

y

Coordenada y del inicio.

border

El color del borde. Un identificador de color creado con imagecolorallocate().

color

El color del relleno. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Rellenar una elipse con un color

<?php
// Crear el gestor de imagen, establecer el fondo a blanco
$im = imagecreatetruecolor(100, 100);
imagefilledrectangle($im, 0, 0, 100, 100, imagecolorallocate($im, 255, 255, 255));

// Dibujar una elipse a rellenar con un borde negro
imageellipse($im, 50, 50, 50, 50, imagecolorallocate($im, 0, 0, 0));

// Establecer los colores del borde y del relleno
$borde = imagecolorallocate($im, 0, 0, 0);
$relleno = imagecolorallocate($im, 255, 0, 0);

// Rellenar la selección
imagefilltoborder($im, 50, 50, $borde, $relleno);

// Imprimir y liberar memoria
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Rellenar una elipse con un color


Aplica un filtro a una imagen

  • « imagefilltoborder
  • imageflip »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Aplica un filtro a una imagen

imagefilter

(PHP 5, PHP 7, PHP 8)

imagefilter — Aplica un filtro a una imagen

Descripción

imagefilter ( resource $image , int $filtertype , int $arg1 = ? , int $arg2 = ? , int $arg3 = ? , int $arg4 = ? ) : bool

imagefilter() aplica el filtro dado por filtertype sobre la imagen image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filtertype

filtertype puede ser lo siguitente:

  • IMG_FILTER_NEGATE: Invierte todos los colores de la imagen.
  • IMG_FILTER_GRAYSCALE: Convierte la imagen a escala de grises.
  • IMG_FILTER_BRIGHTNESS: Cambia el brillo de la imagen. Use arg1 para establecer el nivel de brillo. El rango para el brillo es de -255 a 255.
  • IMG_FILTER_CONTRAST: Cambia el contraste de la imagen. Use arg1 para establecer el nivel de contraste.
  • IMG_FILTER_COLORIZE: Como IMG_FILTER_GRAYSCALE, excepto que se puede especificar el color. Use arg1, arg2 y arg3 en la forma red, green, blue y arg4 para el canal alpha. El rango de cada color es de 0 a 255.
  • IMG_FILTER_EDGEDETECT: Utiliza detección de borde para resaltar los bordes de la imagen.
  • IMG_FILTER_EMBOSS: Pone en relieve la imagen.
  • IMG_FILTER_GAUSSIAN_BLUR: Pone borrosa la imagen usando el método Gaussiano.
  • IMG_FILTER_SELECTIVE_BLUR: Pone borrosa la imagen.
  • IMG_FILTER_MEAN_REMOVAL: Utiliza eliminación media para lograr un efecto "superficial".
  • IMG_FILTER_SMOOTH: Suaviza la imagen. Use arg1 para esteblecer el nivel de suavidad.
  • IMG_FILTER_PIXELATE: Aplica el efecto de pixelación a la imagen, use arg1 para establecer el tamaño de bloque y arg2 para establecer el modo de efecto de pixelación.

arg1

  • IMG_FILTER_BRIGHTNESS: Nivel de brillo.
  • IMG_FILTER_CONTRAST: Nivel de contraste.
  • IMG_FILTER_COLORIZE: Valor del componente rojo.
  • IMG_FILTER_SMOOTH: Nivel de suavidad.
  • IMG_FILTER_PIXELATE: Tamaño de bloque en píxeles.

arg2

  • IMG_FILTER_COLORIZE: Valor del componente verde.
  • IMG_FILTER_PIXELATE: Si usar o no el efecto de pixelación avanzado (por defecto a false).

arg3

  • IMG_FILTER_COLORIZE: Valor del componente azul.

arg4

  • IMG_FILTER_COLORIZE: Canal alfa. Un valor entre 0 y 127. 0 indica completamente opaco mientras que 127 indica completamente transparente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el soporete de pixelación (IMG_FILTER_PIXELATE).
5.2.5 | Se añadió el soporte de alfa para IMG_FILTER_COLORIZE.

Ejemplos

Ejemplo #1 Ejemplo de escala de grises con imagefilter()

<?php
$im = imagecreatefrompng('dave.png');

if($im && imagefilter($im, IMG_FILTER_GRAYSCALE))
{
    echo 'Imagen convertida a escala de grises.';

    imagepng($im, 'dave.png');
}
else
{
    echo 'La conversión a escala de grises falló.';
}

imagedestroy($im);
?>

Ejemplo #2 Ejemplo de brillo con imagefilter()

<?php
$im = imagecreatefrompng('sean.png');

if($im && imagefilter($im, IMG_FILTER_BRIGHTNESS, 20))
{
    echo 'Brillo de la imagen cambiado.';

    imagepng($im, 'sean.png');
    imagedestroy($im);
}
else
{
    echo 'El cambio del brillo de la imagen falló.';
}
?>

Ejemplo #3 Ejemplo de coloración con imagefilter()

<?php
$im = imagecreatefrompng('philip.png');

/* R, G, B, así 0, 255, 0 es verde */
if($im && imagefilter($im, IMG_FILTER_COLORIZE, 0, 255, 0))
{
    echo 'Imagen sombreada a verde con éxito.';

    imagepng($im, 'philip.png');
    imagedestroy($im);
}
else
{
    echo 'El sombreado a verde falló.';
}
?>

Ejemplo #4 Ejemplo de inversión de color con imagefilter()

<?php
// Define nuestra función negativo, así es portable para
// versiones de php sin imagefilter()
function negativo($im)
{
    if(function_exists('imagefilter'))
    {
        return imagefilter($im, IMG_FILTER_NEGATE);
    }

    for($x = 0; $x < imagesx($im); ++$x)
    {
        for($y = 0; $y < imagesy($im); ++$y)
        {
            $index = imagecolorat($im, $x, $y);
            $rgb = imagecolorsforindex($index);
            $color = imagecolorallocate($im, 255 - $rgb['red'], 255 - $rgb['green'], 255 - $rgb['blue']);

            imagesetpixel($im, $x, $y, $color);
        }
    }

    return(true);
}

$im = imagecreatefromjpeg('kalle.jpg');

if($im && negativo($im))
{
    echo 'Imagen convertida a colores negativos con éxtito.';

    imagejpeg($im, 'kalle.jpg', 100);
    imagedestroy($im);
}
else
{
    echo 'La conversión a colores negativos falló.';
}
?>

Ejemplo #5 Ejemplo de pixelación con imagefilter()

<?php
// Cargar el logotipo de PHP, necesitamos crear dos instancias
// para mostrar las diferencias
$logo1 = imagecreatefrompng('./php.png');
$logo2 = imagecreatefrompng('./php.png');

// Crear la instancia de imagen que queremos para mostrar
// las diferencias
$salida = imagecreatetruecolor(imagesx($logo1) * 2, imagesy($logo1));

// Aplicar pixelación a cada instancia, con un tamaño de
// bloque de 3
imagefilter($logo1, IMG_FILTER_PIXELATE, 3);
imagefilter($logo2, IMG_FILTER_PIXELATE, 3, true);

// Fusionar las diferencias a la imagen de salida
imagecopy($salida, $logo1, 0, 0, 0, 0, imagesx($logo1) - 1, imagesy($logo1) - 1);
imagecopy($salida, $logo2, imagesx($logo2), 0, 0, 0, imagesx($logo2) - 1, imagesy($logo2) - 1);
imagedestroy($logo1);
imagedestroy($logo2);

// Imprimir las diferencias
header('Content-Type: image/png');
imagepng($salida);
imagedestroy($salida);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Pixelación con imagefilter()

Notas

Ver también

  • imageconvolution() - Aplicar una matriz de convolución de 3x3, usando coeficiente e índice


Flips an image using a given mode

  • « imagefilter
  • imagefontheight »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Flips an image using a given mode

imageflip

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageflip — Flips an image using a given mode

Descripción

imageflip ( resource $image , int $mode ) : bool

Voltea la imagen dada por image usando el modo dado por mode.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

mode

Modo de volteo; puede ser una de las constantes IMG_FLIP_*:

Constante | Significado
IMG_FLIP_HORIZONTAL | Voltea la imagen horizontalmente.
IMG_FLIP_VERTICAL | Voltea la imagen verticalmente.
IMG_FLIP_BOTH | Voltea la imagen tanto horizontal como verticalmente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Voltea una imagen verticalmente

Este ejemplo utiliza la constante IMG_FLIP_VERTICAL.

<?php
// Fichero
$nombre_fichero = 'phplogo.png';

// Tipo de contenido
header('Content-type: image/png');

// Cargar
$im = imagecreatefrompng($nombre_fichero);

// Voltearla verticalmente
imageflip($im, IMG_FLIP_VERTICAL);

// Imprimirla
imagejpeg($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo: Imagen volteada verticalmente

Ejemplo #2 Voltea la imagen horizontalmente

Este ejemplo utiliza la constante IMG_FLIP_HORIZONTAL.

<?php
// Fichero
$nombre_fichero = 'phplogo.png';

// Tipo de contenido
header('Content-type: image/png');

// Cargar
$im = imagecreatefrompng($nombre_fichero);

// Voltearla horizontalmente
imageflip($im, IMG_FLIP_HORIZONTAL);

// Imprimirla
imagejpeg($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo: Imagen volteada horizontalmente


Obtener el alto de la fuente

  • « imageflip
  • imagefontwidth »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el alto de la fuente

imagefontheight

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefontheight — Obtener el alto de la fuente

Descripción

imagefontheight ( int $font ) : int

Devuelve el alto del píxel de un carácter de la fuente especificada.

Parámetros

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

Valores devueltos

Devuelve el alto de píxel de la fuente.

Ejemplos

Ejemplo #1 Usar imagefontheight() con fuentes incorporadas

<?php
echo 'Alto de la fuente: ' . imagefontheight(4);
?>

El resultado del ejemplo sería algo similar a:

Font height: 16

Ejemplo #2 Usar imagefontheight() junto con imageloadfont()

<?php
// Cargar una fuente .gdf
$font = imageloadfont('anonymous.gdf');

echo 'Alto de la fuente: ' . imagefontheight($font);
?>

El resultado del ejemplo sería algo similar a:

Font height: 43

Ver también

  • imagefontwidth() - Obtener el ancho de la fuente
  • imageloadfont() - Cargar una nueva fuente


Obtener el ancho de la fuente

  • « imagefontheight
  • imageftbbox »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el ancho de la fuente

imagefontwidth

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefontwidth — Obtener el ancho de la fuente

Descripción

imagefontwidth ( int $font ) : int

Devuelve el ancho del píxel de un carácter de una fuente.

Parámetros

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

Valores devueltos

Devuelve el ancho de píxel de la fuente.

Ejemplos

Ejemplo #1 Usar imagefontwidth() con fuentes incorporadas

<?php
echo 'Alto de la fuente: ' . imagefontwidth(4);
?>

El resultado del ejemplo sería algo similar a:

Font width: 8

Ejemplo #2 Usar imagefontwidth() junto con imageloadfont()

<?php
// Cargar una fuente .gdf
$font = imageloadfont('anonymous.gdf');

echo 'Alto de la fuente: ' . imagefontwidth($font);
?>

El resultado del ejemplo sería algo similar a:

Font width: 23

Ver también

  • imagefontheight() - Obtener el alto de la fuente
  • imageloadfont() - Cargar una nueva fuente


Devolver la caja circundante de un texto usando fuentes mediante FreeType 2

  • « imagefontwidth
  • imagefttext »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Devolver la caja circundante de un texto usando fuentes mediante FreeType 2

imageftbbox

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imageftbbox — Devolver la caja circundante de un texto usando fuentes mediante FreeType 2

Descripción

imageftbbox ( float $size , float $angle , string $fontfile , string $text , array $extrainfo = ? ) : array

Esta función calcula y devuelve la caja circundante en píxeles de un texto FreeType.

Parámetros

size

Tamaño de fuente en puntos.

angle

Ángulo en grados en el que text será medido.

fontfile

El nombre de un archivo de fuente TrueType (puede ser una URL). Dependiendo de la versión de la biblioteca GD que esté usando PHP, se intentará buscar archivos que no comiencen con '/' añadiendo '.ttf' al nombre de archivo y buscando en una ruta de biblioteca definida de fuentes.

text

La cadena que va a ser medida.

extrainfo

Posibles índeces de matriz para extrainfo
Clave | Tipo | Significado
linespacing | float | Define el espacio entre líneas

Valores devueltos

imageftbbox() devuelve una matriz con 8 elementos que representan cuatro puntos que hacen la caja circundante del texto:

0 | esquina inferior izquierda, posición X
1 | esquina inferior izquierda, posición Y
2 | esquina inferior derecha, posición X
3 | esquina inferior derecha, posición Y
4 | esquina superior derecha, posición X
5 | esquina superior derecha, posición Y
6 | esquina superior izquierda, posición X
7 | esquina superior izquierda posición Y

Los puntos son relativos a text sin importar el ángulo angle, por lo que "superior izquierda" significa la esquina superior izquierda, viendo el texto horizontalmente.

Ejemplos

Ejemplo #1 Ejemplo de imageftbbox()

<?php
// Crear una imagen de 300x150
$im = imagecreatetruecolor(300, 150);
$negro = imagecolorallocate($im, 0, 0, 0);
$blanco = imagecolorallocate($im, 255, 255, 255);

// Establecer el fondo a blanco
imagefilledrectangle($im, 0, 0, 299, 299, $blanco);

// Ruta de nuestro archivo de fuente
$fuente = './arial.ttf';

// Priemero creamos nuestra caja circundante
$bbox = imageftbbox(10, 0, $fuente, 'The PHP Documentation Group');

// Estas son nuestras coordenadas para X e Y
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) - 5;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

imagefttext($im, 10, 0, $x, $y, $negro, $fuente, 'The PHP Documentation Group');

// Imprimir al navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notas

Nota: Esta función sólo está disponible si PHP fue compilado con suporte de freetype (--with-freetype-dir=DIR)


Escribir texto en la imagen usando fuentes mediante FreeType 2

  • « imageftbbox
  • imagegammacorrect »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Escribir texto en la imagen usando fuentes mediante FreeType 2

imagefttext

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagefttext — Escribir texto en la imagen usando fuentes mediante FreeType 2

Descripción

imagefttext ( resource $image , float $size , float $angle , int $x , int $y , int $color , string $fontfile , string $text , array $extrainfo = ? ) : array

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

size

El tamaño de la fuente que va a ser usada, en puntos.

angle

El ángulo en grados, siendo 0 grados la lectura del texto de izquierda a derecha. Valores mayores representan una rotación en sentido contrario al de las agujas del reloj. Por ejemplo, un valor de 90 resultaria en la lectura de texto de abajo a arriba.

x

Las coordenadas dadas por x e y definirán el punto de referencia del primer carácter (aproximadamente la esquina inferior izquierda del carácter). Esto es diferente de imagestring(), donde x e y definen la esquina superior izquierda del primer carácter. Por ejemplo, "superior izquierda" es 0, 0.

y

La coordenada y. Esto establece la posición de la línea base de las fuentes, no la del pie del carácter.

color

El índice del color deseado para el texto, véase imagecolorexact().

fontfile

La ruta de la fuente TrueType que se desea usar.

Dependiendo de la versión de GD que esté usando PHP, cuando fontfile no comienza con un / inicial, .ttf será añadido al nombre de archivo, y la biblioteca intentará buscar ese nombre de archivo en una ruta de biblioteca definida de fuentes.

Cuando se usan versiones de la biblioteca GD anteriores a 2.0.18, un carácter espacio, en vez de un punto y coma, es usado como el 'separador de ruta' para diferentes archivos de fuente. El uso involuntario de esta característica resultará en en el mensaje de advertencia: Warning: Could not find/open font. La única solución para estas versiones afectadas es mover la fuente a una ruta que no contenga espacios.

En muchos casos donde una fuente reside en el mismo derectorio que el script, el siguiente truco paliará cualquier problema de inclusión.

<?php
// Establecer la variable de entorno para GD
putenv('GDFONTPATH=' . realpath('.'));

// Nombrar la fuente que va ser usada (observe la ausencia de la extensión .ttf)
$fuente = 'UnaFuente';
?>

text

Texto que va a ser insertado en la imagen.

extrainfo

Posibles índeces de matriz para extrainfo
Clave | Tipo | Significado
linespacing | float | Define el espacio entre líneas

Valores devueltos

Esta función devuelve una matriz que define los cuatro puntos de la caja, comenzado por el inferior izquierdo y moviéndose en el sentido de las agujas del reloj:

0 | esquina inferior izquierda, posición X
1 | esquina inferior izquierda, posición Y
2 | esquina inferior derecha, posición X
3 | esquina inferior derecha, posición Y
4 | esquina superior derecha, posición X
5 | esquina superior derecha, posición Y
6 | esquina superior izquierda, posición X
7 | esquina superior izquierda posición Y

Ejemplos

Ejemplo #1 Ejemplo de imagefttext()

<?php
// Crear una imagen de 300x100
$im = imagecreatetruecolor(300, 100);
$rojo = imagecolorallocate($im, 0xFF, 0x00, 0x00);
$negro = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Hacer el fondo rojo
imagefilledrectangle($im, 0, 0, 299, 99, $rojo);

// Ruta a nuestro archivo de fuente ttf
$archivo_fuente = './arial.ttf';

// Dibuja el texto 'PHP Manual' usando un tamaño de fuente de 13
imagefttext($im, 13, 0, 105, 55, $negro, $archivo_fuente, 'PHP Manual');

// Imprimir la imagen al navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notas

Nota: Esta función sólo está disponible si PHP fue compilado con suporte de freetype (--with-freetype-dir=DIR)


Aplicar una corrección gamma a la imagen GD

  • « imagefttext
  • imagegd2 »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Aplicar una corrección gamma a la imagen GD

imagegammacorrect

(PHP 4, PHP 5, PHP 7, PHP 8)

imagegammacorrect — Aplicar una corrección gamma a la imagen GD

Descripción

imagegammacorrect ( resource $image , float $inputgamma , float $outputgamma ) : bool

Aplica una corrección gamma a image, dada una entrada y una salida gamma.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

inputgamma

La entrada gamma.

outputgamma

La salida gamma.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso de imagegammacorrect()

<?php
// Crear una instancia de imagen
$im = imagecreatefromgif('php.gif');

// Corregir gamma, salida = 1.537
imagegammacorrect($im, 1.0, 1.537);

// Guardar y liberar memoria
imagegif($im, './php_gamma_corrected.gif');
imagedestroy($im);
?>


Imprime una imagen GD2 a un navegador o fichero

  • « imagegammacorrect
  • imagegd »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Imprime una imagen GD2 a un navegador o fichero

imagegd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagegd2 — Imprime una imagen GD2 a un navegador o fichero

Descripción

imagegd2 ( resource $image , mixed $to = NULL , int $chunk_size = 128 , int $type = IMG_GD2_RAW ) : bool

Genera una imagen GD2 en el parámetro to.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

to

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

chunk_size

Tamaño del trozo.

type

Puede ser IMG_GD2_RAW o IMG_GD2_COMPRESSED. Por defecto es IMG_GD2_RAW.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió soporte para pasar un resource de flujo a to.

Ejemplos

Ejemplo #1 Imprimir una imagen GD2

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "Una Sencilla Cadena De Texto", $color_texto);

// Imprimir la imagen
imagegd2($im);

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #2 Guardar una imagen GD2

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "Una Sencilla Cadena De Texto", $color_texto);

// Guardar la imagen gd2
// El formato de fichero para imágenes GD2 es .gd2, véase http://www.libgd.org/GdFileFormats
imagegd2($im, 'simple.gd2');

// Liberar memoria
imagedestroy($im);
?>

Notas

Nota:

El formato GD2 se usa comúnmente para permitir una carga rápida de partes de imágenes. Observe que el formato GD2 sólo es utilizable en aplicaciones compatibles con GD2.

Ver también

  • imagegd() - Imprime una imagen GD2 a un navegador o archivo


Imprime una imagen GD2 a un navegador o archivo

  • « imagegd2
  • imagegetclip »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Imprime una imagen GD2 a un navegador o archivo

imagegd

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagegd — Imprime una imagen GD2 a un navegador o archivo

Descripción

imagegd ( resource $image , string $filename = ? ) : bool

Imprime una imagen GD en filename.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Imprimir una imagen GD

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "Una Sencilla Cadena De Texto", $color_texto);

// Imprimir la imagen
imagegd($im);

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #2 Saving a GD image

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "Una Sencilla Cadena De Texto", $color_texto);

// Guardar la imagen gd
// El formato de archivo para imágenes GD es .gd, véase http://www.libgd.org/GdFileFormats
imagegd($im, 'simple.gd');

// Liberar memoria
imagedestroy($im);
?>

Notas

Nota:

El formato GD2 se usa comúnmente para permitir una carga rápida de partes de imágenes. Observe que el formato GD2 sólo es utilizable en aplicaciones compatibles con GD2.

Ver también

  • imagegd2() - Imprime una imagen GD2 a un navegador o fichero


Get the clipping rectangle

  • « imagegd
  • imagegetinterpolation »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Get the clipping rectangle

imagegetclip

(PHP 7 >= 7.2.0, PHP 8)

imagegetclip — Get the clipping rectangle

Descripción

imagegetclip ( resource $im ) : array

imagegetclip() retrieves the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

The function returns an indexed array with the coordinates of the clipping rectangle which has the following entries:

  • x-coordinate of the upper left corner
  • y-coordinate of the upper left corner
  • x-coordinate of the lower right corner
  • y-coordinate of the lower right corner

Ejemplos

Ejemplo #1 imagegetclip() example

Setting and retrieving the clipping rectangle.

<?php
$im = imagecreate(100, 100);
imagesetclip($im, 10,10, 89,89);
print_r(imagegetclip($im));

El resultado del ejemplo sería:

Array
(
    [0] => 10
    [1] => 10
    [2] => 89
    [3] => 89
)

Ver también

  • imagesetclip() - Set the clipping rectangle


Get the interpolation method

  • « imagegetclip
  • imagegif »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Get the interpolation method

imagegetinterpolation

(PHP 8)

imagegetinterpolation — Get the interpolation method

Descripción

imagegetinterpolation ( GdImage $image ) : int

Gets the currently set interpolation method of the image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Returns the interpolation method.

Ver también

  • imagesetinterpolation() - Establecer el método de interpolación


Exportar la imagen al navegador o a un fichero

  • « imagegetinterpolation
  • imagegrabscreen »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Exportar la imagen al navegador o a un fichero

imagegif

(PHP 4, PHP 5, PHP 7, PHP 8)

imagegif — Exportar la imagen al navegador o a un fichero

Descripción

imagegif ( resource $image , string $filename = ? ) : bool

imagegif() crea el archivo GIF en filename desde la imagen image. El argumento image es el devuelto por la función imagecreate() o imagecreatefrom*.

El formato de la imagen será GIF87a a menos que la imagen haya sido hecha transparente con imagecolortransparent(), en cuyo caso el formato de la imagen será GIF89a.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Imprimir una imagen usando imagegif()

<?php
// Crear una nueva instancia de imagen
$im = imagecreatetruecolor(100, 100);

// Hacer el fondo blanco
imagefilledrectangle($im, 0, 0, 99, 99, 0xFFFFFF);

// Dibujar una cadena de texto en la imagen
imagestring($im, 3, 40, 20, 'Biblioteca GD', 0xFFBA00);

// Imprimir la imagen al navegador
header('Content-Type: image/gif');

imagegif($im);
imagedestroy($im);
?>

Ejemplo #2 Convertir una imagen PNG en GIF usando imagegif()

<?php

// Cargar el PNG
$png = imagecreatefrompng('./php.png');

// Guardar la imagen como un GIF
imagegif($png, './php.gif');

// Liberar memoria
imagedestroy($png);

// Hemos acabado
echo '¡La converisón de la imagen PNG a GIF tuvo éxtio!';
?>

Notas

Nota:

El soporte para GIF se eliminó de la biblioteca GD en la Versión 1.6, y se volvió a añdir en la Versión 2.0.28. Esta función no está disponible entre estas versiones. Para más información vea el portal del » Proyecto GD.

El siguiente trozo de código permite escribir apliaciones PHP más portables, autodetectando el tipo de soporte de GD que está disponible. Reemplace la secuencia header ("Content-Type: image/gif"); imagegif ($im); por la secuencia más flexible:

<?php
// Crear una nueva instancia de imagen
$im = imagecreatetruecolor(100, 100);

// Hacer algunas operaciones con la imagen aquí

// Gestionar la salida
if(function_exists('imagegif'))
{
    // Para GIF
    header('Content-Type: image/gif');

    imagegif($im);
}
elseif(function_exists('imagejpeg'))
{
    // Para JPEG
    header('Content-Type: image/jpeg');

    imagejpeg($im, NULL, 100);
}
elseif(function_exists('imagepng'))
{
    // Para PNG
    header('Content-Type: image/png');

    imagepng($im);
}
elseif(function_exists('imagewbmp'))
{
    // Para WBMP
    header('Content-Type: image/vnd.wap.wbmp');

    imagewbmp($im);
}
else
{
    imagedestroy($im);

    die('No hay soporte de imagen en este servidor PHP');
}

// Si se encontró soporte para imágenes de uno de estos
// cuatro formatos, se libera de la memoria
if($im)
{
    imagedestroy($im);
}
?>

Nota:

A partir de PHP 4.0.2 se puede usar la funcion imagetypes() en lugar de function_exists() para verificar la presencia de los distintos formatos de imagen soportados:

<?php
if(imagetypes() & IMG_GIF)
{
    header('Content-Type: image/gif');
    imagegif($im);
}
elseif(imagetypes() & IMG_JPG)
{
    /* ... etc. */
}
?>

Ver también

  • imagepng() - Imprimir una imagen PNG al navegador o a un archivo
  • imagewbmp() - Exportar la imagen al navegador o a un fichero
  • imagejpeg() - Exportar la imagen al navegador o a un fichero
  • imagetypes() - Devolver los tipos de imagen soportados por la versión actual de PHP


Capturar la pantalla completa

  • « imagegif
  • imagegrabwindow »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Capturar la pantalla completa

imagegrabscreen

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

imagegrabscreen — Capturar la pantalla completa

Descripción

imagegrabscreen ( ) : resource

Toma una captura de pantalla de la pantalla completa.

Valores devueltos

Devuelve un identificador de recurso de imagen si tiene éxito, false si falló.

Ejemplos

Ejemplo #1 Ejemplo de imagegrabscreen()

Este ejemplo demuestra cómo tomar una captura de pantalla de la pantalla actual y guardarla como una imagen png.

<?php
$im = imagegrabscreen();
imagepng($im, "mi_captura_de_pantalla.png");
imagedestroy($im);
?>

Notas

Nota:

Esta función sólo está disponible en Windows.

Ver también

  • imagegrabwindow() - Capturar una ventana


Capturar una ventana

  • « imagegrabscreen
  • imageinterlace »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Capturar una ventana

imagegrabwindow

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

imagegrabwindow — Capturar una ventana

Descripción

imagegrabwindow ( int $window_handle , int $client_area = 0 ) : resource

Captura una ventana o su área de cliente usando un gestor de ventanas (la propiedad HWND en instancia COM)

Parámetros

window_handle

El ID del HWND de ventana.

client_area

Incluye el área del cliente de la ventana de aplicación.

Valores devueltos

Devuelve un identificador de recurso de imagen si tiene éxito, false si falló.

Errores/Excepciones

E_NOTICE es emitido si window_handle no es un gestor de ventana válido. E_WARNING es emitido si la API de Windows es demasiado antigua.

Ejemplos

Ejemplo #1 Ejemplo de imagegrabwindow()

Capturar una ventana (IE por ejemplo)

<?php
$navegador = new COM("InternetExplorer.Application");
$gestor = $navegador->HWND;
$navegador->Visible = true;
$im = imagegrabwindow($gestor);
$navegador->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

Capturar una ventana (IE por ejemplo) pero con su contenido

<?php
$navegador = new COM("InternetExplorer.Application");
$gestor = $navegador->HWND;
$navegador->Visible = true;
$navegador->Navigate("http://www.libgd.org");

/* ¿Todavía funciona? */
while ($navegador->Busy) {
    com_message_pump(4000);
}
$im = imagegrabwindow($gestor, 0);
$navegador->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

Notas

Nota:

Esta función sólo está disponible en Windows.

Ver también

  • imagegrabscreen() - Capturar la pantalla completa


Habilitar o deshabilitar en entrelazamiento

  • « imagegrabwindow
  • imageistruecolor »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Habilitar o deshabilitar en entrelazamiento

imageinterlace

(PHP 4, PHP 5, PHP 7, PHP 8)

imageinterlace — Habilitar o deshabilitar en entrelazamiento

Descripción

imageinterlace ( resource $image , int $interlace = 0 ) : int

imageinterlace() activa o desactiva el bit de entrelazamiento.

Si el bit de entrelazamiento está establecido y la imagen es usada como una imagen JPEG, la imagen es creada como un JPEG progresivo.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

interlace

Si no es cero, la imagen será entrelazada, si no, el bit de entrelazamiento será desactivado.

Valores devueltos

Devuelve 1 si el bit de entrelazamiento está establecido para la imagen, 0 si no.

Ejemplos

Ejemplo #1 Activar el entrelazamiento usando imageinterlace()

<?php
// Crear una instancia de imagen
$im = imagecreatefromgif('php.gif');

// Habilitar el entrelazamiento
imageinterlace($im, true);

// Guardar la imagen entrelazada
imagegif($im, './php_entrelazada.gif');
imagedestroy($im);
?>


Averiguar si una imagen es de color verdadero

  • « imageinterlace
  • imagejpeg »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Averiguar si una imagen es de color verdadero

imageistruecolor

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imageistruecolor — Averiguar si una imagen es de color verdadero

Descripción

imageistruecolor ( resource $image ) : bool

imageistruecolor() averigua si la imagen image es una imagen de color verdadero.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Devuelve true si image es de color verdadero, false si no.

Ejemplos

Ejemplo #1 Simple detección de instancias de imagen de color verdadero usando imageistruecolor()

<?php
// $im es una instancia de imagen

// Comprobar si la imagen es de color verdadero o no
if(!imageistruecolor($im))
{
    // Crear una nueva instancia de imagen de color verdadero
    $tc = imagecreatetruecolor(imagesx($im), imagesy($im));

    // Copiar sobre los píxeles
    imagecopy($tc, $im, 0, 0, 0, 0, imagesx($im), imagesy($im));
    imagedestroy($im);

    $im = $tc;
    $tc = NULL;

    // O usar imagepalettetotruecolor()
}

// Continuar trabajando con la instancia de imagen
?>

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • imagepalettetotruecolor() - Convierte una imagen basada en paleta a color verdadero


Exportar la imagen al navegador o a un fichero

  • « imageistruecolor
  • imagelayereffect »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Exportar la imagen al navegador o a un fichero

imagejpeg

(PHP 4, PHP 5, PHP 7, PHP 8)

imagejpeg — Exportar la imagen al navegador o a un fichero

Descripción

imagejpeg ( resource $image , mixed $to = ? , int $quality = ? ) : bool

imagejpeg() crea un archivo JPEG desde image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

to

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

Para saltarse este argumeto para proporcionar el parámetro quality, use null.

quality

quality es opcional, y su valor es desde 0 (peor calidad, archivo más pequeño) a 100 (mejor calidad, archivo más grande). El valor por defecto es el valor de calidad predeterminada de IJG (sobre 75).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Imprimir una imagen JPEG

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Establecer la cabecera de tipo de contenido - en este caso image/jpeg
header('Content-Type: image/jpeg');

// Imprimir la imagen
imagejpeg($im);

// Liberar memoria
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Imprimir una imagen JPEG

Ejemplo #2 Guardar una imagen JPEG

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'Una Sencilla Cadena De Texto', $color_texto);

// Guardar la imagen como 'textosimple.jpg'
imagejpeg($im, 'textosimple.jpg');

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #3 Imprimir la imagen al 75% de calidad

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'Una Sencilla Cadena De Texto', $color_texto);

// Establecer la cabecera de tipo de contenido - en este caso image/jpeg
header('Content-Type: image/jpeg');

// Saltarse el parámetro 'to' usando NULL, después establecer la calidad al 75%
imagejpeg($im, NULL, 75);

// Liberar memoria
imagedestroy($im);
?>

Notas

Nota:

Si quiere imprimir imágenes JPEG Progresivas, necesita habilitar el entrelazamiento con imageinterlace().

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió soporte para pasar un resource de flujo a to.
5.4.0 | Se deshabilitó el paso de un string vacío a filename para saltar este argumeto.

Ver también

  • imagepng() - Imprimir una imagen PNG al navegador o a un archivo
  • imagegif() - Exportar la imagen al navegador o a un fichero
  • imagewbmp() - Exportar la imagen al navegador o a un fichero
  • imageinterlace() - Habilitar o deshabilitar en entrelazamiento
  • imagetypes() - Devolver los tipos de imagen soportados por la versión actual de PHP


Establecer la bandera de mezcla alfa para usar los efectos de capa

  • « imagejpeg
  • imageline »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer la bandera de mezcla alfa para usar los efectos de capa

imagelayereffect

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagelayereffect — Establecer la bandera de mezcla alfa para usar los efectos de capa

Descripción

imagelayereffect ( resource $image , int $effect ) : bool

Establece la bandera de mezcla alfa para usar los efectos de capa.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

effect

Una de las siguientes constantes:

IMG_EFFECT_REPLACE
Usar el píxel de sustitución (equivalente a pasar true a imagealphablending())
IMG_EFFECT_ALPHABLEND
Unsar la mezcla de píxel normal (equivalente a pasar true a imagealphablending())
IMG_EFFECT_NORMAL
Lo mismo que IMG_EFFECT_ALPHABLEND.
IMG_EFFECT_OVERLAY
La capa de revestimieto tiene el efecto de que los píxeles del fondo negro permanecerán negros, los píxeles del fondo blanco permanecerán blancos, pero los los píxeles del fondo gris tomarán el color del píxel del primer plano.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagelayereffect()

<?php
// Establecer una imagen
$im = imagecreatetruecolor(100, 100);

// Establecer un fondo
imagefilledrectangle($im, 0, 0, 100, 100, imagecolorallocate($im, 220, 220, 220));

// Aplicar la bandera de la capa de revestimiento de la mezcla alfa
imagelayereffect($im, IMG_EFFECT_OVERLAY);

// Dibujar dos elipses grises
imagefilledellipse($im, 50, 50, 40, 40, imagecolorallocate($im, 100, 255, 100));
imagefilledellipse($im, 50, 50, 50, 80, imagecolorallocate($im, 100, 100, 255));
imagefilledellipse($im, 50, 50, 80, 50, imagecolorallocate($im, 255, 100, 100));

// Imprimir
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagelayereffect()

Notas

Antes de PHP 5.5.0, esta función solamente está disponible si PHP se compiló con la versión integrada de la biblioteca GD.


Dibujar una línea

  • « imagelayereffect
  • imageloadfont »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una línea

imageline

(PHP 4, PHP 5, PHP 7, PHP 8)

imageline — Dibujar una línea

Descripción

imageline ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

Dibuja una línea entre dos puntos dados.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x1

Coordenada x del primer punto.

y1

Coordenada y del primer punto.

x2

Coordenada x del segundo punto.

y2

Coordenada y del segundo punto.

color

El color de la línea. Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Dibujar una línea gruesa

<?php

function imagelinethick($imagen, $x1, $y1, $x2, $y2, $color, $grueso = 1)
{
    /* esta forma funciona bien sólo para líneas ortogonales
    imagesetthickness($imagen, $grueso);
    return imageline($imagen, $x1, $y1, $x2, $y2, $color);
    */
    if ($grueso == 1) {
        return imageline($imagen, $x1, $y1, $x2, $y2, $color);
    }
    $t = $grueso / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($imagen, round(min($x1, $x2) - $t), round(min($y1, $y2) - $t), round(max($x1, $x2) + $t), round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $puntos = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($imagen, $puntos, 4, $color);
    return imagepolygon($imagen, $puntos, 4, $color);
}

?>

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • imagecolorallocate() - Asigna un color para una imagen


Cargar una nueva fuente

  • « imageline
  • imageopenpolygon »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Cargar una nueva fuente

imageloadfont

(PHP 4, PHP 5, PHP 7, PHP 8)

imageloadfont — Cargar una nueva fuente

Descripción

imageloadfont ( string $file ) : int

imageloadfont() carga un mapa de bits definido por el usuario y devuelve su identificador.

Parámetros

file

El formato del archivo de fuente actualmente es binario y dependiente de la arquitectura. Esto significa que debería generar los archivos de fuente en el mismo tipo de CPU de la máquina donde se está ejecutando PHP.

Formato de archivo de fuente
posición de byte | tipo | descripción
byte 0-3 | int | número de caracteres en la fuente
byte 4-7 | int | valor del primer carácter de la fuente (a menudo 32 para el espacio)
byte 8-11 | int | ancho de píxel de cada carácter
byte 12-15 | int | alto de píxel de cada carácter
byte 16- | char | matriz con la información de los caracteres, un byte por píxel en cada carácter, para un total de (ncars*ancho*alto) bytes.

Valores devueltos

El identificador de fuente que es siempre mayor que 5 para evitar conflictos con fuentes incluidas, o false si se produjeron errores.

Ejemplos

Ejemplo #1 Ejemplo de uso de imageloadfont()

<?php
// Crear una nueva instancia de imagen
$im = imagecreatetruecolor(50, 20);
$negro = imagecolorallocate($im, 0, 0, 0);
$blanco = imagecolorallocate($im, 255, 255, 255);

// Hacer el fondo blanco
imagefilledrectangle($im, 0, 0, 49, 19, $blanco);

// Cargar la fuente gd y escribir 'Hola'
$fuente = imageloadfont('./04b.gdf');
imagestring($im, $fuente, 0, 0, 'Hola', $negro);

// Imprimir al navegador
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ver también

  • imagefontwidth() - Obtener el ancho de la fuente
  • imagefontheight() - Obtener el alto de la fuente


Draws an open polygon

  • « imageloadfont
  • imagepalettecopy »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Draws an open polygon

imageopenpolygon

(PHP 7 >= 7.2.0, PHP 8)

imageopenpolygon — Draws an open polygon

Descripción

imageopenpolygon ( resource $image , array $points , int $num_points , int $color ) : bool

Alternative signature (as of PHP 8.0.0)

imageopenpolygon ( resource $image , array $points , int $color ) : bool

imageopenpolygon() draws an open polygon on the given image. Contrary to imagepolygon(), no line is drawn between the last and the first point.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

points

An array containing the polygon's vertices, e.g.:

points[0] | = x0
points[1] | = y0
points[2] | = x1
points[3] | = y1

num_points

Total number of points (vertices), which must be at least 3.

If this parameter is omitted as per the second signature, points must have an even number of elements, and num_points is assumed to be count($points)/2.
color

Un identificador de color creato con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 imageopenpolygon() example

<?php
// Create a blank image
$image = imagecreatetruecolor(400, 300);

// Allocate a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// Draw the polygon
imageopenpolygon($image, array(
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $col_poly);

// Output the picture to the browser
header('Content-type: image/png');

imagepng($image);
imagedestroy($image);
?>

El resultado del ejemplo sería algo similar a:

Output of example : imageopenpolygon()

Ver también

  • imagepolygon() - Dibujar un polígono


Copiar la paleta de una imagen a otra

  • « imageopenpolygon
  • imagepalettetotruecolor »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Copiar la paleta de una imagen a otra

imagepalettecopy

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagepalettecopy — Copiar la paleta de una imagen a otra

Descripción

imagepalettecopy ( resource $destination , resource $source ) : void

imagepalettecopy() copia la paleta de la imagen source a la imagen destination.

Parámetros

destination

El recurso de imagen de destino.

source

El recurso de imagen de origen.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de imagepalettecopy()

<?php
// Crear dos imágenes de paleta
$paleta1 = imagecreate(100, 100);
$paleta2 = imagecreate(100, 100);

// Asignar verde al fondo
// en la primera imagen de paleta
$verde = imagecolorallocate($paleta1, 0, 255, 0);

// Copiar la paleta de la imagen 1 a la imagen 2
imagepalettecopy($paleta2, $paleta1);

// Ya que la paleta ha sido copiada podemos usar el
// color verde asignado a la imagen 1 sin usar
// imagecolorallocate() dos veces
imagefilledrectangle($paleta2, 0, 0, 99, 99, $verde);

// Imprimir la imagen en el navegdor
header('Content-type: image/png');

imagepng($paleta2);
imagedestroy($paleta1);
imagedestroy($paleta2);
?>


Convierte una imagen basada en paleta a color verdadero

  • « imagepalettecopy
  • imagepng »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Convierte una imagen basada en paleta a color verdadero

imagepalettetotruecolor

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagepalettetotruecolor — Convierte una imagen basada en paleta a color verdadero

Descripción

imagepalettetotruecolor ( resource $src ) : bool

Convierte una imagen basada en paleta, creada por funciones como imagecreate(), a una imagen de color verdadero, como imagecreatetruecolor().

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Devuelve true si la conversión se completó, o si la imagen origen ya era una imagen de color verdadero; de otro modo devuelve false.

Ejemplos

Ejemplo #1 Convertir cualquier recurso de imagaen a color verdadero

<?php
// Retrocompatiblidad
if(!function_exists('imagepalettetotruecolor'))
{
    function imagepalettetotruecolor(&$src)
    {
        if(imageistruecolor($src))
        {
            return(true);
        }

        $dst = imagecreatetruecolor(imagesx($src), imagesy($src));

        imagecopy($dst, $src, 0, 0, 0, 0, imagesx($src), imagesy($src));
        imagedestroy($src);

        $src = $dst;

        return(true);
    }
}

// Cierre asistente
$typeof = function() use($im)
{
    echo 'typeof($im) = ' . (imageistruecolor($im) ? 'true color' : 'palette'), PHP_EOL;
};

// Crear una imagen basada en paleta
$im = imagecreate(100, 100);
$typeof();

// Convertirla a color verdadero
imagepalettetotruecolor($im);
$typeof();

// Liberar la memoria
imagedestroy($im);
?>

El resultado del ejemplo sería:

typeof($im) = palette
typeof($im) = true color

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • imageistruecolor() - Averiguar si una imagen es de color verdadero


Imprimir una imagen PNG al navegador o a un archivo

  • « imagepalettetotruecolor
  • imagepolygon »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Imprimir una imagen PNG al navegador o a un archivo

imagepng

(PHP 4, PHP 5, PHP 7, PHP 8)

imagepng — Imprimir una imagen PNG al navegador o a un archivo

Descripción

imagepng ( resource $image , string $filename = ? , int $quality = ? , int $filters = ? ) : bool

Imprime o guarda una imagen PNG desde image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

Nota:

null no es válido si los argumentos quality y filters no son usados.

quality

Nivel de compresión: desde 0 (sin compresión) hasta 9.

filters

Permite reducir el tamaño del archivo PNG. Es un campo de máscara de bit que puede ser establecido a cualquier combinación de las constantes PNG_FILTER_XXX. PNG_NO_FILTER o PNG_ALL_FILTERS también se pueden usar para, respectivamente, desactivar o activar todos los filtros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.1.3 | Añadido el parámetro filters.
5.1.2 | Añadido el parámetro quality.

Ejemplos

<?php
$im = imagecreatefrompng("prueba.png");

header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ver también

  • imagegif() - Exportar la imagen al navegador o a un fichero
  • imagewbmp() - Exportar la imagen al navegador o a un fichero
  • imagejpeg() - Exportar la imagen al navegador o a un fichero
  • imagetypes() - Devolver los tipos de imagen soportados por la versión actual de PHP
  • imagesavealpha() - Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG


Dibujar un polígono

  • « imagepng
  • imagerectangle »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar un polígono

imagepolygon

(PHP 4, PHP 5, PHP 7, PHP 8)

imagepolygon — Dibujar un polígono

Descripción

imagepolygon ( resource $image , array $points , int $num_points , int $color ) : bool

imagepolygon() crea un polígono en la imagen image dada.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

points

Una matriz que contiene los vértices del polígono, p.ej.:

puntos[0] | = x0
puntos[1] | = y0
puntos[2] | = x1
puntos[3] | = y1

num_points

Número total de puntos (vértices).

color

Un indentificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagepolygon()

<?php
// Crear una imágen en blanco
$imagen = imagecreatetruecolor(400, 300);

// Asignar un color para el polígono
$col_poli = imagecolorallocate($imagen, 255, 255, 255);

// Dibujar el polígono
imagepolygon($imagen, array(
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $col_poli);

// Imprimir la imagen al navagador
header('Content-type: image/png');

imagepng($imagen);
imagedestroy($imagen);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagepolygon()

Ver también

  • imagecreate() - Crea una nueva imagen basada en paleta
  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero


Dibuja un rectángulo

  • « imagepolygon
  • imageresolution »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibuja un rectángulo

imagerectangle

(PHP 4, PHP 5, PHP 7, PHP 8)

imagerectangle — Dibuja un rectángulo

Descripción

imagerectangle ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

imagerectangle() crea un rectángulo comenzando por las coordenadas especificadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x1

Coordenada x superior izquierda.

y1

Coordenada y superior izquierda 0, 0 es la esquina superior izquierda de la imagen.

x2

Coordenada x inferior derecha.

y2

Coordenada y inferior derecha.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo sencillo de imagerectangle()

<?php
// Crear una imagen de 200 x 200
$lienzo = imagecreatetruecolor(200, 200);

// Asignar colores
$rosa = imagecolorallocate($lienzo, 255, 105, 180);
$blanco = imagecolorallocate($lienzo, 255, 255, 255);
$verde = imagecolorallocate($lienzo, 132, 135, 28);

// Dibujar tres rectángulos, cada uno con su color
imagerectangle($lienzo, 50, 50, 150, 150, $rosa);
imagerectangle($lienzo, 45, 60, 120, 100, $blanco);
imagerectangle($lienzo, 100, 120, 75, 160, $verde);

// Imprimir y liberar memoria
header('Content-Type: image/jpeg');

imagejpeg($lienzo);
imagedestroy($lienzo);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Ejemplo sencillo de imagerectangle()


Get or set the resolution of the image

  • « imagerectangle
  • imagerotate »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Get or set the resolution of the image

imageresolution

(PHP 7 >= 7.2.0, PHP 8)

imageresolution — Get or set the resolution of the image

Descripción

imageresolution ( resource $image ) : mixed
imageresolution ( resource $image , int $res_x , int $res_y = $res_x ) : mixed

imageresolution() allows to set and get the resolution of an image in DPI (dots per inch). If none of the optional parameters is given, the current resolution is returned as indexed array. If only res_x is given, the horizontal and vertical resolution are set to this value. If both optional parameters are given, the horizontal and vertical resolution are set to these values, respectively.

The resolution is only used as meta information when images are read from and written to formats supporting this kind of information (curently PNG and JPEG). It does not affect any drawing operations. The default resolution for new images is 96 DPI.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

res_x

The horizontal resolution in DPI.

res_y

The vertical resolution in DPI.

Valores devueltos

When used as getter (first signature), it returns an indexed array of the horizontal and vertical resolution on success, o false en caso de error. When used as setter (second signature), it returns true on success, o false en caso de error.

Ejemplos

Ejemplo #1 Setting and getting the resolution of an image

<?php
$im = imagecreatetruecolor(100, 100);
imageresolution($im, 200);
print_r(imageresolution($im));
imageresolution($im, 300, 72);
print_r(imageresolution($im));
?>

El resultado del ejemplo sería:

Array
(
    [0] => 200
    [1] => 200
)
Array
(
    [0] => 300
    [1] => 72
)


Rotar una imagen con un ángulo dado

  • « imageresolution
  • imagesavealpha »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Rotar una imagen con un ángulo dado

imagerotate

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagerotate — Rotar una imagen con un ángulo dado

Descripción

imagerotate ( resource $image , float $angle , int $bgd_color , int $ignore_transparent = 0 ) : resource

Rota la imgaen image usando el ángulo angle dado en grados.

El centro de rotación es el centro de la imagen, y la imagen rotada puede tener dimensiones diferentes que la imagen original.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

angle

Ángulo de rotación, en grados. El ángulo de rotación es interpretado como el número de grados en el sentido contrario de las agujas de reloj que la imagen va a rotar.

bgd_color

Especifica el color de la zona no cubierta después de la rotación.

ignore_transparent

Si está establecido y no es cero, los colores transparentes son ignorados (de otro modo se conservan).

Valores devueltos

Devuelve un recurso de imgane para la imagen rotada, o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.0 | Esta función ahora se ve afectada por el método de interpolación establecido por la función imagesetinterpolation().
5.1.0 | Se añadió ignore_transparent.

Ejemplos

Ejemplo #1 Rotar una imagen 180 grados

Este ejemplo rota una imagen 180 grados - boca abajo.

<?php
// Archivo y rotación
$nombre_archivo = 'prueba.jpg';
$grados = 180;

// Tipo de contenido
header('Content-type: image/jpeg');

// Cargar
$origen = imagecreatefromjpeg($nombre_archivo);

// Rotar
$rotar = imagerotate($origen, $grados, 0);

// Imprimir
imagejpeg($rotar);

// Liberar la memoria
imagedestroy($origen);
imagedestroy($rotar);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Rotar una imagen 180 grados

Notas

Nota:

Está función se ve afectada por el método de interpolación establecido por imagesetinterpolation().

Ver también

  • imagesetinterpolation() - Establecer el método de interpolación


Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG

  • « imagerotate
  • imagescale »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG

imagesavealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imagesavealpha — Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG

Descripción

imagesavealpha ( resource $image , bool $saveflag ) : bool

imagesavealpha() establece la bandera para intentar guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG.

Se debe deshabilitar la mezcla alfa (imagealphablending($im, false)), para usarlo.

El canal alfa no está soportado por todos los navegadores, si tiene problemas con su navegador, intente cargar su script con un navegador compatible con el canal alfa, p.ej. la última version de Mozilla.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

saveflag

Si se ha de guardar el canal alfa o no. Por defecto es false.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesavealpha()

<?php
// Cargar una imagen png con canales alfa
$png = imagecreatefrompng('./ejemplo_canal_alfa.png');

// Hacer las operaciones requeridas

// Desactivar la mezcla alfa y establecer la bandera alfa
imagealphablending($png, false);
imagesavealpha($png, true);

// Impirmir la imagen al navegador
header('Content-Type: image/png');

imagepng($png);
imagedestroy($png);
?>

Ver también

  • imagealphablending() - Establece el modo de mezcla para una imagen


Redimensiona una imagen usando un nuevo ancho y alto

  • « imagesavealpha
  • imagesetbrush »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Redimensiona una imagen usando un nuevo ancho y alto

imagescale

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagescale — Redimensiona una imagen usando un nuevo ancho y alto

Descripción

imagescale ( resource $image , int $new_width , int $new_height = -1 , int $mode = IMG_BILINEAR_FIXED ) : resource

imagescale() redimensiona una imagen empleando el algoritmo de interpolación dado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

new_width

El ancho al cual redimensionar la imagen.

new_height

El alto al cual redimensionar la imagen. Si se omite o es negativo, la proporción de aspecto se preservará.

Precaución

Siempre se ha de proporcionar la altura si se utiliza PHP 5.5.18 o anterior, o PHP 5.6.2 o anterior, ya que el cálculo de la proporción de aspecto era incorrecto.

mode

Una de las constantes IMG_NEAREST_NEIGHBOUR, IMG_BILINEAR_FIXED, IMG_BICUBIC, IMG_BICUBIC_FIXED u otra cualquiera (usará dos pasadas).

Valores devueltos

Devuelve el recurso de la imagen redimensionada en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.19/5.6.3 | Se ha arreglado el cálculo de la altura si new_height era negativo o se omitía; antes de estas versiones, la proporción de aspecto no se mantenía correctamente.


Establecer la imagen de pincel para el dibujo de líneas

  • « imagescale
  • imagesetclip »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer la imagen de pincel para el dibujo de líneas

imagesetbrush

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetbrush — Establecer la imagen de pincel para el dibujo de líneas

Descripción

imagesetbrush ( resource $image , resource $brush ) : bool

imagesetbrush() establece la imagen de pincel para usarla con todas las funciones de dibujo de líneas (como imageline() y imagepolygon()) cuando se dibuja con los colores especiales IMG_COLOR_BRUSHED o IMG_COLOR_STYLEDBRUSHED.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

brush

Un recurso de imagen.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesetbrush()

<?php
// Cargar un mini logo de php
$php = imagecreatefrompng('./php.png');

// Crear la imagen principal, 100x100
$im = imagecreatetruecolor(100, 100);

// Rellenar el fondo con blanco
$blanco = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 299, 99, $blanco);

// Establecer el pincel
imagesetbrush($im, $php);

// Dibujar un par de pinceles, cada uno traslapando al otro
imageline($im, 50, 50, 50, 60, IMG_COLOR_BRUSHED);

// Imprimir la imagen al navegaador
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
imagedestroy($php);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagesetbrush()

Notas

Nota:

No se necesita tomar acciones especiales cuando se ha dejado de usar un pincel, pero si se destruye la imagen de pincel, ¡no se deben usar los colores IMG_COLOR_BRUSHED o IMG_COLOR_STYLEDBRUSHED hasta que se haya establecido una nueva imagen de pincel!


Set the clipping rectangle

  • « imagesetbrush
  • imagesetinterpolation »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Set the clipping rectangle

imagesetclip

(PHP 7 >= 7.2.0, PHP 8)

imagesetclip — Set the clipping rectangle

Descripción

imagesetclip ( resource $im , int $x1 , int $y1 , int $x2 , int $y2 ) : bool

imagesetclip() sets the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x1

The x-coordinate of the upper left corner.

y1

The y-coordinate of the upper left corner.

x2

The x-coordinate of the lower right corner.

y2

The y-coordinate of the lower right corner.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imagegetclip() - Get the clipping rectangle


Establecer el método de interpolación

  • « imagesetclip
  • imagesetpixel »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer el método de interpolación

imagesetinterpolation

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagesetinterpolation — Establecer el método de interpolación

Descripción

imagesetinterpolation ( resource $image , int $method = IMG_BILINEAR_FIXED ) : bool

Establece el método de interpolación. Establecer un método de interpolación afecta la renderización de varias funciones de GD, tal como la función imagerotate().

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

method

El método de interpolación, que puede ser uno de los siguientes:

  • IMG_BELL: Filtro Bell.
  • IMG_BESSEL: Filtro Bessel.
  • IMG_BICUBIC: Interpolación bicúbica.
  • IMG_BICUBIC_FIXED: Implementación de punto fijo de la interpolación bicúbica.
  • IMG_BILINEAR_FIXED: Implementación de punto fijo de la interpolación bilinear (predeterminado (también en la creación de imágenes)).
  • IMG_BLACKMAN: Función de ventana Blackman.
  • IMG_BOX: Filtro Box blur.
  • IMG_BSPLINE: Interpolación spline.
  • IMG_CATMULLROM: Interpolación spline Hermite cúbica.
  • IMG_GAUSSIAN: Función gaussiana.
  • IMG_GENERALIZED_CUBIC: Interpolación fractal spline cúbica generalizada.
  • IMG_HERMITE: Interpolación Hermite.
  • IMG_HAMMING: Filtro Hamming.
  • IMG_HANNING: Filtro Hanning.
  • IMG_MITCHELL: Filtro Mitchell.
  • IMG_POWER: Interpolación Power.
  • IMG_QUADRATIC: Interpolación cuadrática inversa.
  • IMG_SINC: Función Sinc.
  • IMG_NEAREST_NEIGHBOUR: Interpolación vecino más cercano.
  • IMG_WEIGHTED4: Filtro Weighting.
  • IMG_TRIANGLE: Interpolación de triángulo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesetinterpolation()

<?php
// Cargar una image
$im = imagecreate(500, 500);

// Por omisión, la interpolación es IMG_BILINEAR_FIXED, se cambia
// para usar el filtro 'Mitchell':
imagesetinterpolation($im, IMG_MITCHELL);

// Continuar trabajando con $im ...
?>

Notas

Cambiar el método de interpolación afecta a las siguientes funciones al renderizar:

  • imageaffine()
  • imagerotate()
  • imagescale()


Establecer un simple píxel

  • « imagesetinterpolation
  • imagesetstyle »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer un simple píxel

imagesetpixel

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesetpixel — Establecer un simple píxel

Descripción

imagesetpixel ( resource $image , int $x , int $y , int $color ) : bool

imagesetpixel() dibuja un píxel en las coordenadas especificadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

x

Coordenada x.

y

Coordenada y.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesetpixel()

Un dibujo aleatorio que termina en una imagen regular.

<?php

$x = 200;
$y = 200;

$gd = imagecreatetruecolor($x, $y);

$esquinas[0] = array('x' => 100, 'y' =>  10);
$esquinas[1] = array('x' =>   0, 'y' => 190);
$esquinas[2] = array('x' => 200, 'y' => 190);

$rojo = imagecolorallocate($gd, 255, 0, 0);

for ($i = 0; $i < 100000; $i++) {
  imagesetpixel($gd, round($x),round($y), $rojo);
  $a = rand(0, 2);
  $x = ($x + $esquinas[$a]['x']) / 2;
  $y = ($y + $esquinas[$a]['y']) / 2;
}

header('Content-Type: image/png');
imagepng($gd);

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagesetpixel()

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • imagecolorallocate() - Asigna un color para una imagen
  • imagecolorat() - Obtener el índice del color de un píxel


Establecer el estilo para el dibujo de líneas

  • « imagesetpixel
  • imagesetthickness »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer el estilo para el dibujo de líneas

imagesetstyle

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetstyle — Establecer el estilo para el dibujo de líneas

Descripción

imagesetstyle ( resource $image , array $style ) : bool

imagesetstyle() establece el estilo para ser usado por todas las funciones de dibujo de líneas (como imageline() y imagepolygon()) cuando se dibuja con el color especial IMG_COLOR_STYLED o líneas de imágenes con el color IMG_COLOR_STYLEDBRUSHED.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

style

Una matriz de colores de píxel. Se puede usar la constante IMG_COLOR_TRANSPARENT para añadir un píxel transparente. Observe que style no debe ser un array vacío.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

El siguiente script de ejemplo dibuja una línea discontinua desde la esquina superior izquierda a la esquina inferior derecha del lienzo:

Ejemplo #1 Ejemplo de imagesetstyle()

<?php
header("Content-type: image/jpeg");
$im  = imagecreatetruecolor(100, 100);
$b   = imagecolorallocate($im, 255, 255, 255);
$rojo = imagecolorallocate($im, 255, 0, 0);

/* Dibujar una línea discontinua, 5 píxeles rojos, 5 píxeles blancos */
$estilo = array($rojo, $rojo, $rojo, $rojo, $rojo, $b, $b, $b, $b, $b);
imagesetstyle($im, $estilo);
imageline($im, 0, 0, 100, 100, IMG_COLOR_STYLED);

/* Dibujar una línea de caras felices usando imagesetbrush() con imagesetstyle */
$estilo = array($b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $rojo);
imagesetstyle($im, $estilo);

$pincel = imagecreatefrompng("http://www.libpng.org/pub/png/images/smile.happy.png");
$b2 = imagecolorallocate($pincel, 255, 255, 255);
imagecolortransparent($pincel, $b2);
imagesetbrush($im, $pincel);
imageline($im, 100, 0, 0, 100, IMG_COLOR_STYLEDBRUSHED);

imagejpeg($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagesetstyle()

Ver también

  • imagesetbrush() - Establecer la imagen de pincel para el dibujo de líneas
  • imageline() - Dibujar una línea


Establecer el grosor para el dibujo de líneas

  • « imagesetstyle
  • imagesettile »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer el grosor para el dibujo de líneas

imagesetthickness

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetthickness — Establecer el grosor para el dibujo de líneas

Descripción

imagesetthickness ( resource $image , int $thickness ) : bool

imagesetthickness() establece el grosor de las líneas cuando se dibujan rectágulos, polígonos, arcos, etc..., a thickness píxeles.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

thickness

El grosor, en píxeles.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesetthickness()

<?php
// Crear una imagen de 200x100
$im = imagecreatetruecolor(200, 100);
$blanco = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$negro = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Esteblecer el fondo a blanco
imagefilledrectangle($im, 0, 0, 299, 99, $blanco);

// Establecer el grosor de línea a 5
imagesetthickness($im, 5);

// Dibujar un rectángulo
imagerectangle($im, 14, 14, 185, 85, $negro);

// Imprimir la imagen al navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagesetthickness()


Establecer la imagen de tesela para rellenos

  • « imagesetthickness
  • imagestring »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Establecer la imagen de tesela para rellenos

imagesettile

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesettile — Establecer la imagen de tesela para rellenos

Descripción

imagesettile ( resource $image , resource $tile ) : bool

imagesettile() establece la imagen de tesela para usarse con todas las funciones de relleno de regiones (como imagefill() y imagefilledpolygon()) cuando se rellena con el color especial IMG_COLOR_TILED.

Una tesela es una imagen usada para rellenar un área con un patrón repetido. Cualquier imagen GD se puede usar como una tesela, y estableciendo el índice de color transparente de la imagen de tesela con imagecolortransparent(), se puede hacer que una tesela permita que ciertas partes del área de la capa inferior brillen a través de la imagen.

Nota:

No se necesita tomar acciones especiales cuando se ha dejado de usar una tesela, pero si se destruye la imagen de tesela, ¡no se debe usar el color IMG_COLOR_TILED hasta que se haya establecido una nueva imagen de tesela!

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

tile

El recurso de imagen que va a ser usado como una tesela.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagesettile()

<?php
// Cargar una imagen externa
$zend = imagecreatefromgif('./zend.gif');

// Crear una imagen de 200x200
$im = imagecreatetruecolor(200, 200);

// Establecer la tesela
imagesettile($im, $zend);

// Hacer que la imagen se repita
imagefilledrectangle($im, 0, 0, 199, 199, IMG_COLOR_TILED);

// Imprimir la imagen en el navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
imagedestroy($zend);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagesettile()


Dibujar una cadena horizontalmente

  • « imagesettile
  • imagestringup »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una cadena horizontalmente

imagestring

(PHP 4, PHP 5, PHP 7, PHP 8)

imagestring — Dibujar una cadena horizontalmente

Descripción

imagestring ( resource $image , int $font , int $x , int $y , string $string , int $color ) : bool

Dibuja la cadena string en las coordenadas dadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

x

Coordenada x de la esquina superior izquierda.

y

Coordenada y de la esquina superior izquierda.

string

La cadena a escribir.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagestring()

<?php
// Crear una imagen de 100*30
$im = imagecreate(100, 30);

// Fondo blanco y texto azul
$fondo = imagecolorallocate($im, 255, 255, 255);
$color_texto = imagecolorallocate($im, 0, 0, 255);

// Escribir la cadena en la parte superior izquierda
imagestring($im, 5, 0, 0, 'Hello world!', $color_texto);

// Imprimir la imagen
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagestring()

Ver también

  • imageloadfont() - Cargar una nueva fuente
  • imagettftext() - Escribir texto en la imagen usando fuentes TrueType


Dibujar una cadena verticalmente

  • « imagestring
  • imagesx »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Dibujar una cadena verticalmente

imagestringup

(PHP 4, PHP 5, PHP 7, PHP 8)

imagestringup — Dibujar una cadena verticalmente

Descripción

imagestringup ( resource $image , int $font , int $x , int $y , string $string , int $color ) : bool

Dibuja la cadena string verticalmente en las coordenadas dadas.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

font

Puede ser 1, 2, 3, 4, 5 para fuentes built-in en latin2 encoding (los números más altos corresponden a large fonts) o cualquier de sus propios identificadores de fuentes registrados con imageloadfont().

x

Coordenada x de la esquina inferior izquierda.

y

Coordenada y de la esquina inferior izquierda.

string

La cadena a escribir.

color

Un identificador de color creado con imagecolorallocate().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imagestringup()

<?php
// crear una imagen de 100*100
$im = imagecreatetruecolor(100, 100);

// Escribir el texto
$color_texto = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
imagestringup($im, 3, 40, 80, 'gd library', $color_texto);

// Guardar la imagen
imagepng($im, './stringup.png');
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagestringup()

Ver también

  • imageloadfont() - Cargar una nueva fuente


Obtener el ancho de una imagen

  • « imagestringup
  • imagesy »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el ancho de una imagen

imagesx

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesx — Obtener el ancho de una imagen

Descripción

imagesx ( resource $image ) : int

Devuelve el ancho del recurso image dado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Devuelve el ancho de image o false si se produjeron errores.

Ejemplos

Ejemplo #1 Usar imagesx()

<?php

// crear una imagen de 300*200
$img = imagecreatetruecolor(300, 200);

echo imagesx($img); // 300

?>

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • getimagesize() - Obtener el tamaño de una imagen
  • imagesy() - Obtener el alto de una imagen


Obtener el alto de una imagen

  • « imagesx
  • imagetruecolortopalette »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Obtener el alto de una imagen

imagesy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesy — Obtener el alto de una imagen

Descripción

imagesy ( resource $image ) : int

Devuelve el alto del recurso de imagen image dado.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

Valores devueltos

Devuelve el alto de image o false si se produjeron errores.

Ejemplos

Ejemplo #1 Usar imagesy()

<?php

// crear una imagen de 300*200
$img = imagecreatetruecolor(300, 200);

echo imagesy($img); // 200

?>

Ver también

  • imagecreatetruecolor() - Crear una nueva imagen de color verdadero
  • getimagesize() - Obtener el tamaño de una imagen
  • imagesx() - Obtener el ancho de una imagen


Convertir una imagen de color verdadero en una imagen de paleta

  • « imagesy
  • imagettfbbox »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Convertir una imagen de color verdadero en una imagen de paleta

imagetruecolortopalette

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagetruecolortopalette — Convertir una imagen de color verdadero en una imagen de paleta

Descripción

imagetruecolortopalette ( resource $image , bool $dither , int $ncolors ) : bool

imagetruecolortopalette() convierte una imagen de color verdadero en una imagen de paleta. El código para esta función fue sacado originalmente del código de la biblioteca de Independent JPEG Group, el cual es excelente. El código ha sido modificado para preservar tanta información alfa como sea posible en la paleta resultante, además de preservar colores tanto como sea posible. Esto no funciona tan bien como se podría esperar. Normalmente es mejor simplemente producir una imagen de salida de color verdadero en su lugar, lo que garantiza la calidad más alta de salida.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

dither

Indica si la imagen debería ser entramada - si es true se usará el entramado, lo que resultará en una imágen más moteada pero con una aproximación de color mejor.

ncolors

Establece el número máximo de colores que se deberían retener en la paleta.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Convertir una imagen de color verdadero en una imagen de paleta

<?php
// Crear una nueva imagen de color verdadero
$im = imagecreatetruecolor(100, 100);

// Convertirla a paleta sin entramado y 255 colores
imagetruecolortopalette($im, false, 255);

// Guardar la imagen
imagepng($im, './paletteimage.png');
imagedestroy($im);
?>


Devuelve la caja circundante de un texto usando fuentes TrueType

  • « imagetruecolortopalette
  • imagettftext »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Devuelve la caja circundante de un texto usando fuentes TrueType

imagettfbbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imagettfbbox — Devuelve la caja circundante de un texto usando fuentes TrueType

Descripción

imagettfbbox ( float $size , float $angle , string $fontfile , string $text ) : array

Esta función calcula y devuelve la caja circundante en píxeles de un texto TrueType.

Nota:

imageftbbox() es una variante extendida de imagettfbbox() que además soporta el extrainfo.

Parámetros

size

Tamaño de fuente en puntos.

angle

El ángulo en grados en el que text será medido.

fontfile

La ruta a la fuente TrueType que se desea usar.

Dependiendo de la versión de la biblioteca para PHP de GD que se use, cuando fontfile no comience con un carácter inicial /, se añadirá .ttf al nombre del fichero, y la biblioteca intentará buscar ese nombre de fichero en toda la ruta de fuentes definidas por la biblioteca.

Cuando se usan versiones de la biblioteca GD menores que la 2.0.18, se usa un carácter espacio en lugar de un punto y coma como 'separador de rutas' para diferentes ficheros de fuentes. Un uso no intencionado de esta característica resultará en el mensaje de advertencia: Warning: Could not find/open font. La única solución para estas versiones afectadas es mover la fuente a una ruta que no contenga espacios.

En muchos casos donde una fuente reside en el mismo directorio que el script que la usa, el siguiente truco aliviará cualquier problema de inclusión.

<?php
// Establecer la variable de entorno para GD
putenv('GDFONTPATH=' . realpath('.'));

// Nombre de la fuente a usar (observe la ausencia de la extensión .ttf)
$font = 'SomeFont';
?>

Nota:

Observe que open_basedir no aplica a fontfile.

text

El string a ser medido.

Valores devueltos

imagettfbbox() devuelve un array con 8 elementos que representan cuatro puntos que hacen la caja circundante del texto si se tiene éxito y false en caso de error.

key | contents
0 | esquina inferior izquierda, posición X
1 | esquina inferior izquierda, posición Y
2 | esquina inferior derecha, posición X
3 | esquina inferior derecha, posición Y
4 | esquina superior derecha, posición X
5 | esquina superior derecha, posición Y
6 | esquina superior izquierda, posición X
7 | esquina superior izquierda posición Y

Los puntos son relativos a text sin importar el ángulo angle, por lo que "superior izquierda" significa la esquina superior izquierda, viendo el texto horizontalmente.

Ejemplos

Ejemplo #1 Ejemplo de imagettfbbox()

<?php
// Crear una imagen de 300x150
$im = imagecreatetruecolor(300, 150);
$negro = imagecolorallocate($im, 0, 0, 0);
$blanco = imagecolorallocate($im, 255, 255, 255);

// Establecer el fondo a blanco
imagefilledrectangle($im, 0, 0, 299, 299, $blanco);

// Ruta de nuestro archivo de fuente
$fuente = './arial.ttf';

// Primero creamos nuestra caja circundante para nuestro primer texto
$bbox = imagettfbbox(10, 45, $fuente, 'Powered by PHP ' . phpversion());

// Estas son nuestras coordenadas para X e Y
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) - 25;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

// Escribirlo
imagettftext($im, 10, 45, $x, $y, $negro, $fuente, 'Powered by PHP ' . phpversion());

// Crear la siguiente caja circundante para el segundo texto
$bbox = imagettfbbox(10, 45, $fuente, 'and Zend Engine ' . zend_version());

// Establecer las coordenadas para que esté a continuación del primer texto
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) + 10;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

// Escribirlo
imagettftext($im, 10, 45, $x, $y, $negro, $fuente, 'and Zend Engine ' . zend_version());

// Imprimir al navegador
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notas

Nota: Esta función sólo está disponible si PHP fue compilado con suporte de freetype (--with-freetype-dir=DIR)

Ver también

  • imagettftext() - Escribir texto en la imagen usando fuentes TrueType
  • imageftbbox() - Devolver la caja circundante de un texto usando fuentes mediante FreeType 2


Escribir texto en la imagen usando fuentes TrueType

  • « imagettfbbox
  • imagetypes »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Escribir texto en la imagen usando fuentes TrueType

imagettftext

(PHP 4, PHP 5, PHP 7, PHP 8)

imagettftext — Escribir texto en la imagen usando fuentes TrueType

Descripción

imagettftext ( resource $image , float $size , float $angle , int $x , int $y , int $color , string $fontfile , string $text ) : array

Escribe el texto text dado en una imagen usando fuentes TrueType.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

size

Tamaño de fuente en puntos.

angle

El ángulo en grados, siendo 0 grados la lectura del texto de izquierda a derecha. Valores mayores representan una rotación en sentido contrario al de las agujas del reloj. Por ejemplo, un valor de 90 resultaria en la lectura de texto de abajo a arriba.

x

Las coordenadas dadas por x e y definirán el punto de referencia del primer carácter (aproximadamente la esquina inferior izquierda del carácter). Esto es diferente de imagestring(), donde x e y definen la esquina superior izquierda del primer carácter. Por ejemplo, "superior izquierda" es 0, 0.

y

La coordenada y. Esto establece la posición de la línea base de las fuentes, no la del pie del carácter.

color

El índice de color. Usar el negativo de un índice de color tiene el efecto de desactivar el antialias. Vése imagecolorallocate().

fontfile

La ruta de la fuente TrueType que se desea usar.

Dependiendo de la versión de GD que esté usando PHP, cuando fontfile no comienza con un / inicial, .ttf será añadido al nombre de archivo, y la biblioteca intentará buscar ese nombre de archivo en una ruta de biblioteca definida de fuentes.

Cuando se usan versiones de la biblioteca GD anteriores a 2.0.18, un carácter espacio, en vez de un punto y coma, es usado como el 'separador de ruta' para diferentes archivos de fuente. El uso involuntario de esta característica resultará en en el mensaje de advertencia: Warning: Could not find/open font. La única solución para estas versiones afectadas es mover la fuente a una ruta que no contenga espacios.

En muchos casos donde una fuente reside en el mismo derectorio que el script, el siguiente truco paliará cualquier problema de inclusión.

<?php
// Establecer la variable de entorno para GD
putenv('GDFONTPATH=' . realpath('.'));

// Nombrar la fuente que va ser usada (observe la ausencia de la extensión .ttf)
$fuente = 'UnaFuente';
?>

text

La cadena de texto en codificación UTF-8.

Puede incluir referencias a caracteres numéricos decimales (de la forma: &#8364;) para acceder a caracteres en la fuente que están más allá de la posición 127. El formato hexadecimal (como &#xA9;) está soportado. Las cadenas en codificación UTF-8 pueden pasarse directamente.

Las entidades con nombre, como &copy;, no están soportadas. Considere usar html_entity_decode() para decodificar estas entidades con nombre a strings UTF-8.

Si un carácter se usa en la cadena y no está soportado por la fuente, un rectángulo vacío reemplazará al carácter.

Valores devueltos

Devuelve una matriz con 8 elementos que representan cuatro puntos que hacen la caja circundante. El orden de los puntos es inferior izquierdo, inferior derecho, superior derecho, superior izquierdo. Los puntos son relativos al texto sin importar el ángulo, por lo que "superior izquierdo" significa en la esquina superior izquierda cuando se ve el texto horizontalmente. Devuelve false si se produjo un error.

Historial de cambios

Versión | Descripción
5.2.0 | Ahora es posible especificar una entidad hexadecimal en text.

Ejemplos

Ejemplo #1 Ejemplo de imagettftext()

Este script de ejemplo producirá un PNG blanco de 400x30 píxeles, con la palabra "Testing..." en negro (con sombra gris), con la fuente Arial.

<?php
// Establecer el tipo de contenido
header('Content-Type: image/png');

// Crear la imagen
$im = imagecreatetruecolor(400, 30);

// Crear algunos colores
$blanco = imagecolorallocate($im, 255, 255, 255);
$gris = imagecolorallocate($im, 128, 128, 128);
$negro = imagecolorallocate($im, 0, 0, 0);
imagefilledrectangle($im, 0, 0, 399, 29, $blanco);

// El texto a dibujar
$texto = 'Testing...';
// Reemplace la ruta por la de su propia fuente
$fuente = 'arial.ttf';

// Añadir algo de sombra al texto
imagettftext($im, 20, 0, 11, 21, $gris, $fuente, $texto);

// Añadir el texto
imagettftext($im, 20, 0, 10, 20, $negro, $fuente, $texto);

// Usar imagepng() resultará en un texto más claro comparado con imagejpeg()
imagepng($im);
imagedestroy($im);
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : imagettftext()

Notas

Nota:

Esta función requiere tanto la biblioteca GD como la biblioteca » FreeType.

Ver también

  • imagettfbbox() - Devuelve la caja circundante de un texto usando fuentes TrueType


Devolver los tipos de imagen soportados por la versión actual de PHP

  • « imagettftext
  • imagewbmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Devolver los tipos de imagen soportados por la versión actual de PHP

imagetypes

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

imagetypes — Devolver los tipos de imagen soportados por la versión actual de PHP

Descripción

imagetypes ( ) : int

Devuelve los tipos de imagen soportados por la instalación actual de PHP.

Valores devueltos

Devuelve un campo de bit correspondiente a los formatos de imagen soportados por la versión de GD vinculada a PHP. Los siguietes bits son devueltos, IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP | IMG_XPM.

Ejemplos

Ejemplo #1 Comprobar el soporte para PNG

<?php
if (imagetypes() & IMG_PNG) {
    echo "El soporte para PNG está habilitado";
}
?>


Exportar la imagen al navegador o a un fichero

  • « imagetypes
  • imagewebp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Exportar la imagen al navegador o a un fichero

imagewbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagewbmp — Exportar la imagen al navegador o a un fichero

Descripción

imagewbmp ( resource $image , string $filename = ? , int $foreground = ? ) : bool

imagewbmp() imprime o guarda una versión WBMP de la imagen image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

foreground

Se puede establecer el color de primer plano con este parámetro estableciendo un identificador obtenido de imagecolorallocate(). El color de primer plano por defecto es negro.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Imprimir una imagen WBMP

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Establecer la cabecera de tipo de contenido conveniente - es este caso image/vnd.wap.wbmp
// Consejo: vea image_type_to_mime_type() para los tipos de contenido
header('Content-Type: image/vnd.wap.wbmp');

// Imprimir la imagen
imagewbmp($im);

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #2 Guardar una imagen WBMP

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Guardar la imagen
imagewbmp($im, 'simpletext.wbmp');

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #3 Imprimir la imagen con un primer plano diferente

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Establecer la cabecera de tipo de contenido conveniente - es este caso image/vnd.wap.wbmp
// Consejo: vea image_type_to_mime_type() para los tipos de contenido
header('Content-Type: image/vnd.wap.wbmp');

// Esteblecer un color de primer plano sustituto
$color_primer_plano = imagecolorallocate($im, 255, 0, 0);

imagewbmp($im, NULL, $color_primer_plano);

// Liberar memoria
imagedestroy($im);
?>

Notas

Nota:

El soporte para WBMP sólo está disponible si PHP fue compilado con GD-1.8 o superior.

Ver también

  • image2wbmp() - Exportar la imagen al navegador o a un fichero
  • imagepng() - Imprimir una imagen PNG al navegador o a un archivo
  • imagegif() - Exportar la imagen al navegador o a un fichero
  • imagejpeg() - Exportar la imagen al navegador o a un fichero
  • imagetypes() - Devolver los tipos de imagen soportados por la versión actual de PHP


Imprimir una imagen WebP al navegador o fichero

  • « imagewbmp
  • imagexbm »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Imprimir una imagen WebP al navegador o fichero

imagewebp

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

imagewebp — Imprimir una imagen WebP al navegador o fichero

Descripción

imagewebp ( resource $image , mixed $to = null , int $quality = 80 ) : bool

Imprime o guarda una versión WebP de la imagen dada por image.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

to

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

quality

quality va desde 0 (peor calidad, fichero más pequeño) a 100 (mejor calidad, fichero más grande).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió soporte para pasar un resource de flujo a to.

Ejemplos

Ejemplo #1 Guardar un fichero WebP

<?php
// Crear una imagen en blanco y añadir algo de texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'WebP con PHP', $color_texto);

// Guardar la imagen
imagewebp($im, 'php.webp');

// Liberar memoria
imagedestroy($im);
?>


Imprimir una imagen XBM en el navegador o en un fichero

  • « imagewebp
  • iptcembed »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Imprimir una imagen XBM en el navegador o en un fichero

imagexbm

(PHP 5, PHP 7, PHP 8)

imagexbm — Imprimir una imagen XBM en el navegador o en un fichero

Descripción

imagexbm ( resource $image , string $filename , int $foreground = ? ) : bool

Imprime o guarda una versión XBM de la imagen image.

Nota: imagexbm() no aplica ningún relleno, por lo que el ancho de la image ha de ser múltiplo de 8.

Parámetros

image

Un recurso image, es devuelto por una de las funciones de creación de imágenes, como imagecreatetruecolor().

filename

La ruta o un recurso de flujo de apertura (el cual se cierra automáticamente después de que devuelva esta función) donde guardar el fichero. Si no se establece, o su valor es null, se mostrará directamente en la salida el flujo de imagen sin tratar.

foreground

Se puede establecer el color de primer plano con este parámetro estableciendo un identificador obtenido de imagecolorallocate(). El color de primer plano por defecto es negro. Todos los demás colores son tratados como fondo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Guardar un fichero XBM

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Guardar la imagen
imagexbm($im, 'simpletext.xbm');

// Liberar memoria
imagedestroy($im);
?>

Ejemplo #2 Guardar un fichero XBM con un color de primer plano diferente

<?php
// Crear una imagen en blanco y añadir algún texto
$im = imagecreatetruecolor(120, 20);
$color_texto = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $color_texto);

// Esteblecer un color de primer plano sustituto
$color_primer_plano = imagecolorallocate($im, 255, 0, 0);

// Guardar la imagen
imagexbm($im, NULL, $color_primer_plano);

// Liberar memoria
imagedestroy($im);
?>

Notas


Incluir información IPTC binaria en una imagen JPEG

  • « imagexbm
  • iptcparse »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Incluir información IPTC binaria en una imagen JPEG

iptcembed

(PHP 4, PHP 5, PHP 7, PHP 8)

iptcembed — Incluir información IPTC binaria en una imagen JPEG

Descripción

iptcembed ( string $iptcdata , string $jpeg_file_name , int $spool = 0 ) : mixed

Incluye información IPTC binaria en una imagen JPEG.

Parámetros

iptcdata

La información que va a ser escrita.

jpeg_file_name

Ruta a la imagen JPEG.

spool

Bandera de spool. Si la bandera de spool es menor que 2, el JPEG será devuelto como una cadena. De lo contrario el JPEG será enviado a STDOUT.

Valores devueltos

Si spool es menor que 2, se devolverá el JPEG, o false en caso de error. De lo contrario devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Incluir información IPTC a un JPEG

<?php

// Función iptc_make_tag() por Thies C. Arntzen
function iptc_make_tag($rec, $data, $value)
{
    $length = strlen($value);
    $retval = chr(0x1C) . chr($rec) . chr($data);

    if($length < 0x8000)
    {
        $retval .= chr($length >> 8) .  chr($length & 0xFF);
    }
    else
    {
        $retval .= chr(0x80) .
                   chr(0x04) .
                   chr(($length >> 24) & 0xFF) .
                   chr(($length >> 16) & 0xFF) .
                   chr(($length >> 8) & 0xFF) .
                   chr($length & 0xFF);
    }

    return $retval . $value;
}

// Ruta al fichero jpeg
$ruta = './phplogo.jpg';

// Establecer las etiquetas IPTC
$iptc = array(
    '2#120' => 'Imagen de prueba',
    '2#116' => 'Copyright 2008-2009, The PHP Group'
);

// Convertir las etiquetas IPTC en código binario
$data = '';

foreach($iptc as $etiqueta => $cadena)
{
    $etiqueta = substr($etiqueta, 2);
    $data .= iptc_make_tag(2, $etiqueta, $cadena);
}

// Incluir la información IPTC
$contenido = iptcembed($data, $ruta);

// Escribir la nueva información de la imagen en un fichero.
$fp = fopen($ruta, "wb");
fwrite($fp, $contenido);
fclose($fp);
?>

Notas

Nota:

Esta función no requiere la librería GD image.


Conviertir un bloque IPTC binario en simples etiquetas

  • « iptcembed
  • jpeg2wbmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Conviertir un bloque IPTC binario en simples etiquetas

iptcparse

(PHP 4, PHP 5, PHP 7, PHP 8)

iptcparse — Conviertir un bloque IPTC binario en simples etiquetas

Descripción

iptcparse ( string $iptcblock ) : array

Convierte un bloque » IPTC en sus etiquetas.

Parámetros

iptcblock

Un bloque IPTC binario.

Valores devueltos

Devuelve una matriz usando el marcador de etiquetas como un índice, y el valor como el valor. Devuelve false si se produjo un error o si no se encontró información IPTC.

Ejemplos

Ejemplo #1 iptcparse() usado junto con getimagesize()

<?php
$tamaño = getimagesize('./prueba.jpg', $info);
if(isset($info['APP13']))
{
    $iptc = iptcparse($info['APP13']);
    var_dump($iptc);
}
?>

Notas

Nota:

Esta función no requiere la librería GD image.


Convertir un archiov de imagen JPEG a un archivo de imagen WBMP

  • « iptcparse
  • png2wbmp »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Convertir un archiov de imagen JPEG a un archivo de imagen WBMP

jpeg2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

jpeg2wbmp — Convertir un archiov de imagen JPEG a un archivo de imagen WBMP

Descripción

jpeg2wbmp ( string $jpegname , string $wbmpname , int $dest_height , int $dest_width , int $threshold ) : bool

Convierte un archivo JPEG en un archivo WBMP.

Parámetros

jpegname

Ruta del archivo JPEG.

wbmpname

Ruta del archivo WBMP de destino.

dest_height

Alto de la imagen de destino.

dest_width

Ancho de la imagen de destino.

threshold

Valor de umbral, entre 0 y 8 (inclusive).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de jpeg2wbmp()

<?php
// Ruta del jpeg objetivo
$ruta = './prueba.jpg';

// Obtener las dimensiones de la imagen
$imagen = getimagesize($ruta);

// Convertir la imagen
jpeg2wbmp($ruta, './prueba.wbmp', $imagen[1], $imagen[0], 5);
?>

Ver también

  • png2wbmp() - Convertir un archivo de imagen PNG a un archivo de imagen WBMP


Convertir un archivo de imagen PNG a un archivo de imagen WBMP

  • « jpeg2wbmp
  • Gmagick »
  • PHP Manual
  • Funciones de GD e Imágenes
  • Convertir un archivo de imagen PNG a un archivo de imagen WBMP

png2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

png2wbmp — Convertir un archivo de imagen PNG a un archivo de imagen WBMP

Descripción

png2wbmp ( string $pngname , string $wbmpname , int $dest_height , int $dest_width , int $threshold ) : bool

Convierte un archivo PNG a un archivo WBMP.

Parámetros

pngname

Ruta del archivo PNG.

wbmpname

Ruta del archivo WBMP de destino.

dest_height

Alto de la imagen de destino.

dest_width

Ancho de la imagen de destino.

threshold

Valor de umbral, entre 0 y 8 (inclusive).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejmplo de png2wbmp()

<?php
// Ruta al png objetivo
$ruta = './prueba.png';

// Obtener las dimensiones de la imagen
$imagen = getimagesize($ruta);

// Convertir la imagen
png2wbmp($ruta, './prueba.wbmp', $imagen[1], $imagen[0], 7);
?>

Ver también

  • jpeg2wbmp() - Convertir un archiov de imagen JPEG a un archivo de imagen WBMP


Gmagick

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Ejemplos
  • Gmagick — La clase Gmagick
    • Gmagick::addimage — Añade una nueva imagen a la lista de imágenes del objeto Gmagick
    • Gmagick::addnoiseimage — Añade ruido aleatorio a la imagen
    • Gmagick::annotateimage — Anota una imagen con texto
    • Gmagick::blurimage — Añade un filtro de borrosidad a la imagen
    • Gmagick::borderimage — Rodea la imagen con un borde
    • Gmagick::charcoalimage — Simula un dibujo a carboncillo
    • Gmagick::chopimage — Elimina una región de una imagen y la recorta
    • Gmagick::clear — Limpia todos los recursos asociados con el objeto Gmagick
    • Gmagick::commentimage — Añade un comentario a una imagen
    • Gmagick::compositeimage — Compone una imagen en otra
    • Gmagick::__construct — El constructor Gmagick
    • Gmagick::cropimage — Extrae una región de la imagen
    • Gmagick::cropthumbnailimage — Crea una miniatura recortada
    • Gmagick::current — Devuelve la refencia al objeto Gmagick acutal
    • Gmagick::cyclecolormapimage — Desplaza un mapa de color de una imagen
    • Gmagick::deconstructimages — Devuelve ciertas diferencias de píxeles entre imágenes
    • Gmagick::despeckleimage — Reduce el ruido granular de una imagen
    • Gmagick::destroy — Destruye un objeto Gmagick
    • Gmagick::drawimage — Renderiza el objeto GmagickDraw en la imagen actual
    • Gmagick::edgeimage — Mejora los bordes dentro de una imagen
    • Gmagick::embossimage — Devuelve una imagen en escala de grises con un efecto tridimensional
    • Gmagick::enhanceimage — Mejora la calidad de una imagen con ruido
    • Gmagick::equalizeimage — Ecualiza el histograma de la imagen
    • Gmagick::flipimage — Crea una imagen espejo vertical
    • Gmagick::flopimage — Crea una imagen espejo horizontal
    • Gmagick::frameimage — Añade un borde tridimensional simulado
    • Gmagick::gammaimage — Corrección gamma de una imagen
    • Gmagick::getcopyright — Devuelve el copyright de la API GraphicsMagick como una cadena
    • Gmagick::getfilename — El nombre de archivo asociado a una secuencia de imágenes
    • Gmagick::getimagebackgroundcolor — Devuelve el color de fondo de la imagen
    • Gmagick::getimageblueprimary — Devuelve el punto primario azul de la cromaticidad
    • Gmagick::getimagebordercolor — Devuelve el color del borde de la imagen
    • Gmagick::getimagechanneldepth — Obtiene la profundidad de un canal de imagen en particular
    • Gmagick::getimagecolors — Devuelve el color del índice del mapa de color especificado
    • Gmagick::getimagecolorspace — Obtiene el espacio de colores de la imagen
    • Gmagick::getimagecompose — Devuelve el operador de composición asociado a la imagen
    • Gmagick::getimagedelay — Obetiene el retraso de la imagen
    • Gmagick::getimagedepth — Obtiene la profundidad de la imagen
    • Gmagick::getimagedispose — Obtiene el método de disposición de la imagen
    • Gmagick::getimageextrema — Obtiene los extremos de la imagen
    • Gmagick::getimagefilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia
    • Gmagick::getimageformat — Devuelve el formato de una imagen en particular de una secuencia
    • Gmagick::getimagegamma — Obtiene el valor gamma de la imagen
    • Gmagick::getimagegreenprimary — Devuelve el punto primario verde de la cromaticidad
    • Gmagick::getimageheight — Devuelve el alto de la imagen
    • Gmagick::getimagehistogram — Obtiene el histograma de la imagen
    • Gmagick::getimageindex — Obtiene el índice de la imagen activa actual
    • Gmagick::getimageinterlacescheme — Obtiene la combinación de entrelazado de la imagen
    • Gmagick::getimageiterations — Obtiene las iteraciones de la imagen
    • Gmagick::getimagematte — Comprobar si la imagen tiene un canal mate
    • Gmagick::getimagemattecolor — Devuelve el color mate de la imagen
    • Gmagick::getimageprofile — Devuelve el perfil nominado de la imagen
    • Gmagick::getimageredprimary — Devuelve el punto primario rojo de la cromaticidad
    • Gmagick::getimagerenderingintent — Obtiene la propuesta de renderización de la imagen
    • Gmagick::getimageresolution — Obtiene la resolución X e Y de la imagen
    • Gmagick::getimagescene — Obtiene la escena de la imagen
    • Gmagick::getimagesignature — Genera un resumen de un mensaje SHA-256
    • Gmagick::getimagetype — Obtiene el tipo de imagen potencial.
    • Gmagick::getimageunits — Obtiene las unidades de resolución de la imagen
    • Gmagick::getimagewhitepoint — Devuelve el punto blanco de la cromaticidad
    • Gmagick::getimagewidth — Devuelve el ancho de la imagen
    • Gmagick::getpackagename — Devuelve el nombre del paquete de GraphicsMagick
    • Gmagick::getquantumdepth — Obtiene la profundidad de la cuantía de Gmagick como una cadena
    • Gmagick::getreleasedate — Devuelve la fecha de distribución de GraphicsMagick como una cadena
    • Gmagick::getsamplingfactors — Obtiene el factor de muestreo horizontal y vertical
    • Gmagick::getsize — Devuelve el tamaño asociado con el objeto Gmagick
    • Gmagick::getversion — Devuelve la versión de la API GraphicsMagick
    • Gmagick::hasnextimage — Comprueba si el objeto tiene más imágenes
    • Gmagick::haspreviousimage — Verifica si el objeto tiene una imagen previa
    • Gmagick::implodeimage — Crea una nueva imagen como una copia
    • Gmagick::labelimage — Añade una etiqueta a una imagen
    • Gmagick::levelimage — Ajusta los niveles de la imagen
    • Gmagick::magnifyimage — Escala una imagen x2 proporcionalmente
    • Gmagick::mapimage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
    • Gmagick::medianfilterimage — Aplica un filtro digital
    • Gmagick::minifyimage — Escala una imagen proporcionalmente a la mitad de su tamaño
    • Gmagick::modulateimage — Controla el brillo, la saturación y el tono
    • Gmagick::motionblurimage — Simula borrosidad en movimiento
    • Gmagick::newimage — Crea una nueva imagen
    • Gmagick::nextimage — Moverse a la siguiente imagen
    • Gmagick::normalizeimage — Mejora el contraste de una imagen a color
    • Gmagick::oilpaintimage — Simula una pintura al óleo
    • Gmagick::previousimage — Moverse a la imagen previa del objeto
    • Gmagick::profileimage — Añade o elimina un perfil de una imagen
    • Gmagick::quantizeimage — Analiza los colores dentro de una imagen de referencia
    • Gmagick::quantizeimages — Analiza los colores dentro de una secuencia de imágenes
    • Gmagick::queryfontmetrics — Devuelve una matriz que representa las métricas de la fuente
    • Gmagick::queryfonts — Devuelve las fuentes configuradas
    • Gmagick::queryformats — Devuelve los formatos admitidos por Gmagick
    • Gmagick::radialblurimage — Hace borrosa de forma radial una imagen
    • Gmagick::raiseimage — Crea un efecto de botón en 3D simulado
    • Gmagick::read — Lee una imagen desde un nombre de archivo
    • Gmagick::readimage — Lee una imagen desde un nombre de archivo
    • Gmagick::readimageblob — Lee una imagen desde una cadena binaria
    • Gmagick::readimagefile — Lee una imagen desde un descriptor de archivo abierto
    • Gmagick::reducenoiseimage — Suaviza los contornos de una imagen
    • Gmagick::removeimage — Elimina una imagen de la lista de imágenes
    • Gmagick::removeimageprofile — Elimina el perfil nombrado de la imagen y lo devuelve
    • Gmagick::resampleimage — Re-muestrea la imagen a la resolución deseada
    • Gmagick::resizeimage — Escala una imagen
    • Gmagick::rollimage — Compensa una imagen
    • Gmagick::rotateimage — Rota una imagen
    • Gmagick::scaleimage — Escala el tamaño de una imagen
    • Gmagick::separateimagechannel — Separa un canal de la imagen
    • Gmagick::setCompressionQuality — Establece la calidad de compresión predeterminada del objeto
    • Gmagick::setfilename — Establece el nombre de archivo antes de que se lea o escriba una imagen
    • Gmagick::setimagebackgroundcolor — Establece el color de fondo de la imagen
    • Gmagick::setimageblueprimary — Establece el punto primario azul de la cromaticidad de la imagen
    • Gmagick::setimagebordercolor — Establece el color de borde de la imagen
    • Gmagick::setimagechanneldepth — Establece la profundidad de una canal de imagen en particular
    • Gmagick::setimagecolorspace — Establece el espacio de color de una imagen
    • Gmagick::setimagecompose — Establece el operador de composción de una imagen
    • Gmagick::setimagedelay — Establece el retardo de una imagen
    • Gmagick::setimagedepth — Establece la profundidad de una imagen
    • Gmagick::setimagedispose — Establece el método de disposición de una imagen
    • Gmagick::setimagefilename — Establece el nombre de archivo de una imagen en particular en una secuencia
    • Gmagick::setimageformat — Establece el formato de una imagen en particular
    • Gmagick::setimagegamma — Establece el valor gamma de la imagen
    • Gmagick::setimagegreenprimary — Establece el punto primario verde de la cromaticidad de la imagen
    • Gmagick::setimageindex — Establece la posición del iterador en la lista de imágenes especificada con el parámetro index
    • Gmagick::setimageinterlacescheme — Establece la combinación de entrelazado de la imagen
    • Gmagick::setimageiterations — Establece las iteraciones de la imagen
    • Gmagick::setimageprofile — Añade un perfil nombrado al objeto Gmagick
    • Gmagick::setimageredprimary — Establece el punto primario rojo de la cromaticidad de la imagen
    • Gmagick::setimagerenderingintent — Establece el propósito de renderización de la imagen
    • Gmagick::setimageresolution — Establece la resolución de la imagen
    • Gmagick::setimagescene — Establece la escena de la imagen
    • Gmagick::setimagetype — Establece el tipo de imagen
    • Gmagick::setimageunits — Establece las unidades de resolución de la imagen
    • Gmagick::setimagewhitepoint — Establece el punto blanco de cromaticidad de la imagen
    • Gmagick::setsamplingfactors — Establece los factores de muestreo de la imagen
    • Gmagick::setsize — Establece el tamaño del objeto Gmagick
    • Gmagick::shearimage — Crea un paralelogramo
    • Gmagick::solarizeimage — Aplica un efecto de solarización a la imagen
    • Gmagick::spreadimage — Despalza aleatoriamente cada píxel en un bloque
    • Gmagick::stripimage — Elimina todos los perfiles y comentarios de una imagen
    • Gmagick::swirlimage — Arremolina los píxeles desde el centro de la imagen
    • Gmagick::thumbnailimage — Cambia el tamaño de una imagen
    • Gmagick::trimimage — Elimina los extremos de la imagen
    • Gmagick::write — Alias de Gmagick::writeimage
    • Gmagick::writeimage — Escribe una imagen al nombre de archivo especificado
  • GmagickDraw — La clase GmagickDraw
    • GmagickDraw::annotate — Dibuja texto en la imagen
    • GmagickDraw::arc — Dibuja un arco
    • GmagickDraw::bezier — Dibuja una curva Bézier
    • GmagickDraw::ellipse — Dibuja una elipse en la imagen
    • GmagickDraw::getfillcolor — Devuelve el color de relleno
    • GmagickDraw::getfillopacity — Devuelve la opacidad usada cuando se dibuja
    • GmagickDraw::getfont — Devuelve el tipo de letra
    • GmagickDraw::getfontsize — Devuelve el tamaño de punto de la fuente
    • GmagickDraw::getfontstyle — Devuelve el estilo de fuente
    • GmagickDraw::getfontweight — Devuelve el peso de la fuente
    • GmagickDraw::getstrokecolor — Devuelve el color usado para contornear perfiles de objetos
    • GmagickDraw::getstrokeopacity — Devuelve la opacidad de los perfiles del objeto contorneado
    • GmagickDraw::getstrokewidth — Devuelve el ancho del contorno usado para dibular perfiles del objeto
    • GmagickDraw::gettextdecoration — Devuelve la decoración del texto
    • GmagickDraw::gettextencoding — Devuelve el conjunto de codificación usado para anotaciones de texto
    • GmagickDraw::line — Dibuja una línea en la imagen
    • GmagickDraw::point — Dibuja un punto
    • GmagickDraw::polygon — Dibuja un polígono
    • GmagickDraw::polyline — Dibuja una polilínea
    • GmagickDraw::rectangle — Dibuja un rectángulo
    • GmagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual
    • GmagickDraw::roundrectangle — Dibuja un rectángulo redondeado
    • GmagickDraw::scale — Ajusta el factor de escala
    • GmagickDraw::setfillcolor — Establece el color de relleno a usar cuando se dibujan objetos rellenos
    • GmagickDraw::setfillopacity — Establece la opacidad del relleno
    • GmagickDraw::setfont — Establece la fuente especificada completamente a usar cuando se anota texto
    • GmagickDraw::setfontsize — Establece el tamaño de punto de la fuente a usar cuando se anota texto
    • GmagickDraw::setfontstyle — Establece el estilo de fuente a usar cuando se anota texto
    • GmagickDraw::setfontweight — Establece el peso de la fuente
    • GmagickDraw::setstrokecolor — Establece el color usado para contornear los perfiles del objeto
    • GmagickDraw::setstrokeopacity — Especifica la opacidad del los perfiles del objeto contorneado
    • GmagickDraw::setstrokewidth — Establece el ancho del contorno usado para dibujar los perfiles del objeto.
    • GmagickDraw::settextdecoration — Especifica una decoración
    • GmagickDraw::settextencoding — Especifica el conjunto de codificación del texto
  • GmagickPixel — La clase GmagickPixel
    • GmagickPixel::__construct — El constructor GmagickPixel
    • GmagickPixel::getcolor — Devuelve el color
    • GmagickPixel::getcolorcount — Devuelve la cuenta de color asociada a este color
    • GmagickPixel::getcolorvalue — Obtiene el valor normalizado del canal de color proporcionado
    • GmagickPixel::setcolor — Establece el color
    • GmagickPixel::setcolorvalue — Establece el valor normalizado de uno de los canales


Introducción

Gmagick es una extensión de php para crear, modificar y obtener meta-información de imágenes usando la API GraphicsMagick.

GraphicsMagick se enorgullece de ser la navaja suiza del procesamiento de imágenes. Trabaja con más de 88 formatos importantes incluyendo formatos como DPX, GIF, JPEG, JPEG-2000, PNG, PDF, PNM, y TIFF.

Gmagick consiste en una clase Gmagick principal, una clase GmagickDraw que de hecho es una varita mágica de dibujo y una clase GmagickPixel cuyas instancias representan un sólo píxel de una imagen (color, opacidad).


Requerimientos

Esta extensión trabaja mejor con las versiones 1.4+ de GraphicsMagick y 5.1.3+ de PHP. Gmagick debería funcionar con versiones anteriores hasta GraphicsMagick 1.2.6 pero algunas características y formatos no están soportados por estas versiones. La versión de Windows de GraphicsMagick está disponible en la página web de GraphicsMagick. Para leer acerca de la diferencia entre ImageMagick y GraphicsMagick, verifique esto: » FAQ .


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/gmagick.

Nota: El nombre oficial de esta extensión es gmagick.

Para Windows, la construcción de la extensión Gmagick está disponible » aquí


  • « Instalación
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes de Tipo de Color
Gmagick::COLOR_BLACK (integer)
Negro
Gmagick::COLOR_BLUE (integer)
Azul
Gmagick::COLOR_CYAN (integer)
Cian
Gmagick::COLOR_GREEN (integer)
Verde
Gmagick::COLOR_RED (integer)
Rojo
Gmagick::COLOR_YELLOW (integer)
Amarillo
Gmagick::COLOR_MAGENTA (integer)
Magenta
Gmagick::COLOR_OPACITY (integer)
Opacidad
Gmagick::COLOR_ALPHA (integer)
Alfa
Gmagick::COLOR_FUZZ (integer)
Enfoque
Constantes de Operadores de Composición
Gmagick::COMPOSITE_DEFAULT (integer)
Operador de composición por defecto
Gmagick::COMPOSITE_UNDEFINED (integer)
Operador de composición indefinido
Gmagick::COMPOSITE_NO (integer)
Operador de disposición no definido
Gmagick::COMPOSITE_ADD (integer)
El resultado de imagen + imagen
Gmagick::COMPOSITE_ATOP (integer)
El resultado tiene la misma forma que la imagen, con la imagen compuesta oscurenciendo la imagen donde la imagen forma traslapado
Gmagick::COMPOSITE_BLEND (integer)
Mezcla la imagen
Gmagick::COMPOSITE_BUMPMAP (integer)
Lo mismo que COMPOSITE_MULTIPLY, excepto que el origen primero se covierte a escala de grises.
Gmagick::COMPOSITE_CLEAR (integer)
Hace a la imagen objetivo transparente
Gmagick::COMPOSITE_COLORBURN (integer)
Oscurece la imagen destino para reflejar la imagen de origen
Gmagick::COMPOSITE_COLORDODGE (integer)
Hace más brillante la imagen destino para reflejar la imagen de origen
Gmagick::COMPOSITE_COLORIZE (integer)
Colorea la imagen objetivo utilizando la imagen compuesta
Gmagick::COMPOSITE_COPYBLACK (integer)
Copia el negro del origen al objetivo
Gmagick::COMPOSITE_COPYBLUE (integer)
Copia el azul del origen al objetivo
Gmagick::COMPOSITE_COPY (integer)
Copia la imagen de origen a la imagen objetivo
Gmagick::COMPOSITE_COPYCYAN (integer)
Copia el cian del origen al objetivo
Gmagick::COMPOSITE_COPYGREEN (integer)
Copia el verde del origen al objetivo
Gmagick::COMPOSITE_COPYMAGENTA (integer)
Copia el magenta del origen al objetivo
Gmagick::COMPOSITE_COPYOPACITY (integer)
Copia la opacidad del origen al objetivo
Gmagick::COMPOSITE_COPYRED (integer)
Copia el rojo del origen al objetivo
Gmagick::COMPOSITE_COPYYELLOW (integer)
Copia el amarillo del origen al objetivo
Gmagick::COMPOSITE_DARKEN (integer)
Oscurece la imagen objetivo
Gmagick::COMPOSITE_DSTATOP (integer)
La parte de la capa destino dentro del origen se compone sobre el origen y reemplaza el destino
Gmagick::COMPOSITE_DST (integer)
El objetivo se deja sin tocar
Gmagick::COMPOSITE_DSTIN (integer)
La parte dentro del origen reemplaza el objetivo
Gmagick::COMPOSITE_DSTOUT (integer)
La parte fuera del origen reemplaza el objetivo
Gmagick::COMPOSITE_DSTOVER (integer)
El objetivo reemplaza el origen
Gmagick::COMPOSITE_DIFFERENCE (integer)
Sustrae el más oscuro de los dos colores constituyentes del más luminiso
Gmagick::COMPOSITE_DISPLACE (integer)
Cambia los píxeles de la imagen objetivo como se definió en el origen
Gmagick::COMPOSITE_DISSOLVE (integer)
Disuelve el origen en el objetivo
Gmagick::COMPOSITE_EXCLUSION (integer)
Produce un efecto similar al de Gmagick::COMPOSITE_DIFFERENCE, pero aparece con un contraste menor
Gmagick::COMPOSITE_HARDLIGHT (integer)
Multiplica u oculta los colores, dependiendo del valor del color de origen
Gmagick::COMPOSITE_HUE (integer)
Modifica el tono del objetivo como se definió en el origen
Gmagick::COMPOSITE_IN (integer)
Compone el origen dentro del objetivo
Gmagick::COMPOSITE_LIGHTEN (integer)
Aclara el objetivo como se definió en el origen
Gmagick::COMPOSITE_LUMINIZE (integer)
Hace más luminoso el objetivo como se definió en el origen
Gmagick::COMPOSITE_MINUS (integer)
Sustrae el origen del objetivo
Gmagick::COMPOSITE_MODULATE (integer)
Modula el brillo, la saturación y el tono del objetivo como se definió en el origen
Gmagick::COMPOSITE_MULTIPLY (integer)
Multiplica el objetivo en el origen
Gmagick::COMPOSITE_OUT (integer)
Comopone las partes exteriores del origen en el objetivo
Gmagick::COMPOSITE_OVER (integer)
Compone el origen sobre el objetivo
Gmagick::COMPOSITE_OVERLAY (integer)
Sobrepone el origen en el objetivo
Gmagick::COMPOSITE_PLUS (integer)
Añade el origen al objetivo
Gmagick::COMPOSITE_REPLACE (integer)
Reemplaza el objetivo con el origen
Gmagick::COMPOSITE_SATURATE (integer)
Satura el objetivo como se definió en el origen
Gmagick::COMPOSITE_SCREEN (integer)
El origen y destino son complementados, después multiplicados, y después reemplazan el destino
Gmagick::COMPOSITE_SOFTLIGHT (integer)
Oscurece o ilumina los colores, dependiendo del origen
Gmagick::COMPOSITE_SRCATOP (integer)
La parte de la capa de origen dentro del destino es compuesta en el destino
Gmagick::COMPOSITE_SRC (integer)
El origen se copia al destino
Gmagick::COMPOSITE_SRCIN (integer)
La parte de la capa del origen dentro del destino reemplaza el destino
Gmagick::COMPOSITE_SRCOUT (integer)
La parte de la capa del origen fuera del destino reemplaza el destino
Gmagick::COMPOSITE_SRCOVER (integer)
El origen reemplaza el destino
Gmagick::COMPOSITE_SUBTRACT (integer)
Sustrae los colores en la imagen de origen de la imagen destino
Gmagick::COMPOSITE_THRESHOLD (integer)
El origen es compuesto en el objetivo como se definió en el umbral del origen
Gmagick::COMPOSITE_XOR (integer)
La parte del origen que yace fuera del destino se combina con la parte del destino que yace fuera del origen
Constantes de Modo de Montaje
Gmagick::MONTAGEMODE_FRAME (integer)
Gmagick::MONTAGEMODE_UNFRAME (integer)
Gmagick::MONTAGEMODE_CONCATENATE (integer)
Constantes de Estilo
Gmagick::STYLE_NORMAL (integer)
Gmagick::STYLE_ITALIC (integer)
Gmagick::STYLE_OBLIQUE (integer)
Gmagick::STYLE_ANY (integer)
Constantes de Filtro
Gmagick::FILTER_UNDEFINED (integer)
Gmagick::FILTER_POINT (integer)
Gmagick::FILTER_BOX (integer)
Gmagick::FILTER_TRIANGLE (integer)
Gmagick::FILTER_HERMITE (integer)
Gmagick::FILTER_HANNING (integer)
Gmagick::FILTER_HAMMING (integer)
Gmagick::FILTER_BLACKMAN (integer)
Gmagick::FILTER_GAUSSIAN (integer)
Gmagick::FILTER_QUADRATIC (integer)
Gmagick::FILTER_CUBIC (integer)
Gmagick::FILTER_CATROM (integer)
Gmagick::FILTER_MITCHELL (integer)
Gmagick::FILTER_LANCZOS (integer)
Gmagick::FILTER_BESSEL (integer)
Gmagick::FILTER_SINC (integer)
Constantes de Tipo de Imagen
Gmagick::IMGTYPE_UNDEFINED (integer)
Gmagick::IMGTYPE_BILEVEL (integer)
Gmagick::IMGTYPE_GRAYSCALE (integer)
Gmagick::IMGTYPE_GRAYSCALEMATTE (integer)
Gmagick::IMGTYPE_PALETTE (integer)
Gmagick::IMGTYPE_PALETTEMATTE (integer)
Gmagick::IMGTYPE_TRUECOLOR (integer)
Gmagick::IMGTYPE_TRUECOLORMATTE (integer)
Gmagick::IMGTYPE_COLORSEPARATION (integer)
Gmagick::IMGTYPE_COLORSEPARATIONMATTE (integer)
Gmagick::IMGTYPE_OPTIMIZE (integer)
Cosntantes de Resolución
Gmagick::RESOLUTION_UNDEFINED (integer)
Gmagick::RESOLUTION_PIXELSPERINCH (integer)
Gmagick::RESOLUTION_PIXELSPERCENTIMETER (integer)
Constantes de Compresión
Gmagick::COMPRESSION_UNDEFINED (integer)
Gmagick::COMPRESSION_NO (integer)
Gmagick::COMPRESSION_BZIP (integer)
Gmagick::COMPRESSION_FAX (integer)
Gmagick::COMPRESSION_GROUP4 (integer)
Gmagick::COMPRESSION_JPEG (integer)
Gmagick::COMPRESSION_JPEG2000 (integer)
Gmagick::COMPRESSION_LOSSLESSJPEG (integer)
Gmagick::COMPRESSION_LZW (integer)
Gmagick::COMPRESSION_RLE (integer)
Gmagick::COMPRESSION_ZIP (integer)
Constantes de Pintura
Gmagick::PAINT_POINT (integer)
Gmagick::PAINT_REPLACE (integer)
Gmagick::PAINT_FLOODFILL (integer)
Gmagick::PAINT_FILLTOBORDER (integer)
Gmagick::PAINT_RESET (integer)
Cosntantes de Gravedad
Gmagick::GRAVITY_NORTHWEST (integer)
Gmagick::GRAVITY_NORTH (integer)
Gmagick::GRAVITY_NORTHEAST (integer)
Gmagick::GRAVITY_WEST (integer)
Gmagick::GRAVITY_CENTER (integer)
Gmagick::GRAVITY_EAST (integer)
Gmagick::GRAVITY_SOUTHWEST (integer)
Gmagick::GRAVITY_SOUTH (integer)
Gmagick::GRAVITY_SOUTHEAST (integer)
Constantes de Estiramiento
Gmagick::STRETCH_NORMAL (integer)
Gmagick::STRETCH_ULTRACONDENSED (integer)
Gmagick::STRETCH_CONDENSED (integer)
Gmagick::STRETCH_SEMICONDENSED (integer)
Gmagick::STRETCH_SEMIEXPANDED (integer)
Gmagick::STRETCH_EXPANDED (integer)
Gmagick::STRETCH_EXTRAEXPANDED (integer)
Gmagick::STRETCH_ULTRAEXPANDED (integer)
Gmagick::STRETCH_ANY (integer)
Constantes de Alineamiento
Gmagick::ALIGN_UNDEFINED (integer)
Gmagick::ALIGN_LEFT (integer)
Gmagick::ALIGN_CENTER (integer)
Gmagick::ALIGN_RIGHT (integer)
Constantes de Decoración
Gmagick::DECORATION_NO (integer)
Gmagick::DECORATION_UNDERLINE (integer)
Gmagick::DECORATION_OVERLINE (integer)
Gmagick::DECORATION_LINETROUGH (integer)
Constantes de Ruido
Gmagick::NOISE_UNIFORM (integer)
Gmagick::NOISE_GAUSSIAN (integer)
Gmagick::NOISE_MULTIPLICATIVEGAUSSIAN (integer)
Gmagick::NOISE_IMPULSE (integer)
Gmagick::NOISE_LAPLACIAN (integer)
Gmagick::NOISE_POISSON (integer)
Constantes de Canal
Gmagick::CHANNEL_UNDEFINED (integer)
Gmagick::CHANNEL_RED (integer)
Gmagick::CHANNEL_GRAY (integer)
Gmagick::CHANNEL_CYAN (integer)
Gmagick::CHANNEL_GREEN (integer)
Gmagick::CHANNEL_MAGENTA (integer)
Gmagick::CHANNEL_BLUE (integer)
Gmagick::CHANNEL_YELLOW (integer)
Gmagick::CHANNEL_ALPHA (integer)
Gmagick::CHANNEL_OPACITY (integer)
Gmagick::CHANNEL_MATTE (integer)
Gmagick::CHANNEL_BLACK (integer)
Gmagick::CHANNEL_INDEX (integer)
Gmagick::CHANNEL_ALL (integer)
Constantes de Métrica
Gmagick::METRIC_UNDEFINED (integer)
Gmagick::METRIC_MEANABSOLUTEERROR (integer)
Gmagick::METRIC_MEANSQUAREERROR (integer)
Gmagick::METRIC_PEAKABSOLUTEERROR (integer)
Gmagick::METRIC_PEAKSIGNALTONOISERATIO (integer)
Gmagick::METRIC_ROOTMEANSQUAREDERROR (integer)
Constantes de Píxel
Gmagick::PIXEL_CHAR (integer)
Gmagick::PIXEL_DOUBLE (integer)
Gmagick::PIXEL_FLOAT (integer)
Gmagick::PIXEL_INTEGER (integer)
Gmagick::PIXEL_LONG (integer)
Gmagick::PIXEL_QUANTUM (integer)
Gmagick::PIXEL_SHORT (integer)
Constantes de Espacio de Color
Gmagick::COLORSPACE_UNDEFINED (integer)
Gmagick::COLORSPACE_RGB (integer)
Gmagick::COLORSPACE_GRAY (integer)
Gmagick::COLORSPACE_TRANSPARENT (integer)
Gmagick::COLORSPACE_OHTA (integer)
Gmagick::COLORSPACE_LAB (integer)
Gmagick::COLORSPACE_XYZ (integer)
Gmagick::COLORSPACE_YCBCR (integer)
Gmagick::COLORSPACE_YCC (integer)
Gmagick::COLORSPACE_YIQ (integer)
Gmagick::COLORSPACE_YPBPR (integer)
Gmagick::COLORSPACE_YUV (integer)
Gmagick::COLORSPACE_CMYK (integer)
Gmagick::COLORSPACE_SRGB (integer)
Gmagick::COLORSPACE_HSB (integer)
Gmagick::COLORSPACE_HSL (integer)
Gmagick::COLORSPACE_HWB (integer)
Gmagick::COLORSPACE_REC601LUMA (integer)
Gmagick::COLORSPACE_REC709LUMA (integer)
Gmagick::COLORSPACE_LOG (integer)
Constantes de Métodos de Píxel Virtual
Gmagick::VIRTUALPIXELMETHOD_UNDEFINED (integer)
Gmagick::VIRTUALPIXELMETHOD_BACKGROUND (integer)
Gmagick::VIRTUALPIXELMETHOD_CONSTANT (integer)
Gmagick::VIRTUALPIXELMETHOD_EDGE (integer)
Gmagick::VIRTUALPIXELMETHOD_MIRROR (integer)
Gmagick::VIRTUALPIXELMETHOD_TILE (integer)
Gmagick::VIRTUALPIXELMETHOD_TRANSPARENT (integer)
Constantes de Previsualización
Gmagick::PREVIEW_UNDEFINED (integer)
Gmagick::PREVIEW_ROTATE (integer)
Gmagick::PREVIEW_SHEAR (integer)
Gmagick::PREVIEW_ROLL (integer)
Gmagick::PREVIEW_HUE (integer)
Gmagick::PREVIEW_SATURATION (integer)
Gmagick::PREVIEW_BRIGHTNESS (integer)
Gmagick::PREVIEW_GAMMA (integer)
Gmagick::PREVIEW_SPIFF (integer)
Gmagick::PREVIEW_DULL (integer)
Gmagick::PREVIEW_GRAYSCALE (integer)
Gmagick::PREVIEW_QUANTIZE (integer)
Gmagick::PREVIEW_DESPECKLE (integer)
Gmagick::PREVIEW_REDUCENOISE (integer)
Gmagick::PREVIEW_ADDNOISE (integer)
Gmagick::PREVIEW_SHARPEN (integer)
Gmagick::PREVIEW_BLUR (integer)
Gmagick::PREVIEW_THRESHOLD (integer)
Gmagick::PREVIEW_EDGEDETECT (integer)
Gmagick::PREVIEW_SPREAD (integer)
Gmagick::PREVIEW_SOLARIZE (integer)
Gmagick::PREVIEW_SHADE (integer)
Gmagick::PREVIEW_RAISE (integer)
Gmagick::PREVIEW_SEGMENT (integer)
Gmagick::PREVIEW_SWIRL (integer)
Gmagick::PREVIEW_IMPLODE (integer)
Gmagick::PREVIEW_WAVE (integer)
Gmagick::PREVIEW_OILPAINT (integer)
Gmagick::PREVIEW_CHARCOALDRAWING (integer)
Gmagick::PREVIEW_JPEG (integer)
Constantes de Propósitos de Renderización
Gmagick::RENDERINGINTENT_UNDEFINED (integer)
Gmagick::RENDERINGINTENT_SATURATION (integer)
Gmagick::RENDERINGINTENT_PERCEPTUAL (integer)
Gmagick::RENDERINGINTENT_ABSOLUTE (integer)
Gmagick::RENDERINGINTENT_RELATIVE (integer)
Constantes de Regla de Relleno
Gmagick::FILLRULE_UNDEFINED (integer)
Gmagick::FILLRULE_EVENODD (integer)
Gmagick::FILLRULE_NONZERO (integer)
Constantes de Unidades de Trazado
Gmagick::PATHUNITS_UNDEFINED (integer)
Gmagick::PATHUNITS_USERSPACE (integer)
Gmagick::PATHUNITS_USERSPACEONUSE (integer)
Gmagick::PATHUNITS_OBJECTBOUNDINGBOX (integer)
Constantes de Cierre de Línea
Gmagick::LINECAP_UNDEFINED (integer)
Gmagick::LINECAP_BUTT (integer)
Gmagick::LINECAP_ROUND (integer)
Gmagick::LINECAP_SQUARE (integer)
Constantes de Unión de Línea
Gmagick::LINEJOIN_UNDEFINED (integer)
Gmagick::LINEJOIN_MITER (integer)
Gmagick::LINEJOIN_ROUND (integer)
Gmagick::LINEJOIN_BEVEL (integer)
Constantes de Tipo de Recurso
Gmagick::RESOURCETYPE_UNDEFINED (integer)
Gmagick::RESOURCETYPE_AREA (integer)
Gmagick::RESOURCETYPE_DISK (integer)
Gmagick::RESOURCETYPE_FILE (integer)
Gmagick::RESOURCETYPE_MAP (integer)
Gmagick::RESOURCETYPE_MEMORY (integer)
Constantes de Orientación
Gmagick::ORIENTATION_UNDEFINED (integer)
Gmagick::ORIENTATION_TOPLEFT (integer)
Gmagick::ORIENTATION_TOPRIGHT (integer)
Gmagick::ORIENTATION_BOTTOMRIGHT (integer)
Gmagick::ORIENTATION_BOTTOMLEFT (integer)
Gmagick::ORIENTATION_LEFTTOP (integer)
Gmagick::ORIENTATION_RIGHTTOP (integer)
Gmagick::ORIENTATION_RIGHTBOTTOM (integer)
Gmagick::ORIENTATION_LEFTBOTTOM (integer)


Ejemplos

Lo siguiente muestra algunas operaciones de imágenes de Gmagick comunes.

Ejemplo #1 Ejemplo de Gmagick

<?php
//Instanciar un nuevo objeto Gmagick
$imagen = new Gmagick('example.jpg');

//Hacer una miniatura de una imagen cargada. 0 para los ejes preserva la proporción de aspecto
$imagen->thumbnailImage(100, 0);

//Crear un borde alrededor de la imagen, después simular la imagen para que parezca una pintura al óleo
//Observe el encadenmiento de los métodos mutadores que están soportados en gmagick
$imagen->borderImage("yellow", 8, 8)->oilPaintImage(0.3);

//Escribir la imagen actual en el estado actual de un archivo
$imagen->write('ejemplo_miniatura.jpg');
?>


La clase Gmagick

(PECL gmagick >= Unknown)

Introducción

Sinopsis de la Clase

Gmagick {
/* Métodos */
public addimage ( Gmagick $Gmagick ) : Gmagick
public addnoiseimage ( int $NOISE ) : Gmagick
public annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text ) : Gmagick
public blurimage ( float $radius , float $sigma , int $channel = ? ) : Gmagick
public borderimage ( GmagickPixel $color , int $width , int $height ) : Gmagick
public charcoalimage ( float $radius , float $sigma ) : Gmagick
public chopimage ( int $width , int $height , int $x , int $y ) : Gmagick
public clear ( ) : Gmagick
public commentimage ( string $comment ) : Gmagick
public compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y ) : Gmagick
public __construct ( string $filename = ? )
public cropimage ( int $width , int $height , int $x , int $y ) : Gmagick
public cropthumbnailimage ( int $width , int $height ) : Gmagick
public current ( ) : Gmagick
public cyclecolormapimage ( int $displace ) : Gmagick
public deconstructimages ( ) : Gmagick
public despeckleimage ( ) : Gmagick
public destroy ( ) : bool
public drawimage ( GmagickDraw $GmagickDraw ) : Gmagick
public edgeimage ( float $radius ) : Gmagick
public embossimage ( float $radius , float $sigma ) : Gmagick
public enhanceimage ( ) : Gmagick
public equalizeimage ( ) : Gmagick
public flipimage ( ) : Gmagick
public flopimage ( ) : Gmagick
public frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : Gmagick
public gammaimage ( float $gamma ) : Gmagick
public getcopyright ( ) : string
public getfilename ( ) : string
public getimagebackgroundcolor ( ) : GmagickPixel
public getimageblueprimary ( ) : array
public getimagebordercolor ( ) : GmagickPixel
public getimagechanneldepth ( int $channel_type ) : int
public getimagecolors ( ) : int
public getimagecolorspace ( ) : int
public getimagecompose ( ) : int
public getimagedelay ( ) : int
public getimagedepth ( ) : int
public getimagedispose ( ) : int
public getimageextrema ( ) : array
public getimagefilename ( ) : string
public getimageformat ( ) : string
public getimagegamma ( ) : float
public getimagegreenprimary ( ) : array
public getimageheight ( ) : int
public getimagehistogram ( ) : array
public getimageindex ( ) : int
public getimageinterlacescheme ( ) : int
public getimageiterations ( ) : int
public getimagematte ( ) : int
public getimagemattecolor ( ) : GmagickPixel
public getimageprofile ( string $name ) : string
public getimageredprimary ( ) : array
public getimagerenderingintent ( ) : int
public getimageresolution ( ) : array
public getimagescene ( ) : int
public getimagesignature ( ) : string
public getimagetype ( ) : int
public getimageunits ( ) : int
public getimagewhitepoint ( ) : array
public getimagewidth ( ) : int
public getpackagename ( ) : string
public getquantumdepth ( ) : array
public getreleasedate ( ) : string
public getsamplingfactors ( ) : array
public getsize ( ) : array
public getversion ( ) : array
public hasnextimage ( ) : mixed
public haspreviousimage ( ) : mixed
public implodeimage ( float $radius ) : mixed
public labelimage ( string $label ) : mixed
public levelimage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Gmagick::CHANNEL_DEFAULT ) : mixed
public magnifyimage ( ) : mixed
public mapimage ( gmagick $gmagick , bool $dither ) : Gmagick
public medianfilterimage ( float $radius ) : void
public minifyimage ( ) : Gmagick
public modulateimage ( float $brightness , float $saturation , float $hue ) : Gmagick
public motionblurimage ( float $radius , float $sigma , float $angle ) : Gmagick
public newimage ( int $width , int $height , string $background , string $format = ? ) : Gmagick
public nextimage ( ) : bool
public normalizeimage ( int $channel = ? ) : Gmagick
public oilpaintimage ( float $radius ) : Gmagick
public previousimage ( ) : bool
public profileimage ( string $name , string $profile ) : Gmagick
public quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick
public quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick
public queryfontmetrics ( GmagickDraw $draw , string $text ) : array
public queryfonts ( string $pattern = "*" ) : array
public queryformats ( string $pattern = "*" ) : array
public radialblurimage ( float $angle , int $channel = Gmagick::CHANNEL_DEFAULT ) : Gmagick
public raiseimage ( int $width , int $height , int $x , int $y , bool $raise ) : Gmagick
public read ( string $filename ) : Gmagick
public readimage ( string $filename ) : Gmagick
public readimageblob ( string $imageContents , string $filename = ? ) : Gmagick
public readimagefile ( resource $fp , string $filename = ? ) : Gmagick
public reducenoiseimage ( float $radius ) : Gmagick
public removeimage ( ) : Gmagick
public removeimageprofile ( string $name ) : string
public resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur ) : Gmagick
public resizeimage ( int $width , int $height , int $filter , float $blur , bool $fit = false ) : Gmagick
public rollimage ( int $x , int $y ) : Gmagick
public rotateimage ( mixed $color , float $degrees ) : Gmagick
public scaleimage ( int $width , int $height , bool $fit = false ) : Gmagick
public separateimagechannel ( int $channel ) : Gmagick
setCompressionQuality ( int $quality = 75 ) : Gmagick
public setfilename ( string $filename ) : Gmagick
public setimagebackgroundcolor ( GmagickPixel $color ) : Gmagick
public setimageblueprimary ( float $x , float $y ) : Gmagick
public setimagebordercolor ( GmagickPixel $color ) : Gmagick
public setimagechanneldepth ( int $channel , int $depth ) : Gmagick
public setimagecolorspace ( int $colorspace ) : Gmagick
public setimagecompose ( int $composite ) : Gmagick
public setimagedelay ( int $delay ) : Gmagick
public setimagedepth ( int $depth ) : Gmagick
public setimagedispose ( int $disposeType ) : Gmagick
public setimagefilename ( string $filename ) : Gmagick
public setimageformat ( string $imageFormat ) : Gmagick
public setimagegamma ( float $gamma ) : Gmagick
public setimagegreenprimary ( float $x , float $y ) : Gmagick
public setimageindex ( int $index ) : Gmagick
public setimageinterlacescheme ( int $interlace ) : Gmagick
public setimageiterations ( int $iterations ) : Gmagick
public setimageprofile ( string $name , string $profile ) : Gmagick
public setimageredprimary ( float $x , float $y ) : Gmagick
public setimagerenderingintent ( int $rendering_intent ) : Gmagick
public setimageresolution ( float $xResolution , float $yResolution ) : Gmagick
public setimagescene ( int $scene ) : Gmagick
public setimagetype ( int $imgType ) : Gmagick
public setimageunits ( int $resolution ) : Gmagick
public setimagewhitepoint ( float $x , float $y ) : Gmagick
public setsamplingfactors ( array $factors ) : Gmagick
public setsize ( int $columns , int $rows ) : Gmagick
public shearimage ( mixed $color , float $xShear , float $yShear ) : Gmagick
public solarizeimage ( int $threshold ) : Gmagick
public spreadimage ( float $radius ) : Gmagick
public stripimage ( ) : Gmagick
public swirlimage ( float $degrees ) : Gmagick
public thumbnailimage ( int $width , int $height , bool $fit = false ) : Gmagick
public trimimage ( float $fuzz ) : Gmagick
public writeimage ( string $filename , bool $all_frames = false ) : Gmagick
}

Tabla de contenidos

  • Gmagick::addimage — Añade una nueva imagen a la lista de imágenes del objeto Gmagick
  • Gmagick::addnoiseimage — Añade ruido aleatorio a la imagen
  • Gmagick::annotateimage — Anota una imagen con texto
  • Gmagick::blurimage — Añade un filtro de borrosidad a la imagen
  • Gmagick::borderimage — Rodea la imagen con un borde
  • Gmagick::charcoalimage — Simula un dibujo a carboncillo
  • Gmagick::chopimage — Elimina una región de una imagen y la recorta
  • Gmagick::clear — Limpia todos los recursos asociados con el objeto Gmagick
  • Gmagick::commentimage — Añade un comentario a una imagen
  • Gmagick::compositeimage — Compone una imagen en otra
  • Gmagick::__construct — El constructor Gmagick
  • Gmagick::cropimage — Extrae una región de la imagen
  • Gmagick::cropthumbnailimage — Crea una miniatura recortada
  • Gmagick::current — Devuelve la refencia al objeto Gmagick acutal
  • Gmagick::cyclecolormapimage — Desplaza un mapa de color de una imagen
  • Gmagick::deconstructimages — Devuelve ciertas diferencias de píxeles entre imágenes
  • Gmagick::despeckleimage — Reduce el ruido granular de una imagen
  • Gmagick::destroy — Destruye un objeto Gmagick
  • Gmagick::drawimage — Renderiza el objeto GmagickDraw en la imagen actual
  • Gmagick::edgeimage — Mejora los bordes dentro de una imagen
  • Gmagick::embossimage — Devuelve una imagen en escala de grises con un efecto tridimensional
  • Gmagick::enhanceimage — Mejora la calidad de una imagen con ruido
  • Gmagick::equalizeimage — Ecualiza el histograma de la imagen
  • Gmagick::flipimage — Crea una imagen espejo vertical
  • Gmagick::flopimage — Crea una imagen espejo horizontal
  • Gmagick::frameimage — Añade un borde tridimensional simulado
  • Gmagick::gammaimage — Corrección gamma de una imagen
  • Gmagick::getcopyright — Devuelve el copyright de la API GraphicsMagick como una cadena
  • Gmagick::getfilename — El nombre de archivo asociado a una secuencia de imágenes
  • Gmagick::getimagebackgroundcolor — Devuelve el color de fondo de la imagen
  • Gmagick::getimageblueprimary — Devuelve el punto primario azul de la cromaticidad
  • Gmagick::getimagebordercolor — Devuelve el color del borde de la imagen
  • Gmagick::getimagechanneldepth — Obtiene la profundidad de un canal de imagen en particular
  • Gmagick::getimagecolors — Devuelve el color del índice del mapa de color especificado
  • Gmagick::getimagecolorspace — Obtiene el espacio de colores de la imagen
  • Gmagick::getimagecompose — Devuelve el operador de composición asociado a la imagen
  • Gmagick::getimagedelay — Obetiene el retraso de la imagen
  • Gmagick::getimagedepth — Obtiene la profundidad de la imagen
  • Gmagick::getimagedispose — Obtiene el método de disposición de la imagen
  • Gmagick::getimageextrema — Obtiene los extremos de la imagen
  • Gmagick::getimagefilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia
  • Gmagick::getimageformat — Devuelve el formato de una imagen en particular de una secuencia
  • Gmagick::getimagegamma — Obtiene el valor gamma de la imagen
  • Gmagick::getimagegreenprimary — Devuelve el punto primario verde de la cromaticidad
  • Gmagick::getimageheight — Devuelve el alto de la imagen
  • Gmagick::getimagehistogram — Obtiene el histograma de la imagen
  • Gmagick::getimageindex — Obtiene el índice de la imagen activa actual
  • Gmagick::getimageinterlacescheme — Obtiene la combinación de entrelazado de la imagen
  • Gmagick::getimageiterations — Obtiene las iteraciones de la imagen
  • Gmagick::getimagematte — Comprobar si la imagen tiene un canal mate
  • Gmagick::getimagemattecolor — Devuelve el color mate de la imagen
  • Gmagick::getimageprofile — Devuelve el perfil nominado de la imagen
  • Gmagick::getimageredprimary — Devuelve el punto primario rojo de la cromaticidad
  • Gmagick::getimagerenderingintent — Obtiene la propuesta de renderización de la imagen
  • Gmagick::getimageresolution — Obtiene la resolución X e Y de la imagen
  • Gmagick::getimagescene — Obtiene la escena de la imagen
  • Gmagick::getimagesignature — Genera un resumen de un mensaje SHA-256
  • Gmagick::getimagetype — Obtiene el tipo de imagen potencial.
  • Gmagick::getimageunits — Obtiene las unidades de resolución de la imagen
  • Gmagick::getimagewhitepoint — Devuelve el punto blanco de la cromaticidad
  • Gmagick::getimagewidth — Devuelve el ancho de la imagen
  • Gmagick::getpackagename — Devuelve el nombre del paquete de GraphicsMagick
  • Gmagick::getquantumdepth — Obtiene la profundidad de la cuantía de Gmagick como una cadena
  • Gmagick::getreleasedate — Devuelve la fecha de distribución de GraphicsMagick como una cadena
  • Gmagick::getsamplingfactors — Obtiene el factor de muestreo horizontal y vertical
  • Gmagick::getsize — Devuelve el tamaño asociado con el objeto Gmagick
  • Gmagick::getversion — Devuelve la versión de la API GraphicsMagick
  • Gmagick::hasnextimage — Comprueba si el objeto tiene más imágenes
  • Gmagick::haspreviousimage — Verifica si el objeto tiene una imagen previa
  • Gmagick::implodeimage — Crea una nueva imagen como una copia
  • Gmagick::labelimage — Añade una etiqueta a una imagen
  • Gmagick::levelimage — Ajusta los niveles de la imagen
  • Gmagick::magnifyimage — Escala una imagen x2 proporcionalmente
  • Gmagick::mapimage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
  • Gmagick::medianfilterimage — Aplica un filtro digital
  • Gmagick::minifyimage — Escala una imagen proporcionalmente a la mitad de su tamaño
  • Gmagick::modulateimage — Controla el brillo, la saturación y el tono
  • Gmagick::motionblurimage — Simula borrosidad en movimiento
  • Gmagick::newimage — Crea una nueva imagen
  • Gmagick::nextimage — Moverse a la siguiente imagen
  • Gmagick::normalizeimage — Mejora el contraste de una imagen a color
  • Gmagick::oilpaintimage — Simula una pintura al óleo
  • Gmagick::previousimage — Moverse a la imagen previa del objeto
  • Gmagick::profileimage — Añade o elimina un perfil de una imagen
  • Gmagick::quantizeimage — Analiza los colores dentro de una imagen de referencia
  • Gmagick::quantizeimages — Analiza los colores dentro de una secuencia de imágenes
  • Gmagick::queryfontmetrics — Devuelve una matriz que representa las métricas de la fuente
  • Gmagick::queryfonts — Devuelve las fuentes configuradas
  • Gmagick::queryformats — Devuelve los formatos admitidos por Gmagick
  • Gmagick::radialblurimage — Hace borrosa de forma radial una imagen
  • Gmagick::raiseimage — Crea un efecto de botón en 3D simulado
  • Gmagick::read — Lee una imagen desde un nombre de archivo
  • Gmagick::readimage — Lee una imagen desde un nombre de archivo
  • Gmagick::readimageblob — Lee una imagen desde una cadena binaria
  • Gmagick::readimagefile — Lee una imagen desde un descriptor de archivo abierto
  • Gmagick::reducenoiseimage — Suaviza los contornos de una imagen
  • Gmagick::removeimage — Elimina una imagen de la lista de imágenes
  • Gmagick::removeimageprofile — Elimina el perfil nombrado de la imagen y lo devuelve
  • Gmagick::resampleimage — Re-muestrea la imagen a la resolución deseada
  • Gmagick::resizeimage — Escala una imagen
  • Gmagick::rollimage — Compensa una imagen
  • Gmagick::rotateimage — Rota una imagen
  • Gmagick::scaleimage — Escala el tamaño de una imagen
  • Gmagick::separateimagechannel — Separa un canal de la imagen
  • Gmagick::setCompressionQuality — Establece la calidad de compresión predeterminada del objeto
  • Gmagick::setfilename — Establece el nombre de archivo antes de que se lea o escriba una imagen
  • Gmagick::setimagebackgroundcolor — Establece el color de fondo de la imagen
  • Gmagick::setimageblueprimary — Establece el punto primario azul de la cromaticidad de la imagen
  • Gmagick::setimagebordercolor — Establece el color de borde de la imagen
  • Gmagick::setimagechanneldepth — Establece la profundidad de una canal de imagen en particular
  • Gmagick::setimagecolorspace — Establece el espacio de color de una imagen
  • Gmagick::setimagecompose — Establece el operador de composción de una imagen
  • Gmagick::setimagedelay — Establece el retardo de una imagen
  • Gmagick::setimagedepth — Establece la profundidad de una imagen
  • Gmagick::setimagedispose — Establece el método de disposición de una imagen
  • Gmagick::setimagefilename — Establece el nombre de archivo de una imagen en particular en una secuencia
  • Gmagick::setimageformat — Establece el formato de una imagen en particular
  • Gmagick::setimagegamma — Establece el valor gamma de la imagen
  • Gmagick::setimagegreenprimary — Establece el punto primario verde de la cromaticidad de la imagen
  • Gmagick::setimageindex — Establece la posición del iterador en la lista de imágenes especificada con el parámetro index
  • Gmagick::setimageinterlacescheme — Establece la combinación de entrelazado de la imagen
  • Gmagick::setimageiterations — Establece las iteraciones de la imagen
  • Gmagick::setimageprofile — Añade un perfil nombrado al objeto Gmagick
  • Gmagick::setimageredprimary — Establece el punto primario rojo de la cromaticidad de la imagen
  • Gmagick::setimagerenderingintent — Establece el propósito de renderización de la imagen
  • Gmagick::setimageresolution — Establece la resolución de la imagen
  • Gmagick::setimagescene — Establece la escena de la imagen
  • Gmagick::setimagetype — Establece el tipo de imagen
  • Gmagick::setimageunits — Establece las unidades de resolución de la imagen
  • Gmagick::setimagewhitepoint — Establece el punto blanco de cromaticidad de la imagen
  • Gmagick::setsamplingfactors — Establece los factores de muestreo de la imagen
  • Gmagick::setsize — Establece el tamaño del objeto Gmagick
  • Gmagick::shearimage — Crea un paralelogramo
  • Gmagick::solarizeimage — Aplica un efecto de solarización a la imagen
  • Gmagick::spreadimage — Despalza aleatoriamente cada píxel en un bloque
  • Gmagick::stripimage — Elimina todos los perfiles y comentarios de una imagen
  • Gmagick::swirlimage — Arremolina los píxeles desde el centro de la imagen
  • Gmagick::thumbnailimage — Cambia el tamaño de una imagen
  • Gmagick::trimimage — Elimina los extremos de la imagen
  • Gmagick::write — Alias de Gmagick::writeimage
  • Gmagick::writeimage — Escribe una imagen al nombre de archivo especificado


Añade una nueva imagen a la lista de imágenes del objeto Gmagick

  • « Gmagick
  • Gmagick::addnoiseimage »
  • PHP Manual
  • Gmagick
  • Añade una nueva imagen a la lista de imágenes del objeto Gmagick

Gmagick::addimage

(PECL gmagick >= Unknown)

Gmagick::addimage — Añade una nueva imagen a la lista de imágenes del objeto Gmagick

Descripción

public Gmagick::addimage ( Gmagick $Gmagick ) : Gmagick

Añade una nueva imagen al objeto Gmagick desde la posición actual del objeto de origen. Después de la operación la posición del iterador se mueve al final de la lista.

Parámetros

source

El objeto Gmagick de origen

Valores devueltos

El objeto Gmagick con la imagen añadida

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade ruido aleatorio a la imagen

  • « Gmagick::addimage
  • Gmagick::annotateimage »
  • PHP Manual
  • Gmagick
  • Añade ruido aleatorio a la imagen

Gmagick::addnoiseimage

(PECL gmagick >= Unknown)

Gmagick::addnoiseimage — Añade ruido aleatorio a la imagen

Descripción

public Gmagick::addnoiseimage ( int $NOISE ) : Gmagick

Añade ruido aleatorio a la imagen.

Parámetros

noise_type

El tipo de ruido. Consulte esta lista de constantes de ruido.

Valores devueltos

El objeto Gmagick con el ruido añadido.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Anota una imagen con texto

  • « Gmagick::addnoiseimage
  • Gmagick::blurimage »
  • PHP Manual
  • Gmagick
  • Anota una imagen con texto

Gmagick::annotateimage

(PECL gmagick >= Unknown)

Gmagick::annotateimage — Anota una imagen con texto

Descripción

public Gmagick::annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text ) : Gmagick

Anota una imagen con texto.

Parámetros

GmagickDraw

El objeto GmagickDraw que contiene la configuración para dibujar el texto

x

El índice horizontal en píxeles a la izquierda del texto

y

El índice vertical en píxeles a la línea base del texto

angle

El ángulo en el que escribir el texto

text

La cadena a dibujar

Valores devueltos

El objeto Gmagick con la anotación hecha.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade un filtro de borrosidad a la imagen

  • « Gmagick::annotateimage
  • Gmagick::borderimage »
  • PHP Manual
  • Gmagick
  • Añade un filtro de borrosidad a la imagen

Gmagick::blurimage

(PECL gmagick >= Unknown)

Gmagick::blurimage — Añade un filtro de borrosidad a la imagen

Descripción

public Gmagick::blurimage ( float $radius , float $sigma , int $channel = ? ) : Gmagick

Añade un filtro de borrosidad a la imagen.

Parámetros

radius

Radio de borrosidad

sigma

Desviación estándar

Valores devueltos

El objeto Gmagick borroso

Errores/Excepciones

Arroja un GmagickException en caso de error.


Rodea la imagen con un borde

  • « Gmagick::blurimage
  • Gmagick::charcoalimage »
  • PHP Manual
  • Gmagick
  • Rodea la imagen con un borde

Gmagick::borderimage

(PECL gmagick >= Unknown)

Gmagick::borderimage — Rodea la imagen con un borde

Descripción

public Gmagick::borderimage ( GmagickPixel $color , int $width , int $height ) : Gmagick

Rodea la imagen con un borde del color definido por el objeto GmagickPixel de color de borde o por una cadena de color.

Parámetros

color

El objeto GmagickPixel o una cadena que contiene el color del borde

width

Ancho del borode

height

Alto del borde

Valores devueltos

El objeto Gmagick con el borde definido

Errores/Excepciones

Arroja un GmagickException en caso de error.


Simula un dibujo a carboncillo

  • « Gmagick::borderimage
  • Gmagick::chopimage »
  • PHP Manual
  • Gmagick
  • Simula un dibujo a carboncillo

Gmagick::charcoalimage

(PECL gmagick >= Unknown)

Gmagick::charcoalimage — Simula un dibujo a carboncillo

Descripción

public Gmagick::charcoalimage ( float $radius , float $sigma ) : Gmagick

Simula un dibujo a carboncillo.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central

sigma

La desviación estándar gaussiana, en píxeles

Valores devueltos

El objeto Gmagick con la simulación de carboncillo

Errores/Excepciones

Arroja un GmagickException en caso de error.


Elimina una región de una imagen y la recorta

  • « Gmagick::charcoalimage
  • Gmagick::clear »
  • PHP Manual
  • Gmagick
  • Elimina una región de una imagen y la recorta

Gmagick::chopimage

(PECL gmagick >= Unknown)

Gmagick::chopimage — Elimina una región de una imagen y la recorta

Descripción

public Gmagick::chopimage ( int $width , int $height , int $x , int $y ) : Gmagick

Elimina una región de una imagen y colapsa la imagen para ocupar la porción eliminada.

Parámetros

width

Ancho del área recortada

height

Alto del área recortada

x

Origen X del área recortada

y

Origen Y del área recortada

Valores devueltos

El objeto Gmagick recortado

Errores/Excepciones

Arroja un GmagickException en caso de error.


Limpia todos los recursos asociados con el objeto Gmagick

  • « Gmagick::chopimage
  • Gmagick::commentimage »
  • PHP Manual
  • Gmagick
  • Limpia todos los recursos asociados con el objeto Gmagick

Gmagick::clear

(PECL gmagick >= Unknown)

Gmagick::clear — Limpia todos los recursos asociados con el objeto Gmagick

Descripción

public Gmagick::clear ( ) : Gmagick

Limpia todos los recursos asociados al objeto Gmagick

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick limpiado

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade un comentario a una imagen

  • « Gmagick::clear
  • Gmagick::compositeimage »
  • PHP Manual
  • Gmagick
  • Añade un comentario a una imagen

Gmagick::commentimage

(PECL gmagick >= Unknown)

Gmagick::commentimage — Añade un comentario a una imagen

Descripción

public Gmagick::commentimage ( string $comment ) : Gmagick

Añade un comentario a una imagen.

Parámetros

comment

El comentario a añadir

Valores devueltos

El objeto Gmagick con el comentario añadido.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Compone una imagen en otra

  • « Gmagick::commentimage
  • Gmagick::__construct »
  • PHP Manual
  • Gmagick
  • Compone una imagen en otra

Gmagick::compositeimage

(PECL gmagick >= Unknown)

Gmagick::compositeimage — Compone una imagen en otra

Descripción

public Gmagick::compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y ) : Gmagick

Compone una imagen en otra en el índice especificado.

Parámetros

source

Objeto Gmagick que contiene la imagen compuesta

compose

Operador de composción

x

El índice de columna de la imagen compuesta

y

El índice de fila de la imagen compuesta

Valores devueltos

El objeto Gmagick con composiciones.

Errores/Excepciones

Arroja un GmagickException en caso de error.


El constructor Gmagick

  • « Gmagick::compositeimage
  • Gmagick::cropimage »
  • PHP Manual
  • Gmagick
  • El constructor Gmagick

Gmagick::__construct

(PECL gmagick >= Unknown)

Gmagick::__construct — El constructor Gmagick

Descripción

public Gmagick::__construct ( string $filename = ? )

El constructor Gmagick.

Parámetros

filename

La ruta a una imagen para cargar o una matriz de rutas

Valores devueltos

Devuelve un nuevo objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Extrae una región de la imagen

  • « Gmagick::__construct
  • Gmagick::cropthumbnailimage »
  • PHP Manual
  • Gmagick
  • Extrae una región de la imagen

Gmagick::cropimage

(PECL gmagick >= Unknown)

Gmagick::cropimage — Extrae una región de la imagen

Descripción

public Gmagick::cropimage ( int $width , int $height , int $x , int $y ) : Gmagick

Extrae una región de la imagen.

Parámetros

width

El ancho del recorte

height

El alto del recorte

x

La coordenada X de la esquina superior izquierda de la región recortada

y

La coordenada Y de la esquina superior izquierda de la región recortada

Valores devueltos

El objeto Gmagick recortado

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea una miniatura recortada

  • « Gmagick::cropimage
  • Gmagick::current »
  • PHP Manual
  • Gmagick
  • Crea una miniatura recortada

Gmagick::cropthumbnailimage

(PECL gmagick >= Unknown)

Gmagick::cropthumbnailimage — Crea una miniatura recortada

Descripción

public Gmagick::cropthumbnailimage ( int $width , int $height ) : Gmagick

Crea una miniatura de tamaño fijo ampliando o reduciendo de escala la imagen y recortando un área específica desde el centro.

Parámetros

width

El ancho de la miniatura

height

El alto de la miniatura

Valores devueltos

El objeto Gmagick recortado

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve la refencia al objeto Gmagick acutal

  • « Gmagick::cropthumbnailimage
  • Gmagick::cyclecolormapimage »
  • PHP Manual
  • Gmagick
  • Devuelve la refencia al objeto Gmagick acutal

Gmagick::current

(PECL gmagick >= Unknown)

Gmagick::current — Devuelve la refencia al objeto Gmagick acutal

Descripción

public Gmagick::current ( ) : Gmagick

Devuelve la refencia al objeto Gmagick acutal con el puntero de imagen apuntando a la secuencia correcta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Se devuelve a sí mismo si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Desplaza un mapa de color de una imagen

  • « Gmagick::current
  • Gmagick::deconstructimages »
  • PHP Manual
  • Gmagick
  • Desplaza un mapa de color de una imagen

Gmagick::cyclecolormapimage

(PECL gmagick >= Unknown)

Gmagick::cyclecolormapimage — Desplaza un mapa de color de una imagen

Descripción

public Gmagick::cyclecolormapimage ( int $displace ) : Gmagick

Desplaza un mapa de color de una imagen por el número de posiciones dado. Si se realiza un ciclo del mapa de colores varias veces se puede obtener un efecto psicodélico.

Parámetros

displace

La cantidad a desplazar el mapa de color.

Valores devueltos

Se devuelve a sí mismo si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve ciertas diferencias de píxeles entre imágenes

  • « Gmagick::cyclecolormapimage
  • Gmagick::despeckleimage »
  • PHP Manual
  • Gmagick
  • Devuelve ciertas diferencias de píxeles entre imágenes

Gmagick::deconstructimages

(PECL gmagick >= Unknown)

Gmagick::deconstructimages — Devuelve ciertas diferencias de píxeles entre imágenes

Descripción

public Gmagick::deconstructimages ( ) : Gmagick

Compara cada imagen con la siguiente en una secuencia y devuelve la región circundante máxima de cualquier diferencia de píxeles que se descubra.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un nuevo objeto Gmagick en caso de éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Reduce el ruido granular de una imagen

  • « Gmagick::deconstructimages
  • Gmagick::destroy »
  • PHP Manual
  • Gmagick
  • Reduce el ruido granular de una imagen

Gmagick::despeckleimage

(PECL gmagick >= Unknown)

Gmagick::despeckleimage — Reduce el ruido granular de una imagen

Descripción

public Gmagick::despeckleimage ( ) : Gmagick

Reduce el ruido granular de una imagen mientras preserva los bordes de la imagen original.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick con el ruido granular reducido si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Gmagick::despeckleimage()

<?php
/* ... */
?>

El resultado del ejemplo sería algo similar a:

...

Ver también

  • Classname::Method()


Destruye un objeto Gmagick

  • « Gmagick::despeckleimage
  • Gmagick::drawimage »
  • PHP Manual
  • Gmagick
  • Destruye un objeto Gmagick

Gmagick::destroy

(PECL gmagick >= Unknown)

Gmagick::destroy — Destruye un objeto Gmagick

Descripción

public Gmagick::destroy ( ) : bool

Destruye un objeto Gmagick y libera todos los recursos asociados con él

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Renderiza el objeto GmagickDraw en la imagen actual

  • « Gmagick::destroy
  • Gmagick::edgeimage »
  • PHP Manual
  • Gmagick
  • Renderiza el objeto GmagickDraw en la imagen actual

Gmagick::drawimage

(PECL gmagick >= Unknown)

Gmagick::drawimage — Renderiza el objeto GmagickDraw en la imagen actual

Descripción

public Gmagick::drawimage ( GmagickDraw $GmagickDraw ) : Gmagick

Renderiza el objeto GmagickDraw en la imagen actual

Parámetros

GmagickDraw

Las operaciones de dibujo para renderizar sobre la imagen.

Valores devueltos

El objeto Gmagick dibujado

Errores/Excepciones

Arroja un GmagickException en caso de error.


Mejora los bordes dentro de una imagen

  • « Gmagick::drawimage
  • Gmagick::embossimage »
  • PHP Manual
  • Gmagick
  • Mejora los bordes dentro de una imagen

Gmagick::edgeimage

(PECL gmagick >= Unknown)

Gmagick::edgeimage — Mejora los bordes dentro de una imagen

Descripción

public Gmagick::edgeimage ( float $radius ) : Gmagick

Mejora los bordes dentro de una imagen con un filtro de convolución del radio dado. Use un radio de 0 y éste será seleccionado automáticamente.

Parámetros

radius

El radio de la operación.

Valores devueltos

El objeto Gmagick con los bordes mejorados.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve una imagen en escala de grises con un efecto tridimensional

  • « Gmagick::edgeimage
  • Gmagick::enhanceimage »
  • PHP Manual
  • Gmagick
  • Devuelve una imagen en escala de grises con un efecto tridimensional

Gmagick::embossimage

(PECL gmagick >= Unknown)

Gmagick::embossimage — Devuelve una imagen en escala de grises con un efecto tridimensional

Descripción

public Gmagick::embossimage ( float $radius , float $sigma ) : Gmagick

Devuelve una imagen en escala de grises con un efecto tridimensional. Se convoluciona la imagen con un operador gaussiano del radio y desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y se elegirá un radio apropiado automáticamente.

Parámetros

radius

El radio del efecto

sigma

El valor sigma del efecto

Valores devueltos

El objeto Gmagick "repujado".

Errores/Excepciones

Arroja un GmagickException en caso de error.


Mejora la calidad de una imagen con ruido

  • « Gmagick::embossimage
  • Gmagick::equalizeimage »
  • PHP Manual
  • Gmagick
  • Mejora la calidad de una imagen con ruido

Gmagick::enhanceimage

(PECL gmagick >= Unknown)

Gmagick::enhanceimage — Mejora la calidad de una imagen con ruido

Descripción

public Gmagick::enhanceimage ( ) : Gmagick

Aplica un filtro digital que mejora la calidad de una imagen con ruido.

Valores devueltos

El objeto Gmagick mejorado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Ecualiza el histograma de la imagen

  • « Gmagick::enhanceimage
  • Gmagick::flipimage »
  • PHP Manual
  • Gmagick
  • Ecualiza el histograma de la imagen

Gmagick::equalizeimage

(PECL gmagick >= Unknown)

Gmagick::equalizeimage — Ecualiza el histograma de la imagen

Descripción

public Gmagick::equalizeimage ( ) : Gmagick

Ecualiza el histograma de la imagen.

Valores devueltos

El objeto Gmagick ecualizado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea una imagen espejo vertical

  • « Gmagick::equalizeimage
  • Gmagick::flopimage »
  • PHP Manual
  • Gmagick
  • Crea una imagen espejo vertical

Gmagick::flipimage

(PECL gmagick >= Unknown)

Gmagick::flipimage — Crea una imagen espejo vertical

Descripción

public Gmagick::flipimage ( ) : Gmagick

Crea una imagen espejo vertical reflejando los píxeles alrededor del eje x central.

Valores devueltos

The objeto Gmagick volteado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea una imagen espejo horizontal

  • « Gmagick::flipimage
  • Gmagick::frameimage »
  • PHP Manual
  • Gmagick
  • Crea una imagen espejo horizontal

Gmagick::flopimage

(PECL gmagick >= Unknown)

Gmagick::flopimage — Crea una imagen espejo horizontal

Descripción

public Gmagick::flopimage ( ) : Gmagick

Crea una imagen espejo horizontal reflejando los píxeles alrededor del eje y central.

Valores devueltos

The objeto Gmagick volteado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade un borde tridimensional simulado

  • « Gmagick::flopimage
  • Gmagick::gammaimage »
  • PHP Manual
  • Gmagick
  • Añade un borde tridimensional simulado

Gmagick::frameimage

(PECL gmagick >= Unknown)

Gmagick::frameimage — Añade un borde tridimensional simulado

Descripción

public Gmagick::frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : Gmagick

Añade un borde tridimensional simulado alrededor de la imagen. El ancho y alto especifican el ancho del borde de las caras verticales y horizontales del marco. Los biseles interior y exterior indican el ancho de las sombras interiores y exteriores del marco.

Parámetros

color

Objeto GmagickPixel o un valor de tipo float que representa el color mate

width

El ancho del borde

height

El alto del borde

inner_bevel

El ancho del bisel interior

outer_bevel

El ancho del bisel exterior

Valores devueltos

El objeto Gmagick enmarcado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Corrección gamma de una imagen

  • « Gmagick::frameimage
  • Gmagick::getcopyright »
  • PHP Manual
  • Gmagick
  • Corrección gamma de una imagen

Gmagick::gammaimage

(PECL gmagick >= Unknown)

Gmagick::gammaimage — Corrección gamma de una imagen

Descripción

public Gmagick::gammaimage ( float $gamma ) : Gmagick

Corrección gamma de una imagen. La misma imagen vista en diferentes dispositivos tendrá diferencias perceptuales en la manera en que la intensidad de la imagen esté representada en la pantalla. Especifique niveles gamma indivuduales para los canales rojo, verde y azul, o ajústelos todos con el parámetro gamma. El rango de valores es típicamente desde 0.8 a 2.3.

Parámetros

gamma

La cantidad de corrección gamma.

Valores devueltos

El objeto Gmagick con el valor gamma corregido.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el copyright de la API GraphicsMagick como una cadena

  • « Gmagick::gammaimage
  • Gmagick::getfilename »
  • PHP Manual
  • Gmagick
  • Devuelve el copyright de la API GraphicsMagick como una cadena

Gmagick::getcopyright

(PECL gmagick >= Unknown)

Gmagick::getcopyright — Devuelve el copyright de la API GraphicsMagick como una cadena

Descripción

public Gmagick::getcopyright ( ) : string

Devuelve el copyright de la API GraphicsMagick como una cadena.

Valores devueltos

Devuelve una cadena que contiene el anuncio del copyright de la API GraphicsMagick y de la API de C Magickwand.

Errores/Excepciones

Arroja un GmagickException en caso de error.


El nombre de archivo asociado a una secuencia de imágenes

  • « Gmagick::getcopyright
  • Gmagick::getimagebackgroundcolor »
  • PHP Manual
  • Gmagick
  • El nombre de archivo asociado a una secuencia de imágenes

Gmagick::getfilename

(PECL gmagick >= Unknown)

Gmagick::getfilename — El nombre de archivo asociado a una secuencia de imágenes

Descripción

public Gmagick::getfilename ( ) : string

Devuelve el nombre de archivo asociado a una secuencia de imágenes.

Valores devueltos

Devuelve una cadena si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el color de fondo de la imagen

  • « Gmagick::getfilename
  • Gmagick::getimageblueprimary »
  • PHP Manual
  • Gmagick
  • Devuelve el color de fondo de la imagen

Gmagick::getimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::getimagebackgroundcolor — Devuelve el color de fondo de la imagen

Descripción

public Gmagick::getimagebackgroundcolor ( ) : GmagickPixel

Devuelve el color de fondo de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto GmagickPixel establecido al color de fondo de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el punto primario azul de la cromaticidad

  • « Gmagick::getimagebackgroundcolor
  • Gmagick::getimagebordercolor »
  • PHP Manual
  • Gmagick
  • Devuelve el punto primario azul de la cromaticidad

Gmagick::getimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::getimageblueprimary — Devuelve el punto primario azul de la cromaticidad

Descripción

public Gmagick::getimageblueprimary ( ) : array

Devuelve el punto primario azul de la cromaticidad de una imagen.

Parámetros

x

El punto x primario azul de la cromaticidad.

y

El punto y primario azul de la cromaticidad.

Valores devueltos

Matriz consistente en las coordenadas "x" e "y" del punto.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el color del borde de la imagen

  • « Gmagick::getimageblueprimary
  • Gmagick::getimagechanneldepth »
  • PHP Manual
  • Gmagick
  • Devuelve el color del borde de la imagen

Gmagick::getimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::getimagebordercolor — Devuelve el color del borde de la imagen

Descripción

public Gmagick::getimagebordercolor ( ) : GmagickPixel

Devuelve el color del borde de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Objeto GmagickPixel que representa el color del borde

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la profundidad de un canal de imagen en particular

  • « Gmagick::getimagebordercolor
  • Gmagick::getimagecolors »
  • PHP Manual
  • Gmagick
  • Obtiene la profundidad de un canal de imagen en particular

Gmagick::getimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::getimagechanneldepth — Obtiene la profundidad de un canal de imagen en particular

Descripción

public Gmagick::getimagechanneldepth ( int $channel_type ) : int

Obtiene la profundidad de un canal de imagen en particular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La profundidad del canal de la imagen

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el color del índice del mapa de color especificado

  • « Gmagick::getimagechanneldepth
  • Gmagick::getimagecolorspace »
  • PHP Manual
  • Gmagick
  • Devuelve el color del índice del mapa de color especificado

Gmagick::getimagecolors

(PECL gmagick >= Unknown)

Gmagick::getimagecolors — Devuelve el color del índice del mapa de color especificado

Descripción

public Gmagick::getimagecolors ( ) : int

Devuelve el color del índice del mapa de color especificado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de colores en la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el espacio de colores de la imagen

  • « Gmagick::getimagecolors
  • Gmagick::getimagecompose »
  • PHP Manual
  • Gmagick
  • Obtiene el espacio de colores de la imagen

Gmagick::getimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::getimagecolorspace — Obtiene el espacio de colores de la imagen

Descripción

public Gmagick::getimagecolorspace ( ) : int

Obtiene el espacio de colores de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El espacio de colores

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el operador de composición asociado a la imagen

  • « Gmagick::getimagecolorspace
  • Gmagick::getimagedelay »
  • PHP Manual
  • Gmagick
  • Devuelve el operador de composición asociado a la imagen

Gmagick::getimagecompose

(PECL gmagick >= Unknown)

Gmagick::getimagecompose — Devuelve el operador de composición asociado a la imagen

Descripción

public Gmagick::getimagecompose ( ) : int

Devuelve el operador de composición asociado a la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el operador de composición asociado a la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obetiene el retraso de la imagen

  • « Gmagick::getimagecompose
  • Gmagick::getimagedepth »
  • PHP Manual
  • Gmagick
  • Obetiene el retraso de la imagen

Gmagick::getimagedelay

(PECL gmagick >= Unknown)

Gmagick::getimagedelay — Obetiene el retraso de la imagen

Descripción

public Gmagick::getimagedelay ( ) : int

Obetiene el retraso de la imagen

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el operados de composción asociado con la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la profundidad de la imagen

  • « Gmagick::getimagedelay
  • Gmagick::getimagedispose »
  • PHP Manual
  • Gmagick
  • Obtiene la profundidad de la imagen

Gmagick::getimagedepth

(PECL gmagick >= Unknown)

Gmagick::getimagedepth — Obtiene la profundidad de la imagen

Descripción

public Gmagick::getimagedepth ( ) : int

Obtiene la profundidad de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La profundidad de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el método de disposición de la imagen

  • « Gmagick::getimagedepth
  • Gmagick::getimageextrema »
  • PHP Manual
  • Gmagick
  • Obtiene el método de disposición de la imagen

Gmagick::getimagedispose

(PECL gmagick >= Unknown)

Gmagick::getimagedispose — Obtiene el método de disposición de la imagen

Descripción

public Gmagick::getimagedispose ( ) : int

Obtiene el método de disposición de la imagen

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el método de disposición si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene los extremos de la imagen

  • « Gmagick::getimagedispose
  • Gmagick::getimagefilename »
  • PHP Manual
  • Gmagick
  • Obtiene los extremos de la imagen

Gmagick::getimageextrema

(PECL gmagick >= Unknown)

Gmagick::getimageextrema — Obtiene los extremos de la imagen

Descripción

public Gmagick::getimageextrema ( ) : array

Devuelve una matriz asociativa con las claves "min" y "max". Arroja un GmagickException en caso de error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz asociativa con las claves "min" y "max".

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el nombre de archivo de una imagen en particular de una secuencia

  • « Gmagick::getimageextrema
  • Gmagick::getimageformat »
  • PHP Manual
  • Gmagick
  • Devuelve el nombre de archivo de una imagen en particular de una secuencia

Gmagick::getimagefilename

(PECL gmagick >= Unknown)

Gmagick::getimagefilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia

Descripción

public Gmagick::getimagefilename ( ) : string

Devuelve el nombre de archivo de una imagen en particular de una secuencia

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena con el nombre de archivo de la imagen

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el formato de una imagen en particular de una secuencia

  • « Gmagick::getimagefilename
  • Gmagick::getimagegamma »
  • PHP Manual
  • Gmagick
  • Devuelve el formato de una imagen en particular de una secuencia

Gmagick::getimageformat

(PECL gmagick >= Unknown)

Gmagick::getimageformat — Devuelve el formato de una imagen en particular de una secuencia

Descripción

public Gmagick::getimageformat ( ) : string

Devuelve el formato de una imagen en particular de una secuencia.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena que contiene el formato de imagen si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el valor gamma de la imagen

  • « Gmagick::getimageformat
  • Gmagick::getimagegreenprimary »
  • PHP Manual
  • Gmagick
  • Obtiene el valor gamma de la imagen

Gmagick::getimagegamma

(PECL gmagick >= Unknown)

Gmagick::getimagegamma — Obtiene el valor gamma de la imagen

Descripción

public Gmagick::getimagegamma ( ) : float

Obtiene el valor gamma de la imagen

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor gamma de la imagen si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el punto primario verde de la cromaticidad

  • « Gmagick::getimagegamma
  • Gmagick::getimageheight »
  • PHP Manual
  • Gmagick
  • Devuelve el punto primario verde de la cromaticidad

Gmagick::getimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::getimagegreenprimary — Devuelve el punto primario verde de la cromaticidad

Descripción

public Gmagick::getimagegreenprimary ( ) : array

Devuelve el punto primario verde de la cromaticidad. Devuelve una matriz con las claves "x" e "y".

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz con las claves "x" e "y" si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el alto de la imagen

  • « Gmagick::getimagegreenprimary
  • Gmagick::getimagehistogram »
  • PHP Manual
  • Gmagick
  • Devuelve el alto de la imagen

Gmagick::getimageheight

(PECL gmagick >= Unknown)

Gmagick::getimageheight — Devuelve el alto de la imagen

Descripción

public Gmagick::getimageheight ( ) : int

Devuelve el alto de la imagen

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el alto de la imagen en píxeles.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el histograma de la imagen

  • « Gmagick::getimageheight
  • Gmagick::getimageindex »
  • PHP Manual
  • Gmagick
  • Obtiene el histograma de la imagen

Gmagick::getimagehistogram

(PECL gmagick >= Unknown)

Gmagick::getimagehistogram — Obtiene el histograma de la imagen

Descripción

public Gmagick::getimagehistogram ( ) : array

Devuelve el histograma de la imagen como una matriz de objetos GmagickPixel. Lanza una excepción de tipo GmagickException si se produjo un error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el histograma de la imagen como una matriz de objetos GmagickPixel.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el índice de la imagen activa actual

  • « Gmagick::getimagehistogram
  • Gmagick::getimageinterlacescheme »
  • PHP Manual
  • Gmagick
  • Obtiene el índice de la imagen activa actual

Gmagick::getimageindex

(PECL gmagick >= Unknown)

Gmagick::getimageindex — Obtiene el índice de la imagen activa actual

Descripción

public Gmagick::getimageindex ( ) : int

Devuelve el índice de la imagen activa actual dentro del objeto Gmagick.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice de la imagen activa actual

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la combinación de entrelazado de la imagen

  • « Gmagick::getimageindex
  • Gmagick::getimageiterations »
  • PHP Manual
  • Gmagick
  • Obtiene la combinación de entrelazado de la imagen

Gmagick::getimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::getimageinterlacescheme — Obtiene la combinación de entrelazado de la imagen

Descripción

public Gmagick::getimageinterlacescheme ( ) : int

Obtiene la combinación de entrelazado de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la combinación de entrelazado como un integer si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene las iteraciones de la imagen

  • « Gmagick::getimageinterlacescheme
  • Gmagick::getimagematte »
  • PHP Manual
  • Gmagick
  • Obtiene las iteraciones de la imagen

Gmagick::getimageiterations

(PECL gmagick >= Unknown)

Gmagick::getimageiterations — Obtiene las iteraciones de la imagen

Descripción

public Gmagick::getimageiterations ( ) : int

Obtiene las iteraciones de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las iteraciones de la imagen como un valor integer.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Comprobar si la imagen tiene un canal mate

  • « Gmagick::getimageiterations
  • Gmagick::getimagemattecolor »
  • PHP Manual
  • Gmagick
  • Comprobar si la imagen tiene un canal mate

Gmagick::getimagematte

(PECL gmagick >= Unknown)

Gmagick::getimagematte — Comprobar si la imagen tiene un canal mate

Descripción

public Gmagick::getimagematte ( ) : int

Devuelve true si la imagen tiene un canal mate, si no, devuelve false.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la imagen tiene un canal mate, si no, devuelve false.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el color mate de la imagen

  • « Gmagick::getimagematte
  • Gmagick::getimageprofile »
  • PHP Manual
  • Gmagick
  • Devuelve el color mate de la imagen

Gmagick::getimagemattecolor

(PECL gmagick >= Unknown)

Gmagick::getimagemattecolor — Devuelve el color mate de la imagen

Descripción

public Gmagick::getimagemattecolor ( ) : GmagickPixel

Devuelve un objeto GmagickPixel si se tuvo éxtito. Lanza un excepción GmagickException si se produjo un error.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto GmagickPixel si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el perfil nominado de la imagen

  • « Gmagick::getimagemattecolor
  • Gmagick::getimageredprimary »
  • PHP Manual
  • Gmagick
  • Devuelve el perfil nominado de la imagen

Gmagick::getimageprofile

(PECL gmagick >= Unknown)

Gmagick::getimageprofile — Devuelve el perfil nominado de la imagen

Descripción

public Gmagick::getimageprofile ( string $name ) : string

Devuelve el perfil nominado de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena que contiene el perfil de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el punto primario rojo de la cromaticidad

  • « Gmagick::getimageprofile
  • Gmagick::getimagerenderingintent »
  • PHP Manual
  • Gmagick
  • Devuelve el punto primario rojo de la cromaticidad

Gmagick::getimageredprimary

(PECL gmagick >= Unknown)

Gmagick::getimageredprimary — Devuelve el punto primario rojo de la cromaticidad

Descripción

public Gmagick::getimageredprimary ( ) : array

Devuelve el punto primario rojo de la cromaticidad como una matriz con las claves "x" e "y".

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el punto primario rojo de la cromaticidad como una matriz con las claves "x" e "y".

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la propuesta de renderización de la imagen

  • « Gmagick::getimageredprimary
  • Gmagick::getimageresolution »
  • PHP Manual
  • Gmagick
  • Obtiene la propuesta de renderización de la imagen

Gmagick::getimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::getimagerenderingintent — Obtiene la propuesta de renderización de la imagen

Descripción

public Gmagick::getimagerenderingintent ( ) : int

Obtiene la propuesta de renderización de la imagen

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Extrae una región de la imagen y la devuelve como una nueva varita

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la resolución X e Y de la imagen

  • « Gmagick::getimagerenderingintent
  • Gmagick::getimagescene »
  • PHP Manual
  • Gmagick
  • Obtiene la resolución X e Y de la imagen

Gmagick::getimageresolution

(PECL gmagick >= Unknown)

Gmagick::getimageresolution — Obtiene la resolución X e Y de la imagen

Descripción

public Gmagick::getimageresolution ( ) : array

Devuelve la resolución como una matriz.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la resolución como una matriz.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la escena de la imagen

  • « Gmagick::getimageresolution
  • Gmagick::getimagesignature »
  • PHP Manual
  • Gmagick
  • Obtiene la escena de la imagen

Gmagick::getimagescene

(PECL gmagick >= Unknown)

Gmagick::getimagescene — Obtiene la escena de la imagen

Descripción

public Gmagick::getimagescene ( ) : int

Obtiene la escena de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la escena de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Genera un resumen de un mensaje SHA-256

  • « Gmagick::getimagescene
  • Gmagick::getimagetype »
  • PHP Manual
  • Gmagick
  • Genera un resumen de un mensaje SHA-256

Gmagick::getimagesignature

(PECL gmagick >= Unknown)

Gmagick::getimagesignature — Genera un resumen de un mensaje SHA-256

Descripción

public Gmagick::getimagesignature ( ) : string

Genera un resumen de un mensaje SHA-256 para el flujo de píxeles de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena que contiene el hash SHA-256 del archivo.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el tipo de imagen potencial.

  • « Gmagick::getimagesignature
  • Gmagick::getimageunits »
  • PHP Manual
  • Gmagick
  • Obtiene el tipo de imagen potencial.

Gmagick::getimagetype

(PECL gmagick >= Unknown)

Gmagick::getimagetype — Obtiene el tipo de imagen potencial.

Descripción

public Gmagick::getimagetype ( ) : int

Obtiene el tipo de imagen potencial.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tipo de imagen potencial.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene las unidades de resolución de la imagen

  • « Gmagick::getimagetype
  • Gmagick::getimagewhitepoint »
  • PHP Manual
  • Gmagick
  • Obtiene las unidades de resolución de la imagen

Gmagick::getimageunits

(PECL gmagick >= Unknown)

Gmagick::getimageunits — Obtiene las unidades de resolución de la imagen

Descripción

public Gmagick::getimageunits ( ) : int

Obtiene las unidades de resolución de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las unidades de resolución de la imagen.


Devuelve el punto blanco de la cromaticidad

  • « Gmagick::getimageunits
  • Gmagick::getimagewidth »
  • PHP Manual
  • Gmagick
  • Devuelve el punto blanco de la cromaticidad

Gmagick::getimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::getimagewhitepoint — Devuelve el punto blanco de la cromaticidad

Descripción

public Gmagick::getimagewhitepoint ( ) : array

Devuelve el punto blanco de la cromaticidad como una matriz asociativa con las claves "x" e "y".

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el punto blanco de la cromaticidad como una matriz asociativa con las claves "x" e "y".

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el ancho de la imagen

  • « Gmagick::getimagewhitepoint
  • Gmagick::getpackagename »
  • PHP Manual
  • Gmagick
  • Devuelve el ancho de la imagen

Gmagick::getimagewidth

(PECL gmagick >= Unknown)

Gmagick::getimagewidth — Devuelve el ancho de la imagen

Descripción

public Gmagick::getimagewidth ( ) : int

Devuelve el ancho de la imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el ancho de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el nombre del paquete de GraphicsMagick

  • « Gmagick::getimagewidth
  • Gmagick::getquantumdepth »
  • PHP Manual
  • Gmagick
  • Devuelve el nombre del paquete de GraphicsMagick

Gmagick::getpackagename

(PECL gmagick >= Unknown)

Gmagick::getpackagename — Devuelve el nombre del paquete de GraphicsMagick

Descripción

public Gmagick::getpackagename ( ) : string

Devuelve el nombre del paquete de GraphicsMagick.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del paquete de GraphicsMagick como una cadena.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene la profundidad de la cuantía de Gmagick como una cadena

  • « Gmagick::getpackagename
  • Gmagick::getreleasedate »
  • PHP Manual
  • Gmagick
  • Obtiene la profundidad de la cuantía de Gmagick como una cadena

Gmagick::getquantumdepth

(PECL gmagick >= Unknown)

Gmagick::getquantumdepth — Obtiene la profundidad de la cuantía de Gmagick como una cadena

Descripción

public Gmagick::getquantumdepth ( ) : array

Obtiene la profundidad de la cuantía de Gmagick como una cadena.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Obtiene la profundidad de la cuantía de Gmagick como una cadena.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve la fecha de distribución de GraphicsMagick como una cadena

  • « Gmagick::getquantumdepth
  • Gmagick::getsamplingfactors »
  • PHP Manual
  • Gmagick
  • Devuelve la fecha de distribución de GraphicsMagick como una cadena

Gmagick::getreleasedate

(PECL gmagick >= Unknown)

Gmagick::getreleasedate — Devuelve la fecha de distribución de GraphicsMagick como una cadena

Descripción

public Gmagick::getreleasedate ( ) : string

Devuelve la fecha de distribución de GraphicsMagick como una cadena.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la fecha de distribución de GraphicsMagick como una cadena.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Obtiene el factor de muestreo horizontal y vertical

  • « Gmagick::getreleasedate
  • Gmagick::getsize »
  • PHP Manual
  • Gmagick
  • Obtiene el factor de muestreo horizontal y vertical

Gmagick::getsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::getsamplingfactors — Obtiene el factor de muestreo horizontal y vertical

Descripción

public Gmagick::getsamplingfactors ( ) : array

Obtiene el factor de muestreo horizontal y vertical.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz asociativa con el factor de muestreo horizontal y vertical de la imagen.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve el tamaño asociado con el objeto Gmagick

  • « Gmagick::getsamplingfactors
  • Gmagick::getversion »
  • PHP Manual
  • Gmagick
  • Devuelve el tamaño asociado con el objeto Gmagick

Gmagick::getsize

(PECL gmagick >= Unknown)

Gmagick::getsize — Devuelve el tamaño asociado con el objeto Gmagick

Descripción

public Gmagick::getsize ( ) : array

Devuelve el tamaño asociado con el objeto Gmagick como una matriz con las claves "columns" (columnas) y "rows" (filas).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño asociado con el objeto Gmagick como una matriz con las claves "columns" (columnas) y "rows" (filas).

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve la versión de la API GraphicsMagick

  • « Gmagick::getsize
  • Gmagick::hasnextimage »
  • PHP Manual
  • Gmagick
  • Devuelve la versión de la API GraphicsMagick

Gmagick::getversion

(PECL gmagick >= Unknown)

Gmagick::getversion — Devuelve la versión de la API GraphicsMagick

Descripción

public Gmagick::getversion ( ) : array

Devuelve la versión de la API GraphicsMagick como una cadena y como un número.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la versión de la API GraphicsMagick como una cadena y como un número.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Comprueba si el objeto tiene más imágenes

  • « Gmagick::getversion
  • Gmagick::haspreviousimage »
  • PHP Manual
  • Gmagick
  • Comprueba si el objeto tiene más imágenes

Gmagick::hasnextimage

(PECL gmagick >= Unknown)

Gmagick::hasnextimage — Comprueba si el objeto tiene más imágenes

Descripción

public Gmagick::hasnextimage ( ) : mixed

Devuelve TRUE si el objeto tiene más imágenes cuando se atraviesa la lista en dirección hacia delante.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve TRUE si el objeto tiene más imágenes cuando se atraviesa la lista en dirección hacia delante, devuelve FALSE si no hay ninguna.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Verifica si el objeto tiene una imagen previa

  • « Gmagick::hasnextimage
  • Gmagick::implodeimage »
  • PHP Manual
  • Gmagick
  • Verifica si el objeto tiene una imagen previa

Gmagick::haspreviousimage

(PECL gmagick >= Unknown)

Gmagick::haspreviousimage — Verifica si el objeto tiene una imagen previa

Descripción

public Gmagick::haspreviousimage ( ) : mixed

Devuelve TRUE si el objeto tiene más imágenes cuando se atraviesa la lista en la dirección opuesta

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve TRUE si el objeto tiene más imágenes cuando se atraviesa la lista en la dirección opuesta, devuelve FALSE si no hay ninguna.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea una nueva imagen como una copia

  • « Gmagick::haspreviousimage
  • Gmagick::labelimage »
  • PHP Manual
  • Gmagick
  • Crea una nueva imagen como una copia

Gmagick::implodeimage

(PECL gmagick >= Unknown)

Gmagick::implodeimage — Crea una nueva imagen como una copia

Descripción

public Gmagick::implodeimage ( float $radius ) : mixed

Crea una nueva imagen que es una copia de una existente con los píxeles de la imagen "implosionados" por el porcentaje especificado.

Parámetros

radius

El radio de la implosión

Valores devueltos

Devuelve el objeto Gmagick implosionado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade una etiqueta a una imagen

  • « Gmagick::implodeimage
  • Gmagick::levelimage »
  • PHP Manual
  • Gmagick
  • Añade una etiqueta a una imagen

Gmagick::labelimage

(PECL gmagick >= Unknown)

Gmagick::labelimage — Añade una etiqueta a una imagen

Descripción

public Gmagick::labelimage ( string $label ) : mixed

Añade una etiqueta a una imagen.

Parámetros

label

La etiqueta a añadir

Valores devueltos

Objeto Gmagick con etiqueta.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Ajusta los niveles de la imagen

  • « Gmagick::labelimage
  • Gmagick::magnifyimage »
  • PHP Manual
  • Gmagick
  • Ajusta los niveles de la imagen

Gmagick::levelimage

(PECL gmagick >= Unknown)

Gmagick::levelimage — Ajusta los niveles de la imagen

Descripción

public Gmagick::levelimage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Gmagick::CHANNEL_DEFAULT ) : mixed

Ajusta los niveles de una imagen escalando la caída de los colores entre los puntos blanco y negro especificados al rango completo de cuantía disponible. Los parámetros proporcionados representan los puntos negro, mitad, y blanco. El punto negro especifica el color más oscuro de la imagen. Los colores más oscuros que el punto negro se establecen a cero. El punto medio especifica una corrección gamma a aplicar a la imagen. Mientras que el punto blanco especifica el color más claro de la imagen. Los colores más claros que el punto blanco se establecen al valor de cuantía máximo.

Parámetros

blackPoint

El punto negro de la imagen

gamma

El valor gamma

whitePoint

El punto blanco de la imagen

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Objeto Gmagick con la imagen nivelada.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Escala una imagen x2 proporcionalmente

  • « Gmagick::levelimage
  • Gmagick::mapimage »
  • PHP Manual
  • Gmagick
  • Escala una imagen x2 proporcionalmente

Gmagick::magnifyimage

(PECL gmagick >= Unknown)

Gmagick::magnifyimage — Escala una imagen x2 proporcionalmente

Descripción

public Gmagick::magnifyimage ( ) : mixed

Escala convenientemente una imagen proporcionalmente al doble de su tamaño original.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick ampliado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

  • « Gmagick::magnifyimage
  • Gmagick::medianfilterimage »
  • PHP Manual
  • Gmagick
  • Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

Gmagick::mapimage

(PECL gmagick >= Unknown)

Gmagick::mapimage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

Descripción

public Gmagick::mapimage ( gmagick $gmagick , bool $dither ) : Gmagick

Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia.

Parámetros

gmagick

La imagen de referencia

dither

Establezca este valor integer a algo distinto cero para entramar la imagen mapeada

Valores devueltos

Objeto Gmagick

Errores/Excepciones

Arroja un GmagickException en caso de error.


Aplica un filtro digital

  • « Gmagick::mapimage
  • Gmagick::minifyimage »
  • PHP Manual
  • Gmagick
  • Aplica un filtro digital

Gmagick::medianfilterimage

(PECL gmagick >= Unknown)

Gmagick::medianfilterimage — Aplica un filtro digital

Descripción

public Gmagick::medianfilterimage ( float $radius ) : void

Aplica un filtro digital que mejora la calidad de una imagen con ruido. Cada píxel es reemplazado por la media en un conjunto de píxeles inmediatos como está definido por el radio.

Parámetros

radius

El radio de la zona inmediata de los píxeles.

Valores devueltos

Objeto Gmagick con el filtro de media aplicado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Escala una imagen proporcionalmente a la mitad de su tamaño

  • « Gmagick::medianfilterimage
  • Gmagick::modulateimage »
  • PHP Manual
  • Gmagick
  • Escala una imagen proporcionalmente a la mitad de su tamaño

Gmagick::minifyimage

(PECL gmagick >= Unknown)

Gmagick::minifyimage — Escala una imagen proporcionalmente a la mitad de su tamaño

Descripción

public Gmagick::minifyimage ( ) : Gmagick

Un método conveniente que escala una imagen proporcionalmente a la mitad de su tamaño original

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Controla el brillo, la saturación y el tono

  • « Gmagick::minifyimage
  • Gmagick::motionblurimage »
  • PHP Manual
  • Gmagick
  • Controla el brillo, la saturación y el tono

Gmagick::modulateimage

(PECL gmagick >= Unknown)

Gmagick::modulateimage — Controla el brillo, la saturación y el tono

Descripción

public Gmagick::modulateimage ( float $brightness , float $saturation , float $hue ) : Gmagick

Permite controlar el brillo, la saturación y el tono de una imagen. El tono es el porcentaje de la rotación absoluta desde la posición actual. Por ejemplo, 50 resulta en una rotación en el sentido contrario a las agujas del reloj de 90 grados, 150 resulta en una rotación en el sentido de las agujas del reloj de 90 grados, con 0 y 200 resultando en una rotación de 180 grados.

Parámetros

brightness

El cambio de porcentaje en brillo (-100 a +100).

saturation

El cambio de porcentaje en saturación (-100 a +100)

hue

El cambio de porcentaje en tono (-100 a +100)

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Simula borrosidad en movimiento

  • « Gmagick::modulateimage
  • Gmagick::newimage »
  • PHP Manual
  • Gmagick
  • Simula borrosidad en movimiento

Gmagick::motionblurimage

(PECL gmagick >= Unknown)

Gmagick::motionblurimage — Simula borrosidad en movimiento

Descripción

public Gmagick::motionblurimage ( float $radius , float $sigma , float $angle ) : Gmagick

Simula borrosidad en movimiento. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debe ser mayor que sigma. Use un radio de 0 y MotionBlurImage() seleccionará un radio apropiado automáticamente. El ángulo da el ángulo del movimiento borroso.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central.

sigma

La desviación estándar gaussiana, en píxeles.

angle

Aplica el efecto a lo largo de este ángulo.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea una nueva imagen

  • « Gmagick::motionblurimage
  • Gmagick::nextimage »
  • PHP Manual
  • Gmagick
  • Crea una nueva imagen

Gmagick::newimage

(PECL gmagick >= Unknown)

Gmagick::newimage — Crea una nueva imagen

Descripción

public Gmagick::newimage ( int $width , int $height , string $background , string $format = ? ) : Gmagick

Crea una nueva imagen con el color de fondo especificado

Parámetros

width

Ancho de la nueva imagen

height

Alto de la nueva imagen

background

El color de fondo usado para esta imagen (como float)

format

Formato de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Moverse a la siguiente imagen

  • « Gmagick::newimage
  • Gmagick::normalizeimage »
  • PHP Manual
  • Gmagick
  • Moverse a la siguiente imagen

Gmagick::nextimage

(PECL gmagick >= Unknown)

Gmagick::nextimage — Moverse a la siguiente imagen

Descripción

public Gmagick::nextimage ( ) : bool

Asocia la siguiente imagen de la lista de ímágenes con un objeto Gmagick.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Mejora el contraste de una imagen a color

  • « Gmagick::nextimage
  • Gmagick::oilpaintimage »
  • PHP Manual
  • Gmagick
  • Mejora el contraste de una imagen a color

Gmagick::normalizeimage

(PECL gmagick >= Unknown)

Gmagick::normalizeimage — Mejora el contraste de una imagen a color

Descripción

public Gmagick::normalizeimage ( int $channel = ? ) : Gmagick

Mejora el contraste de una imagen a color ajustando los colores de los píxeles para abarcar el rango completo de colores disponibles.

Parámetros

channel

Identifica el canal a normalizar

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Simula una pintura al óleo

  • « Gmagick::normalizeimage
  • Gmagick::previousimage »
  • PHP Manual
  • Gmagick
  • Simula una pintura al óleo

Gmagick::oilpaintimage

(PECL gmagick >= Unknown)

Gmagick::oilpaintimage — Simula una pintura al óleo

Descripción

public Gmagick::oilpaintimage ( float $radius ) : Gmagick

Aplica un filtro de efecto especial que simula una pintura al óleo. Cada píxel es reemplazado por el color más frecuente que suceda en una región circular definida por el radio.

Parámetros

radius

El radio de la zona inmediata circular.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Moverse a la imagen previa del objeto

  • « Gmagick::oilpaintimage
  • Gmagick::profileimage »
  • PHP Manual
  • Gmagick
  • Moverse a la imagen previa del objeto

Gmagick::previousimage

(PECL gmagick >= Unknown)

Gmagick::previousimage — Moverse a la imagen previa del objeto

Descripción

public Gmagick::previousimage ( ) : bool

Asocia la imagen previa de una lista de imágenes con el objeto Gmagick.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade o elimina un perfil de una imagen

  • « Gmagick::previousimage
  • Gmagick::quantizeimage »
  • PHP Manual
  • Gmagick
  • Añade o elimina un perfil de una imagen

Gmagick::profileimage

(PECL gmagick >= Unknown)

Gmagick::profileimage — Añade o elimina un perfil de una imagen

Descripción

public Gmagick::profileimage ( string $name , string $profile ) : Gmagick

Añade o elimina un perfil ICC, IPTC, o genérico de una imagen. Si el perfil es NULL, se elimina de la imagen, si no, se añade. Use como nombre '*' y un perfil NULL para eliminar todos los perfiles de la imagen.

Parámetros

name

Nombre del perfil a añadir o eliminar: ICC, IPTC, o perfil genérico.

profile

El perfil.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Analiza los colores dentro de una imagen de referencia

  • « Gmagick::profileimage
  • Gmagick::quantizeimages »
  • PHP Manual
  • Gmagick
  • Analiza los colores dentro de una imagen de referencia

Gmagick::quantizeimage

(PECL gmagick >= Unknown)

Gmagick::quantizeimage — Analiza los colores dentro de una imagen de referencia

Descripción

public Gmagick::quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick

Analiza los colores dentro de una imagen de referencia y elige un número fijo de colores que representan la imagen. El objetivo del algoritmo es minimizar la diferencia de colores entre la imagen de entrada y de salida mientras minimiza el tiempo de procesamiento.

Parámetros

numColors

El número de colores.

colorspace

Lleva a cabo una reducción de color en este espacio de color, normalmaente RGBColorspace.

treeDepth

Normalmente, este valor de tipo integer es cero o uno. Un cero o uno indica a Quantize que elija una profundidad de árbol óptima de Log4(número_colores).% Un árbol de esta profundidad generalmente permite la mejor representación de la imagen de referencia con la menor cantidad de memoria y la velocidad de computación más rápida. En algunos casos, como una imagen con dispersión de color baja (un número bajo de colores), se requiere un valor distinto de Log4(número_colores). Para expandir el árbol de colores completamente, use un valor de 8.

dither

Un valor distinto de cero distribuye la diferencia entre una imagen original y el algoritmo de reducción de color correspondiente a los píxeles de la zona inmediata a lo largo de una curva de Hilbert.

measureError

Un valor distinto de cero mide la diferencia entre la imagen original y la cuantificada. Esta diferencia es el error de cuantización total. El error se computa sumando, en todos los píxeles de una imagen, la distancia al cuadrado en el espacio RGB entre cada valor de píxel de referncia y su valor cuantizado.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Analiza los colores dentro de una secuencia de imágenes

  • « Gmagick::quantizeimage
  • Gmagick::queryfontmetrics »
  • PHP Manual
  • Gmagick
  • Analiza los colores dentro de una secuencia de imágenes

Gmagick::quantizeimages

(PECL gmagick >= Unknown)

Gmagick::quantizeimages — Analiza los colores dentro de una secuencia de imágenes

Descripción

public Gmagick::quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick

Analiza los colores dentro de una secuencia de imágenes y elige un número fijo de colores que representan la imagen. El objetivo del algoritmo es minimizar la diferencia de colores entre la imagen de entrada y de salida mientras minimiza el tiempo de procesamiento.

Parámetros

numColors

El número de colores.

colorspace

Lleva a cabo una reducción de color en este espacio de color, normalmaente RGBColorspace.

treeDepth

Normalmente, este valor de tipo integer es cero o uno. Un cero o uno indica a Quantize que elija una profundidad de árbol óptima de Log4(número_colores).% Un árbol de esta profundidad generalmente permite la mejor representación de la imagen de referencia con la menor cantidad de memoria y la velocidad de computación más rápida. En algunos casos, como una imagen con dispersión de color baja (un número bajo de colores), se requiere un valor distinto de Log4(número_colores). Para expandir el árbol de colores completamente, use un valor de 8.

dither

Un valor distinto de cero distribuye la diferencia entre una imagen original y el algoritmo de reducción de color correspondiente a los píxeles de la zona inmediata a lo largo de una curva de Hilbert.

measureError

Un valor distinto de cero mide la diferencia entre la imagen original y la cuantificada. Esta diferencia es el error de cuantización total. El error se computa sumando, en todos los píxeles de una imagen, la distancia al cuadrado en el espacio RGB entre cada valor de píxel de referncia y su valor cuantizado.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve una matriz que representa las métricas de la fuente

  • « Gmagick::quantizeimages
  • Gmagick::queryfonts »
  • PHP Manual
  • Gmagick
  • Devuelve una matriz que representa las métricas de la fuente

Gmagick::queryfontmetrics

(PECL gmagick >= Unknown)

Gmagick::queryfontmetrics — Devuelve una matriz que representa las métricas de la fuente

Descripción

public Gmagick::queryfontmetrics ( GmagickDraw $draw , string $text ) : array

MagickQueryFontMetrics() devuelve una matriz que representa las métricas de la fuente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve las fuentes configuradas

  • « Gmagick::queryfontmetrics
  • Gmagick::queryformats »
  • PHP Manual
  • Gmagick
  • Devuelve las fuentes configuradas

Gmagick::queryfonts

(PECL gmagick >= Unknown)

Gmagick::queryfonts — Devuelve las fuentes configuradas

Descripción

public Gmagick::queryfonts ( string $pattern = "*" ) : array

Devuelve las fuentes soportadas por Gmagick.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Devuelve los formatos admitidos por Gmagick

  • « Gmagick::queryfonts
  • Gmagick::radialblurimage »
  • PHP Manual
  • Gmagick
  • Devuelve los formatos admitidos por Gmagick

Gmagick::queryformats

(PECL gmagick >= Unknown)

Gmagick::queryformats — Devuelve los formatos admitidos por Gmagick

Descripción

public Gmagick::queryformats ( string $pattern = "*" ) : array

Devuelve los formatos admitidos por Gmagick.

Parámetros

pattern

Especifica un string que contiene un patrón.

Valores devueltos

El objeto Gmagick en caso de éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Hace borrosa de forma radial una imagen

  • « Gmagick::queryformats
  • Gmagick::raiseimage »
  • PHP Manual
  • Gmagick
  • Hace borrosa de forma radial una imagen

Gmagick::radialblurimage

(PECL gmagick >= Unknown)

Gmagick::radialblurimage — Hace borrosa de forma radial una imagen

Descripción

public Gmagick::radialblurimage ( float $angle , int $channel = Gmagick::CHANNEL_DEFAULT ) : Gmagick

Hace borrosa de forma radial una imagen.

Parámetros

angle

El ángulo de la borrosidad en grados.

channel

El canal relacionado.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea un efecto de botón en 3D simulado

  • « Gmagick::radialblurimage
  • Gmagick::read »
  • PHP Manual
  • Gmagick
  • Crea un efecto de botón en 3D simulado

Gmagick::raiseimage

(PECL gmagick >= Unknown)

Gmagick::raiseimage — Crea un efecto de botón en 3D simulado

Descripción

public Gmagick::raiseimage ( int $width , int $height , int $x , int $y , bool $raise ) : Gmagick

Crea un efecto de botón tridimensional simulado aclarando y oscureciendo los bordes de la imagen. Los miembros ancho y alto de la información de elevación definen el ancho del borde vertical y horizontal del efecto.

Parámetros

width

Ancho del área a realzar.

height

Alto del área a realzar.

x

Coordenada X

y

Coordenada Y

raise

Un valor distinto de cero crea un efecto de realzado en 3D, de otro modo tiene un efecto contrario.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Lee una imagen desde un nombre de archivo

  • « Gmagick::raiseimage
  • Gmagick::readimage »
  • PHP Manual
  • Gmagick
  • Lee una imagen desde un nombre de archivo

Gmagick::read

(PECL gmagick >= Unknown)

Gmagick::read — Lee una imagen desde un nombre de archivo

Descripción

public Gmagick::read ( string $filename ) : Gmagick

Lee una imagen desde un nombre de archivo.

Parámetros

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Lee una imagen desde un nombre de archivo

  • « Gmagick::read
  • Gmagick::readimageblob »
  • PHP Manual
  • Gmagick
  • Lee una imagen desde un nombre de archivo

Gmagick::readimage

(PECL gmagick >= Unknown)

Gmagick::readimage — Lee una imagen desde un nombre de archivo

Descripción

public Gmagick::readimage ( string $filename ) : Gmagick

Lee una imagen desde un nombre de archivo.

Parámetros

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Lee una imagen desde una cadena binaria

  • « Gmagick::readimage
  • Gmagick::readimagefile »
  • PHP Manual
  • Gmagick
  • Lee una imagen desde una cadena binaria

Gmagick::readimageblob

(PECL gmagick >= Unknown)

Gmagick::readimageblob — Lee una imagen desde una cadena binaria

Descripción

public Gmagick::readimageblob ( string $imageContents , string $filename = ? ) : Gmagick

Lee una imagen desde una cadena binaria.

Parámetros

imageContents

El contenido de la imagen

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Lee una imagen desde un descriptor de archivo abierto

  • « Gmagick::readimageblob
  • Gmagick::reducenoiseimage »
  • PHP Manual
  • Gmagick
  • Lee una imagen desde un descriptor de archivo abierto

Gmagick::readimagefile

(PECL gmagick >= Unknown)

Gmagick::readimagefile — Lee una imagen desde un descriptor de archivo abierto

Descripción

public Gmagick::readimagefile ( resource $fp , string $filename = ? ) : Gmagick

Lee una imagen o secuencia de imágenes desde un descriptor de archivo abierto.

Parámetros

fp

El descriptor de archivo.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Suaviza los contornos de una imagen

  • « Gmagick::readimagefile
  • Gmagick::removeimage »
  • PHP Manual
  • Gmagick
  • Suaviza los contornos de una imagen

Gmagick::reducenoiseimage

(PECL gmagick >= Unknown)

Gmagick::reducenoiseimage — Suaviza los contornos de una imagen

Descripción

public Gmagick::reducenoiseimage ( float $radius ) : Gmagick

Suaviza los contornos de una imagen mientras que se preserva todavía la información del borde. El algoritmo funciona reemplazando cada píxel con su más cercano inmediato en valor. La zona inmediata está definida por el radio. Use un radio de 0 y Gmagick::reduceNoiseImage() seleccionará una radio apropiado automáticamente.

Parámetros

radius

El radio de la zona inmediata de píxeles.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Elimina una imagen de la lista de imágenes

  • « Gmagick::reducenoiseimage
  • Gmagick::removeimageprofile »
  • PHP Manual
  • Gmagick
  • Elimina una imagen de la lista de imágenes

Gmagick::removeimage

(PECL gmagick >= Unknown)

Gmagick::removeimage — Elimina una imagen de la lista de imágenes

Descripción

public Gmagick::removeimage ( ) : Gmagick

Elimina una imagen de la lista de imágenes.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Elimina el perfil nombrado de la imagen y lo devuelve

  • « Gmagick::removeimage
  • Gmagick::resampleimage »
  • PHP Manual
  • Gmagick
  • Elimina el perfil nombrado de la imagen y lo devuelve

Gmagick::removeimageprofile

(PECL gmagick >= Unknown)

Gmagick::removeimageprofile — Elimina el perfil nombrado de la imagen y lo devuelve

Descripción

public Gmagick::removeimageprofile ( string $name ) : string

Elimina el perfil nombrado de la imagen y lo devuelve.

Parámetros

name

El nombre del perfil a devolver: ICC, IPTC, o perfil genérico.

Valores devueltos

El perfil nombrado.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Re-muestrea la imagen a la resolución deseada

  • « Gmagick::removeimageprofile
  • Gmagick::resizeimage »
  • PHP Manual
  • Gmagick
  • Re-muestrea la imagen a la resolución deseada

Gmagick::resampleimage

(PECL gmagick >= Unknown)

Gmagick::resampleimage — Re-muestrea la imagen a la resolución deseada

Descripción

public Gmagick::resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur ) : Gmagick

Re-muestrea la imagen a la resolución deseada.

Parámetros

xResolution

La nueva resolución x de la imagen.

yResolution

La nueva resolución x de la imagen.

filter

El filtro de imagen a usar.

blur

El factor de borrosidad donde mayor que que es borroso, menor que uno es nítido.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Escala una imagen

  • « Gmagick::resampleimage
  • Gmagick::rollimage »
  • PHP Manual
  • Gmagick
  • Escala una imagen

Gmagick::resizeimage

(PECL gmagick >= Unknown)

Gmagick::resizeimage — Escala una imagen

Descripción

public Gmagick::resizeimage ( int $width , int $height , int $filter , float $blur , bool $fit = false ) : Gmagick

Escala una imagen a las dimensiones deseadas con un filtro.

Parámetros

width

El número de columnas en la imagen escalada.

height

El número de filas en la imagen escalada.

filter

El filtro de imagen a usar.

blur

El factor de borrosidad dondo mayor que 1 es borroso, menor que 1 es nítido.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Compensa una imagen

  • « Gmagick::resizeimage
  • Gmagick::rotateimage »
  • PHP Manual
  • Gmagick
  • Compensa una imagen

Gmagick::rollimage

(PECL gmagick >= Unknown)

Gmagick::rollimage — Compensa una imagen

Descripción

public Gmagick::rollimage ( int $x , int $y ) : Gmagick

Compensa una imagen tal como está definido por x e y.

Parámetros

x

El índice x.

y

El índice y.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Rota una imagen

  • « Gmagick::rollimage
  • Gmagick::scaleimage »
  • PHP Manual
  • Gmagick
  • Rota una imagen

Gmagick::rotateimage

(PECL gmagick >= Unknown)

Gmagick::rotateimage — Rota una imagen

Descripción

public Gmagick::rotateimage ( mixed $color , float $degrees ) : Gmagick

Rota una imagen el número de grados especificado. Los triángulos vacíos sobrantes por la rotación de la imagen se rellenan con el color de fondo.

Parámetros

color

El píxel de color de fondo.

degrees

El número de grados que se va a rotar la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Escala el tamaño de una imagen

  • « Gmagick::rotateimage
  • Gmagick::separateimagechannel »
  • PHP Manual
  • Gmagick
  • Escala el tamaño de una imagen

Gmagick::scaleimage

(PECL gmagick >= Unknown)

Gmagick::scaleimage — Escala el tamaño de una imagen

Descripción

public Gmagick::scaleimage ( int $width , int $height , bool $fit = false ) : Gmagick

Escala el tamaño de una imagen a las dimensiones dadas. El otro parámetro será calculado si se pasa 0 como parámetro.

Parámetros

width

El número de columnas en la imagen escalada.

height

El número de filas en la imagen escalada.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Separa un canal de la imagen

  • « Gmagick::scaleimage
  • Gmagick::setCompressionQuality »
  • PHP Manual
  • Gmagick
  • Separa un canal de la imagen

Gmagick::separateimagechannel

(PECL gmagick >= Unknown)

Gmagick::separateimagechannel — Separa un canal de la imagen

Descripción

public Gmagick::separateimagechannel ( int $channel ) : Gmagick

Separa un canal de la imagen y devuelve una imagen en escala de grises. Un canal es un componente de color en particular de cada píxel de la imagen.

Parámetros

channel

Identifica qué canal extraer: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la calidad de compresión predeterminada del objeto

  • « Gmagick::separateimagechannel
  • Gmagick::setfilename »
  • PHP Manual
  • Gmagick
  • Establece la calidad de compresión predeterminada del objeto

Gmagick::setCompressionQuality

(No hay información de versión disponible, podría estar únicamente en Git)

Gmagick::setCompressionQuality — Establece la calidad de compresión predeterminada del objeto

Descripción

Gmagick::setCompressionQuality ( int $quality = 75 ) : Gmagick

Establece la calidad de compresión predeterminada del objeto.

Parámetros

quality

Valores devueltos

El objeto Gmagick en caso de éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.

Ejemplos

Ejemplo #1 Gmagick::setCompressionQuality()

<?php
$gm = new Gmagick();
$gm->read("magick:rose");
$gm->setCompressionQuality(2);
?>


Establece el nombre de archivo antes de que se lea o escriba una imagen

  • « Gmagick::setCompressionQuality
  • Gmagick::setimagebackgroundcolor »
  • PHP Manual
  • Gmagick
  • Establece el nombre de archivo antes de que se lea o escriba una imagen

Gmagick::setfilename

(PECL gmagick >= Unknown)

Gmagick::setfilename — Establece el nombre de archivo antes de que se lea o escriba una imagen

Descripción

public Gmagick::setfilename ( string $filename ) : Gmagick

Establece el nombre de archivo antes de que se lea o escriba una imagen.

Parámetros

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el color de fondo de la imagen

  • « Gmagick::setfilename
  • Gmagick::setimageblueprimary »
  • PHP Manual
  • Gmagick
  • Establece el color de fondo de la imagen

Gmagick::setimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::setimagebackgroundcolor — Establece el color de fondo de la imagen

Descripción

public Gmagick::setimagebackgroundcolor ( GmagickPixel $color ) : Gmagick

Establece el color de fondo de la imagen.

Parámetros

color

La varita de píxel de color de fondo.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el punto primario azul de la cromaticidad de la imagen

  • « Gmagick::setimagebackgroundcolor
  • Gmagick::setimagebordercolor »
  • PHP Manual
  • Gmagick
  • Establece el punto primario azul de la cromaticidad de la imagen

Gmagick::setimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::setimageblueprimary — Establece el punto primario azul de la cromaticidad de la imagen

Descripción

public Gmagick::setimageblueprimary ( float $x , float $y ) : Gmagick

Establece el punto primario azul de la cromaticidad de la imagen.

Parámetros

x

El punto x primario azul.

y

El punto y primario azul.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el color de borde de la imagen

  • « Gmagick::setimageblueprimary
  • Gmagick::setimagechanneldepth »
  • PHP Manual
  • Gmagick
  • Establece el color de borde de la imagen

Gmagick::setimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::setimagebordercolor — Establece el color de borde de la imagen

Descripción

public Gmagick::setimagebordercolor ( GmagickPixel $color ) : Gmagick

Establece el color de borde de la imagen.

Parámetros

color

La várita de píxel de borde.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la profundidad de una canal de imagen en particular

  • « Gmagick::setimagebordercolor
  • Gmagick::setimagecolorspace »
  • PHP Manual
  • Gmagick
  • Establece la profundidad de una canal de imagen en particular

Gmagick::setimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::setimagechanneldepth — Establece la profundidad de una canal de imagen en particular

Descripción

public Gmagick::setimagechanneldepth ( int $channel , int $depth ) : Gmagick

Establece la profundidad de una canal de imagen en particular.

Parámetros

channel

Identifica qué canal extraer: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

depth

La profundidad de la imagen en bits.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el espacio de color de una imagen

  • « Gmagick::setimagechanneldepth
  • Gmagick::setimagecompose »
  • PHP Manual
  • Gmagick
  • Establece el espacio de color de una imagen

Gmagick::setimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::setimagecolorspace — Establece el espacio de color de una imagen

Descripción

public Gmagick::setimagecolorspace ( int $colorspace ) : Gmagick

Establece el espacio de color de una imagen.

Parámetros

colorspace

El espacio de color de la imagen: UndefinedColorspace, RGBColorspace, GRAYColorspace, TransparentColorspace, OHTAColorspace, XYZColorspace, YCbCrColorspace, YCCColorspace, YIQColorspace, YPbPrColorspace, YPbPrColorspace, YUVColorspace, CMYKColorspace, sRGBColorspace, HSLColorspace, o HWBColorspace.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el operador de composción de una imagen

  • « Gmagick::setimagecolorspace
  • Gmagick::setimagedelay »
  • PHP Manual
  • Gmagick
  • Establece el operador de composción de una imagen

Gmagick::setimagecompose

(PECL gmagick >= Unknown)

Gmagick::setimagecompose — Establece el operador de composción de una imagen

Descripción

public Gmagick::setimagecompose ( int $composite ) : Gmagick

Establece el operador de composción de una imagen.

Parámetros

composite

El operador de composición de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el retardo de una imagen

  • « Gmagick::setimagecompose
  • Gmagick::setimagedepth »
  • PHP Manual
  • Gmagick
  • Establece el retardo de una imagen

Gmagick::setimagedelay

(PECL gmagick >= Unknown)

Gmagick::setimagedelay — Establece el retardo de una imagen

Descripción

public Gmagick::setimagedelay ( int $delay ) : Gmagick

Establece el retardo de una imagen

Parámetros

delay

El retardo de la imagen en 1/100avo de segundo.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la profundidad de una imagen

  • « Gmagick::setimagedelay
  • Gmagick::setimagedispose »
  • PHP Manual
  • Gmagick
  • Establece la profundidad de una imagen

Gmagick::setimagedepth

(PECL gmagick >= Unknown)

Gmagick::setimagedepth — Establece la profundidad de una imagen

Descripción

public Gmagick::setimagedepth ( int $depth ) : Gmagick

Establece la profundidad de una imagen

Parámetros

depth

La profundidad de la imgaen en bits: 8, 16, o 32.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el método de disposición de una imagen

  • « Gmagick::setimagedepth
  • Gmagick::setimagefilename »
  • PHP Manual
  • Gmagick
  • Establece el método de disposición de una imagen

Gmagick::setimagedispose

(PECL gmagick >= Unknown)

Gmagick::setimagedispose — Establece el método de disposición de una imagen

Descripción

public Gmagick::setimagedispose ( int $disposeType ) : Gmagick

Establece el método de disposición de una imagen.

Parámetros

disposeType

El tipo de disposición de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el nombre de archivo de una imagen en particular en una secuencia

  • « Gmagick::setimagedispose
  • Gmagick::setimageformat »
  • PHP Manual
  • Gmagick
  • Establece el nombre de archivo de una imagen en particular en una secuencia

Gmagick::setimagefilename

(PECL gmagick >= Unknown)

Gmagick::setimagefilename — Establece el nombre de archivo de una imagen en particular en una secuencia

Descripción

public Gmagick::setimagefilename ( string $filename ) : Gmagick

Establece el nombre de archivo de una imagen en particular en una secuencia.

Parámetros

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el formato de una imagen en particular

  • « Gmagick::setimagefilename
  • Gmagick::setimagegamma »
  • PHP Manual
  • Gmagick
  • Establece el formato de una imagen en particular

Gmagick::setimageformat

(PECL gmagick >= Unknown)

Gmagick::setimageformat — Establece el formato de una imagen en particular

Descripción

public Gmagick::setimageformat ( string $imageFormat ) : Gmagick

Establece el formato de una imagen en particular en una secuencia.

Parámetros

imageFormat

El formato de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el valor gamma de la imagen

  • « Gmagick::setimageformat
  • Gmagick::setimagegreenprimary »
  • PHP Manual
  • Gmagick
  • Establece el valor gamma de la imagen

Gmagick::setimagegamma

(PECL gmagick >= Unknown)

Gmagick::setimagegamma — Establece el valor gamma de la imagen

Descripción

public Gmagick::setimagegamma ( float $gamma ) : Gmagick

Establece el valor gamma de la imagen.

Parámetros

gamma

El valor gamma de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el punto primario verde de la cromaticidad de la imagen

  • « Gmagick::setimagegamma
  • Gmagick::setimageindex »
  • PHP Manual
  • Gmagick
  • Establece el punto primario verde de la cromaticidad de la imagen

Gmagick::setimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::setimagegreenprimary — Establece el punto primario verde de la cromaticidad de la imagen

Descripción

public Gmagick::setimagegreenprimary ( float $x , float $y ) : Gmagick

Establece el punto primario verde de la cromaticidad de la imagen.

Parámetros

x

El punto x primario verde de la cromaticidad.

y

El punto y primario verde de la cromaticidad.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la posición del iterador en la lista de imágenes especificada con el parámetro index

  • « Gmagick::setimagegreenprimary
  • Gmagick::setimageinterlacescheme »
  • PHP Manual
  • Gmagick
  • Establece la posición del iterador en la lista de imágenes especificada con el parámetro index

Gmagick::setimageindex

(PECL gmagick >= Unknown)

Gmagick::setimageindex — Establece la posición del iterador en la lista de imágenes especificada con el parámetro index

Descripción

public Gmagick::setimageindex ( int $index ) : Gmagick

Establece la posición del iterador en la lista de imágenes especificada con el parámetro index.

Parámetros

index

El número de escena.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la combinación de entrelazado de la imagen

  • « Gmagick::setimageindex
  • Gmagick::setimageiterations »
  • PHP Manual
  • Gmagick
  • Establece la combinación de entrelazado de la imagen

Gmagick::setimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::setimageinterlacescheme — Establece la combinación de entrelazado de la imagen

Descripción

public Gmagick::setimageinterlacescheme ( int $interlace ) : Gmagick

Establece la combinación de entrelazado de la imagen.

Parámetros

interlace

La combinación de entrelazado de la imagen: NoInterlace, LineInterlace, PlaneInterlace, PartitionInterlace.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece las iteraciones de la imagen

  • « Gmagick::setimageinterlacescheme
  • Gmagick::setimageprofile »
  • PHP Manual
  • Gmagick
  • Establece las iteraciones de la imagen

Gmagick::setimageiterations

(PECL gmagick >= Unknown)

Gmagick::setimageiterations — Establece las iteraciones de la imagen

Descripción

public Gmagick::setimageiterations ( int $iterations ) : Gmagick

Establece las iteraciones de la imagen.

Parámetros

iterations

El retraso de la imagen en 1/100avo de segundo.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Añade un perfil nombrado al objeto Gmagick

  • « Gmagick::setimageiterations
  • Gmagick::setimageredprimary »
  • PHP Manual
  • Gmagick
  • Añade un perfil nombrado al objeto Gmagick

Gmagick::setimageprofile

(PECL gmagick >= Unknown)

Gmagick::setimageprofile — Añade un perfil nombrado al objeto Gmagick

Descripción

public Gmagick::setimageprofile ( string $name , string $profile ) : Gmagick

Añade un perfil nombrado al objeto Gmagick. Si un perfil con el mismo nobre ya existe, se reemplaza. Este método difiere del método Gmagick::ProfileImage() en que no aplica ningún perfil de color CMS.

Parámetros

name

El nombre del perfil a añadir o eliminar: ICC, IPTC, o perfil genérico.

profile

El perfil.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el punto primario rojo de la cromaticidad de la imagen

  • « Gmagick::setimageprofile
  • Gmagick::setimagerenderingintent »
  • PHP Manual
  • Gmagick
  • Establece el punto primario rojo de la cromaticidad de la imagen

Gmagick::setimageredprimary

(PECL gmagick >= Unknown)

Gmagick::setimageredprimary — Establece el punto primario rojo de la cromaticidad de la imagen

Descripción

public Gmagick::setimageredprimary ( float $x , float $y ) : Gmagick

Establece el punto primario rojo de la cromaticidad de la imagen.

Parámetros

x

El punto x primario rojo.

y

El punto y primario rojo.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el propósito de renderización de la imagen

  • « Gmagick::setimageredprimary
  • Gmagick::setimageresolution »
  • PHP Manual
  • Gmagick
  • Establece el propósito de renderización de la imagen

Gmagick::setimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::setimagerenderingintent — Establece el propósito de renderización de la imagen

Descripción

public Gmagick::setimagerenderingintent ( int $rendering_intent ) : Gmagick

Establece el propósito de renderización de la imagen.

Parámetros

rendering_intent

El propósito de renderización: UndefinedIntent, SaturationIntent, PerceptualIntent, AbsoluteIntent, o RelativeIntent.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la resolución de la imagen

  • « Gmagick::setimagerenderingintent
  • Gmagick::setimagescene »
  • PHP Manual
  • Gmagick
  • Establece la resolución de la imagen

Gmagick::setimageresolution

(PECL gmagick >= Unknown)

Gmagick::setimageresolution — Establece la resolución de la imagen

Descripción

public Gmagick::setimageresolution ( float $xResolution , float $yResolution ) : Gmagick

Establece la resolución de la imagen.

Parámetros

xResolution

La resolución x de la imagen.

yResolution

La resolución y de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece la escena de la imagen

  • « Gmagick::setimageresolution
  • Gmagick::setimagetype »
  • PHP Manual
  • Gmagick
  • Establece la escena de la imagen

Gmagick::setimagescene

(PECL gmagick >= Unknown)

Gmagick::setimagescene — Establece la escena de la imagen

Descripción

public Gmagick::setimagescene ( int $scene ) : Gmagick

Establece la escena de la imagen.

Parámetros

scene

El número de escena de la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el tipo de imagen

  • « Gmagick::setimagescene
  • Gmagick::setimageunits »
  • PHP Manual
  • Gmagick
  • Establece el tipo de imagen

Gmagick::setimagetype

(PECL gmagick >= Unknown)

Gmagick::setimagetype — Establece el tipo de imagen

Descripción

public Gmagick::setimagetype ( int $imgType ) : Gmagick

Establece el tipo de imagen.

Parámetros

imgType

El tipo de imagen: UndefinedType, BilevelType, GrayscaleType, GrayscaleMatteType, PaletteType, PaletteMatteType, TrueColorType, TrueColorMatteType, ColorSeparationType, ColorSeparationMatteType, o OptimizeType.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece las unidades de resolución de la imagen

  • « Gmagick::setimagetype
  • Gmagick::setimagewhitepoint »
  • PHP Manual
  • Gmagick
  • Establece las unidades de resolución de la imagen

Gmagick::setimageunits

(PECL gmagick >= Unknown)

Gmagick::setimageunits — Establece las unidades de resolución de la imagen

Descripción

public Gmagick::setimageunits ( int $resolution ) : Gmagick

Establece las unidades de resolución de la imagen.

Parámetros

resolution

Las unidades de resolución de la imagen: Undefinedresolution, PixelsPerInchResolution, o PixelsPerCentimeterResolution.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el punto blanco de cromaticidad de la imagen

  • « Gmagick::setimageunits
  • Gmagick::setsamplingfactors »
  • PHP Manual
  • Gmagick
  • Establece el punto blanco de cromaticidad de la imagen

Gmagick::setimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::setimagewhitepoint — Establece el punto blanco de cromaticidad de la imagen

Descripción

public Gmagick::setimagewhitepoint ( float $x , float $y ) : Gmagick

Establece el punto blanco de cromaticidad de la imagen.

Parámetros

x

El punto x blanco.

y

El punto y blanco.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece los factores de muestreo de la imagen

  • « Gmagick::setimagewhitepoint
  • Gmagick::setsize »
  • PHP Manual
  • Gmagick
  • Establece los factores de muestreo de la imagen

Gmagick::setsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::setsamplingfactors — Establece los factores de muestreo de la imagen

Descripción

public Gmagick::setsamplingfactors ( array $factors ) : Gmagick

Establece los factores de muestreo de la imagen.

Parámetros

factors

Una matriz de valores de tipo double que representa el factor de muestreo de cada componente de color (en el orden RGB).

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Establece el tamaño del objeto Gmagick

  • « Gmagick::setsamplingfactors
  • Gmagick::shearimage »
  • PHP Manual
  • Gmagick
  • Establece el tamaño del objeto Gmagick

Gmagick::setsize

(PECL gmagick >= Unknown)

Gmagick::setsize — Establece el tamaño del objeto Gmagick

Descripción

public Gmagick::setsize ( int $columns , int $rows ) : Gmagick

Establece el tamaño del Gmagick. Se debe establecer antes de leer un formato de imagen en bruto como RGB, GRAY, o CMYK.

Parámetros

columns

En ancho en píxeles.

rows

En alto en píxeles.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Crea un paralelogramo

  • « Gmagick::setsize
  • Gmagick::solarizeimage »
  • PHP Manual
  • Gmagick
  • Crea un paralelogramo

Gmagick::shearimage

(PECL gmagick >= Unknown)

Gmagick::shearimage — Crea un paralelogramo

Descripción

public Gmagick::shearimage ( mixed $color , float $xShear , float $yShear ) : Gmagick

Desliza un extremo de una imagen a lo largo del eje X o Y, creando un paralelogramo. Un recorte en la dirección X desliza un extremo a lo largo del eje X, mientras que un recorte en la dirección Y desliza un extremo a lo largo del eje Y. La cantidad del recorte se controla por un ángulo de recorte. Para recortes en la dirección X, x_shear se mide relativo al eje Y, y de forma similar, para recortes en la dirección Y, y_shear se mide relativo al eje X. Los triángulos vacíos sobrantes del recorte de la imagen se rellenan con el color de fondo.

Parámetros

color

La varita de píxel de color de fondo.

xShear

El número de grados a recortar la imagen.

yShear

El número de grados a recortar la imagen.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Aplica un efecto de solarización a la imagen

  • « Gmagick::shearimage
  • Gmagick::spreadimage »
  • PHP Manual
  • Gmagick
  • Aplica un efecto de solarización a la imagen

Gmagick::solarizeimage

(PECL gmagick >= Unknown)

Gmagick::solarizeimage — Aplica un efecto de solarización a la imagen

Descripción

public Gmagick::solarizeimage ( int $threshold ) : Gmagick

Aplica un efecto especial a la imagen, similar al efecto conseguido en un cuarto oscuro fotográfico exponiendo selectivamente áreas del papel sensible fotográfico a la luz. Los rangos de umbral van desde 0 al de QuantumRange y es una medida de la extensión de la solarización.

Parámetros

threshold

Define la extensión de la solarización.

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Despalza aleatoriamente cada píxel en un bloque

  • « Gmagick::solarizeimage
  • Gmagick::stripimage »
  • PHP Manual
  • Gmagick
  • Despalza aleatoriamente cada píxel en un bloque

Gmagick::spreadimage

(PECL gmagick >= Unknown)

Gmagick::spreadimage — Despalza aleatoriamente cada píxel en un bloque

Descripción

public Gmagick::spreadimage ( float $radius ) : Gmagick

Método de efecto especial que desplaza aleatoriamente cada píxel en un bloque definido por el parámetro radius (radio).

Parámetros

radius

Elige un píxel aleatorio en una zona inmediata de esta extensión.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Elimina todos los perfiles y comentarios de una imagen

  • « Gmagick::spreadimage
  • Gmagick::swirlimage »
  • PHP Manual
  • Gmagick
  • Elimina todos los perfiles y comentarios de una imagen

Gmagick::stripimage

(PECL gmagick >= Unknown)

Gmagick::stripimage — Elimina todos los perfiles y comentarios de una imagen

Descripción

public Gmagick::stripimage ( ) : Gmagick

Elimina todos los perfiles y comentarios de una imagen.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Arremolina los píxeles desde el centro de la imagen

  • « Gmagick::stripimage
  • Gmagick::thumbnailimage »
  • PHP Manual
  • Gmagick
  • Arremolina los píxeles desde el centro de la imagen

Gmagick::swirlimage

(PECL gmagick >= Unknown)

Gmagick::swirlimage — Arremolina los píxeles desde el centro de la imagen

Descripción

public Gmagick::swirlimage ( float $degrees ) : Gmagick

Arremolina los píxeles desde el centro de la imagen, donde los grados indican el alcance del arco a través del cuál cada píxel es movido. Se puede obtener un efecto más dramático moviendo los grados desde 1 a 360.

Parámetros

degrees

Define la tirantez del efecto de arremolinamiento.

Valores devueltos

El objeto Gmagick si se tuvo éxito

Errores/Excepciones

Arroja un GmagickException en caso de error.


Cambia el tamaño de una imagen

  • « Gmagick::swirlimage
  • Gmagick::trimimage »
  • PHP Manual
  • Gmagick
  • Cambia el tamaño de una imagen

Gmagick::thumbnailimage

(PECL gmagick >= Unknown)

Gmagick::thumbnailimage — Cambia el tamaño de una imagen

Descripción

public Gmagick::thumbnailimage ( int $width , int $height , bool $fit = false ) : Gmagick

Cambia el tamaño de una imagen a las dimensiones dadas y elimina cualquier perfil asociado. El objetivo es producir conjuntos de imágenes de miniaturas pequeñas de bajo coste para mostrar en la web. Si true se da como tercer parámetro, los parámetros columns (columnas) y rows (filas) se usan como máximos para cada cara. Ambas caras serán escaladas a una proporción menor hasta que la comparación sea menor que el parámetro dado para la cara.

Parámetros

width

El ancho de la imagen

height

El alto de la imagen

Valores devueltos

El objeto Gmagick si se tuvo éxito.

Errores/Excepciones

Arroja un GmagickException en caso de error.


Elimina los extremos de la imagen

  • « Gmagick::thumbnailimage
  • Gmagick::write »
  • PHP Manual
  • Gmagick
  • Elimina los extremos de la imagen

Gmagick::trimimage

(PECL gmagick >= Unknown)

Gmagick::trimimage — Elimina los extremos de la imagen

Descripción

public Gmagick::trimimage ( float $fuzz ) : Gmagick

Elimina los extremos que son el color de fondo de la imagen.

Parámetros

fuzz

Por defecto, el objetivo debe coincidir exactamente con un color de píxel en particular. Sin embargo, en la mayoría de los casos dos colores pueden diferir por una cantidad pequeña. El miembro enfoque de la imagen define cuánta tolerancia es aceptable para considerar que dos colores son el mismo. Este parámetro represenata la variación del rango de cuantía.

Valores devueltos

El objeto Gmagick

Errores/Excepciones

Arroja un GmagickException en caso de error.


Alias de Gmagick::writeimage

  • « Gmagick::trimimage
  • Gmagick::writeimage »
  • PHP Manual
  • Gmagick
  • Alias de Gmagick::writeimage

Gmagick::write

(PECL gmagick >= Unknown)

Gmagick::write — Alias de Gmagick::writeimage()

Descripción

Este método es un alias de Gmagick::writeimage().


Escribe una imagen al nombre de archivo especificado

  • « Gmagick::write
  • GmagickDraw »
  • PHP Manual
  • Gmagick
  • Escribe una imagen al nombre de archivo especificado

Gmagick::writeimage

(PECL gmagick >= Unknown)

Gmagick::writeimage — Escribe una imagen al nombre de archivo especificado

Descripción

public Gmagick::writeimage ( string $filename , bool $all_frames = false ) : Gmagick

Escribe una imagen al nombre de archivo especificado. Si el parámetro filename es NULL, la imagen se escribe en el nombre de archivo establecido por Gmagick::ReadImage() o Gmagick::SetImageFilename().

Parámetros

filename

El nombre de archivo de la imagen.

Valores devueltos

El objeto Gmagick

Errores/Excepciones

Arroja un GmagickException en caso de error.


La clase GmagickDraw

(PECL gmagick >= Unknown)

Introducción

Sinopsis de la Clase

GmagickDraw {
/* Métodos */
public annotate ( float $x , float $y , string $text ) : GmagickDraw
public arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : GmagickDraw
public bezier ( array $coordinate_array ) : GmagickDraw
public ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : GmagickDraw
public getfillcolor ( ) : void
public getfillopacity ( ) : float
public getfont ( ) : mixed
public getfontsize ( ) : float
public getfontstyle ( ) : int
public getfontweight ( ) : int
public getstrokecolor ( ) : GmagickPixel
public getstrokeopacity ( ) : float
public getstrokewidth ( ) : float
public gettextdecoration ( ) : int
public gettextencoding ( ) : mixed
public line ( float $sx , float $sy , float $ex , float $ey ) : GmagickDraw
public point ( float $x , float $y ) : GmagickDraw
public polygon ( array $coordinates ) : GmagickDraw
public polyline ( array $coordinate_array ) : GmagickDraw
public rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : GmagickDraw
public rotate ( float $degrees ) : GmagickDraw
public roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : GmagickDraw
public scale ( float $x , float $y ) : GmagickDraw
public setfillcolor ( mixed $color ) : GmagickDraw
public setfillopacity ( float $fill_opacity ) : GmagickDraw
public setfont ( string $font ) : GmagickDraw
public setfontsize ( float $pointsize ) : GmagickDraw
public setfontstyle ( int $style ) : GmagickDraw
public setfontweight ( int $weight ) : GmagickDraw
public setstrokecolor ( mixed $color ) : GmagickDraw
public setstrokeopacity ( float $stroke_opacity ) : GmagickDraw
public setstrokewidth ( float $width ) : GmagickDraw
public settextdecoration ( int $decoration ) : GmagickDraw
public settextencoding ( string $encoding ) : GmagickDraw
}

Tabla de contenidos

  • GmagickDraw::annotate — Dibuja texto en la imagen
  • GmagickDraw::arc — Dibuja un arco
  • GmagickDraw::bezier — Dibuja una curva Bézier
  • GmagickDraw::ellipse — Dibuja una elipse en la imagen
  • GmagickDraw::getfillcolor — Devuelve el color de relleno
  • GmagickDraw::getfillopacity — Devuelve la opacidad usada cuando se dibuja
  • GmagickDraw::getfont — Devuelve el tipo de letra
  • GmagickDraw::getfontsize — Devuelve el tamaño de punto de la fuente
  • GmagickDraw::getfontstyle — Devuelve el estilo de fuente
  • GmagickDraw::getfontweight — Devuelve el peso de la fuente
  • GmagickDraw::getstrokecolor — Devuelve el color usado para contornear perfiles de objetos
  • GmagickDraw::getstrokeopacity — Devuelve la opacidad de los perfiles del objeto contorneado
  • GmagickDraw::getstrokewidth — Devuelve el ancho del contorno usado para dibular perfiles del objeto
  • GmagickDraw::gettextdecoration — Devuelve la decoración del texto
  • GmagickDraw::gettextencoding — Devuelve el conjunto de codificación usado para anotaciones de texto
  • GmagickDraw::line — Dibuja una línea en la imagen
  • GmagickDraw::point — Dibuja un punto
  • GmagickDraw::polygon — Dibuja un polígono
  • GmagickDraw::polyline — Dibuja una polilínea
  • GmagickDraw::rectangle — Dibuja un rectángulo
  • GmagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual
  • GmagickDraw::roundrectangle — Dibuja un rectángulo redondeado
  • GmagickDraw::scale — Ajusta el factor de escala
  • GmagickDraw::setfillcolor — Establece el color de relleno a usar cuando se dibujan objetos rellenos
  • GmagickDraw::setfillopacity — Establece la opacidad del relleno
  • GmagickDraw::setfont — Establece la fuente especificada completamente a usar cuando se anota texto
  • GmagickDraw::setfontsize — Establece el tamaño de punto de la fuente a usar cuando se anota texto
  • GmagickDraw::setfontstyle — Establece el estilo de fuente a usar cuando se anota texto
  • GmagickDraw::setfontweight — Establece el peso de la fuente
  • GmagickDraw::setstrokecolor — Establece el color usado para contornear los perfiles del objeto
  • GmagickDraw::setstrokeopacity — Especifica la opacidad del los perfiles del objeto contorneado
  • GmagickDraw::setstrokewidth — Establece el ancho del contorno usado para dibujar los perfiles del objeto.
  • GmagickDraw::settextdecoration — Especifica una decoración
  • GmagickDraw::settextencoding — Especifica el conjunto de codificación del texto


Dibuja texto en la imagen

  • « GmagickDraw
  • GmagickDraw::arc »
  • PHP Manual
  • GmagickDraw
  • Dibuja texto en la imagen

GmagickDraw::annotate

(PECL gmagick >= Unknown)

GmagickDraw::annotate — Dibuja texto en la imagen

Descripción

public GmagickDraw::annotate ( float $x , float $y , string $text ) : GmagickDraw

Dibuja texto en la imagen.

Parámetros

x

coordenada x a la izquierda del texto

y

coordenada y a la línea base del texto

text

texto a dibujar

Valores devueltos

El objeto GmagickDraw si se tuvo éxito.


Dibuja un arco

  • « GmagickDraw::annotate
  • GmagickDraw::bezier »
  • PHP Manual
  • GmagickDraw
  • Dibuja un arco

GmagickDraw::arc

(PECL gmagick >= Unknown)

GmagickDraw::arc — Dibuja un arco

Descripción

public GmagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : GmagickDraw

Dibuja un arco que cae dentro de un rectángulo circundante en la imagen.

Parámetros

sx

coordenada x del inicio del rectángulo circundante

sy

coordenada y del inicio del rectángulo circundante

ex

coordenada x del final del rectángulo circundante

ey

coordenada y del final del rectángulo circundante

sd

grados de inicio de rotación

ed

grados finales de rotación

Valores devueltos

El objeto GmagickDraw si se tuvo éxito.


Dibuja una curva Bézier

  • « GmagickDraw::arc
  • GmagickDraw::ellipse »
  • PHP Manual
  • GmagickDraw
  • Dibuja una curva Bézier

GmagickDraw::bezier

(PECL gmagick >= Unknown)

GmagickDraw::bezier — Dibuja una curva Bézier

Descripción

public GmagickDraw::bezier ( array $coordinate_array ) : GmagickDraw

Dibuja una curva Bézier a través de un conjunto de puntos en la imagen.

Parámetros

coordinate_array

Matriz de coordenadas

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja una elipse en la imagen

  • « GmagickDraw::bezier
  • GmagickDraw::getfillcolor »
  • PHP Manual
  • GmagickDraw
  • Dibuja una elipse en la imagen

GmagickDraw::ellipse

(PECL gmagick >= Unknown)

GmagickDraw::ellipse — Dibuja una elipse en la imagen

Descripción

public GmagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : GmagickDraw

Dibuja una elipse en la imagen.

Parámetros

ox

coordenada x del origen

oy

coordenada y del origen

rx

radio en x

ry

radio en y

start

inicio de rotación en grados

end

final de rotación en grados

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Devuelve el color de relleno

  • « GmagickDraw::ellipse
  • GmagickDraw::getfillopacity »
  • PHP Manual
  • GmagickDraw
  • Devuelve el color de relleno

GmagickDraw::getfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::getfillcolor — Devuelve el color de relleno

Descripción

public GmagickDraw::getfillcolor ( ) : void

Devuelve el color de relleno usado cuando se dibujan objetos rellenos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El color de relleno de GmagickPixel usado para dibujar objetos rellenos.


Devuelve la opacidad usada cuando se dibuja

  • « GmagickDraw::getfillcolor
  • GmagickDraw::getfont »
  • PHP Manual
  • GmagickDraw
  • Devuelve la opacidad usada cuando se dibuja

GmagickDraw::getfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::getfillopacity — Devuelve la opacidad usada cuando se dibuja

Descripción

public GmagickDraw::getfillopacity ( ) : float

Devuelve la opacidad usada cuando se dibuja

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la opacidad usada cuando se dibuja utilizando el color de relleno o la textura de relleno. Completamente opaco es 1.0.


Devuelve el tipo de letra

  • « GmagickDraw::getfillopacity
  • GmagickDraw::getfontsize »
  • PHP Manual
  • GmagickDraw
  • Devuelve el tipo de letra

GmagickDraw::getfont

(PECL gmagick >= Unknown)

GmagickDraw::getfont — Devuelve el tipo de letra

Descripción

public GmagickDraw::getfont ( ) : mixed

Devuelve una cadena que especifica el tipo de letra usado cuando se anota texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena si se tuvo éxito y false si no está establecido ningún tipo de letra.


Devuelve el tamaño de punto de la fuente

  • « GmagickDraw::getfont
  • GmagickDraw::getfontstyle »
  • PHP Manual
  • GmagickDraw
  • Devuelve el tamaño de punto de la fuente

GmagickDraw::getfontsize

(PECL gmagick >= Unknown)

GmagickDraw::getfontsize — Devuelve el tamaño de punto de la fuente

Descripción

public GmagickDraw::getfontsize ( ) : float

Devuelve el tamaño de punto de la fuente usado cuando se anota texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño de la fuente asociada con el objeto GmagickDraw actual.


Devuelve el estilo de fuente

  • « GmagickDraw::getfontsize
  • GmagickDraw::getfontweight »
  • PHP Manual
  • GmagickDraw
  • Devuelve el estilo de fuente

GmagickDraw::getfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::getfontstyle — Devuelve el estilo de fuente

Descripción

public GmagickDraw::getfontstyle ( ) : int

Devuelve el estilo de fuente usado cuando se anota texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la constante de estilo de fuente (STYLE_) asociada con el objeto GmagickDraw o 0 si no está establecido ningún estilo.


Devuelve el peso de la fuente

  • « GmagickDraw::getfontstyle
  • GmagickDraw::getstrokecolor »
  • PHP Manual
  • GmagickDraw
  • Devuelve el peso de la fuente

GmagickDraw::getfontweight

(PECL gmagick >= Unknown)

GmagickDraw::getfontweight — Devuelve el peso de la fuente

Descripción

public GmagickDraw::getfontweight ( ) : int

Devuelve el peso de la fuente usada cuando se anota texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo int si se tuvo éxito y 0 si no está establecido el peso.


Devuelve el color usado para contornear perfiles de objetos

  • « GmagickDraw::getfontweight
  • GmagickDraw::getstrokeopacity »
  • PHP Manual
  • GmagickDraw
  • Devuelve el color usado para contornear perfiles de objetos

GmagickDraw::getstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::getstrokecolor — Devuelve el color usado para contornear perfiles de objetos

Descripción

public GmagickDraw::getstrokecolor ( ) : GmagickPixel

Devuelve el color usado para contornear perfiles de objetos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto GmagickPixel que describe el color.


Devuelve la opacidad de los perfiles del objeto contorneado

  • « GmagickDraw::getstrokecolor
  • GmagickDraw::getstrokewidth »
  • PHP Manual
  • GmagickDraw
  • Devuelve la opacidad de los perfiles del objeto contorneado

GmagickDraw::getstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::getstrokeopacity — Devuelve la opacidad de los perfiles del objeto contorneado

Descripción

public GmagickDraw::getstrokeopacity ( ) : float

Devuelve la opacidad de los perfiles del objeto contorneado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo double que describe la opacidad.


Devuelve el ancho del contorno usado para dibular perfiles del objeto

  • « GmagickDraw::getstrokeopacity
  • GmagickDraw::gettextdecoration »
  • PHP Manual
  • GmagickDraw
  • Devuelve el ancho del contorno usado para dibular perfiles del objeto

GmagickDraw::getstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::getstrokewidth — Devuelve el ancho del contorno usado para dibular perfiles del objeto

Descripción

public GmagickDraw::getstrokewidth ( ) : float

Devuelve el ancho del contorno usado para dibular perfiles del objeto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un valor de tipo double que describe el ancho del contorno.


Devuelve la decoración del texto

  • « GmagickDraw::getstrokewidth
  • GmagickDraw::gettextencoding »
  • PHP Manual
  • GmagickDraw
  • Devuelve la decoración del texto

GmagickDraw::gettextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::gettextdecoration — Devuelve la decoración del texto

Descripción

public GmagickDraw::gettextdecoration ( ) : int

Devuelve la decoración aplicada cuando se anota texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una de las constantes DECORATION_ y 0 si no está establecida la decoración.


Devuelve el conjunto de codificación usado para anotaciones de texto

  • « GmagickDraw::gettextdecoration
  • GmagickDraw::line »
  • PHP Manual
  • GmagickDraw
  • Devuelve el conjunto de codificación usado para anotaciones de texto

GmagickDraw::gettextencoding

(PECL gmagick >= Unknown)

GmagickDraw::gettextencoding — Devuelve el conjunto de codificación usado para anotaciones de texto

Descripción

public GmagickDraw::gettextencoding ( ) : mixed

Devuelve una cadena que especifica el conjunto de codificación usado para anotaciones de texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena que especifica el conjunto de codificación o false si no está establecida ningúna codificación.


Dibuja una línea en la imagen

  • « GmagickDraw::gettextencoding
  • GmagickDraw::point »
  • PHP Manual
  • GmagickDraw
  • Dibuja una línea en la imagen

GmagickDraw::line

(PECL gmagick >= Unknown)

GmagickDraw::line — Dibuja una línea en la imagen

Descripción

public GmagickDraw::line ( float $sx , float $sy , float $ex , float $ey ) : GmagickDraw

Dibuja una línea en la imagen usando el color del contorno, la opacidad del contorno, y el ancho del contorno acutales.

Parámetros

sx

coordenada x de inicio

sy

coordenada y de inicio

ex

coordenada x final

ey

coordenada y final

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja un punto

  • « GmagickDraw::line
  • GmagickDraw::polygon »
  • PHP Manual
  • GmagickDraw
  • Dibuja un punto

GmagickDraw::point

(PECL gmagick >= Unknown)

GmagickDraw::point — Dibuja un punto

Descripción

public GmagickDraw::point ( float $x , float $y ) : GmagickDraw

Dibuja un punto usando el color de contorno y el grosor de contorno actuales en las coordenadas especificadas.

Parámetros

x

coordenada x del objetivo

y

coordenada y del objetivo

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja un polígono

  • « GmagickDraw::point
  • GmagickDraw::polyline »
  • PHP Manual
  • GmagickDraw
  • Dibuja un polígono

GmagickDraw::polygon

(PECL gmagick >= Unknown)

GmagickDraw::polygon — Dibuja un polígono

Descripción

public GmagickDraw::polygon ( array $coordinates ) : GmagickDraw

Dibuja un polígono usando el contorno, el ancho del contorno, y el color o textura de relleno actuales, usando la matriz de coordenadas especificadas.

Parámetros

coordinates

matriz de coordenadas

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja una polilínea

  • « GmagickDraw::polygon
  • GmagickDraw::rectangle »
  • PHP Manual
  • GmagickDraw
  • Dibuja una polilínea

GmagickDraw::polyline

(PECL gmagick >= Unknown)

GmagickDraw::polyline — Dibuja una polilínea

Descripción

public GmagickDraw::polyline ( array $coordinate_array ) : GmagickDraw

Dibuja una polilínea usando el contorno, el ancho del contorno, y el color o textura de relleno actuales, usando la matriz de coordenadas especificadas.

Parámetros

coordinate_array

La matriz de coordenadas.

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja un rectángulo

  • « GmagickDraw::polyline
  • GmagickDraw::rotate »
  • PHP Manual
  • GmagickDraw
  • Dibuja un rectángulo

GmagickDraw::rectangle

(PECL gmagick >= Unknown)

GmagickDraw::rectangle — Dibuja un rectángulo

Descripción

public GmagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : GmagickDraw

Dibuja un rectángulo dadas dos coordenadas y usando el contorno, el ancho del contorno, y la configuración de relleno actuales.

Parámetros

x1

primera coordenada x

y1

primera coordenada y

x2

segunda coordenada x

y2

primera coordenada y

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Aplica la rotación especificada al espacio de coordenadas actual

  • « GmagickDraw::rectangle
  • GmagickDraw::roundrectangle »
  • PHP Manual
  • GmagickDraw
  • Aplica la rotación especificada al espacio de coordenadas actual

GmagickDraw::rotate

(PECL gmagick >= Unknown)

GmagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual

Descripción

public GmagickDraw::rotate ( float $degrees ) : GmagickDraw

Aplica la rotación especificada al espacio de coordenadas actual.

Parámetros

degrees

grados de rotación

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Dibuja un rectángulo redondeado

  • « GmagickDraw::rotate
  • GmagickDraw::scale »
  • PHP Manual
  • GmagickDraw
  • Dibuja un rectángulo redondeado

GmagickDraw::roundrectangle

(PECL gmagick >= Unknown)

GmagickDraw::roundrectangle — Dibuja un rectángulo redondeado

Descripción

public GmagickDraw::roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : GmagickDraw

Dibuja aun rectángulo redondeado dadas dos coordenadas, los radios de las esquinas x e y, y usando el contorno, el ancho del contorno, y la configuración de relleno actuales.

Parámetros

x1

primera coordenada x

y1

primera coordenada y

x2

segunda coordenada x

y2

segunda coordenada y

rx

radio de la esquina en dirección horizontal

ry

radio de la esquina en dirección vertical

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Ajusta el factor de escala

  • « GmagickDraw::roundrectangle
  • GmagickDraw::setfillcolor »
  • PHP Manual
  • GmagickDraw
  • Ajusta el factor de escala

GmagickDraw::scale

(PECL gmagick >= Unknown)

GmagickDraw::scale — Ajusta el factor de escala

Descripción

public GmagickDraw::scale ( float $x , float $y ) : GmagickDraw

Ajusta el factor de escala a aplicar en las direcciones horizontal y vertical al espacio de coordenadas actual.

Parámetros

x

Factor de escala horizontal

y

Factor de escala vertical

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el color de relleno a usar cuando se dibujan objetos rellenos

  • « GmagickDraw::scale
  • GmagickDraw::setfillopacity »
  • PHP Manual
  • GmagickDraw
  • Establece el color de relleno a usar cuando se dibujan objetos rellenos

GmagickDraw::setfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::setfillcolor — Establece el color de relleno a usar cuando se dibujan objetos rellenos

Descripción

public GmagickDraw::setfillcolor ( mixed $color ) : GmagickDraw

Establece el color de relleno a usar cuando se dibujan objetos rellenos.

Parámetros

color

Un objeto GmagickPixel o un string que indica el color a usar para el relleno.

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece la opacidad del relleno

  • « GmagickDraw::setfillcolor
  • GmagickDraw::setfont »
  • PHP Manual
  • GmagickDraw
  • Establece la opacidad del relleno

GmagickDraw::setfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::setfillopacity — Establece la opacidad del relleno

Descripción

public GmagickDraw::setfillopacity ( float $fill_opacity ) : GmagickDraw

Establece la opacidad a usar cuando de dibuja untilizando el color de relleno o la textura de relleno. Establecerlo a 1.0 hará al relleno completamente opaco.

Parámetros

fill_opacity

La opacidad del relleno

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece la fuente especificada completamente a usar cuando se anota texto

  • « GmagickDraw::setfillopacity
  • GmagickDraw::setfontsize »
  • PHP Manual
  • GmagickDraw
  • Establece la fuente especificada completamente a usar cuando se anota texto

GmagickDraw::setfont

(PECL gmagick >= Unknown)

GmagickDraw::setfont — Establece la fuente especificada completamente a usar cuando se anota texto

Descripción

public GmagickDraw::setfont ( string $font ) : GmagickDraw

Establece la fuente especificada completamente a usar cuando se anota texto.

Parámetros

font

El nombre de la fuente

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el tamaño de punto de la fuente a usar cuando se anota texto

  • « GmagickDraw::setfont
  • GmagickDraw::setfontstyle »
  • PHP Manual
  • GmagickDraw
  • Establece el tamaño de punto de la fuente a usar cuando se anota texto

GmagickDraw::setfontsize

(PECL gmagick >= Unknown)

GmagickDraw::setfontsize — Establece el tamaño de punto de la fuente a usar cuando se anota texto

Descripción

public GmagickDraw::setfontsize ( float $pointsize ) : GmagickDraw

Establece el tamaño de punto de la fuente a usar cuando se anota texto.

Parámetros

pointsize

El tamaño de punto del texto

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el estilo de fuente a usar cuando se anota texto

  • « GmagickDraw::setfontsize
  • GmagickDraw::setfontweight »
  • PHP Manual
  • GmagickDraw
  • Establece el estilo de fuente a usar cuando se anota texto

GmagickDraw::setfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::setfontstyle — Establece el estilo de fuente a usar cuando se anota texto

Descripción

public GmagickDraw::setfontstyle ( int $style ) : GmagickDraw

Establece el estilo de fuente a usar cuando se anota texto. La enumeración AnyStyle actúa como una opción comodín para "no tener cuidado".

Parámetros

style

El estilo de la fuente (NormalStyle, ItalicStyle, ObliqueStyle, AnyStyle)

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el peso de la fuente

  • « GmagickDraw::setfontstyle
  • GmagickDraw::setstrokecolor »
  • PHP Manual
  • GmagickDraw
  • Establece el peso de la fuente

GmagickDraw::setfontweight

(PECL gmagick >= Unknown)

GmagickDraw::setfontweight — Establece el peso de la fuente

Descripción

public GmagickDraw::setfontweight ( int $weight ) : GmagickDraw

Establece el peso de la fuente a usar cuando se anota texto.

Parámetros

weight

El peso de la fuente (rango válido 100-900)

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el color usado para contornear los perfiles del objeto

  • « GmagickDraw::setfontweight
  • GmagickDraw::setstrokeopacity »
  • PHP Manual
  • GmagickDraw
  • Establece el color usado para contornear los perfiles del objeto

GmagickDraw::setstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::setstrokecolor — Establece el color usado para contornear los perfiles del objeto

Descripción

public GmagickDraw::setstrokecolor ( mixed $color ) : GmagickDraw

Establece el color usado para contornear los perfiles del objeto.

Parámetros

color

Un objeto GmagickPixel o un string que representa el color del contorno.

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Especifica la opacidad del los perfiles del objeto contorneado

  • « GmagickDraw::setstrokecolor
  • GmagickDraw::setstrokewidth »
  • PHP Manual
  • GmagickDraw
  • Especifica la opacidad del los perfiles del objeto contorneado

GmagickDraw::setstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::setstrokeopacity — Especifica la opacidad del los perfiles del objeto contorneado

Descripción

public GmagickDraw::setstrokeopacity ( float $stroke_opacity ) : GmagickDraw

Especifica la opacidad del los perfiles del objeto contorneado.

Parámetros

stroke_opacity

La opacidad del contorno. El valor 1.0 es opaco.

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Establece el ancho del contorno usado para dibujar los perfiles del objeto.

  • « GmagickDraw::setstrokeopacity
  • GmagickDraw::settextdecoration »
  • PHP Manual
  • GmagickDraw
  • Establece el ancho del contorno usado para dibujar los perfiles del objeto.

GmagickDraw::setstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::setstrokewidth — Establece el ancho del contorno usado para dibujar los perfiles del objeto.

Descripción

public GmagickDraw::setstrokewidth ( float $width ) : GmagickDraw

Establece el ancho del contorno usado para dibujar los perfiles del objeto

Parámetros

width

El ancho del contorno

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Especifica una decoración

  • « GmagickDraw::setstrokewidth
  • GmagickDraw::settextencoding »
  • PHP Manual
  • GmagickDraw
  • Especifica una decoración

GmagickDraw::settextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::settextdecoration — Especifica una decoración

Descripción

public GmagickDraw::settextdecoration ( int $decoration ) : GmagickDraw

Especifica una decoración que va a ser aplicada cuando se anota texto.

Parámetros

int

Decoración del texto. Una de estas: NoDecoration, UnderlineDecoration, OverlineDecoration, o LineThroughDecoration

Valores devueltos

El objeto GmagickDraw si se tuvo éxito


Especifica el conjunto de codificación del texto

  • « GmagickDraw::settextdecoration
  • GmagickPixel »
  • PHP Manual
  • GmagickDraw
  • Especifica el conjunto de codificación del texto

GmagickDraw::settextencoding

(PECL gmagick >= Unknown)

GmagickDraw::settextencoding — Especifica el conjunto de codificación del texto

Descripción

public GmagickDraw::settextencoding ( string $encoding ) : GmagickDraw

Especifica el conjunto de codificación usado para anotaciones el texto. La única codificación de caracteres que se puede especificar por ahora es "UTF-8" para representar Unicode como una secuencia de bytes. Especifique un string vacío para establecer la codificación de texto a la predeterminada por el sistema. El éxito con la anotación de texto usando Unicode puede requerir fuentes diseñadas para soportar Unicode.

Parámetros

encoding

Cadena de caracteres que especifica la codificación de texto

Valores devueltos

El objeto GmagickDraw en caso de éxito


La clase GmagickPixel

(PECL gmagick >= Unknown)

Introducción

Sinopsis de la Clase

GmagickPixel {
/* Métodos */
public __construct ( string $color = ? )
public getcolor ( bool $as_array = false , bool $normalize_array = false ) : mixed
public getcolorcount ( ) : int
public getcolorvalue ( int $color ) : float
public setcolor ( string $color ) : GmagickPixel
public setcolorvalue ( int $color , float $value ) : GmagickPixel
}

Tabla de contenidos

  • GmagickPixel::__construct — El constructor GmagickPixel
  • GmagickPixel::getcolor — Devuelve el color
  • GmagickPixel::getcolorcount — Devuelve la cuenta de color asociada a este color
  • GmagickPixel::getcolorvalue — Obtiene el valor normalizado del canal de color proporcionado
  • GmagickPixel::setcolor — Establece el color
  • GmagickPixel::setcolorvalue — Establece el valor normalizado de uno de los canales


El constructor GmagickPixel

  • « GmagickPixel
  • GmagickPixel::getcolor »
  • PHP Manual
  • GmagickPixel
  • El constructor GmagickPixel

GmagickPixel::__construct

(PECL gmagick >= Unknown)

GmagickPixel::__construct — El constructor GmagickPixel

Descripción

public GmagickPixel::__construct ( string $color = ? )

Construye un objeto GmagickPixel. Si se especifica un color, el objeto se construye y se inicializa con el color antes de ser devuelto.

Parámetros

color

La cadena de color opcional que se va a usar como el valor inicial de este objeto.

Valores devueltos

El objeto GmagickPixel si se tuvo éxito.


Devuelve el color

  • « GmagickPixel::__construct
  • GmagickPixel::getcolorcount »
  • PHP Manual
  • GmagickPixel
  • Devuelve el color

GmagickPixel::getcolor

(PECL gmagick >= Unknown)

GmagickPixel::getcolor — Devuelve el color

Descripción

public GmagickPixel::getcolor ( bool $as_array = false , bool $normalize_array = false ) : mixed

Devuelve el color descrito por el objeto GmagickPixel, como un string o un array. Si el color tiene establecido un canal de opacidad, este se dará como un cuarto valor en la lista.

Parámetros

as_array

true para indicar que devuelva un array en lugar de un string.

normalize_array

true para normalizar los valores del color.

Valores devueltos

Un string o un array de valores del canal, cada uno normalizado si normalize_array es true. Lanza una GmagickPixelException en caso de error.


Devuelve la cuenta de color asociada a este color

  • « GmagickPixel::getcolor
  • GmagickPixel::getcolorvalue »
  • PHP Manual
  • GmagickPixel
  • Devuelve la cuenta de color asociada a este color

GmagickPixel::getcolorcount

(PECL gmagick >= Unknown)

GmagickPixel::getcolorcount — Devuelve la cuenta de color asociada a este color

Descripción

public GmagickPixel::getcolorcount ( ) : int

Devuelve la cuenta de color asociada a este color

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la cuenta de color como un valor de tipo integer en caso de éxito, lanza una excepción de tipo GmagickPixelException en caso de error.


Obtiene el valor normalizado del canal de color proporcionado

  • « GmagickPixel::getcolorcount
  • GmagickPixel::setcolor »
  • PHP Manual
  • GmagickPixel
  • Obtiene el valor normalizado del canal de color proporcionado

GmagickPixel::getcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::getcolorvalue — Obtiene el valor normalizado del canal de color proporcionado

Descripción

public GmagickPixel::getcolorvalue ( int $color ) : float

Recupera el canal de color especificado, como un número de coma flotante entre 0 y 1.

Parámetros

color

El canal a comprobar, especificado como una de las constantes de canal de Gmagick.

Valores devueltos

El valor del canal, como un número de coma flotante normalizado, lanzando una excepción de tipo GmagickPixelException si se produjo un error.


Establece el color

  • « GmagickPixel::getcolorvalue
  • GmagickPixel::setcolorvalue »
  • PHP Manual
  • GmagickPixel
  • Establece el color

GmagickPixel::setcolor

(PECL gmagick >= Unknown)

GmagickPixel::setcolor — Establece el color

Descripción

public GmagickPixel::setcolor ( string $color ) : GmagickPixel

Establece el color descrito por el objeto GmagickPixel, con una cadena (p.ej. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

Parámetros

color

La definición de color a usar para inicializar el objeto GmagickPixel.

Valores devueltos

El objeto GmagickPixel si se tuvo éxito.


Establece el valor normalizado de uno de los canales

  • « GmagickPixel::setcolor
  • ImageMagick »
  • PHP Manual
  • GmagickPixel
  • Establece el valor normalizado de uno de los canales

GmagickPixel::setcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::setcolorvalue — Establece el valor normalizado de uno de los canales

Descripción

public GmagickPixel::setcolorvalue ( int $color , float $value ) : GmagickPixel

Establece el valor del canal especificado de este objeto al valor proporcionado, el cuál debería estar entre 0 y 1. Esta función se puede usar para proporcionar un canal de opacidad al objeto GmagickPixel.

Parámetros

color

Uno de las constantes de color de canal de Gmagick.

value

El valor para establecer este canal tiene un rango desde 0 a 1.

Valores devueltos

El objeto GmagickPixel si se tuvo éxtio.


Procesamiento de imágenes (ImageMagick)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Imagick — La clase Imagick
    • Imagick::adaptiveBlurImage — Añade un filtro de borrosidad adaptativo a la imagen
    • Imagick::adaptiveResizeImage — Redimensiona una imagen adaptativamente con información dependiente de la triangulación
    • Imagick::adaptiveSharpenImage — Afila la imagen adaptativamente
    • Imagick::adaptiveThresholdImage — Selecciona un umbral para cada píxel basado en un rango de intensidad
    • Imagick::addImage — Añade una nueva imagen a la lista de imágenes del objeto Imagick
    • Imagick::addNoiseImage — Añade ruido aleatorio a la imagen
    • Imagick::affineTransformImage — Transforma una imagen
    • Imagick::animateImages — Anima una imagen o imágenes
    • Imagick::annotateImage — Anota una imagen con texto
    • Imagick::appendImages — Añade un conjunto de imágenes
    • Imagick::autoLevelImage — Description
    • Imagick::averageImages — Calcula la media de un conjunto de imágenes
    • Imagick::blackThresholdImage — Fuerza a todos los píxeles bajo un umbral a ser negros
    • Imagick::blueShiftImage — Description
    • Imagick::blurImage — Añade un filtro de borrosidad a la imagen
    • Imagick::borderImage — Rodea la imagen con un borde
    • Imagick::brightnessContrastImage — Description
    • Imagick::charcoalImage — Simula un dibujo a carboncillo
    • Imagick::chopImage — Borra una región de una imagen y la recorta
    • Imagick::clampImage — Description
    • Imagick::clear — Borra todos los recursos asociados con un objeto Imagick
    • Imagick::clipImage — Recorta a lo largo del primer trazado desde un perfil 8BIM
    • Imagick::clipImagePath — Description
    • Imagick::clipPathImage — Recorta a lo largo de trazados nominados desde un perfil 8BIM
    • Imagick::clone — Hace una copia exacta de un objeto Imagick
    • Imagick::clutImage — Reemplaza los colores de una imagen
    • Imagick::coalesceImages — Compone un conjunto de imágenes
    • Imagick::colorFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::colorizeImage — Mezcla el color de relleno con la imagen
    • Imagick::colorMatrixImage — Description
    • Imagick::combineImages — Combina una o más imágenes en una sóla imagen
    • Imagick::commentImage — Añade un comentario a la imagen
    • Imagick::compareImageChannels — Devuelve la diferencia entre una o más imágenes
    • Imagick::compareImageLayers — Devuelve la región circundante máxima entre imágenes
    • Imagick::compareImages — Compara una imagen con otra reconstruida
    • Imagick::compositeImage — Compone una imagen en otra
    • Imagick::__construct — El constructor Imagick
    • Imagick::contrastImage — Cambia el contraste de una imagen
    • Imagick::contrastStretchImage — Mejora el contraste de una imagen en color
    • Imagick::convolveImage — Aplica una semilla de convolución a medida a la imagen
    • Imagick::count — Get the number of images
    • Imagick::cropImage — Extrae una región de la imagen
    • Imagick::cropThumbnailImage — Crea una miniatura recortada
    • Imagick::current — Devuelve una referencia del objeto Imagick actual
    • Imagick::cycleColormapImage — Desplaza el mapa de colores de una imagen
    • Imagick::decipherImage — Descifra una imagen
    • Imagick::deconstructImages — Devuelve ciertas diferencias de píxeles entre imágenes
    • Imagick::deleteImageArtifact — Borra un artefacto de imagen
    • Imagick::deleteImageProperty — Description
    • Imagick::deskewImage — Elimina la torción de la imagen
    • Imagick::despeckleImage — Reduce el ruido granular de una imagen
    • Imagick::destroy — Destruye un objeto Imagick
    • Imagick::displayImage — Muestra una imagen
    • Imagick::displayImages — Muestra una imagen o una secuencia de imágenes
    • Imagick::distortImage — Deforma una imagen utilizando varios métodos de distorsión
    • Imagick::drawImage — Renderiza el objeto ImagickDraw a la imagen actual
    • Imagick::edgeImage — Mejora los bordes de la imagen
    • Imagick::embossImage — Devuelve una imagen en escala de grises con un efecto tridimensional
    • Imagick::encipherImage — Cifra una imagen
    • Imagick::enhanceImage — Mejora la calidad de una imagen con ruido
    • Imagick::equalizeImage — Ecualiza el histograma de la imagen
    • Imagick::evaluateImage — Aplica una expresión a una imagen
    • Imagick::exportImagePixels — Exporta píxeles de imagen en bruto
    • Imagick::extentImage — Establecer el tamaño de la imagen
    • Imagick::filter — Description
    • Imagick::flattenImages — Fusiona una secuencia de imágenes
    • Imagick::flipImage — Crea una imagen espejo vertical
    • Imagick::floodFillPaintImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::flopImage — Crea una imagen espejo horizontal
    • Imagick::forwardFourierTransformImage — Description
    • Imagick::frameImage — Añade un borde tridimensional simulado
    • Imagick::functionImage — Aplica una función a la imagen
    • Imagick::fxImage — Evalúa una expresión por cada píxel de la imagen
    • Imagick::gammaImage — Corrección gamma de una imagen
    • Imagick::gaussianBlurImage — Hace borrosa una imagen
    • Imagick::getColorspace — Obtiene el espacio de color
    • Imagick::getCompression — Obtiene el tipo de compresión del objeto
    • Imagick::getCompressionQuality — Obtiene la calidad de compresión del objeto
    • Imagick::getCopyright — Devuelve el copyright de la API ImageMagick como una cadena
    • Imagick::getFilename — El nombre de archivo asociado a una secuencia de imágenes
    • Imagick::getFont — Obtiene la fuente
    • Imagick::getFormat — Devuelve el formato de un objeto Imagick
    • Imagick::getGravity — Obtiene la gravedad
    • Imagick::getHomeURL — Devuelve la URL de inicio de ImageMagick
    • Imagick::getImage — Devuelve un nuevo objeto Imagick
    • Imagick::getImageAlphaChannel — Obtiene el canal alfa de una imagen
    • Imagick::getImageArtifact — Obtener el artefacto de imagen
    • Imagick::getImageAttribute — Description
    • Imagick::getImageBackgroundColor — Devuelve el color de fondo de la imagen
    • Imagick::getImageBlob — Devuelve la secuencia de imágenes como un valor de tipo blob
    • Imagick::getImageBluePrimary — Devuelve el punto primario azul de la cromaticidad
    • Imagick::getImageBorderColor — Devuelve el color del borde de la imagen
    • Imagick::getImageChannelDepth — Obtiene la profundidad de un canal de imagen en particular
    • Imagick::getImageChannelDistortion — Compara los canales de imagen de una imagen con una imagen reconstruida
    • Imagick::getImageChannelDistortions — Obtiene las distorsiones del canal
    • Imagick::getImageChannelExtrema — Obtiene los extremos de uno o más canales de imagen
    • Imagick::getImageChannelKurtosis — Obtiene la curtosis y la asimetría estadística de un canal específico
    • Imagick::getImageChannelMean — Obtiene la media y la desviación estándar
    • Imagick::getImageChannelRange — Obtiene el rango del canal
    • Imagick::getImageChannelStatistics — Devuelve las estadísticas de cada canal de la imagen
    • Imagick::getImageClipMask — Obtiene la máscara de recorte de la imagen
    • Imagick::getImageColormapColor — Devuelve el color del índice del mapa de colores especficado
    • Imagick::getImageColors — Obtiene el número de colores únicos de la imagen
    • Imagick::getImageColorspace — Obtiene el espacio de color de la imagen
    • Imagick::getImageCompose — Devuelve el operador de composición asociado a la imagen
    • Imagick::getImageCompression — Obtiene el tipo de compresión de la imagen actual
    • Imagick::getImageCompressionQuality — Obtiene la calidad de compresión de la imagen actual
    • Imagick::getImageDelay — Obtiene el retraso de la imagen
    • Imagick::getImageDepth — Obtiene la profundidad de la imagen
    • Imagick::getImageDispose — Obtiene el método de disposición de la imagen
    • Imagick::getImageDistortion — Compara una imagen con una imagen reconstruida
    • Imagick::getImageExtrema — Obtiene los extremos de la imagen
    • Imagick::getImageFilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia
    • Imagick::getImageFormat — Devuelve el formato de una imagen en particular de una secuencia
    • Imagick::getImageGamma — Obtiene el valor gamma de la imagen
    • Imagick::getImageGeometry — Obtiene el ancho y el alto como un array asociativo
    • Imagick::getImageGravity — Obtiene la gravedad de la imagen
    • Imagick::getImageGreenPrimary — Devuelve el punto primario verde de la cromaticidad
    • Imagick::getImageHeight — Devuelve el alto de la imagen
    • Imagick::getImageHistogram — Obtiene el histograma de la imagen
    • Imagick::getImageIndex — Obtiene el índice de la imagen activa actual
    • Imagick::getImageInterlaceScheme — Obtiene la combinación de entrelazado de la imagen
    • Imagick::getImageInterpolateMethod — Devuelve el método de interpolación
    • Imagick::getImageIterations — Obtiene las iteraciones de la imagen
    • Imagick::getImageLength — Devuelve la longitud de la imagen en bytes
    • Imagick::getImageMatte — Devuelve si la imagen tiene un canal mate
    • Imagick::getImageMatteColor — Devuelve el color mate de la imagen
    • Imagick::getImageMimeType — Description
    • Imagick::getImageOrientation — Obtiene la orientación de la imagen
    • Imagick::getImagePage — Devuelve la geometría de la página
    • Imagick::getImagePixelColor — Devuelve el color del píxel especificado
    • Imagick::getImageProfile — Devuelve el perfil nominado de la imagen
    • Imagick::getImageProfiles — Devuelve los perfiles de la imagen
    • Imagick::getImageProperties — Devuelve las propiedades de la imagen
    • Imagick::getImageProperty — Devuelve la propiedad nominada de la imagen
    • Imagick::getImageRedPrimary — Devuelve el punto primario rojo de la cromaticidad
    • Imagick::getImageRegion — Extrae una región de la imagen
    • Imagick::getImageRenderingIntent — Obtiene el propósito de renderización de la imagen
    • Imagick::getImageResolution — Obtiene la resolución X e Y de la imagen
    • Imagick::getImagesBlob — Devuelve todas las secuencias de imágenes como un blob
    • Imagick::getImageScene — Obtiene la escena de la imagen
    • Imagick::getImageSignature — Genera un resumen de un mensaje SHA-256
    • Imagick::getImageSize — Devuelve la longitud de la imagen en bytes
    • Imagick::getImageTicksPerSecond — Obtiene los pulsos por segundo de la imagen
    • Imagick::getImageTotalInkDensity — Obtiene la densidad de tinta total de la imagen
    • Imagick::getImageType — Obtiene el tipo de imagen potencial
    • Imagick::getImageUnits — Obtiene las unidades de resolución de la imagen
    • Imagick::getImageVirtualPixelMethod — Devuelve el método de píxel virtual
    • Imagick::getImageWhitePoint — Devuelve el punto blanco de la cromaticidad
    • Imagick::getImageWidth — Devuelve el ancho de la imagen
    • Imagick::getInterlaceScheme — Obtiene la combinación de entrelazado de un objeto
    • Imagick::getIteratorIndex — Obtiene el índice de la imagen activa actual
    • Imagick::getNumberImages — Devuelve el número de imágenes del objeto
    • Imagick::getOption — Devuelve un valor asociado con la clave especificada
    • Imagick::getPackageName — Devuelve el nombre del paquete de ImageMagick
    • Imagick::getPage — Devuelve la geometría de la página
    • Imagick::getPixelIterator — Devuelve un objeto MagickPixelIterator
    • Imagick::getPixelRegionIterator — Obtinene un objeto ImagickPixelIterator de una sección de imagen
    • Imagick::getPointSize — Obtiene el tamaño de punto
    • Imagick::getQuantum — Description
    • Imagick::getQuantumDepth — Obtiene la profundidad de la cuantía
    • Imagick::getQuantumRange — Devuelve el rango de cuantía de Imagick
    • Imagick::getRegistry — Description
    • Imagick::getReleaseDate — Devuelve la fecha de distribución de ImageMagick
    • Imagick::getResource — Devuelve el uso de memoria del recurso especificado
    • Imagick::getResourceLimit — Devuelve el límite del recurso especificado
    • Imagick::getSamplingFactors — Obtiene el factor de muestreo horizontal y vertical
    • Imagick::getSize — Devuelve el tamaño asociado con el objeto Imagick
    • Imagick::getSizeOffset — Devuelve el índice de tamaño
    • Imagick::getVersion — Devuelve la versión de la API ImageMagick
    • Imagick::haldClutImage — Reemplaza los colores de la imagen
    • Imagick::hasNextImage — Comprueba si el objeto tiene más imágenes
    • Imagick::hasPreviousImage — Verifica si el objeto tiene una imagen previa
    • Imagick::identifyFormat — Description
    • Imagick::identifyImage — Identifica una imagen y obtiene sus atributos
    • Imagick::implodeImage — Crea una nueva imagen como una copia
    • Imagick::importImagePixels — Importa los píxeles de una imagen
    • Imagick::inverseFourierTransformImage — Description
    • Imagick::labelImage — Añade una etiqueta a una imagen
    • Imagick::levelImage — Ajusta los niveles de la imagen
    • Imagick::linearStretchImage — Estrecha con saturación la intensidad de la imagen
    • Imagick::liquidRescaleImage — Anima una imagen o imágenes
    • Imagick::listRegistry — Description
    • Imagick::magnifyImage — Escala una imagen x2 proporcionalmente
    • Imagick::mapImage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
    • Imagick::matteFloodfillImage — Cambia el valor de transparencia de un color
    • Imagick::medianFilterImage — Aplica un filtro digital
    • Imagick::mergeImageLayers — Fusiona las capas de una imagen
    • Imagick::minifyImage — Escala una imagen proporcionalmente a la mitad de su tamaño
    • Imagick::modulateImage — Controla el brillo, la saturación y el tono
    • Imagick::montageImage — Crea una imagen compuesta
    • Imagick::morphImages — Metamorfosea un conjunto de imágenes
    • Imagick::morphology — Description
    • Imagick::mosaicImages — Forma un mosaico de imágenes
    • Imagick::motionBlurImage — Simula borrosidad en movimiento
    • Imagick::negateImage — Invierte los colores en la imagen de referencia
    • Imagick::newImage — Crea una nueva imagen
    • Imagick::newPseudoImage — Crea una nueva imagen
    • Imagick::nextImage — Se mueve a la siguiente imagen
    • Imagick::normalizeImage — Mejora el contraste de una imagen a color
    • Imagick::oilPaintImage — Simula una pintura al óleo
    • Imagick::opaquePaintImage — Cambia el color de cualquier píxel que coincida con el objetivo
    • Imagick::optimizeImageLayers — Elimina porciones repetidas de imágenes para optimizarlas
    • Imagick::orderedPosterizeImage — Realiza un entramado ordenado
    • Imagick::paintFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::paintOpaqueImage — Cambia cualquier píxel que coincida con el color
    • Imagick::paintTransparentImage — Cambia cualquier píxel que coincida con el color definido para el relleno
    • Imagick::pingImage — Trae los atributos básicos de una imagen
    • Imagick::pingImageBlob — Traer los atributos rápidamente
    • Imagick::pingImageFile — Obtener los atrbutos básicos de la imagen de una manera liviana
    • Imagick::polaroidImage — Simula una fotografía Polaroid
    • Imagick::posterizeImage — Reduce la imagen a un número limitado de niveles de color
    • Imagick::previewImages — Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen
    • Imagick::previousImage — Se mueve a la imagen previa del objeto
    • Imagick::profileImage — Añade o elimina un perfil de una imagen
    • Imagick::quantizeImage — Analiza los colores dentro de una imagen de referencia
    • Imagick::quantizeImages — Analiza los colores dentro de una secuencia de imágenes
    • Imagick::queryFontMetrics — Devuelve una matriz que representa las métricas de la fuente
    • Imagick::queryFonts — Devuelve las fuentes configuradas
    • Imagick::queryFormats — Devuelve los formatos soportados por Imagick
    • Imagick::radialBlurImage — Hace borrosa de forma radial una imagen
    • Imagick::raiseImage — Crea un efecto de botón en 3D simulado
    • Imagick::randomThresholdImage — Crea una imagen de alto contraste y dos colores
    • Imagick::readImage — Lee una imagen desde un nombre de fichero
    • Imagick::readImageBlob — Lee una imagen desde un string binario
    • Imagick::readImageFile — Lee una imagen desde un gestor de fichero abierto
    • Imagick::readimages — Description
    • Imagick::recolorImage — Re-colorea una imagen
    • Imagick::reduceNoiseImage — Suaviza los contornos de una imagen
    • Imagick::remapImage — Re-mapea los colores de una imagen
    • Imagick::removeImage — Quita una imagen de la lista de imágenes
    • Imagick::removeImageProfile — Elimina el perfil nominado de la imagen y lo devuelve
    • Imagick::render — Renderiza todos los comandos de dibujo precedentes
    • Imagick::resampleImage — Remuestrea la imagen a la resolución deseada
    • Imagick::resetImagePage — Reinicia una página de imagen
    • Imagick::resizeImage — Escala una imagen
    • Imagick::rollImage — Compensa una imagen
    • Imagick::rotateImage — Rota una imagen
    • Imagick::rotationalBlurImage — Description
    • Imagick::roundCorners — Redondea las esquinas de una imagen
    • Imagick::sampleImage — Escala una imagen con un muestreo de píxeles
    • Imagick::scaleImage — Escala el tamaño de una imagen
    • Imagick::segmentImage — Segmenta una imagen
    • Imagick::selectiveBlurImage — Description
    • Imagick::separateImageChannel — Separa un canal de la imagen
    • Imagick::sepiaToneImage — Pone una imagen en tono sepia
    • Imagick::setBackgroundColor — Establece el color de fondo por omisión del objeto
    • Imagick::setColorspace — Establecer el espacio de color
    • Imagick::setCompression — Establece el tipo de compresión predeterminado del objeto
    • Imagick::setCompressionQuality — Establece la calidad de compresión predeterminda del objeto
    • Imagick::setFilename — Establece el nombre de archivo antes de que se lea o escriba una imagen
    • Imagick::setFirstIterator — Establece el iterador Imagick para la primera imagen
    • Imagick::setFont — Establece el tipo de letra
    • Imagick::setFormat — Establece el formato del objeto Imagick
    • Imagick::setGravity — Establece la gravedad
    • Imagick::setImage — Reemplaza una imagen en el objeto
    • Imagick::setImageAlphaChannel — Establece el canal alfa de la imagen
    • Imagick::setImageArtifact — Establecer un artefacto de imagen
    • Imagick::setImageAttribute — Description
    • Imagick::setImageBackgroundColor — Establece el color de fondo de la imagen
    • Imagick::setImageBias — Establece el sesgo de la imagen para cualquier método que convolucione una imagen
    • Imagick::setImageBiasQuantum — Description
    • Imagick::setImageBluePrimary — Establece el punto primario azul de la cromaticidad de la imagen
    • Imagick::setImageBorderColor — Establece el color de borde de la imagen
    • Imagick::setImageChannelDepth — Establece la profundidad de una canal de imagen en particular
    • Imagick::setImageClipMask — Establece la máscara de recorte de una imagen
    • Imagick::setImageColormapColor — Establece el color de un índice de mapa de color especificado
    • Imagick::setImageColorspace — Establece el espacio de color de una imagen
    • Imagick::setImageCompose — Establece el operador de composción de una imagen
    • Imagick::setImageCompression — Establece la compresión de una imagen
    • Imagick::setImageCompressionQuality — Establece la calidad de compresión de una imagen
    • Imagick::setImageDelay — Establece el retardo de una imagen
    • Imagick::setImageDepth — Establece la profundidad de una imagen
    • Imagick::setImageDispose — Establece el método de disposición de una imagen
    • Imagick::setImageExtent — Establece el tamaño de una imagen
    • Imagick::setImageFilename — Establece el nombre de archivo de una imagen en particular
    • Imagick::setImageFormat — Establece el formato de una imagen en particular
    • Imagick::setImageGamma — Establece el valor gamma de la imagen
    • Imagick::setImageGravity — Establece la gravedad de la imagen
    • Imagick::setImageGreenPrimary — Establece el punto primario verde de la cromaticidad de la imagen
    • Imagick::setImageIndex — Establece la posición del iterador
    • Imagick::setImageInterlaceScheme — Establece la compresión de la imagen
    • Imagick::setImageInterpolateMethod — Establece el método de interpolación de píxeles
    • Imagick::setImageIterations — Establece las iteraciones de una imagen
    • Imagick::setImageMatte — Establece el canal mate de la imagen
    • Imagick::setImageMatteColor — Establece el color mate de la imagen
    • Imagick::setImageOpacity — Establece el nivel de opacidad de la imagen
    • Imagick::setImageOrientation — Establece la orientación de la imagen
    • Imagick::setImagePage — Establece la geometría de la página de la imagen
    • Imagick::setImageProfile — Añade un perfil nominado al objeto Imagick
    • Imagick::setImageProperty — Establece una propiedad de la imagen
    • Imagick::setImageRedPrimary — Establece el punto primario rojo de la cromaticidad de la imagen
    • Imagick::setImageRenderingIntent — Establece el propósito de renderización de la imagen
    • Imagick::setImageResolution — Establece la resolución de la imagen
    • Imagick::setImageScene — Establece la escena de la imagen
    • Imagick::setImageTicksPerSecond — Establece los ticks por segundo de la imagen
    • Imagick::setImageType — Establece el tipo de imagen
    • Imagick::setImageUnits — Establece las unidades de resolución de la imagen
    • Imagick::setImageVirtualPixelMethod — Establece el método de píxel virtual de la imagen
    • Imagick::setImageWhitePoint — Establece el punto blanco de cromaticidad de la imagen
    • Imagick::setInterlaceScheme — Establece la compresión de la imagen
    • Imagick::setIteratorIndex — Establece la posición del iterador
    • Imagick::setLastIterator — Establece el iterador de Imagick a la última imagen
    • Imagick::setOption — Establece una opción
    • Imagick::setPage — Establece la geometría de página del objeto Imagick
    • Imagick::setPointSize — Establece el tamaño del punto
    • Imagick::setProgressMonitor — Description
    • Imagick::setRegistry — Description
    • Imagick::setResolution — Establece la resolución de la imagen
    • Imagick::setResourceLimit — Establece el límite de un recurso en particular en megabytes
    • Imagick::setSamplingFactors — Establece los factores de muestreo de la imagen
    • Imagick::setSize — Establece el tamaño del objeto Imagick
    • Imagick::setSizeOffset — Establece el tamaño y el índice del objeto Imagick
    • Imagick::setType — Establece el atributo tipo de imagen
    • Imagick::shadeImage — Crea un efecto en 3D
    • Imagick::shadowImage — Simula una sombra de imagen
    • Imagick::sharpenImage — Afila una imagen
    • Imagick::shaveImage — Recorta píxeles de los extremos de la imagen
    • Imagick::shearImage — Crea un paralelogramo
    • Imagick::sigmoidalContrastImage — Ajusta el contraste de una imagen
    • Imagick::sketchImage — Simula el bosquejo de un lapiz
    • Imagick::smushImages — Description
    • Imagick::solarizeImage — Aplica un efecto de solarización a la imagen
    • Imagick::sparseColorImage — Interpola colores
    • Imagick::spliceImage — Une un color sólido en la imagen
    • Imagick::spreadImage — Despalza aleatoriamente cada píxel en un bloque
    • Imagick::statisticImage — Description
    • Imagick::steganoImage — Oculta una marca de agua digital dentro de la imagen
    • Imagick::stereoImage — Compone dos imágenes
    • Imagick::stripImage — Elimina todos los perfiles y comentarios de una imagen
    • Imagick::subImageMatch — Description
    • Imagick::swirlImage — Arremolina los píxeles desde el centro de la imagen
    • Imagick::textureImage — Reviste repetidamente la textura de la imagen
    • Imagick::thresholdImage — Cambia el valor de píexeles individuales basdos en un umbral
    • Imagick::thumbnailImage — Cambia el tamaño de una imagen
    • Imagick::tintImage — Aplica un vector de color a cada píxel en la imagen
    • Imagick::__toString — Devuelve la imagen como un string
    • Imagick::transformImage — Método conveniente para establecer el tamaño del recorte y la geometría de la imagen
    • Imagick::transformImageColorspace — Transforma una imagen a un nuevo espacio de color
    • Imagick::transparentPaintImage — Pinta píxeles transparentes
    • Imagick::transposeImage — Crea una imagen espejo vertical
    • Imagick::transverseImage — Crea una imagen espejo horizontal
    • Imagick::trimImage — Elimina los extremos de la imagen
    • Imagick::uniqueImageColors — Desecha todos los colores de los píxeles excepto uno
    • Imagick::unsharpMaskImage — Afila una imagen
    • Imagick::valid — Comprueba si el elemento actual es válido
    • Imagick::vignetteImage — Añade un filtro de viñeta a la imagen
    • Imagick::waveImage — Aplica un filtro de onda a la imagen
    • Imagick::whiteThresholdImage — Fuerza a todos los píxeles por encima del umbral a ser blancos
    • Imagick::writeImage — Escribe una imagen al nombre de fichero especificado
    • Imagick::writeImageFile — Escribe una imagen a un gestor de archivo
    • Imagick::writeImages — Escribe una imagen o secuencia de imágenes
    • Imagick::writeImagesFile — Escribe fotogramas al gestor de archivo
  • ImagickDraw — La clase ImagickDraw
    • ImagickDraw::affine — Ajusta la matriz de transformación afín actual
    • ImagickDraw::annotation — Dibuja texto en la imagen
    • ImagickDraw::arc — Dibuja un arco
    • ImagickDraw::bezier — Dibuja una curva de Bézier
    • ImagickDraw::circle — Dibuja un círculo
    • ImagickDraw::clear — Borra el objeto ImagickDraw
    • ImagickDraw::clone — Hace una copia exacta del objeto ImagickDraw especificado
    • ImagickDraw::color — Dibuja color en una imagen
    • ImagickDraw::comment — Añade un comentario
    • ImagickDraw::composite — Compone una imagen dentro de la imagen actual
    • ImagickDraw::__construct — El constructor ImagickDraw
    • ImagickDraw::destroy — Libera todos los recursos asociados
    • ImagickDraw::ellipse — Dibuja una elipse en la imagen
    • ImagickDraw::getClipPath — Obtiene el ID del trazado de recorte actual
    • ImagickDraw::getClipRule — Devuelve la regla de relleno de un polígono actual
    • ImagickDraw::getClipUnits — Devuelve la interpretación de unidades del trazado de recorte
    • ImagickDraw::getFillColor — Devuelve el color de relleno
    • ImagickDraw::getFillOpacity — Devuelve la opacidad usada cuando se dibuja
    • ImagickDraw::getFillRule — Devuelve la regla de relleno
    • ImagickDraw::getFont — Devuelve la fuente
    • ImagickDraw::getFontFamily — Devuelve la familia de la fuente
    • ImagickDraw::getFontSize — Devuelve el tamaño de punto de la fuente
    • ImagickDraw::getFontStretch — Description
    • ImagickDraw::getFontStyle — Devuelve el estilo de fuente
    • ImagickDraw::getFontWeight — Devuelve el peso de la fuente
    • ImagickDraw::getGravity — Devuelve la gravedad de emplazamiento del texto
    • ImagickDraw::getStrokeAntialias — Devuelve la configuración de antialias de contorno actual
    • ImagickDraw::getStrokeColor — Devuelve el color usado por los perfiles de objetos contorneados
    • ImagickDraw::getStrokeDashArray — Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados
    • ImagickDraw::getStrokeDashOffset — Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
    • ImagickDraw::getStrokeLineCap — Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
    • ImagickDraw::getStrokeLineJoin — Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados
    • ImagickDraw::getStrokeMiterLimit — Devuelve el límite del inglete del contorno
    • ImagickDraw::getStrokeOpacity — Devuelve la opacidad del perfil de objetos contorneados
    • ImagickDraw::getStrokeWidth — Devuelve al ancho del contorno usado para dibujar contornos de objetos
    • ImagickDraw::getTextAlignment — Devuelve la alineación del texto
    • ImagickDraw::getTextAntialias — Devuelve la configuración de antialias del texto actual
    • ImagickDraw::getTextDecoration — Devuelve la decoración del texto
    • ImagickDraw::getTextEncoding — Devuelve la codificación usada para anotaciones de texto
    • ImagickDraw::getTextInterlineSpacing — Description
    • ImagickDraw::getTextInterwordSpacing — Description
    • ImagickDraw::getTextKerning — Description
    • ImagickDraw::getTextUnderColor — Devuelve el color debajo del texto
    • ImagickDraw::getVectorGraphics — Devuelve una cadena que contiene gráficos vectoriales
    • ImagickDraw::line — Dibuja una línea
    • ImagickDraw::matte — Pinta sobre el canal de opacidad de la imagen
    • ImagickDraw::pathClose — Añade un elemento de trazado al trazado actual
    • ImagickDraw::pathCurveToAbsolute — Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute — Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierRelative — Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToRelative — Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToSmoothAbsolute — Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToSmoothRelative — Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathEllipticArcAbsolute — Dibuja un arco elíptico
    • ImagickDraw::pathEllipticArcRelative — Dibuja un arco elíptico
    • ImagickDraw::pathFinish — Finaliza el trazado actual
    • ImagickDraw::pathLineToAbsolute — Dibuja un trazado de línea
    • ImagickDraw::pathLineToHorizontalAbsolute — Dibuja un trazado de línea horizontal
    • ImagickDraw::pathLineToHorizontalRelative — Dibuja una línea horizontal
    • ImagickDraw::pathLineToRelative — Dibuja un trazado de línea
    • ImagickDraw::pathLineToVerticalAbsolute — Dibuja un línea vertical
    • ImagickDraw::pathLineToVerticalRelative — Dibuja un trazado de línea vertical
    • ImagickDraw::pathMoveToAbsolute — Inicia un nuevo sub-trazado
    • ImagickDraw::pathMoveToRelative — Inicia un nuevo sub-trazado
    • ImagickDraw::pathStart — Declara el inicio de una lista de dibujo de trazados
    • ImagickDraw::point — Dibuja un punto
    • ImagickDraw::polygon — Dibuja un polígono
    • ImagickDraw::polyline — Dibuja una poli-línea
    • ImagickDraw::pop — Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido
    • ImagickDraw::popClipPath — Finaliza una definición de un trazado de recorte
    • ImagickDraw::popDefs — Finaliza una lista de definiciones
    • ImagickDraw::popPattern — Finaliza una definición de patrón
    • ImagickDraw::push — Clona el objeto ImagickDraw actual y lo mete en la pila
    • ImagickDraw::pushClipPath — Inicia la definición de un trazado de recorte
    • ImagickDraw::pushDefs — Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo
    • ImagickDraw::pushPattern — Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado
    • ImagickDraw::rectangle — Dibuja un rectángulo
    • ImagickDraw::render — Renderiza todos los comandos de dibujo precedentes en la imagen
    • ImagickDraw::resetVectorGraphics — Description
    • ImagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual
    • ImagickDraw::roundRectangle — Dibuja un rectángulo redondeado
    • ImagickDraw::scale — Ajusta el factor de escala
    • ImagickDraw::setClipPath — Asocia un trazado de recorte nominado con la imagen
    • ImagickDraw::setClipRule — Establece la regla de relleno de polígonos a usar por el trazado de recorte
    • ImagickDraw::setClipUnits — Establece la interpretación de las unidades de un trazado de recorte
    • ImagickDraw::setFillAlpha — Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno
    • ImagickDraw::setFillColor — Establece el color de relleno que se va a usar para dibujar objetos rellenos
    • ImagickDraw::setFillOpacity — Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno
    • ImagickDraw::setFillPatternURL — Establece la URL a usar como un patrón de relleno para objetos rellenos
    • ImagickDraw::setFillRule — Establece la regla de relleno a usar mientras se dibujan polígonos
    • ImagickDraw::setFont — Establece la fuente especificada completamente para usarla cuando se escribe texto
    • ImagickDraw::setFontFamily — Establece la familia de fuentes para usarla cuando se escribe texto
    • ImagickDraw::setFontSize — Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto
    • ImagickDraw::setFontStretch — Establece el estiramiento de la fuente para usarla cuando se escribe texto
    • ImagickDraw::setFontStyle — Establece el estilo de fuente para usarlo cuando se escribe texto
    • ImagickDraw::setFontWeight — Establece el peso de fuente
    • ImagickDraw::setGravity — Establece la gravedad de ubicación del texto
    • ImagickDraw::setResolution — Description
    • ImagickDraw::setStrokeAlpha — Especifica la opacidad de los perfiles de los objetos contorneados
    • ImagickDraw::setStrokeAntialias — Controla si los perfiles contorneados tiene antialias
    • ImagickDraw::setStrokeColor — Establece el color usado por los perfiles de objetos contorneados
    • ImagickDraw::setStrokeDashArray — Especifica el patrón de rayas y huecos usado por los trazados de contorno
    • ImagickDraw::setStrokeDashOffset — Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
    • ImagickDraw::setStrokeLineCap — Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
    • ImagickDraw::setStrokeLineJoin — Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados
    • ImagickDraw::setStrokeMiterLimit — Especifica el límite del inglete
    • ImagickDraw::setStrokeOpacity — Especifica la opacidad de los perfiles de los objetos contorneados
    • ImagickDraw::setStrokePatternURL — Establece el patrón usado para los perfiles de objetos contorneados
    • ImagickDraw::setStrokeWidth — Establece el ancho del contorno a usar para dibujar perfiles de objetos
    • ImagickDraw::setTextAlignment — Especifica una alineación de texto
    • ImagickDraw::setTextAntialias — Controla si el texto tiene antialias
    • ImagickDraw::setTextDecoration — Especifica una decoración
    • ImagickDraw::setTextEncoding — Especifica el conjunto de codificación del texto
    • ImagickDraw::setTextInterlineSpacing — Description
    • ImagickDraw::setTextInterwordSpacing — Description
    • ImagickDraw::setTextKerning — Description
    • ImagickDraw::setTextUnderColor — Especifica el color de un rectángulo de fondo
    • ImagickDraw::setVectorGraphics — Establece los gráficos vectoriales
    • ImagickDraw::setViewbox — Establece el tamaño de todos los lienzos
    • ImagickDraw::skewX — Tuerce el sistema de coordenadas actual en la dirección horizontal
    • ImagickDraw::skewY — Tuerce el sistema de coordenadas actual en la dirección vertical
    • ImagickDraw::translate — Aplica una traslación del sistema de coordenadas actual
  • ImagickPixel — La clase ImagickPixel
    • ImagickPixel::clear — Borra los recursos asociados con este objeto
    • ImagickPixel::__construct — El constructor ImagickPixel
    • ImagickPixel::destroy — Desasigna los recursos asociados con este objeto
    • ImagickPixel::getColor — Devuelve el color
    • ImagickPixel::getColorAsString — Devuelve el color como string
    • ImagickPixel::getColorCount — Devuelve la cuenta de color asociada a este
    • ImagickPixel::getColorQuantum — Description
    • ImagickPixel::getColorValue — Obtiene el valor normalizado del canal de color proporcionado
    • ImagickPixel::getColorValueQuantum — Description
    • ImagickPixel::getHSL — Devuelve el color HSL normalizado del objeto ImagickPixel
    • ImagickPixel::getIndex — Description
    • ImagickPixel::isPixelSimilar — Comprobar la distancia entre este color y otro
    • ImagickPixel::isPixelSimilarQuantum — Description
    • ImagickPixel::isSimilar — Comprobar la distancia entre este color y otro
    • ImagickPixel::setColor — Establece el color
    • ImagickPixel::setColorCount — Description
    • ImagickPixel::setColorValue — Establece el valor normalizado de uno de los canales
    • ImagickPixel::setColorValueQuantum — Description
    • ImagickPixel::setHSL — Establece el color HSL normalizado
    • ImagickPixel::setIndex — Description
  • ImagickPixelIterator — La clase ImagickPixelIterator
    • ImagickPixelIterator::clear — Borra los recursos asociados con un objeto PixelIterator
    • ImagickPixelIterator::__construct — El constructor ImagickPixelIterator
    • ImagickPixelIterator::destroy — Desasigna los recursos asociacdos con un objeto PixelIterator
    • ImagickPixelIterator::getCurrentIteratorRow — Devuelve la fila actual de objetos ImagickPixel
    • ImagickPixelIterator::getIteratorRow — Devuelve la fila actual del iterador de píxel
    • ImagickPixelIterator::getNextIteratorRow — Devuelve la fila siguiente del iterador de píxel
    • ImagickPixelIterator::getPreviousIteratorRow — Devuelve la fila previa
    • ImagickPixelIterator::newPixelIterator — Devuelve un nuevo iterador de píxel
    • ImagickPixelIterator::newPixelRegionIterator — Devuelve un nuevo iterador de píxel
    • ImagickPixelIterator::resetIterator — Reinicia el iterador de píxel
    • ImagickPixelIterator::setIteratorFirstRow — Establece el iterador de píxel a la primera fila de píxeles
    • ImagickPixelIterator::setIteratorLastRow — Establece el iterador de píxel a la última fila de píxeles
    • ImagickPixelIterator::setIteratorRow — Establecer la fila del iterador de píxel
    • ImagickPixelIterator::syncIterator — Sincornizar el iterador de píxel
  • ImagickKernel — La clase ImagickKernel
    • ImagickKernel::addKernel — Description
    • ImagickKernel::addUnityKernel — Description
    • ImagickKernel::fromBuiltIn — Description
    • ImagickKernel::fromMatrix — Description
    • ImagickKernel::getMatrix — Description
    • ImagickKernel::scale — Description
    • ImagickKernel::separate — Description


Introducción

Imagick es una extensión nativa de php para crear y modificar imágenes utilizando la API ImageMagick.

ImageMagick es un conjunto de software para crear, editar y componer imágenes de mapa de bits. Puede leer, convertir y escribir imágenes en una variedad de formatos (más de 100) incluyendo DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG y TIFF.

ImageMagick Studio LLC es una organización sin ánimo de lucro dedicada a realizar soluciones de software para imágenes disponible libremente.


Requerimientos

Requisitos de instalación en Windows

La información de la versión no difiere de la de arriba. Hay binarios diponibles en http://www.imagemagick.org/ por lo que se puede cargar esta extensión en Windows si necesidad de un compilador.

Requisitos de instalación en otras plataformas

Se requiere PHP >= 5.1.3 e ImageMagick >= 6.2.4. La cantidad de formatos admitidos por Imagick depende completamente de la cantidad de formatos admitidos por la instalación de ImageMagick. Por ejemplo, Imagemagick requiere ghostscript para llevar a cabo operaciones de PDF.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/imagick.

Nota: El nombre oficial de esta extensión es imagick.

Los usuarios de Windows pueden descargar la DLL preconstruida desde el sitio web de » PECL.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Imagick
Nombre | Por defecto | Cambiable | Historial de cambios
imagick.locale_fix | false | PHP_INI_ALL | Disponible desde Imagick 2.1.0
imagick.progress_monitor | false | PHP_INI_SYSTEM | Disponible desde Imagick 2.2.2
imagick.skip_version_check | false | PHP_INI_SYSTEM | Disponible desde Imagick 3.3.0
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

imagick.locale_fix boolean

Corrige un error de dibujo con localismos que emplean ',' como separadores decimales.

imagick.progress_monitor boolean

Usado para habilitar el monitor de progreso de imagen.

imagick.skip_version_check boolean

Cuando Imagick se carga, se comprueba el número de versión de ImageMagick con el que se compiló con el número de verisón que se está utilizando actualmente, produciendo una advertencia si no coinciden. Esta advertencia se puede omitir habilitando esta opción.

No se recomienda utilizar una versión de compilación de Imagick diferente a la versión de ImageMagick que se esté empleado. Aunque pueda parecer que funciona, puede conducir a fallos aleatorios u otro tipo de comportamiento no definido.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes COLOR_*

Constantes de tipo de color. Estas constantes son principalmente usadas por ImagickPixel.

COLOR_BLACK (integer)
Color negro
COLOR_BLUE (integer)
Color azul
COLOR_CYAN (integer)
Color cian
COLOR_GREEN (integer)
Color verde
COLOR_RED (integer)
Color rojo
COLOR_YELLOW (integer)
Color amarillo
COLOR_MAGENTA (integer)
Color magenta
COLOR_OPACITY (integer)
Opacidad del color
COLOR_ALPHA (integer)
Canal alfa del color
COLOR_FUZZ (integer)
Enfoque del color
Constantes DISPOSE

Constantes de Tipo de Disposición

DISPOSE_UNRECOGNIZED (integer)
Tipo de disposición no reconocido
DISPOSE_UNDEFINED (integer)
Tipo de disposición indefinido
DISPOSE_NONE (integer)
Tipo de disposición no definido
DISPOSE_BACKGROUND (integer)
Disposición de fondo
DISPOSE_PREVIOUS (integer)
Disposición previa
Constantes de Operadores de Composición
COMPOSITE_DEFAULT (integer)
Operador de composición por defecto
COMPOSITE_UNDEFINED (integer)
Operador de composición indefinido
COMPOSITE_NO (integer)
Operador de disposición no definido
COMPOSITE_ADD (integer)
El resultado de imagen + imagen
COMPOSITE_ATOP (integer)
El resultado tiene la misma forma que la imagen, con la imagen compuesta oscurenciendo la imagen, donde la imagen forma traslapado
COMPOSITE_BLEND (integer)
Mezcla la imagen
COMPOSITE_BUMPMAP (integer)
Lo mismo que COMPOSITE_MULTIPLY, excepto que el origen primero se covierte a escala de grises.
COMPOSITE_CLEAR (integer)
Hace a la imagen objetivo transparente
COMPOSITE_COLORBURN (integer)
Oscurece la imagen destino para reflejar la imagen de origen
COMPOSITE_COLORDODGE (integer)
Hace más brillante la imagen destino para reflejar la imagen de origen
COMPOSITE_COLORIZE (integer)
Colorea la imagen objetivo utilizando la imagen compuesta
COMPOSITE_COPYBLACK (integer)
Copia el negro del origen al objetivo
COMPOSITE_COPYBLUE (integer)
Copia el azul del origen al objetivo
COMPOSITE_COPY (integer)
Copia la imagen de origen a la imagen objetivo
COMPOSITE_COPYCYAN (integer)
Copia el cian del origen al objetivo
COMPOSITE_COPYGREEN (integer)
Copia el verde del origen al objetivo
COMPOSITE_COPYMAGENTA (integer)
Copia el magenta del origen al objetivo
COMPOSITE_COPYOPACITY (integer)
Copia la opacidad del origen al objetivo
COMPOSITE_COPYRED (integer)
Copia el rojo del origen al objetivo
COMPOSITE_COPYYELLOW (integer)
Copia el amarillo del origen al objetivo
COMPOSITE_DARKEN (integer)
Oscurece la imagen objetivo
COMPOSITE_DSTATOP (integer)
La parte de la capa destino dentro del origen se compone sobre el origen y reemplaza el destino
COMPOSITE_DST (integer)
El objetivo se deja sin tocar
COMPOSITE_DSTIN (integer)
La parte dentro del origen reemplaza el objetivo
COMPOSITE_DSTOUT (integer)
La parte fuera del origen reemplaza el objetivo
COMPOSITE_DSTOVER (integer)
El objetivo reemplaza el origen
COMPOSITE_DIFFERENCE (integer)
Sustrae el más oscuro de los dos colores constituyentes del más luminiso
COMPOSITE_DISPLACE (integer)
Cambia los píxeles de la imagen objetivo como se definió en el origen
COMPOSITE_DISSOLVE (integer)
Disuelve el origen en el objetivo
COMPOSITE_EXCLUSION (integer)
Produce un efecto similar al de imagick::COMPOSITE_DIFFERENCE, pero aparece con un contraste menor
COMPOSITE_HARDLIGHT (integer)
Multiplica u oculta los colores, dependiendo del valor del color de origen
COMPOSITE_HUE (integer)
Modifica el tono del objetivo como se definió en el origen
COMPOSITE_IN (integer)
Compone el origen dentro del objetivo
COMPOSITE_LIGHTEN (integer)
Aclara el objetivo como se definió en el origen
COMPOSITE_LUMINIZE (integer)
Hace más luminoso el objetivo como se definió en el origen
COMPOSITE_MINUS (integer)
Sustrae el origen del objetivo
COMPOSITE_MODULATE (integer)
Modula el brillo, la saturación y el tono del objetivo como se definió en el origen
COMPOSITE_MULTIPLY (integer)
Multiplica el objetivo en el origen
COMPOSITE_OUT (integer)
Comopone las partes exteriores del origen en el objetivo
COMPOSITE_OVER (integer)
Compone el origen sobre el objetivo
COMPOSITE_OVERLAY (integer)
Sobrepone el origen en el objetivo
COMPOSITE_PLUS (integer)
Añade el origen al objetivo
COMPOSITE_REPLACE (integer)
Reemplaza el objetivo con el origen
COMPOSITE_SATURATE (integer)
Satura el objetivo como se definió en el origen
COMPOSITE_SCREEN (integer)
El origen y destino son complementados, después multiplicados, y después reemplazan el destino
COMPOSITE_SOFTLIGHT (integer)
Oscurece o ilumina los colores, dependiendo del origen
COMPOSITE_SRCATOP (integer)
La parte de la capa de origen dentro del destino es compuesta en el destino
COMPOSITE_SRC (integer)
El origen se copia al destino
COMPOSITE_SRCIN (integer)
La parte de la capa del origen dentro del destino reemplaza el destino
COMPOSITE_SRCOUT (integer)
La parte de la capa del origen fuera del destino reemplaza el destino
COMPOSITE_SRCOVER (integer)
El origen reemplaza el destino
COMPOSITE_SUBTRACT (integer)
Sustrae los colores en la imagen de origen de la imagen destino
COMPOSITE_THRESHOLD (integer)
El origen es compuesto en el objetivo como se definió en el umbral del origen
COMPOSITE_XOR (integer)
La parte del origen que yace fuera del destino se combina con la parte del destino que yace fuera del origen
Constantes MONTAGEMODE (Modo de Montaje)

MONTAGEMODE_FRAME (integer)
MONTAGEMODE_UNFRAME (integer)
MONTAGEMODE_CONCATENATE (integer)
Constantes STYLE (Estilo)

STYLE_NORMAL (integer)
STYLE_ITALIC (integer)
STYLE_OBLIQUE (integer)
STYLE_ANY (integer)
Constantes FILTER (Filtro)

FILTER_UNDEFINED (integer)
FILTER_POINT (integer)
FILTER_BOX (integer)
FILTER_TRIANGLE (integer)
FILTER_HERMITE (integer)
FILTER_HANNING (integer)
FILTER_HAMMING (integer)
FILTER_BLACKMAN (integer)
FILTER_GAUSSIAN (integer)
FILTER_QUADRATIC (integer)
FILTER_CUBIC (integer)
FILTER_CATROM (integer)
FILTER_MITCHELL (integer)
FILTER_LANCZOS (integer)
FILTER_BESSEL (integer)
FILTER_SINC (integer)
Constantes IMGTYPE (Tipo de Imagen)

IMGTYPE_UNDEFINED (integer)
IMGTYPE_BILEVEL (integer)
IMGTYPE_GRAYSCALE (integer)
IMGTYPE_GRAYSCALEMATTE (integer)
IMGTYPE_PALETTE (integer)
IMGTYPE_PALETTEMATTE (integer)
IMGTYPE_TRUECOLOR (integer)
IMGTYPE_TRUECOLORMATTE (integer)
IMGTYPE_COLORSEPARATION (integer)
IMGTYPE_COLORSEPARATIONMATTE (integer)
IMGTYPE_OPTIMIZE (integer)
Constantes RESOLUTION (Resolución)

RESOLUTION_UNDEFINED (integer)
RESOLUTION_PIXELSPERINCH (integer)
RESOLUTION_PIXELSPERCENTIMETER (integer)
Constantes COMPRESSION (Compresión)

COMPRESSION_UNDEFINED (integer)
COMPRESSION_NO (integer)
COMPRESSION_BZIP (integer)
COMPRESSION_FAX (integer)
COMPRESSION_GROUP4 (integer)
COMPRESSION_JPEG (integer)
COMPRESSION_JPEG2000 (integer)
COMPRESSION_LOSSLESSJPEG (integer)
COMPRESSION_LZW (integer)
COMPRESSION_RLE (integer)
COMPRESSION_ZIP (integer)
COMPRESSION_DXT1 (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.0 o superior.
COMPRESSION_DXT3 (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.0 o superior.
COMPRESSION_DXT5 (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.0 o superior.
Constantes PAINT (Pintura)

PAINT_POINT (integer)
PAINT_REPLACE (integer)
PAINT_FLOODFILL (integer)
PAINT_FILLTOBORDER (integer)
PAINT_RESET (integer)
Constantes GRAVITY (Gravedad)

GRAVITY_NORTHWEST (integer)
GRAVITY_NORTH (integer)
GRAVITY_NORTHEAST (integer)
GRAVITY_WEST (integer)
GRAVITY_CENTER (integer)
GRAVITY_EAST (integer)
GRAVITY_SOUTHWEST (integer)
GRAVITY_SOUTH (integer)
GRAVITY_SOUTHEAST (integer)
Constantes STRETCH (Estiramiento)

STRETCH_NORMAL (integer)
STRETCH_ULTRACONDENSED (integer)
STRETCH_CONDENSED (integer)
STRETCH_SEMICONDENSED (integer)
STRETCH_SEMIEXPANDED (integer)
STRETCH_EXPANDED (integer)
STRETCH_EXTRAEXPANDED (integer)
STRETCH_ULTRAEXPANDED (integer)
STRETCH_ANY (integer)
Constantes ALIGN (Alineamiento)

ALIGN_UNDEFINED (integer)
ALIGN_LEFT (integer)
ALIGN_CENTER (integer)
ALIGN_RIGHT (integer)
Constantes DECORATION (Decoración)

DECORATION_NO (integer)
DECORATION_UNDERLINE (integer)
DECORATION_OVERLINE (integer)
DECORATION_LINETROUGH (integer)
Constantes NOISE (Ruido)

NOISE_UNIFORM (integer)
NOISE_GAUSSIAN (integer)
NOISE_MULTIPLICATIVEGAUSSIAN (integer)
NOISE_IMPULSE (integer)
NOISE_LAPLACIAN (integer)
NOISE_POISSON (integer)
NOISE_RANDOM (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
Constantes CHANNEL (Canal)

CHANNEL_UNDEFINED (integer)
CHANNEL_RED (integer)
CHANNEL_GRAY (integer)
CHANNEL_CYAN (integer)
CHANNEL_GREEN (integer)
CHANNEL_MAGENTA (integer)
CHANNEL_BLUE (integer)
CHANNEL_YELLOW (integer)
CHANNEL_ALPHA (integer)
CHANNEL_OPACITY (integer)
CHANNEL_MATTE (integer)
CHANNEL_BLACK (integer)
CHANNEL_INDEX (integer)
CHANNEL_ALL (integer)
CHANNEL_DEFAULT (integer)
Constantes METRIC (Métrica)

METRIC_UNDEFINED (integer)
METRIC_MEANABSOLUTEERROR (integer)
METRIC_MEANSQUAREERROR (integer)
METRIC_PEAKABSOLUTEERROR (integer)
METRIC_PEAKSIGNALTONOISERATIO (integer)
METRIC_ROOTMEANSQUAREDERROR (integer)
Constantes PIXEL

PIXEL_CHAR (integer)
PIXEL_DOUBLE (integer)
PIXEL_FLOAT (integer)
PIXEL_INTEGER (integer)
PIXEL_LONG (integer)
PIXEL_QUANTUM (integer)
PIXEL_SHORT (integer)
Constantes EVALUATE

EVALUATE_UNDEFINED (integer)
EVALUATE_ADD (integer)
EVALUATE_AND (integer)
EVALUATE_DIVIDE (integer)
EVALUATE_LEFTSHIFT (integer)
EVALUATE_MAX (integer)
EVALUATE_MIN (integer)
EVALUATE_MULTIPLY (integer)
EVALUATE_OR (integer)
EVALUATE_RIGHTSHIFT (integer)
EVALUATE_SET (integer)
EVALUATE_SUBTRACT (integer)
EVALUATE_XOR (integer)
EVALUATE_POW (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_LOG (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_THRESHOLD (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_THRESHOLDBLACK (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_THRESHOLDWHITE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_GAUSSIANNOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_IMPULSENOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_LAPLACIANNOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_MULTIPLICATIVENOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_POISSONNOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_UNIFORMNOISE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_COSINE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_SINE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
EVALUATE_ADDMODULUS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.4 o superior.
Constantes COLORSPACE (Espacio de Color)

COLORSPACE_UNDEFINED (integer)
COLORSPACE_RGB (integer)
COLORSPACE_GRAY (integer)
COLORSPACE_TRANSPARENT (integer)
COLORSPACE_OHTA (integer)
COLORSPACE_LAB (integer)
COLORSPACE_XYZ (integer)
COLORSPACE_YCBCR (integer)
COLORSPACE_YCC (integer)
COLORSPACE_YIQ (integer)
COLORSPACE_YPBPR (integer)
COLORSPACE_YUV (integer)
COLORSPACE_CMYK (integer)
COLORSPACE_SRGB (integer)
COLORSPACE_HSB (integer)
COLORSPACE_HSL (integer)
COLORSPACE_HWB (integer)
COLORSPACE_REC601LUMA (integer)
COLORSPACE_REC709LUMA (integer)
COLORSPACE_LOG (integer)
COLORSPACE_CMY (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.2 o superior.
Constantes VIRTUALPIXELMETHOD (Métodos de Píxel Virtual)

VIRTUALPIXELMETHOD_UNDEFINED (integer)
VIRTUALPIXELMETHOD_BACKGROUND (integer)
VIRTUALPIXELMETHOD_CONSTANT (integer)
VIRTUALPIXELMETHOD_EDGE (integer)
VIRTUALPIXELMETHOD_MIRROR (integer)
VIRTUALPIXELMETHOD_TILE (integer)
VIRTUALPIXELMETHOD_TRANSPARENT (integer)
VIRTUALPIXELMETHOD_MASK (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.2 o superior.
VIRTUALPIXELMETHOD_BLACK (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.2 o superior.
VIRTUALPIXELMETHOD_GRAY (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.2 o superior.
VIRTUALPIXELMETHOD_WHITE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.2 o superior.
VIRTUALPIXELMETHOD_HORIZONTALTILE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.3 o superior.
VIRTUALPIXELMETHOD_VERTICALTILE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.3 o superior.
Constantes PREVIEW (Previsualización)

PREVIEW_UNDEFINED (integer)
PREVIEW_ROTATE (integer)
PREVIEW_SHEAR (integer)
PREVIEW_ROLL (integer)
PREVIEW_HUE (integer)
PREVIEW_SATURATION (integer)
PREVIEW_BRIGHTNESS (integer)
PREVIEW_GAMMA (integer)
PREVIEW_SPIFF (integer)
PREVIEW_DULL (integer)
PREVIEW_GRAYSCALE (integer)
PREVIEW_QUANTIZE (integer)
PREVIEW_DESPECKLE (integer)
PREVIEW_REDUCENOISE (integer)
PREVIEW_ADDNOISE (integer)
PREVIEW_SHARPEN (integer)
PREVIEW_BLUR (integer)
PREVIEW_THRESHOLD (integer)
PREVIEW_EDGEDETECT (integer)
PREVIEW_SPREAD (integer)
PREVIEW_SOLARIZE (integer)
PREVIEW_SHADE (integer)
PREVIEW_RAISE (integer)
PREVIEW_SEGMENT (integer)
PREVIEW_SWIRL (integer)
PREVIEW_IMPLODE (integer)
PREVIEW_WAVE (integer)
PREVIEW_OILPAINT (integer)
PREVIEW_CHARCOALDRAWING (integer)
PREVIEW_JPEG (integer)
Constantes RENDERINGINTENT (Propósitos de Renderización)

RENDERINGINTENT_UNDEFINED (integer)
RENDERINGINTENT_SATURATION (integer)
RENDERINGINTENT_PERCEPTUAL (integer)
RENDERINGINTENT_ABSOLUTE (integer)
RENDERINGINTENT_RELATIVE (integer)
Constantes INTERLACE

INTERLACE_UNDEFINED (integer)
INTERLACE_NO (integer)
INTERLACE_LINE (integer)
INTERLACE_PLANE (integer)
INTERLACE_PARTITION (integer)
INTERLACE_GIF (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.4 o superior.
INTERLACE_JPEG (integer)
INTERLACE_PNG (integer)
Constantes FILLRULE (Regla de Relleno)

FILLRULE_UNDEFINED (integer)
FILLRULE_EVENODD (integer)
FILLRULE_NONZERO (integer)
Constantes PATHUNITS (Unidades de Trazado)

PATHUNITS_UNDEFINED (integer)
PATHUNITS_USERSPACE (integer)
PATHUNITS_USERSPACEONUSE (integer)
PATHUNITS_OBJECTBOUNDINGBOX (integer)
Constantes LINECAP (Cierre de Línea)

LINECAP_UNDEFINED (integer)
LINECAP_BUTT (integer)
LINECAP_ROUND (integer)
LINECAP_SQUARE (integer)
Constantes LINEJOIN (Unión de Línea)

LINEJOIN_UNDEFINED (integer)
LINEJOIN_MITER (integer)
LINEJOIN_ROUND (integer)
LINEJOIN_BEVEL (integer)
Constantes RESOURCETYPE (Tipo de Recurso)

RESOURCETYPE_UNDEFINED (integer)
RESOURCETYPE_AREA (integer)
Establecer el máximo ancho * alto de una imagen que puede residir en la memoria caché de pixel.
RESOURCETYPE_DISK (integer)
Establecer el espacio máximo de disco permitido en bytes que use la caché de pixel.
RESOURCETYPE_FILE (integer)
Establecer el número máximo de ficheros de caché de pixel abiertos.
RESOURCETYPE_MAP (integer)
Establecer la cantidad máxima de mapa de memoria a asignar en bytes para la caché de pixel.
RESOURCETYPE_MEMORY (integer)
Establecer la cantidad máxima de memoria en bytes a asignar para la caché de pixel desde el montículo.
imagick::RESOURCETYPE_THREAD (integer)
Establecer el máximo de hilos paralelos Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.7.8 o superior.
Constantes LAYERMETHOD

LAYERMETHOD_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_COALESCE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_COMPAREANY (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_COMPARECLEAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_COMPAREOVERLAY (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_DISPOSE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_OPTIMIZE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_OPTIMIZEPLUS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.2.9 o superior.
LAYERMETHOD_OPTIMIZEIMAGE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
LAYERMETHOD_OPTIMIZETRANS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
LAYERMETHOD_REMOVEDUPS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
LAYERMETHOD_REMOVEZERO (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
LAYERMETHOD_COMPOSITE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
LAYERMETHOD_MERGE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.7 o superior.
LAYERMETHOD_FLATTEN (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.7 o superior.
LAYERMETHOD_MOSAIC (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.7 o superior.
Constantes ORIENTATION (Orientación)

ORIENTATION_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_TOPLEFT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_TOPRIGHT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_BOTTOMRIGHT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_BOTTOMLEFT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_LEFTTOP (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_RIGHTTOP (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_RIGHTBOTTOM (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
ORIENTATION_LEFTBOTTOM (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.0 o superior.
Constantes DISTORTION

DISTORTION_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_AFFINE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_AFFINEPROJECTION (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_ARC (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_BILINEAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_PERSPECTIVE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_PERSPECTIVEPROJECTION (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_SCALEROTATETRANSLATE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.6 o superior.
DISTORTION_POLYNOMIAL (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_POLAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_DEPOLAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_BARREL (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_BARRELINVERSE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_SHEPARDS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DISTORTION_SENTINEL (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
Constantes ALPHACHANNEL

ALPHACHANNEL_ACTIVATE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.8 o superior.
ALPHACHANNEL_DEACTIVATE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.8 o superior.
ALPHACHANNEL_RESET (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.8 o superior.
ALPHACHANNEL_SET (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.8 o superior.
ALPHACHANNEL_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
ALPHACHANNEL_COPY (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
ALPHACHANNEL_EXTRACT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
ALPHACHANNEL_OPAQUE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
ALPHACHANNEL_SHAPE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
ALPHACHANNEL_TRANSPARENT (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
Constantes SPARSECOLORMETHOD

SPARSECOLORMETHOD_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
SPARSECOLORMETHOD_BARYCENTRIC (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
SPARSECOLORMETHOD_BILINEAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
SPARSECOLORMETHOD_POLYNOMIAL (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
SPARSECOLORMETHOD_SPEPARDS (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
SPARSECOLORMETHOD_VORONOI (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
Constantes FUNCTION

FUNCTION_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.9 o superior.
FUNCTION_POLYNOMIAL (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.9 o superior.
FUNCTION_SINUSOID (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.9 o superior.
Constantes INTERPOLATE

INTERPOLATE_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_AVERAGE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_BICUBIC (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_BILINEAR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_FILTER (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_INTEGER (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_MESH (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_NEARESTNEIGHBOR (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.2 o superior.
INTERPOLATE_SPLINE (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.3.4 o superior.
Constantes DITHERMETHOD

DITHERMETHOD_UNDEFINED (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DITHERMETHOD_NO (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DITHERMETHOD_RIEMERSMA (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.
DITHERMETHOD_FLOYDSTEINBERG (integer)
Esta constante está disponible si Imagick ha sido compilado con ImageMagick en su versión 6.4.6 o superior.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • ImageMagick
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Imagick hace que la manipulación de imágenes en PHP sea extremadamente sencilla a través de una interfaz OO. Aquí está un ejemplo breve de cómo hacer una miniatura:

Ejemplo #1 Crear una miniatura con Imagick

<?php

header('Content-type: image/jpeg');

$imagen = new Imagick('imagen.jpg');

// Si se proporciona 0 como parámetro de ancho o alto,
// se mantiene la proporción de aspecto
$imagen->thumbnailImage(100, 0);

echo $imagen;

?>

Al usar SPL y otras características OO soportadas en Imagick, puede ser sencillo redimensionar todos los archivos de un directorio (útil para la redimensión por lotes de muchas imágenes de cámara digital para que sean visibles desde una web). Aquí usamos redimensión, ya que queremos mantener cierta meta-información:

Ejemplo #2 Hacer una miniatura de todos los archivos JPG de un directorio

<?php

$imágenes = new Imagick(glob('imagenes/*.JPG'));

foreach($imágenes as $imagen) {

    // Proporcionar 0 fuerza a thumbnailImage a mantener la proporción de aspecto
    $imagen->thumbnailImage(1024,0);

}

$imágenes->writeImages();

?>

Este es un ejemplo de crear un reflejo de una imagen. El reflejo se crea volteando la imagen y poniendo una capa de gradiente sobre ella. Ambas, la imagen original y el reflejo, están sobrepuestas en un lienzo.

Ejemplo #3 Crear un reflejo de una imagen

<?php
/* Leer la imagen */
$im = new Imagick("test.png");

/* Miniaturizar la imagen */
$im->thumbnailImage(200, null);

/* Crear un borde para la imagen */
$im->borderImage(new ImagickPixel("white"), 5, 5);

/* Clonar la imagen y voltearla */
$reflejo = $im->clone();
$reflejo->flipImage();

/* Crear un gradiente. Será sobrepuesto en el reflejo */
$gradiente = new Imagick();

/* El gradiente necesita ser más grande que la imagen y los bordes */
$gradiente->newPseudoImage($reflejo->getImageWidth() + 10, $reflejo->getImageHeight() + 10, "gradient:transparent-black");

/* Componer el gradiente con el reflejo */
$reflejo->compositeImage($gradiente, imagick::COMPOSITE_OVER, 0, 0);

/* Añadir algo de opacidad. Requiere ImageMagick 6.2.9 o superior */
$reflejo->setImageOpacity( 0.3 );

/* Crear un lienzo vacío */
$lienzo = new Imagick();

/* El lienzo necesita ser más grande para mantener ambas imágenes */
$ancho = $im->getImageWidth() + 40;
$alto = ($im->getImageHeight() * 2) + 30;
$lienzo->newImage($ancho, $alto, new ImagickPixel("black"));
$lienzo->setImageFormat("png");

/* Componer la imagen original y el reflejo sobre el lienzo */
$lienzo->compositeImage($im, imagick::COMPOSITE_OVER, 20, 10);
$lienzo->compositeImage($reflejo, imagick::COMPOSITE_OVER, 20, $im->getImageHeight() + 10);

/* Imprimir la imagen */
header("Content-Type: image/png");
echo $lienzo;
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Crear un reflejo de una imagen

Este ejemplo ilustra cómo usar patrones de relleno durante el dibujo.

Ejemplo #4 Rellenar un texto con un gradiente

<?php

/* Crear un nuevo objeto imagick */
$im = new Imagick();

/* Crear una nueva imagen. Será usada como patrón de relleno */
$im->newPseudoImage(50, 50, "gradient:red-black");

/* Crear un objeto imagickdraw */
$dibujo = new ImagickDraw();

/* Iniciar un nuevo patrón llamado "gradient" */
$dibujo->pushPattern('gradient', 0, 0, 50, 50);

/* Componer el gradiente con el patrón */
$dibujo->composite(Imagick::COMPOSITE_OVER, 0, 0, 50, 50, $im);

/* Cerrar el patrón */
$dibujo->popPattern();

/* Usar el patrón llamado "gradient" como el relleno */
$dibujo->setFillPatternURL('#gradient');

/* Establecer el tamaño de fuente a 52 */
$dibujo->setFontSize(52);

/* Anotar algo de texto */
$dibujo->annotation(20, 50, "Hello World!");

/* Crear un nuevo lienzo y una imagen blanca */
$lienzo = new Imagick();
$lienzo->newImage(350, 70, "white");

/* Dibujar el objeto ImagickDraw sobre el lienzo */
$lienzo->drawImage($dibujo);

/* Borde negro de 1px alrededor de la imagen */
$lienzo->borderImage('black', 1, 1);

/* Establecer el formato a PNG */
$lienzo->setImageFormat('png');

/* Imprimir la imagen */
header("Content-Type: image/png");
echo $lienzo;
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Rellenar texto con gradiente

Trabajar con imágenes GIF animadas

Ejemplo #5 Leer una imágen GIF y redimensionar todos los fotogramas

<?php

/* Crear un nuevo objeto imagick y leer el GIF */
$im = new Imagick("ejemplo.gif");

/* Redimensionar todos los fotogramas */
foreach ($im as $fotograma) {
 /* Fotogramas de 50x50 */
 $fotograma->thumbnailImage(50, 50);

 /* Establecer el lienzo virtual para corregir el tamaño */
 $fotograma->setImagePage(50, 50, 0, 0);
}

/* Observe: writeImages en vez de writeImage */
$im->writeImages("example_small.gif", true);
?>

Trabajar con primitivas de elipse y tipos de letra personalizados

Ejemplo #6 Crear un logo de PHP

<?php
/* Establecer el ancho y alto en proporción al logo genuino de PHP */
$ancho = 400;
$alto = 210;

/* Crear un objeto Imagick con lienzo transparente */
$img = new Imagick();
$img->newImage($ancho, $alto, new ImagickPixel('transparent'));

/* Nueva instancia de ImagickDraw para dibujar la elipse */
$dibujo = new ImagickDraw();
/* Establecer el color de relleno púrpura para la elipse */
$dibujo->setFillColor('#777bb4');
/* Establecer las dimensiones de la elipse */
$dibujo->ellipse($ancho / 2, $alto / 2, $ancho / 2, $alto / 2, 0, 360);
/* Dibujar la elipse en el lienzo */
$img->drawImage($dibujo);

/* Restablecer el color de relleno de púrpura a negro para el texto (nota: estamos reutilizando el objeto ImagickDraw) */
$dibujo->setFillColor('black');
/* Establecer el borde del contorno al color blanco */
$dibujo->setStrokeColor('white');
/* Establecer el grosor del borde del contorno */
$dibujo->setStrokeWidth(2);
/* Establecer el interletraje («kerning») del tipo de letra (un valor negativo significa que las letras están más juntas entre ellas) */
$dibujo->setTextKerning(-8);
/* Establecer el tamaño del tipo de letra usado para el logo de PHP */
$dibujo->setFont('Handel Gothic.ttf');
$dibujo->setFontSize(150);
/* Centrar el texto horizontal y verticalmente */
$dibujo->setGravity(Imagick::GRAVITY_CENTER);

/* Añadir en el centro "php" con el índice Y de -10 al lienzo (dentro de la elipse) */
$img->annotateImage($dibujo, 0, -10, 0, 'php');
$img->setImageFormat('png');

/* Establecer la cabecera apropiada para PNG y generar la imagen */
header('Content-Type: image/png');
echo $img;
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo: Crear el logo de PHP con Imagick


La clase Imagick

(PECL imagick 2, PECL imagick 3)

Sinopsis de la Clase

Imagick implements Iterator {
adaptiveBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
adaptiveResizeImage ( int $columns , int $rows , bool $bestfit = false ) : bool
adaptiveSharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
adaptiveThresholdImage ( int $width , int $height , int $offset ) : bool
addImage ( Imagick $source ) : bool
addNoiseImage ( int $noise_type , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
affineTransformImage ( ImagickDraw $matrix ) : bool
animateImages ( string $x_server ) : bool
annotateImage ( ImagickDraw $draw_settings , float $x , float $y , float $angle , string $text ) : bool
appendImages ( bool $stack = false ) : Imagick
public autoLevelImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool
averageImages ( ) : Imagick
blackThresholdImage ( mixed $threshold ) : bool
public blueShiftImage ( float $factor = 1.5 ) : bool
blurImage ( float $radius , float $sigma , int $channel = ? ) : bool
borderImage ( mixed $bordercolor , int $width , int $height ) : bool
public brightnessContrastImage ( float $brightness , float $contrast , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
charcoalImage ( float $radius , float $sigma ) : bool
chopImage ( int $width , int $height , int $x , int $y ) : bool
public clampImage ( string $CHANNEL = Imagick::CHANNEL_DEFAULT ) : void
clear ( ) : bool
clipImage ( ) : bool
public clipImagePath ( string $pathname , string $inside ) : void
clipPathImage ( string $pathname , bool $inside ) : bool
clone ( ) : Imagick
clutImage ( Imagick $lookup_table , float $channel = Imagick::CHANNEL_DEFAULT ) : bool
coalesceImages ( ) : Imagick
colorFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool
colorizeImage ( mixed $colorize , mixed $opacity ) : bool
public colorMatrixImage ( array $color_matrix = Imagick::CHANNEL_DEFAULT ) : bool
combineImages ( int $channelType ) : Imagick
commentImage ( string $comment ) : bool
compareImageChannels ( Imagick $image , int $channelType , int $metricType ) : array
compareImageLayers ( int $method ) : Imagick
compareImages ( Imagick $compare , int $metric ) : array
compositeImage ( Imagick $composite_object , int $composite , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool
__construct ( mixed $files )
contrastImage ( bool $sharpen ) : bool
contrastStretchImage ( float $black_point , float $white_point , int $channel = Imagick::CHANNEL_ALL ) : bool
convolveImage ( array $kernel , int $channel = Imagick::CHANNEL_ALL ) : bool
public count ( int $mode = 0 ) : int
cropImage ( int $width , int $height , int $x , int $y ) : bool
cropThumbnailImage ( int $width , int $height ) : bool
current ( ) : Imagick
cycleColormapImage ( int $displace ) : bool
decipherImage ( string $passphrase ) : bool
deconstructImages ( ) : Imagick
deleteImageArtifact ( string $artifact ) : bool
public deleteImageProperty ( string $name ) : bool
public deskewImage ( float $threshold ) : bool
despeckleImage ( ) : bool
destroy ( ) : bool
displayImage ( string $servername ) : bool
displayImages ( string $servername ) : bool
distortImage ( int $method , array $arguments , bool $bestfit ) : bool
drawImage ( ImagickDraw $draw ) : bool
edgeImage ( float $radius ) : bool
embossImage ( float $radius , float $sigma ) : bool
encipherImage ( string $passphrase ) : bool
enhanceImage ( ) : bool
equalizeImage ( ) : bool
evaluateImage ( int $op , float $constant , int $channel = Imagick::CHANNEL_ALL ) : bool
public exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE ) : array
extentImage ( int $width , int $height , int $x , int $y ) : bool
public filter ( ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_UNDEFINED ) : bool
flattenImages ( ) : Imagick
flipImage ( ) : bool
floodFillPaintImage ( mixed $fill , float $fuzz , mixed $target , int $x , int $y , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
flopImage ( ) : bool
public forwardFourierTransformimage ( bool $magnitude ) : bool
frameImage ( mixed $matte_color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : bool
public functionImage ( int $function , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
fxImage ( string $expression , int $channel = Imagick::CHANNEL_ALL ) : Imagick
gammaImage ( float $gamma , int $channel = Imagick::CHANNEL_ALL ) : bool
gaussianBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_ALL ) : bool
getColorspace ( ) : int
getCompression ( ) : int
getCompressionQuality ( ) : int
getCopyright ( ) : string
getFilename ( ) : string
getFont ( ) : string
getFormat ( ) : string
getGravity ( ) : int
getHomeURL ( ) : string
getImage ( ) : Imagick
getImageAlphaChannel ( ) : int
getImageArtifact ( string $artifact ) : string
public getImageAttribute ( string $key ) : string
getImageBackgroundColor ( ) : ImagickPixel
getImageBlob ( ) : string
getImageBluePrimary ( ) : array
getImageBorderColor ( ) : ImagickPixel
getImageChannelDepth ( int $channel ) : int
getImageChannelDistortion ( Imagick $reference , int $channel , int $metric ) : float
getImageChannelDistortions ( Imagick $reference , int $metric , int $channel = Imagick::CHANNEL_DEFAULT ) : float
getImageChannelExtrema ( int $channel ) : array
public getImageChannelKurtosis ( int $channel = Imagick::CHANNEL_DEFAULT ) : array
getImageChannelMean ( int $channel ) : array
getImageChannelRange ( int $channel ) : array
getImageChannelStatistics ( ) : array
getImageClipMask ( ) : Imagick
getImageColormapColor ( int $index ) : ImagickPixel
getImageColors ( ) : int
getImageColorspace ( ) : int
getImageCompose ( ) : int
getImageCompression ( ) : int
getImageCompressionQuality ( ) : int
getImageDelay ( ) : int
getImageDepth ( ) : int
getImageDispose ( ) : int
getImageDistortion ( MagickWand $reference , int $metric ) : float
getImageExtrema ( ) : array
getImageFilename ( ) : string
getImageFormat ( ) : string
getImageGamma ( ) : float
getImageGeometry ( ) : array
getImageGravity ( ) : int
getImageGreenPrimary ( ) : array
getImageHeight ( ) : int
getImageHistogram ( ) : array
getImageIndex ( ) : int
getImageInterlaceScheme ( ) : int
getImageInterpolateMethod ( ) : int
getImageIterations ( ) : int
getImageLength ( ) : int
getImageMatte ( ) : bool
getImageMatteColor ( ) : ImagickPixel
public getImageMimeType ( ) : string
getImageOrientation ( ) : int
getImagePage ( ) : array
getImagePixelColor ( int $x , int $y ) : ImagickPixel
getImageProfile ( string $name ) : string
getImageProfiles ( string $pattern = "*" , bool $only_names = true ) : array
getImageProperties ( string $pattern = "*" , bool $only_names = true ) : array
getImageProperty ( string $name ) : string
getImageRedPrimary ( ) : array
getImageRegion ( int $width , int $height , int $x , int $y ) : Imagick
getImageRenderingIntent ( ) : int
getImageResolution ( ) : array
getImagesBlob ( ) : string
getImageScene ( ) : int
getImageSignature ( ) : string
getImageSize ( ) : int
getImageTicksPerSecond ( ) : int
getImageTotalInkDensity ( ) : float
getImageType ( ) : int
getImageUnits ( ) : int
getImageVirtualPixelMethod ( ) : int
getImageWhitePoint ( ) : array
getImageWidth ( ) : int
getInterlaceScheme ( ) : int
getIteratorIndex ( ) : int
getNumberImages ( ) : int
getOption ( string $key ) : string
getPackageName ( ) : string
getPage ( ) : array
getPixelIterator ( ) : ImagickPixelIterator
getPixelRegionIterator ( int $x , int $y , int $columns , int $rows ) : ImagickPixelIterator
getPointSize ( ) : float
public static getQuantum ( ) : int
getQuantumDepth ( ) : array
getQuantumRange ( ) : array
public static getRegistry ( string $key ) : string
getReleaseDate ( ) : string
getResource ( int $type ) : int
getResourceLimit ( int $type ) : int
getSamplingFactors ( ) : array
getSize ( ) : array
getSizeOffset ( ) : int
getVersion ( ) : array
public haldClutImage ( Imagick $clut , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
hasNextImage ( ) : bool
hasPreviousImage ( ) : bool
public identifyFormat ( string $embedText ) : string|false
identifyImage ( bool $appendRawOutput = false ) : array
implodeImage ( float $radius ) : bool
public importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels ) : bool
public inverseFourierTransformImage ( Imagick $complement , bool $magnitude ) : bool
labelImage ( string $label ) : bool
levelImage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Imagick::CHANNEL_ALL ) : bool
linearStretchImage ( float $blackPoint , float $whitePoint ) : bool
liquidRescaleImage ( int $width , int $height , float $delta_x , float $rigidity ) : bool
public static listRegistry ( ) : array
magnifyImage ( ) : bool
mapImage ( Imagick $map , bool $dither ) : bool
matteFloodfillImage ( float $alpha , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool
medianFilterImage ( float $radius ) : bool
mergeImageLayers ( int $layer_method ) : bool
minifyImage ( ) : bool
modulateImage ( float $brightness , float $saturation , float $hue ) : bool
montageImage ( ImagickDraw $draw , string $tile_geometry , string $thumbnail_geometry , int $mode , string $frame ) : Imagick
morphImages ( int $number_frames ) : Imagick
public morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
mosaicImages ( ) : Imagick
motionBlurImage ( float $radius , float $sigma , float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
negateImage ( bool $gray , int $channel = Imagick::CHANNEL_ALL ) : bool
newImage ( int $cols , int $rows , mixed $background , string $format = ? ) : bool
newPseudoImage ( int $columns , int $rows , string $pseudoString ) : bool
nextImage ( ) : bool
normalizeImage ( int $channel = Imagick::CHANNEL_ALL ) : bool
oilPaintImage ( float $radius ) : bool
opaquePaintImage ( mixed $target , mixed $fill , float $fuzz , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
optimizeImageLayers ( ) : bool
orderedPosterizeImage ( string $threshold_map , int $channel = Imagick::CHANNEL_ALL ) : bool
paintFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool
paintOpaqueImage ( mixed $target , mixed $fill , float $fuzz , int $channel = Imagick::CHANNEL_ALL ) : bool
paintTransparentImage ( mixed $target , float $alpha , float $fuzz ) : bool
pingImage ( string $filename ) : bool
pingImageBlob ( string $image ) : bool
pingImageFile ( resource $filehandle , string $fileName = ? ) : bool
polaroidImage ( ImagickDraw $properties , float $angle ) : bool
posterizeImage ( int $levels , bool $dither ) : bool
previewImages ( int $preview ) : bool
previousImage ( ) : bool
profileImage ( string $name , string $profile ) : bool
quantizeImage ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool
quantizeImages ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool
queryFontMetrics ( ImagickDraw $properties , string $text , bool $multiline = ? ) : array
queryFonts ( string $pattern = "*" ) : array
queryFormats ( string $pattern = "*" ) : array
radialBlurImage ( float $angle , int $channel = Imagick::CHANNEL_ALL ) : bool
raiseImage ( int $width , int $height , int $x , int $y , bool $raise ) : bool
randomThresholdImage ( float $low , float $high , int $channel = Imagick::CHANNEL_ALL ) : bool
readImage ( string $filename ) : bool
readImageBlob ( string $image , string $filename = ? ) : bool
readImageFile ( resource $filehandle , string $fileName = null ) : bool
public readImages ( array $filenames ) : bool
recolorImage ( array $matrix ) : bool
reduceNoiseImage ( float $radius ) : bool
public remapImage ( Imagick $replacement , int $DITHER ) : bool
removeImage ( ) : bool
removeImageProfile ( string $name ) : string
render ( ) : bool
resampleImage ( float $x_resolution , float $y_resolution , int $filter , float $blur ) : bool
resetImagePage ( string $page ) : bool
resizeImage ( int $columns , int $rows , int $filter , float $blur , bool $bestfit = false ) : bool
rollImage ( int $x , int $y ) : bool
rotateImage ( mixed $background , float $degrees ) : bool
public rotationalBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
roundCorners ( float $x_rounding , float $y_rounding , float $stroke_width = 10 , float $displace = 5 , float $size_correction = -6 ) : bool
sampleImage ( int $columns , int $rows ) : bool
scaleImage ( int $cols , int $rows , bool $bestfit = false ) : bool
public segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold , bool $verbose = false ) : bool
public selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $CHANNEL ) : void
separateImageChannel ( int $channel ) : bool
sepiaToneImage ( float $threshold ) : bool
setBackgroundColor ( mixed $background ) : bool
setColorspace ( int $COLORSPACE ) : bool
setCompression ( int $compression ) : bool
setCompressionQuality ( int $quality ) : bool
setFilename ( string $filename ) : bool
setFirstIterator ( ) : bool
setFont ( string $font ) : bool
setFormat ( string $format ) : bool
setGravity ( int $gravity ) : bool
setImage ( Imagick $replace ) : bool
setImageAlphaChannel ( int $mode ) : bool
setImageArtifact ( string $artifact , string $value ) : bool
public setImageAttribute ( string $key , string $value ) : void
setImageBackgroundColor ( mixed $background ) : bool
setImageBias ( float $bias ) : bool
public setImageBiasQuantum ( string $bias ) : void
setImageBluePrimary ( float $x , float $y ) : bool
setImageBorderColor ( mixed $border ) : bool
setImageChannelDepth ( int $channel , int $depth ) : bool
setImageClipMask ( Imagick $clip_mask ) : bool
setImageColormapColor ( int $index , ImagickPixel $color ) : bool
setImageColorspace ( int $colorspace ) : bool
setImageCompose ( int $compose ) : bool
setImageCompression ( int $compression ) : bool
setImageCompressionQuality ( int $quality ) : bool
setImageDelay ( int $delay ) : bool
setImageDepth ( int $depth ) : bool
setImageDispose ( int $dispose ) : bool
setImageExtent ( int $columns , int $rows ) : bool
setImageFilename ( string $filename ) : bool
setImageFormat ( string $format ) : bool
setImageGamma ( float $gamma ) : bool
setImageGravity ( int $gravity ) : bool
setImageGreenPrimary ( float $x , float $y ) : bool
setImageIndex ( int $index ) : bool
setImageInterlaceScheme ( int $interlace_scheme ) : bool
setImageInterpolateMethod ( int $method ) : bool
setImageIterations ( int $iterations ) : bool
setImageMatte ( bool $matte ) : bool
setImageMatteColor ( mixed $matte ) : bool
setImageOpacity ( float $opacity ) : bool
setImageOrientation ( int $orientation ) : bool
setImagePage ( int $width , int $height , int $x , int $y ) : bool
setImageProfile ( string $name , string $profile ) : bool
setImageProperty ( string $name , string $value ) : bool
setImageRedPrimary ( float $x , float $y ) : bool
setImageRenderingIntent ( int $rendering_intent ) : bool
setImageResolution ( float $x_resolution , float $y_resolution ) : bool
setImageScene ( int $scene ) : bool
setImageTicksPerSecond ( int $ticks_per_second ) : bool
setImageType ( int $image_type ) : bool
setImageUnits ( int $units ) : bool
setImageVirtualPixelMethod ( int $method ) : bool
setImageWhitePoint ( float $x , float $y ) : bool
setInterlaceScheme ( int $interlace_scheme ) : bool
setIteratorIndex ( int $index ) : bool
setLastIterator ( ) : bool
setOption ( string $key , string $value ) : bool
setPage ( int $width , int $height , int $x , int $y ) : bool
setPointSize ( float $point_size ) : bool
public setProgressMonitor ( callable $callback ) : void
public static setRegistry ( string $key , string $value ) : void
setResolution ( float $x_resolution , float $y_resolution ) : bool
setResourceLimit ( int $type , int $limit ) : bool
setSamplingFactors ( array $factors ) : bool
setSize ( int $columns , int $rows ) : bool
setSizeOffset ( int $columns , int $rows , int $offset ) : bool
setType ( int $image_type ) : bool
shadeImage ( bool $gray , float $azimuth , float $elevation ) : bool
shadowImage ( float $opacity , float $sigma , int $x , int $y ) : bool
sharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_ALL ) : bool
shaveImage ( int $columns , int $rows ) : bool
shearImage ( mixed $background , float $x_shear , float $y_shear ) : bool
sigmoidalContrastImage ( bool $sharpen , float $alpha , float $beta , int $channel = Imagick::CHANNEL_ALL ) : bool
sketchImage ( float $radius , float $sigma , float $angle ) : bool
public smushImages ( string $stack , string $offset ) : Imagick
solarizeImage ( int $threshold ) : bool
public sparseColorImage ( int $SPARSE_METHOD , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
spliceImage ( int $width , int $height , int $x , int $y ) : bool
spreadImage ( float $radius ) : bool
public statisticImage ( int $type , int $width , int $height , string $CHANNEL = Imagick::CHANNEL_DEFAULT ) : void
steganoImage ( Imagick $watermark_wand , int $offset ) : Imagick
stereoImage ( Imagick $offset_wand ) : bool
stripImage ( ) : bool
public subImageMatch ( Imagick $Imagick , array &$offset = ? , float &$similarity = ? ) : Imagick
swirlImage ( float $degrees ) : bool
textureImage ( Imagick $texture_wand ) : bool
thresholdImage ( float $threshold , int $channel = Imagick::CHANNEL_ALL ) : bool
thumbnailImage ( int $columns , int $rows , bool $bestfit = false , bool $fill = false ) : bool
tintImage ( mixed $tint , mixed $opacity ) : bool
__toString ( ) : string
transformImage ( string $crop , string $geometry ) : Imagick
transformImageColorspace ( int $colorspace ) : bool
transparentPaintImage ( mixed $target , float $alpha , float $fuzz , bool $invert ) : bool
transposeImage ( ) : bool
transverseImage ( ) : bool
trimImage ( float $fuzz ) : bool
uniqueImageColors ( ) : bool
unsharpMaskImage ( float $radius , float $sigma , float $amount , float $threshold , int $channel = Imagick::CHANNEL_ALL ) : bool
valid ( ) : bool
vignetteImage ( float $blackPoint , float $whitePoint , int $x , int $y ) : bool
waveImage ( float $amplitude , float $length ) : bool
whiteThresholdImage ( mixed $threshold ) : bool
writeImage ( string $filename = NULL ) : bool
writeImageFile ( resource $filehandle ) : bool
writeImages ( string $filename , bool $adjoin ) : bool
writeImagesFile ( resource $filehandle ) : bool
}

Métodos de imagen y métodos globales

La clase Imagick tiene la capacidad de mantener y operar con múltiples imágenes simultáneamente. Esto se consigue mediante una pila interna. Siempre hay un puntero interno que apunta a la imagen actual. Algunas funciones operan con todas las imágenes de la clase Imagick, pero la mayoría operan sólo con la imagen actual de la pila interna. Como convención, los nombres de los métodos pueden contener la palabra Image para denotar que afectan sólo a la imagen actual de la pila.

Métodos de la Clase

Ya que hay muchos métodos, aquí está una lista útil de métodos, algo reducida para su propósito general:

Métodos de la clase por propósito
Efectos de imagen | Métodos get | Métodos set | Lectura/escritura de imágenes | Otros
Imagick::adaptiveBlurImage() | Imagick::getCompression() | Imagick::setBackgroundColor() | Imagick::__construct() | Imagick::clear()
Imagick::adaptiveResizeImage() | Imagick::getFilename() | Imagick::setCompressionQuality() | Imagick::addImage() | Imagick::clone()
Imagick::adaptiveSharpenImage() | Imagick::getFormat() | Imagick::setCompression() | Imagick::appendImages() | Imagick::current()
Imagick::adaptiveThresholdImage() | Imagick::getImageBackgroundColor() | Imagick::setFilename() | Imagick::getFilename() | Imagick::destroy()
Imagick::addNoiseImage() | Imagick::getImageBlob() | Imagick::getImagesBlob() | Imagick::setFormat() | Imagick::getFormat()
Imagick::affinetransformimage() | Imagick::getImageBluePrimary() | Imagick::setImageBackgroundColor() | Imagick::getImageFilename() | Imagick::getHomeURL()
Imagick::annotateImage() | Imagick::getImageBorderColor() | Imagick::setFirstIterator() | Imagick::getImageFormat() | Imagick::commentImage()
Imagick::averageImages() | Imagick::getImageChannelDepth() | Imagick::setImageBias() | Imagick::getImage() | Imagick::getNumberImages()
Imagick::blackThresholdImage() | Imagick::getImageChannelDistortion() | Imagick::setImageBluePrimary() | Imagick::setImageFilename() | Imagick::getReleaseDate()
Imagick::blurImage() | Imagick::getImageChannelExtrema() | Imagick::setImageBorderColor() | Imagick::setImageFormat() | Imagick::getVersion()
Imagick::borderImage() | Imagick::getImageChannelMean() | Imagick::setImageChannelDepth() | Imagick::readImageFile() | Imagick::hasNextImage()
Imagick::charcoalImage() | Imagick::getImageChannelStatistics() | Imagick::setImageColormapColor() | Imagick::readImage() | Imagick::hasPreviousImage()
Imagick::chopImage() | Imagick::getImageColormapColor() | Imagick::setImageColorSpace() | Imagick::writeImages() | Imagick::labelImage()
Imagick::clipImage() | Imagick::getImageColorspace() | Imagick::setImageCompose() | Imagick::writeImage() | Imagick::newImage()
Imagick::clipPathImage() | Imagick::getImageColors() | Imagick::setImageCompression() |  | Imagick::newPseudoImage()
Imagick::coalesceImages() | Imagick::getImageCompose() | Imagick::setImageDelay() |  | Imagick::nextImage()
Imagick::colorFloodFillImage() | Imagick::getImageDelay() | Imagick::setImageDepth() |  | Imagick::pingImageBlob()
Imagick::colorizeImage() | Imagick::getImageDepth() | Imagick::setImageDispose() |  | Imagick::pingImageFile()
Imagick::combineImages() | Imagick::getImageDispose() | Imagick::setImageDispose() |  | Imagick::pingImage()
Imagick::compareImageChannels() | Imagick::getImageDistortion() | Imagick::setImageExtent() |  | Imagick::previousImage()
Imagick::compareImageLayers() | Imagick::getImageExtrema() | Imagick::setImageFilename() |  | Imagick::profileImage()
Imagick::compositeImage() | Imagick::getImageFilename() | Imagick::setImageFormat() |  | Imagick::queryFormats()
Imagick::contrastImage() | Imagick::getImageFormat() | Imagick::setImageGamma() |  | Imagick::removeImageProfile()
Imagick::contrastStretchImage() | Imagick::getImageGamma() | Imagick::setImageGreenPrimary() |  | Imagick::removeImage()
Imagick::convolveImage() | Imagick::getImageGeometry() | Imagick::setImageIndex() |  | Imagick::setFirstIterator()
Imagick::cropImage() | Imagick::getImageGreenPrimary() | Imagick::setImageInterpolateMethod() |  | Imagick::setImageIndex()
Imagick::cycleColormapImage() | Imagick::getImageHeight() | Imagick::setImageIterations() |  | Imagick::valid()
Imagick::deconstructImages() | Imagick::getImageHistogram() | Imagick::setImageMatteColor() |  | Imagick::getCopyright()
Imagick::drawImage() | Imagick::getImageIndex() | Imagick::setImageMatte() |  |
Imagick::edgeImage() | Imagick::getImageInterlaceScheme() | Imagick::setImagePage() |  |
Imagick::embossImage() | Imagick::getImageInterpolateMethod() | Imagick::setImageProfile() |  |
Imagick::enhanceImage() | Imagick::getImageIterations() | Imagick::setImageProperty() |  |
Imagick::equalizeImage() | Imagick::getImageMatteColor() | Imagick::setImageRedPrimary() |  |
Imagick::evaluateImage() | Imagick::getImageMatte() | Imagick::setImageRenderingIntent() |  |
Imagick::flattenImages() | Imagick::getImagePage() | Imagick::setImageResolution() |  |
Imagick::flipImage() | Imagick::getImagePixelColor() | Imagick::setImageScene() |  |
Imagick::flopImage() | Imagick::getImageProfile() | Imagick::setImageTicksPerSecond() |  |
 | Imagick::getImageProperty() | Imagick::setImageType() |  |
Imagick::fxImage() | Imagick::getImageRedPrimary() | Imagick::setImageUnits() |  |
Imagick::gammaImage() | Imagick::getImageRegion() | Imagick::setImageVirtualPixelMethod() |  |
Imagick::gaussianBlurImage() | Imagick::getImageRenderingIntent() | Imagick::setImageWhitepoint() |  |
Imagick::implodeImage() | Imagick::getImageResolution() | Imagick::setInterlaceScheme() |  |
Imagick::levelImage() | Imagick::getImageScene() | Imagick::setOption() |  |
Imagick::linearStretchImage() | Imagick::getImageSignature() | Imagick::setPage() |  |
Imagick::magnifyImage() | Imagick::getImageTicksPerSecond() | Imagick::setResolution() |  |
Imagick::matteFloodFillImage() | Imagick::getImageTotalInkDensity() | Imagick::setResourceLimit() |  |
Imagick::medianFilterImage() | Imagick::getImageType() | Imagick::setSamplingFactors() |  |
Imagick::minifyImage() | Imagick::getImageUnits() | Imagick::setSizeOffset() |  |
Imagick::modulateImage() | Imagick::getImageVirtualPixelMethod() | Imagick::setSize() |  |
Imagick::montageImage() | Imagick::getImageWhitepoint() | Imagick::setType() |  |
Imagick::morphImages() | Imagick::getImageWidth() |  |  |
Imagick::mosaicImages() | Imagick::getImage() |  |  |
Imagick::motionBlurImage() | Imagick::getInterlaceScheme() |  |  |
Imagick::negateImage() | Imagick::getNumberImages() |  |  |
Imagick::normalizeImage() | Imagick::getOption() |  |  |
Imagick::oilPaintImage() | Imagick::getPackageName() |  |  |
Imagick::optimizeImageLayers() | Imagick::getPage() |  |  |
Imagick::paintOpaqueImage() | Imagick::getPixelIterator() |  |  |
Imagick::paintTransparentImage() | Imagick::getPixelRegionIterator() |  |  |
Imagick::posterizeImage() | Imagick::getQuantumDepth() |  |  |
Imagick::radialBlurImage() | Imagick::getQuantumRange() |  |  |
Imagick::raiseImage() | Imagick::getResourceLimit() |  |  |
Imagick::randomThresholdImage() | Imagick::getResource() |  |  |
Imagick::reduceNoiseImage() | Imagick::getSamplingFactors() |  |  |
Imagick::render() | Imagick::getSizeOffset() |  |  |
Imagick::resampleImage() | Imagick::getSize() |  |  |
Imagick::resizeImage() | Imagick::identifyImage() |  |  |
Imagick::rollImage() | Imagick::getImageSize() |  |  |
Imagick::rotateImage() |  |  |  |
Imagick::sampleImage() |  |  |  |
Imagick::scaleImage() |  |  |  |
Imagick::separateImageChannel() |  |  |  |
Imagick::sepiaToneImage() |  |  |  |
Imagick::shadeImage() |  |  |  |
Imagick::shadowImage() |  |  |  |
Imagick::sharpenImage() |  |  |  |
Imagick::shaveImage() |  |  |  |
Imagick::shearImage() |  |  |  |
Imagick::sigmoidalContrastImage() |  |  |  |
Imagick::sketchImage() |  |  |  |
Imagick::solarizeImage() |  |  |  |
Imagick::spliceImage() |  |  |  |
Imagick::spreadImage() |  |  |  |
Imagick::steganoImage() |  |  |  |
Imagick::stereoImage() |  |  |  |
Imagick::stripImage() |  |  |  |
Imagick::swirlImage() |  |  |  |
Imagick::textureImage() |  |  |  |
Imagick::thresholdImage() |  |  |  |
Imagick::thumbnailImage() |  |  |  |
Imagick::tintImage() |  |  |  |
Imagick::transverseImage() |  |  |  |
Imagick::trimImage() |  |  |  |
Imagick::uniqueImageColors() |  |  |  |
Imagick::unsharpMaskImage() |  |  |  |
Imagick::vignetteImage() |  |  |  |
Imagick::waveImage() |  |  |  |
Imagick::whiteThresholdImage() |  |  |  |

Tabla de contenidos

  • Imagick::adaptiveBlurImage — Añade un filtro de borrosidad adaptativo a la imagen
  • Imagick::adaptiveResizeImage — Redimensiona una imagen adaptativamente con información dependiente de la triangulación
  • Imagick::adaptiveSharpenImage — Afila la imagen adaptativamente
  • Imagick::adaptiveThresholdImage — Selecciona un umbral para cada píxel basado en un rango de intensidad
  • Imagick::addImage — Añade una nueva imagen a la lista de imágenes del objeto Imagick
  • Imagick::addNoiseImage — Añade ruido aleatorio a la imagen
  • Imagick::affineTransformImage — Transforma una imagen
  • Imagick::animateImages — Anima una imagen o imágenes
  • Imagick::annotateImage — Anota una imagen con texto
  • Imagick::appendImages — Añade un conjunto de imágenes
  • Imagick::autoLevelImage — Description
  • Imagick::averageImages — Calcula la media de un conjunto de imágenes
  • Imagick::blackThresholdImage — Fuerza a todos los píxeles bajo un umbral a ser negros
  • Imagick::blueShiftImage — Description
  • Imagick::blurImage — Añade un filtro de borrosidad a la imagen
  • Imagick::borderImage — Rodea la imagen con un borde
  • Imagick::brightnessContrastImage — Description
  • Imagick::charcoalImage — Simula un dibujo a carboncillo
  • Imagick::chopImage — Borra una región de una imagen y la recorta
  • Imagick::clampImage — Description
  • Imagick::clear — Borra todos los recursos asociados con un objeto Imagick
  • Imagick::clipImage — Recorta a lo largo del primer trazado desde un perfil 8BIM
  • Imagick::clipImagePath — Description
  • Imagick::clipPathImage — Recorta a lo largo de trazados nominados desde un perfil 8BIM
  • Imagick::clone — Hace una copia exacta de un objeto Imagick
  • Imagick::clutImage — Reemplaza los colores de una imagen
  • Imagick::coalesceImages — Compone un conjunto de imágenes
  • Imagick::colorFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
  • Imagick::colorizeImage — Mezcla el color de relleno con la imagen
  • Imagick::colorMatrixImage — Description
  • Imagick::combineImages — Combina una o más imágenes en una sóla imagen
  • Imagick::commentImage — Añade un comentario a la imagen
  • Imagick::compareImageChannels — Devuelve la diferencia entre una o más imágenes
  • Imagick::compareImageLayers — Devuelve la región circundante máxima entre imágenes
  • Imagick::compareImages — Compara una imagen con otra reconstruida
  • Imagick::compositeImage — Compone una imagen en otra
  • Imagick::__construct — El constructor Imagick
  • Imagick::contrastImage — Cambia el contraste de una imagen
  • Imagick::contrastStretchImage — Mejora el contraste de una imagen en color
  • Imagick::convolveImage — Aplica una semilla de convolución a medida a la imagen
  • Imagick::count — Get the number of images
  • Imagick::cropImage — Extrae una región de la imagen
  • Imagick::cropThumbnailImage — Crea una miniatura recortada
  • Imagick::current — Devuelve una referencia del objeto Imagick actual
  • Imagick::cycleColormapImage — Desplaza el mapa de colores de una imagen
  • Imagick::decipherImage — Descifra una imagen
  • Imagick::deconstructImages — Devuelve ciertas diferencias de píxeles entre imágenes
  • Imagick::deleteImageArtifact — Borra un artefacto de imagen
  • Imagick::deleteImageProperty — Description
  • Imagick::deskewImage — Elimina la torción de la imagen
  • Imagick::despeckleImage — Reduce el ruido granular de una imagen
  • Imagick::destroy — Destruye un objeto Imagick
  • Imagick::displayImage — Muestra una imagen
  • Imagick::displayImages — Muestra una imagen o una secuencia de imágenes
  • Imagick::distortImage — Deforma una imagen utilizando varios métodos de distorsión
  • Imagick::drawImage — Renderiza el objeto ImagickDraw a la imagen actual
  • Imagick::edgeImage — Mejora los bordes de la imagen
  • Imagick::embossImage — Devuelve una imagen en escala de grises con un efecto tridimensional
  • Imagick::encipherImage — Cifra una imagen
  • Imagick::enhanceImage — Mejora la calidad de una imagen con ruido
  • Imagick::equalizeImage — Ecualiza el histograma de la imagen
  • Imagick::evaluateImage — Aplica una expresión a una imagen
  • Imagick::exportImagePixels — Exporta píxeles de imagen en bruto
  • Imagick::extentImage — Establecer el tamaño de la imagen
  • Imagick::filter — Description
  • Imagick::flattenImages — Fusiona una secuencia de imágenes
  • Imagick::flipImage — Crea una imagen espejo vertical
  • Imagick::floodFillPaintImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
  • Imagick::flopImage — Crea una imagen espejo horizontal
  • Imagick::forwardFourierTransformImage — Description
  • Imagick::frameImage — Añade un borde tridimensional simulado
  • Imagick::functionImage — Aplica una función a la imagen
  • Imagick::fxImage — Evalúa una expresión por cada píxel de la imagen
  • Imagick::gammaImage — Corrección gamma de una imagen
  • Imagick::gaussianBlurImage — Hace borrosa una imagen
  • Imagick::getColorspace — Obtiene el espacio de color
  • Imagick::getCompression — Obtiene el tipo de compresión del objeto
  • Imagick::getCompressionQuality — Obtiene la calidad de compresión del objeto
  • Imagick::getCopyright — Devuelve el copyright de la API ImageMagick como una cadena
  • Imagick::getFilename — El nombre de archivo asociado a una secuencia de imágenes
  • Imagick::getFont — Obtiene la fuente
  • Imagick::getFormat — Devuelve el formato de un objeto Imagick
  • Imagick::getGravity — Obtiene la gravedad
  • Imagick::getHomeURL — Devuelve la URL de inicio de ImageMagick
  • Imagick::getImage — Devuelve un nuevo objeto Imagick
  • Imagick::getImageAlphaChannel — Obtiene el canal alfa de una imagen
  • Imagick::getImageArtifact — Obtener el artefacto de imagen
  • Imagick::getImageAttribute — Description
  • Imagick::getImageBackgroundColor — Devuelve el color de fondo de la imagen
  • Imagick::getImageBlob — Devuelve la secuencia de imágenes como un valor de tipo blob
  • Imagick::getImageBluePrimary — Devuelve el punto primario azul de la cromaticidad
  • Imagick::getImageBorderColor — Devuelve el color del borde de la imagen
  • Imagick::getImageChannelDepth — Obtiene la profundidad de un canal de imagen en particular
  • Imagick::getImageChannelDistortion — Compara los canales de imagen de una imagen con una imagen reconstruida
  • Imagick::getImageChannelDistortions — Obtiene las distorsiones del canal
  • Imagick::getImageChannelExtrema — Obtiene los extremos de uno o más canales de imagen
  • Imagick::getImageChannelKurtosis — Obtiene la curtosis y la asimetría estadística de un canal específico
  • Imagick::getImageChannelMean — Obtiene la media y la desviación estándar
  • Imagick::getImageChannelRange — Obtiene el rango del canal
  • Imagick::getImageChannelStatistics — Devuelve las estadísticas de cada canal de la imagen
  • Imagick::getImageClipMask — Obtiene la máscara de recorte de la imagen
  • Imagick::getImageColormapColor — Devuelve el color del índice del mapa de colores especficado
  • Imagick::getImageColors — Obtiene el número de colores únicos de la imagen
  • Imagick::getImageColorspace — Obtiene el espacio de color de la imagen
  • Imagick::getImageCompose — Devuelve el operador de composición asociado a la imagen
  • Imagick::getImageCompression — Obtiene el tipo de compresión de la imagen actual
  • Imagick::getImageCompressionQuality — Obtiene la calidad de compresión de la imagen actual
  • Imagick::getImageDelay — Obtiene el retraso de la imagen
  • Imagick::getImageDepth — Obtiene la profundidad de la imagen
  • Imagick::getImageDispose — Obtiene el método de disposición de la imagen
  • Imagick::getImageDistortion — Compara una imagen con una imagen reconstruida
  • Imagick::getImageExtrema — Obtiene los extremos de la imagen
  • Imagick::getImageFilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia
  • Imagick::getImageFormat — Devuelve el formato de una imagen en particular de una secuencia
  • Imagick::getImageGamma — Obtiene el valor gamma de la imagen
  • Imagick::getImageGeometry — Obtiene el ancho y el alto como un array asociativo
  • Imagick::getImageGravity — Obtiene la gravedad de la imagen
  • Imagick::getImageGreenPrimary — Devuelve el punto primario verde de la cromaticidad
  • Imagick::getImageHeight — Devuelve el alto de la imagen
  • Imagick::getImageHistogram — Obtiene el histograma de la imagen
  • Imagick::getImageIndex — Obtiene el índice de la imagen activa actual
  • Imagick::getImageInterlaceScheme — Obtiene la combinación de entrelazado de la imagen
  • Imagick::getImageInterpolateMethod — Devuelve el método de interpolación
  • Imagick::getImageIterations — Obtiene las iteraciones de la imagen
  • Imagick::getImageLength — Devuelve la longitud de la imagen en bytes
  • Imagick::getImageMatte — Devuelve si la imagen tiene un canal mate
  • Imagick::getImageMatteColor — Devuelve el color mate de la imagen
  • Imagick::getImageMimeType — Description
  • Imagick::getImageOrientation — Obtiene la orientación de la imagen
  • Imagick::getImagePage — Devuelve la geometría de la página
  • Imagick::getImagePixelColor — Devuelve el color del píxel especificado
  • Imagick::getImageProfile — Devuelve el perfil nominado de la imagen
  • Imagick::getImageProfiles — Devuelve los perfiles de la imagen
  • Imagick::getImageProperties — Devuelve las propiedades de la imagen
  • Imagick::getImageProperty — Devuelve la propiedad nominada de la imagen
  • Imagick::getImageRedPrimary — Devuelve el punto primario rojo de la cromaticidad
  • Imagick::getImageRegion — Extrae una región de la imagen
  • Imagick::getImageRenderingIntent — Obtiene el propósito de renderización de la imagen
  • Imagick::getImageResolution — Obtiene la resolución X e Y de la imagen
  • Imagick::getImagesBlob — Devuelve todas las secuencias de imágenes como un blob
  • Imagick::getImageScene — Obtiene la escena de la imagen
  • Imagick::getImageSignature — Genera un resumen de un mensaje SHA-256
  • Imagick::getImageSize — Devuelve la longitud de la imagen en bytes
  • Imagick::getImageTicksPerSecond — Obtiene los pulsos por segundo de la imagen
  • Imagick::getImageTotalInkDensity — Obtiene la densidad de tinta total de la imagen
  • Imagick::getImageType — Obtiene el tipo de imagen potencial
  • Imagick::getImageUnits — Obtiene las unidades de resolución de la imagen
  • Imagick::getImageVirtualPixelMethod — Devuelve el método de píxel virtual
  • Imagick::getImageWhitePoint — Devuelve el punto blanco de la cromaticidad
  • Imagick::getImageWidth — Devuelve el ancho de la imagen
  • Imagick::getInterlaceScheme — Obtiene la combinación de entrelazado de un objeto
  • Imagick::getIteratorIndex — Obtiene el índice de la imagen activa actual
  • Imagick::getNumberImages — Devuelve el número de imágenes del objeto
  • Imagick::getOption — Devuelve un valor asociado con la clave especificada
  • Imagick::getPackageName — Devuelve el nombre del paquete de ImageMagick
  • Imagick::getPage — Devuelve la geometría de la página
  • Imagick::getPixelIterator — Devuelve un objeto MagickPixelIterator
  • Imagick::getPixelRegionIterator — Obtinene un objeto ImagickPixelIterator de una sección de imagen
  • Imagick::getPointSize — Obtiene el tamaño de punto
  • Imagick::getQuantum — Description
  • Imagick::getQuantumDepth — Obtiene la profundidad de la cuantía
  • Imagick::getQuantumRange — Devuelve el rango de cuantía de Imagick
  • Imagick::getRegistry — Description
  • Imagick::getReleaseDate — Devuelve la fecha de distribución de ImageMagick
  • Imagick::getResource — Devuelve el uso de memoria del recurso especificado
  • Imagick::getResourceLimit — Devuelve el límite del recurso especificado
  • Imagick::getSamplingFactors — Obtiene el factor de muestreo horizontal y vertical
  • Imagick::getSize — Devuelve el tamaño asociado con el objeto Imagick
  • Imagick::getSizeOffset — Devuelve el índice de tamaño
  • Imagick::getVersion — Devuelve la versión de la API ImageMagick
  • Imagick::haldClutImage — Reemplaza los colores de la imagen
  • Imagick::hasNextImage — Comprueba si el objeto tiene más imágenes
  • Imagick::hasPreviousImage — Verifica si el objeto tiene una imagen previa
  • Imagick::identifyFormat — Description
  • Imagick::identifyImage — Identifica una imagen y obtiene sus atributos
  • Imagick::implodeImage — Crea una nueva imagen como una copia
  • Imagick::importImagePixels — Importa los píxeles de una imagen
  • Imagick::inverseFourierTransformImage — Description
  • Imagick::labelImage — Añade una etiqueta a una imagen
  • Imagick::levelImage — Ajusta los niveles de la imagen
  • Imagick::linearStretchImage — Estrecha con saturación la intensidad de la imagen
  • Imagick::liquidRescaleImage — Anima una imagen o imágenes
  • Imagick::listRegistry — Description
  • Imagick::magnifyImage — Escala una imagen x2 proporcionalmente
  • Imagick::mapImage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
  • Imagick::matteFloodfillImage — Cambia el valor de transparencia de un color
  • Imagick::medianFilterImage — Aplica un filtro digital
  • Imagick::mergeImageLayers — Fusiona las capas de una imagen
  • Imagick::minifyImage — Escala una imagen proporcionalmente a la mitad de su tamaño
  • Imagick::modulateImage — Controla el brillo, la saturación y el tono
  • Imagick::montageImage — Crea una imagen compuesta
  • Imagick::morphImages — Metamorfosea un conjunto de imágenes
  • Imagick::morphology — Description
  • Imagick::mosaicImages — Forma un mosaico de imágenes
  • Imagick::motionBlurImage — Simula borrosidad en movimiento
  • Imagick::negateImage — Invierte los colores en la imagen de referencia
  • Imagick::newImage — Crea una nueva imagen
  • Imagick::newPseudoImage — Crea una nueva imagen
  • Imagick::nextImage — Se mueve a la siguiente imagen
  • Imagick::normalizeImage — Mejora el contraste de una imagen a color
  • Imagick::oilPaintImage — Simula una pintura al óleo
  • Imagick::opaquePaintImage — Cambia el color de cualquier píxel que coincida con el objetivo
  • Imagick::optimizeImageLayers — Elimina porciones repetidas de imágenes para optimizarlas
  • Imagick::orderedPosterizeImage — Realiza un entramado ordenado
  • Imagick::paintFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo
  • Imagick::paintOpaqueImage — Cambia cualquier píxel que coincida con el color
  • Imagick::paintTransparentImage — Cambia cualquier píxel que coincida con el color definido para el relleno
  • Imagick::pingImage — Trae los atributos básicos de una imagen
  • Imagick::pingImageBlob — Traer los atributos rápidamente
  • Imagick::pingImageFile — Obtener los atrbutos básicos de la imagen de una manera liviana
  • Imagick::polaroidImage — Simula una fotografía Polaroid
  • Imagick::posterizeImage — Reduce la imagen a un número limitado de niveles de color
  • Imagick::previewImages — Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen
  • Imagick::previousImage — Se mueve a la imagen previa del objeto
  • Imagick::profileImage — Añade o elimina un perfil de una imagen
  • Imagick::quantizeImage — Analiza los colores dentro de una imagen de referencia
  • Imagick::quantizeImages — Analiza los colores dentro de una secuencia de imágenes
  • Imagick::queryFontMetrics — Devuelve una matriz que representa las métricas de la fuente
  • Imagick::queryFonts — Devuelve las fuentes configuradas
  • Imagick::queryFormats — Devuelve los formatos soportados por Imagick
  • Imagick::radialBlurImage — Hace borrosa de forma radial una imagen
  • Imagick::raiseImage — Crea un efecto de botón en 3D simulado
  • Imagick::randomThresholdImage — Crea una imagen de alto contraste y dos colores
  • Imagick::readImage — Lee una imagen desde un nombre de fichero
  • Imagick::readImageBlob — Lee una imagen desde un string binario
  • Imagick::readImageFile — Lee una imagen desde un gestor de fichero abierto
  • Imagick::readimages — Description
  • Imagick::recolorImage — Re-colorea una imagen
  • Imagick::reduceNoiseImage — Suaviza los contornos de una imagen
  • Imagick::remapImage — Re-mapea los colores de una imagen
  • Imagick::removeImage — Quita una imagen de la lista de imágenes
  • Imagick::removeImageProfile — Elimina el perfil nominado de la imagen y lo devuelve
  • Imagick::render — Renderiza todos los comandos de dibujo precedentes
  • Imagick::resampleImage — Remuestrea la imagen a la resolución deseada
  • Imagick::resetImagePage — Reinicia una página de imagen
  • Imagick::resizeImage — Escala una imagen
  • Imagick::rollImage — Compensa una imagen
  • Imagick::rotateImage — Rota una imagen
  • Imagick::rotationalBlurImage — Description
  • Imagick::roundCorners — Redondea las esquinas de una imagen
  • Imagick::sampleImage — Escala una imagen con un muestreo de píxeles
  • Imagick::scaleImage — Escala el tamaño de una imagen
  • Imagick::segmentImage — Segmenta una imagen
  • Imagick::selectiveBlurImage — Description
  • Imagick::separateImageChannel — Separa un canal de la imagen
  • Imagick::sepiaToneImage — Pone una imagen en tono sepia
  • Imagick::setBackgroundColor — Establece el color de fondo por omisión del objeto
  • Imagick::setColorspace — Establecer el espacio de color
  • Imagick::setCompression — Establece el tipo de compresión predeterminado del objeto
  • Imagick::setCompressionQuality — Establece la calidad de compresión predeterminda del objeto
  • Imagick::setFilename — Establece el nombre de archivo antes de que se lea o escriba una imagen
  • Imagick::setFirstIterator — Establece el iterador Imagick para la primera imagen
  • Imagick::setFont — Establece el tipo de letra
  • Imagick::setFormat — Establece el formato del objeto Imagick
  • Imagick::setGravity — Establece la gravedad
  • Imagick::setImage — Reemplaza una imagen en el objeto
  • Imagick::setImageAlphaChannel — Establece el canal alfa de la imagen
  • Imagick::setImageArtifact — Establecer un artefacto de imagen
  • Imagick::setImageAttribute — Description
  • Imagick::setImageBackgroundColor — Establece el color de fondo de la imagen
  • Imagick::setImageBias — Establece el sesgo de la imagen para cualquier método que convolucione una imagen
  • Imagick::setImageBiasQuantum — Description
  • Imagick::setImageBluePrimary — Establece el punto primario azul de la cromaticidad de la imagen
  • Imagick::setImageBorderColor — Establece el color de borde de la imagen
  • Imagick::setImageChannelDepth — Establece la profundidad de una canal de imagen en particular
  • Imagick::setImageClipMask — Establece la máscara de recorte de una imagen
  • Imagick::setImageColormapColor — Establece el color de un índice de mapa de color especificado
  • Imagick::setImageColorspace — Establece el espacio de color de una imagen
  • Imagick::setImageCompose — Establece el operador de composción de una imagen
  • Imagick::setImageCompression — Establece la compresión de una imagen
  • Imagick::setImageCompressionQuality — Establece la calidad de compresión de una imagen
  • Imagick::setImageDelay — Establece el retardo de una imagen
  • Imagick::setImageDepth — Establece la profundidad de una imagen
  • Imagick::setImageDispose — Establece el método de disposición de una imagen
  • Imagick::setImageExtent — Establece el tamaño de una imagen
  • Imagick::setImageFilename — Establece el nombre de archivo de una imagen en particular
  • Imagick::setImageFormat — Establece el formato de una imagen en particular
  • Imagick::setImageGamma — Establece el valor gamma de la imagen
  • Imagick::setImageGravity — Establece la gravedad de la imagen
  • Imagick::setImageGreenPrimary — Establece el punto primario verde de la cromaticidad de la imagen
  • Imagick::setImageIndex — Establece la posición del iterador
  • Imagick::setImageInterlaceScheme — Establece la compresión de la imagen
  • Imagick::setImageInterpolateMethod — Establece el método de interpolación de píxeles
  • Imagick::setImageIterations — Establece las iteraciones de una imagen
  • Imagick::setImageMatte — Establece el canal mate de la imagen
  • Imagick::setImageMatteColor — Establece el color mate de la imagen
  • Imagick::setImageOpacity — Establece el nivel de opacidad de la imagen
  • Imagick::setImageOrientation — Establece la orientación de la imagen
  • Imagick::setImagePage — Establece la geometría de la página de la imagen
  • Imagick::setImageProfile — Añade un perfil nominado al objeto Imagick
  • Imagick::setImageProperty — Establece una propiedad de la imagen
  • Imagick::setImageRedPrimary — Establece el punto primario rojo de la cromaticidad de la imagen
  • Imagick::setImageRenderingIntent — Establece el propósito de renderización de la imagen
  • Imagick::setImageResolution — Establece la resolución de la imagen
  • Imagick::setImageScene — Establece la escena de la imagen
  • Imagick::setImageTicksPerSecond — Establece los ticks por segundo de la imagen
  • Imagick::setImageType — Establece el tipo de imagen
  • Imagick::setImageUnits — Establece las unidades de resolución de la imagen
  • Imagick::setImageVirtualPixelMethod — Establece el método de píxel virtual de la imagen
  • Imagick::setImageWhitePoint — Establece el punto blanco de cromaticidad de la imagen
  • Imagick::setInterlaceScheme — Establece la compresión de la imagen
  • Imagick::setIteratorIndex — Establece la posición del iterador
  • Imagick::setLastIterator — Establece el iterador de Imagick a la última imagen
  • Imagick::setOption — Establece una opción
  • Imagick::setPage — Establece la geometría de página del objeto Imagick
  • Imagick::setPointSize — Establece el tamaño del punto
  • Imagick::setProgressMonitor — Description
  • Imagick::setRegistry — Description
  • Imagick::setResolution — Establece la resolución de la imagen
  • Imagick::setResourceLimit — Establece el límite de un recurso en particular en megabytes
  • Imagick::setSamplingFactors — Establece los factores de muestreo de la imagen
  • Imagick::setSize — Establece el tamaño del objeto Imagick
  • Imagick::setSizeOffset — Establece el tamaño y el índice del objeto Imagick
  • Imagick::setType — Establece el atributo tipo de imagen
  • Imagick::shadeImage — Crea un efecto en 3D
  • Imagick::shadowImage — Simula una sombra de imagen
  • Imagick::sharpenImage — Afila una imagen
  • Imagick::shaveImage — Recorta píxeles de los extremos de la imagen
  • Imagick::shearImage — Crea un paralelogramo
  • Imagick::sigmoidalContrastImage — Ajusta el contraste de una imagen
  • Imagick::sketchImage — Simula el bosquejo de un lapiz
  • Imagick::smushImages — Description
  • Imagick::solarizeImage — Aplica un efecto de solarización a la imagen
  • Imagick::sparseColorImage — Interpola colores
  • Imagick::spliceImage — Une un color sólido en la imagen
  • Imagick::spreadImage — Despalza aleatoriamente cada píxel en un bloque
  • Imagick::statisticImage — Description
  • Imagick::steganoImage — Oculta una marca de agua digital dentro de la imagen
  • Imagick::stereoImage — Compone dos imágenes
  • Imagick::stripImage — Elimina todos los perfiles y comentarios de una imagen
  • Imagick::subImageMatch — Description
  • Imagick::swirlImage — Arremolina los píxeles desde el centro de la imagen
  • Imagick::textureImage — Reviste repetidamente la textura de la imagen
  • Imagick::thresholdImage — Cambia el valor de píexeles individuales basdos en un umbral
  • Imagick::thumbnailImage — Cambia el tamaño de una imagen
  • Imagick::tintImage — Aplica un vector de color a cada píxel en la imagen
  • Imagick::__toString — Devuelve la imagen como un string
  • Imagick::transformImage — Método conveniente para establecer el tamaño del recorte y la geometría de la imagen
  • Imagick::transformImageColorspace — Transforma una imagen a un nuevo espacio de color
  • Imagick::transparentPaintImage — Pinta píxeles transparentes
  • Imagick::transposeImage — Crea una imagen espejo vertical
  • Imagick::transverseImage — Crea una imagen espejo horizontal
  • Imagick::trimImage — Elimina los extremos de la imagen
  • Imagick::uniqueImageColors — Desecha todos los colores de los píxeles excepto uno
  • Imagick::unsharpMaskImage — Afila una imagen
  • Imagick::valid — Comprueba si el elemento actual es válido
  • Imagick::vignetteImage — Añade un filtro de viñeta a la imagen
  • Imagick::waveImage — Aplica un filtro de onda a la imagen
  • Imagick::whiteThresholdImage — Fuerza a todos los píxeles por encima del umbral a ser blancos
  • Imagick::writeImage — Escribe una imagen al nombre de fichero especificado
  • Imagick::writeImageFile — Escribe una imagen a un gestor de archivo
  • Imagick::writeImages — Escribe una imagen o secuencia de imágenes
  • Imagick::writeImagesFile — Escribe fotogramas al gestor de archivo


Añade un filtro de borrosidad adaptativo a la imagen

  • « Imagick
  • Imagick::adaptiveResizeImage »
  • PHP Manual
  • Imagick
  • Añade un filtro de borrosidad adaptativo a la imagen

Imagick::adaptiveBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveBlurImage — Añade un filtro de borrosidad adaptativo a la imagen

Descripción

Imagick::adaptiveBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Añade un filtro de borrosidad adaptativo a la imagen. La intensidad de una borrosidad adaptativa depende de si se disminuye dramáticamente en el borde de la imagen, mientras que una borrodidad estándar es uniforme en toda la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central. Proporcione un valor de 0 y el radio será elegido auto-mágicaente.

sigma

La desviación estándar gaussiana, en píxeles.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::adaptiveBlurImage():

Aplicar borrosidad adaptativa a una imagen, después mostrarla en el navegador.

<?php

header('Content-type: image/jpeg');

$imagen = new Imagick('test.jpg');

$imagen->adaptiveBlurImage(5,3);
echo $imagen;

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Usar Imagick::adaptiveBlurImage()

Ver también

  • Imagick::blurImage() - Añade un filtro de borrosidad a la imagen
  • Imagick::motionBlurImage() - Simula borrosidad en movimiento
  • Imagick::radialBlurImage() - Hace borrosa de forma radial una imagen


Redimensiona una imagen adaptativamente con información dependiente de la triangulación

  • « Imagick::adaptiveBlurImage
  • Imagick::adaptiveSharpenImage »
  • PHP Manual
  • Imagick
  • Redimensiona una imagen adaptativamente con información dependiente de la triangulación

Imagick::adaptiveResizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveResizeImage — Redimensiona una imagen adaptativamente con información dependiente de la triangulación

Descripción

Imagick::adaptiveResizeImage ( int $columns , int $rows , bool $bestfit = false ) : bool

Redimensiona una imagen adaptativamente con información dependiente de la triangulación. Evita la borrosidad a través de cambios de color bruscos. Muy útil cuando se usa para encoger ligeramente imágenes a un "tamaño web" ligeramente más pequeño; puede que no tenga una buena apariencia cuando una imagen a tamaño completo se redimensiona adaptativamente a una miniatura. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Nota: La conducta del parámetro bestfit cambió en Imagick 3.0.0. Antes de esta versión dar la dimensión de 400x400 a una imagen de 200x150 debería no tener efecto. En Imagick 3.0.0 y superiores la imagen sería llevada al tamaño de 400x300 ya que este es el "mejor ajuste" para las dimensiones dadas. Si el parámetro bestfit es utilizado, se debe indicar tanto el ancho como el alto.

Parámetros

columns

El número de columnas en la imagen escalada.

rows

El número de filas en la imagen escalada.

bestfit

Si ajustar la imagen dentro de una caja limitada.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Añadido el parámetro opcional de ajuste.
2.1.0 | Este método ahora soporta escalas proporcionales. Pase cero como parámetro para escalar proporcionalmente.

Ejemplos

Ejemplo #1 Usar Imagick::adaptiveResizeImage()

Redimensiona una imagen al tamaño estándar para la web. Este método trabaja mejor cuando se redimensiona a un tamaño sólo ligeramente menor que el tamaño de la imagen previa.

<?php
header('Content-type: image/jpeg');

$imagen = new Imagick('image.jpg');
$image->adaptiveResizeImage(1024,768);

echo $imagen;
?>

Ver también

  • Imagick::chopImage() - Borra una región de una imagen y la recorta
  • Imagick::cropImage() - Extrae una región de la imagen
  • Imagick::magnifyImage() - Escala una imagen x2 proporcionalmente
  • Imagick::minifyImage() - Escala una imagen proporcionalmente a la mitad de su tamaño
  • Imagick::resizeImage() - Escala una imagen
  • Imagick::scaleImage() - Escala el tamaño de una imagen
  • Imagick::shaveImage() - Recorta píxeles de los extremos de la imagen
  • Imagick::thumbnailImage() - Cambia el tamaño de una imagen
  • Imagick::trimImage() - Elimina los extremos de la imagen


Afila la imagen adaptativamente

  • « Imagick::adaptiveResizeImage
  • Imagick::adaptiveThresholdImage »
  • PHP Manual
  • Imagick
  • Afila la imagen adaptativamente

Imagick::adaptiveSharpenImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveSharpenImage — Afila la imagen adaptativamente

Descripción

Imagick::adaptiveSharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Afila la imagen adaptativamente afilando con más intensidad cerca de los bordes de la imagen y con menos intensidad lejos de los bordes. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central. Use 0 para autoseleccionar.

sigma

La desviación estándar gaussiana, en píxeles.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::adaptiveSharpenImage()

Afilar la imagen adaptativamente con radio 2 y sigma 1.

<?php
try {
    $imagen = new Imagick('image.png');
    $imagen->adaptiveSharpenImage(2,1);
} catch(ImagickException $e) {
    echo 'Error: ' , $e->getMessage();
    die();
}
header('Content-type: image/png');
echo $imagen;
?>

Ver también

  • Imagick::sharpenImage() - Afila una imagen


Selecciona un umbral para cada píxel basado en un rango de intensidad

  • « Imagick::adaptiveSharpenImage
  • Imagick::addImage »
  • PHP Manual
  • Imagick
  • Selecciona un umbral para cada píxel basado en un rango de intensidad

Imagick::adaptiveThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveThresholdImage — Selecciona un umbral para cada píxel basado en un rango de intensidad

Descripción

Imagick::adaptiveThresholdImage ( int $width , int $height , int $offset ) : bool

Selecciona un umbral individual para cada píxel basado en un rango de valores de intensidad en su zona local. Esto permite establecer el umbral de una imagen cuyo histograma de intensidad global no contiene picos distintivos.

Parámetros

width

Ancho de la zona local.

height

Alto de la zona local.

offset

El índice medio

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::adaptiveThresholdImage()

<?php
function adaptiveThresholdImage($imagePath, $width, $height, $adaptiveOffset) {
    $imagick = new \Imagick(realpath($imagePath));
    $adaptiveOffsetQuantum = intval($adaptiveOffset * \Imagick::getQuantum());
    $imagick->adaptiveThresholdImage($width, $height, $adaptiveOffsetQuantum);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Añade una nueva imagen a la lista de imágenes del objeto Imagick

  • « Imagick::adaptiveThresholdImage
  • Imagick::addNoiseImage »
  • PHP Manual
  • Imagick
  • Añade una nueva imagen a la lista de imágenes del objeto Imagick

Imagick::addImage

(PECL imagick 2, PECL imagick 3)

Imagick::addImage — Añade una nueva imagen a la lista de imágenes del objeto Imagick

Descripción

Imagick::addImage ( Imagick $source ) : bool

Añade una nueva imagen al objeto Imagick desde la posición actual del objeto de origen. Después de la operación la posición del iterador se mueve al final de la lista.

Parámetros

source

El objeto Imagick de origen

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Añade ruido aleatorio a la imagen

  • « Imagick::addImage
  • Imagick::affineTransformImage »
  • PHP Manual
  • Imagick
  • Añade ruido aleatorio a la imagen

Imagick::addNoiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::addNoiseImage — Añade ruido aleatorio a la imagen

Descripción

Imagick::addNoiseImage ( int $noise_type , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Añade ruido aleatorio a la imagen.

Parámetros

noise_type

El tipo de ruido. Consulte esta lista de constantes de ruido.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::addNoiseImage()

<?php
function addNoiseImage($noiseType, $imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->addNoiseImage($noiseType, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Transforma una imagen

  • « Imagick::addNoiseImage
  • Imagick::animateImages »
  • PHP Manual
  • Imagick
  • Transforma una imagen

Imagick::affineTransformImage

(PECL imagick 2, PECL imagick 3)

Imagick::affineTransformImage — Transforma una imagen

Descripción

Imagick::affineTransformImage ( ImagickDraw $matrix ) : bool

Transforma una imagen como está establecido en la matriz afín.

Parámetros

matrix

La matriz afín

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::affineTransformImage()

<?php
function affineTransformImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $draw = new \ImagickDraw();

    $angle = 40 ;

    $affineRotate = array(
        "sx" => cos($angle), "sy" => cos($angle),
        "rx" => sin($angle), "ry" => -sin($angle),
        "tx" => 0, "ty" => 0,
    );

    $draw->affine($affineRotate);

    $imagick->affineTransformImage($draw);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Anima una imagen o imágenes

  • « Imagick::affineTransformImage
  • Imagick::annotateImage »
  • PHP Manual
  • Imagick
  • Anima una imagen o imágenes

Imagick::animateImages

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::animateImages — Anima una imagen o imágenes

Descripción

Imagick::animateImages ( string $x_server ) : bool

Este método anima la imagen en un servidor X local o remoto. Este método no está disponible en Windows. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

x_server

La dirección del servidor X

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::displayImage() - Muestra una imagen


Anota una imagen con texto

  • « Imagick::animateImages
  • Imagick::appendImages »
  • PHP Manual
  • Imagick
  • Anota una imagen con texto

Imagick::annotateImage

(PECL imagick 2, PECL imagick 3)

Imagick::annotateImage — Anota una imagen con texto

Descripción

Imagick::annotateImage ( ImagickDraw $draw_settings , float $x , float $y , float $angle , string $text ) : bool

Anota una imagen con texto.

Parámetros

draw_settings

El objeto ImagickDraw que contiene la configuración para el dibujo de texto

x

El índice horizontal en píxeles a la izquierda del texto

y

El índice vertical en píxeles de la línea base del texto

angle

El ángulo en el que se escribe el texto

text

La cadena a dibujar

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar Imagick::annotateImage():

Anotar texto en una imagen vacía

<?php
/* Crear algunos objetos */
$imagen = new Imagick();
$dibujo = new ImagickDraw();
$píxel = new ImagickPixel( 'gray' );

/* Nueva imagen */
$imagen->newImage(800, 75, $píxel);

/* Texto negro */
$dibujo->setColor('black');

/* Propiedades de la fuente */
$dibujo->setFont('Bookman-DemiItalic');
$dibujo->setFontSize( 30 );

/* Crear texto */
$imagen->annotateImage($dibujo, 10, 45, 0, 'The quick brown fox jumps over the lazy dog');

/* Dar a la imagen un formato */
$imagen->setImageFormat('png');

/* Imprimir la imagen con cabeceras */
header('Content-type: image/png');
echo $imagen;

?>

Ver también

  • ImagickDraw::annotation() - Dibuja texto en la imagen
  • ImagickDraw::setFont() - Establece la fuente especificada completamente para usarla cuando se escribe texto


Añade un conjunto de imágenes

  • « Imagick::annotateImage
  • Imagick::autoLevelImage »
  • PHP Manual
  • Imagick
  • Añade un conjunto de imágenes

Imagick::appendImages

(PECL imagick 2, PECL imagick 3)

Imagick::appendImages — Añade un conjunto de imágenes

Descripción

Imagick::appendImages ( bool $stack = false ) : Imagick

Añade un conjunto de imágenes en una imagen más grande.

Parámetros

stack

Para apilar las imágenes verticalmente. Por defecto (o si false se especifica) las imágenes se apilan de izquierda a derecha. Si stack es true, las imágenes se apilan de arriba hacia abajo.

Valores devueltos

Devuelve una instancia Imagick si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Imagick::appendImages()

<?php

/* Crear un nuevo objeto Imagick */
$im = new Imagick();

/* Crear imágenes de color rojo, verde y azul */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Añadir las imágenes en una sola */
$im->resetIterator();
$combined = $im->appendImages(true);

/* Imprimir la imagen */
$combined->setImageFormat("png");
header("Content-Type: image/png");
echo $combined;
?>

El resultado del ejemplo sería algo similar a:

Salida de ejemplo : Imagick::appendImages()


Description

  • « Imagick::appendImages
  • Imagick::averageImages »
  • PHP Manual
  • Imagick
  • Description

Imagick::autoLevelImage

(PECL imagick 3 >= 3.3.0)

Imagick::autoLevelImage — Description

Descripción

public Imagick::autoLevelImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adjusts the levels of a particular image channel by scaling the minimum and maximum values to the full quantum range.

Parámetros

channel

Which channel should the auto-levelling should be done on.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::autoLevelImage()

<?php
function autoLevelImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->autoLevelImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Calcula la media de un conjunto de imágenes

  • « Imagick::autoLevelImage
  • Imagick::blackThresholdImage »
  • PHP Manual
  • Imagick
  • Calcula la media de un conjunto de imágenes

Imagick::averageImages

(PECL imagick 2, PECL imagick 3)

Imagick::averageImages — Calcula la media de un conjunto de imágenes

Descripción

Imagick::averageImages ( ) : Imagick

Calcula la media de un conjunto de imágenes.

Valores devueltos

Devuelve un nuevo objeto Imagick si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Fuerza a todos los píxeles bajo un umbral a ser negros

  • « Imagick::averageImages
  • Imagick::blueShiftImage »
  • PHP Manual
  • Imagick
  • Fuerza a todos los píxeles bajo un umbral a ser negros

Imagick::blackThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::blackThresholdImage — Fuerza a todos los píxeles bajo un umbral a ser negros

Descripción

Imagick::blackThresholdImage ( mixed $threshold ) : bool

Es como Imagick::thresholdImage() pero fuerza a todos los píxeles bajo un umbral a ser negros mientras deja todos los píxeles por encima del umbral sin cambios.

Parámetros

threshold

El umbral por debajo del cual todo se vuelve de color negro

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como un parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::blackThresholdImage()

<?php
function blackThresholdImage($imagePath, $thresholdColor) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->blackthresholdimage($thresholdColor);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::blackThresholdImage
  • Imagick::blurImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::blueShiftImage

(PECL imagick 3 >= 3.3.0)

Imagick::blueShiftImage — Description

Descripción

public Imagick::blueShiftImage ( float $factor = 1.5 ) : bool

Mutes the colors of the image to simulate a scene at nighttime in the moonlight.

Parámetros

factor

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::blueShiftImage()

<?php
function blueShiftImage($imagePath, $blueShift) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->blueShiftImage($blueShift);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Añade un filtro de borrosidad a la imagen

  • « Imagick::blueShiftImage
  • Imagick::borderImage »
  • PHP Manual
  • Imagick
  • Añade un filtro de borrosidad a la imagen

Imagick::blurImage

(PECL imagick 2, PECL imagick 3)

Imagick::blurImage — Añade un filtro de borrosidad a la imagen

Descripción

Imagick::blurImage ( float $radius , float $sigma , int $channel = ? ) : bool

Añade un filtro de borrosidad a la imagen. El tercer parámetro opcional es para hacer borroso un canal específico.

Parámetros

radius

Radio de la borrosidad

sigma

Desviación estándar

channel

La constante Channeltype. Cuando no es proporciona, todos los canales se hacen borrosos.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::blurImage():

Hacer borrosa una imagen, después mostrarla en el navegador.

<?php

header('Content-type: image/jpeg');

$imagen = new Imagick('prueba.jpg');

$imagen->blurImage(5,3);
echo $imagen;

?>

Ver también

  • Imagick::adaptiveBlurImage() - Añade un filtro de borrosidad adaptativo a la imagen
  • Imagick::motionBlurImage() - Simula borrosidad en movimiento
  • Imagick::radialBlurImage() - Hace borrosa de forma radial una imagen


Rodea la imagen con un borde

  • « Imagick::blurImage
  • Imagick::brightnessContrastImage »
  • PHP Manual
  • Imagick
  • Rodea la imagen con un borde

Imagick::borderImage

(PECL imagick 2, PECL imagick 3)

Imagick::borderImage — Rodea la imagen con un borde

Descripción

Imagick::borderImage ( mixed $bordercolor , int $width , int $height ) : bool

Rodea la imagen con un borde del color definido por el objeto ImagickPixel de color de borde.

Parámetros

bordercolor

Objeto ImagickPixel o una cadena que contiene el color del borde

width

Ancho del borde

height

Alto del borde

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como el primer parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::borderImage()

<?php
function borderImage($imagePath, $color, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->borderImage($color, $width, $height);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::borderImage
  • Imagick::charcoalImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::brightnessContrastImage

(PECL imagick 3 >= 3.3.0)

Imagick::brightnessContrastImage — Description

Descripción

public Imagick::brightnessContrastImage ( float $brightness , float $contrast , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Change the brightness and/or contrast of an image. It converts the brightness and contrast parameters into slope and intercept and calls a polynomical function to apply to the image.

Parámetros

brightness

contrast

channel

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::brightnessContrastImage()

<?php
function brightnessContrastImage($imagePath, $brightness, $contrast, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->brightnessContrastImage($brightness, $contrast, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simula un dibujo a carboncillo

  • « Imagick::brightnessContrastImage
  • Imagick::chopImage »
  • PHP Manual
  • Imagick
  • Simula un dibujo a carboncillo

Imagick::charcoalImage

(PECL imagick 2, PECL imagick 3)

Imagick::charcoalImage — Simula un dibujo a carboncillo

Descripción

Imagick::charcoalImage ( float $radius , float $sigma ) : bool

Simula un dibujo a carboncillo.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central

sigma

La desviación estándar gaussiana, en píxeles

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::charcoalImage()

<?php
function charcoalImage($imagePath, $radius, $sigma) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->charcoalImage($radius, $sigma);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Borra una región de una imagen y la recorta

  • « Imagick::charcoalImage
  • Imagick::clampImage »
  • PHP Manual
  • Imagick
  • Borra una región de una imagen y la recorta

Imagick::chopImage

(PECL imagick 2, PECL imagick 3)

Imagick::chopImage — Borra una región de una imagen y la recorta

Descripción

Imagick::chopImage ( int $width , int $height , int $x , int $y ) : bool

Borra una región de una imagen y colapsa la imagen para ocupar la porción borrada.

Parámetros

width

Ancho del área cortada

height

Alto del área cortada

x

El punto de referencia X del área cortada

y

El punto de referencia Y del área cortada

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::chopImage():

Ejemplo de uso de Imagick::chopImage

<?php
/* Crear algunos objetos */
$imagen = new Imagick();
$píxel = new ImagickPixel( 'gray' );

/* Nueva imagen */
$imagen->newImage(400, 200, $píxel);

/* Cortar imagen */
$imagen->chopImage(200, 200, 0, 0);

/* Dar un formato a la imagen */
$imagen->setImageFormat('png');

/* Imprimir la imagen con cabeceras */
header('Content-type: image/png');
echo $imagen;

?>

Ver también

  • Imagick::cropImage() - Extrae una región de la imagen


Description

  • « Imagick::chopImage
  • Imagick::clear »
  • PHP Manual
  • Imagick
  • Description

Imagick::clampImage

(PECL imagick 3 >= 3.3.0)

Imagick::clampImage — Description

Descripción

public Imagick::clampImage ( string $CHANNEL = Imagick::CHANNEL_DEFAULT ) : void

Restringe el rango de color desde 0 a la profundidad cuántica.

Parámetros

CHANNEL

Valores devueltos


Borra todos los recursos asociados con un objeto Imagick

  • « Imagick::clampImage
  • Imagick::clipImage »
  • PHP Manual
  • Imagick
  • Borra todos los recursos asociados con un objeto Imagick

Imagick::clear

(PECL imagick 2, PECL imagick 3)

Imagick::clear — Borra todos los recursos asociados con un objeto Imagick

Descripción

Imagick::clear ( ) : bool

Borra todos los recursos asociados con un objeto Imagick.

Valores devueltos

Devuelve true en caso de éxito.


Recorta a lo largo del primer trazado desde un perfil 8BIM

  • « Imagick::clear
  • Imagick::clipImagePath »
  • PHP Manual
  • Imagick
  • Recorta a lo largo del primer trazado desde un perfil 8BIM

Imagick::clipImage

(PECL imagick 2, PECL imagick 3)

Imagick::clipImage — Recorta a lo largo del primer trazado desde un perfil 8BIM

Descripción

Imagick::clipImage ( ) : bool

Recorta a lo largo del primer trazado desde un perfil 8BIM, si está presente.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Description

  • « Imagick::clipImage
  • Imagick::clipPathImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::clipImagePath

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::clipImagePath — Description

Descripción

public Imagick::clipImagePath ( string $pathname , string $inside ) : void

Clips along the named paths from the 8BIM profile, if present. Later operations take effect inside the path. Id may be a number if preceded with #, to work on a numbered path, e.g., "#1" to use the first path.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

pathname

inside

Valores devueltos


Recorta a lo largo de trazados nominados desde un perfil 8BIM

  • « Imagick::clipImagePath
  • Imagick::clone »
  • PHP Manual
  • Imagick
  • Recorta a lo largo de trazados nominados desde un perfil 8BIM

Imagick::clipPathImage

(PECL imagick 2, PECL imagick 3)

Imagick::clipPathImage — Recorta a lo largo de trazados nominados desde un perfil 8BIM

Descripción

Imagick::clipPathImage ( string $pathname , bool $inside ) : bool

Recorta a lo largo de trazados nominados desde un perfil 8BIM, si está presente. Las operaiones posteriores toman efecto dentro del trazado. Puede ser un número si está precedido de #, para trabajar con un trazado numerado, p.ej., "#1" para usar el primer trazado.

Parámetros

pathname

El nombre del trazado

inside

Si es true las operaciones posteriores toman efecto dentro del patrón de recorte. De otro modo, las operaciones toman efecto fuera del patrón de recorte.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Hace una copia exacta de un objeto Imagick

  • « Imagick::clipPathImage
  • Imagick::clutImage »
  • PHP Manual
  • Imagick
  • Hace una copia exacta de un objeto Imagick

Imagick::clone

(PECL imagick 2, PECL imagick 3)

Imagick::clone — Hace una copia exacta de un objeto Imagick

Descripción

Imagick::clone ( ) : Imagick

Hace una copia exacta de un objeto Imagick.

Advertencia

Esta función ha sido declarada OBSOLETA a partir de imagick 3.1.0 en favor del uso de la palabra clave clone.

Ejemplos

Ejemplo #1 Clonación de un objeto Imagick en diferentes versiones de imagick

<?php
// Clonar un objeto Imagick en imagick 2.x y 3.0:
$newImage = $image->clone();

// Clonar un objeto Imagick desde 3.1.0 en adelante:
$newImage = clone $image;
?>

Valores devueltos

Se devuelve una copia de del objeto Imagick.

Historial de cambios

Versión | Descripción
3.1.0 | El método está obsoleto en favor de la palabra clave clone.


Reemplaza los colores de una imagen

  • « Imagick::clone
  • Imagick::coalesceImages »
  • PHP Manual
  • Imagick
  • Reemplaza los colores de una imagen

Imagick::clutImage

(PECL imagick 2, PECL imagick 3)

Imagick::clutImage — Reemplaza los colores de una imagen

Descripción

Imagick::clutImage ( Imagick $lookup_table , float $channel = Imagick::CHANNEL_DEFAULT ) : bool

Reemplaza los colores en una imagen con una paleta de colores. El segundo parámetro opcional reemplaza los colores de un canal específico. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

lookup_table

Objeto Imagick que contiene la paleta de colores

channel

La constante Channeltype. Cuando no se proporciona, los canales predeterminados se reemplazan.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar Imagick::clutImage():

Reemplzar los colores de una imagen desde una paleta de colores.

<?php
$imagen = new Imagick('test.jpg');
$clut = new Imagick();
$clut->newImage(1, 1, new ImagickPixel('black'));
$imagen->clutImage($clut);
$imagen->writeImage('test_out.jpg');
?>

Ver también

  • Imagick::adaptiveBlurImage() - Añade un filtro de borrosidad adaptativo a la imagen
  • Imagick::motionBlurImage() - Simula borrosidad en movimiento
  • Imagick::radialBlurImage() - Hace borrosa de forma radial una imagen


Compone un conjunto de imágenes

  • « Imagick::clutImage
  • Imagick::colorFloodfillImage »
  • PHP Manual
  • Imagick
  • Compone un conjunto de imágenes

Imagick::coalesceImages

(PECL imagick 2, PECL imagick 3)

Imagick::coalesceImages — Compone un conjunto de imágenes

Descripción

Imagick::coalesceImages ( ) : Imagick

Compone un conjunto de imágenes mientras se respeten indices de página y métodos de disposición. Las secuencias de animación GIF, MIFF, y MNG normalmente comienzan con un fondo de imagen y cada imagen subsiguiente varía en tamaño e índice. Devuelve un nuevo objeto Imagick donde cada imagen de la secuencia es del mismo tamaño que la primera y compuesta con la siguiente imagen de la secuencia.

Valores devueltos

Devuelve un nuevo objeto Imagick en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Cambia el valor del color de cualquier píxel que coincida con el objetivo

  • « Imagick::coalesceImages
  • Imagick::colorizeImage »
  • PHP Manual
  • Imagick
  • Cambia el valor del color de cualquier píxel que coincida con el objetivo

Imagick::colorFloodfillImage

(PECL imagick 2, PECL imagick 3)

Imagick::colorFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo

Descripción

Imagick::colorFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool

Cambia el valor del color de cualquier píxel que coincida con el objetivo y esté en el área inmediata.

Parámetros

fill

Objeto ImagickPixel que contiene el color de relleno

fuzz

La cantidad de enfoque. Por ejemplo, establecer el enfoque a 10 y el color a rojo con una intensidad de 100 y 102 respectivamente ahora se interpreta como el mismo color para los propósitos del relleno.

bordercolor

Objeto ImagickPixel que contiene el color de borde

x

Posición X del inicio del relleno

y

Posición Y del inicio del relleno

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como el primer y tercer parámetros. Versiones anteriores sólo permitían un objeto ImagickPixel.


Mezcla el color de relleno con la imagen

  • « Imagick::colorFloodfillImage
  • Imagick::colorMatrixImage »
  • PHP Manual
  • Imagick
  • Mezcla el color de relleno con la imagen

Imagick::colorizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::colorizeImage — Mezcla el color de relleno con la imagen

Descripción

Imagick::colorizeImage ( mixed $colorize , mixed $opacity ) : bool

Mezcla el color de relleno de cada píxel con la imagen.

Parámetros

colorize

Objeto ImagickPixel o una cadena que contiene el color

opacity

Objeto ImagickPixel o un valor float que contiene el valor de la opacidad. 1.0 es completamente opaco y 0.0 es completamente transparente.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como el primer parámetro y que un valor float represente el valor de la opacidad como el segundo parámetro. Versiones anteriores sólo permitían objetos ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::colorizeImage()

<?php
function colorizeImage($imagePath, $color, $opacity) {
    $imagick = new \Imagick(realpath($imagePath));
    $opacity = $opacity / 255.0;
    $opacityColor = new \ImagickPixel("rgba(0, 0, 0, $opacity)");
    $imagick->colorizeImage($color, $opacityColor);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::colorizeImage
  • Imagick::combineImages »
  • PHP Manual
  • Imagick
  • Description

Imagick::colorMatrixImage

(PECL imagick 3 >= 3.3.0)

Imagick::colorMatrixImage — Description

Descripción

public Imagick::colorMatrixImage ( array $color_matrix = Imagick::CHANNEL_DEFAULT ) : bool

Apply color transformation to an image. The method permits saturation changes, hue rotation, luminance to alpha, and various other effects. Although variable-sized transformation matrices can be used, typically one uses a 5x5 matrix for an RGBA image and a 6x6 for CMYKA (or RGBA with offsets). The matrix is similar to those used by Adobe Flash except offsets are in column 6 rather than 5 (in support of CMYKA images) and offsets are normalized (divide Flash offset by 255)

Parámetros

color_matrix

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::colorMatrixImage()

<?php
function colorMatrixImage($imagePath, $colorMatrix) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageOpacity(1);

    //A color matrix should look like:
    //    $colorMatrix = [
    //        1.5, 0.0, 0.0, 0.0, 0.0, -0.157,
    //        0.0, 1.0, 0.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 1.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 0.0, 1.0, 0.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 1.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 0.0,  1.0
    //    ];

    $background = new \Imagick();
    $background->newPseudoImage($imagick->getImageWidth(), $imagick->getImageHeight(),  "pattern:checkerboard");

    $background->setImageFormat('png');

    $imagick->setImageFormat('png');
    $imagick->colorMatrixImage($colorMatrix);

    $background->compositeImage($imagick, \Imagick::COMPOSITE_ATOP, 0, 0);

    header("Content-Type: image/png");
    echo $background->getImageBlob();
}

?>


Combina una o más imágenes en una sóla imagen

  • « Imagick::colorMatrixImage
  • Imagick::commentImage »
  • PHP Manual
  • Imagick
  • Combina una o más imágenes en una sóla imagen

Imagick::combineImages

(PECL imagick 2, PECL imagick 3)

Imagick::combineImages — Combina una o más imágenes en una sóla imagen

Descripción

Imagick::combineImages ( int $channelType ) : Imagick

Combina una o más imágenes en una sóla imagen. El valor de la escala de grises de los píxeles de cada imagen en la secuencia se asigna para especificar los canales de la imagen combinada. El orden típico sería imagen 1 => Red, 2 => Green, 3 => Blue, etc.

Parámetros

channelType

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Añade un comentario a la imagen

  • « Imagick::combineImages
  • Imagick::compareImageChannels »
  • PHP Manual
  • Imagick
  • Añade un comentario a la imagen

Imagick::commentImage

(PECL imagick 2, PECL imagick 3)

Imagick::commentImage — Añade un comentario a la imagen

Descripción

Imagick::commentImage ( string $comment ) : bool

Añade un comentario a la imagen.

Parámetros

comment

El comentario a añadir

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::commentImage():

Comentar una imagen y recuperar el comentario:

<?php

/* Crear un nuevo objeto Imagick */
$im = new imagick();

/* Crear una imagen vacía */
$im->newImage(100, 100, new ImagickPixel("red"));

/* Añadir el comentario a la imagen */
$im->commentImage("¡Hola Mundo!");

/* Mostrar el comentario */
echo $im->getImageProperty("comment");

?>


Devuelve la diferencia entre una o más imágenes

  • « Imagick::commentImage
  • Imagick::compareImageLayers »
  • PHP Manual
  • Imagick
  • Devuelve la diferencia entre una o más imágenes

Imagick::compareImageChannels

(PECL imagick 2, PECL imagick 3)

Imagick::compareImageChannels — Devuelve la diferencia entre una o más imágenes

Descripción

Imagick::compareImageChannels ( Imagick $image , int $channelType , int $metricType ) : array

Compara una o más imágenes y devuelve la imagen de diferencia.

Parámetros

image

Un objeto Imagick que contiene la imagen a comparar.

channelType

Proporcione cualquier constante de canal que sea válida para el modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

metricType

Una de las constantes de tipos de métrica.

Valores devueltos

Array que consiste en new_wand y distortion.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la región circundante máxima entre imágenes

  • « Imagick::compareImageChannels
  • Imagick::compareImages »
  • PHP Manual
  • Imagick
  • Devuelve la región circundante máxima entre imágenes

Imagick::compareImageLayers

(PECL imagick 2, PECL imagick 3)

Imagick::compareImageLayers — Devuelve la región circundante máxima entre imágenes

Descripción

Imagick::compareImageLayers ( int $method ) : Imagick

Compara cada imagen con la siguiente en una secuencia y devuelve la región circundante máxima de cualesquiera deferencias de píxeles que se descubra. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

method

Una de las constantes de método de capas.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::compareImageLayers()

Comparar las capas de la imagen

<?php
/* crear un nuevo objeto imagick */
$im = new Imagick("test.gif");

/* optimizar las capas de la imagen */
$resultado = $im->compareImageLayers(imagick::LAYERMETHOD_COALESCE);

/* trabajar sobre el $resultado */
?>

Ver también

  • Imagick::optimizeImageLayers() - Elimina porciones repetidas de imágenes para optimizarlas
  • Imagick::writeImages() - Escribe una imagen o secuencia de imágenes
  • Imagick::writeImage() - Escribe una imagen al nombre de fichero especificado


Compara una imagen con otra reconstruida

  • « Imagick::compareImageLayers
  • Imagick::compositeImage »
  • PHP Manual
  • Imagick
  • Compara una imagen con otra reconstruida

Imagick::compareImages

(PECL imagick 2, PECL imagick 3)

Imagick::compareImages — Compara una imagen con otra reconstruida

Descripción

Imagick::compareImages ( Imagick $compare , int $metric ) : array

Devuelve un array que contiene una imagen reconstruida y las diferencias entre las imágenes.

Parámetros

compare

Una imagen a comparar.

metric

Proporcione una constante de tipo de métrica válida. Consulte esta lista de constantes métricas.

Valores devueltos

Devuelve un array que contiene una imagen reconstruida y las diferencias entre imágenes.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Uso de Imagick::compareImages():

Comparar imágenes y mostrar la imagen reconstruida

<?php

$imagen1 = new imagick("imagen1.png");
$imagen1 = new imagick("imagen1.png");

$resultado = $imagen1->compareImages($imagen1, Imagick::METRIC_MEANSQUAREERROR);
$resultado[0]->setImageFormat("png");

header("Content-Type: image/png");
echo $resultado[0];

?>


Compone una imagen en otra

  • « Imagick::compareImages
  • Imagick::__construct »
  • PHP Manual
  • Imagick
  • Compone una imagen en otra

Imagick::compositeImage

(PECL imagick 2, PECL imagick 3)

Imagick::compositeImage — Compone una imagen en otra

Descripción

Imagick::compositeImage ( Imagick $composite_object , int $composite , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool

Compone una imagen en otra en el índice especificado. Debería proporcionarse cualquier argumento necesario para el algoritmo de composición a setImageArtifact con 'compose:args' como el primer parámetro y los datos como el segundo.

Parámetros

composite_object

Objeto Imagick que guarda la imagen compuesta

compose

Operador de composición. Véase Constantes de Operadores de Composición

x

El índice de la columna de la imagen compuesta

y

El índice de la fila de la imagen compuesta

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Empleo de Imagick::compositeImage():

Componer dos imágenes con el método de composición 'mathematics'

<?php

// Equivalente a ejecutar el comando
// convert src1.png src2.png -compose mathematics -define compose:args="1,0,-0.5,0.5" -composite output.png

$src1 = new \Imagick("./src1.png");
$src2 = new \Imagick("./src2.png");

$src1->setImageVirtualPixelMethod(Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);
$src1->setImageArtifact('compose:args', "1,0,-0.5,0.5");
$src1->compositeImage($src2, Imagick::COMPOSITE_MATHEMATICS, 0, 0);
$src1->writeImage("./output.png");

?>

Ver también

  • Imagick::setImageArtifact() - Establecer un artefacto de imagen


El constructor Imagick

  • « Imagick::compositeImage
  • Imagick::contrastImage »
  • PHP Manual
  • Imagick
  • El constructor Imagick

Imagick::__construct

(PECL imagick 2, PECL imagick 3)

Imagick::__construct — El constructor Imagick

Descripción

Imagick::__construct ( mixed $files )

Crea una instancia de Imagick para una imagen o conjunto de imágenes especificos.

Parámetros

files

La ruta de una imagen a cargar o un array de rutas. Las rutas pueden incluir comodines para nombres de ficheros, o pueden ser URLs.

Valores devueltos

Devuelve un nuevo objeto Imagick si se tuvo éxtio.

Errores/Excepciones

Lanza ImagickException en caso de error.


Cambia el contraste de una imagen

  • « Imagick::__construct
  • Imagick::contrastStretchImage »
  • PHP Manual
  • Imagick
  • Cambia el contraste de una imagen

Imagick::contrastImage

(PECL imagick 2, PECL imagick 3)

Imagick::contrastImage — Cambia el contraste de una imagen

Descripción

Imagick::contrastImage ( bool $sharpen ) : bool

Mejora la diferencias de intensidad entre elementos claros y oscuros de la imagen. Establezca la agudización a un valor que no sea 0 para aumentar el contraste de la imagen, de otro modo el contraste se reduce.

Parámetros

sharpen

El valor de la agudización

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::contrastImage()

<?php
function contrastImage($imagePath, $contrastType) {
    $imagick = new \Imagick(realpath($imagePath));
    if ($contrastType != 2) {
        $imagick->contrastImage($contrastType);
    }

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Mejora el contraste de una imagen en color

  • « Imagick::contrastImage
  • Imagick::convolveImage »
  • PHP Manual
  • Imagick
  • Mejora el contraste de una imagen en color

Imagick::contrastStretchImage

(PECL imagick 2, PECL imagick 3)

Imagick::contrastStretchImage — Mejora el contraste de una imagen en color

Descripción

Imagick::contrastStretchImage ( float $black_point , float $white_point , int $channel = Imagick::CHANNEL_ALL ) : bool

Mejora el contraste de una imagen en color ajustando los colores de los píxeles de color para abarcar el rango completo de los colores disponibles. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

black_point

El punto blanco.

white_point

El punto negro.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Imagick::CHANNEL_ALL. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.


Aplica una semilla de convolución a medida a la imagen

  • « Imagick::contrastStretchImage
  • Imagick::count »
  • PHP Manual
  • Imagick
  • Aplica una semilla de convolución a medida a la imagen

Imagick::convolveImage

(PECL imagick 2, PECL imagick 3)

Imagick::convolveImage — Aplica una semilla de convolución a medida a la imagen

Descripción

Imagick::convolveImage ( array $kernel , int $channel = Imagick::CHANNEL_ALL ) : bool

Aplica una semilla de convolución a medida a la imagen.

Parámetros

kernel

La semilla de convolución

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::convolveImage()

<?php
function convolveImage($imagePath, $bias, $kernelMatrix) {
    $imagick = new \Imagick(realpath($imagePath));
    //$edgeFindingKernel = [-1, -1, -1, -1, 8, -1, -1, -1, -1,];
    $imagick->setImageBias($bias * \Imagick::getQuantum());
    $imagick->convolveImage($kernelMatrix);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Get the number of images

  • « Imagick::convolveImage
  • Imagick::cropImage »
  • PHP Manual
  • Imagick
  • Get the number of images

Imagick::count

(PECL imagick 3 >= 3.3.0)

Imagick::count — Get the number of images

Descripción

public Imagick::count ( int $mode = 0 ) : int

Returns the number of images.

Parámetros

mode

An unused argument. Currently there is a non-particularly well defined feature in PHP where calling count() on a countable object might (or might not) require this method to accept a parameter. This parameter is here to be conformant with the interface of countable, even though the param is not used.

Valores devueltos

Returns the number of images.


Extrae una región de la imagen

  • « Imagick::count
  • Imagick::cropThumbnailImage »
  • PHP Manual
  • Imagick
  • Extrae una región de la imagen

Imagick::cropImage

(PECL imagick 2, PECL imagick 3)

Imagick::cropImage — Extrae una región de la imagen

Descripción

Imagick::cropImage ( int $width , int $height , int $x , int $y ) : bool

Extrae una región de la imagen.

Parámetros

width

El ancho del recorte

height

El alto del recorte

x

La coordenada X de la esquina superior izquierda de la región recortada

y

La coordenada Y de la esquina superior izquierda de la región recortada

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::cropImage()

<?php
function cropImage($imagePath, $startX, $startY, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->cropImage($width, $height, $startX, $startY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea una miniatura recortada

  • « Imagick::cropImage
  • Imagick::current »
  • PHP Manual
  • Imagick
  • Crea una miniatura recortada

Imagick::cropThumbnailImage

(PECL imagick 2, PECL imagick 3)

Imagick::cropThumbnailImage — Crea una miniatura recortada

Descripción

Imagick::cropThumbnailImage ( int $width , int $height ) : bool

Crea una miniatura de tamaño fijo ampliando o reduciendo de escala la imagen y recortando un área específica desde el centro.

Parámetros

width

El ancho de la miniatura

height

El alto de la miniatura

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve una referencia del objeto Imagick actual

  • « Imagick::cropThumbnailImage
  • Imagick::cycleColormapImage »
  • PHP Manual
  • Imagick
  • Devuelve una referencia del objeto Imagick actual

Imagick::current

(PECL imagick 2, PECL imagick 3)

Imagick::current — Devuelve una referencia del objeto Imagick actual

Descripción

Imagick::current ( ) : Imagick

Devuelve una referencia del objeto Imagick actual con el puntero de imagen en la secuencia correcta.

Valores devueltos

Se devuelve a sí mismo si tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Desplaza el mapa de colores de una imagen

  • « Imagick::current
  • Imagick::decipherImage »
  • PHP Manual
  • Imagick
  • Desplaza el mapa de colores de una imagen

Imagick::cycleColormapImage

(PECL imagick 2, PECL imagick 3)

Imagick::cycleColormapImage — Desplaza el mapa de colores de una imagen

Descripción

Imagick::cycleColormapImage ( int $displace ) : bool

Desplaza el mapa de colores de una imagen por el número de posiciones dados. Si se realiza un ciclo del mapa de colores varias veces se puede obtener un efecto psicodélico.

Parámetros

displace

La cantidad de desplazamiento del mapa de colores.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Descifra una imagen

  • « Imagick::cycleColormapImage
  • Imagick::deconstructImages »
  • PHP Manual
  • Imagick
  • Descifra una imagen

Imagick::decipherImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::decipherImage — Descifra una imagen

Descripción

Imagick::decipherImage ( string $passphrase ) : bool

Descifra una imagen que ha sido cifrada anteriormente. La iamgen debe ser cifrada usando Imagick::encipherImage(). Este método está disponible si Imagick ha sido compilado con la versión 6.3.9 o superior de ImageMagick.

Parámetros

passphrase

La frase de contraseña

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::encipherImage() - Cifra una imagen


Devuelve ciertas diferencias de píxeles entre imágenes

  • « Imagick::decipherImage
  • Imagick::deleteImageArtifact »
  • PHP Manual
  • Imagick
  • Devuelve ciertas diferencias de píxeles entre imágenes

Imagick::deconstructImages

(PECL imagick 2, PECL imagick 3)

Imagick::deconstructImages — Devuelve ciertas diferencias de píxeles entre imágenes

Descripción

Imagick::deconstructImages ( ) : Imagick

Compara cada imagen con la siguiente en una secuencia y devuelve la región circundante máxima de cualquier diferencia de píxeles que se descubra.

Valores devueltos

Devuelve un nuevo objeto Imagick si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Borra un artefacto de imagen

  • « Imagick::deconstructImages
  • Imagick::deleteImageProperty »
  • PHP Manual
  • Imagick
  • Borra un artefacto de imagen

Imagick::deleteImageArtifact

(PECL imagick 3)

Imagick::deleteImageArtifact — Borra un artefacto de imagen

Descripción

Imagick::deleteImageArtifact ( string $artifact ) : bool

Borra un artefacto asociado con la imagen. La diferencia entre las propiedades de imagen y los artefactos de imagen es que las propiedades son públicas y los artefactos son privados. Este método está disponible si Imagick ha sido compilado con la versión 6.5.7 o superior de ImageMagick.

Parámetros

artifact

El nombre del artefacto a borrar.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::setImageArtifact() - Establecer un artefacto de imagen
  • Imagick::getImageArtifact() - Obtener el artefacto de imagen


Description

  • « Imagick::deleteImageArtifact
  • Imagick::deskewImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::deleteImageProperty

(PECL imagick 3 >= 3.3.0)

Imagick::deleteImageProperty — Description

Descripción

public Imagick::deleteImageProperty ( string $name ) : bool

Deletes an image property.

Parámetros

name

The name of the property to delete.

Valores devueltos

Devuelve true en caso de éxito.


Elimina la torción de la imagen

  • « Imagick::deleteImageProperty
  • Imagick::despeckleImage »
  • PHP Manual
  • Imagick
  • Elimina la torción de la imagen

Imagick::deskewImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.3.0)

Imagick::deskewImage — Elimina la torción de la imagen

Descripción

public Imagick::deskewImage ( float $threshold ) : bool

Eeste método se puede usar para eliminar la torción de, por ejemplo, imágenes escaneadas donde el papel no estaba debidamente colocado en la superfice del escáner. Este método está disponible si Imagick ha sido compilado con la versión 6.4.5 o superior de ImageMagick.

Parámetros

threshold

Umbral de detorción

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::deskewImage()

<?php
function deskewImage($threshold) {
    $imagick = new \Imagick(realpath("images/NYTimes-Page1-11-11-1918.jpg"));
    $deskewImagick = clone $imagick;

    //Esto es lo único que se requiere para eliminar la torción.
    $deskewImagick->deskewImage($threshold);

    //El resto de este ejemplo es para hacer el resultado obvio, ya que
    //de lo contrario no sería obvio.
    $trim = 9;

    $deskewImagick->cropImage($deskewImagick->getImageWidth() - $trim, $deskewImagick->getImageHeight(), $trim, 0);
    $imagick->cropImage($imagick->getImageWidth() - $trim, $imagick->getImageHeight(), $trim, 0);
    $deskewImagick->resizeimage($deskewImagick->getImageWidth() / 2, $deskewImagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $imagick->resizeimage($imagick->getImageWidth() / 2, $imagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $newCanvas = new \Imagick();
    $newCanvas->newimage($imagick->getImageWidth() + $deskewImagick->getImageWidth() + 20, $imagick->getImageHeight(), 'red', 'jpg');
    $newCanvas->compositeimage($imagick, \Imagick::COMPOSITE_COPY, 5, 0);
    $newCanvas->compositeimage($deskewImagick, \Imagick::COMPOSITE_COPY, $imagick->getImageWidth() + 10, 0);

    header("Content-Type: image/jpg");
    echo $newCanvas->getImageBlob();
}

?>


Reduce el ruido granular de una imagen

  • « Imagick::deskewImage
  • Imagick::destroy »
  • PHP Manual
  • Imagick
  • Reduce el ruido granular de una imagen

Imagick::despeckleImage

(PECL imagick 2, PECL imagick 3)

Imagick::despeckleImage — Reduce el ruido granular de una imagen

Descripción

Imagick::despeckleImage ( ) : bool

Reduce el ruido granular de una imagen mientras preserva los bordes de la imagen original.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::despeckleImage()

<?php
function despeckleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->despeckleImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Destruye un objeto Imagick

  • « Imagick::despeckleImage
  • Imagick::displayImage »
  • PHP Manual
  • Imagick
  • Destruye un objeto Imagick

Imagick::destroy

(PECL imagick 2, PECL imagick 3)

Imagick::destroy — Destruye un objeto Imagick

Descripción

Imagick::destroy ( ) : bool

Destruye el objeto Imagick y libera todos los recursos asociados a él. Este método está obsoleto en favor de Imagick::clear.

Valores devueltos

Devuelve true en caso de éxito.


Muestra una imagen

  • « Imagick::destroy
  • Imagick::displayImages »
  • PHP Manual
  • Imagick
  • Muestra una imagen

Imagick::displayImage

(PECL imagick 2, PECL imagick 3)

Imagick::displayImage — Muestra una imagen

Descripción

Imagick::displayImage ( string $servername ) : bool

Este método muestra una imagen en un servidor X.

Parámetros

servername

El nombre del servidor X

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Muestra una imagen o una secuencia de imágenes

  • « Imagick::displayImage
  • Imagick::distortImage »
  • PHP Manual
  • Imagick
  • Muestra una imagen o una secuencia de imágenes

Imagick::displayImages

(PECL imagick 2, PECL imagick 3)

Imagick::displayImages — Muestra una imagen o una secuencia de imágenes

Descripción

Imagick::displayImages ( string $servername ) : bool

Muestra una imagen o una secuencia de imágenes en un servidor X.

Parámetros

servername

El nombre del servidor X

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Deforma una imagen utilizando varios métodos de distorsión

  • « Imagick::displayImages
  • Imagick::drawImage »
  • PHP Manual
  • Imagick
  • Deforma una imagen utilizando varios métodos de distorsión

Imagick::distortImage

(PECL imagick 2 >= 2.0.1, PECL imagick 3)

Imagick::distortImage — Deforma una imagen utilizando varios métodos de distorsión

Descripción

Imagick::distortImage ( int $method , array $arguments , bool $bestfit ) : bool

Deforma una imagen utilizando varios métodos de distorsión, mapeando la paleta de colores de la imagen de origen a una nueva imagen destino normalmente del mismo tamaño que la imagen de origen, a menos que 'bestfit' esté establecido a true.

Si 'bestfit' está habilitado, y la distorsión lo permite, la imagen destino se ajusta para asegurarse de que la 'imagen' de origen entera se ajustará dentro de la imagen destino final, la cuál será redimensionada e compensada acordemente. También, en la mayoría de los casos el índice virtual de la imagen de origen será tomado en cuenta en el mapeado.

Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

method

El método de distorsión de la imagen. Véase constantes de distorsión

arguments

Los argumentos para este método de distorsión

bestfit

Intenta redimensionar la imagen destino para ajustarse a la imagen de origen deformada

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::distortImage():

Deformar una imagen y mostrarla en el navegador.

<?php
/* Crear un nuevo objeto */
$im = new Imagick();

/* Crear un nuevo patrón de tablero de ajedrez */
$im->newPseudoImage(100, 100, "pattern:checkerboard");

/* Esteblecer el formato de la imagen a png */
$im->setImageFormat('png');

/* Rellenar las nuevas áreas visibles con transparente */
$im->setImageVirtualPixelMethod(Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);

/* Activar el mate */
$im->setImageMatte(true);

/* Puntos de control para la distorsión */
$puntosControl = array( 10, 10,
                        10, 5,

                        10, $im->getImageHeight() - 20,
                        10, $im->getImageHeight() - 5,

                        $im->getImageWidth() - 10, 10,
                        $im->getImageWidth() - 10, 20,

                        $im->getImageWidth() - 10, $im->getImageHeight() - 10,
                        $im->getImageWidth() - 10, $im->getImageHeight() - 30);

/* Realizar la distorsión */
$im->distortImage(Imagick::DISTORTION_PERSPECTIVE, $puntosControl, true);

/* Imprimir la imagen */
header("Content-Type: image/png");
echo $im;
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Using Imagick::distortImage()

Ver también

  • Imagick::blurImage() - Añade un filtro de borrosidad a la imagen
  • Imagick::motionBlurImage() - Simula borrosidad en movimiento
  • Imagick::radialBlurImage() - Hace borrosa de forma radial una imagen


Renderiza el objeto ImagickDraw a la imagen actual

  • « Imagick::distortImage
  • Imagick::edgeImage »
  • PHP Manual
  • Imagick
  • Renderiza el objeto ImagickDraw a la imagen actual

Imagick::drawImage

(PECL imagick 2, PECL imagick 3)

Imagick::drawImage — Renderiza el objeto ImagickDraw a la imagen actual

Descripción

Imagick::drawImage ( ImagickDraw $draw ) : bool

Renderiza el objeto ImagickDraw a la imagen actual.

Parámetros

draw

Las operaciones de dibujo para renderizar a la imagen.

Valores devueltos

Devuelve true en caso de éxito.


Mejora los bordes de la imagen

  • « Imagick::drawImage
  • Imagick::embossImage »
  • PHP Manual
  • Imagick
  • Mejora los bordes de la imagen

Imagick::edgeImage

(PECL imagick 2, PECL imagick 3)

Imagick::edgeImage — Mejora los bordes de la imagen

Descripción

Imagick::edgeImage ( float $radius ) : bool

Mejora los bordes de la imagen con un filtro de convolución del radio dado. Use un radio de 0 y éste será autoseleccionado.

Parámetros

radius

El radio de la operación.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::edgeImage()

<?php
function edgeImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->edgeImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Devuelve una imagen en escala de grises con un efecto tridimensional

  • « Imagick::edgeImage
  • Imagick::encipherImage »
  • PHP Manual
  • Imagick
  • Devuelve una imagen en escala de grises con un efecto tridimensional

Imagick::embossImage

(PECL imagick 2, PECL imagick 3)

Imagick::embossImage — Devuelve una imagen en escala de grises con un efecto tridimensional

Descripción

Imagick::embossImage ( float $radius , float $sigma ) : bool

Devuelve una imagen en escala de grises con un efecto tridimensional. Se convoluciona la imagen con un operador gaussiano del radio y desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y se elegirá un radio apropiado automáticamente.

Parámetros

radius

El radio de el efecto

sigma

El valor sigma del efecto

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::embossImage()

<?php
function embossImage($imagePath, $radius, $sigma) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->embossImage($radius, $sigma);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Cifra una imagen

  • « Imagick::embossImage
  • Imagick::enhanceImage »
  • PHP Manual
  • Imagick
  • Cifra una imagen

Imagick::encipherImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::encipherImage — Cifra una imagen

Descripción

Imagick::encipherImage ( string $passphrase ) : bool

Covierte los píxeles planos en píxeles cifrados. La imagen no es legible hasta que haya sido descifrada usando Imagick::decipherImage() Este método está disponible si Imagick ha sido compilado con la versión 6.3.9 o superior de ImageMagick.

Parámetros

passphrase

La frase de contraseña

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::decipherImage() - Descifra una imagen


Mejora la calidad de una imagen con ruido

  • « Imagick::encipherImage
  • Imagick::equalizeImage »
  • PHP Manual
  • Imagick
  • Mejora la calidad de una imagen con ruido

Imagick::enhanceImage

(PECL imagick 2, PECL imagick 3)

Imagick::enhanceImage — Mejora la calidad de una imagen con ruido

Descripción

Imagick::enhanceImage ( ) : bool

Aplica un filtro digital que mejora la calidad de una imagen con ruido.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::enhanceImage()

<?php
function enhanceImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->enhanceImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Ecualiza el histograma de la imagen

  • « Imagick::enhanceImage
  • Imagick::evaluateImage »
  • PHP Manual
  • Imagick
  • Ecualiza el histograma de la imagen

Imagick::equalizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::equalizeImage — Ecualiza el histograma de la imagen

Descripción

Imagick::equalizeImage ( ) : bool

Ecualiza el histograma de la imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::equalizeImage()

<?php
function equalizeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->equalizeImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Aplica una expresión a una imagen

  • « Imagick::equalizeImage
  • Imagick::exportImagePixels »
  • PHP Manual
  • Imagick
  • Aplica una expresión a una imagen

Imagick::evaluateImage

(PECL imagick 2, PECL imagick 3)

Imagick::evaluateImage — Aplica una expresión a una imagen

Descripción

Imagick::evaluateImage ( int $op , float $constant , int $channel = Imagick::CHANNEL_ALL ) : bool

Aplica una expresión aritmética, relacional, o lógica a una imagen. Use estos operadores para aclarar u oscurecer una imagen, para aumentar o disminuir el contraste de una imagen, o para producir el "negativo" de una imagen.

Parámetros

op

La evaluación del operador

constant

El valor del operador

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Ejemplos

Ejemplo #1 Usando Imagick::evaluateImage()

Usando evaluateImage para reducir la opacidad de una imagen.

<?php
// Crea un nuevo objecto con la imagen
$im = new Imagick('example-alpha.png');

// Reduce el alfa en un 50%
$im->evaluateImage(Imagick::EVALUATE_DIVIDE, 2, Imagick::CHANNEL_ALPHA);

// Muestra la imagen
header("Content-Type: image/png");
echo $im;
?>

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Exporta píxeles de imagen en bruto

  • « Imagick::evaluateImage
  • Imagick::extentImage »
  • PHP Manual
  • Imagick
  • Exporta píxeles de imagen en bruto

Imagick::exportImagePixels

(PECL imagick 2 >=2.3.0, PECL imagick 3)

Imagick::exportImagePixels — Exporta píxeles de imagen en bruto

Descripción

public Imagick::exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE ) : array

Exporta píxeles de imagen en bruto a una matriz. El mapa define el orden de los píxeles exportados. El tamaño de la matriz devuelta es ancho * alto * strlen(mapa). Este método está disponible si Imagick ha sido compilado con la versión 6.4.7 o superior de ImageMagick.

Parámetros

x

Coordenada X del área exportada

y

Coordenada Y del área exportada

width

Ancho del área exportada

height

Alto del área exportada

map

Orden de los píxeles exportados. Por ejemplo "RGB". Los caracteres válidos para el mapa son R, G, B, A, O, C, Y, M, K, I y P.

STORAGE

Consulte esta lista de constantes de tipo de píxeles

Ejemplos

Ejemplo #1 Usar Imagick::exportImagePixels()

Exportar los píxeles de una imagen a una matriz

<?php

/* Crear un nuevo objeto */
$im = new Imagick();

/* Crear una nueva imagen */
$im->newPseudoImage(0, 0, "magick:rose");

/* Exportar los píxeles de la imagen */
$píxeles = $im->exportImagePixels(10, 10, 2, 2, "RGB", Imagick::PIXEL_CHAR);

/* Imprimir */
var_dump($píxeles);
?>

El resultado del ejemplo sería:

array(12) {
  [0]=>
  int(72)
  [1]=>
  int(64)
  [2]=>
  int(57)
  [3]=>
  int(69)
  [4]=>
  int(59)
  [5]=>
  int(43)
  [6]=>
  int(124)
  [7]=>
  int(120)
  [8]=>
  int(-96)
  [9]=>
  int(91)
  [10]=>
  int(84)
  [11]=>
  int(111)
}

Valores devueltos

Devuelve una matriz que contiene los valores de los píxeles.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establecer el tamaño de la imagen

  • « Imagick::exportImagePixels
  • Imagick::filter »
  • PHP Manual
  • Imagick
  • Establecer el tamaño de la imagen

Imagick::extentImage

(PECL imagick 2, PECL imagick 3)

Imagick::extentImage — Establecer el tamaño de la imagen

Descripción

Imagick::extentImage ( int $width , int $height , int $x , int $y ) : bool

Método cómodo para establecer el tamaño de una imagen. El método establece el tamaño de la imagen y permite ajustar las coordenadas x,y donde comienza el nuevo área. Este método está disponible si Imagick ha sido compilado con la versión 6.3.1 o superior de ImageMagick.

Precaución

Antes de ImageMagick 6.5.7-8 (1623), $x era positivo cuando se desplazaba hacia la izquierda y negativo cuando se desplazaba hacia la derecha, e $y era positivo cuando se desplazaba una imagen hacia arriba y negativo cuando se desplazaba hacia abajo. Entre ImageMagick 6.3.7 (1591) e ImageMagick 6.5.7-8 (1623), los ejes de $x e $y se voltearon, por lo que $x era negativo cuando se desplazaba hacia la izquierda y positivo cuando se desplazaba hacia la derecha, e $y era negativo cuando se desplazaba una imagen hacia arriba y positivo cuando se desplazaba hacia abajo. Entre ImageMagick 6.5.7-8 (1623) e ImageMagick 6.6.9-7 (1641), los ejes de $x e $y se volvieron a voltear a la funcionalidad anterior de ImageMagick 6.5.7-8 (1623).

Parámetros

width

El nuevo ancho

height

El nuevo alto

x

Posición X para el nuevo tamaño

y

Posición Y para el nuevo tamaño

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::resizeImage() - Escala una imagen
  • Imagick::thumbnailImage() - Cambia el tamaño de una imagen
  • Imagick::cropImage() - Extrae una región de la imagen


Description

  • « Imagick::extentImage
  • Imagick::flattenImages »
  • PHP Manual
  • Imagick
  • Description

Imagick::filter

(PECL imagick 3 >= 3.3.0)

Imagick::filter — Description

Advertencia

This function has been DEPRECATED as of Imagick 3.4.4. Relying on this function is highly discouraged.

Descripción

public Imagick::filter ( ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_UNDEFINED ) : bool

Applies a custom convolution kernel to the image.

Parámetros

ImagickKernel

An instance of ImagickKernel that represents either a single kernel or a linked series of kernels.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::filter()

<?php
function filter($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $matrix = [
        [-1, 0, -1],
        [0,  5,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $strength = 0.5;
    $kernel->scale($strength, \Imagick::NORMALIZE_KERNEL_VALUE);
    $kernel->addUnityKernel(1 - $strength);

    $imagick->filter($kernel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Fusiona una secuencia de imágenes

  • « Imagick::filter
  • Imagick::flipImage »
  • PHP Manual
  • Imagick
  • Fusiona una secuencia de imágenes

Imagick::flattenImages

(PECL imagick 2, PECL imagick 3)

Imagick::flattenImages — Fusiona una secuencia de imágenes

Descripción

Imagick::flattenImages ( ) : Imagick

Fusiona una secuencia de imágenes. Esto es útil para combinar capas de Photoshop en una sóla imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Crea una imagen espejo vertical

  • « Imagick::flattenImages
  • Imagick::floodFillPaintImage »
  • PHP Manual
  • Imagick
  • Crea una imagen espejo vertical

Imagick::flipImage

(PECL imagick 2, PECL imagick 3)

Imagick::flipImage — Crea una imagen espejo vertical

Descripción

Imagick::flipImage ( ) : bool

Crea una imagen espejo vertical reflejando los píxeles alrededor del eje x central.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::flipImage()

<?php
function flipImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->flipImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Cambia el valor del color de cualquier píxel que coincida con el objetivo

  • « Imagick::flipImage
  • Imagick::flopImage »
  • PHP Manual
  • Imagick
  • Cambia el valor del color de cualquier píxel que coincida con el objetivo

Imagick::floodFillPaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::floodFillPaintImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo

Descripción

Imagick::floodFillPaintImage ( mixed $fill , float $fuzz , mixed $target , int $x , int $y , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Cambia el valor del color de cualquier píxel que coincida con el objetivo y esté en el área inmediata. Este método es un sustituto del método obsoleto Imagick::paintFloodFillImage(). Este método está disponible si Imagick ha sido compilado con la versión 6.3.8 o superior de ImageMagick.

Parámetros

fill

Objeto ImagickPixel o una cadena que contiene el color de relleno

fuzz

La cantidad de difusión. Por ejemplo, setee fuzz a 10 y el color rojo a intensidades de 100 y 102 respectivamente son ahora interpretados como el mismo color.

target

Objeto ImagickPixel o una cadena que contiene el color objetivo a dibujar

x

Posición X del inicio del relleno

y

Posición Y del inicio del relleno

invert

Si es true se pinta cualquier píxel que no coincida con el color objetivo.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Ejemplo de Imagick::floodfillPaintImage()

<?php

/* Crear un nuevo objeto imagick */
$im = new Imagick();

/* Crear imágenes de color rojo, verde y azul */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Añadir las imágenes para que sean una */
$im->resetIterator();
$combinado = $im->appendImages(true);

/* Guardar la imagen intermedia para la comparación */
$combinado->writeImage("floodfillpaint_intermedia.png");

/* El píxel objetivo a pintar */
$x = 1;
$y = 1;

/* Obtener el color con el que vamos a pintar */
$objetivo = $combinado->getImagePixelColor($x, $y);

/* Pinta el píxel en la posición 1,1 negro y todos los píxeles
   cercanos que coincidan con el color objetivo */
$combinado->floodfillPaintImage("black", 1, $objetivo, $x, $y, false);

/* Guardar el resultado */
$combinado->writeImage("floodfillpaint_resultado.png");
?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Imagick::floodfillPaintImage()
Salida del ejemplo : Imagick::floodfillPaintImage()


Crea una imagen espejo horizontal

  • « Imagick::floodFillPaintImage
  • Imagick::forwardFourierTransformImage »
  • PHP Manual
  • Imagick
  • Crea una imagen espejo horizontal

Imagick::flopImage

(PECL imagick 2, PECL imagick 3)

Imagick::flopImage — Crea una imagen espejo horizontal

Descripción

Imagick::flopImage ( ) : bool

Crea una imagen espejo horizontal reflejando los píxeles alrededor del eje y central.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::flopImage()

<?php
function flopImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->flopImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::flopImage
  • Imagick::frameImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::forwardFourierTransformImage

(PECL imagick 3 >= 3.3.0)

Imagick::forwardFourierTransformImage — Description

Descripción

public Imagick::forwardFourierTransformimage ( bool $magnitude ) : bool

Implements the discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

Parámetros

magnitude

If true, return as magnitude / phase pair otherwise a real / imaginary image pair.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::forwardFourierTransformImage()

<?php
//Utility function for forwardTransformImage
function createMask() {
    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(0);
    $draw->setStrokeColor('rgb(255, 255, 255)');
    $draw->setFillColor('rgb(255, 255, 255)');

    //Draw a circle on the y-axis, with it's centre
    //at x, y that touches the origin
    $draw->circle(250, 250, 220, 250);

    $imagick = new \Imagick();
    $imagick->newImage(512, 512, "black");
    $imagick->drawImage($draw);
    $imagick->gaussianBlurImage(20, 20);
    $imagick->autoLevelImage();

    return $imagick;
}

function forwardFourierTransformImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->resizeimage(512, 512, \Imagick::FILTER_LANCZOS, 1);

    $mask = createMask();
    $imagick->forwardFourierTransformImage(true);

    @$imagick->setimageindex(0);
    $magnitude = $imagick->getimage();

    @$imagick->setimageindex(1);
    $imagickPhase = $imagick->getimage();

    if (true) {
        $imagickPhase->compositeImage($mask, \Imagick::COMPOSITE_MULTIPLY, 0, 0);
    }

    if (false) {
        $output = clone $imagickPhase;
        $output->setimageformat('png');
        header("Content-Type: image/png");
        echo $output->getImageBlob();
    }

    $magnitude->inverseFourierTransformImage($imagickPhase, true);

    $magnitude->setimageformat('png');
    header("Content-Type: image/png");
    echo $magnitude->getImageBlob();
}

?>


Añade un borde tridimensional simulado

  • « Imagick::forwardFourierTransformImage
  • Imagick::functionImage »
  • PHP Manual
  • Imagick
  • Añade un borde tridimensional simulado

Imagick::frameImage

(PECL imagick 2, PECL imagick 3)

Imagick::frameImage — Añade un borde tridimensional simulado

Descripción

Imagick::frameImage ( mixed $matte_color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : bool

Añade un borde tridimensional simulado alrededor de la imagen. El ancho y alto especifican el ancho del borde de las caras verticales y horizontales del marco. Los biseles interior y exterior indican el ancho de las sombras interiores y exteriores del marco.

Parámetros

matte_color

Objeto ImagickPixel o una cadena que representa el color mate

width

El ancho del borde

height

El alto del borde

inner_bevel

El ancho del bisel interior

outer_bevel

El ancho del bisel exterior

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como el primer parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::frameImage()

<?php
function frameImage($imagePath, $color, $width, $height, $innerBevel, $outerBevel) {
    $imagick = new \Imagick(realpath($imagePath));

    $width = $width + $innerBevel + $outerBevel;
    $height = $height + $innerBevel + $outerBevel;

    $imagick->frameimage(
        $color,
        $width,
        $height,
        $innerBevel,
        $outerBevel
    );
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Aplica una función a la imagen

  • « Imagick::frameImage
  • Imagick::fxImage »
  • PHP Manual
  • Imagick
  • Aplica una función a la imagen

Imagick::functionImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::functionImage — Aplica una función a la imagen

Descripción

public Imagick::functionImage ( int $function , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Aplica una expresión aritmética, relacional o lógica a una imagen.

Véase también » ImageMagick v6 Examples - Image Transformations — Function, Multi-Argument Evaluate

Este método está disponible si Imagick ha sido compilado con la versión 6.4.9 o superior de ImageMagick.

Parámetros

function

Consulte esta lista de constantes de función

arguments

Array de argumentos a pasar a esta función.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Crear un degradado sinusoide

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$argumentos = array(3, -90);
$imagick->functionImage(Imagick::FUNCTION_SINUSOID, $argumentos);

header("Content-Type: image/png");
$imagick->setImageFormat("png");
echo $imagick->getImageBlob();
?>

El resultado del ejemplo sería algo similar a:

Salida de crear un degradado sinusoidal

Ejemplo #2 Crear un degradado desde el polinomio (4x^2 - 4x + 1)

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$argumentos = array(4, -4, 1);
$imagick->functionImage(Imagick::FUNCTION_POLYNOMIAL, $argumentos);

header("Content-Type: image/png");
$imagick->setimageformat("png");
echo $imagick->getImageBlob();
?>

El resultado del ejemplo sería algo similar a:

Salida de crear un degradado polinómico

Ejemplo #3 Crear un degradao complejo a partir del polinomio (4x^2 - 4x^2 + 1) modulado por un degradao sinusoide

<?php
$imagick1 = new Imagick();
$imagick1->newPseudoImage(200, 200, 'gradient:black-white');
$argumentos = array(9, -90);
$imagick1->functionImage(Imagick::FUNCTION_SINUSOID, $argumentos);

$imagick2 = new Imagick();
$imagick2->newPseudoImage(200, 200, 'gradient:black-white');
$argumentos = array(0.5, 0);
$imagick2->functionImage(Imagick::FUNCTION_SINUSOID, $argumentos);
$imagick1->compositeimage($imagick2, Imagick::COMPOSITE_MULTIPLY, 0, 0);

header("Content-Type: image/png");
$imagick1->setImageFormat("png");
echo $imagick1->getImageBlob();
?>

El resultado del ejemplo sería algo similar a:

Salida de craer un degradado complejo


Evalúa una expresión por cada píxel de la imagen

  • « Imagick::functionImage
  • Imagick::gammaImage »
  • PHP Manual
  • Imagick
  • Evalúa una expresión por cada píxel de la imagen

Imagick::fxImage

(PECL imagick 2, PECL imagick 3)

Imagick::fxImage — Evalúa una expresión por cada píxel de la imagen

Descripción

Imagick::fxImage ( string $expression , int $channel = Imagick::CHANNEL_ALL ) : Imagick

Evalúa una expresión por cada píxel de la imagen. Consulte » El Operador de Imagen de Efectos Especiales Fx para más información.

Parámetros

expression

La expresión.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::fxImage()

<?php
function fxImage() {
    $imagick = new \Imagick();
    $imagick->newPseudoImage(200, 200, "xc:white");

    $fx = 'xx=i-w/2; yy=j-h/2; rr=hypot(xx,yy); (.5-rr/140)*1.2+.5';
    $fxImage = $imagick->fxImage($fx);

    header("Content-Type: image/png");
    $fxImage->setimageformat('png');
    echo $fxImage->getImageBlob();
}

?>


Corrección gamma de una imagen

  • « Imagick::fxImage
  • Imagick::gaussianBlurImage »
  • PHP Manual
  • Imagick
  • Corrección gamma de una imagen

Imagick::gammaImage

(PECL imagick 2, PECL imagick 3)

Imagick::gammaImage — Corrección gamma de una imagen

Descripción

Imagick::gammaImage ( float $gamma , int $channel = Imagick::CHANNEL_ALL ) : bool

Corrección gamma de una imagen. La misma imagen vista en diferentes dispositivos tendrá diferencias perceptuales en la manera en que la intensidad de la imagen esté representada en la pantalla. Especifique niveles gamma indivuduales para los canales rojo, verde y azul, o ajústelos todos con el parámetro gamma. El rango de valores es típicamente desde 0.8 a 2.3.

Parámetros

gamma

La cantidad de corrección gamma.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::gammaImage()

<?php
function gammaImage($imagePath, $gamma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->gammaImage($gamma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Hace borrosa una imagen

  • « Imagick::gammaImage
  • Imagick::getColorspace »
  • PHP Manual
  • Imagick
  • Hace borrosa una imagen

Imagick::gaussianBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::gaussianBlurImage — Hace borrosa una imagen

Descripción

Imagick::gaussianBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_ALL ) : bool

Hace borrosa una imagen. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y se seleccionará un radio adecuado automáticamente.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central.

sigma

La desviación estándar gaussiana, en píxeles.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::gaussianBlurImage()

<?php
function gaussianBlurImage($imagePath, $radius, $sigma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->gaussianBlurImage($radius, $sigma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Obtiene el espacio de color

  • « Imagick::gaussianBlurImage
  • Imagick::getCompression »
  • PHP Manual
  • Imagick
  • Obtiene el espacio de color

Imagick::getColorspace

(PECL imagick 3)

Imagick::getColorspace — Obtiene el espacio de color

Descripción

Imagick::getColorspace ( ) : int

Obtiene el valor del espacio de color global. Este método está disponible si Imagick ha sido compilado con la versión 6.5.7 o superior de ImageMagick.

Valores devueltos

Devuelve un entero que se puede comparar con constantes COLORSPACE.


Obtiene el tipo de compresión del objeto

  • « Imagick::getColorspace
  • Imagick::getCompressionQuality »
  • PHP Manual
  • Imagick
  • Obtiene el tipo de compresión del objeto

Imagick::getCompression

(PECL imagick 2, PECL imagick 3)

Imagick::getCompression — Obtiene el tipo de compresión del objeto

Descripción

Imagick::getCompression ( ) : int

Obtiene el tipo de compresión del objeto.

Valores devueltos

Devuelve la constante de compresión


Obtiene la calidad de compresión del objeto

  • « Imagick::getCompression
  • Imagick::getCopyright »
  • PHP Manual
  • Imagick
  • Obtiene la calidad de compresión del objeto

Imagick::getCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::getCompressionQuality — Obtiene la calidad de compresión del objeto

Descripción

Imagick::getCompressionQuality ( ) : int

Obtiene la calidad de compresión del objeto.

Valores devueltos

Devuelve un valor de tipo integer que describe la calidad de compresión


Devuelve el copyright de la API ImageMagick como una cadena

  • « Imagick::getCompressionQuality
  • Imagick::getFilename »
  • PHP Manual
  • Imagick
  • Devuelve el copyright de la API ImageMagick como una cadena

Imagick::getCopyright

(PECL imagick 2, PECL imagick 3)

Imagick::getCopyright — Devuelve el copyright de la API ImageMagick como una cadena

Descripción

Imagick::getCopyright ( ) : string

Devuelve el copyright de la API ImageMagick como una cadena.

Valores devueltos

Devuelve una cadena que contiene el anuncio del copyright de la API Imagemagick y de la API de C Magickwand.


El nombre de archivo asociado a una secuencia de imágenes

  • « Imagick::getCopyright
  • Imagick::getFont »
  • PHP Manual
  • Imagick
  • El nombre de archivo asociado a una secuencia de imágenes

Imagick::getFilename

(PECL imagick 2, PECL imagick 3)

Imagick::getFilename — El nombre de archivo asociado a una secuencia de imágenes

Descripción

Imagick::getFilename ( ) : string

El nombre de archivo asociado a una secuencia de imágenes.

Valores devueltos

Devuelve una cadena en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la fuente

  • « Imagick::getFilename
  • Imagick::getFormat »
  • PHP Manual
  • Imagick
  • Obtiene la fuente

Imagick::getFont

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::getFont — Obtiene la fuente

Descripción

Imagick::getFont ( ) : string

Devuelve la propiedad fuente de los objetos. Este método está disponible si Imagick ha sido compilado con la versión 6.3.7 o superior de ImageMagick.

Valores devueltos

Devuelve la cadena que contiene el nombre de la fuente o false si no está establecida la fuente.

Ver también

  • Imagick::setFont() - Establece el tipo de letra
  • ImagickDraw::setFont() - Establece la fuente especificada completamente para usarla cuando se escribe texto
  • ImagickDraw::getFont() - Devuelve la fuente


Devuelve el formato de un objeto Imagick

  • « Imagick::getFont
  • Imagick::getGravity »
  • PHP Manual
  • Imagick
  • Devuelve el formato de un objeto Imagick

Imagick::getFormat

(PECL imagick 2, PECL imagick 3)

Imagick::getFormat — Devuelve el formato de un objeto Imagick

Descripción

Imagick::getFormat ( ) : string

Devuelve el formato de un objeto Imagick.

Valores devueltos

Devuelve el formato de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la gravedad

  • « Imagick::getFormat
  • Imagick::getHomeURL »
  • PHP Manual
  • Imagick
  • Obtiene la gravedad

Imagick::getGravity

(PECL imagick 2, PECL imagick 3)

Imagick::getGravity — Obtiene la gravedad

Descripción

Imagick::getGravity ( ) : int

Obtiene la propiedad gravedad global para el objeto Imagick. Este método está disponible si Imagick ha sido compilado con la versión 6.4.0 o superior de ImageMagick.

Valores devueltos

Devuelve la propiedad gravedad. Consulte esta lista de constantes de gravedad.


Devuelve la URL de inicio de ImageMagick

  • « Imagick::getGravity
  • Imagick::getImage »
  • PHP Manual
  • Imagick
  • Devuelve la URL de inicio de ImageMagick

Imagick::getHomeURL

(PECL imagick 2, PECL imagick 3)

Imagick::getHomeURL — Devuelve la URL de inicio de ImageMagick

Descripción

Imagick::getHomeURL ( ) : string

Devuelve la URL de inicio de ImageMagick.

Valores devueltos

Devuelve un enlace a la página de inicio de imagemagick.


Devuelve un nuevo objeto Imagick

  • « Imagick::getHomeURL
  • Imagick::getImageAlphaChannel »
  • PHP Manual
  • Imagick
  • Devuelve un nuevo objeto Imagick

Imagick::getImage

(PECL imagick 2, PECL imagick 3)

Imagick::getImage — Devuelve un nuevo objeto Imagick

Descripción

Imagick::getImage ( ) : Imagick

Devuelve un nuevo objeto Imagick con la secuencia de imágenes actual.

Valores devueltos

Devuelve un nuevo objeto Imagick con la secuencia de imágenes actual.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el canal alfa de una imagen

  • « Imagick::getImage
  • Imagick::getImageArtifact »
  • PHP Manual
  • Imagick
  • Obtiene el canal alfa de una imagen

Imagick::getImageAlphaChannel

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageAlphaChannel — Obtiene el canal alfa de una imagen

Descripción

Imagick::getImageAlphaChannel ( ) : int

Obtiene el valor del canal alfa de la imagen. El valor devuelto es una de las constantes de canal alfa. Este método está disponible si Imagick ha sido compilado con la versión 6.4.0 o superior de ImageMagick.

Valores devueltos

Devuelve una constante que define el valor del canal alfa actual. Consulte esta lista de constantes de canal alfa.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtener el artefacto de imagen

  • « Imagick::getImageAlphaChannel
  • Imagick::getImageAttribute »
  • PHP Manual
  • Imagick
  • Obtener el artefacto de imagen

Imagick::getImageArtifact

(PECL imagick 3)

Imagick::getImageArtifact — Obtener el artefacto de imagen

Descripción

Imagick::getImageArtifact ( string $artifact ) : string

Obtiene un artefacto asociado con la imagen. La diferencia entre las propiedades de imagen y los artefactos de imagen es que las propiedades son públicas y los artefactos son privados. Este método está disponible si Imagick ha sido compilado con la versión 6.5.7 o superior de ImageMagick.

Parámetros

artifact

El nombre del artefacto

Valores devueltos

Devuelve el valor del artefacto si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::setImageArtifact() - Establecer un artefacto de imagen
  • Imagick::deleteImageArtifact() - Borra un artefacto de imagen


Description

  • « Imagick::getImageArtifact
  • Imagick::getImageBackgroundColor »
  • PHP Manual
  • Imagick
  • Description

Imagick::getImageAttribute

(PECL imagick 2, PECL imagick 3)

Imagick::getImageAttribute — Description

Advertencia

This function has been DEPRECATED as of Imagick 3.4.4. Relying on this function is highly discouraged.

Descripción

public Imagick::getImageAttribute ( string $key ) : string

Returns a named attribute.

Parámetros

key

The key of the attribute to get.

Valores devueltos


Devuelve el color de fondo de la imagen

  • « Imagick::getImageAttribute
  • Imagick::getImageBlob »
  • PHP Manual
  • Imagick
  • Devuelve el color de fondo de la imagen

Imagick::getImageBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBackgroundColor — Devuelve el color de fondo de la imagen

Descripción

Imagick::getImageBackgroundColor ( ) : ImagickPixel

Devuelve el color de fondo de la imagen.

Valores devueltos

Devuelve un objeto ImagickPixel establecido al color de fondo de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la secuencia de imágenes como un valor de tipo blob

  • « Imagick::getImageBackgroundColor
  • Imagick::getImageBluePrimary »
  • PHP Manual
  • Imagick
  • Devuelve la secuencia de imágenes como un valor de tipo blob

Imagick::getImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBlob — Devuelve la secuencia de imágenes como un valor de tipo blob

Descripción

Imagick::getImageBlob ( ) : string

Implementa, directo a la memoria, formatos de imagen. Devuelve la secuencia de imágenes como una cadena. El formato de la imagen determina el formato del blob devuelto (GIF, JPEG, PNG, etc.). Para devolver un formato de imagen diferente use Imagick::setImageFormat().

Valores devueltos

Devuelve una cadena que contiene la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el punto primario azul de la cromaticidad

  • « Imagick::getImageBlob
  • Imagick::getImageBorderColor »
  • PHP Manual
  • Imagick
  • Devuelve el punto primario azul de la cromaticidad

Imagick::getImageBluePrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBluePrimary — Devuelve el punto primario azul de la cromaticidad

Descripción

Imagick::getImageBluePrimary ( ) : array

Devuelve el punto primario azul de la cromaticidad de una imagen.

Parámetros

x

El punto x primario azul de la cromaticidad.

y

El punto y primario azul de la cromaticidad.

Valores devueltos

Matriz consistente en las coordenadas "x" e "y" del punto.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el color del borde de la imagen

  • « Imagick::getImageBluePrimary
  • Imagick::getImageChannelDepth »
  • PHP Manual
  • Imagick
  • Devuelve el color del borde de la imagen

Imagick::getImageBorderColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBorderColor — Devuelve el color del borde de la imagen

Descripción

Imagick::getImageBorderColor ( ) : ImagickPixel

Devuelve el color del borde de la imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la profundidad de un canal de imagen en particular

  • « Imagick::getImageBorderColor
  • Imagick::getImageChannelDistortion »
  • PHP Manual
  • Imagick
  • Obtiene la profundidad de un canal de imagen en particular

Imagick::getImageChannelDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelDepth — Obtiene la profundidad de un canal de imagen en particular

Descripción

Imagick::getImageChannelDepth ( int $channel ) : int

Obtiene la profundidad de un canal de imagen en particular.

Parámetros

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.


Compara los canales de imagen de una imagen con una imagen reconstruida

  • « Imagick::getImageChannelDepth
  • Imagick::getImageChannelDistortions »
  • PHP Manual
  • Imagick
  • Compara los canales de imagen de una imagen con una imagen reconstruida

Imagick::getImageChannelDistortion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelDistortion — Compara los canales de imagen de una imagen con una imagen reconstruida

Descripción

Imagick::getImageChannelDistortion ( Imagick $reference , int $channel , int $metric ) : float

Compara uno o más canales de imagen de una imagen con una imagen reconstruida y devuelve la métrica de distorsión especificada.

Parámetros

reference

Objeto Imagick que se va a comparar.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

metric

Una de las constantes de tipo de métrica.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene las distorsiones del canal

  • « Imagick::getImageChannelDistortion
  • Imagick::getImageChannelExtrema »
  • PHP Manual
  • Imagick
  • Obtiene las distorsiones del canal

Imagick::getImageChannelDistortions

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageChannelDistortions — Obtiene las distorsiones del canal

Descripción

Imagick::getImageChannelDistortions ( Imagick $reference , int $metric , int $channel = Imagick::CHANNEL_DEFAULT ) : float

Compara uno o más canales de imagen de una imagen con una imagen reconstruida y devuelve las métricas de la distorsión especificada Este método está disponible si Imagick ha sido compilado con la versión 6.4.4 o superior de ImageMagick.

Parámetros

reference

Objeto Imagick que contiene la imagen de referencia

metric

Consulte esta lista de constantes de tipo de métrica.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve un valor de tipo double que describe la distorsión del canal.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene los extremos de uno o más canales de imagen

  • « Imagick::getImageChannelDistortions
  • Imagick::getImageChannelKurtosis »
  • PHP Manual
  • Imagick
  • Obtiene los extremos de uno o más canales de imagen

Imagick::getImageChannelExtrema

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelExtrema — Obtiene los extremos de uno o más canales de imagen

Descripción

Imagick::getImageChannelExtrema ( int $channel ) : array

Obtiene los extremos (mínimo y máximo) de uno o más canales de imagen. El valor devuelto es una matriz asociativa con las claves "minima" (mínimo) y "maxima" (máximo).

Parámetros

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la curtosis y la asimetría estadística de un canal específico

  • « Imagick::getImageChannelExtrema
  • Imagick::getImageChannelMean »
  • PHP Manual
  • Imagick
  • Obtiene la curtosis y la asimetría estadística de un canal específico

Imagick::getImageChannelKurtosis

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageChannelKurtosis — Obtiene la curtosis y la asimetría estadística de un canal específico

Descripción

public Imagick::getImageChannelKurtosis ( int $channel = Imagick::CHANNEL_DEFAULT ) : array

Obtiene la curtosis y la asimetría estadística de un canal específico. Este método está disponible si Imagick ha sido compilado con la versión 6.4.9 o superior de ImageMagick.

Parámetros

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve una matriz con los miembros kurtosis (curtosis) y skewness (asimetría estadística).

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la media y la desviación estándar

  • « Imagick::getImageChannelKurtosis
  • Imagick::getImageChannelRange »
  • PHP Manual
  • Imagick
  • Obtiene la media y la desviación estándar

Imagick::getImageChannelMean

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelMean — Obtiene la media y la desviación estándar

Descripción

Imagick::getImageChannelMean ( int $channel ) : array

Obtiene la media y la desviación estándar de uno o más canales de imagen. El valor devuelto es una matriz asociativa con las claves "mean" (media) y "standardDeviation" (desviación estándar).

Parámetros

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el rango del canal

  • « Imagick::getImageChannelMean
  • Imagick::getImageChannelStatistics »
  • PHP Manual
  • Imagick
  • Obtiene el rango del canal

Imagick::getImageChannelRange

(PECL imagick 2 >= 2.2.1, PECL imagick 3)

Imagick::getImageChannelRange — Obtiene el rango del canal

Descripción

Imagick::getImageChannelRange ( int $channel ) : array

Obtiene el rango de uno o más canales de imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.4.0 o superior de ImageMagick.

Parámetros

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve una matriz que contiene los valores mínimo y máximo de el/los canal/es.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve las estadísticas de cada canal de la imagen

  • « Imagick::getImageChannelRange
  • Imagick::getImageClipMask »
  • PHP Manual
  • Imagick
  • Devuelve las estadísticas de cada canal de la imagen

Imagick::getImageChannelStatistics

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelStatistics — Devuelve las estadísticas de cada canal de la imagen

Descripción

Imagick::getImageChannelStatistics ( ) : array

Devuelve las estadísticas de cada canal de la imagen. Las estadísticas incluyen la profundidad del canal, su mínimo y máximo, la media, y la desviación estándar. Se puede acceder a la media del canal rojo, por ejemplo, así:

Valores devueltos

Devuelve true en caso de éxito.


Obtiene la máscara de recorte de la imagen

  • « Imagick::getImageChannelStatistics
  • Imagick::getImageColormapColor »
  • PHP Manual
  • Imagick
  • Obtiene la máscara de recorte de la imagen

Imagick::getImageClipMask

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageClipMask — Obtiene la máscara de recorte de la imagen

Descripción

Imagick::getImageClipMask ( ) : Imagick

Devuelve la máscara de recorte de la imagen. La máscara de recorte es un objeto Imagick que contiene la máscara de recorte. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Valores devueltos

Devuelve un objeto Imagick que contiene la máscara de recorte.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el color del índice del mapa de colores especficado

  • « Imagick::getImageClipMask
  • Imagick::getImageColors »
  • PHP Manual
  • Imagick
  • Devuelve el color del índice del mapa de colores especficado

Imagick::getImageColormapColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColormapColor — Devuelve el color del índice del mapa de colores especficado

Descripción

Imagick::getImageColormapColor ( int $index ) : ImagickPixel

Devuelve el color del índice del mapa de colores especficado.

Parámetros

index

El índice en el mapa de colores de la imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el número de colores únicos de la imagen

  • « Imagick::getImageColormapColor
  • Imagick::getImageColorspace »
  • PHP Manual
  • Imagick
  • Obtiene el número de colores únicos de la imagen

Imagick::getImageColors

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColors — Obtiene el número de colores únicos de la imagen

Descripción

Imagick::getImageColors ( ) : int

Obtiene el número de colores únicos de la imagen.

Valores devueltos

Devuelve true en caso de éxito.


Obtiene el espacio de color de la imagen

  • « Imagick::getImageColors
  • Imagick::getImageCompose »
  • PHP Manual
  • Imagick
  • Obtiene el espacio de color de la imagen

Imagick::getImageColorspace

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColorspace — Obtiene el espacio de color de la imagen

Descripción

Imagick::getImageColorspace ( ) : int

Obtiene el espacio de color de la imagen.

Valores devueltos

Devuelve un entero que se puede comparar con constantes COLORSPACE.


Devuelve el operador de composición asociado a la imagen

  • « Imagick::getImageColorspace
  • Imagick::getImageCompression »
  • PHP Manual
  • Imagick
  • Devuelve el operador de composición asociado a la imagen

Imagick::getImageCompose

(PECL imagick 2, PECL imagick 3)

Imagick::getImageCompose — Devuelve el operador de composición asociado a la imagen

Descripción

Imagick::getImageCompose ( ) : int

Devuelve el operador de composición asociado a la imagen.

Valores devueltos

Devuelve true en caso de éxito.


Obtiene el tipo de compresión de la imagen actual

  • « Imagick::getImageCompose
  • Imagick::getImageCompressionQuality »
  • PHP Manual
  • Imagick
  • Obtiene el tipo de compresión de la imagen actual

Imagick::getImageCompression

(PECL imagick 3 >= 3.3.0)

Imagick::getImageCompression — Obtiene el tipo de compresión de la imagen actual

Descripción

Imagick::getImageCompression ( ) : int

Obtiene el tipo de compresión de la imagen actual.

Valores devueltos

Devuelve la constante de compresión


Obtiene la calidad de compresión de la imagen actual

  • « Imagick::getImageCompression
  • Imagick::getImageDelay »
  • PHP Manual
  • Imagick
  • Obtiene la calidad de compresión de la imagen actual

Imagick::getImageCompressionQuality

(PECL imagick 2 >= 2.2.2, PECL imagick 3)

Imagick::getImageCompressionQuality — Obtiene la calidad de compresión de la imagen actual

Descripción

Imagick::getImageCompressionQuality ( ) : int

Obtiene la calidad de compresión de la imagen actual

Valores devueltos

Devuelve un valor de tipo integer que describe la calidad de compresión de las imágenes


Obtiene el retraso de la imagen

  • « Imagick::getImageCompressionQuality
  • Imagick::getImageDepth »
  • PHP Manual
  • Imagick
  • Obtiene el retraso de la imagen

Imagick::getImageDelay

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDelay — Obtiene el retraso de la imagen

Descripción

Imagick::getImageDelay ( ) : int

Obtiene el retraso de la imagen.

Valores devueltos

Devuelve el retraso de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la profundidad de la imagen

  • « Imagick::getImageDelay
  • Imagick::getImageDispose »
  • PHP Manual
  • Imagick
  • Obtiene la profundidad de la imagen

Imagick::getImageDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDepth — Obtiene la profundidad de la imagen

Descripción

Imagick::getImageDepth ( ) : int

Obtiene la profundidad de la imagen.

Valores devueltos

La profundidad de la imagen.


Obtiene el método de disposición de la imagen

  • « Imagick::getImageDepth
  • Imagick::getImageDistortion »
  • PHP Manual
  • Imagick
  • Obtiene el método de disposición de la imagen

Imagick::getImageDispose

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDispose — Obtiene el método de disposición de la imagen

Descripción

Imagick::getImageDispose ( ) : int

Obtiene el método de disposición de la imagen.

Valores devueltos

Devuelve el método de disposición si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Compara una imagen con una imagen reconstruida

  • « Imagick::getImageDispose
  • Imagick::getImageExtrema »
  • PHP Manual
  • Imagick
  • Compara una imagen con una imagen reconstruida

Imagick::getImageDistortion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDistortion — Compara una imagen con una imagen reconstruida

Descripción

Imagick::getImageDistortion ( MagickWand $reference , int $metric ) : float

Compara una imagen con una imagen reconstruida y devuelve la métrica de distorisión especificada.

Parámetros

reference

Objeto Imagick que se va a comparar.

metric

Una de las constantes de tipo de métrica.

Valores devueltos

Devuelve la métrica de distorsión usada en la imagen (o la mejor deducción de la misma).

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene los extremos de la imagen

  • « Imagick::getImageDistortion
  • Imagick::getImageFilename »
  • PHP Manual
  • Imagick
  • Obtiene los extremos de la imagen

Imagick::getImageExtrema

(PECL imagick 2, PECL imagick 3)

Imagick::getImageExtrema — Obtiene los extremos de la imagen

Descripción

Imagick::getImageExtrema ( ) : array

Obtiene los extremos (mínimo y máximo) de la imagen. Devuelve una matriz asociativa con las claves "min" y "max".

Valores devueltos

Devuelve una matriz asociativa con las claves "min" y "max".

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el nombre de archivo de una imagen en particular de una secuencia

  • « Imagick::getImageExtrema
  • Imagick::getImageFormat »
  • PHP Manual
  • Imagick
  • Devuelve el nombre de archivo de una imagen en particular de una secuencia

Imagick::getImageFilename

(PECL imagick 2, PECL imagick 3)

Imagick::getImageFilename — Devuelve el nombre de archivo de una imagen en particular de una secuencia

Descripción

Imagick::getImageFilename ( ) : string

Devuelve el nombre de archivo de una imagen en particular de una secuencia.

Valores devueltos

Devuelve una cadena con el nombre de archivo de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el formato de una imagen en particular de una secuencia

  • « Imagick::getImageFilename
  • Imagick::getImageGamma »
  • PHP Manual
  • Imagick
  • Devuelve el formato de una imagen en particular de una secuencia

Imagick::getImageFormat

(PECL imagick 2, PECL imagick 3)

Imagick::getImageFormat — Devuelve el formato de una imagen en particular de una secuencia

Descripción

Imagick::getImageFormat ( ) : string

Devuelve el formato de una imagen en particular de una secuencia.

Valores devueltos

Devuelve una cadena que contiene el formato de imagen si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el valor gamma de la imagen

  • « Imagick::getImageFormat
  • Imagick::getImageGeometry »
  • PHP Manual
  • Imagick
  • Obtiene el valor gamma de la imagen

Imagick::getImageGamma

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGamma — Obtiene el valor gamma de la imagen

Descripción

Imagick::getImageGamma ( ) : float

Obtiene el valor gamma de la imagen.

Valores devueltos

Devuelve el valor gamma de la imagen si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el ancho y el alto como un array asociativo

  • « Imagick::getImageGamma
  • Imagick::getImageGravity »
  • PHP Manual
  • Imagick
  • Obtiene el ancho y el alto como un array asociativo

Imagick::getImageGeometry

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGeometry — Obtiene el ancho y el alto como un array asociativo

Descripción

Imagick::getImageGeometry ( ) : array

Obtiene el ancho y el alto como un array asociativo.

Valores devueltos

Devuelve un array con el ancho/alto de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::getImageGeometry()

<?php
function getImageGeometry($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Obtiene la gravedad de la imagen

  • « Imagick::getImageGeometry
  • Imagick::getImageGreenPrimary »
  • PHP Manual
  • Imagick
  • Obtiene la gravedad de la imagen

Imagick::getImageGravity

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageGravity — Obtiene la gravedad de la imagen

Descripción

Imagick::getImageGravity ( ) : int

Obtiene el valor de gravedad actual de la imagen. A diferencia de Imagick::getGravity(), este método devuelve la gravedad definida para la secuencia de imágenes actual. Este método está disponible si Imagick ha sido compilado con la versión 6.4.4 o superior de ImageMagick.

Valores devueltos

Devuelve la propiedad gravedad de las imágenes. Consulte esta lista de constantes de gravedad.


Devuelve el punto primario verde de la cromaticidad

  • « Imagick::getImageGravity
  • Imagick::getImageHeight »
  • PHP Manual
  • Imagick
  • Devuelve el punto primario verde de la cromaticidad

Imagick::getImageGreenPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGreenPrimary — Devuelve el punto primario verde de la cromaticidad

Descripción

Imagick::getImageGreenPrimary ( ) : array

Devuelve el punto primario verde de la cromaticidad. Devuelve un array con las claves "x" e "y".

Valores devueltos

Devuelve un array con las claves "x" e "y" si se tuvo éxito, lanza una ImagickException en caso de error.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el alto de la imagen

  • « Imagick::getImageGreenPrimary
  • Imagick::getImageHistogram »
  • PHP Manual
  • Imagick
  • Devuelve el alto de la imagen

Imagick::getImageHeight

(PECL imagick 2, PECL imagick 3)

Imagick::getImageHeight — Devuelve el alto de la imagen

Descripción

Imagick::getImageHeight ( ) : int

Devuelve el alto de la imagen.

Valores devueltos

Devuelve el alto de la imagen en píxeles.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el histograma de la imagen

  • « Imagick::getImageHeight
  • Imagick::getImageIndex »
  • PHP Manual
  • Imagick
  • Obtiene el histograma de la imagen

Imagick::getImageHistogram

(PECL imagick 2, PECL imagick 3)

Imagick::getImageHistogram — Obtiene el histograma de la imagen

Descripción

Imagick::getImageHistogram ( ) : array

Devuelve el histograma de la imagen como un array de objetos ImagickPixel.

Valores devueltos

Devuelve el histograma de la imagen como un array de objetos ImagickPixel.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Generates Imagick::getImageHistogram()

<?php
function getColorStatistics($histogramElements, $colorChannel) {
    $colorStatistics = [];

    foreach ($histogramElements as $histogramElement) {
        $color = $histogramElement->getColorValue($colorChannel);
        $color = intval($color * 255);
        $count = $histogramElement->getColorCount();

        if (array_key_exists($color, $colorStatistics)) {
            $colorStatistics[$color] += $count;
        }
        else {
            $colorStatistics[$color] = $count;
        }
    }

    ksort($colorStatistics);

    return $colorStatistics;
}

function getImageHistogram($imagePath) {

    $backgroundColor = 'black';

    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(0); //hacer que las líneas sean lo más finas posibles

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    $histogramWidth = 256;
    $histogramHeight = 100; // the height for each RGB segment

    $imagick = new \Imagick(realpath($imagePath));
    //Hacer la imagen pequeña, de lo contrario PHP tiende a quedarse sin memoria
    //Esto podría conducir a resultados erróneos con imágenes que estén patológicamente 'pixeladas'
    $imagick->adaptiveResizeImage(200, 200, true);
    $histogramElements = $imagick->getImageHistogram();

    $histogram = new \Imagick();
    $histogram->newpseudoimage($histogramWidth, $histogramHeight * 3, 'xc:black');
    $histogram->setImageFormat('png');

    $getMax = function ($carry, $item)  {
        if ($item > $carry) {
            return $item;
        }
        return $carry;
    };

    $colorValues = [
        'red' => getColorStatistics($histogramElements, \Imagick::COLOR_RED),
        'lime' => getColorStatistics($histogramElements, \Imagick::COLOR_GREEN),
        'blue' => getColorStatistics($histogramElements, \Imagick::COLOR_BLUE),
    ];

    $max = array_reduce($colorValues['red'] , $getMax, 0);
    $max = array_reduce($colorValues['lime'] , $getMax, $max);
    $max = array_reduce($colorValues['blue'] , $getMax, $max);

    $scale =  $histogramHeight / $max;

    $count = 0;
    foreach ($colorValues as $color => $values) {
        $draw->setstrokecolor($color);

        $offset = ($count + 1) * $histogramHeight;

        foreach ($values as $index => $value) {
            $draw->line($index, $offset, $index, $offset - ($value * $scale));
        }
        $count++;
    }

    $histogram->drawImage($draw);

    header( "Content-Type: image/png" );
    echo $histogram;
}

?>


Obtiene el índice de la imagen activa actual

  • « Imagick::getImageHistogram
  • Imagick::getImageInterlaceScheme »
  • PHP Manual
  • Imagick
  • Obtiene el índice de la imagen activa actual

Imagick::getImageIndex

(PECL imagick 2, PECL imagick 3)

Imagick::getImageIndex — Obtiene el índice de la imagen activa actual

Descripción

Imagick::getImageIndex ( ) : int

Devuelve el índice de la imagen activa actual dentro del objeto Imagick. Este método ha quedado obsoleto. Véase Imagick::getIteratorIndex().

Valores devueltos

Devuelve un valor de tipo integer que contiene el índice de la imagen en la pila.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la combinación de entrelazado de la imagen

  • « Imagick::getImageIndex
  • Imagick::getImageInterpolateMethod »
  • PHP Manual
  • Imagick
  • Obtiene la combinación de entrelazado de la imagen

Imagick::getImageInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::getImageInterlaceScheme — Obtiene la combinación de entrelazado de la imagen

Descripción

Imagick::getImageInterlaceScheme ( ) : int

Obtiene la combinación de entrelazado de la imagen.

Valores devueltos

Devuelve la combinación de entrelazado como un integer en caso de éxito. Lanza ImagickException en caso de error.


Devuelve el método de interpolación

  • « Imagick::getImageInterlaceScheme
  • Imagick::getImageIterations »
  • PHP Manual
  • Imagick
  • Devuelve el método de interpolación

Imagick::getImageInterpolateMethod

(PECL imagick 2, PECL imagick 3)

Imagick::getImageInterpolateMethod — Devuelve el método de interpolación

Descripción

Imagick::getImageInterpolateMethod ( ) : int

Devuelve el método de interpolación de la imagen especificada. El método es una de las constantes Imagick::INTERPOLATE_*.

Valores devueltos

Devuelve el método de interpolación si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene las iteraciones de la imagen

  • « Imagick::getImageInterpolateMethod
  • Imagick::getImageLength »
  • PHP Manual
  • Imagick
  • Obtiene las iteraciones de la imagen

Imagick::getImageIterations

(PECL imagick 2, PECL imagick 3)

Imagick::getImageIterations — Obtiene las iteraciones de la imagen

Descripción

Imagick::getImageIterations ( ) : int

Obtiene las iteraciones de la imagen.

Valores devueltos

Devuelve las iteraciones de la imagen como un valor integer.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la longitud de la imagen en bytes

  • « Imagick::getImageIterations
  • Imagick::getImageMatte »
  • PHP Manual
  • Imagick
  • Devuelve la longitud de la imagen en bytes

Imagick::getImageLength

(PECL imagick 2, PECL imagick 3)

Imagick::getImageLength — Devuelve la longitud de la imagen en bytes

Descripción

Imagick::getImageLength ( ) : int

Devuelve la longitud de la imagen en bytes

Valores devueltos

Devuelve un valor de tipo int que contiene el tamaño de la imagen actual.

Ejemplos

Ejemplo #1 Usar Imagick::getImageLength():

Obtener la longitud en bytes

<?php
$imagen = new Imagick('prueba.jpg');
echo $imagen->getImageLength() . ' bytes';
?>


Devuelve si la imagen tiene un canal mate

  • « Imagick::getImageLength
  • Imagick::getImageMatteColor »
  • PHP Manual
  • Imagick
  • Devuelve si la imagen tiene un canal mate

Imagick::getImageMatte

(PECL imagick 2, PECL imagick 3)

Imagick::getImageMatte — Devuelve si la imagen tiene un canal mate

Descripción

Imagick::getImageMatte ( ) : bool

Devuelve true si la imagen tiene un canal mate, en caso contrario false. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve el color mate de la imagen

  • « Imagick::getImageMatte
  • Imagick::getImageMimeType »
  • PHP Manual
  • Imagick
  • Devuelve el color mate de la imagen

Imagick::getImageMatteColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageMatteColor — Devuelve el color mate de la imagen

Descripción

Imagick::getImageMatteColor ( ) : ImagickPixel

Devuelve el color mate de la imagen.

Valores devueltos

Devuelve un objeto ImagickPixel si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Description

  • « Imagick::getImageMatteColor
  • Imagick::getImageOrientation »
  • PHP Manual
  • Imagick
  • Description

Imagick::getImageMimeType

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageMimeType — Description

Descripción

public Imagick::getImageMimeType ( ) : string

Returns the image mime-type.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene la orientación de la imagen

  • « Imagick::getImageMimeType
  • Imagick::getImagePage »
  • PHP Manual
  • Imagick
  • Obtiene la orientación de la imagen

Imagick::getImageOrientation

(PECL imagick 2, PECL imagick 3)

Imagick::getImageOrientation — Obtiene la orientación de la imagen

Descripción

Imagick::getImageOrientation ( ) : int

Obtiene la orientación de la imagen. El valor de retorno es una de las constantes de orientación.

Valores devueltos

Devuelve un integer si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la geometría de la página

  • « Imagick::getImageOrientation
  • Imagick::getImagePixelColor »
  • PHP Manual
  • Imagick
  • Devuelve la geometría de la página

Imagick::getImagePage

(PECL imagick 2, PECL imagick 3)

Imagick::getImagePage — Devuelve la geometría de la página

Descripción

Imagick::getImagePage ( ) : array

Devuelve la geometría de la página asociada con la imagen en un array con las claves "width", "height", "x", e "y".

Valores devueltos

Devuelve la geometría de la página asociada con la imagen en un array con las claves "width", "height", "x", e "y".

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el color del píxel especificado

  • « Imagick::getImagePage
  • Imagick::getImageProfile »
  • PHP Manual
  • Imagick
  • Devuelve el color del píxel especificado

Imagick::getImagePixelColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImagePixelColor — Devuelve el color del píxel especificado

Descripción

Imagick::getImagePixelColor ( int $x , int $y ) : ImagickPixel

Devuelve el color del píxel especificado.

Parámetros

x

La coordenada x del píxel

y

La coordenada y del píxel

Valores devueltos

Devuelve una instancia de ImagickPixel para el color en las coordenadas dadas.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el perfil nominado de la imagen

  • « Imagick::getImagePixelColor
  • Imagick::getImageProfiles »
  • PHP Manual
  • Imagick
  • Devuelve el perfil nominado de la imagen

Imagick::getImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProfile — Devuelve el perfil nominado de la imagen

Descripción

Imagick::getImageProfile ( string $name ) : string

Devuelve el perfil nominado de la imagen.

Parámetros

name

El nombre del perfil que se va a devolver.

Valores devueltos

Devuelve un string que contiene el perfil de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve los perfiles de la imagen

  • « Imagick::getImageProfile
  • Imagick::getImageProperties »
  • PHP Manual
  • Imagick
  • Devuelve los perfiles de la imagen

Imagick::getImageProfiles

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProfiles — Devuelve los perfiles de la imagen

Descripción

Imagick::getImageProfiles ( string $pattern = "*" , bool $only_names = true ) : array

Devuelve todos los perfiles asociados que coinciden con el patrón. Si se pasa true como segundo parámetro, sólo se devuelven los nombres de los perfiles. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

pattern

El patrón para los nombres de los perfiles.

only_names

Si se devuelve sólo los nombres de los perfiles. Si es false también se devuelven los valores

Valores devueltos

Devuelve un array que contiene los perfiles de la imagen o los nombres de los perfiles.


Devuelve las propiedades de la imagen

  • « Imagick::getImageProfiles
  • Imagick::getImageProperty »
  • PHP Manual
  • Imagick
  • Devuelve las propiedades de la imagen

Imagick::getImageProperties

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProperties — Devuelve las propiedades de la imagen

Descripción

Imagick::getImageProperties ( string $pattern = "*" , bool $only_names = true ) : array

Devuelve todas las propiedades asociadas que coniciden con el patrón. Si se pasa true como segundo parámetro, sólo se devuelven los nombres de las propiedades. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

pattern

El patrón para los nombres de las propiedades.

only_names

Si se devuelve sólo los nombres de las propiedades. Si es false también se devuelven los valores

Valores devueltos

Devuelve un array que contiene las propiedades de la imagen o los nombres de las propiedades.

Ejemplos

Ejemplo #1 Usar Imagick::getImageProperties():

Un ejemplo de extraer la imformación EXIF.

<?php

/* Crear el objeto */
$im = new imagick("/path/to/ejemplo.jpg");

/* Obtener la información EXIF */
$matrizExif = $im->getImageProperties("exif:*");

/* Realizar un bucle a través de las propiedades EXIF */
foreach ($matrizExif as $nombre => $propiedad)
{
    echo "{$nombre} => {$propiedad}<br />\n";
}

?>


Devuelve la propiedad nominada de la imagen

  • « Imagick::getImageProperties
  • Imagick::getImageRedPrimary »
  • PHP Manual
  • Imagick
  • Devuelve la propiedad nominada de la imagen

Imagick::getImageProperty

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProperty — Devuelve la propiedad nominada de la imagen

Descripción

Imagick::getImageProperty ( string $name ) : string

Devuelve la propiedad nominada de la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.3.2 o superior de ImageMagick.

Parámetros

name

nombre de la propiedad (por ejemplo Exif:DateTime)

Ejemplos

Ejemplo #1 Usando Imagick::getImageProperty():

Establecer y obtener la propiedad de la imagen

<?php
$imagen = new Imagick();
$imagen->newImage(300, 200, "black");

$imagen->setImageProperty('Exif:Make', 'Imagick');
echo $imagen->getImageProperty('Exif:Make');
?>

Ver también

  • Imagick::setImageProperty() - Establece una propiedad de la imagen

Valores devueltos

Devuelve un string que contiene la propiedad de la imagen, false si no existe una propiedad con el nombre dado.


Devuelve el punto primario rojo de la cromaticidad

  • « Imagick::getImageProperty
  • Imagick::getImageRegion »
  • PHP Manual
  • Imagick
  • Devuelve el punto primario rojo de la cromaticidad

Imagick::getImageRedPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRedPrimary — Devuelve el punto primario rojo de la cromaticidad

Descripción

Imagick::getImageRedPrimary ( ) : array

Devuelve el punto primario rojo de la cromaticidad como un array con las claves "x" e "y".

Valores devueltos

Devuelve el punto primario rojo de la cromaticidad como un array con las claves "x" e "y". Lanza ImagickException en caso de error.

Errores/Excepciones

Lanza ImagickException en caso de error.


Extrae una región de la imagen

  • « Imagick::getImageRedPrimary
  • Imagick::getImageRenderingIntent »
  • PHP Manual
  • Imagick
  • Extrae una región de la imagen

Imagick::getImageRegion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRegion — Extrae una región de la imagen

Descripción

Imagick::getImageRegion ( int $width , int $height , int $x , int $y ) : Imagick

Extrae una región de la imagen y la devuelve como un nuevo objeto Imagick.

Parámetros

width

El ancho de la región extraída.

height

El alto de la región extraída.

x

Coordenada X de la esquina superior izquierda de la región extraída.

y

Coordenada Y de la esquina superior izquierda de la región extraída.

Valores devueltos

Extrae una región de la imagen y la devuleve como una nueva varita mágica.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el propósito de renderización de la imagen

  • « Imagick::getImageRegion
  • Imagick::getImageResolution »
  • PHP Manual
  • Imagick
  • Obtiene el propósito de renderización de la imagen

Imagick::getImageRenderingIntent

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRenderingIntent — Obtiene el propósito de renderización de la imagen

Descripción

Imagick::getImageRenderingIntent ( ) : int

Obtiene el propósito de renderización de la imagen.

Valores devueltos

Devuelve el propósito de renderización de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la resolución X e Y de la imagen

  • « Imagick::getImageRenderingIntent
  • Imagick::getImagesBlob »
  • PHP Manual
  • Imagick
  • Obtiene la resolución X e Y de la imagen

Imagick::getImageResolution

(PECL imagick 2, PECL imagick 3)

Imagick::getImageResolution — Obtiene la resolución X e Y de la imagen

Descripción

Imagick::getImageResolution ( ) : array

Obtiene la resolución X e Y de la imagen.

Valores devueltos

Devuelve la resolución como un array.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve todas las secuencias de imágenes como un blob

  • « Imagick::getImageResolution
  • Imagick::getImageScene »
  • PHP Manual
  • Imagick
  • Devuelve todas las secuencias de imágenes como un blob

Imagick::getImagesBlob

(PECL imagick 2, PECL imagick 3)

Imagick::getImagesBlob — Devuelve todas las secuencias de imágenes como un blob

Descripción

Imagick::getImagesBlob ( ) : string

Implementa directo a la memoria formatos de imagen. Desvuelve todas las secuencias de imágenes como un string. El formato de la imagen determina el formato del blob devuelto (GIF, JPEG, PNG, etc.). Para devolver un formato de imagen diferente use Imagick::setImageFormat().

Valores devueltos

Devuelve un string que contiene las imágenes. En caso de error, lanza una ImagickException.


Obtiene la escena de la imagen

  • « Imagick::getImagesBlob
  • Imagick::getImageSignature »
  • PHP Manual
  • Imagick
  • Obtiene la escena de la imagen

Imagick::getImageScene

(PECL imagick 2, PECL imagick 3)

Imagick::getImageScene — Obtiene la escena de la imagen

Descripción

Imagick::getImageScene ( ) : int

Obtiene la escena de la imagen.

Valores devueltos

Devuelve la escena de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Genera un resumen de un mensaje SHA-256

  • « Imagick::getImageScene
  • Imagick::getImageSize »
  • PHP Manual
  • Imagick
  • Genera un resumen de un mensaje SHA-256

Imagick::getImageSignature

(PECL imagick 2, PECL imagick 3)

Imagick::getImageSignature — Genera un resumen de un mensaje SHA-256

Descripción

Imagick::getImageSignature ( ) : string

Genera un resumen de un mensaje SHA-256 para el flujo de píxeles de la imagen.

Valores devueltos

Devuelve un string que contiene el hash SHA-256 de el fichero.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la longitud de la imagen en bytes

  • « Imagick::getImageSignature
  • Imagick::getImageTicksPerSecond »
  • PHP Manual
  • Imagick
  • Devuelve la longitud de la imagen en bytes

Imagick::getImageSize

(PECL imagick 2, PECL imagick 3)

Imagick::getImageSize — Devuelve la longitud de la imagen en bytes

Descripción

Imagick::getImageSize ( ) : int

Devuelve la longitud de la imagen en bytes. Obsoleto en favor de Imagick::getImageLength()

Valores devueltos

Devuelve un valor de tipo integer que contiene el tamaño actual de la imagen.


Obtiene los pulsos por segundo de la imagen

  • « Imagick::getImageSize
  • Imagick::getImageTotalInkDensity »
  • PHP Manual
  • Imagick
  • Obtiene los pulsos por segundo de la imagen

Imagick::getImageTicksPerSecond

(PECL imagick 2, PECL imagick 3)

Imagick::getImageTicksPerSecond — Obtiene los pulsos por segundo de la imagen

Descripción

Imagick::getImageTicksPerSecond ( ) : int

Obtiene tlos pulsos por segundo de la imagen.

Valores devueltos

Devuelve los pulsos por segundo de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la densidad de tinta total de la imagen

  • « Imagick::getImageTicksPerSecond
  • Imagick::getImageType »
  • PHP Manual
  • Imagick
  • Obtiene la densidad de tinta total de la imagen

Imagick::getImageTotalInkDensity

(PECL imagick 2, PECL imagick 3)

Imagick::getImageTotalInkDensity — Obtiene la densidad de tinta total de la imagen

Descripción

Imagick::getImageTotalInkDensity ( ) : float

Obtiene la densidad de tinta total de la imagen.

Valores devueltos

Devuelve la densidad de tinta total de la imagen. Lanza ImagickException en caso de error.


Obtiene el tipo de imagen potencial

  • « Imagick::getImageTotalInkDensity
  • Imagick::getImageUnits »
  • PHP Manual
  • Imagick
  • Obtiene el tipo de imagen potencial

Imagick::getImageType

(PECL imagick 2, PECL imagick 3)

Imagick::getImageType — Obtiene el tipo de imagen potencial

Descripción

Imagick::getImageType ( ) : int

Obtiene el tipo de imagen potencial.

Valores devueltos

Devuelve el tipo de imagen potencial.

  • imagick::IMGTYPE_UNDEFINED
  • imagick::IMGTYPE_BILEVEL
  • imagick::IMGTYPE_GRAYSCALE
  • imagick::IMGTYPE_GRAYSCALEMATTE
  • imagick::IMGTYPE_PALETTE
  • imagick::IMGTYPE_PALETTEMATTE
  • imagick::IMGTYPE_TRUECOLOR
  • imagick::IMGTYPE_TRUECOLORMATTE
  • imagick::IMGTYPE_COLORSEPARATION
  • imagick::IMGTYPE_COLORSEPARATIONMATTE
  • imagick::IMGTYPE_OPTIMIZE

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene las unidades de resolución de la imagen

  • « Imagick::getImageType
  • Imagick::getImageVirtualPixelMethod »
  • PHP Manual
  • Imagick
  • Obtiene las unidades de resolución de la imagen

Imagick::getImageUnits

(PECL imagick 2, PECL imagick 3)

Imagick::getImageUnits — Obtiene las unidades de resolución de la imagen

Descripción

Imagick::getImageUnits ( ) : int

Obtiene las unidades de resolución de la imagen.

Valores devueltos

Devuelve las unidades de resolución de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el método de píxel virtual

  • « Imagick::getImageUnits
  • Imagick::getImageWhitePoint »
  • PHP Manual
  • Imagick
  • Devuelve el método de píxel virtual

Imagick::getImageVirtualPixelMethod

(PECL imagick 2, PECL imagick 3)

Imagick::getImageVirtualPixelMethod — Devuelve el método de píxel virtual

Descripción

Imagick::getImageVirtualPixelMethod ( ) : int

Devuelve el método de píxel virtual de la imagen especificada.

Valores devueltos

Devuelve el método de píxel virtual si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el punto blanco de la cromaticidad

  • « Imagick::getImageVirtualPixelMethod
  • Imagick::getImageWidth »
  • PHP Manual
  • Imagick
  • Devuelve el punto blanco de la cromaticidad

Imagick::getImageWhitePoint

(PECL imagick 2, PECL imagick 3)

Imagick::getImageWhitePoint — Devuelve el punto blanco de la cromaticidad

Descripción

Imagick::getImageWhitePoint ( ) : array

Devuelve el punto blanco de la cromaticidad como un array asociativa con las claves "x" e "y".

Valores devueltos

Devuelve el punto blanco de la cromaticidad como un array asociativa con las claves "x" e "y".

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el ancho de la imagen

  • « Imagick::getImageWhitePoint
  • Imagick::getInterlaceScheme »
  • PHP Manual
  • Imagick
  • Devuelve el ancho de la imagen

Imagick::getImageWidth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageWidth — Devuelve el ancho de la imagen

Descripción

Imagick::getImageWidth ( ) : int

Devuelve el ancho de la imagen.

Valores devueltos

Devuelve el ancho de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene la combinación de entrelazado de un objeto

  • « Imagick::getImageWidth
  • Imagick::getIteratorIndex »
  • PHP Manual
  • Imagick
  • Obtiene la combinación de entrelazado de un objeto

Imagick::getInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::getInterlaceScheme — Obtiene la combinación de entrelazado de un objeto

Descripción

Imagick::getInterlaceScheme ( ) : int

Obtiene la combinación del entrelazado de un objeto.

Valores devueltos

Obtiene la varita mágica combinación de entrelazado.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el índice de la imagen activa actual

  • « Imagick::getInterlaceScheme
  • Imagick::getNumberImages »
  • PHP Manual
  • Imagick
  • Obtiene el índice de la imagen activa actual

Imagick::getIteratorIndex

(PECL imagick 2, PECL imagick 3)

Imagick::getIteratorIndex — Obtiene el índice de la imagen activa actual

Descripción

Imagick::getIteratorIndex ( ) : int

Devuelve el índice de la imagen activa actual dentro del objeto Imagick. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve un integer que contiene el índice de la imagen en la pila.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::getIteratorIndex():

Crear imágenes, establecer y obtener el índice del iterador

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

Ver también

  • Imagick::setIteratorIndex() - Establece la posición del iterador
  • Imagick::getImageIndex() - Obtiene el índice de la imagen activa actual
  • Imagick::setImageIndex() - Establece la posición del iterador


Devuelve el número de imágenes del objeto

  • « Imagick::getIteratorIndex
  • Imagick::getOption »
  • PHP Manual
  • Imagick
  • Devuelve el número de imágenes del objeto

Imagick::getNumberImages

(PECL imagick 2, PECL imagick 3)

Imagick::getNumberImages — Devuelve el número de imágenes del objeto

Descripción

Imagick::getNumberImages ( ) : int

Devuelve el número de imágenes asociadas con el objeto Imagick.

Valores devueltos

Devuelve el número de imágenes asociadas con el objeto Imagick.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve un valor asociado con la clave especificada

  • « Imagick::getNumberImages
  • Imagick::getPackageName »
  • PHP Manual
  • Imagick
  • Devuelve un valor asociado con la clave especificada

Imagick::getOption

(PECL imagick 2, PECL imagick 3)

Imagick::getOption — Devuelve un valor asociado con la clave especificada

Descripción

Imagick::getOption ( string $key ) : string

Devuelve un valor asociado dentro del objeto para una clave especificada.

Parámetros

key

El nombre de la opción

Valores devueltos

Devuelve un valor asociado con una varita mágica y la clave especificada.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el nombre del paquete de ImageMagick

  • « Imagick::getOption
  • Imagick::getPage »
  • PHP Manual
  • Imagick
  • Devuelve el nombre del paquete de ImageMagick

Imagick::getPackageName

(PECL imagick 2, PECL imagick 3)

Imagick::getPackageName — Devuelve el nombre del paquete de ImageMagick

Descripción

Imagick::getPackageName ( ) : string

Devuelve el nombre del paquete de ImageMagick.

Valores devueltos

Devuelve el nombre del paquete de ImageMagick como un string.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la geometría de la página

  • « Imagick::getPackageName
  • Imagick::getPixelIterator »
  • PHP Manual
  • Imagick
  • Devuelve la geometría de la página

Imagick::getPage

(PECL imagick 2, PECL imagick 3)

Imagick::getPage — Devuelve la geometría de la página

Descripción

Imagick::getPage ( ) : array

Devuelve la geometría de la página asociada con el objeto Imagick en un array asociativo con las claves "width" (ancho), "height" (alto), "x", e "y".

Valores devueltos

Devuelve la geometría de la página asociada con el objeto Imagick en un array asociativo con las claves "width" (ancho), "height" (alto), "x", e "y". lanzando una ImagickException en caso de error.


Devuelve un objeto MagickPixelIterator

  • « Imagick::getPage
  • Imagick::getPixelRegionIterator »
  • PHP Manual
  • Imagick
  • Devuelve un objeto MagickPixelIterator

Imagick::getPixelIterator

(PECL imagick 2, PECL imagick 3)

Imagick::getPixelIterator — Devuelve un objeto MagickPixelIterator

Descripción

Imagick::getPixelIterator ( ) : ImagickPixelIterator

Devuelve un objeto MagickPixelIterator.

Valores devueltos

Devuelve un objeto ImagickPixelIterator si se tuvo éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::getPixelIterator()

<?php
function getPixelIterator($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelIterator();

    foreach ($imageIterator as $fila => $píxeles) { /* Recorrer las filas de píxeles */
        foreach ($píxeles as $columna => $píxel) { /* Recorrer los píxeles de la fila (columnas) */
            /** @var $pixel \ImagickPixel */
            if ($columna % 2) {
                $píxel->setColor("rgba(0, 0, 0, 0)"); /* Pintar cada segundo píxel de negro */
            }
        }
        $imageIterator->syncIterator(); /* Sincronizar el iterador; esto es importante en cada iteración */
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Obtinene un objeto ImagickPixelIterator de una sección de imagen

  • « Imagick::getPixelIterator
  • Imagick::getPointSize »
  • PHP Manual
  • Imagick
  • Obtinene un objeto ImagickPixelIterator de una sección de imagen

Imagick::getPixelRegionIterator

(PECL imagick 2, PECL imagick 3)

Imagick::getPixelRegionIterator — Obtinene un objeto ImagickPixelIterator de una sección de imagen

Descripción

Imagick::getPixelRegionIterator ( int $x , int $y , int $columns , int $rows ) : ImagickPixelIterator

Obtinene un objeto ImagickPixelIterator de una sección de imagen.

Parámetros

x

La coordenada x de la región.

y

La coordenada y de la región.

columns

El ancho de la región.

rows

El alto de la región.

Valores devueltos

Devuelve un objeto ImagickPixelIterator de una sección de imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Imagick::getPixelRegionIterator()

Recorrer los píxeles de la parte alta izquierda de la imagen, cambiándolos a negro.

<?php
$im = new Imagick(realpath("./testImage.png"));
$areaIterator = $im->getPixelRegionIterator(0, 0, 10, 10);

foreach ($areaIterator as $rowIterator) {
    foreach ($rowIterator as $píxel) {
        // Pintar cada píxel de negro
        $píxel->setColor("rgba(0, 0, 0, 0)");
    }
    $areaIterator->syncIterator();
}
$im->writeImage("./output.png");
?>


Obtiene el tamaño de punto

  • « Imagick::getPixelRegionIterator
  • Imagick::getQuantum »
  • PHP Manual
  • Imagick
  • Obtiene el tamaño de punto

Imagick::getPointSize

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::getPointSize — Obtiene el tamaño de punto

Descripción

Imagick::getPointSize ( ) : float

Devuelve la propiedad tamaño de punto de los objetos. Este método está disponible si Imagick ha sido compilado con la versión 6.3.7 o superior de ImageMagick.

Valores devueltos

Devuelve un float que contiene el tamaño de punto.

Ver también

  • Imagick::setPointSize() - Establece el tamaño del punto


Description

  • « Imagick::getPointSize
  • Imagick::getQuantumDepth »
  • PHP Manual
  • Imagick
  • Description

Imagick::getQuantum

(PECL imagick 3 >= 3.3.0)

Imagick::getQuantum — Description

Descripción

public static Imagick::getQuantum ( ) : int

Returns the ImageMagick quantum range as an integer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene la profundidad de la cuantía

  • « Imagick::getQuantum
  • Imagick::getQuantumRange »
  • PHP Manual
  • Imagick
  • Obtiene la profundidad de la cuantía

Imagick::getQuantumDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getQuantumDepth — Obtiene la profundidad de la cuantía

Descripción

Imagick::getQuantumDepth ( ) : array

Devuelve la profundidad de la cuantía de Imagick como un string.

Valores devueltos

Devuelve la profundidad de la cuantía de Imagick como un string.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el rango de cuantía de Imagick

  • « Imagick::getQuantumDepth
  • Imagick::getRegistry »
  • PHP Manual
  • Imagick
  • Devuelve el rango de cuantía de Imagick

Imagick::getQuantumRange

(PECL imagick 2, PECL imagick 3)

Imagick::getQuantumRange — Devuelve el rango de cuantía de Imagick

Descripción

Imagick::getQuantumRange ( ) : array

Devuelve el rango de cuantía para la instancia de Imagick.

Valores devueltos

Devuelve un array asociativo que contiene el rango de cuantía como un integer ("quantumRangeLong") y como un string ("quantumRangeString").

Errores/Excepciones

Lanza ImagickException en caso de error.


Description

  • « Imagick::getQuantumRange
  • Imagick::getReleaseDate »
  • PHP Manual
  • Imagick
  • Description

Imagick::getRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::getRegistry — Description

Descripción

public static Imagick::getRegistry ( string $key ) : string

Get the StringRegistry entry for the named key or false if not set.

Parámetros

key

The entry to get.

Valores devueltos


Devuelve la fecha de distribución de ImageMagick

  • « Imagick::getRegistry
  • Imagick::getResource »
  • PHP Manual
  • Imagick
  • Devuelve la fecha de distribución de ImageMagick

Imagick::getReleaseDate

(PECL imagick 2, PECL imagick 3)

Imagick::getReleaseDate — Devuelve la fecha de distribución de ImageMagick

Descripción

Imagick::getReleaseDate ( ) : string

Devuelve la fecha de distribución de ImageMagick como un string.

Valores devueltos

Devuelve la fecha de distribución de ImageMagick como un string.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el uso de memoria del recurso especificado

  • « Imagick::getReleaseDate
  • Imagick::getResourceLimit »
  • PHP Manual
  • Imagick
  • Devuelve el uso de memoria del recurso especificado

Imagick::getResource

(PECL imagick 2, PECL imagick 3)

Imagick::getResource — Devuelve el uso de memoria del recurso especificado

Descripción

Imagick::getResource ( int $type ) : int

Devuelve el uso de memoria del recurso especificado en megabytes.

Parámetros

type

Consulte esta lista de constantes de tipos de recursos.

Valores devueltos

Devuelve el uso de memoria del recurso especificado en megabytes.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el límite del recurso especificado

  • « Imagick::getResource
  • Imagick::getSamplingFactors »
  • PHP Manual
  • Imagick
  • Devuelve el límite del recurso especificado

Imagick::getResourceLimit

(PECL imagick 2, PECL imagick 3)

Imagick::getResourceLimit — Devuelve el límite del recurso especificado

Descripción

Imagick::getResourceLimit ( int $type ) : int

Devuelve el límite del recurso especificado.

Parámetros

type

Consulte la lista de constantes de tipos de recursos.

Valores devueltos

Devuelve el límite del recurso especificado en megabytes.

Errores/Excepciones

Lanza ImagickException en caso de error.


Obtiene el factor de muestreo horizontal y vertical

  • « Imagick::getResourceLimit
  • Imagick::getSize »
  • PHP Manual
  • Imagick
  • Obtiene el factor de muestreo horizontal y vertical

Imagick::getSamplingFactors

(PECL imagick 2, PECL imagick 3)

Imagick::getSamplingFactors — Obtiene el factor de muestreo horizontal y vertical

Descripción

Imagick::getSamplingFactors ( ) : array

Obtiene el factor de muestreo horizontal y vertical

Valores devueltos

Devuelve un array asociativo con el factor de muestreo horizontal y vertical de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve el tamaño asociado con el objeto Imagick

  • « Imagick::getSamplingFactors
  • Imagick::getSizeOffset »
  • PHP Manual
  • Imagick
  • Devuelve el tamaño asociado con el objeto Imagick

Imagick::getSize

(PECL imagick 2, PECL imagick 3)

Imagick::getSize — Devuelve el tamaño asociado con el objeto Imagick

Descripción

Imagick::getSize ( ) : array

Devuelve el tamaño asociado con el objeto Imagick como una matriz con las claves "columns" (columnas) y "rows" (filas).

Valores devueltos

Devuelve el tamaño asociado con el objeto Imagick como una matriz con las claves "columns" (columnas) y "rows" (filas).


Devuelve el índice de tamaño

  • « Imagick::getSize
  • Imagick::getVersion »
  • PHP Manual
  • Imagick
  • Devuelve el índice de tamaño

Imagick::getSizeOffset

(PECL imagick 2, PECL imagick 3)

Imagick::getSizeOffset — Devuelve el índice de tamaño

Descripción

Imagick::getSizeOffset ( ) : int

Devuelve el índice de tamaño asociado con el objeto Imagick. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve el índice de tamaño asociado con el objeto Imagick.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve la versión de la API ImageMagick

  • « Imagick::getSizeOffset
  • Imagick::haldClutImage »
  • PHP Manual
  • Imagick
  • Devuelve la versión de la API ImageMagick

Imagick::getVersion

(PECL imagick 2, PECL imagick 3)

Imagick::getVersion — Devuelve la versión de la API ImageMagick

Descripción

Imagick::getVersion ( ) : array

Devuelve la versión de la API ImageMagick como un string y como un número.

Valores devueltos

Devuelve la versión de la API ImageMagick como un string y como un número.

Errores/Excepciones

Lanza ImagickException en caso de error.


Reemplaza los colores de la imagen

  • « Imagick::getVersion
  • Imagick::hasNextImage »
  • PHP Manual
  • Imagick
  • Reemplaza los colores de la imagen

Imagick::haldClutImage

(PECL imagick 3)

Imagick::haldClutImage — Reemplaza los colores de la imagen

Descripción

public Imagick::haldClutImage ( Imagick $clut , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Reemplaza los colores de la imagen usando una paleta Hald. Las imágenes Hald se pueden crear usando un codificador de color HALD.

Parámetros

clut

Objeto Imagick que contiene la paleta Hald.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::haldClutImage()

<?php
function haldClutImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagickPalette = new \Imagick(realpath("images/hald/hald_8.png"));
    $imagickPalette->sepiatoneImage(55);
    $imagick->haldClutImage($imagickPalette);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Comprueba si el objeto tiene más imágenes

  • « Imagick::haldClutImage
  • Imagick::hasPreviousImage »
  • PHP Manual
  • Imagick
  • Comprueba si el objeto tiene más imágenes

Imagick::hasNextImage

(PECL imagick 2, PECL imagick 3)

Imagick::hasNextImage — Comprueba si el objeto tiene más imágenes

Descripción

Imagick::hasNextImage ( ) : bool

Devuelve true si el objeto tiene más imágenes cuando se atraviesa la lista en dirección hacia delante.

Valores devueltos

Devuelve true si el objeto tiene más imágenes cuando se atraviesa la lista en dirección hacia delante, devuelve false si no hay ninguna.


Verifica si el objeto tiene una imagen previa

  • « Imagick::hasNextImage
  • Imagick::identifyFormat »
  • PHP Manual
  • Imagick
  • Verifica si el objeto tiene una imagen previa

Imagick::hasPreviousImage

(PECL imagick 2, PECL imagick 3)

Imagick::hasPreviousImage — Verifica si el objeto tiene una imagen previa

Descripción

Imagick::hasPreviousImage ( ) : bool

Devuelve true si el objeto tiene más imágenes cuando se atraviesa la lista en la dirección opuesta

Valores devueltos

Devuelve true si el objeto tiene más imágenes cuando se atraviesa la lista en la dirección opuesta, devuelve false si no hay ninguna.


Description

  • « Imagick::hasPreviousImage
  • Imagick::identifyImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::identifyFormat

(PECL imagick 3 >= 3.3.0)

Imagick::identifyFormat — Description

Descripción

public Imagick::identifyFormat ( string $embedText ) : string|false

Replaces any embedded formatting characters with the appropriate image property and returns the interpreted text. See http://www.imagemagick.org/script/escape.php for escape sequences.

Parámetros

embedText

A string containing formatting sequences e.g. "Trim box: %@ number of unique colors: %k".

Valores devueltos

Returns format o false en caso de error.

Ejemplos

Ejemplo #1 Imagick::identifyFormat()

<?php
        $output = "Output of 'Trim box: %@ number of unique colors: %k' is: <br/>";
        $imagick = new \Imagick(realpath("./images/artifact/mask.png"));
        $output .= $imagick->identifyFormat("Trim box: %@ number of unique colors: %k");

?>


Identifica una imagen y obtiene sus atributos

  • « Imagick::identifyFormat
  • Imagick::implodeImage »
  • PHP Manual
  • Imagick
  • Identifica una imagen y obtiene sus atributos

Imagick::identifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::identifyImage — Identifica una imagen y obtiene sus atributos

Descripción

Imagick::identifyImage ( bool $appendRawOutput = false ) : array

Identifica una imagen y devuelve los atributos. Los atributos incluyen el ancho, alto, tamaño de la imagen, entre otros.

Parámetros

appendRawOutput

Valores devueltos

Identifica una imagen y devuelve los atributos. Los atributos incluyen el ancho, alto, tamaño de la imagen, entre otros.

Ejemplo #1 Ejemplo de formato resultante

Array
(
    [imageName] => /some/path/image.jpg
    [format] => JPEG (Joint Photographic Experts Group JFIF format)
    [geometry] => Array
        (
            [width] => 90
            [height] => 90
        )

    [type] => TrueColor
    [colorSpace] => RGB
    [resolution] => Array
        (
            [x] => 300
            [y] => 300
        )

    [units] => PixelsPerInch
    [fileSize] => 1.88672kb
    [compression] => JPEG
    [signature] => 9a6dc8f604f97d0d691c0286176ddf992e188f0bebba98494b2146ee2d7118da
)

Errores/Excepciones

Lanza ImagickException en caso de error.


Crea una nueva imagen como una copia

  • « Imagick::identifyImage
  • Imagick::importImagePixels »
  • PHP Manual
  • Imagick
  • Crea una nueva imagen como una copia

Imagick::implodeImage

(PECL imagick 2, PECL imagick 3)

Imagick::implodeImage — Crea una nueva imagen como una copia

Descripción

Imagick::implodeImage ( float $radius ) : bool

Crea una nueva imagen que es una copia de una existente con los píxeles de la imagen "implosionados" por el porcentaje especificado.

Parámetros

radius

El radio de la implosión

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::implodeImage()

<?php
function implodeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->implodeImage(0.0001);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();

}

?>


Importa los píxeles de una imagen

  • « Imagick::implodeImage
  • Imagick::inverseFourierTransformImage »
  • PHP Manual
  • Imagick
  • Importa los píxeles de una imagen

Imagick::importImagePixels

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::importImagePixels — Importa los píxeles de una imagen

Descripción

public Imagick::importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels ) : bool

Importa los píxeles desde una matriz a un imagen. El mapa map normalmete es 'RGB'. Este método impone las siguientes limitaciones para los parámetros: la cantidad de píxeles en la matriz debe coincidir con width x height x longitud del mapa. Este método está disponible si Imagick ha sido compilado con la versión 6.4.5 o superior de ImageMagick.

Parámetros

x

La posición x de la imagen

y

La posición y de la imagen

width

El ancho de la imagen

height

El alto de la imagen

map

Mapa de píxeles ordenados, como una cadena. Esto puede ser por ejemplo RGB. El valor puede ser cualquier combinación u orden de R = rojo, G = verde, B = azul, A = alfa (0 es transparente), O = opacidad (0 es opaco), C = cian, Y = amarillo, M = magenta, K = negro, I = intensidad (para escala de grises), P = relleno.

storage

El método de almacenamiento de los píxeles. Consulte esta lista de constantes de píxel.

pixels

La matriz de píxeles

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo deImagick::importImagePixels()

<?php

/* Generar una matriz de píxeles. 2000 píxeles por raya de color */
$cuenta = 2000 * 3;

$píxeles =
   array_merge(array_pad(array(), $cuenta, 0),
               array_pad(array(), $cuenta, 255),
               array_pad(array(), $cuenta, 0),
               array_pad(array(), $cuenta, 255),
               array_pad(array(), $cuenta, 0));

/* Ancho y alto. El área es la cantidad de píxeles dividido
   por tres. Tres viene de 'RGB', tres valores por píxel */
$ancho = $alto = pow((count($píxeles) / 3), 0.5);

/* Crear una imagen vacía */
$im = new Imagick();
$im->newImage($ancho, $alto, 'gray');

/* Importar los píxeles a la imagen.
   ancho * alto * strlen("RGB") debe coincidir con count($píxeles) */
$im->importImagePixels(0, 0, $ancho, $alto, "RGB", Imagick::PIXEL_CHAR, $píxeles);

/* Imprimir como una imagen jpeg */
$im->setImageFormat('jpg');
header("Content-Type: image/jpg");
echo $im;

?>

El resultado del ejemplo sería algo similar a:

Salida del ejemplo : Imagick::importImagePixels()


Description

  • « Imagick::importImagePixels
  • Imagick::labelImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::inverseFourierTransformImage

(PECL imagick 3 >= 3.3.0)

Imagick::inverseFourierTransformImage — Description

Descripción

public Imagick::inverseFourierTransformImage ( Imagick $complement , bool $magnitude ) : bool

Implements the inverse discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

complement

The second image to combine with this one to form either the magnitude / phase or real / imaginary image pair.

magnitude

If true, combine as magnitude / phase pair otherwise a real / imaginary image pair.

Valores devueltos

Devuelve true en caso de éxito.


Añade una etiqueta a una imagen

  • « Imagick::inverseFourierTransformImage
  • Imagick::levelImage »
  • PHP Manual
  • Imagick
  • Añade una etiqueta a una imagen

Imagick::labelImage

(PECL imagick 2, PECL imagick 3)

Imagick::labelImage — Añade una etiqueta a una imagen

Descripción

Imagick::labelImage ( string $label ) : bool

Añade una etiqueta a una imagen.

Parámetros

label

La etiqueta a añadir

Valores devueltos

Devuelve true en caso de éxito.


Ajusta los niveles de la imagen

  • « Imagick::labelImage
  • Imagick::linearStretchImage »
  • PHP Manual
  • Imagick
  • Ajusta los niveles de la imagen

Imagick::levelImage

(PECL imagick 2, PECL imagick 3)

Imagick::levelImage — Ajusta los niveles de la imagen

Descripción

Imagick::levelImage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Imagick::CHANNEL_ALL ) : bool

Ajusta los niveles de una imagen escalando la caída de los colores entre los puntos blanco y negro especificados al rango completo de cuantía disponible. Los parámetros proporcionados representan los puntos negro, mitad, y blanco. El punto negro especifica el color más oscuro de la imagen. Los colores más oscuros que el punto negro se establecen a cero. El punto medio especifica una corrección gamma a aplicar a la imagen. Mientras que el punto blanco especifica el color más claro de la imagen. Los colores más claros que el punto blanco se establecen al valor de cuantía máximo.

Parámetros

blackPoint

El punto negro de la imagen

gamma

El valor gamma

whitePoint

El punto blanco de la imagen

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::levelImage()

<?php
function levelImage($blackPoint, $gamma, $whitePoint) {
    $imagick = new \Imagick();
    $imagick->newPseudoimage(500, 500, 'gradient:black-white');

    $imagick->setFormat('png');
    $quantum = $imagick->getQuantum();
    $imagick->levelImage($blackPoint / 100 , $gamma, $quantum * $whitePoint / 100);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Estrecha con saturación la intensidad de la imagen

  • « Imagick::levelImage
  • Imagick::liquidRescaleImage »
  • PHP Manual
  • Imagick
  • Estrecha con saturación la intensidad de la imagen

Imagick::linearStretchImage

(PECL imagick 2, PECL imagick 3)

Imagick::linearStretchImage — Estrecha con saturación la intensidad de la imagen

Descripción

Imagick::linearStretchImage ( float $blackPoint , float $whitePoint ) : bool

Estrecha con saturación la intensidad de la imagen.

Parámetros

blackPoint

El punto negro de la imagen

whitePoint

El punto blanco de la imagen

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::linearStretchImage()

<?php
function linearStretchImage($imagePath, $blackThreshold, $whiteThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $pixels = $imagick->getImageWidth() * $imagick->getImageHeight();
    $imagick->linearStretchImage($blackThreshold * $pixels, $whiteThreshold * $pixels);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Anima una imagen o imágenes

  • « Imagick::linearStretchImage
  • Imagick::listRegistry »
  • PHP Manual
  • Imagick
  • Anima una imagen o imágenes

Imagick::liquidRescaleImage

(PECL imagick 2 >= 2.2.0, PECL imagick 3)

Imagick::liquidRescaleImage — Anima una imagen o imágenes

Descripción

Imagick::liquidRescaleImage ( int $width , int $height , float $delta_x , float $rigidity ) : bool

Este método escala las imágenes usando un método de re-escalada líquido. Este método es una implementación de una técnica llamada "seam carving" (talla de costura). Para que este método funcione como es debido, ImageMagick se debe compilar con el soporte para la biblioteca liblqr. Este método está disponible si Imagick ha sido compilado con la versión 6.3.9 o superior de ImageMagick.

Parámetros

width

El ancho del tamaño objetivo

height

El alto del tamaño objetivo

delta_x

Cuánto puede atravesar la costura el eje x. Pasar 0 causa que las costuras sean rectas.

rigidity

Introduce un sesgo para costuras no rectas. Este parámetro normalmente es 0.

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::resizeImage() - Escala una imagen


Description

  • « Imagick::liquidRescaleImage
  • Imagick::magnifyImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::listRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::listRegistry — Description

Descripción

public static Imagick::listRegistry ( ) : array

Enumera todos los ajustes del registro. Devuelve un array con todas los pares de clave/valor del registro.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un arrayn que contiene los pares de clave/valor del registro.


Escala una imagen x2 proporcionalmente

  • « Imagick::listRegistry
  • Imagick::mapImage »
  • PHP Manual
  • Imagick
  • Escala una imagen x2 proporcionalmente

Imagick::magnifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::magnifyImage — Escala una imagen x2 proporcionalmente

Descripción

Imagick::magnifyImage ( ) : bool

Es un método conveniente que escala una imagen proporcionalmente al doble de su tamaño original.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::magnifyImage()

<?php
function magnifyImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->magnifyImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

  • « Imagick::magnifyImage
  • Imagick::matteFloodfillImage »
  • PHP Manual
  • Imagick
  • Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

Imagick::mapImage

(PECL imagick 2, PECL imagick 3)

Imagick::mapImage — Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia

Descripción

Imagick::mapImage ( Imagick $map , bool $dither ) : bool

Parámetros

map

dither

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Cambia el valor de transparencia de un color

  • « Imagick::mapImage
  • Imagick::medianFilterImage »
  • PHP Manual
  • Imagick
  • Cambia el valor de transparencia de un color

Imagick::matteFloodfillImage

(PECL imagick 2, PECL imagick 3)

Imagick::matteFloodfillImage — Cambia el valor de transparencia de un color

Descripción

Imagick::matteFloodfillImage ( float $alpha , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool

Cambia el valor de transparencia de un píxel que coincide con el objetivo y esté en la zona inmediata. Si el método FillToBorderMethod se especifica, el valor de transparencia se cambia por cualquier píxel inmediato que no coincida con el miembro color del borde de la imagen.

Parámetros

alpha

El nivel de transparencia: 1.0 es completamente opaco y 0.0 es completamente transparente.

fuzz

El miembro enfoque de la imagen define cuánta tolerancia se acepta para considerar que dos colores son el mismo.

bordercolor

Un objeto ImagickPixel o una cadena que representa el color del borde.

x

La coordenada x de inicio de la operación.

y

La coordenada y de inicio de la operación.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como tercer parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.


Aplica un filtro digital

  • « Imagick::matteFloodfillImage
  • Imagick::mergeImageLayers »
  • PHP Manual
  • Imagick
  • Aplica un filtro digital

Imagick::medianFilterImage

(PECL imagick 2, PECL imagick 3)

Imagick::medianFilterImage — Aplica un filtro digital

Descripción

Imagick::medianFilterImage ( float $radius ) : bool

Aplica un filtro digital que mejora la calidad de una imagen con ruido. Cada píxel es reemplazado por la media en un conjunto de píxeles inmediatos como está definido por el radio.

Parámetros

radius

El radio de la zona inmediata de los píxeles.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::medianFilterImage()

<?php
function medianFilterImage($radius, $imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    @$imagick->medianFilterImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Fusiona las capas de una imagen

  • « Imagick::medianFilterImage
  • Imagick::minifyImage »
  • PHP Manual
  • Imagick
  • Fusiona las capas de una imagen

Imagick::mergeImageLayers

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::mergeImageLayers — Fusiona las capas de una imagen

Descripción

Imagick::mergeImageLayers ( int $layer_method ) : bool

Fusiona las capas de una imagen. Este método es útil cuando se trabaja con formatos de imagen que usan múltiples capas, como PSD. La fusión se controla usando el parámetro layer_method el cuál define cómo se fusionan las capas. Este método está disponible si Imagick ha sido compilado con la versión 6.3.7 o superior de ImageMagick.

Parámetros

layer_method

Una de las constantes Imagick::LAYERMETHOD_*

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::flattenImages() - Fusiona una secuencia de imágenes

Ejemplos

Ejemplo #1 Imagick::mergeImageLayers()

<?php
function mergeImageLayers($layerMethodType, $imagePath1, $imagePath2) {

    $imagick = new \Imagick(realpath($imagePath));

    $imagick2 = new \Imagick(realpath($imagePath2));
    $imagick->addImage($imagick2);
    $imagick->setImageFormat('png');

    $result = $imagick->mergeImageLayers($layerMethodType);
    header("Content-Type: image/png");
    echo $result->getImageBlob();
}

?>


Escala una imagen proporcionalmente a la mitad de su tamaño

  • « Imagick::mergeImageLayers
  • Imagick::modulateImage »
  • PHP Manual
  • Imagick
  • Escala una imagen proporcionalmente a la mitad de su tamaño

Imagick::minifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::minifyImage — Escala una imagen proporcionalmente a la mitad de su tamaño

Descripción

Imagick::minifyImage ( ) : bool

Es un método conveniente que escala una imagen proporcionalmente a la mitad de su tamaño original.

Valores devueltos

Devuelve true en caso de éxito.


Controla el brillo, la saturación y el tono

  • « Imagick::minifyImage
  • Imagick::montageImage »
  • PHP Manual
  • Imagick
  • Controla el brillo, la saturación y el tono

Imagick::modulateImage

(PECL imagick 2, PECL imagick 3)

Imagick::modulateImage — Controla el brillo, la saturación y el tono

Descripción

Imagick::modulateImage ( float $brightness , float $saturation , float $hue ) : bool

Permite controlar el brillo, la saturación y el tono de una imagen. El tono es el porcentaje de la rotación absoluta desde la posición actual. Por ejemplo, 50 resulta en una rotación en el sentido contrario a las agujas del reloj de 90 grados, 150 resulta en una rotación en el sentido de las agujas del reloj de 90 grados, con 0 y 200 resultando en una rotación de 180 grados.

Parámetros

brightness

saturation

hue

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::modulateImage()

<?php
function modulateImage($imagePath, $hue, $brightness, $saturation) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->modulateImage($brightness, $saturation, $hue);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea una imagen compuesta

  • « Imagick::modulateImage
  • Imagick::morphImages »
  • PHP Manual
  • Imagick
  • Crea una imagen compuesta

Imagick::montageImage

(PECL imagick 2, PECL imagick 3)

Imagick::montageImage — Crea una imagen compuesta

Descripción

Imagick::montageImage ( ImagickDraw $draw , string $tile_geometry , string $thumbnail_geometry , int $mode , string $frame ) : Imagick

Crea una imagen compuesta combinando varias imágenes por separado. Las imágenes forman un mosaico de la imagen compuesta con el nombre de la imagen apareciendo opcionalmente debajo de cada tesela individual.

Parámetros

draw

El nombre de la fuente, tamaño y color se obtienen de este objeto.

tile_geometry

El número de teselas por fila y página (p.ej. 6x4+0+0).

thumbnail_geometry

Tamaño preferido de la imagen y del borde de cada miniatura (p.ej. 120x120+4+3>).

mode

Modo de enmarcación de la miniatura, véase constantes de Modo de Montaje.

frame

Rodea la imagen con un borde ornamental (p.ej. 15x15+3+3). El color del marco es el color mate de la miniatura.

Valores devueltos

Devuelve true en caso de éxito.


Metamorfosea un conjunto de imágenes

  • « Imagick::montageImage
  • Imagick::morphology »
  • PHP Manual
  • Imagick
  • Metamorfosea un conjunto de imágenes

Imagick::morphImages

(PECL imagick 2, PECL imagick 3)

Imagick::morphImages — Metamorfosea un conjunto de imágenes

Descripción

Imagick::morphImages ( int $number_frames ) : Imagick

Metamorfosea un conjunto de imágenes. Los píxeles de la imagen y el tamaño son interpolados linealmente para dar la apariencia de una metamorfosis desde una imagen a la siguiente.

Parámetros

number_frames

El número de imágenes intermedias a generar.

Valores devueltos

Este método devuelve un nuevo objeto Imagick si se tuvo éxito. Lanza ImagickException en caso de error.


Description

  • « Imagick::morphImages
  • Imagick::mosaicImages »
  • PHP Manual
  • Imagick
  • Description

Imagick::morphology

(PECL imagick 3 >= 3.3.0)

Imagick::morphology — Description

Descripción

public Imagick::morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Applies a user supplied kernel to the image according to the given morphology method.

Parámetros

morphologyMethod

Which morphology method to use one of the \Imagick::MORPHOLOGY_* constants.

iterations

The number of iteration to apply the morphology function. A value of -1 means loop until no change found. How this is applied may depend on the morphology method. Typically this is a value of 1.

ImagickKernel

channel

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Convolve Imagick::morphology()

<?php
        $imagick = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_GAUSSIAN, "5,1");
        $imagick->morphology(\Imagick::MORPHOLOGY_CONVOLVE, 2, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Ejemplo #2 Correlate Imagick::morphology()

<?php

        // Top-left pixel must be black
        // Bottom right pixel must be white
        // We don't care about the rest.

        $imagick = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromMatrix(self::$correlateMatrix, [2, 2]);
        $imagick->morphology(\Imagick::MORPHOLOGY_CORRELATE, 1, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Ejemplo #3 Erode Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #4 Erode Intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE_INTENSITY, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #5 Dilate Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #6 Dilate intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE_INTENSITY, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #7 Distance with Chebyshev kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CHEBYSHEV, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #8 Distance with Manhattan kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_MANHATTAN, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #9 Distance with ocatagonal kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGONAL, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #10 Distance with Euclidean kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_EUCLIDEAN, "4");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #11 Edge Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #12 Open Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #13 Open intensity Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.

        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #14 Close Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #15 Close Intensity Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #16 Smooth Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_SMOOTH, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #17 Edge in Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_IN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #18 Edge out Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_OUT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #19 The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_TOP_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #20 The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology()

<?php

        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_BOTTOM_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #21 Hit and Miss Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        //This finds all the pixels with 3 pixels of the right edge
        $matrix = [[1, false, false, 0]];
        $kernel = \ImagickKernel::fromMatrix(
            $matrix,
            [0, 0]
        );
        $canvas->morphology(\Imagick::MORPHOLOGY_HIT_AND_MISS, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #22 Thinning Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THINNING, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #23 Thicken Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #24 Thick to generate a convex hull Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $diamondKernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DIAMOND, "1");
        $convexKernel =  \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CONVEX_HULL, "");

        // The thicken morphology doesn't handle small gaps. We close them
        // with the close morphology.
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, -1, $convexKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);

        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #25 Iterative morphology Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "2");
        $canvas->morphology(\Imagick::MORPHOLOGY_ITERATIVE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Ejemplo #26 Helper functon to get an image silhouette Imagick::morphology()

<?php
    private function getCharacterOutline() {

        $imagick = new \Imagick(realpath("./images/character.png"));
        $character = new \Imagick();
        $character->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:white"
        );
        $canvas = new \Imagick();
        $canvas->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:black"
        );

        $character->compositeimage(
            $imagick,
            \Imagick::COMPOSITE_COPYOPACITY,
            0, 0
        );
        $canvas->compositeimage(
            $character,
            \Imagick::COMPOSITE_ATOP,
            0, 0
        );
        $canvas->setFormat('png');

        return $canvas;
    }

?>


Forma un mosaico de imágenes

  • « Imagick::morphology
  • Imagick::motionBlurImage »
  • PHP Manual
  • Imagick
  • Forma un mosaico de imágenes

Imagick::mosaicImages

(PECL imagick 2, PECL imagick 3)

Imagick::mosaicImages — Forma un mosaico de imágenes

Descripción

Imagick::mosaicImages ( ) : Imagick

Incrusta una secuencia de imágenes para formar una sóla imagen coherente. Devuelve una varita mágica con cada imagen de la secuencia compuesta en la ubicación definida por el índice de página de la imagen.

Valores devueltos

Devuelve true en caso de éxito.


Simula borrosidad en movimiento

  • « Imagick::mosaicImages
  • Imagick::negateImage »
  • PHP Manual
  • Imagick
  • Simula borrosidad en movimiento

Imagick::motionBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::motionBlurImage — Simula borrosidad en movimiento

Descripción

Imagick::motionBlurImage ( float $radius , float $sigma , float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Simula borrosidad en movimiento. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debe ser mayor que sigma. Use un radio de 0 y MotionBlurImage() seleccionará un radio apropiado automáticamente. El ángulo da el ángulo del movimiento borroso.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central.

sigma

La desviación estándar gaussiana, en píxeles.

angle

Aplica el efecto a lo largo de este ángulo.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal. El argumento channel afecta sólo si Imagick es compilado con la versión 6.4.4 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::motionBlurImage()

<?php
function motionBlurImage($imagePath, $radius, $sigma, $angle, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->motionBlurImage($radius, $sigma, $angle, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Invierte los colores en la imagen de referencia

  • « Imagick::motionBlurImage
  • Imagick::newImage »
  • PHP Manual
  • Imagick
  • Invierte los colores en la imagen de referencia

Imagick::negateImage

(PECL imagick 2, PECL imagick 3)

Imagick::negateImage — Invierte los colores en la imagen de referencia

Descripción

Imagick::negateImage ( bool $gray , int $channel = Imagick::CHANNEL_ALL ) : bool

Invierte los colores en la imagen de referencia. La opción de escala de grises significa que sólo los valores de la escala de grises dentro de la imagen se inverten.

Parámetros

gray

Si sólo se invierten los píxeles de la escala de grises dentro de la imagen.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::negateImage()

<?php
function negateImage($imagePath, $grayOnly, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->negateImage($grayOnly, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea una nueva imagen

  • « Imagick::negateImage
  • Imagick::newPseudoImage »
  • PHP Manual
  • Imagick
  • Crea una nueva imagen

Imagick::newImage

(PECL imagick 2, PECL imagick 3)

Imagick::newImage — Crea una nueva imagen

Descripción

Imagick::newImage ( int $cols , int $rows , mixed $background , string $format = ? ) : bool

Crea una nueva imagen y asocia el valor de ImagickPixel al color de fondo

Parámetros

cols

Columnas en la nueva imagen

rows

Filas en la nueva imagen

background

El color de fondo usado para esta imagen

format

El formato de la imagen. Este parámetro se añadió en la versión 2.0.1 de Imagick.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como tercer parámetro Versiones anteriores sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Usar Imagick::newImage():

Crear una nueva imagen y mostrarla.

<?php

$imagen = new Imagick();
$imagen->newImage(100, 100, new ImagickPixel('red'));
$imagen->setImageFormat('png');

header('Content-type: image/png');
echo $imagen;

?>


Crea una nueva imagen

  • « Imagick::newImage
  • Imagick::nextImage »
  • PHP Manual
  • Imagick
  • Crea una nueva imagen

Imagick::newPseudoImage

(PECL imagick 2, PECL imagick 3)

Imagick::newPseudoImage — Crea una nueva imagen

Descripción

Imagick::newPseudoImage ( int $columns , int $rows , string $pseudoString ) : bool

Crea una nueva imagen usando pseudo-formatos de ImageMagick.

Parámetros

columns

columnas en la nueva imagen

rows

filas en la nueva imagen

pseudoString

string que contiene la definición de la pseudo-imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::newPseudoImage()

<?php
function newPseudoImage($canvasType) {
    $imagick = new \Imagick();
    $imagick->newPseudoImage(300, 300, $canvasType);
    $imagick->setImageFormat("png");
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

//newPseudoImage('gradient:red-rgba(64, 255, 255, 0.5)');
//newPseudoImage("radial-gradient:red-blue");
newPseudoImage("plasma:fractal");

?>


Se mueve a la siguiente imagen

  • « Imagick::newPseudoImage
  • Imagick::normalizeImage »
  • PHP Manual
  • Imagick
  • Se mueve a la siguiente imagen

Imagick::nextImage

(PECL imagick 2, PECL imagick 3)

Imagick::nextImage — Se mueve a la siguiente imagen

Descripción

Imagick::nextImage ( ) : bool

Asocia la siguiente imagen de la lista de ímágenes con un objeto Imagick.

Valores devueltos

Devuelve true en caso de éxito.


Mejora el contraste de una imagen a color

  • « Imagick::nextImage
  • Imagick::oilPaintImage »
  • PHP Manual
  • Imagick
  • Mejora el contraste de una imagen a color

Imagick::normalizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::normalizeImage — Mejora el contraste de una imagen a color

Descripción

Imagick::normalizeImage ( int $channel = Imagick::CHANNEL_ALL ) : bool

Mejora el contraste de una imagen a color ajustando los colores de los píxeles para abarcar el rango completo de colores disponibles.

Parámetros

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::normalizeImage()

<?php
function normalizeImage($imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $original = clone $imagick;
    $original->cropimage($original->getImageWidth() / 2, $original->getImageHeight(), 0, 0);
    $imagick->normalizeImage($channel);
    $imagick->compositeimage($original, \Imagick::COMPOSITE_ATOP, 0, 0);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simula una pintura al óleo

  • « Imagick::normalizeImage
  • Imagick::opaquePaintImage »
  • PHP Manual
  • Imagick
  • Simula una pintura al óleo

Imagick::oilPaintImage

(PECL imagick 2, PECL imagick 3)

Imagick::oilPaintImage — Simula una pintura al óleo

Descripción

Imagick::oilPaintImage ( float $radius ) : bool

Aplica un filtro de efecto especial que simula una pintura al óleo. Cada píxel es reemplazado por el color más frecuente que suceda en una región circular definida por el radio.

Parámetros

radius

El radio de la zona circular inmediata.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::oilPaintImage()

<?php
function oilPaintImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->oilPaintImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Cambia el color de cualquier píxel que coincida con el objetivo

  • « Imagick::oilPaintImage
  • Imagick::optimizeImageLayers »
  • PHP Manual
  • Imagick
  • Cambia el color de cualquier píxel que coincida con el objetivo

Imagick::opaquePaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::opaquePaintImage — Cambia el color de cualquier píxel que coincida con el objetivo

Descripción

Imagick::opaquePaintImage ( mixed $target , mixed $fill , float $fuzz , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Cambia cualquier píxel que coincida con el color definido para el relleno. Este método está disponible si Imagick ha sido compilado con la versión 6.3.8 o superior de ImageMagick.

Parámetros

target

Objeto ImagickPixel o una cadena que contiene el color a cambiar

fill

El color sustituto

fuzz

La cantidad de difusión. Por ejemplo, setee fuzz a 10 y el color rojo a intensidades de 100 y 102 respectivamente son ahora interpretados como el mismo color.

invert

Si es true pinta cualquier píxel que no coincida con el color objetivo.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.


Elimina porciones repetidas de imágenes para optimizarlas

  • « Imagick::opaquePaintImage
  • Imagick::orderedPosterizeImage »
  • PHP Manual
  • Imagick
  • Elimina porciones repetidas de imágenes para optimizarlas

Imagick::optimizeImageLayers

(PECL imagick 2, PECL imagick 3)

Imagick::optimizeImageLayers — Elimina porciones repetidas de imágenes para optimizarlas

Descripción

Imagick::optimizeImageLayers ( ) : bool

Compara cada imagen con las formas de disposición del formato GIF de la imagen previa en la secuencia. Desde aquí se intenta seleccionar la imagen recortada más pequeña para reemplazar cada fotograma, mientras se preservan los resultados de la animación. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::optimizeImageLayers()

Leer, optimizar y escribir una imagen GIF

<?php
/* crear un nuevo objeto Imagick */
$im = new Imagick("prueba.gif");

/* optimizar las capas de la imagen */
$im->optimizeImageLayers();

/* escribir la imagen */
$im->writeImages("prueba_optimizada.gif", true);
?>

Ver también

  • Imagick::compareImageLayers() - Devuelve la región circundante máxima entre imágenes
  • Imagick::writeImages() - Escribe una imagen o secuencia de imágenes
  • Imagick::writeImage() - Escribe una imagen al nombre de fichero especificado


Realiza un entramado ordenado

  • « Imagick::optimizeImageLayers
  • Imagick::paintFloodfillImage »
  • PHP Manual
  • Imagick
  • Realiza un entramado ordenado

Imagick::orderedPosterizeImage

(PECL imagick 2 >= 2.2.2, PECL imagick 3)

Imagick::orderedPosterizeImage — Realiza un entramado ordenado

Descripción

Imagick::orderedPosterizeImage ( string $threshold_map , int $channel = Imagick::CHANNEL_ALL ) : bool

Realiza un entramado ordenado basado en varios mapas de umbral de entramado predefinidos, pero sobre múltiples niveles de intensidad, lo que puede ser diferente para distintos canales, según los argumentos de entrada. Este método está disponible si Imagick ha sido compilado con la versión 6.3.1 o superior de ImageMagick.

Parámetros

threshold_map

Un string que contiene el nombre del mapa de umbral de entramado que se va a usar

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::orderedPosterizeImage()

<?php
function orderedPosterizeImage($imagePath, $orderedPosterizeType) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->orderedPosterizeImage($orderedPosterizeType);
    $imagick->setImageFormat('png');

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

//orderedPosterizeImage($imagePath, 'o4x4,3,3');
//orderedPosterizeImage($imagePath, 'o8x8,6,6');
orderedPosterizeImage($imagePath, 'h8x8a');

?>


Cambia el valor del color de cualquier píxel que coincida con el objetivo

  • « Imagick::orderedPosterizeImage
  • Imagick::paintOpaqueImage »
  • PHP Manual
  • Imagick
  • Cambia el valor del color de cualquier píxel que coincida con el objetivo

Imagick::paintFloodfillImage

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::paintFloodfillImage — Cambia el valor del color de cualquier píxel que coincida con el objetivo

Descripción

Imagick::paintFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool

Cambia el valor del color de cualquier píxel que coincida con el objetivo y esté en la zona inmediata. A partir de ImageMagick 6.3.8 este método está obsoleto y se debería usar Imagick::floodfillPaintImage() en su lugar.

Parámetros

fill

Objeto ImagickPixel o un string que contiene el color de relleno

fuzz

La cantidad de enfoque. Por ejemplo, establecer el enfoque a 10 y el color a rojo con una intensidad de 100 y 102 respectivamente ahora se interpreta como el mismo color para los propósitos del relleno.

bordercolor

Objeto ImagickPixel que contiene el color de borde

x

Posición X del inicio del relleno

y

Posición Y del inicio del relleno

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.


Cambia cualquier píxel que coincida con el color

  • « Imagick::paintFloodfillImage
  • Imagick::paintTransparentImage »
  • PHP Manual
  • Imagick
  • Cambia cualquier píxel que coincida con el color

Imagick::paintOpaqueImage

(PECL imagick 2, PECL imagick 3)

Imagick::paintOpaqueImage — Cambia cualquier píxel que coincida con el color

Descripción

Imagick::paintOpaqueImage ( mixed $target , mixed $fill , float $fuzz , int $channel = Imagick::CHANNEL_ALL ) : bool

Cambia cualquier píxel que coincida con el color definido por el relleno.

Parámetros

target

Cambia este color objetivo por el color de relleno de la imagen. Un objeto ImagickPixel o una cadena que representa el color objetivo.

fill

Un objeto ImagickPixel o un string que representa el color de relleno.

fuzz

El miembro enfoque de la imagen define cúanta tolerancia es aceptable para considerar que dos colores son el mismo.

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como primer y segundo parámetros. Versiones anteriores sólo permitían un objeto ImagickPixel.


Cambia cualquier píxel que coincida con el color definido para el relleno

  • « Imagick::paintOpaqueImage
  • Imagick::pingImage »
  • PHP Manual
  • Imagick
  • Cambia cualquier píxel que coincida con el color definido para el relleno

Imagick::paintTransparentImage

(PECL imagick 2, PECL imagick 3)

Imagick::paintTransparentImage — Cambia cualquier píxel que coincida con el color definido para el relleno

Descripción

Imagick::paintTransparentImage ( mixed $target , float $alpha , float $fuzz ) : bool

Cambia cualquier píxel que coincida con el color definido para el relleno.

Parámetros

target

Cambia este color objetivo por el valor de opacidad especificado dentro de la imagen.

alpha

El nivel de transparencia: 1.0 es completamente opaco y 0.0 es completamente transparente.

fuzz

El miembro enfoque de la imagen define cuánta tolerancia es aceptable para considerar que dos colores son el mismo.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como primer parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.


Trae los atributos básicos de una imagen

  • « Imagick::paintTransparentImage
  • Imagick::pingImageBlob »
  • PHP Manual
  • Imagick
  • Trae los atributos básicos de una imagen

Imagick::pingImage

(PECL imagick 2, PECL imagick 3)

Imagick::pingImage — Trae los atributos básicos de una imagen

Descripción

Imagick::pingImage ( string $filename ) : bool

Este método se puede usar para preguntar por el ancho, alto, tamaño y formato de la imagen sin leer toda la imagen de la memoria.

Parámetros

filename

El nombre de fichero de donde se va a leer la información.

Valores devueltos

Devuelve true en caso de éxito.


Traer los atributos rápidamente

  • « Imagick::pingImage
  • Imagick::pingImageFile »
  • PHP Manual
  • Imagick
  • Traer los atributos rápidamente

Imagick::pingImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::pingImageBlob — Traer los atributos rápidamente

Descripción

Imagick::pingImageBlob ( string $image ) : bool

Este método se puede usar para preguntar por el ancho, alto, tamaño y formato de la imagen sin leer toda la imagen de la memoria. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

image

Un string que contiene la imagen.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar Imagick::pingImageBlob()

Hacer ping a una imagen desde un string

<?php
/* leer el contenido de la imagen */
$imagen = file_get_contents("prueba.jpg");

/* crear un nuevo objeto imagick */
$im = new Imagick();

/* pasar el string al objeto imagick */
$im->pingImageBlob($imagen);

/* imprimir el ancho y alto de la image */
echo $im->getImageWidth() . 'x' . $im->getImageHeight();
?>

Ver también

  • Imagick::pingImage() - Trae los atributos básicos de una imagen
  • Imagick::pingImageFile() - Obtener los atrbutos básicos de la imagen de una manera liviana
  • Imagick::readImage() - Lee una imagen desde un nombre de fichero
  • Imagick::readImageBlob() - Lee una imagen desde un string binario
  • Imagick::readImageFile() - Lee una imagen desde un gestor de fichero abierto


Obtener los atrbutos básicos de la imagen de una manera liviana

  • « Imagick::pingImageBlob
  • Imagick::polaroidImage »
  • PHP Manual
  • Imagick
  • Obtener los atrbutos básicos de la imagen de una manera liviana

Imagick::pingImageFile

(PECL imagick 2, PECL imagick 3)

Imagick::pingImageFile — Obtener los atrbutos básicos de la imagen de una manera liviana

Descripción

Imagick::pingImageFile ( resource $filehandle , string $fileName = ? ) : bool

Este método se puede usar para preguntar por el ancho, alto, tamaño y formato de la imagen sin leer toda la imagen de la memoria. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

filehandle

Un gestor de archivo abierto a la imagen.

fileName

Nombre de archivo opcional para esta imagen.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar Imagick::pingImageFile()

Abrir una ubicación remota

<?php
/* usar fopen para abrir una ubicación remota */
$fp = fopen("http://example.com/test.jpg");

/* crear un nuevo objeto imagick */
$im = new Imagick();

/* pasar el gestor a imagick */
$im->pingImageFile($fp);
?>

Ver también

  • Imagick::pingImage() - Trae los atributos básicos de una imagen
  • Imagick::pingImageBlob() - Traer los atributos rápidamente
  • Imagick::readImage() - Lee una imagen desde un nombre de fichero
  • Imagick::readImageBlob() - Lee una imagen desde un string binario
  • Imagick::readImageFile() - Lee una imagen desde un gestor de fichero abierto


Simula una fotografía Polaroid

  • « Imagick::pingImageFile
  • Imagick::posterizeImage »
  • PHP Manual
  • Imagick
  • Simula una fotografía Polaroid

Imagick::polaroidImage

(PECL imagick 2, PECL imagick 3)

Imagick::polaroidImage — Simula una fotografía Polaroid

Descripción

Imagick::polaroidImage ( ImagickDraw $properties , float $angle ) : bool

Simula una fotografía Polaroid. Este método está disponible si Imagick ha sido compilado con la versión 6.3.2 o superior de ImageMagick.

Parámetros

properties

Las propiedades de polaroid

angle

El ángulo de polaroid

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::polaroidImage()

Un ejemplo usando Imagick::polaroidImage()

<?php
/* Crear el objeto */
$imagen = new Imagick('fuente.png');

/* Establecer la opacidad */
$imagen->polaroidImage(new ImagickDraw(), 25);

/* Imprimir la imagen */
header('Content-type: image/png');
echo $imagen;

?>


Reduce la imagen a un número limitado de niveles de color

  • « Imagick::polaroidImage
  • Imagick::previewImages »
  • PHP Manual
  • Imagick
  • Reduce la imagen a un número limitado de niveles de color

Imagick::posterizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::posterizeImage — Reduce la imagen a un número limitado de niveles de color

Descripción

Imagick::posterizeImage ( int $levels , bool $dither ) : bool

Reduce la imagen a un número limitado de niveles de color.

Parámetros

levels

dither

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::posterizeImage()

<?php
function posterizeImage($imagePath, $posterizeType, $numberLevels) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->posterizeImage($numberLevels, $posterizeType);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

posterizeImage($imagePath, \Imagick::DITHERMETHOD_RIEMERSMA, 8);

?>


Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen

  • « Imagick::posterizeImage
  • Imagick::previousImage »
  • PHP Manual
  • Imagick
  • Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen

Imagick::previewImages

(PECL imagick 2, PECL imagick 3)

Imagick::previewImages — Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen

Descripción

Imagick::previewImages ( int $preview ) : bool

Crea un mosaico de 9 miniaturas de la imagen especificada con la operación de proceso de imágenes aplicada en varias intensidades. Esto es de útil para precisar rápidamente un parámetro apropiado para una operación de proceso de imágenes.

Parámetros

preview

Tipo de previsualización. Véase constantes de tipos de previsualización

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Se mueve a la imagen previa del objeto

  • « Imagick::previewImages
  • Imagick::profileImage »
  • PHP Manual
  • Imagick
  • Se mueve a la imagen previa del objeto

Imagick::previousImage

(PECL imagick 2, PECL imagick 3)

Imagick::previousImage — Se mueve a la imagen previa del objeto

Descripción

Imagick::previousImage ( ) : bool

Asocia la imagen previa en una lista de imágenes con el objeto Imagick.

Valores devueltos

Devuelve true en caso de éxito.


Añade o elimina un perfil de una imagen

  • « Imagick::previousImage
  • Imagick::quantizeImage »
  • PHP Manual
  • Imagick
  • Añade o elimina un perfil de una imagen

Imagick::profileImage

(PECL imagick 2, PECL imagick 3)

Imagick::profileImage — Añade o elimina un perfil de una imagen

Descripción

Imagick::profileImage ( string $name , string $profile ) : bool

Añade o elimina un perfil ICC, IPTC, o genérico de una imagen. Si el perfil es NULL, se elimina de la imagen, si no, se añade. Use como nombre '*' y un perfil NULL para eliminar todos los perfiles de la imagen.

Parámetros

name

profile

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Analiza los colores dentro de una imagen de referencia

  • « Imagick::profileImage
  • Imagick::quantizeImages »
  • PHP Manual
  • Imagick
  • Analiza los colores dentro de una imagen de referencia

Imagick::quantizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::quantizeImage — Analiza los colores dentro de una imagen de referencia

Descripción

Imagick::quantizeImage ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool

Parámetros

numberColors

colorspace

treedepth

dither

measureError

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::quantizeImage()

<?php
function quantizeImage($imagePath, $numberColors, $colorSpace, $treeDepth, $dither) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->quantizeImage($numberColors, $colorSpace, $treeDepth, $dither, false);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Analiza los colores dentro de una secuencia de imágenes

  • « Imagick::quantizeImage
  • Imagick::queryFontMetrics »
  • PHP Manual
  • Imagick
  • Analiza los colores dentro de una secuencia de imágenes

Imagick::quantizeImages

(PECL imagick 2, PECL imagick 3)

Imagick::quantizeImages — Analiza los colores dentro de una secuencia de imágenes

Descripción

Imagick::quantizeImages ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool

Parámetros

numberColors

colorspace

treedepth

dither

measureError

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Devuelve una matriz que representa las métricas de la fuente

  • « Imagick::quantizeImages
  • Imagick::queryFonts »
  • PHP Manual
  • Imagick
  • Devuelve una matriz que representa las métricas de la fuente

Imagick::queryFontMetrics

(PECL imagick 2, PECL imagick 3)

Imagick::queryFontMetrics — Devuelve una matriz que representa las métricas de la fuente

Descripción

Imagick::queryFontMetrics ( ImagickDraw $properties , string $text , bool $multiline = ? ) : array

Devuelve un array multidimensional que representa las métricas de la fuente.

Parámetros

properties

Objeto ImagickDraw que contiene las propiedades de la fuente

text

El texto

multiline

Parámetro multilínea. Si se deja vacío se autodetecta

Valores devueltos

Devuelve un array multidimensional que representa las métricas de la fuente.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::queryFontMetrics():

Preguntar por las métricas del texto y verter los resultados en la pantalla.

<?php
/* Crear un nuevo objeto Imagick */
$im = new Imagick();

/* Crear un objeto ImagickDraw */
$draw = new ImagickDraw();

/* Establecer la fuente */
$draw->setFont('/path/to/font.ttf');

/* Verter las métricas de la fuente, autodetectado multilínea */
var_dump($im->queryFontMetrics($draw, "¡Hola Mundo!"));
?>


Devuelve las fuentes configuradas

  • « Imagick::queryFontMetrics
  • Imagick::queryFormats »
  • PHP Manual
  • Imagick
  • Devuelve las fuentes configuradas

Imagick::queryFonts

(PECL imagick 2, PECL imagick 3)

Imagick::queryFonts — Devuelve las fuentes configuradas

Descripción

Imagick::queryFonts ( string $pattern = "*" ) : array

Devuelve las fuentes configuradas.

Parámetros

pattern

El patrón de consulta

Valores devueltos

Devuelve un array que contiene las fuentes configuradas.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::queryFonts()

<?php
        $output = '';
        $output .= "Fonts that match 'Helvetica*' are:<br/>";

        $fontList = \Imagick::queryFonts("Helvetica*");

        foreach ($fontList as $fontName) {
            $output .= '<li>'. $fontName."</li>";
        }

        return $output;

?>


Devuelve los formatos soportados por Imagick

  • « Imagick::queryFonts
  • Imagick::radialBlurImage »
  • PHP Manual
  • Imagick
  • Devuelve los formatos soportados por Imagick

Imagick::queryFormats

(PECL imagick 2, PECL imagick 3)

Imagick::queryFormats — Devuelve los formatos soportados por Imagick

Descripción

Imagick::queryFormats ( string $pattern = "*" ) : array

Devuelve los formatos soportados por Imagick.

Parámetros

pattern

Valores devueltos

Devuelve un array que contiene los formatos soportados por Imagick.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::queryFormats()

<?php
    function render() {
        $output = "";
        $input = \Imagick::queryformats();
        $columns = 6;

        $output .= "<table border='2'>";

        for ($i=0; $i < count($input); $i += $columns) {
            $output .= "<tr>";
            for ($c=0; $c<$columns; $c++) {
                $output .= "<td>";
                if (($i + $c) <  count($input)) {
                    $output .= $input[$i + $c];
                }
                $output .= "</td>";
            }
            $output .= "</tr>";
        }

        $output .= "</table>";

        return $output;
    }

?>


Hace borrosa de forma radial una imagen

  • « Imagick::queryFormats
  • Imagick::raiseImage »
  • PHP Manual
  • Imagick
  • Hace borrosa de forma radial una imagen

Imagick::radialBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::radialBlurImage — Hace borrosa de forma radial una imagen

Descripción

Imagick::radialBlurImage ( float $angle , int $channel = Imagick::CHANNEL_ALL ) : bool

Hace borrosa de forma radial una imagen.

Parámetros

angle

channel

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::radialBlurImage()

<?php
function radialBlurImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    //Blur 3 times with different radii
    $imagick->radialBlurImage(3);
    $imagick->radialBlurImage(5);
    $imagick->radialBlurImage(7);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea un efecto de botón en 3D simulado

  • « Imagick::radialBlurImage
  • Imagick::randomThresholdImage »
  • PHP Manual
  • Imagick
  • Crea un efecto de botón en 3D simulado

Imagick::raiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::raiseImage — Crea un efecto de botón en 3D simulado

Descripción

Imagick::raiseImage ( int $width , int $height , int $x , int $y , bool $raise ) : bool

Crea un efecto de botón tridimensional simulado aclarando y oscureciendo los bordes de la imagen. Los miembros ancho y alto de la información de elevación definen el ancho del borde vertical y horizontal del efecto.

Parámetros

width

height

x

y

raise

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::raiseImage()

<?php
function raiseImage($imagePath, $width, $height, $x, $y, $raise) {
    $imagick = new \Imagick(realpath($imagePath));

    //x and y do nothing?
    $imagick->raiseImage($width, $height, $x, $y, $raise);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea una imagen de alto contraste y dos colores

  • « Imagick::raiseImage
  • Imagick::readImage »
  • PHP Manual
  • Imagick
  • Crea una imagen de alto contraste y dos colores

Imagick::randomThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::randomThresholdImage — Crea una imagen de alto contraste y dos colores

Descripción

Imagick::randomThresholdImage ( float $low , float $high , int $channel = Imagick::CHANNEL_ALL ) : bool

Cambia el valor de píxeles individuales basados en la instensidad de cada píxel comparado con el umbral. El resultado es una imagen de alto contraste y dos colores. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

low

El punto bajo

high

El punto alto

channel

Proporcione cualquier constante de canal que sea válida para su modo de canal. Para aplicar más de un canal, combine las constantes channeltype usando operadores a nivel de bits. Consulte esta lista de constantes de canal.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::randomThresholdImage()

<?php
function randomThresholdimage($imagePath, $lowThreshold, $highThreshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->randomThresholdimage(
        $lowThreshold * \Imagick::getQuantum(),
        $highThreshold * \Imagick::getQuantum(),
        $channel
    );
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Lee una imagen desde un nombre de fichero

  • « Imagick::randomThresholdImage
  • Imagick::readImageBlob »
  • PHP Manual
  • Imagick
  • Lee una imagen desde un nombre de fichero

Imagick::readImage

(PECL imagick 2, PECL imagick 3)

Imagick::readImage — Lee una imagen desde un nombre de fichero

Descripción

Imagick::readImage ( string $filename ) : bool

Lee una imagen desde un nombre de fichero

Parámetros

filename

Valores devueltos

Devuelve true en caso de éxito.


Lee una imagen desde un string binario

  • « Imagick::readImage
  • Imagick::readImageFile »
  • PHP Manual
  • Imagick
  • Lee una imagen desde un string binario

Imagick::readImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::readImageBlob — Lee una imagen desde un string binario

Descripción

Imagick::readImageBlob ( string $image , string $filename = ? ) : bool

Lee una imagen desde un string binario

Parámetros

image

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::readImageBlob()

<?php
function readImageBlob() {
    $base64 = "iVBORw0KGgoAAAANSUhEUgAAAM0AAAD
 NCAMAAAAsYgRbAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5c
 cllPAAAABJQTFRF3NSmzMewPxIG//ncJEJsldTou1jHgAAAARBJREFUeNrs2EEK
 gCAQBVDLuv+V20dENbMY831wKz4Y/VHb/5RGQ0NDQ0NDQ0NDQ0NDQ0NDQ
 0NDQ0NDQ0NDQ0NDQ0NDQ0NDQ0PzMWtyaGhoaGhoaGhoaGhoaGhoxtb0QGho
 aGhoaGhoaGhoaGhoaMbRLEvv50VTQ9OTQ5OpyZ01GpM2g0bfmDQaL7S+ofFC6x
 v3ZpxJiywakzbvd9r3RWPS9I2+MWk0+kbf0Hih9Y17U0nTHibrDDQ0NDQ0NDQ0
 NDQ0NDQ0NTXbRSL/AK72o6GhoaGhoRlL8951vwsNDQ0NDQ1NDc0WyHtDTEhD
 Q0NDQ0NTS5MdGhoaGhoaGhoaGhoaGhoaGhoaGhoaGposzSHAAErMwwQ2HwRQ
 AAAAAElFTkSuQmCC";

    $imageBlob = base64_decode($base64);

    $imagick = new Imagick();
    $imagick->readImageBlob($imageBlob);

    header("Content-Type: image/png");
    echo $imagick;
}

?>


Lee una imagen desde un gestor de fichero abierto

  • « Imagick::readImageBlob
  • Imagick::readimages »
  • PHP Manual
  • Imagick
  • Lee una imagen desde un gestor de fichero abierto

Imagick::readImageFile

(PECL imagick 2, PECL imagick 3)

Imagick::readImageFile — Lee una imagen desde un gestor de fichero abierto

Descripción

Imagick::readImageFile ( resource $filehandle , string $fileName = null ) : bool

Lee una imagen desde un gestor de fichero abierto

Parámetros

filehandle

fileName

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Description

  • « Imagick::readImageFile
  • Imagick::recolorImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::readimages

(PECL imagick 2, PECL imagick 3)

Imagick::readimages — Description

Descripción

public Imagick::readImages ( array $filenames ) : bool

Reads image from an array of filenames. All the images are held in a single Imagick object.

Parámetros

filenames

Valores devueltos

Devuelve true en caso de éxito.


Re-colorea una imagen

  • « Imagick::readimages
  • Imagick::reduceNoiseImage »
  • PHP Manual
  • Imagick
  • Re-colorea una imagen

Imagick::recolorImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::recolorImage — Re-colorea una imagen

Descripción

Imagick::recolorImage ( array $matrix ) : bool

Traslada, escala, recorta, o rota colores de imagen. Este método soporta matrices de tamaño variable pero normalmente se usa una matriz de 5x5 para RGBA y de 6x6 para CMYK. La última fila debería contener los valores normalizados. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

matrix

La matriz que contiene los valores de los colores

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::displayImage() - Muestra una imagen

Ejemplos

Ejemplo #1 Imagick::recolorImage()

<?php
function recolorImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $remapColor = [ 1, 0, 0,
        0, 0, 1,
        0, 1, 0,];

//$remapColor = [
//    1.438, -0.122, -0.016,  0, 0, -0.03,
//    -0.062,  1.378, -0.016,  0, 0,  0.05,
//    -0.062, -0.122, 1.483,   0, 0, -0.02,
//];

    @$imagick->recolorImage($remapColor);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Suaviza los contornos de una imagen

  • « Imagick::recolorImage
  • Imagick::remapImage »
  • PHP Manual
  • Imagick
  • Suaviza los contornos de una imagen

Imagick::reduceNoiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::reduceNoiseImage — Suaviza los contornos de una imagen

Descripción

Imagick::reduceNoiseImage ( float $radius ) : bool

Suaviza los contornos de una imagen mientras que se preserva todavía la información del borde. El algoritmo funciona reemplazando cada píxel con su más cercano inmediato en valor. La zona inmediata está definida por el radio. Use un radio de 0 y Imagick::reduceNoiseImage() seleccionará una radio apropiado automáticamente.

Parámetros

radius

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::reduceNoiseImage()

<?php
function reduceNoiseImage($imagePath, $reduceNoise) {
    $imagick = new \Imagick(realpath($imagePath));
    @$imagick->reduceNoiseImage($reduceNoise);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Re-mapea los colores de una imagen

  • « Imagick::reduceNoiseImage
  • Imagick::removeImage »
  • PHP Manual
  • Imagick
  • Re-mapea los colores de una imagen

Imagick::remapImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::remapImage — Re-mapea los colores de una imagen

Descripción

public Imagick::remapImage ( Imagick $replacement , int $DITHER ) : bool

Reemplaza los colores de una imagen con los definidos por el parámetro replacement. Los colores son reemplazados con el color más cercano posible. Este método está disponible si Imagick ha sido compilado con la versión 6.4.5 o superior de ImageMagick.

Parámetros

replacement

Un objeto Imagick que contiene los colores sustitutos

DITHER

Consulte esta lista de constantes de métodos de entramado

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Quita una imagen de la lista de imágenes

  • « Imagick::remapImage
  • Imagick::removeImageProfile »
  • PHP Manual
  • Imagick
  • Quita una imagen de la lista de imágenes

Imagick::removeImage

(PECL imagick 2, PECL imagick 3)

Imagick::removeImage — Quita una imagen de la lista de imágenes

Descripción

Imagick::removeImage ( ) : bool

Quita una imagen de la lista de imágenes.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Elimina el perfil nominado de la imagen y lo devuelve

  • « Imagick::removeImage
  • Imagick::render »
  • PHP Manual
  • Imagick
  • Elimina el perfil nominado de la imagen y lo devuelve

Imagick::removeImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::removeImageProfile — Elimina el perfil nominado de la imagen y lo devuelve

Descripción

Imagick::removeImageProfile ( string $name ) : string

Elimina el perfil con nombre de la imagen y lo devuelve.

Parámetros

name

Valores devueltos

Devuelve un string que contiene el perfil de la imagen.

Errores/Excepciones

Lanza ImagickException en caso de error.


Renderiza todos los comandos de dibujo precedentes

  • « Imagick::removeImageProfile
  • Imagick::resampleImage »
  • PHP Manual
  • Imagick
  • Renderiza todos los comandos de dibujo precedentes

Imagick::render

(PECL imagick 2, PECL imagick 3)

Imagick::render — Renderiza todos los comandos de dibujo precedentes

Descripción

Imagick::render ( ) : bool

Renderiza todos los comandos de dibujo precedentes.

Valores devueltos

Devuelve true en caso de éxito.


Remuestrea la imagen a la resolución deseada

  • « Imagick::render
  • Imagick::resetImagePage »
  • PHP Manual
  • Imagick
  • Remuestrea la imagen a la resolución deseada

Imagick::resampleImage

(PECL imagick 2, PECL imagick 3)

Imagick::resampleImage — Remuestrea la imagen a la resolución deseada

Descripción

Imagick::resampleImage ( float $x_resolution , float $y_resolution , int $filter , float $blur ) : bool

Remuestrea la imagen a la resolución deseada.

Parámetros

x_resolution

y_resolution

filter

blur

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::resampleImage()

<?php
function resampleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->resampleImage(200, 200, \Imagick::FILTER_LANCZOS, 1);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Reinicia una página de imagen

  • « Imagick::resampleImage
  • Imagick::resizeImage »
  • PHP Manual
  • Imagick
  • Reinicia una página de imagen

Imagick::resetImagePage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::resetImagePage — Reinicia una página de imagen

Descripción

Imagick::resetImagePage ( string $page ) : bool

La definición de página como un string. La string está en formato WxH+x+y (Ancho+Alto+x+y). Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

page

La definición de página. Por ejemplo 7168x5147+0+0

Valores devueltos

Devuelve true en caso de éxito.


Escala una imagen

  • « Imagick::resetImagePage
  • Imagick::rollImage »
  • PHP Manual
  • Imagick
  • Escala una imagen

Imagick::resizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::resizeImage — Escala una imagen

Descripción

Imagick::resizeImage ( int $columns , int $rows , int $filter , float $blur , bool $bestfit = false ) : bool

Escala una imagen a las dimensiones deseadas con un filtro.

Nota: La conducta del parámetro bestfit cambió en Imagick 3.0.0. Antes de esta versión dar la dimensión de 400x400 a una imagen de 200x150 debería no tener efecto. En Imagick 3.0.0 y superiores la imagen sería llevada al tamaño de 400x300 ya que este es el "mejor ajuste" para las dimensiones dadas. Si el parámetro bestfit es utilizado, se debe indicar tanto el ancho como el alto.

Parámetros

columns

Ancho de la imagen

rows

Alto de la imagen

filter

Consulte la lista de constantes de filtro.

blur

El factor de borrosidad donde > 1 es borroso, < 1 es nítido.

bestfit

Parámetro de ajuste opcional.

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Añadido el parámetro opcional de ajuste. Este método ahora soporta escalas proporcionales. Pase cero como parámetro para escalar proporcionalmente.

Ejemplos

Ejemplo #1 Imagick::resizeImage()

<?php
function resizeImage($imagePath, $width, $height, $filterType, $blur, $bestFit, $cropZoom) {
    //The blur factor where &gt; 1 is blurry, &lt; 1 is sharp.
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->resizeImage($width, $height, $filterType, $blur, $bestFit);

    $cropWidth = $imagick->getImageWidth();
    $cropHeight = $imagick->getImageHeight();

    if ($cropZoom) {
        $newWidth = $cropWidth / 2;
        $newHeight = $cropHeight / 2;

        $imagick->cropimage(
            $newWidth,
            $newHeight,
            ($cropWidth - $newWidth) / 2,
            ($cropHeight - $newHeight) / 2
        );

        $imagick->scaleimage(
            $imagick->getImageWidth() * 4,
            $imagick->getImageHeight() * 4
        );
    }

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Compensa una imagen

  • « Imagick::resizeImage
  • Imagick::rotateImage »
  • PHP Manual
  • Imagick
  • Compensa una imagen

Imagick::rollImage

(PECL imagick 2, PECL imagick 3)

Imagick::rollImage — Compensa una imagen

Descripción

Imagick::rollImage ( int $x , int $y ) : bool

Compensa una imagen como está definido por x e y.

Parámetros

x

El índice X.

y

El índice Y.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::rollImage()

<?php
function rollImage($imagePath, $rollX, $rollY) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rollimage($rollX, $rollY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Rota una imagen

  • « Imagick::rollImage
  • Imagick::rotationalBlurImage »
  • PHP Manual
  • Imagick
  • Rota una imagen

Imagick::rotateImage

(PECL imagick 2, PECL imagick 3)

Imagick::rotateImage — Rota una imagen

Descripción

Imagick::rotateImage ( mixed $background , float $degrees ) : bool

Rota una imagen el número de grados especificado. Los triángulos vacíos sobrantes por la rotación de la imagen se rellenan con el color de fondo.

Parámetros

background

El color de fondo

degrees

Ángulo de rotación, en grados. El ángulo de rotación se interpreta como el número de grados a rotar la imagen en sentido de las agujas del reloj.

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una string represente el color como primer parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::rotateImage()

<?php
function rotateImage($imagePath, $angle, $color) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rotateimage($color, $angle);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::rotateImage
  • Imagick::roundCorners »
  • PHP Manual
  • Imagick
  • Description

Imagick::rotationalBlurImage

(PECL imagick 3 >= 3.3.0)

Imagick::rotationalBlurImage — Description

Descripción

public Imagick::rotationalBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Rotational blurs an image.

Parámetros

angle

The angle to apply the blur over.

channel

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::rotationalBlurImage()

<?php
function rotationalBlurImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rotationalBlurImage(3);
    $imagick->rotationalBlurImage(5);
    $imagick->rotationalBlurImage(7);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Redondea las esquinas de una imagen

  • « Imagick::rotationalBlurImage
  • Imagick::sampleImage »
  • PHP Manual
  • Imagick
  • Redondea las esquinas de una imagen

Imagick::roundCorners

(PECL imagick 2, PECL imagick 3)

Imagick::roundCorners — Redondea las esquinas de una imagen

Descripción

Imagick::roundCorners ( float $x_rounding , float $y_rounding , float $stroke_width = 10 , float $displace = 5 , float $size_correction = -6 ) : bool

Redondea las esquinas de una imagen. Los dos primeros parámetros controlan la cantidad de redondeo y los tres últimos parámetros se pueden usar para afinar el proceso de redondeo. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

x_rounding

redondeo x

y_rounding

redondeo y

stroke_width

ancho del contorno

displace

desplazamiento de la imagen

size_correction

corrección del tamaño

Ejemplos

Ejemplo #1 Usar Imagick::roundCorners():

Redondear las esquinas de una imagen

<?php

$imagen = new Imagick();
$imagen->newPseudoImage(100, 100, "magick:rose");
$imagen->setImageFormat("png");

$imagen->roundCorners(5,3);
$imagen->writeImage("redondeada.png");
?>

Valores devueltos

Devuelve true en caso de éxito.


Escala una imagen con un muestreo de píxeles

  • « Imagick::roundCorners
  • Imagick::scaleImage »
  • PHP Manual
  • Imagick
  • Escala una imagen con un muestreo de píxeles

Imagick::sampleImage

(PECL imagick 2, PECL imagick 3)

Imagick::sampleImage — Escala una imagen con un muestreo de píxeles

Descripción

Imagick::sampleImage ( int $columns , int $rows ) : bool

Escala una imagen a las dimensiones deseadas con un muestreo de píxeles. A diferencia de otros métodos de escala, este método no introduce colores adicionales en la imagen escalada.

Parámetros

columns

rows

Valores devueltos

Devuelve true en caso de éxito.


Escala el tamaño de una imagen

  • « Imagick::sampleImage
  • Imagick::segmentImage »
  • PHP Manual
  • Imagick
  • Escala el tamaño de una imagen

Imagick::scaleImage

(PECL imagick 2, PECL imagick 3)

Imagick::scaleImage — Escala el tamaño de una imagen

Descripción

Imagick::scaleImage ( int $cols , int $rows , bool $bestfit = false ) : bool

Escala el tamaño de una imagen a las dimensiones dadas. El otro parámetro será calculado si se pasa 0 como parámetro.

Nota: La conducta del parámetro bestfit cambió en Imagick 3.0.0. Antes de esta versión dar la dimensión de 400x400 a una imagen de 200x150 debería no tener efecto. En Imagick 3.0.0 y superiores la imagen sería llevada al tamaño de 400x300 ya que este es el "mejor ajuste" para las dimensiones dadas. Si el parámetro bestfit es utilizado, se debe indicar tanto el ancho como el alto.

Parámetros

cols

rows

bestfit

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Añadido el parámetro opcional de ajuste. Este método ahora soporta escalas proporcionales. Pase cero como parámetro para escalar proporcionalmente.

Ejemplos

Ejemplo #1 Imagick::scaleImage()

<?php
function scaleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->scaleImage(150, 150, true);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Segmenta una imagen

  • « Imagick::scaleImage
  • Imagick::selectiveBlurImage »
  • PHP Manual
  • Imagick
  • Segmenta una imagen

Imagick::segmentImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::segmentImage — Segmenta una imagen

Descripción

public Imagick::segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold , bool $verbose = false ) : bool

Aanaliza la imagen e identifica unidades que son similares. Este método está disponible si Imagick ha sido compilado con la versión 6.4.5 o superior de ImageMagick.

Parámetros

COLORSPACE

Una de las constantes COLORSPACE.

cluster_threshold

Un porcentaje que describe el número mínimo de píxeles contenidos en la exedra antes de que se considere válido.

smooth_threshold

Elimina el ruido del histograma.

verbose

Si se imprime información detallada acerca de las clases reconocidas.

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::segmentImage()

<?php
function segmentImage($imagePath, $colorSpace, $clusterThreshold, $smoothThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->segmentImage($colorSpace, $clusterThreshold, $smoothThreshold);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

segmentImage($imagePath, \Imagick::COLORSPACE_RGB, 5, 5);

?>


Description

  • « Imagick::segmentImage
  • Imagick::separateImageChannel »
  • PHP Manual
  • Imagick
  • Description

Imagick::selectiveBlurImage

(PECL imagick 3 >= 3.3.0)

Imagick::selectiveBlurImage — Description

Descripción

public Imagick::selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $CHANNEL ) : void

Desenfoca una imagen con un umbral de contraste. Es similar a la máscara 'unsharpen' que enfoca todo con un contraste superior a un cierto umbral.

Parámetros

radius

sigma

threshold

CHANNEL

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::selectiveBlurImage()

<?php
function selectiveBlurImage($imagePath, $radius, $sigma, $threshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->selectiveBlurImage($radius, $sigma, $threshold, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Separa un canal de la imagen

  • « Imagick::selectiveBlurImage
  • Imagick::sepiaToneImage »
  • PHP Manual
  • Imagick
  • Separa un canal de la imagen

Imagick::separateImageChannel

(PECL imagick 2, PECL imagick 3)

Imagick::separateImageChannel — Separa un canal de la imagen

Descripción

Imagick::separateImageChannel ( int $channel ) : bool

Separa un canal de la imagen y devuelve una imagen en escala de grises. Un canal es un componente de color en particular de cada píxel de la imagen.

Parámetros

channel

Qué 'canal' devolver. Para espacios de color distintos del RGB, aún se pueden utilizar las constantes CHANNEL_RED, CHANNEL_GREEN, CHANNEL_BLUE para indicar el primer, segundo y tercer canal.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::separateImageChannel()

<?php
function separateImageChannel($imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->separateimagechannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

separateImageChannel($imagePath, \Imagick::CHANNEL_GREEN);

?>


Pone una imagen en tono sepia

  • « Imagick::separateImageChannel
  • Imagick::setBackgroundColor »
  • PHP Manual
  • Imagick
  • Pone una imagen en tono sepia

Imagick::sepiaToneImage

(PECL imagick 2, PECL imagick 3)

Imagick::sepiaToneImage — Pone una imagen en tono sepia

Descripción

Imagick::sepiaToneImage ( float $threshold ) : bool

Aplica un efecto especial a la imagen, similar al efecto logrado en un cuarto oscuro fotográfico aplicando un tono sepia. El umbral tiene un rango desde 0 hasta el de QuantumRange y es una medida de la extensión del tono sepia. Un umbral de 80 es un buen punto de partida para un tono razonable.

Parámetros

threshold

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::sepiaToneImage()

<?php
function sepiaToneImage($imagePath, $sepia) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sepiaToneImage($sepia);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Establece el color de fondo por omisión del objeto

  • « Imagick::sepiaToneImage
  • Imagick::setColorspace »
  • PHP Manual
  • Imagick
  • Establece el color de fondo por omisión del objeto

Imagick::setBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::setBackgroundColor — Establece el color de fondo por omisión del objeto

Descripción

Imagick::setBackgroundColor ( mixed $background ) : bool

Establece el color de fondo por omisión del objeto.

Parámetros

background

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que un string represente el color como un parámetro. Las versiones anteriores sólo permiten un objeto ImagickPixel.


Establecer el espacio de color

  • « Imagick::setBackgroundColor
  • Imagick::setCompression »
  • PHP Manual
  • Imagick
  • Establecer el espacio de color

Imagick::setColorspace

(PECL imagick 3)

Imagick::setColorspace — Establecer el espacio de color

Descripción

Imagick::setColorspace ( int $COLORSPACE ) : bool

Establece el valor del espacio de color global para el objeto. Este método está disponible si Imagick ha sido compilado con la versión 6.5.7 o superior de ImageMagick.

Parámetros

COLORSPACE

Una de las constantes COLORSPACE

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el tipo de compresión predeterminado del objeto

  • « Imagick::setColorspace
  • Imagick::setCompressionQuality »
  • PHP Manual
  • Imagick
  • Establece el tipo de compresión predeterminado del objeto

Imagick::setCompression

(PECL imagick 2, PECL imagick 3)

Imagick::setCompression — Establece el tipo de compresión predeterminado del objeto

Descripción

Imagick::setCompression ( int $compression ) : bool

Establece el tipo de compresión predeterminado del objeto

Parámetros

compression

Valores devueltos

Devuelve true en caso de éxito.


Establece la calidad de compresión predeterminda del objeto

  • « Imagick::setCompression
  • Imagick::setFilename »
  • PHP Manual
  • Imagick
  • Establece la calidad de compresión predeterminda del objeto

Imagick::setCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::setCompressionQuality — Establece la calidad de compresión predeterminda del objeto

Descripción

Imagick::setCompressionQuality ( int $quality ) : bool

Establece la calidad de compresión predeterminda del objeto.

Precaución

Este método solamente funciona para imágenes nuevas, p.ej., aquellas creadas con Imagick::newPseudoImage. Para imágenes ya existentes se debería utilizar Imagick::setImageCompressionQuality().

Parámetros

quality

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::setCompressionQuality()

<?php
function setCompressionQuality($imagePath, $quality) {

    $backgroundImagick = new \Imagick(realpath($imagePath));
    $imagick = new \Imagick();
    $imagick->setCompressionQuality($quality);
    $imagick->newPseudoImage(
        $backgroundImagick->getImageWidth(),
        $backgroundImagick->getImageHeight(),
        'canvas:white'
    );

    $imagick->compositeImage(
        $backgroundImagick,
        \Imagick::COMPOSITE_ATOP,
        0,
        0
    );

    $imagick->setFormat("jpg");
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Establece el nombre de archivo antes de que se lea o escriba una imagen

  • « Imagick::setCompressionQuality
  • Imagick::setFirstIterator »
  • PHP Manual
  • Imagick
  • Establece el nombre de archivo antes de que se lea o escriba una imagen

Imagick::setFilename

(PECL imagick 2, PECL imagick 3)

Imagick::setFilename — Establece el nombre de archivo antes de que se lea o escriba una imagen

Descripción

Imagick::setFilename ( string $filename ) : bool

Establece el nombre de fichero antes de que se lea o escriba un fichero de imagen.

Parámetros

filename

Valores devueltos

Devuelve true en caso de éxito.


Establece el iterador Imagick para la primera imagen

  • « Imagick::setFilename
  • Imagick::setFont »
  • PHP Manual
  • Imagick
  • Establece el iterador Imagick para la primera imagen

Imagick::setFirstIterator

(PECL imagick 2, PECL imagick 3)

Imagick::setFirstIterator — Establece el iterador Imagick para la primera imagen

Descripción

Imagick::setFirstIterator ( ) : bool

Establece el iterador Imagick para la primera imagen.

Valores devueltos

Devuelve true en caso de éxito.


Establece el tipo de letra

  • « Imagick::setFirstIterator
  • Imagick::setFormat »
  • PHP Manual
  • Imagick
  • Establece el tipo de letra

Imagick::setFont

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setFont — Establece el tipo de letra

Descripción

Imagick::setFont ( string $font ) : bool

Establece la propiedad 'font' del objeto. Este método se puede usar para, por ejemplo, establecer el tipo de letra para una leyenda: pseudo-formato. El tipo de letra necesita estar configurado en la configuración de ImageMagick o ser un fichero cuyo nombre de font debe existir. Este método no debería confundirse con ImagickDraw::setFont() el cuál establece el tipo de letra para un objeto ImagickDraw específico. Este método está disponible si Imagick ha sido compilado con la versión 6.3.7 o superior de ImageMagick.

Parámetros

font

El nombre del tipo de letra o un nombre de fichero

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::getFont() - Obtiene la fuente
  • ImagickDraw::setFont() - Establece la fuente especificada completamente para usarla cuando se escribe texto
  • ImagickDraw::getFont() - Devuelve la fuente

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::setFont()

Ejemplo usando Imagick::setFont

<?php
/* Crear un nuevo objeto imagick */
$im = new Imagick();

/* Establecer el tipo de letra para el objeto */
$im->setFont("example.ttf");

/* Crear una leyenda nueva */
$im->newPseudoImage(100, 100, "caption:Hola");

/* Hacer algo con la imagen */
?>


Establece el formato del objeto Imagick

  • « Imagick::setFont
  • Imagick::setGravity »
  • PHP Manual
  • Imagick
  • Establece el formato del objeto Imagick

Imagick::setFormat

(PECL imagick 2, PECL imagick 3)

Imagick::setFormat — Establece el formato del objeto Imagick

Descripción

Imagick::setFormat ( string $format ) : bool

Establece el formato del objeto Imagick.

Parámetros

format

Valores devueltos

Devuelve true en caso de éxito.


Establece la gravedad

  • « Imagick::setFormat
  • Imagick::setImage »
  • PHP Manual
  • Imagick
  • Establece la gravedad

Imagick::setGravity

(PECL imagick 2 >= 2.2.0, PECL imagick 3)

Imagick::setGravity — Establece la gravedad

Descripción

Imagick::setGravity ( int $gravity ) : bool

Establece la propiedad gravedad global para el objeto Imagick. Este método está disponible si Imagick ha sido compilado con la versión 6.4.0 o superior de ImageMagick.

Parámetros

gravity

La propiedad gravedad. Consulte esta lista de constantes de gravedad.

Valores devueltos

No devuelve ningún valor.


Reemplaza una imagen en el objeto

  • « Imagick::setGravity
  • Imagick::setImageAlphaChannel »
  • PHP Manual
  • Imagick
  • Reemplaza una imagen en el objeto

Imagick::setImage

(PECL imagick 2, PECL imagick 3)

Imagick::setImage — Reemplaza una imagen en el objeto

Descripción

Imagick::setImage ( Imagick $replace ) : bool

Reemplaza la secuencia de imágenes actual por la imagen del objeto sustituto.

Parámetros

replace

El objeto Imagick sustituto.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::setImage()

Un ejemplo usando Imagick::setImage()

<?php
/* Crear los objetos */
$imagen = new Imagick('origen.jpg');
$sustituto = new Imagick('sustituto.jpg');

/* origen.jpg es reemplazado por sustituto.jpg */
$imagen->setImage($sustituto);

/* imprimir la imagen */
header('Content-type: image/jpeg');
echo $imagen;

?>


Establece el canal alfa de la imagen

  • « Imagick::setImage
  • Imagick::setImageArtifact »
  • PHP Manual
  • Imagick
  • Establece el canal alfa de la imagen

Imagick::setImageAlphaChannel

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setImageAlphaChannel — Establece el canal alfa de la imagen

Descripción

Imagick::setImageAlphaChannel ( int $mode ) : bool

Activa o desactiva el canal alfa de la imagen. El parámetro mode es una de las constantes Imagick::ALPHACHANNEL_*. Este método está disponible si Imagick ha sido compilado con la versión 6.3.8 o superior de ImageMagick.

Parámetros

mode

Una de las constantes Imagick::ALPHACHANNEL_*

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::setImageMatte() - Establece el canal mate de la imagen
  • Constantes del canal alfa de Imagick


Establecer un artefacto de imagen

  • « Imagick::setImageAlphaChannel
  • Imagick::setImageAttribute »
  • PHP Manual
  • Imagick
  • Establecer un artefacto de imagen

Imagick::setImageArtifact

(PECL imagick 3)

Imagick::setImageArtifact — Establecer un artefacto de imagen

Descripción

Imagick::setImageArtifact ( string $artifact , string $value ) : bool

Asocia un artefacto con una imagen. La diferencia entre las propiedades de imagen y los artefactos de imagen es que las propiedades son públicas y los artefactos son privados. Este método está disponible si Imagick ha sido compilado con la versión 6.5.7 o superior de ImageMagick.

Parámetros

artifact

El nombre del artefacto

value

El valor del artefacto

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::getImageArtifact() - Obtener el artefacto de imagen
  • Imagick::deleteImageArtifact() - Borra un artefacto de imagen

Ejemplos

Ejemplo #1 Imagick::setImageArtifact()

<?php
function setImageArtifact() {

    $src1 = new \Imagick(realpath("./images/artifact/source1.png"));
    $src2 = new \Imagick(realpath("./images/artifact/source2.png"));

    $src2->setImageVirtualPixelMethod(\Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);
    $src2->setImageArtifact('compose:args', "1,0,-0.5,0.5");
    $src1->compositeImage($src2, Imagick::COMPOSITE_MATHEMATICS, 0, 0);

    $src1->setImageFormat('png');
    header("Content-Type: image/png");
    echo $src1->getImagesBlob();
}

?>


Description

  • « Imagick::setImageArtifact
  • Imagick::setImageBackgroundColor »
  • PHP Manual
  • Imagick
  • Description

Imagick::setImageAttribute

(PECL imagick 2, PECL imagick 3)

Imagick::setImageAttribute — Description

Descripción

public Imagick::setImageAttribute ( string $key , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

key

value

Valores devueltos


Establece el color de fondo de la imagen

  • « Imagick::setImageAttribute
  • Imagick::setImageBias »
  • PHP Manual
  • Imagick
  • Establece el color de fondo de la imagen

Imagick::setImageBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBackgroundColor — Establece el color de fondo de la imagen

Descripción

Imagick::setImageBackgroundColor ( mixed $background ) : bool

Establece el color de fondo de la imagen.

Parámetros

background

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que un string represente el color como un parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.


Establece el sesgo de la imagen para cualquier método que convolucione una imagen

  • « Imagick::setImageBackgroundColor
  • Imagick::setImageBiasQuantum »
  • PHP Manual
  • Imagick
  • Establece el sesgo de la imagen para cualquier método que convolucione una imagen

Imagick::setImageBias

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBias — Establece el sesgo de la imagen para cualquier método que convolucione una imagen

Descripción

Imagick::setImageBias ( float $bias ) : bool

Establece el sesgo de la imagen para cualquier método que convolucione una imagen (p.ej. Imagick::ConvolveImage()).

Parámetros

bias

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::setImageBias()

<?php
//requires ImageMagick version 6.9.0-1 to have an effect on convolveImage
function setImageBias($bias) {
    $imagick = new \Imagick(realpath("images/stack.jpg"));

    $xKernel = array(
        -0.70, 0, 0.70,
        -0.70, 0, 0.70,
        -0.70, 0, 0.70
    );

    $imagick->setImageBias($bias * \Imagick::getQuantum());
    $imagick->convolveImage($xKernel, \Imagick::CHANNEL_ALL);

    $imagick->setImageFormat('png');

    header('Content-type: image/png');
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::setImageBias
  • Imagick::setImageBluePrimary »
  • PHP Manual
  • Imagick
  • Description

Imagick::setImageBiasQuantum

(PECL imagick 3 >= 3.3.0)

Imagick::setImageBiasQuantum — Description

Advertencia

This function has been DEPRECATED as of Imagick 3.4.4. Relying on this function is highly discouraged.

Descripción

public Imagick::setImageBiasQuantum ( string $bias ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

bias

Valores devueltos


Establece el punto primario azul de la cromaticidad de la imagen

  • « Imagick::setImageBiasQuantum
  • Imagick::setImageBorderColor »
  • PHP Manual
  • Imagick
  • Establece el punto primario azul de la cromaticidad de la imagen

Imagick::setImageBluePrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBluePrimary — Establece el punto primario azul de la cromaticidad de la imagen

Descripción

Imagick::setImageBluePrimary ( float $x , float $y ) : bool

Establece el punto primario azul de la cromaticidad de la imagen.

Parámetros

x

y

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el color de borde de la imagen

  • « Imagick::setImageBluePrimary
  • Imagick::setImageChannelDepth »
  • PHP Manual
  • Imagick
  • Establece el color de borde de la imagen

Imagick::setImageBorderColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBorderColor — Establece el color de borde de la imagen

Descripción

Imagick::setImageBorderColor ( mixed $border ) : bool

Establece el color de borde de la imagen.

Parámetros

border

El color de borde

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que un string represente el color como parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.


Establece la profundidad de una canal de imagen en particular

  • « Imagick::setImageBorderColor
  • Imagick::setImageClipMask »
  • PHP Manual
  • Imagick
  • Establece la profundidad de una canal de imagen en particular

Imagick::setImageChannelDepth

(PECL imagick 2, PECL imagick 3)

Imagick::setImageChannelDepth — Establece la profundidad de una canal de imagen en particular

Descripción

Imagick::setImageChannelDepth ( int $channel , int $depth ) : bool

Establece la profundidad de una canal de imagen en particular.

Parámetros

channel

depth

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la máscara de recorte de una imagen

  • « Imagick::setImageChannelDepth
  • Imagick::setImageColormapColor »
  • PHP Manual
  • Imagick
  • Establece la máscara de recorte de una imagen

Imagick::setImageClipMask

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::setImageClipMask — Establece la máscara de recorte de una imagen

Descripción

Imagick::setImageClipMask ( Imagick $clip_mask ) : bool

Establece la máscara de recorte de una imagen desde otro objeto Imagick. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

clip_mask

El objeto Imagick que contiene la máscara de recorte

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::setImageClipMask()

<?php
function setImageClipMask($imagePath) {
    $imagick = new \Imagick();
    $imagick->readImage(realpath($imagePath));

    $width = $imagick->getImageWidth();
    $height = $imagick->getImageHeight();

    $clipMask = new \Imagick();
    $clipMask->newPseudoImage(
        $width,
        $height,
        "canvas:transparent"
    );

    $draw = new \ImagickDraw();
    $draw->setFillColor('white');
    $draw->circle(
        $width / 2,
        $height / 2,
        ($width / 2) + ($width / 4),
        $height / 2
    );
    $clipMask->drawImage($draw);
    $imagick->setImageClipMask($clipMask);

    $imagick->negateImage(false);
    $imagick->setFormat("png");

    header("Content-Type: image/png");
    echo $imagick->getImagesBlob();

}

?>


Establece el color de un índice de mapa de color especificado

  • « Imagick::setImageClipMask
  • Imagick::setImageColorspace »
  • PHP Manual
  • Imagick
  • Establece el color de un índice de mapa de color especificado

Imagick::setImageColormapColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageColormapColor — Establece el color de un índice de mapa de color especificado

Descripción

Imagick::setImageColormapColor ( int $index , ImagickPixel $color ) : bool

Establece el color de un índice de mapa de color especificado.

Parámetros

index

color

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el espacio de color de una imagen

  • « Imagick::setImageColormapColor
  • Imagick::setImageCompose »
  • PHP Manual
  • Imagick
  • Establece el espacio de color de una imagen

Imagick::setImageColorspace

(PECL imagick 2, PECL imagick 3)

Imagick::setImageColorspace — Establece el espacio de color de una imagen

Descripción

Imagick::setImageColorspace ( int $colorspace ) : bool

Establece el espacio de color de una imagen. Este método debería emplearse al crear imágenes nuevas. Para cambiar el espacio de color de una imagen existente se debería utilizar Imagick::transformImageColorspace().

Parámetros

colorspace

Una de las constantes COLORSPACE

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el operador de composción de una imagen

  • « Imagick::setImageColorspace
  • Imagick::setImageCompression »
  • PHP Manual
  • Imagick
  • Establece el operador de composción de una imagen

Imagick::setImageCompose

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompose — Establece el operador de composción de una imagen

Descripción

Imagick::setImageCompose ( int $compose ) : bool

Establece el operador de composción de una imagen, útil para especificar cómo componer la miniatura de la imagen cuando se usa el método Imagick::montageImage().

Parámetros

compose

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la compresión de una imagen

  • « Imagick::setImageCompose
  • Imagick::setImageCompressionQuality »
  • PHP Manual
  • Imagick
  • Establece la compresión de una imagen

Imagick::setImageCompression

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompression — Establece la compresión de una imagen

Descripción

Imagick::setImageCompression ( int $compression ) : bool

Parámetros

compression

Una de las constantes COMPRESSION

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la calidad de compresión de una imagen

  • « Imagick::setImageCompression
  • Imagick::setImageDelay »
  • PHP Manual
  • Imagick
  • Establece la calidad de compresión de una imagen

Imagick::setImageCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompressionQuality — Establece la calidad de compresión de una imagen

Descripción

Imagick::setImageCompressionQuality ( int $quality ) : bool

Establece la calidad de compresión de una imagen.

Parámetros

quality

La calidad de compresión de la imagen como un integer

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::setImageCompressionQuality()

<?php
function setImageCompressionQuality($imagePath, $quality) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageCompressionQuality($quality);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Establece el retardo de una imagen

  • « Imagick::setImageCompressionQuality
  • Imagick::setImageDepth »
  • PHP Manual
  • Imagick
  • Establece el retardo de una imagen

Imagick::setImageDelay

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDelay — Establece el retardo de una imagen

Descripción

Imagick::setImageDelay ( int $delay ) : bool

Establece el retardo de una imagen. Para una imagen animada, esto es la cantidad de tiempo que debería mostrarse este marco de la imagen, antes de mostrar el siguiente marco.

El retardo se puede establecer individualmente para cada marco de una imagen.

Parámetros

delay

La cantidad de tiempo expresado en 'ticks' que debería mostrarse la imagen. Para GIFs animados son 100 ticks por segundo, por lo que un valor de 20 sería 20/100 de un segundo, es decir 1/5 de un segundo.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Modificar un GIF animado con Imagick::setImageDelay()

<?php

// Modificar un GIF animado, y así sus marcos se reproduzcan a una velocidad variable,
// variando entre que se muestre para 50ms hasta 0ms, que causará que el marco
// sea saltado en la mayoría de los navegadores.
$imagick = new Imagick(realpath("Test.gif"));
$imagick = $imagick->coalesceImages();

$numMarcos = 0;

foreach ($imagick as $marco) {
    $imagick->setImageDelay((($numMarcos % 11) * 5));
    $numMarcos++;
}

$imagick = $imagick->deconstructImages();

$imagick->writeImages("/ruta/donde/guardar/output.gif", true);

?>


Establece la profundidad de una imagen

  • « Imagick::setImageDelay
  • Imagick::setImageDispose »
  • PHP Manual
  • Imagick
  • Establece la profundidad de una imagen

Imagick::setImageDepth

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDepth — Establece la profundidad de una imagen

Descripción

Imagick::setImageDepth ( int $depth ) : bool

Establece la profundidad de una imagen.

Parámetros

depth

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el método de disposición de una imagen

  • « Imagick::setImageDepth
  • Imagick::setImageExtent »
  • PHP Manual
  • Imagick
  • Establece el método de disposición de una imagen

Imagick::setImageDispose

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDispose — Establece el método de disposición de una imagen

Descripción

Imagick::setImageDispose ( int $dispose ) : bool

Establece el método de disposición de una imagen.

Parámetros

dispose

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el tamaño de una imagen

  • « Imagick::setImageDispose
  • Imagick::setImageFilename »
  • PHP Manual
  • Imagick
  • Establece el tamaño de una imagen

Imagick::setImageExtent

(PECL imagick 2, PECL imagick 3)

Imagick::setImageExtent — Establece el tamaño de una imagen

Descripción

Imagick::setImageExtent ( int $columns , int $rows ) : bool

Establece el tamaño de una imagen (p.ej. columnas y filas).

Parámetros

columns

rows

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el nombre de archivo de una imagen en particular

  • « Imagick::setImageExtent
  • Imagick::setImageFormat »
  • PHP Manual
  • Imagick
  • Establece el nombre de archivo de una imagen en particular

Imagick::setImageFilename

(PECL imagick 2, PECL imagick 3)

Imagick::setImageFilename — Establece el nombre de archivo de una imagen en particular

Descripción

Imagick::setImageFilename ( string $filename ) : bool

Establece el nombre de fichero de una imagen en particular en una secuencia.

Parámetros

filename

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el formato de una imagen en particular

  • « Imagick::setImageFilename
  • Imagick::setImageGamma »
  • PHP Manual
  • Imagick
  • Establece el formato de una imagen en particular

Imagick::setImageFormat

(PECL imagick 2, PECL imagick 3)

Imagick::setImageFormat — Establece el formato de una imagen en particular

Descripción

Imagick::setImageFormat ( string $format ) : bool

Establece el formato de una imagen en particular en una secuencia.

Parámetros

format

La representación string de un formato de imagen. Los formatos soportados dependen de la instalación de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.


Establece el valor gamma de la imagen

  • « Imagick::setImageFormat
  • Imagick::setImageGravity »
  • PHP Manual
  • Imagick
  • Establece el valor gamma de la imagen

Imagick::setImageGamma

(PECL imagick 2, PECL imagick 3)

Imagick::setImageGamma — Establece el valor gamma de la imagen

Descripción

Imagick::setImageGamma ( float $gamma ) : bool

Establece el valor gamma de la imagen.

Parámetros

gamma

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la gravedad de la imagen

  • « Imagick::setImageGamma
  • Imagick::setImageGreenPrimary »
  • PHP Manual
  • Imagick
  • Establece la gravedad de la imagen

Imagick::setImageGravity

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::setImageGravity — Establece la gravedad de la imagen

Descripción

Imagick::setImageGravity ( int $gravity ) : bool

Establece la propiedad gravedad de la imagen actual. Este método se puede usar para establecer la propiedad gravedad de una sóla secuencia de imágenes. Este método está disponible si Imagick ha sido compilado con la versión 6.4.4 o superior de ImageMagick.

Parámetros

gravity

La propiedad gravedad. Consulte esta lista de constantes de gravedad.

Valores devueltos

No devuelve ningún valor.


Establece el punto primario verde de la cromaticidad de la imagen

  • « Imagick::setImageGravity
  • Imagick::setImageIndex »
  • PHP Manual
  • Imagick
  • Establece el punto primario verde de la cromaticidad de la imagen

Imagick::setImageGreenPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageGreenPrimary — Establece el punto primario verde de la cromaticidad de la imagen

Descripción

Imagick::setImageGreenPrimary ( float $x , float $y ) : bool

Establece el punto primario verde de la cromaticidad de la imagen.

Parámetros

x

y

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la posición del iterador

  • « Imagick::setImageGreenPrimary
  • Imagick::setImageInterlaceScheme »
  • PHP Manual
  • Imagick
  • Establece la posición del iterador

Imagick::setImageIndex

(PECL imagick 2, PECL imagick 3)

Imagick::setImageIndex — Establece la posición del iterador

Descripción

Imagick::setImageIndex ( int $index ) : bool

Establece la posición del iterador en la lista de imágenes especificada con el parámetro index.

Este método ha quedado obsoleto. Véase Imagick::setIteratorIndex().

Parámetros

index

La posición donde se va a establecer el iterador

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la compresión de la imagen

  • « Imagick::setImageIndex
  • Imagick::setImageInterpolateMethod »
  • PHP Manual
  • Imagick
  • Establece la compresión de la imagen

Imagick::setImageInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::setImageInterlaceScheme — Establece la compresión de la imagen

Descripción

Imagick::setImageInterlaceScheme ( int $interlace_scheme ) : bool

Establece la compresión de la imagen.

Parámetros

interlace_scheme

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el método de interpolación de píxeles

  • « Imagick::setImageInterlaceScheme
  • Imagick::setImageIterations »
  • PHP Manual
  • Imagick
  • Establece el método de interpolación de píxeles

Imagick::setImageInterpolateMethod

(PECL imagick 2, PECL imagick 3)

Imagick::setImageInterpolateMethod — Establece el método de interpolación de píxeles

Descripción

Imagick::setImageInterpolateMethod ( int $method ) : bool

Establece el método de interpolación de píxeles.

Parámetros

method

El método es una de las contantes Imagick::INTERPOLATE_*

Valores devueltos

Devuelve true en caso de éxito.


Establece las iteraciones de una imagen

  • « Imagick::setImageInterpolateMethod
  • Imagick::setImageMatte »
  • PHP Manual
  • Imagick
  • Establece las iteraciones de una imagen

Imagick::setImageIterations

(PECL imagick 2, PECL imagick 3)

Imagick::setImageIterations — Establece las iteraciones de una imagen

Descripción

Imagick::setImageIterations ( int $iterations ) : bool

Establece el número de veces que una imagen animada se repite.

Parámetros

iterations

El número de veces que la imagen debería mostrarse en bucle. Establecer a '0' para un bucle infinito.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Uso básido ce Imagick::setImageIterations()

<?php

$imagick = new Imagick(realpath("Test.gif"));

$imagick = $imagick->coalesceImages();
$imagick->setImageIterations(1);
$imagick = $imagick->deconstructImages();

$imagick->writeImages('/ruta/donde/guardar/UnaVez.gif', true);

?>


Establece el canal mate de la imagen

  • « Imagick::setImageIterations
  • Imagick::setImageMatteColor »
  • PHP Manual
  • Imagick
  • Establece el canal mate de la imagen

Imagick::setImageMatte

(PECL imagick 2, PECL imagick 3)

Imagick::setImageMatte — Establece el canal mate de la imagen

Descripción

Imagick::setImageMatte ( bool $matte ) : bool

Establece el canal mate de la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

matte

Si es true activa el canal mate y si es false lo deshabilita.

Valores devueltos

Devuelve true en caso de éxito.


Establece el color mate de la imagen

  • « Imagick::setImageMatte
  • Imagick::setImageOpacity »
  • PHP Manual
  • Imagick
  • Establece el color mate de la imagen

Imagick::setImageMatteColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageMatteColor — Establece el color mate de la imagen

Descripción

Imagick::setImageMatteColor ( mixed $matte ) : bool

Establece el color mate de la imagen.

Parámetros

matte

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que un string represente el color como parámetro. Versiones anteriores sólo permitían un objeto ImagickPixel.


Establece el nivel de opacidad de la imagen

  • « Imagick::setImageMatteColor
  • Imagick::setImageOrientation »
  • PHP Manual
  • Imagick
  • Establece el nivel de opacidad de la imagen

Imagick::setImageOpacity

(PECL imagick 2, PECL imagick 3)

Imagick::setImageOpacity — Establece el nivel de opacidad de la imagen

Descripción

Imagick::setImageOpacity ( float $opacity ) : bool

Establece el nivel de opacidad de la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.3.1 o superior de ImageMagick. Este método opera en todos los canales, lo que significa que, por ejemplo, un valor de la opacidad de 0.5 establecerá todas las áreas transparentes a parcialmente opacas. Para añadir transparencia a áreas que no lo son ya, use Imagick::evaluateImage()

Parámetros

opacity

El nivel de transpariencia: 1.0 es completamente opaco y 0.0 es completamente transparente.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::setImageOpacity()

Un ejemplo usando Imagick::setImageOpacity()

<?php
/* Crear el objeto */
$imagen = new Imagick('origen.png');

/* Establecer la opacidad */
$imagen->setImageOpacity(0.7);

/* Mostrar la imagen */
header('Content-type: image/png');
echo $imagen;

?>


Establece la orientación de la imagen

  • « Imagick::setImageOpacity
  • Imagick::setImagePage »
  • PHP Manual
  • Imagick
  • Establece la orientación de la imagen

Imagick::setImageOrientation

(PECL imagick 2, PECL imagick 3)

Imagick::setImageOrientation — Establece la orientación de la imagen

Descripción

Imagick::setImageOrientation ( int $orientation ) : bool

Establece la orientación de la imagen.

Parámetros

orientation

Una de las constantes de orientación

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::setImageOrientation()

<?php
//Doesn't appear to do anything
function setImageOrientation($imagePath, $orientationType) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageOrientation($orientationType);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Establece la geometría de la página de la imagen

  • « Imagick::setImageOrientation
  • Imagick::setImageProfile »
  • PHP Manual
  • Imagick
  • Establece la geometría de la página de la imagen

Imagick::setImagePage

(PECL imagick 2, PECL imagick 3)

Imagick::setImagePage — Establece la geometría de la página de la imagen

Descripción

Imagick::setImagePage ( int $width , int $height , int $x , int $y ) : bool

Establece la geometría de la página de la imagen.

Parámetros

width

height

x

y

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Añade un perfil nominado al objeto Imagick

  • « Imagick::setImagePage
  • Imagick::setImageProperty »
  • PHP Manual
  • Imagick
  • Añade un perfil nominado al objeto Imagick

Imagick::setImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::setImageProfile — Añade un perfil nominado al objeto Imagick

Descripción

Imagick::setImageProfile ( string $name , string $profile ) : bool

Añade un perfil nominado al objeto Imagick. Si un perfil con el mismo nobre ya existe, se reemplaza. Este método difiere del método Imagick::ProfileImage() en que no aplica ningún perfil de color CMS.

Parámetros

name

profile

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece una propiedad de la imagen

  • « Imagick::setImageProfile
  • Imagick::setImageRedPrimary »
  • PHP Manual
  • Imagick
  • Establece una propiedad de la imagen

Imagick::setImageProperty

(PECL imagick 2, PECL imagick 3)

Imagick::setImageProperty — Establece una propiedad de la imagen

Descripción

Imagick::setImageProperty ( string $name , string $value ) : bool

Establece un propiedad nominada de la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.3.2 o superior de ImageMagick.

Parámetros

name

value

Ejemplos

Ejemplo #1 Usar Imagick::setImageProperty():

Establecer y obtener las propiedades de una imagen

<?php
$imagen = new Imagick();
$imagen->newImage(300, 200, "black");

$imagen->setImageProperty('Exif:Make', 'Imagick');
echo $imagen->getImageProperty('Exif:Make');
?>

Ver también

  • Imagick::getImageProperty() - Devuelve la propiedad nominada de la imagen

Valores devueltos

Devuelve true en caso de éxito.


Establece el punto primario rojo de la cromaticidad de la imagen

  • « Imagick::setImageProperty
  • Imagick::setImageRenderingIntent »
  • PHP Manual
  • Imagick
  • Establece el punto primario rojo de la cromaticidad de la imagen

Imagick::setImageRedPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageRedPrimary — Establece el punto primario rojo de la cromaticidad de la imagen

Descripción

Imagick::setImageRedPrimary ( float $x , float $y ) : bool

Establece el punto primario rojo de la cromaticidad de la imagen.

Parámetros

x

y

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece el propósito de renderización de la imagen

  • « Imagick::setImageRedPrimary
  • Imagick::setImageResolution »
  • PHP Manual
  • Imagick
  • Establece el propósito de renderización de la imagen

Imagick::setImageRenderingIntent

(PECL imagick 2, PECL imagick 3)

Imagick::setImageRenderingIntent — Establece el propósito de renderización de la imagen

Descripción

Imagick::setImageRenderingIntent ( int $rendering_intent ) : bool

Establece el propósito de renderización de la imagen.

Parámetros

rendering_intent

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la resolución de la imagen

  • « Imagick::setImageRenderingIntent
  • Imagick::setImageScene »
  • PHP Manual
  • Imagick
  • Establece la resolución de la imagen

Imagick::setImageResolution

(PECL imagick 2, PECL imagick 3)

Imagick::setImageResolution — Establece la resolución de la imagen

Descripción

Imagick::setImageResolution ( float $x_resolution , float $y_resolution ) : bool

Establece la resolución de la imagen.

Parámetros

x_resolution

y_resolution

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::setImageResolution()

<?php
function setImageResolution($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageResolution(50, 50);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Establece la escena de la imagen

  • « Imagick::setImageResolution
  • Imagick::setImageTicksPerSecond »
  • PHP Manual
  • Imagick
  • Establece la escena de la imagen

Imagick::setImageScene

(PECL imagick 2, PECL imagick 3)

Imagick::setImageScene — Establece la escena de la imagen

Descripción

Imagick::setImageScene ( int $scene ) : bool

Establece la escena de la imagen.

Parámetros

scene

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece los ticks por segundo de la imagen

  • « Imagick::setImageScene
  • Imagick::setImageType »
  • PHP Manual
  • Imagick
  • Establece los ticks por segundo de la imagen

Imagick::setImageTicksPerSecond

(PECL imagick 2, PECL imagick 3)

Imagick::setImageTicksPerSecond — Establece los ticks por segundo de la imagen

Descripción

Imagick::setImageTicksPerSecond ( int $ticks_per_second ) : bool

Ajusta la cantidad de tiempo que se muestra un marco de una imagen animada.

Nota:

Para GIFs animados, esta función no cambia el número de 'ticks de imagen' por segundo, el cual está siempre definido como 100. En su lugar, ajusta la cantidad de tiempo que se muestra un marco para simular el cambio de 'ticks por segundo'.

Por ejemplo, para un GIF animado donde cada marco se muestra para 20 ticks (1/5 de un segundo), al llamar a este método en cada marco de esa imagen con un argumento de 50, los marcos se ajustan para que se muestren por 40 ticks (2/5 de un segundo) y así, la animación se reproducirá a la mitad de la velocidad original.

Parámetros

ticks_per_second

La duración por la que imagen debería mostrarse expresada en ticks por segundo.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Modificar un GIF animado con Imagick::setImageTicksPerSecond()

<?php

// Modificar un GIF animado para que la primera mitad del GIF se reproduzca a
// la mitad de su velocidad, y la segunda mitad se reproduzca al doble de su
// velocidad actual

$imagick = new Imagick(realpath("Test.gif"));
$imagick = $imagick->coalesceImages();

$totalFrames = $imagick->getNumberImages();

$frameCount = 0;

foreach ($imagick as $frame) {
    $imagick->setImageTicksPerSecond(50);

    if ($frameCount < ($totalFrames / 2)) {
        // Modificar el marco para que se muestre al doble de lo actual
        $imagick->setImageTicksPerSecond(50);
    } else {
        // Modificar el marco para que se muestre a la mitad de lo actual
        $imagick->setImageTicksPerSecond(200);
    }

    $frameCount++;
}

$imagick = $imagick->deconstructImages();

$imagick->writeImages("/ruta/donde/guardar/salida.gif", true);

?>


Establece el tipo de imagen

  • « Imagick::setImageTicksPerSecond
  • Imagick::setImageUnits »
  • PHP Manual
  • Imagick
  • Establece el tipo de imagen

Imagick::setImageType

(PECL imagick 2, PECL imagick 3)

Imagick::setImageType — Establece el tipo de imagen

Descripción

Imagick::setImageType ( int $image_type ) : bool

Establece el tipo de imagen.

Parámetros

image_type

Valores devueltos

Devuelve true en caso de éxito.


Establece las unidades de resolución de la imagen

  • « Imagick::setImageType
  • Imagick::setImageVirtualPixelMethod »
  • PHP Manual
  • Imagick
  • Establece las unidades de resolución de la imagen

Imagick::setImageUnits

(PECL imagick 2, PECL imagick 3)

Imagick::setImageUnits — Establece las unidades de resolución de la imagen

Descripción

Imagick::setImageUnits ( int $units ) : bool

Establece las unidades de resolución de la imagen.

Parámetros

units

Valores devueltos

Devuelve true en caso de éxito.


Establece el método de píxel virtual de la imagen

  • « Imagick::setImageUnits
  • Imagick::setImageWhitePoint »
  • PHP Manual
  • Imagick
  • Establece el método de píxel virtual de la imagen

Imagick::setImageVirtualPixelMethod

(PECL imagick 2, PECL imagick 3)

Imagick::setImageVirtualPixelMethod — Establece el método de píxel virtual de la imagen

Descripción

Imagick::setImageVirtualPixelMethod ( int $method ) : bool

Establece el método de píxel virtual de la imagen.

Parámetros

method

Valores devueltos

Devuelve true en caso de éxito.


Establece el punto blanco de cromaticidad de la imagen

  • « Imagick::setImageVirtualPixelMethod
  • Imagick::setInterlaceScheme »
  • PHP Manual
  • Imagick
  • Establece el punto blanco de cromaticidad de la imagen

Imagick::setImageWhitePoint

(PECL imagick 2, PECL imagick 3)

Imagick::setImageWhitePoint — Establece el punto blanco de cromaticidad de la imagen

Descripción

Imagick::setImageWhitePoint ( float $x , float $y ) : bool

Establece el punto blanco de cromaticidad de la imagen.

Parámetros

x

y

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Establece la compresión de la imagen

  • « Imagick::setImageWhitePoint
  • Imagick::setIteratorIndex »
  • PHP Manual
  • Imagick
  • Establece la compresión de la imagen

Imagick::setInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::setInterlaceScheme — Establece la compresión de la imagen

Descripción

Imagick::setInterlaceScheme ( int $interlace_scheme ) : bool

Establece la compresión de la imagen.

Parámetros

interlace_scheme

Valores devueltos

Devuelve true en caso de éxito.


Establece la posición del iterador

  • « Imagick::setInterlaceScheme
  • Imagick::setLastIterator »
  • PHP Manual
  • Imagick
  • Establece la posición del iterador

Imagick::setIteratorIndex

(PECL imagick 2, PECL imagick 3)

Imagick::setIteratorIndex — Establece la posición del iterador

Descripción

Imagick::setIteratorIndex ( int $index ) : bool

Establece el iterador a la posición en la lista de imágenes definida por el parámtro index. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

index

La posición donde se va a establecer el iterador

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar Imagick::setIteratorIndex():

Crear imágenes, establecer y obtener el índice del iterador

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

Ver también

  • Imagick::getIteratorIndex() - Obtiene el índice de la imagen activa actual
  • Imagick::getImageIndex() - Obtiene el índice de la imagen activa actual
  • Imagick::setImageIndex() - Establece la posición del iterador


Establece el iterador de Imagick a la última imagen

  • « Imagick::setIteratorIndex
  • Imagick::setOption »
  • PHP Manual
  • Imagick
  • Establece el iterador de Imagick a la última imagen

Imagick::setLastIterator

(PECL imagick 2 >= 2.0.1, PECL imagick 3)

Imagick::setLastIterator — Establece el iterador de Imagick a la última imagen

Descripción

Imagick::setLastIterator ( ) : bool

Establece el iterador de Imagick a la última imagen.

Valores devueltos

Devuelve true en caso de éxito.


Establece una opción

  • « Imagick::setLastIterator
  • Imagick::setPage »
  • PHP Manual
  • Imagick
  • Establece una opción

Imagick::setOption

(PECL imagick 2, PECL imagick 3)

Imagick::setOption — Establece una opción

Descripción

Imagick::setOption ( string $key , string $value ) : bool

Asocia una o más opciones con la varita.

Parámetros

key

value

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Attempt to reach '$extent' sizeImagick::setOption()

<?php
    function renderJPG($extent) {
        $imagePath = $this->control->getImagePath();
        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('jpg');
        $imagick->setOption('jpeg:extent', $extent);
        header("Content-Type: image/jpg");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #2 Imagick::setOption()

<?php
    function renderPNG($imagePath, $format) {

        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('png');
        $imagick->setOption('png:format', $format);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

    //Save as 64bit PNG.
    renderPNG($imagePath, 'png64');

?>

Ejemplo #3 Imagick::setOption()

<?php
    function renderCustomBitDepthPNG() {
        $imagePath = $this->control->getImagePath();
        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('png');

        $imagick->setOption('png:bit-depth', '16');
        $imagick->setOption('png:color-type', 6);
        header("Content-Type: image/png");
        $crash = true;
        if ($crash) {
            echo $imagick->getImageBlob();
        }
        else {
            $tempFilename = tempnam('./', 'imagick');
            $imagick->writeimage(realpath($tempFilename));
            echo file_get_contents($tempFilename);
        }
    }

?>


Establece la geometría de página del objeto Imagick

  • « Imagick::setOption
  • Imagick::setPointSize »
  • PHP Manual
  • Imagick
  • Establece la geometría de página del objeto Imagick

Imagick::setPage

(PECL imagick 2, PECL imagick 3)

Imagick::setPage — Establece la geometría de página del objeto Imagick

Descripción

Imagick::setPage ( int $width , int $height , int $x , int $y ) : bool

Establece la geometría de página del objeto Imagick.

Parámetros

width

height

x

y

Valores devueltos

Devuelve true en caso de éxito.


Establece el tamaño del punto

  • « Imagick::setPage
  • Imagick::setProgressMonitor »
  • PHP Manual
  • Imagick
  • Establece el tamaño del punto

Imagick::setPointSize

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setPointSize — Establece el tamaño del punto

Descripción

Imagick::setPointSize ( float $point_size ) : bool

Establece la propiedad tamaño del punto de objeto. Este método se puede usar para, por ejemplo, establecer el tamaño de la fuente para las leyendas: pseudo-formato. Este método está disponible si Imagick ha sido compilado con la versión 6.3.7 o superior de ImageMagick.

Parámetros

point_size

El tamaño del punto

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::getPointSize() - Obtiene el tamaño de punto

Ejemplos

Ejemplo #1 Un ejemplo de Imagick::setPointSize()

Ejemplo usando Imagick::setPointSize

<?php
/* Crear el nuevo objeto imagick */
$im = new Imagick();

/* Establecer la fuente para el objeto */
$im->setFont("ejemplo.ttf");

/* Establecer el tamaño del punto */
$im->setPointSize(12);

/* Crear una leyenda nueva */
$im->newPseudoImage(100, 100, "caption:Hola");

/* Hacer algo con la imagen */
?>


Description

  • « Imagick::setPointSize
  • Imagick::setRegistry »
  • PHP Manual
  • Imagick
  • Description

Imagick::setProgressMonitor

(PECL imagick 3 >= 3.3.0)

Imagick::setProgressMonitor — Description

Descripción

public Imagick::setProgressMonitor ( callable $callback ) : void

Establece una retrollamada que será invocada durante el procesamiento de la imagen Imagick.

Parámetros

callback

La función de progreso a llamar. Debe devolver true si el procesamiento de la imagen debe continuar, o false si debe ser cancelado. El parámetro 'offset' indica el progreso y el parámetro 'span' indica la cantidad total de trabajo necesario para realizarla.

callback ( mixed $offset , mixed $span ) : bool
Precaución

Los valores pasados a la función de retrollamada no son consistentes. En particular, el parámetro 'span' puede aumentar durante el procesamiento de la imagen. A causa de esto, el cálculo del procentaje completado de una operación de imagen no es trivial.

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::setProgressMonitor()

<?php
        $abortReason = null;

        try {
            $imagick = new \Imagick(realpath($this->control->getImagePath()));
            $startTime = time();

            $callback = function ($offset, $span)  use ($startTime, &$abortReason) {
                if (((100 * $offset) / $span)  > 20) {
                    $abortReason = "Processing reached 20%";
                    return false;
                }

                $nowTime = time();

                if ($nowTime - $startTime > 5) {
                    $abortReason = "Image processing took more than 5 seconds";
                    return false;
                }
                if (($offset % 5) == 0) {
                    echo "Progress: $offset / $span <br/>";
                }
                return true;
            };

            $imagick->setProgressMonitor($callback);

            $imagick->waveImage(2, 15);

            echo "Data len is: ".strlen($imagick->getImageBlob());
        }
        catch(\ImagickException $e) {
            if ($abortReason != null) {
                echo "Image processing was aborted: ".$abortReason."<br/>";
            }
            else {
                echo "ImagickException caught: ".$e->getMessage()." Exception type is ".get_class($e);
            }
        }

?>


Description

  • « Imagick::setProgressMonitor
  • Imagick::setResolution »
  • PHP Manual
  • Imagick
  • Description

Imagick::setRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::setRegistry — Description

Descripción

public static Imagick::setRegistry ( string $key , string $value ) : void

Establece la clave con nombre de la entrada del registro de ImageMagick al valor dado por value. Esto es útil para establecer "temporary-path", lo cual controla dónde ImageMagick crea imágenes temporales, p.ej., al procesar PDFs.

Parámetros

key

value

Valores devueltos


Establece la resolución de la imagen

  • « Imagick::setRegistry
  • Imagick::setResourceLimit »
  • PHP Manual
  • Imagick
  • Establece la resolución de la imagen

Imagick::setResolution

(PECL imagick 2, PECL imagick 3)

Imagick::setResolution — Establece la resolución de la imagen

Descripción

Imagick::setResolution ( float $x_resolution , float $y_resolution ) : bool

Establece la resolución de la imagen.

Parámetros

x_resolution

La resolución horizontal.

y_resolution

La resolución vertical.

Valores devueltos

Devuelve true en caso de éxito.

Notas

Imagick::setResolution() se debe invocar antes de cargar o crear una imagen.

Ver también

  • Imagick::setImageResolution() - Establece la resolución de la imagen
  • Imagick::getImageResolution() - Obtiene la resolución X e Y de la imagen


Establece el límite de un recurso en particular en megabytes

  • « Imagick::setResolution
  • Imagick::setSamplingFactors »
  • PHP Manual
  • Imagick
  • Establece el límite de un recurso en particular en megabytes

Imagick::setResourceLimit

(PECL imagick 2, PECL imagick 3)

Imagick::setResourceLimit — Establece el límite de un recurso en particular en megabytes

Descripción

Imagick::setResourceLimit ( int $type , int $limit ) : bool

Este método se usa para modificar los límites de los recursos de la biblioteca ImageMagick subyacente.

Parámetros

type

Consulte la lista de constantes de tipos de recurso.

limit

El límite del recurso. La unidad depende del tipo de recurso a limitar.

Valores devueltos

Devuelve true en caso de éxito.


Establece los factores de muestreo de la imagen

  • « Imagick::setResourceLimit
  • Imagick::setSize »
  • PHP Manual
  • Imagick
  • Establece los factores de muestreo de la imagen

Imagick::setSamplingFactors

(PECL imagick 2, PECL imagick 3)

Imagick::setSamplingFactors — Establece los factores de muestreo de la imagen

Descripción

Imagick::setSamplingFactors ( array $factors ) : bool

Establece los factores de muestreo de la imagen.

Parámetros

factors

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::setSamplingFactors()

<?php
function setSamplingFactors($imagePath) {

    $imagePath = "../imagick/images/FineDetail.png";
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageFormat('jpg');
    $imagick->setSamplingFactors(array('2x2', '1x1', '1x1'));

    $compressed = $imagick->getImageBlob();

    $reopen = new \Imagick();
    $reopen->readImageBlob($compressed);

    $reopen->resizeImage(
        $reopen->getImageWidth() * 4,
        $reopen->getImageHeight() * 4,
        \Imagick::FILTER_POINT,
        1
    );

    header("Content-Type: image/jpg");
    echo $reopen->getImageBlob();
}

?>


Establece el tamaño del objeto Imagick

  • « Imagick::setSamplingFactors
  • Imagick::setSizeOffset »
  • PHP Manual
  • Imagick
  • Establece el tamaño del objeto Imagick

Imagick::setSize

(PECL imagick 2, PECL imagick 3)

Imagick::setSize — Establece el tamaño del objeto Imagick

Descripción

Imagick::setSize ( int $columns , int $rows ) : bool

Establece el tamaño del Imagick. Se debe establecer antes de leer un formato de imagen en bruto como RGB, GRAY, o CMYK.

Parámetros

columns

rows

Valores devueltos

Devuelve true en caso de éxito.


Establece el tamaño y el índice del objeto Imagick

  • « Imagick::setSize
  • Imagick::setType »
  • PHP Manual
  • Imagick
  • Establece el tamaño y el índice del objeto Imagick

Imagick::setSizeOffset

(PECL imagick 2, PECL imagick 3)

Imagick::setSizeOffset — Establece el tamaño y el índice del objeto Imagick

Descripción

Imagick::setSizeOffset ( int $columns , int $rows , int $offset ) : bool

Establece el tamaño y el índice del objeto Imagick. Se debe establecer antes de leer un formato de imagen en bruto como RGB, GRAY, o CMYK. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

columns

El ancho en píxeles.

rows

El alto en píxeles.

offset

El índice de la imagen.

Valores devueltos

Devuelve true en caso de éxito.


Establece el atributo tipo de imagen

  • « Imagick::setSizeOffset
  • Imagick::shadeImage »
  • PHP Manual
  • Imagick
  • Establece el atributo tipo de imagen

Imagick::setType

(PECL imagick 2, PECL imagick 3)

Imagick::setType — Establece el atributo tipo de imagen

Descripción

Imagick::setType ( int $image_type ) : bool

Establece el atributo tipo de imagen.

Parámetros

image_type

Valores devueltos

Devuelve true en caso de éxito.


Crea un efecto en 3D

  • « Imagick::setType
  • Imagick::shadowImage »
  • PHP Manual
  • Imagick
  • Crea un efecto en 3D

Imagick::shadeImage

(PECL imagick 2, PECL imagick 3)

Imagick::shadeImage — Crea un efecto en 3D

Descripción

Imagick::shadeImage ( bool $gray , float $azimuth , float $elevation ) : bool

Hace brillar una luz distante sobre una imagen para crear un efecto tridimensional. Se controla la posición de la luz con los parámetros azimuth (acimut) y elevation (elevación); el acimut se mide en grados desde el eje X y la elevación se mide en píxeles por encima del eje Z. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

gray

Un valor distinto de cero sombrea la intensidad de cada píxel.

azimuth

Define la dirección de la fuente de luz.

elevation

Define la dirección de la fuente de luz.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza una excepción de tipo ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::shadeImage()

<?php
function shadeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shadeImage(true, 45, 20);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simula una sombra de imagen

  • « Imagick::shadeImage
  • Imagick::sharpenImage »
  • PHP Manual
  • Imagick
  • Simula una sombra de imagen

Imagick::shadowImage

(PECL imagick 2, PECL imagick 3)

Imagick::shadowImage — Simula una sombra de imagen

Descripción

Imagick::shadowImage ( float $opacity , float $sigma , int $x , int $y ) : bool

Simula una sombra de imagen.

Parámetros

opacity

sigma

x

y

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::shadowImage()

<?php
function shadowImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shadowImage(0.4, 10, 50, 5);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Afila una imagen

  • « Imagick::shadowImage
  • Imagick::shaveImage »
  • PHP Manual
  • Imagick
  • Afila una imagen

Imagick::sharpenImage

(PECL imagick 2, PECL imagick 3)

Imagick::sharpenImage — Afila una imagen

Descripción

Imagick::sharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_ALL ) : bool

Afila una imagen. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y Imagick::sketchImage()() seleccionará un radio apropiado automáticamente.

Parámetros

radius

sigma

channel

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::sharpenImage()

<?php
function sharpenImage($imagePath, $radius, $sigma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sharpenimage($radius, $sigma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Recorta píxeles de los extremos de la imagen

  • « Imagick::sharpenImage
  • Imagick::shearImage »
  • PHP Manual
  • Imagick
  • Recorta píxeles de los extremos de la imagen

Imagick::shaveImage

(PECL imagick 2, PECL imagick 3)

Imagick::shaveImage — Recorta píxeles de los extremos de la imagen

Descripción

Imagick::shaveImage ( int $columns , int $rows ) : bool

Recorta píxeles de los extremos de la imagen. Asigna la memoria necesaria para la estructura de la nueva imagen y devuelve un puntero a la nueva imagen.

Parámetros

columns

rows

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::shaveImage()

<?php
function shaveImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shaveImage(100, 50);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea un paralelogramo

  • « Imagick::shaveImage
  • Imagick::sigmoidalContrastImage »
  • PHP Manual
  • Imagick
  • Crea un paralelogramo

Imagick::shearImage

(PECL imagick 2, PECL imagick 3)

Imagick::shearImage — Crea un paralelogramo

Descripción

Imagick::shearImage ( mixed $background , float $x_shear , float $y_shear ) : bool

Desliza un extremo de una imagen a lo largo del eje X o Y, creando un paralelogramo. Un recorte en la dirección X desliza un extremo a lo largo del eje X, mientras que un recorte en la dirección Y desliza un extremo a lo largo del eje Y. La cantidad del recorte se controla por un ángulo de recorte. Para recortes en la dirección X, x_shear se mide relativo al eje Y, y de forma similar, para recortes en la dirección Y, y_shear se mide relativo al eje X. Los triángulos vacíos sobrantes del recorte de la imagen se rellenan con el color de fondo.

Parámetros

background

El color de fondo

x_shear

El número de grados a recortar sobre el eje x

y_shear

El número de grados a recortar sobre el eje y

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que un string represente el color como primer parámetro. Versiones previas sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::shearImage()

<?php
function shearImage($imagePath, $color, $shearX, $shearY) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shearimage($color, $shearX, $shearY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Ajusta el contraste de una imagen

  • « Imagick::shearImage
  • Imagick::sketchImage »
  • PHP Manual
  • Imagick
  • Ajusta el contraste de una imagen

Imagick::sigmoidalContrastImage

(PECL imagick 2, PECL imagick 3)

Imagick::sigmoidalContrastImage — Ajusta el contraste de una imagen

Descripción

Imagick::sigmoidalContrastImage ( bool $sharpen , float $alpha , float $beta , int $channel = Imagick::CHANNEL_ALL ) : bool

Ajusta el contraste de una imagen con un algoritmo de contraste sigmoide no lineal. Aumenta el contraste de la imagen usando una función de transferencia sigmoide sin saturar los reflejos o las sombras. El contraste indica cuánto se incrementa el contraste (0 es nada; 3 es normal; 20 es enérgico); el punto medio indica dónde caen los medios tonos de la imagen resultante (0 es blanco; 50 es medio gris; 100 es negro). Establezca el parámtero sharpen a true para incrementar el contraste de la imagen, si no, el contraste se reduce.

Véase también » ImageMagick v6 Examples - Image Transformations — Sigmoidal Non-linearity Contrast

Parámetros

sharpen

Si es true, aumenta el contraste, si es false lo decrementa.

alpha

La cantidad de contraste a aplicar. 1 es muy poco, 5 es una cantidad significativa, 20 es extremo.

beta

Donde estará el punto medio del degradado. Este valor debería estar entre 0 y 1, multiplicado por el valor de cuantía de ImageMagick.

channel

A qué canales de color se aplicará el contraste.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Crear una imagen degradada usando Imagick::sigmoidalContrastImage() apta para mezclar dos imágenes suavemente, con la mezcla definida por $contraste y el $punto_medio

<?php

function generateBlendImage($ancho, $alto, $contraste = 10, $punto_medio = 0.5) {
    $imagick = new Imagick();
    $imagick->newPseudoImage($ancho, $alto, 'gradient:black-white');
    $quanta = $imagick->getQuantumRange();
    $imagick->sigmoidalContrastImage(true, $contraste, $punto_medio * $cuantías["quantumRangeLong"]);

    return $imagick;
}

?>

Errores/Excepciones

Lanza ImagickException en caso de error.


Simula el bosquejo de un lapiz

  • « Imagick::sigmoidalContrastImage
  • Imagick::smushImages »
  • PHP Manual
  • Imagick
  • Simula el bosquejo de un lapiz

Imagick::sketchImage

(PECL imagick 2, PECL imagick 3)

Imagick::sketchImage — Simula el bosquejo de un lapiz

Descripción

Imagick::sketchImage ( float $radius , float $sigma , float $angle ) : bool

Simula el bosquejo de un lapiz. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y Imagick::sketchImage() seleccionará un radio apropiado automáticamente. El ángulo da el ángulo del movimiento borroso. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

radius

El radio gaussiano, en píxeles, sin contar el píxel central.

sigma

La desviación estándar gaussiana, en píxeles.

angle

Aplica el efecto a lo largo de este ángulo.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::sketchImage()

<?php
function sketchImage($imagePath, $radius, $sigma, $angle) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sketchimage($radius, $sigma, $angle);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::sketchImage
  • Imagick::solarizeImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::smushImages

(PECL imagick 3 >= 3.3.0)

Imagick::smushImages — Description

Descripción

public Imagick::smushImages ( string $stack , string $offset ) : Imagick

Toma todas las imágenes desde puntero de imágenes actual hasta el final de la lista y las "aplasta" unas contra otras de arriba a abajo si el parámetro 'stack' es true, de lo contrario lo hace de izquierda a derecha.

Parámetros

stack

offset

Valores devueltos

La nueva imagen aplastada.

Ejemplos

Ejemplo #1 Imagick::smushImages()

<?php
function smushImages($imagePath, $imagePath2) {

    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = new \Imagick(realpath($imagePath2));

    $imagick->addimage($imagick2);
    $smushed = $imagick->smushImages(false, 50);
    $smushed->setImageFormat('jpg');
    header("Content-Type: image/jpg");
    echo $smushed->getImageBlob();
}

?>


Aplica un efecto de solarización a la imagen

  • « Imagick::smushImages
  • Imagick::sparseColorImage »
  • PHP Manual
  • Imagick
  • Aplica un efecto de solarización a la imagen

Imagick::solarizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::solarizeImage — Aplica un efecto de solarización a la imagen

Descripción

Imagick::solarizeImage ( int $threshold ) : bool

Aplica un efecto especial a la imagen, similar al efecto conseguido en un cuarto oscuro fotográfico exponiendo selectivamente áreas del papel sensible fotográfico a la luz. Los rangos de umbral van desde 0 al de QuantumRange y es una medida de la extensión de la solarización.

Parámetros

threshold

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::solarizeImage()

<?php
function solarizeImage($imagePath, $solarizeThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->solarizeImage($solarizeThreshold * \Imagick::getQuantum());
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Interpola colores

  • « Imagick::solarizeImage
  • Imagick::spliceImage »
  • PHP Manual
  • Imagick
  • Interpola colores

Imagick::sparseColorImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::sparseColorImage — Interpola colores

Descripción

public Imagick::sparseColorImage ( int $SPARSE_METHOD , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Dada la matriz de argumentos que contiene valores númericos, este método interpola los colores encontrados en esas coordenadas a través de la imagen completa usando sparse_method. Este método está disponible si Imagick ha sido compilado con la versión 6.4.5 o superior de ImageMagick.

Parámetros

SPARSE_METHOD

Consulte esta lista de constantes de métodos de escasez

arguments

Una matriz que contiene las coodenadas. El formato de la matriz es array(1,1, 2,45)

CHANNEL

Proporciona cualquier contante de canal que sea válida para su modo de canal. Para aplicarlo a más de un canal, combine constantes de canal using bitwise operadores bit a bit. El valor por defecto para Imagick::CHANNEL_DEFAULT. Referirse a esta lista de constantes de canal

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric2() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(
            400, 400,
            $points,
            \Imagick::SPARSECOLORMETHOD_BARYCENTRIC
        );
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #2 SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage()

<?php
    function renderImageBilinear() {
        $points = [[0.30, 0.10, 'red'], [0.10, 0.80, 'blue'], [0.70, 0.60, 'lime'], [0.80, 0.20, 'yellow'],];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_BILINEAR);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #3 SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage()

<?php
    function renderImageShepards() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(600, 600, $points, \Imagick::SPARSECOLORMETHOD_SPEPARDS);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #4 SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage()

<?php
    function renderImageVoronoi() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_VORONOI);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #5 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric() {
        $points = [
            [0, 0, 'skyblue'],
            [-1, 1, 'skyblue'],
            [1, 1, 'black'],
        ];
        $imagick = createGradientImage(600, 200, $points, \Imagick::SPARSECOLORMETHOD_BARYCENTRIC);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Ejemplo #6 createGradientImage is used by other examples. Imagick::sparseColorImage()

<?php
function createGradientImage($width, $height, $colorPoints, $sparseMethod, $absolute = false) {

    $imagick = new \Imagick();
    $imagick->newImage($width, $height, "white");
    $imagick->setImageFormat("png");

    $barycentricPoints = array();

    foreach ($colorPoints as $colorPoint) {

        if ($absolute == true) {
            $barycentricPoints[] = $colorPoint[0];
            $barycentricPoints[] = $colorPoint[1];
        }
        else {
            $barycentricPoints[] = $colorPoint[0] * $width;
            $barycentricPoints[] = $colorPoint[1] * $height;
        }

        if (is_string($colorPoint[2])) {
            $imagickPixel = new \ImagickPixel($colorPoint[2]);
        }
        else if ($colorPoint[2] instanceof \ImagickPixel) {
            $imagickPixel = $colorPoint[2];
        }
        else{
            $errorMessage = sprintf(
                "Value %s is neither a string nor an ImagickPixel class. Cannot use as a color.",
                $colorPoint[2]
            );

            throw new \InvalidArgumentException(
                $errorMessage
            );
        }

        $red = $imagickPixel->getColorValue(\Imagick::COLOR_RED);
        $green = $imagickPixel->getColorValue(\Imagick::COLOR_GREEN);
        $blue = $imagickPixel->getColorValue(\Imagick::COLOR_BLUE);
        $alpha = $imagickPixel->getColorValue(\Imagick::COLOR_ALPHA);

        $barycentricPoints[] = $red;
        $barycentricPoints[] = $green;
        $barycentricPoints[] = $blue;
        $barycentricPoints[] = $alpha;
    }

    $imagick->sparseColorImage($sparseMethod, $barycentricPoints);

    return $imagick;
}

?>


Une un color sólido en la imagen

  • « Imagick::sparseColorImage
  • Imagick::spreadImage »
  • PHP Manual
  • Imagick
  • Une un color sólido en la imagen

Imagick::spliceImage

(PECL imagick 2, PECL imagick 3)

Imagick::spliceImage — Une un color sólido en la imagen

Descripción

Imagick::spliceImage ( int $width , int $height , int $x , int $y ) : bool

Une un color sólido en la imagen.

Parámetros

width

height

x

y

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::spliceImage()

<?php
function spliceImage($imagePath, $startX, $startY, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->spliceImage($width, $height, $startX, $startY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Despalza aleatoriamente cada píxel en un bloque

  • « Imagick::spliceImage
  • Imagick::statisticImage »
  • PHP Manual
  • Imagick
  • Despalza aleatoriamente cada píxel en un bloque

Imagick::spreadImage

(PECL imagick 2, PECL imagick 3)

Imagick::spreadImage — Despalza aleatoriamente cada píxel en un bloque

Descripción

Imagick::spreadImage ( float $radius ) : bool

Método de efecto especial que desplaza aleatoriamente cada píxel en un bloque definido por el parámetro radius (radio).

Parámetros

radius

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::spreadImage()

<?php
function spreadImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->spreadImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • « Imagick::spreadImage
  • Imagick::steganoImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::statisticImage

(PECL imagick 3 >= 3.3.0)

Imagick::statisticImage — Description

Descripción

public Imagick::statisticImage ( int $type , int $width , int $height , string $CHANNEL = Imagick::CHANNEL_DEFAULT ) : void

Reemplaza cada píxel con la correspondiente estadística de la proximidad del alto y ancho especficado.

Parámetros

type

width

height

CHANNEL

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::statisticImage()

<?php
function statisticImage($imagePath, $statisticType, $width, $height, $channel) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->statisticImage(
        $statisticType,
        $width,
        $height,
        $channel
    );

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

statisticImage($imagePath, \Imagick::STATISTIC_MEDIAN, 5, 5, \Imagick::CHANNEL_DEFAULT);

?>


Oculta una marca de agua digital dentro de la imagen

  • « Imagick::statisticImage
  • Imagick::stereoImage »
  • PHP Manual
  • Imagick
  • Oculta una marca de agua digital dentro de la imagen

Imagick::steganoImage

(PECL imagick 2, PECL imagick 3)

Imagick::steganoImage — Oculta una marca de agua digital dentro de la imagen

Descripción

Imagick::steganoImage ( Imagick $watermark_wand , int $offset ) : Imagick

Oculta una marca de agua digital dentro de la imagen. Recupere la marca de agua oculta después para demostrar la autenticidad de la imagen. El parámetro offset define la posición inicial dentro de la imagen para ocultar la marca de agua.

Parámetros

watermark_wand

offset

Valores devueltos

Devuelve true en caso de éxito.


Compone dos imágenes

  • « Imagick::steganoImage
  • Imagick::stripImage »
  • PHP Manual
  • Imagick
  • Compone dos imágenes

Imagick::stereoImage

(PECL imagick 2, PECL imagick 3)

Imagick::stereoImage — Compone dos imágenes

Descripción

Imagick::stereoImage ( Imagick $offset_wand ) : bool

Compone dos imágenes y produce una sóla imagen que es la composición de una imagen izquierda y derecha de una pareja estéreo.

Parámetros

offset_wand

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Elimina todos los perfiles y comentarios de una imagen

  • « Imagick::stereoImage
  • Imagick::subImageMatch »
  • PHP Manual
  • Imagick
  • Elimina todos los perfiles y comentarios de una imagen

Imagick::stripImage

(PECL imagick 2, PECL imagick 3)

Imagick::stripImage — Elimina todos los perfiles y comentarios de una imagen

Descripción

Imagick::stripImage ( ) : bool

Elimina todos los perfiles y comentarios de una imagen.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.


Description

  • « Imagick::stripImage
  • Imagick::swirlImage »
  • PHP Manual
  • Imagick
  • Description

Imagick::subImageMatch

(PECL imagick 3 >= 3.3.0)

Imagick::subImageMatch — Description

Descripción

public Imagick::subImageMatch ( Imagick $Imagick , array &$offset = ? , float &$similarity = ? ) : Imagick

Busca una subimagen en la imagen actual y devuelve una imagen de similitud tal que una ubicación que coincida exactamente es completamente blanca, mientras que si no coincide ningún píxel, negra, o, de otro modo, algún nivel de gris intermedio. También se pueden pasar los parámetros opcionales 'bestMatch' y 'similarity'. Después de llamar a la función, 'similarity' se establecerá a la «puntuación» de la similitud entre la subimagen y la posición coincidente de la imagen más grande, bestMatch contendrá un array asociativo con los elementos 'x', 'y', 'width' y 'height', los cuales describen la resión coincidente.

Parámetros

Imagick

offset

similarity

Una nueva imagen que muestra la cantidad de similitud de cada píxel.

Valores devueltos

Ejemplos

Ejemplo #1 Imagick::subImageMatch()

<?php
function subImageMatch($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = clone $imagick;
    $imagick2->cropimage(40, 40, 250, 110);
    $imagick2->vignetteimage(0, 1, 3, 3);

    $similarity = null;
    $bestMatch = null;
    $comparison = $imagick->subImageMatch($imagick2, $bestMatch, $similarity);

    $comparison->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Arremolina los píxeles desde el centro de la imagen

  • « Imagick::subImageMatch
  • Imagick::textureImage »
  • PHP Manual
  • Imagick
  • Arremolina los píxeles desde el centro de la imagen

Imagick::swirlImage

(PECL imagick 2, PECL imagick 3)

Imagick::swirlImage — Arremolina los píxeles desde el centro de la imagen

Descripción

Imagick::swirlImage ( float $degrees ) : bool

Arremolina los píxeles desde el centro de la imagen, donde los grados indican el alcance del arco a través del cuál cada píxel es movido. Se puede obtener un efecto más dramático moviendo los grados desde 1 a 360.

Parámetros

degrees

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::swirlImage()

<?php
function swirlImage($imagePath, $swirl) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->swirlImage($swirl);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Reviste repetidamente la textura de la imagen

  • « Imagick::swirlImage
  • Imagick::thresholdImage »
  • PHP Manual
  • Imagick
  • Reviste repetidamente la textura de la imagen

Imagick::textureImage

(PECL imagick 2, PECL imagick 3)

Imagick::textureImage — Reviste repetidamente la textura de la imagen

Descripción

Imagick::textureImage ( Imagick $texture_wand ) : bool

Reviste repetidamente la textura de la imagen a través y hacia abajo del lienzo de la imagen.

Parámetros

texture_wand

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::textureImage()

<?php
function textureImage($imagePath) {
    $image = new \Imagick();
    $image->newImage(640, 480, new \ImagickPixel('pink'));
    $image->setImageFormat("jpg");
    $texture = new \Imagick(realpath($imagePath));
    $texture->scaleimage($image->getimagewidth() / 4, $image->getimageheight() / 4);
    $image = $image->textureImage($texture);
    header("Content-Type: image/jpg");
    echo $image;
}

?>


Cambia el valor de píexeles individuales basdos en un umbral

  • « Imagick::textureImage
  • Imagick::thumbnailImage »
  • PHP Manual
  • Imagick
  • Cambia el valor de píexeles individuales basdos en un umbral

Imagick::thresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::thresholdImage — Cambia el valor de píexeles individuales basdos en un umbral

Descripción

Imagick::thresholdImage ( float $threshold , int $channel = Imagick::CHANNEL_ALL ) : bool

Cambia el valor de píxeles individuales basados en la inatensidad de cada píxel comparado con el umbral. El resultado es una imagen de alto contraste de dos colores.

Parámetros

threshold

channel

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::thresholdImage()

<?php
function thresholdimage($imagePath, $threshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->thresholdimage($threshold * \Imagick::getQuantum(), $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Cambia el tamaño de una imagen

  • « Imagick::thresholdImage
  • Imagick::tintImage »
  • PHP Manual
  • Imagick
  • Cambia el tamaño de una imagen

Imagick::thumbnailImage

(PECL imagick 2, PECL imagick 3)

Imagick::thumbnailImage — Cambia el tamaño de una imagen

Descripción

Imagick::thumbnailImage ( int $columns , int $rows , bool $bestfit = false , bool $fill = false ) : bool

Cambia el tamaño de una imagen a las dimensiones dadas y elimina cualquier perfil asociado. El objetivo es producir imágenes de miniaturas pequeñas de bajo coste aptas para mostrar en la web. Si se proporciona true al tercer parámetro, los parámetros columns y rows se usan como máximos para cada cara. Ambas caras serán escaladas a una proporción menor hasta que coincidan o sean menores que el parámetro dado para la cara.

Nota: La conducta del parámetro bestfit cambió en Imagick 3.0.0. Antes de esta versión dar la dimensión de 400x400 a una imagen de 200x150 debería no tener efecto. En Imagick 3.0.0 y superiores la imagen sería llevada al tamaño de 400x300 ya que este es el "mejor ajuste" para las dimensiones dadas. Si el parámetro bestfit es utilizado, se debe indicar tanto el ancho como el alto.

Parámetros

columns

Ancho de la imagen

rows

Alto de la imagen

bestfit

Si se fuerzan valores máximos

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::thumbnailImage()

<?php
function thumbnailImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setbackgroundcolor('rgb(64, 64, 64)');
    $imagick->thumbnailImage(100, 100, true, true);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Aplica un vector de color a cada píxel en la imagen

  • « Imagick::thumbnailImage
  • Imagick::__toString »
  • PHP Manual
  • Imagick
  • Aplica un vector de color a cada píxel en la imagen

Imagick::tintImage

(PECL imagick 2, PECL imagick 3)

Imagick::tintImage — Aplica un vector de color a cada píxel en la imagen

Descripción

Imagick::tintImage ( mixed $tint , mixed $opacity ) : bool

Aplica un vector de color a cada píxel en la imagen. La longitud del vector es 0 para blanco y negro y su máximo para los medios-tonos. La función de precisión del vector es f(x)=(1-(4.0*((x-0.5)*(x-0.5)))).

Parámetros

tint

opacity

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una string represente el color como primer parámetro y que un valor de tipo float represente la opacidad como segundo parámetro. Versiones previas sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::tintImage()

<?php
function tintImage($r, $g, $b, $a) {
    $a = $a / 100;

    $imagick = new \Imagick();
    $imagick->newPseudoImage(400, 400, 'gradient:black-white');

    $tint = new \ImagickPixel("rgb($r, $g, $b)");
    $opacity = new \ImagickPixel("rgb(128, 128, 128, $a)");
    $imagick->tintImage($tint, $opacity);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Devuelve la imagen como un string

  • « Imagick::tintImage
  • Imagick::transformImage »
  • PHP Manual
  • Imagick
  • Devuelve la imagen como un string

Imagick::__toString

(PECL imagick 2, PECL imagick 3)

Imagick::__toString — Devuelve la imagen como un string

Descripción

Imagick::__toString ( ) : string

Devuelve la imagen actual como un string. Solamente devolverá una única imagen; no debería usarse con objetos Imagick que contengan varias imágenges, p.ej., un GIF animado o un PDF con varias páginas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el contenido del string en caso de éxito o un string vacío en caso de fallo.

Ver también

  • Imagick::getImageBlob() - Devuelve la secuencia de imágenes como un valor de tipo blob
  • Imagick::getImagesBlob() - Devuelve todas las secuencias de imágenes como un blob


Método conveniente para establecer el tamaño del recorte y la geometría de la imagen

  • « Imagick::__toString
  • Imagick::transformImageColorspace »
  • PHP Manual
  • Imagick
  • Método conveniente para establecer el tamaño del recorte y la geometría de la imagen

Imagick::transformImage

(PECL imagick 2, PECL imagick 3)

Imagick::transformImage — Método conveniente para establecer el tamaño del recorte y la geometría de la imagen

Descripción

Imagick::transformImage ( string $crop , string $geometry ) : Imagick

Método conveniente para establecer el tamaño del recorte y la geometría de la imagen desde cadenas. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

crop

Un string de geometría de recorte. Esta geometría define una sub-región de la imagen a recortar.

geometry

Un string de geometría de imagen. Esta geometría define el tamaño final de la imagen.

Valores devueltos

Devuelve un objeto Imagick que contiene la imagen transformada.

Ejemplos

Ejemplo #1 Usar Imagick::transformImage():

El ejemplo crea una imagen negra de 100x100 black.

<?php
$imagen = new Imagick();
$imagen->newImage(300, 200, "black");
$imagen_nueva = $imagen->transformImage("100x100", "100x100");
$imagen_nueva->writeImage('test_out.jpg');
?>

Ver también

  • Imagick::cropImage() - Extrae una región de la imagen
  • Imagick::resizeImage() - Escala una imagen
  • Imagick::thumbnailImage() - Cambia el tamaño de una imagen


Transforma una imagen a un nuevo espacio de color

  • « Imagick::transformImage
  • Imagick::transparentPaintImage »
  • PHP Manual
  • Imagick
  • Transforma una imagen a un nuevo espacio de color

Imagick::transformImageColorspace

(PECL imagick 3)

Imagick::transformImageColorspace — Transforma una imagen a un nuevo espacio de color

Descripción

Imagick::transformImageColorspace ( int $colorspace ) : bool

Transforma una imagen a un nuevo espacio de color

Parámetros

colorspace

El espacio de color al que debería convertirse la imagen, una de las constantes COLORSPACE, p.ej. Imagick::COLORSPACE_CMYK.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Imagick::transformImageColorspace()

Tranformar una imagen a un nuevo espacio de color, y extraer luego un solo canal para así poder ver los valores del mismo.

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    //el canal debería ser una de las constantes de canal, p.ej. \Imagick::CHANNEL_BLUE
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}
?>

Ver también

  • Imagick::setColorSpace() - Establecer el espacio de color

Ejemplos

Ejemplo #2 Imagick::transformImageColorspace()

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Pinta píxeles transparentes

  • « Imagick::transformImageColorspace
  • Imagick::transposeImage »
  • PHP Manual
  • Imagick
  • Pinta píxeles transparentes

Imagick::transparentPaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::transparentPaintImage — Pinta píxeles transparentes

Descripción

Imagick::transparentPaintImage ( mixed $target , float $alpha , float $fuzz , bool $invert ) : bool

Pinta píxeles transparente que coincidan con el color objetivo. Este método está disponible si Imagick ha sido compilado con la versión 6.3.8 o superior de ImageMagick.

Parámetros

target

El color objetivo a pintar

alpha

El nivel de transparencia: 1.0 es totalmente opaco y 0.0, totalmente transparente.

fuzz

La cantidad de difusión. Por ejemplo, setee fuzz a 10 y el color rojo a intensidades de 100 y 102 respectivamente son ahora interpretados como el mismo color.

invert

Si es true pinta cualquier píxel que no coincida con el color objetivo.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::transparentPaintImage()

<?php
function transparentPaintImage($color, $alpha, $fuzz) {
    $imagick = new \Imagick(realpath("images/BlueScreen.jpg"));

    //Need to be in a format that supports transparency
    $imagick->setimageformat('png');

    $imagick->transparentPaintImage(
        $color, $alpha, $fuzz * \Imagick::getQuantum(), false
    );

    //Not required, but helps tidy up left over pixels
    $imagick->despeckleimage();

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Crea una imagen espejo vertical

  • « Imagick::transparentPaintImage
  • Imagick::transverseImage »
  • PHP Manual
  • Imagick
  • Crea una imagen espejo vertical

Imagick::transposeImage

(PECL imagick 2, PECL imagick 3)

Imagick::transposeImage — Crea una imagen espejo vertical

Descripción

Imagick::transposeImage ( ) : bool

Crea una imagen espejo vertical reflejando los píxeles alrededor del eje x central mientras los rota 90 grados. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::transverseImage() - Crea una imagen espejo horizontal

Ejemplos

Ejemplo #1 Imagick::transposeImage()

<?php
function transposeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transposeImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Crea una imagen espejo horizontal

  • « Imagick::transposeImage
  • Imagick::trimImage »
  • PHP Manual
  • Imagick
  • Crea una imagen espejo horizontal

Imagick::transverseImage

(PECL imagick 2, PECL imagick 3)

Imagick::transverseImage — Crea una imagen espejo horizontal

Descripción

Imagick::transverseImage ( ) : bool

Crea una imagen espejo horizontal reflejando los píxeles sobre el eje y central mientras que los rota 270 grados. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::transposeImage() - Crea una imagen espejo vertical

Ejemplos

Ejemplo #1 Imagick::transverseImage()

<?php
function transverseImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transverseImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Elimina los extremos de la imagen

  • « Imagick::transverseImage
  • Imagick::uniqueImageColors »
  • PHP Manual
  • Imagick
  • Elimina los extremos de la imagen

Imagick::trimImage

(PECL imagick 2, PECL imagick 3)

Imagick::trimImage — Elimina los extremos de la imagen

Descripción

Imagick::trimImage ( float $fuzz ) : bool

Elimina los extremos que son el color de fondo de la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

fuzz

Por defecto, el objetivo debe coincidir exactamente con un color de píxel en particular. Sin embargo, en la mayoría de los casos dos colores pueden diferir por una cantidad pequeña. El miembro enfoque de la imagen define cuánta tolerancia es aceptable para considerar que dos colores son el mismo. Este parámetro represenata la variación del rango de cuantía.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Usar Imagick::trimImage():

Recortar una imagen, después mostrarla en el navegador.

<?php
/* Crear el objeto y leer la imagen */
$im = new Imagick("imagen.jpg");

/* Recortar la imagen. */
$im->trimImage(0);

/* Imprimir la imagen */
header("Content-Type: image/" . $im->getImageFormat());
echo $im;
?>

Ver también

  • Imagick::getQuantumDepth() - Obtiene la profundidad de la cuantía
  • Imagick::getQuantumRange() - Devuelve el rango de cuantía de Imagick


Desecha todos los colores de los píxeles excepto uno

  • « Imagick::trimImage
  • Imagick::unsharpMaskImage »
  • PHP Manual
  • Imagick
  • Desecha todos los colores de los píxeles excepto uno

Imagick::uniqueImageColors

(PECL imagick 2,PECL imagick 3)

Imagick::uniqueImageColors — Desecha todos los colores de los píxeles excepto uno

Descripción

Imagick::uniqueImageColors ( ) : bool

Desecha todos los colores de los píxeles excepto uno. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Imagick::uniqueImageColors()

<?php
function uniqueImageColors($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    //Reduce the image to 256 colours nicely.
    $imagick->quantizeImage(256, \Imagick::COLORSPACE_YIQ, 0, false, false);
    $imagick->uniqueImageColors();
    $imagick->scaleimage($imagick->getImageWidth(), $imagick->getImageHeight() * 20);
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Afila una imagen

  • « Imagick::uniqueImageColors
  • Imagick::valid »
  • PHP Manual
  • Imagick
  • Afila una imagen

Imagick::unsharpMaskImage

(PECL imagick 2, PECL imagick 3)

Imagick::unsharpMaskImage — Afila una imagen

Descripción

Imagick::unsharpMaskImage ( float $radius , float $sigma , float $amount , float $threshold , int $channel = Imagick::CHANNEL_ALL ) : bool

Afila una imagen. Se convoluciona la imagen con un operador gaussiano del radio y la desviación estándar (sigma) dados. Para obtener resultados razonables, el radio debería ser mayor que sigma. Use un radio de 0 y Imagick::sketchImage() seleccionará un radio apropiado automáticamente.

Parámetros

radius

sigma

amount

threshold

channel

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ejemplos

Ejemplo #1 Imagick::unsharpMaskImage()

<?php
function unsharpMaskImage($imagePath, $radius, $sigma, $amount, $unsharpThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->unsharpMaskImage($radius, $sigma, $amount, $unsharpThreshold);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Comprueba si el elemento actual es válido

  • « Imagick::unsharpMaskImage
  • Imagick::vignetteImage »
  • PHP Manual
  • Imagick
  • Comprueba si el elemento actual es válido

Imagick::valid

(PECL imagick 2, PECL imagick 3)

Imagick::valid — Comprueba si el elemento actual es válido

Descripción

Imagick::valid ( ) : bool

Comprueba si el elemento actual es válido.

Valores devueltos

Devuelve true en caso de éxito.


Añade un filtro de viñeta a la imagen

  • « Imagick::valid
  • Imagick::waveImage »
  • PHP Manual
  • Imagick
  • Añade un filtro de viñeta a la imagen

Imagick::vignetteImage

(PECL imagick 2, PECL imagick 3)

Imagick::vignetteImage — Añade un filtro de viñeta a la imagen

Descripción

Imagick::vignetteImage ( float $blackPoint , float $whitePoint , int $x , int $y ) : bool

Suaviza los extremos de la imagen al estilo viñeta. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

blackPoint

El punto negro.

whitePoint

El punto blanco.

x

Índice X de la elipse

y

Índice Y de la elipse

Valores devueltos

Devuelve true en caso de éxito.

Ver también

  • Imagick::waveImage() - Aplica un filtro de onda a la imagen
  • Imagick::swirlImage() - Arremolina los píxeles desde el centro de la imagen

Ejemplos

Ejemplo #1 Imagick::vignetteImage()

<?php
function vignetteImage($imagePath, $blackPoint, $whitePoint, $x, $y) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->vignetteImage($blackPoint, $whitePoint, $x, $y);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Aplica un filtro de onda a la imagen

  • « Imagick::vignetteImage
  • Imagick::whiteThresholdImage »
  • PHP Manual
  • Imagick
  • Aplica un filtro de onda a la imagen

Imagick::waveImage

(PECL imagick 2, PECL imagick 3)

Imagick::waveImage — Aplica un filtro de onda a la imagen

Descripción

Imagick::waveImage ( float $amplitude , float $length ) : bool

Aplica un filtro de onda a la imagen. Este método está disponible si Imagick ha sido compilado con la versión 6.2.9 o superior de ImageMagick.

Parámetros

amplitude

La amplitud de la onda.

length

La longitud de la onda.

Valores devueltos

Devuelve true en caso de éxito.

Errores/Excepciones

Lanza ImagickException en caso de error.

Ver también

  • Imagick::solarizeImage() - Aplica un efecto de solarización a la imagen
  • Imagick::oilpaintImage() - Simula una pintura al óleo
  • Imagick::embossImage() - Devuelve una imagen en escala de grises con un efecto tridimensional
  • Imagick::addNoiseImage() - Añade ruido aleatorio a la imagen
  • Imagick::swirlImage() - Arremolina los píxeles desde el centro de la imagen

Ejemplos

Ejemplo #1 WaveImage can be quite slow Imagick::waveImage()

<?php
function waveImage($imagePath, $amplitude, $length) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->waveImage($amplitude, $length);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Fuerza a todos los píxeles por encima del umbral a ser blancos

  • « Imagick::waveImage
  • Imagick::writeImage »
  • PHP Manual
  • Imagick
  • Fuerza a todos los píxeles por encima del umbral a ser blancos

Imagick::whiteThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::whiteThresholdImage — Fuerza a todos los píxeles por encima del umbral a ser blancos

Descripción

Imagick::whiteThresholdImage ( mixed $threshold ) : bool

Es como Imagick::ThresholdImage() excepto que fuerza a todos los píxeles por encima del umbral a ser blancos dejando todos los píxeles por debajo del umbral sin cambios.

Parámetros

threshold

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
2.1.0 | Ahora se permite que una cadena represente el color como parámetro. Versiones previas sólo permitían un objeto ImagickPixel.

Ejemplos

Ejemplo #1 Imagick::whiteThresholdImage()

<?php
function whiteThresholdImage($imagePath, $color) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->whiteThresholdImage($color);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Escribe una imagen al nombre de fichero especificado

  • « Imagick::whiteThresholdImage
  • Imagick::writeImageFile »
  • PHP Manual
  • Imagick
  • Escribe una imagen al nombre de fichero especificado

Imagick::writeImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImage — Escribe una imagen al nombre de fichero especificado

Descripción

Imagick::writeImage ( string $filename = NULL ) : bool

Escribe una imagen al nombre de fichero especificado. Si el parámetro 'filename' es NULL, la imagen se escribe en el nombre de fichero establecido por Imagick::readImage() o Imagick::setImageFilename().

Parámetros

filename

Nombre del fichero donde escribir la imagen. La extensión del nombre de fichero define el tipo del fichero. El formato puede ser forzado independientemente del formato que use la extensión del fichero: usando un prefijo, por ejemplo "jpg:test.png".

Valores devueltos

Devuelve true en caso de éxito.


Escribe una imagen a un gestor de archivo

  • « Imagick::writeImage
  • Imagick::writeImages »
  • PHP Manual
  • Imagick
  • Escribe una imagen a un gestor de archivo

Imagick::writeImageFile

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImageFile — Escribe una imagen a un gestor de archivo

Descripción

Imagick::writeImageFile ( resource $filehandle ) : bool

Escribe una secuencia de imágenes a un gestor de archivo abierto. El gestro debe ser abierto con, por ejemplo, fopen. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

filehandle

El gestor de archivo donde se va a escribir la imagen

Valores devueltos

Devuelve true en caso de éxito.


Escribe una imagen o secuencia de imágenes

  • « Imagick::writeImageFile
  • Imagick::writeImagesFile »
  • PHP Manual
  • Imagick
  • Escribe una imagen o secuencia de imágenes

Imagick::writeImages

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImages — Escribe una imagen o secuencia de imágenes

Descripción

Imagick::writeImages ( string $filename , bool $adjoin ) : bool

Escribe una imagen o secuencia de imágenes.

Parámetros

filename

adjoin

Valores devueltos

Devuelve true en caso de éxito.


Escribe fotogramas al gestor de archivo

  • « Imagick::writeImages
  • ImagickDraw »
  • PHP Manual
  • Imagick
  • Escribe fotogramas al gestor de archivo

Imagick::writeImagesFile

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImagesFile — Escribe fotogramas al gestor de archivo

Descripción

Imagick::writeImagesFile ( resource $filehandle ) : bool

Escribe todos los fotogramas en un gestor de archivo abierto. Este método se puede usar para escribir gifs u otras imágenes multi-fotograma en un gestor de archivo abierto. Este método está disponible si Imagick ha sido compilado con la versión 6.3.6 o superior de ImageMagick.

Parámetros

filehandle

El gestor de archivo donde se van a escribir las imágenes

Valores devueltos

Devuelve true en caso de éxito.


La clase ImagickDraw

(PECL imagick 2, PECL imagick 3)

Sinopsis de la Clase

ImagickDraw {
affine ( array $affine ) : bool
annotation ( float $x , float $y , string $text ) : bool
arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : bool
bezier ( array $coordinates ) : bool
circle ( float $ox , float $oy , float $px , float $py ) : bool
clear ( ) : bool
clone ( ) : ImagickDraw
color ( float $x , float $y , int $paintMethod ) : bool
comment ( string $comment ) : bool
composite ( int $compose , float $x , float $y , float $width , float $height , Imagick $compositeWand ) : bool
__construct ( )
destroy ( ) : bool
ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : bool
getClipPath ( ) : string
getClipRule ( ) : int
getClipUnits ( ) : int
getFillColor ( ) : ImagickPixel
getFillOpacity ( ) : float
getFillRule ( ) : int
getFont ( ) : string
getFontFamily ( ) : string
getFontSize ( ) : float
public getFontStretch ( ) : int
getFontStyle ( ) : int
getFontWeight ( ) : int
getGravity ( ) : int
getStrokeAntialias ( ) : bool
getStrokeColor ( ) : ImagickPixel
getStrokeDashArray ( ) : array
getStrokeDashOffset ( ) : float
getStrokeLineCap ( ) : int
getStrokeLineJoin ( ) : int
getStrokeMiterLimit ( ) : int
getStrokeOpacity ( ) : float
getStrokeWidth ( ) : float
getTextAlignment ( ) : int
getTextAntialias ( ) : bool
getTextDecoration ( ) : int
getTextEncoding ( ) : string
public getTextInterlineSpacing ( ) : float
public getTextInterwordSpacing ( ) : float
public getTextKerning ( ) : float
getTextUnderColor ( ) : ImagickPixel
getVectorGraphics ( ) : string
line ( float $sx , float $sy , float $ex , float $ey ) : bool
matte ( float $x , float $y , int $paintMethod ) : bool
pathClose ( ) : bool
pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y ) : bool
pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y ) : bool
pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y ) : bool
pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y ) : bool
pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y ) : bool
pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y ) : bool
pathEllipticArcAbsolute ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
pathEllipticArcRelative ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
pathFinish ( ) : bool
pathLineToAbsolute ( float $x , float $y ) : bool
pathLineToHorizontalAbsolute ( float $x ) : bool
pathLineToHorizontalRelative ( float $x ) : bool
pathLineToRelative ( float $x , float $y ) : bool
pathLineToVerticalAbsolute ( float $y ) : bool
pathLineToVerticalRelative ( float $y ) : bool
pathMoveToAbsolute ( float $x , float $y ) : bool
pathMoveToRelative ( float $x , float $y ) : bool
pathStart ( ) : bool
point ( float $x , float $y ) : bool
polygon ( array $coordinates ) : bool
polyline ( array $coordinates ) : bool
pop ( ) : bool
popClipPath ( ) : bool
popDefs ( ) : bool
popPattern ( ) : bool
push ( ) : bool
pushClipPath ( string $clip_mask_id ) : bool
pushDefs ( ) : bool
pushPattern ( string $pattern_id , float $x , float $y , float $width , float $height ) : bool
rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : bool
render ( ) : bool
public resetVectorGraphics ( ) : void
rotate ( float $degrees ) : bool
roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : bool
scale ( float $x , float $y ) : bool
setClipPath ( string $clip_mask ) : bool
setClipRule ( int $fill_rule ) : bool
setClipUnits ( int $clip_units ) : bool
setFillAlpha ( float $opacity ) : bool
setFillColor ( ImagickPixel $fill_pixel ) : bool
setFillOpacity ( float $fillOpacity ) : bool
setFillPatternURL ( string $fill_url ) : bool
setFillRule ( int $fill_rule ) : bool
setFont ( string $font_name ) : bool
setFontFamily ( string $font_family ) : bool
setFontSize ( float $pointsize ) : bool
setFontStretch ( int $fontStretch ) : bool
setFontStyle ( int $style ) : bool
setFontWeight ( int $font_weight ) : bool
setGravity ( int $gravity ) : bool
public setResolution ( string $x_resolution , string $y_resolution ) : void
setStrokeAlpha ( float $opacity ) : bool
setStrokeAntialias ( bool $stroke_antialias ) : bool
setStrokeColor ( ImagickPixel $stroke_pixel ) : bool
setStrokeDashArray ( array $dashArray ) : bool
setStrokeDashOffset ( float $dash_offset ) : bool
setStrokeLineCap ( int $linecap ) : bool
setStrokeLineJoin ( int $linejoin ) : bool
setStrokeMiterLimit ( int $miterlimit ) : bool
setStrokeOpacity ( float $stroke_opacity ) : bool
setStrokePatternURL ( string $stroke_url ) : bool
setStrokeWidth ( float $stroke_width ) : bool
setTextAlignment ( int $alignment ) : bool
setTextAntialias ( bool $antiAlias ) : bool
setTextDecoration ( int $decoration ) : bool
setTextEncoding ( string $encoding ) : bool
public setTextInterlineSpacing ( float $spacing ) : void
public setTextInterwordSpacing ( float $spacing ) : void
public setTextKerning ( float $kerning ) : void
setTextUnderColor ( ImagickPixel $under_color ) : bool
setVectorGraphics ( string $xml ) : bool
setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 ) : bool
skewX ( float $degrees ) : bool
skewY ( float $degrees ) : bool
translate ( float $x , float $y ) : bool
}

Tabla de contenidos

  • ImagickDraw::affine — Ajusta la matriz de transformación afín actual
  • ImagickDraw::annotation — Dibuja texto en la imagen
  • ImagickDraw::arc — Dibuja un arco
  • ImagickDraw::bezier — Dibuja una curva de Bézier
  • ImagickDraw::circle — Dibuja un círculo
  • ImagickDraw::clear — Borra el objeto ImagickDraw
  • ImagickDraw::clone — Hace una copia exacta del objeto ImagickDraw especificado
  • ImagickDraw::color — Dibuja color en una imagen
  • ImagickDraw::comment — Añade un comentario
  • ImagickDraw::composite — Compone una imagen dentro de la imagen actual
  • ImagickDraw::__construct — El constructor ImagickDraw
  • ImagickDraw::destroy — Libera todos los recursos asociados
  • ImagickDraw::ellipse — Dibuja una elipse en la imagen
  • ImagickDraw::getClipPath — Obtiene el ID del trazado de recorte actual
  • ImagickDraw::getClipRule — Devuelve la regla de relleno de un polígono actual
  • ImagickDraw::getClipUnits — Devuelve la interpretación de unidades del trazado de recorte
  • ImagickDraw::getFillColor — Devuelve el color de relleno
  • ImagickDraw::getFillOpacity — Devuelve la opacidad usada cuando se dibuja
  • ImagickDraw::getFillRule — Devuelve la regla de relleno
  • ImagickDraw::getFont — Devuelve la fuente
  • ImagickDraw::getFontFamily — Devuelve la familia de la fuente
  • ImagickDraw::getFontSize — Devuelve el tamaño de punto de la fuente
  • ImagickDraw::getFontStretch — Description
  • ImagickDraw::getFontStyle — Devuelve el estilo de fuente
  • ImagickDraw::getFontWeight — Devuelve el peso de la fuente
  • ImagickDraw::getGravity — Devuelve la gravedad de emplazamiento del texto
  • ImagickDraw::getStrokeAntialias — Devuelve la configuración de antialias de contorno actual
  • ImagickDraw::getStrokeColor — Devuelve el color usado por los perfiles de objetos contorneados
  • ImagickDraw::getStrokeDashArray — Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados
  • ImagickDraw::getStrokeDashOffset — Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
  • ImagickDraw::getStrokeLineCap — Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
  • ImagickDraw::getStrokeLineJoin — Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados
  • ImagickDraw::getStrokeMiterLimit — Devuelve el límite del inglete del contorno
  • ImagickDraw::getStrokeOpacity — Devuelve la opacidad del perfil de objetos contorneados
  • ImagickDraw::getStrokeWidth — Devuelve al ancho del contorno usado para dibujar contornos de objetos
  • ImagickDraw::getTextAlignment — Devuelve la alineación del texto
  • ImagickDraw::getTextAntialias — Devuelve la configuración de antialias del texto actual
  • ImagickDraw::getTextDecoration — Devuelve la decoración del texto
  • ImagickDraw::getTextEncoding — Devuelve la codificación usada para anotaciones de texto
  • ImagickDraw::getTextInterlineSpacing — Description
  • ImagickDraw::getTextInterwordSpacing — Description
  • ImagickDraw::getTextKerning — Description
  • ImagickDraw::getTextUnderColor — Devuelve el color debajo del texto
  • ImagickDraw::getVectorGraphics — Devuelve una cadena que contiene gráficos vectoriales
  • ImagickDraw::line — Dibuja una línea
  • ImagickDraw::matte — Pinta sobre el canal de opacidad de la imagen
  • ImagickDraw::pathClose — Añade un elemento de trazado al trazado actual
  • ImagickDraw::pathCurveToAbsolute — Dibuja una curva cúbica de Bézier
  • ImagickDraw::pathCurveToQuadraticBezierAbsolute — Dibuja una curva Bézier cuadrática
  • ImagickDraw::pathCurveToQuadraticBezierRelative — Dibuja una curva Bézier cuadrática
  • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Dibuja una curva Bézier cuadrática
  • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Dibuja una curva Bézier cuadrática
  • ImagickDraw::pathCurveToRelative — Dibuja una curva cúbica de Bézier
  • ImagickDraw::pathCurveToSmoothAbsolute — Dibuja una curva cúbica de Bézier
  • ImagickDraw::pathCurveToSmoothRelative — Dibuja una curva cúbica de Bézier
  • ImagickDraw::pathEllipticArcAbsolute — Dibuja un arco elíptico
  • ImagickDraw::pathEllipticArcRelative — Dibuja un arco elíptico
  • ImagickDraw::pathFinish — Finaliza el trazado actual
  • ImagickDraw::pathLineToAbsolute — Dibuja un trazado de línea
  • ImagickDraw::pathLineToHorizontalAbsolute — Dibuja un trazado de línea horizontal
  • ImagickDraw::pathLineToHorizontalRelative — Dibuja una línea horizontal
  • ImagickDraw::pathLineToRelative — Dibuja un trazado de línea
  • ImagickDraw::pathLineToVerticalAbsolute — Dibuja un línea vertical
  • ImagickDraw::pathLineToVerticalRelative — Dibuja un trazado de línea vertical
  • ImagickDraw::pathMoveToAbsolute — Inicia un nuevo sub-trazado
  • ImagickDraw::pathMoveToRelative — Inicia un nuevo sub-trazado
  • ImagickDraw::pathStart — Declara el inicio de una lista de dibujo de trazados
  • ImagickDraw::point — Dibuja un punto
  • ImagickDraw::polygon — Dibuja un polígono
  • ImagickDraw::polyline — Dibuja una poli-línea
  • ImagickDraw::pop — Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido
  • ImagickDraw::popClipPath — Finaliza una definición de un trazado de recorte
  • ImagickDraw::popDefs — Finaliza una lista de definiciones
  • ImagickDraw::popPattern — Finaliza una definición de patrón
  • ImagickDraw::push — Clona el objeto ImagickDraw actual y lo mete en la pila
  • ImagickDraw::pushClipPath — Inicia la definición de un trazado de recorte
  • ImagickDraw::pushDefs — Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo
  • ImagickDraw::pushPattern — Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado
  • ImagickDraw::rectangle — Dibuja un rectángulo
  • ImagickDraw::render — Renderiza todos los comandos de dibujo precedentes en la imagen
  • ImagickDraw::resetVectorGraphics — Description
  • ImagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual
  • ImagickDraw::roundRectangle — Dibuja un rectángulo redondeado
  • ImagickDraw::scale — Ajusta el factor de escala
  • ImagickDraw::setClipPath — Asocia un trazado de recorte nominado con la imagen
  • ImagickDraw::setClipRule — Establece la regla de relleno de polígonos a usar por el trazado de recorte
  • ImagickDraw::setClipUnits — Establece la interpretación de las unidades de un trazado de recorte
  • ImagickDraw::setFillAlpha — Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno
  • ImagickDraw::setFillColor — Establece el color de relleno que se va a usar para dibujar objetos rellenos
  • ImagickDraw::setFillOpacity — Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno
  • ImagickDraw::setFillPatternURL — Establece la URL a usar como un patrón de relleno para objetos rellenos
  • ImagickDraw::setFillRule — Establece la regla de relleno a usar mientras se dibujan polígonos
  • ImagickDraw::setFont — Establece la fuente especificada completamente para usarla cuando se escribe texto
  • ImagickDraw::setFontFamily — Establece la familia de fuentes para usarla cuando se escribe texto
  • ImagickDraw::setFontSize — Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto
  • ImagickDraw::setFontStretch — Establece el estiramiento de la fuente para usarla cuando se escribe texto
  • ImagickDraw::setFontStyle — Establece el estilo de fuente para usarlo cuando se escribe texto
  • ImagickDraw::setFontWeight — Establece el peso de fuente
  • ImagickDraw::setGravity — Establece la gravedad de ubicación del texto
  • ImagickDraw::setResolution — Description
  • ImagickDraw::setStrokeAlpha — Especifica la opacidad de los perfiles de los objetos contorneados
  • ImagickDraw::setStrokeAntialias — Controla si los perfiles contorneados tiene antialias
  • ImagickDraw::setStrokeColor — Establece el color usado por los perfiles de objetos contorneados
  • ImagickDraw::setStrokeDashArray — Especifica el patrón de rayas y huecos usado por los trazados de contorno
  • ImagickDraw::setStrokeDashOffset — Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
  • ImagickDraw::setStrokeLineCap — Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
  • ImagickDraw::setStrokeLineJoin — Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados
  • ImagickDraw::setStrokeMiterLimit — Especifica el límite del inglete
  • ImagickDraw::setStrokeOpacity — Especifica la opacidad de los perfiles de los objetos contorneados
  • ImagickDraw::setStrokePatternURL — Establece el patrón usado para los perfiles de objetos contorneados
  • ImagickDraw::setStrokeWidth — Establece el ancho del contorno a usar para dibujar perfiles de objetos
  • ImagickDraw::setTextAlignment — Especifica una alineación de texto
  • ImagickDraw::setTextAntialias — Controla si el texto tiene antialias
  • ImagickDraw::setTextDecoration — Especifica una decoración
  • ImagickDraw::setTextEncoding — Especifica el conjunto de codificación del texto
  • ImagickDraw::setTextInterlineSpacing — Description
  • ImagickDraw::setTextInterwordSpacing — Description
  • ImagickDraw::setTextKerning — Description
  • ImagickDraw::setTextUnderColor — Especifica el color de un rectángulo de fondo
  • ImagickDraw::setVectorGraphics — Establece los gráficos vectoriales
  • ImagickDraw::setViewbox — Establece el tamaño de todos los lienzos
  • ImagickDraw::skewX — Tuerce el sistema de coordenadas actual en la dirección horizontal
  • ImagickDraw::skewY — Tuerce el sistema de coordenadas actual en la dirección vertical
  • ImagickDraw::translate — Aplica una traslación del sistema de coordenadas actual


Ajusta la matriz de transformación afín actual

  • « ImagickDraw
  • ImagickDraw::annotation »
  • PHP Manual
  • ImagickDraw
  • Ajusta la matriz de transformación afín actual

ImagickDraw::affine

(PECL imagick 2, PECL imagick 3)

ImagickDraw::affine — Ajusta la matriz de transformación afín actual

Descripción

ImagickDraw::affine ( array $affine ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Ajusta la matriz de transformación afín actual con la matriz de transformación afín especificada.

Parámetros

affine

Los parámetros de la matriz afín

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::affine()

<?php
function affine($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $PI = 3.141592653589794;
    $angle = 60 * $PI / 360;

    //Scale the drawing co-ordinates.
    $affineScale = array("sx" => 1.75, "sy" => 1.75, "rx" => 0, "ry" => 0, "tx" => 0, "ty" => 0);

    //Shear the drawing co-ordinates.
    $affineShear = array("sx" => 1, "sy" => 1, "rx" => sin($angle), "ry" => -sin($angle), "tx" => 0, "ty" => 0);

    //Rotate the drawing co-ordinates. The shear affine matrix
    //produces incorrectly scaled drawings.
    $affineRotate = array("sx" => cos($angle), "sy" => cos($angle), "rx" => sin($angle), "ry" => -sin($angle), "tx" => 0, "ty" => 0,);

    //Translate (offset) the drawing
    $affineTranslate = array("sx" => 1, "sy" => 1, "rx" => 0, "ry" => 0, "tx" => 30, "ty" => 30);

    //The identiy affine matrix
    $affineIdentity = array("sx" => 1, "sy" => 1, "rx" => 0, "ry" => 0, "tx" => 0, "ty" => 0);

    $examples = [$affineScale, $affineShear, $affineRotate, $affineTranslate, $affineIdentity,];

    $count = 0;

    foreach ($examples as $example) {
        $draw->push();
        $draw->translate(($count % 2) * 250, intval($count / 2) * 250);
        $draw->translate(100, 100);
        $draw->affine($example);
        $draw->rectangle(-50, -50, 50, 50);
        $draw->pop();
        $count++;
    }

    //Create an image object which the draw commands can be rendered into
    $image = new \Imagick();
    $image->newImage(500, 750, $backgroundColor);
    $image->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $image->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Dibuja texto en la imagen

  • « ImagickDraw::affine
  • ImagickDraw::arc »
  • PHP Manual
  • ImagickDraw
  • Dibuja texto en la imagen

ImagickDraw::annotation

(PECL imagick 2, PECL imagick 3)

ImagickDraw::annotation — Dibuja texto en la imagen

Descripción

ImagickDraw::annotation ( float $x , float $y , string $text ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja texto en la imagen.

Parámetros

x

Coordenada x donde se dibuja el texto

y

Coordenada y donde se dibuja el texto

text

El texto que se va a dibujar en la imagen

Valores devueltos

No devuelve ningún valor.


Dibuja un arco

  • « ImagickDraw::annotation
  • ImagickDraw::bezier »
  • PHP Manual
  • ImagickDraw
  • Dibuja un arco

ImagickDraw::arc

(PECL imagick 2, PECL imagick 3)

ImagickDraw::arc — Dibuja un arco

Descripción

ImagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un arco que cae dentro de un rectángulo limitado en la imagen.

Parámetros

sx

Coordenada x del comienzo del rectángulo limitado

sy

Coordenada y del comienzo del rectángulo limitado

ex

Coordenada x del final del rectángulo limitado

ey

Coordenada y del final del rectángulo limitado

sd

comienzo de los grados de rotación

ed

final de los grados de rotación

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::arc()

<?php
function arc($strokeColor, $fillColor, $backgroundColor, $startX, $startY, $endX, $endY, $startAngle, $endAngle) {

    //Create a ImagickDraw object to draw into.
    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);

    $draw->arc($startX, $startY, $endX, $endY, $startAngle, $endAngle);

    //Create an image object which the draw commands can be rendered into
    $image = new \Imagick();
    $image->newImage(IMAGE_WIDTH, IMAGE_HEIGHT, $backgroundColor);
    $image->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $image->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Dibuja una curva de Bézier

  • « ImagickDraw::arc
  • ImagickDraw::circle »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva de Bézier

ImagickDraw::bezier

(PECL imagick 2, PECL imagick 3)

ImagickDraw::bezier — Dibuja una curva de Bézier

Descripción

ImagickDraw::bezier ( array $coordinates ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva de Bézier a través de un conjunto de puntos en la imagen.

Parámetros

coordinates

Array multidimensional como array( array( 'x' => 1, 'y' => 2 ), array( 'x' => 3, 'y' => 4 ) )

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::bezier()

<?php
function bezier($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $smoothPointsSet = [
        [
            ['x' => 10.0 * 5, 'y' => 10.0 * 5],
            ['x' => 30.0 * 5, 'y' => 90.0 * 5],
            ['x' => 25.0 * 5, 'y' => 10.0 * 5],
            ['x' => 50.0 * 5, 'y' => 50.0 * 5],
        ],
        [
            ['x' => 50.0 * 5, 'y' => 50.0 * 5],
            ['x' => 75.0 * 5, 'y' => 90.0 * 5],
            ['x' => 70.0 * 5, 'y' => 10.0 * 5],
            ['x' => 90.0 * 5, 'y' => 40.0 * 5],
        ],
    ];

    foreach ($smoothPointsSet as $points) {
        $draw->bezier($points);
    }

    $disjointPoints = [
        [
            ['x' => 10 * 5, 'y' => 10 * 5],
            ['x' => 30 * 5, 'y' => 90 * 5],
            ['x' => 25 * 5, 'y' => 10 * 5],
            ['x' => 50 * 5, 'y' => 50 * 5],
        ],
        [
            ['x' => 50 * 5, 'y' => 50 * 5],
            ['x' => 80 * 5, 'y' => 50 * 5],
            ['x' => 70 * 5, 'y' => 10 * 5],
            ['x' => 90 * 5, 'y' => 40 * 5],
         ]
    ];
    $draw->translate(0, 200);

    foreach ($disjointPoints as $points) {
        $draw->bezier($points);
    }

    //Create an image object which the draw commands can be rendered into
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $imagick->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Dibuja un círculo

  • « ImagickDraw::bezier
  • ImagickDraw::clear »
  • PHP Manual
  • ImagickDraw
  • Dibuja un círculo

ImagickDraw::circle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::circle — Dibuja un círculo

Descripción

ImagickDraw::circle ( float $ox , float $oy , float $px , float $py ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un círculo en la imagen.

Parámetros

ox

coordenada x del origen

oy

coordenada y del origen

px

coordenada x del perímetro

py

coordenada y del perímetro

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::circle()

<?php
function circle($strokeColor, $fillColor, $backgroundColor, $originX, $originY, $endX, $endY) {

    //Create a ImagickDraw object to draw into.
    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->circle($originX, $originY, $endX, $endY);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Borra el objeto ImagickDraw

  • « ImagickDraw::circle
  • ImagickDraw::clone »
  • PHP Manual
  • ImagickDraw
  • Borra el objeto ImagickDraw

ImagickDraw::clear

(PECL imagick 2, PECL imagick 3)

ImagickDraw::clear — Borra el objeto ImagickDraw

Descripción

ImagickDraw::clear ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Borra el objeto ImagickDraw de cualquier comando acumulado, y reinicia la configuración que contiene a sus valores predeterminados.

Valores devueltos

Devuelve un objeto ImagickDraw.


Hace una copia exacta del objeto ImagickDraw especificado

  • « ImagickDraw::clear
  • ImagickDraw::color »
  • PHP Manual
  • ImagickDraw
  • Hace una copia exacta del objeto ImagickDraw especificado

ImagickDraw::clone

(PECL imagick 2, PECL imagick 3)

ImagickDraw::clone — Hace una copia exacta del objeto ImagickDraw especificado

Descripción

ImagickDraw::clone ( ) : ImagickDraw
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Hace una copia exacta del objeto ImagickDraw especificado.

Valores devueltos

Lo que devuelve la función, primero si se tuvo éxito, después si falló. Véase también la entidad &return.success;


Dibuja color en una imagen

  • « ImagickDraw::clone
  • ImagickDraw::comment »
  • PHP Manual
  • ImagickDraw
  • Dibuja color en una imagen

ImagickDraw::color

(PECL imagick 2, PECL imagick 3)

ImagickDraw::color — Dibuja color en una imagen

Descripción

ImagickDraw::color ( float $x , float $y , int $paintMethod ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja color en una imagen usando el color de relleno actual, comenzando por la posición especificada y usando el método de pintura especificado.

Parámetros

x

coordenada x de la pintura

y

coordenada y de la pintura

paintMethod

una de las constantes PAINT_

Valores devueltos

No devuelve ningún valor.


Añade un comentario

  • « ImagickDraw::color
  • ImagickDraw::composite »
  • PHP Manual
  • ImagickDraw
  • Añade un comentario

ImagickDraw::comment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::comment — Añade un comentario

Descripción

ImagickDraw::comment ( string $comment ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Añade un comentario a un vector de flujo de salida.

Parámetros

comment

El string de comentario que se va a añadir al vector de flujo de salida

Valores devueltos

No devuelve ningún valor.


Compone una imagen dentro de la imagen actual

  • « ImagickDraw::comment
  • ImagickDraw::__construct »
  • PHP Manual
  • ImagickDraw
  • Compone una imagen dentro de la imagen actual

ImagickDraw::composite

(PECL imagick 2, PECL imagick 3)

ImagickDraw::composite — Compone una imagen dentro de la imagen actual

Descripción

ImagickDraw::composite ( int $compose , float $x , float $y , float $width , float $height , Imagick $compositeWand ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Compone una imagen dentro de la imagen actual, usando el operador de composición especificado, la posición especificada, y el tamaño especificado.

Parámetros

compose

el operador de composición. Una de las constantes COMPOSITE_

x

coordenada x de la esquina superior izquierda

y

coordenada y de la esquina superior izquierda

width

ancho de la imagen compuesta

height

alto de la imagen compuesta

compositeWand

el objeto Imagick de donde se va a tomar la imagen compuesta

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::composite()

<?php
function composite($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setFillOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFont("../fonts/CANDY.TTF");
    $draw->setFontSize(140);
    $draw->rectangle(0, 0, 1000, 300);
    $draw->setFillColor('white');
    $draw->setfillopacity(1);
    $draw->annotation(50, 180, "Lorem Ipsum!");

    //Create an image object which the draw commands can be rendered into
    $imagick = new \Imagick();
    $imagick->newImage(1000, 302, $backgroundColor);
    $imagick->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $imagick->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


El constructor ImagickDraw

  • « ImagickDraw::composite
  • ImagickDraw::destroy »
  • PHP Manual
  • ImagickDraw
  • El constructor ImagickDraw

ImagickDraw::__construct

(PECL imagick 2, PECL imagick 3)

ImagickDraw::__construct — El constructor ImagickDraw

Descripción

ImagickDraw::__construct ( )
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

El constructor de ImagickDraw

Valores devueltos

No devuelve ningún valor.


Libera todos los recursos asociados

  • « ImagickDraw::__construct
  • ImagickDraw::ellipse »
  • PHP Manual
  • ImagickDraw
  • Libera todos los recursos asociados

ImagickDraw::destroy

(PECL imagick 2, PECL imagick 3)

ImagickDraw::destroy — Libera todos los recursos asociados

Descripción

ImagickDraw::destroy ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Libera todos los recursos asociados con el objeto ImagickDraw.

Valores devueltos

No devuelve ningún valor.


Dibuja una elipse en la imagen

  • « ImagickDraw::destroy
  • ImagickDraw::getClipPath »
  • PHP Manual
  • ImagickDraw
  • Dibuja una elipse en la imagen

ImagickDraw::ellipse

(PECL imagick 2, PECL imagick 3)

ImagickDraw::ellipse — Dibuja una elipse en la imagen

Descripción

ImagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una elipse en la imagen.

Parámetros

ox

oy

rx

ry

start

end

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::ellipse()

<?php
function ellipse($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->ellipse(125, 70, 100, 50, 0, 360);
    $draw->ellipse(350, 70, 100, 50, 0, 315);

    $draw->push();
    $draw->translate(125, 250);
    $draw->rotate(30);
    $draw->ellipse(0, 0, 100, 50, 0, 360);
    $draw->pop();

    $draw->push();
    $draw->translate(350, 250);
    $draw->rotate(30);
    $draw->ellipse(0, 0, 100, 50, 0, 315);
    $draw->pop();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Obtiene el ID del trazado de recorte actual

  • « ImagickDraw::ellipse
  • ImagickDraw::getClipRule »
  • PHP Manual
  • ImagickDraw
  • Obtiene el ID del trazado de recorte actual

ImagickDraw::getClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipPath — Obtiene el ID del trazado de recorte actual

Descripción

ImagickDraw::getClipPath ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene el ID del trazado de recorte actual.

Valores devueltos

Devuelve un string que contiene el ID del trazado de recorte o false si no existe ningún trazado de recorte.


Devuelve la regla de relleno de un polígono actual

  • « ImagickDraw::getClipPath
  • ImagickDraw::getClipUnits »
  • PHP Manual
  • ImagickDraw
  • Devuelve la regla de relleno de un polígono actual

ImagickDraw::getClipRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipRule — Devuelve la regla de relleno de un polígono actual

Descripción

ImagickDraw::getClipRule ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la regla de relleno de un polígono actual usada por el trazado de recorte.

Valores devueltos

Devuelve una de las constantes FILLRULE_.


Devuelve la interpretación de unidades del trazado de recorte

  • « ImagickDraw::getClipRule
  • ImagickDraw::getFillColor »
  • PHP Manual
  • ImagickDraw
  • Devuelve la interpretación de unidades del trazado de recorte

ImagickDraw::getClipUnits

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipUnits — Devuelve la interpretación de unidades del trazado de recorte

Descripción

ImagickDraw::getClipUnits ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la interpretación de unidades del trazado de recorte.

Valores devueltos

Devuelve un integer si se tuvo éxito.


Devuelve el color de relleno

  • « ImagickDraw::getClipUnits
  • ImagickDraw::getFillOpacity »
  • PHP Manual
  • ImagickDraw
  • Devuelve el color de relleno

ImagickDraw::getFillColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillColor — Devuelve el color de relleno

Descripción

ImagickDraw::getFillColor ( ) : ImagickPixel
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el color de relleno usado cuando se dibujan objetos rellenos.

Valores devueltos

Devuelve un objeto ImagickPixel.


Devuelve la opacidad usada cuando se dibuja

  • « ImagickDraw::getFillColor
  • ImagickDraw::getFillRule »
  • PHP Manual
  • ImagickDraw
  • Devuelve la opacidad usada cuando se dibuja

ImagickDraw::getFillOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillOpacity — Devuelve la opacidad usada cuando se dibuja

Descripción

ImagickDraw::getFillOpacity ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la opacidad usada cuando se dibuja utilizando el color de relleno o la textura de relleno. Completamente opaco es 1.0.

Valores devueltos

La opacidad.


Devuelve la regla de relleno

  • « ImagickDraw::getFillOpacity
  • ImagickDraw::getFont »
  • PHP Manual
  • ImagickDraw
  • Devuelve la regla de relleno

ImagickDraw::getFillRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillRule — Devuelve la regla de relleno

Descripción

ImagickDraw::getFillRule ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la regla de relleno usada mientras se dibujan polígonos.

Valores devueltos

Devuelve una constante FILLRULE_


Devuelve la fuente

  • « ImagickDraw::getFillRule
  • ImagickDraw::getFontFamily »
  • PHP Manual
  • ImagickDraw
  • Devuelve la fuente

ImagickDraw::getFont

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFont — Devuelve la fuente

Descripción

ImagickDraw::getFont ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un string especificando la fuente usada cuando se escribe texto.

Valores devueltos

Devuelve un string si se tuvo éxito o false si no está establecida la fuente.


Devuelve la familia de la fuente

  • « ImagickDraw::getFont
  • ImagickDraw::getFontSize »
  • PHP Manual
  • ImagickDraw
  • Devuelve la familia de la fuente

ImagickDraw::getFontFamily

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontFamily — Devuelve la familia de la fuente

Descripción

ImagickDraw::getFontFamily ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la familia de la fuente usada cuando se escribe texto.

Valores devueltos

Devuelve la familia de la fuente seleccionada actualmente o false si no está establecida la familia de la fuente.


Devuelve el tamaño de punto de la fuente

  • « ImagickDraw::getFontFamily
  • ImagickDraw::getFontStretch »
  • PHP Manual
  • ImagickDraw
  • Devuelve el tamaño de punto de la fuente

ImagickDraw::getFontSize

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontSize — Devuelve el tamaño de punto de la fuente

Descripción

ImagickDraw::getFontSize ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el tamaño de punto de la fuente usado cuando se escribe texto.

Valores devueltos

Devuelve el tamaño de punto de la fuente asociada al objeto ImagickDraw actual.


Description

  • « ImagickDraw::getFontSize
  • ImagickDraw::getFontStyle »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getFontStretch

(PECL imagick 2 >=2.3.0, PECL imagick 3)

ImagickDraw::getFontStretch — Description

Descripción

public ImagickDraw::getFontStretch ( ) : int

Obtiene el elongamiento de la fuente a usar cuando se escribe texto. Devuelve un objeto StretchType.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Devuelve el estilo de fuente

  • « ImagickDraw::getFontStretch
  • ImagickDraw::getFontWeight »
  • PHP Manual
  • ImagickDraw
  • Devuelve el estilo de fuente

ImagickDraw::getFontStyle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontStyle — Devuelve el estilo de fuente

Descripción

ImagickDraw::getFontStyle ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el estilo de fuente usado cuando se escribe texto.

Valores devueltos

Devuelve la constante de estilo de fuente (STYLE_) asociada al objeto ImagickDraw o 0 si no está establecido ningún estilo.


Devuelve el peso de la fuente

  • « ImagickDraw::getFontStyle
  • ImagickDraw::getGravity »
  • PHP Manual
  • ImagickDraw
  • Devuelve el peso de la fuente

ImagickDraw::getFontWeight

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontWeight — Devuelve el peso de la fuente

Descripción

ImagickDraw::getFontWeight ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el peso de la fuente usada cuando se escribe texto.

Valores devueltos

Devuelve un integer si se tuvo éxito o 0 si no está estabecido ningún peso.


Devuelve la gravedad de emplazamiento del texto

  • « ImagickDraw::getFontWeight
  • ImagickDraw::getStrokeAntialias »
  • PHP Manual
  • ImagickDraw
  • Devuelve la gravedad de emplazamiento del texto

ImagickDraw::getGravity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getGravity — Devuelve la gravedad de emplazamiento del texto

Descripción

ImagickDraw::getGravity ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la gravedad de emplazamiento del texto usada cuando se escribe texto.

Valores devueltos

Devuelve una constante GRAVITY_ si se tuvo éxito y 0 si no está establecida la gravedad.


Devuelve la configuración de antialias de contorno actual

  • « ImagickDraw::getGravity
  • ImagickDraw::getStrokeColor »
  • PHP Manual
  • ImagickDraw
  • Devuelve la configuración de antialias de contorno actual

ImagickDraw::getStrokeAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeAntialias — Devuelve la configuración de antialias de contorno actual

Descripción

ImagickDraw::getStrokeAntialias ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la configuración antialias de contorno actual. Los perfiles contorneados tienen antialias por defecto. Cuando se deshabilita el antialias, los píxeles contorneados son puestos en el umbral para determinar si se debería usar el color de contorno o el color del lienzo subyacente.

Valores devueltos

Devuelve true si el antialias está on y false si está off.


Devuelve el color usado por los perfiles de objetos contorneados

  • « ImagickDraw::getStrokeAntialias
  • ImagickDraw::getStrokeDashArray »
  • PHP Manual
  • ImagickDraw
  • Devuelve el color usado por los perfiles de objetos contorneados

ImagickDraw::getStrokeColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeColor — Devuelve el color usado por los perfiles de objetos contorneados

Descripción

ImagickDraw::getStrokeColor ( ) : ImagickPixel
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el color usado por los perfiles de objetos contorneados.

Parámetros

stroke_color

Valores devueltos

Devuelve un objeto ImagickPixel que describe el color.


Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados

  • « ImagickDraw::getStrokeColor
  • ImagickDraw::getStrokeDashOffset »
  • PHP Manual
  • ImagickDraw
  • Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados

ImagickDraw::getStrokeDashArray

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeDashArray — Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados

Descripción

ImagickDraw::getStrokeDashArray ( ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados.

Valores devueltos

Devuelve un array si se tuvo éxito y un array vacío si no está establecido.


Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

  • « ImagickDraw::getStrokeDashArray
  • ImagickDraw::getStrokeLineCap »
  • PHP Manual
  • ImagickDraw
  • Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

ImagickDraw::getStrokeDashOffset

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeDashOffset — Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

Descripción

ImagickDraw::getStrokeDashOffset ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad.

Valores devueltos

Devuelve un float que representa el índice y 0 si no está establecido.


Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

  • « ImagickDraw::getStrokeDashOffset
  • ImagickDraw::getStrokeLineJoin »
  • PHP Manual
  • ImagickDraw
  • Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

ImagickDraw::getStrokeLineCap

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeLineCap — Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

Descripción

ImagickDraw::getStrokeLineCap ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados.

Valores devueltos

Devuelve una de las constantes LINECAP_ o 0 si el cierre de línea de contorno no está establecido.


Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados

  • « ImagickDraw::getStrokeLineCap
  • ImagickDraw::getStrokeMiterLimit »
  • PHP Manual
  • ImagickDraw
  • Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados

ImagickDraw::getStrokeLineJoin

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeLineJoin — Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados

Descripción

ImagickDraw::getStrokeLineJoin ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la forma que se va a usar en las esquinas de los trazados (u otras formas vectoriales) cuando están contorneados.

Valores devueltos

Devuelve una de las constantes LINEJOIN_ o 0 si la junta de líneas de contorno no está establecida.


Devuelve el límite del inglete del contorno

  • « ImagickDraw::getStrokeLineJoin
  • ImagickDraw::getStrokeOpacity »
  • PHP Manual
  • ImagickDraw
  • Devuelve el límite del inglete del contorno

ImagickDraw::getStrokeMiterLimit

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeMiterLimit — Devuelve el límite del inglete del contorno

Descripción

ImagickDraw::getStrokeMiterLimit ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el límite del inglete del contorno. Cuando dos segmentos de línea se encuentran en un águlo agudo y la unión del inglete ha sido especificada para 'lineJoin', es posible que el inglete se extienda más allá del grosor de la línea que contornea el trazado. 'miterLimit' impone un límite en la proporción de la longitud del inglete a 'lineWidth'.

Valores devueltos

Devuelve un integer que describe el límite del inglete y 0 si no está establecido el límite del inglete.


Devuelve la opacidad del perfil de objetos contorneados

  • « ImagickDraw::getStrokeMiterLimit
  • ImagickDraw::getStrokeWidth »
  • PHP Manual
  • ImagickDraw
  • Devuelve la opacidad del perfil de objetos contorneados

ImagickDraw::getStrokeOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeOpacity — Devuelve la opacidad del perfil de objetos contorneados

Descripción

ImagickDraw::getStrokeOpacity ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la opacidad del perfil de objetos contorneados.

Valores devueltos

Devuelve float que describe la opacidad.


Devuelve al ancho del contorno usado para dibujar contornos de objetos

  • « ImagickDraw::getStrokeOpacity
  • ImagickDraw::getTextAlignment »
  • PHP Manual
  • ImagickDraw
  • Devuelve al ancho del contorno usado para dibujar contornos de objetos

ImagickDraw::getStrokeWidth

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeWidth — Devuelve al ancho del contorno usado para dibujar contornos de objetos

Descripción

ImagickDraw::getStrokeWidth ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve al ancho del contorno usado para dibujar contornos de objetos.

Valores devueltos

Devuelve un float que describe el ancho del contorno.


Devuelve la alineación del texto

  • « ImagickDraw::getStrokeWidth
  • ImagickDraw::getTextAntialias »
  • PHP Manual
  • ImagickDraw
  • Devuelve la alineación del texto

ImagickDraw::getTextAlignment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextAlignment — Devuelve la alineación del texto

Descripción

ImagickDraw::getTextAlignment ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la alineación aplicada cuando se escribe texto.

Valores devueltos

Devuelve una de las constantes ALIGN_ y 0 si no está establecida la alineación.


Devuelve la configuración de antialias del texto actual

  • « ImagickDraw::getTextAlignment
  • ImagickDraw::getTextDecoration »
  • PHP Manual
  • ImagickDraw
  • Devuelve la configuración de antialias del texto actual

ImagickDraw::getTextAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextAntialias — Devuelve la configuración de antialias del texto actual

Descripción

ImagickDraw::getTextAntialias ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la configuración de antialias del texto actual, que determina si el texto tiene antialias o no. El texto tiene antialias por defecto.

Valores devueltos

Devuelve true si el texto tiene antialias y false si no.


Devuelve la decoración del texto

  • « ImagickDraw::getTextAntialias
  • ImagickDraw::getTextEncoding »
  • PHP Manual
  • ImagickDraw
  • Devuelve la decoración del texto

ImagickDraw::getTextDecoration

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextDecoration — Devuelve la decoración del texto

Descripción

ImagickDraw::getTextDecoration ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la decoración aplicada cuando se escribe texto.

Valores devueltos

Devuelve una de las constantes DECORATION_ y 0 si no está establecida la decoración.


Devuelve la codificación usada para anotaciones de texto

  • « ImagickDraw::getTextDecoration
  • ImagickDraw::getTextInterlineSpacing »
  • PHP Manual
  • ImagickDraw
  • Devuelve la codificación usada para anotaciones de texto

ImagickDraw::getTextEncoding

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextEncoding — Devuelve la codificación usada para anotaciones de texto

Descripción

ImagickDraw::getTextEncoding ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un string que especifica la codificación usada para anotaciones de texto.

Valores devueltos

Devuelve un string que especifica la codificación o false si la codificación de texto no está establecida.


Description

  • « ImagickDraw::getTextEncoding
  • ImagickDraw::getTextInterwordSpacing »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextInterlineSpacing

(PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextInterlineSpacing — Description

Descripción

public ImagickDraw::getTextInterlineSpacing ( ) : float

Obtiene el espaciado entre líneas del texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « ImagickDraw::getTextInterlineSpacing
  • ImagickDraw::getTextKerning »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextInterwordSpacing

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextInterwordSpacing — Description

Descripción

public ImagickDraw::getTextInterwordSpacing ( ) : float

Obtiene el espaciado entre palabras del texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « ImagickDraw::getTextInterwordSpacing
  • ImagickDraw::getTextUnderColor »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextKerning

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextKerning — Description

Descripción

public ImagickDraw::getTextKerning ( ) : float

Obtiene el interletraje («kerning») del texto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Devuelve el color debajo del texto

  • « ImagickDraw::getTextKerning
  • ImagickDraw::getVectorGraphics »
  • PHP Manual
  • ImagickDraw
  • Devuelve el color debajo del texto

ImagickDraw::getTextUnderColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextUnderColor — Devuelve el color debajo del texto

Descripción

ImagickDraw::getTextUnderColor ( ) : ImagickPixel
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el color de un rectángulo de fondo para colocar bajo anotaciones de texto.

Valores devueltos

Devuelve un objeto ImagickPixel que describe el color.


Devuelve una cadena que contiene gráficos vectoriales

  • « ImagickDraw::getTextUnderColor
  • ImagickDraw::line »
  • PHP Manual
  • ImagickDraw
  • Devuelve una cadena que contiene gráficos vectoriales

ImagickDraw::getVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getVectorGraphics — Devuelve una cadena que contiene gráficos vectoriales

Descripción

ImagickDraw::getVectorGraphics ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un string que especifica los gráficos vectoriales generados por cualquier llamada a gráficos hecha desde que el objeto ImagickDraw fue instanciado.

Valores devueltos

Devuelve un string que contiene los gráficos vectoriales.


Dibuja una línea

  • « ImagickDraw::getVectorGraphics
  • ImagickDraw::matte »
  • PHP Manual
  • ImagickDraw
  • Dibuja una línea

ImagickDraw::line

(PECL imagick 2, PECL imagick 3)

ImagickDraw::line — Dibuja una línea

Descripción

ImagickDraw::line ( float $sx , float $sy , float $ex , float $ey ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una línea en la imagen usando el color de contorno actual, la opacidad de contorno, y el ancho de contorno.

Parámetros

sx

coordenada x de inicio

sy

coordenada y de inicio

ex

coordenada x final

ey

coordenada y final

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::line()

<?php
function line($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->line(125, 70, 100, 50);
    $draw->line(350, 170, 100, 150);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Pinta sobre el canal de opacidad de la imagen

  • « ImagickDraw::line
  • ImagickDraw::pathClose »
  • PHP Manual
  • ImagickDraw
  • Pinta sobre el canal de opacidad de la imagen

ImagickDraw::matte

(PECL imagick 2, PECL imagick 3)

ImagickDraw::matte — Pinta sobre el canal de opacidad de la imagen

Descripción

ImagickDraw::matte ( float $x , float $y , int $paintMethod ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Pinta sobre el canal de opacidad de la imagen para establecer los píxeles afectados a transparentes, para influir en la opacidad de los píxeles.

Parámetros

x

coordenada x del mate

y

coordenada y del mate

paintMethod

constante PAINT_

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ImagickDraw::matte()

<?php
function matte($strokeColor, $fillColor, $backgroundColor, $paintType) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->matte(120, 120, $paintType);
    $draw->rectangle(100, 100, 300, 200);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Añade un elemento de trazado al trazado actual

  • « ImagickDraw::matte
  • ImagickDraw::pathCurveToAbsolute »
  • PHP Manual
  • ImagickDraw
  • Añade un elemento de trazado al trazado actual

ImagickDraw::pathClose

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathClose — Añade un elemento de trazado al trazado actual

Descripción

ImagickDraw::pathClose ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Añade un elemento de trazado al trazado actual el cuál cierra el subtrazado actual dibujando una línea recta desde el punto actual hasta el punto de inicio del subtrazado actual más reciente (normalmente el punto más actual del movimiento).

Valores devueltos

No devuelve ningún valor.


Dibuja una curva cúbica de Bézier

  • « ImagickDraw::pathClose
  • ImagickDraw::pathCurveToQuadraticBezierAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva cúbica de Bézier

ImagickDraw::pathCurveToAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToAbsolute — Dibuja una curva cúbica de Bézier

Descripción

ImagickDraw::pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva cúbica de Bézier desde el punto actual a (x,y) usando (x1,y1) como punto de control en el inicio de la curva y (x2,y2) como punto de control en el final de la curva, usando coordenadas absolutas. Al final del comando, el nuevo punto actual se convierte en el par de coordenadas (x,y) usado en el Bezígono.

Parámetros

x1

coordenada x del primer punto de control

y1

coordenada y del primer punto de control

x2

coordenada x del segundo punto de control

y2

coordenada y del segundo punto de control

x

coordenada x del final de la curva

y

coordenada y del final de la curva

Valores devueltos

No devuelve ningún valor.


Dibuja una curva Bézier cuadrática

  • « ImagickDraw::pathCurveToAbsolute
  • ImagickDraw::pathCurveToQuadraticBezierRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva Bézier cuadrática

ImagickDraw::pathCurveToQuadraticBezierAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierAbsolute — Dibuja una curva Bézier cuadrática

Descripción

ImagickDraw::pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva Bézier cuadrática desde el punto actual a (x,y) usando (x1,y1) como el punto de control utilizando coordenadas absolutas. Al final del comando, el nuevo punto actual se convierte en el par de coordenadas (x,y) usado en el Bezígono.

Parámetros

x1

coordenada x del punto de control

y1

coordenada y del punto de control

x

coordenada x del punto final

y

coordenada y del punto final

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::pathCurveToQuadraticBezierAbsolute()

<?php
function pathCurveToQuadraticBezierAbsolute($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50,250);

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is the first two params, and the end point is the last two params.
    $draw->pathCurveToQuadraticBezierAbsolute(
        150,50,
        250,250
    );

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is mirrored from the previous curves control point
    // and the end point is defined by the x, y values.
    $draw->pathCurveToQuadraticBezierSmoothAbsolute(
        450,250
    );

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is mirrored from the previous curves control point
    // and the end point is defined relative from the current position by the x, y values.
    $draw->pathCurveToQuadraticBezierSmoothRelative(
        200,-100
    );

    $draw->pathFinish();

    $imagick = new \Imagick();
    $imagick->newImage(700, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();

}

?>


Dibuja una curva Bézier cuadrática

  • « ImagickDraw::pathCurveToQuadraticBezierAbsolute
  • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva Bézier cuadrática

ImagickDraw::pathCurveToQuadraticBezierRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierRelative — Dibuja una curva Bézier cuadrática

Descripción

ImagickDraw::pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva Bézier cuadrática desde el punto actual a (x,y) usando (x1,y1) como el punto de control utilizando coordenadas relativas. Al final del comando, el nuevo punto actual se convierte en el par de coordenadas (x,y) usado en el Bezígono.

Parámetros

x1

coordenada x de inicio

y1

coordenada y de inicio

x

coordenada x final

y

coordenada y final

Valores devueltos

No devuelve ningún valor.


Dibuja una curva Bézier cuadrática

  • « ImagickDraw::pathCurveToQuadraticBezierRelative
  • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva Bézier cuadrática

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Dibuja una curva Bézier cuadrática

Descripción

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y ) : bool

Dibuja una curva Bézier cuadrática (usando coordenadas absolutas) desde el punto actual a (x, y). Se asume que el punto de control es la refelxión del punto de control del comando previo relativo al punto actual. (Si no hay comando previo o el comando previo no es DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut o DrawPathCurveToQuadraticBezierSmoothRelative, se asume que el punto de control coincide con el punto actual). Al final del comando, el nuevo punto actual se convierte en el par de coordenadas final (x, y) usado en el Bezígono.

Esta función no se puede utilizar para continuar de forma suave una curva Bézier cúbica. Solamente puede continuarse suavemente desde una curva cuadrática.

Parámetros

x

coordenada x final

y

coordenada y final

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute()

<?php
$draw = new \ImagickDraw();

$draw->setStrokeOpacity(1);
$draw->setStrokeColor("black");
$draw->setFillColor("blue");

$draw->setStrokeWidth(2);
$draw->setFontSize(72);

$draw->pathStart();
$draw->pathMoveToAbsolute(50,250);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is the first two params, and the end point is the last two params.
$draw->pathCurveToQuadraticBezierAbsolute(
    150,50,
    250,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothAbsolute(
    450,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined relative from the current position by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothRelative(
    200,-100
);

$draw->pathFinish();

$imagick = new \Imagick();
$imagick->newImage(700, 500, $backgroundColor);
$imagick->setImageFormat("png");

$imagick->drawImage($draw);

header("Content-Type: image/png");
echo $imagick->getImageBlob();
?>


Dibuja una curva Bézier cuadrática

  • « ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
  • ImagickDraw::pathCurveToRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva Bézier cuadrática

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Dibuja una curva Bézier cuadrática

Descripción

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva Bézier cuadrática (usando coordenadas relativas) desde el punto actual a (x, y). Se asume que el punto de control es la refelxión del punto de control del comando previo relativo al punto actual. (Si no hay comando previo o el comando previo no es DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut o DrawPathCurveToQuadraticBezierSmoothRelative, se asume que el punto de control coincide con el punto actual). Al final del comando, el nuevo punto actual se convierte en el par de coordenadas final (x, y) usado en el Bezígono.

Esta función no se puede utilizar para continuar de forma suave una curva Bézier cúbica. Solamente puede continuarse suavemente desde una curva cuadrática.

Parámetros

x

coordenada x final

y

coordenada y final

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::pathCurveToQuadraticBezierSmoothRelative()

<?php
$draw = new \ImagickDraw();

$draw->setStrokeOpacity(1);
$draw->setStrokeColor("black");
$draw->setFillColor("blue");

$draw->setStrokeWidth(2);
$draw->setFontSize(72);

$draw->pathStart();
$draw->pathMoveToAbsolute(50,250);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is the first two params, and the end point is the last two params.
$draw->pathCurveToQuadraticBezierAbsolute(
    150,50,
    250,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothAbsolute(
    450,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined relative from the current position by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothRelative(
    200,-100
);

$draw->pathFinish();

$imagick = new \Imagick();
$imagick->newImage(700, 500, $backgroundColor);
$imagick->setImageFormat("png");

$imagick->drawImage($draw);

header("Content-Type: image/png");
echo $imagick->getImageBlob();
?>


Dibuja una curva cúbica de Bézier

  • « ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
  • ImagickDraw::pathCurveToSmoothAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva cúbica de Bézier

ImagickDraw::pathCurveToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToRelative — Dibuja una curva cúbica de Bézier

Descripción

ImagickDraw::pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva cúbica de Bézier desde el punto actual a (x,y) usando (x1,y1) como punto de control en el inicio de la curva y (x2,y2) como punto de control en el final de la curva, usando coordenadas relativas. Al final del comando, el nuevo punto actual se convierte en el par de coordenadas (x,y) usado en el Bezígono.

Parámetros

x1

coordenada x del punto de control inicial

y1

coordenada y del punto de control inicial

x2

coordenada x del punto de control final

y2

coordenada y del punto de control final

x

coordenada x final

y

coordenada y final

Valores devueltos

No devuelve ningún valor.


Dibuja una curva cúbica de Bézier

  • « ImagickDraw::pathCurveToRelative
  • ImagickDraw::pathCurveToSmoothRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva cúbica de Bézier

ImagickDraw::pathCurveToSmoothAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToSmoothAbsolute — Dibuja una curva cúbica de Bézier

Descripción

ImagickDraw::pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva cúbica de Bézier desde el punto actual a (x,y) usando coordenadas absolutas. Se asume que el primer punto de control es la reflexión del segundo punto de control del comando anterior relativo a punto actual. (Si no hay comando previo o el comando previo no es DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute o DrawPathCurveToSmoothRelative, se asume que el primer punto de control coincide con el punto actual.) (x2,y2) es el segundo punto de control (es decir, el punto de control al final de la curva). Al final del comando, el nuevo punto actual se convierte en el par de coordenadas final (x, y) usado en el Bezígono.

Parámetros

x2

coordenada x del segundo punto de control

y2

coordenada y del segundo punto de control

x

coordenada x del punto final

y

coordenada y del punto final

Valores devueltos

No devuelve ningún valor.


Dibuja una curva cúbica de Bézier

  • « ImagickDraw::pathCurveToSmoothAbsolute
  • ImagickDraw::pathEllipticArcAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja una curva cúbica de Bézier

ImagickDraw::pathCurveToSmoothRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToSmoothRelative — Dibuja una curva cúbica de Bézier

Descripción

ImagickDraw::pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una curva cúbica de Bézier desde el punto actual a (x,y) usando coordenadas relativas. Se asume que el primer punto de control es la reflexión del segundo punto de control del comando anterior relativo a punto actual. (Si no hay comando previo o el comando previo no es DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute o DrawPathCurveToSmoothRelative, se asume que el primer punto de control coincide con el punto actual.) (x2,y2) es el segundo punto de control (es decir, el punto de control al final de la curva). Al final del comando, el nuevo punto actual se convierte en el par de coordenadas final (x, y) usado en el Bezígono.

Parámetros

x2

coordenada x del segundo punto de control

y2

coordenada y del segundo punto de control

x

coordenada x del punto final

y

coordenada y del punto final

Valores devueltos

No devuelve ningún valor.


Dibuja un arco elíptico

  • « ImagickDraw::pathCurveToSmoothRelative
  • ImagickDraw::pathEllipticArcRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja un arco elíptico

ImagickDraw::pathEllipticArcAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathEllipticArcAbsolute — Dibuja un arco elíptico

Descripción

ImagickDraw::pathEllipticArcAbsolute ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un arco elíptico desde el punto actual a (x, y) usando coordenadas absolutas. El tamaño y la orientación de la elipse están definidos por dos radios (rx, ry) y xAxisRotation, que indica cómo rota la elipse completa en relación al sistema de coordenadas actual. El centro (cx, cy) de la elipse se calcula automáticamente para satisfacer las limitaciones impuestas por otros parámetros. largeArcFlag y sweepFlag contribuyen al cálculo automático y ayudan a determinar cómo se dibuja el arco. Si largeArcFlag es true entonces se dibuja el arco más largo disponible. Si sweepFlag es true, entonces se dibuja el arco que coincida con una rotación en sentido de las agujas del reloj.

Parámetros

rx

radio x

ry

radio y

x_axis_rotation

eje de rotación x

large_arc_flag

bandera de arco largo

sweep_flag

bandera de barrido

x

coordenada x

y

coordenada y

Valores devueltos

No devuelve ningún valor.


Dibuja un arco elíptico

  • « ImagickDraw::pathEllipticArcAbsolute
  • ImagickDraw::pathFinish »
  • PHP Manual
  • ImagickDraw
  • Dibuja un arco elíptico

ImagickDraw::pathEllipticArcRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathEllipticArcRelative — Dibuja un arco elíptico

Descripción

ImagickDraw::pathEllipticArcRelative ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un arco elíptico desde el punto actual a (x, y) usando coordenadas relativas. El tamaño y la orientación de la elipse están definidos por dos radios (rx, ry) y xAxisRotation, que indica cómo rota la elipse completa en relación al sistema de coordenadas actual. El centro (cx, cy) de la elipse se calcula automáticamente para satisfacer las limitaciones impuestas por otros parámetros. largeArcFlag y sweepFlag contribuyen al cálculo automático y ayudan a determinar cómo se dibuja el arco. Si largeArcFlag es true entonces se dibuja el arco más largo disponible. Si sweepFlag es true, entonces se dibuja el arco que coincida con una rotación en sentido de las agujas del reloj.

Parámetros

rx

radio x

ry

radio y

x_axis_rotation

eje de rotación x

large_arc_flag

bandera de arco largo

sweep_flag

bandera de barrido

x

coordenada x

y

coordenada y

Valores devueltos

No devuelve ningún valor.


Finaliza el trazado actual

  • « ImagickDraw::pathEllipticArcRelative
  • ImagickDraw::pathLineToAbsolute »
  • PHP Manual
  • ImagickDraw
  • Finaliza el trazado actual

ImagickDraw::pathFinish

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathFinish — Finaliza el trazado actual

Descripción

ImagickDraw::pathFinish ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Finaliza el trazado actual.

Valores devueltos

No devuelve ningún valor.


Dibuja un trazado de línea

  • « ImagickDraw::pathFinish
  • ImagickDraw::pathLineToHorizontalAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja un trazado de línea

ImagickDraw::pathLineToAbsolute

(PECL imagick 2)

ImagickDraw::pathLineToAbsolute — Dibuja un trazado de línea

Descripción

ImagickDraw::pathLineToAbsolute ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea desde el punto actual a las coordenadas dadas usando coordenadas absolutas. Las coordenadas entonces se convierten en el nuevo punto actual.

Parámetros

x

coordenada x de inicio

y

coordenada y de inicio

Valores devueltos

No devuelve ningún valor.


Dibuja un trazado de línea horizontal

  • « ImagickDraw::pathLineToAbsolute
  • ImagickDraw::pathLineToHorizontalRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja un trazado de línea horizontal

ImagickDraw::pathLineToHorizontalAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToHorizontalAbsolute — Dibuja un trazado de línea horizontal

Descripción

ImagickDraw::pathLineToHorizontalAbsolute ( float $x ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea horizontal desde el punto actual al punto objetivo usando coordenadas absolutas. El punto objetivo entonces se convierte en el nuevo punto actual.

Parámetros

x

coordenada x

Valores devueltos

No devuelve ningún valor.


Dibuja una línea horizontal

  • « ImagickDraw::pathLineToHorizontalAbsolute
  • ImagickDraw::pathLineToRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja una línea horizontal

ImagickDraw::pathLineToHorizontalRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToHorizontalRelative — Dibuja una línea horizontal

Descripción

ImagickDraw::pathLineToHorizontalRelative ( float $x ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea horizontal desde el punto actual al punto objetivo usando coordenadas relativas. El punto objetivo entonces se convierte en el nuevo punto actual.

Parámetros

x

coordenada x

Valores devueltos

No devuelve ningún valor.


Dibuja un trazado de línea

  • « ImagickDraw::pathLineToHorizontalRelative
  • ImagickDraw::pathLineToVerticalAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja un trazado de línea

ImagickDraw::pathLineToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToRelative — Dibuja un trazado de línea

Descripción

ImagickDraw::pathLineToRelative ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea desde el punto actual a las coordenadas dadas usando coordenadas relativas. Las coordenadas entonces se convierten en el nuevo punto actual.

Parámetros

x

coordenada x de inicio

y

coordenada y de inicio

Valores devueltos

No devuelve ningún valor.


Dibuja un línea vertical

  • « ImagickDraw::pathLineToRelative
  • ImagickDraw::pathLineToVerticalRelative »
  • PHP Manual
  • ImagickDraw
  • Dibuja un línea vertical

ImagickDraw::pathLineToVerticalAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToVerticalAbsolute — Dibuja un línea vertical

Descripción

ImagickDraw::pathLineToVerticalAbsolute ( float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea vertical desde el punto actual al punto objetivo usando coordenadas absolutas. El punto objetivo entonces se convierte en el nuevo punto actual.

Parámetros

y

coordenada y

Valores devueltos

No devuelve ningún valor.


Dibuja un trazado de línea vertical

  • « ImagickDraw::pathLineToVerticalAbsolute
  • ImagickDraw::pathMoveToAbsolute »
  • PHP Manual
  • ImagickDraw
  • Dibuja un trazado de línea vertical

ImagickDraw::pathLineToVerticalRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToVerticalRelative — Dibuja un trazado de línea vertical

Descripción

ImagickDraw::pathLineToVerticalRelative ( float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un trazado de línea vertical desde el punto actual al punto objetivo usando coordenadas relativas. El punto objetivo entonces se convierte en el nuevo punto actual.

Parámetros

y

coordenada y

Valores devueltos

No devuelve ningún valor.


Inicia un nuevo sub-trazado

  • « ImagickDraw::pathLineToVerticalRelative
  • ImagickDraw::pathMoveToRelative »
  • PHP Manual
  • ImagickDraw
  • Inicia un nuevo sub-trazado

ImagickDraw::pathMoveToAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathMoveToAbsolute — Inicia un nuevo sub-trazado

Descripción

ImagickDraw::pathMoveToAbsolute ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Inicia un nuevo sub-trazado en las coordenadas dadas usando coordenadas absolutas. El punto actual entonces se convierte en las coordenadas especificadas.

Parámetros

x

coordenada x del punto de inicio

y

coordenada y del punto de inicio

Valores devueltos

No devuelve ningún valor.


Inicia un nuevo sub-trazado

  • « ImagickDraw::pathMoveToAbsolute
  • ImagickDraw::pathStart »
  • PHP Manual
  • ImagickDraw
  • Inicia un nuevo sub-trazado

ImagickDraw::pathMoveToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathMoveToRelative — Inicia un nuevo sub-trazado

Descripción

ImagickDraw::pathMoveToRelative ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Inicia un nuevo sub-trazado en las coordenadas dadas usando coordenadas relativas. El punto actual entonces se convierte en las coordenadas especificadas.

Parámetros

x

coordenada x del objetivo

y

coordenada y del objetivo

Valores devueltos

No devuelve ningún valor.


Declara el inicio de una lista de dibujo de trazados

  • « ImagickDraw::pathMoveToRelative
  • ImagickDraw::point »
  • PHP Manual
  • ImagickDraw
  • Declara el inicio de una lista de dibujo de trazados

ImagickDraw::pathStart

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathStart — Declara el inicio de una lista de dibujo de trazados

Descripción

ImagickDraw::pathStart ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Declara el inicio de una lista de dibujo de trazados que finaliza con un comando DrawPathFinish() coincidente. Todos los demás comandos DrawPath deben estar encerrados entre comandos DrawPathFinish(). Ésto es debido a que los comandos de dibujo de trazados son comandos subordinados y no funcionan por sí mismos.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::pathStart()

<?php
function pathStart($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 50);
    $draw->pathLineToAbsolute(100, 50);
    $draw->pathLineToRelative(0, 50);
    $draw->pathLineToHorizontalRelative(-50);
    $draw->pathFinish();

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 50);
    $draw->pathMoveToRelative(300, 0);
    $draw->pathLineToRelative(50, 0);
    $draw->pathLineToVerticalRelative(50);
    $draw->pathLineToHorizontalAbsolute(350);
    $draw->pathclose();
    $draw->pathFinish();

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 300);
    $draw->pathCurveToAbsolute(50, 300, 100, 200, 300, 300);
    $draw->pathLineToVerticalAbsolute(350);
    $draw->pathFinish();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Dibuja un punto

  • « ImagickDraw::pathStart
  • ImagickDraw::polygon »
  • PHP Manual
  • ImagickDraw
  • Dibuja un punto

ImagickDraw::point

(PECL imagick 2, PECL imagick 3)

ImagickDraw::point — Dibuja un punto

Descripción

ImagickDraw::point ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un punto usando el color del contorno y el grosor del contorno en las coordenadas especificadas.

Parámetros

x

coordenada x del punto

y

coordenada y del punto

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::point()

<?php
function point($fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setFillColor($fillColor);

    for ($x = 0; $x < 10000; $x++) {
        $draw->point(rand(0, 500), rand(0, 500));
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Dibuja un polígono

  • « ImagickDraw::point
  • ImagickDraw::polyline »
  • PHP Manual
  • ImagickDraw
  • Dibuja un polígono

ImagickDraw::polygon

(PECL imagick 2, PECL imagick 3)

ImagickDraw::polygon — Dibuja un polígono

Descripción

ImagickDraw::polygon ( array $coordinates ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un polígono usando el contorno, el ancho del contorno, y el color de relleno o de la textura actuales, usando el array de coordenadas especificado.

Parámetros

coordinates

array multidimensional como array( array( 'x' => 3, 'y' => 4 ), array( 'x' => 2, 'y' => 6 ) );

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::polygon()

<?php
function polygon($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(4);

    $draw->setFillColor($fillColor);

    $points = [
        ['x' => 40 * 5, 'y' => 10 * 5],
        ['x' => 20 * 5, 'y' => 20 * 5],
        ['x' => 70 * 5, 'y' => 50 * 5],
        ['x' => 60 * 5, 'y' => 15 * 5],
    ];

    $draw->polygon($points);

    $image = new \Imagick();
    $image->newImage(500, 300, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Dibuja una poli-línea

  • « ImagickDraw::polygon
  • ImagickDraw::pop »
  • PHP Manual
  • ImagickDraw
  • Dibuja una poli-línea

ImagickDraw::polyline

(PECL imagick 2, PECL imagick 3)

ImagickDraw::polyline — Dibuja una poli-línea

Descripción

ImagickDraw::polyline ( array $coordinates ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja una poli-línea usando el contorno, el ancho del contorno, y el color de relleno o de la textura actuales, usando el array de coordenadas especificado.

Parámetros

coordinates

array de coordenadas x e y: array( array( 'x' => 4, 'y' => 6 ), array( 'x' => 8, 'y' => 10 ) )

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::polyline()

<?php
function polyline($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(5);

    $points = [
        ['x' => 40 * 5, 'y' => 10 * 5],
        ['x' => 20 * 5, 'y' => 20 * 5],
        ['x' => 70 * 5, 'y' => 50 * 5],
        ['x' => 60 * 5, 'y' => 15 * 5]
    ];

    $draw->polyline($points);

    $image = new \Imagick();
    $image->newImage(500, 300, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido

  • « ImagickDraw::polyline
  • ImagickDraw::popClipPath »
  • PHP Manual
  • ImagickDraw
  • Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido

ImagickDraw::pop

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pop — Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido

Descripción

ImagickDraw::pop ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido. Pueden existir mútiples objetos ImagickDraw. Es un error intentar sacar más objetos ImagickDraw de los que se han metido, y es una forma apropiada sacar todos los objetos ImagickDraw que han sido metidos.

Valores devueltos

Devuelve true si se tuvo éxito y false si falló.


Finaliza una definición de un trazado de recorte

  • « ImagickDraw::pop
  • ImagickDraw::popDefs »
  • PHP Manual
  • ImagickDraw
  • Finaliza una definición de un trazado de recorte

ImagickDraw::popClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popClipPath — Finaliza una definición de un trazado de recorte

Descripción

ImagickDraw::popClipPath ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Finaliza una definición de un trazado de recorte.

Valores devueltos

No devuelve ningún valor.


Finaliza una lista de definiciones

  • « ImagickDraw::popClipPath
  • ImagickDraw::popPattern »
  • PHP Manual
  • ImagickDraw
  • Finaliza una lista de definiciones

ImagickDraw::popDefs

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popDefs — Finaliza una lista de definiciones

Descripción

ImagickDraw::popDefs ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Finaliza una lista de definiciones.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::popDefs()

<?php
function popDefs($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setstrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->pushDefs();
    $draw->setStrokeColor('white');
    $draw->rectangle(50, 50, 200, 200);
    $draw->popDefs();

    $draw->rectangle(300, 50, 450, 200);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Finaliza una definición de patrón

  • « ImagickDraw::popDefs
  • ImagickDraw::push »
  • PHP Manual
  • ImagickDraw
  • Finaliza una definición de patrón

ImagickDraw::popPattern

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popPattern — Finaliza una definición de patrón

Descripción

ImagickDraw::popPattern ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Finaliza una definición de patrón.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Clona el objeto ImagickDraw actual y lo mete en la pila

  • « ImagickDraw::popPattern
  • ImagickDraw::pushClipPath »
  • PHP Manual
  • ImagickDraw
  • Clona el objeto ImagickDraw actual y lo mete en la pila

ImagickDraw::push

(PECL imagick 2, PECL imagick 3)

ImagickDraw::push — Clona el objeto ImagickDraw actual y lo mete en la pila

Descripción

ImagickDraw::push ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Clona el objeto ImagickDraw actual para crear un nuevo objeto ImagickDraw, que es añadido a la pila de ImagickDraw. Los objetos de dibujo ImagickDraw originales pueden ser devueltos invocando a pop(). Los objetos ImagickDraw son almacenados en una pila ImagickDraw. Por cada Pop debe haber habido un Push equivalente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ImagickDraw::push()

<?php
function push($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillModifiedColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->push();
    $draw->translate(50, 50);
    $draw->rectangle(200, 200, 300, 300);
    $draw->pop();
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Inicia la definición de un trazado de recorte

  • « ImagickDraw::push
  • ImagickDraw::pushDefs »
  • PHP Manual
  • ImagickDraw
  • Inicia la definición de un trazado de recorte

ImagickDraw::pushClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushClipPath — Inicia la definición de un trazado de recorte

Descripción

ImagickDraw::pushClipPath ( string $clip_mask_id ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Inicia la definición de un trazado de recorte el cuál está compuesto por cualquier número de comandos de dibujo y finalizado por un comando ImagickDraw::popClipPath().

Parámetros

clip_mask_id

Id de la máscara de recorte

Valores devueltos

No devuelve ningún valor.


Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo

  • « ImagickDraw::pushClipPath
  • ImagickDraw::pushPattern »
  • PHP Manual
  • ImagickDraw
  • Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo

ImagickDraw::pushDefs

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushDefs — Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo

Descripción

ImagickDraw::pushDefs ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Indica que los comandos hasta un comando ImagickDraw::popDefs() finalizador crean elementos nominados (p.ej. trazados de recorte, texturas, etc.) los cuales pueden ser procesados previamente de forma segura para la eficiencia.

Valores devueltos

No devuelve ningún valor.


Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado

  • « ImagickDraw::pushDefs
  • ImagickDraw::rectangle »
  • PHP Manual
  • ImagickDraw
  • Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado

ImagickDraw::pushPattern

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushPattern — Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado

Descripción

ImagickDraw::pushPattern ( string $pattern_id , float $x , float $y , float $width , float $height ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Indica que los comandos subsiguientes hasta un comando DrawPopPattern() comprenden la definición de un patrón nominado. Al espacio del patrón se le asigna las coordenadas de la esquina superior izquierda, un ancho y alto, y se convierte en su propio espacio de dibujo. Cualquier cosa que se pueda dibujar se puede usar en una definición de patrón. Los patrones nominados se pueden usar como definiciones de contorno o pincel.

Parámetros

pattern_id

el id del patrón

x

coordenada x de la esquina superior izquierda

y

coordenada y de la esquina superior izquierda

width

ancho del patrón

height

alto del patrón

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ImagickDraw::pushPattern()

<?php
function pushPattern($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(1);

    $draw->pushPattern("MyFirstPattern", 0, 0, 50, 50);
    for ($x = 0; $x < 50; $x += 10) {
        for ($y = 0; $y < 50; $y += 5) {
            $positionX = $x + (($y / 5) % 5);
            $draw->rectangle($positionX, $y, $positionX + 5, $y + 5);
        }
    }
    $draw->popPattern();

    $draw->setFillOpacity(0);
    $draw->rectangle(100, 100, 400, 400);
    $draw->setFillOpacity(1);

    $draw->setFillOpacity(1);

    $draw->push();
    $draw->setFillPatternURL('#MyFirstPattern');
    $draw->setFillColor('yellow');
    $draw->rectangle(100, 100, 400, 400);
    $draw->pop();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Dibuja un rectángulo

  • « ImagickDraw::pushPattern
  • ImagickDraw::render »
  • PHP Manual
  • ImagickDraw
  • Dibuja un rectángulo

ImagickDraw::rectangle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::rectangle — Dibuja un rectángulo

Descripción

ImagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un rectángulo dando dos coordenadas y usando el contorno, el ancho del contorno, y la configuración de rellenos actuales.

Parámetros

x1

coordenada x de la esquina superior izquierda

y1

coordenada y de la esquina superior izquierda

x2

coordenada x de la esquina inferior derecha

y2

coordenada y de la esquina inferior derecha

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::rectangle()

<?php
function rectangle($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->rectangle(200, 200, 300, 300);
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Renderiza todos los comandos de dibujo precedentes en la imagen

  • « ImagickDraw::rectangle
  • ImagickDraw::resetVectorGraphics »
  • PHP Manual
  • ImagickDraw
  • Renderiza todos los comandos de dibujo precedentes en la imagen

ImagickDraw::render

(PECL imagick 2, PECL imagick 3)

ImagickDraw::render — Renderiza todos los comandos de dibujo precedentes en la imagen

Descripción

ImagickDraw::render ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Renderiza todos los comandos de dibujo precedentes en la imagen

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Description

  • « ImagickDraw::render
  • ImagickDraw::rotate »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::resetVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::resetVectorGraphics — Description

Descripción

public ImagickDraw::resetVectorGraphics ( ) : void

Reinicia los gráficos de vectores.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Aplica la rotación especificada al espacio de coordenadas actual

  • « ImagickDraw::resetVectorGraphics
  • ImagickDraw::roundRectangle »
  • PHP Manual
  • ImagickDraw
  • Aplica la rotación especificada al espacio de coordenadas actual

ImagickDraw::rotate

(PECL imagick 2, PECL imagick 3)

ImagickDraw::rotate — Aplica la rotación especificada al espacio de coordenadas actual

Descripción

ImagickDraw::rotate ( float $degrees ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Aplica la rotación especificada al espacio de coordenadas actual.

Parámetros

degrees

grados a rotar

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::rotate()

<?php
function rotate($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeOpacity(1);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);
    $draw->setFillColor($fillModifiedColor);
    $draw->rotate(15);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Dibuja un rectángulo redondeado

  • « ImagickDraw::rotate
  • ImagickDraw::scale »
  • PHP Manual
  • ImagickDraw
  • Dibuja un rectángulo redondeado

ImagickDraw::roundRectangle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::roundRectangle — Dibuja un rectángulo redondeado

Descripción

ImagickDraw::roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Dibuja un rectángulo redondeado dando dos coordenadas, los radios x e y de las esquinas y usando el contorno, el ancho del contorno, y la configuración de relleno actuales.

Parámetros

x1

coordenada x de la esquina superior izquierda

y1

coordenada y de la esquina superior izquierda

x2

coordenada x de la esquina inferior derecha

y2

coordenada y de la esquina inferior derecha

rx

redondeo x

ry

redondeo y

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::roundRectangle()

<?php
function roundRectangle($strokeColor, $fillColor, $backgroundColor, $startX, $startY, $endX, $endY, $roundX, $roundY) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->roundRectangle($startX, $startY, $endX, $endY, $roundX, $roundY);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Ajusta el factor de escala

  • « ImagickDraw::roundRectangle
  • ImagickDraw::setClipPath »
  • PHP Manual
  • ImagickDraw
  • Ajusta el factor de escala

ImagickDraw::scale

(PECL imagick 2, PECL imagick 3)

ImagickDraw::scale — Ajusta el factor de escala

Descripción

ImagickDraw::scale ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Ajusta el factor de escala a aplicar en las direcciones horizontal y vertical al espacio de coordenadas actual.

Parámetros

x

factor horizontal

y

factor vertical

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::scale()

<?php
function scale($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(4);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);
    $draw->setFillColor($fillModifiedColor);
    $draw->scale(1.4, 1.4);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Asocia un trazado de recorte nominado con la imagen

  • « ImagickDraw::scale
  • ImagickDraw::setClipRule »
  • PHP Manual
  • ImagickDraw
  • Asocia un trazado de recorte nominado con la imagen

ImagickDraw::setClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipPath — Asocia un trazado de recorte nominado con la imagen

Descripción

ImagickDraw::setClipPath ( string $clip_mask ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Asocia un trazado de recorte nominado con la imagen. Sólo las áreas dibujadas por el trazado de recorte serán modificadas mientras permanezca el efecto.

Parámetros

clip_mask

el nombre del trazado de recorte

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setClipPath()

<?php
function setClipPath($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $clipPathName = 'testClipPath';

    $draw->pushClipPath($clipPathName);
    $draw->rectangle(0, 0, 250, 250);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);
    $draw->rectangle(100, 100, 400, 400);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la regla de relleno de polígonos a usar por el trazado de recorte

  • « ImagickDraw::setClipPath
  • ImagickDraw::setClipUnits »
  • PHP Manual
  • ImagickDraw
  • Establece la regla de relleno de polígonos a usar por el trazado de recorte

ImagickDraw::setClipRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipRule — Establece la regla de relleno de polígonos a usar por el trazado de recorte

Descripción

ImagickDraw::setClipRule ( int $fill_rule ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la regla de relleno de polígonos a usar por el trazado de recorte.

Parámetros

fill_rule

constante FILLRULE_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setClipRule()

<?php
function setClipRule($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    //\Imagick::FILLRULE_EVENODD
    //\Imagick::FILLRULE_NONZERO

    $clipPathName = 'testClipPath';
    $draw->pushClipPath($clipPathName);
    $draw->setClipRule(\Imagick::FILLRULE_EVENODD);
    $draw->rectangle(0, 0, 300, 500);
    $draw->rectangle(200, 0, 500, 500);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);
    $draw->rectangle(200, 200, 300, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la interpretación de las unidades de un trazado de recorte

  • « ImagickDraw::setClipRule
  • ImagickDraw::setFillAlpha »
  • PHP Manual
  • ImagickDraw
  • Establece la interpretación de las unidades de un trazado de recorte

ImagickDraw::setClipUnits

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipUnits — Establece la interpretación de las unidades de un trazado de recorte

Descripción

ImagickDraw::setClipUnits ( int $clip_units ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la interpretación de las unidades de un trazado de recorte.

Parámetros

clip_units

el número de unidades de recorte

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setClipUnits()

<?php
function setClipUnits($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $clipPathName = 'testClipPath';
    $draw->setClipUnits(\Imagick::RESOLUTION_PIXELSPERINCH);
    $draw->pushClipPath($clipPathName);
    $draw->rectangle(0, 0, 250, 250);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);

    //RESOLUTION_PIXELSPERINCH
    //RESOLUTION_PIXELSPERCENTIMETER

    $draw->rectangle(200, 200, 300, 300);
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno

  • « ImagickDraw::setClipUnits
  • ImagickDraw::setFillColor »
  • PHP Manual
  • ImagickDraw
  • Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno

ImagickDraw::setFillAlpha

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillAlpha — Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno

Descripción

ImagickDraw::setFillAlpha ( float $opacity ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno. Completamente opaco es 1.0.

Parámetros

opacity

canal alfa de relleno

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFillAlpha()

<?php
function setFillAlpha($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->rectangle(100, 200, 200, 300);
    @$draw->setFillAlpha(0.4);
    $draw->rectangle(300, 200, 400, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el color de relleno que se va a usar para dibujar objetos rellenos

  • « ImagickDraw::setFillAlpha
  • ImagickDraw::setFillOpacity »
  • PHP Manual
  • ImagickDraw
  • Establece el color de relleno que se va a usar para dibujar objetos rellenos

ImagickDraw::setFillColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillColor — Establece el color de relleno que se va a usar para dibujar objetos rellenos

Descripción

ImagickDraw::setFillColor ( ImagickPixel $fill_pixel ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el color de relleno que se va a usar para dibujar objetos rellenos.

Parámetros

fill_pixel

objeto ImagickPixel a usar para establecer el color

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFillColor()

<?php
function setFillColor($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(1.5);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle(50, 50, 150, 150);

    $draw->setFillColor("rgb(200, 32, 32)");
    $draw->rectangle(200, 50, 300, 150);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno

  • « ImagickDraw::setFillColor
  • ImagickDraw::setFillPatternURL »
  • PHP Manual
  • ImagickDraw
  • Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno

ImagickDraw::setFillOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillOpacity — Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno

Descripción

ImagickDraw::setFillOpacity ( float $fillOpacity ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o de la textura Completamente opaco es 1.0.

Parámetros

fillOpacity

la opacidad de relleno

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFillOpacity()

<?php
function setFillOpacity($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->rectangle(100, 200, 200, 300);

    $draw->setFillOpacity(0.4);
    $draw->rectangle(300, 200, 400, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la URL a usar como un patrón de relleno para objetos rellenos

  • « ImagickDraw::setFillOpacity
  • ImagickDraw::setFillRule »
  • PHP Manual
  • ImagickDraw
  • Establece la URL a usar como un patrón de relleno para objetos rellenos

ImagickDraw::setFillPatternURL

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillPatternURL — Establece la URL a usar como un patrón de relleno para objetos rellenos

Descripción

ImagickDraw::setFillPatternURL ( string $fill_url ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la URL a usar como un patrón de relleno para objetos rellenos. Sólo se soportan URL locales ("#identificador") por el momento. Estas URL locales normalmente son creadas para definir un patrón de relleno nominado con DrawPushPattern/DrawPopPattern.

Parámetros

fill_url

La URL a usar para obtener el patrón de relleno.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece la regla de relleno a usar mientras se dibujan polígonos

  • « ImagickDraw::setFillPatternURL
  • ImagickDraw::setFont »
  • PHP Manual
  • ImagickDraw
  • Establece la regla de relleno a usar mientras se dibujan polígonos

ImagickDraw::setFillRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillRule — Establece la regla de relleno a usar mientras se dibujan polígonos

Descripción

ImagickDraw::setFillRule ( int $fill_rule ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la regla de relleno a usar mientras se dibujan polígonos.

Parámetros

fill_rule

constante FILLRULE_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFillRule()

<?php
function setFillRule($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $fillRules = [\Imagick::FILLRULE_NONZERO, \Imagick::FILLRULE_EVENODD];

    $points = 11;
    $size = 150;

    $draw->translate(175, 160);

    for ($x = 0; $x < 2; $x++) {
        $draw->setFillRule($fillRules[$x]);
        $draw->pathStart();
        for ($n = 0; $n < $points * 2; $n++) {

            if ($n >= $points) {
                $angle = fmod($n * 360 * 4 / $points, 360) * pi() / 180;
            }
            else {
                $angle = fmod($n * 360 * 3 / $points, 360) * pi() / 180;
            }

            $positionX = $size * sin($angle);
            $positionY = $size * cos($angle);

            if ($n == 0) {
                $draw->pathMoveToAbsolute($positionX, $positionY);
            }
            else {
                $draw->pathLineToAbsolute($positionX, $positionY);
            }
        }

        $draw->pathClose();
        $draw->pathFinish();

        $draw->translate(325, 0);
    }

    $image = new \Imagick();
    $image->newImage(700, 320, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Establece la fuente especificada completamente para usarla cuando se escribe texto

  • « ImagickDraw::setFillRule
  • ImagickDraw::setFontFamily »
  • PHP Manual
  • ImagickDraw
  • Establece la fuente especificada completamente para usarla cuando se escribe texto

ImagickDraw::setFont

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFont — Establece la fuente especificada completamente para usarla cuando se escribe texto

Descripción

ImagickDraw::setFont ( string $font_name ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la fuente especificada completamente para usarla cuando se escribe texto.

Parámetros

font_name

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::setFont()

<?php
function setFont($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(36);

    $draw->setFont("../fonts/Arial.ttf");
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFont("../fonts/Consolas.ttf");
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFont("../fonts/CANDY.TTF");
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFont("../fonts/Inconsolata-dz.otf");
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la familia de fuentes para usarla cuando se escribe texto

  • « ImagickDraw::setFont
  • ImagickDraw::setFontSize »
  • PHP Manual
  • ImagickDraw
  • Establece la familia de fuentes para usarla cuando se escribe texto

ImagickDraw::setFontFamily

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontFamily — Establece la familia de fuentes para usarla cuando se escribe texto

Descripción

ImagickDraw::setFontFamily ( string $font_family ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la familia de fuentes para usarla cuando se escribe texto.

Parámetros

font_family

la familia de fuentes

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::setFontFamily()

<?php
function setFontFamily($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $draw->setFontSize(48);

    $draw->setFontFamily("Times");
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontFamily("AvantGarde");
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontFamily("NewCenturySchlbk");
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFontFamily("Palatino");
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(450, 250, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto

  • « ImagickDraw::setFontFamily
  • ImagickDraw::setFontStretch »
  • PHP Manual
  • ImagickDraw
  • Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto

ImagickDraw::setFontSize

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontSize — Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto

Descripción

ImagickDraw::setFontSize ( float $pointsize ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto.

Parámetros

pointsize

el tamaño del punto

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFontSize()

<?php
function setFontSize($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFont("../fonts/Arial.ttf");

    $sizes = [24, 36, 48, 60, 72];

    foreach ($sizes as $size) {
        $draw->setFontSize($size);
        $draw->annotation(50, ($size * $size / 16), "Lorem Ipsum!");
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el estiramiento de la fuente para usarla cuando se escribe texto

  • « ImagickDraw::setFontSize
  • ImagickDraw::setFontStyle »
  • PHP Manual
  • ImagickDraw
  • Establece el estiramiento de la fuente para usarla cuando se escribe texto

ImagickDraw::setFontStretch

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontStretch — Establece el estiramiento de la fuente para usarla cuando se escribe texto

Descripción

ImagickDraw::setFontStretch ( int $fontStretch ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el estiramiento de la fuente para usarla cuando se escribe texto. La enumeración AnyStyle actúa como una opción comodín para "no tener cuidado".

Parámetros

fontStretch

constante STRETCH_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFontStretch()

<?php
function setFontStretch($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(36);

    $fontStretchTypes = [
        \Imagick::STRETCH_ULTRACONDENSED,
        \Imagick::STRETCH_CONDENSED,
        \Imagick::STRETCH_SEMICONDENSED,
        \Imagick::STRETCH_SEMIEXPANDED,
        \Imagick::STRETCH_EXPANDED,
        \Imagick::STRETCH_EXTRAEXPANDED,
        \Imagick::STRETCH_ULTRAEXPANDED,
        \Imagick::STRETCH_ANY
    ];

    $offset = 0;
    foreach ($fontStretchTypes as $fontStretch) {
        $draw->setFontStretch($fontStretch);
        $draw->annotation(50, 75 + $offset, "Lorem Ipsum!");
        $offset += 50;
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el estilo de fuente para usarlo cuando se escribe texto

  • « ImagickDraw::setFontStretch
  • ImagickDraw::setFontWeight »
  • PHP Manual
  • ImagickDraw
  • Establece el estilo de fuente para usarlo cuando se escribe texto

ImagickDraw::setFontStyle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontStyle — Establece el estilo de fuente para usarlo cuando se escribe texto

Descripción

ImagickDraw::setFontStyle ( int $style ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el estilo de fuente para usarlo cuando se escribe texto. La enumeración AnyStyle actúa como una opción comodín para "no tener cuidado".

Parámetros

style

constante STYLETYPE_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setFontStyle()

<?php
function setFontStyle($fillColor, $strokeColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(36);
    $draw->setFontStyle(\Imagick::STYLE_NORMAL);
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontStyle(\Imagick::STYLE_ITALIC);
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontStyle(\Imagick::STYLE_OBLIQUE);
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(350, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el peso de fuente

  • « ImagickDraw::setFontStyle
  • ImagickDraw::setGravity »
  • PHP Manual
  • ImagickDraw
  • Establece el peso de fuente

ImagickDraw::setFontWeight

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontWeight — Establece el peso de fuente

Descripción

ImagickDraw::setFontWeight ( int $font_weight ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el peso de fuente para usarlo cuando se escribe texto.

Parámetros

font_weight

Valores devueltos

Ejemplos

Ejemplo #1 ImagickDraw::setFontWeight()

<?php
function setFontWeight($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(1);

    $draw->setFontSize(36);

    $draw->setFontWeight(100);
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontWeight(200);
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontWeight(400);
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFontWeight(800);
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece la gravedad de ubicación del texto

  • « ImagickDraw::setFontWeight
  • ImagickDraw::setResolution »
  • PHP Manual
  • ImagickDraw
  • Establece la gravedad de ubicación del texto

ImagickDraw::setGravity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setGravity — Establece la gravedad de ubicación del texto

Descripción

ImagickDraw::setGravity ( int $gravity ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la gravedad de ubicación del texto para usarla cuando se escribe texto.

Parámetros

gravity

Una constante GRAVITY_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setGravity()

<?php
function setGravity($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(24);

    $gravitySettings = array(
        \Imagick::GRAVITY_NORTHWEST => 'NorthWest',
        \Imagick::GRAVITY_NORTH => 'North',
        \Imagick::GRAVITY_NORTHEAST => 'NorthEast',
        \Imagick::GRAVITY_WEST => 'West',
        \Imagick::GRAVITY_CENTER => 'Centre',
        \Imagick::GRAVITY_SOUTHWEST => 'SouthWest',
        \Imagick::GRAVITY_SOUTH => 'South',
        \Imagick::GRAVITY_SOUTHEAST => 'SouthEast',
        \Imagick::GRAVITY_EAST => 'East'
    );

    $draw->setFont("../fonts/Arial.ttf");

    foreach ($gravitySettings as $type => $description) {
        $draw->setGravity($type);
        $draw->annotation(50, 50, '"' . $description . '"');
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Description

  • « ImagickDraw::setGravity
  • ImagickDraw::setStrokeAlpha »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setResolution

(PECL imagick 3 >= 3.1.0)

ImagickDraw::setResolution — Description

Descripción

public ImagickDraw::setResolution ( string $x_resolution , string $y_resolution ) : void

Establece la resolución.

Parámetros

x_resolution

y_resolution

Valores devueltos


Especifica la opacidad de los perfiles de los objetos contorneados

  • « ImagickDraw::setResolution
  • ImagickDraw::setStrokeAntialias »
  • PHP Manual
  • ImagickDraw
  • Especifica la opacidad de los perfiles de los objetos contorneados

ImagickDraw::setStrokeAlpha

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeAlpha — Especifica la opacidad de los perfiles de los objetos contorneados

Descripción

ImagickDraw::setStrokeAlpha ( float $opacity ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica la opacidad de los perfiles de los objetos contorneados.

Parámetros

opacity

opacidad

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeAlpha()

<?php
function setStrokeAlpha($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeOpacity(0.1);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Controla si los perfiles contorneados tiene antialias

  • « ImagickDraw::setStrokeAlpha
  • ImagickDraw::setStrokeColor »
  • PHP Manual
  • ImagickDraw
  • Controla si los perfiles contorneados tiene antialias

ImagickDraw::setStrokeAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeAntialias — Controla si los perfiles contorneados tiene antialias

Descripción

ImagickDraw::setStrokeAntialias ( bool $stroke_antialias ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Controla si los perfiles contorneados tiene antialias. Los perfiles contorneados tiene antialias por defecto. Cuando se deshabilita el antialias, los píxeles contorneados son puestos en el umbral para determinar si se debería usar el color de contorno o el color del lienzo subyacente.

Parámetros

stroke_antialias

la configuración de antialias

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeAntialias()

<?php
function setStrokeAntialias($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setStrokeAntialias(false);
    $draw->line(100, 100, 400, 105);

    $draw->line(100, 140, 400, 185);

    $draw->setStrokeAntialias(true);
    $draw->line(100, 110, 400, 115);
    $draw->line(100, 150, 400, 195);

    $image = new \Imagick();
    $image->newImage(500, 250, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Establece el color usado por los perfiles de objetos contorneados

  • « ImagickDraw::setStrokeAntialias
  • ImagickDraw::setStrokeDashArray »
  • PHP Manual
  • ImagickDraw
  • Establece el color usado por los perfiles de objetos contorneados

ImagickDraw::setStrokeColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeColor — Establece el color usado por los perfiles de objetos contorneados

Descripción

ImagickDraw::setStrokeColor ( ImagickPixel $stroke_pixel ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el color usado por los perfiles de objetos contorneados.

Parámetros

stroke_pixel

el color de contorno

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeColor()

<?php
function setStrokeColor($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(5);

    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);

    $draw->setStrokeOpacity(0.1);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica el patrón de rayas y huecos usado por los trazados de contorno

  • « ImagickDraw::setStrokeColor
  • ImagickDraw::setStrokeDashOffset »
  • PHP Manual
  • ImagickDraw
  • Especifica el patrón de rayas y huecos usado por los trazados de contorno

ImagickDraw::setStrokeDashArray

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeDashArray — Especifica el patrón de rayas y huecos usado por los trazados de contorno

Descripción

ImagickDraw::setStrokeDashArray ( array $dashArray ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica el patrón de rayas y huecos usado por los trazados de contorno. strokeDashArray representa una matriz de números que especifican la longitud de las rayas y huecos alternados en píxeles. Si se proporciona un número de valores impar, la lista de valores se repite para producir un número de valores par. Para quitar una matriz de discontinuidad existente, pase un argumento con cero número de elementos y una matriz de discontinuidad null. Una matriz strokeDashArray_ típica puede contener los números 5 3 2.

Parámetros

dashArray

matriz de elementos de tipo float

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeDashArray()

<?php
function setStrokeDashArray($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);

    $draw->setStrokeDashArray([10, 10]);
    $draw->rectangle(100, 50, 225, 175);

    $draw->setStrokeDashArray([20, 5, 20, 5, 5, 5,]);
    $draw->rectangle(275, 50, 400, 175);

    $draw->setStrokeDashArray([20, 5, 20, 5, 5]);
    $draw->rectangle(100, 200, 225, 350);

    $draw->setStrokeDashArray([1, 1, 1, 1, 2, 2, 3, 3, 5, 5, 8, 8, 13, 13, 21, 21, 34, 34, 55, 55, 89, 89, 144, 144, 233, 233, 377, 377, 610, 610, 987, 987, 1597, 1597, 2584, 2584, 4181, 4181,]);

    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

  • « ImagickDraw::setStrokeDashArray
  • ImagickDraw::setStrokeLineCap »
  • PHP Manual
  • ImagickDraw
  • Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

ImagickDraw::setStrokeDashOffset

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeDashOffset — Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad

Descripción

ImagickDraw::setStrokeDashOffset ( float $dash_offset ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad.

Parámetros

dash_offset

índice de discontinuidad

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeDashOffset()

<?php
function setStrokeDashOffset($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);
    $draw->setStrokeDashArray([20, 20]);
    $draw->setStrokeDashOffset(0);
    $draw->rectangle(100, 50, 225, 175);

    //Start the dash effect halfway through the solid portion
    $draw->setStrokeDashOffset(10);
    $draw->rectangle(275, 50, 400, 175);

    //Start the dash effect on the space portion
    $draw->setStrokeDashOffset(20);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeDashOffset(5);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

  • « ImagickDraw::setStrokeDashOffset
  • ImagickDraw::setStrokeLineJoin »
  • PHP Manual
  • ImagickDraw
  • Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

ImagickDraw::setStrokeLineCap

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeLineCap — Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados

Descripción

ImagickDraw::setStrokeLineCap ( int $linecap ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados.

Parámetros

linecap

constante LINECAP_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeLineCap()

<?php
function setStrokeLineCap($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(25);

    $lineTypes = [\Imagick::LINECAP_BUTT, \Imagick::LINECAP_ROUND, \Imagick::LINECAP_SQUARE,];

    $offset = 0;

    foreach ($lineTypes as $lineType) {
        $draw->setStrokeLineCap($lineType);
        $draw->line(50 + $offset, 50, 50 + $offset, 250);
        $offset += 50;
    }

    $imagick = new \Imagick();
    $imagick->newImage(300, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados

  • « ImagickDraw::setStrokeLineCap
  • ImagickDraw::setStrokeMiterLimit »
  • PHP Manual
  • ImagickDraw
  • Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados

ImagickDraw::setStrokeLineJoin

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeLineJoin — Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados

Descripción

ImagickDraw::setStrokeLineJoin ( int $linejoin ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica la forma que se va a usar en las esquinas de los trazados (u otras formas vectoriales) cuando están contorneados.

Parámetros

linejoin

constante LINEJOIN_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeLineJoin()

<?php
function setStrokeLineJoin($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(20);

    $offset = 220;

    $lineJoinStyle = [
        \Imagick::LINEJOIN_MITER,
        \Imagick::LINEJOIN_ROUND,
        \Imagick::LINEJOIN_BEVEL,
        ];

    for ($x = 0; $x < count($lineJoinStyle); $x++) {
        $draw->setStrokeLineJoin($lineJoinStyle[$x]);
        $points = [
            ['x' => 40 * 5, 'y' => 10 * 5 + $x * $offset],
            ['x' => 20 * 5, 'y' => 20 * 5 + $x * $offset],
            ['x' => 70 * 5, 'y' => 50 * 5 + $x * $offset],
            ['x' => 40 * 5, 'y' => 10 * 5 + $x * $offset],
        ];

        $draw->polyline($points);
    }

    $image = new \Imagick();
    $image->newImage(500, 700, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica el límite del inglete

  • « ImagickDraw::setStrokeLineJoin
  • ImagickDraw::setStrokeOpacity »
  • PHP Manual
  • ImagickDraw
  • Especifica el límite del inglete

ImagickDraw::setStrokeMiterLimit

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeMiterLimit — Especifica el límite del inglete

Descripción

ImagickDraw::setStrokeMiterLimit ( int $miterlimit ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica el límite del inglete. Cuando dos segmentos de línea se encuentran en un águlo agudo y la unión del inglete ha sido especificada para 'lineJoin', es posible que el inglete se extienda más allá del grosor de la línea que contornea el trazado. 'miterLimit' impone un límite en la proporción de la longitud del inglete a 'lineWidth'.

Parámetros

miterlimit

el límite del inglete

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeMiterLimit()

<?php
function setStrokeMiterLimit($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeOpacity(0.6);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(10);

    $yOffset = 100;

    $draw->setStrokeLineJoin(\Imagick::LINEJOIN_MITER);

    for ($y = 0; $y < 3; $y++) {

        $draw->setStrokeMiterLimit(40 * $y);

        $points = [
            ['x' => 22 * 3, 'y' => 15 * 4 + $y * $yOffset],
            ['x' => 20 * 3, 'y' => 20 * 4 + $y * $yOffset],
            ['x' => 70 * 5, 'y' => 45 * 4 + $y * $yOffset],
        ];

        $draw->polygon($points);
    }

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    $image->setImageType(\Imagick::IMGTYPE_PALETTE);
    $image->setImageCompressionQuality(100);
    $image->stripImage();

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica la opacidad de los perfiles de los objetos contorneados

  • « ImagickDraw::setStrokeMiterLimit
  • ImagickDraw::setStrokePatternURL »
  • PHP Manual
  • ImagickDraw
  • Especifica la opacidad de los perfiles de los objetos contorneados

ImagickDraw::setStrokeOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeOpacity — Especifica la opacidad de los perfiles de los objetos contorneados

Descripción

ImagickDraw::setStrokeOpacity ( float $stroke_opacity ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica la opacidad de los perfiles de los objetos contorneados.

Parámetros

stroke_opacity

opacidad del contorno. 1.0 es completamente opaco

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeOpacity()

<?php
function setStrokeOpacity($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(10);
    $draw->setStrokeOpacity(1);
    $draw->line(100, 80, 400, 125);
    $draw->rectangle(25, 200, 150, 350);
    $draw->setStrokeOpacity(0.5);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(200, 200, 325, 350);
    $draw->setStrokeOpacity(0.2);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(375, 200, 500, 350);

    $image = new \Imagick();
    $image->newImage(550, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Establece el patrón usado para los perfiles de objetos contorneados

  • « ImagickDraw::setStrokeOpacity
  • ImagickDraw::setStrokeWidth »
  • PHP Manual
  • ImagickDraw
  • Establece el patrón usado para los perfiles de objetos contorneados

ImagickDraw::setStrokePatternURL

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokePatternURL — Establece el patrón usado para los perfiles de objetos contorneados

Descripción

ImagickDraw::setStrokePatternURL ( string $stroke_url ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el patrón usado para los perfiles de objetos contorneados.

Parámetros

stroke_url

URL contorneada

Valores devueltos

imagick.imagickdraw.return.success;


Establece el ancho del contorno a usar para dibujar perfiles de objetos

  • « ImagickDraw::setStrokePatternURL
  • ImagickDraw::setTextAlignment »
  • PHP Manual
  • ImagickDraw
  • Establece el ancho del contorno a usar para dibujar perfiles de objetos

ImagickDraw::setStrokeWidth

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeWidth — Establece el ancho del contorno a usar para dibujar perfiles de objetos

Descripción

ImagickDraw::setStrokeWidth ( float $stroke_width ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el ancho del contorno a usar para dibujar perfiles de objetos.

Parámetros

stroke_width

ancho del contorno

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setStrokeWidth()

<?php
function setStrokeWidth($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeWidth(5);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Especifica una alineación de texto

  • « ImagickDraw::setStrokeWidth
  • ImagickDraw::setTextAntialias »
  • PHP Manual
  • ImagickDraw
  • Especifica una alineación de texto

ImagickDraw::setTextAlignment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextAlignment — Especifica una alineación de texto

Descripción

ImagickDraw::setTextAlignment ( int $alignment ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica una alineación de texto para aplicarla cuando se escribe texto.

Parámetros

alignment

constante ALIGN_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setTextAlignment()

<?php
function setTextAlignment($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(36);

    $draw->setTextAlignment(\Imagick::ALIGN_LEFT);
    $draw->annotation(250, 75, "Lorem Ipsum!");
    $draw->setTextAlignment(\Imagick::ALIGN_CENTER);
    $draw->annotation(250, 150, "Lorem Ipsum!");
    $draw->setTextAlignment(\Imagick::ALIGN_RIGHT);
    $draw->annotation(250, 225, "Lorem Ipsum!");
    $draw->line(250, 0, 250, 500);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Controla si el texto tiene antialias

  • « ImagickDraw::setTextAlignment
  • ImagickDraw::setTextDecoration »
  • PHP Manual
  • ImagickDraw
  • Controla si el texto tiene antialias

ImagickDraw::setTextAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextAntialias — Controla si el texto tiene antialias

Descripción

ImagickDraw::setTextAntialias ( bool $antiAlias ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Controla si el texto tiene antialias. El texto tiene antialias por defecto.

Parámetros

antiAlias

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setTextAntialias()

<?php
function setTextAntialias($fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor('none');
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(32);
    $draw->setTextAntialias(false);
    $draw->annotation(5, 30, "Lorem Ipsum!");
    $draw->setTextAntialias(true);
    $draw->annotation(5, 65, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(220, 80, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    //Scale the image so that people can see the aliasing.
    $imagick->scaleImage(220 * 6, 80 * 6);
    $imagick->cropImage(640, 480, 0, 0);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Especifica una decoración

  • « ImagickDraw::setTextAntialias
  • ImagickDraw::setTextEncoding »
  • PHP Manual
  • ImagickDraw
  • Especifica una decoración

ImagickDraw::setTextDecoration

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextDecoration — Especifica una decoración

Descripción

ImagickDraw::setTextDecoration ( int $decoration ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica una decoración a aplicar cuando se escribe texto.

Parámetros

decoration

constante DECORATION_

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setTextDecoration()

<?php
function setTextDecoration($strokeColor, $fillColor, $backgroundColor, $textDecoration) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->setTextDecoration($textDecoration);
    $draw->annotation(50, 75, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 200, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Especifica el conjunto de codificación del texto

  • « ImagickDraw::setTextDecoration
  • ImagickDraw::setTextInterlineSpacing »
  • PHP Manual
  • ImagickDraw
  • Especifica el conjunto de codificación del texto

ImagickDraw::setTextEncoding

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextEncoding — Especifica el conjunto de codificación del texto

Descripción

ImagickDraw::setTextEncoding ( string $encoding ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica el conjunto de codificación del texto para usar en las anotaciones de texto. La única codificación de caracteres que se puede especificar por el momento es "UTF-8" para la representación Unicode como una secuencia de bytes. Especifique un string vacío para establecer la codificación de texto al predeterminado del sistema. El éxito en la anotación de texto usando Unicode podría requerir tipos de letra diseñados para admitir Unicode.

Parámetros

encoding

El nombre de la codificación.

Valores devueltos

No devuelve ningún valor.


Description

  • « ImagickDraw::setTextEncoding
  • ImagickDraw::setTextInterwordSpacing »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextInterlineSpacing

(PECL imagick 3 >= 3.1.0)

ImagickDraw::setTextInterlineSpacing — Description

Descripción

public ImagickDraw::setTextInterlineSpacing ( float $spacing ) : void

Establece el espaciado interlínea del texto.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

spacing

Valores devueltos


Description

  • « ImagickDraw::setTextInterlineSpacing
  • ImagickDraw::setTextKerning »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextInterwordSpacing

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickDraw::setTextInterwordSpacing — Description

Descripción

public ImagickDraw::setTextInterwordSpacing ( float $spacing ) : void

Establece el espaciado entre palabras del texto.

Parámetros

spacing

Valores devueltos


Description

  • « ImagickDraw::setTextInterwordSpacing
  • ImagickDraw::setTextUnderColor »
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextKerning

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickDraw::setTextKerning — Description

Descripción

public ImagickDraw::setTextKerning ( float $kerning ) : void

Establece el interletraje («kerning») del texto

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

kerning

Valores devueltos


Especifica el color de un rectángulo de fondo

  • « ImagickDraw::setTextKerning
  • ImagickDraw::setVectorGraphics »
  • PHP Manual
  • ImagickDraw
  • Especifica el color de un rectángulo de fondo

ImagickDraw::setTextUnderColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextUnderColor — Especifica el color de un rectángulo de fondo

Descripción

ImagickDraw::setTextUnderColor ( ImagickPixel $under_color ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Especifica el color de un rectángulo de fondo para colocarlo bajo anotaciones de texto.

Parámetros

under_color

el color de debajo

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setTextUnderColor()

<?php
function setTextUnderColor($strokeColor, $fillColor, $backgroundColor, $textUnderColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->annotation(50, 75, "Lorem Ipsum!");
    $draw->setTextUnderColor($textUnderColor);
    $draw->annotation(50, 175, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece los gráficos vectoriales

  • « ImagickDraw::setTextUnderColor
  • ImagickDraw::setViewbox »
  • PHP Manual
  • ImagickDraw
  • Establece los gráficos vectoriales

ImagickDraw::setVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setVectorGraphics — Establece los gráficos vectoriales

Descripción

ImagickDraw::setVectorGraphics ( string $xml ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece los gráficos vectoriales asociados al objeto ImagickDraw especificado. Use este método con ImagickDraw::getVectorGraphics() como un método de persistencia del estado de los gráficos vectoriales.

Parámetros

xml

archivo xml que contiene los gráficos vectoriales

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ImagickDraw::setVectorGraphics()

<?php
function setVectorGraphics() {
    //Setup a draw object with some drawing in it.
    $draw = new \ImagickDraw();
    $draw->setFillColor("red");
    $draw->circle(20, 20, 50, 50);
    $draw->setFillColor("blue");
    $draw->circle(50, 70, 50, 50);
    $draw->rectangle(50, 120, 80, 150);

    //Get the drawing as a string
    $SVG = $draw->getVectorGraphics();

    //$svg is a string, and could be saved anywhere a string can be saved

    //Use the saved drawing to generate a new draw object
    $draw2 = new \ImagickDraw();
    //Apparently the SVG text is missing the root element.
    $draw2->setVectorGraphics("<root>".$SVG."</root>");

    $imagick = new \Imagick();
    $imagick->newImage(200, 200, 'white');
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw2);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Establece el tamaño de todos los lienzos

  • « ImagickDraw::setVectorGraphics
  • ImagickDraw::skewX »
  • PHP Manual
  • ImagickDraw
  • Establece el tamaño de todos los lienzos

ImagickDraw::setViewbox

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setViewbox — Establece el tamaño de todos los lienzos

Descripción

ImagickDraw::setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el tamaño de todos los lienzos para ser grabados con la información del vector de pintura. Normalmente esto se especifica usando el mismo tamaño que la imagen del lienzo. Cuando la información del vector se guarda a formatos SVG o MVG, se usa la caja de vistas para especificar el tamaño de la imagen del lienzo donde un visionador renderizará la información del vector.

Parámetros

x1

coordenada x izquierda

y1

coordenada y izquierda

x2

coordenada x derecha

y2

coordenada y derecha

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::setViewBox()

<?php
function setViewBox($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    /*

    Sets the overall canvas size to be recorded with the drawing vector data. Usually this will be specified using the same size as the canvas image. When the vector data is saved to SVG or MVG formats, the viewbox is use to specify the size of the canvas image that a viewer will render the vector data on.

     */

    $draw->circle(250, 250, 250, 0);
    $draw->setviewbox(0, 0, 200, 200);
    $draw->circle(125, 250, 250, 250);
    $draw->translate(250, 125);
    $draw->circle(0, 0, 125, 0);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Tuerce el sistema de coordenadas actual en la dirección horizontal

  • « ImagickDraw::setViewbox
  • ImagickDraw::skewY »
  • PHP Manual
  • ImagickDraw
  • Tuerce el sistema de coordenadas actual en la dirección horizontal

ImagickDraw::skewX

(PECL imagick 2, PECL imagick 3)

ImagickDraw::skewX — Tuerce el sistema de coordenadas actual en la dirección horizontal

Descripción

ImagickDraw::skewX ( float $degrees ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Tuerce el sistema de coordenadas actual en la dirección horizontal.

Parámetros

degrees

grados de torción

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::skewX()

<?php
function skewX($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
               $startX, $startY, $endX, $endY, $skew) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);
    $draw->setFillColor($fillModifiedColor);
    $draw->skewX($skew);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Tuerce el sistema de coordenadas actual en la dirección vertical

  • « ImagickDraw::skewX
  • ImagickDraw::translate »
  • PHP Manual
  • ImagickDraw
  • Tuerce el sistema de coordenadas actual en la dirección vertical

ImagickDraw::skewY

(PECL imagick 2, PECL imagick 3)

ImagickDraw::skewY — Tuerce el sistema de coordenadas actual en la dirección vertical

Descripción

ImagickDraw::skewY ( float $degrees ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Tuerce el sistema de coordenadas actual en la dirección vertical.

Parámetros

degrees

grados de torción

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::skewY()

<?php
function skewY($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
               $startX, $startY, $endX, $endY, $skew) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);
    $draw->setFillColor($fillModifiedColor);
    $draw->skewY($skew);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Aplica una traslación del sistema de coordenadas actual

  • « ImagickDraw::skewY
  • ImagickPixel »
  • PHP Manual
  • ImagickDraw
  • Aplica una traslación del sistema de coordenadas actual

ImagickDraw::translate

(PECL imagick 2, PECL imagick 3)

ImagickDraw::translate — Aplica una traslación del sistema de coordenadas actual

Descripción

ImagickDraw::translate ( float $x , float $y ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Aplica una traslación del sistema de coordenadas actual el cuál mueve el origen del sistema de coordenadas a las coordenadas especifiacadas.

Parámetros

x

traslación horizontal

y

traslación vertical

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ImagickDraw::translate()

<?php
function translate($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
                   $startX, $startY, $endX, $endY, $translateX, $translateY) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $draw->setFillColor($fillModifiedColor);
    $draw->translate($translateX, $translateY);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


La clase ImagickPixel

(PECL imagick 2, PECL imagick 3)

Sinopsis de la Clase

ImagickPixel {
clear ( ) : bool
__construct ( string $color = ? )
destroy ( ) : bool
getColor ( bool $normalized = false ) : array
getColorAsString ( ) : string
getColorCount ( ) : int
public getColorQuantum ( ) : mixed
getColorValue ( int $color ) : float
public getColorValueQuantum ( ) : mixed
getHSL ( ) : array
public getIndex ( ) : int
isPixelSimilar ( ImagickPixel $color , float $fuzz ) : bool
public isPixelSimilarQuantum ( string $color , string $fuzz = ? ) : bool
isSimilar ( ImagickPixel $color , float $fuzz ) : bool
setColor ( string $color ) : bool
public setcolorcount ( string $colorCount ) : void
setColorValue ( int $color , float $value ) : bool
public setColorValueQuantum ( int $color , mixed $value ) : void
setHSL ( float $hue , float $saturation , float $luminosity ) : bool
public setIndex ( int $index ) : void
}

Tabla de contenidos

  • ImagickPixel::clear — Borra los recursos asociados con este objeto
  • ImagickPixel::__construct — El constructor ImagickPixel
  • ImagickPixel::destroy — Desasigna los recursos asociados con este objeto
  • ImagickPixel::getColor — Devuelve el color
  • ImagickPixel::getColorAsString — Devuelve el color como string
  • ImagickPixel::getColorCount — Devuelve la cuenta de color asociada a este
  • ImagickPixel::getColorQuantum — Description
  • ImagickPixel::getColorValue — Obtiene el valor normalizado del canal de color proporcionado
  • ImagickPixel::getColorValueQuantum — Description
  • ImagickPixel::getHSL — Devuelve el color HSL normalizado del objeto ImagickPixel
  • ImagickPixel::getIndex — Description
  • ImagickPixel::isPixelSimilar — Comprobar la distancia entre este color y otro
  • ImagickPixel::isPixelSimilarQuantum — Description
  • ImagickPixel::isSimilar — Comprobar la distancia entre este color y otro
  • ImagickPixel::setColor — Establece el color
  • ImagickPixel::setColorCount — Description
  • ImagickPixel::setColorValue — Establece el valor normalizado de uno de los canales
  • ImagickPixel::setColorValueQuantum — Description
  • ImagickPixel::setHSL — Establece el color HSL normalizado
  • ImagickPixel::setIndex — Description


Borra los recursos asociados con este objeto

  • « ImagickPixel
  • ImagickPixel::__construct »
  • PHP Manual
  • ImagickPixel
  • Borra los recursos asociados con este objeto

ImagickPixel::clear

(PECL imagick 2, PECL imagick 3)

ImagickPixel::clear — Borra los recursos asociados con este objeto

Descripción

ImagickPixel::clear ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Borra el objeto ImagickPixel, dejándolo en un estado nuevo. Esto también desestablece cualquier color asociado con el objeto.

Valores devueltos

Devuelve true en caso de éxito.


El constructor ImagickPixel

  • « ImagickPixel::clear
  • ImagickPixel::destroy »
  • PHP Manual
  • ImagickPixel
  • El constructor ImagickPixel

ImagickPixel::__construct

(PECL imagick 2, PECL imagick 3)

ImagickPixel::__construct — El constructor ImagickPixel

Descripción

ImagickPixel::__construct ( string $color = ? )
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Construye un objeto ImagickPixel. Si se especifica un color, el objeto se construye y después se inicializa con ese color antes de ser devuelto.

Parámetros

color

La cadena de color opcional a usar como el valor inicial de este objeto.

Valores devueltos

Devuelve un objeto ImagickPixel si se tuvo éxito, lanzando una excepción ImagickPixelException si falló.

Ejemplos

Ejemplo #1 ImagickPixel::construct()

<?php
function construct() {

    $columns = 4;

    $exampleColors = array(
        "rgba(100%, 0%, 0%, 0.5)",
        "hsb(33.3333%, 100%,  75%)", // medium green
        "hsl(120, 255,   191.25)", //medium green
        "graya(50%, 0.5)", //  semi-transparent mid gray
        "LightCoral", "none", //"cmyk(0.9, 0.48, 0.83, 0.50)",
        "#f00", //  #rgb
        "#ff0000", //  #rrggbb
        "#ff0000ff", //  #rrggbbaa
        "#ffff00000000", //  #rrrrggggbbbb
        "#ffff00000000ffff", //  #rrrrggggbbbbaaaa
        "rgb(255, 0, 0)", //  an integer in the range 0—255 for each component
        "rgb(100.0%, 0.0%, 0.0%)", //  a float in the range 0—100% for each component
        "rgb(255, 0, 0)", //  range 0 - 255
        "rgba(255, 0, 0, 1.0)", //  the same, with an explicit alpha value
        "rgb(100%, 0%, 0%)", //  range 0.0% - 100.0%
        "rgba(100%, 0%, 0%, 1.0)", //  the same, with an explicit alpha value
    );

    $draw = new \ImagickDraw();
    $count = 0;
    $black = new \ImagickPixel('rgb(0, 0, 0)');

    foreach ($exampleColors as $exampleColor) {
        $color = new \ImagickPixel($exampleColor);

        $draw->setstrokewidth(1.0);
        $draw->setStrokeColor($black);
        $draw->setFillColor($color);
        $offsetX = ($count % $columns) * 50 + 5;
        $offsetY = intval($count / $columns) * 50 + 5;
        $draw->rectangle(0 + $offsetX, 0 + $offsetY, 40 + $offsetX, 40 + $offsetY);
        $count++;
    }

    $image = new \Imagick();
    $image->newImage(350, 350, "blue");
    $image->setImageFormat("png");
    $image->drawImage($draw);
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Desasigna los recursos asociados con este objeto

  • « ImagickPixel::__construct
  • ImagickPixel::getColor »
  • PHP Manual
  • ImagickPixel
  • Desasigna los recursos asociados con este objeto

ImagickPixel::destroy

(PECL imagick 2, PECL imagick 3)

ImagickPixel::destroy — Desasigna los recursos asociados con este objeto

Descripción

ImagickPixel::destroy ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Desasigna cualquier recurso usado por el objeto ImagickPixel, y desestablece cualquier color asociado. El objeto no debería ser usado después de que se haya llamado a la función destructora.

Valores devueltos

Devuelve true en caso de éxito.


Devuelve el color

  • « ImagickPixel::destroy
  • ImagickPixel::getColorAsString »
  • PHP Manual
  • ImagickPixel
  • Devuelve el color

ImagickPixel::getColor

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColor — Devuelve el color

Descripción

ImagickPixel::getColor ( bool $normalized = false ) : array

Devuelve el color descrito por el objeto ImagickPixel, como un array. Si el color tiene establecido un canal de opacidad, es proporcionado como un cuarto valor de la lista.

Parámetros

normalized

Normalizar los valores del color

Valores devueltos

Un array de valores de canal, normalizados si se da true como parámetro. Lanza una ImagickPixelException si se produjo un error.

Ejemplos

Ejemplo #1 Uso básico de Imagick::getColor()

<?php

//Crear un ImagickPixel con el color predefinido 'brown'
$color = new ImagickPixel('brown');

//Establecer el color para que tenga un alfa de 25%
$color->setColorValue(Imagick::COLOR_ALPHA, 64 / 256.0);

$colorInfo = $color->getColor();

echo "Valores estándar".PHP_EOL;
print_r($colorInfo);

$colorInfo = $color->getColor(true);

echo "Valores normalizados:".PHP_EOL;
print_r($colorInfo);

?>

El resultado del ejemplo sería:

Valores estándar
Array
(
    [r] => 165
    [g] => 42
    [b] => 42
    [a] => 0
)
Valores normalizados:
Array
(
    [r] => 0.64705882352941
    [g] => 0.16470588235294
    [b] => 0.16470588235294
    [a] => 0.25000381475547
)


Devuelve el color como string

  • « ImagickPixel::getColor
  • ImagickPixel::getColorCount »
  • PHP Manual
  • ImagickPixel
  • Devuelve el color como string

ImagickPixel::getColorAsString

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

ImagickPixel::getColorAsString — Devuelve el color como string

Descripción

ImagickPixel::getColorAsString ( ) : string

Devuelve el color del objeto ImagickPixel como string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el color del objeto ImagickPixel como string.

Ejemplos

Ejemplo #1 Uso básico de Imagick::getColorAsString()

<?php

//Crear un ImagickPixel con el color predefinido 'brown'
$color = new ImagickPixel('brown');

$color->setColorValue(Imagick::COLOR_ALPHA, 64 / 256.0);

$colorInfo = $color->getColorAsString();

print_r($colorInfo);
?>

El resultado del ejemplo sería:

rgb(165,42,42)

Notas

Nota: Alfa no es devuelto

Esta función no devuelve el valor del canal alfa del color en el string.


Devuelve la cuenta de color asociada a este

  • « ImagickPixel::getColorAsString
  • ImagickPixel::getColorQuantum »
  • PHP Manual
  • ImagickPixel
  • Devuelve la cuenta de color asociada a este

ImagickPixel::getColorCount

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColorCount — Devuelve la cuenta de color asociada a este

Descripción

ImagickPixel::getColorCount ( ) : int

Devuelve la cuenta de color asociada a este.

La cuenta de color es el número de píxeles de la imagen que tienen el mismo color que este ImagickPixel.

ImagickPixel::getColorCount solamente parece funcionar para objetos ImagickPixel creados a través de Imagick::getImageHistogram()

Valores devueltos

Devuelve la cuenta de color como un entero si se tuvo éxito, lanzando una excepción ImagickPixelException si falló.

Ejemplos

Ejemplo #1 getColorCount() de ImagickPixel

<?php
    $imagick = new \Imagick();
    $imagick->newPseudoImage(640, 480, "magick:logo");
    $histogramElements = $imagick->getImageHistogram();
    $lastColor = array_pop($histogramElements);
    echo "La última cuenta de color de píxel es: ".$lastColor->getColorCount();
?>

La salida será similar a:

La última cuenta de color de píxel es: 256244


Description

  • « ImagickPixel::getColorCount
  • ImagickPixel::getColorValue »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getColorQuantum

(No hay información de versión disponible, podría estar únicamente en Git)

ImagickPixel::getColorQuantum — Description

Descripción

public ImagickPixel::getColorQuantum ( ) : mixed

Devuelve el color del píxel de un array como valores Quantum. Si ImageMagick se compiló como HDRI, estos serán valores de tipo float, de lo contrario serán enteros.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor quantum del elemento de color. Float si ImageMagick se compiló con HDRI, entero de lo contrario.


Obtiene el valor normalizado del canal de color proporcionado

  • « ImagickPixel::getColorQuantum
  • ImagickPixel::getColorValueQuantum »
  • PHP Manual
  • ImagickPixel
  • Obtiene el valor normalizado del canal de color proporcionado

ImagickPixel::getColorValue

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColorValue — Obtiene el valor normalizado del canal de color proporcionado

Descripción

ImagickPixel::getColorValue ( int $color ) : float

Recupera el valor del canal de color especificado, como un número de punto flotante entre 0 y 1.

Parámetros

color

El color del que obtener el valor, especificado como una de las constantes de color de Imagick. Puede ser uno de los colores RGB, colores CMYK, alfa y opacidad, p.ej. (Imagick::COLOR_BLUE, Imagick::COLOR_MAGENTA).

Valores devueltos

El valor del canal, como un número de punto flotante normalizado, lanzando una ImagickPixelException si se produce un error.

Ejemplos

Ejemplo #1 Uso básico de Imagick::getColorValue()

<?php

$color = new ImagickPixel('rgba(90%, 20%, 20%, 0.75)');

echo "El valor Alfa es ".$color->getColorValue(Imagick::COLOR_ALPHA).PHP_EOL;
echo "".PHP_EOL;
echo "El valor Rojo es ".$color->getColorValue(Imagick::COLOR_RED).PHP_EOL;
echo "El valor Verde es ".$color->getColorValue(Imagick::COLOR_GREEN).PHP_EOL;
echo "El valor Azul es ".$color->getColorValue(Imagick::COLOR_BLUE).PHP_EOL;
echo "".PHP_EOL;
echo "El valor Cian es ".$color->getColorValue(Imagick::COLOR_CYAN).PHP_EOL;
echo "El valor Magenta es ".$color->getColorValue(Imagick::COLOR_MAGENTA).PHP_EOL;
echo "El valor Amarillo es ".$color->getColorValue(Imagick::COLOR_YELLOW).PHP_EOL;
echo "El valor Negro es ".$color->getColorValue(Imagick::COLOR_BLACK).PHP_EOL;

?>

El resultado del ejemplo sería:

El valor Alfa es 0.74999618524453

El valor Rojo es 0.90000762951095
El valor Verde es 0.2
El valor Azul es 0.2

El valor Cian es 0.90000762951095
El valor Magenta es 0.2
El valor Amarillo es 0.2
El valor Negro es 0


Description

  • « ImagickPixel::getColorValue
  • ImagickPixel::getHSL »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getColorValueQuantum

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::getColorValueQuantum — Description

Descripción

public ImagickPixel::getColorValueQuantum ( ) : mixed

Obtiene el valor quantum value de un color del objeto ImagickPixel. El valor devuelto es de tipo float si ImageMagick se compiló con HDRI, o un entero en caso contrario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor quantum del elemento de color. Float si ImageMagick se compiló con HDRI, entero de lo contrario.

Ejemplos

Ejemplo #1 ImagickPixel::getColorValueQuantum()

<?php
        $color = new \ImagickPixel('rgb(128, 5, 255)');
        $colorRed = $color->getColorValueQuantum(\Imagick::COLOR_RED);
        $colorGreen = $color->getColorValueQuantum(\Imagick::COLOR_GREEN);
        $colorBlue = $color->getColorValueQuantum(\Imagick::COLOR_BLUE);
        $colorAlpha = $color->getColorValueQuantum(\Imagick::COLOR_ALPHA);

        printf(
            "Red: %s Green: %s  Blue %s Alpha: %s",
            $colorRed,
            $colorGreen,
            $colorBlue,
            $colorAlpha
        );

?>


Devuelve el color HSL normalizado del objeto ImagickPixel

  • « ImagickPixel::getColorValueQuantum
  • ImagickPixel::getIndex »
  • PHP Manual
  • ImagickPixel
  • Devuelve el color HSL normalizado del objeto ImagickPixel

ImagickPixel::getHSL

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getHSL — Devuelve el color HSL normalizado del objeto ImagickPixel

Descripción

ImagickPixel::getHSL ( ) : array

Devuelve el color HSL normalizado descrito por el objeto ImagickPixel, con cada uno de los tres valores como números de punto flotante entre 0.0 y 1.0.

Valores devueltos

Devuelve el valor de HSL en un array con las claves "hue", "saturation", y "luminosity". Lanza una ImagickPixelException en caso de error.

Ejemplos

Ejemplo #1 Uso básico de Imagick::getHSL()

<?php

$color = new ImagickPixel('rgb(90%, 10%, 10%)');

$colorInfo = $color->getHSL();

print_r($colorInfo);

?>

El resultado del ejemplo sería:

Array
(
    [hue] => 0
    [saturation] => 0.80001220740379
    [luminosity] => 0.50000762951095
)

Notas

Nota:

Disponible con la versión 6.2.9 o superior de la biblioteca ImageMagick.


Description

  • « ImagickPixel::getHSL
  • ImagickPixel::isPixelSimilar »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getIndex

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::getIndex — Description

Descripción

public ImagickPixel::getIndex ( ) : int

Obtiene el índice del mapa de color de la varita de píxeles.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Comprobar la distancia entre este color y otro

  • « ImagickPixel::getIndex
  • ImagickPixel::isPixelSimilarQuantum »
  • PHP Manual
  • ImagickPixel
  • Comprobar la distancia entre este color y otro

ImagickPixel::isPixelSimilar

(PECL imagick 3 >= 3.3.0)

ImagickPixel::isPixelSimilar — Comprobar la distancia entre este color y otro

Descripción

ImagickPixel::isPixelSimilar ( ImagickPixel $color , float $fuzz ) : bool

Comprueba la distancia entre el color descrito por este objeto ImagickPixel y el objeto proporcionado, trazando sus valores RGB en el cubo de color. Si la distancia entre dos puntos es menor que the valor del parámetro fuzz dado, los colores son similares. Este método reemplaza a ImagickPixel::isSimilar() y normaliza de forma correcta el valor de fuzz a QuantumRange de ImageMagick.

Parámetros

color

El objeto ImagickPixel a comparar con este objeto.

fuzz

La distancia máxima dentro de la que considerar que estos colores son iguales. El máximo teórico para este valor es la reíz cuadrada de tres (1.732).

Valores devueltos

Devuelve true en caso de éxito.


Description

  • « ImagickPixel::isPixelSimilar
  • ImagickPixel::isSimilar »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::isPixelSimilarQuantum

(PECL imagick 3 >= 3.3.0)

ImagickPixel::isPixelSimilarQuantum — Description

Descripción

public ImagickPixel::isPixelSimilarQuantum ( string $color , string $fuzz = ? ) : bool

Devuelve true si la distancia entre dos colores es menor que la distancia especificada. El valor de fuzz debería estar en el rango 0-QuantumRange. El valor máximo representa la mayor distancia posible en el espacio de color, p.ej., de RGB(0, 0, 0) a RGB(255, 255, 255) en el espacio de color RGB

Parámetros

color

fuzz

Valores devueltos


Comprobar la distancia entre este color y otro

  • « ImagickPixel::isPixelSimilarQuantum
  • ImagickPixel::setColor »
  • PHP Manual
  • ImagickPixel
  • Comprobar la distancia entre este color y otro

ImagickPixel::isSimilar

(PECL imagick 2, PECL imagick 3)

ImagickPixel::isSimilar — Comprobar la distancia entre este color y otro

Descripción

ImagickPixel::isSimilar ( ImagickPixel $color , float $fuzz ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Comprueba la distancia entre el color descrito por este objeto ImagickPixel y el color del objeto proporcionado, determinando sus valores RGB del cubo de colores. Si la distancia entre los dos puntos es menor que el valor de enfoque (fuzz) dado, los colores son similares. Obsoleto en favor de ImagickPixel::isPixelSimilar().

Parámetros

color

El objeto ImagickPixel a comparar con este objeto.

fuzz

La distancia máxima dentro de la cual se considera a estos colores como similares. El máximo teórico para este valor es la raíz cuadrada de tres (1.732).

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickPixel::isSimilar()

<?php
        // The tests below are written with the maximum distance expressed as 255
        // so we need to scale them by the square root of 3 - the diagonal length
        // of a unit cube.
        $root3 = 1.732050807568877;

        $tests = array(
            ['rgb(245, 0, 0)',      'rgb(255, 0, 0)',   9 / $root3,         false,],
            ['rgb(245, 0, 0)',      'rgb(255, 0, 0)',  10 / $root3,         true,],
            ['rgb(0, 0, 0)',        'rgb(7, 7, 0)',     9 / $root3,         false,],
            ['rgb(0, 0, 0)',        'rgb(7, 7, 0)',    10 / $root3,         true,],
            ['rgba(0, 0, 0, 1)',    'rgba(7, 7, 0, 1)', 9 / $root3,         false,],
            ['rgba(0, 0, 0, 1)',    'rgba(7, 7, 0, 1)',    10 / $root3,     true,],
            ['rgb(128, 128, 128)',  'rgb(128, 128, 120)',   7 / $root3,     false,],
            ['rgb(128, 128, 128)',  'rgb(128, 128, 120)',   8 / $root3,     true,],
            ['rgb(0, 0, 0)',        'rgb(255, 255, 255)',   254.9,          false,],
            ['rgb(0, 0, 0)',        'rgb(255, 255, 255)',   255,            true,],
            ['rgb(255, 0, 0)',      'rgb(0, 255, 255)',     254.9,          false,],
            ['rgb(255, 0, 0)',      'rgb(0, 255, 255)',     255,            true,],
            ['black',               'rgba(0, 0, 0)',        0.0,            true],
            ['black',               'rgba(10, 0, 0, 1.0)',  10.0 / $root3,  true],);

        $output = "<table width='100%' class='infoTable'><thead>
                <tr>
                <th>
                Color 1
                </th>
                <th>
                Color 2
                </th>
                <th>
                    Test distance * 255
                </th>
                <th>
                    Is within distance
                </th>
                </tr>
        </thead>";

        $output .= "<tbody>";

        foreach ($tests as $testInfo) {
            $color1 = $testInfo[0];
            $color2 = $testInfo[1];
            $distance = $testInfo[2];
            $expectation = $testInfo[3];
            $testDistance = ($distance / 255.0);

            $color1Pixel = new \ImagickPixel($color1);
            $color2Pixel = new \ImagickPixel($color2);

            $isSimilar = $color1Pixel->isPixelSimilar($color2Pixel, $testDistance);

            if ($isSimilar !== $expectation) {
                echo "Test distance failed. Color [$color1] compared to color [$color2] is not within distance $testDistance FAILED.".NL;
            }

            $layout = "<tr>
                <td>%s</td>
                <td>%s</td>
                <td>%s</td>
                <td style='text-align: center;'>%s</td>
            </tr>";

            $output .= sprintf(
                $layout,
                $color1,
                $color2,
                $distance,
                $isSimilar ? 'yes' : 'no'
            );
        }

        $output .= "</tbody></table>";

        return $output;

?>


Establece el color

  • « ImagickPixel::isSimilar
  • ImagickPixel::setColorCount »
  • PHP Manual
  • ImagickPixel
  • Establece el color

ImagickPixel::setColor

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColor — Establece el color

Descripción

ImagickPixel::setColor ( string $color ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el color descrito por el objeto ImagickPixel, con una cadena (p.ej. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

Parámetros

color

La definición de color a usar para inicializar el objeto ImagickPixel.

Valores devueltos

Devuelve true si el color especificado fue establecido, false si no.

Ejemplos

Ejemplo #1 ImagickPixel::setColor()

<?php
function setColor() {
    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel('green');
    $fillColor = new \ImagickPixel();
    $fillColor->setColor('rgba(100%, 75%, 0%, 1.0)');

    $draw->setstrokewidth(3.0);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, "SteelBlue2");
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Description

  • « ImagickPixel::setColor
  • ImagickPixel::setColorValue »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setColorCount

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColorCount — Description

Descripción

public ImagickPixel::setcolorcount ( string $colorCount ) : void

Establece el total del color asociada a este color.

Parámetros

colorCount

Valores devueltos


Establece el valor normalizado de uno de los canales

  • « ImagickPixel::setColorCount
  • ImagickPixel::setColorValueQuantum »
  • PHP Manual
  • ImagickPixel
  • Establece el valor normalizado de uno de los canales

ImagickPixel::setColorValue

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColorValue — Establece el valor normalizado de uno de los canales

Descripción

ImagickPixel::setColorValue ( int $color , float $value ) : bool

Establece el valor del canal especificado de este objeto al valor proporcionado, que debería estar entre 0 y 1. Esta función se puede usar para proporcionar un canal de opacidad a un objeto ImagickPixel.

Parámetros

color

Una de las constantes de color de Imagick, p.ej. \Imagick::COLOR_GREEN o \Imagick::COLOR_ALPHA.

value

El valor a establecer para este canal, desde 0 a 1.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Uso básico de Imagick::setColorValue()

<?php

$color  = new \ImagickPixel('firebrick');

$color->setColorValue(Imagick::COLOR_ALPHA, 0.5);

print_r($color->getcolor(true));
?>

El resultado del ejemplo sería:

Array
(
    [r] => 0.69803921568627
    [g] => 0.13333333333333
    [b] => 0.13333333333333
    [a] => 0.50000762951095
)


Description

  • « ImagickPixel::setColorValue
  • ImagickPixel::setHSL »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setColorValueQuantum

(PECL imagick 2 >=2.3.0, PECL imagick 3)

ImagickPixel::setColorValueQuantum — Description

Descripción

public ImagickPixel::setColorValueQuantum ( int $color , mixed $value ) : void

Establece el valor quantum de un elemento de color del objeto ImagickPixel.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

color

El color a establecer, p. ej. \Imagick::COLOR_GREEN.

value

El valor quantum a establecer para el elemento de color. Debería ser de tipo float si ImageMagick se compiló con HDRI, o, en caso contrario, un entero en el rango 0 a Imagick::getQuantum().

Valores devueltos

Ejemplos

Ejemplo #1 ImagickPixel::setColorValueQuantum()

<?php
function setColorValueQuantum() {
    $image = new \Imagick();

    $quantumRange = $image->getQuantumRange();

    $draw = new \ImagickDraw();
    $color = new \ImagickPixel('blue');
    $color->setcolorValueQuantum(\Imagick::COLOR_RED, 128 * $quantumRange['quantumRangeLong'] / 256);

    $draw->setstrokewidth(1.0);
    $draw->setStrokeColor($color);
    $draw->setFillColor($color);
    $draw->rectangle(200, 200, 300, 300);

    $image->newImage(500, 500, "SteelBlue2");
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Establece el color HSL normalizado

  • « ImagickPixel::setColorValueQuantum
  • ImagickPixel::setIndex »
  • PHP Manual
  • ImagickPixel
  • Establece el color HSL normalizado

ImagickPixel::setHSL

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setHSL — Establece el color HSL normalizado

Descripción

ImagickPixel::setHSL ( float $hue , float $saturation , float $luminosity ) : bool

Establece el color descrito por el objeto ImagickPixel usando valores normalizados para el tono, saturación y luminosidad.

Parámetros

hue

El valor normalizado del tono, descrito como un arco fraccionario (entre 0 y 1) del círculo tonal, donde el valor cero es rojo.

saturation

El valor normalizado de la saturación, con 1 como saturación completa.

luminosity

El valor normalizado de la luminosidad, en una escala desde negro con 0 a blanco con 1, con el valor completo de HS en 0.5 de luminosidad.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 Usar ImagickPixel::setHSL() para modificar un color

<?php

//Crear un color rojo casi puro
$color = new ImagickPixel('rgb(90%, 10%, 10%)');

//Obtener sus valores HSL
$colorInfo = $color->getHSL();

//Rotar el tono 180 grados
$newHue = $colorInfo['hue'] + 0.5;
if ($newHue > 1) {
    $newHue = $newHue - 1;
}

//Establecer el objeto ImagickPixel para el nuevo color
$colorInfo = $color->setHSL($newHue, $colorInfo['saturation'], $colorInfo['luminosity']);

//Comprobar que el nuevo color es azul/verde
$colorInfo = $color->getcolor();
print_r($colorInfo);

?>

El resultado del ejemplo sería:

Array
(
    [r] => 26
    [g] => 230
    [b] => 230
    [a] => 255
)

Notas

Nota:

Disponible con la versión 6.2.9 o superior de la biblioteca ImageMagick.


Description

  • « ImagickPixel::setHSL
  • ImagickPixelIterator »
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setIndex

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::setIndex — Description

Descripción

public ImagickPixel::setIndex ( int $index ) : void

Establece el índice del mapa de color de la varita de píxeles.

Parámetros

index

Valores devueltos


La clase ImagickPixelIterator

(PECL imagick 2, PECL imagick 3)

Sinopsis de la Clase

ImagickPixelIterator {
clear ( ) : bool
__construct ( Imagick $wand )
destroy ( ) : bool
getCurrentIteratorRow ( ) : array
getIteratorRow ( ) : int
getNextIteratorRow ( ) : array
getPreviousIteratorRow ( ) : array
newPixelIterator ( Imagick $wand ) : bool
newPixelRegionIterator ( Imagick $wand , int $x , int $y , int $columns , int $rows ) : bool
resetIterator ( ) : bool
setIteratorFirstRow ( ) : bool
setIteratorLastRow ( ) : bool
setIteratorRow ( int $row ) : bool
syncIterator ( ) : bool
}

Tabla de contenidos

  • ImagickPixelIterator::clear — Borra los recursos asociados con un objeto PixelIterator
  • ImagickPixelIterator::__construct — El constructor ImagickPixelIterator
  • ImagickPixelIterator::destroy — Desasigna los recursos asociacdos con un objeto PixelIterator
  • ImagickPixelIterator::getCurrentIteratorRow — Devuelve la fila actual de objetos ImagickPixel
  • ImagickPixelIterator::getIteratorRow — Devuelve la fila actual del iterador de píxel
  • ImagickPixelIterator::getNextIteratorRow — Devuelve la fila siguiente del iterador de píxel
  • ImagickPixelIterator::getPreviousIteratorRow — Devuelve la fila previa
  • ImagickPixelIterator::newPixelIterator — Devuelve un nuevo iterador de píxel
  • ImagickPixelIterator::newPixelRegionIterator — Devuelve un nuevo iterador de píxel
  • ImagickPixelIterator::resetIterator — Reinicia el iterador de píxel
  • ImagickPixelIterator::setIteratorFirstRow — Establece el iterador de píxel a la primera fila de píxeles
  • ImagickPixelIterator::setIteratorLastRow — Establece el iterador de píxel a la última fila de píxeles
  • ImagickPixelIterator::setIteratorRow — Establecer la fila del iterador de píxel
  • ImagickPixelIterator::syncIterator — Sincornizar el iterador de píxel


Borra los recursos asociados con un objeto PixelIterator

  • « ImagickPixelIterator
  • ImagickPixelIterator::__construct »
  • PHP Manual
  • ImagickPixelIterator
  • Borra los recursos asociados con un objeto PixelIterator

ImagickPixelIterator::clear

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::clear — Borra los recursos asociados con un objeto PixelIterator

Descripción

ImagickPixelIterator::clear ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Borra los recursos asociados con un objeto PixelIterator.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickPixelIterator::clear()

<?php
function clear($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));

    $imageIterator = $imagick->getPixelRegionIterator(100, 100, 250, 200);

    /* Loop through pixel rows */
    foreach ($imageIterator as $pixels) {
        /** @var $pixel \ImagickPixel */
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            if ($column % 2) {
                /* Paint every second pixel black*/
                $pixel->setColor("rgba(0, 0, 0, 0)");
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    $imageIterator->clear();

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


El constructor ImagickPixelIterator

  • « ImagickPixelIterator::clear
  • ImagickPixelIterator::destroy »
  • PHP Manual
  • ImagickPixelIterator
  • El constructor ImagickPixelIterator

ImagickPixelIterator::__construct

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::__construct — El constructor ImagickPixelIterator

Descripción

ImagickPixelIterator::__construct ( Imagick $wand )
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

El constructor de ImagickPixelIterator

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickPixelIterator::construct()

<?php
function construct($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = new \ImagickPixelIterator($imagick);

    /* Loop through pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 2) {
                /* Paint every second pixel black*/
                $pixel->setColor("rgba(0, 0, 0, 0)");
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Desasigna los recursos asociacdos con un objeto PixelIterator

  • « ImagickPixelIterator::__construct
  • ImagickPixelIterator::getCurrentIteratorRow »
  • PHP Manual
  • ImagickPixelIterator
  • Desasigna los recursos asociacdos con un objeto PixelIterator

ImagickPixelIterator::destroy

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::destroy — Desasigna los recursos asociacdos con un objeto PixelIterator

Descripción

ImagickPixelIterator::destroy ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Desasigna los recursos asociacdos con un objeto PixelIterator.

Valores devueltos

Devuelve true en caso de éxito.


Devuelve la fila actual de objetos ImagickPixel

  • « ImagickPixelIterator::destroy
  • ImagickPixelIterator::getIteratorRow »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve la fila actual de objetos ImagickPixel

ImagickPixelIterator::getCurrentIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getCurrentIteratorRow — Devuelve la fila actual de objetos ImagickPixel

Descripción

ImagickPixelIterator::getCurrentIteratorRow ( ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la fila actual como una matriz de objetos ImagickPixel desde el iterador de píxel.

Valores devueltos

Devuelve una fila como una matriz de objetos ImagickPixel que pueden ser iterados también.


Devuelve la fila actual del iterador de píxel

  • « ImagickPixelIterator::getCurrentIteratorRow
  • ImagickPixelIterator::getNextIteratorRow »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve la fila actual del iterador de píxel

ImagickPixelIterator::getIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getIteratorRow — Devuelve la fila actual del iterador de píxel

Descripción

ImagickPixelIterator::getIteratorRow ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la fila actual del iterador de píxel.

Valores devueltos

Devuelve el índice de tipo integer de la fila, lanzando una excepción ImagickPixelIteratorException si se produjo un error.


Devuelve la fila siguiente del iterador de píxel

  • « ImagickPixelIterator::getIteratorRow
  • ImagickPixelIterator::getPreviousIteratorRow »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve la fila siguiente del iterador de píxel

ImagickPixelIterator::getNextIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getNextIteratorRow — Devuelve la fila siguiente del iterador de píxel

Descripción

ImagickPixelIterator::getNextIteratorRow ( ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la fila siguientes como una matriz de varitas mágicas de píxeles desde el iterador de píxel.

Valores devueltos

Devuelve la fila siguiente como una matriz de objetos ImagickPixel, lanzando una excepción ImagickPixelIteratorException si se produjo un error.

Ejemplos

Ejemplo #1 ImagickPixelIterator::getNextIteratorRow()

<?php
function getNextIteratorRow($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelIterator();

    $count = 0;
    while ($pixels = $imageIterator->getNextIteratorRow()) {
        if (($count % 3) == 0) {
            /* Loop through the pixels in the row (columns) */
            foreach ($pixels as $column => $pixel) {
                /** @var $pixel \ImagickPixel */
                if ($column % 2) {
                    /* Paint every second pixel black*/
                    $pixel->setColor("rgba(0, 0, 0, 0)");
                }
            }
            /* Sync the iterator, this is important to do on each iteration */
            $imageIterator->syncIterator();
        }

        $count += 1;
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Devuelve la fila previa

  • « ImagickPixelIterator::getNextIteratorRow
  • ImagickPixelIterator::newPixelIterator »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve la fila previa

ImagickPixelIterator::getPreviousIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getPreviousIteratorRow — Devuelve la fila previa

Descripción

ImagickPixelIterator::getPreviousIteratorRow ( ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la fila previa como una matriz de varitas mágicas de píxeles desde el iterador de píxel.

Valores devueltos

Devuelve la fila previa como una matriz de objetos ImagickPixelWand desde ImagickPixelIterator, lanzando una excepción ImagickPixelIteratorException si se produjo un error.


Devuelve un nuevo iterador de píxel

  • « ImagickPixelIterator::getPreviousIteratorRow
  • ImagickPixelIterator::newPixelRegionIterator »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve un nuevo iterador de píxel

ImagickPixelIterator::newPixelIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::newPixelIterator — Devuelve un nuevo iterador de píxel

Descripción

ImagickPixelIterator::newPixelIterator ( Imagick $wand ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un nuevo iterador de píxel.

Valores devueltos

Devuelve true en caso de éxito. Lanzando una excepción ImagickPixelIteratorException.


Devuelve un nuevo iterador de píxel

  • « ImagickPixelIterator::newPixelIterator
  • ImagickPixelIterator::resetIterator »
  • PHP Manual
  • ImagickPixelIterator
  • Devuelve un nuevo iterador de píxel

ImagickPixelIterator::newPixelRegionIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::newPixelRegionIterator — Devuelve un nuevo iterador de píxel

Descripción

ImagickPixelIterator::newPixelRegionIterator ( Imagick $wand , int $x , int $y , int $columns , int $rows ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un nuevo iterador de píxel.

Parámetros

wand

x

y

columns

rows

Valores devueltos

Devuelve un nuevo objeto ImagickPixelIterator si se tuvo éxtio; si falló, lanza una excepción ImagickPixelIteratorException.


Reinicia el iterador de píxel

  • « ImagickPixelIterator::newPixelRegionIterator
  • ImagickPixelIterator::setIteratorFirstRow »
  • PHP Manual
  • ImagickPixelIterator
  • Reinicia el iterador de píxel

ImagickPixelIterator::resetIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::resetIterator — Reinicia el iterador de píxel

Descripción

ImagickPixelIterator::resetIterator ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Reinicia el iterador de píxel. Usar junto con ImagickPixelIterator::getNextIteratorRow() para iterar todos los píxeles en un contenedor de píxeles.

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickPixelIterator::resetIterator()

<?php
function resetIterator($imagePath) {

    $imagick = new \Imagick(realpath($imagePath));

    $imageIterator = $imagick->getPixelIterator();

    /* Loop trough pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 2) {

                /* Make every second pixel 25% red*/
                $pixel->setColorValue(\Imagick::COLOR_RED, 64);
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    $imageIterator->resetiterator();

    /* Loop trough pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 3) {
                $pixel->setColorValue(\Imagick::COLOR_BLUE, 64); /* Make every second pixel a little blue*/
                //$pixel->setColor("rgba(0, 0, 128, 0)"); /* Paint every second pixel black*/
            }
        }
        $imageIterator->syncIterator(); /* Sync the iterator, this is important to do on each iteration */
    }

    $imageIterator->clear();

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Establece el iterador de píxel a la primera fila de píxeles

  • « ImagickPixelIterator::resetIterator
  • ImagickPixelIterator::setIteratorLastRow »
  • PHP Manual
  • ImagickPixelIterator
  • Establece el iterador de píxel a la primera fila de píxeles

ImagickPixelIterator::setIteratorFirstRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorFirstRow — Establece el iterador de píxel a la primera fila de píxeles

Descripción

ImagickPixelIterator::setIteratorFirstRow ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el iterador de píxel a la primera fila de píxeles.

Valores devueltos

Devuelve true en caso de éxito.


Establece el iterador de píxel a la última fila de píxeles

  • « ImagickPixelIterator::setIteratorFirstRow
  • ImagickPixelIterator::setIteratorRow »
  • PHP Manual
  • ImagickPixelIterator
  • Establece el iterador de píxel a la última fila de píxeles

ImagickPixelIterator::setIteratorLastRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorLastRow — Establece el iterador de píxel a la última fila de píxeles

Descripción

ImagickPixelIterator::setIteratorLastRow ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece el iterador de píxel a la última fila de píxeles.

Valores devueltos

Devuelve true en caso de éxito.


Establecer la fila del iterador de píxel

  • « ImagickPixelIterator::setIteratorLastRow
  • ImagickPixelIterator::syncIterator »
  • PHP Manual
  • ImagickPixelIterator
  • Establecer la fila del iterador de píxel

ImagickPixelIterator::setIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorRow — Establecer la fila del iterador de píxel

Descripción

ImagickPixelIterator::setIteratorRow ( int $row ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece la fila del iterador de píxel.

Parámetros

row

Valores devueltos

Devuelve true en caso de éxito.

Ejemplos

Ejemplo #1 ImagickPixelIterator::setIteratorRow()

<?php
function setIteratorRow($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelRegionIterator(200, 100, 200, 200);

    for ($x = 0; $x < 20; $x++) {
        $imageIterator->setIteratorRow($x * 5);
        $pixels = $imageIterator->getCurrentIteratorRow();
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $pixel) {
            /** @var $pixel \ImagickPixel */
            /* Paint every second pixel black*/
            $pixel->setColor("rgba(0, 0, 0, 0)");
        }

        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Sincornizar el iterador de píxel

  • « ImagickPixelIterator::setIteratorRow
  • ImagickKernel »
  • PHP Manual
  • ImagickPixelIterator
  • Sincornizar el iterador de píxel

ImagickPixelIterator::syncIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::syncIterator — Sincornizar el iterador de píxel

Descripción

ImagickPixelIterator::syncIterator ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Sincroniza el iterador de píxel.

Valores devueltos

Devuelve true en caso de éxito.


La clase ImagickKernel

(PECL imagick >= 3.3.0)

Introducción

Sinopsis de la Clase

ImagickKernel {
/* Métodos */
public addKernel ( ImagickKernel $ImagickKernel ) : void
public addUnityKernel ( ) : void
public static fromBuiltin ( string $kernelType , string $kernelString ) : ImagickKernel
public static fromMatrix ( array $matrix , array $origin = ? ) : ImagickKernel
public getMatrix ( ) : array
public scale ( ) : void
public separate ( ) : array
}

Tabla de contenidos

  • ImagickKernel::addKernel — Description
  • ImagickKernel::addUnityKernel — Description
  • ImagickKernel::fromBuiltIn — Description
  • ImagickKernel::fromMatrix — Description
  • ImagickKernel::getMatrix — Description
  • ImagickKernel::scale — Description
  • ImagickKernel::separate — Description


Description

  • « ImagickKernel
  • ImagickKernel::addUnityKernel »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::addKernel

(PECL imagick >= 3.3.0)

ImagickKernel::addKernel — Description

Descripción

public ImagickKernel::addKernel ( ImagickKernel $ImagickKernel ) : void

Adjunta otro núcleo («kernel») a este para que ambos puedan aplicarse a una única función de morfología o filtro. Devuelve el nuevo núcleo combinado.

Parámetros

ImagickKernel

Valores devueltos

Ejemplos

Ejemplo #1 ImagickKernel::addKernel()

<?php
function addKernel($imagePath) {
    $matrix1 = [
        [-1, -1, -1],
        [ 0,  0,  0],
        [ 1,  1,  1],
    ];

    $matrix2 = [
        [-1,  0,  1],
        [-1,  0,  1],
        [-1,  0,  1],
    ];

    $kernel1 = ImagickKernel::fromMatrix($matrix1);
    $kernel2 = ImagickKernel::fromMatrix($matrix2);
    $kernel1->addKernel($kernel2);

    $imagick = new \Imagick(realpath($imagePath));
    $imagick->filter($kernel1);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();

}

?>


Description

  • « ImagickKernel::addKernel
  • ImagickKernel::fromBuiltIn »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::addUnityKernel

(PECL imagick >= 3.3.0)

ImagickKernel::addUnityKernel — Description

Descripción

public ImagickKernel::addUnityKernel ( ) : void

Añade una cantidad dada de Núcleo de Convolución 'Unidad' al núcleo («kernel») preescalado y normalizado dado. En efecto, esto añade dicha cantidad de la imagen original al núcleo de convolución resultante. El efecto resultante es convertir los núcleos definidos a núcleos no nítidos con una suave borrosidad o a núcleos nítidos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 ImagickKernel::addUnityKernel()

<?php

    function renderKernelTable($matrix) {
        $output = "<table class='infoTable'>";

        foreach ($matrix as $row) {
            $output .= "<tr>";
            foreach ($row as $cell) {
                $output .= "<td style='text-align:left'>";
                if ($cell === false) {
                    $output .= "false";
                }
                else {
                    $output .= round($cell, 3);
                }
                $output .= "</td>";
            }
            $output .= "</tr>";
        }

        $output .= "</table>";

        return $output;
    }

    $matrix = [
        [-1, 0, -1],
        [ 0, 4,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $kernel->scale(1, \Imagick::NORMALIZE_KERNEL_VALUE);
    $output = "Before adding unity kernel: <br/>";
    $output .= renderKernelTable($kernel->getMatrix());
    $kernel->addUnityKernel(0.5);
    $output .= "After adding unity kernel: <br/>";
    $output .= renderKernelTable($kernel->getMatrix());

    $kernel->scale(1, \Imagick::NORMALIZE_KERNEL_VALUE);
    $output .= "After renormalizing kernel: <br/>";
    $output .= renderKernelTable($kernel->getMatrix());

    echo $output;

?>

Ejemplo #2 ImagickKernel::addUnityKernel()

<?php
function addUnityKernel($imagePath) {

    $matrix = [
        [-1, 0, -1],
        [ 0, 4,  0],
        [-1, 0, -1],
    ];

    $kernel = ImagickKernel::fromMatrix($matrix);

    $kernel->scale(4, \Imagick::NORMALIZE_KERNEL_VALUE);
    $kernel->addUnityKernel(0.5);

    $imagick = new \Imagick(realpath($imagePath));
    $imagick->filter($kernel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();

}

?>


Description

  • « ImagickKernel::addUnityKernel
  • ImagickKernel::fromMatrix »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::fromBuiltIn

(PECL imagick >= 3.3.0)

ImagickKernel::fromBuiltIn — Description

Descripción

public static ImagickKernel::fromBuiltin ( string $kernelType , string $kernelString ) : ImagickKernel

Crea un núcleo («kernel») desde uno integrado. Veáse http://www.imagemagick.org/Usage/morphology/#kernel para algunos ejemplos. Actualmente no están admitidos los símbolos de 'rotación'. Ejemplo: $diamondKernel = ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DIAMOND, "2");

Parámetros

kerneltype

El tipo de núcleo a construir, p.ej., \Imagick::KERNEL_DIAMOND

kernelString

Una cadena que describe los parámetros, p.ej., "4,2.5"

Valores devueltos

Ejemplos

Ejemplo #1 ImagickKernel::fromBuiltin()

<?php

function renderKernel(ImagickKernel $imagickKernel) {
    $matrix = $imagickKernel->getMatrix();

    $imageMargin = 20;

    $tileSize = 20;
    $tileSpace = 4;
    $shadowSigma = 4;
    $shadowDropX = 20;
    $shadowDropY = 0;

    $radius = ($tileSize / 2) * 0.9;

    $rows = count($matrix);
    $columns = count($matrix[0]);

    $imagickDraw = new \ImagickDraw();

    $imagickDraw->setFillColor('#afafaf');
    $imagickDraw->setStrokeColor('none');

    $imagickDraw->translate($imageMargin, $imageMargin);
    $imagickDraw->push();

    ksort($matrix);

    foreach ($matrix as $row) {
        ksort($row);
        $imagickDraw->push();
        foreach ($row as $cell) {
            if ($cell !== false) {
                $color = intval(255 * $cell);
                $colorString = sprintf("rgb(%f, %f, %f)", $color, $color, $color);
                $imagickDraw->setFillColor($colorString);
                $imagickDraw->rectangle(0, 0, $tileSize, $tileSize);
            }
            $imagickDraw->translate(($tileSize + $tileSpace), 0);
        }
        $imagickDraw->pop();
        $imagickDraw->translate(0, ($tileSize + $tileSpace));
    }

    $imagickDraw->pop();

    $width = ($columns * $tileSize) + (($columns - 1) * $tileSpace);
    $height = ($rows * $tileSize) + (($rows - 1) * $tileSpace);

    $imagickDraw->push();
    $imagickDraw->translate($width/2 , $height/2);
    $imagickDraw->setFillColor('rgba(0, 0, 0, 0)');
    $imagickDraw->setStrokeColor('white');
    $imagickDraw->circle(0, 0, $radius - 1, 0);
    $imagickDraw->setStrokeColor('black');
    $imagickDraw->circle(0, 0, $radius, 0);
    $imagickDraw->pop();

    $canvasWidth = $width + (2 * $imageMargin);
    $canvasHeight = $height + (2 * $imageMargin);

    $kernel = new \Imagick();
    $kernel->newPseudoImage(
        $canvasWidth,
        $canvasHeight,
        'canvas:none'
    );

    $kernel->setImageFormat('png');
    $kernel->drawImage($imagickDraw);

    /* crear una sombra paralela en su misma capa */
    $canvas = $kernel->clone();
    $canvas->setImageBackgroundColor(new \ImagickPixel('rgb(0, 0, 0)'));
    $canvas->shadowImage(100, $shadowSigma, $shadowDropX, $shadowDropY);

    $canvas->setImagePage($canvasWidth, $canvasHeight, -5, -5);
    $canvas->cropImage($canvasWidth, $canvasHeight, 0, 0);

    /* componer la capa de texto original con shadow_layer */
    $canvas->compositeImage($kernel, \Imagick::COMPOSITE_OVER, 0, 0);
    $canvas->setImageFormat('png');

    return $canvas;
}

function createFromBuiltin($kernelType, $kernelFirstTerm, $kernelSecondTerm, $kernelThirdTerm) {
    $string = '';

    if ($kernelFirstTerm != false && strlen(trim($kernelFirstTerm)) != 0) {
        $string .= $kernelFirstTerm;

        if ($kernelSecondTerm != false && strlen(trim($kernelSecondTerm)) != 0) {
            $string .= ','.$kernelSecondTerm;
            if ($kernelThirdTerm != false && strlen(trim($kernelThirdTerm)) != 0) {
                $string .= ','.$kernelThirdTerm;
            }
        }
    }

    $kernel = ImagickKernel::fromBuiltIn(
        $kernelType,
        $string
    );

    return $kernel;
}

function fromBuiltin($kernelType, $kernelFirstTerm, $kernelSecondTerm, $kernelThirdTerm) {
    $diamondKernel = createFromBuiltin($kernelType, $kernelFirstTerm, $kernelSecondTerm, $kernelThirdTerm);
    $imagick = renderKernel($diamondKernel);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

fromBuiltin(\Imagick::KERNEL_DIAMOND, 2, false, false);

?>


Description

  • « ImagickKernel::fromBuiltIn
  • ImagickKernel::getMatrix »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::fromMatrix

(PECL imagick >= 3.3.0)

ImagickKernel::fromMatrix — Description

Descripción

public static ImagickKernel::fromMatrix ( array $matrix , array $origin = ? ) : ImagickKernel

Crea un núcleo («kernel») desde una matriz 2D de valore. Cada balor debería ser o bien de tipo float (si el elemento debería utilizarse) o bien 'false' si el elemento debería saltarse. Para matrices que son de tamaño impar en ambas dimensiones, el píxel de origen será el centro del núcleo. Para todos los demás tamaños de núcleos, el píxel de origen será especificado.

Parámetros

array

Una matriz (esto es, un array 2D) de valores que definen el núlceo. Cada elemento debería ser o bien un valor de tipo float o FALSE si el elemento no debería ser empleado por el núcleo.

array

El elemento del núcleo que debería utilizarse como píxel de origen. P.ej., para una matriz de 3x3, indicar el origen como [2, 2] especificaría que el elemento inferior derecho sería el píxel de origen.

Valores devueltos

El objeto ImagickKernel generado.

Ejemplos

Ejemplo #1 ImagickKernel::fromMatrix()

<?php

function renderKernel(ImagickKernel $imagickKernel) {
    $matrix = $imagickKernel->getMatrix();

    $imageMargin = 20;

    $tileSize = 20;
    $tileSpace = 4;
    $shadowSigma = 4;
    $shadowDropX = 20;
    $shadowDropY = 0;

    $radius = ($tileSize / 2) * 0.9;

    $rows = count($matrix);
    $columns = count($matrix[0]);

    $imagickDraw = new \ImagickDraw();

    $imagickDraw->setFillColor('#afafaf');
    $imagickDraw->setStrokeColor('none');

    $imagickDraw->translate($imageMargin, $imageMargin);
    $imagickDraw->push();

    ksort($matrix);

    foreach ($matrix as $row) {
        ksort($row);
        $imagickDraw->push();
        foreach ($row as $cell) {
            if ($cell !== false) {
                $color = intval(255 * $cell);
                $colorString = sprintf("rgb(%f, %f, %f)", $color, $color, $color);
                $imagickDraw->setFillColor($colorString);
                $imagickDraw->rectangle(0, 0, $tileSize, $tileSize);
            }
            $imagickDraw->translate(($tileSize + $tileSpace), 0);
        }
        $imagickDraw->pop();
        $imagickDraw->translate(0, ($tileSize + $tileSpace));
    }

    $imagickDraw->pop();

    $width = ($columns * $tileSize) + (($columns - 1) * $tileSpace);
    $height = ($rows * $tileSize) + (($rows - 1) * $tileSpace);

    $imagickDraw->push();
    $imagickDraw->translate($width/2 , $height/2);
    $imagickDraw->setFillColor('rgba(0, 0, 0, 0)');
    $imagickDraw->setStrokeColor('white');
    $imagickDraw->circle(0, 0, $radius - 1, 0);
    $imagickDraw->setStrokeColor('black');
    $imagickDraw->circle(0, 0, $radius, 0);
    $imagickDraw->pop();

    $canvasWidth = $width + (2 * $imageMargin);
    $canvasHeight = $height + (2 * $imageMargin);

    $kernel = new \Imagick();
    $kernel->newPseudoImage(
        $canvasWidth,
        $canvasHeight,
        'canvas:none'
    );

    $kernel->setImageFormat('png');
    $kernel->drawImage($imagickDraw);

    /* crear una sombra paralela en su misma capa */
    $canvas = $kernel->clone();
    $canvas->setImageBackgroundColor(new \ImagickPixel('rgb(0, 0, 0)'));
    $canvas->shadowImage(100, $shadowSigma, $shadowDropX, $shadowDropY);

    $canvas->setImagePage($canvasWidth, $canvasHeight, -5, -5);
    $canvas->cropImage($canvasWidth, $canvasHeight, 0, 0);

    /* componer la capa de texto original con shadow_layer */
    $canvas->compositeImage($kernel, \Imagick::COMPOSITE_OVER, 0, 0);
    $canvas->setImageFormat('png');

    return $canvas;
}

function createFromMatrix() {
    $matrix = [
        [0.5, 0, 0.2],
        [0, 1, 0],
        [0.9, 0, false],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);

    return $kernel;
}

function fromMatrix() {
    $kernel = createFromMatrix();
    $imagick = renderKernel($kernel);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Description

  • « ImagickKernel::fromMatrix
  • ImagickKernel::scale »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::getMatrix

(PECL imagick >= 3.3.0)

ImagickKernel::getMatrix — Description

Descripción

public ImagickKernel::getMatrix ( ) : array

Obtiene la matriz 2D de valores empleados en este núcleo («kernel»). Los elementos son o del tipo float para elementos que se emplean, o 'false' si el elemento debería omitirse.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una matriz (array 2D) de los valores que representan el núcleo.

Ejemplos

Ejemplo #1 ImagickKernel::getMatrix()

<?php

function renderKernelTable($matrix) {
    $output = "<table class='infoTable'>";

    foreach ($matrix as $row) {
        $output .= "<tr>";
        foreach ($row as $cell) {
            $output .= "<td style='text-align:left'>";
            if ($cell === false) {
                $output .= "false";
            }
            else {
                $output .= round($cell, 3);
            }
            $output .= "</td>";
        }
        $output .= "</tr>";
    }

    $output .= "</table>";

    return $output;
}

    $output = "The built-in kernel name 'ring' with parameters of '2,3.5':<br/>";
    $kernel = \ImagickKernel::fromBuiltIn(
        \Imagick::KERNEL_RING,
        "2,3.5"
    );
    $matrix = $kernel->getMatrix();
    $output .= renderKernelTable($matrix);

    echo $output;

?>


Description

  • « ImagickKernel::getMatrix
  • ImagickKernel::separate »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::scale

(PECL imagick >= 3.3.0)

ImagickKernel::scale — Description

Descripción

public ImagickKernel::scale ( ) : void

ScaleKernelInfo() escala la lista de núcleos («kernels») dada por la cantidad proporcionada, con o sin normalización de la suma de los valores de los núcleos (según las banderas dadas). El comportamiento exacto de esta función depende del tipo de normalización empleada. Para más detalles, véase http://www.imagemagick.org/api/morphology.php#ScaleKernelInfo. La banderas debería se Imagick::NORMALIZE_KERNEL_VALUE, Imagick::NORMALIZE_KERNEL_CORRELATE, Imagick::NORMALIZE_KERNEL_PERCENT o no estar establecida.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 ImagickKernel::scale()

<?php

    function renderKernelTable($matrix) {
        $output = "<table class='infoTable'>";

        foreach ($matrix as $row) {
            $output .= "<tr>";
            foreach ($row as $cell) {
                $output .= "<td style='text-align:left'>";
                if ($cell === false) {
                    $output .= "false";
                }
                else {
                    $output .= round($cell, 3);
                }
                $output .= "</td>";
            }
            $output .= "</tr>";
        }

        $output .= "</table>";

        return $output;
    }

    $output = "";

    $matrix = [
        [-1, 0, -1],
        [ 0, 4,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $kernelClone = clone $kernel;

    $output .= "Start kernel<br/>";
    $output .= renderKernelTable($kernel->getMatrix());

    $output .= "Scaling with NORMALIZE_KERNEL_VALUE. The  <br/>";
    $kernel->scale(2, \Imagick::NORMALIZE_KERNEL_VALUE);
    $output .= renderKernelTable($kernel->getMatrix());

    $kernel = clone $kernelClone;
    $output .= "Scaling by percent<br/>";
    $kernel->scale(2, \Imagick::NORMALIZE_KERNEL_PERCENT);
    $output .= renderKernelTable($kernel->getMatrix());

    $matrix2 = [
        [-1, -1, 1],
        [ -1, false,  1],
        [1, 1, 1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix2);
    $output .= "Scaling by correlate<br/>";
    $kernel->scale(1, \Imagick::NORMALIZE_KERNEL_CORRELATE);
    $output .= renderKernelTable($kernel->getMatrix());

    return $output;
?>


Description

  • « ImagickKernel::scale
  • Extensiones relacionadas con Email »
  • PHP Manual
  • ImagickKernel
  • Description

ImagickKernel::separate

(PECL imagick >= 3.3.0)

ImagickKernel::separate — Description

Descripción

public ImagickKernel::separate ( ) : array

Divide un conjunto enlazado de núcleos («kernels») y devuelve un array de ImagickKernels.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 ImagickKernel::separate()

<?php

    function renderKernelTable($matrix) {

        $output = "<table class='infoTable'>";
        foreach ($matrix as $row) {
            $output .= "<tr>";
            foreach ($row as $cell) {
                $output .= "<td style='text-align:left'>";
                if ($cell === false) {
                    $output .= "false";
                }
                else {
                    $output .= round($cell, 3);
                }
                $output .= "</td>";
            }
            $output .= "</tr>";
        }

        $output .= "</table>";

        return $output;
    }

    $matrix = [
        [-1, 0, -1],
        [ 0, 4,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $kernel->scale(4, \Imagick::NORMALIZE_KERNEL_VALUE);
    $diamondKernel = \ImagickKernel::fromBuiltIn(
        \Imagick::KERNEL_DIAMOND,
        "2"
    );

    $kernel->addKernel($diamondKernel);

    $kernelList = $kernel->separate();

    $output = '';
    $count = 0;
    foreach ($kernelList as $kernel) {
        $output .= "<br/>Kernel $count<br/>";
        $output .= renderKernelTable($kernel->getMatrix());
        $count++;
    }

    return $output;

?>


Extensiones relacionadas con Email

  • IMAP — IMAP, POP3 y NNTP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de IMAP
  • Mail
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de mail
  • Mailparse
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones Mailparse


IMAP, POP3 y NNTP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de IMAP
    • imap_8bit — Convertir una cadena 8bit a una cadena quoted-printable
    • imap_alerts — Devuelve todos los mensajes de alerte de IMAP que han sucedido
    • imap_append — Añadir un mensaje de cadena a un buzón especificado
    • imap_base64 — Decodificar un texto cifrado con BASE64
    • imap_binary — Convertir una cadena 8bit a una cadena base64
    • imap_body — Leer el cuerpo del mensaje
    • imap_bodystruct — Leer la estructura de una sección del cuerpo especificado de un mensaje especificado
    • imap_check — Comprobar el buzón actual
    • imap_clearflag_full — Limpia las banderas de mensajes
    • imap_close — Cerrar una secuencia IMAP
    • imap_create — Alias de imap_createmailbox
    • imap_createmailbox — Crear un nuevo buzón de correo
    • imap_delete — Marcar un mensaje para su borrado del buzón actual
    • imap_deletemailbox — Elimina un buzón
    • imap_errors — Devuelve todos los errores de IMAP que han ocurrido
    • imap_expunge — Borra todos los mensajes marcados para eliminación
    • imap_fetch_overview — Leer una visión general de la información de las cabeceras del mensaje dado
    • imap_fetchbody — Traer una sección en particular del cuerpo del mensaje
    • imap_fetchheader — Devolver la cabecera de un mensaje
    • imap_fetchmime — Obtener las cabeceras MIME para una sección en particular del mensaje
    • imap_fetchstructure — Leer la estructura de un mensaje en particular
    • imap_fetchtext — Alias de imap_body
    • imap_gc — Limpia la caché de IMAP
    • imap_get_quota — Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón
    • imap_get_quotaroot — Obtener la cuota de ajustes por usuario
    • imap_getacl — Obtiene el ACL para un buzón dado
    • imap_getmailboxes — Leer la lista de buzones, devolviendo información detallada de cada uno
    • imap_getsubscribed — Listar todos los buzones suscritos
    • imap_header — Alias de imap_headerinfo
    • imap_headerinfo — Leer la cabecera del mensaje
    • imap_headers — Devuelve las cabeceras de todos los mensajes de un buzón
    • imap_last_error — Obtiene el último error de IMAP que ocurrió durante esta petición de página
    • imap_list — Leer la lista de buzones
    • imap_listmailbox — Alias de imap_list
    • imap_listscan — Devuelve la lista de buzones que coinciden con el texto dado
    • imap_listsubscribed — Alias de imap_lsub
    • imap_lsub — Listar todos los buzones suscritos
    • imap_mail_compose — Crear un mensaje MIME basado en las secciones sobre y cuerpo
    • imap_mail_copy — Copiar los mensajes especificados a un buzón
    • imap_mail_move — Mover los mensajes especificados a un buzón
    • imap_mail — Enviar un mensaje de correo electrónico
    • imap_mailboxmsginfo — Obtener información sobre el buzón actual
    • imap_mime_header_decode — Decodificar los elementos de la cabecera MIME
    • imap_msgno — Obtiene el número de secuencia de mensaje para el UID dado
    • imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8
    • imap_num_msg — Obtiene el número de mensajes del buzón actual
    • imap_num_recent — Obtiene el número de mensajes recientes en el buzón actual
    • imap_open — Abrir un flujo IMAP a un buzón
    • imap_ping — Comprobar si el flujo de IMAP está aún activo
    • imap_qprint — Convertir una cadena imprimible entrecomillada a una cadena de 8 bits
    • imap_rename — Alias de imap_renamemailbox
    • imap_renamemailbox — Renombrar un buzón antiguo a un buzón nuevo
    • imap_reopen — Reabrir un flujo IMAP hacia un nuevo buzón
    • imap_rfc822_parse_adrlist — Analiza una cadena de dirección
    • imap_rfc822_parse_headers — Analizar cabeceras de correo desde una cadena
    • imap_rfc822_write_address — Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal
    • imap_savebody — Guardar una sección del cuerpo específica en un fichero
    • imap_scan — Alias de imap_listscan
    • imap_scanmailbox — Alias de imap_listscan
    • imap_search — Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado
    • imap_set_quota — Establece una cuota para un buzón dado
    • imap_setacl — Establece el ACL para el buzón dado
    • imap_setflag_full — Establece banderas en mensajes
    • imap_sort — Obtiene y ordena mensajes
    • imap_status — Devuelve la información de estado de un buzón
    • imap_subscribe — Suscribirse a un buzón
    • imap_thread — Devuelve un árbol de mensajes hilados
    • imap_timeout — Establece o obtiene el tiempo de espera de imap
    • imap_uid — Esta función devuelve el UID del número de secuencia del mensaje dado
    • imap_undelete — Desmarcar el mensaje que está marcado para borrar
    • imap_unsubscribe — Cancelar la inscripción de un buzón
    • imap_utf7_decode — Decodifica una cadena codificada con UTF-7 modificado
    • imap_utf7_encode — Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado
    • imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7
    • imap_utf8 — Convierte texto codificado MIME en UTF-8


Introducción

Estas funciones permiten operar con el protocolo IMAP, así como con los protocolos NNTP y POP3, y los métodos de acceso al buzón local.

Sin embargo, se advierte que algunas funciones de IMAP no funcionarán correctamente con el protocolo POP.


Requerimientos

Esta extensión requiere la instalación de la biblioteca c-client. Descargue la última versión desde » https://github.com/uw-imap/imap y compílela.

Es importante que no copie los ficheros fuente de IMAP directamente en el directorio de inclusión del sistema ya que puede haber conflictos. En su lugar, cree un nuevo directorio dentro del directorio de inclusión del sistema, tal como /usr/local/imap-2000b/ (la ubicación y el nombre depende de su configuración y versión de IMAP), y dentro de este nuevo directorio cree unos directorios adicionales llamados lib/ e include/. Desde el directorio de c-client del árbol fuente de IMAP, copie todos los ficheros *.h en include/ y todos los ficheros *.c en lib/. Además, cuando compile IMAP, se creará un fichero llamado c-client.a. Póngalo también en el directorio lib/, pero renómbrelo como libc-client.a.

Nota:

Para construir la biblioteca c-client con soporte para SSL y/o Kerberos, lea los documentos proporcionados con el paquete.

Nota: En Mandrake Linux, la biblioteca IMAP (libc-client.a) es compilada sin soporte para Kerberos. Se instala una versión diferente con SSL (client-PHP4.a). La biblioteca debe ser compilada para añadir soporte para Kerberos.


Instalación

Para que estas funciones funcionen, tiene que compilar PHP con --with-imap[=DIR], donde DIR es el prefijo de instalación de c-client. De nuestro ejemplo anterior, se usaría --with-imap=/usr/local/imap-2000b. Esta ubicación depende de dónde creó este directorio según la descripción de arriba. Los usuarios de Windows pueden incluir la DLL php_imap.dll en php.ini.

IMAP no está soportado en sistemas anteriores a Windows 2000. Esto es porque usa funciones de encriptación para habilitar conexiones SSL a los servidores de correo.

Nota: Dependiendo de cómo se configuró c-client, también podría necesitar añadir --with-imap-ssl=/path/to/openssl/ y/o --with-kerberos=/path/to/kerberos a la línea de configure de PHP.

Advertencia

Las extensiones IMAP, recode y YAZ no se pueden usar en conjunto, debido a que ambas utilizan el mismo símbolo interno. Anotación: Yaz 2.0 y versiones superiores no tienen este problema..


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

IMAP Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
imap.enable_insecure_rsh | "0" | PHP_INI_SYSTEM | Available as of PHP 7.1.25, 7.2.13 and 7.3.0. Formerly, it was implicitly enabled.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

imap.enable_insecure_rsh boolean

Establishing a connection to a server may invoke rsh or ssh commands, unless this php.ini option is disabled.

Advertencia

Neither PHP nor the IMAP library filter mailbox names before passing them to rsh or ssh commands, thus passing untrusted data to this function without disabling this php.ini option is insecure.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

NIL (integer)
OP_DEBUG (integer)
OP_READONLY (integer)
Abrir el buzón sólo lectura
OP_ANONYMOUS (integer)
No usar o actualizar un .newsrc para noticias (sólo NNTP)
OP_SHORTCACHE (integer)
OP_SILENT (integer)
OP_PROTOTYPE (integer)
OP_HALFOPEN (integer)
Para nombres IMAP y NNTP, abre una conexion, pero no abre un buzón.
OP_EXPUNGE (integer)
OP_SECURE (integer)
CL_EXPUNGE (integer)
Expurga el buzón silenciosamente antes de cerralo al llamar a imap_close()
FT_UID (integer)
El parámetro es un UID
FT_PEEK (integer)
No establece la bandera \Seen flag si no está establecida ya
FT_NOT (integer)
FT_INTERNAL (integer)
La cadena devuelta está en formato interno, no se canonizará a CRLF.
FT_PREFETCHTEXT (integer)
ST_UID (integer)
El argumento secuenciado contiene UIDs en vez números secuenciados
ST_SILENT (integer)
ST_SET (integer)
CP_UID (integer)
Los números secuenciados contienen UIDS
CP_MOVE (integer)
Borra los mensajes del buzón actual después de copiarlos con imap_mail_copy()
SE_UID (integer)
Devuelve UIDs en vez de números secuenciados.
SE_FREE (integer)
SE_NOPREFETCH (integer)
No preobtiene mensajes buscados
SO_FREE (integer)
SO_NOSERVER (integer)
SA_MESSAGES (integer)
SA_RECENT (integer)
SA_UNSEEN (integer)
SA_UIDNEXT (integer)
SA_UIDVALIDITY (integer)
SA_ALL (integer)
LATT_NOINFERIORS (integer)
Este buzón no tiene "hijos" (no hay buzones debajo de éste).
LATT_NOSELECT (integer)
Esto es sólo un contenedor, no un buzón - no puede abrirlo.
LATT_MARKED (integer)
El buzón es marcado. Usada únicamente por UW-IMAPD.
LATT_UNMARKED (integer)
El buzón no es marcado. Usada únicamente por UW-IMAPD.
SORTDATE (integer)
Criterio de ordenación para imap_sort(): fecha del mensaje
SORTARRIVAL (integer)
Criterio de ordenación para imap_sort(): fecha de llegada
SORTFROM (integer)
Criterio de ordenación para imap_sort(): buzón en la primera dirección De
SORTSUBJECT (integer)
Criterio de ordenación para imap_sort(): sujeto del mensaje
SORTTO (integer)
Criterio de ordenación para imap_sort(): buzón en la primera dirección Para
SORTCC (integer)
Criterio de ordenación para imap_sort(): buzón en la primera dirección CC
SORTSIZE (integer)
Criterio de ordenación para imap_sort(): tamaño del mensaje en octetos
TYPETEXT (integer)
Tipo principal del cuerpo: texto sin formato
TYPEMULTIPART (integer)
Tipo principal del cuerpo: multiparte
TYPEMESSAGE (integer)
Tipo principal del cuerpo: mensaje encapsulado
TYPEAPPLICATION (integer)
Tipo principal del cuerpo: datos de aplicación
TYPEAUDIO (integer)
Tipo principal del cuerpo: audio
TYPEIMAGE (integer)
Tipo principal del cuerpo: imagen estática
TYPEVIDEO (integer)
Tipo principal del cuerpo: vídeo
TYPEMODEL (integer)
Tipo principal del cuerpo: modelo
TYPEOTHER (integer)
Tipo principal del cuerpo: desconocido
ENC7BIT (integer)
Codificación del cuerpo: datos semáticos de SMTP de 7 bit
ENC8BIT (integer)
Codificación del cuerpo: datos semáticos de SMTP de 8 bit
ENCBINARY (integer)
Codificación del cuerpo: datos binarios de 8 bit
ENCBASE64 (integer)
Codificación del cuerpo: datos codificados en base-64
ENCQUOTEDPRINTABLE (integer)
Codificación del cuerpo: datos de 8 bit como 7 bit legible por humanos
ENCOTHER (integer)
Codificación del cuerpo: desconocida
IMAP_OPENTIMEOUT (integer)
IMAP_READTIMEOUT (integer)
IMAP_WRITETIMEOUT (integer)
IMAP_CLOSETIMEOUT (integer)
LATT_REFERRAL (integer)
LATT_HASCHILDREN (integer)
LATT_HASNOCHILDREN (integer)
IMAP_GC_ELT (integer)
Recolector de basura, limpia los elementos en la caché de mensajes.
IMAP_GC_ENV (integer)
Recolector de basura, limpia los sobres y los cuerpos.
IMAP_GC_TEXTS (integer)
Recolector de basura, limpia el texto.


Funciones de IMAP

Ver también

Este documento no entra en detalle de todos los tópicos competentes a las funciones proporcionadas. Se proporciona más información en la documentación de la biblioteca fuente c-client (docs/internal.txt). y en los siguientes documentos RFC:

  • » RFC2821: Simple Mail Transfer Protocol (SMTP).
  • » RFC2822: Standard for ARPA internet text messages.
  • » RFC2060: Internet Message Access Protocol (IMAP) Version 4rev1.
  • » RFC1939: Post Office Protocol Version 3 (POP3).
  • » RFC977: Network News Transfer Protocol (NNTP).
  • » RFC2076: Common Internet Message Headers.
  • » RFC2045 , » RFC2046 , » RFC2047 , » RFC2048 & » RFC2049: Multipurpose Internet Mail Extensions (MIME).
También está disponible una visión general detallada en los libros » Programming Internet Email por David Wood y » Managing IMAP por Dianna Mullet & Kevin Mullet.

Tabla de contenidos

  • imap_8bit — Convertir una cadena 8bit a una cadena quoted-printable
  • imap_alerts — Devuelve todos los mensajes de alerte de IMAP que han sucedido
  • imap_append — Añadir un mensaje de cadena a un buzón especificado
  • imap_base64 — Decodificar un texto cifrado con BASE64
  • imap_binary — Convertir una cadena 8bit a una cadena base64
  • imap_body — Leer el cuerpo del mensaje
  • imap_bodystruct — Leer la estructura de una sección del cuerpo especificado de un mensaje especificado
  • imap_check — Comprobar el buzón actual
  • imap_clearflag_full — Limpia las banderas de mensajes
  • imap_close — Cerrar una secuencia IMAP
  • imap_create — Alias de imap_createmailbox
  • imap_createmailbox — Crear un nuevo buzón de correo
  • imap_delete — Marcar un mensaje para su borrado del buzón actual
  • imap_deletemailbox — Elimina un buzón
  • imap_errors — Devuelve todos los errores de IMAP que han ocurrido
  • imap_expunge — Borra todos los mensajes marcados para eliminación
  • imap_fetch_overview — Leer una visión general de la información de las cabeceras del mensaje dado
  • imap_fetchbody — Traer una sección en particular del cuerpo del mensaje
  • imap_fetchheader — Devolver la cabecera de un mensaje
  • imap_fetchmime — Obtener las cabeceras MIME para una sección en particular del mensaje
  • imap_fetchstructure — Leer la estructura de un mensaje en particular
  • imap_fetchtext — Alias de imap_body
  • imap_gc — Limpia la caché de IMAP
  • imap_get_quota — Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón
  • imap_get_quotaroot — Obtener la cuota de ajustes por usuario
  • imap_getacl — Obtiene el ACL para un buzón dado
  • imap_getmailboxes — Leer la lista de buzones, devolviendo información detallada de cada uno
  • imap_getsubscribed — Listar todos los buzones suscritos
  • imap_header — Alias de imap_headerinfo
  • imap_headerinfo — Leer la cabecera del mensaje
  • imap_headers — Devuelve las cabeceras de todos los mensajes de un buzón
  • imap_last_error — Obtiene el último error de IMAP que ocurrió durante esta petición de página
  • imap_list — Leer la lista de buzones
  • imap_listmailbox — Alias de imap_list
  • imap_listscan — Devuelve la lista de buzones que coinciden con el texto dado
  • imap_listsubscribed — Alias de imap_lsub
  • imap_lsub — Listar todos los buzones suscritos
  • imap_mail_compose — Crear un mensaje MIME basado en las secciones sobre y cuerpo
  • imap_mail_copy — Copiar los mensajes especificados a un buzón
  • imap_mail_move — Mover los mensajes especificados a un buzón
  • imap_mail — Enviar un mensaje de correo electrónico
  • imap_mailboxmsginfo — Obtener información sobre el buzón actual
  • imap_mime_header_decode — Decodificar los elementos de la cabecera MIME
  • imap_msgno — Obtiene el número de secuencia de mensaje para el UID dado
  • imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8
  • imap_num_msg — Obtiene el número de mensajes del buzón actual
  • imap_num_recent — Obtiene el número de mensajes recientes en el buzón actual
  • imap_open — Abrir un flujo IMAP a un buzón
  • imap_ping — Comprobar si el flujo de IMAP está aún activo
  • imap_qprint — Convertir una cadena imprimible entrecomillada a una cadena de 8 bits
  • imap_rename — Alias de imap_renamemailbox
  • imap_renamemailbox — Renombrar un buzón antiguo a un buzón nuevo
  • imap_reopen — Reabrir un flujo IMAP hacia un nuevo buzón
  • imap_rfc822_parse_adrlist — Analiza una cadena de dirección
  • imap_rfc822_parse_headers — Analizar cabeceras de correo desde una cadena
  • imap_rfc822_write_address — Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal
  • imap_savebody — Guardar una sección del cuerpo específica en un fichero
  • imap_scan — Alias de imap_listscan
  • imap_scanmailbox — Alias de imap_listscan
  • imap_search — Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado
  • imap_set_quota — Establece una cuota para un buzón dado
  • imap_setacl — Establece el ACL para el buzón dado
  • imap_setflag_full — Establece banderas en mensajes
  • imap_sort — Obtiene y ordena mensajes
  • imap_status — Devuelve la información de estado de un buzón
  • imap_subscribe — Suscribirse a un buzón
  • imap_thread — Devuelve un árbol de mensajes hilados
  • imap_timeout — Establece o obtiene el tiempo de espera de imap
  • imap_uid — Esta función devuelve el UID del número de secuencia del mensaje dado
  • imap_undelete — Desmarcar el mensaje que está marcado para borrar
  • imap_unsubscribe — Cancelar la inscripción de un buzón
  • imap_utf7_decode — Decodifica una cadena codificada con UTF-7 modificado
  • imap_utf7_encode — Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado
  • imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7
  • imap_utf8 — Convierte texto codificado MIME en UTF-8


Convertir una cadena 8bit a una cadena quoted-printable

  • « Funciones de IMAP
  • imap_alerts »
  • PHP Manual
  • Funciones de IMAP
  • Convertir una cadena 8bit a una cadena quoted-printable

imap_8bit

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_8bit — Convertir una cadena 8bit a una cadena quoted-printable

Descripción

imap_8bit ( string $string ) : string

Convertir una cadena 8bit a una cadena quoted-printable (de acuerdo a su definición en » RFC2045, sección 6.7).

Parámetros

string

La cadena 8bit a convertir

Valores devueltos

Devuelve una cadena codificada con el método quoted-printable.

Ver también

  • imap_qprint() - Convertir una cadena imprimible entrecomillada a una cadena de 8 bits


Devuelve todos los mensajes de alerte de IMAP que han sucedido

  • « imap_8bit
  • imap_append »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve todos los mensajes de alerte de IMAP que han sucedido

imap_alerts

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_alerts — Devuelve todos los mensajes de alerte de IMAP que han sucedido

Descripción

imap_alerts ( ) : array

Devuelve todos los mensajes de alerta de IMAP generados desde la última llamada a imap_alerts(), o el inicio de la página.

Al llamar a imap_alerts(), la pila de alertas se limpia posteriormente. La especificación IMAP requiere que estos mensajes sean pasados al usuario.

Valores devueltos

Devuelve un array de todos los mensajes de alerta de IMAP generados o false si no hay mensajes de alerta disponibles.

Ver también

  • imap_errors() - Devuelve todos los errores de IMAP que han ocurrido


Añadir un mensaje de cadena a un buzón especificado

  • « imap_alerts
  • imap_base64 »
  • PHP Manual
  • Funciones de IMAP
  • Añadir un mensaje de cadena a un buzón especificado

imap_append

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_append — Añadir un mensaje de cadena a un buzón especificado

Descripción

imap_append ( resource $imap_stream , string $mailbox , string $message , string $options = null , string $internal_date = null ) : bool

Añade un mensaje de cadena dado por message al buzón especificado por mailbox.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, veáse imap_open() para más información

message

El mensaje a añadir, como cadena

Cuando se toma el servidor Cyrus IMAP, se debe usar "\r\n" como terminador de final de línea en lugar de "\n", o la operación fallará

options

Si se proporciona, options también serán escritas al mailbox

internal_date

Si este parámetro se establece, establecerá INTERNALDATE en el mensaje añadido. El parámetro debería ser una cadena de fecha conforme a las especificaciones rfc2060 para un valor date_time.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.2 | Se añadió el soporte de INTERNALDATE para imap_append.

Ejemplos

Ejemplo #1 Ejemplo de imap_append()

<?php
$stream = imap_open("{imap.example.org}INBOX.Drafts", "username", "password");

$check = imap_check($stream);
echo "Msg Count before append: ". $check->Nmsgs . "\n";

imap_append($stream, "{imap.example.org}INBOX.Drafts"
                   , "From: me@example.com\r\n"
                   . "To: you@example.com\r\n"
                   . "Subject: test\r\n"
                   . "\r\n"
                   . "this is a test message, please ignore\r\n"
                   );

$check = imap_check($stream);
echo "Msg Count after append : ". $check->Nmsgs . "\n";

imap_close($stream);
?>


Decodificar un texto cifrado con BASE64

  • « imap_append
  • imap_binary »
  • PHP Manual
  • Funciones de IMAP
  • Decodificar un texto cifrado con BASE64

imap_base64

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_base64 — Decodificar un texto cifrado con BASE64

Descripción

imap_base64 ( string $text ) : string

Decodifica el text cifrado en BASE-64 dado.

Parámetros

text

El texto cifrado

Valores devueltos

Devuelve el mensaje decodificado como una cadena.

Ver también

  • imap_binary() - Convertir una cadena 8bit a una cadena base64
  • base64_encode() - Codifica datos con MIME base64
  • base64_decode() - Decodifica datos codificados con MIME base64
  • » RFC2045, Sección 6.8


Convertir una cadena 8bit a una cadena base64

  • « imap_base64
  • imap_body »
  • PHP Manual
  • Funciones de IMAP
  • Convertir una cadena 8bit a una cadena base64

imap_binary

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_binary — Convertir una cadena 8bit a una cadena base64

Descripción

imap_binary ( string $string ) : string

Convertir una cadena 8bit a una cadena base64 de acuerdo al documento » RFC2045, Sección 6.8.

Parámetros

string

La cadena 8bit

Valores devueltos

Devuelve una cadena codificada mediante base64.

Ver también

  • imap_base64() - Decodificar un texto cifrado con BASE64


Leer el cuerpo del mensaje

  • « imap_binary
  • imap_bodystruct »
  • PHP Manual
  • Funciones de IMAP
  • Leer el cuerpo del mensaje

imap_body

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_body — Leer el cuerpo del mensaje

Descripción

imap_body ( resource $imap_stream , int $msg_number , int $options = 0 ) : string

imap_body() devuelve el cuerpo del mensaje, numerado por msg_number en el buzón actual.

imap_body() sólo devolverá una copia palabra por palabra del cuerpo del mensaje. Para extraer partes simples de un mensaje multiparte codificado mediante MIME tiene que usar imap_fetchstructure() para analizar su estructura y imap_fetchbody() para extraer una copia de un componente simple del cuerpo.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

options

El parámetro opcional options es una máscara de bits con uno o más de lo siguiente:

  • FT_UID - msg_number es un UID
  • FT_PEEK - No establece la bandera \Seen si no lo está ya
  • FT_INTERNAL - La cadena devuelta está en formato interno, no se canonizará a CRLF.

Valores devueltos

Devuelve el cuerpo del mensaje especificado, como cadena.


Leer la estructura de una sección del cuerpo especificado de un mensaje especificado

  • « imap_body
  • imap_check »
  • PHP Manual
  • Funciones de IMAP
  • Leer la estructura de una sección del cuerpo especificado de un mensaje especificado

imap_bodystruct

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_bodystruct — Leer la estructura de una sección del cuerpo especificado de un mensaje especificado

Descripción

imap_bodystruct ( resource $imap_stream , int $msg_number , string $section ) : object

Leer la estructura de una sección del cuerpo especificado de un mensaje especificado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

section

La sección del cuerpo a leer

Valores devueltos

Devuelve la información en un objeto; para una descripción detallada de la estructura del objeto y sus propiedades veáse imap_fetchstructure().

Ver también

  • imap_fetchstructure() - Leer la estructura de un mensaje en particular


Comprobar el buzón actual

  • « imap_bodystruct
  • imap_clearflag_full »
  • PHP Manual
  • Funciones de IMAP
  • Comprobar el buzón actual

imap_check

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_check — Comprobar el buzón actual

Descripción

imap_check ( resource $imap_stream ) : object

Comprueba la información sobre el buzón actual.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve la información en un objeto con las siguientes propiedades:

  • Date - momento actual del sistema formateado según » RFC2822
  • Driver - protocolo usado para acceder a este buzón: POP3, IMAP, NNTP
  • Mailbox - el nombre del buzón
  • Nmsgs - número de mensajes en el buzón
  • Recent - número de mensajes recientes en el buzón

Devuelve false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_check()

<?php

$imap_obj = imap_check($imap_stream);
var_dump($imap_obj);

?>

El resultado del ejemplo sería algo similar a:

object(stdClass)(5) {
  ["Date"]=>
  string(37) "Wed, 10 Dec 2003 17:56:54 +0100 (CET)"
  ["Driver"]=>
  string(4) "imap"
  ["Mailbox"]=>
  string(54)
  "{www.example.com:143/imap/user="foo@example.com"}INBOX"
  ["Nmsgs"]=>
  int(1)
  ["Recent"]=>
  int(0)
}


Limpia las banderas de mensajes

  • « imap_check
  • imap_close »
  • PHP Manual
  • Funciones de IMAP
  • Limpia las banderas de mensajes

imap_clearflag_full

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_clearflag_full — Limpia las banderas de mensajes

Descripción

imap_clearflag_full ( resource $imap_stream , string $sequence , string $flag , int $options = 0 ) : bool

Esta función borra la bandera especificada por flag a las banderas establecidas para los mensajes en la secuencia especificada por sequence.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

sequence

Una secuencia de números de mensaje. Puede enumerar los mensajes deseados con la sintaxis X,Y, o recuperar todos los mensajes dentro de un intervalo con la sintaxis X:Y.

flag

Las banderas que se pueden eliminar son "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", y "\\Draft" (como está definido en » RFC2060)

options

options es una máscara de bits y puede contener la única opción:

  • ST_UID - El argumento secuenciado contiene UIDs en lugar de números secuenciados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_setflag_full() - Establece banderas en mensajes


Cerrar una secuencia IMAP

  • « imap_clearflag_full
  • imap_create »
  • PHP Manual
  • Funciones de IMAP
  • Cerrar una secuencia IMAP

imap_close

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_close — Cerrar una secuencia IMAP

Descripción

imap_close ( resource $imap_stream , int $flag = 0 ) : bool

Cierra la secuencia imap.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

flag

Si se define como CL_EXPUNGE, la función limpiará el buzón silenciosamente antes de cerrarlo, eliminando todos los mensajes marcados para este fin. Es posible obtener el mismo resultado usando imap_expunge()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_open() - Abrir un flujo IMAP a un buzón


Alias de imap_createmailbox

  • « imap_close
  • imap_createmailbox »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_createmailbox

imap_create

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_create — Alias de imap_createmailbox()

Descripción

Esta función es un alias de: imap_createmailbox().


Crear un nuevo buzón de correo

  • « imap_create
  • imap_delete »
  • PHP Manual
  • Funciones de IMAP
  • Crear un nuevo buzón de correo

imap_createmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_createmailbox — Crear un nuevo buzón de correo

Descripción

imap_createmailbox ( resource $imap_stream , string $mailbox ) : bool

Crea un nuevo buzón de correo especificado por buzon.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

buzon

El nombre del buzón, ver imap_open() para más información. Los nombres que contengan caracteres internacionales deben ser codificados mediante imap_utf7_encode()

Advertencia

El paso de datos no confiables a este parámetro es inseguro, a menos que imap.enable_insecure_rsh esté inhabilitado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_createmailbox()

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
     or die("can't connect: " . imap_last_error());

$name1 = "phpnewbox";
$name2 = imap_utf7_encode("phpnewböx"); // phpnewb&w7Y-x

$newname = $name1;

echo "Newname will be '$name1'<br />\n";

// ahora crearemos un nuevo buzón "phptestbox" en su carpeta de entrada,
// chequearemos su status después de su creación y finalmente lo removeremos
// para recuperar el estado inicial del buzón de entrada

if (@imap_createmailbox($mbox, imap_utf7_encode("{imap.example.org}INBOX.$newname"))) {
    $status = @imap_status($mbox, "{imap.example.org}INBOX.$newname", SA_ALL);
    if ($status) {
        echo "your new mailbox '$name1' has the following status:<br />\n";
        echo "Messages:   " . $status->messages    . "<br />\n";
        echo "Recent:     " . $status->recent      . "<br />\n";
        echo "Unseen:     " . $status->unseen      . "<br />\n";
        echo "UIDnext:    " . $status->uidnext     . "<br />\n";
        echo "UIDvalidity:" . $status->uidvalidity . "<br />\n";

        if (imap_renamemailbox($mbox, "{imap.example.org}INBOX.$newname", "{imap.example.org}INBOX.$name2")) {
            echo "renamed new mailbox from '$name1' to '$name2'<br />\n";
            $newname = $name2;
        } else {
            echo "imap_renamemailbox on new mailbox failed: " . imap_last_error() . "<br />\n";
        }
    } else {
        echo "imap_status on new mailbox failed: " . imap_last_error() . "<br />\n";
    }

    if (@imap_deletemailbox($mbox, "{imap.example.org}INBOX.$newname")) {
        echo "new mailbox removed to restore initial state<br />\n";
    } else {
        echo "imap_deletemailbox on new mailbox failed: " . implode("<br />\n", imap_errors()) . "<br />\n";
    }

} else {
    echo "could not create new mailbox: " . implode("<br />\n", imap_errors()) . "<br />\n";
}

imap_close($mbox);
?>

Ver también

  • imap_renamemailbox() - Renombrar un buzón antiguo a un buzón nuevo
  • imap_deletemailbox() - Elimina un buzón


Marcar un mensaje para su borrado del buzón actual

  • « imap_createmailbox
  • imap_deletemailbox »
  • PHP Manual
  • Funciones de IMAP
  • Marcar un mensaje para su borrado del buzón actual

imap_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_delete — Marcar un mensaje para su borrado del buzón actual

Descripción

imap_delete ( resource $imap_stream , int $msg_number , int $options = 0 ) : bool

Marca los mensajes listados en msg_number para su eliminación. Los mensajes marcados para eliminar permanecerán en el buzón hasta que se llame imap_expunge() o imap_close() con el parámetro opcional CL_EXPUNGE.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

options

Es posible usar el valor FT_UID que indica que la función debe tratar el argumento msg_number como un UID.

Valores devueltos

Devuelve true.

Ejemplos

Ejemplo #1 Ejemplo de imap_delete()

<?php

$buzon = imap_open("{imap.example.org}INBOX", "usuario", "contraseña")
    or die("No es posible conectarse: " . imap_last_error());

$chequeo = imap_mailboxmsginfo($buzon);
echo "Mensajes antes de borrar: " . $chequeo->Nmsgs . "<br />\n";

imap_delete($buzon, 1);

$chequeo = imap_mailboxmsginfo($buzon);
echo "Mensajes después de borrar: " . $chequeo->Nmsgs . "<br />\n";

imap_expunge($buzon);

$chequeo = imap_mailboxmsginfo($buzon);
echo "Mensajes después de purgar: " . $chequeo->Nmsgs . "<br />\n";

imap_close($buzon);
?>

Notas

Nota:

los buzones IMAP quizá no guardan el estado de sus mensajes entre conexiones, así que imap_expunge() debe llamarse durante la misma conexión para garantizar que los mensajes marcados para eliminación sean realmente borrados.

Ver también

  • imap_undelete() - Desmarcar el mensaje que está marcado para borrar
  • imap_expunge() - Borra todos los mensajes marcados para eliminación
  • imap_close() - Cerrar una secuencia IMAP


Elimina un buzón

  • « imap_delete
  • imap_errors »
  • PHP Manual
  • Funciones de IMAP
  • Elimina un buzón

imap_deletemailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_deletemailbox — Elimina un buzón

Descripción

imap_deletemailbox ( resource $imap_stream , string $mailbox ) : bool

Elimina el buzón espeicificado por mailbox.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más informacion

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_createmailbox() - Crear un nuevo buzón de correo
  • imap_renamemailbox() - Renombrar un buzón antiguo a un buzón nuevo
  • imap_open() - Abrir un flujo IMAP a un buzón para el formato de mbox


Devuelve todos los errores de IMAP que han ocurrido

  • « imap_deletemailbox
  • imap_expunge »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve todos los errores de IMAP que han ocurrido

imap_errors

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_errors — Devuelve todos los errores de IMAP que han ocurrido

Descripción

imap_errors ( ) : array

Obtiene todos los errores de IMAP (si los hay) que han ocurrido durante esta petición de página o desde que se reinició la pila de errores.

Al llamar a imap_errors(), la pila de errores se limpia posteriormente.

Valores devueltos

Esta función devuelve un array con todos los mensajes de error de IMAP generados desde la última llamada a imap_errors(), o desde el principio de la página. Devuelve false si no hay disponible ningún mensaje de error.

Ver también

  • imap_last_error() - Obtiene el último error de IMAP que ocurrió durante esta petición de página
  • imap_alerts() - Devuelve todos los mensajes de alerte de IMAP que han sucedido


Borra todos los mensajes marcados para eliminación

  • « imap_errors
  • imap_fetch_overview »
  • PHP Manual
  • Funciones de IMAP
  • Borra todos los mensajes marcados para eliminación

imap_expunge

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_expunge — Borra todos los mensajes marcados para eliminación

Descripción

imap_expunge ( resource $imap_stream ) : bool

Borra todos los mensajes marcados para eliminación por imap_delete(), imap_mail_move(), o imap_setflag_full().

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve true.


Leer una visión general de la información de las cabeceras del mensaje dado

  • « imap_expunge
  • imap_fetchbody »
  • PHP Manual
  • Funciones de IMAP
  • Leer una visión general de la información de las cabeceras del mensaje dado

imap_fetch_overview

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetch_overview — Leer una visión general de la información de las cabeceras del mensaje dado

Descripción

imap_fetch_overview ( resource $imap_stream , string $sequence , int $options = 0 ) : array

Esta función obtiene las cabeceras del correo de la secuencia dada por sequence y devuelve una visión general de sus contenidos.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

sequence

Una descripción de la secuencia de mensajes. Puede enumerar los mensajes deseados con la sintaxis X,Y, o recuperar todos los mensajes dentro de un intervalo con la sintaxis X:Y

options

sequence contendrá una secuencia de índices de mensajes; o UIDs, si este parámetro está establecido a FT_UID.

Valores devueltos

Devuelve un array de objetos que describen una cabecera de mensaje cada uno. El objeto sólo definirá una propiedad si ésta existe. Las propiedades posibles son:

  • subject - el sujeto del mensaje
  • from - quién lo envió
  • to - destinatario
  • date - cuándo fue enviado
  • message_id - ID del mensaje
  • references - es una referencia a este id de mensaje
  • in_reply_to - es una respueste a este id de mensaje
  • size - tamaño en bytes
  • uid - UID del mensaje que está en el buzón
  • msgno - número de secuencia de mensaje en el buzón
  • recent - este mensaje está marcado como reciente
  • flagged - este mensaje está marcado
  • answered - este mensaje está marcado como respondido
  • deleted - este mensaje está marcado para su eliminación
  • seen - este mensaje está marcado como ya leído
  • draft - este mensaje está marcado como borrador

Ejemplos

Ejemplo #1 Ejemplo de imap_fetch_overview()

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password")
     or die("no se puede conectar: " . imap_last_error());

$MC = imap_check($mbox);

// Obtener una visión general de todos los mensajes de INBOX
$result = imap_fetch_overview($mbox,"1:{$MC->Nmsgs}",0);
foreach ($result as $overview) {
    echo "#{$overview->msgno} ({$overview->date}) - From: {$overview->from}
    {$overview->subject}\n";
}
imap_close($mbox);
?>

Ver también

  • imap_fetchheader() - Devolver la cabecera de un mensaje


Traer una sección en particular del cuerpo del mensaje

  • « imap_fetch_overview
  • imap_fetchheader »
  • PHP Manual
  • Funciones de IMAP
  • Traer una sección en particular del cuerpo del mensaje

imap_fetchbody

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchbody — Traer una sección en particular del cuerpo del mensaje

Descripción

imap_fetchbody ( resource $imap_stream , int $msg_number , string $section , int $options = 0 ) : string

Traer una sección en particular del cuerpo de los mensajes especificados. Las partes del cuerpo no son decodificadas por esta función.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

section

El número de la parte. Es una cadena de enteros delimitada por puntos cuyo índice dentro de la parte del cuerpo se lista como en la especificación IMAP4

options

Una máscara de bits con uno o más de lo siguiente:

  • FT_UID - El msg_number es un UID
  • FT_PEEK - No establece la bandera \Seen si no está ya establecida
  • FT_INTERNAL - La cadena devuelta está en formato interno, no canonizará a CRLF.

Valores devueltos

Devuelve una sección en particular del cuerpo de los mensajes especificados como una cadena de texto.

Ver también

  • imap_savebody() - Guardar una sección del cuerpo específica en un fichero
  • imap_fetchstructure() - Leer la estructura de un mensaje en particular


Devolver la cabecera de un mensaje

  • « imap_fetchbody
  • imap_fetchmime »
  • PHP Manual
  • Funciones de IMAP
  • Devolver la cabecera de un mensaje

imap_fetchheader

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchheader — Devolver la cabecera de un mensaje

Descripción

imap_fetchheader ( resource $imap_stream , int $msg_number , int $options = 0 ) : string

Esta función lleva a cabo la obtención de la cabecera completa, sin filtrar, con formato » RFC2822 del mensaje especificado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

options

Las opciones dadas por options son:

  • FT_UID - El argumento msgno es un UID
  • FT_INTERNAL - La cadena devuelta está en formato "interno" sin ningún intento de canonizar a nuevas líneas CRLF
  • FT_PREFETCHTEXT - RFC822.TEXT debería ser preobtenido al mismo tiempo. Esto evita un RTT extra en una conexión IMAP si se desea un mensaje de texto completo (p.ej. en una operación "guardar en fichero local")

Valores devueltos

Devuelve la cabecera del mensaje especificado como una cadena de texto.

Ver también

  • imap_fetch_overview() - Leer una visión general de la información de las cabeceras del mensaje dado


Obtener las cabeceras MIME para una sección en particular del mensaje

  • « imap_fetchheader
  • imap_fetchstructure »
  • PHP Manual
  • Funciones de IMAP
  • Obtener las cabeceras MIME para una sección en particular del mensaje

imap_fetchmime

(PHP 5 >= 5.3.6, PHP 7, PHP 8)

imap_fetchmime — Obtener las cabeceras MIME para una sección en particular del mensaje

Descripción

imap_fetchmime ( resource $imap_stream , int $msg_number , string $section , int $options = 0 ) : string

Obtener las cabeceras MIME de una sección en particular del cuerpo de los mensajes especificados.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

section

El número de parte. Es una cadnea de enteros delimitados por un punto que indexa dentro de una lista de partes del cuerpo como en la especificación IMAP4

options

Una máscara de bits con uno o más de lo siguiente:

  • FT_UID - msg_number es un UID
  • FT_PEEK - No establecer la bandera \Seen si no está ya establecida
  • FT_INTERNAL - La cadena devuelta está en formato interno, no se canonizará a CRLF.

Valores devueltos

Devuelve las cabeceras MIME de una sección en particular del cuerpo de los mensajes especificados como una cadena de texto.

Ver también

  • imap_fetchbody() - Traer una sección en particular del cuerpo del mensaje
  • imap_fetchstructure() - Leer la estructura de un mensaje en particular
  • imap_fetchheader() - Devolver la cabecera de un mensaje


Leer la estructura de un mensaje en particular

  • « imap_fetchmime
  • imap_fetchtext »
  • PHP Manual
  • Funciones de IMAP
  • Leer la estructura de un mensaje en particular

imap_fetchstructure

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchstructure — Leer la estructura de un mensaje en particular

Descripción

imap_fetchstructure ( resource $imap_stream , int $msg_number , int $options = 0 ) : object

Obtiene toda la información de la estructura de un mensaje dado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje.

options

Este parámetro opcional sólo puede tener una única opción, FT_UID, que indica a la función que trate el argumento msg_number como un UID.

Valores devueltos

Devuelve un objeto que incluye la envoltura, información interna, tamaño, banderas y cuerpo de la estructura además de un objeto similar para cada adjunto mime. La estructura de los objetos devueltos es como sigue:

Objetos devueltos para imap_fetchstructure()
type | Tipo de cuerpo principal
encoding | Codificación de la transferencia del cuerpo
ifsubtype | true si hay una cadena subtipo
subtype | Subtipo MIME
ifdescription | true si hay una cadena de descripción
description | Contenido de la cadena de descripción
ifid | true si hay una cadena de identificación
id | Cadena de identificación
lines | Número de líneas
bytes | Número de bytes
ifdisposition | true si hay una cadena de disposición
disposition | Cadena de disposición
ifdparameters | true si el array dparameters existe
dparameters | Un array de objetos donde cada objeto tiene una propiedad "attribute" y "value" correspondientes a los parámetros de la cabecera MIME Content-disposition.
ifparameters | true si el array de parámetros existe
parameters | Una array de objetos donde cada objeto tiene una propiedad "attribute" y "value".
parts | Un array de objetos idéntico en estructura al objeto de más alto nivel, cada uno correspondiendo una parte del cuerpo MIME.

Tipo principal del cuerpo (el valor podría variar con la biblioteca empleada; se recomienda el uso de constantes)
Valor | Tipo | Constante
0 | text | TYPETEXT
1 | multipart | TYPEMULTIPART
2 | message | TYPEMESSAGE
3 | application | TYPEAPPLICATION
4 | audio | TYPEAUDIO
5 | image | TYPEIMAGE
6 | video | TYPEVIDEO
7 | model | TYPEMODEL
8 | other | TYPEOTHER

Codificaciones de transferencia (el valor podría cambiar con la biblioteca empleada; se recomienda el uso de constantes)
Valor | Tipo | Constante
0 | 7bit | ENC7BIT
1 | 8bit | ENC8BIT
2 | Binary | ENCBINARY
3 | Base64 | ENCBASE64
4 | Quoted-Printable | ENCQUOTEDPRINTABLE
5 | other | ENCOTHER

Ver también

  • imap_fetchbody() - Traer una sección en particular del cuerpo del mensaje
  • imap_bodystruct() - Leer la estructura de una sección del cuerpo especificado de un mensaje especificado


Alias de imap_body

  • « imap_fetchstructure
  • imap_gc »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_body

imap_fetchtext

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchtext — Alias de imap_body()

Descripción

Esta función es un alias de: imap_body().


Limpia la caché de IMAP

  • « imap_fetchtext
  • imap_get_quota »
  • PHP Manual
  • Funciones de IMAP
  • Limpia la caché de IMAP

imap_gc

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_gc — Limpia la caché de IMAP

Descripción

imap_gc ( resource $imap_stream , int $caches ) : bool

Limpia la caché de entradas de un tipo específico.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

caches

Especifica la caché a limpiar. Puede ser una o una combinación de las siguientes constantes: IMAP_GC_ELT (elementos de caché de mensajes), IMAP_GC_ENV (sobre y cuerpos), IMAP_GC_TEXTS (textos).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_gc()

<?php

$mbox = imap_open("{imap.example.org:143}", "username", "password");

imap_gc($mbox, IMAP_GC_ELT);

?>


Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón

  • « imap_gc
  • imap_get_quotaroot »
  • PHP Manual
  • Funciones de IMAP
  • Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón

imap_get_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

imap_get_quota — Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón

Descripción

imap_get_quota ( resource $imap_stream , string $quota_root ) : array

Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón.

Para una versión de usuario no administrador de esta función, por favor véase la función imap_get_quotaroot() de PHP.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

quota_root

quota_root normalmente debería estar en la forma ususario.nombre donde nombre es el buzón del que se quiere obtener información.

Valores devueltos

Devuelve un array con valores integer de límite y uso par el buzón dado. El valor del límite representa la cantidad total de espacio permitido a este buzón. El valor de uso representa el nivle de capacidad actual de los buzones. Devolverá false en caso de error.

Desde PHP 4.3, la función refleja de manera más apropiada la funcionalidad como está dictada en » RFC2087. El array de valores devuelto ha cambiado para soportar un número ilimitado de recursos devueltos (es decir, mensajes, o subcarpetas) con cada recurso nombrado recibiendo una clave de array individual. Cada valor de la clave contiene otro array con los valores uso y límite dentro de él.

Por razones de retrocompatibilidad, los métodos de acceso originales aún están disponibles, aunque se sugiere actualizar.

Ejemplos

Ejemplo #1 Ejemplo de imap_get_quota()

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("no se puede conectar: " . imap_last_error());

$quota_value = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_value)) {
    echo "Usage level is: " . $quota_value['usage'];
    echo "Limit level is: " . $quota_value['limit'];
}

imap_close($mbox);
?>

Ejemplo #2 Ejemplo de imap_get_quota() 4.3 o superiro

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("no se puede conectar: " . imap_last_error());

$quota_values = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_values)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit is: " .  $message['limit'];

   /* ...  */
}

imap_close($mbox);
?>

Notas

Esta función está actualmente disponible para usuarios de la biblioteca c-client2000 o superior.

El imap_stream dado debe ser abierto como el administrador de correo, si no la función fallará.

Ver también

  • imap_open() - Abrir un flujo IMAP a un buzón
  • imap_set_quota() - Establece una cuota para un buzón dado
  • imap_get_quotaroot() - Obtener la cuota de ajustes por usuario


Obtener la cuota de ajustes por usuario

  • « imap_get_quota
  • imap_getacl »
  • PHP Manual
  • Funciones de IMAP
  • Obtener la cuota de ajustes por usuario

imap_get_quotaroot

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imap_get_quotaroot — Obtener la cuota de ajustes por usuario

Descripción

imap_get_quotaroot ( resource $imap_stream , string $quota_root ) : array

Obtnener la cuota de ajustes por usuario. EL valor límite representa la cantidad total de espacio permitido para este uso de buzón total de usuario. El valor del uso representa la capacidad de buzón total del usuario actual.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

quota_root

quota_root normalmente debería estar en la forma de su buzón (es decir, INBOX).

Valores devueltos

Devuelve un array de valores concernientes al buzón del usuario especificado. Todos los valores contienen una clave basada en el nombre del recurso, y dentro un array correspondiente al los valores uso y límite.

Esta función devolverá false en el caso de fallo de llamada, y un array de información acerca de la conexión sobre una respuesta no analizable desde el servidor.

Ejemplos

Ejemplo #1 Ejemplo de imap_get_quotaroot()

<?php
$mbox = imap_open("{imap.example.org}", "kalowsky", "password", OP_HALFOPEN)
      or die("no se pudo conectar: " . imap_last_error());

$cuota = imap_get_quotaroot($mbox, "INBOX");
if (is_array($cuota)) {
   $almacén = $cuota['STORAGE'];
   echo "El nivel de uso de STORAGE es: " .  $almacén['usage'];
   echo "El nivel de uso de STORAGE es: " .  $almacén['limit'];

   $mensaje = $cuota['MESSAGE'];
   echo "El nivel de uso de MESSAGE es: " .  $mensaje['usage'];
   echo "El nivel de uso de MESSAGE es: " .  $mensaje['limit'];

   /* ...  */

}

imap_close($mbox);
?>

Notas

Esta función actualmente sólo está disponible para usuarios de la biblioteca c-client2000 o superior.

imap_stream debería estar abierto mientras se compruebe el buzón del usuario en cuestión.

Ver también

  • imap_open() - Abrir un flujo IMAP a un buzón
  • imap_set_quota() - Establece una cuota para un buzón dado
  • imap_get_quota() - Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón


Obtiene el ACL para un buzón dado

  • « imap_get_quotaroot
  • imap_getmailboxes »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene el ACL para un buzón dado

imap_getacl

(PHP 5, PHP 7, PHP 8)

imap_getacl — Obtiene el ACL para un buzón dado

Descripción

imap_getacl ( resource $imap_stream , string $mailbox ) : array

GObtiene el ACL para un buzón dado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, veáse imap_open() para más información

Valores devueltos

Devuelve un array asociativo de pares "folder" => "acl" pairs.

Ejemplos

Ejemplo #1 Ejemplo de imap_getacl()

<?php

print_r(imap_getacl($conn_id, 'user.joecool'));

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [asubfolder] => lrswipcda
    [anothersubfolder] => lrswipcda
)

Notas

Esta función sólo está disponible para usuarios de la biblioteca c-client2000 o superior.

Ver también

  • imap_setacl() - Establece el ACL para el buzón dado


Leer la lista de buzones, devolviendo información detallada de cada uno

  • « imap_getacl
  • imap_getsubscribed »
  • PHP Manual
  • Funciones de IMAP
  • Leer la lista de buzones, devolviendo información detallada de cada uno

imap_getmailboxes

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_getmailboxes — Leer la lista de buzones, devolviendo información detallada de cada uno

Descripción

imap_getmailboxes ( resource $imap_stream , string $ref , string $pattern ) : array

Obtiene información sobre los buzones.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

ref

ref normalmente debería ser la especificación del servidor como está descrita en imap_open()

pattern

Especifica donde en la jerarquía del buzón para empezar a buscar.

Hay dos caracteres especiales que se pueden pasar como parte del pattern: '*' y '%'. '*' significa devolver todos los buzones. Si se pasa el pattern como '*', se obtendrá una lista de toda la jerarquía del buzón. '%' significa devolver sólo el nivel actual. '%' como el parámetro pattern devolverá solamente el nivel superior de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón en el directorio ~/mail, pero no en los subdirectorios de ese directorio.

Valores devueltos

Devuelve un array de objetos que contienen la información de los buzones. Cada objeto tiene los atributos name (nombre), especificando el nombre completo del buzón; delimiter (delimitador), que es el delimitador de jerarquía de la parte de la jerarquía en la que está este buzón, y attributes (atributos). Attributes es una máscara de bits que puede comprobar con:

  • LATT_NOINFERIORS - Este buzón contiene, y no puede contener ningún "hijo" (no hay buzones por debajo de este). Una llamada a imap_createmailbox() no funcionará con este buzón.

  • LATT_NOSELECT - Es solo un contenedor, no un buzón - no se puede abrir.

  • LATT_MARKED - Este buzón está marcado. Esto significa que puede contener mensajes nuevos desde la última vez que se comprobó. No proporcionado por todos los servidores IMAP.

  • LATT_UNMARKED - Este buzó no está marcado, no contiene nuevos mensajes. Si se proporciona MARKED o UNMARKED, se puede asumir que el servidor IMAP soporta esta característica para este buzón.

Ejemplos

Ejemplo #1 Ejemplo de imap_getmailboxes()

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("no se puede conectar: " . imap_last_error());

$lista = imap_getmailboxes($mbox, "{imap.example.org}", "*");
if (is_array($lista)) {
    foreach ($lista as $clave => $valor) {
        echo "($clave) ";
        echo imap_utf7_decode($valor->name) . ",";
        echo "'" . $valor->delimiter . "',";
        echo $valor->attributes . "<br />\n";
    }
} else {
    echo "imap_getmailboxes falló: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Ver también

  • imap_getsubscribed() - Listar todos los buzones suscritos


Listar todos los buzones suscritos

  • « imap_getmailboxes
  • imap_header »
  • PHP Manual
  • Funciones de IMAP
  • Listar todos los buzones suscritos

imap_getsubscribed

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_getsubscribed — Listar todos los buzones suscritos

Descripción

imap_getsubscribed ( resource $imap_stream , string $ref , string $pattern ) : array

Obtiene información sobre los buzones suscritos.

Idéntica a imap_getmailboxes(), excepto que sólo devuelve los buzones al que está suscrito el usuario.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

ref

ref normalmente debería ser la especificación del servidor como está descrita en imap_open()

pattern

Especifica donde en la jerarquía del buzón para empezar a buscar.

Hay dos caracteres especiales que se pueden pasar como parte del pattern: '*' y '%'. '*' significa devolver todos los buzones. Si se pasa el pattern como '*', se obtendrá una lista de toda la jerarquía del buzón. '%' significa devolver sólo el nivel actual. '%' como el parámetro pattern devolverá solamente el nivel superior de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón en el directorio ~/mail, pero no en los subdirectorios de ese directorio.

Valores devueltos

Devuelve un array de objetos de contienen información de los buzones. Cada objeto tiene los atributos name (nombre), especificando el nombre completo del buzón; delimiter (delimitador), que es el delimitador de jerarquía para la parte de jerarquía en la que está este buzón, y attributes (atributos). Attributes es una máscara de bits que puede ser comprobada con:

  • LATT_NOINFERIORS - Este buzón no tiene "hijos" (no hay buzones por debajo de este).
  • LATT_NOSELECT - Esto es solo un contenedor, no un buzón - no puede abrirlo.
  • LATT_MARKED - Este buzón está marcado. Solo usado por UW-IMAPD.
  • LATT_UNMARKED - Este buzón no está marcado. Solo usado por UW-IMAPD.


Alias de imap_headerinfo

  • « imap_getsubscribed
  • imap_headerinfo »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_headerinfo

imap_header

(PHP 4, PHP 5, PHP 7)

imap_header — Alias de imap_headerinfo()

Descripción

Esta función es un alias de: imap_headerinfo().


Leer la cabecera del mensaje

  • « imap_header
  • imap_headers »
  • PHP Manual
  • Funciones de IMAP
  • Leer la cabecera del mensaje

imap_headerinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_headerinfo — Leer la cabecera del mensaje

Descripción

imap_headerinfo ( resource $imap_stream , int $msg_number , int $fromlength = 0 , int $subjectlength = 0 , string $defaulthost = null ) : object

Obtiene información sobre el número de mensaje dado leyendo sus cabeceras.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje

fromlength

Número de caracteres para la propiedad fetchfrom. Debe ser mayor que cero o igual a cero.

subjectlength

Número de caracteres para la propiedad fetchsubject. Debe ser mayor que cero o igual a cero.

defaulthost

Valores devueltos

Devuelve la información en un objeto con las siguientes propiedades:

  • toaddress - to completo: línea, hasta 1024 caracteres
  • to - un array de objetos desde To: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • fromaddress - from completo: línea, hasta 1024 caracteres
  • from - un array de objetos desde From: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • ccaddress - cc completo: línea, hasta 1024 caracteres
  • cc - un array de objetos desde Cc: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • bccaddress - bcc completo: línea, hasta 1024 caracteres
  • bcc - un array de objetos desde Bcc: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • reply_toaddress - Reply-To completo: línea, hasta 1024 caracteres
  • reply_to - un array de objetos desde Reply-To: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • senderaddress - sender completo: línea, hasta 1024 caracteres
  • sender - un array de objetos desde Sender: línea, con las siguientes propiedades: personal, adl, mailbox, y host
  • return_pathaddress - Return-Path completo: línea, hasta 1024 caracteres
  • return_path - un array de objetos desde Return-Path: línea, con las siguienets propiedades: personal, adl, mailbox, y host
  • remail -
  • date - La fecha del mensaje como se encuentra en sus cabeceras
  • Date - Lo mismo que date
  • subject - El sujeto del mensaje
  • Subject - Lo mismo que subject
  • in_reply_to -
  • message_id -
  • newsgroups -
  • followup_to -
  • references -
  • Recent - R si es reciente y visto, N si es reciente y no visto, ' ' si no es reciente.
  • Unseen - U si no está visto Y no es reciente, ' ' si está visto O no visto y es reciente
  • Flagged - F si está marcado, ' ' si no está marcado
  • Answered - A si está respondido, ' ' si no está respondido
  • Deleted - D si está borrado, ' ' si no está borrado
  • Draft - X si es un borrador, ' ' si no es un borrador
  • Msgno - El número de mensaje
  • MailDate -
  • Size - El tamaño del mensaje
  • udate - fecha del mensaje de correo en época Unix
  • fetchfrom - línea from formateada a encajar fromlength caracteres
  • fetchsubject - línea subject formateada a encajar subjectlength caracteres

Ver también

  • imap_fetch_overview() - Leer una visión general de la información de las cabeceras del mensaje dado


Devuelve las cabeceras de todos los mensajes de un buzón

  • « imap_headerinfo
  • imap_last_error »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve las cabeceras de todos los mensajes de un buzón

imap_headers

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_headers — Devuelve las cabeceras de todos los mensajes de un buzón

Descripción

imap_headers ( resource $imap_stream ) : array

Devuelve las cabeceras de todos los mensajes de un buzón.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve un array de cadenas formateadas con la información de cabecera. Un elemento por mensaje de correo.


Obtiene el último error de IMAP que ocurrió durante esta petición de página

  • « imap_headers
  • imap_list »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene el último error de IMAP que ocurrió durante esta petición de página

imap_last_error

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_last_error — Obtiene el último error de IMAP que ocurrió durante esta petición de página

Descripción

imap_last_error ( ) : string

Obtiene el texto completo del últime mensaje de error de IMAP que ocurrión de la página actual. La pila de errores se queda intacta; llamar a imap_last_error() posteriormente, sin que intervengan errores, devolverá el mismo error.

Valores devueltos

Devuelve el texto completo de último mensaje de error de IMAP que ocurrio en la página actual. Devuelve false si no hay disponibles mensajes de error.

Ver también

  • imap_errors() - Devuelve todos los errores de IMAP que han ocurrido


Leer la lista de buzones

  • « imap_last_error
  • imap_listmailbox »
  • PHP Manual
  • Funciones de IMAP
  • Leer la lista de buzones

imap_list

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_list — Leer la lista de buzones

Descripción

imap_list ( resource $imap_stream , string $ref , string $pattern ) : array

Leer la lista de buzones.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

ref

ref normalmente debería ser la especificación del servidor como está descrita en imap_open().

pattern

Especifica donde en la jerarquía del buzón para empezar a buscar.

Hay dos caracteres especiales que se pueden pasar como parte del pattern: '*' y '%'. '*' significa devolver todos los buzones. Si se pasa el pattern como '*', se obtendrá una lista de toda la jerarquía del buzón. '%' significa devolver sólo el nivel actual. '%' como el parámetro pattern devolverá solamente el nivel superior de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón en el directorio ~/mail, pero no en los subdirectorios de ese directorio.

Valores devueltos

Devuelve un array que contiene los nombres de los buzones.

Ejemplos

Ejemplo #1 Ejemplo de imap_list()

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("no se puede conectar: " . imap_last_error());

$list = imap_list($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $val) {
        echo imap_utf7_decode($val) . "\n";
    }
} else {
    echo "imap_list failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Ver también

  • imap_getmailboxes() - Leer la lista de buzones, devolviendo información detallada de cada uno
  • imap_lsub() - Listar todos los buzones suscritos


Alias de imap_list

  • « imap_list
  • imap_listscan »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_list

imap_listmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listmailbox — Alias de imap_list()

Descripción

Esta función es un alias de: imap_list().


Devuelve la lista de buzones que coinciden con el texto dado

  • « imap_listmailbox
  • imap_listsubscribed »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve la lista de buzones que coinciden con el texto dado

imap_listscan

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listscan — Devuelve la lista de buzones que coinciden con el texto dado

Descripción

imap_listscan ( resource $imap_stream , string $ref , string $pattern , string $content ) : array

Devuelve un array que contiene los nombres de los buzones que tienen el contenido dado por content en el texto del buzón.

Esta función es similar a imap_listmailbox(), excepto que verificará además la presencia de la cadena content dentro de la información del buzón.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

ref

ref normalmente debería ser la especificación del servidor como está descrita en imap_open()

pattern

Especifica donde en la jerarquía del buzón para empezar a buscar.

Hay dos caracteres especiales que se pueden pasar como parte del pattern: '*' y '%'. '*' significa devolver todos los buzones. Si se pasa el pattern como '*', se obtendrá una lista de toda la jerarquía del buzón. '%' significa devolver sólo el nivel actual. '%' como el parámetro pattern devolverá solamente el nivel superior de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón en el directorio ~/mail, pero no en los subdirectorios de ese directorio.

content

La cadena buscada

Valores devueltos

Devuelve un array que contiene los nombres de los buzones que tienen el contenido dado por content en el texto del buzón.

Ver también

  • imap_listmailbox() - Alias de imap_list
  • imap_search() - Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado


Alias de imap_lsub

  • « imap_listscan
  • imap_lsub »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_lsub

imap_listsubscribed

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listsubscribed — Alias de imap_lsub()

Descripción

Esta función es un alias de: imap_lsub().


Listar todos los buzones suscritos

  • « imap_listsubscribed
  • imap_mail_compose »
  • PHP Manual
  • Funciones de IMAP
  • Listar todos los buzones suscritos

imap_lsub

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_lsub — Listar todos los buzones suscritos

Descripción

imap_lsub ( resource $imap_stream , string $ref , string $pattern ) : array

Obtiene un array de todos lo buzones que tiene suscritos.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

ref

ref normalmente debería ser la especificación del servidor como está descrita en imap_open()

pattern

Especifica donde en la jerarquía del buzón para empezar a buscar.

Hay dos caracteres especiales que se pueden pasar como parte del pattern: '*' y '%'. '*' significa devolver todos los buzones. Si se pasa el pattern como '*', se obtendrá una lista de toda la jerarquía del buzón. '%' significa devolver sólo el nivel actual. '%' como el parámetro pattern devolverá solamente el nivel superior de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón en el directorio ~/mail, pero no en los subdirectorios de ese directorio.

Valores devueltos

Devuelve un array de todos los buzones suscritos.

Ver también

  • imap_list() - Leer la lista de buzones
  • imap_getmailboxes() - Leer la lista de buzones, devolviendo información detallada de cada uno


Crear un mensaje MIME basado en las secciones sobre y cuerpo

  • « imap_lsub
  • imap_mail_copy »
  • PHP Manual
  • Funciones de IMAP
  • Crear un mensaje MIME basado en las secciones sobre y cuerpo

imap_mail_compose

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_compose — Crear un mensaje MIME basado en las secciones sobre y cuerpo

Descripción

imap_mail_compose ( array $envelope , array $body ) : string

Crear un mensaje MIME basado en las secciones de sobre dado por envelope y cuerpo dado por body.

Parámetros

envelope

Un array asociativo de campos de cabecers. Las claves válidas son: "remail", "return_path", "date", "from", "reply_to", "in_reply_to", "subject", "to", "cc", "bcc", "message_id" y "custom_headers" (que contiene un array asociativo de otras cabeceras).

body

Un array indexado de cuerpos

Un cuero en un array asociativo que puede consistir en las siguientes claves: "type", "encoding", "charset", "type.parameters", "subtype", "id", "description", "disposition.type", "disposition", "contents.data", "lines", "bytes" y "md5".

Valores devueltos

Devuelve el mensaje MIME.

Ejemplos

Ejemplo #1 Ejemplo de imap_mail_compose()

<?php

$sobre["from"]= "joe@example.com";
$sobre["to"]  = "foo@example.com";
$sobre["cc"]  = "bar@example.com";

$parte1["type"] = TYPEMULTIPART;
$parte1["subtype"] = "mixed";

$nombre_fichero = "/tmp/imap.c.gz";
$fp = fopen($nombre_fichero, "r");
$contenido = fread($fp, filesize($nombre_fichero));
fclose($fp);

$parte2["type"] = TYPEAPPLICATION;
$parte2["encoding"] = ENCBINARY;
$parte2["subtype"] = "octet-stream";
$parte2["description"] = basename($nombre_fichero);
$parte2["contents.data"] = $contenido;

$parte3["type"] = TYPETEXT;
$parte3["subtype"] = "plain";
$parte3["description"] = "description3";
$parte3["contents.data"] = "contents.data3\n\n\n\t";

$cuerpo[1] = $parte1;
$cuerpo[2] = $parte2;
$cuerpo[3] = $parte3;

echo nl2br(imap_mail_compose($sobre, $cuerpo));

?>


Copiar los mensajes especificados a un buzón

  • « imap_mail_compose
  • imap_mail_move »
  • PHP Manual
  • Funciones de IMAP
  • Copiar los mensajes especificados a un buzón

imap_mail_copy

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_copy — Copiar los mensajes especificados a un buzón

Descripción

imap_mail_copy ( resource $imap_stream , string $msglist , string $mailbox , int $options = 0 ) : bool

Copia los mensajes de correo especificados por msglist al buzón especificado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msglist

msglist es un rango, no números de mensajes (como está descrito en » RFC2060).

mailbox

El nombre del buzón, véase imap_open() para más información

options

options es una máscara de bits de un o más de

  • CP_UID - los números de secuencia conetienen UIDS
  • CP_MOVE - Borrar los mensajes del buzón actual después de copiar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_mail_move() - Mover los mensajes especificados a un buzón


Mover los mensajes especificados a un buzón

  • « imap_mail_copy
  • imap_mail »
  • PHP Manual
  • Funciones de IMAP
  • Mover los mensajes especificados a un buzón

imap_mail_move

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_move — Mover los mensajes especificados a un buzón

Descripción

imap_mail_move ( resource $imap_stream , string $msglist , string $mailbox , int $options = 0 ) : bool

Mueve los mensajes de correo especificados por msglist al buzón especificado por mailbox.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msglist

msglist es un rango, y no números de mensajes (como está descrito en » RFC2060).

mailbox

El nombre del buzón, véase imap_open() para más información

options

options es una máscara de bits y puede contener la única opción:

  • CP_UID - los números de secuencia que contienen UIDS

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

imap_mail_move() marcará el correo original con una bandera de eliminación, para eliminarlo con éxito se debe hacer una llamada a imap_expunge().

Ver también

  • imap_mail_copy() - Copiar los mensajes especificados a un buzón


Enviar un mensaje de correo electrónico

  • « imap_mail_move
  • imap_mailboxmsginfo »
  • PHP Manual
  • Funciones de IMAP
  • Enviar un mensaje de correo electrónico

imap_mail

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail — Enviar un mensaje de correo electrónico

Descripción

imap_mail ( string $to , string $subject , string $message , string $additional_headers = null , string $cc = null , string $bcc = null , string $rpath = null ) : bool

Esta función permite enviar emails con el manejo correcto de los destinatarios Cc y Bcc.

Los parámetros to, cc y bcc son todos strings y son analizados como la lista de direcciones » RFC822.

Parámetros

to

El destinatario

subject

El asunto del correo

message

El cuerpo del correo, véase imap_mail_compose()

additional_headers

Como string con cabeceras adicionales para ser establecidas en el correo

cc

bcc

Los destinatarios especificados en bcc recibirán el correo, pero son excluidos de las cabeceras.

rpath

Use este parámetro para especificar la ruta de vuelta si la entrega del corro falla. Esto es útil al usar PHP como un cliente de correo para múltiples usuarios.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mail() - Enviar correo
  • imap_mail_compose() - Crear un mensaje MIME basado en las secciones sobre y cuerpo


Obtener información sobre el buzón actual

  • « imap_mail
  • imap_mime_header_decode »
  • PHP Manual
  • Funciones de IMAP
  • Obtener información sobre el buzón actual

imap_mailboxmsginfo

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mailboxmsginfo — Obtener información sobre el buzón actual

Descripción

imap_mailboxmsginfo ( resource $imap_stream ) : object

Comprueba el estado del buzón actual del servidor. Es similar a imap_status(), excepto que resumirá el tamaño de todos los mensajes del buzón, lo que tomará algún tiempo adicional para ejecutarse.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve la información en un objeto con las siguientes propiedades:

Propiedades del buzón
Date | fecha del último cambio (fecha/hora actuales)
Driver | controlador
Mailbox | nombre del buzón
Nmsgs | número de mensajes
Recent | número de mensajes recientes
Unread | número de mensajes no leídos
Deleted | número de mensajes eliminados
Size | tamaño del buzón

Devuelve false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_mailboxmsginfo()

<?php

$buzón = imap_open("{imap.example.org}INBOX", "username", "password")
      or die("no se puede conectar: " . imap_last_error());

$comprobar = imap_mailboxmsginfo($buzón);

if ($comprobar) {
    echo "Fecha: "       . $comprobar->Date    . "<br />\n" ;
    echo "Controlador: " . $comprobar->Driver  . "<br />\n" ;
    echo "Buzón: "       . $comprobar->Mailbox . "<br />\n" ;
    echo "Mensajes: "    . $comprobar->Nmsgs   . "<br />\n" ;
    echo "Recientes: "   . $comprobar->Recent  . "<br />\n" ;
    echo "No leídos: "   . $comprobar->Unread  . "<br />\n" ;
    echo "Eliminados: "  . $comprobar->Deleted . "<br />\n" ;
    echo "Tamaño: "      . $comprobar->Size    . "<br />\n" ;
} else {
    echo "Falló imap_mailboxmsginfo(): " . imap_last_error() . "<br />\n";
}

imap_close($mbox);

?>


Decodificar los elementos de la cabecera MIME

  • « imap_mailboxmsginfo
  • imap_msgno »
  • PHP Manual
  • Funciones de IMAP
  • Decodificar los elementos de la cabecera MIME

imap_mime_header_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mime_header_decode — Decodificar los elementos de la cabecera MIME

Descripción

imap_mime_header_decode ( string $text ) : array

Decodifica las extensiones de la cabecera del mensaje MIME que no son texto ASCII (véase » RFC2047).

Parámetros

text

El texto MIME

Valores devueltos

Los elementos decodificados son devueltos como un array de objetos, donde cada objeto tiene dos propiedades, charset y text.

Si el elemento no ha sido codificado, y en otras palabras está en US-ASCII plano, la propiedad charset de ese elemento está establecida a default.

Ejemplos

Ejemplo #1 Ejemplo de imap_mime_header_decode()

<?php
$texto = "=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <keld@example.com>";

$elementos = imap_mime_header_decode($texto);
for ($i=0; $i<count($elementos); $i++) {
    echo "Conjunto de caracteres: {$elementos[$i]->charset}\n";
    echo "Texto: {$elementos[$i]->text}\n\n";
}
?>

El resultado del ejemplo sería:

Charset: ISO-8859-1
Texto: Keld Jørn Simonsen

Charset: default
Texto:  <keld@example.com>

En el ejemplo de arriba tendríamos dos elemetos, donce el primer elemento ha sido codificado previamente con ISO-8859-1, y el segundo elemento sería US-ASCII plano.

Ver también

  • imap_utf8() - Convierte texto codificado MIME en UTF-8


Obtiene el número de secuencia de mensaje para el UID dado

  • « imap_mime_header_decode
  • imap_mutf7_to_utf8 »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene el número de secuencia de mensaje para el UID dado

imap_msgno

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_msgno — Obtiene el número de secuencia de mensaje para el UID dado

Descripción

imap_msgno ( resource $imap_stream , int $uid ) : int

Devuelve el número de secuencia de mensaje para el uid dado.

Esta función es la inversa de imap_uid().

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

uid

El UID del mensaje

Valores devueltos

Devuelve el número de secuencia de mensaje para el uid dado.

Ver también

  • imap_uid() - Esta función devuelve el UID del número de secuencia del mensaje dado


Decode a modified UTF-7 string to UTF-8

  • « imap_msgno
  • imap_num_msg »
  • PHP Manual
  • Funciones de IMAP
  • Decode a modified UTF-7 string to UTF-8

imap_mutf7_to_utf8

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8

Descripción

imap_mutf7_to_utf8 ( string $string ) : string|false

Decode a modified UTF-7 (as specified in RFC 2060, section 5.1.3) string to UTF-8.

Nota:

This function is only available, if libcclient exports utf8_to_mutf7().

Parámetros

string

A string encoded in modified UTF-7.

Valores devueltos

Returns string converted to UTF-8, o false en caso de error.

Ver también

  • imap_utf8_to_mutf7() - Encode a UTF-8 string to modified UTF-7


Obtiene el número de mensajes del buzón actual

  • « imap_mutf7_to_utf8
  • imap_num_recent »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene el número de mensajes del buzón actual

imap_num_msg

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_num_msg — Obtiene el número de mensajes del buzón actual

Descripción

imap_num_msg ( resource $imap_stream ) : int

Obtiene el número de mensajes del buzón actual.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve el número de mensajes del buzón actual, como un integer.

Ver también

  • imap_num_recent() - Obtiene el número de mensajes recientes en el buzón actual
  • imap_status() - Devuelve la información de estado de un buzón


Obtiene el número de mensajes recientes en el buzón actual

  • « imap_num_msg
  • imap_open »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene el número de mensajes recientes en el buzón actual

imap_num_recent

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_num_recent — Obtiene el número de mensajes recientes en el buzón actual

Descripción

imap_num_recent ( resource $imap_stream ) : int

Obtiene el número de mensajes recientes en el buzón actual.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve el número de mensajes recientes en el buzón actual, como un integer.

Ver también

  • imap_num_msg() - Obtiene el número de mensajes del buzón actual
  • imap_status() - Devuelve la información de estado de un buzón


Abrir un flujo IMAP a un buzón

  • « imap_num_recent
  • imap_ping »
  • PHP Manual
  • Funciones de IMAP
  • Abrir un flujo IMAP a un buzón

imap_open

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_open — Abrir un flujo IMAP a un buzón

Descripción

imap_open ( string $mailbox , string $username , string $password , int $options = 0 , int $n_retries = 0 , array $params = null ) : resource

Abre un flujo IMAP a un buzón dado por mailbox.

Esta función también se puede usar para abrir flujos a servidores POP3 y NNTP, pero sólo algunas funciones y características están disponibles en servidores IMAP.

Parámetros

mailbox

Un nombre de buzón consiste en una ruta de servidor y una de buzón para este servidor. El nombre especial INBOX permanece para los buzones personales de ususarios actuales. Los nombres de buzón que contienen caracteres internacionales además de aquellos imprimibles del espacio ASCII tienen que ser codificados con imap_utf7_encode().

La ruta del servidor, que está encerrada entre '{' y '}', consiste en los nombres de los servidores o direcciones ip, y el puerto opcional (prefijado por ':'), y una especificación de protocolo opcional (prefijada por '/').

La parte del servidor el obligatoria en todos los parámetros del buzón.

Todos los nombres que empiezan con { son nombres remotos, y están en la forma "{" nombre_sistema_remoto [":" puerto] [banderas] "}" [nombre_buzón] donde:

  • nombre_sistema_remoto - -Nombre de dominio de internet o dirección IP del servidor entre corchetes.
  • port - número de puerto TCP opcional, por omisión es el puerto por defecto para ese servicio
  • flags - banderas opcionales, véase la siguiente tabla.
  • mailbox_name - nombre del buzón remoto, por defecto es INBOX

Banderas opcionales para los nombres
Bandera | Descricpción
/service=servicio | servicio de acceso al buzón, por defecto es "imap"
/user=usuario | nombre de usuario remoto para identificar en el servidor
/authuser=usuario | usuario de autentificación remoto; si se especifica es el nombre de usuario cuya contraseña es usada (p.ej. administrador)
/anonymous | acceso remoto como usuario anónimo
/debug | grabar la telemetría de protocolo en el registro de depuración de la aplicación
/secure | no transmitir una contraseña en texto plano en la red
/imap, /imap2, /imap2bis, /imap4, /imap4rev1 | equivalente a /service=imap
/pop3 | equivalente a /service=pop3
/nntp | equivalente a /service=nntp
/norsh | no usar rsh o ssh para establecer una sesión de IMAP preautenticada
/ssl | usar Secure Socket Layer (Capa de Conexión Segura) para encriptar la sesión
/validate-cert | validar certificados desde el servidor TLS/SSL (este es el comportamiento predeterminado)
/novalidate-cert | no validar certificador desde el servidor TLS/SSL, necesario si el servidor usa certificados autofirmados
/tls | forzar el uso de start-TLS para encriptar la sesión, y rechazar la conexión a servidores que no la soportan
/notls | no realizar start-TLS para encriptar la sesión, incluso con los servidores que la soportan
/readonly | petición de apertura de un buzón de sólo lectura (sólo IMAP; ignorado en NNTP, y un error con SMTP y POP3)

username

El nombre de usuario

password

La contraseña asociada con username

options

options es una máscara de bits con uno o más de lo siguiente:

  • OP_READONLY - Abrir un buzón de sólo lectura
  • OP_ANONYMOUS - No usar o actualizar un .newsrc para noticias (sólo NNTP)
  • OP_HALFOPEN - Para nombres IMAP y NNTP, abrir una conexión pero no abrir el buzón.
  • CL_EXPUNGE - Expurgar el buzón automáticamente al cierre del mismo (véase también imap_delete() y imap_expunge())
  • OP_DEBUG - Depurar negociaciones de protocolo
  • OP_SHORTCACHE - Almacenamiento en caché corto (sólo elt)
  • OP_SILENT - No dejar pasar eventos (uso interno)
  • OP_PROTOTYPE - Devolver el prototipo de controlador
  • OP_SECURE - No realizar autenticación no segura

n_retries

Número máximo de intentos de conexión

params

Parámetros de conexión, las siguientes claves (cadena) pueden usarse para establecer uno o más parámetros de conexión:

  • DISABLE_AUTHENTICATOR - Deshabilitar las propieades de autenticación

Valores devueltos

Devuelve un flujo IMAP en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.2 | Se añadió params
5.2.0 | Se añadió n_retries

Ejemplos

Ejemplo #1 Diferentes usos de imap_open()

<?php
// Para conectarse a un servidor IMAP que se ejecuta en el puerto 142 de la máquina local,
// haga lo siguiente:
$mbox = imap_open("{localhost:143}INBOX", "user_id", "password");

// Para conectarse a un servidor POP3 en el puerto 110 del servidor local, use:
$mbox = imap_open ("{localhost:110/pop3}INBOX", "user_id", "password");

// Para conectarse a un servidor SSL, IMAP o POP3, añada /ssl después de la especificación
// del protocolo:
$mbox = imap_open ("{localhost:993/imap/ssl}INBOX", "user_id", "password");

// Para conectarse a un servidor SSL, IMAP o POP3, con un certificado autofirmado,
// añada /ssl/novalidate-cert después de la especificación del protocolo:
$mbox = imap_open ("{localhost:995/pop3/ssl/novalidate-cert}", "user_id", "password");

// Para conectarse a un servidor NNTP en el puerto 119 en el servidor local, use:
$nntp = imap_open ("{localhost:119/nntp}comp.test", "", "");
// Para conectarse a un servidor remoto reemplace "localhost" con el nombre o la
// dirección IP del servidor al que se quiere conectar.
?>

Ejemplo #2 Ejemplo de imap_open()

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password");

echo "<h1>Buzones</h1>\n";
$carpetas = imap_listmailbox($mbox, "{imap.example.org:143}", "*");

if ($carpetas == false) {
    echo "Llamada fallida<br />\n";
} else {
    foreach ($carpetas as $val) {
        echo $val . "<br />\n";
    }
}

echo "<h1>Cabeceras en INBOX</h1>\n";
$cabeceras = imap_headers($mbox);

if ($cabeceras == false) {
    echo "Llamada fallida<br />\n";
} else {
    foreach ($cabeceras as $val) {
        echo $val . "<br />\n";
    }
}

imap_close($mbox);
?>

Ver también

  • imap_close() - Cerrar una secuencia IMAP


Comprobar si el flujo de IMAP está aún activo

  • « imap_open
  • imap_qprint »
  • PHP Manual
  • Funciones de IMAP
  • Comprobar si el flujo de IMAP está aún activo

imap_ping

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_ping — Comprobar si el flujo de IMAP está aún activo

Descripción

imap_ping ( resource $imap_stream ) : bool

imap_ping() realiza un ping al flujo para ver si aún está activo. Puede descubrir nuevos correos; este es el método preferido para una "comporbación de nuevos correos" periódica así como para "mantenerlo vivo" para servidores que tienen un tiempo límite de inactividad.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

Valores devueltos

Devuelve true si el flujo está aún activo, false si no.

Ejemplos

Ejemplo #1 Ejemplo de imap_ping()

<?php

$imap = imap_open("{imap.example.org}", "mailadmin", "password");

// después de dormir algo
if (!imap_ping($imap)) {
    // dhacer alguna cosa para reconectar
}

?>


Convertir una cadena imprimible entrecomillada a una cadena de 8 bits

  • « imap_ping
  • imap_rename »
  • PHP Manual
  • Funciones de IMAP
  • Convertir una cadena imprimible entrecomillada a una cadena de 8 bits

imap_qprint

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_qprint — Convertir una cadena imprimible entrecomillada a una cadena de 8 bits

Descripción

imap_qprint ( string $string ) : string

Convertir una cadena imprimible entrecomillada a una cadena de 8 bits según » RFC2045, sección 6.7.

Parámetros

string

Una cadena imprimible entrecomillada

Valores devueltos

Devuelve una cadena de 8 bits.

Ver también

  • imap_8bit() - Convertir una cadena 8bit a una cadena quoted-printable


Alias de imap_renamemailbox

  • « imap_qprint
  • imap_renamemailbox »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_renamemailbox

imap_rename

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rename — Alias de imap_renamemailbox()

Descripción

Esta función es un alias de: imap_renamemailbox().


Renombrar un buzón antiguo a un buzón nuevo

  • « imap_rename
  • imap_reopen »
  • PHP Manual
  • Funciones de IMAP
  • Renombrar un buzón antiguo a un buzón nuevo

imap_renamemailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_renamemailbox — Renombrar un buzón antiguo a un buzón nuevo

Descripción

imap_renamemailbox ( resource $imap_stream , string $old_mbox , string $new_mbox ) : bool

Esta función renombra un buzón antiguo a un buzón nuevo (véase imap_open() para el formato de los nombres de mbox).

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

old_mbox

El nombre antiguo del buzón, véase imap_open() para más información

new_mbox

El nuevo nombre del buzón, véase imap_open() para más información

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_createmailbox() - Crear un nuevo buzón de correo
  • imap_deletemailbox() - Elimina un buzón


Reabrir un flujo IMAP hacia un nuevo buzón

  • « imap_renamemailbox
  • imap_rfc822_parse_adrlist »
  • PHP Manual
  • Funciones de IMAP
  • Reabrir un flujo IMAP hacia un nuevo buzón

imap_reopen

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_reopen — Reabrir un flujo IMAP hacia un nuevo buzón

Descripción

imap_reopen ( resource $imap_stream , string $mailbox , int $options = 0 , int $n_retries = 0 ) : bool

Reabre el flujo espeicificado a un nuevo buzón dado por mailbox sobre un servidor IMAP o NNTP.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más información

options

options es una máscara de bits con uno o más de lo siguiente:

  • OP_READONLY - Abrir el buzón en sólo lectura
  • OP_ANONYMOUS - No usar o actualizar un .newsrc para noticias (sólo NNTP)
  • OP_HALFOPEN - Para nombres IMAP y NNTP, abrir una conexión pero no abrir un buzón.
  • OP_EXPUNGE - Expurgar y reciclar el flujo de manera silenciosa
  • CL_EXPUNGE - Expurgar el buzón automáticamente al cierre del mismo (véase también imap_delete() y imap_expunge())

n_retries

Número máximo de intentos de conexion

Valores devueltos

Devuelve true si el flujo es reabierto, false si no.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió n_retries

Ejemplos

Ejemplo #1 Ejemplo de imap_reopen()

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password") or die(implode(", ", imap_errors()));
// ...
imap_reopen($mbox, "{imap.example.org:143}INBOX.Sent") or die(implode(", ", imap_errors()));
// ..
?>


Analiza una cadena de dirección

  • « imap_reopen
  • imap_rfc822_parse_headers »
  • PHP Manual
  • Funciones de IMAP
  • Analiza una cadena de dirección

imap_rfc822_parse_adrlist

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_parse_adrlist — Analiza una cadena de dirección

Descripción

imap_rfc822_parse_adrlist ( string $address , string $default_host ) : array

Analiza la cadena de dirección como está definido en » RFC2822 y para cada dirección.

Parámetros

address

Una cadena que contiene direcciones

default_host

El nombre del host predeterminado

Valores devueltos

Devuelve un array de objetos. Las propiedades de los objetos son:

  • mailbox - el nombre del buzón (nombre de usuario)
  • host - el nombre del host
  • personal - el nombre personal
  • adl - ruta fuente del dominio

Ejemplos

Ejemplo #1 Ejemplo de imap_rfc822_parse_adrlist()

<?php

$cadena_dirección = "Joe Doe <doe@example.com>, postmaster@example.com, root";
$array_dirección  = imap_rfc822_parse_adrlist($cadena_dirección, "example.com");
if (!is_array($array_dirección) || count($array_dirección) < 1) {
    die("algo está mal\n");
}

foreach ($array_dirección as $id => $val) {
    echo "# $id\n";
    echo "  mailbox : " . $val->mailbox . "\n";
    echo "  host    : " . $val->host . "\n";
    echo "  personal: " . $val->personal . "\n";
    echo "  adl     : " . $val->adl . "\n";
}
?>

El resultado del ejemplo sería:

# 0
  mailbox : doe
  host    : example.com
  personal: Joe Doe
  adl     :
# 1
  mailbox : postmaster
  host    : example.com
  personal:
  adl     :
# 2
  mailbox : root
  host    : example.com
  personal:
  adl     :

Ver también

  • imap_rfc822_parse_headers() - Analizar cabeceras de correo desde una cadena


Analizar cabeceras de correo desde una cadena

  • « imap_rfc822_parse_adrlist
  • imap_rfc822_write_address »
  • PHP Manual
  • Funciones de IMAP
  • Analizar cabeceras de correo desde una cadena

imap_rfc822_parse_headers

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_parse_headers — Analizar cabeceras de correo desde una cadena

Descripción

imap_rfc822_parse_headers ( string $headers , string $defaulthost = "UNKNOWN" ) : object

Obtiene un objeto de varios elementos de cabecera, similar a imap_header().

Parámetros

headers

La información de las cabeceras analizadas

defaulthost

El nombre del host predeterminado

Valores devueltos

Devuelve un objeto similar al devuelto por imap_header(), excepto por las banderas y otras propiedades que vienen del servidor IMAP.

Ver también

  • imap_rfc822_parse_adrlist() - Analiza una cadena de dirección


Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal

  • « imap_rfc822_parse_headers
  • imap_savebody »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal

imap_rfc822_write_address

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_write_address — Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal

Descripción

imap_rfc822_write_address ( string $mailbox , string $host , string $personal ) : string

Devuelve una dirección de correo correctamente formateada como está definido en » RFC2822 dada la información necesaria.

Parámetros

mailbox

El nombre del buzón, véase imap_open() para más información

host

La parte del host del correo

personal

El nombre del propietario de la cuenta

Valores devueltos

Devuelve una cadena de dirección de correo correctamente formateada como está definido en » RFC2822.

Ejemplos

Ejemplo #1 Ejemplo de imap_rfc822_write_address()

<?php
echo imap_rfc822_write_address("hartmut", "example.com", "Hartmut Holzgraefe");
?>

El resultado del ejemplo sería:

Hartmut Holzgraefe <hartmut@example.com>


Guardar una sección del cuerpo específica en un fichero

  • « imap_rfc822_write_address
  • imap_scan »
  • PHP Manual
  • Funciones de IMAP
  • Guardar una sección del cuerpo específica en un fichero

imap_savebody

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

imap_savebody — Guardar una sección del cuerpo específica en un fichero

Descripción

imap_savebody ( resource $imap_stream , mixed $file , int $msg_number , string $part_number = "" , int $options = 0 ) : bool

Guarda una parte del cuerpo completo de un mensaje especificado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

file

La ruta al fichero guardado como una cadena, o un descriptor de fichero válido devuelto por fopen().

msg_number

El número de mensaje

part_number

El número de parte. Es una cadena de enteros delimitada por puntos que indexa a una lista de partes de cuerpos como por la especificación IMAP4

options

Una máscara de bits de uno o más de lo siguiente:

  • FT_UID - msg_number es un UID
  • FT_PEEK - No establecer la bandera \Seen si no lo está ya
  • FT_INTERNAL - La cadena devuelta está en formato intermo, no canonizará a CRLF.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_fetchbody() - Traer una sección en particular del cuerpo del mensaje


Alias de imap_listscan

  • « imap_savebody
  • imap_scanmailbox »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_listscan

imap_scan

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_scan — Alias de imap_listscan()

Descripción

Esta función es un alias de: imap_listscan().


Alias de imap_listscan

  • « imap_scan
  • imap_search »
  • PHP Manual
  • Funciones de IMAP
  • Alias de imap_listscan

imap_scanmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_scanmailbox — Alias de imap_listscan()

Descripción

Esta función es un alias de: imap_listscan().


Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado

  • « imap_scanmailbox
  • imap_set_quota »
  • PHP Manual
  • Funciones de IMAP
  • Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado

imap_search

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_search — Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado

Descripción

imap_search ( resource $imap_stream , string $criteria , int $options = SE_FREE , string $charset = null ) : array

Esta función realiza una búsqueda en el buzón actualmente abierto en el flujo IMAP dado.

Por ejemplo, para hacer coincidir todos los mensajes no respondidos por Mami, debería usar: "UNANSWERED FROM mami". La búsqueda parece ser insensible a mayúsculas-minúsculas. La lista de criterios viene dada por una lectura del código fuente de c-client UW y puede estar incompleta o no ser exacta (véase » RFC2060, sección 6.4.4).

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

criteria

Una cadena, delimitada por espacios, en la que están permitidas las siguientes palabras clave. Cualquier argumento multi-palabra (p.ej. FROM "joey smith") debe encerrarse entre comillas. Los resultados serán contra todos los parámetros del campo criteria.

  • ALL - devuelve todos los mensajes que coinciden con el resto del criterio
  • ANSWERED - coincide con los mensajes con la bandera \\ANSWERED establecida
  • BCC "cadena" - coincide con los mensajes con "cadena" en el campo Bcc:
  • BEFORE "fecha" - coincide con los mensajes con Date: antes de "fecha"
  • BODY "cadena" - coincide con los mensajes con "cadena" en el cuerpo del mensaje
  • CC "cadena" - coincide con los mensajes con "cadena" en el campo Cc:
  • DELETED - coincide con los mensajes borrados
  • FLAGGED - coincide con los mensajes con la bandera \\FLAGGED establecida (algunas veces referidos como Importante o Urgente)
  • FROM "cadena" - coincide con los mensajes con "cadena" en el campo From:
  • KEYWORD "cadena" - coincide con los mensajes con "cadena" como palabra clave
  • NEW - coincide con los mensajes nuevos
  • OLD - coincide con los mensajes antiguos
  • ON "fecha" - coincide con los mensajes con Date: coincidiendo con "fecha"
  • RECENT - coincide con los mensajes con la bandera \\RECENT establecida
  • SEEN - coincide con los mensajes que han sido leídos (la bandera \\SEEN está estabecido)
  • SINCE "fecha" - coincide con los mensajes con Date: después de "fecha"
  • SUBJECT "cadena" - coincide con los mensajes con "cadena" en Subject:
  • TEXT "cadena" - coincide con los mensajes con el texto "cadena"
  • TO "cadena" - coincide con los mensajes con "cadena" en To:
  • UNANSWERED - coincide con los mensajes que no han sido respondidos
  • UNDELETED - coincide con los mensajes que no están eliminados
  • UNFLAGGED - coincide con los mensajes que no tienen bandera
  • UNKEYWORD "cadena" - coincide con los mensajes que no tienen la palabra clave "cadena"
  • UNSEEN - coincide con los mensajes que aún no han sido leídos

options

Los valores válidos para options son SE_UID, que causa que el array devuelto contenga UIDs en vez de números de secuencia de mensajes.

charset

Conjunto de caracteres MIME a utilizar cuando se ordenan cadenas.

Valores devueltos

Devuelve un array de números de mensajes o UIDs.

Devuelve false si no comprende el criterio de búsqueda dado por criteria o no se han encontrado mensajes.

Ejemplos

Ejemplo #1 imap_search() example

<?php
$conn   = imap_open('{imap.example.com:993/imap/ssl}INBOX', 'foo@example.com', 'pass123', OP_READONLY);

$some   = imap_search($conn, 'SUBJECT "COMO ser Guapo" SINCE "8 August 2008"', SE_UID);
$msgnos = imap_search($conn, 'ALL');
$uids   = imap_search($conn, 'ALL', SE_UID);

print_r($some);
print_r($msgnos);
print_r($uids);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 4
    [1] => 6
    [2] => 11
)
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
    [5] => 6
)
Array
(
    [0] => 1
    [1] => 4
    [2] => 6
    [3] => 8
    [4] => 11
    [5] => 12
)

Ver también

  • imap_listscan() - Devuelve la lista de buzones que coinciden con el texto dado


Establece una cuota para un buzón dado

  • « imap_search
  • imap_setacl »
  • PHP Manual
  • Funciones de IMAP
  • Establece una cuota para un buzón dado

imap_set_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

imap_set_quota — Establece una cuota para un buzón dado

Descripción

imap_set_quota ( resource $imap_stream , string $quota_root , int $quota_limit ) : bool

Establece una cuota de límite superior sobre una base por buzón.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

quota_root

El buzón que tiene una cuota a establecer. Debería seguir el formato estándar de IMAP para un buzón: user.name.

quota_limit

El tamaño máximo (en KB) para quota_root

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_set_quota()

<?php
$mbox = imap_open("{imap.example.org:143}", "mailadmin", "password");

if (!imap_set_quota($mbox, "user.kalowsky", 3000)) {
    echo "Error al establecer la cuota\n";
    return;
}

imap_close($mbox);
?>

Notas

Esta función actualmente sólo esta disponible para usuarios de la biblioteca c-client2000 o superior.

El parámetro imap_stream dado debe ser abierto como el administrador del buzón, de otro modo está función fallará.

Ver también

  • imap_open() - Abrir un flujo IMAP a un buzón
  • imap_get_quota() - Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón


Establece el ACL para el buzón dado

  • « imap_set_quota
  • imap_setflag_full »
  • PHP Manual
  • Funciones de IMAP
  • Establece el ACL para el buzón dado

imap_setacl

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imap_setacl — Establece el ACL para el buzón dado

Descripción

imap_setacl ( resource $imap_stream , string $mailbox , string $id , string $rights ) : bool

Establece el ACL para un buzón dado.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más información

id

El ususario al que dar los derechos.

rights

Los derechos a dar al usuario. Al pasar una cadena vacía borrará acl.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Esta función actualmente sólo está disponiblre para usuarior de la biblioteca c-client2000 o superior.

Ver también

  • imap_getacl() - Obtiene el ACL para un buzón dado


Establece banderas en mensajes

  • « imap_setacl
  • imap_sort »
  • PHP Manual
  • Funciones de IMAP
  • Establece banderas en mensajes

imap_setflag_full

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_setflag_full — Establece banderas en mensajes

Descripción

imap_setflag_full ( resource $imap_stream , string $sequence , string $flag , int $options = NIL ) : bool

Realiza un almacenaje para añadir la bandera especificada por flag al conjunto de banderas para los mensajes en la secuencia especificada por sequence.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

sequence

Una secuencia de números de mensaje. Puede enumerar los mensajes deseados con la sintaxis X,Y, o recuperar todos los mensajes dentro de un intervalo con la sintaxis X:Y

flag

Las banderas que se pueden establecer son \Seen, \Answered, \Flagged, \Deleted, y \Draft como estaá definido en » RFC2060.

options

Una máscara de bits que puede contener la única opción:

  • ST_UID - El argumento sequence contiene UIDs en lugar de números de secuencia

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de imap_setflag_full()

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password")
     or die("no se puede conectar: " . imap_last_error());

$estado = imap_setflag_full($mbox, "2,5", "\\Seen \\Flagged");

echo gettype($estado) . "\n";
echo $estado . "\n";

imap_close($mbox);
?>

Ver también

  • imap_clearflag_full() - Limpia las banderas de mensajes


Obtiene y ordena mensajes

  • « imap_setflag_full
  • imap_status »
  • PHP Manual
  • Funciones de IMAP
  • Obtiene y ordena mensajes

imap_sort

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_sort — Obtiene y ordena mensajes

Descripción

imap_sort ( resource $imap_stream , int $criteria , int $reverse , int $options = 0 , string $search_criteria = null , string $charset = null ) : array

Obtiene y ordena números de mensajes según los parámetros dados.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

criteria

El criterio puede ser un (y sólo uno) de los siguientes:

  • SORTDATE - Date (fecha) del mensaje
  • SORTARRIVAL - fecha de llegada
  • SORTFROM - buzón en la primera dirección From (De)
  • SORTSUBJECT - asunto del mensaje
  • SORTTO - buzón en la primera dirección To (Para)
  • SORTCC - buzón en la primera dirección cc
  • SORTSIZE - tamaño del mensaje en octetos

reverse

Establezca esto a 1 para ordenación inversa

options

options es una máscara de bits de uno o más de lo siguiente:

  • SE_UID - Devolver UIDs en vez de números de secuencia
  • SE_NOPREFETCH - No preobtener mensajes buscados

search_criteria

Cadena de criterios de búsqueda en formato IMAP2. Véase imap_search() para más detalles.

charset

Conjunto de caracteres MIME a utilizar cuando se ordenan cadenas.

Valores devueltos

Devuelve un array de números de mensajes ordenados según los parámetros dados.


Devuelve la información de estado de un buzón

  • « imap_sort
  • imap_subscribe »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve la información de estado de un buzón

imap_status

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_status — Devuelve la información de estado de un buzón

Descripción

imap_status ( resource $imap_stream , string $mailbox , int $options ) : object

Obtiene la información de estado sobre el buzón dado por mailbox.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más información

options

Las banderas válidas son:

  • SA_MESSAGES - establece $estado->messages al número de mensajes del buzón
  • SA_RECENT - establece $estado->recent al número de mensajes recientes del buzón
  • SA_UNSEEN - establece $estado->unseen al número de mensajes no vistos (nuevos) del buzón
  • SA_UIDNEXT - establece $estado->uidnext al siguiente uid a usar del buzón
  • SA_UIDVALIDITY - establece $estado->uidvalidity a la constante que cambia cuando los uids para el buzón ya no pueden ser válidos
  • SA_ALL - establece todo lo anterior

Valores devueltos

Esta función devuelve un objeto que contiene la infomación de estado. El objeto tiene las siguientes propiedades: messages, recent, unseen, uidnext, y uidvalidity.

flags también está establecido, contiene una máscara de bits que puede ser comprobada con cualquiera de las contastes de arriba.

Ejemplos

Ejemplo #1 Ejemplo de imap_status()

<?php
$mbox = imap_open("{imap.example.com}", "username", "password", OP_HALFOPEN)
      or die("no se pudo conectar: " . imap_last_error());

$estado = imap_status($mbox, "{imap.example.org}INBOX", SA_ALL);
if ($estado) {
  echo "Mensajes:    " . $estado->messages    . "<br />\n";
  echo "Recientes:   " . $estado->recent      . "<br />\n";
  echo "No vistos:   " . $estado->unseen      . "<br />\n";
  echo "SiguienteUID:" . $estado->uidnext     . "<br />\n";
  echo "ValidezUID:  " . $estado->uidvalidity . "<br />\n";
} else {
  echo "imap_status failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>


Suscribirse a un buzón

  • « imap_status
  • imap_thread »
  • PHP Manual
  • Funciones de IMAP
  • Suscribirse a un buzón

imap_subscribe

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_subscribe — Suscribirse a un buzón

Descripción

imap_subscribe ( resource $imap_stream , string $mailbox ) : bool

Suscribirse a un buzón nuevo.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más información

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_unsubscribe() - Cancelar la inscripción de un buzón


Devuelve un árbol de mensajes hilados

  • « imap_subscribe
  • imap_timeout »
  • PHP Manual
  • Funciones de IMAP
  • Devuelve un árbol de mensajes hilados

imap_thread

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imap_thread — Devuelve un árbol de mensajes hilados

Descripción

imap_thread ( resource $imap_stream , int $options = SE_FREE ) : array

Obtiene un árbol de mensajes hilados.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

options

Valores devueltos

imap_thread() devuelve un array asociativo que contiene un árbol de mensajes hilados mediante REFERENCES, o false en caso de error.

Cada mensaje del buzón actual será representado por tres entradas en el array resultante:

  • $thread["XX.num"] - número de mensaje actual

  • $thread["XX.next"]

  • $thread["XX.branch"]

Ejemplos

Ejemplo #1 Ejemplo de imap_thread()

<?php

// Imprimimos los hilos de un grupo de noticias, en HTML

$nntp = imap_open('{news.example.com:119/nntp}some.newsgroup', '', '');
$threads = imap_thread($nntp);

foreach ($threads as $key => $val) {
  $tree = explode('.', $key);
  if ($tree[1] == 'num') {
    $header = imap_headerinfo($nntp, $val);
    echo "<ul>\n\t<li>" . $header->fromaddress . "\n";
  } elseif ($tree[1] == 'branch') {
    echo "\t</li>\n</ul>\n";
  }
}

imap_close($nntp);

?>


Establece o obtiene el tiempo de espera de imap

  • « imap_thread
  • imap_uid »
  • PHP Manual
  • Funciones de IMAP
  • Establece o obtiene el tiempo de espera de imap

imap_timeout

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

imap_timeout — Establece o obtiene el tiempo de espera de imap

Descripción

imap_timeout ( int $timeout_type , int $timeout = -1 ) : mixed

Establece o obtiene el tiempo de espera de imap.

Parámetros

timeout_type

Uno de los siguientes tipos: IMAP_OPENTIMEOUT, IMAP_READTIMEOUT, IMAP_WRITETIMEOUT, o IMAP_CLOSETIMEOUT.

timeout

El tiempo de espera, en segundos.

Valores devueltos

Si se establece el parámetro timeout, esta función devuelve true en caso de éxito y false en caso de error.

Si no se proporciona timeout o se evalúa a -1, se devuelve el valor del tiempo de espera de timeout_type como un valor de tipo entero.

Ejemplos

Ejemplo #1 Ejemplo de imap_timeout()

<?php

echo "El tiempo de espera de lectura actual es " . imap_timeout(IMAP_READTIMEOUT) . "\n";

?>


Esta función devuelve el UID del número de secuencia del mensaje dado

  • « imap_timeout
  • imap_undelete »
  • PHP Manual
  • Funciones de IMAP
  • Esta función devuelve el UID del número de secuencia del mensaje dado

imap_uid

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_uid — Esta función devuelve el UID del número de secuencia del mensaje dado

Descripción

imap_uid ( resource $imap_stream , int $msg_number ) : int

Esta función devuelve el UID del número de secuencia del mensaje dado. Un UID es un identificador único que no cambiará durante el tiempo mientras que un número de secuencia de un mensaje puede cambiar si el contenido del buzón cambia.

Esta función es la inversa de imap_msgno().

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

El número de mensaje.

Valores devueltos

EL UID del mensaje dado.

Notas

Nota:

Esta función no está soportada por buzones POP3.

Ver también

  • imap_msgno() - Obtiene el número de secuencia de mensaje para el UID dado


Desmarcar el mensaje que está marcado para borrar

  • « imap_uid
  • imap_unsubscribe »
  • PHP Manual
  • Funciones de IMAP
  • Desmarcar el mensaje que está marcado para borrar

imap_undelete

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_undelete — Desmarcar el mensaje que está marcado para borrar

Descripción

imap_undelete ( resource $imap_stream , int $msg_number , int $flags = 0 ) : bool

Elimina la bandera de borrado de un mensaje especificado, que está establecida mediante imap_delete() o imap_mail_move().

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

msg_number

EL número de mensaje

flags

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_delete() - Marcar un mensaje para su borrado del buzón actual
  • imap_mail_move() - Mover los mensajes especificados a un buzón


Cancelar la inscripción de un buzón

  • « imap_undelete
  • imap_utf7_decode »
  • PHP Manual
  • Funciones de IMAP
  • Cancelar la inscripción de un buzón

imap_unsubscribe

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_unsubscribe — Cancelar la inscripción de un buzón

Descripción

imap_unsubscribe ( resource $imap_stream , string $mailbox ) : bool

Cancela la inscripción del buzón especificado por mailbox.

Parámetros

imap_stream

IMAP stream devuelto por imap_open().

mailbox

El nombre del buzón, véase imap_open() para más información

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • imap_subscribe() - Suscribirse a un buzón


Decodifica una cadena codificada con UTF-7 modificado

  • « imap_unsubscribe
  • imap_utf7_encode »
  • PHP Manual
  • Funciones de IMAP
  • Decodifica una cadena codificada con UTF-7 modificado

imap_utf7_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf7_decode — Decodifica una cadena codificada con UTF-7 modificado

Descripción

imap_utf7_decode ( string $text ) : string

Decodifica el parámetro text UTF-7 modificado en una cadena ISO-8859-1.

Esta función es necesaria para decodificar nombres de buzones que contienen ciertos caracteres que no están en el rango de caracteres imprimibles de ASCII.

Parámetros

text

Una cadena codificada UTF-7 modificado, como está definido en » RFC 2060, sección 5.1.3 (el UTF-7 original fue definido en » RFC1642).

Valores devueltos

Devuelve una cadena que está codificada en ISO-8859-1 y consisite en la misma secuencia de caracteres de text, o false si text contiene una secuencia UTF-7 modificado no válida o text contiene un carácter que no es parte del conjunto de caracteres ISO-8859-1.

Ver también

  • imap_utf7_encode() - Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado


Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado

  • « imap_utf7_decode
  • imap_utf8_to_mutf7 »
  • PHP Manual
  • Funciones de IMAP
  • Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado

imap_utf7_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf7_encode — Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado

Descripción

imap_utf7_encode ( string $data ) : string

Convierte data a texto UTF-7 modificado.

Esto es necesario para codificar nombres de buzones que contienen ciertos caracteres que no están en el conjunto de caracters imprimibles de ASCII.

Parámetros

data

Una cadena ISO-8859-1.

Valores devueltos

Devuelve data codificado con la codificación UTF-7 modificada como está definido en » RFC 2060, sección 5.1.3 (el UTF-7 original fue definido en » RFC1642).

Ver también

  • imap_utf7_decode() - Decodifica una cadena codificada con UTF-7 modificado


Encode a UTF-8 string to modified UTF-7

  • « imap_utf7_encode
  • imap_utf8 »
  • PHP Manual
  • Funciones de IMAP
  • Encode a UTF-8 string to modified UTF-7

imap_utf8_to_mutf7

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7

Descripción

imap_utf8_to_mutf7 ( string $string ) : string|false

Encode a UTF-8 string to modified UTF-7 (as specified in RFC 2060, section 5.1.3).

Nota:

This function is only available, if libcclient exports utf8_to_mutf7().

Parámetros

string

A UTF-8 encoded string.

Valores devueltos

Returns string converted to modified UTF-7, o false en caso de error.

Ver también

  • imap_mutf7_to_utf8() - Decode a modified UTF-7 string to UTF-8


Convierte texto codificado MIME en UTF-8

  • « imap_utf8_to_mutf7
  • Mail »
  • PHP Manual
  • Funciones de IMAP
  • Convierte texto codificado MIME en UTF-8

imap_utf8

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf8 — Convierte texto codificado MIME en UTF-8

Descripción

imap_utf8 ( string $mime_encoded_text ) : string

Convierte el parámetro dado por mime_encoded_text en UTF-8.

Parámetros

mime_encoded_text

Una cadena codificada MIME. El método de codificación MIME y la especificación UTF-8 están descritas en » RFC2047 y » RFC2044 respectivamente.

Valores devueltos

Devuelve una cadena codificada en UTF-8.

Ver también

  • imap_mime_header_decode() - Decodificar los elementos de la cabecera MIME


Mail

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de mail
    • ezmlm_hash — Calcula el valor hash que necesita EZMLM
    • mail — Enviar correo


  • « Mail
  • Instalación/Configuración »
  • PHP Manual
  • Mail
  • Introducción

Introducción

La función mail() permite enviar correos.


Requerimientos

Para que las funciones de Mail estén disponibles, PHP debe tener acceso al binario de sendmail en el sistema durante el momento de compilación. Si se usa otro sistema de correo como qmail o postfix, es necesario que el wrapper apropiado venga con él. PHP buscará primero sendmail en PATH y entonces en: /usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib. Es altamente recomendable que sendmail se encuentre en PATH. Además, el usuario con el que está compilado PHP debe tener permiso para acceder al binario de sendmail.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Mail
Nombre | Por defecto | Cambiable | Historial de cambios
mail.add_x_header | "0" | PHP_INI_PERDIR | Disponible a partir de PHP 5.3.0.
mail.log | NULL | PHP_INI_PERDIR | Disponible a partir de PHP 5.3.0. (PHP_INI_SYSTEM|PHP_INI_PERDIR)
mail.force_extra_parameters | NULL | PHP_INI_PERDIR | Disponible a partir de PHP 5.0.0. (PHP_INI_SYSTEM|PHP_INI_PERDIR)
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL | Disponible a partir de PHP 4.3.0.
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | "/usr/sbin/sendmail -t -i" | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

mail.add_x_header bool

Añade X-PHP-Originating-Script que incluirá el UID del script seguido por el nombre del fichero.

mail.log string

La ruta al archivo log que registrará todos los llamados a la función mail(). Las entradas de registro incluyen la ruta completa al script, número de línea, dirección To y cabeceras.

mail.force_extra_parameters string

Fuerza la adición de los parámetros especificados a ser pasados como parámetros extra al binario de sendmail. Estos parámetros siempre remplazarán el valor del 5º parámetro a mail(), incluso en el modo seguro.

SMTP string

Únicamente bajo Windows: nombre del servidor o dirección IP del servidor SMTP que debe usar PHP para enviar los correos con la función mail().

smtp_port int

Únicamente bajo Windows: número del puerto al que conectar en el servidor especificado en las opciones SMTP cuando se envíe un correo con mail(); por defecto 25. Disponible desde PHP 4.3.0.

sendmail_from string

Cual dirección de correo "From:" debe ser usada como remitente del correo enviado por PHP bajo Windows. Esta directiva también establece el valor de la cabecera "Return-Path:".

sendmail_path string

Ruta donde puede encontrarse el programa sendmail, generalmente /usr/sbin/sendmail o /usr/lib/sendmail. configure intenta localizarlo para establecerlo por defecto, pero si falla, se usa esta variable.

Los sistemas que no usen sendmail deberían establecer esta directiva al wrapper o sistema alternativo que ofrezca el sistema de correo, si tiene. Por ejemplo, usuarios de » Qmail pueden fijar como valor /var/qmail/bin/sendmail o /var/qmail/bin/qmail-inject.

qmail-inject no requiere ninguna opción para procesar correo correctamente.

Esta directiva funciona también bajo Windows. Si se le da un valor, smtp, smtp_port y sendmail_from son ignorados y se ejecuta el comando especificado.


  • « Tipos de recursos
  • Funciones de mail »
  • PHP Manual
  • Mail
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de mail

Tabla de contenidos

  • ezmlm_hash — Calcula el valor hash que necesita EZMLM
  • mail — Enviar correo


Calcula el valor hash que necesita EZMLM

  • « Funciones de mail
  • mail »
  • PHP Manual
  • Funciones de mail
  • Calcula el valor hash que necesita EZMLM

ezmlm_hash

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ezmlm_hash — Calcula el valor hash que necesita EZMLM

Descripción

ezmlm_hash ( string $addr ) : int

ezmlm_hash() calcula el valor hash necesario cuando se guardan listas de correo EZMLM en una base de datos MySQL.

Parámetros

addr

La dirección de correo de la que se quiere crear el hash.

Valores devueltos

El valor hash de addr.

Ejemplos

Ejemplo #1 Calcular el hash de un usuario suscriptor.

<?php

$usuario = "joecool@example.com";
$hash = ezmlm_hash($usuario);
$query = sprintf("INSERT INTO sample VALUES (%s, '%s')", $hash, $usuario);
$db->query($query); // usando interface PHPLIB db

?>


Enviar correo

  • « ezmlm_hash
  • Mailparse »
  • PHP Manual
  • Funciones de mail
  • Enviar correo

mail

(PHP 4, PHP 5, PHP 7, PHP 8)

mail — Enviar correo

Descripción

mail ( string $to , string $subject , string $message , string $additional_headers = ? , string $additional_parameters = ? ) : bool

Envía un correo electrónico.

Parámetros

to

Destinatario/s del correo.

El formato de este string debe cumplir con la » RFC 2822. Algunos ejemplos son:

  • usuario@example.com
  • usuario@example.com, otrousuario@example.com
  • Usuario <usuario@example.com>
  • Usuario <usuario@example.com>, Otro usuario <otrousuario@example.com>

subject

Título del correo electrónico a enviar.

Precaución

El título debe cumplir con la » RFC 2047.

message

Mensaje a enviar.

Cada línea debería separarse con un CRLF (\r\n). Las líneas no deberían ocupar más de 70 caracteres.

Precaución

(Sólo en Windows) Cuando PHP se comunica directamente con un servidor SMTP, si encuentra un punto al principio de la línea, éste se elimina. Para evitar esto es necesario reemplazar estas apariciones con un doble punto.

<?php
$texto = str_replace("\n.", "\n..", $texto);
?>

additional_headers (opcional)

String a insertar al final de la cabecera del correo.

Se usa normalmente para añadir cabeceras extra (From, Cc y Bcc). Las cabeceras múltiples adicionales deberían separarse con un CRLF(\r\n). Si se usan datos externos para componer esta cabecera, los datos deberían ser saneados para que no se inyecten cabeceras no deseadas.

Nota:

additional_headers no posee protección de inyección de cabeceras de correo. Por tanto, los usuarios deben asegurarse de que las cabeceras especificadas son seguras y contienen solamente cabeceras. Es decir, nunca iniciar el cuerpo del correo con varias nuevas líneas.

Nota:

Cuando se envía un correo, este debe contener una cabecera From. Puede establecerse con el parámetro additional_headers, o puede definirse un valor predeterminaro en php.ini.

Si no se realiza esta acción se obtendrá un mensaje de error similar a Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing (Advertencia: mail(): "sendmail_from" no establecido en php.ini o falta la cabecera personalizada "From:"). La cabecera From también establece Return-Path bajo Windows.

Nota:

Si no se reciben los mensajes enviados, intente usar solamente LF (\n). Algunos agentes de transferencia de correo de Unix (como » qmail) reemplzan LF por CRLF automáticamente (lo que conlleva doblar CR si se usa CRLF). Esto debería ser el último recurso, pues no cumple con la » RFC 2822.

additional_parameters (opcional)

El parámetro additional_parameters puede usarse para indicar opciones adicionales como opciones de línea de comandos al programa que está configurado para usarse cuando se envía correo, definido por la opción de configuración sendmail_path. Por ejemplo, puede usarse para establecer la dirección de correo del remitente usando sendmail con su opción -f.

Este parámetro es escapado internamente por escapeshellcmd() para prevenir la ejecución del comando. Aunque escapeshellcmd() evita la ejecución del comando, permite añadir parámetros adicionales. Por razones de seguridad, se recomienda que el usuario sanee este parámetro para evitar que se añadan parámetros indeseados al comando.

Ya que escapeshellcmd() se aplica automáticamente, algunos caracteres que están permitidos como direcciones de correo electrónico por algún RFC no se pueden usar. mail() no puede permitir tales caracteres, por lo que en programas donde el uso de tales caracters sea necesario, se recomienda una vía alternativa de enviar correos (como usar un marco de trabajo o una biblioteca).

El usuario usado por el servidor web debería ser añadido como usuario de confianza en la configuración de sendmail para evitar que se añada la cabecera 'X-Warning' al mensaje cuando se añada la dirección de remitente (-f) usando este método. Para los usuarios de sendmail, este fichero es /etc/mail/trusted-users.

Valores devueltos

Devuelve true si el correo ha sido aceptado para su envío, de lo contrario false.

Es importante tener en cuenta que si el correo es aceptado para su envío, NO quiere decir que el correo haya alcanzado el destino indicado.

Historial de cambios

Versión | Descripción
7.2.0 | El parámetro additional_headers ahora también acepta array.

Ejemplos

Ejemplo #1 Enviar un correo.

Usando mail() para enviar un correo simple:

<?php
// El mensaje
$mensaje = "Línea 1\r\nLínea 2\r\nLínea 3";

// Si cualquier línea es más larga de 70 caracteres, se debería usar wordwrap()
$mensaje = wordwrap($mensaje, 70, "\r\n");

// Enviarlo
mail('caffeinated@example.com', 'Mi título', $mensaje);
?>

Ejemplo #2 Enviar un correo con cabeceras extra.

Adición de cabeceras básicas, diciendo al MUA las direcciones From y Reply-To:

<?php
$para      = 'nobody@example.com';
$titulo    = 'El título';
$mensaje   = 'Hola';
$cabeceras = 'From: webmaster@example.com' . "\r\n" .
    'Reply-To: webmaster@example.com' . "\r\n" .
    'X-Mailer: PHP/' . phpversion();

mail($para, $titulo, $mensaje, $cabeceras);
?>

Ejemplo #3 Enviar un correo con parámetros de línea de comando adicionales.

Se puede usar el parámetro additional_parameters para proporcionar parámetros adicicionales al programa configurado para usar en el envío de correo utilizando sendmail_path.

<?php
mail('nadie@example.com', 'El título', 'El mensaje', null,
'-fwebmaster@example.com');
?>

Ejemplo #4 Envío de un correo HTML

Es posible también enviar correos HTML con mail().

<?php
// Varios destinatarios
$para  = 'aidan@example.com' . ', '; // atención a la coma
$para .= 'wez@example.com';

// título
$título = 'Recordatorio de cumpleaños para Agosto';

// mensaje
$mensaje = '
<html>
<head>
  <title>Recordatorio de cumpleaños para Agosto</title>
</head>
<body>
  <p>¡Estos son los cumpleaños para Agosto!</p>
  <table>
    <tr>
      <th>Quien</th><th>Día</th><th>Mes</th><th>Año</th>
    </tr>
    <tr>
      <td>Joe</td><td>3</td><td>Agosto</td><td>1970</td>
    </tr>
    <tr>
      <td>Sally</td><td>17</td><td>Agosto</td><td>1973</td>
    </tr>
  </table>
</body>
</html>
';

// Para enviar un correo HTML, debe establecerse la cabecera Content-type
$cabeceras  = 'MIME-Version: 1.0' . "\r\n";
$cabeceras .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";

// Cabeceras adicionales
$cabeceras .= 'To: Mary <mary@example.com>, Kelly <kelly@example.com>' . "\r\n";
$cabeceras .= 'From: Recordatorio <cumples@example.com>' . "\r\n";
$cabeceras .= 'Cc: birthdayarchive@example.com' . "\r\n";
$cabeceras .= 'Bcc: birthdaycheck@example.com' . "\r\n";

// Enviarlo
mail($para, $título, $mensaje, $cabeceras);
?>

Nota:

Si la intención es enviar HTML u otro tipo de correo complejo, es recomendable usar el paquete PEAR » PEAR::Mail_Mime.

Notas

Nota:

La implementación en Windows de mail() difiere bastante de la implementación en Unix. Primero, no usa un binario local para componer mensajes ya que sólo opera en sockets directos, lo que significa que es necesario un MTA escuchando en un socket de red (que puede estar tanto en localhost como en una máquina remota).

Segundo, las cabeceras personalizadas como From:, Cc:, Bcc: y Date:, de entrada no son interpretadas por el MTA, aunque son analizadas por PHP.

Por esto, el parámetro to no debería ser una dirección de correo de la forma "Algo <alguien@example.com>". Es posible que el comando mail no analice esto correctamente mientrasz dialoga con el MTA.

Nota:

Es importante indicar que la función mail() no es conveniente para grandes volúmenes de correo en bucle. Esta función abre y cierra un socket SMTP para cada correo, algo que no es muy eficiente.

Para enviar una gran cantidad de correo, véanse los paquetes » PEAR::Mail y » PEAR::Mail_Queue.

Nota:

Las siguientes RFC pueden ser de utilidad: » RFC 1896, » RFC 2045, » RFC 2046, » RFC 2047, » RFC 2048, » RFC 2049, y » RFC 2822.

Ver también

  • imap_mail() - Enviar un mensaje de correo electrónico
  • » PEAR::Mail
  • » PEAR::Mail_Mime


Mailparse

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones Mailparse
    • mailparse_determine_best_xfer_encoding — Obtiene la mejor forma de codificar
    • mailparse_msg_create — Crea un recurso de correo mime
    • mailparse_msg_extract_part_file — Extrae/decodifica una sección de mensaje
    • mailparse_msg_extract_part — Extrae/decodifica una sección de mensaje
    • mailparse_msg_extract_whole_part_file — Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada
    • mailparse_msg_free — Libera un recurso MIME
    • mailparse_msg_get_part_data — Devuelve una matriz asociativa de información sobre el mensaje
    • mailparse_msg_get_part — Devuelve un gestor sobre una sección dada en un mensaje mime
    • mailparse_msg_get_structure — Devuelve una matriz de nombres de sección mime en el mensaje dado
    • mailparse_msg_parse_file — Procesa un archivo
    • mailparse_msg_parse — Procesar datos incrementalmente sobre un búfer
    • mailparse_rfc822_parse_addresses — Procesa direcciones compatibles con RFC 822
    • mailparse_stream_encode — Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino
    • mailparse_uudecode_all — Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu


Introducción

Mailparse es una extensión para analizar y trabajar con los mensajes de correo electrónico. Esto puede tratarse con los mensajes compatibles » RFC 822 y » RFC 2045 (MIME).

Mailparse está basado en flujo, lo que significa que no guarda en memoria las copias de los archivos que procesa - lo que es muy eficiente para recursos cuando se trata de mensajes de gran tamaño.

Nota:

Mailparse requiere la extensión mbstring, y mbstring debe cargarse antes de mailparse.


Instalación

Esta extensión » PECL no se distribuye con PHP. Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mailparse.

Para poder utilizar estas funciones se debe compilar PHP con soporte para mailparse mediante la opción de configuración --enable-mailparse.

Los usuarios de windows deben habilitar php_mailparse.dll en el fichero php.ini con el fin de usar estas funciones. Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .

Es necesario que la extensión mbstring esté cargada antes que mailparse.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

MAILPARSE_EXTRACT_OUTPUT (integer)
MAILPARSE_EXTRACT_STREAM (integer)
MAILPARSE_EXTRACT_RETURN (integer)


Funciones Mailparse

Tabla de contenidos

  • mailparse_determine_best_xfer_encoding — Obtiene la mejor forma de codificar
  • mailparse_msg_create — Crea un recurso de correo mime
  • mailparse_msg_extract_part_file — Extrae/decodifica una sección de mensaje
  • mailparse_msg_extract_part — Extrae/decodifica una sección de mensaje
  • mailparse_msg_extract_whole_part_file — Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada
  • mailparse_msg_free — Libera un recurso MIME
  • mailparse_msg_get_part_data — Devuelve una matriz asociativa de información sobre el mensaje
  • mailparse_msg_get_part — Devuelve un gestor sobre una sección dada en un mensaje mime
  • mailparse_msg_get_structure — Devuelve una matriz de nombres de sección mime en el mensaje dado
  • mailparse_msg_parse_file — Procesa un archivo
  • mailparse_msg_parse — Procesar datos incrementalmente sobre un búfer
  • mailparse_rfc822_parse_addresses — Procesa direcciones compatibles con RFC 822
  • mailparse_stream_encode — Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino
  • mailparse_uudecode_all — Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu


Obtiene la mejor forma de codificar

  • « Funciones Mailparse
  • mailparse_msg_create »
  • PHP Manual
  • Funciones Mailparse
  • Obtiene la mejor forma de codificar

mailparse_determine_best_xfer_encoding

(PECL mailparse >= 0.9.0)

mailparse_determine_best_xfer_encoding — Obtiene la mejor forma de codificar

Descripción

mailparse_determine_best_xfer_encoding ( resource $fp ) : string

Encuentra la mejor forma de codificar el contenido leído del apuntador de archivo dado.

Parámetros

fp

Un apuntador de archivo válido, que reciba operaciones de búsqueda.

Valores devueltos

Devuelve una de las codificaciones de caracteres soportadas por el módulo mbstring.

Ejemplos

Ejemplo #1 Ejemplo de mailparse_determine_best_xfer_encoding()

<?php

$aa = fopen('alguncorreo.eml', 'r');
echo 'Mejor codificación: ' . mailparse_determine_best_xfer_encoding($aa);

?>

El resultado del ejemplo sería algo similar a:

Mejor codificación: 7bit


Crea un recurso de correo mime

  • « mailparse_determine_best_xfer_encoding
  • mailparse_msg_extract_part_file »
  • PHP Manual
  • Funciones Mailparse
  • Crea un recurso de correo mime

mailparse_msg_create

(PECL mailparse >= 0.9.0)

mailparse_msg_create — Crea un recurso de correo mime

Descripción

mailparse_msg_create ( ) : resource

Crea un recurso tipo correo MIME.

Valores devueltos

Devuelve un recurso que puede ser usado para interpretar un mensaje.

Ver también

  • mailparse_msg_free() - Libera un recurso MIME
  • mailparse_msg_parse_file() - Procesa un archivo


Extrae/decodifica una sección de mensaje

  • « mailparse_msg_create
  • mailparse_msg_extract_part »
  • PHP Manual
  • Funciones Mailparse
  • Extrae/decodifica una sección de mensaje

mailparse_msg_extract_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part_file — Extrae/decodifica una sección de mensaje

Descripción

mailparse_msg_extract_part_file ( resource $mimemail , mixed $filename , callable $callbackfunc = ? ) : string

Extrae/decodifica una sección de mensaje del archivo indicado.

Los contenidos de la sección serán decodificados de acuerdo a su codificación de transferencia - se soportan base64, imprimible-con-comillas y texto uuencode.

Parámetros

mimemail

Un recurso MIME válido, creado con mailparse_msg_create().

filename

Puede ser un nombre de archivo o un recurso de secuencia válido.

callbackfunc

Si se define, este parámetro debe ser una llamada de retorno válida, a la cual le será pasada la sección extraída, o null para asegurarse de que esta función devuelva la sección extraída.

Si no se especifica, los contenidos serán enviados a "stdout".

Valores devueltos

Si callbackfunc es diferente de null devuelve true en caso de éxito.

Si callbackfunc es null, devuelve la sección extraída como una cadena.

Devuelve false en caso de fallo.

Ver también

  • mailparse_msg_extract_part() - Extrae/decodifica una sección de mensaje
  • mailparse_msg_extract_whole_part_file() - Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada


Extrae/decodifica una sección de mensaje

  • « mailparse_msg_extract_part_file
  • mailparse_msg_extract_whole_part_file »
  • PHP Manual
  • Funciones Mailparse
  • Extrae/decodifica una sección de mensaje

mailparse_msg_extract_part

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part — Extrae/decodifica una sección de mensaje

Descripción

mailparse_msg_extract_part ( resource $mimemail , string $msgbody , callable $callbackfunc = ? ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mimemail

Un recurso MIME válido.

msgbody

callbackfunc

Valores devueltos

No devuelve ningún valor.

Ver también

  • mailparse_msg_extract_part_file() - Extrae/decodifica una sección de mensaje
  • mailparse_msg_extract_whole_part_file() - Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada


Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada

  • « mailparse_msg_extract_part
  • mailparse_msg_free »
  • PHP Manual
  • Funciones Mailparse
  • Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada

mailparse_msg_extract_whole_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_whole_part_file — Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada

Descripción

mailparse_msg_extract_whole_part_file ( resource $mimemail , string $filename , callable $callbackfunc = ? ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mimemail

Un recurso MIME válido.

filename

callbackfunc

Valores devueltos

Ver también

  • mailparse_msg_extract_part() - Extrae/decodifica una sección de mensaje
  • mailparse_msg_extract_part_file() - Extrae/decodifica una sección de mensaje


Libera un recurso MIME

  • « mailparse_msg_extract_whole_part_file
  • mailparse_msg_get_part_data »
  • PHP Manual
  • Funciones Mailparse
  • Libera un recurso MIME

mailparse_msg_free

(PECL mailparse >= 0.9.0)

mailparse_msg_free — Libera un recurso MIME

Descripción

mailparse_msg_free ( resource $mimemail ) : bool

Libera un recurso MIME.

Parámetros

mimemail

Un recurso MIME válido reservado por mailparse_msg_create() o mailparse_msg_parse_file().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • mailparse_msg_create() - Crea un recurso de correo mime
  • mailparse_msg_parse_file() - Procesa un archivo


Devuelve una matriz asociativa de información sobre el mensaje

  • « mailparse_msg_free
  • mailparse_msg_get_part »
  • PHP Manual
  • Funciones Mailparse
  • Devuelve una matriz asociativa de información sobre el mensaje

mailparse_msg_get_part_data

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part_data — Devuelve una matriz asociativa de información sobre el mensaje

Descripción

mailparse_msg_get_part_data ( resource $mimemail ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mimemail

Un recurso MIME válido.


Devuelve un gestor sobre una sección dada en un mensaje mime

  • « mailparse_msg_get_part_data
  • mailparse_msg_get_structure »
  • PHP Manual
  • Funciones Mailparse
  • Devuelve un gestor sobre una sección dada en un mensaje mime

mailparse_msg_get_part

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part — Devuelve un gestor sobre una sección dada en un mensaje mime

Descripción

mailparse_msg_get_part ( resource $mimemail , string $mimesection ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mimemail

Un recurso MIME válido.

mimesection


Devuelve una matriz de nombres de sección mime en el mensaje dado

  • « mailparse_msg_get_part
  • mailparse_msg_parse_file »
  • PHP Manual
  • Funciones Mailparse
  • Devuelve una matriz de nombres de sección mime en el mensaje dado

mailparse_msg_get_structure

(PECL mailparse >= 0.9.0)

mailparse_msg_get_structure — Devuelve una matriz de nombres de sección mime en el mensaje dado

Descripción

mailparse_msg_get_structure ( resource $mimemail ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mimemail

Un recurso MIME válido.


Procesa un archivo

  • « mailparse_msg_get_structure
  • mailparse_msg_parse »
  • PHP Manual
  • Funciones Mailparse
  • Procesa un archivo

mailparse_msg_parse_file

(PECL mailparse >= 0.9.0)

mailparse_msg_parse_file — Procesa un archivo

Descripción

mailparse_msg_parse_file ( string $filename ) : resource

Procesa un archivo. Este es el modo óptimo de interpretar un archivo que tenga en disco.

Parámetros

filename

Ruta al archivo que contiene el mensaje. El archivo es abierto y secuenciado a través del analizador sintáctico.

Valores devueltos

Devuelve un recurso MIME que representa la estructura, o false en caso de error.

Ver también

  • mailparse_msg_free() - Libera un recurso MIME
  • mailparse_msg_create() - Crea un recurso de correo mime


Procesar datos incrementalmente sobre un búfer

  • « mailparse_msg_parse_file
  • mailparse_rfc822_parse_addresses »
  • PHP Manual
  • Funciones Mailparse
  • Procesar datos incrementalmente sobre un búfer

mailparse_msg_parse

(PECL mailparse >= 0.9.0)

mailparse_msg_parse — Procesar datos incrementalmente sobre un búfer

Descripción

mailparse_msg_parse ( resource $mimemail , string $data ) : bool

Procesa datos incrementalmente al interior del recurso de correo mime entregado.

Esta función le permite secuenciar porciones de un archivo en pedazos, en lugar de leer y procesarlo en su totalidad.

Parámetros

mimemail

Un recurso MIME válido.

data

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Procesa direcciones compatibles con RFC 822

  • « mailparse_msg_parse
  • mailparse_stream_encode »
  • PHP Manual
  • Funciones Mailparse
  • Procesa direcciones compatibles con RFC 822

mailparse_rfc822_parse_addresses

(PECL mailparse >= 0.9.0)

mailparse_rfc822_parse_addresses — Procesa direcciones compatibles con RFC 822

Descripción

mailparse_rfc822_parse_addresses ( string $addresses ) : array

Procesa una lista de recipientes compatible con » RFC 822, tal como la que es encontrada en una cabecera To:.

Parámetros

addresses

Una cadena que contiene direcciones, como: Wez Furlong <wez@example.com>, pepe@example.com

Nota:

Esta cadena no debe contener el nombre de la cabecera.

Valores devueltos

Devuelve una matriz de matrices asociativas con las siguientes claves para cada recipiente:

display | El nombre del recipiente, para propósitos de muestra. Si esta parte no es definida para un recipiente, esta clave contendrá el mismo valor que address.
address | La dirección de correo electrónico
is_group | true si el recipiente es un grupo de noticias, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de mailparse_rfc822_parse_addresses()

<?php

$to = 'Wez Furlong <wez@example.com>, pepe@example.com';
var_dump(mailparse_rfc822_parse_addresses($to));

?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  array(3) {
    ["display"]=>
    string(11) "Wez Furlong"
    ["address"]=>
    string(15) "wez@example.com"
    ["is_group"]=>
    bool(false)
  }
  [1]=>
  array(3) {
    ["display"]=>
    string(16) "pepe@example.com"
    ["address"]=>
    string(16) "pepe@example.com"
    ["is_group"]=>
    bool(false)
  }
}


Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino

  • « mailparse_rfc822_parse_addresses
  • mailparse_uudecode_all »
  • PHP Manual
  • Funciones Mailparse
  • Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino

mailparse_stream_encode

(PECL mailparse >= 0.9.0)

mailparse_stream_encode — Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino

Descripción

mailparse_stream_encode ( resource $sourcefp , resource $destfp , string $encoding ) : bool

Secuencia datos del apuntador de archivo fuente, aplica la codificacion y escribe al apuntador de archivo de destino.

Parámetros

sourcefp

Un gestor de archivo válido. El archivo es secuenciado a través del procesador.

destfp

El gestor de archivo de destino, en el cual los datos codificados serán escritos.

encoding

Una de las codificaciones de caracteres soportadas por el módulo mbstring.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de mailparse_stream_encode()

<?php

// Contenido de email.eml: hola, este es un trozo de texto=hola.
$aa = fopen('email.eml', 'r');

$dest = tmpfile();

mailparse_stream_encode($aa, $dest, "quoted-printable");

rewind($dest);

// Mostrar el contenido del nuevo archivo
fpassthru($dest);

?>

El resultado del ejemplo sería:

hola, este es un trozo de texto=3Dhola.


Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu

  • « mailparse_stream_encode
  • Extensiones matemáticas »
  • PHP Manual
  • Funciones Mailparse
  • Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu

mailparse_uudecode_all

(PECL mailparse >= 0.9.0)

mailparse_uudecode_all — Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu

Descripción

mailparse_uudecode_all ( resource $fp ) : array

Lee los datos del apuntador de archivo dado y extrae cada archivo codificado mediante uuencode embebido en un archivo temporal.

Parámetros

fp

Un apuntador de archivo válido.

Valores devueltos

Devuelve una matriz de matrices asociativas, listando la información de cada archivo.

filename | Ruta al nombre de archivo temporal creado
origfilename | El nombre de archivo original, solo para partes codificadas mediante uuencode
La primera entrada es el cuerpo del mensaje. Las siguientes son los archivos uuencode decodificados.

Ejemplos

Ejemplo #1 Ejemplo de mailparse_uudecode_all()

<?php

$texto = <<<EOD
To: fred@example.com

hello, this is some text hello.
blah blah blah.

begin 644 test.txt
/=&AI<R!I<R!A('1E<W0*
`
end

EOD;

$aa = tmpfile();
fwrite($aa, $texto);

$datos = mailparse_uudecode_all($aa);

echo "BODY\n";
readfile($datos[0]["filename"]);
echo "UUE ({$datos[1]['origfilename']})\n";
readfile($datos[1]["filename"]);

// Limpiar
unlink($datos[0]["filename"]);
unlink($datos[1]["filename"]);

?>

El resultado del ejemplo sería:

BODY
To: fred@example.com

hello, this is some text hello.
blah blah blah.

UUE (test.txt)
this is a test


Extensiones matemáticas

  • BC Math — Matemáticas de precisión arbitraria BCMath
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de BC Math
  • GMP — Precisión Múltiple de GNU (GNU Multiple Precision)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de GMP
    • GMP — La clase GMP
  • Math — Funciones matemáticas
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones Matemáticas
  • Estadísticas
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Estadísticas
  • Trader — Análisis técnico para comerciantes
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Trader


Matemáticas de precisión arbitraria BCMath

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de BC Math
    • bcadd — Añade dos números de precisión arbitrária
    • bccomp — Compara dos números de precisión arbitraria
    • bcdiv — Divide dos números de precisión arbitraria
    • bcmod — Obtiene el módulo de un número de precisión arbitraria
    • bcmul — Multiplica dos números de precisión arbitraria
    • bcpow — Elevar un número de precisión arbitraria a otro
    • bcpowmod — Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado
    • bcscale — Establece los parametros de scale por defecto para todas las funciones matemáticas de bc
    • bcsqrt — Obtiene la raiz cuadrada de un número de precisión arbitraria
    • bcsub — Resta un número de precisión arbitraria de otro


Introducción

Para operaciones matemáticas de precisión arbitraria PHP ofrece la Calculadora Binaria, la cual adminte números de cualquier tamaño y precisión, representados como strings.


Instalación

Esta función solamente está disponible si PHP está configurado con --enable-bcmath.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

BCmath Opciones de Configuración
Nombre | Por defecto | Cambiable | Historial de cambios
bcmath.scale | "0" | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

bcmath.scale integer

Número de dígitos decimales para todas las funciones bcmath. Ver también bcscale().


  • « Tipos de recursos
  • Funciones de BC Math »
  • PHP Manual
  • BC Math
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de BC Math

Tabla de contenidos

  • bcadd — Añade dos números de precisión arbitrária
  • bccomp — Compara dos números de precisión arbitraria
  • bcdiv — Divide dos números de precisión arbitraria
  • bcmod — Obtiene el módulo de un número de precisión arbitraria
  • bcmul — Multiplica dos números de precisión arbitraria
  • bcpow — Elevar un número de precisión arbitraria a otro
  • bcpowmod — Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado
  • bcscale — Establece los parametros de scale por defecto para todas las funciones matemáticas de bc
  • bcsqrt — Obtiene la raiz cuadrada de un número de precisión arbitraria
  • bcsub — Resta un número de precisión arbitraria de otro


Añade dos números de precisión arbitrária

  • « Funciones de BC Math
  • bccomp »
  • PHP Manual
  • Funciones de BC Math
  • Añade dos números de precisión arbitrária

bcadd

(PHP 4, PHP 5, PHP 7, PHP 8)

bcadd — Añade dos números de precisión arbitrária

Descripción

bcadd ( string $left_operand , string $right_operand , int $scale = 0 ) : string

Suma operando_izquierda y operando_derecha.

Parámetros

left_operand

El left_operand, como una cadena

right_operand

El right_operand, como una cadena

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

La suma de dos operandos, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo bcadd()

<?php

$a = '1.234';
$b = '5';

echo bcadd($a, $b);     // 6
echo bcadd($a, $b, 4);  // 6.2340

?>

Ver también

  • bcsub() - Resta un número de precisión arbitraria de otro


Compara dos números de precisión arbitraria

  • « bcadd
  • bcdiv »
  • PHP Manual
  • Funciones de BC Math
  • Compara dos números de precisión arbitraria

bccomp

(PHP 4, PHP 5, PHP 7, PHP 8)

bccomp — Compara dos números de precisión arbitraria

Descripción

bccomp ( string $left_operand , string $right_operand , int $scale = 0 ) : int

Compara el left_operand contra right_operand y devuelve como resultado un entero.

Parámetros

left_operand

El operador de la izquierda, como una cadena.

right_operand

El operador de la derecha, como una cadena.

scale

El parámetro opcional scale es usado para indicar el número de dígitos decimales que se utilizarán en la comparación.

Valores devueltos

Devuelve 0 si los dos operandos son iguales, 1 si el left_operand es mayor que el right_operand, de lo contrario -1.

Ejemplos

Ejemplo #1 Ejemplobccomp()

<?php

echo bccomp('1', '2') . "\n";   // -1
echo bccomp('1.00001', '1', 3); // 0
echo bccomp('1.00001', '1', 5); // 1

?>


Divide dos números de precisión arbitraria

  • « bccomp
  • bcmod »
  • PHP Manual
  • Funciones de BC Math
  • Divide dos números de precisión arbitraria

bcdiv

(PHP 4, PHP 5, PHP 7, PHP 8)

bcdiv — Divide dos números de precisión arbitraria

Descripción

bcdiv ( string $left_operand , string $right_operand , int $scale = 0 ) : string

Divide el left_operand por el right_operand.

Parámetros

left_operand

El left operand, como una cadena.

right_operand

El right operand, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

Devuelve el resultado de la división como una cadena, or null si el right_operand es 0.

Ejemplos

Ejemplo #1 Ejemplo bcdiv()

<?php

echo bcdiv('105', '6.55957', 3);  // 16.007

?>

Ver también

  • bcmul() - Multiplica dos números de precisión arbitraria


Obtiene el módulo de un número de precisión arbitraria

  • « bcdiv
  • bcmul »
  • PHP Manual
  • Funciones de BC Math
  • Obtiene el módulo de un número de precisión arbitraria

bcmod

(PHP 4, PHP 5, PHP 7, PHP 8)

bcmod — Obtiene el módulo de un número de precisión arbitraria

Descripción

bcmod ( string $left_operand , string $modulus ) : string

Obtiene el módulo del left_operand usando modulus.

Parámetros

left_operand

El left operand, como una cadena.

modulus

El modulus, como una cadena.

Valores devueltos

Devuelve el módulo como una cadena, o null si modulus es 0.

Ejemplos

Ejemplo #1 Ejemplo bcmod()

<?php
echo bcmod('4', '2'); // 0
echo bcmod('2', '4'); // 2
?>

Ver también

  • bcdiv() - Divide dos números de precisión arbitraria


Multiplica dos números de precisión arbitraria

  • « bcmod
  • bcpow »
  • PHP Manual
  • Funciones de BC Math
  • Multiplica dos números de precisión arbitraria

bcmul

(PHP 4, PHP 5, PHP 7, PHP 8)

bcmul — Multiplica dos números de precisión arbitraria

Descripción

bcmul ( string $left_operand , string $right_operand , int $scale = 0 ) : string

Multiplica el left_operand por el right_operand.

Parámetros

left_operand

El left operand, como una cadena.

right_operand

El right operand, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

Devuelve el resultado como una cadena.

Ejemplos

Ejemplo #1 Ejemplo bcmul()

<?php
echo bcmul('1.34747474747', '35', 3); // 47.161
echo bcmul('2', '4'); // 8
?>

Ver también

  • bcdiv() - Divide dos números de precisión arbitraria


Elevar un número de precisión arbitraria a otro

  • « bcmul
  • bcpowmod »
  • PHP Manual
  • Funciones de BC Math
  • Elevar un número de precisión arbitraria a otro

bcpow

(PHP 4, PHP 5, PHP 7, PHP 8)

bcpow — Elevar un número de precisión arbitraria a otro

Descripción

bcpow ( string $left_operand , string $right_operand , int $scale = ? ) : string

Elevar left_operand a la potencia right_operand.

Parámetros

left_operand

El left operand, como una cadena.

right_operand

El right operand, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

Devuelve el resultado como una cadena.

Ejemplos

Ejemplo #1 Ejemplo bcpow()

<?php

echo bcpow('4.2', '3', 2); // 74.08

?>

Notas

Nota:

bcpow() podría devolver un resultado con menos dígitos tras el punto decimal que los indicados en el parámetro scale. Esto sucede únicamente cuando el resultado no necesita toda la precisión disponible por scale. Por ejemplo:

Ejemplo #2 Ejemplo de escalado de bcpow()

<?php
echo bcpow('5', '2', 2);     // imprime "25", no "25.00"
?>

Ver también

  • bcpowmod() - Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado
  • bcsqrt() - Obtiene la raiz cuadrada de un número de precisión arbitraria


Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado

  • « bcpow
  • bcscale »
  • PHP Manual
  • Funciones de BC Math
  • Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado

bcpowmod

(PHP 5, PHP 7, PHP 8)

bcpowmod — Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado

Descripción

bcpowmod ( string $left_operand = "" , string $right_operand = "" , string $modulus = "" , int $scale = int ) : string

Usa el método de exponenciación rápida para aumentar el left_operand a la potencia right_operand con respecto al módulo modulus.

Parámetros

left_operand

El left operand, como una cadena.

right_operand

El right operand, como una cadena.

modulus

El modulus, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

Devuelve el resultado como una cadena, o null si modulus es 0.

Notas

Nota:

Debido a que este método utiliza la operación módulo, podrían obtenerse resultados inesperados en números enteros no positivos.

Ejemplos

Los siguientes dos comandos son funcionalmente idénticos. La version bcpowmod() sin embargo, se ejecuta en menos tiempo y admite mas parametros.

<?php
$a = bcpowmod($x, $y, $mod);

$b = bcmod(bcpow($x, $y), $mod);

// $a and $b are equal to each other.

?>

Ver también

  • bcpow() - Elevar un número de precisión arbitraria a otro
  • bcmod() - Obtiene el módulo de un número de precisión arbitraria


Establece los parametros de scale por defecto para todas las funciones matemáticas de bc

  • « bcpowmod
  • bcsqrt »
  • PHP Manual
  • Funciones de BC Math
  • Establece los parametros de scale por defecto para todas las funciones matemáticas de bc

bcscale

(PHP 4, PHP 5, PHP 7, PHP 8)

bcscale — Establece los parametros de scale por defecto para todas las funciones matemáticas de bc

Descripción

bcscale ( int $scale ) : bool

Establece los parametros de scale para todas las subsiguientes llamadas a funciones matemáticas bc, donde no se especifica el parametro de scale.

Parámetros

scale

El factor scale.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo bcscale()

<?php

// default scale : 3
bcscale(3);
echo bcdiv('105', '6.55957'); // 16.007

// this is the same without bcscale()
echo bcdiv('105', '6.55957', 3); // 16.007

?>


Obtiene la raiz cuadrada de un número de precisión arbitraria

  • « bcscale
  • bcsub »
  • PHP Manual
  • Funciones de BC Math
  • Obtiene la raiz cuadrada de un número de precisión arbitraria

bcsqrt

(PHP 4, PHP 5, PHP 7, PHP 8)

bcsqrt — Obtiene la raiz cuadrada de un número de precisión arbitraria

Descripción

bcsqrt ( string $operand , int $scale = 0 ) : string

Devuelve la raiz cudrada de operand.

Parámetros

operand

El operand, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

Devuelve la raiz cuadrada como una cadena, o null si operand es negativo.

Ejemplos

Ejemplo #1 Ejemplo bcsqrt()

<?php

echo bcsqrt('2', 3); // 1.414

?>

Ver también

  • bcpow() - Elevar un número de precisión arbitraria a otro


Resta un número de precisión arbitraria de otro

  • « bcsqrt
  • GMP »
  • PHP Manual
  • Funciones de BC Math
  • Resta un número de precisión arbitraria de otro

bcsub

(PHP 4, PHP 5, PHP 7, PHP 8)

bcsub — Resta un número de precisión arbitraria de otro

Descripción

bcsub ( string $left_operand , string $right_operand , int $scale = 0 ) : string

Resta el right_operand del left_operand.

Parámetros

left_operand

El left operand, como una cadena.

right_operand

El right operand, como una cadena.

scale

Este parámetro opcional es usado para establecer el número de dígitos después del punto decimal en el resultado. Si se omite, su valor será el de la escala establecida globalmente con la función bcscale(), o se recurrirá a 0 si este valor no ha sido establecido.

Valores devueltos

El resultado de la resta, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo bcsub()

<?php

$a = '1.234';
$b = '5';

echo bcsub($a, $b);     // -3
echo bcsub($a, $b, 4);  // -3.7660

?>

Ver también

  • bcadd() - Añade dos números de precisión arbitrária


Precisión Múltiple de GNU (GNU Multiple Precision)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de GMP
    • gmp_abs — Valor absoluto
    • gmp_add — Agrega números
    • gmp_and — AND a nivel de bit
    • gmp_binomial — Calculates binomial coefficient
    • gmp_clrbit — Limpia un bit
    • gmp_cmp — Compara los números
    • gmp_com — Calcula uno de los complementos
    • gmp_div_q — Divide los números
    • gmp_div_qr — Divide los números y obtiene el cociente y resto
    • gmp_div_r — El resto de la división de los números
    • gmp_div — Alias de gmp_div_q
    • gmp_divexact — División exacta de números
    • gmp_export — Exportar a un string binario
    • gmp_fact — Factorial
    • gmp_gcd — Calcula el máximo común divisor
    • gmp_gcdext — Calcula el máximo común divisor y multiplicadores
    • gmp_hamdist — Distancia Hamming
    • gmp_import — Importar de un string binario
    • gmp_init — Crea un número GMP
    • gmp_intval — Convertir un número GMP a entero
    • gmp_invert — Inverso del modulo
    • gmp_jacobi — Símbolo Jacobi
    • gmp_kronecker — Kronecker symbol
    • gmp_lcm — Calculate LCM
    • gmp_legendre — Símbolo Legendre
    • gmp_mod — Modulo de operación
    • gmp_mul — Multiplicación de números
    • gmp_neg — Número negativo
    • gmp_nextprime — Encuentra el siguiente número primo
    • gmp_or — Nivel de bit OR
    • gmp_perfect_power — Perfect power check
    • gmp_perfect_square — Comprueba el cuadrado perfecto
    • gmp_popcount — Cuenta la población
    • gmp_pow — Aumenta el número a la potencia
    • gmp_powm — Eleva un número a la potencia con modulo
    • gmp_prob_prime — Revisa si el número es "probablemente primo"
    • gmp_random_bits — Un número aleatorio
    • gmp_random_range — Un número aleatorio
    • gmp_random_seed — Establece la semilla RNG
    • gmp_random — Numero al azar
    • gmp_root — Tomar la parte entera de una raíz enésima
    • gmp_rootrem — Tomar la parte entera y el resto de una raíz enésima
    • gmp_scan0 — Escanear para 0
    • gmp_scan1 — Escanear para 1
    • gmp_setbit — Establece el bit
    • gmp_sign — El símbolo del número
    • gmp_sqrt — Calcula la raíz cuadrada
    • gmp_sqrtrem — Raíz cuadrada con resto
    • gmp_strval — Convierte un número GMP a cadena
    • gmp_sub — Resta los números
    • gmp_testbit — Prueba si un bit es establecido
    • gmp_xor — Nivel de bit XOR
  • GMP — La clase GMP


Introducción

Estas funciones permiten trabajar con números enteros de longitud arbitraria usando la biblioteca MP de GNU.

Nota:

La mayoría de las funciones de GMP aceptan argumentos numéricos. Estos se muestran en esta documentación como objetos GMP. Sin enbargo, observe que PHP 5.5 y anteriores representaban números GMP como resource. La mayoría de estas funciones también aceptarán argumentos numéricos y de string, siempre que sea posible convertir estos últimos a un número. Además, si existe una función de más rendimiento que pueda operar con los argumentos (de tipo entero solamente), sería usada en su lugar (esto se realiza de forma transparente). Véase también la función gmp_init().

Nota:

A partir de PHP 5.6 en adelante, se pueden usar los operadores aritméticos, a nivel de bit y de comparación con los objetos GMP devueltos desde gmp_init() y otras funciones de GMP.

Advertencia

Los objetos grandes deben especificarse como cadenas, o de lo contrario, PHP los forzará a floats, resultando en una pérdida de precisión.

Nota: Esta extensión está disponible en plataformas Windows desde PHP 5.1.0.


Requerimientos

Se puede descargar la biblioteca GMP desde » http://gmplib.org/#DOWNLOAD. En este sitio también está disponible el manual de GMP.

Se requiere al menos la versión 2 de GMP, aunque algunas funciones requieren una versión más reciente de la biblioteca GMP.


Instalación

En orden a de tener estas funciones disponibles, se tiene que compilar el PHP con apoyo de GMP por el uso de la opción --with-gmp.


Tipos de recursos

Antes de PHP 5.6, la mayoría de las funciones de GMP operan con o devuelven recursos de número GMP. Desde PHP 5.6 en adelante se usan objetos GMP en lugar del recursos de números GMP.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

GMP_ROUND_ZERO (integer)
GMP_ROUND_PLUSINF (integer)
GMP_ROUND_MINUSINF (integer)
GMP_VERSION (string)
La versión de la librería GMP


Ejemplos

Ejemplo #1 Función factorial usando GMP

<?php
function fact($x)
{
    $return = 1;
    for ($i=2; $i <= $x; $i++) {
        $return = gmp_mul($return, $i);
    }
    return $return;
}

echo gmp_strval(fact(1000)) . "\n";
?>

Esto va a calcular el factorial de 1000 (Un bonito gran número) muy rápido.


Funciones de GMP

Ver también

Más funciones matemáticas pueden ser encontradas en la Extensiones matemáticas sección

Tabla de contenidos

  • gmp_abs — Valor absoluto
  • gmp_add — Agrega números
  • gmp_and — AND a nivel de bit
  • gmp_binomial — Calculates binomial coefficient
  • gmp_clrbit — Limpia un bit
  • gmp_cmp — Compara los números
  • gmp_com — Calcula uno de los complementos
  • gmp_div_q — Divide los números
  • gmp_div_qr — Divide los números y obtiene el cociente y resto
  • gmp_div_r — El resto de la división de los números
  • gmp_div — Alias de gmp_div_q
  • gmp_divexact — División exacta de números
  • gmp_export — Exportar a un string binario
  • gmp_fact — Factorial
  • gmp_gcd — Calcula el máximo común divisor
  • gmp_gcdext — Calcula el máximo común divisor y multiplicadores
  • gmp_hamdist — Distancia Hamming
  • gmp_import — Importar de un string binario
  • gmp_init — Crea un número GMP
  • gmp_intval — Convertir un número GMP a entero
  • gmp_invert — Inverso del modulo
  • gmp_jacobi — Símbolo Jacobi
  • gmp_kronecker — Kronecker symbol
  • gmp_lcm — Calculate LCM
  • gmp_legendre — Símbolo Legendre
  • gmp_mod — Modulo de operación
  • gmp_mul — Multiplicación de números
  • gmp_neg — Número negativo
  • gmp_nextprime — Encuentra el siguiente número primo
  • gmp_or — Nivel de bit OR
  • gmp_perfect_power — Perfect power check
  • gmp_perfect_square — Comprueba el cuadrado perfecto
  • gmp_popcount — Cuenta la población
  • gmp_pow — Aumenta el número a la potencia
  • gmp_powm — Eleva un número a la potencia con modulo
  • gmp_prob_prime — Revisa si el número es "probablemente primo"
  • gmp_random_bits — Un número aleatorio
  • gmp_random_range — Un número aleatorio
  • gmp_random_seed — Establece la semilla RNG
  • gmp_random — Numero al azar
  • gmp_root — Tomar la parte entera de una raíz enésima
  • gmp_rootrem — Tomar la parte entera y el resto de una raíz enésima
  • gmp_scan0 — Escanear para 0
  • gmp_scan1 — Escanear para 1
  • gmp_setbit — Establece el bit
  • gmp_sign — El símbolo del número
  • gmp_sqrt — Calcula la raíz cuadrada
  • gmp_sqrtrem — Raíz cuadrada con resto
  • gmp_strval — Convierte un número GMP a cadena
  • gmp_sub — Resta los números
  • gmp_testbit — Prueba si un bit es establecido
  • gmp_xor — Nivel de bit XOR


Valor absoluto

  • « Funciones de GMP
  • gmp_add »
  • PHP Manual
  • Funciones de GMP
  • Valor absoluto

gmp_abs

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_abs — Valor absoluto

Descripción

gmp_abs ( GMP $a ) : GMP

Obtiene el valor absoluto de un número.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve el valor absoluto a, como un número GMP.

Ejemplos

Ejemplo #1 Ejemplo de gmp_abs()

<?php
$abs1 = gmp_abs("274982683358");
$abs2 = gmp_abs("-274982683358");

echo gmp_strval($abs1) . "\n";
echo gmp_strval($abs2) . "\n";
?>

El resultado del ejemplo sería:

274982683358
274982683358


Agrega números

  • « gmp_abs
  • gmp_and »
  • PHP Manual
  • Funciones de GMP
  • Agrega números

gmp_add

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_add — Agrega números

Descripción

gmp_add ( GMP $a , GMP $b ) : GMP

Agrega dos números.

Parámetros

a

Un número que va a ser agregado.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

Un número que va a ser agregado.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número GMP representa la suma de los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de gmp_add()

<?php
$sum = gmp_add("123456789012345", "76543210987655");
echo gmp_strval($sum) . "\n";
?>

El resultado del ejemplo sería:

200000000000000


AND a nivel de bit

  • « gmp_add
  • gmp_binomial »
  • PHP Manual
  • Funciones de GMP
  • AND a nivel de bit

gmp_and

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_and — AND a nivel de bit

Descripción

gmp_and ( GMP $a , GMP $b ) : GMP

Calcula el AND a nivel de bit de dos números GMP.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número represetando la comparación del nivel de bit AND.

Ejemplos

Ejemplo #1 Ejemplo de gmp_and()

<?php
$and1 = gmp_and("0xfffffffff4", "0x4");
$and2 = gmp_and("0xfffffffff4", "0x8");
echo gmp_strval($and1) . "\n";
echo gmp_strval($and2) . "\n";
?>

El resultado del ejemplo sería:

4
0


Calculates binomial coefficient

  • « gmp_and
  • gmp_clrbit »
  • PHP Manual
  • Funciones de GMP
  • Calculates binomial coefficient

gmp_binomial

(PHP 7 >= 7.3.0, PHP 8)

gmp_binomial — Calculates binomial coefficient

Descripción

gmp_binomial ( GMP|int|string $n , int $k ) : GMP

Calculates the binomial coefficient C(n, k).

Parámetros

n

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

k

Valores devueltos

Returns the binomial coefficient C(n, k).

Errores/Excepciones

Throws ValueError if k is negative. Prior to PHP 8.0.0, E_WARNING was issued instead.

Historial de cambios

Versión | Descripción
8.0.0 | This function no longer returns false on failure.


Limpia un bit

  • « gmp_binomial
  • gmp_cmp »
  • PHP Manual
  • Funciones de GMP
  • Limpia un bit

gmp_clrbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_clrbit — Limpia un bit

Descripción

gmp_clrbit ( GMP $a , int $index ) : void

Limpia el bit (lo establece a 0) index en a. El índice empieza 0.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

index

El índice del bit a limpiar. El índice 0 representa el bit menos significantivo.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_clrbit()

<?php
$a = gmp_init("0xff");
gmp_clrbit($a, 0); // index starts at 0, least significant bit
echo gmp_strval($a) . "\n";
?>

El resultado del ejemplo sería:

254

Notas

Nota:

A diferencia de otras funciones GMP, La gmp_clrbit() tiene que ser llamada con un recurso GMP que ya exista (usando gmp_init() por ejemplo). No se va a crear automáticamente.

Ver también

  • gmp_setbit() - Establece el bit
  • gmp_testbit() - Prueba si un bit es establecido


Compara los números

  • « gmp_clrbit
  • gmp_com »
  • PHP Manual
  • Funciones de GMP
  • Compara los números

gmp_cmp

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_cmp — Compara los números

Descripción

gmp_cmp ( GMP $a , GMP $b ) : int

Compara dos números.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuleve un valor positivo si a > b, el cero si a = b y el valor negativo de a si a < b.

Ejemplos

Ejemplo #1 gmp_cmp() example

<?php
$cmp1 = gmp_cmp("1234", "1000"); // greater than
$cmp2 = gmp_cmp("1000", "1234"); // less than
$cmp3 = gmp_cmp("1234", "1234"); // equal to

echo "$cmp1 $cmp2 $cmp3\n";
?>

El resultado del ejemplo sería:

1 -1 0


Calcula uno de los complementos

  • « gmp_cmp
  • gmp_div_q »
  • PHP Manual
  • Funciones de GMP
  • Calcula uno de los complementos

gmp_com

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_com — Calcula uno de los complementos

Descripción

gmp_com ( GMP $a ) : GMP

Devuelve uno de los complementos de a.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve uno de los complementos de a, como un número GMP.

Ejemplos

Ejemplo #1 Ejemplo de gmp_com()

<?php
$com = gmp_com("1234");
echo gmp_strval($com) . "\n";
?>

El resultado del ejemplo sería:

-1235


Divide los números

  • « gmp_com
  • gmp_div_qr »
  • PHP Manual
  • Funciones de GMP
  • Divide los números

gmp_div_q

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_q — Divide los números

Descripción

gmp_div_q ( GMP $a , GMP $b , int $round = GMP_ROUND_ZERO ) : GMP

Divide a con b y devuelve el entero resultante.

Parámetros

a

El número que sera dividido.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

El número que a esta siendo dividido.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

round

El redondeo resultante es definido por el round, el cual puede tener uno de los siguientes valores:

  • GMP_ROUND_ZERO: El resultante es truncado hacia o.
  • GMP_ROUND_PLUSINF:El resultado es redondeado hacia +infinity.
  • GMP_ROUND_MINUSINF: El resultado es redondeado hacia -infinity.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_div_q()

<?php
$div1 = gmp_div_q("100", "5");
echo gmp_strval($div1) . "\n";

$div2 = gmp_div_q("1", "3");
echo gmp_strval($div2) . "\n";

$div3 = gmp_div_q("1", "3", GMP_ROUND_PLUSINF);
echo gmp_strval($div3) . "\n";

$div4 = gmp_div_q("-1", "4", GMP_ROUND_PLUSINF);
echo gmp_strval($div4) . "\n";

$div5 = gmp_div_q("-1", "4", GMP_ROUND_MINUSINF);
echo gmp_strval($div5) . "\n";
?>

El resultado del ejemplo sería:

20
0
1
0
-1

Notas

Nota:

This function can also be called as gmp_div().

Ver también

  • gmp_div_r() - El resto de la división de los números
  • gmp_div_qr() - Divide los números y obtiene el cociente y resto


Divide los números y obtiene el cociente y resto

  • « gmp_div_q
  • gmp_div_r »
  • PHP Manual
  • Funciones de GMP
  • Divide los números y obtiene el cociente y resto

gmp_div_qr

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_qr — Divide los números y obtiene el cociente y resto

Descripción

gmp_div_qr ( GMP $n , GMP $d , int $round = GMP_ROUND_ZERO ) : array

La función divide a n por d.

Parámetros

n

El número que es dividido.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

d

El número que es dividio por n.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

round

Ver la función gmp_div_q() para la descripción del argumento round.

Valores devueltos

Devuelve un array, con el primer elemento siendo [n/d] (el entero resultante de la división) y el segundo siendo (n - [n/d] * d) (el resto de la división).

Ejemplos

Ejemplo #1 División de números GMP

<?php
$a = gmp_init("0x41682179fbf5");
$res = gmp_div_qr($a, "0xDEFE75");
printf("El resultado es: q - %s, r - %s",
       gmp_strval($res[0]), gmp_strval($res[1]));
?>

Ver también

  • gmp_div_q() - Divide los números
  • gmp_div_r() - El resto de la división de los números


El resto de la división de los números

  • « gmp_div_qr
  • gmp_div »
  • PHP Manual
  • Funciones de GMP
  • El resto de la división de los números

gmp_div_r

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_r — El resto de la división de los números

Descripción

gmp_div_r ( GMP $n , GMP $d , int $round = GMP_ROUND_ZERO ) : GMP

Calcula el resto de la división entera de n por d. El tiene el signo del argumento n, si no es cero.

Parámetros

n

El número que es dividido.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

d

El número que es dividio por n.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

round

Ver la función gmp_div_q() para la descripción del argumento round.

Valores devueltos

The remainder, as a GMP number.

Ejemplos

Ejemplo #1 gmp_div_r() example

<?php
$div = gmp_div_r("105", "20");
echo gmp_strval($div) . "\n";
?>

El resultado del ejemplo sería:

5

Ver también

  • gmp_div_q() - Divide los números
  • gmp_div_qr() - Divide los números y obtiene el cociente y resto


Alias de gmp_div_q

  • « gmp_div_r
  • gmp_divexact »
  • PHP Manual
  • Funciones de GMP
  • Alias de gmp_div_q

gmp_div

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div — Alias de gmp_div_q()

Descripción

Esta función es un alias de: gmp_div_q().


División exacta de números

  • « gmp_div
  • gmp_export »
  • PHP Manual
  • Funciones de GMP
  • División exacta de números

gmp_divexact

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_divexact — División exacta de números

Descripción

gmp_divexact ( GMP $n , GMP $d ) : GMP

Divide n por d, usando el rápido algoritmo de "división exacta". Ésta función produce el resultado correcto solo cuando es conocida por adelantado d divide a n.

Parámetros

n

El número que es dividido.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

d

El número que es dividio por a.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo degmp_divexact()

<?php
$div1 = gmp_divexact("10", "2");
echo gmp_strval($div1) . "\n";

$div2 = gmp_divexact("10", "3"); // resultado falso
echo gmp_strval($div2) . "\n";
?>

El resultado del ejemplo sería:

5
2863311534


Exportar a un string binario

  • « gmp_divexact
  • gmp_fact »
  • PHP Manual
  • Funciones de GMP
  • Exportar a un string binario

gmp_export

(PHP 5 >= 5.6.1, PHP 7, PHP 8)

gmp_export — Exportar a un string binario

Descripción

gmp_export ( GMP $gmpnumber , integer $word_size , integer $options ) : string

Exporta un número GMP a un string binario

Parámetros

gmpnumber

El número GMP a exportar

word_size

El valor predeterminado es 1. El número de bytes de cada trozo de datos binarios. Principalmente se emplea junto con el parámetro 'options'.

options

El valor predeterminado es GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

Valores devueltos

Devuelve un string o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gmp_export()

<?php
$number = gmp_init(16705);
echo gmp_export($number) . "\n";
?>

El resultado del ejemplo sería:

AA


Factorial

  • « gmp_export
  • gmp_gcd »
  • PHP Manual
  • Funciones de GMP
  • Factorial

gmp_fact

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_fact — Factorial

Descripción

gmp_fact ( mixed $a ) : GMP

Calcula el factorial (a!) de a.

Parámetros

a

El número factorial.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo degmp_fact()

<?php
$fact1 = gmp_fact(5); // 5 * 4 * 3 * 2 * 1
echo gmp_strval($fact1) . "\n";

$fact2 = gmp_fact(50); // 50 * 49 * 48, ... etc
echo gmp_strval($fact2) . "\n";
?>

El resultado del ejemplo sería:

120
30414093201713378043612608166064768844377641568960512000000000000


Calcula el máximo común divisor

  • « gmp_fact
  • gmp_gcdext »
  • PHP Manual
  • Funciones de GMP
  • Calcula el máximo común divisor

gmp_gcd

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_gcd — Calcula el máximo común divisor

Descripción

gmp_gcd ( GMP $a , GMP $b ) : GMP

Calcula el máximo común divisor de a y b. El resultado es siempre positivo aun si cualquiera de, o ambos, operadores fueran negativos.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número positivo GMP que divide dentro a ambos a y b.

Ejemplos

Ejemplo #1 Ejemplo degmp_gcd()

<?php
$gcd = gmp_gcd("12", "21");
echo gmp_strval($gcd) . "\n";
?>

El resultado del ejemplo sería:

3


Calcula el máximo común divisor y multiplicadores

  • « gmp_gcd
  • gmp_hamdist »
  • PHP Manual
  • Funciones de GMP
  • Calcula el máximo común divisor y multiplicadores

gmp_gcdext

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_gcdext — Calcula el máximo común divisor y multiplicadores

Descripción

gmp_gcdext ( GMP $a , GMP $b ) : array

Calcula g, s, y t, tal que a*s + b*t = g = gcd(a,b), donde gcd es el máximo común divisor. Devuelve un arreglo con los elementos respectivos g, s y t.

Ésta función puede ser usada para resolver ecuaciones de diofántica lineal equations en dos variables. Estas son ecuaciones que permiten solo soluciones enteras y tienen la forma: a*x + b*y = c. Para más información, vaya a » "Diophantine Equation" en la página MathWorld

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un array de números GMP.

Ejemplos

Ejemplo #1 Resolver ecuaciones de diofántica lineal

<?php
// Resolver la ecuación a*s + b*t = g
// donde a = 12, b = 21, g = gcd(12, 21) = 3
$a = gmp_init(12);
$b = gmp_init(21);
$g = gmp_gcd($a, $b);
$r = gmp_gcdext($a, $b);

$check_gcd = (gmp_strval($g) == gmp_strval($r['g']));
$eq_res = gmp_add(gmp_mul($a, $r['s']), gmp_mul($b, $r['t']));
$check_res = (gmp_strval($g) == gmp_strval($eq_res));

if ($check_gcd && $check_res) {
    $fmt = "Solution: %d*%d + %d*%d = %d\n";
    printf($fmt, gmp_strval($a), gmp_strval($r['s']), gmp_strval($b),
    gmp_strval($r['t']), gmp_strval($r['g']));
} else {
    echo "Error mientras se resolvia la ecuación\n";
}

// output: Solución: 12*2 + 21*-1 = 3
?>


Distancia Hamming

  • « gmp_gcdext
  • gmp_import »
  • PHP Manual
  • Funciones de GMP
  • Distancia Hamming

gmp_hamdist

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_hamdist — Distancia Hamming

Descripción

gmp_hamdist ( GMP $a , GMP $b ) : int

Devuelve la distancia hamming entre a y b. Ambos operadores deberían ser no negativos.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Debería ser positivo.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Debería ser positivo.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo degmp_hamdist()

<?php
$ham1 = gmp_init("1001010011", 2);
$ham2 = gmp_init("1011111100", 2);
echo gmp_hamdist($ham1, $ham2) . "\n";

/* la distancia hamming es equivalente a: */
echo gmp_popcount(gmp_xor($ham1, $ham2)) . "\n";
?>

El resultado del ejemplo sería:

6
6

Ver también

  • gmp_popcount() - Cuenta la población
  • gmp_xor() - Nivel de bit XOR


Importar de un string binario

  • « gmp_hamdist
  • gmp_init »
  • PHP Manual
  • Funciones de GMP
  • Importar de un string binario

gmp_import

(PHP 5 >= 5.6.1, PHP 7, PHP 8)

gmp_import — Importar de un string binario

Descripción

gmp_import ( string $data , integer $word_size , integer $options ) : GMP

Importar un número GMP de un string binario

Parámetros

data

El string binario a importar

word_size

El valor predeterminado es 1. El número de bytes de cada trozo de datos binarios. Principalmente se emplea junto con el parámetro 'options'.

options

El valor predeterminado es GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

Valores devueltos

Devuelve un número GMP o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gmp_import()

<?php
$number = gmp_import("\0");
echo gmp_strval($number) . "\n";

$number = gmp_import("\0\1\2");
echo gmp_strval($number) . "\n";
?>

El resultado del ejemplo sería:

0
528


Crea un número GMP

  • « gmp_import
  • gmp_intval »
  • PHP Manual
  • Funciones de GMP
  • Crea un número GMP

gmp_init

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_init — Crea un número GMP

Descripción

gmp_init ( mixed $number , int $base = 0 ) : GMP

Crea un número GMP de un entero o cadena.

Parámetros

number

Un entero o cadena. La representación de la cadena puede ser decimal, hexadecimal or octal.

base

La base.

La base puede variar de 2 a 36. Si la base es 0 (valor por defecto), la actual base es determinada de los caracteres lideres: si los primeros dos caracteres son 0x o 0X, el hexadecimal es asumido, sin embargo si el primer carácter es "0", el octal es asumido, sin embargo el decimal es asumido.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Historial de cambios

Versión | Descripción
5.3.2 | La base fue extendidad de 2 a 36, a 2 a 62 y -2 a -36.

Notas

Nota:

Para usar la base extendidad introducida en PHP 5.3.2, entonces PHP tiene que ser compilado en contra de GMP 4.2.0 o superior.

Ejemplos

Ejemplo #1 Creación de un número GMP

<?php
$a = gmp_init(123456);
$b = gmp_init("0xFFFFDEBACDFEDF7200");
?>

Notas

Nota:

No es necesario llamar ésta función si se desea usar un entero o cadena en lugar de un número GMP en una función GMP, como gmp_add(). Los argumentos de la función son automáticamente convertidos a números GMP, si tal conversión es posible y necesaria, usando las mismas reglas como gmp_init().


Convertir un número GMP a entero

  • « gmp_init
  • gmp_invert »
  • PHP Manual
  • Funciones de GMP
  • Convertir un número GMP a entero

gmp_intval

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_intval — Convertir un número GMP a entero

Descripción

gmp_intval ( GMP $gmpnumber ) : int

Esta función convierte un número GMP an un integer nativo de PHP.

Parámetros

gmpnumber

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

El valor integer de gmpnumber.

Ejemplos

Ejemplo #1 Ejemplo de gmp_intval()

<?php
// muestra el valor correcto
echo gmp_intval("2147483647") . "\n";

//muestra el valor correcto
echo gmp_intval("2147483648") . "\n";

// muestra el valor correcto
echo gmp_strval("2147483648") . "\n";
?>

El resultado del ejemplo sería:

2147483647
2147483647
2147483648

Notas

Advertencia

Ésta función retorna un resultado satisfactorio solo si el numero actualmente encaja con el PHP entero (ej., símbolo de tipo largo). Si se desea imprimir solo imprimir el húmero GMP, Se usa gmp_strval().


Inverso del modulo

  • « gmp_intval
  • gmp_jacobi »
  • PHP Manual
  • Funciones de GMP
  • Inverso del modulo

gmp_invert

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_invert — Inverso del modulo

Descripción

gmp_invert ( GMP $a , GMP $b ) : GMP

Computa el inverso del modulo de a b.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número GMO en éxito o false Si el inverso.

Ejemplos

Ejemplo #1 Ejemplo de gmp_invert()

<?php
echo gmp_invert("5", "10"); // sin inverso no inverse, ninguna salida, el resultado es falso
$invert = gmp_invert("5", "11");
echo gmp_strval($invert) . "\n";
?>

El resultado del ejemplo sería:

9


Símbolo Jacobi

  • « gmp_invert
  • gmp_kronecker »
  • PHP Manual
  • Funciones de GMP
  • Símbolo Jacobi

gmp_jacobi

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_jacobi — Símbolo Jacobi

Descripción

gmp_jacobi ( GMP $a , GMP $p ) : int

Computa el » símbolo Jacobi de a y p. p debería ser impar y tiene que ser positivo.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

p

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Debería ser impar y tiene que ser positivo.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_jacobi()

<?php
echo gmp_jacobi("1", "3") . "\n";
echo gmp_jacobi("2", "3") . "\n";
?>

El resultado del ejemplo sería:

1
0


Kronecker symbol

  • « gmp_jacobi
  • gmp_lcm »
  • PHP Manual
  • Funciones de GMP
  • Kronecker symbol

gmp_kronecker

(PHP 7 >= 7.3.0, PHP 8)

gmp_kronecker — Kronecker symbol

Descripción

gmp_kronecker ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

This function computes the Kronecker symbol of num1 and num2.

Parámetros

num1

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

num2

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Returns the Kronecker symbol of num1 and num2

Ver también

  • gmp_jacobi() - Símbolo Jacobi
  • gmp_legendre() - Símbolo Legendre


Calculate LCM

  • « gmp_kronecker
  • gmp_legendre »
  • PHP Manual
  • Funciones de GMP
  • Calculate LCM

gmp_lcm

(PHP 7 >= 7.3.0, PHP 8)

gmp_lcm — Calculate LCM

Descripción

gmp_lcm ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

This function computes the least common multiple (lcm) of num1 and num2.

Parámetros

num1

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

num2

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ver también

  • gmp_gcd() - Calcula el máximo común divisor


Símbolo Legendre

  • « gmp_lcm
  • gmp_mod »
  • PHP Manual
  • Funciones de GMP
  • Símbolo Legendre

gmp_legendre

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_legendre — Símbolo Legendre

Descripción

gmp_legendre ( GMP $a , GMP $p ) : int

Computa el » Símbolo Legendre de a y p. p debería ser impar y tiene que ser positivo.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

p

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

debería ser impar y tiene que ser positivo.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_legendre()

<?php
echo gmp_legendre("1", "3") . "\n";
echo gmp_legendre("2", "3") . "\n";
?>

El resultado del ejemplo sería:

1
0


Modulo de operación

  • « gmp_legendre
  • gmp_mul »
  • PHP Manual
  • Funciones de GMP
  • Modulo de operación

gmp_mod

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_mod — Modulo de operación

Descripción

gmp_mod ( GMP $n , GMP $d ) : GMP

Calcula el modulo de n d. El resultado es siempre no negativo, el símbolo de d es ignorado.

Parámetros

n

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

d

El modulo que es evaluado.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_mod()

<?php
$mod = gmp_mod("8", "3");
echo gmp_strval($mod) . "\n";
?>

El resultado del ejemplo sería:

2


Multiplicación de números

  • « gmp_mod
  • gmp_neg »
  • PHP Manual
  • Funciones de GMP
  • Multiplicación de números

gmp_mul

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_mul — Multiplicación de números

Descripción

gmp_mul ( GMP $a , GMP $b ) : GMP

Multiplicación de a por b y devuelve el resultado.

Parámetros

a

Un número que va a ser multiplicado por b.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

Un número que va a ser multiplicado por a.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo degmp_mul()

<?php
$mul = gmp_mul("12345678", "2000");
echo gmp_strval($mul) . "\n";
?>

El resultado del ejemplo sería:

24691356000


Número negativo

  • « gmp_mul
  • gmp_nextprime »
  • PHP Manual
  • Funciones de GMP
  • Número negativo

gmp_neg

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_neg — Número negativo

Descripción

gmp_neg ( GMP $a ) : GMP

Devuelve el valor negativo de un número.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve -a, como un número GMP.

Ejemplos

Ejemplo #1 Ejemplo degmp_neg()

<?php
$neg1 = gmp_neg("1");
echo gmp_strval($neg1) . "\n";
$neg2 = gmp_neg("-1");
echo gmp_strval($neg2) . "\n";
?>

El resultado del ejemplo sería:

-1
1


Encuentra el siguiente número primo

  • « gmp_neg
  • gmp_or »
  • PHP Manual
  • Funciones de GMP
  • Encuentra el siguiente número primo

gmp_nextprime

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

gmp_nextprime — Encuentra el siguiente número primo

Descripción

gmp_nextprime ( int $a ) : GMP

Encuentra el siguiente número primo

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve el siguiente número primo o mayor a, como un número GMP.

Ejemplos

Ejemplo #1 Ejemplo de gmp_nextprime()

<?php
$prime1 = gmp_nextprime(10); // el siguiente número primo o superior que 10
$prime2 = gmp_nextprime(-1000); // el siguiente número primo o superior que -1000

echo gmp_strval($prime1) . "\n";
echo gmp_strval($prime2) . "\n";
?>

El resultado del ejemplo sería:

11
-997

Notas

Nota:

Ésta función usa un algoritmo probabilístico para identificar el número primo y posibilita la obtención de un número compuesto que sea extremadamente pequeño.


Nivel de bit OR

  • « gmp_nextprime
  • gmp_perfect_power »
  • PHP Manual
  • Funciones de GMP
  • Nivel de bit OR

gmp_or

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_or — Nivel de bit OR

Descripción

gmp_or ( GMP $a , GMP $b ) : GMP

Calcula el nivel de bit OR de dos números GMP.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_or()

<?php
$or1 = gmp_or("0xfffffff2", "4");
echo gmp_strval($or1, 16) . "\n";
$or2 = gmp_or("0xfffffff2", "2");
echo gmp_strval($or2, 16) . "\n";
?>

El resultado del ejemplo sería:

fffffff6
fffffff2


Perfect power check

  • « gmp_or
  • gmp_perfect_square »
  • PHP Manual
  • Funciones de GMP
  • Perfect power check

gmp_perfect_power

(PHP 7 >= 7.3.0, PHP 8)

gmp_perfect_power — Perfect power check

Descripción

gmp_perfect_power ( GMP|int|string $num ) : bool

Checks whether num is a perfect power.

Parámetros

num

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Returns true if num is a perfect power, false otherwise.

Ver también

  • gmp_perfect_square() - Comprueba el cuadrado perfecto


Comprueba el cuadrado perfecto

  • « gmp_perfect_power
  • gmp_popcount »
  • PHP Manual
  • Funciones de GMP
  • Comprueba el cuadrado perfecto

gmp_perfect_square

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_perfect_square — Comprueba el cuadrado perfecto

Descripción

gmp_perfect_square ( GMP $a ) : bool

Revisa si un número es cuadrado perfecto.

Parámetros

a

El número a ser revisado como un cuadrado perfecto.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devielve true si a es un cuadrado perfecto, sino false.

Ejemplos

Ejemplo #1 Ejemplo de gmp_perfect_square()

<?php
// 3 * 3, cuadrado perfecto
var_dump(gmp_perfect_square("9"));

// no es un cuadrado perfecto
var_dump(gmp_perfect_square("7"));

// 1234567890 * 1234567890, cuadrado perfecto
var_dump(gmp_perfect_square("1524157875019052100"));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)

Ver también

  • gmp_sqrt() - Calcula la raíz cuadrada
  • gmp_sqrtrem() - Raíz cuadrada con resto


Cuenta la población

  • « gmp_perfect_square
  • gmp_pow »
  • PHP Manual
  • Funciones de GMP
  • Cuenta la población

gmp_popcount

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_popcount — Cuenta la población

Descripción

gmp_popcount ( GMP $a ) : int

Obtiene el conteo de la población.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

El conteo de la población de a, como un integer.

Ejemplos

Ejemplo #1 Ejemplo de gmp_popcount()

<?php
$pop1 = gmp_init("10000101", 2); // 3 1's
echo gmp_popcount($pop1) . "\n";
$pop2 = gmp_init("11111110", 2); // 7 1's
echo gmp_popcount($pop2) . "\n";
?>

El resultado del ejemplo sería:

3
7


Aumenta el número a la potencia

  • « gmp_popcount
  • gmp_powm »
  • PHP Manual
  • Funciones de GMP
  • Aumenta el número a la potencia

gmp_pow

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_pow — Aumenta el número a la potencia

Descripción

gmp_pow ( GMP $base , int $exp ) : GMP

Aumenta la base a la potencia exp.

Parámetros

base

La base del número.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

exp

La potencia positiva a elevar la base.

Valores devueltos

El nuevo (elevado) número, como un número GMP. El caso de 0^0 produce 1.

Ejemplos

Ejemplo #1 Ejemplo de gmp_pow()

<?php
$pow1 = gmp_pow("2", 31);
echo gmp_strval($pow1) . "\n";
$pow2 = gmp_pow("0", 0);
echo gmp_strval($pow2) . "\n";
$pow3 = gmp_pow("2", -1); // exponente negativo, genera peligro
echo gmp_strval($pow3) . "\n";
?>

El resultado del ejemplo sería:

2147483648
1


Eleva un número a la potencia con modulo

  • « gmp_pow
  • gmp_prob_prime »
  • PHP Manual
  • Funciones de GMP
  • Eleva un número a la potencia con modulo

gmp_powm

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_powm — Eleva un número a la potencia con modulo

Descripción

gmp_powm ( GMP $base , GMP $exp , GMP $mod ) : GMP

Calcula la (base elevada a la potencia exp) con modulo mod. Si exp es negativo, el resultado es indefinido.

Parámetros

base

La base del número.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

exp

La potencia positiva a elevar la base.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

mod

El modulo.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

El nuevo (elevado) número, como un número GMP.

Ejemplos

Ejemplo #1 gmp_powm() example

<?php
$pow1 = gmp_powm("2", "31", "2147483649");
echo gmp_strval($pow1) . "\n";
?>

El resultado del ejemplo sería:

2147483648


Revisa si el número es "probablemente primo"

  • « gmp_powm
  • gmp_random_bits »
  • PHP Manual
  • Funciones de GMP
  • Revisa si el número es "probablemente primo"

gmp_prob_prime

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_prob_prime — Revisa si el número es "probablemente primo"

Descripción

gmp_prob_prime ( GMP $a , int $reps = 10 ) : int

La función usa la prueba probabilística de Miller-Rabin para revisar si un número es primo.

Parámetros

a

El número a ser revisado como primo.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

reps

Valores rasonables de reps varían de 5 a 10 (por defecto siendo 10); un valor superior disminuye la probabilidad para un número no primo a pasar como un "probable" primo.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Si ésta función devolvier 0, a es definitivamente no primo. Si devuelve 1, entonces a es "probablemente" primo. si devolviera 2, entonces a es seguramente primo.

Ejemplos

Ejemplo #1 Ejemplo de gmp_prob_prime()

<?php
// definitivamente no primo
echo gmp_prob_prime("6") . "\n";

// probablemente primo
echo gmp_prob_prime("1111111111111111111") . "\n";

// definitivamente primo
echo gmp_prob_prime("11") . "\n";
?>

El resultado del ejemplo sería:

0
1
2


Un número aleatorio

  • « gmp_prob_prime
  • gmp_random_range »
  • PHP Manual
  • Funciones de GMP
  • Un número aleatorio

gmp_random_bits

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

gmp_random_bits — Un número aleatorio

Descripción

gmp_random_bits ( integer $bits ) : GMP

Genera un número aleatorio. El número estará entre 0 y (2 ** bits) - 1.

bits debe ser mayor que 0, siendo el valor máximo el restringido por la memoria disponible.

Parámetros

bits

El número de bits.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número GMP aleatorio.

Ejemplos

Ejemplo #1 Ejemplo de gmp_random_bits()

<?php
$rand1 = gmp_random_bits(3); // número aleatorio entre 0 y 7
$rand2 = gmp_random_bits(5); // número aleatorio entre 0 y 31

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

El resultado del ejemplo sería:

3
15


Un número aleatorio

  • « gmp_random_bits
  • gmp_random_seed »
  • PHP Manual
  • Funciones de GMP
  • Un número aleatorio

gmp_random_range

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

gmp_random_range — Un número aleatorio

Descripción

gmp_random_range ( GMP $min , GMP $max ) : GMP

Generar un número aleatorio. El número estará entre min y max.

min y max pueden ser ambos negativos, pero min debe ser siempre menor que max.

Parámetros

min

Un número GMP que representa el límite inferior del número aleatorio

max

Un número GMP que representa el límite superior del número aleatorio

Valores devueltos

Un número GMP aleatorio.

Ejemplos

Ejemplo #1 Ejemplo de gmp_random_range()

<?php
$rand1 = gmp_random_range(0, 100);    // número aleatior entre 0 y 100
$rand2 = gmp_random_range(-100, -10); // número aleatior entre -100 y -10

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

El resultado del ejemplo sería:

42
-67


Establece la semilla RNG

  • « gmp_random_range
  • gmp_random »
  • PHP Manual
  • Funciones de GMP
  • Establece la semilla RNG

gmp_random_seed

(PHP 7, PHP 8)

gmp_random_seed — Establece la semilla RNG

Descripción

gmp_random_seed ( mixed $seed ) : mixed

Parámetros

seed

La semilla para las funciones gmp_random(),
gmp_random_bits(), y
gmp_random_range() functions.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Returns null on success.

Errores/Excepciones

Emite un E_WARNING y devuelve false si seed no es válido.

Ejemplos

Ejemplo #1 Ejemplo de gmp_random_seed()

<?php
// establecer la semilla
gmp_random_seed(100);

var_dump(gmp_strval(gmp_random(1)));

// establecer la semilla para algo más
gmp_random_seed(gmp_init(-100));

var_dump(gmp_strval(gmp_random_bits(10)));

// establecer la semilla a algo inválido
var_dump(gmp_random_seed('not a number'));

El resultado del ejemplo sería:

string(20) "15370156633245019617"
string(3) "683"

Warning: gmp_random_seed(): Unable to convert variable to GMP - string is not an integer in %s on line %d
bool(false)

Ver también

  • gmp_init() - Crea un número GMP
  • gmp_random() - Numero al azar
  • gmp_random_bits() - Un número aleatorio
  • gmp_random_range() - Un número aleatorio


Numero al azar

  • « gmp_random_seed
  • gmp_root »
  • PHP Manual
  • Funciones de GMP
  • Numero al azar

gmp_random

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_random — Numero al azar

Descripción

gmp_random ( int $limiter = 20 ) : GMP

Genera un número al azar. El número se va a ubicar entre cero y el número de bits por miembro multiplicado por el limiter. Si el limiter es negativo, Los números generados son negativos.

Un miembro es un mecanismo interno GMP. El número de bits en un miembro es no estático, y puede variar de sistema a sistema. Generalmente, el número de bits en un miembro es 16 o 32, pero esto no es garantizado.

Parámetros

limiter

El limitador.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Un número al azar GMP.

Ejemplos

Ejemplo #1 Ejemplo de gmp_random()

<?php
$rand1 = gmp_random(1); // número al azar de 0 a 1 * bits por miembro
$rand2 = gmp_random(2); // número al azar de 0 a 2 * bits por miembro

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

El resultado del ejemplo sería:

1915834968
8642564075890328087


Tomar la parte entera de una raíz enésima

  • « gmp_random
  • gmp_rootrem »
  • PHP Manual
  • Funciones de GMP
  • Tomar la parte entera de una raíz enésima

gmp_root

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

gmp_root — Tomar la parte entera de una raíz enésima

Descripción

gmp_root ( GMP $a , int $nth ) : GMP

Toma la raíz enésima dada por nth de a y devuelve el componente entero del resultado.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

nth

La raíz positiva a tomar de a.

Valores devueltos

El componente entero de la raíz resultante, como número GMP.


Tomar la parte entera y el resto de una raíz enésima

  • « gmp_root
  • gmp_scan0 »
  • PHP Manual
  • Funciones de GMP
  • Tomar la parte entera y el resto de una raíz enésima

gmp_rootrem

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

gmp_rootrem — Tomar la parte entera y el resto de una raíz enésima

Descripción

gmp_rootrem ( GMP $a , int $nth ) : array

Toma la raíz enésima dada por nth de a y devuelve el componente entero y el resto del resultado.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

nth

La raíz positiva a tomar de a.

Valores devueltos

Un array de dos elementos, donde el primero es el componente entero de la raíz, y el segundo es el resto, ambos representados como números GMP.


Escanear para 0

  • « gmp_rootrem
  • gmp_scan1 »
  • PHP Manual
  • Funciones de GMP
  • Escanear para 0

gmp_scan0

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_scan0 — Escanear para 0

Descripción

gmp_scan0 ( GMP $a , int $start ) : int

Escanea a, empezando con el bit de start, hacia los bits mas significantes, hasta que el primero bit establecido es encontrado.

Parámetros

a

El número a escanear.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

start

El inicio del bit.

Valores devueltos

Devuelve el índice del bit encontrado, como un integer. El índice inicia desde 0.

Ejemplos

Ejemplo #1 Ejemplo de gmp_scan0()

<?php
// "0" el bit se encuentra en la posición 3. El índice inica en 0
$s1 = gmp_init("10111", 2);
echo gmp_scan0($s1, 0) . "\n";

// "0" el bit se encuentra en la posición 7. El índice inica en 5
$s2 = gmp_init("101110000", 2);
echo gmp_scan0($s2, 5) . "\n";
?>

El resultado del ejemplo sería:

3
7


Escanear para 1

  • « gmp_scan0
  • gmp_setbit »
  • PHP Manual
  • Funciones de GMP
  • Escanear para 1

gmp_scan1

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_scan1 — Escanear para 1

Descripción

gmp_scan1 ( GMP $a , int $start ) : int

Escanea a, empezando con el bit de start, hacia los bits mas significantes, hasta que el primero bit establecido es encontrado.

Parámetros

a

El número a escanear.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

start

El inicio del bit.

Valores devueltos

Devuelve el índice del bit encontrado, como un integer. Si el bit establecido no es encontrado, -1 se devuelto.

Ejemplos

Ejemplo #1 Ejemplo de gmp_scan1()

<?php
// "1" el bit se encuentra en la posición 3. El índice inica en 0
$s1 = gmp_init("01000", 2);
echo gmp_scan1($s1, 0) . "\n";

// "1" el bit se encuentra en la posición 9. El índice inica en 5
$s2 = gmp_init("01000001111", 2);
echo gmp_scan1($s2, 5) . "\n";
?>

El resultado del ejemplo sería:

3
9


Establece el bit

  • « gmp_scan1
  • gmp_sign »
  • PHP Manual
  • Funciones de GMP
  • Establece el bit

gmp_setbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_setbit — Establece el bit

Descripción

gmp_setbit ( GMP &$a , int $index , bool $bit_on = true ) : void

Establece el index del bit en a.

Parámetros

a

El valor a modificar.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

index

El índice del bit a establecer. El índice 0 representa el bit menos significativo.

bit_on

Verdadero para establecer el bit (establecer a 1/on); falso para limpiar el bit (establecer a 0/off).

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_setbit() - índice 0

<?php
$a = gmp_init("2"); //
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0); // 0b10 ahora es 0b11
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

El resultado del ejemplo sería:

2 -> 0b10
3 -> 0b11

Ejemplo #2 Ejemplo de gmp_setbit() - índice 1

<?php
$a = gmp_init("0xfd");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 1); // el índice empieza en 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

El resultado del ejemplo sería:

253 -> 0b11111101
255 -> 0b11111111

Ejemplo #3 Ejemplo de gmp_setbit() - limpiar un bit

<?php
$a = gmp_init("0xff");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0, false); // limpiar el bit en el índice 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

El resultado del ejemplo sería:

255 -> 0b11111111
254 -> 0b11111110

Notas

Nota:

A diferencia de otras funciones GMP, gmp_setbit() debe ser llamado con un recurso GMP que ya exista (usando gmp_init() por ejemplo). No puede ser automáticamente creado.

Ver también

  • gmp_clrbit() - Limpia un bit
  • gmp_testbit() - Prueba si un bit es establecido


El símbolo del número

  • « gmp_setbit
  • gmp_sqrt »
  • PHP Manual
  • Funciones de GMP
  • El símbolo del número

gmp_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sign — El símbolo del número

Descripción

gmp_sign ( GMP $a ) : int

Revisa el símbolo del número.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve 1 si a es positivo, -1 si a es negativo, y 0 si a es cero.

Ejemplos

Ejemplo #1 Ejemplo de gmp_sign()

<?php
// positivo
echo gmp_sign("500") . "\n";

// negativo
echo gmp_sign("-500") . "\n";

// cero
echo gmp_sign("0") . "\n";
?>

El resultado del ejemplo sería:

1
-1
0

Ver también

  • gmp_abs() - Valor absoluto
  • abs() - Valor absoluto


Calcula la raíz cuadrada

  • « gmp_sign
  • gmp_sqrtrem »
  • PHP Manual
  • Funciones de GMP
  • Calcula la raíz cuadrada

gmp_sqrt

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sqrt — Calcula la raíz cuadrada

Descripción

gmp_sqrt ( GMP $a ) : GMP

Calcula la raíz cuadrada de a.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

La porción entera de la raíz cuadrada, como un número GMP.

Ejemplos

Ejemplo #1 Ejemplo de gmp_sqrt()

<?php
$sqrt1 = gmp_sqrt("9");
$sqrt2 = gmp_sqrt("7");
$sqrt3 = gmp_sqrt("1524157875019052100");

echo gmp_strval($sqrt1) . "\n";
echo gmp_strval($sqrt2) . "\n";
echo gmp_strval($sqrt3) . "\n";
?>

El resultado del ejemplo sería:

3
2
1234567890


Raíz cuadrada con resto

  • « gmp_sqrt
  • gmp_strval »
  • PHP Manual
  • Funciones de GMP
  • Raíz cuadrada con resto

gmp_sqrtrem

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sqrtrem — Raíz cuadrada con resto

Descripción

gmp_sqrtrem ( GMP $a ) : array

Calcula la raíz cuadrada de un número, con resto.

Parámetros

a

El número a ser la raíz cuadrada.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

Devuelve un arreglo donde el primer elemento es el entero de la raíz cuadrada de a y el segundo es el resto (ej., La diferencia entre a y el primer elemento de la raíz cuadrada).

Ejemplos

Ejemplo #1 Ejemplo degmp_sqrtrem()

<?php
list($sqrt1, $sqrt1rem) = gmp_sqrtrem("9");
list($sqrt2, $sqrt2rem) = gmp_sqrtrem("7");
list($sqrt3, $sqrt3rem) = gmp_sqrtrem("1048576");

echo gmp_strval($sqrt1) . ", " . gmp_strval($sqrt1rem) . "\n";
echo gmp_strval($sqrt2) . ", " . gmp_strval($sqrt2rem) . "\n";
echo gmp_strval($sqrt3) . ", " . gmp_strval($sqrt3rem) . "\n";
?>

El resultado del ejemplo sería:

3, 0
2, 3
1024, 0


Convierte un número GMP a cadena

  • « gmp_sqrtrem
  • gmp_sub »
  • PHP Manual
  • Funciones de GMP
  • Convierte un número GMP a cadena

gmp_strval

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_strval — Convierte un número GMP a cadena

Descripción

gmp_strval ( GMP $gmpnumber , int $base = 10 ) : string

Convierte un número GMP a la representación de cadena en base base. La base por defecto es 10.

Parámetros

gmpnumber

El número GMP a convertir en cadena.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

base

La base del número retornado. La base por defecto es 10. Los valores permitidos para la base son de 2 a 62 y -2 a -36.

Valores devueltos

El número, como una string.

Historial de cambios

Versión | Descripción
5.3.2 | La base fue extendida de 2 a 36, a 2 a 62 y -2 a -36.

Notas

Nota:

To use the extended base introduced in PHP 5.3.2, then PHP must be compiled against GMP 4.2.0 or greater.

Ejemplos

Ejemplo #1 Converting a GMP number to a string

<?php
$a = gmp_init("0x41682179fbf5");
printf("Decimal: %s, base 36: %s", gmp_strval($a), gmp_strval($a,36));
?>


Resta los números

  • « gmp_strval
  • gmp_testbit »
  • PHP Manual
  • Funciones de GMP
  • Resta los números

gmp_sub

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sub — Resta los números

Descripción

gmp_sub ( GMP $a , GMP $b ) : GMP

Resta b con a y devuelve el resultado.

Parámetros

a

El número a ser restado.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

El número restado con a.

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo de gmp_sub()

<?php
$sub = gmp_sub("281474976710656", "4294967296"); // 2^48 - 2^32
echo gmp_strval($sub) . "\n";
?>

El resultado del ejemplo sería:

281470681743360


Prueba si un bit es establecido

  • « gmp_sub
  • gmp_xor »
  • PHP Manual
  • Funciones de GMP
  • Prueba si un bit es establecido

gmp_testbit

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gmp_testbit — Prueba si un bit es establecido

Descripción

gmp_testbit ( GMP $a , int $index ) : bool

Prueba si un bit es establecido.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

index

El bit a probar

Valores devueltos

Devuelve true si el bit se establece en el recurso $a, de otro modo devuelve false.

Errores/Excepciones

Se emite un error de nivel E_WARNING cuando index es menor que cero, y se devuelve false.

Ejemplos

Ejemplo #1 Ejemplo degmp_testbit()

<?php
$n = gmp_init("1000000");
var_dump(gmp_testbit($n, 1));
gmp_setbit($n, 1);
var_dump(gmp_testbit($n, 1));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • gmp_setbit() - Establece el bit
  • gmp_clrbit() - Limpia un bit


Nivel de bit XOR

  • « gmp_testbit
  • GMP »
  • PHP Manual
  • Funciones de GMP
  • Nivel de bit XOR

gmp_xor

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_xor — Nivel de bit XOR

Descripción

gmp_xor ( GMP $a , GMP $b ) : GMP

Calcula el nivel de bit exclusivo OR (XOR) de dos números GMP.

Parámetros

a

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

b

resource de número de GMP en PHP 5.5 y anterior, o un objeto de GMP en PHP 5.6 y posterior, o un string numérico siempre que sea posible convertirlo a un número.

Valores devueltos

resource de número de GMP en PHP 5.5 y anterior, o un objeto GMP en PHP 5.6 y posterior.

Ejemplos

Ejemplo #1 Ejemplo degmp_xor()

<?php
$xor1 = gmp_init("1101101110011101", 2);
$xor2 = gmp_init("0110011001011001", 2);

$xor3 = gmp_xor($xor1, $xor2);

echo gmp_strval($xor3, 2) . "\n";
?>

El resultado del ejemplo sería:

1011110111000100


La clase GMP

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

Introducción

Un número GMP. Estos objetos admiten los operadores aritméticos, a nivel de bit y de comparación sobrecargados.

Nota:

No se proporciona ninguna interfaz orientada a objetos para manipular objetos GMP. Use la API de GMP procedimental.

GMP implements Serializable {
}


Funciones matemáticas

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones Matemáticas
    • abs — Valor absoluto
    • acos — Arco coseno
    • acosh — Arco coseno hiperbólico
    • asin — Arco seno
    • asinh — Arco seno hiperbólico
    • atan2 — Arco tangente de dos variables
    • atan — Arco tangente
    • atanh — Arco tangente hiperbólica
    • base_convert — Convertir un número entre bases arbitrarias
    • bindec — Binario a decimal
    • ceil — Redondear fracciones hacia arriba
    • cos — Coseno
    • cosh — Coseno hiperbólico
    • decbin — Decimal a binario
    • dechex — Decimal a hexadecimal
    • decoct — Decimal a octal
    • deg2rad — Convierte el número en grados a su equivalente en radianes
    • exp — Calcula la exponencial de e
    • expm1 — Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
    • fdiv — Divides two numbers, according to IEEE 754
    • floor — Redondear fracciones hacia abajo
    • fmod — Devuelve el resto en punto flotante (módulo) de la división de los argumentos
    • getrandmax — Mostrar el mayor valor aleatorio posible
    • hexdec — Hexadecimal a decimal
    • hypot — Calcula la longitud de la hipotenusa de un triángulo de ángulo recto
    • intdiv — División entera
    • is_finite — Encuentra si un valor es un número finito legal
    • is_infinite — Encuentra si un valor es infinito
    • is_nan — Encuentra si un valor no es un número
    • lcg_value — Generador lineal congruente combinado
    • log10 — Logaritmo en base 10
    • log1p — Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
    • log — Logaritmo natural
    • max — Encontrar el valor más alto
    • min — Encontrar el valor más bajo
    • mt_getrandmax — Mostrar el mayor valor aleatorio posible
    • mt_rand — Genera un mejor número entero aleatorio
    • mt_srand — Genera el mejor número aleatorio a partir de una semilla
    • octdec — Octal a decimal
    • pi — Obtener valor de pi
    • pow — Expresión exponencial
    • rad2deg — Convierte el número en radianes a su equivalente en grados
    • rand — Genera un número entero aleatorio
    • round — Redondea un float
    • sin — Seno
    • sinh — Seno hiperbólico
    • sqrt — Raíz cuadrada
    • srand — Genera un número aleatorio a partir de una semilla
    • tan — Tangente
    • tanh — Tangente hiperbólica


Introducción

Estas funciones matemáticas sólo manipularán valores que estén dentro del rango de los tipos integer y float de su ordenador (que se corresponden actualmente con los tipos de C long y double respectivamente). En el caso de emplear números mayores, consulte las funciones matemáticas de precisión arbitraria.

Consulte también la página del manual sobre operadores aritméticos.


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

Constantes matemáticas
Constante | Valor | Descripción | Disponibilidad
M_PI | 3.14159265358979323846 | Pi |
M_E | 2.7182818284590452354 | e |
M_LOG2E | 1.4426950408889634074 | log_2 e |
M_LOG10E | 0.43429448190325182765 | log_10 e |
M_LN2 | 0.69314718055994530942 | log_e 2 |
M_LN10 | 2.30258509299404568402 | log_e 10 |
M_PI_2 | 1.57079632679489661923 | pi/2 |
M_PI_4 | 0.78539816339744830962 | pi/4 |
M_1_PI | 0.31830988618379067154 | 1/pi |
M_2_PI | 0.63661977236758134308 | 2/pi |
M_SQRTPI | 1.77245385090551602729 | sqrt(pi) | PHP 5.2.0
M_2_SQRTPI | 1.12837916709551257390 | 2/sqrt(pi) |
M_SQRT2 | 1.41421356237309504880 | sqrt(2) |
M_SQRT3 | 1.73205080756887729352 | sqrt(3) | PHP 5.2.0
M_SQRT1_2 | 0.70710678118654752440 | 1/sqrt(2) |
M_LNPI | 1.14472988584940017414 | log_e(pi) | PHP 5.2.0
M_EULER | 0.57721566490153286061 | Constante de Euler | PHP 5.2.0
PHP_ROUND_HALF_UP | 1 | Redondeo al siguiente medio superior | PHP 5.3.0
PHP_ROUND_HALF_DOWN | 2 | Redondeo al medio inferior | PHP 5.3.0
PHP_ROUND_HALF_EVEN | 3 | Redondeo de las mitades de números pares | PHP 5.3.0
PHP_ROUND_HALF_ODD | 4 | Redondeo de las mitades de números impares | PHP 5.3.0
NAN | NAN (como float) | No es un numero (NAN=Not A Number) |
INF | INF (como float) | Infinito |

Todas las constantes sin una versión de PHP indicada están disponibles desde la PHP 5.0.0.


Funciones Matemáticas

Tabla de contenidos

  • abs — Valor absoluto
  • acos — Arco coseno
  • acosh — Arco coseno hiperbólico
  • asin — Arco seno
  • asinh — Arco seno hiperbólico
  • atan2 — Arco tangente de dos variables
  • atan — Arco tangente
  • atanh — Arco tangente hiperbólica
  • base_convert — Convertir un número entre bases arbitrarias
  • bindec — Binario a decimal
  • ceil — Redondear fracciones hacia arriba
  • cos — Coseno
  • cosh — Coseno hiperbólico
  • decbin — Decimal a binario
  • dechex — Decimal a hexadecimal
  • decoct — Decimal a octal
  • deg2rad — Convierte el número en grados a su equivalente en radianes
  • exp — Calcula la exponencial de e
  • expm1 — Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
  • fdiv — Divides two numbers, according to IEEE 754
  • floor — Redondear fracciones hacia abajo
  • fmod — Devuelve el resto en punto flotante (módulo) de la división de los argumentos
  • getrandmax — Mostrar el mayor valor aleatorio posible
  • hexdec — Hexadecimal a decimal
  • hypot — Calcula la longitud de la hipotenusa de un triángulo de ángulo recto
  • intdiv — División entera
  • is_finite — Encuentra si un valor es un número finito legal
  • is_infinite — Encuentra si un valor es infinito
  • is_nan — Encuentra si un valor no es un número
  • lcg_value — Generador lineal congruente combinado
  • log10 — Logaritmo en base 10
  • log1p — Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
  • log — Logaritmo natural
  • max — Encontrar el valor más alto
  • min — Encontrar el valor más bajo
  • mt_getrandmax — Mostrar el mayor valor aleatorio posible
  • mt_rand — Genera un mejor número entero aleatorio
  • mt_srand — Genera el mejor número aleatorio a partir de una semilla
  • octdec — Octal a decimal
  • pi — Obtener valor de pi
  • pow — Expresión exponencial
  • rad2deg — Convierte el número en radianes a su equivalente en grados
  • rand — Genera un número entero aleatorio
  • round — Redondea un float
  • sin — Seno
  • sinh — Seno hiperbólico
  • sqrt — Raíz cuadrada
  • srand — Genera un número aleatorio a partir de una semilla
  • tan — Tangente
  • tanh — Tangente hiperbólica


Valor absoluto

  • « Funciones Matemáticas
  • acos »
  • PHP Manual
  • Funciones Matemáticas
  • Valor absoluto

abs

(PHP 4, PHP 5, PHP 7, PHP 8)

abs — Valor absoluto

Descripción

abs ( mixed $number ) : number

Devuelve el valor absoluto de number.

Parámetros

number

Valor decimal a convertir

Valores devueltos

El valor absoluto de number. Si el argumento number es del tipo float, el valor devuelto es también del tipo float, siendo para los otros casos del tipo integer (debido a que float tiene normalmente un rango de valores mayor que integer).

Ejemplos

Ejemplo #1 Ejemplo de abs()

<?php
echo abs(-4.2); // 4.2 (double/float)
echo abs(5);    // 5 (integer)
echo abs(-5);   // 5 (integer)
?>

Ver también

  • gmp_abs() - Valor absoluto
  • gmp_sign() - El símbolo del número


Arco coseno

  • « abs
  • acosh »
  • PHP Manual
  • Funciones Matemáticas
  • Arco coseno

acos

(PHP 4, PHP 5, PHP 7, PHP 8)

acos — Arco coseno

Descripción

acos ( float $arg ) : float

Devuelve el arco coseno de arg en radianes. acos() es la función complementaria de cos(), lo que quiere decir que a==cos(acos(a)) para cada valor de a en el rango de acos()'.

Parámetros

arg

El argumento a procesar

Valores devueltos

The arc cosine of arg in radians.

Ver también

  • cos() - Coseno
  • acosh() - Arco coseno hiperbólico
  • asin() - Arco seno
  • atan() - Arco tangente


Arco coseno hiperbólico

  • « acos
  • asin »
  • PHP Manual
  • Funciones Matemáticas
  • Arco coseno hiperbólico

acosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

acosh — Arco coseno hiperbólico

Descripción

acosh ( float $arg ) : float

Devuelve el arco coseno hiperbólico de arg, es decir, el valor cuyo coseno hiperbólico es arg.

Parámetros

arg

El argumento a procesar

Valores devueltos

El arco coseno hiperbólico de arg

Historial de cambios

Versión | Descripción
5.3.0 | La función esta disponible en todas las plataformas

Ver también

  • cosh() - Coseno hiperbólico
  • acos() - Arco coseno
  • asinh() - Arco seno hiperbólico
  • atanh() - Arco tangente hiperbólica


Arco seno

  • « acosh
  • asinh »
  • PHP Manual
  • Funciones Matemáticas
  • Arco seno

asin

(PHP 4, PHP 5, PHP 7, PHP 8)

asin — Arco seno

Descripción

asin ( float $arg ) : float

Devuelve el arco seno de arg en radianes. asin() es la función complementaria de sin(), lo que quiere decir que a==sin(asin(a)) para cada valor de a en el rango de asin().

Parámetros

arg

El argumento a procesar

Valores devueltos

El arco seno de arg en radianes

Ver también

  • sin() - Seno
  • asinh() - Arco seno hiperbólico
  • acos() - Arco coseno
  • atan() - Arco tangente


Arco seno hiperbólico

  • « asin
  • atan2 »
  • PHP Manual
  • Funciones Matemáticas
  • Arco seno hiperbólico

asinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

asinh — Arco seno hiperbólico

Descripción

asinh ( float $arg ) : float

Devuelve el arco seno hiperbólico de arg, es decir, el valor cuyo seno hiperbólico es arg.

Parámetros

arg

El argumento a procesar

Valores devueltos

El arco seno hiperbólico de arg

Historial de cambios

Versión | Descripción
5.3.0 | La función esta disponible en todas las plataformas

Ver también

  • sinh() - Seno hiperbólico
  • asin() - Arco seno
  • acosh() - Arco coseno hiperbólico
  • atanh() - Arco tangente hiperbólica


Arco tangente de dos variables

  • « asinh
  • atan »
  • PHP Manual
  • Funciones Matemáticas
  • Arco tangente de dos variables

atan2

(PHP 4, PHP 5, PHP 7, PHP 8)

atan2 — Arco tangente de dos variables

Descripción

atan2 ( float $y , float $x ) : float

Esta función calcula el arco tangente de las dos variables x y y. Es similar a calcular el arco tangente de y / x, excepto que los signos de ambos argumentos son usados para determinar el cuadrante del resultado.

La función devuelve el resultado en radianes, que se encuentra entre -PI y PI (inclusive).

Parámetros

y

Parámetro dividendo

x

Parámetro divisor

Valores devueltos

El arco tangente de y/x en radianes.

Ver también

  • atan() - Arco tangente


Arco tangente

  • « atan2
  • atanh »
  • PHP Manual
  • Funciones Matemáticas
  • Arco tangente

atan

(PHP 4, PHP 5, PHP 7, PHP 8)

atan — Arco tangente

Descripción

atan ( float $arg ) : float

Devuelve el arco tangente de arg en radianes. atan() es la función complementaria de tan(), lo que quiere decir que a==tan(atan(a)) para cada valor de a en el rango de atan().

Parámetros

arg

El argumento a procesar

Valores devueltos

El arco tangente de arg en radianes.

Ver también

  • tan() - Tangente
  • atanh() - Arco tangente hiperbólica
  • asin() - Arco seno
  • acos() - Arco coseno


Arco tangente hiperbólica

  • « atan
  • base_convert »
  • PHP Manual
  • Funciones Matemáticas
  • Arco tangente hiperbólica

atanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

atanh — Arco tangente hiperbólica

Descripción

atanh ( float $arg ) : float

Devuelve el arco tangente hiperbólico de arg, es decir, el valor cuya tangente hiperbólica es arg.

Parámetros

arg

El argumento a procesar

Valores devueltos

El arco tangente hiperbólico de arg

Historial de cambios

Versión | Descripción
5.3.0 | La función esta disponible en todas las plataformas

Ver también

  • tanh() - Tangente hiperbólica
  • atan() - Arco tangente
  • asinh() - Arco seno hiperbólico
  • acosh() - Arco coseno hiperbólico


Convertir un número entre bases arbitrarias

  • « atanh
  • bindec »
  • PHP Manual
  • Funciones Matemáticas
  • Convertir un número entre bases arbitrarias

base_convert

(PHP 4, PHP 5, PHP 7, PHP 8)

base_convert — Convertir un número entre bases arbitrarias

Descripción

base_convert ( string $number , int $frombase , int $tobase ) : string

Devuelve una cadena que contiene el número dado por number representado en base tobase. La base en la cual es dado number es especificada en frombase. Tanto frombase como tobase tienen que ser valores entre 2 y 36, inclusive. Los dígitos en números con una base mayor que 10 serán representados con las letras a-z, en donde a significa 10, b significa 11 y z significa 35. No importa si las letras son mayúsculas o minúsculas: number se interpretará correctamente.

Advertencia

base_convert() puede perder precisión en números grandes debido a las propiedades relacionadas con el tipo interno "double" o "flotante" usado. Por favor, consulte la sección sobre Números de punto flotante del manual para información más específica y limitaciones.

Parámetros

number

El número a convertir. Cualquier carácter inválido en number será ignorado silenciosamente.

frombase

La base en que se encuentra number

tobase

La base a la cual convertir number

Valores devueltos

number convertido a base tobase

Ejemplos

Ejemplo #1 Ejemplo de base_convert()

<?php
$hexadecimal = 'a37334';
echo base_convert($hexadecimal, 16, 2);
?>

El resultado del ejemplo sería:

101000110111001100110100

Ver también

  • intval() - Obtiene el valor entero de una variable


Binario a decimal

  • « base_convert
  • ceil »
  • PHP Manual
  • Funciones Matemáticas
  • Binario a decimal

bindec

(PHP 4, PHP 5, PHP 7, PHP 8)

bindec — Binario a decimal

Descripción

bindec ( string $binary_string ) : number

Devuelve el equivalente decimal del número binario representado por el argumento binary_string.

bindec() convierte un número binario a un integer o, si es necesario por razones de tamaño, a un float.

bindec() interpreta todos los valores de binary_string como enteros sin signo. Esto es debido a que bindec() considera al bit más significativo como otro orden de magnitud en lugar de como el bit de signo.

Parámetros

binary_string

El string binario a convertir

Advertencia

Este parámetro debe ser un string. Cualquier otro tipo de dato empleado puede producir resultados inesperados.

Valores devueltos

El valor decimal de binary_string

Ejemplos

Ejemplo #1 Ejemplo de bindec()

<?php
echo bindec('110011') . "\n";
echo bindec('000110011') . "\n";

echo bindec('111');
?>

El resultado del ejemplo sería:

51
51
7

Ejemplo #2 bindec() interpreta las entradas como enteros sin signo

<?php
/*
 * La lección de este ejemplo es el resultado
 * más que el código de PHP en sí.
 */

$magnitude_lower = pow(2, (PHP_INT_SIZE * 8) - 2);
p($magnitude_lower - 1);
p($magnitude_lower, '¿Ve el incremento?  Obsérvelo la próxima vez...');

p(PHP_INT_MAX, 'PHP_INT_MAX');
p(~PHP_INT_MAX, 'interpretado como uno más que PHP_INT_MAX');

if (PHP_INT_SIZE == 4) {
    $nota = 'interpretado como el mayor entero sin signo';
} else {
    $nota = 'interpretado como el mayor entero sin signo
              (18446744073709551615) aunque sesgado por la precisión del float';
}
p(-1, $nota);

function p($entrada, $nota = '') {
    echo "entrada:      $entrada\n";

    $formato = '%0' . (PHP_INT_SIZE * 8) . 'b';
    $bin = sprintf($formato, $entrada);
    echo "binario:      $bin\n";

    ini_set('precision', 20);  // Para la legibilidad en bloques de 64 bits.
    $dec = bindec($bin);
    echo 'bindec():     ' . $dec . "\n";

    if ($nota) {
        echo "NOTA:         $nota\n";
    }

    echo "\n";
}
?>

El resultado del ejemplo en equipos de 32 bit sería:

entrada:      1073741823
binario:      00111111111111111111111111111111
bindec():     1073741823

entrada:      1073741824
binario:      01000000000000000000000000000000
bindec():     1073741824
NOTA:         ¿Ve el incremento?  Obsérvelo la próxima vez...

entrada:      2147483647
binario:      01111111111111111111111111111111
bindec():     2147483647
NOTA:         PHP_INT_MAX

entrada:      -2147483648
binario:      10000000000000000000000000000000
bindec():     2147483648
NOTA:         interpretado como uno más que PHP_INT_MAX

entrada:      -1
binario:      11111111111111111111111111111111
bindec():     4294967295
NOTA:         interpretado como el mayor entero sin signo

El resultado del ejemplo en equipos de 64 bit sería:

entrada:      4611686018427387903
binario:      0011111111111111111111111111111111111111111111111111111111111111
bindec():     4611686018427387903

entrada:      4611686018427387904
binario:      0100000000000000000000000000000000000000000000000000000000000000
bindec():     4611686018427387904
NOTA:         ¿Ve el incremento?  Obsérvelo la próxima vez...

entrada:      9223372036854775807
binario:      0111111111111111111111111111111111111111111111111111111111111111
bindec():     9223372036854775807
NOTA:         PHP_INT_MAX

entrada:      -9223372036854775808
binario:      1000000000000000000000000000000000000000000000000000000000000000
bindec():     9223372036854775808
NOTA:         interpretado como uno más que PHP_INT_MAX

entrada:      -1
binario:      1111111111111111111111111111111111111111111111111111111111111111
bindec():     18446744073709551616
NOTA:         interpretado como el mayor entero sin signo
              (18446744073709551615) aunque sesgado por la precisión del float

Notas

Nota:

Esta función puede convertir números que son demasiado grandes para caber en el tipo integer de cada plataforma, devolviendo en este caso un valor de tipo float para los valores mayores.

Ver también

  • decbin() - Decimal a binario
  • octdec() - Octal a decimal
  • hexdec() - Hexadecimal a decimal
  • base_convert() - Convertir un número entre bases arbitrarias


Redondear fracciones hacia arriba

  • « bindec
  • cos »
  • PHP Manual
  • Funciones Matemáticas
  • Redondear fracciones hacia arriba

ceil

(PHP 4, PHP 5, PHP 7, PHP 8)

ceil — Redondear fracciones hacia arriba

Descripción

ceil ( float $value ) : float

Devuelve el siguiente valor entero mayor redondeando hacia arriba value si fuera necesario.

Parámetros

value

El valor a redondear

Valores devueltos

value redondeado al siguiente entero más alto. El valor de retorno de ceil() sigue siendo de tipo float ya que el rango de valores de float es usualmente mayor que el del tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de ceil()

<?php
echo ceil(4.3);    // 5
echo ceil(9.999);  // 10
echo ceil(-3.14);  // -3
?>

Ver también

  • floor() - Redondear fracciones hacia abajo
  • round() - Redondea un float


Coseno

  • « ceil
  • cosh »
  • PHP Manual
  • Funciones Matemáticas
  • Coseno

cos

(PHP 4, PHP 5, PHP 7, PHP 8)

cos — Coseno

Descripción

cos ( float $arg ) : float

cos() devuelve el coseno del parámetro arg. El parámetro arg está en radianes.

Parámetros

arg

Un ángulo en radianes

Valores devueltos

El coseno de arg

Ejemplos

Ejemplo #1 Ejemplo de cos()

<?php

echo cos(M_PI); // -1

?>

Ver también

  • acos() - Arco coseno
  • sin() - Seno
  • tan() - Tangente
  • deg2rad() - Convierte el número en grados a su equivalente en radianes


Coseno hiperbólico

  • « cos
  • decbin »
  • PHP Manual
  • Funciones Matemáticas
  • Coseno hiperbólico

cosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cosh — Coseno hiperbólico

Descripción

cosh ( float $arg ) : float

Devuelve el coseno hiperbólico de arg, definido como (exp(arg) + exp(-arg))/2.

Parámetros

arg

El argumento a procesar

Valores devueltos

El coseno hiperbólico de arg

Ver también

  • cos() - Coseno
  • acosh() - Arco coseno hiperbólico
  • sinh() - Seno hiperbólico
  • cosh()


Decimal a binario

  • « cosh
  • dechex »
  • PHP Manual
  • Funciones Matemáticas
  • Decimal a binario

decbin

(PHP 4, PHP 5, PHP 7, PHP 8)

decbin — Decimal a binario

Descripción

decbin ( int $number ) : string

Devuelve una cadena que contiene una representación binaria del argumento number.

Parámetros

number

Valor decimal a convertir

Rango de entradas en máquinas de 32-bit
number positivo | number negativo | valor de retorno
0 | 0
1 | 1
2 | 10
... progresión normal ...
2147483646 | 1111111111111111111111111111110
2147483647 (mayor entero con signo) | 1111111111111111111111111111111 (31 1's)
2147483648 | -2147483648 | 10000000000000000000000000000000
... progresión normal ...
4294967294 | -2 | 11111111111111111111111111111110
4294967295 (mayor entero sin signo) | -1 | 11111111111111111111111111111111 (32 1's)
Rango de entradas en máquinas de 64-bit
number positivo | number negativo | valor de retorno
0 | 0
1 | 1
2 | 10
... progresión normal ...
9223372036854775806 | 111111111111111111111111111111111111111111111111111111111111110
9223372036854775807 (mayor entero con signo) | 111111111111111111111111111111111111111111111111111111111111111 (63 1's)
-9223372036854775808 | 1000000000000000000000000000000000000000000000000000000000000000
... progresión normal ...
-2 | 1111111111111111111111111111111111111111111111111111111111111110
-1 | 1111111111111111111111111111111111111111111111111111111111111111 (64 1's)

Valores devueltos

Cadena de la representación binaria de number

Ejemplos

Ejemplo #1 Ejemplo de decbin()

<?php
echo decbin(12) . "\n";
echo decbin(26);
?>

El resultado del ejemplo sería:

1100
11010

Ver también

  • bindec() - Binario a decimal
  • decoct() - Decimal a octal
  • dechex() - Decimal a hexadecimal
  • base_convert() - Convertir un número entre bases arbitrarias
  • printf() - Imprimir una cadena con formato, usando %b, %032b o %064b como formato
  • sprintf(), usando %b, %032b o %064b como formato


Decimal a hexadecimal

  • « decbin
  • decoct »
  • PHP Manual
  • Funciones Matemáticas
  • Decimal a hexadecimal

dechex

(PHP 4, PHP 5, PHP 7, PHP 8)

dechex — Decimal a hexadecimal

Descripción

dechex ( int $number ) : string

Devuelve una cadena que contiene una representación hexadecimal del argumento number dado.

El mayor número que puede convertirse es PHP_INT_MAX * 2 + 1 (o -1): en plataformas de 32 bits, este será 4294967295 en decimal, cuyos resultados utilizando dechex() devolverán ffffffff.

Parámetros

number

Valor decimal a convertir.

Aunque los tipos integer PHP tienen signo, la dechex() los trata como enteros sin signo, de igual forma los enteros negativos serán tratados como si no tuvieran signo.

Valores devueltos

Representación tipo cadena hexadecimal de number.

Ejemplos

Ejemplo #1 Ejemplo dechex()

<?php
echo dechex(10) . "\n";
echo dechex(47);
?>

El resultado del ejemplo sería:

a
2f

Ejemplo #2 Ejemplo de dechex() con números enteros grandes

<?php
// La salida siguiente asume una plataforma de 32-bit.
// Tenga en cuenta que la salida es la misma para todos los valores.
echo dechex(-1)."\n";
echo dechex(PHP_INT_MAX * 2 + 1)."\n";
echo dechex(pow(2, 32) - 1)."\n";
?>

El resultado del ejemplo sería:

ffffffff
ffffffff
ffffffff

Ver también

  • hexdec() - Hexadecimal a decimal
  • decbin() - Decimal a binario
  • decoct() - Decimal a octal
  • base_convert() - Convertir un número entre bases arbitrarias


Decimal a octal

  • « dechex
  • deg2rad »
  • PHP Manual
  • Funciones Matemáticas
  • Decimal a octal

decoct

(PHP 4, PHP 5, PHP 7, PHP 8)

decoct — Decimal a octal

Descripción

decoct ( int $number ) : string

Devuelve una cadena que contiene una representación octal del argumento number dado. El mayor número dque puede ser convertido depende de la plataforma empleada. Para plataformas de 32 bits, este es normalmente 4294967295 en decimal, resultando en 37777777777. Para plataformas de 64 bits, este es normalmente 9223372036854775807 en decimal, resultando en 777777777777777777777.

Parámetros

number

Valor decimal a convertir

Valores devueltos

Representación tipo cadena octal de numero

Ejemplos

Ejemplo #1 Ejemplo de decoct()

<?php
echo decoct(15) . "\n";
echo decoct(264);
?>

El resultado del ejemplo sería:

17
410

Ver también

  • octdec() - Octal a decimal
  • decbin() - Decimal a binario
  • dechex() - Decimal a hexadecimal
  • base_convert() - Convertir un número entre bases arbitrarias


Convierte el número en grados a su equivalente en radianes

  • « decoct
  • exp »
  • PHP Manual
  • Funciones Matemáticas
  • Convierte el número en grados a su equivalente en radianes

deg2rad

(PHP 4, PHP 5, PHP 7, PHP 8)

deg2rad — Convierte el número en grados a su equivalente en radianes

Descripción

deg2rad ( float $number ) : float

Esta función convierte a numero desde grados a su equivalente en radianes.

Parámetros

number

Valor angular en grados

Valores devueltos

El equivalente en radianes de number

Ejemplos

Ejemplo #1 Ejemplo de deg2rad()

<?php

echo deg2rad(45); // 0.785398163397
var_dump(deg2rad(45) === M_PI_4); // bool(true)

?>

Ver también

  • rad2deg() - Convierte el número en radianes a su equivalente en grados


Calcula la exponencial de e

  • « deg2rad
  • expm1 »
  • PHP Manual
  • Funciones Matemáticas
  • Calcula la exponencial de e

exp

(PHP 4, PHP 5, PHP 7, PHP 8)

exp — Calcula la exponencial de e

Descripción

exp ( float $arg ) : float

Devuelve e elevado a la potencia de arg.

Nota:

'e' es la base del sistema natural de logaritmos, y su valor aproximado es 2.718282.

Parámetros

arg

El argumento a procesar

Valores devueltos

'e' elevado a la potencia de arg

Ejemplos

Ejemplo #1 Ejemplo de exp()

<?php
echo exp(12) . "\n";
echo exp(5.7);
?>

El resultado del ejemplo sería:

1.6275E+005
298.87

Ver también

  • log() - Logaritmo natural
  • pow() - Expresión exponencial


Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

  • « exp
  • fdiv »
  • PHP Manual
  • Funciones Matemáticas
  • Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

expm1

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

expm1 — Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

Descripción

expm1 ( float $arg ) : float

expm1() devuelve el equivalente a 'exp(arg) - 1' calculado de tal forma que no pierde precisión incluso cuando el valor de arg se aproxima a cero, un caso donde 'exp (arg) - 1' puede ser inexacto debido a la resta de dos numeros que son casi iguales.

Parámetros

arg

El argumento a procesar

Valores devueltos

'e' elevado a la potencia de arg menos uno

Historial de cambios

Versión | Descripción
5.3.0 | Esta función está ahora disponible en todas las plataformas.

Ver también

  • log1p() - Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
  • exp() - Calcula la exponencial de e


Divides two numbers, according to IEEE 754

  • « expm1
  • floor »
  • PHP Manual
  • Funciones Matemáticas
  • Divides two numbers, according to IEEE 754

fdiv

(PHP 8)

fdiv — Divides two numbers, according to IEEE 754

Descripción

fdiv ( float $num1 , float $num2 ) : float

Returns the floating point result of dividing the num1 by the num2. If the num2 is zero, then one of INF, -INF, or NAN will be returned.

Note that in comparisons, NAN will never == or ===, any value, including itself.

Parámetros

num1

The dividend (numerator)

num2

The divisor

Valores devueltos

The floating point result of num1/num2

Ejemplos

Ejemplo #1 Using fdiv()

<?php
var_dump(fdiv(5.7, 1.3)); // float(4.384615384615385)
var_dump(fdiv(4, 2)); // float(2)
var_dump(fdiv(1.0, 0.0)); // float(INF)
var_dump(fdiv(-1.0, 0.0)); // float(-INF)
var_dump(fdiv(0.0, 0.0)); // float(NAN)
?>

Ver también

  • / - Floating-point division
  • intdiv() - Integer division
  • fmod() - Modulus


Redondear fracciones hacia abajo

  • « fdiv
  • fmod »
  • PHP Manual
  • Funciones Matemáticas
  • Redondear fracciones hacia abajo

floor

(PHP 4, PHP 5, PHP 7, PHP 8)

floor — Redondear fracciones hacia abajo

Descripción

floor ( float $value ) : mixed

Devuelve el siguiente valor de tipo integer (como float), redondeando value si fuera necesario.

Parámetros

value

El valor numérico a redondear

Valores devueltos

value redondeado al anterior entero más bajo. El valor de retorno de floor() sigue siendo de tipo float ya que el rango de valores de float es usualmente mayor que el del tipo integer. Esta función devuelve FALSE en caso de error (p.ej., al pasar un array).

Ejemplos

Ejemplo #1 Ejemplo de floor()

<?php
echo floor(4.3);   // 4
echo floor(9.999); // 9
echo floor(-3.14); // -4
?>

Ver también

  • ceil() - Redondear fracciones hacia arriba
  • round() - Redondea un float


Devuelve el resto en punto flotante (módulo) de la división de los argumentos

  • « floor
  • getrandmax »
  • PHP Manual
  • Funciones Matemáticas
  • Devuelve el resto en punto flotante (módulo) de la división de los argumentos

fmod

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

fmod — Devuelve el resto en punto flotante (módulo) de la división de los argumentos

Descripción

fmod ( float $x , float $y ) : float

Devuelve el resto en punto flotante de dividir el dividendo (x) por el divisor (y). El resto (r) es definido como: x = i * y + r, para algún entero i. Si y es diferente de cero, r tiene el mismo signo que x y una magnitud menor que la magnitud de y.

Parámetros

x

El dividendo

y

El divisor

Valores devueltos

El resto en punto flotante de x/y

Ejemplos

Ejemplo #1 Uso de fmod()

<?php
$x = 5.7;
$y = 1.3;
$r = fmod($x, $y);
// $r es igual a 0.5, ya que 4 * 1.3 + 0.5 = 5.7
?>


Mostrar el mayor valor aleatorio posible

  • « fmod
  • hexdec »
  • PHP Manual
  • Funciones Matemáticas
  • Mostrar el mayor valor aleatorio posible

getrandmax

(PHP 4, PHP 5, PHP 7, PHP 8)

getrandmax — Mostrar el mayor valor aleatorio posible

Descripción

getrandmax ( ) : int

Devuelve el valor máximo que puede ser devuelto por una llamada a rand().

Valores devueltos

El valor aleatorio más grande posible devuelto por rand()

Ver también

  • rand() - Genera un número entero aleatorio
  • srand() - Genera un número aleatorio a partir de una semilla
  • mt_getrandmax() - Mostrar el mayor valor aleatorio posible


Hexadecimal a decimal

  • « getrandmax
  • hypot »
  • PHP Manual
  • Funciones Matemáticas
  • Hexadecimal a decimal

hexdec

(PHP 4, PHP 5, PHP 7, PHP 8)

hexdec — Hexadecimal a decimal

Descripción

hexdec ( string $hex_string ) : number

Devuelve el equivalente decimal del número hexadecimal representado por el argumento cadena_hex. hexdec() convierte un string hexadecimal a un número decimal.

hexdec() ignora cualquier caracter no hexadecimal que encuentre.

Parámetros

hex_string

El string hexadecimal a convertir

Valores devueltos

La representación decimal de hex_string

Ejemplos

Ejemplo #1 Ejemplo de hexdec()

<?php
var_dump(hexdec("See"));
var_dump(hexdec("ee"));
// ambos imprimen "int(238)"

var_dump(hexdec("that")); // imprime "int(10)"
var_dump(hexdec("a0")); // imprime "int(160)"
?>

Notas

Nota:

Esta función puede convertir números que son demasiado grandes para caber en el tipo integer de cada plataforma, devolviendo en este caso un valor de tipo float para los valores mayores.

Ver también

  • dechex() - Decimal a hexadecimal
  • bindec() - Binario a decimal
  • octdec() - Octal a decimal
  • base_convert() - Convertir un número entre bases arbitrarias


Calcula la longitud de la hipotenusa de un triángulo de ángulo recto

  • « hexdec
  • intdiv »
  • PHP Manual
  • Funciones Matemáticas
  • Calcula la longitud de la hipotenusa de un triángulo de ángulo recto

hypot

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

hypot — Calcula la longitud de la hipotenusa de un triángulo de ángulo recto

Descripción

hypot ( float $x , float $y ) : float

hypot() devuelve la longitud de la hipotenusa de un triángulo de ángulo recto con lados de longitud x y y, o la distancio del punto (x, y) a partir del origen. Esto es equivalente a sqrt(x*x + y*y).

Parámetros

x

Longitud del primer lado

y

Longitud del segundo lado

Valores devueltos

La longitud calculada de la hipotenusa


División entera

  • « hypot
  • is_finite »
  • PHP Manual
  • Funciones Matemáticas
  • División entera

intdiv

(PHP 7, PHP 8)

intdiv — División entera

Descripción

intdiv ( int $dividend , int $divisor ) : int

Devuelve el cociente entero de la división de dividend entre divisor.

Parámetros

dividend

El número a dividir.

divisor

El número que divide a dividend

Valores devueltos

El cociente entero de la división de dividend entre divisor.

Errores/Excepciones

Si divisor es 0, se lanza una excepción DivisionByZeroError. Si dividend es PHP_INT_MIN y divisor es -1, entonces se lanza una excepción ArithmeticError.

Ejemplos

Ejemplo #1 Ejemplo de intdiv()

<?php
var_dump(intdiv(3, 2));
var_dump(intdiv(-3, 2));
var_dump(intdiv(3, -2));
var_dump(intdiv(-3, -2));
var_dump(intdiv(PHP_INT_MAX, PHP_INT_MAX));
var_dump(intdiv(PHP_INT_MIN, PHP_INT_MIN));
var_dump(intdiv(PHP_INT_MIN, -1));
var_dump(intdiv(1, 0));
?>
int(1)
int(-1)
int(-1)
int(1)
int(1)
int(1)

Fatal error: Uncaught ArithmeticError: Division of PHP_INT_MIN by -1 is not an integer in %s on line 8
Fatal error: Uncaught DivisionByZeroError: Division by zero in %s on line 9


Encuentra si un valor es un número finito legal

  • « intdiv
  • is_infinite »
  • PHP Manual
  • Funciones Matemáticas
  • Encuentra si un valor es un número finito legal

is_finite

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_finite — Encuentra si un valor es un número finito legal

Descripción

is_finite ( float $val ) : bool

Verifica si val es un número finito legal en esta plataforma.

Parámetros

val

El valor a chequear

Valores devueltos

true si val es un número finito legal en el rango permitido para un valor flotante PHP en esta plataforma, false de lo contrario.

Ver también

  • is_infinite() - Encuentra si un valor es infinito
  • is_nan() - Encuentra si un valor no es un número


Encuentra si un valor es infinito

  • « is_finite
  • is_nan »
  • PHP Manual
  • Funciones Matemáticas
  • Encuentra si un valor es infinito

is_infinite

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_infinite — Encuentra si un valor es infinito

Descripción

is_infinite ( float $val ) : bool

Devuelve true si val es infinito (positivo o negativo), como el resultado de log(0) o cualquier valor demasiado grande para caber en un flotante en esta plataforma.

Parámetros

val

El valor a chequear

Valores devueltos

true si val es infinito, false de lo contrario.

Ver también

  • is_finite() - Encuentra si un valor es un número finito legal
  • is_nan() - Encuentra si un valor no es un número


Encuentra si un valor no es un número

  • « is_infinite
  • lcg_value »
  • PHP Manual
  • Funciones Matemáticas
  • Encuentra si un valor no es un número

is_nan

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_nan — Encuentra si un valor no es un número

Descripción

is_nan ( float $val ) : bool

Verifica si val no es un numero, como por ejemplo el resultado de acos(1.01).

Parámetros

val

El valor a revisar

Valores devueltos

Devuelve true si val no es un número, en caso contrario devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de is_nan()

<?php
// Invalid calculation, will return a
// NaN value
$nan = acos(8);

var_dump($nan, is_nan($nan));
?>

El resultado del ejemplo sería:

float(NAN)
bool(true)

Ver también

  • is_finite() - Encuentra si un valor es un número finito legal
  • is_infinite() - Encuentra si un valor es infinito


Generador lineal congruente combinado

  • « is_nan
  • log10 »
  • PHP Manual
  • Funciones Matemáticas
  • Generador lineal congruente combinado

lcg_value

(PHP 4, PHP 5, PHP 7, PHP 8)

lcg_value — Generador lineal congruente combinado

Descripción

lcg_value ( ) : float

lcg_value() devuelve un número pseudo-aleatorio en el rango (0, 1). La función combina dos generadores congruentes con periodos de 2^31 - 85 y 2^31 - 249. El periodo de esta función es igual al producto de ambos primos.

Precaución

Esta función no genera valores criptográficos fiables por lo que no debería empelarse para propósitos criptográficos. Si fuera necesario un valor criptográfico seguro, considérese utilizar random_int(), random_bytes(), o openssl_random_pseudo_bytes() en su lugar.

Valores devueltos

Un valor flotante pseudo-aleatorio en el rango de (0, 1)

Ver también

  • rand() - Genera un número entero aleatorio
  • mt_rand() - Genera un mejor número entero aleatorio


Logaritmo en base 10

  • « lcg_value
  • log1p »
  • PHP Manual
  • Funciones Matemáticas
  • Logaritmo en base 10

log10

(PHP 4, PHP 5, PHP 7, PHP 8)

log10 — Logaritmo en base 10

Descripción

log10 ( float $arg ) : float

Devuelve el logaritmo en base 10 de arg.

Parámetros

arg

El argumento a procesar

Valores devueltos

El logaritmo en base 10 de arg

Ver también

  • log() - Logaritmo natural


Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

  • « log10
  • log »
  • PHP Manual
  • Funciones Matemáticas
  • Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

log1p

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

log1p — Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.

Descripción

log1p ( float $number ) : float

log1p() devuelve el equivalente a log(1 + number) calculado de tal forma que no pierde precisión incluso cuando el valor de number se aproxima a cero. log() puede devolver sólo log(1) en este caso debido a la falta de precisión.

Parámetros

number

El argumento a procesar

Valores devueltos

log(1 + number)

Historial de cambios

Versión | Descripción
5.3.0 | Esta función está disponible en todas las plataformas.

Ver también

  • expm1() - Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
  • log() - Logaritmo natural
  • log10() - Logaritmo en base 10


Logaritmo natural

  • « log1p
  • max »
  • PHP Manual
  • Funciones Matemáticas
  • Logaritmo natural

log

(PHP 4, PHP 5, PHP 7, PHP 8)

log — Logaritmo natural

Descripción

log ( float $arg , float $base = M_E ) : float

Si se especifica el parámetro opcional base, log() devuelve logbase arg, y en caso contrario log() devuelve el logaritmo natural de arg.

Parámetros

arg

El valor al que se desea calcular el logaritmo

base

La base opcinal del logaritmo a usar (por omisión es 'e' y por lo tanto el logaritmo natural).

Valores devueltos

El logaritmo de arg en la base dada por base, si se indica, o en su lugar el logaritmo natural.

Ver también

  • log10() - Logaritmo en base 10
  • exp() - Calcula la exponencial de e
  • pow() - Expresión exponencial


Encontrar el valor más alto

  • « log
  • min »
  • PHP Manual
  • Funciones Matemáticas
  • Encontrar el valor más alto

max

(PHP 4, PHP 5, PHP 7, PHP 8)

max — Encontrar el valor más alto

Descripción

max ( array $values ) : mixed
max ( mixed $value1 , mixed $value2 , mixed $... = ? ) : mixed

Si el primer y único parámetro es un array, max() devuelve el valor más alto de ese array. Si se proporcionan al menos dos parámetros, max() devuelve el mayor de estos valores.

Nota:

Los valores de diferentes tipos serán comparados utilizando las reglas de comparación estándar. Por ejemplo, un string no numérico será comparado con un integer como si fuera 0, aunque varios valores no numéricos de tipo string serán comparados alfanuméricamente. El valor real devuelto será del tipo original sin ninguna conversión aplicada.

Precaución

Tenga cuidado al pasar argumentos con valores de tipos mezclados debido a que max() puede producir resultados impredecibles.

Parámetros

values

Un array que contiene los valores.

value1

Cualquier valor comparable.

value2

Cualquier valor comparable.

...

Cualquier valor comparable.

Valores devueltos

max() devuelve el valor del parámetro considerado "el mayor" según las reglas de comparación estándar. Si varios valores de diferentes tipos se evalúan como iguales (p.ej. 0 y 'abc'), será devuelto el primero proporcionado a la función.

Si se pasa un array vacío, se devolverá false y se emitirá un error E_WARNING.

Ejemplos

Ejemplo #1 Ejemplos de uso de max()

<?php
echo max(2, 3, 1, 6, 7);  // 7
echo max(array(2, 4, 5)); // 5

// La cadena 'hola' es tratada como 0 cuando se compara con un número entero
// Ya que los dos valores son iguales, el orden en el que se proporcionan determina el resultado
echo max(0, 'hola');     // 0
echo max('hola', 0);     // hola

// Aquí se compara -1 < 0, por lo que 'hola' es el valor mayor
echo max(-1, 'hola');    // hola

// Con varios arrays de diferentes longitudes, max devuelve el más largo
$val = max(array(2, 2, 2), array(1, 1, 1, 1)); // array(1, 1, 1, 1)

// Varios arrays de la misma longitud son comparados de izquierda a derecha,
// así que en nuestro ejemplo: 2 == 2, pero 5 > 4
$val = max(array(2, 4, 8), array(2, 5, 1)); // array(2, 5, 1)

// Si se pasan un array y algo que no sea un array, será devuelto el array,
// ya que las comparaciones tratan a los arrays como mayores que cualquier otro valor
$val = max('cadena', array(2, 5, 7), 42);   // array(2, 5, 7)

// Si un argumento es NULL o un booleano, será comparado con
// otros valores usando la regla FALSE < TRUE independientemente de los otros tipos involucrados
// En los ejemplos de abajo, -10 y 10 son tratados como TRUE en la comparación
$val = max(-10, FALSE); // -10

// 0, por el contrario, es tratado como FALSE, por lo que es "menor que" TRUE
$val = max(0, TRUE); // TRUE
?>

Ver también

  • min() - Encontrar el valor más bajo
  • count() - Cuenta todos los elementos de un array o algo de un objeto


Encontrar el valor más bajo

  • « max
  • mt_getrandmax »
  • PHP Manual
  • Funciones Matemáticas
  • Encontrar el valor más bajo

min

(PHP 4, PHP 5, PHP 7, PHP 8)

min — Encontrar el valor más bajo

Descripción

min ( array $values ) : mixed
min ( mixed $value1 , mixed $value2 , mixed $... = ? ) : mixed

Si el primer y único parámetro es un array, min() devuelve el valor más bajo de ese array. Si se proporcionan al menos dos parámetros, min() devuelve el menor de estos valores.

Nota:

Valores de diferentes tipos serán comparados utilizando las reglas de comparación estándar. Por ejemplo, un string no numérico será comparado con un integer como si fuera 0, aunque varios valores de tipo string serán comparados alfanuméricamente. El valor real devuelto será del tipo original sin ninguna conversión aplicada.

Parámetros

valores

Un array que contiene los valores.

value1

Cualquier valor comparable.

value2

Cualquier valor comparable.

...

Cualquier valor comparable.

Valores devueltos

min() devuelve el valor del parámetro condierado "el menor" según la comparación estándar. Si varios valores de diferentes tipos se evalúan como iguales (p.ej. 0 y 'abc'), será devuelto el primero proporcionado a la función.

Si se pasa un array vacío, se devolverá false y se emitirá un error E_WARNING.

Ejemplos

Ejemplo #1 Ejemplos de uso de min()

<?php
echo min(2, 3, 1, 6, 7);  // 1
echo min(array(2, 4, 5)); // 2

// La cadena 'hola' es tratada como 0 cuando se compara con un número entero
// Ya que los dos valores son iguales, el orden en el que se proporcionan determina el resultado
echo min(0, 'hola');     // 0
echo min('hola', 0);     // hola

// Aquí se compara -1 < 0, por lo que -1 es el valor menor
echo min('hola', -1);    // -1

// Con varios arrays de diferentes longitudes, min devuelve el más corto
$val = min(array(2, 2, 2), array(1, 1, 1, 1)); // array(2, 2, 2)

// Varios arrays de la misma longitud son comparados de izquierda a derecha,
// así que en nuestro ejemplo: 2 == 2, pero 4 < 5
$val = min(array(2, 4, 8), array(2, 5, 1)); // array(2, 4, 8)

// Si se pasan un array y algo que no sea un array, el array nunca es devuelto
// ya que las comparaciones tratan a los arrays como mayores que cualquier otro valor
$val = min('string', array(2, 5, 7), 42);   // string

// Si un argumento es NULL o un booleano, será comparado con
// otros valores usando la regla FALSE < TRUE independientemente de los otros tipos involucrados
// En los ejemplos de abajo, -10 y 10 son tratados como TRUE en la comparación
$val = min(-10, FALSE, 10); // FALSE
$val = min(-10, NULL, 10);  // NULL

// 0, por el contrario, es tratado como FALSE, por lo que es "menor que" TRUE
$val = min(0, TRUE); // 0
?>

Ver también

  • max() - Encontrar el valor más alto
  • count() - Cuenta todos los elementos de un array o algo de un objeto


Mostrar el mayor valor aleatorio posible

  • « min
  • mt_rand »
  • PHP Manual
  • Funciones Matemáticas
  • Mostrar el mayor valor aleatorio posible

mt_getrandmax

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_getrandmax — Mostrar el mayor valor aleatorio posible

Descripción

mt_getrandmax ( ) : int

Devuelve el valor máximo que puede ser devuelto por una llamada a mt_rand().

Valores devueltos

Devuelve el valor aleatorio máximo devuelto por una llamada a mt_rand() sin argumentos, el cual es el valor máximo que se puede emplear para su parámetro max sin que sea ampliado el resultado (y por lo tanto menos aleatorio).

Ejemplos

Ejemplo #1 Calcular un número de coma flotante aleatorio

<?php
function randomFloat($min = 0, $max = 1) {
    return $min + mt_rand() / mt_getrandmax() * ($max - $min);
}

var_dump(randomFloat());
var_dump(randomFloat(2, 20));
?>

El resultado del ejemplo sería algo similar a:

float(0.91601131712832)
float(16.511210331931)

Ver también

  • mt_rand() - Genera un mejor número entero aleatorio
  • mt_srand() - Genera el mejor número aleatorio a partir de una semilla
  • getrandmax() - Mostrar el mayor valor aleatorio posible


Genera un mejor número entero aleatorio

  • « mt_getrandmax
  • mt_srand »
  • PHP Manual
  • Funciones Matemáticas
  • Genera un mejor número entero aleatorio

mt_rand

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_rand — Genera un mejor número entero aleatorio

Descripción

mt_rand ( ) : int
mt_rand ( int $min , int $max ) : int

Muchos generadores de números aleatorios de libcs antiguas tienen características dudosas o desconocidas y son lentas. De manera predeterminada, PHP usa la libc generadora de números aleatorios con la función rand(). La función mt_rand() es un sustituto de dicha función. Utiliza un generador de números aleatorios con características conocidas usando » Mersenne Twister, que produce números aleatorios cuatro veces más rápido que el promedio proporcionado por la libc rand().

Si se emplea sin los argumentos opcionales min y max, mt_rand() devuelve un valor pseudoaleatorio entre 0 y mt_getrandmax(). Para obtener un número aleatorio entre 5 y 15 (incluidos), por ejemplo, use mt_rand(5, 15).

Precaución

Esta función no genera valores criptográficos fiables por lo que no debería empelarse para propósitos criptográficos. Si fuera necesario un valor criptográfico seguro, considérese utilizar random_int(), random_bytes(), o openssl_random_pseudo_bytes() en su lugar.

Parámetros

min

Opcionalmente, el menor valor a devolver (por defecto: 0)

max

Opcionalmente, el mayor valor a devolver (por defecto: mt_getrandmax())

Valores devueltos

Un valor entero aleatorio entre min (o 0) y max (o mt_getrandmax(), incluidos), o false si max es menor que min.

Historial de cambios

Versión | Descripción
5.3.4 | Emite un error de nivel E_WARNING y devuelve false si max < min.

Ejemplos

Ejemplo #1 Ejemplo de mt_rand()

<?php
echo mt_rand() . "\n";
echo mt_rand() . "\n";

echo mt_rand(5, 15);
?>

El resultado del ejemplo sería algo similar a:

1604716014
1478613278
6

Notas

Advertencia

El rango min-max debe estar entre el rango mt_getrandmax(). Esto es, (max - min) <= mt_getrandmax() De lo contrario, mt_rand() podría devolver números aleatorios pobres.

Ver también

  • mt_srand() - Genera el mejor número aleatorio a partir de una semilla
  • mt_getrandmax() - Mostrar el mayor valor aleatorio posible
  • random_int() - Genera números enteros seudoaleatorios criptográficamente seguros
  • random_bytes() - Genera bytes seudoaleatorios criptográficamente seguros
  • openssl_random_pseudo_bytes() - Genera una cadena de bytes pseudo-aleatoria
  • rand() - Genera un número entero aleatorio


Genera el mejor número aleatorio a partir de una semilla

  • « mt_rand
  • octdec »
  • PHP Manual
  • Funciones Matemáticas
  • Genera el mejor número aleatorio a partir de una semilla

mt_srand

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_srand — Genera el mejor número aleatorio a partir de una semilla

Descripción

mt_srand ( int $seed = ? ) : void

Incorpora la semilla seed al generador de números aleatorios, o con un valor aleatorio si no se proporciona seed.

Nota: No es necesario usar una semilla para usar el generador de números aleatorios con srand() o mt_srand() ya que se hace automáticamente.

Parámetros

seed

Valor de la semilla opcional

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.2.1 | La implementación de Mersenne Twister en PHP ahora usa un nuevo algoritmo para la semilla de Richard Wagner. La misma semilla ahora ya no produce la misma secuencia de valores como sucedía en anteriores versiones. No se espera que se vuelva a cambiar de nuevo este comportamiento, aunque, no obstante, se considera inseguro confiar en él.

Ejemplos

Ejemplo #1 Ejemplo de mt_srand()

<?php
// semilla de microsegundos
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return (float) $sec + ((float) $usec * 100000);
}
mt_srand(make_seed());
$randval = mt_rand();
?>

Ver también

  • mt_rand() - Genera un mejor número entero aleatorio
  • mt_getrandmax() - Mostrar el mayor valor aleatorio posible
  • srand() - Genera un número aleatorio a partir de una semilla


Octal a decimal

  • « mt_srand
  • pi »
  • PHP Manual
  • Funciones Matemáticas
  • Octal a decimal

octdec

(PHP 4, PHP 5, PHP 7, PHP 8)

octdec — Octal a decimal

Descripción

octdec ( string $octal_string ) : number

Devuelve el valor decimal equivalente al número octal representado por el argumento cadena_octal.

Parámetros

octal_string

El string octal a convertir

Valores devueltos

La representación decimal de octal_string

Ejemplos

Ejemplo #1 Ejemplo de octdec()

<?php
echo octdec('77') . "\n";
echo octdec(decoct(45));
?>

El resultado del ejemplo sería:

63
45

Notas

Nota:

Esta función puede convertir números que son demasiado grandes para caber en el tipo integer de cada plataforma, devolviendo en este caso un valor de tipo float para los valores mayores.

Ver también

  • decoct() - Decimal a octal
  • bindec() - Binario a decimal
  • hexdec() - Hexadecimal a decimal
  • base_convert() - Convertir un número entre bases arbitrarias


Obtener valor de pi

  • « octdec
  • pow »
  • PHP Manual
  • Funciones Matemáticas
  • Obtener valor de pi

pi

(PHP 4, PHP 5, PHP 7, PHP 8)

pi — Obtener valor de pi

Descripción

pi ( ) : float

Devuelve una aproximación de pi. El valor float devuelto tiene una precisión basada en la directiva precision en php.ini, cuyo valor predeterminado es 14. Asimismo, es posible usar la constantio M_PI, la cual produce el mismo resultado que pi().

Valores devueltos

El valor de pi como flotante.

Ejemplos

Ejemplo #1 Ejemplo de pi()

<?php
echo pi(); // 3.1415926535898
echo M_PI; // 3.1415926535898
?>


Expresión exponencial

  • « pi
  • rad2deg »
  • PHP Manual
  • Funciones Matemáticas
  • Expresión exponencial

pow

(PHP 4, PHP 5, PHP 7, PHP 8)

pow — Expresión exponencial

Descripción

pow ( number $base , number $exp ) : number

Devuelve el valor de base elevado a la potencia exp.

Nota:

En PHP 5.6 en adelante, se podría preferir el empleo del operador **.

Parámetros

base

La base a emplear

exp

El exponente

Valores devueltos

base elevada a la potencia de exp. Si ambos argumentos son números enteros no negativos y el resultado puede ser representado como un entero, el resultado será devuelto con tipo integer; de lo contrario se devuelve como un float.

Ejemplos

Ejemplo #1 Algunos ejemplos de pow()

<?php

var_dump(pow(2, 8)); // int(256)
echo pow(-1, 20); // 1
echo pow(0, 0); // 1
echo pow(10, -1); // 0.1

echo pow(-1, 5.5); // PHP >=5.2.2: NAN
echo pow(-1, 5.5); // PHP <5.2.2: -NAN
?>

Notas

Nota:

Esta función convertirá toda entrada en un número, incluso valores no escalares, lo cual podría conducir a resultados extraños.

Ver también

  • exp() - Calcula la exponencial de e
  • sqrt() - Raíz cuadrada
  • bcpow() - Elevar un número de precisión arbitraria a otro
  • gmp_pow() - Aumenta el número a la potencia


Convierte el número en radianes a su equivalente en grados

  • « pow
  • rand »
  • PHP Manual
  • Funciones Matemáticas
  • Convierte el número en radianes a su equivalente en grados

rad2deg

(PHP 4, PHP 5, PHP 7, PHP 8)

rad2deg — Convierte el número en radianes a su equivalente en grados

Descripción

rad2deg ( float $number ) : float

Esta función convierte a numero desde radianes a grados.

Parámetros

number

Un valor en radianes

Valores devueltos

El equivalente de number en grados

Ejemplos

Ejemplo #1 Ejemplo de rad2deg()

<?php

echo rad2deg(M_PI_4); // 45

?>

Ver también

  • deg2rad() - Convierte el número en grados a su equivalente en radianes


Genera un número entero aleatorio

  • « rad2deg
  • round »
  • PHP Manual
  • Funciones Matemáticas
  • Genera un número entero aleatorio

rand

(PHP 4, PHP 5, PHP 7, PHP 8)

rand — Genera un número entero aleatorio

Descripción

rand ( ) : int
rand ( int $min , int $max ) : int

Si se invoca sin los argumentos opcionales min y max, rand() devuelve un entero pseudoaleatorio entre 0 y getrandmax(). Para obtener un número aleatorio entre 5 y 15 (incluidos), por ejemplo, use rand(5, 15).

Precaución

Esta función no genera valores criptográficos fiables por lo que no debería empelarse para propósitos criptográficos. Si fuera necesario un valor criptográfico seguro, considérese utilizar random_int(), random_bytes(), o openssl_random_pseudo_bytes() en su lugar.

Nota: En algunas plataformas (como en Windows), getrandmax() sólo alcanza hasta 32767. En caso de necesitar un valor mayor de 32767, se deberá especificar min y max para crear un valor mayor que este, o considere emplear mt_rand() en su lugar.

Parámetros

min

El menor valor a devolver (por defecto: 0)

max

El mayor valor a devolver (por defecto: getrandmax())

Valores devueltos

Un valor pseudoaleatorio entre min (o 0) y max (o getrandmax(), incluidos).

Ejemplos

Ejemplo #1 Ejemplo de rand()

<?php
echo rand() . "\n";
echo rand() . "\n";

echo rand(5, 15);
?>

El resultado del ejemplo sería algo similar a:

7771
22264
11

Notas

Advertencia

El rango min-max debe estar entre el rango getrandmax(). Esto es, (max - min) <= getrandmax() De lo contrario, rand() podría devolver números aleatorios pobres.

Ver también

  • srand() - Genera un número aleatorio a partir de una semilla
  • getrandmax() - Mostrar el mayor valor aleatorio posible
  • mt_rand() - Genera un mejor número entero aleatorio
  • random_int() - Genera números enteros seudoaleatorios criptográficamente seguros
  • random_bytes() - Genera bytes seudoaleatorios criptográficamente seguros
  • openssl_random_pseudo_bytes() - Genera una cadena de bytes pseudo-aleatoria


Redondea un float

  • « rand
  • sin »
  • PHP Manual
  • Funciones Matemáticas
  • Redondea un float

round

(PHP 4, PHP 5, PHP 7, PHP 8)

round — Redondea un float

Descripción

round ( float $val , int $precision = 0 , int $mode = PHP_ROUND_HALF_UP ) : float

Devuelve el valor redondeado de val con la precision especificada (número de dígitos desde el punto decimal). precision puede también ser negativo o cero (valor predeterminado).

Nota: PHP no maneja correctamente cadenas como "12,300.2" por defecto. Consulte conversión desde cadenas.

Parámetros

val

El valor a redondear

precision

Opcionalmente, el número de dígitos decimales a redondear.

mode

Use una de las siguientes constantes para especificar el modo de redondeo.

Constante | Descripción
PHP_ROUND_HALF_UP | Redondea val hacia arriba a precision lugares decimales alejándose de cero, cuando está a medio camino. Hace que 1.5 sea 2, y -1.5 sea -2.
PHP_ROUND_HALF_DOWN | Redondea val hacia abajo a precision lugares decimales hacia cero, cuando está a medio camino. Hace que 1.5 sea 1, y -1.5 sea -1.
PHP_ROUND_HALF_EVEN | Redondea val a precision lugares decimales hacia el siguiente valor par.
PHP_ROUND_HALF_ODD | Redondea val a precision lugares decimales hacia el siguiente valor impar.

Valores devueltos

El valor redondeado

Ejemplos

Ejemplo #1 Ejemplos de round()

<?php
echo round(3.4);         // 3
echo round(3.5);         // 4
echo round(3.6);         // 4
echo round(3.6, 0);      // 4
echo round(1.95583, 2);  // 1.96
echo round(1241757, -3); // 1242000
echo round(5.045, 2);    // 5.05
echo round(5.055, 2);    // 5.06
?>

Ejemplo #2 Ejemplos de mode

<?php
echo round(9.5, 0, PHP_ROUND_HALF_UP);   // 10
echo round(9.5, 0, PHP_ROUND_HALF_DOWN); // 9
echo round(9.5, 0, PHP_ROUND_HALF_EVEN); // 10
echo round(9.5, 0, PHP_ROUND_HALF_ODD);  // 9

echo round(8.5, 0, PHP_ROUND_HALF_UP);   // 9
echo round(8.5, 0, PHP_ROUND_HALF_DOWN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_EVEN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_ODD);  // 9
?>

Ejemplo #3 Ejemplos de mode con precisión

<?php
/* Usar PHP_ROUND_HALF_UP com precisión de 1 dígito decimal */
echo round( 1.55, 1, PHP_ROUND_HALF_UP);   //  1.6
echo round( 1.54, 1, PHP_ROUND_HALF_UP);   //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_UP);   // -1.6
echo round(-1.54, 1, PHP_ROUND_HALF_UP);   // -1.5

/* Usar PHP_ROUND_HALF_DOWN com precisión de 1 dígito decimal */
echo round( 1.55, 1, PHP_ROUND_HALF_DOWN); //  1.5
echo round( 1.54, 1, PHP_ROUND_HALF_DOWN); //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_DOWN); // -1.5
echo round(-1.54, 1, PHP_ROUND_HALF_DOWN); // -1.5

/* Usar PHP_ROUND_HALF_EVEN com precisión de 1 dígito decimal */
echo round( 1.55, 1, PHP_ROUND_HALF_EVEN); //  1.6
echo round( 1.54, 1, PHP_ROUND_HALF_EVEN); //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_EVEN); // -1.6
echo round(-1.54, 1, PHP_ROUND_HALF_EVEN); // -1.5

/* Usar PHP_ROUND_HALF_ODD com precisión de 1 dígito decimal */
echo round( 1.55, 1, PHP_ROUND_HALF_ODD);  //  1.5
echo round( 1.54, 1, PHP_ROUND_HALF_ODD);  //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_ODD);  // -1.5
echo round(-1.54, 1, PHP_ROUND_HALF_ODD);  // -1.5
?>

Historial de cambios

Versión | Descripción
5.3.0 | Se introdujo el parámetro mode.
5.2.7 | El funcionamiento interno en round() se modificó para adecuarse al estándar C99.

Ver también

  • ceil() - Redondear fracciones hacia arriba
  • floor() - Redondear fracciones hacia abajo
  • number_format() - Formatear un número con los millares agrupados


Seno

  • « round
  • sinh »
  • PHP Manual
  • Funciones Matemáticas
  • Seno

sin

(PHP 4, PHP 5, PHP 7, PHP 8)

sin — Seno

Descripción

sin ( float $arg ) : float

sin() devuelve el seno del parámetro arg. El parámetro arg se encuentra en radianes.

Parámetros

arg

Un valor en radianes

Valores devueltos

El seno de arg

Ejemplos

Ejemplo #1 Ejemplo de sin()

<?php

// La precisión depende de su directiva de precisión
echo sin(deg2rad(60));  //  0.866025403 ...
echo sin(60);           // -0.304810621 ...

?>

Ver también

  • asin() - Arco seno
  • sinh() - Seno hiperbólico
  • cos() - Coseno
  • tan() - Tangente
  • deg2rad() - Convierte el número en grados a su equivalente en radianes


Seno hiperbólico

  • « sin
  • sqrt »
  • PHP Manual
  • Funciones Matemáticas
  • Seno hiperbólico

sinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

sinh — Seno hiperbólico

Descripción

sinh ( float $arg ) : float

Devuelve el seno hiperbólico de arg, definido como (exp(arg) - exp(-arg))/2.

Parámetros

arg

El argumento a procesar

Valores devueltos

El seno hiperbólico de arg

Ver también

  • sin() - Seno
  • asinh() - Arco seno hiperbólico
  • cosh() - Coseno hiperbólico
  • tanh() - Tangente hiperbólica


Raíz cuadrada

  • « sinh
  • srand »
  • PHP Manual
  • Funciones Matemáticas
  • Raíz cuadrada

sqrt

(PHP 4, PHP 5, PHP 7, PHP 8)

sqrt — Raíz cuadrada

Descripción

sqrt ( float $arg ) : float

Devuelve la raíz cuadrada de arg.

Parámetros

arg

El argumento a procesar

Valores devueltos

La raíz cuadrada de arg o el valor especial NAN para números negativos.

Ejemplos

Ejemplo #1 Ejemplo de sqrt()

<?php
// La precisión depende de la directiva de precisión elegida
echo sqrt(9); // 3
echo sqrt(10); // 3.16227766 ...
?>

Ver también

  • pow() - Expresión exponencial


Genera un número aleatorio a partir de una semilla

  • « sqrt
  • tan »
  • PHP Manual
  • Funciones Matemáticas
  • Genera un número aleatorio a partir de una semilla

srand

(PHP 4, PHP 5, PHP 7, PHP 8)

srand — Genera un número aleatorio a partir de una semilla

Descripción

srand ( int $seed = ? ) : void

Incorpora la semilla seed al generador de números aleatorios, o con un valor aleatorio si no se proporciona seed.

Nota: No es necesario usar una semilla para usar el generador de números aleatorios con srand() o mt_srand() ya que se hace automáticamente.

Parámetros

seed

Valor de la semilla opcional

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de srand()

<?php
// semilla de microsegundos
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return (float) $sec + ((float) $usec * 100000);
}
srand(make_seed());
$randval = rand();
?>

Ver también

  • rand() - Genera un número entero aleatorio
  • getrandmax() - Mostrar el mayor valor aleatorio posible
  • mt_srand() - Genera el mejor número aleatorio a partir de una semilla


Tangente

  • « srand
  • tanh »
  • PHP Manual
  • Funciones Matemáticas
  • Tangente

tan

(PHP 4, PHP 5, PHP 7, PHP 8)

tan — Tangente

Descripción

tan ( float $arg ) : float

tan() devuelve la tangente del parámetro arg. El parámetro arg se encuentra en radianes.

Parámetros

arg

El argumento a procesar en radianes

Valores devueltos

La tangente de arg

Ejemplos

Ejemplo #1 Ejemplo de tan()

<?php

echo tan(M_PI_4); // 1

?>

Ver también

  • atan() - Arco tangente
  • atan2() - Arco tangente de dos variables
  • sin() - Seno
  • cos() - Coseno
  • tanh() - Tangente hiperbólica
  • deg2rad() - Convierte el número en grados a su equivalente en radianes


Tangente hiperbólica

  • « tan
  • Estadísticas »
  • PHP Manual
  • Funciones Matemáticas
  • Tangente hiperbólica

tanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

tanh — Tangente hiperbólica

Descripción

tanh ( float $arg ) : float

Devuelve la tangente hiperbólica de arg, definida como sinh(arg)/cosh(arg).

Parámetros

arg

El argumento a procesar

Valores devueltos

La tangente hiperbólica de arg

Ver también

  • tan() - Tangente
  • atanh() - Arco tangente hiperbólica
  • sinh() - Seno hiperbólico
  • cosh() - Coseno hiperbólico


Estadísticas

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Estadísticas
    • stats_absolute_deviation — Devuelve la desviación media de una matriz de valores
    • stats_cdf_beta — Calcula un parámetro de la distribución beta según los valores dados a los otros
    • stats_cdf_binomial — Calcula un parámetro de la distribución binomial según los valores dados a los otros
    • stats_cdf_cauchy — No documentada
    • stats_cdf_chisquare — Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros
    • stats_cdf_exponential — No documentada
    • stats_cdf_f — Calcula un parámetro de la distribución F según los valores dados a los otros
    • stats_cdf_gamma — Calcula un parámetro de la distribución gamma según los valores dados a los otros
    • stats_cdf_laplace — No documentada
    • stats_cdf_logistic — No documentada
    • stats_cdf_negative_binomial — Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros
    • stats_cdf_noncentral_chisquare — Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros
    • stats_cdf_noncentral_f — Calcula un parámetro de la distribución F no central según los valores dados a los otros
    • stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others
    • stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others
    • stats_cdf_poisson — Calcula un parámetro de la distribución de Poisson según los valores dados a los otros
    • stats_cdf_t — Calcula un parámetro de la distribución T según los valores dados a los otros
    • stats_cdf_uniform — No documentada
    • stats_cdf_weibull — No documentada
    • stats_covariance — Computa la covarianza de dos conjuntos de datos
    • stats_dens_beta — No documentada
    • stats_dens_cauchy — No documentada
    • stats_dens_chisquare — No documentada
    • stats_dens_exponential — No documentada
    • stats_dens_f — Descripción
    • stats_dens_gamma — No documentada
    • stats_dens_laplace — No documentada
    • stats_dens_logistic — No documentada
    • stats_dens_normal — No documentada
    • stats_dens_pmf_binomial — No documentada
    • stats_dens_pmf_hypergeometric — Descripción
    • stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution
    • stats_dens_pmf_poisson — No documentada
    • stats_dens_t — No documentada
    • stats_dens_uniform — Probability density function of the uniform distribution
    • stats_dens_weibull — No documentada
    • stats_harmonic_mean — Devuelve la media armónica de una matriz de valores
    • stats_kurtosis — Computa la curtosis de la información de la matriz
    • stats_rand_gen_beta — Genera una desviación aleatoria beta
    • stats_rand_gen_chisquare — Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria
    • stats_rand_gen_exponential — Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"
    • stats_rand_gen_f — Genera una desviación aleatoria
    • stats_rand_gen_funiform — Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)
    • stats_rand_gen_gamma — Genera desviaciones aleatorias desde una distribución gamma
    • stats_rand_gen_ibinomial_negative — Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))
    • stats_rand_gen_ibinomial — Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE
    • stats_rand_gen_int — Genera enteros aleatorios entre 1 y 2147483562
    • stats_rand_gen_ipoisson — Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)
    • stats_rand_gen_iuniform — Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)
    • stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution
    • stats_rand_gen_noncentral_f — Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no central hasta la variación ji-cuadrado de denominador central
    • stats_rand_gen_noncentral_t — Genera una desviación aleatoria sencilla desde una distribución T no central
    • stats_rand_gen_normal — Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF
    • stats_rand_gen_t — Genera una desviación aleatoria sencilla desde una distribución T
    • stats_rand_get_seeds — No documentada
    • stats_rand_phrase_to_seeds — Generar dos semillas para el generador de números aleatorios RGN
    • stats_rand_ranf — Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual
    • stats_rand_setall — No documentada
    • stats_skew — Computa la oblicuidad de los datos de una matriz
    • stats_standard_deviation — Devuelve la desviación estándar
    • stats_stat_binomial_coef — No documentada
    • stats_stat_correlation — No documentada
    • stats_stat_factorial — Returns the factorial of an integer
    • stats_stat_independent_t — No documentada
    • stats_stat_innerproduct — Descripción
    • stats_stat_paired_t — No documentada
    • stats_stat_percentile — No documentada
    • stats_stat_powersum — No documentada
    • stats_variance — Devuelve la varianza de población


Introducción

Esta es la extensión de estadísticas. Contiene varias docenas de funciones útiles para cálculo estadístico. Es una envoltura sobre 2 bibliotecas ceintíficas, a saber DCDFLIB (Biblioteca de rutinas en C para Funciones de Distribución Acumulada, Inversos, y Otros parámetros) por B. Brown & J. Lavato y RANDLIB por Barry Brown, James Lavato & Kathy Russell. Incluye funciones CD y PD.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

No se necesitan bibliotecas externas. La extensión viene incluida con las bibliotecas usadas.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/stats.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Tipos de recursos
  • Funciones de Estadísticas »
  • PHP Manual
  • Estadísticas
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Estadísticas

Tabla de contenidos

  • stats_absolute_deviation — Devuelve la desviación media de una matriz de valores
  • stats_cdf_beta — Calcula un parámetro de la distribución beta según los valores dados a los otros
  • stats_cdf_binomial — Calcula un parámetro de la distribución binomial según los valores dados a los otros
  • stats_cdf_cauchy — No documentada
  • stats_cdf_chisquare — Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros
  • stats_cdf_exponential — No documentada
  • stats_cdf_f — Calcula un parámetro de la distribución F según los valores dados a los otros
  • stats_cdf_gamma — Calcula un parámetro de la distribución gamma según los valores dados a los otros
  • stats_cdf_laplace — No documentada
  • stats_cdf_logistic — No documentada
  • stats_cdf_negative_binomial — Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros
  • stats_cdf_noncentral_chisquare — Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros
  • stats_cdf_noncentral_f — Calcula un parámetro de la distribución F no central según los valores dados a los otros
  • stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others
  • stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others
  • stats_cdf_poisson — Calcula un parámetro de la distribución de Poisson según los valores dados a los otros
  • stats_cdf_t — Calcula un parámetro de la distribución T según los valores dados a los otros
  • stats_cdf_uniform — No documentada
  • stats_cdf_weibull — No documentada
  • stats_covariance — Computa la covarianza de dos conjuntos de datos
  • stats_dens_beta — No documentada
  • stats_dens_cauchy — No documentada
  • stats_dens_chisquare — No documentada
  • stats_dens_exponential — No documentada
  • stats_dens_f — Descripción
  • stats_dens_gamma — No documentada
  • stats_dens_laplace — No documentada
  • stats_dens_logistic — No documentada
  • stats_dens_normal — No documentada
  • stats_dens_pmf_binomial — No documentada
  • stats_dens_pmf_hypergeometric — Descripción
  • stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution
  • stats_dens_pmf_poisson — No documentada
  • stats_dens_t — No documentada
  • stats_dens_uniform — Probability density function of the uniform distribution
  • stats_dens_weibull — No documentada
  • stats_harmonic_mean — Devuelve la media armónica de una matriz de valores
  • stats_kurtosis — Computa la curtosis de la información de la matriz
  • stats_rand_gen_beta — Genera una desviación aleatoria beta
  • stats_rand_gen_chisquare — Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria
  • stats_rand_gen_exponential — Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"
  • stats_rand_gen_f — Genera una desviación aleatoria
  • stats_rand_gen_funiform — Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)
  • stats_rand_gen_gamma — Genera desviaciones aleatorias desde una distribución gamma
  • stats_rand_gen_ibinomial_negative — Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))
  • stats_rand_gen_ibinomial — Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE
  • stats_rand_gen_int — Genera enteros aleatorios entre 1 y 2147483562
  • stats_rand_gen_ipoisson — Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)
  • stats_rand_gen_iuniform — Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)
  • stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution
  • stats_rand_gen_noncentral_f — Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no central hasta la variación ji-cuadrado de denominador central
  • stats_rand_gen_noncentral_t — Genera una desviación aleatoria sencilla desde una distribución T no central
  • stats_rand_gen_normal — Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF
  • stats_rand_gen_t — Genera una desviación aleatoria sencilla desde una distribución T
  • stats_rand_get_seeds — No documentada
  • stats_rand_phrase_to_seeds — Generar dos semillas para el generador de números aleatorios RGN
  • stats_rand_ranf — Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual
  • stats_rand_setall — No documentada
  • stats_skew — Computa la oblicuidad de los datos de una matriz
  • stats_standard_deviation — Devuelve la desviación estándar
  • stats_stat_binomial_coef — No documentada
  • stats_stat_correlation — No documentada
  • stats_stat_factorial — Returns the factorial of an integer
  • stats_stat_independent_t — No documentada
  • stats_stat_innerproduct — Descripción
  • stats_stat_paired_t — No documentada
  • stats_stat_percentile — No documentada
  • stats_stat_powersum — No documentada
  • stats_variance — Devuelve la varianza de población


Devuelve la desviación media de una matriz de valores

  • « Funciones de Estadísticas
  • stats_cdf_beta »
  • PHP Manual
  • Funciones de Estadísticas
  • Devuelve la desviación media de una matriz de valores

stats_absolute_deviation

(PECL stats >= 1.0.0)

stats_absolute_deviation — Devuelve la desviación media de una matriz de valores

Descripción

stats_absolute_deviation ( array $a ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

Valores devueltos


Calcula un parámetro de la distribución beta según los valores dados a los otros

  • « stats_absolute_deviation
  • stats_cdf_binomial »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución beta según los valores dados a los otros

stats_cdf_beta

(PECL stats >= 1.0.0)

stats_cdf_beta — Calcula un parámetro de la distribución beta según los valores dados a los otros

Descripción

stats_cdf_beta ( float $par1 , float $par2 , float $par3 , int $which ) : float

Método La función de distribución acumulativa (P) se calcula directamente mediante código asociado con la referencia siguiente. DiDinato, A. R. and Morris, A. H. Algorithm 708: Significant Digit Computation of the Incomplete Beta Function Ratios. ACM Trans. Math. Softw. 18 (1993), 360-373. El cálculo de los demás parámetros implica una búsqueda de un valor que produzca del valor deseado de P. La búsqueda depende de la monotonía de P con el otro parámetro. Nota La densidad de beta es proporcional a t^(A-1) * (1-t)^(B-1) Argumentos P -- La integral desde 0 a X de la distribución ji-cuadrado. Rango de entrada: [0, 1]. Q -- 1-P. Rango de entrada: [0, 1]. P + Q = 1.0. X -- Límite superior de integración de la densidad beta. Rango de entrada: [0,1]. Rango de búsqueda: [0,1] Y -- 1-X. Rango de entrada: [0,1]. Rango de búsqueda: [0,1] X + Y = 1.0. A -- El primer parámetro de la densidad beta. Rango de entrada: (0, +infinito). Rango de búsqueda: [1D-100,1D100] B -- El segundo parámetro de la densidad beta. Rango de entrada: (0, +infinito). Rango de búsqueda: [1D-100,1D100] STATUS -- 0 si el cálculo se completo correctamente -I si el parámetro de entrada número I está fuera de rango 1 si la respuesta parece ser menor que el límite de búsqueda más bajo 2 si la respuesta parece ser mayor que el límite de búsqueda más alto 3 si P + Q .ne. 1 4 si X + Y .ne. 1 BOUND -- Indefinido si STATUS es 0 Límite excedido por el parámetro número I si STATUS es negativo. Límite de búsqueda inferior si STATUS es 1. Límite de búsqueda superior si STATUS es 2.

Parámetros

par1

par2

par3

which

Un entero que indica cuál de los valores de los cuatro siguientes argumentos se va a calcular desde los otros. Ralgo válido: 1..4 which = 1 : Calcula P y Q desde X,Y,A y B which = 2 : Calcula X y Y desde P,Q,A y B which = 3 : Calcula A desde P,Q,X,Y y B which = 4 : Calcula B desde P,Q,X,Y y A

Valores devueltos

STATUS -- 0 si el cálculo se completo correctamente -I si el parámetro de entrada número I está fuera de rango 1 si la respuesta parece ser menor que el límite de búsqueda más bajo 2 si la respuesta parece ser mayor que el límite de búsqueda más alto 3 si P + Q .ne. 1 4 si X + Y .ne. 1


Calcula un parámetro de la distribución binomial según los valores dados a los otros

  • « stats_cdf_beta
  • stats_cdf_cauchy »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución binomial según los valores dados a los otros

stats_cdf_binomial

(PECL stats >= 1.0.0)

stats_cdf_binomial — Calcula un parámetro de la distribución binomial según los valores dados a los otros

Descripción

stats_cdf_binomial ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


No documentada

  • « stats_cdf_binomial
  • stats_cdf_chisquare »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_cauchy

(PECL stats >= 1.0.0)

stats_cdf_cauchy — No documentada

Descripción

stats_cdf_cauchy ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros

  • « stats_cdf_cauchy
  • stats_cdf_exponential »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros

stats_cdf_chisquare

(PECL stats >= 1.0.0)

stats_cdf_chisquare — Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros

Descripción

stats_cdf_chisquare ( float $par1 , float $par2 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

which

Valores devueltos


No documentada

  • « stats_cdf_chisquare
  • stats_cdf_f »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_exponential

(PECL stats >= 1.0.0)

stats_cdf_exponential — No documentada

Descripción

stats_cdf_exponential ( float $par1 , float $par2 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

which

Valores devueltos


Calcula un parámetro de la distribución F según los valores dados a los otros

  • « stats_cdf_exponential
  • stats_cdf_gamma »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución F según los valores dados a los otros

stats_cdf_f

(PECL stats >= 1.0.0)

stats_cdf_f — Calcula un parámetro de la distribución F según los valores dados a los otros

Descripción

stats_cdf_f ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Calcula un parámetro de la distribución gamma según los valores dados a los otros

  • « stats_cdf_f
  • stats_cdf_laplace »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución gamma según los valores dados a los otros

stats_cdf_gamma

(PECL stats >= 1.0.0)

stats_cdf_gamma — Calcula un parámetro de la distribución gamma según los valores dados a los otros

Descripción

stats_cdf_gamma ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


No documentada

  • « stats_cdf_gamma
  • stats_cdf_logistic »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_laplace

(PECL stats >= 1.0.0)

stats_cdf_laplace — No documentada

Descripción

stats_cdf_laplace ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


No documentada

  • « stats_cdf_laplace
  • stats_cdf_negative_binomial »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_logistic

(PECL stats >= 1.0.0)

stats_cdf_logistic — No documentada

Descripción

stats_cdf_logistic ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros

  • « stats_cdf_logistic
  • stats_cdf_noncentral_chisquare »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros

stats_cdf_negative_binomial

(PECL stats >= 1.0.0)

stats_cdf_negative_binomial — Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros

Descripción

stats_cdf_negative_binomial ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros

  • « stats_cdf_negative_binomial
  • stats_cdf_noncentral_f »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros

stats_cdf_noncentral_chisquare

(PECL stats >= 1.0.0)

stats_cdf_noncentral_chisquare — Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros

Descripción

stats_cdf_noncentral_chisquare ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Calcula un parámetro de la distribución F no central según los valores dados a los otros

  • « stats_cdf_noncentral_chisquare
  • stats_cdf_noncentral_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución F no central según los valores dados a los otros

stats_cdf_noncentral_f

(PECL stats >= 1.0.0)

stats_cdf_noncentral_f — Calcula un parámetro de la distribución F no central según los valores dados a los otros

Descripción

stats_cdf_noncentral_f ( float $par1 , float $par2 , float $par3 , float $par4 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

par4

which

Valores devueltos


Calculates any one parameter of the non-central t-distribution give values for the others

  • « stats_cdf_noncentral_f
  • stats_cdf_normal »
  • PHP Manual
  • Funciones de Estadísticas
  • Calculates any one parameter of the non-central t-distribution give values for the others

stats_cdf_noncentral_t

(PECL stats >= 1.0.0)

stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others

Descripción

stats_cdf_noncentral_t ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the non-central t-distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, nu, and mu denotes cumulative distribution function, the value of the random variable, the degrees of freedom and the non-centrality parameter of the distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | nu | mu
2 | x | CDF | nu | mu
3 | nu | x | CDF | mu
4 | mu | x | CDF | nu

Parámetros

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

Valores devueltos

Returns CDF, x, nu, or mu, determined by which.


Calculates any one parameter of the normal distribution given values for the others

  • « stats_cdf_noncentral_t
  • stats_cdf_poisson »
  • PHP Manual
  • Funciones de Estadísticas
  • Calculates any one parameter of the normal distribution given values for the others

stats_cdf_normal

(PECL stats >= 1.0.0)

stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others

Descripción

stats_cdf_normal ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the normal distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, mu, and sigma denotes cumulative distribution function, the value of the random variable, the mean and the standard deviation of the normal distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | mu | sigma
2 | x | CDF | mu | sigma
3 | mu | x | CDF | sigma
4 | sigma | x | CDF | mu

Parámetros

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

Valores devueltos

Returns CDF, x, mu, or sigma, determined by which.


Calcula un parámetro de la distribución de Poisson según los valores dados a los otros

  • « stats_cdf_normal
  • stats_cdf_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución de Poisson según los valores dados a los otros

stats_cdf_poisson

(PECL stats >= 1.0.0)

stats_cdf_poisson — Calcula un parámetro de la distribución de Poisson según los valores dados a los otros

Descripción

stats_cdf_poisson ( float $par1 , float $par2 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

which

Valores devueltos


Calcula un parámetro de la distribución T según los valores dados a los otros

  • « stats_cdf_poisson
  • stats_cdf_uniform »
  • PHP Manual
  • Funciones de Estadísticas
  • Calcula un parámetro de la distribución T según los valores dados a los otros

stats_cdf_t

(PECL stats >= 1.0.0)

stats_cdf_t — Calcula un parámetro de la distribución T según los valores dados a los otros

Descripción

stats_cdf_t ( float $par1 , float $par2 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

which

Valores devueltos


No documentada

  • « stats_cdf_t
  • stats_cdf_weibull »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_uniform

(PECL stats >= 1.0.0)

stats_cdf_uniform — No documentada

Descripción

stats_cdf_uniform ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


No documentada

  • « stats_cdf_uniform
  • stats_covariance »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_cdf_weibull

(PECL stats >= 1.0.0)

stats_cdf_weibull — No documentada

Descripción

stats_cdf_weibull ( float $par1 , float $par2 , float $par3 , int $which ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

par1

par2

par3

which

Valores devueltos


Computa la covarianza de dos conjuntos de datos

  • « stats_cdf_weibull
  • stats_dens_beta »
  • PHP Manual
  • Funciones de Estadísticas
  • Computa la covarianza de dos conjuntos de datos

stats_covariance

(PECL stats >= 1.0.0)

stats_covariance — Computa la covarianza de dos conjuntos de datos

Descripción

stats_covariance ( array $a , array $b ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

b

Valores devueltos


No documentada

  • « stats_covariance
  • stats_dens_cauchy »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_beta

(PECL stats >= 1.0.0)

stats_dens_beta — No documentada

Descripción

stats_dens_beta ( float $x , float $a , float $b ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

a

b

Valores devueltos


No documentada

  • « stats_dens_beta
  • stats_dens_chisquare »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_cauchy

(PECL stats >= 1.0.0)

stats_dens_cauchy — No documentada

Descripción

stats_dens_cauchy ( float $x , float $ave , float $stdev ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

ave

stdev

Valores devueltos


No documentada

  • « stats_dens_cauchy
  • stats_dens_exponential »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_chisquare

(PECL stats >= 1.0.0)

stats_dens_chisquare — No documentada

Descripción

stats_dens_chisquare ( float $x , float $dfr ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

dfr

Valores devueltos


No documentada

  • « stats_dens_chisquare
  • stats_dens_f »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_exponential

(PECL stats >= 1.0.0)

stats_dens_exponential — No documentada

Descripción

stats_dens_exponential ( float $x , float $scale ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

scale

Valores devueltos


Descripción

  • « stats_dens_exponential
  • stats_dens_gamma »
  • PHP Manual
  • Funciones de Estadísticas
  • Descripción

stats_dens_f

(PECL stats >= 1.0.0)

stats_dens_f —

Descripción

stats_dens_f ( float $x , float $dfr1 , float $dfr2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

dfr1

dfr2

Valores devueltos


No documentada

  • « stats_dens_f
  • stats_dens_laplace »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_gamma

(PECL stats >= 1.0.0)

stats_dens_gamma — No documentada

Descripción

stats_dens_gamma ( float $x , float $shape , float $scale ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

shape

scale

Valores devueltos


No documentada

  • « stats_dens_gamma
  • stats_dens_logistic »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_laplace

(PECL stats >= 1.0.0)

stats_dens_laplace — No documentada

Descripción

stats_dens_laplace ( float $x , float $ave , float $stdev ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

ave

stdev

Valores devueltos


No documentada

  • « stats_dens_laplace
  • stats_dens_normal »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_logistic

(PECL stats >= 1.0.0)

stats_dens_logistic — No documentada

Descripción

stats_dens_logistic ( float $x , float $ave , float $stdev ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

ave

stdev

Valores devueltos


No documentada

  • « stats_dens_logistic
  • stats_dens_pmf_binomial »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_normal

(PECL stats >= 1.0.0)

stats_dens_normal — No documentada

Descripción

stats_dens_normal ( float $x , float $ave , float $stdev ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

ave

stdev

Valores devueltos


No documentada

  • « stats_dens_normal
  • stats_dens_pmf_hypergeometric »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_pmf_binomial

(PECL stats >= 1.0.0)

stats_dens_pmf_binomial — No documentada

Descripción

stats_dens_pmf_binomial ( float $x , float $n , float $pi ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

n

pi

Valores devueltos


Descripción

  • « stats_dens_pmf_binomial
  • stats_dens_pmf_negative_binomial »
  • PHP Manual
  • Funciones de Estadísticas
  • Descripción

stats_dens_pmf_hypergeometric

(PECL stats >= 1.0.0)

stats_dens_pmf_hypergeometric —

Descripción

stats_dens_pmf_hypergeometric ( float $n1 , float $n2 , float $N1 , float $N2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

n1

n2

N1

N2

Valores devueltos


Probability mass function of the negative binomial distribution

  • « stats_dens_pmf_hypergeometric
  • stats_dens_pmf_poisson »
  • PHP Manual
  • Funciones de Estadísticas
  • Probability mass function of the negative binomial distribution

stats_dens_pmf_negative_binomial

(PECL stats >= 1.0.0)

stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution

Descripción

stats_dens_pmf_negative_binomial ( float $x , float $n , float $pi ) : float

Returns the probability mass at x, where the random variable follows the negative binomial distribution of which the number of the success is n and the success rate is pi.

Parámetros

x

The value at which the probability mass is calculated

n

The number of the success of the distribution

pi

The success rate of the distribution

Valores devueltos

The probability mass at x or false for failure.


No documentada

  • « stats_dens_pmf_negative_binomial
  • stats_dens_t »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_pmf_poisson

(PECL stats >= 1.0.0)

stats_dens_pmf_poisson — No documentada

Descripción

stats_dens_pmf_poisson ( float $x , float $lb ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

lb

Valores devueltos


No documentada

  • « stats_dens_pmf_poisson
  • stats_dens_uniform »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_t

(PECL stats >= 1.0.0)

stats_dens_t — No documentada

Descripción

stats_dens_t ( float $x , float $dfr ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

dfr

Valores devueltos


Probability density function of the uniform distribution

  • « stats_dens_t
  • stats_dens_weibull »
  • PHP Manual
  • Funciones de Estadísticas
  • Probability density function of the uniform distribution

stats_dens_uniform

(PECL stats >= 1.0.0)

stats_dens_uniform — Probability density function of the uniform distribution

Descripción

stats_dens_uniform ( float $x , float $a , float $b ) : float

Returns the probability density at x, where the random variable follows the uniform distribution of which the lower bound is a and the upper bound is b.

Parámetros

x

The value at which the probability density is calculated

a

The lower bound of the distribution

b

The upper bound of the distribution

Valores devueltos

The probability density at x or false for failure.


No documentada

  • « stats_dens_uniform
  • stats_harmonic_mean »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_dens_weibull

(PECL stats >= 1.0.0)

stats_dens_weibull — No documentada

Descripción

stats_dens_weibull ( float $x , float $a , float $b ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

a

b

Valores devueltos


Devuelve la media armónica de una matriz de valores

  • « stats_dens_weibull
  • stats_kurtosis »
  • PHP Manual
  • Funciones de Estadísticas
  • Devuelve la media armónica de una matriz de valores

stats_harmonic_mean

(PECL stats >= 1.0.0)

stats_harmonic_mean — Devuelve la media armónica de una matriz de valores

Descripción

stats_harmonic_mean ( array $a ) : number
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

Valores devueltos


Computa la curtosis de la información de la matriz

  • « stats_harmonic_mean
  • stats_rand_gen_beta »
  • PHP Manual
  • Funciones de Estadísticas
  • Computa la curtosis de la información de la matriz

stats_kurtosis

(PECL stats >= 1.0.0)

stats_kurtosis — Computa la curtosis de la información de la matriz

Descripción

stats_kurtosis ( array $a ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

Valores devueltos


Genera una desviación aleatoria beta

  • « stats_kurtosis
  • stats_rand_gen_chisquare »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria beta

stats_rand_gen_beta

(PECL stats >= 1.0.0)

stats_rand_gen_beta — Genera una desviación aleatoria beta

Descripción

stats_rand_gen_beta ( float $a , float $b ) : float

Devuelve una desviación aleatoria desde una distribución beta con los parámetros A y B. La densidad de beta es x^(a-1) * (1-x)^(b-1) / B(a,b) para 0 < x <. Método R. C. H. Cheng.

Parámetros

a

b

Valores devueltos


Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria

  • « stats_rand_gen_beta
  • stats_rand_gen_exponential »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria

stats_rand_gen_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_chisquare — Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria

Descripción

stats_rand_gen_chisquare ( float $df ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

df

Valores devueltos


Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"

  • « stats_rand_gen_chisquare
  • stats_rand_gen_f »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"

stats_rand_gen_exponential

(PECL stats >= 1.0.0)

stats_rand_gen_exponential — Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"

Descripción

stats_rand_gen_exponential ( float $av ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

av

Valores devueltos


Genera una desviación aleatoria

  • « stats_rand_gen_exponential
  • stats_rand_gen_funiform »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria

stats_rand_gen_f

(PECL stats >= 1.0.0)

stats_rand_gen_f — Genera una desviación aleatoria

Descripción

stats_rand_gen_f ( float $dfn , float $dfd ) : float

Genera una desviación aleatoria desde la distribución F (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador. Método : genera directamente el ratio de las variaciones ji-cuadrado.

Parámetros

dfn

dfd

Valores devueltos


Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)

  • « stats_rand_gen_f
  • stats_rand_gen_gamma »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)

stats_rand_gen_funiform

(PECL stats >= 1.0.0)

stats_rand_gen_funiform — Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)

Descripción

stats_rand_gen_funiform ( float $low , float $high ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

low

high

Valores devueltos


Genera desviaciones aleatorias desde una distribución gamma

  • « stats_rand_gen_funiform
  • stats_rand_gen_ibinomial_negative »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera desviaciones aleatorias desde una distribución gamma

stats_rand_gen_gamma

(PECL stats >= 1.0.0)

stats_rand_gen_gamma — Genera desviaciones aleatorias desde una distribución gamma

Descripción

stats_rand_gen_gamma ( float $a , float $r ) : float

Genera desviaciones aleatorias desde una distribución gamma cuya densidad es (A**R)/Gamma(R) * X**(R-1) * Exp(-A*X).

Parámetros

a

parámetro de ubicación de la distribución Gamma (a > 0).

r

parámetro de forma de la distribución Gamma (r > 0).

Valores devueltos


Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))

  • « stats_rand_gen_gamma
  • stats_rand_gen_ibinomial »
  • PHP Manual
  • Funciones de Estadísticas
  • Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))

stats_rand_gen_ibinomial_negative

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial_negative — Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))

Descripción

stats_rand_gen_ibinomial_negative ( int $n , float $p ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

n

p

Valores devueltos


Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE

  • « stats_rand_gen_ibinomial_negative
  • stats_rand_gen_int »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE

stats_rand_gen_ibinomial

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial — Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE

Descripción

stats_rand_gen_ibinomial ( int $n , float $pp ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

n

pp

Valores devueltos


Genera enteros aleatorios entre 1 y 2147483562

  • « stats_rand_gen_ibinomial
  • stats_rand_gen_ipoisson »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera enteros aleatorios entre 1 y 2147483562

stats_rand_gen_int

(PECL stats >= 1.0.0)

stats_rand_gen_int — Genera enteros aleatorios entre 1 y 2147483562

Descripción

stats_rand_gen_int ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Valores devueltos


Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)

  • « stats_rand_gen_int
  • stats_rand_gen_iuniform »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)

stats_rand_gen_ipoisson

(PECL stats >= 1.0.0)

stats_rand_gen_ipoisson — Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)

Descripción

stats_rand_gen_ipoisson ( float $mu ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mu

Valores devueltos


Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)

  • « stats_rand_gen_ipoisson
  • stats_rand_gen_noncentral_chisquare »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)

stats_rand_gen_iuniform

(PECL stats >= 1.0.0)

stats_rand_gen_iuniform — Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)

Descripción

stats_rand_gen_iuniform ( int $low , int $high ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

low

high

Valores devueltos


Generates a random deviate from the non-central chi-square distribution

  • « stats_rand_gen_iuniform
  • stats_rand_gen_noncentral_f »
  • PHP Manual
  • Funciones de Estadísticas
  • Generates a random deviate from the non-central chi-square distribution

stats_rand_gen_noncentral_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution

Descripción

stats_rand_gen_noncentral_chisquare ( float $df , float $xnonc ) : float

Returns a random deviate from the non-central chi-square distribution with degrees of freedom, df, and non-centrality parameter, xnonc.

Parámetros

df

The degrees of freedom

xnonc

The non-centrality parameter

Valores devueltos

A random deviate


Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no centra

  • « stats_rand_gen_noncentral_chisquare
  • stats_rand_gen_noncentral_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no central hasta la variación ji-cuadrado de denominador central

stats_rand_gen_noncentral_f

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_f — Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no central hasta la variación ji-cuadrado de denominador central

Descripción

stats_rand_gen_noncentral_f ( float $dfn , float $dfd , float $xnonc ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

dfn

dfd

xnonc

Valores devueltos


Genera una desviación aleatoria sencilla desde una distribución T no central

  • « stats_rand_gen_noncentral_f
  • stats_rand_gen_normal »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria sencilla desde una distribución T no central

stats_rand_gen_noncentral_t

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_t — Genera una desviación aleatoria sencilla desde una distribución T no central

Descripción

stats_rand_gen_noncentral_t ( float $df , float $xnonc ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

df

xnonc

Valores devueltos


Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF

  • « stats_rand_gen_noncentral_t
  • stats_rand_gen_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF

stats_rand_gen_normal

(PECL stats >= 1.0.0)

stats_rand_gen_normal — Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF

Descripción

stats_rand_gen_normal ( float $av , float $sd ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

av

sd

Valores devueltos


Genera una desviación aleatoria sencilla desde una distribución T

  • « stats_rand_gen_normal
  • stats_rand_get_seeds »
  • PHP Manual
  • Funciones de Estadísticas
  • Genera una desviación aleatoria sencilla desde una distribución T

stats_rand_gen_t

(PECL stats >= 1.0.0)

stats_rand_gen_t — Genera una desviación aleatoria sencilla desde una distribución T

Descripción

stats_rand_gen_t ( float $df ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

df

Valores devueltos


No documentada

  • « stats_rand_gen_t
  • stats_rand_phrase_to_seeds »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_rand_get_seeds

(PECL stats >= 1.0.0)

stats_rand_get_seeds — No documentada

Descripción

stats_rand_get_seeds ( ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Valores devueltos


Generar dos semillas para el generador de números aleatorios RGN

  • « stats_rand_get_seeds
  • stats_rand_ranf »
  • PHP Manual
  • Funciones de Estadísticas
  • Generar dos semillas para el generador de números aleatorios RGN

stats_rand_phrase_to_seeds

(PECL stats >= 1.0.0)

stats_rand_phrase_to_seeds — Generar dos semillas para el generador de números aleatorios RGN

Descripción

stats_rand_phrase_to_seeds ( string $phrase ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

phrase

Valores devueltos


Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual

  • « stats_rand_phrase_to_seeds
  • stats_rand_setall »
  • PHP Manual
  • Funciones de Estadísticas
  • Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual

stats_rand_ranf

(PECL stats >= 1.0.0)

stats_rand_ranf — Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual

Descripción

stats_rand_ranf ( ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Valores devueltos


No documentada

  • « stats_rand_ranf
  • stats_skew »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_rand_setall

(PECL stats >= 1.0.0)

stats_rand_setall — No documentada

Descripción

stats_rand_setall ( int $iseed1 , int $iseed2 ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iseed1

iseed2

Valores devueltos


Computa la oblicuidad de los datos de una matriz

  • « stats_rand_setall
  • stats_standard_deviation »
  • PHP Manual
  • Funciones de Estadísticas
  • Computa la oblicuidad de los datos de una matriz

stats_skew

(PECL stats >= 1.0.0)

stats_skew — Computa la oblicuidad de los datos de una matriz

Descripción

stats_skew ( array $a ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

Valores devueltos


Devuelve la desviación estándar

  • « stats_skew
  • stats_stat_binomial_coef »
  • PHP Manual
  • Funciones de Estadísticas
  • Devuelve la desviación estándar

stats_standard_deviation

(PECL stats >= 1.0.0)

stats_standard_deviation — Devuelve la desviación estándar

Descripción

stats_standard_deviation ( array $a , bool $sample = false ) : float

Parámetros

a

El array de datos de los que calcular la desviación estándar. Observed que todos los valores del array serán convertidos a float.

sample

Indica si a representa una muestra de la población; por omisión es false.

Valores devueltos

Devuelve la desviación estándar en caso de éxito; false en caso de error.

Errores/Excepciones

Emite un error de nivel E_WARNING cuando hay menos de dos valores en a.


No documentada

  • « stats_standard_deviation
  • stats_stat_correlation »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_binomial_coef

(PECL stats >= 1.0.0)

stats_stat_binomial_coef — No documentada

Descripción

stats_stat_binomial_coef ( int $x , int $n ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

x

n

Valores devueltos


No documentada

  • « stats_stat_binomial_coef
  • stats_stat_factorial »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_correlation

(PECL stats >= 1.0.0)

stats_stat_correlation — No documentada

Descripción

stats_stat_correlation ( array $arr1 , array $arr2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

arr1

arr2

Valores devueltos


Returns the factorial of an integer

  • « stats_stat_correlation
  • stats_stat_independent_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Returns the factorial of an integer

stats_stat_factorial

(PECL stats >= 1.0.0)

stats_stat_factorial — Returns the factorial of an integer

Descripción

stats_stat_factorial ( int $n ) : float

Returns the factorial of an integer, n.

Parámetros

n

An integer

Valores devueltos

The factorial of n.


No documentada

  • « stats_stat_factorial
  • stats_stat_innerproduct »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_independent_t

(PECL stats >= 1.0.0)

stats_stat_independent_t — No documentada

Descripción

stats_stat_independent_t ( array $arr1 , array $arr2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

arr1

arr2

Valores devueltos


Descripción

  • « stats_stat_independent_t
  • stats_stat_paired_t »
  • PHP Manual
  • Funciones de Estadísticas
  • Descripción

stats_stat_innerproduct

(PECL stats >= 1.0.0)

stats_stat_innerproduct —

Descripción

stats_stat_innerproduct ( array $arr1 , array $arr2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

arr1

arr2

Valores devueltos


No documentada

  • « stats_stat_innerproduct
  • stats_stat_percentile »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_paired_t

(PECL stats >= 1.0.0)

stats_stat_paired_t — No documentada

Descripción

stats_stat_paired_t ( array $arr1 , array $arr2 ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

arr1

arr2

Valores devueltos


No documentada

  • « stats_stat_paired_t
  • stats_stat_powersum »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_percentile

(PECL stats >= 1.0.0)

stats_stat_percentile — No documentada

Descripción

stats_stat_percentile ( float $df , float $xnonc ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

df

xnonc

Valores devueltos


No documentada

  • « stats_stat_percentile
  • stats_variance »
  • PHP Manual
  • Funciones de Estadísticas
  • No documentada

stats_stat_powersum

(PECL stats >= 1.0.0)

stats_stat_powersum — No documentada

Descripción

stats_stat_powersum ( array $arr , float $power ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

arr

power

Valores devueltos


Devuelve la varianza de población

  • « stats_stat_powersum
  • Trader »
  • PHP Manual
  • Funciones de Estadísticas
  • Devuelve la varianza de población

stats_variance

(PECL stats >= 1.0.0)

stats_variance — Devuelve la varianza de población

Descripción

stats_variance ( array $a , bool $sample = false ) : float
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

a

sample

Valores devueltos


Análisis técnico para comerciantes

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Funciones de Trader
    • trader_acos — Arcocoseno trigonométrico de vectores
    • trader_ad — Línea A/D Chaikin
    • trader_add — Suma aritmética de vectores
    • trader_adosc — Oscilador A/D Chaikin
    • trader_adx — Índice de movimiento direccional medio
    • trader_adxr — Tasación del índice de movimiento direccional medio
    • trader_apo — Oscilador de precio absoluto
    • trader_aroon — Aroon
    • trader_aroonosc — Oscilador Aroon
    • trader_asin — Arcoseno trigonométrico de vectores
    • trader_atan — Arcotangente trigonométrica de vectores
    • trader_atr — Rango verdadero medio
    • trader_avgprice — Precio medio
    • trader_bbands — Bandas de Bollinger
    • trader_beta — Beta
    • trader_bop — Equilibrio de poder
    • trader_cci — Índice de Canal de Comodidad
    • trader_cdl2crows — Dos Cuervos
    • trader_cdl3blackcrows — Tres Cuervos Negros
    • trader_cdl3inside — Tres Velas Interiores Alcistas/Bajistas
    • trader_cdl3linestrike — Triple Golpe
    • trader_cdl3outside — Tres Velas Exteriores Alcistas/Bajistas
    • trader_cdl3starsinsouth — Tres Estrellas en el Sur
    • trader_cdl3whitesoldiers — Tres Soldados Blancos Avanzando
    • trader_cdlabandonedbaby — Bebé Abandonado
    • trader_cdladvanceblock — Avance en Bloque
    • trader_cdlbelthold — Belt-hold
    • trader_cdlbreakaway — Escape
    • trader_cdlclosingmarubozu — Vela Cerrada Marubozu
    • trader_cdlconcealbabyswall — Pequeña Golondrina Escondida
    • trader_cdlcounterattack — Contraataque
    • trader_cdldarkcloudcover — Cubierta de Nube Oscura
    • trader_cdldoji — Doji
    • trader_cdldojistar — Estrella Doji
    • trader_cdldragonflydoji — Doji Libélula
    • trader_cdlengulfing — Patrón envolvente
    • trader_cdleveningdojistar — Estrella Vespertina Doji
    • trader_cdleveningstar — Estrella de Atardecer
    • trader_cdlgapsidesidewhite — Velas blancas paralelas de hueco alcista/bajista
    • trader_cdlgravestonedoji — Doji Lápida
    • trader_cdlhammer — Martillo
    • trader_cdlhangingman — Hombre Colgado
    • trader_cdlharami — Patrón Harami
    • trader_cdlharamicross — Patrón Cruz Harami
    • trader_cdlhighwave — Vela de Onda Alta
    • trader_cdlhikkake — Patrón Hikkake
    • trader_cdlhikkakemod — Patrón Hikkake Modificado
    • trader_cdlhomingpigeon — Paloma Mensajera
    • trader_cdlidentical3crows — Tres Cuervos Idénticos
    • trader_cdlinneck — Patrón Formación en el cuello
    • trader_cdlinvertedhammer — Martilllo Invertido
    • trader_cdlkicking — Patada
    • trader_cdlkickingbylength — Patada - alza/baja determinada por el marubozu más largo
    • trader_cdlladderbottom — Suelo de escalera
    • trader_cdllongleggeddoji — Doji Zancudo
    • trader_cdllongline — Vela de Línea Larga
    • trader_cdlmarubozu — Marubozu
    • trader_cdlmatchinglow — Mínimos coincidentes
    • trader_cdlmathold — Mat Hold
    • trader_cdlmorningdojistar — Lucero del Alba Doji
    • trader_cdlmorningstar — Lucero del Alba
    • trader_cdlonneck — Patrón Sobre el cuello
    • trader_cdlpiercing — Patrón penetrante
    • trader_cdlrickshawman — Calesero
    • trader_cdlrisefall3methods — Triple Formación Alcista/Bajista
    • trader_cdlseparatinglines — Lineas Separadas
    • trader_cdlshootingstar — Estrella Fugaz
    • trader_cdlshortline — Vela de Línea Corta
    • trader_cdlspinningtop — Peonza
    • trader_cdlstalledpattern — Patrón Añejo
    • trader_cdlsticksandwich — Bocadillo
    • trader_cdltakuri — Takuri (Libélula Doji con sombra muy larga)
    • trader_cdltasukigap — Hueco Tasuki
    • trader_cdlthrusting — Patrón de empuje
    • trader_cdltristar — Patrón de tres estrellas
    • trader_cdlunique3river — Tres ríos únicos
    • trader_cdlupsidegap2crows — Dos Cuervos tras un Huevo al Alza
    • trader_cdlxsidegap3methods — Métodos de Tres Huevos al Alza/Baja
    • trader_ceil — Redondeo hacia arriba de vectores
    • trader_cmo — Oscilador de momento de Chande
    • trader_correl — Coeficiente de correlación de Pearson (r)
    • trader_cos — Coseno trigonométrico de vectores
    • trader_cosh — Coseno hiperbólico de un vector
    • trader_dema — Media móvil exponencial doble
    • trader_div — División aritmética de vectores
    • trader_dx — Índice de movimiento direccional
    • trader_ema — Media móvil exponencial
    • trader_errno — Obtener el código de error
    • trader_exp — Exponencial aritmética de vectores
    • trader_floor — Redondeo hacia abajo de vectores
    • trader_get_compat — Obtiene el modo de compatibilidad
    • trader_get_unstable_period — Obtiene el periodo inestable
    • trader_ht_dcperiod — Transformación de Hilbert - Período de ciclo dominante
    • trader_ht_dcphase — Transformación de Hilbert - Fase de ciclo dominante
    • trader_ht_phasor — Transformación de Hilbert - Componentes de un fasor
    • trader_ht_sine — Transformación de Hilbert - Sinusoide
    • trader_ht_trendline — Transformación de Hilbert - Línea de tendencia instantánea
    • trader_ht_trendmode — Transformación de Hilbert - Tendencia vs Modo de ciclo
    • trader_kama — Media móvil adaptativa de Kaufman
    • trader_linearreg_angle — Ángulo de regresión lineal
    • trader_linearreg_intercept — Intercepción de regresión lineal
    • trader_linearreg_slope — Pendiente de regresión lineal
    • trader_linearreg — Regresión lineal
    • trader_ln — Logaritmo natural de vectores
    • trader_log10 — Logaritmo en base 10 de vectores
    • trader_ma — Media móvil
    • trader_macd — Convergencia/divergencia de la media móvil
    • trader_macdext — MACD con tipo MA controlable
    • trader_macdfix — Convergencia/divergencia fija 12/26 de la media móvil
    • trader_mama — Media móvil adaptativa MESA
    • trader_mavp — Media móvil con periodo variable
    • trader_max — Valor mayor sobre un periodo especificado
    • trader_maxindex — Índice del valor mayor sobre un periodo especificado
    • trader_medprice — Precio medio
    • trader_mfi — Índice de flujo de dinero
    • trader_midpoint — Punto medio sobre un periodo
    • trader_midprice — Precio de punto medio sobre un periodo
    • trader_min — Valor más bajo sobre un periodo especificado
    • trader_minindex — Índice del valor más bajo sobre un periodo especificado
    • trader_minmax — Valores más altos y bajos sobre un periodo especificado
    • trader_minmaxindex — Índices de los valores más bajos y altos sobre un periodo especificado
    • trader_minus_di — Indicador direccional menos
    • trader_minus_dm — Movimiento direccional menos
    • trader_mom — Momentum
    • trader_mult — Multiplicación aritmética de vectores
    • trader_natr — Rango verdadero de la media normalizada
    • trader_obv — Volumen sobre balance
    • trader_plus_di — Indicador direccional más
    • trader_plus_dm — Movimiento direccional más
    • trader_ppo — Oscilador de precio porcentual
    • trader_roc — Ritmo de cambio : ((precio/precioAnterior)-1)*100
    • trader_rocp — Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior
    • trader_rocr100 — Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100
    • trader_rocr — Ratio del ritmo de cambio: (precio/precioAnterior)
    • trader_rsi — Índice de fuerza relativa
    • trader_sar — Sistema parabólico
    • trader_sarext — Sistema parabólico - Extendido
    • trader_set_compat — Establece el modo de compatibilidad
    • trader_set_unstable_period — Establece el periodo inestable
    • trader_sin — Seno trigonométrico de vectores
    • trader_sinh — Seno hiperbólico de vectores
    • trader_sma — Media móvil simple
    • trader_sqrt — Raíz cuadrada de vectores
    • trader_stddev — Desviación estándar
    • trader_stoch — Estocástico
    • trader_stochf — Estocástico rápido
    • trader_stochrsi — Índice de fuerza relativa estocástica
    • trader_sub — Sustracción artimética de vectores
    • trader_sum — Sumatorio
    • trader_t3 — Media móvil exponencial triple (T3)
    • trader_tan — Tangente trigonométrica de vectores
    • trader_tanh — Tangente hiperbólica trigonométrica de vectores
    • trader_tema — Media móvil exponencial triple
    • trader_trange — Rango verdadero
    • trader_trima — Media móvil triangular
    • trader_trix — Ritmo de cambio de 1 día (RDC) de una MME suave triple
    • trader_tsf — Previsión de series de tiempo
    • trader_typprice — Precio típico
    • trader_ultosc — Oscilador final
    • trader_var — Varianza
    • trader_wclprice — Precio de cierre ponderado
    • trader_willr — %R de Williams
    • trader_wma — Media móvil ponderada


Introducción

La extensión trader es una biblioteca de código abierto gratuita basada en TA-Lib. Está dedicada a los desarrolladores de software de actividad comercial que requieren realizar análisis técnicos de datos de mercado financiero. Al lado de muchos indicadores como ADX, MACD, RSI, Estocástico, TRIX, están presentes el reconocimiento de patrones de velas y varias funciones de vectores aritméticas y algebraicas.

Los cálculos se pueden realizar en dos modos: TA-Lib y Metastock. Cambiándolo usando trader_set_compat() afectará la manera en que funcionan algunas funciones de trader.

Algunas funciones de trader proporcionan diferentes resultados dependiendo del "punto de inicio" de los datos involucrados. Esto se refiere a menudo como que una función posee memoria. Un ejemplo de tales funciones es la Media móvil exponencial. Es posible controlar el perido inestable (la cantidad de datos a quitar) usando la función trader_set_unstable_period().

Se puede encontrar documentación ampliada sobre indicadores, fórmulas e implementaciones en otros lenguajes de programación en » tadoc.org.


Requerimientos

La extensión Trader está basada en » TA-Lib. TA-Lib está integrada completamente en la extensión, por lo que no es necesaria ninguna biblioteca externa.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/trader.

Hay diponible una DLL para esta extensión de PECL en » http://windows.php.net/downloads/pecl/releases/trader/.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Trader Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
trader.real_precision | 3 | PHP_INI_ALL | Desde trader 0.2.1
trader.real_round_mode | HALF_DOWN | PHP_INI_ALL | Desde trader 0.3.0

He aquí una breve explicación de las directivas de configuración.

trader.real_precision integer

Todos los valores de los arrays devueltos serán redondeados a esta precisión. Sin enbargo, los cálculos dentro de TA-Lib se realizarán con valores no redondeados.

trader.real_round_mode string

Controla la política de redondeo de números reales de trader. Los valores válidos son HALF_UP, HALF_DOWN, HALF_EVEN y HALF_ODD. El comportamiento es idéntico al de la función round() usada con el argumento de modo.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

TRADER_MA_TYPE_SMA (integer)
TRADER_MA_TYPE_EMA (integer)
TRADER_MA_TYPE_WMA (integer)
TRADER_MA_TYPE_DEMA (integer)
TRADER_MA_TYPE_TEMA (integer)
TRADER_MA_TYPE_TRIMA (integer)
TRADER_MA_TYPE_KAMA (integer)
TRADER_MA_TYPE_MAMA (integer)
TRADER_MA_TYPE_T3 (integer)
TRADER_REAL_MIN (float)
TRADER_REAL_MAX (float)
TRADER_FUNC_UNST_ADX (integer)
TRADER_FUNC_UNST_ADXR (integer)
TRADER_FUNC_UNST_ATR (integer)
TRADER_FUNC_UNST_CMO (integer)
TRADER_FUNC_UNST_DX (integer)
TRADER_FUNC_UNST_EMA (integer)
TRADER_FUNC_UNST_HT_DCPERIOD (integer)
TRADER_FUNC_UNST_HT_DCPHASE (integer)
TRADER_FUNC_UNST_HT_PHASOR (integer)
TRADER_FUNC_UNST_HT_SINE (integer)
TRADER_FUNC_UNST_HT_TRENDLINE (integer)
TRADER_FUNC_UNST_HT_TRENDMODE (integer)
TRADER_FUNC_UNST_KAMA (integer)
TRADER_FUNC_UNST_MAMA (integer)
TRADER_FUNC_UNST_MFI (integer)
TRADER_FUNC_UNST_MINUS_DI (integer)
TRADER_FUNC_UNST_MINUS_DM (integer)
TRADER_FUNC_UNST_NATR (integer)
TRADER_FUNC_UNST_PLUS_DI (integer)
TRADER_FUNC_UNST_PLUS_DM (integer)
TRADER_FUNC_UNST_RSI (integer)
TRADER_FUNC_UNST_STOCHRSI (integer)
TRADER_FUNC_UNST_T3 (integer)
TRADER_FUNC_UNST_ALL (integer)
TRADER_FUNC_UNST_NONE (integer)
TRADER_COMPATIBILITY_DEFAULT (integer)
TRADER_COMPATIBILITY_METASTOCK (integer)
TRADER_ERR_SUCCESS (integer)
TRADER_ERR_LIB_NOT_INITIALIZE (integer)
TRADER_ERR_BAD_PARAM (integer)
TRADER_ERR_ALLOC_ERR (integer)
TRADER_ERR_GROUP_NOT_FOUND (integer)
TRADER_ERR_FUNC_NOT_FOUND (integer)
TRADER_ERR_INVALID_HANDLE (integer)
TRADER_ERR_INVALID_PARAM_HOLDER (integer)
TRADER_ERR_INVALID_PARAM_HOLDER_TYPE (integer)
TRADER_ERR_INVALID_PARAM_FUNCTION (integer)
TRADER_ERR_INPUT_NOT_ALL_INITIALIZE (integer)
TRADER_ERR_OUTPUT_NOT_ALL_INITIALIZE (integer)
TRADER_ERR_OUT_OF_RANGE_START_INDEX (integer)
TRADER_ERR_OUT_OF_RANGE_END_INDEX (integer)
TRADER_ERR_INVALID_LIST_TYPE (integer)
TRADER_ERR_BAD_OBJECT (integer)
TRADER_ERR_NOT_SUPPORTED (integer)
TRADER_ERR_INTERNAL_ERROR (integer)
TRADER_ERR_UNKNOWN_ERROR (integer)


Funciones de Trader

Tabla de contenidos

  • trader_acos — Arcocoseno trigonométrico de vectores
  • trader_ad — Línea A/D Chaikin
  • trader_add — Suma aritmética de vectores
  • trader_adosc — Oscilador A/D Chaikin
  • trader_adx — Índice de movimiento direccional medio
  • trader_adxr — Tasación del índice de movimiento direccional medio
  • trader_apo — Oscilador de precio absoluto
  • trader_aroon — Aroon
  • trader_aroonosc — Oscilador Aroon
  • trader_asin — Arcoseno trigonométrico de vectores
  • trader_atan — Arcotangente trigonométrica de vectores
  • trader_atr — Rango verdadero medio
  • trader_avgprice — Precio medio
  • trader_bbands — Bandas de Bollinger
  • trader_beta — Beta
  • trader_bop — Equilibrio de poder
  • trader_cci — Índice de Canal de Comodidad
  • trader_cdl2crows — Dos Cuervos
  • trader_cdl3blackcrows — Tres Cuervos Negros
  • trader_cdl3inside — Tres Velas Interiores Alcistas/Bajistas
  • trader_cdl3linestrike — Triple Golpe
  • trader_cdl3outside — Tres Velas Exteriores Alcistas/Bajistas
  • trader_cdl3starsinsouth — Tres Estrellas en el Sur
  • trader_cdl3whitesoldiers — Tres Soldados Blancos Avanzando
  • trader_cdlabandonedbaby — Bebé Abandonado
  • trader_cdladvanceblock — Avance en Bloque
  • trader_cdlbelthold — Belt-hold
  • trader_cdlbreakaway — Escape
  • trader_cdlclosingmarubozu — Vela Cerrada Marubozu
  • trader_cdlconcealbabyswall — Pequeña Golondrina Escondida
  • trader_cdlcounterattack — Contraataque
  • trader_cdldarkcloudcover — Cubierta de Nube Oscura
  • trader_cdldoji — Doji
  • trader_cdldojistar — Estrella Doji
  • trader_cdldragonflydoji — Doji Libélula
  • trader_cdlengulfing — Patrón envolvente
  • trader_cdleveningdojistar — Estrella Vespertina Doji
  • trader_cdleveningstar — Estrella de Atardecer
  • trader_cdlgapsidesidewhite — Velas blancas paralelas de hueco alcista/bajista
  • trader_cdlgravestonedoji — Doji Lápida
  • trader_cdlhammer — Martillo
  • trader_cdlhangingman — Hombre Colgado
  • trader_cdlharami — Patrón Harami
  • trader_cdlharamicross — Patrón Cruz Harami
  • trader_cdlhighwave — Vela de Onda Alta
  • trader_cdlhikkake — Patrón Hikkake
  • trader_cdlhikkakemod — Patrón Hikkake Modificado
  • trader_cdlhomingpigeon — Paloma Mensajera
  • trader_cdlidentical3crows — Tres Cuervos Idénticos
  • trader_cdlinneck — Patrón Formación en el cuello
  • trader_cdlinvertedhammer — Martilllo Invertido
  • trader_cdlkicking — Patada
  • trader_cdlkickingbylength — Patada - alza/baja determinada por el marubozu más largo
  • trader_cdlladderbottom — Suelo de escalera
  • trader_cdllongleggeddoji — Doji Zancudo
  • trader_cdllongline — Vela de Línea Larga
  • trader_cdlmarubozu — Marubozu
  • trader_cdlmatchinglow — Mínimos coincidentes
  • trader_cdlmathold — Mat Hold
  • trader_cdlmorningdojistar — Lucero del Alba Doji
  • trader_cdlmorningstar — Lucero del Alba
  • trader_cdlonneck — Patrón Sobre el cuello
  • trader_cdlpiercing — Patrón penetrante
  • trader_cdlrickshawman — Calesero
  • trader_cdlrisefall3methods — Triple Formación Alcista/Bajista
  • trader_cdlseparatinglines — Lineas Separadas
  • trader_cdlshootingstar — Estrella Fugaz
  • trader_cdlshortline — Vela de Línea Corta
  • trader_cdlspinningtop — Peonza
  • trader_cdlstalledpattern — Patrón Añejo
  • trader_cdlsticksandwich — Bocadillo
  • trader_cdltakuri — Takuri (Libélula Doji con sombra muy larga)
  • trader_cdltasukigap — Hueco Tasuki
  • trader_cdlthrusting — Patrón de empuje
  • trader_cdltristar — Patrón de tres estrellas
  • trader_cdlunique3river — Tres ríos únicos
  • trader_cdlupsidegap2crows — Dos Cuervos tras un Huevo al Alza
  • trader_cdlxsidegap3methods — Métodos de Tres Huevos al Alza/Baja
  • trader_ceil — Redondeo hacia arriba de vectores
  • trader_cmo — Oscilador de momento de Chande
  • trader_correl — Coeficiente de correlación de Pearson (r)
  • trader_cos — Coseno trigonométrico de vectores
  • trader_cosh — Coseno hiperbólico de un vector
  • trader_dema — Media móvil exponencial doble
  • trader_div — División aritmética de vectores
  • trader_dx — Índice de movimiento direccional
  • trader_ema — Media móvil exponencial
  • trader_errno — Obtener el código de error
  • trader_exp — Exponencial aritmética de vectores
  • trader_floor — Redondeo hacia abajo de vectores
  • trader_get_compat — Obtiene el modo de compatibilidad
  • trader_get_unstable_period — Obtiene el periodo inestable
  • trader_ht_dcperiod — Transformación de Hilbert - Período de ciclo dominante
  • trader_ht_dcphase — Transformación de Hilbert - Fase de ciclo dominante
  • trader_ht_phasor — Transformación de Hilbert - Componentes de un fasor
  • trader_ht_sine — Transformación de Hilbert - Sinusoide
  • trader_ht_trendline — Transformación de Hilbert - Línea de tendencia instantánea
  • trader_ht_trendmode — Transformación de Hilbert - Tendencia vs Modo de ciclo
  • trader_kama — Media móvil adaptativa de Kaufman
  • trader_linearreg_angle — Ángulo de regresión lineal
  • trader_linearreg_intercept — Intercepción de regresión lineal
  • trader_linearreg_slope — Pendiente de regresión lineal
  • trader_linearreg — Regresión lineal
  • trader_ln — Logaritmo natural de vectores
  • trader_log10 — Logaritmo en base 10 de vectores
  • trader_ma — Media móvil
  • trader_macd — Convergencia/divergencia de la media móvil
  • trader_macdext — MACD con tipo MA controlable
  • trader_macdfix — Convergencia/divergencia fija 12/26 de la media móvil
  • trader_mama — Media móvil adaptativa MESA
  • trader_mavp — Media móvil con periodo variable
  • trader_max — Valor mayor sobre un periodo especificado
  • trader_maxindex — Índice del valor mayor sobre un periodo especificado
  • trader_medprice — Precio medio
  • trader_mfi — Índice de flujo de dinero
  • trader_midpoint — Punto medio sobre un periodo
  • trader_midprice — Precio de punto medio sobre un periodo
  • trader_min — Valor más bajo sobre un periodo especificado
  • trader_minindex — Índice del valor más bajo sobre un periodo especificado
  • trader_minmax — Valores más altos y bajos sobre un periodo especificado
  • trader_minmaxindex — Índices de los valores más bajos y altos sobre un periodo especificado
  • trader_minus_di — Indicador direccional menos
  • trader_minus_dm — Movimiento direccional menos
  • trader_mom — Momentum
  • trader_mult — Multiplicación aritmética de vectores
  • trader_natr — Rango verdadero de la media normalizada
  • trader_obv — Volumen sobre balance
  • trader_plus_di — Indicador direccional más
  • trader_plus_dm — Movimiento direccional más
  • trader_ppo — Oscilador de precio porcentual
  • trader_roc — Ritmo de cambio : ((precio/precioAnterior)-1)*100
  • trader_rocp — Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior
  • trader_rocr100 — Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100
  • trader_rocr — Ratio del ritmo de cambio: (precio/precioAnterior)
  • trader_rsi — Índice de fuerza relativa
  • trader_sar — Sistema parabólico
  • trader_sarext — Sistema parabólico - Extendido
  • trader_set_compat — Establece el modo de compatibilidad
  • trader_set_unstable_period — Establece el periodo inestable
  • trader_sin — Seno trigonométrico de vectores
  • trader_sinh — Seno hiperbólico de vectores
  • trader_sma — Media móvil simple
  • trader_sqrt — Raíz cuadrada de vectores
  • trader_stddev — Desviación estándar
  • trader_stoch — Estocástico
  • trader_stochf — Estocástico rápido
  • trader_stochrsi — Índice de fuerza relativa estocástica
  • trader_sub — Sustracción artimética de vectores
  • trader_sum — Sumatorio
  • trader_t3 — Media móvil exponencial triple (T3)
  • trader_tan — Tangente trigonométrica de vectores
  • trader_tanh — Tangente hiperbólica trigonométrica de vectores
  • trader_tema — Media móvil exponencial triple
  • trader_trange — Rango verdadero
  • trader_trima — Media móvil triangular
  • trader_trix — Ritmo de cambio de 1 día (RDC) de una MME suave triple
  • trader_tsf — Previsión de series de tiempo
  • trader_typprice — Precio típico
  • trader_ultosc — Oscilador final
  • trader_var — Varianza
  • trader_wclprice — Precio de cierre ponderado
  • trader_willr — %R de Williams
  • trader_wma — Media móvil ponderada


Arcocoseno trigonométrico de vectores

  • « Funciones de Trader
  • trader_ad »
  • PHP Manual
  • Funciones de Trader
  • Arcocoseno trigonométrico de vectores

trader_acos

(PECL trader >= 0.2.0)

trader_acos — Arcocoseno trigonométrico de vectores

Descripción

trader_acos ( array $real ) : array

Calcula el arcocoseno para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Línea A/D Chaikin

  • « trader_acos
  • trader_add »
  • PHP Manual
  • Funciones de Trader
  • Línea A/D Chaikin

trader_ad

(PECL trader >= 0.2.0)

trader_ad — Línea A/D Chaikin

Descripción

trader_ad ( array $high , array $low , array $close , array $volume ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

volume

Volumen comerciado, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Suma aritmética de vectores

  • « trader_ad
  • trader_adosc »
  • PHP Manual
  • Funciones de Trader
  • Suma aritmética de vectores

trader_add

(PECL trader >= 0.2.0)

trader_add — Suma aritmética de vectores

Descripción

trader_add ( array $real0 , array $real1 ) : array

Calcula la suma de vectores de real0 a real1 y devuelve el vector resultante.

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Oscilador A/D Chaikin

  • « trader_add
  • trader_adx »
  • PHP Manual
  • Funciones de Trader
  • Oscilador A/D Chaikin

trader_adosc

(PECL trader >= 0.2.0)

trader_adosc — Oscilador A/D Chaikin

Descripción

trader_adosc ( array $high , array $low , array $close , array $volume , int $fastPeriod = ? , int $slowPeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

volume

Volumen comerciado, array de valores reales.

fastPeriod

Número del periodo para el MA rápido. Rango válido desde 2 hasta 100000.

slowPeriod

Número del periodo para el MA lento. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Índice de movimiento direccional medio

  • « trader_adosc
  • trader_adxr »
  • PHP Manual
  • Funciones de Trader
  • Índice de movimiento direccional medio

trader_adx

(PECL trader >= 0.2.0)

trader_adx — Índice de movimiento direccional medio

Descripción

trader_adx ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tasación del índice de movimiento direccional medio

  • « trader_adx
  • trader_apo »
  • PHP Manual
  • Funciones de Trader
  • Tasación del índice de movimiento direccional medio

trader_adxr

(PECL trader >= 0.2.0)

trader_adxr — Tasación del índice de movimiento direccional medio

Descripción

trader_adxr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Oscilador de precio absoluto

  • « trader_adxr
  • trader_aroon »
  • PHP Manual
  • Funciones de Trader
  • Oscilador de precio absoluto

trader_apo

(PECL trader >= 0.2.0)

trader_apo — Oscilador de precio absoluto

Descripción

trader_apo ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $mAType = ? ) : array

Parámetros

real

Array de valores reales.

fastPeriod

Número del periodo para el MA rápido. Rango válido desde 2 hasta 100000.

slowPeriod

Número del periodo para el MA lento. Rango válido desde 2 hasta 100000.

mAType

Tipo de media móvil. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Aroon

  • « trader_apo
  • trader_aroonosc »
  • PHP Manual
  • Funciones de Trader
  • Aroon

trader_aroon

(PECL trader >= 0.2.0)

trader_aroon — Aroon

Descripción

trader_aroon ( array $high , array $low , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Oscilador Aroon

  • « trader_aroon
  • trader_asin »
  • PHP Manual
  • Funciones de Trader
  • Oscilador Aroon

trader_aroonosc

(PECL trader >= 0.2.0)

trader_aroonosc — Oscilador Aroon

Descripción

trader_aroonosc ( array $high , array $low , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Arcoseno trigonométrico de vectores

  • « trader_aroonosc
  • trader_atan »
  • PHP Manual
  • Funciones de Trader
  • Arcoseno trigonométrico de vectores

trader_asin

(PECL trader >= 0.2.0)

trader_asin — Arcoseno trigonométrico de vectores

Descripción

trader_asin ( array $real ) : array

Calcula el seno para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Arcotangente trigonométrica de vectores

  • « trader_asin
  • trader_atr »
  • PHP Manual
  • Funciones de Trader
  • Arcotangente trigonométrica de vectores

trader_atan

(PECL trader >= 0.2.0)

trader_atan — Arcotangente trigonométrica de vectores

Descripción

trader_atan ( array $real ) : array

Calcula la arcotangente para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Rango verdadero medio

  • « trader_atan
  • trader_avgprice »
  • PHP Manual
  • Funciones de Trader
  • Rango verdadero medio

trader_atr

(PECL trader >= 0.2.0)

trader_atr — Rango verdadero medio

Descripción

trader_atr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Precio medio

  • « trader_atr
  • trader_bbands »
  • PHP Manual
  • Funciones de Trader
  • Precio medio

trader_avgprice

(PECL trader >= 0.2.0)

trader_avgprice — Precio medio

Descripción

trader_avgprice ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Bandas de Bollinger

  • « trader_avgprice
  • trader_beta »
  • PHP Manual
  • Funciones de Trader
  • Bandas de Bollinger

trader_bbands

(PECL trader >= 0.2.0)

trader_bbands — Bandas de Bollinger

Descripción

trader_bbands ( array $real , int $timePeriod = ? , float $nbDevUp = ? , float $nbDevDn = ? , int $mAType = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

nbDevUp

Desviación multiplicadora para la banda superior. Rango válido desde TRADER_REAL_MIN hasta TRADER_REAL_MAX.

nbDevDn

Desviación multiplicadora para la banda inferior. Rango válido desde TRADER_REAL_MIN hasta TRADER_REAL_MAX.

mAType

Tipo de media móvil. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Beta

  • « trader_bbands
  • trader_bop »
  • PHP Manual
  • Funciones de Trader
  • Beta

trader_beta

(PECL trader >= 0.2.0)

trader_beta — Beta

Descripción

trader_beta ( array $real0 , array $real1 , int $timePeriod = ? ) : array

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Equilibrio de poder

  • « trader_beta
  • trader_cci »
  • PHP Manual
  • Funciones de Trader
  • Equilibrio de poder

trader_bop

(PECL trader >= 0.2.0)

trader_bop — Equilibrio de poder

Descripción

trader_bop ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Índice de Canal de Comodidad

  • « trader_bop
  • trader_cdl2crows »
  • PHP Manual
  • Funciones de Trader
  • Índice de Canal de Comodidad

trader_cci

(PECL trader >= 0.2.0)

trader_cci — Índice de Canal de Comodidad

Descripción

trader_cci ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Dos Cuervos

  • « trader_cci
  • trader_cdl3blackcrows »
  • PHP Manual
  • Funciones de Trader
  • Dos Cuervos

trader_cdl2crows

(PECL trader >= 0.2.0)

trader_cdl2crows — Dos Cuervos

Descripción

trader_cdl2crows ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Cuervos Negros

  • « trader_cdl2crows
  • trader_cdl3inside »
  • PHP Manual
  • Funciones de Trader
  • Tres Cuervos Negros

trader_cdl3blackcrows

(PECL trader >= 0.2.0)

trader_cdl3blackcrows — Tres Cuervos Negros

Descripción

trader_cdl3blackcrows ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Velas Interiores Alcistas/Bajistas

  • « trader_cdl3blackcrows
  • trader_cdl3linestrike »
  • PHP Manual
  • Funciones de Trader
  • Tres Velas Interiores Alcistas/Bajistas

trader_cdl3inside

(PECL trader >= 0.2.0)

trader_cdl3inside — Tres Velas Interiores Alcistas/Bajistas

Descripción

trader_cdl3inside ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Triple Golpe

  • « trader_cdl3inside
  • trader_cdl3outside »
  • PHP Manual
  • Funciones de Trader
  • Triple Golpe

trader_cdl3linestrike

(PECL trader >= 0.2.0)

trader_cdl3linestrike — Triple Golpe

Descripción

trader_cdl3linestrike ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Velas Exteriores Alcistas/Bajistas

  • « trader_cdl3linestrike
  • trader_cdl3starsinsouth »
  • PHP Manual
  • Funciones de Trader
  • Tres Velas Exteriores Alcistas/Bajistas

trader_cdl3outside

(PECL trader >= 0.2.0)

trader_cdl3outside — Tres Velas Exteriores Alcistas/Bajistas

Descripción

trader_cdl3outside ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Estrellas en el Sur

  • « trader_cdl3outside
  • trader_cdl3whitesoldiers »
  • PHP Manual
  • Funciones de Trader
  • Tres Estrellas en el Sur

trader_cdl3starsinsouth

(PECL trader >= 0.2.0)

trader_cdl3starsinsouth — Tres Estrellas en el Sur

Descripción

trader_cdl3starsinsouth ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Soldados Blancos Avanzando

  • « trader_cdl3starsinsouth
  • trader_cdlabandonedbaby »
  • PHP Manual
  • Funciones de Trader
  • Tres Soldados Blancos Avanzando

trader_cdl3whitesoldiers

(PECL trader >= 0.2.0)

trader_cdl3whitesoldiers — Tres Soldados Blancos Avanzando

Descripción

trader_cdl3whitesoldiers ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Bebé Abandonado

  • « trader_cdl3whitesoldiers
  • trader_cdladvanceblock »
  • PHP Manual
  • Funciones de Trader
  • Bebé Abandonado

trader_cdlabandonedbaby

(PECL trader >= 0.2.0)

trader_cdlabandonedbaby — Bebé Abandonado

Descripción

trader_cdlabandonedbaby ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Avance en Bloque

  • « trader_cdlabandonedbaby
  • trader_cdlbelthold »
  • PHP Manual
  • Funciones de Trader
  • Avance en Bloque

trader_cdladvanceblock

(PECL trader >= 0.2.0)

trader_cdladvanceblock — Avance en Bloque

Descripción

trader_cdladvanceblock ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Belt-hold

  • « trader_cdladvanceblock
  • trader_cdlbreakaway »
  • PHP Manual
  • Funciones de Trader
  • Belt-hold

trader_cdlbelthold

(PECL trader >= 0.2.0)

trader_cdlbelthold — Belt-hold

Descripción

trader_cdlbelthold ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Escape

  • « trader_cdlbelthold
  • trader_cdlclosingmarubozu »
  • PHP Manual
  • Funciones de Trader
  • Escape

trader_cdlbreakaway

(PECL trader >= 0.2.0)

trader_cdlbreakaway — Escape

Descripción

trader_cdlbreakaway ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Vela Cerrada Marubozu

  • « trader_cdlbreakaway
  • trader_cdlconcealbabyswall »
  • PHP Manual
  • Funciones de Trader
  • Vela Cerrada Marubozu

trader_cdlclosingmarubozu

(PECL trader >= 0.2.0)

trader_cdlclosingmarubozu — Vela Cerrada Marubozu

Descripción

trader_cdlclosingmarubozu ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Pequeña Golondrina Escondida

  • « trader_cdlclosingmarubozu
  • trader_cdlcounterattack »
  • PHP Manual
  • Funciones de Trader
  • Pequeña Golondrina Escondida

trader_cdlconcealbabyswall

(PECL trader >= 0.2.0)

trader_cdlconcealbabyswall — Pequeña Golondrina Escondida

Descripción

trader_cdlconcealbabyswall ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Contraataque

  • « trader_cdlconcealbabyswall
  • trader_cdldarkcloudcover »
  • PHP Manual
  • Funciones de Trader
  • Contraataque

trader_cdlcounterattack

(PECL trader >= 0.2.0)

trader_cdlcounterattack — Contraataque

Descripción

trader_cdlcounterattack ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Cubierta de Nube Oscura

  • « trader_cdlcounterattack
  • trader_cdldoji »
  • PHP Manual
  • Funciones de Trader
  • Cubierta de Nube Oscura

trader_cdldarkcloudcover

(PECL trader >= 0.2.0)

trader_cdldarkcloudcover — Cubierta de Nube Oscura

Descripción

trader_cdldarkcloudcover ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Doji

  • « trader_cdldarkcloudcover
  • trader_cdldojistar »
  • PHP Manual
  • Funciones de Trader
  • Doji

trader_cdldoji

(PECL trader >= 0.2.0)

trader_cdldoji — Doji

Descripción

trader_cdldoji ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Estrella Doji

  • « trader_cdldoji
  • trader_cdldragonflydoji »
  • PHP Manual
  • Funciones de Trader
  • Estrella Doji

trader_cdldojistar

(PECL trader >= 0.2.0)

trader_cdldojistar — Estrella Doji

Descripción

trader_cdldojistar ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Doji Libélula

  • « trader_cdldojistar
  • trader_cdlengulfing »
  • PHP Manual
  • Funciones de Trader
  • Doji Libélula

trader_cdldragonflydoji

(PECL trader >= 0.2.0)

trader_cdldragonflydoji — Doji Libélula

Descripción

trader_cdldragonflydoji ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón envolvente

  • « trader_cdldragonflydoji
  • trader_cdleveningdojistar »
  • PHP Manual
  • Funciones de Trader
  • Patrón envolvente

trader_cdlengulfing

(PECL trader >= 0.2.0)

trader_cdlengulfing — Patrón envolvente

Descripción

trader_cdlengulfing ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Estrella Vespertina Doji

  • « trader_cdlengulfing
  • trader_cdleveningstar »
  • PHP Manual
  • Funciones de Trader
  • Estrella Vespertina Doji

trader_cdleveningdojistar

(PECL trader >= 0.2.0)

trader_cdleveningdojistar — Estrella Vespertina Doji

Descripción

trader_cdleveningdojistar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Estrella de Atardecer

  • « trader_cdleveningdojistar
  • trader_cdlgapsidesidewhite »
  • PHP Manual
  • Funciones de Trader
  • Estrella de Atardecer

trader_cdleveningstar

(PECL trader >= 0.2.0)

trader_cdleveningstar — Estrella de Atardecer

Descripción

trader_cdleveningstar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Velas blancas paralelas de hueco alcista/bajista

  • « trader_cdleveningstar
  • trader_cdlgravestonedoji »
  • PHP Manual
  • Funciones de Trader
  • Velas blancas paralelas de hueco alcista/bajista

trader_cdlgapsidesidewhite

(PECL trader >= 0.2.0)

trader_cdlgapsidesidewhite — Velas blancas paralelas de hueco alcista/bajista

Descripción

trader_cdlgapsidesidewhite ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Doji Lápida

  • « trader_cdlgapsidesidewhite
  • trader_cdlhammer »
  • PHP Manual
  • Funciones de Trader
  • Doji Lápida

trader_cdlgravestonedoji

(PECL trader >= 0.2.0)

trader_cdlgravestonedoji — Doji Lápida

Descripción

trader_cdlgravestonedoji ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Martillo

  • « trader_cdlgravestonedoji
  • trader_cdlhangingman »
  • PHP Manual
  • Funciones de Trader
  • Martillo

trader_cdlhammer

(PECL trader >= 0.2.0)

trader_cdlhammer — Martillo

Descripción

trader_cdlhammer ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Hombre Colgado

  • « trader_cdlhammer
  • trader_cdlharami »
  • PHP Manual
  • Funciones de Trader
  • Hombre Colgado

trader_cdlhangingman

(PECL trader >= 0.2.0)

trader_cdlhangingman — Hombre Colgado

Descripción

trader_cdlhangingman ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Harami

  • « trader_cdlhangingman
  • trader_cdlharamicross »
  • PHP Manual
  • Funciones de Trader
  • Patrón Harami

trader_cdlharami

(PECL trader >= 0.2.0)

trader_cdlharami — Patrón Harami

Descripción

trader_cdlharami ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Cruz Harami

  • « trader_cdlharami
  • trader_cdlhighwave »
  • PHP Manual
  • Funciones de Trader
  • Patrón Cruz Harami

trader_cdlharamicross

(PECL trader >= 0.2.0)

trader_cdlharamicross — Patrón Cruz Harami

Descripción

trader_cdlharamicross ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Vela de Onda Alta

  • « trader_cdlharamicross
  • trader_cdlhikkake »
  • PHP Manual
  • Funciones de Trader
  • Vela de Onda Alta

trader_cdlhighwave

(PECL trader >= 0.2.0)

trader_cdlhighwave — Vela de Onda Alta

Descripción

trader_cdlhighwave ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Hikkake

  • « trader_cdlhighwave
  • trader_cdlhikkakemod »
  • PHP Manual
  • Funciones de Trader
  • Patrón Hikkake

trader_cdlhikkake

(PECL trader >= 0.2.0)

trader_cdlhikkake — Patrón Hikkake

Descripción

trader_cdlhikkake ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Hikkake Modificado

  • « trader_cdlhikkake
  • trader_cdlhomingpigeon »
  • PHP Manual
  • Funciones de Trader
  • Patrón Hikkake Modificado

trader_cdlhikkakemod

(PECL trader >= 0.2.0)

trader_cdlhikkakemod — Patrón Hikkake Modificado

Descripción

trader_cdlhikkakemod ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Paloma Mensajera

  • « trader_cdlhikkakemod
  • trader_cdlidentical3crows »
  • PHP Manual
  • Funciones de Trader
  • Paloma Mensajera

trader_cdlhomingpigeon

(PECL trader >= 0.2.0)

trader_cdlhomingpigeon — Paloma Mensajera

Descripción

trader_cdlhomingpigeon ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres Cuervos Idénticos

  • « trader_cdlhomingpigeon
  • trader_cdlinneck »
  • PHP Manual
  • Funciones de Trader
  • Tres Cuervos Idénticos

trader_cdlidentical3crows

(PECL trader >= 0.2.0)

trader_cdlidentical3crows — Tres Cuervos Idénticos

Descripción

trader_cdlidentical3crows ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Formación en el cuello

  • « trader_cdlidentical3crows
  • trader_cdlinvertedhammer »
  • PHP Manual
  • Funciones de Trader
  • Patrón Formación en el cuello

trader_cdlinneck

(PECL trader >= 0.2.0)

trader_cdlinneck — Patrón Formación en el cuello

Descripción

trader_cdlinneck ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Martilllo Invertido

  • « trader_cdlinneck
  • trader_cdlkicking »
  • PHP Manual
  • Funciones de Trader
  • Martilllo Invertido

trader_cdlinvertedhammer

(PECL trader >= 0.2.0)

trader_cdlinvertedhammer — Martilllo Invertido

Descripción

trader_cdlinvertedhammer ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patada

  • « trader_cdlinvertedhammer
  • trader_cdlkickingbylength »
  • PHP Manual
  • Funciones de Trader
  • Patada

trader_cdlkicking

(PECL trader >= 0.2.0)

trader_cdlkicking — Patada

Descripción

trader_cdlkicking ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patada - alza/baja determinada por el marubozu más largo

  • « trader_cdlkicking
  • trader_cdlladderbottom »
  • PHP Manual
  • Funciones de Trader
  • Patada - alza/baja determinada por el marubozu más largo

trader_cdlkickingbylength

(PECL trader >= 0.2.0)

trader_cdlkickingbylength — Patada - alza/baja determinada por el marubozu más largo

Descripción

trader_cdlkickingbylength ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Suelo de escalera

  • « trader_cdlkickingbylength
  • trader_cdllongleggeddoji »
  • PHP Manual
  • Funciones de Trader
  • Suelo de escalera

trader_cdlladderbottom

(PECL trader >= 0.2.0)

trader_cdlladderbottom — Suelo de escalera

Descripción

trader_cdlladderbottom ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Doji Zancudo

  • « trader_cdlladderbottom
  • trader_cdllongline »
  • PHP Manual
  • Funciones de Trader
  • Doji Zancudo

trader_cdllongleggeddoji

(PECL trader >= 0.2.0)

trader_cdllongleggeddoji — Doji Zancudo

Descripción

trader_cdllongleggeddoji ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Vela de Línea Larga

  • « trader_cdllongleggeddoji
  • trader_cdlmarubozu »
  • PHP Manual
  • Funciones de Trader
  • Vela de Línea Larga

trader_cdllongline

(PECL trader >= 0.2.0)

trader_cdllongline — Vela de Línea Larga

Descripción

trader_cdllongline ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Marubozu

  • « trader_cdllongline
  • trader_cdlmatchinglow »
  • PHP Manual
  • Funciones de Trader
  • Marubozu

trader_cdlmarubozu

(PECL trader >= 0.2.0)

trader_cdlmarubozu — Marubozu

Descripción

trader_cdlmarubozu ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Mínimos coincidentes

  • « trader_cdlmarubozu
  • trader_cdlmathold »
  • PHP Manual
  • Funciones de Trader
  • Mínimos coincidentes

trader_cdlmatchinglow

(PECL trader >= 0.2.0)

trader_cdlmatchinglow — Mínimos coincidentes

Descripción

trader_cdlmatchinglow ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Mat Hold

  • « trader_cdlmatchinglow
  • trader_cdlmorningdojistar »
  • PHP Manual
  • Funciones de Trader
  • Mat Hold

trader_cdlmathold

(PECL trader >= 0.2.0)

trader_cdlmathold — Mat Hold

Descripción

trader_cdlmathold ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Lucero del Alba Doji

  • « trader_cdlmathold
  • trader_cdlmorningstar »
  • PHP Manual
  • Funciones de Trader
  • Lucero del Alba Doji

trader_cdlmorningdojistar

(PECL trader >= 0.2.0)

trader_cdlmorningdojistar — Lucero del Alba Doji

Descripción

trader_cdlmorningdojistar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Lucero del Alba

  • « trader_cdlmorningdojistar
  • trader_cdlonneck »
  • PHP Manual
  • Funciones de Trader
  • Lucero del Alba

trader_cdlmorningstar

(PECL trader >= 0.2.0)

trader_cdlmorningstar — Lucero del Alba

Descripción

trader_cdlmorningstar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

penetration

Porcentaje de penetración de una vela dentro de otra.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Sobre el cuello

  • « trader_cdlmorningstar
  • trader_cdlpiercing »
  • PHP Manual
  • Funciones de Trader
  • Patrón Sobre el cuello

trader_cdlonneck

(PECL trader >= 0.2.0)

trader_cdlonneck — Patrón Sobre el cuello

Descripción

trader_cdlonneck ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón penetrante

  • « trader_cdlonneck
  • trader_cdlrickshawman »
  • PHP Manual
  • Funciones de Trader
  • Patrón penetrante

trader_cdlpiercing

(PECL trader >= 0.2.0)

trader_cdlpiercing — Patrón penetrante

Descripción

trader_cdlpiercing ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Calesero

  • « trader_cdlpiercing
  • trader_cdlrisefall3methods »
  • PHP Manual
  • Funciones de Trader
  • Calesero

trader_cdlrickshawman

(PECL trader >= 0.2.0)

trader_cdlrickshawman — Calesero

Descripción

trader_cdlrickshawman ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Triple Formación Alcista/Bajista

  • « trader_cdlrickshawman
  • trader_cdlseparatinglines »
  • PHP Manual
  • Funciones de Trader
  • Triple Formación Alcista/Bajista

trader_cdlrisefall3methods

(PECL trader >= 0.2.0)

trader_cdlrisefall3methods — Triple Formación Alcista/Bajista

Descripción

trader_cdlrisefall3methods ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Lineas Separadas

  • « trader_cdlrisefall3methods
  • trader_cdlshootingstar »
  • PHP Manual
  • Funciones de Trader
  • Lineas Separadas

trader_cdlseparatinglines

(PECL trader >= 0.2.0)

trader_cdlseparatinglines — Lineas Separadas

Descripción

trader_cdlseparatinglines ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Estrella Fugaz

  • « trader_cdlseparatinglines
  • trader_cdlshortline »
  • PHP Manual
  • Funciones de Trader
  • Estrella Fugaz

trader_cdlshootingstar

(PECL trader >= 0.2.0)

trader_cdlshootingstar — Estrella Fugaz

Descripción

trader_cdlshootingstar ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Vela de Línea Corta

  • « trader_cdlshootingstar
  • trader_cdlspinningtop »
  • PHP Manual
  • Funciones de Trader
  • Vela de Línea Corta

trader_cdlshortline

(PECL trader >= 0.2.0)

trader_cdlshortline — Vela de Línea Corta

Descripción

trader_cdlshortline ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Peonza

  • « trader_cdlshortline
  • trader_cdlstalledpattern »
  • PHP Manual
  • Funciones de Trader
  • Peonza

trader_cdlspinningtop

(PECL trader >= 0.2.0)

trader_cdlspinningtop — Peonza

Descripción

trader_cdlspinningtop ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón Añejo

  • « trader_cdlspinningtop
  • trader_cdlsticksandwich »
  • PHP Manual
  • Funciones de Trader
  • Patrón Añejo

trader_cdlstalledpattern

(PECL trader >= 0.2.0)

trader_cdlstalledpattern — Patrón Añejo

Descripción

trader_cdlstalledpattern ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Bocadillo

  • « trader_cdlstalledpattern
  • trader_cdltakuri »
  • PHP Manual
  • Funciones de Trader
  • Bocadillo

trader_cdlsticksandwich

(PECL trader >= 0.2.0)

trader_cdlsticksandwich — Bocadillo

Descripción

trader_cdlsticksandwich ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Takuri (Libélula Doji con sombra muy larga)

  • « trader_cdlsticksandwich
  • trader_cdltasukigap »
  • PHP Manual
  • Funciones de Trader
  • Takuri (Libélula Doji con sombra muy larga)

trader_cdltakuri

(PECL trader >= 0.2.0)

trader_cdltakuri — Takuri (Libélula Doji con sombra muy larga)

Descripción

trader_cdltakuri ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Hueco Tasuki

  • « trader_cdltakuri
  • trader_cdlthrusting »
  • PHP Manual
  • Funciones de Trader
  • Hueco Tasuki

trader_cdltasukigap

(PECL trader >= 0.2.0)

trader_cdltasukigap — Hueco Tasuki

Descripción

trader_cdltasukigap ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón de empuje

  • « trader_cdltasukigap
  • trader_cdltristar »
  • PHP Manual
  • Funciones de Trader
  • Patrón de empuje

trader_cdlthrusting

(PECL trader >= 0.2.0)

trader_cdlthrusting — Patrón de empuje

Descripción

trader_cdlthrusting ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Patrón de tres estrellas

  • « trader_cdlthrusting
  • trader_cdlunique3river »
  • PHP Manual
  • Funciones de Trader
  • Patrón de tres estrellas

trader_cdltristar

(PECL trader >= 0.2.0)

trader_cdltristar — Patrón de tres estrellas

Descripción

trader_cdltristar ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Tres ríos únicos

  • « trader_cdltristar
  • trader_cdlupsidegap2crows »
  • PHP Manual
  • Funciones de Trader
  • Tres ríos únicos

trader_cdlunique3river

(PECL trader >= 0.2.0)

trader_cdlunique3river — Tres ríos únicos

Descripción

trader_cdlunique3river ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Dos Cuervos tras un Huevo al Alza

  • « trader_cdlunique3river
  • trader_cdlxsidegap3methods »
  • PHP Manual
  • Funciones de Trader
  • Dos Cuervos tras un Huevo al Alza

trader_cdlupsidegap2crows

(PECL trader >= 0.2.0)

trader_cdlupsidegap2crows — Dos Cuervos tras un Huevo al Alza

Descripción

trader_cdlupsidegap2crows ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Métodos de Tres Huevos al Alza/Baja

  • « trader_cdlupsidegap2crows
  • trader_ceil »
  • PHP Manual
  • Funciones de Trader
  • Métodos de Tres Huevos al Alza/Baja

trader_cdlxsidegap3methods

(PECL trader >= 0.2.0)

trader_cdlxsidegap3methods — Métodos de Tres Huevos al Alza/Baja

Descripción

trader_cdlxsidegap3methods ( array $open , array $high , array $low , array $close ) : array

Parámetros

open

Precio de apertura, array de valores reales.

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Redondeo hacia arriba de vectores

  • « trader_cdlxsidegap3methods
  • trader_cmo »
  • PHP Manual
  • Funciones de Trader
  • Redondeo hacia arriba de vectores

trader_ceil

(PECL trader >= 0.2.0)

trader_ceil — Redondeo hacia arriba de vectores

Descripción

trader_ceil ( array $real ) : array

Calcula el siguiente entero mayor para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Oscilador de momento de Chande

  • « trader_ceil
  • trader_correl »
  • PHP Manual
  • Funciones de Trader
  • Oscilador de momento de Chande

trader_cmo

(PECL trader >= 0.2.0)

trader_cmo — Oscilador de momento de Chande

Descripción

trader_cmo ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Coeficiente de correlación de Pearson (r)

  • « trader_cmo
  • trader_cos »
  • PHP Manual
  • Funciones de Trader
  • Coeficiente de correlación de Pearson (r)

trader_correl

(PECL trader >= 0.2.0)

trader_correl — Coeficiente de correlación de Pearson (r)

Descripción

trader_correl ( array $real0 , array $real1 , int $timePeriod = ? ) : array

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Coseno trigonométrico de vectores

  • « trader_correl
  • trader_cosh »
  • PHP Manual
  • Funciones de Trader
  • Coseno trigonométrico de vectores

trader_cos

(PECL trader >= 0.2.0)

trader_cos — Coseno trigonométrico de vectores

Descripción

trader_cos ( array $real ) : array

Calcula el coseno para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Coseno hiperbólico de un vector

  • « trader_cos
  • trader_dema »
  • PHP Manual
  • Funciones de Trader
  • Coseno hiperbólico de un vector

trader_cosh

(PECL trader >= 0.2.0)

trader_cosh — Coseno hiperbólico de un vector

Descripción

trader_cosh ( array $real ) : array

Calcula el coseno hiperbólico para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Media móvil exponencial doble

  • « trader_cosh
  • trader_div »
  • PHP Manual
  • Funciones de Trader
  • Media móvil exponencial doble

trader_dema

(PECL trader >= 0.2.0)

trader_dema — Media móvil exponencial doble

Descripción

trader_dema ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


División aritmética de vectores

  • « trader_dema
  • trader_dx »
  • PHP Manual
  • Funciones de Trader
  • División aritmética de vectores

trader_div

(PECL trader >= 0.2.0)

trader_div — División aritmética de vectores

Descripción

trader_div ( array $real0 , array $real1 ) : array

Divide cada valor de real0 por el valor correspondiente de real1 y devuelve el array resultante.

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de fallo.


Índice de movimiento direccional

  • « trader_div
  • trader_ema »
  • PHP Manual
  • Funciones de Trader
  • Índice de movimiento direccional

trader_dx

(PECL trader >= 0.2.0)

trader_dx — Índice de movimiento direccional

Descripción

trader_dx ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil exponencial

  • « trader_dx
  • trader_errno »
  • PHP Manual
  • Funciones de Trader
  • Media móvil exponencial

trader_ema

(PECL trader >= 0.2.0)

trader_ema — Media móvil exponencial

Descripción

trader_ema ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Obtener el código de error

  • « trader_ema
  • trader_exp »
  • PHP Manual
  • Funciones de Trader
  • Obtener el código de error

trader_errno

(PECL trader >= 0.3.0)

trader_errno — Obtener el código de error

Descripción

trader_errno ( ) : int

Obtener el código de error de la última operación.

Valores devueltos

Devuelve el código de error identificado por una de las constantes TRADER_ERR_*.


Exponencial aritmética de vectores

  • « trader_errno
  • trader_floor »
  • PHP Manual
  • Funciones de Trader
  • Exponencial aritmética de vectores

trader_exp

(PECL trader >= 0.2.0)

trader_exp — Exponencial aritmética de vectores

Descripción

trader_exp ( array $real ) : array

Calcula e elevado a la potencia de cada valor de real. Devuelve un array con los datos calculados.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Redondeo hacia abajo de vectores

  • « trader_exp
  • trader_get_compat »
  • PHP Manual
  • Funciones de Trader
  • Redondeo hacia abajo de vectores

trader_floor

(PECL trader >= 0.2.0)

trader_floor — Redondeo hacia abajo de vectores

Descripción

trader_floor ( array $real ) : array

Calcula el siguiente entero menor para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Obtiene el modo de compatibilidad

  • « trader_floor
  • trader_get_unstable_period »
  • PHP Manual
  • Funciones de Trader
  • Obtiene el modo de compatibilidad

trader_get_compat

(PECL trader >= 0.2.2)

trader_get_compat — Obtiene el modo de compatibilidad

Descripción

trader_get_compat ( ) : int

Obtiene el modo de compatibilidad que afecta a la forma de realizar los cálculos de todas las funciones de la extensión.

Valores devueltos

Devuelve el id del modo de compatibilidad que puede ser identificado por la serie de constantes de TRADER_COMPATIBILITY_*.


Obtiene el periodo inestable

  • « trader_get_compat
  • trader_ht_dcperiod »
  • PHP Manual
  • Funciones de Trader
  • Obtiene el periodo inestable

trader_get_unstable_period

(PECL trader >= 0.2.2)

trader_get_unstable_period — Obtiene el periodo inestable

Descripción

trader_get_unstable_period ( int $functionId ) : int

Obtiene el factor de periodo inestable para una función en particular.

Parámetros

functionId

El ID de la función por la que leer el factor. Se debería usar la serie de constantes TRADER_FUNC_UNST_*.

Valores devueltos

Devuelve el factor del periodo inestable para la función correspondiente.


Transformación de Hilbert - Período de ciclo dominante

  • « trader_get_unstable_period
  • trader_ht_dcphase »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Período de ciclo dominante

trader_ht_dcperiod

(PECL trader >= 0.2.0)

trader_ht_dcperiod — Transformación de Hilbert - Período de ciclo dominante

Descripción

trader_ht_dcperiod ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Transformación de Hilbert - Fase de ciclo dominante

  • « trader_ht_dcperiod
  • trader_ht_phasor »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Fase de ciclo dominante

trader_ht_dcphase

(PECL trader >= 0.2.0)

trader_ht_dcphase — Transformación de Hilbert - Fase de ciclo dominante

Descripción

trader_ht_dcphase ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Transformación de Hilbert - Componentes de un fasor

  • « trader_ht_dcphase
  • trader_ht_sine »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Componentes de un fasor

trader_ht_phasor

(PECL trader >= 0.2.0)

trader_ht_phasor — Transformación de Hilbert - Componentes de un fasor

Descripción

trader_ht_phasor ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Transformación de Hilbert - Sinusoide

  • « trader_ht_phasor
  • trader_ht_trendline »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Sinusoide

trader_ht_sine

(PECL trader >= 0.2.0)

trader_ht_sine — Transformación de Hilbert - Sinusoide

Descripción

trader_ht_sine ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Transformación de Hilbert - Línea de tendencia instantánea

  • « trader_ht_sine
  • trader_ht_trendmode »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Línea de tendencia instantánea

trader_ht_trendline

(PECL trader >= 0.2.0)

trader_ht_trendline — Transformación de Hilbert - Línea de tendencia instantánea

Descripción

trader_ht_trendline ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Transformación de Hilbert - Tendencia vs Modo de ciclo

  • « trader_ht_trendline
  • trader_kama »
  • PHP Manual
  • Funciones de Trader
  • Transformación de Hilbert - Tendencia vs Modo de ciclo

trader_ht_trendmode

(PECL trader >= 0.2.0)

trader_ht_trendmode — Transformación de Hilbert - Tendencia vs Modo de ciclo

Descripción

trader_ht_trendmode ( array $real ) : array

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil adaptativa de Kaufman

  • « trader_ht_trendmode
  • trader_linearreg_angle »
  • PHP Manual
  • Funciones de Trader
  • Media móvil adaptativa de Kaufman

trader_kama

(PECL trader >= 0.2.0)

trader_kama — Media móvil adaptativa de Kaufman

Descripción

trader_kama ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Ángulo de regresión lineal

  • « trader_kama
  • trader_linearreg_intercept »
  • PHP Manual
  • Funciones de Trader
  • Ángulo de regresión lineal

trader_linearreg_angle

(PECL trader >= 0.2.0)

trader_linearreg_angle — Ángulo de regresión lineal

Descripción

trader_linearreg_angle ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Intercepción de regresión lineal

  • « trader_linearreg_angle
  • trader_linearreg_slope »
  • PHP Manual
  • Funciones de Trader
  • Intercepción de regresión lineal

trader_linearreg_intercept

(PECL trader >= 0.2.0)

trader_linearreg_intercept — Intercepción de regresión lineal

Descripción

trader_linearreg_intercept ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Pendiente de regresión lineal

  • « trader_linearreg_intercept
  • trader_linearreg »
  • PHP Manual
  • Funciones de Trader
  • Pendiente de regresión lineal

trader_linearreg_slope

(PECL trader >= 0.2.0)

trader_linearreg_slope — Pendiente de regresión lineal

Descripción

trader_linearreg_slope ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Regresión lineal

  • « trader_linearreg_slope
  • trader_ln »
  • PHP Manual
  • Funciones de Trader
  • Regresión lineal

trader_linearreg

(PECL trader >= 0.2.0)

trader_linearreg — Regresión lineal

Descripción

trader_linearreg ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Logaritmo natural de vectores

  • « trader_linearreg
  • trader_log10 »
  • PHP Manual
  • Funciones de Trader
  • Logaritmo natural de vectores

trader_ln

(PECL trader >= 0.2.0)

trader_ln — Logaritmo natural de vectores

Descripción

trader_ln ( array $real ) : array

Calcula el logaritmo natural para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Logaritmo en base 10 de vectores

  • « trader_ln
  • trader_ma »
  • PHP Manual
  • Funciones de Trader
  • Logaritmo en base 10 de vectores

trader_log10

(PECL trader >= 0.2.0)

trader_log10 — Logaritmo en base 10 de vectores

Descripción

trader_log10 ( array $real ) : array

Calcula el logaritmo en base 10 para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil

  • « trader_log10
  • trader_macd »
  • PHP Manual
  • Funciones de Trader
  • Media móvil

trader_ma

(PECL trader >= 0.2.0)

trader_ma — Media móvil

Descripción

trader_ma ( array $real , int $timePeriod = ? , int $mAType = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

mAType

Tipo de media móvil. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Convergencia/divergencia de la media móvil

  • « trader_ma
  • trader_macdext »
  • PHP Manual
  • Funciones de Trader
  • Convergencia/divergencia de la media móvil

trader_macd

(PECL trader >= 0.2.0)

trader_macd — Convergencia/divergencia de la media móvil

Descripción

trader_macd ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $signalPeriod = ? ) : array

Parámetros

real

Array de valores reales.

fastPeriod

Número del periodo para el MA rápido. Rango válido desde 2 hasta 100000.

slowPeriod

Número del periodo para el MA lento. Rango válido desde 2 hasta 100000.

signalPeriod

Suavizado para la línea de señal (nb de periodo). Rango válido desde 1 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


MACD con tipo MA controlable

  • « trader_macd
  • trader_macdfix »
  • PHP Manual
  • Funciones de Trader
  • MACD con tipo MA controlable

trader_macdext

(PECL trader >= 0.2.0)

trader_macdext — MACD con tipo MA controlable

Descripción

trader_macdext ( array $real , int $fastPeriod = ? , int $fastMAType = ? , int $slowPeriod = ? , int $slowMAType = ? , int $signalPeriod = ? , int $signalMAType = ? ) : array

Parámetros

real

Array de valores reales.

fastPeriod

Número del periodo para el MA rápido. Rango válido desde 2 hasta 100000.

fastMAType

Tipo de media móvil para MA rápido. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

slowPeriod

Número del periodo para el MA lento. Rango válido desde 2 hasta 100000.

slowMAType

Tipo de media móvil para MA lento. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

signalPeriod

Suavizado para la línea de señal (nb de periodo). Rango válido desde 1 hasta 100000.

signalMAType

Tipo de media móvil para la línea de señal. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Convergencia/divergencia fija 12/26 de la media móvil

  • « trader_macdext
  • trader_mama »
  • PHP Manual
  • Funciones de Trader
  • Convergencia/divergencia fija 12/26 de la media móvil

trader_macdfix

(PECL trader >= 0.2.0)

trader_macdfix — Convergencia/divergencia fija 12/26 de la media móvil

Descripción

trader_macdfix ( array $real , int $signalPeriod = ? ) : array

Parámetros

real

Array de valores reales.

signalPeriod

Suavizado para la línea de señal (nb de periodo). Rango válido desde 1 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil adaptativa MESA

  • « trader_macdfix
  • trader_mavp »
  • PHP Manual
  • Funciones de Trader
  • Media móvil adaptativa MESA

trader_mama

(PECL trader >= 0.2.0)

trader_mama — Media móvil adaptativa MESA

Descripción

trader_mama ( array $real , float $fastLimit = ? , float $slowLimit = ? ) : array

Parámetros

real

Array de valores reales.

fastLimit

Límite superior usado en el algoritmo adaptativo. Rango válido desde 0.01 hasta 0.99.

slowLimit

Límite inferior usado en el algoritmo adaptativo. Rango válido desde 0.01 hasta 0.99.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil con periodo variable

  • « trader_mama
  • trader_max »
  • PHP Manual
  • Funciones de Trader
  • Media móvil con periodo variable

trader_mavp

(PECL trader >= 0.2.0)

trader_mavp — Media móvil con periodo variable

Descripción

trader_mavp ( array $real , array $periods , int $minPeriod = ? , int $maxPeriod = ? , int $mAType = ? ) : array

Parámetros

real

Array de valores reales.

periods

Array de valores reales.

minPeriod

Un valor menor que el mínimo se cambiará al periodo mínimo. Rango válido desde 2 hasta 100000

maxPeriod

Un valor mayor que el mínimo se cambiará al periodo máximo. Rango válido desde 2 hasta 100000

mAType

Tipo de media móvil. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Valor mayor sobre un periodo especificado

  • « trader_mavp
  • trader_maxindex »
  • PHP Manual
  • Funciones de Trader
  • Valor mayor sobre un periodo especificado

trader_max

(PECL trader >= 0.2.0)

trader_max — Valor mayor sobre un periodo especificado

Descripción

trader_max ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índice del valor mayor sobre un periodo especificado

  • « trader_max
  • trader_medprice »
  • PHP Manual
  • Funciones de Trader
  • Índice del valor mayor sobre un periodo especificado

trader_maxindex

(PECL trader >= 0.2.0)

trader_maxindex — Índice del valor mayor sobre un periodo especificado

Descripción

trader_maxindex ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Precio medio

  • « trader_maxindex
  • trader_mfi »
  • PHP Manual
  • Funciones de Trader
  • Precio medio

trader_medprice

(PECL trader >= 0.2.0)

trader_medprice — Precio medio

Descripción

trader_medprice ( array $high , array $low ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índice de flujo de dinero

  • « trader_medprice
  • trader_midpoint »
  • PHP Manual
  • Funciones de Trader
  • Índice de flujo de dinero

trader_mfi

(PECL trader >= 0.2.0)

trader_mfi — Índice de flujo de dinero

Descripción

trader_mfi ( array $high , array $low , array $close , array $volume , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

volume

Volumen comerciado, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Punto medio sobre un periodo

  • « trader_mfi
  • trader_midprice »
  • PHP Manual
  • Funciones de Trader
  • Punto medio sobre un periodo

trader_midpoint

(PECL trader >= 0.2.0)

trader_midpoint — Punto medio sobre un periodo

Descripción

trader_midpoint ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Precio de punto medio sobre un periodo

  • « trader_midpoint
  • trader_min »
  • PHP Manual
  • Funciones de Trader
  • Precio de punto medio sobre un periodo

trader_midprice

(PECL trader >= 0.2.0)

trader_midprice — Precio de punto medio sobre un periodo

Descripción

trader_midprice ( array $high , array $low , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Valor más bajo sobre un periodo especificado

  • « trader_midprice
  • trader_minindex »
  • PHP Manual
  • Funciones de Trader
  • Valor más bajo sobre un periodo especificado

trader_min

(PECL trader >= 0.2.0)

trader_min — Valor más bajo sobre un periodo especificado

Descripción

trader_min ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índice del valor más bajo sobre un periodo especificado

  • « trader_min
  • trader_minmax »
  • PHP Manual
  • Funciones de Trader
  • Índice del valor más bajo sobre un periodo especificado

trader_minindex

(PECL trader >= 0.2.0)

trader_minindex — Índice del valor más bajo sobre un periodo especificado

Descripción

trader_minindex ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Valores más altos y bajos sobre un periodo especificado

  • « trader_minindex
  • trader_minmaxindex »
  • PHP Manual
  • Funciones de Trader
  • Valores más altos y bajos sobre un periodo especificado

trader_minmax

(PECL trader >= 0.2.0)

trader_minmax — Valores más altos y bajos sobre un periodo especificado

Descripción

trader_minmax ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índices de los valores más bajos y altos sobre un periodo especificado

  • « trader_minmax
  • trader_minus_di »
  • PHP Manual
  • Funciones de Trader
  • Índices de los valores más bajos y altos sobre un periodo especificado

trader_minmaxindex

(PECL trader >= 0.2.0)

trader_minmaxindex — Índices de los valores más bajos y altos sobre un periodo especificado

Descripción

trader_minmaxindex ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Indicador direccional menos

  • « trader_minmaxindex
  • trader_minus_dm »
  • PHP Manual
  • Funciones de Trader
  • Indicador direccional menos

trader_minus_di

(PECL trader >= 0.2.0)

trader_minus_di — Indicador direccional menos

Descripción

trader_minus_di ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Movimiento direccional menos

  • « trader_minus_di
  • trader_mom »
  • PHP Manual
  • Funciones de Trader
  • Movimiento direccional menos

trader_minus_dm

(PECL trader >= 0.2.0)

trader_minus_dm — Movimiento direccional menos

Descripción

trader_minus_dm ( array $high , array $low , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Momentum

  • « trader_minus_dm
  • trader_mult »
  • PHP Manual
  • Funciones de Trader
  • Momentum

trader_mom

(PECL trader >= 0.2.0)

trader_mom — Momentum

Descripción

trader_mom ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Multiplicación aritmética de vectores

  • « trader_mom
  • trader_natr »
  • PHP Manual
  • Funciones de Trader
  • Multiplicación aritmética de vectores

trader_mult

(PECL trader >= 0.2.0)

trader_mult — Multiplicación aritmética de vectores

Descripción

trader_mult ( array $real0 , array $real1 ) : array

Calcula el producto escalar de real0 con real1 y devuelve el vector resultante.

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Rango verdadero de la media normalizada

  • « trader_mult
  • trader_obv »
  • PHP Manual
  • Funciones de Trader
  • Rango verdadero de la media normalizada

trader_natr

(PECL trader >= 0.2.0)

trader_natr — Rango verdadero de la media normalizada

Descripción

trader_natr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Volumen sobre balance

  • « trader_natr
  • trader_plus_di »
  • PHP Manual
  • Funciones de Trader
  • Volumen sobre balance

trader_obv

(PECL trader >= 0.2.0)

trader_obv — Volumen sobre balance

Descripción

trader_obv ( array $real , array $volume ) : array

Parámetros

real

Array de valores reales.

volume

Volumen comerciado, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Indicador direccional más

  • « trader_obv
  • trader_plus_dm »
  • PHP Manual
  • Funciones de Trader
  • Indicador direccional más

trader_plus_di

(PECL trader >= 0.2.0)

trader_plus_di — Indicador direccional más

Descripción

trader_plus_di ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Movimiento direccional más

  • « trader_plus_di
  • trader_ppo »
  • PHP Manual
  • Funciones de Trader
  • Movimiento direccional más

trader_plus_dm

(PECL trader >= 0.2.0)

trader_plus_dm — Movimiento direccional más

Descripción

trader_plus_dm ( array $high , array $low , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Oscilador de precio porcentual

  • « trader_plus_dm
  • trader_roc »
  • PHP Manual
  • Funciones de Trader
  • Oscilador de precio porcentual

trader_ppo

(PECL trader >= 0.2.0)

trader_ppo — Oscilador de precio porcentual

Descripción

trader_ppo ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $mAType = ? ) : array

Parámetros

real

Array de valores reales.

fastPeriod

Número del periodo para el MA rápido. Rango válido desde 2 hasta 100000.

slowPeriod

Número del periodo para el MA lento. Rango válido desde 2 hasta 100000.

mAType

Tipo de media móvil. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Ritmo de cambio : ((precio/precioAnterior)-1)*100

  • « trader_ppo
  • trader_rocp »
  • PHP Manual
  • Funciones de Trader
  • Ritmo de cambio : ((precio/precioAnterior)-1)*100

trader_roc

(PECL trader >= 0.2.0)

trader_roc — Ritmo de cambio : ((precio/precioAnterior)-1)*100

Descripción

trader_roc ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior

  • « trader_roc
  • trader_rocr100 »
  • PHP Manual
  • Funciones de Trader
  • Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior

trader_rocp

(PECL trader >= 0.2.0)

trader_rocp — Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior

Descripción

trader_rocp ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100

  • « trader_rocp
  • trader_rocr »
  • PHP Manual
  • Funciones de Trader
  • Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100

trader_rocr100

(PECL trader >= 0.2.0)

trader_rocr100 — Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100

Descripción

trader_rocr100 ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Ratio del ritmo de cambio: (precio/precioAnterior)

  • « trader_rocr100
  • trader_rsi »
  • PHP Manual
  • Funciones de Trader
  • Ratio del ritmo de cambio: (precio/precioAnterior)

trader_rocr

(PECL trader >= 0.2.0)

trader_rocr — Ratio del ritmo de cambio: (precio/precioAnterior)

Descripción

trader_rocr ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índice de fuerza relativa

  • « trader_rocr
  • trader_sar »
  • PHP Manual
  • Funciones de Trader
  • Índice de fuerza relativa

trader_rsi

(PECL trader >= 0.2.0)

trader_rsi — Índice de fuerza relativa

Descripción

trader_rsi ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Sistema parabólico

  • « trader_rsi
  • trader_sarext »
  • PHP Manual
  • Funciones de Trader
  • Sistema parabólico

trader_sar

(PECL trader >= 0.2.0)

trader_sar — Sistema parabólico

Descripción

trader_sar ( array $high , array $low , float $acceleration = ? , float $maximum = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

acceleration

Factor de aceleración usado hasta el valor máximo. Rango válido de 0 hasta TRADER_REAL_MAX.

maximum

Valor máximo del factor de aceleración. Rango válido de 0 hasta TRADER_REAL_MAX.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Sistema parabólico - Extendido

  • « trader_sar
  • trader_set_compat »
  • PHP Manual
  • Funciones de Trader
  • Sistema parabólico - Extendido

trader_sarext

(PECL trader >= 0.2.0)

trader_sarext — Sistema parabólico - Extendido

Descripción

trader_sarext ( array $high , array $low , float $startValue = ? , float $offsetOnReverse = ? , float $accelerationInitLong = ? , float $accelerationLong = ? , float $accelerationMaxLong = ? , float $accelerationInitShort = ? , float $accelerationShort = ? , float $accelerationMaxShort = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

startValue

Valor inicial y dirección. 0 para Auto, >0 para Long, <0 para Short. Rango válido de TRADER_REAL_MIN hasta TRADER_REAL_MAX.

offsetOnReverse

Índice de porcentaje añadido/eliminado a la parada inicial sobre el reverso short/long reversal. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationInitLong

Valor inicial del factor de aceleración para la dirección Long. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationLong

Factor de acelereción para la dirección Long. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationMaxLong

Valor máximo del factor de aceleración para la dirección Long. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationInitShort

Valor inicial del factor de aceleración para la dirección Short. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationShort

Factor de aceleración para la dirección Short. Rango válido de 0 hasta TRADER_REAL_MAX.

accelerationMaxShort

Valor máximo del factor de aceleración para la dirección Short. Rango válido de 0 hasta TRADER_REAL_MAX.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Establece el modo de compatibilidad

  • « trader_sarext
  • trader_set_unstable_period »
  • PHP Manual
  • Funciones de Trader
  • Establece el modo de compatibilidad

trader_set_compat

(PECL trader >= 0.2.2)

trader_set_compat — Establece el modo de compatibilidad

Descripción

trader_set_compat ( int $compatId ) : void

Establece el modo de compatibilidad que afectará a la forma de realizar los cálculos de todas las funciones de la extensión.

Parámetros

compatId

El ID de compatibilidad. Debería usarse la serie de constantes TRADER_COMPATIBILITY_*.

Valores devueltos

No devuelve ningún valor.


Establece el periodo inestable

  • « trader_set_compat
  • trader_sin »
  • PHP Manual
  • Funciones de Trader
  • Establece el periodo inestable

trader_set_unstable_period

(PECL trader >= 0.2.2)

trader_set_unstable_period — Establece el periodo inestable

Descripción

trader_set_unstable_period ( int $functionId , int $timePeriod ) : void

Factor de periodos inestables de influencia para funciones, las cuales son sensibles a él. Se puede encontrar más información sobre periodos inestables en la página de la documentación de la API » TA-Lib.

Parámetros

functionId

El ID de la función para la cual debería establecerse el factor. Se pueden usar la serie de constantes TRADER_FUNC_UNST_* para afectar a la función correspondiente.

timePeriod

El valor de periodo inestable.

Valores devueltos

No devuelve ningún valor.


Seno trigonométrico de vectores

  • « trader_set_unstable_period
  • trader_sinh »
  • PHP Manual
  • Funciones de Trader
  • Seno trigonométrico de vectores

trader_sin

(PECL trader >= 0.2.0)

trader_sin — Seno trigonométrico de vectores

Descripción

trader_sin ( array $real ) : array

Calcula el seno para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Seno hiperbólico de vectores

  • « trader_sin
  • trader_sma »
  • PHP Manual
  • Funciones de Trader
  • Seno hiperbólico de vectores

trader_sinh

(PECL trader >= 0.2.0)

trader_sinh — Seno hiperbólico de vectores

Descripción

trader_sinh ( array $real ) : array

Calcula el seno hiperbólico para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil simple

  • « trader_sinh
  • trader_sqrt »
  • PHP Manual
  • Funciones de Trader
  • Media móvil simple

trader_sma

(PECL trader >= 0.2.0)

trader_sma — Media móvil simple

Descripción

trader_sma ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Raíz cuadrada de vectores

  • « trader_sma
  • trader_stddev »
  • PHP Manual
  • Funciones de Trader
  • Raíz cuadrada de vectores

trader_sqrt

(PECL trader >= 0.2.0)

trader_sqrt — Raíz cuadrada de vectores

Descripción

trader_sqrt ( array $real ) : array

Calcula la raíz cuadrada de cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Desviación estándar

  • « trader_sqrt
  • trader_stoch »
  • PHP Manual
  • Funciones de Trader
  • Desviación estándar

trader_stddev

(PECL trader >= 0.2.0)

trader_stddev — Desviación estándar

Descripción

trader_stddev ( array $real , int $timePeriod = ? , float $nbDev = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

nbDev

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Estocástico

  • « trader_stddev
  • trader_stochf »
  • PHP Manual
  • Funciones de Trader
  • Estocástico

trader_stoch

(PECL trader >= 0.2.0)

trader_stoch — Estocástico

Descripción

trader_stoch ( array $high , array $low , array $close , int $fastK_Period = ? , int $slowK_Period = ? , int $slowK_MAType = ? , int $slowD_Period = ? , int $slowD_MAType = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

fastK_Period

Periodo de tiempo para la construcción de la línea K-Rápida. Rango válido desde 1 hasta 100000.

slowK_Period

Suavizado para la realización de la línea K-Lenta. Rango válido desde 1 hasta 100000, normalmente establecido a 3.

slowK_MAType

Tipo de media móvil para K-lento. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

slowD_Period

Suavizado para la realización de la línea D-Lenta. Rango válido desde 1 hasta 100000.

slowD_MAType

Tipo de media móvil para D-lento. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Estocástico rápido

  • « trader_stoch
  • trader_stochrsi »
  • PHP Manual
  • Funciones de Trader
  • Estocástico rápido

trader_stochf

(PECL trader >= 0.2.0)

trader_stochf — Estocástico rápido

Descripción

trader_stochf ( array $high , array $low , array $close , int $fastK_Period = ? , int $fastD_Period = ? , int $fastD_MAType = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

fastK_Period

Periodo de tiempo para la construcción de la línea K-Rápida. Rango válido desde 1 hasta 100000.

fastD_Period

Suavizado para la realización de la línea D-Rápida. Rango válido desde 1 hasta 100000, normalmente establecido a 3.

fastD_MAType

Tipo de media móvil para D-rápido. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Índice de fuerza relativa estocástica

  • « trader_stochf
  • trader_sub »
  • PHP Manual
  • Funciones de Trader
  • Índice de fuerza relativa estocástica

trader_stochrsi

(PECL trader >= 0.2.0)

trader_stochrsi — Índice de fuerza relativa estocástica

Descripción

trader_stochrsi ( array $real , int $timePeriod = ? , int $fastK_Period = ? , int $fastD_Period = ? , int $fastD_MAType = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

fastK_Period

Periodo de tiempo para la construcción de la línea K-Rápida. Rango válido desde 1 hasta 100000.

fastD_Period

Suavizado para la realización de la línea D-Rápida. Rango válido desde 1 hasta 100000, normalmente establecido a 3.

fastD_MAType

Tipo de media móvil para D-rápido. Se debería usar la serie de constantes TRADER_MA_TYPE_*.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Sustracción artimética de vectores

  • « trader_stochrsi
  • trader_sum »
  • PHP Manual
  • Funciones de Trader
  • Sustracción artimética de vectores

trader_sub

(PECL trader >= 0.2.0)

trader_sub — Sustracción artimética de vectores

Descripción

trader_sub ( array $real0 , array $real1 ) : array

Calcula la suma de vectores de real1 desde real0 y devuelve el vector resultante.

Parámetros

real0

Array de valores reales.

real1

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Sumatorio

  • « trader_sub
  • trader_t3 »
  • PHP Manual
  • Funciones de Trader
  • Sumatorio

trader_sum

(PECL trader >= 0.2.0)

trader_sum — Sumatorio

Descripción

trader_sum ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil exponencial triple (T3)

  • « trader_sum
  • trader_tan »
  • PHP Manual
  • Funciones de Trader
  • Media móvil exponencial triple (T3)

trader_t3

(PECL trader >= 0.2.0)

trader_t3 — Media móvil exponencial triple (T3)

Descripción

trader_t3 ( array $real , int $timePeriod = ? , float $vFactor = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

vFactor

Factor de volumen. Rango válido desde 1 hasta 0.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Tangente trigonométrica de vectores

  • « trader_t3
  • trader_tanh »
  • PHP Manual
  • Funciones de Trader
  • Tangente trigonométrica de vectores

trader_tan

(PECL trader >= 0.2.0)

trader_tan — Tangente trigonométrica de vectores

Descripción

trader_tan ( array $real ) : array

Calcula la tangente para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Tangente hiperbólica trigonométrica de vectores

  • « trader_tan
  • trader_tema »
  • PHP Manual
  • Funciones de Trader
  • Tangente hiperbólica trigonométrica de vectores

trader_tanh

(PECL trader >= 0.2.0)

trader_tanh — Tangente hiperbólica trigonométrica de vectores

Descripción

trader_tanh ( array $real ) : array

Calcula la tangente hiperbólica para cada valor de real y devuelve el array resultante.

Parámetros

real

Array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil exponencial triple

  • « trader_tanh
  • trader_trange »
  • PHP Manual
  • Funciones de Trader
  • Media móvil exponencial triple

trader_tema

(PECL trader >= 0.2.0)

trader_tema — Media móvil exponencial triple

Descripción

trader_tema ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Rango verdadero

  • « trader_tema
  • trader_trima »
  • PHP Manual
  • Funciones de Trader
  • Rango verdadero

trader_trange

(PECL trader >= 0.2.0)

trader_trange — Rango verdadero

Descripción

trader_trange ( array $high , array $low , array $close ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil triangular

  • « trader_trange
  • trader_trix »
  • PHP Manual
  • Funciones de Trader
  • Media móvil triangular

trader_trima

(PECL trader >= 0.2.0)

trader_trima — Media móvil triangular

Descripción

trader_trima ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Ritmo de cambio de 1 día (RDC) de una MME suave triple

  • « trader_trima
  • trader_tsf »
  • PHP Manual
  • Funciones de Trader
  • Ritmo de cambio de 1 día (RDC) de una MME suave triple

trader_trix

(PECL trader >= 0.2.0)

trader_trix — Ritmo de cambio de 1 día (RDC) de una MME suave triple

Descripción

trader_trix ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Previsión de series de tiempo

  • « trader_trix
  • trader_typprice »
  • PHP Manual
  • Funciones de Trader
  • Previsión de series de tiempo

trader_tsf

(PECL trader >= 0.2.0)

trader_tsf — Previsión de series de tiempo

Descripción

trader_tsf ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Precio típico

  • « trader_tsf
  • trader_ultosc »
  • PHP Manual
  • Funciones de Trader
  • Precio típico

trader_typprice

(PECL trader >= 0.2.0)

trader_typprice — Precio típico

Descripción

trader_typprice ( array $high , array $low , array $close ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Oscilador final

  • « trader_typprice
  • trader_var »
  • PHP Manual
  • Funciones de Trader
  • Oscilador final

trader_ultosc

(PECL trader >= 0.2.0)

trader_ultosc — Oscilador final

Descripción

trader_ultosc ( array $high , array $low , array $close , int $timePeriod1 = ? , int $timePeriod2 = ? , int $timePeriod3 = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod1

Número de barras para el primer periodo. Rango válido de 1 hasta 100000.

timePeriod2

Número de barras para el segundo periodo. Rango válido de 1 hasta 100000.

timePeriod3

Número de barras para el tercer periodo. Rango válido de 1 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Varianza

  • « trader_ultosc
  • trader_wclprice »
  • PHP Manual
  • Funciones de Trader
  • Varianza

trader_var

(PECL trader >= 0.2.0)

trader_var — Varianza

Descripción

trader_var ( array $real , int $timePeriod = ? , float $nbDev = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

nbDev

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Precio de cierre ponderado

  • « trader_var
  • trader_willr »
  • PHP Manual
  • Funciones de Trader
  • Precio de cierre ponderado

trader_wclprice

(PECL trader >= 0.2.0)

trader_wclprice — Precio de cierre ponderado

Descripción

trader_wclprice ( array $high , array $low , array $close ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


%R de Williams

  • « trader_wclprice
  • trader_wma »
  • PHP Manual
  • Funciones de Trader
  • %R de Williams

trader_willr

(PECL trader >= 0.2.0)

trader_willr — %R de Williams

Descripción

trader_willr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

Parámetros

high

Precio alto, array de valores reales.

low

Precio bajo, array de valores reales.

close

Precio de cierre, array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Media móvil ponderada

  • « trader_willr
  • Salida MIME que no es texto »
  • PHP Manual
  • Funciones de Trader
  • Media móvil ponderada

trader_wma

(PECL trader >= 0.2.0)

trader_wma — Media móvil ponderada

Descripción

trader_wma ( array $real , int $timePeriod = ? ) : array

Parámetros

real

Array de valores reales.

timePeriod

Número del periodo. Rango válido desde 2 hasta 100000.

Valores devueltos

Devuelve un array con los datos calculados o false en caso de error.


Salida MIME que no es texto

  • FDF — Formato de Datos de Formularios
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de FDF
  • GnuPG — GNU Privacy Guard
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de GnuPG
  • wkhtmltox
    • Introducción
    • Instalación/Configuración
    • wkhtmltox\PDF\Converter — La clase wkhtmltox\PDF\Converter
    • wkhtmltox\PDF\Object — La clase wkhtmltox\PDF\Object
    • wkhtmltox\Image\Converter — La clase wkhtmltox\Image\Converter
  • PS — Creación de documentos PostScript
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de PS
  • RpmInfo
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • RpmInfo Funciones
  • XLSWriter
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Vtiful\Kernel\Excel — The Vtiful\Kernel\Excel class
    • Vtiful\Kernel\Format — The Vtiful\Kernel\Format class


Formato de Datos de Formularios

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de FDF
    • fdf_add_doc_javascript — Añadir código javascript al documento FDF
    • fdf_add_template — Añadir una plantilla al documento FDF
    • fdf_close — Cierra un documento FDF
    • fdf_create — Crear un nuevo documento FDF
    • fdf_enum_values — Invocar una función definida por el usuario por cada dato del documento
    • fdf_errno — Devuelve el código de error de la última operación sobre fdf
    • fdf_error — Consultar la descripción de un código de error FDF
    • fdf_get_ap — Consultar la publicación de un campo
    • fdf_get_attachment — Extraer un fichero subido por FDF
    • fdf_get_encoding — Consultar el valor de la clave /Encoding
    • fdf_get_file — Obtener el valor de la clave /F
    • fdf_get_flags — Consultar banderas de un campo
    • fdf_get_opt — Consultar un valor del array de opciones de un campo
    • fdf_get_status — Obtener el valor de la clave /STATUS
    • fdf_get_value — Obtener el valor de un campo
    • fdf_get_version — Consulta el número de versión de la API o de un fichero FDF
    • fdf_header — Establecer cabeceras de salida específicas de FDF
    • fdf_next_field_name — Obtener el siguiente nombre de campo
    • fdf_open_string — Consulta un documento FDF a partir de un string
    • fdf_open — Abrir un documento FDF
    • fdf_remove_item — Asignar contenedor para el formulario
    • fdf_save_string — Devuelve el documento FDF en forma de string
    • fdf_save — Guardar un documento FDF
    • fdf_set_ap — Establecer la apariencia de un campo
    • fdf_set_encoding — Asignar codificación de caracteres de FDF
    • fdf_set_file — Establecer el documento PDF en donde desplegar datos FDF
    • fdf_set_flags — Establecer banderas de un campo
    • fdf_set_javascript_action — Añadir una acción javascript a un campo
    • fdf_set_on_import_javascript — Añadir código javascript para ejecutar cuando Acrobat abra el FDF
    • fdf_set_opt — Establecer una opción sobre un campo
    • fdf_set_status — Establecer el valor de la clave /STATUS
    • fdf_set_submit_form_action — Asignar acción a un campo de formulario al enviarse
    • fdf_set_target_frame — Definir contenedor en el que mostrar el formulario
    • fdf_set_value — Establecer el valor de un campo
    • fdf_set_version — Asignar número de versión a un fichero FDF


Introducción

El Formato de Datos de Formularios (FDF) es un formato para manejar formularios de documentos PDF. Debería leer la documentación en » http://www.adobe.com/devnet/acrobat/fdftoolkit.html para obtener más información acerca de qué es y cómo funciona FDF en general.

La idea general de FDF es similar a la de los formularios HTML. Básicamente se diferencian en el formato en el que se transmiten los datos al servidor cuando se pulsa el botón "Enviar" (en realidad ésto es el Formato de Datos de Formularios), y en el formato del propio formulario (que es Portable Document Format, PDF). Una de las funcionalidades que ofrecen las funciones de FDF es el procesamiento de datos FDF. Pero hay más. Se podría usar un formulario PDF existente y rellenar sus campos de entrada con datos sin necesidad de modificar el propio formulario. En ese caso, se podría crear un documento PDF (fdf_create()), establecer el valor de cada campo (fdf_set_value()) y vincularlo con el formulario PDF (fdf_set_file()). Finalmente se ha de enviar al navegador con el MimeType application/vnd.fdf. El complemento de Acrobat Reader del navegador reconocerá el MimeType, leerá el formulario PDF asociado y rellenará los datos desde el documento FDF.

Al abrir un documento PDF con un editor de textos se puede identificar un objeto catálogo con el nombre FDF. Este objeto puede contener varias entradas, como Fields, F, Status, etc. Lo más frecuente es que sean de tipo Fields, las cuales apuntan a una lista de campos de entrada, y F, que contienen el nombre de fichero del documento PDF al que pertenecen estos datos. En la documentación de FDF se hace referencia a estas entradas con los nombres de /F-Key y /Status-Key. La modificación de estas entradas se realiza mediante funciones como fdf_set_file() y fdf_set_status(). Los campos se modifican con fdf_set_value(), fdf_set_opt(), etc.


Requerimientos

Es necesario tener el SDK de FDF, disponible en » http://www.adobe.com/devnet/acrobat/fdftoolkit.html. Desde PHP 4.3.0 es necesario tener al menos la versión 5.0 del SDK. La biblioteca de herramientas de FDF sólo está disponible en formato binario, y las plataformas a las que Adobe da soporte son Win32, Linux, Solaris y AIX.


Instalación

Esta extensión se considera no mantenida y abandonada. Sin embargo, el código fuente para esta extensión sigue estando disponible en PECL SVN aquí: » https://svn.php.net/viewvc/pecl/fdf.

Esta extensión ya no se incluye con PHP a partir de PHP 5.3.0.

Nota: Si tuviera algún problema al configurar PHP con soporte para fdftk, compruebe si el fichero de cabeceras fdftk.h y la biblioteca libfdftk.so están en el lugar adecuado. El comando configure permite tanto la estructura de directorios de la distribución del SDK de FDF, como el habitual sistema DIR/include / DIR/lib, de manera que puede apuntar directamente al directorio descomprimido, o poniendo el nombre del fichero de cabeceras y de la biblioteca de acuerdo a su sistema, por ejemplo /usr/local/include y /usr/local/lib y configurarlo con --with-fdftk=/usr/local.

Nota: Nota para usuarios de Win32

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: fdftk.dll


Tipos de recursos

La mayoría de funciones fdf requieren un recurso fdf como primer parámetro. Un recurso fdf es un manejador para utilizar un fichero fdf ya abierto. Se puede obtener un recurso fdf usando fdf_create(), fdf_open() y fdf_open_string().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

FDFValue (integer)
FDFStatus (integer)
FDFFile (integer)
FDFID (integer)
FDFFf (integer)
FDFSetFf (integer)
FDFClearFf (integer)
FDFFlags (integer)
FDFSetF (integer)
FDFClrF (integer)
FDFAP (integer)
FDFAS (integer)
FDFAction (integer)
FDFAA (integer)
FDFAPRef (integer)
FDFIF (integer)
FDFEnter (integer)
FDFExit (integer)
FDFDown (integer)
FDFUp (integer)
FDFFormat (integer)
FDFValidate (integer)
FDFKeystroke (integer)
FDFCalculate (integer)
FDFNormalAP (integer)
FDFRolloverAP (integer)
FDFDownAP (integer)


Ejemplos

Los siguientes ejemplos ilustran cómo se evalúan los datos del formulario.

Ejemplo #1 Evaluar un documento FDF

<?php
// Abrir fdf a partir de la cadena de entrada que proporciona la propia extensión
// El formulario pdf contiene varios campos de texto con los nombres
// volume, date, comment, publisher, preparer, y dos campos checkbox,
// show_publisher y show_preparer.
$fdf = fdf_open_string($HTTP_FDF_DATA);
$volume = fdf_get_value($fdf, "volume");
echo "El campo volume tiene el valor '<b>$volume</b>'<br />";

$date = fdf_get_value($fdf, "date");
echo "El campo date tiene el valor '<b>$date</b>'<br />";

$comment = fdf_get_value($fdf, "comment");
echo "El campo comment tiene el valor '<b>$comment</b>'<br />";

if (fdf_get_value($fdf, "show_publisher") == "On") {
  $publisher = fdf_get_value($fdf, "publisher");
  echo "El campo publisher tiene el valor '<b>$publisher</b>'<br />";
} else
  echo "No se debe mostrar el campo oublisher.<br />";

if (fdf_get_value($fdf, "show_preparer") == "On") {
  $preparer = fdf_get_value($fdf, "preparer");
  echo "El campo preparer tiene el valor '<b>$preparer</b>'<br />";
} else
  echo "No se debe mostrar el campo preparer.<br />";
fdf_close($fdf);
?>


Funciones de FDF

Tabla de contenidos

  • fdf_add_doc_javascript — Añadir código javascript al documento FDF
  • fdf_add_template — Añadir una plantilla al documento FDF
  • fdf_close — Cierra un documento FDF
  • fdf_create — Crear un nuevo documento FDF
  • fdf_enum_values — Invocar una función definida por el usuario por cada dato del documento
  • fdf_errno — Devuelve el código de error de la última operación sobre fdf
  • fdf_error — Consultar la descripción de un código de error FDF
  • fdf_get_ap — Consultar la publicación de un campo
  • fdf_get_attachment — Extraer un fichero subido por FDF
  • fdf_get_encoding — Consultar el valor de la clave /Encoding
  • fdf_get_file — Obtener el valor de la clave /F
  • fdf_get_flags — Consultar banderas de un campo
  • fdf_get_opt — Consultar un valor del array de opciones de un campo
  • fdf_get_status — Obtener el valor de la clave /STATUS
  • fdf_get_value — Obtener el valor de un campo
  • fdf_get_version — Consulta el número de versión de la API o de un fichero FDF
  • fdf_header — Establecer cabeceras de salida específicas de FDF
  • fdf_next_field_name — Obtener el siguiente nombre de campo
  • fdf_open_string — Consulta un documento FDF a partir de un string
  • fdf_open — Abrir un documento FDF
  • fdf_remove_item — Asignar contenedor para el formulario
  • fdf_save_string — Devuelve el documento FDF en forma de string
  • fdf_save — Guardar un documento FDF
  • fdf_set_ap — Establecer la apariencia de un campo
  • fdf_set_encoding — Asignar codificación de caracteres de FDF
  • fdf_set_file — Establecer el documento PDF en donde desplegar datos FDF
  • fdf_set_flags — Establecer banderas de un campo
  • fdf_set_javascript_action — Añadir una acción javascript a un campo
  • fdf_set_on_import_javascript — Añadir código javascript para ejecutar cuando Acrobat abra el FDF
  • fdf_set_opt — Establecer una opción sobre un campo
  • fdf_set_status — Establecer el valor de la clave /STATUS
  • fdf_set_submit_form_action — Asignar acción a un campo de formulario al enviarse
  • fdf_set_target_frame — Definir contenedor en el que mostrar el formulario
  • fdf_set_value — Establecer el valor de un campo
  • fdf_set_version — Asignar número de versión a un fichero FDF


Añadir código javascript al documento FDF

  • « Funciones de FDF
  • fdf_add_template »
  • PHP Manual
  • Funciones de FDF
  • Añadir código javascript al documento FDF

fdf_add_doc_javascript

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_add_doc_javascript — Añadir código javascript al documento FDF

Descripción

fdf_add_doc_javascript ( resource $fdf_document , string $script_name , string $script_code ) : bool

Añade un script al FDF, que una vez que se importe, Acrobat añade a los scripts del documento.

Parámetros

fdf_document

Manejador de documento FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

script_name

Nombre del script.

script_code

Código del script. Se recomienda encarecidamente usar \r para los cambios de línea del código del script.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añadiendo código JavaScript a un FDF

<?php
$fdf = fdf_create();
fdf_add_doc_javascript($fdf, "PlusOne", "function PlusOne(x)\r{\r  return x+1;\r}\r");
fdf_save($fdf);
?>

Creará un FDF como éste:

%FDF-1.2
%âãÏÓ
1 0 obj
<<
/FDF << /JavaScript << /Doc [ (PlusOne)(function PlusOne\(x\)\r{\r  return x+1;\r}\r)] >> >>
>>
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF


Añadir una plantilla al documento FDF

  • « fdf_add_doc_javascript
  • fdf_close »
  • PHP Manual
  • Funciones de FDF
  • Añadir una plantilla al documento FDF

fdf_add_template

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_add_template — Añadir una plantilla al documento FDF

Descripción

fdf_add_template ( resource $fdf_document , int $newpage , string $filename , string $template , int $rename ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Cierra un documento FDF

  • « fdf_add_template
  • fdf_create »
  • PHP Manual
  • Funciones de FDF
  • Cierra un documento FDF

fdf_close

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_close — Cierra un documento FDF

Descripción

fdf_close ( resource $fdf_document ) : void

Cierra el documento FDF.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

Valores devueltos

No devuelve ningún valor.

Ver también

  • fdf_open() - Abrir un documento FDF


Crear un nuevo documento FDF

  • « fdf_close
  • fdf_enum_values »
  • PHP Manual
  • Funciones de FDF
  • Crear un nuevo documento FDF

fdf_create

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_create — Crear un nuevo documento FDF

Descripción

fdf_create ( ) : resource

Crea un nuevo documento FDF.

Esta función es requerida si se desea poblar campos de entrada en un documento PDF con datos.

Valores devueltos

Devuelve un gestor de documento FDF, o false en caso de error.

Ejemplos

Ejemplo #1 Poblar un documento PDF

<?php
$salida_fdf = fdf_create();
fdf_set_value($salida_fdf, "volume", $volumen, 0);

fdf_set_file($salida_fdf, "http:/prueba_fdf/etiqueta_resultado.pdf");
fdf_save($salida_fdf, "salida_prueba.fdf");
fdf_close($salida_fdf);
Header("Content-type: application/vnd.fdf");
$aa = fopen("salida_prueba.fdf", "r");
fpassthru($aa);
unlink("salida_prueba.fdf");
?>

Ver también

  • fdf_close() - Cierra un documento FDF
  • fdf_save() - Guardar un documento FDF
  • fdf_open() - Abrir un documento FDF


Invocar una función definida por el usuario por cada dato del documento

  • « fdf_create
  • fdf_errno »
  • PHP Manual
  • Funciones de FDF
  • Invocar una función definida por el usuario por cada dato del documento

fdf_enum_values

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_enum_values — Invocar una función definida por el usuario por cada dato del documento

Descripción

fdf_enum_values ( resource $fdf_document , callable $function , mixed $userdata = ? ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve el código de error de la última operación sobre fdf

  • « fdf_enum_values
  • fdf_error »
  • PHP Manual
  • Funciones de FDF
  • Devuelve el código de error de la última operación sobre fdf

fdf_errno

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_errno — Devuelve el código de error de la última operación sobre fdf

Descripción

fdf_errno ( ) : int

Devuelve el código de error de la última llamada a una función FDF.

Puede obtenerse una descripción textual del error usando fdf_error().

Valores devueltos

Devuelve el código de error en forma de entero, o cero si no hubo errores.

Ver también

  • fdf_error() - Consultar la descripción de un código de error FDF


Consultar la descripción de un código de error FDF

  • « fdf_errno
  • fdf_get_ap »
  • PHP Manual
  • Funciones de FDF
  • Consultar la descripción de un código de error FDF

fdf_error

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_error — Consultar la descripción de un código de error FDF

Descripción

fdf_error ( int $error_code = -1 ) : string

Devuelve una descripción textual del código de error FDF de error_code.

Parámetros

error_code

Código de error obtenido con fdf_errno(). Si se omite, se utilizará el código de error interno que estableció la última operación.

Valores devueltos

Devuelve el mensaje de error en forma de string, o el texto no error si no hubo ningún error.

Ver también

  • fdf_errno() - Devuelve el código de error de la última operación sobre fdf


Consultar la publicación de un campo

  • « fdf_error
  • fdf_get_attachment »
  • PHP Manual
  • Funciones de FDF
  • Consultar la publicación de un campo

fdf_get_ap

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_ap — Consultar la publicación de un campo

Descripción

fdf_get_ap ( resource $fdf_document , string $field , int $face , string $filename ) : bool

Consulta la publicación de un field (es decir, el valor de la clave /AP) y lo almacena en un fichero.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

field

face

Los valores posibles son FDFNormalAP, FDFRolloverAP o FDFDownAP.

filename

Nombre del fichero en el que se guardará la publicación.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Extraer un fichero subido por FDF

  • « fdf_get_ap
  • fdf_get_encoding »
  • PHP Manual
  • Funciones de FDF
  • Extraer un fichero subido por FDF

fdf_get_attachment

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_attachment — Extraer un fichero subido por FDF

Descripción

fdf_get_attachment ( resource $fdf_document , string $fieldname , string $savepath ) : array

Extrae un fichero subido por medio del campo "selección de fichero" fieldname, y lo almacena en savepath.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

fieldname

savepath

Puede ser o bien el nombre de un fichero, o bien el de un directorio existente en el que creará usando el nombre original del fichero. Si hubiera algún otro fichero con ese nombre, se scobrescribiría.

Nota:

Aparentemente el único método para consultar el nombre original del fichero consiste en almacenar el archivo usando un directorio como savepath para después consultar el nombre (basename) con el que se guardó.

Valores devueltos

El array devuelto contiene los siguientes campos:

  • path - ruta donde se ha almacenado
  • size - tamaño del fichero en bytes
  • type - Si se proporcionó en el FDF, mimetype

Ejemplos

Ejemplo #1 Guardando un fichero subido por FDF

<?php
  $fdf = fdf_open_string($HTTP_FDF_DATA);
  $data = fdf_get_attachment($fdf, "filename", "/tmpdir");
  echo "El fichero subido se ha guardado en $data[path]";
?>


Consultar el valor de la clave /Encoding

  • « fdf_get_attachment
  • fdf_get_file »
  • PHP Manual
  • Funciones de FDF
  • Consultar el valor de la clave /Encoding

fdf_get_encoding

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_encoding — Consultar el valor de la clave /Encoding

Descripción

fdf_get_encoding ( resource $fdf_document ) : string

Consulta el valor de la clave /Encoding.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

Valores devueltos

Devuelve la codificación en forma de string. Si se utiliza el esquema por defecto default PDFDocEncoding/Unicode, se devuelve una cadena vacía.

Ver también

  • fdf_set_encoding() - Asignar codificación de caracteres de FDF


Obtener el valor de la clave /F

  • « fdf_get_encoding
  • fdf_get_flags »
  • PHP Manual
  • Funciones de FDF
  • Obtener el valor de la clave /F

fdf_get_file

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_file — Obtener el valor de la clave /F

Descripción

fdf_get_file ( resource $fdf_document ) : string

Obtiene el valor de la clave /F.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

Valores devueltos

Devuelve el valor de la clave, como una cadena.

Ver también

  • fdf_set_file() - Establecer el documento PDF en donde desplegar datos FDF


Consultar banderas de un campo

  • « fdf_get_file
  • fdf_get_opt »
  • PHP Manual
  • Funciones de FDF
  • Consultar banderas de un campo

fdf_get_flags

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_flags — Consultar banderas de un campo

Descripción

fdf_get_flags ( resource $fdf_document , string $fieldname , int $whichflags ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Consultar un valor del array de opciones de un campo

  • « fdf_get_flags
  • fdf_get_status »
  • PHP Manual
  • Funciones de FDF
  • Consultar un valor del array de opciones de un campo

fdf_get_opt

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECLv)

fdf_get_opt — Consultar un valor del array de opciones de un campo

Descripción

fdf_get_opt ( resource $fdf_document , string $fieldname , int $element = -1 ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Obtener el valor de la clave /STATUS

  • « fdf_get_opt
  • fdf_get_value »
  • PHP Manual
  • Funciones de FDF
  • Obtener el valor de la clave /STATUS

fdf_get_status

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_status — Obtener el valor de la clave /STATUS

Descripción

fdf_get_status ( resource $fdf_document ) : string

Obtiene el valor de la clave /STATUS.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

Valores devueltos

Devuelve el valor de la clave, como una cadena.

Ver también

  • fdf_set_status() - Establecer el valor de la clave /STATUS


Obtener el valor de un campo

  • « fdf_get_status
  • fdf_get_version »
  • PHP Manual
  • Funciones de FDF
  • Obtener el valor de un campo

fdf_get_value

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_value — Obtener el valor de un campo

Descripción

fdf_get_value ( resource $fdf_document , string $fieldname , int $which = -1 ) : mixed

Obtiene el valor del campo solicitado.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

fieldname

Nombre del campo FDF, como una cadena.

which

Los elementos de un campo tipo matriz pueden ser recuperados pasando este parámetro opcional, comenzando desde cero. Para campos que no son matrices, este parámetro será ignorado.

Valores devueltos

Devuelve el valor del campo.

Historial de cambios

Versión | Descripción
4.3.0 | El soporte para matrices y el parámetro cuales fue agregado.

Ver también

  • fdf_set_value() - Establecer el valor de un campo


Consulta el número de versión de la API o de un fichero FDF

  • « fdf_get_value
  • fdf_header »
  • PHP Manual
  • Funciones de FDF
  • Consulta el número de versión de la API o de un fichero FDF

fdf_get_version

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_version — Consulta el número de versión de la API o de un fichero FDF

Descripción

fdf_get_version ( resource $fdf_document = ? ) : string

Devuelve la versión FDF del documento dado, o bien el número de versión de la API si no se utilizó ningún parámetro.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

Valores devueltos

Devuelve la versión en forma de string. En el sistema FDF actual 5.0 el número de versión de la API es 5.0 y el número de versión de los documentos es o bien 1.2, 1.3 o 1.4.

Ver también

  • fdf_set_version() - Asignar número de versión a un fichero FDF


Establecer cabeceras de salida específicas de FDF

  • « fdf_get_version
  • fdf_next_field_name »
  • PHP Manual
  • Funciones de FDF
  • Establecer cabeceras de salida específicas de FDF

fdf_header

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVNf)

fdf_header — Establecer cabeceras de salida específicas de FDF

Descripción

fdf_header ( ) : void

Es una función apropiada para establecer cabeceras HTTP para salidas de FDF. Establece el Content-type: a application/vnd.fdf.

Valores devueltos

No devuelve ningún valor.


Obtener el siguiente nombre de campo

  • « fdf_header
  • fdf_open_string »
  • PHP Manual
  • Funciones de FDF
  • Obtener el siguiente nombre de campo

fdf_next_field_name

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_next_field_name — Obtener el siguiente nombre de campo

Descripción

fdf_next_field_name ( resource $fdf_document , string $fieldname = ? ) : string

Obtiene el nombre del campo siguiente al campo dado. Este nombre puede ser usado con varias funciones.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

fieldname

Nombre del campo FDF, como una cadena. Si no se define, se asumirá el primer campo.

Valores devueltos

Devuelve el nombre de campo como una cadena.

Ejemplos

Ejemplo #1 Detección de todos los nombres de campo en un FDF

<?php
$fdf = fdf_open($HTTP_FDF_DATA);
for ($campo = fdf_next_field_name($fdf);
    $campo != "";
    $campo = fdf_next_field_name($fdf, $campo)) {
    echo "campo: $campo\n";
}
?>

Ver también

  • fdf_get_value() - Obtener el valor de un campo


Consulta un documento FDF a partir de un string

  • « fdf_next_field_name
  • fdf_open »
  • PHP Manual
  • Funciones de FDF
  • Consulta un documento FDF a partir de un string

fdf_open_string

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_open_string — Consulta un documento FDF a partir de un string

Descripción

fdf_open_string ( string $fdf_data ) : resource

Consulta los datos de un formulario a partir de un string.

Puede usar fdf_open_string() junto con $HTTP_FDF_DATA para procesar un formulario de entrada FDF que procede de un equipo cliente remoto.

Parámetros

fdf_data

Datos tal y como los devolvió un formulario PDF, o como fueron creados al usar fdf_create() y fdf_save_string().

Valores devueltos

Devuelve un manejador de documentos FDF, o false en caso de error.

Ejemplos

Ejemplo #1 Accediendo a los datos de un formulario

<?php
$fdf = fdf_open_string($HTTP_FDF_DATA);
/* ... */
fdf_close($fdf);
?>

Ver también

  • fdf_open() - Abrir un documento FDF
  • fdf_close() - Cierra un documento FDF
  • fdf_create() - Crear un nuevo documento FDF
  • fdf_save_string() - Devuelve el documento FDF en forma de string


Abrir un documento FDF

  • « fdf_open_string
  • fdf_remove_item »
  • PHP Manual
  • Funciones de FDF
  • Abrir un documento FDF

fdf_open

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_open — Abrir un documento FDF

Descripción

fdf_open ( string $filename ) : resource

Abre un archivo con datos de formulario.

También es posible usar fdf_open_string() para procesar los resultados de una petición POST de formulario PDF.

Parámetros

filename

Ruta al archivo FDF. Este archivo debe contener los datos devueltos de un formulario PDF creado usando fdf_create() y fdf_save().

Valores devueltos

Devuelve un gestor de documento FDF, o false en caso de error.

Ejemplos

Ejemplo #1 Acceso a datos de formulario

<?php
// Guardar los datos FDF en un archivo temporal
$aa_fdf = fopen("prueba.fdf", "w");
fwrite($aa_fdf, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($aa_fdf);

// Abrir el archivo temporal y evaluar los datos
$fdf = fdf_open("prueba.fdf");
/* ... */
fdf_close($fdf);
?>

Ver también

  • fdf_open_string() - Consulta un documento FDF a partir de un string
  • fdf_close() - Cierra un documento FDF
  • fdf_create() - Crear un nuevo documento FDF
  • fdf_save() - Guardar un documento FDF


Asignar contenedor para el formulario

  • « fdf_open
  • fdf_save_string »
  • PHP Manual
  • Funciones de FDF
  • Asignar contenedor para el formulario

fdf_remove_item

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_remove_item — Asignar contenedor para el formulario

Descripción

fdf_remove_item ( resource $fdf_document , string $fieldname , int $item ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve el documento FDF en forma de string

  • « fdf_remove_item
  • fdf_save »
  • PHP Manual
  • Funciones de FDF
  • Devuelve el documento FDF en forma de string

fdf_save_string

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_save_string — Devuelve el documento FDF en forma de string

Descripción

fdf_save_string ( resource $fdf_document ) : string

Devuelve el documento FDF en forma de string.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

Valores devueltos

Devuelve el documento en forma de string, o false en caso de error.

Ejemplos

Ejemplo #1 Salvando un FDF como string

<?php
$fdf = fdf_create();
fdf_set_value($fdf, "foo", "bar");
$str = fdf_save_string($fdf);
fdf_close($fdf);
echo $str;
?>

El resultado del ejemplo sería:

%FDF-1.2
%âãÏÓ
1 0 obj
<<
/FDF << /Fields 2 0 R >>
>>
endobj
2 0 obj
[
<< /T (foo)/V (bar)>>
]
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

Ver también

  • fdf_open_string() - Consulta un documento FDF a partir de un string
  • fdf_close() - Cierra un documento FDF
  • fdf_create() - Crear un nuevo documento FDF
  • fdf_save() - Guardar un documento FDF


Guardar un documento FDF

  • « fdf_save_string
  • fdf_set_ap »
  • PHP Manual
  • Funciones de FDF
  • Guardar un documento FDF

fdf_save

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_save — Guardar un documento FDF

Descripción

fdf_save ( resource $fdf_document , string $filename = ? ) : bool

Guarda un documento FDF.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

filename

Si se define, el FDF resultante será escrito en este parámetro. De lo contrario, esta función escribirá el FDF en la secuencia de salida PHP predeterminada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_close() - Cierra un documento FDF
  • fdf_create() - Crear un nuevo documento FDF
  • fdf_save_string() - Devuelve el documento FDF en forma de string


Establecer la apariencia de un campo

  • « fdf_save
  • fdf_set_encoding »
  • PHP Manual
  • Funciones de FDF
  • Establecer la apariencia de un campo

fdf_set_ap

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_ap — Establecer la apariencia de un campo

Descripción

fdf_set_ap ( resource $fdf_document , string $field_name , int $face , string $filename , int $page_number ) : bool

Establece la apariencia de un campo (es decir, el valor de la clave /AP).

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

field_name

face

Los valores posibles son FDFNormalAP, FDFRolloverAP y FDFDownAP.

filename

page_number

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Asignar codificación de caracteres de FDF

  • « fdf_set_ap
  • fdf_set_file »
  • PHP Manual
  • Funciones de FDF
  • Asignar codificación de caracteres de FDF

fdf_set_encoding

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_encoding — Asignar codificación de caracteres de FDF

Descripción

fdf_set_encoding ( resource $fdf_document , string $encoding ) : bool

Establece la codificación de caracteres del documento FDF.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

encoding

Nombre de codicación. Los siguientes tipos están soportados: "Shift-JIS", "UHC", "GBK" y "BigFive".

Si se usa una cadena vacía, se restablecerá el esquema de codificación por omisión PDFDocEncoding/Unicode.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer el documento PDF en donde desplegar datos FDF

  • « fdf_set_encoding
  • fdf_set_flags »
  • PHP Manual
  • Funciones de FDF
  • Establecer el documento PDF en donde desplegar datos FDF

fdf_set_file

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_file — Establecer el documento PDF en donde desplegar datos FDF

Descripción

fdf_set_file ( resource $fdf_document , string $url , string $target_frame = ? ) : bool

Selecciona un documento PDF diferente para desplegar los resultados de formulario desde el formulario en donde se originaron.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

url

Debe ser una URL absoluta.

target_frame

Use este parámetro para especificar el marco en el cual desplegar el documento. También es posible definir el valor predeterminado para este parámetro usando fdf_set_target_frame().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Paso de datos FDF a un segundo formulario

<?php
  /* establecer tipo de contenido para Adobe FDF */
  fdf_header();

  /* iniciar nuevo fdf */
  $fdf = fdf_create();

  /* definir campo "foo" al valor "bar" */
  fdf_set_value($fdf, "foo", "bar");

  /* decir al cliente que despliegue datos FDF usando "formulario_fdf.pdf" */
  fdf_set_file($fdf, "http://www.example.com/formulario_fdf.pdf");

  /* producir salida fdf */
  fdf_save($fdf);

  /* limpiar */
  fdf_close($fdf);
?>

Ver también

  • fdf_get_file() - Obtener el valor de la clave /F
  • fdf_set_target_frame() - Definir contenedor en el que mostrar el formulario


Establecer banderas de un campo

  • « fdf_set_file
  • fdf_set_javascript_action »
  • PHP Manual
  • Funciones de FDF
  • Establecer banderas de un campo

fdf_set_flags

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_flags — Establecer banderas de un campo

Descripción

fdf_set_flags ( resource $fdf_document , string $fieldname , int $whichFlags , int $newFlags ) : bool

Establece determinadas banderas al campo proporcionado.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

fieldname

Nombre del campo FDF, en forma de string.

whichFlags

newFlags

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_set_opt() - Establecer una opción sobre un campo


Añadir una acción javascript a un campo

  • « fdf_set_flags
  • fdf_set_on_import_javascript »
  • PHP Manual
  • Funciones de FDF
  • Añadir una acción javascript a un campo

fdf_set_javascript_action

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_javascript_action — Añadir una acción javascript a un campo

Descripción

fdf_set_javascript_action ( resource $fdf_document , string $fieldname , int $trigger , string $script ) : bool

Añade una acción javascript al campo solicitado.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

fieldname

Nombre del campo FDF, en forma de string.

trigger

script

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_set_submit_form_action() - Asignar acción a un campo de formulario al enviarse


Añadir código javascript para ejecutar cuando Acrobat abra el FDF

  • « fdf_set_javascript_action
  • fdf_set_opt »
  • PHP Manual
  • Funciones de FDF
  • Añadir código javascript para ejecutar cuando Acrobat abra el FDF

fdf_set_on_import_javascript

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_on_import_javascript — Añadir código javascript para ejecutar cuando Acrobat abra el FDF

Descripción

fdf_set_on_import_javascript ( resource $fdf_document , string $script , bool $before_data_import ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Ver también

  • fdf_add_doc_javascript() - Añadir código javascript al documento FDF
  • fdf_set_javascript_action() - Añadir una acción javascript a un campo


Establecer una opción sobre un campo

  • « fdf_set_on_import_javascript
  • fdf_set_status »
  • PHP Manual
  • Funciones de FDF
  • Establecer una opción sobre un campo

fdf_set_opt

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_opt — Establecer una opción sobre un campo

Descripción

fdf_set_opt ( resource $fdf_document , string $fieldname , int $element , string $str1 , string $str2 ) : bool

Establece opciones sobre el campo solicitado.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

fieldname

Nombre del campo FDF, en forma de string.

element

str1

str2

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_set_flags() - Establecer banderas de un campo


Establecer el valor de la clave /STATUS

  • « fdf_set_opt
  • fdf_set_submit_form_action »
  • PHP Manual
  • Funciones de FDF
  • Establecer el valor de la clave /STATUS

fdf_set_status

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_status — Establecer el valor de la clave /STATUS

Descripción

fdf_set_status ( resource $fdf_document , string $status ) : bool

Establece el valor de la clave /STATUS. Cuando un cliente recibe un FDF con el campo status definido, el valor será presentado en una caja de alerta.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

status

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_get_status() - Obtener el valor de la clave /STATUS


Asignar acción a un campo de formulario al enviarse

  • « fdf_set_status
  • fdf_set_target_frame »
  • PHP Manual
  • Funciones de FDF
  • Asignar acción a un campo de formulario al enviarse

fdf_set_submit_form_action

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_submit_form_action — Asignar acción a un campo de formulario al enviarse

Descripción

fdf_set_submit_form_action ( resource $fdf_document , string $fieldname , int $trigger , string $script , int $flags ) : bool

Añade una acción al campo de formulario solicitado que se ejecutará al enviarse.

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

fieldname

Nombre del campo FDF, en forma de string.

trigger

script

flags

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_set_javascript_action() - Añadir una acción javascript a un campo


Definir contenedor en el que mostrar el formulario

  • « fdf_set_submit_form_action
  • fdf_set_value »
  • PHP Manual
  • Funciones de FDF
  • Definir contenedor en el que mostrar el formulario

fdf_set_target_frame

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_target_frame — Definir contenedor en el que mostrar el formulario

Descripción

fdf_set_target_frame ( resource $fdf_document , string $frame_name ) : bool

Define el contenedor en el que mostrar el PDF resultante definido en fdf_save_file().

Parámetros

fdf_document

Manejador de documentos FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

frame_name

Nombre del contenedor, en forma de string.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_save_file()


Establecer el valor de un campo

  • « fdf_set_target_frame
  • fdf_set_version »
  • PHP Manual
  • Funciones de FDF
  • Establecer el valor de un campo

fdf_set_value

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_value — Establecer el valor de un campo

Descripción

fdf_set_value ( resource $fdf_document , string $fieldname , mixed $value , int $isName = ? ) : bool

Establece el valor para el campo dado.

Parámetros

fdf_document

El gestor de documento FDF, devuelto por fdf_create(), fdf_open() o fdf_open_string().

fieldname

Nombre del campo FDF, como una cadena.

value

Este parámetro será almacenado como una cadena a menos que sea una matriz. En este caso todos los elementos de la matriz serán almacenados como una matriz de valores.

isName

Nota:

En versiones antiguas del conjunto de herramientas FDF, el último parámetro determinada si el valor del campo era convertido a un nombre PDF (= 1) o usado como cadena PDF (= 0).

Este valor ya no es usado en la versión actual, 5.0, del conjunto de herramientas. Por razones de compatibilidad, aun es soportado como un parámetro opcional desde PHP 4.3, pero ignorado internamente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
4.3.0 | El soporte para matrices en el parámetro value fue agregado.

Ver también

  • fdf_get_value() - Obtener el valor de un campo
  • fdf_remove_item() - Asignar contenedor para el formulario


Asignar número de versión a un fichero FDF

  • « fdf_set_value
  • GnuPG »
  • PHP Manual
  • Funciones de FDF
  • Asignar número de versión a un fichero FDF

fdf_set_version

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_version — Asignar número de versión a un fichero FDF

Descripción

fdf_set_version ( resource $fdf_document , string $version ) : bool

Asigna la version FDF al documento solicitado.

Algunas de las funcionalidades de las que suporta esta extensión sólo están disponibles para las últimas versiones de FDF.

Parámetros

fdf_document

Manejador de documentos de FDF, devuelto por fdf_create(), fdf_open() o por fdf_open_string().

version

Nombre de versión. En el sistema FDF actual 5.0, puede ser o bien 1.2, 1.3 o 1.4.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • fdf_get_version() - Consulta el número de versión de la API o de un fichero FDF


GNU Privacy Guard

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Firma de texto (clearsign)
  • Funciones de GnuPG
    • gnupg_adddecryptkey — Añade una llave para desencriptar
    • gnupg_addencryptkey — Añade una llave para encriptar
    • gnupg_addsignkey — Añade una llave para firmar
    • gnupg_cleardecryptkeys — Elimina todas las llaves establecidas anteriormente para desencriptar
    • gnupg_clearencryptkeys — Elimina todas las llaves establecidas anteriormente paraencriptar
    • gnupg_clearsignkeys — Elimina todas las llaves establecidas anteriormente para firmar
    • gnupg_decrypt — Desencripta un texto dado
    • gnupg_decryptverify — Desencripta y verifica un texto dado
    • gnupg_encrypt — Encripta el texto dado
    • gnupg_encryptsign — Encripta y firma un texto dado
    • gnupg_export — Exporta una llave
    • gnupg_geterror — Retorna el texto de error si una función falla
    • gnupg_getprotocol — Retorna el protocolo activo actualmente para todas las operaciones
    • gnupg_import — Importa una llave
    • gnupg_init — Inicializa una conexión
    • gnupg_keyinfo — Retorna un array con información sobre todas las llaves que coinciden con un patrón dado
    • gnupg_setarmor — Activa o desactiva la salida blindada
    • gnupg_seterrormode — Fija el modo para error_reporting
    • gnupg_setsignmode — Fija el modo para firmar
    • gnupg_sign — Firma un texto dado
    • gnupg_verify — Verifica un texto firmado


  • « GnuPG
  • Instalación/Configuración »
  • PHP Manual
  • GnuPG
  • Introducción

Introducción

Este módulo permite interactuar con » gnupg.


Requerimientos

La extensión gnupg requiere PHP 4.3. Para usar esta extensión con orientación de objetos (OO), se requiere PHP5.

Esta extensión requiere la » librería gpgme


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/gnupg.


Constantes predefinidas

GNUPG_SIG_MODE_NORMAL (integer)
GNUPG_SIG_MODE_DETACH (integer)
GNUPG_SIG_MODE_CLEAR (integer)
GNUPG_VALIDITY_UNKNOWN (integer)
GNUPG_VALIDITY_UNDEFINED (integer)
GNUPG_VALIDITY_NEVER (integer)
GNUPG_VALIDITY_MARGINAL (integer)
GNUPG_VALIDITY_FULL (integer)
GNUPG_VALIDITY_ULTIMATE (integer)
GNUPG_PROTOCOL_OpenPGP (integer)
GNUPG_PROTOCOL_CMS (integer)
GNUPG_SIGSUM_VALID (integer)
GNUPG_SIGSUM_GREEN (integer)
GNUPG_SIGSUM_RED (integer)
GNUPG_SIGSUM_KEY_REVOKED (integer)
GNUPG_SIGSUM_KEY_EXPIRED (integer)
GNUPG_SIGSUM_KEY_MISSING (integer)
GNUPG_SIGSUM_SIG_EXPIRED (integer)
GNUPG_SIGSUM_CRL_MISSING (integer)
GNUPG_SIGSUM_CRL_TOO_OLD (integer)
GNUPG_SIGSUM_BAD_POLICY (integer)
GNUPG_SIGSUM_SYS_ERROR (integer)
GNUPG_ERROR_WARNING (integer)
GNUPG_ERROR_EXCEPTION (integer)
GNUPG_ERROR_SILENT (integer)


  • « Constantes predefinidas
  • Firma de texto (clearsign) »
  • PHP Manual
  • GnuPG
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Firma de texto (clearsign)


Firma de texto (clearsign)

Ejemplo que firma un texto dado.

Ejemplo #1 Ejemplo de firma (clearsign) gnupg mediante funciones

<?php
// Inicializamos gnupg
$res = gnupg_init();
// Esto realmente no es necesario, clearsign es el valor por defecto
gnupg_setsignmode($res,GNUPG_SIG_MODE_CLEAR);
// Añade clave con la contraseña 'test' para firmar
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
// Firma
$signed = gnupg_sign($res,"just a test");
echo $signed;
?>

Ejemplo #2 Ejemplo de firma gnupg (clearsign) mediante orientación a objetos

<?php
// Instanciamos la clase
$gnupg = new gnupg();
// Esto realmente no es necesario, clearsign es el valor por defecto
$gnupg->setsignmode(gnupg::SIG_MODE_CLEAR);
// Añade clave con la contraseña 'test' para firmar
$gnupg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
// Firma
$signed = $gnupg->sign("just a test");
echo $signed;
?>

Ejemplo #3 keylistiterator

Esta extensión trae también un Iterator para un juego de claves

<?php
// Crea un nuevo Iterator para listar todas las claves públicas que coinciden
// con 'example'
$iterator = new gnupg_keylistiterator("example");
foreach($iterator as $fingerprint => $userid){
    echo $fingerprint." -> ".$userid."\n";
}
?>


Funciones de GnuPG

Notas

Esta extensión hace uso del llavero de claves del usuario actual. Este llavero generalmente se encuentra en ~./.gnupg/. Para especificar una localización diferente, almacenar el path en la variable de entorno GNUPGHOME. Ver putenv para más información sobre cómo realizarlo.

Algunas funciones requieren especificar alguna clave. Se puede espeficicar mediante cualquiera cosa que se refiera a una clave única (userid, key-id, fingerprint, ...). Esta documentación usa el fingerprint para todos los ejemplos.

Tabla de contenidos

  • gnupg_adddecryptkey — Añade una llave para desencriptar
  • gnupg_addencryptkey — Añade una llave para encriptar
  • gnupg_addsignkey — Añade una llave para firmar
  • gnupg_cleardecryptkeys — Elimina todas las llaves establecidas anteriormente para desencriptar
  • gnupg_clearencryptkeys — Elimina todas las llaves establecidas anteriormente paraencriptar
  • gnupg_clearsignkeys — Elimina todas las llaves establecidas anteriormente para firmar
  • gnupg_decrypt — Desencripta un texto dado
  • gnupg_decryptverify — Desencripta y verifica un texto dado
  • gnupg_encrypt — Encripta el texto dado
  • gnupg_encryptsign — Encripta y firma un texto dado
  • gnupg_export — Exporta una llave
  • gnupg_geterror — Retorna el texto de error si una función falla
  • gnupg_getprotocol — Retorna el protocolo activo actualmente para todas las operaciones
  • gnupg_import — Importa una llave
  • gnupg_init — Inicializa una conexión
  • gnupg_keyinfo — Retorna un array con información sobre todas las llaves que coinciden con un patrón dado
  • gnupg_setarmor — Activa o desactiva la salida blindada
  • gnupg_seterrormode — Fija el modo para error_reporting
  • gnupg_setsignmode — Fija el modo para firmar
  • gnupg_sign — Firma un texto dado
  • gnupg_verify — Verifica un texto firmado


Añade una llave para desencriptar

  • « Funciones de GnuPG
  • gnupg_addencryptkey »
  • PHP Manual
  • Funciones de GnuPG
  • Añade una llave para desencriptar

gnupg_adddecryptkey

(PECL gnupg >= 0.5)

gnupg_adddecryptkey — Añade una llave para desencriptar

Descripción

gnupg_adddecryptkey ( resource $identifier , string $fingerprint , string $passphrase ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

fingerprint

La clave fingerprint.

passphrase

La contraseña de paso.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_adddecryptkey() mediante funciones

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Ejemplo #2 Ejemplo de gnupg_adddecryptkey() mediante OO

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>


Añade una llave para encriptar

  • « gnupg_adddecryptkey
  • gnupg_addsignkey »
  • PHP Manual
  • Funciones de GnuPG
  • Añade una llave para encriptar

gnupg_addencryptkey

(PECL gnupg >= 0.5)

gnupg_addencryptkey — Añade una llave para encriptar

Descripción

gnupg_addencryptkey ( resource $identifier , string $fingerprint ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

fingerprint

La clave fingerprint.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_addencryptkey() mediante funciones

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
?>

Ejemplo #2 Ejemplo de gnupg_addencryptkey() mediante OO

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
?>


Añade una llave para firmar

  • « gnupg_addencryptkey
  • gnupg_cleardecryptkeys »
  • PHP Manual
  • Funciones de GnuPG
  • Añade una llave para firmar

gnupg_addsignkey

(PECL gnupg >= 0.5)

gnupg_addsignkey — Añade una llave para firmar

Descripción

gnupg_addsignkey ( resource $identifier , string $fingerprint , string $passphrase = ? ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

fingerprint

La clave fingerprint.

passphrase

La contraseña.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_addsignkey() mediante funciones

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Ejemplo #2 Ejemplo de gnupg_addsignkey() mediante OO

<?php
$gpg = new gnupg();
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>


Elimina todas las llaves establecidas anteriormente para desencriptar

  • « gnupg_addsignkey
  • gnupg_clearencryptkeys »
  • PHP Manual
  • Funciones de GnuPG
  • Elimina todas las llaves establecidas anteriormente para desencriptar

gnupg_cleardecryptkeys

(PECL gnupg >= 0.5)

gnupg_cleardecryptkeys — Elimina todas las llaves establecidas anteriormente para desencriptar

Descripción

gnupg_cleardecryptkeys ( resource $identifier ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_cleardecryptkeys() mediante funciones

<?php
$res = gnupg_init();
gnupg_cleardecryptkeys($res);
?>

Ejemplo #2 Ejemplo de gnupg_cleardecryptkeys() mediante OO

<?php
$gpg = new gnupg();
$gpg -> cleardecryptkeys();
?>


Elimina todas las llaves establecidas anteriormente paraencriptar

  • « gnupg_cleardecryptkeys
  • gnupg_clearsignkeys »
  • PHP Manual
  • Funciones de GnuPG
  • Elimina todas las llaves establecidas anteriormente paraencriptar

gnupg_clearencryptkeys

(PECL gnupg >= 0.5)

gnupg_clearencryptkeys — Elimina todas las llaves establecidas anteriormente paraencriptar

Descripción

gnupg_clearencryptkeys ( resource $identifier ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_clearencryptkeys() mediante funciones

<?php
$res = gnupg_init();
gnupg_clearencryptkeys($res);
?>

Ejemplo #2 Ejemplo de gnupg_clearencryptkeys() mediante OO

<?php
$gpg = new gnupg();
$gpg -> clearencryptkeys();
?>


Elimina todas las llaves establecidas anteriormente para firmar

  • « gnupg_clearencryptkeys
  • gnupg_decrypt »
  • PHP Manual
  • Funciones de GnuPG
  • Elimina todas las llaves establecidas anteriormente para firmar

gnupg_clearsignkeys

(PECL gnupg >= 0.5)

gnupg_clearsignkeys — Elimina todas las llaves establecidas anteriormente para firmar

Descripción

gnupg_clearsignkeys ( resource $identifier ) : bool

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_clearsignkeys() mediante funciones

<?php
$res = gnupg_init();
gnupg_clearsignkeys($res);
?>

Ejemplo #2 Ejemplo de gnupg_clearsignkeys() mediante OO

<?php
$gpg = new gnupg();
$gpg -> clearsignkeys();
?>


Desencripta un texto dado

  • « gnupg_clearsignkeys
  • gnupg_decryptverify »
  • PHP Manual
  • Funciones de GnuPG
  • Desencripta un texto dado

gnupg_decrypt

(PECL gnupg >= 0.1)

gnupg_decrypt — Desencripta un texto dado

Descripción

gnupg_decrypt ( resource $identifier , string $text ) : string

Desencripta un texto dado con las claves, establecidas anteriormente con gnupg_adddecryptkey.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

text

El texto a ser desencriptado.

Valores devueltos

En caso de éxito, esta función retorna el texto desencriptado. En caso de fallo, la función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_decrypt() mediante funciones

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = gnupg_decrypt($res,$encrypted_text);
echo $plain;
?>

Ejemplo #2 Ejemplo de gnupg_encrypt() mediante OO

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = $gpg -> decrypt($encrypted_text);
echo $plain;
?>


Desencripta y verifica un texto dado

  • « gnupg_decrypt
  • gnupg_encrypt »
  • PHP Manual
  • Funciones de GnuPG
  • Desencripta y verifica un texto dado

gnupg_decryptverify

(PECL gnupg >= 0.2)

gnupg_decryptverify — Desencripta y verifica un texto dado

Descripción

gnupg_decryptverify ( resource $identifier , string $text , string &$plaintext ) : array

Desencripta y verifica un texto dado y retorna información sobre la firma.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

text

El texto a ser desencriptado.

plaintext

El parámetro plaintext se rellena con el texto desencriptado.

Valores devueltos

En caso de éxito, esta función retorna información sobra la firma y rellena el parámetro plaintext con el texto desencriptado. En caso de fallo, esta función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_decryptverify() mediante funciones

<?php
$plaintext = "";
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = gnupg_decryptverify($res,$text,$plaintext);
print_r($info);
?>

Ejemplo #2 Ejemplo de gnupg_decryptverify() mediante OO

<?php
$plaintext = "";
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = $gpg -> decryptverify($text,$plaintext);
print_r($info);
?>


Encripta el texto dado

  • « gnupg_decryptverify
  • gnupg_encryptsign »
  • PHP Manual
  • Funciones de GnuPG
  • Encripta el texto dado

gnupg_encrypt

(PECL gnupg >= 0.1)

gnupg_encrypt — Encripta el texto dado

Descripción

gnupg_encrypt ( resource $identifier , string $plaintext ) : string

Encripta el parámetro plaintext con las llaves que se han indicado anteriormente mediante gnupg_addencryptkey y retrona el texto encriptado.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

plaintext

El texto a ser encriptado.

Valores devueltos

En caso de éxito, la función retorna el texto encriptado. En caso de fallo, la función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_encrypt() mediante funciones

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
$enc = gnupg_encrypt($res, "just a test");
echo $enc;
?>

Ejemplo #2 Ejemplo de gnupg_encrypt() mediante OO

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$enc = $gpg -> encrypt("just a test");
echo $enc;
?>


Encripta y firma un texto dado

  • « gnupg_encrypt
  • gnupg_export »
  • PHP Manual
  • Funciones de GnuPG
  • Encripta y firma un texto dado

gnupg_encryptsign

(PECL gnupg >= 0.2)

gnupg_encryptsign — Encripta y firma un texto dado

Descripción

gnupg_encryptsign ( resource $identifier , string $plaintext ) : string

Encripta y firma el parámetro plaintext con las llaves que se an indicado anteriormente mediante gnupg_addsignkey y gnupg_addencryptkey y retorna el texto encriptado y firmado.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

plaintext

El texto a ser encriptado.

Valores devueltos

En caso de éxito, esta función retorna el texto encriptado y firmado. En caso de fallo, esta función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_encryptsign() mediante funciones

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = gnupg_encryptsign($res, "just a test");
echo $enc;
?>

Ejemplo #2 Ejemplo de gnupg_encryptsign() mediante OO

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = $gpg -> encryptsign("just a test");
echo $enc;
?>


Exporta una llave

  • « gnupg_encryptsign
  • gnupg_geterror »
  • PHP Manual
  • Funciones de GnuPG
  • Exporta una llave

gnupg_export

(PECL gnupg >= 0.1)

gnupg_export — Exporta una llave

Descripción

gnupg_export ( resource $identifier , string $fingerprint ) : string

Exporta la llave fingerprint.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

fingerprint

La clave fingerprint.

Valores devueltos

En caso de éxito, esta función retorna los datos de la llave. En caso de error, retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_export() mediante funciones

<?php
$res = gnupg_init();
$export = gnupg_export($res,"8660281B6051D071D94B5B230549F9DC851566DC");
echo $export;
?>

Ejemplo #2 Ejemplo de gnupg_export() mediante OO

<?php
$gpg = new gnupg();
$export = $gpg -> export("8660281B6051D071D94B5B230549F9DC851566DC");
?>


Retorna el texto de error si una función falla

  • « gnupg_export
  • gnupg_getprotocol »
  • PHP Manual
  • Funciones de GnuPG
  • Retorna el texto de error si una función falla

gnupg_geterror

(PECL gnupg >= 0.1)

gnupg_geterror — Retorna el texto de error si una función falla

Descripción

gnupg_geterror ( resource $identifier ) : string

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

Valores devueltos

Retorna el texto de error si hay un fallo en las funciones, o false en cualquier otro caso.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_geterror() mediante funciones

<?php
$res = gnupg_init();
echo gnupg_geterror($res);
?>

Ejemplo #2 Ejemplo de gnupg_geterror() mediante OO

<?php
$gpg = new gnupg();
echo $gpg -> geterror();
?>


Retorna el protocolo activo actualmente para todas las operaciones

  • « gnupg_geterror
  • gnupg_import »
  • PHP Manual
  • Funciones de GnuPG
  • Retorna el protocolo activo actualmente para todas las operaciones

gnupg_getprotocol

(PECL gnupg >= 0.1)

gnupg_getprotocol — Retorna el protocolo activo actualmente para todas las operaciones

Descripción

gnupg_getprotocol ( resource $identifier ) : int

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

Valores devueltos

Retorna el protocolo activo actualmente que puede ser uno de los siguientes: GNUPG_PROTOCOL_OpenPGP o GNUPG_PROTOCOL_CMS.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_getprotocol() mediante funciones

<?php
$res = gnupg_init();
echo gnupg_getprotocol($res);
?>

Ejemplo #2 Ejemplo de gnupg_getprotocol() mediante

<?php
$gpg = new gnupg();
echo $gpg -> getprotocol();
?>


Importa una llave

  • « gnupg_getprotocol
  • gnupg_init »
  • PHP Manual
  • Funciones de GnuPG
  • Importa una llave

gnupg_import

(PECL gnupg >= 0.3)

gnupg_import — Importa una llave

Descripción

gnupg_import ( resource $identifier , string $keydata ) : array

Importa la llave keydata y retorna un array con la información sobre el proceso de importación.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

keydata

Los datos de la llave que se va a importar.

Valores devueltos

En caso de éxito, esta función retorna un array con la información sobre el proceso de importación. En caso de fallo, esta función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_import() mediante funciones

<?php
$res = gnupg_init();
$info = gnupg_import($res,$keydata);
print_r($info);
?>

Ejemplo #2 Ejemplo de gnupg_import() mediante OO

<?php
$gpg = new gnupg();
$info = $gpg -> import($keydata);
print_r($info);
?>


Inicializa una conexión

  • « gnupg_import
  • gnupg_keyinfo »
  • PHP Manual
  • Funciones de GnuPG
  • Inicializa una conexión

gnupg_init

(PECL gnupg >= 0.4)

gnupg_init — Inicializa una conexión

Descripción

gnupg_init ( ) : resource

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una conexión de tipo GnuPG resource usada por otras funciones GnuPG.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_init() mediante funciones

<?php
$res = gnupg_init();
?>

Ejemplo #2 Ejemplo del inicializador gnupg mediante OO

<?php
$gpg = new gnupg();
?>


Retorna un array con información sobre todas las llaves que coinciden con un patrón dado

  • « gnupg_init
  • gnupg_setarmor »
  • PHP Manual
  • Funciones de GnuPG
  • Retorna un array con información sobre todas las llaves que coinciden con un patrón dado

gnupg_keyinfo

(PECL gnupg >= 0.1)

gnupg_keyinfo — Retorna un array con información sobre todas las llaves que coinciden con un patrón dado

Descripción

gnupg_keyinfo ( resource $identifier , string $pattern ) : array

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

pattern

El patrón a comprobar contra la llave.

Valores devueltos

Retorna un array con información sobre todas las llaves que coinciden con un patrón dado o false si ocurre un error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_keyinfo() mediante funciones

<?php
$res = gnupg_init();
$info = gnupg_keyinfo($res, 'test');
print_r($info);
?>

Ejemplo #2 Ejemplo de gnupg_keyinfo() mediante OO

<?php
$gpg = new gnupg();
$info = $gpg -> keyinfo("test");
print_r($info);
?>


Activa o desactiva la salida blindada

  • « gnupg_keyinfo
  • gnupg_seterrormode »
  • PHP Manual
  • Funciones de GnuPG
  • Activa o desactiva la salida blindada

gnupg_setarmor

(PECL gnupg >= 0.1)

gnupg_setarmor — Activa o desactiva la salida blindada

Descripción

gnupg_setarmor ( resource $identifier , int $armor ) : bool

Activa o desactiva la salida blindada.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

armor

Cualquiera valor entero que no sea cero a esta función activa la salida blindada (por defecto). Si se pasa 0, se desactiva la salida blindada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_setarmor() mediante funciones

<?php
$res = gnupg_init();
gnupg_setarmor($res,1); // Activa la salida blindada
gnupg_setarmor($res,0); // Desactiva la salida blindada
?>

Ejemplo #2 Ejemplo de gnupg_setarmor() mediante OO

<?php
$gpg = new gnupg();
$gpg -> setarmor(1); // Activa la salida blindada
$gpg -> setarmor(0); // Desactiva la salida blindada
?>


Fija el modo para error_reporting

  • « gnupg_setarmor
  • gnupg_setsignmode »
  • PHP Manual
  • Funciones de GnuPG
  • Fija el modo para error_reporting

gnupg_seterrormode

(PECL gnupg >= 0.6)

gnupg_seterrormode — Fija el modo para error_reporting

Descripción

gnupg_seterrormode ( resource $identifier , int $errormode ) : void

Fija el modo para error_reporting.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

errormode

El modo de error.

errormode toma el valor de una constante indicando qué tipo de error_reporting debe ser usado. Los posibles valores son: GNUPG_ERROR_WARNING, GNUPG_ERROR_EXCEPTION y GNUPG_ERROR_SILENT. Por defecto se usa GNUPG_ERROR_SILENT.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Pejemplo de gnupg_seterrormode() mediante funciones

<?php
$res = gnupg_init();
gnupg_seterrormode($res,GNUPG_ERROR_WARNING); // lanza un PHP-Warning en caso de error
?>

Ejemplo #2 Ejemplo de gnupg_seterrormode() mediante OO

<?php
$gpg = new gnupg();
$gpg -> seterrormode(gnupg::ERROR_EXCEPTION); // lanza una excepción en caso de error
?>


Fija el modo para firmar

  • « gnupg_seterrormode
  • gnupg_sign »
  • PHP Manual
  • Funciones de GnuPG
  • Fija el modo para firmar

gnupg_setsignmode

(PECL gnupg >= 0.1)

gnupg_setsignmode — Fija el modo para firmar

Descripción

gnupg_setsignmode ( resource $identifier , int $signmode ) : bool

Fija el modo para firmar.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

sigmode

El modo para firmar.

signmode toma el valor de una constante indicando qué tipo de firma debería producirse. Los posibles valores son: GNUPG_SIG_MODE_NORMAL, GNUPG_SIG_MODE_DETACH y GNUPG_SIG_MODE_CLEAR. Por defecto se usa GNUPG_SIG_MODE_CLEAR.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_setsignmode() mediante funciones

<?php
$res = gnupg_init();
gnupg_setsignmode($res,GNUPG_SIG_MODE_DETACH); // produce una firma separada
?>

Ejemplo #2 Ejemplo de gnupg_setsignmode() mediante OO

<?php
$gpg = new gnupg();
$gpg -> setsignmode(gnupg::SIG_MODE_DETACH); // produce una firma separada
?>


Firma un texto dado

  • « gnupg_setsignmode
  • gnupg_verify »
  • PHP Manual
  • Funciones de GnuPG
  • Firma un texto dado

gnupg_sign

(PECL gnupg >= 0.1)

gnupg_sign — Firma un texto dado

Descripción

gnupg_sign ( resource $identifier , string $plaintext ) : string

Firma plaintext con las llaves que se han indicado anteriormente con gnupg_addsignkey y retorna el texto firmado o la firma, dependiendo de lo que se haya indicado en gnupg_setsignmode.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

plaintext

El texto a ser firmado.

Valores devueltos

En caso de éxito, esta función retorna el texto firmado o la firma. En caso de fallo, esta función retorna false

Ejemplos

Ejemplo #1 Ejemplo de gnupg_sign() mediante funciones

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = gnupg_sign($res, "just a test");
echo $signed;
?>

Ejemplo #2 Ejemplo de gnupg_sign() mediante OO

<?php
$gpg = new gnupg();
$gpg -> setsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = $gpg -> sign("just a test");
echo $signed;
?>


Verifica un texto firmado

  • « gnupg_sign
  • wkhtmltox »
  • PHP Manual
  • Funciones de GnuPG
  • Verifica un texto firmado

gnupg_verify

(PECL gnupg >= 0.1)

gnupg_verify — Verifica un texto firmado

Descripción

gnupg_verify ( resource $identifier , string $signed_text , string $signature , string &$plaintext = ? ) : array

Verifica el texto dado en signed_text y retorna información sobre la firma.

Parámetros

identifier

El identificador gnupg, desde una llamada a gnupg_init() o gnupg.

signed_text

El texto firmado.

signature

La firma. Para verificar un texto firmado, indicar el valor false.

plaintext

El texto plano. Si se indica este parámetro opcional, se rellena con el texto.

Valores devueltos

En caso de éxito, esta función retorna información sobre la firma. En caso de fallo, esta función retorna false.

Ejemplos

Ejemplo #1 Ejemplo de gnupg_verify() mediante funciones

<?php
$plaintext = "";
$res = gnupg_init();
// firmado
$info = gnupg_verify($res,$signed_text,false,$plaintext);
print_r($info);
// firma separada
$info = gnupg_verify($res,$signed_text,$signature);
print_r($info);
?>

Ejemplo #2 Ejemplo de gnupg_verify() mediante OO

<?php
$plaintext = "";
$gpg = new gnupg();
// firmado
$info = $gpg -> verify($signed_text,false,$plaintext);
print_r($info);
// firma separada
$info = $gpg -> verify($signed_text,$signature);
print_r($info);
?>


wkhtmltox

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • wkhtmltox\PDF\Converter — La clase wkhtmltox\PDF\Converter
    • wkhtmltox\PDF\Converter::add — Añade un objeto para su conversión
    • wkhtmltox\PDF\Converter::__construct — Create a new PDF converter
    • wkhtmltox\PDF\Converter::convert — Realiza la conversión a PDF
    • wkhtmltox\PDF\Converter::getVersion — Determina la versión del convertidor
  • wkhtmltox\PDF\Object — La clase wkhtmltox\PDF\Object
    • wkhtmltox\PDF\Object::__construct — Create a new PDF Object
  • wkhtmltox\Image\Converter — La clase wkhtmltox\Image\Converter
    • wkhtmltox\Image\Converter::__construct — Create a new Image converter
    • wkhtmltox\Image\Converter::convert — Realiza la conversión de la imagen
    • wkhtmltox\Image\Converter::getVersion — Determina la versión del convertidor


Introducción

libwkhtmltox es una librería LGPLv3 de código abierto para renderizar HTML en PDF y varios formatos de imagen usando el motor de renderización QtWebKit.


Requerimientos

La fuente de libwkhtmltox y las liberaciones binarias se distribuyen en » wkhtmltopdf.org.

Precaución

Los usuarios de Windows necesitan dar el paso adicional de añadir wkhtmltox.dll a su PATH.


Instalación

El código fuente de esta extensión, y los binarios para Windows están alojados en » github,

Buscando el código fuente y construyendo la extensión:

git clone https://github.com/krakjoe/wkhtmltox
cd wkhtmltox
phpize
./configure --with-wkhtmltox=/path/to/wkhtmltox/installation
make
sudo make install

Buscando actualizaciones y reconstruyendo la extensión:

cd wkhtmltox
phpize --clean
git pull origin master
phpize
./configure --with-wkhtmltox=/path/to/wkhtmltox/installation
make
sudo make install


Configuración en tiempo de ejecución

Nombre | Descripción | Por defecto | Etapa | Changelog
wkhtmltox.graphics | permite a libwkhtmltox usar gráficos | Off | PHP_INI_SYSTEM | PHP_INI_PERDIR | >= 0.3.2


La clase wkhtmltox\PDF\Converter

(wkhtmltox >= 0.1.0)

Introducción

Convierte una entrada HTML, o un conjunto de entradas HTML, en una salida PDF

Sinopsis de la Clase

wkhtmltox\PDF\Converter {
/* Constructor */
public __construct ( array $settings = ? )
/* Métodos */
public add ( wkhtmltox\PDF\Object $object ) : void
public convert ( ) : ?string
public getVersion ( ) : string
}

Tabla de contenidos

  • wkhtmltox\PDF\Converter::add — Añade un objeto para su conversión
  • wkhtmltox\PDF\Converter::__construct — Create a new PDF converter
  • wkhtmltox\PDF\Converter::convert — Realiza la conversión a PDF
  • wkhtmltox\PDF\Converter::getVersion — Determina la versión del convertidor


Añade un objeto para su conversión

  • « wkhtmltox\PDF\Converter
  • wkhtmltox\PDF\Converter::__construct »
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Añade un objeto para su conversión

wkhtmltox\PDF\Converter::add

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::add — Añade un objeto para su conversión

Descripción

public wkhtmltox\PDF\Converter::add ( wkhtmltox\PDF\Object $object ) : void

Añade el objeto dado a la conversión

Parámetros

object

El objeto a añadir


Create a new PDF converter

  • « wkhtmltox\PDF\Converter::add
  • wkhtmltox\PDF\Converter::convert »
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Create a new PDF converter

wkhtmltox\PDF\Converter::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::__construct — Create a new PDF converter

Descripción

public wkhtmltox\PDF\Converter::__construct ( array $settings = ? )

Creates a PDF converter, using optional configuration settings

Parámetros

settings

Name | Description | Values | Changelog
size.pageSize | paper size of output document | A4 | >= 0.1.0
size.width | with of the output document | 210mm | >= 0.1.0
size.height | height of the output document | 297mm | >= 0.1.0
orientation orientation of the output document
Landscape
Portrait
>= 0.1.0
colorMode color mode of the output document
Color
Greyscale
>= 0.1.0
resolution | resoluition of the output document | most likely has no effect | >= 0.1.0
dpi | dpi to use while printing | 80 | >= 0.1.0
pageOffset | integer added to page numbers generating headers, footers, and toc | >= 0.1.0
copies | >= 0.1.0
collate | collate copies | boolean | >= 0.1.0
outline | generate PDF outline | boolean | >= 0.1.0
outlineDepth | maximum depth of outline | >= 0.1.0
dumpOutline | path of file to dump outline XML | >= 0.1.0
out | path of output file, if "-" stdout is used | >= 0.1.0
documentTitle | title for the output document | >= 0.1.0
useCompression | enable or disable lossless compression | boolean | >= 0.1.0
margin.top | size of the top margin | 2cm | >= 0.1.0
margin.bottom | size of the bottom margin | 2cm | >= 0.1.0
margin.left | size of the left margin | 2cm | >= 0.1.0
margin.right | size of the right margin | 2cm | >= 0.1.0
imageDPI | maximum DPI for images in the output document | >= 0.1.0
imageQuality | the jpeg compression factor for images in the output document | 94 | >= 0.1.0
load.cookieJar | path of file used to load and store cookies | /tmp/cookies.txt | >= 0.1.0


Realiza la conversión a PDF

  • « wkhtmltox\PDF\Converter::__construct
  • wkhtmltox\PDF\Converter::getVersion »
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Realiza la conversión a PDF

wkhtmltox\PDF\Converter::convert

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::convert — Realiza la conversión a PDF

Descripción

public wkhtmltox\PDF\Converter::convert ( ) : ?string

Realiza la conversión de todos los objetos añadidos anteriormente

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Donde se utiliza el valor de retorno, se llenará con el contenido del buffer de conversión


Determina la versión del convertidor

  • « wkhtmltox\PDF\Converter::convert
  • wkhtmltox\PDF\Object »
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Determina la versión del convertidor

wkhtmltox\PDF\Converter::getVersion

(wkhtmltox >= 0.3.2)

wkhtmltox\PDF\Converter::getVersion — Determina la versión del convertidor

Descripción

public wkhtmltox\PDF\Converter::getVersion ( ) : string

Determina la versión del convertidor según lo informado por libwkhtmltox

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string de versión


La clase wkhtmltox\PDF\Object

(wkhtmltox >= 0.1.0)

Introducción

Representa un documento HTML, convertidor de entrada a PDF

Sinopsis de la Clase

wkhtmltox\PDF\Object {
/* Constructor */
public __construct ( string $buffer , array $settings = ? )
}

Tabla de contenidos

  • wkhtmltox\PDF\Object::__construct — Create a new PDF Object


Create a new PDF Object

  • « wkhtmltox\PDF\Object
  • wkhtmltox\Image\Converter »
  • PHP Manual
  • wkhtmltox\PDF\Object
  • Create a new PDF Object

wkhtmltox\PDF\Object::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Object::__construct — Create a new PDF Object

Descripción

public wkhtmltox\PDF\Object::__construct ( string $buffer , array $settings = ? )

Creates a new PDF Object from the given buffer and optional configuration settings

Parámetros

buffer

HTML

settings

Name | Description | Values | Changelog
page | URL or path of the HTML to convert | >= 0.1.0
useExternalLinks | set true to convert external links in the input into external PDF links in the output | boolean | >= 0.1.0
useLocalLinks | set true to convert internal links in the input into internal PDF links in the output | boolean | >= 0.1.0
produceForms | set true to turn HTML forms into PDF forms | boolean | >= 0.1.0
replacements | undocumented | >= 0.1.0
includeInOutline | set true to include sections from this object in the outline and toc | boolean | >= 0.1.0
pagesCount | set true to make page count in toc inclusive of the number of pages in this object | boolean | >= 0.1.0
tocXsl | set to style sheet to convert this object into a toc object | >= 0.1.0
toc.useDottedLines | set true to use dotted lines in toc | boolean | >= 0.1.0
toc.captionText | the caption text for toc | >= 0.1.0
toc.forwardLinks | set true to create links from toc to content | boolean | >= 0.1.0
toc.backLinks | set true to create links from content to toc | boolean | >= 0.1.0
toc.indentation | indentation for toc | 2em | >= 0.1.0
toc.fontScale | the factor to scale down the font at every toc level | 0.8 | >= 0.1.0
header.fontSize | font size for use in header | 13 | >= 0.1.0
header.fontName | name of font for use in header | times | >= 0.1.0
header.left | text for left of header | >= 0.1.0
header.center | text for center of header | >= 0.1.0
header.right | text for right of header | >= 0.1.0
header.line | enable or disable horizontal rule under header | boolean | >= 0.1.0
header.spacing | space between header and content | 1.8 | >= 0.1.0
header.htmlUrl | URL or path of HTML to use in header | >= 0.1.0
footer.fontSize | font size for use in footer | 13 | >= 0.1.0
footer.fontName | name of font for use in footer | times | >= 0.1.0
footer.left | text for left of footer | >= 0.1.0
footer.center | text for center of footer | >= 0.1.0
footer.right | text for right of footer | >= 0.1.0
footer.line | enable or disable horizontal rule under footer | boolean | >= 0.1.0
footer.spacing | space between footer and content | 1.8 | >= 0.1.0
footer.htmlUrl | URL or path of HTML to use in footer | >= 0.1.0
load.username | user name to use when loging into a website | bart | >= 0.1.0
load.password | the password to used when logging into a website | elbarto | >= 0.1.0
load.jsdelay | the amount of time in milliseconds to wait after a page is loaded until it is captured | 1200 | >= 0.1.0
load.zoomFactor | how much zoom should be applied to the content | 2.2 | >= 0.1.0
load.customHeaders | custom headers to send when requesting the main web page | >= 0.1.0
load.repertCustomHeaders | set true to send with all requests | boolean | >= 0.1.0
load.cookies | cookie string to send when requesting the main web page | >= 0.1.0
load.post | post string to send when requesting the main web page | >= 0.1.0
load.blockLocalFileAccess | disallow local and piped files to access other local files | boolean | >= 0.1.0
load.stopSlowScript | stop slow running javascript | boolean
load.debugJavascript | allow javascript to raise warnings | boolean | >= 0.1.0
load.loadErrorHandling set error handling strategy
abort | abort the convertion process
skip | do not add the object to the final output
ignore | try to add the object to the final output
>= 0.1.0
load.proxy | >= 0.1.0
web.background | include background image in output | boolean | >= 0.1.0
web.loadImages | include images in output | boolean | >= 0.1.0
web.enableJavascript | enable or disable javascript | boolean | >= 0.1.0
web.enableIntelligentShrinking | enable to attempt to fit more content on page, only applies to PDF output | boolean | >= 0.1.0
web.minimumFontSize | the minimum font size allowed | 9 | >= 0.1.0
web.printMediaType | print content using print media type instead of screen media type | boolean | >= 0.1.0
web.defaultEncoding | content to use where no encoding is specified | utf-8 | >= 0.1.0
web.userStyleSheet | URL or path to a user specified style sheet | /path/to/style.css | >= 0.1.0
web.enablePlugins | enable or disable NS plugins | boolean | >= 0.1.0


La clase wkhtmltox\Image\Converter

(wkhtmltox >= 0.1.0)

Introducción

Convierte una entrada HTML en varios formatos de imagen

Sinopsis de la Clase

wkhtmltox\Image\Converter {
/* Constructor */
public __construct ( string $buffer = ? , array $settings = ? )
/* Métodos */
public convert ( ) : ?string
public getVersion ( ) : string
}

Tabla de contenidos

  • wkhtmltox\Image\Converter::__construct — Create a new Image converter
  • wkhtmltox\Image\Converter::convert — Realiza la conversión de la imagen
  • wkhtmltox\Image\Converter::getVersion — Determina la versión del convertidor


Create a new Image converter

  • « wkhtmltox\Image\Converter
  • wkhtmltox\Image\Converter::convert »
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Create a new Image converter

wkhtmltox\Image\Converter::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\Image\Converter::__construct — Create a new Image converter

Descripción

public wkhtmltox\Image\Converter::__construct ( string $buffer = ? , array $settings = ? )

Creates an Image converter, optionally taking an input buffer and configuration settings

Parámetros

buffer

HTML

settings

Name | Description | Values | Changelog
in | URL or path of the input file, if "-" stdin is used | /path/to/markup.html | >= 0.1.0
out | path of output file, if "-" stdout is used, by default an internal buffer is used | /path/to/output.png | >= 0.1.0
fmt output format to use
"" default
jpg | output as JPEG
png | output as PNG
bmp | output as bitmap
svg | output as SVG
>= 0.1.0
transparent | when outputting a PNG or SVG, make the white background transparent | boolean | >= 0.1.0
screenWidth | the with of the screen used to render in pixels | 800 | >= 0.1.0
smartWidth | when true, screenWidth is expanded to the content width | boolean | >= 0.1.0
quality | compression factor to use when outputting a JPEG image | 94 | >= 0.1.0
crop.left | left/x coordinate of the window to capture in pixels | 200 | >= 0.1.0
crop.top | top/y coordinate of the window to capture in pixels | 200 | >= 0.1.0
crop.width | width of the window to capture in pixels | 200 | >= 0.1.0
crop.height | height of the window to capture in pixels | 200 | >= 0.1.0
load.cookieJar | path of file used to load and store cookies | /tmp/cookies.txt | >= 0.1.0
load.username | user name to use when loging into a website | bart | >= 0.1.0
load.password | the password to used when logging into a website | elbarto | >= 0.1.0
load.jsdelay | the amount of time in milliseconds to wait after a page is loaded until it is captured | 1200 | >= 0.1.0
load.zoomFactor | how much zoom should be applied to the content | 2.2 | >= 0.1.0
load.customHeaders | custom headers to send when requesting the main web page | >= 0.1.0
load.repertCustomHeaders | set true to send with all requests | boolean | >= 0.1.0
load.cookies | cookie string to send when requesting the main web page | >= 0.1.0
load.post | post string to send when requesting the main web page | >= 0.1.0
load.blockLocalFileAccess | disallow local and piped files to access other local files | boolean | >= 0.1.0
load.stopSlowScript | stop slow running javascript | boolean
load.debugJavascript | allow javascript to raise warnings | boolean | >= 0.1.0
load.loadErrorHandling set error handling strategy
abort | abort the convertion process
skip | do not add the object to the final output
ignore | try to add the object to the final output
>= 0.1.0
load.proxy | >= 0.1.0
web.background | include background image in output | boolean | >= 0.1.0
web.loadImages | include images in output | boolean | >= 0.1.0
web.enableJavascript | enable or disable javascript | boolean | >= 0.1.0
web.enableIntelligentShrinking | enable to attempt to fit more content on page, only applies to PDF output | boolean | >= 0.1.0
web.minimumFontSize | the minimum font size allowed | 9 | >= 0.1.0
web.printMediaType | print content using print media type instead of screen media type | boolean | >= 0.1.0
web.defaultEncoding | content to use where no encoding is specified | utf-8 | >= 0.1.0
web.userStyleSheet | URL or path to a user specified style sheet | /path/to/style.css | >= 0.1.0
web.enablePlugins | enable or disable NS plugins | boolean | >= 0.1.0


Realiza la conversión de la imagen

  • « wkhtmltox\Image\Converter::__construct
  • wkhtmltox\Image\Converter::getVersion »
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Realiza la conversión de la imagen

wkhtmltox\Image\Converter::convert

(wkhtmltox >= 0.1.0)

wkhtmltox\Image\Converter::convert — Realiza la conversión de la imagen

Descripción

public wkhtmltox\Image\Converter::convert ( ) : ?string

Realiza la conversión de la memoria intermedia de entrada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Cuando se utilice el valor de retorno, se rellenará con el contenido de la memoria intermedia de conversión


Determina la versión del convertidor

  • « wkhtmltox\Image\Converter::convert
  • PS »
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Determina la versión del convertidor

wkhtmltox\Image\Converter::getVersion

(wkhtmltox >= 0.3.2)

wkhtmltox\Image\Converter::getVersion — Determina la versión del convertidor

Descripción

public wkhtmltox\Image\Converter::getVersion ( ) : string

Determina la versión del convertidor según lo informado por libwkhtmltox

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string de versión

Advertencia

Esto todavía no se ha implementado por libwkhtmltox


Creación de documentos PostScript

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de PS
    • ps_add_bookmark — Añadir un marcapáginas a la página actual
    • ps_add_launchlink — Añadir un vínculo que lance un fichero
    • ps_add_locallink — Añadir un vínculo hacia una página del mismo documento
    • ps_add_note — Añadir una nota a la página actual
    • ps_add_pdflink — Añadir un vínculo hacia una página de un segundo documento PDF
    • ps_add_weblink — Añadir un vínculo hacia una ubicación web
    • ps_arc — Dibujar un arco en el sentido contrario a las agujas del reloj
    • ps_arcn — Dibujar un arco en el sentido de las agujas del reloj
    • ps_begin_page — Empezar una nueva página
    • ps_begin_pattern — Iniciar un nuevo patrón
    • ps_begin_template — Iniciar una nueva plantilla
    • ps_circle — Dibujar un círculo
    • ps_clip — Realizar un recorte utilizando el trazado actual
    • ps_close_image — Cerrar una imagen y liberar memoria
    • ps_close — Cerrar un documento PostScript
    • ps_closepath_stroke — Cerrar y contornear un trazado
    • ps_closepath — Cerrar un trazado
    • ps_continue_text — Continuar el texto en la siguiente línea
    • ps_curveto — Dibujar una curva
    • ps_delete — Borrar todos los recursos de un documento PostScript
    • ps_end_page — Finalizar una página
    • ps_end_pattern — Finalizar un patrón
    • ps_end_template — Finalizar una plantilla
    • ps_fill_stroke — Rellenar y contornear el trazado actual
    • ps_fill — Rellenar el trazado actual
    • ps_findfont — Cargar una fuente
    • ps_get_buffer — Obtener el buffer completo que contiene la información generada de PS
    • ps_get_parameter — Obtener ciertos parámetros
    • ps_get_value — Obtener ciertos valores
    • ps_hyphenate — Particionar silábicamente una palabra
    • ps_include_file — Leer un fichero externo con código PostScript sin tratar
    • ps_lineto — Dibujar una línea
    • ps_makespotcolor — Crear un color directo
    • ps_moveto — Establecer el punto actual
    • ps_new — Crear un nuevo objeto de documento PostScript
    • ps_open_file — Abrir un fichero para su impresión
    • ps_open_image_file — Abre una imagen desde un fichero
    • ps_open_image — Leer una imagen para su colocación posterior
    • ps_open_memory_image — Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS
    • ps_place_image — Colocar una imágen en la página
    • ps_rect — Dibujar un rectángulo
    • ps_restore — Restaurar un contexto previamente guardado
    • ps_rotate — Establecer el factor de rotación
    • ps_save — Guardar el contexto actual
    • ps_scale — Estalecer el factor de escala
    • ps_set_border_color — Establecer el color del borde de las anotaciones
    • ps_set_border_dash — Establece la longitud de las rayas del borde de las anotaciones
    • ps_set_border_style — Establecer el estilo del borde de las anotaciones
    • ps_set_info — Establecer los campos de información del documento
    • ps_set_parameter — Establecer ciertos parámetros
    • ps_set_text_pos — Establecer la posición de la salida de texto
    • ps_set_value — Establecer ciertos valores
    • ps_setcolor — Establecer el color actual
    • ps_setdash — Establecer la apariencia de una línea discontinua
    • ps_setflat — Establecer la planicidad
    • ps_setfont — Establecer la fuente a usar para la siguiente impresión
    • ps_setgray — Establecer el valor de gris
    • ps_setlinecap — Establecer la apariencia de los extremos de línea
    • ps_setlinejoin — Establecer cómo están unidas las líneas conectadas
    • ps_setlinewidth — Establecer el ancho de una línea
    • ps_setmiterlimit — Establecer el límite del inglete
    • ps_setoverprintmode — Establecer el modo de sobreimpresión
    • ps_setpolydash — Establecer la apariencia de una línea discontinua
    • ps_shading_pattern — Crear un patrón basado en un sombreado
    • ps_shading — Crear un sombreado para su uso posterior
    • ps_shfill — Rellenar un área con un sombreado
    • ps_show_boxed — Imprimir texto en una caja
    • ps_show_xy2 — Imprimir texto en una posición
    • ps_show_xy — Imprimir texto en una posición dada
    • ps_show2 — Imprimir texto en la posición actual
    • ps_show — Imprimir texto
    • ps_string_geometry — Establecer la geometría de una cadena de caracteres
    • ps_stringwidth — Obtener el ancho de una cadena
    • ps_stroke — Dibujar el trazado actual
    • ps_symbol_name — Obtener el nombre de un glifo
    • ps_symbol_width — Obtener el ancho de un glifo
    • ps_symbol — Imprimir un glifo
    • ps_translate — Establecer una traslación


Introducción

Este módulo permite la creación de documentos PostScript. Tiene muchas similitudes con la extensión pdf. Realmente, la API es casi idéntica y en la mayoría de los casos se puede remplazar el prefijo de cada función pdf_ por ps_. Esto también es válido para funciones que no tienen significado en un documento PostScript (como añadir hipervínculos), aunque tendrá efecto si el documento se convierte a PDF.

Los documentos creados por esta extensión a veces son incluso superiores que los documentos creados con la extensión pdf, ya que las funciones de interpretación de texto de pslib pueden manejar el interletraje («kerning»), la partición silábica y las ligaduras, lo que resulta en una mejor impresión de texto encajado.


Requerimientos

Se necesita al menos pslib >= 0.1.12. La biblioteca de ps (pslib) está disponible en » http://pslib.sourceforge.net/.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ps.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un documento PostScript devuelto por la función ps_new().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las siguientes dos tablas muestran las constantes definidas por la extensión ps.

Constantes para extremos de líneas
Nombre | Significado
ps_LINECAP_BUTT |
ps_LINECAP_ROUND |
ps_LINECAP_SQUARED |
Constantes para unión de líneas
Nombre | Significado
ps_LINEJOIN_MITER |
ps_LINEJOIN_ROUND |
ps_LINEJOIN_BEVEL |


Funciones de PS

Información de contacto

Si tiene comentarios, correcciones de errores, mejoras para esta extensión o para pslib, por favor envíeme un correo » steinm@php.net. Cualquier ayuda es bienvenida.

Tabla de contenidos

  • ps_add_bookmark — Añadir un marcapáginas a la página actual
  • ps_add_launchlink — Añadir un vínculo que lance un fichero
  • ps_add_locallink — Añadir un vínculo hacia una página del mismo documento
  • ps_add_note — Añadir una nota a la página actual
  • ps_add_pdflink — Añadir un vínculo hacia una página de un segundo documento PDF
  • ps_add_weblink — Añadir un vínculo hacia una ubicación web
  • ps_arc — Dibujar un arco en el sentido contrario a las agujas del reloj
  • ps_arcn — Dibujar un arco en el sentido de las agujas del reloj
  • ps_begin_page — Empezar una nueva página
  • ps_begin_pattern — Iniciar un nuevo patrón
  • ps_begin_template — Iniciar una nueva plantilla
  • ps_circle — Dibujar un círculo
  • ps_clip — Realizar un recorte utilizando el trazado actual
  • ps_close_image — Cerrar una imagen y liberar memoria
  • ps_close — Cerrar un documento PostScript
  • ps_closepath_stroke — Cerrar y contornear un trazado
  • ps_closepath — Cerrar un trazado
  • ps_continue_text — Continuar el texto en la siguiente línea
  • ps_curveto — Dibujar una curva
  • ps_delete — Borrar todos los recursos de un documento PostScript
  • ps_end_page — Finalizar una página
  • ps_end_pattern — Finalizar un patrón
  • ps_end_template — Finalizar una plantilla
  • ps_fill_stroke — Rellenar y contornear el trazado actual
  • ps_fill — Rellenar el trazado actual
  • ps_findfont — Cargar una fuente
  • ps_get_buffer — Obtener el buffer completo que contiene la información generada de PS
  • ps_get_parameter — Obtener ciertos parámetros
  • ps_get_value — Obtener ciertos valores
  • ps_hyphenate — Particionar silábicamente una palabra
  • ps_include_file — Leer un fichero externo con código PostScript sin tratar
  • ps_lineto — Dibujar una línea
  • ps_makespotcolor — Crear un color directo
  • ps_moveto — Establecer el punto actual
  • ps_new — Crear un nuevo objeto de documento PostScript
  • ps_open_file — Abrir un fichero para su impresión
  • ps_open_image_file — Abre una imagen desde un fichero
  • ps_open_image — Leer una imagen para su colocación posterior
  • ps_open_memory_image — Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS
  • ps_place_image — Colocar una imágen en la página
  • ps_rect — Dibujar un rectángulo
  • ps_restore — Restaurar un contexto previamente guardado
  • ps_rotate — Establecer el factor de rotación
  • ps_save — Guardar el contexto actual
  • ps_scale — Estalecer el factor de escala
  • ps_set_border_color — Establecer el color del borde de las anotaciones
  • ps_set_border_dash — Establece la longitud de las rayas del borde de las anotaciones
  • ps_set_border_style — Establecer el estilo del borde de las anotaciones
  • ps_set_info — Establecer los campos de información del documento
  • ps_set_parameter — Establecer ciertos parámetros
  • ps_set_text_pos — Establecer la posición de la salida de texto
  • ps_set_value — Establecer ciertos valores
  • ps_setcolor — Establecer el color actual
  • ps_setdash — Establecer la apariencia de una línea discontinua
  • ps_setflat — Establecer la planicidad
  • ps_setfont — Establecer la fuente a usar para la siguiente impresión
  • ps_setgray — Establecer el valor de gris
  • ps_setlinecap — Establecer la apariencia de los extremos de línea
  • ps_setlinejoin — Establecer cómo están unidas las líneas conectadas
  • ps_setlinewidth — Establecer el ancho de una línea
  • ps_setmiterlimit — Establecer el límite del inglete
  • ps_setoverprintmode — Establecer el modo de sobreimpresión
  • ps_setpolydash — Establecer la apariencia de una línea discontinua
  • ps_shading_pattern — Crear un patrón basado en un sombreado
  • ps_shading — Crear un sombreado para su uso posterior
  • ps_shfill — Rellenar un área con un sombreado
  • ps_show_boxed — Imprimir texto en una caja
  • ps_show_xy2 — Imprimir texto en una posición
  • ps_show_xy — Imprimir texto en una posición dada
  • ps_show2 — Imprimir texto en la posición actual
  • ps_show — Imprimir texto
  • ps_string_geometry — Establecer la geometría de una cadena de caracteres
  • ps_stringwidth — Obtener el ancho de una cadena
  • ps_stroke — Dibujar el trazado actual
  • ps_symbol_name — Obtener el nombre de un glifo
  • ps_symbol_width — Obtener el ancho de un glifo
  • ps_symbol — Imprimir un glifo
  • ps_translate — Establecer una traslación


Añadir un marcapáginas a la página actual

  • « Funciones de PS
  • ps_add_launchlink »
  • PHP Manual
  • Funciones de PS
  • Añadir un marcapáginas a la página actual

ps_add_bookmark

(PECL ps >= 1.1.0)

ps_add_bookmark — Añadir un marcapáginas a la página actual

Descripción

ps_add_bookmark ( resource $psdoc , string $text , int $parent = 0 , int $open = 0 ) : int

Añade un marcapáginas a la página actual. Los marcapáginas normalmente aparecen en los visualizadores de PDF a la izquierda de la página como un árbol jerárquico. Al hacer clic en un marcapáginas saltará a la página en cuestión.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto usado para mostrar el marcapáginas.

parent

Un marcapáginas previamente creado por esta función que se usa como padre del nuevo marcapáginas.

open

Si open es distinto de cero, el visualizador de PDF mostrará el marcapáginas abierto.

Valores devueltos

El valor devuelto es una referencia al marcapáginas. Sólo se utiliza si el marcapáginas se usa como padre. El valor es mayor que cero si la función tiene éxito. En caso de error se devolverá cero.

Ver también

  • ps_add_launchlink() - Añadir un vínculo que lance un fichero
  • ps_add_pdflink() - Añadir un vínculo hacia una página de un segundo documento PDF
  • ps_add_weblink() - Añadir un vínculo hacia una ubicación web


Añadir un vínculo que lance un fichero

  • « ps_add_bookmark
  • ps_add_locallink »
  • PHP Manual
  • Funciones de PS
  • Añadir un vínculo que lance un fichero

ps_add_launchlink

(PECL ps >= 1.1.0)

ps_add_launchlink — Añadir un vínculo que lance un fichero

Descripción

ps_add_launchlink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename ) : bool

Coloca un hipervínculo, en la posición dada, que apunta a un fichero de un programa, el cual se iniciará al hacer clic sobre él. La posición origen del hipervículo es un rectángulo que tiene su esquina inferior izquierda en (llx, lly) y su esquina superior derecha en (urx, ury). El rectángulo tiene por defecto un borde fino azul.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

llx

La coordenada x de la esquina inferior izquierda.

lly

La coordenada y de la esquina inferior izquierda.

urx

La coordenada x de la esquina superior derecha.

ury

La coordenada y de la esquina superior derecha.

filename

La ruta del programa a iniciar cuando se haga clic sobre el vínculo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_add_locallink() - Añadir un vínculo hacia una página del mismo documento
  • ps_add_pdflink() - Añadir un vínculo hacia una página de un segundo documento PDF
  • ps_add_weblink() - Añadir un vínculo hacia una ubicación web


Añadir un vínculo hacia una página del mismo documento

  • « ps_add_launchlink
  • ps_add_note »
  • PHP Manual
  • Funciones de PS
  • Añadir un vínculo hacia una página del mismo documento

ps_add_locallink

(PECL ps >= 1.1.0)

ps_add_locallink — Añadir un vínculo hacia una página del mismo documento

Descripción

ps_add_locallink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , int $page , string $dest ) : bool

Coloca un hipervínculo, en la posición dada, que apunta a una página del mismo documento. Al hacer clic sobre el vínculo se irá a la página en cuestión. La primera página de un documento tiene el número 1.

La posición origen del hipervículo es un rectángulo que tiene su esquina inferior izquierda en (llx, lly) y su esquina superior derecha en (urx, ury). El rectángulo tiene por defecto un borde fino azul.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

llx

La coordenada x de la esquina inferior izquierda.

lly

La coordenada y de la esquina inferior izquierda.

urx

La coordenada x de la esquina superior derecha.

ury

La coordenada y de la esquina superior derecha.

page

El número de la página mostrada al hacer clic en el vínculo.

dest

El parámetro dest determina cómo visualizar el documento. Puede ser fitpage, fitwidth, fitheight, o fitbbox.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_add_launchlink() - Añadir un vínculo que lance un fichero
  • ps_add_pdflink() - Añadir un vínculo hacia una página de un segundo documento PDF
  • ps_add_weblink() - Añadir un vínculo hacia una ubicación web


Añadir una nota a la página actual

  • « ps_add_locallink
  • ps_add_pdflink »
  • PHP Manual
  • Funciones de PS
  • Añadir una nota a la página actual

ps_add_note

(PECL ps >= 1.1.0)

ps_add_note — Añadir una nota a la página actual

Descripción

ps_add_note ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $contents , string $title , string $icon , int $open ) : bool

Añade una nota en una cierta posición del página. Las notas son como pequeñas hojas rectangulares con texto dentro que pueden ser colocadas en cualquer lugar de una página. Se muestran tanto plegadas como desplegadas. Si están desplegadas se utiliza el icono especificado como marcador de posición.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

llx

La coordenada x de la esquina inferior izquierda.

lly

La coordenada y de la esquina inferior izquierda.

urx

La coordenada x de la esquina superior derecha.

ury

La coordenada y de la esquina superior derecha.

contents

El texto de la nota.

title

El título de la nota a mostrar en la cabecera de la nota.

icon

El icono mostrado si la nota está plegada. Este parámetro puede ser establecido a comment, insert, note, paragraph, newparagraph, key, o help.

open

Si open es distinto de cero, la nota se mostrará desplegada después de abrir el documento con un visualizador de pdf.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_add_pdflink() - Añadir un vínculo hacia una página de un segundo documento PDF
  • ps_add_launchlink() - Añadir un vínculo que lance un fichero
  • ps_add_locallink() - Añadir un vínculo hacia una página del mismo documento
  • ps_add_weblink() - Añadir un vínculo hacia una ubicación web


Añadir un vínculo hacia una página de un segundo documento PDF

  • « ps_add_note
  • ps_add_weblink »
  • PHP Manual
  • Funciones de PS
  • Añadir un vínculo hacia una página de un segundo documento PDF

ps_add_pdflink

(PECL ps >= 1.1.0)

ps_add_pdflink — Añadir un vínculo hacia una página de un segundo documento PDF

Descripción

ps_add_pdflink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename , int $page , string $dest ) : bool

Coloca un hipervínculo, en la posición dada, que apunta a un segundo documento pdf. Al hacer clic sobre el vínculo se irá a la página dada del segundo documento. La primera página de un documento tiene el número 1.

La posición origen del hipervículo es un rectángulo que tiene su esquina inferior izquierda en (llx, lly) y su esquina superior derecha en (urx, ury). El rectángulo tiene por defecto un borde fino azul.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

llx

La coordenada x de la esquina inferior izquierda.

lly

La coordenada y de la esquina inferior izquierda.

urx

La coordenada x de la esquina superior derecha.

ury

La coordenada y de la esquina superior derecha.

filename

El nombre del documento pdf a abrir cuando se haga clic en este vínculo.

page

El número de página del documento pdf destino

dest

El parámetro dest determina cómo visualizar el documento. Puede ser fitpage, fitwidth, fitheight, o fitbbox.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_add_launchlink() - Añadir un vínculo que lance un fichero
  • ps_add_locallink() - Añadir un vínculo hacia una página del mismo documento
  • ps_add_weblink() - Añadir un vínculo hacia una ubicación web


Añadir un vínculo hacia una ubicación web

  • « ps_add_pdflink
  • ps_arc »
  • PHP Manual
  • Funciones de PS
  • Añadir un vínculo hacia una ubicación web

ps_add_weblink

(PECL ps >= 1.1.0)

ps_add_weblink — Añadir un vínculo hacia una ubicación web

Descripción

ps_add_weblink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $url ) : bool

Coloca un hipervínculo, en la posición dada, que apunta a una página web. La posición origen del hipervículo es un rectángulo que tiene su esquina inferior izquierda en (llx, lly) y su esquina superior derecha en (urx, ury). El rectángulo tiene por defecto un borde fino azul.

La nota no será visible si el documento se imprime o visualiza, pero se mostrará si es convertido a PDF ya sea con Acrobat Distiller™ o Ghostview.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

llx

La coordenada x de la esquina inferior izquierda.

lly

La coordenada y de la esquina inferior izquierda.

urx

La coordenada x de la esquina superior derecha.

ury

La coordenada y de la esquina superior derecha.

url

El URL del hipervínculo a abrir cuando se haga clic en este vínculo, p.ej. http://www.php.net.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_add_launchlink() - Añadir un vínculo que lance un fichero
  • ps_add_locallink() - Añadir un vínculo hacia una página del mismo documento
  • ps_add_pdflink() - Añadir un vínculo hacia una página de un segundo documento PDF


Dibujar un arco en el sentido contrario a las agujas del reloj

  • « ps_add_weblink
  • ps_arcn »
  • PHP Manual
  • Funciones de PS
  • Dibujar un arco en el sentido contrario a las agujas del reloj

ps_arc

(PECL ps >= 1.1.0)

ps_arc — Dibujar un arco en el sentido contrario a las agujas del reloj

Descripción

ps_arc ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta ) : bool

Dibuja una porción de un círculo con su punto medio en (x, y). El arco comienza en un ángulo dado por alpha y termina en un ángulo dado por beta. Se dibuja en el sentido contrario al de las agujas del reloj (use la función ps_arcn() para dibujarlo en el sentido de las agujas del reloj). El trazado añadido al trazado actual comienza en el arco con el ángulo alpha y termina en el arco con el ángulo beta.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del punto medio del círculo.

y

La coordenada y del punto medio del círculo.

radius

El radio del círculo

alpha

El ángulo de inicio dado en grados.

beta

El ángulo final dado en grados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_arcn() - Dibujar un arco en el sentido de las agujas del reloj


Dibujar un arco en el sentido de las agujas del reloj

  • « ps_arc
  • ps_begin_page »
  • PHP Manual
  • Funciones de PS
  • Dibujar un arco en el sentido de las agujas del reloj

ps_arcn

(PECL ps >= 1.1.0)

ps_arcn — Dibujar un arco en el sentido de las agujas del reloj

Descripción

ps_arcn ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta ) : bool

Dibuja una porción de un círculo con su punto medio en (x, y). El arco comienza en un ángulo dado por alpha y termina en un ángulo dado por beta. Se dibuja en el sentido de las agujas del reloj (use la función ps_arc() para dibujarlo en sentido contrario al de las agujas del reloj). El trazado añadido al trazado actual comienza en el arco con el ángulo beta y termina en el arco con el ángulo alpha.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del punto medio del círculo.

y

La coordenada y del punto medio del círculo.

radius

El radio del círculo

alpha

El ángulo de inicio dado en grados.

beta

El ángulo final dado en grados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_arc() - Dibujar un arco en el sentido contrario a las agujas del reloj


Empezar una nueva página

  • « ps_arcn
  • ps_begin_pattern »
  • PHP Manual
  • Funciones de PS
  • Empezar una nueva página

ps_begin_page

(PECL ps >= 1.1.0)

ps_begin_page — Empezar una nueva página

Descripción

ps_begin_page ( resource $psdoc , float $width , float $height ) : bool

Empiza una nueva página. Aunque los parámetros width y height implican un tamaño de página diferente para cada página, esto no es posible en PostScript. La primera llamada a la función ps_begin_page() establecerá el tamaño de página para el documento entero. Las llamadas consecutivas no tendrán efecto, excepto para crear una nueva página. La situación es diferente si se intenta convertir el documento PostScript a PDF. Esta función coloca marcas pdf dentro del documento, con lo que se puede establecer el tamaño de cada página individualmente. El documento PDF resultante tendrá diferentes tamaños de página.

Aunque PostScript no conoce diferentes tamaños de página, pslib coloca una caja circundante para cada página dentro del documento. Este tamaño es evaluado por algunos visualizadores de PostScript y tendrá precedencia sobre el campo BoundingBox de la cabecera (Header) del documento. Esto puede llevar a resultados inesperados cuando se establece BoundingBox con su esquina inferior izquierda diferente de (0, 0), ya que la caja circundante de la página siempre tendrá una esquina inferior izquierda (0, 0) y sobrescribirá la configuración global.

Cada página está encapsulada en la forma guardar/restaurar. Esto significa que la mayoría de los ajustes hechos en una página no se conservarán para la siguiente página.

Si hasta la primera llamada a la función ps_begin_page() no existen llamadas a la función ps_findfont(), la cabecera del documento PostScript se imprimirá y la caja circundante será establecida al tamaño de la primera página. La esquina inferior izquierda de la caja circundante se establecerá a (0, 0). Si si llamó antes a la función ps_findfont(), la cabecera ya ha sido impresa, y el documento no tendrá una caja circundante válida. Para prevenir esto, se debería llamar a la función ps_set_info() para establecer el campo de información BoundingBox y posiblemente Orientation antes de cualquier llamada a las funciones ps_findfont() o ps_begin_page().

Nota:

Hasta la versión 0.2.6 de pslib, esta función siempre sobrescribía los campos BoundingBox y Orientation si antes habían sido establecidos con la función ps_set_info() y no se había llamado antes a la función ps_findfont().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

width

El ancho de la página en píxeles, p.ej. 596 para el formato A4

height

El alto de la página en píxeles, p.ej. 842 para el formato A4

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_end_page() - Finalizar una página
  • ps_findfont() - Cargar una fuente
  • ps_set_info() - Establecer los campos de información del documento


Iniciar un nuevo patrón

  • « ps_begin_page
  • ps_begin_template »
  • PHP Manual
  • Funciones de PS
  • Iniciar un nuevo patrón

ps_begin_pattern

(PECL ps >= 1.2.0)

ps_begin_pattern — Iniciar un nuevo patrón

Descripción

ps_begin_pattern ( resource $psdoc , float $width , float $height , float $xstep , float $ystep , int $painttype ) : int

Inicia un nuevo patrón. Un patrón es como una página que contiene, por ejemplo, un dibujo que puede ser utilizado par rellenar áreas. Se usa como un color llamando a la función ps_setcolor() y estableciendo el espacio de color a pattern.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

width

El ancho del patrón en píxeles.

height

El alto del patrón en píxeles.

x-step

La distancia en píxeles de la ubicación del patrón en dirección horizontal.

y-step

La distancia en píxeles de la ubicación del patrón en dirección vertical.

painttype

Debe ser 1 ó 2.

Valores devueltos

El identificador del patrón o false en caso de error.

Ejemplos

Ejemplo #1 Crear y usar un patrón

<?php
$ps = ps_new();

if (!ps_open_file($ps, "patrón.ps")) {
  print "No se puede abrir el fichero PostScript\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "patrón.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de patrón");

$patrón_ps = ps_begin_pattern($ps, 10.0, 10.0, 10.0, 10.0, 1);
ps_setlinewidth($ps, 0.2);
ps_setcolor($ps, "stroke", "rgb", 0.0, 0.0, 1.0, 0.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 7, 7);
ps_stroke($ps);
ps_moveto($ps, 0, 7);
ps_lineto($ps, 7, 0);
ps_stroke($ps);
ps_end_pattern($ps);

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "both", "pattern", $patrón_ps, 0.0, 0.0, 0.0);
ps_rect($ps, 50, 400, 200, 200);
ps_fill($ps);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Ver también

  • ps_end_pattern() - Finalizar un patrón
  • ps_setcolor() - Establecer el color actual
  • ps_shading_pattern() - Crear un patrón basado en un sombreado


Iniciar una nueva plantilla

  • « ps_begin_pattern
  • ps_circle »
  • PHP Manual
  • Funciones de PS
  • Iniciar una nueva plantilla

ps_begin_template

(PECL ps >= 1.2.0)

ps_begin_template — Iniciar una nueva plantilla

Descripción

ps_begin_template ( resource $psdoc , float $width , float $height ) : int

Inicia una nueva plantilla. A una plantilla se le conoce como forma en el lenguaje postscript. Se crea de forma similar a un patrón pero se utiliza como una imagen. Las plantilla a menudo se usan para dibujar algo que se coloca varias veces a lo largo de un documento, p.ej. el logotipo de una compañía. Se puede usar todas las funciones de dibujo dentro de una plantilla. La plantilla no será dibujada hasta que sea colocada medianta la función ps_place_image().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

width

El ancho de la plantilla en píxeles.

height

El alto de la plantilla en píxeles.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Crear y utilizar una plantilla

<?php
$ps = ps_new();

if (!ps_open_file($ps, "plantilla.ps")) {
  print "No se puede abrir el fichero PostScript\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "plantilla.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de plantilla");

$plantilla_ps = ps_begin_template($ps, 30.0, 30.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 30, 30);
ps_moveto($ps, 0, 30);
ps_lineto($ps, 30, 0);
ps_stroke($ps);
ps_end_template($ps);

ps_begin_page($ps, 596, 842);
ps_place_image($ps, $plantilla_ps, 20.0, 20.0, 1.0);
ps_place_image($ps, $plantilla_ps, 50.0, 30.0, 0.5);
ps_place_image($ps, $plantilla_ps, 70.0, 70.0, 0.6);
ps_place_image($ps, $plantilla_ps, 30.0, 50.0, 1.3);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Ver también

  • ps_end_template() - Finalizar una plantilla


Dibujar un círculo

  • « ps_begin_template
  • ps_clip »
  • PHP Manual
  • Funciones de PS
  • Dibujar un círculo

ps_circle

(PECL ps >= 1.1.0)

ps_circle — Dibujar un círculo

Descripción

ps_circle ( resource $psdoc , float $x , float $y , float $radius ) : bool

Dibuja un círculo con su punto medio en (x, y). El círculo comienza y termina en la posición (x+radius, y). Si esta función es llamada fuera de un trazado se iniciará un nuevo trazado. Si es llamada dentro de un trazado añadirá el círculo como un subtrazado. Si la última operación de dibujo no finaliza en el punto (x+radius, y) habrá un hueco en el trazado.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del punto medio del círculo.

y

La coordenada y del punto medio del círculo.

radius

El radio del círculo

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_arc() - Dibujar un arco en el sentido contrario a las agujas del reloj
  • ps_arcn() - Dibujar un arco en el sentido de las agujas del reloj


Realizar un recorte utilizando el trazado actual

  • « ps_circle
  • ps_close_image »
  • PHP Manual
  • Funciones de PS
  • Realizar un recorte utilizando el trazado actual

ps_clip

(PECL ps >= 1.1.0)

ps_clip — Realizar un recorte utilizando el trazado actual

Descripción

ps_clip ( resource $psdoc ) : bool

Toma el trazado actual y lo usa para definir el borde de un área de recorte. Todo lo dibujado fuera de ese área no será visible.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_closepath() - Cerrar un trazado


Cerrar una imagen y liberar memoria

  • « ps_clip
  • ps_close »
  • PHP Manual
  • Funciones de PS
  • Cerrar una imagen y liberar memoria

ps_close_image

(PECL ps >= 1.1.0)

ps_close_image — Cerrar una imagen y liberar memoria

Descripción

ps_close_image ( resource $psdoc , int $imageid ) : void

Cierra una imagen y libera sus recursos. Una vez que una imagen ha sido cerrada ya no puede usarse más.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

imageid

El identificador de recursos de la imagen, como el devuelto por las funciones ps_open_image() o ps_open_image_file().

Valores devueltos

Devuelve null en caso de éxito, o false en caso de error.

Ver también

  • ps_open_image() - Leer una imagen para su colocación posterior
  • ps_open_image_file() - Abre una imagen desde un fichero


Cerrar un documento PostScript

  • « ps_close_image
  • ps_closepath_stroke »
  • PHP Manual
  • Funciones de PS
  • Cerrar un documento PostScript

ps_close

(PECL ps >= 1.1.0)

ps_close — Cerrar un documento PostScript

Descripción

ps_close ( resource $psdoc ) : bool

Cierra el documento PostScript.

Esta función escribe el tráiler del documento PostScript. También escribe el árbol de marcapáginas. ps_close() no libera ningún recurso, lo que se realiza mediante la función ps_delete().

Esta función también es llamda por la función ps_delete() si no ha sido llamada antes.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_open_file() - Abrir un fichero para su impresión
  • ps_delete() - Borrar todos los recursos de un documento PostScript


Cerrar y contornear un trazado

  • « ps_close
  • ps_closepath »
  • PHP Manual
  • Funciones de PS
  • Cerrar y contornear un trazado

ps_closepath_stroke

(PECL ps >= 1.1.0)

ps_closepath_stroke — Cerrar y contornear un trazado

Descripción

ps_closepath_stroke ( resource $psdoc ) : bool

Conecta el último punto con el primer punto de un trazado y dibuja la línea cerrada resultante.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_closepath() - Cerrar un trazado


Cerrar un trazado

  • « ps_closepath_stroke
  • ps_continue_text »
  • PHP Manual
  • Funciones de PS
  • Cerrar un trazado

ps_closepath

(PECL ps >= 1.1.0)

ps_closepath — Cerrar un trazado

Descripción

ps_closepath ( resource $psdoc ) : bool

Conecta el último punto con el primer punto de un trazado. El trazado resultante puede usarse para contornear, rellenar, recortar, etc...

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_clip() - Realizar un recorte utilizando el trazado actual
  • ps_closepath_stroke() - Cerrar y contornear un trazado


Continuar el texto en la siguiente línea

  • « ps_closepath
  • ps_curveto »
  • PHP Manual
  • Funciones de PS
  • Continuar el texto en la siguiente línea

ps_continue_text

(PECL ps >= 1.1.0)

ps_continue_text — Continuar el texto en la siguiente línea

Descripción

ps_continue_text ( resource $psdoc , string $text ) : bool

Imprime un texto una línea por debajo de la última línea. La interlínea se toma del valor "leading", el cual debe establecerse con la función ps_set_value(). La posición actual del texto se determina por los valores "textx" y "texty", los cuales pueden solicitarse con la función ps_get_value().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto a imprimir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_show() - Imprimir texto
  • ps_show_xy() - Imprimir texto en una posición dada
  • ps_show_boxed() - Imprimir texto en una caja


Dibujar una curva

  • « ps_continue_text
  • ps_delete »
  • PHP Manual
  • Funciones de PS
  • Dibujar una curva

ps_curveto

(PECL ps >= 1.1.0)

ps_curveto — Dibujar una curva

Descripción

ps_curveto ( resource $psdoc , float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 ) : bool

Añade una sección de una curva cúbica de Bézier al trazado actual descrita por los tres puntos de control dados.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x1

La coordenada x del primer punto de control.

y1

La coordenada y del primer punto de control.

x2

La coordenada x del segundo punto de control.

y2

La coordenada y del segundo punto de control.

x3

La coordenada x del tercer punto de control.

y3

La coordenada y del tercer punto de control.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_lineto() - Dibujar una línea


Borrar todos los recursos de un documento PostScript

  • « ps_curveto
  • ps_end_page »
  • PHP Manual
  • Funciones de PS
  • Borrar todos los recursos de un documento PostScript

ps_delete

(PECL ps >= 1.1.0)

ps_delete — Borrar todos los recursos de un documento PostScript

Descripción

ps_delete ( resource $psdoc ) : bool

Principalmente libera la memoria usada por el documento. También cierra un fichero, si no fue cerrado antes con la función ps_close(). En cualquier caso, antes se debería cerrar el fichero con la función ps_close(), ya que ps_close() no sólo cierra el fichero, sino que también imprime un tráiler que contiene comentarios de PostScript, como el número de páginas del documento, y añade la jerarquía de marcapáginas.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_close() - Cerrar un documento PostScript


Finalizar una página

  • « ps_delete
  • ps_end_pattern »
  • PHP Manual
  • Funciones de PS
  • Finalizar una página

ps_end_page

(PECL ps >= 1.1.0)

ps_end_page — Finalizar una página

Descripción

ps_end_page ( resource $psdoc ) : bool

Finaliza un página que ha sido empezada con la función ps_begin_page(). Al finalizar una página se abandonará el contexto de dibujo actual, lo que, por ejemplo, requiere recargar la fuentes si fueron cargadas dentro de la página, y establecer muchos otros parámetros como el ancho de línea, color...

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_begin_page() - Empezar una nueva página


Finalizar un patrón

  • « ps_end_page
  • ps_end_template »
  • PHP Manual
  • Funciones de PS
  • Finalizar un patrón

ps_end_pattern

(PECL ps >= 1.2.0)

ps_end_pattern — Finalizar un patrón

Descripción

ps_end_pattern ( resource $psdoc ) : bool

Finaliza un patrón que fue creado con la función ps_begin_pattern(). Una vez que el patrón ha sido finalizado se puede usar como un color para rellenar áreas.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_begin_pattern() - Iniciar un nuevo patrón


Finalizar una plantilla

  • « ps_end_pattern
  • ps_fill_stroke »
  • PHP Manual
  • Funciones de PS
  • Finalizar una plantilla

ps_end_template

(PECL ps >= 1.2.0)

ps_end_template — Finalizar una plantilla

Descripción

ps_end_template ( resource $psdoc ) : bool

Finaliza una plantilla que fue creada con la función ps_begin_template(). Una vez que la plantilla ha sido finalizada se puede usar como una imagen.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_begin_template() - Iniciar una nueva plantilla


Rellenar y contornear el trazado actual

  • « ps_end_template
  • ps_fill »
  • PHP Manual
  • Funciones de PS
  • Rellenar y contornear el trazado actual

ps_fill_stroke

(PECL ps >= 1.1.0)

ps_fill_stroke — Rellenar y contornear el trazado actual

Descripción

ps_fill_stroke ( resource $psdoc ) : bool

Rellena y dibuja el trazado construido previamente con llamadas a funciones de dibujo, como ps_lineto().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_fill() - Rellenar el trazado actual
  • ps_stroke() - Dibujar el trazado actual


Rellenar el trazado actual

  • « ps_fill_stroke
  • ps_findfont »
  • PHP Manual
  • Funciones de PS
  • Rellenar el trazado actual

ps_fill

(PECL ps >= 1.1.0)

ps_fill — Rellenar el trazado actual

Descripción

ps_fill ( resource $psdoc ) : bool

Rellena el trazaco construido previamente con llamdas a las funciones de dibujo, como ps_lineto().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_fill_stroke() - Rellenar y contornear el trazado actual
  • ps_stroke() - Dibujar el trazado actual


Cargar una fuente

  • « ps_fill
  • ps_get_buffer »
  • PHP Manual
  • Funciones de PS
  • Cargar una fuente

ps_findfont

(PECL ps >= 1.1.0)

ps_findfont — Cargar una fuente

Descripción

ps_findfont ( resource $psdoc , string $fontname , string $encoding , bool $embed = false ) : int

Carga una fuente para su uso posterior. Antes de que un texto se imprima con una fuente cargada, ésta debe establecerse con a la función ps_setfont(). Esta función necesita el fichero de métrica de fuentes de Adobe para poder calcular el espacio utilizado por los caracteres. Una fuente que sea cargada dentro de una página solamente estára disponible en esta página. Las fuentes que van a ser usadas en el documento completo tienen que ser cargadas antes de llamar por primera vez a la función ps_begin_page(). Llamar a la función ps_findfont() entre páginas hará que esa fuente esté disponible para todas las páginas siguientes.

El nombre del fichero afm debe ser nombre_de_fuente.afm. Si la fuente estará embebida, el fichero nombre_de_fuente.pfb que contiene el esquema de la fuente también debe estar presente.

Llamar a la función ps_findfont() antes de la primera página requiere imprimir la cabecera postscript que incluya el campo BoundingBox para el documento entero. Normalmente BoundingBox se establece con la primera llamada a la fucnión ps_begin_page(), que ahora va después de la función ps_findfont(). Por lo tanto, BoundingBox no se ha establecido y se emitirá una advertencia al llamar a la función ps_findfont(). Para prevenir esta situación, se debería llamar a la función ps_set_parameter() para establecer BoundingBox antes de llamar a la función ps_findfont().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

fontname

El nombre de la fuente.

encoding

ps_findfont() intentará cargar el fichero pasado al parámetro encoding. Los archivos codificados tienen la misma sintaxis que los utilizados por dvips(1). Contienen un vector de codificación de fuente (que actualmente no se usa pero debe estar presente) y una lista de ligaduras extra para prolongar la lista de ligaduras derivada del fichero afm.

encoding puede ser null o la cadena vacía si se usará la codificación predeterminada (TeXBase1).

Si la codificación se establece a builtin no habrá recodificación y se usará la codificación específica de la fuente. Esto es muy útil con fuentes de símbolos.

embed

Si se establece a un valor >0 la fuente será embebida en el documento. Esto requiere que el esquema de la fuente (fichero .pfb) esté presente.

Valores devueltos

Devuelve el identificador de la fuente, o cero en caso de error. El identificador es un número positivo.

Ver también

  • ps_begin_page() - Empezar una nueva página
  • ps_setfont() - Establecer la fuente a usar para la siguiente impresión


Obtener el buffer completo que contiene la información generada de PS

  • « ps_findfont
  • ps_get_parameter »
  • PHP Manual
  • Funciones de PS
  • Obtener el buffer completo que contiene la información generada de PS

ps_get_buffer

(PECL ps >= 1.1.0)

ps_get_buffer — Obtener el buffer completo que contiene la información generada de PS

Descripción

ps_get_buffer ( resource $psdoc ) : string

Esta función aún no está implementada. Siempre devolverá una cadena vacía. La idea para una implementación posterior es escribir el contenido del fichero postscript en un buffer interno si se solicita la creación en memoria, y recuperar el contenifo del buffer con esta función. Actualmente, los documentos creados en memoria son enviados al visualizador sin la participación de un buffer.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Ver también

  • ps_open_file() - Abrir un fichero para su impresión


Obtener ciertos parámetros

  • « ps_get_buffer
  • ps_get_value »
  • PHP Manual
  • Funciones de PS
  • Obtener ciertos parámetros

ps_get_parameter

(PECL ps >= 1.1.0)

ps_get_parameter — Obtener ciertos parámetros

Descripción

ps_get_parameter ( resource $psdoc , string $name , float $modifier = ? ) : string

Obtiene varios parámetros que se establecieron directamente con la función ps_set_parameter() o indirectamente por alguna de las otras funciones. Los parámetros son por definición valores de tipo string. Esta función no se puede usar para recuperar recursos que también fueron establecidos con la función ps_set_parameter().

El parámetro name puede tener los siguientes valores:

fontname

El nombre de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

fontencoding

La codificación de la fuente activa.

dottedversion

La versión de la biblioteca pslib subyacente con el formato <mayor>.<menor>.<submenor>

scope

El ámbito de dibujo actual. Puede ser un objeto, un documento, null, una página, un patrón, un trazado, una plantilla, un prólogo, una fuente, un glifo.

ligaturedisolvechar

El carácter que disuelve una ligadura. Si se está utilizando una fuente que contiene la ligadura 'ff' y '|' es el carácter para disolver la ligadura, 'f|f' resultará en dos 'f' en lugar de la ligadura 'ff'.

imageencoding

La codificación utilizada para codificar imágenes. Puede ser hex o 85. La codificación hex usa dos bytes en el fichero postscript por cada byte de la imagen. 85 representa la codificación Ascii85.

linenumbermode

Establecer a paragraph si las líneas están numeradas dentro de un párrafo, o box si están numeradas dentro de una caja circundante.

linebreak

Se usa solamente si el texto se imprime con la función ps_show_boxed(). Si se establece a true un retorno de carro añadirá un salto de línea.

parbreak

Se usa solamente si el texto se imprime con la función ps_show_boxed(). Si se establece a true un retorno de carro iniciará un nuevo párrafo.

hyphenation

Se usa solamente si el texto se imprime con la función ps_show_boxed(). Si se establece a true el párrafo será dividido mediante guiones si está establecido y existe un diccionario de partición silábica.

hyphendict

Nombre de fichero del diccionario usado como patrón de partición silábica.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

name

El nombre del parámetro.

modifier

Un identificador necesario si se solicita un parámetro de un recurso, p.ej. el tamaño de una imagen. En tal caso se pasa el ID del recurso.

Valores devueltos

Devuelve el valor del parámetro o false en caso de error.

Ver también

  • ps_set_parameter() - Establecer ciertos parámetros


Obtener ciertos valores

  • « ps_get_parameter
  • ps_hyphenate »
  • PHP Manual
  • Funciones de PS
  • Obtener ciertos valores

ps_get_value

(PECL ps >= 1.1.0)

ps_get_value — Obtener ciertos valores

Descripción

ps_get_value ( resource $psdoc , string $name , float $modifier = ? ) : float

Obtiene varios valores que se establecieron con la función ps_set_value(). Los valores son por definición valores de tipo float.

El parámetro name puede tener los siguientes valores:

fontsize

El tamaño de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

font

La fuente activa misma.

imagewidth

El ancho de la imagen cuyo ID es pasado al parámetro modifier.

imageheight

El alto de la imagen cuyo ID es pasado al parámetro modifier.

capheight

El alto de una M mayúscula de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

ascender

El ascendente de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

descender

El descendente de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

italicangle

El ángulo de la letra itálica de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

underlineposition

La posición del subrayado de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

underlinethickness

El grosor del subrayado de la fuente activa o la fuente cuyo identificador es pasado al parámetro modifier.

textx

La coordenada x para la impresión del texto.

texty

La coordenada y para la impresión del texto.

textrendering

El modo actual de renderización de texto.

textrise

El espacio por el que el texto es alzado por encima de la línea base.

leading

La distancia entre líneas de texto en puntos.

wordspacing

El espacio entre palabras como un múltiplo del ancho de un carácter espacio.

charspacing

El espacio entre caracteres. Si "charspacing" es != 0.0, las liagaduras siempre serán disueltas.

hyphenminchars

El número mínimo de caracteres divididos mediante guión al final de una palabra.

parindent

El sangrado de las primeras n líneas de un párrafo.

numindentlines

El número de línea a sangrar de un párrafo si "parindent" != 0.0.

parskip

La distancia entre párrafos.

linenumberspace

El espacio total delante de cada línea para el número de línea.

linenumbersep

El espacio entre la línea y el número de línea.

major

El número de la versión mayor de pslib.

minor

El número de la versión menor pslib.

subminor, revision

El número de la versión submenor de pslib.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

name

El nombre del valor.

modifier

El parámetro modifier especifica el recurso por el que recuperar el valor. Puede ser el ID de una fuente o imagen.

Valores devueltos

Devuelve el valor del parámetros o false.

Ver también

  • ps_set_value() - Establecer ciertos valores


Particionar silábicamente una palabra

  • « ps_get_value
  • ps_include_file »
  • PHP Manual
  • Funciones de PS
  • Particionar silábicamente una palabra

ps_hyphenate

(PECL ps >= 1.1.1)

ps_hyphenate — Particionar silábicamente una palabra

Descripción

ps_hyphenate ( resource $psdoc , string $text ) : array

Particiona silábicamente la palabra proporcionada. ps_hyphenate() evalúa el valor "hyphenminchars" (establecido mediante la función ps_set_value()) y el parámetro "hyphendict" (establecido mediante la función ps_set_parameter()). "hyphendict" debe establecerse antes de llamar a esta función.

Esta función requiere que la categoría de configuración regional LC_CTYPE sea establecida correctamente. Esto se realiza cuando la extensión se inicializa utilizando las variables de entorno. Lea el manual de 'locale' de sistemas Unix para más información.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

text no debería contener ningún carácter que no sea una letra. Las posiciones posibles para las divisiones son devueltas en un array de números enteros. Cada número es la posición del carácter de text después del cual puede tomar lugar una partición silábica.

Valores devueltos

Un array de enteros indicando la posición de posibles divisiones del texto o false en caso de error.

Ejemplos

Ejemplo #1 Particionar silábicamente un texto

<?php
$palabra = "Koordinatensystem";
$doumento_ps = ps_new();
ps_set_parameter($doumento_ps, "hyphendict", "hyph_de.dic");
$guiones = ps_hyphenate($doumento_ps, $palabra);
for($i=0; $i<strlen($palabra); $i++) {
  echo $palabra[$i];
  if(in_array($i, $guiones))
    echo "-";
}
ps_delete($doumento_ps);
?>

El resultado del ejemplo sería:

Ko-ordi-na-ten-sys-tem

Ver también

  • ps_show_boxed() - Imprimir texto en una caja
  • locale(1)


Leer un fichero externo con código PostScript sin tratar

  • « ps_hyphenate
  • ps_lineto »
  • PHP Manual
  • Funciones de PS
  • Leer un fichero externo con código PostScript sin tratar

ps_include_file

(PECL ps >= 1.3.4)

ps_include_file — Leer un fichero externo con código PostScript sin tratar

Descripción

ps_include_file ( resource $psdoc , string $file ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

file

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Dibujar una línea

  • « ps_include_file
  • ps_makespotcolor »
  • PHP Manual
  • Funciones de PS
  • Dibujar una línea

ps_lineto

(PECL ps >= 1.1.0)

ps_lineto — Dibujar una línea

Descripción

ps_lineto ( resource $psdoc , float $x , float $y ) : bool

Añade una línea recta al trazado actual desde el punto actual hasta las coordenadas dadas. Use la función ps_moveto() para establecer el punto de inicio de la línea.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del punto final de la línea.

y

La coordenada y del punto final de la línea.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Dibujar un rectángulo

<?php
$ps = ps_new();
if (!ps_open_file($ps, "rectángulo.ps")) {
  print "No se puede abrir el fichero PostScript\n";
  exit;
}

ps_set_info($ps, "Creator", "rectángulo.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de lineto");

ps_begin_page($ps, 596, 842);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

Ver también

  • ps_moveto() - Establecer el punto actual


Crear un color directo

  • « ps_lineto
  • ps_moveto »
  • PHP Manual
  • Funciones de PS
  • Crear un color directo

ps_makespotcolor

(PECL ps >= 1.1.0)

ps_makespotcolor — Crear un color directo

Descripción

ps_makespotcolor ( resource $psdoc , string $name , int $reserved = 0 ) : int

Crea un color directo desde el color de relleno actual. El color de relleno debe ser definido en los espacios de color RGB, CMYK o gris. El nombre del color directo puede ser un nombre arbitrario. Un color directo se puece establecer como cualquier otro color con la función ps_setcolor(). Cuando el documento no se imprime, sino que se muestra con un visualizador de postscript, se utiliza el color dado en el espacio de color especificado.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

name

El nombre del color directo, p.ej. Pantone 5565.

Valores devueltos

El ID del nuevo color directo o 0 en caso de error.

Ejemplos

Ejemplo #1 Crear y utilizar un color directo

<?php
$ps = ps_new();
if (!ps_open_file($ps, "color_directo.ps")) {
  print "No se puede abrir el fichero PostScript\n";
  exit;
}

ps_set_info($ps, "Creator", "color_directo.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de color directo");

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "fill", "cmyk", 0.37, 0.0, 0.34, 0.34);
$color_directo = ps_makespotcolor($ps, "PANTONE 5565 C", 0);
ps_setcolor($ps, "fill", "spot", $color_directo, 0.5, 0.0, 0.0);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_fill($ps);
ps_end_page($ps);

ps_delete($ps);
?>

Este ejemplo crea el color directo "PANTONE 5565 C" que es un verde oscuro (oliva) y rellena un rectángulo con el 50% de intensidad.

Ver también

  • ps_setcolor() - Establecer el color actual


Establecer el punto actual

  • « ps_makespotcolor
  • ps_new »
  • PHP Manual
  • Funciones de PS
  • Establecer el punto actual

ps_moveto

(PECL ps >= 1.1.0)

ps_moveto — Establecer el punto actual

Descripción

ps_moveto ( resource $psdoc , float $x , float $y ) : bool

Establece el punto actual a unas coordenadas nuevas. Si esta es la primera llamada a la función ps_moveto() después de haber finalizado un trazado previo, se iniciará un nuevo trazado. Si esta función es llamada en mitad de un trazado establecerá el punto actual e iniciará un subtrazado.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del punto al que moverse.

y

La coordenada y del punto al que moverse.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_lineto() - Dibujar una línea


Crear un nuevo objeto de documento PostScript

  • « ps_moveto
  • ps_open_file »
  • PHP Manual
  • Funciones de PS
  • Crear un nuevo objeto de documento PostScript

ps_new

(PECL ps >= 1.1.0)

ps_new — Crear un nuevo objeto de documento PostScript

Descripción

ps_new ( ) : resource

Crea una nueva instancia de documento. No crea el fichero en disco o en memoria, simplemente establece todo. ps_new() normalmente es seguido de una llamada a la función ps_open_file() para crear realmente el documento postscript.

Valores devueltos

Un recurso de un documento PostScript, o false en caso de error. El valor devuelto es pasado a todas las demás funciones como primer argumento.

Ver también

  • ps_delete() - Borrar todos los recursos de un documento PostScript


Abrir un fichero para su impresión

  • « ps_new
  • ps_open_image_file »
  • PHP Manual
  • Funciones de PS
  • Abrir un fichero para su impresión

ps_open_file

(PECL ps >= 1.1.0)

ps_open_file — Abrir un fichero para su impresión

Descripción

ps_open_file ( resource $psdoc , string $filename = ? ) : bool

Crea un fichero en disco y escribe el documento PostScript en él. El fichero será cerrado cuando se llame a la función ps_close().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

filename

El nombre del fichero postscript. Si no se proporciona filename el documento será creado en memoria y todas las salidas irán directas al visualizador.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_close() - Cerrar un documento PostScript


Abre una imagen desde un fichero

  • « ps_open_file
  • ps_open_image »
  • PHP Manual
  • Funciones de PS
  • Abre una imagen desde un fichero

ps_open_image_file

(PECL ps >= 1.1.0)

ps_open_image_file — Abre una imagen desde un fichero

Descripción

ps_open_image_file ( resource $psdoc , string $type , string $filename , string $stringparam = ? , int $intparam = 0 ) : int

Carga una imagen para su uso posterior.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

El tipo de la imagen. Los posibles valores son png, jpeg, o eps.

filename

El nombre del fichero que contiene la información de la imagen.

stringparam

No se utiliza.

intparam

No se utiliza.

Valores devueltos

Devuelve el identificador de la imagen, o cero en caso de error. El identificador es un número positivo mayor que 0.

Ver también

  • ps_open_image() - Leer una imagen para su colocación posterior
  • ps_place_image() - Colocar una imágen en la página
  • ps_close_image() - Cerrar una imagen y liberar memoria


Leer una imagen para su colocación posterior

  • « ps_open_image_file
  • ps_open_memory_image »
  • PHP Manual
  • Funciones de PS
  • Leer una imagen para su colocación posterior

ps_open_image

(PECL ps >= 1.1.0)

ps_open_image — Leer una imagen para su colocación posterior

Descripción

ps_open_image ( resource $psdoc , string $type , string $source , string $data , int $lenght , int $width , int $height , int $components , int $bpc , string $params ) : int

Lee una imagen que ya está disponible en memoria. El parámetro source actualmente no se evalua y se asume que es memory. La información de la imagen es una secuencia de píxeles que comienza en la esquina superior izquierda y termina en la exquina inferior derecha. Cada píxel consiste en componentes de color dados por components, y cada componente tiene bpc bits.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

El tipo de la imagen. Los posibles valores son png, jpeg, o eps.

source

No se utiliza.

data

La información de la imagen.

length

La longitud de la información de la imagen.

width

El ancho de la imagen.

height

El alto de la imagen.

components

El número de componentes de cada píxel. Puede ser 1 (imágenes en escala de grises), 3 (imágenes rgb), o 4 (imágenes cmyk, rgba).

bpc

Número de bits por componente (normalmente 8).

params

Valores devueltos

Devuelve el identificador de la imagen, o cero en caso de error. El identificador es un número positivo mayor que 0.

Ver también

  • ps_open_image_file() - Abre una imagen desde un fichero
  • ps_place_image() - Colocar una imágen en la página
  • ps_close_image() - Cerrar una imagen y liberar memoria


Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS

  • « ps_open_image
  • ps_place_image »
  • PHP Manual
  • Funciones de PS
  • Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS

ps_open_memory_image

(PECL ps >= 1.1.0)

ps_open_memory_image — Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS

Descripción

ps_open_memory_image ( resource $psdoc , int $gd ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

gd


Colocar una imágen en la página

  • « ps_open_memory_image
  • ps_rect »
  • PHP Manual
  • Funciones de PS
  • Colocar una imágen en la página

ps_place_image

(PECL ps >= 1.1.0)

ps_place_image — Colocar una imágen en la página

Descripción

ps_place_image ( resource $psdoc , int $imageid , float $x , float $y , float $scale ) : bool

Coloca una imagen cargada anteriormente en la página. La imagen puede ser redimensionada. Si la imagen también debe rotarse, se ha de rotar antes el sistema de coordenadas con la función ps_rotate().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

imageid

El identificador de recursos de la imagen, como el devuelto por las funciones ps_open_image() o ps_open_image_file().

x

La coordenada x de la esquina inferior izquierda de la imagen.

y

La coordenada y de la esquina inferior izquierda de la imagen.

scale

El factor de escala de la imagen. Una escala de 1.0 resultará en una resolución de 72 dpi, ya que cada píxel es equivalente a 1 punto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_open_image() - Leer una imagen para su colocación posterior
  • ps_open_image_file() - Abre una imagen desde un fichero


Dibujar un rectángulo

  • « ps_place_image
  • ps_restore »
  • PHP Manual
  • Funciones de PS
  • Dibujar un rectángulo

ps_rect

(PECL ps >= 1.1.0)

ps_rect — Dibujar un rectángulo

Descripción

ps_rect ( resource $psdoc , float $x , float $y , float $width , float $height ) : bool

Dibuja un rectángulo con su esquina inferior izquierda en (x, y). El rectángulo comienza y finaliza en su esquina inferior izquierda. Si se llama a esta función fuera de un trazado iniciará un nuevo trazado. Se es llamada dentro de un trazado añadirá el rectángulo como un subtrazado. Si la última operación de dibujo no finaliza en la esquina inferior izquierda, existirá un hueco en el trazado.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x de la esquina inferior izquierda del rectángulo.

y

La coordenada y de la esquina inferior izquierda del rectángulo.

width

El ancho de la imagen.

height

El alto de la imagen.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_arc() - Dibujar un arco en el sentido contrario a las agujas del reloj
  • ps_cirle()
  • ps_lineto() - Dibujar una línea


Restaurar un contexto previamente guardado

  • « ps_rect
  • ps_rotate »
  • PHP Manual
  • Funciones de PS
  • Restaurar un contexto previamente guardado

ps_restore

(PECL ps >= 1.1.0)

ps_restore — Restaurar un contexto previamente guardado

Descripción

ps_restore ( resource $psdoc ) : bool

Restaura un conexto de gráficos previamente guardado. Cualquier llamada a la función ps_save() debe estar acompañada por una llamada a ps_restore(). Todas las transformaciones de coordenadas, ajustes de estilos de línea, ajustes de color, etc., son restauradas al estado anterior de la llamada a la función ps_save().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_save() - Guardar el contexto actual


Establecer el factor de rotación

  • « ps_restore
  • ps_save »
  • PHP Manual
  • Funciones de PS
  • Establecer el factor de rotación

ps_rotate

(PECL ps >= 1.1.0)

ps_rotate — Establecer el factor de rotación

Descripción

ps_rotate ( resource $psdoc , float $rot ) : bool

Establece la rotación del sistema de coordenadas.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

rot

El ángulo de rotación en grados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Rotación del sistema de coordenadas

<?php
function rectángulo($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "rotación.ps")) {
  print "No se pudo abrir el fichero PostScript\n";
  exit;
}

ps_set_info($ps, "Creator", "rotación.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de rotación");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 100, 100);
ps_rotate($ps, 45);
rectángulo($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Texto sin rotación");
ps_end_page($ps);

ps_delete($ps);
?>

El ejemplo anterior ilustra una forma muy común de rotar un gráfico (en este caso un rectángulo) simplemente rotando el sistema de coordenadas. Ya que se asume que el origen del sistema de coordenadas del gráfico es (0,0), el sistema de coordenadas de la página también es trasladado para colocar los gráficos no en el extremo de la pagina. Se debe poner atención en el orden de ps_translate() y ps_rotate(). En el caso anterior el rectángulo es rotado alrededor del punto (100, 100) en el sistema de coordenadas sin trasladar. Si se cambian las dos sentencias se obtendrá un resultado completamente diferente.

Para poder imprimir el texto siguiente en la posición original, todas las modificaciones del sistema de coordenadas son encapsuladas en las funciones ps_save() y ps_restore().

Ver también

  • ps_scale() - Estalecer el factor de escala
  • ps_translate() - Establecer una traslación


Guardar el contexto actual

  • « ps_rotate
  • ps_scale »
  • PHP Manual
  • Funciones de PS
  • Guardar el contexto actual

ps_save

(PECL ps >= 1.1.0)

ps_save — Guardar el contexto actual

Descripción

ps_save ( resource $psdoc ) : bool

Guarda el contexto de gráficos actual, conteniendo ajustes de color, de traslación y de rotación, y algunos más. Un contexto guardado puede ser restaurado con ps_restore().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_restore() - Restaurar un contexto previamente guardado


Estalecer el factor de escala

  • « ps_save
  • ps_set_border_color »
  • PHP Manual
  • Funciones de PS
  • Estalecer el factor de escala

ps_scale

(PECL ps >= 1.1.0)

ps_scale — Estalecer el factor de escala

Descripción

ps_scale ( resource $psdoc , float $x , float $y ) : bool

Establece el factor de escala horizontal y vertical del sistema de coordenadas.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

El factor de escala en dirección horizontal.

y

El factor de escala en dirección vertical.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_rotate() - Establecer el factor de rotación
  • ps_translate() - Establecer una traslación


Establecer el color del borde de las anotaciones

  • « ps_scale
  • ps_set_border_dash »
  • PHP Manual
  • Funciones de PS
  • Establecer el color del borde de las anotaciones

ps_set_border_color

(PECL ps >= 1.1.0)

ps_set_border_color — Establecer el color del borde de las anotaciones

Descripción

ps_set_border_color ( resource $psdoc , float $red , float $green , float $blue ) : bool

Los vínculos añadidos con una de las funciones ps_add_weblink(), ps_add_pdflink(), etc., se mostrarán con un rectángulo circundante cuando el documento postscript es convertido a pdf y visualizado en un visualizador de pdf. Este rectángulo no es visible en el documento postscript. Esta función establece el color de la línea del borde del rectángulo.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

red

El componente rojo del color del borde.

green

El componente verde del color del borde.

blue

El componente azul del color del borde.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_set_border_dash() - Establece la longitud de las rayas del borde de las anotaciones
  • ps_set_border_style() - Establecer el estilo del borde de las anotaciones


Establece la longitud de las rayas del borde de las anotaciones

  • « ps_set_border_color
  • ps_set_border_style »
  • PHP Manual
  • Funciones de PS
  • Establece la longitud de las rayas del borde de las anotaciones

ps_set_border_dash

(PECL ps >= 1.1.0)

ps_set_border_dash — Establece la longitud de las rayas del borde de las anotaciones

Descripción

ps_set_border_dash ( resource $psdoc , float $black , float $white ) : bool

Los vínculos añadidos con una de las funciones ps_add_weblink(), ps_add_pdflink(), etc. se mostrarán con un rectángulo circundante cuando el documento postscript es convertido a pdf y visualizado en un visualizador de pdf. Este rectángulo no es visible en el documento postscript. Esta función establece la longitud de las porciones negras y blancas de una línea de borde discontinua.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

black

La longitud de la raya.

white

La longitud del hueco entre rayas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_set_border_color() - Establecer el color del borde de las anotaciones
  • ps_set_border_style() - Establecer el estilo del borde de las anotaciones


Establecer el estilo del borde de las anotaciones

  • « ps_set_border_dash
  • ps_set_info »
  • PHP Manual
  • Funciones de PS
  • Establecer el estilo del borde de las anotaciones

ps_set_border_style

(PECL ps >= 1.1.0)

ps_set_border_style — Establecer el estilo del borde de las anotaciones

Descripción

ps_set_border_style ( resource $psdoc , string $style , float $width ) : bool

Los vínculos añadidos con una de las funciones ps_add_weblink(), ps_add_pdflink(), etc. se mostrarán con un rectángulo circundante cuando el documento postscript es convertido a pdf y visualizado en un visualizador de pdf. Este rectángulo no es visible en el documento postscript. Esta función establece la apariencia y el ancho de la línea del borde.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

style

style puede ser solid o dashed.

width

El ancho del borde.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_set_border_color() - Establecer el color del borde de las anotaciones
  • ps_set_border_dash() - Establece la longitud de las rayas del borde de las anotaciones


Establecer los campos de información del documento

  • « ps_set_border_style
  • ps_set_parameter »
  • PHP Manual
  • Funciones de PS
  • Establecer los campos de información del documento

ps_set_info

(PECL ps >= 1.1.0)

ps_set_info — Establecer los campos de información del documento

Descripción

ps_set_info ( resource $p , string $key , string $val ) : bool

Establece ciertos campos de información del documento. Estos campos se mostrarán como un comentario en la cabecera del fichero PostScript. Si el documento es convertido a pdf, estos campos también se usarán para la información del documento.

El campo BoundingBox normalmente se establece al valor dado a la primera página. Esto sólo funciona si no se ha llamado antes a la función ps_findfont(). En tal caso BoundingBox estará sin establecer a menos que se establezca explícitamente con esta función.

Esta función ya no tendrá efecto cuando la cabecera del fichero postscript ha sido escrita. Debe ser llamada antes de la primera página o de la primera llamada a la función ps_findfont().

Parámetros

psdoc

Un identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

key

El nombre del campo de información a establecer. Los valores que se pueden establecer son Keywords (palabras clave), Subject (asunto), Title (título), Creator (creador), Author (autor), BoundingBox (caja circundante), y Orientation (orientación). Tenga en cuenta que algunos de ellos tienen un significado para los visualizadoes de PostScript.

value

El valor del campo de información. El campo Orientation puede ser establecido a Portrait (horizontal) o Landscape (vertical). El campo BoundingBox es una cadena de caracteres que consiste en cuatro números. Los dos primeros son las coordenadas de la esquina inferior izquierda de la página. Los dos últimos son las coordenadas de la esquina superior derecha.

Nota:

Hasta la versión 0.2.6 de pslib, los campos BoundingBox y Orientation eran sobrescritos por la función ps_begin_page(), a menos que se llamara antes a la función ps_findfont().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_findfont() - Cargar una fuente
  • ps_begin_page() - Empezar una nueva página


Establecer ciertos parámetros

  • « ps_set_info
  • ps_set_text_pos »
  • PHP Manual
  • Funciones de PS
  • Establecer ciertos parámetros

ps_set_parameter

(PECL ps >= 1.1.0)

ps_set_parameter — Establecer ciertos parámetros

Descripción

ps_set_parameter ( resource $psdoc , string $name , string $value ) : bool

Establece varios parámetros que son utilizados por muchas funciones. Los parámetros son por definción valores de tipo string.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

name

Para una lista de los posibles nombres véase la función ps_get_parameter().

value

El valor del parámetro.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_get_parameters()
  • ps_set_value() - Establecer ciertos valores


Establecer la posición de la salida de texto

  • « ps_set_parameter
  • ps_set_value »
  • PHP Manual
  • Funciones de PS
  • Establecer la posición de la salida de texto

ps_set_text_pos

(PECL ps >= 1.1.0)

ps_set_text_pos — Establecer la posición de la salida de texto

Descripción

ps_set_text_pos ( resource $psdoc , float $x , float $y ) : bool

Establece la posición de la siguiente salida de texto. Alternativamente se puede establecer los valores x e y por serparado llamando a la función ps_set_value() y eligiendo textx y texty respectivamente como el nombre del valor.

Si se ha de imprimir el texto en una cierta posición es más conveniente utilizar la función ps_show_xy() en lugar de establecer la posición del texto y llamar a la función ps_show().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x de la nueva posición del texto.

y

La coordenada y de la nueva posición del texto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Colocar texto en una posición dada

<?php
$ps = ps_new();
if (!ps_open_file($ps, "texto.ps")) {
  print "No se pudo abrir el fichero PostScript\n";
  exit;
}

ps_set_info($ps, "Creator", "rectángulo.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de colocación de texto");

ps_begin_page($ps, 596, 842);
$psfont = ps_findfont($ps, "Helvetica", "", 0);
ps_setfont($ps, $psfont, 8.0);
ps_show_xy($ps, "Algún texto en (100, 100)", 100, 100);

ps_set_value($ps, "textx", 100);
ps_set_value($ps, "texty", 120);
ps_show($ps, "Algún texto en (100, 120)");
ps_end_page($ps);

ps_delete($ps);
?>

Ver también

  • ps_set_value() - Establecer ciertos valores
  • ps_show() - Imprimir texto


Establecer ciertos valores

  • « ps_set_text_pos
  • ps_setcolor »
  • PHP Manual
  • Funciones de PS
  • Establecer ciertos valores

ps_set_value

(PECL ps >= 1.1.0)

ps_set_value — Establecer ciertos valores

Descripción

ps_set_value ( resource $psdoc , string $name , float $value ) : bool

Establece varios valores que son utilizados por muchas funciones. Los parámetros son por definición valores de tipo float.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

name

El nombre dado por name puede ser uno de los siguientes:

textrendering

La manera en que se muestra el texto.

textx

La coordenada x para la impresión del texto.

texty

La coordenada y para la impresión del texto.

wordspacing

La distancia entre palabras relativa al ancho de un espacio.

leading

La distancia entre líneas en píxeles.

value

El valor del parámetro.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_get_value() - Obtener ciertos valores
  • ps_set_parameter() - Establecer ciertos parámetros


Establecer el color actual

  • « ps_set_value
  • ps_setdash »
  • PHP Manual
  • Funciones de PS
  • Establecer el color actual

ps_setcolor

(PECL ps >= 1.1.0)

ps_setcolor — Establecer el color actual

Descripción

ps_setcolor ( resource $psdoc , string $type , string $colorspace , float $c1 , float $c2 , float $c3 , float $c4 ) : bool

Establece el color para dibujar, rellanar, o ambos.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

El parámetro type puede ser both (ambos), fill (relleno), o fillstroke (contornear).

colorspace

El espacio de color debería ser gray, rgb, cmyk, spot, pattern. Dependiendo del espacio de color se usará solamente el primero parámetro, los tres primeros o todos los parámetros.

c1

Dependiendo del espacio de color es el componente rojo (rgb), el componente cian (cmyk), el valor de gris (gray), el identificador del color directo (spot) o el identificador del patrón (pattern).

c2

Dependiendo del espacio de color es el componente verde (rgb) o el componente magenta (cmyk).

c3

Dependiendo del espacio de color es el componente azul (rgb) o el componente amarillo (cmyk).

c4

Este parámetro sólo debe establecerse en el espacio de color cmyk, y especifica el componente negro.

Errores

El segundo parámetro actualmente no siempre es evaluado. El color es a veces establecido para relleno o dibujo como si se le pasara fillstroke.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer la apariencia de una línea discontinua

  • « ps_setcolor
  • ps_setflat »
  • PHP Manual
  • Funciones de PS
  • Establecer la apariencia de una línea discontinua

ps_setdash

(PECL ps >= 1.1.0)

ps_setdash — Establecer la apariencia de una línea discontinua

Descripción

ps_setdash ( resource $psdoc , float $on , float $off ) : bool

Establece la longitud de las porciones negras y blancas de una línea discontinua.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

on

La longitud de la raya.

off

La longitud del hueco entre rayas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setpolydash() - Establecer la apariencia de una línea discontinua


Establecer la planicidad

  • « ps_setdash
  • ps_setfont »
  • PHP Manual
  • Funciones de PS
  • Establecer la planicidad

ps_setflat

(PECL ps >= 1.1.0)

ps_setflat — Establecer la planicidad

Descripción

ps_setflat ( resource $psdoc , float $value ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

value

El valor dado a value debe estar entre 0.2 y 1.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer la fuente a usar para la siguiente impresión

  • « ps_setflat
  • ps_setgray »
  • PHP Manual
  • Funciones de PS
  • Establecer la fuente a usar para la siguiente impresión

ps_setfont

(PECL ps >= 1.1.0)

ps_setfont — Establecer la fuente a usar para la siguiente impresión

Descripción

ps_setfont ( resource $psdoc , int $fontid , float $size ) : bool

Establece una fuente, la cual ha de ser cargada antes con la función ps_findfont(). Imprimir texto sin establecer una fuente resultará en un error.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

fontid

El identificador de la fuente, como el devuelto por la función ps_findfont().

size

El tamaño de la fuente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_findfont() - Cargar una fuente
  • ps_set_text_pos() - Establecer la posición de la salida de texto para un ejemplo.


Establecer el valor de gris

  • « ps_setfont
  • ps_setlinecap »
  • PHP Manual
  • Funciones de PS
  • Establecer el valor de gris

ps_setgray

(PECL ps >= 1.1.0)

ps_setgray — Establecer el valor de gris

Descripción

ps_setgray ( resource $psdoc , float $gray ) : bool

Establece el valor de gris para todas las operaciones de dibujo siguientes.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

gray

El valor debe estar entre 0 (blanco) and 1 (negro).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setcolor() - Establecer el color actual


Establecer la apariencia de los extremos de línea

  • « ps_setgray
  • ps_setlinejoin »
  • PHP Manual
  • Funciones de PS
  • Establecer la apariencia de los extremos de línea

ps_setlinecap

(PECL ps >= 1.1.0)

ps_setlinecap — Establecer la apariencia de los extremos de línea

Descripción

ps_setlinecap ( resource $psdoc , int $type ) : bool

Establece la apariencia de los extremos de línea.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

El tipo de extremo de línea. Los valores posibles son PS_LINECAP_BUTT, PS_LINECAP_ROUND, o PS_LINECAP_SQUARED.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setlinejoin() - Establecer cómo están unidas las líneas conectadas
  • ps_setlinewidth() - Establecer el ancho de una línea
  • ps_setmiterlimit() - Establecer el límite del inglete


Establecer cómo están unidas las líneas conectadas

  • « ps_setlinecap
  • ps_setlinewidth »
  • PHP Manual
  • Funciones de PS
  • Establecer cómo están unidas las líneas conectadas

ps_setlinejoin

(PECL ps >= 1.1.0)

ps_setlinejoin — Establecer cómo están unidas las líneas conectadas

Descripción

ps_setlinejoin ( resource $psdoc , int $type ) : bool

Establece cómo se unen las líneas

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

La forma de unir las líneas. Los valores posibles son PS_LINEJOIN_MITER, PS_LINEJOIN_ROUND, o PS_LINEJOIN_BEVEL.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setlinecap() - Establecer la apariencia de los extremos de línea
  • ps_setlinewidth() - Establecer el ancho de una línea
  • ps_setmiterlimit() - Establecer el límite del inglete


Establecer el ancho de una línea

  • « ps_setlinejoin
  • ps_setmiterlimit »
  • PHP Manual
  • Funciones de PS
  • Establecer el ancho de una línea

ps_setlinewidth

(PECL ps >= 1.1.0)

ps_setlinewidth — Establecer el ancho de una línea

Descripción

ps_setlinewidth ( resource $psdoc , float $width ) : bool

Esteblece el ancho de línea para todas las operaciones de dibujo siguientes.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

width

El ancho de las líneas en puntos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setlinecap() - Establecer la apariencia de los extremos de línea
  • ps_setlinejoin() - Establecer cómo están unidas las líneas conectadas
  • ps_setmiterlimit() - Establecer el límite del inglete


Establecer el límite del inglete

  • « ps_setlinewidth
  • ps_setoverprintmode »
  • PHP Manual
  • Funciones de PS
  • Establecer el límite del inglete

ps_setmiterlimit

(PECL ps >= 1.1.0)

ps_setmiterlimit — Establecer el límite del inglete

Descripción

ps_setmiterlimit ( resource $psdoc , float $value ) : bool

Si dos líneas se unen en un ángulo pequeño y la unión de líneas está establecida a PS_LINEJOIN_MITER, el pico resultante será muy largo. El límite de inglete es la proporción máxima entre la longitud del inglete (la longitud del pico) y del ancho de línea.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

value

La proporción máxima entre la longitud del inglete y del ancho de línea. Los valores grandes (> 10) resultarán en picos muy largos cuando dos líneas se encuentren en un ángulo pequeño. Mantenga el predeterminado a menos que sepa lo que está haciendo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_setlinecap() - Establecer la apariencia de los extremos de línea
  • ps_setlinejoin() - Establecer cómo están unidas las líneas conectadas
  • ps_setlinewidth() - Establecer el ancho de una línea


Establecer el modo de sobreimpresión

  • « ps_setmiterlimit
  • ps_setpolydash »
  • PHP Manual
  • Funciones de PS
  • Establecer el modo de sobreimpresión

ps_setoverprintmode

(PECL ps >= 1.3.0)

ps_setoverprintmode — Establecer el modo de sobreimpresión

Descripción

ps_setoverprintmode ( resource $psdoc , int $mode ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

mode

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer la apariencia de una línea discontinua

  • « ps_setoverprintmode
  • ps_shading_pattern »
  • PHP Manual
  • Funciones de PS
  • Establecer la apariencia de una línea discontinua

ps_setpolydash

(PECL ps >= 1.1.0)

ps_setpolydash — Establecer la apariencia de una línea discontinua

Descripción

ps_setpolydash ( resource $psdoc , float $arr ) : bool

Establece la longitud de las porciones negras y blancas de una línea discontinua. La función ps_setpolydash() se usa para establecer patrones discontinuos más complejos.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

arr

arr es una lista de elementos de longitud alternados para las porcioines negras y blancas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Dibujar una línea discontinua

<?php
$ps = ps_new();
if (!ps_open_file($ps, "poliraya.ps")) {
   print "No se puede abrir el fichero PostScript\n";
     exit;
}

ps_set_info($ps, "Creator", "poliraya.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de poliraya");

ps_begin_page($ps, 596, 842);
ps_setpolydash($ps, array(10, 5, 2, 5));
ps_moveto($ps, 100, 100);
ps_lineto($ps, 200, 200);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

Este ejemplo dibuja una línea con rayas de 10 y 2 puntos de longitud, y huecos de 5 puntos entre ellas.

Ver también

  • ps_setdash() - Establecer la apariencia de una línea discontinua


Crear un patrón basado en un sombreado

  • « ps_setpolydash
  • ps_shading »
  • PHP Manual
  • Funciones de PS
  • Crear un patrón basado en un sombreado

ps_shading_pattern

(PECL ps >= 1.3.0)

ps_shading_pattern — Crear un patrón basado en un sombreado

Descripción

ps_shading_pattern ( resource $psdoc , int $shadingid , string $optlist ) : int

Crea un patrón basado en un sombreado, el cual ha de ser creado antes con la función ps_shading(). Los patrones de sombreado se pueden usar como patrones normales.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

shadingid

El identificador de un sombreado previamente creado con la función ps_shading().

optlist

Este argumento actualmente no se usa.

Valores devueltos

El identificador del patrón o false en caso de error.

Ver también

  • ps_shading() - Crear un sombreado para su uso posterior
  • ps_shfill() - Rellenar un área con un sombreado


Crear un sombreado para su uso posterior

  • « ps_shading_pattern
  • ps_shfill »
  • PHP Manual
  • Funciones de PS
  • Crear un sombreado para su uso posterior

ps_shading

(PECL ps >= 1.3.0)

ps_shading — Crear un sombreado para su uso posterior

Descripción

ps_shading ( resource $psdoc , string $type , float $x0 , float $y0 , float $x1 , float $y1 , float $c1 , float $c2 , float $c3 , float $c4 , string $optlist ) : int

Crea un sombreado que puede ser utilizado por las funciones ps_shfill() o ps_shading_pattern().

El color del sombreado puede estar en cualquier espacio de color excepto para pattern.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

type

El tipo de sombreado puede ser radial o axial. Cada sombreado comienza con el color de relleno actual y termina con los valores de color pasados a los parámetros c1 a c4 (véase la función ps_setcolor() para sus significados).

x0, x1, y0, y1

Las coordenadas x0, y0, x1, y1 son el punto de inicio y el punto final del sombreado. Si el tipo de sombreado es radial los dos puntos son los puntos medios de un círculo inicial y final.

c1, c2, c3, c4

Véase la función ps_setcolor() para sus significados.

optlist

Si el sombreado es de tipo radial el parámetro optlist debe contener también los parámetros r0 y r1 con el radio del círculo inicial y final.

Valores devueltos

Devuelve el identificador del patrón o false en caso de error.

Ver también

  • ps_shading_pattern() - Crear un patrón basado en un sombreado
  • ps_shfill() - Rellenar un área con un sombreado


Rellenar un área con un sombreado

  • « ps_shading
  • ps_show_boxed »
  • PHP Manual
  • Funciones de PS
  • Rellenar un área con un sombreado

ps_shfill

(PECL ps >= 1.3.0)

ps_shfill — Rellenar un área con un sombreado

Descripción

ps_shfill ( resource $psdoc , int $shadingid ) : bool

Rellena un área con un sombreado, que ha de ser creado antes con la función ps_shading(). Esta es una manera alternativa de crear un patrón desde un sombreado con la función ps_shading_pattern() y usar el patrón como color de relleno.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

shadingid

El identificador de un sombreado previamente creado con la función ps_shading().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_shading() - Crear un sombreado para su uso posterior
  • ps_shading_pattern() - Crear un patrón basado en un sombreado


Imprimir texto en una caja

  • « ps_shfill
  • ps_show_xy2 »
  • PHP Manual
  • Funciones de PS
  • Imprimir texto en una caja

ps_show_boxed

(PECL ps >= 1.1.0)

ps_show_boxed — Imprimir texto en una caja

Descripción

ps_show_boxed ( resource $psdoc , string $text , float $left , float $bottom , float $width , float $height , string $hmode , string $feature = ? ) : int

Imprime un texto en la caja dada. La esquina inferior izquierda de la caja está en (left, bottom). Los saltos de línea se insertarán según sean necesarios. Los espacios múltiples se tratan como uno sólo. Las tabulaciones son tratadas como espacios.

El texto será particionado silábicamente si el parámetro hyphenation es establecido a true y el parámetro hyphendict contiene un nombre de fichero válido para un fichero de patrones de partición silábica. La interlínea se toma del valor leading. Los párrafos pueden ser separados por una línea vacía como en TeX. Si el valor parindent es establecido a un valor > 0.0, las primeras n líneas serán sangradas. El número de líneas n se establece mediante el parámetro numindentlines. Para prevenir el sangrado de los primeros m párrafos se ha de establecer el valor parindentskip a un número positivo.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto a imprimir en la caja dada.

left

La coordenada x de la esquina inferior izquierda de la caja.

bottom

La coordenada y de la esquina inferior izquierda de la caja.

width

El ancho de la caja.

height

El alto de la caja.

hmode

El parámetro hmode puede ser "justify" (justificado), "fulljustify" (justificado completamete), "right" (a la derecha), "left" (a la izquierda), o "center" (centrado). La diferencia entre "justify" y "fulljustify" afecta a la última línea de la caja. En el modo "fulljustify" la última línea será justificada a izquierda y derecha a menos que sea también la última línea del párrafo. En el modo "justify" siempre será justificada a la izquierda.

feature

Parámetros utilizados

La salida de la función ps_show_boxed() se puede configurar con varios parámetros y valores que deben ser establecidos con las funciones ps_set_parameter() o ps_set_value(). Junto a los parámetros y valores que afectan a la impresión del texto, son evaluados los siguientes parámetros y valores:

leading (valor)

La distancia entre la línea base de dos líneas consecutivas.

linebreak (parámetro)

Establecer a "true" si se necesita un retorno de carro al inicio de una nueva línea en lugar de tratarlo como un espacio. Por defecto es "false".

parbreak (parámetro)

Establecer a "true" si se necesita un retorno de carro en una sola línea para iniciar un nuevo párrafo en lugar de tratarlo como un espacio. Por defecto es "true".

hyphenation (parámetro)

Establecer a "true" para activar la partición silábica. Se requiere establecer un diccionario con el parámetro "hyphendict". Por defecto es "false".

hyphendict (parámetro)

El nombre de fichero del diccionario usado para los patrones de partición silábica (véase más abajo).

hyphenminchar (valor)

El número de caracteres que debe haber al menos antes o después del guión. Esto implica que sólo las palabras de al menos dos veces este valor serán particionadas silábicamente. El valor predeterminado es tres. Establecer un valor de cero resultará en el valor predeterminado.

parindent (valor)

Establece la cantidad de espacio en píxeles para la sangría de las m primeras líneas de un párrafo. m puede establecerse con el valor "numindentlines".

parskip (valor)

Establece el valor de espacio extra entre párrafos. Por defecto es 0, lo que resultará en una distancia de líneas normal.

numindentlines (valor)

El número de líneas desde el inicio del párrafo que serán sangradas. Por defecto es 1.

parindentskip (valor)

El número de párrafos de la caja cuyas primeras líneas no serán sangradas. Por defecto es 0. Esto es útil para párrafos situados justo antes de una sección de cabecera o para texto continuado en una segunda caja. En ambdos casos se debería establecer a 1.

linenumbermode (parámetro)

Establece la manera en que las líneas son numeradas. Los posibles valores son "box" para la numeración de líneas en la caja completa o "paragraph" para la numeración de líneas dentro de cada párrafo.

linenumberspace (valor)

El espacio para la columna a la izquierda de la línea numerada que contiene el número de línea. El número de línea será justificado a la derecha dentro de esta columna. Por defecto es 20.

linenumbersep (valor)

El espacio entre la columna con los números de línea y la línea misma. Por defecto es 5.

Partición silábica

El texto se particiona silábicamente si el parámetro hyphenation es "true" y está establecido un diccionario de partición silábica válido. pslib no trae su propio diccionario de partición silábica, pero utiliza uno de openoffice, scribus o koffice. Se pueden encontrar estos diccionarios para diferentes lenguajes en uno de los siguientes directios si el software está instalado:

  • /usr/share/apps/koffice/hyphdicts/
  • /usr/lib/scribus/dicts/
  • /usr/lib/openoffice/share/dict/ooo/
Actualmente, scribus parece tener los diccionarios de partición silábica más completos.

Valores devueltos

El número de caracteres que no podrán ser escritos.

Ver también

  • ps_continue_text() - Continuar el texto en la siguiente línea


Imprimir texto en una posición

  • « ps_show_boxed
  • ps_show_xy »
  • PHP Manual
  • Funciones de PS
  • Imprimir texto en una posición

ps_show_xy2

(PECL ps >= 1.1.0)

ps_show_xy2 — Imprimir texto en una posición

Descripción

ps_show_xy2 ( resource $psdoc , string $text , int $len , float $xcoor , float $ycoor ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Imprimir texto en una posición dada

  • « ps_show_xy2
  • ps_show2 »
  • PHP Manual
  • Funciones de PS
  • Imprimir texto en una posición dada

ps_show_xy

(PECL ps >= 1.1.0)

ps_show_xy — Imprimir texto en una posición dada

Descripción

ps_show_xy ( resource $psdoc , string $text , float $x , float $y ) : bool

Imprime texto en la posición de texto dada.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto a imprimir.

x

La coordenada x de la esquina inferior izquierda de la caja circundante del texto.

y

La coordenada y de la esquina inferior izquierda de la caja circundante del texto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_continue_text() - Continuar el texto en la siguiente línea
  • ps_show() - Imprimir texto


Imprimir texto en la posición actual

  • « ps_show_xy
  • ps_show »
  • PHP Manual
  • Funciones de PS
  • Imprimir texto en la posición actual

ps_show2

(PECL ps >= 1.1.0)

ps_show2 — Imprimir texto en la posición actual

Descripción

ps_show2 ( resource $psdoc , string $text , int $len ) : bool

Imprime texto en la posición actual. No imprime más de len caracteres.

Parámetros

psdoc

Un identificador de recurso del fichero postscript, como el devuelto por la función ps_new().

text

El texto a imprimir.

len

El número máximo de caracteres a imprimir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Imprimir texto

  • « ps_show2
  • ps_string_geometry »
  • PHP Manual
  • Funciones de PS
  • Imprimir texto

ps_show

(PECL ps >= 1.1.0)

ps_show — Imprimir texto

Descripción

ps_show ( resource $psdoc , string $text ) : bool

Imprime un texto en la posición de texto actual. La posición de texto puede ser establecida almacenado las coordenadas x e y en los valores textx y texty con la función ps_set_value(). La función emitirá un error si no se estableció antes una fuente con la función ps_setfont().

ps_show() evalúa los siguientes parámetros y valores establecidos por las funciones ps_set_parameter() y ps_set_value():

charspacing (valor)

Distancia entre dos glifos consecutivos. Si este valor es distinto de cero todas las ligaduras serán resueltas. Están permitidos valores menores que cero.

kerning (parámetro)

Establecer este parámetro a "false" desactivará el interletraje. El interletraje está activado por defecto.

ligatures (parámetro)

Establecer esta parámetro a "false" desactivará el uso de ligaduras. Las ligaduras están activadas por defecto.

underline (parámetro)

Establecer esta parámetro a "true" activará el subrayado. El subrayado está desctivado por defecto.

overline (parámetro)

Establecer esta parámetro a "true" activará el suprarayado. El suprarayado está desctivado por defecto.

strikeout (parámetro)

Establecer esta parámetro a "true" activará el tachado. El tachado está desctivado por defecto.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto a imprimir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_continue_text() - Continuar el texto en la siguiente línea
  • ps_show_xy() - Imprimir texto en una posición dada
  • ps_setfont() - Establecer la fuente a usar para la siguiente impresión


Establecer la geometría de una cadena de caracteres

  • « ps_show
  • ps_stringwidth »
  • PHP Manual
  • Funciones de PS
  • Establecer la geometría de una cadena de caracteres

ps_string_geometry

(PECL ps >= 1.2.0)

ps_string_geometry — Establecer la geometría de una cadena de caracteres

Descripción

ps_string_geometry ( resource $psdoc , string $text , int $fontid = 0 , float $size = 0.0 ) : array

Esta función es similar a la función ps_stringwidth(), excepto que devuelve un array de dimensiones que contiene el ancho, el ascendente y el descendente del texto.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto por el cual se calcula la geometría.

fontid

El identificador de la fuente a usar. Si no se especifica una fuente se usará la fuente actual.

size

El tamaño de la fuente. Si no se especifica un tamaño se usará el tamaño actual.

Valores devueltos

Un array con las dimensiones de una cadena. El elemento 'width' contiene el ancho de la cadena devuelto por la función ps_stringwidth(). El elemento 'descender' contiene el descendente máximo y 'ascender' el ascendente máximo de la cadena.

Ver también

  • ps_continue_text() - Continuar el texto en la siguiente línea
  • ps_stringwidth() - Obtener el ancho de una cadena


Obtener el ancho de una cadena

  • « ps_string_geometry
  • ps_stroke »
  • PHP Manual
  • Funciones de PS
  • Obtener el ancho de una cadena

ps_stringwidth

(PECL ps >= 1.1.0)

ps_stringwidth — Obtener el ancho de una cadena

Descripción

ps_stringwidth ( resource $psdoc , string $text , int $fontid = 0 , float $size = 0.0 ) : float

Calcula el ancho de una cadena en puntos si fue impresa con la fuente y tamaño de fuente dados. Esta función necesita un fichero de métrica de fuente de Adobe para calcular el ancho preciso. Si la partición silábica está activada se tomará en cuenta.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

text

El texto por el que calcular el ancho.

fontid

El identificador de la fuente a usar. Si no se especifica ninguna fuente se usará la fuente actual.

size

El tamaño de la fuente. Si no se especifica ningún tamaño se usará el tamaño actual.

Valores devueltos

El ancho de una cadena en puntos.

Ver también

  • ps_string_geometry() - Establecer la geometría de una cadena de caracteres


Dibujar el trazado actual

  • « ps_stringwidth
  • ps_symbol_name »
  • PHP Manual
  • Funciones de PS
  • Dibujar el trazado actual

ps_stroke

(PECL ps >= 1.1.0)

ps_stroke — Dibujar el trazado actual

Descripción

ps_stroke ( resource $psdoc ) : bool

Dibuja el trazado construido previamente con las llamadas a las funciones de dibujo como ps_lineto().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_closepath_stroke() - Cerrar y contornear un trazado
  • ps_fill() - Rellenar el trazado actual
  • ps_fill_stroke() - Rellenar y contornear el trazado actual


Obtener el nombre de un glifo

  • « ps_stroke
  • ps_symbol_width »
  • PHP Manual
  • Funciones de PS
  • Obtener el nombre de un glifo

ps_symbol_name

(PECL ps >= 1.2.0)

ps_symbol_name — Obtener el nombre de un glifo

Descripción

ps_symbol_name ( resource $psdoc , int $ord , int $fontid = 0 ) : string

Esta función necesita un fichero de métrica de fuentes de Adobe para conocer los glifos que están disponibles.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

ord

El parámetro ord es la posición del glifo en el vector de codificación de fuente.

fontid

El identificador de la fuente a usar. Si no se especifica ninguna fuente se usará la fuente actual.

Valores devueltos

El nombre de un glifo de la fuente dada.

Ver también

  • ps_symbol() - Imprimir un glifo
  • ps_symbol_width() - Obtener el ancho de un glifo


Obtener el ancho de un glifo

  • « ps_symbol_name
  • ps_symbol »
  • PHP Manual
  • Funciones de PS
  • Obtener el ancho de un glifo

ps_symbol_width

(PECL ps >= 1.2.0)

ps_symbol_width — Obtener el ancho de un glifo

Descripción

ps_symbol_width ( resource $psdoc , int $ord , int $fontid = 0 , float $size = 0.0 ) : float

Calcula el ancho de un glifo en puntos si fue impreso con la fuente y el tamaño de fuente dados. Esta función necesita un fichero de métrica de fuentes de Adobe para calcular el ancho preciso.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

ord

La posición del glifo en el vector de codificación de fuente.

fontid

El identificador de la fuente a usar. Si no se especifica ninguna fuente se usará la fuente actual.

size

El tamaño de la fuente. Si no se especifica ningún tamaño se usará el tamaño actual.

Valores devueltos

El ancho de un glifo en puntos.

Ver también

  • ps_symbol() - Imprimir un glifo
  • ps_symbol_name() - Obtener el nombre de un glifo


Imprimir un glifo

  • « ps_symbol_width
  • ps_translate »
  • PHP Manual
  • Funciones de PS
  • Imprimir un glifo

ps_symbol

(PECL ps >= 1.2.0)

ps_symbol — Imprimir un glifo

Descripción

ps_symbol ( resource $psdoc , int $ord ) : bool

Imprime el glifo de la posición ord del vector de codificación de fuentes de la fuente actual. La codificación de fuente para una fuente se puede establecer cargando la fuente con la función ps_findfont().

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

ord

La posición del glifo en el vector de codificación de fuentes.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ps_symbol_name() - Obtener el nombre de un glifo
  • ps_symbol_width() - Obtener el ancho de un glifo


Establecer una traslación

  • « ps_symbol
  • RpmInfo »
  • PHP Manual
  • Funciones de PS
  • Establecer una traslación

ps_translate

(PECL ps >= 1.1.0)

ps_translate — Establecer una traslación

Descripción

ps_translate ( resource $psdoc , float $x , float $y ) : bool

Establece un nuevo punto inicial del sistema de coordenadas.

Parámetros

psdoc

El identificador de recursos del fichero postscript, como el devuelto por la función ps_new().

x

La coordenada x del origen del sistema de coordenadas trasladado.

y

La coordenada y del origen del sistema de coordenadas trasladado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Traslación del sistema de coordenadas

<?php
function rectángulo($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "traslación.ps")) {
  print "No se puede abrir el fichero PostScript\n";
  exit;
}

ps_set_info($ps, "Creator", "traslación.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Ejemplo de traslación");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_translate($ps, 500, 750);
rectángulo($ps);
ps_translate($ps, -500, -750);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Texto en posición inicial");
ps_end_page($ps);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 500, 750);
rectángulo($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Texto en posición inicial");
ps_end_page($ps);

ps_delete($ps);
?>

El ejemplo anterior demuestra dos maneras posibles de colocar un gráfico (en este caso un rectángulo) en cualquier posición de la página, mientras que el gráfico mismo utiliza su propio sistema de coordenadas. El truco está en cambiar el origen del sistema de coodenadas acutal antes de dibujar el rectángulo. La traslación tiene que ser deshecha después de dibujar el gráfico.

En la segunda página se aplica un enfoque algo diferente y más elegante. En vez de deshacer la traslación con una segunda llamada a la función ps_translate() el contexto de gráficos se guarda antes de modificar el sistema de coordenadas y se restaura después de dibujar el rectángulo.

Ver también

  • ps_scale() - Estalecer el factor de escala
  • ps_rotate() - Establecer el factor de rotación


RpmInfo

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Installation via PECL
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • RpmInfo Funciones
    • rpmaddtag — Add tag retrieved in query
    • rpmdbinfo — Get information from installed RPM
    • rpmdbsearch — Search RPM packages
    • rpminfo — Get information from a RPM file
    • rpmvercmp — RPM version comparison


Introducción

This extension enables you to retrieve information from RPM files or from the installed RPMs database.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Installation via PECL
  • Configuración en tiempo de ejecución
  • Tipos de recursos


  • « Instalación/Configuración
  • Installation via PECL »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

This extension requires » librpm version 4.11.3 or higher.


Installation via PECL

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/rpminfo.


  • « Installation via PECL
  • Tipos de recursos »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

RPMVERSION (string)
System librpm version.
RPMSENSE_ANY (int)
RPMSENSE_LESS (int)
RPMSENSE_GREATER (int)
RPMSENSE_EQUAL (int)
RPMSENSE_POSTTRANS (int)
RPMSENSE_PREREQ (int)
RPMSENSE_PRETRANS (int)
RPMSENSE_INTERP (int)
RPMSENSE_SCRIPT_PRE (int)
RPMSENSE_SCRIPT_POST (int)
RPMSENSE_SCRIPT_PREUN (int)
RPMSENSE_SCRIPT_POSTUN (int)
RPMSENSE_SCRIPT_VERIFY (int)
RPMSENSE_FIND_REQUIRES (int)
RPMSENSE_FIND_PROVIDES (int)
RPMSENSE_TRIGGERIN (int)
RPMSENSE_TRIGGERUN (int)
RPMSENSE_TRIGGERPOSTUN (int)
RPMSENSE_MISSINGOK (int)
RPMSENSE_RPMLIB (int)
RPMSENSE_TRIGGERPREIN (int)
RPMSENSE_KEYRING (int)
RPMSENSE_CONFIG (int)
RPMMIRE_DEFAULT (int)
Search pattern is a regular expression with \., .* and ^...$ added.
RPMMIRE_STRCMP (int)
Search pattern is a string, using strcmp(3).
RPMMIRE_REGEX (int)
Search pattern is a regular expression, using regcomp(3).
RPMMIRE_GLOB (int)
Search pattern is a glob expression, using fnmatch(3).
RPMTAG_ARCH (int)
RPMTAG_ARCHIVESIZE (int)
RPMTAG_BASENAMES (int)
Name (not path) of files, with database index.
RPMTAG_BUGURL (int)
RPMTAG_BUILDARCHS (int)
RPMTAG_BUILDHOST (int)
RPMTAG_BUILDTIME (int)
RPMTAG_C (int)
RPMTAG_CHANGELOGNAME (int)
RPMTAG_CHANGELOGTEXT (int)
RPMTAG_CHANGELOGTIME (int)
RPMTAG_CLASSDICT (int)
RPMTAG_CONFLICTFLAGS (int)
RPMTAG_CONFLICTNAME (int)
Conflicting dependencies, with database index.
RPMTAG_CONFLICTNEVRS (int)
RPMTAG_CONFLICTS (int)
RPMTAG_CONFLICTVERSION (int)
RPMTAG_COOKIE (int)
RPMTAG_DBINSTANCE (int)
RPMTAG_DEPENDSDICT (int)
RPMTAG_DESCRIPTION (int)
RPMTAG_DIRINDEXES (int)
RPMTAG_DIRNAMES (int)
Directory of files, with database index.
RPMTAG_DISTRIBUTION (int)
RPMTAG_DISTTAG (int)
RPMTAG_DISTURL (int)
RPMTAG_DSAHEADER (int)
RPMTAG_E (int)
RPMTAG_ENCODING (int)
RPMTAG_ENHANCEFLAGS (int)
RPMTAG_ENHANCENAME (int)
Weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_ENHANCENEVRS (int)
RPMTAG_ENHANCES (int)
RPMTAG_ENHANCEVERSION (int)
RPMTAG_EPOCH (int)
RPMTAG_EPOCHNUM (int)
RPMTAG_EVR (int)
RPMTAG_EXCLUDEARCH (int)
RPMTAG_EXCLUDEOS (int)
RPMTAG_EXCLUSIVEARCH (int)
RPMTAG_EXCLUSIVEOS (int)
RPMTAG_FILECAPS (int)
RPMTAG_FILECLASS (int)
RPMTAG_FILECOLORS (int)
RPMTAG_FILECONTEXTS (int)
RPMTAG_FILEDEPENDSN (int)
RPMTAG_FILEDEPENDSX (int)
RPMTAG_FILEDEVICES (int)
RPMTAG_FILEDIGESTALGO (int)
RPMTAG_FILEDIGESTS (int)
RPMTAG_FILEFLAGS (int)
RPMTAG_FILEGROUPNAME (int)
RPMTAG_FILEINODES (int)
RPMTAG_FILELANGS (int)
RPMTAG_FILELINKTOS (int)
RPMTAG_FILEMD5S (int)
RPMTAG_FILEMODES (int)
RPMTAG_FILEMTIMES (int)
RPMTAG_FILENAMES (int)
RPMTAG_FILENLINKS (int)
RPMTAG_FILEPROVIDE (int)
RPMTAG_FILERDEVS (int)
RPMTAG_FILEREQUIRE (int)
RPMTAG_FILESIGNATURELENGTH (int)
RPMTAG_FILESIGNATURES (int)
RPMTAG_FILESIZES (int)
RPMTAG_FILESTATES (int)
RPMTAG_FILETRIGGERCONDS (int)
RPMTAG_FILETRIGGERFLAGS (int)
RPMTAG_FILETRIGGERINDEX (int)
RPMTAG_FILETRIGGERNAME (int)
File trigger name, with database index, requires librpm >= 4.13.
RPMTAG_FILETRIGGERPRIORITIES (int)
RPMTAG_FILETRIGGERSCRIPTFLAGS (int)
RPMTAG_FILETRIGGERSCRIPTPROG (int)
RPMTAG_FILETRIGGERSCRIPTS (int)
RPMTAG_FILETRIGGERTYPE (int)
RPMTAG_FILETRIGGERVERSION (int)
RPMTAG_FILEUSERNAME (int)
RPMTAG_FILEVERIFYFLAGS (int)
RPMTAG_FSCONTEXTS (int)
RPMTAG_GIF (int)
RPMTAG_GROUP (int)
Group of the package, with database index.
RPMTAG_HDRID (int)
RPMTAG_HEADERCOLOR (int)
RPMTAG_HEADERI18NTABLE (int)
RPMTAG_HEADERIMAGE (int)
RPMTAG_HEADERIMMUTABLE (int)
RPMTAG_HEADERREGIONS (int)
RPMTAG_HEADERSIGNATURES (int)
RPMTAG_ICON (int)
RPMTAG_INSTALLCOLOR (int)
RPMTAG_INSTALLTID (int)
Installation transaction ID, with database index.
RPMTAG_INSTALLTIME (int)
RPMTAG_INSTFILENAMES (int)
Path of files, with database index.
RPMTAG_INSTPREFIXES (int)
RPMTAG_LICENSE (int)
RPMTAG_LONGARCHIVESIZE (int)
RPMTAG_LONGFILESIZES (int)
RPMTAG_LONGSIGSIZE (int)
RPMTAG_LONGSIZE (int)
RPMTAG_MODULARITYLABEL (int)
RPMTAG_N (int)
RPMTAG_NAME (int)
Package name, with database index.
RPMTAG_NEVR (int)
RPMTAG_NEVRA (int)
RPMTAG_NOPATCH (int)
RPMTAG_NOSOURCE (int)
RPMTAG_NVR (int)
RPMTAG_NVRA (int)
RPMTAG_O (int)
RPMTAG_OBSOLETEFLAGS (int)
RPMTAG_OBSOLETENAME (int)
Obsoleted packages, with database index.
RPMTAG_OBSOLETENEVRS (int)
RPMTAG_OBSOLETES (int)
RPMTAG_OBSOLETEVERSION (int)
RPMTAG_OLDENHANCES (int)
RPMTAG_OLDENHANCESFLAGS (int)
RPMTAG_OLDENHANCESNAME (int)
RPMTAG_OLDENHANCESVERSION (int)
RPMTAG_OLDFILENAMES (int)
RPMTAG_OLDSUGGESTS (int)
RPMTAG_OLDSUGGESTSFLAGS (int)
RPMTAG_OLDSUGGESTSNAME (int)
RPMTAG_OLDSUGGESTSVERSION (int)
RPMTAG_OPTFLAGS (int)
RPMTAG_ORDERFLAGS (int)
RPMTAG_ORDERNAME (int)
RPMTAG_ORDERVERSION (int)
RPMTAG_ORIGBASENAMES (int)
RPMTAG_ORIGDIRINDEXES (int)
RPMTAG_ORIGDIRNAMES (int)
RPMTAG_ORIGFILENAMES (int)
RPMTAG_OS (int)
RPMTAG_P (int)
RPMTAG_PACKAGER (int)
RPMTAG_PATCH (int)
RPMTAG_PATCHESFLAGS (int)
RPMTAG_PATCHESNAME (int)
RPMTAG_PATCHESVERSION (int)
RPMTAG_PAYLOADCOMPRESSOR (int)
RPMTAG_PAYLOADDIGEST (int)
RPMTAG_PAYLOADDIGESTALT (int)
Since librpm >= 4.16.
RPMTAG_PAYLOADDIGESTALGO (int)
RPMTAG_PAYLOADFLAGS (int)
RPMTAG_PAYLOADFORMAT (int)
RPMTAG_PKGID (int)
RPMTAG_PLATFORM (int)
RPMTAG_POLICIES (int)
RPMTAG_POLICYFLAGS (int)
RPMTAG_POLICYNAMES (int)
RPMTAG_POLICYTYPES (int)
RPMTAG_POLICYTYPESINDEXES (int)
RPMTAG_POSTIN (int)
RPMTAG_POSTINFLAGS (int)
RPMTAG_POSTINPROG (int)
RPMTAG_POSTTRANS (int)
RPMTAG_POSTTRANSFLAGS (int)
RPMTAG_POSTTRANSPROG (int)
RPMTAG_POSTUN (int)
RPMTAG_POSTUNFLAGS (int)
RPMTAG_POSTUNPROG (int)
RPMTAG_PREFIXES (int)
RPMTAG_PREIN (int)
RPMTAG_PREINFLAGS (int)
RPMTAG_PREINPROG (int)
RPMTAG_PRETRANS (int)
RPMTAG_PRETRANSFLAGS (int)
RPMTAG_PRETRANSPROG (int)
RPMTAG_PREUN (int)
RPMTAG_PREUNFLAGS (int)
RPMTAG_PREUNPROG (int)
RPMTAG_PROVIDEFLAGS (int)
RPMTAG_PROVIDENAME (int)
Provided dependencies, with database index.
RPMTAG_PROVIDENEVRS (int)
RPMTAG_PROVIDES (int)
RPMTAG_PROVIDEVERSION (int)
RPMTAG_PUBKEYS (int)
RPMTAG_R (int)
RPMTAG_RECOMMENDFLAGS (int)
RPMTAG_RECOMMENDNAME (int)
Recommended weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_RECOMMENDNEVRS (int)
RPMTAG_RECOMMENDS (int)
RPMTAG_RECOMMENDVERSION (int)
RPMTAG_RECONTEXTS (int)
RPMTAG_RELEASE (int)
RPMTAG_REMOVETID (int)
RPMTAG_REQUIREFLAGS (int)
RPMTAG_REQUIRENAME (int)
Required dependencies, with database index.
RPMTAG_REQUIRENEVRS (int)
RPMTAG_REQUIRES (int)
RPMTAG_REQUIREVERSION (int)
RPMTAG_RPMVERSION (int)
RPMTAG_RSAHEADER (int)
RPMTAG_SHA1HEADER (int)
SHA1 signature, with database index.
RPMTAG_SHA256HEADER (int)
RPMTAG_SIGGPG (int)
RPMTAG_SIGMD5 (int)
MD5 signature, with database index.
RPMTAG_SIGPGP (int)
RPMTAG_SIGSIZE (int)
RPMTAG_SIZE (int)
RPMTAG_SOURCE (int)
RPMTAG_SOURCEPACKAGE (int)
RPMTAG_SOURCEPKGID (int)
RPMTAG_SOURCERPM (int)
RPMTAG_SUGGESTFLAGS (int)
RPMTAG_SUGGESTNAME (int)
Suggested weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_SUGGESTNEVRS (int)
RPMTAG_SUGGESTS (int)
RPMTAG_SUGGESTVERSION (int)
RPMTAG_SUMMARY (int)
RPMTAG_SUPPLEMENTFLAGS (int)
RPMTAG_SUPPLEMENTNAME (int)
Weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_SUPPLEMENTNEVRS (int)
RPMTAG_SUPPLEMENTS (int)
RPMTAG_SUPPLEMENTVERSION (int)
RPMTAG_TRANSFILETRIGGERCONDS (int)
RPMTAG_TRANSFILETRIGGERFLAGS (int)
RPMTAG_TRANSFILETRIGGERINDEX (int)
RPMTAG_TRANSFILETRIGGERNAME (int)
Transaction file trigger name, with database index, requires librpm >= 4.13.
RPMTAG_TRANSFILETRIGGERPRIORITIES (int)
RPMTAG_TRANSFILETRIGGERSCRIPTFLAGS (int)
RPMTAG_TRANSFILETRIGGERSCRIPTPROG (int)
RPMTAG_TRANSFILETRIGGERSCRIPTS (int)
RPMTAG_TRANSFILETRIGGERTYPE (int)
RPMTAG_TRANSFILETRIGGERVERSION (int)
RPMTAG_TRIGGERCONDS (int)
RPMTAG_TRIGGERFLAGS (int)
RPMTAG_TRIGGERINDEX (int)
RPMTAG_TRIGGERNAME (int)
Trigger name, with database index.
RPMTAG_TRIGGERSCRIPTFLAGS (int)
RPMTAG_TRIGGERSCRIPTPROG (int)
RPMTAG_TRIGGERSCRIPTS (int)
RPMTAG_TRIGGERTYPE (int)
RPMTAG_TRIGGERVERSION (int)
RPMTAG_URL (int)
RPMTAG_V (int)
RPMTAG_VCS (int)
RPMTAG_VENDOR (int)
RPMTAG_VERBOSE (int)
RPMTAG_VERIFYSCRIPT (int)
RPMTAG_VERIFYSCRIPTFLAGS (int)
RPMTAG_VERIFYSCRIPTPROG (int)
RPMTAG_VERSION (int)
RPMTAG_XPM (int)


RpmInfo Funciones

Tabla de contenidos

  • rpmaddtag — Add tag retrieved in query
  • rpmdbinfo — Get information from installed RPM
  • rpmdbsearch — Search RPM packages
  • rpminfo — Get information from a RPM file
  • rpmvercmp — RPM version comparison


Add tag retrieved in query

  • « RpmInfo Funciones
  • rpmdbinfo »
  • PHP Manual
  • RpmInfo Funciones
  • Add tag retrieved in query

rpmaddtag

(PECL rpminfo >= 0.5.0)

rpmaddtag — Add tag retrieved in query

Descripción

rpmaddtag ( int $tag ) : bool

Add an additional retrieved tag in subsequent queries.

Parámetros

tag

One of RPMTAG_* constant, see the rpminfo constants page.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • rpminfo() - Get information from a RPM file
  • rpmdbinfo() - Get information from installed RPM
  • rpmdbsearch() - Search RPM packages


Get information from installed RPM

  • « rpmaddtag
  • rpmdbsearch »
  • PHP Manual
  • RpmInfo Funciones
  • Get information from installed RPM

rpmdbinfo

(PECL rpminfo >= 0.2.0)

rpmdbinfo — Get information from installed RPM

Descripción

rpmdbinfo ( string $nevr , bool $full = false ) : array

Retrieve information about an installed package, from the system RPM database.

Parámetros

nevr

Name with optional epoch, version and release.

full

If true all information headers for the file are retrieved, else only a minimal set.

Valores devueltos

An array of array of information or NULL on error.

Ver también

  • rpmaddtag() - Add tag retrieved in query

Ejemplos

Ejemplo #1 A rpmdbinfo() example

<?php
rpmaddtag(RPMTAG_INSTALLTIME);
$info = rpmdbinfo("php-pecl-rpminfo");
print_r($info);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [Name] => php-pecl-rpminfo
            [Version] => 0.4.2
            [Release] => 1.fc31
            [Summary] => RPM information
            [Installtime] => 1586244687
            [Arch] => x86_64
        )
)


Search RPM packages

  • « rpmdbinfo
  • rpminfo »
  • PHP Manual
  • RpmInfo Funciones
  • Search RPM packages

rpmdbsearch

(PECL rpminfo >= 0.3.0)

rpmdbsearch — Search RPM packages

Descripción

rpmdbsearch ( string $pattern , int $rpmtag = RPMTAG_NAME , int $rpmmire = -1 , bool $full = false ) : array

Search packages in the system RPM database.

Parámetros

pattern

Value to search for.

rpmtag

Search criterion, one of RPMTAG_* constant, see the rpminfo constants page.

rpmmire

Pattern type, one of RPMMIRE_* constant, see the rpminfo constants page. When < 0 the criterion must equals the value, and database index is used if possible.

full

If true all information headers for the file are retrieved, else only a minimal set.

Valores devueltos

An array of array of information or NULL on error.

Ver también

  • rpmaddtag() - Add tag retrieved in query

Ejemplos

Ejemplo #1 Searching for the package owning a file

<?php
$info = rpmdbsearch("/usr/bin/php", RPMTAG_INSTFILENAMES);
print_r($info);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [Name] => php-cli
            [Version] => 7.4.4
            [Release] => 1.fc32
            [Summary] => Command-line interface for PHP
            [Arch] => x86_64
        )

)


Get information from a RPM file

  • « rpmdbsearch
  • rpmvercmp »
  • PHP Manual
  • RpmInfo Funciones
  • Get information from a RPM file

rpminfo

(PECL rpminfo >= 0.1.0)

rpminfo — Get information from a RPM file

Descripción

rpminfo ( string $path , bool $full = false , string &$error = ? ) : array

Retrieve information about a local file, a RPM package.

Parámetros

path

Path of the RPM file.

full

If true all information headers for the file are retrieved, else only a minimal set.

error

If provided, will receive the possible error message, and will avoid a runtime warning.

Valores devueltos

An array of information or NULL on error.

Ver también

  • rpmaddtag() - Add tag retrieved in query

Ejemplos

Ejemplo #1 A rpminfo() example

<?php
rpmaddtag(RPMTAG_BUILDTIME);
$info = rpminfo("./php-pecl-rpminfo-0.4.2-1.el8.remi.7.4.x86_64.rpm");
print_r($info);
?>

El resultado del ejemplo sería:

Array
(
    [Name] => php-pecl-rpminfo
    [Version] => 0.4.2
    [Release] => 1.el8
    [Summary] => RPM information
    [Buildtime] => 1586244821
    [Arch] => x86_64
)


RPM version comparison

  • « rpminfo
  • XLSWriter »
  • PHP Manual
  • RpmInfo Funciones
  • RPM version comparison

rpmvercmp

(PECL rpminfo >= 0.1.0)

rpmvercmp — RPM version comparison

Descripción

rpmvercmp ( string $evr1 , string $evr2 ) : int

Compare 2 RPM versions.

Parámetros

evr1

First epoch:version-release string

evr2

Second epoch:version-release string

Valores devueltos

Returns < 0 if evr1 is less than evr2, > 0 if evr1 is greater than evr2, and 0 if they are equal.


XLSWriter

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Tipos de recursos
  • Constantes predefinidas
  • Vtiful\Kernel\Excel — The Vtiful\Kernel\Excel class
    • Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet
    • Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter
    • Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory
    • Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor
    • Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data
    • Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName
    • Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle
    • Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header
    • Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula
    • Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage
    • Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText
    • Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells
    • Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output
    • Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn
    • Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow
  • Vtiful\Kernel\Format — The Vtiful\Kernel\Format class
    • Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align
    • Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold
    • Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic
    • Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline


  • « XLSWriter
  • Instalación/Configuración »
  • PHP Manual
  • XLSWriter
  • Introducción

Introducción

Una eficiente y rápida extensión de exportación de archivos xlsx.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

XLSWriter requiere PHP 7.0 y superior.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/xlswriter


Tipos de recursos

Hay un recurso utilizado por la versión de procedimiento de la extensión XLSWriter: devuelto por fileName() o \Vtiful\Kernel\Format.


  • « Tipos de recursos
  • Vtiful\Kernel\Excel »
  • PHP Manual
  • XLSWriter
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


The Vtiful\Kernel\Excel class

(PECL xlswriter >= 1.2.1)

Introducción

Crea archivos xlsx y fija las celdas y produce los archivos xlsx

Sinopsis de la Clase

Vtiful\Kernel\Excel {
/* Métodos */
public addSheet ( string $sheetName )
public autoFilter ( string $scope )
public constMemory ( string $fileName , string $sheetName = ? )
public __construct ( array $config )
public data ( array $data )
public fileName ( string $fileName , string $sheetName = ? )
public getHandle ( )
public header ( array $headerData )
public insertFormula ( int $row , int $column , string $formula )
public insertImage ( int $row , int $column , string $localImagePath )
public insertText ( int $row , int $column , stringintdouble $data , string $format = ? )
public mergeCells ( string $scope , string $data )
public output ( )
public setColumn ( string $range , float $width , resource $format = ? )
public setRow ( string $range , float $height , resource $format = ? )
}

Tabla de contenidos

  • Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet
  • Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter
  • Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory
  • Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor
  • Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data
  • Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName
  • Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle
  • Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header
  • Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula
  • Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage
  • Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText
  • Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells
  • Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output
  • Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn
  • Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow


Vtiful\Kernel\Excel addSheet

  • « Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel::autoFilter »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel addSheet

Vtiful\Kernel\Excel::addSheet

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet

Descripción

public Vtiful\Kernel\Excel::addSheet ( string $sheetName )

Crea una nueva hoja de trabajo en el archivo xlsx.

Parámetros

sheetName

Nombre de la hoja de trabajo

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
        ['viest', 23],
        ['wjx', 23]
    ]);

$file->addSheet('sheet_two')
    ->header(['name', 'age'])
    ->data([
        ['james', 33],
        ['king', 33]
    ]);

$file->output();
?>


Vtiful\Kernel\Excel autoFilter

  • « Vtiful\Kernel\Excel::addSheet
  • Vtiful\Kernel\Excel::constMemory »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel autoFilter

Vtiful\Kernel\Excel::autoFilter

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter

Descripción

public Vtiful\Kernel\Excel::autoFilter ( string $scope )

Añade el autofiltro a una hoja de trabajo.

Parámetros

scope

Celda de inicio y final del string de coordenadas.

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName('test.xlsx')
        ->header(['name', 'age'])
        ->data($data)
        ->autoFilter('A1:B11')  // auto filter
        ->output();
?>


Vtiful\Kernel\Excel constMemory

  • « Vtiful\Kernel\Excel::autoFilter
  • Vtiful\Kernel\Excel::__construct »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel constMemory

Vtiful\Kernel\Excel::constMemory

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory

Descripción

public Vtiful\Kernel\Excel::constMemory ( string $fileName , string $sheetName = ? )

Escribe un archivo grande con un uso constante de la memoria.

Parámetros

fileName

Nombre del archivo XLSX

sheetName

Nombre de la hoja de trabajo

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
  'path' => '/home/viest'
];

$fileObject = new \Vtiful\Kernel\Excel($config);

$file = $instance->constMemory('tutorial.xlsx', 'sheet');
?>


Vtiful\Kernel\Excel constructor

  • « Vtiful\Kernel\Excel::constMemory
  • Vtiful\Kernel\Excel::data »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel constructor

Vtiful\Kernel\Excel::__construct

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor

Descripción

public Vtiful\Kernel\Excel::__construct ( array $config )

Vtiful\Kernel\Excel constructor, crea un objeto de clase.

Parámetros

config

Configuración de la exportación de archivos XLSX

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
  'path' => '/home/viest'
];

$excelObject = new \Vtiful\Kernel\Excel($config);
?>


Vtiful\Kernel\Excel data

  • « Vtiful\Kernel\Excel::__construct
  • Vtiful\Kernel\Excel::fileName »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel data

Vtiful\Kernel\Excel::data

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data

Descripción

public Vtiful\Kernel\Excel::data ( array $data )

Escribe un dato en la hoja de trabajo.

Parámetros

data

datos de la hoja de trabajo

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
      ['viest', 23],
      ['wjx', 23],
    ]);
?>


Vtiful\Kernel\Excel fileName

  • « Vtiful\Kernel\Excel::data
  • Vtiful\Kernel\Excel::getHandle »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel fileName

Vtiful\Kernel\Excel::fileName

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName

Descripción

public Vtiful\Kernel\Excel::fileName ( string $fileName , string $sheetName = ? )

Crear un nuevo archivo xlsx y crea una hoja de trabajo.

Parámetros

fileName

Nombre del archivo XLSX

sheetName

Nombre de la hoja de trabajo

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
  'path' => '/home/viest'
];

$fileObject = new \Vtiful\Kernel\Excel($config);

$file = $instance->fileName('tutorial.xlsx', 'sheet');
?>


Vtiful\Kernel\Excel getHandle

  • « Vtiful\Kernel\Excel::fileName
  • Vtiful\Kernel\Excel::header »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel getHandle

Vtiful\Kernel\Excel::getHandle

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle

Descripción

public Vtiful\Kernel\Excel::getHandle ( )

Consigue el manejo de los recursos de texto xlsx.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Recurso

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age']);

$handle = $file->getHandle();
?>


Vtiful\Kernel\Excel header

  • « Vtiful\Kernel\Excel::getHandle
  • Vtiful\Kernel\Excel::insertFormula »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel header

Vtiful\Kernel\Excel::header

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header

Descripción

public Vtiful\Kernel\Excel::header ( array $headerData )

Escribe un encabezado en la hoja de trabajo.

Parámetros

headerData

datos de la cabecera de la hoja de trabajo

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age']);
?>


Vtiful\Kernel\Excel insertFormula

  • « Vtiful\Kernel\Excel::header
  • Vtiful\Kernel\Excel::insertImage »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertFormula

Vtiful\Kernel\Excel::insertFormula

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula

Descripción

public Vtiful\Kernel\Excel::insertFormula ( int $row , int $column , string $formula )

Inserta la fórmula de cálculo.

Parámetros

row

fila de celdas

column

columna de celdas

formula

formula string

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx")
    ->header(['name', 'money']);

for($index = 1; $index < 10; $index++) {
    $file->insertText($index, 0, 'viest');
    $file->insertText($index, 1, 10);
}

$file->insertText(12, 0, "Total");
$file->insertFormula(12, 1, '=SUM(B2:B11)'); // insertar la fórmula

$file->output();


Vtiful\Kernel\Excel insertImage

  • « Vtiful\Kernel\Excel::insertFormula
  • Vtiful\Kernel\Excel::insertText »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertImage

Vtiful\Kernel\Excel::insertImage

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage

Descripción

public Vtiful\Kernel\Excel::insertImage ( int $row , int $column , string $localImagePath )

Inserta una imagen local en la celda.

Parámetros

row

fila de celdas

column

columna de celdas

localImagePath

ruta de la imagen local

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx");

$file->insertImage(5, 0, '/vagrant/ASW-G-66.jpg');

$file->output();


Vtiful\Kernel\Excel insertText

  • « Vtiful\Kernel\Excel::insertImage
  • Vtiful\Kernel\Excel::mergeCells »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertText

Vtiful\Kernel\Excel::insertText

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText

Descripción

public Vtiful\Kernel\Excel::insertText ( int $row , int $column , stringintdouble $data , string $format = ? )

Escribe texto en una celda.

Parámetros

row

fila de celdas

column

columna de celdas

data

los datos que se escribirán

format

Formato string

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx")
    ->header(['name', 'money']);

for ($index = 0; $index < 10; $index++) {
    $file->insertText($index+1, 0, 'viest');
    $file->insertText($index+1, 1, 10000, '#,##0');
}

$textFile->output();


Vtiful\Kernel\Excel mergeCells

  • « Vtiful\Kernel\Excel::insertText
  • Vtiful\Kernel\Excel::output »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel mergeCells

Vtiful\Kernel\Excel::mergeCells

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells

Descripción

public Vtiful\Kernel\Excel::mergeCells ( string $scope , string $data )

Combinar Celdas.

Parámetros

scope

strings de coordenadas de inicio y fin de la celda

data

datos string

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$excel->fileName("test.xlsx")
        ->mergeCells('A1:C1', 'Merge cells')
        ->output();


Vtiful\Kernel\Excel output

  • « Vtiful\Kernel\Excel::mergeCells
  • Vtiful\Kernel\Excel::setColumn »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel output

Vtiful\Kernel\Excel::output

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output

Descripción

public Vtiful\Kernel\Excel::output ( )

Salida del archivo xlsx al disco.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ruta de archivo XLSX;

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
      ['viest', 23],
      ['wjx', 23],
    ]);

$path = $file->output();
?>


Vtiful\Kernel\Excel setColumn

  • « Vtiful\Kernel\Excel::output
  • Vtiful\Kernel\Excel::setRow »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel setColumn

Vtiful\Kernel\Excel::setColumn

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn

Descripción

public Vtiful\Kernel\Excel::setColumn ( string $range , float $width , resource $format = ? )

Establece el formato de la columna.

Parámetros

range

los string de coordenadas de inicio y fin de la celda

width

ancho de la columna

format

recurso de formato de celdas

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $boldStyle)
    ->output();


Vtiful\Kernel\Excel setRow

  • « Vtiful\Kernel\Excel::setColumn
  • Vtiful\Kernel\Format »
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel setRow

Vtiful\Kernel\Excel::setRow

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow

Descripción

public Vtiful\Kernel\Excel::setRow ( string $range , float $height , resource $format = ? )

Establece el formato de la columna.

Parámetros

range

los strings de coordenadas de inicio y fin de la celda

height

altura de la fila

format

recurso de formato de celdas

Valores devueltos

instancia Vtiful\Kernel\Excel

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setRow('A1', 20, $boldStyle,)
    ->output();


The Vtiful\Kernel\Format class

(PECL xlswriter >= 1.2.1)

Introducción

Crea un objeto con formato de celda

Sinopsis de la Clase

Vtiful\Kernel\Format {
/* Constantes */
const int FORMAT_ALIGN_LEFT = 1 ;
const int FORMAT_ALIGN_CENTER = 2 ;
const int FORMAT_ALIGN_RIGHT = 3 ;
const int FORMAT_ALIGN_FILL = 4 ;
const int FORMAT_ALIGN_JUSTIFY = 5 ;
const int FORMAT_ALIGN_CENTER_ACROSS = 6 ;
const int FORMAT_ALIGN_DISTRIBUTED = 7 ;
const int FORMAT_ALIGN_VERTICAL_TOP = 8 ;
const int FORMAT_ALIGN_VERTICAL_BOTTOM = 9 ;
const int FORMAT_ALIGN_VERTICAL_CENTER = 10 ;
const int FORMAT_ALIGN_VERTICAL_JUSTIFY = 11 ;
const int FORMAT_ALIGN_VERTICAL_DISTRIBUTED = 12 ;
const int UNDERLINE_SINGLE = 1 ;
const int UNDERLINE_DOUBLE = 2 ;
const int UNDERLINE_SINGLE_ACCOUNTING = 3 ;
const int UNDERLINE_DOUBLE_ACCOUNTING = 4 ;
/* Métodos */
public align ( resource $handle , int $style )
public bold ( resource $handle )
public italic ( resource $handle )
public underline ( resource $handle , int $style )
}

Constantes predefinidas

Vtiful\Kernel\Format::FORMAT_ALIGN_LEFT

Vtiful\Kernel\Format::FORMAT_ALIGN_CENTER

Vtiful\Kernel\Format::FORMAT_ALIGN_RIGHT

Vtiful\Kernel\Format::FORMAT_ALIGN_FILL

Vtiful\Kernel\Format::FORMAT_ALIGN_JUSTIFY

Vtiful\Kernel\Format::FORMAT_ALIGN_CENTER_ACROSS

Vtiful\Kernel\Format::FORMAT_ALIGN_DISTRIBUTED

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_TOP

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_BOTTOM

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_CENTER

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_JUSTIFY

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_DISTRIBUTED

Vtiful\Kernel\Format::UNDERLINE_SINGLE

Vtiful\Kernel\Format::UNDERLINE_DOUBLE

Vtiful\Kernel\Format::UNDERLINE_SINGLE_ACCOUNTING

Vtiful\Kernel\Format::UNDERLINE_DOUBLE_ACCOUNTING

Tabla de contenidos

  • Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align
  • Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold
  • Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic
  • Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline


Vtiful\Kernel\Format align

  • « Vtiful\Kernel\Format
  • Vtiful\Kernel\Format::bold »
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format align

Vtiful\Kernel\Format::align

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align

Descripción

public Vtiful\Kernel\Format::align ( resource $handle , int $style )

establece la alineación de la celda

Parámetros

handle

manejador de archivos xlsx

style

constante Vtiful\Kernel\Format

Valores devueltos

Recurso

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$alignStyle = \Vtiful\Kernel\Format::align($fileHandle, \Vtiful\Kernel\Format::FORMAT_ALIGN_LEFT);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $align)
    ->output();
?>


Vtiful\Kernel\Format bold

  • « Vtiful\Kernel\Format::align
  • Vtiful\Kernel\Format::italic »
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format bold

Vtiful\Kernel\Format::bold

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold

Descripción

public Vtiful\Kernel\Format::bold ( resource $handle )

Vtiful\Kernel\Format formato en negrita

Parámetros

handle

manejador de archivos xlsx

Valores devueltos

Recurso

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $boldStyle)
    ->output();
?>


Vtiful\Kernel\Format italic

  • « Vtiful\Kernel\Format::bold
  • Vtiful\Kernel\Format::underline »
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format italic

Vtiful\Kernel\Format::italic

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic

Descripción

public Vtiful\Kernel\Format::italic ( resource $handle )

Vtiful\Kernel\Format formato cursivo

Parámetros

handle

manejador de archivos xlsx

Valores devueltos

Recurso

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$italicStyle = \Vtiful\Kernel\Format::italic($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $italicStyle)
    ->output();
?>


Vtiful\Kernel\Format underline

  • « Vtiful\Kernel\Format::italic
  • Extensiones de control de procesos »
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format underline

Vtiful\Kernel\Format::underline

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline

Descripción

public Vtiful\Kernel\Format::underline ( resource $handle , int $style )

Vtiful\Kernel\Format formato subrayado

Parámetros

handle

manejador de archivos xlsx

style

constante Vtiful\Kernel\Format

Valores devueltos

Recurso

Ejemplos

Ejemplo #1 ejemplo

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$underlineStyle = \Vtiful\Kernel\Format::underline($fileHandle, \Vtiful\Kernel\Format::UNDERLINE_SINGLE);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $underlineStyle)
    ->output();
?>


Extensiones de control de procesos

  • Eio
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones Eio
  • Ev
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Watchers
    • Watcher callbacks
    • Periodic watcher operation modes
    • Ev — La clase Ev
    • EvCheck — The EvCheck class
    • EvChild — The EvChild class
    • EvEmbed — The EvEmbed class
    • EvFork — The EvFork class
    • EvIdle — The EvIdle class
    • EvIo — The EvIo class
    • EvLoop — The EvLoop class
    • EvPeriodic — The EvPeriodic class
    • EvPrepare — The EvPrepare class
    • EvSignal — The EvSignal class
    • EvStat — The EvStat class
    • EvTimer — The EvTimer class
    • EvWatcher — The EvWatcher class
  • Expect
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Expect
  • PCNTL — Control de procesos
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones PCNTL
  • POSIX
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones POSIX
  • Ejecución de programas — Ejecución de programas del sistema
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de ejecución de programas
  • parallel
    • Introducción
    • Installation
    • Philosophy
    • Functional API
    • parallel\Runtime — The parallel\Runtime class
    • parallel\Future — The parallel\Future class
    • parallel\Channel — The parallel\Channel class
    • parallel\Events — The parallel\Events class
    • parallel\Events\Input — The parallel\Events\Input class
    • parallel\Events\Event — The parallel\Events\Event class
    • parallel\Events\Event\Type — The parallel\Events\Event\Type class
    • parallel\Sync — The parallel\Sync class
  • pthreads
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Threaded — La clase Threaded
    • Thread — La clase Thread
    • Worker — La clase Worker
    • Collectable — La clase Collectable
    • Modificadores — Modificadores de métodos
    • Pool — La clase Pool
    • Mutex — La clase Mutex
    • Cond — La clase Cond
  • pht
    • Introducción
    • Instalación/Configuración
    • pht\Thread — The Thread class
    • pht\Runnable — The Runnable interface
    • pht\HashTable — The HashTable class
    • pht\Vector — The Vector class
    • pht\Queue — The Queue class
    • pht\AtomicInteger — The AtomicInteger class
    • pht\Threaded — The Threaded interface
  • Semaphore — Semáforo, Memoria Compartida e IPC
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Semáforo
  • Memoria compartida
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de memoria compartida
  • Sync
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • SyncMutex — The SyncMutex class
    • SyncSemaphore — The SyncSemaphore class
    • SyncEvent — The SyncEvent class
    • SyncReaderWriter — The SyncReaderWriter class
    • SyncSharedMemory — The SyncSharedMemory class


Eio

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones Eio
    • eio_busy — Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas
    • eio_cancel — Cancelar una petición
    • eio_chmod — Cambiar los permisos de fichero/directorio
    • eio_chown — Cambiar los permisos de un fichero/directorio
    • eio_close — Cerrar un fichero
    • eio_custom — Ejecutar una petición personalizada como cualquier otra llamada eio_*
    • eio_dup2 — Duplicar un descriptor de fichero
    • eio_event_loop — Monitorizar libeio hasta que todas las peticiones sean procesadas
    • eio_fallocate — Permitir al llamador manipular directamente el espacio de disco asignado a un fichero
    • eio_fchmod — Cambiar los permisos de un fichero
    • eio_fchown — Cambiar el propietario del fichero
    • eio_fdatasync — Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento
    • eio_fstat — Obtener el estado de un fichero
    • eio_fstatvfs — Obtener las estadísticas del sistema de ficheros
    • eio_fsync — Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento
    • eio_ftruncate — Truncar un fichero
    • eio_futime — Cambiar los momentos de último y acceso y modificación de un fichero
    • eio_get_event_stream — Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio
    • eio_get_last_error — Devuelve un string que describe el último error asociado con un recurso de petición
    • eio_grp_add — Añadir una petición al grupo de peticiones
    • eio_grp_cancel — Cancelar un grupo de peticiones
    • eio_grp_limit — Establecer el límite de un grupo
    • eio_grp — Crear un grupo de peticiones
    • eio_init — (Re-)inicializa Eio
    • eio_link — Crear un enlace duro par un fichero
    • eio_lstat — Obtener el estado de un fichero
    • eio_mkdir — Crear un directorio
    • eio_mknod — Crear un fichero especial u ordinario
    • eio_nop — No hace nada, sólo recorre el ciclo de peticiones entero
    • eio_npending — Devolver el número de peticiones, excepto las no manejadas
    • eio_nready — Devolver el número de peticiones aún no tratadas
    • eio_nreqs — Devuelve el número de peticiones a ser procesadas
    • eio_nthreads — Devuelve el número de hilos actualmente en uso
    • eio_open — Abrir un fichero
    • eio_poll — Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas
    • eio_read — Leer de un descriptor de fichero en un índice dado
    • eio_readahead — Perform file readahead into page cache
    • eio_readdir — Leer un directorio al completo
    • eio_readlink — Leer el valor de un enlace simbólico
    • eio_realpath — Obtener el nombre de ruta absoluto canonizado
    • eio_rename — Cambiar el nombre o la ubicación de un fichero
    • eio_rmdir — Eliminar un directorio
    • eio_seek — Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence
    • eio_sendfile — Transferir información entre descriptores de ficheros
    • eio_set_max_idle — Establecer el número máximo de hilos parados
    • eio_set_max_parallel — Esteblecer el máximo de hilos paralelos
    • eio_set_max_poll_reqs — Establecer el máximo número de peticiones procesadas en una monitorización
    • eio_set_max_poll_time — Establecer el tiempo máximo de monitorización
    • eio_set_min_parallel — Esteblecer el número de hilos paralelos mínimo
    • eio_stat — Obtener el estado de un fichero
    • eio_statvfs — Obtener las estadísticas del sistema de ficheros
    • eio_symlink — Crear un enlace simbólico
    • eio_sync_file_range — Sincornizar un segmento de fichero con el disco
    • eio_sync — Consignar el caché de buffer cache al disco
    • eio_syncfs — Realizar una llamada al sistema de syncfs de Linux si está disponible
    • eio_truncate — Truncar un fichero
    • eio_unlink — Borrar un nombre y posiblemente el fichero al que se refiere
    • eio_utime — Cambiar los momentos de último y acceso y modificación de un fichero
    • eio_write — Escribir en un fichero


Introducción

Esta extensión proporciona E/S POSIX asíncrona a través de la biblioteca de C » libeio escrita por Marc Lehmann.

Nota: Esta extensión no está disponible en plataformas Windows.

Advertencia

Es importante tener en cuenta que cada solicitud se ejecuta en un hilo, y el orden de ejecución continua de peticiones en cola es basicamente impredecible. Por ejemplo, el siguiente trozo de código es incorrecto.

Ejemplo #1 Incorrect requests

<?php
// Petición para crear un enlace simbólico de $nombre_archivo a $enlace
eio_symlink($nombre_archivo, $enlace);

// Petición para mover $nombre_archivo a $nuevo_nombre_archivo
eio_rename($nombre_archivo, $nuevo_nombre_archivo);

// Procesar las peticiones
eio_event_loop();
?>
En el ejemplo de arriba la petición eio_rename() puede finalizar antes que eio_symlink(). Para corregirlo se podría llamar a eio_rename() en la llamada de retorno de eio_symlink():

Ejemplo #2 Llamar a una petición desde una llamada de retorno de petición

<?php
function mi_enlace_simbólico_hecho($nombre_archivo, $resultado) {
 // Petición para mover $nombre_archivo a $nuevo_nombre_archivo
 eio_rename($nombre_archivo, "/ruta/a/nuevo-nombre");

 // Procesar las peticiones
 eio_event_loop();
}

// Petición para crear un enlace simbólico de $nombre_archivo a $enlace
eio_symlink($nombre_archivo, $enlace, EIO_PRI_DEFAULT, "mi_enlace_simbólico_hecho", $nombre_archivo);

 // Procesar las peticiones
eio_event_loop();
?>
Alternativamente, podría querer crear un grupo de peticiones:

Ejemplo #3 Llamar a una petición desde una llamada de retorno de petición

<?php
/* Se llama cuando el grupo de peticiones está hecho */
function mi_grupo_hecho($data, $resultado) {
 // ...
}

function mi_enlace_simbólico_hecho($nombre_archivo, $resultado) {
 // Crear una petición eio_rename y añadirla al grupo
 $petición = eio_rename($nombre_archivo, "/ruta/a/nuevo-nombre");
 eio_grp_add($grupo, $petición);
 // Podría querer añadir más peticiones...
}

// Crear un grupo de peticiones
$grupo = eio_grp("mi_grupo_hecho", "mis_datos_de_grupo");

// Crear una petición eio_symlink y añadirla al grupo
// Pasar $nombre_archivo a la llamada de retorno
$petición = eio_symlink($nombre_archivo, $enlace,
  EIO_PRI_DEFAULT, "mi_enlace_simbólico_hecho", $nombre_archivo);
eio_grp_add($grupo, $petición);

 // Procesar las peticiones
eio_event_loop();
?>
El grupo es un tipo especial de peticion que podría acumular un conjunto de peticiones eio regulares. Se podría usar para crear una petición compleja para abrir, leer y cerrar un fichero.

Desde la versión 0.3.0 alfa, una variable usada internamete en las comunicaciones con libeio, podía ser recuperada con eio_get_event_stream(). La variable se podría usar para vincularse a un bucle de eventos soportado por alguna otra extensión. Se podría organizar un sencillo bucle de eventos donde eio y libevent trabajaran juntos:

Ejemplo #4 Usar eio con libevent

<?php
function mi_eio_poll($df, $eventos, $argumentos) {
    /* Algunas regulaciones de libevent podrían ir aquí .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. y aquí */
}

function mi_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$evento = event_new();

// Este flujo se usa para vincularse con libevent
$df = eio_get_event_stream();

eio_nop(EIO_PRI_DEFAULT, "mi_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "mi_res_cb", "mkdir data");
/* algunas llamadas eio_* aquí ... */

// establecer las banderas del evento
event_set($evento, $df, EV_READ /*| EV_PERSIST*/, "mi_eio_poll", array($evento, $base));

// Establecer la base del evento
event_base_set($evento, $base);

// habilitar el evento
event_add($evento);

// iniciar el bucle de eventos
event_base_loop($base);

/* Lo mismo estará disponible mediante interfaz libevent con buffer */
?>


Requerimientos

Esta extensión tiene la biblioteca » libeio embebida. Por lo que NO se necesita instalar libeio por separado.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/eio.

Para información sobre la instalación manual, lea el fichero INSTALL incluido en el paquete.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Existen dos tipos de recursos en esta extensión: petición y grupo de peticiones.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes de prioridad de petición:

EIO_PRI_MIN (integer)
Prioridad de petición mínima
EIO_PRI_DEFAULT (integer)
Prioridad de petición predeterminada
EIO_PRI_MAX (integer)
Prioridad de petición máxima

El argumento whence de eio_seek():

EIO_SEEK_SET (integer)
El índice es establecido para espcificar el número de bytes (offset).
EIO_SEEK_CUR (integer)
El índice es establecido a su ubicación actual más offset bytes.
EIO_SEEK_END (integer)
El índice es establecido a el tamaño del fichero más offset bytes.

Banderas usadas con eio_readdir():

EIO_READDIR_DENTS (integer)
Bandera eio_readdir(). Si se especifica, el argumento resultante de la llamada de retorno se convierte en un array con las siguientes claves: 'names' - array de nombres de directorios 'dents' - array de structura eio_dirent-como los arrays pero teniendo las siguientes claves: 'name' - el nombre del directorio; 'type' - una de las constantes EIO_DT_*; 'inode' - el número de inodo, si está disponible, de otro modo sin especificar;
EIO_READDIR_DIRS_FIRST (integer)
Cuando se especifica esta bandera, los nombres serán devueltos en un orden donde probablemente los directorios vallan primero, en un orden de estadísticas óptimo.
EIO_READDIR_STAT_ORDER (integer)
Cuando se especifica esta bandera, los nombres serán devueltos en un orden apropiado para realizar estadísticas (stat) con cada uno. Cuando se planea usar la función stat() para realizar estadísticas de todos los archivos del directorio dado, el orden devuelto probablemente sea más rápido.
EIO_READDIR_FOUND_UNKNOWN (integer)
EIO_DT_UNKNOWN (integer)
Tipo de nodo desconocido(muy común). Se necistan más estadísticas (stat()).
EIO_DT_FIFO (integer)
Tipo de nodo FIFO
EIO_DT_CHR (integer)
Tipo de nodo
EIO_DT_MPC (integer)
Tipo de nodo de dispositivo de caracteres multiplexado (v7+coherent)
EIO_DT_DIR (integer)
Tipo de nodo de directorio
EIO_DT_NAM (integer)
Tipo de nodo de fichero Xenix nominado especial
EIO_DT_BLK (integer)
Tipo de nodo
EIO_DT_MPB (integer)
Dispositivo de bloqueo multiplexado (v7+coherent)
EIO_DT_REG (integer)
Tipo de nodo
EIO_DT_NWK (integer)
EIO_DT_CMP (integer)
Tipo de noto especial de red HP-UX
EIO_DT_LNK (integer)
Tipo de nodo de vínculo
EIO_DT_SOCK (integer)
Tipo de nodo socket
EIO_DT_DOOR (integer)
Tipo de nodo de puerta de Solaris
EIO_DT_WHT (integer)
Tipo de nodo
EIO_DT_MAX (integer)
Valor de tipo de nodo más alto

Modo de acceso para el argumento flags de eio_open():

EIO_O_RDONLY (integer)
EIO_O_WRONLY (integer)
EIO_O_RDWR (integer)
EIO_O_NONBLOCK (integer)
EIO_O_APPEND (integer)
EIO_O_CREAT (integer)
EIO_O_TRUNC (integer)
EIO_O_EXCL (integer)
EIO_O_FSYNC (integer)

Banderas del argumento mode de eio_open():

EIO_S_IRUSR (integer)
EIO_S_IWUSR (integer)
EIO_S_IXUSR (integer)
EIO_S_IRGRP (integer)
EIO_S_IWGRP (integer)
EIO_S_IXGRP (integer)
EIO_S_IROTH (integer)
EIO_S_IWOTH (integer)
EIO_S_IXOTH (integer)
EIO_S_IFREG (integer)
EIO_S_IFCHR (integer)
EIO_S_IFBLK (integer)
EIO_S_IFIFO (integer)
EIO_S_IFSOCK (integer)

Banderas de eio_sync_file_range():

EIO_SYNC_FILE_RANGE_WAIT_BEFORE (integer)
EIO_SYNC_FILE_RANGE_WRITE (integer)
EIO_SYNC_FILE_RANGE_WAIT_AFTER (integer)

Banderas de eio_fallocate():

EIO_FALLOC_FL_KEEP_SIZE (integer)

Nota:

Las constantes EIO_S_I* tienen el mismo significado que sus homónimos S_I* de POSIX.

Nota:

EIO_SYNC_FILE_*tienen el mismo significado que sus homónimos SYNC_FILE_**.

Nota:

EIO_O_*tienen el mismo significado que sus homónimos O_*de POSIX.


Ejemplos

Ejemplo #1 Cancelar una petición

<?php
 /* Es llamada cuando finaliza eio_nop() */
 function mi_llamada_retorno_nop($datos, $resultado) {
  echo "mi_nop ", $datos, "\n";
 }

// Esta llamada a eio_nop() será cancelada
$petición = eio_nop(EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "1");
var_dump($petición);
eio_cancel($petición);

// Esta vez eio_nop() será procesada
eio_nop(EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "2");

// Process requests
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(4) of type (EIO Request Descriptor)
mi_nop 2

Ejemplo #2 Llamar a eio_chmod()

<?php
$nombre_fichero_temp = dirname(__FILE__) ."eio-fichero-temp.tmp";
touch($nombre_fichero_temp);

/* Es llamada cuando finaliza eio_chmod() */
function mi_llamada_retorno_chmod($datos, $resultado) {
    global $nombre_fichero_temp;

    if ($resultado == 0 && !is_readable($nombre_fichero_temp) && is_writable($nombre_fichero_temp)) {
        echo "eio_chmod_ok";
    }

    @unlink($nombre_fichero_temp);
}

eio_chmod($nombre_fichero_temp, 0200, EIO_PRI_DEFAULT, "mi_llamada_retorno_chmod");
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

eio_chmod_ok

Ejemplo #3 Realizar una petición personalizada

<?php
/* Llamada de retorno para la llamada de retorno personalizada */
function mi_llamada_retorno_personalizada($datos, $resultado) {
    var_dump($datos);
    var_dump(count($resultado));
    var_dump($resultado['data_modified']);
    var_dump($resultado['result']);
}

/* La petición personalizada */
function mi_personalizada($datos) {
    var_dump($datos);

    $resultado = array(
        'result'        => 1001,
        'data_modified' => "mis datos personalizados",
    );

    return $resultado;
}

$datos = "mis_datos_personalizados";
$petición = eio_custom("mi_personalizada", EIO_PRI_DEFAULT, "mi_llamada_retorno_personalizada", $datos);
var_dump($petición);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(4) of type (EIO Request Descriptor)
string(24) "mis_datos_personalizados"
string(24) "mis_datos_personalizados"
int(2)
string(24) "mis datos personalizados"
int(1001)

Ejemplo #4 Agrupar peticiones

<?php
/*
 * Crear un grupo de peticiones para abrir, leer y cerrar un fichero
 */

$nombre_fichero_temp = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($nombre_fichero_temp, "w");
fwrite($fp, "algunos datos");
fclose($fp);

/* Es llamada cuando el grupo de peticiones está hecho */
function mi_grupo_hecho($datos, $resultado) {
 global $nombre_fichero_temp;
 var_dump($resultado == 0);
 @unlink($nombre_fichero_temp);
}

/* Es llamada cuando eio_open() termina */
function mi_grupo_llamada_retorno_fichero_abierto($datos, $resultado) {
 global $mi_df_fichero, $grupo;

 $mi_df_fichero = $resultado;

 var_dump($resultado > 0);

 // Crear una petición eio_read() y añadirla al grupo
 $petición = eio_read($mi_df_fichero, 4, 0, EIO_PRI_DEFAULT, "mi_grupo_llamada_retorno_fichero_leído");
 eio_grp_add($grupo, $petición);
}

/* Is called when eio_read() done */
function mi_grupo_llamada_retorno_fichero_leído($datos, $resultado) {
 global $mi_df_fichero, $grupo;

 var_dump($resultado);

 // Crear una petición eio_close() y añadirla al grupo
 $petición = eio_close($mi_df_fichero);
 eio_grp_add($grupo, $petición);
}

$grupo = eio_grp("mi_grupo_hecho", "mis_datos_grupo");

// Crear una petición eio_open() y añadirla al grupo
$petición = eio_open($nombre_fichero_temp, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "mi_grupo_llamada_retorno_fichero_abierto", NULL);
eio_grp_add($grupo, $petición);
var_dump($grupo);

eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(6) of type (EIO Group Descriptor)
bool(true)
string(7) "algunos"
bool(true)

Ejemplo #5 Emplear eio con la extensión libevent

<?php
function mi_eio_poll($df, $eventos, $argumentos) {
    /* Algunas regulaciones de libevent podrían ir aquí .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. y aquí */
}

function mi_llamada_retorno_nop($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$evento = event_new();

$df = eio_get_event_stream();
var_dump($df);

eio_nop(EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "nop data");
/* algunas llamadas eio_* aquí ... */

// establecer las banderas del evento
event_set($evento, $df, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($evento, $base));

// Establecer la base del evento
event_base_set($evento, $base);

// habilitar el evento
event_add($evento);

// iniciar el bucle de eventos
event_base_loop($base);

/* Lo mismo estará disponible mediante interfaz libevent con buffer */
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"

Ejemplo #6 Emplear eio con la extensión event

<?php
$base = new EventBase();

// Recuperar el flujo de sondeo de eio.
// Observe, esta variable debería permanecer viva mientras se ejecute el bucle.
$eio_stream = eio_get_event_stream();

// Vincular el flujo de sondeo de eio al bucle de evento.
$poll_event = new Event($base, $eio_stream, Event::READ, function () {
  if (eio_nreqs()) {
    eio_poll();
  }
});
$poll_event->add();

// Añadir trabajos de eio
eio_nop(EIO_PRI_DEFAULT, function () {
  echo "eio_nop\n";
});

// Añadir eventos
$timer = Event::timer($base, function () {
  echo "2 segundos transcurridos\n";
});
$timer->add(2);

// Despachar eventos.
$base->dispatch();
?>

El resultado del ejemplo sería algo similar a:

eio_nop
2 segundos transcurridos


Funciones Eio

Tabla de contenidos

  • eio_busy — Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas
  • eio_cancel — Cancelar una petición
  • eio_chmod — Cambiar los permisos de fichero/directorio
  • eio_chown — Cambiar los permisos de un fichero/directorio
  • eio_close — Cerrar un fichero
  • eio_custom — Ejecutar una petición personalizada como cualquier otra llamada eio_*
  • eio_dup2 — Duplicar un descriptor de fichero
  • eio_event_loop — Monitorizar libeio hasta que todas las peticiones sean procesadas
  • eio_fallocate — Permitir al llamador manipular directamente el espacio de disco asignado a un fichero
  • eio_fchmod — Cambiar los permisos de un fichero
  • eio_fchown — Cambiar el propietario del fichero
  • eio_fdatasync — Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento
  • eio_fstat — Obtener el estado de un fichero
  • eio_fstatvfs — Obtener las estadísticas del sistema de ficheros
  • eio_fsync — Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento
  • eio_ftruncate — Truncar un fichero
  • eio_futime — Cambiar los momentos de último y acceso y modificación de un fichero
  • eio_get_event_stream — Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio
  • eio_get_last_error — Devuelve un string que describe el último error asociado con un recurso de petición
  • eio_grp_add — Añadir una petición al grupo de peticiones
  • eio_grp_cancel — Cancelar un grupo de peticiones
  • eio_grp_limit — Establecer el límite de un grupo
  • eio_grp — Crear un grupo de peticiones
  • eio_init — (Re-)inicializa Eio
  • eio_link — Crear un enlace duro par un fichero
  • eio_lstat — Obtener el estado de un fichero
  • eio_mkdir — Crear un directorio
  • eio_mknod — Crear un fichero especial u ordinario
  • eio_nop — No hace nada, sólo recorre el ciclo de peticiones entero
  • eio_npending — Devolver el número de peticiones, excepto las no manejadas
  • eio_nready — Devolver el número de peticiones aún no tratadas
  • eio_nreqs — Devuelve el número de peticiones a ser procesadas
  • eio_nthreads — Devuelve el número de hilos actualmente en uso
  • eio_open — Abrir un fichero
  • eio_poll — Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas
  • eio_read — Leer de un descriptor de fichero en un índice dado
  • eio_readahead — Perform file readahead into page cache
  • eio_readdir — Leer un directorio al completo
  • eio_readlink — Leer el valor de un enlace simbólico
  • eio_realpath — Obtener el nombre de ruta absoluto canonizado
  • eio_rename — Cambiar el nombre o la ubicación de un fichero
  • eio_rmdir — Eliminar un directorio
  • eio_seek — Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence
  • eio_sendfile — Transferir información entre descriptores de ficheros
  • eio_set_max_idle — Establecer el número máximo de hilos parados
  • eio_set_max_parallel — Esteblecer el máximo de hilos paralelos
  • eio_set_max_poll_reqs — Establecer el máximo número de peticiones procesadas en una monitorización
  • eio_set_max_poll_time — Establecer el tiempo máximo de monitorización
  • eio_set_min_parallel — Esteblecer el número de hilos paralelos mínimo
  • eio_stat — Obtener el estado de un fichero
  • eio_statvfs — Obtener las estadísticas del sistema de ficheros
  • eio_symlink — Crear un enlace simbólico
  • eio_sync_file_range — Sincornizar un segmento de fichero con el disco
  • eio_sync — Consignar el caché de buffer cache al disco
  • eio_syncfs — Realizar una llamada al sistema de syncfs de Linux si está disponible
  • eio_truncate — Truncar un fichero
  • eio_unlink — Borrar un nombre y posiblemente el fichero al que se refiere
  • eio_utime — Cambiar los momentos de último y acceso y modificación de un fichero
  • eio_write — Escribir en un fichero


Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas

  • « Funciones Eio
  • eio_cancel »
  • PHP Manual
  • Funciones Eio
  • Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas

eio_busy

(PECL eio >= 0.0.1dev)

eio_busy — Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas

Descripción

eio_busy ( int $delay , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_busy() incrementa artificialmente la carga tomanto delay segundos para ejecutarse. Puede usarse para depuración, o evaluaciones comparativas.

Parámetros

delay

Retraso en segundos

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

Esta llamada de retorno se llama cuando está hecho todo el grupo de peticiones.

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_busy() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_nop() - No hace nada, sólo recorre el ciclo de peticiones entero


Cancelar una petición

  • « eio_busy
  • eio_chmod »
  • PHP Manual
  • Funciones Eio
  • Cancelar una petición

eio_cancel

(PECL eio >= 0.0.1dev)

eio_cancel — Cancelar una petición

Descripción

eio_cancel ( resource $req ) : void

eio_cancel() cancela una petición especificada por req

Parámetros

req

E rescurso de petición

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de eio_cancel()

<?php
 /* Es llamada cuando eio_nop() finaliza */
 function mi_llamada_retorno_nop($datos, $resultado) {
  echo "mi_nop ", $datos, "\n";
 }

// Esta llamada a eio_nop() será cancelada
$petición = eio_nop(EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "1");
var_dump($petición);
eio_cancel($petición);

// Esta vez eio_nop() será procesada
eio_nop(EIO_PRI_DEFAULT, "mi_llamada_retorno_nop", "2");

// Procesar las peticiones
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(4) of type (EIO Request Descriptor)
mi_nop 2

Ver también

  • eio_grp_cancel() - Cancelar un grupo de peticiones


Cambiar los permisos de fichero/directorio

  • « eio_cancel
  • eio_chown »
  • PHP Manual
  • Funciones Eio
  • Cambiar los permisos de fichero/directorio

eio_chmod

(PECL eio >= 0.0.1dev)

eio_chmod — Cambiar los permisos de fichero/directorio

Descripción

eio_chmod ( string $path , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_chmod() cambia los permisos de un fichero o directorio. Los nuevos permisos son especificados mediandte mode.

Parámetros

path

La ruta al fichero o directorio objetivo

Advertencia

Evita rutas relativas

mode

Los nuevos permisos. P.ej. 0644.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_chmod() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_chown() - Cambiar los permisos de un fichero/directorio


Cambiar los permisos de un fichero/directorio

  • « eio_chmod
  • eio_close »
  • PHP Manual
  • Funciones Eio
  • Cambiar los permisos de un fichero/directorio

eio_chown

(PECL eio >= 0.0.1dev)

eio_chown — Cambiar los permisos de un fichero/directorio

Descripción

eio_chown ( string $path , int $uid , int $gid = -1 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Cambia los permisos de un fichero o directorio.

Parámetros

path

La ruta al fichero o directorio.

Advertencia

Evita rutas relativas

uid

El ID de usuario. Se ignora si es aigual a -1.

gid

El ID de grupo. Se ignora si es aigual a -1.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_chown() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_chmod() - Cambiar los permisos de fichero/directorio


Cerrar un fichero

  • « eio_chown
  • eio_custom »
  • PHP Manual
  • Funciones Eio
  • Cerrar un fichero

eio_close

(PECL eio >= 0.0.1dev)

eio_close — Cerrar un fichero

Descripción

eio_close ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_close() cierra el fichero especificado por fd.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_close() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_open() - Abrir un fichero


Ejecutar una petición personalizada como cualquier otra llamada eio_*

  • « eio_close
  • eio_dup2 »
  • PHP Manual
  • Funciones Eio
  • Ejecutar una petición personalizada como cualquier otra llamada eio_*

eio_custom

(PECL eio >= 0.0.1dev)

eio_custom — Ejecutar una petición personalizada como cualquier otra llamada eio_*

Descripción

eio_custom ( callable $execute , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_custom() ejecuta una función personalizada especificada por execute procesándola igual que cualquier otra llamada eio_*.

Parámetros

execute

Especifica la función de petición que debería coincidir con el siguiente prototipo:

      mixed execute(mixed data);
callback es una llamada de retorno de finalización de evento que debería coincidir con el siguiente prototipo:
      void callback(mixed data, mixed result);
data son los datos pasados a execute mediante el argumento data sin modificaciones result valor devuelto por execute

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_custom() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_custom()

<?php
/* Llamada de retorno para la llamada de retorno personalizada */
function mi_llamada_retorno_personalizada($datos, $resultado) {
    var_dump($datos);
    var_dump(count($resultado));
    var_dump($resultado['datos_modificados']);
    var_dump($resultado['resultado']);
}

/* La petición personalizada */
function mi_personalizada($datos) {
    var_dump($datos);

    $resultado = array(
        'resultado'         => 1001,
        'datos_modificados' => "mis datos personalizados",
    );

    return $resultado;
}

$datos = "mis_datos_personalizados";
$petición = eio_custom("mi_personalizada", EIO_PRI_DEFAULT, "mi_llamada_retorno_personalizada", $datos);
var_dump($petición);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(4) of type (EIO Request Descriptor)
string(24) "mis_datos_personalizados"
string(24) "mis_datos_personalizados"
int(2)
string(24) "mis datos personalizados"
int(1001)


Duplicar un descriptor de fichero

  • « eio_custom
  • eio_event_loop »
  • PHP Manual
  • Funciones Eio
  • Duplicar un descriptor de fichero

eio_dup2

(PECL eio >= 0.0.1dev)

eio_dup2 — Duplicar un descriptor de fichero

Descripción

eio_dup2 ( mixed $fd , mixed $fd2 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_dup2() duplica un descriptor de fichero.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor de fichero numérico origen

fd2

Un flujo, un recurso Socket, o un descriptor de fichero numérico objetivo

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_dup2() devuelve un recurso de petición en caso de éxito o false en caso de error.


Monitorizar libeio hasta que todas las peticiones sean procesadas

  • « eio_dup2
  • eio_fallocate »
  • PHP Manual
  • Funciones Eio
  • Monitorizar libeio hasta que todas las peticiones sean procesadas

eio_event_loop

(PECL eio >= 0.0.1dev)

eio_event_loop — Monitorizar libeio hasta que todas las peticiones sean procesadas

Descripción

eio_event_loop ( ) : bool

eio_event_loop() monitoriza libeio hasta que todas las peticiones sean procesadas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_event_loop() devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_event_loop()

<?php
$nombre_fichero_temp = "fichero-temp-eio.tmp";
touch($nombre_fichero_temp);

/* Es llamada cuando eio_chmod() finaliza */
function mi_llamada_retorno_chmod($datos, $resultado) {
    global $nombre_fichero_temp;

    if ($resultado == 0 && !is_readable($nombre_fichero_temp) && is_writable($nombre_fichero_temp)) {
        echo "eio_chmod_ok";
    }

    @unlink($nombre_fichero_temp);
}

eio_chmod($nombre_fichero_temp, 0200, EIO_PRI_DEFAULT, "mi_llamada_retorno_chmod");
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

eio_chmod_ok

Ver también

  • eio_poll() - Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas


Permitir al llamador manipular directamente el espacio de disco asignado a un fichero

  • « eio_event_loop
  • eio_fchmod »
  • PHP Manual
  • Funciones Eio
  • Permitir al llamador manipular directamente el espacio de disco asignado a un fichero

eio_fallocate

(PECL eio >= 0.0.1dev)

eio_fallocate — Permitir al llamador manipular directamente el espacio de disco asignado a un fichero

Descripción

eio_fallocate ( mixed $fd , int $mode , int $offset , int $length , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fallocate() permite al llamador manipular directamente el espacio de disco asignado al fichero especificado por el descriptor de fichero fd para el rango de bytes empezando por offset y continuando length bytes.

Nota: El fichero debería abrirse para lectura

Se debería usar OR entre EIO_O_CREAT y EIO_O_WRONLY o EIO_O_RDWR

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero, p.ej., devuelto por eio_open().

mode

Actualmente sólo está soportada una bandera para el modo: EIO_FALLOC_FL_KEEP_SIZE (lo mismo que la constante POSIX FALLOC_FL_KEEP_SIZE).

offset

Especifica el inicio del rango de bytes.

length

Especifica la longitud del rango de bytes.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_fallocate() devuelve un recurso de petición en caso de éxito o false en caso de error.


Cambiar los permisos de un fichero

  • « eio_fallocate
  • eio_fchown »
  • PHP Manual
  • Funciones Eio
  • Cambiar los permisos de un fichero

eio_fchmod

(PECL eio >= 0.0.1dev)

eio_fchmod — Cambiar los permisos de un fichero

Descripción

eio_fchmod ( mixed $fd , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fchmod() cambia los permisos del fichero especificado por el descriptor de fichero fd.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero, p.ej., devuelto por eio_open().

mode

Los nuevos permisos. P.ej. 0644.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_fchmod() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_fchown() - Cambiar el propietario del fichero


Cambiar el propietario del fichero

  • « eio_fchmod
  • eio_fdatasync »
  • PHP Manual
  • Funciones Eio
  • Cambiar el propietario del fichero

eio_fchown

(PECL eio >= 0.0.1dev)

eio_fchown — Cambiar el propietario del fichero

Descripción

eio_fchown ( mixed $fd , int $uid , int $gid = -1 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fchown() cambia el propietario del fichero especificado por el descriptor de fichero fd.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

uid

El ID de ususario. Se ignora si es igual a -1.

gid

El ID de grupo. Se ignora si es igual a -1.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Ver también

  • eio_fchmod() - Cambiar los permisos de un fichero


Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento

  • « eio_fchown
  • eio_fstat »
  • PHP Manual
  • Funciones Eio
  • Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento

eio_fdatasync

(PECL eio >= 0.0.1dev)

eio_fdatasync — Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento

Descripción

eio_fdatasync ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fdatasync() sincroniza el estado de ficheros que están en memoria con un dispositivo de almacenamiento.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero, p.ej., devuelto por eio_open().

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_fdatasync() devuelve un recurso de petición en caso de éxito o false en caso de error.


Obtener el estado de un fichero

  • « eio_fdatasync
  • eio_fstatvfs »
  • PHP Manual
  • Funciones Eio
  • Obtener el estado de un fichero

eio_fstat

(PECL eio >= 0.0.1dev)

eio_fstat — Obtener el estado de un fichero

Descripción

eio_fstat ( mixed $fd , int $pri , callable $callback , mixed $data = ? ) : resource

eio_fstat() devuelve la información del estado de un fichero en el argumento result de callback

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_busy() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_lstat()

<?php
// Create temporary file
$nombre_fichero_temp = dirname(__FILE__) ."/fichero-eio.tmp";
touch($nombre_fichero_temp);

/* Se llama cuando eio_fstat() termina */
function my_res_cb($datos, $resultado) {
 // Debería imprimir un array con la información de las estadísticas
 var_dump($resultado);

 if ($datos['fd']) {
  // Cerrar el fichero temporal
  eio_close($datos['fd']);
  eio_event_loop();
 }
 // Eliminar el fichero temporal
 @unlink($datos['file']);
}

/* Se llama cuando eio_open() termina */
function my_open_cb($datos, $resultado) {
 // Preparar los datos para la llamada de retorno
 $d = array(
  'fd'  => $resultado,
  'file'=> $datos
 );
 // Solicitar la información de las estadísticas
 eio_fstat($resultado, EIO_PRI_DEFAULT, "my_res_cb", $d);
 // Procesar la/s petición/es
 eio_event_loop();
}

// Abrir el fichero temporal
eio_open($nombre_fichero_temp, EIO_O_RDONLY, NULL, EIO_PRI_DEFAULT,
  "my_open_cb", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489159)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318239506)
  ["st_mtime"]=>
  int(1318239506)
  ["st_ctime"]=>
  int(1318239506)
}

Ver también

  • eio_lstat() - Obtener el estado de un fichero
  • eio_stat() - Obtener el estado de un fichero


Obtener las estadísticas del sistema de ficheros

  • « eio_fstat
  • eio_fsync »
  • PHP Manual
  • Funciones Eio
  • Obtener las estadísticas del sistema de ficheros

eio_fstatvfs

(PECL eio >= 0.0.1dev)

eio_fstatvfs — Obtener las estadísticas del sistema de ficheros

Descripción

eio_fstatvfs ( mixed $fd , int $pri , callable $callback , mixed $data = ? ) : resource

eio_fstatvfs() devuelve las estadísticas del sistema de ficheros en el parámetro result de callback.

Parámetros

fd

Un descriptor de fichero de un fichero del sistema de ficheros abierto.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_fstatvfs() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_statvfs() - Obtener las estadísticas del sistema de ficheros


Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento

  • « eio_fstatvfs
  • eio_ftruncate »
  • PHP Manual
  • Funciones Eio
  • Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento

eio_fsync

(PECL eio >= 0.0.1dev)

eio_fsync — Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento

Descripción

eio_fsync ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Sincroniza el estado de un fichero en memoria con un dispositivo de almacenamiento

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_fsync() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_sync() - Consignar el caché de buffer cache al disco


Truncar un fichero

  • « eio_fsync
  • eio_futime »
  • PHP Manual
  • Funciones Eio
  • Truncar un fichero

eio_ftruncate

(PECL eio >= 0.0.1dev)

eio_ftruncate — Truncar un fichero

Descripción

eio_ftruncate ( mixed $fd , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_ftruncate() hace que un fichero regular referenciado por el descriptor de fichero fd sea truncado a exactamente length bytes.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

offset

Índice desde el principio del fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_ftruncate() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_truncate() - Truncar un fichero


Cambiar los momentos de último y acceso y modificación de un fichero

  • « eio_ftruncate
  • eio_get_event_stream »
  • PHP Manual
  • Funciones Eio
  • Cambiar los momentos de último y acceso y modificación de un fichero

eio_futime

(PECL eio >= 0.0.1dev)

eio_futime — Cambiar los momentos de último y acceso y modificación de un fichero

Descripción

eio_futime ( mixed $fd , float $atime , float $mtime , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_futime() cambia los momentos de último acceso y modificación de un fichero.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero, p.ej., devuelto por eio_open().

atime

Momento de acceso

mtime

Momento de modificación

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_futime() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_utime() - Cambiar los momentos de último y acceso y modificación de un fichero


Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio

  • « eio_futime
  • eio_get_last_error »
  • PHP Manual
  • Funciones Eio
  • Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio

eio_get_event_stream

(PECL eio >= 0.3.1b)

eio_get_event_stream — Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio

Descripción

eio_get_event_stream ( ) : mixed

eio_get_event_stream() adquiere un flujo que representa una variable usada en comunicaciones internas con libeio. Se podría usar para vinculaciones con algún bucle de eventos proporcionado por otra extensión PECL, por ejemplo libevent.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_get_event_stream() devuelve un flujo en caso de éxito; de otro modo devuelve null

Ejemplos

Ejemplo #1 Usar eio con libevent

<?php
function mi_eio_poll($df, $eventos, $argumento) {
    /* Algunas regulaciones de libevent podrían ir aquí .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. y aquí */
}

function my_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$evento = event_new();

$df = eio_get_event_stream();
var_dump($df);

eio_nop(EIO_PRI_DEFAULT, "my_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_res_cb", "mkdir data");
/* algunas llamadas eio_* aquí ... */

// establecer la banderas del evento
event_set($evento, $df, EV_READ /*| EV_PERSIST*/, "mi_eio_poll", array($evento, $base));

// establecer la base del evento
event_base_set($evento, $base);

// habilitar el evento
event_add($evento);

// iniciar el bucle de eventos
event_base_loop($base);

/* Lo mismo estará disponible mediante interfaz libevent con buffer */
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"


Devuelve un string que describe el último error asociado con un recurso de petición

  • « eio_get_event_stream
  • eio_grp_add »
  • PHP Manual
  • Funciones Eio
  • Devuelve un string que describe el último error asociado con un recurso de petición

eio_get_last_error

(PECL eio >= 1.0.0)

eio_get_last_error — Devuelve un string que describe el último error asociado con un recurso de petición

Descripción

eio_get_last_error ( resource $req ) : string

eio_get_last_error() devuelve un string que describe el último error asociado con req.

Parámetros

req

El recurso de petición

Valores devueltos

eio_get_last_error() devuelve un string que describe el último error asociado con el recurso de petición dado por req.

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Añadir una petición al grupo de peticiones

  • « eio_get_last_error
  • eio_grp_cancel »
  • PHP Manual
  • Funciones Eio
  • Añadir una petición al grupo de peticiones

eio_grp_add

(PECL eio >= 0.0.1dev)

eio_grp_add — Añadir una petición al grupo de peticiones

Descripción

eio_grp_add ( resource $grp , resource $req ) : void

eio_grp_add() añade una petición al grupo de peticiones.

Parámetros

grp

El recurso de grupo de peticiones devuelto por eio_grp()

req

El recurso de petición

Valores devueltos

eio_grp_add() no devuelve ningún valor.

Ejemplos

Ejemplo #1 Agrupar peticiones

<?php
/*
 * Crear un grupo de peticiones para abrir, leer y cerrar un fichero
 */

// Crear un fichero temporal y escribir algunos bytes en él
$nombre_fichero_temp = dirname(__FILE__) ."/fichero-eio.tmp";
$fp = fopen($nombre_fichero_temp, "w");
fwrite($fp, "algunos datos");
fclose($fp);

/* Es llamada cuando el grupo de peticiones está hecho */
function mi_grupo_hecho($datos, $resultado) {
 var_dump($resultado == 0);
 @unlink($datos);
}

/* Es llamada cuando eio_open() termina */
function mi_llamada_retorno_fichero_abierto($datos, $resultado) {
 global $grupo;

 // $resultado debería contener el descriptor del fichero
 var_dump($resultado > 0);

 // Crear una petición eio_read() y añadirla al grupo
 // Pasar el descriptor del fichero a la llamada de retorno
 $petición = eio_read($resultado, 4, 0,
   EIO_PRI_DEFAULT, "mi_llamada_retorno_grupo_fichero_leído", $resultado);
 eio_grp_add($grupo, $petición);
}

/* Es llamada cuando eio_read() termina */
function mi_llamada_retorno_grupo_fichero_leído($datos, $resultado) {
 global $grupo;

 // Leer bytes
 var_dump($resultado);

 // Crear una petición eio_close() y añadirla al grupo
 // $datos debería contener el descriptor del fichero
 $petición = eio_close($datos);
 eio_grp_add($grupo, $petición);
}

// Crear un grupo de peticiones
$grupo = eio_grp("mi_grupo_hecho", $nombre_fichero_temp);
var_dump($grupo);

// Crear una petición eio_open() y añadirla al grupo
$petición = eio_open($nombre_fichero_temp, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "mi_llamada_retorno_fichero_abierto", NULL);
eio_grp_add($grupo, $petición);

// Procesar las peticiones
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

resource(6) of type (EIO Group Descriptor)
bool(true)
string(7) "algunos"
bool(true)

Ver también

  • eio_grp() - Crear un grupo de peticiones
  • eio_grp_cancel() - Cancelar un grupo de peticiones
  • eio_grp_limit() - Establecer el límite de un grupo


Cancelar un grupo de peticiones

  • « eio_grp_add
  • eio_grp_limit »
  • PHP Manual
  • Funciones Eio
  • Cancelar un grupo de peticiones

eio_grp_cancel

(PECL eio >= 0.0.1dev)

eio_grp_cancel — Cancelar un grupo de peticiones

Descripción

eio_grp_cancel ( resource $grp ) : void

eio_grp_cancel() cancela un grupo de peticiones especificadas por el recurso de grupo de peticiones grp.

Parámetros

grp

El recurso de grupo de peticiones devuelto por eio_grp().

Valores devueltos

No devuelve ningún valor.

Ver también

  • eio_grp() - Crear un grupo de peticiones
  • eio_grp_add() - Añadir una petición al grupo de peticiones


Establecer el límite de un grupo

  • « eio_grp_cancel
  • eio_grp »
  • PHP Manual
  • Funciones Eio
  • Establecer el límite de un grupo

eio_grp_limit

(PECL eio >= 0.0.1dev)

eio_grp_limit — Establecer el límite de un grupo

Descripción

eio_grp_limit ( resource $grp , int $limit ) : void

Número límite de peticiones en un grupo de peticiones.

Parámetros

grp

El recurso de grupo de peticiones.

limit

El número de peticiones del grupo.

Valores devueltos

No devuelve ningún valor.

Ver también

  • eio_grp_add() - Añadir una petición al grupo de peticiones


Crear un grupo de peticiones

  • « eio_grp_limit
  • eio_init »
  • PHP Manual
  • Funciones Eio
  • Crear un grupo de peticiones

eio_grp

(PECL eio >= 0.0.1dev)

eio_grp — Crear un grupo de peticiones

Descripción

eio_grp ( callable $callback , string $data = NULL ) : resource

eio_grp() crea un grupo de peticiones.

Parámetros

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_grp() devuelve un recurso de grupo de peticiones en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_grp()

<?php
$nombre_fichero_temp = dirname(__FILE__) ."/fichero-eio.tmp";
$fp = fopen($nombre_fichero_temp, "w");
fwrite($fp, "algunos datos");
fclose($fp);
$mi_df_fichero = NULL;

/* Es llamada cuando el grupo de peticiones está hecho */
function mi_grupo_hecho($datos, $resultado) {
 // Eliminar el fichero, si aún existe
 @unlink($datos);
}

/* Es llamada al abrir el fichero temporal */
function mi_llamada_retorno_grupo_fichero_abierto($datos, $resultado) {
 global $mi_df_fichero, $grupo;

 $mi_df_fichero = $resultado;

 $petición = eio_read($mi_df_fichero, 4, 0,
   EIO_PRI_DEFAULT, "mi_llamada_retorno_grupo_fichero_leído");
 eio_grp_add($grupo, $petición);
}

/* Es llamada cuando el fichero es leído */
function mi_llamada_retorno_grupo_fichero_leído($datos, $resultado) {
 global $mi_df_fichero, $grupo;

 var_dump($resultado);

 // Crear una petición para cerrar el fichero
 $petición = eio_close($mi_df_fichero);

 // Añadir la petición al grupo
 eio_grp_add($grupo, $petición);
}

// Crear un grupo de peticiones
$grupo = eio_grp("mi_grupo_hecho", $nombre_fichero_temp);

// Crear una petición
$petición = eio_open($nombre_fichero_temp, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "mi_llamada_retorno_grupo_fichero_abierto", NULL);

// Añadir la petición al grupo
eio_grp_add($grupo, $petición);

// Procesar las peticiones
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(7) "algunos"

Ver también

  • eio_grp_cancel() - Cancelar un grupo de peticiones
  • eio_grp_add() - Añadir una petición al grupo de peticiones


(Re-)inicializa Eio

  • « eio_grp
  • eio_link »
  • PHP Manual
  • Funciones Eio
  • (Re-)inicializa Eio

eio_init

(PECL eio = 1.0.0)

eio_init — (Re-)inicializa Eio

Descripción

eio_init ( ) : void

eio_init() (re-)inicializa Eio. Asigna memoria para estructuras internas de libeio y Eio. Se puede llamar a eio_init() antes de usar las funciones de Eio. De otro modo, será invocada internamente la primera vez que se invoque a una función de Eio en un proceso.

Advertencia

Esta característica obsoleta será eliminada con certeza en el futuro. Desde Eio 1.1.0, eio_init() está obsoleta. En Eio 1.0.0, debido a las » restricciones de libeio, se debe llamar a eio_init() en procesos hijos, si se enjendra uno por cualquier medio. Se debe evitar utilizar Eio en procesos padres, si se emplea en hijos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Crear un enlace duro par un fichero

  • « eio_init
  • eio_lstat »
  • PHP Manual
  • Funciones Eio
  • Crear un enlace duro par un fichero

eio_link

(PECL eio >= 0.0.1dev)

eio_link — Crear un enlace duro par un fichero

Descripción

eio_link ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_link() crea el enlace duro dado por new_path para un fichero especificado por path.

Parámetros

path

La ruta del fichero origen.

new_path

La ruta del fichero destino.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de eio_link()

<?php
$nombre_fichero = dirname(__FILE__)."/symlink.dat";
touch($nombre_fichero);
$enlace = dirname(__FILE__)."/symlink.link";
$enlace_duro = dirname(__FILE__)."/hardlink.link";

function mi_llamada_retorno_hardlink($datos, $resultado) {
    global $enlace, $nombre_fichero;
    var_dump(file_exists($datos) && !is_link($datos));
    @unlink($datos);

    eio_symlink($nombre_fichero, $enlace, EIO_PRI_DEFAULT, "mi_llamada_retorno_symlink", $enlace);
}

function mi_llamada_retorno_symlink($datos, $resultado) {
    global $enlace, $nombre_fichero;
    var_dump(file_exists($data) && is_link($datos));

    if (!eio_readlink($datos, EIO_PRI_DEFAULT, "mi_llamada_retorno_readlink", NULL)) {
        @unlink($enlace);
        @unlink($nombre_fichero);
    }
}

function mi_llamada_retorno_readlink($datos, $resultado) {
    global $nombre_fichero, $enlace;
    var_dump($resultado);

    @unlink($enlace);
    @unlink($nombre_fichero);
}

eio_link($nombre_fichero, $enlace_duro, EIO_PRI_DEFAULT, "mi_llamada_retorno_hardlink", $enlace_duro);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
string(%d) "%ssymlink.dat"

Ver también

  • eio_symlink() - Crear un enlace simbólico


Obtener el estado de un fichero

  • « eio_link
  • eio_mkdir »
  • PHP Manual
  • Funciones Eio
  • Obtener el estado de un fichero

eio_lstat

(PECL eio >= 0.0.1dev)

eio_lstat — Obtener el estado de un fichero

Descripción

eio_lstat ( string $path , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_lstat() devuelve la información del estado de un fichero en el argumento result de callback

Parámetros

path

La ruta de archivo

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_lstat() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_lstat()

<?php
$nombre_fichero_temp = dirname(__FILE__). "/fichero-eio.tmp";
touch($nombre_fichero_temp);

function my_res_cb($datos, $resultado) {
    var_dump($datos);
    var_dump($resultado);
}

function my_open_cb($datos, $resultado) {
    eio_close($resultado);
    eio_event_loop();

    @unlink($datos);
}

eio_lstat($nombre_fichero_temp, EIO_PRI_DEFAULT, "my_res_cb", "eio_lstat");
eio_open($nombre_fichero_temp, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(9) "eio_lstat"
array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2099197)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318235777)
  ["st_mtime"]=>
  int(1318235777)
  ["st_ctime"]=>
  int(1318235777)
}

Ver también

  • eio_stat() - Obtener el estado de un fichero
  • eio_fstat() - Obtener el estado de un fichero


Crear un directorio

  • « eio_lstat
  • eio_mknod »
  • PHP Manual
  • Funciones Eio
  • Crear un directorio

eio_mkdir

(PECL eio >= 0.0.1dev)

eio_mkdir — Crear un directorio

Descripción

eio_mkdir ( string $path , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_mkdir() crea un directorio con el acceso especificado por mode.

Parámetros

path

La ruta del nuevo directorio.

mode

Modo de acceso, p.ej. 0755

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_mkdir() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_mkdir()

<?php
$nombre_directorio_temp = "dir-tmp-eio";

/* Es llamada cuando eio_mkdir() finaliza */
function mi_llamada_retorno_mkdir($datos, $resultado) {
 if ($resultado == 0 && is_dir($nombre_directorio_temp)
   && !is_readable($nombre_directorio_temp)
   && is_writable($nombre_directorio_temp)) {
  echo "eio_mkdir_ok";
 }

 // Eliminar el directorio
    if (file_exists($datos))
        rmdir($nombre_directorio_temp);
}

// Crear un directorio con modo de acceso 0300
eio_mkdir($nombre_directorio_temp, 0300, EIO_PRI_DEFAULT, "mi_llamada_retorno_mkdir", $nombre_directorio_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

eio_mkdir_ok

Ver también

  • eio_rmdir() - Eliminar un directorio


Crear un fichero especial u ordinario

  • « eio_mkdir
  • eio_nop »
  • PHP Manual
  • Funciones Eio
  • Crear un fichero especial u ordinario

eio_mknod

(PECL eio >= 0.0.1dev)

eio_mknod — Crear un fichero especial u ordinario

Descripción

eio_mknod ( string $path , int $mode , int $dev , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_mknod() crea un fichero ordinario o especial (a menudo).

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

path

Ruta del nuevo nodo (fichero).

mode

Especifica tanto los permisos a usar como el tipo de nodo a ser creado. Debería ser una combinación (usando el operador OR) de uno de los tipos de fichero listados abajo y los permisos para el nuevo nodo (p.ej. 0640). Los tipos de ficheros posibles son: EIO_S_IFREG (fichero regular), EIO_S_IFCHR (fichero de carácter), EIO_S_IFBLK (fichero especial de bloqueo), EIO_S_IFIFO (FIFO - tubería nominada) y EIO_S_IFSOCK (socket de dominio UNIX). Para especificar permisos se podrían usar constantes EIO_S_I*.

dev

Si el tipo de fichero es EIO_S_IFCHR o EIO_S_IFBLK, dev especifica el número mayor y menor del recién creado fichero especial de dispositivo. De otro modo dev es ignorado. Véase la página del manual mknod(2) para más detalles.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_mknod() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_mknod()

<?php
// Nombre FIFO
$nombre_fichero_temp = "/tmp/eio-temp-fifo";

/* Se llama cuando eio_mknod() finaliza */
function mi_llamada_retorno_mknod($datos, $resultado) {
    $s = stat($datos);
    var_dump($s);

    if ($resultado == 0) {
        echo "eio_mknod_ok";
    }

    @unlink($datos);
}

eio_mknod($nombre_fichero_temp, EIO_S_IFIFO, 0,
    EIO_PRI_DEFAULT, "mi_llamada_retorno_mknod", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

array(26) {
  [0]=>
  int(17)
  [1]=>
  int(2337608)
  [2]=>
  int(4096)
  [3]=>
  int(1)
  [4]=>
  int(1000)
  [5]=>
  int(100)
  [6]=>
  int(0)
  [7]=>
  int(0)
  [8]=>
  int(1318241261)
  [9]=>
  int(1318241261)
  [10]=>
  int(1318241261)
  [11]=>
  int(4096)
  [12]=>
  int(0)
  ["dev"]=>
  int(17)
  ["ino"]=>
  int(2337608)
  ["mode"]=>
  int(4096)
  ["nlink"]=>
  int(1)
  ["uid"]=>
  int(1000)
  ["gid"]=>
  int(100)
  ["rdev"]=>
  int(0)
  ["size"]=>
  int(0)
  ["atime"]=>
  int(1318241261)
  ["mtime"]=>
  int(1318241261)
  ["ctime"]=>
  int(1318241261)
  ["blksize"]=>
  int(4096)
  ["blocks"]=>
  int(0)
}
eio_mknod_ok

Ver también

  • eio_open() - Abrir un fichero


No hace nada, sólo recorre el ciclo de peticiones entero

  • « eio_mknod
  • eio_npending »
  • PHP Manual
  • Funciones Eio
  • No hace nada, sólo recorre el ciclo de peticiones entero

eio_nop

(PECL eio >= 0.0.1dev)

eio_nop — No hace nada, sólo recorre el ciclo de peticiones entero

Descripción

eio_nop ( int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_nop() no hace nada, sólo recorre el ciclo de peticiones entero. Podría ser util al depurar.

Parámetros

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_nop() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_busy() - Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas


Devolver el número de peticiones, excepto las no manejadas

  • « eio_nop
  • eio_nready »
  • PHP Manual
  • Funciones Eio
  • Devolver el número de peticiones, excepto las no manejadas

eio_npending

(PECL eio >= 0.0.1dev)

eio_npending — Devolver el número de peticiones, excepto las no manejadas

Descripción

eio_npending ( ) : int

eio_npending() devuelve el número de peticiones, excepto las no manejadas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_npending() devuelve el número de peticiones, excepto las no manejadas.

Ver también

  • eio_nreqs() - Devuelve el número de peticiones a ser procesadas
  • eio_nready() - Devolver el número de peticiones aún no tratadas
  • eio_nthreads() - Devuelve el número de hilos actualmente en uso


Devolver el número de peticiones aún no tratadas

  • « eio_npending
  • eio_nreqs »
  • PHP Manual
  • Funciones Eio
  • Devolver el número de peticiones aún no tratadas

eio_nready

(PECL eio >= 0.0.1dev)

eio_nready — Devolver el número de peticiones aún no tratadas

Descripción

eio_nready ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_nready() devuelve el número de peticiones aún no tratadas

Ver también

  • eio_nreqs() - Devuelve el número de peticiones a ser procesadas
  • eio_nready()
  • eio_nthreads() - Devuelve el número de hilos actualmente en uso


Devuelve el número de peticiones a ser procesadas

  • « eio_nready
  • eio_nthreads »
  • PHP Manual
  • Funciones Eio
  • Devuelve el número de peticiones a ser procesadas

eio_nreqs

(PECL eio >= 0.0.1dev)

eio_nreqs — Devuelve el número de peticiones a ser procesadas

Descripción

eio_nreqs ( ) : int

eio_nreqs() se podría llamar en un bucle personalizado al llamar a eio_poll().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_nreqs() devuelve el número de peticiones a ser procesadas.

Ejemplos

Ejemplo #1 Ejepmlo de eio_nreqs()

<?php
function res_cb($datos, $resultado) {
    var_dump($datos);
    var_dump($resultado);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    eio_poll();
}
?>

El resultado del ejemplo sería algo similar a:

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

Ver también

  • eio_poll() - Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas
  • eio_nready() - Devolver el número de peticiones aún no tratadas


Devuelve el número de hilos actualmente en uso

  • « eio_nreqs
  • eio_open »
  • PHP Manual
  • Funciones Eio
  • Devuelve el número de hilos actualmente en uso

eio_nthreads

(PECL eio >= 0.0.1dev)

eio_nthreads — Devuelve el número de hilos actualmente en uso

Descripción

eio_nthreads ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_nthreads() devuelve el número de hilos actualmente en uso.

Ver también

  • eio_npending() - Devolver el número de peticiones, excepto las no manejadas
  • eio_nready() - Devolver el número de peticiones aún no tratadas
  • eio_nreqs() - Devuelve el número de peticiones a ser procesadas
  • eio_set_max_idle() - Establecer el número máximo de hilos parados
  • eio_set_max_parallel() - Esteblecer el máximo de hilos paralelos
  • eio_set_min_parallel() - Esteblecer el número de hilos paralelos mínimo


Abrir un fichero

  • « eio_nthreads
  • eio_poll »
  • PHP Manual
  • Funciones Eio
  • Abrir un fichero

eio_open

(PECL eio >= 0.0.1dev)

eio_open — Abrir un fichero

Descripción

eio_open ( string $path , int $flags , int $mode , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_open() abre el archivo especificado por path en el modo de acceso mode con

Parámetros

path

Ruta del archivo a abrir.

Advertencia

En algunas SAPIs (p.ej. PHP-FPM) podría fallar si no se especifica la ruta completa.

flags

Una de las constantes EIO_O_*, o sus combinaciones. Las constantes EIO_O_* tienen el mismo significado que sus correspondientes homónimas O_* definidas en el fichero de cabecera C fnctl.h. Por defecto es EIO_O_RDWR.

mode

Una de las constantes EIO_S_I*, o sus combinaciones (mediante el operador a nivel de bits OR). Las constantes tienen el mismo significado que sus homónimas S_I* definidas en el archivo de cabecera C » sys/stat.h. Necesario si se crea un fichero. En otro caso es ignorado.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_open() devuelve un descriptor de fichero en el argumento result de callback en caso de éxito; de otro modo, result es igual a -1.

Ejemplos

Ejemplo #1 Ejemplo de eio_open()

<?php
$nombre_fichero_temp = "eio-fichero-temp.tmp";

/* Se llama cuando eio_close() finaliza */
function my_close_cb($datos, $resultado) {
 // Cero indica éxito
    var_dump($resultado == 0);
 @unlink($datos);
}

/* Se llama cuando eio_open() finaliza */
function mi_llamada_retorno_fichero_abierto($datos, $resultado) {
 // $resultado debería contener el descriptor de fichero
    var_dump($resultado > 0);

    if ($resultado > 0) {
  // Cerrar el fichero
        eio_close($resultado, EIO_PRI_DEFAULT, "my_close_cb", $datos);
        eio_event_loop();
    }
}

// Crear un nuevo fichero para lectura y escritura
// Denegar al grupo y a otros realizar cualquier cosa con ese fichero
eio_open($nombre_fichero_temp, EIO_O_CREAT | EIO_O_RDWR, EIO_S_IRUSR | EIO_S_IWUSR,
  EIO_PRI_DEFAULT, "mi_llamada_retorno_fichero_abierto", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)

Ver también

  • eio_mknod() - Crear un fichero especial u ordinario


Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas

  • « eio_open
  • eio_read »
  • PHP Manual
  • Funciones Eio
  • Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas

eio_poll

(PECL eio >= 0.0.1dev)

eio_poll — Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas

Descripción

eio_poll ( ) : int

eio_poll() se puede usar para implementar un bucle de eventos especial. Para esto, podria usarse eio_nreqs() para comprobar si existen peticiones no procesadas.

Nota:

Aplicable solamente al implementar bucles de eventos del espacio de usuario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Si cualquier invocación a una petición devuelve un valor distinto de cero, devuelve ese valor. De otro modo devuelve 0.

Ejemplos

Ejemplo #1 Ejemplo de eio_poll()

<?php
function res_cb($datos, $resultado) {
    var_dump($datos);
    var_dump($resultado);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    // Algún IPC específico más o menos
    eio_poll();
}
?>

El resultado del ejemplo sería algo similar a:

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

Ver también

  • eio_nreqs() - Devuelve el número de peticiones a ser procesadas


Leer de un descriptor de fichero en un índice dado

  • « eio_poll
  • eio_readahead »
  • PHP Manual
  • Funciones Eio
  • Leer de un descriptor de fichero en un índice dado

eio_read

(PECL eio >= 0.0.1dev)

eio_read — Leer de un descriptor de fichero en un índice dado

Descripción

eio_read ( mixed $fd , int $length , int $offset , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_read() lee hasta length bytes desde el descriptor de fichero fd empezando en offset. Los bytes leídos son almacenados en el argumento result de callback.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

length

El número máximo de bytes a leer.

offset

El índice dentro del fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_read() almacena los bytes leídos en el argumento result de la función callback.

Ejemplos

Ejemplo #1 Ejemplo de eio_read()

<?php
// Abrir un fichero temporal y escribir algunos bytes en él
$nombre_fichero_temp = "eio-temp-file.tmp";
$fp = fopen($nombre_fichero_temp, "w");
fwrite($fp, "1234567890");
fclose($fp);

/* Es llamada cuando eio_read() termina */
function mi_llamada_retorno_read($datos, $resultado) {
    global $nombre_fichero_temp;

 // Imprimir los bytes leídos
    var_dump($resultado);

 // Cerrar el fichero
    eio_close($datos);
    eio_event_loop();

 // Eliminar el fichero temporal
    @unlink($nombre_fichero_temp);
}

/* Es llamada cuanco eio_open() termina */
function mi_llamada_retorno_fichero abierto($datos, $resultado) {
 // $resultado debería contener el descriptor del fichero
    if ($resultado > 0) {
  // Leer 5 bytes empezando desde el tercero
        eio_read($resultado, 5, 2, EIO_PRI_DEFAULT, "mi_llamada_retorno_read", $resultado);
        eio_event_loop();
    } else {
  // eio_open() falló
        unlink($datos);
    }
}

// Abrir el fichero para leer y escribir
eio_open($nombre_fichero_temp, EIO_O_RDWR, NULL,
    EIO_PRI_DEFAULT, "mi_llamada_retorno_fichero abierto", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(5) "34567"

Ver también

  • eio_open() - Abrir un fichero
  • eio_write() - Escribir en un fichero
  • eio_close() - Cerrar un fichero
  • eio_event_loop() - Monitorizar libeio hasta que todas las peticiones sean procesadas


Perform file readahead into page cache

  • « eio_read
  • eio_readdir »
  • PHP Manual
  • Funciones Eio
  • Perform file readahead into page cache

eio_readahead

(PECL eio >= 0.0.1dev)

eio_readahead — Perform file readahead into page cache

Descripción

eio_readahead ( mixed $fd , int $offset , int $length , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_readahead() rellena la caché de página con información de un fichero, por lo que lecturas posteriores de ese fichero no bloquearán la E/S del disco. Véase la página del manual READAHEAD(2) para más detalles.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero.

offset

El punto de inicio desde el cual se va a leer la información.

length

El número de bytes a leer.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_readahead() devuelve un recurso de petición en caso de éxito o false en caso de error.


Leer un directorio al completo

  • « eio_readahead
  • eio_readlink »
  • PHP Manual
  • Funciones Eio
  • Leer un directorio al completo

eio_readdir

(PECL eio >= 0.0.1dev)

eio_readdir — Leer un directorio al completo

Descripción

eio_readdir ( string $path , int $flags , int $pri , callable $callback , string $data = NULL ) : resource

Leer un directorio al completo (mediante las llamadas al sistema de opendir, readdir y closedir) y devuelve o los nombres o un array en el argumento result de la función callback, dependiendo del argumento flags.

Parámetros

path

La ruta del directorio.

flags

Una combinación de constantes EIO_READDIR_*.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_readdir() devuelve un recurso de petición en caso de éxito, o false en caso de error. Establece el argumento result de la función callback function según el parámetro flags:

EIO_READDIR_DENTS (integer)
Bandera eio_readdir(). Si se especifica, el argumento resultante de la llamada de retorno se convierte en un array con las siguientes claves: 'names' - array de nombres de directorios 'dents' - array de structura eio_dirent-como los arrays pero teniendo las siguientes claves: 'name' - el nombre del directorio; 'type' - una de las constantes EIO_DT_*; 'inode' - el número de inodo, si está disponible, de otro modo sin especificar;
EIO_READDIR_DIRS_FIRST (integer)
Cuando se especifica esta bandera, los nombres serán devueltos en un orden donde probablemente los directorios vallan primero, en un orden de estadísticas óptimo.
EIO_READDIR_STAT_ORDER (integer)
Cuando se especifica esta bandera, los nombres serán devueltos en un orden apropiado para realizar estadísticas (stat) con cada uno. Cuando se planea usar la función stat() para realizar estadísticas de todos los archivos del directorio dado, el orden devuelto probablemente sea más rápido.
EIO_READDIR_FOUND_UNKNOWN (integer)

Tipos de nodos:

EIO_DT_UNKNOWN (integer)
Tipo de nodo desconocido(muy común). Se necistan más estadísticas (stat()).
EIO_DT_FIFO (integer)
Tipo de nodo FIFO
EIO_DT_CHR (integer)
Tipo de nodo
EIO_DT_MPC (integer)
Tipo de nodo de dispositivo de caracteres multiplexado (v7+coherent)
EIO_DT_DIR (integer)
Tipo de nodo de directorio
EIO_DT_NAM (integer)
Tipo de nodo de fichero Xenix nominado especial
EIO_DT_BLK (integer)
Tipo de nodo
EIO_DT_MPB (integer)
Dispositivo de bloqueo multiplexado (v7+coherent)
EIO_DT_REG (integer)
Tipo de nodo
EIO_DT_NWK (integer)
EIO_DT_CMP (integer)
Tipo de noto especial de red HP-UX
EIO_DT_LNK (integer)
Tipo de nodo de vínculo
EIO_DT_SOCK (integer)
Tipo de nodo socket
EIO_DT_DOOR (integer)
Tipo de nodo de puerta de Solaris
EIO_DT_WHT (integer)
Tipo de nodo
EIO_DT_MAX (integer)
Valor de tipo de nodo más alto

Ejemplos

Ejemplo #1 eio_readdir() example

<?php
/* Es llamada cuando eio_readdir() finaliza */
function mi_llamada_retorno_readdir($datos, $resultado) {
    echo __FUNCTION__, " llamada\n";
    echo "datos: "; var_dump($datos);
    echo "resultado: "; var_dump($resultado);
    echo "\n";
}

eio_readdir("/var/spool/news", EIO_READDIR_STAT_ORDER | EIO_READDIR_DIRS_FIRST,
  EIO_PRI_DEFAULT, "mi_llamada_retorno_readdir");
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

mi_llamada_retorno_readdir llamada
datos: NULL
resultado: array(2) {
 ["names"]=>
  array(7) {
   [0]=>
    string(7) "archive"
    [1]=>
    string(8) "articles"
    [2]=>
    string(8) "incoming"
    [3]=>
    string(7) "innfeed"
    [4]=>
    string(8) "outgoing"
    [5]=>
    string(8) "overview"
    [6]=>
    string(3) "tmp"
  }
 ["dents"]=>
  array(7) {
   [0]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "archive"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393265)
    }
   [1]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "articles"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393266)
    }
   [2]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "incoming"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393267)
    }
   [3]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "innfeed"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393269)
    }
   [4]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "outgoing"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393270)
    }
   [5]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "overview"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393271)
    }
   [6]=>
    array(3)
    {
     ["name"]=>
      string(3)
      "tmp"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393272)
    }
  }
}


Leer el valor de un enlace simbólico

  • « eio_readdir
  • eio_realpath »
  • PHP Manual
  • Funciones Eio
  • Leer el valor de un enlace simbólico

eio_readlink

(PECL eio >= 0.0.1dev)

eio_readlink — Leer el valor de un enlace simbólico

Descripción

eio_readlink ( string $path , int $pri , callable $callback , string $data = NULL ) : resource

Parámetros

path

La ruta del enlace simbólico fuente

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_readlink() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_readlink()

<?php
$nombre_fichero = dirname(__FILE__)."/symlink.dat";
touch($nombre_fichero);
$enlace = dirname(__FILE__)."/symlink.link";
$enlace_duro = dirname(__FILE__)."/hardlink.link";

function mi_llamada_retorno_hardlink($datos, $resultado) {
    global $enlace, $nombre_fichero;
    var_dump(file_exists($datos) && !is_link($datos));
    @unlink($datos);

    eio_symlink($nombre_fichero, $enlace, EIO_PRI_DEFAULT, "mi_llamada_retorno_symlink", $enlace);
}

function mi_llamada_retorno_symlink($datos, $resultado) {
    global $enlace, $nombre_fichero;
    var_dump(file_exists($datos) && is_link($datos));

    if (!eio_readlink($datos, EIO_PRI_DEFAULT, "mi_llamada_retorno_readlink", NULL)) {
        @unlink($enlace);
        @unlink($nombre_fichero);
    }
}

function mi_llamada_retorno_readlink($datos, $resultado) {
    global $nombre_fichero, $enlace;
    var_dump($resultado);

    @unlink($enlace);
    @unlink($nombre_fichero);
}

eio_link($nombre_fichero, $enlace_duro, EIO_PRI_DEFAULT, "mi_llamada_retorno_hardlink", $enlace_duro);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
string(16) "/tmp/symlink.dat"

Ver también

  • eio_symlink() - Crear un enlace simbólico


Obtener el nombre de ruta absoluto canonizado

  • « eio_readlink
  • eio_rename »
  • PHP Manual
  • Funciones Eio
  • Obtener el nombre de ruta absoluto canonizado

eio_realpath

(PECL eio >= 0.0.1dev)

eio_realpath — Obtener el nombre de ruta absoluto canonizado

Descripción

eio_realpath ( string $path , int $pri , callable $callback , string $data = NULL ) : resource

eio_realpath() devuelve el nombre de ruta absoluto canonizado en el argumento result de la función callback.

Parámetros

path

EL nombre abreviado

pri

callback

data

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo deeio_realpath()

<?php
var_dump(getcwd());

function mi_llamada_retorno_realpath($datos, $resultado) {
    var_dump($resultado);
}

eio_realpath("../", EIO_PRI_DEFAULT, "mi_llamada_retorno_realpath");
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(12) "/home/ruslan"
string(5) "/home"


Cambiar el nombre o la ubicación de un fichero

  • « eio_realpath
  • eio_rmdir »
  • PHP Manual
  • Funciones Eio
  • Cambiar el nombre o la ubicación de un fichero

eio_rename

(PECL eio >= 0.0.1dev)

eio_rename — Cambiar el nombre o la ubicación de un fichero

Descripción

eio_rename ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_rename() renombra o mueve un fichero a una nueva ubicación.

Parámetros

path

La ruta de origen

new_path

La ruta destino

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_rename() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_rename()

<?php
$nombre_fichero = dirname(__FILE__)."/fichero-eio-temp.dat";
touch($nombre_fichero);
$nuevo_nombre_fichero = dirname(__FILE__)."/nuevo-fichero-eio-temp.dat";

function mi_llamada_retorno_rename($datos, $resultado) {
    global $nombre_fichero, $nuevo_nombre_fichero;

    if ($resultado == 0 && !file_exists($nombre_fichero) && file_exists($nuevo_nombre_fichero)) {
        @unlink($nuevo_nombre_fichero);
        echo "eio_rename_ok";
    } else {
        @unlink($nombre_fichero);
    }
}

eio_rename($nombre_fichero, $nuevo_nombre_fichero, EIO_PRI_DEFAULT, "mi_llamada_retorno_rename", $nombre_fichero);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

eio_rename_ok


Eliminar un directorio

  • « eio_rename
  • eio_seek »
  • PHP Manual
  • Funciones Eio
  • Eliminar un directorio

eio_rmdir

(PECL eio >= 0.0.1dev)

eio_rmdir — Eliminar un directorio

Descripción

eio_rmdir ( string $path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_rmdir() elimina un directorio.

Parámetros

path

La ruta del directorio

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_rmdir() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de eio_rmdir()

<?php
$nombre_directorio_temp = "dir-tmp-eio";
mkdir($nombre_directorio_temp);

function mi_llamada_retorno_rmdir($datos, $resultado) {
    if ($resultado == 0 && !file_exists($datos)) {
        echo "eio_rmdir_ok";
    } else if (file_exists($datos)) {
        rmdir($datos);
    }
}

eio_rmdir($nombre_directorio_temp, EIO_PRI_DEFAULT, "mi_llamada_retorno_rmdir", $nombre_directorio_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

eio_rmdir_ok

Ver también

  • eio_mkdir() - Crear un directorio


Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence

  • « eio_rmdir
  • eio_sendfile »
  • PHP Manual
  • Funciones Eio
  • Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence

eio_seek

(PECL eio >= 0.5.0b)

eio_seek — Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence

Descripción

eio_seek ( mixed $fd , int $offset , int $whence , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_seek() reposiciona el índice del fichero abierto asociado con el flujo, el recurso Socket, o el descriptor de fichero especificado por fd al argumento offset según la directiva whence como sigue:

  • EIO_SEEK_SET - Establece la posición igual a offset bytes.
  • EIO_SEEK_CUR - Establece la posición a la ubicación actual más offset.
  • EIO_SEEK_END - Establece la posición al final del fichero más offset.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor de fichero numérico

offset

El punto de inicio desde donde van a leerse los datos.

length

El número de bytes a leer.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Una variable arbitraria pasada a callback.

Valores devueltos

eio_seek() devuelve el recurso solicitado en caso de éxito o false en case de error.


Transferir información entre descriptores de ficheros

  • « eio_seek
  • eio_set_max_idle »
  • PHP Manual
  • Funciones Eio
  • Transferir información entre descriptores de ficheros

eio_sendfile

(PECL eio >= 0.0.1dev)

eio_sendfile — Transferir información entre descriptores de ficheros

Descripción

eio_sendfile ( mixed $out_fd , mixed $in_fd , int $offset , int $length , int $pri = ? , callable $callback = ? , string $data = ? ) : resource

eio_sendfile() copia información entre un descriptor de fichero y otror. Véase la página del manual SENDFILE(2) para más detalles.

Parámetros

out_fd

Un flujo de salida, un recurso Socket, o un descriptor de fichero. Debería ser abierto para escritura.

in_fd

Un flujo de entrada, un recurso Socket, o un descriptor de fichero. Debería ser abierto para lectura.

offset

El índice dentro del fichero fuente.

length

El número de bytes a copiar.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_sendfile() devuelve un recurso de petición en caso de éxito o false en caso de error.


Establecer el número máximo de hilos parados

  • « eio_sendfile
  • eio_set_max_parallel »
  • PHP Manual
  • Funciones Eio
  • Establecer el número máximo de hilos parados

eio_set_max_idle

(PECL eio >= 0.0.1dev)

eio_set_max_idle — Establecer el número máximo de hilos parados

Descripción

eio_set_max_idle ( int $nthreads ) : void

Parámetros

nthreads

El número de hilo parados.

Valores devueltos

No devuelve ningún valor.

Ver también

  • eio_nthreads() - Devuelve el número de hilos actualmente en uso
  • eio_set_min_parallel() - Esteblecer el número de hilos paralelos mínimo
  • eio_set_max_parallel() - Esteblecer el máximo de hilos paralelos


Esteblecer el máximo de hilos paralelos

  • « eio_set_max_idle
  • eio_set_max_poll_reqs »
  • PHP Manual
  • Funciones Eio
  • Esteblecer el máximo de hilos paralelos

eio_set_max_parallel

(PECL eio >= 0.0.1dev)

eio_set_max_parallel — Esteblecer el máximo de hilos paralelos

Descripción

eio_set_max_parallel ( int $nthreads ) : void

Parámetros

nthreads

El número de hilos paralelos.

Valores devueltos

No devuelve ningún valor.

Ver también

  • eio_nthreads() - Devuelve el número de hilos actualmente en uso
  • eio_set_max_idle() - Establecer el número máximo de hilos parados
  • eio_set_min_parallel() - Esteblecer el número de hilos paralelos mínimo


Establecer el máximo número de peticiones procesadas en una monitorización

  • « eio_set_max_parallel
  • eio_set_max_poll_time »
  • PHP Manual
  • Funciones Eio
  • Establecer el máximo número de peticiones procesadas en una monitorización

eio_set_max_poll_reqs

(PECL eio >= 0.0.1dev)

eio_set_max_poll_reqs — Establecer el máximo número de peticiones procesadas en una monitorización

Descripción

eio_set_max_poll_reqs ( int $nreqs ) : void

Parámetros

nreqs

El número de peticiones

Valores devueltos

No devuelve ningún valor.


Establecer el tiempo máximo de monitorización

  • « eio_set_max_poll_reqs
  • eio_set_min_parallel »
  • PHP Manual
  • Funciones Eio
  • Establecer el tiempo máximo de monitorización

eio_set_max_poll_time

(PECL eio >= 0.0.1dev)

eio_set_max_poll_time — Establecer el tiempo máximo de monitorización

Descripción

eio_set_max_poll_time ( float $nseconds ) : void

La monitorización se detiene si toma más de nseconds segundos.

Parámetros

nseconds

El número de segundos

Valores devueltos

No devuelve ningún valor.


Esteblecer el número de hilos paralelos mínimo

  • « eio_set_max_poll_time
  • eio_stat »
  • PHP Manual
  • Funciones Eio
  • Esteblecer el número de hilos paralelos mínimo

eio_set_min_parallel

(PECL eio >= 0.0.1dev)

eio_set_min_parallel — Esteblecer el número de hilos paralelos mínimo

Descripción

eio_set_min_parallel ( string $nthreads ) : void

Parámetros

nthreads

El número de hilos paralelos.

Valores devueltos

No devuelve ningún valor.

Ver también

  • eio_nthreads() - Devuelve el número de hilos actualmente en uso
  • eio_set_max_idle() - Establecer el número máximo de hilos parados
  • eio_set_max_parallel() - Esteblecer el máximo de hilos paralelos


Obtener el estado de un fichero

  • « eio_set_min_parallel
  • eio_statvfs »
  • PHP Manual
  • Funciones Eio
  • Obtener el estado de un fichero

eio_stat

(PECL eio >= 0.0.1dev)

eio_stat — Obtener el estado de un fichero

Descripción

eio_stat ( string $path , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_stat() devuelve la información del estado de un fichero en el argumento result de callback

Parámetros

path

La ruta de archivo

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_stat()devuelve un recurso de petición en caso de éxito o false en caso de error. En caso de éxito asigna el argumento result de callback a un array.

Ejemplos

Ejemplo #1 Ejemplo de eio_stat()

<?php
$nombre_fichero_temp = "fichero-eio.tmp";
touch($nombre_fichero_temp);

function my_res_cb($datos, $resultado) {
    var_dump($datos);
    var_dump($resultado);
}

function my_open_cb($datos, $resultado) {
    eio_close($resultado);
    eio_event_loop();

    @unlink($datos);
}

eio_stat($nombre_fichero_temp, EIO_PRI_DEFAULT, "my_res_cb", "eio_stat");
eio_open($nombre_fichero_temp, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(8) "eio_stat"
array(12) {
  ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489173)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318250380)
  ["st_mtime"]=>
  int(1318250380)
  ["st_ctime"]=>
  int(1318250380)
}

Ver también

  • eio_lstat() - Obtener el estado de un fichero
  • eio_fstat() - Obtener el estado de un fichero


Obtener las estadísticas del sistema de ficheros

  • « eio_stat
  • eio_symlink »
  • PHP Manual
  • Funciones Eio
  • Obtener las estadísticas del sistema de ficheros

eio_statvfs

(PECL eio >= 0.0.1dev)

eio_statvfs — Obtener las estadísticas del sistema de ficheros

Descripción

eio_statvfs ( string $path , int $pri , callable $callback , mixed $data = ? ) : resource

eio_statvfs() devuelve la información de las estadísticas del sistema de ficheros en el argumento result de callback

Parámetros

path

El nombre de ruta de cualquier fichero dentro del sistema de ficheros montado

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_statvfs() devuelve un recurso de petición en caso de éxito o false en caso de error. En caso de éxito asigna el argumento result de callback a un array.

Ejemplos

Ejemplo #1 Ejemplo de eio_statvfs()

<?php
$nombre_fichero_temp = '/tmp/fichero-eio.tmp';
touch($nombre_fichero_temp);

function mi_llamada_retorno_statvfs($datos, $resultado) {
    var_dump($datos);
    var_dump($resultado);

 @unlink($datos);
}

eio_statvfs($nombre_fichero_temp, EIO_PRI_DEFAULT, "mi_llamada_retorno_statvfs", $nombre_fichero_temp);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

string(17) "/tmp/eio-file.tmp"
array(11) {
  ["f_bsize"]=>
  int(4096)
  ["f_frsize"]=>
  int(4096)
  ["f_blocks"]=>
  int(262144)
  ["f_bfree"]=>
  int(262111)
  ["f_bavail"]=>
  int(262111)
  ["f_files"]=>
  int(1540815)
  ["f_ffree"]=>
  int(1540743)
  ["f_favail"]=>
  int(1540743)
  ["f_fsid"]=>
  int(0)
  ["f_flag"]=>
  int(4102)
  ["f_namemax"]=>
  int(255)
}


Crear un enlace simbólico

  • « eio_statvfs
  • eio_sync_file_range »
  • PHP Manual
  • Funciones Eio
  • Crear un enlace simbólico

eio_symlink

(PECL eio >= 0.0.1dev)

eio_symlink — Crear un enlace simbólico

Descripción

eio_symlink ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_symlink() crea un enlace simbólico new_path hacia path.

Parámetros

path

La ruta fuente

new_path

La ruta destino

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_symlink() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 eio_symlink() example

<?php
$nombre_fichero = dirname(__FILE__)."/symlink.dat";
touch($nombre_fichero);
$enlace = dirname(__FILE__)."/symlink.link";

function mi_llamada_retorno_symlink($datos, $resultado) {
    global $enlace, $nombre_fichero;
    var_dump(file_exists($datos) && is_link($datos));

    if (!eio_readlink($datos, EIO_PRI_DEFAULT, "mi_llamada_retorno_readlink", NULL)) {
        @unlink($enlace);
        @unlink($nombre_fichero);
    }
}

function mi_llamada_retorno_readlink($datos, $resultado) {
    global $nombre_fichero, $enlace;
    var_dump($resultado);

    @unlink($enlace);
    @unlink($nombre_fichero);
}

eio_symlink($nombre_fichero, $enlace, EIO_PRI_DEFAULT, "mi_llamada_retorno_symlink", $enlace);
eio_event_loop();
?>

El resultado del ejemplo sería algo similar a:

bool(true)
string(16) "/tmp/symlink.dat"

Ver también

  • eio_link() - Crear un enlace duro par un fichero


Sincornizar un segmento de fichero con el disco

  • « eio_symlink
  • eio_sync »
  • PHP Manual
  • Funciones Eio
  • Sincornizar un segmento de fichero con el disco

eio_sync_file_range

(PECL eio >= 0.0.1dev)

eio_sync_file_range — Sincornizar un segmento de fichero con el disco

Descripción

eio_sync_file_range ( mixed $fd , int $offset , int $nbytes , int $flags , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_sync_file_range() permite un control preciso al sincronizar el fichero abierto mencionado por el descriptor de fichero fd con el disco.

Parámetros

fd

El descriptor de fichero

offset

El byte de inicio del rango del archivo a ser sincronizado

nbytes

Especifica la longitud del rango a ser sincronizado, en bytes. Si nbytes es cero, son sicronizados todos los bytes desde offset hasta el final del fichero.

flags

Una máscara de bits. Puede incluir cualquiera de los siguientes valores: EIO_SYNC_FILE_RANGE_WAIT_BEFORE, EIO_SYNC_FILE_RANGE_WRITE, EIO_SYNC_FILE_RANGE_WAIT_AFTER. Estas banderas tienen el mismo significado que sus homónimas SYNC_FILE_RANGE_* (véase la página del manual SYNC_FILE_RANGE(2)).

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_sync_file_range() devuelve un recurso de petición en caso de éxito o false en caso de error.


Consignar el caché de buffer cache al disco

  • « eio_sync_file_range
  • eio_syncfs »
  • PHP Manual
  • Funciones Eio
  • Consignar el caché de buffer cache al disco

eio_sync

(PECL eio >= 0.0.1dev)

eio_sync — Consignar el caché de buffer cache al disco

Descripción

eio_sync ( int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Parámetros

Esta función no tiene parámetros.

Valores devueltos

eio_sync() devuelve un recurso de petición en caso de éxito o false en caso de error.


Realizar una llamada al sistema de syncfs de Linux si está disponible

  • « eio_sync
  • eio_truncate »
  • PHP Manual
  • Funciones Eio
  • Realizar una llamada al sistema de syncfs de Linux si está disponible

eio_syncfs

(PECL eio >= 0.0.1dev)

eio_syncfs — Realizar una llamada al sistema de syncfs de Linux si está disponible

Descripción

eio_syncfs ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Parámetros

fd

Descriptor de fichero

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_syncfs() devuelve un recurso de petición en caso de éxito o false en caso de error.


Truncar un fichero

  • « eio_syncfs
  • eio_unlink »
  • PHP Manual
  • Funciones Eio
  • Truncar un fichero

eio_truncate

(PECL eio >= 0.0.1dev)

eio_truncate — Truncar un fichero

Descripción

eio_truncate ( string $path , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_truncate() hace que el fichero nominado por path sea truncado al tamaño de exactamente length bytes

Parámetros

path

Ruta del fichero.

offset

Índice desde el principio del fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_busy() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_ftruncate() - Truncar un fichero


Borrar un nombre y posiblemente el fichero al que se refiere

  • « eio_truncate
  • eio_utime »
  • PHP Manual
  • Funciones Eio
  • Borrar un nombre y posiblemente el fichero al que se refiere

eio_unlink

(PECL eio >= 0.0.1dev)

eio_unlink — Borrar un nombre y posiblemente el fichero al que se refiere

Descripción

eio_unlink ( string $path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_unlink() borra un nombre del sistema de ficheros.

Parámetros

path

Ruta del fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_unlink() devuelve un recurso de petición en caso de éxito o false en caso de error.


Cambiar los momentos de último y acceso y modificación de un fichero

  • « eio_unlink
  • eio_write »
  • PHP Manual
  • Funciones Eio
  • Cambiar los momentos de último y acceso y modificación de un fichero

eio_utime

(PECL eio >= 0.0.1dev)

eio_utime — Cambiar los momentos de último y acceso y modificación de un fichero

Descripción

eio_utime ( string $path , float $atime , float $mtime , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Parámetros

path

Ruta del fichero.

atime

Momento de acceso

mtime

Momento de modificación

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_utime() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_futime() - Cambiar los momentos de último y acceso y modificación de un fichero


Escribir en un fichero

  • « eio_utime
  • Ev »
  • PHP Manual
  • Funciones Eio
  • Escribir en un fichero

eio_write

(PECL eio >= 0.0.1dev)

eio_write — Escribir en un fichero

Descripción

eio_write ( mixed $fd , string $str , int $length = 0 , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_write() escribe hasta length bytes desde str en el índice offset desde el principo del fichero.

Parámetros

fd

Un flujo, un recurso Socket, o un descriptor numérico de fichero, p.ej., devuelto por eio_open().

str

La cadena fuente

length

Número máximo de bytes a escribir.

offset

ïndice desde el principio del fichero.

pri

La prioridad de petición: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, o null. Si se pasa null, pri es establecido internamente a EIO_PRI_DEFAULT.

callback

La función callback es llamada cuando la petición está hecha. Debería seguir el siguiente prototipo:

void callback(mixed $data, int $result[, resource $req]);
data

son datos personalizados pasados a la petición.

result

es el valor del resultado específico de la petición; básicamente, el valor devuelto por la correspondiente llamada al sistema.

req

es el recurso de petición opcional que puede usarse con funciones como eio_get_last_error()

data

Variable arbitraria pasada a callback.

Valores devueltos

eio_write() devuelve un recurso de petición en caso de éxito o false en caso de error.

Ver también

  • eio_open() - Abrir un fichero


Ev

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Watchers
  • Watcher callbacks
  • Periodic watcher operation modes
  • Ev — La clase Ev
    • Ev::backend — Devuelve un entero que describe el back-end utilizado por libev
    • Ev::depth — Devuelve la profundidad de la recursividad
    • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops
    • Ev::feedSignal — Feed a signal event info Ev
    • Ev::feedSignalEvent — Feed signal event into the default loop
    • Ev::iteration — Return the number of times the default event loop has polled for new events
    • Ev::now — Returns the time when the last iteration of the default event loop has started
    • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
    • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform
    • Ev::resume — Resume previously suspended default event loop
    • Ev::run — Begin checking for events and calling callbacks for the default loop
    • Ev::sleep — Block the process for the given number of seconds
    • Ev::stop — Stops the default event loop
    • Ev::supportedBackends — Returns the set of backends supported by current libev configuration
    • Ev::suspend — Suspend the default event loop
    • Ev::time — Returns the current time in fractional seconds since the epoch
    • Ev::verify — Performs internal consistency checks(for debugging)
  • EvCheck — The EvCheck class
    • EvCheck::__construct — Constructs the EvCheck watcher object
    • EvCheck::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild — The EvChild class
    • EvChild::__construct — Constructs the EvChild watcher object
    • EvChild::createStopped — Create instance of a stopped EvCheck watcher
    • EvChild::set — Configures the watcher
  • EvEmbed — The EvEmbed class
    • EvEmbed::__construct — Constructs the EvEmbed object
    • EvEmbed::createStopped — Create stopped EvEmbed watcher object
    • EvEmbed::set — Configures the watcher
    • EvEmbed::sweep — Realizar un único barrido sin bloqueos sobre el bucle embebido
  • EvFork — The EvFork class
    • EvFork::__construct — Constructs the EvFork watcher object
    • EvFork::createStopped — Creates a stopped instance of EvFork watcher class
  • EvIdle — The EvIdle class
    • EvIdle::__construct — Constructs the EvIdle watcher object
    • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object
  • EvIo — The EvIo class
    • EvIo::__construct — Constructs EvIo watcher object
    • EvIo::createStopped — Create stopped EvIo watcher object
    • EvIo::set — Configures the watcher
  • EvLoop — The EvLoop class
    • EvLoop::backend — Returns an integer describing the backend used by libev
    • EvLoop::check — Creates EvCheck object associated with the current event loop instance
    • EvLoop::child — Creates EvChild object associated with the current event loop
    • EvLoop::__construct — Constructs the event loop object
    • EvLoop::defaultLoop — Returns or creates the default event loop
    • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object
    • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
    • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork — Must be called after a fork
    • EvLoop::now — Returns the current "event loop time"
    • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
    • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume — Resume previously suspended default event loop
    • EvLoop::run — Begin checking for events and calling callbacks for the loop
    • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop — Stops the event loop
    • EvLoop::suspend — Suspend the loop
    • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify — Performs internal consistency checks(for debugging)
  • EvPeriodic — The EvPeriodic class
    • EvPeriodic::again — Simply stops and restarts the periodic watcher again
    • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::__construct — Constructs EvPeriodic watcher object
    • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
    • EvPeriodic::set — Configures the watcher
  • EvPrepare — The EvPrepare class
    • EvPrepare::__construct — Construye un objeto observador de EvPrepare
    • EvPrepare::createStopped — Crea una instancia detenida del watcher (testigo) EvPrepare
  • EvSignal — The EvSignal class
    • EvSignal::__construct — Construye el objeto observador EvSignal
    • EvSignal::createStopped — Create stopped EvSignal watcher object
    • EvSignal::set — Configura el testigo
  • EvStat — The EvStat class
    • EvStat::attr — Returns the values most recently detected by Ev
    • EvStat::__construct — Constructs EvStat watcher object
    • EvStat::createStopped — Create a stopped EvStat watcher object
    • EvStat::prev — Returns the previous set of values returned by EvStat::attr
    • EvStat::set — Configures the watcher
    • EvStat::stat — Initiates the stat call
  • EvTimer — The EvTimer class
    • EvTimer::again — Restarts the timer watcher
    • EvTimer::__construct — Constructs an EvTimer watcher object
    • EvTimer::createStopped — Creates EvTimer stopped watcher object
    • EvTimer::set — Configures the watcher
  • EvWatcher — The EvWatcher class
    • EvWatcher::clear — Clear watcher pending status
    • EvWatcher::__construct — Abstract constructor of a watcher object
    • EvWatcher::feed — Feeds the given revents set into the event loop
    • EvWatcher::getLoop — Returns the loop responsible for the watcher
    • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive — Configures whether to keep the loop from returning
    • EvWatcher::setCallback — Sets new callback for the watcher
    • EvWatcher::start — Starts the watcher
    • EvWatcher::stop — Stops the watcher


Introducción

Esta extensión proporciona una interfaz a la biblioteca » libev ; un bucle de eventos completísimo de alto rendimiento escrito en C.

Nota: Esta extensión no está disponible en plataformas Windows.

Libev es un bucle de eventos: se toma interés en ciertos eventos (como que un descriptor de fichero sea legible o que expire un tiempo de espera), y se administrarán estas fuentes de eventos y se proveerá al programa con eventos.

Para hacer esto, se debe tomar más o menos control completo sobre el proceso (o hilo) ejecutando el gestor de bucles de evetos, y luego comunicar los eventos mediante un mecanismo de llamada de retorno.

Se toma interés en ciertos eventos registrando los así llamados testigos de eventos, y luego entergarlos a libev iniciando el testigo.

Para más detalles consulte la » documentación de libev


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

La biblioteca libev está embebida en esta extensión. No es necesario instalarla por separado.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ev .


Constantes predefinidas

Esta extensión no tiene ninguna constante definida.

La mayoría de las constantes se trasladaron a la clase singleton Ev.


Ejemplos

Ejemplo #1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

El resultado del ejemplo sería algo similar a:

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

Ejemplo #2 Periodic timer. Tick each 10.5 seconds

<?php
$w = new EvPeriodic(0., 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Ejemplo #3 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
    return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Ejemplo #4 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Ejemplo #5 Wait until STDIN is readable

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
    echo "STDIN is readable\n";
});

Ev::run(Ev::RUN_ONCE);
?>

Ejemplo #6 Use some async I/O to access a socket

<?php
/* Use some async I/O to access a socket */

// `sockets' extension still logs warnings
// for EINPROGRESS, EAGAIN/EWOULDBLOCK etc.
error_reporting(E_ERROR);

$e_nonblocking = array (/*EAGAIN or EWOULDBLOCK*/11, /*EINPROGRESS*/115);

// Get the port for the WWW service
$service_port = getservbyname('www', 'tcp');

// Get the IP address for the target host
$address = gethostbyname('google.co.uk');

// Create a TCP/IP socket
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === FALSE) {
    echo "socket_create() failed: reason: "
        .socket_strerror(socket_last_error()) . "\n";
}

// Set O_NONBLOCK flag
socket_set_nonblock($socket);

// Abort on timeout
$timeout_watcher = new EvTimer(10.0, 0., function () use ($socket) {
    socket_close($socket);
    Ev::stop(Ev::BREAK_ALL);
});

// Make HEAD request when the socket is writable
$write_watcher = new EvIo($socket, Ev::WRITE, function ($w)
    use ($socket, $timeout_watcher, $e_nonblocking)
{
    // Stop timeout watcher
    $timeout_watcher->stop();
    // Stop write watcher
    $w->stop();

    $in = "HEAD / HTTP/1.1\r\n";
    $in .= "Host: google.co.uk\r\n";
    $in .= "Connection: Close\r\n\r\n";

    if (!socket_write($socket, $in, strlen($in))) {
        trigger_error("Failed writing $in to socket", E_USER_ERROR);
    }

    $read_watcher = new EvIo($socket, Ev::READ, function ($w, $re)
        use ($socket, $e_nonblocking)
    {
        // Socket is readable. recv() 20 bytes using non-blocking mode
        $ret = socket_recv($socket, $out, 20, MSG_DONTWAIT);

        if ($ret) {
            echo $out;
        } elseif ($ret === 0) {
            // All read
            $w->stop();
            socket_close($socket);
            return;
        }

        // Caught EINPROGRESS, EAGAIN, or EWOULDBLOCK
        if (in_array(socket_last_error(), $e_nonblocking)) {
            return;
        }

        $w->stop();
        socket_close($socket);
    });

    Ev::run();
});

$result = socket_connect($socket, $address, $service_port);

Ev::run();
?>

El resultado del ejemplo sería algo similar a:

HTTP/1.1 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1252
Date: Sun, 23 Dec 2012 16:08:27 GMT
Expires: Tue, 22 Jan 2013 16:08:27 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Connection: close

Ejemplo #7 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
    ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
    : 0;

if ($loop_lo) {
    $embed = new EvEmbed($loop_lo, function () {});
} else {
    $loop_lo = $loop_hi;
}
?>

Ejemplo #8 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ejemplo #9 Handle SIGTERM signal

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM received\n";
    $watcher->stop();
});

Ev::run();
?>

Ejemplo #10 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

Ejemplo #11 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

Ejemplo #12 Process status changes

<?php
$pid = pcntl_fork();

if ($pid == -1) {
    fprintf(STDERR, "pcntl_fork failed\n");
} elseif ($pid) {
    $w = new EvChild($pid, FALSE, function ($w, $revents) {
        $w->stop();

        printf("Process %d exited with status %d\n", $w->rpid, $w->rstatus);
    });

    Ev::run();

    // Protect against Zombies
    pcntl_wait($status);
} else {
    //Forked child
    exit(2);
}
?>


Watchers

A watcher is an object that gets created to record interest in some event. For instance, the following code waits for STDIN to become readable:

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
 echo "STDIN is readable\n";
});
Ev::run(Ev::RUN_ONCE);
?>

All the watcher constructors automatically start the watchers. createStopped methods create stopped watchers(e.g. EvIo::createStopped() )

Note that a watcher will automatically be stopped when the watcher object is destroyed. Therefore, the watcher objects returned by the constructors or factory methods should be kept.

Note also that all methods changing some watcher property( set , priority etc.) automatically stop and start it again if it is active, which means pending events get lost.

See also: Watcher callbacks .


Watcher callbacks

All watchers can be active(waiting for events) or inactive(paused). Only active watchers will have their callbacks invoked. All callbacks will be called with at least two arguments: watcher - the watcher, and revents a bitmask of received events.

Watcher callbacks are passed to the watcher constructors (the classes derived from EvWatcher - EvCheck::__construct() , EvChild::__construct() etc.). A watcher callback should match the following prototype:

callback ( object $watcher = NULL , int $revents = NULL ) : void

watcher

The watcher instance(of a class extending EvWatcher ).

revents

Watcher received events .

Each watcher type has its associated bit in revents , so one can use the same callback for multiple watchers. The event mask is named after the type, i.e. EvChild (or EvLoop::child() ) sets EV::CHILD , EvPrepare (or EvLoop::prepare() ) sets Ev::PREPARE , EvPeriodic (or EvLoop::periodic() ) sets Ev::PERIODIC and so on, with the exception of I/O events (which can set both Ev::READ and Ev::WRITE bits).


Periodic watcher operation modes

EvPeriodic watcher works in different modes depending on the offset , interval and reschedule_cb parameters.

  1. Absolute timer . In this mode interval = 0 , reschedule_cb = null. This time simply fires at the wallclock time offset and doesn't repeat. It will not adjust when a time jump occurs, that is, if it is to be run at January 1st 2014 then it will run when the system time reaches or surpasses this time.

  2. Repeating interval timer . In this mode interval > 0 , reschedule_cb = null; the watcher will always be scheduled to timeout at the next offset + N * interval time(for some integer N ) and then repeat, regardless of any time jumps.

    This can be used to create timers that do not drift with respect to system time:

    <?php
    $hourly     = EvPeriodic(0, 3600, NULL, function () {
      echo     "once per hour\n";
    });
    ?>
    That doesn't mean there will always be 3600 seconds in between triggers, but only that the callback will be called when the system time shows a full hour( UTC ).

    EvPeriodic will try to run the callback in this mode at the next possible time where time = offset ( mod interval ), regardless of any time jumps.

  3. Manual reschedule mode . In this mode reschedule_cb is a callable .

    interval and offset are both being ignored. Instead, each time the periodic watcher gets scheduled, the reschedule callback ( reschedule_cb ) will be called with the watcher as first, and the current time as second argument.

    This callback must not stop or destroy this or any other periodic watchers, ever, and must not call any event loop functions or methods. To stop it return 1e30 and stop it afterwards. An EvPrepare watcher may be used for this task.

    It must return the next time to trigger, based on the passed time value (that is, the lowest time value larger than or equal to the second argument). It will usually be called just before the callback will be triggered, but might be called at other times, too.

    Ejemplo #1 Using reschedule callback

    <?php
    // Tick each 10.5 seconds

    function reschedule_cb ($watcher, $now) {
       return     $now + (10.5. - fmod($now, 10.5));
    }

    $w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
       echo     time(), PHP_EOL;
    });

    Ev::run();
    ?>


La clase Ev

(PECL ev >= 0.2.0)

Introducción

Ev es una clase estática que proporciona acceso al bucle por omsión y a algunas operaciones comunes.

Sinopsis de la Clase

final Ev {
/* Constantes */
const integer FLAG_AUTO = 0 ;
const integer FLAG_NOENV = 16777216 ;
const integer FLAG_FORKCHECK = 33554432 ;
const integer FLAG_NOINOTIFY = 1048576 ;
const integer FLAG_SIGNALFD = 2097152 ;
const integer FLAG_NOSIGMASK = 4194304 ;
const integer RUN_NOWAIT = 1 ;
const integer RUN_ONCE = 2 ;
const integer BREAK_CANCEL = 0 ;
const integer BREAK_ONE = 1 ;
const integer BREAK_ALL = 2 ;
const integer MINPRI = -2 ;
const integer MAXPRI = 2 ;
const integer READ = 1 ;
const integer WRITE = 2 ;
const integer TIMER = 256 ;
const integer PERIODIC = 512 ;
const integer SIGNAL = 1024 ;
const integer CHILD = 2048 ;
const integer STAT = 4096 ;
const integer IDLE = 8192 ;
const integer PREPARE = 16384 ;
const integer CHECK = 32768 ;
const integer EMBED = 65536 ;
const integer CUSTOM = 16777216 ;
const integer ERROR = 2147483648 ;
const integer BACKEND_SELECT = 1 ;
const integer BACKEND_POLL = 2 ;
const integer BACKEND_EPOLL = 4 ;
const integer BACKEND_KQUEUE = 8 ;
const integer BACKEND_DEVPOLL = 16 ;
const integer BACKEND_PORT = 32 ;
const integer BACKEND_ALL = 63 ;
const integer BACKEND_MASK = 65535 ;
/* Métodos */
final public static backend ( ) : int
final public static depth ( ) : int
final public static embeddableBackends ( ) : int
final public static feedSignal ( int $signum ) : void
final public static feedSignalEvent ( int $signum ) : void
final public static iteration ( ) : int
final public static now ( ) : float
final public static nowUpdate ( ) : void
final public static recommendedBackends ( ) : int
final public static resume ( ) : void
final public static run ( int $flags = ? ) : void
final public static sleep ( float $seconds ) : void
final public static stop ( int $how = ? ) : void
final public static supportedBackends ( ) : int
final public static suspend ( ) : void
final public static time ( ) : float
final public static verify ( ) : void
}

Constantes predefinidas

Flags disponibles para crear un bucle:

Ev::FLAG_AUTO

El valor del flag por defecto

Ev::FLAG_NOENV

Si este flag es utilizado (o el programa corre setuid o setgid), libev no tendrá en cuenta la variable de entorno LIBEV_FLAGS . De otro modo (por defecto), LIBEV_FLAGS reemplazará los flags completamente si es definido. Útil para evaluación de performance y para encontrar errores.

Ev::FLAG_FORKCHECK

Permite que libev verifique un fork en cada iteración, en lugar de llamar a EvLoop::fork() manualmente. Esto funciona al llamar a getpid() en cada iteración del bucle, y como tal podrá alentizar el bucle de eventos con numerosas iteraciones, aunque esto no es usualmente notorio. Este flag no puede ser reemplazado o especificado mediante la variable de entorno LIBEV_FLAGS.

Ev::FLAG_NOINOTIFY

Cuando este flag es especificado, libev no intentará utilizar la API inotify para sus watchers » ev_stat. El flag puede ser útil para conservar los descriptores de archivo inotify, ya que de otro modo cada bucle que utilice watchers ev_stat consumen un handle inotify.

Ev::FLAG_SIGNALFD

Cuando este flag es especificado, libev intentará utilizar la API signalfd para sus watchers » ev_signal (y » ev_child ). Esta API entrega las señales sincrónicamente, lo que la hace más rápida y puede permitir obtener los datos de señal encolados. También puede simplificar el manejo de señales mediante hilos, siempre y cuando las señales sean bloqueadas apropiadamente en los hilos. Signalfd no será utilizado por defecto.

Ev::FLAG_NOSIGMASK

Cuando este flag es especificado, libev hará imposible la modificación de la máscara de señal. Esto significa que será necesario asegurarse que las señales están desbloqueadas antes de recibirlas.

Este comportamiento es útil para el manejo de señales personalizado, o para manipular señales solamente en hilos específicos.

Flags disponibles para Ev::run() , o EvLoop::run()

Ev::RUN_NOWAIT

Significa que el bucle de eventos buscará nuevos eventos, y manejará aquellos eventos y cualquier otro evento pendiente, pero no esperará ni bloqueará el proceso en caso de que no haya eventos, retornando luego de una iteración del bucle. Esto es útil para obtener nuevos eventos mientras se realizan cálculos costosos, manteniendo el programa funcionando.

Ev::RUN_ONCE

Significa que el bucle de eventos buscará nuevos eventos (esperando si es necesario) y manejará aquellos eventos, y cualquier otro evento pendiente. Bloqueará el proceso hasta que al menos un evento esté disponible (que podría ser un evento interno a libev, por lo que no hay garantía de que un callback registrado por el usuario sea llamado), y retornará luego de una iteración del bucle.

Flags disponibles para Ev::stop() , o EvLoop::stop()

Ev::BREAK_CANCEL

Cancelar la operación break.

Ev::BREAK_ONE

Hace que la llamada interior Ev::run() (o EvLoop::run() ) retorne.

Ev::BREAK_ALL

Hace que todas las llamadas Ev::run() (o EvLoop::run() ) retornen.

Prioridades Watcher:

Ev::MINPRI

Prioridad mínima disponible.

Ev::MAXPRI

Prioridad máxima disponible.

Máscaras de Bit de los eventos (recibidos):

Ev::READ

El descriptor de archivo en el watcher EvIo se ha vuelto disponible.

Ev::WRITE

El descriptor de archivo en el watcher EvIo se ha vuelto modificable.

Ev::TIMER

El watcher EvTimer ha agotado su tiempo.

Ev::PERIODIC

El watcher EvPeriodic ha agotado su tiempo.

Ev::SIGNAL

Una señal especificada en EvSignal::__construct() ha sido recibida.

Ev::CHILD

El pid especificado en EvChild::__construct() ha recibido una alteración de estado.

Ev::STAT

El path especificado en el watcher EvStat ha modificado sus atributos.

Ev::IDLE

El watcher EvIdle trabaja cuando no hay nada que hacer con otros watchers.

Ev::PREPARE

Todos los watchers EvPrepare son invocados justo antes de que Ev::run() comience. Así, los watchers EvPrepare son los últimos en ser invocados antes de que el bucle de eventos duerma, o busque nuevos eventos.

Ev::CHECK

Todos los watchers EvCheck son encolados justo luego de que Ev::run() haya obtenido los nuevos eventos, pero antes de que encole cualquier callback para los eventos recibidos. Así, los watchers EvCheck serán invocados antes que cualquier otro watcher de la misma o menor prioridad dentro de la iteración del bucle de eventos.

Ev::EMBED

El bucle embebido especificado en el watcher EvEmbed necesita atención.

Ev::CUSTOM

Nunca enviado (o utilizado) por libev, pero puede ser libremente utilizado por los usuarios de libev para enviar señales a watchers (por ejemplo a través de EvWatcher::feed() ).

Ev::ERROR

Un error no especificado ha ocurrido, y el watcher se ha detenido. Esto puede ocurrir ya sea porque el watcher no haya sido inicializado apropiadamente debido a que libev ha agotado la memoria disponible, porque un descriptor de archivo se encontraba ya cerrado, o por cualquier otro problema. Libev considera estos errores como errores de aplicación. Véase también » ANATOMY OF A WATCHER

Flags de Backend:

Ev::BACKEND_SELECT

Backend select(2)

Ev::BACKEND_POLL

Backend poll(2)

Ev::BACKEND_EPOLL

Backend específico a Linux epoll(7) tanto para kernels anteriores o posteriores a la versión 2.6.9

Ev::BACKEND_KQUEUE

Backend kqueue utilizado en la mayoría de los sistemas BSD. El watcher EvEmbed puede ser utilizado para embeber un bucle (con e backend kqueue ) dentro de otro. Por ejemplo, uno puede intentar crear un bucle de eventos con el backend kqueue y utilizarlo solamente por sus sockets.

Ev::BACKEND_DEVPOLL

Backend Solaris 8. Aún no implementado.

Ev::BACKEND_PORT

Mecanismo de puerto Solaris 10 con buena escalabilidad.

Ev::BACKEND_ALL

Intentar todos los backends (incluso los corrompidos). No es recomendado utilizar este flag explícitamente. En su lugar deberían utilizarse operaciones Bitwise (por ejemplo Ev::BACKEND_ALL & ~ Ev::BACKEND_KQUEUE ). Utiliza Ev::recommendedBackends() , o no especifiques ningún backend en especial.

Ev::BACKEND_MASK

No es un backend, sino una máscara que permite seleccionar todos los bits de backends desde el valor flags para sacar de la máscara cualquier backend (por ejemplo cuando se modifica la variable de entorno LIBEV_FLAGS ).

Nota:

Durante la fase de inicialización del módulo, Ev registtra para el bucle por defecto una llamada a » ev_loop_fork a través de pthread_atfork (si se encuentra disponible).

Nota:

Existen métodos que ofrecen acceso al bucle de eventos por defecto en la clase Ev (por ejemplo Ev::iteration() , Ev::depth() etc.) Para bucles personalizados (creados con EvLoop::__construct() ) estos valores pueden ser accedidos a través de propiedades y métodos correspondientes de la clase EvLoop .

La instancia del bucle de eventos por defecto puede ser obtenida a través del método EvLoop::defaultLoop() .

Tabla de contenidos

  • Ev::backend — Devuelve un entero que describe el back-end utilizado por libev
  • Ev::depth — Devuelve la profundidad de la recursividad
  • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops
  • Ev::feedSignal — Feed a signal event info Ev
  • Ev::feedSignalEvent — Feed signal event into the default loop
  • Ev::iteration — Return the number of times the default event loop has polled for new events
  • Ev::now — Returns the time when the last iteration of the default event loop has started
  • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
  • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform
  • Ev::resume — Resume previously suspended default event loop
  • Ev::run — Begin checking for events and calling callbacks for the default loop
  • Ev::sleep — Block the process for the given number of seconds
  • Ev::stop — Stops the default event loop
  • Ev::supportedBackends — Returns the set of backends supported by current libev configuration
  • Ev::suspend — Suspend the default event loop
  • Ev::time — Returns the current time in fractional seconds since the epoch
  • Ev::verify — Performs internal consistency checks(for debugging)


Devuelve un entero que describe el back-end utilizado por libev

  • « Ev
  • Ev::depth »
  • PHP Manual
  • Ev
  • Devuelve un entero que describe el back-end utilizado por libev

Ev::backend

(PECL ev >= 0.2.0)

Ev::backend — Devuelve un entero que describe el back-end utilizado por libev

Descripción

final public static Ev::backend ( ) : int

Devuelve un entero que describe el back-end utilizado por libev . Véase Backend flags

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero (máscara de bits) que describe el back-end utilizado por libev .

Ver también

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags


Devuelve la profundidad de la recursividad

  • « Ev::backend
  • Ev::embeddableBackends »
  • PHP Manual
  • Ev
  • Devuelve la profundidad de la recursividad

Ev::depth

(PECL ev >= 0.2.0)

Ev::depth — Devuelve la profundidad de la recursividad

Descripción

final public static Ev::depth ( ) : int

El número de veces Ev::run() se ha introducido menos el número de veces Ev::run() fue terminada normalmente, en otras palabras, el nivel de recursividad. fuera de Ev::run() , este número es 0 . En una llamada de retorno, este número es 1 , a menos que Ev::run() fue invocado recursivamente (o desde otro subproceso), en cuyo caso es mayor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

ev_depth() Devuelve la profundidad de la recursividad del bucle por defecto.

Ver también

  • Ev::iteration() - Return the number of times the default event loop has polled for new events


Returns the set of backends that are embeddable in other event loops

  • « Ev::depth
  • Ev::feedSignal »
  • PHP Manual
  • Ev
  • Returns the set of backends that are embeddable in other event loops

Ev::embeddableBackends

(PECL ev >= 0.2.0)

Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops

Descripción

final public static Ev::embeddableBackends ( ) : int

Returns the set of backends that are embeddable in other event loops.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Ejemplos

Ejemplo #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ver también

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags
  • Examples


Feed a signal event info Ev

  • « Ev::embeddableBackends
  • Ev::feedSignalEvent »
  • PHP Manual
  • Ev
  • Feed a signal event info Ev

Ev::feedSignal

(PECL ev >= 0.2.0)

Ev::feedSignal — Feed a signal event info Ev

Descripción

final public static Ev::feedSignal ( int $signum ) : void

Simulates a signal receive. It is safe to call this function at any time, from any context, including signal handlers or random threads. Its main use is to customise signal handling in the process.

Unlike Ev::feedSignalEvent() , this works regardless of which loop has registered the signal.

Parámetros

signum

Signal number. See signal(7) man page for detals. You can use constants exported by pcntl extension.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::feedSignalEvent() - Feed signal event into the default loop


Feed signal event into the default loop

  • « Ev::feedSignal
  • Ev::iteration »
  • PHP Manual
  • Ev
  • Feed signal event into the default loop

Ev::feedSignalEvent

(No hay información de versión disponible, podría estar únicamente en Git)

Ev::feedSignalEvent — Feed signal event into the default loop

Descripción

final public static Ev::feedSignalEvent ( int $signum ) : void

Feed signal event into the default loop. Ev will react to this call as if the signal specified by signal had occurred.

Parámetros

signum

Signal number. See signal(7) man page for detals. See also constants exported by pcntl extension.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::feedSignal() - Feed a signal event info Ev


Return the number of times the default event loop has polled for new events

  • « Ev::feedSignalEvent
  • Ev::now »
  • PHP Manual
  • Ev
  • Return the number of times the default event loop has polled for new events

Ev::iteration

(PECL ev >= 0.2.0)

Ev::iteration — Return the number of times the default event loop has polled for new events

Descripción

final public static Ev::iteration ( ) : int

Return the number of times the event loop has polled for new events. Sometimes useful as a generation counter.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns number of polls of the default event loop.

Ver también

  • Ev::depth() - Devuelve la profundidad de la recursividad


Returns the time when the last iteration of the default event loop has started

  • « Ev::iteration
  • Ev::nowUpdate »
  • PHP Manual
  • Ev
  • Returns the time when the last iteration of the default event loop has started

Ev::now

(PECL ev >= 0.2.0)

Ev::now — Returns the time when the last iteration of the default event loop has started

Descripción

final public static Ev::now ( ) : float

Returns the time when the last iteration of the default event loop has started. This is the time that timers( EvTimer and EvPeriodic ) are based on, and referring to it is usually faster then calling Ev::time() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns number of seconds(fractional) representing the time when the last iteration of the default event loop has started.

Ver también

  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress


Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

  • « Ev::now
  • Ev::recommendedBackends »
  • PHP Manual
  • Ev
  • Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

Ev::nowUpdate

(PECL ev >= 0.2.0)

Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

Descripción

final public static Ev::nowUpdate ( ) : void

Establishes the current time by querying the kernel, updating the time returned by Ev::now() in the progress. This is a costly operation and is usually done automatically within Ev::run() .

This method is rarely useful, but when some event callback runs for a very long time without entering the event loop, updating libev 's consideration of the current time is a good idea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Returns a bit mask of recommended backends for current platform

  • « Ev::nowUpdate
  • Ev::resume »
  • PHP Manual
  • Ev
  • Returns a bit mask of recommended backends for current platform

Ev::recommendedBackends

(PECL ev >= 0.2.0)

Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform

Descripción

final public static Ev::recommendedBackends ( ) : int

Returns the set of all backends compiled into this binary of libev and also recommended for this platform, meaning it will work for most file descriptor types. This set is often smaller than the one returned by ev_supported_backends() , as for example kqueue is broken on most BSD systems and will not be auto-detected unless it is requested explicitly. This is the set of backends that libev will probe no backends specified explicitly.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Ejemplos

Ejemplo #1 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
 ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
 : 0;

if ($loop_lo) {
 $embed = new EvEmbed($loop_lo, function () {});
} else {
 $loop_lo = $loop_hi;
}
?>

Ver también

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags
  • Examples


Resume previously suspended default event loop

  • « Ev::recommendedBackends
  • Ev::run »
  • PHP Manual
  • Ev
  • Resume previously suspended default event loop

Ev::resume

(PECL ev >= 0.2.0)

Ev::resume — Resume previously suspended default event loop

Descripción

final public static Ev::resume ( ) : void

Ev::suspend() and Ev::resume() methods suspend and resume a loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

Calling suspend / resume has the side effect of updating the event loop time(see Ev::nowUpdate() ).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::suspend() - Suspend the default event loop


Begin checking for events and calling callbacks for the default loop

  • « Ev::resume
  • Ev::sleep »
  • PHP Manual
  • Ev
  • Begin checking for events and calling callbacks for the default loop

Ev::run

(PECL ev >= 0.2.0)

Ev::run — Begin checking for events and calling callbacks for the default loop

Descripción

final public static Ev::run ( int $flags = ? ) : void

Begin checking for events and calling callbacks for the default loop . Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is true), in which case the return value will be false. The return value can generally be interpreted as if true, there is more work left to do .

Parámetros

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::stop() - Stops the default event loop
  • EvLoop::run() - Begin checking for events and calling callbacks for the loop


Block the process for the given number of seconds

  • « Ev::run
  • Ev::stop »
  • PHP Manual
  • Ev
  • Block the process for the given number of seconds

Ev::sleep

(PECL ev >= 0.2.0)

Ev::sleep — Block the process for the given number of seconds

Descripción

final public static Ev::sleep ( float $seconds ) : void

Block the process for the given number of seconds.

Parámetros

seconds

Fractional number of seconds

Valores devueltos

No devuelve ningún valor.


Stops the default event loop

  • « Ev::sleep
  • Ev::supportedBackends »
  • PHP Manual
  • Ev
  • Stops the default event loop

Ev::stop

(PECL ev >= 0.2.0)

Ev::stop — Stops the default event loop

Descripción

final public static Ev::stop ( int $how = ? ) : void

Stops the default event loop

Parámetros

how

One of Ev::BREAK_* constants .

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::run() - Begin checking for events and calling callbacks for the default loop


Returns the set of backends supported by current libev configuration

  • « Ev::stop
  • Ev::suspend »
  • PHP Manual
  • Ev
  • Returns the set of backends supported by current libev configuration

Ev::supportedBackends

(PECL ev >= 0.2.0)

Ev::supportedBackends — Returns the set of backends supported by current libev configuration

Descripción

final public static Ev::supportedBackends ( ) : int

Returns the set of backends supported by current libev configuration.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Ejemplos

Ejemplo #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ver también

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Backend flags
  • Examples


Suspend the default event loop

  • « Ev::supportedBackends
  • Ev::time »
  • PHP Manual
  • Ev
  • Suspend the default event loop

Ev::suspend

(PECL ev >= 0.2.0)

Ev::suspend — Suspend the default event loop

Descripción

final public static Ev::suspend ( ) : void

Ev::suspend() and Ev::resume() methods suspend and resume the default loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::resume() - Resume previously suspended default event loop


Returns the current time in fractional seconds since the epoch

  • « Ev::suspend
  • Ev::verify »
  • PHP Manual
  • Ev
  • Returns the current time in fractional seconds since the epoch

Ev::time

(PECL ev >= 0.2.0)

Ev::time — Returns the current time in fractional seconds since the epoch

Descripción

final public static Ev::time ( ) : float

Returns the current time in fractional seconds since the epoch. Consider using Ev::now()

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current time in fractional seconds since the epoch.

Ver también

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Performs internal consistency checks(for debugging)

  • « Ev::time
  • EvCheck »
  • PHP Manual
  • Ev
  • Performs internal consistency checks(for debugging)

Ev::verify

(PECL ev >= 0.2.0)

Ev::verify — Performs internal consistency checks(for debugging)

Descripción

final public static Ev::verify ( ) : void

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


The EvCheck class

(PECL ev >= 0.2.0)

Introducción

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn’t matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

Sinopsis de la Clase

EvCheck extends EvWatcher {
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( string $callback , string $data = ? , string $priority = ? ) : object
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Tabla de contenidos

  • EvCheck::__construct — Constructs the EvCheck watcher object
  • EvCheck::createStopped — Create instance of a stopped EvCheck watcher


Constructs the EvCheck watcher object

  • « EvCheck
  • EvCheck::createStopped »
  • PHP Manual
  • EvCheck
  • Constructs the EvCheck watcher object

EvCheck::__construct

(PECL ev >= 0.2.0)

EvCheck::__construct — Constructs the EvCheck watcher object

Descripción

public EvCheck::__construct ( callable $callback , mixed $data = ? , int $priority = ? )

Constructs the EvCheck watcher object.

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvCheck object on success.

Ver también

  • EvPrepare
  • EvLoop::check() - Creates EvCheck object associated with the current event loop instance


Create instance of a stopped EvCheck watcher

  • « EvCheck::__construct
  • EvChild »
  • PHP Manual
  • EvCheck
  • Create instance of a stopped EvCheck watcher

EvCheck::createStopped

(PECL ev >= 0.2.0)

EvCheck::createStopped — Create instance of a stopped EvCheck watcher

Descripción

final public static EvCheck::createStopped ( string $callback , string $data = ? , string $priority = ? ) : object

Create instance of a stopped EvCheck watcher

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvCheck object on success.

Ver también

  • EvPrepare


The EvChild class

(PECL ev >= 0.2.0)

Introducción

EvChild watchers trigger when the process receives a SIGCHLD in response to some child status changes (most typically when a child dies or exits). It is permissible to install an EvChild watcher after the child has been forked(which implies it might have already exited), as long as the event loop isn't entered(or is continued from a watcher), i.e. forking and then immediately registering a watcher for the child is fine, but forking and registering a watcher a few event loop iterations later or in the next callback invocation is not.

It is allowed to register EvChild watchers in the default loop only.

Sinopsis de la Clase

EvChild extends EvWatcher {
/* Propiedades */
public $pid ;
public $rpid ;
public $rstatus ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( int $pid , bool $trace , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( int $pid , bool $trace , callable $callback , mixed $data = ? , int $priority = ? ) : object
public set ( int $pid , bool $trace ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

pid

Readonly . The process ID this watcher watches out for, or 0 , meaning any process ID.

rpid

Readonly .The process ID that detected a status change.

rstatus

Readonly . The process exit status caused by rpid .

Tabla de contenidos

  • EvChild::__construct — Constructs the EvChild watcher object
  • EvChild::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild::set — Configures the watcher


Constructs the EvChild watcher object

  • « EvChild
  • EvChild::createStopped »
  • PHP Manual
  • EvChild
  • Constructs the EvChild watcher object

EvChild::__construct

(PECL ev >= 0.2.0)

EvChild::__construct — Constructs the EvChild watcher object

Descripción

public EvChild::__construct ( int $pid , bool $trace , callable $callback , mixed $data = null , int $priority = 0 )

Constructs the EvChild watcher object.

Call the callback when a status change for process ID pid (or any PID if pid is 0 ) has been received(a status change happens when the process terminates or is killed, or, when trace is true, additionally when it is stopped or continued). In other words, when the process receives a SIGCHLD , Ev will fetch the outstanding exit/wait status for all changed/zombie children and call the callback.

It is valid to install a child watcher after an EvChild has exited but before the event loop has started its next iteration. For example, first one calls fork , then the new child process might exit, and only then an EvChild watcher is installed in the parent for the new PID .

You can access both exit/tracing status and pid by using the rstatus and rpid properties of the watcher object.

The number of PID watchers per PID is unlimited. All of them will be called.

The EvChild::createStopped() method doesn't start(activate) the newly created watcher.

Parámetros

pid

Wait for status changes of process PID(or any process if PID is specified as 0 ).

trace

If false, only activate the watcher when the process terminates. Otherwise(true) additionally activate the watcher when the process is stopped or continued.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvChild object on success.

Ver también

  • EvLoop::child() - Creates EvChild object associated with the current event loop


Create instance of a stopped EvCheck watcher

  • « EvChild::__construct
  • EvChild::set »
  • PHP Manual
  • EvChild
  • Create instance of a stopped EvCheck watcher

EvChild::createStopped

(PECL ev >= 0.2.0)

EvChild::createStopped — Create instance of a stopped EvCheck watcher

Descripción

final public static EvChild::createStopped ( int $pid , bool $trace , callable $callback , mixed $data = ? , int $priority = ? ) : object

The same as EvChild::__construct() , but doesn't start the watcher automatically.

Parámetros

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Ver también

  • EvChild::__construct() - Constructs the EvChild watcher object
  • EvLoop::child() - Creates EvChild object associated with the current event loop


Configures the watcher

  • « EvChild::createStopped
  • EvEmbed »
  • PHP Manual
  • EvChild
  • Configures the watcher

EvChild::set

(PECL ev >= 0.2.0)

EvChild::set — Configures the watcher

Descripción

public EvChild::set ( int $pid , bool $trace ) : void

Parámetros

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvChild::__construct() - Constructs the EvChild watcher object


The EvEmbed class

(PECL ev >= 0.2.0)

Introducción

Used to embed one event loop into another.

Sinopsis de la Clase

EvEmbed extends EvWatcher {
/* Propiedades */
public $embed ;
/* Métodos */
public __construct ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? )
final public static createStopped ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? ) : void
public set ( object $other ) : void
public sweep ( ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

is_active

data

is_pending

priority

embed

Tabla de contenidos

  • EvEmbed::__construct — Constructs the EvEmbed object
  • EvEmbed::createStopped — Create stopped EvEmbed watcher object
  • EvEmbed::set — Configures the watcher
  • EvEmbed::sweep — Realizar un único barrido sin bloqueos sobre el bucle embebido


Constructs the EvEmbed object

  • « EvEmbed
  • EvEmbed::createStopped »
  • PHP Manual
  • EvEmbed
  • Constructs the EvEmbed object

EvEmbed::__construct

(PECL ev >= 0.2.0)

EvEmbed::__construct — Constructs the EvEmbed object

Descripción

public EvEmbed::__construct ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? )

This is a rather advanced watcher type that lets to embed one event loop into another(currently only IO events are supported in the embedded loop, other types of watchers might be handled in a delayed or incorrect fashion and must not be used).

See » the libev documentation for details.

This watcher is most useful on BSD systems without working kqueue to still be able to handle a large number of sockets. See example below.

Parámetros

other

Instance of EvLoop . The loop to embed, this loop must be embeddable(see Ev::embeddableBackends() ).

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvEmbed object on success.

Ejemplos

Ejemplo #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
 * Check if kqueue is available but not recommended and create a kqueue backend
 * for use with sockets (which usually work with any kqueue implementation).
 * Store the kqueue/socket-only event loop in loop_socket. (One might optionally
 * use EVFLAG_NOENV, too)
 *
 * Example borrowed from
 * http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
 */
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ver también

  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops


Create stopped EvEmbed watcher object

  • « EvEmbed::__construct
  • EvEmbed::set »
  • PHP Manual
  • EvEmbed
  • Create stopped EvEmbed watcher object

EvEmbed::createStopped

(PECL ev >= 0.2.0)

EvEmbed::createStopped — Create stopped EvEmbed watcher object

Descripción

final public static EvEmbed::createStopped ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? ) : void

The same as EvEmbed::__construct() , but doesn't start the watcher automatically.

Parámetros

other

The same as for EvEmbed::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns stopped EvEmbed object on success.

Ver también

  • EvEmbed::__construct() - Constructs the EvEmbed object
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops


Configures the watcher

  • « EvEmbed::createStopped
  • EvEmbed::sweep »
  • PHP Manual
  • EvEmbed
  • Configures the watcher

EvEmbed::set

(PECL ev >= 0.2.0)

EvEmbed::set — Configures the watcher

Descripción

public EvEmbed::set ( object $other ) : void

Configures the watcher to use other event loop object.

Parámetros

other

The same as for EvEmbed::__construct()

Valores devueltos

No devuelve ningún valor.


Realizar un único barrido sin bloqueos sobre el bucle embebido

  • « EvEmbed::set
  • EvFork »
  • PHP Manual
  • EvEmbed
  • Realizar un único barrido sin bloqueos sobre el bucle embebido

EvEmbed::sweep

(PECL ev >= 0.2.0)

EvEmbed::sweep — Realizar un único barrido sin bloqueos sobre el bucle embebido

Descripción

public EvEmbed::sweep ( ) : void

Realizar un único barrido sin bloqueos sobre el bucle embebido. Funciona de forma similar a lo siguiente, aunque de una forma más apropiada para bucles embebidos:

<?php
$other->start(Ev::RUN_NOWAIT);
?>

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvWatcher::start() - Starts the watcher


The EvFork class

(PECL ev >= 0.2.0)

Introducción

Fork watchers are called when a fork() was detected (usually because whoever signalled libev about it by calling EvLoop::fork() ). The invocation is done before the event loop blocks next and before EvCheck watchers are being called, and only in the child after the fork. Note, that if whoever calling EvLoop::fork() calls it in the wrong process, the fork handlers will be invoked, too.

Sinopsis de la Clase

EvFork extends EvWatcher {
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( string $callback , string $data = ? , string $priority = ? ) : object
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Tabla de contenidos

  • EvFork::__construct — Constructs the EvFork watcher object
  • EvFork::createStopped — Creates a stopped instance of EvFork watcher class


Constructs the EvFork watcher object

  • « EvFork
  • EvFork::createStopped »
  • PHP Manual
  • EvFork
  • Constructs the EvFork watcher object

EvFork::__construct

(PECL ev >= 0.2.0)

EvFork::__construct — Constructs the EvFork watcher object

Descripción

public EvFork::__construct ( callable $callback , mixed $data = null , int $priority = 0 )

Constructs the EvFork watcher object and starts the watcher automatically.

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvFork object on success.

Ver también

  • EvLoop::fork() - Creates EvFork watcher object associated with the current event loop instance
  • EvCheck


Creates a stopped instance of EvFork watcher class

  • « EvFork::__construct
  • EvIdle »
  • PHP Manual
  • EvFork
  • Creates a stopped instance of EvFork watcher class

EvFork::createStopped

(PECL ev >= 0.2.0)

EvFork::createStopped — Creates a stopped instance of EvFork watcher class

Descripción

final public static EvFork::createStopped ( string $callback , string $data = ? , string $priority = ? ) : object

The same as EvFork::__construct() , but doesn't start the watcher automatically.

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvFork(stopped) object on success.

Ver también

  • EvFork::__construct() - Constructs the EvFork watcher object


The EvIdle class

(PECL ev >= 0.2.0)

Introducción

EvIdle watchers trigger events when no other events of the same or higher priority are pending ( EvPrepare , EvCheck and other EvIdle watchers do not count as receiving events ).

Thus, as long as the process is busy handling sockets or timeouts(or even signals) of the same or higher priority it will not be triggered. But when the process is in idle(or only lower-priority watchers are pending), the EvIdle watchers are being called once per event loop iteration - until stopped, that is, or the process receives more events and becomes busy again with higher priority stuff.

Apart from keeping the process non-blocking(which is a useful on its own sometimes), EvIdle watchers are a good place to do "pseudo-background processing" , or delay processing stuff to after the event loop has handled all outstanding events.

The most noticeable effect is that as long as any idle watchers are active, the process will not block when waiting for new events.

Sinopsis de la Clase

EvIdle extends EvWatcher {
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( string $callback , mixed $data = ? , int $priority = ? ) : object
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Tabla de contenidos

  • EvIdle::__construct — Constructs the EvIdle watcher object
  • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object


Constructs the EvIdle watcher object

  • « EvIdle
  • EvIdle::createStopped »
  • PHP Manual
  • EvIdle
  • Constructs the EvIdle watcher object

EvIdle::__construct

(PECL ev >= 0.2.0)

EvIdle::__construct — Constructs the EvIdle watcher object

Descripción

public EvIdle::__construct ( callable $callback , mixed $data = ? , int $priority = ? )

Constructs the EvIdle watcher object and starts the watcher automatically.

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvIdle object on success.

Ver también

  • EvIdle::createStopped() - Creates instance of a stopped EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance


Creates instance of a stopped EvIdle watcher object

  • « EvIdle::__construct
  • EvIo »
  • PHP Manual
  • EvIdle
  • Creates instance of a stopped EvIdle watcher object

EvIdle::createStopped

(PECL ev >= 0.2.0)

EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object

Descripción

final public static EvIdle::createStopped ( string $callback , mixed $data = ? , int $priority = ? ) : object

The same as EvIdle::__construct() , but doesn't start the watcher automatically.

Parámetros

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvIdle object on success.

Ver también

  • EvIdle::__construct() - Constructs the EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance


The EvIo class

(PECL ev >= 0.2.0)

Introducción

EvIo watchers check whether a file descriptor(or socket, or a stream castable to numeric file descriptor) is readable or writable in each iteration of the event loop, or, more precisely, when reading would not block the process and writing would at least be able to write some data. This behaviour is called level-triggering because events are kept receiving as long as the condition persists. To stop receiving events just stop the watcher.

The number of read and/or write event watchers per fd is unlimited. Setting all file descriptors to non-blocking mode is also usually a good idea(but not required).

Another thing to watch out for is that it is quite easy to receive false readiness notifications, i.e. the callback might be called with Ev::READ but a subsequent read() will actually block because there is no data. It is very easy to get into this situation. Thus it is best to always use non-blocking I/O: An extra read() returning EAGAIN (or similar) is far preferable to a program hanging until some data arrives.

If for some reason it is impossible to run the fd in non-blocking mode, then separately re-test whether a file descriptor is really ready. Some people additionally use SIGALRM and an interval timer, just to be sure thry won't block infinitely.

Always consider using non-blocking mode.

Sinopsis de la Clase

EvIo extends EvWatcher {
/* Propiedades */
public $fd ;
public $events ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( mixed $fd , int $events , callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo
public set ( mixed $fd , int $events ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

fd

events

Tabla de contenidos

  • EvIo::__construct — Constructs EvIo watcher object
  • EvIo::createStopped — Create stopped EvIo watcher object
  • EvIo::set — Configures the watcher


Constructs EvIo watcher object

  • « EvIo
  • EvIo::createStopped »
  • PHP Manual
  • EvIo
  • Constructs EvIo watcher object

EvIo::__construct

(PECL ev >= 0.2.0)

EvIo::__construct — Constructs EvIo watcher object

Descripción

public EvIo::__construct ( mixed $fd , int $events , callable $callback , mixed $data = ? , int $priority = ? )

Constructs EvIo watcher object and starts the watcher automatically.

Parámetros

fd

Can be a stream opened with fopen() or similar functions, numeric file descriptor, or socket.

events

Ev::READ and/or Ev::WRITE . See the bit masks .

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvIo object on success.

Ver también

  • EvIo::createStopped() - Create stopped EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance


Create stopped EvIo watcher object

  • « EvIo::__construct
  • EvIo::set »
  • PHP Manual
  • EvIo
  • Create stopped EvIo watcher object

EvIo::createStopped

(PECL ev >= 0.2.0)

EvIo::createStopped — Create stopped EvIo watcher object

Descripción

final public static EvIo::createStopped ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo

The same as EvIo::__construct() , but doesn't start the watcher automatically.

Parámetros

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvIo object on success.

Ver también

  • EvIo::__construct() - Constructs EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance


Configures the watcher

  • « EvIo::createStopped
  • EvLoop »
  • PHP Manual
  • EvIo
  • Configures the watcher

EvIo::set

(PECL ev >= 0.2.0)

EvIo::set — Configures the watcher

Descripción

public EvIo::set ( mixed $fd , int $events ) : void

Configures the EvIo watcher

Parámetros

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

Valores devueltos

No devuelve ningún valor.


The EvLoop class

(PECL ev >= 0.2.0)

Introducción

Represents an event loop that is always distinct from the default loop . Unlike the default loop , it cannot handle EvChild watchers.

Having threads we have to create a loop per thread, and use the default loop in the parent thread.

The default event loop is initialized automatically by Ev . It is accessible via methods of the Ev class, or via EvLoop::defaultLoop() method.

Sinopsis de la Clase

final EvLoop {
/* Propiedades */
public $data ;
public $backend ;
public $is_default_loop ;
public $iteration ;
public $pending ;
public $io_interval ;
public $timeout_interval ;
public $depth ;
/* Métodos */
public backend ( ) : int
final public check ( string $callback , string $data = ? , string $priority = ? ) : EvCheck
final public child ( string $pid , string $trace , string $callback , string $data = ? , string $priority = ? ) : EvChild
public __construct ( int $flags = ? , mixed $data = NULL , float $io_interval = 0.0 , float $timeout_interval = 0.0 )
public static defaultLoop ( int $flags = Ev::FLAG_AUTO , mixed $data = NULL , float $io_interval = 0. , float $timeout_interval = 0. ) : EvLoop
final public embed ( string $other , string $callback = ? , string $data = ? , string $priority = ? ) : EvEmbed
final public fork ( callable $callback , mixed $data = null , int $priority = 0 ) : EvFork
final public idle ( callable $callback , mixed $data = null , int $priority = 0 ) : EvIdle
public invokePending ( ) : void
final public io ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo
public loopFork ( ) : void
public now ( ) : float
public nowUpdate ( ) : void
final public periodic ( float $offset , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic
final public prepare ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare
public resume ( ) : void
public run ( int $flags = 0 ) : void
final public signal ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal
final public stat ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvStat
public stop ( int $how = ? ) : void
public suspend ( ) : void
final public timer ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer
public verify ( ) : void
}

Propiedades

data

Custom data attached to loop

backend

Readonly . The backend flags indicating the event backend in use.

is_default_loop

Readonly . true if it is the default event loop.

iteration

The current iteration count of the loop. See Ev::iteration()

pending

The number of pending watchers. 0 indicates that there are no watchers pending.

io_interval

Higher io_interval allows libev to spend more time collecting EvIo events, so more events can be handled per iteration, at the cost of increasing latency. Timeouts (both EvPeriodic and EvTimer ) will not be affected. Setting this to a non-zero value will introduce an additional sleep() call into most loop iterations. The sleep time ensures that libev will not poll for EvIo events more often than once per this interval, on average. Many programs can usually benefit by setting the io_interval to a value near 0.1 , which is often enough for interactive servers(not for games). It usually doesn't make much sense to set it to a lower value than 0.01 , as this approaches the timing granularity of most systems.

See also » FUNCTIONS CONTROLLING EVENT LOOPS .

timeout_interval

Higher timeout_interval allows libev to spend more time collecting timeouts, at the expense of increased latency/jitter/inexactness(the watcher callback will be called later). EvIo watchers will not be affected. Setting this to a non-null value will not introduce any overhead in libev . See also » FUNCTIONS CONTROLLING EVENT LOOPS .

depth

The recursion depth. See Ev::depth() .

Tabla de contenidos

  • EvLoop::backend — Returns an integer describing the backend used by libev
  • EvLoop::check — Creates EvCheck object associated with the current event loop instance
  • EvLoop::child — Creates EvChild object associated with the current event loop
  • EvLoop::__construct — Constructs the event loop object
  • EvLoop::defaultLoop — Returns or creates the default event loop
  • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object
  • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
  • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
  • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
  • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
  • EvLoop::loopFork — Must be called after a fork
  • EvLoop::now — Returns the current "event loop time"
  • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
  • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
  • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
  • EvLoop::resume — Resume previously suspended default event loop
  • EvLoop::run — Begin checking for events and calling callbacks for the loop
  • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
  • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
  • EvLoop::stop — Stops the event loop
  • EvLoop::suspend — Suspend the loop
  • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
  • EvLoop::verify — Performs internal consistency checks(for debugging)


Returns an integer describing the backend used by libev

  • « EvLoop
  • EvLoop::check »
  • PHP Manual
  • EvLoop
  • Returns an integer describing the backend used by libev

EvLoop::backend

(PECL ev >= 0.2.0)

EvLoop::backend — Returns an integer describing the backend used by libev

Descripción

public EvLoop::backend ( ) : int

The same as Ev::backend() , but for the loop instance.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an integer describing the backend used by libev. See Ev::backend() .

Ver también

  • Ev::backend() - Devuelve un entero que describe el back-end utilizado por libev


Creates EvCheck object associated with the current event loop instance

  • « EvLoop::backend
  • EvLoop::child »
  • PHP Manual
  • EvLoop
  • Creates EvCheck object associated with the current event loop instance

EvLoop::check

(PECL ev >= 0.2.0)

EvLoop::check — Creates EvCheck object associated with the current event loop instance

Descripción

final public EvLoop::check ( string $callback , string $data = ? , string $priority = ? ) : EvCheck

Creates EvCheck object associated with the current event loop instance.

Parámetros

All parameters have the same meaning as for EvCheck::__construct()

Valores devueltos

Returns EvCheck object on success.

Ver también

  • EvCheck::__construct() - Constructs the EvCheck watcher object


Creates EvChild object associated with the current event loop

  • « EvLoop::check
  • EvLoop::__construct »
  • PHP Manual
  • EvLoop
  • Creates EvChild object associated with the current event loop

EvLoop::child

(PECL ev >= 0.2.0)

EvLoop::child — Creates EvChild object associated with the current event loop

Descripción

final public EvLoop::child ( string $pid , string $trace , string $callback , string $data = ? , string $priority = ? ) : EvChild

Creates EvChild object associated with the current event loop.

Parámetros

All parameters have the same meaning as for EvChild::__construct()

Valores devueltos

Returns EvChild object on success.

Ver también

  • EvChild::__construct() - Constructs the EvChild watcher object


Constructs the event loop object

  • « EvLoop::child
  • EvLoop::defaultLoop »
  • PHP Manual
  • EvLoop
  • Constructs the event loop object

EvLoop::__construct

(PECL ev >= 0.2.0)

EvLoop::__construct — Constructs the event loop object

Descripción

public EvLoop::__construct ( int $flags = ? , mixed $data = NULL , float $io_interval = 0.0 , float $timeout_interval = 0.0 )

Constructs the event loop object.

Parámetros

flags

One of the event loop flags

data

Custom data associated with the loop.

io_interval

See io_interval

timeout_interval

See timeout_interval

Valores devueltos

Returns new EvLoop object.

Ver también

  • EvLoop::defaultLoop() - Returns or creates the default event loop


Returns or creates the default event loop

  • « EvLoop::__construct
  • EvLoop::embed »
  • PHP Manual
  • EvLoop
  • Returns or creates the default event loop

EvLoop::defaultLoop

(PECL ev >= 0.2.0)

EvLoop::defaultLoop — Returns or creates the default event loop

Descripción

public static EvLoop::defaultLoop ( int $flags = Ev::FLAG_AUTO , mixed $data = NULL , float $io_interval = 0. , float $timeout_interval = 0. ) : EvLoop

If the default event loop is not created, EvLoop::defaultLoop() creates it with the specified parameters. Otherwise, it just returns the object representing previously created instance ignoring all the parameters.

Parámetros

flags

One of the event loop flags

data

Custom data to associate with the loop.

io_collect_interval

See io_interval

timeout_collect_interval

See timeout_interval

Valores devueltos

Returns EvLoop object on success.

Ver también

  • EvLoop::__construct() - Constructs the event loop object


Creates an instance of EvEmbed watcher associated with the current EvLoop object

  • « EvLoop::defaultLoop
  • EvLoop::fork »
  • PHP Manual
  • EvLoop
  • Creates an instance of EvEmbed watcher associated with the current EvLoop object

EvLoop::embed

(PECL ev >= 0.2.0)

EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object

Descripción

final public EvLoop::embed ( string $other , string $callback = ? , string $data = ? , string $priority = ? ) : EvEmbed

Creates an instance of EvEmbed watcher associated with the current EvLoop object.

Parámetros

All parameters have the same meaning as for EvEmbed::__construct() .

Valores devueltos

Returns EvEmbed object on success.

Ver también

  • EvEmbed::__construct() - Constructs the EvEmbed object


Creates EvFork watcher object associated with the current event loop instance

  • « EvLoop::embed
  • EvLoop::idle »
  • PHP Manual
  • EvLoop
  • Creates EvFork watcher object associated with the current event loop instance

EvLoop::fork

(PECL ev >= 0.2.0)

EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance

Descripción

final public EvLoop::fork ( callable $callback , mixed $data = null , int $priority = 0 ) : EvFork

Creates EvFork watcher object associated with the current event loop instance

Parámetros

All parameters have the same meaning as for EvFork::__construct()

Valores devueltos

Returns EvFork object on success.

Ver también

  • EvFork::__construct() - Constructs the EvFork watcher object


Creates EvIdle watcher object associated with the current event loop instance

  • « EvLoop::fork
  • EvLoop::invokePending »
  • PHP Manual
  • EvLoop
  • Creates EvIdle watcher object associated with the current event loop instance

EvLoop::idle

(PECL ev >= 0.2.0)

EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance

Descripción

final public EvLoop::idle ( callable $callback , mixed $data = null , int $priority = 0 ) : EvIdle

Creates EvIdle watcher object associated with the current event loop instance

Parámetros

All the parameters have the same meaning as for EvIdle::__construct()

Valores devueltos

Returns EvIdle object on success.

Ver también

  • EvIdle::__construct() - Constructs the EvIdle watcher object


Invoke all pending watchers while resetting their pending state

  • « EvLoop::idle
  • EvLoop::io »
  • PHP Manual
  • EvLoop
  • Invoke all pending watchers while resetting their pending state

EvLoop::invokePending

(PECL ev >= 0.2.0)

EvLoop::invokePending — Invoke all pending watchers while resetting their pending state

Descripción

public EvLoop::invokePending ( ) : void

Invoke all pending watchers while resetting their pending state.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Create EvIo watcher object associated with the current event loop instance

  • « EvLoop::invokePending
  • EvLoop::loopFork »
  • PHP Manual
  • EvLoop
  • Create EvIo watcher object associated with the current event loop instance

EvLoop::io

(PECL ev >= 0.2.0)

EvLoop::io — Create EvIo watcher object associated with the current event loop instance

Descripción

final public EvLoop::io ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo

Create EvIo watcher object associated with the current event loop instance.

Parámetros

All parameters have the same meaning as for EvIo::__construct()

Valores devueltos

Returns EvIo object on success.

Ver también

  • EvIo::__construct() - Constructs EvIo watcher object


Must be called after a fork

  • « EvLoop::io
  • EvLoop::now »
  • PHP Manual
  • EvLoop
  • Must be called after a fork

EvLoop::loopFork

(PECL ev >= 0.2.0)

EvLoop::loopFork — Must be called after a fork

Descripción

public EvLoop::loopFork ( ) : void

Must be called after a fork in the child, before entering or continuing the event loop. An alternative is to use Ev::FLAG_FORKCHECK which calls this function automatically, at some performance loss (refer to the » libev documentation ).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Returns the current "event loop time"

  • « EvLoop::loopFork
  • EvLoop::nowUpdate »
  • PHP Manual
  • EvLoop
  • Returns the current "event loop time"

EvLoop::now

(PECL ev >= 0.2.0)

EvLoop::now — Returns the current "event loop time"

Descripción

public EvLoop::now ( ) : float

Returns the current "event loop time", which is the time the event loop received events and started processing them. This timestamp does not change as long as callbacks are being processed, and this is also the base time used for relative timers. You can treat it as the timestamp of the event occurring(or more correctly, libev finding out about it).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns time of the event loop in (fractional) seconds.

Ver también

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

  • « EvLoop::now
  • EvLoop::periodic »
  • PHP Manual
  • EvLoop
  • Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

EvLoop::nowUpdate

(PECL ev >= 0.2.0)

EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

Descripción

public EvLoop::nowUpdate ( ) : void

Establishes the current time by querying the kernel, updating the time returned by EvLoop::now() in the progress. This is a costly operation and is usually done automatically within EvLoop::run() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvLoop::now() - Returns the current "event loop time"
  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress


Creates EvPeriodic watcher object associated with the current event loop instance

  • « EvLoop::nowUpdate
  • EvLoop::prepare »
  • PHP Manual
  • EvLoop
  • Creates EvPeriodic watcher object associated with the current event loop instance

EvLoop::periodic

(PECL ev >= 0.2.0)

EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance

Descripción

final public EvLoop::periodic ( float $offset , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic

Creates EvPeriodic watcher object associated with the current event loop instance

Parámetros

All parameters have the same maening as for EvPeriodic::__construct()

Valores devueltos

Returns EvPeriodic object on success.

Ver también

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object


Creates EvPrepare watcher object associated with the current event loop instance

  • « EvLoop::periodic
  • EvLoop::resume »
  • PHP Manual
  • EvLoop
  • Creates EvPrepare watcher object associated with the current event loop instance

EvLoop::prepare

(PECL ev >= 0.2.0)

EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance

Descripción

final public EvLoop::prepare ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare

Creates EvPrepare watcher object associated with the current event loop instance

Parámetros

All parameters have the same maening as for EvPrepare()

Valores devueltos

Returns EvPrepare object on success

Ver también

  • EvPrepare::__construct() - Construye un objeto observador de EvPrepare


Resume previously suspended default event loop

  • « EvLoop::prepare
  • EvLoop::run »
  • PHP Manual
  • EvLoop
  • Resume previously suspended default event loop

EvLoop::resume

(PECL ev >= 0.2.0)

EvLoop::resume — Resume previously suspended default event loop

Descripción

public EvLoop::resume ( ) : void

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvLoop::suspend() - Suspend the loop
  • Ev::resume() - Resume previously suspended default event loop


Begin checking for events and calling callbacks for the loop

  • « EvLoop::resume
  • EvLoop::signal »
  • PHP Manual
  • EvLoop
  • Begin checking for events and calling callbacks for the loop

EvLoop::run

(PECL ev >= 0.2.0)

EvLoop::run — Begin checking for events and calling callbacks for the loop

Descripción

public EvLoop::run ( int $flags = 0 ) : void

Begin checking for events and calling callbacks for the current event loop. Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is true), in which case the return value will be false. The return value can generally be interpreted as if true, there is more work left to do .

Parámetros

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvLoop::stop() - Stops the event loop
  • Ev::run() - Begin checking for events and calling callbacks for the default loop


Creates EvSignal watcher object associated with the current event loop instance

  • « EvLoop::run
  • EvLoop::stat »
  • PHP Manual
  • EvLoop
  • Creates EvSignal watcher object associated with the current event loop instance

EvLoop::signal

(PECL ev >= 0.2.0)

EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance

Descripción

final public EvLoop::signal ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal

Creates EvSignal watcher object associated with the current event loop instance

Parámetros

All parameters have the same meaning as for EvSignal::__construct()

Valores devueltos

Returns EvSignal object on success

Ver también

  • EvSignal::__construct() - Construye el objeto observador EvSignal


Creates EvStat watcher object associated with the current event loop instance

  • « EvLoop::signal
  • EvLoop::stop »
  • PHP Manual
  • EvLoop
  • Creates EvStat watcher object associated with the current event loop instance

EvLoop::stat

(PECL ev >= 0.2.0)

EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance

Descripción

final public EvLoop::stat ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvStat

Creates EvStat watcher object associated with the current event loop instance

Parámetros

All parameters have the same meaning as for EvSignal::__construct()

Valores devueltos

Returns EvStat object on success

Ver también

  • EvSignal::__construct() - Construye el objeto observador EvSignal


Stops the event loop

  • « EvLoop::stat
  • EvLoop::suspend »
  • PHP Manual
  • EvLoop
  • Stops the event loop

EvLoop::stop

(PECL ev >= 0.2.0)

EvLoop::stop — Stops the event loop

Descripción

public EvLoop::stop ( int $how = ? ) : void

Stops the event loop

Parámetros

how

One of Ev::BREAK_* constants .

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvLoop::run() - Begin checking for events and calling callbacks for the loop
  • Ev::stop() - Stops the default event loop


Suspend the loop

  • « EvLoop::stop
  • EvLoop::timer »
  • PHP Manual
  • EvLoop
  • Suspend the loop

EvLoop::suspend

(PECL ev >= 0.2.0)

EvLoop::suspend — Suspend the loop

Descripción

public EvLoop::suspend ( ) : void

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvLoop::resume() - Resume previously suspended default event loop
  • Ev::suspend() - Suspend the default event loop


Creates EvTimer watcher object associated with the current event loop instance

  • « EvLoop::suspend
  • EvLoop::verify »
  • PHP Manual
  • EvLoop
  • Creates EvTimer watcher object associated with the current event loop instance

EvLoop::timer

(PECL ev >= 0.2.0)

EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance

Descripción

final public EvLoop::timer ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer

Creates EvTimer watcher object associated with the current event loop instance

Parámetros

All parameters have the same meaning as for EvTimer::__construct()

Valores devueltos

Returns EvTimer object on success

Ver también

  • EvTimer::__construct() - Constructs an EvTimer watcher object


Performs internal consistency checks(for debugging)

  • « EvLoop::timer
  • EvPeriodic »
  • PHP Manual
  • EvLoop
  • Performs internal consistency checks(for debugging)

EvLoop::verify

(PECL ev >= 0.2.0)

EvLoop::verify — Performs internal consistency checks(for debugging)

Descripción

public EvLoop::verify ( ) : void

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ev::verify() - Performs internal consistency checks(for debugging)


The EvPeriodic class

(PECL ev >= 0.2.0)

Introducción

Periodic watchers are also timers of a kind, but they are very versatile.

Unlike EvTimer , EvPeriodic watchers are not based on real time(or relative time, the physical time that passes) but on wall clock time(absolute time, calendar or clock). The difference is that wall clock time can run faster or slower than real time, and time jumps are not uncommon(e.g. when adjusting it).

EvPeriodic watcher can be configured to trigger after some specific point in time. For example, if an EvPeriodic watcher is configured to trigger "in 10 seconds" (e.g. EvLoop::now() + 10.0 , i.e. an absolute time, not a delay), and the system clock is reset to January of the previous year , then it will take a year or more to trigger the event (unlike an EvTimer , which would still trigger roughly 10 seconds after starting it as it uses a relative timeout).

As with timers, the callback is guaranteed to be invoked only when the point in time where it is supposed to trigger has passed. If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

Sinopsis de la Clase

EvPeriodic extends EvWatcher {
/* Propiedades */
public $offset ;
public $interval ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public again ( ) : void
public at ( ) : float
public __construct ( float $offset , string $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( float $offset , float $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic
public set ( float $offset , float $interval ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

offset

When repeating, this contains the offset value, otherwise this is the absolute point in time(the offset value passed to EvPeriodic::set() , although libev might modify this value for better numerical stability).

interval

The current interval value. Can be modified any time, but changes only take effect when the periodic timer fires or EvPeriodic::again() is being called.

Tabla de contenidos

  • EvPeriodic::again — Simply stops and restarts the periodic watcher again
  • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
  • EvPeriodic::__construct — Constructs EvPeriodic watcher object
  • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
  • EvPeriodic::set — Configures the watcher


Simply stops and restarts the periodic watcher again

  • « EvPeriodic
  • EvPeriodic::at »
  • PHP Manual
  • EvPeriodic
  • Simply stops and restarts the periodic watcher again

EvPeriodic::again

(PECL ev >= 0.2.0)

EvPeriodic::again — Simply stops and restarts the periodic watcher again

Descripción

public EvPeriodic::again ( ) : void

Simply stops and restarts the periodic watcher again. This is only useful when attributes are changed.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvTimer::again() - Restarts the timer watcher


Returns the absolute time that this watcher is supposed to trigger next

  • « EvPeriodic::again
  • EvPeriodic::__construct »
  • PHP Manual
  • EvPeriodic
  • Returns the absolute time that this watcher is supposed to trigger next

EvPeriodic::at

(PECL ev >= 0.2.0)

EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next

Descripción

public EvPeriodic::at ( ) : float

When the watcher is active, returns the absolute time that this watcher is supposed to trigger next. This is not the same as the offset argument to EvPeriodic::set() or EvPeriodic::__construct() , but indeed works even in interval mode.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the absolute time this watcher is supposed to trigger next in seconds.


Constructs EvPeriodic watcher object

  • « EvPeriodic::at
  • EvPeriodic::createStopped »
  • PHP Manual
  • EvPeriodic
  • Constructs EvPeriodic watcher object

EvPeriodic::__construct

(PECL ev >= 0.2.0)

EvPeriodic::__construct — Constructs EvPeriodic watcher object

Descripción

public EvPeriodic::__construct ( float $offset , string $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 )

Constructs EvPeriodic watcher object and starts it automatically. EvPeriodic::createStopped() method creates stopped periodic watcher.

Parámetros

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass null. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvPeriodic object on success.

Ejemplos

Ejemplo #1 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
 return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Ejemplo #2 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Ejemplo #3 Hourly watcher

<?php
$hourly = EvPeriodic(0, 3600, NULL, function () {
 echo "once per hour\n";
});
?>

Ver también

  • Periodic watcher operation modes
  • EvTimer
  • EvPeriodic::createStopped() - Create a stopped EvPeriodic watcher


Create a stopped EvPeriodic watcher

  • « EvPeriodic::__construct
  • EvPeriodic::set »
  • PHP Manual
  • EvPeriodic
  • Create a stopped EvPeriodic watcher

EvPeriodic::createStopped

(PECL ev >= 0.2.0)

EvPeriodic::createStopped — Create a stopped EvPeriodic watcher

Descripción

final public static EvPeriodic::createStopped ( float $offset , float $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic

Create EvPeriodic object. Unlike EvPeriodic::__construct() this method doesn't start the watcher automatically.

Parámetros

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass null. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvPeriodic watcher object on success.

Ver también

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object
  • EvTimer::createStopped() - Creates EvTimer stopped watcher object


Configures the watcher

  • « EvPeriodic::createStopped
  • EvPrepare »
  • PHP Manual
  • EvPeriodic
  • Configures the watcher

EvPeriodic::set

(PECL ev >= 0.2.0)

EvPeriodic::set — Configures the watcher

Descripción

public EvPeriodic::set ( float $offset , float $interval ) : void

(Re-)Configures EvPeriodic watcher

Parámetros

offset

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

interval

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

Valores devueltos

No devuelve ningún valor.


The EvPrepare class

(PECL ev >= 0.2.0)

Introducción

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn’t matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

Sinopsis de la Clase

EvPrepare extends EvWatcher {
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( string $callback , string $data = ? , string $priority = ? )
final public static createStopped ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Tabla de contenidos

  • EvPrepare::__construct — Construye un objeto observador de EvPrepare
  • EvPrepare::createStopped — Crea una instancia detenida del watcher (testigo) EvPrepare


Construye un objeto observador de EvPrepare

  • « EvPrepare
  • EvPrepare::createStopped »
  • PHP Manual
  • EvPrepare
  • Construye un objeto observador de EvPrepare

EvPrepare::__construct

(PECL ev >= 0.2.0)

EvPrepare::__construct — Construye un objeto observador de EvPrepare

Descripción

public EvPrepare::__construct ( string $callback , string $data = ? , string $priority = ? )

Construye un objeto observador de EvPrepare e inicia el observador autmáticamente. Si fuera necesario un observador detenido, considere el empleo de EvPrepare::createStopped()

Parámetros

callback

Ver Retrollamadas de observadores .

data

Datos personalizados asociados con el observador.

priority

Prioridad del observador

Valores devueltos

Devuelve el objeto EvPrepare en caso de éxito.

Ver también

  • EvCheck


Crea una instancia detenida del watcher (testigo) EvPrepare

  • « EvPrepare::__construct
  • EvSignal »
  • PHP Manual
  • EvPrepare
  • Crea una instancia detenida del watcher (testigo) EvPrepare

EvPrepare::createStopped

(PECL ev >= 0.2.0)

EvPrepare::createStopped — Crea una instancia detenida del watcher (testigo) EvPrepare

Descripción

final public static EvPrepare::createStopped ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare

Crea una instancia detenida del testigo EvPrepare. A diferencia de EvPrepare::__construct() , este método no inicia el testigo automáticamente.

Parámetros

callback

Ver Retrollamada del testigo .

data

Datos personalizados asociados con el testigo.

priority

Prioridad del testigo

Valores devueltos

Devuelve el objeto EvPrepare en caso de éxito.

Ver también

  • EvPrepare::__construct() - Construye un objeto observador de EvPrepare
  • EvWatcher::start() - Starts the watcher


The EvSignal class

(PECL ev >= 0.2.0)

Introducción

EvSignal watchers will trigger an event when the process receives a specific signal one or more times. Even though signals are very asynchronous, libev will try its best to deliver signals synchronously, i.e. as part of the normal event processing, like any other event.

There is no limit for the number of watchers for the same signal, but only within the same loop, i.e. one can watch for SIGINT in the default loop and for SIGIO in another loop, but it is not allowed to watch for SIGINT in both the default loop and another loop at the same time. At the moment, SIGCHLD is permanently tied to the default loop.

If possible and supported, libev will install its handlers with SA_RESTART (or equivalent) behaviour enabled, so system calls should not be unduly interrupted. In case of a problem with system calls getting interrupted by signals, all the signals can be blocked in an EvCheck watcher and unblocked in a EvPrepare watcher.

Sinopsis de la Clase

EvSignal extends EvWatcher {
/* Propiedades */
public $signum ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public __construct ( int $signum , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal
public set ( int $signum ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

signum

Signal number. See the constants exported by pcntl extension. See also signal(7) man page.

Tabla de contenidos

  • EvSignal::__construct — Construye el objeto observador EvSignal
  • EvSignal::createStopped — Create stopped EvSignal watcher object
  • EvSignal::set — Configura el testigo


Construye el objeto observador EvSignal

  • « EvSignal
  • EvSignal::createStopped »
  • PHP Manual
  • EvSignal
  • Construye el objeto observador EvSignal

EvSignal::__construct

(PECL ev >= 0.2.0)

EvSignal::__construct — Construye el objeto observador EvSignal

Descripción

public EvSignal::__construct ( int $signum , callable $callback , mixed $data = null , int $priority = 0 )

Construye el objeto observador EvSignal y lo inicia automáticamente. Para un observador periódico detenido, considere la posibilidad de usar EvSignal::createStopped().

Parámetros

signum

Número de señal. Ver las constantes exportadas por la extensión pcntl. Ver también la página principal de signal(7).

callback

Ver Las llamadas de los observadores .

data

Datos personalizados asociados con el observador.

priority

Prioridad del observador

Valores devueltos

Devuelve el objeto EvSignal en caso de éxito.

Ejemplos

Ejemplo #1 Manejar la señal SIGTERM

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM recibida\n";
    $watcher->stop();
});

Ev::run();
?>

Ver también

  • EvSignal::createStopped() - Create stopped EvSignal watcher object


Create stopped EvSignal watcher object

  • « EvSignal::__construct
  • EvSignal::set »
  • PHP Manual
  • EvSignal
  • Create stopped EvSignal watcher object

EvSignal::createStopped

(PECL ev >= 0.2.0)

EvSignal::createStopped — Create stopped EvSignal watcher object

Descripción

final public static EvSignal::createStopped ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal

Create stopped EvSignal watcher object. Unlike EvSignal::__construct() , this method does't start the watcher automatically.

Parámetros

signum

Signal number. See constants exported by pcntl extension. See also signal(7) man page.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvSignal object on success.

Ver también

  • EvWatcher::start() - Starts the watcher
  • EvSignal::__construct() - Construye el objeto observador EvSignal


Configura el testigo

  • « EvSignal::createStopped
  • EvStat »
  • PHP Manual
  • EvSignal
  • Configura el testigo

EvSignal::set

(PECL ev >= 0.2.0)

EvSignal::set — Configura el testigo

Descripción

public EvSignal::set ( int $signum ) : void

Configura el testigo.

Parámetros

signum

Señal numérica. La misma que para EvSignal::__construct()

Valores devueltos

No devuelve ningún valor.


The EvStat class

(PECL ev >= 0.2.0)

Introducción

EvStat monitors a file system path for attribute changes. It calls stat() on that path in regular intervals(or when the OS signals it changed) and sees if it changed compared to the last time, invoking the callback if it did.

The path does not need to exist: changing from "path exists" to "path does not exist" is a status change like any other. The condition "path does not exist" is signified by the 'nlink' item being 0(returned by EvStat::attr() method).

The path must not end in a slash or contain special components such as '.' or .. . The path should be absolute: if it is relative and the working directory changes, then the behaviour is undefined.

Since there is no portable change notification interface available, the portable implementation simply calls stat() regularly on the path to see if it changed somehow. For this case a recommended polling interval can be specified. If one specifies a polling interval of 0.0 (highly recommended) then a suitable, unspecified default value will be used(which could be expected to be around 5 seconds, although this might change dynamically). libev will also impose a minimum interval which is currently around 0.1 , but that’s usually overkill.

This watcher type is not meant for massive numbers of EvStat watchers, as even with OS-supported change notifications, this can be resource-intensive.

Sinopsis de la Clase

EvStat extends EvWatcher {
/* Propiedades */
public $path ;
public $interval ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public attr ( ) : array
public __construct ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : void
public prev ( ) : void
public set ( string $path , float $interval ) : void
public stat ( ) : bool
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

interval

Readonly . Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

path

Readonly . The path to wait for status changes on.

Tabla de contenidos

  • EvStat::attr — Returns the values most recently detected by Ev
  • EvStat::__construct — Constructs EvStat watcher object
  • EvStat::createStopped — Create a stopped EvStat watcher object
  • EvStat::prev — Returns the previous set of values returned by EvStat::attr
  • EvStat::set — Configures the watcher
  • EvStat::stat — Initiates the stat call


Returns the values most recently detected by Ev

  • « EvStat
  • EvStat::__construct »
  • PHP Manual
  • EvStat
  • Returns the values most recently detected by Ev

EvStat::attr

(PECL ev >= 0.2.0)

EvStat::attr — Returns the values most recently detected by Ev

Descripción

public EvStat::attr ( ) : array

Returns array of the values most recently detected by Ev

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns array with the values most recently detect by Ev(without actual stat 'ing):

List for item keys of the array returned by EvStat::attr()
Key | Description
'dev' | ID of device containing file
'ino' | inode number
'mode' | protection
'nlink' | number of hard links
'uid' | user ID of owner
'size' | total size, in bytes
'gid' | group ID of owner
'rdev' | device ID (if special file)
'blksize' | blocksize for file system I/O
'blocks' | number of 512B blocks allocated
'atime' | time of last access
'ctime' | time of last status change
'mtime' | time of last modification

See stat(2) man page for details.

Ejemplos

Ejemplo #1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

Ver también

  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr
  • EvStat::stat() - Initiates the stat call


Constructs EvStat watcher object

  • « EvStat::attr
  • EvStat::createStopped »
  • PHP Manual
  • EvStat
  • Constructs EvStat watcher object

EvStat::__construct

(PECL ev >= 0.2.0)

EvStat::__construct — Constructs EvStat watcher object

Descripción

public EvStat::__construct ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 )

Constructs EvStat watcher object and starts the watcher automatically.

Parámetros

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvStat watcher object on succes.

Ejemplos

Ejemplo #1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
 echo "/var/log/messages changed\n";

 $attr = $w->attr();

 if ($attr['nlink']) {
  printf("Current size: %ld\n", $attr['size']);
  printf("Current atime: %ld\n", $attr['atime']);
  printf("Current mtime: %ld\n", $attr['mtime']);
 } else {
  fprintf(STDERR, "`messages` file is not there!");
  $w->stop();
 }
});

Ev::run();
?>


Create a stopped EvStat watcher object

  • « EvStat::__construct
  • EvStat::prev »
  • PHP Manual
  • EvStat
  • Create a stopped EvStat watcher object

EvStat::createStopped

(PECL ev >= 0.2.0)

EvStat::createStopped — Create a stopped EvStat watcher object

Descripción

final public static EvStat::createStopped ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : void

Creates EvStat watcher object, but doesn't start it automatically(unlike EvStat::__construct() ).

Parámetros

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns a stopped EvStat watcher object on success.

Ver también

  • EvStat::__construct() - Constructs EvStat watcher object
  • EvWatcher::start() - Starts the watcher


Returns the previous set of values returned by EvStat::attr

  • « EvStat::createStopped
  • EvStat::set »
  • PHP Manual
  • EvStat
  • Returns the previous set of values returned by EvStat::attr

EvStat::prev

(PECL ev >= 0.2.0)

EvStat::prev — Returns the previous set of values returned by EvStat::attr

Descripción

public EvStat::prev ( ) : void

Just like EvStat::attr() , but returns the previous set of values.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array with the same structure as the array returned by EvStat::attr() . The array contains previously detected values.

Ver también

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::stat() - Initiates the stat call


Configures the watcher

  • « EvStat::prev
  • EvStat::stat »
  • PHP Manual
  • EvStat
  • Configures the watcher

EvStat::set

(PECL ev >= 0.2.0)

EvStat::set — Configures the watcher

Descripción

public EvStat::set ( string $path , float $interval ) : void

Configures the watcher.

Parámetros

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

Valores devueltos

No devuelve ningún valor.


Initiates the stat call

  • « EvStat::set
  • EvTimer »
  • PHP Manual
  • EvStat
  • Initiates the stat call

EvStat::stat

(PECL ev >= 0.2.0)

EvStat::stat — Initiates the stat call

Descripción

public EvStat::stat ( ) : bool

Initiates the stat call(updates internal cache). It stats(using lstat ) the path specified in the watcher and sets to the values found.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if path exists. Otherwise false.

Ver también

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr


The EvTimer class

(PECL ev >= 0.2.0)

Introducción

EvTimer watchers are simple relative timers that generate an event after a given time, and optionally repeating in regular intervals after that.

The timers are based on real time, that is, if one registers an event that times out after an hour and resets the system clock to January last year , it will still time out after(roughly) one hour. "Roughly" because detecting time jumps is hard, and some inaccuracies are unavoidable.

The callback is guaranteed to be invoked only after its timeout has passed (not at, so on systems with very low-resolution clocks this might introduce a small delay). If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones of the same priority with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

The timer itself will do a best-effort at avoiding drift, that is, if a timer is configured to trigger every 10 seconds, then it will normally trigger at exactly 10 second intervals. If, however, the script cannot keep up with the timer because it takes longer than those 10 seconds to do) the timer will not fire more than once per event loop iteration.

Sinopsis de la Clase

EvTimer extends EvWatcher {
/* Propiedades */
public $repeat ;
public $remaining ;
/* Propiedades heredadas */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public again ( ) : void
public __construct ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer
public set ( float $after , float $repeat ) : void
/* Métodos heredados */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Propiedades

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

remaining

Returns the remaining time until a timer fires. If the timer is active, then this time is relative to the current event loop time, otherwise it's the timeout value currently configured.

That is, after instanciating an EvTimer with an after value of 5.0 and repeat value of 7.0 , remaining returns 5.0 . When the timer is started and one second passes, remaining will return 4.0 . When the timer expires and is restarted, it will return roughly 7.0 (likely slightly less as callback invocation takes some time too), and so on.

Tabla de contenidos

  • EvTimer::again — Restarts the timer watcher
  • EvTimer::__construct — Constructs an EvTimer watcher object
  • EvTimer::createStopped — Creates EvTimer stopped watcher object
  • EvTimer::set — Configures the watcher


Restarts the timer watcher

  • « EvTimer
  • EvTimer::__construct »
  • PHP Manual
  • EvTimer
  • Restarts the timer watcher

EvTimer::again

(PECL ev >= 0.2.0)

EvTimer::again — Restarts the timer watcher

Descripción

public EvTimer::again ( ) : void

This will act as if the timer timed out and restart it again if it is repeating. The exact semantics are:

  1. if the timer is pending, its pending status is cleared.

  2. if the timer is started but non-repeating, stop it (as if it timed out).

  3. if the timer is repeating, either start it if necessary (with the repeat value), or reset the running timer to the repeat value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvWatcher::stop() - Stops the watcher


Constructs an EvTimer watcher object

  • « EvTimer::again
  • EvTimer::createStopped »
  • PHP Manual
  • EvTimer
  • Constructs an EvTimer watcher object

EvTimer::__construct

(PECL ev >= 0.2.0)

EvTimer::__construct — Constructs an EvTimer watcher object

Descripción

public EvTimer::__construct ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 )

Constructs an EvTimer watcher object.

Parámetros

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvTimer object on success.

Ejemplos

Ejemplo #1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

El resultado del ejemplo sería algo similar a:

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

Ver también

  • EvTimer::createStopped() - Creates EvTimer stopped watcher object
  • EvPeriodic
  • » ev_timer - relative and optionally repeating timeouts
  • » Be smart about timeouts


Creates EvTimer stopped watcher object

  • « EvTimer::__construct
  • EvTimer::set »
  • PHP Manual
  • EvTimer
  • Creates EvTimer stopped watcher object

EvTimer::createStopped

(PECL ev >= 0.2.0)

EvTimer::createStopped — Creates EvTimer stopped watcher object

Descripción

final public static EvTimer::createStopped ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer

Creates EvTimer stopped watcher object. Unlike EvTimer::__construct() , this method doesn't start the watcher automatically.

Parámetros

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Valores devueltos

Returns EvTimer watcher object on success.

Ejemplos

Ejemplo #1 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

Ver también

  • EvTimer::__construct() - Constructs an EvTimer watcher object
  • EvPeriodic


Configures the watcher

  • « EvTimer::createStopped
  • EvWatcher »
  • PHP Manual
  • EvTimer
  • Configures the watcher

EvTimer::set

(PECL ev >= 0.2.0)

EvTimer::set — Configures the watcher

Descripción

public EvTimer::set ( float $after , float $repeat ) : void

Configures the watcher

Parámetros

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

Valores devueltos

No devuelve ningún valor.


The EvWatcher class

(PECL ev >= 0.2.0)

Introducción

EvWatcher is a base class for all watchers( EvCheck , EvChild etc.). Since EvWatcher 's constructor is abstract , one can't(and don't need to) create EvWatcher objects directly.

Sinopsis de la Clase

abstract EvWatcher {
/* Propiedades */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Métodos */
public clear ( ) : int
abstract public __construct ( )
public feed ( int $revents ) : void
public getLoop ( ) : EvLoop
public invoke ( int $revents ) : void
public keepalive ( bool $value = ? ) : bool
public setCallback ( callable $callback ) : void
public start ( ) : void
public stop ( ) : void
}

Propiedades

is_active

Readonly . true if the watcher is active. false otherwise.

data

User custom data associated with the watcher

is_pending

Readonly .true if the watcher is pending, i.e. it has outstanding events, but its callback has not yet been invoked. false otherwise. As long, as a watcher is pending(but not active), one must not change its priority.

priority

int between Ev::MINPRI and Ev::MAXPRI . Pending watchers with higher priority will be invoked before watchers with lower priority, but priority will not keep watchers from being executed(except for EvIdle watchers). EvIdle watchers provide functionality to suppress invocation when higher priority events are pending.

Tabla de contenidos

  • EvWatcher::clear — Clear watcher pending status
  • EvWatcher::__construct — Abstract constructor of a watcher object
  • EvWatcher::feed — Feeds the given revents set into the event loop
  • EvWatcher::getLoop — Returns the loop responsible for the watcher
  • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
  • EvWatcher::keepalive — Configures whether to keep the loop from returning
  • EvWatcher::setCallback — Sets new callback for the watcher
  • EvWatcher::start — Starts the watcher
  • EvWatcher::stop — Stops the watcher


Clear watcher pending status

  • « EvWatcher
  • EvWatcher::__construct »
  • PHP Manual
  • EvWatcher
  • Clear watcher pending status

EvWatcher::clear

(PECL ev >= 0.2.0)

EvWatcher::clear — Clear watcher pending status

Descripción

public EvWatcher::clear ( ) : int

If the watcher is pending, this method clears its pending status and returns its revents bitset(as if its callback was invoked). If the watcher isn't pending it does nothing and returns 0 .

Sometimes it can be useful to "poll" a watcher instead of waiting for its callback to be invoked, which can be accomplished with this function.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

In case if the watcher is pending, returns revents bitset as if the watcher callback had been invoked. Otherwise returns 0 .


Abstract constructor of a watcher object

  • « EvWatcher::clear
  • EvWatcher::feed »
  • PHP Manual
  • EvWatcher
  • Abstract constructor of a watcher object

EvWatcher::__construct

(PECL ev >= 0.2.0)

EvWatcher::__construct — Abstract constructor of a watcher object

Descripción

abstract public EvWatcher::__construct ( )

EvWatcher::__construct() is an abstract constructor of a watcher object implemented in the derived classes.


Feeds the given revents set into the event loop

  • « EvWatcher::__construct
  • EvWatcher::getLoop »
  • PHP Manual
  • EvWatcher
  • Feeds the given revents set into the event loop

EvWatcher::feed

(PECL ev >= 0.2.0)

EvWatcher::feed — Feeds the given revents set into the event loop

Descripción

public EvWatcher::feed ( int $revents ) : void

Feeds the given revents set into the event loop, as if the specified event had happened for the watcher.

Parámetros

revents

Bit mask of watcher received events .

Valores devueltos

No devuelve ningún valor.


Returns the loop responsible for the watcher

  • « EvWatcher::feed
  • EvWatcher::invoke »
  • PHP Manual
  • EvWatcher
  • Returns the loop responsible for the watcher

EvWatcher::getLoop

(PECL ev >= 0.2.0)

EvWatcher::getLoop — Returns the loop responsible for the watcher

Descripción

public EvWatcher::getLoop ( ) : EvLoop

Returns the loop responsible for the watcher

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns EvLoop event loop object responsible for the watcher.


Invokes the watcher callback with the given received events bit mask

  • « EvWatcher::getLoop
  • EvWatcher::keepalive »
  • PHP Manual
  • EvWatcher
  • Invokes the watcher callback with the given received events bit mask

EvWatcher::invoke

(PECL ev >= 0.2.0)

EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask

Descripción

public EvWatcher::invoke ( int $revents ) : void

Invokes the watcher callback with the given received events bit mask.

Parámetros

revents

Bit mask of watcher received events .

Valores devueltos

No devuelve ningún valor.


Configures whether to keep the loop from returning

  • « EvWatcher::invoke
  • EvWatcher::setCallback »
  • PHP Manual
  • EvWatcher
  • Configures whether to keep the loop from returning

EvWatcher::keepalive

(PECL ev >= 0.2.0)

EvWatcher::keepalive — Configures whether to keep the loop from returning

Descripción

public EvWatcher::keepalive ( bool $value = ? ) : bool

Configures whether to keep the loop from returning. With keepalive value set to false the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

Watchers have keepalive value true by default.

Clearing keepalive status is useful when returning from Ev::run() / EvLoop::run() just because of the watcher is undesirable. It could be a long running UDP socket watcher or so.

Parámetros

value

With keepalive value set to false the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

Valores devueltos

Returns the previous state.

Ejemplos

Ejemplo #1 Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.

<?php
$udp_socket = ...
$udp_watcher = new EvIo($udp_socket, Ev::READ, function () { /* ... */ });
$udp_watcher->keepalive(FALSE);
?>


Sets new callback for the watcher

  • « EvWatcher::keepalive
  • EvWatcher::start »
  • PHP Manual
  • EvWatcher
  • Sets new callback for the watcher

EvWatcher::setCallback

(PECL ev >= 0.2.0)

EvWatcher::setCallback — Sets new callback for the watcher

Descripción

public EvWatcher::setCallback ( callable $callback ) : void

Sets new callback for the watcher

Parámetros

callback

See Watcher callbacks .

Valores devueltos

No devuelve ningún valor.


Starts the watcher

  • « EvWatcher::setCallback
  • EvWatcher::stop »
  • PHP Manual
  • EvWatcher
  • Starts the watcher

EvWatcher::start

(PECL ev >= 0.2.0)

EvWatcher::start — Starts the watcher

Descripción

public EvWatcher::start ( ) : void

Marks the watcher as active. Note that only active watchers will receive events.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvWatcher::stop() - Stops the watcher


Stops the watcher

  • « EvWatcher::start
  • Expect »
  • PHP Manual
  • EvWatcher
  • Stops the watcher

EvWatcher::stop

(PECL ev >= 0.2.0)

EvWatcher::stop — Stops the watcher

Descripción

public EvWatcher::stop ( ) : void

Marks the watcher as inactive. Note that only active watchers will receive events.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EvWatcher::start() - Starts the watcher


Expect

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ejemplos de uso de Expect
  • Funciones de Expect
    • expect_expectl — Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF
    • expect_popen — Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso


Introducción

Esta extensión permite interactuar con procesos mediante PTY. Se recomienda tener en cuenta la envoltura expect:// junto con las funciones del sistema de ficheros, lo cual ofrece una interfaz más sencilla e intuitiva.


Requerimientos

Este módulo utiliza las funciones de la biblioteca » expect. Se necesita la versión de libexpect >= 5.43.0.


Instalación

Esta extensión » PECL no se distribuye con PHP. Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/expect.

Para poder utilizar estas funciones, se debe compilar PHP con soporte para expect utilizando la opción de configuración --with-expect[=DIR].

Los usuarios de Windows deben habilitar php_expect.dll dentro del fichero php.ini para poder utilizar estas funciones. Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

La extensión Expect se configura mediante opciones del fichero de configuración php.ini.

Opciones de configuración de Expect
Nombre | Por defecto | Cambiable | Registro de cambios
expect.timeout | "10" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.logfile | "" | PHP_INI_ALL |
expect.match_max | "" | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

expect.timeout integer

Tiempo de espera de datos, al usar la función expect_expectl().

"-1" deshabilita el tiempo de espera.

Nota:

"0" provoca que expect_expectl() devuelva el control inmediatamente.

expect.loguser boolean

Indica si Expect debe enviar alguna salida del proceso creado a la salida estándar. Dado que normalmente los programas interactivos imprimen en pantalla los datos de entrada, esto sería suficiente para poder mostrar los dos lados de la conversación.

expect.logfile string

Nombre del fichero en el que se escribirá la salida del proceso creado. Si no existiera, se crearía.

Nota:

Si se establece un valor, se escribe la salida independientemente del valor de expect.loguser.

expect.match_max integer

Cambia el tamaño por omisión (2000 bytes) del buffer utilizado para que coincida con los asteriscos en el patrón.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

expect_popen() devuelve el flujo del PTY usado por expect_expectl().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

EXP_GLOB (integer)
Indica que el patrón es del tipo glob (tipo Unix).
EXP_EXACT (integer)
Indica que el patrón es una cadena exacta.
EXP_REGEXP (integer)
Indica que el patrón es un texto de tipo expresión regular.
EXP_EOF (integer)
Valor, devuelto por expect_expectl(), cada vez que se alcanza EOF (fin del fichero).
EXP_TIMEOUT (integer)
Valor, devuelto por expect_expectl() pasados unos determinados segundos, con el valor especificado en expect.timeout
EXP_FULLBUFFER (integer)
Valor, devuelto por expect_expectl() si no coincidiera ningún patrón.


  • « Constantes predefinidas
  • Ejemplos de uso de Expect »
  • PHP Manual
  • Expect
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplos de uso de Expect


Ejemplos de uso de Expect

Ejemplo #1 Ejemplo de uso de Expect

Este ejemplo conecta a un host remoto mediante SSH, y muestra el tiempo que lleva en funcionamiento dicho host con uptime.

<?php
ini_set("expect.loguser", "Off");

$stream = fopen("expect://ssh root@remotehost uptime", "r");

$cases = array (
    array (0 => "password:", 1 => PASSWORD)
);

switch (expect_expectl ($stream, $cases)) {
    case PASSWORD:
        fwrite ($stream, "password\n");
        break;

    default:
        die ("Error al tratar de conectar con el host remoto\n");
}

while ($line = fgets($stream)) {
      print $line;
}
fclose ($stream);
?>

El siguiente ejemplo conecta con un host remoto, determina si el SO instalado es de 32 o de 64 bits, y finalmente actualiza el paquete que corresponda.

Ejemplo #2 Otro ejemplo de uso de Expect

<?php
ini_set("expect.timeout", -1);
ini_set("expect.loguser", "Off");

$stream = expect_popen("ssh root@remotehost");

while (true) {
    switch (expect_expectl ($stream, array (
            array ("password:", PASSWORD), // SSH pide contraseña
            array ("yes/no)?", YESNO), // SSH pide si almacenar o no el host
            array ("~$ ", SHELL, EXP_EXACT), // ¡Hemos conectado!
    ))) {
        case PASSWORD:
            fwrite ($stream, "secret\n");
            break;

        case YESNO:
            fwrite ($stream, "yes\n");
            break;

        case SHELL:
            fwrite ($stream, "uname -a\n");
            while (true) {
                    switch (expect_expectl ($stream, array (
                            array ("~$ ", SHELL, EXP_EXACT), // ¡Hemos conectado!
                            array ("^Linux.*$", UNAME, EXP_REGEXP), // salida de uname -a
                    ), $match)) {
                        case UNAME:
                            $uname .= $match[0];
                            break;

                        case SHELL:
                            // Run update:
                            if (strstr ($uname, "x86_64")) {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_64bit.rpm\n");
                            } else {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_32bit.rpm\n");
                            }
                            fwrite ($stream, "exit\n");
                            break 2;

                        case EXP_TIMEOUT:
                        case EXP_EOF:
                            break 2;

                        default:
                            die ("Ha ocurrido un error\n");
                    }
            }
            break 2;

        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2;

        default:
            die ("Ha ocurrido un error\n");
    }
}

fclose ($stream);
?>


Funciones de Expect

Tabla de contenidos

  • expect_expectl — Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF
  • expect_popen — Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso


Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF

  • « Funciones de Expect
  • expect_popen »
  • PHP Manual
  • Funciones de Expect
  • Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF

expect_expectl

(PECL expect >= 0.1.0)

expect_expectl — Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF

Descripción

expect_expectl ( resource $expect , array $cases , array &$match = ? ) : int

Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF.

Si se proporciona el parámetro match, se le asignará el resultado de la búsqueda. La cadena que coincide se encuentra en match[0]. Las subcadenas que coincidan (de acuerdo a los paréntesis) con el patrón original se encuentran en match[1], match[2], y así hasta match[9] (límite establecido por libexpect).

Parámetros

expect

Flujo de Expect, abierto anteriormente con expect_popen().

cases

Matriz con casos de expect. Cada caso será un array indexado, tal como se describe en la siguiente tabla:

Array de Caso de Expect
Clave de índice | Tipo de valor | Descripción | Es Obligatorio | Valor por omisión
0 | string | patrón, que buscará coincidencias en la salida del flujo | sí
1 | mixto | valor, que devolverá esta función, si coincidiera el patrón | sí
2 | integer | tipo de patrón, de entre: EXP_GLOB, EXP_EXACT o EXP_REGEXP | no | EXP_GLOB

Valores devueltos

Devuelve valores asociados con el patrón que coincida.

En caso de error esta función devuelve: EXP_EOF, EXP_TIMEOUT o EXP_FULLBUFFER

Historial de cambios

Versión | Descripción
0.2.1 | Antes de la versión 0.2.1, en el parámetro match se devolvía el string que coincidiera, no un array de substrings coincidentes.

Ejemplos

Ejemplo #1 Ejemplo de expect_expectl()

<?php
// Copias de los archivos de host remoto:
ini_set("expect.timeout", 30);

$stream = fopen("expect://scp user@remotehost:/var/log/messages /home/user/messages.txt", "r");

$cases = array(
    // array(patrón, valor que se devolverá si el patrón es encontrado)
    array("password:", "asked for password"),
    array("yes/no)?",  "asked for yes/no")
);

while (true) {
    switch (expect_expectl($stream, $cases)) {
        case "asked for password":
            fwrite($stream, "my password\n");
            break;
        case "asked for yes/no":
            fwrite($stream, "yes\n");
            break;
        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2; // break tanto la sentencia switch y el bucle while
        default:
            die "Error has occurred!";
    }
}

fclose($stream);
?>

Ver también

  • expect_popen() - Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso


Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso

  • « expect_expectl
  • PCNTL »
  • PHP Manual
  • Funciones de Expect
  • Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso

expect_popen

(PECL expect >= 0.1.0)

expect_popen — Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso

Descripción

expect_popen ( string $command ) : resource

Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso.

Parámetros

command

Comando a ejecutar.

Valores devueltos

Devuelve un flujo PTY abierto al stdio, stdout, y stderr del prceso.

En caso de error, devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de expect_popen()

<?php
// Entrar en el repositorio CVS de PHP.net
$stream = expect_popen ("cvs -d :pserver:anonymous@cvs.php.net:/repository login");
sleep (3);
fwrite ($stream, "phpfi\n");
fclose ($stream);
?>

Ver también

  • popen() - Abre un proceso de un puntero a un fichero


Control de procesos

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Basic usage
  • Funciones PCNTL
    • pcntl_alarm — Set an alarm clock for delivery of a signal
    • pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting
    • pcntl_errno — Alias de pcntl_get_last_error
    • pcntl_exec — Executes specified program in current process space
    • pcntl_fork — Forks the currently running process
    • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
    • pcntl_getpriority — Get the priority of any process
    • pcntl_setpriority — Change the priority of any process
    • pcntl_signal_dispatch — Calls signal handlers for pending signals
    • pcntl_signal_get_handler — Get the current handler for specified signal
    • pcntl_signal — Installs a signal handler
    • pcntl_sigprocmask — Sets and retrieves blocked signals
    • pcntl_sigtimedwait — Waits for signals, with a timeout
    • pcntl_sigwaitinfo — Waits for signals
    • pcntl_strerror — Retrieve the system error message associated with the given errno
    • pcntl_wait — Waits on or returns the status of a forked child
    • pcntl_waitpid — Waits on or returns the status of a forked child
    • pcntl_wexitstatus — Returns the return code of a terminated child
    • pcntl_wifexited — Checks if status code represents a normal exit
    • pcntl_wifsignaled — Checks whether the status code represents a termination due to a signal
    • pcntl_wifstopped — Checks whether the child process is currently stopped
    • pcntl_wstopsig — Returns the signal which caused the child to stop
    • pcntl_wtermsig — Returns the signal which caused the child to terminate


Introducción

El soporte para el Control de Procesos en PHP implementa el estilo UNIX de creación de procesos, ejecución de programas, gestión de señales y terminación de procesos. El Control de Procesos no debería estar habilitado en un entorno de servidor web, ya que podrían ocurrir resultados inesperados si cualquier función del Control de Procesos es usada dentro de dichos entornos.

Esta documentación busca explicar el uso general de cada una de las funciones del Control de Procesos. Para obtener información detallada sobre el control de procesos de UNIX se recomienda consultar la documentación del sistema incluyendo fork(2), waitpid(2) y signal(2) o una referencia completa, como el libro "Advanced Programming in the UNIX Environment" de W. Richard Stevens (Addison-Wesley).

PCNTL ahora usa pulsos (ticks) como mecanismo de retrollamada de manejadores de señal, que es mucho más rápido que el mecanismo previo. Este cambio sigue la misma semántica que usar "pulsos de usuario". Se usa la sentencia declare() para especificar los lugares del programa donde se permiten que sucedan las retrollamadas. Esto te permite minimizar la sobrecarga de manejar eventos asincrónicos. En el pasado, compilar PHP con pcntl habilitado siempre provocaba esta sobrecarga, sin importar si el script realmente empleaba pcntl.

Existe un ajuste que todos los scripts de pcntl anteriores a PHP 4.3.0 deben realizar para que funcionen, que es o bien usar declare() en una sección donde se desean permitir las retrollamadas o simplemente habilitarlas a lo largo del script usando la nueva sintaxsis global de declare().

Nota: Esta extensión no está disponible en plataformas Windows.


Instalación

Soporte de Control de procesos en PHP no está habilitado de forma predeterminada. Tiene que compilar la versión CGI o CLI de PHP con la opción de configuración --enable-pcntl al compilar PHP para habilitar el soporte de Control de procesos.

Nota:

Actualmente, este módulo no funciona en las plataformas no Unix (Windows).


Constantes predefinidas

The following list of signals are supported by the Process Control functions. Please see your systems signal(7) man page for details of the default behavior of these signals.

WNOHANG (int)
WUNTRACED (int)
SIG_IGN (int)
SIG_DFL (int)
SIG_ERR (int)
SIGHUP (int)
SIGINT (int)
SIGQUIT (int)
SIGILL (int)
SIGTRAP (int)
SIGABRT (int)
SIGIOT (int)
SIGBUS (int)
SIGFPE (int)
SIGKILL (int)
SIGUSR1 (int)
SIGSEGV (int)
SIGUSR2 (int)
SIGPIPE (int)
SIGALRM (int)
SIGTERM (int)
SIGSTKFLT (int)
SIGCLD (int)
SIGCHLD (int)
SIGCONT (int)
SIGSTOP (int)
SIGTSTP (int)
SIGTTIN (int)
SIGTTOU (int)
SIGURG (int)
SIGXCPU (int)
SIGXFSZ (int)
SIGVTALRM (int)
SIGPROF (int)
SIGWINCH (int)
SIGPOLL (int)
SIGIO (int)
SIGPWR (int)
SIGSYS (int)
SIGBABY (int)
SIG_BLOCK (int)
Available since PHP 5.3.0.
SIG_UNBLOCK (int)
Available since PHP 5.3.0.
SIG_SETMASK (int)
Available since PHP 5.3.0.
SI_USER (int)
Available since PHP 5.3.0.
SI_NOINFO (int)
Available since PHP 5.3.0.
SI_KERNEL (int)
Available since PHP 5.3.0.
SI_QUEUE (int)
Available since PHP 5.3.0.
SI_TIMER (int)
Available since PHP 5.3.0.
SI_MSGGQ (int)
Available since PHP 5.3.0.
SI_ASYNCIO (int)
Available since PHP 5.3.0.
SI_SIGIO (int)
Available since PHP 5.3.0.
SI_TKILL (int)
Available since PHP 5.3.0.
CLD_EXITED (int)
Available since PHP 5.3.0.
CLD_KILLED (int)
Available since PHP 5.3.0.
CLD_DUMPED (int)
Available since PHP 5.3.0.
CLD_TRAPPED (int)
Available since PHP 5.3.0.
CLD_STOPPED (int)
Available since PHP 5.3.0.
CLD_CONTINUED (int)
Available since PHP 5.3.0.
TRAP_BRKPT (int)
Available since PHP 5.3.0.
TRAP_TRACE (int)
Available since PHP 5.3.0.
POLL_IN (int)
Available since PHP 5.3.0.
POLL_OUT (int)
Available since PHP 5.3.0.
POLL_MSG (int)
Available since PHP 5.3.0.
POLL_ERR (int)
Available since PHP 5.3.0.
POLL_PRI (int)
Available since PHP 5.3.0.
POLL_HUP (int)
Available since PHP 5.3.0.
ILL_ILLOPC (int)
Available since PHP 5.3.0.
ILL_ILLOPN (int)
Available since PHP 5.3.0.
ILL_ILLADR (int)
Available since PHP 5.3.0.
ILL_ILLTRP (int)
Available since PHP 5.3.0.
ILL_PRVOPC (int)
Available since PHP 5.3.0.
ILL_PRVREG (int)
Available since PHP 5.3.0.
ILL_COPROC (int)
Available since PHP 5.3.0.
ILL_BADSTK (int)
Available since PHP 5.3.0.
FPE_INTDIV (int)
Available since PHP 5.3.0.
FPE_INTOVF (int)
Available since PHP 5.3.0.
FPE_FLTDIV (int)
Available since PHP 5.3.0.
FPE_FLTOVF (int)
Available since PHP 5.3.0.
FPE_FLTUND (int)
Available since PHP 5.3.0.
FPE_FLTRES (int)
Available since PHP 5.3.0.
FPE_FLTINV (int)
Available since PHP 5.3.0.
FPE_FLTSUB (int)
Available since PHP 5.3.0.
SEGV_MAPERR (int)
Available since PHP 5.3.0.
SEGV_ACCERR (int)
Available since PHP 5.3.0.
BUS_ADRALN (int)
Available since PHP 5.3.0.
BUS_ADRERR (int)
Available since PHP 5.3.0.
BUS_OBJERR (int)
Available since PHP 5.3.0.


  • « Constantes predefinidas
  • Basic usage »
  • PHP Manual
  • PCNTL
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Basic usage


Basic usage

This example forks off a daemon process with a signal handler.

Ejemplo #1 Process Control Example

<?php
declare(ticks=1);

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     exit(); // we are the parent
} else {
     // we are the child
}

// detach from the controlling terminal
if (posix_setsid() == -1) {
    die("could not detach from terminal");
}

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// loop forever performing tasks
while (1) {

    // do something interesting here

}

function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         default:
             // handle all other signals
     }

}

?>


Funciones PCNTL

Ver también

Echar una ojeada a la sección sobre las funciones POSIX puede ser útil.

Tabla de contenidos

  • pcntl_alarm — Set an alarm clock for delivery of a signal
  • pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting
  • pcntl_errno — Alias de pcntl_get_last_error
  • pcntl_exec — Executes specified program in current process space
  • pcntl_fork — Forks the currently running process
  • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
  • pcntl_getpriority — Get the priority of any process
  • pcntl_setpriority — Change the priority of any process
  • pcntl_signal_dispatch — Calls signal handlers for pending signals
  • pcntl_signal_get_handler — Get the current handler for specified signal
  • pcntl_signal — Installs a signal handler
  • pcntl_sigprocmask — Sets and retrieves blocked signals
  • pcntl_sigtimedwait — Waits for signals, with a timeout
  • pcntl_sigwaitinfo — Waits for signals
  • pcntl_strerror — Retrieve the system error message associated with the given errno
  • pcntl_wait — Waits on or returns the status of a forked child
  • pcntl_waitpid — Waits on or returns the status of a forked child
  • pcntl_wexitstatus — Returns the return code of a terminated child
  • pcntl_wifexited — Checks if status code represents a normal exit
  • pcntl_wifsignaled — Checks whether the status code represents a termination due to a signal
  • pcntl_wifstopped — Checks whether the child process is currently stopped
  • pcntl_wstopsig — Returns the signal which caused the child to stop
  • pcntl_wtermsig — Returns the signal which caused the child to terminate


Set an alarm clock for delivery of a signal

  • « Funciones PCNTL
  • pcntl_async_signals »
  • PHP Manual
  • Funciones PCNTL
  • Set an alarm clock for delivery of a signal

pcntl_alarm

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pcntl_alarm — Set an alarm clock for delivery of a signal

Descripción

pcntl_alarm ( int $seconds ) : int

Creates a timer that will send a SIGALRM signal to the process after the given number of seconds. Any call to pcntl_alarm() will cancel any previously set alarm.

Parámetros

seconds

The number of seconds to wait. If seconds is zero, no new alarm is created.

Valores devueltos

Returns the time in seconds that any previously scheduled alarm had remaining before it was to be delivered, or 0 if there was no previously scheduled alarm.


Enable/disable asynchronous signal handling or return the old setting

  • « pcntl_alarm
  • pcntl_errno »
  • PHP Manual
  • Funciones PCNTL
  • Enable/disable asynchronous signal handling or return the old setting

pcntl_async_signals

(PHP 7 >= 7.1.0, PHP 8)

pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting

Descripción

pcntl_async_signals ( bool $on = null ) : bool

If the on parameter is omitted, pcntl_async_signals() returns whether asynchronous signal handling is enabled. Otherwise, asynchronous signal handling is enabled or disabled.

Parámetros

on

Whether asynchronous signal handling should be enabled.

Valores devueltos

When used as getter (that is without the optional parameter) it returns whether asynchronous signal handling is enabled. When used as setter (that is with the optional parameter given), it returns whether asynchronous signal handling was enabled before the function call.

Ver también

  • declare


Alias de pcntl_get_last_error

  • « pcntl_async_signals
  • pcntl_exec »
  • PHP Manual
  • Funciones PCNTL
  • Alias de pcntl_get_last_error

pcntl_errno

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_errno — Alias de pcntl_get_last_error()

Descripción

Esta función es un alias de: pcntl_get_last_error()


Executes specified program in current process space

  • « pcntl_errno
  • pcntl_fork »
  • PHP Manual
  • Funciones PCNTL
  • Executes specified program in current process space

pcntl_exec

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pcntl_exec — Executes specified program in current process space

Descripción

pcntl_exec ( string $path , array $args = ? , array $envs = ? ) : void

Executes the program with the given arguments.

Parámetros

path

path must be the path to a binary executable or a script with a valid path pointing to an executable in the shebang ( #!/usr/local/bin/perl for example) as the first line. See your system's man execve(2) page for additional information.

args

args is an array of argument strings passed to the program.

envs

envs is an array of strings which are passed as environment to the program. The array is in the format of name => value, the key being the name of the environmental variable and the value being the value of that variable.

Valores devueltos

devuelve null en caso de éxito o false en caso de error.


Forks the currently running process

  • « pcntl_exec
  • pcntl_get_last_error »
  • PHP Manual
  • Funciones PCNTL
  • Forks the currently running process

pcntl_fork

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_fork — Forks the currently running process

Descripción

pcntl_fork ( ) : int

The pcntl_fork() function creates a child process that differs from the parent process only in its PID and PPID. Please see your system's fork(2) man page for specific details as to how fork works on your system.

Valores devueltos

On success, the PID of the child process is returned in the parent's thread of execution, and a 0 is returned in the child's thread of execution. On failure, a -1 will be returned in the parent's context, no child process will be created, and a PHP error is raised.

Ejemplos

Ejemplo #1 pcntl_fork() example

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die('could not fork');
} else if ($pid) {
     // we are the parent
     pcntl_wait($status); //Protect against Zombie children
} else {
     // we are the child
}

?>

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_signal() - Installs a signal handler
  • setproctitle() - Establecer el título de proceso


Retrieve the error number set by the last pcntl function which failed

  • « pcntl_fork
  • pcntl_getpriority »
  • PHP Manual
  • Funciones PCNTL
  • Retrieve the error number set by the last pcntl function which failed

pcntl_get_last_error

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed

Descripción

pcntl_get_last_error ( ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns error code.

Ver también

  • pcntl_strerror() - Retrieve the system error message associated with the given errno


Get the priority of any process

  • « pcntl_get_last_error
  • pcntl_setpriority »
  • PHP Manual
  • Funciones PCNTL
  • Get the priority of any process

pcntl_getpriority

(PHP 5, PHP 7, PHP 8)

pcntl_getpriority — Get the priority of any process

Descripción

pcntl_getpriority ( int $pid = getmypid() , int $process_identifier = PRIO_PROCESS ) : int

pcntl_getpriority() gets the priority of pid. Because priority levels can differ between system types and kernel versions, please see your system's getpriority(2) man page for specific details.

Parámetros

pid

If not specified, the pid of the current process is used.

process_identifier

One of PRIO_PGRP, PRIO_USER or PRIO_PROCESS.

Valores devueltos

pcntl_getpriority() returns the priority of the process or false on error. A lower numerical value causes more favorable scheduling.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ver también

  • pcntl_setpriority() - Change the priority of any process


Change the priority of any process

  • « pcntl_getpriority
  • pcntl_signal_dispatch »
  • PHP Manual
  • Funciones PCNTL
  • Change the priority of any process

pcntl_setpriority

(PHP 5, PHP 7, PHP 8)

pcntl_setpriority — Change the priority of any process

Descripción

pcntl_setpriority ( int $priority , int $pid = getmypid() , int $process_identifier = PRIO_PROCESS ) : bool

pcntl_setpriority() sets the priority of pid.

Parámetros

priority

priority is generally a value in the range -20 to 20. The default priority is 0 while a lower numerical value causes more favorable scheduling. Because priority levels can differ between system types and kernel versions, please see your system's setpriority(2) man page for specific details.

pid

If not specified, the pid of the current process is used.

process_identifier

One of PRIO_PGRP, PRIO_USER or PRIO_PROCESS.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • pcntl_getpriority() - Get the priority of any process


Calls signal handlers for pending signals

  • « pcntl_setpriority
  • pcntl_signal_get_handler »
  • PHP Manual
  • Funciones PCNTL
  • Calls signal handlers for pending signals

pcntl_signal_dispatch

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_signal_dispatch — Calls signal handlers for pending signals

Descripción

pcntl_signal_dispatch ( ) : bool

The pcntl_signal_dispatch() function calls the signal handlers installed by pcntl_signal() for each pending signal.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pcntl_signal_dispatch() example

<?php
echo "Installing signal handler...\n";
pcntl_signal(SIGHUP,  function($signo) {
     echo "signal handler called\n";
});

echo "Generating signal SIGHUP to self...\n";
posix_kill(posix_getpid(), SIGHUP);

echo "Dispatching...\n";
pcntl_signal_dispatch();

echo "Done\n";

?>

El resultado del ejemplo sería algo similar a:

Installing signal handler...
Generating signal SIGHUP to self...
Dispatching...
signal handler called
Done

Ver también

  • pcntl_signal() - Installs a signal handler
  • pcntl_sigprocmask() - Sets and retrieves blocked signals
  • pcntl_sigwaitinfo() - Waits for signals
  • pcntl_sigtimedwait() - Waits for signals, with a timeout


Get the current handler for specified signal

  • « pcntl_signal_dispatch
  • pcntl_signal »
  • PHP Manual
  • Funciones PCNTL
  • Get the current handler for specified signal

pcntl_signal_get_handler

(PHP 7 >= 7.1.0, PHP 8)

pcntl_signal_get_handler — Get the current handler for specified signal

Descripción

pcntl_signal_get_handler ( int $signo ) : mixed

The pcntl_signal_get_handler() function will get the current handler for the specified signo.

Parámetros

signo

The signal number.

Valores devueltos

This function may return an integer value that refers to SIG_DFL or SIG_IGN. If you set a custom handler a string value containing the function name is returned.

Historial de cambios

Versión | Descripción
7.1.0 | pcntl_signal_get_handler() has been added.

Ejemplos

Ejemplo #1 pcntl_signal_get_handler() example

<?php
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

function pcntl_test($signo) {}
pcntl_signal(SIGUSR1, 'pcntl_test');
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: string(10) "pcntl_test"

pcntl_signal(SIGUSR1, SIG_DFL);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

pcntl_signal(SIGUSR1, SIG_IGN);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(1)
?>

Ver también

  • pcntl_signal() - Installs a signal handler


Installs a signal handler

  • « pcntl_signal_get_handler
  • pcntl_sigprocmask »
  • PHP Manual
  • Funciones PCNTL
  • Installs a signal handler

pcntl_signal

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_signal — Installs a signal handler

Descripción

pcntl_signal ( int $signo , callable|int $handler , bool $restart_syscalls = true ) : bool

The pcntl_signal() function installs a new signal handler or replaces the current signal handler for the signal indicated by signo.

Parámetros

signo

The signal number.

handler

The signal handler. This may be either a callable, which will be invoked to handle the signal, or either of the two global constants SIG_IGN or SIG_DFL, which will ignore the signal or restore the default signal handler respectively.

If a callable is given, it must implement the following signature:

handler ( int $signo , mixed $siginfo ) : void
signo
The signal being handled.
siginfo
If operating systems supports siginfo_t structures, this will be an array of signal information dependent on the signal.

Nota:

Note that when you set a handler to an object method, that object's reference count is increased which makes it persist until you either change the handler to something else, or your script ends.

restart_syscalls

Specifies whether system call restarting should be used when this signal arrives.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.1.0 | As of PHP 7.1.0 the handler callback is given a second argument containing the siginfo of the specific signal. This data is only supplied if the operating system has the siginfo_t structure. If the OS does not implement siginfo_t NULL is supplied.

Ejemplos

Ejemplo #1 pcntl_signal() example

<?php
// tick use required
declare(ticks = 1);

// signal handler function
function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         case SIGUSR1:
             echo "Caught SIGUSR1...\n";
             break;
         default:
             // handle all other signals
     }

}

echo "Installing signal handler...\n";

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP,  "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

// or use an object
// pcntl_signal(SIGUSR1, array($obj, "do_something"));

echo"Generating signal SIGUSR1 to self...\n";

// send SIGUSR1 to current process id
// posix_* functions require the posix extension
posix_kill(posix_getpid(), SIGUSR1);

echo "Done\n";

?>

Notas

pcntl_signal() doesn't stack the signal handlers, but replaces them.

Ver también

  • pcntl_fork() - Forks the currently running process
  • pcntl_waitpid() - Waits on or returns the status of a forked child


Sets and retrieves blocked signals

  • « pcntl_signal
  • pcntl_sigtimedwait »
  • PHP Manual
  • Funciones PCNTL
  • Sets and retrieves blocked signals

pcntl_sigprocmask

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigprocmask — Sets and retrieves blocked signals

Descripción

pcntl_sigprocmask ( int $how , array $set , array &$oldset = ? ) : bool

The pcntl_sigprocmask() function adds, removes or sets blocked signals, depending on the how parameter.

Parámetros

how

Sets the behavior of pcntl_sigprocmask(). Possible values:

  • SIG_BLOCK: Add the signals to the currently blocked signals.
  • SIG_UNBLOCK: Remove the signals from the currently blocked signals.
  • SIG_SETMASK: Replace the currently blocked signals by the given list of signals.

set

List of signals.

oldset

The oldset parameter is set to an array containing the list of the previously blocked signals.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 pcntl_sigprocmask() example

<?php
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));
$oldset = array();
pcntl_sigprocmask(SIG_UNBLOCK, array(SIGHUP), $oldset);
?>

Ver también

  • pcntl_sigwaitinfo() - Waits for signals
  • pcntl_sigtimedwait() - Waits for signals, with a timeout


Waits for signals, with a timeout

  • « pcntl_sigprocmask
  • pcntl_sigwaitinfo »
  • PHP Manual
  • Funciones PCNTL
  • Waits for signals, with a timeout

pcntl_sigtimedwait

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigtimedwait — Waits for signals, with a timeout

Descripción

pcntl_sigtimedwait ( array $set , array &$siginfo = ? , int $seconds = 0 , int $nanoseconds = 0 ) : int

The pcntl_sigtimedwait() function operates in exactly the same way as pcntl_sigwaitinfo() except that it takes two additional parameters, seconds and nanoseconds, which enable an upper bound to be placed on the time for which the script is suspended.

Parámetros

set

Array of signals to wait for.

siginfo

The siginfo is set to an array containing information about the signal. See pcntl_sigwaitinfo().

seconds

Timeout in seconds.

nanoseconds

Timeout in nanoseconds.

Valores devueltos

On success, pcntl_sigtimedwait() returns a signal number.

Ver también

  • pcntl_sigprocmask() - Sets and retrieves blocked signals
  • pcntl_sigwaitinfo() - Waits for signals


Waits for signals

  • « pcntl_sigtimedwait
  • pcntl_strerror »
  • PHP Manual
  • Funciones PCNTL
  • Waits for signals

pcntl_sigwaitinfo

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigwaitinfo — Waits for signals

Descripción

pcntl_sigwaitinfo ( array $set , array &$siginfo = ? ) : int

The pcntl_sigwaitinfo() function suspends execution of the calling script until one of the signals given in set are delivered. If one of the signal is already pending (e.g. blocked by pcntl_sigprocmask()), pcntl_sigwaitinfo() will return immediately.

Parámetros

set

Array of signals to wait for.

siginfo

The siginfo parameter is set to an array containing information about the signal.

The following elements are set for all signals:

  • signo: Signal number
  • errno: An error number
  • code: Signal code

The following elements may be set for the SIGCHLD signal:

  • status: Exit value or signal
  • utime: User time consumed
  • stime: System time consumed
  • pid: Sending process ID
  • uid: Real user ID of sending process

The following elements may be set for the SIGILL, SIGFPE, SIGSEGV and SIGBUS signals:

  • addr: Memory location which caused fault

The following element may be set for the SIGPOLL signal:

  • band: Band event
  • fd: File descriptor number

Valores devueltos

On success, pcntl_sigwaitinfo() returns a signal number.

Ejemplos

Ejemplo #1 pcntl_sigwaitinfo() example

<?php
echo "Blocking SIGHUP signal\n";
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));

echo "Sending SIGHUP to self\n";
posix_kill(posix_getpid(), SIGHUP);

echo "Waiting for signals\n";
$info = array();
pcntl_sigwaitinfo(array(SIGHUP), $info);
?>

Ver también

  • pcntl_sigprocmask() - Sets and retrieves blocked signals
  • pcntl_sigtimedwait() - Waits for signals, with a timeout


Retrieve the system error message associated with the given errno

  • « pcntl_sigwaitinfo
  • pcntl_wait »
  • PHP Manual
  • Funciones PCNTL
  • Retrieve the system error message associated with the given errno

pcntl_strerror

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_strerror — Retrieve the system error message associated with the given errno

Descripción

pcntl_strerror ( int $errno ) : string|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

errno

Valores devueltos

Returns error description on success o false en caso de error.

Ver también

  • pcntl_get_last_error() - Retrieve the error number set by the last pcntl function which failed


Waits on or returns the status of a forked child

  • « pcntl_strerror
  • pcntl_waitpid »
  • PHP Manual
  • Funciones PCNTL
  • Waits on or returns the status of a forked child

pcntl_wait

(PHP 5, PHP 7, PHP 8)

pcntl_wait — Waits on or returns the status of a forked child

Descripción

pcntl_wait ( int &$status , int $options = 0 , array &$rusage = ? ) : int

The wait function suspends execution of the current process until a child has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function. If a child has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's wait(2) man page for specific details as to how wait works on your system.

Nota:

This function is equivalent to calling pcntl_waitpid() with a -1 pid and no options.

Parámetros

status

pcntl_wait() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

options

If wait3 is available on your system (mostly BSD-style systems), you can provide the optional options parameter. If this parameter is not provided, wait will be used for the system call. If wait3 is not available, providing a value for options will have no effect. The value of options is the value of zero or more of the following two constants OR'ed together:

Possible values for options
WNOHANG | Return immediately if no child has exited.
WUNTRACED | Return for children which are stopped, and whose status has not been reported.

Valores devueltos

pcntl_wait() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was provided as an option (on wait3-available systems) and no child was available.

Ver también

  • pcntl_fork() - Forks the currently running process
  • pcntl_signal() - Installs a signal handler
  • pcntl_wifexited() - Checks if status code represents a normal exit
  • pcntl_wifstopped() - Checks whether the child process is currently stopped
  • pcntl_wifsignaled() - Checks whether the status code represents a termination due to a signal
  • pcntl_wexitstatus() - Returns the return code of a terminated child
  • pcntl_wtermsig() - Returns the signal which caused the child to terminate
  • pcntl_wstopsig() - Returns the signal which caused the child to stop
  • pcntl_waitpid() - Waits on or returns the status of a forked child


Waits on or returns the status of a forked child

  • « pcntl_wait
  • pcntl_wexitstatus »
  • PHP Manual
  • Funciones PCNTL
  • Waits on or returns the status of a forked child

pcntl_waitpid

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_waitpid — Waits on or returns the status of a forked child

Descripción

pcntl_waitpid ( int $pid , int &$status , int $options = 0 , array &$rusage = ? ) : int

Suspends execution of the current process until a child as specified by the pid argument has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function.

If a child as requested by pid has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's waitpid(2) man page for specific details as to how waitpid works on your system.

Parámetros

pid

The value of pid can be one of the following:

possible values for pid
< -1 | wait for any child process whose process group ID is equal to the absolute value of pid.
-1 | wait for any child process; this is the same behaviour that the wait function exhibits.
0 | wait for any child process whose process group ID is equal to that of the calling process.
> 0 | wait for the child whose process ID is equal to the value of pid.

Nota:

Specifying -1 as the pid is equivalent to the functionality pcntl_wait() provides (minus options).

status

pcntl_waitpid() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

options

The value of options is the value of zero or more of the following two global constants OR'ed together:

possible values for options
WNOHANG | return immediately if no child has exited.
WUNTRACED | return for children which are stopped, and whose status has not been reported.

Valores devueltos

pcntl_waitpid() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was used and no child was available

Ver también

  • pcntl_fork() - Forks the currently running process
  • pcntl_signal() - Installs a signal handler
  • pcntl_wifexited() - Checks if status code represents a normal exit
  • pcntl_wifstopped() - Checks whether the child process is currently stopped
  • pcntl_wifsignaled() - Checks whether the status code represents a termination due to a signal
  • pcntl_wexitstatus() - Returns the return code of a terminated child
  • pcntl_wtermsig() - Returns the signal which caused the child to terminate
  • pcntl_wstopsig() - Returns the signal which caused the child to stop


Returns the return code of a terminated child

  • « pcntl_waitpid
  • pcntl_wifexited »
  • PHP Manual
  • Funciones PCNTL
  • Returns the return code of a terminated child

pcntl_wexitstatus

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wexitstatus — Returns the return code of a terminated child

Descripción

pcntl_wexitstatus ( int $status ) : int

Returns the return code of a terminated child. This function is only useful if pcntl_wifexited() returned true.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns the return code, as an integer.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_wifexited() - Checks if status code represents a normal exit


Checks if status code represents a normal exit

  • « pcntl_wexitstatus
  • pcntl_wifsignaled »
  • PHP Manual
  • Funciones PCNTL
  • Checks if status code represents a normal exit

pcntl_wifexited

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifexited — Checks if status code represents a normal exit

Descripción

pcntl_wifexited ( int $status ) : bool

Checks whether the child status code represents a normal exit.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns true if the child status code represents a normal exit, false otherwise.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_wexitstatus() - Returns the return code of a terminated child


Checks whether the status code represents a termination due to a signal

  • « pcntl_wifexited
  • pcntl_wifstopped »
  • PHP Manual
  • Funciones PCNTL
  • Checks whether the status code represents a termination due to a signal

pcntl_wifsignaled

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifsignaled — Checks whether the status code represents a termination due to a signal

Descripción

pcntl_wifsignaled ( int $status ) : bool

Checks whether the child process exited because of a signal which was not caught.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns true if the child process exited because of a signal which was not caught, false otherwise.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_signal() - Installs a signal handler


Checks whether the child process is currently stopped

  • « pcntl_wifsignaled
  • pcntl_wstopsig »
  • PHP Manual
  • Funciones PCNTL
  • Checks whether the child process is currently stopped

pcntl_wifstopped

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifstopped — Checks whether the child process is currently stopped

Descripción

pcntl_wifstopped ( int $status ) : bool

Checks whether the child process which caused the return is currently stopped; this is only possible if the call to pcntl_waitpid() was done using the option WUNTRACED.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns true if the child process which caused the return is currently stopped, false otherwise.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child


Returns the signal which caused the child to stop

  • « pcntl_wifstopped
  • pcntl_wtermsig »
  • PHP Manual
  • Funciones PCNTL
  • Returns the signal which caused the child to stop

pcntl_wstopsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wstopsig — Returns the signal which caused the child to stop

Descripción

pcntl_wstopsig ( int $status ) : int

Returns the number of the signal which caused the child to stop. This function is only useful if pcntl_wifstopped() returned true.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns the signal number.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_wifstopped() - Checks whether the child process is currently stopped


Returns the signal which caused the child to terminate

  • « pcntl_wstopsig
  • POSIX »
  • PHP Manual
  • Funciones PCNTL
  • Returns the signal which caused the child to terminate

pcntl_wtermsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wtermsig — Returns the signal which caused the child to terminate

Descripción

pcntl_wtermsig ( int $status ) : int

Returns the number of the signal that caused the child process to terminate. This function is only useful if pcntl_wifsignaled() returned true.

Parámetros

status

El parámetro status es el parámetro de estado proporcionado a una correcta llamada a pcntl_waitpid().

Valores devueltos

Returns the signal number, as an integer.

Ver también

  • pcntl_waitpid() - Waits on or returns the status of a forked child
  • pcntl_signal() - Installs a signal handler
  • pcntl_wifsignaled() - Checks whether the status code represents a termination due to a signal


POSIX

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • Constantes para posix_access
    • Constantes para posix_mknod
    • Constantes para posix_setrlimit
  • Funciones POSIX
    • posix_access — Determinar la accesibilidad de un archivo
    • posix_ctermid — Obtener el nombre de la ruta del terminal controlador
    • posix_errno — Alias de posix_get_last_error
    • posix_get_last_error — Recuperar el número de error establecido por la última función posix que ha fallado
    • posix_getcwd — Nombre de la ruta del directorio actual
    • posix_getegid — Devuelve el ID efectivo de grupo del proceso actual
    • posix_geteuid — Devolver el ID efectivo de usuario del proceso actual
    • posix_getgid — Devuelve el ID real de grupo del proceso actual
    • posix_getgrgid — Devolver información sobre un grupo mediante un id de grupo
    • posix_getgrnam — Devolver información sobre un grupo mediante su nombre
    • posix_getgroups — Devolver el conjunto de grupos del proceso actual
    • posix_getlogin — Devuelve el nombre del inicio de sesión
    • posix_getpgid — Obtener el id del grupo de procesos para un control de trabajo
    • posix_getpgrp — Devolver el identificador de grupo de proceso actual
    • posix_getpid — Devolver el identificador del proceso actual
    • posix_getppid — Devolver el identificador del proceso padre
    • posix_getpwnam — Devolver información sobre un usuario mediante su nombre de usuario
    • posix_getpwuid — Devolver información sobre un usuario mediante su id de usuario
    • posix_getrlimit — Devolver información sobre los límites de recursos del sistema
    • posix_getsid — Obtener el sid actual del proceos
    • posix_getuid — Devolver el ID real de usuario del proceso actual
    • posix_initgroups — Calcular la lista de acceso al grupo
    • posix_isatty — Determinar si un descriptor de fichero es un terminal interactiva
    • posix_kill — Enviar una señal a un proceso
    • posix_mkfifo — Crear un archivo especial fifo (un pipe con nombre)
    • posix_mknod — Crear un fichero especial u ordinario (POSIX.1)
    • posix_setegid — Establecer el GID efectivo del proceso actual
    • posix_seteuid — Establecer el UID efectivo del proceso actual
    • posix_setgid — Establecer el GID de proceso actual
    • posix_setpgid — Establecer el id de grupo de procesos para el control de trabajo
    • posix_setrlimit — Establecer los límites de recursos del sistema
    • posix_setsid — Hacer del proceso actual un líder de sesión
    • posix_setuid — Establecer el UID del proceso actual
    • posix_strerror — Recuperar el mensaje de error del sistema asociado con el errno dado
    • posix_times — Obtener los tiempos de procesos
    • posix_ttyname — Determinar el nombre del dispositivo terminal
    • posix_uname — Obtener el nombre del sistema


Introducción

Este módulo contiene una interfaz a aquellas funciones definidas en el documénto de estándares IEEE 1003.1 (POSIX.1) que no son accesibles mediante otros medios.

Advertencia

Se pueden obtener datos sensibles con las funciones de POSIX, p.ej. posix_getpwnam() y similares.

Nota: Esta extensión no está disponible en plataformas Windows.


Instalación

Las funciones POSIX son habilitadas por defecto. Puede deshabilitar las funciones tipo POSIX con --disable-posix.


Constantes predefinidas

Tabla de contenidos

  • Constantes para posix_access
  • Constantes para posix_mknod
  • Constantes para posix_setrlimit

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.


Constantes para posix_access

  • « Constantes predefinidas
  • Constantes para posix_mknod »
  • PHP Manual
  • Constantes predefinidas
  • Constantes para posix_access

Constantes para posix_access()

Nota:

Estas constantes están disponibles desde PHP 5.1.0. Observe que algunas de ellas podrían no estar disponibles en su sistema.

POSIX_F_OK (integer)
Comprobar si el fichero existe.
POSIX_R_OK (integer)
Comprobar si el fichero existe y tiene permisos de lectura.
POSIX_W_OK (integer)
Comprobar si el fichero existe y tiene permisos de escritura.
POSIX_X_OK (integer)
Comprobar si el fichero existe y tiene permisos de ejecución.


Constantes para posix_mknod

  • « Constantes para posix_access
  • Constantes para posix_setrlimit »
  • PHP Manual
  • Constantes predefinidas
  • Constantes para posix_mknod

Constantes para posix_mknod()

Nota:

Estas constantes están disponibles desde PHP 5.1.0. Observe que algunas de ellas podrían no estar disponibles en su sistema.

POSIX_S_IFBLK (integer)
Fichero especial de bloque
POSIX_S_IFCHR (integer)
Fichero especial de carácter
POSIX_S_IFIFO (integer)
Fichero especial FIFO (tubería con nombre)
POSIX_S_IFREG (integer)
Fichero normal
POSIX_S_IFSOCK (integer)
Socket


Constantes para posix_setrlimit

  • « Constantes para posix_mknod
  • Funciones POSIX »
  • PHP Manual
  • Constantes predefinidas
  • Constantes para posix_setrlimit

Constantes para posix_setrlimit()

Nota:

Estas constantes están disponibles desde PHP 7.0.0. Observe que algunas de ellas podrían no estar disponibles en su sistema.

Nota:

Sería conveniente leer las notas de abajo junto con la página principal de setrlimit() de su sistema operativo específico, ya que hay diferencia en cómo estos límites son interpretados, incluso entre sistema operativos que aseguran implementar POSIX por completo.

POSIX_RLIMIT_AS (integer)
El tamaño máximo del espacio de direcciones del proceso en bytes. Véase también la directiva de configuración memory_limit de PHP.
POSIX_RLIMIT_CORE (integer)
El tamaño máximo de un fichero de núcleo. Si el límite se establece a 0, no se generará ningún fichero de núcleo.
POSIX_RLIMIT_CPU (integer)
La cantidad máxima de tiempo de CPU que puede usar el proceso, en segundos. Cuando se alcanza el límite blando, se envia una señal SIGXCPU, la cual puede ser capturada con pcntl_signal(). Dependiendo del sistema operativo, se podrían enviar señales SIGXCPU adicionales cada segundo hasta alcanzar el límite duro, en cuyo punto se envía una señal SIGKILL no capturable. Véase también set_time_limit().
POSIX_RLIMIT_DATA (integer)
El tamaño máximo del segmento de datos del proceso, en bytes. Es extremadamente improbable que este límite tenga efecto en la ejecución de PHP a menos que una extensión utilice las llamadas brk() o sbrk().
POSIX_RLIMIT_FSIZE (integer)
El tamaño máximo de ficheros que puede crear un proceso, en bytes.
POSIX_RLIMIT_LOCKS (integer)
El número máximo de bloqueos que puede crear un proceso. Solamente está soportado en núcleos de Linux extremadamente antiguos.
POSIX_RLIMIT_MEMLOCK (integer)
El número máximo de bytes que pueden estar bloqueados en memoria.
POSIX_RLIMIT_MSGQUEUE (integer)
El número máximo de bytes que pueden ser asignados a colas de mensajes de POSIX. PHP no viene con soporte para colas de mensajes de POSIX, por lo que este límite no tendrá ningún efecto a menos que se utilice una extensión que implemente dicho soporte.
POSIX_RLIMIT_NICE (integer)
El valor máximo en el cual el proceso puede ser «reniced». El valor que se empleará será 20 - límite, ya que los valores límite de recursos no pueden ser negativos.
POSIX_RLIMIT_NOFILE (integer)
Un valor uno mayor que el número máximo de descriptor de fichero que puede ser abierto por este proceso.
POSIX_RLIMIT_NPROC (integer)
El número máximo de procesos (y/o hilos, en algunos sistemas operativos) que pueden ser creado por el ID de usuario resal del proceso.
POSIX_RLIMIT_RSS (integer)
El tamaño máximo del conjunto de residentes del proceso, en páginas.
POSIX_RLIMIT_RTPRIO (integer)
El prioridad de tiempo real qeu se puede establecer mediante las llamadas sched_setscheduler() y sched_setparam() al sistema.
POSIX_RLIMIT_RTTIME (integer)
La cantidad máxima de tiempo de CPU, en microsegundos, que el proceso puede consumir sin hacer una llamada bloqueanta al sistema si emplea una programación de tiempo real.
POSIX_RLIMIT_SIGPENDING (integer)
El número máximo de señales que se pueden poner en cola para el ID de usuario real del proceso.
POSIX_RLIMIT_STACK (integer)
El tamaño máximo de la pila de procesos, en bytes.
POSIX_RLIMIT_INFINITY (integer)
Empleada para indicar un valor infinito para un límite de recurso.


Funciones POSIX

Ver también

La sección sobre Funciones de Control de Procesos puede serle de interés.

Tabla de contenidos

  • posix_access — Determinar la accesibilidad de un archivo
  • posix_ctermid — Obtener el nombre de la ruta del terminal controlador
  • posix_errno — Alias de posix_get_last_error
  • posix_get_last_error — Recuperar el número de error establecido por la última función posix que ha fallado
  • posix_getcwd — Nombre de la ruta del directorio actual
  • posix_getegid — Devuelve el ID efectivo de grupo del proceso actual
  • posix_geteuid — Devolver el ID efectivo de usuario del proceso actual
  • posix_getgid — Devuelve el ID real de grupo del proceso actual
  • posix_getgrgid — Devolver información sobre un grupo mediante un id de grupo
  • posix_getgrnam — Devolver información sobre un grupo mediante su nombre
  • posix_getgroups — Devolver el conjunto de grupos del proceso actual
  • posix_getlogin — Devuelve el nombre del inicio de sesión
  • posix_getpgid — Obtener el id del grupo de procesos para un control de trabajo
  • posix_getpgrp — Devolver el identificador de grupo de proceso actual
  • posix_getpid — Devolver el identificador del proceso actual
  • posix_getppid — Devolver el identificador del proceso padre
  • posix_getpwnam — Devolver información sobre un usuario mediante su nombre de usuario
  • posix_getpwuid — Devolver información sobre un usuario mediante su id de usuario
  • posix_getrlimit — Devolver información sobre los límites de recursos del sistema
  • posix_getsid — Obtener el sid actual del proceos
  • posix_getuid — Devolver el ID real de usuario del proceso actual
  • posix_initgroups — Calcular la lista de acceso al grupo
  • posix_isatty — Determinar si un descriptor de fichero es un terminal interactiva
  • posix_kill — Enviar una señal a un proceso
  • posix_mkfifo — Crear un archivo especial fifo (un pipe con nombre)
  • posix_mknod — Crear un fichero especial u ordinario (POSIX.1)
  • posix_setegid — Establecer el GID efectivo del proceso actual
  • posix_seteuid — Establecer el UID efectivo del proceso actual
  • posix_setgid — Establecer el GID de proceso actual
  • posix_setpgid — Establecer el id de grupo de procesos para el control de trabajo
  • posix_setrlimit — Establecer los límites de recursos del sistema
  • posix_setsid — Hacer del proceso actual un líder de sesión
  • posix_setuid — Establecer el UID del proceso actual
  • posix_strerror — Recuperar el mensaje de error del sistema asociado con el errno dado
  • posix_times — Obtener los tiempos de procesos
  • posix_ttyname — Determinar el nombre del dispositivo terminal
  • posix_uname — Obtener el nombre del sistema


Determinar la accesibilidad de un archivo

  • « Funciones POSIX
  • posix_ctermid »
  • PHP Manual
  • Funciones POSIX
  • Determinar la accesibilidad de un archivo

posix_access

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

posix_access — Determinar la accesibilidad de un archivo

Descripción

posix_access ( string $file , int $mode = POSIX_F_OK ) : bool

posix_access() verifica el permiso del usuario sobre un archivo.

Parámetros

file

El nombre del archivo a ser probado.

mode

Una máscara consistente de uno o más de los valores POSIX_F_OK, POSIX_R_OK, POSIX_W_OK y POSIX_X_OK.

POSIX_R_OK, POSIX_W_OK y POSIX_X_OK solicitan que se verifique si el archivo existe y tiene permisos de lectura, escritura y ejecución, respectivamente. POSIX_F_OK simplemente verifica la existencia del archivo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de posix_access()

Este ejemplo verificará si el $archivo puede leerse y escribirse, de lo contrario imprimirá un mensaje de error.

<?php

$archivo = 'algun_archivo';

if (posix_access($archivo, POSIX_R_OK | POSIX_W_OK)) {
    echo '¡El archivo puede leerse y escribirse!';

} else {
    $error = posix_get_last_error();

    echo "Error $error: " . posix_strerror($error);
}

?>

Notas

Ver también

  • posix_get_last_error() - Recuperar el número de error establecido por la última función posix que ha fallado
  • posix_strerror() - Recuperar el mensaje de error del sistema asociado con el errno dado


Obtener el nombre de la ruta del terminal controlador

  • « posix_access
  • posix_errno »
  • PHP Manual
  • Funciones POSIX
  • Obtener el nombre de la ruta del terminal controlador

posix_ctermid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_ctermid — Obtener el nombre de la ruta del terminal controlador

Descripción

posix_ctermid ( ) : string

Genera un string que es el nombre de la ruta del terminal controlador actual para el proceso. En caso de error se establecerá a errno, que puede ser comprobado usando posix_get_last_error()

Valores devueltos

En caso de terminación exitosa, devuelve un string del nombre de ruta del terminal controlador actual. De otro modo devuelve false y se establece errno, que puede ser comprobado con posix_get_last_error().

Ejemplos

Ejemplo #1 Ejemplo de posix_ctermid()

Este ejemplo mostrará la ruta del TTY actual.

<?php
echo "Esto ejecutándome desde ".posix_ctermid();
?>

Ver también

  • posix_ttyname() - Determinar el nombre del dispositivo terminal
  • posix_get_last_error() - Recuperar el número de error establecido por la última función posix que ha fallado


Alias de posix_get_last_error

  • « posix_ctermid
  • posix_get_last_error »
  • PHP Manual
  • Funciones POSIX
  • Alias de posix_get_last_error

posix_errno

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_errno — Alias de posix_get_last_error()

Descripción

Esta función es un alias de: posix_get_last_error().


Recuperar el número de error establecido por la última función posix que ha fallado

  • « posix_errno
  • posix_getcwd »
  • PHP Manual
  • Funciones POSIX
  • Recuperar el número de error establecido por la última función posix que ha fallado

posix_get_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_get_last_error — Recuperar el número de error establecido por la última función posix que ha fallado

Descripción

posix_get_last_error ( ) : int

Recupera el número de error establecido por la última función posix que falló. El mensaje de error del sistema asociado con el valor errno puede ser consultado con posix_strerror().

Valores devueltos

Devuelve el valor errno (número de error) definido por la última función posix que haya fallado. Si no existe un error, se devuelve 0.

Ejemplos

Ejemplo #1 Ejemplo de posix_get_last_error()

Este ejemplo intenta matar un id de proceso inexistente, lo cual establecerá el error más reciente. Entonces el valor errno será impreso.

<?php
posix_kill(999459,SIGKILL);
echo 'Su error devuelto fue '.posix_get_last_error(); //Su error devuelto fue ___
?>

Ver también

  • posix_strerror() - Recuperar el mensaje de error del sistema asociado con el errno dado


Nombre de la ruta del directorio actual

  • « posix_get_last_error
  • posix_getegid »
  • PHP Manual
  • Funciones POSIX
  • Nombre de la ruta del directorio actual

posix_getcwd

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getcwd — Nombre de la ruta del directorio actual

Descripción

posix_getcwd ( ) : string

Obtiene el nombre de ruta absoluta del directorio de trabajo actual del script. En caso de error se establece errno, que puede ser verificado usando posix_get_last_error()

Valores devueltos

Devuelve un string del nombre de la ruta absoluta en caso de éxito. En caso de error devuelve false y se establece errno, que puede ser verificado con posix_get_last_error().

Ejemplos

Ejemplo #1 Ejemplo de posix_getcwd()

Este ejemplo devolverá la ruta absoluta del directorio actual de trabajo del script.

<?php
echo 'Mi directorio actual de trabajo es '.posix_getcwd();
?>

Notas

Nota:

Esta función puede fallar si

  • El permiso de Lectura o Búsqueda fue denegado
  • El nombre de la ruta ya no existe


Devuelve el ID efectivo de grupo del proceso actual

  • « posix_getcwd
  • posix_geteuid »
  • PHP Manual
  • Funciones POSIX
  • Devuelve el ID efectivo de grupo del proceso actual

posix_getegid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getegid — Devuelve el ID efectivo de grupo del proceso actual

Descripción

posix_getegid ( ) : int

Devuelve el ID efectivo de grupo efectivo numérico del proceso actual.

Valores devueltos

Devuelve un integer del ID del grupo efectivo.

Ejemplos

Ejemplo #1 Ejemplo de posix_getegid()

Este ejemplo imprimirá el id efectivo del grupo, una vez que es cambiado con posix_setegid().

<?php
echo 'Mi id del grupo real es '.posix_getgid(); //20
posix_setegid(40);
echo 'Mi id del grupo real es  '.posix_getgid(); //20
echo 'Mi id del grupo efectivo es  '.posix_getegid(); //40
?>

Notas

posix_getegid() es diferente de posix_getgid() ya que el ID efectivo del grupo se puede cambiar mediante una llamada al proceso usando posix_setegid().

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo
  • posix_getgid() - Devuelve el ID real de grupo del proceso actual
  • posix_setgid() - Establecer el GID de proceso actual


Devolver el ID efectivo de usuario del proceso actual

  • « posix_getegid
  • posix_getgid »
  • PHP Manual
  • Funciones POSIX
  • Devolver el ID efectivo de usuario del proceso actual

posix_geteuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_geteuid — Devolver el ID efectivo de usuario del proceso actual

Descripción

posix_geteuid ( ) : int

Devuelve el ID efectivo numérico de usuario del proceso actual. Véase también posix_getpwuid() para información sobre cómo convertirlo en un nombre de usuario utilizable.

Valores devueltos

Devuelve el id de usuario, como un valor de tipo integer

Ejemplos

Ejemplo #1 Ejemplo de posix_geteuid()

Este ejemplo mostrará el id del usuario actual y establecerá el id efectivo de usuario en un id aparte usando posix_seteuid(), luego mostrará la diferencia entre el id real y el id efectivo.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_seteuid(10000);
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10000
?>

Ver también

  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario
  • posix_getuid() - Devolver el ID real de usuario del proceso actual
  • posix_setuid() - Establecer el UID del proceso actual
  • POSIX man page GETEUID(2)


Devuelve el ID real de grupo del proceso actual

  • « posix_geteuid
  • posix_getgrgid »
  • PHP Manual
  • Funciones POSIX
  • Devuelve el ID real de grupo del proceso actual

posix_getgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgid — Devuelve el ID real de grupo del proceso actual

Descripción

posix_getgid ( ) : int

Devuelve el ID real numérico de grupo del proceso actual.

Valores devueltos

Devuelve el id real de grupo, como un valor de tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de posix_getgid()

Este ejemplo imprimirá el id real de grupo, incluso una vez que el id efectivo de grupo ha sido cambiado.

<?php
echo 'Mi id real de grupo es '.posix_getgid(); //20
posix_setegid(40);
echo 'Mi id real de grupo es '.posix_getgid(); //20
echo 'Mi id efectivo de grupo es '.posix_getegid(); //40
?>

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo
  • posix_getegid() - Devuelve el ID efectivo de grupo del proceso actual
  • posix_setgid() - Establecer el GID de proceso actual
  • POSIX man page GETGID(2)


Devolver información sobre un grupo mediante un id de grupo

  • « posix_getgid
  • posix_getgrnam »
  • PHP Manual
  • Funciones POSIX
  • Devolver información sobre un grupo mediante un id de grupo

posix_getgrgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgrgid — Devolver información sobre un grupo mediante un id de grupo

Descripción

posix_getgrgid ( int $gid ) : array

Obtiene información sobre un grupo porporcionando su id.

Parámetros

gid

El id del grupo.

Valores devueltos

Los elementos del array devueltos son:

El array de información de grupo
Elemento | Descripción
name | El elemento name contiene el nombre del grupo. Es una abreviatura, normalmente menos de 16 caracteres "soportan" el groupo, no el nombre real completo.
passwd | El elemento passwd contiene la contraseña del grupo en un formato encriptado. A menudo, por ejemplo bajo un sistema que emplea contraseñas "shadow", se devuelve un asterisco en su lugar.
gid | El ID del grupo, debería ser el mismo que el del parámetro gid usado al llamar a la función, y por lo tanto redundante.
members | Consiste en un array de strings de todos los miembros del grupo.

Ejemplos

Ejemplo #1 Ejemplo de uso deposix_getgrgid()

<?php

$groupid   = posix_getegid();
$groupinfo = posix_getgrgid($groupid);

print_r($groupinfo);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ver también

  • posix_getegid() - Devuelve el ID efectivo de grupo del proceso actual
  • posix_getgrnam() - Devolver información sobre un grupo mediante su nombre
  • filegroup() - Obtiene el grupo de un archivo
  • stat() - Da información acerca de un fichero
  • POSIX man page GETGRNAM(3)


Devolver información sobre un grupo mediante su nombre

  • « posix_getgrgid
  • posix_getgroups »
  • PHP Manual
  • Funciones POSIX
  • Devolver información sobre un grupo mediante su nombre

posix_getgrnam

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgrnam — Devolver información sobre un grupo mediante su nombre

Descripción

posix_getgrnam ( string $name ) : array

Obtiene información sobre un grupo, proporcioinado su nombre.

Parámetros

name

EL nombre del grupo

Valores devueltos

Los elementos del array devuelto son:

El array de información del grupo
Elemento | Descripción
name | El elemento name contiene el nombre del grupo. Es una abreviatura, normalmente menos de 16 caracteres "soportan" el groupo, no el nombre real completo. Debería ser el mismo que el del parámetro name usado al llamar a la función, y por lo tanto redundante.
passwd | El elemento passwd contiene la contraseña del grupo en un formato encriptado. A menudo, por ejemplo bajo un sistema que emplea contraseñas "shadow", se devuelve un asterisco en su lugar.
gid | El ID del grupo en forma numérica.
members | Consiste en un array de strings de todos los miembros del grupo.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getgrnam()

<?php

$groupinfo = posix_getgrnam("toons");

print_r($groupinfo);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ver también

  • posix_getegid() - Devuelve el ID efectivo de grupo del proceso actual
  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo
  • filegroup() - Obtiene el grupo de un archivo
  • stat() - Da información acerca de un fichero
  • POSIX man page GETGRNAM(3)


Devolver el conjunto de grupos del proceso actual

  • « posix_getgrnam
  • posix_getlogin »
  • PHP Manual
  • Funciones POSIX
  • Devolver el conjunto de grupos del proceso actual

posix_getgroups

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgroups — Devolver el conjunto de grupos del proceso actual

Descripción

posix_getgroups ( ) : array

Obtiene el conjunto de grupos del proceso actual.

Valores devueltos

Devuelve un array de enteros que contiene los ids numéricos del conjunto de grupos del proceso actual.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getgroups()

<?php

$groups = posix_getgroups();

print_r($groups);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => 4
    [1] => 20
    [2] => 24
    [3] => 25
    [4] => 29
    [5] => 30
    [6] => 33
    [7] => 44
    [8] => 46
    [9] => 104
    [10] => 109
    [11] => 110
    [12] => 1000
)

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo


Devuelve el nombre del inicio de sesión

  • « posix_getgroups
  • posix_getpgid »
  • PHP Manual
  • Funciones POSIX
  • Devuelve el nombre del inicio de sesión

posix_getlogin

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getlogin — Devuelve el nombre del inicio de sesión

Descripción

posix_getlogin ( ) : string

Delvuelve el nombre del inicio de sesión del usuario propietarios del proceso actual.

Valores devueltos

Devuelve el nombre de inicio de sesión del usuario, como valor de tipo string.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getlogin()

<?php
echo posix_getlogin(); //apache
?>

Ver también

  • posix_getpwnam() - Devolver información sobre un usuario mediante su nombre de usuario
  • POSIX man page GETLOGIN(3)


Obtener el id del grupo de procesos para un control de trabajo

  • « posix_getlogin
  • posix_getpgrp »
  • PHP Manual
  • Funciones POSIX
  • Obtener el id del grupo de procesos para un control de trabajo

posix_getpgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpgid — Obtener el id del grupo de procesos para un control de trabajo

Descripción

posix_getpgid ( int $pid ) : int

Devuelve el identificador del grupo de procesos del proceso pid o false en caso de error.

Parámetros

pid

El ide del proceso.

Valores devueltos

Devuelve el identificador, como valor de tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getpgid()

<?php
$pid = posix_getppid();
echo posix_getpgid($pid); //35
?>

Notas

Nota:

Esta no es una función POSIX, pero es usual en sistemas BSD y System V. Si el sistema no soporta esta función, no será incluidaen tiempo de compilación. Se puede comprobar con function_exists().

Ver también

  • posix_getppid() - Devolver el identificador del proceso padre
  • Página del manual SETPGID(2)


Devolver el identificador de grupo de proceso actual

  • « posix_getpgid
  • posix_getpid »
  • PHP Manual
  • Funciones POSIX
  • Devolver el identificador de grupo de proceso actual

posix_getpgrp

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpgrp — Devolver el identificador de grupo de proceso actual

Descripción

posix_getpgrp ( ) : int

Devuelve el identificador de grupo de proceso del proceso actual.

Valores devueltos

Devuelve el identificador, como valor de tipo integer.

Ver también

  • POSIX.1 y la página del manual getpgrp(2) en los sistemas POSIX para más información sobre grupos de procesos.


Devolver el identificador del proceso actual

  • « posix_getpgrp
  • posix_getppid »
  • PHP Manual
  • Funciones POSIX
  • Devolver el identificador del proceso actual

posix_getpid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpid — Devolver el identificador del proceso actual

Descripción

posix_getpid ( ) : int

Devolver el identificador de proceso del proceso actual.

Valores devueltos

Devuelve el identificador, como valor de tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getpid()

<?php
echo posix_getpid(); //8805
?>

Ver también

  • posix_kill() - Enviar una señal a un proceso
  • POSIX man page GETPID(2)


Devolver el identificador del proceso padre

  • « posix_getpid
  • posix_getpwnam »
  • PHP Manual
  • Funciones POSIX
  • Devolver el identificador del proceso padre

posix_getppid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getppid — Devolver el identificador del proceso padre

Descripción

posix_getppid ( ) : int

Devuelve el identificador de proceso del proceso padre del proceso actual.

Valores devueltos

Devuelve el identificador, como valor de tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getppid()

<?php
echo posix_getppid(); //8259
?>


Devolver información sobre un usuario mediante su nombre de usuario

  • « posix_getppid
  • posix_getpwuid »
  • PHP Manual
  • Funciones POSIX
  • Devolver información sobre un usuario mediante su nombre de usuario

posix_getpwnam

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpwnam — Devolver información sobre un usuario mediante su nombre de usuario

Descripción

posix_getpwnam ( string $username ) : array

Devuelve un array de información sobre el usuario dado.

Parámetros

username

Un nombre de usuario alfanumérico.

Valores devueltos

En caso de éxito se devuelve un array con los siguientes elementos, si no se devuelve false:

El array de información de usuario
Elemento | Descripción
name | El elemento name contiene el nombre del grupo. Es una abreviatura, normalmente menos de 16 caracteres "soportan" el groupo, no el nombre real completo. Debería se el mismo que el parámetro username usado al llamar a la función, y por lo tanto redundante.
passwd | El elemento passwd contiene la contraseña del grupo en un formato encriptado. A menudo, por ejemplo bajo un sistema que emplea contraseñas "shadow", se devuelve un asterisco en su lugar.
uid | El ID del usuario en forma numérica.
gid | El ID de grupo del usuario. Use la función posix_getgrgid() para resolver el nombre de grupo y una lista de sus miembros.
gecos | GECOS es un término obosleto que se refiere al campo de información "finger" de un sistema de procesamiento por lotes Honeywell. El campo, sin embargo, todavía existe, y su contenido ha sido formalizado por POSIX. El campo contiene una lista separada por comas que contiene el nombre completo del usuario, teléfono de oficina, número de oficina, y el número de teléfono de casa. En la mayoría de los sistemas solo está disponible el nombre de usuario completo.
dir | Este elemento contiene la ruta absoluta al directorio "home" del usuario.
shell | El elemento shell contiene la ruta absoluta al ejecutable del executable del shell predeterminado de usuario.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getpwnam()

<?php

$userinfo = posix_getpwnam("tom");

print_r($userinfo);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [gecos]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Ver también

  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario
  • POSIX man page GETPWNAM(3)


Devolver información sobre un usuario mediante su id de usuario

  • « posix_getpwnam
  • posix_getrlimit »
  • PHP Manual
  • Funciones POSIX
  • Devolver información sobre un usuario mediante su id de usuario

posix_getpwuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpwuid — Devolver información sobre un usuario mediante su id de usuario

Descripción

posix_getpwuid ( int $uid ) : array

Devuelve un array de información sobre el usuario denotado por el ID de usuario dado.

Parámetros

uid

El identificador de usuario.

Valores devueltos

Devuelve un array asociativo con los siguientes elementos:

El array de información de usuario
Elemento | Descripción
name | El elemento 'name' contiene el nombre de usuario. Es una abreviatura, normalmente un "apodo" de menos de 16 caracteres del nombre del usuario, no el nombre real completo.
passwd | El elemento 'passwd' contiene la contraseña del usuario en un formato encriptado. A menudo, por ejemplo, bajo un sistema que emplea contraseñas "shadow", se devuelve un asterisco en su lugar.
uid | El ID del usuario, debería ser el mismo que el del parámetro uid empleado al llamar a la función, y por lo tanto redundante.
gid | El ID de grupo del usuario. Emplee la función posix_getgrgid() para resolver el nombre de grupo y una lista de sus miembros.
gecos | GECOS es un término obosleto que se refiere al campo de información "finger" de un sistema de procesamiento por lotes Honeywell. El campo, sin embargo, todavía existe, y su contenido ha sido formalizado por POSIX. El campo contiene una lista separada por comas con el nombre completo del usuario, teléfono de oficina, número de oficina, y el número de teléfono de casa. En la mayoría de los sistemas solo está disponible el nombre de usuario completo.
dir | Este elemento contiene la ruta absoluta al directorio "home" del usuario.
shell | El elemento 'shell' contiene la ruta absoluta al ejecutable del shell predeterminado del usuario.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getpwuid()

<?php

$userinfo = posix_getpwuid(10000);

print_r($userinfo);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [gecos]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Ver también

  • posix_getpwnam() - Devolver información sobre un usuario mediante su nombre de usuario
  • Página GETPWNAM(3) del man de POSIX


Devolver información sobre los límites de recursos del sistema

  • « posix_getpwuid
  • posix_getsid »
  • PHP Manual
  • Funciones POSIX
  • Devolver información sobre los límites de recursos del sistema

posix_getrlimit

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getrlimit — Devolver información sobre los límites de recursos del sistema

Descripción

posix_getrlimit ( ) : array

posix_getrlimit() devuelve un array de información sobre los límites "soft" y "hard" del recurso actual.

Cada recurso tiene asociado un límite blando («soft») y otro duro («hard»). El límite blando es el valor que el núcleo impone al recurso correspondiente. El límete duro actúa como tope para el límite blando. Un proceso sin privilegios solo puede establecer su límite blando a un valor desde 0 al límite duro, e irreparablemente menor que su límite duro.

Valores devueltos

Devuelve un array asociativo de elementos para cada límite que es definido. Cada límite tiene un límite soft y hard.

Lista de los límites posibles devueltos
Nombre del límite | Descripción del límite
core | El tamaño máximo del archivo core. Cuando es 0, no se crean archivos core. Cuando los archivos core son mayores que su tamaño se truncarán a este tamaño.
totalmem | The maximum size of the memory of the process, in bytes.
virtualmem | El tamaño máximo de memoria virtual para el proceso, en bytes.
data | El tamaño máximo de the data segment for the process, in bytes.
stack | El tamaño máximo de la pila del proceso, en bytes.
rss | El número máximo de páginas virtuales residentes en RAM
maxproc | El número máximo de procesos que pueden ser creados para el ID real de usuario del proceso llamante.
memlock | El número máximo de bytes de memoria que puede ser bloqueados en RAM.
cpu | La cantidad de tiempo que se permite al proceso usar la CPU.
filesize | El tamaño máximo del segmento de datos del proceso, en bytes.
openfiles | Uno más que el número máximo de descriptores de ficheros abiertos.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getrlimit()

<?php

$límites = posix_getrlimit();

print_r($límites);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [soft core] => 0
    [hard core] => unlimited
    [soft data] => unlimited
    [hard data] => unlimited
    [soft stack] => 8388608
    [hard stack] => unlimited
    [soft totalmem] => unlimited
    [hard totalmem] => unlimited
    [soft rss] => unlimited
    [hard rss] => unlimited
    [soft maxproc] => unlimited
    [hard maxproc] => unlimited
    [soft memlock] => unlimited
    [hard memlock] => unlimited
    [soft cpu] => unlimited
    [hard cpu] => unlimited
    [soft filesize] => unlimited
    [hard filesize] => unlimited
    [soft openfiles] => 1024
    [hard openfiles] => 1024
)

Ver también

  • Página del manual GETRLIMIT(2)
  • posix_setrlimit() - Establecer los límites de recursos del sistema


Obtener el sid actual del proceos

  • « posix_getrlimit
  • posix_getuid »
  • PHP Manual
  • Funciones POSIX
  • Obtener el sid actual del proceos

posix_getsid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getsid — Obtener el sid actual del proceos

Descripción

posix_getsid ( int $pid ) : int

Devuelve el identificador de sesión del proceso pid. El identificador de sesión de un proceso es el id de grupo del proceso del líder de la sesión.

Parámetros

pid

Eñ identificador de proceso. Si se establece a 0, se asume el proceso actual. Si se especifica un pid no válido, se devuelve false y se establece un error que puede ser verificado con posix_get_last_error().

Valores devueltos

Devuelve el identificador, como valor de tipo integer.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getsid()

<?php
$pid = posix_getpid();
echo posix_getsid($pid); //8805
?>

Ver también

  • posix_getpgid() - Obtener el id del grupo de procesos para un control de trabajo
  • posix_setsid() - Hacer del proceso actual un líder de sesión
  • POSIX man page GETSID(2)


Devolver el ID real de usuario del proceso actual

  • « posix_getsid
  • posix_initgroups »
  • PHP Manual
  • Funciones POSIX
  • Devolver el ID real de usuario del proceso actual

posix_getuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getuid — Devolver el ID real de usuario del proceso actual

Descripción

posix_getuid ( ) : int

Devuelve el ID real numérico de usuario del proceso actual.

Valores devueltos

Devuelve el id de usuario, como valor de tipo integer

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_getuid()

<?php
echo posix_getuid(); //10000
?>

Ver también

  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario
  • POSIX man page GETUID(2)


Calcular la lista de acceso al grupo

  • « posix_getuid
  • posix_isatty »
  • PHP Manual
  • Funciones POSIX
  • Calcular la lista de acceso al grupo

posix_initgroups

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

posix_initgroups — Calcular la lista de acceso al grupo

Descripción

posix_initgroups ( string $name , int $base_group_id ) : bool

Calcula la lista de acceso al grupo para el usuario especificado en el parámetro name.

Parámetros

name

El usuario para el que se va a calcular la lista.

base_group_id

Normalmente el número de grupo del fichero de contraseñas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • La página del manua Unix para initgroups(3).


Determinar si un descriptor de fichero es un terminal interactiva

  • « posix_initgroups
  • posix_kill »
  • PHP Manual
  • Funciones POSIX
  • Determinar si un descriptor de fichero es un terminal interactiva

posix_isatty

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_isatty — Determinar si un descriptor de fichero es un terminal interactiva

Descripción

posix_isatty ( mixed $fd ) : bool

Determina si el descriptor de fichero fd hace referencia a un dispositivo tipo terminal válido.

Parámetros

fd

El descriptor del fichero, el cual se prevee que sea o un resource de fichero o un integer. Se asumirá que un integer sea un descriptor de fichero que pueda pasarse directamente a la llamada del sistema subyacente.

En la mayoría de los casos se proporcionará un resource de fichero.

Valores devueltos

Devuelve true si fd es un descriptor abierto conectado a una terminal, y false de lo contrario.

Ver también

  • posix_ttyname() - Determinar el nombre del dispositivo terminal


Enviar una señal a un proceso

  • « posix_isatty
  • posix_mkfifo »
  • PHP Manual
  • Funciones POSIX
  • Enviar una señal a un proceso

posix_kill

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_kill — Enviar una señal a un proceso

Descripción

posix_kill ( int $pid , int $sig ) : bool

Envía la señal sig al proceso con el identificador de proceso pid.

Parámetros

pid

El identificador de proceso.

sig

Una de las constantes de señales PCNTL.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • La página del manual kill(2) del sistema POSIX, la cual contiene información información sobre identificadores de procesos negativos, el pid especial 0, el pid especial -1, y la señal número 0.


Crear un archivo especial fifo (un pipe con nombre)

  • « posix_kill
  • posix_mknod »
  • PHP Manual
  • Funciones POSIX
  • Crear un archivo especial fifo (un pipe con nombre)

posix_mkfifo

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_mkfifo — Crear un archivo especial fifo (un pipe con nombre)

Descripción

posix_mkfifo ( string $pathname , int $mode ) : bool

posix_mkfifo() crea un archivo FIFO especial que existe en el sistema de archivos y actúa como un punto de comunicación bi-direccional para los procesos.

Parámetros

pathname

Ruta al archivo FIFO.

mode

El segundo parámetro modo tiene que ser definido en notación octal (p.ej. 0644). El permiso del FIFO recién creado depende también del valor umask() actual. Los permisos del archivo creado son (modo & ~umask).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas


Crear un fichero especial u ordinario (POSIX.1)

  • « posix_mkfifo
  • posix_setegid »
  • PHP Manual
  • Funciones POSIX
  • Crear un fichero especial u ordinario (POSIX.1)

posix_mknod

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

posix_mknod — Crear un fichero especial u ordinario (POSIX.1)

Descripción

posix_mknod ( string $pathname , int $mode , int $major = 0 , int $minor = 0 ) : bool

Crea un fichero especial u ordinario.

Parámetros

pathname

El fichero a crear

mode

Este parámetro se construye mediante un operador a nivel de bits OR entre el tipo de fichero (una de las siguientes constantes: POSIX_S_IFREG, POSIX_S_IFCHR, POSIX_S_IFBLK, POSIX_S_IFIFO o POSIX_S_IFSOCK) y los permisos.

major

El identificador de kernel mayor del dispositivo (necesario pasarlo al usar S_IFCHR o S_IFBLK).

minor

El identificador de kernel menor del dispositivo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de posix_mknod()

<?php

$fichero = '/tmp/fich_tmp';  // nombre del fichero
$tipo = POSIX_S_IFBLK;   // tipo de fichero
$permisos = 0777;     // octal
$mayor = 1;
$menor = 8;              // /dev/random

if (!posix_mknod($fichero, $tipo | $permisos, $mayor, $menor)) {
    die('Error ' . posix_get_last_error() . ': ' . posix_strerror(posix_get_last_error()));
}

?>

Ver también

  • posix_mkfifo() - Crear un archivo especial fifo (un pipe con nombre)


Establecer el GID efectivo del proceso actual

  • « posix_mknod
  • posix_seteuid »
  • PHP Manual
  • Funciones POSIX
  • Establecer el GID efectivo del proceso actual

posix_setegid

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

posix_setegid — Establecer el GID efectivo del proceso actual

Descripción

posix_setegid ( int $gid ) : bool

Establece el ID de grupo efectivo del proceso actual. Esta es una función privilegiada y se necesitan los permisos apropiados (usualmente root) en el sistema para contar con la capacidad de ejecutar esta función.

Parámetros

gid

El id de grupo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de posix_setegid()

Este ejemplo imprimirá el id de grupo efectivo, una vez cambiado.

<?php
echo 'Mi id de grupo real es '.posix_getgid(); //20
posix_setegid(40);
echo 'Mi id de grupo real es '.posix_getgid(); //20
echo 'Mi id de grupo efectivo es '.posix_getegid(); //40
?>

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo
  • posix_getgid() - Devuelve el ID real de grupo del proceso actual
  • posix_setgid() - Establecer el GID de proceso actual


Establecer el UID efectivo del proceso actual

  • « posix_setegid
  • posix_setgid »
  • PHP Manual
  • Funciones POSIX
  • Establecer el UID efectivo del proceso actual

posix_seteuid

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

posix_seteuid — Establecer el UID efectivo del proceso actual

Descripción

posix_seteuid ( int $uid ) : bool

Establece el ID de usuario real del proceso actual. Esta es una función privilegiada y se necesitan los permisos apropiados (usualmente root) en el sistema para tener la capacidad de ejecutar esta función.

Parámetros

uid

El id de usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • posix_setgid() - Establecer el GID de proceso actual


Establecer el GID de proceso actual

  • « posix_seteuid
  • posix_setpgid »
  • PHP Manual
  • Funciones POSIX
  • Establecer el GID de proceso actual

posix_setgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setgid — Establecer el GID de proceso actual

Descripción

posix_setgid ( int $gid ) : bool

Establece el ID real de grupo al proceso actual. Esta en una función privilegiada y necesita los privilegios apropiados (normalmente "root") en el sistema para ser capaza de realizar esta función. El orden apropiado de las llamadas a las funciones es posix_setgid() primero, posix_setuid() la última.

Nota:

Si el llamador es un superusuario también se establecerá el id efectivo de grupo.

Parámetros

gid

El id de grupo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de posix_setgid()

Este ejemplo imprimirá el id efectivo de grupo, una vez cambiado.

<?php
echo 'Mi id real de grupo es '.posix_getgid(); //20
posix_setgid(40);
echo 'Mi id real de grupo es '.posix_getgid(); //40
echo 'Mi id efectivo de grupo es '.posix_getegid(); //40
?>

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo
  • posix_getgid() - Devuelve el ID real de grupo del proceso actual


Establecer el id de grupo de procesos para el control de trabajo

  • « posix_setgid
  • posix_setrlimit »
  • PHP Manual
  • Funciones POSIX
  • Establecer el id de grupo de procesos para el control de trabajo

posix_setpgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setpgid — Establecer el id de grupo de procesos para el control de trabajo

Descripción

posix_setpgid ( int $pid , int $pgid ) : bool

Permite al proceso pid unirse al grupo de procesos pgid.

Parámetros

pid

El id del proceso.

pgid

El id de grupo de procesos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • Véase POSIX.1 y la página del manual setsid(2) del sistema POSIX para más información sobre grupos de proceoss y control de trabajo.


Establecer los límites de recursos del sistema

  • « posix_setpgid
  • posix_setsid »
  • PHP Manual
  • Funciones POSIX
  • Establecer los límites de recursos del sistema

posix_setrlimit

(PHP 7, PHP 8)

posix_setrlimit — Establecer los límites de recursos del sistema

Descripción

posix_setrlimit ( int $resource , int $softlimit , int $hardlimit ) : bool

posix_setrlimit() establece los límites blando y duro para un recurso de sistema dado.

Cada recurso tiene asociado un límite blando («soft») y otro duro («hard»). El límite blando es el valor que el núcleo impone al recurso correspondiente. El límete duro actúa como tope para el límite blando. Un proceso sin privilegios solo puede establecer su límite blando a un valor desde 0 al límite duro, e irreparablemente menor que su límite duro.

Parámetros

resource

La constante de límite de recurso conrrespondiente al límite a establecer.

softlimit

El límite blando, en la unidad que el límite del recurso requiera, o POSIX_RLIMIT_INFINITY.

hardlimit

El límite duro, en la unidad que el límite del recurso requiera, o POSIX_RLIMIT_INFINITY.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • La página SETRLIMIT(2) de man
  • posix_getrlimit() - Devolver información sobre los límites de recursos del sistema


Hacer del proceso actual un líder de sesión

  • « posix_setrlimit
  • posix_setuid »
  • PHP Manual
  • Funciones POSIX
  • Hacer del proceso actual un líder de sesión

posix_setsid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setsid — Hacer del proceso actual un líder de sesión

Descripción

posix_setsid ( ) : int

Hace del proceso actual un líder de sesión.

Valores devueltos

Devuelve un id de sesión, o -1 si ocurrió algún error.

Ver también

  • Las páginas del manual POSIX.1 y setsid(2) del sistema POSIX para más información sobre los grupos de procesos y el control de trabajo.


Establecer el UID del proceso actual

  • « posix_setsid
  • posix_strerror »
  • PHP Manual
  • Funciones POSIX
  • Establecer el UID del proceso actual

posix_setuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setuid — Establecer el UID del proceso actual

Descripción

posix_setuid ( int $uid ) : bool

Establece el ID real de usuario del proceso actual. Esta es una función privilegiada que necesita los privilegios apropiados (normalmente root) del sistema para que sea capaz de realizar esta función.

Parámetros

uid

El id de usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de posix_setuid()

Este ejemplo mostrará el id de usuario actual y después lo establecerá a un valor diferente.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_setuid(10000);
echo posix_getuid()."\n"; //10000
echo posix_geteuid()."\n"; //10000
?>

Ver también

  • posix_setgid() - Establecer el GID de proceso actual
  • posix_seteuid() - Establecer el UID efectivo del proceso actual
  • posix_getuid() - Devolver el ID real de usuario del proceso actual
  • posix_geteuid() - Devolver el ID efectivo de usuario del proceso actual


Recuperar el mensaje de error del sistema asociado con el errno dado

  • « posix_setuid
  • posix_times »
  • PHP Manual
  • Funciones POSIX
  • Recuperar el mensaje de error del sistema asociado con el errno dado

posix_strerror

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_strerror — Recuperar el mensaje de error del sistema asociado con el errno dado

Descripción

posix_strerror ( int $errno ) : string

Devuelve el mensaje de error del sistema POSIX asociado con el errno. Es posible obtener el parámetro errno llamando la función posix_get_last_error().

Parámetros

errno

Un número de error POSIX, devuelto por posix_get_last_error(). Si se define como 0, entonces se devuelve la cadena "Success".

Valores devueltos

Devuelve el mensaje de error, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de posix_strerror()

Este ejemplo intentará matar un proceso que no existe, luego imprimirá el mensaje de error correspondiente.

<?php
posix_kill(50,SIGKILL);
echo posix_strerror(posix_get_last_error())."\n";
?>

El resultado del ejemplo sería algo similar a:

No such process

Ver también

  • posix_get_last_error() - Recuperar el número de error establecido por la última función posix que ha fallado


Obtener los tiempos de procesos

  • « posix_strerror
  • posix_ttyname »
  • PHP Manual
  • Funciones POSIX
  • Obtener los tiempos de procesos

posix_times

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_times — Obtener los tiempos de procesos

Descripción

posix_times ( ) : array

Obtiene informaciónsobre el uso actual de CPU.

Valores devueltos

Devuelve un hash de cadenas con iformación sobre el uso de CPU del proceso actual. Los índices del hash son:

  • ticks - el número de pulsos de reloj que han trasncurrido desde el reinicio.
  • utime - tiempo de usuario usado por el proceso actual.
  • stime - tiempo de sistema usado por el proceso actual.
  • cutime - tiempop de usuario usado por el proceso actual y sus hijos.
  • cstime - tiempo de sistema usado por el proceso actual y sus hijos.

Notas

Advertencia

Esta función no es fiable de usar, puede devolver valores negativos para tiempos altos.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_times()

<?php

$tiempos = posix_times();

print_r($tiempos );
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [ticks] => 25814410
    [utime] => 1
    [stime] => 1
    [cutime] => 0
    [cstime] => 0
)


Determinar el nombre del dispositivo terminal

  • « posix_times
  • posix_uname »
  • PHP Manual
  • Funciones POSIX
  • Determinar el nombre del dispositivo terminal

posix_ttyname

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_ttyname — Determinar el nombre del dispositivo terminal

Descripción

posix_ttyname ( mixed $fd ) : string

Devuelve un string de la ruta absulota del dispositivo terminal actual que está abierto en el descriptor de ficheros fd.

Parámetros

fd

El descriptor del fichero, el cual se prevee que sea o un resource de fichero o un integer. Se asumirá que un integer sea un descriptor de fichero que pueda pasarse directamente a la llamada del sistema subyacente.

En la mayoría de los casos se proporcionará un resource de fichero.

Valores devueltos

En caso de éxito devuelve un string de la ruta absoluta del fd. En caso de fallo devuelve false


Obtener el nombre del sistema

  • « posix_ttyname
  • Ejecución de programas »
  • PHP Manual
  • Funciones POSIX
  • Obtener el nombre del sistema

posix_uname

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_uname — Obtener el nombre del sistema

Descripción

posix_uname ( ) : array

Obtiene información sobre elsistema.

Posix requiere que estas suposiciones no deben hacerse sobre el formato de los valores, p.ej. la suposición que la versión puede contener tres dígitos o cualquier otra cosa devuelta por esta función.

Valores devueltos

Returns un hash de cadena con información sobre el sistema. Los índices del hash son

  • sysname - nombre del sistema operativo (p.ej. Linux)
  • nodename - nombre del sistema (p.ej. valiant)
  • release - versión de publicación del sistema operativo (p.ej. 2.2.10)
  • version - versión del sistema operativo (p.ej. #4 Tue Jul 20 17:01:36 MEST 1999)
  • machine - arquitectura del sistema (p.ej. i586)
  • domainname - nombre del dominio DNS (p.ej. example.com)

domainname es una extensión GNU y no es parte de POSIX.1, por lo que este campo solamente está disponible en sistemas GNU o cuando se usa GNU libc.

Ejemplos

Ejemplo #1 Ejemplo de uso de posix_uname()

<?php
$uname=posix_uname();
print_r($uname);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [sysname] => Linux
    [nodename] => funbox
    [release] => 2.6.20-15-server
    [version] => #2 SMP Sun Apr 15 07:41:34 UTC 2007
    [machine] => i686
)


Ejecución de programas del sistema

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de ejecución de programas
    • escapeshellarg — Escapar una cadena a ser usada como argumento del intérprete de comandos
    • escapeshellcmd — Escapar meta-caracteres del intérprete de comandos
    • exec — Ejecutar un programa externo
    • passthru — Ejecuta un programa externo y muestra la salida en bruto
    • proc_close — Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso
    • proc_get_status — Obtiene información sobre un proceso abierto por proc_open
    • proc_nice — Modificar la prioridad del proceso actual
    • proc_open — Ejecuta un comando y abre un puntero de fichero para entrada/salida
    • proc_terminate — Mata un proceso abierto mediante proc_open
    • shell_exec — Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena
    • system — Ejecutar un programa externo y mostrar su salida


Introducción

Estas funciones proveen medios para ejecutar comandos en el sistema en sí, y medios para hacer seguros estos comandos.

Nota:

Todas las funciones de ejecución llaman a los comandos a través de cmd.exe bajo Windows. Por lo tanto, el usuario que llame a estas funciones necesita los privilegios apropiados para ejecutar este comando. La única excepción es proc_open() con la opción bypass_shell.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un recurso de proceso devuelto por proc_open().


  • « Tipos de recursos
  • Funciones de ejecución de programas »
  • PHP Manual
  • Ejecución de programas
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de ejecución de programas

Notas

Advertencia

Los archivos abiertos con seguridad (especialmente sesiones abiertas) deben ser cerrados antes de ejecutar un programa en segundo plano.

Ver también

Estas funciones están también estrechamente relacionadas con el operador de comillas invertidas.

Tabla de contenidos

  • escapeshellarg — Escapar una cadena a ser usada como argumento del intérprete de comandos
  • escapeshellcmd — Escapar meta-caracteres del intérprete de comandos
  • exec — Ejecutar un programa externo
  • passthru — Ejecuta un programa externo y muestra la salida en bruto
  • proc_close — Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso
  • proc_get_status — Obtiene información sobre un proceso abierto por proc_open
  • proc_nice — Modificar la prioridad del proceso actual
  • proc_open — Ejecuta un comando y abre un puntero de fichero para entrada/salida
  • proc_terminate — Mata un proceso abierto mediante proc_open
  • shell_exec — Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena
  • system — Ejecutar un programa externo y mostrar su salida


Escapar una cadena a ser usada como argumento del intérprete de comandos

  • « Funciones de ejecución de programas
  • escapeshellcmd »
  • PHP Manual
  • Funciones de ejecución de programas
  • Escapar una cadena a ser usada como argumento del intérprete de comandos

escapeshellarg

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

escapeshellarg — Escapar una cadena a ser usada como argumento del intérprete de comandos

Descripción

escapeshellarg ( string $arg ) : string

escapeshellarg() agrega comillas sencillas alrededor de una cadena y rodea de comillas/escapa cualquier comilla sencilla existente, permitiéndole pasar la cadena directamente a una función del intérprete de comandos, y logrando que sea tratada como un solo argumento seguro. Esta función debe ser usada para escapar argumentos individuales a funciones del intérprete de comandos que provienen de la entrada del usuario. Las funciones del intérprete de comandos incluyen exec(), system() y el operador de comilla invertida.

En Windows, escapeshellarg() elimina en su lugar los signos de porcentaje, remplaza las comillas dobles por espacios y añade comillas dobles al string.

Parámetros

arg

El argumento que será escapado.

Valores devueltos

La cadena escapada.

Ejemplos

Ejemplo #1 Ejemplo de escapeshellarg()

<?php
system('ls '.escapeshellarg($dir));
?>

Ver también

  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos
  • exec() - Ejecutar un programa externo
  • popen() - Abre un proceso de un puntero a un fichero
  • system() - Ejecutar un programa externo y mostrar su salida
  • operador de comilla invertida


Escapar meta-caracteres del intérprete de comandos

  • « escapeshellarg
  • exec »
  • PHP Manual
  • Funciones de ejecución de programas
  • Escapar meta-caracteres del intérprete de comandos

escapeshellcmd

(PHP 4, PHP 5, PHP 7, PHP 8)

escapeshellcmd — Escapar meta-caracteres del intérprete de comandos

Descripción

escapeshellcmd ( string $command ) : string

escapeshellcmd() escapa cualquier caracter en una cadena que pudiera ser usada para engañar a un comando shell para que ejecute comandos arbitrarios. Esta función debería usarse para asegurarse de que cualquier información procedente de la entrada del usuario sea escapada antes de que dicha información sea pasada a las funciones exec() o system(), o al operador de comilla invertida.

Los siguientes caracteres son precedidos por una barra invertida: #&;`|*?~<>^()[]{}$\, \x0A y \xFF. ' y " son escapados únicamente si no están emparejados. En Windows, todos estos caracteres más % son reemplazados en su lugar por un espacio.

Parámetros

command

El comando a ser escapado.

Valores devueltos

La cadena escapada.

Ejemplos

Ejemplo #1 Ejemplo de escapeshellcmd()

<?php
// Permitimos intencionadamente un número arbitrario de argumentos aquí.
$comando = './configure '.$_POST['configure_options'];

$comando_escapado = escapeshellcmd($comando);

system($comando_escapado);
?>

Advertencia

escapeshellcmd() debería usarse en la cadena de comandos completa, y aún permitir al atacante pasar un número de argumentos arbitrario. Para escapar un único argumento se debería usar en su lugar la función escapeshellarg().

Ver también

  • escapeshellarg() - Escapar una cadena a ser usada como argumento del intérprete de comandos
  • exec() - Ejecutar un programa externo
  • popen() - Abre un proceso de un puntero a un fichero
  • system() - Ejecutar un programa externo y mostrar su salida
  • operador de comilla invertida


Ejecutar un programa externo

  • « escapeshellcmd
  • passthru »
  • PHP Manual
  • Funciones de ejecución de programas
  • Ejecutar un programa externo

exec

(PHP 4, PHP 5, PHP 7, PHP 8)

exec — Ejecutar un programa externo

Descripción

exec ( string $command , array &$output = ? , int &$return_var = ? ) : string

exec() ejecuta el comando dado.

Parámetros

command

El comando que será ejecutado.

output

Si el argumento output está presente, entonces el array especificado será llenado con cada línea de la salida del comando. El espacio en blanco extra, como \n, no es incluido en este array. Note que si el array ya contiene algunos elementos, exec() anexará sus resultados al final del array. Si no desea que la función anexe los elementos, use unset() sobre el array antes de pasarla a exec().

return_var

Si el argumento return_var está presente junto con el argumento output, entonces el status de retorno del comando ejecutado será escrito en esta variable.

Valores devueltos

La última línea de los resultados del comando. Si necesita ejecutar un comando y tener todos los datos desde el comando pasados directamente de vuelta sin interferencia alguna, use la función passthru().

Para obtener la salida del comando ejecutado, asegúrese de definir y usar el parámetro output.

Ejemplos

Ejemplo #1 Un ejemplo de exec()

<?php
// imprime el nombre de usuario que tiene control del proceso php/httpd activo
// (en un sistema con el ejecutable "whoami" disponible en la ruta)
echo exec('whoami');
?>

Notas

Advertencia

Si se va a permitir que datos provenientes del usuario sean enviados a esta función, habría que utilizar escapeshellarg() o escapeshellcmd() para asegurarse que el usuario no intenta engañar al sistema para que ejecute comandos arbitrarios.

Nota:

Si ejecutamos un programa con esta función y queremos dejarlo ejecutándose en segundo plano, hay que asegurarse que la salida del mismo es redireccionada a un fichero u otro flujo de salida o PHP se quedará esperando hasta que la ejecución del programa termine.

Ver también

  • system() - Ejecutar un programa externo y mostrar su salida
  • passthru() - Ejecuta un programa externo y muestra la salida en bruto
  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos
  • pcntl_exec() - Executes specified program in current process space
  • operador de comilla invertida


Ejecuta un programa externo y muestra la salida en bruto

  • « exec
  • proc_close »
  • PHP Manual
  • Funciones de ejecución de programas
  • Ejecuta un programa externo y muestra la salida en bruto

passthru

(PHP 4, PHP 5, PHP 7, PHP 8)

passthru — Ejecuta un programa externo y muestra la salida en bruto

Descripción

passthru ( string $command , int &$return_var = ? ) : void

La función passthru() es parecida a la función exec() que ejecuta un command. Esta función deberia ser usada en lugar de exec() o system() cuando la salida desde la línea de comandos de Unix sean datos binarios, los cuales sea necesario pasar directamente al navegador. Un uso común para esto, sería para ejecutar algo como las utilidades pbmplus que pueden mostrar directamente una imagen en streaming. Estableciendo el Content-type como image/gif y llamando al programa pbmplus para mostrar un gif, se podrian crear scripts PHP que mostrasen imágenes directamente.

Parámetros

command

El comando que será ejecutado.

return_var

Si está presente el argumento return_var, el valor de retorno de la línea de comandos de Unix será colocado aquí.

Valores devueltos

No devuelve ningún valor.

Notas

Advertencia

Si se va a permitir que datos provenientes del usuario sean enviados a esta función, habría que utilizar escapeshellarg() o escapeshellcmd() para asegurarse que el usuario no intenta engañar al sistema para que ejecute comandos arbitrarios.

Nota:

Si ejecutamos un programa con esta función y queremos dejarlo ejecutándose en segundo plano, hay que asegurarse que la salida del mismo es redireccionada a un fichero u otro flujo de salida o PHP se quedará esperando hasta que la ejecución del programa termine.

Ver también

  • exec() - Ejecutar un programa externo
  • system() - Ejecutar un programa externo y mostrar su salida
  • popen() - Abre un proceso de un puntero a un fichero
  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos
  • backtick operator


Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso

  • « passthru
  • proc_get_status »
  • PHP Manual
  • Funciones de ejecución de programas
  • Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso

proc_close

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

proc_close — Cierra un proceso abierto mediante proc_open() y devuelve el códido de salida de tal proceso

Descripción

proc_close ( resource $process ) : int

proc_close() es similar a pclose() excepto que este solo funciona con procesos abiertos mediante proc_open(). proc_close() espera para la terminación del proceso, y devuelve su código de salida. Si se han abierto tuberias para este proceso, se deberia usar fclose() antes de la llamada a esta función para evitar un punto muerto - es decir, los procesos hijos no seran capaces de salir mientras que las tuberias estan abiertas.

Parámetros

process

El recurso de proc_open() que será cerrado.

Valores devueltos

Devuelve el estado de terminación del proceso que se ejecutó. En caso de error se devolverá -1.


Obtiene información sobre un proceso abierto por proc_open

  • « proc_close
  • proc_nice »
  • PHP Manual
  • Funciones de ejecución de programas
  • Obtiene información sobre un proceso abierto por proc_open

proc_get_status

(PHP 5, PHP 7, PHP 8)

proc_get_status — Obtiene información sobre un proceso abierto por proc_open()

Descripción

proc_get_status ( resource $process ) : array

proc_get_status() recupera información sobre un proceso abierto mediante el uso de proc_open().

Parámetros

process

El resource proc_open() que será evaluado.

Valores devueltos

Un valor array con la información recolectada en caso de éxito, y false si ocurre un error. La matriz devuelta contiene los siguientes elementos:

element | type | description
command | string | La cadena del comando que fue pasada a proc_open().
pid | int | process id
running | bool | true si el proceso aun está siendo ejecutado, false si ha terminado.
signaled | bool | true si el proceso hijo ha sido terminado por una señal no atrapada. En windows, este valor siempre es false.
stopped | bool | true si el proceso hijo fue detenido por una señal. En windows, este valor siempre es false.
exitcode | int | El código de salida devuelto por el proceso (el cual tiene sentido únicamente si running es false). Solo la primera llamada a esta función devuelve el valor real, la siguiente llamada devuelve -1.
termsig | int | El número de la señal que causó que el proceso hijo finalizara su ejecución (sólo tiene sentido si signaled es true).
stopsig | int | El número de la señal que causó que el proceso hijo detuviera su ejecución (sólo tiene sentido si stopped es true).

Ver también

  • proc_open() - Ejecuta un comando y abre un puntero de fichero para entrada/salida


Modificar la prioridad del proceso actual

  • « proc_get_status
  • proc_open »
  • PHP Manual
  • Funciones de ejecución de programas
  • Modificar la prioridad del proceso actual

proc_nice

(PHP 5, PHP 7, PHP 8)

proc_nice — Modificar la prioridad del proceso actual

Descripción

proc_nice ( int $increment ) : bool

proc_nice() modifica la prioridad del proceso actual por la cantidad especificada en increment. Un increment positivo reducirá la prioridad del proceso actual, mientras que un increment negativo la incrementará.

proc_nice() no está relacionada con proc_open() y sus funciones asociadas en ninguna forma.

Parámetros

increment

El valor de incremento del cambio de prioridad.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si ocurre un error, como que el usuario carezca de permisos para modificar la prioridad, un error de nivel E_WARNING es generado también.

Notas

Nota: Disponibilidad

proc_nice() existirá únicamente si su sistema tiene soporte para 'nice'. 'nice' está definido de acuerdo a los estándares: SVr4, SVID EXT, AT&T, X/OPEN, BSD 4.3. Esto quiere decir que proc_nice() no está disponible en Windows.


Ejecuta un comando y abre un puntero de fichero para entrada/salida

  • « proc_nice
  • proc_terminate »
  • PHP Manual
  • Funciones de ejecución de programas
  • Ejecuta un comando y abre un puntero de fichero para entrada/salida

proc_open

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

proc_open — Ejecuta un comando y abre un puntero de fichero para entrada/salida

Descripción

proc_open ( string $cmd , array $descriptorspec , array &$pipes , string $cwd = ? , array $env = ? , array $other_options = ? ) : resource

proc_open() es similar a popen() pero provee un grado de control mucho más grande sobre la ejecución del programa.

Parámetros

cmd

El comando a ejecutar

descriptorspec

Un array indexado donde la clave representa el número descriptor y el valor representa como PHP pasará que descriptor para que proceso hijo. 0 es stdin, 1 es stdout, 2 es stderr.

Cada elemento puede ser:

  • Un array que describe la tubería que se va a pasar al proceso. El primer elemento es el tipo de descriptor, y el segundo elemento es una opción para el tipo dado. Los tipos válidos son: pipe (en este caso el segundo elemento sería r para pasar a leer el final de la tubería para el proceso, o w para pasar a escribir al final) y file (en este caso el segundo elemento sería el nombre de fichero).
  • Un recurso de flujo representando un descriptor de un fichero real (p.e. un fichero abierto, un socket, STDIN).

Los números descriptores de fichero no estan limitados a 0, 1 y 2. Se puede especificar cualquier número descriptor válido de fichero, y este ser pasado al proceso hijo. Esto permite a su script para inteoperar con otros scripts que corren como "co-procesos". En particular esto es útil pasando passphrases para programas como PGP, GPG y OpenSSL de una manera más segura. Esto es útil también para la lectura de la información del estado provista por estos programas en descriptores de fichero auxiliares.

pipes

En un array indexado es establecerán los punteros de fichero que se corresponden con el fin de cualquier tuberia PHP que se haya creado.

cwd

El directorio inicial de trabajo para el comando. Este debe ser una ruta absoluta, o si se prefiere puede ser null si se desea usar el valor por defecto (entonces será el directorio de trabajo del proceso PHP en curso)

env

Un array con las variables de entorno para el comando que será ejecutado, o null para usar el mismo entorno como el del proceso PHP en curso.

other_options

Permite especificar opciones adicionales. Actualmente las opciones soportadas incluidas son:

  • suppress_errors (solo windows): suprime errores generados por esta función cuando es establece en true
  • bypass_shell (solo windows): Desvia en la consola de cmd.exe cuando se establece en true

Valores devueltos

Devuelve un recurso representando el proceso, cuando se haya terminado con él, deberá ser liberado usandoproc_close(). En caso de error devuelve false.

Historial de cambios

Versión | Descripción
5.2.1 | Añadida la opción bypass_shell al parámetro other_options.

Ejemplos

Ejemplo #1 Ejemplo de proc_open()

<?php
$descriptorspec = array(
   0 => array("pipe", "r"),  // stdin es una tubería usada por el hijo para lectura
   1 => array("pipe", "w"),  // stdout es una tubería usada por el hijo para escritura
   2 => array("file", "/tmp/error-output.txt", "a") // stderr es un fichero para escritura
);

$cwd = '/tmp';
$env = array('some_option' => 'aeiou');

$process = proc_open('php', $descriptorspec, $pipes, $cwd, $env);

if (is_resource($process)) {
    // $pipes ahora será algo como:
    // 0 => gestor de escritura conectado al stdin hijo
    // 1 => gestor de lectura conectado al stdout hijo
    // Cualquier error de salida será anexado a /tmp/error-output.txt

    fwrite($pipes[0], '<?php print_r($_ENV); ?>');
    fclose($pipes[0]);

    echo "--".stream_get_contents($pipes[1])."--";
    fclose($pipes[1]);

    // Es importante que se cierren todas las tubería antes de llamar a
    // proc_close para evitar así un punto muerto
    $return_value = proc_close($process);

    echo "command returned $return_value\n";
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [some_option] => aeiou
    [PWD] => /tmp
    [SHLVL] => 1
    [_] => /usr/local/bin/php
)
command returned 0

Notas

Nota:

Compatibilidad con Windows: Los descriptores por encima de 2 (stderr) se ponen a disposición del proceso hijo como gestores heredables, pero desde la arquitectura de Windows no se asocia el número descriptor de fichero con los gestores de bajo nivel. El proceso hijo (todavia) no tiene un medio de acceso a estos gestores. Stdin, stdout and stderr funcionan como se esperaba.

Nota:

Si solamente se necesita una tubería de proceso unidireccional, es mejor usar popen() en su lugar, ya que es mucho más fácil de utilizar.

Ver también

  • popen() - Abre un proceso de un puntero a un fichero
  • exec() - Ejecutar un programa externo
  • system() - Ejecutar un programa externo y mostrar su salida
  • passthru() - Ejecuta un programa externo y muestra la salida en bruto
  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
  • The backtick operator


Mata un proceso abierto mediante proc_open

  • « proc_open
  • shell_exec »
  • PHP Manual
  • Funciones de ejecución de programas
  • Mata un proceso abierto mediante proc_open

proc_terminate

(PHP 5, PHP 7, PHP 8)

proc_terminate — Mata un proceso abierto mediante proc_open

Descripción

proc_terminate ( resource $process , int $signal = 15 ) : bool

Señala un process (creado usando proc_open()) que debe terminar. proc_terminate() regresa inmediatamente y espera a la terminación del proceso.

proc_terminate() Permite terminar el proceso y continuar con otras tareas. Puede consultar el estado del proceso (para ver si se ha detenido) usando la función proc_get_status().

Parámetros

process

El recurso de proc_open() que será cerrado.

signal

Este parámetro opcional solo es útil en sistemas operativos POSIX; puede especificar una señal para enviar al proceso utilizando la llamada al sistema kill(2). Por defecto es SIGTERM.

Valores devueltos

Devuelve el estado de terminación del proceso que se ejecutó.

Historial de cambios

Versión | Descripción
5.2.2 | Versiones previas usadas para destruir el recurso de un proceso dado.

Ver también

  • proc_open() - Ejecuta un comando y abre un puntero de fichero para entrada/salida
  • proc_close() - Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso
  • proc_get_status() - Obtiene información sobre un proceso abierto por proc_open


Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena

  • « proc_terminate
  • system »
  • PHP Manual
  • Funciones de ejecución de programas
  • Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena

shell_exec

(PHP 4, PHP 5, PHP 7, PHP 8)

shell_exec — Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena

Descripción

shell_exec ( string $cmd ) : string

Esta función es idéntica al operador de comillas invertidas.

Parámetros

cmd

El comando que será ejecutado.

Valores devueltos

La salida del comando ejecutado o null si ocurre un error o el comando no produce ninguna salida.

Nota:

Esta función puede devolver null cuando ocurre un error o cuando el programa no produce ninguna salida. No es posible detectar los fallos de ejecución usando esta función. exec() debería usarse cuando sea necesario el acceso al código de salida del programa.

Ejemplos

Ejemplo #1 Un ejemplo de shell_exec()

<?php
$salida = shell_exec('ls -lart');
echo "<pre>$salida</pre>";
?>

Ver también

  • exec() - Ejecutar un programa externo
  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos


Ejecutar un programa externo y mostrar su salida

  • « shell_exec
  • parallel »
  • PHP Manual
  • Funciones de ejecución de programas
  • Ejecutar un programa externo y mostrar su salida

system

(PHP 4, PHP 5, PHP 7, PHP 8)

system — Ejecutar un programa externo y mostrar su salida

Descripción

system ( string $command , int &$return_var = ? ) : string

system() es similar a la versión C de la función de mismo nombre, dado que ejecuta el command dado y muestra el resultado.

La llamada a system() también intenta volcar automáticamente el búfer de salida del servidor web después de cada línea de salida, si PHP está corriendo como un módulo de servidor.

Si necesita ejecutar un comando y recibir de vuelta todo los datos del mismo sin interferencias, use la función passthru().

Parámetros

comando

El comando que será ejecutado.

return_var

Si el argumento return_var se encuentra presente, entonces el status devuelto por el comando ejecutado será almacenado en esta variable.

Valores devueltos

Devuelve la última línea de la salida del comando en caso de tener éxito, y false si ocurre un error.

Ejemplos

Ejemplo #1 Ejemplo de system()

<?php
echo '<pre>';

// Muestra el resultado completo del comando "ls", y devuelve la
// ultima linea de la salida en $ultima_linea. Almacena el valor de
// retorno del comando en $retval.
$ultima_linea = system('ls', $retval);

// Imprimir informacion adicional
echo '
</pre>
<hr />Ultima linea de la salida: ' . $ultima_linea . '
<hr />Valor de retorno: ' . $retval;
?>

Notas

Advertencia

Si se va a permitir que datos provenientes del usuario sean enviados a esta función, habría que utilizar escapeshellarg() o escapeshellcmd() para asegurarse que el usuario no intenta engañar al sistema para que ejecute comandos arbitrarios.

Nota:

Si ejecutamos un programa con esta función y queremos dejarlo ejecutándose en segundo plano, hay que asegurarse que la salida del mismo es redireccionada a un fichero u otro flujo de salida o PHP se quedará esperando hasta que la ejecución del programa termine.

Ver también

  • exec() - Ejecutar un programa externo
  • passthru() - Ejecuta un programa externo y muestra la salida en bruto
  • popen() - Abre un proceso de un puntero a un fichero
  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos
  • pcntl_exec() - Executes specified program in current process space
  • el operador de comillas invertidas


parallel

  • Introducción
  • Installation
  • Philosophy
  • Functional API
    • parallel\bootstrap — Bootstrapping
    • parallel\run — Execution
  • parallel\Runtime — The parallel\Runtime class
    • parallel\Runtime::__construct — Runtime Construction
    • parallel\Runtime::run — Execution
    • parallel\Runtime::close — Runtime Graceful Join
    • parallel\Runtime::kill — Runtime Join
  • parallel\Future — The parallel\Future class
    • parallel\Future::cancel — Cancellation
    • parallel\Future::cancelled — State Detection
    • parallel\Future::done — State Detection
    • parallel\Future::value — Resolution
  • parallel\Channel — The parallel\Channel class
    • parallel\Channel::__construct — Channel Construction
    • parallel\Channel::make — Access
    • parallel\Channel::open — Access
    • parallel\Channel::recv — Sharing
    • parallel\Channel::send — Sharing
    • parallel\Channel::close — Closing
  • parallel\Events — The parallel\Events class
    • parallel\Events::setBlocking — Behaviour
    • parallel\Events::setTimeout — Behaviour
    • parallel\Events::setInput — Input
    • parallel\Events::addChannel — Targets
    • parallel\Events::addFuture — Targets
    • parallel\Events::remove — Targets
    • parallel\Events::poll — Polling
  • parallel\Events\Input — The parallel\Events\Input class
    • parallel\Events\Input::add — Inputs
    • parallel\Events\Input::clear — Inputs
    • parallel\Events\Input::remove — Inputs
  • parallel\Events\Event — The parallel\Events\Event class
  • parallel\Events\Event\Type — The parallel\Events\Event\Type class
  • parallel\Sync — The parallel\Sync class
    • parallel\Sync::__construct — Construction
    • parallel\Sync::get — Access
    • parallel\Sync::set — Access
    • parallel\Sync::wait — Synchronization
    • parallel\Sync::notify — Synchronization
    • parallel\Sync::__invoke — Synchronization


Introducción

parallel is a parallel concurrency extension for PHP 7.2+.

A brief description of the concepts core to parallel follows, more detailed information may be found within this section of the manual.

Runtime

A parallel\Runtime represents a PHP interpreter thread. A parallel\Runtime is configured with an optional bootstrap file passed to parallel\Runtime::__construct(), this is typically an autoloader, or some other preloading routine: The bootstrap file will be included before any task is executed.

After construction the parallel\Runtime remains available until it is closed, killed, or destroyed by the normal scoping rules of PHP objects. parallel\Runtime::run() allows the programmer to schedule tasks for execution in parallel. A parallel\Runtime has a FIFO schedule, tasks will be executed in the order that they are scheduled.

Functional API

parallel implements a functional, higher level API on top of parallel\Runtime that provides a single function entry point to executing parallel code with automatic scheduling: parallel\run().

Task

A task is simply a Closure intended for parallel execution. The Closure may contain almost any instruction, including nested closures. However, there are some instructions that are prohibited in tasks:

  • yield

  • use by-reference

  • declare class

  • declare named function

Nota:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Nota:

No instructions are prohibited in the files which the task may include.

Future

The parallel\Future is used to access the return value from the task, and exposes an API for cancellation of the task.

Channel

A task may be scheduled with arguments, use lexical scope variables (by-value), and return a value (via a parallel\Future), but these only allow uni-directional communication: They allow the programmer to send data into and retrieve data from a task, but do not allow bi-directional communication between tasks. The parallel\Channel API allows bi-directional communication between tasks, a parallel\Channel is a socket-like link between tasks that the programmer can use to send and receive data.

Events

The parallel\Events API implements a native feel (Traversable) event loop, and parallel\Events::poll() method. It allows the programmer to work with sets of channels and or futures. The programmer simply adds channels and futures to the event loop, optionally setting the input for writes with parallel\Events::setInput(), and enters into a foreach: parallel will read from and write to objects as they become available yielding parallel\Events\Event objects describing the operations that have occurred.

Ver también

  • Philosophy


Installation

Requerimientos

parallel requires a build of PHP with ZTS (Zend Thread Safety) enabled ( --enable-maintainer-zts or --enable-zts on Windows )

Precaución

Zend Thread Safety cannot be enabled post build; it is a build time configuration option.

parallel should build anywhere there is a working Posix Threads header (pthread.h) and ZTS build of PHP, including Windows (using the pthread-w32 project from redhat).

Instalación

parallel releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/parallel.

Windows users can download prebuilt release binaries from the » PECL website.

Precaución

Windows users need to take the additional step of adding pthreadVC2.dll (distributed with Windows releases) to their PATH.


Philosophy

This section contains philosophies important to writing parallel code and some details about the internal implementation of parallel.

Do not communicate by sharing memory; instead, share memory by communicating.

This philosophy which is embraced by parallel has its origins in Go, one of the most widely admired if not used platforms for writing parallel code at the moment. Go programmers have to work hard to live up to this ideal: PHP and parallel do all the hard work for the programmer, and by default.

In conventional threading models found in other languages, generally threads are communicating with one another through nothing more than by virtue of the fact that they operate in the same address space. The programmer must deploy mutual exclusion, condition variables, and other low level threading or synchronization primitives in order to ensure proper communication of state and consistency.

When the conventional model is inversed, it means that threads only share memory as a result of communication (a variable is passed over a Channel for example).

When parallel passes a variable from one thread to another by any means - Task arguments, return via Future, and Channels - it is passed by value. In all but the case of unbuffered channels, the variable is also buffered so that it may not change (or be destroyed) before it is used in whichever thread the variable is being passed to. An unbuffered read over a channel is the only instance in which a thread directly reads memory allocated by another thread, it can do so safely because the thread that owns the memory is waiting for the read to complete before it can continue to manipulate it, and the thread that does not own the memory reads by value. When both threads continue, they are no longer sharing memory.

This makes writing and reasoning about parallel code much easier than the conventional model of threading. It means the programmer does not need to consider that threads may be manipulating data concurrently, because that is not possible.

This also makes PHP the perfect platform for implementing a parallel concurrency API based on CSP (message passing over channels), because PHP itself is shared nothing - PHP threads operate in their own virtual address space by default, and so may only share memory by communicating.

Data should have a definitive single owner

When approaching the CSP model for the first time, a programmer versed in the traditional model of threading may find themselves looking for concurrent data structures, because that is what they are used too: they pass around shared objects for manipulation.

When it comes to the CSP model, there is no need for data structures to be shared by many tasks, and indeed, it is simpler if they are not. The data should be owned by a single task, changes to (or operations on) that data structure should be communicated over channels and performed by the owner of the data, the success, failure, or result (state) of the change (or operation) being communicated back.

Once again the share nothing nature of PHP and copy by value nature of parallel helps the programmer to achieve this goal, no data will be shared by accident, only ever as a result of communication.


Functional API

The parallel\Runtime API provides a great degree of control to the power PHP programmer, and those intimately familiar with writing applications that use parallel concurrency.

The functional API provides less control in exchange for the ability to make decisions for the programmer:

  • all executing runtimes are bootstrapped identically

  • scheduling is determined by the API, not the programmer

parallel\run() provides the guarantee that the task will begin to execute in parallel as soon as allowed by hardware and operating system constraints, without needlessly creating runtimes. For most applications the functional API should be preferred.

Tabla de contenidos

  • parallel\bootstrap — Bootstrapping
  • parallel\run — Execution


Bootstrapping

  • « Functional API
  • parallel\run »
  • PHP Manual
  • Functional API
  • Bootstrapping

parallel\bootstrap

(1.0.0)

parallel\bootstrap — Bootstrapping

Descripción

parallel\bootstrap ( string $file ) : void

Shall use the provided file to bootstrap all runtimes created for automatic scheduling via parallel\run().

Exceptions

Advertencia

Shall throw parallel\Runtime\Error\Bootstrap if previously called for this process.

Advertencia

Shall throw parallel\Runtime\Error\Bootstrap if called after parallel\run().

Ver también

  • parallel\Runtime::run


Execution

  • « parallel\bootstrap
  • parallel\Runtime »
  • PHP Manual
  • Functional API
  • Execution

parallel\run

(1.0.0)

parallel\run — Execution

Descripción

parallel\run ( Closure $task ) : Future|null

Shall schedule task for execution in parallel.

parallel\run ( Closure $task , array $argv ) : Future|null

Shall schedule task for execution in parallel, passing argv at execution time.

Automatic Scheduling

If a \parallel\Runtime internally created and cached by a previous call to parallel\run() is idle, it will be used to execute the task. If no \parallel\Runtime is idle parallel will create and cache a \parallel\Runtime.

Nota:

\parallel\Runtime objects created by the programmer are not used for automatic scheduling.

Parámetros

task

A Closure with specific characteristics.

argv

An array of arguments with specific characteristics to be passed to task at execution time.

Task Characteristics

Closures scheduled for parallel execution must not:

  • accept or return by reference
  • accept or return internal objects (see notes)
  • execute a limited set of instructions

Instructions prohibited in Closures intended for parallel execution are:

  • yield
  • use by-reference
  • declare class
  • declare named function

Nota:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Nota:

No instructions are prohibited in the files which the task may include.

Arguments Characteristics

Arguments must not:

  • contain references
  • contain resources
  • contain internal objects (see notes)

Nota:

In the case of file stream resources, the resource will be cast to the file descriptor and passed as int where possible, this is unsupported on Windows.

Internal Objects Notes

Internal objects generally use a custom structure which cannot be copied by value safely, PHP currently lacks the mechanics to do this (without serialization) and so only objects that do not use a custom structure may be shared.

Some internal objects do not use a custom structure, for example parallel\Events\Event and so may be shared.

Closures are a special kind of internal object and support being copied by value, and so may be shared.

Channels are central to writing parallel code and support concurrent access and execution by necessity, and so may be shared.

Advertencia

A user class that extends an internal class may use a custom structure as defined by the internal class, in which case they cannot be copied by value safely, and so may not be shared.

Valores devueltos

Advertencia

The return parallel\Future must not be ignored when the task contains a return or throw statement.

Exceptions

Advertencia

Shall throw parallel\Runtime\Error\Closed if parallel\Runtime was closed.

Advertencia

Shall throw parallel\Runtime\Error\IllegalFunction if task is a closure created from an internal function.

Advertencia

Shall throw parallel\Runtime\Error\IllegalInstruction if task contains illegal instructions.

Advertencia

Shall throw parallel\Runtime\Error\IllegalParameter if task accepts or argv contains illegal variables.

Advertencia

Shall throw parallel\Runtime\Error\IllegalReturn if task returns illegally.

Ver también

  • parallel\Runtime::run


The parallel\Runtime class

(0.8.0)

Runtime Objects

Each runtime represents a single PHP thread, the thread is created (and bootstrapped) upon construction. The thread then waits for tasks to be scheduled: Scheduled tasks will be executed FIFO and then the thread will resume waiting until more tasks are scheduled, or it's closed, killed, or destroyed by the normal scoping rules of PHP objects.

Advertencia

When a runtime is destroyed by the normal scoping rules of PHP objects, it will first execute all of the tasks that were scheduled, and block while doing so.

Runtime Bootstrapping

When a new runtime is created, it does not share code with the thread (or process) that created it. This means it doesn't have the same classes and functions loaded, nor the same autoloader set. In some cases, a very lightweight runtime is desirable because the tasks that will be scheduled do not need access to the code in the parent thread. In those cases where the tasks do need to access the same code, it is enough to set an autoloader as the bootstrap.

Nota:

preloading may be used in conjunction with parallel, in this case preloaded code is available without bootstrapping

Sinopsis de la Clase

final parallel\Runtime {
/* Create */
public __construct ( )
public __construct ( string $bootstrap )
/* Execute */
public run ( Closure $task ) : Future|null
public run ( Closure $task , array $argv ) : Future|null
/* Join */
public close ( ) : void
public kill ( ) : void
}

Tabla de contenidos

  • parallel\Runtime::__construct — Runtime Construction
  • parallel\Runtime::run — Execution
  • parallel\Runtime::close — Runtime Graceful Join
  • parallel\Runtime::kill — Runtime Join


Runtime Construction

  • « parallel\Runtime
  • parallel\Runtime::run »
  • PHP Manual
  • parallel\Runtime
  • Runtime Construction

parallel\Runtime::__construct

(0.8.0)

parallel\Runtime::__construct — Runtime Construction

Descripción

public parallel\Runtime::__construct ( )

Shall construct a new runtime without bootstrapping.

public parallel\Runtime::__construct ( string $bootstrap )

Shall construct a bootstrapped runtime.

Parámetros

bootstrap

The location of a bootstrap file, generally an autoloader.

Exceptions

Advertencia

Shall throw parallel\Runtime\Error if thread could not be created

Advertencia

Shall throw parallel\Runtime\Bootstrap if bootstrapping failed


Execution

  • « parallel\Runtime::__construct
  • parallel\Runtime::close »
  • PHP Manual
  • parallel\Runtime
  • Execution

parallel\Runtime::run

(0.8.0)

parallel\Runtime::run — Execution

Descripción

public parallel\Runtime::run ( Closure $task ) : Future|null

Shall schedule task for execution in parallel.

public parallel\Runtime::run ( Closure $task , array $argv ) : Future|null

Shall schedule task for execution in parallel, passing argv at execution time.

Parámetros

task

A Closure with specific characteristics.

argv

An array of arguments with specific characteristics to be passed to task at execution time.

Task Characteristics

Closures scheduled for parallel execution must not:

  • accept or return by reference
  • accept or return internal objects (see notes)
  • execute a limited set of instructions

Instructions prohibited in Closures intended for parallel execution are:

  • yield
  • use by-reference
  • declare class
  • declare named function

Nota:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Nota:

No instructions are prohibited in the files which the task may include.

Arguments Characteristics

Arguments must not:

  • contain references
  • contain resources
  • contain internal objects (see notes)

Nota:

In the case of file stream resources, the resource will be cast to the file descriptor and passed as int where possible, this is unsupported on Windows.

Internal Objects Notes

Internal objects generally use a custom structure which cannot be copied by value safely, PHP currently lacks the mechanics to do this (without serialization) and so only objects that do not use a custom structure may be shared.

Some internal objects do not use a custom structure, for example parallel\Events\Event and so may be shared.

Closures are a special kind of internal object and support being copied by value, and so may be shared.

Channels are central to writing parallel code and support concurrent access and execution by necessity, and so may be shared.

Advertencia

A user class that extends an internal class may use a custom structure as defined by the internal class, in which case they cannot be copied by value safely, and so may not be shared.

Valores devueltos

Advertencia

The return parallel\Future must not be ignored when the task contains a return or throw statement.

Exceptions

Advertencia

Shall throw parallel\Runtime\Error\Closed if parallel\Runtime was closed.

Advertencia

Shall throw parallel\Runtime\Error\IllegalFunction if task is a closure created from an internal function.

Advertencia

Shall throw parallel\Runtime\Error\IllegalInstruction if task contains illegal instructions.

Advertencia

Shall throw parallel\Runtime\Error\IllegalParameter if task accepts or argv contains illegal variables.

Advertencia

Shall throw parallel\Runtime\Error\IllegalReturn if task returns illegally.


Runtime Graceful Join

  • « parallel\Runtime::run
  • parallel\Runtime::kill »
  • PHP Manual
  • parallel\Runtime
  • Runtime Graceful Join

parallel\Runtime::close

(0.8.0)

parallel\Runtime::close — Runtime Graceful Join

Descripción

public parallel\Runtime::close ( ) : void

Shall request that the runtime shutsdown.

Nota:

Tasks scheduled for execution will be executed before the shutdown occurs.

Exceptions

Advertencia

Shall throw parallel\Runtime\Error\Closed if Runtime was already closed.


Runtime Join

  • « parallel\Runtime::close
  • parallel\Future »
  • PHP Manual
  • parallel\Runtime
  • Runtime Join

parallel\Runtime::kill

(0.8.0)

parallel\Runtime::kill — Runtime Join

Descripción

public parallel\Runtime::kill ( ) : void

Shall attempt to force the runtime to shutdown.

Nota:

Tasks scheduled for execution will not be executed, the currently running task shall be interrupted.

Advertencia

Internal function calls in progress cannot be interrupted.

Exceptions

Advertencia

Shall throw parallel\Runtime\Error\Closed if Runtime was closed.


The parallel\Future class

(0.8.0)

Futures

A Future represents the return value or uncaught exception from a task, and exposes an API for cancellation.

Ejemplo #1 Example showing Future as return value

<?php
$runtime = new \parallel\Runtime;
$future  = $runtime->run(function(){
    return "World";
});
printf("Hello %s\n", $future->value());
?>

El resultado del ejemplo sería algo similar a:

Hello World

The behaviour of a future also allows it to be used as a simple synchronization point even where the task does not return a value explicitly.

Ejemplo #2 Example showing Future as synchronization point

<?php
$runtime = new \parallel\Runtime;
$future  = $runtime->run(function(){
    echo "in child ";
    for ($i = 0; $i < 500; $i++) {
        if ($i % 10 == 0) {
            echo ".";
        }
    }
    echo " leaving child";
});

$future->value();
echo "\nparent continues\n";
?>

El resultado del ejemplo sería algo similar a:

in child .................................................. leaving child
parent continues

Sinopsis de la Clase

final parallel\Future {
/* Resolution */
public value ( ) : mixed
/* State */
public cancelled ( ) : bool
public done ( ) : bool
/* Cancellation */
public cancel ( ) : bool
}

Tabla de contenidos

  • parallel\Future::cancel — Cancellation
  • parallel\Future::cancelled — State Detection
  • parallel\Future::done — State Detection
  • parallel\Future::value — Resolution


Cancellation

  • « parallel\Future
  • parallel\Future::cancelled »
  • PHP Manual
  • parallel\Future
  • Cancellation

parallel\Future::cancel

(0.9.0)

parallel\Future::cancel — Cancellation

Descripción

public parallel\Future::cancel ( ) : bool

Shall try to cancel the task

Nota:

If task is running, it will be interrupted.

Advertencia

Internal function calls in progress cannot be interrupted.

Exceptions

Advertencia

Shall throw parallel\Future\Error\Killed if parallel\Runtime executing task was killed.

Advertencia

Shall throw parallel\Future\Error\Cancelled if task was already cancelled.


State Detection

  • « parallel\Future::cancel
  • parallel\Future::done »
  • PHP Manual
  • parallel\Future
  • State Detection

parallel\Future::cancelled

(0.9.0)

parallel\Future::cancelled — State Detection

Descripción

public parallel\Future::cancelled ( ) : bool

Shall indicate if the task was cancelled


State Detection

  • « parallel\Future::cancelled
  • parallel\Future::value »
  • PHP Manual
  • parallel\Future
  • State Detection

parallel\Future::done

(0.8.0)

parallel\Future::done — State Detection

Descripción

public parallel\Future::done ( ) : bool

Shall indicate if the task is completed


Resolution

  • « parallel\Future::done
  • parallel\Channel »
  • PHP Manual
  • parallel\Future
  • Resolution

parallel\Future::value

(0.8.0)

parallel\Future::value — Resolution

Descripción

public parallel\Future::value ( ) : mixed

Shall return (and if necessary wait for) return from task

Exceptions

Advertencia

Shall throw parallel\Future\Error if waiting failed (internal error).

Advertencia

Shall throw parallel\Future\Error\Killed if parallel\Runtime executing task was killed.

Advertencia

Shall throw parallel\Future\Error\Cancelled if task was cancelled.

Advertencia

Shall throw parallel\Future\Error\Foreign if task raised an unrecognized uncaught exception.

Advertencia

Shall rethrow Throwable uncaught in task


The parallel\Channel class

(0.9.0)

Unbuffered Channels

An unbuffered channel will block on calls to parallel\Channel::send() until there is a receiver, and block on calls to parallel\Channel::recv() until there is a sender. This means an unbuffered channel is not only a way to share data among tasks but also a simple method of synchronization.

An unbuffered channel is the fastest way to share data among tasks, requiring the least copying.

Buffered Channels

A buffered channel will not block on calls to parallel\Channel::send() until capacity is reached, calls to parallel\Channel::recv() will block until there is data in the buffer.

Closures over Channels

A powerful feature of parallel channels is that they allow the exchange of closures between tasks (and runtimes).

When a closure is sent over a channel the closure is buffered, it doesn't change the buffering of the channel transmitting the closure, but it does effect the static scope inside the closure: The same closure sent to different runtimes, or the same runtime, will not share their static scope.

This means that whenever a closure is executed that was transmitted by a channel, static state will be as it was when the closure was buffered.

Anonymous Channels

The anonymous channel constructor allows the programmer to avoid assigning names to every channel: parallel will generate a unique name for anonymous channels.

Sinopsis de la Clase

final parallel\Channel {
/* Anonymous Constructor */
public __construct ( )
public __construct ( int $capacity )
/* Access */
public make ( string $name ) : Channel
public make ( string $name , int $capacity ) : Channel
public open ( string $name ) : Channel
/* Sharing */
public recv ( ) : mixed
public send ( mixed $value ) : void
/* Closing */
public close ( ) : void
/* Constant for Infinitely Buffered */
const Infinite ;
}

Tabla de contenidos

  • parallel\Channel::__construct — Channel Construction
  • parallel\Channel::make — Access
  • parallel\Channel::open — Access
  • parallel\Channel::recv — Sharing
  • parallel\Channel::send — Sharing
  • parallel\Channel::close — Closing


Channel Construction

  • « parallel\Channel
  • parallel\Channel::make »
  • PHP Manual
  • parallel\Channel
  • Channel Construction

parallel\Channel::__construct

(1.1.0)

parallel\Channel::__construct — Channel Construction

Descripción

public parallel\Channel::__construct ( )

Shall make an anonymous unbuffered channel

public parallel\Channel::__construct ( int $capacity )

Shall make an anonymous buffered channel with the given capacity

Parámetros

capacity

May be Channel::Infinite or a positive integer


Access

  • « parallel\Channel::__construct
  • parallel\Channel::open »
  • PHP Manual
  • parallel\Channel
  • Access

parallel\Channel::make

(0.9.0)

parallel\Channel::make — Access

Descripción

public parallel\Channel::make ( string $name ) : Channel

Shall make an unbuffered channel with the given name

public parallel\Channel::make ( string $name , int $capacity ) : Channel

Shall make a buffered channel with the given name and capacity

Parámetros

name

The name of the channel.

capacity

May be Channel::Infinite or a positive integer

Exceptions

Advertencia

Shall throw parallel\Channel\Error\Existence if channel already exists.


Access

  • « parallel\Channel::make
  • parallel\Channel::recv »
  • PHP Manual
  • parallel\Channel
  • Access

parallel\Channel::open

(0.9.0)

parallel\Channel::open — Access

Descripción

public parallel\Channel::open ( string $name ) : Channel

Shall open the channel with the given name

Exceptions

Advertencia

Shall throw parallel\Channel\Error\Existence if channel does not exist.


Sharing

  • « parallel\Channel::open
  • parallel\Channel::send »
  • PHP Manual
  • parallel\Channel
  • Sharing

parallel\Channel::recv

(0.9.0)

parallel\Channel::recv — Sharing

Descripción

public parallel\Channel::recv ( ) : mixed

Shall recv a value from this channel

Exceptions

Advertencia

Shall throw parallel\Channel\Error\Closed if channel is closed.


Sharing

  • « parallel\Channel::recv
  • parallel\Channel::close »
  • PHP Manual
  • parallel\Channel
  • Sharing

parallel\Channel::send

(0.9.0)

parallel\Channel::send — Sharing

Descripción

public parallel\Channel::send ( mixed $value ) : void

Shall send the given value on this channel

Exceptions

Advertencia

Shall throw parallel\Channel\Error\Closed if channel is closed.

Advertencia

Shall throw parallel\Channel\Error\IllegalValue if value is illegal.


Closing

  • « parallel\Channel::send
  • parallel\Events »
  • PHP Manual
  • parallel\Channel
  • Closing

parallel\Channel::close

(0.9.0)

parallel\Channel::close — Closing

Descripción

public parallel\Channel::close ( ) : void

Shall close this channel

Exceptions

Advertencia

Shall throw parallel\Channel\Error\Closed if channel is closed.


The parallel\Events class

(0.9.0)

The Event Loop

The Event loop monitors the state of sets of futures and or channels (targets) in order to perform read (parallel\Future::value(), parallel\Channel::recv()) and write (parallel\Channel::send()) operations as the targets become available and the operations may be performed without blocking the event loop.

Sinopsis de la Clase

final parallel\Events implements Countable , Traversable {
/* Input */
public setInput ( Input $input ) : void
/* Targets */
public addChannel ( parallel\Channel $channel ) : void
public addFuture ( string $name , parallel\Future $future ) : void
public remove ( string $target ) : void
/* Behaviour */
public setBlocking ( bool $blocking ) : void
public setTimeout ( int $timeout ) : void
/* Polling */
public poll ( ) : Event|null
}

Tabla de contenidos

  • parallel\Events::setBlocking — Behaviour
  • parallel\Events::setTimeout — Behaviour
  • parallel\Events::setInput — Input
  • parallel\Events::addChannel — Targets
  • parallel\Events::addFuture — Targets
  • parallel\Events::remove — Targets
  • parallel\Events::poll — Polling


Behaviour

  • « parallel\Events
  • parallel\Events::setTimeout »
  • PHP Manual
  • parallel\Events
  • Behaviour

parallel\Events::setBlocking

(0.9.0)

parallel\Events::setBlocking — Behaviour

Descripción

By default when events are polled for, blocking will occur (at the PHP level) until the first event can be returned: Setting blocking mode to false will cause poll to return control if the first target polled is not ready.

This differs from setting a timeout of 0 with parallel\Events::setTimeout(), since a timeout of 0, while allowed, will cause an exception to be raised, which may be extremely slow or wasteful if what is really desired is non-blocking behaviour.

A non-blocking loop effects the return value of parallel\Events::poll(), such that it may be null before all events have been processed.

public parallel\Events::setBlocking ( bool $blocking ) : void

Shall set blocking mode

Exceptions

Advertencia

Shall throw parallel\Events\Error if loop has timeout set.


Behaviour

  • « parallel\Events::setBlocking
  • parallel\Events::setInput »
  • PHP Manual
  • parallel\Events
  • Behaviour

parallel\Events::setTimeout

(0.9.0)

parallel\Events::setTimeout — Behaviour

Descripción

By default when events are polled for, blocking will occur (at the PHP level) until the first event can be returned: Setting the timeout causes an exception to be thrown when the timeout is reached.

This differs from setting blocking mode to false with parallel\Events::setBlocking(), which will not cause an exception to be thrown.

public parallel\Events::setTimeout ( int $timeout ) : void

Shall set the timeout in microseconds

Exceptions

Advertencia

Shall throw parallel\Events\Error if loop is non-blocking.


Input

  • « parallel\Events::setTimeout
  • parallel\Events::addChannel »
  • PHP Manual
  • parallel\Events
  • Input

parallel\Events::setInput

(0.9.0)

parallel\Events::setInput — Input

Descripción

public parallel\Events::setInput ( Input $input ) : void

Shall set input for this event loop


Targets

  • « parallel\Events::setInput
  • parallel\Events::addFuture »
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::addChannel

(0.9.0)

parallel\Events::addChannel — Targets

Descripción

public parallel\Events::addChannel ( parallel\Channel $channel ) : void

Shall watch for events on the given channel

Exceptions

Advertencia

Shall throw parallel\Events\Error\Existence if channel was already added.


Targets

  • « parallel\Events::addChannel
  • parallel\Events::remove »
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::addFuture

(0.9.0)

parallel\Events::addFuture — Targets

Descripción

public parallel\Events::addFuture ( string $name , parallel\Future $future ) : void

Shall watch for events on the given future

Exceptions

Advertencia

Shall throw parallel\Events\Error\Existence if target with the given name was already added.


Targets

  • « parallel\Events::addFuture
  • parallel\Events::poll »
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::remove

(0.9.0)

parallel\Events::remove — Targets

Descripción

public parallel\Events::remove ( string $target ) : void

Shall remove the given target

Exceptions

Advertencia

Shall throw parallel\Events\Error\Existence if target with the given name was not found.


Polling

  • « parallel\Events::remove
  • parallel\Events\Input »
  • PHP Manual
  • parallel\Events
  • Polling

parallel\Events::poll

(0.9.0)

parallel\Events::poll — Polling

Descripción

public parallel\Events::poll ( ) : Event|null

Shall poll for the next event

Valores devueltos

Should there be no targets remaining, null shall be returned

Should this be a non-blocking loop, and blocking would occur, null shall be returned

Otherwise, the parallel\Events\Event returned describes the event.

Exceptions

Advertencia

Shall throw parallel\Events\Error\Timeout if timeout is used and reached.


The parallel\Events\Input class

(0.9.0)

Events Input

An Input object is a container for data that the parallel\Events object will write to parallel\Channel objects as they become available. Multiple event loops may share an Input container - parallel does not verify the contents of the container when it is set as the input for a parallel\Events object.

Nota:

When a parallel\Events object performs a write, the target is removed from the input object as if parallel\Events\Input::remove() were called.

Sinopsis de la Clase

final parallel\Events\Input {
public add ( string $target , mixed $value ) : void
public remove ( string $target ) : void
public clear ( ) : void
}

Tabla de contenidos

  • parallel\Events\Input::add — Inputs
  • parallel\Events\Input::clear — Inputs
  • parallel\Events\Input::remove — Inputs


Inputs

  • « parallel\Events\Input
  • parallel\Events\Input::clear »
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::add

(0.9.0)

parallel\Events\Input::add — Inputs

Descripción

public parallel\Events\Input::add ( string $target , mixed $value ) : void

Shall set input for the given target

Exceptions

Advertencia

Shall throw parallel\Events\Input\Error\Existence if input for target already exists.

Advertencia

Shall throw parallel\Events\Input\Error\IllegalValue if value is illegal (object, null).


Inputs

  • « parallel\Events\Input::add
  • parallel\Events\Input::remove »
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::clear

(0.9.0)

parallel\Events\Input::clear — Inputs

Descripción

public parallel\Events\Input::clear ( ) : void

Shall remove input for all targets


Inputs

  • « parallel\Events\Input::clear
  • parallel\Events\Event »
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::remove

(0.9.0)

parallel\Events\Input::remove — Inputs

Descripción

public parallel\Events\Input::remove ( string $target ) : void

Shall remove input for the given target

Exceptions

Advertencia

Shall throw parallel\Events\Input\Error\Existence if input for target does not exist.


The parallel\Events\Event class

(0.9.0)

Event Objects

When an Event is returned, Event::$object shall be removed from the loop that returned it, should the event be a write event the Input for Event::$source shall also be removed.

Sinopsis de la Clase

final parallel\Events\Event {
/* Shall be one of Event\Type constants */
public int $type ;
/* Shall be the source of the event (target name) */
public string $source ;
/* Shall be either Future or Channel */
public object $object ;
/* Shall be set for Read/Error events */
public $value ;
}


The parallel\Events\Event\Type class

(0.9.0)

Sinopsis de la Clase

final parallel\Events\Event\Type {
/* Event::$object was read into Event::$value */
const Read ;
/* Input for Event::$source written to Event::$object */
const Write ;
/* Event::$object (Channel) was closed */
const Close ;
/* Event::$object (Future) was cancelled */
const Cancel ;
/* Runtime executing Event::$object (Future) was killed */
const Kill ;
/* Event::$object (Future) raised error */
const Error ;
}


The parallel\Sync class

(1.1.0)

Low Level Synchronization

The parallel\Sync class provides access to low level synchronization primitives, mutex, condition variables, and allows the implementation of semaphores.

Synchronization for most applications is much better implemented using channels, however, in some cases authors of low level code may find it useful to be able to access these lower level mechanisms.

Sinopsis de la Clase

final parallel\Sync {
/* Constructor */
public __construct ( )
public __construct ( scalar $value )
/* Access */
public get ( ) : scalar
public set ( scalar $value )
/* Synchronization */
public wait ( )
public notify ( bool $all = ? )
public __invoke ( callable $critical )
}

Tabla de contenidos

  • parallel\Sync::__construct — Construction
  • parallel\Sync::get — Access
  • parallel\Sync::set — Access
  • parallel\Sync::wait — Synchronization
  • parallel\Sync::notify — Synchronization
  • parallel\Sync::__invoke — Synchronization


Construction

  • « parallel\Sync
  • parallel\Sync::get »
  • PHP Manual
  • parallel\Sync
  • Construction

parallel\Sync::__construct

(1.1.0)

parallel\Sync::__construct — Construction

Descripción

public parallel\Sync::__construct ( )

Shall construct a new synchronization object with no value

public parallel\Sync::__construct ( scalar $value )

Shall construct a new synchronization object containing the given scalar value

Exceptions

Advertencia

Shall throw parallel\Sync\Error\IllegalValue if value is non-scalar.


Access

  • « parallel\Sync::__construct
  • parallel\Sync::set »
  • PHP Manual
  • parallel\Sync
  • Access

parallel\Sync::get

(1.1.0)

parallel\Sync::get — Access

Descripción

public parallel\Sync::get ( ) : scalar

Shall atomically return the syncrhonization objects value


Access

  • « parallel\Sync::get
  • parallel\Sync::wait »
  • PHP Manual
  • parallel\Sync
  • Access

parallel\Sync::set

(1.1.0)

parallel\Sync::set — Access

Descripción

public parallel\Sync::set ( scalar $value )

Shall atomically set the value of the synchronization object

Exceptions

Advertencia

Shall throw parallel\Sync\Error\IllegalValue if value is non-scalar.


Synchronization

  • « parallel\Sync::set
  • parallel\Sync::notify »
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::wait

(1.1.0)

parallel\Sync::wait — Synchronization

Descripción

public parallel\Sync::wait ( )

Shall wait for notification on this synchronization object


Synchronization

  • « parallel\Sync::wait
  • parallel\Sync::__invoke »
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::notify

(1.1.0)

parallel\Sync::notify — Synchronization

Descripción

public parallel\Sync::notify ( bool $all = ? )

Shall notify one (by default) or all threads waiting on the synchronization object


Synchronization

  • « parallel\Sync::notify
  • pthreads »
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::__invoke

(1.1.0)

parallel\Sync::__invoke — Synchronization

Descripción

public parallel\Sync::__invoke ( callable $critical )

Shall exclusively enter into the critical code


pthreads

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Threaded — La clase Threaded
    • Threaded::chunk — Manipulation
    • Threaded::count — Manipulation
    • Threaded::extend — Runtime Manipulation
    • Threaded::from — Creation
    • Threaded::getTerminationInfo — Error Detection
    • Threaded::isRunning — State Detection
    • Threaded::isTerminated — State Detection
    • Threaded::isWaiting — State Detection
    • Threaded::lock — Synchronization
    • Threaded::merge — Manipulation
    • Threaded::notify — Synchronization
    • Threaded::notifyOne — Synchronization
    • Threaded::pop — Manipulation
    • Threaded::run — Execution
    • Threaded::shift — Manipulation
    • Threaded::synchronized — Synchronization
    • Threaded::unlock — Synchronization
    • Threaded::wait — Synchronization
  • Thread — La clase Thread
    • Thread::detach — Ejecución
    • Thread::getCreatorId — Identificación
    • Thread::getCurrentThread — Identificación
    • Thread::getCurrentThreadId — Identification
    • Thread::getThreadId — Identification
    • Thread::globally — Execution
    • Thread::isJoined — State Detection
    • Thread::isStarted — State Detection
    • Thread::join — Synchronization
    • Thread::kill — Ejecución
    • Thread::start — Execution
  • Worker — La clase Worker
    • Worker::collect — Collect references to completed tasks
    • Worker::getStacked — Gets the remaining stack size
    • Worker::isShutdown — State Detection
    • Worker::isWorking — State Detection
    • Worker::shutdown — Shutdown the worker
    • Worker::stack — Stacking work
    • Worker::unstack — Unstacking work
  • Collectable — La clase Collectable
    • Collectable::isGarbage — Determinar si un objeto ha sido marcado como basura
    • Collectable::setGarbage — Marcar un objeto como basura
  • Modificadores — Modificadores de métodos
  • Pool — La clase Pool
    • Pool::collect — Collect references to completed tasks
    • Pool::__construct — Creates a new Pool of Workers
    • Pool::resize — Resize the Pool
    • Pool::shutdown — Shutdown all workers
    • Pool::submit — Submits an object for execution
    • Pool::submitTo — Submits a task to a specific worker for execution
  • Mutex — La clase Mutex
    • Mutex::create — Create a Mutex
    • Mutex::destroy — Destroy Mutex
    • Mutex::lock — Acquire Mutex
    • Mutex::trylock — Attempt to Acquire Mutex
    • Mutex::unlock — Release Mutex
  • Cond — La clase Cond
    • Cond::broadcast — Broadcast a Condition
    • Cond::create — Create a Condition
    • Cond::destroy — Destroy a Condition
    • Cond::signal — Signal a Condition
    • Cond::wait — Wait for Condition


Introducción

pthreads es una API orientada a objetos que permite la ejecución multihilo en el espacio de usuario de PHP. Incluye todas las herramientas necesarias para crear aplicaciones multihilo. Las aplicaciones de PHP pueden crear, leer, escribir, ejecutar y sincronizar objetos Thread, Worker y Threaded.

Un objeto Threaded: Un objeto Threaded forma la base de la funcionalidad que permite a pthreads operar. Expone métodos de sincronización y algunas interfaces útiles para el programador.

Un Thread: El usuario puede implementar un Thread (Hilo) extendiendo la declaración de Thread que proporciona pthreads, implementando el método run. Cualquier miembro puede ser escrito y leído por cualquier contexto con una referencia al objeto Thread; también, cualquier contexto puede ejecutar cualquier método público o protegido. El método run de la implementación se ejecuta en un hilo diferente cuando se invoca al método start de la implementación desde el contexto (esto es, hilo o proceso) que lo creó. Solamente el contexto que crea el hilo puede iniciarlo y unirlo.

Un objeto Worker: Un Worker Thread posee un estado persistente, y estará disponible desde la llamada a start hasta que el objeto salga del ámbito, o se apague explícitamente. Cualquier contexto con una referencia puede apilar objetos sobre el Worker, los cuales serán ejecutados por el Worker en un Thread diferente. El método run de un Worker se ejecuta antes de cualquier objeto de la pila, de tal forma que se pueden inicializar recursos que podrían necesitar los objetos venideros.

Una Pool: Una Pool de hilos Worker se puede emplear para distribuir objetos Threaded entre objetos Worker. La clase Pool incluida implementa esta funcionalidad cuidando de realizar la referenciación de una manera apropiada. Introducida en v1.0.0, la implementación de Pool es la forma más fácil y eficiente de utilizar múltiples hilos.

Precaución

Pool es un objeto normal de PHP, por lo que sus instancias no deberían compartirse entre contextos.

Sincronización: Todos los objeto que crea pthreads poseen sincronización interna en la forma ( familiar para los programadores de Java ) de ::wait y ::notify. La invocación de ::wait sobre un objeto causará que el contexto espere a que otro contexto invoque a ::notify sobre el mismo objeto. Esto pertmite una sincronización potente entre objetos Threaded de PHP.

Precaución

Cualquier objeto cuyo propósito sea emplearlo en escenarios multihilo de una aplicación debería extender a Threaded.

Modificadores de métodos: Los métodos protegidos de objetos Threaded están protegidos por pthreads, por lo que solamente un contexto podría llamar a dichos métodos a la vez. Los métodos privados de objetos Threaded solamente pueden ser invocados desde dentro de un objeto Threaded durante su ejecución.

Almacenamiento de datos: Como regla general, cualquier tipo de dato que se pueda serializar puede ser empleado como un miembro de un objeto Threaded; puede ser leído y escrito desde cualquier contexto con una referencia al objeto Threaded. No todos los tipos de datos se almacenan en serie; los tipos básicos se almacenan en su forma verdadera. Los tipos complejos, los arrays, y los objetos que no son Threaded se almacenan en serie; pueden ser leídos y escritos en el objeto Threaded desde cualquier contexto con una referencia. Con la excepción de los objetos Threaded, cualquier referencia empleada para establecer un miembro de un objeto Threaded está separada de la referencia del objeto Threaded; los mismos datos pueden ser leídos directamente desde el objeto Threaded en cualquier momento por cualquier contexto con una referencia al objeto Threaded.

Miembros estáticos: Cuando se crea un nuevo contexto ( Thread o Worker ), generalmente se copia, aunque los recursos y los objetos con un estado interno se anulan (por motivos de seguridad). Esto permite que funcionen como un tipo de almacen local de hilos. Por ejemplo, al iniciar el contexto, una clase cuyos miembros estáticos incluyen información de conexión a un servidor de bases de datos y la conexión misma, tendrá simplemente la información de la conexión copiada, no la conexión, permitiendo que el nuevo contexto inicie una conexión de la misma forma que el contexto que la creó, almacenando la conexión en el mismo lugar sin afectar al contexto original.

Precaución

Cuando se ejecutan print_r, var_dump y otras funciones de depuración de objetos, estas no incluyen protección de recursividad.

Nota:

Recursos: Las extensiones y la funcionalidad que definen recursos de PHP no están preparados para este tipo de entorno; pthreads toma medidas preventivas para que los recursos sean compartidos entre contextos; sin embargo, para la mayoría de tipos de recursos debería considerarse inseguro. Se deberían extremar las precauciones al compartir recursos entre contextos.

Precaución

En el entorno en el que se ejecute pthreads, son necesarias algunas restricciones y limitaciones para proporcionar un entorno estable.


Requerimientos

pthreads requiere construir PHP con ZTS (Zend Thread Safety) habilitado ( --enable-maintainer-zts o --enable-zts on Windows )

Precaución

Zend Thread Safety no se puede activar después de la construcción; es una opción de construcción en tiempo de configuración.

pthreads debería construirse en un lugar donde haya una cabecera Posix Threads (pthread.h) funcionando y una construcción ZTS de PHP, incluyendo Windows (empleando el proyecto pthread-w32 de redhat).


Instalación

Las versiones de pthreads están alojadas por PECL, y el código fuente por » github; la ruta más sencilla para instalarla es la ruta normal de PECL: » https://pecl.php.net/package/pthreads.

Los usuarios de Windows pueden descargar los binarios de una versión preconstruida desde el sitio web de » PECL.

Precaución

Los usuarios de Windows necesitan realizar un paso más para añadir pthreadVC2.dll (distribuido con las versiones de Windows) a su PATH.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

PTHREADS_INHERIT_ALL (integer)
Las opciones predeterminadas para todos los Thread; hace que pthreads copie el entorno al iniciar nuevos Thread
PTHREADS_INHERIT_NONE (integer)
No heredar nada al iniciar nuevos Thread
PTHREADS_INHERIT_INI (integer)
Heredar las entradas INI al iniciar nuevos Thread
PTHREADS_INHERIT_CONSTANTS (integer)
Heredar las constantes declaradas por el usuario al iniciar nuevos Thread
PTHREADS_INHERIT_CLASSES (integer)
Heredar las clases declaradas por el usuario al iniciar nuevos Thread
PTHREADS_INHERIT_FUNCTIONS (integer)
Heredar las funciones declaradas por el usuario al iniciar nuevos Thread
PTHREADS_INHERIT_INCLUDES (integer)
Heredar la información del fichero incluido al iniciar nuevos Thread
PTHREADS_INHERIT_COMMENTS (integer)
Heredar todos los comentarios al iniciar nuevos Thread
PTHREADS_ALLOW_HEADERS (integer)
Permitir que los nuevos Thread envíen cabeceras a la salida estándar (normalmente prohibido)


La clase Threaded

(PECL pthreads >= 2.0.0)

Introducción

Los objetos Threaded forman la base de la capacidad de pthreads para ejecutar código de usuario en paralelo; exponen métodos de sincronización y varias interfaces útiles.

Lo más importante de los objetos Threaded es que proporcionan seguridad implícita para el programador; todas las operaciones en el ámbito del objeto son seguras.

Sinopsis de la Clase

Threaded implements Traversable , Countable , ArrayAccess {
/* Métodos */
public chunk ( int $size , bool $preserve ) : array
public count ( ) : int
public extend ( string $class ) : bool
public from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public getTerminationInfo ( ) : array
public isRunning ( ) : bool
public isTerminated ( ) : bool
public isWaiting ( ) : bool
public lock ( ) : bool
public merge ( mixed $from , bool $overwrite = ? ) : bool
public notify ( ) : bool
public notifyOne ( ) : bool
public pop ( ) : bool
public run ( ) : void
public shift ( ) : mixed
public synchronized ( Closure $block , mixed ...$args ) : mixed
public unlock ( ) : bool
public wait ( int $timeout = ? ) : bool
}

Tabla de contenidos

  • Threaded::chunk — Manipulation
  • Threaded::count — Manipulation
  • Threaded::extend — Runtime Manipulation
  • Threaded::from — Creation
  • Threaded::getTerminationInfo — Error Detection
  • Threaded::isRunning — State Detection
  • Threaded::isTerminated — State Detection
  • Threaded::isWaiting — State Detection
  • Threaded::lock — Synchronization
  • Threaded::merge — Manipulation
  • Threaded::notify — Synchronization
  • Threaded::notifyOne — Synchronization
  • Threaded::pop — Manipulation
  • Threaded::run — Execution
  • Threaded::shift — Manipulation
  • Threaded::synchronized — Synchronization
  • Threaded::unlock — Synchronization
  • Threaded::wait — Synchronization


Manipulation

  • « Threaded
  • Threaded::count »
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::chunk

(PECL pthreads >= 2.0.0)

Threaded::chunk — Manipulation

Descripción

public Threaded::chunk ( int $size , bool $preserve ) : array

Fetches a chunk of the objects property table of the given size, optionally preserving keys

Parámetros

size

The number of items to fetch

preserve

Preserve the keys of members, by default false

Valores devueltos

An array of items from the objects property table

Ejemplos

Ejemplo #1 Fetch a chunk of the property table

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump($safe->chunk(5));
?>

El resultado del ejemplo sería:

array(5) {
  [0]=>
  int(0)
  [1]=>
  int(1)
  [2]=>
  int(2)
  [3]=>
  int(3)
  [4]=>
  int(4)
}


Manipulation

  • « Threaded::chunk
  • Threaded::extend »
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::count

(PECL pthreads >= 2.0.0)

Threaded::count — Manipulation

Descripción

public Threaded::count ( ) : int

Returns the number of properties for this object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Counting the properties of an object

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump(count($safe));
?>

El resultado del ejemplo sería:

int(10)


Runtime Manipulation

  • « Threaded::count
  • Threaded::from »
  • PHP Manual
  • Threaded
  • Runtime Manipulation

Threaded::extend

(PECL pthreads >= 2.0.8)

Threaded::extend — Runtime Manipulation

Descripción

public Threaded::extend ( string $class ) : bool

Makes thread safe standard class at runtime

Parámetros

class

The class to extend

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Runtime inheritance

<?php
class My {}

Threaded::extend(My::class);

$my = new My();

var_dump($my instanceof Threaded);
?>

El resultado del ejemplo sería:

bool(true)


Creation

  • « Threaded::extend
  • Threaded::getTerminationInfo »
  • PHP Manual
  • Threaded
  • Creation

Threaded::from

(PECL pthreads >= 2.0.9)

Threaded::from — Creation

Advertencia

This method has been removed in pthreads v3. With the introduction of anonymous classes in PHP 7, these can now be used instead.

Descripción

public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded

Creates an anonymous Threaded object from closures

Parámetros

run

The closure to use for ::run

construct

The constructor to use for anonymous object

args

The arguments to pass to constructor

Valores devueltos

A new anonymous Threaded object

Ejemplos

Ejemplo #1 Thread safe objects from closures

<?php
$pool = new Pool(4);
$pool->submit(Collectable::from(function(){
    echo "Hello World";
    $this->setGarbage();
}));
/* ... */
$pool->shutdown();
?>

El resultado del ejemplo sería:

Hello World


Error Detection

  • « Threaded::from
  • Threaded::isRunning »
  • PHP Manual
  • Threaded
  • Error Detection

Threaded::getTerminationInfo

(PECL pthreads < 3.0.0)

Threaded::getTerminationInfo — Error Detection

Advertencia

This method has been removed in pthreads v3. Instead, the body of Threaded::run() can be wrapped in a try...catch block to detect errors (since most errors in PHP 7 have been converted to exceptions).

Descripción

public Threaded::getTerminationInfo ( ) : array

Retrieves terminal error information from the referenced object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

array containing the termination conditions of the referenced object

Ejemplos

Ejemplo #1 Detecting fatal errors in Threads

<?php
class My extends Thread {
    public function run() {
        @not_found();
    }
}

$my = new My();
$my->start();
$my->join();

var_dump($my->isTerminated(), $my->getTerminationInfo());
?>

El resultado del ejemplo sería:

bool(true)
array(4) {
  ["scope"]=>
  string(2) "My"
  ["function"]=>
  string(3) "run"
  ["file"]=>
  string(29) "/usr/src/pthreads/sandbox.php"
  ["line"]=>
  int(4)
}


State Detection

  • « Threaded::getTerminationInfo
  • Threaded::isTerminated »
  • PHP Manual
  • Threaded
  • State Detection

Threaded::isRunning

(PECL pthreads >= 2.0.0)

Threaded::isRunning — State Detection

Descripción

public Threaded::isRunning ( ) : bool

Tell if the referenced object is executing

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of state

Nota:

A object is considered running while executing the run method

Ejemplos

Ejemplo #1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isRunning());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

El resultado del ejemplo sería:

bool(true)


State Detection

  • « Threaded::isRunning
  • Threaded::isWaiting »
  • PHP Manual
  • Threaded
  • State Detection

Threaded::isTerminated

(PECL pthreads >= 2.0.0)

Threaded::isTerminated — State Detection

Descripción

public Threaded::isTerminated ( ) : bool

Tell if the referenced object was terminated during execution; suffered fatal errors, or threw uncaught exceptions

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of state

Ejemplos

Ejemplo #1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        i_do_not_exist();
    }
}
$my = new My();
$my->start();
$my->join();
var_dump($my->isTerminated());
?>

El resultado del ejemplo sería:

bool(true)


State Detection

  • « Threaded::isTerminated
  • Threaded::lock »
  • PHP Manual
  • Threaded
  • State Detection

Threaded::isWaiting

(PECL pthreads < 3.0.0)

Threaded::isWaiting — State Detection

Advertencia

This method has been removed in pthreads v3.

Descripción

public Threaded::isWaiting ( ) : bool

Tell if the referenced object is waiting for notification

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of state

Ejemplos

Ejemplo #1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$this->done)
                $thread->wait();
        }, $this);
    }

    protected $done;
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    var_dump(
        $thread->isWaiting());
    $thread->done = true;
    $thread->notify();
}, $my);
?>

El resultado del ejemplo sería:

bool(true)


Synchronization

  • « Threaded::isWaiting
  • Threaded::merge »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::lock

(PECL pthreads < 3.0.0)

Threaded::lock — Synchronization

Advertencia

This method has been removed in pthreads v3. The Threaded::synchronized() method should now be used.

Descripción

public Threaded::lock ( ) : bool

Lock the referenced objects property table

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Locking Object Properties

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** nobody can read or write **/
        var_dump($this->unlock());
        /** reading / writing resumed for all other contexts */
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

bool(true)
bool(true)


Manipulation

  • « Threaded::lock
  • Threaded::notify »
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::merge

(PECL pthreads >= 2.0.0)

Threaded::merge — Manipulation

Descripción

public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool

Merges data into the current object

Parámetros

from

The data to merge

overwrite

Overwrite existing keys, by default true

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Merging into the property table of a threaded object

<?php
$array = [];

while (count($array) < 10)
    $array[] = count($array);

$stdClass = new stdClass();
$stdClass->foo = "foo";
$stdClass->bar = "bar";
$stdClass->baz = "baz";

$safe = new Threaded();
$safe->merge($array);

$safe->foo = "bar";
$safe->merge($stdClass, false);

var_dump($safe);
?>

El resultado del ejemplo sería:

object(Threaded)#2 (13) {
  ["0"]=>
  int(0)
  ["1"]=>
  int(1)
  ["2"]=>
  int(2)
  ["3"]=>
  int(3)
  ["4"]=>
  int(4)
  ["5"]=>
  int(5)
  ["6"]=>
  int(6)
  ["7"]=>
  int(7)
  ["8"]=>
  int(8)
  ["9"]=>
  int(9)
  ["foo"]=>
  string(3) "bar"
  ["bar"]=>
  string(3) "bar"
  ["baz"]=>
  string(3) "baz"
}


Synchronization

  • « Threaded::merge
  • Threaded::notifyOne »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::notify

(PECL pthreads >= 2.0.0)

Threaded::notify — Synchronization

Descripción

public Threaded::notify ( ) : bool

Send notification to the referenced object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

El resultado del ejemplo sería:

bool(true)


Synchronization

  • « Threaded::notify
  • Threaded::pop »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::notifyOne

(PECL pthreads >= 3.0.0)

Threaded::notifyOne — Synchronization

Descripción

public Threaded::notifyOne ( ) : bool

Send notification to the referenced object. This unblocks at least one of the blocked threads (as opposed to unblocking all of them, as seen with Threaded::notify()).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notifyOne();
}, $my);
var_dump($my->join());
?>

El resultado del ejemplo sería:

bool(true)


Manipulation

  • « Threaded::notifyOne
  • Threaded::run »
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::pop

(PECL pthreads >= 2.0.0)

Threaded::pop — Manipulation

Descripción

public Threaded::pop ( ) : bool

Pops an item from the objects property table

Valores devueltos

The last item from the objects property table

Ejemplos

Ejemplo #1 Popping the last item from the property table of a threaded object

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->pop());
?>

El resultado del ejemplo sería:

int(9)


Execution

  • « Threaded::pop
  • Threaded::shift »
  • PHP Manual
  • Threaded
  • Execution

Threaded::run

(PECL pthreads >= 2.0.0)

Threaded::run — Execution

Descripción

public Threaded::run ( ) : void

The programmer should always implement the run method for objects that are intended for execution.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The methods return value, if used, will be ignored


Manipulation

  • « Threaded::run
  • Threaded::synchronized »
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::shift

(PECL pthreads >= 2.0.0)

Threaded::shift — Manipulation

Descripción

public Threaded::shift ( ) : mixed

Shifts an item from the objects property table

Valores devueltos

The first item from the objects property table

Ejemplos

Ejemplo #1 Shifting the first item from the property table of a threaded object

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->shift());
?>

El resultado del ejemplo sería:

int(0)


Synchronization

  • « Threaded::shift
  • Threaded::unlock »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::synchronized

(PECL pthreads >= 2.0.0)

Threaded::synchronized — Synchronization

Descripción

public Threaded::synchronized ( Closure $block , mixed ...$args ) : mixed

Executes the block while retaining the referenced objects synchronization lock for the calling context

Parámetros

block

The block of code to execute

args

Variable length list of arguments to use as function arguments to the block

Valores devueltos

The return value from the block

Ejemplos

Ejemplo #1 Synchronizing

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

El resultado del ejemplo sería:

bool(true)


Synchronization

  • « Threaded::synchronized
  • Threaded::wait »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::unlock

(PECL pthreads < 3.0.0)

Threaded::unlock — Synchronization

Advertencia

This method has been removed in pthreads v3. The Threaded::synchronized() method should now be used.

Descripción

public Threaded::unlock ( ) : bool

Unlock the referenced objects storage for the calling context

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Locking the property table of a threaded object

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** nobody can read or write **/
        var_dump($this->unlock());
        /** reading / writing resumed for all other contexts */
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

bool(true)
bool(true)


Synchronization

  • « Threaded::unlock
  • Thread »
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::wait

(PECL pthreads >= 2.0.0)

Threaded::wait — Synchronization

Descripción

public Threaded::wait ( int $timeout = ? ) : bool

Will cause the calling context to wait for notification from the referenced object

Parámetros

timeout

An optional timeout in microseconds

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

El resultado del ejemplo sería:

bool(true)


La clase Thread

(PECL pthreads >= 2.0.0)

Introducción

Cuando se invoca al método start de Thread, se ejecutará el código del método run en un Thread diferente, en paralelo.

Después de ejecutar el método run, el Thread terminará inmediatamente; será unido al Thread creador en el momento apropiado.

Advertencia

Depender del motor para determinar cuándo un Thread debería unirse podría ocasionar un comportamiento no deseado; el programador debería ser explícito siempre que sea posible.

Sinopsis de la Clase

Thread extends Threaded implements Countable , Traversable , ArrayAccess {
/* Métodos */
public detach ( ) : void
public getCreatorId ( ) : integer
public static getCurrentThread ( ) : Thread
public static getCurrentThreadId ( ) : int
public getThreadId ( ) : int
public static globally ( ) : mixed
public isJoined ( ) : bool
public isStarted ( ) : bool
public join ( ) : bool
public kill ( ) : void
public start ( int $options = ? ) : bool
/* Métodos heredados */
public Threaded::chunk ( int $size , bool $preserve ) : array
public Threaded::count ( ) : int
public Threaded::extend ( string $class ) : bool
public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public Threaded::getTerminationInfo ( ) : array
public Threaded::isRunning ( ) : bool
public Threaded::isTerminated ( ) : bool
public Threaded::isWaiting ( ) : bool
public Threaded::lock ( ) : bool
public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool
public Threaded::notify ( ) : bool
public Threaded::notifyOne ( ) : bool
public Threaded::pop ( ) : bool
public Threaded::run ( ) : void
public Threaded::shift ( ) : mixed
public Threaded::synchronized ( Closure $block , mixed ...$args ) : mixed
public Threaded::unlock ( ) : bool
public Threaded::wait ( int $timeout = ? ) : bool
}

Tabla de contenidos

  • Thread::detach — Ejecución
  • Thread::getCreatorId — Identificación
  • Thread::getCurrentThread — Identificación
  • Thread::getCurrentThreadId — Identification
  • Thread::getThreadId — Identification
  • Thread::globally — Execution
  • Thread::isJoined — State Detection
  • Thread::isStarted — State Detection
  • Thread::join — Synchronization
  • Thread::kill — Ejecución
  • Thread::start — Execution


Ejecución

  • « Thread
  • Thread::getCreatorId »
  • PHP Manual
  • Thread
  • Ejecución

Thread::detach

(PECL pthreads < 3.0.0)

Thread::detach — Ejecución

Descripción

public Thread::detach ( ) : void

Desconecta el hilo referenciado por el contexto de la llamada, ¡de manera peligrosa!

Advertencia

Este método puede causar una conducta indefinida o insegura. Por lo general no debe ser utilizado. Está presente en los casos de integridad y de uso avanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Identificación

  • « Thread::detach
  • Thread::getCurrentThread »
  • PHP Manual
  • Thread
  • Identificación

Thread::getCreatorId

(PECL pthreads >= 2.0.0)

Thread::getCreatorId — Identificación

Descripción

public Thread::getCreatorId ( ) : integer

Devolverá la identificación del hilo que creó el hilo referenciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una identificación numérica

Ejemplos

Ejemplo #1 Devuelve la identificación del hilo o proceso que el hilo referenciado creó.

<?php
class My extends Thread {
    public function run() {
        printf("%s created by Thread #%lu\n", __CLASS__, $this->getCreatorId());
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

My created by Thread #123456778899


Identificación

  • « Thread::getCreatorId
  • Thread::getCurrentThreadId »
  • PHP Manual
  • Thread
  • Identificación

Thread::getCurrentThread

(PECL pthreads >= 2.0.0)

Thread::getCurrentThread — Identificación

Descripción

public static Thread::getCurrentThread ( ) : Thread

Devuelve una referencia al hilo que está siendo ejecutado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto representando la ejecución del hilo actual.

Ejemplos

Ejemplo #1 Devuelve el hilo que se está ejecutando

<?php
class My extends Thread {
    public function run() {
        var_dump(Thread::getCurrentThread());
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

object(My)#2 (0) {
}


Identification

  • « Thread::getCurrentThread
  • Thread::getThreadId »
  • PHP Manual
  • Thread
  • Identification

Thread::getCurrentThreadId

(PECL pthreads >= 2.0.0)

Thread::getCurrentThreadId — Identification

Descripción

public static Thread::getCurrentThreadId ( ) : int

Will return the identity of the currently executing Thread

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A numeric identity

Ejemplos

Ejemplo #1 Return the identity of the currently executing Thread

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, Thread::getCurrentThreadId());
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

My is Thread #123456778899


Identification

  • « Thread::getCurrentThreadId
  • Thread::globally »
  • PHP Manual
  • Thread
  • Identification

Thread::getThreadId

(PECL pthreads >= 2.0.0)

Thread::getThreadId — Identification

Descripción

public Thread::getThreadId ( ) : int

Will return the identity of the referenced Thread

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A numeric identity

Ejemplos

Ejemplo #1 Return the identity of the referenced Thread

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, $this->getThreadId());
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

My is Thread #123456778899


Execution

  • « Thread::getThreadId
  • Thread::isJoined »
  • PHP Manual
  • Thread
  • Execution

Thread::globally

(PECL pthreads < 3.0.0)

Thread::globally — Execution

Advertencia

This method has been removed in pthreads v3.

Descripción

public static Thread::globally ( ) : mixed

Will execute a Callable in the global scope

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The return value of the Callable

Ejemplos

Ejemplo #1 Execute in the global scope

<?php
class My extends Thread {
    public function run() {
        global $std;

        Thread::globally(function(){
            $std = new stdClass;
        });

        var_dump($std);
    }
}
$my = new My();
$my->start();
?>

El resultado del ejemplo sería:

object(stdClass)#3 (0) {
}


State Detection

  • « Thread::globally
  • Thread::isStarted »
  • PHP Manual
  • Thread
  • State Detection

Thread::isJoined

(PECL pthreads >= 2.0.0)

Thread::isJoined — State Detection

Descripción

public Thread::isJoined ( ) : bool

Tell if the referenced Thread has been joined

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of state

Ejemplos

Ejemplo #1 Detect the state of the referenced Thread

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isJoined());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

El resultado del ejemplo sería:

bool(false)


State Detection

  • « Thread::isJoined
  • Thread::join »
  • PHP Manual
  • Thread
  • State Detection

Thread::isStarted

(PECL pthreads >= 2.0.0)

Thread::isStarted — State Detection

Descripción

public Thread::isStarted ( ) : bool

Tell if the referenced Thread was started

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean indication of state

Ejemplos

Ejemplo #1 Tell if the referenced Thread was started

<?php
$worker = new Worker();
$worker->start();
var_dump($worker->isStarted());
?>

El resultado del ejemplo sería:

bool(true)


Synchronization

  • « Thread::isStarted
  • Thread::kill »
  • PHP Manual
  • Thread
  • Synchronization

Thread::join

(PECL pthreads >= 2.0.0)

Thread::join — Synchronization

Descripción

public Thread::join ( ) : bool

Causes the calling context to wait for the referenced Thread to finish executing

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Join with the referenced Thread

<?php
class My extends Thread {
    public function run() {
        /* ... */
    }
}
$my = new My();
$my->start();
/* ... */
var_dump($my->join());
/* ... */
?>

El resultado del ejemplo sería:

bool(true)


Ejecución

  • « Thread::join
  • Thread::start »
  • PHP Manual
  • Thread
  • Ejecución

Thread::kill

(PECL pthreads < 3.0.0)

Thread::kill — Ejecución

Descripción

public Thread::kill ( ) : void

Fuerza a terminar al hilo referenciado.

Advertencia

El programador no debería terminar hilos por la fuerza normalmente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una indicación booleana indicando el éxito.

Ejemplos

Ejemplo #1 Termina el hilo referenciado

<?php
class T extends Thread {
    public function run() {
        $stdin = fopen("php://stdin", "r");
        while(($line = fgets($stdin))) {
            echo $line;
        }
    }
}

$t = new T();
$t->start();

var_dump($t->kill());
?>

El resultado del ejemplo sería:

bool(true)


Execution

  • « Thread::kill
  • Worker »
  • PHP Manual
  • Thread
  • Execution

Thread::start

(PECL pthreads >= 2.0.0)

Thread::start — Execution

Descripción

public Thread::start ( int $options = ? ) : bool

Will start a new Thread to execute the implemented run method

Parámetros

options

An optional mask of inheritance constants, by default PTHREADS_INHERIT_ALL

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Starting Threads

<?php
class My extends Thread {
    public function run() {
        /** ... **/
    }
}
$my = new My();
var_dump($my->start());
?>

El resultado del ejemplo sería:

bool(true)


La clase Worker

(PECL pthreads >= 2.0.0)

Introducción

Los hilos Worker poseen un contexto persistente, por lo que, en la mayoría de los casos, deberían emplearse sobre objetos Threads.

Cuando un Worker se inicia, se ejecutará el método run, pero el Thread no abandonará hasta que se dé una de las siguientes condiciones:

  • el Worker sale del ámbito (ya no quedan más referencias)

  • el programador llama al apagado

  • el script finaliza

Esto significa que el programador puede reutilizar el contexto durante toda la ejecución; la colocación de objetos en la pila del Worker ocasionará que el Worker ejecute los objetos apilados del método run.

Advertencia

El programador debe conservar referencias a los objetos apilados hasta que hayan sido ejecutados o desapilados; la clase Pool proporciona una abstracción de más alto nivel de la funcionalidad del Worker, administrando las referencias para el programador.

Sinopsis de la Clase

Worker extends Thread implements Traversable , Countable , ArrayAccess {
/* Métodos */
public collect ( Callable $collector = ? ) : int
public getStacked ( ) : int
public isShutdown ( ) : bool
public isWorking ( ) : bool
public shutdown ( ) : bool
public stack ( Threaded &$work ) : int
public unstack ( ) : int
/* Métodos heredados */
public Thread::detach ( ) : void
public Thread::getCreatorId ( ) : integer
public static Thread::getCurrentThread ( ) : Thread
public static Thread::getCurrentThreadId ( ) : int
public Thread::getThreadId ( ) : int
public static Thread::globally ( ) : mixed
public Thread::isJoined ( ) : bool
public Thread::isStarted ( ) : bool
public Thread::join ( ) : bool
public Thread::kill ( ) : void
public Thread::start ( int $options = ? ) : bool
}

Tabla de contenidos

  • Worker::collect — Collect references to completed tasks
  • Worker::getStacked — Gets the remaining stack size
  • Worker::isShutdown — State Detection
  • Worker::isWorking — State Detection
  • Worker::shutdown — Shutdown the worker
  • Worker::stack — Stacking work
  • Worker::unstack — Unstacking work


Collect references to completed tasks

  • « Worker
  • Worker::getStacked »
  • PHP Manual
  • Worker
  • Collect references to completed tasks

Worker::collect

(PECL pthreads >= 3.0.0)

Worker::collect — Collect references to completed tasks

Descripción

public Worker::collect ( Callable $collector = ? ) : int

Allows the worker to collect references determined to be garbage by the optionally given collector.

Parámetros

collector

A Callable collector that returns a boolean on whether the task can be collected or not. Only in rare cases should a custom collector need to be used.

Valores devueltos

The number of remaining tasks on the worker's stack to be collected.

Ejemplos

Ejemplo #1 A basic example of Worker::collect()

<?php
$worker = new Worker();

echo "There are currently {$worker->collect()} tasks on the stack to be collected\n";

for ($i = 0; $i < 15; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->collect()} tasks remaining on the stack to be collected\n";

$worker->start();

while ($worker->collect()); // blocks until all tasks have finished executing

echo "There are now {$worker->collect()} tasks on the stack to be collected\n";

$worker->shutdown();

El resultado del ejemplo sería:

There are currently 0 tasks on the stack to be collected
There are 15 tasks remaining on the stack to be collected
There are now 0 tasks on the stack to be collected


Gets the remaining stack size

  • « Worker::collect
  • Worker::isShutdown »
  • PHP Manual
  • Worker
  • Gets the remaining stack size

Worker::getStacked

(PECL pthreads >= 2.0.0)

Worker::getStacked — Gets the remaining stack size

Descripción

public Worker::getStacked ( ) : int

Returns the number of tasks left on the stack

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of tasks currently waiting to be executed by the worker

Ejemplos

Ejemplo #1 A basic example of Worker::getStacked

<?php
$worker = new Worker();

for ($i = 0; $i < 5; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->getStacked()} stacked tasks\n";

El resultado del ejemplo sería:

There are 5 stacked tasks


State Detection

  • « Worker::getStacked
  • Worker::isWorking »
  • PHP Manual
  • Worker
  • State Detection

Worker::isShutdown

(PECL pthreads >= 2.0.0)

Worker::isShutdown — State Detection

Descripción

public Worker::isShutdown ( ) : bool

Whether the worker has been shutdown or not.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns whether the worker has been shutdown or not.

Ejemplos

Ejemplo #1 Detect the state of a worker

<?php
$worker = new Worker();
$worker->start();

var_dump($worker->isShutdown());

$worker->shutdown();

var_dump($worker->isShutdown());

El resultado del ejemplo sería:

bool(false)
bool(true)


State Detection

  • « Worker::isShutdown
  • Worker::shutdown »
  • PHP Manual
  • Worker
  • State Detection

Worker::isWorking

(PECL pthreads >= 2.0.0)

Worker::isWorking — State Detection

Advertencia

This method has been removed in pthreads v3. The Worker::getStacked() method should be used to see if the worker still has tasks to execute.

Descripción

public Worker::isWorking ( ) : bool

Tell if a Worker is executing Stackables

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean indication of state

Ejemplos

Ejemplo #1 Detect the state of a Worker

<?php
$my = new Worker();
$my->start();
/* ... */
if ($my->isWorking()) {
    /* ... the Worker is busy executing another object */
}
?>


Shutdown the worker

  • « Worker::isWorking
  • Worker::stack »
  • PHP Manual
  • Worker
  • Shutdown the worker

Worker::shutdown

(PECL pthreads >= 2.0.0)

Worker::shutdown — Shutdown the worker

Descripción

public Worker::shutdown ( ) : bool

Shuts down the worker after executing all of the stacked tasks.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Whether the worker was successfully shutdown or not.

Ejemplos

Ejemplo #1 Shutdown the referenced worker

<?php
$my = new Worker();
$my->start();
/* stack/execute tasks */
var_dump($my->shutdown());

El resultado del ejemplo sería:

bool(true)


Stacking work

  • « Worker::shutdown
  • Worker::unstack »
  • PHP Manual
  • Worker
  • Stacking work

Worker::stack

(PECL pthreads >= 2.0.0)

Worker::stack — Stacking work

Descripción

public Worker::stack ( Threaded &$work ) : int

Appends the new work to the stack of the referenced worker.

Parámetros

work

A Threaded object to be executed by the worker.

Valores devueltos

The new size of the stack.

Ejemplos

Ejemplo #1 Stacking a task for execution onto a worker

<?php
$worker = new Worker();
$work = new class extends Threaded {};

var_dump($worker->stack($work));

El resultado del ejemplo sería:

int(1)


Unstacking work

  • « Worker::stack
  • Collectable »
  • PHP Manual
  • Worker
  • Unstacking work

Worker::unstack

(PECL pthreads >= 2.0.0)

Worker::unstack — Unstacking work

Descripción

public Worker::unstack ( ) : int

Removes the first task (the oldest one) in the stack.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The new size of the stack.

Historial de cambios

Versión | Descripción
v3 | The parameter to specify the task to unstack has been removed. Now, only the first task in the stack is removed.

Ejemplos

Ejemplo #1 Removing objects from the stack of Workers

<?php
$my = new Worker();
$work = new class extends Threaded {};

var_dump($my->stack($work));
var_dump($my->unstack());

El resultado del ejemplo sería:

int(1)
int(0)


La clase Collectable

(PECL pthreads >= 2.0.8)

Introducción

Representa un objeto apto para la recolección de basura.

Los objetos Collectable tienen por objeto ser utilizados por la clase Pool, remplazando los objetos Threaded como unidad de trabajo. Proporcionan métodos para establecer y detectar la recolección de un objeto.

Sinopsis de la Clase

Collectable extends Threaded {
/* Métodos */
public isGarbage ( ) : bool
public setGarbage ( ) : void
/* Métodos heredados */
public Threaded::chunk ( int $size , bool $preserve ) : array
public Threaded::count ( ) : int
public Threaded::extend ( string $class ) : bool
public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public Threaded::getTerminationInfo ( ) : array
public Threaded::isRunning ( ) : bool
public Threaded::isTerminated ( ) : bool
public Threaded::isWaiting ( ) : bool
public Threaded::lock ( ) : bool
public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool
public Threaded::notify ( ) : bool
public Threaded::notifyOne ( ) : bool
public Threaded::pop ( ) : bool
public Threaded::run ( ) : void
public Threaded::shift ( ) : mixed
public Threaded::synchronized ( Closure $block , mixed ...$args ) : mixed
public Threaded::unlock ( ) : bool
public Threaded::wait ( int $timeout = ? ) : bool
}

Tabla de contenidos

  • Collectable::isGarbage — Determinar si un objeto ha sido marcado como basura
  • Collectable::setGarbage — Marcar un objeto como basura


Determinar si un objeto ha sido marcado como basura

  • « Collectable
  • Collectable::setGarbage »
  • PHP Manual
  • Collectable
  • Determinar si un objeto ha sido marcado como basura

Collectable::isGarbage

(PECL pthreads >= 2.0.8)

Collectable::isGarbage — Determinar si un objeto ha sido marcado como basura

Descripción

public Collectable::isGarbage ( ) : bool

Se puede llamar en Pool::collect() para determinar si este objeto es basura.

Ver también

  • Pool::collect() - Collect references to completed tasks


Marcar un objeto como basura

  • « Collectable::isGarbage
  • Modificadores »
  • PHP Manual
  • Collectable
  • Marcar un objeto como basura

Collectable::setGarbage

(PECL pthreads < 3.0.0)

Collectable::setGarbage — Marcar un objeto como basura

Descripción

public Collectable::setGarbage ( ) : void

Debería invocarse una vez por objeto cuando este ha finalizado su ejecución o ya no existen referncia al mismo.

Ver también

  • Collectable::isGarbage() - Determinar si un objeto ha sido marcado como basura


Modificadores de métodos

pthreads sobrescribe la funcionalidad de los modificadores de métodos protegidos y privados para proporcionar funcionalidad más adecuada para objetos multihilo. pthreads aplica esta funcionalidad a todos los objetos Threaded desde su creación.

Ejemplo #1 Ejemplo de método protegido: los métodos protegidos solamente pueden ser ejecutados por un Thread a la vez.

<?php
class EjemploThread extends Thread {
    public function run() {
        /* código del Thread */
        if ($this->synchronized()) {

        }
    }

    protected function exclusive() {
        /* método sincronizado */
    }
}

$thread = new EjemploThread();
if ($thread->start()) {
    $thread->exclusive();
}
?>

Ejemplo #2 Ejemplo de método privado: los métodos privados solamente pueden ser ejecutados por el objeto Threaded durante su ejecución

<?php
class EjemploThread extends Thread {
    public function run() {
        /* código del Thread */
        if ($this->insideonly()) {

        }
    }

    private function insideonly() {
        /* método privado */
    }
}

$thread = new EjemploThread();
if ($thread->start()) {
    $thread->insideonly();
}
?>


La clase Pool

(PECL pthreads >= 2.0.0)

Introducción

Un objeto Pool es un contenedor para, y un controlador de, un número ajustable de Workers.

El aprovisionamiento (pooling) proporciona una abstracción de más alto nivel de la funcionalidad de un Worker, incluyendo la administración de referencias en la forma requerida por pthreads.

Sinopsis de la Clase

Pool {
/* Propiedades */
protected $size ;
protected $class ;
protected $workers ;
protected $work ;
protected $ctor ;
protected $last ;
/* Métodos */
public collect ( Callable $collector = ? ) : int
public __construct ( int $size , string $class = ? , array $ctor = ? ) : Pool
public resize ( int $size ) : void
public shutdown ( ) : void
public submit ( Threaded $task ) : int
public submitTo ( int $worker , Threaded $task ) : int
}

Propiedades

size

Número máximo de objetos Worker que puede utilizar este objeto Pool

class

La clase del objeto Worker

ctor

Los argumentos para el construcitor de los nuevos Workers

workers

Referencias a los Workers

work

Referencias a los objetos Threaded enviados al objeto Pool

last

Índice del último Worker usado

Tabla de contenidos

  • Pool::collect — Collect references to completed tasks
  • Pool::__construct — Creates a new Pool of Workers
  • Pool::resize — Resize the Pool
  • Pool::shutdown — Shutdown all workers
  • Pool::submit — Submits an object for execution
  • Pool::submitTo — Submits a task to a specific worker for execution


Collect references to completed tasks

  • « Pool
  • Pool::__construct »
  • PHP Manual
  • Pool
  • Collect references to completed tasks

Pool::collect

(PECL pthreads >= 2.0.0)

Pool::collect — Collect references to completed tasks

Descripción

public Pool::collect ( Callable $collector = ? ) : int

Allows the pool to collect references determined to be garbage by the optionally given collector.

Parámetros

collector

A Callable collector that returns a boolean on whether the task can be collected or not. Only in rare cases should a custom collector need to be used.

Valores devueltos

The number of remaining tasks in the pool to be collected.

Historial de cambios

Versión | Descripción
v3 | An integer is now returned, and the collector parameter is now optional.

Ejemplos

Ejemplo #1 A basic example of Pool::collect()

<?php
$pool = new Pool(4);

for ($i = 0; $i < 15; ++$i) {
    $pool->submit(new class extends Threaded {});
}

while ($pool->collect()); // blocks until all tasks have finished executing

$pool->shutdown();


Creates a new Pool of Workers

  • « Pool::collect
  • Pool::resize »
  • PHP Manual
  • Pool
  • Creates a new Pool of Workers

Pool::__construct

(PECL pthreads >= 2.0.0)

Pool::__construct — Creates a new Pool of Workers

Descripción

public Pool::__construct ( int $size , string $class = ? , array $ctor = ? ) : Pool

Construct a new pool of workers. Pools lazily create their threads, which means new threads will only be spawned when they are required to execute tasks.

Parámetros

size

The maximum number of workers for this pool to create

class

The class for new Workers. If no class is given, then it defaults to the Worker class.

ctor

An array of arguments to be passed to new workers' constructors

Valores devueltos

The new pool

Ejemplos

Ejemplo #1 Creating Pools

<?php
class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);

var_dump($pool);
?>

El resultado del ejemplo sería:

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  NULL
  ["work":protected]=>
  NULL
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(0)
}


Resize the Pool

  • « Pool::__construct
  • Pool::shutdown »
  • PHP Manual
  • Pool
  • Resize the Pool

Pool::resize

(PECL pthreads >= 2.0.0)

Pool::resize — Resize the Pool

Descripción

public Pool::resize ( int $size ) : void

Resize the Pool

Parámetros

size

The maximum number of Workers this Pool can create

Valores devueltos

void


Shutdown all workers

  • « Pool::resize
  • Pool::submit »
  • PHP Manual
  • Pool
  • Shutdown all workers

Pool::shutdown

(PECL pthreads >= 2.0.0)

Pool::shutdown — Shutdown all workers

Descripción

public Pool::shutdown ( ) : void

Shuts down all of the workers in the pool. This will block until all submitted tasks have been executed.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No value is returned.

Ejemplos

Ejemplo #1 Shutting down a pool

<?php
class Task extends Threaded
{
    public function run()
    {
        usleep(500000);
    }
}

$pool = new Pool(4);

for ($i = 0; $i < 10; ++$i) {
    $pool->submit(new Task());
}

$pool->shutdown(); // blocks until all submitted tasks have finished executing


Submits an object for execution

  • « Pool::shutdown
  • Pool::submitTo »
  • PHP Manual
  • Pool
  • Submits an object for execution

Pool::submit

(PECL pthreads >= 2.0.0)

Pool::submit — Submits an object for execution

Descripción

public Pool::submit ( Threaded $task ) : int

Submit the task to the next Worker in the Pool

Parámetros

task

The task for execution

Valores devueltos

the identifier of the Worker executing the object

Ejemplos

Ejemplo #1 Submitting Tasks

<?php
class MyWork extends Threaded {

    public function run() {
        /* ... */
    }
}

class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);
$pool->submit(new MyWork());
var_dump($pool);
?>

El resultado del ejemplo sería:

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  array(1) {
    [0]=>
    object(MyWorker)#4 (1) {
      ["something"]=>
      object(Something)#5 (0) {
      }
    }
  }
  ["work":protected]=>
  array(1) {
    [0]=>
    object(MyWork)#3 (1) {
      ["worker"]=>
      object(MyWorker)#5 (1) {
        ["something"]=>
        object(Something)#6 (0) {
        }
      }
    }
  }
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(1)
}


Submits a task to a specific worker for execution

  • « Pool::submit
  • Mutex »
  • PHP Manual
  • Pool
  • Submits a task to a specific worker for execution

Pool::submitTo

(PECL pthreads >= 2.0.0)

Pool::submitTo — Submits a task to a specific worker for execution

Descripción

public Pool::submitTo ( int $worker , Threaded $task ) : int

Submit a task to the specified worker in the pool. The workers are indexed from 0, and will only exist if the pool has needed to create them (since threads are lazily spawned).

Parámetros

worker

The worker to stack the task onto, indexed from 0.

task

The task for execution.

Valores devueltos

The identifier of the worker that accepted the task.

Ejemplos

Ejemplo #1 Submitting tasks to a specific worker

<?php
class Task extends Threaded {
    public function run() {
        var_dump(Thread::getCurrentThreadID());
    }
}

$pool = new Pool(2);

$pool->submit(new Task());

for ($i = 0; $i < 5; ++$i) {
    $pool->submitTo(0, new Task()); // stack all tasks onto the first worker
}

$pool->submitTo(1, new Task()); // cannot stack the task onto the second worker due to it not existing yet

$pool->shutdown();

El resultado del ejemplo sería:

int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)

Fatal error: Uncaught Exception: The selected worker (1) does not exist in %s:%d


La clase Mutex

(PECL pthreads < 3.0.0)

Introducción

Los métodos estáticos de la clase Mutex proporcionan acceso directo a la funcionalidad de Mutex de Posix.

Sinopsis de la Clase

Mutex {
/* Métodos */
final public static create ( bool $lock = ? ) : int
final public static destroy ( int $mutex ) : bool
final public static lock ( int $mutex ) : bool
final public static trylock ( int $mutex ) : bool
final public static unlock ( int $mutex , bool $destroy = ? ) : bool
}

Tabla de contenidos

  • Mutex::create — Create a Mutex
  • Mutex::destroy — Destroy Mutex
  • Mutex::lock — Acquire Mutex
  • Mutex::trylock — Attempt to Acquire Mutex
  • Mutex::unlock — Release Mutex


Create a Mutex

  • « Mutex
  • Mutex::destroy »
  • PHP Manual
  • Mutex
  • Create a Mutex

Mutex::create

(PECL pthreads < 3.0.0)

Mutex::create — Create a Mutex

Advertencia

The Mutex class has been removed in pthreads v3.

Descripción

final public static Mutex::create ( bool $lock = ? ) : int

Create, and optionally lock a new Mutex for the caller

Parámetros

lock

Setting lock to true will lock the Mutex for the caller before returning the handle

Valores devueltos

A newly created and optionally locked Mutex handle

Ejemplos

Ejemplo #1 Mutex Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You have the physical address of the Mutex **/
var_dump($mutex);
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

int(40096976)


Destroy Mutex

  • « Mutex::create
  • Mutex::lock »
  • PHP Manual
  • Mutex
  • Destroy Mutex

Mutex::destroy

(PECL pthreads < 3.0.0)

Mutex::destroy — Destroy Mutex

Advertencia

The Mutex class has been removed in pthreads v3.

Descripción

final public static Mutex::destroy ( int $mutex ) : bool

Destroying Mutex handles must be carried out explicitly by the programmer when they are finished with the Mutex handle.

Parámetros

mutex

A handle returned by a previous call to Mutex::create(). The handle should not be locked by any Thread when Mutex::destroy() is called.

Valores devueltos

A boolean indication of success

Ejemplos

Ejemplo #1 Mutex Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You have the physical address of the Mutex **/
var_dump($mutex);
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

int(40096976)


Acquire Mutex

  • « Mutex::destroy
  • Mutex::trylock »
  • PHP Manual
  • Mutex
  • Acquire Mutex

Mutex::lock

(PECL pthreads < 3.0.0)

Mutex::lock — Acquire Mutex

Advertencia

The Mutex class has been removed in pthreads v3.

Descripción

final public static Mutex::lock ( int $mutex ) : bool

Attempt to lock the Mutex for the caller.

An attempt to lock a Mutex owned (locked) by another Thread will result in blocking.

Parámetros

mutex

A handle returned by a previous call to Mutex::create().

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now lock the mutex in any context **/
var_dump(Mutex::lock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)


Attempt to Acquire Mutex

  • « Mutex::lock
  • Mutex::unlock »
  • PHP Manual
  • Mutex
  • Attempt to Acquire Mutex

Mutex::trylock

(PECL pthreads < 3.0.0)

Mutex::trylock — Attempt to Acquire Mutex

Advertencia

The Mutex class has been removed in pthreads v3.

Descripción

final public static Mutex::trylock ( int $mutex ) : bool

Attempt to lock the Mutex for the caller without blocking if the Mutex is owned (locked) by another Thread.

Parámetros

mutex

A handle returned by a previous call to Mutex::create().

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now try to lock the mutex in any context **/
var_dump(Mutex::trylock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)


Release Mutex

  • « Mutex::trylock
  • Cond »
  • PHP Manual
  • Mutex
  • Release Mutex

Mutex::unlock

(PECL pthreads < 3.0.0)

Mutex::unlock — Release Mutex

Advertencia

The Mutex class has been removed in pthreads v3.

Descripción

final public static Mutex::unlock ( int $mutex , bool $destroy = ? ) : bool

Attempts to unlock the Mutex for the caller, optionally destroying the Mutex handle. The calling thread should own the Mutex at the time of the call.

Parámetros

mutex

A handle returned by a previous call to Mutex::create().

destroy

When true pthreads will destroy the Mutex after a successful unlock.

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now lock the mutex in any context **/
var_dump(Mutex::lock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

bool(true)
bool(true)


La clase Cond

(PECL pthreads < 3.0.0)

Introducción

Los métodos estáticos de la clase Cond proporcionan acceso directo a las Variables de Condición de Posix.

Sinopsis de la Clase

Cond {
/* Métodos */
final public static broadcast ( int $condition ) : bool
final public static create ( ) : int
final public static destroy ( int $condition ) : bool
final public static signal ( int $condition ) : bool
final public static wait ( int $condition , int $mutex , int $timeout = ? ) : bool
}

Tabla de contenidos

  • Cond::broadcast — Broadcast a Condition
  • Cond::create — Create a Condition
  • Cond::destroy — Destroy a Condition
  • Cond::signal — Signal a Condition
  • Cond::wait — Wait for Condition


Broadcast a Condition

  • « Cond
  • Cond::create »
  • PHP Manual
  • Cond
  • Broadcast a Condition

Cond::broadcast

(PECL pthreads < 3.0.0)

Cond::broadcast — Broadcast a Condition

Advertencia

The Cond class has been removed in pthreads v3.

Descripción

final public static Cond::broadcast ( int $condition ) : bool

Broadcast to all Threads blocking on a call to Cond::wait().

Parámetros

condition

A handle to a Condition Variable returned by a previous call to Cond::create()

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Condition Broadcasting

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::broadcast($cond));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

El resultado del ejemplo sería:

bool(true)


Create a Condition

  • « Cond::broadcast
  • Cond::destroy »
  • PHP Manual
  • Cond
  • Create a Condition

Cond::create

(PECL pthreads < 3.0.0)

Cond::create — Create a Condition

Advertencia

The Cond class has been removed in pthreads v3.

Descripción

final public static Cond::create ( ) : int

Creates a new Condition Variable for the caller.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A handle to a Condition Variable

Ejemplos

Ejemplo #1 Condition Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** You can now use the Cond in any context **/
var_dump($cond);
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

El resultado del ejemplo sería:

int(4540682)


Destroy a Condition

  • « Cond::create
  • Cond::signal »
  • PHP Manual
  • Cond
  • Destroy a Condition

Cond::destroy

(PECL pthreads < 3.0.0)

Cond::destroy — Destroy a Condition

Advertencia

The Cond class has been removed in pthreads v3.

Descripción

final public static Cond::destroy ( int $condition ) : bool

Destroying Condition Variable handles must be carried out explicitly by the programmer when they are finished with the Condition Variable. No Threads should be blocking on a call to Cond::wait() when the call to Cond::destroy() takes place.

Parámetros

condition

A handle to a Condition Variable returned by a previous call to Cond::create()

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Condition Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** You can now use the Cond in any context **/
var_dump($cond);
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

El resultado del ejemplo sería:

int(4540682)


Signal a Condition

  • « Cond::destroy
  • Cond::wait »
  • PHP Manual
  • Cond
  • Signal a Condition

Cond::signal

(PECL pthreads < 3.0.0)

Cond::signal — Signal a Condition

Advertencia

The Cond class has been removed in pthreads v3.

Descripción

final public static Cond::signal ( int $condition ) : bool

Parámetros

condition

A handle returned by a previous call to Cond::create()

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Condition Signalling

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::signal($cond));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

El resultado del ejemplo sería:

bool(true)


Wait for Condition

  • « Cond::signal
  • pht »
  • PHP Manual
  • Cond
  • Wait for Condition

Cond::wait

(PECL pthreads < 3.0.0)

Cond::wait — Wait for Condition

Advertencia

The Cond class has been removed in pthreads v3.

Descripción

final public static Cond::wait ( int $condition , int $mutex , int $timeout = ? ) : bool

Wait for a signal on a Condition Variable, optionally specifying a timeout to limit waiting time.

Parámetros

condition

A handle returned by a previous call to Cond::create().

mutex

A handle returned by a previous call to Mutex::create() and owned (locked) by the caller.

timeout

An optional timeout, in microseconds ( millionths of a second ).

Valores devueltos

A boolean indication of success.

Ejemplos

Ejemplo #1 Waiting for Conditions

<?php
/** PLEASE NOTE THIS EXAMPLE WILL CAUSE THE PROCESS TO HANG **/
$mutex = Mutex::create(true);
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::wait($cond, $mutex));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
Mutex::unlock($mutex);
Mutex::destroy($mutex);
?>

El resultado del ejemplo sería:

int(49685473)


pht

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • pht\Thread — The Thread class
    • pht\Thread::addClassTask — Class threading
    • pht\Thread::addFileTask — File threading
    • pht\Thread::addFunctionTask — Function threading
    • pht\Thread::join — Joins a thread
    • pht\Thread::start — Starts the new thread
    • pht\Thread::taskCount — Gets a thread's task count
  • pht\Runnable — The Runnable interface
    • pht\Runnable::run — The entry point of a threaded class
  • pht\HashTable — The HashTable class
    • pht\HashTable::lock — Acquires the hash table's mutex lock
    • pht\HashTable::size — Gets the size of the hash table
    • pht\HashTable::unlock — Releases the hash table's mutex lock
  • pht\Vector — The Vector class
    • pht\Vector::__construct — Vector creation
    • pht\Vector::deleteAt — Deletes a value in the vector
    • pht\Vector::insertAt — Inserts a value into the vector
    • pht\Vector::lock — Acquires the vector's mutex lock
    • pht\Vector::pop — Pops a value to the vector
    • pht\Vector::push — Pushes a value to the vector
    • pht\Vector::resize — Resizes a vector
    • pht\Vector::shift — Shifts a value from the vector
    • pht\Vector::size — Gets the size of the vector
    • pht\Vector::unlock — Releases the vector's mutex lock
    • pht\Vector::unshift — Unshifts a value to the vector front
    • pht\Vector::updateAt — Updates a value in the vector
  • pht\Queue — The Queue class
    • pht\Queue::front — Returns the first value from a queue
    • pht\Queue::lock — Acquires the queue's mutex lock
    • pht\Queue::pop — Pops a value off of the front of a queue
    • pht\Queue::push — Pushes a value to the end of a queue
    • pht\Queue::size — Gets the size of the queue
    • pht\Queue::unlock — Releases the queue's mutex lock
  • pht\AtomicInteger — The AtomicInteger class
    • pht\AtomicInteger::__construct — AtomicInteger creation
    • pht\AtomicInteger::dec — Decrements the atomic integer's value by one
    • pht\AtomicInteger::get — Gets the atomic integer's value
    • pht\AtomicInteger::inc — Increments the atomic integer's value by one
    • pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock
    • pht\AtomicInteger::set — Sets the atomic integer's value
    • pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock
  • pht\Threaded — The Threaded interface
    • pht\Threaded::lock — Acquires the mutex lock
    • pht\Threaded::unlock — Releases the mutex lock


Introducción

pht is a new threading extension for PHP. It enables for classes, functions, and even entire files to be threaded. Currently, pht can only be used with PHP 7.2. This is due to ZTS mode being unsafe in PHP 7.0 and 7.1. Support for PHP >7.2 is coming soon.

Advertencia

The pht extension should not be used in a web server environment. Threading should be restricted to CLI-based applications only.

The approach to threading that pht takes is to abstract away the thread itself behind a dedicated object (pht\Thread). Tasks are then added to the thread's internal task queue, where they are processed when the thread is started (via pht\Thread::start()).

All thread tasks will execute in isolation inside of the newly spawned thread. For class tasks, this means the spawned objects cannot be passed around between threads. By keeping the threading contexts completely separate from one-another, there becomes no need to serialise the properties of threaded objects (which is a necessary evil if such objects have to operate in multiple threads).

The isolation of threading contexts makes the passing around of data between them somewhat problematic. To solve this problem, threadable data structures (pht\HashTable, pht\Vector, and pht\Queue) have been implemented to allow for a two-way communication style between threads, where they expose mutex locks to control their integrity. These data structures can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with them. They are reference-counted across threads, and so they do not need to be explicitly destroyed. This approach to threading means that only the given built-in data structures need to be safely passed around between threads.

Atomic values are also supported by pht. Currently, only an pht\AtomicInteger class exists. Like the threaded data structures, it too can safely be passed around between threads.


Requerimientos

pht requires a ZTS (Zend Thread Safety) version of PHP. Currently, only PHP 7.2 is supported. Support for PHP 7.3 (which will be released at the end of 2018) will be coming soon. PHP 7.0 and 7.1 are unsafe to support, due to race conditions in ZTS mode.

pht should be compatible for any OS with the pthread library (or pthread-win32 library, which is for Windows).


Instalación

pht releases are hosted (along with its source code) on the » pht GitHub repository. Unix developers will need to build from source (» instructions here). Windows developers can download the appropriate .dll file from the » repository's releases page. They will need to ensure that the provided pthreadVC2.dll file (which is distributed alongside the extension's .dll file) is made available in their PATH environment variable.


  • « Instalación
  • pht\Thread »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


The Thread class

(PECL pht >= 0.0.1)

Introducción

The pht\Thread class abstracts away a native thread. It has an internal task queue, where the methods pht\Thread::addClassTask(), pht\Thread::addFunctionTask(), and pht\Thread::addFileTask() push new tasks onto this queue. Invoking the pht\Thread::start() method will cause the new thread to be spawned, where it will then begin working through the task queue. A thread may be reused for any number of tasks.

Sinopsis de la Clase

pht\Thread {
/* Métodos */
public addClassTask ( string $className , mixed ...$ctorArgs ) : void
public addFileTask ( string $fileName , mixed ...$globals ) : void
public addFunctionTask ( callable $func , mixed ...$funcArgs ) : void
public join ( ) : void
public start ( ) : void
public taskCount ( ) : int
}

Tabla de contenidos

  • pht\Thread::addClassTask — Class threading
  • pht\Thread::addFileTask — File threading
  • pht\Thread::addFunctionTask — Function threading
  • pht\Thread::join — Joins a thread
  • pht\Thread::start — Starts the new thread
  • pht\Thread::taskCount — Gets a thread's task count


Class threading

  • « pht\Thread
  • pht\Thread::addFileTask »
  • PHP Manual
  • pht\Thread
  • Class threading

pht\Thread::addClassTask

(PECL pht >= 0.0.1)

pht\Thread::addClassTask — Class threading

Descripción

public pht\Thread::addClassTask ( string $className , mixed ...$ctorArgs ) : void

Adds a new class task to a pht\Threads internal task queue.

Parámetros

className

The name of the class to be threaded. This class must implement the pht\Runnable interface.

ctorArgs

An optional list of arguments for the threaded class' constructor. These arguments will be serialised (since they are being passed to another thread).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Adding a new class task to a thread

<?php

use pht\{Thread, Runnable};

class Task implements Runnable
{
    private $one;

    public function __construct(int $one)
    {
        $this->one = $one;
    }

    public function run()
    {
        var_dump($this->one);
    }
}

$thread = new Thread();

$thread->addClassTask(Task::class, 1);

$thread->start();
$thread->join();

El resultado del ejemplo sería:

int(1)


File threading

  • « pht\Thread::addClassTask
  • pht\Thread::addFunctionTask »
  • PHP Manual
  • pht\Thread
  • File threading

pht\Thread::addFileTask

(PECL pht >= 0.0.1)

pht\Thread::addFileTask — File threading

Descripción

public pht\Thread::addFileTask ( string $fileName , mixed ...$globals ) : void

Adds a new file task to a pht\Threads internal task queue.

Parámetros

func

The name of the file to be threaded.

globals

An optional list of arguments for the file. These arguments will be placed into a $_THREAD superglobal, which will be made available inside of the threaded file. All arguments will be serialised (since they are being passed to another thread).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Adding a new file task to a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->addFileTask('file.php', 1, 2, 3);

$thread->start();
$thread->join();

file.php:

<?php

[$one, $two, $three] = $_THREAD;

var_dump($one, $two, $three);

El resultado del ejemplo sería:

int(1)
int(2)
int(3)


Function threading

  • « pht\Thread::addFileTask
  • pht\Thread::join »
  • PHP Manual
  • pht\Thread
  • Function threading

pht\Thread::addFunctionTask

(PECL pht >= 0.0.1)

pht\Thread::addFunctionTask — Function threading

Descripción

public pht\Thread::addFunctionTask ( callable $func , mixed ...$funcArgs ) : void

Adds a new function task to a pht\Threads internal task queue.

Parámetros

func

The function to be threaded. If it is bound to an instance, then $this will become null.

funcArgs

An optional list of arguments for the function. These arguments will be serialised (since they are being passed to another thread).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Adding a new function task to a thread

<?php

use pht\Thread;

class Test
{
    public static function run(){var_dump(5);}
    public static function run2(){var_dump(6);}
}

function aFunc(){var_dump(3);}

$thread = new Thread();

$thread->addFunctionTask(static function($one) {var_dump($one);}, 1);
$thread->addFunctionTask(function() {var_dump(2);});
$thread->addFunctionTask('aFunc');
$thread->addFunctionTask('array_map', function ($n) {var_dump($n);}, [4]);
$thread->addFunctionTask(['Test', 'run']);
$thread->addFunctionTask([new Test, 'run2']);

$thread->start();
$thread->join();

El resultado del ejemplo sería:

int(1)
int(2)
int(3)
int(4)
int(5)
int(6)


Joins a thread

  • « pht\Thread::addFunctionTask
  • pht\Thread::start »
  • PHP Manual
  • pht\Thread
  • Joins a thread

pht\Thread::join

(PECL pht >= 0.0.1)

pht\Thread::join — Joins a thread

Descripción

public pht\Thread::join ( ) : void

This method will join the spawned thread (though it will first wait for that thread's internal task queue to finish). As a matter of good practice, threads should always be joined. Not joining a thread may lead to undefined behaviour.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Joining a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->start();
$thread->join();


Starts the new thread

  • « pht\Thread::join
  • pht\Thread::taskCount »
  • PHP Manual
  • pht\Thread
  • Starts the new thread

pht\Thread::start

(PECL pht >= 0.0.1)

pht\Thread::start — Starts the new thread

Descripción

public pht\Thread::start ( ) : void

This will cause a new thread to be spawned for the associated pht\Thread object, where its internal task queue will begin to be processed.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Starting a new thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->start();
$thread->join();


Gets a thread's task count

  • « pht\Thread::start
  • pht\Runnable »
  • PHP Manual
  • pht\Thread
  • Gets a thread's task count

pht\Thread::taskCount

(PECL pht >= 0.0.1)

pht\Thread::taskCount — Gets a thread's task count

Descripción

public pht\Thread::taskCount ( ) : int

Retrieves the current task count of a pht\Thread.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The number of tasks remaining to be processed.

Ejemplos

Ejemplo #1 Getting the task count of a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->addFunctionTask(function (){});
$thread->addFunctionTask(function (){});
$thread->addFunctionTask(function (){});

var_dump($thread->taskCount());

El resultado del ejemplo sería:

int(3)


The Runnable interface

(PECL pht >= 0.0.1)

Introducción

The pht\Runnable interface enforces the implementation of a run() method on classes that should be threaded. This method acts as the entry point of the threaded class.

Sinopsis de la Interfaz

pht\Runnable {
/* Métodos */
public run ( ) : void
}

Tabla de contenidos

  • pht\Runnable::run — The entry point of a threaded class


The entry point of a threaded class

  • « pht\Runnable
  • pht\HashTable »
  • PHP Manual
  • pht\Runnable
  • The entry point of a threaded class

pht\Runnable::run

(PECL pht >= 0.0.1)

pht\Runnable::run — The entry point of a threaded class

Descripción

public pht\Runnable::run ( ) : void

This method acts as the entry point of execution for a threaded class. It must be defined by all classes that will be threaded.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.


The HashTable class

(PECL pht >= 0.0.1)

Introducción

The pht\HashTable class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so it does not need to be explicitly destroyed.

The pht\HashTable class enables for array access upon its objects (along with the isset() and unset() functions). The ArrayAccess interface is not explicitly implemented, however, because it is only needed for such abilities by userland classes.

Sinopsis de la Clase

pht\HashTable implements pht\Threaded {
/* Métodos */
public lock ( ) : void
public size ( ) : int
public unlock ( ) : void
}

Tabla de contenidos

  • pht\HashTable::lock — Acquires the hash table's mutex lock
  • pht\HashTable::size — Gets the size of the hash table
  • pht\HashTable::unlock — Releases the hash table's mutex lock


Acquires the hash table's mutex lock

  • « pht\HashTable
  • pht\HashTable::size »
  • PHP Manual
  • pht\HashTable
  • Acquires the hash table's mutex lock

pht\HashTable::lock

(PECL pht >= 0.0.1)

pht\HashTable::lock — Acquires the hash table's mutex lock

Descripción

public pht\HashTable::lock ( ) : void

This method will acquire the mutex lock associated with the hash table. The mutex lock should always be acquired when manipulating the hash table if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a hash table's mutex lock

<?php

use pht\{Thread, HashTable};

$thread = new Thread();
$hashTable = new HashTable();

$thread->addFunctionTask(function ($hashTable) {
    $hashTable->lock();
    $hashTable['a'] = 1;
    $hashTable->unlock();
}, $hashTable);

$thread->start();

// $hashTable is currently being used by multiple threads
$hashTable->lock();
$hashTable['b'] = 2;
$hashTable->unlock();

$thread->join();


Gets the size of the hash table

  • « pht\HashTable::lock
  • pht\HashTable::unlock »
  • PHP Manual
  • pht\HashTable
  • Gets the size of the hash table

pht\HashTable::size

(PECL pht >= 0.0.1)

pht\HashTable::size — Gets the size of the hash table

Descripción

public pht\HashTable::size ( ) : int

Returns the current size of the hash table. This operation requires a pht\HashTable's mutex lock to be held if it is being used by multiple threads.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The size of the hash table.

Ejemplos

Ejemplo #1 Getting a hash table's size

<?php

use pht\HashTable;

$hashTable = new HashTable();

$hashTable['a'] = 1;
$hashTable['b'] = 2;

var_dump($hashTable->size());

El resultado del ejemplo sería:

int(2)


Releases the hash table's mutex lock

  • « pht\HashTable::size
  • pht\Vector »
  • PHP Manual
  • pht\HashTable
  • Releases the hash table's mutex lock

pht\HashTable::unlock

(PECL pht >= 0.0.1)

pht\HashTable::unlock — Releases the hash table's mutex lock

Descripción

public pht\HashTable::unlock ( ) : void

This method will release the mutex lock associated with the hash table.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a hash table's mutex lock

<?php

use pht\{Thread, HashTable};

$thread = new Thread();
$hashTable = new HashTable();

$thread->addFunctionTask(function ($hashTable) {
    $hashTable->lock();
    $hashTable['a'] = 1;
    $hashTable->unlock();
}, $hashTable);

$thread->start();

// $hashTable is currently being used by multiple threads
$hashTable->lock();
$hashTable['b'] = 2;
$hashTable->unlock();

$thread->join();


The Vector class

(PECL pht >= 0.0.1)

Introducción

The pht\Vector class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so is does not need to be explicitly destroyed.

The pht\Vector class enables for array access upon its objects (along with the isset() and unset() functions). The ArrayAccess interface is not explicitly implemented, however, because it is only needed for such abilities by userland classes.

Sinopsis de la Clase

pht\Vector implements pht\Threaded {
/* Métodos */
public __construct ( int $size = 0 , mixed $value = 0 ) : Vector
public deleteAt ( int $offset ) : void
public insertAt ( mixed $value , int $offset ) : void
public lock ( ) : void
public pop ( ) : mixed
public push ( mixed $value ) : void
public resize ( int $size , mixed $value = 0 ) : void
public shift ( ) : mixed
public size ( ) : int
public unlock ( ) : void
public unshift ( mixed $value ) : void
public updateAt ( mixed $value , int $offset ) : void
}

Tabla de contenidos

  • pht\Vector::__construct — Vector creation
  • pht\Vector::deleteAt — Deletes a value in the vector
  • pht\Vector::insertAt — Inserts a value into the vector
  • pht\Vector::lock — Acquires the vector's mutex lock
  • pht\Vector::pop — Pops a value to the vector
  • pht\Vector::push — Pushes a value to the vector
  • pht\Vector::resize — Resizes a vector
  • pht\Vector::shift — Shifts a value from the vector
  • pht\Vector::size — Gets the size of the vector
  • pht\Vector::unlock — Releases the vector's mutex lock
  • pht\Vector::unshift — Unshifts a value to the vector front
  • pht\Vector::updateAt — Updates a value in the vector


Vector creation

  • « pht\Vector
  • pht\Vector::deleteAt »
  • PHP Manual
  • pht\Vector
  • Vector creation

pht\Vector::__construct

(PECL pht >= 0.0.1)

pht\Vector::__construct — Vector creation

Descripción

public pht\Vector::__construct ( int $size = 0 , mixed $value = 0 ) : Vector

Handles the creation of a new vector.

Parámetros

size

The size of the vector that will be created.

value

The value to initialise the empty slots in the vector to.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Creating a new vector

<?php

use pht\Vector;

$vector1 = new Vector(1);
$vector2 = new Vector(2, 1);

var_dump($vector1, $vector2);

El resultado del ejemplo sería:

object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}
object(pht\Vector)#2 (2) {
  [0]=>
  int(1)
  [1]=>
  int(1)
}


Deletes a value in the vector

  • « pht\Vector::__construct
  • pht\Vector::insertAt »
  • PHP Manual
  • pht\Vector
  • Deletes a value in the vector

pht\Vector::deleteAt

(PECL pht >= 0.0.1)

pht\Vector::deleteAt — Deletes a value in the vector

Descripción

public pht\Vector::deleteAt ( int $offset ) : void

This method deletes a value at the specified offset in the vector (in linear time).

Since the pht\Vector class supports array access, deleting values can also be performed using the array subset notation ([]) in combination with the unset() function.

Parámetros

offset

The offset at which the value will be deleted at. This offset must be within the 0..(N-1) range (inclusive), where N is the size of the vector. Attempting to delete at offsets outside of this range will result in an Error exception.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Deleting values in a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;
$vector[] = 3;
$vector[] = 4;

$vector->deleteAt(1);
unset($vector[1]);

var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (2) {
  [0]=>
  int(1)
  [1]=>
  int(4)
}


Inserts a value into the vector

  • « pht\Vector::deleteAt
  • pht\Vector::lock »
  • PHP Manual
  • pht\Vector
  • Inserts a value into the vector

pht\Vector::insertAt

(PECL pht >= 0.0.1)

pht\Vector::insertAt — Inserts a value into the vector

Descripción

public pht\Vector::insertAt ( mixed $value , int $offset ) : void

This method inserts a value at the specified offset into the vector (in linear time). The vector will automatically be resized if it is not large enough.

Parámetros

value

The value to be inserted into the vector. This value will be serialised (since it may be passed around between threads).

offset

The offset at which the value will be inserted at. This offset must be within the 0..N range (inclusive), where N is the size of the vector. Inserting at position N is the equivalent of using pht\Vector::push(), and inserting at position 0 is the equivalent of using pht\Vector::unshift(). Attempting to insert at offsets outside of this range will result in an Error exception.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Inserting a value into a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->insertAt(3, 0); // insert 3 at start
$vector->insertAt(1, 0); // insert 1 at start (before 3)
$vector->insertAt(2, 1); // insert 2 in middle (after 1 and before 3)

var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Acquires the vector's mutex lock

  • « pht\Vector::insertAt
  • pht\Vector::pop »
  • PHP Manual
  • pht\Vector
  • Acquires the vector's mutex lock

pht\Vector::lock

(PECL pht >= 0.0.1)

pht\Vector::lock — Acquires the vector's mutex lock

Descripción

public pht\Vector::lock ( ) : void

This method will acquire the mutex lock associated with the vector. The mutex lock should always be acquired when manipulating the vector if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a vector's mutex lock

<?php

use pht\{Thread, Vector};

$thread = new Thread();
$vector = new Vector();

$thread->addFunctionTask(function ($vector) {
    $vector->lock();
    $vector[] = 1;
    $vector->unlock();
}, $vector);

$thread->start();

// $vector is currently being used by multiple threads
$vector->lock();
$vector[] = 2;
$vector->unlock();

$thread->join();


Pops a value to the vector

  • « pht\Vector::lock
  • pht\Vector::push »
  • PHP Manual
  • pht\Vector
  • Pops a value to the vector

pht\Vector::pop

(PECL pht >= 0.0.1)

pht\Vector::pop — Pops a value to the vector

Descripción

public pht\Vector::pop ( ) : mixed

This method pops a value from the end of a vector (in constant time). Popping a value from an empty vector will result in an Error exception.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value from the end of the vector.

Ejemplos

Ejemplo #1 Popping a value from a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector->pop());

El resultado del ejemplo sería:

int(2)


Pushes a value to the vector

  • « pht\Vector::pop
  • pht\Vector::resize »
  • PHP Manual
  • pht\Vector
  • Pushes a value to the vector

pht\Vector::push

(PECL pht >= 0.0.1)

pht\Vector::push — Pushes a value to the vector

Descripción

public pht\Vector::push ( mixed $value ) : void

This method pushes a value onto the end of a vector (in constant time). The vector will automatically be resized if it is not large enough.

Since the pht\Vector class supports array access, new values can also be pushed onto the vector using the empty subset notation ([]).

Parámetros

value

The value to be pushed onto the end of the vector. This value will be serialised (since it may be passed around between threads).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Pushing values to a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}


Resizes a vector

  • « pht\Vector::push
  • pht\Vector::shift »
  • PHP Manual
  • pht\Vector
  • Resizes a vector

pht\Vector::resize

(PECL pht >= 0.0.1)

pht\Vector::resize — Resizes a vector

Descripción

public pht\Vector::resize ( int $size , mixed $value = 0 ) : void

Resizes the vector. If it is enlarged, then the value parameter will be used to fill in the new slots. If it is made smaller, then the end values will be truncated.

Parámetros

size

The new size of the vector.

value

The value to initialise the empty vector slots to (only used if the vector is enlarged).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Resizing a vector

<?php

use pht\Vector;

$vector = new Vector(1);
var_dump($vector);
$vector->resize(2, 1);
var_dump($vector);
$vector->resize(1, 2); // unused second arg
var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}
object(pht\Vector)#1 (2) {
  [0]=>
  int(0)
  [1]=>
  int(1)
}
object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}


Shifts a value from the vector

  • « pht\Vector::resize
  • pht\Vector::size »
  • PHP Manual
  • pht\Vector
  • Shifts a value from the vector

pht\Vector::shift

(PECL pht >= 0.0.1)

pht\Vector::shift — Shifts a value from the vector

Descripción

public pht\Vector::shift ( ) : mixed

This method shifts a value from the front of a vector (in linear time). Shifting a value from an empty vector will result in an Error exception.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value from the front of the vector.

Ejemplos

Ejemplo #1 Shifting a value from a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector->shift());

El resultado del ejemplo sería:

int(1)


Gets the size of the vector

  • « pht\Vector::shift
  • pht\Vector::unlock »
  • PHP Manual
  • pht\Vector
  • Gets the size of the vector

pht\Vector::size

(PECL pht >= 0.0.1)

pht\Vector::size — Gets the size of the vector

Descripción

public pht\Vector::size ( ) : int

Returns the current size of the vector. This operation requires a pht\Vector's mutex lock to be held if it is being used by multiple threads.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The size of the vector.

Ejemplos

Ejemplo #1 Getting a vector's size

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;
$vector[] = 3;

var_dump($vector->size());

El resultado del ejemplo sería:

int(3)


Releases the vector's mutex lock

  • « pht\Vector::size
  • pht\Vector::unshift »
  • PHP Manual
  • pht\Vector
  • Releases the vector's mutex lock

pht\Vector::unlock

(PECL pht >= 0.0.1)

pht\Vector::unlock — Releases the vector's mutex lock

Descripción

public pht\Vector::unlock ( ) : void

This method will release the mutex lock associated with the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a vector's mutex lock

<?php

use pht\{Thread, Vector};

$thread = new Thread();
$vector = new Vector();

$thread->addFunctionTask(function ($vector) {
    $vector->lock();
    $vector[] = 1;
    $vector->unlock();
}, $vector);

$thread->start();

// $vector is currently being used by multiple threads
$vector->lock();
$vector[] = 2;
$vector->unlock();

$thread->join();


Unshifts a value to the vector front

  • « pht\Vector::unlock
  • pht\Vector::updateAt »
  • PHP Manual
  • pht\Vector
  • Unshifts a value to the vector front

pht\Vector::unshift

(PECL pht >= 0.0.1)

pht\Vector::unshift — Unshifts a value to the vector front

Descripción

public pht\Vector::unshift ( mixed $value ) : void

This method unshifts a value to the front of a vector (in linear time). The vector will automatically be resized if it is not large enough.

Parámetros

value

The value to be pushed onto the beginning of the vector. This value will be serialised (since it may be passed around between threads).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Unshifting a value to the front of a vector

<?php

use pht\Vector;

$vector = new Vector();

for ($i = 0; $i < 3; ++$i) {
    $vector->unshift($i); // causes a quadratic runtime, beware
}

var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (3) {
  [0]=>
  int(2)
  [1]=>
  int(1)
  [2]=>
  int(0)
}


Updates a value in the vector

  • « pht\Vector::unshift
  • pht\Queue »
  • PHP Manual
  • pht\Vector
  • Updates a value in the vector

pht\Vector::updateAt

(PECL pht >= 0.0.1)

pht\Vector::updateAt — Updates a value in the vector

Descripción

public pht\Vector::updateAt ( mixed $value , int $offset ) : void

This method updates a value at the specified offset in the vector (in linear time). The vector will automatically be resized if it is not large enough.

Since the pht\Vector class supports array access, updating values can also be performed using the array subset notation ([]).

Parámetros

value

The value to be inserted into the vector. This value will be serialised (since it may be passed around between threads).

offset

The offset at which the value will be updated at. This offset must be within the 0..(N-1) range (inclusive), where N is the size of the vector. Attempting to update at offsets outside of this range will result in an Error exception.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Updating a value in a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;

$vector->updateAt(3, 0);
$vector[1] = 4;

var_dump($vector);

El resultado del ejemplo sería:

object(pht\Vector)#1 (2) {
  [0]=>
  int(3)
  [1]=>
  int(4)
}


The Queue class

(PECL pht >= 0.0.1)

Introducción

The pht\Queue class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so it does not need to be explicitly destroyed.

Sinopsis de la Clase

pht\Queue implements pht\Threaded {
/* Métodos */
public front ( ) : mixed
public lock ( ) : void
public pop ( ) : mixed
public push ( mixed $value ) : void
public size ( ) : int
public unlock ( ) : void
}

Tabla de contenidos

  • pht\Queue::front — Returns the first value from a queue
  • pht\Queue::lock — Acquires the queue's mutex lock
  • pht\Queue::pop — Pops a value off of the front of a queue
  • pht\Queue::push — Pushes a value to the end of a queue
  • pht\Queue::size — Gets the size of the queue
  • pht\Queue::unlock — Releases the queue's mutex lock


Returns the first value from a queue

  • « pht\Queue
  • pht\Queue::lock »
  • PHP Manual
  • pht\Queue
  • Returns the first value from a queue

pht\Queue::front

(PECL pht >= 0.0.1)

pht\Queue::front — Returns the first value from a queue

Descripción

public pht\Queue::front ( ) : mixed

This method will remove a value from the front of the queue (in constant time). Attempting to return the front value from an empty queue will result in an Error exception.

Precaución

Due to the fact that all values in a pht\Queue are serialised, extracting a value from the queue will require it to be deserialised. This can incur a noticeable performance hit if the inspection of the queue's front value is performed within a loop.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value on the front of the queue.

Ejemplos

Ejemplo #1 Retrieving the front value of a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue->front());

El resultado del ejemplo sería:

int(1)

Ejemplo #2 Retrieving the front value in a loop (bad example - don't do this)

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(array_fill(0, 2000, 0));

for ($i = 0; $i < count($queue->front()); ++$i); // quadratic runtime

Ejemplo #3 Retrieving the front value in a loop (good example)

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(array_fill(0, 2000, 0));

$front = $queue->front(); // create a separate variable
for ($i = 0; $i < count($front); ++$i); // linear runtime


Acquires the queue's mutex lock

  • « pht\Queue::front
  • pht\Queue::pop »
  • PHP Manual
  • pht\Queue
  • Acquires the queue's mutex lock

pht\Queue::lock

(PECL pht >= 0.0.1)

pht\Queue::lock — Acquires the queue's mutex lock

Descripción

public pht\Queue::lock ( ) : void

This method will acquire the mutex lock associated with the queue. The mutex lock should always be acquired when manipulating the queue if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a queue's mutex lock

<?php

use pht\{Thread, Queue};

$thread = new Thread();
$queue = new Queue();

$thread->addFunctionTask(function ($queue) {
    $queue->lock();
    $queue->push(1);
    $queue->unlock();
}, $queue);

$thread->start();

// $queue is currently being used by multiple threads
$queue->lock();
$queue->push(1);
$queue->unlock();

$thread->join();

// $queue is only being used in this thread now, so no need to lock it
while ($queue->size()) {
    var_dump($queue->pop());
}

El resultado del ejemplo sería:

int(1)
int(1)


Pops a value off of the front of a queue

  • « pht\Queue::lock
  • pht\Queue::push »
  • PHP Manual
  • pht\Queue
  • Pops a value off of the front of a queue

pht\Queue::pop

(PECL pht >= 0.0.1)

pht\Queue::pop — Pops a value off of the front of a queue

Descripción

public pht\Queue::pop ( ) : mixed

This method will remove a value from the front of the queue (in constant time). Attempting to pop a value from an empty queue will result in an Error exception.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value removed from the queue.

Ejemplos

Ejemplo #1 Popping a value from a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue->pop());

El resultado del ejemplo sería:

int(1)


Pushes a value to the end of a queue

  • « pht\Queue::pop
  • pht\Queue::size »
  • PHP Manual
  • pht\Queue
  • Pushes a value to the end of a queue

pht\Queue::push

(PECL pht >= 0.0.1)

pht\Queue::push — Pushes a value to the end of a queue

Descripción

public pht\Queue::push ( mixed $value ) : void

This method will add a value onto the queue.

Parámetros

value

The value to be added to a pht\Queue. This value will be serialised (since it may be passed around between threads).

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Pushing a value to a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue);

El resultado del ejemplo sería:

object(pht\Queue)#1 (1) {
  [0]=>
  int(1)
}


Gets the size of the queue

  • « pht\Queue::push
  • pht\Queue::unlock »
  • PHP Manual
  • pht\Queue
  • Gets the size of the queue

pht\Queue::size

(PECL pht >= 0.0.1)

pht\Queue::size — Gets the size of the queue

Descripción

public pht\Queue::size ( ) : int

Returns the current size of the queue. This operation requires a pht\Queue's mutex lock to be held if it is being used by multiple threads.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The size of the queue.

Ejemplos

Ejemplo #1 Getting a queue's size

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);
$queue->push(1);

var_dump($queue->size());

El resultado del ejemplo sería:

int(2)


Releases the queue's mutex lock

  • « pht\Queue::size
  • pht\AtomicInteger »
  • PHP Manual
  • pht\Queue
  • Releases the queue's mutex lock

pht\Queue::unlock

(PECL pht >= 0.0.1)

pht\Queue::unlock — Releases the queue's mutex lock

Descripción

public pht\Queue::unlock ( ) : void

This method will release the mutex lock associated with the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Locking a queue's mutex lock

<?php

use pht\{Thread, Queue};

$thread = new Thread();
$queue = new Queue();

$thread->addFunctionTask(function ($queue) {
    $queue->lock();
    $queue->push(1);
    $queue->unlock();
}, $queue);

$thread->start();

// $queue is currently being used by multiple threads
$queue->lock();
$queue->push(1);
$queue->unlock();

$thread->join();

// $queue is only being used in this thread now, so no need to lock it
while ($queue->size()) {
    var_dump($queue->pop());
}

El resultado del ejemplo sería:

int(1)
int(1)


The AtomicInteger class

(PECL pht >= 0.0.1)

Introducción

The pht\AtomicInteger class is currently the only supported atomic value. It allows for an integer to be safely passed around between, and manipulated, by multiple threads. The methods exposed by this class do not need mutex locking, since they will acquire the internal mutex lock implicitly. pht\AtomicInteger::lock() and pht\AtomicInteger::unlock() are still exposed, however, for when multiple operations involving the same pht\AtomicInteger object need to be grouped together.

The mutex locks of the atomic values are reentrant safe.

Sinopsis de la Clase

pht\AtomicInteger implements pht\Threaded {
/* Métodos */
public __construct ( int $value = 0 ) : AtomicInteger
public dec ( ) : void
public get ( ) : int
public inc ( ) : void
public lock ( ) : void
public set ( int $value ) : void
public unlock ( ) : void
}

Tabla de contenidos

  • pht\AtomicInteger::__construct — AtomicInteger creation
  • pht\AtomicInteger::dec — Decrements the atomic integer's value by one
  • pht\AtomicInteger::get — Gets the atomic integer's value
  • pht\AtomicInteger::inc — Increments the atomic integer's value by one
  • pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock
  • pht\AtomicInteger::set — Sets the atomic integer's value
  • pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock


AtomicInteger creation

  • « pht\AtomicInteger
  • pht\AtomicInteger::dec »
  • PHP Manual
  • pht\AtomicInteger
  • AtomicInteger creation

pht\AtomicInteger::__construct

(PECL pht >= 0.0.1)

pht\AtomicInteger::__construct — AtomicInteger creation

Descripción

public pht\AtomicInteger::__construct ( int $value = 0 ) : AtomicInteger

Handles the creation of a new atomic integer.

Parámetros

value

The value to initialise the atomic integer to.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Creating a new atomic integer

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(100);

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(100)


Decrements the atomic integer's value by one

  • « pht\AtomicInteger::__construct
  • pht\AtomicInteger::get »
  • PHP Manual
  • pht\AtomicInteger
  • Decrements the atomic integer's value by one

pht\AtomicInteger::dec

(PECL pht >= 0.0.1)

pht\AtomicInteger::dec — Decrements the atomic integer's value by one

Descripción

public pht\AtomicInteger::dec ( ) : void

This method will decrement the atomic integer's value by one. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Decrementing an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->dec();
$atomicInteger->dec();

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(-2)


Gets the atomic integer's value

  • « pht\AtomicInteger::dec
  • pht\AtomicInteger::inc »
  • PHP Manual
  • pht\AtomicInteger
  • Gets the atomic integer's value

pht\AtomicInteger::get

(PECL pht >= 0.0.1)

pht\AtomicInteger::get — Gets the atomic integer's value

Descripción

public pht\AtomicInteger::get ( ) : int

This method will fetch the current value of the atomic integer. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current integer value of the atomic integer.

Ejemplos

Ejemplo #1 Getting an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(2)


Increments the atomic integer's value by one

  • « pht\AtomicInteger::get
  • pht\AtomicInteger::lock »
  • PHP Manual
  • pht\AtomicInteger
  • Increments the atomic integer's value by one

pht\AtomicInteger::inc

(PECL pht >= 0.0.1)

pht\AtomicInteger::inc — Increments the atomic integer's value by one

Descripción

public pht\AtomicInteger::inc ( ) : void

This method will increment the atomic integer's value by one. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Incrementing an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->inc();
$atomicInteger->inc();

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(2)


Acquires the atomic integer's mutex lock

  • « pht\AtomicInteger::inc
  • pht\AtomicInteger::set »
  • PHP Manual
  • pht\AtomicInteger
  • Acquires the atomic integer's mutex lock

pht\AtomicInteger::lock

(PECL pht >= 0.0.1)

pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock

Descripción

public pht\AtomicInteger::lock ( ) : void

This method will acquire the mutex lock associated with the atomic integer. The mutex lock only needs to be acquired when needing to group together multiple operations.

The mutex locks of the atomic values are reentrant safe. It is therefore valid for the same thread to reacquire a mutex lock that it has already acquired.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Grouping together an atomic integer's operations (requiring a mutex lock)

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

// assumes $atomicInteger is being used by multiple threads
$atomicInteger->lock();
$atomicInteger->set($atomicInteger->get() * 2); // double the value
$atomicInteger->unlock();

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(4)


Sets the atomic integer's value

  • « pht\AtomicInteger::lock
  • pht\AtomicInteger::unlock »
  • PHP Manual
  • pht\AtomicInteger
  • Sets the atomic integer's value

pht\AtomicInteger::set

(PECL pht >= 0.0.1)

pht\AtomicInteger::set — Sets the atomic integer's value

Descripción

public pht\AtomicInteger::set ( int $value ) : void

This method will set the value of the atomic integer. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

Parámetros

value

The value to set the atomic integer to.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Setting an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->set(20);

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(20)


Releases the atomic integer's mutex lock

  • « pht\AtomicInteger::set
  • pht\Threaded »
  • PHP Manual
  • pht\AtomicInteger
  • Releases the atomic integer's mutex lock

pht\AtomicInteger::unlock

(PECL pht >= 0.0.1)

pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock

Descripción

public pht\AtomicInteger::unlock ( ) : void

This method will release the mutex lock associated with the atomic integer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.

Ejemplos

Ejemplo #1 Grouping together an atomic integer's operations (requiring a mutex lock)

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

// assumes $atomicInteger is being used by multiple threads
$atomicInteger->lock();
$atomicInteger->set($atomicInteger->get() * 2); // double the value
$atomicInteger->unlock();

var_dump($atomicInteger->get());

El resultado del ejemplo sería:

int(4)


The Threaded interface

(PECL pht >= 0.0.1)

Introducción

The pht\Threaded interface is an internal interface used by the Inter-Thread Communication (ITC) data structures (pht\HashTable, pht\Queue, and pht\Vector). It allows those data structures to be threaded and ensures that the mutex locking API (pht\Threaded::lock() and pht\Threaded::unlock()) is implemented by each of the ITC data structures. It is not implementable by userland classes (since standalone mutex locks are not exposed).

Sinopsis de la Interfaz

pht\Threaded {
/* Métodos */
public lock ( ) : void
public unlock ( ) : void
}

Tabla de contenidos

  • pht\Threaded::lock — Acquires the mutex lock
  • pht\Threaded::unlock — Releases the mutex lock


Acquires the mutex lock

  • « pht\Threaded
  • pht\Threaded::unlock »
  • PHP Manual
  • pht\Threaded
  • Acquires the mutex lock

pht\Threaded::lock

(PECL pht >= 0.0.1)

pht\Threaded::lock — Acquires the mutex lock

Descripción

public pht\Threaded::lock ( ) : void

This method will acquire the mutex lock associated with the given class (either a pht\HashTable, pht\Queue, pht\Vector, or pht\AtomicInteger).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.


Releases the mutex lock

  • « pht\Threaded::lock
  • Semaphore »
  • PHP Manual
  • pht\Threaded
  • Releases the mutex lock

pht\Threaded::unlock

(PECL pht >= 0.0.1)

pht\Threaded::unlock — Releases the mutex lock

Descripción

public pht\Threaded::unlock ( ) : void

This method will unlock the mutex lock associated with the given class (either a pht\HashTable, pht\Queue, pht\Vector, or pht\AtomicInteger).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No return value.


Semáforo, Memoria Compartida e IPC

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Semáforo
    • ftok — Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V
    • msg_get_queue — Crear o adjuntar a una cola de mensajes
    • msg_queue_exists — Verificar si una cola de mensajes existe
    • msg_receive — Recibir un mensaje de la cola de mensajes
    • msg_remove_queue — Destruir una cola de mensajes
    • msg_send — Eviar un mensaje a una cola de mensajes
    • msg_set_queue — Establecer información en la estructura de datos de la cola de mensajes
    • msg_stat_queue — Devuelve información desde la estructura de datos de la cola de mensajes
    • sem_acquire — Adquirir un semáforo
    • sem_get — Obtener el id de un semáforo
    • sem_release — Liberar un semáforo
    • sem_remove — Eliminar un semáforo
    • shm_attach — Crea o abre un segmento de memoria compartida
    • shm_detach — Desconectarse del segmento de memoria compartida
    • shm_get_var — Devuelve una variable desde la memoria compartida
    • shm_has_var — Verificar si existe una entrada específica
    • shm_put_var — Inserta o actualiza una variable en la memoria compartida
    • shm_remove_var — Eliminar una variable de la memoria compartida
    • shm_remove — Elimina la memoria compartida de sistemas Unix


Introducción

Este módulo proporciona envolturas para la familia de funciones de IPC de System V. Incluye semáforos, memoria compartida y comunicación entre procesos (IPC).

Los semáforos se pueden usar para proveer acceso exclusivo a recursos en la máquina actual, o limitar el número de procesos que puede usar un recurso simultáneamente.

Este módulo también proporciona funciones de memoria compartida usando la memoria compartida de System V. La memoria compartida se puede usar para proveer acceso a variables globales. Diferentes demonios httpd e incluso otros programas (tales como Perl, C, ...) son capaces de acceder a estos datos para proporcionar un intercambio de datos global. Recuerde que la memoria compartida NO es segura en accesos simultáneos. Use los semáforos para la sincronización.

Límites de la memoria compartida impuestos por Unix OS
SHMMAX | tamaño máximo de memoria compartida, normalmente 131072 bytes
SHMMIN | tamaño mínimo de memoria compartida, normalmente 1 byte
SHMMNI | cantidad máxima de segmentos de memoria compartida en un sistema, normalmente 100
SHMSEG | cantidad máxima de segmentos de memoria compartida por proceso, normalmente 6

Las funciones de comunicación se pueden usar para enviar y recibir mensajes hacia/desde otros procesos. Proporcionan medios efectivos y sencillos para intercambiar datos entre los procesos, sin la necesidad de configurar una alternativa usando sockets de dominio Unix.

Nota: Esta extensión no está disponible en plataformas Windows.


Instalación

Por defecto, el soporte para estas funciones no está disponible. Para habilitar el soporte del semáforo de System V compile PHP con la opción --enable-sysvsem. Para habilitar el soporte de la memoria compartida de System V compile PHP con la opción --enable-sysvshm. Para habilitar el soporte de mensajes de System V compile PHP con la opción --enable-sysvmsg.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración del Semáforo
Nombre | Por defecto | Cambiable | Historial de cambios
sysvshm.init_mem | 10000 | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

sysvshm.init_mem int

Un tamaño predeterminado del segmento de memoria compartida.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes de mensage de System V
Constante | Tipo | Registro de Cambios
MSG_IPC_NOWAIT | integer |
MSG_EAGAIN | integer | A partir de 5.2.0
MSG_ENOMSG | integer | A partir de 5.2.0
MSG_NOERROR | integer |
MSG_EXCEPT | integer |


Funciones de Semáforo

Tabla de contenidos

  • ftok — Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V
  • msg_get_queue — Crear o adjuntar a una cola de mensajes
  • msg_queue_exists — Verificar si una cola de mensajes existe
  • msg_receive — Recibir un mensaje de la cola de mensajes
  • msg_remove_queue — Destruir una cola de mensajes
  • msg_send — Eviar un mensaje a una cola de mensajes
  • msg_set_queue — Establecer información en la estructura de datos de la cola de mensajes
  • msg_stat_queue — Devuelve información desde la estructura de datos de la cola de mensajes
  • sem_acquire — Adquirir un semáforo
  • sem_get — Obtener el id de un semáforo
  • sem_release — Liberar un semáforo
  • sem_remove — Eliminar un semáforo
  • shm_attach — Crea o abre un segmento de memoria compartida
  • shm_detach — Desconectarse del segmento de memoria compartida
  • shm_get_var — Devuelve una variable desde la memoria compartida
  • shm_has_var — Verificar si existe una entrada específica
  • shm_put_var — Inserta o actualiza una variable en la memoria compartida
  • shm_remove_var — Eliminar una variable de la memoria compartida
  • shm_remove — Elimina la memoria compartida de sistemas Unix


Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V

  • « Funciones de Semáforo
  • msg_get_queue »
  • PHP Manual
  • Funciones de Semáforo
  • Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V

ftok

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftok — Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V

Descripción

ftok ( string $pathname , string $proj ) : int

La función conviete el nombre de ruta dado por pathname de un archivo existente accesible y un identificador de proyecto a un valor de tipo integer para usarlo, por ejemplo, con shmop_open() y otras claves IPC de System V.

Parámetros

pathname

Ruta a un archivo accedible.

proj

Identificador de proyecto. Debe ser una cadena de un carácter.

Valores devueltos

Si se tuvo éxito, el valor devuelto será el valor de la clave creada, de otro modo se devolverá -1.

Ver también

  • shmop_open() - Crea o abre un segmento de memoria compartida
  • sem_get() - Obtener el id de un semáforo


Crear o adjuntar a una cola de mensajes

  • « ftok
  • msg_queue_exists »
  • PHP Manual
  • Funciones de Semáforo
  • Crear o adjuntar a una cola de mensajes

msg_get_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_get_queue — Crear o adjuntar a una cola de mensajes

Descripción

msg_get_queue ( int $key , int $perms = 0666 ) : resource

msg_get_queue() devuelve un id que se puede usar para acceder a la cola de mensajes de System V con la clave dada por key. La primera llamada crea la cola de mensajes con los permisos opcionales dados por perms. Una segunda llamada a msg_get_queue() por la misma clave key devolverá un identificador de cola de mensajes diferente, pero ambos identificadores acceden a la misma cola de mensajes subyacente.

Parámetros

key

ID numérico de la cola de mensajes

perms

Permisos de la cola. Por defecto es 0666. Si la cola de mensajes ya existe, perms será ignorado.

Valores devueltos

Devuelve un gestor de recurso que se puede usar para acceder a la cola de mensajes de System V.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_send() - Eviar un mensaje a una cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes
  • msg_set_queue() - Establecer información en la estructura de datos de la cola de mensajes


Verificar si una cola de mensajes existe

  • « msg_get_queue
  • msg_receive »
  • PHP Manual
  • Funciones de Semáforo
  • Verificar si una cola de mensajes existe

msg_queue_exists

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

msg_queue_exists — Verificar si una cola de mensajes existe

Descripción

msg_queue_exists ( int $key ) : bool

Verifica si la clave dada por el parámetro key de la cola de mensajes existe.

Parámetros

key

La clave de la cola.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes


Recibir un mensaje de la cola de mensajes

  • « msg_queue_exists
  • msg_remove_queue »
  • PHP Manual
  • Funciones de Semáforo
  • Recibir un mensaje de la cola de mensajes

msg_receive

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_receive — Recibir un mensaje de la cola de mensajes

Descripción

msg_receive ( resource $queue , int $desiredmsgtype , int &$msgtype , int $maxsize , mixed &$message , bool $unserialize = true , int $flags = 0 , int &$errorcode = ? ) : bool

msg_receive() recibirá el primer mensaje de la cola especificada por queue del tipo especificado por desiredmsgtype.

Parámetros

queue

desiredmsgtype

Si desiredmsgtype es 0, se devolverá el mensaje al frente de la cola. Si desiredmsgtype es mayor que 0, se devolverá el primer mensaje de ese tipo. Si desiredmsgtype es menor que 0, se leerá el primer mensaje de la cola con el tipo más bajo menor o igual que el valor absoluto de desiredmsgtype. Si ningún mensaje concuerda con el criterio, el script esperará hasta que un mensaje apropiado llegue a la cola. Se puede prevenir que se bloquee el script especificando MSG_IPC_NOWAIT en el parámetro flags.

msgtype

El tipo de mensaje que fue recibido se almacenará en este parámetro.

maxsize

El tamaño máximo del mensaje aceptado se especifica mediante maxsize; si el mensaje de la cola es mayor que este tamaño la función fallará (a menos que se establezca flags como está descrito abajo).

message

El mensaje recibido será almacenado en message, a menos que hubiera errores al recibir dicho mensaje.

unserialize

Si está establecido a true, el mensaje es tratado como si fuera serializado usando el mismo mecanismo que el del módulo de sesión. El mensaje será deserializado y después devuelto al script. Esto permite recibir de forma sencilla matrices y objetos complejos desde otros scripts de PHP, o si se está usando el serializador WDDX, desde cualquier fuente compatible con WDDX.

Si unserialize es false, el mensaje será devuelto como cadena segura a nivel binario.

flags

El parámetro opcional flags permite pasar banderas a la llamada a bajo nivel de msgrcv. Por defecto es 0, pero se puede especificar uno o más de los siguientes valores (añadiéndolos o usando OR).

Flag values for msg_receive
MSG_IPC_NOWAIT | Si no hay mensajes del tipo deseado dado por desiredmsgtype, devuelve inmediatamente y no espera. La función fallará y devolverá un valor de tipo integer correspondiente a MSG_ENOMSG.
MSG_EXCEPT | Usar esta bandera en combinación con un desiredmsgtype mayor que 0 causará que la función reciba el primer mensaje que no sea igual a desiredmsgtype.
MSG_NOERROR | Si el mensaje es mayor que maxsize, establecer esta bandera truncará el mensaje a maxsize y no enviará un error.

errorcode

Si la función falla, el parámetro opcional errorcode será establecido al valor de la variable errno del sistema.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Si se finalizó con éxito, la estructura de datos de la cola de mensajes se actualiza como sigue: msg_lrpid se establece al ID del proceso de llamada, msg_qnum se disminuye en 1 y msg_rtime se establece al momento actual.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_send() - Eviar un mensaje a una cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes
  • msg_set_queue() - Establecer información en la estructura de datos de la cola de mensajes


Destruir una cola de mensajes

  • « msg_receive
  • msg_send »
  • PHP Manual
  • Funciones de Semáforo
  • Destruir una cola de mensajes

msg_remove_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_remove_queue — Destruir una cola de mensajes

Descripción

msg_remove_queue ( resource $queue ) : bool

msg_remove_queue() destruye la cola de mensajes especificada por queue. Sólo use esta función cuando todos los procesos hayan terminado de trabajar con la cola de mensajes y necesite liberar los recursos del sistema ocupados por ella.

Parámetros

queue

Gestor de recurso de la cola de mensajes

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • msg_get_queue() - Crear o adjuntar a una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes
  • msg_set_queue() - Establecer información en la estructura de datos de la cola de mensajes


Eviar un mensaje a una cola de mensajes

  • « msg_remove_queue
  • msg_set_queue »
  • PHP Manual
  • Funciones de Semáforo
  • Eviar un mensaje a una cola de mensajes

msg_send

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_send — Eviar un mensaje a una cola de mensajes

Descripción

msg_send ( resource $queue , int $msgtype , mixed $message , bool $serialize = true , bool $blocking = true , int &$errorcode = ? ) : bool

msg_send() envía un message del tipo msgtype (DEBE ser mayor que 0) a la cola de mensajes especificada por queue.

Parámetros

queue

msgtype

message

serialize

El parámetro opcional serialize controla el modo de enviar el mensaje dado por message. serialize es por defecto true lo que significa que message es serializado usando el mismo mecanismo que el módulo de sesión antes de ser enviado a la cola. Esto permite matrices y objetos complejos para ser enviados a otros scripts de PHP, o si se está usando el serializador WDDX, para cualquier cliente compatible con WDDX.

blocking

Si el mensaje es demasiado largo para caber en la cola el script esperará hasta que otro proceso lea los mensajes de la cola y libere sufieciente espacio para el mensaje que se va a enviar. Esto se llama bloqueo; se puede prevenir el bloqueo estableciendo el parámetro blocking a false, en cuyo caso msg_send() devolverá inmediatamente false si el mensaje es demasiado grande para la cola, y establecerá el parámetro opcional errorcode a MSG_EAGAIN, indicando que se debería intentar enviar el mensaje de nuevo un poco más tarde.

errorcode

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Al finalizar con éxito, la estructura de datos de la cola de mensajes se actualiza como sigue: msg_lspid se establece al ID del proceso de llamada, msg_qnum se incrementa en 1 y msg_stime se establece al momento actual.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes
  • msg_set_queue() - Establecer información en la estructura de datos de la cola de mensajes


Establecer información en la estructura de datos de la cola de mensajes

  • « msg_send
  • msg_stat_queue »
  • PHP Manual
  • Funciones de Semáforo
  • Establecer información en la estructura de datos de la cola de mensajes

msg_set_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_set_queue — Establecer información en la estructura de datos de la cola de mensajes

Descripción

msg_set_queue ( resource $queue , array $data ) : bool

msg_set_queue() permite que se cambien los valores de los campos msg_perm.uid, msg_perm.gid, msg_perm.mode y msg_qbytes fields de la estructura de datos de la cola de mensajes subyacente.

Cambiar la estructura de datos requerirá que PHP sea ejecutado mediante el mismo usuario que creó la cola, los propietarios de la cola (como está determinado por los campos msg_perm.xxx existentes), o sea ejecutado con privilegios root. Se requieren los privilegios root para aumentar los valores de msg_qbytes por encima del límite definido por el sistema.

Parámetros

queue

Gestor de recurso de cola de mensajes

data

Se especifican los valores que se requieren estableciendo el valor de las claves que se neceditan en la matriz data.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_stat_queue() - Devuelve información desde la estructura de datos de la cola de mensajes
  • msg_get_queue() - Crear o adjuntar a una cola de mensajes


Devuelve información desde la estructura de datos de la cola de mensajes

  • « msg_set_queue
  • sem_acquire »
  • PHP Manual
  • Funciones de Semáforo
  • Devuelve información desde la estructura de datos de la cola de mensajes

msg_stat_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_stat_queue — Devuelve información desde la estructura de datos de la cola de mensajes

Descripción

msg_stat_queue ( resource $queue ) : array

msg_stat_queue() devuelve los metadatos de la cola de mensajes para la cola de mensajes especificada por el parámetro queue. Esto es útil para, por ejemplo, determinar qué proceso envía el mensaje que fue recibido.

Parámetros

queue

Gestor de recurso de la cola de mensajes

Valores devueltos

El valor devuelto es una matriz cuyas claves y valores tienen el siguiente significado:

Estructura de la matriz para msg_stat_queue
msg_perm.uid | El uid del propietario de la cola.
msg_perm.gid | El gid del propietario de la cola.
msg_perm.mode | El modo de acceso a archivo de la cola.
msg_stime | El momento en que se envió el último mensaje a la cola.
msg_rtime | El momento en que se recibió el último mensaje desde la cola.
msg_ctime | El momento en que la cola cambió por última vez.
msg_qnum | El número de mensajes en espera para ser leídos desde la cola.
msg_qbytes | El número máximo de bytes permitidos en una cola de mensajes. En Linux, este valor puede ser leído y modificado mediante /proc/sys/kernel/msgmnb.
msg_lspid | El pid del proceso que envió el último mensaje a la cola.
msg_lrpid | El pid del proceso que recibió el último mensaje desde la cola.

Ver también

  • msg_remove_queue() - Destruir una cola de mensajes
  • msg_receive() - Recibir un mensaje de la cola de mensajes
  • msg_get_queue() - Crear o adjuntar a una cola de mensajes
  • msg_set_queue() - Establecer información en la estructura de datos de la cola de mensajes


Adquirir un semáforo

  • « msg_stat_queue
  • sem_get »
  • PHP Manual
  • Funciones de Semáforo
  • Adquirir un semáforo

sem_acquire

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_acquire — Adquirir un semáforo

Descripción

sem_acquire ( resource $sem_identifier , bool $nowait = false ) : bool

sem_acquire() por defecto queda en espera (si es necesario) hasta que el semáforo pueda ser adquirido. Un proceso que intente adquirir un semáforo que ya ha sido adquirido quedará en espera para siempre si al adquirir el semáforo causa que su número máximo de semáforo sea excedido.

Después de procesar una petición, cualquier semáforo adquirido por el proceso pero no liberado explícitamente será liberado automáticamente y se generará un mensaje de tipo warning.

Parámetros

sem_identifier

sem_identifier es un recurso de semáforo obtenido desde sem_get().

nowait

Especifica si el proceso no debería esperar a que el semáforo sea adquirido. Si se establece a true, la llamada devolverá false inmediatamente si un semáforo no se puede adquirir de inmediato.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.6.1 | Se añadió el parámetro $nowait.

Ver también

  • sem_get() - Obtener el id de un semáforo
  • sem_release() - Liberar un semáforo


Obtener el id de un semáforo

  • « sem_acquire
  • sem_release »
  • PHP Manual
  • Funciones de Semáforo
  • Obtener el id de un semáforo

sem_get

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_get — Obtener el id de un semáforo

Descripción

sem_get ( int $key , int $max_acquire = 1 , int $perm = 0666 , int $auto_release = 1 ) : resource

sem_get() devuelve un id que se puede usar para acceder al semáforo de System V con la clave dada por key.

Una segunda llamada a sem_get() para la misma clave devolverá un identificador de semáforo diferente, pero ambos identificadores accederán al mismo semáforo subyacente.

Parámetros

key

max_acquire

El número de procesos que puede adquirir el semáforo simultáneamente está establecido por max_acquire.

perm

Los permisos del semáforo. En realidad este valor se establece sólo si el proceso que lo encuentra es el único proceso actualmente adjunto al semáforo.

auto_release

Especifica si el semáforo debería ser liberado automáticamente al cierre de la petición.

Valores devueltos

Devuelve un identificador de semáforo positivo en caso de éxito, o false en caso de error.

Notas

Advertencia

Al usar sem_get() para acceder a un semáforo creado fuera de PHP, se ha de observar que el semáforo debe haber sido creado como un conjunto de 3 semáforos (por ejemplo, especificando 3 en el parámetro nsems, al llamar a la función semget() de C), de lo contrario, PHP no podrá acceder al semáforo.

Ver también

  • sem_acquire() - Adquirir un semáforo
  • sem_release() - Liberar un semáforo
  • ftok() - Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V


Liberar un semáforo

  • « sem_get
  • sem_remove »
  • PHP Manual
  • Funciones de Semáforo
  • Liberar un semáforo

sem_release

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_release — Liberar un semáforo

Descripción

sem_release ( resource $sem_identifier ) : bool

sem_release() libera el semáforo si actualmente está adquirido por el proceso llamador, de otro modo se generará una advertencia.

Después de liberar el semáforo se puede llamar a sem_acquire() para readquirirlo.

Parámetros

sem_identifier

Un gestor de recurso de semáforo devuelto por sem_get().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • sem_get() - Obtener el id de un semáforo
  • sem_acquire() - Adquirir un semáforo


Eliminar un semáforo

  • « sem_release
  • shm_attach »
  • PHP Manual
  • Funciones de Semáforo
  • Eliminar un semáforo

sem_remove

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

sem_remove — Eliminar un semáforo

Descripción

sem_remove ( resource $sem_identifier ) : bool

sem_remove() elimina el semáforo dado.

Después de eliminar el semáforo, éste ya no está accesible.

Parámetros

sem_identifier

Un identificador de recurso de semáforo devuelto por sem_get().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • sem_get() - Obtener el id de un semáforo
  • sem_release() - Liberar un semáforo
  • sem_acquire() - Adquirir un semáforo


Crea o abre un segmento de memoria compartida

  • « sem_remove
  • shm_detach »
  • PHP Manual
  • Funciones de Semáforo
  • Crea o abre un segmento de memoria compartida

shm_attach

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_attach — Crea o abre un segmento de memoria compartida

Descripción

shm_attach ( int $key , int $memsize = ? , int $perm = 0666 ) : resource

shm_attach() devuelve un id que se puede usar para acceder a la memoria compartida de System V con la clave dada por key, la primera llamada crea el segmento de memoria compartida con memsize y los permisos opcionales a nivel de bits perm.

Una segunda llamada a shm_attach() para la misma clave dada por key devolverá un identificador de memoria diferente, pero ambos identificadores acceden a la misma memoria compartida subyacente. memsize y perm serán ignorados.

Parámetros

key

Un ID numérico de segmento de memoria compartida

memsize

El tamaño de la memoria. Si no se proporciona, por defecto es el valor de sysvshm.init_mem del php.ini, de otro modo es 10000 bytes.

perm

Los bits de permiso opcionales. Por defecto es 0666.

Valores devueltos

Devuelve un identificador de segmento de memoria compartida.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora devuelve un recurso en vez de un integer.

Notas

Nota:

Esta función solía devolver un valor integer antes de PHP 5.3.0. Para obtener el mismo valor de un modo portable, el valor devuelto puede ser convertido a un integer:

<?php
// Crear un fichero temporal y devolver su ruta
$tmp = tempnam('/tmp', 'PHP');

// Obtener la clave de token del fichero
$key = ftok($tmp, 'a');

// Adjuntar el recurso SHM, observe la conversión después
$id = shm_attach($key);

if ($id === false) {
    die('No se pudo crear el segmento de memoria compartida');
}

// Convertir a integer, ya que antes de PHP 5.3.0 se devuelve
// el id del recurso, el cual puede ser expuesto cuando se convierte un recurso
// en un integer
$id = (integer) $id;
?>

Ver también

  • shm_detach() - Desconectarse del segmento de memoria compartida
  • ftok() - Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V


Desconectarse del segmento de memoria compartida

  • « shm_attach
  • shm_get_var »
  • PHP Manual
  • Funciones de Semáforo
  • Desconectarse del segmento de memoria compartida

shm_detach

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_detach — Desconectarse del segmento de memoria compartida

Descripción

shm_detach ( resource $shm_identifier ) : bool

shm_detach() desconecta de la memoria compartida dada por el parámetro shm_identifier creado por shm_attach(). Recuerde que la memoria compartida aún existe en el sistema Unix y que la información todavía está presente.

Parámetros

shm_identifier

Un gestor de recurso de memoria compartida devuelto por shm_attach()

Valores devueltos

shm_detach() siempre devuelve true.

Ver también

  • shm_attach() - Crea o abre un segmento de memoria compartida
  • shm_remove() - Elimina la memoria compartida de sistemas Unix
  • shm_remove_var() - Eliminar una variable de la memoria compartida


Devuelve una variable desde la memoria compartida

  • « shm_detach
  • shm_has_var »
  • PHP Manual
  • Funciones de Semáforo
  • Devuelve una variable desde la memoria compartida

shm_get_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_get_var — Devuelve una variable desde la memoria compartida

Descripción

shm_get_var ( resource $shm_identifier , int $variable_key ) : mixed

shm_get_var() devuelve la variable con la clave dada por variable_key, del segmento de memoria compartida dado. La variable todavía está presente en la memoria compartida.

Parámetros

shm_identifier

Segmento de memoria compartida, obtenido desde shm_attach().

variable_key

La clave de la variable.

Valores devueltos

Devuelve la variable con la clave dada.

Ver también

  • shm_has_var() - Verificar si existe una entrada específica
  • shm_put_var() - Inserta o actualiza una variable en la memoria compartida


Verificar si existe una entrada específica

  • « shm_get_var
  • shm_put_var »
  • PHP Manual
  • Funciones de Semáforo
  • Verificar si existe una entrada específica

shm_has_var

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

shm_has_var — Verificar si existe una entrada específica

Descripción

shm_has_var ( resource $shm_identifier , int $variable_key ) : bool

Verifica si una clave específica existe dentro de un segmento de memoria compartida.

Parámetros

shm_identifier

Segmento de memoria compartida, obtenido desde shm_attach().

variable_key

La clave de la variable.

Valores devueltos

Devuelve true si la entrada existe, si no false

Ver también

  • shm_get_var() - Devuelve una variable desde la memoria compartida
  • shm_put_var() - Inserta o actualiza una variable en la memoria compartida


Inserta o actualiza una variable en la memoria compartida

  • « shm_has_var
  • shm_remove_var »
  • PHP Manual
  • Funciones de Semáforo
  • Inserta o actualiza una variable en la memoria compartida

shm_put_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_put_var — Inserta o actualiza una variable en la memoria compartida

Descripción

shm_put_var ( resource $shm_identifier , int $variable_key , mixed $variable ) : bool

shm_put_var() inserta o actualiza variable con la clave cada por variable_key.

Se emitirán advertencias (nivel E_WARNING) si shm_identifier no es un índice de memoria compartida SysV válido o si no hay suficiente memoria compartida restante para completar la petición.

Parámetros

shm_identifier

Un gestor de recurso de memoria compartida devuelto por shm_attach()

variable_key

La clave de la variable.

variable

La variable. Todos los tipos de variables que soporta serialize() se pueden usar: generalmente esto significa todos los tipos excepto los recursos y algunos objetos internos que no pueden ser serialzados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • shm_get_var() - Devuelve una variable desde la memoria compartida
  • shm_has_var() - Verificar si existe una entrada específica


Eliminar una variable de la memoria compartida

  • « shm_put_var
  • shm_remove »
  • PHP Manual
  • Funciones de Semáforo
  • Eliminar una variable de la memoria compartida

shm_remove_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_remove_var — Eliminar una variable de la memoria compartida

Descripción

shm_remove_var ( resource $shm_identifier , int $variable_key ) : bool

Elimina una variable con la clave dada por variable_key y libera la memoria ocupada.

Parámetros

shm_identifier

El identificador de memoria compartida devuelto por shm_attach()

variable_key

La clave de la variable.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • shm_remove() - Elimina la memoria compartida de sistemas Unix


Elimina la memoria compartida de sistemas Unix

  • « shm_remove_var
  • Memoria compartida »
  • PHP Manual
  • Funciones de Semáforo
  • Elimina la memoria compartida de sistemas Unix

shm_remove

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_remove — Elimina la memoria compartida de sistemas Unix

Descripción

shm_remove ( resource $shm_identifier ) : bool

shm_remove() elimina el identificador de memoria compartida shm_identifier. Toda la información será destruida.

Parámetros

shm_identifier

El identificador de memoria compartida devuelto por shm_attach()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • shm_remove_var() - Eliminar una variable de la memoria compartida


Memoria compartida

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones de memoria compartida
    • shmop_close — Cerrar un segmento de memoria compartida
    • shmop_delete — Borrar segmento de memoria compartida
    • shmop_open — Crea o abre un segmento de memoria compartida
    • shmop_read — Leer datos desde un segmento de memoria compartida
    • shmop_size — Obtiene el tamaño de un segmento de memoria compartida
    • shmop_write — Escribir datos en un segmento de memoria compartida


Introducción

Shmop es un conjunto de funciones que permiten a PHP leer, escribir, crear y borrar de forma sencilla segmentos de memoria compartida de tipo UNIX.


  • « Requerimientos
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

Para utilizar shmop tendrá que compilar PHP con el parámetro --enable-shmop en su línea de configuración.


Tipos de recursos

A partir de PHP 7.0.0 esta extensión define el tipo de recurso shmop que es un manejador para un bloque de memoria compartida.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Memoria compartida
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • Memoria compartida
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo #1 Resumen de las operaciones con Memoria Compartida

<?php

// Crear un segmento de memoria compartida de 100 bytes con un identificador igual a 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if (!$shm_id) {
    echo "Couldn't create shared memory segment\n";
}

// Obtener tamaño del segmento de memoria compartida
$shm_size = shmop_size($shm_id);
echo "SHM Block Size: " . $shm_size . " has been created.\n";

// Escribir una cadena de prueba en la memoria compartida
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if ($shm_bytes_written != strlen("my shared memory block")) {
    echo "Couldn't write the entire length of data\n";
}

// Ahora vamos a leer la cadena de texto
$my_string = shmop_read($shm_id, 0, $shm_size);
if (!$my_string) {
    echo "Couldn't read from shared memory block\n";
}
echo "The data inside shared memory was: " . $my_string . "\n";

//Ahora vamos a eliminar y cerrar el segmento de memoria compartida
if (!shmop_delete($shm_id)) {
    echo "Couldn't mark shared memory block for deletion.";
}
shmop_close($shm_id);

?>


Funciones de memoria compartida

Tabla de contenidos

  • shmop_close — Cerrar un segmento de memoria compartida
  • shmop_delete — Borrar segmento de memoria compartida
  • shmop_open — Crea o abre un segmento de memoria compartida
  • shmop_read — Leer datos desde un segmento de memoria compartida
  • shmop_size — Obtiene el tamaño de un segmento de memoria compartida
  • shmop_write — Escribir datos en un segmento de memoria compartida


Cerrar un segmento de memoria compartida

  • « Funciones de memoria compartida
  • shmop_delete »
  • PHP Manual
  • Funciones de memoria compartida
  • Cerrar un segmento de memoria compartida

shmop_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_close — Cerrar un segmento de memoria compartida

Descripción

shmop_close ( resource $shmid ) : void

shmop_close() se utiliza para cerrar un segmento de memoria compartida.

Parámetros

shmid

El recurso del segmento de memoria compartida creado por shmop_open()

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo de shmid ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Cerrando segmento de memoria compartida

<?php
shmop_close($shm_id);
?>

Este ejemplo cierra un segmento de memoria compartida identificado por $shm_id.

Ver también

  • shmop_open() - Crea o abre un segmento de memoria compartida


Borrar segmento de memoria compartida

  • « shmop_close
  • shmop_open »
  • PHP Manual
  • Funciones de memoria compartida
  • Borrar segmento de memoria compartida

shmop_delete

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_delete — Borrar segmento de memoria compartida

Descripción

shmop_delete ( resource $shmid ) : bool

shmop_delete() es utilizado para borrar un segmento de memoria compartida.

Parámetros

shmid

El recurso de memoria compartida creado por shmop_open()

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo de shmid ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Borrando segmento de memoria compartida

<?php
shmop_delete($shm_id);
?>

Este ejemplo borra un segmento de memoria compartida identificado por $shm_id.


Crea o abre un segmento de memoria compartida

  • « shmop_delete
  • shmop_read »
  • PHP Manual
  • Funciones de memoria compartida
  • Crea o abre un segmento de memoria compartida

shmop_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_open — Crea o abre un segmento de memoria compartida

Descripción

shmop_open ( int $key , string $flags , int $mode , int $size ) : resource

shmop_open() puede crear o abrir un segmento de memoria compartida.

Parámetros

key

Identificador que el sistema utilizará para ese segmento de memoria compartida. Puede ser indicado tanto en formato decimal como hexadecimal.

flags

Los indicadores que puede usar son:

  • "a" para acceder (establece SHM_RDONLY para shmat) utilice este indicador cuando necesite abrir un segmento de memoria compartida de sólo lectura
  • "c" para crear (establece IPC_CREATE) utilice este indicador cuando necesite crear un nuevo segmento de memoria compartida o para intentar abrir en modo de lectura y escritura un segmento que ya existe
  • "w" para acceder en modo de lectura y escritura utilice este indicador cuando necesite leer un segmento de memoria compartida y además poder escribir en él, se trata de la opción más habitual en la mayoría de los casos.
  • "n" crea un nuevo segmento de memoria compartida (establece IPC_CREATE|IPC_EXCL) utilice este indicador cuando necesite crear un nuevo segmento de memoria compartida, pero si existe otro segmento de memoria compartida con la misma clave, fallará. Esta opción es útil para propósitos de seguridad que evitan por ejemplo los exploit conocidos como "condiciones de carrera" (en inglés "race conditions").

mode

Permisos que se van a asignar al segmento de memoria compartida, estos son similares a los que se asignan a los archivos. Los permisos deben pasarse en formato octal, como por ejemplo 0644

size

El tamaño en bytes del segmento de memoria compartida que quiere crear

Nota:

Nota: El tercer y cuarto parámetro deberán ser igual a 0 (cero) si está abriendo un segmento de memoria compartida existente.

Valores devueltos

En caso de éxito shmop_open() devolverá un recurso que puede utilizar para acceder al segmento de memoria compartida que ha creado. false es devuelto en caso de fallo.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo devuelto de shmop_open() ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Crear un nuevo segmento de memoria compartida

<?php
$shm_key = ftok(__FILE__, 't');
$shm_id = shmop_open($shm_key, "c", 0644, 100);
?>

En este ejemplo se abre un segmento de memoria compartida con un identificador de sistema devuelto por ftok().

Ver también

  • shmop_close() - Cerrar un segmento de memoria compartida
  • shmop_delete() - Borrar segmento de memoria compartida


Leer datos desde un segmento de memoria compartida

  • « shmop_open
  • shmop_size »
  • PHP Manual
  • Funciones de memoria compartida
  • Leer datos desde un segmento de memoria compartida

shmop_read

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_read — Leer datos desde un segmento de memoria compartida

Descripción

shmop_read ( resource $shmid , int $start , int $count ) : string

shmop_read() leerá una cadena desde un segmento de memoria compartida.

Parámetros

shmid

El identificador del segmento de memoria compartida creado por shmop_open()

start

Offset desde el que comenzar a leer

count

El número de bytes a leer. 0 lee shmop_size($shmid) - $start bytes.

Valores devueltos

Devuelve los datos o false en caso de error.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo de shmid ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Lectura de un segmento de memoria compartida

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

Este ejemplo, leerá los 50 primeros bytes del segmento de memoria compartida y almacenará los datos en la variable $shm_data.

Ver también

  • shmop_write() - Escribir datos en un segmento de memoria compartida


Obtiene el tamaño de un segmento de memoria compartida

  • « shmop_read
  • shmop_write »
  • PHP Manual
  • Funciones de memoria compartida
  • Obtiene el tamaño de un segmento de memoria compartida

shmop_size

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_size — Obtiene el tamaño de un segmento de memoria compartida

Descripción

shmop_size ( resource $shmid ) : int

shmop_size() es utilizado ara obtener el tamaño en bytes, de un segmento de memoria compartida.

Parámetros

shmid

El identificador del segmento de memoria compartida creado por shmop_open()

Valores devueltos

Devuelve un entero, el cual representa el número de bytes que ocupa el segmento de memoria compartida.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo de shmid ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Obtención del tamaño de un segmento de memoria compartida

<?php
$shm_size = shmop_size($shm_id);
?>

Este ejemplo, almacenará el tamaño del segmento de memoria compartida identificado por $shm_id en $shm_size.


Escribir datos en un segmento de memoria compartida

  • « shmop_size
  • Sync »
  • PHP Manual
  • Funciones de memoria compartida
  • Escribir datos en un segmento de memoria compartida

shmop_write

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_write — Escribir datos en un segmento de memoria compartida

Descripción

shmop_write ( resource $shmid , string $data , int $offset ) : int

shmop_write() escribirá una cadena en un segmento de memoria compartida.

Parámetros

shmid

El identificador del segmento de la memoria compartida creado por shmop_open()

data

Una cadena a escribir en el segmento de la memoria compartida

offset

Especifica dónde empezará a escribir los datos en el interior del segmento de la memoria compartida.

Valores devueltos

El tamaño de la data escrita, o false en caso de fallo.

Historial de cambios

Versión | Descripción
7.0.0 | El tipo de shmid ha sido cambiado de int a resource.

Ejemplos

Ejemplo #1 Escribiendo en un segmento de memoria compartida

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

Este ejemplo escribirá los datos contenidos en $my_string en el segmento de memoria compartida, $shm_bytes_written contendrá el número de bytes escritos.

Ver también

  • shmop_read() - Leer datos desde un segmento de memoria compartida


Sync

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • SyncMutex — The SyncMutex class
    • SyncMutex::__construct — Constructs a new SyncMutex object
    • SyncMutex::lock — Waits for an exclusive lock
    • SyncMutex::unlock — Unlocks the mutex
  • SyncSemaphore — The SyncSemaphore class
    • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
    • SyncSemaphore::lock — Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock — Increases the count of the semaphore
  • SyncEvent — The SyncEvent class
    • SyncEvent::__construct — Constructs a new SyncEvent object
    • SyncEvent::fire — Fires/sets the event
    • SyncEvent::reset — Resets a manual event
    • SyncEvent::wait — Waits for the event to be fired/set
  • SyncReaderWriter — The SyncReaderWriter class
    • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
    • SyncReaderWriter::readlock — Waits for a read lock
    • SyncReaderWriter::readunlock — Releases a read lock
    • SyncReaderWriter::writelock — Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock — Releases a write lock
  • SyncSharedMemory — The SyncSharedMemory class
    • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
    • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read — Copy data from named shared memory
    • SyncSharedMemory::size — Returns the size of the named shared memory
    • SyncSharedMemory::write — Copy data to named shared memory


Introducción

The 'sync' extension introduces cross-platform synchonization objects into PHP. Named and unnamed Mutex, Semaphore, Event, Reader-Writer, and named Shared Memory objects provide OS-level synchronization on both POSIX (e.g. Linux) and Windows platforms.

Automatic cleanup of acquired synchronization objects takes place during extension teardown. This means that if PHP prematurely terminates a script (e.g. script execution time is exceeded), objects will not be left in an unknown state. The only exception to this is if PHP itself crashes (e.g. an internal buffer overflow).

Unnamed synchronization objects don't have a lot of use outside of a multithreaded scenario. Unnamed objects are more useful in conjunction with the pthreads PECL extension.

Nota:

Named objects require additional care to be used on all systems. If an object is instantiated with a specific set of parameters, it must always be instantiated with those parameters or the object will probably end up in an inconsistent state until the next reboot or a system administrator cleans up the mess.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

A system with support for POSIX shared memory (shm_open()) or running Windows.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/sync.


  • « Tipos de recursos
  • SyncMutex »
  • PHP Manual
  • Sync
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


The SyncMutex class

(PECL sync >= 1.0.0)

Introducción

A cross-platform, native implementation of named and unnamed countable mutex objects.

A mutex is a mutual exclusion object that restricts access to a shared resource (e.g. a file) to a single instance. Countable mutexes acquire the mutex a single time and internally track the number of times the mutex is locked. The mutex is unlocked as soon as it goes out of scope or is unlocked the same number of times that it was locked.

Sinopsis de la Clase

SyncMutex {
/* Métodos */
public __construct ( string $name = ? )
public lock ( int $wait = -1 ) : bool
public unlock ( bool $all = false ) : bool
}

Tabla de contenidos

  • SyncMutex::__construct — Constructs a new SyncMutex object
  • SyncMutex::lock — Waits for an exclusive lock
  • SyncMutex::unlock — Unlocks the mutex


Constructs a new SyncMutex object

  • « SyncMutex
  • SyncMutex::lock »
  • PHP Manual
  • SyncMutex
  • Constructs a new SyncMutex object

SyncMutex::__construct

(PECL sync >= 1.0.0)

SyncMutex::__construct — Constructs a new SyncMutex object

Descripción

public SyncMutex::__construct ( string $name = ? )

Constructs a named or unnamed countable mutex.

Parámetros

name

The name of the mutex if this is a named mutex object.

Nota:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

Valores devueltos

The new SyncMutex object. An exception is thrown if the mutex cannot be created or opened.

Ejemplos

Ejemplo #1 SyncMutex::__construct() named mutex with lock timeout example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

Ejemplo #2 SyncMutex::__construct() unnamed mutex example

<?php
$mutex = new SyncMutex();

$mutex->lock();

/* ... */

$mutex->unlock();
?>

Ver también

  • SyncMutex::lock() - Waits for an exclusive lock
  • SyncMutex::unlock() - Unlocks the mutex


Waits for an exclusive lock

  • « SyncMutex::__construct
  • SyncMutex::unlock »
  • PHP Manual
  • SyncMutex
  • Waits for an exclusive lock

SyncMutex::lock

(PECL sync >= 1.0.0)

SyncMutex::lock — Waits for an exclusive lock

Descripción

public SyncMutex::lock ( int $wait = -1 ) : bool

Obtains an exclusive lock on a SyncMutex object. If the lock is already acquired, then this increments an internal counter.

Parámetros

wait

The number of milliseconds to wait for the exclusive lock. A value of -1 is infinite.

Valores devueltos

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncMutex::lock() example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

Ver también

  • SyncMutex::unlock() - Unlocks the mutex


Unlocks the mutex

  • « SyncMutex::lock
  • SyncSemaphore »
  • PHP Manual
  • SyncMutex
  • Unlocks the mutex

SyncMutex::unlock

(PECL sync >= 1.0.0)

SyncMutex::unlock — Unlocks the mutex

Descripción

public SyncMutex::unlock ( bool $all = false ) : bool

Decreases the internal counter of a SyncMutex object. When the internal counter reaches zero, the actual lock on the object is released.

Parámetros

all

Specifies whether or not to set the internal counter to zero and therefore release the lock.

Valores devueltos

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncMutex::unlock() example

<?php
$mutex = new SyncMutex("UniqueName");

$mutex->lock();

/* ... */

$mutex->unlock();
?>

Ver también

  • SyncMutex::lock() - Waits for an exclusive lock


The SyncSemaphore class

(PECL sync >= 1.0.0)

Introducción

A cross-platform, native implementation of named and unnamed semaphore objects.

A semaphore restricts access to a limited resource to a limited number of instances. Semaphores differ from mutexes in that they can allow more than one instance to access a resource at one time while a mutex only allows one instance at a time.

Sinopsis de la Clase

SyncSemaphore {
/* Métodos */
public __construct ( string $name = ? , int $initialval = 1 , bool $autounlock = true )
public lock ( int $wait = -1 ) : bool
public unlock ( int &$prevcount = ? ) : bool
}

Tabla de contenidos

  • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
  • SyncSemaphore::lock — Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock — Increases the count of the semaphore


Constructs a new SyncSemaphore object

  • « SyncSemaphore
  • SyncSemaphore::lock »
  • PHP Manual
  • SyncSemaphore
  • Constructs a new SyncSemaphore object

SyncSemaphore::__construct

(PECL sync >= 1.0.0)

SyncSemaphore::__construct — Constructs a new SyncSemaphore object

Descripción

public SyncSemaphore::__construct ( string $name = ? , int $initialval = 1 , bool $autounlock = true )

Constructs a named or unnamed semaphore.

Parámetros

name

The name of the semaphore if this is a named semaphore object.

Nota:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

initialval

The initial value of the semaphore. This is the number of locks that may be obtained.

autounlock

Specifies whether or not to automatically unlock the semaphore at the conclusion of the PHP script.

Advertencia

If an object is: A named semaphore with an autounlock of FALSE, the object is locked, and the PHP script concludes before the object is unlocked, then the underlying semaphore will end up in an inconsistent state.

Valores devueltos

The new SyncSemaphore object. An exception is thrown if the semaphore cannot be created or opened.

Ejemplos

Ejemplo #1 SyncSemaphore::__construct() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ver también

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock() - Increases the count of the semaphore


Decreases the count of the semaphore or waits

  • « SyncSemaphore::__construct
  • SyncSemaphore::unlock »
  • PHP Manual
  • SyncSemaphore
  • Decreases the count of the semaphore or waits

SyncSemaphore::lock

(PECL sync >= 1.0.0)

SyncSemaphore::lock — Decreases the count of the semaphore or waits

Descripción

public SyncSemaphore::lock ( int $wait = -1 ) : bool

Decreases the count of a SyncSemaphore object or waits until the semaphore becomes non-zero.

Parámetros

wait

The number of milliseconds to wait for the semaphore. A value of -1 is infinite.

Valores devueltos

A boolean of TRUE if the lock operation was successful, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncSemaphore::lock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ver también

  • SyncSemaphore::unlock() - Increases the count of the semaphore


Increases the count of the semaphore

  • « SyncSemaphore::lock
  • SyncEvent »
  • PHP Manual
  • SyncSemaphore
  • Increases the count of the semaphore

SyncSemaphore::unlock

(PECL sync >= 1.0.0)

SyncSemaphore::unlock — Increases the count of the semaphore

Descripción

public SyncSemaphore::unlock ( int &$prevcount = ? ) : bool

Increases the count of a SyncSemaphore object.

Parámetros

prevcount

Returns the previous count of the semaphore.

Valores devueltos

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncSemaphore::unlock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ver también

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits


The SyncEvent class

(PECL sync >= 1.0.0)

Introducción

A cross-platform, native implementation of named and unnamed event objects. Both automatic and manual event objects are supported.

An event object waits, without polling, for the object to be fired/set. One instance waits on the event object while another instance fires/sets the event. Event objects are useful wherever a long-running process would otherwise poll a resource (e.g. checking to see if uploaded data needs to be processed).

Sinopsis de la Clase

SyncEvent {
/* Métodos */
public __construct ( string $name = ? , bool $manual = false , bool $prefire = false )
public fire ( ) : bool
public reset ( ) : bool
public wait ( int $wait = -1 ) : bool
}

Tabla de contenidos

  • SyncEvent::__construct — Constructs a new SyncEvent object
  • SyncEvent::fire — Fires/sets the event
  • SyncEvent::reset — Resets a manual event
  • SyncEvent::wait — Waits for the event to be fired/set


Constructs a new SyncEvent object

  • « SyncEvent
  • SyncEvent::fire »
  • PHP Manual
  • SyncEvent
  • Constructs a new SyncEvent object

SyncEvent::__construct

(PECL sync >= 1.0.0)

SyncEvent::__construct — Constructs a new SyncEvent object

Descripción

public SyncEvent::__construct ( string $name = ? , bool $manual = false , bool $prefire = false )

Constructs a named or unnamed event object.

Parámetros

name

The name of the event if this is a named event object.

Nota:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

manual

Specifies whether or not the event object must be reset manually.

Nota:

Manual reset event objects allow all waiting processes through until the object is reset.

prefire

Specifies whether or not to prefire (signal) the event object.

Nota:

Only has impact if the calling process/thread is the first to create the object.

Valores devueltos

The new SyncEvent object. An exception is thrown if the event object cannot be created or opened.

Ejemplos

Ejemplo #1 SyncEvent::__construct() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Historial de cambios

Versión | Descripción
PECL sync 1.1.0 | Added prefire.

Ver también

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set


Fires/sets the event

  • « SyncEvent::__construct
  • SyncEvent::reset »
  • PHP Manual
  • SyncEvent
  • Fires/sets the event

SyncEvent::fire

(PECL sync >= 1.0.0)

SyncEvent::fire — Fires/sets the event

Descripción

public SyncEvent::fire ( ) : bool

Fires/sets a SyncEvent object. Lets multiple threads through that are waiting if the event object was created with a manual value of TRUE.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean of TRUE if the event was fired, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncEvent::fire() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Ver también

  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set


Resets a manual event

  • « SyncEvent::fire
  • SyncEvent::wait »
  • PHP Manual
  • SyncEvent
  • Resets a manual event

SyncEvent::reset

(PECL sync >= 1.0.0)

SyncEvent::reset — Resets a manual event

Descripción

public SyncEvent::reset ( ) : bool

Resets a SyncEvent object that has been fired/set. Only valid for manual event objects.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean value of TRUE if the object was successfully reset, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncEvent::reset() example

<?php
// In a web application:
$event = new SyncEvent("DemoApplication", true);
$event->wait();

// In a cron job:
$event = new SyncEvent("DemoApplication", true);
$event->reset();
/* ... Do some maintenance task(s) ... */
$event->fire();
?>

Ver también

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset()
  • SyncEvent::wait() - Waits for the event to be fired/set


Waits for the event to be fired/set

  • « SyncEvent::reset
  • SyncReaderWriter »
  • PHP Manual
  • SyncEvent
  • Waits for the event to be fired/set

SyncEvent::wait

(PECL sync >= 1.0.0)

SyncEvent::wait — Waits for the event to be fired/set

Descripción

public SyncEvent::wait ( int $wait = -1 ) : bool

Waits for the SyncEvent object to be fired.

Parámetros

wait

The number of milliseconds to wait for the event to be fired. A value of -1 is infinite.

Valores devueltos

A boolean of TRUE if the event was fired, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncEvent::wait() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Ver también

  • SyncEvent::fire() - Fires/sets the event


The SyncReaderWriter class

(PECL sync >= 1.0.0)

Introducción

A cross-platform, native implementation of named and unnamed reader-writer objects.

A reader-writer object allows many readers or one writer to access a resource. This is an efficient solution for managing resources where access will primarily be read-only but exclusive write access is occasionally necessary.

Sinopsis de la Clase

SyncReaderWriter {
/* Métodos */
public __construct ( string $name = ? , bool $autounlock = true )
public readlock ( int $wait = -1 ) : bool
public readunlock ( ) : bool
public writelock ( int $wait = -1 ) : bool
public writeunlock ( ) : bool
}

Tabla de contenidos

  • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
  • SyncReaderWriter::readlock — Waits for a read lock
  • SyncReaderWriter::readunlock — Releases a read lock
  • SyncReaderWriter::writelock — Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock — Releases a write lock


Constructs a new SyncReaderWriter object

  • « SyncReaderWriter
  • SyncReaderWriter::readlock »
  • PHP Manual
  • SyncReaderWriter
  • Constructs a new SyncReaderWriter object

SyncReaderWriter::__construct

(PECL sync >= 1.0.0)

SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object

Descripción

public SyncReaderWriter::__construct ( string $name = ? , bool $autounlock = true )

Constructs a named or unnamed reader-writer object.

Parámetros

name

The name of the reader-writer if this is a named reader-writer object.

Nota:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

autounlock

Specifies whether or not to automatically unlock the reader-writer at the conclusion of the PHP script.

Advertencia

If an object is: A named reader-writer with an autounlock of FALSE, the object is locked for either reading or writing, and the PHP script concludes before the object is unlocked, then the underlying objects will end up in an inconsistent state.

Valores devueltos

The new SyncReaderWriter object. An exception is thrown if the reader-writer cannot be created or opened.

Ejemplos

Ejemplo #1 SyncReaderWriter::__construct() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();

$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ver también

  • SyncReaderWriter::readlock() - Waits for a read lock
  • SyncReaderWriter::readunlock() - Releases a read lock
  • SyncReaderWriter::writelock() - Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock() - Releases a write lock


Waits for a read lock

  • « SyncReaderWriter::__construct
  • SyncReaderWriter::readunlock »
  • PHP Manual
  • SyncReaderWriter
  • Waits for a read lock

SyncReaderWriter::readlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readlock — Waits for a read lock

Descripción

public SyncReaderWriter::readlock ( int $wait = -1 ) : bool

Obtains a read lock on a SyncReaderWriter object.

Parámetros

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

Valores devueltos

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncReaderWriter::readlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

Ver también

  • SyncReaderWriter::readunlock() - Releases a read lock


Releases a read lock

  • « SyncReaderWriter::readlock
  • SyncReaderWriter::writelock »
  • PHP Manual
  • SyncReaderWriter
  • Releases a read lock

SyncReaderWriter::readunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readunlock — Releases a read lock

Descripción

public SyncReaderWriter::readunlock ( ) : bool

Releases a read lock on a SyncReaderWriter object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncReaderWriter::readunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

Ver también

  • SyncReaderWriter::readlock() - Waits for a read lock


Waits for an exclusive write lock

  • « SyncReaderWriter::readunlock
  • SyncReaderWriter::writeunlock »
  • PHP Manual
  • SyncReaderWriter
  • Waits for an exclusive write lock

SyncReaderWriter::writelock

(PECL sync >= 1.0.0)

SyncReaderWriter::writelock — Waits for an exclusive write lock

Descripción

public SyncReaderWriter::writelock ( int $wait = -1 ) : bool

Obtains an exclusive write lock on a SyncReaderWriter object.

Parámetros

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

Valores devueltos

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncReaderWriter::writelock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ver también

  • SyncReaderWriter::writeunlock() - Releases a write lock


Releases a write lock

  • « SyncReaderWriter::writelock
  • SyncSharedMemory »
  • PHP Manual
  • SyncReaderWriter
  • Releases a write lock

SyncReaderWriter::writeunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::writeunlock — Releases a write lock

Descripción

public SyncReaderWriter::writeunlock ( ) : bool

Releases a write lock on a SyncReaderWriter object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncReaderWriter::writeunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ver también

  • SyncReaderWriter::writelock() - Waits for an exclusive write lock


The SyncSharedMemory class

(PECL sync >= 1.1.0)

Introducción

A cross-platform, native, consistent implementation of named shared memory objects.

Shared memory lets two separate processes communicate without the need for complex pipes or sockets. There are several integer-based shared memory implementations for PHP. Named shared memory is an alternative.

Synchronization objects (e.g. SyncMutex) are still required to protect most uses of shared memory.

Sinopsis de la Clase

SyncSharedMemory {
/* Métodos */
public __construct ( string $name , int $size )
public first ( ) : bool
public read ( int $start = 0 , int $length = ? )
public size ( ) : bool
public write ( string $string = ? , int $start = 0 )
}

Tabla de contenidos

  • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::read — Copy data from named shared memory
  • SyncSharedMemory::size — Returns the size of the named shared memory
  • SyncSharedMemory::write — Copy data to named shared memory


Constructs a new SyncSharedMemory object

  • « SyncSharedMemory
  • SyncSharedMemory::first »
  • PHP Manual
  • SyncSharedMemory
  • Constructs a new SyncSharedMemory object

SyncSharedMemory::__construct

(PECL sync >= 1.1.0)

SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object

Descripción

public SyncSharedMemory::__construct ( string $name , int $size )

Constructs a named shared memory object.

Parámetros

name

The name of the shared memory object.

Nota:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

size

The size, in bytes, of shared memory to reserve.

Nota:

The amount of memory cannot be resized later. Request sufficient storage up front.

Valores devueltos

The new SyncSharedMemory object. An exception is thrown if the shared memory object cannot be created or opened.

Ejemplos

Ejemplo #1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write(json_encode(array("name" => "my_report.txt")));
?>

Ver también

  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::size() - Returns the size of the named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Check to see if the object is the first instance system-wide of named shared memory

  • « SyncSharedMemory::__construct
  • SyncSharedMemory::read »
  • PHP Manual
  • SyncSharedMemory
  • Check to see if the object is the first instance system-wide of named shared memory

SyncSharedMemory::first

(PECL sync >= 1.1.0)

SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory

Descripción

public SyncSharedMemory::first ( ) : bool

Retrieves the system-wide first instance status of a SyncSharedMemory object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A boolean of TRUE if the object is the first instance system-wide, FALSE otherwise.

Ejemplos

Ejemplo #1 SyncSharedMemory::first() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

var_dump($mem->first());

$mem2 = new SyncSharedMemory("AppReportName", 1024);

var_dump($mem2->first());
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)

Ver también

  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Copy data from named shared memory

  • « SyncSharedMemory::first
  • SyncSharedMemory::size »
  • PHP Manual
  • SyncSharedMemory
  • Copy data from named shared memory

SyncSharedMemory::read

(PECL sync >= 1.1.0)

SyncSharedMemory::read — Copy data from named shared memory

Descripción

public SyncSharedMemory::read ( int $start = 0 , int $length = ? )

Copies data from named shared memory.

Parámetros

start

The start/offset, in bytes, to begin reading.

Nota:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

length

The number of bytes to read.

Nota:

If unspecified, reading will stop at the end of the shared memory segment.

If the value is negative, reading will stop the specified number of bytes from the end of the shared memory segment.

Valores devueltos

A string containing the data read from shared memory.

Ejemplos

Ejemplo #1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");

$result = $mem->read(3, -4);
var_dump($result);
?>

El resultado del ejemplo sería algo similar a:

string(3) "ort"

Ver también

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read()


Returns the size of the named shared memory

  • « SyncSharedMemory::read
  • SyncSharedMemory::write »
  • PHP Manual
  • SyncSharedMemory
  • Returns the size of the named shared memory

SyncSharedMemory::size

(PECL sync >= 1.1.0)

SyncSharedMemory::size — Returns the size of the named shared memory

Descripción

public SyncSharedMemory::size ( ) : bool

Retrieves the shared memory size of a SyncSharedMemory object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An integer containing the size of the shared memory. This will be the same size that was passed to the constructor.

Ejemplos

Ejemplo #1 SyncSharedMemory::size() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
var_dump($mem->size());
?>

El resultado del ejemplo sería algo similar a:

int(1024)

Ver también

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Copy data to named shared memory

  • « SyncSharedMemory::size
  • Otras extensiones básicas »
  • PHP Manual
  • SyncSharedMemory
  • Copy data to named shared memory

SyncSharedMemory::write

(PECL sync >= 1.1.0)

SyncSharedMemory::write — Copy data to named shared memory

Descripción

public SyncSharedMemory::write ( string $string = ? , int $start = 0 )

Copies data to named shared memory.

Parámetros

string

The data to write to shared memoy.

Nota:

If the size of the data exceeds the size of the shared memory, the number of bytes written returned will be less than the length of the input.

start

The start/offset, in bytes, to begin writing.

Nota:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

Valores devueltos

An integer containing the number of bytes written to shared memory.

Ejemplos

Ejemplo #1 SyncSharedMemory::write() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");
var_dump($result);

$result = $mem->write("report.txt", -3);
var_dump($result);
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(3)

Ver también

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write()
  • SyncSharedMemory::read() - Copy data from named shared memory


Otras extensiones básicas

  • GeoIP — Localización Geo IP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de GeoIP
  • FANN — FANN (Fast Artificial Neural Network - Red Neuronal Artificial Rápida)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Fann
    • FANNConnection — La clase FANNConnection
  • JSON — JavaScript Object Notation
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • JsonSerializable — La interfaz JsonSerializable
    • Funciones de JSON
  • Lua
    • Introducción
    • Instalación/Configuración
    • Lua — La clase Lua
    • LuaClosure — La clase LuaClosure
  • LuaSandbox
    • Introducción
    • Instalación/Configuración
    • Differences from Standard Lua
    • Ejemplos
    • LuaSandbox — The LuaSandbox class
    • LuaSandboxFunction — The LuaSandboxFunction class
    • LuaSandboxError — The LuaSandboxError class
    • LuaSandboxErrorError — The LuaSandboxErrorError class
    • LuaSandboxFatalError — The LuaSandboxFatalError class
    • LuaSandboxMemoryError — The LuaSandboxMemoryError class
    • LuaSandboxRuntimeError — The LuaSandboxRuntimeError class
    • LuaSandboxSyntaxError — The LuaSandboxSyntaxError class
    • LuaSandboxTimeoutError — The LuaSandboxTimeoutError class
  • Misc. — Funciones varias
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones Varias
    • Registro de cambios
  • Seaslog
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Seaslog Funciones
    • SeasLog — The SeasLog class
  • SPL — SPL - Biblioteca estándar de PHP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Estructuras de datos
    • Iteradores
    • Interfaces
    • Excepciones
    • Funciones SPL
    • Manejo de ficheros
    • Misceláneos clases e interfaces
  • Flujos
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Filtros de Flujos
    • Contextos de Flujos
    • Errores de Flujos
    • Ejemplos
    • php_user_filter — La clase php_user_filter
    • streamWrapper — La clase streamWrapper
    • Funciones de Flujos
  • Swoole
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Swoole Funciones
    • Swoole\Async — The Swoole\Async class
    • Swoole\Atomic — The Swoole\Atomic class
    • Swoole\Buffer — The Swoole\Buffer class
    • Swoole\Channel — The Swoole\Channel class
    • Swoole\Client — The Swoole\Client class
    • Swoole\Connection\Iterator — The Swoole\Connection\Iterator class
    • Swoole\Coroutine — The Swoole\Coroutine class
    • Swoole\Event — The Swoole\Event class
    • Swoole\Exception — The Swoole\Exception class
    • Swoole\Http\Client — The Swoole\Http\Client class
    • Swoole\Http\Request — The Swoole\Http\Request class
    • Swoole\Http\Response — The Swoole\Http\Response class
    • Swoole\Http\Server — The Swoole\Http\Server class
    • Swoole\Lock — The Swoole\Lock class
    • Swoole\Mmap — The Swoole\Mmap class
    • Swoole\MySQL — The Swoole\MySQL class
    • Swoole\MySQL\Exception — The Swoole\MySQL\Exception class
    • Swoole\Process — The Swoole\Process class
    • Swoole\Redis\Server — The Swoole\Redis\Server class
    • Swoole\Serialize — The Swoole\Serialize class
    • Swoole\Server — The Swoole\Server class
    • Swoole\Table — The Swoole\Table class
    • Swoole\Timer — The Swoole\Timer class
    • Swoole\WebSocket\Frame — The Swoole\WebSocket\Frame class
    • Swoole\WebSocket\Server — The Swoole\WebSocket\Server class
  • Tidy
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Tidy — La clase tidy
    • tidyNode — La clase tidyNode
    • Funciones de Tidy
  • Tokenizer
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones Tokenizer
  • URLs
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de URL
  • V8js — Motor de integración V8 Javascript
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • V8Js — The V8Js class
    • V8JsException — La clase V8JsException
  • Yaml — Serialización de datos YAML
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Callbacks
    • Funciones de Yaml
  • Yaf — Yet Another Framework
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Configuración de la Aplicación
    • Yaf_Application — La clase Yaf_Application
    • Yaf_Bootstrap_Abstract — La clase Yaf_Bootstrap_Abstract
    • Yaf_Dispatcher — La clase Yaf_Dispatcher
    • Yaf_Config_Abstract — La clase Yaf_Config_Abstract
    • Yaf_Config_Ini — La clase Yaf_Config_Ini
    • Yaf_Config_Simple — LA clase Yaf_Config_Simple
    • Yaf_Controller_Abstract — La clase Yaf_Controller_Abstract
    • Yaf_Action_Abstract — La clase Yaf_Action_Abstract
    • Yaf_View_Interface — La clase Yaf_View_Interface
    • Yaf_View_Simple — La clase Yaf_View_Simple
    • Yaf_Loader — La clase Yaf_Loader
    • Yaf_Plugin_Abstract — La clase Yaf_Plugin_Abstract
    • Yaf_Registry — La clase Yaf_Registry
    • Yaf_Request_Abstract — La clase Yaf_Request_Abstract
    • Yaf_Request_Http — La clase Yaf_Request_Http
    • Yaf_Request_Simple — La clase Yaf_Request_Simple
    • Yaf_Response_Abstract — La clase Yaf_Response_Abstract
    • Yaf_Route_Interface — La clase Yaf_Route_Interface
    • Yaf_Route_Map — La clase Yaf_Route_Map
    • Yaf_Route_Regex — La clase Yaf_Route_Regex
    • Yaf_Route_Rewrite — La clase Yaf_Route_Rewrite
    • Yaf_Router — La clase Yaf_Router
    • Yaf_Route_Simple — La clase Yaf_Route_Simple
    • Yaf_Route_Static — La clase Yaf_Route_Static
    • Yaf_Route_Supervar — La clase Yaf_Route_Supervar
    • Yaf_Session — La clase Yaf_Session
    • Yaf_Exception — La clase Yaf_Exception
    • Yaf_Exception_TypeError — La clase Yaf_Exception_TypeError
    • Yaf_Exception_StartupError — La clase Yaf_Exception_StartupError
    • Yaf_Exception_DispatchFailed — La clase Yaf_Exception_DispatchFailed
    • Yaf_Exception_RouterFailed — La clase Yaf_Exception_RouterFailed
    • Yaf_Exception_LoadFailed — La clase Yaf_Exception_LoadFailed
    • Yaf_Exception_LoadFailed_Module — La clase Yaf_Exception_LoadFailed_Module
    • Yaf_Exception_LoadFailed_Controller — La clase Yaf_Exception_LoadFailed_Controller
    • Yaf_Exception_LoadFailed_Action — La clase Yaf_Exception_LoadFailed_Action
    • Yaf_Exception_LoadFailed_View — La clase Yaf_Exception_LoadFailed_View
  • Yaconf
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Yaconf — La clase Yaconf
  • Taint
    • Introducción
    • Instalación/Configuración
    • Más detalles
    • Funciones de taint
  • Data Structures
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Collection — The Collection interface
    • Hashable — La interface Hashable
    • Sequence — The Sequence interface
    • Vector — La clase Vector
    • Deque — La clase Deque
    • Map — La clase Map
    • Pair — La clase Pair
    • Set — The Set class
    • Stack — The Stack class
    • Queue — The Queue class
    • PriorityQueue — The PriorityQueue class


Localización Geo IP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de GeoIP
    • geoip_asnum_by_name — Obtiene los Números de sistemas autónomos (ASN)
    • geoip_continent_code_by_name — Obtiene la abreviación de dos letras del continente
    • geoip_country_code_by_name — Obtiene la abreviación de dos letras del país
    • geoip_country_code3_by_name — Obtiene la abreviación de tres letras del país
    • geoip_country_name_by_name — Obtiene el nombre del país completo
    • geoip_database_info — Obtener información de la base de datos GeoIP
    • geoip_db_avail — Determina si la base de datos GeoIP está disponible
    • geoip_db_filename — Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP
    • geoip_db_get_all_info — Devuelve información detallada sobre todos los tipos de bases de datos GeoIP
    • geoip_domain_by_name — Obtener el nombre de dominio de segundo nivel
    • geoip_id_by_name — Obtiene el tipo de conexión a Internet
    • geoip_isp_by_name — Obtiene el nombre del proveedor de servicios de Internet (ISP)
    • geoip_netspeedcell_by_name — Obtener la velocidad de la conexión a Internet
    • geoip_org_by_name — Consultar nombre de la organización
    • geoip_record_by_name — Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP
    • geoip_region_by_name — Consultar el código de país y de región
    • geoip_region_name_by_code — Devuelve, a partir de una combinación de código de país y de región, el nombre de región
    • geoip_setup_custom_directory — Establecer un directorio personalizado para la base de datos de GeoIP
    • geoip_time_zone_by_country_and_region — Devuelve, a partir de una combinación de país y región, la zona horaria


Introducción

La extensión GeoIP permite buscar la localización de una dirección IP. Como la ciudad, estado, país, longitud, latitud y otro tipo de información como ISP y tipo de conexión puede ser obtenida con la ayuda de GeoIP.


Requerimientos

Para instalar esta extensión es necesaria la versión 1.4.0 o superior de la biblioteca en C GeoIP. Se puede obtener la última versión en » http://www.maxmind.com/app/c para compilarla uno mismo.

Por defecto, sólo se tendrá acceso a las bases de datos Free GeoIP Country o GeoLite City . Aunque este módulo puede funcionar con otros tipos de bases de datos, se debe adquirir una licencia comercial en » Maxmind.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/geoip.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de GeoIP
Nombre | Por defecto | Cambiable | Historial de cambios
geoip.custom_directory | "" | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

geoip.custom_directory string

Vacío por defecto, pero se puede establecer para forzarlo a ser una ruta de base de datos diferente de la compilada en la biblioteca.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

GEOIP_COUNTRY_EDITION (integer)
GEOIP_REGION_EDITION_REV0 (integer)
GEOIP_CITY_EDITION_REV0 (integer)
GEOIP_ORG_EDITION (integer)
GEOIP_ISP_EDITION (integer)
GEOIP_CITY_EDITION_REV1 (integer)
GEOIP_REGION_EDITION_REV1 (integer)
GEOIP_PROXY_EDITION (integer)
GEOIP_ASNUM_EDITION (integer)
GEOIP_NETSPEED_EDITION (integer)
GEOIP_DOMAIN_EDITION (integer)

The following constants are for net speed:

GEOIP_UNKNOWN_SPEED (integer)
GEOIP_DIALUP_SPEED (integer)
GEOIP_CABLEDSL_SPEED (integer)
GEOIP_CORPORATE_SPEED (integer)


Funciones de GeoIP

Tabla de contenidos

  • geoip_asnum_by_name — Obtiene los Números de sistemas autónomos (ASN)
  • geoip_continent_code_by_name — Obtiene la abreviación de dos letras del continente
  • geoip_country_code_by_name — Obtiene la abreviación de dos letras del país
  • geoip_country_code3_by_name — Obtiene la abreviación de tres letras del país
  • geoip_country_name_by_name — Obtiene el nombre del país completo
  • geoip_database_info — Obtener información de la base de datos GeoIP
  • geoip_db_avail — Determina si la base de datos GeoIP está disponible
  • geoip_db_filename — Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP
  • geoip_db_get_all_info — Devuelve información detallada sobre todos los tipos de bases de datos GeoIP
  • geoip_domain_by_name — Obtener el nombre de dominio de segundo nivel
  • geoip_id_by_name — Obtiene el tipo de conexión a Internet
  • geoip_isp_by_name — Obtiene el nombre del proveedor de servicios de Internet (ISP)
  • geoip_netspeedcell_by_name — Obtener la velocidad de la conexión a Internet
  • geoip_org_by_name — Consultar nombre de la organización
  • geoip_record_by_name — Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP
  • geoip_region_by_name — Consultar el código de país y de región
  • geoip_region_name_by_code — Devuelve, a partir de una combinación de código de país y de región, el nombre de región
  • geoip_setup_custom_directory — Establecer un directorio personalizado para la base de datos de GeoIP
  • geoip_time_zone_by_country_and_region — Devuelve, a partir de una combinación de país y región, la zona horaria


Obtiene los Números de sistemas autónomos (ASN)

  • « Funciones de GeoIP
  • geoip_continent_code_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene los Números de sistemas autónomos (ASN)

geoip_asnum_by_name

(PECL geoip >= 1.1.0)

geoip_asnum_by_name — Obtiene los Números de sistemas autónomos (ASN)

Descripción

geoip_asnum_by_name ( string $hostname ) : string

La función geoip_asnum_by_name() retorna los Números de sistemas autónomos (ASN) asociados con una dirección IP.

Parámetros

hostname

El nombre del host o la dirección IP.

Valores devueltos

Retorna el ASN en caso de éxito, o false si la dirección no se encuentra en la base de datos.

Ejemplos

Ejemplo #1 Un ejemplo de geoip_asnum_by_name()

Este ejemplo mostrará el ASN del host www.example.com.

<?php
$asn = geoip_asnum_by_name('www.example.com');

if ($asn) {
    echo 'El ASN es: ' $asn;
}
?>

El resultado del ejemplo sería:

El ASN es: AS15133 EdgeCast Networks, Inc


Obtiene la abreviación de dos letras del continente

  • « geoip_asnum_by_name
  • geoip_country_code_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene la abreviación de dos letras del continente

geoip_continent_code_by_name

(PECL geoip >= 1.0.3)

geoip_continent_code_by_name — Obtiene la abreviación de dos letras del continente

Descripción

geoip_continent_code_by_name ( string $hostname ) : string

La función geoip_continent_code_by_name() devolverá la abreviación de dos letras del continente que corresponde al nombre de sitio web o una dirección IP.

Parámetros

hostname

El nombre del sitio web o dirección IP cuya localización quiere ser obtenida.

Valores devueltos

Devuelve una abreviación de dos letras del nombre del continente en caso de éxito, o false si la dirección no puede encontrarse en la base de datos.

Códigos de continentes
Código | Nombre del continente
AF | África
AN | Antártica
AS | Asia
EU | Europa
NA | Norte américa
OC | Oceanía
SA | Sur america

Ejemplos

Ejemplo #1 Un ejemplo de geoip_continent_code_by_name()

Mostrará donde el sitio web example.com está localizado.

<?php
$continent = geoip_continent_code_by_name('www.example.com');
if ($continent) {
    echo 'Este sitio web está localizado en: ' . $continent;
}
?>

El resultado del ejemplo sería:

 Este sitio web está localizado en: NA

Ver también

  • geoip_country_code_by_name() - Obtiene la abreviación de dos letras del país


Obtiene la abreviación de dos letras del país

  • « geoip_continent_code_by_name
  • geoip_country_code3_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene la abreviación de dos letras del país

geoip_country_code_by_name

(PECL geoip >= 0.2.0)

geoip_country_code_by_name — Obtiene la abreviación de dos letras del país

Descripción

geoip_country_code_by_name ( string $hostname ) : string

La función geoip_country_code_by_name() devolverá la abreviación de dos letras correspondientes al sitio web o a la dirección IP.

Parámetros

hostname

El sitio web o la dirección IP cuya localización quiere obtenerse.

Valores devueltos

Devuelve la abreviación de dos letras del código ISO en caso de éxito, o false si la dirección IP no puede ser encontrada en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_country_code_by_name()

Mostrará donde el sitio web está localizado.

<?php
$country = geoip_country_code_by_name('www.example.com');
if ($country) {
    echo 'Este sitio web está localizado en: ' . $country;
}
?>

El resultado del ejemplo sería:

Este sitio web está localizado en: US

Notas

Precaución

Por favor, véase » http://www.maxmind.com/en/iso3166 para una lista completa de los posibles valores devueltos, incluyendo códigos especiales.

Ver también

  • geoip_country_code3_by_name() - Obtiene la abreviación de tres letras del país
  • geoip_country_name_by_name() - Obtiene el nombre del país completo


Obtiene la abreviación de tres letras del país

  • « geoip_country_code_by_name
  • geoip_country_name_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene la abreviación de tres letras del país

geoip_country_code3_by_name

(PECL geoip >= 0.2.0)

geoip_country_code3_by_name — Obtiene la abreviación de tres letras del país

Descripción

geoip_country_code3_by_name ( string $hostname ) : string

La función geoip_country_code3_by_name() devolverá la abreviación de tres letras del país correspondientes al sitio web o dirección IP.

Parámetros

hostname

El sitio web o dirección IP cuya localización quiere comprobarse.

Valores devueltos

Devuelve la abreviación de tres letras del país en caso de éxito, o false si la dirección no puede encontrarse en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_country_code3_by_name()

Mostrará donde está localizado el sitio web example.com.

<?php
$pais = geoip_country_code3_by_name('www.example.com');
if ($country) {
    echo 'Este sitio web está localizado en: ' . $pais;
}
?>

El resultado del ejemplo sería:

Este sitio web está localizado en: USA

Ver también

  • geoip_country_code_by_name() - Obtiene la abreviación de dos letras del país
  • geoip_country_name_by_name() - Obtiene el nombre del país completo


Obtiene el nombre del país completo

  • « geoip_country_code3_by_name
  • geoip_database_info »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene el nombre del país completo

geoip_country_name_by_name

(PECL geoip >= 0.2.0)

geoip_country_name_by_name — Obtiene el nombre del país completo

Descripción

geoip_country_name_by_name ( string $hostname ) : string

La función geoip_country_name_by_name() devolverá el nombre del país correspondiente a un equipo o dirección IP.

Parámetros

hostname

El equipo o dirección IP del cual queremos obtener la ubicación, debe estar activo.

Valores devueltos

Devuelve el nombre del país, o false si la dirección no puede ser encontrada en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_country_name_by_name()

Esto mostrará la ubicación de ejemplo.com.

<?php
$country = geoip_country_name_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

El resultado del ejemplo sería:

 This host is located in: United States

Ver también

  • geoip_country_code_by_name() - Obtiene la abreviación de dos letras del país
  • geoip_country_code3_by_name() - Obtiene la abreviación de tres letras del país


Obtener información de la base de datos GeoIP

  • « geoip_country_name_by_name
  • geoip_db_avail »
  • PHP Manual
  • Funciones de GeoIP
  • Obtener información de la base de datos GeoIP

geoip_database_info

(PECL geoip >= 0.2.0)

geoip_database_info — Obtener información de la base de datos GeoIP

Descripción

geoip_database_info ( int $database = GEOIP_COUNTRY_EDITION ) : string

geoip_database_info() devuelve la versión que corresponda en la base de datos de GeoIP, tal y como se define en el fichero binario.

Si se invoca sin ningún parámetro, devuelve la versión de la edición GeoIP Free Country Edition.

Parámetros

database

Tipo de base de datos en forma de entero. Puede usar algunas constantes de las que se definen para esta extensión (de la forma GEOIP_*_EDITION).

Valores devueltos

Devuelve la versión de la base de datos que corresponda, o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de geoip_database_info()

Mostrará información sobre la base de datos.

<?php
print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

El resultado del ejemplo sería:

GEO-106FREE 20060801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved


Determina si la base de datos GeoIP está disponible

  • « geoip_database_info
  • geoip_db_filename »
  • PHP Manual
  • Funciones de GeoIP
  • Determina si la base de datos GeoIP está disponible

geoip_db_avail

(PECL geoip >= 1.0.1)

geoip_db_avail — Determina si la base de datos GeoIP está disponible

Descripción

geoip_db_avail ( int $database ) : bool

La función geoip_db_avail() devuelve si la base de datos GeoIP está disponible y puede ser abierta.

No indica si el fichero es una base de datos o no, sólo si se puede ser leída.

Parámetros

database

El tipo de base de datos como entero. Se pueden usar varias constantes definidas con esta extensión (ej: GEOIP_*_EDITION).

Valores devueltos

Devuelve true si la base de datos existe, false si no puede ser encontrada, o null en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de geoip_db_avail()

Mostrará la versión de la base de datos actual.

<?php

if (geoip_db_avail(GEOIP_COUNTRY_EDITION))
    print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

El resultado del ejemplo sería:

GEO-106FREE 20080801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved


Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP

  • « geoip_db_avail
  • geoip_db_get_all_info »
  • PHP Manual
  • Funciones de GeoIP
  • Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP

geoip_db_filename

(PECL geoip >= 1.0.1)

geoip_db_filename — Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP

Descripción

geoip_db_filename ( int $database ) : string

La función geoip_db_filename() devuelve el nombre del fichero que corresponde a la base de datos GeoIP.

No indica si el fichero existe o no en el disco, sólo en donde la librería está buscando el fichero de la base de datos.

Parámetros

database

El tipo de base de datos como entero. Se pueden usar varias constantes definidas con la extensión (ej: GEOIP_*_EDITION).

Valores devueltos

Devuelve el nombre del fichero correspondiente a la base de datos o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de geoip_db_filename()

Mostrará el nombre del fichero que corresponde a la base de datos.

<?php

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

El resultado del ejemplo sería:

/usr/share/GeoIP/GeoIP.dat


Devuelve información detallada sobre todos los tipos de bases de datos GeoIP

  • « geoip_db_filename
  • geoip_domain_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Devuelve información detallada sobre todos los tipos de bases de datos GeoIP

geoip_db_get_all_info

(PECL geoip >= 1.0.1)

geoip_db_get_all_info — Devuelve información detallada sobre todos los tipos de bases de datos GeoIP

Descripción

geoip_db_get_all_info ( ) : array

geoip_db_get_all_info() devuelve un array multi-dimensional con información detallada sobre todos los tipos de bases de datos GeoIP.

Esta función está disponible incluso aunque no haya ninguna base de datos instalada. Simplemente las marcará como no disponibles.

Esta es la lista de nombres de las claves del array asociativo:

  • "available" -- Boolean, indica si la base de datos está disponible (consulte geoip_db_avail())
  • "description" -- Descripción de la base de datos
  • "filename" -- Nombre del fichero en disco que contiene la base de datos (consulte geoip_db_filename())

Valores devueltos

Devuelve un array asociativo.

Ejemplos

Ejemplo #1 Ejemplo de geoip_db_get_all_info()

Mostrará el array que contiene la información.

<?php
$infos = geoip_db_get_all_info();
if (is_array($infos)) {
    var_dump($infos);
}
?>

El resultado del ejemplo sería:

array(11) {
  [1]=>
  array(3) {
    ["available"]=>
    bool(true)
    ["description"]=>
    string(21) "GeoIP Country Edition"
    ["filename"]=>
    string(32) "/usr/share/GeoIP/GeoIP.dat"
  }

[ ... ]

  [11]=>
  array(3) {
    ["available"]=>
    bool(false)
    ["description"]=>
    string(25) "GeoIP Domain Name Edition"
    ["filename"]=>
    string(38) "/usr/share/GeoIP/GeoIPDomain.dat"
  }
}

Ejemplo #2 Ejemplo de geoip_db_get_all_info()

Puede utilizar distintas constantes como claves para consultar sólo una determinada información.

<?php
$infos = geoip_db_get_all_info();
if ($infos[GEOIP_COUNTRY_EDITION]['available']) {
    echo $infos[GEOIP_COUNTRY_EDITION]['description'];
}
?>

El resultado del ejemplo sería:

GeoIP Country Edition


Obtener el nombre de dominio de segundo nivel

  • « geoip_db_get_all_info
  • geoip_id_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtener el nombre de dominio de segundo nivel

geoip_domain_by_name

(PECL geoip >= 1.1.0)

geoip_domain_by_name — Obtener el nombre de dominio de segundo nivel

Descripción

geoip_domain_by_name ( string $hostname ) : string

La función geoip_domain_by_name() devolverá los nombres de dominios de segundo nivel asociados con un nombre de host o una dirección IP.

Esta función sólo está disponible actualmente a usuarios que hayan comprado una edición comercial de GeoIP Domain Edition. Se emitirá una advertencia si no se puede localizar la propia base de datos.

Parámetros

hostname

El nombre de host o dirección IP.

Valores devueltos

Devuelve el nombre de dominio en caso de éxito, o false si no se puede encontrar la dirección en la base de datos.

Ejemplos

Ejemplo #1 Un ejemplo de geoip_domain_by_name()

Mostrar el dominio asociado a la IP 61.106.139.1.

<?php
$domain = geoip_domain_by_name('61.106.139.1');

if ($domain) {
    echo 'El dominio es: '. $domain;
}

?>

El resultado del ejemplo sería:

El dominio es: von.co.kr


Obtiene el tipo de conexión a Internet

  • « geoip_domain_by_name
  • geoip_isp_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene el tipo de conexión a Internet

geoip_id_by_name

(PECL geoip >= 0.2.0)

geoip_id_by_name — Obtiene el tipo de conexión a Internet

Descripción

geoip_id_by_name ( string $hostname ) : int

La función geoip_id_by_name() devolverá el tipo de conexión a Internet correspondiente a un sitio web o a una dirección IP.

El valor devuelto es numérico y puede ser comparado con las siguientes constantes:

  • GEOIP_UNKNOWN_SPEED
  • GEOIP_DIALUP_SPEED
  • GEOIP_CABLEDSL_SPEED
  • GEOIP_CORPORATE_SPEED

Parámetros

hostname

El sitio web o dirección IP cuyo tipo de conexión quiere comprobarse.

Valores devueltos

Devuelve el tipo de conexión.

Ejemplos

Ejemplo #1 Ejemplo de geoip_id_by_name()

Mostrará el tipo de conexión del sitio web example.com.

<?php
$netspeed = geoip_id_by_name('www.example.com');

echo 'El tipo de conexión es';

switch ($netspeed) {
    case GEOIP_DIALUP_SPEED:
        echo 'módem';
        break;
    case GEOIP_CABLEDSL_SPEED:
        echo 'cable o ADSL';
        break;
    case GEOIP_CORPORATE_SPEED:
        echo 'corporativo';
        break;
    case GEOIP_UNKNOWN_SPEED:
    default:
        echo 'desconocido';
}
?>

El resultado del ejemplo sería:

El tipo de conexión es corporativo


Obtiene el nombre del proveedor de servicios de Internet (ISP)

  • « geoip_id_by_name
  • geoip_netspeedcell_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtiene el nombre del proveedor de servicios de Internet (ISP)

geoip_isp_by_name

(PECL geoip >= 1.0.2)

geoip_isp_by_name — Obtiene el nombre del proveedor de servicios de Internet (ISP)

Descripción

geoip_isp_by_name ( string $hostname ) : string

La función geoip_isp_by_name() devolverá el nombre del proveedor de servicios de Internet (ISP) que tenga asignado una dirección IP.

Esta función sólo se encuentra disponible para los usuarios que han comprado un GeoIP ISP Edición Comercial. Se devolverá una advertencia si no puede ser localizado en la base de datos.

Parámetros

hostname

El nombre de equipo o la dirección IP.

Valores devueltos

Devuelve el nombre del ISP si es correcto, o false si la dirección IP no puede ser localizada en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_isp_by_name()

Esto mostrará el ISP de ejemplo.com.

<?php
$isp = geoip_isp_by_name('www.example.com');
if ($isp) {
    echo 'This host IP is from ISP: ' . $isp;
}
?>

El resultado del ejemplo sería:

This host IP is from ISP: ICANN c/o Internet Assigned Numbers Authority


Obtener la velocidad de la conexión a Internet

  • « geoip_isp_by_name
  • geoip_org_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Obtener la velocidad de la conexión a Internet

geoip_netspeedcell_by_name

(PECL geoip >= 1.1.0)

geoip_netspeedcell_by_name — Obtener la velocidad de la conexión a Internet

Descripción

geoip_netspeedcell_by_name ( string $hostname ) : string

La función geoip_netspeedcell_by_name() devolverá el tipo y la velocidad de conexión awill Internet correspondiente a un nombre de host o a una dirección IP.

Esta función solamente está disponible si se utiliza la versión 1.4.8 o superior de la Biblioteca de GeoIP.

Esta función sólo está disponible actualmente a usuarios que hayan comprado una edición comercial de GeoIP Domain Edition. Se emitirá una advertencia si no se puede localizar la propia base de datos.

El valor devuelto es un string, cuyos valores más comunes son:

  • Cable/DSL
  • Dialup
  • Cellular
  • Corporate

Parámetros

hostname

El nombre de host o la dirección IP.

Valores devueltos

Devuelve la velocidad de conexión en caso de éxito, o false si la dirección no se puede encontrar en la base de datos.

Ejemplos

Ejemplo #1 Un ejemplo de geoip_netspeedcell_by_name()

Mostrar la velocidad de conexión del host example.com.

<?php
$netspeed = geoip_netspeedcell_by_name('www.example.com');

if ($netspeed) {
    echo 'El tipo de conexión es: '. $netspeed;
}
?>

El resultado del ejemplo sería:

El tipo de conexión es: Corporate


Consultar nombre de la organización

  • « geoip_netspeedcell_by_name
  • geoip_record_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Consultar nombre de la organización

geoip_org_by_name

(PECL geoip >= 0.2.0)

geoip_org_by_name — Consultar nombre de la organización

Descripción

geoip_org_by_name ( string $hostname ) : string

geoip_org_by_name() devuelve el nombre de la organización a la que una IP está asignada.

Esta función está actualmente disponible solo para usuarios que hayan adquirido una edición comercial de GeoIP. Se lanzará una alerta si no se pudiera localizar la base de datos apropiada

Parámetros

hostname

Nombre de host o dirección IP.

Valores devueltos

En caso de éxito devuelve el nombre de la organización, false si la dirección no se pudiera encontrar en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_org_by_name()

Muestra a quién está asignada la IP del host example.com.

<?php
$org = geoip_org_by_name('www.example.com');
if ($org) {
    echo 'Este host IP está asignado a: ' . $org;
}
?>

El resultado del ejemplo sería:

Este host IP está asignado a: ICANN c/o Internet Assigned Numbers Authority


Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP

  • « geoip_org_by_name
  • geoip_region_by_name »
  • PHP Manual
  • Funciones de GeoIP
  • Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP

geoip_record_by_name

(PECL geoip >= 0.2.0)

geoip_record_by_name — Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP

Descripción

geoip_record_by_name ( string $hostname ) : array

La función geoip_record_by_name() devuelve información a partir de un nombre de host o de una dirección IP.

Esta función está disponible tanto para la edición GeoLite City como para la edición comercial GeoIP City. Si no se encontrara la base de datos apropiada, se emitirá una alerta.

Los nombres de las claves del array asociativo son:

  • "continent_code" -- Código de continente en dos letras (a partir de la versión 1.0.4 con libgeoip 1.4.3 o superior)
  • "country_code" -- Código de país de dos letras (consulte geoip_country_code_by_name())
  • "country_code3" -- Código de país de tres letras (consulte geoip_country_code3_by_name())
  • "country_name" -- Nombre del país (consulte geoip_country_name_by_name())
  • "region" -- Código de la región (p.ej: CA para California)
  • "city" -- Ciudad.
  • "postal_code" -- Código postal, FSA o Código Zip.
  • "latitude" -- Latitud en forma de tipo double con signo.
  • "longitude" -- Longitud en forma de tipo double con signo.
  • "dma_code" -- Código de Área de Mercado Designado (sólo en EEUU y en Canadá)
  • "area_code" -- Código de área PSTN (p. ej: 212)

Parámetros

hostname

Nombre de host o dirección IP que se va a consultar.

Valores devueltos

En caso de éxito devuelve un array asociativo, o false si no se pudiera encontrar la dirección en la base de datos.

Historial de cambios

Versión | Descripción
1.0.4 | Añadido el código de continente, con la biblioteca GeoIP 1.4.3 o superior.
1.0.3 | Añadido código de país de 3 letras, y nombre de país.

Ejemplos

Ejemplo #1 Ejemplo de geoip_record_by_name()

Muestra el array que contiene el registro del host example.com.

<?php
$record = geoip_record_by_name('www.example.com');
if ($record) {
    print_r($record);
}
?>

El resultado del ejemplo sería:

Array
(
    [continent_code] => NA
    [country_code] => US
    [country_code3] => USA
    [country_name] => United States
    [region] => CA
    [city] => Marina Del Rey
    [postal_code] =>
    [latitude] => 33.9776992798
    [longitude] => -118.435096741
    [dma_code] => 803
    [area_code] => 310
)


Consultar el código de país y de región

  • « geoip_record_by_name
  • geoip_region_name_by_code »
  • PHP Manual
  • Funciones de GeoIP
  • Consultar el código de país y de región

geoip_region_by_name

(PECL geoip >= 0.2.0)

geoip_region_by_name — Consultar el código de país y de región

Descripción

geoip_region_by_name ( string $hostname ) : array

geoip_region_by_name() devuelve el país y región al que pertenecen un nombre de host o una dirección IP.

Esta función está actualmente disponible sólo a usuarios que han adquirido una edición comercial GeoIP Region. Si no se pudiera localizar la base de datos necesaria, se emtirá una alerta.

Estas son las claves del array asociativo que devuelve la función:

  • "country_code" -- Código de dos letras de país (vea geoip_country_code_by_name())
  • "region" -- Código de región (p.ej: CA para California)

Parámetros

hostname

Nombre de host o dirección IP donde consultamos la región.

Valores devueltos

En caso de éxito devuelve un array asociativo, o false si no se pudiera localizar la dirección en la base de datos.

Ejemplos

Ejemplo #1 Ejemplo de geoip_region_by_name()

Mostrará en pantalla el array que almacena el código de país y la región del host example.com.

<?php
$region = geoip_region_by_name('www.example.com');
if ($region) {
    print_r($region);
}
?>

El resultado del ejemplo sería:

Array
(
    [country_code] => US
    [region] => CA
)


Devuelve, a partir de una combinación de código de país y de región, el nombre de región

  • « geoip_region_by_name
  • geoip_setup_custom_directory »
  • PHP Manual
  • Funciones de GeoIP
  • Devuelve, a partir de una combinación de código de país y de región, el nombre de región

geoip_region_name_by_code

(PECL geoip >= 1.0.4)

geoip_region_name_by_code — Devuelve, a partir de una combinación de código de país y de región, el nombre de región

Descripción

geoip_region_name_by_code ( string $country_code , string $region_code ) : string

geoip_region_name_by_code() devuelve el nombre de región que corresponde a una combinación de códigos de país y de región.

En Estados Unidos el código de región de cada estado corresponde a una abreviatura de dos letras. En Canadá el código de región de cada provincia o territorio corresponde al código de dos letras empleado por los servicios postales de Canadá.

En el resto de países, GeoIP utiliza códigos FIPS 10-4 para identificar a las regiones. Consulte » http://www.maxmind.com/app/fips10_4 para conocer una lista detallada de los códigos FIPS 10-4.

Esta función está disponible en todas las versiones de GeoIP Library igual o superiores a la 1.4.1. La información se extrae directamente de la biblioteca GeoIP, y no de ninguna base de datos.

Parámetros

country_code

Código de dos letras del país (vea geoip_country_code_by_name())

region_code

Código de dos letras (o dígitos) de la región (vea geoip_region_by_name())

Valores devueltos

En caso de éxito devuelve el nombre de región, o false si no se pudiera encontrar esa combinación de país-región.

Ejemplos

Ejemplo #1 Ejemplo de geoip_region_name_by_code() usando código de región para EEUU/Cánada

Mostrará en pantalla el nombre de región para el país CA (Cánada), región QC (Quebec).

<?php
$region = geoip_region_name_by_code('CA', 'QC');
if ($region) {
    echo 'Nombre de región de CA/QC: ' . $region;
}
?>

El resultado del ejemplo sería:

Nombre de región de CA/QC: Quebec

Ejemplo #2 Ejemplo de geoip_region_name_by_code() usando códigos FIPS

Mostrará en pantalla el nombre de región para el país JP (Japón), región 01.

<?php
$region = geoip_region_name_by_code('JP', '01');
if ($region) {
    echo 'Nombre de región de JP/01: ' . $region;
}
?>

El resultado del ejemplo sería:

Nombre de región de JP/01: Aichi


Establecer un directorio personalizado para la base de datos de GeoIP

  • « geoip_region_name_by_code
  • geoip_time_zone_by_country_and_region »
  • PHP Manual
  • Funciones de GeoIP
  • Establecer un directorio personalizado para la base de datos de GeoIP

geoip_setup_custom_directory

(PECL geoip >= 1.1.0)

geoip_setup_custom_directory — Establecer un directorio personalizado para la base de datos de GeoIP

Descripción

geoip_setup_custom_directory ( string $path ) : void

La función geoip_setup_custom_directory() cambiará el directorio personalizado de la base de datos de GeoIP. Esto equivale a cambiar geoip.custom_directory.

Parámetros

path

La ruta completa del disco donde se encuentra la base de datos de GeoIP.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un ejemplo de geoip_setup_custom_directory()

Esto cambiará la ruta de la base de datos predeterminada de GeoIP.

<?php

geoip_setup_custom_directory('/alguna/otra/ruta');

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

El resultado del ejemplo sería:

/some/other/path/GeoIP.dat


Devuelve, a partir de una combinación de país y región, la zona horaria

  • « geoip_setup_custom_directory
  • FANN »
  • PHP Manual
  • Funciones de GeoIP
  • Devuelve, a partir de una combinación de país y región, la zona horaria

geoip_time_zone_by_country_and_region

(PECL geoip >= 1.0.4)

geoip_time_zone_by_country_and_region — Devuelve, a partir de una combinación de país y región, la zona horaria

Descripción

geoip_time_zone_by_country_and_region ( string $country_code , string $region_code = ? ) : string

geoip_time_zone_by_country_and_region() devuelve la zona horaria correspondiente a una combinación de códigos de país y de región.

En Estados Unidos el código de región de cada estado corresponde a una abreviatura de dos letras. En Canadá el código de región de cada provincia o territorio corresponde al código de dos letras empleado por los servicios postales de Canadá.

En el resto de países, GeoIP utiliza códigos FIPS 10-4 para identificar a las regiones. Consulte » http://www.maxmind.com/app/fips10_4 para conocer una lista detallada de los códigos FIPS 10-4.

Esta función está disponible en todas las versiones de GeoIP Library igual o superiores a la 1.4.1. La información se extrae directamente de la biblioteca GeoIP, y no de ninguna base de datos.

Parámetros

country_code

Código de dos letras del país (vea geoip_country_code_by_name())

region_code

Código de dos letras (o dígitos) de la región (vea geoip_region_by_name())

Valores devueltos

En caso de éxito devuelve la zona horaria, o false si no se pudiera encontrar la combinación país y región.

Ejemplos

Ejemplo #1 Ejemplo de geoip_time_zone_by_country_and_region() usando códigos de región de EEUU/Canadá

Mostrará en pantalla la zona horaria de CA (Canadá), en la región QC (Quebec).

<?php
$timezone = geoip_time_zone_by_country_and_region('CA', 'QC');
if ($timezone) {
    echo 'Zona horaria de CA/QC: ' . $timezone;
}
?>

El resultado del ejemplo sería:

Zona horaria de CA/QC: America/Montreal

Ejemplo #2 Ejemplo de geoip_time_zone_by_country_and_region() usando códigos FIPS

Mostrará en pantalla la zona horaria de JP (Japón), en la región 01 (Aichi).

<?php
$timezone = geoip_time_zone_by_country_and_region('JP', '01');
if ($timezone) {
    echo 'Zona horaria de JP/01: ' . $timezone;
}
?>

El resultado del ejemplo sería:

Zona horaria de JP/01: Asia/Tokyo


FANN (Fast Artificial Neural Network - Red Neuronal Artificial Rápida)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Entrenamiento XOR
  • Funciones de Fann
    • fann_cascadetrain_on_data — Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
    • fann_cascadetrain_on_file — Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
    • fann_clear_scaling_params — Limpia los parámetros de escala
    • fann_copy — Crea una copia de una estructura fann
    • fann_create_from_file — Construye una red neuronal de retropropagación desde un fichero de configuración
    • fann_create_shortcut_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
    • fann_create_shortcut — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
    • fann_create_sparse_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas
    • fann_create_sparse — Crea una red neuronal de retropropagación estándar que no está conectada completamente
    • fann_create_standard_array — Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas
    • fann_create_standard — Crea una red neuronal de retropropagación estándar completamente conectada
    • fann_create_train_from_callback — Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario
    • fann_create_train — Crea una estructura de datos de entrenamiento vacía
    • fann_descale_input — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
    • fann_descale_output — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
    • fann_descale_train — Descalar datos de entrada y salida basados en parámetros previamente calculados
    • fann_destroy_train — Destruye los datos de entrenamiento
    • fann_destroy — Destruye la red por completo y libera adecuadamente toda la memoria asociada
    • fann_duplicate_train_data — Devuelve una copia exacta de uno datos de entrenamiento de fann
    • fann_get_activation_function — Devuelve la función de activación
    • fann_get_activation_steepness — Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
    • fann_get_bias_array — Obtener el número de tendencias de cada capa de una red
    • fann_get_bit_fail_limit — Devuelve el límite de fallo de bit empleado durante un entrenamiento
    • fann_get_bit_fail — El número de bit fallidos
    • fann_get_cascade_activation_functions_count — Devuelve el número de funciones de activación en cascada
    • fann_get_cascade_activation_functions — Devuelve las funciones de activación en cascada
    • fann_get_cascade_activation_steepnesses_count — El número de pendientes de activación
    • fann_get_cascade_activation_steepnesses — Devuelve las pendientes de activación en cascada
    • fann_get_cascade_candidate_change_fraction — Devuelve la fracción de cambio de candidatas en cascada
    • fann_get_cascade_candidate_limit — Devuelve el límite de candidatas
    • fann_get_cascade_candidate_stagnation_epochs — Devuelve el número de épocas de estancamiento de candidatas en cascada
    • fann_get_cascade_max_cand_epochs — Devuelve el máximo de épocas de candidatas
    • fann_get_cascade_max_out_epochs — Devuelve el máximo de épocas de salida
    • fann_get_cascade_min_cand_epochs — Devuelve el mínimo de épocas de candidatas
    • fann_get_cascade_min_out_epochs — Devuelve el mínimo de épocas de salida
    • fann_get_cascade_num_candidate_groups — Devuelve el número de grupos de candidatas
    • fann_get_cascade_num_candidates — Devuelve el número de candidatas empleadas durante un entrenamiento
    • fann_get_cascade_output_change_fraction — Devuelve la fracción de cambio de salida en cascada
    • fann_get_cascade_output_stagnation_epochs — Devuelve el número de épocas de estancamiento de salida en cascada
    • fann_get_cascade_weight_multiplier — Devuelve el multiplicador de peso
    • fann_get_connection_array — Obtener las conexiones de la red
    • fann_get_connection_rate — Obtener el índice de conexión empleado al crear la red
    • fann_get_errno — Devuelve el número del último error
    • fann_get_errstr — Devuelve el string de último error
    • fann_get_layer_array — Obtener el número de neuronas de cada capa de la red
    • fann_get_learning_momentum — Devuelve el momento del aprendizaje
    • fann_get_learning_rate — Devuelve el índice de aprendizaje
    • fann_get_MSE — Lee el error cuadrático medio de la red
    • fann_get_network_type — Obtener el tipo de una red neuronal
    • fann_get_num_input — Obtener el número de neuronas de entrada
    • fann_get_num_layers — Obtener el número de capas de la red neuronal
    • fann_get_num_output — Obtener el número de neuronas de salida
    • fann_get_quickprop_decay — Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop
    • fann_get_quickprop_mu — Devuelve el factor mu
    • fann_get_rprop_decrease_factor — Devuelve el factor de disminución empleado durante un entrenamiento RPROP
    • fann_get_rprop_delta_max — Devuelve el tamaño de paso máximo
    • fann_get_rprop_delta_min — Devuelve el tamaño de paso mínimo
    • fann_get_rprop_delta_zero — Devuelve el tamaño de paso inicial
    • fann_get_rprop_increase_factor — Devuelve el factor de aumento empleado durante un entrenamiento RPROP
    • fann_get_sarprop_step_error_shift — Devuelve el desplazamiento del error de paso de sarprop
    • fann_get_sarprop_step_error_threshold_factor — Devuelve el factor de umbral del error de paso de sarprop
    • fann_get_sarprop_temperature — Devuelve la temperatura de sarprop
    • fann_get_sarprop_weight_decay_shift — Devuelve el desplazamiento de decadencia del peso de sarprop
    • fann_get_total_connections — Obtener el número total de conexiones de la red completa
    • fann_get_total_neurons — Obtener el número total de neuronas de la red completa
    • fann_get_train_error_function — Devuelve la función de error empleada durante un entrenamiento
    • fann_get_train_stop_function — Devuelve la función de parada empleada durante el entrenamiento
    • fann_get_training_algorithm — Devuelve el algoritmo de entrenamiento
    • fann_init_weights — Inicializar los pesos empleando el algoritmo de Widrow + Nguyen
    • fann_length_train_data — Devuelve el número de patrones de entrenamiento de los datos de entrenamiento
    • fann_merge_train_data — Funde los datos de entrenamiento
    • fann_num_input_train_data — Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento
    • fann_num_output_train_data — Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento
    • fann_print_error — Imprime el string de error
    • fann_randomize_weights — Dar a cada conexión un peso aleatorio entre min_weight y max_weight
    • fann_read_train_from_file — Lee un fichero que almacena datos de entrenamiento
    • fann_reset_errno — Reinicia el número del último error
    • fann_reset_errstr — Reinicia el string del último error
    • fann_reset_MSE — Reinicia el error cuadrático medio de la red
    • fann_run — Ejecutará la entrada a través de la red neuronal
    • fann_save_train — Guarda la estructura de entrenamiento en un fichero
    • fann_save — Guarda la red completa a un fichero de configuración
    • fann_scale_input_train_data — Escala las entradas de los datos de entrenamiento al rango especificado
    • fann_scale_input — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
    • fann_scale_output_train_data — Escala las salidas de los datos de entrenamiento al rango especificado
    • fann_scale_output — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
    • fann_scale_train_data — Escala la entradas y salidas de los datos de entrenamiento al rango especificado
    • fann_scale_train — Escalar datos de entrada y salida basados en parámetros previamente calculados
    • fann_set_activation_function_hidden — Establece la función de activación para todas las capas ocultas
    • fann_set_activation_function_layer — Establece la función de activación para todas las neuronas de la capa proporcionada
    • fann_set_activation_function_output — Establece la función de activación para la capa de salida
    • fann_set_activation_function — Establece la función de activación para la neurona y capa proporcionadas
    • fann_set_activation_steepness_hidden — Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
    • fann_set_activation_steepness_layer — Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
    • fann_set_activation_steepness_output — Establece la pendiente de activación de la capa de salida
    • fann_set_activation_steepness — Establece la pendiente de activación el número de neurona y capa proporcionados
    • fann_set_bit_fail_limit — Establece el límite de fallo de bit empleado durante un entrenamiento
    • fann_set_callback — Establece la función de retrollamada a emplear durante el entrenamiento
    • fann_set_cascade_activation_functions — Establece el array de funciones de activación de candidatas en cascada
    • fann_set_cascade_activation_steepnesses — Establece el array de pendientes de activación de candidatas en cascada
    • fann_set_cascade_candidate_change_fraction — Establece la fracción de cambio de candidatas en cascada
    • fann_set_cascade_candidate_limit — Establece el límite de candidatas
    • fann_set_cascade_candidate_stagnation_epochs — Establece el número de épocas de estancamiento de candidatas en cascada
    • fann_set_cascade_max_cand_epochs — Establece el máximo de épocas de candidatas
    • fann_set_cascade_max_out_epochs — Establece el máximo de épocas de salida
    • fann_set_cascade_min_cand_epochs — Establece el mínimo de épocas de candidatas
    • fann_set_cascade_min_out_epochs — Establece el mínimo de épocas de salida
    • fann_set_cascade_num_candidate_groups — Establece el número de grupos de candidatas
    • fann_set_cascade_output_change_fraction — Establece la fracción de cambio de salida en cascada
    • fann_set_cascade_output_stagnation_epochs — Establece el número de épocas de estancamiento de salida en cascada
    • fann_set_cascade_weight_multiplier — Establece el multiplicador de peso
    • fann_set_error_log — Establece dónde registrar los errores
    • fann_set_input_scaling_params — Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento
    • fann_set_learning_momentum — Establece el momento del aprendizaje
    • fann_set_learning_rate — Establece el índice de aprendizaje
    • fann_set_output_scaling_params — Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento
    • fann_set_quickprop_decay — Establece el factor de decadencia de quickprop
    • fann_set_quickprop_mu — Establece el factor mu de quickprop
    • fann_set_rprop_decrease_factor — Establece el factor de disminución empleado durante un entrenamiento RPROP
    • fann_set_rprop_delta_max — Establece el tamaño de paso máximo
    • fann_set_rprop_delta_min — Establece el tamaño de paso mínimo
    • fann_set_rprop_delta_zero — Establece el tamaño de paso inicial
    • fann_set_rprop_increase_factor — Establece el factor de aumento empleado durante un entrenamiento RPROP
    • fann_set_sarprop_step_error_shift — Establece el desplazamiento del error de paso de sarprop
    • fann_set_sarprop_step_error_threshold_factor — Establece el factor de umbral del error de paso de sarprop
    • fann_set_sarprop_temperature — Establece la temperatura de sarprop
    • fann_set_sarprop_weight_decay_shift — Establece el desplazamiento de decadencia del peso de sarprop
    • fann_set_scaling_params — Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento
    • fann_set_train_error_function — Establecer la función de error empleada durante un entrenamiento
    • fann_set_train_stop_function — Establece la función de parada empleada durante el entrenamiento
    • fann_set_training_algorithm — Establece el algoritmo de entrenamiento
    • fann_set_weight_array — Establecer las conexiones de la red
    • fann_set_weight — Establecer una conexión de la red
    • fann_shuffle_train_data — Mezcla los datos de entrenamiento, aleatorizando el orden
    • fann_subset_train_data — Devuelve una copia de un subconjunto de los datos de entrenamiento
    • fann_test_data — Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
    • fann_test — Probar con un conjunto de entradas, y un conjunto de salidas deseadas
    • fann_train_epoch — Entrenar una época con un conjunto de datos de entrenamiento
    • fann_train_on_data — Entrena un conjunto de datos completo por un período de tiempo
    • fann_train_on_file — Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo
    • fann_train — Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas
  • FANNConnection — La clase FANNConnection
    • FANNConnection::__construct — El constructor de la conexión
    • FANNConnection::getFromNeuron — Devuelve las posiciones de la neurona inicial
    • FANNConnection::getToNeuron — Devuelve las posiciones de la neurona terminal
    • FANNConnection::getWeight — Devuelve el peso de la conexión
    • FANNConnection::setWeight — Establece el peso de la conexión


Introducción

Enlace de PHP para la biblioteca FANN (Fast Artificial Neural Network - Red Neuronal Artificial Rápida), la cual implementa redes neuronales artificiales multicapa con soporte para redes completa y escasamente conectadas. Incluye un marco de trabajo para el manejo sencillo de conjuntos de datos de entrenamiento. Es sencilla de utilizar, es versátil, está bien documentada, y es rápida.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

PHP >= 5.2.0 y libfann >= 2.1.0


Instalación

La extensión FANN para PHP debería funcionar en todos los sistemas Linux.

  • Instalación de la biblioteca FANN
  • Instalación desde PECL
  • Instalación manual

Instalación de la biblioteca FANN

Antes de iniciar la instalación asegúrese de que libfann está instalada en su sistema. Es parte del repositorio principal en la mayoría de las distribuciones de Linux (busque por `fann`). Es necesaria una versión de desarrollo.

Si no está instalada, es necesario instalarla primero. Descárguela desde el » sitio oficial u obténgala desde el repositorio de su distribución. Por ejemplo, en Fedora:

$ sudo yum install fann-devel
o Ubuntu:

$ sudo apt-get install libfann-dev

Instalación desde PECL

Esta extensión está disponible en PECL. La instalación es muy sencilla. Simplemente ejecute:

$ sudo pecl install fann

Instalación manual

Para desarrolladores y gente interesada en los últimos cambios, se puede compilar el controlador desde el último código fuente en » Github. Diríjase a Github y haga clic en el botón "Download ZIP". Después ejecute:

$ unzip php-fann-master.zip
$ cd php-fann-master
$ phpize
$ ./configure
$ make all
$ sudo make install

Realice los siguientes cambios en php.ini:

  • Asugúrese de que la variable extension_dir apunta al directorio que contiene fann.so. El proceso de construcción mostrará dónde está instalando el controlador de PHP con una salida parecida a esta:

Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/fann.so'
    Asegúrese de que es el mismo que el del directorio de extensiones de PHP ejecutando:

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    Si no lo fuera, cambie extension_dir en php.ini o mueva fann.so.

  • Para cargar la extensión al inicio de PHP, añada la línea:

extension=fann.so


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Algoritmos de entrenamiento
FANN_TRAIN_INCREMENTAL (integer)
Algoritmo de retropropagación estándar, donde los pesos se actualizan después de cada patrón de entrenamiento. Esto significa que los pesos se actualizan muchas veces durante una única época. Por este motivo, algunos problemas entrenarán muy rápido con este algoritmo, mientras que problemas más avanzados no entrenarán muy bien.
FANN_TRAIN_BATCH (integer)
Algoritmo de retropropagación estándar, donde los pesos se actualizan después de calcular el error cuadrático medio para el conjunto de entrenamiento completo. Esto significa que los pesos solamente se actualizan una vez durante una época. Por este motivo, algunos problemas entrenarán más lento con este algoritmo. Aunque debido a que el error cuadrático medio se calcula más correctamente que en el entrenamiento incremental, algunos probleamas alcanzarán soluciones mejores con este algoritmo.
FANN_TRAIN_RPROP (integer)
Un algoritmo de entrenamiento por lotes más avanzado que alcanza buenos resultados para muchos problemas. El algoritmo de entrenamiento RPROP es adaptativo, por lo que no emplea learning_rate. Sin embargo, se pueden establecer otros parámetros para cambiar la manera en que funciona el algoritmo RPROP, aunque solamente se recomienda para usuarios que sepan cómo funciona el algoritmo de entrenamiento RPROP. El algoritmo de entrenamiento RPROP está descrito por [Riedmiller y Braun, 1993], aunque el algoritmo real de aprendizaje utilizado aquí es el algoritmo de entrenamiento iRPROP-, el cual está descrito por [Igel y Husken, 2000], y es una variedad del algoritmo de entrenamiento RPROP estándar.
FANN_TRAIN_QUICKPROP (integer)
Un algoritmo de entrenamiento por lotes más avanzado que alcanza buenos resultados para muchos problemas. El algoritmo de entrenamiento quickprop emplea el parámetro learning_rate junto con otros parámetros más avanzados, aunque solamente se recomienda cambiar estos parámetros avanzados a usuarios que sepan cómo funciona el algoritmo de entrenamiento quickprop. El algoritmo de entrenamiento quickprop está descrito por [Fahlman, 1988].
FANN_TRAIN_SARPROP (integer)
Algoritmo de entrenamiento más avanzado aún. Solamente para la versión 2.2
Funciones de activación
FANN_LINEAR (integer)
Función de activación lineal.
FANN_THRESHOLD (integer)
Función de activación de umbral.
FANN_THRESHOLD_SYMMETRIC (integer)
Función de activación de umbral.
FANN_SIGMOID (integer)
Función de activación sigmoide.
FANN_SIGMOID_STEPWISE (integer)
Aproximación lineal escalonada a la sigmoide.
FANN_SIGMOID_SYMMETRIC (integer)
Función de activación sigmoide simétrica, también conocida como tanh.
FANN_SIGMOID_SYMMETRIC_STEPWISE (integer)
Aproximación lineal escalonada a la sigmoide simétrica.
FANN_GAUSSIAN (integer)
Función de activación gaussiana.
FANN_GAUSSIAN_SYMMETRIC (integer)
Función de activación gaussiana simétrica.
FANN_GAUSSIAN_STEPWISE (integer)
Función de activación gaussiana escalonada.
FANN_ELLIOT (integer)
Función de activación rápida (igual que la sigmoide) definida por David Elliott.
FANN_ELLIOT_SYMMETRIC (integer)
Función de activación rápida (igual que la sigmoide simétrica) definida por David Elliott.
FANN_LINEAR_PIECE (integer)
Función de activación lineal acotada.
FANN_LINEAR_PIECE_SYMMETRIC (integer)
Función de activación lineal acotada.
FANN_SIN_SYMMETRIC (integer)
Función de activación sinusal periódica.
FANN_COS_SYMMETRIC (integer)
Función de activación cosinusal periódica.
FANN_SIN (integer)
Función de activación sinusal periódica.
FANN_COS (integer)
Función de activación cosinusal periódica.
Funciones de error utilizadas durante el entrenamiento
FANN_ERRORFUNC_LINEAR (integer)
Función de error lineal estándar.
FANN_ERRORFUNC_TANH (integer)
Función de erorr tanh, normalmente mejor, aunque puede requerir un índice de aprendizaje menor. Esta función de error dirige de forma agresiva las salidas que difieren mucho de las deseadas, mientras que no dirige las salidas que únicamente difieren más bien poco. Esta función de activación no se recomienda para entrenamientos en cascada y entrenamientos incrementales.
Criterios de parada utilizados durante el entrenamiento
FANN_STOPFUNC_MSE (integer)
El criterio de parada el es valor del Error Cuadrático Medio (ECM - MSE por sus siglas en inglés).
FANN_STOPFUNC_BIT (integer)
El criterio de parada es el número de bit que fallan. El número de bit significa el número de neuronas de salida que difieren más del límite de fallo de bit (véanse fann_get_bit_fail_limit y fann_set_bit_fail_limit). Los bit se cuentan en todos los datos de entrenamiento, por lo que este número puede ser mayor que el número de datos de entrenamiento.
Definición de los tipos de redes empleados por fann_get_network_type()
FANN_NETTYPE_LAYER (integer)
Cada capa únicamente posee conexiones a la siguiente capa.
FANN_NETTYPE_SHORTCUT (integer)
Cada capa posee conexiones a todas las capas siguientes.
Errores
FANN_E_NO_ERROR (integer)
Sin errores.
FANN_E_CANT_OPEN_CONFIG_R (integer)
No se puede abrir el fichero de configuración para lectura.
FANN_E_CANT_OPEN_CONFIG_W (integer)
No se puede abrir el fichero de configuración para escritura.
FANN_E_WRONG_CONFIG_VERSION (integer)
Versión errónea del fichero de configuración.
FANN_E_CANT_READ_CONFIG (integer)
Error al leer información del fichero de configuración.
FANN_E_CANT_READ_NEURON (integer)
Error al leer información de neuronas desde el fichero de configuración.
FANN_E_CANT_READ_CONNECTIONS (integer)
Error al leer conexiones desde el fichero de configuración.
FANN_E_WRONG_NUM_CONNECTIONS (integer)
Número de conexiones diferente del esperado.
FANN_E_CANT_OPEN_TD_W (integer)
No se puede abrir el fichero de datos de entrenamiento para escritura.
FANN_E_CANT_OPEN_TD_R (integer)
No se puede abrir el fichero de datos de entrenamiento para lectura.
FANN_E_CANT_READ_TD (integer)
Error al leer datos de entrenamiento desde el fichero.
FANN_E_CANT_ALLOCATE_MEM (integer)
No se puede asignar memoria.
FANN_E_CANT_TRAIN_ACTIVATION (integer)
No se puede entrenar con la función de activación seleccionada.
FANN_E_CANT_USE_ACTIVATION (integer)
No se puede utilizar la función de activación seleccionada.
FANN_E_TRAIN_DATA_MISMATCH (integer)
Diferencias irreconciliables entre dos estructuras fann_train_data.
FANN_E_CANT_USE_TRAIN_ALG (integer)
No se puede utilizar el algoritmo de entrenamiento seleccionado.
FANN_E_TRAIN_DATA_SUBSET (integer)
Intento de tomar un subconjunto que no está dentro del conjunto de entrenamiento.
FANN_E_INDEX_OUT_OF_BOUND (integer)
Índice fuera de los límites.
FANN_E_SCALE_NOT_PRESENT (integer)
No están presentes los parámetro de escala.
FANN_E_INPUT_NO_MATCH (integer)
El número de neuronas de entrada en los datos de la Red Neuronal Artificial (RNA - ANN por sus siglas en inglés) no coinciden.
FANN_E_OUTPUT_NO_MATCH (integer)
El número de neuronas de salida en los datos de la Red Neuronal Artificial (RNA - ANN por sus siglas en inglés) no coinciden.


  • « Constantes predefinidas
  • Entrenamiento XOR »
  • PHP Manual
  • FANN
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Entrenamiento XOR


Entrenamiento XOR

Este ejemplo muestra cómo entrenar datos para una función XOR

Ejemplo #1 Fichero xor.data

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

Ejemplo #2 Entrenamiento sencillo

<?php
$num_entradas = 2;
$num_salidas = 1;
$num_capas = 3;
$num_neuronas_ocultas = 3;
$error_deseado = 0.001;
$máx_épocas = 500000;
$épocas_entre_informes = 1000;

$rna = fann_create_standard($num_capas, $num_entradas, $num_neuronas_ocultas, $num_salidas);

if ($rna) {
    fann_set_activation_function_hidden($rna, FANN_SIGMOID_SYMMETRIC);
    fann_set_activation_function_output($rna, FANN_SIGMOID_SYMMETRIC);

    $nombre_fichero = dirname(__FILE__) . "/xor.data";
    if (fann_train_on_file($rna, $nombre_fichero, $máx_épocas, $épocas_entre_informes, $error_deseado))
        fann_save($rna, dirname(__FILE__) . "/xor_float.net");

    fann_destroy($rna);
}
?>

Este ejemplo muestra cómo leer y ejecutar datos para una función XOR

Ejemplo #3 Prueba sencilla

<?php
$fichero_entrenamiento = (dirname(__FILE__) . "/xor_float.net");
if (!is_file($fichero_entrenamiento))
    die("El fichero xor_float.net no ha sido creado. Ejecute simple_train.php para generarlo");

$rna = fann_create_from_file($fichero_entrenamiento);
if (!$rna)
    die("No se pudo crear ANN");

$entrada = array(-1, 1);
$calc_out = fann_run($rna, $entrada);
printf("xor test (%f,%f) -> %f\n", $entrada[0], $entrada[1], $calc_out[0]);
fann_destroy($rna);
?>


Funciones de Fann

Tabla de contenidos

  • fann_cascadetrain_on_data — Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
  • fann_cascadetrain_on_file — Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
  • fann_clear_scaling_params — Limpia los parámetros de escala
  • fann_copy — Crea una copia de una estructura fann
  • fann_create_from_file — Construye una red neuronal de retropropagación desde un fichero de configuración
  • fann_create_shortcut_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
  • fann_create_shortcut — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
  • fann_create_sparse_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas
  • fann_create_sparse — Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_standard_array — Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas
  • fann_create_standard — Crea una red neuronal de retropropagación estándar completamente conectada
  • fann_create_train_from_callback — Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario
  • fann_create_train — Crea una estructura de datos de entrenamiento vacía
  • fann_descale_input — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
  • fann_descale_output — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
  • fann_descale_train — Descalar datos de entrada y salida basados en parámetros previamente calculados
  • fann_destroy_train — Destruye los datos de entrenamiento
  • fann_destroy — Destruye la red por completo y libera adecuadamente toda la memoria asociada
  • fann_duplicate_train_data — Devuelve una copia exacta de uno datos de entrenamiento de fann
  • fann_get_activation_function — Devuelve la función de activación
  • fann_get_activation_steepness — Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
  • fann_get_bias_array — Obtener el número de tendencias de cada capa de una red
  • fann_get_bit_fail_limit — Devuelve el límite de fallo de bit empleado durante un entrenamiento
  • fann_get_bit_fail — El número de bit fallidos
  • fann_get_cascade_activation_functions_count — Devuelve el número de funciones de activación en cascada
  • fann_get_cascade_activation_functions — Devuelve las funciones de activación en cascada
  • fann_get_cascade_activation_steepnesses_count — El número de pendientes de activación
  • fann_get_cascade_activation_steepnesses — Devuelve las pendientes de activación en cascada
  • fann_get_cascade_candidate_change_fraction — Devuelve la fracción de cambio de candidatas en cascada
  • fann_get_cascade_candidate_limit — Devuelve el límite de candidatas
  • fann_get_cascade_candidate_stagnation_epochs — Devuelve el número de épocas de estancamiento de candidatas en cascada
  • fann_get_cascade_max_cand_epochs — Devuelve el máximo de épocas de candidatas
  • fann_get_cascade_max_out_epochs — Devuelve el máximo de épocas de salida
  • fann_get_cascade_min_cand_epochs — Devuelve el mínimo de épocas de candidatas
  • fann_get_cascade_min_out_epochs — Devuelve el mínimo de épocas de salida
  • fann_get_cascade_num_candidate_groups — Devuelve el número de grupos de candidatas
  • fann_get_cascade_num_candidates — Devuelve el número de candidatas empleadas durante un entrenamiento
  • fann_get_cascade_output_change_fraction — Devuelve la fracción de cambio de salida en cascada
  • fann_get_cascade_output_stagnation_epochs — Devuelve el número de épocas de estancamiento de salida en cascada
  • fann_get_cascade_weight_multiplier — Devuelve el multiplicador de peso
  • fann_get_connection_array — Obtener las conexiones de la red
  • fann_get_connection_rate — Obtener el índice de conexión empleado al crear la red
  • fann_get_errno — Devuelve el número del último error
  • fann_get_errstr — Devuelve el string de último error
  • fann_get_layer_array — Obtener el número de neuronas de cada capa de la red
  • fann_get_learning_momentum — Devuelve el momento del aprendizaje
  • fann_get_learning_rate — Devuelve el índice de aprendizaje
  • fann_get_MSE — Lee el error cuadrático medio de la red
  • fann_get_network_type — Obtener el tipo de una red neuronal
  • fann_get_num_input — Obtener el número de neuronas de entrada
  • fann_get_num_layers — Obtener el número de capas de la red neuronal
  • fann_get_num_output — Obtener el número de neuronas de salida
  • fann_get_quickprop_decay — Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop
  • fann_get_quickprop_mu — Devuelve el factor mu
  • fann_get_rprop_decrease_factor — Devuelve el factor de disminución empleado durante un entrenamiento RPROP
  • fann_get_rprop_delta_max — Devuelve el tamaño de paso máximo
  • fann_get_rprop_delta_min — Devuelve el tamaño de paso mínimo
  • fann_get_rprop_delta_zero — Devuelve el tamaño de paso inicial
  • fann_get_rprop_increase_factor — Devuelve el factor de aumento empleado durante un entrenamiento RPROP
  • fann_get_sarprop_step_error_shift — Devuelve el desplazamiento del error de paso de sarprop
  • fann_get_sarprop_step_error_threshold_factor — Devuelve el factor de umbral del error de paso de sarprop
  • fann_get_sarprop_temperature — Devuelve la temperatura de sarprop
  • fann_get_sarprop_weight_decay_shift — Devuelve el desplazamiento de decadencia del peso de sarprop
  • fann_get_total_connections — Obtener el número total de conexiones de la red completa
  • fann_get_total_neurons — Obtener el número total de neuronas de la red completa
  • fann_get_train_error_function — Devuelve la función de error empleada durante un entrenamiento
  • fann_get_train_stop_function — Devuelve la función de parada empleada durante el entrenamiento
  • fann_get_training_algorithm — Devuelve el algoritmo de entrenamiento
  • fann_init_weights — Inicializar los pesos empleando el algoritmo de Widrow + Nguyen
  • fann_length_train_data — Devuelve el número de patrones de entrenamiento de los datos de entrenamiento
  • fann_merge_train_data — Funde los datos de entrenamiento
  • fann_num_input_train_data — Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento
  • fann_num_output_train_data — Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento
  • fann_print_error — Imprime el string de error
  • fann_randomize_weights — Dar a cada conexión un peso aleatorio entre min_weight y max_weight
  • fann_read_train_from_file — Lee un fichero que almacena datos de entrenamiento
  • fann_reset_errno — Reinicia el número del último error
  • fann_reset_errstr — Reinicia el string del último error
  • fann_reset_MSE — Reinicia el error cuadrático medio de la red
  • fann_run — Ejecutará la entrada a través de la red neuronal
  • fann_save_train — Guarda la estructura de entrenamiento en un fichero
  • fann_save — Guarda la red completa a un fichero de configuración
  • fann_scale_input_train_data — Escala las entradas de los datos de entrenamiento al rango especificado
  • fann_scale_input — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
  • fann_scale_output_train_data — Escala las salidas de los datos de entrenamiento al rango especificado
  • fann_scale_output — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
  • fann_scale_train_data — Escala la entradas y salidas de los datos de entrenamiento al rango especificado
  • fann_scale_train — Escalar datos de entrada y salida basados en parámetros previamente calculados
  • fann_set_activation_function_hidden — Establece la función de activación para todas las capas ocultas
  • fann_set_activation_function_layer — Establece la función de activación para todas las neuronas de la capa proporcionada
  • fann_set_activation_function_output — Establece la función de activación para la capa de salida
  • fann_set_activation_function — Establece la función de activación para la neurona y capa proporcionadas
  • fann_set_activation_steepness_hidden — Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
  • fann_set_activation_steepness_layer — Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
  • fann_set_activation_steepness_output — Establece la pendiente de activación de la capa de salida
  • fann_set_activation_steepness — Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_set_bit_fail_limit — Establece el límite de fallo de bit empleado durante un entrenamiento
  • fann_set_callback — Establece la función de retrollamada a emplear durante el entrenamiento
  • fann_set_cascade_activation_functions — Establece el array de funciones de activación de candidatas en cascada
  • fann_set_cascade_activation_steepnesses — Establece el array de pendientes de activación de candidatas en cascada
  • fann_set_cascade_candidate_change_fraction — Establece la fracción de cambio de candidatas en cascada
  • fann_set_cascade_candidate_limit — Establece el límite de candidatas
  • fann_set_cascade_candidate_stagnation_epochs — Establece el número de épocas de estancamiento de candidatas en cascada
  • fann_set_cascade_max_cand_epochs — Establece el máximo de épocas de candidatas
  • fann_set_cascade_max_out_epochs — Establece el máximo de épocas de salida
  • fann_set_cascade_min_cand_epochs — Establece el mínimo de épocas de candidatas
  • fann_set_cascade_min_out_epochs — Establece el mínimo de épocas de salida
  • fann_set_cascade_num_candidate_groups — Establece el número de grupos de candidatas
  • fann_set_cascade_output_change_fraction — Establece la fracción de cambio de salida en cascada
  • fann_set_cascade_output_stagnation_epochs — Establece el número de épocas de estancamiento de salida en cascada
  • fann_set_cascade_weight_multiplier — Establece el multiplicador de peso
  • fann_set_error_log — Establece dónde registrar los errores
  • fann_set_input_scaling_params — Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento
  • fann_set_learning_momentum — Establece el momento del aprendizaje
  • fann_set_learning_rate — Establece el índice de aprendizaje
  • fann_set_output_scaling_params — Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento
  • fann_set_quickprop_decay — Establece el factor de decadencia de quickprop
  • fann_set_quickprop_mu — Establece el factor mu de quickprop
  • fann_set_rprop_decrease_factor — Establece el factor de disminución empleado durante un entrenamiento RPROP
  • fann_set_rprop_delta_max — Establece el tamaño de paso máximo
  • fann_set_rprop_delta_min — Establece el tamaño de paso mínimo
  • fann_set_rprop_delta_zero — Establece el tamaño de paso inicial
  • fann_set_rprop_increase_factor — Establece el factor de aumento empleado durante un entrenamiento RPROP
  • fann_set_sarprop_step_error_shift — Establece el desplazamiento del error de paso de sarprop
  • fann_set_sarprop_step_error_threshold_factor — Establece el factor de umbral del error de paso de sarprop
  • fann_set_sarprop_temperature — Establece la temperatura de sarprop
  • fann_set_sarprop_weight_decay_shift — Establece el desplazamiento de decadencia del peso de sarprop
  • fann_set_scaling_params — Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento
  • fann_set_train_error_function — Establecer la función de error empleada durante un entrenamiento
  • fann_set_train_stop_function — Establece la función de parada empleada durante el entrenamiento
  • fann_set_training_algorithm — Establece el algoritmo de entrenamiento
  • fann_set_weight_array — Establecer las conexiones de la red
  • fann_set_weight — Establecer una conexión de la red
  • fann_shuffle_train_data — Mezcla los datos de entrenamiento, aleatorizando el orden
  • fann_subset_train_data — Devuelve una copia de un subconjunto de los datos de entrenamiento
  • fann_test_data — Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
  • fann_test — Probar con un conjunto de entradas, y un conjunto de salidas deseadas
  • fann_train_epoch — Entrenar una época con un conjunto de datos de entrenamiento
  • fann_train_on_data — Entrena un conjunto de datos completo por un período de tiempo
  • fann_train_on_file — Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo
  • fann_train — Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas


Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

  • « Funciones de Fann
  • fann_cascadetrain_on_file »
  • PHP Manual
  • Funciones de Fann
  • Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

fann_cascadetrain_on_data

(PECL fann >= 1.0.0)

fann_cascadetrain_on_data — Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

Descripción

fann_cascadetrain_on_data ( resource $ann , resource $data , int $max_neurons , int $neurons_between_reports , float $desired_error ) : bool

La fracción de cambio de salida en cascada es un número entre 0 y 1 que determina lo grande que debería ser el cambio del valor de una fracción de fann_get_MSE() en fann_get_cascade_output_stagnation_epochs() durante el entrenamiento de las conexiones de salida, para que el entrenamiento no se estanque. Si el entrenamiento se estanca, el entrenamiento de las conexiones de salida finalizará y se prepararán nuevas candidatas.

Este entrenamiento emplea los parámetros establecidos en las funciones fann_set_cascade_..., aunque también emplea otro algoritmo de entrenamiento debido a su algoritmo de entrenamiento interno. Este algoritmo se puede establecer a FANN_TRAIN_RPROP o FANN_TRAIN_QUICKPROP mediante fann_set_training_algorithm(), y los parámetros establecidos para estos algoritmos de entrenamiento también afectarán al entrenamiento en cascada.

Parámetros

ann

Un resource de red neuronal.

data

Un resource de datos de entrenamiento de red neuronal.

max_neurons

El número máximo de neuronas a añadir a la red neuronal.

neurons_between_reports

El número de neuronas entre impresiones de informes de estado. Un valor de cero significa que no deberían imprimirse informes.

desired_error

El fann_get_MSE() o fann_get_bit_fail() deseados, dependiendo de la función de parada elegida mediante fann_set_train_stop_function().

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_cascadetrain_on_file() - Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2


Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

  • « fann_cascadetrain_on_data
  • fann_clear_scaling_params »
  • PHP Manual
  • Funciones de Fann
  • Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

fann_cascadetrain_on_file

(PECL fann >= 1.0.0)

fann_cascadetrain_on_file — Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2

Descripción

fann_cascadetrain_on_file ( resource $ann , string $filename , int $max_neurons , int $neurons_between_reports , float $desired_error ) : bool

Realiza lo mismo que fann_cascadetrain_on_data(), pero lee los datos de entrenamiento directamente desde un fichero.

Parámetros

ann

Un resource de red neuronal.

filename

El número máximo de neuronas a añadir a la red neuronal.

max_neurons

El número de neuronas entre impresiones de informes de estado a la salida estándar. Un valor de cero significa que no deberían imprimirse informes.

neurons_between_reports

El número de neuronas entre impresiones de informes de estado. Un valor de cero significa que no deberían imprimirse informes.

desired_error

El fann_get_MSE() o fann_get_bit_fail() deseados, dependiendo de la función de parada elegida mediante fann_set_train_stop_function().

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_cascadetrain_on_data() - Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2


Limpia los parámetros de escala

  • « fann_cascadetrain_on_file
  • fann_copy »
  • PHP Manual
  • Funciones de Fann
  • Limpia los parámetros de escala

fann_clear_scaling_params

(PECL fann >= 1.0.0)

fann_clear_scaling_params — Limpia los parámetros de escala

Descripción

fann_clear_scaling_params ( resource $ann ) : bool

Limpia los parámetros de escala.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Crea una copia de una estructura fann

  • « fann_clear_scaling_params
  • fann_create_from_file »
  • PHP Manual
  • Funciones de Fann
  • Crea una copia de una estructura fann

fann_copy

(PECL fann >= 1.0.0)

fann_copy — Crea una copia de una estructura fann

Descripción

fann_copy ( resource $ann ) : resource

Crea una copia de una estructura fann.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Devuelve una copia de un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_test() - Probar con un conjunto de entradas, y un conjunto de salidas deseadas


Construye una red neuronal de retropropagación desde un fichero de configuración

  • « fann_copy
  • fann_create_shortcut_array »
  • PHP Manual
  • Funciones de Fann
  • Construye una red neuronal de retropropagación desde un fichero de configuración

fann_create_from_file

(PECL fann >= 1.0.0)

fann_create_from_file — Construye una red neuronal de retropropagación desde un fichero de configuración

Descripción

fann_create_from_file ( string $configuration_file ) : resource

Construye una red neuronal de retropropagación desde un fichero de configuración, el cual ha sido guardado mediante fann_save().

Parámetros

configuration_file

La ruta al fichero de configuración.

Valores devueltos

Devuelve un resource de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_save() - Guarda la red completa a un fichero de configuración


Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

  • « fann_create_from_file
  • fann_create_shortcut »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

fann_create_shortcut_array

(PECL fann >= 1.0.0)

fann_create_shortcut_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

Descripción

fann_create_shortcut_array ( int $num_layers , array $layers ) : resource

Crea una red neuronal de retropropagación estándar que no está completamente conectada y que tiene conexiones de atajo, empleando un array con tamaños de capas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

layers

Un array con los tamaños de las capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_shortcut() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
  • fann_create_sparse() - Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_standard() - Crea una red neuronal de retropropagación estándar completamente conectada


Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

  • « fann_create_shortcut_array
  • fann_create_sparse_array »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

fann_create_shortcut

(PECL fann >= 1.0.0)

fann_create_shortcut — Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo

Descripción

fann_create_shortcut ( int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : reference

Creates a standard backpropagation neural network, which is not fully connected and which also has shortcut connections.

Las conexiones de atajo son conexiones que saltan capas. Una red completamente conectada con conexiones de atajo es una red donde todas las neuronas están conectadas a todas las neuronas de capas posteriores, incluyendo conexiones directas entre la capa de entrada y la de salida.

Parámetros

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

num_neurons1

El número de neuronas de la primera capa.

num_neurons2

El número de neuronas de la segunda capa.

...

El número de neuronas de la otras capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_shortcut_array() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
  • fann_create_sparse() - Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_standard() - Crea una red neuronal de retropropagación estándar completamente conectada


Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas

  • « fann_create_shortcut
  • fann_create_sparse »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas

fann_create_sparse_array

(PECL fann >= 1.0.0)

fann_create_sparse_array — Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas

Descripción

fann_create_sparse_array ( float $connection_rate , int $num_layers , array $layers ) : ReturnType

Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas

Parámetros

connection_rate

El índice de conexión controla cuántas conexiones habrá en la red. Si el índice de conexión está establecido a 1, la red estará completamente conectada, aunque si está establecida a 0.5, solamente se establecerán la mitad de las conexiones. Un índice de conexión de 1 generará el mismo resultado que fann_create_standard().

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

layers

Un array con los tamaños de las capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_sparse() - Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_standard() - Crea una red neuronal de retropropagación estándar completamente conectada
  • fann_create_shortcut() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo


Crea una red neuronal de retropropagación estándar que no está conectada completamente

  • « fann_create_sparse_array
  • fann_create_standard_array »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar que no está conectada completamente

fann_create_sparse

(PECL fann >= 1.0.0)

fann_create_sparse — Crea una red neuronal de retropropagación estándar que no está conectada completamente

Descripción

fann_create_sparse ( float $connection_rate , int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : ReturnType

Crea una red neuronal de retropropagación estándar que no está conectada completamente.

Parámetros

connection_rate

El índice de conexión controla cuántas conexiones habrá en la red. Si el índice de conexión está establecido a 1, la red estará completamente conectada, aunque si está establecida a 0.5, solamente se establecerán la mitad de las conexiones. Un índice de conexión de 1 generará el mismo resultado que fann_create_standard().

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

num_neurons1

El número de neuronas de la primera capa.

num_neurons2

El número de neuronas de la segunda capa.

...

El número de neuronas de la otras capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_sparse_array() - Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas
  • fann_create_standard() - Crea una red neuronal de retropropagación estándar completamente conectada
  • fann_create_shortcut() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo


Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas

  • « fann_create_sparse
  • fann_create_standard »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas

fann_create_standard_array

(PECL fann >= 1.0.0)

fann_create_standard_array — Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas

Descripción

fann_create_standard_array ( int $num_layers , array $layers ) : resource

Crea una red neuronal de retropropagación estándar completamente conectada.

Habrá una neurona de tendencia en cada capa (excepto en la de salida), y dicha neurona estará conectada a todas las neuronas de la siguiente capa. Al ejecutar la red, los nodos de tendencia siempre emiten 1.

Para destruir una red neuronal, utilice la función fann_destroy().

Parámetros

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

layers

Un array con los tamaños de las capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_standard() - Crea una red neuronal de retropropagación estándar completamente conectada
  • fann_create_sparse() - Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_shortcut() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo


Crea una red neuronal de retropropagación estándar completamente conectada

  • « fann_create_standard_array
  • fann_create_train_from_callback »
  • PHP Manual
  • Funciones de Fann
  • Crea una red neuronal de retropropagación estándar completamente conectada

fann_create_standard

(PECL fann >= 1.0.0)

fann_create_standard — Crea una red neuronal de retropropagación estándar completamente conectada

Descripción

fann_create_standard ( int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : resource

Crea una red neuronal de retropropagación estándar completamente conectada.

Habrá una neurona de tendencia en cada capa (excepto en la de salida), y dicha neurona estará conectada a todas las neuronas de la siguiente capa. Al ejecutar la red, los nodos de tendencia siempre emiten 1.

Para destruir una red neuronal, utilice la función fann_destroy().

Parámetros

num_layers

El número total de capas incluyendo la capa de entrada y de salida.

num_neurons1

El número de neuronas de la primera capa.

num_neurons2

El número de neuronas de la segunda capa.

...

El número de neuronas de la otras capas.

Valores devueltos

Devuelve un recurso de red neuronal en caso de éxito, o false en caso de error.

Ver también

  • fann_create_standard_array() - Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas
  • fann_create_sparse() - Crea una red neuronal de retropropagación estándar que no está conectada completamente
  • fann_create_shortcut() - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo


Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario

  • « fann_create_standard
  • fann_create_train »
  • PHP Manual
  • Funciones de Fann
  • Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario

fann_create_train_from_callback

(PECL fann >= 1.0.0)

fann_create_train_from_callback — Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario

Descripción

fann_create_train_from_callback ( int $num_data , int $num_input , int $num_output , callable $user_function ) : resource

Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario. Debido a que los datos de entrenamiento se numeran (datos 1, datos 2...), el usuario debe escribir una función que reciba el número del conjunto de datos de entrenamiento (entrada, salida) y que devuelva el conjunto.

Parámetros

num_data

El número de datos de entrenamiento

num_input

El número de entradas por datos de entrenamiento

num_output

El número de salidas por datos de entrenamiento

user_function

La función proporcionada por elusuario con los siguientes parámetros:

  • num - El número del conjunto de datos de entrenamiento
  • num_input - El número de entradas por datos de entrenamiento
  • num_output - El número de salidas por datos de entrenamiento

La función debería devolver un array asociativo con las claves input y output y con dos valores para la entrada y la salida.

Valores devueltos

Devuelve un resource de datos de entrenamiento en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de fann_create_train_from_callback()

<?php
function create_train_callback($num_data, $num_input, $num_output) {
    return array(
        "input" => array_fill(0, $num_input, 1),
        "output" => array_fill(0, $num_output, 1),
    );
}

$num_data = 3;
$num_input = 2;
$num_output = 1;
$train_data = fann_create_train_from_callback($num_data, $num_input, $num_output, "create_train_callback");
if ($train_data) {
    // Hacer algo con $train_data
}
?>

Ver también

  • fann_read_train_from_file() - Lee un fichero que almacena datos de entrenamiento
  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_destroy_train() - Destruye los datos de entrenamiento
  • fann_save_train() - Guarda la estructura de entrenamiento en un fichero


Crea una estructura de datos de entrenamiento vacía

  • « fann_create_train_from_callback
  • fann_descale_input »
  • PHP Manual
  • Funciones de Fann
  • Crea una estructura de datos de entrenamiento vacía

fann_create_train

(PECL fann >= 1.0.0)

fann_create_train — Crea una estructura de datos de entrenamiento vacía

Descripción

fann_create_train ( int $num_data , int $num_input , int $num_output ) : resource

Crea una estructura de datos de entrenamiento vacía.

Parámetros

num_data

El número de datos de entrenamiento

num_input

El número de entradas por datos de entrenamiento

num_output

El número de salidas por datos de entrenamiento

Valores devueltos

Devuelve un resource de datos de entrenamiento en caso de éxito, o false en caso de error.

Ver también

  • fann_read_train_from_file() - Lee un fichero que almacena datos de entrenamiento
  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_destroy_train() - Destruye los datos de entrenamiento
  • fann_save_train() - Guarda la estructura de entrenamiento en un fichero


Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

  • « fann_create_train
  • fann_descale_output »
  • PHP Manual
  • Funciones de Fann
  • Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

fann_descale_input

(PECL fann >= 1.0.0)

fann_descale_input — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

Descripción

fann_descale_input ( resource $ann , array $input_vector ) : bool

Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

input_vector

El vector de entrada a desescalar

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_input() - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
  • fann_descale_output() - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados


Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

  • « fann_descale_input
  • fann_descale_train »
  • PHP Manual
  • Funciones de Fann
  • Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

fann_descale_output

(PECL fann >= 1.0.0)

fann_descale_output — Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados

Descripción

fann_descale_output ( resource $ann , array $output_vector ) : bool

Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

output_vector

El vector de salida a desescalar

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_output() - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
  • fann_descale_input() - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados


Descalar datos de entrada y salida basados en parámetros previamente calculados

  • « fann_descale_output
  • fann_destroy_train »
  • PHP Manual
  • Funciones de Fann
  • Descalar datos de entrada y salida basados en parámetros previamente calculados

fann_descale_train

(PECL fann >= 1.0.0)

fann_descale_train — Descalar datos de entrada y salida basados en parámetros previamente calculados

Descripción

fann_descale_train ( resource $ann , resource $train_data ) : bool

Descalar datos de entrada y salida basados en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_train() - Escalar datos de entrada y salida basados en parámetros previamente calculados
  • fann_set_scaling_params() - Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento


Destruye los datos de entrenamiento

  • « fann_descale_train
  • fann_destroy »
  • PHP Manual
  • Funciones de Fann
  • Destruye los datos de entrenamiento

fann_destroy_train

(PECL fann >= 1.0.0)

fann_destroy_train — Destruye los datos de entrenamiento

Descripción

fann_destroy_train ( resource $train_data ) : bool

Destruye los datos de entrenamiento.

Parámetros

train_data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Destruye la red por completo y libera adecuadamente toda la memoria asociada

  • « fann_destroy_train
  • fann_duplicate_train_data »
  • PHP Manual
  • Funciones de Fann
  • Destruye la red por completo y libera adecuadamente toda la memoria asociada

fann_destroy

(PECL fann >= 1.0.0)

fann_destroy — Destruye la red por completo y libera adecuadamente toda la memoria asociada

Descripción

fann_destroy ( resource $ann ) : bool

Destruye la red por completo y libera adecuadamente toda la memoria asociada.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Devuelve una copia exacta de uno datos de entrenamiento de fann

  • « fann_destroy
  • fann_get_activation_function »
  • PHP Manual
  • Funciones de Fann
  • Devuelve una copia exacta de uno datos de entrenamiento de fann

fann_duplicate_train_data

(PECL fann >= 1.0.0)

fann_duplicate_train_data — Devuelve una copia exacta de uno datos de entrenamiento de fann

Descripción

fann_duplicate_train_data ( resource $data ) : resource

Devuelve una copia exacta de un resource de datos de entrenamiento de fann.

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve un resource de datos de entrenamiento en caso de éxito, o false en caso de error.


Devuelve la función de activación

  • « fann_duplicate_train_data
  • fann_get_activation_steepness »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la función de activación

fann_get_activation_function

(PECL fann >= 1.0.0)

fann_get_activation_function — Devuelve la función de activación

Descripción

fann_get_activation_function ( resource $ann , int $layer , int $neuron ) : int

Obtiene la función de activación para la neurona número the neuron en la capa número layer, contando la capa de entrada como capa 0.

No es posible obtener funciones de activación para neuronas de la capa de entrada.

El valor devuelto es una de las constantes de funciones de activación.

Parámetros

ann

Un resource de red neuronal.

layer

El número de capa.

neuron

El número de neurona.

Valores devueltos

Una constante de funciones de aprendizaje o -1 si la neurona no está definida en la red neuronal, o false en caso de error.

Ver también

  • fann_set_activation_function_layer() - Establece la función de activación para todas las neuronas de la capa proporcionada
  • fann_set_activation_function_hidden() - Establece la función de activación para todas las capas ocultas
  • fann_set_activation_function_output() - Establece la función de activación para la capa de salida
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas


Devuelve la pendiente de activación para el número de neurona y de capa proporcionados

  • « fann_get_activation_function
  • fann_get_bias_array »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la pendiente de activación para el número de neurona y de capa proporcionados

fann_get_activation_steepness

(PECL fann >= 1.0.0)

fann_get_activation_steepness — Devuelve la pendiente de activación para el número de neurona y de capa proporcionados

Descripción

fann_get_activation_steepness ( resource $ann , int $layer , int $neuron ) : float

Obtiene la pendiente de activación para la neurona número neuron en la capa número layer, contando la capa de entrada como capa 0.

No es posible obtener la pendiente de activación para neuronas de la capa de entrada.

La pendiente de una función de activación dice algo sobre cómo de rápido va la función de activación del mínimo al máximo. Un valor alto para la función de activación proporcionará un entrenamiento más agresivo.

Cuando se entrenan redes neuronales donde los valores de salida deberían estar en los extremos (normalmente 0 y 1, dependiendo de la función de activación), se puede emplear una función de activación (p.ej. 1.0).

La pendiente de activación predeterminada es 0.5.

Parámetros

ann

Un resource de red neuronal.

layer

El número de capa

neuron

El número de neurona

Valores devueltos

La pendiente de activación para la neurona o -1 si la neurona no está definida en la red neuronal, o false en caso de error.

Ver también

  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas
  • fann_set_activation_steepness_layer() - Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
  • fann_set_activation_steepness_hidden() - Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
  • fann_set_activation_steepness_output() - Establece la pendiente de activación de la capa de salida
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados


Obtener el número de tendencias de cada capa de una red

  • « fann_get_activation_steepness
  • fann_get_bit_fail_limit »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número de tendencias de cada capa de una red

fann_get_bias_array

(PECL fann >= 1.0.0)

fann_get_bias_array — Obtener el número de tendencias de cada capa de una red

Descripción

fann_get_bias_array ( resource $ann ) : array

Obtener el número de tendencias de cada capa de una red.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Un array con de números de tendencias en cada capa.


Devuelve el límite de fallo de bit empleado durante un entrenamiento

  • « fann_get_bias_array
  • fann_get_bit_fail »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el límite de fallo de bit empleado durante un entrenamiento

fann_get_bit_fail_limit

(PECL fann >= 1.0.0)

fann_get_bit_fail_limit — Devuelve el límite de fallo de bit empleado durante un entrenamiento

Descripción

fann_get_bit_fail_limit ( resource $ann ) : float

Devuelve el límite de fallo de bit empleado durante un entrenamiento.

El límite de fallo de bit se emplea durante un entrenamiento donde la función de parada esté establecida a FANN_STOPFUNC_BIT.

El límite es la diferencia máxima aceptada entre la salida provista y la salida real durante un entrenamiento. Cada salida que diverja más que este límite se cuenta como un bit de error. Esta diferencia se dividide entre dos al tratar con funciones de activación simétrica, por lo que las funciones de activación simétrica y no simétrica pueden utilizar el mismo límite.

El límite de fallo de bit es 0.35.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El límite de fallo de bit, o false en caso de error.

Ver también

  • fann_set_bit_fail_limit() - Establece el límite de fallo de bit empleado durante un entrenamiento


El número de bit fallidos

  • « fann_get_bit_fail_limit
  • fann_get_cascade_activation_functions_count »
  • PHP Manual
  • Funciones de Fann
  • El número de bit fallidos

fann_get_bit_fail

(PECL fann >= 1.0.0)

fann_get_bit_fail — El número de bit fallidos

Descripción

fann_get_bit_fail ( resource $ann ) : int

El número de bit fallidos; es el número de neuronas de salida que difieren más del límte de fallo de bit (véanse fann_get_bit_fail_limit() y fann_set_bit_fail_limit()). Los bit se cuentan en todos los datos de entrenamiento, por lo que este número puede ser mayor que el número de datos de entrenamiento.

Este valor es reiniciado por fann_reset_MSE() y actualizado por las mismas funciones que también actualizan el valor del ECM (p.ej., fann_test_data() y fann_train_epoch())

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de bit fallidos, o false en caso de error.

Ver también

  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_reset_MSE() - Reinicia el error cuadrático medio de la red
  • fann_test_data() - Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
  • fann_train_epoch() - Entrenar una época con un conjunto de datos de entrenamiento
  • fann_get_bit_fail_limit() - Devuelve el límite de fallo de bit empleado durante un entrenamiento
  • fann_set_bit_fail_limit() - Establece el límite de fallo de bit empleado durante un entrenamiento


Devuelve el número de funciones de activación en cascada

  • « fann_get_bit_fail
  • fann_get_cascade_activation_functions »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de funciones de activación en cascada

fann_get_cascade_activation_functions_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions_count — Devuelve el número de funciones de activación en cascada

Descripción

fann_get_cascade_activation_functions_count ( resource $ann ) : int

El número de funciones de activación del array fann_get_cascade_activation_functions().

El número predeterminado de funciones de activación es 6.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de funciones de activación en cascada, o false en caso de error.

Ver también

  • fann_get_cascade_activation_functions() - Devuelve las funciones de activación en cascada
  • fann_set_cascade_activation_functions() - Establece el array de funciones de activación de candidatas en cascada


Devuelve las funciones de activación en cascada

  • « fann_get_cascade_activation_functions_count
  • fann_get_cascade_activation_steepnesses_count »
  • PHP Manual
  • Funciones de Fann
  • Devuelve las funciones de activación en cascada

fann_get_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions — Devuelve las funciones de activación en cascada

Descripción

fann_get_cascade_activation_functions ( resource $ann ) : array

El array de funciones de activación en cascada es un array con las diferentes funciones de activación empleadas por las cadidatas.

Véase fann_get_cascade_num_candidates() para una descripción de las neuronas candidatas generadas por este array.

Las funciones de activación predeterminadas son FANN_SIGMOID, FANN_SIGMOID_SYMMETRIC, FANN_GAUSSIAN, FANN_GAUSSIAN_SYMMETRIC, FANN_ELLIOT y FANN_ELLIOT_SYMMETRIC.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Las funciones de activación en cascada, o false en caso de error.

Ver también

  • fann_get_cascade_activation_functions_count() - Devuelve el número de funciones de activación en cascada
  • fann_set_cascade_activation_functions() - Establece el array de funciones de activación de candidatas en cascada


El número de pendientes de activación

  • « fann_get_cascade_activation_functions
  • fann_get_cascade_activation_steepnesses »
  • PHP Manual
  • Funciones de Fann
  • El número de pendientes de activación

fann_get_cascade_activation_steepnesses_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses_count — El número de pendientes de activación

Descripción

fann_get_cascade_activation_steepnesses_count ( resource $ann ) : int

El número de pendientes de activación del array fann_get_cascade_activation_functions().

El número de pendientes de activación predeterminado es 4.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de pendientes de activación, o false en caso de error.

Ver también

  • fann_get_cascade_activation_steepnesses() - Devuelve las pendientes de activación en cascada
  • fann_set_cascade_activation_functions() - Establece el array de funciones de activación de candidatas en cascada


Devuelve las pendientes de activación en cascada

  • « fann_get_cascade_activation_steepnesses_count
  • fann_get_cascade_candidate_change_fraction »
  • PHP Manual
  • Funciones de Fann
  • Devuelve las pendientes de activación en cascada

fann_get_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses — Devuelve las pendientes de activación en cascada

Descripción

fann_get_cascade_activation_steepnesses ( resource $ann ) : array

El array de pendientes de activación en cascada es un array con las diferentes funciones de activación empleadas por las candidatas.

Véase fann_get_cascade_num_candidates() para una descripción de las neuronas candidatas generadas por este array.

Las pendientes de activación predeterminadas son {0.25, 0.50, 0.75, 1.00}.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Las pendientes de activación en cascada, o false en caso de error.

Ver también

  • fann_get_cascade_activation_steepnesses_count() - El número de pendientes de activación
  • fann_set_cascade_activation_steepnesses() - Establece el array de pendientes de activación de candidatas en cascada


Devuelve la fracción de cambio de candidatas en cascada

  • « fann_get_cascade_activation_steepnesses
  • fann_get_cascade_candidate_limit »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la fracción de cambio de candidatas en cascada

fann_get_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_change_fraction — Devuelve la fracción de cambio de candidatas en cascada

Descripción

fann_get_cascade_candidate_change_fraction ( resource $ann ) : float

La fracción de cambio de candidatas en cascada es un número entre 0 y 1 que determina lo grande que debería ser el cambio del valor de una fracción de fann_get_MSE() en fann_get_cascade_candidate_stagnation_epochs() durante el entrenamiento de las neuronas candidatas, para que el entrenamiento no se estanque. Si el entrenamiento se estanca, el entrenamiento de las neuronas candidatas finalizará y se seleccionarán nuevas candidatas.

Esto significa que si el ECM no cambia por una fracción de fann_get_cascade_candidate_change_fraction() durante un período de fann_get_cascade_candidate_stagnation_epochs(), el entrenamiento de las neuronas candidatas se para delbido a que el entrenamiento ha estancado.

Si la fracción de cambio de candidatas en cascada es baja, las neuronas candidatas serán entrenadas más, y si la fracción es alta, serán entrenadas menos.

La fracción de cambio de candidatas en cascada predeterminada es 0.01, que es equivalente a un cambio del 1% en el ECM.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

The cascade candidate change fraction, or false on error.

Ver también

  • fann_set_cascade_candidate_change_fraction() - Establece la fracción de cambio de candidatas en cascada
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_get_cascade_candidate_stagnation_epochs() - Devuelve el número de épocas de estancamiento de candidatas en cascada


Devuelve el límite de candidatas

  • « fann_get_cascade_candidate_change_fraction
  • fann_get_cascade_candidate_stagnation_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el límite de candidatas

fann_get_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_limit — Devuelve el límite de candidatas

Descripción

fann_get_cascade_candidate_limit ( resource $ann ) : float

El límite de candidatas es un límite de cuánto podrían ser entrenadas las neuronas candidatas. El límite es un límite de la proporción entre el ECM y la puntuación de la candidata.

Establecezca este valor a uno más bajo para evitar el sobreajuste, y a uno más alto si el sobreajuste no es un problema.

El límite de candidatas predetermiado es 1000.0.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El límite de candidatas, o false en caso de error.

Ver también

  • fann_set_cascade_candidate_limit() - Establece el límite de candidatas


Devuelve el número de épocas de estancamiento de candidatas en cascada

  • « fann_get_cascade_candidate_limit
  • fann_get_cascade_max_cand_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de épocas de estancamiento de candidatas en cascada

fann_get_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_stagnation_epochs — Devuelve el número de épocas de estancamiento de candidatas en cascada

Descripción

fann_get_cascade_candidate_stagnation_epochs ( resource $ann ) : float

El número de épocas de estancamiento de candidatas en cascada determina el número de entrenamiento de épocas permitido para continuar sin cambiar el ECM por una fracción de fann_get_cascade_candidate_change_fraction().

Véase más información sobre este parámetro en fann_get_cascade_candidate_change_fraction().

El número de épocas de estancamiento de candidatas en cascada predeterminado es 12.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de épocas de estancamiento de candidatas en cascada, o false en caso de error.

Ver también

  • fann_set_cascade_candidate_stagnation_epochs() - Establece el número de épocas de estancamiento de candidatas en cascada
  • fann_get_cascade_candidate_change_fraction() - Devuelve la fracción de cambio de candidatas en cascada


Devuelve el máximo de épocas de candidatas

  • « fann_get_cascade_candidate_stagnation_epochs
  • fann_get_cascade_max_out_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el máximo de épocas de candidatas

fann_get_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_cand_epochs — Devuelve el máximo de épocas de candidatas

Descripción

fann_get_cascade_max_cand_epochs ( resource $ann ) : int

El máximo de épocas de cadidatas determina el número máximo de épocas que podrían ser entrenadas las conexiones de entrada a las candidatas antes de añadir una nueva neurona candidata.

El máximo de épocas de candidatas predterminado es 150.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El máximo de épocas de candidtas, o false en caso de error.

Ver también

  • fann_set_cascade_max_cand_epochs() - Establece el máximo de épocas de candidatas


Devuelve el máximo de épocas de salida

  • « fann_get_cascade_max_cand_epochs
  • fann_get_cascade_min_cand_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el máximo de épocas de salida

fann_get_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_out_epochs — Devuelve el máximo de épocas de salida

Descripción

fann_get_cascade_max_out_epochs ( resource $ann ) : int

El máximo de épocas de salida determina el número máximo de épocas que podrían ser entrenadas las conexiones de salida después de añadir una nueva neurona candidata.

El máximo de épocas de salida predterminado es 150.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El máximo de épocas de salida, o false en caso de error.

Ver también

  • fann_set_cascade_max_out_epochs() - Establece el máximo de épocas de salida


Devuelve el mínimo de épocas de candidatas

  • « fann_get_cascade_max_out_epochs
  • fann_get_cascade_min_out_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el mínimo de épocas de candidatas

fann_get_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_cand_epochs — Devuelve el mínimo de épocas de candidatas

Descripción

fann_get_cascade_min_cand_epochs ( resource $ann ) : int

El mínimo de épocas de cadidatas determina el número máximo de épocas que podrían ser entrenadas las conexiones de entrada a las candidatas antes de añadir una nueva neurona candidata.

El mínimo de épocas de candidatas predterminado es 150.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El mínimo de épocas de candidtas, o false en caso de error.

Ver también

  • fann_set_cascade_min_cand_epochs() - Establece el mínimo de épocas de candidatas


Devuelve el mínimo de épocas de salida

  • « fann_get_cascade_min_cand_epochs
  • fann_get_cascade_num_candidate_groups »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el mínimo de épocas de salida

fann_get_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_out_epochs — Devuelve el mínimo de épocas de salida

Descripción

fann_get_cascade_min_out_epochs ( resource $ann ) : int

El mínimo de épocas de salida determina el número mínimo de épocas que deben ser entrenadas las conexiones de salida después de añadir una nueva neurona candidata.

El mínimo de épocas de salida predterminado es 150.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El mínimo de épocas de salida, o false en caso de error.

Ver también

  • fann_set_cascade_min_out_epochs() - Establece el mínimo de épocas de salida


Devuelve el número de grupos de candidatas

  • « fann_get_cascade_min_out_epochs
  • fann_get_cascade_num_candidates »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de grupos de candidatas

fann_get_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidate_groups — Devuelve el número de grupos de candidatas

Descripción

fann_get_cascade_num_candidate_groups ( resource $ann ) : int

El número de grupos de candidatas es el número de grupos de candidatas idénticos que se emplearán durante un entrenamiento.

Este número se puede usar para tener más candidatas sin tener que definir nuevos parámetros para las candidatas.

Véase fann_get_cascade_num_candidates() para una descripción de las neuronas candidatas generadas por este parámetro.

El número de grupos de candidatas predeterminado es 2.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de grupos de candidatas, o false en caso de error.

Ver también

  • fann_set_cascade_num_candidate_groups() - Establece el número de grupos de candidatas


Devuelve el número de candidatas empleadas durante un entrenamiento

  • « fann_get_cascade_num_candidate_groups
  • fann_get_cascade_output_change_fraction »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de candidatas empleadas durante un entrenamiento

fann_get_cascade_num_candidates

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidates — Devuelve el número de candidatas empleadas durante un entrenamiento

Descripción

fann_get_cascade_num_candidates ( resource $ann ) : int

El número de candidatas empleadas durante el entrenamiento (calculado multiplicando
fann_get_cascade_activation_functions_count(),
fann_get_cascade_activation_steepnesses_count() y
fann_get_cascade_num_candidate_groups()).

Las candidatas reales están definidos por los array fann_get_cascade_activation_functions() y fann_get_cascade_activation_steepnesses(). Estos array definen las funciones de activación y las pendientes de activación empleadas por las neuronas candidatas. Si hay 2 funciones de activación en el array de funciones de activación y 3 pendientes en el array de pendientes, habrá 2x3=6 candidatas diferentes que serán entrenados. Estas 6 candidatas diferentes se puedn copiar a varios grupos de candidatas, donde la única diferencia entre estos grupos es el peso inicial. Si el número de grupos se establece a 2, el número de neuronas candidatas será 2x3x2=12. El número de grupos de candidatas está definido por fann_set_cascade_num_candidate_groups().

El número de candidatas predeterminado es 6x4x2 = 48

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de candidatas emleadas durante un entrenamiento, o false en caso de error.

Ver también

  • fann_get_cascade_activation_functions() - Devuelve las funciones de activación en cascada
  • fann_get_cascade_activation_functions_count() - Devuelve el número de funciones de activación en cascada
  • fann_get_cascade_activation_steepnesses() - Devuelve las pendientes de activación en cascada
  • fann_get_cascade_activation_steepnesses_count() - El número de pendientes de activación
  • fann_get_cascade_num_candidate_groups() - Devuelve el número de grupos de candidatas


Devuelve la fracción de cambio de salida en cascada

  • « fann_get_cascade_num_candidates
  • fann_get_cascade_output_stagnation_epochs »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la fracción de cambio de salida en cascada

fann_get_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_output_change_fraction — Devuelve la fracción de cambio de salida en cascada

Descripción

fann_get_cascade_output_change_fraction ( resource $ann ) : float

La fracción de cambio de salida en cascada es un número entre 0 y 1 que determina lo grande que debería ser el cambio del valor de una fracción de fann_get_MSE() en fann_get_cascade_output_stagnation_epochs() durante el entrenamiento de las conexiones de salida, para que el entrenamiento no se estanque. Si el entrenamiento se estanca, el entrenamiento de las conexiones de salida finalizará y se prepararán nuevas candidatas.

Esto significa que si el ECM no cambia por una fracción de fann_get_cascade_output_change_fraction() durante un período de fann_get_cascade_output_stagnation_epochs(), el entrenamiento de las conexiones de salida se para delbido a que el entrenamiento ha estancado.

Si la fracción de cambio de salida en cascada es baja, las conexiones de salida serán entrenadas más, y si la fracción es alta, serán entrenadas menos.

La fracción de cambio de salida en cascada predeterminada es 0.01, que es equivalente a un cambio del 1% en el ECM.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

La fracción de cambio de salida en cascada, o false en caso de error.

Ver también

  • fann_set_cascade_output_change_fraction() - Establece la fracción de cambio de salida en cascada
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_get_cascade_output_stagnation_epochs() - Devuelve el número de épocas de estancamiento de salida en cascada


Devuelve el número de épocas de estancamiento de salida en cascada

  • « fann_get_cascade_output_change_fraction
  • fann_get_cascade_weight_multiplier »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de épocas de estancamiento de salida en cascada

fann_get_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_output_stagnation_epochs — Devuelve el número de épocas de estancamiento de salida en cascada

Descripción

fann_get_cascade_output_stagnation_epochs ( resource $ann ) : int

El número de épocas de estacamiento de salida en cascada determina el número de épocas que se le permite al entrenamiento continuar sin cambiar el ECM por una fracción de fann_get_cascade_output_change_fraction().

Véase más información sobre este parámetro en fann_get_cascade_output_change_fraction().

El número predeterminado de épocas de estancamiento de salida en cascada es 12.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de épocas de estancamiento de salida en cascada, o false en caso de error.

Ver también

  • fann_set_cascade_output_stagnation_epochs() - Establece el número de épocas de estancamiento de salida en cascada
  • fann_get_cascade_output_change_fraction() - Devuelve la fracción de cambio de salida en cascada


Devuelve el multiplicador de peso

  • « fann_get_cascade_output_stagnation_epochs
  • fann_get_connection_array »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el multiplicador de peso

fann_get_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_get_cascade_weight_multiplier — Devuelve el multiplicador de peso

Descripción

fann_get_cascade_weight_multiplier ( resource $ann ) : float

El multiplicador de peso es un parámetro que se emplea para multiplicar los pesos de la neurona candidata antes de añadir la neurona a la red neuronal. Este parámetro está normalmente entre 0 y 1, y se emplea para hacer el entrenamiento un poco menos agresivo.

El multiplicador de peso predeterminado es 0.4.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El multiplicador de peso, o false en caso de error.

Ver también

  • fann_set_cascade_weight_multiplier() - Establece el multiplicador de peso


Obtener las conexiones de la red

  • « fann_get_cascade_weight_multiplier
  • fann_get_connection_rate »
  • PHP Manual
  • Funciones de Fann
  • Obtener las conexiones de la red

fann_get_connection_array

(PECL fann >= 1.0.0)

fann_get_connection_array — Obtener las conexiones de la red

Descripción

fann_get_connection_array ( resource $ann ) : array

Obtener las conexiones de la red.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Un array con las conexiones de la red.


Obtener el índice de conexión empleado al crear la red

  • « fann_get_connection_array
  • fann_get_errno »
  • PHP Manual
  • Funciones de Fann
  • Obtener el índice de conexión empleado al crear la red

fann_get_connection_rate

(PECL fann >= 1.0.0)

fann_get_connection_rate — Obtener el índice de conexión empleado al crear la red

Descripción

fann_get_connection_rate ( resource $ann ) : float

Obtener el índice de conexión empleado al crear la red.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El índice de conexión empleado al crear la red, o false en caso de error.


Devuelve el número del último error

  • « fann_get_connection_rate
  • fann_get_errstr »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número del último error

fann_get_errno

(PECL fann >= 1.0.0)

fann_get_errno — Devuelve el número del último error

Descripción

fann_get_errno ( resource $errdat ) : int

Devuelve el número del último error.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El número de error, o false en caso de error.

Ver también

  • fann_reset_errno() - Reinicia el número del último error
  • fann_get_errstr() - Devuelve el string de último error


Devuelve el string de último error

  • « fann_get_errno
  • fann_get_layer_array »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el string de último error

fann_get_errstr

(PECL fann >= 1.0.0)

fann_get_errstr — Devuelve el string de último error

Descripción

fann_get_errstr ( resource $errdat ) : string

Devuelve el string de último error.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El string del último error, o false en caso de error.

Ver también

  • fann_reset_errstr() - Reinicia el string del último error
  • fann_get_errno() - Devuelve el número del último error


Obtener el número de neuronas de cada capa de la red

  • « fann_get_errstr
  • fann_get_learning_momentum »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número de neuronas de cada capa de la red

fann_get_layer_array

(PECL fann >= 1.0.0)

fann_get_layer_array — Obtener el número de neuronas de cada capa de la red

Descripción

fann_get_layer_array ( resource $ann ) : array

Obtener el número de neuronas de cada capa de la red neuronal.

Las tendencias no se incluyen, coincidiendo así las capas con las funciones fann_create.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Un array de números de neuronas en cada capa.


Devuelve el momento del aprendizaje

  • « fann_get_layer_array
  • fann_get_learning_rate »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el momento del aprendizaje

fann_get_learning_momentum

(PECL fann >= 1.0.0)

fann_get_learning_momentum — Devuelve el momento del aprendizaje

Descripción

fann_get_learning_momentum ( resource $ann ) : float

El momento del aprendizaje se puede emplear para acelerar un entrenamiento FANN_TRAIN_INCREMENTAL. Sin embargo, un momento muy alto no beneficiará al entrenamiento. Establecer el momento a 0 es lo mismo que no emplear el parmámetro del momento. El valor recomendado para el valor de este parámetro está entre 0.0 y 1.0.

El momento predeterminado es 0.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

El moemento del aprendizaje, o false en caso de error.

Ver también

  • fann_set_learning_momentum() - Establece el momento del aprendizaje
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Devuelve el índice de aprendizaje

  • « fann_get_learning_momentum
  • fann_get_MSE »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el índice de aprendizaje

fann_get_learning_rate

(PECL fann >= 1.0.0)

fann_get_learning_rate — Devuelve el índice de aprendizaje

Descripción

fann_get_learning_rate ( resource $ann ) : float

El índice de aprendizaje se emplea para determinar la agresividad de un entrenamiento para algunos de los algoritmo de entrenamiento (FANN_TRAIN_INCREMENTAL, FANN_TRAIN_BATCH y FANN_TRAIN_QUICKPROP). Observe, sin embargo, que no se emplea en FANN_TRAIN_RPROP.

El índice de aprendizaje predeterminado es 0.7.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El índice de aprendizaje, o false en caso de error.

Ver también

  • fann_set_learning_rate() - Establece el índice de aprendizaje
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Lee el error cuadrático medio de la red

  • « fann_get_learning_rate
  • fann_get_network_type »
  • PHP Manual
  • Funciones de Fann
  • Lee el error cuadrático medio de la red

fann_get_MSE

(PECL fann >= 1.0.0)

fann_get_MSE — Lee el error cuadrático medio de la red

Descripción

fann_get_MSE ( resource $ann ) : float

Lee el error cuadrático medio de la red.

Este valor se calcula durante un entrenamiento o una prueba, por lo que a veces puede estar un poco alejados si los pesos han cambiado desde el último cálculo de este valor.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El error cuadrático medio, o false en caso de error.

Ver también

  • fann_test_data() - Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos


Obtener el tipo de una red neuronal

  • « fann_get_MSE
  • fann_get_num_input »
  • PHP Manual
  • Funciones de Fann
  • Obtener el tipo de una red neuronal

fann_get_network_type

(PECL fann >= 1.0.0)

fann_get_network_type — Obtener el tipo de una red neuronal

Descripción

fann_get_network_type ( resource $ann ) : int

Obtener el tipo de una red neuronal.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Una constante de tipo de red, o false en caso de error.


Obtener el número de neuronas de entrada

  • « fann_get_network_type
  • fann_get_num_layers »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número de neuronas de entrada

fann_get_num_input

(PECL fann >= 1.0.0)

fann_get_num_input — Obtener el número de neuronas de entrada

Descripción

fann_get_num_input ( resource $ann ) : int

Obtener el número de neuronas de entrada.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de neuronas de entrada, o false en caso de error.


Obtener el número de capas de la red neuronal

  • « fann_get_num_input
  • fann_get_num_output »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número de capas de la red neuronal

fann_get_num_layers

(PECL fann >= 1.0.0)

fann_get_num_layers — Obtener el número de capas de la red neuronal

Descripción

fann_get_num_layers ( resource $ann ) : int

Obtener el número de capas de la red neuronal.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de capas de la red neuronal, o false en caso de error.


Obtener el número de neuronas de salida

  • « fann_get_num_layers
  • fann_get_quickprop_decay »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número de neuronas de salida

fann_get_num_output

(PECL fann >= 1.0.0)

fann_get_num_output — Obtener el número de neuronas de salida

Descripción

fann_get_num_output ( resource $ann ) : int

Obtener el número de neuronas de salida.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número de neuronas de salida, o false en caso de error.


Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop

  • « fann_get_num_output
  • fann_get_quickprop_mu »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop

fann_get_quickprop_decay

(PECL fann >= 1.0.0)

fann_get_quickprop_decay — Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop

Descripción

fann_get_quickprop_decay ( resource $ann ) : float

La decadencia es un número pequeño negativo que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop. Se emplea para asegurarse de que los pesos no sean demasiado altos durante el entrenamiento.

La decadencia predeterminada es -0.0001.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

The decay, or false on error.

Ver también

  • fann_set_quickprop_decay() - Establece el factor de decadencia de quickprop


Devuelve el factor mu

  • « fann_get_quickprop_decay
  • fann_get_rprop_decrease_factor »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el factor mu

fann_get_quickprop_mu

(PECL fann >= 1.0.0)

fann_get_quickprop_mu — Devuelve el factor mu

Descripción

fann_get_quickprop_mu ( resource $ann ) : float

El factor mu se emplea para aumentar y disminuir el tamaño del paso durante un entrenamiento quickprop. El factor mu debería estar siempre por encima de 1, ya que, de lo contrario, lo disminuiría cuando se suponía que debía de aumentarlo.

El factor mu predeterminado es 1.75.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Ek factor mu, o false en caso de error.

Ver también

  • fann_set_quickprop_mu() - Establece el factor mu de quickprop


Devuelve el factor de disminución empleado durante un entrenamiento RPROP

  • « fann_get_quickprop_mu
  • fann_get_rprop_delta_max »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el factor de disminución empleado durante un entrenamiento RPROP

fann_get_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_get_rprop_decrease_factor — Devuelve el factor de disminución empleado durante un entrenamiento RPROP

Descripción

fann_get_rprop_decrease_factor ( resource $ann ) : float

El factor de disminución es un valor menor que 1, el cual se emplea para disminuir el tamaño del paso durante un entrenamiento RPROP.

El factor de disminución predeterminado es 0.5.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El factor de disminución, o false en caso de error.

Ver también

  • fann_set_rprop_decrease_factor() - Establece el factor de disminución empleado durante un entrenamiento RPROP


Devuelve el tamaño de paso máximo

  • « fann_get_rprop_decrease_factor
  • fann_get_rprop_delta_min »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el tamaño de paso máximo

fann_get_rprop_delta_max

(PECL fann >= 1.0.0)

fann_get_rprop_delta_max — Devuelve el tamaño de paso máximo

Descripción

fann_get_rprop_delta_max ( resource $ann ) : float

El tamaño de paso máximo es un número positivo que determina lo grande que podría ser el tamaño de paso máximo.

El valor predeterminado de delta máximo es 50.0.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El tamaño de paso máximo, o false en caso de error.

Ver también

  • fann_set_rprop_delta_max() - Establece el tamaño de paso máximo
  • fann_get_rprop_delta_min() - Devuelve el tamaño de paso mínimo


Devuelve el tamaño de paso mínimo

  • « fann_get_rprop_delta_max
  • fann_get_rprop_delta_zero »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el tamaño de paso mínimo

fann_get_rprop_delta_min

(PECL fann >= 1.0.0)

fann_get_rprop_delta_min — Devuelve el tamaño de paso mínimo

Descripción

fann_get_rprop_delta_min ( resource $ann ) : float

El tamaño de paso mínimo es un número positivo pequeño que determina lo pequeño que podría ser el tamaño de paso mínimo.

El valor predeterminado de delta mínimo es 0.0.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El tamaño de paso mínimo, o false en caso de error.

Ver también

  • fann_set_rprop_delta_min() - Establece el tamaño de paso mínimo


Devuelve el tamaño de paso inicial

  • « fann_get_rprop_delta_min
  • fann_get_rprop_increase_factor »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el tamaño de paso inicial

fann_get_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_get_rprop_delta_zero — Devuelve el tamaño de paso inicial

Descripción

fann_get_rprop_delta_zero ( resource $ann ) : ReturnType

El tamaño de paso inicial es un número positivo que determina el tamaño de paso inicial.

El valor predeterminado de delta cero es 0.1.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El tamaño de paso inicial, o false en caso de error.

Ver también

  • fann_set_rprop_delta_zero() - Establece el tamaño de paso inicial
  • fann_get_rprop_delta_min() - Devuelve el tamaño de paso mínimo
  • fann_get_rprop_delta_max() - Devuelve el tamaño de paso máximo


Devuelve el factor de aumento empleado durante un entrenamiento RPROP

  • « fann_get_rprop_delta_zero
  • fann_get_sarprop_step_error_shift »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el factor de aumento empleado durante un entrenamiento RPROP

fann_get_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_get_rprop_increase_factor — Devuelve el factor de aumento empleado durante un entrenamiento RPROP

Descripción

fann_get_rprop_increase_factor ( resource $ann ) : float

El factor de aumento es un valor mayor que 1, el cual se emplea para aumentar el tamaño del paso durante un entrenamiento RPROP.

El factor de aumento predeterminado es 1.2.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El factor de aumento, o false en caso de error.

Ver también

  • fann_set_rprop_increase_factor() - Establece el factor de aumento empleado durante un entrenamiento RPROP


Devuelve el desplazamiento del error de paso de sarprop

  • « fann_get_rprop_increase_factor
  • fann_get_sarprop_step_error_threshold_factor »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el desplazamiento del error de paso de sarprop

fann_get_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_shift — Devuelve el desplazamiento del error de paso de sarprop

Descripción

fann_get_sarprop_step_error_shift ( resource $ann ) : float

Devuelve el desplazamiento del error de paso de sarprop.

El desplazamiento del error de paso predeterminado es 1.385.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El desplazamiento del error de paso de sarprop , o false en caso de error.

Ver también

  • fann_set_sarprop_step_error_shift() - Establece el desplazamiento del error de paso de sarprop


Devuelve el factor de umbral del error de paso de sarprop

  • « fann_get_sarprop_step_error_shift
  • fann_get_sarprop_temperature »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el factor de umbral del error de paso de sarprop

fann_get_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_threshold_factor — Devuelve el factor de umbral del error de paso de sarprop

Descripción

fann_get_sarprop_step_error_threshold_factor ( resource $ann ) : float

Devuelve el factor de umbral del error de paso de sarprop.

El factor predeterminado es 0.1.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El factor de umbral del error de paso de sarprop, o false en caso de error.

Ver también

  • fann_set_sarprop_step_error_threshold_factor() - Establece el factor de umbral del error de paso de sarprop


Devuelve la temperatura de sarprop

  • « fann_get_sarprop_step_error_threshold_factor
  • fann_get_sarprop_weight_decay_shift »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la temperatura de sarprop

fann_get_sarprop_temperature

(PECL fann >= 1.0.0)

fann_get_sarprop_temperature — Devuelve la temperatura de sarprop

Descripción

fann_get_sarprop_temperature ( resource $ann ) : float

Devuelve la temperatura de sarprop.

La temperatura predeterminada es 0.015.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

La temperatura de sarprop, o false en caso de error.

Ver también

  • fann_set_sarprop_temperature() - Establece la temperatura de sarprop


Devuelve el desplazamiento de decadencia del peso de sarprop

  • « fann_get_sarprop_temperature
  • fann_get_total_connections »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el desplazamiento de decadencia del peso de sarprop

fann_get_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_weight_decay_shift — Devuelve el desplazamiento de decadencia del peso de sarprop

Descripción

fann_get_sarprop_weight_decay_shift ( resource $ann ) : float

Devuelve el desplazamiento de decadencia del peso de sarprop.

El valor de delta máximo es -6.644.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El desplazamiento de decadencia del peso de sarprop, o false en caso de error.

Ver también

  • fann_set_sarprop_weight_decay_shift() - Establece el desplazamiento de decadencia del peso de sarprop


Obtener el número total de conexiones de la red completa

  • « fann_get_sarprop_weight_decay_shift
  • fann_get_total_neurons »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número total de conexiones de la red completa

fann_get_total_connections

(PECL fann >= 1.0.0)

fann_get_total_connections — Obtener el número total de conexiones de la red completa

Descripción

fann_get_total_connections ( resource $ann ) : int

Obtener el número total de conexiones de la red completa.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número total de conexiones de la red completa, o false en caso de error.


Obtener el número total de neuronas de la red completa

  • « fann_get_total_connections
  • fann_get_train_error_function »
  • PHP Manual
  • Funciones de Fann
  • Obtener el número total de neuronas de la red completa

fann_get_total_neurons

(PECL fann >= 1.0.0)

fann_get_total_neurons — Obtener el número total de neuronas de la red completa

Descripción

fann_get_total_neurons ( resource $ann ) : int

Obtener el número total de neuronas de la red completa. Este número también incluye las neuronas de tendencia, por lo que una red 2-4-2 posee 2+4+2 +2(tendencias) = 10 neuronas.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

El número total de neuronas de la red completa, o false en caso de error.


Devuelve la función de error empleada durante un entrenamiento

  • « fann_get_total_neurons
  • fann_get_train_stop_function »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la función de error empleada durante un entrenamiento

fann_get_train_error_function

(PECL fann >= 1.0.0)

fann_get_train_error_function — Devuelve la función de error empleada durante un entrenamiento

Descripción

fann_get_train_error_function ( resource $ann ) : int

Devuelve la función de error empleada durante un entrenamiento.

Las funciones de error están descritas en las constantes de funciones de error.

La función de error predeteminada es FANN_ERRORFUNC_TANH.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

La constante de función de error, o false en caso de error.

Ver también

  • fann_set_train_error_function() - Establecer la función de error empleada durante un entrenamiento


Devuelve la función de parada empleada durante el entrenamiento

  • « fann_get_train_error_function
  • fann_get_training_algorithm »
  • PHP Manual
  • Funciones de Fann
  • Devuelve la función de parada empleada durante el entrenamiento

fann_get_train_stop_function

(PECL fann >= 1.0.0)

fann_get_train_stop_function — Devuelve la función de parada empleada durante el entrenamiento

Descripción

fann_get_train_stop_function ( resource $ann ) : int

Devuelve la función de parada empleada durante el entrenamiento.

Las funciones de parada están descritas en las constantes de funciones de parada.

La función de parada predeterminada es FANN_STOPFUNC_MSE.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

La constante de función de parada, o false en caso de error.

Ver también

  • fann_set_train_stop_function() - Establece la función de parada empleada durante el entrenamiento


Devuelve el algoritmo de entrenamiento

  • « fann_get_train_stop_function
  • fann_init_weights »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el algoritmo de entrenamiento

fann_get_training_algorithm

(PECL fann >= 1.0.0)

fann_get_training_algorithm — Devuelve el algoritmo de entrenamiento

Descripción

fann_get_training_algorithm ( resource $ann ) : int

Devuelve el algoritmo de entrenamiento. Este algoritmo lo utilizan fann_train_on_data() y funciones asociadas.

Observe que este algoritmo también se emplea durante fann_cascadetrain_on_data(), aunque solamente están permitidos FANN_TRAIN_RPROP y FANN_TRAIN_QUICKPROP durante un entrenamiento en cascada.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

La constante de Algoritmo de entrenamiento, o false en caso de error.

Ver también

  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Inicializar los pesos empleando el algoritmo de Widrow + Nguyen

  • « fann_get_training_algorithm
  • fann_length_train_data »
  • PHP Manual
  • Funciones de Fann
  • Inicializar los pesos empleando el algoritmo de Widrow + Nguyen

fann_init_weights

(PECL fann >= 1.0.0)

fann_init_weights — Inicializar los pesos empleando el algoritmo de Widrow + Nguyen

Descripción

fann_init_weights ( resource $ann , resource $train_data ) : bool

Inicializar los pesos empleando el algoritmo de Widrow + Nguyen.

Esta función tiene un comportamiento similar a fann_randomize_weights(). Empleará el algoritmo desarrollado por Derrick Nguyen y Bernard Widrow para establecer los pesos de tal forma que aceleren el entrenamiento. Esta técnica no siempre funciona, por lo que en algunos casos puede ser menoes eficiente que una simple inicialización aleatoria.

El algoritmo requiere el acceso al rango de datos de entrada (por ejemplo, entradas mayores y menores), por lo que acepta un segundo parámetro, data, que son los datos de entrenamiento que se emplearán para entrenar la red.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_randomize_weights() - Dar a cada conexión un peso aleatorio entre min_weight y max_weight
  • fann_read_train_from_file() - Lee un fichero que almacena datos de entrenamiento


Devuelve el número de patrones de entrenamiento de los datos de entrenamiento

  • « fann_init_weights
  • fann_merge_train_data »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de patrones de entrenamiento de los datos de entrenamiento

fann_length_train_data

(PECL fann >= 1.0.0)

fann_length_train_data — Devuelve el número de patrones de entrenamiento de los datos de entrenamiento

Descripción

fann_length_train_data ( resource $data ) : int

Devuelve el número de patrones de entrenamiento del resource de datos de entrenamiento.

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El número de elementos del resource de datos de entrenamiento, o false en caso de error.


Funde los datos de entrenamiento

  • « fann_length_train_data
  • fann_num_input_train_data »
  • PHP Manual
  • Funciones de Fann
  • Funde los datos de entrenamiento

fann_merge_train_data

(PECL fann >= 1.0.0)

fann_merge_train_data — Funde los datos de entrenamiento

Descripción

fann_merge_train_data ( resource $data1 , resource $data2 ) : resource

Funde los datos de data1 y data2 en un nuevo resource de datos de entrenamiento.

Parámetros

data1

Un resource de datos de entrenamiento de red neuronal.

data2

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El nuevo resource de datos de entrenamiento fundido, o false en caso de error.


Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento

  • « fann_merge_train_data
  • fann_num_output_train_data »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento

fann_num_input_train_data

(PECL fann >= 1.0.0)

fann_num_input_train_data — Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento

Descripción

fann_num_input_train_data ( resource $data ) : int

Devuelve el número de entradas de cada patrón de entrenamiento del resource de datos de entrenamiento.

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El número de entradas, o false en caso de error.

Ver también

  • fann_length_train_data() - Devuelve el número de patrones de entrenamiento de los datos de entrenamiento
  • fann_num_output_train_data() - Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento


Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento

  • « fann_num_input_train_data
  • fann_print_error »
  • PHP Manual
  • Funciones de Fann
  • Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento

fann_num_output_train_data

(PECL fann >= 1.0.0)

fann_num_output_train_data — Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento

Descripción

fann_num_output_train_data ( resource $data ) : int

Devuelve el número de salidas de cada patrón de entrenamiento del resource de datos de entrenamiento.

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El número de salidas, o false en caso de error.

Ver también

  • fann_length_train_data() - Devuelve el número de patrones de entrenamiento de los datos de entrenamiento
  • fann_num_input_train_data() - Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento


Imprime el string de error

  • « fann_num_output_train_data
  • fann_randomize_weights »
  • PHP Manual
  • Funciones de Fann
  • Imprime el string de error

fann_print_error

(PECL fann >= 1.0.0)

fann_print_error — Imprime el string de error

Descripción

fann_print_error ( string $errdat ) : void

Imprime el string de error.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

Valores devueltos

No se devuelve ningún valor.

Ver también

  • fann_get_errstr() - Devuelve el string de último error


Dar a cada conexión un peso aleatorio entre min_weight y max_weight

  • « fann_print_error
  • fann_read_train_from_file »
  • PHP Manual
  • Funciones de Fann
  • Dar a cada conexión un peso aleatorio entre min_weight y max_weight

fann_randomize_weights

(PECL fann >= 1.0.0)

fann_randomize_weights — Dar a cada conexión un peso aleatorio entre min_weight y max_weight

Descripción

fann_randomize_weights ( resource $ann , float $min_weight , float $max_weight ) : bool

Dar a cada conexión un peso aleatorio entre min_weight y max_weight.

Desde el comienzo, los pesos son aleatorios, entre -0.1 y 0.1.

Parámetros

ann

Un resource de red neuronal.

min_weight

El valor del peso máximo.

max_weight

El valor del peso mínimo.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_init_weights() - Inicializar los pesos empleando el algoritmo de Widrow + Nguyen


Lee un fichero que almacena datos de entrenamiento

  • « fann_randomize_weights
  • fann_reset_errno »
  • PHP Manual
  • Funciones de Fann
  • Lee un fichero que almacena datos de entrenamiento

fann_read_train_from_file

(PECL fann >= 1.0.0)

fann_read_train_from_file — Lee un fichero que almacena datos de entrenamiento

Descripción

fann_read_train_from_file ( string $filename ) : resource

Lee un fichero que almacena datos de entrenamiento.

Parámetros

filename

El fichero de entrada con el siguiente formato:

número_datos_entrenamiento número_entradas número_salidas
datos de entrada separados por un espacio
datos de salida separados por un espacio

.
.
.

datos de entrada separados por un espacio
datos de salida separados por un espacio

Valores devueltos

Devuelve un resource de datos de entrenamiento en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de fann_read_train_from_file()

<?php
$train_data = fann_read_train_from_file("xor.data");
if ($train_data) {
    // Hacer algo con $train_data para la función XOR
}
?>

Contents of xor.data

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_destroy_train() - Destruye los datos de entrenamiento
  • fann_save_train() - Guarda la estructura de entrenamiento en un fichero


Reinicia el número del último error

  • « fann_read_train_from_file
  • fann_reset_errstr »
  • PHP Manual
  • Funciones de Fann
  • Reinicia el número del último error

fann_reset_errno

(PECL fann >= 1.0.0)

fann_reset_errno — Reinicia el número del último error

Descripción

fann_reset_errno ( resource $errdat ) : void

Reinicia el número del último error.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

Valores devueltos

No se devuelve ningún valor.

Ver también

  • fann_get_errno() - Devuelve el número del último error
  • fann_reset_errstr() - Reinicia el string del último error


Reinicia el string del último error

  • « fann_reset_errno
  • fann_reset_MSE »
  • PHP Manual
  • Funciones de Fann
  • Reinicia el string del último error

fann_reset_errstr

(PECL fann >= 1.0.0)

fann_reset_errstr — Reinicia el string del último error

Descripción

fann_reset_errstr ( resource $errdat ) : void

Reinicia el string del último error.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

Valores devueltos

No se devuelve ningún valor.

Ver también

  • fann_get_errstr() - Devuelve el string de último error
  • fann_reset_errno() - Reinicia el número del último error


Reinicia el error cuadrático medio de la red

  • « fann_reset_errstr
  • fann_run »
  • PHP Manual
  • Funciones de Fann
  • Reinicia el error cuadrático medio de la red

fann_reset_MSE

(PECL fann >= 1.0.0)

fann_reset_MSE — Reinicia el error cuadrático medio de la red

Descripción

fann_reset_MSE ( string $ann ) : bool

Reinicia el error cuadrático medio de la red.

Esta función también reinicia el número de bit que fallan.

Parámetros

ann

Un resource de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_get_bit_fail() - El número de bit fallidos
  • fann_get_bit_fail_limit() - Devuelve el límite de fallo de bit empleado durante un entrenamiento


Ejecutará la entrada a través de la red neuronal

  • « fann_reset_MSE
  • fann_save_train »
  • PHP Manual
  • Funciones de Fann
  • Ejecutará la entrada a través de la red neuronal

fann_run

(PECL fann >= 1.0.0)

fann_run — Ejecutará la entrada a través de la red neuronal

Descripción

fann_run ( resource $ann , array $input ) : array

Ejecutará la entrada a través de la red neuronal, devolviendo un array de salidas, el número de las que son iguales al número de neuronas de la capa de salida.

Parámetros

ann

Un resource de red neuronal.

input

Un array de valores de entrada.

Valores devueltos

Un array de valores de salida, o false en caso de error.


Guarda la estructura de entrenamiento en un fichero

  • « fann_run
  • fann_save »
  • PHP Manual
  • Funciones de Fann
  • Guarda la estructura de entrenamiento en un fichero

fann_save_train

(PECL fann >= 1.0.0)

fann_save_train — Guarda la estructura de entrenamiento en un fichero

Descripción

fann_save_train ( resource $data , string $file_name ) : bool

Guarda la estructura de entrenamiento en un fichero, con el formato especificado en fann_read_train_from_file().

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

file_name

El nombre delfichero donde guardar los datos de entrenamiento.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_read_train_from_file() - Lee un fichero que almacena datos de entrenamiento


Guarda la red completa a un fichero de configuración

  • « fann_save_train
  • fann_scale_input_train_data »
  • PHP Manual
  • Funciones de Fann
  • Guarda la red completa a un fichero de configuración

fann_save

(PECL fann >= 1.0.0)

fann_save — Guarda la red completa a un fichero de configuración

Descripción

fann_save ( resource $ann , string $configuration_file ) : bool

Guarda la red completa a un fichero de configuración.

El fichero de configuración contiene toda la información sobre la red neuronal y habilita a fann_create_from_file() para crear una copia exacta de la red neuronal y de todos los parámetros asociados a dicha red.

Estos tres parámetros (fann_set_callback(), fann_set_error_log(), fann_set_user_data()) NO se guardan en el fichero porque no se pueden llevar a una ubicación diferente de forma segura. Tampoco se guardan los parámetros temporales generados durante el entrenamiento, como fann_get_MSE().

Parámetros

ann

Un resource de red neuronal.

configuration_file

La ruta al fichero de configuración.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_create_from_file() - Construye una red neuronal de retropropagación desde un fichero de configuración


Escala las entradas de los datos de entrenamiento al rango especificado

  • « fann_save
  • fann_scale_input »
  • PHP Manual
  • Funciones de Fann
  • Escala las entradas de los datos de entrenamiento al rango especificado

fann_scale_input_train_data

(PECL fann >= 1.0.0)

fann_scale_input_train_data — Escala las entradas de los datos de entrenamiento al rango especificado

Descripción

fann_scale_input_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

Escala las entradas de los datos de entrenamiento al rango especificado.

Parámetros

train_data

Un resource de datos de entrenamiento de red neuronal.

new_min

El nuevo mínimo después de escalar las entradas de los datos de entrenamiento.

new_max

El nuevo máximo después de escalar las entradas de los datos de entrenamiento.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_output_train_data() - Escala las salidas de los datos de entrenamiento al rango especificado
  • fann_scale_train_data() - Escala la entradas y salidas de los datos de entrenamiento al rango especificado


Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

  • « fann_scale_input_train_data
  • fann_scale_output_train_data »
  • PHP Manual
  • Funciones de Fann
  • Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

fann_scale_input

(PECL fann >= 1.0.0)

fann_scale_input — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

Descripción

fann_scale_input ( resource $ann , array $input_vector ) : bool

Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

input_vector

El vector de entrada a escalar

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_descale_input() - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
  • fann_scale_output() - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados


Escala las salidas de los datos de entrenamiento al rango especificado

  • « fann_scale_input
  • fann_scale_output »
  • PHP Manual
  • Funciones de Fann
  • Escala las salidas de los datos de entrenamiento al rango especificado

fann_scale_output_train_data

(PECL fann >= 1.0.0)

fann_scale_output_train_data — Escala las salidas de los datos de entrenamiento al rango especificado

Descripción

fann_scale_output_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

Escala las salidas de los datos de entrenamiento al rango especificado.

Parámetros

train_data

Un resource de datos de entrenamiento de red neuronal.

new_min

El nuevo mínimo después de escalar las salidas de los datos de entrenamiento.

new_max

El nuevo máximo después de escalar las salidas de los datos de entrenamiento.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_input_train_data() - Escala las entradas de los datos de entrenamiento al rango especificado
  • fann_scale_train_data() - Escala la entradas y salidas de los datos de entrenamiento al rango especificado


Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

  • « fann_scale_output_train_data
  • fann_scale_train_data »
  • PHP Manual
  • Funciones de Fann
  • Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

fann_scale_output

(PECL fann >= 1.0.0)

fann_scale_output — Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados

Descripción

fann_scale_output ( resource $ann , array $output_vector ) : bool

Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

output_vector

El vector de salida a escalar

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_descale_output() - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
  • fann_scale_input() - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados


Escala la entradas y salidas de los datos de entrenamiento al rango especificado

  • « fann_scale_output
  • fann_scale_train »
  • PHP Manual
  • Funciones de Fann
  • Escala la entradas y salidas de los datos de entrenamiento al rango especificado

fann_scale_train_data

(PECL fann >= 1.0.0)

fann_scale_train_data — Escala la entradas y salidas de los datos de entrenamiento al rango especificado

Descripción

fann_scale_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

Escala la entradas y salidas de los datos de entrenamiento al rango especificado.

Parámetros

train_data

Un resource de datos de entrenamiento de red neuronal.

new_min

El nuevo mínimo después de escalar las entradas y salidas de los datos de entrenamiento.

new_max

El nuevo máximo después de escalar las entradas y salidas de los datos de entrenamiento.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_scale_output_train_data() - Escala las salidas de los datos de entrenamiento al rango especificado
  • fann_scale_input_train_data() - Escala las entradas de los datos de entrenamiento al rango especificado


Escalar datos de entrada y salida basados en parámetros previamente calculados

  • « fann_scale_train_data
  • fann_set_activation_function_hidden »
  • PHP Manual
  • Funciones de Fann
  • Escalar datos de entrada y salida basados en parámetros previamente calculados

fann_scale_train

(PECL fann >= 1.0.0)

fann_scale_train — Escalar datos de entrada y salida basados en parámetros previamente calculados

Descripción

fann_scale_train ( resource $ann , resource $train_data ) : bool

Escalar datos de entrada y salida basados en parámetros previamente calculados.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_descale_train() - Descalar datos de entrada y salida basados en parámetros previamente calculados
  • fann_set_scaling_params() - Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento


Establece la función de activación para todas las capas ocultas

  • « fann_scale_train
  • fann_set_activation_function_layer »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de activación para todas las capas ocultas

fann_set_activation_function_hidden

(PECL fann >= 1.0.0)

fann_set_activation_function_hidden — Establece la función de activación para todas las capas ocultas

Descripción

fann_set_activation_function_hidden ( resource $ann , int $activation_function ) : bool

Establece la función de activación para todas las capas ocultas.

Parámetros

ann

Un resource de red neuronal.

activation_function

La constante de funciones de activación.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas
  • fann_set_activation_function_layer() - Establece la función de activación para todas las neuronas de la capa proporcionada
  • fann_set_activation_function_output() - Establece la función de activación para la capa de salida
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados


Establece la función de activación para todas las neuronas de la capa proporcionada

  • « fann_set_activation_function_hidden
  • fann_set_activation_function_output »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de activación para todas las neuronas de la capa proporcionada

fann_set_activation_function_layer

(PECL fann >= 1.0.0)

fann_set_activation_function_layer — Establece la función de activación para todas las neuronas de la capa proporcionada

Descripción

fann_set_activation_function_layer ( resource $ann , int $activation_function , int $layer ) : bool

Establece la función de activación para todas las neuronas de la capa número layer, contanldo la capa de entrada como capa 0.

No es posible establecer funciones de activación para las neuronas de la capa de entrada.

Parámetros

ann

Un resource de red neuronal.

activation_function

La constante de funciones de activación.

layer

El número de capa.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas
  • fann_set_activation_function_hidden() - Establece la función de activación para todas las capas ocultas
  • fann_set_activation_function_output() - Establece la función de activación para la capa de salida
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados


Establece la función de activación para la capa de salida

  • « fann_set_activation_function_layer
  • fann_set_activation_function »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de activación para la capa de salida

fann_set_activation_function_output

(PECL fann >= 1.0.0)

fann_set_activation_function_output — Establece la función de activación para la capa de salida

Descripción

fann_set_activation_function_output ( resource $ann , int $activation_function ) : bool

Establece la función de activación para la capa de salida.

Parámetros

ann

Un resource de red neuronal.

activation_function

La constante de funciones de activación.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas
  • fann_set_activation_function_layer() - Establece la función de activación para todas las neuronas de la capa proporcionada
  • fann_set_activation_function_hidden() - Establece la función de activación para todas las capas ocultas
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados


Establece la función de activación para la neurona y capa proporcionadas

  • « fann_set_activation_function_output
  • fann_set_activation_steepness_hidden »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de activación para la neurona y capa proporcionadas

fann_set_activation_function

(PECL fann >= 1.0.0)

fann_set_activation_function — Establece la función de activación para la neurona y capa proporcionadas

Descripción

fann_set_activation_function ( resource $ann , int $activation_function , int $layer , int $neuron ) : bool

Establece la función de activación para la neurona número neuron en la capa número layer, contando al capa de entrada como capa 0.

No es posible establecer funciones de activación para las neuronas de la capa de entrada.

Al elegir una función de activación, es importante observar que las funciones de activación tienen un rango diferente. FANN_SIGMOID está, p.ej., en el rango 0 - 1, mientras que FANN_SIGMOID_SYMMETRIC está en el rango -1 - 1, y FANN_LINEAR no tiene límites.

The supplied activation_function value must be one of the activation functions constants.

El valor devuelto es una de las constantes de funciones de activación.

Parámetros

ann

Un resource de red neuronal.

activation_function

La constante de funciones de activación.

layer

El número de capa.

neuron

El número de neurona.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_function_layer() - Establece la función de activación para todas las neuronas de la capa proporcionada
  • fann_set_activation_function_hidden() - Establece la función de activación para todas las capas ocultas
  • fann_set_activation_function_output() - Establece la función de activación para la capa de salida
  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_get_activation_function() - Devuelve la función de activación


Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas

  • « fann_set_activation_function
  • fann_set_activation_steepness_layer »
  • PHP Manual
  • Funciones de Fann
  • Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas

fann_set_activation_steepness_hidden

(PECL fann >= 1.0.0)

fann_set_activation_steepness_hidden — Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas

Descripción

fann_set_activation_steepness_hidden ( resource $ann , float $activation_steepness ) : bool

Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas.

Parámetros

ann

Un resource de red neuronal.

activation_steepness

La pendiente de activación.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_set_activation_steepness_layer() - Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
  • fann_set_activation_steepness_output() - Establece la pendiente de activación de la capa de salida
  • fann_get_activation_steepness() - Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas


Establece la pendiente de activación para todas las neuronas del número de capa proporcionada

  • « fann_set_activation_steepness_hidden
  • fann_set_activation_steepness_output »
  • PHP Manual
  • Funciones de Fann
  • Establece la pendiente de activación para todas las neuronas del número de capa proporcionada

fann_set_activation_steepness_layer

(PECL fann >= 1.0.0)

fann_set_activation_steepness_layer — Establece la pendiente de activación para todas las neuronas del número de capa proporcionada

Descripción

fann_set_activation_steepness_layer ( resource $ann , float $activation_steepness , int $layer ) : bool

Establece la pendiente de activación para todas las neuronas de la capa número layer, contando la capa de entrada como capa 0.

No es posible establecer una pendiente de activación en la capa de entrada.

Parámetros

ann

Un resource de red neuronal.

activation_steepness

La pendiente de activación.

layer

El número de capa.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_set_activation_steepness_hidden() - Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
  • fann_set_activation_steepness_output() - Establece la pendiente de activación de la capa de salida
  • fann_get_activation_steepness() - Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas


Establece la pendiente de activación de la capa de salida

  • « fann_set_activation_steepness_layer
  • fann_set_activation_steepness »
  • PHP Manual
  • Funciones de Fann
  • Establece la pendiente de activación de la capa de salida

fann_set_activation_steepness_output

(PECL fann >= 1.0.0)

fann_set_activation_steepness_output — Establece la pendiente de activación de la capa de salida

Descripción

fann_set_activation_steepness_output ( resource $ann , float $activation_steepness ) : bool

Establece la pendiente de activación de la capa de salida.

Parámetros

ann

Un resource de red neuronal.

activation_steepness

La pendiente de activación.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_steepness() - Establece la pendiente de activación el número de neurona y capa proporcionados
  • fann_set_activation_steepness_layer() - Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
  • fann_set_activation_steepness_hidden() - Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
  • fann_get_activation_steepness() - Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas


Establece la pendiente de activación el número de neurona y capa proporcionados

  • « fann_set_activation_steepness_output
  • fann_set_bit_fail_limit »
  • PHP Manual
  • Funciones de Fann
  • Establece la pendiente de activación el número de neurona y capa proporcionados

fann_set_activation_steepness

(PECL fann >= 1.0.0)

fann_set_activation_steepness — Establece la pendiente de activación el número de neurona y capa proporcionados

Descripción

fann_set_activation_steepness ( resource $ann , float $activation_steepness , int $layer , int $neuron ) : bool

Establece la pendiente de activación en la neurona número neuron de la capa número layer, contando la capa de entrada como capa 0.

No es posible establecer una pendiente de activación en la capa de entrada.

La pendiente de una función de activación dice algo sobre cómo de rápido va la función de activación del mínimo al máximo. Un valor alto para la función de activación proporcionará un entrenamiento más agresivo.

Cuando se entrenan redes neuronales donde los valores de salida deberían estar en los extremos (normalmente 0 y 1, dependiendo de la función de activación), se puede emplear una función de activación (p.ej. 1.0).

La pendiente de activación predeterminada es 0.5.

Parámetros

ann

Un resource de red neuronal.

activation_steepness

La pendiente de activación.

layer

El número de capa.

neuron

El número de neurona.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_activation_steepness_layer() - Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
  • fann_set_activation_steepness_hidden() - Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
  • fann_set_activation_steepness_output() - Establece la pendiente de activación de la capa de salida
  • fann_get_activation_steepness() - Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
  • fann_set_activation_function() - Establece la función de activación para la neurona y capa proporcionadas


Establece el límite de fallo de bit empleado durante un entrenamiento

  • « fann_set_activation_steepness
  • fann_set_callback »
  • PHP Manual
  • Funciones de Fann
  • Establece el límite de fallo de bit empleado durante un entrenamiento

fann_set_bit_fail_limit

(PECL fann >= 1.0.0)

fann_set_bit_fail_limit — Establece el límite de fallo de bit empleado durante un entrenamiento

Descripción

fann_set_bit_fail_limit ( resource $ann , float $bit_fail_limit ) : bool

Establece el límite de fallo de bit empleado durante un entrenamiento.

Parámetros

ann

Un resource de red neuronal.

bit_fail_limit

El límite de fallo de bit.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_bit_fail_limit() - Devuelve el límite de fallo de bit empleado durante un entrenamiento


Establece la función de retrollamada a emplear durante el entrenamiento

  • « fann_set_bit_fail_limit
  • fann_set_cascade_activation_functions »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de retrollamada a emplear durante el entrenamiento

fann_set_callback

(PECL fann >= 1.0.0)

fann_set_callback — Establece la función de retrollamada a emplear durante el entrenamiento

Descripción

fann_set_callback ( resource $ann , collable $callback ) : bool

Establece la función de retrollamada a emplear durante el entrenamiento. Esto significa que es llamada desde fann_train_on_data() o fann_train_on_file().

Parámetros

ann

Un resource de red neuronal.

callback

La función de retrollamada proporcionada toma los siguientes parámetros:

  • ann - El resource de red neuronal
  • train - El resource de datos de entrenamiento o null si se llamada desde fann_train_on_file()
  • max_epochs - El número máximo de épocas que debería continuar el entrenamiento
  • epochs_between_reports - El número de épocas entre llamadas a esta función
  • desired_error - El fann_get_MSE() deseado o fann_get_bit_fail(), dependiendo de la función de parada elegida mediante fann_set_train_stop_function()
  • epochs - La época actual

La retrollamada debería devolver true. Si devuelve false, el entrenamiento finalizará.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_train_on_file() - Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo


Establece el array de funciones de activación de candidatas en cascada

  • « fann_set_callback
  • fann_set_cascade_activation_steepnesses »
  • PHP Manual
  • Funciones de Fann
  • Establece el array de funciones de activación de candidatas en cascada

fann_set_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_set_cascade_activation_functions — Establece el array de funciones de activación de candidatas en cascada

Descripción

fann_set_cascade_activation_functions ( resource $ann , array $cascade_activation_functions ) : bool

Establece el array de funciones de activación de candidatas en cascada.

Véase fann_get_cascade_num_candidates() para una descripción de las neuronas candidatas generadas por este array.

Parámetros

ann

Un resource de red neuronal.

cascade_activation_functions

El array de funciones de activación de candidatas en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_activation_functions_count() - Devuelve el número de funciones de activación en cascada
  • fann_set_cascade_activation_functions()


Establece el array de pendientes de activación de candidatas en cascada

  • « fann_set_cascade_activation_functions
  • fann_set_cascade_candidate_change_fraction »
  • PHP Manual
  • Funciones de Fann
  • Establece el array de pendientes de activación de candidatas en cascada

fann_set_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_set_cascade_activation_steepnesses — Establece el array de pendientes de activación de candidatas en cascada

Descripción

fann_set_cascade_activation_steepnesses ( resource $ann , array $cascade_activation_steepnesses_count ) : bool

Establece el array de pendientes de activación de candidatas en cascada.

Véase fann_get_cascade_num_candidates() para una descripción de las neuronas candidatas generadas por este array.

Parámetros

ann

Un resource de red neuronal.

cascade_activation_steepnesses_count

El array de pendientes de activación de candidatas en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_activation_steepnesses() - Devuelve las pendientes de activación en cascada
  • fann_get_cascade_activation_steepnesses_count() - El número de pendientes de activación


Establece la fracción de cambio de candidatas en cascada

  • « fann_set_cascade_activation_steepnesses
  • fann_set_cascade_candidate_limit »
  • PHP Manual
  • Funciones de Fann
  • Establece la fracción de cambio de candidatas en cascada

fann_set_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_change_fraction — Establece la fracción de cambio de candidatas en cascada

Descripción

fann_set_cascade_candidate_change_fraction ( resource $ann , float $cascade_candidate_change_fraction ) : bool

Establece la fracción de cambio de candidatas en cascada.

Parámetros

ann

Un resource de red neuronal.

cascade_candidate_change_fraction

La fracción de cambio de candidatas en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_candidate_change_fraction() - Devuelve la fracción de cambio de candidatas en cascada


Establece el límite de candidatas

  • « fann_set_cascade_candidate_change_fraction
  • fann_set_cascade_candidate_stagnation_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece el límite de candidatas

fann_set_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_limit — Establece el límite de candidatas

Descripción

fann_set_cascade_candidate_limit ( resource $ann , float $cascade_candidate_limit ) : bool

Establece el límite de candidatas.

Parámetros

ann

Un resource de red neuronal.

cascade_candidate_limit

El límite de candidatas.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_candidate_limit() - Devuelve el límite de candidatas


Establece el número de épocas de estancamiento de candidatas en cascada

  • « fann_set_cascade_candidate_limit
  • fann_set_cascade_max_cand_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece el número de épocas de estancamiento de candidatas en cascada

fann_set_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_stagnation_epochs — Establece el número de épocas de estancamiento de candidatas en cascada

Descripción

fann_set_cascade_candidate_stagnation_epochs ( resource $ann , int $cascade_candidate_stagnation_epochs ) : bool

Establece el número de épocas de estancamiento de candidatas en cascada.

Parámetros

ann

Un resource de red neuronal.

cascade_candidate_stagnation_epochs

El número de épocas de estancamiento de candidatas en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_candidate_stagnation_epochs() - Devuelve el número de épocas de estancamiento de candidatas en cascada


Establece el máximo de épocas de candidatas

  • « fann_set_cascade_candidate_stagnation_epochs
  • fann_set_cascade_max_out_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece el máximo de épocas de candidatas

fann_set_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_cand_epochs — Establece el máximo de épocas de candidatas

Descripción

fann_set_cascade_max_cand_epochs ( resource $ann , int $cascade_max_cand_epochs ) : bool

Establece el máximo de épocas de candidatas.

Parámetros

ann

Un resource de red neuronal.

cascade_max_cand_epochs

El máximo de épocas de candidatas.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_max_cand_epochs() - Devuelve el máximo de épocas de candidatas


Establece el máximo de épocas de salida

  • « fann_set_cascade_max_cand_epochs
  • fann_set_cascade_min_cand_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece el máximo de épocas de salida

fann_set_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_out_epochs — Establece el máximo de épocas de salida

Descripción

fann_set_cascade_max_out_epochs ( resource $ann , int $cascade_max_out_epochs ) : bool

Establece el máximo de épocas de salida.

Parámetros

ann

Un resource de red neuronal.

cascade_max_out_epochs

El máximo de épocas de salida.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_max_out_epochs() - Devuelve el máximo de épocas de salida


Establece el mínimo de épocas de candidatas

  • « fann_set_cascade_max_out_epochs
  • fann_set_cascade_min_out_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece el mínimo de épocas de candidatas

fann_set_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_cand_epochs — Establece el mínimo de épocas de candidatas

Descripción

fann_set_cascade_min_cand_epochs ( resource $ann , int $cascade_min_cand_epochs ) : bool

Establece el mínimo de épocas de candidatas.

Parámetros

ann

Un resource de red neuronal.

cascade_min_cand_epochs

El máximo de mínimo de candidatas.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_min_cand_epochs() - Devuelve el mínimo de épocas de candidatas


Establece el mínimo de épocas de salida

  • « fann_set_cascade_min_cand_epochs
  • fann_set_cascade_num_candidate_groups »
  • PHP Manual
  • Funciones de Fann
  • Establece el mínimo de épocas de salida

fann_set_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_out_epochs — Establece el mínimo de épocas de salida

Descripción

fann_set_cascade_min_out_epochs ( resource $ann , int $cascade_min_out_epochs ) : bool

Establece el mínimo de épocas de salida.

Parámetros

ann

Un resource de red neuronal.

cascade_min_out_epochs

El mínimo de épocas de salida.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_min_out_epochs() - Devuelve el mínimo de épocas de salida


Establece el número de grupos de candidatas

  • « fann_set_cascade_min_out_epochs
  • fann_set_cascade_output_change_fraction »
  • PHP Manual
  • Funciones de Fann
  • Establece el número de grupos de candidatas

fann_set_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_set_cascade_num_candidate_groups — Establece el número de grupos de candidatas

Descripción

fann_set_cascade_num_candidate_groups ( resource $ann , int $cascade_num_candidate_groups ) : bool

Establece el número de grupos de candidatas.

Parámetros

ann

Un resource de red neuronal.

cascade_num_candidate_groups

El número de grupos de candidatas.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_num_candidate_groups() - Devuelve el número de grupos de candidatas


Establece la fracción de cambio de salida en cascada

  • « fann_set_cascade_num_candidate_groups
  • fann_set_cascade_output_stagnation_epochs »
  • PHP Manual
  • Funciones de Fann
  • Establece la fracción de cambio de salida en cascada

fann_set_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_output_change_fraction — Establece la fracción de cambio de salida en cascada

Descripción

fann_set_cascade_output_change_fraction ( resource $ann , float $cascade_output_change_fraction ) : bool

Establece la fracción de cambio de salida en cascada.

Parámetros

ann

Un resource de red neuronal.

cascade_output_change_fraction

La fracción de cambio de salida en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_output_change_fraction() - Devuelve la fracción de cambio de salida en cascada


Establece el número de épocas de estancamiento de salida en cascada

  • « fann_set_cascade_output_change_fraction
  • fann_set_cascade_weight_multiplier »
  • PHP Manual
  • Funciones de Fann
  • Establece el número de épocas de estancamiento de salida en cascada

fann_set_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_output_stagnation_epochs — Establece el número de épocas de estancamiento de salida en cascada

Descripción

fann_set_cascade_output_stagnation_epochs ( resource $ann , int $cascade_output_stagnation_epochs ) : bool

Establece el número de épocas de estancamiento de salida en cascada.

Parámetros

ann

Un resource de red neuronal.

cascade_output_stagnation_epochs

El número de épocas de estancamiento de salida en cascada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_output_stagnation_epochs() - Devuelve el número de épocas de estancamiento de salida en cascada


Establece el multiplicador de peso

  • « fann_set_cascade_output_stagnation_epochs
  • fann_set_error_log »
  • PHP Manual
  • Funciones de Fann
  • Establece el multiplicador de peso

fann_set_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_set_cascade_weight_multiplier — Establece el multiplicador de peso

Descripción

fann_set_cascade_weight_multiplier ( resource $ann , float $cascade_weight_multiplier ) : bool

Establece el multiplicador de peso.

Parámetros

ann

Un resource de red neuronal.

cascade_weight_multiplier

El multiplicador de peso.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_cascade_weight_multiplier() - Devuelve el multiplicador de peso


Establece dónde registrar los errores

  • « fann_set_cascade_weight_multiplier
  • fann_set_input_scaling_params »
  • PHP Manual
  • Funciones de Fann
  • Establece dónde registrar los errores

fann_set_error_log

(PECL fann >= 1.0.0)

fann_set_error_log — Establece dónde registrar los errores

Descripción

fann_set_error_log ( resource $errdat , string $log_file ) : void

Establece dónde registrar los errores.

Parámetros

errdat

Un resource de red neuronal o un resource de datos de entrenamiento de red neuronal.

log_file

La ruta al fichero de registro.

Valores devueltos

No se devuelve ningún valor.


Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento

  • « fann_set_error_log
  • fann_set_learning_momentum »
  • PHP Manual
  • Funciones de Fann
  • Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento

fann_set_input_scaling_params

(PECL fann >= 1.0.0)

fann_set_input_scaling_params — Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento

Descripción

fann_set_input_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max ) : bool

Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

new_input_min

El límite inferior deseado de los datos de entrada después de escalar (no seguido estrictamente)

new_input_max

El límite superior deseado de los datos de entrada después de escalar (no seguido estrictamente)

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_output_scaling_params() - Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento


Establece el momento del aprendizaje

  • « fann_set_input_scaling_params
  • fann_set_learning_rate »
  • PHP Manual
  • Funciones de Fann
  • Establece el momento del aprendizaje

fann_set_learning_momentum

(PECL fann >= 1.0.0)

fann_set_learning_momentum — Establece el momento del aprendizaje

Descripción

fann_set_learning_momentum ( resource $ann , float $learning_momentum ) : bool

Establece el momento del aprendizaje.

Hay más información disponible en fann_get_learning_momentum().

Parámetros

ann

Un resource de red neuronal.

learning_momentum

El momento del aprendizaje

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_learning_momentum() - Devuelve el momento del aprendizaje
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Establece el índice de aprendizaje

  • « fann_set_learning_momentum
  • fann_set_output_scaling_params »
  • PHP Manual
  • Funciones de Fann
  • Establece el índice de aprendizaje

fann_set_learning_rate

(PECL fann >= 1.0.0)

fann_set_learning_rate — Establece el índice de aprendizaje

Descripción

fann_set_learning_rate ( resource $ann , float $learning_rate ) : bool

Establece el índice de aprendizaje.

Hay más información en fann_get_learning_rate().

Parámetros

ann

Un resource de red neuronal.

learning_rate

El índice de aprendizaje.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_learning_rate() - Devuelve el índice de aprendizaje
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento

  • « fann_set_learning_rate
  • fann_set_quickprop_decay »
  • PHP Manual
  • Funciones de Fann
  • Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento

fann_set_output_scaling_params

(PECL fann >= 1.0.0)

fann_set_output_scaling_params — Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento

Descripción

fann_set_output_scaling_params ( resource $ann , resource $train_data , float $new_output_min , float $new_output_max ) : bool

Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

new_output_min

El límite inferior deseado de los datos de salida después de escalar (no seguido estrictamente)

new_output_max

El límite superior deseado de los datos de salida después de escalar (no seguido estrictamente)

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_input_scaling_params() - Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento


Establece el factor de decadencia de quickprop

  • « fann_set_output_scaling_params
  • fann_set_quickprop_mu »
  • PHP Manual
  • Funciones de Fann
  • Establece el factor de decadencia de quickprop

fann_set_quickprop_decay

(PECL fann >= 1.0.0)

fann_set_quickprop_decay — Establece el factor de decadencia de quickprop

Descripción

fann_set_quickprop_decay ( resource $ann , float $quickprop_decay ) : bool

Establece el factor de decadencia de quickprop.

Parámetros

ann

Un resource de red neuronal.

quickprop_decay

El factor de decadencia de quickprop.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_quickprop_decay() - Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop


Establece el factor mu de quickprop

  • « fann_set_quickprop_decay
  • fann_set_rprop_decrease_factor »
  • PHP Manual
  • Funciones de Fann
  • Establece el factor mu de quickprop

fann_set_quickprop_mu

(PECL fann >= 1.0.0)

fann_set_quickprop_mu — Establece el factor mu de quickprop

Descripción

fann_set_quickprop_mu ( resource $ann , float $quickprop_mu ) : bool

Establece el factor mu de quickprop.

Parámetros

ann

Un resource de red neuronal.

quickprop_mu

El factor mu.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_quickprop_mu() - Devuelve el factor mu


Establece el factor de disminución empleado durante un entrenamiento RPROP

  • « fann_set_quickprop_mu
  • fann_set_rprop_delta_max »
  • PHP Manual
  • Funciones de Fann
  • Establece el factor de disminución empleado durante un entrenamiento RPROP

fann_set_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_set_rprop_decrease_factor — Establece el factor de disminución empleado durante un entrenamiento RPROP

Descripción

fann_set_rprop_decrease_factor ( resource $ann , float $rprop_decrease_factor ) : bool

Establece el factor de disminución empleado durante un entrenamiento RPROP.

Parámetros

ann

Un resource de red neuronal.

rprop_decrease_factor

El factor de disminución.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_rprop_decrease_factor() - Devuelve el factor de disminución empleado durante un entrenamiento RPROP


Establece el tamaño de paso máximo

  • « fann_set_rprop_decrease_factor
  • fann_set_rprop_delta_min »
  • PHP Manual
  • Funciones de Fann
  • Establece el tamaño de paso máximo

fann_set_rprop_delta_max

(PECL fann >= 1.0.0)

fann_set_rprop_delta_max — Establece el tamaño de paso máximo

Descripción

fann_set_rprop_delta_max ( resource $ann , float $rprop_delta_max ) : bool

El tamaño de paso máximo es un número positivo que determina lo grande que podría ser el tamaño de paso máximo.

Parámetros

ann

Un resource de red neuronal.

rprop_delta_max

El tamaño de paso máximo.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_rprop_delta_max() - Devuelve el tamaño de paso máximo
  • fann_get_rprop_delta_min() - Devuelve el tamaño de paso mínimo


Establece el tamaño de paso mínimo

  • « fann_set_rprop_delta_max
  • fann_set_rprop_delta_zero »
  • PHP Manual
  • Funciones de Fann
  • Establece el tamaño de paso mínimo

fann_set_rprop_delta_min

(PECL fann >= 1.0.0)

fann_set_rprop_delta_min — Establece el tamaño de paso mínimo

Descripción

fann_set_rprop_delta_min ( resource $ann , float $rprop_delta_min ) : bool

El tamaño de paso mínimo es un número positivo pequeño que determina lo pequeño que podría ser el tamaño de paso mínimo.

Parámetros

ann

Un resource de red neuronal.

rprop_delta_min

El tamaño de paso mínimo.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_rprop_delta_min() - Devuelve el tamaño de paso mínimo


Establece el tamaño de paso inicial

  • « fann_set_rprop_delta_min
  • fann_set_rprop_increase_factor »
  • PHP Manual
  • Funciones de Fann
  • Establece el tamaño de paso inicial

fann_set_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_set_rprop_delta_zero — Establece el tamaño de paso inicial

Descripción

fann_set_rprop_delta_zero ( resource $ann , float $rprop_delta_zero ) : bool

El tamaño de paso inicial es un número positivo que determina el tamaño de paso inicial.

Parámetros

ann

Un resource de red neuronal.

rprop_delta_zero

El tamaño de paso inicial.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_rprop_delta_zero() - Devuelve el tamaño de paso inicial
  • fann_get_rprop_delta_min() - Devuelve el tamaño de paso mínimo
  • fann_get_rprop_delta_max() - Devuelve el tamaño de paso máximo


Establece el factor de aumento empleado durante un entrenamiento RPROP

  • « fann_set_rprop_delta_zero
  • fann_set_sarprop_step_error_shift »
  • PHP Manual
  • Funciones de Fann
  • Establece el factor de aumento empleado durante un entrenamiento RPROP

fann_set_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_set_rprop_increase_factor — Establece el factor de aumento empleado durante un entrenamiento RPROP

Descripción

fann_set_rprop_increase_factor ( resource $ann , float $rprop_increase_factor ) : bool

Establece el factor de aumento empleado durante un entrenamiento RPROP.

Parámetros

ann

Un resource de red neuronal.

rprop_increase_factor

El aumento de disminución.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_rprop_increase_factor() - Devuelve el factor de aumento empleado durante un entrenamiento RPROP


Establece el desplazamiento del error de paso de sarprop

  • « fann_set_rprop_increase_factor
  • fann_set_sarprop_step_error_threshold_factor »
  • PHP Manual
  • Funciones de Fann
  • Establece el desplazamiento del error de paso de sarprop

fann_set_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_shift — Establece el desplazamiento del error de paso de sarprop

Descripción

fann_set_sarprop_step_error_shift ( resource $ann , float $sarprop_step_error_shift ) : bool

Establece el desplazamiento del error de paso de sarprop.

Parámetros

ann

Un resource de red neuronal.

sarprop_step_error_shift

El desplazamiento del error de paso de sarprop.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_sarprop_step_error_shift() - Devuelve el desplazamiento del error de paso de sarprop


Establece el factor de umbral del error de paso de sarprop

  • « fann_set_sarprop_step_error_shift
  • fann_set_sarprop_temperature »
  • PHP Manual
  • Funciones de Fann
  • Establece el factor de umbral del error de paso de sarprop

fann_set_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_threshold_factor — Establece el factor de umbral del error de paso de sarprop

Descripción

fann_set_sarprop_step_error_threshold_factor ( resource $ann , float $sarprop_step_error_threshold_factor ) : bool

Establece el factor de umbral del error de paso de sarprop.

Parámetros

ann

Un resource de red neuronal.

sarprop_step_error_threshold_factor

El factor de umbral del error de paso de sarprop.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_sarprop_step_error_threshold_factor() - Devuelve el factor de umbral del error de paso de sarprop


Establece la temperatura de sarprop

  • « fann_set_sarprop_step_error_threshold_factor
  • fann_set_sarprop_weight_decay_shift »
  • PHP Manual
  • Funciones de Fann
  • Establece la temperatura de sarprop

fann_set_sarprop_temperature

(PECL fann >= 1.0.0)

fann_set_sarprop_temperature — Establece la temperatura de sarprop

Descripción

fann_set_sarprop_temperature ( resource $ann , float $sarprop_temperature ) : bool

Establece la temperatura de sarprop.

Parámetros

ann

Un resource de red neuronal.

sarprop_temperature

La temperatura de sarprop.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_sarprop_temperature() - Devuelve la temperatura de sarprop


Establece el desplazamiento de decadencia del peso de sarprop

  • « fann_set_sarprop_temperature
  • fann_set_scaling_params »
  • PHP Manual
  • Funciones de Fann
  • Establece el desplazamiento de decadencia del peso de sarprop

fann_set_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_weight_decay_shift — Establece el desplazamiento de decadencia del peso de sarprop

Descripción

fann_set_sarprop_weight_decay_shift ( resource $ann , float $sarprop_weight_decay_shift ) : bool

Establece el desplazamiento de decadencia del peso de sarprop.

Parámetros

ann

Un resource de red neuronal.

sarprop_weight_decay_shift

El desplazamiento de decadencia del peso de sarprop.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_sarprop_weight_decay_shift() - Devuelve el desplazamiento de decadencia del peso de sarprop


Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento

  • « fann_set_sarprop_weight_decay_shift
  • fann_set_train_error_function »
  • PHP Manual
  • Funciones de Fann
  • Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento

fann_set_scaling_params

(PECL fann >= 1.0.0)

fann_set_scaling_params — Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento

Descripción

fann_set_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max , float $new_output_min , float $new_output_max ) : bool

Calcular los parámetros de escala de entradas y salidas para un uso futuro basados en datos de entrenamiento.

Parámetros

ann

Un resource de red neuronal.

train_data

Un resource de datos de entrenamiento de red neuronal.

new_input_min

El límite inferior deseado de los datos de entrada después de escalar (no seguido estrictamente)

new_input_max

El límite superior deseado de los datos de entrada después de escalar (no seguido estrictamente)

new_output_min

El límite inferior deseado de los datos de salida después de escalar (no seguido estrictamente)

new_output_max

El límite superior deseado de los datos de salida después de escalar (no seguido estrictamente)

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_set_input_scaling_params() - Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento
  • fann_set_output_scaling_params() - Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento


Establecer la función de error empleada durante un entrenamiento

  • « fann_set_scaling_params
  • fann_set_train_stop_function »
  • PHP Manual
  • Funciones de Fann
  • Establecer la función de error empleada durante un entrenamiento

fann_set_train_error_function

(PECL fann >= 1.0.0)

fann_set_train_error_function — Establecer la función de error empleada durante un entrenamiento

Descripción

fann_set_train_error_function ( resource $ann , int $error_function ) : bool

Establecer la función de error empleada durante un entrenamiento.

Las funciones de error están descritas en las constantes de funciones de error.

Parámetros

ann

Un resource de red neuronal.

error_function

La constante de función de error .

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_train_error_function() - Devuelve la función de error empleada durante un entrenamiento


Establece la función de parada empleada durante el entrenamiento

  • « fann_set_train_error_function
  • fann_set_training_algorithm »
  • PHP Manual
  • Funciones de Fann
  • Establece la función de parada empleada durante el entrenamiento

fann_set_train_stop_function

(PECL fann >= 1.0.0)

fann_set_train_stop_function — Establece la función de parada empleada durante el entrenamiento

Descripción

fann_set_train_stop_function ( resource $ann , int $stop_function ) : bool

Establece la función de parada empleada durante el entrenamiento.

Las funciones de parada están descritas en las constantes de funciones de parada.

Parámetros

ann

Un resource de red neuronal.

stop_function

La constante de función de parada.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_train_stop_function() - Devuelve la función de parada empleada durante el entrenamiento


Establece el algoritmo de entrenamiento

  • « fann_set_train_stop_function
  • fann_set_weight_array »
  • PHP Manual
  • Funciones de Fann
  • Establece el algoritmo de entrenamiento

fann_set_training_algorithm

(PECL fann >= 1.0.0)

fann_set_training_algorithm — Establece el algoritmo de entrenamiento

Descripción

fann_set_training_algorithm ( resource $ann , int $training_algorithm ) : bool

Establece el algoritmo de entrenamiento.

Hay más información disponible en fann_get_training_algorithm().

Parámetros

ann

Un resource de red neuronal.

training_algorithm

La constante de Algoritno de entrenamiento.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_get_training_algorithm() - Devuelve el algoritmo de entrenamiento


Establecer las conexiones de la red

  • « fann_set_training_algorithm
  • fann_set_weight »
  • PHP Manual
  • Funciones de Fann
  • Establecer las conexiones de la red

fann_set_weight_array

(PECL fann >= 1.0.0)

fann_set_weight_array — Establecer las conexiones de la red

Descripción

fann_set_weight_array ( resource $ann , array $connections ) : bool

Establecer las conexiones de la red.

Solamente se pueden cambiar los pesos. Las conexiones y los pesos se ignoran si no existen en la red.

Parámetros

ann

Un resource de red neuronal.

connections

Un array de objetos FANNConnection

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Establecer una conexión de la red

  • « fann_set_weight_array
  • fann_shuffle_train_data »
  • PHP Manual
  • Funciones de Fann
  • Establecer una conexión de la red

fann_set_weight

(PECL fann >= 1.0.0)

fann_set_weight — Establecer una conexión de la red

Descripción

fann_set_weight ( resource $ann , int $from_neuron , int $to_neuron , float $weight ) : bool

Establecer una conexión de la red.

Parámetros

ann

Un resource de red neuronal.

from_neuron

La neurona donde empiza la conexión.

to_neuron

La neurona donde finaliza la conexión.

weight

El peso de la conexión.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Mezcla los datos de entrenamiento, aleatorizando el orden

  • « fann_set_weight
  • fann_subset_train_data »
  • PHP Manual
  • Funciones de Fann
  • Mezcla los datos de entrenamiento, aleatorizando el orden

fann_shuffle_train_data

(PECL fann >= 1.0.0)

fann_shuffle_train_data — Mezcla los datos de entrenamiento, aleatorizando el orden

Descripción

fann_shuffle_train_data ( resource $train_data ) : bool

Mezcla los datos de entrenamiento, aleatorizando el orden. Es lo recomendado para entrenamientos incrementales, mientras que no tiene influencia durante entrenamientos por lotes.

Parámetros

train_data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


Devuelve una copia de un subconjunto de los datos de entrenamiento

  • « fann_shuffle_train_data
  • fann_test_data »
  • PHP Manual
  • Funciones de Fann
  • Devuelve una copia de un subconjunto de los datos de entrenamiento

fann_subset_train_data

(PECL fann >= 1.0.0)

fann_subset_train_data — Devuelve una copia de un subconjunto de los datos de entrenamiento

Descripción

fann_subset_train_data ( resource $data , int $pos , int $length ) : resource

Devuelve una copia de un subconjunto del resource de datos de entrenamiento, empezando en la posición pos y con length elementos hacia adelante.

fann_subset_train_data(train_data, 0, fann_length_train_data(train_data)) hace lo mismo que fann_duplicate_train_data()

Parámetros

data

Un resource de datos de entrenamiento de red neuronal.

pos

La posición de inicio.

length

El número de elementos a copiar.

Valores devueltos

Devuelve un resource de datos de entrenamiento en caso de éxito, o false en caso de error.

Ver también

  • fann_duplicate_train_data() - Devuelve una copia exacta de uno datos de entrenamiento de fann


Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos

  • « fann_subset_train_data
  • fann_test »
  • PHP Manual
  • Funciones de Fann
  • Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos

fann_test_data

(PECL fann >= 1.0.0)

fann_test_data — Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos

Descripción

fann_test_data ( resource $ann , resource $data ) : float

Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos.

Esta función actualiza el ECM y los valores de fallo de bit.

Parámetros

ann

Un resource de red neuronal.

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El ECM actualizado, o false en caso de error.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_train_epoch() - Entrenar una época con un conjunto de datos de entrenamiento
  • fann_get_bit_fail() - El número de bit fallidos
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Probar con un conjunto de entradas, y un conjunto de salidas deseadas

  • « fann_test_data
  • fann_train_epoch »
  • PHP Manual
  • Funciones de Fann
  • Probar con un conjunto de entradas, y un conjunto de salidas deseadas

fann_test

(PECL fann >= 1.0.0)

fann_test — Probar con un conjunto de entradas, y un conjunto de salidas deseadas

Descripción

fann_test ( resource $ann , array $input , array $desired_output ) : bool

Probar con un conjunto de entradas, y un conjunto de salidas deseadas. Esta operación actualiza el error cuadrático medio, aunque no cambia la red de ninguna manera.

Parámetros

ann

Un resource de red neuronal.

input

Un array de entradas. Este array debe ser exactamente de fann_get_num_input() de longitud.

desired_output

Un array de salidas deseadas. Este array debe ser exactamente de fann_get_num_output() de longitud.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_test_data() - Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
  • fann_train() - Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas
  • fann_get_num_input() - Obtener el número de neuronas de entrada
  • fann_get_num_output() - Obtener el número de neuronas de salida


Entrenar una época con un conjunto de datos de entrenamiento

  • « fann_test
  • fann_train_on_data »
  • PHP Manual
  • Funciones de Fann
  • Entrenar una época con un conjunto de datos de entrenamiento

fann_train_epoch

(PECL fann >= 1.0.0)

fann_train_epoch — Entrenar una época con un conjunto de datos de entrenamiento

Descripción

fann_train_epoch ( resource $ann , resource $data ) : float

Entrena una época con los datos de entrenamiento almacenados en data. Una época es donde todos los datos de entrenamiento son considerados exactamente una vez.

Esta función devuelve el ECM tal como es calculado antes o durante el entrenamiento real. No es el ECM real después de la época de entrenamiento, ya que calcularlo requerirá atravesar el conjunto de entrenamiento completo una vez más. El empleo de este valor durante el entrenamiento es más que adecuado.

El algoritmo de entrenaiento empleado por esta función se elige mediante la función fann_set_training_algorithm().

Parámetros

ann

Un resource de red neuronal.

data

Un resource de datos de entrenamiento de red neuronal.

Valores devueltos

El ECM, o false en caso de error.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_test_data() - Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento


Entrena un conjunto de datos completo por un período de tiempo

  • « fann_train_epoch
  • fann_train_on_file »
  • PHP Manual
  • Funciones de Fann
  • Entrena un conjunto de datos completo por un período de tiempo

fann_train_on_data

(PECL fann >= 1.0.0)

fann_train_on_data — Entrena un conjunto de datos completo por un período de tiempo

Descripción

fann_train_on_data ( resource $ann , resource $data , int $max_epochs , int $epochs_between_reports , float $desired_error ) : bool

Entrena un conjunto de datos completo por un período de tiempo.

Este entrenamiento emplea el algoritmo de entrenamiento elegido mediante fann_set_training_algorithm() y los parámetros establecidos para estos algoritmos de entrenamiento.

Parámetros

ann

Un resource de red neuronal.

data

Un resource de datos de entrenamiento de red neuronal.

max_epochs

El número máximo de épocas que debería continuar el entrenamiento.

epochs_between_reports

El número de épocas entre llamadas a funciones de retrollamada. Un valor de cero significa que no se llamará a la función del usuario.

desired_error

El fann_get_MSE() o fann_get_bit_fail() deseados, dependiendo de la función de parada elegida mediante fann_set_train_stop_function().

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_file() - Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo
  • fann_train_epoch() - Entrenar una época con un conjunto de datos de entrenamiento
  • fann_get_bit_fail() - El número de bit fallidos
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_set_train_stop_function() - Establece la función de parada empleada durante el entrenamiento
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento
  • fann_set_callback() - Establece la función de retrollamada a emplear durante el entrenamiento


Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo

  • « fann_train_on_data
  • fann_train »
  • PHP Manual
  • Funciones de Fann
  • Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo

fann_train_on_file

(PECL fann >= 1.0.0)

fann_train_on_file — Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo

Descripción

fann_train_on_file ( resource $ann , string $filename , int $max_epochs , int $epochs_between_reports , float $desired_error ) : bool

Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo.

Este entrenamiento emplea el algoritmo de entrenamiento elegido mediante fann_set_training_algorithm() y los parámetros establecidos para estos algoritmos de entrenamiento.

Parámetros

ann

Un resource de red neuronal.

filename

El fichero que contiene los datos de entrenamiento.

max_epochs

El número máximo de épocas que debería continuar el entrenamiento.

epochs_between_reports

El número de épocas entre llamadas a funciones de retrollamada. Un valor de cero significa que no se llamará a la función del usuario.

desired_error

El fann_get_MSE() o fann_get_bit_fail() deseados, dependiendo de la función de parada elegida mediante fann_set_train_stop_function().

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_train_epoch() - Entrenar una época con un conjunto de datos de entrenamiento
  • fann_get_bit_fail() - El número de bit fallidos
  • fann_get_MSE() - Lee el error cuadrático medio de la red
  • fann_set_train_stop_function() - Establece la función de parada empleada durante el entrenamiento
  • fann_set_training_algorithm() - Establece el algoritmo de entrenamiento
  • fann_set_callback() - Establece la función de retrollamada a emplear durante el entrenamiento


Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas

  • « fann_train_on_file
  • FANNConnection »
  • PHP Manual
  • Funciones de Fann
  • Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas

fann_train

(PECL fann >= 1.0.0)

fann_train — Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas

Descripción

fann_train ( resource $ann , array $input , array $desired_output ) : bool

Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas. Este entrenamiento siempre es incremental, ya que solamente está presente un patrón.

Parámetros

ann

Un resource de red neuronal.

input

Un array de entradas. Este array debe ser exactamente de fann_get_num_input() de longitud.

desired_output

Un array de salidas deseadas. Este array debe ser exactamente de fann_get_num_output() de longitud.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.

Ver también

  • fann_train_on_data() - Entrena un conjunto de datos completo por un período de tiempo
  • fann_train_epoch() - Entrenar una época con un conjunto de datos de entrenamiento
  • fann_get_num_input() - Obtener el número de neuronas de entrada
  • fann_get_num_output() - Obtener el número de neuronas de salida


La clase FANNConnection

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

FANNConnection se emplea para la conexión de redes neuronales. Los objetos de esta clase se emplean en fann_get_connection_array() y fann_set_weight_array().

Sinopsis de la Clase

FANNConnection {
/* Propiedades */
public $from_neuron ;
public $to_neuron ;
public $weight ;
/* Métodos */
public __construct ( int $from_neuron , int $to_neuron , float $weight )
public getFromNeuron ( ) : int
public getToNeuron ( ) : int
public getWeight ( ) : void
public setWeight ( float $weight ) : bool
}

Propiedades

from_neuron

La neurona donde empieza la conexión.

to_neuron

La neurona donde finaliza la conexión.

weight

El peso de la conexión.

Tabla de contenidos

  • FANNConnection::__construct — El constructor de la conexión
  • FANNConnection::getFromNeuron — Devuelve las posiciones de la neurona inicial
  • FANNConnection::getToNeuron — Devuelve las posiciones de la neurona terminal
  • FANNConnection::getWeight — Devuelve el peso de la conexión
  • FANNConnection::setWeight — Establece el peso de la conexión


El constructor de la conexión

  • « FANNConnection
  • FANNConnection::getFromNeuron »
  • PHP Manual
  • FANNConnection
  • El constructor de la conexión

FANNConnection::__construct

(PECL fann >= 1.0.0)

FANNConnection::__construct — El constructor de la conexión

Descripción

public FANNConnection::__construct ( int $from_neuron , int $to_neuron , float $weight )

Crea una nueva conexión e inicializa sus parámetros. Después de crear la conexión, solamente se puede cambiar el peso.

Parámetros

from_neuron

El número de posición de la neurona inicial.

to_neuron

El número de posición de la neurona terminal.

weight

El valor del peso de la conexión.


Devuelve las posiciones de la neurona inicial

  • « FANNConnection::__construct
  • FANNConnection::getToNeuron »
  • PHP Manual
  • FANNConnection
  • Devuelve las posiciones de la neurona inicial

FANNConnection::getFromNeuron

(PECL fann >= 1.0.0)

FANNConnection::getFromNeuron — Devuelve las posiciones de la neurona inicial

Descripción

public FANNConnection::getFromNeuron ( ) : int

Devuelve las posiciones de la neurona inicial.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Las posiciones de la neurona inicial.


Devuelve las posiciones de la neurona terminal

  • « FANNConnection::getFromNeuron
  • FANNConnection::getWeight »
  • PHP Manual
  • FANNConnection
  • Devuelve las posiciones de la neurona terminal

FANNConnection::getToNeuron

(PECL fann >= 1.0.0)

FANNConnection::getToNeuron — Devuelve las posiciones de la neurona terminal

Descripción

public FANNConnection::getToNeuron ( ) : int

Devuelve las posiciones de la neurona terminal.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Las posiciones de la neurona terminal.


Devuelve el peso de la conexión

  • « FANNConnection::getToNeuron
  • FANNConnection::setWeight »
  • PHP Manual
  • FANNConnection
  • Devuelve el peso de la conexión

FANNConnection::getWeight

(PECL fann >= 1.0.0)

FANNConnection::getWeight — Devuelve el peso de la conexión

Descripción

public FANNConnection::getWeight ( ) : void

Devuelve el peso de la conexión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El peso de la conexión.


Establece el peso de la conexión

  • « FANNConnection::getWeight
  • JSON »
  • PHP Manual
  • FANNConnection
  • Establece el peso de la conexión

FANNConnection::setWeight

(PECL fann >= 1.0.0)

FANNConnection::setWeight — Establece el peso de la conexión

Descripción

public FANNConnection::setWeight ( float $weight ) : bool

Establece el peso de la conexión.

Este método es diferente de fann_set_weight(). No actualiza el valor del peso de la red. El valor de la red se actualiza solamente después de llamar a fann_set_weight_array().

Parámetros

weight

El peso de la conexión.

Valores devueltos

Devuelve true en caso de éxito, o false de lo contrario.


JavaScript Object Notation

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • JsonSerializable — La interfaz JsonSerializable
    • JsonSerializable::jsonSerialize — Especifica los datos que deberían serializarse para JSON
  • Funciones de JSON
    • json_decode — Decodifica un string de JSON
    • json_encode — Retorna la representación JSON del valor dado
    • json_last_error_msg — Devuelve el string con el error de la última llamada a json_encode() o a json_decode()
    • json_last_error — Devuelve el último error ocurrido


Introducción

Esta extensión implementa el formato de intercambio de datos » JavaScript Object Notation (JSON) La decodificación se realiza mediante el análisis sintáctico basado en la implementación de JSON_checker por Douglas Crockford.

Nota:

PHP implementa un superconjunto de JSON tal como se especifica en la » RFC 7159 original.


Instalación

A partir de PHP 5.2.0, la extensión JSON se compila e incluye en PHP por defecto.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/json


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las siguientes constantes indican el tipo de error retornado por json_last_error().

JSON_ERROR_NONE (integer)
No ha ocurrido ningún error. Disponible desde PHP 5.3.0.
JSON_ERROR_DEPTH (integer)
Se ha excedido la profundidad máxima de la pila. Disponible desde PHP 5.3.0.
JSON_ERROR_STATE_MISMATCH (integer)
Por desbordamiento de buffer o cuando los modos no coinciden. Disponible desde PHP 5.3.0.
JSON_ERROR_CTRL_CHAR (integer)
Error del carácter de control, posiblemente se ha codificado de forma incorrecta. Disponible desde PHP 5.3.0.
JSON_ERROR_SYNTAX (integer)
Error de sintaxis. Disponible desde PHP 5.3.0.
JSON_ERROR_UTF8 (integer)
Caracteres UTF-8 mal formados, posiblemente codificados incorrectamente. Esta constante está disponible desde PHP 5.3.3.
JSON_ERROR_RECURSION (integer)

El objeto o array pasado a json_encode() incluye referencias recursivas y no se puede codificar. Si se proporcionó la opción JSON_PARTIAL_OUTPUT_ON_ERROR, se codificará null en el lugar de la referencia recursiva.

Esta constante está disponible a partir de PHP 5.5.0.

JSON_ERROR_INF_OR_NAN (integer)

El valor pasado a json_encode() incluye NAN o INF. Si se proporcionó la opción JSON_PARTIAL_OUTPUT_ON_ERROR, se codificará 0 en el lugar de estos números especiales.

Esta constante está disponible a partir de PHP 5.5.0.

JSON_ERROR_UNSUPPORTED_TYPE (integer)

Se proporcionó un valor de un tipo no admitido para json_encode(), tal como un resource. Si se proporcionó la opción JSON_PARTIAL_OUTPUT_ON_ERROR, se codificará null en el lugar del valor no admitido.

Esta constante está disponible a partir de PHP 5.5.0.

Las siguientes constantes se pueden combinar para obtener opciones para json_encode().

JSON_HEX_TAG (integer)
Todos los < y > se convierten a \u003C y \u003E. Disponible desde PHP 5.3.0.
JSON_HEX_AMP (integer)
Todos los & se convierten a \u0026. Disponible desde PHP 5.3.0.
JSON_HEX_APOS (integer)
Todas las ' se convierten a \u0027. Disponible desde PHP 5.3.0.
JSON_HEX_QUOT (integer)
Todas las " se convierten a \u0022. Disponible desde PHP 5.3.0.
JSON_FORCE_OBJECT (integer)
Devuelve un objeto en vez de un array cuando se usa un array no asociativo. Especialmente útil cuando el destinatario del resultado espera un objeto y el array está vacío. Disponible desde PHP 5.3.0.
JSON_NUMERIC_CHECK (integer)
Codifica textos numéricos como números. Disponible desde PHP 5.3.3.
JSON_BIGINT_AS_STRING (integer)
Codifica integer grandes como su valor del string original. Disponible desde PHP 5.4.0.
JSON_PRETTY_PRINT (integer)
Utiliza espacios en blanco para formatear los datos devueltos. Disponible desde PHP 5.4.0.
JSON_UNESCAPED_SLASHES (integer)
No escapar /. Disponible desde PHP 5.4.0.
JSON_UNESCAPED_UNICODE (integer)
Codificar caracteres Unicode multibyte literalmente (por defecto es escapado como \uXXXX). Disponible desde PHP 5.4.0.
JSON_PARTIAL_OUTPUT_ON_ERROR (integer)
Sustituir algunos valores no codificables en lugar de fallar. Disponible desde PHP 5.5.0.
JSON_PRESERVE_ZERO_FRACTION (integer)
Se asegura de que los valores float son siempre codificados como valores de punto flotante. Disponible desde PHP 5.6.6.


La interfaz JsonSerializable

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Introducción

Los objetos que implementen JsonSerializable puede personalizar su representación JSON cuando se codifica con json_encode().

Sinopsis de la Interfaz

JsonSerializable {
/* Métodos */
abstract public jsonSerialize ( ) : mixed
}

Tabla de contenidos

  • JsonSerializable::jsonSerialize — Especifica los datos que deberían serializarse para JSON


Especifica los datos que deberían serializarse para JSON

  • « JsonSerializable
  • Funciones de JSON »
  • PHP Manual
  • JsonSerializable
  • Especifica los datos que deberían serializarse para JSON

JsonSerializable::jsonSerialize

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

JsonSerializable::jsonSerialize — Especifica los datos que deberían serializarse para JSON

Descripción

abstract public JsonSerializable::jsonSerialize ( ) : mixed

Serializa el objeto a un valor que puede ser serializado de forma nativa por json_encode().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los datos que pueden ser serializados por json_encode(), los cuales son un valor de cualquier tipo distinto de resource.

Ejemplos

Ejemplo #1 Ejemplo de JsonSerializable::jsonSerialize() devolviendo un array

<?php
class ArrayValue implements JsonSerializable {
    public function __construct(array $array) {
        $this->array = $array;
    }

    public function jsonSerialize() {
        return $this->array;
    }
}

$array = [1, 2, 3];
echo json_encode(new ArrayValue($array), JSON_PRETTY_PRINT);
?>

El resultado del ejemplo sería:

[
    1,
    2,
    3
]

Ejemplo #2 Ejemplo de JsonSerializable::jsonSerialize() devolviendo un array asociativo

<?php
class ArrayValue implements JsonSerializable {
    public function __construct(array $array) {
        $this->array = $array;
    }

    public function jsonSerialize() {
        return $this->array;
    }
}

$array = ['foo' => 'bar', 'quux' => 'baz'];
echo json_encode(new ArrayValue($array), JSON_PRETTY_PRINT);
?>

El resultado del ejemplo sería:

{
    "foo": "bar",
    "quux": "baz"
}

Ejemplo #3 Ejemplo de JsonSerializable::jsonSerialize() devolviento un integer

<?php
class IntegerValue implements JsonSerializable {
    public function __construct($number) {
        $this->number = (integer) $number;
    }

    public function jsonSerialize() {
        return $this->number;
    }
}

echo json_encode(new IntegerValue(1), JSON_PRETTY_PRINT);
?>

El resultado del ejemplo sería:

1

Ejemplo #4 Ejemplo de JsonSerializable::jsonSerialize() devolviendo un string

<?php
class StringValue implements JsonSerializable {
    public function __construct($string) {
        $this->string = (string) $string;
    }

    public function jsonSerialize() {
        return $this->string;
    }
}

echo json_encode(new StringValue('¡Hola!'), JSON_PRETTY_PRINT);
?>

El resultado del ejemplo sería:

"¡Hola!"


Funciones de JSON

Tabla de contenidos

  • json_decode — Decodifica un string de JSON
  • json_encode — Retorna la representación JSON del valor dado
  • json_last_error_msg — Devuelve el string con el error de la última llamada a json_encode() o a json_decode()
  • json_last_error — Devuelve el último error ocurrido


Decodifica un string de JSON

  • « Funciones de JSON
  • json_encode »
  • PHP Manual
  • Funciones de JSON
  • Decodifica un string de JSON

json_decode

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL json >= 1.2.0)

json_decode — Decodifica un string de JSON

Descripción

json_decode ( string $json , bool $assoc = false , int $depth = 512 , int $options = 0 ) : mixed

Convierte un string codificado en JSON a una variable de PHP.

Parámetros

json

El string de json a decodificar.

Esta función sólo trabaja con string codificados en UTF-8.

Nota:

PHP implementa un superconjunto de JSON tal como se especifica en la » RFC 7159 original.

assoc

Cuando es true, los object devueltos serán convertidos a array asociativos.

depth

Profundidad de recursividad especificada por el usuario.

options

Máscara de bit de opciones de decodificación de JSON. Actualmente solamente está soportada JSON_BIGINT_AS_STRING (por defecto, convierte enteros grandes en valores de tipo float)

Valores devueltos

Devuelve el valor codificado en json en un tipo de PHP apropiado. Los valores true, false y null son devueltos como true, false y null respectivamente. null es devuelto si el parámetro json no se puede decodificar o si los datos codificados son más profundos que el límite de recursividad.

Ejemplos

Ejemplo #1 Ejemplos de json_decode()

<?php
$json = '{"a":1,"b":2,"c":3,"d":4,"e":5}';

var_dump(json_decode($json));
var_dump(json_decode($json, true));

?>

El resultado del ejemplo sería:

object(stdClass)#1 (5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

array(5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

Ejemplo #2 Acceder a propiedades de objeto no válidas

Se puede acceder a elementos de un objeto que contienen caracteres no permitidos por la convención de nombres de PHP (p.ej., el guión) encapsulando el nombre del elemento entre llaves y apóstrofe.

<?php

$json = '{"foo-bar": 12345}';

$obj = json_decode($json);
print $obj->{'foo-bar'}; // 12345

?>

Ejemplo #3 Errores comunes al usar json_decode()

<?php

// los siguientes string son válidos en JavaScript pero no en JSON

// el nombre y el valor deben estar entre comillas dobles
// las comillas simples no son válidas
$json_erróneo = "{ 'bar': 'baz' }";
json_decode($json_erróneo); // null

// el nombre debe estar entre comillas dobles
$json_erróneo = '{ bar: "baz" }';
json_decode($json_erróneo); // null

// las comas finales no están permitidas
$json_erróneo = '{ bar: "baz", }';
json_decode($json_erróneo); // null

?>

Ejemplo #4 Errores con depth

<?php
// Codificar los datos.
$json = json_encode(
    array(
        1 => array(
            'Inglés' => array(
                'One',
                'January'
            ),
            'Francés' => array(
            'Une',
            'Janvier'
            )
        )
    )
);

// Definir los errores.
$constantes = get_defined_constants(true);
$errores_json = array();
foreach ($constantes["json"] as $nombre => $valor) {
    if (!strncmp($nombre, "JSON_ERROR_", 11)) {
        $errores_json[$valor] = $nombre;
    }
}

// Mostrar los errores para diferentes profundidades.
foreach (range(4, 3, -1) as $profundidad) {
    var_dump(json_decode($json, true, $profundidad));
    echo 'Último error: ', $errores_json[json_last_error()], PHP_EOL, PHP_EOL;
}
?>

El resultado del ejemplo sería:

array(1) {
  [1]=>
  array(2) {
    ["Inglés"]=>
    array(2) {
      [0]=>
      string(3) "One"
      [1]=>
      string(7) "January"
    }
    ["Francés"]=>
    array(2) {
      [0]=>
      string(3) "Une"
      [1]=>
      string(7) "Janvier"
    }
  }
}
Último error: JSON_ERROR_NONE

NULL
Último error: JSON_ERROR_DEPTH

Ejemplo #5 json_decode() de enteros grandes

<?php
$json = '{"number": 12345678901234567890}';

var_dump(json_decode($json));
var_dump(json_decode($json, false, 512, JSON_BIGINT_AS_STRING));

?>

El resultado del ejemplo sería:

object(stdClass)#1 (1) {
  ["number"]=>
  float(1.2345678901235E+19)
}
object(stdClass)#1 (1) {
  ["number"]=>
  string(20) "12345678901234567890"
}

Notas

Nota:

La especificación de JSON no es JavaScript, pero sí un subconjunto de JavaScript.

Nota:

En el caso de ocurrir un error durante la decodificación, se puede usar json_last_error() para determinar la naturaleza exacta del mismo.

Historial de cambios

Versión | Descripción
5.6.0 | Ya no se aceptan variantes que no estén en minúsculas de los literales true, false y null como entradas válidas, por lo que se generarán advertencias.
5.4.0 | Se añadió el parámetro options.
5.3.0 | Se añadió el parámetro opcional depth. La profundidad de recursividad predeterminada se aumentó de 128 a 512
5.2.3 | La profundidad de recursividad predeterminada se aumentó de 20 a 128
5.2.1 | Se añadió soporte para la decodificación de JSON de tipos básicos.

Ver también

  • json_encode() - Retorna la representación JSON del valor dado
  • json_last_error() - Devuelve el último error ocurrido


Retorna la representación JSON del valor dado

  • « json_decode
  • json_last_error_msg »
  • PHP Manual
  • Funciones de JSON
  • Retorna la representación JSON del valor dado

json_encode

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL json >= 1.2.0)

json_encode — Retorna la representación JSON del valor dado

Descripción

json_encode ( mixed $value , int $flags = 0 , int $depth = 512 ) : string|false

Devuelve un string con la representación JSON de value.

La codificación se ve afectada por los flags suministrados y además la codificación de los valores de tipo float dependen del valor de serialize_precision.

Parámetros

value

El value a ser codificado. Puede ser de cualquier tipo menos un resource.

Todos los datos de tipo string deben estar codificados con UTF-8.

Nota:

PHP implementa un superconjunto de JSON tal como se especifica en la » RFC 7159 original.

flags

Máscara de bits que compuesta por JSON_FORCE_OBJECT, JSON_HEX_QUOT, JSON_HEX_TAG, JSON_HEX_AMP, JSON_HEX_APOS, JSON_INVALID_UTF8_IGNORE, JSON_INVALID_UTF8_SUBSTITUTE, JSON_NUMERIC_CHECK, JSON_PARTIAL_OUTPUT_ON_ERROR, JSON_PRESERVE_ZERO_FRACTION, JSON_PRETTY_PRINT, JSON_UNESCAPED_LINE_TERMINATORS, JSON_UNESCAPED_SLASHES, JSON_UNESCAPED_UNICODE, JSON_THROW_ON_ERROR. El comportamiento de estas constantes se describe en la página de constantes de JSON.

depth

Establece la profundidad máxima. Debe ser mayor que cero.

Valores devueltos

Devuelve un string JSON codificado en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.3.0 | JSON_THROW_ON_ERROR Se añadió a flags.
7.2.0 | JSON_INVALID_UTF8_IGNORE, and JSON_INVALID_UTF8_SUBSTITUTE Se añadieron a flags.
7.1.0 | JSON_UNESCAPED_LINE_TERMINATORS Se añadió a flags.
7.1.0 | serialize_precision se utiliza en lugar de precision al codificar 'doubles'.

Ejemplos

Ejemplo #1 Un ejemplo de json_encode()

<?php
$arr = array('a' => 1, 'b' => 2, 'c' => 3, 'd' => 4, 'e' => 5);

echo json_encode($arr);
?>

El resultado del ejemplo sería:

{"a":1,"b":2,"c":3,"d":4,"e":5}

Ejemplo #2 Un ejemplo de json_encode() mostrando algunas de las opciones en acción

<?php
$a = array('<foo>',"'bar'",'"baz"','&blong&', "\xc3\xa9");

echo "Normal: ",  json_encode($a), "\n";
echo "Tags: ",    json_encode($a, JSON_HEX_TAG), "\n";
echo "Apos: ",    json_encode($a, JSON_HEX_APOS), "\n";
echo "Quot: ",    json_encode($a, JSON_HEX_QUOT), "\n";
echo "Amp: ",     json_encode($a, JSON_HEX_AMP), "\n";
echo "Unicode: ", json_encode($a, JSON_UNESCAPED_UNICODE), "\n";
echo "All: ",     json_encode($a, JSON_HEX_TAG | JSON_HEX_APOS | JSON_HEX_QUOT | JSON_HEX_AMP | JSON_UNESCAPED_UNICODE), "\n\n";

$b = array();

echo "Array vacío retornado como array: ", json_encode($b), "\n";
echo "Array vacío retornado como object: ", json_encode($b, JSON_FORCE_OBJECT), "\n\n";

$c = array(array(1,2,3));

echo "Array no asociativo retornado como array: ", json_encode($c), "\n";
echo "Array no asociativo retornado como objeto: ", json_encode($c, JSON_FORCE_OBJECT), "\n\n";

$d = array('foo' => 'bar', 'baz' => 'long');

echo "Array asociativo siempre es retornado como objeto: ", json_encode($d), "\n";
echo "Array asociativo siempre es retornado como objeto: ", json_encode($d, JSON_FORCE_OBJECT), "\n\n";

?>

El resultado del ejemplo sería:

Normal: ["<foo>","'bar'","\"baz\"","&blong&","\u00e9"]
Tags: ["\u003Cfoo\u003E","'bar'","\"baz\"","&blong&","\u00e9"]
Apos: ["<foo>","\u0027bar\u0027","\"baz\"","&blong&","\u00e9"]
Quot: ["<foo>","'bar'","\u0022baz\u0022","&blong&","\u00e9"]
Amp: ["<foo>","'bar'","\"baz\"","\u0026blong\u0026","\u00e9"]
Unicode: ["<foo>","'bar'","\"baz\"","&blong&","é"]
All: ["\u003Cfoo\u003E","\u0027bar\u0027","\u0022baz\u0022","\u0026blong\u0026","é"]

Array vacío retornado como array: []
Array vacío retornado como object: {}

Array no asociativo retornado como array: [[1,2,3]]
Array no asociativo retornado como objeto: {"0":{"0":1,"1":2,"2":3}}

Array asociativo siempre es retornado como objeto: {"foo":"bar","baz":"long"}
Array asociativo siempre es retornado como objeto: {"foo":"bar","baz":"long"}

Ejemplo #3 Ejemplo de la opción JSON_NUMERIC_CHECK

<?php
echo "Los string que representan números automáticamente se convierten en números".PHP_EOL;
$numbers = array('+123123', '-123123', '1.2e3', '0.00001');
var_dump(
 $numbers,
 json_encode($numbers, JSON_NUMERIC_CHECK)
);
echo "String que contienen números formateados incorrectamente".PHP_EOL;
$strings = array('+a33123456789', 'a123');
var_dump(
 $strings,
 json_encode($strings, JSON_NUMERIC_CHECK)
);
?>

El resultado del ejemplo sería:

Los string que representan números automáticamente se convierten en números
array(4) {
  [0]=>
  string(7) "+123123"
  [1]=>
  string(7) "-123123"
  [2]=>
  string(5) "1.2e3"
  [3]=>
  string(7) "0.00001"
}
string(28) "[123123,-123123,1200,1.0e-5]"
String que contienen números formateados incorrectamente
array(2) {
  [0]=>
  string(13) "+a33123456789"
  [1]=>
  string(4) "a123"
}
string(24) "["+a33123456789","a123"]"

Ejemplo #4 Ejemplo de array secuencial contra array no secuencial

<?php
echo "Array sencuencial".PHP_EOL;
$sequential = array("foo", "bar", "baz", "blong");
var_dump(
 $sequential,
 json_encode($sequential)
);

echo PHP_EOL."Array no secuencial".PHP_EOL;
$nonsequential = array(1=>"foo", 2=>"bar", 3=>"baz", 4=>"blong");
var_dump(
 $nonsequential,
 json_encode($nonsequential)
);

echo PHP_EOL."Array secuencial con una clave destruida".PHP_EOL;
unset($sequential[1]);
var_dump(
 $sequential,
 json_encode($sequential)
);
?>

El resultado del ejemplo sería:

Array sencuencial
array(4) {
  [0]=>
  string(3) "foo"
  [1]=>
  string(3) "bar"
  [2]=>
  string(3) "baz"
  [3]=>
  string(5) "blong"
}
string(27) "["foo","bar","baz","blong"]"

Array no secuencial"
array(4) {
  [1]=>
  string(3) "foo"
  [2]=>
  string(3) "bar"
  [3]=>
  string(3) "baz"
  [4]=>
  string(5) "blong"
}
string(43) "{"1":"foo","2":"bar","3":"baz","4":"blong"}"

Array secuencial con una clave destruida
array(3) {
  [0]=>
  string(3) "foo"
  [2]=>
  string(3) "baz"
  [3]=>
  string(5) "blong"
}
string(33) "{"0":"foo","2":"baz","3":"blong"}"

Ejemplo #5 Ejemplo de la opción JSON_PRESERVE_ZERO_FRACTION

<?php
var_dump(json_encode(12.0, JSON_PRESERVE_ZERO_FRACTION));
var_dump(json_encode(12.0));
?>

El resultado del ejemplo sería:

string(4) "12.0"
string(2) "12"

Notas

Nota:

En el evento de un fallo a codificar, json_last_error() puede ser usado para determinar la naturaleza exacta del error.

Nota:

Cuando se codifica un array, si las claves no están en una secuencia numérica continua comenzando por 0, todas las claves son codificadas como cadenas, y explícitamente especificadas para cada pareja clave-valor.

Nota:

Al igual que el codificador JSON de referencia, json_encode() generará JSON que es un valor simple (esto es, ni un objeto ni un array) si de proporciona un string, integer, float o boolean como entrada de value. Mientras que muchos decodificadores aceptarán estos valores como JSON válido, algunos no lo harán, ya que la especificación es ambigua en este aspecto.

Para resumir, compruebe siempre que el decodificador de JSON puede manejar la salida que se genere desde json_encode().

Ver también

  • JsonSerializable
  • json_decode() - Decodifica un string de JSON
  • json_last_error() - Devuelve el último error ocurrido
  • serialize() - Genera una representación apta para el almacenamiento de un valor


Devuelve el string con el error de la última llamada a json_encode() o a json_decode()

  • « json_encode
  • json_last_error »
  • PHP Manual
  • Funciones de JSON
  • Devuelve el string con el error de la última llamada a json_encode() o a json_decode()

json_last_error_msg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

json_last_error_msg — Devuelve el string con el error de la última llamada a json_encode() o a json_decode()

Descripción

json_last_error_msg ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el mensaje de error en caso de éxito, "No Error" si no ocurrió ningún error, o false en caso de error.

Ver también

  • json_last_error() - Devuelve el último error ocurrido


Devuelve el último error ocurrido

  • « json_last_error_msg
  • Lua »
  • PHP Manual
  • Funciones de JSON
  • Devuelve el último error ocurrido

json_last_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

json_last_error — Devuelve el último error ocurrido

Descripción

json_last_error ( ) : int

Devuelve el último error (si existe) que ocurrió durante la última codificación/decodificación JSON.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un integer, que puede ser una de las siguientes constantes:

Códigos de error de JSON
Constante | Significado | Disponibilidad
JSON_ERROR_NONE | No ocurrió ningún error |
JSON_ERROR_DEPTH | Se ha excedido la profundidad máxima de la pila |
JSON_ERROR_STATE_MISMATCH | JSON con formato incorrecto o inválido |
JSON_ERROR_CTRL_CHAR | Error del carácter de control, posiblemente se ha codificado de forma incorrecta |
JSON_ERROR_SYNTAX | Error de sintaxis |
JSON_ERROR_UTF8 | Caracteres UTF-8 mal formados, posiblemente codificados de forma incorrecta | PHP 5.3.3
JSON_ERROR_RECURSION | Una o más referencias recursivas en el valor a codificar | PHP 5.5.0
JSON_ERROR_INF_OR_NAN | Uno o más valores NAN o INF en el valor a codificar | PHP 5.5.0
JSON_ERROR_UNSUPPORTED_TYPE | Se proporcionó un valor de un tipo que no se puede codificar | PHP 5.5.0
JSON_ERROR_INVALID_PROPERTY_NAME | Se dio un nombre de una propiedad que no puede ser codificada | PHP 7.0.0
JSON_ERROR_UTF16 | Caracteres UTF-16 malformados, posiblemente codificados de forma incorrecta | PHP 7.0.0

Ejemplos

Ejemplo #1 Ejemplo de json_last_error()

<?php
// Un string json válido
$json[] = '{"Organización": "Equipo de documentación PHP"}';

// Un string json no válido que causa un error de sintaxis, en este caso, se ha
// usado ' en vez de " para entrecomillar
$json[] = "{'Organización': 'Equipo de documentación PHP'}";

foreach($json as $string) {
    echo 'Decodificando: ' . $string;
    json_decode($string);

    switch(json_last_error()) {
        case JSON_ERROR_NONE:
            echo ' - Sin errores';
        break;
        case JSON_ERROR_DEPTH:
            echo ' - Excedido tamaño máximo de la pila';
        break;
        case JSON_ERROR_STATE_MISMATCH:
            echo ' - Desbordamiento de buffer o los modos no coinciden';
        break;
        case JSON_ERROR_CTRL_CHAR:
            echo ' - Encontrado carácter de control no esperado';
        break;
        case JSON_ERROR_SYNTAX:
            echo ' - Error de sintaxis, JSON mal formado';
        break;
        case JSON_ERROR_UTF8:
            echo ' - Caracteres UTF-8 malformados, posiblemente codificados de forma incorrecta';
        break;
        default:
            echo ' - Error desconocido';
        break;
    }

    echo PHP_EOL;
}
?>

El resultado del ejemplo sería:

Decoding: {"Organización": "Equipo de documentación PHP"} - Sin errores
Decoding: {'Organización': 'Equipo de documentación PHP'} - Error de sintaxis, JSON mal formado

Ejemplo #2 json_last_error() en json_encode()

<?php
// Secuencia inválida UTF8
$text = "\xB1\x31";

$json  = json_encode($text);
$error = json_last_error();

var_dump($json, $error === JSON_ERROR_UTF8);
?>

El resultado del ejemplo sería:

string(4) "null"
bool(true)

Ver también

  • json_last_error_msg() - Devuelve el string con el error de la última llamada a json_encode() o a json_decode()
  • json_decode() - Decodifica un string de JSON
  • json_encode() - Retorna la representación JSON del valor dado


Lua

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Lua — La clase Lua
    • Lua::assign — Asigna una variable de PHP a Lua
    • Lua::call — Llama funciones de Lua
    • Lua::__construct — Constructor de Lua
    • Lua::eval — Evalúa una cadena de texto como código Lua
    • Lua::getVersion — Obtiene la versión
    • Lua::include — Analiza un fichero script Lua
    • Lua::registerCallback — Registra una función PHP en Lua
  • LuaClosure — La clase LuaClosure
    • LuaClosure::__invoke — Invoke luaclosure


Introducción

"Lua es un lenguaje de programación muy potente, rápido, ligero e integrable." Esta extensión incorpora el intérprete de Lua y ofrece una API Orientada a Objectos a las variables y funciones de Lua.


Requerimientos

Para poder usar esta extensión, debe tener Lua instalado, se encuentra disponible en la » página oficial de Lua


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/lua.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Configuración en tiempo de ejecución
  • Lua »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


La clase Lua

(PECL lua >=0.9.0)

Introducción

Sinopsis de la Clase

Lua {
/* Constants */
const string LUA_VERSION = Lua 5.1.4 ;
/* Métodos */
public assign ( string $name , string $value ) : mixed
public call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public __call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public __construct ( string $lua_script_file = NULL )
public eval ( string $statements ) : mixed
public getVersion ( ) : string
public include ( string $file ) : mixed
public registerCallback ( string $name , callable $function ) : mixed
}

Constantes predefinidas

Lua::LUA_VERSION

Tabla de contenidos

  • Lua::assign — Asigna una variable de PHP a Lua
  • Lua::call — Llama funciones de Lua
  • Lua::__construct — Constructor de Lua
  • Lua::eval — Evalúa una cadena de texto como código Lua
  • Lua::getVersion — Obtiene la versión
  • Lua::include — Analiza un fichero script Lua
  • Lua::registerCallback — Registra una función PHP en Lua


Asigna una variable de PHP a Lua

  • « Lua
  • Lua::call »
  • PHP Manual
  • Lua
  • Asigna una variable de PHP a Lua

Lua::assign

(PECL lua >=0.9.0)

Lua::assign — Asigna una variable de PHP a Lua

Descripción

public Lua::assign ( string $name , string $value ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos

Devuelve $this o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Lua::assign()

<?php
$lua = new Lua();
$lua->assign("php_var", array(1=>1, 2, 3)); //índice de la tabla empieza en 1
$lua->eval(<<<CODE
    print(php_var);
CODE
);
?>

El resultado del ejemplo sería:

Array
 (
     [1] => 1
     [2] => 2
     [3] => 3
 )


Llama funciones de Lua

  • « Lua::assign
  • Lua::__construct »
  • PHP Manual
  • Lua
  • Llama funciones de Lua

Lua::call

Lua::__call

(PECL lua >=0.9.0)

Lua::call -- Lua::__call — Llama funciones de Lua

Descripción

public Lua::call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public Lua::__call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

lua_func

Nombre de la función en Lua

args

Argumentos pasados a la función de Lua

use_self

Cuando se debe usar self

Valores devueltos

Devuelve el resultado de la función llamada, null si los argumentos son inválidos o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de la función Lua::call()

<?php
$lua = new Lua();
$lua->eval(<<<CODE
  function dummy(foo, bar)
    print(foo, ",", bar)
  end
CODE
);
$lua->call("dummy", array("Lua", "geiliable\n"));
var_dump($lua->call(array("table", "concat"), array(array(1=>1, 2=>2, 3=>3), "-")));
?>

El resultado del ejemplo sería algo similar a:

Lua,geiliable
string(5) "1-2-3"

Ver también

  • Lua::__call


Constructor de Lua

  • « Lua::call
  • Lua::eval »
  • PHP Manual
  • Lua
  • Constructor de Lua

Lua::__construct

(PECL lua >=0.9.0)

Lua::__construct — Constructor de Lua

Descripción

public Lua::__construct ( string $lua_script_file = NULL )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

lua_script_file

Valores devueltos


Evalúa una cadena de texto como código Lua

  • « Lua::__construct
  • Lua::getVersion »
  • PHP Manual
  • Lua
  • Evalúa una cadena de texto como código Lua

Lua::eval

(PECL lua >=0.9.0)

Lua::eval — Evalúa una cadena de texto como código Lua

Descripción

public Lua::eval ( string $statements ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

statements

Valores devueltos

Devuelve el resultado del código evaluado, null si los parámetros son inválidos o false en caseo de error.

Ejemplos

Ejemplo #1 Ejemplo de la función Lua::eval()

<?php
    $lua = new Lua();
    $lua->eval(<<<CODE
     print(2);
CODE
);
?>

El resultado del ejemplo sería:

2


Obtiene la versión

  • « Lua::eval
  • Lua::include »
  • PHP Manual
  • Lua
  • Obtiene la versión

Lua::getVersion

(PECL lua >=0.9.0)

Lua::getVersion — Obtiene la versión

Descripción

public Lua::getVersion ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve Lua::LUA_VERSION.


Analiza un fichero script Lua

  • « Lua::getVersion
  • Lua::registerCallback »
  • PHP Manual
  • Lua
  • Analiza un fichero script Lua

Lua::include

(PECL lua >=0.9.0)

Lua::include — Analiza un fichero script Lua

Descripción

public Lua::include ( string $file ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

file

Valores devueltos

Devuelve el resultado del código incluido, null en caso que los argumentos pasados sean erróneos o false para cualquier otro tipo de error.


Registra una función PHP en Lua

  • « Lua::include
  • LuaClosure »
  • PHP Manual
  • Lua
  • Registra una función PHP en Lua

Lua::registerCallback

(No hay información de versión disponible, podría estar únicamente en Git)

Lua::registerCallback — Registra una función PHP en Lua

Descripción

public Lua::registerCallback ( string $name , callable $function ) : mixed

Registra una función PHP en Lua con el nombre de función que se indique en "$name"

Parámetros

name

function

Una función de llamada de retorno válida PHP

Valores devueltos

Devuelve $this, null en caso que los argumentos sean erróneos o false para cualquier otro tipo de error.

Ejemplos

Ejemplo #1 Ejemplo de Lua::registerCallback()

<?php
$lua = new Lua();
$lua->registerCallback("echo", "var_dump");
$lua->eval(<<<CODE
    echo({1, 2, 3});
CODE
);
?>

El resultado del ejemplo sería:

array(3) {
  [1]=>
  float(1)
  [2]=>
  float(2)
  [3]=>
  float(3)
}


La clase LuaClosure

(PECL lua >=0.9.0)

Introducción

LuaClosure es una clase contenedor para LUA_TFUNCTION que puede ser devuelta al llamar a la función Lua.

Sinopsis de la Clase

LuaClosure {
/* Métodos */
public __invoke ( mixed $... = ? ) : void
}

Tabla de contenidos

  • LuaClosure::__invoke — Invoke luaclosure


Invoke luaclosure

  • « LuaClosure
  • LuaSandbox »
  • PHP Manual
  • LuaClosure
  • Invoke luaclosure

LuaClosure::__invoke

(PECL lua >=0.9.0)

LuaClosure::__invoke — Invoke luaclosure

Descripción

public LuaClosure::__invoke ( mixed $... = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

...

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de LuaClosure::__invoke()

<?php
$lua = new Lua();
$closure = $lua->eval(<<<CODE
    return (function ()
        print("hello world")
    end)
CODE
);

$lua->call($closure);
/* después de PHP 5.3 */
$closure();
?>

El resultado del ejemplo sería:

hello worldhello world


LuaSandbox

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Differences from Standard Lua
  • Ejemplos
    • Basic usage for LuaSandbox
  • LuaSandbox — The LuaSandbox class
    • LuaSandbox::callFunction — Call a function in a Lua global variable
    • LuaSandbox::disableProfiler — Disable the profiler
    • LuaSandbox::enableProfiler — Enable the profiler.
    • LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment
    • LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment
    • LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment
    • LuaSandbox::getProfilerFunctionReport — Fetch profiler data
    • LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua
    • LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment
    • LuaSandbox::loadString — Load Lua code into the Lua environment
    • LuaSandbox::pauseUsageTimer — Pause the CPU usage timer
    • LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library
    • LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment
    • LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment
    • LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer
    • LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction
  • LuaSandboxFunction — The LuaSandboxFunction class
    • LuaSandboxFunction::call — Call a Lua function
    • LuaSandboxFunction::__construct — Unused
    • LuaSandboxFunction::dump — Dump the function as a binary blob
  • LuaSandboxError — The LuaSandboxError class
  • LuaSandboxErrorError — The LuaSandboxErrorError class
  • LuaSandboxFatalError — The LuaSandboxFatalError class
  • LuaSandboxMemoryError — The LuaSandboxMemoryError class
  • LuaSandboxRuntimeError — The LuaSandboxRuntimeError class
  • LuaSandboxSyntaxError — The LuaSandboxSyntaxError class
  • LuaSandboxTimeoutError — The LuaSandboxTimeoutError class


Introducción

LuaSandbox is an extension for PHP 5, PHP 7, and HHVM to allow safely running untrusted Lua 5.1 code from within PHP.

Differences compared to the Lua extension:

  • LuaSandbox has support for time and memory limits.

  • LuaSandbox provides a default-safe environment for running untrusted code. Stock Lua functions were reviewed for security, and several were patched accordingly.

  • LuaSandbox has a PHP interface which is more complex, precise and powerful, but it is less convenient for developers.

  • LuaSandbox supports only Lua 5.1. It is difficult to change this, because LuaSandbox uses heavily modified Lua standard libraries, and due to the lack of backwards compatibility between major Lua versions. LuaSandbox aims to maximise backwards compatibility with user-supplied scripts.


Requerimientos

To use this extension, Lua 5.1 will need to be installed, available on the » Lua homepage.

To make full use of the timer features, LuaSandbox should be installed on Linux.

If FreeBSD or Mac OS X is used, only real (wall-clock) time is supported, the functions purporting to return CPU time will actually return wall clock time.

If Windows is used, no timer functions will be supported. The time limits will be inoperable.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/luasandbox.

If the operating system is Debian 9 or later, or Ubuntu 18.04 or later, then LuaSandbox should typically be installed from the package php-luasandbox:

sudo apt-get install php-luasandbox

Debian 9 users may need to add

deb http://ftp.debian.org/debian stretch-backports main
to their » sources.list.


  • « Configuración en tiempo de ejecución
  • Differences from Standard Lua »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Differences from Standard Lua

LuaSandbox provides a sandboxed environment which differs in some ways from standard Lua 5.1.

Features that are not available

  • dofile(), loadfile(), and the io package, as they allow direct filesystem access. If needed, filesystem access should be done via PHP callbacks.

  • The package package, including require() and module(), as it depends heavily on direct filesystem access. A pure-Lua rewrite such as that used in the MediaWiki Scribunto extension may be used instead.

  • load() and loadstring(), to allow for static analysis of Lua code.

  • print(), since it outputs to standard output. If needed, output should be done via PHP callbacks.

  • Most of the os package, as it allows manipulation of the process and executing of other processes.

    • os.clock(), os.date(), os.difftime(), and os.time() remain available.

  • Most of the debug package, as it allows manipulation of Lua state and metadata in ways that can break sandboxing.

    • debug.traceback() remains available.

  • string.dump(), as it may expose internal data.

  • collectgarbage(), gcinfo(), and the coroutine package have not been reviewed for security.

Features that have been modified

  • pcall() and xpcall() cannot catch certain errors, particularly timeout errors.

  • tostring() does not include pointer addresses.

  • string.match() has been patched to limit the recursion depth and to periodically check for a timeout.

  • math.random() and math.randomseed() are replaced with versions that don't share state with PHP's rand().

  • The Lua 5.2 __pairs and __ipairs metamethods are supported by pairs() and ipairs().


  • « Differences from Standard Lua
  • Basic usage for LuaSandbox »
  • PHP Manual
  • LuaSandbox
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Basic usage for LuaSandbox


Basic usage for LuaSandbox

Once you've compiled PHP with LuaSandbox support, you can begin using LuaSandbox to safely run user-provided Lua code.

Ejemplo #1 Execute some Lua code

<?php

$sandbox = new LuaSandbox;
$sandbox->setMemoryLimit( 50 * 1024 * 1024 );
$sandbox->setCPULimit( 10 );

// Register some functions in the Lua environment

function frobnosticate( $v ) {
    return [ $v + 42 ];
}

$sandbox->registerLibrary( 'php', [
    'frobnosticate' => 'frobnosticate',
    'output' => function ( $string ) {
        echo "$string\n";
    },
    'error' => function () {
        throw new LuaSandboxRuntimeError( "Something is wrong" );
    }
] );

// Execute some Lua code, including callbacks into PHP and into Lua

$luaCode = <<<EOF
php.output( "Hello, world" );

return "Hi", function ( v )
    return php.frobnosticate( v + 200 )
end
EOF;

list( $hi, $frob ) = $sandbox->loadString( $luaCode )->call();
assert( $frob->call( 4000 ) === [ 4242 ] );

// PHP-thrown LuaSandboxRuntimeError exceptions can be caught inside Lua

list( $ok, $message ) = $sandbox->loadString( 'return pcall( php.error )' )->call();
assert( !$ok );
assert( $message === 'Something is wrong' );

?>


The LuaSandbox class

(PECL luasandbox >= 1.0.0)

Introducción

The LuaSandbox class creates a Lua environment and allows for execution of Lua code.

Sinopsis de la Clase

LuaSandbox {
/* Constants */
const int SAMPLES = 0 ;
const int SECONDS = 1 ;
const int PERCENT = 2 ;
/* Métodos */
public callFunction ( string $name , mixed ...$args ) : array|bool
public disableProfiler ( ) : void
public enableProfiler ( float $period = 0.02 ) : bool
public getCPUUsage ( ) : float
public getMemoryUsage ( ) : int
public getPeakMemoryUsage ( ) : int
public getProfilerFunctionReport ( int $units = LuaSandbox::SECONDS ) : array
public static getVersionInfo ( ) : array
public loadBinary ( string $code , string $chunkName = '' ) : LuaSandboxFunction
public loadString ( string $code , string $chunkName = '' ) : LuaSandboxFunction
public pauseUsageTimer ( ) : bool
public registerLibrary ( string $libname , array $functions ) : void
public setCPULimit ( float|bool $limit ) : void
public setMemoryLimit ( int $limit ) : void
public unpauseUsageTimer ( ) : void
public wrapPhpFunction ( callable $function ) : LuaSandboxFunction
}

Constantes predefinidas

LuaSandbox::SAMPLES

Used with LuaSandbox::getProfilerFunctionReport() to return timings in samples.

LuaSandbox::SECONDS

Used with LuaSandbox::getProfilerFunctionReport() to return timings in seconds.

LuaSandbox::PERCENT

Used with LuaSandbox::getProfilerFunctionReport() to return timings in percentages of the total.

Tabla de contenidos

  • LuaSandbox::callFunction — Call a function in a Lua global variable
  • LuaSandbox::disableProfiler — Disable the profiler
  • LuaSandbox::enableProfiler — Enable the profiler.
  • LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment
  • LuaSandbox::getProfilerFunctionReport — Fetch profiler data
  • LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua
  • LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment
  • LuaSandbox::loadString — Load Lua code into the Lua environment
  • LuaSandbox::pauseUsageTimer — Pause the CPU usage timer
  • LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library
  • LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment
  • LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment
  • LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer
  • LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction


Call a function in a Lua global variable

  • « LuaSandbox
  • LuaSandbox::disableProfiler »
  • PHP Manual
  • LuaSandbox
  • Call a function in a Lua global variable

LuaSandbox::callFunction

(PECL luasandbox >= 1.0.0)

LuaSandbox::callFunction — Call a function in a Lua global variable

Descripción

public LuaSandbox::callFunction ( string $name , mixed ...$args ) : array|bool

Calls a function in a Lua global variable.

If the name contains "." characters, the function is located via recursive table accesses, as if the name were a Lua expression.

If the variable does not exist, or is not a function, false will be returned and a warning issued.

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

Parámetros

name

Lua variable name.

args

Arguments to the function.

Valores devueltos

Returns an array of values returned by the Lua function, which may be empty, or false in case of failure.

Ejemplos

Ejemplo #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Call Lua's string.match
$captures = $sandbox->callFunction( 'string.match', $string, $pattern );

?>


Disable the profiler

  • « LuaSandbox::callFunction
  • LuaSandbox::enableProfiler »
  • PHP Manual
  • LuaSandbox
  • Disable the profiler

LuaSandbox::disableProfiler

(PECL luasandbox >= 1.1.0)

LuaSandbox::disableProfiler — Disable the profiler

Descripción

public LuaSandbox::disableProfiler ( ) : void

Disables the profiler.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • LuaSandbox::enableProfiler() - Enable the profiler.
  • LuaSandbox::getProfilerFunctionReport() - Fetch profiler data


Enable the profiler.

  • « LuaSandbox::disableProfiler
  • LuaSandbox::getCPUUsage »
  • PHP Manual
  • LuaSandbox
  • Enable the profiler.

LuaSandbox::enableProfiler

(PECL luasandbox >= 1.1.0)

LuaSandbox::enableProfiler — Enable the profiler.

Descripción

public LuaSandbox::enableProfiler ( float $period = 0.02 ) : bool

Enables the profiler. Profiling will begin when Lua code is entered.

The profiler periodically samples the Lua environment to record the running function. Testing indicates that at least on Linux, setting a period less than 1ms will lead to a high overrun count but no performance problems.

Parámetros

period

Sampling period in seconds.

Valores devueltos

Returns a boolean indicating whether the profiler is enabled.

Ver también

  • LuaSandbox::disableProfiler() - Disable the profiler
  • LuaSandbox::getProfilerFunctionReport() - Fetch profiler data


Fetch the current CPU time usage of the Lua environment

  • « LuaSandbox::enableProfiler
  • LuaSandbox::getMemoryUsage »
  • PHP Manual
  • LuaSandbox
  • Fetch the current CPU time usage of the Lua environment

LuaSandbox::getCPUUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment

Descripción

public LuaSandbox::getCPUUsage ( ) : float

Fetches the current CPU time usage of the Lua environment.

This includes time spent in PHP callbacks.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current CPU time usage in seconds.

Nota:

On Windows, this function always returns zero. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, this function will return the elapsed wall-clock time, not CPU time.

Ver también

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Fetch the current memory usage of the Lua environment

  • « LuaSandbox::getCPUUsage
  • LuaSandbox::getPeakMemoryUsage »
  • PHP Manual
  • LuaSandbox
  • Fetch the current memory usage of the Lua environment

LuaSandbox::getMemoryUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment

Descripción

public LuaSandbox::getMemoryUsage ( ) : int

Fetches the current memory usage of the Lua environment.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current memory usage in bytes.

Ver también

  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Fetch the peak memory usage of the Lua environment

  • « LuaSandbox::getMemoryUsage
  • LuaSandbox::getProfilerFunctionReport »
  • PHP Manual
  • LuaSandbox
  • Fetch the peak memory usage of the Lua environment

LuaSandbox::getPeakMemoryUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment

Descripción

public LuaSandbox::getPeakMemoryUsage ( ) : int

Fetches the peak memory usage of the Lua environment.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the peak memory usage in bytes.

Ver también

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Fetch profiler data

  • « LuaSandbox::getPeakMemoryUsage
  • LuaSandbox::getVersionInfo »
  • PHP Manual
  • LuaSandbox
  • Fetch profiler data

LuaSandbox::getProfilerFunctionReport

(PECL luasandbox >= 1.1.0)

LuaSandbox::getProfilerFunctionReport — Fetch profiler data

Descripción

public LuaSandbox::getProfilerFunctionReport ( int $units = LuaSandbox::SECONDS ) : array

For a profiling instance previously started by LuaSandbox::enableProfiler(), get a report of the cost of each function.

The measurement unit used for the cost is determined by the $units parameter:

LuaSandbox::SAMPLES

Measure in number of samples.

LuaSandbox::SECONDS

Measure in seconds of CPU time.

LuaSandbox::PERCENT

Measure percentage of CPU time.

Parámetros

units

Measurement unit constant.

Valores devueltos

Returns profiler measurements, sorted in descending order, as an associative array. Keys are the Lua function names (with source file and line defined in angle brackets), values are the measurements as int or float.

Nota:

On Windows, this function always returns an empty array. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, this function will report the elapsed wall-clock time, not CPU time.

Ejemplos

Ejemplo #1 Profiling Lua code

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Start the profiler
$sandbox->enableProfiler( 0.01 );

// ... Execute some Lua code here ...

// Fetch the profiler data
$data = $sandbox->getProfilerFunctionReport();

?>


Return the versions of LuaSandbox and Lua

  • « LuaSandbox::getProfilerFunctionReport
  • LuaSandbox::loadBinary »
  • PHP Manual
  • LuaSandbox
  • Return the versions of LuaSandbox and Lua

LuaSandbox::getVersionInfo

(PECL luasandbox >= 1.6.0)

LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua

Descripción

public static LuaSandbox::getVersionInfo ( ) : array

Returns the versions of LuaSandbox and Lua.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array with two keys:

element | type | description
LuaSandbox | string | The version of the LuaSandbox extension.
Lua | string | The library name and version as defined by the LUA_RELEASE macro, for example, "Lua 5.1.5".


Load a precompiled binary chunk into the Lua environment

  • « LuaSandbox::getVersionInfo
  • LuaSandbox::loadString »
  • PHP Manual
  • LuaSandbox
  • Load a precompiled binary chunk into the Lua environment

LuaSandbox::loadBinary

(PECL luasandbox >= 1.0.0)

LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment

Descripción

public LuaSandbox::loadBinary ( string $code , string $chunkName = '' ) : LuaSandboxFunction

Loads data generated by LuaSandboxFunction::dump().

Parámetros

code

Data from LuaSandboxFunction::dump().

chunkName

Name for the loaded function.

Valores devueltos

Returns a LuaSandboxFunction.

Ver también

  • LuaSandbox::loadString() - Load Lua code into the Lua environment


Load Lua code into the Lua environment

  • « LuaSandbox::loadBinary
  • LuaSandbox::pauseUsageTimer »
  • PHP Manual
  • LuaSandbox
  • Load Lua code into the Lua environment

LuaSandbox::loadString

(PECL luasandbox >= 1.0.0)

LuaSandbox::loadString — Load Lua code into the Lua environment

Descripción

public LuaSandbox::loadString ( string $code , string $chunkName = '' ) : LuaSandboxFunction

Loads Lua code into the Lua environment.

This is the equivalent of standard Lua's loadstring() function.

Parámetros

code

Lua code.

chunkName

Name for the loaded chunk, for use in error traces.

Valores devueltos

Returns a LuaSandboxFunction which, when executed, will execute the passed $code.

Ejemplos

Ejemplo #1 Loading code into Lua

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Load the code
$function = $sandbox->loadString(
<<<CODE
    return "Hello, world"
CODE
);

// Execute the loaded code
var_dump( $function->call() );

?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  string(12) "Hello, world"
}

Ver también

  • LuaSandbox::registerLibrary() - Register a set of PHP functions as a Lua library
  • LuaSandbox::wrapPhpFunction() - Wrap a PHP callable in a LuaSandboxFunction


Pause the CPU usage timer

  • « LuaSandbox::loadString
  • LuaSandbox::registerLibrary »
  • PHP Manual
  • LuaSandbox
  • Pause the CPU usage timer

LuaSandbox::pauseUsageTimer

(PECL luasandbox >= 1.4.0)

LuaSandbox::pauseUsageTimer — Pause the CPU usage timer

Descripción

public LuaSandbox::pauseUsageTimer ( ) : bool

Pauses the CPU usage timer.

This only has effect when called from within a callback from Lua. When execution returns to Lua, the timer will be automatically unpaused. If a new call into Lua is made, the timer will be unpaused for the duration of that call.

If a PHP callback calls into Lua again with timer not paused, and then that Lua function calls into PHP again, the second PHP call will not be able to pause the timer. The logic is that even though the second PHP call would avoid counting the CPU usage against the limit, the first call still counts it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a bool indicating whether the timer is now paused.

Ejemplos

Ejemplo #1 Manipulating the usage timer

<?php

// create a new LuaSandbox and set a CPU limit
$sandbox = new LuaSandbox();
$sandbox->setCPULimit( 1 );

function doWait( $t ) {
    $end = microtime( true ) + $t;
    while ( microtime( true ) < $end ) {
        // waste CPU cycles
    }
}

// Register a PHP callback
$sandbox->registerLibrary( 'php', [
    'test' => function () use ( $sandbox ) {
        $sandbox->pauseUsageTimer();
        doWait( 5 );

        $sandbox->unpauseUsageTimer();
        doWait( 0.1 );
    },
    'test2' => function () use ( $sandbox ) {
        $sandbox->pauseUsageTimer();
        $sandbox->unpauseUsageTimer();
        doWait( 1.1 );
    }
] );

echo "This should not time out...\n";
$sandbox->loadString( 'php.test()' )->call();

echo "This should time out.\n";
try {
    $sandbox->loadString( 'php.test2()' )->call();
    echo "It did not?\n";
} catch ( LuaSandboxTimeoutError $ex ) {
    echo "It did! " . $ex->getMessage() . "\n";
}

?>

El resultado del ejemplo sería:

This should not time out...
This should time out.
It did! The maximum execution time for this script was exceeded

Ver también

  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment
  • LuaSandbox::unpauseUsageTimer() - Unpause the timer paused by LuaSandbox::pauseUsageTimer


Register a set of PHP functions as a Lua library

  • « LuaSandbox::pauseUsageTimer
  • LuaSandbox::setCPULimit »
  • PHP Manual
  • LuaSandbox
  • Register a set of PHP functions as a Lua library

LuaSandbox::registerLibrary

(PECL luasandbox >= 1.0.0)

LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library

Descripción

public LuaSandbox::registerLibrary ( string $libname , array $functions ) : void

Registers a set of PHP functions as a Lua library, so that Lua can call the relevant PHP code.

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

Parámetros

libname

The name of the library. In the Lua state, the global variable of this name will be set to the table of functions. If the table already exists, the new functions will be added to it.

functions

An array, where each key is a function name, and each value is a corresponding PHP callable.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Registering PHP functions to call from Lua

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Register some functions in the Lua environment

function frobnosticate( $v ) {
    return [ $v + 42 ];
}

$sandbox->registerLibrary( 'php', [
    'frobnosticate' => 'frobnosticate',
    'output' => function ( $string ) {
        echo "$string\n";
    },
    'error' => function () {
        throw new LuaSandboxRuntimeError( "Something is wrong" );
    }
] );

?>

Ver también

  • LuaSandbox::loadString() - Load Lua code into the Lua environment
  • LuaSandbox::wrapPhpFunction() - Wrap a PHP callable in a LuaSandboxFunction


Set the CPU time limit for the Lua environment

  • « LuaSandbox::registerLibrary
  • LuaSandbox::setMemoryLimit »
  • PHP Manual
  • LuaSandbox
  • Set the CPU time limit for the Lua environment

LuaSandbox::setCPULimit

(PECL luasandbox >= 1.0.0)

LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment

Descripción

public LuaSandbox::setCPULimit ( float|bool $limit ) : void

Sets the CPU time limit for the Lua environment.

If the total user and system time used by the environment after the call to this method exceeds this limit, a LuaSandboxTimeoutError exception is thrown.

Time used in PHP callbacks is included in the limit.

Setting the time limit from a callback while Lua is running causes the timer to be reset, or started if it was not already running.

Nota:

On Windows, the CPU limit will be ignored. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, wall-clock time rather than CPU time will be limited.

Parámetros

limit

Limit as a float in seconds, or false for no limit.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// set a time limit
$sandbox->setCPULimit( 2 );

// Run Lua code
$sandbox->loadString( 'while true do end' )->call();

?>

El resultado del ejemplo sería algo similar a:

PHP Fatal error:  Uncaught LuaSandboxTimeoutError: The maximum execution time for this script was exceeded

Ver también

  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Set the memory limit for the Lua environment

  • « LuaSandbox::setCPULimit
  • LuaSandbox::unpauseUsageTimer »
  • PHP Manual
  • LuaSandbox
  • Set the memory limit for the Lua environment

LuaSandbox::setMemoryLimit

(PECL luasandbox >= 1.0.0)

LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment

Descripción

public LuaSandbox::setMemoryLimit ( int $limit ) : void

Sets the memory limit for the Lua environment.

If this limit is exceeded, a LuaSandboxMemoryError exception is thrown.

Parámetros

limit

Memory limit in bytes.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// set a memory limit
$sandbox->setMemoryLimit( 50 * 1024 * 1024 );

// Run Lua code
$sandbox->loadString( 'local x = "x"; while true do x = x .. x; end' )->call();

?>

El resultado del ejemplo sería algo similar a:

PHP Fatal error:  Uncaught LuaSandboxMemoryError: not enough memory

Ver también

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Unpause the timer paused by LuaSandbox::pauseUsageTimer

  • « LuaSandbox::setMemoryLimit
  • LuaSandbox::wrapPhpFunction »
  • PHP Manual
  • LuaSandbox
  • Unpause the timer paused by LuaSandbox::pauseUsageTimer

LuaSandbox::unpauseUsageTimer

(PECL luasandbox >= 1.4.0)

LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer()

Descripción

public LuaSandbox::unpauseUsageTimer ( ) : void

Unpauses the timer paused by LuaSandbox::pauseUsageTimer().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • LuaSandbox::pauseUsageTimer() - Pause the CPU usage timer
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Wrap a PHP callable in a LuaSandboxFunction

  • « LuaSandbox::unpauseUsageTimer
  • LuaSandboxFunction »
  • PHP Manual
  • LuaSandbox
  • Wrap a PHP callable in a LuaSandboxFunction

LuaSandbox::wrapPhpFunction

(PECL luasandbox >= 1.2.0)

LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction

Descripción

public LuaSandbox::wrapPhpFunction ( callable $function ) : LuaSandboxFunction

Wraps a PHP callable in a LuaSandboxFunction, so it can be passed into Lua as an anonymous function.

The function must return either an array of values (which may be empty), or null which is equivalent to returning the empty array.

Exceptions will be raised as errors in Lua, however only LuaSandboxRuntimeError exceptions may be caught inside Lua with pcall() or xpcall().

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

Parámetros

function

Callable to wrap.

Valores devueltos

Returns a LuaSandboxFunction.

Ver también

  • LuaSandbox::loadString() - Load Lua code into the Lua environment
  • LuaSandbox::registerLibrary() - Register a set of PHP functions as a Lua library


The LuaSandboxFunction class

(PECL luasandbox >= 1.0.0)

Introducción

Represents a Lua function, allowing it to be called from PHP.

A LuaSandboxFunction may be obtained as a return value from Lua, as a parameter
passed to a callback from Lua, or by using
LuaSandbox::wrapPhpFunction(),
LuaSandbox::loadString(), or
LuaSandbox::loadBinary().

Sinopsis de la Clase

LuaSandboxFunction {
/* Métodos */
public call ( string ...$args ) : array|bool
public dump ( ) : string
}

Tabla de contenidos

  • LuaSandboxFunction::call — Call a Lua function
  • LuaSandboxFunction::__construct — Unused
  • LuaSandboxFunction::dump — Dump the function as a binary blob


Call a Lua function

  • « LuaSandboxFunction
  • LuaSandboxFunction::__construct »
  • PHP Manual
  • LuaSandboxFunction
  • Call a Lua function

LuaSandboxFunction::call

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::call — Call a Lua function

Descripción

public LuaSandboxFunction::call ( string ...$args ) : array|bool

Calls a Lua function.

Errors considered to be the fault of the PHP code will result in the function returning false and E_WARNING being raised, for example, a resource type being used as an argument. Lua errors will result in a LuaSandboxRuntimeError exception being thrown.

PHP and Lua types are converted as follows:

  • PHP null is Lua nil, and vice versa.

  • PHP ints and floats are converted to Lua numbers. Infinity and NAN are supported.

  • Lua numbers without a fractional part between approximately -2**53 and 2**53 are converted to PHP ints, with others being converted to PHP floats.

  • PHP bools are Lua booleans, and vice versa.

  • PHP strings are Lua strings, and vice versa.

  • Lua functions are PHP LuaSandboxFunction objects, and vice versa. General PHP callables are not supported.

  • PHP arrays are converted to Lua tables, and vice versa.

    • Note that Lua typically indexes arrays from 1, while PHP indexes arrays from 0. No adjustment is made for these differing conventions.

    • Self-referential arrays are not supported in either direction.

    • PHP references are dereferenced.

    • Lua __pairs and __ipairs are processed. __index is ignored.

    • When converting from PHP to Lua, integer keys between -2**53 and 2**53 are represented as Lua numbers. All other keys are represented as Lua strings.

    • When converting from Lua to PHP, keys other than strings and numbers will result in an error, as will collisions when converting numbers to strings or vice versa (since PHP considers things like $a[0] and $a["0"] as being equivalent).

  • All other types are unsupported and will raise an error/exception, including general PHP objects and Lua userdata and thread types.

Lua functions inherently return a list of results. So on success, this method returns an array containing all of the values returned by Lua, with int keys starting from zero. Lua may return no results, in which case an empty array is returned.

Parámetros

args

Arguments passed to the function.

Valores devueltos

Returns an array of values returned by the function, which may be empty, or false on error.


Unused

  • « LuaSandboxFunction::call
  • LuaSandboxFunction::dump »
  • PHP Manual
  • LuaSandboxFunction
  • Unused

LuaSandboxFunction::__construct

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::__construct — Unused

Descripción

final private LuaSandboxFunction::__construct ( )

LuaSandboxFunction are obtained as a return value from Lua,
as a parameter passed to a callback from Lua, or by using
LuaSandbox::wrapPhpFunction(),
LuaSandbox::loadString(), or
LuaSandbox::loadBinary(). They cannot be constructed directly.

Parámetros

Esta función no tiene parámetros.


Dump the function as a binary blob

  • « LuaSandboxFunction::__construct
  • LuaSandboxError »
  • PHP Manual
  • LuaSandboxFunction
  • Dump the function as a binary blob

LuaSandboxFunction::dump

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::dump — Dump the function as a binary blob

Descripción

public LuaSandboxFunction::dump ( ) : string

Dumps the function as a binary blob.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a string that may be passed to LuaSandbox::loadBinary().


The LuaSandboxError class

(PECL luasandbox >= 1.0.0)

Introducción

Base class for LuaSandbox exceptions

Sinopsis de la Clase

LuaSandboxError extends Exception {
/* Constants */
const int RUN = 2 ;
const int SYNTAX = 3 ;
const int MEM = 4 ;
const int ERR = 5 ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Constantes predefinidas

LuaSandboxError::RUN

LuaSandboxError::SYNTAX

LuaSandboxError::MEM

LuaSandboxError::ERR


The LuaSandboxErrorError class

(PECL luasandbox >= 1.0.0)

Introducción

Exception thrown when Lua encounters an error inside an error handler.

Sinopsis de la Clase

LuaSandboxErrorError extends LuaSandboxFatalError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxFatalError class

(PECL luasandbox >= 1.0.0)

Introducción

Uncatchable LuaSandbox exceptions.

These may not be caught inside Lua using pcall() or xpcall().

Sinopsis de la Clase

LuaSandboxFatalError extends LuaSandboxError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxMemoryError class

(PECL luasandbox >= 1.0.0)

Introducción

Exception thrown when Lua cannot allocate memory.

Sinopsis de la Clase

LuaSandboxMemoryError extends LuaSandboxFatalError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Ver también

  • LuaSandbox::setMemoryLimit()


The LuaSandboxRuntimeError class

(PECL luasandbox >= 1.0.0)

Introducción

Catchable LuaSandbox runtime exceptions.

These may be caught inside Lua using pcall() or xpcall().

Sinopsis de la Clase

LuaSandboxRuntimeError extends LuaSandboxError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxSyntaxError class

(PECL luasandbox >= 1.0.0)

Introducción

Exception thrown when Lua code cannot be parsed.

Sinopsis de la Clase

LuaSandboxSyntaxError extends LuaSandboxFatalError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxTimeoutError class

(PECL luasandbox >= 1.0.0)

Introducción

Exception thrown when the configured CPU time limit is exceeded.

Sinopsis de la Clase

LuaSandboxTimeoutError extends LuaSandboxFatalError {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Ver también

  • LuaSandbox::setCPULimit()


Funciones varias

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones Varias
    • connection_aborted — Verifica si el cliente se desconectó
    • connection_status — Devuelve el campo de bits de status de conexión
    • constant — Devuelve el valor de una constante
    • define — Define una constante con nombre
    • defined — Comprueba si existe una constante con nombre dada
    • die — Equivalente a exit
    • eval — Evaluar una cadena como código de PHP
    • exit — Imprime un mensaje y termina el script actual
    • get_browser — Indica de lo que es capaz el navegador del usuario
    • __halt_compiler — Detiene la ejecución del compilador
    • highlight_file — Remarcado de la sintaxis de un fichero
    • highlight_string — Remarcado de sintaxis de una cadena
    • hrtime — Get the system's high resolution time
    • ignore_user_abort — Establecer si la desconexión de un cliente debería abortar la ejecución del script
    • pack — Empaqueta información a una cadena binaria
    • php_strip_whitespace — Devuelve el código fuente sin los comentarios y espacios blancos
    • sapi_windows_cp_conv — Convert string from one codepage to another
    • sapi_windows_cp_get — Get current codepage
    • sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible
    • sapi_windows_cp_set — Set process codepage
    • sapi_windows_generate_ctrl_event — Send a CTRL event to another process
    • sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler
    • sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
    • show_source — Alias de highlight_file
    • sleep — Retrasar la ejecución
    • sys_getloadavg — Obtiene la carga media del sistema
    • time_nanosleep — Retrasar por un número de segundos y nanosegundos
    • time_sleep_until — Hacer que el script duerma hasta el momento especificado
    • uniqid — Generar un ID único
    • unpack — Desempaqueta datos de una cadena binaria
    • usleep — Retrasar la ejecución en microsegundos
  • Registro de cambios


Introducción

Estas funciones han sido colocadas aquí debido a que ninguna de ellas parece encajar en las demás categorías.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración Misc.
Nombre | Por defecto | Cambiable | Historial de cambios
ignore_user_abort | "0" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.bg | "#FFFFFF" | PHP_INI_ALL | Removed in PHP 5.4.0.
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

ignore_user_abort boolean

false por defecto. Si se cambia a true los scripts no finalizarán después de que un cliente aborte su conexión.

Véase también ignore_user_abort().

highlight.bg string
highlight.comment string
highlight.default string
highlight.html string
highlight.keyword string
highlight.string string

Los colores para el modo Highlighting. Cualquier cosa que sea aceptable en <font color="??????"> funcionará.

browscap string

El nombre (p.ej.: browscap.ini) y la localización del archivo de aptitudes del navegador. Véase también get_browser().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

CONNECTION_ABORTED (integer)
CONNECTION_NORMAL (integer)
CONNECTION_TIMEOUT (integer)
__COMPILER_HALT_OFFSET__ (integer)
Agregada en PHP 5.1.


Funciones Varias

Tabla de contenidos

  • connection_aborted — Verifica si el cliente se desconectó
  • connection_status — Devuelve el campo de bits de status de conexión
  • constant — Devuelve el valor de una constante
  • define — Define una constante con nombre
  • defined — Comprueba si existe una constante con nombre dada
  • die — Equivalente a exit
  • eval — Evaluar una cadena como código de PHP
  • exit — Imprime un mensaje y termina el script actual
  • get_browser — Indica de lo que es capaz el navegador del usuario
  • __halt_compiler — Detiene la ejecución del compilador
  • highlight_file — Remarcado de la sintaxis de un fichero
  • highlight_string — Remarcado de sintaxis de una cadena
  • hrtime — Get the system's high resolution time
  • ignore_user_abort — Establecer si la desconexión de un cliente debería abortar la ejecución del script
  • pack — Empaqueta información a una cadena binaria
  • php_strip_whitespace — Devuelve el código fuente sin los comentarios y espacios blancos
  • sapi_windows_cp_conv — Convert string from one codepage to another
  • sapi_windows_cp_get — Get current codepage
  • sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible
  • sapi_windows_cp_set — Set process codepage
  • sapi_windows_generate_ctrl_event — Send a CTRL event to another process
  • sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler
  • sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
  • show_source — Alias de highlight_file
  • sleep — Retrasar la ejecución
  • sys_getloadavg — Obtiene la carga media del sistema
  • time_nanosleep — Retrasar por un número de segundos y nanosegundos
  • time_sleep_until — Hacer que el script duerma hasta el momento especificado
  • uniqid — Generar un ID único
  • unpack — Desempaqueta datos de una cadena binaria
  • usleep — Retrasar la ejecución en microsegundos


Verifica si el cliente se desconectó

  • « Funciones Varias
  • connection_status »
  • PHP Manual
  • Funciones Varias
  • Verifica si el cliente se desconectó

connection_aborted

(PHP 4, PHP 5, PHP 7, PHP 8)

connection_aborted — Verifica si el cliente se desconectó

Descripción

connection_aborted ( ) : int

Verifica si el cliente se ha desconectado.

Valores devueltos

Devuelve 1 si el cliente se desconectó, 0 de lo contrario.

Ver también

  • connection_status() - Devuelve el campo de bits de status de conexión
  • ignore_user_abort() - Establecer si la desconexión de un cliente debería abortar la ejecución del script
  • Manejo de Conexiones para una descripción completa del manejo de conexiones en PHP.


Devuelve el campo de bits de status de conexión

  • « connection_aborted
  • constant »
  • PHP Manual
  • Funciones Varias
  • Devuelve el campo de bits de status de conexión

connection_status

(PHP 4, PHP 5, PHP 7, PHP 8)

connection_status — Devuelve el campo de bits de status de conexión

Descripción

connection_status ( ) : int

Obtiene el campo de bits de status de la conexión.

Valores devueltos

Devuelve el campo de bits de status de la conexión, el cual puede ser usado junto con las constantes CONNECTION_XXX para determinar el status de conexión.

Ver también

  • connection_aborted() - Verifica si el cliente se desconectó
  • ignore_user_abort() - Establecer si la desconexión de un cliente debería abortar la ejecución del script
  • Manejo de Conexiones para una descripción completa del manejo de conexiones en PHP.


Devuelve el valor de una constante

  • « connection_status
  • define »
  • PHP Manual
  • Funciones Varias
  • Devuelve el valor de una constante

constant

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

constant — Devuelve el valor de una constante

Descripción

constant ( string $name ) : mixed

Devuelve el valor de una constante indicada por name.

constant() es útil si se necesita recuperar el valor de una constante, pero no se conoce su nombre. Esto es, está almacenada en una variable o es devuelta por una función.

Esta función también funciona con las constantes de clases.

Parámetros

name

El nombre de la constante.

Valores devueltos

Devuelve el valor de la constante, o null si la constante no está definida.

Errores/Excepciones

Se generará un error de nivel E_WARNING si la constante no está definida.

Ejemplos

Ejemplo #1 Ejemplo de constant()

<?php

define("MAXSIZE", 100);

echo MAXSIZE;
echo constant("MAXSIZE"); // lo mismo que la línea anterior

interface bar {
    const test = 'foobar!';
}

class foo {
    const test = 'foobar!';
}

$const = 'test';

var_dump(constant('bar::'. $const)); // string(7) "foobar!"
var_dump(constant('foo::'. $const)); // string(7) "foobar!"

?>

Ver también

  • define() - Define una constante con nombre
  • defined() - Comprueba si existe una constante con nombre dada
  • La sección sobre Constantes


Define una constante con nombre

  • « constant
  • defined »
  • PHP Manual
  • Funciones Varias
  • Define una constante con nombre

define

(PHP 4, PHP 5, PHP 7, PHP 8)

define — Define una constante con nombre

Descripción

define ( string $name , mixed $value , bool $case_insensitive = false ) : bool

Define una constante con nombre en tiempo de ejecución.

Parámetros

name

El nombre de la constante.

value

El valor de la constante. En PHP 5, value debe ser un valor scalar (integer, float, string, boolean, o null). En PHP 7, también se aceptan valores de tipo array.

Advertencia

Aunque es posible definir constantes de tipo resource, no se recomienda debido a que podría causar un comportamiento impredecible.

case_insensitive

Si está establecido a true, la constante será definida insensible a mayúsculas-minúsculas. El comportamiento predeterminado es sensible a mayúsculas-minúsculas; esto es, CONSTANTE y Constante representan valores diferentes.

Nota:

Las constantes insensibles a mayúsculas-minúsculas se almacenan en minúsculas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.0.0 | Están permitidos valores array.

Ejemplos

Ejemplo #1 Definir Constantes

<?php
define("CONSTANTE", "Hola mundo.");
echo CONSTANTE; // imprime "Hola mundo."
echo Constante; // imprime "Constante" y emite un aviso.

define("SALUDO", "Hola tú.", true);
echo SALUDO; // imprime "Hola tú."
echo Saludo; // imprime "Hola tú."

// Funciona a partir de PHP 7
define('ANIMALES', array(
    'perro',
    'gato',
    'pájaro'
));
echo ANIMALES[1]; // muestra "gato"

?>

Ver también

  • defined() - Comprueba si existe una constante con nombre dada
  • constant() - Devuelve el valor de una constante
  • La sección sobre Constantes


Comprueba si existe una constante con nombre dada

  • « define
  • die »
  • PHP Manual
  • Funciones Varias
  • Comprueba si existe una constante con nombre dada

defined

(PHP 4, PHP 5, PHP 7, PHP 8)

defined — Comprueba si existe una constante con nombre dada

Descripción

defined ( string $name ) : bool

Comprueba si existe la constante dada y está definida.

Nota:

Si quiere ver si existe una variable, use isset(), ya que defined() sólo se aplica a constantes. Si quiere ver si existe una función, use function_exists().

Parámetros

name

El nombre de la constante.

Valores devueltos

Devuelve true si la constante con nombre dada por name ha sido definida, si no devuelve false.

Ejemplos

Ejemplo #1 Comprobar constantes

<?php
/* Observe el uso de las comillas, esto es importante. Este ejemplo comprueba
 * si e´string 'PRUEBA' es un nombre de una constante con nombre PRUEBA */
if (defined('PRUEBA')) {
    echo PRUEBA;
}
?>

Ver también

  • define() - Define una constante con nombre
  • constant() - Devuelve el valor de una constante
  • get_defined_constants() - Devuelve un array asociativo con los nombres de todas las constantes y sus valores
  • function_exists() - Devuelve true si la función dada ha sido definida
  • La sección sobre Constantes


Equivalente a exit

  • « defined
  • eval »
  • PHP Manual
  • Funciones Varias
  • Equivalente a exit

die

(PHP 4, PHP 5, PHP 7, PHP 8)

die — Equivalente a exit

Descripción

Este constructor de lenguaje es equivalente a exit().


Evaluar una cadena como código de PHP

  • « die
  • exit »
  • PHP Manual
  • Funciones Varias
  • Evaluar una cadena como código de PHP

eval

(PHP 4, PHP 5, PHP 7, PHP 8)

eval — Evaluar una cadena como código de PHP

Descripción

eval ( string $code ) : mixed

Evalua el código dado por code como código PHP.

Precaución

El constructor de lenguaje eval() es muy peligroso porque permite la ejecución de código de PHP arbitrario. Su uso está totalmente desaconsejado. Si se ha verificado cuidadosamente que no existe otra opción que usar este constructor, se ha de poner especial atención en no pasar ninguna información proporcionada por el usuario a esta función sin haberla validado apropiadamente con anterioridad.

Parámetros

code

El código de PHP válido ser evaluado.

El código no debe encerrarse entre etiquetas de PHP de apertura y cierre, es decir, se debe pasar 'echo "¡Hola!";' en vez de '<?php echo "¡Hola!"; ?>'. Aún es posible abandonar y reentrar en el modo PHP usando las etiquetas de PHP apropiadas, p.ej. 'echo "¡En el modo PHP!"; ?>¡En el modo HTML!<?php echo "¡De vuelta en el modo PHP!";'.

Aparte de que el código pasado debe ser código de PHP válido. Esto incluye que todas las sentencias deben finalizar apropiadamente usando un punto y coma. 'echo "¡Hola!"', por ejemplo, causará un error de análisis, mientras que 'echo "¡Hola!";' funcionará.

Una sentencia return finalizará inmediantamente la evaluación del código.

El código se ejecutará en el ámbito del código que llama a eval(). Así, cualquier variable definida o cambiada en la llamada a eval() permanecerá visible después de que finalice.

Valores devueltos

eval() devuelve null a menos que se llame a return en el código evaluado, en cuyo caso el valor pasado a return es devuelto. A partir de PHP 7, si hay un error de análisis en el código evaluado, eval() lanzará una excepción ParseError. Antes de PHP 7, eval() devolvía false y la ejecución del código posterior continuaba normalmente. No es posible capturar un error de análisis de eval() usando set_error_handler().

Ejemplos

Ejemplo #1 Ejemplo de eval() - fusión de texto sencillo

<?php
$cadena = 'taza';
$nombre = 'café';
$str = 'Esto es una $cadena con mi $nombre en ella.';
echo $str. "\n";
eval("\$str = \"$str\";");
echo $str. "\n";
?>

El resultado del ejemplo sería:

Esto es una $cadena con mi $nombre en ella.
Esto es una taza con mi café en ella.

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Sugerencia

Como con todo lo que genera un resultado directamente en el navegador, se pueden utilizar las funciones de control de salida para capturar el resultado de esta función y guardarlo, por ejemplo, en un string.

Nota:

En caso de un error fatal en el código evaluado, se saldrá del script completamente.

Ver también

  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro


Imprime un mensaje y termina el script actual

  • « eval
  • get_browser »
  • PHP Manual
  • Funciones Varias
  • Imprime un mensaje y termina el script actual

exit

(PHP 4, PHP 5, PHP 7, PHP 8)

exit — Imprime un mensaje y termina el script actual

Descripción

exit ( string $status = ? ) : void
exit ( int $status ) : void

Finaliza la ejecución del script. Funciones shutdown y Objectos destructores siempre serán ejecutados incluso si se llama a la función exit.

exit es una construcción de lenguaje y puede ser llamada sin paréntesis si no se le pasa status.

Parámetros

status

Si status es una cadena, esta función imprime el status justo antes de salir.

Si status es un valor integer, ese valor será usado también como el status de salida y no se mostrará. Los status de salida deben estar en el rango 0 a 254, el status de salida 255 es reservado por PHP y no debe ser usado. El status 0 es usado para finalizar el programa de forma satisfactoria.

Nota: PHP >= 4.2.0 NO imprime el status si es un valor integer.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de exit

<?php

$nombre_archivo = '/ruta/hacia/archivo-datos';
$archivo = fopen($nombre_archivo, 'r')
    or exit("no se pudo abrir el archivo ($nombre_archivo)");

?>

Ejemplo #2 Ejemplo de status de exit

<?php

//finalizar el programa normalmente
exit;
exit();
exit(0);

//finalizar con un código de error
exit(1);
exit(0376); //octal

?>

Ejemplo #3 Las funciones Shutdown y los destructores se ejecutan igualmente

<?php
class Foo
{
    public function __destruct()
    {
        echo 'Destruct: ' . __METHOD__ . '()' . PHP_EOL;
    }
}

function shutdown()
{
    echo 'Shutdown: ' . __FUNCTION__ . '()' . PHP_EOL;
}

$foo = new Foo();
register_shutdown_function('shutdown');

exit();
echo 'Esto no se mostrará.';
?>

El resultado del ejemplo sería:

 Shutdown: shutdown()
 Destruct: Foo::__destruct()

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Nota:

Esta construcción de lenguaje es equivalente a die().

Ver también

  • register_shutdown_function() - Registrar una función para que sea ejecutada al cierre


Indica de lo que es capaz el navegador del usuario

  • « exit
  • __halt_compiler »
  • PHP Manual
  • Funciones Varias
  • Indica de lo que es capaz el navegador del usuario

get_browser

(PHP 4, PHP 5, PHP 7, PHP 8)

get_browser — Indica de lo que es capaz el navegador del usuario

Descripción

get_browser ( string $user_agent = ? , bool $return_array = false ) : mixed

Intenta determinar las capacidades del navegador de usuario, buscando la información del navegador en el archivo browscap.ini.

Parámetros

user_agent

El Agente de Usuario a ser analizado. Por defecto, se usa el valor de la cabecera HTTP del Agente de Usuario; sin embargo, se puede modificar esto (es decir, buscar otra información del navegador) pasando este parámetro.

Se puede saltar este parámetro con un valor null.

return_array

Si está establecido a true, esta función devolverá un array en vez de un object.

Valores devueltos

La información es devuelta en un objeto o en un array que contendrán varios elementos de información que representan, por ejemplo, una cadena con los números de la versión mayor y menor del navegador y el ID; valores true/false para características tales como marcos, JavaScript, y cookies; etc.

El valor cookies simplemente significa que el navegador mismo es capaz de aceptar cookies y no significa si el usuario ha habilitado el navagador para que acepte cookies. La única forma de probar si las cookies son aceptadas es establecer una con setcookie(), recargar, y comprobar su valor.

Ejemplos

Ejemplo #1 Listar toda la información sobre el navegador del usuario

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "\n\n";

$navegador = get_browser(null, true);
print_r($navegador);
?>

El resultado del ejemplo sería algo similar a:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Array
(
    [browser_name_regex] => ^mozilla/5\.0 (windows; .; windows nt 5\.1; .*rv:.*) gecko/.* firefox/0\.9.*$
    [browser_name_pattern] => Mozilla/5.0 (Windows; ?; Windows NT 5.1; *rv:*) Gecko/* Firefox/0.9*
    [parent] => Firefox 0.9
    [platform] => WinXP
    [browser] => Firefox
    [version] => 0.9
    [majorver] => 0
    [minorver] => 9
    [cssversion] => 2
    [frames] => 1
    [iframes] => 1
    [tables] => 1
    [cookies] => 1
    [backgroundsounds] =>
    [vbscript] =>
    [javascript] => 1
    [javaapplets] => 1
    [activexcontrols] =>
    [cdf] =>
    [aol] =>
    [beta] => 1
    [win16] =>
    [crawler] =>
    [stripper] =>
    [wap] =>
    [netclr] =>
)

Notas

Nota:

Para que esto funcione, la configuración de browscap en php.ini debe apuntar a la ubicación correcta del archivo browscap.ini en su sistema.

browscap.ini no está incluido con PHP, pero se pude encontrar un archivo actualizado aquí » php_browscap.ini.

Mientras que browscap.ini contiene información sobre muchos navegadores, recae en el usuario la actualización para mantener la bases de datos vigente. El formato del archivo se explica por sí solo.


Detiene la ejecución del compilador

  • « get_browser
  • highlight_file »
  • PHP Manual
  • Funciones Varias
  • Detiene la ejecución del compilador

__halt_compiler

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

__halt_compiler — Detiene la ejecución del compilador

Descripción

__halt_compiler ( ) : void

Detiene la ejecución del compilador. Esto puede ser útil para embeber información en scripts de PHP, como en archivos de instalación.

La posición de byte del inicio de la información se puede determinar por la constante __COMPILER_HALT_OFFSET__, la cuál está definida sólo si hay un __halt_compiler() presente en el archivo.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Un Ejemplo de __halt_compiler()

<?php

// abrir este archivo
$fp = fopen(__FILE__, 'r');

// buscar el puntero de archivo a la información
fseek($fp, __COMPILER_HALT_OFFSET__);

// e imprimirlo
var_dump(stream_get_contents($fp));

// el final de la ejecución del script
__halt_compiler(); la información de instalación (p.ej. tar, gz, PHP, etc.)

Notas

Nota:

__halt_compiler() sólo se puede usar desde el ámbito más externo.


Remarcado de la sintaxis de un fichero

  • « __halt_compiler
  • highlight_string »
  • PHP Manual
  • Funciones Varias
  • Remarcado de la sintaxis de un fichero

highlight_file

(PHP 4, PHP 5, PHP 7, PHP 8)

highlight_file — Remarcado de la sintaxis de un fichero

Descripción

highlight_file ( string $filename , bool $return = false ) : mixed

Imprime o devuelve una versión con la sintaxis remarcada del código contenido en el fichero dado por filename usando los colores definidos en el remarcador de sintaxis interno de PHP.

Muchos servidores están configurados para remaracar automáticamente ficheros con la extensión phps. Por ejemplo, cuando se visione example.phps mostrará la fuente con la sintaxis remarcada del fichero. Para habilitar esto, añada esta línea a httpd.conf:

AddType application/x-httpd-php-source .phps

Parámetros

filename

Ruta al fichero PHP a ser remarcado.

return

Establecer este parámetro a true para hacer que esta función devuelva el código remarcado.

Valores devueltos

Si return está establecido a true, devuelve el código remarcado como string en vez de imprimirlo. De otro modo, devolverá true en caso de éxito, y false en caso de error.

Notas

Precaución

Se debería tener cuidado al usar la función highlight_file() para asegurarse de que no se revela inadvertidamente información sensible como contraseñas o cualquier otro tipo de información que podría crear un riesgo potencial de seguridad.

Nota:

Cuando el parámetro return se usa, esta función utiliza el almacenamiento en búfer de salida interno, por lo que no puede usarse dentro de una función de llamada de retorno ob_start().

Ver también

  • highlight_string() - Remarcado de sintaxis de una cadena
  • Directivas INI de resaltado


Remarcado de sintaxis de una cadena

  • « highlight_file
  • hrtime »
  • PHP Manual
  • Funciones Varias
  • Remarcado de sintaxis de una cadena

highlight_string

(PHP 4, PHP 5, PHP 7, PHP 8)

highlight_string — Remarcado de sintaxis de una cadena

Descripción

highlight_string ( string $str , bool $return = false ) : mixed

Imprime o devuelve marcas html para una versión con la sintaxis remarcada del código de PHP dado usando los colores definidos en el remarcador de sintaxis interno de PHP.

Parámetros

str

El código PHP a ser remarcado. Esto podría incluir la etiqueta de apertura.

return

Establezca este parámetro a true para hacer que esta función devuelva el código remarcado.

Valores devueltos

Si return está establecido a true, devuelve el código remarcado como cadena en vez de imprimirlo. De otro modo, devolverá true en caso de éxito, y false en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de highlight_string()

<?php
highlight_string('<?php phpinfo(); ?>');
?>

El ejemplo de arriba imprimirá (en PHP 4):

<code><font color="#000000">
<font color="#0000BB">&lt;?php phpinfo</font><font color="#007700">(); </font><font color="#0000BB">?&gt;</font>
</font>
</code>

El ejemplo de arriba imprimirá (en PHP 5):

<code><span style="color: #000000">
<span style="color: #0000BB">&lt;?php phpinfo</span><span style="color: #007700">(); </span><span style="color: #0000BB">?&gt;</span>
</span>
</code>

Notas

Nota:

Cuando el parámetro return se usa, esta función utiliza el almacenamiento en búfer de salida interno, por lo que no puede usarse dentro de una función de llamada de retorno ob_start().

La marca de HTML generada está sujeta a cambios.

Ver también

  • highlight_file() - Remarcado de la sintaxis de un fichero
  • Directivas INI de resaltado


Get the system's high resolution time

  • « highlight_string
  • ignore_user_abort »
  • PHP Manual
  • Funciones Varias
  • Get the system's high resolution time

hrtime

(PHP 7 >= 7.3.0, PHP 8)

hrtime — Get the system's high resolution time

Descripción

hrtime ( bool $as_number = false ) : array|int|float|false

Returns the system's high resolution time, counted from an arbitrary point in time. The delivered timestamp is monotonic and can not be adjusted.

Parámetros

as_number

Whether the high resolution time should be returned as array or number.

Valores devueltos

Returns an array of integers in the form [seconds, nanoseconds], if the parameter as_number is false. Otherwise the nanoseconds are returned as int (64bit platforms) or float (32bit platforms). Returns false on failure.

Ejemplos

Ejemplo #1 hrtime() usage

<?php
echo hrtime(true), PHP_EOL;
print_r(hrtime());
?>

El resultado del ejemplo sería algo similar a:

10444739687370679
Array
(
    [0] => 10444739
    [1] => 687464812
)

Ver también

  • The High resolution timing extension
  • microtime() - Devuelve la fecha Unix actual con microsegundos


Establecer si la desconexión de un cliente debería abortar la ejecución del script

  • « hrtime
  • pack »
  • PHP Manual
  • Funciones Varias
  • Establecer si la desconexión de un cliente debería abortar la ejecución del script

ignore_user_abort

(PHP 4, PHP 5, PHP 7, PHP 8)

ignore_user_abort — Establecer si la desconexión de un cliente debería abortar la ejecución del script

Descripción

ignore_user_abort ( bool $value = ? ) : int

Establece si la desconexión de un cliente debería ocasionar que el script sea abortado.

Cuando se ejecuta PHP como un script de línea de comandos, y el tty del script finaliza sin que el script haya terminado, el script cesará su ejecución la siguiente vez que se intente escribir algo, a menos que value esté establecido a true

Parámetros

value

Si se establece, esta función establecerá la configuración ini de ignore_user_abort al valor dado por value. Si no, esta función sólo devolverá la configuración previa sin cambiarla.

Valores devueltos

Devuelve la configuración previa, como un integer.

Ejemplos

Ejemplo #1 Un ejemplo ignore_user_abort()

<?php
// Ignorar los abortos hechos por el usuario y permitir que el script
// se ejecute siempre
ignore_user_abort(true);
set_time_limit(0);

echo 'Probando la gestión de conexión de PHP';

// Ejecutar un bucle que hará, con suerte,
// que hagamos clic fuera de la
// página o en el botón "Parar".
while(1)
{
    // ¿Falló la conexión?
    if(connection_status() != CONNECTION_NORMAL)
    {
        break;
    }

    // Dormir durante 10 segundos
    sleep(10);
}

// Si se alcanza esto, el 'break'
// fue provocado desde dentro del bucle while

// Por tanto, aquí podemos realizar una anotación o cualquier
// otra tarea que sea necesaria sin depender realmente del
// navegador.
?>

Notas

PHP no detectará que el usuario abortó la conexión hasta que se haga un intento de enviar información al cliente. Usar simplemente una sentencia echo no garantiza que la información sea enviada, veáse flush().

Ver también

  • connection_aborted() - Verifica si el cliente se desconectó
  • connection_status() - Devuelve el campo de bits de status de conexión
  • Manejo de conexiones para una descripción completa del manejo de conexiones de PHP.


Empaqueta información a una cadena binaria

  • « ignore_user_abort
  • php_strip_whitespace »
  • PHP Manual
  • Funciones Varias
  • Empaqueta información a una cadena binaria

pack

(PHP 4, PHP 5, PHP 7, PHP 8)

pack — Empaqueta información a una cadena binaria

Descripción

pack ( string $format , mixed $args = ? , mixed $... = ? ) : string

Empaqueta los argumentos dados a una cadena binaria según el formato dado por format.

La idea de esta función fue tomada de Perl y todos los códigos de formato funcionan igual que en Perl. Sin embargo, hay algunos códigos de formato que no están, como el código de formato "u" de Perl.

Observe que la distinción entre valores con signo y sin signo sólo afecta a la función unpack(), la función pack() da los mismos resultados para códigos de formato con y sin signo.

Parámetros

format

La cadena format consiste en códigos de formato seguidos de un argumento opcional de repetición. El argumento de repetición puede ser un valor entero o * para repetir hasta el final de los datos de entrada. Para a, A, h, H las repeticiones especifican cuántos caracteres se toman de un argumento de datos, para @ es la posición absoluta donde colocar el dato siguiente, para todo lo demás las repeticiones especifican cuántos argumentos de datos se consumen y empaquetan en la cadena binaria resultante.

Los formatos implementados actualmente son:

Caracteres de formato de pack()
Código | Descripción
a | cadena rellena de NUL
A | cadena rellena de SPACE
h | cadena hexadecimal, nibble bajo primero
H | cadena hexadecimal, nibble alto primero
c | signed char
C | carácter sin signo
s | short con signo (siempre 16 bits, orden de byte de la máquina)
S | short sin signo (siempre 16 bits, orden de byte de la máquina)
n | short sin signo (siempre 16 bits, orden de byte big endian)
v | short sin signo (siempre 16 bits, orden de byte little endian)
i | integer con signo (tamaño y orden de byte dependientes de la máquina)
I | integer sin signo (tamaño y orden de byte dependientes de la máquina)
l | long con signo (siempre 32 bits, orden de byte de la máquina)
L | long sin signo (siempre 32 bits, orden de byte de la máquina)
N | long sin signo (siempre 32 bits, orden de byte big endian)
V | long sin signo (siempre 32 bits, orden de byte little endian)
q | long largo con signo (siempre 64 bit, orden de byte big endian)
Q | long largo sin signo (siempre 64 bit, orden de byte big endian)
J | long largo sin signo (siempre 64 bit, orden de byte big endian)
P | long largo sin signo (siempre 64 bit, orden de byte little endian)
f | float (tamaño y representación dependientes de la máquina)
d | double (tamaño y representación dependientes de la máquina)
x | byte NUL
X | copia de seguridad de un byte
Z | Cadena rellena de NUL (nuevo en PHP 5.5)
@ relleno de NUL hasta la posición absoluta

args

Valores devueltos

Devuelve una cadena binaria que contiene información.

Historial de cambios

Versión | Descripción
5.6.3 | Se añadieron los códigos "q", "Q", "J" y "P" para habilitar el trabajo con número de 64 bit.
5.5.0 | Se añadió el código "Z" con funcionalidad equivalente a "a" por compatibilidad con Perl.

Ejemplos

Ejemplo #1 Ejemplo de pack()

<?php
$datosbinarios = pack("nvc*", 0x1234, 0x5678, 65, 66);
?>

La cadena binaria resultante será de 6 bytes de longitud y contendrá la secuencia de bytes 0x12, 0x34, 0x78, 0x56, 0x41, 0x42.

Notas

Precaución

Observe que PHP almacena internamente los valores de tipo integer como valores con signo de tamaño dependiente de la máquina (de tipo long de C). Los literales de tipo integer y las operaciones que producen números fuera de los límites del tipo integer serán almacenados como float. Cuando se empaquetan estos floats como integers, primero son convertidos al tipo integer. Esto puede o no puede resultar en el patrón de bytes deseado.

El caso más relevante es cuando se empaquetan números sin signo que serían representables con el tipo integer si fueran sin signo. En sistemas donde el tipo integer tiene un tamaño de 32 bits, la conversión normalmente resultará en el mismo patrón de bytes que si el tipo integer fuera sin signo (aunque esto depende de las conversiones de con signo a sin signo definidas en la implementación, conforme al estándar de C). En sistemas donde el tipo integer tiene un tamaño de 64 bits, el tipo float casi con toda seguridad no tendrá una mantisa suficientemente grande para mantener el valor sin pérdida de precisión. Si esos sistemas también tienen un tipo int de C de 64 bits nativo (al contrario que la mayoría de sistemas basados en UNIX), la única forma de usar el formato de empaquetación I en el rango superior es crear valores integer negativos con la misma representación de bytes que el valor sin signo deseado.

Ver también

  • unpack() - Desempaqueta datos de una cadena binaria


Devuelve el código fuente sin los comentarios y espacios blancos

  • « pack
  • sapi_windows_cp_conv »
  • PHP Manual
  • Funciones Varias
  • Devuelve el código fuente sin los comentarios y espacios blancos

php_strip_whitespace

(PHP 5, PHP 7, PHP 8)

php_strip_whitespace — Devuelve el código fuente sin los comentarios y espacios blancos

Descripción

php_strip_whitespace ( string $filename ) : string

Devuelve el código fuente PHP en nombre_archivo, habiendo removido los comentarios PHP y los espacios blancos. Esto puede ser útil para determinar la cantidad de código real en sus scripts, en comparación con la cantidad de comentarios. Esto es similar al uso de php -w desde la línea de comandos.

Parámetros

filename

Ruta al archivo PHP.

Valores devueltos

El código fuente limpiado será devuelto en caso de éxito, o una cadena vacía si ocurre un error.

Nota:

Esta función respeta el valor de la directiva ini para short_open_tag

Nota:

Esta función trabaja como se describe, a partir de PHP 5.0.1. Antes de esta versión, solo devolvía una cadena vacía. Para más información sobre este fallo y su comportamiento anterior, vea el reporte de fallos » #29606.

Ejemplos

Ejemplo #1 Ejemplo de php_strip_whitespace()

<?php
// Comentario PHP aquí

/*
 * Otro comentario PHP
 */

echo        php_strip_whitespace(__FILE__);
// Los saltos de línea son considerados espacios blancos, y son eliminados también:
hacer_nada();
?>

El resultado del ejemplo sería:

<?php
 echo php_strip_whitespace(__FILE__); hacer_nada(); ?>

Note que los comentarios PHP han sido eliminados, al igual que los espacios blancos y la nueva línea después de la primera sentencia echo.


Convert string from one codepage to another

  • « php_strip_whitespace
  • sapi_windows_cp_get »
  • PHP Manual
  • Funciones Varias
  • Convert string from one codepage to another

sapi_windows_cp_conv

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_conv — Convert string from one codepage to another

Descripción

sapi_windows_cp_conv ( int|string $in_codepage , int|string $out_codepage , string $subject ) : string

Convert string from one codepage to another.

Parámetros

in_codepage

The codepage of the subject string. Either the codepage name or identifier.

out_codepage

The codepage to convert the subject string to. Either the codepage name or identifier.

subject

The string to convert.

Valores devueltos

The subject string converted to out_codepage, or null on failure.

Errores/Excepciones

This function issues E_WARNING level errors, if invalid codepages are given, or if the subject is not valid for in_codepage.

Ver también

  • sapi_windows_cp_get() - Get current codepage
  • iconv() - Convierte un string a la codificación de caracteres indicada


Get current codepage

  • « sapi_windows_cp_conv
  • sapi_windows_cp_is_utf8 »
  • PHP Manual
  • Funciones Varias
  • Get current codepage

sapi_windows_cp_get

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_get — Get current codepage

Descripción

sapi_windows_cp_get ( string $kind = "" ) : int

Gets the current codepage.

Parámetros

kind

The kind of operating system codepage to get, either 'ansi' or 'oem'. Any other value refers to the current codepage of the process.

Valores devueltos

If kind is 'ansi', the current ANSI code page of the operating system is returned. If kind is 'oem', the current OEM code page of the operating system is returned. Otherwise, the current codepage of the process is returned.

Ver también

  • sapi_windows_cp_set() - Set process codepage


Indicates whether the codepage is UTF-8 compatible

  • « sapi_windows_cp_get
  • sapi_windows_cp_set »
  • PHP Manual
  • Funciones Varias
  • Indicates whether the codepage is UTF-8 compatible

sapi_windows_cp_is_utf8

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible

Descripción

sapi_windows_cp_is_utf8 ( ) : bool

Indicates whether the codepage of the current process is UTF-8 compatible.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns whether the codepage of the current process is UTF-8 compatible.

Ver también

  • sapi_windows_cp_get() - Get current codepage


Set process codepage

  • « sapi_windows_cp_is_utf8
  • sapi_windows_generate_ctrl_event »
  • PHP Manual
  • Funciones Varias
  • Set process codepage

sapi_windows_cp_set

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_set — Set process codepage

Descripción

sapi_windows_cp_set ( int $cp ) : bool

Set the codepage of the current process.

Parámetros

cp

A codepage identifier.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • sapi_windows_cp_get() - Get current codepage


Send a CTRL event to another process

  • « sapi_windows_cp_set
  • sapi_windows_set_ctrl_handler »
  • PHP Manual
  • Funciones Varias
  • Send a CTRL event to another process

sapi_windows_generate_ctrl_event

(PHP 7 >= 7.4.0, PHP 8)

sapi_windows_generate_ctrl_event — Send a CTRL event to another process

Descripción

sapi_windows_generate_ctrl_event ( int $event , int $pid = 0 ) : bool

Sends a CTRL event to another process in the same process group.

Parámetros

event

The CTRL even to send; either PHP_WINDOWS_EVENT_CTRL_C or PHP_WINDOWS_EVENT_CTRL_BREAK.

pid

The ID of the process to which to send the event to. If 0 is given, the event is sent to all processes of the process group.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Basic sapi_windows_generate_ctrl_event() Usage

This example shows how to pass along CTRL+BREAK events to a child process. In this case the child process echoes I'm still alive every second, until the user presses CTRL+BREAK, what causes only the child process to be terminated.

<?php
// forward CTRL+BREAK events to the child process
sapi_windows_set_ctrl_handler('sapi_windows_generate_ctrl_event');

// create a child process which echoes every second
$cmd = ['php', '-r', 'while (true) { echo "I\'m still alive\n"; sleep(1); }'];
$descspec = array(['pipe', 'r'], ['pipe', 'w'], ['pipe', 'w']);
$options = ['create_process_group' => true];
$proc = proc_open($cmd, $descspec, $pipes, null, null, $options);
while (true) {
    echo fgets($pipes[1]);
}
?>

Ver también

  • proc_open() - Ejecuta un comando y abre un puntero de fichero para entrada/salida
  • sapi_windows_set_ctrl_handler() - Set or remove a CTRL event handler


Set or remove a CTRL event handler

  • « sapi_windows_generate_ctrl_event
  • sapi_windows_vt100_support »
  • PHP Manual
  • Funciones Varias
  • Set or remove a CTRL event handler

sapi_windows_set_ctrl_handler

(PHP 7 >= 7.4.0, PHP 8)

sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler

Descripción

sapi_windows_set_ctrl_handler ( callable $callable , bool $add = true ) : bool

Sets or removes a CTRL event handler, which allows Windows CLI processes to intercept or ignore CTRL+C and CTRL+BREAK events. Note that in multithreaded environments, this is only possible when called from the main thread.

Parámetros

callable

A callback function to set or remove. If set, this function will be called whenever a CTRL+C or CTRL+BREAK event occurs. The function is supposed to have the following signature:

handler ( int $event ) : void
event
The CTRL event which has been received; either PHP_WINDOWS_EVENT_CTRL_C or PHP_WINDOWS_EVENT_CTRL_BREAK.
Setting a null callable causes the process to ignore CTRL+C events, but not CTRL+BREAK events.

add

If true, the handler is set. If false, the handler is removed.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Basic sapi_windows_set_ctrl_handler() Usage

This example shows how to intercept CTRL events.

<?php
function ctrl_handler(int $event)
{
    switch ($event) {
        case PHP_WINDOWS_EVENT_CTRL_C:
            echo "You have pressed CTRL+C\n";
            break;
        case PHP_WINDOWS_EVENT_CTRL_BREAK:
            echo "You have pressed CTRL+BREAK\n";
            break;
    }
}

sapi_windows_set_ctrl_handler('ctrl_handler');
while (true); // infinite loop, so the handler can be triggered
?>

Ver también

  • sapi_windows_generate_ctrl_event() - Send a CTRL event to another process


Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

  • « sapi_windows_set_ctrl_handler
  • show_source »
  • PHP Manual
  • Funciones Varias
  • Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

sapi_windows_vt100_support

(PHP 7 >= 7.2.0, PHP 8)

sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

Descripción

sapi_windows_vt100_support ( resource $stream , bool $enable = ? ) : bool

If enable is omitted, the function returns true if the stream stream has VT100 control codes enabled, false otherwise.

If enable is specified, the function will try to enable or disable the VT100 features of the stream stream. If the feature has been successfully enabled (or disabled), the function will return true, or false otherwise.

At startup, PHP tries to enable the VT100 feature of the STDOUT/STDERR streams. By the way, if those streams are redirected to a file, the VT100 features may not be enabled.

If VT100 support is enabled, it is possible to use control sequences as they are known from the VT100 terminal. They allow the modification of the terminal's output. On Windows these sequences are called Console Virtual Terminal Sequences.

Advertencia

This function uses the ENABLE_VIRTUAL_TERMINAL_PROCESSING flag implemented in the Windows 10 API, so the VT100 feature may not be available on older Windows versions.

Parámetros

stream

The stream on which the function will operate.

enable

If specified, the VT100 feature will be enabled (if true) or disabled (if false).

Valores devueltos

If enable is not specified: returns true if the VT100 feature is enabled, false otherwise.

If enable is specified: Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 sapi_windows_vt100_support() default state

By default, STDOUT and STDERR have the VT100 feature enabled.

php -r "var_export(sapi_windows_vt100_support(STDOUT));echo ' ';var_export(sapi_windows_vt100_support(STDERR));"

El resultado del ejemplo sería algo similar a:

true true

By the way, if a stream is redirected, the VT100 feature will not be enabled:

php -r "var_export(sapi_windows_vt100_support(STDOUT));echo ' ';var_export(sapi_windows_vt100_support(STDERR));" 2>NUL

El resultado del ejemplo sería algo similar a:

true false

Ejemplo #2 sapi_windows_vt100_support() changing state

You won't be able to enable the VT100 feature of STDOUT or STDERR if the stream is redirected.

php -r "var_export(sapi_windows_vt100_support(STDOUT, true));echo ' ';var_export(sapi_windows_vt100_support(STDERR, true));" 2>NUL

El resultado del ejemplo sería algo similar a:

true false

Ejemplo #3 Example usage of VT100 support enabled

<?php
$out = fopen('php://stdout','w');
fwrite($out, 'Just forgot a lettr.');
// Moves the cursor two characters backwards
fwrite($out, "\033[2D");
// Inserts one blank, shifting existing text to the right -> Just forgot a lett r.
fwrite($out, "\033[1@");
fwrite($out, 'e');
?>

El resultado del ejemplo sería:

Just forgot a letter.


Alias de highlight_file

  • « sapi_windows_vt100_support
  • sleep »
  • PHP Manual
  • Funciones Varias
  • Alias de highlight_file

show_source

(PHP 4, PHP 5, PHP 7, PHP 8)

show_source — Alias de highlight_file()

Descripción

Esta función es un alias de: highlight_file().


Retrasar la ejecución

  • « show_source
  • sys_getloadavg »
  • PHP Manual
  • Funciones Varias
  • Retrasar la ejecución

sleep

(PHP 4, PHP 5, PHP 7, PHP 8)

sleep — Retrasar la ejecución

Descripción

sleep ( int $seconds ) : int

Retrasa la ejecución del programa durante el número de segundos dados por seconds.

Parámetros

seconds

El tiempo de parada en segundos.

Valores devueltos

Devuelve cero en caso de éxito, o false en caso de error.

Si la llamada se interrumpió por una señal, sleep() devuelve un valor distinto de cero. En Windows, este valor será siempre 192 (el valor de la constante WAIT_IO_COMPLETION dentro de la API de Windows). En otras plataformas, el valor devuelto será el número de segundos que quedan para dormir.

Errores/Excepciones

Si el número de segundos especificado por seconds es negativo, esta función generará un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.3.4 | Antes de PHP 5.3.4, en Windows, sleep() siempre devuelve null cuando el sueño ha sucedido, si tener en cuenta si el sueño fue interrumpido o no.

Ejemplos

Ejemplo #1 Ejemplo de sleep()

<?php

// hora actual
echo date('h:i:s') . "\n";

// dormir durante 10 segundos
sleep(10);

// ¡despierta!
echo date('h:i:s') . "\n";

?>

Este ejemplo imprimirá (después de 10 segundos)

05:31:23
05:31:33

Ver también

  • usleep() - Retrasar la ejecución en microsegundos
  • time_nanosleep() - Retrasar por un número de segundos y nanosegundos
  • time_sleep_until() - Hacer que el script duerma hasta el momento especificado
  • set_time_limit() - Limita el tiempo máximo de ejecución


Obtiene la carga media del sistema

  • « sleep
  • time_nanosleep »
  • PHP Manual
  • Funciones Varias
  • Obtiene la carga media del sistema

sys_getloadavg

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

sys_getloadavg — Obtiene la carga media del sistema

Descripción

sys_getloadavg ( ) : array

Devuelve tres muestras que representan la carga media del sistema (el número de procesos en la cola de ejecución del sistema) sobre los últimos 1, 5 y 15 minutos, respectivamente.

Valores devueltos

Devuelve un array con tres muestras (últimos 1, 5 y 15 minutos).

Ejemplos

Ejemplo #1 Ejemplo de sys_getloadavg()

<?php
$carga = sys_getloadavg();
if ($carga[0] > 0.80) {
    header('HTTP/1.1 503 Ocupado, pruebe más tarde');
    die('Servidor ocupado. Por favor, inténtelo de nuevo más tarde.');
}
?>

Notas

Nota: Esta función no está implementada en plataformas Windows.


Retrasar por un número de segundos y nanosegundos

  • « sys_getloadavg
  • time_sleep_until »
  • PHP Manual
  • Funciones Varias
  • Retrasar por un número de segundos y nanosegundos

time_nanosleep

(PHP 5, PHP 7, PHP 8)

time_nanosleep — Retrasar por un número de segundos y nanosegundos

Descripción

time_nanosleep ( int $seconds , int $nanoseconds ) : mixed

Retrasa la ejecución del programa por el nùmero de segundos y nanosegundos dados respectivamente por seconds y nanoseconds.

Parámetros

seconds

Debe ser un entero no negativo.

nanoseconds

Debe ser un entero positivo menor que mil millones (1000000000)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Si el retraso fue interrumpido por una señal se devolverá una matriz asociativa con los siguientes componentes:

  • seconds - número de segundos que quedan del retraso
  • nanoseconds - número de nanosegundos que quedan del retraso

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Ejemplos

Ejemplo #1 Ejemplo de time_nanosleep()

<?php
// ¡Cuidado! Esto no funcionará como se esperaba si se devuelve una matriz
if (time_nanosleep(0, 500000000)) {
    echo "Dormido durante medio segundo.\n";
}

// Esto es mejor:
if (time_nanosleep(0, 500000000) === true) {
    echo "Dormido durante medio segundo.\n";
}

// Y esto es el mejor:
$nano = time_nanosleep(2, 100000);

if ($nano === true) {
    echo "Dormido durante 2 segundos, 100 microsegundos.\n";
} elseif ($nano === false) {
    echo "Falló la dormida.\n";
} elseif (is_array($nano)) {
    $segundos = $nano['seconds'];
    $nanosegundos = $nano['nanoseconds'];
    echo "Interrumpido por una señal.\n";
    echo "Tiempo restante: $segundos segundos, $nanosegundos nanosegundos.";
}
?>

Ver también

  • sleep() - Retrasar la ejecución
  • usleep() - Retrasar la ejecución en microsegundos
  • time_sleep_until() - Hacer que el script duerma hasta el momento especificado
  • set_time_limit() - Limita el tiempo máximo de ejecución


Hacer que el script duerma hasta el momento especificado

  • « time_nanosleep
  • uniqid »
  • PHP Manual
  • Funciones Varias
  • Hacer que el script duerma hasta el momento especificado

time_sleep_until

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

time_sleep_until — Hacer que el script duerma hasta el momento especificado

Descripción

time_sleep_until ( float $timestamp ) : bool

Hace que el script duerma hasta la marca de tiempo especificada dada por timestamp.

Parámetros

timestamp

La marca de tiempo en la que el script debería despertar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Errores/Excepciones

Si la timestamp especificada está en el pasado, esta función generará un error de nivel E_WARNING.

Ejemplos

Ejemplo #1 Un ejemplo de time_sleep_until()

<?php

//devuelve false y genera una advertencia
var_dump(time_sleep_until(time()-1));

// puede funcionar solamente en ordenadores más rápidos, dormirá durante 0.2 segundos
var_dump(time_sleep_until(microtime(true)+0.2));

?>

Notas

Nota: Todas las señales serán emitidas después de que despierte el script.

Ver también

  • sleep() - Retrasar la ejecución
  • usleep() - Retrasar la ejecución en microsegundos
  • time_nanosleep() - Retrasar por un número de segundos y nanosegundos
  • set_time_limit() - Limita el tiempo máximo de ejecución


Generar un ID único

  • « time_sleep_until
  • unpack »
  • PHP Manual
  • Funciones Varias
  • Generar un ID único

uniqid

(PHP 4, PHP 5, PHP 7, PHP 8)

uniqid — Generar un ID único

Descripción

uniqid ( string $prefix = "" , bool $more_entropy = false ) : string

Obtiene un identificador único prefijado basado en la hora actual en microsegundos.

Advertencia

Esta función no crea valores de tipo string aleatorios ni impredecibles. Esta función no debe usarse con propósitos de seguridad. Use una función o generador aleatorios criptográficamente seguros y funciones hash criptográficamente seguras para crear ID de seguridad impredecibles.

Parámetros

prefix

Puede ser útil, por ejemplo, si se generan identificadores simultáneamente en varios hosts que podrían, por casualidad, generar el identificador en el mismo microsegundo.

Con un prefix vacío, el string devuelto tendrá una longitud de 13 caracteres. Si more_entropy es true, tendrá 23 caracteres.

more_entropy

Si está establecido a true, uniqid() añadirá entropía adicional (usando el generador congruente lineal combinado) al final del valor retornado, lo que incrementará la posibilidad de que el resultado sea único.

Valores devueltos

Devuelve el identificador único, como string.

Ejemplos

Ejemplo #1 Ejemplo de uniqid()

<?php
/* Un id único, como: 4b3403665fea6 */
printf("uniqid(): %s\r\n", uniqid());

/* También podemos prefijar el id único, esto es lo mismo que
 * hacer:
 *
 * $uniqid = $prefijo . uniqid();
 * $uniqid = uniqid($prefijo);
 */
printf("uniqid('php_'): %s\r\n", uniqid('php_'));

/* También podemos activar el parámetro more_entropy, que es
 * necesario en algunos sistemas, como Cygwin. Esto hace que uniqid()
 * produzca un valor como: 4b340550242239.64159797
 */
printf("uniqid('', true): %s\r\n", uniqid('', true));
?>

Notas

Precaución

Esta función no genera tokens criptográficamente seguros, de hecho, el valor devuelto, sin pasar ningún parámetro adicional, es ligeramente diferente del de microtime(). Si fuera necesario generar tokens criptográficamente seguros utilice openssl_random_pseudo_bytes().

Nota:

Bajo Cygwin, more_entropy debe ser establecido a true para que esta función funcione.


Desempaqueta datos de una cadena binaria

  • « uniqid
  • usleep »
  • PHP Manual
  • Funciones Varias
  • Desempaqueta datos de una cadena binaria

unpack

(PHP 4, PHP 5, PHP 7, PHP 8)

unpack — Desempaqueta datos de una cadena binaria

Descripción

unpack ( string $format , string $data ) : array

Desempaqueta desde una cadena binaria a una matriz de acuerdo a format.

Los datos desempaquetados son almacenados en una matriz asociativa. Para lograr esto es necesario nombrar los diferentes códigos de formato y separarlos con una barra /. Si estuviera presente un parámetro repetidor, cada una de las claves de la matriz tendría un número de secuencia tras el valor establecido.

Parámetros

format

Vea pack() para una explicación de los códigos de formato.

data

Los datos empaquetados.

Valores devueltos

Devuelve una matriz asociativa que contiene los elementos desempaquetados de la cadena binaria.

Historial de cambios

Versión Descripción
5.5.0

Cambios realizados para poner esta función en línea con Perl:

El código "a" ahora guarda bytes NULL sobrantes de cola.

El código "A" ahora elimina todos los espacios en blanco ASCII sobrantes de cola (espacios, tabulaciones, nuevas líneas, retorno de carro, y bytes NULL).

Se añadió en código "Z" para cadenas rellenadas con NULL, y elimina los bytes NULL sobrantes de cola.

Ejemplos

Ejemplo #1 Ejemplo de unpack()

<?php
$datosbinarios = "\x04\x00\xa0\x00";
$matriz = unpack("cchars/nint", $datosbinarios);
?>

La matriz resultante contendrá las entradas "chars" con el valor 4 e "int" con el valor 160.

Ejemplo #2 Ejemplo de unpack() con un repetidor

<?php
$datosbinarios = "\x04\x00\xa0\x00";
$matriz = unpack("c2chars/nint", $datosbinarios);
?>

La matriz resultante contendrá las entradas "chars1", "chars2" e "int".

Notas

Precaución

Note que PHP almacena internamente los valores enteros como valores con signo. Si desempaqueta un entero largo sin signo y es del mismo tamaño que los valores almacenados internamente por PHP, el resultado será un número negativo incluso si se especifica un valor sin signo al desempaquetar.

Precaución

Tenga en cuenta que si un elemento no tiene nombre, se usará una cadena vacía. Si hubiera más de un elemento sin nombre, esto significaría que se sobrescribirían algunos datos, ya que sus claves coincidirían, como ocurre en:

Ejemplo #3 Ejemplo unpack() con claves sin nombre

<?php
$datosbinarios = "\x32\x42\x00\xa0";
$matriz = unpack("c2/n", $datosbinarios);
var_dump($matriz);
?>

La matriz resultante contendrá las entradas "1" con el valor 160 y "2" con 66. El primer valor del especificador c quedaría sobrescrito por el primer valor del especificador n.

Ver también

  • pack() - Empaqueta información a una cadena binaria


Retrasar la ejecución en microsegundos

  • « unpack
  • Registro de cambios »
  • PHP Manual
  • Funciones Varias
  • Retrasar la ejecución en microsegundos

usleep

(PHP 4, PHP 5, PHP 7, PHP 8)

usleep — Retrasar la ejecución en microsegundos

Descripción

usleep ( int $micro_seconds ) : void

Retrasa la ejecución del programa durante el número de microsegundos dados.

Parámetros

micro_seconds

Tiempo de parada en microsegundos. Un microsegundo el la millonésima parte de un segundo.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de usleep()

<?php

// Hora actual
echo date('h:i:s') . "\n";

// Esperar 2 segundos
usleep(2000000);

// ¡De vuelta!
echo date('h:i:s') . "\n";

?>

El resultado del ejemplo sería:

11:13:28
11:13:30

Ver también

  • sleep() - Retrasar la ejecución
  • time_nanosleep() - Retrasar por un número de segundos y nanosegundos
  • time_sleep_until() - Hacer que el script duerma hasta el momento especificado
  • set_time_limit() - Limita el tiempo máximo de ejecución


Registro de cambios

A las clases/funciones/métodos de esta extensión se han realizado los siguientes cambios.

Version | Function | Description
7.0.0 | define | Están permitidos valores array.
5.6.3 | pack | Se añadieron los códigos "q", "Q", "J" y "P" para habilitar el trabajo con número de 64 bit.
5.5.0 | pack | Se añadió el código "Z" con funcionalidad equivalente a "a" por compatibilidad con Perl.
 | unpack | Cambios realizados para poner esta función en línea con Perl: El código "a" ahora guarda bytes NULL sobrantes de cola. El código "A" ahora elimina todos los espacios en blanco ASCII sobrantes de cola (espacios, tabulaciones, nuevas líneas, retorno de carro, y bytes NULL). Se añadió en código "Z" para cadenas rellenadas con NULL, y elimina los bytes NULL sobrantes de cola.
5.3.4 | sleep | Antes de PHP 5.3.4, en Windows, sleep siempre devuelve null cuando el sueño ha sucedido, si tener en cuenta si el sueño fue interrumpido o no.
5.3.0 | time_nanosleep | Esta función ahora está disponible en plataformas Windows.
 | time_sleep_until | Esta función ahora está disponible en plataformas Windows.


Seaslog

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Seaslog Funciones
    • seaslog_get_author — Get SeasLog author.
    • seaslog_get_version — Get SeasLog version.
  • SeasLog — The SeasLog class
    • SeasLog::alert — Record alert log information
    • SeasLog::analyzerCount — Get log count by level, log_path and key_word
    • SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order
    • SeasLog::closeLoggerStream — Manually release stream flow from logger
    • SeasLog::__construct — Description
    • SeasLog::critical — Record critical log information
    • SeasLog::debug — Record debug log information
    • SeasLog::__destruct — Description
    • SeasLog::emergency — Record emergency log information
    • SeasLog::error — Record error log information
    • SeasLog::flushBuffer — Flush logs buffer, dump to appender file, or send to remote api with tcp/udp
    • SeasLog::getBasePath — Get SeasLog base path.
    • SeasLog::getBuffer — Get the logs buffer in memory as array
    • SeasLog::getBufferEnabled — Determin if buffer enabled
    • SeasLog::getDatetimeFormat — Get SeasLog datetime format style
    • SeasLog::getLastLogger — Get SeasLog last logger path
    • SeasLog::getRequestID — Get SeasLog request_id differentiated requests
    • SeasLog::getRequestVariable — Get SeasLog request variable
    • SeasLog::info — Record info log information
    • SeasLog::log — The Common Record Log Function
    • SeasLog::notice — Record notice log information
    • SeasLog::setBasePath — Set SeasLog base path
    • SeasLog::setDatetimeFormat — Set SeasLog datetime format style
    • SeasLog::setLogger — Set SeasLog logger name
    • SeasLog::setRequestID — Set SeasLog request_id differentiated requests
    • SeasLog::setRequestVariable — Manually set SeasLog request variable
    • SeasLog::warning — Record warning log information


Introducción

The Seaslog is an effective,fast,stable log extension for PHP.

SeasLog requires PHP 5.2.0 or greater. Earlier versions may not work.

The log journal,which is usually the operate record of the system, software and the application record. Through the analysis of the log,it can facilitate users to understand the operation of the system, software and the application situation. If your application log is rich enough, it can also analyze the previous use’s operation behavior,type, regional distribution or other more information. The application log also points the multiple levels at the same time, you can easily get the application analysis of health status, timely find problems and quick positioning, and solve the problem, remedy the loss.

The error_log, syslog function which built in PHP is powerful and excellent performance, but due to various defects (error_log have no error level, no fixed format, syslog regardless of module, and mix with system log ), reducing a lot of flexibility , and can't meet the application requirements.

The good news is that there are a number of third-party log class library established to make up for the defects, such as log4php, plog, monolog (of course, there are many applications in the project development of the log class).

So is there a log of libraries meet the following requirements:

  • Modules, classification
  • Simple configuration(preferably without configuration)
  • Clear log format and easy understanding
  • Simple application and well performance
Seaslog just meet these demands.

What is provided at present:

  • In the PHP project, record the log specification and repidly.
  • Configure the default log directory and module
  • Specified log directory and capture current configuration
  • Preliminary analysis of the early warning framework
  • Efficient log buffer and convenient buffer debug
  • Follow the PSR-3 log interface specification
  • Automatically record error information
  • Automatically record abnormal information
  • Support Connect the TCP port, send with RFC5424
  • Support Connect the UDP port, send with RFC5424
  • Support RequestId differentiated requests
  • Support for log template customizations

Read More » SeasLog Document at Github.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/seaslog


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Seaslog Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
seaslog.appender | 1 | PHP_INI_SYSTEM |
seaslog.appender_retry | 0 | PHP_INI_ALL |
seaslog.level | 8 | PHP_INI_ALL |
seaslog.remote_host | 127.0.0.1 | PHP_INI_ALL |
seaslog.remote_port | 514 | PHP_INI_ALL |
seaslog.remote_timeout | 1 | PHP_INI_SYSTEM |
seaslog.default_basepath | /var/log/www | PHP_INI_SYSTEM |
seaslog.default_logger | default | PHP_INI_SYSTEM |
seaslog.default_template | %T | %L | %P | %Q | %t | %M | PHP_INI_SYSTEM |
seaslog.default_datetime_format | Y-m-d H:i:s | PHP_INI_SYSTEM |
seaslog.trace_error | 1 | PHP_INI_ALL |
seaslog.trace_exception | 0 | PHP_INI_SYSTEM |
seaslog.trace_notice | 0 | PHP_INI_ALL |
seaslog.trace_warning | 0 | PHP_INI_ALL |
seaslog.use_buffer | 0 | PHP_INI_SYSTEM |
seaslog.buffer_size | 0 | PHP_INI_ALL |
seaslog.buffer_disabled_in_cli | 0 | PHP_INI_SYSTEM |
seaslog.disting_type | 0 | PHP_INI_SYSTEM |
seaslog.disting_folder | 1 | PHP_INI_SYSTEM |
seaslog.disting_by_hour | 0 | PHP_INI_SYSTEM |
seaslog.recall_depth | 0 | PHP_INI_ALL |
seaslog.trim_wrap | 0 | PHP_INI_ALL |
seaslog.ignore_warning | 1 | PHP_INI_ALL |
seaslog.throw_exception | 1 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

seaslog.appender int

Switch the Record Log Data Store. 1File 2TCP 3UDP (Switch default 1)

SeasLog will send log to tcp://remote_host:remote_port or udp://remote_host:remote_port server, when seaslog.appender configured to `2 (TCP)` or `3 (UDP)`.

When SeasLog send log to TCP/UDP,style follow RFC5424. The `{logInfo}` affected by seaslog.default_template.

The log style finally formatted such as:
<15>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | DEBUG | 21423 | 599157af4e937 | 1466787583.322 | this is a neeke debug
<14>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | INFO | 21423 | 599157af4e937 | 1466787583.323 | this is a info log
<13>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | NOTICE | 21423 | 599157af4e937 | 1466787583.324 | this is a notice log
seaslog.appender_retry int

Record Log Retry Count. Default 0 (Do Not Retry)

seaslog.buffer_disabled_in_cli int

Disable buffer in cli. 1-Y 0-N(Default)

Switch the configure buffer_disabled_in_cli on. The buffer_disabled_in_cli switch default off. If switch buffer_disabled_in_cli on, and running in cli, seaslog.use_buffer setting will be discarded, Seaslog write to the Data Store IMMEDIATELY.

seaslog.buffer_size int

Configure the buffer_size with 100. The buffer_size default 0, it’s meaning don’t use buffer. If buffer_size > 0,SeasLog will rewritten down into the Data Store when the prerecorded log in memory count >= this buffer_size,and then refresh the memory poll.

seaslog.default_basepath string

Default Log Base Path. Defult "/var/log/www".

seaslog.default_datetime_format string

The DateTime Style. Default "Y-m-d H:i:s".

seaslog.default_logger string

Default Logger Path. Default "default".

seaslog.disting_by_hour int

Switch use the logger with hour. 1-Y 0-N(Default)

Nota:

seaslog.disting_by_hour = 1 Switch use Logger DisTing by hour. It’s meaning SeasLog will create the file each one hour.

seaslog.disting_folder int

Switch use the logger with folder. 1-Y(Default) 0-N

Nota:

seaslog.disting_folder = 1 Switch use Logger DisTing by folder, it’s meaning SeasLog will create the file deistic by folder, and when this configure close SeasLog will create file use underline connect Logger and Time like default_20180211.log.

seaslog.disting_type int

Switch use the logger with type. 1-Y 0-N(Default)

Nota:

seaslog.disting_type = 1 Switch use Logger DisTing by type, it’s meaning SeasLog will create the file deistic info\warn\error and the other type.

seaslog.ignore_warning int

Switch ignore SeasLog warning. 1-On(Default) 0-Off

Nota:

seaslog.ignore_warning = 1 Open a warning to ignore SeasLog itself. When directory permissions or receive server ports are blocked, they are ignored; when closed, a warning is thrown.

seaslog.level int

Record logger level. Default 8 (All of them). 0-EMERGENCY 1-ALERT 2-CRITICAL 3-ERROR 4-WARNING 5-NOTICE 6-INFO 7-DEBUG 8-ALL

Nota:

Tips: The configuration item has changed since the 1.7.0 version. Before the 1.7.0 version, the smaller the value, the more logs are taken according to the level: 0-all 1-debug 2-info 3-notice 4-warning 5-error 6-critical 7-alert 8-emergency Before the 1.7.0 version, Default 0 (All of them).

seaslog.recall_depth int

Log function recall depth.Will affected variable `LineNo` in `%F`. Default 0

seaslog.remote_host string

If you use Record TCP or UDP, configure this remote ip. Default "127.0.0.1"

seaslog.remote_port int

If you use Record TCP or UDP, configure this remote port. Default 514

seaslog.remote_timeout int

If you use Record TCP or UDP, configure this remote timeout. Default 1 second

seaslog.throw_exception int

Switch throw SeasLog exception. 1-On(Default) 0-Off

Nota:

seaslog.throw_exception = 1 Open an exception that throws the SeasLog to throw itself. When the directory authority or the receive server port is blocked, throw an exception; do not throw an exception when closed.

seaslog.trace_error int

Automatic Record final error with default logger. 1-Y(Default) 0-N

seaslog.trace_exception int

Automatic Record exception with default logger. 1-Y 0-N(Default)

seaslog.trace_notice int

Automatic Record notice with default logger. 1-Y 0-N(Default)

seaslog.trace_warning int

Automatic Record warning with default logger. 1-Y 0-N(Default)

seaslog.trim_wrap int

Trim the \n and \r in log message. 1-On 0-Off(Default)

seaslog.use_buffer int

Switch use the log buffer with memory. 1-Y 0-N(Default)

Nota:

seaslog.use_buffer = 1 Switch the configure use_buffer on. The use_buffer switch default off. If switch use_buffer on, SeasLog prerecord the log with memory, and them would be rewritten down into the Data Store by request shutdown or php process exit (PHP RSHUTDOWN or PHP MSHUTDOWN).

seaslog.default_template string

Default Log template. Default "%T | %L | %P | %Q | %t | %M".

Nota:

`SeasLog`The following default variables are provided, which can be used directly in the log template and replaced as a corresponding value when the log is eventually generated.

Default log template is:`seaslog.default_template = "%T | %L | %P | %Q | %t | %M"`, that's mean,default log style is:`{dateTime} | {level} | {pid} | {uniqid} | {timeStamp} | {logInfo}`

If you custom log template, such as:`seaslog.default_template = "[%T]:%L %P %Q %t %M" `, that's will mean,log style was custom as:`[{dateTime}]:{level} {pid} {uniqid} {timeStamp} {logInfo}`

Seaslog Default Variable Table
Variable Name | Description
%L | Level.
%M | Message.
%T | DateTime. Such as`2017-08-16 19:15:02`,affected by `seaslog.default_datetime_format`.
%t | Timestamp. Such as`1502882102.862`,accurate to milliseconds.
%Q | RequestId. To distinguish a single request, such as not invoking the `SeasLog::setRequestId($string)` function, the unique value generated by the built-in `static char *get_uniqid ()` function is used when the request is initialized.
%H | HostName.
%P | ProcessId.
%D | Domain:Port. Such as`www.cloudwise.com:80`; When Cli, Such as `cli`.
%R | Request URI. Such as`/app/user/signin`; When Cli it's the index script, Such as `CliIndex.php`.
%m | Request Method. Such as`Get`; When Cli it's the command script, Such as `/bin/bash`.
%I | Client IP; When Cli it's `local`. Priority value: HTTP_X_REAL_IP > HTTP_X_FORWARDED_FOR > REMOTE_ADDR
%F | FileName:LineNo. Such as `UserService.php:118`.
%U | MemoryUsage. byte. Call `zend_memory_usage`.
%u | PeakMemoryUsage. byte. Call `zend_memory_peak_usage`.
%C | `TODO` Class::Action. Such as `UserService::getUserInfo`


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SEASLOG_VERSION (string)
SEASLOG_AUTHOR (string)
SEASLOG_ALL (string)
"ALL"
SEASLOG_DEBUG (string)
"DEBUG" - Detailed debug information.Fine-grained information events.
SEASLOG_INFO (string)
"INFO" - Interesting events.Emphasizes the running process of the application.
SEASLOG_NOTICE (string)
"NOTICE" - Normal but significant events.Information that is more important than the INFO level during execution.
SEASLOG_WARNING (string)
"WARNING" - Exceptional occurrences that are not errors.Potentially aberrant information that needs attention and needs to be repaired.
SEASLOG_ERROR (string)
"ERROR" - Runtime errors that do not require immediate action but should typically.
SEASLOG_CRITICAL (string)
"CRITICAL" - Critical conditions.Need to be repaired immediately, and the program component is unavailable.
SEASLOG_ALERT (string)
"ALERT" - Action must be taken immediately.Immediate attention should be given to relevant personnel for emergency repairs.
SEASLOG_EMERGENCY (string)
"EMERGENCY" - System is unusable.
SEASLOG_DETAIL_ORDER_ASC (int)
1
SEASLOG_DETAIL_ORDER_DESC (int)
2
SEASLOG_APPENDER_FILE (int)
1
SEASLOG_APPENDER_TCP (int)
2
SEASLOG_APPENDER_UDP (int)
3
SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL (int)
1
SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN (int)
2
SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT (int)
1
SEASLOG_REQUEST_VARIABLE_REQUEST_URI (int)
2
SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD (int)
3
SEASLOG_REQUEST_VARIABLE_CLIENT_IP (int)
4


Ejemplos

Ejemplo #1 Get and set base path

<?php
  $basePath1 = SeasLog::getBasePath();

  SeasLog::setBasePath('/log/base_test');
  $basePath2 = SeasLog::getBasePath();

  var_dump($basePath1,$basePath2);

  ?>

El resultado del ejemplo sería algo similar a:

  string(12) "/var/log/www"
  string(14) "/log/base_test"

Ejemplo #2 Get and set logger

<?php
$lastLogger1 = SeasLog::getLastLogger();

SeasLog::setLogger('testModule/app1');
$lastLogger2 = SeasLog::getLastLogger();

var_dump($lastLogger1,$lastLogger2);

?>

El resultado del ejemplo sería algo similar a:

string(7) "default"
string(15) "testModule/app1"

Ejemplo #3 Fast write log

<?php
SeasLog::log(SEASLOG_ERROR,'this is a error test by ::log');
SeasLog::debug('this is a {userName} debug',array('{userName}' => 'neeke'));
SeasLog::info('this is a info log');
SeasLog::notice('this is a notice log');
SeasLog::warning('your {website} was down,please {action} it ASAP!',array('{website}' => 'github.com','{action}' => 'rboot'));
SeasLog::error('a error log');
SeasLog::critical('some thing was critical');
SeasLog::alert('yes this is a {messageName}',array('{messageName}' => 'alertMSG'));
SeasLog::emergency('Just now, the house next door was completely burnt out! {note}',array('{note}' => 'it`s a joke'));
?>

As the default, seaslog.default_template = "%T | %L | %P | %Q | %t | %M". That's mean,as the default,log record style is: `{dateTime} | {level} | {pid} | {uniqid} | {timeStamp} | {logInfo}`.

El resultado del ejemplo sería algo similar a:

seaslog.appender = 1

2014-07-27 08:53:52 | ERROR | 23625 | 599159975a9ff | 1406422432.786 | this is a error test by log
2014-07-27 08:53:52 | DEBUG | 23625 | 599159975a9ff | 1406422432.786 | this is a neeke debug
2014-07-27 08:53:52 | INFO | 23625 | 599159975a9ff | 1406422432.787 | this is a info log
2014-07-27 08:53:52 | NOTICE | 23625 | 599159975a9ff | 1406422432.787 | this is a notice log
2014-07-27 08:53:52 | WARNING | 23625 | 599159975a9ff | 1406422432.787 | your github.com was down,please rboot it ASAP!
2014-07-27 08:53:52 | ERROR | 23625 | 599159975a9ff | 1406422432.787 | a error log
2014-07-27 08:53:52 | CRITICAL | 23625 | 599159975a9ff | 1406422432.787 | some thing was critical
2014-07-27 08:53:52 | EMERGENCY | 23625 | 599159975a9ff | 1406422432.787 | Just now, the house next door was completely burnt out! it is a joke

El resultado del ejemplo sería algo similar a:

seaslog.appender = 2 or seaslog.appender = 3

The log style finally formatted such as:
<15>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | DEBUG | 21423 | 599157af4e937 | 1466787583.322 | this is a neeke debug
<14>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | INFO | 21423 | 599157af4e937 | 1466787583.323 | this is a info log
<13>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | NOTICE | 21423 | 599157af4e937 | 1466787583.324 | this is a notice log

Ejemplo #4 Fast count some type of log count value

SeasLog get count value of `grep -wc` use system pipe and return to PHP (array or int).

<?php
$countResult1 = SeasLog::analyzerCount();
$countResult2 = SeasLog::analyzerCount(SEASLOG_WARNING);
$countResult3 = SeasLog::analyzerCount(SEASLOG_ERROR,date('Ymd',time()));

var_dump($countResult1,$countResult2,$countResult3);

?>

El resultado del ejemplo sería algo similar a:

array(8) {
  ["DEBUG"]=>
  int(3)
  ["INFO"]=>
  int(3)
  ["NOTICE"]=>
  int(3)
  ["WARNING"]=>
  int(3)
  ["ERROR"]=>
  int(6)
  ["CRITICAL"]=>
  int(3)
  ["ALERT"]=>
  int(3)
  ["EMERGENCY"]=>
  int(3)
}
int(7)
int(1)

Ejemplo #5 Acquisit some type of log list

SeasLog get count value of `grep -w` use system pipe and return array to PHP.

<?php
$detailErrorArray = SeasLog::analyzerDetail(SEASLOG_ERROR);
var_dump($detailErrorArray);

var_dump(SeasLog::analyzerDetail(SEASLOG_ERROR,date('Ymd',time())));
?>

El resultado del ejemplo sería algo similar a:

array(6) {
  [0] =>
  string(83) "2014-02-24 00:14:02 | ERROR | 8568 | 599157af4e937 | 1393172042.717 | test error 3 "
  [1] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8594 | 5991576584446 | 1393172044.104 | test error 3 "
  [2] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8620 | 1502697015147 | 1393172044.862 | test error 3 "
  [3] =>
  string(83) "2014-02-24 00:14:05 | ERROR | 8646 | 599159975a9ff | 1393172045.989 | test error 3 "
  [4] =>
  string(83) "2014-02-24 00:14:07 | ERROR | 8672 | 599159986ec28 | 1393172047.882 | test error 3 "
  [5] =>
  string(83) "2014-02-24 00:14:08 | ERROR | 8698 | 5991599981cec | 1393172048.736 | test error 3 "
}

array(2) {
  [0] =>
  string(83) "2014-02-24 00:14:02 | ERROR | 8568 | 599157af4e937 | 1393172042.717 | test error 3 "
  [1] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8594 | 5991576584446 | 1393172044.104 | test error 3 "
}


Seaslog Funciones

Tabla de contenidos

  • seaslog_get_author — Get SeasLog author.
  • seaslog_get_version — Get SeasLog version.


Get SeasLog author.

  • « Seaslog Funciones
  • seaslog_get_version »
  • PHP Manual
  • Seaslog Funciones
  • Get SeasLog author.

seaslog_get_author

(PECL seaslog >=1.0.0)

seaslog_get_author — Get SeasLog author.

Descripción

seaslog_get_author ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return SeasLog author as string.

Ejemplos

Ejemplo #1 seaslog_get_author() example

<?php

var_dump(seaslog_get_author());

?>

El resultado del ejemplo sería algo similar a:

string(29) "Chitao.Gao  [ neeke@php.net ]"


Get SeasLog version.

  • « seaslog_get_author
  • SeasLog »
  • PHP Manual
  • Seaslog Funciones
  • Get SeasLog version.

seaslog_get_version

(PECL seaslog >=1.0.0)

seaslog_get_version — Get SeasLog version.

Descripción

seaslog_get_version ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return SeasLog version (SEASLOG_VERSION) as string.

Ejemplos

Ejemplo #1 seaslog_get_version() example

<?php

var_dump(seaslog_get_version());

?>

El resultado del ejemplo sería algo similar a:

string(5) "1.8.4"


The SeasLog class

(PECL seaslog >=1.0.0)

Introducción

Sinopsis de la Clase

SeasLog {
/* Métodos */
public static alert ( string $message , array $content = ? , string $logger = ? ) : bool
public static analyzerCount ( string $level , string $log_path = ? , string $key_word = ? ) : mixed
public static analyzerDetail ( string $level , string $log_path = ? , string $key_word = ? , int $start = ? , int $limit = ? , int $order = ? ) : mixed
public static closeLoggerStream ( int $model , string $logger ) : bool
public static critical ( string $message , array $content = ? , string $logger = ? ) : bool
public static debug ( string $message , array $content = ? , string $logger = ? ) : bool
public __destruct ( )
public static emergency ( string $message , array $content = ? , string $logger = ? ) : bool
public static error ( string $message , array $content = ? , string $logger = ? ) : bool
public static flushBuffer ( ) : bool
public static Seaslog::getBasePath ( ) : string
public static getBuffer ( ) : array
public static getBufferEnabled ( ) : bool
public static getDatetimeFormat ( ) : string
public static getLastLogger ( ) : string
public static getRequestID ( ) : string
public static getRequestVariable ( int $key ) : bool
public static info ( string $message , array $content = ? , string $logger = ? ) : bool
public static log ( string $level , string $message = ? , array $content = ? , string $logger = ? ) : bool
public static notice ( string $message , array $content = ? , string $logger = ? ) : bool
public static setBasePath ( string $base_path ) : bool
public static setDatetimeFormat ( string $format ) : bool
public static setLogger ( string $logger ) : bool
public static setRequestID ( string $request_id ) : bool
public static setRequestVariable ( int $key , string $value ) : bool
public static warning ( string $message , array $content = ? , string $logger = ? ) : bool
}

Tabla de contenidos

  • SeasLog::alert — Record alert log information
  • SeasLog::analyzerCount — Get log count by level, log_path and key_word
  • SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order
  • SeasLog::closeLoggerStream — Manually release stream flow from logger
  • SeasLog::__construct — Description
  • SeasLog::critical — Record critical log information
  • SeasLog::debug — Record debug log information
  • SeasLog::__destruct — Description
  • SeasLog::emergency — Record emergency log information
  • SeasLog::error — Record error log information
  • SeasLog::flushBuffer — Flush logs buffer, dump to appender file, or send to remote api with tcp/udp
  • SeasLog::getBasePath — Get SeasLog base path.
  • SeasLog::getBuffer — Get the logs buffer in memory as array
  • SeasLog::getBufferEnabled — Determin if buffer enabled
  • SeasLog::getDatetimeFormat — Get SeasLog datetime format style
  • SeasLog::getLastLogger — Get SeasLog last logger path
  • SeasLog::getRequestID — Get SeasLog request_id differentiated requests
  • SeasLog::getRequestVariable — Get SeasLog request variable
  • SeasLog::info — Record info log information
  • SeasLog::log — The Common Record Log Function
  • SeasLog::notice — Record notice log information
  • SeasLog::setBasePath — Set SeasLog base path
  • SeasLog::setDatetimeFormat — Set SeasLog datetime format style
  • SeasLog::setLogger — Set SeasLog logger name
  • SeasLog::setRequestID — Set SeasLog request_id differentiated requests
  • SeasLog::setRequestVariable — Manually set SeasLog request variable
  • SeasLog::warning — Record warning log information


Record alert log information

  • « SeasLog
  • SeasLog::analyzerCount »
  • PHP Manual
  • SeasLog
  • Record alert log information

SeasLog::alert

(PECL seaslog >=1.0.0)

SeasLog::alert — Record alert log information

Descripción

public static SeasLog::alert ( string $message , array $content = ? , string $logger = ? ) : bool

Record alert log information.

Nota:

"ALERT" - Action must be taken immediately. Immediate attention should be given to relevant personnel for emergency repairs.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::alert() example

<?php

var_dump(SeasLog::alert('log message'));

//with content
var_dump(SeasLog::alert('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::alert('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


Get log count by level, log_path and key_word

  • « SeasLog::alert
  • SeasLog::analyzerDetail »
  • PHP Manual
  • SeasLog
  • Get log count by level, log_path and key_word

SeasLog::analyzerCount

(PECL seaslog >=1.1.6)

SeasLog::analyzerCount — Get log count by level, log_path and key_word

Descripción

public static SeasLog::analyzerCount ( string $level , string $log_path = ? , string $key_word = ? ) : mixed

`SeasLog` get count value of `grep -ai '{level}' | grep -aic '{key_word}'` use system pipe and return to PHP (array or int).

Parámetros

level

String. The log information level.

log_path

String. The log information path.

key_word

String. The search key word for log information.

Valores devueltos

If `level` is SEASLOG_ALL or Empty, return all levels count as `array`. If `level` is SEASLOG_INFO or the other level, return count as `int`.

Ejemplos

Ejemplo #1 SeasLog::analyzerCount() example

<?php

$countResult1 = SeasLog::analyzerCount();

//with `level`
$countResult2 = SeasLog::analyzerCount(SEASLOG_DEBUG);

//with `level` and `log_path`
$countResult3 = SeasLog::analyzerCount(SEASLOG_ERROR,date('Ymd',time()));

//with `level` and `key_word`
$countResult4 = SeasLog::analyzerCount(SEASLOG_DEBUG,NULL,'accessToken');

var_dump($countResult1,$countResult2,$countResult3,$countResult4);

?>

El resultado del ejemplo sería algo similar a:

array(8) {
  ["DEBUG"]=>
  int(180)
  ["INFO"]=>
  int(214)
  ["NOTICE"]=>
  int(0)
  ["WARNING"]=>
  int(0)
  ["ERROR"]=>
  int(228)
  ["CRITICAL"]=>
  int(244)
  ["ALERT"]=>
  int(1)
  ["EMERGENCY"]=>
  int(0)
}

int(180)

int(228)

int(29)

Ver también

  • SeasLog::analyzerDetail() - Get log detail by level, log_path, key_word, start, limit, order


Get log detail by level, log_path, key_word, start, limit, order

  • « SeasLog::analyzerCount
  • SeasLog::closeLoggerStream »
  • PHP Manual
  • SeasLog
  • Get log detail by level, log_path, key_word, start, limit, order

SeasLog::analyzerDetail

(PECL seaslog >=1.1.6)

SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order

Descripción

public static SeasLog::analyzerDetail ( string $level , string $log_path = ? , string $key_word = ? , int $start = ? , int $limit = ? , int $order = ? ) : mixed

`SeasLog` get results of `grep -ai '{level}' | grep -ai '{key_word}' | sed -n '{start},{limit}'p` use system pipe and return array to PHP.

Parámetros

level

String. The log information level.

log_path

String. The log information path.

key_word

String. The search key word for log information.

start

Int. Default is `1`.

limit

Int. Default is `20`.

order

Int. Default is SEASLOG_DETAIL_ORDER_ASC. See also:

  • SEASLOG_DETAIL_ORDER_ASC
  • SEASLOG_DETAIL_ORDER_DESC

Valores devueltos

Return results as array.

Nota:

When `start`,`limit` is not NULL and in Windows, SeasLog will threw exception with message 'Param start and limit don't support Windows'.

Ejemplos

Ejemplo #1 SeasLog::analyzerDetail() example

<?php

$result1 = SeasLog::analyzerDetail(SEASLOG_ERROR);

//with `logger` and `key_word`
$result2 = SeasLog::analyzerDetail(SEASLOG_ERROR,'test/logger/','neeke');

//with `start` and `limit`
$result3 = SeasLog::analyzerDetail(SEASLOG_ERROR,'test/logger/','neeke',1,2);

var_dump($result1,$result2,$result3);
?>

El resultado del ejemplo sería algo similar a:

array(20) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
  [2]=>
  string(93) "2018-07-09 12:52:55 | ERROR | 12265 | 5b42ea277b8d4 | 1531111975.506 | log message from neeke"
  [3]=>
  string(104) "2018-07-09 12:52:55 | ERROR | 12274 | 5b42ea27db5dc | 1531111975.898 | log message from the other people"
...
}

array(3) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
  [2]=>
  string(93) "2018-07-09 12:52:55 | ERROR | 12265 | 5b42ea277b8d4 | 1531111975.506 | log message from neeke"
}

array(2) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
}

Ver también

  • SeasLog::analyzerCount() - Get log count by level, log_path and key_word


Manually release stream flow from logger

  • « SeasLog::analyzerDetail
  • SeasLog::__construct »
  • PHP Manual
  • SeasLog
  • Manually release stream flow from logger

SeasLog::closeLoggerStream

(PECL seaslog >=1.8.6)

SeasLog::closeLoggerStream — Manually release stream flow from logger

Descripción

public static SeasLog::closeLoggerStream ( int $model , string $logger ) : bool

Manually release stream flow from logger. SeasLog caches the stream handle opened by the log logger to save the overhead of creating a stream. The handle will be automatically released at the end of the request. If in CLI mode, the process will also automatically release when it exits. Or you can use the following functions to manually release(manually release function needs to update SeasLog 1.8.6 or updated version).

Parámetros

model

Constant int.

  • SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL
  • SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN

logger

The logger name.

Valores devueltos

Return TRUE on released stream flow success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::closeLoggerStream() example

<?php

var_dump(SeasLog::closeLoggerStream());
var_dump(SeasLog::closeLoggerStream(SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL));
var_dump(SeasLog::closeLoggerStream(SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN, 'logger_name'));

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)

Ver también

  • SeasLog::setLogger() - Set SeasLog logger name
  • SeasLog::getLastLogger() - Get SeasLog last logger path


Description

  • « SeasLog::closeLoggerStream
  • SeasLog::critical »
  • PHP Manual
  • SeasLog
  • Description

SeasLog::__construct

(PECL seaslog >=1.0.0)

SeasLog::__construct — Description

Descripción

public SeasLog::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Ejemplos

Ejemplo #1 SeasLog::__construct() example

<?php

/* ... */

?>

El resultado del ejemplo sería algo similar a:

...


Record critical log information

  • « SeasLog::__construct
  • SeasLog::debug »
  • PHP Manual
  • SeasLog
  • Record critical log information

SeasLog::critical

(PECL seaslog >=1.0.0)

SeasLog::critical — Record critical log information

Descripción

public static SeasLog::critical ( string $message , array $content = ? , string $logger = ? ) : bool

Record critical log information.

Nota:

"CRITICAL" - Critical conditions.Need to be repaired immediately, and the program component is unavailable.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::critical() example

<?php

var_dump(SeasLog::critical('log message'));

//with content
var_dump(SeasLog::critical('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::critical('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


Record debug log information

  • « SeasLog::critical
  • SeasLog::__destruct »
  • PHP Manual
  • SeasLog
  • Record debug log information

SeasLog::debug

(PECL seaslog >=1.0.0)

SeasLog::debug — Record debug log information

Descripción

public static SeasLog::debug ( string $message , array $content = ? , string $logger = ? ) : bool

Record debug log information.

Nota:

"DEBUG" - Detailed debug information.Fine-grained information events.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::debug() example

<?php

var_dump(SeasLog::debug('log message'));

//with content
var_dump(SeasLog::debug('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::debug('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


Description

  • « SeasLog::debug
  • SeasLog::emergency »
  • PHP Manual
  • SeasLog
  • Description

SeasLog::__destruct

(PECL seaslog >=1.0.0)

SeasLog::__destruct — Description

Descripción

public SeasLog::__destruct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 SeasLog::__destruct() example

<?php

/* ... */

?>

El resultado del ejemplo sería algo similar a:

...


Record emergency log information

  • « SeasLog::__destruct
  • SeasLog::error »
  • PHP Manual
  • SeasLog
  • Record emergency log information

SeasLog::emergency

(PECL seaslog >=1.0.0)

SeasLog::emergency — Record emergency log information

Descripción

public static SeasLog::emergency ( string $message , array $content = ? , string $logger = ? ) : bool

Record emergency log information.

Nota:

"EMERGENCY" - System is unusable.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::emergency() example

<?php

var_dump(SeasLog::emergency('log message'));

//with content
var_dump(SeasLog::emergency('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::emergency('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::log() - The Common Record Log Function


Record error log information

  • « SeasLog::emergency
  • SeasLog::flushBuffer »
  • PHP Manual
  • SeasLog
  • Record error log information

SeasLog::error

(PECL seaslog >=1.0.0)

SeasLog::error — Record error log information

Descripción

public static SeasLog::error ( string $message , array $content = ? , string $logger = ? ) : bool

Record error log information.

Nota:

"ERROR" - Runtime errors that do not require immediate action but should typically.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::error() example

<?php

var_dump(SeasLog::error('log message'));

//with content
var_dump(SeasLog::error('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::error('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


Flush logs buffer, dump to appender file, or send to remote api with tcp/udp

  • « SeasLog::error
  • SeasLog::getBasePath »
  • PHP Manual
  • SeasLog
  • Flush logs buffer, dump to appender file, or send to remote api with tcp/udp

SeasLog::flushBuffer

(PECL seaslog >=1.0.0)

SeasLog::flushBuffer — Flush logs buffer, dump to appender file, or send to remote api with tcp/udp

Descripción

public static SeasLog::flushBuffer ( ) : bool

Flush logs buffer by seaslog.appender: dump to file, or send to remote api with tcp/udp.

Nota:

See also: seaslog.appender_retry seaslog.remote_host seaslog.remote_port

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return TRUE on flush buffer success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::flushBuffer() example

<?php

SeasLog::info('info log');
SeasLog::debug('debug log');
var_dump(SeasLog::getBuffer());
var_dump(SeasLog::flushBuffer());
var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(79) "2018-07-07 10:47:58 | INFO | 71910 | 5b4029ded6009 | 1530931678.877 | info log
"
    [1]=>
    string(81) "2018-07-07 10:47:58 | DEBUG | 71910 | 5b4029ded6009 | 1530931678.877 | debug log
"
  }
}
bool(true)
array(0) {
}

Ver también

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBufferEnabled() - Determin if buffer enabled
  • SeasLog::getBuffer() - Get the logs buffer in memory as array


Get SeasLog base path.

  • « SeasLog::flushBuffer
  • SeasLog::getBuffer »
  • PHP Manual
  • SeasLog
  • Get SeasLog base path.

SeasLog::getBasePath

(PECL seaslog >=1.0.0)

SeasLog::getBasePath — Get SeasLog base path.

Descripción

public static Seaslog::getBasePath ( ) : string

Use the Function SeasLog::getBasePath() will get the value of seaslog.default_basepath what configured in php.ini(seaslog.ini).

If you use Seaslog::setBasePath(), will change the result.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return seaslog.default_basepath as string.

Ejemplos

Ejemplo #1 SeasLog::getBasePath() example

<?php

var_dump(SeasLog::getBasePath());

?>

El resultado del ejemplo sería algo similar a:

string(12) "/var/log/www"


Get the logs buffer in memory as array

  • « SeasLog::getBasePath
  • SeasLog::getBufferEnabled »
  • PHP Manual
  • SeasLog
  • Get the logs buffer in memory as array

SeasLog::getBuffer

(PECL seaslog >=1.0.0)

SeasLog::getBuffer — Get the logs buffer in memory as array

Descripción

public static SeasLog::getBuffer ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return an array from logs buffer in memory.

Ejemplos

Ejemplo #1 SeasLog::getBuffer() example

<?php

var_dump(SeasLog::info('info log'));
var_dump(SeasLog::debug('debug log'));
var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(79) "2018-07-07 10:43:32 | INFO | 71785 | 5b4028d4c58d5 | 1530931412.810 | info log
"
    [1]=>
    string(81) "2018-07-07 10:43:32 | DEBUG | 71785 | 5b4028d4c58d5 | 1530931412.810 | debug log
"
  }
}

Ver también

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBufferEnabled() - Determin if buffer enabled
  • SeasLog::flushBuffer() - Flush logs buffer, dump to appender file, or send to remote api with tcp/udp


Determin if buffer enabled

  • « SeasLog::getBuffer
  • SeasLog::getDatetimeFormat »
  • PHP Manual
  • SeasLog
  • Determin if buffer enabled

SeasLog::getBufferEnabled

(PECL seaslog >=1.0.0)

SeasLog::getBufferEnabled — Determin if buffer enabled

Descripción

public static SeasLog::getBufferEnabled ( ) : bool

Result join seaslog.use_buffer and seaslog.buffer_disabled_in_cli.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return TRUE on seaslog.use_buffer is true. If switch seaslog.buffer_disabled_in_cli on, and running in cli, seaslog.use_buffer setting will be discarded, Seaslog write to the Data Store IMMEDIATELY.

Ejemplos

Ejemplo #1 SeasLog::getBufferEnabled() example

<?php

var_dump(SeasLog::getBufferEnabled());

?>

El resultado del ejemplo sería algo similar a:

bool(false)

Ver también

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBuffer() - Get the logs buffer in memory as array
  • SeasLog::flushBuffer() - Flush logs buffer, dump to appender file, or send to remote api with tcp/udp


Get SeasLog datetime format style

  • « SeasLog::getBufferEnabled
  • SeasLog::getLastLogger »
  • PHP Manual
  • SeasLog
  • Get SeasLog datetime format style

SeasLog::getDatetimeFormat

(PECL seaslog >=1.0.0)

SeasLog::getDatetimeFormat — Get SeasLog datetime format style

Descripción

public static SeasLog::getDatetimeFormat ( ) : string

Get SeasLog datetime format style. Use the Function SeasLog::getDatetimeFormat() will get the value of seaslog.default_datetime_format what configured in php.ini(seaslog.ini).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Get SeasLog datetime format style of seaslog.default_datetime_format. Use the Function SeasLog::setDatetimeFormat() will change this value.

Ejemplos

Ejemplo #1 SeasLog::getDatetimeFormat() example

<?php

var_dump(SeasLog::getDateTimeFormat());
var_dump(SeasLog::setDateTimeFormat('Ymd His'));
var_dump(SeasLog::getDateTimeFormat());

?>

El resultado del ejemplo sería algo similar a:

string(11) "Y-m-d H:i:s"
bool(true)
string(7) "Ymd His"

Ver también

  • SeasLog::setDatetimeFormat() - Set SeasLog datetime format style


Get SeasLog last logger path

  • « SeasLog::getDatetimeFormat
  • SeasLog::getRequestID »
  • PHP Manual
  • SeasLog
  • Get SeasLog last logger path

SeasLog::getLastLogger

(PECL seaslog >=1.0.0)

SeasLog::getLastLogger — Get SeasLog last logger path

Descripción

public static SeasLog::getLastLogger ( ) : string

Use the Function SeasLog::getLastLogger() will get the value of seaslog.default_logger what configured in php.ini(seaslog.ini).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Use the Function SeasLog::setLogger() will change the value of function SeasLog::getLastLogger().

Ejemplos

Ejemplo #1 SeasLog::getLastLogger() example

<?php

var_dump(SeasLog::getLastLogger());
SeasLog::setLogger('theNewLogger');
var_dump(SeasLog::getLastLogger());
?>

El resultado del ejemplo sería algo similar a:

string(7) "default"
string(12) "theNewLogger"

Ver también

  • SeasLog::setLogger() - Set SeasLog logger name


Get SeasLog request_id differentiated requests

  • « SeasLog::getLastLogger
  • SeasLog::getRequestVariable »
  • PHP Manual
  • SeasLog
  • Get SeasLog request_id differentiated requests

SeasLog::getRequestID

(PECL seaslog >=1.0.0)

SeasLog::getRequestID — Get SeasLog request_id differentiated requests

Descripción

public static SeasLog::getRequestID ( ) : string

To distinguish a single request, such as not invoking the SeasLog::setRequestId() function, the unique value generated by the built-in `static char *get_uniqid ()` function is used when the request is initialized.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return string generated by the built-in `static char *get_uniqid ()` function, or setted by SeasLog::setRequestId() function.

Ejemplos

Ejemplo #1 SeasLog::getRequestID() example

<?php

var_dump(SeasLog::getRequestID());
var_dump(SeasLog::setRequestID('reqeust_id_test_'.time()))
var_dump(SeasLog::getRequestID());

?>

El resultado del ejemplo sería algo similar a:

string(13) "5b3f21a209519"
bool(true)
string(26) "reqeust_id_test_1530864034"

Ver también

  • SeasLog::setRequestID() - Set SeasLog request_id differentiated requests
  • The Variable `%Q` in Seaslog Default Variable Table.


Get SeasLog request variable

  • « SeasLog::getRequestID
  • SeasLog::info »
  • PHP Manual
  • SeasLog
  • Get SeasLog request variable

SeasLog::getRequestVariable

(PECL seaslog >=1.9.0)

SeasLog::getRequestVariable — Get SeasLog request variable

Descripción

public static SeasLog::getRequestVariable ( int $key ) : bool

Get SeasLog request variable.

Parámetros

key

Constant int.

  • SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT
  • SEASLOG_REQUEST_VARIABLE_REQUEST_URI
  • SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD
  • SEASLOG_REQUEST_VARIABLE_CLIENT_IP

Valores devueltos

Return request variable value on set success.

Ejemplos

Ejemplo #1 SeasLog::getRequestVariable() example

<?php

$sDomainPort = 'domain:port';
$sRequestUri = 'uri';
$sRequestMethod = 'method';
$sClientIp = 'client_ip';

$iErrorKey = 1000;

$oSeasLog = new SeasLog();

var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT, $sDomainPort));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI, $sRequestUri));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD, $sRequestMethod));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP, $sClientIp));

var_dump($oSeasLog->setRequestVariable($iErrorKey,NULL));

var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT) == $sDomainPort);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI) == $sRequestUri);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD) == $sRequestMethod);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP) == $sClientIp);

var_dump($oSeasLog->getRequestVariable($iErrorKey));

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(false)

Ver también

  • SeasLog::setRequestVariable() - Manually set SeasLog request variable


Record info log information

  • « SeasLog::getRequestVariable
  • SeasLog::log »
  • PHP Manual
  • SeasLog
  • Record info log information

SeasLog::info

(PECL seaslog >=1.0.0)

SeasLog::info — Record info log information

Descripción

public static SeasLog::info ( string $message , array $content = ? , string $logger = ? ) : bool

Record info log information.

Nota:

"INFO" - Interesting events.Emphasizes the running process of the application.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::info() example

<?php

var_dump(SeasLog::info('log message'));

//with content
var_dump(SeasLog::info('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::info('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


The Common Record Log Function

  • « SeasLog::info
  • SeasLog::notice »
  • PHP Manual
  • SeasLog
  • The Common Record Log Function

SeasLog::log

(PECL seaslog >=1.0.0)

SeasLog::log — The Common Record Log Function

Descripción

public static SeasLog::log ( string $level , string $message = ? , array $content = ? , string $logger = ? ) : bool

The Common Record Log Function.

Parámetros

level

Can use level in:

  • SEASLOG_DEBUG
  • SEASLOG_INFO
  • SEASLOG_NOTICE
  • SEASLOG_WARNING
  • SEASLOG_ERROR
  • SEASLOG_CRITICAL
  • SEASLOG_ALERT
  • SEASLOG_EMERGENCY
Or you can create a new level self-help.

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::log() example

<?php

var_dump(SeasLog::log(SEASLOG_INFO,'info log'));
var_dump(SeasLog::getBuffer());

//create a new level self-help.
var_dump(SeasLog::log('MySelfLevel','info log'));
var_dump(SeasLog::getBuffer());

//with `content`
var_dump(SeasLog::log('MySelfLevel','info log {NAME}',array('NAME' => 'neeke')));
var_dump(SeasLog::getBuffer());

//with `logger`
var_dump(SeasLog::log('MySelfLevel','info log {NAME}',array('NAME' => 'neeke'),'tmp_logger'));
var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(79) "2018-07-07 11:12:37 | INFO | 72427 | 5b402fa56a2ea | 1530933157.436 | info log
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(86) "2018-07-07 11:13:59 | MySelfLevel | 72470 | 5b402ff781c5e | 1530933239.532 | info log
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:28:12 | MySelfLevel | 72833 | 5b40334ce6a2f | 1530934092.946 | info log neeke
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(86) "2018-07-07 11:20:12 | INFO | 72616 | 5b40316c3641e | 1530933612.222 | info log neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information


Record notice log information

  • « SeasLog::log
  • SeasLog::setBasePath »
  • PHP Manual
  • SeasLog
  • Record notice log information

SeasLog::notice

(PECL seaslog >=1.0.0)

SeasLog::notice — Record notice log information

Descripción

public static SeasLog::notice ( string $message , array $content = ? , string $logger = ? ) : bool

Record notice log information.

Nota:

"NOTICE" - Normal but significant events.Information that is more important than the INFO level during execution.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::notice() example

<?php

var_dump(SeasLog::notice('log message'));

//with content
var_dump(SeasLog::notice('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::notice('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


Set SeasLog base path

  • « SeasLog::notice
  • SeasLog::setDatetimeFormat »
  • PHP Manual
  • SeasLog
  • Set SeasLog base path

SeasLog::setBasePath

(PECL seaslog >=1.0.0)

SeasLog::setBasePath — Set SeasLog base path

Descripción

public static SeasLog::setBasePath ( string $base_path ) : bool

Set SeasLog base path.

Parámetros

base_path

String.

Valores devueltos

Return TRUE on setted base path success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::setBasePath() example

<?php

/* ... */

?>

El resultado del ejemplo sería algo similar a:

...


Set SeasLog datetime format style

  • « SeasLog::setBasePath
  • SeasLog::setLogger »
  • PHP Manual
  • SeasLog
  • Set SeasLog datetime format style

SeasLog::setDatetimeFormat

(PECL seaslog >=1.0.0)

SeasLog::setDatetimeFormat — Set SeasLog datetime format style

Descripción

public static SeasLog::setDatetimeFormat ( string $format ) : bool

Set SeasLog datetime format style.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

format

String. Such as `Y-m-d H:i:s` or `Ymd His`. See also first param `format` at date().

Valores devueltos

Return TRUE on setted datetime format success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::setDatetimeFormat() example

<?php

var_dump(SeasLog::setDateTimeFormat('Ymd His'));

?>

El resultado del ejemplo sería algo similar a:

bool(true)

Ver también

  • SeasLog::getDateTimeFormat() - Get SeasLog datetime format style


Set SeasLog logger name

  • « SeasLog::setDatetimeFormat
  • SeasLog::setRequestID »
  • PHP Manual
  • SeasLog
  • Set SeasLog logger name

SeasLog::setLogger

(PECL seaslog >=1.0.0)

SeasLog::setLogger — Set SeasLog logger name

Descripción

public static SeasLog::setLogger ( string $logger ) : bool

Use the Function SeasLog::setLogger() will change the value of function SeasLog::getLastLogger(). Than's mean, SeasLog will record loginfo into the logger directory.

Parámetros

logger

Logger name.

Valores devueltos

Return TRUE on created logger disectory success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::setLogger() example

<?php

var_dump(SeasLog::setLogger('testModule/testLogger'));

?>

El resultado del ejemplo sería algo similar a:

bool(true)

Ver también

  • SeasLog::getLastLogger() - Get SeasLog last logger path
  • SeasLog::closeLoggerStream() - Manually release stream flow from logger


Set SeasLog request_id differentiated requests

  • « SeasLog::setLogger
  • SeasLog::setRequestVariable »
  • PHP Manual
  • SeasLog
  • Set SeasLog request_id differentiated requests

SeasLog::setRequestID

(PECL seaslog >=1.0.0)

SeasLog::setRequestID — Set SeasLog request_id differentiated requests

Descripción

public static SeasLog::setRequestID ( string $request_id ) : bool

To distinguish a single request, such as not invoking the SeasLog::setRequestId() function, the unique value generated by the built-in `static char *get_uniqid ()` function is used when the request is initialized.

Parámetros

request_id

String.

Valores devueltos

Return TRUE on set request_id success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::setRequestID() example

<?php

var_dump(SeasLog::setRequestID(time() . rand()));

?>

El resultado del ejemplo sería algo similar a:

bool(true)

Ver también

  • SeasLog::getRequestID() - Get SeasLog request_id differentiated requests


Manually set SeasLog request variable

  • « SeasLog::setRequestID
  • SeasLog::warning »
  • PHP Manual
  • SeasLog
  • Manually set SeasLog request variable

SeasLog::setRequestVariable

(PECL seaslog >=1.9.0)

SeasLog::setRequestVariable — Manually set SeasLog request variable

Descripción

public static SeasLog::setRequestVariable ( int $key , string $value ) : bool

Manually set SeasLog request variable.

Parámetros

key

Constant int.

  • SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT
  • SEASLOG_REQUEST_VARIABLE_REQUEST_URI
  • SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD
  • SEASLOG_REQUEST_VARIABLE_CLIENT_IP

value

The request variable value.

Valores devueltos

Return TRUE on set success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::setRequestVariable() example

<?php

$sDomainPort = 'domain:port';
$sRequestUri = 'uri';
$sRequestMethod = 'method';
$sClientIp = 'client_ip';

$iErrorKey = 1000;

$oSeasLog = new SeasLog();

var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT, $sDomainPort));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI, $sRequestUri));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD, $sRequestMethod));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP, $sClientIp));

var_dump($oSeasLog->setRequestVariable($iErrorKey,NULL));

var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT) == $sDomainPort);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI) == $sRequestUri);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD) == $sRequestMethod);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP) == $sClientIp);

var_dump($oSeasLog->getRequestVariable($iErrorKey));

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(false)

Ver también

  • SeasLog::getRequestVariable() - Get SeasLog request variable


Record warning log information

  • « SeasLog::setRequestVariable
  • SPL »
  • PHP Manual
  • SeasLog
  • Record warning log information

SeasLog::warning

(PECL seaslog >=1.0.0)

SeasLog::warning — Record warning log information

Descripción

public static SeasLog::warning ( string $message , array $content = ? , string $logger = ? ) : bool

Record warning log information.

Nota:

"WARNING" - Exceptional occurrences that are not errors. Potentially aberrant information that needs attention and needs to be repaired.

Parámetros

message

The log message.

content

The `message` contain placeholders which implementors replace with values from content array. Sush as `message` is `log info from {NAME}` and `content` is `array('NAME' => neeke)`, the log information will `log info from neeke`.

logger

The `logger` cased by the third param would be used right this right now, like a temp logger, when the function SeasLog::setLogger() called in pre content. If `logger` NULL or "", SeasLog will use lastest logger setted by SeasLog::setLogger().

Valores devueltos

Return TRUE on record log information success, FALSE on failure.

Ejemplos

Ejemplo #1 SeasLog::warning() example

<?php

var_dump(SeasLog::warning('log message'));

//with content
var_dump(SeasLog::warning('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::warning('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

Ver también

  • seaslog.default_template
  • SeasLog::debug() - Record debug log information
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - Record notice log information
  • SeasLog::error() - Record error log information
  • SeasLog::critical() - Record critical log information
  • SeasLog::alert() - Record alert log information
  • SeasLog::emergency() - Record emergency log information
  • SeasLog::log() - The Common Record Log Function


SPL - Biblioteca estándar de PHP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Estructuras de datos
    • SplDoublyLinkedList — La clase SplDoublyLinkedList
    • SplStack — La clase SplStack
    • SplQueue — La clase SplQueue
    • SplHeap — La clase SplHeap
    • SplMaxHeap — la clase SplMaxHeap
    • SplMinHeap — La clase SplMinHeap
    • SplPriorityQueue — la clase SplPriorityQueue
    • SplFixedArray — La clase SplFixedArray
    • SplObjectStorage — La clase SplObjectStorage
  • Iteradores
    • AppendIterator — La clase AppendIterator
    • ArrayIterator — La clase ArrayIterator
    • CachingIterator — La clase CachingIterator
    • CallbackFilterIterator — La clase CallbackFilterIterator
    • DirectoryIterator — La clase DirectoryIterator
    • EmptyIterator — La clase EmptyIterator
    • FilesystemIterator — La clase FilesystemIterator
    • FilterIterator — The FilterIterator class
    • GlobIterator — La clase GlobIterator
    • InfiniteIterator — La clase InfiniteIterator
    • IteratorIterator — La clase IteratorIterator
    • LimitIterator — La clase LimitIterator
    • MultipleIterator — La clase MultipleIterator
    • NoRewindIterator — La clase NoRewindIterator
    • ParentIterator — La clase ParentIterator
    • RecursiveArrayIterator — La clase RecursiveArrayIterator
    • RecursiveCachingIterator — La clase RecursiveCachingIterator
    • RecursiveCallbackFilterIterator — La clase RecursiveCallbackFilterIterator
    • RecursiveDirectoryIterator — La clase RecursiveDirectoryIterator
    • RecursiveFilterIterator — La clase RecursiveFilterIterator
    • RecursiveIteratorIterator — La clase RecursiveIteratorIterator
    • RecursiveRegexIterator — La clase RecursiveRegexIterator
    • RecursiveTreeIterator — La clase RecursiveTreeIterator
    • RegexIterator — La clase RegexIterator
  • Interfaces
    • Countable — El interfaz Countable
    • OuterIterator — El interfaz OuterIterator
    • RecursiveIterator — El interfaz RecursiveIterator
    • SeekableIterator — La interfaz SeekableIterator
  • Excepciones
    • BadFunctionCallException — La clase BadFunctionCallException
    • BadMethodCallException — La clase BadMethodCallException
    • DomainException — La clase DomainException
    • InvalidArgumentException — La clase InvalidArgumentException
    • LengthException — La clase LengthException
    • LogicException — La clase LogicException
    • OutOfBoundsException — La clase OutOfBoundsException
    • OutOfRangeException — La clase OutOfRangeException
    • OverflowException — La clase OverflowException
    • RangeException — La clase RangeException
    • RuntimeException — La clase RuntimeException
    • UnderflowException — La clase UnderflowException
    • UnexpectedValueException — La clase UnexpectedValueException
  • Funciones SPL
    • class_implements — Devuelve las interfaces que son implementadas por la clase o interfaz dadas
    • class_parents — Devuelve las clases padre de la clase dada.
    • class_uses — Devolver los "traits" usados por la clase dada
    • iterator_apply — Llamar a una función para cada elemento de un iterador
    • iterator_count — Contar los elementos de un iterador
    • iterator_to_array — Copiar el iterador a un array
    • spl_autoload_call — Probar todos las funciones registradas __autoload() para cargar la clase solicitada
    • spl_autoload_extensions — Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload
    • spl_autoload_functions — Devolver todas las funciones __autoload() registradas
    • spl_autoload_register — Registrar las funciones dadas como implementación de __autoload()
    • spl_autoload_unregister — Desregistrar una función dada como implementación de __autoload()
    • spl_autoload — Implementación predeterminada para __autoload()
    • spl_classes — Devuelve las clases SPL disponibles
    • spl_object_hash — Devuelve el id del hash del objeto dado
    • spl_object_id — Return the integer object handle for given object
  • Manejo de ficheros
    • SplFileInfo — La clase SplFileInfo
    • SplFileObject — La clase SplFileObject
    • SplTempFileObject — La clase SplTempFileObject
  • Misceláneos clases e interfaces
    • ArrayObject — La clase ArrayObject
    • SplObserver — La interfaz SplObserver
    • SplSubject — El interfaz SplSubject


Introducción

La Biblioteca Estándar de PHP (SPL por las siglas de Standard PHP Library en inglés) es una colección de interfaces y clases pensadas para solucionar problemas comunes.

No es necesaria ninguna biblioteca externa para construir esta extensión. Está disponible y compilada de forma predeterminada en PHP 5.0.0.

SPL proporciona un conjunto de estructuras de datos estándar, un conjunto de iteradores para recorrer objetos, un conjunto de interfaces, un conjunto de excepciones estándar, varias clases para trabajar con ficheros, y un conjunto de funciones como spl_autoload_register()


Instalación

Esta extensión está disponible y compilada por defecto desde PHP 5.0.0.

Nota:

Desde PHP 5.3.0 esta extensión no puede ser desactivada, estando, por lo tanto, siempre disponible.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Advertencia

SPL usa constantes de clase desde PHP 5.1. En versiones anteriores se usan constantes del tipo RIT_LEAVES_ONLY.


Estructuras de datos

Tabla de contenidos

  • SplDoublyLinkedList
  • SplStack
  • SplQueue
  • SplHeap
  • SplMaxHeap
  • SplMinHeap
  • SplPriorityQueue
  • SplFixedArray
  • SplObjectStorage

SPL provee un conjunto de estructuras de datos estándar. Estas están agrupadas por su implementación subyacente la cual usualmente define su campo de aplicación general.

Listas doblemente enlazadas

Una Lista Doblemente Enlazada (LDE) es una lista de nodos enlazados entre ellos en ambas direcciones. Las operaciones de iteración, acceso a ambos extremos, adición o remoción de nodos tienen un costo de O(1) cuando la estructura subyacente es una LDE. Por lo tanto, proporciona una implementación decente para pilas y colas.

  • SplDoublyLinkedList
    • SplStack
    • SplQueue

Montículos

Los montículos son estructuras de árboles que siguen la propiedad de los montículos: cada nodo es mayor o igual que sus hijos, cuando son comparados utilizando el método de comparación implementado, el cual es global al montículo.

  • SplHeap
    • SplMaxHeap
    • SplMinHeap
  • SplPriorityQueue

Arrays

Los array son estructuras que almacenan datos de una forma continua y accesible mediante índices. No deben confundirse con los array de PHP: los array de PHP son en realidad implementados como tablas hash ordenadas.

  • SplFixedArray

Mapa

Un mapa es una estructura de datos que contiene parejas de clave-valor. Los array de PHP pueden ser vistos como correspondencias (mapas) de enteros/string a valores. SPL proporciona una correspondencia de objetos a datos. Este mapa puede ser utilizado además como un conjunto de objetos.

  • SplObjectStorage


La clase SplDoublyLinkedList

(PHP 5 >= 5.3.0, PHP 7)

Introducción

La clase SplDoublyLinkedList proporciona las principales funcionalidades de una lista doblemente enlazada.

Sinopsis de la Clase

SplDoublyLinkedList implements Iterator , ArrayAccess , Countable , Serializable {
/* Constantes */
const integer IT_MODE_LIFO = 2 ;
const integer IT_MODE_FIFO = 0 ;
const integer IT_MODE_DELETE = 1 ;
const integer IT_MODE_KEEP = 0 ;
/* Métodos */
public __construct ( )
public add ( mixed $index , mixed $newval ) : void
public bottom ( ) : mixed
public count ( ) : int
public current ( ) : mixed
public getIteratorMode ( ) : int
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public pop ( ) : mixed
public prev ( ) : void
public push ( mixed $value ) : void
public rewind ( ) : void
public serialize ( ) : string
public setIteratorMode ( int $mode ) : void
public shift ( ) : mixed
public top ( ) : mixed
public unserialize ( string $serialized ) : void
public unshift ( mixed $value ) : void
public valid ( ) : bool
}

Constantes predefinidas

Iteration Direction

SplDoublyLinkedList::IT_MODE_LIFO

La lista será iterada en un orden de última entrada, primera salida, como una pila.

SplDoublyLinkedList::IT_MODE_FIFO

La lista será iterada en un orden de entrada y salida, como una cola.

Comportamiento de Iteración

SplDoublyLinkedList::IT_MODE_DELETE

La iteración eliminará los elementos iterados.

SplDoublyLinkedList::IT_MODE_KEEP

La iteración no eliminará los elementos iterados.

Tabla de contenidos

  • SplDoublyLinkedList::add — Añadir/insertar un nuevo valor en el índice especificado
  • SplDoublyLinkedList::bottom — Examinar el nodo del comienzo de la lista doblemente enlazada
  • SplDoublyLinkedList::__construct — Construye una nueva lista doblemente enlazada
  • SplDoublyLinkedList::count — Cuenta el número de elementos de la lista doblemente enlazada
  • SplDoublyLinkedList::current — Devuelve la entrada actual del array
  • SplDoublyLinkedList::getIteratorMode — Devuelve el modo de iteración
  • SplDoublyLinkedList::isEmpty — Comprueba si la lista doblemente enlazada está vacía
  • SplDoublyLinkedList::key — Devuelve el índice del nodo actual
  • SplDoublyLinkedList::next — Avanza a la siguiente entrada
  • SplDoublyLinkedList::offsetExists — Devuelve si el índice solicitado existe
  • SplDoublyLinkedList::offsetGet — Devuelve el valor del índice específicado
  • SplDoublyLinkedList::offsetSet — Establece el valor del índice específicado
  • SplDoublyLinkedList::offsetUnset — Borra el valor de el índice específicado
  • SplDoublyLinkedList::pop — Extrae un nodo del final de la lista doblementa enlazada
  • SplDoublyLinkedList::prev — Retrocede a la entrada anterior
  • SplDoublyLinkedList::push — Inserta un elemento al final de la lista doblemente enlazada
  • SplDoublyLinkedList::rewind — Rebobina el iterador hasta el inicio
  • SplDoublyLinkedList::serialize — Serializa el almacenamiento
  • SplDoublyLinkedList::setIteratorMode — Establece el modo de iteración
  • SplDoublyLinkedList::shift — Quita un nodo del inicio de la lista doblemente enlazada
  • SplDoublyLinkedList::top — Examina el nodo del final de la lista doblemente enlazada
  • SplDoublyLinkedList::unserialize — Deserializa el almacenamiento
  • SplDoublyLinkedList::unshift — Antepone un elemento a la lista doblemente enlazada
  • SplDoublyLinkedList::valid — Comprueba si la lista doblemente enlazada contiene más nodos


Añadir/insertar un nuevo valor en el índice especificado

  • « SplDoublyLinkedList
  • SplDoublyLinkedList::bottom »
  • PHP Manual
  • SplDoublyLinkedList
  • Añadir/insertar un nuevo valor en el índice especificado

SplDoublyLinkedList::add

(PHP 5 >= 5.5.0, PHP 7)

SplDoublyLinkedList::add — Añadir/insertar un nuevo valor en el índice especificado

Descripción

public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void

Inserta el valor dado por newval en el índice especificado por index, reorganizando el valor anterior a ese índice (y todos los valores subsiguientes) a través de la lista.

Parámetros

index

El índice donde insertar el nuevo valor.

newval

El nuevo valor para index.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una OutOfRangeException cuando index está fuera de los límites o cuando index no puede ser analizado como un integer.


Examinar el nodo del comienzo de la lista doblemente enlazada

  • « SplDoublyLinkedList::add
  • SplDoublyLinkedList::__construct »
  • PHP Manual
  • SplDoublyLinkedList
  • Examinar el nodo del comienzo de la lista doblemente enlazada

SplDoublyLinkedList::bottom

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::bottom — Examinar el nodo del comienzo de la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::bottom ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de el primer nodo.

Errores/Excepciones

Lanza una RuntimeException cuando la estructura de datos está vacía.


Construye una nueva lista doblemente enlazada

  • « SplDoublyLinkedList::bottom
  • SplDoublyLinkedList::count »
  • PHP Manual
  • SplDoublyLinkedList
  • Construye una nueva lista doblemente enlazada

SplDoublyLinkedList::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::__construct — Construye una nueva lista doblemente enlazada

Descripción

public SplDoublyLinkedList::__construct ( )

Construye una nueva lista doblemente enlazada vacía.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplDoublyLinkedList::__construct()

<?php
$lde = new SplDoublyLinkedList();

$lde->push(2);
$lde->push(3);
$lde->unshift(5);

var_dump($lde);
?>

El resultado del ejemplo sería:

object(SplDoublyLinkedList)#1 (2) {
  ["flags":"SplDoublyLinkedList":private]=>
  int(0)
  ["dllist":"SplDoublyLinkedList":private]=>
  array(3) {
    [0]=>
    int(5)
    [1]=>
    int(2)
    [2]=>
    int(3)
  }
}


Cuenta el número de elementos de la lista doblemente enlazada

  • « SplDoublyLinkedList::__construct
  • SplDoublyLinkedList::current »
  • PHP Manual
  • SplDoublyLinkedList
  • Cuenta el número de elementos de la lista doblemente enlazada

SplDoublyLinkedList::count

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::count — Cuenta el número de elementos de la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::count ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de elementos de la lista doblemente enlazada.


Devuelve la entrada actual del array

  • « SplDoublyLinkedList::count
  • SplDoublyLinkedList::getIteratorMode »
  • PHP Manual
  • SplDoublyLinkedList
  • Devuelve la entrada actual del array

SplDoublyLinkedList::current

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::current — Devuelve la entrada actual del array

Descripción

public SplDoublyLinkedList::current ( ) : mixed

Obtiene el nodo actual de la lista doblemente enlazada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del nodo actual.


Devuelve el modo de iteración

  • « SplDoublyLinkedList::current
  • SplDoublyLinkedList::isEmpty »
  • PHP Manual
  • SplDoublyLinkedList
  • Devuelve el modo de iteración

SplDoublyLinkedList::getIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::getIteratorMode — Devuelve el modo de iteración

Descripción

public SplDoublyLinkedList::getIteratorMode ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los diferentes modos y banderas que afectan la iteración.


Comprueba si la lista doblemente enlazada está vacía

  • « SplDoublyLinkedList::getIteratorMode
  • SplDoublyLinkedList::key »
  • PHP Manual
  • SplDoublyLinkedList
  • Comprueba si la lista doblemente enlazada está vacía

SplDoublyLinkedList::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::isEmpty — Comprueba si la lista doblemente enlazada está vacía

Descripción

public SplDoublyLinkedList::isEmpty ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve si la lista doblemente enlazada está vacía.


Devuelve el índice del nodo actual

  • « SplDoublyLinkedList::isEmpty
  • SplDoublyLinkedList::next »
  • PHP Manual
  • SplDoublyLinkedList
  • Devuelve el índice del nodo actual

SplDoublyLinkedList::key

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::key — Devuelve el índice del nodo actual

Descripción

public SplDoublyLinkedList::key ( ) : mixed

Esta función devuelve el índice del nodo actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice del nodo actual.


Avanza a la siguiente entrada

  • « SplDoublyLinkedList::key
  • SplDoublyLinkedList::offsetExists »
  • PHP Manual
  • SplDoublyLinkedList
  • Avanza a la siguiente entrada

SplDoublyLinkedList::next

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::next — Avanza a la siguiente entrada

Descripción

public SplDoublyLinkedList::next ( ) : void

Mueve el iterador al siguiente nodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Devuelve si el índice solicitado existe

  • « SplDoublyLinkedList::next
  • SplDoublyLinkedList::offsetGet »
  • PHP Manual
  • SplDoublyLinkedList
  • Devuelve si el índice solicitado existe

SplDoublyLinkedList::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetExists — Devuelve si el índice solicitado existe

Descripción

public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool

Parámetros

index

El índice a comprobar.

Valores devueltos

true si el índice index solicitado existe, false en caso contrario.


Devuelve el valor del índice específicado

  • « SplDoublyLinkedList::offsetExists
  • SplDoublyLinkedList::offsetSet »
  • PHP Manual
  • SplDoublyLinkedList
  • Devuelve el valor del índice específicado

SplDoublyLinkedList::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetGet — Devuelve el valor del índice específicado

Descripción

public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed

Parámetros

index

El índice con el valor.

Valores devueltos

El valor específicado en index.

Errores/Excepciones

Lanza una OutOfRangeException cuando index está fuera de los límites o cuando index no se puede analizar como un entero.


Establece el valor del índice específicado

  • « SplDoublyLinkedList::offsetGet
  • SplDoublyLinkedList::offsetUnset »
  • PHP Manual
  • SplDoublyLinkedList
  • Establece el valor del índice específicado

SplDoublyLinkedList::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetSet — Establece el valor del índice específicado

Descripción

public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void

Establece el valor del índice dado por index al valor especificado por newval.

Parámetros

index

El índice a establer.

newval

El nuevo valor para index.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una OutOfRangeException cuando index está fuera de los límites o cuando index no se puede analizar como un entero.


Borra el valor de el índice específicado

  • « SplDoublyLinkedList::offsetSet
  • SplDoublyLinkedList::pop »
  • PHP Manual
  • SplDoublyLinkedList
  • Borra el valor de el índice específicado

SplDoublyLinkedList::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetUnset — Borra el valor de el índice específicado

Descripción

public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void

Borra el valor del índice específicado.

Parámetros

index

El índice a borrar.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una OutOfRangeException cuando index está fuera de los límites o cuando index no se puede analizar como un entero.


Extrae un nodo del final de la lista doblementa enlazada

  • « SplDoublyLinkedList::offsetUnset
  • SplDoublyLinkedList::prev »
  • PHP Manual
  • SplDoublyLinkedList
  • Extrae un nodo del final de la lista doblementa enlazada

SplDoublyLinkedList::pop

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::pop — Extrae un nodo del final de la lista doblementa enlazada

Descripción

public SplDoublyLinkedList::pop ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del nodo a extraer.

Errores/Excepciones

Lanza una RuntimeException cuando la estructura de datos está vacía.


Retrocede a la entrada anterior

  • « SplDoublyLinkedList::pop
  • SplDoublyLinkedList::push »
  • PHP Manual
  • SplDoublyLinkedList
  • Retrocede a la entrada anterior

SplDoublyLinkedList::prev

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::prev — Retrocede a la entrada anterior

Descripción

public SplDoublyLinkedList::prev ( ) : void

Mueve el iterador al nodo anterior.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Inserta un elemento al final de la lista doblemente enlazada

  • « SplDoublyLinkedList::prev
  • SplDoublyLinkedList::rewind »
  • PHP Manual
  • SplDoublyLinkedList
  • Inserta un elemento al final de la lista doblemente enlazada

SplDoublyLinkedList::push

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::push — Inserta un elemento al final de la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::push ( mixed $value ) : void

Inserta el valor dado por value al final de la lista doblemente enlazada.

Parámetros

value

El valor a insertar.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador hasta el inicio

  • « SplDoublyLinkedList::push
  • SplDoublyLinkedList::serialize »
  • PHP Manual
  • SplDoublyLinkedList
  • Rebobina el iterador hasta el inicio

SplDoublyLinkedList::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::rewind — Rebobina el iterador hasta el inicio

Descripción

public SplDoublyLinkedList::rewind ( ) : void

Rebobina el iterador hasta el inicio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Serializa el almacenamiento

  • « SplDoublyLinkedList::rewind
  • SplDoublyLinkedList::setIteratorMode »
  • PHP Manual
  • SplDoublyLinkedList
  • Serializa el almacenamiento

SplDoublyLinkedList::serialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::serialize — Serializa el almacenamiento

Descripción

public SplDoublyLinkedList::serialize ( ) : string

Serializa el almacenamiento.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El string serializado.

Ver también

  • SplDoublyLinkedList::unserialize() - Deserializa el almacenamiento


Establece el modo de iteración

  • « SplDoublyLinkedList::serialize
  • SplDoublyLinkedList::shift »
  • PHP Manual
  • SplDoublyLinkedList
  • Establece el modo de iteración

SplDoublyLinkedList::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::setIteratorMode — Establece el modo de iteración

Descripción

public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void

Parámetros

mode

Hay dos conjuntos ortogonales de los modos que se pueden establecer:

  • La dirección de la iteración (ya sea uno o el otro):
    • SplDoublyLinkedList::IT_MODE_LIFO (Estilo de pila)
    • SplDoublyLinkedList::IT_MODE_FIFO (Estilo de cola)
  • El comportamiento del iterador (ya sea uno o el otro):
    • SplDoublyLinkedList::IT_MODE_DELETE (Los elementos son eliminados por el iterador)
    • SplDoublyLinkedList::IT_MODE_KEEP (Los elementos son recorridos por el iterador)

El modo predeterminado es: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

Valores devueltos

No devuelve ningún valor.


Quita un nodo del inicio de la lista doblemente enlazada

  • « SplDoublyLinkedList::setIteratorMode
  • SplDoublyLinkedList::top »
  • PHP Manual
  • SplDoublyLinkedList
  • Quita un nodo del inicio de la lista doblemente enlazada

SplDoublyLinkedList::shift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::shift — Quita un nodo del inicio de la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::shift ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del nodo a quitar.

Errores/Excepciones

Lanza una RuntimeException cuando la estructura de datos está vacía.


Examina el nodo del final de la lista doblemente enlazada

  • « SplDoublyLinkedList::shift
  • SplDoublyLinkedList::unserialize »
  • PHP Manual
  • SplDoublyLinkedList
  • Examina el nodo del final de la lista doblemente enlazada

SplDoublyLinkedList::top

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::top — Examina el nodo del final de la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::top ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del último nodo.

Errores/Excepciones

Lanza una RuntimeException cuando la estructura de datos está vacía.


Deserializa el almacenamiento

  • « SplDoublyLinkedList::top
  • SplDoublyLinkedList::unshift »
  • PHP Manual
  • SplDoublyLinkedList
  • Deserializa el almacenamiento

SplDoublyLinkedList::unserialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::unserialize — Deserializa el almacenamiento

Descripción

public SplDoublyLinkedList::unserialize ( string $serialized ) : void

Deserializa el almacenamiento, desde SplDoublyLinkedList::serialize().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

serialized

Es string serializada.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SplDoublyLinkedList::serialize() - Serializa el almacenamiento


Antepone un elemento a la lista doblemente enlazada

  • « SplDoublyLinkedList::unserialize
  • SplDoublyLinkedList::valid »
  • PHP Manual
  • SplDoublyLinkedList
  • Antepone un elemento a la lista doblemente enlazada

SplDoublyLinkedList::unshift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::unshift — Antepone un elemento a la lista doblemente enlazada

Descripción

public SplDoublyLinkedList::unshift ( mixed $value ) : void

Antepone el valor dado por value al inicio de la lista doblemente enlazada.

Parámetros

value

El valor a anteponer.

Valores devueltos

No devuelve ningún valor.


Comprueba si la lista doblemente enlazada contiene más nodos

  • « SplDoublyLinkedList::unshift
  • SplStack »
  • PHP Manual
  • SplDoublyLinkedList
  • Comprueba si la lista doblemente enlazada contiene más nodos

SplDoublyLinkedList::valid

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::valid — Comprueba si la lista doblemente enlazada contiene más nodos

Descripción

public SplDoublyLinkedList::valid ( ) : bool

Comprueba si la lista doblemente enlazada contiene más nodos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la lista doblemente enlazada contiene más nodos, o false en caso contrario.


La clase SplStack

(PHP 5 >= 5.3.0, PHP 7)

Introducción

La clase SplStack proporciona la funcionalidad principal de una pila implementada mediante una lista doblemente enlazada.

Sinopsis de la Clase

SplStack extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* Métodos */
__construct ( )
setIteratorMode ( int $mode ) : void
/* Métodos heredados */
public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::bottom ( ) : mixed
public SplDoublyLinkedList::count ( ) : int
public SplDoublyLinkedList::current ( ) : mixed
public SplDoublyLinkedList::getIteratorMode ( ) : int
public SplDoublyLinkedList::isEmpty ( ) : bool
public SplDoublyLinkedList::key ( ) : mixed
public SplDoublyLinkedList::next ( ) : void
public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool
public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed
public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void
public SplDoublyLinkedList::pop ( ) : mixed
public SplDoublyLinkedList::prev ( ) : void
public SplDoublyLinkedList::push ( mixed $value ) : void
public SplDoublyLinkedList::rewind ( ) : void
public SplDoublyLinkedList::serialize ( ) : string
public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void
public SplDoublyLinkedList::shift ( ) : mixed
public SplDoublyLinkedList::top ( ) : mixed
public SplDoublyLinkedList::unserialize ( string $serialized ) : void
public SplDoublyLinkedList::unshift ( mixed $value ) : void
public SplDoublyLinkedList::valid ( ) : bool
}

Tabla de contenidos

  • SplStack::__construct — Construye una nueva pila implementada mediante una lista doblemente enlazada
  • SplStack::setIteratorMode — Establece el modo de iteración


Construye una nueva pila implementada mediante una lista doblemente enlazada

  • « SplStack
  • SplStack::setIteratorMode »
  • PHP Manual
  • SplStack
  • Construye una nueva pila implementada mediante una lista doblemente enlazada

SplStack::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplStack::__construct — Construye una nueva pila implementada mediante una lista doblemente enlazada

Descripción

SplStack::__construct ( )

Construye una nueva pila vacía.

Nota:

Este método automáticamente establece el modo del iterador a SplDoublyLinkedList::IT_MODE_LIFO.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplStack::__construct()

<?php
$q = new SplStack();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

El resultado del ejemplo sería:

3
2
1


Establece el modo de iteración

  • « SplStack::__construct
  • SplQueue »
  • PHP Manual
  • SplStack
  • Establece el modo de iteración

SplStack::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplStack::setIteratorMode — Establece el modo de iteración

Descripción

SplStack::setIteratorMode ( int $mode ) : void

Parámetros

mode

Este es el único parámetro de iteración que se puede modificar.

  • El comportamiento del iterador (ya sea uno o el otro):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

El modo por omisión es 0x2 : SplDoublyLinkedList::IT_MODE_LIFO | SplDoublyLinkedList::IT_MODE_KEEP

Advertencia

La dirección de iteración puede La dirección de la iteración ya no puede ser cambiado para SplStacks. Si se intenta hacer esto lanzará una RuntimeException.

Valores devueltos

No devuelve ningún valor.


La clase SplQueue

(PHP 5 >= 5.3.0, PHP 7)

Introducción

la clase SplQueue proporciona la funcionalidad principales de una cola implementada mediante una lista doblemente enlazada.

Sinopsis de la Clase

SplQueue extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* Métodos */
__construct ( )
dequeue ( ) : mixed
enqueue ( mixed $value ) : void
setIteratorMode ( int $mode ) : void
/* Métodos heredados */
public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::bottom ( ) : mixed
public SplDoublyLinkedList::count ( ) : int
public SplDoublyLinkedList::current ( ) : mixed
public SplDoublyLinkedList::getIteratorMode ( ) : int
public SplDoublyLinkedList::isEmpty ( ) : bool
public SplDoublyLinkedList::key ( ) : mixed
public SplDoublyLinkedList::next ( ) : void
public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool
public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed
public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void
public SplDoublyLinkedList::pop ( ) : mixed
public SplDoublyLinkedList::prev ( ) : void
public SplDoublyLinkedList::push ( mixed $value ) : void
public SplDoublyLinkedList::rewind ( ) : void
public SplDoublyLinkedList::serialize ( ) : string
public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void
public SplDoublyLinkedList::shift ( ) : mixed
public SplDoublyLinkedList::top ( ) : mixed
public SplDoublyLinkedList::unserialize ( string $serialized ) : void
public SplDoublyLinkedList::unshift ( mixed $value ) : void
public SplDoublyLinkedList::valid ( ) : bool
}

Tabla de contenidos

  • SplQueue::__construct — Construye una nueva cola implementada usando una lista doblemente enlazada
  • SplQueue::dequeue — Quita un nodo de la cola
  • SplQueue::enqueue — Añade un elemento a la cola
  • SplQueue::setIteratorMode — Establece el modo de iteración


Construye una nueva cola implementada usando una lista doblemente enlazada

  • « SplQueue
  • SplQueue::dequeue »
  • PHP Manual
  • SplQueue
  • Construye una nueva cola implementada usando una lista doblemente enlazada

SplQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::__construct — Construye una nueva cola implementada usando una lista doblemente enlazada

Descripción

SplQueue::__construct ( )

Construye una nueva cola vacía.

Nota:

Este método automáticamente establece el modo del iterador a SplDoublyLinkedList::IT_MODE_FIFO.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplQueue::__construct()

<?php
$q = new SplQueue();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

El resultado del ejemplo sería:

1
2
3

Ejemplo #2 Manejo eficiente de las tareas con SplQueue

<?php
$q = new SplQueue();
$q->setIteratorMode(SplQueue::IT_MODE_DELETE);

// ... algunas de las tareas enqueue en la cola ...

// proceso que
foreach ($q as $task) {
    // ... procesa $task ...

    // agregar nuevas tareas en la cola
    $q[] = $newTask;
    // ...
}
?>


Quita un nodo de la cola

  • « SplQueue::__construct
  • SplQueue::enqueue »
  • PHP Manual
  • SplQueue
  • Quita un nodo de la cola

SplQueue::dequeue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::dequeue — Quita un nodo de la cola

Descripción

SplQueue::dequeue ( ) : mixed

Quita un value en la parte superior de la cola.

Nota:

SplQueue::dequeue() es un alias de SplDoublyLinkedList::shift().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de el nodo a quitar de la cola.


Añade un elemento a la cola

  • « SplQueue::dequeue
  • SplQueue::setIteratorMode »
  • PHP Manual
  • SplQueue
  • Añade un elemento a la cola

SplQueue::enqueue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::enqueue — Añade un elemento a la cola

Descripción

SplQueue::enqueue ( mixed $value ) : void

Añadir un value al final de la cola.

Nota:

SplQueue::enqueue() es un alias de SplDoublyLinkedList::push().

Parámetros

value

El valor que se va a añadir.

Valores devueltos

No devuelve ningún valor.


Establece el modo de iteración

  • « SplQueue::enqueue
  • SplHeap »
  • PHP Manual
  • SplQueue
  • Establece el modo de iteración

SplQueue::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::setIteratorMode — Establece el modo de iteración

Descripción

SplQueue::setIteratorMode ( int $mode ) : void

Parámetros

mode

Este es el único parámetro de iteración que se puede modificar.

  • El comportamiento de la iteración (ya sea uno o el otro):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elementos son eliminados por el iterador)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elementos son atravesados por el iterador)

El modo por omisión es: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

Advertencia

La dirección de iteración puede no ser cambiada para SplQueues, esto es siempre SplDoublyLinkedList::IT_MODE_FIFO.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una RuntimeException al intentar cambiar la dirección de la iteración usando SplDoublyLinkedList::IT_MODE_LIFO.


La clase SplHeap

(PHP 5 >= 5.3.0, PHP 7)

Introducción

La clase SplHeap proporciona la funcionalidad principal de un montículo.

Sinopsis de la Clase

abstract SplHeap implements Iterator , Countable {
/* Métodos */
public __construct ( )
abstract protected compare ( mixed $value1 , mixed $value2 ) : int
public count ( ) : int
public current ( ) : mixed
public extract ( ) : mixed
public insert ( mixed $value ) : void
public isCorrupted ( ) : bool
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public recoverFromCorruption ( ) : void
public rewind ( ) : void
public top ( ) : mixed
public valid ( ) : bool
}

Tabla de contenidos

  • SplHeap::compare — Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba
  • SplHeap::__construct — Construye un nuevo heap vacío
  • SplHeap::count — Cuenta el número de elementos en el montón
  • SplHeap::current — Devuelve el nodo actual señalado por el iterador
  • SplHeap::extract — Extrae un nodo de la parte superior del montón
  • SplHeap::insert — Inserta un elemento en el montón
  • SplHeap::isCorrupted — Tells if the heap is in a corrupted state
  • SplHeap::isEmpty — Comprueba si el montón actual está vacío
  • SplHeap::key — Devuelve el índice de el nodo actual
  • SplHeap::next — Avanzar al siguiente nodo
  • SplHeap::recoverFromCorruption — Recuperarse de un estado dañado y permitir un mayor número de acciones en el montón
  • SplHeap::rewind — Rebobina el iterador al comienzo
  • SplHeap::top — Observar el nodo desde el comienzo del montón
  • SplHeap::valid — Comprueba si el montón contiene más nodos


Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

  • « SplHeap
  • SplHeap::__construct »
  • PHP Manual
  • SplHeap
  • Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

SplHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::compare — Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

Descripción

abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int

Comparar value1 con value2.

Advertencia

Lanza una excepción en SplHeap::compare() que puede dañar el montón y colocarlo en un estado bloqueado. Se puede desbloquear llamando a SplHeap::recoverFromCorruption(). Sin embargo, algunos elementos podrían no ser colocados correctamente y por lo tanto pueden romper la propiedad del montón.

Parámetros

value1

El valor de el primer nodo a ser comparado.

value2

El valor de el segundo nodo a ser comparado.

Valores devueltos

El resultado de la comparación, integer positivo si value1 es mayor que value2, 0 si son iguales, en caso contrario integer negativo.

Nota:

No es recomendado tener múltiples elementos con el mismo valor en el montón. Estos terminarán con una posición arbitraria relativa.


Construye un nuevo heap vacío

  • « SplHeap::compare
  • SplHeap::count »
  • PHP Manual
  • SplHeap
  • Construye un nuevo heap vacío

SplHeap::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::__construct — Construye un nuevo heap vacío

Descripción

public SplHeap::__construct ( )

Construye un nuevo heap vacío.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Cuenta el número de elementos en el montón

  • « SplHeap::__construct
  • SplHeap::current »
  • PHP Manual
  • SplHeap
  • Cuenta el número de elementos en el montón

SplHeap::count

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::count — Cuenta el número de elementos en el montón

Descripción

public SplHeap::count ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de elementos en el montón.


Devuelve el nodo actual señalado por el iterador

  • « SplHeap::count
  • SplHeap::extract »
  • PHP Manual
  • SplHeap
  • Devuelve el nodo actual señalado por el iterador

SplHeap::current

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::current — Devuelve el nodo actual señalado por el iterador

Descripción

public SplHeap::current ( ) : mixed

Obtiene el nodo actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de el nodo actual.


Extrae un nodo de la parte superior del montón

  • « SplHeap::current
  • SplHeap::insert »
  • PHP Manual
  • SplHeap
  • Extrae un nodo de la parte superior del montón

SplHeap::extract

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::extract — Extrae un nodo de la parte superior del montón

Descripción

public SplHeap::extract ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del nodo a ser extraído.

Errores/Excepciones

Lanza una excepción RuntimeException cuando la estructura de datos está vacía.


Inserta un elemento en el montón

  • « SplHeap::extract
  • SplHeap::isCorrupted »
  • PHP Manual
  • SplHeap
  • Inserta un elemento en el montón

SplHeap::insert

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::insert — Inserta un elemento en el montón

Descripción

public SplHeap::insert ( mixed $value ) : void

Inserta un value en el montón.

Parámetros

value

El valor a ser insertado.

Valores devueltos

No devuelve ningún valor.


Tells if the heap is in a corrupted state

  • « SplHeap::insert
  • SplHeap::isEmpty »
  • PHP Manual
  • SplHeap
  • Tells if the heap is in a corrupted state

SplHeap::isCorrupted

(PHP 7)

SplHeap::isCorrupted — Tells if the heap is in a corrupted state

Descripción

public SplHeap::isCorrupted ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the heap is corrupted, false otherwise.


Comprueba si el montón actual está vacío

  • « SplHeap::isCorrupted
  • SplHeap::key »
  • PHP Manual
  • SplHeap
  • Comprueba si el montón actual está vacío

SplHeap::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::isEmpty — Comprueba si el montón actual está vacío

Descripción

public SplHeap::isEmpty ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve si el montón está vacío.


Devuelve el índice de el nodo actual

  • « SplHeap::isEmpty
  • SplHeap::next »
  • PHP Manual
  • SplHeap
  • Devuelve el índice de el nodo actual

SplHeap::key

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::key — Devuelve el índice de el nodo actual

Descripción

public SplHeap::key ( ) : mixed

Esta función devuelve el índice de el nodo actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice de el nodo actual.


Avanzar al siguiente nodo

  • « SplHeap::key
  • SplHeap::recoverFromCorruption »
  • PHP Manual
  • SplHeap
  • Avanzar al siguiente nodo

SplHeap::next

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::next — Avanzar al siguiente nodo

Descripción

public SplHeap::next ( ) : void

Avanzar al siguiente nodo. Borrará el nodo superior del montón.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Recuperarse de un estado dañado y permitir un mayor número de acciones en el montón

  • « SplHeap::next
  • SplHeap::rewind »
  • PHP Manual
  • SplHeap
  • Recuperarse de un estado dañado y permitir un mayor número de acciones en el montón

SplHeap::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::recoverFromCorruption — Recuperarse de un estado dañado y permitir un mayor número de acciones en el montón

Descripción

public SplHeap::recoverFromCorruption ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador al comienzo

  • « SplHeap::recoverFromCorruption
  • SplHeap::top »
  • PHP Manual
  • SplHeap
  • Rebobina el iterador al comienzo

SplHeap::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::rewind — Rebobina el iterador al comienzo

Descripción

public SplHeap::rewind ( ) : void

Esto rebobina el iterador hasta el inicio. Esto es un no-op para los montones ya que el iterador es virtual y, de hecho, nunca se mueve desde la parte superior de la pila.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Observar el nodo desde el comienzo del montón

  • « SplHeap::rewind
  • SplHeap::valid »
  • PHP Manual
  • SplHeap
  • Observar el nodo desde el comienzo del montón

SplHeap::top

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::top — Observar el nodo desde el comienzo del montón

Descripción

public SplHeap::top ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de el nodo del comienzo.

Errores/Excepciones

Lanza una excepción RuntimeException cuando la estructura de datos está vacía.


Comprueba si el montón contiene más nodos

  • « SplHeap::top
  • SplMaxHeap »
  • PHP Manual
  • SplHeap
  • Comprueba si el montón contiene más nodos

SplHeap::valid

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::valid — Comprueba si el montón contiene más nodos

Descripción

public SplHeap::valid ( ) : bool

Comprueba si el montón contiene más nodos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el montón contiene más nodos, en caso contrario false.


la clase SplMaxHeap

(PHP 5 >= 5.3.0, PHP 7)

Introducción

La clase SplMaxHeap proporciona la funcionalidad principal de un montículo, manteniendo el máximo en la parte superior.

Sinopsis de la Clase

SplMaxHeap extends SplHeap implements Iterator , Countable {
/* Métodos */
protected compare ( mixed $value1 , mixed $value2 ) : int
/* Métodos heredados */
abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int
public SplHeap::count ( ) : int
public SplHeap::current ( ) : mixed
public SplHeap::extract ( ) : mixed
public SplHeap::insert ( mixed $value ) : void
public SplHeap::isCorrupted ( ) : bool
public SplHeap::isEmpty ( ) : bool
public SplHeap::key ( ) : mixed
public SplHeap::next ( ) : void
public SplHeap::recoverFromCorruption ( ) : void
public SplHeap::rewind ( ) : void
public SplHeap::top ( ) : mixed
public SplHeap::valid ( ) : bool
}

Tabla de contenidos

  • SplMaxHeap::compare — Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba


Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

  • « SplMaxHeap
  • SplMinHeap »
  • PHP Manual
  • SplMaxHeap
  • Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

SplMaxHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMaxHeap::compare — Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba

Descripción

protected SplMaxHeap::compare ( mixed $value1 , mixed $value2 ) : int

Comparar value1 con value2.

Parámetros

value1

El valor de el primer nodo a ser comparado.

value2

El valor de el segundo nodo a ser comparado.

Valores devueltos

El resultado de la comparación, un integer positivo si value1 es mayor que value2, 0 si son iguales, en caso contrario un integer negativo.

Nota:

No es recomendado tener múltiples elementos con el mismo valor en el montón. Estos terminarán con una posición arbitraria relativa.


La clase SplMinHeap

(PHP 5 >= 5.3.0, PHP 7)

Introducción

La clase SplMinHeap proporciona la funcionalidad principal de un montículo, manteniendo el mínimo en la parte superior.

Sinopsis de la Clase

SplMinHeap extends SplHeap implements Iterator , Countable {
/* Métodos */
protected compare ( mixed $value1 , mixed $value2 ) : int
/* Métodos heredados */
abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int
public SplHeap::count ( ) : int
public SplHeap::current ( ) : mixed
public SplHeap::extract ( ) : mixed
public SplHeap::insert ( mixed $value ) : void
public SplHeap::isCorrupted ( ) : bool
public SplHeap::isEmpty ( ) : bool
public SplHeap::key ( ) : mixed
public SplHeap::next ( ) : void
public SplHeap::recoverFromCorruption ( ) : void
public SplHeap::rewind ( ) : void
public SplHeap::top ( ) : mixed
public SplHeap::valid ( ) : bool
}

Tabla de contenidos

  • SplMinHeap::compare — Comparar elementos con el fin de colocarlos correctamente en el montón em la parte de arriba


Comparar elementos con el fin de colocarlos correctamente en el montón em la parte de arriba

  • « SplMinHeap
  • SplPriorityQueue »
  • PHP Manual
  • SplMinHeap
  • Comparar elementos con el fin de colocarlos correctamente en el montón em la parte de arriba

SplMinHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMinHeap::compare — Comparar elementos con el fin de colocarlos correctamente en el montón em la parte de arriba

Descripción

protected SplMinHeap::compare ( mixed $value1 , mixed $value2 ) : int

Compara value1 con value2.

Parámetros

value1

El valor de el primer nodo a ser comparado.

value2

El valor de el segundo nodo a ser comparado.

Valores devueltos

El resultado de la comparación, un integer positivo si value1 es menor que value2, 0 si son iguales, en caso contrario integer negativo.

Nota:

No es recomendable tener múltiples elementos con el mismo valor en el montón. Having multiple elements with the same value in a Heap is not recommended. Estos terminarán en una por sición arbitraria relativa.


la clase SplPriorityQueue

(PHP 5 >= 5.3.0, PHP 7)

Introducción

la clase SplPriorityQueue proporciona la funcionalidad principal de una cola de prioridad, implementada mediante un montículo máximo.

Sinopsis de la Clase

SplPriorityQueue implements Iterator , Countable {
/* Métodos */
public __construct ( )
public compare ( mixed $priority1 , mixed $priority2 ) : int
public count ( ) : int
public current ( ) : mixed
public extract ( ) : mixed
public getExtractFlags ( ) : int
public insert ( mixed $value , mixed $priority ) : bool
public isCorrupted ( ) : bool
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public recoverFromCorruption ( ) : void
public rewind ( ) : void
public setExtractFlags ( int $flags ) : void
public top ( ) : mixed
public valid ( ) : bool
}

Tabla de contenidos

  • SplPriorityQueue::compare — Comparar las prioridades con el fin de colocar los elementos correctamente en el montón, mientras que tamizar arriba
  • SplPriorityQueue::__construct — Construye una nueva cola vacía
  • SplPriorityQueue::count — Cuenta el número de elementos en la cola
  • SplPriorityQueue::current — Volver nodo actual que apunta el iterador
  • SplPriorityQueue::extract — Extrae un nodo de la parte superior del montículo y desplaza hacia arriba
  • SplPriorityQueue::getExtractFlags — Get the flags of extraction
  • SplPriorityQueue::insert — Inserta un elemento en la cola en la parte de arriba
  • SplPriorityQueue::isCorrupted — Tells if the priority queue is in a corrupted state
  • SplPriorityQueue::isEmpty — Comprueba si la cola está vacía
  • SplPriorityQueue::key — Devuelve el índice del nodo actual
  • SplPriorityQueue::next — Pasar a la siguiente nodo
  • SplPriorityQueue::recoverFromCorruption — Recuperar desde la condición corrupta y permitir acciones más en la cola
  • SplPriorityQueue::rewind — Rebobinar iterador de vuelta al inicio (no-op)
  • SplPriorityQueue::setExtractFlags — Establece el modo de extracción
  • SplPriorityQueue::top — Mira en el nodo de la parte superior de la cola
  • SplPriorityQueue::valid — Comprobar si la cola contiene más nodos


Comparar las prioridades con el fin de colocar los elementos correctamente en el montón, mientras que tamizar arriba

  • « SplPriorityQueue
  • SplPriorityQueue::__construct »
  • PHP Manual
  • SplPriorityQueue
  • Comparar las prioridades con el fin de colocar los elementos correctamente en el montón, mientras que tamizar arriba

SplPriorityQueue::compare

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::compare — Comparar las prioridades con el fin de colocar los elementos correctamente en el montón, mientras que tamizar arriba

Descripción

public SplPriorityQueue::compare ( mixed $priority1 , mixed $priority2 ) : int

Compare priority1 con priority2.

Parámetros

priority1

La prioridad del primer nodo que se compara.

priority2

La prioridad del segundo nodo que se compara.

Valores devueltos

Resultados de la comparación, entero positivo si priority1es mayor que priority2 , O si son iguales, entero negativo lo contrario.

Nota:

Varios elementos con la misma prioridad que se quita de la cola sin ningún orden en particular.


Construye una nueva cola vacía

  • « SplPriorityQueue::compare
  • SplPriorityQueue::count »
  • PHP Manual
  • SplPriorityQueue
  • Construye una nueva cola vacía

SplPriorityQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::__construct — Construye una nueva cola vacía

Descripción

public SplPriorityQueue::__construct ( )

Esto construye una nueva cola vacía.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Cuenta el número de elementos en la cola

  • « SplPriorityQueue::__construct
  • SplPriorityQueue::current »
  • PHP Manual
  • SplPriorityQueue
  • Cuenta el número de elementos en la cola

SplPriorityQueue::count

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::count — Cuenta el número de elementos en la cola

Descripción

public SplPriorityQueue::count ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de elementos en la cola.


Volver nodo actual que apunta el iterador

  • « SplPriorityQueue::count
  • SplPriorityQueue::extract »
  • PHP Manual
  • SplPriorityQueue
  • Volver nodo actual que apunta el iterador

SplPriorityQueue::current

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::current — Volver nodo actual que apunta el iterador

Descripción

public SplPriorityQueue::current ( ) : mixed

Obtener el nodo de estructura de datos actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de prioridad (o ambos) del nodo actual, dependiendo de la bandera extracto.


Extrae un nodo de la parte superior del montículo y desplaza hacia arriba

  • « SplPriorityQueue::current
  • SplPriorityQueue::getExtractFlags »
  • PHP Manual
  • SplPriorityQueue
  • Extrae un nodo de la parte superior del montículo y desplaza hacia arriba

SplPriorityQueue::extract

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::extract — Extrae un nodo de la parte superior del montículo y desplaza hacia arriba

Descripción

public SplPriorityQueue::extract ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor o prioridad (o ambos) del nodo extraído, dependiendo de la bandera de extracción.


Get the flags of extraction

  • « SplPriorityQueue::extract
  • SplPriorityQueue::insert »
  • PHP Manual
  • SplPriorityQueue
  • Get the flags of extraction

SplPriorityQueue::getExtractFlags

(PHP 7)

SplPriorityQueue::getExtractFlags — Get the flags of extraction

Descripción

public SplPriorityQueue::getExtractFlags ( ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Inserta un elemento en la cola en la parte de arriba

  • « SplPriorityQueue::getExtractFlags
  • SplPriorityQueue::isCorrupted »
  • PHP Manual
  • SplPriorityQueue
  • Inserta un elemento en la cola en la parte de arriba

SplPriorityQueue::insert

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::insert — Inserta un elemento en la cola en la parte de arriba

Descripción

public SplPriorityQueue::insert ( mixed $value , mixed $priority ) : bool

Inserta un value con la prioridad priority en la cola.

Parámetros

value

El valor a insertar.

priority

La prioridad asociada.

Valores devueltos

Devuelve true.


Tells if the priority queue is in a corrupted state

  • « SplPriorityQueue::insert
  • SplPriorityQueue::isEmpty »
  • PHP Manual
  • SplPriorityQueue
  • Tells if the priority queue is in a corrupted state

SplPriorityQueue::isCorrupted

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::isCorrupted — Tells if the priority queue is in a corrupted state

Descripción

public SplPriorityQueue::isCorrupted ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the priority queue is corrupted, false otherwise.


Comprueba si la cola está vacía

  • « SplPriorityQueue::isCorrupted
  • SplPriorityQueue::key »
  • PHP Manual
  • SplPriorityQueue
  • Comprueba si la cola está vacía

SplPriorityQueue::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::isEmpty — Comprueba si la cola está vacía

Descripción

public SplPriorityQueue::isEmpty ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Indica si la cola está vacía.


Devuelve el índice del nodo actual

  • « SplPriorityQueue::isEmpty
  • SplPriorityQueue::next »
  • PHP Manual
  • SplPriorityQueue
  • Devuelve el índice del nodo actual

SplPriorityQueue::key

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::key — Devuelve el índice del nodo actual

Descripción

public SplPriorityQueue::key ( ) : mixed

Este método devuelve el índice del nodo actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice el nodo actual.


Pasar a la siguiente nodo

  • « SplPriorityQueue::key
  • SplPriorityQueue::recoverFromCorruption »
  • PHP Manual
  • SplPriorityQueue
  • Pasar a la siguiente nodo

SplPriorityQueue::next

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::next — Pasar a la siguiente nodo

Descripción

public SplPriorityQueue::next ( ) : void

Extrae el nodo superior de la cola.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Recuperar desde la condición corrupta y permitir acciones más en la cola

  • « SplPriorityQueue::next
  • SplPriorityQueue::rewind »
  • PHP Manual
  • SplPriorityQueue
  • Recuperar desde la condición corrupta y permitir acciones más en la cola

SplPriorityQueue::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::recoverFromCorruption — Recuperar desde la condición corrupta y permitir acciones más en la cola

Descripción

public SplPriorityQueue::recoverFromCorruption ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobinar iterador de vuelta al inicio (no-op)

  • « SplPriorityQueue::recoverFromCorruption
  • SplPriorityQueue::setExtractFlags »
  • PHP Manual
  • SplPriorityQueue
  • Rebobinar iterador de vuelta al inicio (no-op)

SplPriorityQueue::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::rewind — Rebobinar iterador de vuelta al inicio (no-op)

Descripción

public SplPriorityQueue::rewind ( ) : void

Este rebobina el iterador al comienzo. Se trata de un no-op de montones como el iterador es virtual y de hecho nunca se mueve de arriba del montón.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Establece el modo de extracción

  • « SplPriorityQueue::rewind
  • SplPriorityQueue::top »
  • PHP Manual
  • SplPriorityQueue
  • Establece el modo de extracción

SplPriorityQueue::setExtractFlags

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::setExtractFlags — Establece el modo de extracción

Descripción

public SplPriorityQueue::setExtractFlags ( int $flags ) : void

Parámetros

flags

Define lo que se extrae por SplPriorityQueue::current(), SplPriorityQueue::top() y SplPriorityQueue::extract().

  • SplPriorityQueue::EXTR_DATA (0x00000001): Extraer los datos
  • SplPriorityQueue::EXTR_PRIORITY (0x00000002): Extraer la prioridad
  • SplPriorityQueue::EXTR_BOTH (0x00000003): Extraer un array con ambos

El modo por omisión es SplPriorityQueue::EXTR_DATA.

Valores devueltos

No devuelve ningún valor.


Mira en el nodo de la parte superior de la cola

  • « SplPriorityQueue::setExtractFlags
  • SplPriorityQueue::valid »
  • PHP Manual
  • SplPriorityQueue
  • Mira en el nodo de la parte superior de la cola

SplPriorityQueue::top

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::top — Mira en el nodo de la parte superior de la cola

Descripción

public SplPriorityQueue::top ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor o prioridad (o ambas) del nodo superior, dependiendo de las flags.


Comprobar si la cola contiene más nodos

  • « SplPriorityQueue::top
  • SplFixedArray »
  • PHP Manual
  • SplPriorityQueue
  • Comprobar si la cola contiene más nodos

SplPriorityQueue::valid

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::valid — Comprobar si la cola contiene más nodos

Descripción

public SplPriorityQueue::valid ( ) : bool

Comprueba si la cola contiene más nodos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la cola los contiene y mas nodos, false de lo contrario.


La clase SplFixedArray

(PHP 5 >= 5.3.0, PHP 7)

Introducción

la clase SplFixedArray proporciona la funcionalidad principal de un array. La principal diferencia entre SplFixedArray y un array normal de PHP es que la clase SplFixedArray es de longitud fija y sólo permite enteros dentro del rango de índices. La ventaja es que usa menos memoría que un array estándar.

Sinopsis de la Clase

SplFixedArray implements Iterator , ArrayAccess , Countable {
/* Métodos */
public __construct ( int $size = 0 )
public count ( ) : int
public current ( ) : mixed
public static fromArray ( array $array , bool $save_indexes = true ) : SplFixedArray
public getSize ( ) : int
public key ( ) : int
public next ( ) : void
public offsetExists ( int $index ) : bool
public offsetGet ( int $index ) : mixed
public offsetSet ( int $index , mixed $newval ) : void
public offsetUnset ( int $index ) : void
public rewind ( ) : void
public setSize ( int $size ) : bool
public toArray ( ) : array
public valid ( ) : bool
public __wakeup ( ) : void
}

Ejemplos

Ejemplo #1 Ejemplo de uso SplFixedArray

<?php
// Inicializar el array con una longitud fija
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

var_dump($array[0]); // NULL
var_dump($array[1]); // int(2)

var_dump($array["4"]); // string(3) "foo"

// Aumentar el tamaño del array a 10
$array->setSize(10);

$array[9] = "asdf";

// Reducir el tamaño de un array a 2
$array->setSize(2);

// Las siguientes líneas lanzan una RuntimeException: Index invalid or out of range (Índice inválido o fuera de rango)
try {
    var_dump($array["non-numeric"]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[-1]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[5]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}
?>

El resultado del ejemplo sería:

NULL
int(2)
string(3) "foo"
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range

Tabla de contenidos

  • SplFixedArray::__construct — Construye un nuevo array fijo
  • SplFixedArray::count — Devuelve el tamaño del array
  • SplFixedArray::current — Devuelve la entrada del array actual
  • SplFixedArray::fromArray — Importa un array PHP en una instancia SplFixedArray
  • SplFixedArray::getSize — Obtiene el tamaño de el array
  • SplFixedArray::key — Devuelve los índices del array actual
  • SplFixedArray::next — Mover a la siguiente entrada
  • SplFixedArray::offsetExists — Devuelve si el índice solicitado existe
  • SplFixedArray::offsetGet — Devuelve el valor en el índice específicado
  • SplFixedArray::offsetSet — Establece un nuevo valor para el índice específicado
  • SplFixedArray::offsetUnset — Destruye el valor en el índice específicado
  • SplFixedArray::rewind — Rebobina el iterador hasta el inicio
  • SplFixedArray::setSize — Cambiar el tamaño de un array
  • SplFixedArray::toArray — Devuelve un array PHP de un array fijo
  • SplFixedArray::valid — Comprueba si el array contiene más elementos
  • SplFixedArray::__wakeup — Reinicializar el array después de ser deserializado


Construye un nuevo array fijo

  • « SplFixedArray
  • SplFixedArray::count »
  • PHP Manual
  • SplFixedArray
  • Construye un nuevo array fijo

SplFixedArray::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::__construct — Construye un nuevo array fijo

Descripción

public SplFixedArray::__construct ( int $size = 0 )

Inicializa un array fijo con un número de valores null igual al tamaño dado por size.

Parámetros

size

El tamaño de el array fijo. Se exige que sea un número entre 0 y PHP_INT_MAX.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo InvalidArgumentException cuando size es un número negativo number.

Emite un E_WARNING cuando size no se puede procesar como un número.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::__construct()

<?php
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

foreach($array as $v) {
  var_dump($v);
}
?>

El resultado del ejemplo sería:

NULL
int(2)
NULL
NULL
string(3) "foo"


Devuelve el tamaño del array

  • « SplFixedArray::__construct
  • SplFixedArray::current »
  • PHP Manual
  • SplFixedArray
  • Devuelve el tamaño del array

SplFixedArray::count

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::count — Devuelve el tamaño del array

Descripción

public SplFixedArray::count ( ) : int

Devuelve el tamaño del array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño del array.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::count()

<?php
$array = new SplFixedArray(5);
echo $array->count() . "\n";
echo count($array) . "\n";
?>

El resultado del ejemplo sería:

5
5

Notas

Nota:

Este método es funcionalmente equivalente al método SplFixedArray::getSize().

Nota:

El cómputo de elementos es siempre igual al tamaño del conjunto ya que todos los valores son inicialmente inicializados con null.

Ver también

  • SplFixedArray::getSize() - Obtiene el tamaño de el array


Devuelve la entrada del array actual

  • « SplFixedArray::count
  • SplFixedArray::fromArray »
  • PHP Manual
  • SplFixedArray
  • Devuelve la entrada del array actual

SplFixedArray::current

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::current — Devuelve la entrada del array actual

Descripción

public SplFixedArray::current ( ) : mixed

Obtiene la entrada del elemento array actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del elemento actual.

Errores/Excepciones

Lanza una excepción de tipo RuntimeException cuando el puntero interno del array apunta a un índice no válido o está fuera de los límites.


Importa un array PHP en una instancia SplFixedArray

  • « SplFixedArray::current
  • SplFixedArray::getSize »
  • PHP Manual
  • SplFixedArray
  • Importa un array PHP en una instancia SplFixedArray

SplFixedArray::fromArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::fromArray — Importa un array PHP en una instancia SplFixedArray

Descripción

public static SplFixedArray::fromArray ( array $array , bool $save_indexes = true ) : SplFixedArray

Importa un array PHP en una nueva instancia SplFixedArray.

Parámetros

array

El array a importar.

save_indexes

Intenta guardar los índices numéricos usados en el array original.

Valores devueltos

Devuelve una instancia de SplFixedArray conteniendo el contenido de el array.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::fromArray()

<?php
$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3));

var_dump($fa);

$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3), false);

var_dump($fa);
?>

El resultado del ejemplo sería:

object(SplFixedArray)#1 (4) {
  [0]=>
  int(2)
  [1]=>
  int(1)
  [2]=>
  NULL
  [3]=>
  int(3)
}
object(SplFixedArray)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Obtiene el tamaño de el array

  • « SplFixedArray::fromArray
  • SplFixedArray::key »
  • PHP Manual
  • SplFixedArray
  • Obtiene el tamaño de el array

SplFixedArray::getSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::getSize — Obtiene el tamaño de el array

Descripción

public SplFixedArray::getSize ( ) : int

Obtiener el tamaño de el array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño de el array, como un integer.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::getSize()

<?php
$array = new SplFixedArray(5);
echo $array->getSize()."\n";
$array->setSize(10);
echo $array->getSize()."\n";
?>

El resultado del ejemplo sería:

5
10

Notas

Nota:

Este método es funcionalmente equivalente al método SplFixedArray::count()

Ver también

  • SplFixedArray::count() - Devuelve el tamaño del array


Devuelve los índices del array actual

  • « SplFixedArray::getSize
  • SplFixedArray::next »
  • PHP Manual
  • SplFixedArray
  • Devuelve los índices del array actual

SplFixedArray::key

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::key — Devuelve los índices del array actual

Descripción

public SplFixedArray::key ( ) : int

Devuelve los índice del array actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los índices del array actual.


Mover a la siguiente entrada

  • « SplFixedArray::key
  • SplFixedArray::offsetExists »
  • PHP Manual
  • SplFixedArray
  • Mover a la siguiente entrada

SplFixedArray::next

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::next — Mover a la siguiente entrada

Descripción

public SplFixedArray::next ( ) : void

Mover el iterador a la siguiente entrada en el array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Devuelve si el índice solicitado existe

  • « SplFixedArray::next
  • SplFixedArray::offsetGet »
  • PHP Manual
  • SplFixedArray
  • Devuelve si el índice solicitado existe

SplFixedArray::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetExists — Devuelve si el índice solicitado existe

Descripción

public SplFixedArray::offsetExists ( int $index ) : bool

Comprueba si el índice index solicitado existe.

Parámetros

index

El índice a ser comprobado.

Valores devueltos

true si el indice index existe, en caso contrario false.


Devuelve el valor en el índice específicado

  • « SplFixedArray::offsetExists
  • SplFixedArray::offsetSet »
  • PHP Manual
  • SplFixedArray
  • Devuelve el valor en el índice específicado

SplFixedArray::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetGet — Devuelve el valor en el índice específicado

Descripción

public SplFixedArray::offsetGet ( int $index ) : mixed

Devuelve el valor en el índice index específicado.

Parámetros

index

El índice con el valor.

Valores devueltos

El valor específicado en index.

Errores/Excepciones

Lanza una excepción de tipo RuntimeException cuando index está fuera del tamaño definido del array o cuando index no se puede procesar como un entero.


Establece un nuevo valor para el índice específicado

  • « SplFixedArray::offsetGet
  • SplFixedArray::offsetUnset »
  • PHP Manual
  • SplFixedArray
  • Establece un nuevo valor para el índice específicado

SplFixedArray::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetSet — Establece un nuevo valor para el índice específicado

Descripción

public SplFixedArray::offsetSet ( int $index , mixed $newval ) : void

Establece el valor en el index específicado en newval.

Parámetros

index

El índice a ser establecido.

newval

El nuevo valor para index.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo RuntimeException cuando index está fuera del tamaño definido del array o cuando index no se puede procesar como un entero.


Destruye el valor en el índice específicado

  • « SplFixedArray::offsetSet
  • SplFixedArray::rewind »
  • PHP Manual
  • SplFixedArray
  • Destruye el valor en el índice específicado

SplFixedArray::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetUnset — Destruye el valor en el índice específicado

Descripción

public SplFixedArray::offsetUnset ( int $index ) : void

Destruye el valor en el índice específicado.

Parámetros

index

El índice a ser destruido.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción de tipo RuntimeException cuando index está fuera del tamaño definido del array o cuando index no se puede procesar como un entero.


Rebobina el iterador hasta el inicio

  • « SplFixedArray::offsetUnset
  • SplFixedArray::setSize »
  • PHP Manual
  • SplFixedArray
  • Rebobina el iterador hasta el inicio

SplFixedArray::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::rewind — Rebobina el iterador hasta el inicio

Descripción

public SplFixedArray::rewind ( ) : void

Rebobina el iterador hasta el inicio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Cambiar el tamaño de un array

  • « SplFixedArray::rewind
  • SplFixedArray::toArray »
  • PHP Manual
  • SplFixedArray
  • Cambiar el tamaño de un array

SplFixedArray::setSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::setSize — Cambiar el tamaño de un array

Descripción

public SplFixedArray::setSize ( int $size ) : bool

Cambiar el tamaño de un array al nuevo tamaño dado por el parámetro size. Si size es menor que el tamaño actual del array, cualquier valor posterior al nuevo tamaño será descartado. Si size es mayoy que el tamaño actual del array, el array será rellenado con valores null.

Parámetros

size

El nuevo tamaño del array. Debería ser un valor entre 0 y PHP_INT_MAX.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Lanza una excepción de tipo InvalidArgumentException cuando size es menor que cero.

Emite un E_WARNING cuando size no se puede usar como un número.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::setSize()

<?php
   $array = new SplFixedArray(5);
   echo $array->getSize()."\n";
   $array->setSize(10);
   echo $array->getSize()."\n";
?>

El resultado del ejemplo sería:

5
10


Devuelve un array PHP de un array fijo

  • « SplFixedArray::setSize
  • SplFixedArray::valid »
  • PHP Manual
  • SplFixedArray
  • Devuelve un array PHP de un array fijo

SplFixedArray::toArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::toArray — Devuelve un array PHP de un array fijo

Descripción

public SplFixedArray::toArray ( ) : array

Devuelve un array PHP de un array fijo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array PHP, similar al array fijo.

Ejemplos

Ejemplo #1 Ejemplo de SplFixedArray::toArray()

<?php
$fa = new SplFixedArray(3);
$fa[0] = 0;
$fa[2] = 2;
var_dump($fa->toArray());
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  int(0)
  [1]=>
  NULL
  [2]=>
  int(2)
}


Comprueba si el array contiene más elementos

  • « SplFixedArray::toArray
  • SplFixedArray::__wakeup »
  • PHP Manual
  • SplFixedArray
  • Comprueba si el array contiene más elementos

SplFixedArray::valid

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::valid — Comprueba si el array contiene más elementos

Descripción

public SplFixedArray::valid ( ) : bool

Comprueba si el array contiene más elementos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el array contiene más elementos, en caso contrario false.


Reinicializar el array después de ser deserializado

  • « SplFixedArray::valid
  • SplObjectStorage »
  • PHP Manual
  • SplFixedArray
  • Reinicializar el array después de ser deserializado

SplFixedArray::__wakeup

(PHP 5 >= 5.5.0, PHP 7)

SplFixedArray::__wakeup — Reinicializar el array después de ser deserializado

Descripción

public SplFixedArray::__wakeup ( ) : void

Reinicializa el array después de ser deserializado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


La clase SplObjectStorage

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La clase SplObjectStorage proporciona una correspondencia de objetos de datos o, ignorando los datos, un conjunto de objetos. Este doble propósito puede ser útil en muchos casos relacionados con la necesidad de identificar objetos de forma única.

Sinopsis de la Clase

SplObjectStorage implements Countable , Iterator , Serializable , ArrayAccess {
/* Métodos */
public addAll ( SplObjectStorage $storage ) : void
public attach ( object $object , mixed $data = null ) : void
public contains ( object $object ) : bool
public count ( ) : int
public current ( ) : object
public detach ( object $object ) : void
public getHash ( object $object ) : string
public getInfo ( ) : mixed
public key ( ) : int
public next ( ) : void
public offsetExists ( object $object ) : bool
public offsetGet ( object $object ) : mixed
public offsetSet ( object $object , mixed $data = null ) : void
public offsetUnset ( object $object ) : void
public removeAll ( SplObjectStorage $storage ) : void
public removeAllExcept ( SplObjectStorage $storage ) : void
public rewind ( ) : void
public serialize ( ) : string
public setInfo ( mixed $data ) : void
public unserialize ( string $serialized ) : void
public valid ( ) : bool
}

Ejemplos

Ejemplo #1 SplObjectStorage como un conjunto

<?php
// Como un conjunto de objetos
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s->attach($o1);
$s->attach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));

$s->detach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Ejemplo #2 SplObjectStorage como un mapa

<?php
// Como una correspondencia de objetos a datos
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s[$o1] = "data for object 1";
$s[$o2] = array(1,2,3);

if (isset($s[$o2])) {
    var_dump($s[$o2]);
}
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

Tabla de contenidos

  • SplObjectStorage::addAll — Agrega todos los objetos de otro almacenamiento
  • SplObjectStorage::attach — Agrega un objeto en el almacenamiento
  • SplObjectStorage::contains — Comprueba si el almacenamiento contiene un objeto específico
  • SplObjectStorage::count — Devuelve el número de objetos en el almacenamiento
  • SplObjectStorage::current — Devuelve la entrada actual de almacenamiento
  • SplObjectStorage::detach — Quita un object de el almacenamiento
  • SplObjectStorage::getHash — Calcular un identificador único (hash) para los objetos contenidos
  • SplObjectStorage::getInfo — Devuelve los datos asociados con la entrada del iterador actual
  • SplObjectStorage::key — Devuelve el índice en el que se encuentra el iterador actualmente
  • SplObjectStorage::next — Mover a la siguiente entrada
  • SplObjectStorage::offsetExists — Comprueba si un objeto existe en el almacenamiento
  • SplObjectStorage::offsetGet — Devuelve los datos asociados con un object
  • SplObjectStorage::offsetSet — Asocia datos a un objeto en el almacenamiento
  • SplObjectStorage::offsetUnset — Quita un objeto de el almacenamiento
  • SplObjectStorage::removeAll — Remover objetos contenidos en otro almacenamiento de el almacenamiento actual
  • SplObjectStorage::removeAllExcept — Remover objetos excepto los contenidos en otro almacenamiento del almacenamiento actual
  • SplObjectStorage::rewind — Rebobina el iterador a el primer elemento de el almacenamiento
  • SplObjectStorage::serialize — Serializa el almacenamiento
  • SplObjectStorage::setInfo — Establece los datos asociados con el iterador de la entrada actual
  • SplObjectStorage::unserialize — Deserializa un almacenamiento desde su representación string
  • SplObjectStorage::valid — Comprobar si la entrada actual del iterador es válida


Agrega todos los objetos de otro almacenamiento

  • « SplObjectStorage
  • SplObjectStorage::attach »
  • PHP Manual
  • SplObjectStorage
  • Agrega todos los objetos de otro almacenamiento

SplObjectStorage::addAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::addAll — Agrega todos los objetos de otro almacenamiento

Descripción

public SplObjectStorage::addAll ( SplObjectStorage $storage ) : void

Agrega todos los pares de objetos de datos de un diferente almacenamiento en el almacenamiento actual.

Parámetros

storage

El almacenamiento que se quiere importar.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::addAll()

<?php
$o = new StdClass;
$a = new SplObjectStorage();
$a[$o] = "hola";

$b = new SplObjectStorage();
$b->addAll($a);
echo $b[$o]."\n";
?>

El resultado del ejemplo sería algo similar a:

hola

Ver también

  • SplObjectStorage::removeAll() - Remover objetos contenidos en otro almacenamiento de el almacenamiento actual


Agrega un objeto en el almacenamiento

  • « SplObjectStorage::addAll
  • SplObjectStorage::contains »
  • PHP Manual
  • SplObjectStorage
  • Agrega un objeto en el almacenamiento

SplObjectStorage::attach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::attach — Agrega un objeto en el almacenamiento

Descripción

public SplObjectStorage::attach ( object $object , mixed $data = null ) : void

Añade un object dentro del almacenamiento, y opcionalmente se asocian a algunos datos.

Parámetros

object

El object a ser añadido.

data

Los datos asociados con el object.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::attach()

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$s = new SplObjectStorage();
$s->attach($o1); // similar a $s[$o1] = NULL;
$s->attach($o2, "hola"); // similar a $s[$o2] = "hola";

var_dump($s[$o1]);
var_dump($s[$o2]);

?>

El resultado del ejemplo sería algo similar a:

NULL
string(4) "hola"

Historial de cambios

Versión | Descripción
5.3.0 | Añadido el parámetro data.

Ver también

  • SplObjectStorage::detach() - Quita un object de el almacenamiento
  • SplObjectStorage::offsetSet() - Asocia datos a un objeto en el almacenamiento


Comprueba si el almacenamiento contiene un objeto específico

  • « SplObjectStorage::attach
  • SplObjectStorage::count »
  • PHP Manual
  • SplObjectStorage
  • Comprueba si el almacenamiento contiene un objeto específico

SplObjectStorage::contains

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::contains — Comprueba si el almacenamiento contiene un objeto específico

Descripción

public SplObjectStorage::contains ( object $object ) : bool

Comprueba si el almacenamiento contiene al object proporcionado.

Parámetros

object

El object a ser comprobado.

Valores devueltos

Devuelve true si el object está en el almacenamiento, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::contains()

<?php
$o1 = new StdClass;
$o2 = new StdClass;

$s = new SplObjectStorage();

$s[$o1] = "hola";
var_dump($s->contains($o1));
var_dump($s->contains($o2));
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)

Ver también

  • SplObjectStorage::offsetExists() - Comprueba si un objeto existe en el almacenamiento


Devuelve el número de objetos en el almacenamiento

  • « SplObjectStorage::contains
  • SplObjectStorage::current »
  • PHP Manual
  • SplObjectStorage
  • Devuelve el número de objetos en el almacenamiento

SplObjectStorage::count

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::count — Devuelve el número de objetos en el almacenamiento

Descripción

public SplObjectStorage::count ( ) : int

Cuenta el número de objetos en el almacenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de objetos en el almacenamiento.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::count()

<?php
$s = new SplObjectStorage();
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);
$s->attach($o2);
$s->attach($o1);
var_dump($s->count());
var_dump(count($s));
?>

El resultado del ejemplo sería algo similar a:

int(2)
int(2)

Ver también

  • SplObjectStorage::attach() - Agrega un objeto en el almacenamiento
  • SplObjectStorage::detach() - Quita un object de el almacenamiento


Devuelve la entrada actual de almacenamiento

  • « SplObjectStorage::count
  • SplObjectStorage::detach »
  • PHP Manual
  • SplObjectStorage
  • Devuelve la entrada actual de almacenamiento

SplObjectStorage::current

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::current — Devuelve la entrada actual de almacenamiento

Descripción

public SplObjectStorage::current ( ) : object

Devuelve la entrada actual de almacenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El object en la posición actual iterador.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::current()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar a current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

Ver también

  • SplObjectStorage::rewind() - Rebobina el iterador a el primer elemento de el almacenamiento
  • SplObjectStorage::key() - Devuelve el índice en el que se encuentra el iterador actualmente
  • SplObjectStorage::next() - Mover a la siguiente entrada
  • SplObjectStorage::valid() - Comprobar si la entrada actual del iterador es válida
  • SplObjectStorage::getInfo() - Devuelve los datos asociados con la entrada del iterador actual


Quita un object de el almacenamiento

  • « SplObjectStorage::current
  • SplObjectStorage::getHash »
  • PHP Manual
  • SplObjectStorage
  • Quita un object de el almacenamiento

SplObjectStorage::detach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::detach — Quita un object de el almacenamiento

Descripción

public SplObjectStorage::detach ( object $object ) : void

Quita un object de el almacenamiento.

Parámetros

object

El object a ser removido.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::detach()

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->detach($o);
var_dump(count($s));
?>

El resultado del ejemplo sería algo similar a:

int(1)
int(0)

Ver también

  • SplObjectStorage::attach() - Agrega un objeto en el almacenamiento
  • SplObjectStorage::removeAll() - Remover objetos contenidos en otro almacenamiento de el almacenamiento actual


Calcular un identificador único (hash) para los objetos contenidos

  • « SplObjectStorage::detach
  • SplObjectStorage::getInfo »
  • PHP Manual
  • SplObjectStorage
  • Calcular un identificador único (hash) para los objetos contenidos

SplObjectStorage::getHash

(PHP 5 >= 5.4.0, PHP 7)

SplObjectStorage::getHash — Calcular un identificador único (hash) para los objetos contenidos

Descripción

public SplObjectStorage::getHash ( object $object ) : string

Este método calcula un identificador para los objetos añadidos a un objeto SplObjectStorage.

La implementación en la clase SplObjectStorage devuelve el mismo valor que la función spl_object_hash().

El objeto de almacenamiento nunca contendrá más de un objeto con el mismo identificador. Por lo tanto, se puede usar para implementar un conjunto (una colección de valores únicos) donde la cualidad de un objeto de ser único está determinada por el valor devuelto por esta función.

Parámetros

object

El objeto cuyo identificador va a ser calculado.

Valores devueltos

Un string con el identificador calculado.

Errores/Excepciones

Se lanza una excepción de tipo RuntimeException cuando el valor devuelto no es un string.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::getHash()

<?php
class OneSpecimenPerClassStorage extends SplObjectStorage {
    public function getHash($o) {
        return get_class($o);
    }
}
class A {}

$s = new OneSpecimenPerClassStorage;
$o1 = new stdClass;
$o2 = new stdClass;
$o3 = new A;

$s[$o1] = 1;
//$o2 es considerado igual a $o1, por lo que el valor es reemplazado
$s[$o2] = 2;
$s[$o3] = 3;

//estos objetos son considerados iguales a los objetos anteriores
//por lo que se pueden usar para acceder a los valores almacenados en ellos
$p1 = new stdClass;
$p2 = new A;
echo $s[$p1], "\n";
echo $s[$p2], "\n";
?>

El resultado del ejemplo sería algo similar a:

2
3

Ver también

  • spl_object_hash() - Devuelve el id del hash del objeto dado


Devuelve los datos asociados con la entrada del iterador actual

  • « SplObjectStorage::getHash
  • SplObjectStorage::key »
  • PHP Manual
  • SplObjectStorage
  • Devuelve los datos asociados con la entrada del iterador actual

SplObjectStorage::getInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::getInfo — Devuelve los datos asociados con la entrada del iterador actual

Descripción

public SplObjectStorage::getInfo ( ) : mixed

Devuelve los datos o información, asociada al objeto señalado por la posición actual de el iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los datos asociados con la posición actual de el iterador.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::getInfo()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar a current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

Ver también

  • SplObjectStorage::current() - Devuelve la entrada actual de almacenamiento
  • SplObjectStorage::rewind() - Rebobina el iterador a el primer elemento de el almacenamiento
  • SplObjectStorage::key() - Devuelve el índice en el que se encuentra el iterador actualmente
  • SplObjectStorage::next() - Mover a la siguiente entrada
  • SplObjectStorage::valid() - Comprobar si la entrada actual del iterador es válida
  • SplObjectStorage::setInfo() - Establece los datos asociados con el iterador de la entrada actual


Devuelve el índice en el que se encuentra el iterador actualmente

  • « SplObjectStorage::getInfo
  • SplObjectStorage::next »
  • PHP Manual
  • SplObjectStorage
  • Devuelve el índice en el que se encuentra el iterador actualmente

SplObjectStorage::key

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::key — Devuelve el índice en el que se encuentra el iterador actualmente

Descripción

public SplObjectStorage::key ( ) : int

Devuelve el índice en el que se encuentra el iterador actualmente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El índice correspondiente a la posición de el iterador.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::key()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar a current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

Ver también

  • SplObjectStorage::rewind() - Rebobina el iterador a el primer elemento de el almacenamiento
  • SplObjectStorage::current() - Devuelve la entrada actual de almacenamiento
  • SplObjectStorage::next() - Mover a la siguiente entrada
  • SplObjectStorage::valid() - Comprobar si la entrada actual del iterador es válida


Mover a la siguiente entrada

  • « SplObjectStorage::key
  • SplObjectStorage::offsetExists »
  • PHP Manual
  • SplObjectStorage
  • Mover a la siguiente entrada

SplObjectStorage::next

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::next — Mover a la siguiente entrada

Descripción

public SplObjectStorage::next ( ) : void

Mover el iterador al siguiente object en el almacenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::next()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar a current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

Ver también

  • SPLObjectStorage::rewind() - Rebobina el iterador a el primer elemento de el almacenamiento


Comprueba si un objeto existe en el almacenamiento

  • « SplObjectStorage::next
  • SplObjectStorage::offsetGet »
  • PHP Manual
  • SplObjectStorage
  • Comprueba si un objeto existe en el almacenamiento

SplObjectStorage::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetExists — Comprueba si un objeto existe en el almacenamiento

Descripción

public SplObjectStorage::offsetExists ( object $object ) : bool

Comprueba si un object existe en el almacenamiento.

Nota:

SplObjectStorage::offsetExists() es un alias de SplObjectStorage::contains().

Parámetros

object

El object a ser comprobado.

Valores devueltos

Devuelve true si el object existe en el almacenamiento, y false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::offsetExists()

<?php
$s = new SplObjectStorage;
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);

var_dump($s->offsetExists($o1)); // Similar a isset($s[$o1])
var_dump($s->offsetExists($o2)); // Similar a isset($s[$o2])
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)

Ver también

  • SplObjectStorage::offsetSet() - Asocia datos a un objeto en el almacenamiento
  • SplObjectStorage::offsetGet() - Devuelve los datos asociados con un object
  • SplObjectStorage::offsetUnset() - Quita un objeto de el almacenamiento


Devuelve los datos asociados con un object

  • « SplObjectStorage::offsetExists
  • SplObjectStorage::offsetSet »
  • PHP Manual
  • SplObjectStorage
  • Devuelve los datos asociados con un object

SplObjectStorage::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetGet — Devuelve los datos asociados con un object

Descripción

public SplObjectStorage::offsetGet ( object $object ) : mixed

Devuelve los datos asociados con un object en el almacenamiento.

Parámetros

object

El object a ser comprobado.

Valores devueltos

Los datos previamente asociados con el object en el almacenamiento.

Errores/Excepciones

Lanza una excepción de tipo UnexpectedValueException cuando no se pudo encontrar object.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::offsetGet()

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;
$o2 = new StdClass;

$s[$o1] = "hola";
$s->attach($o2);

var_dump($s->offsetGet($o1)); // Similar a $s[$o1]
var_dump($s->offsetGet($o2)); // Similar a $s[$o2]
?>

El resultado del ejemplo sería algo similar a:

string(4) "hola"
NULL

Ver también

  • SplObjectStorage::offsetSet() - Asocia datos a un objeto en el almacenamiento
  • SplObjectStorage::offsetExists() - Comprueba si un objeto existe en el almacenamiento
  • SplObjectStorage::offsetUnset() - Quita un objeto de el almacenamiento


Asocia datos a un objeto en el almacenamiento

  • « SplObjectStorage::offsetGet
  • SplObjectStorage::offsetUnset »
  • PHP Manual
  • SplObjectStorage
  • Asocia datos a un objeto en el almacenamiento

SplObjectStorage::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetSet — Asocia datos a un objeto en el almacenamiento

Descripción

public SplObjectStorage::offsetSet ( object $object , mixed $data = null ) : void

Asocia datos a un object en el almacenamiento.

Nota:

SplObjectStorage::offsetSet() es un alias de SplObjectStorage::attach().

Parámetros

object

El object al que se le van a asociar datos.

data

Los datos asociados con el object.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::offsetSet()

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;

$s->offsetSet($o1, "hola"); // Similar a $s[$o1] = "hola";

var_dump($s[$o1]);
?>

El resultado del ejemplo sería algo similar a:

string(4) "hola"

Ver también

  • SplObjectStorage::attach() - Agrega un objeto en el almacenamiento
  • SplObjectStorage::offsetGet() - Devuelve los datos asociados con un object
  • SplObjectStorage::offsetExists() - Comprueba si un objeto existe en el almacenamiento
  • SplObjectStorage::offsetUnset() - Quita un objeto de el almacenamiento


Quita un objeto de el almacenamiento

  • « SplObjectStorage::offsetSet
  • SplObjectStorage::removeAll »
  • PHP Manual
  • SplObjectStorage
  • Quita un objeto de el almacenamiento

SplObjectStorage::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetUnset — Quita un objeto de el almacenamiento

Descripción

public SplObjectStorage::offsetUnset ( object $object ) : void

Quitar un object de el almacenamiento.

Nota:

SplObjectStorage::offsetUnset() es un alias de SplObjectStorage::detach().

Parámetros

object

El object a ser removido.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::offsetUnset()

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->offsetUnset($o); // Similar a unset($s[$o])
var_dump(count($s));
?>

El resultado del ejemplo sería algo similar a:

int(1)
int(0)

Ver también

  • SplObjectStorage::offsetGet() - Devuelve los datos asociados con un object
  • SplObjectStorage::offsetSet() - Asocia datos a un objeto en el almacenamiento
  • SplObjectStorage::offsetExists() - Comprueba si un objeto existe en el almacenamiento


Remover objetos contenidos en otro almacenamiento de el almacenamiento actual

  • « SplObjectStorage::offsetUnset
  • SplObjectStorage::removeAllExcept »
  • PHP Manual
  • SplObjectStorage
  • Remover objetos contenidos en otro almacenamiento de el almacenamiento actual

SplObjectStorage::removeAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::removeAll — Remover objetos contenidos en otro almacenamiento de el almacenamiento actual

Descripción

public SplObjectStorage::removeAll ( SplObjectStorage $storage ) : void

Remover objetos contenidos en otro almacenamiento de el almacenamiento actual.

Parámetros

storage

El almacenamiento que contiene los elementos a remover.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::removeAll()

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$a = new SplObjectStorage();
$a[$o1] = "foo";

$b = new SplObjectStorage();
$b[$o1] = "bar";
$b[$o2] = "gee";

var_dump(count($b));
$b->removeAll($a);
var_dump(count($b));
?>

El resultado del ejemplo sería algo similar a:

int(2)
int(1)

Ver también

  • SplObjectStorage::addAll() - Agrega todos los objetos de otro almacenamiento


Remover objetos excepto los contenidos en otro almacenamiento del almacenamiento actual

  • « SplObjectStorage::removeAll
  • SplObjectStorage::rewind »
  • PHP Manual
  • SplObjectStorage
  • Remover objetos excepto los contenidos en otro almacenamiento del almacenamiento actual

SplObjectStorage::removeAllExcept

(PHP 5 >= 5.3.6, PHP 7)

SplObjectStorage::removeAllExcept — Remover objetos excepto los contenidos en otro almacenamiento del almacenamiento actual

Descripción

public SplObjectStorage::removeAllExcept ( SplObjectStorage $storage ) : void

Remover todos los objetos excepto los contenidos en otro almacenamiento del almacenamiento actual.

Parámetros

storage

El almacenamiento que contiene los elementos a mantener en el almacenamiento actual.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::removeAllExcept()

<?php
$a = (object) 'a';
$b = (object) 'b';
$c = (object) 'c';

$foo = new SplObjectStorage;
$foo->attach($a);
$foo->attach($b);

$bar = new SplObjectStorage;
$bar->attach($b);
$bar->attach($c);

$foo->removeAllExcept($bar);
var_dump($foo->contains($a));
var_dump($foo->contains($b));
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Rebobina el iterador a el primer elemento de el almacenamiento

  • « SplObjectStorage::removeAllExcept
  • SplObjectStorage::serialize »
  • PHP Manual
  • SplObjectStorage
  • Rebobina el iterador a el primer elemento de el almacenamiento

SplObjectStorage::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::rewind — Rebobina el iterador a el primer elemento de el almacenamiento

Descripción

public SplObjectStorage::rewind ( ) : void

Rebobina el iterador a el primer elemento de el almacenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::rewind()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar a current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

int(1)
int(0)

Ver también

  • SplObjectStorage::next() - Mover a la siguiente entrada


Serializa el almacenamiento

  • « SplObjectStorage::rewind
  • SplObjectStorage::setInfo »
  • PHP Manual
  • SplObjectStorage
  • Serializa el almacenamiento

SplObjectStorage::serialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::serialize — Serializa el almacenamiento

Descripción

public SplObjectStorage::serialize ( ) : string

Devuelve un string que representa el almacenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un string que representa el almacenamiento.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::serialize()

<?php
$s = new SplObjectStorage;
$o = new StdClass;
$s[$o] = "datos";

echo $s->serialize()."\n";
?>

El resultado del ejemplo sería algo similar a:

x:i:1;O:8:"stdClass":0:{},s:4:"datos";;m:a:0:{}

Ver también

  • SplObjectStorage::unserialize() - Deserializa un almacenamiento desde su representación string


Establece los datos asociados con el iterador de la entrada actual

  • « SplObjectStorage::serialize
  • SplObjectStorage::unserialize »
  • PHP Manual
  • SplObjectStorage
  • Establece los datos asociados con el iterador de la entrada actual

SplObjectStorage::setInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::setInfo — Establece los datos asociados con el iterador de la entrada actual

Descripción

public SplObjectStorage::setInfo ( mixed $data ) : void

Asocia datos o información, con el objeto actualmente señalado por el iterador.

Parámetros

data

Los datos a ser asociados con la entrada del iterador actual.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::setInfo()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $s->setInfo("new");
    $s->next();
}
var_dump($s[$o1]);
var_dump($s[$o2]);
?>

El resultado del ejemplo sería algo similar a:

string(3) "new"
string(3) "new"

Ver también

  • SplObjectStorage::current() - Devuelve la entrada actual de almacenamiento
  • SplObjectStorage::rewind() - Rebobina el iterador a el primer elemento de el almacenamiento
  • SplObjectStorage::key() - Devuelve el índice en el que se encuentra el iterador actualmente
  • SplObjectStorage::next() - Mover a la siguiente entrada
  • SplObjectStorage::valid() - Comprobar si la entrada actual del iterador es válida
  • SplObjectStorage::getInfo() - Devuelve los datos asociados con la entrada del iterador actual


Deserializa un almacenamiento desde su representación string

  • « SplObjectStorage::setInfo
  • SplObjectStorage::valid »
  • PHP Manual
  • SplObjectStorage
  • Deserializa un almacenamiento desde su representación string

SplObjectStorage::unserialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::unserialize — Deserializa un almacenamiento desde su representación string

Descripción

public SplObjectStorage::unserialize ( string $serialized ) : void

Deserializa las entradas del almacenamiento y los añade al almacenamiento actual.

Parámetros

serialized

La representación serializada de el almacenamiento.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::unserialize()

<?php
$s1 = new SplObjectStorage;
$s2 = new SplObjectStorage;
$o = new StdClass;
$s1[$o] = "datos";

$s2->unserialize($s1->serialize());

var_dump(count($s2));
?>

El resultado del ejemplo sería algo similar a:

int(1)

Ver también

  • SplObjectStorage::serialize() - Serializa el almacenamiento


Comprobar si la entrada actual del iterador es válida

  • « SplObjectStorage::unserialize
  • Iteradores »
  • PHP Manual
  • SplObjectStorage
  • Comprobar si la entrada actual del iterador es válida

SplObjectStorage::valid

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::valid — Comprobar si la entrada actual del iterador es válida

Descripción

public SplObjectStorage::valid ( ) : bool

Devuelve si la entrada actual del iterador es válida.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada actual del iterador es válida, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplObjectStorage::valid()

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    echo $s->key()."\n";
    $s->next();
}
?>

El resultado del ejemplo sería algo similar a:

0
1

Ver también

  • SplObjectStorage::current() - Devuelve la entrada actual de almacenamiento
  • SplObjectStorage::getInfo() - Devuelve los datos asociados con la entrada del iterador actual


Iteradores

Tabla de contenidos

  • AppendIterator
  • ArrayIterator
  • CachingIterator
  • CallbackFilterIterator
  • DirectoryIterator
  • EmptyIterator
  • FilesystemIterator
  • FilterIterator
  • GlobIterator
  • InfiniteIterator
  • IteratorIterator
  • LimitIterator
  • MultipleIterator
  • NoRewindIterator
  • ParentIterator
  • RecursiveArrayIterator
  • RecursiveCachingIterator
  • RecursiveCallbackFilterIterator
  • RecursiveDirectoryIterator
  • RecursiveFilterIterator
  • RecursiveIteratorIterator
  • RecursiveRegexIterator
  • RecursiveTreeIterator
  • RegexIterator

SPL proporciona un grupo de iteradores para recorrer objetos.

Árbol de las Clases de Iteradores de SPL

  • ArrayIterator
    • RecursiveArrayIterator
  • EmptyIterator
  • IteratorIterator
    • AppendIterator
    • CachingIterator
      • RecursiveCachingIterator
    • FilterIterator
      • CallbackFilterIterator
        • RecursiveCallbackFilterIterator
      • RecursiveFilterIterator
        • ParentIterator
      • RegexIterator
        • RecursiveRegexIterator
    • InfiniteIterator
    • LimitIterator
    • NoRewindIterator
  • MultipleIterator
  • RecursiveIteratorIterator
    • RecursiveTreeIterator
  • DirectoryIterator (extends SplFileInfo)
    • FilesystemIterator
      • GlobIterator
      • RecursiveDirectoryIterator


La clase AppendIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Iterador que recorre varios iteradores uno tras otro.

Sinopsis de la Clase

AppendIterator extends IteratorIterator implements OuterIterator {
/* Métodos */
public __construct ( )
public append ( Iterator $iterator ) : void
public current ( ) : mixed
public getArrayIterator ( ) : ArrayIterator
public getInnerIterator ( ) : Iterator
public getIteratorIndex ( ) : int
public key ( ) : scalar
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* Métodos heredados */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Tabla de contenidos

  • AppendIterator::append — Añade un iterador
  • AppendIterator::__construct — Construye un AppendIterator
  • AppendIterator::current — Obtiene el valor actual
  • AppendIterator::getArrayIterator — Obtiene el getArrayIterator
  • AppendIterator::getInnerIterator — Obtiene el iterador interno
  • AppendIterator::getIteratorIndex — Obtiene un índice de iteradores
  • AppendIterator::key — Obtiene la clave actual
  • AppendIterator::next — Desplazarse al siguiente elemento
  • AppendIterator::rewind — Rebobina el iterador
  • AppendIterator::valid — Comprueba la validación del elemento actual


Añade un iterador

  • « AppendIterator
  • AppendIterator::__construct »
  • PHP Manual
  • AppendIterator
  • Añade un iterador

AppendIterator::append

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::append — Añade un iterador

Descripción

public AppendIterator::append ( Iterator $iterator ) : void

Añade un iterador.

Parámetros

iterator

El iterador a añadir.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de AppendIterator::append()

<?php
$array_a = new ArrayIterator(array('a', 'b', 'c'));
$array_b = new ArrayIterator(array('d', 'e', 'f'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    echo $current;
}
?>

El resultado del ejemplo sería:

abcdef

Ver también

  • AppendIterator::__construct() - Construye un AppendIterator


Construye un AppendIterator

  • « AppendIterator::append
  • AppendIterator::current »
  • PHP Manual
  • AppendIterator
  • Construye un AppendIterator

AppendIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::__construct — Construye un AppendIterator

Descripción

public AppendIterator::__construct ( )

Construye un AppendIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Recorriendo AppendIterator con foreach

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$ingredientes = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($ingredientes);

foreach ($appendIterator as $key => $item) {
    echo $key . ' => ' . $item . PHP_EOL;
}
?>

El resultado del ejemplo sería:

0 => Margarita
1 => Siciliana
2 => Hawaii
0 => Cheese
1 => Anchovies
2 => Olives
3 => Pineapple
4 => Ham

Ejemplo #2 Recorriendo AppendIterator con la API de AppendIterator

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$ingredientes = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($ingredientes);

while ($appendIterator->valid()) {
    printf(
        '%s => %s => %s%s',
        $appendIterator->getIteratorIndex(),
        $appendIterator->key(),
        $appendIterator->current(),
        PHP_EOL
    );
    $appendIterator->next();
}
?>

El resultado del ejemplo sería:

0 => 0 => Margarita
0 => 1 => Siciliana
0 => 2 => Hawaii
1 => 0 => Cheese
1 => 1 => Anchovies
1 => 2 => Olives
1 => 3 => Pineapple
1 => 4 => Ham

Notas

Precaución

Al usar iterator_to_array() para copiar los valores de AppendIterator a un array, debe asignarse al parámetro opcional use_key el valor false. Si use_key no es false, las claves que se repitan en los iteradores internos se sobrescribirán en el array final. No existe ninguna forma para preservar las claves originales.

Ver también

  • AppendIterator::append() - Añade un iterador


Obtiene el valor actual

  • « AppendIterator::__construct
  • AppendIterator::getArrayIterator »
  • PHP Manual
  • AppendIterator
  • Obtiene el valor actual

AppendIterator::current

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::current — Obtiene el valor actual

Descripción

public AppendIterator::current ( ) : mixed

Obtiene el valor actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Si el valor actual es válido o null en caso contrario.

Ver también

  • Iterator::current() - Devuelve el elemento actual
  • AppendIterator::key() - Obtiene la clave actual
  • AppendIterator::valid() - Comprueba la validación del elemento actual
  • AppendIterator::next() - Desplazarse al siguiente elemento
  • AppendIterator::rewind() - Rebobina el iterador


Obtiene el getArrayIterator

  • « AppendIterator::current
  • AppendIterator::getInnerIterator »
  • PHP Manual
  • AppendIterator
  • Obtiene el getArrayIterator

AppendIterator::getArrayIterator

(PHP 5 >= 5.2.0, PHP 7)

AppendIterator::getArrayIterator — Obtiene el getArrayIterator

Descripción

public AppendIterator::getArrayIterator ( ) : ArrayIterator

Este método obtiene el objeto ArrayIterator empleado para almacenar los iteradores añadidos con AppendIterator::append().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un ArrayIterator que contiene los iteradores añadidos.

Ver también

  • AppendIterator::getInnerIterator() - Obtiene el iterador interno


Obtiene el iterador interno

  • « AppendIterator::getArrayIterator
  • AppendIterator::getIteratorIndex »
  • PHP Manual
  • AppendIterator
  • Obtiene el iterador interno

AppendIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::getInnerIterator — Obtiene el iterador interno

Descripción

public AppendIterator::getInnerIterator ( ) : Iterator

Este método devuelve el iterador interno actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno actual, o null si no hay ninguno.

Ejemplos

Ejemplo #1 Ejemplo de AppendIterator::getInnerIterator()

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new RegexIterator($array_a, '/^[ac]/');

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    $inner = $iterator->getInnerIterator();
    if ($inner instanceOf RegexIterator) {
        echo 'Filtered: ';
    } else {
        echo 'Original: ';
    }
    echo $current . PHP_EOL;
}
?>

El resultado del ejemplo sería:

Original: aardwolf
Original: bear
Original: capybara
Filtered: aardwolf
Filtered: capybara

Ver también

  • AppendIterator::getIteratorIndex() - Obtiene un índice de iteradores


Obtiene un índice de iteradores

  • « AppendIterator::getInnerIterator
  • AppendIterator::key »
  • PHP Manual
  • AppendIterator
  • Obtiene un índice de iteradores

AppendIterator::getIteratorIndex

(PHP 5 >= 5.2.0, PHP 7)

AppendIterator::getIteratorIndex — Obtiene un índice de iteradores

Descripción

public AppendIterator::getIteratorIndex ( ) : int

Obtiene el índice del iterador actual actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un integer, que es el índice basado en cero del iterador interno actual.

Ejemplos

Ejemplo #1 Ejemplo básico de AppendIterator.getIteratorIndex()

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $key => $current) {
    echo $iterator->getIteratorIndex() . '  ' . $key . ' ' . $current . PHP_EOL;
}
?>

El resultado del ejemplo sería:

0  a aardwolf
0  b bear
0  c capybara
1  0 apple
1  1 orange
1  2 lemon

Ver también

  • AppendIterator::getInnerIterator() - Obtiene el iterador interno
  • AppendIterator::getArrayIterator() - Obtiene el getArrayIterator


Obtiene la clave actual

  • « AppendIterator::getIteratorIndex
  • AppendIterator::next »
  • PHP Manual
  • AppendIterator
  • Obtiene la clave actual

AppendIterator::key

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::key — Obtiene la clave actual

Descripción

public AppendIterator::key ( ) : scalar

Obtener la clave actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave actual si es válida o null en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo básico de AppendIterator::key()

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

// Manual iteration
$iterator->rewind();
while ($iterator->valid()) {
    echo $iterator->key() . ' ' . $iterator->current() . PHP_EOL;
    $iterator->next();
}

echo PHP_EOL;

// With foreach
foreach ($iterator as $key => $current) {
    echo $key . ' ' . $current . PHP_EOL;
}
?>

El resultado del ejemplo sería:

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

Ver también

  • Iterator::key() - Devuelve la clave del elemento actual
  • AppendIterator::current() - Obtiene el valor actual
  • AppendIterator::valid() - Comprueba la validación del elemento actual
  • AppendIterator::next() - Desplazarse al siguiente elemento
  • AppendIterator::rewind() - Rebobina el iterador


Desplazarse al siguiente elemento

  • « AppendIterator::key
  • AppendIterator::rewind »
  • PHP Manual
  • AppendIterator
  • Desplazarse al siguiente elemento

AppendIterator::next

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::next — Desplazarse al siguiente elemento

Descripción

public AppendIterator::next ( ) : void

Se desplaza al siguiente elemento. Esto significa a otro iterador por lo que rebobina ese iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Iterator::next() - Avanza al siguiente elemento
  • AppendIterator::current() - Obtiene el valor actual
  • AppendIterator::key() - Obtiene la clave actual
  • AppendIterator::valid() - Comprueba la validación del elemento actual
  • AppendIterator::rewind() - Rebobina el iterador


Rebobina el iterador

  • « AppendIterator::next
  • AppendIterator::valid »
  • PHP Manual
  • AppendIterator
  • Rebobina el iterador

AppendIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::rewind — Rebobina el iterador

Descripción

public AppendIterator::rewind ( ) : void

Rebobina al primer elemento del primer iterador interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Iterator::rewind() - Rebobine la Iterator al primer elemento
  • AppendIterator::current() - Obtiene el valor actual
  • AppendIterator::key() - Obtiene la clave actual
  • AppendIterator::next() - Desplazarse al siguiente elemento
  • AppendIterator::valid() - Comprueba la validación del elemento actual


Comprueba la validación del elemento actual

  • « AppendIterator::rewind
  • ArrayIterator »
  • PHP Manual
  • AppendIterator
  • Comprueba la validación del elemento actual

AppendIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::valid — Comprueba la validación del elemento actual

Descripción

public AppendIterator::valid ( ) : bool

Comprueba la validación del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la iteración actual es válida, false en caso contrario.

Ver también

  • AppendIterator::current() - Obtiene el valor actual
  • AppendIterator::key() - Obtiene la clave actual
  • AppendIterator::next() - Desplazarse al siguiente elemento
  • AppendIterator::rewind() - Rebobina el iterador


La clase ArrayIterator

(PHP 5, PHP 7)

Introducción

Este iterador permite eliminar y modificar valores y claves cuando se recorren arrays y objetos.

Cuando se quiere iterar sobre el mismo array varias veces, se necesita instanciar ArrayObject y dejarle que cree instancias ArrayIterator que hacen referencia a la misma usando foreach o llamando a su método getIterator() de forma manual.

Sinopsis de la Clase

ArrayIterator implements ArrayAccess , SeekableIterator , Countable , Serializable {
/* Constantes */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* Métodos */
public append ( mixed $value ) : void
public asort ( ) : void
public __construct ( mixed $array = array() , int $flags = 0 )
public count ( ) : int
public current ( ) : mixed
public getArrayCopy ( ) : array
public getFlags ( ) : void
public key ( ) : mixed
public ksort ( ) : void
public natcasesort ( ) : void
public natsort ( ) : void
public next ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public rewind ( ) : void
public seek ( int $position ) : void
public serialize ( ) : string
public setFlags ( string $flags ) : void
public uasort ( string $cmp_function ) : void
public uksort ( string $cmp_function ) : void
public unserialize ( string $serialized ) : string
public valid ( ) : bool
}

Constantes predefinidas

ArrayIterator Flags

ArrayIterator::STD_PROP_LIST

Las propiedades del objeto tienen su funcionalidad normal cuando se accede a ellas como lista (var_dump, foreach, etc.).

ArrayIterator::ARRAY_AS_PROPS

Se puede acceder a las entradas como propiedades (lectura y escritura).

Tabla de contenidos

  • ArrayIterator::append — Añade un elemento
  • ArrayIterator::asort — Ordena array por sus valores
  • ArrayIterator::__construct — Construye un ArrayIterator
  • ArrayIterator::count — Cuenta elementos
  • ArrayIterator::current — Devuelve la entrada actual del array
  • ArrayIterator::getArrayCopy — Obtener copia de un array
  • ArrayIterator::getFlags — Obtener opciones
  • ArrayIterator::key — Devuelve la clave actual del array
  • ArrayIterator::ksort — Ordena un array por sus claves
  • ArrayIterator::natcasesort — Ordena un array de forma natural, sensible a mayúsculas
  • ArrayIterator::natsort — Ordena un array de forma natural
  • ArrayIterator::next — Desplaza a la siguiente entrada
  • ArrayIterator::offsetExists — Compruebar si el índice existe
  • ArrayIterator::offsetGet — Obtener el valor de un índice
  • ArrayIterator::offsetSet — Establece el valor para un índice
  • ArrayIterator::offsetUnset — Destruye el valor de un índice
  • ArrayIterator::rewind — Rebobinar array al inicio
  • ArrayIterator::seek — Buscar la posición
  • ArrayIterator::serialize — Serializar
  • ArrayIterator::setFlags — Definir opciones de comportamiento
  • ArrayIterator::uasort — Ordenado definido por el usuario
  • ArrayIterator::uksort — Ordenado definido por el usuario
  • ArrayIterator::unserialize — Deserializar
  • ArrayIterator::valid — Comprueba si un array contiene más entradas


Añade un elemento

  • « ArrayIterator
  • ArrayIterator::asort »
  • PHP Manual
  • ArrayIterator
  • Añade un elemento

ArrayIterator::append

(PHP 5, PHP 7)

ArrayIterator::append — Añade un elemento

Descripción

public ArrayIterator::append ( mixed $value ) : void

Añade el valor cómo el último elemento.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

value

El valor a añadir.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

Este método no puede ser llamado cuando ArrayIterator hace referencia a un objeto.

Ver también

  • ArrayIterator::next() - Desplaza a la siguiente entrada


Ordena array por sus valores

  • « ArrayIterator::append
  • ArrayIterator::__construct »
  • PHP Manual
  • ArrayIterator
  • Ordena array por sus valores

ArrayIterator::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::asort — Ordena array por sus valores

Descripción

public ArrayIterator::asort ( ) : void

Ordena un array por sus valores.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::ksort() - Ordena un array por sus claves
  • ArrayIterator::natcasesort() - Ordena un array de forma natural, sensible a mayúsculas
  • ArrayIterator::natsort() - Ordena un array de forma natural


Construye un ArrayIterator

  • « ArrayIterator::asort
  • ArrayIterator::count »
  • PHP Manual
  • ArrayIterator
  • Construye un ArrayIterator

ArrayIterator::__construct

(PHP 5, PHP 7)

ArrayIterator::__construct — Construye un ArrayIterator

Descripción

public ArrayIterator::__construct ( mixed $array = array() , int $flags = 0 )

Construye un objeto ArrayIterator.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

array

El array o objecto a ser iterado.

flags

Banderas para controlar el comportamiento del objeto ArrayIterator. Véase ArrayIterator::setFlags().

Valores devueltos

Un objeto ArrayIterator.

Errores/Excepciones

ArrayIterator::__construct() lanza una InvalidArgumentException si es dado cualquier otra cosa a parte de un array o un objeto.

Ver también

  • ArrayIterator::getArrayCopy() - Obtener copia de un array


Cuenta elementos

  • « ArrayIterator::__construct
  • ArrayIterator::current »
  • PHP Manual
  • ArrayIterator
  • Cuenta elementos

ArrayIterator::count

(PHP 5, PHP 7)

ArrayIterator::count — Cuenta elementos

Descripción

public ArrayIterator::count ( ) : int

Obtiene el número de elementos de un array, o el número de propiedades públicas en un objeto.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número.

Ver también

  • ArrayIterator::getFlags() - Obtener opciones


Devuelve la entrada actual del array

  • « ArrayIterator::count
  • ArrayIterator::getArrayCopy »
  • PHP Manual
  • ArrayIterator
  • Devuelve la entrada actual del array

ArrayIterator::current

(PHP 5, PHP 7)

ArrayIterator::current — Devuelve la entrada actual del array

Descripción

public ArrayIterator::current ( ) : mixed

Obtiene la entrada actual del array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La entrada actual del array.

Ejemplos

Ejemplo #1 Ejemplo de ArrayIterator::current()

<?php
$array = array('1' => 'uno',
               '2' => 'dos',
               '3' => 'tres');

$arrayobject = new ArrayObject($array);

for($iterator = $arrayobject->getIterator();
    $iterator->valid();
    $iterator->next()) {

    echo $iterator->key() . ' => ' . $iterator->current() . "\n";
}
?>

El resultado del ejemplo sería:

1 => uno
2 => dos
3 => tres


Obtener copia de un array

  • « ArrayIterator::current
  • ArrayIterator::getFlags »
  • PHP Manual
  • ArrayIterator
  • Obtener copia de un array

ArrayIterator::getArrayCopy

(PHP 5, PHP 7)

ArrayIterator::getArrayCopy — Obtener copia de un array

Descripción

public ArrayIterator::getArrayCopy ( ) : array

Obtiene una copia de un array.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una copia de un array, o un array de las propiedades públicas si ArrayIterator hace referencia a un objeto.

Ver también

  • ArrayIterator::valid() - Comprueba si un array contiene más entradas


Obtener opciones

  • « ArrayIterator::getArrayCopy
  • ArrayIterator::key »
  • PHP Manual
  • ArrayIterator
  • Obtener opciones

ArrayIterator::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::getFlags — Obtener opciones

Descripción

public ArrayIterator::getFlags ( ) : void

Obtiene las opciones actuales.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current flags.

Ver también

  • ArrayIterator::valid() - Comprueba si un array contiene más entradas


Devuelve la clave actual del array

  • « ArrayIterator::getFlags
  • ArrayIterator::ksort »
  • PHP Manual
  • ArrayIterator
  • Devuelve la clave actual del array

ArrayIterator::key

(PHP 5, PHP 7)

ArrayIterator::key — Devuelve la clave actual del array

Descripción

public ArrayIterator::key ( ) : mixed

Esta función devuelve la clave actual del array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave actual del array.

Ejemplos

Ejemplo #1 Ejemplo de ArrayIterator::key()

<?php
$array = array('key' => 'value');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

echo $iterator->key(); //key
?>


Ordena un array por sus claves

  • « ArrayIterator::key
  • ArrayIterator::natcasesort »
  • PHP Manual
  • ArrayIterator
  • Ordena un array por sus claves

ArrayIterator::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::ksort — Ordena un array por sus claves

Descripción

public ArrayIterator::ksort ( ) : void

Ordena un array por sus claves.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::asort() - Ordena array por sus valores
  • ArrayIterator::natcasesort() - Ordena un array de forma natural, sensible a mayúsculas
  • ArrayIterator::natsort() - Ordena un array de forma natural


Ordena un array de forma natural, sensible a mayúsculas

  • « ArrayIterator::ksort
  • ArrayIterator::natsort »
  • PHP Manual
  • ArrayIterator
  • Ordena un array de forma natural, sensible a mayúsculas

ArrayIterator::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natcasesort — Ordena un array de forma natural, sensible a mayúsculas

Descripción

public ArrayIterator::natcasesort ( ) : void

Ordena las entradas por valores usando un algoritmo de "ordenado natural" sensible a mayúsculas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::asort() - Ordena array por sus valores
  • ArrayIterator::ksort() - Ordena un array por sus claves
  • ArrayIterator::natsort() - Ordena un array de forma natural
  • natcasesort() - Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas


Ordena un array de forma natural

  • « ArrayIterator::natcasesort
  • ArrayIterator::next »
  • PHP Manual
  • ArrayIterator
  • Ordena un array de forma natural

ArrayIterator::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natsort — Ordena un array de forma natural

Descripción

public ArrayIterator::natsort ( ) : void

Ordena las entradas por valores usando un algoritmo de "ordenado natural".

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::asort() - Ordena array por sus valores
  • ArrayIterator::ksort() - Ordena un array por sus claves
  • ArrayIterator::natcasesort() - Ordena un array de forma natural, sensible a mayúsculas
  • natsort() - Ordena un array usando un algoritmo de "orden natural"


Desplaza a la siguiente entrada

  • « ArrayIterator::natsort
  • ArrayIterator::offsetExists »
  • PHP Manual
  • ArrayIterator
  • Desplaza a la siguiente entrada

ArrayIterator::next

(PHP 5, PHP 7)

ArrayIterator::next — Desplaza a la siguiente entrada

Descripción

public ArrayIterator::next ( ) : void

El iterador a la siguiente entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayIterator::next()

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'cero';
$arrayobject[] = 'uno';

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

El resultado del ejemplo sería:

0 => cero
1 => uno


Compruebar si el índice existe

  • « ArrayIterator::next
  • ArrayIterator::offsetGet »
  • PHP Manual
  • ArrayIterator
  • Compruebar si el índice existe

ArrayIterator::offsetExists

(PHP 5, PHP 7)

ArrayIterator::offsetExists — Compruebar si el índice existe

Descripción

public ArrayIterator::offsetExists ( mixed $index ) : bool

Comprueba si el índice existe.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice a ser comprobado.

Valores devueltos

true si el índice existe, en caso contrario false

Ver también

  • ArrayIterator::valid() - Comprueba si un array contiene más entradas


Obtener el valor de un índice

  • « ArrayIterator::offsetExists
  • ArrayIterator::offsetSet »
  • PHP Manual
  • ArrayIterator
  • Obtener el valor de un índice

ArrayIterator::offsetGet

(PHP 5, PHP 7)

ArrayIterator::offsetGet — Obtener el valor de un índice

Descripción

public ArrayIterator::offsetGet ( mixed $index ) : mixed

Obtiene el valor del índice proporcionado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice para obtener el valor.

Valores devueltos

El valor del índice index.

Ver también

  • ArrayIterator::offsetSet() - Establece el valor para un índice
  • ArrayIterator::offsetUnset() - Destruye el valor de un índice


Establece el valor para un índice

  • « ArrayIterator::offsetGet
  • ArrayIterator::offsetUnset »
  • PHP Manual
  • ArrayIterator
  • Establece el valor para un índice

ArrayIterator::offsetSet

(PHP 5, PHP 7)

ArrayIterator::offsetSet — Establece el valor para un índice

Descripción

public ArrayIterator::offsetSet ( mixed $index , mixed $newval ) : void

Establecer el valor para el índice dado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice a ser establecido.

newval

El nuevo valor para almacenar en el índice.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::offsetGet() - Obtener el valor de un índice
  • ArrayIterator::offsetUnset() - Destruye el valor de un índice


Destruye el valor de un índice

  • « ArrayIterator::offsetSet
  • ArrayIterator::rewind »
  • PHP Manual
  • ArrayIterator
  • Destruye el valor de un índice

ArrayIterator::offsetUnset

(PHP 5, PHP 7)

ArrayIterator::offsetUnset — Destruye el valor de un índice

Descripción

public ArrayIterator::offsetUnset ( mixed $index ) : void

Destruir el valor de un índice dado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice a ser destruido.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::offsetGet() - Obtener el valor de un índice
  • ArrayIterator::offsetSet() - Establece el valor para un índice


Rebobinar array al inicio

  • « ArrayIterator::offsetUnset
  • ArrayIterator::seek »
  • PHP Manual
  • ArrayIterator
  • Rebobinar array al inicio

ArrayIterator::rewind

(PHP 5, PHP 7)

ArrayIterator::rewind — Rebobinar array al inicio

Descripción

public ArrayIterator::rewind ( ) : void

Rebobina el iterador al inicio del array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayIterator::rewind()

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';
$arrayobject[] = 'two';

$iterator = $arrayobject->getIterator();

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rebobinar al inicio
echo $iterator->key(); //0
?>


Buscar la posición

  • « ArrayIterator::rewind
  • ArrayIterator::serialize »
  • PHP Manual
  • ArrayIterator
  • Buscar la posición

ArrayIterator::seek

(PHP 5, PHP 7)

ArrayIterator::seek — Buscar la posición

Descripción

public ArrayIterator::seek ( int $position ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

position

La posición a buscar.

Valores devueltos

No devuelve ningún valor.


Serializar

  • « ArrayIterator::seek
  • ArrayIterator::setFlags »
  • PHP Manual
  • ArrayIterator
  • Serializar

ArrayIterator::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::serialize — Serializar

Descripción

public ArrayIterator::serialize ( ) : string

Serializa.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El ArrayIterator serializado.

Ver también

  • ArrayIterator::unserialize() - Deserializar


Definir opciones de comportamiento

  • « ArrayIterator::serialize
  • ArrayIterator::uasort »
  • PHP Manual
  • ArrayIterator
  • Definir opciones de comportamiento

ArrayIterator::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::setFlags — Definir opciones de comportamiento

Descripción

public ArrayIterator::setFlags ( string $flags ) : void

Define opciones de comportamiento.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

flags

Un bitmask como se indica:

  • 0 = Propiedades del objeto tienen su normal comportamiento cuando son obtenidas como lista (var_dump, foreach, etc.).
  • 1 = Índicies de array pueden ser accedidos como propiedades de lectura/escritura.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::getFlags() - Obtener opciones


Ordenado definido por el usuario

  • « ArrayIterator::setFlags
  • ArrayIterator::uksort »
  • PHP Manual
  • ArrayIterator
  • Ordenado definido por el usuario

ArrayIterator::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uasort — Ordenado definido por el usuario

Descripción

public ArrayIterator::uasort ( string $cmp_function ) : void

Ordena las entradas por los valores usando una función definida por el usuario.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

cmp_function

La función de comparación usada para el ordenado.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::uksort() - Ordenado definido por el usuario
  • usort() - Ordena un array según sus valores usando una función de comparación definida por el usuario


Ordenado definido por el usuario

  • « ArrayIterator::uasort
  • ArrayIterator::unserialize »
  • PHP Manual
  • ArrayIterator
  • Ordenado definido por el usuario

ArrayIterator::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uksort — Ordenado definido por el usuario

Descripción

public ArrayIterator::uksort ( string $cmp_function ) : void

Ordena las entradas por clave usando una función definida por el usuario.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

cmp_function

La función de comparación usada para el ordenado.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ArrayIterator::uasort() - Ordenado definido por el usuario
  • uksort() - Ordena un array según sus claves usando una función de comparación definida por el usuario


Deserializar

  • « ArrayIterator::uksort
  • ArrayIterator::valid »
  • PHP Manual
  • ArrayIterator
  • Deserializar

ArrayIterator::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::unserialize — Deserializar

Descripción

public ArrayIterator::unserialize ( string $serialized ) : string

Deserializa.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

serialized

El objecto serializado ArrayIterator para deserializar.

Valores devueltos

The ArrayIterator.

Ver también

  • ArrayIterator::serialize() - Serializar


Comprueba si un array contiene más entradas

  • « ArrayIterator::unserialize
  • CachingIterator »
  • PHP Manual
  • ArrayIterator
  • Comprueba si un array contiene más entradas

ArrayIterator::valid

(PHP 5, PHP 7)

ArrayIterator::valid — Comprueba si un array contiene más entradas

Descripción

public ArrayIterator::valid ( ) : bool

Comprueba si un array contiene más entradas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el iterador es válido, false si no.

Ejemplos

Ejemplo #1 Ejemplo de ArrayIterator::valid()

<?php
$array = array('1' => 'uno');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

var_dump($iterator->valid()); //bool(true)

$iterator->next(); // avanza al siguiente ítem

//bool(false) porque solo hay un elemento array
var_dump($iterator->valid());
?>


La clase CachingIterator

(PHP 5, PHP 7)

Introducción

Este objeto admite iteraciones almacenadas en caché sobre otros iteradores.

Sinopsis de la Clase

CachingIterator extends IteratorIterator implements OuterIterator , ArrayAccess , Countable {
/* Constantes */
const integer CALL_TOSTRING = 1 ;
const integer CATCH_GET_CHILD = 16 ;
const integer TOSTRING_USE_KEY = 2 ;
const integer TOSTRING_USE_CURRENT = 4 ;
const integer TOSTRING_USE_INNER = 8 ;
const integer FULL_CACHE = 256 ;
/* Métodos */
public __construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public count ( ) : int
public current ( ) : void
public getCache ( ) : array
public getFlags ( ) : int
public getInnerIterator ( ) : Iterator
public hasNext ( ) : void
public key ( ) : scalar
public next ( ) : void
public offsetExists ( mixed $index ) : void
public offsetGet ( string $index ) : void
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( string $index ) : void
public rewind ( ) : void
public setFlags ( int $flags ) : void
public __toString ( ) : void
public valid ( ) : void
}

Constantes predefinidas

CachingIterator::CALL_TOSTRING

Convierte cada elemento a un string.

CachingIterator::CATCH_GET_CHILD

No lanzar una excepción en el acceso a los hijos.

CachingIterator::TOSTRING_USE_KEY

Usa key para la conversión a string.

CachingIterator::TOSTRING_USE_CURRENT

Usa current para la conversión a string.

CachingIterator::TOSTRING_USE_INNER

Usa inner para la conversión a string.

CachingIterator::FULL_CACHE

Almacena en caché todos los datos leídos.

Tabla de contenidos

  • CachingIterator::__construct — Construir un nuevo objeto CachingIterator para el iterador
  • CachingIterator::count — El número de elementos en el iterador
  • CachingIterator::current — Devuelve el elemento actual
  • CachingIterator::getCache — Recuperar el contenido de la caché
  • CachingIterator::getFlags — Obtener las banderas utilizadas
  • CachingIterator::getInnerIterator — Devuelve el iterador interno
  • CachingIterator::hasNext — Comprueba que el iterador interno tenga un elemento siguiente válido
  • CachingIterator::key — Devuelve la clave del elemento actual
  • CachingIterator::next — Desplaza el iterador adelante
  • CachingIterator::offsetExists — Comprobar existencia de un índice
  • CachingIterator::offsetGet — El propósito offsetGet
  • CachingIterator::offsetSet — El propósito offsetSet
  • CachingIterator::offsetUnset — El propósito offsetUnset
  • CachingIterator::rewind — Rebobina el iterador
  • CachingIterator::setFlags — El propósito de setFlags
  • CachingIterator::__toString — Devolver la representación en formato cadena del elemento actual
  • CachingIterator::valid — Comprueba que el elemento actual sea válido


Construir un nuevo objeto CachingIterator para el iterador

  • « CachingIterator
  • CachingIterator::count »
  • PHP Manual
  • CachingIterator
  • Construir un nuevo objeto CachingIterator para el iterador

CachingIterator::__construct

(PHP 5, PHP 7)

CachingIterator::__construct — Construir un nuevo objeto CachingIterator para el iterador

Descripción

public CachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

Iterador a usar en caché

flags

Máscara de bits de las opciones.


El número de elementos en el iterador

  • « CachingIterator::__construct
  • CachingIterator::current »
  • PHP Manual
  • CachingIterator
  • El número de elementos en el iterador

CachingIterator::count

(PHP 5 >= 5.2.2, PHP 7)

CachingIterator::count — El número de elementos en el iterador

Descripción

public CachingIterator::count ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el número de elementos en el iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La cuenta del número de elementos que han sido iterados.


Devuelve el elemento actual

  • « CachingIterator::count
  • CachingIterator::getCache »
  • PHP Manual
  • CachingIterator
  • Devuelve el elemento actual

CachingIterator::current

(PHP 5, PHP 7)

CachingIterator::current — Devuelve el elemento actual

Descripción

public CachingIterator::current ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el elemento actual en el iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Mixed

Ver también

  • Iterator::current() - Devuelve el elemento actual


Recuperar el contenido de la caché

  • « CachingIterator::current
  • CachingIterator::getFlags »
  • PHP Manual
  • CachingIterator
  • Recuperar el contenido de la caché

CachingIterator::getCache

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getCache — Recuperar el contenido de la caché

Descripción

public CachingIterator::getCache ( ) : array

Recupera el contenido de la caché.

Nota:

Se debe utilizar el indicador CachingIterator::FULL_CACHE.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array que contiene los elementos de la caché.

Errores/Excepciones

Lanza una BadMethodCallException cuando no se está utilizando el indicador CachingIterator::FULL_CACHE.

Ejemplos

Ejemplo #1 Ejemplo de CachingIterator::getCache().

<?php
$iterador = new ArrayIterator(array(1, 2, 3));
$caché    = new CachingIterator($iterador, CachingIterator::FULL_CACHE);

$caché->next();
$caché->next();
var_dump($caché->getCache());

$caché->next();
var_dump($caché->getCache());
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}
array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Obtener las banderas utilizadas

  • « CachingIterator::getCache
  • CachingIterator::getInnerIterator »
  • PHP Manual
  • CachingIterator
  • Obtener las banderas utilizadas

CachingIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getFlags — Obtener las banderas utilizadas

Descripción

public CachingIterator::getFlags ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene la máscara de bits usada para esta instancia de ChachingIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Descripción...


Devuelve el iterador interno

  • « CachingIterator::getFlags
  • CachingIterator::hasNext »
  • PHP Manual
  • CachingIterator
  • Devuelve el iterador interno

CachingIterator::getInnerIterator

(PHP 5, PHP 7)

CachingIterator::getInnerIterator — Devuelve el iterador interno

Descripción

public CachingIterator::getInnerIterator ( ) : Iterator
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el iterador enviado al constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objecto implementado el iterfaz iterador.


Comprueba que el iterador interno tenga un elemento siguiente válido

  • « CachingIterator::getInnerIterator
  • CachingIterator::key »
  • PHP Manual
  • CachingIterator
  • Comprueba que el iterador interno tenga un elemento siguiente válido

CachingIterator::hasNext

(PHP 5, PHP 7)

CachingIterator::hasNext — Comprueba que el iterador interno tenga un elemento siguiente válido

Descripción

public CachingIterator::hasNext ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve la clave del elemento actual

  • « CachingIterator::hasNext
  • CachingIterator::next »
  • PHP Manual
  • CachingIterator
  • Devuelve la clave del elemento actual

CachingIterator::key

(PHP 5, PHP 7)

CachingIterator::key — Devuelve la clave del elemento actual

Descripción

public CachingIterator::key ( ) : scalar
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Este método devuelve la clave del elemento actual.

Parámetros

Esta función no tiene parámetros.


Desplaza el iterador adelante

  • « CachingIterator::key
  • CachingIterator::offsetExists »
  • PHP Manual
  • CachingIterator
  • Desplaza el iterador adelante

CachingIterator::next

(PHP 5, PHP 7)

CachingIterator::next — Desplaza el iterador adelante

Descripción

public CachingIterator::next ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Desplaza el iterador adelante.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Comprobar existencia de un índice

  • « CachingIterator::next
  • CachingIterator::offsetGet »
  • PHP Manual
  • CachingIterator
  • Comprobar existencia de un índice

CachingIterator::offsetExists

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetExists — Comprobar existencia de un índice

Descripción

public CachingIterator::offsetExists ( mixed $index ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice a ser comprobado.

Valores devueltos

Devuelve true si la entrada a la que hace referencia el índice existe, en caso contrario false.


El propósito offsetGet

  • « CachingIterator::offsetExists
  • CachingIterator::offsetSet »
  • PHP Manual
  • CachingIterator
  • El propósito offsetGet

CachingIterator::offsetGet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetGet — El propósito offsetGet

Descripción

public CachingIterator::offsetGet ( string $index ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

Descripción...

Valores devueltos

Descripción...


El propósito offsetSet

  • « CachingIterator::offsetGet
  • CachingIterator::offsetUnset »
  • PHP Manual
  • CachingIterator
  • El propósito offsetSet

CachingIterator::offsetSet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetSet — El propósito offsetSet

Descripción

public CachingIterator::offsetSet ( mixed $index , mixed $newval ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice del elemento a ser establecido.

newval

El nuevo valor para el index.

Valores devueltos

No devuelve ningún valor.


El propósito offsetUnset

  • « CachingIterator::offsetSet
  • CachingIterator::rewind »
  • PHP Manual
  • CachingIterator
  • El propósito offsetUnset

CachingIterator::offsetUnset

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetUnset — El propósito offsetUnset

Descripción

public CachingIterator::offsetUnset ( string $index ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

El índice de el elemento a ser destruido.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador

  • « CachingIterator::offsetUnset
  • CachingIterator::setFlags »
  • PHP Manual
  • CachingIterator
  • Rebobina el iterador

CachingIterator::rewind

(PHP 5, PHP 7)

CachingIterator::rewind — Rebobina el iterador

Descripción

public CachingIterator::rewind ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Rebobinar el iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


El propósito de setFlags

  • « CachingIterator::rewind
  • CachingIterator::__toString »
  • PHP Manual
  • CachingIterator
  • El propósito de setFlags

CachingIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::setFlags — El propósito de setFlags

Descripción

public CachingIterator::setFlags ( int $flags ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Establece las flags para el objeto CachingIterator.

Parámetros

flags

Máscara de flags a establecer.

Valores devueltos

No devuelve ningún valor.


Devolver la representación en formato cadena del elemento actual

  • « CachingIterator::setFlags
  • CachingIterator::valid »
  • PHP Manual
  • CachingIterator
  • Devolver la representación en formato cadena del elemento actual

CachingIterator::__toString

(PHP 5, PHP 7)

CachingIterator::__toString — Devolver la representación en formato cadena del elemento actual

Descripción

public CachingIterator::__toString ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene la representación en formato cadena del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La representación en formato cadena del elemento actual.


Comprueba que el elemento actual sea válido

  • « CachingIterator::__toString
  • CallbackFilterIterator »
  • PHP Manual
  • CachingIterator
  • Comprueba que el elemento actual sea válido

CachingIterator::valid

(PHP 5, PHP 7)

CachingIterator::valid — Comprueba que el elemento actual sea válido

Descripción

public CachingIterator::valid ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Comprueba que el elemento actual sea válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


La clase CallbackFilterIterator

(PHP 5 >= 5.4.0, PHP 7)

Introducción

Sinopsis de la Clase

CallbackFilterIterator extends FilterIterator implements OuterIterator {
/* Métodos */
public __construct ( Iterator $iterator , callable $callback )
public accept ( ) : bool
/* Métodos heredados */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

Ejemplos

La llamada de retorno debería aceptar hasta tres argumentos: el elemento actual, la clave actual y el iterador, respectivamente.

Ejemplo #1 Argumentos disponibles de la llamada de retorno

<?php

/**
 * Llamada de retorno para CallbackFilterIterator
 *
 * @param $current   Valor del elemento actual
 * @param $key       Clave del elemento actual
 * @param $iterator  Iterador a filtrar
 * @return boolean   TRUE para aceptar el elemento actual, de lo contrario FALSE
 */
function my_callback($current, $key, $iterator) {
    // Aquí el código de filtrado
}

?>

Se posría usar algún callable,como un string que contenga nombre de función, un array para un método, o una función anónima.

Ejemplo #2 Ejemplos básicos de llamada de retorno

<?php

$dir = new FilesystemIterator(__DIR__);

// Filtrar ficheros de gran tamaño ( > 100MB)
function is_large_file($current) {
    return $current->isFile() && $current->getSize() > 104857600;
}
$large_files = new CallbackFilterIterator($dir, 'is_large_file');

// Filtrar directorios
$files = new CallbackFilterIterator($dir, function ($current, $key, $iterator) {
    return $current->isDir() && ! $iterator->isDot();
});

?>

Tabla de contenidos

  • CallbackFilterIterator::accept — Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos
  • CallbackFilterIterator::__construct — Crear un iterador filtrado desde otro iterador


Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos

  • « CallbackFilterIterator
  • CallbackFilterIterator::__construct »
  • PHP Manual
  • CallbackFilterIterator
  • Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos

CallbackFilterIterator::accept

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::accept — Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos

Descripción

public CallbackFilterIterator::accept ( ) : bool

Este método llama a la llamada de retorno con el valor actual, la clave actual y el iterador interno.

La llamada de retorno se espera que devuelva true si el elemento actual es aceptado, o en caso contrario false.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true para aceptar el elemento actual, o en caso contrario false.

Ver también

  • Ejemplos de CallbackFilterIterator
  • CallbackFilterIterator::__construct() - Crear un iterador filtrado desde otro iterador


Crear un iterador filtrado desde otro iterador

  • « CallbackFilterIterator::accept
  • DirectoryIterator »
  • PHP Manual
  • CallbackFilterIterator
  • Crear un iterador filtrado desde otro iterador

CallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::__construct — Crear un iterador filtrado desde otro iterador

Descripción

public CallbackFilterIterator::__construct ( Iterator $iterator , callable $callback )

Crea un iterador filtrado usando callback (llamada de retorno) Creates a filtered iterator using the callback para determinar que elementos van a ser aceptados o rechazados.

Parámetros

iterator

El iterador a ser filtrado.

callback

La llamada de retorno, debe devolver true para aceptar el elemento actual o en caso contrario false. Véase los Ejemplos.

Puede ser cualquier valor válido de callback.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ejemplos de CallbackFilterIterator
  • CallbackFilterIterator::accept() - Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos


La clase DirectoryIterator

(PHP 5, PHP 7)

Introducción

La clase DirectoryIterator proporciona un sencilla interfaz para ver el contenido de los directorios del sistema de ficheros.

Sinopsis de la Clase

DirectoryIterator extends SplFileInfo implements SeekableIterator {
/* Métodos */
public __construct ( string $path )
public current ( ) : DirectoryIterator
public getATime ( ) : int
public getBasename ( string $suffix = ? ) : string
public getCTime ( ) : int
public getExtension ( ) : string
public getFilename ( ) : string
public getGroup ( ) : int
public getInode ( ) : int
public getMTime ( ) : int
public getOwner ( ) : int
public getPath ( ) : string
public getPathname ( ) : string
public getPerms ( ) : int
public getSize ( ) : int
public getType ( ) : string
public isDir ( ) : bool
public isDot ( ) : bool
public isExecutable ( ) : bool
public isFile ( ) : bool
public isLink ( ) : bool
public isReadable ( ) : bool
public isWritable ( ) : bool
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
public seek ( int $position ) : void
public __toString ( ) : string
public valid ( ) : bool
}

Historial de cambios

Versión | Descripción
5.1.2 | DirectoryIterator amplía SplFileInfo.

Tabla de contenidos

  • DirectoryIterator::__construct — Construye un iterador nuevo directorio de una ruta
  • DirectoryIterator::current — Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::getATime — Obtener el último acceso del elemento actual DirectoryIterator
  • DirectoryIterator::getBasename — Obtener el nombre base del elemento actual DirectoryIterator
  • DirectoryIterator::getCTime — Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator
  • DirectoryIterator::getExtension — Obtiene la extensión de un fichero
  • DirectoryIterator::getFilename — Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getGroup — Obtiene el grupo para el elemento actual DirectoryIterator
  • DirectoryIterator::getInode — Obtiene el inodo para el elemento actual DirectoryIterator
  • DirectoryIterator::getMTime — Obtiene la última modificación para el elemento actual DirectoryIterator
  • DirectoryIterator::getOwner — Obtiene el dueño del elemento actual DirectoryIterator
  • DirectoryIterator::getPath — Obtiene la ruta del elemento iterador actual sin nombre de fichero
  • DirectoryIterator::getPathname — Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getPerms — Obtiene los permisos del elemento actual DirectoryIterator
  • DirectoryIterator::getSize — obtiene el tamaño de el elemento actual DirectoryIterator
  • DirectoryIterator::getType — Determina el tipo del elemento actual DirectoryIterator
  • DirectoryIterator::isDir — Determina si el elemento actual DirectoryIterator es un directorio
  • DirectoryIterator::isDot — Determina si el elemento actual DirectoryIterator es '.' o '..'
  • DirectoryIterator::isExecutable — Determina si el emento actual DirectoryIterator es ejecutable
  • DirectoryIterator::isFile — Determina si el elemento actual DirectoryIterator es un fichero
  • DirectoryIterator::isLink — Determina si el elemento actual DirectoryIterator es un enlace simbólico
  • DirectoryIterator::isReadable — Determina si el elemento actual DirectoryIterator puede ser leído
  • DirectoryIterator::isWritable — Determina si el elemento actual DirectoryIterator se puede escribir
  • DirectoryIterator::key — Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::next — Avanza al siguiente elemento DirectoryIterator
  • DirectoryIterator::rewind — Robobina DirectoryIterator hasta volver al inicio
  • DirectoryIterator::seek — Mueve el apuntador interno del elemento DirectoryIterator
  • DirectoryIterator::__toString — Obtiene el nombre del fichero como un string
  • DirectoryIterator::valid — Comprueba si la actual posición de DirectoryIterator es un fichero válido


Construye un iterador nuevo directorio de una ruta

  • « DirectoryIterator
  • DirectoryIterator::current »
  • PHP Manual
  • DirectoryIterator
  • Construye un iterador nuevo directorio de una ruta

DirectoryIterator::__construct

(PHP 5, PHP 7)

DirectoryIterator::__construct — Construye un iterador nuevo directorio de una ruta

Descripción

public DirectoryIterator::__construct ( string $path )

Construye un iterador nuevo directorio de una ruta.

Parámetros

path

La ruta del directorio a recorrer.

Errores/Excepciones

Lanza una UnexpectedValueException si path no se puede abrir.

Lanza una RuntimeException si path es una cadena vacía.

Historial de cambios

Versión | Descripción
5.3.0 | Lanza una UnexpectedValueException si path no se puede abrir.
5.1.3 | Lanza una RuntimeException si path es una cadena vacía.
5.1.0 | Lanza una RuntimeException en caso de error. Anteriormente lanzaba una Exception.

Ejemplos

Ejemplo #1 Un DirectoryIterator::__construct() ejemplo

Este ejemplo le mostrará los contenidos del directorio que contiene el script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        var_dump($fileinfo->getFilename());
    }
}
?>

Ver también

  • SplFileInfo
  • Iterator


Devuelve el elemento actual del DirectoryIterator

  • « DirectoryIterator::__construct
  • DirectoryIterator::getATime »
  • PHP Manual
  • DirectoryIterator
  • Devuelve el elemento actual del DirectoryIterator

DirectoryIterator::current

(PHP 5, PHP 7)

DirectoryIterator::current — Devuelve el elemento actual del DirectoryIterator

Descripción

public DirectoryIterator::current ( ) : DirectoryIterator

Obtiene el elemento actual del DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El elemento actual del DirectoryIterator.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::current()

Este ejemplo mostrará el contenido del directorio que contiene al script.

<?php
$iterador = new DirectoryIterator(__DIR__);
while($iterador->valid()) {
    $fichero = $iterador->current();
    echo $iterador->key() . " => " . $fichero->getFilename() . "\n";
    $iterador->next();
}
?>

El resultado del ejemplo sería algo similar a:

0 => .
1 => ..
2 => manzana.jpg
3 => banana.jpg
4 => index.php
5 => pera.jpg

Ver también

  • DirectoryIterator::key() - Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator
  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio
  • DirectoryIterator::valid() - Comprueba si la actual posición de DirectoryIterator es un fichero válido
  • Iterator::current() - Devuelve el elemento actual


Obtener el último acceso del elemento actual DirectoryIterator

  • « DirectoryIterator::current
  • DirectoryIterator::getBasename »
  • PHP Manual
  • DirectoryIterator
  • Obtener el último acceso del elemento actual DirectoryIterator

DirectoryIterator::getATime

(PHP 5, PHP 7)

DirectoryIterator::getATime — Obtener el último acceso del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getATime ( ) : int

Obtiene el último acceso del elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la hora del último acceso al fichero, en formato Unix timestamp.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getATime()

Muestra una lista de los ficheros en el directorio del script y los últimos tiempos de acceso.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getATime() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pera.jpg 12240047979

Ver también

  • DirectoryIterator::getCTime() - Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator
  • DirectoryIterator::getMTime() - Obtiene la última modificación para el elemento actual DirectoryIterator
  • fileatime() - Obtiene el momento del último acceso a un archivo


Obtener el nombre base del elemento actual DirectoryIterator

  • « DirectoryIterator::getATime
  • DirectoryIterator::getCTime »
  • PHP Manual
  • DirectoryIterator
  • Obtener el nombre base del elemento actual DirectoryIterator

DirectoryIterator::getBasename

(PHP 5 >= 5.2.2, PHP 7)

DirectoryIterator::getBasename — Obtener el nombre base del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getBasename ( string $suffix = ? ) : string

Obtiene el nombre base del elemento actual DirectoryIterator.

Parámetros

suffix

Si el nombre base termina en suffix, este será cortado.

Valores devueltos

El nombre base del elemento actual DirectoryIterator.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getBasename()

Este ejemplo mostrará una lista completa de los nombres base y los nombres base con sufijo .jpg eliminado de los ficheros del directorio que contiene el script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getBasename() . "\n";
        echo $fileinfo->getBasename('.jpg') . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
manzana
banana.jpg
banana
index.php
index.php
pera.jpg
pera

Ver también

  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getPath() - Obtiene la ruta del elemento iterador actual sin nombre de fichero
  • DirectoryIterator::getPathname() - Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator
  • basename() - Devuelve el último componente de nombre de una ruta
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator

  • « DirectoryIterator::getBasename
  • DirectoryIterator::getExtension »
  • PHP Manual
  • DirectoryIterator
  • Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator

DirectoryIterator::getCTime

(PHP 5, PHP 7)

DirectoryIterator::getCTime — Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getCTime ( ) : int

Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el último cambio de tiempo de el fichero, en formato Unix timestamp.

Ejemplos

Ejemplo #1 DirectoryIterator::getCTime() example

Este ejemplo mostrará el nombre del fichero y el último cambio de tiempo de los ficheros de el directorio que contiene el script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " cambiado en " . $fileinfo->getCTime() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg cambiado en 1240398312
banana.jpg cambiado en 1238605440
index.php cambiado en 1240398935
pera.jpg cambiado en 1237423740

Ver también

  • DirectoryIterator::getATime() - Obtener el último acceso del elemento actual DirectoryIterator
  • DirectoryIterator::getMTime() - Obtiene la última modificación para el elemento actual DirectoryIterator
  • filectime() - Obtiene el momento del último cambio del i-nodo de un archivo


Obtiene la extensión de un fichero

  • « DirectoryIterator::getCTime
  • DirectoryIterator::getFilename »
  • PHP Manual
  • DirectoryIterator
  • Obtiene la extensión de un fichero

DirectoryIterator::getExtension

(PHP 5 >= 5.3.6, PHP 7)

DirectoryIterator::getExtension — Obtiene la extensión de un fichero

Descripción

public DirectoryIterator::getExtension ( ) : string

Recupera la extensión de un fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string que contiene la extensión del ficher, o un string vacío si el fichoer no tiene extensión.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getExtension()

<?php

$directory = new DirectoryIterator(__DIR__);
foreach ($directory as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getExtension() . "\n";
    }
}

?>

El resultado del ejemplo sería algo similar a:

php
txt
jpg
gz

Notas

Nota:

Este método sólo está disponible a partir de PHP 5.3.6. Otra manera de obtener la extensión es usar la función pathinfo().

<?php
$extension = pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION);
?>

Ver también

  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getBasename() - Obtener el nombre base del elemento actual DirectoryIterator
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Devuelve el nombre del fichero del elemento actual DirectoryIterator

  • « DirectoryIterator::getExtension
  • DirectoryIterator::getGroup »
  • PHP Manual
  • DirectoryIterator
  • Devuelve el nombre del fichero del elemento actual DirectoryIterator

DirectoryIterator::getFilename

(PHP 5, PHP 7)

DirectoryIterator::getFilename — Devuelve el nombre del fichero del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getFilename ( ) : string

Obtiene el nombre del elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero del elemento actual DirectoryIterator.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getFilename()

Este ejemplo mostrará el contenido de el directorio que contiene al script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

.
..
manzana.jpg
banana.jpg
index.php
pera.jpg

Ver también

  • DirectoryIterator::getBasename() - Obtener el nombre base del elemento actual DirectoryIterator
  • DirectoryIterator::getPath() - Obtiene la ruta del elemento iterador actual sin nombre de fichero
  • DirectoryIterator::getPathname() - Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Obtiene el grupo para el elemento actual DirectoryIterator

  • « DirectoryIterator::getFilename
  • DirectoryIterator::getInode »
  • PHP Manual
  • DirectoryIterator
  • Obtiene el grupo para el elemento actual DirectoryIterator

DirectoryIterator::getGroup

(PHP 5, PHP 7)

DirectoryIterator::getGroup — Obtiene el grupo para el elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getGroup ( ) : int

Obtiene el id del grupo de el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el id del grupo de el elemento actual DirectoryIterator en formato numérico.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getGroup()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$groupid  = $iterator->getGroup();
echo 'Directorio pertenece al grupo con id ' . $groupid . "\n";
print_r(posix_getgrgid($groupid));
?>

El resultado del ejemplo sería algo similar a:

Directorio pertenece al grupo con id 42
Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ver también

  • DirectoryIterator::getiNode() - Obtiene el inodo para el elemento actual DirectoryIterator
  • DirectoryIterator::getOwner() - Obtiene el dueño del elemento actual DirectoryIterator
  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator
  • filegroup() - Obtiene el grupo de un archivo
  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo


Obtiene el inodo para el elemento actual DirectoryIterator

  • « DirectoryIterator::getGroup
  • DirectoryIterator::getMTime »
  • PHP Manual
  • DirectoryIterator
  • Obtiene el inodo para el elemento actual DirectoryIterator

DirectoryIterator::getInode

(PHP 5, PHP 7)

DirectoryIterator::getInode — Obtiene el inodo para el elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getInode ( ) : int

Obtiene el número de inodo para el elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de inodo para el fichero.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getInode()

Este ejemplo muestra el número de inodo para el directorio que contiene al script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getInode();
?>

Ver también

  • DirectoryIterator::getGroup() - Obtiene el grupo para el elemento actual DirectoryIterator
  • DirectoryIterator::getOwner() - Obtiene el dueño del elemento actual DirectoryIterator
  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator
  • fileinode() - Obtiene el i-nodo del archivo


Obtiene la última modificación para el elemento actual DirectoryIterator

  • « DirectoryIterator::getInode
  • DirectoryIterator::getOwner »
  • PHP Manual
  • DirectoryIterator
  • Obtiene la última modificación para el elemento actual DirectoryIterator

DirectoryIterator::getMTime

(PHP 5, PHP 7)

DirectoryIterator::getMTime — Obtiene la última modificación para el elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getMTime ( ) : int

Obtiene la última modificación para el elemento actual DirectoryIterator, en formato Unix timestamp.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

la última modificación del fichero, en formato Unix timestamp.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getMTime()

Mostrará una lista de ficheros en el directorio donde se encuentra el script y su última fecha de modificación.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getMTime() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pera.jpg 12240047979

Ver también

  • DirectoryIterator::getATime() - Obtener el último acceso del elemento actual DirectoryIterator
  • DirectoryIterator::getCTime() - Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator
  • filemtime() - Obtiene el momento de la última modificación de un archivo


Obtiene el dueño del elemento actual DirectoryIterator

  • « DirectoryIterator::getMTime
  • DirectoryIterator::getPath »
  • PHP Manual
  • DirectoryIterator
  • Obtiene el dueño del elemento actual DirectoryIterator

DirectoryIterator::getOwner

(PHP 5, PHP 7)

DirectoryIterator::getOwner — Obtiene el dueño del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getOwner ( ) : int

Obtiene el dueño del elemento actual DirectoryIterator, en formato numérico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El dueño de el fichero, en formato numérico.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getOwner()

Este ejemplo mostrará el duseño de el directorio que contiene al script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
print_r(posix_getpwuid($iterator->getOwner()));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [name] => tom
    [passwd] => x
    [uid] => 501
    [gid] => 42
    [gecos] => Tom Cat
    [dir] => /home/tom
    [shell] => /bin/bash
)

Ver también

  • DirectoryIterator::getGroup() - Obtiene el grupo para el elemento actual DirectoryIterator
  • DirectoryIterator::getiNode() - Obtiene el inodo para el elemento actual DirectoryIterator
  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator
  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario


Obtiene la ruta del elemento iterador actual sin nombre de fichero

  • « DirectoryIterator::getOwner
  • DirectoryIterator::getPathname »
  • PHP Manual
  • DirectoryIterator
  • Obtiene la ruta del elemento iterador actual sin nombre de fichero

DirectoryIterator::getPath

(PHP 5, PHP 7)

DirectoryIterator::getPath — Obtiene la ruta del elemento iterador actual sin nombre de fichero

Descripción

public DirectoryIterator::getPath ( ) : string

Obtiene la ruta del elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta de el fichero, omitiendo el nombre del fichero y los slash.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getPath()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getPath();
?>

El resultado del ejemplo sería algo similar a:

/home/examples/public_html

Ver también

  • DirectoryIterator::getBasename() - Obtener el nombre base del elemento actual DirectoryIterator
  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getPathname() - Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator

  • « DirectoryIterator::getPath
  • DirectoryIterator::getPerms »
  • PHP Manual
  • DirectoryIterator
  • Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator

DirectoryIterator::getPathname

(PHP 5, PHP 7)

DirectoryIterator::getPathname — Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getPathname ( ) : string

Obtiene la ruta y nombre de el fichero actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta y el nombre del fichero actual. Directorios no tienen slash.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getPathname()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getPathname() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

/home/examples/.
/home/examples/..
/home/examples/manzana.jpg
/home/examples/banana.jpg
/home/examples/getpathname.php
/home/examples/pera.jpg

Ver también

  • DirectoryIterator::getBasename() - Obtener el nombre base del elemento actual DirectoryIterator
  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getPath() - Obtiene la ruta del elemento iterador actual sin nombre de fichero
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Obtiene los permisos del elemento actual DirectoryIterator

  • « DirectoryIterator::getPathname
  • DirectoryIterator::getSize »
  • PHP Manual
  • DirectoryIterator
  • Obtiene los permisos del elemento actual DirectoryIterator

DirectoryIterator::getPerms

(PHP 5, PHP 7)

DirectoryIterator::getPerms — Obtiene los permisos del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getPerms ( ) : int

Obtiene los permisos del elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los permisos de el fichero, Returns the permissions of the file, como un integer decimal.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getPerms()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        $octal_perms = substr(sprintf('%o', $fileinfo->getPerms()), -4);
        echo $fileinfo->getFilename() . " " . $octal_perms . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg 0644
banana.jpg 0644
index.php 0744
pera.jpg 0644

Ver también

  • DirectoryIterator::isExecutable() - Determina si el emento actual DirectoryIterator es ejecutable
  • DirectoryIterator::isReadable() - Determina si el elemento actual DirectoryIterator puede ser leído
  • DirectoryIterator::isWritable() - Determina si el elemento actual DirectoryIterator se puede escribir


obtiene el tamaño de el elemento actual DirectoryIterator

  • « DirectoryIterator::getPerms
  • DirectoryIterator::getType »
  • PHP Manual
  • DirectoryIterator
  • obtiene el tamaño de el elemento actual DirectoryIterator

DirectoryIterator::getSize

(PHP 5, PHP 7)

DirectoryIterator::getSize — obtiene el tamaño de el elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getSize ( ) : int

Obtiene el tamaño del fichero de el elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tamaño del fichero en bytes.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getSize()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getSize() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg 15385
banana.jpg 15190
ejemplo.php 170
pera.jpg 34406

Ver también

  • filesize() - Obtiene el tamaño de un fichero


Determina el tipo del elemento actual DirectoryIterator

  • « DirectoryIterator::getSize
  • DirectoryIterator::isDir »
  • PHP Manual
  • DirectoryIterator
  • Determina el tipo del elemento actual DirectoryIterator

DirectoryIterator::getType

(PHP 5, PHP 7)

DirectoryIterator::getType — Determina el tipo del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::getType ( ) : string

Determina el tipo del fichero al que pertenece el elemento actual DirectoryIterator. Puede ser file, link, o dir.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string que representa el tipo de el fichero. Puede ser file, link, or dir.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::getType()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getFilename() . " " . $fileinfo->getType() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

. dir
.. dir
manzana.jpg file
banana.jpg file
ejemplo.php file
pera.jpg file

Ver también

  • DirectoryIterator::isDir() - Determina si el elemento actual DirectoryIterator es un directorio
  • DirectoryIterator::isDot() - Determina si el elemento actual DirectoryIterator es '.' o '..'
  • DirectoryIterator::isFile() - Determina si el elemento actual DirectoryIterator es un fichero
  • DirectoryIterator::isLink() - Determina si el elemento actual DirectoryIterator es un enlace simbólico


Determina si el elemento actual DirectoryIterator es un directorio

  • « DirectoryIterator::getType
  • DirectoryIterator::isDot »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator es un directorio

DirectoryIterator::isDir

(PHP 5, PHP 7)

DirectoryIterator::isDir — Determina si el elemento actual DirectoryIterator es un directorio

Descripción

public DirectoryIterator::isDir ( ) : bool

Determina si el elemento actual DirectoryIterator es un directorio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si es un directorio, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isDir()

Este ejemplo mostrará los directorios del directorio actual donde se encuentra el script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isDir()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

.
..
manzanas
bananas
peras

Ver también

  • DirectoryIterator::getType() - Determina el tipo del elemento actual DirectoryIterator
  • DirectoryIterator::isDot() - Determina si el elemento actual DirectoryIterator es '.' o '..'
  • DirectoryIterator::isFile() - Determina si el elemento actual DirectoryIterator es un fichero
  • DirectoryIterator::isLink() - Determina si el elemento actual DirectoryIterator es un enlace simbólico


Determina si el elemento actual DirectoryIterator es '.' o '..'

  • « DirectoryIterator::isDir
  • DirectoryIterator::isExecutable »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator es '.' o '..'

DirectoryIterator::isDot

(PHP 5, PHP 7)

DirectoryIterator::isDot — Determina si el elemento actual DirectoryIterator es '.' o '..'

Descripción

public DirectoryIterator::isDot ( ) : bool

Determina si el elemento actual DirectoryIterator es un directorio y es . o ..

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la entrada es . o .., en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isDot()

Este ejemplo mostrará todos los ficheros, omitiendo las entradas . y .. e.j.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
ejemplo.php
pera.jpg

Ver también

  • DirectoryIterator::getType() - Determina el tipo del elemento actual DirectoryIterator
  • DirectoryIterator::isDir() - Determina si el elemento actual DirectoryIterator es un directorio
  • DirectoryIterator::isFile() - Determina si el elemento actual DirectoryIterator es un fichero
  • DirectoryIterator::isLink() - Determina si el elemento actual DirectoryIterator es un enlace simbólico


Determina si el emento actual DirectoryIterator es ejecutable

  • « DirectoryIterator::isDot
  • DirectoryIterator::isFile »
  • PHP Manual
  • DirectoryIterator
  • Determina si el emento actual DirectoryIterator es ejecutable

DirectoryIterator::isExecutable

(PHP 5, PHP 7)

DirectoryIterator::isExecutable — Determina si el emento actual DirectoryIterator es ejecutable

Descripción

public DirectoryIterator::isExecutable ( ) : bool

Determina si el elemento actual DirectoryIterator es ejecutable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada es ejecutable, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isExecutable()

Este ejemplo mostrará los ficheros en el directorio que contiene al script si son ejecutables.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isExecutable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

ejemplo.php
miscript.sh

Ver también

  • DirectoryIterator::isReadable() - Determina si el elemento actual DirectoryIterator puede ser leído
  • DirectoryIterator::isWritable() - Determina si el elemento actual DirectoryIterator se puede escribir
  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator


Determina si el elemento actual DirectoryIterator es un fichero

  • « DirectoryIterator::isExecutable
  • DirectoryIterator::isLink »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator es un fichero

DirectoryIterator::isFile

(PHP 5, PHP 7)

DirectoryIterator::isFile — Determina si el elemento actual DirectoryIterator es un fichero

Descripción

public DirectoryIterator::isFile ( ) : bool

Determina si el elemento actual DirectoryIterator es un fichero normal.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el fichero existe y si es un fichero normal (que no sea un link o dir), en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isFile()

Este ejemplo mostrará una lista de todos los ficheros normales en el directorio que contiene el script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
ejemplo.php
pera.jpg

Ver también

  • DirectoryIterator::getType() - Determina el tipo del elemento actual DirectoryIterator
  • DirectoryIterator::isDir() - Determina si el elemento actual DirectoryIterator es un directorio
  • DirectoryIterator::isDot() - Determina si el elemento actual DirectoryIterator es '.' o '..'
  • DirectoryIterator::isLink() - Determina si el elemento actual DirectoryIterator es un enlace simbólico


Determina si el elemento actual DirectoryIterator es un enlace simbólico

  • « DirectoryIterator::isFile
  • DirectoryIterator::isReadable »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator es un enlace simbólico

DirectoryIterator::isLink

(PHP 5, PHP 7)

DirectoryIterator::isLink — Determina si el elemento actual DirectoryIterator es un enlace simbólico

Descripción

public DirectoryIterator::isLink ( ) : bool

Determina si el elemento actual DirectoryIterator es un enlace simbólico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el elemento es un enlace simbólico, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isLink()

Este ejemplo contiene una función recursiva para remover el árbol del directorio.

<?php
/**
 * Esta función eliminará todos los ficheros resursivamente en la ruta dada sin seguir
 * los enlaces simbólicos.
 *
 * @param string $path Ruta del directorio a remover
 */
function removeDir($path) {
    $dir = new DirectoryIterator($path);
    foreach ($dir as $fileinfo) {
        if ($fileinfo->isFile() || $fileinfo->isLink()) {
            unlink($fileinfo->getPathName());
        } elseif (!$fileinfo->isDot() && $fileinfo->isDir()) {
            removeDir($fileinfo->getPathName());
        }
    }
    rmdir($path);
}

removeDir('foo');
?>

Ver también

  • DirectoryIterator::getType() - Determina el tipo del elemento actual DirectoryIterator
  • DirectoryIterator::isDir() - Determina si el elemento actual DirectoryIterator es un directorio
  • DirectoryIterator::isDot() - Determina si el elemento actual DirectoryIterator es '.' o '..'
  • DirectoryIterator::isFile() - Determina si el elemento actual DirectoryIterator es un fichero


Determina si el elemento actual DirectoryIterator puede ser leído

  • « DirectoryIterator::isLink
  • DirectoryIterator::isWritable »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator puede ser leído

DirectoryIterator::isReadable

(PHP 5, PHP 7)

DirectoryIterator::isReadable — Determina si el elemento actual DirectoryIterator puede ser leído

Descripción

public DirectoryIterator::isReadable ( ) : bool

Determina si el elemento actual DirectoryIterator se puede leer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el fichero se puede leer, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isReadable()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isReadable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
ejemplo.php
pera.jpg

Ver también

  • DirectoryIterator::isExecutable() - Determina si el emento actual DirectoryIterator es ejecutable
  • DirectoryIterator::isWritable() - Determina si el elemento actual DirectoryIterator se puede escribir
  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator


Determina si el elemento actual DirectoryIterator se puede escribir

  • « DirectoryIterator::isReadable
  • DirectoryIterator::key »
  • PHP Manual
  • DirectoryIterator
  • Determina si el elemento actual DirectoryIterator se puede escribir

DirectoryIterator::isWritable

(PHP 5, PHP 7)

DirectoryIterator::isWritable — Determina si el elemento actual DirectoryIterator se puede escribir

Descripción

public DirectoryIterator::isWritable ( ) : bool

Determina si el elemento actual DirectoryIterator se puede escribir.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se puede escribir en el fichero/directorio, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::isWritable()

Este ejemplo lista todos los ficheros y directorios que pueden ser abiertos para escribir en el directorio que contiene el script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isWritable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

manzanas.txt
bananas.html
peras

Ver también

  • DirectoryIterator::getPerms() - Obtiene los permisos del elemento actual DirectoryIterator
  • DirectoryIterator::isExecutable() - Determina si el emento actual DirectoryIterator es ejecutable
  • DirectoryIterator::isReadable() - Determina si el elemento actual DirectoryIterator puede ser leído


Devuelve la clave del elemento actual DirectoryIterator

  • « DirectoryIterator::isWritable
  • DirectoryIterator::next »
  • PHP Manual
  • DirectoryIterator
  • Devuelve la clave del elemento actual DirectoryIterator

DirectoryIterator::key

(PHP 5, PHP 7)

DirectoryIterator::key — Devuelve la clave del elemento actual DirectoryIterator

Descripción

public DirectoryIterator::key ( ) : string

Obtiene la clave para el elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave para el elemento actual DirectoryIterator.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::key()

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->key() . " => " . $fileinfo->getFilename() . "\n";
    }
}
?>

El resultado del ejemplo sería algo similar a:

0 => manzana.jpg
1 => banana.jpg
2 => index.php
3 => pera.jpg

Ver también

  • DirectoryIterator::current() - Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator
  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio
  • DirectoryIterator::valid() - Comprueba si la actual posición de DirectoryIterator es un fichero válido
  • Iterator::key() - Devuelve la clave del elemento actual


Avanza al siguiente elemento DirectoryIterator

  • « DirectoryIterator::key
  • DirectoryIterator::rewind »
  • PHP Manual
  • DirectoryIterator
  • Avanza al siguiente elemento DirectoryIterator

DirectoryIterator::next

(PHP 5, PHP 7)

DirectoryIterator::next — Avanza al siguiente elemento DirectoryIterator

Descripción

public DirectoryIterator::next ( ) : void

Avanzar al siguiente elemento DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::next()

List the contents of a directory using a while loop.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

El resultado del ejemplo sería algo similar a:

.
..
manzana.jpg
banana.jpg
index.php
pera.jpg

Ver también

  • DirectoryIterator::current() - Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::key() - Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio
  • DirectoryIterator::valid() - Comprueba si la actual posición de DirectoryIterator es un fichero válido
  • Iterator::next() - Avanza al siguiente elemento


Robobina DirectoryIterator hasta volver al inicio

  • « DirectoryIterator::next
  • DirectoryIterator::seek »
  • PHP Manual
  • DirectoryIterator
  • Robobina DirectoryIterator hasta volver al inicio

DirectoryIterator::rewind

(PHP 5, PHP 7)

DirectoryIterator::rewind — Robobina DirectoryIterator hasta volver al inicio

Descripción

public DirectoryIterator::rewind ( ) : void

Robobinar DirectoryIterator hasta volver al inicio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::rewind()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //Rebobinándose al inicio
echo $iterator->key(); //0
?>

Ver también

  • DirectoryIterator::current() - Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::key() - Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator
  • DirectoryIterator::valid() - Comprueba si la actual posición de DirectoryIterator es un fichero válido
  • Iterator::rewind() - Rebobine la Iterator al primer elemento


Mueve el apuntador interno del elemento DirectoryIterator

  • « DirectoryIterator::rewind
  • DirectoryIterator::__toString »
  • PHP Manual
  • DirectoryIterator
  • Mueve el apuntador interno del elemento DirectoryIterator

DirectoryIterator::seek

(PHP 5 >= 5.3.0, PHP 7)

DirectoryIterator::seek — Mueve el apuntador interno del elemento DirectoryIterator

Descripción

public DirectoryIterator::seek ( int $position ) : void

Mueve el apuntador interno a la posición dada en el elemento DirectoryIterator.

Parámetros

position

La base cero de la posición numérica a mover el apuntador interno.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::seek()

Mueve el apuntador interno al cuarto elemento en el directorio que contiene al script. Los primeros dos son generalmente . y ..

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$iterator->seek(3);
if ($iterator->valid()) {
    echo $iterator->getFilename();
} else {
    echo 'No hay fichero en la posición 3';
}
?>

Ver también

  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio
  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator
  • SeekableIterator::seek() - Mueve la posición del apuntador interno


Obtiene el nombre del fichero como un string

  • « DirectoryIterator::seek
  • DirectoryIterator::valid »
  • PHP Manual
  • DirectoryIterator
  • Obtiene el nombre del fichero como un string

DirectoryIterator::__toString

(PHP 5, PHP 7)

DirectoryIterator::__toString — Obtiene el nombre del fichero como un string

Descripción

public DirectoryIterator::__toString ( ) : string

Obtener el nombre del fichero del el elemento actual DirectoryIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero del elemento actual DirectoryIterator.

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::__toString()

Este ejemplo mostrará una lista con el contenido del directorio que contiene el script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo;
}
?>

El resultado del ejemplo sería algo similar a:

.
..
manzana.jpg
banana.jpg
index.php
pera.jpg

Ver también

  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • El método mágico __toString()


Comprueba si la actual posición de DirectoryIterator es un fichero válido

  • « DirectoryIterator::__toString
  • EmptyIterator »
  • PHP Manual
  • DirectoryIterator
  • Comprueba si la actual posición de DirectoryIterator es un fichero válido

DirectoryIterator::valid

(PHP 5, PHP 7)

DirectoryIterator::valid — Comprueba si la actual posición de DirectoryIterator es un fichero válido

Descripción

public DirectoryIterator::valid ( ) : bool

Comprobar si la posición actual de DirectoryIterator es un fichero válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la posición es válida, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de DirectoryIterator::valid()

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

// Bucle hasta el final del iterador
while($iterator->valid()) {
    $iterator->next();
}

$iterator->valid(); // FALSE
$iterator->rewind();
$iterator->valid(); // TRUE

?>

Ver también

  • DirectoryIterator::current() - Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::key() - Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator
  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio
  • Iterator::valid() - Comprueba si la posición actual es válido


La clase EmptyIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La clase EmptyIterator para un iterador vacío.

Sinopsis de la Clase

EmptyIterator implements Iterator {
/* Métodos */
public current ( ) : mixed
public key ( ) : scalar
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Tabla de contenidos

  • EmptyIterator::current — El método current()
  • EmptyIterator::key — El método key()
  • EmptyIterator::next — El método next()
  • EmptyIterator::rewind — El método rewind()
  • EmptyIterator::valid — El método valid()


El método current()

  • « EmptyIterator
  • EmptyIterator::key »
  • PHP Manual
  • EmptyIterator
  • El método current()

EmptyIterator::current

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::current — El método current()

Descripción

public EmptyIterator::current ( ) : mixed

Esta función no debe ser llamada. Lanza una excepción en su acceso.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Errores/Excepciones

Lanza una Exception si es llamada.

Valores devueltos

No devuelve ningún valor.


El método key()

  • « EmptyIterator::current
  • EmptyIterator::next »
  • PHP Manual
  • EmptyIterator
  • El método key()

EmptyIterator::key

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::key — El método key()

Descripción

public EmptyIterator::key ( ) : scalar

Esta función no debe ser llamada. Lanza una excepción en su acceso.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Errores/Excepciones

Lanza una Exception si es llamada.

Valores devueltos

No devuelve ningún valor.


El método next()

  • « EmptyIterator::key
  • EmptyIterator::rewind »
  • PHP Manual
  • EmptyIterator
  • El método next()

EmptyIterator::next

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::next — El método next()

Descripción

public EmptyIterator::next ( ) : void

No opera, nada a hacer.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


El método rewind()

  • « EmptyIterator::next
  • EmptyIterator::valid »
  • PHP Manual
  • EmptyIterator
  • El método rewind()

EmptyIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::rewind — El método rewind()

Descripción

public EmptyIterator::rewind ( ) : void

No opera, nada a hacer.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


El método valid()

  • « EmptyIterator::rewind
  • FilesystemIterator »
  • PHP Manual
  • EmptyIterator
  • El método valid()

EmptyIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::valid — El método valid()

Descripción

public EmptyIterator::valid ( ) : bool

El método valid() de EmptyIterator.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

false


La clase FilesystemIterator

(PHP 5 >= 5.3.0, PHP 7)

Introducción

El iterador Filesystem

Sinopsis de la Clase

FilesystemIterator extends DirectoryIterator implements SeekableIterator {
/* Constantes */
const integer CURRENT_AS_PATHNAME = 32 ;
const integer CURRENT_AS_FILEINFO = 0 ;
const integer CURRENT_AS_SELF = 16 ;
const integer CURRENT_MODE_MASK = 240 ;
const integer KEY_AS_PATHNAME = 0 ;
const integer KEY_AS_FILENAME = 256 ;
const integer FOLLOW_SYMLINKS = 512 ;
const integer KEY_MODE_MASK = 3840 ;
const integer NEW_CURRENT_AND_KEY = 256 ;
const integer SKIP_DOTS = 4096 ;
const integer UNIX_PATHS = 8192 ;
/* Métodos */
public __construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public current ( ) : mixed
public getFlags ( ) : int
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
public setFlags ( int $flags = ? ) : void
/* Métodos heredados */
public DirectoryIterator::current ( ) : DirectoryIterator
public DirectoryIterator::getATime ( ) : int
public DirectoryIterator::getBasename ( string $suffix = ? ) : string
public DirectoryIterator::getCTime ( ) : int
public DirectoryIterator::getExtension ( ) : string
public DirectoryIterator::getFilename ( ) : string
public DirectoryIterator::getGroup ( ) : int
public DirectoryIterator::getInode ( ) : int
public DirectoryIterator::getMTime ( ) : int
public DirectoryIterator::getOwner ( ) : int
public DirectoryIterator::getPath ( ) : string
public DirectoryIterator::getPathname ( ) : string
public DirectoryIterator::getPerms ( ) : int
public DirectoryIterator::getSize ( ) : int
public DirectoryIterator::getType ( ) : string
public DirectoryIterator::isDir ( ) : bool
public DirectoryIterator::isDot ( ) : bool
public DirectoryIterator::isExecutable ( ) : bool
public DirectoryIterator::isFile ( ) : bool
public DirectoryIterator::isLink ( ) : bool
public DirectoryIterator::isReadable ( ) : bool
public DirectoryIterator::isWritable ( ) : bool
public DirectoryIterator::key ( ) : string
public DirectoryIterator::next ( ) : void
public DirectoryIterator::rewind ( ) : void
public DirectoryIterator::seek ( int $position ) : void
public DirectoryIterator::__toString ( ) : string
public DirectoryIterator::valid ( ) : bool
}

Constantes predefinidas

FilesystemIterator::CURRENT_AS_PATHNAME

Hace que FilesystemIterator::current() devuelva el nombre de la ruta.

FilesystemIterator::CURRENT_AS_FILEINFO

Hace que FilesystemIterator::current() devuelva una instancia de SplFileInfo .

FilesystemIterator::CURRENT_AS_SELF

Hace que FilesystemIterator::current() devuelva $this (el objeto FilesystemIterator).

FilesystemIterator::CURRENT_MODE_MASK

Enmascara FilesystemIterator::current()

FilesystemIterator::KEY_AS_PATHNAME

Hace que FilesystemIterator::key() devuelva el nombre de la ruta.

FilesystemIterator::KEY_AS_FILENAME

Hace que FilesystemIterator::key() devuelva el nombre de fichero.

FilesystemIterator::FOLLOW_SYMLINKS

Hace que RecursiveDirectoryIterator::hasChildren() siga enlaces simbólicos.

FilesystemIterator::KEY_MODE_MASK

Enmascara FilesystemIterator::key()

FilesystemIterator::NEW_CURRENT_AND_KEY

Igual que FilesystemIterator::KEY_AS_FILENAME | FilesystemIterator::CURRENT_AS_FILEINFO.

FilesystemIterator::SKIP_DOTS

Ignora los ficheros punto (. y ..).

FilesystemIterator::UNIX_PATHS

Hace que las rutas usen la barra hacia adelante del estilo Unix independientemente de la predeterminada del sistema. Observe que la ruta path pasada al constructor no se modifica.

Historial de cambios

Versión | Descripción
5.3.1 | Añadido FilesystemIterator::FOLLOW_SYMLINKS

Tabla de contenidos

  • FilesystemIterator::__construct — Construye un nuevo iterador filesystem
  • FilesystemIterator::current — El fichero actual
  • FilesystemIterator::getFlags — Obtiene el manejo de flags
  • FilesystemIterator::key — Recupera la clave del fichero actual
  • FilesystemIterator::next — Moverse al siguiente fichero
  • FilesystemIterator::rewind — Rebobina hasta volver al inicio
  • FilesystemIterator::setFlags — Establece las flags de manejo


Construye un nuevo iterador filesystem

  • « FilesystemIterator
  • FilesystemIterator::current »
  • PHP Manual
  • FilesystemIterator
  • Construye un nuevo iterador filesystem

FilesystemIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::__construct — Construye un nuevo iterador filesystem

Descripción

public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )

Construir un nuevo iterador filesystem a partir del path.

Parámetros

path

la ruta de el elemento filesystem a iterar.

flags

Los flags pueden ser proporcionados para afectar el comportamiento de algunos métodos. Una lista de flags puede ser vista en constantes predefinidas FilesystemIterator. Estos pueden ser establecidos después con FilesystemIterator::setFlags()

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una UnexpectedValueException Si el path no puede ser encontrado.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::__construct()

<?php
$it = new FilesystemIterator(dirname(__FILE__));
foreach ($it as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

El resultado del ejemplo sería:

manzanas.jpg
banana.jpg
ejemplo.php

Ver también

  • FilesystemIterator::setFlags() - Establece las flags de manejo
  • DirectoryIterator::__construct() - Construye un iterador nuevo directorio de una ruta


El fichero actual

  • « FilesystemIterator::__construct
  • FilesystemIterator::getFlags »
  • PHP Manual
  • FilesystemIterator
  • El fichero actual

FilesystemIterator::current

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::current — El fichero actual

Descripción

public FilesystemIterator::current ( ) : mixed

Obtiene información de fichero del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre del fichero, información del fichero, o $this dependiendo de los indicadores establecidos. Véase las constantes de FilesystemIterator.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::current()

Este ejemplo enumerará el contenido del directorio que contiene al script.

<?php
$iterador = new FilesystemIterator(__DIR__, FilesystemIterator::CURRENT_AS_PATHNAME);
foreach ($iterador as $fileinfo) {
    echo $iterador->current() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

/www/ejemplos/manzana.jpg
/www/ejemplos/banana.jpg
/www/ejemplos/ejemplo.php

Ver también

  • Las constantes de FilesystemIterator
  • DirectoryIterator::current() - Devuelve el elemento actual del DirectoryIterator
  • DirectoryIterator::getFileName() - Devuelve el nombre del fichero del elemento actual DirectoryIterator


Obtiene el manejo de flags

  • « FilesystemIterator::current
  • FilesystemIterator::key »
  • PHP Manual
  • FilesystemIterator
  • Obtiene el manejo de flags

FilesystemIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::getFlags — Obtiene el manejo de flags

Descripción

public FilesystemIterator::getFlags ( ) : int

Obtener el manejo de flags, como está establecido en FilesystemIterator::__construct() o FilesystemIterator::setFlags().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un valor integer con las flags establecidas.

Ver también

  • FilesystemIterator::__construct() - Construye un nuevo iterador filesystem
  • FilesystemIterator::setFlags() - Establece las flags de manejo


Recupera la clave del fichero actual

  • « FilesystemIterator::getFlags
  • FilesystemIterator::next »
  • PHP Manual
  • FilesystemIterator
  • Recupera la clave del fichero actual

FilesystemIterator::key

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::key — Recupera la clave del fichero actual

Descripción

public FilesystemIterator::key ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de la ruta o el nombre del fichero dependiendo de las flags establecidas. Véase las constantes FilesystemIterator.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::key()

Este ejemplo mostrará el contenido del directorio actual que contiene al script.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);
foreach ($iterator as $fileinfo) {
    echo $iterator->key() . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
ejemplo.php

Ver también

  • constantes FilesystemIterator
  • DirectoryIterator::key() - Devuelve la clave del elemento actual DirectoryIterator
  • DirectoryIterator::getFilename() - Devuelve el nombre del fichero del elemento actual DirectoryIterator
  • DirectoryIterator::getPathname() - Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator


Moverse al siguiente fichero

  • « FilesystemIterator::key
  • FilesystemIterator::rewind »
  • PHP Manual
  • FilesystemIterator
  • Moverse al siguiente fichero

FilesystemIterator::next

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::next — Moverse al siguiente fichero

Descripción

public FilesystemIterator::next ( ) : void

Moverse al siguiente fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::next()

Lista el contenido de un directorio usando un bucle while.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
ejemplo.php

Ver también

  • DirectoryIterator::next() - Avanza al siguiente elemento DirectoryIterator


Rebobina hasta volver al inicio

  • « FilesystemIterator::next
  • FilesystemIterator::setFlags »
  • PHP Manual
  • FilesystemIterator
  • Rebobina hasta volver al inicio

FilesystemIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::rewind — Rebobina hasta volver al inicio

Descripción

public FilesystemIterator::rewind ( ) : void

Rebobinar el directorio hasta volver al inicio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::rewind()

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);

echo $iterator->key() . "\n";

$iterator->next();
echo $iterator->key() . "\n";

$iterator->rewind();
echo $iterator->key() . "\n";
?>

El resultado del ejemplo sería algo similar a:

manzana.jpg
banana.jpg
manzana.jpg

Ver también

  • DirectoryIterator::rewind() - Robobina DirectoryIterator hasta volver al inicio


Establece las flags de manejo

  • « FilesystemIterator::rewind
  • FilterIterator »
  • PHP Manual
  • FilesystemIterator
  • Establece las flags de manejo

FilesystemIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::setFlags — Establece las flags de manejo

Descripción

public FilesystemIterator::setFlags ( int $flags = ? ) : void

Establecer las flags de manejo.

Parámetros

flags

las flags de manejo a establecer. Véase las constantes FilesystemIterator.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de FilesystemIterator::key()

Este ejemplo demuestra las diferencias entre las flags FilesystemIterator::KEY_AS_PATHNAME y FilesystemIterator::KEY_AS_FILENAME.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_PATHNAME);
echo "Clave como nombre de rura:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}

$iterator->setFlags(FilesystemIterator::KEY_AS_FILENAME);
echo "\nClave como nombre de fichero:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Clave como nombre de rura:
/www/examples/apple.jpg
/www/examples/banana.jpg
/www/examples/example.php

Clave como nombre de fichero:
apple.jpg
banana.jpg
example.php

Ver también

  • FilesystemIterator::__construct() - Construye un nuevo iterador filesystem
  • FilesystemIterator::getFlags() - Obtiene el manejo de flags


The FilterIterator class

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Este iterador abstracto filtra valores no deseados. Esta clase debería ser ampliada para implementar filtros personalizados. FilterIterator::accept() debe ser implementado en la subclase.

Sinopsis de la Clase

abstract FilterIterator extends IteratorIterator implements OuterIterator {
/* Métodos */
public abstract accept ( ) : bool
public __construct ( Iterator $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : Iterator
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Tabla de contenidos

  • FilterIterator::accept — Comprueba si el elemento actual del iterador es aceptable
  • FilterIterator::__construct — Construye un filterIterator
  • FilterIterator::current — Obtiene el valor del elemento actual
  • FilterIterator::getInnerIterator — Obtiene el iterador interno
  • FilterIterator::key — Obtiene la clave actual
  • FilterIterator::next — Mueve el iterador a la siguiente posición
  • FilterIterator::rewind — Rebobina el iterador
  • FilterIterator::valid — Comprueba si el elemento actual es válido


Comprueba si el elemento actual del iterador es aceptable

  • « FilterIterator
  • FilterIterator::__construct »
  • PHP Manual
  • FilterIterator
  • Comprueba si el elemento actual del iterador es aceptable

FilterIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::accept — Comprueba si el elemento actual del iterador es aceptable

Descripción

public abstract FilterIterator::accept ( ) : bool

Devuelve si el elemento actual del iterador es aceptable a través de este filtro.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el elemento actual es aceptable, o false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de FilterIterator::accept()

<?php
// Este iterador filtra los valores con menos de 10 caracteres
class LengthFilterIterator extends FilterIterator {

    public function accept() {
        // Sólo acepta string con una longitud de 10 o mayor
        return strlen(parent::current()) >= 10;
    }

}

$arrayIterator = new ArrayIterator(array('test1', 'más de 10 caracteres'));
$lengthFilter = new LengthFilterIterator($arrayIterator);

foreach ($lengthFilter as $value) {
    echo $value . "\n";
}
?>

El resultado del ejemplo sería:

más de 10 caracteres


Construye un filterIterator

  • « FilterIterator::accept
  • FilterIterator::current »
  • PHP Manual
  • FilterIterator
  • Construye un filterIterator

FilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::__construct — Construye un filterIterator

Descripción

public FilterIterator::__construct ( Iterator $iterator )

Construir un nuevo FilterIterator, que consiste en pasar un iterator y aplicar varios filtros a este.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El iterador que va a ser filtrado.

Valores devueltos

The FilterIterator.

Ver también

  • LimitIterator::__construct() - Construye un LimitIterator


Obtiene el valor del elemento actual

  • « FilterIterator::__construct
  • FilterIterator::getInnerIterator »
  • PHP Manual
  • FilterIterator
  • Obtiene el valor del elemento actual

FilterIterator::current

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::current — Obtiene el valor del elemento actual

Descripción

public FilterIterator::current ( ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

obtiene el valor del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del elemento actual.

Ver también

  • FilterIterator::key() - Obtiene la clave actual
  • FilterIterator::next() - Mueve el iterador a la siguiente posición


Obtiene el iterador interno

  • « FilterIterator::current
  • FilterIterator::key »
  • PHP Manual
  • FilterIterator
  • Obtiene el iterador interno

FilterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::getInnerIterator — Obtiene el iterador interno

Descripción

public FilterIterator::getInnerIterator ( ) : Iterator
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene el iterador interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno.


Obtiene la clave actual

  • « FilterIterator::getInnerIterator
  • FilterIterator::next »
  • PHP Manual
  • FilterIterator
  • Obtiene la clave actual

FilterIterator::key

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::key — Obtiene la clave actual

Descripción

public FilterIterator::key ( ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene la clave actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave actual.

Ver también

  • FilterIterator::next() - Mueve el iterador a la siguiente posición
  • FilterIterator::current() - Obtiene el valor del elemento actual


Mueve el iterador a la siguiente posición

  • « FilterIterator::key
  • FilterIterator::rewind »
  • PHP Manual
  • FilterIterator
  • Mueve el iterador a la siguiente posición

FilterIterator::next

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::next — Mueve el iterador a la siguiente posición

Descripción

public FilterIterator::next ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Mover el iterador a la siguiente posición.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • FilterIterator::current() - Obtiene el valor del elemento actual
  • FilterIterator::key() - Obtiene la clave actual


Rebobina el iterador

  • « FilterIterator::next
  • FilterIterator::valid »
  • PHP Manual
  • FilterIterator
  • Rebobina el iterador

FilterIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::rewind — Rebobina el iterador

Descripción

public FilterIterator::rewind ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Rebobinar el iterador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • FilterIterator::current() - Obtiene el valor del elemento actual
  • FilterIterator::key() - Obtiene la clave actual
  • FilterIterator::next() - Mueve el iterador a la siguiente posición


Comprueba si el elemento actual es válido

  • « FilterIterator::rewind
  • GlobIterator »
  • PHP Manual
  • FilterIterator
  • Comprueba si el elemento actual es válido

FilterIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::valid — Comprueba si el elemento actual es válido

Descripción

public FilterIterator::valid ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Comprobar si el elemento actual es válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el elemento actual es válido, en caso contrario false


La clase GlobIterator

(PHP 5 >= 5.3.0, PHP 7)

Introducción

Recorre un sistema de ficheros de forma similar a glob().

Sinopsis de la Clase

GlobIterator extends FilesystemIterator implements SeekableIterator , Countable {
/* Constantaes heredadas constants */
const integer FilesystemIterator::CURRENT_AS_PATHNAME = 32 ;
const integer FilesystemIterator::CURRENT_AS_FILEINFO = 0 ;
const integer FilesystemIterator::CURRENT_AS_SELF = 16 ;
const integer FilesystemIterator::CURRENT_MODE_MASK = 240 ;
const integer FilesystemIterator::KEY_AS_PATHNAME = 0 ;
const integer FilesystemIterator::KEY_AS_FILENAME = 256 ;
const integer FilesystemIterator::FOLLOW_SYMLINKS = 512 ;
const integer FilesystemIterator::KEY_MODE_MASK = 3840 ;
const integer FilesystemIterator::NEW_CURRENT_AND_KEY = 256 ;
const integer FilesystemIterator::SKIP_DOTS = 4096 ;
const integer FilesystemIterator::UNIX_PATHS = 8192 ;
/* Métodos */
public __construct ( string $pattern , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )
public count ( ) : int
/* Métodos heredados */
public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public FilesystemIterator::current ( ) : mixed
public FilesystemIterator::getFlags ( ) : int
public FilesystemIterator::key ( ) : string
public FilesystemIterator::next ( ) : void
public FilesystemIterator::rewind ( ) : void
public FilesystemIterator::setFlags ( int $flags = ? ) : void
}

Tabla de contenidos

  • GlobIterator::__construct — Construye un directorio usando glob
  • GlobIterator::count — Obtiene el número de directorios y ficheros


Construye un directorio usando glob

  • « GlobIterator
  • GlobIterator::count »
  • PHP Manual
  • GlobIterator
  • Construye un directorio usando glob

GlobIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::__construct — Construye un directorio usando glob

Descripción

public GlobIterator::__construct ( string $pattern , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )

Construye un nuevo iterador de directorio de una expresión glob.

Parámetros

pattern

Un patrón glob().

flags

flags de opción, las flags pueden ser máscaras de las constantes FilesystemIterator.

Ejemplos

Ejemplo #1 Ejemplo de GlobIterator

<?php
$iterator = new GlobIterator('*.dll', FilesystemIterator::KEY_AS_FILENAME);

if (!$iterator->count()) {
    echo 'No matches';
} else {
    $n = 0;

    printf("Matched %d item(s)\r\n", $iterator->count());

    foreach ($iterator as $item) {
        printf("[%d] %s\r\n", ++$n, $iterator->key());
    }
}
?>

El resultado del ejemplo sería algo similar a:

Matched 2 item(s)
[1] php5ts.dll
[2] php_gd2.dll

Ver también

  • DirectoryIterator::__construct() - Construye un iterador nuevo directorio de una ruta
  • GlobIterator::count() - Obtiene el número de directorios y ficheros
  • glob() - Buscar coincidencias de nombres de ruta con un patrón


Obtiene el número de directorios y ficheros

  • « GlobIterator::__construct
  • InfiniteIterator »
  • PHP Manual
  • GlobIterator
  • Obtiene el número de directorios y ficheros

GlobIterator::count

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::count — Obtiene el número de directorios y ficheros

Descripción

public GlobIterator::count ( ) : int

Obtener el número de directorios y ficheros encontrados por la expresión glob.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de directoeios y ficheros, como un integer.

Ejemplos

Ejemplo #1 Ejemplo de GlobIterator::count()

<?php
$iterator = new GlobIterator('*.xml');

printf("Elementos encontrado(s): %d \r\n", $iterator->count());
?>

El resultado del ejemplo sería algo similar a:

Elementos encontrado(s): 8

Ver también

  • GlobIterator::__construct() - Construye un directorio usando glob
  • count() - Cuenta todos los elementos de un array o algo de un objeto
  • glob() - Buscar coincidencias de nombres de ruta con un patrón


La clase InfiniteIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La clase InfiniteIterator permite recorrer un iterador de forma infinita sin tener que rebobinar manualmente el iterador al llegar a su final.

Sinopsis de la Clase

InfiniteIterator extends IteratorIterator implements OuterIterator {
/* Métodos */
public __construct ( Iterator $iterator )
public next ( ) : void
/* Métodos heredados */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Tabla de contenidos

  • InfiniteIterator::__construct — Construye un InfiniteIterator
  • InfiniteIterator::next — Mueve el iterador interno hacía adelante o se rebobina


Construye un InfiniteIterator

  • « InfiniteIterator
  • InfiniteIterator::next »
  • PHP Manual
  • InfiniteIterator
  • Construye un InfiniteIterator

InfiniteIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::__construct — Construye un InfiniteIterator

Descripción

public InfiniteIterator::__construct ( Iterator $iterator )

Construye un InfiniteIterator de un Iterator.

Parámetros

iterator

El iterador a iterar infinitamente.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una E_RECOVERABLE_ERROR si el parámetro iterator no es un Iterator.

Ejemplos

Ejemplo #1 Ejemplo de InfiniteIterator::__construct()

<?php
$arrayit  = new ArrayIterator(array('gato','perro'));
$infinite = new InfiniteIterator($arrayit);
$limit    = new LimitIterator($infinite, 0, 7);
foreach($limit as $value)
{
    echo "$value\n";
}
?>

El resultado del ejemplo sería:

gato
perro
gato
perro
gato
perro
gato

Ver también

  • InfiniteIterator::next() - Mueve el iterador interno hacía adelante o se rebobina


Mueve el iterador interno hacía adelante o se rebobina

  • « InfiniteIterator::__construct
  • IteratorIterator »
  • PHP Manual
  • InfiniteIterator
  • Mueve el iterador interno hacía adelante o se rebobina

InfiniteIterator::next

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::next — Mueve el iterador interno hacía adelante o se rebobina

Descripción

public InfiniteIterator::next ( ) : void

Mueve el elemento del Iterator interno al siguiente elemento si hay alguno, en caso contrario rebobina el Iterator interno hasta el inicio.

Nota:

Incluso un InfiniteIterator se detiene si un Iterator está vacío.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • InfiniteIterator::__construct() - Construye un InfiniteIterator


La clase IteratorIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Esta envoltura de iteradores permite la conversión de todo aquello que es Traversable a un iterador. Es importante comprender que la mayoría de las clases que no implementan iteradores, lo más probable es que no permitan todas las características del iterador. Si es así, deberían proporcionarse técnicas para evitar un uso indebido, de lo contrario se pueden esperar excepciones o errores fatales.

Sinopsis de la Clase

IteratorIterator implements OuterIterator {
/* Métodos */
public __construct ( Traversable $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : Traversable
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Notas

Nota:

Esta clase permite el acceso a métodos del iterador interno mediante el método mágico __call.

Tabla de contenidos

  • IteratorIterator::__construct — Crear un iterador de cualquier cosa que se pueda recorrer
  • IteratorIterator::current — Obtener el valor actual
  • IteratorIterator::getInnerIterator — Obtener el iterador interno
  • IteratorIterator::key — Obtener la clave del elemento actual
  • IteratorIterator::next — Avanzar al siguiente elemento
  • IteratorIterator::rewind — Rebobinar al primer elemento
  • IteratorIterator::valid — Comprobar si el iterador es válido


Crear un iterador de cualquier cosa que se pueda recorrer

  • « IteratorIterator
  • IteratorIterator::current »
  • PHP Manual
  • IteratorIterator
  • Crear un iterador de cualquier cosa que se pueda recorrer

IteratorIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::__construct — Crear un iterador de cualquier cosa que se pueda recorrer

Descripción

public IteratorIterator::__construct ( Traversable $iterator )

Crea un iterador de cualquier cosa que se pueda recorrer.

Parámetros

iterator

El iterador recorrible.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Traversable


Obtener el valor actual

  • « IteratorIterator::__construct
  • IteratorIterator::getInnerIterator »
  • PHP Manual
  • IteratorIterator
  • Obtener el valor actual

IteratorIterator::current

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::current — Obtener el valor actual

Descripción

public IteratorIterator::current ( ) : mixed

Obtiene el valor actual del elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del elemento actual.

Ver también

  • IteratorIterator::key() - Obtener la clave del elemento actual


Obtener el iterador interno

  • « IteratorIterator::current
  • IteratorIterator::key »
  • PHP Manual
  • IteratorIterator
  • Obtener el iterador interno

IteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::getInnerIterator — Obtener el iterador interno

Descripción

public IteratorIterator::getInnerIterator ( ) : Traversable

Obtiene el iterador interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno tal y como se pasó a IteratorIterator::__construct().

Ver también

  • Iterator
  • OuterIterator


Obtener la clave del elemento actual

  • « IteratorIterator::getInnerIterator
  • IteratorIterator::next »
  • PHP Manual
  • IteratorIterator
  • Obtener la clave del elemento actual

IteratorIterator::key

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::key — Obtener la clave del elemento actual

Descripción

public IteratorIterator::key ( ) : mixed

Obtiene la clave del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave del elemento actual.

Ver también

  • IteratorIterator::current() - Obtener el valor actual


Avanzar al siguiente elemento

  • « IteratorIterator::key
  • IteratorIterator::rewind »
  • PHP Manual
  • IteratorIterator
  • Avanzar al siguiente elemento

IteratorIterator::next

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::next — Avanzar al siguiente elemento

Descripción

public IteratorIterator::next ( ) : void

Avanza al siguiente elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • IteratorIterator::rewind() - Rebobinar al primer elemento
  • IteratorIterator::valid() - Comprobar si el iterador es válido


Rebobinar al primer elemento

  • « IteratorIterator::next
  • IteratorIterator::valid »
  • PHP Manual
  • IteratorIterator
  • Rebobinar al primer elemento

IteratorIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::rewind — Rebobinar al primer elemento

Descripción

public IteratorIterator::rewind ( ) : void

Rebobinar al primer elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • IteratorIterator::next() - Avanzar al siguiente elemento
  • IteratorIterator::valid() - Comprobar si el iterador es válido


Comprobar si el iterador es válido

  • « IteratorIterator::rewind
  • LimitIterator »
  • PHP Manual
  • IteratorIterator
  • Comprobar si el iterador es válido

IteratorIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::valid — Comprobar si el iterador es válido

Descripción

public IteratorIterator::valid ( ) : bool

Comprueba si el iterador es válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el iterador es válido, false en caso contrario

Ver también

  • iterator_count() - Contar los elementos de un iterador
  • IteratorIterator::current() - Obtener el valor actual


La clase LimitIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La clase LimitIterator permite recorrer un limitado subconjunto de elemento de un Iterator.

Sinopsis de la Clase

LimitIterator extends IteratorIterator implements OuterIterator {
/* Métodos */
public __construct ( Iterator $iterator , int $offset = 0 , int $count = -1 )
public current ( ) : mixed
public getInnerIterator ( ) : Iterator
public getPosition ( ) : int
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public seek ( int $position ) : int
public valid ( ) : bool
}

Ejemplos

Ejemplo #1 Ejemplo de uso de LimitIterator

<?php

// Crea un iterador a limitar
$frutas = new ArrayIterator(array(
    'manzana',
    'banana',
    'cereza',
    'ciruela',
    'baya'
));

// Recorre el bucle sólo para las tres primeras frutas
foreach (new LimitIterator($frutas, 0, 3) as $fruta) {
    var_dump($fruta);
}

echo "\n";

// Recorre el bucle desde la tercera fruta hasta el final
// Nota: empieza por 0, por manzana
foreach (new LimitIterator($frutas, 2) as $fruta) {
    var_dump($fruta);
}

?>

El resultado del ejemplo sería:

string(7) "manzana"
string(6) "banana"
string(6) "cereza"

string(6) "cereza"
string(7) "ciruela"
string(4) "baya"

Tabla de contenidos

  • LimitIterator::__construct — Construye un LimitIterator
  • LimitIterator::current — Obtiene el elemento actual
  • LimitIterator::getInnerIterator — Obtiene el iterador interno
  • LimitIterator::getPosition — Devuelve la posición actual
  • LimitIterator::key — Obtiene la clave actual
  • LimitIterator::next — Mueve el iterador a la siguiente posición
  • LimitIterator::rewind — Rebobina el iterador a un punto específicado
  • LimitIterator::seek — Mueve el apuntador interno a la posición dada
  • LimitIterator::valid — Comprobar si el elemento actual es válido


Construye un LimitIterator

  • « LimitIterator
  • LimitIterator::current »
  • PHP Manual
  • LimitIterator
  • Construye un LimitIterator

LimitIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::__construct — Construye un LimitIterator

Descripción

public LimitIterator::__construct ( Iterator $iterator , int $offset = 0 , int $count = -1 )

Construye un nuevo LimitIterator de un iterator con un determinado inicio offset y un máximo count.

Parámetros

iterator

El Iterator a limitar.

offset

Índice opcional de el límite.

count

Cuenta opcional de el límite.

Valores devueltos

El nuevo LimitIterator.

Errores/Excepciones

Lanza una OutOfRangeException si el offset es menor que 0 o el count es menor que -1.

Ejemplos

Ejemplo #1 Ejemplo de LimitIterator::__construct()

<?php
$ait = new ArrayIterator(array('a', 'b', 'c', 'd', 'e'));
$lit = new LimitIterator($ait, 1, 3);
foreach ($lit as $value) {
    echo $value . "\n";
}
?>

El resultado del ejemplo sería:

b
c
d

Ver también

  • Ejemplos de LimitIterator


Obtiene el elemento actual

  • « LimitIterator::__construct
  • LimitIterator::getInnerIterator »
  • PHP Manual
  • LimitIterator
  • Obtiene el elemento actual

LimitIterator::current

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::current — Obtiene el elemento actual

Descripción

public LimitIterator::current ( ) : mixed

Obtener el elemento actual del Iterator interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el elemento actual o null si no hay ninguno.

Ver también

  • LimitIterator::key() - Obtiene la clave actual
  • LimitIterator::next() - Mueve el iterador a la siguiente posición
  • LimitIterator::rewind() - Rebobina el iterador a un punto específicado
  • LimitIterator::seek() - Mueve el apuntador interno a la posición dada
  • LimitIterator::valid() - Comprobar si el elemento actual es válido


Obtiene el iterador interno

  • « LimitIterator::current
  • LimitIterator::getPosition »
  • PHP Manual
  • LimitIterator
  • Obtiene el iterador interno

LimitIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getInnerIterator — Obtiene el iterador interno

Descripción

public LimitIterator::getInnerIterator ( ) : Iterator

Obtener el Iterator interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno pasado a LimitIterator::__construct().

Ver también

  • LimitIterator::__construct() - Construye un LimitIterator
  • IteratorIterator::getInnerIterator() - Obtener el iterador interno


Devuelve la posición actual

  • « LimitIterator::getInnerIterator
  • LimitIterator::key »
  • PHP Manual
  • LimitIterator
  • Devuelve la posición actual

LimitIterator::getPosition

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getPosition — Devuelve la posición actual

Descripción

public LimitIterator::getPosition ( ) : int

Obtiene la posición basada en cero de el Iterator interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La posición actual.

Ejemplos

Ejemplo #1 Ejemplo de LimitIterator::getPosition()

<?php
$fruits = array(
    'a' => 'manzana',
    'b' => 'banana',
    'c' => 'cereza',
    'd' => 'ciruela',
    'e' => 'baya'
);
$array_it = new ArrayIterator($fruits);
$limit_it = new LimitIterator($array_it, 2, 3);
foreach ($limit_it as $item) {
    echo $limit_it->getPosition() . ' ' . $item . "\n";
}
?>

El resultado del ejemplo sería:

2 cereza
3 ciruela
4 baya

Ver también

  • FilterIterator::key() - Obtiene la clave actual


Obtiene la clave actual

  • « LimitIterator::getPosition
  • LimitIterator::next »
  • PHP Manual
  • LimitIterator
  • Obtiene la clave actual

LimitIterator::key

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::key — Obtiene la clave actual

Descripción

public LimitIterator::key ( ) : mixed

Obtiene la clave para el elemento actual en el Iterator interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clave de el elemento actual.

Ver también

  • LimitIterator::getPosition() - Devuelve la posición actual
  • LimitIterator::current() - Obtiene el elemento actual
  • LimitIterator::next() - Mueve el iterador a la siguiente posición
  • LimitIterator::rewind() - Rebobina el iterador a un punto específicado
  • LimitIterator::seek() - Mueve el apuntador interno a la posición dada
  • LimitIterator::valid() - Comprobar si el elemento actual es válido


Mueve el iterador a la siguiente posición

  • « LimitIterator::key
  • LimitIterator::rewind »
  • PHP Manual
  • LimitIterator
  • Mueve el iterador a la siguiente posición

LimitIterator::next

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::next — Mueve el iterador a la siguiente posición

Descripción

public LimitIterator::next ( ) : void

Mover el iterador a la siguiente posición

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • LimitIterator::current() - Obtiene el elemento actual
  • LimitIterator::key() - Obtiene la clave actual
  • LimitIterator::rewind() - Rebobina el iterador a un punto específicado
  • LimitIterator::seek() - Mueve el apuntador interno a la posición dada
  • LimitIterator::valid() - Comprobar si el elemento actual es válido


Rebobina el iterador a un punto específicado

  • « LimitIterator::next
  • LimitIterator::seek »
  • PHP Manual
  • LimitIterator
  • Rebobina el iterador a un punto específicado

LimitIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::rewind — Rebobina el iterador a un punto específicado

Descripción

public LimitIterator::rewind ( ) : void

Rebobina el iterador a un índice de inicio específicado en LimitIterator::__construct().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • LimitIterator::current() - Obtiene el elemento actual
  • LimitIterator::key() - Obtiene la clave actual
  • LimitIterator::next() - Mueve el iterador a la siguiente posición
  • LimitIterator::seek() - Mueve el apuntador interno a la posición dada
  • LimitIterator::valid() - Comprobar si el elemento actual es válido


Mueve el apuntador interno a la posición dada

  • « LimitIterator::rewind
  • LimitIterator::valid »
  • PHP Manual
  • LimitIterator
  • Mueve el apuntador interno a la posición dada

LimitIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::seek — Mueve el apuntador interno a la posición dada

Descripción

public LimitIterator::seek ( int $position ) : int

Mueve el iterador a el índice específicado por position.

Parámetros

position

La posición para mover el apuntador interno.

Valores devueltos

Devuelve el índice de la posición después de mover el apuntador interno.

Errores/Excepciones

Lanza una OutOfBoundsException si la posición está fuera de los límites específicados en LimitIterator::__construct().

Ver también

  • LimitIterator::current() - Obtiene el elemento actual
  • LimitIterator::key() - Obtiene la clave actual
  • LimitIterator::rewind() - Rebobina el iterador a un punto específicado
  • LimitIterator::next() - Mueve el iterador a la siguiente posición
  • LimitIterator::valid() - Comprobar si el elemento actual es válido


Comprobar si el elemento actual es válido

  • « LimitIterator::seek
  • MultipleIterator »
  • PHP Manual
  • LimitIterator
  • Comprobar si el elemento actual es válido

LimitIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::valid — Comprobar si el elemento actual es válido

Descripción

public LimitIterator::valid ( ) : bool

Comprobar si el elemento actual es válido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • LimitIterator::current() - Obtiene el elemento actual
  • LimitIterator::key() - Obtiene la clave actual
  • LimitIterator::rewind() - Rebobina el iterador a un punto específicado
  • LimitIterator::next() - Mueve el iterador a la siguiente posición
  • LimitIterator::seek() - Mueve el apuntador interno a la posición dada


La clase MultipleIterator

(PHP 5 >= 5.3.0, PHP 7)

Introducción

Un iterador que secuencialmente recorre todos los iteradores adjuntos.

Sinopsis de la Clase

MultipleIterator implements Iterator {
/* Constantes */
const integer MIT_NEED_ANY = 0 ;
const integer MIT_NEED_ALL = 1 ;
const integer MIT_KEYS_NUMERIC = 0 ;
const integer MIT_KEYS_ASSOC = 2 ;
/* Métodos */
public __construct ( int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC )
public attachIterator ( Iterator $iterator , string $infos = ? ) : void
public containsIterator ( Iterator $iterator ) : bool
public countIterators ( ) : int
public current ( ) : array
public detachIterator ( Iterator $iterator ) : void
public getFlags ( ) : int
public key ( ) : array
public next ( ) : void
public rewind ( ) : void
public setFlags ( int $flags ) : void
public valid ( ) : bool
}

Constantes predefinidas

MultipleIterator::MIT_NEED_ANY

No requiere que todos los subiteradores sean válidos en la iteración.

MultipleIterator::MIT_NEED_ALL

Requiere que todos los subiteradores sean válidos en la iteración.

MultipleIterator::MIT_KEYS_NUMERIC

Las claves se crean desde la posición de los subiteradores.

MultipleIterator::MIT_KEYS_ASSOC

Las claves se crean desde la información asociada de los subiteradores.

Tabla de contenidos

  • MultipleIterator::attachIterator — Adjunta información al iterador
  • MultipleIterator::__construct — Construye un nuevo MultipleIterator
  • MultipleIterator::containsIterator — Comprueba si un iterador está adjunto
  • MultipleIterator::countIterators — Obtiene el número de instancias de iteradores adjuntos
  • MultipleIterator::current — Obtiene las instancias registradas del iterador
  • MultipleIterator::detachIterator — Desasocia un iterador
  • MultipleIterator::getFlags — Obtiene información de las flags
  • MultipleIterator::key — Obtiene las instancias registradas del iterador
  • MultipleIterator::next — Mueve todas las instancias de iterador adjuntadas hacía la siguiente
  • MultipleIterator::rewind — Rebobina todas las instancias de iterador adjuntadas
  • MultipleIterator::setFlags — Establece las flags
  • MultipleIterator::valid — Comprueba la validez de los subiteradores


Adjunta información al iterador

  • « MultipleIterator
  • MultipleIterator::__construct »
  • PHP Manual
  • MultipleIterator
  • Adjunta información al iterador

MultipleIterator::attachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::attachIterator — Adjunta información al iterador

Descripción

public MultipleIterator::attachIterator ( Iterator $iterator , string $infos = ? ) : void

Adjunta información al iterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El nuevo iterador para ser adjuntado.

infos

La información asociada al iterador, debe ser un integer, un string, o null.

Valores devueltos

Description...

Errores/Excepciones

Lanza una IllegalValueException si el parámetro iterator no es válido, o si infos ya está asociado a la información.

Ver también

  • MultipleIterator::__construct() - Construye un nuevo MultipleIterator


Construye un nuevo MultipleIterator

  • « MultipleIterator::attachIterator
  • MultipleIterator::containsIterator »
  • PHP Manual
  • MultipleIterator
  • Construye un nuevo MultipleIterator

MultipleIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::__construct — Construye un nuevo MultipleIterator

Descripción

public MultipleIterator::__construct ( int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC )

Construye un nuevo MultipleIterator.

Parámetros

flags

Las flags a ser establecidas, de acuerdo a las constantes Flag.

  • MultipleIterator::MIT_NEED_ALL or MultipleIterator::MIT_NEED_ANY
  • MultipleIterator::MIT_KEYS_NUMERIC or MultipleIterator::MIT_KEYS_ASSOC

Por omisión MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Iterar un MultipleIterator

<?php
$people = new ArrayIterator(array('John', 'Jane', 'Jack', 'Judy'));
$roles  = new ArrayIterator(array('Developer', 'Scrum Master', 'Project Owner'));

$team = new MultipleIterator($flags);
$team->attachIterator($people, 'person');
$team->attachIterator($roles, 'role');

foreach ($team as $member) {
    print_r($member);
}
?>

Salida con $flags = MIT_NEED_ALL|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)

Salida con $flags = MIT_NEED_ANY|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)
Array
(
    [0] => Judy
    [1] =>
)

Salida con $flags = MIT_NEED_ALL|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)

Salida con $flags = MIT_NEED_ANY|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)
Array
(
    [person] => Judy
    [role] =>
)

Ver también

  • Constantes Flag
  • MultipleIterator::valid() - Comprueba la validez de los subiteradores


Comprueba si un iterador está adjunto

  • « MultipleIterator::__construct
  • MultipleIterator::countIterators »
  • PHP Manual
  • MultipleIterator
  • Comprueba si un iterador está adjunto

MultipleIterator::containsIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::containsIterator — Comprueba si un iterador está adjunto

Descripción

public MultipleIterator::containsIterator ( Iterator $iterator ) : bool

Comprueba si un iterador está adjunto o no.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El iterador a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • MultipleIterator::valid() - Comprueba la validez de los subiteradores


Obtiene el número de instancias de iteradores adjuntos

  • « MultipleIterator::containsIterator
  • MultipleIterator::current »
  • PHP Manual
  • MultipleIterator
  • Obtiene el número de instancias de iteradores adjuntos

MultipleIterator::countIterators

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::countIterators — Obtiene el número de instancias de iteradores adjuntos

Descripción

public MultipleIterator::countIterators ( ) : int

Obtiene el número de instancias de iteradores adjuntos.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de instancias de iteradores adjuntos (como un integer).

Ver también

  • MultipleIterator::containsIterator() - Comprueba si un iterador está adjunto


Obtiene las instancias registradas del iterador

  • « MultipleIterator::countIterators
  • MultipleIterator::detachIterator »
  • PHP Manual
  • MultipleIterator
  • Obtiene las instancias registradas del iterador

MultipleIterator::current

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::current — Obtiene las instancias registradas del iterador

Descripción

public MultipleIterator::current ( ) : array

Obtiene las instancias registradas del iterador del resultado current().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array conteniendo los valores actuales de cada iterador adjuntado, o false si no hay ningún iterador adjuntado.

Errores/Excepciones

Lanza una RuntimeException si el modo MIT_NEED_ALL está establecido y almenos uno de los iteradores adjuntados no es válido. O lanza una IllegalValueException si la clave es null y se establece MIT_KEYS_ASSOC.

Ver también

  • MultipleIterator::valid() - Comprueba la validez de los subiteradores


Desasocia un iterador

  • « MultipleIterator::current
  • MultipleIterator::getFlags »
  • PHP Manual
  • MultipleIterator
  • Desasocia un iterador

MultipleIterator::detachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::detachIterator — Desasocia un iterador

Descripción

public MultipleIterator::detachIterator ( Iterator $iterator ) : void

Desasocia un iterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El iterador a ser desasociado.

Valores devueltos

No devuelve ningún valor.

Ver también

  • MultipleIterator::attachIterator() - Adjunta información al iterador


Obtiene información de las flags

  • « MultipleIterator::detachIterator
  • MultipleIterator::key »
  • PHP Manual
  • MultipleIterator
  • Obtiene información de las flags

MultipleIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::getFlags — Obtiene información de las flags

Descripción

public MultipleIterator::getFlags ( ) : int

Obtiene información acerca de las flags.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Información acerca de las flags, como un integer.

Ver también

  • Constantes Flag
  • MultipleIterator::__construct() - Construye un nuevo MultipleIterator
  • MultipleIterator::setFlags() - Establece las flags


Obtiene las instancias registradas del iterador

  • « MultipleIterator::getFlags
  • MultipleIterator::next »
  • PHP Manual
  • MultipleIterator
  • Obtiene las instancias registradas del iterador

MultipleIterator::key

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::key — Obtiene las instancias registradas del iterador

Descripción

public MultipleIterator::key ( ) : array

Obtiene las instancias registradas del iterador del resultado key().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con todas las instancias registradas del iterador, o false si ninguna instancia ha sido adjuntada.

Errores/Excepciones

Lanza una LogicException si se establece el modo MIT_NEED_ALL, y al menos un iterador adjuntado no es válido.

Invocar este método desde foreach provoca un mensaje de advertencia "Illegal type returned" (devuelto tipo no válido).

Ver también

  • MultipleIterator::current() - Obtiene las instancias registradas del iterador


Mueve todas las instancias de iterador adjuntadas hacía la siguiente

  • « MultipleIterator::key
  • MultipleIterator::rewind »
  • PHP Manual
  • MultipleIterator
  • Mueve todas las instancias de iterador adjuntadas hacía la siguiente

MultipleIterator::next

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::next — Mueve todas las instancias de iterador adjuntadas hacía la siguiente

Descripción

public MultipleIterator::next ( ) : void

Mueve todas las instancias de iterador adjuntadas hacía la siguiente.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • MultipleIterator::rewind() - Rebobina todas las instancias de iterador adjuntadas


Rebobina todas las instancias de iterador adjuntadas

  • « MultipleIterator::next
  • MultipleIterator::setFlags »
  • PHP Manual
  • MultipleIterator
  • Rebobina todas las instancias de iterador adjuntadas

MultipleIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::rewind — Rebobina todas las instancias de iterador adjuntadas

Descripción

public MultipleIterator::rewind ( ) : void

Rebobina todas las instancias de iterador adjuntadas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • MultipleIterator::next() - Mueve todas las instancias de iterador adjuntadas hacía la siguiente


Establece las flags

  • « MultipleIterator::rewind
  • MultipleIterator::valid »
  • PHP Manual
  • MultipleIterator
  • Establece las flags

MultipleIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::setFlags — Establece las flags

Descripción

public MultipleIterator::setFlags ( int $flags ) : void

Establece las flags.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

flags

Las flags a ser establecidas, de acuerdo a las Constantes Flag

Valores devueltos

No devuelve ningún valor.

Ver también

  • Constantes Flag
  • MultipleIterator::__construct() - Construye un nuevo MultipleIterator
  • MultipleIterator::getFlags() - Obtiene información de las flags


Comprueba la validez de los subiteradores

  • « MultipleIterator::setFlags
  • NoRewindIterator »
  • PHP Manual
  • MultipleIterator
  • Comprueba la validez de los subiteradores

MultipleIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::valid — Comprueba la validez de los subiteradores

Descripción

public MultipleIterator::valid ( ) : bool

Comprueba la validez de los subiteradores.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si uno o todos los subiteradores son válidos dependiendo de las flags, o false en caso contrario.

Ver también

  • MultipleIterator::__construct() - Construye un nuevo MultipleIterator


La clase NoRewindIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Este iterador no puede ser rebobinado.

Sinopsis de la Clase

NoRewindIterator extends IteratorIterator {
/* Métodos */
public __construct ( Iterator $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : iterator
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* Métodos heredados */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Tabla de contenidos

  • NoRewindIterator::__construct — Construye un NoRewindIterator
  • NoRewindIterator::current — Obtener el valor actual
  • NoRewindIterator::getInnerIterator — Obtiene el iterador interno
  • NoRewindIterator::key — Obtiene la clave actual
  • NoRewindIterator::next — Avanza al siguiente elemento
  • NoRewindIterator::rewind — Evita la operación de rebobinado en el iterador interno
  • NoRewindIterator::valid — Valida el iterador


Construye un NoRewindIterator

  • « NoRewindIterator
  • NoRewindIterator::current »
  • PHP Manual
  • NoRewindIterator
  • Construye un NoRewindIterator

NoRewindIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::__construct — Construye un NoRewindIterator

Descripción

public NoRewindIterator::__construct ( Iterator $iterator )

Construye un NoRewindIterator.

Parámetros

iterator

El iterador a ser usado.

Valores devueltos

Un NoRewindIterator() basado en el iterator pasado.

Ejemplos

Ejemplo #1 Ejemplo de NoRewindIterator::__construct()

El segundo bucle no imprime nada porque el iterador solo puede usarse una vez, no se puede rebobinar.

<?php
$fruit = array('manzana', 'banano', 'arándano');

$arr = new ArrayObject($fruit);
$it  = new NoRewindIterator($arr->getIterator());

echo "Fruit A:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}

echo "Fruit B:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Fruit A:
manzana
banano
arándano
Fruit B:

Ver también

  • NoRewindIterator::valid() - Valida el iterador


Obtener el valor actual

  • « NoRewindIterator::__construct
  • NoRewindIterator::getInnerIterator »
  • PHP Manual
  • NoRewindIterator
  • Obtener el valor actual

NoRewindIterator::current

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::current — Obtener el valor actual

Descripción

public NoRewindIterator::current ( ) : mixed

Obtiene el valor actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor actual.

Ver también

  • NoRewindIterator::key() - Obtiene la clave actual


Obtiene el iterador interno

  • « NoRewindIterator::current
  • NoRewindIterator::key »
  • PHP Manual
  • NoRewindIterator
  • Obtiene el iterador interno

NoRewindIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::getInnerIterator — Obtiene el iterador interno

Descripción

public NoRewindIterator::getInnerIterator ( ) : iterator

Obtiene el iterador interno, que fué pasado a NoRewindIterator.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno, como fué pasado a NoRewindIterator::__construct().

Ver también

  • NoRewindIterator::valid() - Valida el iterador


Obtiene la clave actual

  • « NoRewindIterator::getInnerIterator
  • NoRewindIterator::next »
  • PHP Manual
  • NoRewindIterator
  • Obtiene la clave actual

NoRewindIterator::key

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::key — Obtiene la clave actual

Descripción

public NoRewindIterator::key ( ) : mixed

Obtener la clave actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave actual.

Ver también

  • NoRewindIterator::next() - Avanza al siguiente elemento


Avanza al siguiente elemento

  • « NoRewindIterator::key
  • NoRewindIterator::rewind »
  • PHP Manual
  • NoRewindIterator
  • Avanza al siguiente elemento

NoRewindIterator::next

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::next — Avanza al siguiente elemento

Descripción

public NoRewindIterator::next ( ) : void

Avanzar al siguiente elemento.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • NoRewindIterator::rewind() - Evita la operación de rebobinado en el iterador interno


Evita la operación de rebobinado en el iterador interno

  • « NoRewindIterator::next
  • NoRewindIterator::valid »
  • PHP Manual
  • NoRewindIterator
  • Evita la operación de rebobinado en el iterador interno

NoRewindIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::rewind — Evita la operación de rebobinado en el iterador interno

Descripción

public NoRewindIterator::rewind ( ) : void

Evita la operación de rebobinado en el iterador interno.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de NoRewindIterator::rewind()

Este ejemplo demuestra que, si se llama a rewind en un objeto NoRewindIterator no tiene ningún efecto.

<?php
$fruits = array("limon", "naranja", "manzana", "pera");

$noRewindIterator = new NoRewindIterator(new ArrayIterator($fruits));

echo $noRewindIterator->current() . "\n";
$noRewindIterator->next();
// ahora rebobine el iterador (nada debería suceder)
$noRewindIterator->rewind();
echo $noRewindIterator->current() . "\n";
?>

El resultado del ejemplo sería:

limon
naranja


Valida el iterador

  • « NoRewindIterator::rewind
  • ParentIterator »
  • PHP Manual
  • NoRewindIterator
  • Valida el iterador

NoRewindIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::valid — Valida el iterador

Descripción

public NoRewindIterator::valid ( ) : bool

Comprueba si el iterador es válido.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • NoRewindIterator::getInnerIterator() - Obtiene el iterador interno


La clase ParentIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Esta FilterIterator ampliada permite una iteración recursiva usando RecursiveIteratorIterator, que solamente muestra los elementos que tienen hijos.

Sinopsis de la Clase

ParentIterator extends RecursiveFilterIterator implements RecursiveIterator , OuterIterator {
/* Métodos */
public accept ( ) : bool
public __construct ( RecursiveIterator $iterator )
public getChildren ( ) : ParentIterator
public hasChildren ( ) : bool
public next ( ) : void
public rewind ( ) : void
/* Métodos heredados */
public OuterIterator::getInnerIterator ( ) : Iterator
}

Tabla de contenidos

  • ParentIterator::accept — Determina aceptabilidad
  • ParentIterator::__construct — Construye un ParentIterator
  • ParentIterator::getChildren — Devuelve los iteradores hijo contenidos en un ParentIterator
  • ParentIterator::hasChildren — Comprueba si los iteradores internos del elemento actual tiene un hijos
  • ParentIterator::next — Mueve el iterador a la siguiente posición
  • ParentIterator::rewind — Rebobina el iterador


Determina aceptabilidad

  • « ParentIterator
  • ParentIterator::__construct »
  • PHP Manual
  • ParentIterator
  • Determina aceptabilidad

ParentIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::accept — Determina aceptabilidad

Descripción

public ParentIterator::accept ( ) : bool

Determina si el elemento actual tiene un hijo.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el elemento actual es aceptable, en caso contrario false.

Ver también

  • ParentIterator::hasChildren() - Comprueba si los iteradores internos del elemento actual tiene un hijos
  • FilterIterator::accept() - Comprueba si el elemento actual del iterador es aceptable


Construye un ParentIterator

  • « ParentIterator::accept
  • ParentIterator::getChildren »
  • PHP Manual
  • ParentIterator
  • Construye un ParentIterator

ParentIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::__construct — Construye un ParentIterator

Descripción

public ParentIterator::__construct ( RecursiveIterator $iterator )

Construye un ParentIterator en un iterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El iterador a ser construido.

Valores devueltos

El ParentIterator.


Devuelve los iteradores hijo contenidos en un ParentIterator

  • « ParentIterator::__construct
  • ParentIterator::hasChildren »
  • PHP Manual
  • ParentIterator
  • Devuelve los iteradores hijo contenidos en un ParentIterator

ParentIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::getChildren — Devuelve los iteradores hijo contenidos en un ParentIterator

Descripción

public ParentIterator::getChildren ( ) : ParentIterator

Obtiene los iteradores hijo contenidos en un ParentIterator.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un object.


Comprueba si los iteradores internos del elemento actual tiene un hijos

  • « ParentIterator::getChildren
  • ParentIterator::next »
  • PHP Manual
  • ParentIterator
  • Comprueba si los iteradores internos del elemento actual tiene un hijos

ParentIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::hasChildren — Comprueba si los iteradores internos del elemento actual tiene un hijos

Descripción

public ParentIterator::hasChildren ( ) : bool

Comprueba si los iteradores internos del elemento actual tiene un hijos.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Mueve el iterador a la siguiente posición

  • « ParentIterator::hasChildren
  • ParentIterator::rewind »
  • PHP Manual
  • ParentIterator
  • Mueve el iterador a la siguiente posición

ParentIterator::next

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::next — Mueve el iterador a la siguiente posición

Descripción

public ParentIterator::next ( ) : void

Mueve el iterador a la siguiente posición.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador

  • « ParentIterator::next
  • RecursiveArrayIterator »
  • PHP Manual
  • ParentIterator
  • Rebobina el iterador

ParentIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::rewind — Rebobina el iterador

Descripción

public ParentIterator::rewind ( ) : void

Rebobinar el iterador.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


La clase RecursiveArrayIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Este iterador permite destruir y modificar valores y claves mientras se iteran arrays y objetos de la misma manera que con ArrayIterator. Adicionalmente es posible iterar la entrada del iterador actual.

Sinopsis de la Clase

RecursiveArrayIterator extends ArrayIterator implements RecursiveIterator {
/* Constantaes heredadas constants */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* Constantes */
const integer CHILD_ARRAYS_ONLY = 4 ;
/* Métodos */
public getChildren ( ) : RecursiveArrayIterator
public hasChildren ( ) : bool
/* Inherits */
public ArrayIterator::append ( mixed $value ) : void
public ArrayIterator::asort ( ) : void
public ArrayIterator::__construct ( mixed $array = array() , int $flags = 0 )
public ArrayIterator::count ( ) : int
public ArrayIterator::current ( ) : mixed
public ArrayIterator::getArrayCopy ( ) : array
public ArrayIterator::getFlags ( ) : void
public ArrayIterator::key ( ) : mixed
public ArrayIterator::ksort ( ) : void
public ArrayIterator::natcasesort ( ) : void
public ArrayIterator::natsort ( ) : void
public ArrayIterator::next ( ) : void
public ArrayIterator::offsetExists ( mixed $index ) : bool
public ArrayIterator::offsetGet ( mixed $index ) : mixed
public ArrayIterator::offsetSet ( mixed $index , mixed $newval ) : void
public ArrayIterator::offsetUnset ( mixed $index ) : void
public ArrayIterator::rewind ( ) : void
public ArrayIterator::seek ( int $position ) : void
public ArrayIterator::serialize ( ) : string
public ArrayIterator::setFlags ( string $flags ) : void
public ArrayIterator::uasort ( string $cmp_function ) : void
public ArrayIterator::uksort ( string $cmp_function ) : void
public ArrayIterator::unserialize ( string $serialized ) : string
public ArrayIterator::valid ( ) : bool
}

Constantes predefinidas

RecursiveArrayIterator Flags

RecursiveArrayIterator::CHILD_ARRAYS_ONLY

Trata sólo los array (no objetos) como si tuvieran hijos para la itaración recursiva.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió la flag CHILD_ARRAYS_ONLY.

Tabla de contenidos

  • RecursiveArrayIterator::getChildren — Devuelve un iterador para la entrada actual si este es un array o un object
  • RecursiveArrayIterator::hasChildren — Devuelve si la entrada actual es un array o un objeto


Devuelve un iterador para la entrada actual si este es un array o un object

  • « RecursiveArrayIterator
  • RecursiveArrayIterator::hasChildren »
  • PHP Manual
  • RecursiveArrayIterator
  • Devuelve un iterador para la entrada actual si este es un array o un object

RecursiveArrayIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::getChildren — Devuelve un iterador para la entrada actual si este es un array o un object

Descripción

public RecursiveArrayIterator::getChildren ( ) : RecursiveArrayIterator

Devuelve un iterador interno para la entrada actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un iterador para la entrada actual, si este es un array o un object.

Errores/Excepciones

Lanza una InvalidArgumentException si la entrada actual no contiene un array o un object.

Ejemplos

Ejemplo #1 Ejemplo de RecursiveArrayIterator::getChildren()

<?php
$fruits = array("a" => "limon", "b" => "naranja", array("a" => "manzana", "p" => "pera"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    if ($iterator->hasChildren()) {
        // imprimir todos los hijos
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No hijos.\n";
    }

    $iterator->next();
}
?>

El resultado del ejemplo sería:

No hijos.
No hijos.
a : manzana
p : pera

Ver también

  • RecursiveArrayIterator::hasChildren() - Devuelve si la entrada actual es un array o un objeto


Devuelve si la entrada actual es un array o un objeto

  • « RecursiveArrayIterator::getChildren
  • RecursiveCachingIterator »
  • PHP Manual
  • RecursiveArrayIterator
  • Devuelve si la entrada actual es un array o un objeto

RecursiveArrayIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::hasChildren — Devuelve si la entrada actual es un array o un objeto

Descripción

public RecursiveArrayIterator::hasChildren ( ) : bool

Devuelve si la entrada actual es un array o un object para que un iterador puede ser obtenido a través de RecursiveArrayIterator::getChildren().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada actual es un array o un object, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de RecursiveArrayIterator::hasChildren()

<?php
$fruits = array("a" => "limon", "b" => "naranja", array("a" => "manzana", "p" => "pera"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    // Comprueba si hay hijos
    if ($iterator->hasChildren()) {
        // imprime todos los hijos
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No hijos.\n";
    }

    $iterator->next();
}
?>

El resultado del ejemplo sería:

No hijos.
No hijos.
a : manzana
p : pera

Ver también

  • RecursiveArrayIterator::getChildren() - Devuelve un iterador para la entrada actual si este es un array o un object


La clase RecursiveCachingIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

...

Sinopsis de la Clase

RecursiveCachingIterator extends CachingIterator implements Countable , ArrayAccess , OuterIterator , RecursiveIterator {
/* Constantaes heredadas constants */
const integer CachingIterator::CALL_TOSTRING = 1 ;
const integer CachingIterator::CATCH_GET_CHILD = 16 ;
const integer CachingIterator::TOSTRING_USE_KEY = 2 ;
const integer CachingIterator::TOSTRING_USE_CURRENT = 4 ;
const integer CachingIterator::TOSTRING_USE_INNER = 8 ;
const integer CachingIterator::FULL_CACHE = 256 ;
/* Métodos */
public __construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public getChildren ( ) : RecursiveCachingIterator
public hasChildren ( ) : bool
/* Inherits */
public CachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public CachingIterator::count ( ) : int
public CachingIterator::current ( ) : void
public CachingIterator::getCache ( ) : array
public CachingIterator::getFlags ( ) : int
public CachingIterator::getInnerIterator ( ) : Iterator
public CachingIterator::hasNext ( ) : void
public CachingIterator::key ( ) : scalar
public CachingIterator::next ( ) : void
public CachingIterator::offsetExists ( mixed $index ) : void
public CachingIterator::offsetGet ( string $index ) : void
public CachingIterator::offsetSet ( mixed $index , mixed $newval ) : void
public CachingIterator::offsetUnset ( string $index ) : void
public CachingIterator::rewind ( ) : void
public CachingIterator::setFlags ( int $flags ) : void
public CachingIterator::__toString ( ) : void
public CachingIterator::valid ( ) : void
}

Tabla de contenidos

  • RecursiveCachingIterator::__construct — Construct
  • RecursiveCachingIterator::getChildren — Devuelve los iteradores internos hijos como un RecursiveCachingIterator
  • RecursiveCachingIterator::hasChildren — Comprueba si el elemento actual de un iterador interno tiene hijos


Construct

  • « RecursiveCachingIterator
  • RecursiveCachingIterator::getChildren »
  • PHP Manual
  • RecursiveCachingIterator
  • Construct

RecursiveCachingIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::__construct — Construct

Descripción

public RecursiveCachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )

Construye un nuevo RecursiveCachingIterator, que consiste en pasar un iterator.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

iterator

El iterador a ser usado.

flags

Las flags. Use CALL_TOSTRING para llamar a RecursiveCachingIterator::__toString() para cada elemento (por omisión), y/o CATCH_GET_CHILD para capturar excepciones cuando se intenta obtener un hijo.

Valores devueltos

La clase RecursiveCachingIterator.

Ver también

  • CachingIterator::__construct() - Construir un nuevo objeto CachingIterator para el iterador


Devuelve los iteradores internos hijos como un RecursiveCachingIterator

  • « RecursiveCachingIterator::__construct
  • RecursiveCachingIterator::hasChildren »
  • PHP Manual
  • RecursiveCachingIterator
  • Devuelve los iteradores internos hijos como un RecursiveCachingIterator

RecursiveCachingIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::getChildren — Devuelve los iteradores internos hijos como un RecursiveCachingIterator

Descripción

public RecursiveCachingIterator::getChildren ( ) : RecursiveCachingIterator
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los iteradores internos hijos, como un RecursiveCachingIterator.


Comprueba si el elemento actual de un iterador interno tiene hijos

  • « RecursiveCachingIterator::getChildren
  • RecursiveCallbackFilterIterator »
  • PHP Manual
  • RecursiveCachingIterator
  • Comprueba si el elemento actual de un iterador interno tiene hijos

RecursiveCachingIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::hasChildren — Comprueba si el elemento actual de un iterador interno tiene hijos

Descripción

public RecursiveCachingIterator::hasChildren ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el iterador interno tiene hijos, en caso contrario false


La clase RecursiveCallbackFilterIterator

(PHP 5 >= 5.4.0, PHP 7)

Introducción

Sinopsis de la Clase

RecursiveCallbackFilterIterator extends CallbackFilterIterator implements OuterIterator , RecursiveIterator {
/* Métodos */
public __construct ( RecursiveIterator $iterator , string $callback )
public getChildren ( ) : RecursiveCallbackFilterIterator
public hasChildren ( ) : bool
/* Métodos heredados */
public CallbackFilterIterator::accept ( ) : bool
}

Ejemplos

La llamada de retorno debería aceptar hasta tres argumentos: el elemento actual, la clave actual y el iterador, respectivamente.

Ejemplo #1 Argumentos disponibles de la llamada de retorno

<?php

/**
 * Llamada de retorno para RecursiveCallbackFilterIterator
 *
 * @param $current   El valor del elemento actual
 * @param $key       La clave del elemento actual
 * @param $iterator  El iterador a filtrar
 * @return boolean   TRUE si acepta el elemento actual, de lo contrario FALSE
 */
function my_callback($current, $key, $iterator) {
    // Aquí, el código de filtrado
}

?>

Filtrar un iterador recursivo generalmente conlleva dos condiciones. La primera es que, con el fin de permitir la recursividad, la función de llamada de retorno debería devolver true si el iterador actual tiene hijos. La segunda es la condición normal de filtro, como el tamaño de fichero o la comprobación de la extensión como en el ejemplo de abajo.

Ejemplo #2 Ejemplo básico de llamada de retorno recursiva

<?php

$dir = new FilesystemIterator(__DIR__);

// Filtrar ficheros de gran tamaño ( > 100MB)
$ficheros = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Permitir recursividad
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Buscar ficheros de gran tamaño
    if ($current->isFile() && $current->getSize() > 104857600) {
        return TRUE;
    }
    return FALSE;
});

foreach (new RecursiveIteratorIterator($ficheros) as $fichero) {
    echo $fichero->getPathname() . PHP_EOL;
}

?>

Tabla de contenidos

  • RecursiveCallbackFilterIterator::__construct — Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator
  • RecursiveCallbackFilterIterator::getChildren — D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::hasChildren — Comprueba si los iteradores internos del elemento actual tiene hijos


Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator

  • « RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::getChildren »
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator

RecursiveCallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::__construct — Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator

Descripción

public RecursiveCallbackFilterIterator::__construct ( RecursiveIterator $iterator , string $callback )

Crea un iterador filtrado desde un RecursiveIterator usando el parámetro callback para determinar si los elementos son aceptados o rechazados.

Parámetros

iterator

El iterador recursivo a ser filtrado.

callback

la llamada de retorno, debe retornar true para aceptar el elemento actual o en caso contrario false. Véase los Ejemplos.

Puede ser cualquier valor válido de callable.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Ejemplos de RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::getChildren() - D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Comprueba si los iteradores internos del elemento actual tiene hijos


D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator

  • « RecursiveCallbackFilterIterator::__construct
  • RecursiveCallbackFilterIterator::hasChildren »
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator

RecursiveCallbackFilterIterator::getChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::getChildren — D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator

Descripción

public RecursiveCallbackFilterIterator::getChildren ( ) : RecursiveCallbackFilterIterator

Recupera los hijos filtrados de el iterador interno.

RecursiveCallbackFilterIterator::hasChildren() debe ser usado para determinar si hay hijos para ser recuperados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un RecursiveCallbackFilterIterator que contiene a los hijos.

Ver también

  • Ejemplos de RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::__construct() - Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Comprueba si los iteradores internos del elemento actual tiene hijos


Comprueba si los iteradores internos del elemento actual tiene hijos

  • « RecursiveCallbackFilterIterator::getChildren
  • RecursiveDirectoryIterator »
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • Comprueba si los iteradores internos del elemento actual tiene hijos

RecursiveCallbackFilterIterator::hasChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::hasChildren — Comprueba si los iteradores internos del elemento actual tiene hijos

Descripción

public RecursiveCallbackFilterIterator::hasChildren ( ) : bool

Devuelve true si el elemento actual tiene hijos, o false en caso contrario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Retorna true si el elemento actual tiene hijos, o false en caso contrario.

Ejemplos

Ejemplo #1 Uso básico de RecursiveCallbackFilterIterator::hasChildren()

<?php

$dir = new RecursiveDirectoryIterator(__DIR__);

// Iteracicón recursiva de todos los ficheros XML
$files = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Permite la recursividad en los directorios
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Comprueba si es un fichero XML
    if (!strcasecmp($current->getExtension(), 'xml')) {
        return TRUE;
    }
    return FALSE;
});

?>

Ver también

  • Ejemplos de RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::__construct() - Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator
  • RecursiveCallbackFilteriterator::getChildren() - D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator


La clase RecursiveDirectoryIterator

(PHP 5, PHP 7)

Introducción

La clase RecursiveDirectoryIterator proporciona una interfaz para iterar recursivamente directorios del sistema de ficheros.

Sinopsis de la Clase

RecursiveDirectoryIterator extends FilesystemIterator implements SeekableIterator , RecursiveIterator {
/* Constantaes heredadas constants */
const integer FilesystemIterator::CURRENT_AS_PATHNAME = 32 ;
const integer FilesystemIterator::CURRENT_AS_FILEINFO = 0 ;
const integer FilesystemIterator::CURRENT_AS_SELF = 16 ;
const integer FilesystemIterator::CURRENT_MODE_MASK = 240 ;
const integer FilesystemIterator::KEY_AS_PATHNAME = 0 ;
const integer FilesystemIterator::KEY_AS_FILENAME = 256 ;
const integer FilesystemIterator::FOLLOW_SYMLINKS = 512 ;
const integer FilesystemIterator::KEY_MODE_MASK = 3840 ;
const integer FilesystemIterator::NEW_CURRENT_AND_KEY = 256 ;
const integer FilesystemIterator::SKIP_DOTS = 4096 ;
const integer FilesystemIterator::UNIX_PATHS = 8192 ;
/* Métodos */
public __construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )
public getChildren ( ) : mixed
public getSubPath ( ) : string
public getSubPathname ( ) : string
public hasChildren ( bool $allow_links = false ) : bool
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
/* Métodos heredados */
public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public FilesystemIterator::current ( ) : mixed
public FilesystemIterator::getFlags ( ) : int
public FilesystemIterator::key ( ) : string
public FilesystemIterator::next ( ) : void
public FilesystemIterator::rewind ( ) : void
public FilesystemIterator::setFlags ( int $flags = ? ) : void
}

Historial de cambios

Versión | Descripción
5.3.0 | La clase FilesystemIterator fue introducida como una clase padre. Anteriormente, el padre era la clase DirectoryIterator.
5.3.0 | Se implementó SeekableIterator.
5.2.11, 5.3.1 | Agregado RecursiveDirectoryIterator::FOLLOW_SYMLINKS

Tabla de contenidos

  • RecursiveDirectoryIterator::__construct — Construye un RecursiveDirectoryIterator
  • RecursiveDirectoryIterator::getChildren — Devuelve un iterador de la entrada actual si se trata de un directorio
  • RecursiveDirectoryIterator::getSubPath — Obtiene sub ruta
  • RecursiveDirectoryIterator::getSubPathname — Obtiene la sub ruta y nombre
  • RecursiveDirectoryIterator::hasChildren — Devuelve si la entrada actual es un directorio y no '.' o '..'
  • RecursiveDirectoryIterator::key — Devuelve la ruta y nombre de fichero del directorio
  • RecursiveDirectoryIterator::next — Mover a la siguiente entrada
  • RecursiveDirectoryIterator::rewind — Rebobina el directorio hasta el inicio


Construye un RecursiveDirectoryIterator

  • « RecursiveDirectoryIterator
  • RecursiveDirectoryIterator::getChildren »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Construye un RecursiveDirectoryIterator

RecursiveDirectoryIterator::__construct

(PHP 5 >= 5.1.2, PHP 7)

RecursiveDirectoryIterator::__construct — Construye un RecursiveDirectoryIterator

Descripción

public RecursiveDirectoryIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )

Construye un RecursiveDirectoryIterator() para el path proporcionado.

Parámetros

path

La ruta de el directorio a ser iterado.

flags

Se pueden proporcionar flags para afectar el comportamiento de algunos métodos. Una lista de flags puede encontrarse en Constantes predefinidas FilesystemIterator. También se pueden establecer más tarde con FilesystemIterator::setFlags().

Valores devueltos

Devuelve el RecursiveDirectoryIterator recién creado.

Errores/Excepciones

Lanza una UnexpectedValueException si el path no puede ser encontrado o este no es un directorio.

Ejemplos

Ejemplo #1 Ejemplo de RecursiveDirectoryIterator

<?php

$directorio = '/tmp';

$it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directorio));

$it->rewind();
while($it->valid()) {

    if (!$it->isDot()) {
        echo 'SubPathName: ' . $it->getSubPathName() . "\n";
        echo 'SubPath:     ' . $it->getSubPath() . "\n";
        echo 'Key:         ' . $it->key() . "\n\n";
    }

    $it->next();
}

?>

El resultado del ejemplo sería algo similar a:

SubPathName: fruta/manzana.xml
SubPath:     fruta
Key:         /tmp/fruta/manzana.xml

SubPathName: stuff.xml
SubPath:
Key:         /tmp/stuff.xml

SubPathName: vegetales/zanahoria.xml
SubPath:     vegetales
Key:         /tmp/vegetales/zanahoria.xml

Ver también

  • FilesystemIterator::__construct() - Construye un nuevo iterador filesystem
  • RecursiveIteratorIterator::__construct() - Construir un objeto RecursiveIteratorIterator
  • Constantes predefinidas FilesystemIterator


Devuelve un iterador de la entrada actual si se trata de un directorio

  • « RecursiveDirectoryIterator::__construct
  • RecursiveDirectoryIterator::getSubPath »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Devuelve un iterador de la entrada actual si se trata de un directorio

RecursiveDirectoryIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getChildren — Devuelve un iterador de la entrada actual si se trata de un directorio

Descripción

public RecursiveDirectoryIterator::getChildren ( ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre de fichero, información de fichero o $this dependiendo de las banderas establecidas. Véase las constantes FilesystemIterator.


Obtiene sub ruta

  • « RecursiveDirectoryIterator::getChildren
  • RecursiveDirectoryIterator::getSubPathname »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Obtiene sub ruta

RecursiveDirectoryIterator::getSubPath

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPath — Obtiene sub ruta

Descripción

public RecursiveDirectoryIterator::getSubPath ( ) : string

Devuelve el sub ruta relativo al directorio dado en el constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La sub ruta.

Ejemplos

Ejemplo #1 Ejemplo de getSubPath()

$directory = '/tmp';

      $it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

      foreach ($it as $file) {
          echo 'SubPathName: ' . $it->getSubPathName() . "\n";
          echo 'SubPath:     ' . $it->getSubPath() . "\n\n";
      }

El resultado del ejemplo sería algo similar a:

     SubPathName: fruit/apple.xml
     SubPath:     fruit

     SubPathName: stuff.xml
     SubPath:

     SubPathName: veggies/carrot.xml
     SubPath:     veggies

Ver también

  • RecursiveDirectoryIterator::getSubPathName() - Obtiene la sub ruta y nombre
  • RecursiveDirectoryIterator::key() - Devuelve la ruta y nombre de fichero del directorio


Obtiene la sub ruta y nombre

  • « RecursiveDirectoryIterator::getSubPath
  • RecursiveDirectoryIterator::hasChildren »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Obtiene la sub ruta y nombre

RecursiveDirectoryIterator::getSubPathname

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPathname — Obtiene la sub ruta y nombre

Descripción

public RecursiveDirectoryIterator::getSubPathname ( ) : string

Obtiene la sub ruta y nombre del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La sub ruta (sub directorio) y nombre del fichero.

Ejemplos

Ejemplo #1 Ejemplo de getSubPathname()

$directory = '/tmp';

      $it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

      foreach ($it as $file) {
          echo 'SubPathName: ' . $it->getSubPathName() . "\n";
          echo 'SubPath:     ' . $it->getSubPath() . "\n\n";
      }

El resultado del ejemplo sería algo similar a:

     SubPathName: fruit/apple.xml
     SubPath:     fruit

     SubPathName: stuff.xml
     SubPath:

     SubPathName: veggies/carrot.xml
     SubPath:     veggies

Ver también

  • RecursiveDirectoryIterator::getSubPath() - Obtiene sub ruta
  • RecursiveDirectoryIterator::key() - Devuelve la ruta y nombre de fichero del directorio


Devuelve si la entrada actual es un directorio y no '.' o '..'

  • « RecursiveDirectoryIterator::getSubPathname
  • RecursiveDirectoryIterator::key »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Devuelve si la entrada actual es un directorio y no '.' o '..'

RecursiveDirectoryIterator::hasChildren

(PHP 5, PHP 7)

RecursiveDirectoryIterator::hasChildren — Devuelve si la entrada actual es un directorio y no '.' o '..'

Descripción

public RecursiveDirectoryIterator::hasChildren ( bool $allow_links = false ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

allow_links

Valores devueltos

Devuelve si la entrada actual es un directorio y no '.' o '..'


Devuelve la ruta y nombre de fichero del directorio

  • « RecursiveDirectoryIterator::hasChildren
  • RecursiveDirectoryIterator::next »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Devuelve la ruta y nombre de fichero del directorio

RecursiveDirectoryIterator::key

(PHP 5, PHP 7)

RecursiveDirectoryIterator::key — Devuelve la ruta y nombre de fichero del directorio

Descripción

public RecursiveDirectoryIterator::key ( ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta y nombre de fichero del directorio.


Mover a la siguiente entrada

  • « RecursiveDirectoryIterator::key
  • RecursiveDirectoryIterator::rewind »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Mover a la siguiente entrada

RecursiveDirectoryIterator::next

(PHP 5, PHP 7)

RecursiveDirectoryIterator::next — Mover a la siguiente entrada

Descripción

public RecursiveDirectoryIterator::next ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el directorio hasta el inicio

  • « RecursiveDirectoryIterator::next
  • RecursiveFilterIterator »
  • PHP Manual
  • RecursiveDirectoryIterator
  • Rebobina el directorio hasta el inicio

RecursiveDirectoryIterator::rewind

(PHP 5, PHP 7)

RecursiveDirectoryIterator::rewind — Rebobina el directorio hasta el inicio

Descripción

public RecursiveDirectoryIterator::rewind ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


La clase RecursiveFilterIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Este iterador abstracto filtra valores no deseados de RecursiveIterator. Esta clase debería ampliarse para implementar filtros personalizados. El método RecursiveFilterIterator::accept() debe ser implementado en la subclase.

Sinopsis de la Clase

abstract RecursiveFilterIterator extends FilterIterator implements OuterIterator , RecursiveIterator {
/* Métodos */
public __construct ( RecursiveIterator $iterator )
public getChildren ( ) : RecursiveFilterIterator
public hasChildren ( ) : bool
/* Métodos heredados */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

Tabla de contenidos

  • RecursiveFilterIterator::__construct — Crear un RecursiveFilterIterator a partir de un RecursiveIterator
  • RecursiveFilterIterator::getChildren — Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren — Comprueba si el elemento actual del iterador interno tiene hijos


Crear un RecursiveFilterIterator a partir de un RecursiveIterator

  • « RecursiveFilterIterator
  • RecursiveFilterIterator::getChildren »
  • PHP Manual
  • RecursiveFilterIterator
  • Crear un RecursiveFilterIterator a partir de un RecursiveIterator

RecursiveFilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::__construct — Crear un RecursiveFilterIterator a partir de un RecursiveIterator

Descripción

public RecursiveFilterIterator::__construct ( RecursiveIterator $iterator )

Crea un RecursiveFilterIterator a partir de un RecursiveIterator.

Parámetros

iterator

El RecursiveIterator a ser filtrado.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo básico de RecursiveFilterIterator()

<?php
class TestsOnlyFilter extends RecursiveFilterIterator {
    public function accept() {
        // Aceptar el elemento actual si podemos utilizar la recursión en este
        // o este valor empieza con "test"
        return $this->hasChildren() || (strpos($this->current(), "test") !== FALSE);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new TestsOnlyFilter($iterator);

foreach(new RecursiveIteratorIterator($filter) as $key => $value)
{
    echo $value . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

test1
test3
test4
test5

Ejemplo #2 Ejemplo de RecursiveFilterIterator()

<?php
class ComenzarConElFiltro extends RecursiveFilterIterator {

    protected $word;

    public function __construct(RecursiveIterator $rit, $word) {
        $this->word = $word;
        parent::__construct($rit);
    }

    public function accept() {
        return $this->hasChildren() OR strpos($this->current(), $this->word) === 0;
    }

    public function getChildren() {
        return new self($this->getInnerIterator()->getChildren(), $this->word);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new ComenzarConElFiltro($iterator, "test");

foreach(new RecursiveIteratorIterator($filter) as $clave => $valor)
{
    echo $valor . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

test1
test3
test4
test5

Ver también

  • RecursiveFilterIterator::getChildren() - Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren() - Comprueba si el elemento actual del iterador interno tiene hijos
  • FilterIterator::accept() - Comprueba si el elemento actual del iterador es aceptable


Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator

  • « RecursiveFilterIterator::__construct
  • RecursiveFilterIterator::hasChildren »
  • PHP Manual
  • RecursiveFilterIterator
  • Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator

RecursiveFilterIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::getChildren — Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator

Descripción

public RecursiveFilterIterator::getChildren ( ) : RecursiveFilterIterator

Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un RecursiveFilterIterator que conntiene los hijos del iterador interno.

Ver también

  • RecursiveFilterIterator::hasChildren() - Comprueba si el elemento actual del iterador interno tiene hijos
  • RecursiveIterator::getChildren() - Devuelve un iterador para la entrada actual


Comprueba si el elemento actual del iterador interno tiene hijos

  • « RecursiveFilterIterator::getChildren
  • RecursiveIteratorIterator »
  • PHP Manual
  • RecursiveFilterIterator
  • Comprueba si el elemento actual del iterador interno tiene hijos

RecursiveFilterIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::hasChildren — Comprueba si el elemento actual del iterador interno tiene hijos

Descripción

public RecursiveFilterIterator::hasChildren ( ) : bool

Comprueba si el elemento actual del iterador interno tiene hijos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el iterador interno tiene hijos, en caso contrario false

Ver también

  • RecursiveFilterIterator::getChildren() - Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator
  • RecursiveIterator::hasChildren() - Retorna si un iterador puede ser creado para la entrada actual


La clase RecursiveIteratorIterator

(PHP 5, PHP 7)

Introducción

Se puede usar para recorrer iteradores recursivos.

Sinopsis de la Clase

RecursiveIteratorIterator implements OuterIterator {
/* Constantes */
const integer LEAVES_ONLY = 0 ;
const integer SELF_FIRST = 1 ;
const integer CHILD_FIRST = 2 ;
const integer CATCH_GET_CHILD = 16 ;
/* Métodos */
public beginChildren ( ) : void
public beginIteration ( ) : void
public callGetChildren ( ) : RecursiveIterator
public callHasChildren ( ) : bool
public __construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )
public current ( ) : mixed
public endChildren ( ) : void
public endIteration ( ) : void
public getDepth ( ) : int
public getInnerIterator ( ) : iterator
public getMaxDepth ( ) : mixed
public getSubIterator ( int $level = ? ) : RecursiveIterator
public key ( ) : mixed
public next ( ) : void
public nextElement ( ) : void
public rewind ( ) : void
public setMaxDepth ( int $max_depth = -1 ) : void
public valid ( ) : bool
/* Métodos heredados */
public OuterIterator::getInnerIterator ( ) : Iterator
}

Constantes predefinidas

RecursiveIteratorIterator::LEAVES_ONLY

RecursiveIteratorIterator::SELF_FIRST

RecursiveIteratorIterator::CHILD_FIRST

RecursiveIteratorIterator::CATCH_GET_CHILD

Tabla de contenidos

  • RecursiveIteratorIterator::beginChildren — Inicio del hijo
  • RecursiveIteratorIterator::beginIteration — Inicio de la iteración
  • RecursiveIteratorIterator::callGetChildren — Obtener hijo
  • RecursiveIteratorIterator::callHasChildren — Comprueba si tiene hijos
  • RecursiveIteratorIterator::__construct — Construir un objeto RecursiveIteratorIterator
  • RecursiveIteratorIterator::current — Acceder al valor del elemento actual
  • RecursiveIteratorIterator::endChildren — Final de los hijos
  • RecursiveIteratorIterator::endIteration — Final de la iteración
  • RecursiveIteratorIterator::getDepth — Obtener la profundidad actual de la iteración recursiva
  • RecursiveIteratorIterator::getInnerIterator — Obtener el iterador interno
  • RecursiveIteratorIterator::getMaxDepth — Obtener el máximo de profundidad
  • RecursiveIteratorIterator::getSubIterator — El subiterador activo actual
  • RecursiveIteratorIterator::key — Acceder a la clave actual
  • RecursiveIteratorIterator::next — Moverse al siguiente elemento
  • RecursiveIteratorIterator::nextElement — Siguiente elemento
  • RecursiveIteratorIterator::rewind — Rebobina el iterador al primer elemento al nivel superior del iterador interno
  • RecursiveIteratorIterator::setMaxDepth — Establecer el máximo de profundidad
  • RecursiveIteratorIterator::valid — Comprueba si la posición actual es válida


Inicio del hijo

  • « RecursiveIteratorIterator
  • RecursiveIteratorIterator::beginIteration »
  • PHP Manual
  • RecursiveIteratorIterator
  • Inicio del hijo

RecursiveIteratorIterator::beginChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginChildren — Inicio del hijo

Descripción

public RecursiveIteratorIterator::beginChildren ( ) : void

Se llama después de llamar a RecursiveIteratorIterator::getChildren(), y está asociada con RecursiveIteratorIterator::rewind().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Inicio de la iteración

  • « RecursiveIteratorIterator::beginChildren
  • RecursiveIteratorIterator::callGetChildren »
  • PHP Manual
  • RecursiveIteratorIterator
  • Inicio de la iteración

RecursiveIteratorIterator::beginIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginIteration — Inicio de la iteración

Descripción

public RecursiveIteratorIterator::beginIteration ( ) : void

Se llama cuando la iteración comienza (después del primer RecursiveIteratorIterator::rewind().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Obtener hijo

  • « RecursiveIteratorIterator::beginIteration
  • RecursiveIteratorIterator::callHasChildren »
  • PHP Manual
  • RecursiveIteratorIterator
  • Obtener hijo

RecursiveIteratorIterator::callGetChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callGetChildren — Obtener hijo

Descripción

public RecursiveIteratorIterator::callGetChildren ( ) : RecursiveIterator

Obtiene el hijo de el elemento actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A RecursiveIterator().


Comprueba si tiene hijos

  • « RecursiveIteratorIterator::callGetChildren
  • RecursiveIteratorIterator::__construct »
  • PHP Manual
  • RecursiveIteratorIterator
  • Comprueba si tiene hijos

RecursiveIteratorIterator::callHasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callHasChildren — Comprueba si tiene hijos

Descripción

public RecursiveIteratorIterator::callHasChildren ( ) : bool

Llamado para cada elemento para comprobar si tiene hijos o no.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el elemento tiene hijos, en caso contrario false


Construir un objeto RecursiveIteratorIterator

  • « RecursiveIteratorIterator::callHasChildren
  • RecursiveIteratorIterator::current »
  • PHP Manual
  • RecursiveIteratorIterator
  • Construir un objeto RecursiveIteratorIterator

RecursiveIteratorIterator::__construct

(PHP 5 >= 5.1.3, PHP 7)

RecursiveIteratorIterator::__construct — Construir un objeto RecursiveIteratorIterator

Descripción

public RecursiveIteratorIterator::__construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )

Crea un objeto RecursiveIteratorIterator desde un objeto RecursiveIterator.

Parámetros

iterator

El iterador desde el que va a ser construido. Puede ser un objeto RecursiveIterator o IteratorAggregate.

mode

Modo opcional. Los valores posibles son

  • RecursiveIteratorIterator::LEAVES_ONLY - El predeterminado. Lista sólo las hojas en la iteración.
  • RecursiveIteratorIterator::SELF_FIRST - Lista las hojas y los padres en la iteración con los padres primero.
  • RecursiveIteratorIterator::CHILD_FIRST - Lista las hojas y los padres en la iteración con las hojas primero.

flags

Bandera opcional. Los valore posibles son RecursiveIteratorIterator::CATCH_GET_CHILD que ignorará las excepciones lanzadas en llamadas a RecursiveIteratorIterator::getChildren().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Iterar un RecursiveIteratorIterator

<?php
$array = array(
    array(
        array(
            array(
                'leaf-0-0-0-0',
                'leaf-0-0-0-1'
            ),
            'leaf-0-0-0'
        ),
        array(
            array(
                'leaf-0-1-0-0',
                'leaf-0-1-0-1'
            ),
            'leaf-0-1-0'
        ),
        'leaf-0-0'
    )
);

$iterator = new RecursiveIteratorIterator(
    new RecursiveArrayIterator($array),
    $mode
);
foreach ($iterator as $key => $leaf) {
    echo "$key => $leaf", PHP_EOL;
}
?>

Salida con $mode = RecursiveIteratorIterator::LEAVES_ONLY

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => leaf-0-0-0
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => leaf-0-1-0
0 => leaf-0-0

Salida con $mode = RecursiveIteratorIterator::SELF_FIRST

0 => Array
0 => Array
0 => Array
0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
1 => leaf-0-0-0
1 => Array
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
1 => leaf-0-1-0
2 => leaf-0-0

Salida con $mode = RecursiveIteratorIterator::CHILD_FIRST

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => Array
1 => leaf-0-0-0
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => Array
1 => leaf-0-1-0
1 => Array
2 => leaf-0-0
0 => Array


Acceder al valor del elemento actual

  • « RecursiveIteratorIterator::__construct
  • RecursiveIteratorIterator::endChildren »
  • PHP Manual
  • RecursiveIteratorIterator
  • Acceder al valor del elemento actual

RecursiveIteratorIterator::current

(PHP 5, PHP 7)

RecursiveIteratorIterator::current — Acceder al valor del elemento actual

Descripción

public RecursiveIteratorIterator::current ( ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor del elemento actual.


Final de los hijos

  • « RecursiveIteratorIterator::current
  • RecursiveIteratorIterator::endIteration »
  • PHP Manual
  • RecursiveIteratorIterator
  • Final de los hijos

RecursiveIteratorIterator::endChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endChildren — Final de los hijos

Descripción

public RecursiveIteratorIterator::endChildren ( ) : void

Llamado cuando recursivamente se llega al final de un nivel.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Final de la iteración

  • « RecursiveIteratorIterator::endChildren
  • RecursiveIteratorIterator::getDepth »
  • PHP Manual
  • RecursiveIteratorIterator
  • Final de la iteración

RecursiveIteratorIterator::endIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endIteration — Final de la iteración

Descripción

public RecursiveIteratorIterator::endIteration ( ) : void

Se llama cuando la iteración finaliza (cuando RecursiveIteratorIterator::valid() retorne false.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Obtener la profundidad actual de la iteración recursiva

  • « RecursiveIteratorIterator::endIteration
  • RecursiveIteratorIterator::getInnerIterator »
  • PHP Manual
  • RecursiveIteratorIterator
  • Obtener la profundidad actual de la iteración recursiva

RecursiveIteratorIterator::getDepth

(PHP 5, PHP 7)

RecursiveIteratorIterator::getDepth — Obtener la profundidad actual de la iteración recursiva

Descripción

public RecursiveIteratorIterator::getDepth ( ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La profundidad actual de la iteración recursiva.


Obtener el iterador interno

  • « RecursiveIteratorIterator::getDepth
  • RecursiveIteratorIterator::getMaxDepth »
  • PHP Manual
  • RecursiveIteratorIterator
  • Obtener el iterador interno

RecursiveIteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getInnerIterator — Obtener el iterador interno

Descripción

public RecursiveIteratorIterator::getInnerIterator ( ) : iterator

Obtiene el sub iterador interno actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El sub iterador actual.


Obtener el máximo de profundidad

  • « RecursiveIteratorIterator::getInnerIterator
  • RecursiveIteratorIterator::getSubIterator »
  • PHP Manual
  • RecursiveIteratorIterator
  • Obtener el máximo de profundidad

RecursiveIteratorIterator::getMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getMaxDepth — Obtener el máximo de profundidad

Descripción

public RecursiveIteratorIterator::getMaxDepth ( ) : mixed

Obtiene el máximo de profundidad permitido.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El máximo de profundidad aceptado, o false si cualquier profundidad está permitida.

Ver también

  • RecursiveIteratorIterator::setMaxDepth() - Establecer el máximo de profundidad


El subiterador activo actual

  • « RecursiveIteratorIterator::getMaxDepth
  • RecursiveIteratorIterator::key »
  • PHP Manual
  • RecursiveIteratorIterator
  • El subiterador activo actual

RecursiveIteratorIterator::getSubIterator

(PHP 5, PHP 7)

RecursiveIteratorIterator::getSubIterator — El subiterador activo actual

Descripción

public RecursiveIteratorIterator::getSubIterator ( int $level = ? ) : RecursiveIterator
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

level

Valores devueltos

El subiterador activo actual.


Acceder a la clave actual

  • « RecursiveIteratorIterator::getSubIterator
  • RecursiveIteratorIterator::next »
  • PHP Manual
  • RecursiveIteratorIterator
  • Acceder a la clave actual

RecursiveIteratorIterator::key

(PHP 5, PHP 7)

RecursiveIteratorIterator::key — Acceder a la clave actual

Descripción

public RecursiveIteratorIterator::key ( ) : mixed
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La clave actual.


Moverse al siguiente elemento

  • « RecursiveIteratorIterator::key
  • RecursiveIteratorIterator::nextElement »
  • PHP Manual
  • RecursiveIteratorIterator
  • Moverse al siguiente elemento

RecursiveIteratorIterator::next

(PHP 5, PHP 7)

RecursiveIteratorIterator::next — Moverse al siguiente elemento

Descripción

public RecursiveIteratorIterator::next ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Siguiente elemento

  • « RecursiveIteratorIterator::next
  • RecursiveIteratorIterator::rewind »
  • PHP Manual
  • RecursiveIteratorIterator
  • Siguiente elemento

RecursiveIteratorIterator::nextElement

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::nextElement — Siguiente elemento

Descripción

public RecursiveIteratorIterator::nextElement ( ) : void

Se llama cuando el siguiente elemento está disponible.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador al primer elemento al nivel superior del iterador interno

  • « RecursiveIteratorIterator::nextElement
  • RecursiveIteratorIterator::setMaxDepth »
  • PHP Manual
  • RecursiveIteratorIterator
  • Rebobina el iterador al primer elemento al nivel superior del iterador interno

RecursiveIteratorIterator::rewind

(PHP 5, PHP 7)

RecursiveIteratorIterator::rewind — Rebobina el iterador al primer elemento al nivel superior del iterador interno

Descripción

public RecursiveIteratorIterator::rewind ( ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Establecer el máximo de profundidad

  • « RecursiveIteratorIterator::rewind
  • RecursiveIteratorIterator::valid »
  • PHP Manual
  • RecursiveIteratorIterator
  • Establecer el máximo de profundidad

RecursiveIteratorIterator::setMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::setMaxDepth — Establecer el máximo de profundidad

Descripción

public RecursiveIteratorIterator::setMaxDepth ( int $max_depth = -1 ) : void

Establece el máximo de profundidad permitida.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

max_depth

El máximo de profundidad permitida. Se usa -1 para cualquier profundidad.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una Exception si max_depth es menor que -1.


Comprueba si la posición actual es válida

  • « RecursiveIteratorIterator::setMaxDepth
  • RecursiveRegexIterator »
  • PHP Manual
  • RecursiveIteratorIterator
  • Comprueba si la posición actual es válida

RecursiveIteratorIterator::valid

(PHP 5, PHP 7)

RecursiveIteratorIterator::valid — Comprueba si la posición actual es válida

Descripción

public RecursiveIteratorIterator::valid ( ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la posición actual es válida, en caso contrario false


La clase RecursiveRegexIterator

(PHP 5 >= 5.2.0, PHP 7)

Introducción

Este iterador recursivo puede filtrar otro iterador recursivo mediante una expresión regular.

Sinopsis de la Clase

RecursiveRegexIterator extends RegexIterator implements RecursiveIterator {
/* Constantaes heredadas constants */
const integer MATCH = 0 ;
const integer GET_MATCH = 1 ;
const integer ALL_MATCHES = 2 ;
const integer SPLIT = 3 ;
const integer REPLACE = 4 ;
const integer USE_KEY = 1 ;
/* Métodos */
public __construct ( RecursiveIterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )
public getChildren ( ) : RecursiveRegexIterator
public hasChildren ( ) : bool
/* Métodos heredados */
public RecursiveIterator::getChildren ( ) : RecursiveIterator
public RecursiveIterator::hasChildren ( ) : bool
public RegexIterator::accept ( ) : bool
public RegexIterator::getFlags ( ) : int
public RegexIterator::getMode ( ) : int
public RegexIterator::getPregFlags ( ) : int
public RegexIterator::getRegex ( ) : string
public RegexIterator::setFlags ( int $flags ) : void
public RegexIterator::setMode ( int $mode ) : void
public RegexIterator::setPregFlags ( int $preg_flags ) : void
}

Tabla de contenidos

  • RecursiveRegexIterator::__construct — Crea un nuevo RecursiveRegexIterator
  • RecursiveRegexIterator::getChildren — Devuelve un iterador para la entrada actual
  • RecursiveRegexIterator::hasChildren — Retorna si un iterador puede ser obtenido de la entrada actual


Crea un nuevo RecursiveRegexIterator

  • « RecursiveRegexIterator
  • RecursiveRegexIterator::getChildren »
  • PHP Manual
  • RecursiveRegexIterator
  • Crea un nuevo RecursiveRegexIterator

RecursiveRegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::__construct — Crea un nuevo RecursiveRegexIterator

Descripción

public RecursiveRegexIterator::__construct ( RecursiveIterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )

Crea un nuevo iterador de expresión regular.

Parámetros

iterator

El iterador recursivo al que se le va a aplicar el filtro regex.

regex

La expresión regular a coincidir.

mode

Modo de operación, véase RegexIterator::setMode() para una lista de todos los modos.

flags

Flags especiales, véase RegexIterator::setFlags() para una lista de todas las flags disponibles.

preg_flags

Las flags de expresión regular. De estas flags depende el parámetro de modo de funcionamiento.

RegexIterator preg_flags
Modo de operación | flags disponibles
RecursiveRegexIterator::ALL_MATCHES | Véase preg_match_all().
RecursiveRegexIterator::GET_MATCH | Véase preg_match().
RecursiveRegexIterator::MATCH | Véase preg_match().
RecursiveRegexIterator::REPLACE | nada.
RecursiveRegexIterator::SPLIT | Véase preg_split().

Ejemplos

Ejemplo #1 Ejemplo de RecursiveRegexIterator::__construct()

Crear un nuevo RegexIterator que filtre todos los string que empiezan con 'test'

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // print all children
        echo "Hijos: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No tiene hijos\n";
    }

}
?>

El resultado del ejemplo sería algo similar a:

No tiene hijos
Hijos: test4 test5

Ver también

  • preg_match() - Realiza una comparación con una expresión regular
  • preg_match_all() - Realiza una comparación global de una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_split() - Divide un string mediante una expresión regular


Devuelve un iterador para la entrada actual

  • « RecursiveRegexIterator::__construct
  • RecursiveRegexIterator::hasChildren »
  • PHP Manual
  • RecursiveRegexIterator
  • Devuelve un iterador para la entrada actual

RecursiveRegexIterator::getChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::getChildren — Devuelve un iterador para la entrada actual

Descripción

public RecursiveRegexIterator::getChildren ( ) : RecursiveRegexIterator

Devuelve un iterador para la entrada actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un iterador para la entrada actual, si este puede se puede iterar sobre el iterador interno.

Errores/Excepciones

Se lanza una InvalidArgumentException si la entrada actual no contiene un valor que pueda ser iterado sobre el iterador interno.

Ejemplos

Ejemplo #1 Ejemplo de RecursiveRegexIterator::getChildren()

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // imprime todos los hijos
        echo "Hijos: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No tiene hijos\n";
    }

}
?>

El resultado del ejemplo sería:

No tiene hijos
Hijos: test4 test5

Ver también

  • RecursiveRegexIterator::hasChildren() - Retorna si un iterador puede ser obtenido de la entrada actual


Retorna si un iterador puede ser obtenido de la entrada actual

  • « RecursiveRegexIterator::getChildren
  • RecursiveTreeIterator »
  • PHP Manual
  • RecursiveRegexIterator
  • Retorna si un iterador puede ser obtenido de la entrada actual

RecursiveRegexIterator::hasChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::hasChildren — Retorna si un iterador puede ser obtenido de la entrada actual

Descripción

public RecursiveRegexIterator::hasChildren ( ) : bool

Retorna si un iterador puede ser obtenido de la entrada actual. Este iterador puede ser obtenido mediante RecursiveRegexIterator::getChildren().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si un iterador puede ser obtenido de la entrada actual, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de RecursiveRegexIterator::hasChildren()

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $value) {
    var_dump($rRegexIterator->hasChildren());
}
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • RecursiveRegexIterator::getChildren() - Devuelve un iterador para la entrada actual


La clase RecursiveTreeIterator

(PHP 5 >= 5.3.0, PHP 7)

Introducción

Permite recorrer un RecursiveIterator para generar un árbol gráfico ASCII.

Sinopsis de la Clase

RecursiveTreeIterator extends RecursiveIteratorIterator implements OuterIterator {
/* Constantaes heredadas constants */
const integer RecursiveIteratorIterator::LEAVES_ONLY = 0 ;
const integer RecursiveIteratorIterator::SELF_FIRST = 1 ;
const integer RecursiveIteratorIterator::CHILD_FIRST = 2 ;
const integer RecursiveIteratorIterator::CATCH_GET_CHILD = 16 ;
/* Constantes */
const integer BYPASS_CURRENT = 4 ;
const integer BYPASS_KEY = 8 ;
const integer PREFIX_LEFT = 0 ;
const integer PREFIX_MID_HAS_NEXT = 1 ;
const integer PREFIX_MID_LAST = 2 ;
const integer PREFIX_END_HAS_NEXT = 3 ;
const integer PREFIX_END_LAST = 4 ;
const integer PREFIX_RIGHT = 5 ;
/* Métodos */
public beginChildren ( ) : void
public beginIteration ( ) : RecursiveIterator
public callGetChildren ( ) : RecursiveIterator
public callHasChildren ( ) : bool
public __construct ( RecursiveIterator|IteratorAggregate $it , int $flags = RecursiveTreeIterator::BYPASS_KEY , int $cit_flags = CachingIterator::CATCH_GET_CHILD , int $mode = RecursiveIteratorIterator::SELF_FIRST )
public current ( ) : string
public endChildren ( ) : void
public endIteration ( ) : void
public getEntry ( ) : string
public getPostfix ( ) : string
public getPrefix ( ) : string
public key ( ) : string
public next ( ) : void
public nextElement ( ) : void
public rewind ( ) : void
public setPostfix ( string $postfix ) : void
public setPrefixPart ( int $part , string $value ) : void
public valid ( ) : bool
/* Métodos heredados */
public RecursiveIteratorIterator::beginChildren ( ) : void
public RecursiveIteratorIterator::beginIteration ( ) : void
public RecursiveIteratorIterator::callGetChildren ( ) : RecursiveIterator
public RecursiveIteratorIterator::callHasChildren ( ) : bool
public RecursiveIteratorIterator::__construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )
public RecursiveIteratorIterator::current ( ) : mixed
public RecursiveIteratorIterator::endChildren ( ) : void
public RecursiveIteratorIterator::endIteration ( ) : void
public RecursiveIteratorIterator::getDepth ( ) : int
public RecursiveIteratorIterator::getInnerIterator ( ) : iterator
public RecursiveIteratorIterator::getMaxDepth ( ) : mixed
public RecursiveIteratorIterator::getSubIterator ( int $level = ? ) : RecursiveIterator
public RecursiveIteratorIterator::key ( ) : mixed
public RecursiveIteratorIterator::next ( ) : void
public RecursiveIteratorIterator::nextElement ( ) : void
public RecursiveIteratorIterator::rewind ( ) : void
public RecursiveIteratorIterator::setMaxDepth ( int $max_depth = -1 ) : void
public RecursiveIteratorIterator::valid ( ) : bool
}

Constantes predefinidas

RecursiveTreeIterator::BYPASS_CURRENT

RecursiveTreeIterator::BYPASS_KEY

RecursiveTreeIterator::PREFIX_LEFT

RecursiveTreeIterator::PREFIX_MID_HAS_NEXT

RecursiveTreeIterator::PREFIX_MID_LAST

RecursiveTreeIterator::PREFIX_END_HAS_NEXT

RecursiveTreeIterator::PREFIX_END_LAST

RecursiveTreeIterator::PREFIX_RIGHT

Tabla de contenidos

  • RecursiveTreeIterator::beginChildren — Inicio de los hijos
  • RecursiveTreeIterator::beginIteration — Inicio de la iteración
  • RecursiveTreeIterator::callGetChildren — Obtener los hijos
  • RecursiveTreeIterator::callHasChildren — Comprobar si tiene hijos
  • RecursiveTreeIterator::__construct — Construye un nuevo RecursiveTreeIterator
  • RecursiveTreeIterator::current — Obtener el elemento actual
  • RecursiveTreeIterator::endChildren — Final de los hijos
  • RecursiveTreeIterator::endIteration — Fin de la iteración
  • RecursiveTreeIterator::getEntry — obtener la entrada actual
  • RecursiveTreeIterator::getPostfix — Obtiener el postfijo
  • RecursiveTreeIterator::getPrefix — Obtener el prefijo
  • RecursiveTreeIterator::key — Obtiene la clave de el elemento actual
  • RecursiveTreeIterator::next — Mover al siguiente elemento
  • RecursiveTreeIterator::nextElement — Comprueba si hay un siguiente elemento
  • RecursiveTreeIterator::rewind — Rebobina el iterador
  • RecursiveTreeIterator::setPostfix — Set postfix
  • RecursiveTreeIterator::setPrefixPart — Establece la parte de el prefijo
  • RecursiveTreeIterator::valid — Comprueba la validez


Inicio de los hijos

  • « RecursiveTreeIterator
  • RecursiveTreeIterator::beginIteration »
  • PHP Manual
  • RecursiveTreeIterator
  • Inicio de los hijos

RecursiveTreeIterator::beginChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginChildren — Inicio de los hijos

Descripción

public RecursiveTreeIterator::beginChildren ( ) : void

Se le llama cuando recursiva está en un nivel inferior.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Inicio de la iteración

  • « RecursiveTreeIterator::beginChildren
  • RecursiveTreeIterator::callGetChildren »
  • PHP Manual
  • RecursiveTreeIterator
  • Inicio de la iteración

RecursiveTreeIterator::beginIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginIteration — Inicio de la iteración

Descripción

public RecursiveTreeIterator::beginIteration ( ) : RecursiveIterator

Se llama cuando comienza la iteración (después de llamar a RecursiveTreeIterator::rewind()).

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un RecursiveIterator.


Obtener los hijos

  • « RecursiveTreeIterator::beginIteration
  • RecursiveTreeIterator::callHasChildren »
  • PHP Manual
  • RecursiveTreeIterator
  • Obtener los hijos

RecursiveTreeIterator::callGetChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callGetChildren — Obtener los hijos

Descripción

public RecursiveTreeIterator::callGetChildren ( ) : RecursiveIterator

Obtiene los hijos de el elemento actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un RecursiveIterator.


Comprobar si tiene hijos

  • « RecursiveTreeIterator::callGetChildren
  • RecursiveTreeIterator::__construct »
  • PHP Manual
  • RecursiveTreeIterator
  • Comprobar si tiene hijos

RecursiveTreeIterator::callHasChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callHasChildren — Comprobar si tiene hijos

Descripción

public RecursiveTreeIterator::callHasChildren ( ) : bool

Se llama para cada elemento para comprobar si tiene hijos o no.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si tiene hijos, en caso contrario false.


Construye un nuevo RecursiveTreeIterator

  • « RecursiveTreeIterator::callHasChildren
  • RecursiveTreeIterator::current »
  • PHP Manual
  • RecursiveTreeIterator
  • Construye un nuevo RecursiveTreeIterator

RecursiveTreeIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::__construct — Construye un nuevo RecursiveTreeIterator

Descripción

public RecursiveTreeIterator::__construct
 ( RecursiveIterator|IteratorAggregate $it
, int $flags = RecursiveTreeIterator::BYPASS_KEY
, int $cit_flags = CachingIterator::CATCH_GET_CHILD
, int $mode = RecursiveIteratorIterator::SELF_FIRST
)

Construye un nuevo RecursiveTreeIterator desde un iterador recursivo suministrado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

it

El RecursiveIterator o IteratorAggregate a iterar.

flags

Se pueden proporcionar flags que afectarán el comportamiento de algunos métodos. Una lista de flags puede verse en Constantes predefinidas RecursiveTreeIterator.

caching_it_flags

Flags que afectan el comportamiento interno de RecursiveCachingIterator.

mode

Flags que afectan el comportamiento interno de RecursiveIteratorIterator.

Valores devueltos

No devuelve ningún valor.


Obtener el elemento actual

  • « RecursiveTreeIterator::__construct
  • RecursiveTreeIterator::endChildren »
  • PHP Manual
  • RecursiveTreeIterator
  • Obtener el elemento actual

RecursiveTreeIterator::current

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::current — Obtener el elemento actual

Descripción

public RecursiveTreeIterator::current ( ) : string

Obtiene el elemento actual prefijo y postfijo.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el elemento actual prefijo y postfijo.


Final de los hijos

  • « RecursiveTreeIterator::current
  • RecursiveTreeIterator::endIteration »
  • PHP Manual
  • RecursiveTreeIterator
  • Final de los hijos

RecursiveTreeIterator::endChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endChildren — Final de los hijos

Descripción

public RecursiveTreeIterator::endChildren ( ) : void

Se llama cuando se llega recursivamente al final de un nivel.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Fin de la iteración

  • « RecursiveTreeIterator::endChildren
  • RecursiveTreeIterator::getEntry »
  • PHP Manual
  • RecursiveTreeIterator
  • Fin de la iteración

RecursiveTreeIterator::endIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endIteration — Fin de la iteración

Descripción

public RecursiveTreeIterator::endIteration ( ) : void

Se llama cuando la iteración termina (o cuando RecursiveTreeIterator::valid() retorne false)

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


obtener la entrada actual

  • « RecursiveTreeIterator::endIteration
  • RecursiveTreeIterator::getPostfix »
  • PHP Manual
  • RecursiveTreeIterator
  • obtener la entrada actual

RecursiveTreeIterator::getEntry

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getEntry — obtener la entrada actual

Descripción

public RecursiveTreeIterator::getEntry ( ) : string

Obtiene la parte de el árbol de el elemento actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la parte de el árbol de el elemento actual.


Obtiener el postfijo

  • « RecursiveTreeIterator::getEntry
  • RecursiveTreeIterator::getPrefix »
  • PHP Manual
  • RecursiveTreeIterator
  • Obtiener el postfijo

RecursiveTreeIterator::getPostfix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPostfix — Obtiener el postfijo

Descripción

public RecursiveTreeIterator::getPostfix ( ) : string

Obtiene el string a colocar después del elemento actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el string a colocar después del elemento actual.


Obtener el prefijo

  • « RecursiveTreeIterator::getPostfix
  • RecursiveTreeIterator::key »
  • PHP Manual
  • RecursiveTreeIterator
  • Obtener el prefijo

RecursiveTreeIterator::getPrefix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPrefix — Obtener el prefijo

Descripción

public RecursiveTreeIterator::getPrefix ( ) : string

Obtiene el string a colocar antes del elemento actual.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el string a colocar antes del elemento actual.


Obtiene la clave de el elemento actual

  • « RecursiveTreeIterator::getPrefix
  • RecursiveTreeIterator::next »
  • PHP Manual
  • RecursiveTreeIterator
  • Obtiene la clave de el elemento actual

RecursiveTreeIterator::key

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::key — Obtiene la clave de el elemento actual

Descripción

public RecursiveTreeIterator::key ( ) : string

Obtiene la clave con prefiro y postfijo.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clave actual con prefijo y postfijo.


Mover al siguiente elemento

  • « RecursiveTreeIterator::key
  • RecursiveTreeIterator::nextElement »
  • PHP Manual
  • RecursiveTreeIterator
  • Mover al siguiente elemento

RecursiveTreeIterator::next

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::next — Mover al siguiente elemento

Descripción

public RecursiveTreeIterator::next ( ) : void

Mover la posición al siguiente elemento.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Comprueba si hay un siguiente elemento

  • « RecursiveTreeIterator::next
  • RecursiveTreeIterator::rewind »
  • PHP Manual
  • RecursiveTreeIterator
  • Comprueba si hay un siguiente elemento

RecursiveTreeIterator::nextElement

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::nextElement — Comprueba si hay un siguiente elemento

Descripción

public RecursiveTreeIterator::nextElement ( ) : void

Se llama cuando hay un siguiente elemento disponible.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Rebobina el iterador

  • « RecursiveTreeIterator::nextElement
  • RecursiveTreeIterator::setPostfix »
  • PHP Manual
  • RecursiveTreeIterator
  • Rebobina el iterador

RecursiveTreeIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::rewind — Rebobina el iterador

Descripción

public RecursiveTreeIterator::rewind ( ) : void

Rebobina el iterador hasta el primer elemento de el iterador interno superior.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Set postfix

  • « RecursiveTreeIterator::rewind
  • RecursiveTreeIterator::setPrefixPart »
  • PHP Manual
  • RecursiveTreeIterator
  • Set postfix

RecursiveTreeIterator::setPostfix

(PHP 5 >= 5.5.3, PHP 7)

RecursiveTreeIterator::setPostfix — Set postfix

Descripción

public RecursiveTreeIterator::setPostfix ( string $postfix ) : void

Sets postfix as used in RecursiveTreeIterator::getPostfix().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

postfix

Valores devueltos

No devuelve ningún valor.


Establece la parte de el prefijo

  • « RecursiveTreeIterator::setPostfix
  • RecursiveTreeIterator::valid »
  • PHP Manual
  • RecursiveTreeIterator
  • Establece la parte de el prefijo

RecursiveTreeIterator::setPrefixPart

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::setPrefixPart — Establece la parte de el prefijo

Descripción

public RecursiveTreeIterator::setPrefixPart ( int $part , string $value ) : void

Establece la parte del prefijo usada en el árbol gráfico.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

part

Una de las constantes RecursiveTreeIterator::PREFIX_*.

value

El valor a ser asignado a la parte del prefijo especificado en part.

Valores devueltos

No devuelve ningún valor.


Comprueba la validez

  • « RecursiveTreeIterator::setPrefixPart
  • RegexIterator »
  • PHP Manual
  • RecursiveTreeIterator
  • Comprueba la validez

RecursiveTreeIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::valid — Comprueba la validez

Descripción

public RecursiveTreeIterator::valid ( ) : bool

Comprueba si la posición actual es válida.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la posición actual es válida, en caso contrario false


La clase RegexIterator

(PHP 5 >= 5.2.0, PHP 7)

Introducción

Este iterador puede ser usado para filtrar otro iterador basado en una expresión regular.

Sinopsis de la Clase

RegexIterator extends FilterIterator {
/* Constantes */
const integer MATCH = 0 ;
const integer GET_MATCH = 1 ;
const integer ALL_MATCHES = 2 ;
const integer SPLIT = 3 ;
const integer REPLACE = 4 ;
const integer USE_KEY = 1 ;
/* Métodos */
public __construct ( Iterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )
public accept ( ) : bool
public getFlags ( ) : int
public getMode ( ) : int
public getPregFlags ( ) : int
public getRegex ( ) : string
public setFlags ( int $flags ) : void
public setMode ( int $mode ) : void
public setPregFlags ( int $preg_flags ) : void
/* Métodos heredados */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

Constantes predefinidas

Modos de operación RegexIterator

RegexIterator::ALL_MATCHES

Devuelve todas las coincidencias de la entrada actual. (véase preg_match_all()).

RegexIterator::GET_MATCH

Devuelve la primera coincidencia de la entrada actual. (véase preg_match()).

RegexIterator::MATCH

Sólo ejecuta la coincidencia (filtro) para la entrada actual (véase preg_match()).

RegexIterator::REPLACE

Reemplaza la entrada actual (véase preg_replace(); No está completamente implementado)

RegexIterator::SPLIT

Devuelve los valores divididos de la entrada actual (véase preg_split()).

Flags RegexIterator

RegexIterator::USE_KEY

Flag especial: Coincidir con la clave de entrada en lugar del valor de la entrada.

Tabla de contenidos

  • RegexIterator::accept — Obtener el estado de aceptación
  • RegexIterator::__construct — Crea un nuevo RegexIterator
  • RegexIterator::getFlags — Obtener flags
  • RegexIterator::getMode — Devuelve el modo de operación
  • RegexIterator::getPregFlags — Devuelve las flags de expresión regular
  • RegexIterator::getRegex — Devuelve la expresión regular actual
  • RegexIterator::setFlags — Establece las flags
  • RegexIterator::setMode — Establece el modo de operación
  • RegexIterator::setPregFlags — Establece las flags de expresión regular


Obtener el estado de aceptación

  • « RegexIterator
  • RegexIterator::__construct »
  • PHP Manual
  • RegexIterator
  • Obtener el estado de aceptación

RegexIterator::accept

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::accept — Obtener el estado de aceptación

Descripción

public RegexIterator::accept ( ) : bool

Coincidir (string) RegexIterator::current()
(o RegexIterator::key() si la flag
RegexIterator::USE_KEY está establecida)
con la expresión regular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si coincide, en caso contrario false.

Ejemplos

Ejemplo #1 RegexIterator::accept() example

Este ejemplo muestra sólo los elementos aceptados que coinciden con la expresión regular.

<?php
$names = new ArrayIterator(array('Ann', 'Bob', 'Charlie', 'David'));
$filter = new RegexIterator($names, '/^[B-D]/');
foreach ($filter as $name) {
    echo $name . PHP_EOL;
}
?>

El resultado del ejemplo sería:

Bob
Charlie
David

Ver también

  • RegexIterator constants
  • RegexIterator::setFlags() - Establece las flags


Crea un nuevo RegexIterator

  • « RegexIterator::accept
  • RegexIterator::getFlags »
  • PHP Manual
  • RegexIterator
  • Crea un nuevo RegexIterator

RegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::__construct — Crea un nuevo RegexIterator

Descripción

public RegexIterator::__construct ( Iterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )

Crea un nuevo RegexIterator que filtra un Iterator usando una expresión regular.

Parámetros

iterator

El iterador al que se le va a aplicar el filtro regex.

regex

la expresión regular a coincidir.

mode

Modo de operación, véase RegexIterator::setMode() para una lista de todos los modos.

flags

Flags especiales, véase RegexIterator::setFlags() para una lista de todas las flags disponibles.

preg_flags

Las flags de expresión regular. Estas flags dependen de el parámetro de modo de operación.

RegexIterator preg_flags
operation mode | available flags
RegexIterator::ALL_MATCHES | Véase preg_match_all().
RegexIterator::GET_MATCH | Véase preg_match().
RegexIterator::MATCH | Véase preg_match().
RegexIterator::REPLACE | Nada.
RegexIterator::SPLIT | Véase preg_split().

Errores/Excepciones

Lanza una InvalidArgumentException si el argumento regex es inválido.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::__construct()

Crea un nuevo RegexIterator que filtra todos los string que empiezan con 'test'.

<?php
$arrayIterator = new ArrayIterator(array('test 1', 'another test', 'test 123'));
$regexIterator = new RegexIterator($arrayIterator, '/^test/');

foreach ($regexIterator as $value) {
    echo $value . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

test 1
test 123

Ver también

  • preg_match() - Realiza una comparación con una expresión regular
  • preg_match_all() - Realiza una comparación global de una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_split() - Divide un string mediante una expresión regular


Obtener flags

  • « RegexIterator::__construct
  • RegexIterator::getMode »
  • PHP Manual
  • RegexIterator
  • Obtener flags

RegexIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getFlags — Obtener flags

Descripción

public RegexIterator::getFlags ( ) : int

Devuelve las flags, véase RegexIterator::setFlags() para una lista de todas las flags disponibles.

Valores devueltos

Devuelve las flags establecidas.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::getFlags()

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

if ($regexIterator->getFlags() & RegexIterator::USE_KEY) {
    echo 'Filtrado basado en las claves del array.';
} else {
    echo 'Filtrado basado en los valores del array.';
}
?>

El resultado del ejemplo sería:

Filtrado basado en las claves del array.

Ver también

  • RegexIterator::setFlags() - Establece las flags


Devuelve el modo de operación

  • « RegexIterator::getFlags
  • RegexIterator::getPregFlags »
  • PHP Manual
  • RegexIterator
  • Devuelve el modo de operación

RegexIterator::getMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getMode — Devuelve el modo de operación

Descripción

public RegexIterator::getMode ( ) : int

Devuelve el modo de operación, véase RegexIterator::setMode() para una lista de todos los modos de operación.

Valores devueltos

Devuelve los modos de operación.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::getMode()

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'otro test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^[a-z]+/', RegexIterator::GET_MATCH);

$mode = $regexIterator->getMode();
if ($mode & RegexIterator::GET_MATCH) {
    echo 'Obteniendo la coincidencia para cada elemento.';
} elseif ($mode & RegexIterator::ALL_MATCHES) {
    echo 'Obteniendo las coincidencias para cada elemento.';
} elseif ($mode & RegexIterator::MATCH) {
    echo 'Obteniendo cada elemento si este coincide.';
} elseif ($mode & RegexIterator::SPLIT) {
    echo 'Obteniendo las piezas de cada elemento.';
}
?>

El resultado del ejemplo sería:

Obteniendo la coincidencia para cada elemento.

Ver también

  • RegexIterator::setMode() - Establece el modo de operación


Devuelve las flags de expresión regular

  • « RegexIterator::getMode
  • RegexIterator::getRegex »
  • PHP Manual
  • RegexIterator
  • Devuelve las flags de expresión regular

RegexIterator::getPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getPregFlags — Devuelve las flags de expresión regular

Descripción

public RegexIterator::getPregFlags ( ) : int

Devuelve las flags de expresión regular, véase RegexIterator::__construct() para una lista de todas las flags.

Valores devueltos

Devuelve un bitmask de las flags de expresión regular.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::getPregFlags()

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'otro test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/\s/', RegexIterator::SPLIT);
$regexIterator->setPregFlags(PREG_SPLIT_NO_EMPTY | PREG_SPLIT_OFFSET_CAPTURE);

if ($regexIterator->getPregFlags() & PREG_SPLIT_NO_EMPTY) {
    echo 'Ignorando las piezas vacías';
} else {
    echo 'No ignora piezas vacías';
}

?>

El resultado del ejemplo sería:

Ignorando las piezas vacías

Ver también

  • RegexIterator::setPregFlags() - Establece las flags de expresión regular


Devuelve la expresión regular actual

  • « RegexIterator::getPregFlags
  • RegexIterator::setFlags »
  • PHP Manual
  • RegexIterator
  • Devuelve la expresión regular actual

RegexIterator::getRegex

(PHP 5 >= 5.4.0, PHP 7)

RegexIterator::getRegex — Devuelve la expresión regular actual

Descripción

public RegexIterator::getRegex ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Establece las flags

  • « RegexIterator::getRegex
  • RegexIterator::setMode »
  • PHP Manual
  • RegexIterator
  • Establece las flags

RegexIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setFlags — Establece las flags

Descripción

public RegexIterator::setFlags ( int $flags ) : void

Establece las flags.

Parámetros

flags

Las flags a ser establecidas, The flags to set, un bitmask de constantes de la clase.

Las flags disponibles se enumeran a continuación. El verdadero significado de estas flags se describe en las Constantes predefinidas.

Flags RegexIterator
value | constant
1 | RegexIterator::USE_KEY

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::setFlags()

Crear un nuevo RegexIterator que filtre todas las entradas que empiecen con la palabra clave 'test'.

<?php
$test = array ('str1' => 'test 1', 'teststr2' => 'otro test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

foreach ($regexIterator as $clave => $valor) {
    echo $clave . ' => ' . $valor . "\n";
}
?>

El resultado del ejemplo sería:

teststr2 => otro test

Ver también

  • RegexIterator::getFlags() - Obtener flags


Establece el modo de operación

  • « RegexIterator::setFlags
  • RegexIterator::setPregFlags »
  • PHP Manual
  • RegexIterator
  • Establece el modo de operación

RegexIterator::setMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setMode — Establece el modo de operación

Descripción

public RegexIterator::setMode ( int $mode ) : void

Establecer el modo de operación.

Parámetros

mode

El modo de operación.

Los modos disponibles se enumeran a continuación. El verdadero significado de estos modos se describe en las constantes predefinidas.

Modos RegexIterator
value | constant
0 | RegexIterator::MATCH
1 | RegexIterator::GET_MATCH
2 | RegexIterator::ALL_MATCHES
3 | RegexIterator::SPLIT
4 | RegexIterator::REPLACE

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::setMode()

<?php
$test = array ('str1' => 'test 1', 'test str2' => 'otro test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
// Filtra todo lo que empiece con 'test ' seguido por uno o más números.
$regexIterator = new RegexIterator($arrayIterator, '/^test (\d+)/');
// Modo de operación: Reemplaza el valor actual con las coincidencias
$regexIterator->setMode(RegexIterator::GET_MATCH);

foreach ($regexIterator as $clave => $valor) {
    // imprime el o los números que coincidan
    echo $key . ' => ' . $value[1] . PHP_EOL;
}
?>

El resultado del ejemplo sería algo similar a:

str1 => 1
str3 => 123

Ver también

  • RegexIterator::getMode() - Devuelve el modo de operación


Establece las flags de expresión regular

  • « RegexIterator::setMode
  • Interfaces »
  • PHP Manual
  • RegexIterator
  • Establece las flags de expresión regular

RegexIterator::setPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setPregFlags — Establece las flags de expresión regular

Descripción

public RegexIterator::setPregFlags ( int $preg_flags ) : void

Establece las flags de expresión regular.

Parámetros

preg_flags

Las flags de expresión regular. Véase RegexIterator::__construct() para una lista de todas las flags disponibles.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de RegexIterator::setPregFlags()

Crea un nuevo RegexIterator que filtra todas las entradas donde la clave del array empiece con 'test'.

<?php
$test = array ('test 1', 'otro test', 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/', RegexIterator::GET_MATCH);

$regexIterator->setPregFlags(PREG_OFFSET_CAPTURE);

foreach ($regexIterator as $clave => $valor) {
    var_dump($valor);
}
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}

Ver también

  • RegexIterator::getPregFlags() - Devuelve las flags de expresión regular


Interfaces

Tabla de contenidos

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator

SPL proporciona un grupo de interfaces.

Ver también Interfaces y clases predefinidas

Lista de interfaces

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator
  • SplObserver
  • SplSubject


El interfaz Countable

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Las clases implementado Countable pueden ser usadas con la función count().

Sinopsis de la Interfaz

Countable {
/* Métodos */
abstract public count ( ) : int
}

Tabla de contenidos

  • Countable::count — Cuenta los elementos de un objeto


Cuenta los elementos de un objeto

  • « Countable
  • OuterIterator »
  • PHP Manual
  • Countable
  • Cuenta los elementos de un objeto

Countable::count

(PHP 5 >= 5.1.0, PHP 7)

Countable::count — Cuenta los elementos de un objeto

Descripción

abstract public Countable::count ( ) : int

Este método se ejecuta cuando se utiliza la función count() sobre un objeto que implemente la interfaz Countable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El recuento personalizado como un integer.

Nota:

El valor devuelto se convierte en integer.

Ejemplos

Ejemplo #1 Ejemplo de Countable::count()

<?php
class miContador implements Countable {
    private $cuenta = 0;
    public function count() {
        return ++$this->cuenta;
    }
}

$contador = new miContador;

for($i=0; $i<10; ++$i) {
    echo "He contado usando count() " . count($contador) . " veces\n";
}
?>

El resultado del ejemplo sería algo similar a:

He contado usando count() 1 veces
He contado usando count() 2 veces
He contado usando count() 3 veces
He contado usando count() 4 veces
He contado usando count() 5 veces
He contado usando count() 6 veces
He contado usando count() 7 veces
He contado usando count() 8 veces
He contado usando count() 9 veces
He contado usando count() 10 veces


El interfaz OuterIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Las clases que implementan OuterIterator pueden ser usadas para iterar sobre iteradores.

Sinopsis de la Interfaz

OuterIterator extends Iterator {
/* Métodos */
public getInnerIterator ( ) : Iterator
/* Métodos heredados */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Tabla de contenidos

  • OuterIterator::getInnerIterator — Devuelve el iterador interno de la entrada actual


Devuelve el iterador interno de la entrada actual

  • « OuterIterator
  • RecursiveIterator »
  • PHP Manual
  • OuterIterator
  • Devuelve el iterador interno de la entrada actual

OuterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

OuterIterator::getInnerIterator — Devuelve el iterador interno de la entrada actual

Descripción

public OuterIterator::getInnerIterator ( ) : Iterator

Devuelve el iterador interno de la entrada actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El iterador interno de la entrada actual.


El interfaz RecursiveIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Las clases que implementan RecursiveIterator pueden ser usadas para iterar sobre iteradores de forma recursiva.

Sinopsis de la Interfaz

RecursiveIterator extends Iterator {
/* Métodos */
public getChildren ( ) : RecursiveIterator
public hasChildren ( ) : bool
/* Métodos heredados */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Tabla de contenidos

  • RecursiveIterator::getChildren — Devuelve un iterador para la entrada actual
  • RecursiveIterator::hasChildren — Retorna si un iterador puede ser creado para la entrada actual


Devuelve un iterador para la entrada actual

  • « RecursiveIterator
  • RecursiveIterator::hasChildren »
  • PHP Manual
  • RecursiveIterator
  • Devuelve un iterador para la entrada actual

RecursiveIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::getChildren — Devuelve un iterador para la entrada actual

Descripción

public RecursiveIterator::getChildren ( ) : RecursiveIterator

Devuelve un iterador para la entrada del iterador actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un iterador de la entrada actual.

Ver también

  • RecursiveIterator::hasChildren() - Retorna si un iterador puede ser creado para la entrada actual


Retorna si un iterador puede ser creado para la entrada actual

  • « RecursiveIterator::getChildren
  • SeekableIterator »
  • PHP Manual
  • RecursiveIterator
  • Retorna si un iterador puede ser creado para la entrada actual

RecursiveIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::hasChildren — Retorna si un iterador puede ser creado para la entrada actual

Descripción

public RecursiveIterator::hasChildren ( ) : bool

Retorna si un iterador puede ser creado para la entrada actual. RecursiveIterator::getChildren().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la entrada actual puede se puede iterar, en caso contrario false.

Ver también

  • RecursiveIterator::getChildren() - Devuelve un iterador para la entrada actual


La interfaz SeekableIterator

(PHP 5 >= 5.1.0, PHP 7)

Introducción

El iterador Seekable.

Sinopsis de la Interfaz

SeekableIterator extends Iterator {
/* Métodos */
abstract public seek ( int $position ) : void
/* Métodos heredados */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Ejemplo #1 Uso básico

Este ejemplo muestra cómo crear un SeekableIterator personalizado, buscar una posición y manejar una posición inválida.

<?php
class MiSeekableIterator implements SeekableIterator {

    private $posición = 0;

    private $array = array(
        "primer elemento",
        "segundo elemento",
        "tercer elemento",
        "cuarto elemento"
    );

    /* Métodos requeridos para la interfaz SeekableIterator */

    public function seek($posición) {
      if (!isset($this->array[$posición])) {
          throw new OutOfBoundsException("Posición de búsqueda inválida ($posición)");
      }

      $this->posición = $posición;
    }

    /* Métodos requeridos para la interfaz Iterador */

    public function rewind() {
        $this->posición = 0;
    }

    public function current() {
        return $this->array[$this->posición];
    }

    public function key() {
        return $this->posición;
    }

    public function next() {
        ++$this->posición;
    }

    public function valid() {
        return isset($this->array[$this->posición]);
    }
}

try {

    $it = new MiSeekableIterator;
    echo $it->current(), "\n";

    $it->seek(2);
    echo $it->current(), "\n";

    $it->seek(1);
    echo $it->current(), "\n";

    $it->seek(10);

} catch (OutOfBoundsException $e) {
    echo $e->getMessage();
}
?>

El resultado del ejemplo sería algo similar a:

primer elemento
tercer elemento
segundo elemento
Posición de búsqueda inválida (10)

Tabla de contenidos

  • SeekableIterator::seek — Mueve la posición del apuntador interno


Mueve la posición del apuntador interno

  • « SeekableIterator
  • Excepciones »
  • PHP Manual
  • SeekableIterator
  • Mueve la posición del apuntador interno

SeekableIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

SeekableIterator::seek — Mueve la posición del apuntador interno

Descripción

abstract public SeekableIterator::seek ( int $position ) : void

Mueve la posición del apuntador interno en el iterador.

Parámetros

position

La posición para mover el apuntador interno.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Las implementaciones deben lanzar una OutOfBoundsException si la posición position no es válida.

Ejemplos

Ejemplo #1 Ejemplo de SeekableIterator::seek()

Mueve el apuntador de el elemento a la posición 3 en el iterador (ArrayIterator implements SeekableIterator).

<?php
$array = array("manzana", "banana", "cereza", "ciruela", "baya");
$iterator = new ArrayIterator($array);
$iterator->seek(3);
echo $iterator->current();
?>

El resultado del ejemplo sería algo similar a:

ciruela

Ver también

  • SeekableIterator
  • Iterator


Excepciones

Tabla de contenidos

  • BadFunctionCallException
  • BadMethodCallException
  • DomainException
  • InvalidArgumentException
  • LengthException
  • LogicException
  • OutOfBoundsException
  • OutOfRangeException
  • OverflowException
  • RangeException
  • RuntimeException
  • UnderflowException
  • UnexpectedValueException

SPL proporcina un conunto de Excepciones estándar.

Véase también Excepciones predefinidas

Árbol de Clases de Excepciones de SPL

  • LogicException (extends Exception)
    • BadFunctionCallException
      • BadMethodCallException
    • DomainException
    • InvalidArgumentException
    • LengthException
    • OutOfRangeException
  • RuntimeException (extends Exception)
    • OutOfBoundsException
    • OverflowException
    • RangeException
    • UnderflowException
    • UnexpectedValueException


La clase BadFunctionCallException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si la llamada de retorno hace referencia a una función no definida o faltan algunos de los argumentos.

Sinopsis de la Clase

BadFunctionCallException extends LogicException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase BadMethodCallException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si la llamada de retorno hace referencia a una función no definida o faltan algunos de los argumentos.

Sinopsis de la Clase

BadMethodCallException extends BadFunctionCallException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase DomainException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Excepción lanzada si un valor no se adhiere a un dominio definido de datos válidos.

Sinopsis de la Clase

DomainException extends LogicException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase InvalidArgumentException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Excepción lanzada si un argumento no es del tipo previsto.

Sinopsis de la Clase

InvalidArgumentException extends LogicException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase LengthException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si el valor longitud no es válido.

Sinopsis de la Clase

LengthException extends LogicException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase LogicException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Excepción que representa un error en la lógica del programa. Este tipo de excepciones debería conducir directamente a una reparación del código.

Sinopsis de la Clase

LogicException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase OutOfBoundsException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si el valor no es una clave válida. Representa los errores que no pueden ser detectados en tiempo de ejecucción.

Sinopsis de la Clase

OutOfBoundsException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase OutOfRangeException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción cuando se solicita un índice ilegal. Esto representa un error que debe ser detectado en tiempo de compilación.

Sinopsis de la Clase

OutOfRangeException extends LogicException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase OverflowException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción cuando se agrega un elemento en un contenedor lleno.

Sinopsis de la Clase

OverflowException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase RangeException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Excepción que se produce para indicar los errores de rango durante la ejecución del programa. Normalmente, esto significa que hubo un error aritmético distinto a bajo/sobre flujo. Esta es la versión en tiempo de ejecución de DomainException.

Sinopsis de la Clase

RangeException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase RuntimeException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si hay un error que sólo se puede encontrar en tiempo de ejecución.

Sinopsis de la Clase

RuntimeException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase UnderflowException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción cuando se lleva a cabo una operación no válida o un contenedor vacío, tal como eliminar un elemento.

Sinopsis de la Clase

UnderflowException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase UnexpectedValueException

(PHP 5 >= 5.1.0, PHP 7)

Introducción

Lanza una excepción si un valor no coincide con un grupo de valores. Generalmente, esto sucede cuando una función llama a otra función y espera que el valor de retorno sea de cierto tipo o un valor aritmético no incluido o un errores relacionados con el buffer.

Sinopsis de la Clase

UnexpectedValueException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Funciones SPL

Tabla de contenidos

  • class_implements — Devuelve las interfaces que son implementadas por la clase o interfaz dadas
  • class_parents — Devuelve las clases padre de la clase dada.
  • class_uses — Devolver los "traits" usados por la clase dada
  • iterator_apply — Llamar a una función para cada elemento de un iterador
  • iterator_count — Contar los elementos de un iterador
  • iterator_to_array — Copiar el iterador a un array
  • spl_autoload_call — Probar todos las funciones registradas __autoload() para cargar la clase solicitada
  • spl_autoload_extensions — Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload
  • spl_autoload_functions — Devolver todas las funciones __autoload() registradas
  • spl_autoload_register — Registrar las funciones dadas como implementación de __autoload()
  • spl_autoload_unregister — Desregistrar una función dada como implementación de __autoload()
  • spl_autoload — Implementación predeterminada para __autoload()
  • spl_classes — Devuelve las clases SPL disponibles
  • spl_object_hash — Devuelve el id del hash del objeto dado
  • spl_object_id — Return the integer object handle for given object


Devuelve las interfaces que son implementadas por la clase o interfaz dadas

  • « Funciones SPL
  • class_parents »
  • PHP Manual
  • Funciones SPL
  • Devuelve las interfaces que son implementadas por la clase o interfaz dadas

class_implements

(PHP 5, PHP 7)

class_implements — Devuelve las interfaces que son implementadas por la clase o interfaz dadas

Descripción

class_implements ( mixed $class , bool $autoload = true ) : array

Esta función devuelve un array con los nombres de las interfaces que implementa la class dada y sus padres.

Parámetros

class

Un objeto (instancia de clase) o un string (nombre de clase o interfaz).

autoload

Establece si se va a permitir que la clase se cargue automáticamente a a través del método mágico __autoload().

Valores devueltos

Un array en caso de éxito, o false en caso de error.

Historial de cambios

Versión | Descripción
5.1.0 | Añadida la opción para pasar el parámetro class como un string. Añadido el parámetro autoload.

Ejemplos

Ejemplo #1 Ejemplo de class_implements()

<?php

interface foo { }
class bar implements foo {}

print_r(class_implements(new bar));

// desde PHP 5.1.0 se puede especificar el parámetro como un string
print_r(class_implements('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// uso de __autoload para cargar la clase 'not_loaded'
print_r(class_implements('not_loaded', true));

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [foo] => foo
)

Array
(
    [interface_of_not_loaded] => interface_of_not_loaded
)

Ver también

  • class_parents() - Devuelve las clases padre de la clase dada.
  • get_declared_interfaces() - Devuelve un array con todas las interfaces declaradas


Devuelve las clases padre de la clase dada.

  • « class_implements
  • class_uses »
  • PHP Manual
  • Funciones SPL
  • Devuelve las clases padre de la clase dada.

class_parents

(PHP 5, PHP 7)

class_parents — Devuelve las clases padre de la clase dada.

Descripción

class_parents ( mixed $class , bool $autoload = true ) : array

Esta función devuelve un array con los nombres de las clases padre de la class dada.

Parámetros

class

Un objeto (instancia de clase) o un string (nombre de clase).

autoload

Establece si se va a permitir que la clase se cargue automáticamente a a través del método mágico __autoload().

Valores devueltos

Un array en caso de éxito, o false en caso de error.

Historial de cambios

Versión | Descripción
5.1.0 | Añadida la opción para pasar el parámetro class como un string. Añadido el parámetro autoload.

Ejemplos

Ejemplo #1 Ejemplo de class_parents()

<?php

class foo { }
class bar extends foo {}

print_r(class_parents(new bar));

// desde PHP 5.1.0 se puede especificar el parámetro como un string
print_r(class_parents('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// uso de __autoload para cargar la clase 'not_loaded'
print_r(class_parents('not_loaded', true));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [foo] => foo
)

Array
(
    [parent_of_not_loaded] => parent_of_not_loaded
)

Ver también

  • class_implements() - Devuelve las interfaces que son implementadas por la clase o interfaz dadas


Devolver los "traits" usados por la clase dada

  • « class_parents
  • iterator_apply »
  • PHP Manual
  • Funciones SPL
  • Devolver los "traits" usados por la clase dada

class_uses

(PHP 5 >= 5.4.0, PHP 7)

class_uses — Devolver los "traits" usados por la clase dada

Descripción

class_uses ( mixed $class , bool $autoload = true ) : array

Esta función devuelve un array con los nombres de los "traits" que usa la class dada. Sin embargo, esto no incluye ningún "trait" usado por una clase padre.

Parámetros

class

Un objeto (instancia de clase) o una cadena (nombre de clase).

autoload

Si permitir a esta función cargar la clase automáticamente a través del método mágico __autoload().

Valores devueltos

Un array en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de class_uses()

<?php

trait foo { }
class bar {
  use foo;
}

print_r(class_uses(new bar));

print_r(class_uses('bar'));

function __autoload($nombre_clase) {
   require_once $nombre_clase . '.php';
}

// use __autoload para cargar la clase 'no_cargada'
print_r(class_uses('no_cargada', true));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [foo] => foo
)

Array
(
    [foo] => foo
)

Array
(
    [trait_of_not_loaded] => trait_of_not_loaded
)

Ver también

  • class_parents() - Devuelve las clases padre de la clase dada.
  • get_declared_traits() - Devuelve un array de todos los traits declarados


Llamar a una función para cada elemento de un iterador

  • « class_uses
  • iterator_count »
  • PHP Manual
  • Funciones SPL
  • Llamar a una función para cada elemento de un iterador

iterator_apply

(PHP 5 >= 5.1.0, PHP 7)

iterator_apply — Llamar a una función para cada elemento de un iterador

Descripción

iterator_apply ( Traversable $iterator , callable $function , array $args = ? ) : int

Llama a una función para cada elemento de un iterador.

Parámetros

iterator

La clase a recorrer.

function

La función de llamada de retorno a invocar para cada elemento.

Nota: Esta función debe retornar true para continuar recorriendo el iterator.

args

Argumentos a pasar a la función de llamada de retorno.

Valores devueltos

Devuelve el número de iteraciones.

Ejemplos

Ejemplo #1 Ejemplo de iterator_apply()

<?php
function print_caps(Iterator $iterator) {
    echo strtoupper($iterator->current()) . "\n";
    return TRUE;
}

$it = new ArrayIterator(array("Manzanas", "Bananas", "Cerezas"));
iterator_apply($it, "print_caps", array($it));
?>

El resultado del ejemplo sería:

MANZANAS
BANANAS
CEREZAS

Ver también

  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array


Contar los elementos de un iterador

  • « iterator_apply
  • iterator_to_array »
  • PHP Manual
  • Funciones SPL
  • Contar los elementos de un iterador

iterator_count

(PHP 5 >= 5.1.0, PHP 7)

iterator_count — Contar los elementos de un iterador

Descripción

iterator_count ( Traversable $iterator ) : int

Contar los elementos de un iterador. iterator_count() no garantiza conservar la posición actual de iterator.

Parámetros

iterator

El iterador a contar.

Valores devueltos

El número de elementos de iterator.

Ejemplos

Ejemplo #1 Ejemplo de iterator_count()

<?php
$iterator = new ArrayIterator(array('recipe'=>'panqueques', 'huevo', 'leche', 'harina'));
var_dump(iterator_count($iterator));
?>

El resultado del ejemplo sería:

int(4)

Ejemplo #2 iterator_count() modifica la posición

<?php
$iterator = new ArrayIterator(['uno', 'dos', 'tres']);
var_dump($iterator->current());
var_dump(iterator_count($iterator));
var_dump($iterator->current());
?>

El resultado del ejemplo sería:

string(3) "uno"
int(3)
NULL

Ejemplo #3 iterator_count() en bucles foreach

<?php
$iterator = new ArrayIterator(['uno', 'dos', 'tres']);
foreach ($iterator as $clave => $valor) {
    echo "$clave: $valor (", iterator_count($iterator), ")\n";
}?>

El resultado del ejemplo sería:

0: uno (3)


Copiar el iterador a un array

  • « iterator_count
  • spl_autoload_call »
  • PHP Manual
  • Funciones SPL
  • Copiar el iterador a un array

iterator_to_array

(PHP 5 >= 5.1.0, PHP 7)

iterator_to_array — Copiar el iterador a un array

Descripción

iterator_to_array ( Traversable $iterator , bool $use_keys = true ) : array

Copia los elementos de un iterador a un array.

Parámetros

iterator

El iterador a copiar.

use_keys

Si usar las claves del elemento iterador como índice.

En PHP 5.5 y posterior, si una clave es un array u object, se generará una advertencia. Las claves null serán convertidas a un string vacío, las claves float serán truncadas a su equivalente integer, las claves resource generarán una advertencia y serán convertidas a sus ID de recurso, y las claves boolean serán convertidas a enteros.

Nota:

Si no se establece este parámetro o se establece a true, las claves duplicadas serán sobrescritas. El último valor con una clave dada estará en el array devuelto. Para obtener todos los valores en cualquier caso, se ha de establecer este parámetro a false.

Valores devueltos

Un array que contiene los elementos del iterator.

Historial de cambios

Versión | Descripción
5.5.0 | iterator_to_array() da soporte a tipos de claves diferentes a integer y string cuando el parámetro use_keys está habilitado.
5.2.1 | Añadido el parámetro use_keys.

Ejemplos

Ejemplo #1 Ejemplo de iterator_to_array()

<?php
$iterator = new ArrayIterator(array('recipe'=>'panqueques', 'huevo', 'leche', 'harina'));
var_dump(iterator_to_array($iterator, true));
var_dump(iterator_to_array($iterator, false));
?>

El resultado del ejemplo sería:

array(4) {
  ["recipe"]=>
  string(10) "panqueques"
  [0]=>
  string(5) "huevo"
  [1]=>
  string(5) "leche"
  [2]=>
  string(6) "harina"
}
array(4) {
  [0]=>
  string(10) "panqueques"
  [1]=>
  string(5) "huevo"
  [2]=>
  string(5) "leche"
  [3]=>
  string(6) "harina"
}


Probar todos las funciones registradas __autoload() para cargar la clase solicitada

  • « iterator_to_array
  • spl_autoload_extensions »
  • PHP Manual
  • Funciones SPL
  • Probar todos las funciones registradas __autoload() para cargar la clase solicitada

spl_autoload_call

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_call — Probar todos las funciones registradas __autoload() para cargar la clase solicitada

Descripción

spl_autoload_call ( string $class_name ) : void

Esta función puede ser usada manualmente para buscar una clase o interface usando las funciones registradas __autoload.

Parámetros

class_name

El nombre de la clase a ser buscada.

Valores devueltos

No devuelve ningún valor.


Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload

  • « spl_autoload_call
  • spl_autoload_functions »
  • PHP Manual
  • Funciones SPL
  • Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload

spl_autoload_extensions

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_extensions — Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload

Descripción

spl_autoload_extensions ( string $file_extensions = ? ) : string

Esta función puede modificar y verificar las extensiones de ficheros que estará usando spl_autoload() en respaldo de la función interna __autoload().

Parámetros

file_extensions

Cuando se llama sin ningún argumento, simplemente devuelve la lista actual de extensiones separadas por comas. Para modificar la lista de extensiones de fichero, llame a las funciones con la nueva lista de extensiones de fichero a usar en una simple cadena con cada extensión serparada por una coma.

Valores devueltos

Una lista delimitada por comas de las extensiones predeterminadas de ficheros de para spl_autoload().


Devolver todas las funciones __autoload() registradas

  • « spl_autoload_extensions
  • spl_autoload_register »
  • PHP Manual
  • Funciones SPL
  • Devolver todas las funciones __autoload() registradas

spl_autoload_functions

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_functions — Devolver todas las funciones __autoload() registradas

Descripción

spl_autoload_functions ( ) : array

Obtiene todas las funciones __autoload() registradas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con todas las funciones __autoload registradas. Si la cola de autocarga no está activada, el valor devuelto es false. Si no hay ninguna función registrada, el valor devuelto será un array vacío.


Registrar las funciones dadas como implementación de __autoload()

  • « spl_autoload_functions
  • spl_autoload_unregister »
  • PHP Manual
  • Funciones SPL
  • Registrar las funciones dadas como implementación de __autoload()

spl_autoload_register

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_register — Registrar las funciones dadas como implementación de __autoload()

Descripción

spl_autoload_register ( callable $autoload_function = ? , bool $throw = true , bool $prepend = false ) : bool

Registra una función con la cola de __autoload proporcionada por spl. Si la cola aún no ha sido activa, será activada.

Si el código contiene una función __autoload() existente, dicha función debe estar explícitamente registrada en la cola de __autoload. Esto es debido a que spl_autoload_register() de hecho reemplazará la caché del motor para la función __autoload() mediante spl_autoload() o spl_autoload_call().

Si deben haber varias funciones de autocarga, spl_autoload_register() lo permite. De hecho, crea una cola de funciones de autocarga y las recorre en el orden en que fueron definidas. Por el contrario, __autoload() sólo puede definirse una vez.

Parámetros

autoload_function

La función de autocarga a registrar. Si no se proporciona ningún parámetro, será registrada la implementación predeterminada de spl_autoload().

throw

Este parámetro especifica si spl_autoload_register() debería lanzar excepciones cuando el parámetro autoload_function no puede ser registrado.

prepend

Si es true, spl_autoload_register() antepondrá el autocargador en la pila de autocarga en vez de posponerlo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Se introdujo el soporte para espacios de nombres.
5.3.0 | Se añadio el parámetro prepend.

Ejemplos

Ejemplo #1 spl_autoload_register() como sustituto de una función __autoload()

<?php

// function __autoload($clase) {
//     include 'clases/' . $clase . '.clase.php';
// }

function mi_autocargador($clase) {
    include 'clases/' . $clase . '.clase.php';
}

spl_autoload_register('mi_autocargador');

// O, utilizar una función anónima, a partir de PHP 5.3.0
spl_autoload_register(function ($clase) {
    include 'clases/' . $clase . '.clase.php';
});

?>

Ejemplo #2 Ejemplo de spl_autoload_register() donde la clase no es cargada

<?php

namespace Foobar;

class Foo {
    static public function test($nombre) {
        print '[['. $nombre .']]';
    }
}

spl_autoload_register(__NAMESPACE__ .'\Foo::test'); // A partir de PHP 5.3.0

new ClaseInexistente;

?>

El resultado del ejemplo sería algo similar a:

[[Foobar\ClaseInexistente]]
Fatal error: Class 'Foobar\ClaseInexistente' not found in ...

Ver también

  • __autoload() - Intenta cargar una clase sin definir


Desregistrar una función dada como implementación de __autoload()

  • « spl_autoload_register
  • spl_autoload »
  • PHP Manual
  • Funciones SPL
  • Desregistrar una función dada como implementación de __autoload()

spl_autoload_unregister

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_unregister — Desregistrar una función dada como implementación de __autoload()

Descripción

spl_autoload_unregister ( mixed $autoload_function ) : bool

Elimina una función de la cola de autocarga. Si la cola está activada y vacía después de eliminar la función dada, será desactivada.

Cuando esta función resulte en la desactivación de la cola, cualquier función de __autoload que existiera previamente no será reactivada.

Parámetros

autoload_function

La función de autocarga a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Implementación predeterminada para __autoload()

  • « spl_autoload_unregister
  • spl_classes »
  • PHP Manual
  • Funciones SPL
  • Implementación predeterminada para __autoload()

spl_autoload

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload — Implementación predeterminada para __autoload()

Descripción

spl_autoload ( string $class_name , string $file_extensions = spl_autoload_extensions() ) : void

Esta función pretende usarse como una implementación predeterminada para __autoload(). Si no se especifica nada más y spl_autoload_register() es llamada sin ningún parámetro, esta función será usada para cualquier llamada posterior a __autoload().

Parámetros

class_name

El nombre de la clase en minúsculas (y espacio de nombres) que va ser instanciado.

file_extensions

Por omisión, comprueba todas las rutas de inclusión que contienen nombres de fichero construidos por el nombre de la clase en minúsculas añadido por las extensiones de nombre de fichero .inc y .php.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una LogicException cuando no se encuentra la clase y no hay otros autocargadores registrados.


Devuelve las clases SPL disponibles

  • « spl_autoload
  • spl_object_hash »
  • PHP Manual
  • Funciones SPL
  • Devuelve las clases SPL disponibles

spl_classes

(PHP 5, PHP 7)

spl_classes — Devuelve las clases SPL disponibles

Descripción

spl_classes ( ) : array

Esta función devuelve un array con las clases SPL actualmente disponibles.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array que contiene las clases SPL actualmente disponibles.

Ejemplos

Ejemplo #1 Ejemplo de spl_classes()

<?php

print_r(spl_classes());

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [ArrayObject] => ArrayObject
    [ArrayIterator] => ArrayIterator
    [CachingIterator] => CachingIterator
    [RecursiveCachingIterator] => RecursiveCachingIterator
    [DirectoryIterator] => DirectoryIterator
    [FilterIterator] => FilterIterator
    [LimitIterator] => LimitIterator
    [ParentIterator] => ParentIterator
    [RecursiveDirectoryIterator] => RecursiveDirectoryIterator
    [RecursiveIterator] => RecursiveIterator
    [RecursiveIteratorIterator] => RecursiveIteratorIterator
    [SeekableIterator] => SeekableIterator
    [SimpleXMLIterator] => SimpleXMLIterator
)


Devuelve el id del hash del objeto dado

  • « spl_classes
  • spl_object_id »
  • PHP Manual
  • Funciones SPL
  • Devuelve el id del hash del objeto dado

spl_object_hash

(PHP 5 >= 5.2.0, PHP 7)

spl_object_hash — Devuelve el id del hash del objeto dado

Descripción

spl_object_hash ( object $obj ) : string

Esta función devuelve un identificador único del objeto. Este id puede ser empleado como una clave hash para almacenar objetos o para identificar un objeto, siempre que el objeto no sea destruído. Una vez que el objeto se destruye, su hash puede ser reutilizado por otros objetos.

Parámetros

object

Cualquier objeto.

Valores devueltos

Un string que es único para cada objeto que existe actualmente y que siempre es el mismo para cada objeto.

Ejemplos

Ejemplo #1 Ejemplo de spl_object_hash()

<?php
$id = spl_object_hash($object);
$storage[$id] = $object;
?>

Notas

Nota:

Cuando un objeto es destruido, este hash puede ser reutilizado para otros objetos.


Return the integer object handle for given object

  • « spl_object_hash
  • Manejo de ficheros »
  • PHP Manual
  • Funciones SPL
  • Return the integer object handle for given object

spl_object_id

(PHP 7 >= 7.2.0)

spl_object_id — Return the integer object handle for given object

Descripción

spl_object_id ( object $obj ) : int

This function returns a unique identifier for the object. The object id is unique for the lifetime of the object. Once the object is destroyed, its id may be reused for other objects. This behavior is similar to spl_object_hash().

Parámetros

object

Any object.

Valores devueltos

An integer identifier that is unique for each currently existing object and is always the same for each object.

Ejemplos

Ejemplo #1 A spl_object_id() example

<?php
$id = spl_object_id($object);
$storage[$id] = $object;
?>

Notas

Nota:

When an object is destroyed, its id may be reused for other objects.


Manejo de ficheros

Tabla de contenidos

  • SplFileInfo
  • SplFileObject
  • SplTempFileObject

SPL proporciona una serie de clases para trabajar con ficheros.


La clase SplFileInfo

(PHP 5 >= 5.1.2, PHP 7)

Introducción

La clase SplFileInfo ofrece un interfaz de alto nivel orientado a objetos para la información de un fichero individual.

Sinopsis de la Clase

SplFileInfo {
/* Métodos */
public __construct ( string $file_name )
public getATime ( ) : int
public getBasename ( string $suffix = ? ) : string
public getCTime ( ) : int
public getExtension ( ) : string
public getFileInfo ( string $class_name = ? ) : SplFileInfo
public getFilename ( ) : string
public getGroup ( ) : int
public getInode ( ) : int
public getLinkTarget ( ) : string
public getMTime ( ) : int
public getOwner ( ) : int
public getPath ( ) : string
public getPathInfo ( string $class_name = ? ) : SplFileInfo
public getPathname ( ) : string
public getPerms ( ) : int
public getRealPath ( ) : string
public getSize ( ) : int
public getType ( ) : string
public isDir ( ) : bool
public isExecutable ( ) : bool
public isFile ( ) : bool
public isLink ( ) : bool
public isReadable ( ) : bool
public isWritable ( ) : bool
public openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject
public setFileClass ( string $class_name = "SplFileObject" ) : void
public setInfoClass ( string $class_name = "SplFileInfo" ) : void
public __toString ( ) : string
}

Tabla de contenidos

  • SplFileInfo::__construct — Construir un objeto nuevo SplFileInfo
  • SplFileInfo::getATime — Obtiene la hora del último acceso al fichero
  • SplFileInfo::getBasename — Obtiene el nombre base del fichero
  • SplFileInfo::getCTime — Obtiene el i-nodo de el cambio de tiempo
  • SplFileInfo::getExtension — Obtiene la extensión del fichero
  • SplFileInfo::getFileInfo — Obtiene un objeto SplFileInfo para el fichero
  • SplFileInfo::getFilename — Obtiene el nombre del fichero
  • SplFileInfo::getGroup — Obtiene el grupo de el fichero
  • SplFileInfo::getInode — Obtiene el i-nodo de el fichero
  • SplFileInfo::getLinkTarget — Obtiene el destino de un enlace del sistema de ficheros
  • SplFileInfo::getMTime — Obtiene la fecha de la última modificación
  • SplFileInfo::getOwner — Obtiene el dueño de el fichero
  • SplFileInfo::getPath — Obtiene la ruta sin el nombre de fichero
  • SplFileInfo::getPathInfo — Obtiene un objeto SplFileInfo para la ruta
  • SplFileInfo::getPathname — Obtiene la ruta de un fichero
  • SplFileInfo::getPerms — Obtiene los permisos del fichero
  • SplFileInfo::getRealPath — Obtiene la ruta absoluta al fichero
  • SplFileInfo::getSize — Obtiene el tamaño de el fichero
  • SplFileInfo::getType — Obtiene el tipo del fichero
  • SplFileInfo::isDir — Dice si el fichero es un directorio
  • SplFileInfo::isExecutable — Comprueba si el fichero es ejecutable
  • SplFileInfo::isFile — Dice is el objeto hace referencia a un fichero normal
  • SplFileInfo::isLink — Comprueba si el fichero es un link
  • SplFileInfo::isReadable — Comprueba si el fichero se puede leer
  • SplFileInfo::isWritable — Comprueba si se puede escribir en el fichero
  • SplFileInfo::openFile — Obtiene un objeto SplFileObject para el fichero
  • SplFileInfo::setFileClass — Establece la clase empleada con SplFileInfo::openFile
  • SplFileInfo::setInfoClass — Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo
  • SplFileInfo::__toString — Devuelve la ruta de el fichero como un string


Construir un objeto nuevo SplFileInfo

  • « SplFileInfo
  • SplFileInfo::getATime »
  • PHP Manual
  • SplFileInfo
  • Construir un objeto nuevo SplFileInfo

SplFileInfo::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__construct — Construir un objeto nuevo SplFileInfo

Descripción

public SplFileInfo::__construct ( string $file_name )

Crea un nuevo objeto para el SplFileInfo nombre_archivo especificado. El fichero no tiene por qué existir, o ser de lectura.

Parámetros

file_name

Ruta del fichero.

Ejemplos

Ejemplo #1 SplFileInfo::__construct() ejemplo

<?php
$info = new SplFileInfo('example.php');
if ($info->isFile()) {
    echo $info->getRealPath();
}
?>


Obtiene la hora del último acceso al fichero

  • « SplFileInfo::__construct
  • SplFileInfo::getBasename »
  • PHP Manual
  • SplFileInfo
  • Obtiene la hora del último acceso al fichero

SplFileInfo::getATime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getATime — Obtiene la hora del último acceso al fichero

Descripción

public SplFileInfo::getATime ( ) : int

Obtiene la hora del último acceso al fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tiempo del ultimo acceso al fichero.

Errores/Excepciones

Lanza RunTimeException en caso de error.

Ver también

  • fileatime() - Obtiene el momento del último acceso a un archivo


Obtiene el nombre base del fichero

  • « SplFileInfo::getATime
  • SplFileInfo::getCTime »
  • PHP Manual
  • SplFileInfo
  • Obtiene el nombre base del fichero

SplFileInfo::getBasename

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getBasename — Obtiene el nombre base del fichero

Descripción

public SplFileInfo::getBasename ( string $suffix = ? ) : string

Este método devuelve el nombre base del fichero, directorio o enlace sin informacion de la ruta de acceso.

Parámetros

suffix

Sufijo opcional para omitir el nombre de la base devuelta.

Valores devueltos

Devuelve el nombre de la base, sin información de la ruta de acceso.

Ejemplos

Ejemplo #1 SplFileInfo::getBasename()ejemplo

<?php
$info = new SplFileInfo('file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename('.txt'));
?>

El resultado del ejemplo sería algo similar a:

string(8) "file.txt"
string(8) "file.txt"
string(4) "file"

Ver también

  • SplFileInfo::getFilename() - Obtiene el nombre del fichero


Obtiene el i-nodo de el cambio de tiempo

  • « SplFileInfo::getBasename
  • SplFileInfo::getExtension »
  • PHP Manual
  • SplFileInfo
  • Obtiene el i-nodo de el cambio de tiempo

SplFileInfo::getCTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getCTime — Obtiene el i-nodo de el cambio de tiempo

Descripción

public SplFileInfo::getCTime ( ) : int

Devuelve el i-nodo de el cambio de tiempo para el fichero. El tiempo es retornado en formato Unix timestamp.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El último cambio del tiempo, en formato Unix timestamp.

Errores/Excepciones

Lanza una RunTimeException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getCTime()

<?php
$info = new SplFileInfo(__FILE__);
echo 'El último cambio ' . date('g:i a', $info->getCTime());
?>

El resultado del ejemplo sería algo similar a:

El último cambio 1:49 pm

Ver también

  • filectime() - Obtiene el momento del último cambio del i-nodo de un archivo


Obtiene la extensión del fichero

  • « SplFileInfo::getCTime
  • SplFileInfo::getFileInfo »
  • PHP Manual
  • SplFileInfo
  • Obtiene la extensión del fichero

SplFileInfo::getExtension

(PHP 5 >= 5.3.6, PHP 7)

SplFileInfo::getExtension — Obtiene la extensión del fichero

Descripción

public SplFileInfo::getExtension ( ) : string

Devuelve la extensión del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string que contiene la extensión del fichero, o un vacío string si el archivo no tiene extensión.

Ejemplos

Ejemplo #1 SplFileInfo::getExtension() ejemplo

<?php

$info = new SplFileInfo('foo.txt');
var_dump($info->getExtension());

$info = new SplFileInfo('photo.jpg');
var_dump($info->getExtension());

$info = new SplFileInfo('something.tar.gz');
var_dump($info->getExtension());

?>

El resultado del ejemplo sería:

string(3) "txt"
string(3) "jpg"
string(2) "gz"

Notas

Nota:

Este método sólo está disponible a partir de PHP 5.3.6. Otra forma de obtener la extensión es usar la función pathinfo().

<?php
$extension = pathinfo($info->getFilename(), PATHINFO_EXTENSION);
?>

Ver también

  • SplFileInfo::getFilename() - Obtiene el nombre del fichero
  • SplFileInfo::getBasename() - Obtiene el nombre base del fichero
  • pathinfo() - Devuelve información acerca de la ruta de un fichero


Obtiene un objeto SplFileInfo para el fichero

  • « SplFileInfo::getExtension
  • SplFileInfo::getFilename »
  • PHP Manual
  • SplFileInfo
  • Obtiene un objeto SplFileInfo para el fichero

SplFileInfo::getFileInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFileInfo — Obtiene un objeto SplFileInfo para el fichero

Descripción

public SplFileInfo::getFileInfo ( string $class_name = ? ) : SplFileInfo

Este método obtiene un objeto SplFileInfo para el fichero de referencia.

Parámetros

class_name

Nombre de una clase SplFileInfo derivada de su uso.

Valores devueltos

Un objeto SplFileInfo creado para el fichero.

Ver también

  • SplFileInfo::setInfoClass() - Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo


Obtiene el nombre del fichero

  • « SplFileInfo::getFileInfo
  • SplFileInfo::getGroup »
  • PHP Manual
  • SplFileInfo
  • Obtiene el nombre del fichero

SplFileInfo::getFilename

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFilename — Obtiene el nombre del fichero

Descripción

public SplFileInfo::getFilename ( ) : string

Obtiene el nombre del fichero sin ningún tipo de información de la ruta de acceso.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre del fichero.

Ejemplos

Ejemplo #1 SplFileInfo::getFilename() ejemplo

<?php
$info = new SplFileInfo('foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('/path/to/foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/svn.php');
var_dump($info->getFilename());
?>

El resultado del ejemplo sería algo similar a:

string(7) "foo.txt"
string(7) "foo.txt"
string(0) ""
string(7) "svn.php"

Ver también

  • SplFileInfo::getBasename() - Obtiene el nombre base del fichero


Obtiene el grupo de el fichero

  • « SplFileInfo::getFilename
  • SplFileInfo::getInode »
  • PHP Manual
  • SplFileInfo
  • Obtiene el grupo de el fichero

SplFileInfo::getGroup

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getGroup — Obtiene el grupo de el fichero

Descripción

public SplFileInfo::getGroup ( ) : int

Obtiene el grupo del fichero. El ID del grupo es retornado en formato numérico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El ID del grupo en formato numérico.

Errores/Excepciones

Lanza una RuntimeException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getGroup()

<?php
$info = new SplFileInfo(__FILE__);
print_r(posix_getgrgid($info->getGroup()));
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • posix_getgrgid() - Devolver información sobre un grupo mediante un id de grupo


Obtiene el i-nodo de el fichero

  • « SplFileInfo::getGroup
  • SplFileInfo::getLinkTarget »
  • PHP Manual
  • SplFileInfo
  • Obtiene el i-nodo de el fichero

SplFileInfo::getInode

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getInode — Obtiene el i-nodo de el fichero

Descripción

public SplFileInfo::getInode ( ) : int

Obtiene el número de i-nodo de el objeto filesystem.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de i-nodo de el objeto filesystem.

Errores/Excepciones

Lanza una RuntimeException en caso de error.

Ver también

  • fileinode() - Obtiene el i-nodo del archivo


Obtiene el destino de un enlace del sistema de ficheros

  • « SplFileInfo::getInode
  • SplFileInfo::getMTime »
  • PHP Manual
  • SplFileInfo
  • Obtiene el destino de un enlace del sistema de ficheros

SplFileInfo::getLinkTarget

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getLinkTarget — Obtiene el destino de un enlace del sistema de ficheros

Descripción

public SplFileInfo::getLinkTarget ( ) : string

Obtiene el destino de un enlace del sistema de ficheros.

Nota:

El destino no puede ser una ruta real en el sistema de ficheros. Use SplFileInfo::getRealPath() para determinar la ruta verdadera en el sistema de fucheros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el destino de el enlace del sistema de ficheros.

Errores/Excepciones

Lanza una RuntimeException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getLinkTarget()

<?php
$info = new SplFileInfo('/Users/bbieber/workspace');
if ($info->isLink()) {
    var_dump($info->getLinkTarget());
    var_dump($info->getRealPath());
}
?>

El resultado del ejemplo sería algo similar a:

string(19) "Documents/workspace"
string(34) "/Users/bbieber/Documents/workspace"

Ver también

  • SplFileInfo::isLink() - Comprueba si el fichero es un link
  • SplFileInfo::getRealPath() - Obtiene la ruta absoluta al fichero


Obtiene la fecha de la última modificación

  • « SplFileInfo::getLinkTarget
  • SplFileInfo::getOwner »
  • PHP Manual
  • SplFileInfo
  • Obtiene la fecha de la última modificación

SplFileInfo::getMTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getMTime — Obtiene la fecha de la última modificación

Descripción

public SplFileInfo::getMTime ( ) : int

Devuelve el tiempo cuando el contenido de el fichero ha sido cambiado. El tiempo retornado en formato Unix timestamp.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la fecha de modificación de el fichero, en formato Unix timestamp.

Ver también

  • filemtime() - Obtiene el momento de la última modificación de un archivo


Obtiene el dueño de el fichero

  • « SplFileInfo::getMTime
  • SplFileInfo::getPath »
  • PHP Manual
  • SplFileInfo
  • Obtiene el dueño de el fichero

SplFileInfo::getOwner

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getOwner — Obtiene el dueño de el fichero

Descripción

public SplFileInfo::getOwner ( ) : int

Obtiene el dueño de el fichero. El ID del dueño retornado en formato numérico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El id del dueño en formato numérico.

Errores/Excepciones

Lanza una RuntimeException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getOwner()

<?php
$info = new SplFileInfo('file.txt');
print_r(posix_getpwuid($info->getOwner()));
?>

Ver también

  • posix_getpwuid() - Devolver información sobre un usuario mediante su id de usuario
  • SplFileInfo::getGroup() - Obtiene el grupo de el fichero


Obtiene la ruta sin el nombre de fichero

  • « SplFileInfo::getOwner
  • SplFileInfo::getPathInfo »
  • PHP Manual
  • SplFileInfo
  • Obtiene la ruta sin el nombre de fichero

SplFileInfo::getPath

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPath — Obtiene la ruta sin el nombre de fichero

Descripción

public SplFileInfo::getPath ( ) : string

Devuelve la ruta de el fichero, omitiendo el nombre del fichero y cualquier barra.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta a el fichero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getPath()

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPath());

$info = new SplFileInfo('/usr/');
var_dump($info->getPath());?>

El resultado del ejemplo sería algo similar a:

string(8) "/usr/bin"
string(4) "/usr"

Ver también

  • SplFileInfo::getRealPath() - Obtiene la ruta absoluta al fichero
  • SplFileInfo::getFilename() - Obtiene el nombre del fichero
  • SplFileInfo::getPathInfo() - Obtiene un objeto SplFileInfo para la ruta


Obtiene un objeto SplFileInfo para la ruta

  • « SplFileInfo::getPath
  • SplFileInfo::getPathname »
  • PHP Manual
  • SplFileInfo
  • Obtiene un objeto SplFileInfo para la ruta

SplFileInfo::getPathInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathInfo — Obtiene un objeto SplFileInfo para la ruta

Descripción

public SplFileInfo::getPathInfo ( string $class_name = ? ) : SplFileInfo

Obtiene un objeto SplFileInfo para el padre de el fichero actual.

Parámetros

class_name

Nombre de una clase SplFileInfo derivada a usar.

Valores devueltos

Devuelve un objeto SplFileInfo para la ruta padre de el fichero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getPathInfo()

<?php
$info = new SplFileInfo('/usr/bin/php');
$parent_info = $info->getPathInfo();
var_dump($parent_info->getRealPath());
?>

El resultado del ejemplo sería algo similar a:

string(8) "/usr/bin"

Ver también

  • SplFileInfo::setInfoClass() - Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo


Obtiene la ruta de un fichero

  • « SplFileInfo::getPathInfo
  • SplFileInfo::getPerms »
  • PHP Manual
  • SplFileInfo
  • Obtiene la ruta de un fichero

SplFileInfo::getPathname

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathname — Obtiene la ruta de un fichero

Descripción

public SplFileInfo::getPathname ( ) : string

Devuelve la ruta de el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

la ruta de el fichero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getPathname()

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPathname());
?>

El resultado del ejemplo sería algo similar a:

string(12) "/usr/bin/php"

Ver también

  • SplFileInfo::getRealPath() - Obtiene la ruta absoluta al fichero


Obtiene los permisos del fichero

  • « SplFileInfo::getPathname
  • SplFileInfo::getRealPath »
  • PHP Manual
  • SplFileInfo
  • Obtiene los permisos del fichero

SplFileInfo::getPerms

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPerms — Obtiene los permisos del fichero

Descripción

public SplFileInfo::getPerms ( ) : int

Obtiene los permisos del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los permisos de el fichero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getPerms()

<?php
$info = new SplFileInfo('/tmp');
echo substr(sprintf('%o', $info->getPerms()), -4);

$info = new SplFileInfo(__FILE__);
echo substr(sprintf('%o', $info->getPerms()), -4);
?>

El resultado del ejemplo sería algo similar a:

1777
0644


Obtiene la ruta absoluta al fichero

  • « SplFileInfo::getPerms
  • SplFileInfo::getSize »
  • PHP Manual
  • SplFileInfo
  • Obtiene la ruta absoluta al fichero

SplFileInfo::getRealPath

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getRealPath — Obtiene la ruta absoluta al fichero

Descripción

public SplFileInfo::getRealPath ( ) : string

Este método expande todos los enlaces simbólicos, resuelve las referencias relativas y retorna la ruta real al fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta al fichero, o false si el fichero no existe.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getRealPath()

<?php
$info = new SplFileInfo('/..//./../../'.__FILE__);
var_dump($info->getRealPath());

$info = new SplFileInfo('/tmp');
var_dump($info->getRealPath());

$info = new SplFileInfo('/I/Do/Not/Exist');
var_dump($info->getRealPath());

$info = new SplFileInfo('php://output');
var_dump($info->getRealPath());

$info = new SplFileInfo("");
var_dump($info->getRealPath());
?>

El resultado del ejemplo sería algo similar a:

string(28) "/private/tmp/phptempfile.php"
string(12) "/private/tmp"
bool(false)
bool(false)
string(12) "/private/tmp"

Ver también

  • SplFileInfo::isLink() - Comprueba si el fichero es un link
  • realpath() - Devuelve el nombre de la ruta absoluta canonizado


Obtiene el tamaño de el fichero

  • « SplFileInfo::getRealPath
  • SplFileInfo::getType »
  • PHP Manual
  • SplFileInfo
  • Obtiene el tamaño de el fichero

SplFileInfo::getSize

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getSize — Obtiene el tamaño de el fichero

Descripción

public SplFileInfo::getSize ( ) : int

Devuelve el tamaño de el fichero en bytes para el fichero referenciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El tamaño del fichero en bytes.

Errores/Excepciones

Lanza una RuntimeException si el fichero no existe o en caso de error.

Ver también

  • filesize() - Obtiene el tamaño de un fichero


Obtiene el tipo del fichero

  • « SplFileInfo::getSize
  • SplFileInfo::isDir »
  • PHP Manual
  • SplFileInfo
  • Obtiene el tipo del fichero

SplFileInfo::getType

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getType — Obtiene el tipo del fichero

Descripción

public SplFileInfo::getType ( ) : string

Devuelve el tipo de el fichero referenciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un string representando el tipo de la entrada. Puede ser file, link, o dir

Errores/Excepciones

Lanza una RuntimeException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::getType()

<?php

$info = new SplFileInfo(__FILE__);
echo $info->getType().PHP_EOL;

$info = new SplFileInfo(dirname(__FILE__));
echo $info->getType();

?>

El resultado del ejemplo sería algo similar a:

file
dir


Dice si el fichero es un directorio

  • « SplFileInfo::getType
  • SplFileInfo::isExecutable »
  • PHP Manual
  • SplFileInfo
  • Dice si el fichero es un directorio

SplFileInfo::isDir

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isDir — Dice si el fichero es un directorio

Descripción

public SplFileInfo::isDir ( ) : bool

Este método puede ser usado para determinar si el fichero es un directorio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si es un directorio, false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::isDir()

<?php
$d = new SplFileInfo(dirname(__FILE__));
var_dump($d->isDir());

$d = new SplFileInfo(__FILE__);
var_dump($d->isDir());
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)


Comprueba si el fichero es ejecutable

  • « SplFileInfo::isDir
  • SplFileInfo::isFile »
  • PHP Manual
  • SplFileInfo
  • Comprueba si el fichero es ejecutable

SplFileInfo::isExecutable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isExecutable — Comprueba si el fichero es ejecutable

Descripción

public SplFileInfo::isExecutable ( ) : bool

Comprueba si el fichero es ejecutable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si es ejecutable, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::isExecutable()

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->isExecutable());

$info = new SplFileInfo('/usr/bin');
var_dump($info->isExecutable());

$info = new SplFileInfo('foo');
var_dump($info->isExecutable());
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(false)


Dice is el objeto hace referencia a un fichero normal

  • « SplFileInfo::isExecutable
  • SplFileInfo::isLink »
  • PHP Manual
  • SplFileInfo
  • Dice is el objeto hace referencia a un fichero normal

SplFileInfo::isFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isFile — Dice is el objeto hace referencia a un fichero normal

Descripción

public SplFileInfo::isFile ( ) : bool

Comprueba si el fichero que el objecto SplFileInfo hace referencia existe es un fichero regular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el fichero existe y si es un fichero normal (no un enlace), false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::isFile()

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isFile());

$info = new SplFileInfo(dirname(__FILE__));
var_dump($info->isFile());
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)


Comprueba si el fichero es un link

  • « SplFileInfo::isFile
  • SplFileInfo::isReadable »
  • PHP Manual
  • SplFileInfo
  • Comprueba si el fichero es un link

SplFileInfo::isLink

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isLink — Comprueba si el fichero es un link

Descripción

public SplFileInfo::isLink ( ) : bool

Use este método para comprobar si el fichero referenciado por el objeto SplFileInfo es un link.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el fichero es un link, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::isLink()

<?php
$info = new SplFileInfo('/path/to/symlink');
if ($info->isLink()) {
    echo 'The real path is '.$info->getRealPath();
}
?>

Ver también

  • SplFileInfo::getRealPath() - Obtiene la ruta absoluta al fichero


Comprueba si el fichero se puede leer

  • « SplFileInfo::isLink
  • SplFileInfo::isWritable »
  • PHP Manual
  • SplFileInfo
  • Comprueba si el fichero se puede leer

SplFileInfo::isReadable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isReadable — Comprueba si el fichero se puede leer

Descripción

public SplFileInfo::isReadable ( ) : bool

Comprueba si el fichero se puede leer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se puede leer, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::isReadable()

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isReadable());

$info = new SplFileInfo('foo');
var_dump($info->isReadable());
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)


Comprueba si se puede escribir en el fichero

  • « SplFileInfo::isReadable
  • SplFileInfo::openFile »
  • PHP Manual
  • SplFileInfo
  • Comprueba si se puede escribir en el fichero

SplFileInfo::isWritable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isWritable — Comprueba si se puede escribir en el fichero

Descripción

public SplFileInfo::isWritable ( ) : bool

Comprueba si se puede escribir en el fichero actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se puede escribir, en caso contrario false;


Obtiene un objeto SplFileObject para el fichero

  • « SplFileInfo::isWritable
  • SplFileInfo::setFileClass »
  • PHP Manual
  • SplFileInfo
  • Obtiene un objeto SplFileObject para el fichero

SplFileInfo::openFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::openFile — Obtiene un objeto SplFileObject para el fichero

Descripción

public SplFileInfo::openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject

Crea un object SplFileObject de el fichero. Esto es útil porque SplFileObject contiene otros métodos para manipular el fichero mientras que SplFileInfo sólo es útil para obtener información, por ejemplo si el fichero tiene permisos de escritura.

Parámetros

open_mode

El modo para abrir el fichero. Véase la documentación de fopen() para una descripción de los posibles modos. Por omisión es de sólo lectura.

use_include_path

Cuando está definido a true, el fichero también es buscado dentro de include_path

context

Se refiere a context sección del manual para una descripción de contexts.

Valores devueltos

El fichero abierto como un objeto SplFileObject.

Errores/Excepciones

Lanza una RuntimeException si el fichero no se puede abrir (p.ej. permisos insuficientes).

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::openFile()

<?php
$fileinfo = new SplFileInfo('/tmp/foo.txt');

if ($fileinfo->isWritable()) {

    $fileobj = $fileinfo->openFile('a');

    $fileobj->fwrite("Añadiendo este texto de prueba");
}
?>

Ver también

  • SplFileObject
  • stream_context_create() - Crear un contexto de flujo
  • fopen() - Abre un fichero o un URL


Establece la clase empleada con SplFileInfo::openFile

  • « SplFileInfo::openFile
  • SplFileInfo::setInfoClass »
  • PHP Manual
  • SplFileInfo
  • Establece la clase empleada con SplFileInfo::openFile

SplFileInfo::setFileClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setFileClass — Establece la clase empleada con SplFileInfo::openFile()

Descripción

public SplFileInfo::setFileClass ( string $class_name = "SplFileObject" ) : void

Este método se emplea para establecer una clase propia que será utilizada cuando se invoque a SplFileInfo::openFile(). El nombre de la clase pasado a este método debe ser SplFileObject o una clase derivada de SplFileObject.

Parámetros

class_name

El nombre de la clase a emplear cuando se invoca a SplFileInfo::openFile().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::setFileClass()

<?php
// Crear una clase que extiende a SplFileObject
class MiFoo extends SplFileObject {}

$info = new SplFileInfo(__FILE__);
// Establecer la clase a usar
$info->setFileClass('MiFoo');
var_dump($info->openFile());
?>

El resultado del ejemplo sería algo similar a:

object(MiFoo)#2 (0) { }

Ver también

  • SplFileInfo::openFile() - Obtiene un objeto SplFileObject para el fichero


Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo

  • « SplFileInfo::setFileClass
  • SplFileInfo::__toString »
  • PHP Manual
  • SplFileInfo
  • Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo

SplFileInfo::setInfoClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setInfoClass — Establece la clase empleada con SplFileInfo::getFileInfo() y SplFileInfo::getPathInfo()

Descripción

public SplFileInfo::setInfoClass ( string $class_name = "SplFileInfo" ) : void

Este método se emplea para establecer una clase propia que será utilizada cuando se invoque a SplFileInfo::getFileInfo() y SplFileInfo::getPathInfo(). El nombre de la clase pasado a este método debe ser SplFileInfo o una clase derivada de SplFileInfo.

Parámetros

class_name

El nombre de la clase a emplear cuando se invoca a SplFileInfo::getFileInfo() y SplFileInfo::getPathInfo().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::setFileClass()

<?php
// Crear una clase que extiende a SplFileInfo
class MiFoo extends SplFileInfo {}

$info = new SplFileInfo('foo');
// Establecer el nombre de clase a usar
$info->setInfoClass('MiFoo');
var_dump($info->getFileInfo());
?>

El resultado del ejemplo sería algo similar a:

object(MiFoo)#2 (0) { }

Ver también

  • SplFileInfo::getFileInfo() - Obtiene un objeto SplFileInfo para el fichero


Devuelve la ruta de el fichero como un string

  • « SplFileInfo::setInfoClass
  • SplFileObject »
  • PHP Manual
  • SplFileInfo
  • Devuelve la ruta de el fichero como un string

SplFileInfo::__toString

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__toString — Devuelve la ruta de el fichero como un string

Descripción

public SplFileInfo::__toString ( ) : string

Este método retornará el nombre de fichero de el fichero referenciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la ruta a el fichero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileInfo::__toString()

<?php
$info = new SplFileInfo('foo');
var_dump($info->__toString());
echo $info.PHP_EOL;

$info = new SplFileInfo('/usr/bin/php');
var_dump($info->__toString());
echo $info.PHP_EOL;
?>

El resultado del ejemplo sería algo similar a:

string(3) "foo"
foo
string(12) "/usr/bin/php"
/usr/bin/php


La clase SplFileObject

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La clase SplFileObject ofrece una interfaz orientada a objetos para un fichero.

Sinopsis de la Clase

SplFileObject extends SplFileInfo implements RecursiveIterator , SeekableIterator {
/* Constantes */
const integer DROP_NEW_LINE = 1 ;
const integer READ_AHEAD = 2 ;
const integer SKIP_EMPTY = 4 ;
const integer READ_CSV = 8 ;
/* Métodos */
public __construct ( string $filename , string $open_mode = "r" , bool $use_include_path = false , resource $context = ? )
public current ( ) : string|array
public eof ( ) : bool
public fflush ( ) : bool
public fgetc ( ) : string
public fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array
public fgets ( ) : string
public fgetss ( string $allowable_tags = ? ) : string
public flock ( int $operation , int &$wouldblock = ? ) : bool
public fpassthru ( ) : int
public fputcsv ( array $fields , string $delimiter = "," , string $enclosure = '"' , string $escape = "\" ) : int
public fread ( int $length ) : string
public fscanf ( string $format , mixed &$... = ? ) : mixed
public fseek ( int $offset , int $whence = SEEK_SET ) : int
public fstat ( ) : array
public ftell ( ) : int
public ftruncate ( int $size ) : bool
public fwrite ( string $str , int $length = ? ) : int
public getChildren ( ) : void
public getCsvControl ( ) : array
public getFlags ( ) : int
public getMaxLineLen ( ) : int
public hasChildren ( ) : bool
public key ( ) : int
public next ( ) : void
public rewind ( ) : void
public seek ( int $line_pos ) : void
public setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void
public setFlags ( int $flags ) : void
public setMaxLineLen ( int $max_len ) : void
public valid ( ) : bool
/* Métodos heredados */
public SplFileInfo::getATime ( ) : int
public SplFileInfo::getBasename ( string $suffix = ? ) : string
public SplFileInfo::getCTime ( ) : int
public SplFileInfo::getExtension ( ) : string
public SplFileInfo::getFileInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getFilename ( ) : string
public SplFileInfo::getGroup ( ) : int
public SplFileInfo::getInode ( ) : int
public SplFileInfo::getLinkTarget ( ) : string
public SplFileInfo::getMTime ( ) : int
public SplFileInfo::getOwner ( ) : int
public SplFileInfo::getPath ( ) : string
public SplFileInfo::getPathInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getPathname ( ) : string
public SplFileInfo::getPerms ( ) : int
public SplFileInfo::getRealPath ( ) : string
public SplFileInfo::getSize ( ) : int
public SplFileInfo::getType ( ) : string
public SplFileInfo::isDir ( ) : bool
public SplFileInfo::isExecutable ( ) : bool
public SplFileInfo::isFile ( ) : bool
public SplFileInfo::isLink ( ) : bool
public SplFileInfo::isReadable ( ) : bool
public SplFileInfo::isWritable ( ) : bool
public SplFileInfo::openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject
public SplFileInfo::setFileClass ( string $class_name = "SplFileObject" ) : void
public SplFileInfo::setInfoClass ( string $class_name = "SplFileInfo" ) : void
public SplFileInfo::__toString ( ) : string
}

Constantes predefinidas

SplFileObject::DROP_NEW_LINE

Colocar nuevas líneas al final de una línea.

SplFileObject::READ_AHEAD

Leer sobre rewind/next.

SplFileObject::SKIP_EMPTY

Saltar líneas vacías en el fichero. Esto requiere que la bandera READ_AHEAD esté activada para que funcione como se tenía previsto.

SplFileObject::READ_CSV

Leer líneas como filas CSV.

Historial de cambios

Versión | Descripción
5.3.9 | El valor de SplFileObject::SKIP_EMPTY cambió a 4. Anteriormente, el valor era 6.

Tabla de contenidos

  • SplFileObject::__construct — Construye un nuevo objeto de fichero
  • SplFileObject::current — Recupera la línea actual del fichero
  • SplFileObject::eof — Comprueba si es el final del fichero
  • SplFileObject::fflush — Vuelca el resultado en el fichero
  • SplFileObject::fgetc — Obtiene un caracter del fichero
  • SplFileObject::fgetcsv — Obtiene la línea del archivo y analiza como campos CSV
  • SplFileObject::fgets — Obtener la línea de el fichero
  • SplFileObject::fgetss — Obtiene la línea de el fichero y elimina etiquetas HTML
  • SplFileObject::flock — Bloqueo de ficheros portable
  • SplFileObject::fpassthru — Imprimir todos los datos restantes en un apuntador de fichero
  • SplFileObject::fputcsv — Escribir un array de campos como una línea CSV
  • SplFileObject::fread — Leer un fichero
  • SplFileObject::fscanf — Analiza la entrada de un fichero de acuerdo a un formato
  • SplFileObject::fseek — Busca una posiciónn
  • SplFileObject::fstat — Obtiene información de el fichero
  • SplFileObject::ftell — Devuelve la posición del fichero actual
  • SplFileObject::ftruncate — Trunca el archivo a una longitud dada
  • SplFileObject::fwrite — Escribe en el fichero
  • SplFileObject::getChildren — Ningún propósito
  • SplFileObject::getCsvControl — Obtiene el carácter delimitador, el circundante y de escape para campos CSV
  • SplFileObject::getCurrentLine — Alias de SplFileObject::fgets
  • SplFileObject::getFlags — Obtener las flags de SplFileObject
  • SplFileObject::getMaxLineLen — Obtener la longitud máxima de línea
  • SplFileObject::hasChildren — SplFileObject no tiene hijos
  • SplFileObject::key — Obtiene el número de línea
  • SplFileObject::next — Leer la siguiente línea
  • SplFileObject::rewind — Rebobina el fichero hasta la primera línea
  • SplFileObject::seek — Mueve el apuntador interno a la línea específicada
  • SplFileObject::setCsvControl — Establece el carácter delimitador, el circundante y el de escape para campos CSV
  • SplFileObject::setFlags — Establece flags para el SplFileObject
  • SplFileObject::setMaxLineLen — Establecer la longitud máxima de una línea
  • SplFileObject::__toString — Alias de SplFileObject::fgets
  • SplFileObject::valid — Comprueba si el final del finchero ha sido alcanzado


Construye un nuevo objeto de fichero

  • « SplFileObject
  • SplFileObject::current »
  • PHP Manual
  • SplFileObject
  • Construye un nuevo objeto de fichero

SplFileObject::__construct

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__construct — Construye un nuevo objeto de fichero

Descripción

public SplFileObject::__construct ( string $filename , string $open_mode = "r" , bool $use_include_path = false , resource $context = ? )

Construye un nuevo objeto de fichero.

Parámetros

filename

El fichero a leer.

Sugerencia

Se puede emplear un URL como nombre de fichero con esta función si las envolturas de fopen han sido activadas. Véase fopen() para más información de cómo especificar el nombre de fichero. Véanse las Protocolos y Envolturas soportados; continen enlaces con información sobre las diferentes capacidades que tienen las envolturas, notas sobre su empleo, e información de cualquier variable predefinida que podría proporcionarse.

open_mode

El modo en el que abrir el fichero. Véase fopen() para una lista de los modos permitidos.

use_include_path

Si se va a buscar filename en el include_path.

context

Un contexto válido creado con stream_context_create().

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una RuntimeException si filename no se puede abrir.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::__construct()

Este ejemplo abre el fichero actual y recorre su contenido, línea por línea.

<?php
$fichero = new SplFileObject(__FILE__);
foreach ($fichero as $num_línea => $línea) {
    echo "La línea $num_línea es $línea";
}
?>

El resultado del ejemplo sería algo similar a:

La línea 0 es <?php
La línea 1 es $fichero = new SplFileObject(__FILE__);
La línea 2 es foreach ($fichero as $num_línea => $línea) {
La línea 3 es     echo "La línea $num_línea es $línea";
La línea 4 es }
La línea 5 es ?>

Ver también

  • SplFileInfo::openFile() - Obtiene un objeto SplFileObject para el fichero
  • fopen() - Abre un fichero o un URL


Recupera la línea actual del fichero

  • « SplFileObject::__construct
  • SplFileObject::eof »
  • PHP Manual
  • SplFileObject
  • Recupera la línea actual del fichero

SplFileObject::current

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::current — Recupera la línea actual del fichero

Descripción

public SplFileObject::current ( ) : string|array

Recupera la línea actual del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Recupera la línea actual del fichero. Si la flag SplFileObject::READ_CSV está establecida, este método devuelve un array conteniendo la línea actual analizada como datos CSV.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::current()

<?php
$fichero = new SplFileObject(__FILE__);
foreach ($fichero as $k => $linea) {
   echo ($fichero->key() + 1) . ': ' . $fichero->current();
}
?>

El resultado del ejemplo sería algo similar a:

1: <?php
2: $fichero = new SplFileObject(__FILE__);
3: foreach ($fichero as $linea) {
4:     echo ($fichero->key() + 1) . ': ' . $fichero->current();
5: }
6: ?>

Ver también

  • SplFileObject::key() - Obtiene el número de línea
  • SplFileObject::seek() - Mueve el apuntador interno a la línea específicada
  • SplFileObject::next() - Leer la siguiente línea
  • SplFileObject::rewind() - Rebobina el fichero hasta la primera línea
  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado


Comprueba si es el final del fichero

  • « SplFileObject::current
  • SplFileObject::fflush »
  • PHP Manual
  • SplFileObject
  • Comprueba si es el final del fichero

SplFileObject::eof

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::eof — Comprueba si es el final del fichero

Descripción

public SplFileObject::eof ( ) : bool

Determina si el final de el fichero ha sido alcanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si es el final de el fichero, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::eof()

<?php
$fichero = new SplFileObject("frutas.txt");
while ( ! $fichero->eof()) {
    echo $fichero->fgets();
}
?>

El resultado del ejemplo sería algo similar a:

manzana
banana
cereza
naranja
baya

Ver también

  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado
  • feof() - Comprueba si el puntero a un archivo está al final del archivo


Vuelca el resultado en el fichero

  • « SplFileObject::eof
  • SplFileObject::fgetc »
  • PHP Manual
  • SplFileObject
  • Vuelca el resultado en el fichero

SplFileObject::fflush

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fflush — Vuelca el resultado en el fichero

Descripción

public SplFileObject::fflush ( ) : bool

Fuerza a escribir en todo el búfer de salida al fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fflush()

<?php
$file = new SplFileObject('variado.txt', 'r+');
$file->rewind();
$file->fwrite("Foo");
$file->fflush();
$file->ftruncate($file->ftell());
?>

Ver también

  • SplFileObject::fwrite() - Escribe en el fichero


Obtiene un caracter del fichero

  • « SplFileObject::fflush
  • SplFileObject::fgetcsv »
  • PHP Manual
  • SplFileObject
  • Obtiene un caracter del fichero

SplFileObject::fgetc

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetc — Obtiene un caracter del fichero

Descripción

public SplFileObject::fgetc ( ) : string

Obtiene un caracter del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string conteniendo un solo caracter leído de el fichero o false si es el final del fichero.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fgetc()

<?php
$fichero = new SplFileObject('texto.txt');
while (false !== ($char = $fichero->fgetc())) {
    echo "$char\n";
}
?>

Ver también

  • SplFileObject::fgets() - Obtener la línea de el fichero


Obtiene la línea del archivo y analiza como campos CSV

  • « SplFileObject::fgetc
  • SplFileObject::fgets »
  • PHP Manual
  • SplFileObject
  • Obtiene la línea del archivo y analiza como campos CSV

SplFileObject::fgetcsv

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetcsv — Obtiene la línea del archivo y analiza como campos CSV

Descripción

public SplFileObject::fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array

Obtiene una línea del archivo que está en formato CSV y devuelve un array que contiene los campos leídos.

Nota:

Esta función tiene en cuenta los ajustes de localización. Si LC_CTYPE es p.e. en_US.UTF-8, los archivos en codificaciones de un byte pueden ser leídos erróneamente por esta función.

Parámetros

delimiter

El delimitador de campo (un solo carácter). El valor por defecto es una coma o el valor establecido usando SplFileObject::setCsvControl().

enclosure

El carácter circundante de cada campo (sólo un carácter). Por omisión, son comillas dobles o el valor establecido por SplFileObject::setCsvControl().

escape

El carácter de escape (a lo sumo un carácter). Por defecto es una barra invertida (\) o el valor establecido usando SplFileObject::setCsvControl(). Un string vacío ("") desactiva el mecanismo de escape propio.

Nota: Normalmente un carácter enclosure se escapa dentro de un campo duplicándolo; sin embargo, el carácter escape puede ser usado como una alternativa. Así que para los valores de parámetros por defecto "" y \" tienen el mismo significado. Aparte de permitir espacar el carácter enclosure el carácter escape no tiene un significado especial; ni siquiera está destinado a escapar de sí mismo.

Valores devueltos

Devuelve un array indexado que contiene los campos que se leen, o false en caso de error.

Nota:

Una línea en blanco en un archivo CSV será devuelto como un array que comprende un único null a menos que se utilice SplFileObject::SKIP_EMPTY | SplFileObject::DROP_NEW_LINE, en cuyo caso se saltan las líneas vacías.

Historial de cambios

Versión | Descripción
7.4.0 | El parámetro escape ahora también acepta un string vacío para desactivar el mecanismo de escape propio.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fgetcsv()

<?php
$file = new SplFileObject("data.csv");
while (!$file->eof()) {
    var_dump($file->fgetcsv());
}
?>

Ejemplo #2 Ejemplo de SplFileObject::READ_CSV

<?php
$file = new SplFileObject("animals.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $row) {
    list($animal, $class, $legs) = $row;
    printf("A %s is a %s with %d legs\n", $animal, $class, $legs);
}
?>

El contenido de animals.csv

crocodile,reptile,4
dolphin,mammal,0
duck,bird,2
koala,mammal,4
salmon,fish,0

El resultado del ejemplo sería algo similar a:

A crocodile is a reptile with 4 legs
A dolphin is a mammal with 0 legs
A duck is a bird with 2 legs
A koala is a mammal with 4 legs
A salmon is a fish with 0 legs

Ver también

  • SplFileObject::setCsvControl() - Establece el carácter delimitador, el circundante y el de escape para campos CSV
  • SplFileObject::setFlags() - Establece flags para el SplFileObject
  • SplFileObject::READ_CSV
  • SplFileObject::current() - Recupera la línea actual del fichero


Obtener la línea de el fichero

  • « SplFileObject::fgetcsv
  • SplFileObject::fgetss »
  • PHP Manual
  • SplFileObject
  • Obtener la línea de el fichero

SplFileObject::fgets

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgets — Obtener la línea de el fichero

Descripción

public SplFileObject::fgets ( ) : string

Obtener la línea de el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string conteniendo la siguiente línea de el fichero, o false en caso de error.

Errores/Excepciones

Lanza una RuntimeException si el fichero no puede ser leído.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fgets()

Este ejemplo simplemente imprime el contenido de texto.txt línea por línea.

<?php
$fichero = new SplFileObject("texto.txt");
while (!$fichero->eof()) {
    echo $fichero->fgets();
}
?>

Ver también

  • fgets() - Obtiene una línea desde el puntero a un fichero
  • SplFileObject::fgetss() - Obtiene la línea de el fichero y elimina etiquetas HTML
  • SplFileObject::fgetc() - Obtiene un caracter del fichero
  • SplFileObject::current() - Recupera la línea actual del fichero


Obtiene la línea de el fichero y elimina etiquetas HTML

  • « SplFileObject::fgets
  • SplFileObject::flock »
  • PHP Manual
  • SplFileObject
  • Obtiene la línea de el fichero y elimina etiquetas HTML

SplFileObject::fgetss

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetss — Obtiene la línea de el fichero y elimina etiquetas HTML

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.3.0. Su uso está totalmente desaconsejado.

Descripción

public SplFileObject::fgetss ( string $allowable_tags = ? ) : string

Idéntico a SplFileObject::fgets(), excepto que SplFileObject::fgetss() intenta eliminar las etiquetas HTML y PHP de el texto que se lee. La función mantiene el estado de análisis sintáctico de llamada a llamada, y como tal no es equivalente a la llamada strip_tags() sobre el valor de retorno de SplFileObject::fgets().

Parámetros

allowable_tags

Parámetro opcional para especificar etiquetas que no deben ser eliminadas.

Valores devueltos

Devuelve un string conteniendo la siguiente línea de el fichero con el código HTML y PHP eliminado, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fgetss()

<?php
$str = <<<EOD
<html><body>
 <p>Bienvenid@! Hoy es el <?php echo(date('jS')); ?> de <?= date('F'); ?>.</p>
</body></html>
Texto fuera del bloque HTML.
EOD;
file_put_contents("ejemplo.php", $str);

$fichero = new SplFileObject("ejemplo.php");
while (!$fichero->eof()) {
    echo $fichero->fgetss();
}
?>

El resultado del ejemplo sería algo similar a:

Bienvenid@! Hoy es el  de .

Texto fuera del bloque HTML.

Ver también

  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • SplFileObject::fgets() - Obtener la línea de el fichero
  • SplFileObject::fgetc() - Obtiene un caracter del fichero
  • SplFileObject::current() - Recupera la línea actual del fichero
  • El filtro string.strip_tags


Bloqueo de ficheros portable

  • « SplFileObject::fgetss
  • SplFileObject::fpassthru »
  • PHP Manual
  • SplFileObject
  • Bloqueo de ficheros portable

SplFileObject::flock

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::flock — Bloqueo de ficheros portable

Descripción

public SplFileObject::flock ( int $operation , int &$wouldblock = ? ) : bool

Bloquea o desbloquea el fichero de la misma manera portable que flock().

Parámetros

operation

operation es una operación de las siguientes:

  • LOCK_SH para adquirir un bloqueo compartido (lectura).
  • LOCK_EX para adquirir un bloqueo exclusivo (escritura).
  • LOCK_UN para liberar un bloqueo (compartido o exclusivo).
  • LOCK_NB para no esperar mientras se adquiere el bloqueo.

wouldblock

Establecer a true si el bloqueo hará que la función quede esperando (condición de errno EWOULDBLOCK).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::flock()

<?php
$file = new SplFileObject("/tmp/bloqueado.txt", "w");
if ($file->flock(LOCK_EX)) { // adquirir un bloqueo exclusivo
    $file->ftruncate(0);     // truncar el fichero
    $file->fwrite("Escribir alguna cosa\n");
    $file->flock(LOCK_UN);   // liberar el bloqueo
} else {
    echo "¡No se pudo obtener el bloqueo!";
}
?>

Historial de cambios

Versión | Descripción
5.5.22, 5.6.6 | Añadido soporte para el parámetro wouldblock en Windows.
5.3.2 | Se eliminó el desbloqueo automático cuando se cierra el manejador de recursos del archivo. El desbloqueo ahora siempre tiene que hacerse manualmente.

Ver también

  • flock() - Bloqueo de ficheros recomendado y portable


Imprimir todos los datos restantes en un apuntador de fichero

  • « SplFileObject::flock
  • SplFileObject::fputcsv »
  • PHP Manual
  • SplFileObject
  • Imprimir todos los datos restantes en un apuntador de fichero

SplFileObject::fpassthru

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fpassthru — Imprimir todos los datos restantes en un apuntador de fichero

Descripción

public SplFileObject::fpassthru ( ) : int

Lee hasta el final en el puntero de el fichero dado de la posición actual y escribe el resultado a el búfer de salida.

Puede que se necesite llamar a SplFileObject::rewind() You may need to call SplFileObject::rewind() para reiniciar el puntero del fichero al inicio de el fichero si se tiene datos escritos en el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de caracteres leídos del handle y pasados a través de la salida.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fpassthru()

<?php

// Abrir el fichero en modo binario
$file = new SplFileObject("./img/ok.png", "rb");

// Enviar las cabeceras de permisos
header("Content-Type: image/png");
header("Content-Length: " . $file->getSize());

// Volcar la imagen y fin del script
$file->fpassthru();
exit;

?>

Ver también

  • fpassthru() - Escribe toda la información restante de un puntero a un archivo


Escribir un array de campos como una línea CSV

  • « SplFileObject::fpassthru
  • SplFileObject::fread »
  • PHP Manual
  • SplFileObject
  • Escribir un array de campos como una línea CSV

SplFileObject::fputcsv

(PHP 5 >= 5.4.0, PHP 7)

SplFileObject::fputcsv — Escribir un array de campos como una línea CSV

Descripción

public SplFileObject::fputcsv
 ( array $fields
, string $delimiter = ","
, string $enclosure = '"'
, string $escape = "\"
) : int

Escribe el array fields en el fichero como una línea CVS.

Parámetros

fields

Un array de valores.

delimiter

El parámetro opcional delimiter establece el delimitador de campos (sólo un carácter).

enclosure

El parámetro opcional enclosure establece el carácter circundante de cada campo (sólo un carácter).

escape

El parámetro opcional escape establece el carácter de escape (solamente un carácter).

Valores devueltos

Devuelve la longitud del string escrito o false en caso de error.

Devuelve false, y no escribe la línea CVS en el fichero, si el parámetro delimiter o enclosure no es un único carácter.

Errores/Excepciones

Emite un error de nivel E_WARNING si el parámetro delimiter o enclosure no es un único carácter.

Historial de cambios

Versión | Descripción
5.5.21, 5.6.5 | Se añadió el parámetro escape.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fputcsv()

<?php

$lista = array (
    array('aaa', 'bbb', 'ccc', 'dddd'),
    array('123', '456', '789'),
    array('"aaa"', '"bbb"')
);

$fichero = new SplFileObject('fichero.csv', 'w');

foreach ($lista as $campos) {
    $fichero->fputcsv($campos);
}

?>

El ejemplo anterior escribirá lo siguiente en fichero.csv:

aaa,bbb,ccc,dddd
123,456,789
"""aaa""","""bbb"""

Ver también

  • fputcsv() - Dar formato CSV a una línea y escribirla en un puntero a un fichero
  • SplFileObject::fgetcsv() - Obtiene la línea del archivo y analiza como campos CSV


Leer un fichero

  • « SplFileObject::fputcsv
  • SplFileObject::fscanf »
  • PHP Manual
  • SplFileObject
  • Leer un fichero

SplFileObject::fread

(PHP 5 >= 5.5.11, PHP 7)

SplFileObject::fread — Leer un fichero

Descripción

public SplFileObject::fread ( int $length ) : string

Lee de un fichero el número de bytes dado.

Parámetros

length

El número de bytes a leer.

Valores devueltos

Devuelve el string léido desde el fichero o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fread()

<?php
// Pasar el contenido de un fichero a un string
$nombre_fichero = "/usr/local/something.txt";
$fichero = new SplFileObject($nombre_fichero, "r");
$contenido = $fichero->fread($fichero->getSize());
?>

Notas

Nota:

Observe que SplFileObject::fread() lee desde la posición actual del puntero del fichero. Use SplFileObject::ftell() para conocer la posición actual del puntero, y SplFileObject::rewind() (o SplFileObject::fseek()) para posicionar el puntero al inicio.

Ver también

  • fread() - Lectura de un fichero en modo binario seguro


Analiza la entrada de un fichero de acuerdo a un formato

  • « SplFileObject::fread
  • SplFileObject::fseek »
  • PHP Manual
  • SplFileObject
  • Analiza la entrada de un fichero de acuerdo a un formato

SplFileObject::fscanf

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fscanf — Analiza la entrada de un fichero de acuerdo a un formato

Descripción

public SplFileObject::fscanf ( string $format , mixed &$... = ? ) : mixed

Lee una línea de el fichero e interpreta este de acuerdo a el format, especificado, como es descrito en la documentación de sprintf().

Cualquier espacio en blanco en el format string coincide con cualquier espacio en blanco en la línea de el fichero. Esto significa que incluso un \t en el formato string puede coincidir con un sólo caracter de espacio en la secuencia de entrada.

Parámetros

format

El formato especificado descrito en la documentación de sprintf().

...

Los valores opcionales asignados.

Valores devueltos

Si sólo se pasa un parámetro a este método, los valores analizados serán devueltos como un array. De lo contrario, si se paran los parámetros opcionales, la función devolverá el número de valores asignados. Los parámetros opcionales deben ser pasados por referencia.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fscanf()

<?php
$file = new SplFileObject("usuarios.txt");
while ($usuarioinfo = $file->fscanf("%s %s %s")) {
    list ($nombre, $profesion, $codigopais) = $usuarioinfo;
    // Operar con  $name $profession $countrycode
}
?>

Contenido de usuarios.txt

javier   argonaut    pe
hiroshi  sculptor    jp
robert   slacker     us
luigi    florist     it

Ver también

  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato


Busca una posiciónn

  • « SplFileObject::fscanf
  • SplFileObject::fstat »
  • PHP Manual
  • SplFileObject
  • Busca una posiciónn

SplFileObject::fseek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fseek — Busca una posiciónn

Descripción

public SplFileObject::fseek ( int $offset , int $whence = SEEK_SET ) : int

Mueve el puntero interno a una posición en el fichero medido en bytes desde el principio de el fichero obtenido, añadiendo offset a la posición especificada por whence.

Parámetros

offset

El índice. Un valor negativo puede ser utilizado para mover hacía atrás por el fichero que será útil cuando SEEK_END es usado como un valor de whence.

whence

Los valores de whence son:

  • SEEK_SET - Establece la posición igual a offset bytes.
  • SEEK_CUR - Establece la posición a la ubicación actual más offset.
  • SEEK_END - Establece la posición al final de el fichero más offset.

Si no se especifica whence, se supone que es SEEK_SET.

Valores devueltos

Devuelve 0 si la búsqueda fué exitosa, -1 en caso contrario. Tenga en cuenta que buscando un EOF pasado no se considera como un error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fseek()

<?php
$file = new SplFileObject("algunfichero.txt");

// Leer la primera línea
$data = $file->fgets();

// Mover atrás a el principio de el fichero
// Igual que $file->rewind();
$file->fseek(0);
?>

Ver también

  • fseek() - Busca sobre un puntero a un fichero


Obtiene información de el fichero

  • « SplFileObject::fseek
  • SplFileObject::ftell »
  • PHP Manual
  • SplFileObject
  • Obtiene información de el fichero

SplFileObject::fstat

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fstat — Obtiene información de el fichero

Descripción

public SplFileObject::fstat ( ) : array

Obtiene estadísticas de el fichero. Se comporta de forma idéntica a fstat().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con las estadísticas de el fichero; el formato de el array es descrito en detalle en la página del manual de stat().

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fstat()

<?php
$file = new SplFileObject("/etc/passwd");
$stat = $file->fstat();

// Imprimir sólo la parte asociada
print_r(array_slice($stat, 13));

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

Ver también

  • fstat() - Obtiene información acerca de un archivo usando un puntero al archivo abierto
  • stat() - Da información acerca de un fichero


Devuelve la posición del fichero actual

  • « SplFileObject::fstat
  • SplFileObject::ftruncate »
  • PHP Manual
  • SplFileObject
  • Devuelve la posición del fichero actual

SplFileObject::ftell

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftell — Devuelve la posición del fichero actual

Descripción

public SplFileObject::ftell ( ) : int

Devuelve la posición de el puntero de fichero que representa el índice actual en el flujo del fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la posición de el puntero de fichero como un integer, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::ftell()

<?php
$file = new SplFileObject("/etc/passwd");

// Lee la primera línea
$data = $file->fgets();

// ¿Dónde estamos?
echo $file->ftell();
?>

Ver también

  • ftell() - Devuelve la posición de lectura/escritura actual del puntero a un fichero


Trunca el archivo a una longitud dada

  • « SplFileObject::ftell
  • SplFileObject::fwrite »
  • PHP Manual
  • SplFileObject
  • Trunca el archivo a una longitud dada

SplFileObject::ftruncate

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftruncate — Trunca el archivo a una longitud dada

Descripción

public SplFileObject::ftruncate ( int $size ) : bool

Trunca el archivo a size bytes.

Parámetros

size

El tamaño a truncar.

Nota:

Si size es más grande que el fichero este es extendido con bytes null.

Si size es más pequeño que el archivo, los datos extra se perderán.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::ftruncate()

<?php
// Crea un fichero conteniendo "Hola Mundo!"
$file = new SplFileObject("/tmp/ftruncate", "w+");
$file->fwrite("Hola Mundo!");

// Truncar a 4 bytes
$file->ftruncate(4);

// Rebobina y leer los datos
$file->rewind();
echo $file->fgets();
?>

El resultado del ejemplo sería algo similar a:

Hola

Ver también

  • ftruncate() - Trunca un archivo a una longitud dada


Escribe en el fichero

  • « SplFileObject::ftruncate
  • SplFileObject::getChildren »
  • PHP Manual
  • SplFileObject
  • Escribe en el fichero

SplFileObject::fwrite

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fwrite — Escribe en el fichero

Descripción

public SplFileObject::fwrite ( string $str , int $length = ? ) : int

Escribe el contenido de un string a el fichero.

Parámetros

str

El string a ser escrito en el fichero.

length

Si se utiliza el argumento length, la escritura se detendrá después de que se han escrito length bytes o o se llega al final del string, lo que ocurra primero.

Valores devueltos

Devuelve el número de bytes escritos, o false en caso de error.

Historial de cambios

Versión | Descripción
7.4.0 | La función ahora devuelve false en vez de cero en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::fwrite()

<?php
$file = new SplFileObject("fwrite.txt", "w");
$written = $file->fwrite("12345");
echo "Escritos $written bytes a el fichero";
?>

El resultado del ejemplo sería algo similar a:

Escritos 5 bytes a el fichero

Ver también

  • fwrite() - Escritura de un archivo en modo binario seguro


Ningún propósito

  • « SplFileObject::fwrite
  • SplFileObject::getCsvControl »
  • PHP Manual
  • SplFileObject
  • Ningún propósito

SplFileObject::getChildren

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getChildren — Ningún propósito

Descripción

public SplFileObject::getChildren ( ) : void

Una clase SplFileObject no tiene hijos así que este método devolverá null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • RecursiveIterator::getChildren() - Devuelve un iterador para la entrada actual


Obtiene el carácter delimitador, el circundante y de escape para campos CSV

  • « SplFileObject::getChildren
  • SplFileObject::getCurrentLine »
  • PHP Manual
  • SplFileObject
  • Obtiene el carácter delimitador, el circundante y de escape para campos CSV

SplFileObject::getCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::getCsvControl — Obtiene el carácter delimitador, el circundante y de escape para campos CSV

Descripción

public SplFileObject::getCsvControl ( ) : array

Obtiene el carácter delimitador, el circundante y de escape usados para analizar campos CSV.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array indexado que contiene el carácter delimitador, el circundante y el de escape.

Historial de cambios

Versión | Descripción
7.4.0 | El carácter de escape puede ser ahora un string vacío.
5.6.25, 7.0.10 | Se añadió el carácter de escape al array devuelto.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::getCsvControl()

<?php
$fichero = new SplFileObject("datos.txt");
print_r($fichero->getCsvControl());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => ,
    [1] => "
    [2] => \
)

Ver también

  • SplFileObject::setCsvControl() - Establece el carácter delimitador, el circundante y el de escape para campos CSV
  • SplFileObject::fgetcsv() - Obtiene la línea del archivo y analiza como campos CSV


Alias de SplFileObject::fgets

  • « SplFileObject::getCsvControl
  • SplFileObject::getFlags »
  • PHP Manual
  • SplFileObject
  • Alias de SplFileObject::fgets

SplFileObject::getCurrentLine

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::getCurrentLine — Alias de SplFileObject::fgets()

Descripción

Este método es un alias de: SplFileObject::fgets().


Obtener las flags de SplFileObject

  • « SplFileObject::getCurrentLine
  • SplFileObject::getMaxLineLen »
  • PHP Manual
  • SplFileObject
  • Obtener las flags de SplFileObject

SplFileObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getFlags — Obtener las flags de SplFileObject

Descripción

public SplFileObject::getFlags ( ) : int

Obtiene las flags establecidas en una instancia de SplFileObject como un integer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un integer que representa las flags.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::getFlags()

<?php
$file = new SplFileObject(__FILE__, "r");

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Saltando líneas vacías\n";
} else {
    echo "Sin saltar líneas vacías\n";
}

$file->setFlags(SplFileObject::SKIP_EMPTY);

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Saltando líneas vacías\n";
} else {
    echo "Sin saltar líneas vacías\n";
}
?>

El resultado del ejemplo sería algo similar a:

Sin saltar líneas vacías
Saltando líneas vacías

Ver también

  • SplFileObject::setFlags() - Establece flags para el SplFileObject


Obtener la longitud máxima de línea

  • « SplFileObject::getFlags
  • SplFileObject::hasChildren »
  • PHP Manual
  • SplFileObject
  • Obtener la longitud máxima de línea

SplFileObject::getMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getMaxLineLen — Obtener la longitud máxima de línea

Descripción

public SplFileObject::getMaxLineLen ( ) : int

Obtiene la longitud máxima de línea establecida por SplFileObject::setMaxLineLen().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la longitud máxima de línea si ha sido establecido con SplFileObject::setMaxLineLen(), por omisión es 0.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::getMaxLineLen()

<?php
$file = new SplFileObject("fichero.txt");
var_dump($file->getMaxLineLen());

$file->setMaxLineLen(20);
var_dump($file->getMaxLineLen());
?>

El resultado del ejemplo sería algo similar a:

int(0)
int(20)

Ver también

  • Classname::Method()


SplFileObject no tiene hijos

  • « SplFileObject::getMaxLineLen
  • SplFileObject::key »
  • PHP Manual
  • SplFileObject
  • SplFileObject no tiene hijos

SplFileObject::hasChildren

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::hasChildren — SplFileObject no tiene hijos

Descripción

public SplFileObject::hasChildren ( ) : bool

Una clase SplFileObject no tiene hijos. Este método siempre devuelve false.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve false

Ver también

  • RecursiveIterator::hasChildren() - Retorna si un iterador puede ser creado para la entrada actual


Obtiene el número de línea

  • « SplFileObject::hasChildren
  • SplFileObject::next »
  • PHP Manual
  • SplFileObject
  • Obtiene el número de línea

SplFileObject::key

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::key — Obtiene el número de línea

Descripción

public SplFileObject::key ( ) : int

Obtener el número de línea.

Nota:

Este nñumero puede no ser reflejado en la línea actual en el fichero si el método SplFileObject::setMaxLineLen() es usado para leer posiciones fijas de el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de línea actual.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::key()

<?php
$file = new SplFileObject("lipsum.txt");
foreach ($file as $line) {
    echo $file->key() . ". " . $line;
}
?>

El resultado del ejemplo sería algo similar a:

0. Lorem ipsum dolor sit amet, consectetur adipiscing elit.
1. Duis nec sapien felis, ac sodales nisl.
2. Lorem ipsum dolor sit amet, consectetur adipiscing elit.

Ejemplo #2 SplFileObject::key() ejemplo con SplFileObject::setMaxLineLen()

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $file->key() . ". " . $line . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

0. Lorem ipsum dolor s
1. it amet, consectetu
2. r adipiscing elit.
3.

4. Duis nec sapien fel
5. is, ac sodales nisl
6. .

7. Lorem ipsum dolor s
8. it amet, consectetu
9. r adipiscing elit.

Ver también

  • SplFileObject::current() - Recupera la línea actual del fichero
  • SplFileObject::seek() - Mueve el apuntador interno a la línea específicada
  • SplFileObject::next() - Leer la siguiente línea
  • SplFileObject::rewind() - Rebobina el fichero hasta la primera línea
  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado


Leer la siguiente línea

  • « SplFileObject::key
  • SplFileObject::rewind »
  • PHP Manual
  • SplFileObject
  • Leer la siguiente línea

SplFileObject::next

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::next — Leer la siguiente línea

Descripción

public SplFileObject::next ( ) : void

Mover a la siguiente línea en el fichero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::next()

<?php
// Leer el fichero línea por línea
$file = new SplFileObject("variado.txt");
while (!$file->eof()) {
    echo $file->current();
    $file->next();
}
?>

Ver también

  • SplFileObject::current() - Recupera la línea actual del fichero
  • SplFileObject::key() - Obtiene el número de línea
  • SplFileObject::seek() - Mueve el apuntador interno a la línea específicada
  • SplFileObject::rewind() - Rebobina el fichero hasta la primera línea
  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado


Rebobina el fichero hasta la primera línea

  • « SplFileObject::next
  • SplFileObject::seek »
  • PHP Manual
  • SplFileObject
  • Rebobina el fichero hasta la primera línea

SplFileObject::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::rewind — Rebobina el fichero hasta la primera línea

Descripción

public SplFileObject::rewind ( ) : void

Rebobina el fichero hasta la primera línea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una RuntimeException si no se puede rebobinar.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::rewind()

<?php
$file = new SplFileObject("variado.txt");

// Recorrer todo el fichero
foreach ($file as $line) { }

// Rebobinar hasta la primera línea
$file->rewind();

// Imprime la primera línea
echo $file->current();
?>

Ver también

  • SplFileObject::current() - Recupera la línea actual del fichero
  • SplFileObject::key() - Obtiene el número de línea
  • SplFileObject::seek() - Mueve el apuntador interno a la línea específicada
  • SplFileObject::next() - Leer la siguiente línea
  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado


Mueve el apuntador interno a la línea específicada

  • « SplFileObject::rewind
  • SplFileObject::setCsvControl »
  • PHP Manual
  • SplFileObject
  • Mueve el apuntador interno a la línea específicada

SplFileObject::seek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::seek — Mueve el apuntador interno a la línea específicada

Descripción

public SplFileObject::seek ( int $line_pos ) : void

Mueve el apuntador interno a la línea específicada en el fichero.

Parámetros

line_pos

El número base cero a mover el apuntador interno.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una LogicException si el parámetro line_pos es negativo.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::seek()

Este ejemplo imprime la tercera línea de el script que se encuentra en la posición 2.

<?php
$file = new SplFileObject(__FILE__);
$file->seek(2);
echo $file->current();
?>

El resultado del ejemplo sería algo similar a:

$file->seek(2);

Ver también

  • SplFileObject::current() - Recupera la línea actual del fichero
  • SplFileObject::key() - Obtiene el número de línea
  • SplFileObject::next() - Leer la siguiente línea
  • SplFileObject::rewind() - Rebobina el fichero hasta la primera línea
  • SplFileObject::valid() - Comprueba si el final del finchero ha sido alcanzado


Establece el carácter delimitador, el circundante y el de escape para campos CSV

  • « SplFileObject::seek
  • SplFileObject::setFlags »
  • PHP Manual
  • SplFileObject
  • Establece el carácter delimitador, el circundante y el de escape para campos CSV

SplFileObject::setCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::setCsvControl — Establece el carácter delimitador, el circundante y el de escape para campos CSV

Descripción

public SplFileObject::setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void

Establece el carácter delimitador, el circundante y el de escape para analizar campos CSV.

Parámetros

delimiter

El delimitador de campos (un sólo carácter).

enclosure

El carácter circundante de cada campo (un sólo carácter).

escape

The field escape character (at most one character). An empty string ("") disables the proprietary escape mechanism.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
7.4.0 | El parámetro escape ahora acepta un string vacío para desactivar el mecanismo de escape.
5.3.0 | Añadido el parámetro escape.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::setCsvControl()

<?php
$fichero = new SplFileObject("datos.csv");
$fichero->setFlags(SplFileObject::READ_CSV);
$fichero->setCsvControl('|');
foreach ($fichero as $fila) {
    list ($frutas, $cantidad) = $fila;
    // Hacer algo con los valores
}
?>

Contenido de data.csv

<?php
manzanas|20
bananas|14
cerezas|87
?>

Ver también

  • SplFileObject::getCsvControl() - Obtiene el carácter delimitador, el circundante y de escape para campos CSV
  • SplFileObject::fgetcsv() - Obtiene la línea del archivo y analiza como campos CSV


Establece flags para el SplFileObject

  • « SplFileObject::setCsvControl
  • SplFileObject::setMaxLineLen »
  • PHP Manual
  • SplFileObject
  • Establece flags para el SplFileObject

SplFileObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setFlags — Establece flags para el SplFileObject

Descripción

public SplFileObject::setFlags ( int $flags ) : void

Establece las flags a ser usadas por el SplFileObject.

Parámetros

flags

Bitmask de las flags a establecer. Véase las Constantes SplFileObject para una lista de flags disponibles.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::setFlags()

<?php
$file = new SplFileObject("datos.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $fields) {
    var_dump($fields);
}
?>

Ver también

  • SplFileObject::getFlags() - Obtener las flags de SplFileObject


Establecer la longitud máxima de una línea

  • « SplFileObject::setFlags
  • SplFileObject::__toString »
  • PHP Manual
  • SplFileObject
  • Establecer la longitud máxima de una línea

SplFileObject::setMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setMaxLineLen — Establecer la longitud máxima de una línea

Descripción

public SplFileObject::setMaxLineLen ( int $max_len ) : void

Establece la longitud máxima de una línea a ser leída.

Parámetros

max_len

La longitud de una línea.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una excepción DomainException cuando max_len es menor que cero.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::setMaxLineLen()

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $line . "\n";
}
?>

Contenido de lipsum.txt

Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Duis nec sapien felis, ac sodales nisl.
Nulla vitae magna vitae purus aliquet consequat.

El resultado del ejemplo sería algo similar a:

Lorem ipsum dolor s
it amet, consectetu
r adipiscing elit.

Duis nec sapien fel
is, ac sodales nisl
.

Nulla vitae magna v
itae purus aliquet
consequat.

Ver también

  • Classname::Method()


Alias de SplFileObject::fgets

  • « SplFileObject::setMaxLineLen
  • SplFileObject::valid »
  • PHP Manual
  • SplFileObject
  • Alias de SplFileObject::fgets

SplFileObject::__toString

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__toString — Alias de SplFileObject::fgets()

Descripción

Este método es un alias de: SplFileObject::fgets().

Historial de cambios

Versión | Descripción
7.2.19, 7.3.6 | Cambiado de un alias de SplFileObject::current() a un alias de SplFileObject::fgets().


Comprueba si el final del finchero ha sido alcanzado

  • « SplFileObject::__toString
  • SplTempFileObject »
  • PHP Manual
  • SplFileObject
  • Comprueba si el final del finchero ha sido alcanzado

SplFileObject::valid

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::valid — Comprueba si el final del finchero ha sido alcanzado

Descripción

public SplFileObject::valid ( ) : bool

Comprueba si el final del finchero ha sido alcanzado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el final no ha sido alcanzado, en caso contrario false.

Ejemplos

Ejemplo #1 Ejemplo de SplFileObject::valid()

<?php
// Recorrer el fichero, línea por línea
$file = new SplFileObject("fichero.txt");
while ($file->valid()) {
    echo $file->fgets();
}
?>

Ver también

  • SplFileObject::current() - Recupera la línea actual del fichero
  • SplFileObject::key() - Obtiene el número de línea
  • SplFileObject::seek() - Mueve el apuntador interno a la línea específicada
  • SplFileObject::next() - Leer la siguiente línea
  • SplFileObject::rewind() - Rebobina el fichero hasta la primera línea


La clase SplTempFileObject

(PHP 5 >= 5.1.2, PHP 7)

Introducción

La clase SplTempFileObject ofrece una interfaz orientada a objectos para ficheros temporales.

Sinopsis de la Clase

SplTempFileObject extends SplFileObject implements SeekableIterator , RecursiveIterator {
/* Constantaes heredadas constants */
const integer SplFileObject::DROP_NEW_LINE = 1 ;
const integer SplFileObject::READ_AHEAD = 2 ;
const integer SplFileObject::SKIP_EMPTY = 4 ;
const integer SplFileObject::READ_CSV = 8 ;
/* Métodos */
public __construct ( int $max_memory = ? )
/* Métodos heredados */
public SplFileObject::current ( ) : string|array
public SplFileObject::eof ( ) : bool
public SplFileObject::fflush ( ) : bool
public SplFileObject::fgetc ( ) : string
public SplFileObject::fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array
public SplFileObject::fgets ( ) : string
public SplFileObject::fgetss ( string $allowable_tags = ? ) : string
public SplFileObject::flock ( int $operation , int &$wouldblock = ? ) : bool
public SplFileObject::fpassthru ( ) : int
public SplFileObject::fputcsv
 ( array $fields
, string $delimiter = ","
, string $enclosure = '"'
, string $escape = "\"
) : int
public SplFileObject::fread ( int $length ) : string
public SplFileObject::fscanf ( string $format , mixed &$... = ? ) : mixed
public SplFileObject::fseek ( int $offset , int $whence = SEEK_SET ) : int
public SplFileObject::fstat ( ) : array
public SplFileObject::ftell ( ) : int
public SplFileObject::ftruncate ( int $size ) : bool
public SplFileObject::fwrite ( string $str , int $length = ? ) : int
public SplFileObject::getChildren ( ) : void
public SplFileObject::getCsvControl ( ) : array
public SplFileObject::getFlags ( ) : int
public SplFileObject::getMaxLineLen ( ) : int
public SplFileObject::hasChildren ( ) : bool
public SplFileObject::key ( ) : int
public SplFileObject::next ( ) : void
public SplFileObject::rewind ( ) : void
public SplFileObject::seek ( int $line_pos ) : void
public SplFileObject::setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void
public SplFileObject::setFlags ( int $flags ) : void
public SplFileObject::setMaxLineLen ( int $max_len ) : void
public SplFileObject::valid ( ) : bool
}

Tabla de contenidos

  • SplTempFileObject::__construct — Construir un nuevo objeto de fichero temporal


Construir un nuevo objeto de fichero temporal

  • « SplTempFileObject
  • Misceláneos clases e interfaces »
  • PHP Manual
  • SplTempFileObject
  • Construir un nuevo objeto de fichero temporal

SplTempFileObject::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplTempFileObject::__construct — Construir un nuevo objeto de fichero temporal

Descripción

public SplTempFileObject::__construct ( int $max_memory = ? )

Construir un nuevo objeto de fichero temporal.

Parámetros

max_memory

La cantidad máxima de memoria (en bytes, por omisión es 2 MB) para el fichero temporal a usar. Su el fichero temporal supera este tamaño, Este será movido a un archivo en el directorio temporal del sistema.

Si max_memory es negativo, se usará memoria. Si max_memory es cero, no se usará memoria.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza una RuntimeException si un error ocurre.

Ejemplos

Ejemplo #1 Ejemplo de SplTempFileObject()

Este ejemplo escribe un fichero temporal en la memoria mientras se puede escribir y leer en este.

<?php
$temp = new SplTempFileObject();
$temp->fwrite("Esta es la primera línea\n");
$temp->fwrite("Y esta es la segunda.\n");
echo "Escrito " . $temp->ftell() . " bytes al fichero temporal.\n\n";

// Rebobina y lee lo que fué escrito
$temp->rewind();
foreach ($temp as $line) {
    echo $line;
}
?>

El resultado del ejemplo sería algo similar a:

Escrito 47 bytes al fichero temporal.

Esta es la primera línea
Y esta es la segunda.

Ver también

  • SplFileObject
  • PHP input/output streams (para php://temp y php://memory)


Misceláneos clases e interfaces

Tabla de contenidos

  • ArrayObject
  • SplObserver
  • SplSubject

Clases e interfaces que no entran en ninguna de las categorías SPL.


La clase ArrayObject

(PHP 5, PHP 7)

Introducción

Esta clase permite a los objetos funcionar como arrays.

Sinopsis de la Clase

ArrayObject implements IteratorAggregate , ArrayAccess , Serializable , Countable {
/* Constantes */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* Métodos */
public __construct ( mixed $input = array() , int $flags = 0 , string $iterator_class = "ArrayIterator" )
public append ( mixed $value ) : void
public asort ( ) : void
public count ( ) : int
public exchangeArray ( mixed $input ) : array
public getArrayCopy ( ) : array
public getFlags ( ) : int
public getIterator ( ) : ArrayIterator
public getIteratorClass ( ) : string
public ksort ( ) : void
public natcasesort ( ) : void
public natsort ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public serialize ( ) : string
public setFlags ( int $flags ) : void
public setIteratorClass ( string $iterator_class ) : void
public uasort ( callable $cmp_function ) : void
public uksort ( callable $cmp_function ) : void
public unserialize ( string $serialized ) : void
}

Constantes predefinidas

Banderas de ArrayObject

ArrayObject::STD_PROP_LIST

Las propiedades del objeto tienen un comportamiento normal cuando se acceden como listado (var_dump, foreach, etc.).

ArrayObject::ARRAY_AS_PROPS

Se puede acceder a las entradas como propiedades (lectura y escritura).

Historial de cambios

Versión | Descripción
5.3.0 | Se implementó Serializable.

Tabla de contenidos

  • ArrayObject::append — Añade un valor
  • ArrayObject::asort — Ordena las entradas por valor
  • ArrayObject::__construct — Construir un nuevo objeto Array
  • ArrayObject::count — Obtener el número de propiedades públicas en la clase ArrayObject
  • ArrayObject::exchangeArray — Intercambia el array por otro
  • ArrayObject::getArrayCopy — Crea una copia de la clase ArrayObject
  • ArrayObject::getFlags — Obtiene las flags de comportamiento
  • ArrayObject::getIterator — Crear un nuevo iterador desde una instancia ArrayObject
  • ArrayObject::getIteratorClass — Obtiene el nombre de clase iterador para ArrayObject
  • ArrayObject::ksort — Ordena las entradas por clave
  • ArrayObject::natcasesort — Ordena un array usando un algoritmo orden natural
  • ArrayObject::natsort — Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::offsetExists — Devuelve si el índice solicitado existe
  • ArrayObject::offsetGet — Devuelve el valor del índice especificado
  • ArrayObject::offsetSet — Establece el valor en el índice especificado
  • ArrayObject::offsetUnset — Destruye el valor para el índice especificado
  • ArrayObject::serialize — Serializar un ArrayObject
  • ArrayObject::setFlags — Establece las flags de comportamiento
  • ArrayObject::setIteratorClass — Establece el nombre de clase iterador para ArrayObject
  • ArrayObject::uasort — Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
  • ArrayObject::uksort — Ordena las entradas por clave usando una función de comparación definida por el usuario
  • ArrayObject::unserialize — Deserializar el objeto ArrayObject


Añade un valor

  • « ArrayObject
  • ArrayObject::asort »
  • PHP Manual
  • ArrayObject
  • Añade un valor

ArrayObject::append

(PHP 5, PHP 7)

ArrayObject::append — Añade un valor

Descripción

public ArrayObject::append ( mixed $value ) : void

Añade un nuevo valor como el último elemento.

Nota:

Este método no puede ser llamado cuando la clase ArrayObject fue construida a partir de un objeto. Utilice ArrayObject::offsetSet() en su lugar.

Parámetros

value

El valor a ser añadido.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::append()

<?php
$arrayobj = new ArrayObject(array('primero','segundo','tercero'));
$arrayobj->append('cuarto');
$arrayobj->append(array('quinto', 'sexto'));
var_dump($arrayobj);
?>

El resultado del ejemplo sería:

object(ArrayObject)#1 (5) {
  [0]=>
  string(5) "primero"
  [1]=>
  string(6) "segundo"
  [2]=>
  string(5) "tercero"
  [3]=>
  string(6) "cuarto"
  [4]=>
  array(2) {
    [0]=>
    string(4) "quinto"
    [1]=>
    string(3) "sexto"
  }
}

Ver también

  • ArrayObject::offsetSet() - Establece el valor en el índice especificado


Ordena las entradas por valor

  • « ArrayObject::append
  • ArrayObject::__construct »
  • PHP Manual
  • ArrayObject
  • Ordena las entradas por valor

ArrayObject::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::asort — Ordena las entradas por valor

Descripción

public ArrayObject::asort ( ) : void

Ordenar las entradas de modo que las claves mantengan su correlación con las entradas que están asociadas. Esto se utiliza principalmente para ordenar arrays asociativos cuando el orden de los elementos es importante.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ArrayObject::asort() example

<?php
$fruits = array("d" => "limon", "a" => "naranja", "b" => "banana", "c" => "manzana");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->asort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

b = banana
d = limon
c = manzana
a = naranja

Las frutas han sido ordenadas en orden alfabético, y la clave asociada con cada entrada se ha mantenido.

Ver también

  • ArrayObject::ksort() - Ordena las entradas por clave
  • ArrayObject::natsort() - Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::natcasesort() - Ordena un array usando un algoritmo orden natural
  • ArrayObject::uasort() - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
  • ArrayObject::uksort() - Ordena las entradas por clave usando una función de comparación definida por el usuario


Construir un nuevo objeto Array

  • « ArrayObject::asort
  • ArrayObject::count »
  • PHP Manual
  • ArrayObject
  • Construir un nuevo objeto Array

ArrayObject::__construct

(PHP 5, PHP 7)

ArrayObject::__construct — Construir un nuevo objeto Array

Descripción

public ArrayObject::__construct ( mixed $input = array() , int $flags = 0 , string $iterator_class = "ArrayIterator" )

Esto crea un nuevo objeto array.

Parámetros

input

Este parámetro de input (entrada) acepta un array o un objeto.

flags

Flags para controlar el comportamiento del objeto ArrayObject.

iterator_class

Especifica la clase que va a ser usada para la iteración del objeto ArrayObject. ArrayIterator es la clase usada por omisión.

Valores devueltos

Devuelve un objeto ArrayObject en caso de éxito.

Errores/Excepciones

Lanza una InvalidArgumentException cuando:

  • input no es un array u objeto
  • flags no es un integer
  • iterator_class no es un objeto que implementa Iterator

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::__construct()

<?php
$array = array('1' => 'uno',
               '2' => 'dos',
               '3' => 'tres');

$arrayobject = new ArrayObject($array);

var_dump($arrayobject);
?>

El resultado del ejemplo sería:

object(ArrayObject)#1 (3) {
  [1]=>
  string(3) "uno"
  [2]=>
  string(3) "dos"
  [3]=>
  string(5) "tres"
}

Ver también

  • ArrayObject::setflags() - Establece las flags de comportamiento


Obtener el número de propiedades públicas en la clase ArrayObject

  • « ArrayObject::__construct
  • ArrayObject::exchangeArray »
  • PHP Manual
  • ArrayObject
  • Obtener el número de propiedades públicas en la clase ArrayObject

ArrayObject::count

(PHP 5, PHP 7)

ArrayObject::count — Obtener el número de propiedades públicas en la clase ArrayObject

Descripción

public ArrayObject::count ( ) : int

Obtiene el número de propiedades públicas en la clase ArrayObject.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de propiedades públicas en la clase ArrayObject.

Nota:

Cuando la clase ArrayObject se construye a partir de un array todas las propiedades son públicas.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::count()

<?php
class Ejemplo {
    public $public = 'prop:public';
    private $prv   = 'prop:private';
    protected $prt = 'prop:protected';
}

$arrayobj = new ArrayObject(new Ejemplo());
var_dump($arrayobj->count());

$arrayobj = new ArrayObject(array('primero','segundo','tercero'));
var_dump($arrayobj->count());
?>

El resultado del ejemplo sería:

int(1)
int(3)


Intercambia el array por otro

  • « ArrayObject::count
  • ArrayObject::getArrayCopy »
  • PHP Manual
  • ArrayObject
  • Intercambia el array por otro

ArrayObject::exchangeArray

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::exchangeArray — Intercambia el array por otro

Descripción

public ArrayObject::exchangeArray ( mixed $input ) : array

Intercambiar el array actual con otro array u objeto.

Parámetros

input

El nuevo array u objeto a ser intercambiado con el array actual.

Valores devueltos

Devuelve el array antiguo.

Ejemplos

Ejemplo #1 ArrayObject::exchangeArray() example

<?php
// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);
// Array de lugares en Europa
$locations = array('Amsterdam', 'Paris', 'London');

$fruitsArrayObject = new ArrayObject($fruits);

// Now exchange fruits for locations
$old = $fruitsArrayObject->exchangeArray($locations);
print_r($old);
print_r($fruitsArrayObject);

?>

El resultado del ejemplo sería:

Array
(
    [limones] => 1
    [naranjas] => 4
    [bananas] => 5
    [manzanas] => 10
)
ArrayObject Object
(
    [0] => Amsterdam
    [1] => Paris
    [2] => London
)


Crea una copia de la clase ArrayObject

  • « ArrayObject::exchangeArray
  • ArrayObject::getFlags »
  • PHP Manual
  • ArrayObject
  • Crea una copia de la clase ArrayObject

ArrayObject::getArrayCopy

(PHP 5, PHP 7)

ArrayObject::getArrayCopy — Crea una copia de la clase ArrayObject

Descripción

public ArrayObject::getArrayCopy ( ) : array

Exporta la clase ArrayObject a un array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una copia del array. Cuando la clase ArrayObject hace referencia a un objeto, un array de las propiedades públicas del objeto que será devuelto.

Ejemplos

Ejemplo #1 ArrayObject::getArrayCopy() example

<?php
// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);

$fruitsArrayObject = new ArrayObject($fruits);
$fruitsArrayObject['peras'] = 4;

// crear una copia del array
$copy = $fruitsArrayObject->getArrayCopy();
print_r($copy);

?>

El resultado del ejemplo sería:

Array
(
    [limones] => 1
    [naranjas] => 4
    [bananas] => 5
    [manzanas] => 10
    [peras] => 4
)


Obtiene las flags de comportamiento

  • « ArrayObject::getArrayCopy
  • ArrayObject::getIterator »
  • PHP Manual
  • ArrayObject
  • Obtiene las flags de comportamiento

ArrayObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getFlags — Obtiene las flags de comportamiento

Descripción

public ArrayObject::getFlags ( ) : int

Obtener las flags de comportamiento de la clase ArrayObject. Véase el método ArrayObject::setFlags para obtener una lista de las flags disponibles.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las flags de comportamiento de la clase ArrayObject.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::getFlags()

<?php
// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Obtiene las flags actuales.
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);

// Establece nuevas flags.
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);

// Obtener las nuevas flags.
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);
?>

El resultado del ejemplo sería:

int(0)
int(2)

Ver también

  • ArrayObject::setFlags


Crear un nuevo iterador desde una instancia ArrayObject

  • « ArrayObject::getFlags
  • ArrayObject::getIteratorClass »
  • PHP Manual
  • ArrayObject
  • Crear un nuevo iterador desde una instancia ArrayObject

ArrayObject::getIterator

(PHP 5, PHP 7)

ArrayObject::getIterator — Crear un nuevo iterador desde una instancia ArrayObject

Descripción

public ArrayObject::getIterator ( ) : ArrayIterator

Crear un nuevo iterador desde una instancia ArrayObject.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un iterador de una clase ArrayObject.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::getIterator()

<?php
$array = array('1' => 'uno',
               '2' => 'dos',
               '3' => 'tres');

$arrayobject = new ArrayObject($array);

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

El resultado del ejemplo sería:

1 => uno
2 => dos
3 => tres


Obtiene el nombre de clase iterador para ArrayObject

  • « ArrayObject::getIterator
  • ArrayObject::ksort »
  • PHP Manual
  • ArrayObject
  • Obtiene el nombre de clase iterador para ArrayObject

ArrayObject::getIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getIteratorClass — Obtiene el nombre de clase iterador para ArrayObject

Descripción

public ArrayObject::getIteratorClass ( ) : string

Obtener el nombre de clase iterador de array que es utilizado por ArrayObject::getIterator().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the iterator class name that is used to iterate over this object.

Ejemplos

Ejemplo #1 ArrayObject::getIteratorClass() example

<?php
// ArrayIterator personalizado (hereda de ArrayIterator)
class MiArrayIterator extends ArrayIterator {
    //Implementación personalizada
}

// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Obtener el nombre de la clase iterador actual
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);

// Establece el nuevo nombre de clase
$fruitsArrayObject->setIteratorClass('MiArrayIterator');

// Obtener el nuevo nombre de clase iterador
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);
?>

El resultado del ejemplo sería:

string(13) "ArrayIterator"
string(15) "MiArrayIterator"

Ver también

  • El método ArrayObject::setIteratorClass


Ordena las entradas por clave

  • « ArrayObject::getIteratorClass
  • ArrayObject::natcasesort »
  • PHP Manual
  • ArrayObject
  • Ordena las entradas por clave

ArrayObject::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::ksort — Ordena las entradas por clave

Descripción

public ArrayObject::ksort ( ) : void

ordenar las entradas por clave, manteniendo la correlación de claves para la entrada. Esto es útil principalmente en arrays asociativos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::ksort()

<?php
$fruits = array("d" => "limon", "a" => "naranja", "b" => "banana", "c" => "manzana");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->ksort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
 ?>

El resultado del ejemplo sería:

a = naranja
b = banana
c = manzana
d = limon

Ver también

  • ArrayObject::asort() - Ordena las entradas por valor
  • ArrayObject::natsort() - Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::natcasesort() - Ordena un array usando un algoritmo orden natural
  • ArrayObject::uasort() - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
  • ArrayObject::uksort() - Ordena las entradas por clave usando una función de comparación definida por el usuario


Ordena un array usando un algoritmo orden natural

  • « ArrayObject::ksort
  • ArrayObject::natsort »
  • PHP Manual
  • ArrayObject
  • Ordena un array usando un algoritmo orden natural

ArrayObject::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natcasesort — Ordena un array usando un algoritmo orden natural

Descripción

public ArrayObject::natcasesort ( ) : void

Este método es la versión insensible de ArrayObject::natsort.

Este método implementa un algoritmo que ordena string alfanuméricos en la forma en que un humano debe mantener la asociación clave/valor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::natcasesort()

<?php
$array = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png', 'img1.png', 'IMG3.png');

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Orden estándar\n";
print_r($arr1);

$arr2->natcasesort();
echo "\nOrden natural (mayúsculas/minúsculas)\n";
print_r($arr2);
?>

El resultado del ejemplo sería:

Orden estándar
ArrayObject Object
(
    [0] => IMG0.png
    [5] => IMG3.png
    [4] => img1.png
    [2] => img10.png
    [1] => img12.png
    [3] => img2.png
)

Orden natural (mayúsculas/minúsculas)
ArrayObject Object
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

Para obtener más información véase la página: » Comparación de cadenas en orden natural de Martin Pool's.

Ver también

  • ArrayObject::asort() - Ordena las entradas por valor
  • ArrayObject::ksort() - Ordena las entradas por clave
  • ArrayObject::natsort() - Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::uasort() - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
  • ArrayObject::uksort() - Ordena las entradas por clave usando una función de comparación definida por el usuario


Ordena entradas usando un algoritmo de orden natural

  • « ArrayObject::natcasesort
  • ArrayObject::offsetExists »
  • PHP Manual
  • ArrayObject
  • Ordena entradas usando un algoritmo de orden natural

ArrayObject::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natsort — Ordena entradas usando un algoritmo de orden natural

Descripción

public ArrayObject::natsort ( ) : void

Este método implementa un algoritmo que ordena string alfanuméricas en la forma en que un humano seguiría manteniendo la asociación clave/valor. Esto se describe como un "orden natural". Un ejemplo de la diferencia entre este algoritmo y los algoritmos comunes de computadoras para ordenar string. (Usado en el método ArrayObject::asort) puede verse en el siguiente ejemplo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::natsort()

<?php
$array = array("img12.png", "img10.png", "img2.png", "img1.png");

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Ordenamiento estándar\n";
print_r($arr1);

$arr2->natsort();
echo "\nOrdenamiento de orden naturar\n";
print_r($arr2);
?>

El resultado del ejemplo sería:

Ordenamiento estándar
ArrayObject Object
(
    [3] => img1.png
    [1] => img10.png
    [0] => img12.png
    [2] => img2.png
)

Ordenamiento de orden naturar
ArrayObject Object
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

Para obtener más información véase la página: » Comparación de cadenas en orden natural de Martin Pool's.

Ver también

  • ArrayObject::asort() - Ordena las entradas por valor
  • ArrayObject::ksort() - Ordena las entradas por clave
  • ArrayObject::natcasesort() - Ordena un array usando un algoritmo orden natural
  • ArrayObject::uasort() - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
  • ArrayObject::uksort() - Ordena las entradas por clave usando una función de comparación definida por el usuario


Devuelve si el índice solicitado existe

  • « ArrayObject::natsort
  • ArrayObject::offsetGet »
  • PHP Manual
  • ArrayObject
  • Devuelve si el índice solicitado existe

ArrayObject::offsetExists

(PHP 5, PHP 7)

ArrayObject::offsetExists — Devuelve si el índice solicitado existe

Descripción

public ArrayObject::offsetExists ( mixed $index ) : bool

Parámetros

index

El índice a ser comprobado.

Valores devueltos

true si el índice solicitado existe, en caso contrario false

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::offsetExists()

<?php
$arrayobj = new ArrayObject(array('cero', 'uno', 'ejemplo'=>'e.j.'));
var_dump($arrayobj->offsetExists(1));
var_dump($arrayobj->offsetExists('ejemplo'));
var_dump($arrayobj->offsetExists('noencontrado'));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(false)


Devuelve el valor del índice especificado

  • « ArrayObject::offsetExists
  • ArrayObject::offsetSet »
  • PHP Manual
  • ArrayObject
  • Devuelve el valor del índice especificado

ArrayObject::offsetGet

(PHP 5, PHP 7)

ArrayObject::offsetGet — Devuelve el valor del índice especificado

Descripción

public ArrayObject::offsetGet ( mixed $index ) : mixed

Parámetros

index

El índice con el valor.

Valores devueltos

El valor del índice especificado o null.

Errores/Excepciones

Produce un mensajde de error E_NOTICE al especificar un índice inexistente.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::offsetGet()

<?php
$arrayobj = new ArrayObject(array('cero', 7, 'ejemplo'=>'p.ej.'));
var_dump($arrayobj->offsetGet(1));
var_dump($arrayobj->offsetGet('ejemplo'));
var_dump($arrayobj->offsetExists('no_encontrado'));
?>

El resultado del ejemplo sería:

int(7)
string(5) "p.ej."
bool(false)


Establece el valor en el índice especificado

  • « ArrayObject::offsetGet
  • ArrayObject::offsetUnset »
  • PHP Manual
  • ArrayObject
  • Establece el valor en el índice especificado

ArrayObject::offsetSet

(PHP 5, PHP 7)

ArrayObject::offsetSet — Establece el valor en el índice especificado

Descripción

public ArrayObject::offsetSet ( mixed $index , mixed $newval ) : void

Establecer el valor en el índice especificado por newval.

Parámetros

index

El índice a ser establecido.

newval

El nuevo valor para el index.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::offsetSet()

<?php
class Ejemplo {
    public $property = 'prop:public';
}
$arrayobj = new ArrayObject(new Ejemplo());
$arrayobj->offsetSet(4, 'cuatro');
$arrayobj->offsetSet('grupo', array('g1', 'g2'));
var_dump($arrayobj);

$arrayobj = new ArrayObject(array('cero','uno'));
$arrayobj->offsetSet(null, 'último');
var_dump($arrayobj);
?>

El resultado del ejemplo sería:

object(ArrayObject)#1 (3) {
  ["property"]=>
  string(11) "prop:public"
  [4]=>
  string(6) "cuatro"
  ["grupo"]=>
  array(2) {
    [0]=>
    string(2) "g1"
    [1]=>
    string(2) "g2"
  }
}
object(ArrayObject)#3 (3) {
  [0]=>
  string(4) "cero"
  [1]=>
  string(3) "uno"
  [2]=>
  string(6) "último"
}

Ver también

  • ArrayObject::append() - Añade un valor


Destruye el valor para el índice especificado

  • « ArrayObject::offsetSet
  • ArrayObject::serialize »
  • PHP Manual
  • ArrayObject
  • Destruye el valor para el índice especificado

ArrayObject::offsetUnset

(PHP 5, PHP 7)

ArrayObject::offsetUnset — Destruye el valor para el índice especificado

Descripción

public ArrayObject::offsetUnset ( mixed $index ) : void

Destruir el valor para el índice especificado.

Parámetros

index

El índice a ser destruido.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::offsetUnset()

<?php
$arrayobj = new ArrayObject(array(0=>'cero',2=>'dos'));
$arrayobj->offsetUnset(2);
var_dump($arrayobj);
?>

El resultado del ejemplo sería:

object(ArrayObject)#1 (1) {
  [0]=>
  string(4) "cero"
}


Serializar un ArrayObject

  • « ArrayObject::offsetUnset
  • ArrayObject::setFlags »
  • PHP Manual
  • ArrayObject
  • Serializar un ArrayObject

ArrayObject::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::serialize — Serializar un ArrayObject

Descripción

public ArrayObject::serialize ( ) : string

Serializa un ArrayObject.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Representación serializada de ArrayObject.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::serialize()

<?php
$o = new ArrayObject();

$s1 = serialize($o);
$s2 = $o->serialize();

var_dump($s1);
var_dump($s2);
?>

El resultado del ejemplo sería:

string(45) "C:11:"ArrayObject":21:{x:i:0;a:0:{};m:a:0:{}}"
string(21) "x:i:0;a:0:{};m:a:0:{}"

Ver también

  • ArrayObject::unserialize() - Deserializar el objeto ArrayObject
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Serialización de objetos


Establece las flags de comportamiento

  • « ArrayObject::serialize
  • ArrayObject::setIteratorClass »
  • PHP Manual
  • ArrayObject
  • Establece las flags de comportamiento

ArrayObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setFlags — Establece las flags de comportamiento

Descripción

public ArrayObject::setFlags ( int $flags ) : void

Establecer las flags que cambian el comportamiento de la clase ArrayObject.

Parámetros

flags

El nuevo comportamiento de ArrayObject. Se necesita una máscara de bits, o constantes con nombre. El uso de constantes con nombre es bastante recomendable para asegurar la compatibilidad con versiones futuras.

Las flags de comportamiento disponibles se enumeran a continuación. El significado de estos parámetros están descritos en las constantes predefinidas.

Flags de comportamiento de ArrayObject
value | constant
1 | ArrayObject::STD_PROP_LIST
2 | ArrayObject::ARRAY_AS_PROPS

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::setFlags()

<?php
// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Intento de usar una clave de array como propiedad
var_dump($fruitsArrayObject->limones);
// Establecer que las claves del array puedan ser usadas como propiedades
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);
// Vuelva a intentarlo
var_dump($fruitsArrayObject->limones);
?>

El resultado del ejemplo sería:

NULL
int(1)


Establece el nombre de clase iterador para ArrayObject

  • « ArrayObject::setFlags
  • ArrayObject::uasort »
  • PHP Manual
  • ArrayObject
  • Establece el nombre de clase iterador para ArrayObject

ArrayObject::setIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setIteratorClass — Establece el nombre de clase iterador para ArrayObject

Descripción

public ArrayObject::setIteratorClass ( string $iterator_class ) : void

Establecer el nombre de clase iterador que es usado por ArrayObject::getIterator().

Parámetros

iterator_class

El nombre de clase de el array iterador a usar cuando se itera sobre este objeto.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::setIteratorClass()

<?php
// ArrayIterator personalizado (hereda de ArrayIterator)
class MiArrayIterator extends ArrayIterator {
    // custom implementation
}

// Array de frutas
$fruits = array("limones" => 1, "naranjas" => 4, "bananas" => 5, "manzanas" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Establece el nombre de clase del iterador nuevamente.
$fruitsArrayObject->setIteratorClass('MiArrayIterator');
print_r($fruitsArrayObject->getIterator());

?>

El resultado del ejemplo sería:

MyArrayIterator Object
(
    [limones] => 1
    [naranjas] => 4
    [bananas] => 5
    [manzanas] => 10
)


Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves

  • « ArrayObject::setIteratorClass
  • ArrayObject::uksort »
  • PHP Manual
  • ArrayObject
  • Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves

ArrayObject::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uasort — Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves

Descripción

public ArrayObject::uasort ( callable $cmp_function ) : void

Esta función ordena las entradas de forma que las claves mantengan su correlación con la entrada que está asociada con, una función de comparación definida por el usuario.

Esto se utiliza principalmente para ordenar arrays asociativos donde el orden de los elementos es importante.

Parámetros

cmp_function

La función cmp_function acepta 2 parámetros que serán llenados por pares de entradas. La función de comparación debe devolver un integer menor que, igual a, o mayor que cero si el primer argumento es menor que, igual a, o mayor que el segundo.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::uasort()

<?php
// Función de comparación
function cmp($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Array a ser ordenado
$array = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
$arrayObject = new ArrayObject($array);
print_r($arrayObject);

// Ordena e imprime el resultado del array
$arrayObject->uasort('cmp');
print_r($arrayObject);
?>

El resultado del ejemplo sería:

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

Ver también

  • ArrayObject::asort() - Ordena las entradas por valor
  • ArrayObject::ksort() - Ordena las entradas por clave
  • ArrayObject::natsort() - Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::natcasesort() - Ordena un array usando un algoritmo orden natural
  • ArrayObject::uksort() - Ordena las entradas por clave usando una función de comparación definida por el usuario


Ordena las entradas por clave usando una función de comparación definida por el usuario

  • « ArrayObject::uasort
  • ArrayObject::unserialize »
  • PHP Manual
  • ArrayObject
  • Ordena las entradas por clave usando una función de comparación definida por el usuario

ArrayObject::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uksort — Ordena las entradas por clave usando una función de comparación definida por el usuario

Descripción

public ArrayObject::uksort ( callable $cmp_function ) : void

Esta función ordena las claves de las entradas usando una función de compración suministrada por el usuario. La correlación de clave será mantenida.

Parámetros

cmp_function

La función de devolución de llamada de comparación.

La función cmp_function acepta 2 parámetros que serán llenados por pares de entradas. La función de comparación debe devolver un integer menor que, igual a, o mayor que cero si el primer argumento es menor que, igual a, o mayor que el segundo.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de ArrayObject::uksort()

<?php
function cmp($a, $b) {
    $a = preg_replace('@^(a|an|the) @', '', $a);
    $b = preg_replace('@^(a|an|the) @', '', $b);
    return strcasecmp($a, $b);
}

$array = array("John" => 1, "la Tierra" => 2, "una manzana" => 3, "una banana" => 4);
$arrayObject = new ArrayObject($array);
$arrayObject->uksort('cmp');

foreach ($arrayObject as $key => $value) {
    echo "$key: $value\n";
}
?>

El resultado del ejemplo sería:

una manzana: 3
una banana: 4
la Tierra: 2
John: 1

Ver también

  • ArrayObject::asort() - Ordena las entradas por valor
  • ArrayObject::ksort() - Ordena las entradas por clave
  • ArrayObject::natsort() - Ordena entradas usando un algoritmo de orden natural
  • ArrayObject::natcasesort() - Ordena un array usando un algoritmo orden natural
  • ArrayObject::uasort() - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves


Deserializar el objeto ArrayObject

  • « ArrayObject::uksort
  • SplObserver »
  • PHP Manual
  • ArrayObject
  • Deserializar el objeto ArrayObject

ArrayObject::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::unserialize — Deserializar el objeto ArrayObject

Descripción

public ArrayObject::unserialize ( string $serialized ) : void

Deserializa un objeto ArrayObject serializado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

serialized

El objeto ArrayObject serializado.

Valores devueltos

El objeto ArrayObject deserializado.

Ver también

  • ArrayIterator::serialize() - Serializar
  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • Serialización de objetos


La interfaz SplObserver

(PHP 5 >= 5.1.0, PHP 7)

Introducción

La interfaz SplObserver se utiliza junto con SplSubject para implementar el patrón de diseño observador.

Sinopsis de la Interfaz

SplObserver {
/* Métodos */
abstract public update ( SplSubject $subject ) : void
}

Tabla de contenidos

  • SplObserver::update — Recibe actualizaciones de sujeto


Recibe actualizaciones de sujeto

  • « SplObserver
  • SplSubject »
  • PHP Manual
  • SplObserver
  • Recibe actualizaciones de sujeto

SplObserver::update

(PHP 5 >= 5.1.0, PHP 7)

SplObserver::update — Recibe actualizaciones de sujeto

Descripción

abstract public SplObserver::update ( SplSubject $subject ) : void

Este método es llamado cuando cualquier SplSubject se use para llamar llamadas adjuntas SplSubject::notify().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

subject

El objeto SplSubject notificando al observador de una actualización.

Valores devueltos

No devuelve ningún valor.


El interfaz SplSubject

(PHP 5 >= 5.1.0, PHP 7)

Introducción

El interfaz SplSubject es usado en conjunto con SplObserver para implementar el patrón de diseño Observer.

Sinopsis de la Interfaz

SplSubject {
/* Métodos */
abstract public attach ( SplObserver $observer ) : void
abstract public detach ( SplObserver $observer ) : void
abstract public notify ( ) : void
}

Tabla de contenidos

  • SplSubject::attach — Adjuntar un SplObserver
  • SplSubject::detach — Separa un observador
  • SplSubject::notify — Notificar un observador


Adjuntar un SplObserver

  • « SplSubject
  • SplSubject::detach »
  • PHP Manual
  • SplSubject
  • Adjuntar un SplObserver

SplSubject::attach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::attach — Adjuntar un SplObserver

Descripción

abstract public SplSubject::attach ( SplObserver $observer ) : void

Adjunta un SplObserver de esta forma puede ser notificado cuando hayan actualizaciones.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

observer

El SplObserver a adjuntar.

Valores devueltos

No devuelve ningún valor.


Separa un observador

  • « SplSubject::attach
  • SplSubject::notify »
  • PHP Manual
  • SplSubject
  • Separa un observador

SplSubject::detach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::detach — Separa un observador

Descripción

abstract public SplSubject::detach ( SplObserver $observer ) : void

Separa un observador del sujeto para dejar de notificarlo cuando hayan actualizaciones.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

observer

El SplObserver a separar.

Valores devueltos

No devuelve ningún valor.


Notificar un observador

  • « SplSubject::detach
  • Flujos »
  • PHP Manual
  • SplSubject
  • Notificar un observador

SplSubject::notify

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::notify — Notificar un observador

Descripción

abstract public SplSubject::notify ( ) : void

Notifica todos los observadores adjuntos.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Flujos

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Clases de Flujos
  • Constantes predefinidas
  • Filtros de Flujos
  • Contextos de Flujos
  • Errores de Flujos
  • Ejemplos
    • Ejemplo de clase registrada como envoltura de flujo
  • php_user_filter — La clase php_user_filter
    • php_user_filter::filter — Llamado cuando se aplica un filtro
    • php_user_filter::onClose — Llamado cuando se cierra el filtro
    • php_user_filter::onCreate — Llamado cuando se crea el filtro
  • streamWrapper — La clase streamWrapper
    • streamWrapper::__construct — Construye una nueva envoltura de flujo
    • streamWrapper::__destruct — Destruye una envoltura de flujo existente
    • streamWrapper::dir_closedir — Cerrar un gestor de directorio
    • streamWrapper::dir_opendir — Abrir un gestor de directorio
    • streamWrapper::dir_readdir — Leer una entrada desde el gestor de directorio
    • streamWrapper::dir_rewinddir — Rebobina el gestor de directorio
    • streamWrapper::mkdir — Crear un directorio
    • streamWrapper::rename — Renombra un archivo o directorio
    • streamWrapper::rmdir — Elimina un directorio
    • streamWrapper::stream_cast — Recuperar el recurso subyacente
    • streamWrapper::stream_close — Cerrar un recurso
    • streamWrapper::stream_eof — Comprueba si un puntero a un archivo está en el final del archivo (EOF)
    • streamWrapper::stream_flush — Vuelca la salida
    • streamWrapper::stream_lock — Bloqueo de archivos asesorado
    • streamWrapper::stream_metadata — Cambiar las opciones del flujo
    • streamWrapper::stream_open — Abre un archivo o una URL
    • streamWrapper::stream_read — Leer un flujo
    • streamWrapper::stream_seek — Busca la ubicación específica en un flujo
    • streamWrapper::stream_set_option — Cambiar las opciones del flujo
    • streamWrapper::stream_stat — Recuperar información sobre un recurso de archivo
    • streamWrapper::stream_tell — Recuperar la posición actual de un flujo
    • streamWrapper::stream_truncate — Truncar un flujo
    • streamWrapper::stream_write — Escribir en un flujo
    • streamWrapper::unlink — Borrar un archivo
    • streamWrapper::url_stat — Recuperar información sobre un archivo
  • Funciones de Flujos
    • stream_bucket_append — Añade un recipiente a una cadena de recipientes
    • stream_bucket_make_writeable — Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él
    • stream_bucket_new — Crear un nuevo recipiente para usarlo en el flujo actual
    • stream_bucket_prepend — Añade un recipiente al principio de una cadena de recipientes
    • stream_context_create — Crear un contexto de flujo
    • stream_context_get_default — Recuperar el contexto de flujo predeterminado
    • stream_context_get_options — Recuperar las opciones para un flujo/envoltura/contexto
    • stream_context_get_params — Recuperar los parámetros de un contexto
    • stream_context_set_default — Establecer el contexto de flujo predeterminado
    • stream_context_set_option — Establece una opción para un flujo/envoltura/contexto
    • stream_context_set_params — Establecer parámetros para un flujo/envoltura/contexto
    • stream_copy_to_stream — Copia información desde un flujo a otro
    • stream_filter_append — Enlaza un filtro a un flujo
    • stream_filter_prepend — Adjunta un filtro a un flujo
    • stream_filter_register — Registrar un filtro de flujo definido por el usuario
    • stream_filter_remove — Elimina un filtro de un flujo
    • stream_get_contents — Transfiere el resto de un flujo a una cadena
    • stream_get_filters — Recuperar la lista de los filtros registrados
    • stream_get_line — Obtiene una línea del recurso de flujo hasta un delimitador dado
    • stream_get_meta_data — Recuperar meta-información o de cabecera de punteros a flujos/archivo
    • stream_get_transports — Recuperar la lista de transportes de socket registrados
    • stream_get_wrappers — Recupera la lista de los flujos registrados
    • stream_is_local — Comprueba si un flujo es un flujo local
    • stream_isatty — Check if a stream is a TTY
    • stream_notification_callback — Una función de retrollamada para el parámetro de contexto de notificación
    • stream_register_wrapper — Alias de stream_wrapper_register
    • stream_resolve_include_path — Resuelve el nombre de archivo en la ruta incluida
    • stream_select — Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
    • stream_set_blocking — Establecer el modo bloqueo/no-bloqueo en un flujo
    • stream_set_chunk_size — Establecer el tamaño de trozo de flujo
    • stream_set_read_buffer — Establece el búfer de lectura de archivos en el flujo dado
    • stream_set_timeout — Establecer un perido de tiempo de espera en un flujo
    • stream_set_write_buffer — Establece el búfer para escritura de ficheros en el flujo dado
    • stream_socket_accept — Acepta una conexión sobre un socket creado por stream_socket_server
    • stream_socket_client — Abrir una conexión de socket de dominio de Internet o Unix
    • stream_socket_enable_crypto — Activa/desactiva la encriptación en un socket ya conectado
    • stream_socket_get_name — Recuperar el nombre de los sockets locales o remotos
    • stream_socket_pair — Crea un pareja de flujos de socket conectados e indistinguibles
    • stream_socket_recvfrom — Recibir información de un socket, conectado o no
    • stream_socket_sendto — Envía un mensaje a un socket, ya esté conectado o no
    • stream_socket_server — Crear un socket de servidor de dominio de Internet o de Unix
    • stream_socket_shutdown — Cerrar una conexión full-duplex
    • stream_supports_lock — Indica si el flujo soporta bloqueo
    • stream_wrapper_register — Registra una envoltura de URL implementada como una clase de PHP
    • stream_wrapper_restore — Restablece una envoltura incluida que se dejó de registrar previamente
    • stream_wrapper_unregister — Deja de registrar una envoltura de URL


Introducción

Los flujos fueron introducidos en PHP 4.3.0 como una manera de generalizar operaciones con ficheros, redes, compresión de datos, y otras operaciones que comparten un conjunto común de funciones y usos. En su definición más simple, un flujo es un objeto de tipo resource que exhibe un comportamiento similar al de un flujo. Esto es, puede ser leído o escrito de una manera lineal, y puede usar la función fseek() para buscar posiciones arbitrarias dentro del flujo.

Una envoltura es un código adicional que le indica al flujo cómo manejar protocolos/codificaciones específicos. Por ejemplo, la envoltura http sabe cómo traducir un URL a una petición HTTP/1.0 para un fichero en un servidor remoto. Existen muchas envolturas incluidas en PHP de manera predeterminada (véase Protocolos y Envolturas soportados), y también se pueden añadir envolturas personalizadas a un script de PHP usando stream_wrapper_register(), o directamente desde una extensión. Ya que se puede añadir cualquier clase de envoltura a PHP, no existe un límite establecido sobre lo que se puede hacer con ellas. Para acceder a la lista de las envolturas actualmente registradas, use stream_get_wrappers().

Un flujo está descrito como: esquema://objetivo

  • esquema(string) - El nombre de la envoltura que se va a usar. Algunos ejemplos incluyen: file, http, https, ftp, ftps, compress.zlib, compress.bz2, y php. Una lista con las envolturas incluidas en PHP puede verse en la sección Protocolos y Envolturas soportados. Si no se especifica una envoltura, se usará la función predeterminada (normalmente file://).
  • objetivo - Depende de la envoltura usada. Para flujos relacionados con el sistema de ficheros, nomrmalmente es una ruta y un nombre de fichero. Para flujos relacionados con redes, normalmente es un nombre de host, a menudo con una ruta añadida al final. Se puede encontrar una descripción de los objetivos para los flujos incluidos en PHP en la sección Protocolos y Envolturas soportados.


Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación
  • Configuración en tiempo de ejecución
  • Clases de Flujos


  • « Requerimientos
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

Los flujos son parte integral de PHP desde la versión 4.3.0. No se necesita nada para habilitarlos.


  • « Instalación
  • Clases de Flujos »
  • PHP Manual
  • Instalación/Configuración
  • Configuración en tiempo de ejecución

Configuración en tiempo de ejecución

Esta extensión no tiene directivas de configuración definidas en php.ini.


Clases de Flujos

Las envolturas diseñadas por el usuario se pueden registrar mediante stream_wrapper_register(), usando la definición de la clase mostrada en esa página del manual.

La clase php_user_filter está predefinida y es una clase base abstracta para usarla con filtros definidos por el usuario. Véase la página del manual de stream_filter_register() para detalles sobre la implementación de filtros definidos por el usuario.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constante | Descripción
STREAM_FILTER_READ * | Usada con stream_filter_append() y stream_filter_prepend() para indicar que el filtro especificado debería aplicarse solamente al leer
STREAM_FILTER_WRITE * | Usada con stream_filter_append() y stream_filter_prepend() para indicar que el filtro especificado debería aplicarse solamente al escribir
STREAM_FILTER_ALL * | Esta constante es equivalente a STREAM_FILTER_READ | STREAM_FILTER_WRITE
PSFS_PASS_ON * | Codigo Devuelto indicando que el filtro de espacio de usuario devolvió recipientes en $out.
PSFS_FEED_ME * | Codigo Devuelto indicando que el filtro de espacio de usuario no devolvió recipientes en $out (es decir, No hay información disponible).
PSFS_ERR_FATAL * | Codigo Devuelto indicando que el filtro de espacio de usuario encontró un error irrecuperable (es decir, Recibida información no válida).
PSFS_FLAG_NORMAL | Lectura/escritura normal.
PSFS_FLAG_FLUSH_INC | Un volcado incremental.
PSFS_FLAG_FLUSH_CLOSE | Volcado final antes de cerrar.
STREAM_USE_PATH | Bandera que indica si el flujo usó la ruta incluida.
STREAM_REPORT_ERRORS | Bandera que indica si la envoltura es responsable de lanzar errores usando trigger_error() durante la apertura del flujo. Si no se establece esta bandera, no debería de lanzarse ningún error.
STREAM_CLIENT_ASYNC_CONNECT * | Apertura del socket del cliente de manera asíncrona. Esta opción debe utilizarse junto con la bandera STREAM_CLIENT_CONNECT. Usada con stream_socket_client().
STREAM_CLIENT_CONNECT * | Apertura de la conexión de socket del cliente. Los sockets del cliente deberían incluir siempre esta bandera. Usada con stream_socket_client().
STREAM_CLIENT_PERSISTENT * | El socket del cliente abierto con stream_socket_client() debería permanecer persistente entre cargas de páginas.
STREAM_SERVER_BIND * | Le indica a un flujo creado con stream_socket_server() que enlace al objetivo especificado. Los sockets del servidor deberían incluir siempre esta bandera.
STREAM_SERVER_LISTEN * | Le indica a un flujo creado con stream_socket_server() y enlazado usando la bandera STREAM_SERVER_BIND que inicie la escucha del socket. Los transportes orientados a conexión (como TCP) deben usar esta bandera, de otro modo el socket del servidor no se habilitará. Usar esta bandera para transportes no orientados a conexión (como UDP) es un error.
STREAM_NOTIFY_RESOLVE * | Ha sido resuelta una dirección remota necesaria para este flujo, o la resolución falló. Véase severity para una indicación de lo que sucedió.
STREAM_NOTIFY_CONNECT | Ha sido establecida una conexión con un recurso externo.
STREAM_NOTIFY_AUTH_REQUIRED | Se requiere autorización adicional para acceder al recurso especificado. Normalmente emitido con nivel de severity de STREAM_NOTIFY_SEVERITY_ERR.
STREAM_NOTIFY_MIME_TYPE_IS | El tipo mime del recurso ha sido indentificado, consulte message para una descripción del tipo encontrado.
STREAM_NOTIFY_FILE_SIZE_IS | El tamaño del recurso ha sido encontrado.
STREAM_NOTIFY_REDIRECTED | El recurso externo ha redireccionado el flujo a una ubicación alternativa. Consulte message.
STREAM_NOTIFY_PROGRESS | Indica el progreso actual de la transmisión del flujo en bytes_transferred y posiblemente también en bytes_max.
STREAM_NOTIFY_COMPLETED * | No hay más información disponible en el flujo.
STREAM_NOTIFY_FAILURE | Ocurrión un error genérico en el flujo, consulte message y message_code para más detalles.
STREAM_NOTIFY_AUTH_RESULT | La autorización ha sido completada (con o sin éxito).
STREAM_NOTIFY_SEVERITY_INFO | Notificación normal, ningún error relacionado.
STREAM_NOTIFY_SEVERITY_WARN | Condición de no haber ningún error crítico. El proceso puede continuar.
STREAM_NOTIFY_SEVERITY_ERR | Ocurrió un error crítico. El proceso no puede continuar.
STREAM_IPPROTO_ICMP + | Proporciona un socket ICMP.
STREAM_IPPROTO_IP + | Proporciona un socket IP.
STREAM_IPPROTO_RAW + | Proporciona un socket RAW.
STREAM_IPPROTO_TCP + | Proporciona un socket TCP.
STREAM_IPPROTO_UDP + | Proporciona un socket UDP.
STREAM_PF_INET + | Protocolo de Internet Versión 4 (IPv4).
STREAM_PF_INET6 + | Protocolo de Internet Versión 6 (IPv6).
STREAM_PF_UNIX + | Protocolos internos de sistemas Unix.
STREAM_SOCK_DGRAM + | Proporciona datagramas, que son mensajes no orientados a conexión (UDP, por ejemplo).
STREAM_SOCK_RAW + | Proporciona un socket sin tratar, el cuál porporciona acceso a los protocolos e interfaces de red internos. Normalmente este tipo de socket está disponible para el usuario root.
STREAM_SOCK_RDM + | Proporciona un socket RDM (Reliably-Delivered Messages, Mensajes Formalmente Emitidos).
STREAM_SOCK_SEQPACKET + | Proporciona un socket de flujo de paquetes secuenciados.
STREAM_SOCK_STREAM + | Proporciona flujos secuenciados de bytes bidireccionales con un mecanismo de transmisión de información fuera de banda (TCP, por ejemplo).
STREAM_SHUT_RD | Usado con stream_socket_shutdown() para deshabilitar más recepciones. Añadido en PHP 5.2.1.
STREAM_SHUT_WR | Usado con stream_socket_shutdown() para deshabilitar más transmisiones. Añadido en PHP 5.2.1.
STREAM_SHUT_RDWR | Usado con stream_socket_shutdown() para deshabilitar más recepciones y transmisiones. Añadido en PHP 5.2.1.
STREAM_CAST_FOR_SELECT | Conversión del tipo de flujo, para cuando stream_select() llama a stream_cast().
STREAM_CAST_AS_STREAM | Conversión del tipo de flujo, cuando stream_cast() es llamada de otro modo (vea la constante de arriba).
STREAM_META_TOUCH | Usado con stream_metadata(), para especificar la llamada a touch().
STREAM_META_OWNER | Usado con stream_metadata(), para especificar la llamda a chown().
STREAM_META_OWNER_NAME | Usado con stream_metadata(), para especificar la llamada a chown().
STREAM_META_GROUP | Usado con stream_metadata(), para especificar la llamada a chgrp().
STREAM_META_GROUP_NAME | Usado con stream_metadata(), para especificar la llamada a chgrp().
STREAM_META_ACCESS | Usado con stream_metadata(), para especificar la llamada a chmod().

Nota: Las constantes marcadas con * están disponibles desde PHP 5.0.0.

Nota: Las constantes marcadas con + están disponibles desde PHP 5.1.0 y son usadas junto con stream_socket_pair(). Por favor, observe que alguna de estas constantes podría no estar disponible en su sistema.

Nota: Las constantes STREAM_META_* están disponibles desde PHP 5.4.0 y están destinadas a ser usadas con stream_metadata().


Filtros de Flujos

Un filtro es una pieza final de código que puede realizar operaciones sobre información que está siendo leída o escrita en un flujo. Se puede apilar cualquier número de filtros en un flujo. Los filtros personalizados se pueden definir en un script de PHP usando stream_filter_register() o en una extensión. Para acceder a la lista de los filtros actualmente registrados, use stream_get_filters().


Contextos de Flujos

Un contexto es un conjunto de parámetros y opciones específicas de envolturas que modifican o mejoran el comportamiento de un flujo. Los contextos se crean usando stream_context_create() y se pueden pasar a la mayoría de las funciones de creación de flujos relacionados con sistemas de archivos (esto es, fopen(), file(), file_get_contents(), etc...).

Se pueden especificar opciones cuando se llama a stream_context_create(), o después, usando stream_context_set_option(). Una lista de opciones específicas de envolturas se puede encontrar en el capítulo Opciones y parámetros de contexto.

Se pueden especificar parámetros para los contextos usando la función stream_context_set_params().


Errores de Flujos

Como con cualquier función relacionada con un archivo o con un socket, una operación sobre un flujo puede fallar por varias razones normales (esto es: Incapaz de conectarse al host remoto, archivo no encontrado, etc...). Una llamada relacionada con un flujo puede también fallar porque el flujo no está registrado en el sistema en ejecución. Véase la matriz devuelta por stream_get_wrappers() para una lista de los flujos soportados por su instalación de PHP. Como con la mayoría de la funciones internas de PHP, si ocurre un error se generará un mensaje E_WARNING describiendo la naturaleza del error.


Ejemplos

Tabla de contenidos

  • Ejemplo de clase registrada como envoltura de flujo

Ejemplo #1 Usar file_get_contents() para recuperar información desde múltiples fuentes

<?php
/* Leer un archivo local desde /home/bar */
$archivolocal = file_get_contents("/home/bar/foo.txt");

/* Igual que arriba, explícitamente nombrando el protocolo FILE */
$archivolocal = file_get_contents("file:///home/bar/foo.txt");

/* Leer un archivo remoto desde www.example.com usando HTTP */
$archivohttp  = file_get_contents("http://www.example.com/foo.txt");

/* Leer un archivo remoto desde www.example.com usando HTTPS */
$archivohttps = file_get_contents("https://www.example.com/foo.txt");

/* Leer un archivo remoto desde ftp.example.com usando FTP */
$archivoftp   = file_get_contents("ftp://user:pass@ftp.example.com/foo.txt");

/* Leer un archivo remoto desde ftp.example.com usando FTPS */
$archivoftps  = file_get_contents("ftps://user:pass@ftp.example.com/foo.txt");
?>

Ejemplo #2 Hacer una petición POST a un servidor https

<?php
/* Enviar una petición POST a https://secure.example.com/form_action.php
* Incluir los elementos de formulario llamados "foo" y "bar" con valores sin importancia
*/

$sock = fsockopen("ssl://secure.example.com", 443, $errno, $errstr, 30);
if (!$sock) die("$errstr ($errno)\n");

$data = "foo=" . urlencode("Valor para Foo") . "&bar=" . urlencode("Valor para Bar");

fwrite($sock, "POST /form_action.php HTTP/1.0\r\n");
fwrite($sock, "Host: secure.example.com\r\n");
fwrite($sock, "Content-type: application/x-www-form-urlencoded\r\n");
fwrite($sock, "Content-length: " . strlen($data) . "\r\n");
fwrite($sock, "Accept: */*\r\n");
fwrite($sock, "\r\n");
fwrite($sock, $data);

$headers = "";
while ($str = trim(fgets($sock, 4096)))
$headers .= "$str\n";

echo "\n";

$body = "";
while (!feof($sock))
$body .= fgets($sock, 4096);

fclose($sock);
?>

Ejemplo #3 Escribir información en un archivo compirmido

<?php
/* Crear un archivo comprimido que contiene una cadena arbitraria
* El archivo se puede volver a leer usando el flujo compress.zlib o
* descomprimiéndolo desde la línea de comandos usando 'gzip -d foo-bar.txt.gz'
*/
$fp = fopen("compress.zlib://foo-bar.txt.gz", "wb");
if (!$fp) die("No se puede crear el archivo.");

fwrite($fp, "Esto es una prueba.\n");

fclose($fp);
?>


Ejemplo de clase registrada como envoltura de flujo

El ejemplo de abajo implementa un gestor de protocolo var:// que permite el acceso a la lectura/escritura de una variable global nominada usando un flujo de sistema de archivos estándar tal como fread(). El protocolo var:// implementado abajo, dada la URL "var://foo", leerá/escribirá información hacia/desde $GLOBALS["foo"].

Ejemplo #1 Un Flujo para leer/escribir variables globales

<?php

class FlujoVariable {
    var $posición;
    var $nombre;

    function stream_open($ruta, $modo, $opciones, &$ruta_abierta)
    {
        $url = parse_url($ruta);
        $this->nombre = $url["host"];
        $this->posición = 0;

        return true;
    }

    function stream_read($cuenta)
    {
        $ret = substr($GLOBALS[$this->nombre], $this->posición, $cuenta);
        $this->posición += strlen($ret);
        return $ret;
    }

    function stream_write($data)
    {
        $izquierda = substr($GLOBALS[$this->nombre], 0, $this->posición);
        $derecha = substr($GLOBALS[$this->nombre], $this->posición + strlen($data));
        $GLOBALS[$this->nombre] = $izquierda . $data . $derecha;
        $this->posición += strlen($data);
        return strlen($data);
    }

    function stream_tell()
    {
        return $this->posición;
    }

    function stream_eof()
    {
        return $this->posición >= strlen($GLOBALS[$this->nombre]);
    }

    function stream_seek($índice, $dónde)
    {
        switch ($dónde) {
            case SEEK_SET:
                if ($índice < strlen($GLOBALS[$this->nombre]) && $índice >= 0) {
                     $this->posición = $índice;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_CUR:
                if ($índice >= 0) {
                     $this->posición += $índice;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_END:
                if (strlen($GLOBALS[$this->nombre]) + $índice >= 0) {
                     $this->posición = strlen($GLOBALS[$this->nombre]) + $índice;
                     return true;
                } else {
                     return false;
                }
                break;

            default:
                return false;
        }
    }

    function stream_metadata($ruta, $opción, $var)
    {
        if($opción== STREAM_META_TOUCH) {
            $url = parse_url($ruta);
            $varname = $url["host"];
            if(!isset($GLOBALS[$varname])) {
                $GLOBALS[$varname] = '';
            }
            return true;
        }
        return false;
    }
}

stream_wrapper_register("var", "FlujoVariable")
    or die("Error al registrar el protocolo");

$mivar = "";

$fp = fopen("var://mivar", "r+");

fwrite($fp, "línea1\n");
fwrite($fp, "línea2\n");
fwrite($fp, "línea3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($mivar);

?>

El resultado del ejemplo sería:

línea1
línea2
línea3
string(24) "línea1
línea2
línea3
"


La clase php_user_filter

(PHP 5, PHP 7, PHP 8)

Introducción

Los hijos de esta clase son pasados a stream_filter_register().

Sinopsis de la Clase

php_user_filter {
/* Propiedades */
public $filtername ;
public $params ;
/* Métodos */
public filter ( resource $in , resource $out , int &$consumed , bool $closing ) : int
public onClose ( ) : void
public onCreate ( ) : bool
}

Propiedades

filtername

El nombre del filtro registrado por stream_filter_append().

params

Tabla de contenidos

  • php_user_filter::filter — Llamado cuando se aplica un filtro
  • php_user_filter::onClose — Llamado cuando se cierra el filtro
  • php_user_filter::onCreate — Llamado cuando se crea el filtro


Llamado cuando se aplica un filtro

  • « php_user_filter
  • php_user_filter::onClose »
  • PHP Manual
  • php_user_filter
  • Llamado cuando se aplica un filtro

php_user_filter::filter

(PHP 5, PHP 7, PHP 8)

php_user_filter::filter — Llamado cuando se aplica un filtro

Descripción

public php_user_filter::filter ( resource $in , resource $out , int &$consumed , bool $closing ) : int

Este método es llamado siempre que los datos son leídos desde o escritos en el flujo adjunto (como con fread() o fwrite()).

Parámetros

in

in es un recurso que apunta a una cadena de recipientes que contiene uno o más objetos recipiente que contienen información que va a ser filtrada.

out

out es un recurso que apunta a una segunda cadena de recipientes dentro de la cual se deberían ubicar los recipientes modificados.

consumed

consumed, el cual siempre debe ser declarado por referencia, debería ser incrementado por la longitud de la información que el filtro lee y altera. En la mayoría de los casos esto significa que se incrementará consumed por $recipiente->datalen para cada $recipiente.

closing

Si el flujo está en el proceso de cierre (y por lo tanto éste es el último pase a través de la cadena de filtros), el parámetro closing será establecido a true.

Valores devueltos

El método filter() debe devolver uno de estos tres valores cuando se complete.

Valor Devuelto | Significado
PSFS_PASS_ON | El filtró se procesó con éxito con información disponible en la cadena de recipientes out.
PSFS_FEED_ME | El filtró se procesó con éxito, sin embargo no había información disponible que devolver. Se requiere más información del flujo o del filtro previo.
PSFS_ERR_FATAL (predeterminado) | El filtro experimentó un error irrecuperable y no puede continuar.


Llamado cuando se cierra el filtro

  • « php_user_filter::filter
  • php_user_filter::onCreate »
  • PHP Manual
  • php_user_filter
  • Llamado cuando se cierra el filtro

php_user_filter::onClose

(PHP 5, PHP 7, PHP 8)

php_user_filter::onClose — Llamado cuando se cierra el filtro

Descripción

public php_user_filter::onClose ( ) : void

Este método es llamado bajo el cierre del filtro (normalmente también durante el cierre del flujo), y se ejecuta después de llamar al método flush. Si se asignó o inicializo cualquier recurso durante onCreate(), este sería el momento de destruirlo o deshacerse de él.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de retorono es ignorado.


Llamado cuando se crea el filtro

  • « php_user_filter::onClose
  • streamWrapper »
  • PHP Manual
  • php_user_filter
  • Llamado cuando se crea el filtro

php_user_filter::onCreate

(PHP 5, PHP 7, PHP 8)

php_user_filter::onCreate — Llamado cuando se crea el filtro

Descripción

public php_user_filter::onCreate ( ) : bool

Este método se llama durante la instanciación del objeto de la clase del filtro. Si el filtro asigna o inicializa cualquier otro recurso (como un buffer), éste es el lugar para hacerlo.

Cuando primero se instancia el filtro, y se llama a elfiltro->onCreate(), estarán disponibles varias propiedades como se muestra en la tabla de abajo.

Propiedad | Contenido
FilterClass->filtername | Una cadena que contiene el nombre del filtro con el que fue instanciado. Los filtros pueden ser registrados bajo múltiples nombres o bajo comodines. Use esta propiedad para determinar qué nombre fue usado.
FilterClass->params | El contenido del parámetro params pasado a stream_filter_append() o a stream_filter_prepend().
FilterClass->stream | El recurso de flujo que va a ser filtrado. Quizás disponible sólo durante las llamadas a filter() cuando el parámetro closing es false.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La implementación de este método debería devolver false en caso de error, o true en caso de éxito.


La clase streamWrapper

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

Introducción

Permite implementar sus propios gestores de protocolo y flujos para usarlos con las demás funciones de sistemas de archivos (como fopen(), fread() etc.).

Nota:

Esta NO es una clase real, sólo es un prototipo de cómo debería ser una clase que define su propio protocolo.

Nota:

Implementar los métodos de distinta forma que la descrita aquí puede conducir a un comportamiento indefinido.

Una instancia de esta clase se inicializa tan pronto como una función de flujo intente acceder al protocolo al que está asociado.

Sinopsis de la Clase

streamWrapper {
/* Propiedades */
public resource $context ;
/* Métodos */
__construct ( )
__destruct ( )
public dir_closedir ( ) : bool
public dir_opendir ( string $path , int $options ) : bool
public dir_readdir ( ) : string
public dir_rewinddir ( ) : bool
public mkdir ( string $path , int $mode , int $options ) : bool
public rename ( string $path_from , string $path_to ) : bool
public rmdir ( string $path , int $options ) : bool
public stream_cast ( int $cast_as ) : resource
public stream_close ( ) : void
public stream_eof ( ) : bool
public stream_flush ( ) : bool
public stream_lock ( int $operation ) : bool
public stream_metadata ( string $path , int $option , mixed $value ) : bool
public stream_open ( string $path , string $mode , int $options , string &$opened_path ) : bool
public stream_read ( int $count ) : string
public stream_seek ( int $offset , int $whence = SEEK_SET ) : bool
public stream_set_option ( int $option , int $arg1 , int $arg2 ) : bool
public stream_stat ( ) : array
public stream_tell ( ) : int
public stream_truncate ( int $new_size ) : bool
public stream_write ( string $data ) : int
public unlink ( string $path ) : bool
public url_stat ( string $path , int $flags ) : array
}

Propiedades

recurso de context

El contexto actual, o null si no se pasó ningún contexto a la función que realizó la llamada.

Use la función stream_context_get_options() para analizar el contexto.

Nota:

Esta propiedad debe ser pública para que PHP pueda rellenarla con el recurso de contexto real.

Historial de cambios

Versión | Descripción
5.0.0 | Se añadió la propiedad context.

Ver también

  • Ejemplo de clase registrada como envoltura de flujo
  • stream_wrapper_register()
  • stream_wrapper_unregister()
  • stream_wrapper_restore()

Tabla de contenidos

  • streamWrapper::__construct — Construye una nueva envoltura de flujo
  • streamWrapper::__destruct — Destruye una envoltura de flujo existente
  • streamWrapper::dir_closedir — Cerrar un gestor de directorio
  • streamWrapper::dir_opendir — Abrir un gestor de directorio
  • streamWrapper::dir_readdir — Leer una entrada desde el gestor de directorio
  • streamWrapper::dir_rewinddir — Rebobina el gestor de directorio
  • streamWrapper::mkdir — Crear un directorio
  • streamWrapper::rename — Renombra un archivo o directorio
  • streamWrapper::rmdir — Elimina un directorio
  • streamWrapper::stream_cast — Recuperar el recurso subyacente
  • streamWrapper::stream_close — Cerrar un recurso
  • streamWrapper::stream_eof — Comprueba si un puntero a un archivo está en el final del archivo (EOF)
  • streamWrapper::stream_flush — Vuelca la salida
  • streamWrapper::stream_lock — Bloqueo de archivos asesorado
  • streamWrapper::stream_metadata — Cambiar las opciones del flujo
  • streamWrapper::stream_open — Abre un archivo o una URL
  • streamWrapper::stream_read — Leer un flujo
  • streamWrapper::stream_seek — Busca la ubicación específica en un flujo
  • streamWrapper::stream_set_option — Cambiar las opciones del flujo
  • streamWrapper::stream_stat — Recuperar información sobre un recurso de archivo
  • streamWrapper::stream_tell — Recuperar la posición actual de un flujo
  • streamWrapper::stream_truncate — Truncar un flujo
  • streamWrapper::stream_write — Escribir en un flujo
  • streamWrapper::unlink — Borrar un archivo
  • streamWrapper::url_stat — Recuperar información sobre un archivo


Construye una nueva envoltura de flujo

  • « streamWrapper
  • streamWrapper::__destruct »
  • PHP Manual
  • streamWrapper
  • Construye una nueva envoltura de flujo

streamWrapper::__construct

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::__construct — Construye una nueva envoltura de flujo

Descripción

streamWrapper::__construct ( )

Llamado cuando se abre la envoltura de flujo, justo antes de streamWrapper::stream_open().

Parámetros

Esta función no tiene parámetros.


Destruye una envoltura de flujo existente

  • « streamWrapper::__construct
  • streamWrapper::dir_closedir »
  • PHP Manual
  • streamWrapper
  • Destruye una envoltura de flujo existente

streamWrapper::__destruct

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::__destruct — Destruye una envoltura de flujo existente

Descripción

streamWrapper::__destruct ( )

Llamado al cerrar la envoltura de flujo, justo antes de streamWrapper::stream_flush().

Parámetros

Esta función no tiene parámetros.


Cerrar un gestor de directorio

  • « streamWrapper::__destruct
  • streamWrapper::dir_opendir »
  • PHP Manual
  • streamWrapper
  • Cerrar un gestor de directorio

streamWrapper::dir_closedir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_closedir — Cerrar un gestor de directorio

Descripción

public streamWrapper::dir_closedir ( ) : bool

Este método es llamado en respuesta a closedir().

Cualquier recurso que fue bloqueado o asignado durante la apertura y utiliza el flujo de directorio, debería ser liberado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • closedir() - Cierra un gestor de directorio
  • streamWrapper::dir_opendir() - Abrir un gestor de directorio


Abrir un gestor de directorio

  • « streamWrapper::dir_closedir
  • streamWrapper::dir_readdir »
  • PHP Manual
  • streamWrapper
  • Abrir un gestor de directorio

streamWrapper::dir_opendir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_opendir — Abrir un gestor de directorio

Descripción

public streamWrapper::dir_opendir ( string $path , int $options ) : bool

Este método es llamado en respuesta a opendir().

Parámetros

path

Especifica la URL que fue pasada a opendir().

Nota:

La URL se puede desmontar con parse_url().

options

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • opendir() - Abre un gestor de directorio
  • streamWrapper::dir_closedir() - Cerrar un gestor de directorio
  • parse_url() - Analiza un URL y devuelve sus componentes


Leer una entrada desde el gestor de directorio

  • « streamWrapper::dir_opendir
  • streamWrapper::dir_rewinddir »
  • PHP Manual
  • streamWrapper
  • Leer una entrada desde el gestor de directorio

streamWrapper::dir_readdir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_readdir — Leer una entrada desde el gestor de directorio

Descripción

public streamWrapper::dir_readdir ( ) : string

Este método es llamado en respuesta a readdir().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Debería devolver un valor de tipo string que representa el siguiente nombre de archivo, o false si no hay un siguiente archivo.

Nota:

El valor devuelto será convertido a un valor de tipo string.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Ejemplos

Ejemplo #1 Listar los ficheros de archivos tar

<?php
class streamWrapper {
    protected $fp;

    public function dir_opendir($ruta, $opciones) {
        $url = parse_url($ruta);

        $ruta = $url["host"] . $url["path"];

        if (!is_readable($ruta)) {
            trigger_error("$ruta no es legible por mí", E_USER_NOTICE);
            return false;
        }
        if (!is_file($ruta)) {
            trigger_error("$ruta no es un fichero", E_USER_NOTICE);
            return false;
        }

        $this->fp = fopen($ruta, "rb");
        return true;
    }

    public function dir_readdir() {
        // Extraer la cabecera para esta entrada
        $cabecera = fread($this->fp, 512);
        $data = unpack("a100filename/a8mode/a8uid/a8gid/a12size/a12mtime/a8checksum/a1filetype/a100link/a100linkedfile", $cabecera);

        // Recortar el nombre de archivo y tamaño de archivo
        $nombre_archivo = trim($data["filename"]);

        // Â¿No hay nombre de archivo? Estamos en el final del archivo tar
        if (!$nombre_archivo) {
            return false;
        }

        $octal_bytes = trim($data["size"]);
        // El tamaño de archivo es definido en octetos
        $bytes  = octdec($octal_bytes);

        // tar redondea hacia arriba en múltiplos de 512 bytes (rellenando con ceros)
        $resto = $bytes % 512;
        if ($resto > 0) {
            $bytes += 512 - $resto;
        }

        // Buscar sobre el archivo
        fseek($this->fp, $bytes, SEEK_CUR);

        return $nombre_archivo;
    }

    public function dir_closedir() {
        return fclose($this->fp);
    }

    public function dir_rewinddir() {
        return fseek($this->fp, 0, SEEK_SET);
    }
}

stream_wrapper_register("tar", "streamWrapper");
$gestor = opendir("tar://ejemplo.tar");
while (false !== ($file = readdir($gestor))) {
    var_dump($file);
}

echo "Rewinding..\n";
rewind($gestor);
var_dump(readdir($gestor));

closedir($gestor);
?>

El resultado del ejemplo sería algo similar a:

string(13) "construct.xml"
string(16) "dir-closedir.xml"
string(15) "dir-opendir.xml"
string(15) "dir-readdir.xml"
string(17) "dir-rewinddir.xml"
string(9) "mkdir.xml"
string(10) "rename.xml"
string(9) "rmdir.xml"
string(15) "stream-cast.xml"
string(16) "stream-close.xml"
string(14) "stream-eof.xml"
string(16) "stream-flush.xml"
string(15) "stream-lock.xml"
string(15) "stream-open.xml"
string(15) "stream-read.xml"
string(15) "stream-seek.xml"
string(21) "stream-set-option.xml"
string(15) "stream-stat.xml"
string(15) "stream-tell.xml"
string(16) "stream-write.xml"
string(10) "unlink.xml"
string(12) "url-stat.xml"
Rewinding..
string(13) "construct.xml"

Ver también

  • readdir() - Lee una entrada desde un gestor de directorio


Rebobina el gestor de directorio

  • « streamWrapper::dir_readdir
  • streamWrapper::mkdir »
  • PHP Manual
  • streamWrapper
  • Rebobina el gestor de directorio

streamWrapper::dir_rewinddir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_rewinddir — Rebobina el gestor de directorio

Descripción

public streamWrapper::dir_rewinddir ( ) : bool

Este método es llamado en respuesta a rewinddir().

Debería reiniciar la salida generada por streamWrapper::dir_readdir(). Esto es: La siguiente llamada a streamWrapper::dir_readdir() debería devolver la primera entrada en la ubicación devueta por streamWrapper::dir_opendir().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • rewinddir() - Regresar el gestor de directorio
  • streamWrapper::dir_readdir() - Leer una entrada desde el gestor de directorio


Crear un directorio

  • « streamWrapper::dir_rewinddir
  • streamWrapper::rename »
  • PHP Manual
  • streamWrapper
  • Crear un directorio

streamWrapper::mkdir

(PHP 5, PHP 7, PHP 8)

streamWrapper::mkdir — Crear un directorio

Descripción

public streamWrapper::mkdir ( string $path , int $mode , int $options ) : bool

Este método es llamado en respuesta a mkdir().

Nota:

Para que el mensaje de error apropiado sea devuelto, este método no debería ser definido si la envoltura no soporta la creación de directorios.

Parámetros

path

El directorio que debería ser creado.

mode

El valor pasdo a mkdir().

options

Una máscara a nivel de bits de valores, como STREAM_MKDIR_RECURSIVE.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • mkdir() - Crea un directorio
  • streamwrapper::rmdir() - Elimina un directorio


Renombra un archivo o directorio

  • « streamWrapper::mkdir
  • streamWrapper::rmdir »
  • PHP Manual
  • streamWrapper
  • Renombra un archivo o directorio

streamWrapper::rename

(PHP 5, PHP 7, PHP 8)

streamWrapper::rename — Renombra un archivo o directorio

Descripción

public streamWrapper::rename ( string $path_from , string $path_to ) : bool

Este método es llamado en respuesta a rename().

Debería intentar renombrar path_from a path_to

Nota:

Para que el mensaje de error apropiado sea devuelto, este método no debería ser definido si la envoltura no soporta el renombramiento de archivos.

Parámetros

path_from

La URL al archivo actual.

path_to

La URL que debería ser renombrada por path_from.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • rename() - Renombra un fichero o directorio


Elimina un directorio

  • « streamWrapper::rename
  • streamWrapper::stream_cast »
  • PHP Manual
  • streamWrapper
  • Elimina un directorio

streamWrapper::rmdir

(PHP 5, PHP 7, PHP 8)

streamWrapper::rmdir — Elimina un directorio

Descripción

public streamWrapper::rmdir ( string $path , int $options ) : bool

Este método es llamado en respuesta a rmdir().

Nota:

Para que el mensaje de error apropiado sea devuelto, este método no debería ser definido si la envoltura no soporta la eliminación de directorios.

Parámetros

path

La URL del directorio que debería ser eliminado.

options

Una máscara a nivel de bits de valores, como STREAM_MKDIR_RECURSIVE.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • rmdir() - Elimina un directorio
  • streamwrapper::mkdir() - Crear un directorio
  • streamwrapper::unlink() - Borrar un archivo


Recuperar el recurso subyacente

  • « streamWrapper::rmdir
  • streamWrapper::stream_close »
  • PHP Manual
  • streamWrapper
  • Recuperar el recurso subyacente

streamWrapper::stream_cast

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

streamWrapper::stream_cast — Recuperar el recurso subyacente

Descripción

public streamWrapper::stream_cast ( int $cast_as ) : resource

Este método es llamado en respuesta a stream_select().

Parámetros

cast_as

Puede ser STREAM_CAST_FOR_SELECT cuando stream_select() llama a stream_cast(), o STREAM_CAST_AS_STREAM cuando stream_cast() es llamado para otros usos.

Valores devueltos

Debería devolver el recurso de flujo subyacente usado por la envoltura, o false.

Ver también

  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec


Cerrar un recurso

  • « streamWrapper::stream_cast
  • streamWrapper::stream_eof »
  • PHP Manual
  • streamWrapper
  • Cerrar un recurso

streamWrapper::stream_close

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_close — Cerrar un recurso

Descripción

public streamWrapper::stream_close ( ) : void

Este método es llamado en respuesta a fclose().

Todos los recursos que estaban bloqueados o asignados por la envoltura deberían ser liberados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • fclose() - Cierra un puntero a un archivo abierto
  • streamWrapper::dir_closedir() - Cerrar un gestor de directorio


Comprueba si un puntero a un archivo está en el final del archivo (EOF)

  • « streamWrapper::stream_close
  • streamWrapper::stream_flush »
  • PHP Manual
  • streamWrapper
  • Comprueba si un puntero a un archivo está en el final del archivo (EOF)

streamWrapper::stream_eof

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_eof — Comprueba si un puntero a un archivo está en el final del archivo (EOF)

Descripción

public streamWrapper::stream_eof ( ) : bool

Este método es llamado en respuesta a feof().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Debería devolver true si la posición de lectura/escritura está al final del flujo y no hay más información disponible para leer, o de otro modo false.

Notas

Advertencia

Al leer un fichero entero (por ejemplo, con file_get_contents()), PHP llamará a streamWrapper::stream_read() seguido de streamWrapper::stream_eof() en un bucle, pero siempre y cuando streamWrapper::stream_read() devuelva un texto no vacío, el valor que devuelva streamWrapper::stream_eof() será ignorado.

Ver también

  • feof() - Comprueba si el puntero a un archivo está al final del archivo


Vuelca la salida

  • « streamWrapper::stream_eof
  • streamWrapper::stream_lock »
  • PHP Manual
  • streamWrapper
  • Vuelca la salida

streamWrapper::stream_flush

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_flush — Vuelca la salida

Descripción

public streamWrapper::stream_flush ( ) : bool

Este método es llamado en respuesta a fflush() y cuando el flujo está siendo cerrado mientras cualquier dato no volcado haya sido escrito en él antes.

Si se tiene información en la caché del flujo pero aún no se ha guardado en el almacenamiento subyacente, se debería hacer ahora.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Debería devolver true si la información en la caché se almacenó con éxito (o si no había información que almacenar), o false si la información podría no estar almacenada.

Notas

Nota:

Si no está implementado, se asume que el valor devuelto es false.

Ver también

  • fflush() - Vuelca la salida a un archivo


Bloqueo de archivos asesorado

  • « streamWrapper::stream_flush
  • streamWrapper::stream_metadata »
  • PHP Manual
  • streamWrapper
  • Bloqueo de archivos asesorado

streamWrapper::stream_lock

(PHP 5, PHP 7, PHP 8)

streamWrapper::stream_lock — Bloqueo de archivos asesorado

Descripción

public streamWrapper::stream_lock ( int $operation ) : bool

Este método es llamado en respuesta a flock(), cuando se utiliza file_put_contents() (cuando el parámetro flags contiene LOCK_EX), stream_set_blocking() y cuando se cierra el flujo (LOCK_UN).

Parámetros

operation

operation es una de las operaciones siguientes:

  • LOCK_SH para adquirir un bloqueo compartido (lectura).
  • LOCK_EX para adquirir un bloqueo exclusivo (escritura).
  • LOCK_UN para liberar un bloqueo (compartido o exclusivo).
  • LOCK_NB, utilice esta operación si no quiere que flock() bloquee mientras opera. (no soportado en Windows)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (es decir, no implementado).

Ver también

  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • flock() - Bloqueo de ficheros recomendado y portable


Cambiar las opciones del flujo

  • « streamWrapper::stream_lock
  • streamWrapper::stream_open »
  • PHP Manual
  • streamWrapper
  • Cambiar las opciones del flujo

streamWrapper::stream_metadata

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

streamWrapper::stream_metadata — Cambiar las opciones del flujo

Descripción

public streamWrapper::stream_metadata ( string $path , int $option , mixed $value ) : bool

Este método es llamado para establecer metadatos en el flujo. Se invoca cuando una de las siguientes funciones es llamada sobre un URL de flujo:

  • touch()
  • chmod()
  • chown()
  • chgrp()
Observe que algunas de estas operaciones pueden no estar disponibles en su sistema.

Nota: La función está disponible desde PHP 5.4.0.

Parámetros

path

La ruta del fichero o el URL a establecer los metadatos. Observe que en caso de ser un URL, debe ser un URL delimitado por ://. No se admiten otros formatos de URL.

option

Una de las siguientes opciones:

  • STREAM_META_TOUCH (El método fue llamado en respuesta a touch())
  • STREAM_META_OWNER_NAME (El método fue llamado en respuesta a chown() con parámetro de tipo string)
  • STREAM_META_OWNER (El método fue llamado en respuesta a chown())
  • STREAM_META_GROUP_NAME (El método fue llamado en respuesta a chgrp())
  • STREAM_META_GROUP (El método fue llamado en respuesta a chgrp())
  • STREAM_META_ACCESS (El método fue llamado en respuesta a chmod())

value

Si el parámetro option es

  • STREAM_META_TOUCH: Array que consiste en dos argumentos de la función touch().
  • STREAM_META_OWNER_NAME o STREAM_META_GROUP_NAME: El nombre del usuario/grupo propietario como string.
  • STREAM_META_OWNER o STREAM_META_GROUP: El valor del argumento del usuario/grupo propietario como integer.
  • STREAM_META_ACCESS: El argumento de la función chmod() como integer.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si option no se implementa, debería devolver false.

Ver también

  • touch() - Establece el momento de acceso y modificación de un archivo
  • chmod() - Cambia el modo de un fichero
  • chown() - Cambia el propietario del fichero
  • chgrp() - Cambia el grupo del archivo


Abre un archivo o una URL

  • « streamWrapper::stream_metadata
  • streamWrapper::stream_read »
  • PHP Manual
  • streamWrapper
  • Abre un archivo o una URL

streamWrapper::stream_open

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_open — Abre un archivo o una URL

Descripción

public streamWrapper::stream_open ( string $path , string $mode , int $options , string &$opened_path ) : bool

Este método es llamado inmediatemente después de que la envoltura sea inicializada (p.ej. usando fopen() y file_get_contents()).

Parámetros

path

Especifica la URL que fue pasada a la función original.

Nota:

La URL se puede desmontar con parse_url(). Observe que sólo las URL delimitadas por :// están soportadas. : y :/ aunque técnicamente son URL válidas, no lo están.

mode

El modo usado para abrir el archivo, como está detallado en fopen().

Nota:

Recuerde verificar si mode es válido para la ruta path solicitada.

options

Contiene banderas adicionales establecidas por la API de flujos. Puede contener uno o más de los siguientes valores usando OR entre ellos.

Bandera | Descripción
STREAM_USE_PATH | Si la ruta path es relativa, se busca el recurso usando include_path.
STREAM_REPORT_ERRORS | Si está establecida esta bandera, uno mismo es responsble de lanzar errores usando trigger_error() durante la apertura del flujo. Si esta bandera no está establecida, no se debería lanzar ningún error.

opened_path

Si la ruta path es abierta con éxito, y STREAM_USE_PATH está establecido en options, opened_path debería ser establecido a la ruta completa del archivo/recurso que fue abierto realmente.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • fopen() - Abre un fichero o un URL
  • parse_url() - Analiza un URL y devuelve sus componentes


Leer un flujo

  • « streamWrapper::stream_open
  • streamWrapper::stream_seek »
  • PHP Manual
  • streamWrapper
  • Leer un flujo

streamWrapper::stream_read

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_read — Leer un flujo

Descripción

public streamWrapper::stream_read ( int $count ) : string

Este método es llamado en respuesta a fread() y fgets().

Nota:

Recuerde actualizar la posición de lectura/escritura del flujo (por el número de bytes que fueron leídos con éxito).

Parámetros

count

Cuántos bytes de información desde la posición actual deberían ser devueltos.

Valores devueltos

Si hay menos bytes disponibles que en count devolver tantos como estén disponibles. Si no hay más información disponible, devolver false o una cadena vacía.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Nota:

Si el valor devuelto es mayor que count se emitirá un error de nivel E_WARNING y la información en exceso se perderá.

Notas

Nota:

streamWrapper::stream_eof() es llamado directamente después de llamar a streamWrapper::stream_read() para verificar si EOF ha sido alcanzado. Si no está implementado, se asume EOF.

Advertencia

Al leer un fichero entero (por ejemplo, con file_get_contents()), PHP llamará a streamWrapper::stream_read() seguido de streamWrapper::stream_eof() en un bucle, pero siempre y cuando streamWrapper::stream_read() devuelva un texto no vacío, el valor que devuelva streamWrapper::stream_eof() será ignorado.

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fgets() - Obtiene una línea desde el puntero a un fichero


Busca la ubicación específica en un flujo

  • « streamWrapper::stream_read
  • streamWrapper::stream_set_option »
  • PHP Manual
  • streamWrapper
  • Busca la ubicación específica en un flujo

streamWrapper::stream_seek

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_seek — Busca la ubicación específica en un flujo

Descripción

public streamWrapper::stream_seek ( int $offset , int $whence = SEEK_SET ) : bool

Este método es llamado en respuesta a fseek().

La posición de lectura/escritura del flujo debería ser actualizada según offset y whence.

Parámetros

offset

El flujo de desplazamiento a buscar.

whence

Valores posibles:

  • SEEK_SET - Establece la posición igual a offset bytes.
  • SEEK_CUR - Establece la posición de la ubicación actual más offset.
  • SEEK_END - Establece la posición al final del archivo más offset.

Valores devueltos

Devuelve true si la posición se ha actualizado, si no false.

Notas

Nota:

Si no está implementado, se asume que el valor devuelto es false

Nota:

Si se tuvo éxito,
streamWrapper::stream_tell() se llama directamente, después
de llamar a streamWrapper::stream_seek(). Si
streamWrapper::stream_tell() falla, el valor devuelto
a la función de llamada se establece en false

Nota:

No todas las operaciones de búsqueda de el flujo conllevan a la llamada de esta función. Los flujos de PHP tienen buffer para la lectura activado por defecto (véase también stream_set_read_buffer()) y la búsqueda se puede realizar con sólo mover el puntero del buffer.

Ver también

  • fseek() - Busca sobre un puntero a un fichero


Cambiar las opciones del flujo

  • « streamWrapper::stream_seek
  • streamWrapper::stream_stat »
  • PHP Manual
  • streamWrapper
  • Cambiar las opciones del flujo

streamWrapper::stream_set_option

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

streamWrapper::stream_set_option — Cambiar las opciones del flujo

Descripción

public streamWrapper::stream_set_option ( int $option , int $arg1 , int $arg2 ) : bool

Este método es llamado para establecer las opciones del flujo.

Parámetros

option

Una de las siguientes opciones:

  • STREAM_OPTION_BLOCKING (El método fue llamado en respuesta a stream_set_blocking())
  • STREAM_OPTION_READ_TIMEOUT (El método fue llamado en respuesta a stream_set_timeout())
  • STREAM_OPTION_WRITE_BUFFER (El método fue llamado en respuesta a stream_set_write_buffer())

arg1

Si option es

  • STREAM_OPTION_BLOCKING: modo de bloqueo solicitado (1 significa bloqueo, 0 sin bloqueo).
  • STREAM_OPTION_READ_TIMEOUT: tiempo de espera en segundos.
  • STREAM_OPTION_WRITE_BUFFER: modo del buffer (STREAM_BUFFER_NONE o STREAM_BUFFER_FULL).

arg2

Si option es

  • STREAM_OPTION_BLOCKING: Esta opción no está establecida.
  • STREAM_OPTION_READ_TIMEOUT: tiempo de espera en microsegundos.
  • STREAM_OPTION_WRITE_BUFFER: el tamaño del buffer solicitado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si option no está implementado, debería devolver false..

Ver también

  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • stream_set_write_buffer() - Establece el búfer para escritura de ficheros en el flujo dado


Recuperar información sobre un recurso de archivo

  • « streamWrapper::stream_set_option
  • streamWrapper::stream_tell »
  • PHP Manual
  • streamWrapper
  • Recuperar información sobre un recurso de archivo

streamWrapper::stream_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_stat — Recuperar información sobre un recurso de archivo

Descripción

public streamWrapper::stream_stat ( ) : array

Este método es llamado en respuesta a fstat().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Véase stat().

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Ver también

  • stat() - Da información acerca de un fichero
  • streamwrapper::url_stat() - Recuperar información sobre un archivo


Recuperar la posición actual de un flujo

  • « streamWrapper::stream_stat
  • streamWrapper::stream_truncate »
  • PHP Manual
  • streamWrapper
  • Recuperar la posición actual de un flujo

streamWrapper::stream_tell

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_tell — Recuperar la posición actual de un flujo

Descripción

public streamWrapper::stream_tell ( ) : int

Este método es llamado en respuesta a fseek() para determinar la posición actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Debería devolver la posición actual del flujo.

Ver también

  • ftell() - Devuelve la posición de lectura/escritura actual del puntero a un fichero


Truncar un flujo

  • « streamWrapper::stream_tell
  • streamWrapper::stream_write »
  • PHP Manual
  • streamWrapper
  • Truncar un flujo

streamWrapper::stream_truncate

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

streamWrapper::stream_truncate — Truncar un flujo

Descripción

public streamWrapper::stream_truncate ( int $new_size ) : bool

Responderá a la truncación, p.ej. a través de ftruncate().

Parámetros

new_size

El nuevo tamaño.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ftruncate() - Trunca un archivo a una longitud dada


Escribir en un flujo

  • « streamWrapper::stream_truncate
  • streamWrapper::unlink »
  • PHP Manual
  • streamWrapper
  • Escribir en un flujo

streamWrapper::stream_write

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_write — Escribir en un flujo

Descripción

public streamWrapper::stream_write ( string $data ) : int

Este método es llamado en respuesta a fwrite().

Nota:

Recuerde actualizar la posición actual del flujo por el número de bytes que fueron escritos con éxito.

Parámetros

data

Esta información debería ser almacenada en el flujo subyacente.

Nota:

Si no hay espacio suficiente en el flujo subyacente, guardar lo más posible.

Valores devueltos

Debería devolver el número de bytes que fueron almacenados con éxito, o 0 si no se puede almacenar nada.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Nota:

Si el valor devuelto es mayor que la longitud de data, se emitirá un E_WARNING y el valor devuelto será truncado a su longitud.

Ver también

  • fwrite() - Escritura de un archivo en modo binario seguro


Borrar un archivo

  • « streamWrapper::stream_write
  • streamWrapper::url_stat »
  • PHP Manual
  • streamWrapper
  • Borrar un archivo

streamWrapper::unlink

(PHP 5, PHP 7, PHP 8)

streamWrapper::unlink — Borrar un archivo

Descripción

public streamWrapper::unlink ( string $path ) : bool

Este método es llamado en respuesta a unlink().

Nota:

Para que el mensaje de error apropiado sea devuelto, este método no debería ser definido si la envoltura no soporta la eliminación de archivos.

Parámetros

path

LA URL del archivo que debería ser borrado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • unlink() - Borra un fichero
  • streamWrapper::rmdir() - Elimina un directorio


Recuperar información sobre un archivo

  • « streamWrapper::unlink
  • Funciones de Flujos »
  • PHP Manual
  • streamWrapper
  • Recuperar información sobre un archivo

streamWrapper::url_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::url_stat — Recuperar información sobre un archivo

Descripción

public streamWrapper::url_stat ( string $path , int $flags ) : array

Este método es llamado en respuesta a todas las funciones relacionadas con stat(), como:

  • copy()
  • fileperms()
  • fileinode()
  • filesize()
  • fileowner()
  • filegroup()
  • fileatime()
  • filemtime()
  • filectime()
  • filetype()
  • is_writable()
  • is_readable()
  • is_executable()
  • is_file()
  • is_dir()
  • is_link()
  • file_exists()
  • lstat()
  • stat()
  • SplFileInfo::getPerms()
  • SplFileInfo::getInode()
  • SplFileInfo::getSize()
  • SplFileInfo::getOwner()
  • SplFileInfo::getGroup()
  • SplFileInfo::getATime()
  • SplFileInfo::getMTime()
  • SplFileInfo::getCTime()
  • SplFileInfo::getType()
  • SplFileInfo::isWritable()
  • SplFileInfo::isReadable()
  • SplFileInfo::isExecutable()
  • SplFileInfo::isFile()
  • SplFileInfo::isDir()
  • SplFileInfo::isLink()
  • RecursiveDirectoryIterator::hasChildren()

Parámetros

path

La ruta del archivo o de la URL de donde obtener las estadísticas. Observe que en el caso que sea una URL, debe ser una URL delimitada con ://. No están soportadas formas de URL.

flags

Contiene banderas adicionales establecidas por la API de flujos. Puede contener uno o más de los siguientes valores usando OR entre ellos.

Bandera | Descripción
STREAM_URL_STAT_LINK | Para recursos con la capacidad de enlazar a otros recursos (como HTTP Location: forward, o un enlace simbólico de sistema de archivos). Esta bandera especifica que sólo debería ser devuelta la información acerca del enlace mismo, no del recurso apuntado por el enlace. Esta bandera está establecida en respuesta a las llamadas a lstat(), is_link(), o filetype().
STREAM_URL_STAT_QUIET | Si esta bandera está establecida, la envoltura no debería lanzar ningún error. Si esta bandera no está establecida, uno mismo es responsable de notificar errores usando la función trigger_error() durante la obtención de estadísticas de la ruta.

Valores devueltos

Debería devolver tantos elementos como tiene stat(). Valores desconocidos o no disponibles deberían ser establecidos a un valor razonable (normalmente 0).

Errores/Excepciones

Emite un E_WARNING si la llamada a este método falla (por ej., por no estar implementado).

Notas

Nota:

La propiedad streamWrapper::$context es actualizada si se pasa un contexto válido en la función invocante.

Ver también

  • stat() - Da información acerca de un fichero
  • streamwrapper::stream_stat() - Recuperar información sobre un recurso de archivo


Funciones de Flujos

Tabla de contenidos

  • stream_bucket_append — Añade un recipiente a una cadena de recipientes
  • stream_bucket_make_writeable — Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él
  • stream_bucket_new — Crear un nuevo recipiente para usarlo en el flujo actual
  • stream_bucket_prepend — Añade un recipiente al principio de una cadena de recipientes
  • stream_context_create — Crear un contexto de flujo
  • stream_context_get_default — Recuperar el contexto de flujo predeterminado
  • stream_context_get_options — Recuperar las opciones para un flujo/envoltura/contexto
  • stream_context_get_params — Recuperar los parámetros de un contexto
  • stream_context_set_default — Establecer el contexto de flujo predeterminado
  • stream_context_set_option — Establece una opción para un flujo/envoltura/contexto
  • stream_context_set_params — Establecer parámetros para un flujo/envoltura/contexto
  • stream_copy_to_stream — Copia información desde un flujo a otro
  • stream_filter_append — Enlaza un filtro a un flujo
  • stream_filter_prepend — Adjunta un filtro a un flujo
  • stream_filter_register — Registrar un filtro de flujo definido por el usuario
  • stream_filter_remove — Elimina un filtro de un flujo
  • stream_get_contents — Transfiere el resto de un flujo a una cadena
  • stream_get_filters — Recuperar la lista de los filtros registrados
  • stream_get_line — Obtiene una línea del recurso de flujo hasta un delimitador dado
  • stream_get_meta_data — Recuperar meta-información o de cabecera de punteros a flujos/archivo
  • stream_get_transports — Recuperar la lista de transportes de socket registrados
  • stream_get_wrappers — Recupera la lista de los flujos registrados
  • stream_is_local — Comprueba si un flujo es un flujo local
  • stream_isatty — Check if a stream is a TTY
  • stream_notification_callback — Una función de retrollamada para el parámetro de contexto de notificación
  • stream_register_wrapper — Alias de stream_wrapper_register
  • stream_resolve_include_path — Resuelve el nombre de archivo en la ruta incluida
  • stream_select — Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
  • stream_set_blocking — Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_chunk_size — Establecer el tamaño de trozo de flujo
  • stream_set_read_buffer — Establece el búfer de lectura de archivos en el flujo dado
  • stream_set_timeout — Establecer un perido de tiempo de espera en un flujo
  • stream_set_write_buffer — Establece el búfer para escritura de ficheros en el flujo dado
  • stream_socket_accept — Acepta una conexión sobre un socket creado por stream_socket_server
  • stream_socket_client — Abrir una conexión de socket de dominio de Internet o Unix
  • stream_socket_enable_crypto — Activa/desactiva la encriptación en un socket ya conectado
  • stream_socket_get_name — Recuperar el nombre de los sockets locales o remotos
  • stream_socket_pair — Crea un pareja de flujos de socket conectados e indistinguibles
  • stream_socket_recvfrom — Recibir información de un socket, conectado o no
  • stream_socket_sendto — Envía un mensaje a un socket, ya esté conectado o no
  • stream_socket_server — Crear un socket de servidor de dominio de Internet o de Unix
  • stream_socket_shutdown — Cerrar una conexión full-duplex
  • stream_supports_lock — Indica si el flujo soporta bloqueo
  • stream_wrapper_register — Registra una envoltura de URL implementada como una clase de PHP
  • stream_wrapper_restore — Restablece una envoltura incluida que se dejó de registrar previamente
  • stream_wrapper_unregister — Deja de registrar una envoltura de URL


Añade un recipiente a una cadena de recipientes

  • « Funciones de Flujos
  • stream_bucket_make_writeable »
  • PHP Manual
  • Funciones de Flujos
  • Añade un recipiente a una cadena de recipientes

stream_bucket_append

(PHP 5, PHP 7, PHP 8)

stream_bucket_append — Añade un recipiente a una cadena de recipientes

Descripción

stream_bucket_append ( resource $brigade , object $bucket ) : void
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él

  • « stream_bucket_append
  • stream_bucket_new »
  • PHP Manual
  • Funciones de Flujos
  • Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él

stream_bucket_make_writeable

(PHP 5, PHP 7, PHP 8)

stream_bucket_make_writeable — Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él

Descripción

stream_bucket_make_writeable ( resource $brigade ) : object
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Crear un nuevo recipiente para usarlo en el flujo actual

  • « stream_bucket_make_writeable
  • stream_bucket_prepend »
  • PHP Manual
  • Funciones de Flujos
  • Crear un nuevo recipiente para usarlo en el flujo actual

stream_bucket_new

(PHP 5, PHP 7, PHP 8)

stream_bucket_new — Crear un nuevo recipiente para usarlo en el flujo actual

Descripción

stream_bucket_new ( resource $stream , string $buffer ) : object
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Añade un recipiente al principio de una cadena de recipientes

  • « stream_bucket_new
  • stream_context_create »
  • PHP Manual
  • Funciones de Flujos
  • Añade un recipiente al principio de una cadena de recipientes

stream_bucket_prepend

(PHP 5, PHP 7, PHP 8)

stream_bucket_prepend — Añade un recipiente al principio de una cadena de recipientes

Descripción

stream_bucket_prepend ( resource $brigade , object $bucket ) : void

Se puede invocar a esta función para añadir un recipiente al principio de una cadena de recipientes. Normalmente se llama desde php_user_filter::filter().

Parámetros

brigade

brigade es un recurso que apunta a una bucjet brigade (cadena de recipientes) que contiene uno o más objetos bucket (recipiente).

bucket

Un objeto recipiente.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplos de stream_bucket_prepend()

<?php

class foo extends php_user_filter {
  protected $calls = 0;
  public function filter($in, $out, &$consumed, $closing) {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $consumed += $bucket->datalen;
      if ($this->calls++ == 2) {
        // Este recipiente aparecerá de nuevo antes que cualquier otro recipiente.
        stream_bucket_prepend($in, $bucket);
      }
    }
    return PSFS_FEED_ME;
  }
}
stream_filter_register('test', 'foo');
print  file_get_contents('php://filter/read=test/resource=foo');
?>


Crear un contexto de flujo

  • « stream_bucket_prepend
  • stream_context_get_default »
  • PHP Manual
  • Funciones de Flujos
  • Crear un contexto de flujo

stream_context_create

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_create — Crear un contexto de flujo

Descripción

stream_context_create ( array $options = ? , array $params = ? ) : resource

Crea y devuelve un contexto de flujo con cualquier opción proporcionada en options.

Parámetros

options

Debe ser un array asociativo de arrays asociativos con el formato $matriz['envoltura']['opción'] = $valor.

Por defecto es un array vacío.

params

Debe ser un array asociativo en el formato $matriz['parámetro'] = $valor. Consulte parámetros de contexto para un listado de los parámetros de flujo estándar.

Valores devueltos

Un resource de contexto de flujo.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el argumento opcional params.

Ejemplos

Ejemplo #1 Usar stream_context_create()

<?php
$opciones = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$contexto = stream_context_create($opciones);

/* Envía una petición http a www.example.com
   con las cabeceras adicionales mostradas arriba */
$fp = fopen('http://www.example.com', 'r', false, $contexto);
fpassthru($fp);
fclose($fp);
?>

Ver también

  • stream_context_set_option() - Establece una opción para un flujo/envoltura/contexto
  • Listado de las envolturas soportadas (Protocolos y Envolturas soportados)
  • Opciones de contexto (Opciones y parámetros de contexto)


Recuperar el contexto de flujo predeterminado

  • « stream_context_create
  • stream_context_get_options »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar el contexto de flujo predeterminado

stream_context_get_default

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_context_get_default — Recuperar el contexto de flujo predeterminado

Descripción

stream_context_get_default ( array $options = ? ) : resource

Devuelve el contexto de flujo predeterminado que es usado siempre que las operaciones con archivos (fopen(), file_get_contents(), etc...) son llamadas sin un parámetro de contexto. Las opciones para el contexto predeterminado pueden ser especificadas opcionalmente con esta función usando la misma sintaxis que en stream_context_create().

Parámetros

options
options debe ser una matriz asociativa de matrices asociativas con el formato $matriz['envoltura']['opción'] = $valor.

Nota:

A partir de PHP 5.3.0, la función stream_context_set_default() se puede usar para establecer el contexto predeterminado.

Valores devueltos

Un resource de contexto de flujo.

Ejemplos

Ejemplo #1 Usar stream_context_get_default()

<?php
$opc_pred = array(
  'http'=>array(
    'método'=>"GET",
    'cabecera'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$opc_alt = array(
  'http'=>array(
    'método'=>"POST",
    'cabecera'=>"Content-type: application/x-www-form-urlencoded\r\n" .
              "Content-length: " . strlen("baz=bomb"),
    'contenido'=>"baz=bomb"
  )
);

$predeterminado = stream_context_get_default($opc_pred);
$alternativo = stream_context_create($opc_alt);

/* Envía una petición GET normal al servidor proxy en 10.54.1.39
 * Para www.example.com usar opciones de contexto especificadas en $opc_pred
 */
readfile('http://www.example.com');

/* Envía una petición POST directamente a www.example.com
 * Usar opciones de contexto especificadas en $opc_alt
 */
readfile('http://www.example.com', false, $alternativo);

?>

Ver también

  • stream_context_create() - Crear un contexto de flujo
  • Listado de envolturas soportadas con opciones de contexto (Protocolos y Envolturas soportados).


Recuperar las opciones para un flujo/envoltura/contexto

  • « stream_context_get_default
  • stream_context_get_params »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar las opciones para un flujo/envoltura/contexto

stream_context_get_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_get_options — Recuperar las opciones para un flujo/envoltura/contexto

Descripción

stream_context_get_options ( resource $stream_or_context ) : array

Devuelve una matriz de opciones del el flujo o contexto especificados.

Parámetros

stream_or_context

El stream (flujo) o context (contexto) de donde se van a obtener las opciones

Valores devueltos

Devuelve una matriz asociativa con las opciones.

Ejemplos

Ejemplo #1 Ejemplo de stream_context_get_options()

<?php
$params = array("método" => "POST");

stream_context_set_default(array("http" => $params));

var_dump(stream_context_get_options(stream_context_get_default()));

?>

El resultado del ejemplo sería algo similar a:

array(1) {
  ["http"]=>
  array(1) {
    ["método"]=>
    string(4) "POST"
  }
}


Recuperar los parámetros de un contexto

  • « stream_context_get_options
  • stream_context_set_default »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar los parámetros de un contexto

stream_context_get_params

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_context_get_params — Recuperar los parámetros de un contexto

Descripción

stream_context_get_params ( resource $stream_or_context ) : array

Recupera la información de los parámetros y de las opciones de un flujo o contexto.

Parámetros

stream_or_context

Un resource de flujo o un resource de contexto

Valores devueltos

Devuelve una matriz asociativa que contiene todas las opciones y parámetros del contexto.

Ejemplos

Ejemplo #1 Ejemplo de stream_context_get_params()

Ejemplo de uso básico

<?php
$ctx = stream_context_create();
$params = array("notification" => "stream_notification_callback");
stream_context_set_params($ctx, $params);

var_dump(stream_context_get_params($ctx));
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["notification"]=>
  string(28) "stream_notification_callback"
  ["options"]=>
  array(0) {
  }
}

Ver también

  • stream_context_set_option() - Establece una opción para un flujo/envoltura/contexto
  • stream_context_get_params()
  • stream_context_set_params() - Establecer parámetros para un flujo/envoltura/contexto


Establecer el contexto de flujo predeterminado

  • « stream_context_get_params
  • stream_context_set_option »
  • PHP Manual
  • Funciones de Flujos
  • Establecer el contexto de flujo predeterminado

stream_context_set_default

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_context_set_default — Establecer el contexto de flujo predeterminado

Descripción

stream_context_set_default ( array $options ) : resource

Establece el contexto de flujo predeterminado que será usado siempre que la operaciones de archivos (fopen(), file_get_contents(), etc...) sean llamadas sin un parámetro de contexto. Usa la misma sintaxis que stream_context_create().

Parámetros

options

Las opciones a establecer para el contexto predeterminado.

Nota:

options debe ser una matriz asociativa de matrices asociativas con el formato $matriz['envoltura']['opción'] = $valor.

Valores devueltos

Devuelve el contexto de flujo predeterminado.

Ejemplos

Ejemplo #1 Ejemplo de stream_context_set_default()

<?php
$opcs_pred = array(
  'http'=>array(
    'método'=>"GET",
    'cabecera'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$predeterminado = stream_context_set_default($opcs_pred);

/* Envía una petición GET normal al servidor proxy en 10.54.1.39
 * Para www.example.com usar opciones de contexto especificadas en $opcs_pred
 */
readfile('http://www.example.com');
?>

Ver también

  • stream_context_create() - Crear un contexto de flujo
  • stream_context_get_default() - Recuperar el contexto de flujo predeterminado
  • Listado de las envolturas soportadas con opciones de contexto (Protocolos y Envolturas soportados).


Establece una opción para un flujo/envoltura/contexto

  • « stream_context_set_default
  • stream_context_set_params »
  • PHP Manual
  • Funciones de Flujos
  • Establece una opción para un flujo/envoltura/contexto

stream_context_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_set_option — Establece una opción para un flujo/envoltura/contexto

Descripción

stream_context_set_option ( resource $stream_or_context , string $wrapper , string $option , mixed $value ) : bool
stream_context_set_option ( resource $stream_or_context , array $options ) : bool

Esteblece una opción en el contexto especificado. value es establecio a option para wrapper

Parámetros

stream_or_context

El recurso de flujo o de contexto al que se le va a aplicar las opciones.

options

Las opciones a establecer al contexto predeterminado.

Nota:

options debe ser una matriz asociativa de matrices asociativas con el formato $matriz['envoltura']['opción'] = $valor.

Consulte opciones y parámetros de contexto para una lista de opciones de flujos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establecer parámetros para un flujo/envoltura/contexto

  • « stream_context_set_option
  • stream_copy_to_stream »
  • PHP Manual
  • Funciones de Flujos
  • Establecer parámetros para un flujo/envoltura/contexto

stream_context_set_params

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_set_params — Establecer parámetros para un flujo/envoltura/contexto

Descripción

stream_context_set_params ( resource $stream_or_context , array $params ) : bool

Establece parámetros en el contexto especificado.

Parámetros

stream_or_context

El flujo o el contexto para aplicar los parámetros.

params

Un array de parámetros para configurar.

Nota:

params debería ser un array asociativo con la estructura: $parámetros['nombre_parametro'] = "valor_parametro";.

Parámetros soportados

Parámetros | Propósito
notification | Nombre de la función de llamada de retorno definida por el usuario a ser llamada siempre que un flujo provoque una notificación. Sólo se soporta para los stream wrappers http:// y ftp://.
options | Array de opciones como en opciones y parámetros de contexto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • stream_notification_callback() - Una función de retrollamada para el parámetro de contexto de notificación


Copia información desde un flujo a otro

  • « stream_context_set_params
  • stream_filter_append »
  • PHP Manual
  • Funciones de Flujos
  • Copia información desde un flujo a otro

stream_copy_to_stream

(PHP 5, PHP 7, PHP 8)

stream_copy_to_stream — Copia información desde un flujo a otro

Descripción

stream_copy_to_stream ( resource $source , resource $dest , int $maxlength = -1 , int $offset = 0 ) : int

Hace una copia de hasta maxlength bytes de información desde la posición actual (o desde la posición de offset, si se especifica) desde source a dest. Si no se especifica maxlength, todo el contenido restante de source será copiado.

Parámetros

source

El flujo de origen

dest

El flujo de destino

maxlength

Máximos bytes a copiar

offset

El índice donde comenzar a copiar información

Valores devueltos

Devuelve el número total de bytes copiados, o false en caso de error.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro offset

Ejemplos

Ejemplo #1 Un ejemplo de stream_copy_to_stream()

<?php
$origen   = fopen('http://www.example.com', 'r');
$destino1 = fopen('primer1k.txt', 'w');
$destino2 = fopen('resto.txt', 'w');

echo stream_copy_to_stream($origen, $destino1, 1024) . " bytes copiados a primer1k.txt\n";
echo stream_copy_to_stream($origen, $destino2) . " bytes copiados a resto.txt\n";

?>

Ver también

  • copy() - Copia un fichero


Enlaza un filtro a un flujo

  • « stream_copy_to_stream
  • stream_filter_prepend »
  • PHP Manual
  • Funciones de Flujos
  • Enlaza un filtro a un flujo

stream_filter_append

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_filter_append — Enlaza un filtro a un flujo

Descripción

stream_filter_append ( resource $stream , string $filtername , int $read_write = ? , mixed $params = ? ) : resource

Añade un nombre de filtro dado por filtername a la lista de filtros adjuntos a stream.

Parámetros

stream

El flujo objetivo.

filtername

El nombre del filtro.

read_write

Por omisión, stream_filter_append() enlazará el filtro a la cadena de filtros de lectura si el archivo fue abierto para lectura (esto es, Modo de Archivo: r, y/o +). El filtro también será enlazado a la cadena de filtros de escritura si el archivo fue abierto para escritura (esto es, Modo de Archivo: w, a, y/o +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, y/o STREAM_FILTER_ALL también se pueden pasar al parámetro read_write para sobrescribir este comportamiento.

params

Este filtro será añadido con los parámetros params especificados al final de la lista y por lo tanto será llamado el último durante las operaciones de flujo. Para añadir un filtro al principio de la lista use stream_filter_prepend().

Valores devueltos

Devuelve un recurso en caso de éxito o false en caso de fallo. El recurso se puede emplear para referirse a esta instnacia del filtro durante una llamada a stream_filter_remove().

Se devuelve false si stream no es un recurso o si filtername no se puede localizar.

Historial de cambios

Versión | Descripción
5.1.0 | Antes de PHP 5.1.0, esta función devolvía true si se tuvo éxito o false en caso de error.

Ejemplos

Ejemplo #1 Controlar dónde son aplicados los filtros

<?php
/* Abrir un archivo de prueba para lectura y escritura */
$fp = fopen('prueba.txt', 'w+');

/* Aplicar el filtro ROT13 filter a la
 * cadena de filtros de escritura, pero no a la
 * cadena de filtros de lectura */
stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);

/* Escribir una cadena sencilla al archivo
 * será ROT13 transformado a la
 * salida */
fwrite($fp, "Esto es una prueba\n");

/* Retroceder al principio del archivo */
rewind($fp);

/* Leer el contenido del archivo desde atrás.
 * Si el filtro ha sido aplicado a la
 * cadena de filtros de lectura veríamos
 * el texto con el filtro ROT13 deshecho a su estado original */
fpassthru($fp);

fclose($fp);

/* Salida esperada
   ---------------

Rfgb rf han cehron

 */
?>

Notas

Nota: Cuando se usan filtros personalizos (de usuario)
stream_filter_register() debe llamarse primero para registrar el filtro de usuario deseado en filtername.

Nota: La información del flujo se lee desde recursos (locales y remotos) en trozos, con cualquier información sin consumir guardada en bufferes internos. Cuando un nuevo filtro se añade a un flujo, la información en los bufferes internos se procesa a través del nuevo filtro en ese momento. Esto difiere del comportamiento de stream_filter_prepend().

Nota: Cuando un filtro se añade para lectura y escritura, se crean dos instancias del filtro. stream_filter_append() se debe llamar dos veces con STREAM_FILTER_READ y STREAM_FILTER_WRITE para obtener ambos recursos del filtro.

Ver también

  • stream_filter_register() - Registrar un filtro de flujo definido por el usuario
  • stream_filter_prepend() - Adjunta un filtro a un flujo
  • stream_get_filters() - Recuperar la lista de los filtros registrados


Adjunta un filtro a un flujo

  • « stream_filter_append
  • stream_filter_register »
  • PHP Manual
  • Funciones de Flujos
  • Adjunta un filtro a un flujo

stream_filter_prepend

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_filter_prepend — Adjunta un filtro a un flujo

Descripción

stream_filter_prepend ( resource $stream , string $filtername , int $read_write = ? , mixed $params = ? ) : resource

Añade un nombre de filtro dado por filtername a la lista de filtros adjuntos a stream.

Parámetros

stream

El flujo objetivo.

filtername

El nombre del filtro.

read_write

Por omisión, stream_filter_prepend() adjuntará el filtro a la cadena de filtros de lectura si el fichero fue abierto para lectura (esto es, Modo de Fichero: r, y/o +). El filtro también será adjuntado a la cadena de filtros de escritura si el fichero fue abierto para escritura (esto es, Modo de Fichero: w, a, y/o +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, y/o STREAM_FILTER_ALL también se pueden pasar al parámetro read_write para sobrescribir este comportamiento. Véase stream_filter_append() para un ejemplo de cómo usar este parámetro.

params

Este filtro será añadido con los parámetros params especificados al inicio de la lista y, por lo tanto, será llamado el primero durante las operaciones de flujo. Para añadir un filtro al final de la lista, use stream_filter_append().

Valores devueltos

Devuelve un recurso en caso de éxito o false en caso de fallo. El recurso se puede emplear para referirse a esta instnacia del filtro durante una llamada a stream_filter_remove().

Se devuelve false si stream no es un recurso o si filtername no se puede localizar.

Historial de cambios

Versión | Descripción
5.1.0 | Antes de PHP 5.1.0, esta función devolvía true en caso de éxito o false en caso de error.

Notas

Nota: Cuando se usan filtros personalizos (de usuario)
stream_filter_register() debe llamarse primero para registrar el filtro de usuario deseado en filtername.

Nota: La información del flujo se lee desde recursos (locales y remotos) en trozos, con cualquier información sin consumir guardada en búferes internos. Cuando un nuevo filtro se añade a un flujo, la información en los búferes internos, la cuál ha sido ya procesada por otros filtros, no será procesada por el nuevo filtro en ese momento. Esto difiere del comportamiento de stream_filter_append().

Nota: Cuando un filtro se añade para lectura y escritura, se crean dos instancias del filtro. stream_filter_prepend() se debe llamar dos veces con STREAM_FILTER_READ y STREAM_FILTER_WRITE para obtener ambos recursos del filtro.

Ver también

  • stream_filter_register() - Registrar un filtro de flujo definido por el usuario
  • stream_filter_append() - Enlaza un filtro a un flujo


Registrar un filtro de flujo definido por el usuario

  • « stream_filter_prepend
  • stream_filter_remove »
  • PHP Manual
  • Funciones de Flujos
  • Registrar un filtro de flujo definido por el usuario

stream_filter_register

(PHP 5, PHP 7, PHP 8)

stream_filter_register — Registrar un filtro de flujo definido por el usuario

Descripción

stream_filter_register ( string $filtername , string $classname ) : bool

stream_filter_register() permite implementar un filtro propio sobre cualquier flujo registrado usado con las demás funciones de sistema de archivos (como fopen(), fread() etc.).

Parámetros

filtername

El nombre del filtro que va a ser registrado.

classname

Para implementar un filtro se necesita definir una clase como una extensión de php_user_filter con un número de funciones miembro. Cuando se lleva a cabo operaciones de lectura/escritura en el flujo al cuál el filtro está enlazado, PHP pasará la información a través de este filtro (y cualquier otro filtro enlazado a ese flujo) por lo que la información puede ser modificada como se desee. Se deben implementar los métodos exactamente como se describe en php_user_filter - hacerlo de otro modo conducirá a un comportamiento indefinido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

stream_filter_register() devolverá false si filtername ya está definido.

Ejemplos

Ejemplo #1 Filtro para poner en mayúsculas caracteres en el flujo foo-bar.txt

El ejemplo de abajo implementa un filtro llamado strtoupper en el flujo foo-bar.txt que pondrá en mayúsculas todos los caracteres de letras escritos en/leídos desde este flujo.

<?php

/* Definir nuestra clase de filtro */
class strtoupper_filter extends php_user_filter {
  function filter($entrada, $salida, &$consumido, $cerrar)
  {
    while ($recipiente = stream_bucket_make_writeable($entrada)) {
      $recipiente->data = strtoupper($recipiente->data);
      $consumido += $recipiente->datalen;
      stream_bucket_append($salida, $recipiente);
    }
    return PSFS_PASS_ON;
  }
}

/* Registrar nuestro filtro con PHP */
stream_filter_register("strtoupper", "strtoupper_filter")
    or die("Fallo al registrar el filtro");

$fp = fopen("foo-bar.txt", "w");

/* Enlazar el filtro al flujo recién abierto */
stream_filter_append($fp, "strtoupper");

fwrite($fp, "Fila1\n");
fwrite($fp, "Palabra - 2\n");
fwrite($fp, "Tan Sencillo Como 123\n");

fclose($fp);

/* Leer el contenido desde atrás
 */
readfile("foo-bar.txt");

?>

El resultado del ejemplo sería:

FILA1
PALABRA - 2
TAN SENCILLO COMO 123

Ejemplo #2 Registrar una clase de filtro genérica para comparar múltiples nombres de filtro.

<?php

/* Definir nuestra clase de filtro */
class string_filter extends php_user_filter {
  var $modo;

  function filter($entrada, $salida, &$consumido, $cerrar)
  {
    while ($recipiente = stream_bucket_make_writeable($entrada)) {
      if ($this->mode == 1) {
        $recipiente->data = strtoupper($recipiente->data);
      } elseif ($this->mode == 0) {
        $recipiente->data = strtolower($recipiente->data);
      }

      $consumido += $recipiente->datalen;
      stream_bucket_append($salida, $recipiente);
    }
    return PSFS_PASS_ON;
  }

  function onCreate()
  {
    if ($this->filtername == 'str.toupper') {
      $this->mode = 1;
    } elseif ($this->filtername == 'str.tolower') {
      $this->mode = 0;
    } else {
      /* Se preguntó por otro filtro str.*,
         informar del fallo, por lo que PHP seguirá mirando */
      return false;
    }

    return true;
  }
}

/* Registrar nuestro filtro con PHP */
stream_filter_register("str.*", "string_filter")
    or die("Fallo al registrar el filtro");

$fp = fopen("foo-bar.txt", "w");

/* Enlazar el filtro al flujo recién abierto
   Alternativamente podríamos enlazar a str.tolower aquí */
stream_filter_append($fp, "str.toupper");

fwrite($fp, "Fila1\n");
fwrite($fp, "Palabra - 2\n");
fwrite($fp, "Tan Sencillo Como 123\n");

fclose($fp);

/* Leer el contenido desde atrás
 */
readfile("foo-bar.txt");

?>

El resultado del ejemplo sería:

FILA1
PALABRA - 2
TAN SENCILLO COMO 123

Ver también

  • stream_wrapper_register() - Registra una envoltura de URL implementada como una clase de PHP
  • stream_filter_append() - Enlaza un filtro a un flujo
  • stream_filter_prepend() - Adjunta un filtro a un flujo


Elimina un filtro de un flujo

  • « stream_filter_register
  • stream_get_contents »
  • PHP Manual
  • Funciones de Flujos
  • Elimina un filtro de un flujo

stream_filter_remove

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_filter_remove — Elimina un filtro de un flujo

Descripción

stream_filter_remove ( resource $stream_filter ) : bool

Elimina un filtro de flujo previamente añadido al flujo con stream_filter_prepend() o stream_filter_append(). Cualquier información restante en el buffer interno del filtro será volcada al siguiente filtro antes de eliminarla.

Parámetros

stream_filter

El filtro de flujo a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Refiltrar dináminamente un flujo

<?php
/* Abrir un archivo de prueba para lectura y escritura */
$fp = fopen("prueba.txt", "rw");

$filtro_rot13 = stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);
fwrite($fp, "Esto es ");
stream_filter_remove($filtro_rot13);
fwrite($fp, "una prueba\n");

rewind($fp);
fpassthru($fp);
fclose($fp);

?>

El resultado del ejemplo sería:

Rfgb rf una prueba

Ver también

  • stream_filter_register() - Registrar un filtro de flujo definido por el usuario
  • stream_filter_append() - Enlaza un filtro a un flujo
  • stream_filter_prepend() - Adjunta un filtro a un flujo


Transfiere el resto de un flujo a una cadena

  • « stream_filter_remove
  • stream_get_filters »
  • PHP Manual
  • Funciones de Flujos
  • Transfiere el resto de un flujo a una cadena

stream_get_contents

(PHP 5, PHP 7, PHP 8)

stream_get_contents — Transfiere el resto de un flujo a una cadena

Descripción

stream_get_contents ( resource $handle , int $maxlength = -1 , int $offset = -1 ) : string

Idéntica a file_get_contents(), excepto que stream_get_contents() opera sobre un recurso de flujo ya abierto y devuelve el resto del contenido en una cadena, hasta maxlength bytes y comenzando por el offset especificado.

Parámetros

handle (resource)

Un recurso de flujo (p.ej. devuelto desde fopen())

maxlength (integer)

El máximo de bytes a leer. Por defecto es -1 (lee todo el buffer restante).

offset (integer)

Busca el índice especificado antes de leer. Si este número es negativo, no se hará ninguna búsqueda y la lectura comenzará desde la posición actual.

Valores devueltos

Devuelve una cadena o false en caso de error.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro offset.

Ejemplos

Ejemplo #1 Ejemplo de stream_get_contents()

<?php

if ($stream = fopen('http://www.example.com', 'r')) {
    // imprimir toda la página empezando por el índice 10
    echo stream_get_contents($stream, -1, 10);

    fclose($stream);
}

if ($stream = fopen('http://www.example.net', 'r')) {
    // imprimir los 5 primeros bytes
    echo stream_get_contents($stream, 5);

    fclose($stream);
}

?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fread() - Lectura de un fichero en modo binario seguro
  • fpassthru() - Escribe toda la información restante de un puntero a un archivo


Recuperar la lista de los filtros registrados

  • « stream_get_contents
  • stream_get_line »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar la lista de los filtros registrados

stream_get_filters

(PHP 5, PHP 7, PHP 8)

stream_get_filters — Recuperar la lista de los filtros registrados

Descripción

stream_get_filters ( ) : array

Recupera la lista de los filtros registrados en el sistema en ejecución.

Valores devueltos

Devuelve una matriz indexada que contiene el nombre de todos los filtros de flujo disponibles.

Ejemplos

Ejemplo #1 Usar stream_get_filters()

<?php
$streamlist = stream_get_filters();
print_r($streamlist);
?>

El resultado del ejemplo sería algo similar a:

Array (
  [0] => string.rot13
  [1] => string.toupper
  [2] => string.tolower
  [3] => string.base64
  [4] => string.quoted-printable
)

Ver también

  • stream_filter_register() - Registrar un filtro de flujo definido por el usuario
  • stream_get_wrappers() - Recupera la lista de los flujos registrados


Obtiene una línea del recurso de flujo hasta un delimitador dado

  • « stream_get_filters
  • stream_get_meta_data »
  • PHP Manual
  • Funciones de Flujos
  • Obtiene una línea del recurso de flujo hasta un delimitador dado

stream_get_line

(PHP 5, PHP 7, PHP 8)

stream_get_line — Obtiene una línea del recurso de flujo hasta un delimitador dado

Descripción

stream_get_line ( resource $handle , int $length , string $ending = ? ) : string

Obtiene una linea desde el gestor dado.

La lectura finaliza cuando hayan sido leídos length bytes, cuando se encuentre la cadena especificada por ending (la cuál no está incluida en el valor devuelto), o sobre EOF (lo que suceda primero).

Esta función es casi indéntica a fgets() excepto que permite delimitadores de fin de línea distintos a los habituales \n, \r, y \r\n, y no devuelve el delimitador mismo.

Parámetros

handle

Un gestor de archivo válido.

length

El número de bytes a leer desde el gestor.

ending

Un delimitador de cadena opcional.

Valores devueltos

Devuelve una cadena de hasta length bytes leídos desde el archivo apuntado por handle.

Si ocurre un error, devuelve false.

Ver también

  • fread() - Lectura de un fichero en modo binario seguro
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetc() - Obtiene un carácter de un puntero a un archivo


Recuperar meta-información o de cabecera de punteros a flujos/archivo

  • « stream_get_line
  • stream_get_transports »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar meta-información o de cabecera de punteros a flujos/archivo

stream_get_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_get_meta_data — Recuperar meta-información o de cabecera de punteros a flujos/archivo

Descripción

stream_get_meta_data ( resource $stream ) : array

Devuelve información sobre un stream (flujo) existente.

Parámetros

stream

El flujo puede ser cualquier flujo creado por fopen(), fsockopen() y pfsockopen().

Valores devueltos

La matriz resultante contiene los siguientes elementos:

  • timed_out (bool) - true si el flujo agota el tiempo mientras espera información en la última llamada a fread() o fgets().

  • blocked (bool) - true si el flujo está en el modo de bloqueo IO. Véase stream_set_blocking().

  • eof (bool) - true si el flujo ha alcanzado la marca eof (end-of-file, final de archivo). Observe que para flujos de socket este miembro puede ser true incluso cuando unread_bytes no es cero. Para determinar si hay más información para leer, use feof() en vez de leer este elemento.

  • unread_bytes (int) - el número de bytes contenidos actualmente en el propio buffer interno de PHP.

    Nota: No se debería usar este valor en un script.

  • stream_type (string) - una etiqueta que describe la implementación subyacente del flujo.

  • wrapper_type (string) - una etiqueta que describe la implementación de la envoltura de protocolo que traslapa al flujo. Véase Protocolos y Envolturas soportados para más información acerca de envolturas.

  • wrapper_data (mixed) - la información específica de la envoltura vinculada a este flujo. Véase Protocolos y Envolturas soportados para más información acerca de envolturas y su infomración de envoltura.

  • mode (string) - el tipo de acceso requerido para este flujo (véase la Tabla 1 de la referencia de fopen())

  • seekable (bool) - si el flujo acutal puede ser buscado.

  • uri (string) - la URI/nombre de archivo asociado con este flujo.

Ejemplos

Ejemplo #1 Ejemplo de stream_get_meta_data()

<?php
$url = 'http://www.example.com/';

if (!$fp = fopen($url, 'r')) {
    trigger_error("Incapaz de abrir la URL ($url)", E_USER_ERROR);
}

$meta = stream_get_meta_data($fp);

print_r($meta);

fclose($fp);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [wrapper_data] => Array
        (
            [0] => HTTP/1.1 200 OK
            [1] => Server: Apache/2.2.3 (Red Hat)
            [2] => Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT
            [3] => ETag: "b300b4-1b6-4059a80bfd280"
            [4] => Accept-Ranges: bytes
            [5] => Content-Type: text/html; CHARSET=Windows-1252
            [6] => Set-Cookie: FOO=BAR; expires=Fri, 21-Dec-2012 12:00:00 GMT; path=/; domain=.example.com
            [6] => Connection: close
            [7] => Date: Fri, 16 Oct 2009 12:00:00 GMT
            [8] => Age: 1164
            [9] => Content-Length: 438
        )

    [wrapper_type] => http
    [stream_type] => tcp_socket/ssl
    [mode] => r
    [unread_bytes] => 438
    [seekable] =>
    [uri] => http://www.example.com/
    [timed_out] =>
    [blocked] => 1
    [eof] =>
)

Notas

Nota:

Esta función NO funciona en sockets creados por la extensión Socket.

Ver también

  • get_headers() - Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP
  • $http_response_header


Recuperar la lista de transportes de socket registrados

  • « stream_get_meta_data
  • stream_get_wrappers »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar la lista de transportes de socket registrados

stream_get_transports

(PHP 5, PHP 7, PHP 8)

stream_get_transports — Recuperar la lista de transportes de socket registrados

Descripción

stream_get_transports ( ) : array

Devuelve una matriz indexada que contiene el nombre de todos los transportes de socket disponibles en el sistema en ejecución.

Valores devueltos

Devuelve una matriz indexada de nombres de transportes de socket.

Ejemplos

Ejemplo #1 Usar stream_get_transports()

<?php
$xportlist = stream_get_transports();
print_r($xportlist);
?>

El resultado del ejemplo sería algo similar a:

Array (
  [0] => tcp
  [1] => udp
  [2] => unix
  [3] => udg
)

Ver también

  • stream_get_filters() - Recuperar la lista de los filtros registrados
  • stream_get_wrappers() - Recupera la lista de los flujos registrados


Recupera la lista de los flujos registrados

  • « stream_get_transports
  • stream_is_local »
  • PHP Manual
  • Funciones de Flujos
  • Recupera la lista de los flujos registrados

stream_get_wrappers

(PHP 5, PHP 7, PHP 8)

stream_get_wrappers — Recupera la lista de los flujos registrados

Descripción

stream_get_wrappers ( ) : array

Recupera la lista de los flujos registrados disponibles en el sistema en ejecución.

Valores devueltos

Devuelve una matriz indexada que contiene el nombre de todas las envolturas de flujo disponibles en el sistema en ejecución.

Ejemplos

Ejemplo #1 Ejemplo de stream_get_wrappers()

<?php
print_r(stream_get_wrappers());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => php
    [1] => file
    [2] => http
    [3] => ftp
    [4] => compress.bzip2
    [5] => compress.zlib
)

Ejemplo #2 Comprobar la existencia de una envoltura de flujo

<?php
// comprobar la existencia de la envoltura de flujo bzip2
if (in_array('compress.bzip2', stream_get_wrappers())) {
    echo 'compress.bzip2:// soporte habilitado.';
} else {
    echo 'compress.bzip2:// soporte no habilitado.';
}
?>

Ver también

  • stream_wrapper_register() - Registra una envoltura de URL implementada como una clase de PHP


Comprueba si un flujo es un flujo local

  • « stream_get_wrappers
  • stream_isatty »
  • PHP Manual
  • Funciones de Flujos
  • Comprueba si un flujo es un flujo local

stream_is_local

(PHP 5 >= 5.2.4, PHP 7, PHP 8)

stream_is_local — Comprueba si un flujo es un flujo local

Descripción

stream_is_local ( mixed $stream_or_url ) : bool

Comprueba si un flujo, o una URL, es o no local.

Parámetros

stream_or_url

El resource de flujo o URL a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de stream_is_local()

Ejemplo de uso básico.

<?php
var_dump(stream_is_local("http://example.com"));
var_dump(stream_is_local("/etc"));
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Check if a stream is a TTY

  • « stream_is_local
  • stream_notification_callback »
  • PHP Manual
  • Funciones de Flujos
  • Check if a stream is a TTY

stream_isatty

(PHP 7 >= 7.2.0, PHP 8)

stream_isatty — Check if a stream is a TTY

Descripción

stream_isatty ( resource $stream ) : bool

Determines if stream stream refers to a valid terminal type device. This is a more portable version of posix_isatty(), since it works on Windows systems too.

Parámetros

stream

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 stream_isatty() example

This command can be used to determine if a standard output / standard error stream is redirected to a file.

php -r "var_export(stream_isatty(STDERR));"

El resultado del ejemplo sería algo similar a:

true
php -r "var_export(stream_isatty(STDERR));" 2>output.txt

El resultado del ejemplo sería algo similar a:

false


Una función de retrollamada para el parámetro de contexto de notificación

  • « stream_isatty
  • stream_register_wrapper »
  • PHP Manual
  • Funciones de Flujos
  • Una función de retrollamada para el parámetro de contexto de notificación

stream_notification_callback

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

stream_notification_callback — Una función de retrollamada para el parámetro de contexto de notificación

Descripción

stream_notification_callback ( int $notification_code , int $severity , string $message , int $message_code , int $bytes_transferred , int $bytes_max ) : void

Una función de tipo callable, usada por el parámetro de contexto de notificación, llamado durante un evento.

Nota:

Esta no es una función real, sólo un prototipo de cómo la función debería ser.

Parámetros

notification_code

Una de las constantes de notificación STREAM_NOTIFY_*.

severity

Una de las constantes de notificación STREAM_NOTIFY_SEVERITY_*.

message

Pasado si un mensaje descriptivo está disponible para el evento.

message_code

Pasado si un código de mensaje descriptivo está disponible para el evento.

Esto significa que el valor depende de la envoltura específica en uso.

bytes_transferred

Si se puede aplicar, el parámetro bytes_transferred será rellenado.

bytes_max

Si se puede aplicar, el parámetro bytes_max será rellenado.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de stream_notification_callback()

<?php
function stream_notification_callback($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max) {

    switch($notification_code) {
        case STREAM_NOTIFY_RESOLVE:
        case STREAM_NOTIFY_AUTH_REQUIRED:
        case STREAM_NOTIFY_COMPLETED:
        case STREAM_NOTIFY_FAILURE:
        case STREAM_NOTIFY_AUTH_RESULT:
            var_dump($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max);
            /* Ignore */
            break;

        case STREAM_NOTIFY_REDIRECTED:
            echo "Redireccionando a: ", $message;
            break;

        case STREAM_NOTIFY_CONNECT:
            echo "Conectado...";
            break;

        case STREAM_NOTIFY_FILE_SIZE_IS:
            echo "Obtenido el tamaño de archivo: ", $bytes_max;
            break;

        case STREAM_NOTIFY_MIME_TYPE_IS:
            echo "Encontrado el tipo mime: ", $message;
            break;

        case STREAM_NOTIFY_PROGRESS:
            echo "Hecho algún progreso, descargado ", $bytes_transferred, " hasta el momento";
            break;
    }
    echo "\n";
}

$ctx = stream_context_create();
stream_context_set_params($ctx, array("notification" => "stream_notification_callback"));

file_get_contents("http://php.net/contact", false, $ctx);
?>

El resultado del ejemplo sería algo similar a:

Conectado...
Encontrado el tipo mime: text/html; CHARSET=Windows-1252
Redireccionando a: http://no.php.net/contact
Conectado...
Obtenido el tamaño de archivo: 0
Found the mime-type: text/html; CHARSET=Windows-1252
Redireccionando a: http://no.php.net/contact.php
Conectado...
Obtenido el tamaño de archivo: 4589
Encontrado el tipo mime: text/html;CHARSET=Windows-1252
Hecho algún progreso, descargado 0 hasta el momento
Hecho algún progreso, descargado 0 hasta el momento
Hecho algún progreso, descargado 0 hasta el momento
Hecho algún progreso, descargado 1440 hasta el momento
Hecho algún progreso, descargado 2880 hasta el momento
Hecho algún progreso, descargado 4320 hasta el momento
Hecho algún progreso, descargado 5760 hasta el momento
Hecho algún progreso, descargado 6381 hasta el momento
Hecho algún progreso, descargado 7002 hasta el momento

Ejemplo #2 Barra de progreso sencilla para la descarga por parte del cliente por línea de comandos

<?php
function usage($argv) {
    echo "Uso:\n";
    printf("\tphp %s <http://example.com/file> <localfile>\n", $argv[0]);
    exit(1);
}

function stream_notification_callback($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max) {
    static $filesize = null;

    switch($notification_code) {
    case STREAM_NOTIFY_RESOLVE:
    case STREAM_NOTIFY_AUTH_REQUIRED:
    case STREAM_NOTIFY_COMPLETED:
    case STREAM_NOTIFY_FAILURE:
    case STREAM_NOTIFY_AUTH_RESULT:
        /* Ignore */
        break;

    case STREAM_NOTIFY_REDIRECTED:
        echo "Redireccionando a: ", $message, "\n";
        break;

    case STREAM_NOTIFY_CONNECT:
        echo "Conectado...\n";
        break;

    case STREAM_NOTIFY_FILE_SIZE_IS:
        $filesize = $bytes_max;
        echo "Tamaño de archivo: ", $filesize, "\n";
        break;

    case STREAM_NOTIFY_MIME_TYPE_IS:
        echo "Tipo mime: ", $message, "\n";
        break;

    case STREAM_NOTIFY_PROGRESS:
        if ($bytes_transferred > 0) {
            if (!isset($filesize)) {
                printf("\rTamaño de archivo desconocido.. %2d kb hecho..", $bytes_transferred/1024);
            } else {
                $length = (int)(($bytes_transferred/$filesize)*100);
                printf("\r[%-100s] %d%% (%2d/%2d kb)", str_repeat("=", $length). ">", $length, ($bytes_transferred/1024), $filesize/1024);
            }
        }
        break;
    }
}

isset($argv[1], $argv[2]) or usage($argv);

$ctx = stream_context_create();
stream_context_set_params($ctx, array("notification" => "stream_notification_callback"));

$fp = fopen($argv[1], "r", false, $ctx);
if (is_resource($fp) && file_put_contents($argv[2], $fp)) {
    echo "\nÂ¡Hecho!\n";
    exit(0);
}

$err = error_get_last();
echo "\nErrrrrorr..\n", $err["message"], "\n";
exit(1);
?>

Ejecutar el ejemplo anterior con: php -n fetch.php http://no2.php.net/get/php-5-LATEST.tar.bz2/from/this/mirror php-latest.tar.bz2 imprimirá algo similar a:

Conectado...
Tipo mime: text/html; CHARSET=Windows-1252
Redireccionando a: http://no2.php.net/distributions/php-5.2.5.tar.bz2
Conectado...
Tamaño de archivo: 7773024
Tipo mime: application/octet-stream
[========================================>                                                           ] 40% (3076/7590 kb)

Ver también

  • Contexto parámetros


Alias de stream_wrapper_register

  • « stream_notification_callback
  • stream_resolve_include_path »
  • PHP Manual
  • Funciones de Flujos
  • Alias de stream_wrapper_register

stream_register_wrapper

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_register_wrapper — Alias de stream_wrapper_register()

Descripción

Esta función es un alias de: stream_wrapper_register().


Resuelve el nombre de archivo en la ruta incluida

  • « stream_register_wrapper
  • stream_select »
  • PHP Manual
  • Funciones de Flujos
  • Resuelve el nombre de archivo en la ruta incluida

stream_resolve_include_path

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

stream_resolve_include_path — Resuelve el nombre de archivo en la ruta incluida

Descripción

stream_resolve_include_path ( string $filename ) : string

Resuelve filename en la ruta incluida según las mismas reglas que en fopen()/include.

Parámetros

filename

El nombre de fichero a resolver.

Valores devueltos

Devuelve un string que contiene el nombre de fichero absoluto resuelto, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de stream_resolve_include_path()

Ejemplo de uso básico.

<?php
var_dump(stream_resolve_include_path("prueba.php"));
?>

El resultado del ejemplo sería algo similar a:

string(22) "/var/www/html/prueba.php"


Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec

  • « stream_resolve_include_path
  • stream_set_blocking »
  • PHP Manual
  • Funciones de Flujos
  • Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec

stream_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_select — Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec

Descripción

stream_select ( array &$read , array &$write , array &$except , int $tv_sec , int $tv_usec = 0 ) : int

La función stream_select() acepta matrices de flujos y espera a que cambien su estado. Su operación es equivalente a la de la función socket_select() excepto que actúa sobre flujos.

Parámetros

read

Los flujos listados en la matriz read serán observados para comprobar si los caracteres están disponibles para la lectura (de manera más precisa, para ver si una lectura no bloqueará - en particular, un recurso de flujo está también listo en el final de archivo, en cuyo caso una llamada a fread() devolverá una cadena de longitud cero).

write

Los flujos listados en la matriz write serán observados para comprobar si una escritura no bloqueará.

except

Los flujos listados en la matriz except serán observados para una llegada de información excepcional de alta prioridad ("fuera de banda").

Nota:

Cuando stream_select() devuelve, las matrices read, write y except se modifican para indicar qué recursos de flujo cambiaron de estado actualmente.

No se necesita pasar cada matriz a stream_select(). Se pueden omitir y usar una matriz vacía o null en su lugar. No se olvide también de que estas matrices son pasadas por referencia y serán modificadas después de que stream_select() devuelva.
tv_sec

Los parámetros tv_sec y tv_usec forman juntos el parámetro timeout, tv_sec especifica el número de segundos mientras que tv_usec especifica el número de microsegundos. El timeout (tiemop de espera) es un límite superior de la cantidad de tiempo que stream_select() esperará antes de devolver. Si tv_sec y tv_usec están establecidos a 0, stream_select() no esperará información - en su lugar devolverá inmediantamente, indicando el estado acutal de los flujos.

Si tv_sec es null stream_select() puede bloquear indefinidamente, devolviendo sólo cuando ocurra un evento de los flujos observados (o si una señal interrumpe la llamada al sistema).

Advertencia

Usar un valor de tiempo de espera de 0 permite emitir instantáneamente el estado de los flujos, sin embargo, NO es una buena idea usar un valor de tiempo de espera de 0 en un bucle ya que causará que el script consuma demasiado tiempo de la CPU.

Es mucho mejor especificar un valor de tiempo de espera de unos pocos segundos, aunque si se necesita comprobar y ejecutar actualmente otro código, usar un valor de tiempo de espera de al menos 200000 microsegundos ayudará a reducir el uso de la CPU del script.

Recuerde que el valor del tiempo de espera es el tiempo máximo que transcurrirá; stream_select() devolverá tan pronto como los flujos requeridos estén listos para su uso.

tv_usec

Véase la descripción de tv_sec.

Valores devueltos

Si se tuvo éxito stream_select() devolverá el número de recursos de flujo contenidos en las matrices modificadas, lo cual puede ser cero si el tiempo de espera expira antes de que no ocurra nada interesante. Si se produjo un error devolverá false y se lanzará una advertendia (esto puede suceder si la llamada al sistema es interrumpida por una señal entrante).

Ejemplos

Ejemplo #1 Ejemplo de stream_select()

Este ejemplo hace una comprobación para ver si ha llegado información para leer sobre $stream1 o $stream2. Ya que el tiempo de espera es 0 devolverá inmediatamente:

<?php
/* Prepararse para leer una matriz */
$read   = array($stream1, $stream2);
$write  = NULL;
$except = NULL;
if (false === ($num_changed_streams = stream_select($read, $write, $except, 0))) {
    /* Manejo de errores */
} elseif ($num_changed_streams > 0) {
    /* Sucedió algo interesante en al menos uno de los flujos */
}
?>

Notas

Nota:

Debido a las limitaciones en el actual Zend Engine no es posible pasar un modificador constante como null directamente como un parámetro a una función que espera que este parámetro sea pasado por referencia. En su lugar use una variable temporal o una expresión con el miembro más a la izquierda como una variable temporal:

<?php
$e = NULL;
stream_select($r, $w, $e, 0);
?>

Nota:

Asegúrese de usar el operador === cuando se compruebe un error. Ya que stream_select() puede devolver 0, la comparación con == sería evaluada como true:

<?php
$e = NULL;
if (false === stream_select($r, $w, $e, 0)) {
    echo "Falló stream_select()\n";
}
?>

Nota:

Si se lee/escribe en un flujo devuelto en las matrices sea consciente de que éstas no leen/escriben necesariamente la cantidad total de información que se solicitó. Inluso sólo pueden ser capaces de leer/escribir un sólo byte.

Nota:

Algunos flujos (como zlib) no pueden ser seleccionados por esta función.

Nota:

Compatibilidad con Windows: stream_select() usado sobre una tubería devuelta desde proc_open() puede causar pérdida de información bajo Windows 98.

El uso de stream_select() sobre descriptores de archivos devueltos por proc_open() fallará y devolverá false bajo Windows.

Ver también

  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo


Establecer el modo bloqueo/no-bloqueo en un flujo

  • « stream_select
  • stream_set_chunk_size »
  • PHP Manual
  • Funciones de Flujos
  • Establecer el modo bloqueo/no-bloqueo en un flujo

stream_set_blocking

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_blocking — Establecer el modo bloqueo/no-bloqueo en un flujo

Descripción

stream_set_blocking ( resource $stream , bool $mode ) : bool

Establece el modo de bloqueo o no-bloqueo en un stream.

Esta función funciona con cualquier flujo que soporte el modo de no bloqueo (actualmente, archivos normales y flujos de socket).

Parámetros

stream

El flujo.

mode

Si mode es false, el flujo dado será cambiado al modo de no-bloqueo, y si es true, será cambiado al modo de bloqueo. Esto afecta a las llamadas a, por ejemplo, fgets() y fread() que leen desde un flujo. En el modo de no-bloquo una llamada a fgets() devolverá siempre inmediatamente mientras que en el modo de bloqueo esperará a que la información esté disponible en el flujo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Esta función se llamaba anteriormente set_socket_blocking() y después socket_set_blocking() pero este uso está obsoleto.

Ver también

  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec


Establecer el tamaño de trozo de flujo

  • « stream_set_blocking
  • stream_set_read_buffer »
  • PHP Manual
  • Funciones de Flujos
  • Establecer el tamaño de trozo de flujo

stream_set_chunk_size

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

stream_set_chunk_size — Establecer el tamaño de trozo de flujo

Descripción

stream_set_chunk_size ( resource $fp , int $chunk_size ) : int

Estblece el tamaño de trozo de flujo.

Parámetros

fp

El flujo objetivo.

chunk_size

El nuevo tamaño de trozo deseado.

Valores devueltos

Devuelve el tamaño de trozo anterior en caso de éxito.

Devolverá false si chunk_size es menor que 1 o mayor que PHP_INT_MAX.

Errores/Excepciones

Emitirá un error de nivel E_WARNING si chunk_size es menor que 1 o mayor que PHP_INT_MAX.


Establece el búfer de lectura de archivos en el flujo dado

  • « stream_set_chunk_size
  • stream_set_timeout »
  • PHP Manual
  • Funciones de Flujos
  • Establece el búfer de lectura de archivos en el flujo dado

stream_set_read_buffer

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

stream_set_read_buffer — Establece el búfer de lectura de archivos en el flujo dado

Descripción

stream_set_read_buffer ( resource $stream , int $buffer ) : int

Establece el búfer de lectura. Es equivalente a stream_set_write_buffer(), excepto que es para operaciones de escritura-

Parámetros

stream

El puntero al archivo.

buffer

El número de bytes del buffer. Si buffer es 0 las operaciones de lectura no son volcadas al buffer. Esto asegura que todas las lecturas hechas con fread() son completadas antes de que a otros procesos se les permita leer en ese flujo de entrada.

Valores devueltos

Devuelve 0 en caso de éxito, u otro valor si la petición no se pudo satisfacer.

Ver también

  • stream_set_write_buffer() - Establece el búfer para escritura de ficheros en el flujo dado


Establecer un perido de tiempo de espera en un flujo

  • « stream_set_read_buffer
  • stream_set_write_buffer »
  • PHP Manual
  • Funciones de Flujos
  • Establecer un perido de tiempo de espera en un flujo

stream_set_timeout

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_timeout — Establecer un perido de tiempo de espera en un flujo

Descripción

stream_set_timeout ( resource $stream , int $seconds , int $microseconds = 0 ) : bool

Establece el valor del tiempo de espera en stream, expresado como la suma de seconds y microseconds.

Cuando el flujo agota el tiempo de espera, la clave 'timed_out' de la matriz devuelta por stream_get_meta_data() se establece a true, aunque no se genere un error/advertencia.

Parámetros

stream

El flujo objetivo.

seconds

La parte de segundos del tiempo de espera a establecer.

microseconds

La parte de microsegundos del tiempo de espera a establecer.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
4.3.0 | A partira de PHP 4.3, esta función pude (potencialmente) trabajar con cualquier tipo de flujos. En PHP 4.3, los sockets basados en flujos son aún el único tipo soportado en el núcleo de PHP, aunque los flujos de otras extensiones pueden soportar esta función.

Ejemplos

Ejemplo #1 Ejemplo de stream_set_timeout()

<?php
$fp = fsockopen("www.example.com", 80);
if (!$fp) {
    echo "No se puede abrir\n";
} else {

    fwrite($fp, "GET / HTTP/1.0\r\n\r\n");
    stream_set_timeout($fp, 2);
    $res = fread($fp, 2000);

    $info = stream_get_meta_data($fp);
    fclose($fp);

    if ($info['timed_out']) {
        echo '¡La conexión agotó el tiempo de espera!';
    } else {
        echo $res;
    }

}
?>

Notas

Nota:

Esta función no funciona con operaciones avanzadas como stream_socket_recvfrom(), use stream_select() con el parámetro tiempo de espera (timeout) en su lugar.

Esta función se llamaba anteriormente set_socket_timeout() y después socket_set_timeout() pero este uso está obsoleto.

Ver también

  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix
  • fopen() - Abre un fichero o un URL


Establece el búfer para escritura de ficheros en el flujo dado

  • « stream_set_timeout
  • stream_socket_accept »
  • PHP Manual
  • Funciones de Flujos
  • Establece el búfer para escritura de ficheros en el flujo dado

stream_set_write_buffer

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_write_buffer — Establece el búfer para escritura de ficheros en el flujo dado

Descripción

stream_set_write_buffer ( resource $stream , int $buffer ) : int

Establece el buffer para escribir operaciones en el stream dado a buffer bytes.

La salida usando fwrite() normalmente tiene un buffer de 8K. Esto significa que si hay dos procesos esperando a escribir en el mismo flujo de salida (un fichero), cada uno se pausa después de 8K de información para permitir que el otro escriba.

Parámetros

stream

El puntero a un fichero.

buffer

El número de bytes del buffer. Si buffer es 0 las operaciones de escritura no usarán buffer. Esto asegura que todas las escrituras con fwrite() se completen antes de que a otros procesos se les permita escribir en ese flujo de salida.

Valores devueltos

Devuelve 0 en caso de éxito, u otro valor si la petición no se pudo satisfacer.

Ejemplos

Ejemplo #1 Ejemplo de stream_set_write_buffer()

El siguiente ejemplo muestra cómo usar stream_set_write_buffer()para crear un flujo sin buffer.

<?php
$fp = fopen($file, "w");
if ($fp) {
  if (stream_set_write_buffer($fp, 0) !== 0) {
      // cambiar el almacenamiento en bufer fallido
  }
  fwrite($fp, $output);
  fclose($fp);
}
?>

Ver también

  • fopen() - Abre un fichero o un URL
  • fwrite() - Escritura de un archivo en modo binario seguro


Acepta una conexión sobre un socket creado por stream_socket_server

  • « stream_set_write_buffer
  • stream_socket_client »
  • PHP Manual
  • Funciones de Flujos
  • Acepta una conexión sobre un socket creado por stream_socket_server

stream_socket_accept

(PHP 5, PHP 7, PHP 8)

stream_socket_accept — Acepta una conexión sobre un socket creado por stream_socket_server()

Descripción

stream_socket_accept ( resource $server_socket , float $timeout = ini_get("default_socket_timeout") , string &$peername = ? ) : resource

Acepta una conexión sobre un socket creado previamente por stream_socket_server().

Parámetros

server_socket

El socket del servidor desde donde aceptar una conexión.

timeout

Sobreescribe el tiemo de espera aceptado por defecto del socket. Esto debería darse en segundos.

peername

Se establecerá al nombre (dirección) del cliente que se conectó, si está incluido y disponible desde el transporte seleccionado.

Nota:

También se puede determinar después usando stream_socket_get_name().

Valores devueltos

Devuelve un flujo a la conexión del socket aceptado o false en caso de error.

Notas

Advertencia

Esta función no debería usarse con sockets de servidor UDP. En su lugar, use stream_socket_recvfrom() y stream_socket_sendto().

Ver también

  • stream_socket_server() - Crear un socket de servidor de dominio de Internet o de Unix
  • stream_socket_get_name() - Recuperar el nombre de los sockets locales o remotos
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fwrite() - Escritura de un archivo en modo binario seguro
  • fclose() - Cierra un puntero a un archivo abierto
  • feof() - Comprueba si el puntero a un archivo está al final del archivo
  • Funciones de cURL


Abrir una conexión de socket de dominio de Internet o Unix

  • « stream_socket_accept
  • stream_socket_enable_crypto »
  • PHP Manual
  • Funciones de Flujos
  • Abrir una conexión de socket de dominio de Internet o Unix

stream_socket_client

(PHP 5, PHP 7, PHP 8)

stream_socket_client — Abrir una conexión de socket de dominio de Internet o Unix

Descripción

stream_socket_client ( string $remote_socket , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") , int $flags = STREAM_CLIENT_CONNECT , resource $context = ? ) : resource

Inicia una conexión de flujo o datagrama al destino especificado por remote_socket. El tipo de socket creado se determina por el transporte especificado usando el formato de URL estándar: transporte://objetivo. Para sockets de Dominio de Internet (AF_INET) como TCP y UDP, la porción del objetivo del parámetro remote_socket debería consistir en un nombre de host o dirección IP seguida de dos puntos y un número de puerto. Para sockets de dominio de Unix, la porción de target apuntará al archivo de socket del sistema de archivos.

Nota:

El flujo será abierto por defecto en modo de bloqueo. Se puede cambiar al modo de no bloqueo usando stream_set_blocking().

Parámetros

remote_socket

Dirección del socket al que se va a conectar.

errno

Será establecido al número de error a nivel de sistema si la conexión falla.

errstr

Será establecido al mensaje de error a nivel de sistema si la conexión falla.

timeout

Número de segundos hasta que la llamda al sistema de connect() debería esperar.

Nota: Este parámetro sólo se aplica cuando no se hace un intento de conexión asíncrona.

Nota:

Para establecer un tiempo de espera para lectura/escritura de información sobre el socket, use la función stream_set_timeout(), ya que timeout sólo se aplica mientras se hace una conexión al socket.

flags

Campo de máscara de bits que puede ser establecido a cualquier combinación de banderas de conexión. Actualmente la selección de banderas de conexión está limitada a STREAM_CLIENT_CONNECT (por defecto), STREAM_CLIENT_ASYNC_CONNECT y STREAM_CLIENT_PERSISTENT.

context

Un recurso de contexto válido creado con stream_context_create().

Valores devueltos

Si se tuvo éxito, un recurso de flujo es devuelto, el cuál se puede
usar junto con las demás funciones de archivo (tales como
fgets(), fgetss(),
fwrite(), fclose(), y
feof()), false si falló.

Errores/Excepciones

Si falló, los argumentos errno y errstr serán rellenados con el error a nivel de sistema actual que ocurrió en la llamda a nivel de sistema de connect(). Si el valor devuelto en errno es 0 y la función devolvió false, es una indicación de que el error ocurrió antes de la llamada a connect(). Esto es lo más probable debido a un problema de inicialización del socket. Observe que los argumentos errno y errstr siempre serán pasados por referencia.

Ejemplos

Ejemplo #1 Ejemplo de stream_socket_client()

<?php
$fp = stream_socket_client("tcp://www.example.com:80", $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\nAccept: */*\r\n\r\n");
    while (!feof($fp)) {
        echo fgets($fp, 1024);
    }
    fclose($fp);
}
?>

Ejemplo #2 Usar una conexión UDP

Recuperar el día y la hora desde el servicio "daytime" de UDP (puerto 13) en localhost.

<?php
$fp = stream_socket_client("udp://127.0.0.1:13", $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Notas

Advertencia

Los sockects UDP a veces parecerán estar abiertos sin un error, incluso si el host remoto es inalcanzable. El error sólo aparecerá cuando se lea o escriba información desde/en el socket. La razón de esto es que UDP es un protocolo no orientado a conexión, lo que significa que el sistema operativo no intenta establecer un enlace para el socket hasta que se necesite enviar o recibir informaicón.

Nota: Cuando se especifique una dirección numérica IPv6 (por ej., fe80::1), la IP debe ser encerrada entre corchetes — por ejemplo, tcp://[fe80::1]:80.

Nota:

Dependiendo del entorno, pueden no estar disponibles el dominio Unix o el tiempo de espera opcional de la conexión. Una lista de transportes disponibles se puede recuperar unsando stream_get_transports(). Véase Lista de Transportes de Sockets Soportados para una lista de transportes incluidos.

Ver también

  • stream_socket_server() - Crear un socket de servidor de dominio de Internet o de Unix
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • stream_select() - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fwrite() - Escritura de un archivo en modo binario seguro
  • fclose() - Cierra un puntero a un archivo abierto
  • feof() - Comprueba si el puntero a un archivo está al final del archivo
  • Funciones de cURL


Activa/desactiva la encriptación en un socket ya conectado

  • « stream_socket_client
  • stream_socket_get_name »
  • PHP Manual
  • Funciones de Flujos
  • Activa/desactiva la encriptación en un socket ya conectado

stream_socket_enable_crypto

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_socket_enable_crypto — Activa/desactiva la encriptación en un socket ya conectado

Descripción

stream_socket_enable_crypto ( resource $stream , bool $enable , int $crypto_type = ? , resource $session_stream = ? ) : mixed

Habilita o deshabilita la encriptación en un flujo.

Una vez que la configuración de encriptación está habilitada, la criptografía se puede activar o desactivar pasando true o false al parámetro enable.

Parámetros

stream

El recurso de flujo.

enable

Activa/descativa la criptografía en el flujo.

crypto_type

Configura la encriptación en el flujo. Los métodos válidos son

  • STREAM_CRYPTO_METHOD_SSLv2_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv3_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv23_CLIENT
  • STREAM_CRYPTO_METHOD_TLS_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv2_SERVER
  • STREAM_CRYPTO_METHOD_SSLv3_SERVER
  • STREAM_CRYPTO_METHOD_SSLv23_SERVER
  • STREAM_CRYPTO_METHOD_TLS_SERVER

Si se omite, se utilizará en su lugar la opción de contexto crypto_type sobre el contexto SSL del flujo.

session_stream

Establece el flujo con los ajustes de session_stream.

Valores devueltos

Devuelve true si se tuvo éxito, false si la negociación falló o 0 si no hay suficiente información y se debería intertar otra vez (sólo para sockets no bloqueados).

Historial de cambios

Versión | Descripción
5.6.0 | crypto_type ahora es opcional.

Ejemplos

Ejemplo #1 Ejemplo de stream_socket_enable_crypto()

<?php
$fp = stream_socket_client("tcp://myproto.example.com:31337", $errno, $errstr, 30);
if (!$fp) {
    die("Incapaz de conectar a: $errstr ($errno)");
}

/* Activar la encriptación para la fase de identificación */
stream_socket_enable_crypto($fp, true, STREAM_CRYPTO_METHOD_SSLv23_CLIENT);
fwrite($fp, "USER god\r\n");
fwrite($fp, "PASS secret\r\n");

/* Desactivar la encriptación para el resto */
stream_socket_enable_crypto($fp, false);

while ($motd = fgets($fp)) {
    echo $motd;
}

fclose($fp);
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Funciones de OpenSSL
    •

  • Lista de Transportes de Sockets Soportados
    •


Recuperar el nombre de los sockets locales o remotos

  • « stream_socket_enable_crypto
  • stream_socket_pair »
  • PHP Manual
  • Funciones de Flujos
  • Recuperar el nombre de los sockets locales o remotos

stream_socket_get_name

(PHP 5, PHP 7, PHP 8)

stream_socket_get_name — Recuperar el nombre de los sockets locales o remotos

Descripción

stream_socket_get_name ( resource $handle , bool $want_peer ) : string

Devuelve el nombre local o remoto de una conexión de socket dada.

Parámetros

handle

El socket del que se va a obtener el nombre.

want_peer

Si se establece a true se devolverá el nombre del socket remoto, si se establece a false se devolverá el nombre del socket local.

Valores devueltos

El nombre del socket.

Ver también

  • stream_socket_accept() - Acepta una conexión sobre un socket creado por stream_socket_server


Crea un pareja de flujos de socket conectados e indistinguibles

  • « stream_socket_get_name
  • stream_socket_recvfrom »
  • PHP Manual
  • Funciones de Flujos
  • Crea un pareja de flujos de socket conectados e indistinguibles

stream_socket_pair

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_socket_pair — Crea un pareja de flujos de socket conectados e indistinguibles

Descripción

stream_socket_pair ( int $domain , int $type , int $protocol ) : array

stream_socket_pair() crea un pareja de flujos de socket conectados e indistinguibles. Esta fnción se usa normalmente en IPC (Inter-Process Communication, Comunicación entre Procesos).

Parámetros

domain

La familia de protocolos que se va a usar: STREAM_PF_INET, STREAM_PF_INET6 o STREAM_PF_UNIX

type

El tipo de comunicación que se va a usar: STREAM_SOCK_DGRAM, STREAM_SOCK_RAW, STREAM_SOCK_RDM, STREAM_SOCK_SEQPACKET o STREAM_SOCK_STREAM

protocol

El protocolo que se va a usar: STREAM_IPPROTO_ICMP, STREAM_IPPROTO_IP, STREAM_IPPROTO_RAW, STREAM_IPPROTO_TCP o STREAM_IPPROTO_UDP

Nota: Por favor, consulte la lista de constantes de Flujos para más detalles de cada constante.

Valores devueltos

Devuelve un array con los dos recursos de socket si se tuvo éxito, o false si falló.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Ejemplos

Ejemplo #1 Un ejemplo de stream_socket_pair()

Este ejemplo muestra el uso básico de stream_socket_pair() en Comunciación entre Proceses (IPC).

<?php

$sockets = stream_socket_pair(STREAM_PF_UNIX, STREAM_SOCK_STREAM, STREAM_IPPROTO_IP);
$pid     = pcntl_fork();

if ($pid == -1) {
     die('no se pudo bifurcar');

} else if ($pid) {
     /* padre */
    fclose($sockets[0]);

    fwrite($sockets[1], "PID hijo: $pid\n");
    echo fgets($sockets[1]);

    fclose($sockets[1]);

} else {
    /* hijo */
    fclose($sockets[1]);

    fwrite($sockets[0], "mensaje desde el hijo\n");
    echo fgets($sockets[0]);

    fclose($sockets[0]);
}

?>

El resultado del ejemplo sería algo similar a:

PID hijo: 1378
mensaje desde el hijo


Recibir información de un socket, conectado o no

  • « stream_socket_pair
  • stream_socket_sendto »
  • PHP Manual
  • Funciones de Flujos
  • Recibir información de un socket, conectado o no

stream_socket_recvfrom

(PHP 5, PHP 7, PHP 8)

stream_socket_recvfrom — Recibir información de un socket, conectado o no

Descripción

stream_socket_recvfrom ( resource $socket , int $length , int $flags = 0 , string &$address = ? ) : string

stream_socket_recvfrom() acepta información desde un socket remoto hasta length bytes.

Parámetros

socket

El socket remoto.

length

El número de bytes a recibir desde el socket.

flags

El valor de flags puede ser una combinación de los siguientes valores:

Valores posibles para flags
STREAM_OOB | Procesar información OOB (out-of-band, fuera de banda).
STREAM_PEEK | Recuperar información del socket, pero sin consumir el buffer. Las llamadas subsiguientes a fread() o stream_socket_recvfrom() verán la misma información.

address

Si se proporciona address, será rellenado con la dirección de socket remoto.

Valores devueltos

Devuelve la información leída, como cadena

Ejemplos

Ejemplo #1 Ejemplo de stream_socket_recvfrom()

<?php
/* Abrir un socket de servidor al puerto 1234 en localhost */
$server = stream_socket_server('tcp://127.0.0.1:1234');

/* Aceptar una conexión */
$socket = stream_socket_accept($server);

/* Tomar un paquete (1500 es un tamaño de MTU típico) de información OOB */
echo "Recibido Fuera de Banda: '" . stream_socket_recvfrom($socket, 1500, STREAM_OOB) . "'\n";

/* Echar un vistazo a la información en banda normal, pero sin comsumirla. */
echo "Información: '" . stream_socket_recvfrom($socket, 1500, STREAM_PEEK) . "'\n";

/* Obtener el mismo paquete exactamente otra vez, pero eliminándolo del buffer esta vez. */
echo "Información: '" . stream_socket_recvfrom($socket, 1500) . "'\n";

/* Cerrarlo */
fclose($socket);
fclose($server);
?>

Notas

Nota:

Si un mensaje recibido es mayor que el parámetro length, los bytes en exceso se pueden desechar dependiendo del tipo de socket desde el que se recbió el mensaje (como UDP).

Nota:

Las llamadas a stream_socket_recvfrom() sobre flujos basados en sockets, después de las llamadas a funciones de flujos basados en buffer (como fread() o stream_get_line()), leen información directamente desde el socket y evitan el buffer del flujo.

Ver también

  • stream_socket_sendto() - Envía un mensaje a un socket, ya esté conectado o no
  • stream_socket_client() - Abrir una conexión de socket de dominio de Internet o Unix
  • stream_socket_server() - Crear un socket de servidor de dominio de Internet o de Unix


Envía un mensaje a un socket, ya esté conectado o no

  • « stream_socket_recvfrom
  • stream_socket_server »
  • PHP Manual
  • Funciones de Flujos
  • Envía un mensaje a un socket, ya esté conectado o no

stream_socket_sendto

(PHP 5, PHP 7, PHP 8)

stream_socket_sendto — Envía un mensaje a un socket, ya esté conectado o no

Descripción

stream_socket_sendto ( resource $socket , string $data , int $flags = 0 , string $address = ? ) : int

Envía la infomración data especificada a través del socket.

Parámetros

socket

El socket al que se le va a enviar data.

data

La información que va a ser enviada.

flags

El valor de flags puede ser una combinación de los siguientes valores:

Valores posibles para flags
STREAM_OOB Procesar información OOB (out-of-band, fuera de banda).

address

La dirección especificada cuando el flujo de socket fue creado, será usada a menos que se especifique una dirección alternativa en address.

Si se especifica, debe estar en formato decimal con puntos (o [ipv6]).

Valores devueltos

Devuelve un código de resultado, como un entero.

Ejemplos

Ejemplo #1 Ejemplo de stream_socket_sendto()

<?php
/* Abrir un socket al puerto 1234 en localhost */
$socket = stream_socket_client('tcp://127.0.0.1:1234');

/* Enviar información ordinaria mediante canales oridinarios. */
fwrite($socket, "Transmisión de información normal.");

/* Enviar más información fuera de banda. */
stream_socket_sendto($socket, "Información Fuera de Banda.", STREAM_OOB);

/* Cerrarlo */
fclose($socket);
?>

Ver también

  • stream_socket_recvfrom() - Recibir información de un socket, conectado o no
  • stream_socket_client() - Abrir una conexión de socket de dominio de Internet o Unix
  • stream_socket_server() - Crear un socket de servidor de dominio de Internet o de Unix


Crear un socket de servidor de dominio de Internet o de Unix

  • « stream_socket_sendto
  • stream_socket_shutdown »
  • PHP Manual
  • Funciones de Flujos
  • Crear un socket de servidor de dominio de Internet o de Unix

stream_socket_server

(PHP 5, PHP 7, PHP 8)

stream_socket_server — Crear un socket de servidor de dominio de Internet o de Unix

Descripción

stream_socket_server ( string $local_socket , int &$errno = ? , string &$errstr = ? , int $flags = STREAM_SERVER_BIND | STREAM_SERVER_LISTEN , resource $context = ? ) : resource

Crea un socket de flujo o de datagrama en local_socket.

Esta función sólo crea un socket, para empezar a aceptar conexiones use stream_socket_accept().

Parámetros

local_socket

El tipo de socket creado se determina por el transporte especificado usando el formato de URL estándar: transporte://objetivo.

Para sockets de Dominio de Internet (AF_INET) como TCP y UDP, la porción del objetivo del parámetro remote_socket debería consistir en un nombre de host o dirección IP seguida de dos puntos y un número de puerto. Para sockets de dominio de Unix, la porción del objetivo apuntará al archivo de socket del sistema de archivos.

Dependiendo del entorno, los sockets de dominio Unix pueden no estar disponibles. Una lista de transportes disponibles se puede recuperar unsado stream_get_transports(). Véase Lista de Transportes de Sockets Soportados para una lista de transportes incluidos.

errno

Si los argumentos opcionales errno y errstr están presentes, serán establecidos para indicar el error a nivel de sistema ocurrido en las llamadas a nivel de sistema de socket(), bind(), y listen(). Si el valor devuelto en errno es 0 y la función devuelve false, es una indicación de que el error ocurrió antes de la llamada a bind(). Esto es lo más probable debido a un problema de inicialización del socket. Observe que los argumentos errno y errstr siempre serán pasados por referencia.

errstr

Véase la descripción de errno.

flags

Campo de máscara de bits que puede ser establecido a cualquier combinación de banderas de conexión.

Nota:

Para sockets UDP, se debe usar STREAM_SERVER_BIND como parámetro flags.

context

Valores devueltos

Devuelve un flujo creado, o false si se produjo un error.

Ejemplos

Ejemplo #1 Usar sockets de servidor de TCP

<?php
$socket = stream_socket_server("tcp://0.0.0.0:8000", $errno, $errstr);
if (!$socket) {
  echo "$errstr ($errno)<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, 'La fecha y hora actuales es ' . date('n/j/Y g:i a') . "\n");
    fclose($conn);
  }
  fclose($socket);
}
?>

El ejemplo de abajo muestra cómo actuar como un servidor de hora que responde a peticiones de hora como se muestra en un ejemplo de stream_socket_client().

Nota: La mayoría de los sistemas requieren acceso root para crear un socket de servidor sobre un puerto inferor a 1024.

Ejemplo #2 Usar sockets de servidor de UDP

<?php
$socket = stream_socket_server("udp://127.0.0.1:1113", $errno, $errstr, STREAM_SERVER_BIND);
if (!$socket) {
    die("$errstr ($errno)");
}

do {
    $pkt = stream_socket_recvfrom($socket, 1, 0, $peer);
    echo "$peer\n";
    stream_socket_sendto($socket, date("D M j H:i:s Y\r\n"), 0, $peer);
} while ($pkt !== false);

?>

Notas

Nota: Cuando se especifique una dirección numérica IPv6 (por ej., fe80::1), la IP debe ser encerrada entre corchetes — por ejemplo, tcp://[fe80::1]:80.

Ver también

  • stream_socket_client() - Abrir una conexión de socket de dominio de Internet o Unix
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fwrite() - Escritura de un archivo en modo binario seguro
  • fclose() - Cierra un puntero a un archivo abierto
  • feof() - Comprueba si el puntero a un archivo está al final del archivo
  • La extensión Curl


Cerrar una conexión full-duplex

  • « stream_socket_server
  • stream_supports_lock »
  • PHP Manual
  • Funciones de Flujos
  • Cerrar una conexión full-duplex

stream_socket_shutdown

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

stream_socket_shutdown — Cerrar una conexión full-duplex

Descripción

stream_socket_shutdown ( resource $stream , int $how ) : bool

Cierra (parcialmente o no) una conexión full-duplex.

Nota:

El búfer o búferes podrían o no estar vaciados.

Parámetros

stream

Un flujo abierto (con stream_socket_client(), por ejemplo)

how

Una de las siguientes constantes: STREAM_SHUT_RD (deshabilita recepciones), STREAM_SHUT_WR (deshabilita transmisiones) o STREAM_SHUT_RDWR (deshabilita recepciones y transmisiones).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de stream_socket_shutdown()

<?php

$servidor = stream_socket_server('tcp://127.0.0.1:1337');
$cliente = stream_socket_client('tcp://127.0.0.1:1337');

var_dump(fputs($cliente, "hola"));

stream_socket_shutdown($cliente, STREAM_SHUT_WR);
var_dump(fputs($cliente, "hola")); // no funciona ahora

?>

El resultado del ejemplo sería algo similar a:

int(5)

Notice: fputs(): send of 5 bytes failed with errno=32 Broken pipe in test.php on line 9
int(0)

Ver también

  • fclose() - Cierra un puntero a un archivo abierto


Indica si el flujo soporta bloqueo

  • « stream_socket_shutdown
  • stream_wrapper_register »
  • PHP Manual
  • Funciones de Flujos
  • Indica si el flujo soporta bloqueo

stream_supports_lock

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_supports_lock — Indica si el flujo soporta bloqueo

Descripción

stream_supports_lock ( resource $stream ) : bool

Indica si el flujo soporta bloqueo a través de flock().

Parámetros

stream

El flujo a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • flock() - Bloqueo de ficheros recomendado y portable


Registra una envoltura de URL implementada como una clase de PHP

  • « stream_supports_lock
  • stream_wrapper_restore »
  • PHP Manual
  • Funciones de Flujos
  • Registra una envoltura de URL implementada como una clase de PHP

stream_wrapper_register

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

stream_wrapper_register — Registra una envoltura de URL implementada como una clase de PHP

Descripción

stream_wrapper_register ( string $protocol , string $classname , int $flags = 0 ) : bool

Permite implementar sus propios gestores de protocolo y flujos para usarlos con todas las demás funciones de sisitema de archivos (tales como fopen(), fread() etc.).

Parámetros

protocol

El nombre de la envoltura a ser registrada.

classname

El nombre de la clase que implementa protocol.

flags

Debería ser establecido a STREAM_IS_URL si protocol es un protocolo de URL. Por defecto es 0, flujo local.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

stream_wrapper_register() devolverá false si protocol ya tiene un gestor.

Historial de cambios

Versión | Descripción
5.2.4 | Añadido el parámetro flags.

Ejemplos

Ejemplo #1 Cómo registrar una envoltura de flujo

<?php
$existed = in_array("var", stream_get_wrappers());
if ($existed) {
    stream_wrapper_unregister("var");
}
stream_wrapper_register("var", "VariableStream");
$mivar = "";

$fp = fopen("var://mivar", "r+");

fwrite($fp, "línea1\n");
fwrite($fp, "línea2\n");
fwrite($fp, "línea3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($mivar);

if ($existed) {
    stream_wrapper_restore("var");
}

?>

El resultado del ejemplo sería:

línea1
línea2
línea3
string(24) "línea1
línea2
línea3
"

Ver también

  • La clase prototipo streamWrapper
  • Ejemplo de clase registrada como envoltura de flujo
  • stream_wrapper_unregister() - Deja de registrar una envoltura de URL
  • stream_wrapper_restore() - Restablece una envoltura incluida que se dejó de registrar previamente
  • stream_get_wrappers() - Recupera la lista de los flujos registrados


Restablece una envoltura incluida que se dejó de registrar previamente

  • « stream_wrapper_register
  • stream_wrapper_unregister »
  • PHP Manual
  • Funciones de Flujos
  • Restablece una envoltura incluida que se dejó de registrar previamente

stream_wrapper_restore

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_wrapper_restore — Restablece una envoltura incluida que se dejó de registrar previamente

Descripción

stream_wrapper_restore ( string $protocol ) : bool

Restablece una envoltura incluida que se dejó de registrar previamente con stream_wrapper_unregister().

Parámetros

protocol

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Deja de registrar una envoltura de URL

  • « stream_wrapper_restore
  • Swoole »
  • PHP Manual
  • Funciones de Flujos
  • Deja de registrar una envoltura de URL

stream_wrapper_unregister

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_wrapper_unregister — Deja de registrar una envoltura de URL

Descripción

stream_wrapper_unregister ( string $protocol ) : bool

Permite deshabilitar una envoltura de flujo ya definida. Una vez que la envoltura ha sido deshabilitada, se la puede sobreescribir con una envoltura definida por el usuario usando stream_wrapper_register() o rehabilitándola después com stream_wrapper_restore().

Parámetros

protocol

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Swoole

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Swoole Funciones
    • swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup
    • swoole_async_read — Read file stream asynchronously
    • swoole_async_readfile — Read a file asynchronously
    • swoole_async_set — Update the async I/O options
    • swoole_async_write — Write data to a file stream asynchronously
    • swoole_async_writefile — Write data to a file asynchronously
    • swoole_client_select — Get the file description which are ready to read/write or error
    • swoole_cpu_num — Get the number of CPU
    • swoole_errno — Get the error code of the latest system call
    • swoole_event_add — Add new callback functions of a socket into the EventLoop
    • swoole_event_defer — Add callback function to the next event loop
    • swoole_event_del — Remove all event callback functions of a socket
    • swoole_event_exit — Exit the eventloop, only available at the client side
    • swoole_event_set — Update the event callback functions of a socket
    • swoole_event_wait — Start the event loop
    • swoole_event_write — Write data to a socket
    • swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine
    • swoole_last_error — Get the lastest error message
    • swoole_load_module — Load a swoole extension
    • swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop
    • swoole_set_process_name — Set the process name
    • swoole_strerror — Convert the Errno into error messages
    • swoole_timer_after — Trigger a one time callback function in the future
    • swoole_timer_exists — Check if a timer callback function is existed
    • swoole_timer_tick — Trigger a timer tick callback function by time interval
    • swoole_version — Get the version of Swoole
  • Swoole\Async — The Swoole\Async class
    • Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.
    • Swoole\Async::read — Read file stream asynchronously.
    • Swoole\Async::readFile — Read a file asynchronously.
    • Swoole\Async::set — Update the async I/O options.
    • Swoole\Async::write — Write data to a file stream asynchronously.
    • Swoole\Async::writeFile — Description
  • Swoole\Atomic — The Swoole\Atomic class
    • Swoole\Atomic::add — Add a number to the value to the atomic object.
    • Swoole\Atomic::cmpset — Compare and set the value of the atomic object.
    • Swoole\Atomic::__construct — Construct a swoole atomic object.
    • Swoole\Atomic::get — Get the current value of the atomic object.
    • Swoole\Atomic::set — Set a new value to the atomic object.
    • Swoole\Atomic::sub — Subtract a number to the value of the atomic object.
  • Swoole\Buffer — The Swoole\Buffer class
    • Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
    • Swoole\Buffer::clear — Reset the memory buffer.
    • Swoole\Buffer::__construct — Fixed size memory blocks allocation.
    • Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.
    • Swoole\Buffer::expand — Expand the size of memory buffer.
    • Swoole\Buffer::read — Read data from the memory buffer based on offset and length.
    • Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.
    • Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
    • Swoole\Buffer::__toString — Get the string value of the memory buffer.
    • Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.
  • Swoole\Channel — The Swoole\Channel class
    • Swoole\Channel::__construct — Construct a Swoole Channel
    • Swoole\Channel::__destruct — Destruct a Swoole channel.
    • Swoole\Channel::pop — Read and pop data from swoole channel.
    • Swoole\Channel::push — Write and push data into Swoole channel.
    • Swoole\Channel::stats — Get stats of swoole channel.
  • Swoole\Client — The Swoole\Client class
    • Swoole\Client::close — Close the connection established.
    • Swoole\Client::connect — Connect to the remote TCP or UDP port.
    • Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.
    • Swoole\Client::__destruct — Destruct the Swoole client.
    • Swoole\Client::getpeername — Get the remote socket name of the connection.
    • Swoole\Client::getsockname — Get the local socket name of the connection.
    • Swoole\Client::isConnected — Check if the connection is established.
    • Swoole\Client::on — Add callback functions triggered by events.
    • Swoole\Client::pause — Pause receiving data.
    • Swoole\Client::pipe — Redirect the data to another file descriptor.
    • Swoole\Client::recv — Receive data from the remote socket.
    • Swoole\Client::resume — Resume receiving data.
    • Swoole\Client::send — Send data to the remote TCP socket.
    • Swoole\Client::sendfile — Send file to the remote TCP socket.
    • Swoole\Client::sendto — Send data to the remote UDP address.
    • Swoole\Client::set — Set the Swoole client parameters before the connection is established.
    • Swoole\Client::sleep — Remove the TCP client from system event loop.
    • Swoole\Client::wakeup — Add the TCP client back into the system event loop.
  • Swoole\Connection\Iterator — The Swoole\Connection\Iterator class
    • Swoole\Connection\Iterator::count — Count connections.
    • Swoole\Connection\Iterator::current — Return current connection entry.
    • Swoole\Connection\Iterator::key — Return key of the current connection.
    • Swoole\Connection\Iterator::next — Move to the next connection.
    • Swoole\Connection\Iterator::offsetExists — Check if offet exists.
    • Swoole\Connection\Iterator::offsetGet — Offset to retrieve.
    • Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.
    • Swoole\Connection\Iterator::offsetUnset — Unset an offset.
    • Swoole\Connection\Iterator::rewind — Rewinds iterator
    • Swoole\Connection\Iterator::valid — Check if current position is valid.
  • Swoole\Coroutine — The Swoole\Coroutine class
    • Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters
    • Swoole\Coroutine::call_user_func — Call a callback given by the first parameter
    • Swoole\Coroutine::cli_wait — Description
    • Swoole\Coroutine::create — Description
    • Swoole\Coroutine\Client::close — Description
    • Swoole\Coroutine\Client::connect — Description
    • Swoole\Coroutine\Client::__construct — Description
    • Swoole\Coroutine\Client::__destruct — Description
    • Swoole\Coroutine\Client::getpeername — Description
    • Swoole\Coroutine\Client::getsockname — Description
    • Swoole\Coroutine\Client::isConnected — Description
    • Swoole\Coroutine\Client::recv — Description
    • Swoole\Coroutine\Client::send — Description
    • Swoole\Coroutine\Client::sendfile — Description
    • Swoole\Coroutine\Client::sendto — Description
    • Swoole\Coroutine\Client::set — Description
    • Swoole\Coroutine\Http\Client::addFile — Description
    • Swoole\Coroutine\Http\Client::close — Description
    • Swoole\Coroutine\Http\Client::__construct — Description
    • Swoole\Coroutine\Http\Client::__destruct — Description
    • Swoole\Coroutine\Http\Client::execute — Description
    • Swoole\Coroutine\Http\Client::get — Description
    • Swoole\Coroutine\Http\Client::getDefer — Description
    • Swoole\Coroutine\Http\Client::isConnected — Description
    • Swoole\Coroutine\Http\Client::post — Description
    • Swoole\Coroutine\Http\Client::recv — Description
    • Swoole\Coroutine\Http\Client::set — Description
    • Swoole\Coroutine\Http\Client::setCookies — Description
    • Swoole\Coroutine\Http\Client::setData — Description
    • Swoole\Coroutine\Http\Client::setDefer — Description
    • Swoole\Coroutine\Http\Client::setHeaders — Description
    • Swoole\Coroutine\Http\Client::setMethod — Description
    • Swoole\Coroutine\MySQL::close — Description
    • Swoole\Coroutine\MySQL::connect — Description
    • Swoole\Coroutine\MySQL::__construct — Description
    • Swoole\Coroutine\MySQL::__destruct — Description
    • Swoole\Coroutine\MySQL::getDefer — Description
    • Swoole\Coroutine\MySQL::query — Description
    • Swoole\Coroutine\MySQL::recv — Description
    • Swoole\Coroutine\MySQL::setDefer — Description
    • Swoole\Coroutine::getuid — Description
    • Swoole\Coroutine::resume — Description
    • Swoole\Coroutine::suspend — Description
  • Swoole\Event — The Swoole\Event class
    • Swoole\Event::add — Add new callback functions of a socket into the EventLoop.
    • Swoole\Event::defer — Add a callback function to the next event loop.
    • Swoole\Event::del — Remove all event callback functions of a socket.
    • Swoole\Event::exit — Exit the eventloop, only available at client side.
    • Swoole\Event::set — Update the event callback functions of a socket.
    • Swoole\Event::wait — Description
    • Swoole\Event::write — Write data to the socket.
  • Swoole\Exception — The Swoole\Exception class
  • Swoole\Http\Client — The Swoole\Http\Client class
    • Swoole\Http\Client::addFile — Add a file to the post form.
    • Swoole\Http\Client::close — Close the http connection.
    • Swoole\Http\Client::__construct — Construct the async HTTP client.
    • Swoole\Http\Client::__destruct — Destruct the HTTP client.
    • Swoole\Http\Client::download — Download a file from the remote server.
    • Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.
    • Swoole\Http\Client::get — Send GET http request to the remote server.
    • Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.
    • Swoole\Http\Client::on — Register callback function by event name.
    • Swoole\Http\Client::post — Send POST http request to the remote server.
    • Swoole\Http\Client::push — Push data to websocket client.
    • Swoole\Http\Client::set — Update the HTTP client paramters.
    • Swoole\Http\Client::setCookies — Set the http request cookies.
    • Swoole\Http\Client::setData — Set the HTTP request body data.
    • Swoole\Http\Client::setHeaders — Set the HTTP request headers.
    • Swoole\Http\Client::setMethod — Set the HTTP request method.
    • Swoole\Http\Client::upgrade — Upgrade to websocket protocol.
  • Swoole\Http\Request — The Swoole\Http\Request class
    • Swoole\Http\Request::__destruct — Destruct the HTTP request.
    • Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.
  • Swoole\Http\Response — The Swoole\Http\Response class
    • Swoole\Http\Response::cookie — Set the cookies of the HTTP response.
    • Swoole\Http\Response::__destruct — Destruct the HTTP response.
    • Swoole\Http\Response::end — Send data for the HTTP request and finish the response.
    • Swoole\Http\Response::gzip — Enable the gzip of response content.
    • Swoole\Http\Response::header — Set the HTTP response headers.
    • Swoole\Http\Response::initHeader — Init the HTTP response header.
    • Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.
    • Swoole\Http\Response::sendfile — Send file through the HTTP response.
    • Swoole\Http\Response::status — Set the status code of the HTTP response.
    • Swoole\Http\Response::write — Append HTTP body content to the HTTP response.
  • Swoole\Http\Server — The Swoole\Http\Server class
    • Swoole\Http\Server::on — Bind callback function to HTTP server by event name.
    • Swoole\Http\Server::start — Start the swoole http server.
  • Swoole\Lock — The Swoole\Lock class
    • Swoole\Lock::__construct — Construct a memory lock.
    • Swoole\Lock::__destruct — Destory a Swoole memory lock.
    • Swoole\Lock::lock_read — Lock a read-write lock for reading.
    • Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.
    • Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.
    • Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.
    • Swoole\Lock::unlock — Release the lock.
  • Swoole\Mmap — The Swoole\Mmap class
    • Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.
  • Swoole\MySQL — The Swoole\MySQL class
    • Swoole\MySQL::close — Close the async MySQL connection.
    • Swoole\MySQL::connect — Connect to the remote MySQL server.
    • Swoole\MySQL::__construct — Construct an async MySQL client.
    • Swoole\MySQL::__destruct — Destory the async MySQL client.
    • Swoole\MySQL::getBuffer — Description
    • Swoole\MySQL::on — Register callback function based on event name.
    • Swoole\MySQL::query — Run the SQL query.
  • Swoole\MySQL\Exception — The Swoole\MySQL\Exception class
  • Swoole\Process — The Swoole\Process class
    • Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.
    • Swoole\Process::close — Close the pipe to the child process.
    • Swoole\Process::__construct — Construct a process.
    • Swoole\Process::daemon — Change the process to be a daemon process.
    • Swoole\Process::__destruct — Destory the process.
    • Swoole\Process::exec — Execute system commands.
    • Swoole\Process::exit — Stop the child processes.
    • Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.
    • Swoole\Process::kill — Send signal to the child process.
    • Swoole\Process::name — Set name of the process.
    • Swoole\Process::pop — Read and pop data from the message queue.
    • Swoole\Process::push — Write and push data into the message queue.
    • Swoole\Process::read — Read data sending to the process.
    • Swoole\Process::signal — Send signal to the child processes.
    • Swoole\Process::start — Start the process.
    • Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.
    • Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.
    • Swoole\Process::wait — Wait for the events of child processes.
    • Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.
  • Swoole\Redis\Server — The Swoole\Redis\Server class
    • Swoole\Redis\Server::format — Description
    • Swoole\Redis\Server::setHandler — Description
    • Swoole\Redis\Server::start — Description
  • Swoole\Serialize — The Swoole\Serialize class
    • Swoole\Serialize::pack — Serialize the data.
    • Swoole\Serialize::unpack — Unserialize the data.
  • Swoole\Server — The Swoole\Server class
    • Swoole\Server::addlistener — Add a new listener to the server.
    • Swoole\Server::addProcess — Add a user defined swoole_process to the server.
    • Swoole\Server::after — Trigger a callback function after a period of time.
    • Swoole\Server::bind — Bind the connection to a user defined user ID.
    • Swoole\Server::clearTimer — Stop and destory a timer.
    • Swoole\Server::close — Close a connection to the client.
    • Swoole\Server::confirm — Check status of the connection.
    • Swoole\Server::connection_info — Get the connection info by file description.
    • Swoole\Server::connection_list — Get all of the established connections.
    • Swoole\Server::__construct — Construct a Swoole server.
    • Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.
    • Swoole\Server\Port::__construct — Construct a server port
    • Swoole\Server\Port::__destruct — Destory server port
    • Swoole\Server\Port::on — Register callback functions by event.
    • Swoole\Server\Port::set — Set protocol of the server port.
    • Swoole\Server::exist — Check if the connection is existed.
    • Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.
    • Swoole\Server::getClientInfo — Get the connection info by file description.
    • Swoole\Server::getClientList — Get all of the established connections.
    • Swoole\Server::getLastError — Get the error code of the most recent error.
    • Swoole\Server::heartbeat — Check all the connections on the server.
    • Swoole\Server::listen — Listen on the given IP and port, socket type.
    • Swoole\Server::on — Register a callback function by event name.
    • Swoole\Server::pause — Stop receiving data from the connection.
    • Swoole\Server::protect — Set the connection to be protected mode.
    • Swoole\Server::reload — Restart all the worker process.
    • Swoole\Server::resume — Start receving data from the connection.
    • Swoole\Server::send — Send data to the client.
    • Swoole\Server::sendfile — Send file to the connection.
    • Swoole\Server::sendMessage — Send message to worker processes by ID.
    • Swoole\Server::sendto — Send data to the remote UDP address.
    • Swoole\Server::sendwait — Send data to the remote socket in the blocking way.
    • Swoole\Server::set — Set the runtime settings of the swoole server.
    • Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.
    • Swoole\Server::start — Start the Swoole server.
    • Swoole\Server::stats — Get the stats of the Swoole server.
    • Swoole\Server::stop — Stop the Swoole server.
    • Swoole\Server::task — Send data to the task worker processes.
    • Swoole\Server::taskwait — Send data to the task worker processes in blocking way.
    • Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.
    • Swoole\Server::tick — Repeats a given function at every given time-interval.
  • Swoole\Table — The Swoole\Table class
    • Swoole\Table::column — Set the data type and size of the columns.
    • Swoole\Table::__construct — Construct a Swoole memory table with fixed size.
    • Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.
    • Swoole\Table::create — Create the swoole memory table.
    • Swoole\Table::current — Get the current row.
    • Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::del — Delete a row in the Swoole table by $row_key.
    • Swoole\Table::destroy — Destroy the Swoole table.
    • Swoole\Table::exist — Check if a row is existed by $row_key.
    • Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::incr — Increment the value by $row_key and $column_key.
    • Swoole\Table::key — Get the key of current row.
    • Swoole\Table::next — Iterator the next row.
    • Swoole\Table::rewind — Rewind the iterator.
    • Swoole\Table::set — Update a row of the table by $row_key.
    • Swoole\Table::valid — Check current if the current row is valid.
  • Swoole\Timer — The Swoole\Timer class
    • Swoole\Timer::after — Trigger a callback function after a period of time.
    • Swoole\Timer::clear — Delete a timer by timer ID.
    • Swoole\Timer::exists — Check if a timer is existed.
    • Swoole\Timer::tick — Repeats a given function at every given time-interval.
  • Swoole\WebSocket\Frame — The Swoole\WebSocket\Frame class
  • Swoole\WebSocket\Server — The Swoole\WebSocket\Server class
    • Swoole\WebSocket\Server::exist — Check if the file descriptor exists.
    • Swoole\WebSocket\Server::on — Register event callback function
    • Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.
    • Swoole\WebSocket\Server::push — Push data to the remote client.
    • Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.


Introducción

Swoole is a high-performance networking framework using an event-driven, asynchronous, non-blocking I/O model. It can be used to develop high-performance, scalable, concurrent TCP, UDP, Unix socket, HTTP, Websocket services. To get started, please check the » Swoole Docs.

Nota: Esta extensión no está disponible en plataformas Windows.


Instalación

Use --with-swoole[=DIR] when compiling PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/swoole


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Swoole Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
swoole.aio_thread_num | 2 | PHP_INI_ALL |
swoole.display_errors | On | PHP_INI_ALL |
swoole.fast_serialize | Off | PHP_INI_ALL |
swoole.unixsock_buffer_size | 8388608 | PHP_INI_ALL |
swoole.use_namespace | On | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

swoole.aio_thread_num int

POSIX asynchronous I/O thread number

swoole.display_errors string

This determines whether Swoole errors should be printed to the screen.

swoole.fast_serialize string

Whether to enable Swoole fast_serialize.

swoole.unixsock_buffer_size int

Buffer size of Unix socket.

swoole.use_namespace string

Whether to use PHP namespaces


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SWOOLE_BASE (int)
SWOOLE_THREAD (int)
SWOOLE_PROCESS (int)
SWOOLE_IPC_UNSOCK (int)
SWOOLE_IPC_MSGQUEUE (int)
SWOOLE_IPC_PREEMPTIVE (int)
SWOOLE_SOCK_TCP (int)
SWOOLE_SOCK_TCP6 (int)
SWOOLE_SOCK_UDP (int)
SWOOLE_SOCK_UDP6 (int)
SWOOLE_SOCK_UNIX_DGRAM (int)
SWOOLE_SOCK_UNIX_STREAM (int)
SWOOLE_TCP (int)
SWOOLE_TCP6 (int)
SWOOLE_UDP (int)
SWOOLE_UDP6 (int)
SWOOLE_UNIX_DGRAM (int)
SWOOLE_UNIX_STREAM (int)
SWOOLE_SOCK_SYNC (int)
SWOOLE_SOCK_ASYNC (int)
SWOOLE_SYNC (int)
SWOOLE_ASYNC (int)
SWOOLE_KEEP (int)
SWOOLE_EVENT_READ (int)
SWOOLE_EVENT_WRITE (int)
SWOOLE_VERSION (string)
SWOOLE_AIO_BASE (int)
SWOOLE_AIO_LINUX (int)
SWOOLE_FILELOCK (int)
SWOOLE_MUTEX (int)
SWOOLE_SEM (int)
SWOOLE_RWLOCK (int)
WEBSOCKET_OPCODE_TEXT (int)
WEBSOCKET_OPCODE_BINARY (int)
WEBSOCKET_OPCODE_PING (int)
WEBSOCKET_STATUS_CONNECTION (int)
WEBSOCKET_STATUS_HANDSHAKE (int)
WEBSOCKET_STATUS_FRAME (int)
WEBSOCKET_STATUS_ACTIVE (int)
SWOOLE_FAST_PACK (int)


Swoole Funciones

Tabla de contenidos

  • swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup
  • swoole_async_read — Read file stream asynchronously
  • swoole_async_readfile — Read a file asynchronously
  • swoole_async_set — Update the async I/O options
  • swoole_async_write — Write data to a file stream asynchronously
  • swoole_async_writefile — Write data to a file asynchronously
  • swoole_client_select — Get the file description which are ready to read/write or error
  • swoole_cpu_num — Get the number of CPU
  • swoole_errno — Get the error code of the latest system call
  • swoole_event_add — Add new callback functions of a socket into the EventLoop
  • swoole_event_defer — Add callback function to the next event loop
  • swoole_event_del — Remove all event callback functions of a socket
  • swoole_event_exit — Exit the eventloop, only available at the client side
  • swoole_event_set — Update the event callback functions of a socket
  • swoole_event_wait — Start the event loop
  • swoole_event_write — Write data to a socket
  • swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine
  • swoole_last_error — Get the lastest error message
  • swoole_load_module — Load a swoole extension
  • swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop
  • swoole_set_process_name — Set the process name
  • swoole_strerror — Convert the Errno into error messages
  • swoole_timer_after — Trigger a one time callback function in the future
  • swoole_timer_exists — Check if a timer callback function is existed
  • swoole_timer_tick — Trigger a timer tick callback function by time interval
  • swoole_version — Get the version of Swoole


Async and non-blocking hostname to IP lookup

  • « Swoole Funciones
  • swoole_async_read »
  • PHP Manual
  • Swoole Funciones
  • Async and non-blocking hostname to IP lookup

swoole_async_dns_lookup

(PECL swoole >= 1.9.0)

swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup

Descripción

swoole_async_dns_lookup ( string $hostname , callable $callback ) : bool

Parámetros

hostname

The host name.

callback
callback ( string $hostname , string $ip ) : mixed
hostname

The host name.

IP

The IP address.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Read file stream asynchronously

  • « swoole_async_dns_lookup
  • swoole_async_readfile »
  • PHP Manual
  • Swoole Funciones
  • Read file stream asynchronously

swoole_async_read

(PECL swoole >= 1.9.0)

swoole_async_read — Read file stream asynchronously

Descripción

swoole_async_read ( string $filename , callable $callback , int $chunk_size = 65536 , int $offset = 0 ) : bool

Parámetros

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file stream.

chunk_size

The chunk length.

offset

The offset.

Valores devueltos

Whether the read is succeed.


Read a file asynchronously

  • « swoole_async_read
  • swoole_async_set »
  • PHP Manual
  • Swoole Funciones
  • Read a file asynchronously

swoole_async_readfile

(PECL swoole >= 1.9.0)

swoole_async_readfile — Read a file asynchronously

Descripción

swoole_async_readfile ( string $filename , callable $callback ) : bool

Parámetros

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Update the async I/O options

  • « swoole_async_readfile
  • swoole_async_write »
  • PHP Manual
  • Swoole Funciones
  • Update the async I/O options

swoole_async_set

(PECL swoole >= 1.9.0)

swoole_async_set — Update the async I/O options

Descripción

swoole_async_set ( array $settings ) : void

Parámetros

settings


Write data to a file stream asynchronously

  • « swoole_async_set
  • swoole_async_writefile »
  • PHP Manual
  • Swoole Funciones
  • Write data to a file stream asynchronously

swoole_async_write

(PECL swoole >= 1.9.0)

swoole_async_write — Write data to a file stream asynchronously

Descripción

swoole_async_write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : bool

Parámetros

filename

The filename being written.

content

The content writing to the file.

offset

The offset.

callback

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Write data to a file asynchronously

  • « swoole_async_write
  • swoole_client_select »
  • PHP Manual
  • Swoole Funciones
  • Write data to a file asynchronously

swoole_async_writefile

(PECL swoole >= 1.9.0)

swoole_async_writefile — Write data to a file asynchronously

Descripción

swoole_async_writefile ( string $filename , string $content , callable $callback = ? , int $flags = 0 ) : bool

Parámetros

filename

The filename being written.

content

The content writing to the file.

callback

flags

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Get the file description which are ready to read/write or error

  • « swoole_async_writefile
  • swoole_cpu_num »
  • PHP Manual
  • Swoole Funciones
  • Get the file description which are ready to read/write or error

swoole_client_select

(PECL swoole >= 1.9.0)

swoole_client_select — Get the file description which are ready to read/write or error

Descripción

swoole_client_select ( array &$read_array , array &$write_array , array &$error_array , float $timeout = 0.5 ) : int

Parámetros

read_array

write_array

error_array

timeout

Valores devueltos


Get the number of CPU

  • « swoole_client_select
  • swoole_errno »
  • PHP Manual
  • Swoole Funciones
  • Get the number of CPU

swoole_cpu_num

(PECL swoole >= 1.9.0)

swoole_cpu_num — Get the number of CPU

Descripción

swoole_cpu_num ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The number of CPU.


Get the error code of the latest system call

  • « swoole_cpu_num
  • swoole_event_add »
  • PHP Manual
  • Swoole Funciones
  • Get the error code of the latest system call

swoole_errno

(PECL swoole >= 1.9.0)

swoole_errno — Get the error code of the latest system call

Descripción

swoole_errno ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Add new callback functions of a socket into the EventLoop

  • « swoole_errno
  • swoole_event_defer »
  • PHP Manual
  • Swoole Funciones
  • Add new callback functions of a socket into the EventLoop

swoole_event_add

(PECL swoole >= 1.9.0)

swoole_event_add — Add new callback functions of a socket into the EventLoop

Descripción

swoole_event_add ( int $fd , callable $read_callback = ? , callable $write_callback = ? , int $events = 0 ) : int

Parámetros

fd

read_callback

write_callback

events

Valores devueltos


Add callback function to the next event loop

  • « swoole_event_add
  • swoole_event_del »
  • PHP Manual
  • Swoole Funciones
  • Add callback function to the next event loop

swoole_event_defer

(PECL swoole >= 1.9.0)

swoole_event_defer — Add callback function to the next event loop

Descripción

swoole_event_defer ( callable $callback ) : bool

Parámetros

callback

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Remove all event callback functions of a socket

  • « swoole_event_defer
  • swoole_event_exit »
  • PHP Manual
  • Swoole Funciones
  • Remove all event callback functions of a socket

swoole_event_del

(PECL swoole >= 1.9.0)

swoole_event_del — Remove all event callback functions of a socket

Descripción

swoole_event_del ( int $fd ) : bool

Parámetros

fd

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Exit the eventloop, only available at the client side

  • « swoole_event_del
  • swoole_event_set »
  • PHP Manual
  • Swoole Funciones
  • Exit the eventloop, only available at the client side

swoole_event_exit

(PECL swoole >= 1.9.0)

swoole_event_exit — Exit the eventloop, only available at the client side

Descripción

swoole_event_exit ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Update the event callback functions of a socket

  • « swoole_event_exit
  • swoole_event_wait »
  • PHP Manual
  • Swoole Funciones
  • Update the event callback functions of a socket

swoole_event_set

(PECL swoole >= 1.9.0)

swoole_event_set — Update the event callback functions of a socket

Descripción

swoole_event_set ( int $fd , callable $read_callback = ? , callable $write_callback = ? , int $events = 0 ) : bool

Parámetros

fd

read_callback

write_callback

events

Valores devueltos


Start the event loop

  • « swoole_event_set
  • swoole_event_write »
  • PHP Manual
  • Swoole Funciones
  • Start the event loop

swoole_event_wait

(PECL swoole >= 1.9.0)

swoole_event_wait — Start the event loop

Descripción

swoole_event_wait ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Write data to a socket

  • « swoole_event_wait
  • swoole_get_local_ip »
  • PHP Manual
  • Swoole Funciones
  • Write data to a socket

swoole_event_write

(PECL swoole >= 1.9.0)

swoole_event_write — Write data to a socket

Descripción

swoole_event_write ( int $fd , string $data ) : bool

Parámetros

fd

data

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Get the IPv4 IP addresses of each NIC on the machine

  • « swoole_event_write
  • swoole_last_error »
  • PHP Manual
  • Swoole Funciones
  • Get the IPv4 IP addresses of each NIC on the machine

swoole_get_local_ip

(PECL swoole >= 1.9.0)

swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine

Descripción

swoole_get_local_ip ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the lastest error message

  • « swoole_get_local_ip
  • swoole_load_module »
  • PHP Manual
  • Swoole Funciones
  • Get the lastest error message

swoole_last_error

(PECL swoole >= 1.9.0)

swoole_last_error — Get the lastest error message

Descripción

swoole_last_error ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Load a swoole extension

  • « swoole_last_error
  • swoole_select »
  • PHP Manual
  • Swoole Funciones
  • Load a swoole extension

swoole_load_module

(PECL swoole >= 1.9.0)

swoole_load_module — Load a swoole extension

Descripción

swoole_load_module ( string $filename ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Select the file descriptions which are ready to read/write or error in the eventloop

  • « swoole_load_module
  • swoole_set_process_name »
  • PHP Manual
  • Swoole Funciones
  • Select the file descriptions which are ready to read/write or error in the eventloop

swoole_select

(PECL swoole >= 1.9.0)

swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop

Descripción

swoole_select ( array &$read_array , array &$write_array , array &$error_array , float $timeout = ? ) : int

Parámetros

read_array

write_array

error_array

timeout

Valores devueltos


Set the process name

  • « swoole_select
  • swoole_strerror »
  • PHP Manual
  • Swoole Funciones
  • Set the process name

swoole_set_process_name

(PECL swoole >= 1.9.0)

swoole_set_process_name — Set the process name

Descripción

swoole_set_process_name ( string $process_name , int $size = 128 ) : void

Parámetros

process_name

Valores devueltos


Convert the Errno into error messages

  • « swoole_set_process_name
  • swoole_timer_after »
  • PHP Manual
  • Swoole Funciones
  • Convert the Errno into error messages

swoole_strerror

(PECL swoole >= 1.9.0)

swoole_strerror — Convert the Errno into error messages

Descripción

swoole_strerror ( int $errno , int $error_type = 0 ) : string

Parámetros

errno

Valores devueltos


Trigger a one time callback function in the future

  • « swoole_strerror
  • swoole_timer_exists »
  • PHP Manual
  • Swoole Funciones
  • Trigger a one time callback function in the future

swoole_timer_after

(PECL swoole >= 1.9.0)

swoole_timer_after — Trigger a one time callback function in the future

Descripción

swoole_timer_after ( int $ms , callable $callback , mixed $param = ? ) : int

Parámetros

ms

callback

param

Valores devueltos


Check if a timer callback function is existed

  • « swoole_timer_after
  • swoole_timer_tick »
  • PHP Manual
  • Swoole Funciones
  • Check if a timer callback function is existed

swoole_timer_exists

(PECL swoole >= 1.9.0)

swoole_timer_exists — Check if a timer callback function is existed

Descripción

swoole_timer_exists ( int $timer_id ) : bool

Parámetros

timer_id

Valores devueltos


Trigger a timer tick callback function by time interval

  • « swoole_timer_exists
  • swoole_version »
  • PHP Manual
  • Swoole Funciones
  • Trigger a timer tick callback function by time interval

swoole_timer_tick

(PECL swoole >= 1.9.0)

swoole_timer_tick — Trigger a timer tick callback function by time interval

Descripción

swoole_timer_tick ( int $ms , callable $callback , mixed $param = ? ) : int

Parámetros

ms

callback

Valores devueltos


Get the version of Swoole

  • « swoole_timer_tick
  • Swoole\Async »
  • PHP Manual
  • Swoole Funciones
  • Get the version of Swoole

swoole_version

(PECL swoole >= 1.9.0)

swoole_version — Get the version of Swoole

Descripción

swoole_version ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The version of Swoole.


The Swoole\Async class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Async {
/* Métodos */
public static dnsLookup ( string $hostname , callable $callback ) : void
public static read ( string $filename , callable $callback , int $chunk_size = ? , int $offset = ? ) : bool
public static readFile ( string $filename , callable $callback ) : void
public static set ( array $settings ) : void
public static write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : void
public static writeFile ( string $filename , string $content , callable $callback = ? , string $flags = ? ) : void
}

Tabla de contenidos

  • Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.
  • Swoole\Async::read — Read file stream asynchronously.
  • Swoole\Async::readFile — Read a file asynchronously.
  • Swoole\Async::set — Update the async I/O options.
  • Swoole\Async::write — Write data to a file stream asynchronously.
  • Swoole\Async::writeFile — Description


Async and non-blocking hostname to IP lookup.

  • « Swoole\Async
  • Swoole\Async::read »
  • PHP Manual
  • Swoole\Async
  • Async and non-blocking hostname to IP lookup.

Swoole\Async::dnsLookup

(PECL swoole >= 1.9.0)

Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.

Descripción

public static Swoole\Async::dnsLookup ( string $hostname , callable $callback ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

hostname

The host name.

callback
callback ( string $hostname , string $ip ) : mixed
hostname

The host name.

IP

The IP address.


Read file stream asynchronously.

  • « Swoole\Async::dnsLookup
  • Swoole\Async::readFile »
  • PHP Manual
  • Swoole\Async
  • Read file stream asynchronously.

Swoole\Async::read

(PECL swoole >= 1.9.0)

Swoole\Async::read — Read file stream asynchronously.

Descripción

public static Swoole\Async::read ( string $filename , callable $callback , int $chunk_size = ? , int $offset = ? ) : bool

Parámetros

filename

The name of the file.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file stream.

chunk_size

The chunk length.

offset

The offset.

Valores devueltos

Whether the read is succeed.


Read a file asynchronously.

  • « Swoole\Async::read
  • Swoole\Async::set »
  • PHP Manual
  • Swoole\Async
  • Read a file asynchronously.

Swoole\Async::readFile

(PECL swoole >= 1.9.0)

Swoole\Async::readFile — Read a file asynchronously.

Descripción

public static Swoole\Async::readFile ( string $filename , callable $callback ) : void

Parámetros

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file.


Update the async I/O options.

  • « Swoole\Async::readFile
  • Swoole\Async::write »
  • PHP Manual
  • Swoole\Async
  • Update the async I/O options.

Swoole\Async::set

(PECL swoole >= 1.9.0)

Swoole\Async::set — Update the async I/O options.

Descripción

public static Swoole\Async::set ( array $settings ) : void

Parámetros

settings


Write data to a file stream asynchronously.

  • « Swoole\Async::set
  • Swoole\Async::writeFile »
  • PHP Manual
  • Swoole\Async
  • Write data to a file stream asynchronously.

Swoole\Async::write

(PECL swoole >= 1.9.0)

Swoole\Async::write — Write data to a file stream asynchronously.

Descripción

public static Swoole\Async::write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : void

Parámetros

filename

The filename being written.

content

The content writing to the file.

offset

The offset.

callback


Description

  • « Swoole\Async::write
  • Swoole\Atomic »
  • PHP Manual
  • Swoole\Async
  • Description

Swoole\Async::writeFile

(PECL swoole >= 1.9.0)

Swoole\Async::writeFile — Description

Descripción

public static Swoole\Async::writeFile ( string $filename , string $content , callable $callback = ? , string $flags = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

filename

The filename being written.

content

The content writing to the file.

callback

flags


The Swoole\Atomic class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Atomic {
/* Métodos */
public add ( int $add_value = ? ) : int
public cmpset ( int $cmp_value , int $new_value ) : int
public get ( ) : int
public set ( int $value ) : int
public sub ( int $sub_value = ? ) : int
}

Tabla de contenidos

  • Swoole\Atomic::add — Add a number to the value to the atomic object.
  • Swoole\Atomic::cmpset — Compare and set the value of the atomic object.
  • Swoole\Atomic::__construct — Construct a swoole atomic object.
  • Swoole\Atomic::get — Get the current value of the atomic object.
  • Swoole\Atomic::set — Set a new value to the atomic object.
  • Swoole\Atomic::sub — Subtract a number to the value of the atomic object.


Add a number to the value to the atomic object.

  • « Swoole\Atomic
  • Swoole\Atomic::cmpset »
  • PHP Manual
  • Swoole\Atomic
  • Add a number to the value to the atomic object.

Swoole\Atomic::add

(PECL swoole >= 1.9.0)

Swoole\Atomic::add — Add a number to the value to the atomic object.

Descripción

public Swoole\Atomic::add ( int $add_value = ? ) : int

Add a number to the value to the atomic object.

Parámetros

add_value

The value which will be added to the current value.

Valores devueltos

The new value of the atomic object.


Compare and set the value of the atomic object.

  • « Swoole\Atomic::add
  • Swoole\Atomic::__construct »
  • PHP Manual
  • Swoole\Atomic
  • Compare and set the value of the atomic object.

Swoole\Atomic::cmpset

(PECL swoole >= 1.9.0)

Swoole\Atomic::cmpset — Compare and set the value of the atomic object.

Descripción

public Swoole\Atomic::cmpset ( int $cmp_value , int $new_value ) : int

Parámetros

cmp_value

The value to compare with the current value of the atomic object.

new_value

The value to set to the atomic object if the cmp_value is the same as the current value of the atomic object.

Valores devueltos

The new value of the atomic object.


Construct a swoole atomic object.

  • « Swoole\Atomic::cmpset
  • Swoole\Atomic::get »
  • PHP Manual
  • Swoole\Atomic
  • Construct a swoole atomic object.

Swoole\Atomic::__construct

(PECL swoole >= 1.9.0)

Swoole\Atomic::__construct — Construct a swoole atomic object.

Descripción

public Swoole\Atomic::__construct ( int $value = ? )

Swoole atomic object is a integer variable allows any processor to atomically test and modify. It is implemented based on CPU atomic instructions. The Swoole atomic variables have to defined before swoole_server->start.

Compare-and-swap (CAS) is an atomic instruction used in multithreading to achieve synchronization. It compares the content of a memory location with a given value and, only if they are the same, modifies the content of that memory location to a new given value.

Parámetros

value

The value of the atomic object.


Get the current value of the atomic object.

  • « Swoole\Atomic::__construct
  • Swoole\Atomic::set »
  • PHP Manual
  • Swoole\Atomic
  • Get the current value of the atomic object.

Swoole\Atomic::get

(PECL swoole >= 1.9.0)

Swoole\Atomic::get — Get the current value of the atomic object.

Descripción

public Swoole\Atomic::get ( ) : int

Get the current value of the atomic object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current value of the atomic object.


Set a new value to the atomic object.

  • « Swoole\Atomic::get
  • Swoole\Atomic::sub »
  • PHP Manual
  • Swoole\Atomic
  • Set a new value to the atomic object.

Swoole\Atomic::set

(PECL swoole >= 1.9.0)

Swoole\Atomic::set — Set a new value to the atomic object.

Descripción

public Swoole\Atomic::set ( int $value ) : int

Set a new value to the atomic object.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

value

The value to set to the atomic object.

Valores devueltos

The current value of the atomic object.


Subtract a number to the value of the atomic object.

  • « Swoole\Atomic::set
  • Swoole\Buffer »
  • PHP Manual
  • Swoole\Atomic
  • Subtract a number to the value of the atomic object.

Swoole\Atomic::sub

(PECL swoole >= 1.9.0)

Swoole\Atomic::sub — Subtract a number to the value of the atomic object.

Descripción

public Swoole\Atomic::sub ( int $sub_value = ? ) : int

Subtract a number to the value of the atomic object.

Parámetros

sub_value

The value which will be subtracted to the current value.

Valores devueltos

The current value of the atomic object.


The Swoole\Buffer class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Buffer {
/* Métodos */
public append ( string $data ) : int
public clear ( ) : void
public __destruct ( ) : void
public expand ( int $size ) : int
public read ( int $offset , int $length ) : string
public recycle ( ) : void
public substr ( int $offset , int $length = ? , bool $remove = ? ) : string
public __toString ( ) : string
public write ( int $offset , string $data ) : void
}

Tabla de contenidos

  • Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
  • Swoole\Buffer::clear — Reset the memory buffer.
  • Swoole\Buffer::__construct — Fixed size memory blocks allocation.
  • Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.
  • Swoole\Buffer::expand — Expand the size of memory buffer.
  • Swoole\Buffer::read — Read data from the memory buffer based on offset and length.
  • Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.
  • Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
  • Swoole\Buffer::__toString — Get the string value of the memory buffer.
  • Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.


Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

  • « Swoole\Buffer
  • Swoole\Buffer::clear »
  • PHP Manual
  • Swoole\Buffer
  • Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

Swoole\Buffer::append

(PECL swoole >= 1.9.0)

Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

Descripción

public Swoole\Buffer::append ( string $data ) : int

Parámetros

data

The string or binary data to append at the end of the memory buffer.

Valores devueltos

The new size of the memory buffer.


Reset the memory buffer.

  • « Swoole\Buffer::append
  • Swoole\Buffer::__construct »
  • PHP Manual
  • Swoole\Buffer
  • Reset the memory buffer.

Swoole\Buffer::clear

(PECL swoole >= 1.9.0)

Swoole\Buffer::clear — Reset the memory buffer.

Descripción

public Swoole\Buffer::clear ( ) : void

Parámetros

Esta función no tiene parámetros.


Fixed size memory blocks allocation.

  • « Swoole\Buffer::clear
  • Swoole\Buffer::__destruct »
  • PHP Manual
  • Swoole\Buffer
  • Fixed size memory blocks allocation.

Swoole\Buffer::__construct

(PECL swoole >= 1.9.0)

Swoole\Buffer::__construct — Fixed size memory blocks allocation.

Descripción

public Swoole\Buffer::__construct ( int $size = ? )

Parámetros

size

The size of the memory to allocate.


Destruct the Swoole memory buffer.

  • « Swoole\Buffer::__construct
  • Swoole\Buffer::expand »
  • PHP Manual
  • Swoole\Buffer
  • Destruct the Swoole memory buffer.

Swoole\Buffer::__destruct

(PECL swoole >= 1.9.0)

Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.

Descripción

public Swoole\Buffer::__destruct ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


Expand the size of memory buffer.

  • « Swoole\Buffer::__destruct
  • Swoole\Buffer::read »
  • PHP Manual
  • Swoole\Buffer
  • Expand the size of memory buffer.

Swoole\Buffer::expand

(PECL swoole >= 1.9.0)

Swoole\Buffer::expand — Expand the size of memory buffer.

Descripción

public Swoole\Buffer::expand ( int $size ) : int

Parámetros

size

The new size of the memory buffer.

Valores devueltos

The new size of the memory buffer.


Read data from the memory buffer based on offset and length.

  • « Swoole\Buffer::expand
  • Swoole\Buffer::recycle »
  • PHP Manual
  • Swoole\Buffer
  • Read data from the memory buffer based on offset and length.

Swoole\Buffer::read

(PECL swoole >= 1.9.0)

Swoole\Buffer::read — Read data from the memory buffer based on offset and length.

Descripción

public Swoole\Buffer::read ( int $offset , int $length ) : string

Parámetros

offset

The offset.

length

The length.

Valores devueltos

The data readed from the memory buffer.


Release the memory to OS which is not used by the memory buffer.

  • « Swoole\Buffer::read
  • Swoole\Buffer::substr »
  • PHP Manual
  • Swoole\Buffer
  • Release the memory to OS which is not used by the memory buffer.

Swoole\Buffer::recycle

(PECL swoole >= 1.9.0)

Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.

Descripción

public Swoole\Buffer::recycle ( ) : void

Parámetros

Esta función no tiene parámetros.


Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

  • « Swoole\Buffer::recycle
  • Swoole\Buffer::__toString »
  • PHP Manual
  • Swoole\Buffer
  • Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

Swoole\Buffer::substr

(PECL swoole >= 1.9.0)

Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

Descripción

public Swoole\Buffer::substr ( int $offset , int $length = ? , bool $remove = ? ) : string

If $remove is set to be true and $offset is set to be 0, the data will be removed from the buffer. The memory for storing the data will be released when the buffer object is deconstructed.

Parámetros

offset

The offset.

length

The length.

remove

Whether to remove the data from the memory buffer.

Valores devueltos

The data or string readed from the memory buffer.


Get the string value of the memory buffer.

  • « Swoole\Buffer::substr
  • Swoole\Buffer::write »
  • PHP Manual
  • Swoole\Buffer
  • Get the string value of the memory buffer.

Swoole\Buffer::__toString

(PECL swoole >= 1.9.0)

Swoole\Buffer::__toString — Get the string value of the memory buffer.

Descripción

public Swoole\Buffer::__toString ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The string value of the memory buffer.


Write data to the memory buffer. The memory allocated for the buffer will not be changed.

  • « Swoole\Buffer::__toString
  • Swoole\Channel »
  • PHP Manual
  • Swoole\Buffer
  • Write data to the memory buffer. The memory allocated for the buffer will not be changed.

Swoole\Buffer::write

(PECL swoole >= 1.9.0)

Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.

Descripción

public Swoole\Buffer::write ( int $offset , string $data ) : void

Parámetros

offset

The offset.

data

The data to write to the memory buffer.

Valores devueltos


The Swoole\Channel class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Channel {
/* Métodos */
public __destruct ( ) : void
public pop ( ) : mixed
public push ( string $data ) : bool
public stats ( ) : array
}

Tabla de contenidos

  • Swoole\Channel::__construct — Construct a Swoole Channel
  • Swoole\Channel::__destruct — Destruct a Swoole channel.
  • Swoole\Channel::pop — Read and pop data from swoole channel.
  • Swoole\Channel::push — Write and push data into Swoole channel.
  • Swoole\Channel::stats — Get stats of swoole channel.


Construct a Swoole Channel

  • « Swoole\Channel
  • Swoole\Channel::__destruct »
  • PHP Manual
  • Swoole\Channel
  • Construct a Swoole Channel

Swoole\Channel::__construct

(PECL swoole >= 1.9.0)

Swoole\Channel::__construct — Construct a Swoole Channel

Descripción

public Swoole\Channel::__construct ( string $size )

Swoole channel is memory data structure works like Chan in Golang, implemented based on shared memory and mutex locks. It can be used as high performance message queue in memory. Construct a swoole channel with a fixed size. The minimum size of a swoole channel is 64KB. Exceptions will be thrown if there is not enough memory.

Parámetros

size

The size of the Swoole channel.


Destruct a Swoole channel.

  • « Swoole\Channel::__construct
  • Swoole\Channel::pop »
  • PHP Manual
  • Swoole\Channel
  • Destruct a Swoole channel.

Swoole\Channel::__destruct

(PECL swoole >= 1.9.0)

Swoole\Channel::__destruct — Destruct a Swoole channel.

Descripción

public Swoole\Channel::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.


Read and pop data from swoole channel.

  • « Swoole\Channel::__destruct
  • Swoole\Channel::push »
  • PHP Manual
  • Swoole\Channel
  • Read and pop data from swoole channel.

Swoole\Channel::pop

(PECL swoole >= 1.9.0)

Swoole\Channel::pop — Read and pop data from swoole channel.

Descripción

public Swoole\Channel::pop ( ) : mixed

Parámetros

Esta función no tiene parámetros.

Valores devueltos

If the channel is empty, the function will return false, or return the unserialized data.


Write and push data into Swoole channel.

  • « Swoole\Channel::pop
  • Swoole\Channel::stats »
  • PHP Manual
  • Swoole\Channel
  • Write and push data into Swoole channel.

Swoole\Channel::push

(PECL swoole >= 1.9.0)

Swoole\Channel::push — Write and push data into Swoole channel.

Descripción

public Swoole\Channel::push ( string $data ) : bool

Data can be any non-empty PHP variable, the variable will be serialized if it is not string type.

If size of the data is more than 8KB, swoole channel will use temp files storage.

The function will return true if the write operation is succeeded, or return false if there is not enough space.

Parámetros

data

The data to push into the Swoole channel.

Valores devueltos

Wheter the data is pushed into he Swoole channel.


Get stats of swoole channel.

  • « Swoole\Channel::push
  • Swoole\Client »
  • PHP Manual
  • Swoole\Channel
  • Get stats of swoole channel.

Swoole\Channel::stats

(PECL swoole >= 1.9.0)

Swoole\Channel::stats — Get stats of swoole channel.

Descripción

public Swoole\Channel::stats ( ) : array

Get the numbers of queued elements and total size of the memory used by the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The stats of the Swoole channel.


The Swoole\Client class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Client {
/* Constants */
const int MSG_OOB = 1 ;
const int MSG_PEEK = 2 ;
const int MSG_DONTWAIT = 128 ;
const int MSG_WAITALL = 64 ;
/* Propiedades */
public $errCode ;
public $sock ;
public $reuse ;
public $reuseCount ;
/* Métodos */
public close ( bool $force = ? ) : bool
public connect ( string $host , int $port = ? , int $timeout = ? , int $flag = ? ) : bool
public __destruct ( ) : void
public getpeername ( ) : array
public getsockname ( ) : array
public isConnected ( ) : bool
public on ( string $event , callable $callback ) : void
public pause ( ) : void
public pipe ( string $socket ) : void
public recv ( string $size = ? , string $flag = ? ) : void
public resume ( ) : void
public send ( string $data , string $flag = ? ) : int
public sendfile ( string $filename , int $offset = ? ) : bool
public sendto ( string $ip , int $port , string $data ) : bool
public set ( array $settings ) : void
public sleep ( ) : void
public wakeup ( ) : void
}

Propiedades

errCode

sock

reuse

reuseCount

Constantes predefinidas

Swoole\Client::MSG_OOB

Swoole\Client::MSG_PEEK

Swoole\Client::MSG_DONTWAIT

Swoole\Client::MSG_WAITALL

Tabla de contenidos

  • Swoole\Client::close — Close the connection established.
  • Swoole\Client::connect — Connect to the remote TCP or UDP port.
  • Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.
  • Swoole\Client::__destruct — Destruct the Swoole client.
  • Swoole\Client::getpeername — Get the remote socket name of the connection.
  • Swoole\Client::getsockname — Get the local socket name of the connection.
  • Swoole\Client::isConnected — Check if the connection is established.
  • Swoole\Client::on — Add callback functions triggered by events.
  • Swoole\Client::pause — Pause receiving data.
  • Swoole\Client::pipe — Redirect the data to another file descriptor.
  • Swoole\Client::recv — Receive data from the remote socket.
  • Swoole\Client::resume — Resume receiving data.
  • Swoole\Client::send — Send data to the remote TCP socket.
  • Swoole\Client::sendfile — Send file to the remote TCP socket.
  • Swoole\Client::sendto — Send data to the remote UDP address.
  • Swoole\Client::set — Set the Swoole client parameters before the connection is established.
  • Swoole\Client::sleep — Remove the TCP client from system event loop.
  • Swoole\Client::wakeup — Add the TCP client back into the system event loop.


Close the connection established.

  • « Swoole\Client
  • Swoole\Client::connect »
  • PHP Manual
  • Swoole\Client
  • Close the connection established.

Swoole\Client::close

(PECL swoole >= 1.9.0)

Swoole\Client::close — Close the connection established.

Descripción

public Swoole\Client::close ( bool $force = ? ) : bool

Parámetros

force

Whether force to close the connection.

Valores devueltos

Whether the connection is closed.


Connect to the remote TCP or UDP port.

  • « Swoole\Client::close
  • Swoole\Client::__construct »
  • PHP Manual
  • Swoole\Client
  • Connect to the remote TCP or UDP port.

Swoole\Client::connect

(PECL swoole >= 1.9.0)

Swoole\Client::connect — Connect to the remote TCP or UDP port.

Descripción

public Swoole\Client::connect ( string $host , int $port = ? , int $timeout = ? , int $flag = ? ) : bool

Parámetros

host

The host name of the remote address.

port

The port number of the remote address.

timeout

The timeout(second) of connect/send/recv, the dafault value is 0.1s

flag

If the type of client is UDP, the $flag means if to enable the configuration udp_connect. If the configuration udp_connect is enabled, the client will only receive the data from specified ip:port. If the type of client is TCP and the $flag is set to 1, it must use swoole_client_select to check the connection status before send/recv.

Valores devueltos

Whether the connection is established.


Create Swoole sync or async TCP/UDP client, with or without SSL.

  • « Swoole\Client::connect
  • Swoole\Client::__destruct »
  • PHP Manual
  • Swoole\Client
  • Create Swoole sync or async TCP/UDP client, with or without SSL.

Swoole\Client::__construct

(PECL swoole >= 1.9.0)

Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.

Descripción

public Swoole\Client::__construct ( int $sock_type , int $is_async = ? )

Parámetros

sock_type

The type of socket: SWOOLE_TCP, SWOOLE_UDP, SWOOLE_ASYNC, SWOOLE_SSL, SWOOLE_KEEP.

is_async

Synchronous or asynchronous client.


Destruct the Swoole client.

  • « Swoole\Client::__construct
  • Swoole\Client::getpeername »
  • PHP Manual
  • Swoole\Client
  • Destruct the Swoole client.

Swoole\Client::__destruct

(PECL swoole >= 1.9.0)

Swoole\Client::__destruct — Destruct the Swoole client.

Descripción

public Swoole\Client::__destruct ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


Get the remote socket name of the connection.

  • « Swoole\Client::__destruct
  • Swoole\Client::getsockname »
  • PHP Manual
  • Swoole\Client
  • Get the remote socket name of the connection.

Swoole\Client::getpeername

(PECL swoole >= 1.9.0)

Swoole\Client::getpeername — Get the remote socket name of the connection.

Descripción

public Swoole\Client::getpeername ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The host and port of the remote socket.


Get the local socket name of the connection.

  • « Swoole\Client::getpeername
  • Swoole\Client::isConnected »
  • PHP Manual
  • Swoole\Client
  • Get the local socket name of the connection.

Swoole\Client::getsockname

(PECL swoole >= 1.9.0)

Swoole\Client::getsockname — Get the local socket name of the connection.

Descripción

public Swoole\Client::getsockname ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The host and port of the local socket.


Check if the connection is established.

  • « Swoole\Client::getsockname
  • Swoole\Client::on »
  • PHP Manual
  • Swoole\Client
  • Check if the connection is established.

Swoole\Client::isConnected

(PECL swoole >= 1.9.0)

Swoole\Client::isConnected — Check if the connection is established.

Descripción

public Swoole\Client::isConnected ( ) : bool

This method returns the connection status of application layer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Whether the connection is established.


Add callback functions triggered by events.

  • « Swoole\Client::isConnected
  • Swoole\Client::pause »
  • PHP Manual
  • Swoole\Client
  • Add callback functions triggered by events.

Swoole\Client::on

(PECL swoole >= 1.9.0)

Swoole\Client::on — Add callback functions triggered by events.

Descripción

public Swoole\Client::on ( string $event , callable $callback ) : void

Parámetros

event

callback


Pause receiving data.

  • « Swoole\Client::on
  • Swoole\Client::pipe »
  • PHP Manual
  • Swoole\Client
  • Pause receiving data.

Swoole\Client::pause

(PECL swoole >= 1.9.0)

Swoole\Client::pause — Pause receiving data.

Descripción

public Swoole\Client::pause ( ) : void

Parámetros

Esta función no tiene parámetros.


Redirect the data to another file descriptor.

  • « Swoole\Client::pause
  • Swoole\Client::recv »
  • PHP Manual
  • Swoole\Client
  • Redirect the data to another file descriptor.

Swoole\Client::pipe

(PECL swoole >= 1.9.0)

Swoole\Client::pipe — Redirect the data to another file descriptor.

Descripción

public Swoole\Client::pipe ( string $socket ) : void

Parámetros

socket


Receive data from the remote socket.

  • « Swoole\Client::pipe
  • Swoole\Client::resume »
  • PHP Manual
  • Swoole\Client
  • Receive data from the remote socket.

Swoole\Client::recv

(PECL swoole >= 1.9.0)

Swoole\Client::recv — Receive data from the remote socket.

Descripción

public Swoole\Client::recv ( string $size = ? , string $flag = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

size

flag

Valores devueltos


Resume receiving data.

  • « Swoole\Client::recv
  • Swoole\Client::send »
  • PHP Manual
  • Swoole\Client
  • Resume receiving data.

Swoole\Client::resume

(PECL swoole >= 1.9.0)

Swoole\Client::resume — Resume receiving data.

Descripción

public Swoole\Client::resume ( ) : void

Parámetros

Esta función no tiene parámetros.


Send data to the remote TCP socket.

  • « Swoole\Client::resume
  • Swoole\Client::sendfile »
  • PHP Manual
  • Swoole\Client
  • Send data to the remote TCP socket.

Swoole\Client::send

(PECL swoole >= 1.9.0)

Swoole\Client::send — Send data to the remote TCP socket.

Descripción

public Swoole\Client::send ( string $data , string $flag = ? ) : int

Parámetros

data

The data to send which can be string or binary

flag

Valores devueltos

If the client sends data successfully, it returns the length of data sent. Or it returns false and sets $swoole_client->errCode. For sync client, there is no limit for the data to send. For async client, The limit for the data to send is socket_buffer_size.


Send file to the remote TCP socket.

  • « Swoole\Client::send
  • Swoole\Client::sendto »
  • PHP Manual
  • Swoole\Client
  • Send file to the remote TCP socket.

Swoole\Client::sendfile

(PECL swoole >= 1.9.0)

Swoole\Client::sendfile — Send file to the remote TCP socket.

Descripción

public Swoole\Client::sendfile ( string $filename , int $offset = ? ) : bool

This is a wrapper of the Linux sendfile system call.

Parámetros

filename

File path of the file to send.

offset

Offset of the file to send

Valores devueltos


Send data to the remote UDP address.

  • « Swoole\Client::sendfile
  • Swoole\Client::set »
  • PHP Manual
  • Swoole\Client
  • Send data to the remote UDP address.

Swoole\Client::sendto

(PECL swoole >= 1.9.0)

Swoole\Client::sendto — Send data to the remote UDP address.

Descripción

public Swoole\Client::sendto ( string $ip , int $port , string $data ) : bool

The swoole client should be type of SWOOLE_SOCK_UDP or SWOOLE_SOCK_UDP6.

Parámetros

ip

The IP address of remote host, IPv4 or IPv6.

port

The port number of remote host.

data

The data to send which should be less-than 64K.

Valores devueltos


Set the Swoole client parameters before the connection is established.

  • « Swoole\Client::sendto
  • Swoole\Client::sleep »
  • PHP Manual
  • Swoole\Client
  • Set the Swoole client parameters before the connection is established.

Swoole\Client::set

(PECL swoole >= 1.9.0)

Swoole\Client::set — Set the Swoole client parameters before the connection is established.

Descripción

public Swoole\Client::set ( array $settings ) : void

Parámetros

settings

Valores devueltos


Remove the TCP client from system event loop.

  • « Swoole\Client::set
  • Swoole\Client::wakeup »
  • PHP Manual
  • Swoole\Client
  • Remove the TCP client from system event loop.

Swoole\Client::sleep

(PECL swoole >= 1.9.0)

Swoole\Client::sleep — Remove the TCP client from system event loop.

Descripción

public Swoole\Client::sleep ( ) : void

Remove the TCP client from system event loop.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Add the TCP client back into the system event loop.

  • « Swoole\Client::sleep
  • Swoole\Connection\Iterator »
  • PHP Manual
  • Swoole\Client
  • Add the TCP client back into the system event loop.

Swoole\Client::wakeup

(PECL swoole >= 1.9.0)

Swoole\Client::wakeup — Add the TCP client back into the system event loop.

Descripción

public Swoole\Client::wakeup ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Connection\Iterator class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Connection\Iterator implements Iterator , Countable , ArrayAccess {
/* Métodos */
public count ( ) : int
public current ( ) : Connection
public key ( ) : int
public next ( ) : Connection
public offsetExists ( int $index ) : bool
public offsetGet ( string $index ) : Connection
public offsetSet ( int $offset , mixed $connection ) : void
public offsetUnset ( int $offset ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Tabla de contenidos

  • Swoole\Connection\Iterator::count — Count connections.
  • Swoole\Connection\Iterator::current — Return current connection entry.
  • Swoole\Connection\Iterator::key — Return key of the current connection.
  • Swoole\Connection\Iterator::next — Move to the next connection.
  • Swoole\Connection\Iterator::offsetExists — Check if offet exists.
  • Swoole\Connection\Iterator::offsetGet — Offset to retrieve.
  • Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.
  • Swoole\Connection\Iterator::offsetUnset — Unset an offset.
  • Swoole\Connection\Iterator::rewind — Rewinds iterator
  • Swoole\Connection\Iterator::valid — Check if current position is valid.


Count connections.

  • « Swoole\Connection\Iterator
  • Swoole\Connection\Iterator::current »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Count connections.

Swoole\Connection\Iterator::count

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::count — Count connections.

Descripción

public Swoole\Connection\Iterator::count ( ) : int

Gets the number of connections.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The number of connections.


Return current connection entry.

  • « Swoole\Connection\Iterator::count
  • Swoole\Connection\Iterator::key »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Return current connection entry.

Swoole\Connection\Iterator::current

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::current — Return current connection entry.

Descripción

public Swoole\Connection\Iterator::current ( ) : Connection

Get current connection entry.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current connection entry.


Return key of the current connection.

  • « Swoole\Connection\Iterator::current
  • Swoole\Connection\Iterator::next »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Return key of the current connection.

Swoole\Connection\Iterator::key

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::key — Return key of the current connection.

Descripción

public Swoole\Connection\Iterator::key ( ) : int

This function returns key of the current connection.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Key of the current connection.


Move to the next connection.

  • « Swoole\Connection\Iterator::key
  • Swoole\Connection\Iterator::offsetExists »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Move to the next connection.

Swoole\Connection\Iterator::next

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::next — Move to the next connection.

Descripción

public Swoole\Connection\Iterator::next ( ) : Connection

The iterator to the next connection.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Check if offet exists.

  • « Swoole\Connection\Iterator::next
  • Swoole\Connection\Iterator::offsetGet »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Check if offet exists.

Swoole\Connection\Iterator::offsetExists

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetExists — Check if offet exists.

Descripción

public Swoole\Connection\Iterator::offsetExists ( int $index ) : bool

Check if offset exists.

Parámetros

index

The offset being checked.

Valores devueltos

Returns TRUE if the offset exists, otherwise FALSE.


Offset to retrieve.

  • « Swoole\Connection\Iterator::offsetExists
  • Swoole\Connection\Iterator::offsetSet »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Offset to retrieve.

Swoole\Connection\Iterator::offsetGet

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetGet — Offset to retrieve.

Descripción

public Swoole\Connection\Iterator::offsetGet ( string $index ) : Connection

Return the connection at specified offset.

Parámetros

index

The offset to retrieve.

Valores devueltos


Assign a Connection to the specified offset.

  • « Swoole\Connection\Iterator::offsetGet
  • Swoole\Connection\Iterator::offsetUnset »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Assign a Connection to the specified offset.

Swoole\Connection\Iterator::offsetSet

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.

Descripción

public Swoole\Connection\Iterator::offsetSet ( int $offset , mixed $connection ) : void

Assign a Connection to the specified offset.

Parámetros

offset

The offset to assign the Connection to.

connection

The connection to set.

Valores devueltos


Unset an offset.

  • « Swoole\Connection\Iterator::offsetSet
  • Swoole\Connection\Iterator::rewind »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Unset an offset.

Swoole\Connection\Iterator::offsetUnset

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetUnset — Unset an offset.

Descripción

public Swoole\Connection\Iterator::offsetUnset ( int $offset ) : void

Unsets an offset.

Parámetros

offset

The offset to unset.

Valores devueltos


Rewinds iterator

  • « Swoole\Connection\Iterator::offsetUnset
  • Swoole\Connection\Iterator::valid »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Rewinds iterator

Swoole\Connection\Iterator::rewind

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::rewind — Rewinds iterator

Descripción

public Swoole\Connection\Iterator::rewind ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Check if current position is valid.

  • « Swoole\Connection\Iterator::rewind
  • Swoole\Coroutine »
  • PHP Manual
  • Swoole\Connection\Iterator
  • Check if current position is valid.

Swoole\Connection\Iterator::valid

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::valid — Check if current position is valid.

Descripción

public Swoole\Connection\Iterator::valid ( ) : bool

Checks if the current position is valid.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns TRUE if the current iterator position is valid, otherwise FALSE.


The Swoole\Coroutine class

(PECL swoole >= 2.0.0)

Introducción

Sinopsis de la Clase

Swoole\Coroutine {
/* Métodos */
public static call_user_func_array ( callable $callback , array $param_array ) : mixed
public static call_user_func ( callable $callback , mixed ...$args ) : mixed
public static cli_wait ( ) : ReturnType
public static create ( ) : ReturnType
public Swoole\Coroutine\Client::close ( ) : ReturnType
public Swoole\Coroutine\Client::connect ( ) : ReturnType
public Swoole\Coroutine\Client::__destruct ( ) : ReturnType
public Swoole\Coroutine\Client::getpeername ( ) : ReturnType
public Swoole\Coroutine\Client::getsockname ( ) : ReturnType
public Swoole\Coroutine\Client::isConnected ( ) : ReturnType
public Swoole\Coroutine\Client::recv ( ) : ReturnType
public Swoole\Coroutine\Client::send ( ) : ReturnType
public Swoole\Coroutine\Client::sendfile ( ) : ReturnType
public Swoole\Coroutine\Client::sendto ( ) : ReturnType
public Swoole\Coroutine\Client::set ( ) : ReturnType
public Swoole\Coroutine\Http\Client::addFile ( ) : ReturnType
public Swoole\Coroutine\Http\Client::close ( ) : ReturnType
public Swoole\Coroutine\Http\Client::__destruct ( ) : ReturnType
public Swoole\Coroutine\Http\Client::execute ( ) : ReturnType
public Swoole\Coroutine\Http\Client::get ( ) : ReturnType
public Swoole\Coroutine\Http\Client::getDefer ( ) : ReturnType
public Swoole\Coroutine\Http\Client::isConnected ( ) : ReturnType
public Swoole\Coroutine\Http\Client::post ( ) : ReturnType
public Swoole\Coroutine\Http\Client::recv ( ) : ReturnType
public Swoole\Coroutine\Http\Client::set ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setCookies ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setData ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setDefer ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setHeaders ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setMethod ( ) : ReturnType
public Swoole\Coroutine\MySQL::close ( ) : ReturnType
public Swoole\Coroutine\MySQL::connect ( ) : ReturnType
public Swoole\Coroutine\MySQL::__destruct ( ) : ReturnType
public Swoole\Coroutine\MySQL::getDefer ( ) : ReturnType
public Swoole\Coroutine\MySQL::query ( ) : ReturnType
public Swoole\Coroutine\MySQL::recv ( ) : ReturnType
public Swoole\Coroutine\MySQL::setDefer ( ) : ReturnType
public static getuid ( ) : ReturnType
public static resume ( ) : ReturnType
public static suspend ( ) : ReturnType
}

Tabla de contenidos

  • Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters
  • Swoole\Coroutine::call_user_func — Call a callback given by the first parameter
  • Swoole\Coroutine::cli_wait — Description
  • Swoole\Coroutine::create — Description
  • Swoole\Coroutine\Client::close — Description
  • Swoole\Coroutine\Client::connect — Description
  • Swoole\Coroutine\Client::__construct — Description
  • Swoole\Coroutine\Client::__destruct — Description
  • Swoole\Coroutine\Client::getpeername — Description
  • Swoole\Coroutine\Client::getsockname — Description
  • Swoole\Coroutine\Client::isConnected — Description
  • Swoole\Coroutine\Client::recv — Description
  • Swoole\Coroutine\Client::send — Description
  • Swoole\Coroutine\Client::sendfile — Description
  • Swoole\Coroutine\Client::sendto — Description
  • Swoole\Coroutine\Client::set — Description
  • Swoole\Coroutine\Http\Client::addFile — Description
  • Swoole\Coroutine\Http\Client::close — Description
  • Swoole\Coroutine\Http\Client::__construct — Description
  • Swoole\Coroutine\Http\Client::__destruct — Description
  • Swoole\Coroutine\Http\Client::execute — Description
  • Swoole\Coroutine\Http\Client::get — Description
  • Swoole\Coroutine\Http\Client::getDefer — Description
  • Swoole\Coroutine\Http\Client::isConnected — Description
  • Swoole\Coroutine\Http\Client::post — Description
  • Swoole\Coroutine\Http\Client::recv — Description
  • Swoole\Coroutine\Http\Client::set — Description
  • Swoole\Coroutine\Http\Client::setCookies — Description
  • Swoole\Coroutine\Http\Client::setData — Description
  • Swoole\Coroutine\Http\Client::setDefer — Description
  • Swoole\Coroutine\Http\Client::setHeaders — Description
  • Swoole\Coroutine\Http\Client::setMethod — Description
  • Swoole\Coroutine\MySQL::close — Description
  • Swoole\Coroutine\MySQL::connect — Description
  • Swoole\Coroutine\MySQL::__construct — Description
  • Swoole\Coroutine\MySQL::__destruct — Description
  • Swoole\Coroutine\MySQL::getDefer — Description
  • Swoole\Coroutine\MySQL::query — Description
  • Swoole\Coroutine\MySQL::recv — Description
  • Swoole\Coroutine\MySQL::setDefer — Description
  • Swoole\Coroutine::getuid — Description
  • Swoole\Coroutine::resume — Description
  • Swoole\Coroutine::suspend — Description


Call a callback with an array of parameters

  • « Swoole\Coroutine
  • Swoole\Coroutine::call_user_func »
  • PHP Manual
  • Swoole\Coroutine
  • Call a callback with an array of parameters

Swoole\Coroutine::call_user_func_array

(PECL swoole >= 2.0.0)

Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters

Descripción

public static Swoole\Coroutine::call_user_func_array ( callable $callback , array $param_array ) : mixed

Calls the callback given by the first parameter with the parameters in param_array.

Parámetros

callback

The callable to be called.

param_array

Zero or more parameters in the array to be passed to the callback.

Valores devueltos


Call a callback given by the first parameter

  • « Swoole\Coroutine::call_user_func_array
  • Swoole\Coroutine::cli_wait »
  • PHP Manual
  • Swoole\Coroutine
  • Call a callback given by the first parameter

Swoole\Coroutine::call_user_func

(PECL swoole >= 2.0.0)

Swoole\Coroutine::call_user_func — Call a callback given by the first parameter

Descripción

public static Swoole\Coroutine::call_user_func ( callable $callback , mixed ...$args ) : mixed

Calls the callback given by the first parameter and passes the remaining parameters as arguments.

Parámetros

callback

The callable to be called.

args

Zero or more parameters to be passed to the callback.

Valores devueltos


Description

  • « Swoole\Coroutine::call_user_func
  • Swoole\Coroutine::create »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::cli_wait

(PECL swoole >= 2.0.0)

Swoole\Coroutine::cli_wait — Description

Descripción

public static Swoole\Coroutine::cli_wait ( ) : ReturnType

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine::cli_wait
  • Swoole\Coroutine\Client::close »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::create

(PECL swoole >= 2.0.0)

Swoole\Coroutine::create — Description

Descripción

public static Swoole\Coroutine::create ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine::create
  • Swoole\Coroutine\Client::connect »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::close — Description

Descripción

public Swoole\Coroutine\Client::close ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::close
  • Swoole\Coroutine\Client::__construct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::connect

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::connect — Description

Descripción

public Swoole\Coroutine\Client::connect ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::connect
  • Swoole\Coroutine\Client::__destruct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::__construct — Description

Descripción

public Swoole\Coroutine\Client::__construct ( )

Parámetros

Esta función no tiene parámetros.


Description

  • « Swoole\Coroutine\Client::__construct
  • Swoole\Coroutine\Client::getpeername »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::__destruct — Description

Descripción

public Swoole\Coroutine\Client::__destruct ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::__destruct
  • Swoole\Coroutine\Client::getsockname »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::getpeername

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::getpeername — Description

Descripción

public Swoole\Coroutine\Client::getpeername ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::getpeername
  • Swoole\Coroutine\Client::isConnected »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::getsockname

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::getsockname — Description

Descripción

public Swoole\Coroutine\Client::getsockname ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::getsockname
  • Swoole\Coroutine\Client::recv »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::isConnected

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::isConnected — Description

Descripción

public Swoole\Coroutine\Client::isConnected ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::isConnected
  • Swoole\Coroutine\Client::send »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::recv — Description

Descripción

public Swoole\Coroutine\Client::recv ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::recv
  • Swoole\Coroutine\Client::sendfile »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::send

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::send — Description

Descripción

public Swoole\Coroutine\Client::send ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::send
  • Swoole\Coroutine\Client::sendto »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::sendfile

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::sendfile — Description

Descripción

public Swoole\Coroutine\Client::sendfile ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::sendfile
  • Swoole\Coroutine\Client::set »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::sendto

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::sendto — Description

Descripción

public Swoole\Coroutine\Client::sendto ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::sendto
  • Swoole\Coroutine\Http\Client::addFile »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::set

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::set — Description

Descripción

public Swoole\Coroutine\Client::set ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Client::set
  • Swoole\Coroutine\Http\Client::close »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::addFile

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::addFile — Description

Descripción

public Swoole\Coroutine\Http\Client::addFile ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::addFile
  • Swoole\Coroutine\Http\Client::__construct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::close — Description

Descripción

public Swoole\Coroutine\Http\Client::close ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::close
  • Swoole\Coroutine\Http\Client::__destruct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::__construct — Description

Descripción

public Swoole\Coroutine\Http\Client::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


Description

  • « Swoole\Coroutine\Http\Client::__construct
  • Swoole\Coroutine\Http\Client::execute »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::__destruct — Description

Descripción

public Swoole\Coroutine\Http\Client::__destruct ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::__destruct
  • Swoole\Coroutine\Http\Client::get »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::execute

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::execute — Description

Descripción

public Swoole\Coroutine\Http\Client::execute ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::execute
  • Swoole\Coroutine\Http\Client::getDefer »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::get

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::get — Description

Descripción

public Swoole\Coroutine\Http\Client::get ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::get
  • Swoole\Coroutine\Http\Client::isConnected »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::getDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::getDefer — Description

Descripción

public Swoole\Coroutine\Http\Client::getDefer ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::getDefer
  • Swoole\Coroutine\Http\Client::post »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::isConnected

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::isConnected — Description

Descripción

public Swoole\Coroutine\Http\Client::isConnected ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::isConnected
  • Swoole\Coroutine\Http\Client::recv »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::post

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::post — Description

Descripción

public Swoole\Coroutine\Http\Client::post ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::post
  • Swoole\Coroutine\Http\Client::set »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::recv — Description

Descripción

public Swoole\Coroutine\Http\Client::recv ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::recv
  • Swoole\Coroutine\Http\Client::setCookies »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::set

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::set — Description

Descripción

public Swoole\Coroutine\Http\Client::set ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::set
  • Swoole\Coroutine\Http\Client::setData »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setCookies

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setCookies — Description

Descripción

public Swoole\Coroutine\Http\Client::setCookies ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::setCookies
  • Swoole\Coroutine\Http\Client::setDefer »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setData

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setData — Description

Descripción

public Swoole\Coroutine\Http\Client::setData ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::setData
  • Swoole\Coroutine\Http\Client::setHeaders »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setDefer — Description

Descripción

public Swoole\Coroutine\Http\Client::setDefer ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::setDefer
  • Swoole\Coroutine\Http\Client::setMethod »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setHeaders

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setHeaders — Description

Descripción

public Swoole\Coroutine\Http\Client::setHeaders ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::setHeaders
  • Swoole\Coroutine\MySQL::close »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setMethod

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setMethod — Description

Descripción

public Swoole\Coroutine\Http\Client::setMethod ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\Http\Client::setMethod
  • Swoole\Coroutine\MySQL::connect »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::close — Description

Descripción

public Swoole\Coroutine\MySQL::close ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::close
  • Swoole\Coroutine\MySQL::__construct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::connect

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::connect — Description

Descripción

public Swoole\Coroutine\MySQL::connect ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::connect
  • Swoole\Coroutine\MySQL::__destruct »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::__construct — Description

Descripción

public Swoole\Coroutine\MySQL::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


Description

  • « Swoole\Coroutine\MySQL::__construct
  • Swoole\Coroutine\MySQL::getDefer »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::__destruct — Description

Descripción

public Swoole\Coroutine\MySQL::__destruct ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::__destruct
  • Swoole\Coroutine\MySQL::query »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::getDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::getDefer — Description

Descripción

public Swoole\Coroutine\MySQL::getDefer ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::getDefer
  • Swoole\Coroutine\MySQL::recv »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::query

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::query — Description

Descripción

public Swoole\Coroutine\MySQL::query ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::query
  • Swoole\Coroutine\MySQL::setDefer »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::recv — Description

Descripción

public Swoole\Coroutine\MySQL::recv ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::recv
  • Swoole\Coroutine::getuid »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::setDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::setDefer — Description

Descripción

public Swoole\Coroutine\MySQL::setDefer ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine\MySQL::setDefer
  • Swoole\Coroutine::resume »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::getuid

(PECL swoole >= 2.0.0)

Swoole\Coroutine::getuid — Description

Descripción

public static Swoole\Coroutine::getuid ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine::getuid
  • Swoole\Coroutine::suspend »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::resume

(PECL swoole >= 2.0.0)

Swoole\Coroutine::resume — Description

Descripción

public static Swoole\Coroutine::resume ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\Coroutine::resume
  • Swoole\Event »
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::suspend

(PECL swoole >= 2.0.0)

Swoole\Coroutine::suspend — Description

Descripción

public static Swoole\Coroutine::suspend ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Event class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Event {
/* Métodos */
public static add ( int $fd , callable $read_callback , callable $write_callback = ? , string $events = ? ) : bool
public static defer ( mixed $callback ) : void
public static del ( string $fd ) : bool
public static exit ( ) : void
public static set ( int $fd , string $read_callback = ? , string $write_callback = ? , string $events = ? ) : bool
public static wait ( ) : void
public static write ( string $fd , string $data ) : void
}

Tabla de contenidos

  • Swoole\Event::add — Add new callback functions of a socket into the EventLoop.
  • Swoole\Event::defer — Add a callback function to the next event loop.
  • Swoole\Event::del — Remove all event callback functions of a socket.
  • Swoole\Event::exit — Exit the eventloop, only available at client side.
  • Swoole\Event::set — Update the event callback functions of a socket.
  • Swoole\Event::wait — Description
  • Swoole\Event::write — Write data to the socket.


Add new callback functions of a socket into the EventLoop.

  • « Swoole\Event
  • Swoole\Event::defer »
  • PHP Manual
  • Swoole\Event
  • Add new callback functions of a socket into the EventLoop.

Swoole\Event::add

(PECL swoole >= 1.9.0)

Swoole\Event::add — Add new callback functions of a socket into the EventLoop.

Descripción

public static Swoole\Event::add ( int $fd , callable $read_callback , callable $write_callback = ? , string $events = ? ) : bool

Parámetros

fd

read_callback

write_callback

events

Valores devueltos


Add a callback function to the next event loop.

  • « Swoole\Event::add
  • Swoole\Event::del »
  • PHP Manual
  • Swoole\Event
  • Add a callback function to the next event loop.

Swoole\Event::defer

(PECL swoole >= 1.9.0)

Swoole\Event::defer — Add a callback function to the next event loop.

Descripción

public static Swoole\Event::defer ( mixed $callback ) : void

Parámetros

callback

Valores devueltos


Remove all event callback functions of a socket.

  • « Swoole\Event::defer
  • Swoole\Event::exit »
  • PHP Manual
  • Swoole\Event
  • Remove all event callback functions of a socket.

Swoole\Event::del

(PECL swoole >= 1.9.0)

Swoole\Event::del — Remove all event callback functions of a socket.

Descripción

public static Swoole\Event::del ( string $fd ) : bool

Parámetros

fd

Valores devueltos


Exit the eventloop, only available at client side.

  • « Swoole\Event::del
  • Swoole\Event::set »
  • PHP Manual
  • Swoole\Event
  • Exit the eventloop, only available at client side.

Swoole\Event::exit

(PECL swoole >= 1.9.0)

Swoole\Event::exit — Exit the eventloop, only available at client side.

Descripción

public static Swoole\Event::exit ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Update the event callback functions of a socket.

  • « Swoole\Event::exit
  • Swoole\Event::wait »
  • PHP Manual
  • Swoole\Event
  • Update the event callback functions of a socket.

Swoole\Event::set

(PECL swoole >= 1.9.0)

Swoole\Event::set — Update the event callback functions of a socket.

Descripción

public static Swoole\Event::set ( int $fd , string $read_callback = ? , string $write_callback = ? , string $events = ? ) : bool

Parámetros

fd

read_callback

write_callback

events

Valores devueltos


Description

  • « Swoole\Event::set
  • Swoole\Event::write »
  • PHP Manual
  • Swoole\Event
  • Description

Swoole\Event::wait

(PECL swoole >= 1.9.0)

Swoole\Event::wait — Description

Descripción

public static Swoole\Event::wait ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Write data to the socket.

  • « Swoole\Event::wait
  • Swoole\Exception »
  • PHP Manual
  • Swoole\Event
  • Write data to the socket.

Swoole\Event::write

(PECL swoole >= 1.9.0)

Swoole\Event::write — Write data to the socket.

Descripción

public static Swoole\Event::write ( string $fd , string $data ) : void

Parámetros

fd

data

Valores devueltos


The Swoole\Exception class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Exception extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


The Swoole\Http\Client class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Http\Client {
/* Propiedades */
public $errCode ;
public $sock ;
/* Métodos */
public addFile ( string $path , string $name , string $type = ? , string $filename = ? , string $offset = ? ) : void
public close ( ) : void
public __destruct ( ) : void
public download ( string $path , string $file , callable $callback , int $offset = ? ) : void
public execute ( string $path , string $callback ) : void
public get ( string $path , callable $callback ) : void
public isConnected ( ) : bool
public on ( string $event_name , callable $callback ) : void
public post ( string $path , string $data , callable $callback ) : void
public push ( string $data , string $opcode = ? , string $finish = ? ) : void
public set ( array $settings ) : void
public setCookies ( array $cookies ) : void
public setData ( string $data ) : ReturnType
public setHeaders ( array $headers ) : void
public setMethod ( string $method ) : void
public upgrade ( string $path , string $callback ) : void
}

Propiedades

errCode

sock

Tabla de contenidos

  • Swoole\Http\Client::addFile — Add a file to the post form.
  • Swoole\Http\Client::close — Close the http connection.
  • Swoole\Http\Client::__construct — Construct the async HTTP client.
  • Swoole\Http\Client::__destruct — Destruct the HTTP client.
  • Swoole\Http\Client::download — Download a file from the remote server.
  • Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.
  • Swoole\Http\Client::get — Send GET http request to the remote server.
  • Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.
  • Swoole\Http\Client::on — Register callback function by event name.
  • Swoole\Http\Client::post — Send POST http request to the remote server.
  • Swoole\Http\Client::push — Push data to websocket client.
  • Swoole\Http\Client::set — Update the HTTP client paramters.
  • Swoole\Http\Client::setCookies — Set the http request cookies.
  • Swoole\Http\Client::setData — Set the HTTP request body data.
  • Swoole\Http\Client::setHeaders — Set the HTTP request headers.
  • Swoole\Http\Client::setMethod — Set the HTTP request method.
  • Swoole\Http\Client::upgrade — Upgrade to websocket protocol.


Add a file to the post form.

  • « Swoole\Http\Client
  • Swoole\Http\Client::close »
  • PHP Manual
  • Swoole\Http\Client
  • Add a file to the post form.

Swoole\Http\Client::addFile

(PECL swoole >= 1.9.0)

Swoole\Http\Client::addFile — Add a file to the post form.

Descripción

public Swoole\Http\Client::addFile ( string $path , string $name , string $type = ? , string $filename = ? , string $offset = ? ) : void

Parámetros

path

name

type

filename

offset

Valores devueltos


Close the http connection.

  • « Swoole\Http\Client::addFile
  • Swoole\Http\Client::__construct »
  • PHP Manual
  • Swoole\Http\Client
  • Close the http connection.

Swoole\Http\Client::close

(PECL swoole >= 1.9.0)

Swoole\Http\Client::close — Close the http connection.

Descripción

public Swoole\Http\Client::close ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Construct the async HTTP client.

  • « Swoole\Http\Client::close
  • Swoole\Http\Client::__destruct »
  • PHP Manual
  • Swoole\Http\Client
  • Construct the async HTTP client.

Swoole\Http\Client::__construct

(PECL swoole >= 1.9.0)

Swoole\Http\Client::__construct — Construct the async HTTP client.

Descripción

public Swoole\Http\Client::__construct ( string $host , string $port = ? , bool $ssl = ? )

Parámetros

host

The hostname of the remote host.

port

The port number of the remote host.

ssl

Whether to enable SSL.


Destruct the HTTP client.

  • « Swoole\Http\Client::__construct
  • Swoole\Http\Client::download »
  • PHP Manual
  • Swoole\Http\Client
  • Destruct the HTTP client.

Swoole\Http\Client::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Client::__destruct — Destruct the HTTP client.

Descripción

public Swoole\Http\Client::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Download a file from the remote server.

  • « Swoole\Http\Client::__destruct
  • Swoole\Http\Client::execute »
  • PHP Manual
  • Swoole\Http\Client
  • Download a file from the remote server.

Swoole\Http\Client::download

(PECL swoole >= 1.9.0)

Swoole\Http\Client::download — Download a file from the remote server.

Descripción

public Swoole\Http\Client::download ( string $path , string $file , callable $callback , int $offset = ? ) : void

Parámetros

path

file

callback

offset

Valores devueltos


Send the HTTP request after setting the parameters.

  • « Swoole\Http\Client::download
  • Swoole\Http\Client::get »
  • PHP Manual
  • Swoole\Http\Client
  • Send the HTTP request after setting the parameters.

Swoole\Http\Client::execute

(PECL swoole >= 1.9.0)

Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.

Descripción

public Swoole\Http\Client::execute ( string $path , string $callback ) : void

Parámetros

path

callback

Valores devueltos


Send GET http request to the remote server.

  • « Swoole\Http\Client::execute
  • Swoole\Http\Client::isConnected »
  • PHP Manual
  • Swoole\Http\Client
  • Send GET http request to the remote server.

Swoole\Http\Client::get

(PECL swoole >= 1.9.0)

Swoole\Http\Client::get — Send GET http request to the remote server.

Descripción

public Swoole\Http\Client::get ( string $path , callable $callback ) : void

Parámetros

path

callback

Valores devueltos


Check if the HTTP connection is connected.

  • « Swoole\Http\Client::get
  • Swoole\Http\Client::on »
  • PHP Manual
  • Swoole\Http\Client
  • Check if the HTTP connection is connected.

Swoole\Http\Client::isConnected

(PECL swoole >= 1.9.0)

Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.

Descripción

public Swoole\Http\Client::isConnected ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Register callback function by event name.

  • « Swoole\Http\Client::isConnected
  • Swoole\Http\Client::post »
  • PHP Manual
  • Swoole\Http\Client
  • Register callback function by event name.

Swoole\Http\Client::on

(PECL swoole >= 1.9.0)

Swoole\Http\Client::on — Register callback function by event name.

Descripción

public Swoole\Http\Client::on ( string $event_name , callable $callback ) : void

Parámetros

event_name

callback

Valores devueltos


Send POST http request to the remote server.

  • « Swoole\Http\Client::on
  • Swoole\Http\Client::push »
  • PHP Manual
  • Swoole\Http\Client
  • Send POST http request to the remote server.

Swoole\Http\Client::post

(PECL swoole >= 1.9.0)

Swoole\Http\Client::post — Send POST http request to the remote server.

Descripción

public Swoole\Http\Client::post ( string $path , string $data , callable $callback ) : void

Parámetros

path

data

callback

Valores devueltos


Push data to websocket client.

  • « Swoole\Http\Client::post
  • Swoole\Http\Client::set »
  • PHP Manual
  • Swoole\Http\Client
  • Push data to websocket client.

Swoole\Http\Client::push

(PECL swoole >= 1.9.0)

Swoole\Http\Client::push — Push data to websocket client.

Descripción

public Swoole\Http\Client::push ( string $data , string $opcode = ? , string $finish = ? ) : void

Parámetros

data

opcode

finish

Valores devueltos


Update the HTTP client paramters.

  • « Swoole\Http\Client::push
  • Swoole\Http\Client::setCookies »
  • PHP Manual
  • Swoole\Http\Client
  • Update the HTTP client paramters.

Swoole\Http\Client::set

(PECL swoole >= 1.9.0)

Swoole\Http\Client::set — Update the HTTP client paramters.

Descripción

public Swoole\Http\Client::set ( array $settings ) : void

Parámetros

settings

Valores devueltos


Set the http request cookies.

  • « Swoole\Http\Client::set
  • Swoole\Http\Client::setData »
  • PHP Manual
  • Swoole\Http\Client
  • Set the http request cookies.

Swoole\Http\Client::setCookies

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setCookies — Set the http request cookies.

Descripción

public Swoole\Http\Client::setCookies ( array $cookies ) : void

Parámetros

cookies

Valores devueltos


Set the HTTP request body data.

  • « Swoole\Http\Client::setCookies
  • Swoole\Http\Client::setHeaders »
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request body data.

Swoole\Http\Client::setData

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setData — Set the HTTP request body data.

Descripción

public Swoole\Http\Client::setData ( string $data ) : ReturnType

The HTTP method will be changed to be POST.

Parámetros

data

Valores devueltos


Set the HTTP request headers.

  • « Swoole\Http\Client::setData
  • Swoole\Http\Client::setMethod »
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request headers.

Swoole\Http\Client::setHeaders

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setHeaders — Set the HTTP request headers.

Descripción

public Swoole\Http\Client::setHeaders ( array $headers ) : void

Parámetros

headers

Valores devueltos


Set the HTTP request method.

  • « Swoole\Http\Client::setHeaders
  • Swoole\Http\Client::upgrade »
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request method.

Swoole\Http\Client::setMethod

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setMethod — Set the HTTP request method.

Descripción

public Swoole\Http\Client::setMethod ( string $method ) : void

Parámetros

method

Valores devueltos


Upgrade to websocket protocol.

  • « Swoole\Http\Client::setMethod
  • Swoole\Http\Request »
  • PHP Manual
  • Swoole\Http\Client
  • Upgrade to websocket protocol.

Swoole\Http\Client::upgrade

(PECL swoole >= 1.9.0)

Swoole\Http\Client::upgrade — Upgrade to websocket protocol.

Descripción

public Swoole\Http\Client::upgrade ( string $path , string $callback ) : void

Parámetros

path

callback

Valores devueltos


The Swoole\Http\Request class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Http\Request {
/* Métodos */
public __destruct ( ) : void
public rawcontent ( ) : string
}

Tabla de contenidos

  • Swoole\Http\Request::__destruct — Destruct the HTTP request.
  • Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.


Destruct the HTTP request.

  • « Swoole\Http\Request
  • Swoole\Http\Request::rawcontent »
  • PHP Manual
  • Swoole\Http\Request
  • Destruct the HTTP request.

Swoole\Http\Request::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Request::__destruct — Destruct the HTTP request.

Descripción

public Swoole\Http\Request::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the raw HTTP POST body.

  • « Swoole\Http\Request::__destruct
  • Swoole\Http\Response »
  • PHP Manual
  • Swoole\Http\Request
  • Get the raw HTTP POST body.

Swoole\Http\Request::rawcontent

(PECL swoole >= 1.9.0)

Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.

Descripción

public Swoole\Http\Request::rawcontent ( ) : string

This method is used for the POST data which isn't in the form of `application/x-www-form-urlencoded`.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Http\Response class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Http\Response {
/* Métodos */
public cookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : string
public __destruct ( ) : void
public end ( string $content = ? ) : void
public gzip ( string $compress_level = ? ) : ReturnType
public header ( string $key , string $value , string $ucwords = ? ) : void
public initHeader ( ) : ReturnType
public rawcookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : ReturnType
public sendfile ( string $filename , int $offset = ? ) : ReturnType
public status ( string $http_code ) : ReturnType
public write ( string $content ) : void
}

Tabla de contenidos

  • Swoole\Http\Response::cookie — Set the cookies of the HTTP response.
  • Swoole\Http\Response::__destruct — Destruct the HTTP response.
  • Swoole\Http\Response::end — Send data for the HTTP request and finish the response.
  • Swoole\Http\Response::gzip — Enable the gzip of response content.
  • Swoole\Http\Response::header — Set the HTTP response headers.
  • Swoole\Http\Response::initHeader — Init the HTTP response header.
  • Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.
  • Swoole\Http\Response::sendfile — Send file through the HTTP response.
  • Swoole\Http\Response::status — Set the status code of the HTTP response.
  • Swoole\Http\Response::write — Append HTTP body content to the HTTP response.


Set the cookies of the HTTP response.

  • « Swoole\Http\Response
  • Swoole\Http\Response::__destruct »
  • PHP Manual
  • Swoole\Http\Response
  • Set the cookies of the HTTP response.

Swoole\Http\Response::cookie

(PECL swoole >= 1.9.0)

Swoole\Http\Response::cookie — Set the cookies of the HTTP response.

Descripción

public Swoole\Http\Response::cookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : string

Parámetros

name

value

expires

path

domain

secure

httponly

Valores devueltos


Destruct the HTTP response.

  • « Swoole\Http\Response::cookie
  • Swoole\Http\Response::end »
  • PHP Manual
  • Swoole\Http\Response
  • Destruct the HTTP response.

Swoole\Http\Response::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Response::__destruct — Destruct the HTTP response.

Descripción

public Swoole\Http\Response::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Send data for the HTTP request and finish the response.

  • « Swoole\Http\Response::__destruct
  • Swoole\Http\Response::gzip »
  • PHP Manual
  • Swoole\Http\Response
  • Send data for the HTTP request and finish the response.

Swoole\Http\Response::end

(PECL swoole >= 1.9.0)

Swoole\Http\Response::end — Send data for the HTTP request and finish the response.

Descripción

public Swoole\Http\Response::end ( string $content = ? ) : void

Parámetros

content

Valores devueltos


Enable the gzip of response content.

  • « Swoole\Http\Response::end
  • Swoole\Http\Response::header »
  • PHP Manual
  • Swoole\Http\Response
  • Enable the gzip of response content.

Swoole\Http\Response::gzip

(PECL swoole >= 1.9.0)

Swoole\Http\Response::gzip — Enable the gzip of response content.

Descripción

public Swoole\Http\Response::gzip ( string $compress_level = ? ) : ReturnType

The header about Content-Encoding will be added automatically.

Parámetros

compress_level

Valores devueltos


Set the HTTP response headers.

  • « Swoole\Http\Response::gzip
  • Swoole\Http\Response::initHeader »
  • PHP Manual
  • Swoole\Http\Response
  • Set the HTTP response headers.

Swoole\Http\Response::header

(PECL swoole >= 1.9.0)

Swoole\Http\Response::header — Set the HTTP response headers.

Descripción

public Swoole\Http\Response::header ( string $key , string $value , string $ucwords = ? ) : void

Parámetros

key

value

ucwords

Valores devueltos


Init the HTTP response header.

  • « Swoole\Http\Response::header
  • Swoole\Http\Response::rawcookie »
  • PHP Manual
  • Swoole\Http\Response
  • Init the HTTP response header.

Swoole\Http\Response::initHeader

(PECL swoole >= 1.9.0)

Swoole\Http\Response::initHeader — Init the HTTP response header.

Descripción

public Swoole\Http\Response::initHeader ( ) : ReturnType

Init the HTTP response header.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Set the raw cookies to the HTTP response.

  • « Swoole\Http\Response::initHeader
  • Swoole\Http\Response::sendfile »
  • PHP Manual
  • Swoole\Http\Response
  • Set the raw cookies to the HTTP response.

Swoole\Http\Response::rawcookie

(PECL swoole >= 1.9.0)

Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.

Descripción

public Swoole\Http\Response::rawcookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : ReturnType

Parámetros

name

value

expires

path

domain

secure

httponly

Valores devueltos


Send file through the HTTP response.

  • « Swoole\Http\Response::rawcookie
  • Swoole\Http\Response::status »
  • PHP Manual
  • Swoole\Http\Response
  • Send file through the HTTP response.

Swoole\Http\Response::sendfile

(PECL swoole >= 1.9.0)

Swoole\Http\Response::sendfile — Send file through the HTTP response.

Descripción

public Swoole\Http\Response::sendfile ( string $filename , int $offset = ? ) : ReturnType

Send file through the HTTP response.

Parámetros

filename

offset

Valores devueltos


Set the status code of the HTTP response.

  • « Swoole\Http\Response::sendfile
  • Swoole\Http\Response::write »
  • PHP Manual
  • Swoole\Http\Response
  • Set the status code of the HTTP response.

Swoole\Http\Response::status

(PECL swoole >= 1.9.0)

Swoole\Http\Response::status — Set the status code of the HTTP response.

Descripción

public Swoole\Http\Response::status ( string $http_code ) : ReturnType

Set the status code of the HTTP response.

Parámetros

http_code

Valores devueltos


Append HTTP body content to the HTTP response.

  • « Swoole\Http\Response::status
  • Swoole\Http\Server »
  • PHP Manual
  • Swoole\Http\Response
  • Append HTTP body content to the HTTP response.

Swoole\Http\Response::write

(PECL swoole >= 1.9.0)

Swoole\Http\Response::write — Append HTTP body content to the HTTP response.

Descripción

public Swoole\Http\Response::write ( string $content ) : void

Append HTTP body content to the HTTP response.

Parámetros

content

Valores devueltos


The Swoole\Http\Server class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Http\Server extends Swoole\Server {
/* Métodos */
public on ( string $event_name , callable $callback ) : void
public start ( ) : void
/* Métodos heredados */
public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void
public Swoole\Server::addProcess ( swoole_process $process ) : bool
public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public Swoole\Server::bind ( int $fd , int $uid ) : bool
public Swoole\Server::clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool
public Swoole\Server::confirm ( int $fd ) : bool
public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array
public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public Swoole\Server::exist ( int $fd ) : bool
public Swoole\Server::finish ( string $data ) : void
public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::getLastError ( ) : int
public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed
public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool
public Swoole\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Server::pause ( int $fd ) : void
public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void
public Swoole\Server::reload ( ) : bool
public Swoole\Server::resume ( int $fd ) : void
public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool
public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool
public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public Swoole\Server::sendwait ( int $fd , string $data ) : bool
public Swoole\Server::set ( array $settings ) : ReturnType
public Swoole\Server::shutdown ( ) : void
public Swoole\Server::start ( ) : void
public Swoole\Server::stats ( ) : array
public Swoole\Server::stop ( int $worker_id = ? ) : bool
public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void
}

Tabla de contenidos

  • Swoole\Http\Server::on — Bind callback function to HTTP server by event name.
  • Swoole\Http\Server::start — Start the swoole http server.


Bind callback function to HTTP server by event name.

  • « Swoole\Http\Server
  • Swoole\Http\Server::start »
  • PHP Manual
  • Swoole\Http\Server
  • Bind callback function to HTTP server by event name.

Swoole\Http\Server::on

(PECL swoole >= 1.9.0)

Swoole\Http\Server::on — Bind callback function to HTTP server by event name.

Descripción

public Swoole\Http\Server::on ( string $event_name , callable $callback ) : void

Bind callback function to HTTP server by event name.

Parámetros

event_name

callback

Valores devueltos


Start the swoole http server.

  • « Swoole\Http\Server::on
  • Swoole\Lock »
  • PHP Manual
  • Swoole\Http\Server
  • Start the swoole http server.

Swoole\Http\Server::start

(PECL swoole >= 1.9.0)

Swoole\Http\Server::start — Start the swoole http server.

Descripción

public Swoole\Http\Server::start ( ) : void

Start the swoole http server.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Lock class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Lock {
/* Métodos */
public __destruct ( ) : void
public lock_read ( ) : void
public lock ( ) : void
public trylock_read ( ) : void
public trylock ( ) : void
public unlock ( ) : void
}

Tabla de contenidos

  • Swoole\Lock::__construct — Construct a memory lock.
  • Swoole\Lock::__destruct — Destory a Swoole memory lock.
  • Swoole\Lock::lock_read — Lock a read-write lock for reading.
  • Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.
  • Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.
  • Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.
  • Swoole\Lock::unlock — Release the lock.


Construct a memory lock.

  • « Swoole\Lock
  • Swoole\Lock::__destruct »
  • PHP Manual
  • Swoole\Lock
  • Construct a memory lock.

Swoole\Lock::__construct

(PECL swoole >= 1.9.0)

Swoole\Lock::__construct — Construct a memory lock.

Descripción

public Swoole\Lock::__construct ( string $type = ? , string $file_lock_location = ? )

Swoole lock is used for data synchronization between multiple theads or processes.

Parámetros

type

file_lock_location


Destory a Swoole memory lock.

  • « Swoole\Lock::__construct
  • Swoole\Lock::lock_read »
  • PHP Manual
  • Swoole\Lock
  • Destory a Swoole memory lock.

Swoole\Lock::__destruct

(PECL swoole >= 1.9.0)

Swoole\Lock::__destruct — Destory a Swoole memory lock.

Descripción

public Swoole\Lock::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Lock a read-write lock for reading.

  • « Swoole\Lock::__destruct
  • Swoole\Lock::lock »
  • PHP Manual
  • Swoole\Lock
  • Lock a read-write lock for reading.

Swoole\Lock::lock_read

(PECL swoole >= 1.9.0)

Swoole\Lock::lock_read — Lock a read-write lock for reading.

Descripción

public Swoole\Lock::lock_read ( ) : void

Lock a read-write lock for reading.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Try to acquire the lock. It will block if the lock is not available.

  • « Swoole\Lock::lock_read
  • Swoole\Lock::trylock_read »
  • PHP Manual
  • Swoole\Lock
  • Try to acquire the lock. It will block if the lock is not available.

Swoole\Lock::lock

(PECL swoole >= 1.9.0)

Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.

Descripción

public Swoole\Lock::lock ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Try to lock a read-write lock for reading and return straight away even the lock is not available.

  • « Swoole\Lock::lock
  • Swoole\Lock::trylock »
  • PHP Manual
  • Swoole\Lock
  • Try to lock a read-write lock for reading and return straight away even the lock is not available.

Swoole\Lock::trylock_read

(PECL swoole >= 1.9.0)

Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.

Descripción

public Swoole\Lock::trylock_read ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Try to acquire the lock and return straight away even the lock is not available.

  • « Swoole\Lock::trylock_read
  • Swoole\Lock::unlock »
  • PHP Manual
  • Swoole\Lock
  • Try to acquire the lock and return straight away even the lock is not available.

Swoole\Lock::trylock

(PECL swoole >= 1.9.0)

Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.

Descripción

public Swoole\Lock::trylock ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Release the lock.

  • « Swoole\Lock::trylock
  • Swoole\Mmap »
  • PHP Manual
  • Swoole\Lock
  • Release the lock.

Swoole\Lock::unlock

(PECL swoole >= 1.9.0)

Swoole\Lock::unlock — Release the lock.

Descripción

public Swoole\Lock::unlock ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Mmap class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Mmap {
/* Métodos */
public static open ( string $filename , string $size = ? , string $offset = ? ) : ReturnType
}

Tabla de contenidos

  • Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.


Map a file into memory and return the stream resource which can be used by PHP stream operations.

  • « Swoole\Mmap
  • Swoole\MySQL »
  • PHP Manual
  • Swoole\Mmap
  • Map a file into memory and return the stream resource which can be used by PHP stream operations.

Swoole\Mmap::open

(PECL swoole >= 1.9.0)

Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.

Descripción

public static Swoole\Mmap::open ( string $filename , string $size = ? , string $offset = ? ) : ReturnType

Parámetros

filename

size

offset

Valores devueltos


The Swoole\MySQL class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\MySQL {
/* Métodos */
public close ( ) : void
public connect ( array $server_config , callable $callback ) : void
public __destruct ( ) : void
public getBuffer ( ) : ReturnType
public on ( string $event_name , callable $callback ) : void
public query ( string $sql , callable $callback ) : ReturnType
}

Tabla de contenidos

  • Swoole\MySQL::close — Close the async MySQL connection.
  • Swoole\MySQL::connect — Connect to the remote MySQL server.
  • Swoole\MySQL::__construct — Construct an async MySQL client.
  • Swoole\MySQL::__destruct — Destory the async MySQL client.
  • Swoole\MySQL::getBuffer — Description
  • Swoole\MySQL::on — Register callback function based on event name.
  • Swoole\MySQL::query — Run the SQL query.


Close the async MySQL connection.

  • « Swoole\MySQL
  • Swoole\MySQL::connect »
  • PHP Manual
  • Swoole\MySQL
  • Close the async MySQL connection.

Swoole\MySQL::close

(PECL swoole >= 1.9.0)

Swoole\MySQL::close — Close the async MySQL connection.

Descripción

public Swoole\MySQL::close ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Connect to the remote MySQL server.

  • « Swoole\MySQL::close
  • Swoole\MySQL::__construct »
  • PHP Manual
  • Swoole\MySQL
  • Connect to the remote MySQL server.

Swoole\MySQL::connect

(PECL swoole >= 1.9.0)

Swoole\MySQL::connect — Connect to the remote MySQL server.

Descripción

public Swoole\MySQL::connect ( array $server_config , callable $callback ) : void

Connect to the remote MySQL server.

Parámetros

server_config

callback

Valores devueltos


Construct an async MySQL client.

  • « Swoole\MySQL::connect
  • Swoole\MySQL::__destruct »
  • PHP Manual
  • Swoole\MySQL
  • Construct an async MySQL client.

Swoole\MySQL::__construct

(PECL swoole >= 1.9.0)

Swoole\MySQL::__construct — Construct an async MySQL client.

Descripción

public Swoole\MySQL::__construct ( )

Construct an async MySQL client.

Parámetros

Esta función no tiene parámetros.


Destory the async MySQL client.

  • « Swoole\MySQL::__construct
  • Swoole\MySQL::getBuffer »
  • PHP Manual
  • Swoole\MySQL
  • Destory the async MySQL client.

Swoole\MySQL::__destruct

(PECL swoole >= 1.9.0)

Swoole\MySQL::__destruct — Destory the async MySQL client.

Descripción

public Swoole\MySQL::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Description

  • « Swoole\MySQL::__destruct
  • Swoole\MySQL::on »
  • PHP Manual
  • Swoole\MySQL
  • Description

Swoole\MySQL::getBuffer

(PECL swoole >= 1.9.0)

Swoole\MySQL::getBuffer — Description

Descripción

public Swoole\MySQL::getBuffer ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Register callback function based on event name.

  • « Swoole\MySQL::getBuffer
  • Swoole\MySQL::query »
  • PHP Manual
  • Swoole\MySQL
  • Register callback function based on event name.

Swoole\MySQL::on

(PECL swoole >= 1.9.0)

Swoole\MySQL::on — Register callback function based on event name.

Descripción

public Swoole\MySQL::on ( string $event_name , callable $callback ) : void

Register callback function based on event name, current only 'close' event is supported.

Parámetros

event_name

callback

Valores devueltos


Run the SQL query.

  • « Swoole\MySQL::on
  • Swoole\MySQL\Exception »
  • PHP Manual
  • Swoole\MySQL
  • Run the SQL query.

Swoole\MySQL::query

(PECL swoole >= 1.9.0)

Swoole\MySQL::query — Run the SQL query.

Descripción

public Swoole\MySQL::query ( string $sql , callable $callback ) : ReturnType

Parámetros

sql

callback

Valores devueltos


The Swoole\MySQL\Exception class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\MySQL\Exception extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


The Swoole\Process class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Process {
/* Constants */
const int IPC_NOWAIT = 256 ;
/* Métodos */
public static alarm ( int $interval_usec ) : void
public close ( ) : void
public static daemon ( bool $nochdir = ? , bool $noclose = ? ) : void
public __destruct ( ) : void
public exec ( string $exec_file , string $args ) : ReturnType
public exit ( string $exit_code = ? ) : void
public freeQueue ( ) : void
public static kill ( int $pid , string $signal_no = ? ) : void
public name ( string $process_name ) : void
public pop ( int $maxsize = ? ) : mixed
public push ( string $data ) : bool
public read ( int $maxsize = ? ) : string
public static signal ( string $signal_no , callable $callback ) : void
public start ( ) : void
public statQueue ( ) : array
public useQueue ( int $key , int $mode = ? ) : bool
public static wait ( bool $blocking = ? ) : array
public write ( string $data ) : int
}

Constantes predefinidas

Swoole\Process::IPC_NOWAIT

Tabla de contenidos

  • Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.
  • Swoole\Process::close — Close the pipe to the child process.
  • Swoole\Process::__construct — Construct a process.
  • Swoole\Process::daemon — Change the process to be a daemon process.
  • Swoole\Process::__destruct — Destory the process.
  • Swoole\Process::exec — Execute system commands.
  • Swoole\Process::exit — Stop the child processes.
  • Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.
  • Swoole\Process::kill — Send signal to the child process.
  • Swoole\Process::name — Set name of the process.
  • Swoole\Process::pop — Read and pop data from the message queue.
  • Swoole\Process::push — Write and push data into the message queue.
  • Swoole\Process::read — Read data sending to the process.
  • Swoole\Process::signal — Send signal to the child processes.
  • Swoole\Process::start — Start the process.
  • Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.
  • Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.
  • Swoole\Process::wait — Wait for the events of child processes.
  • Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.


High precision timer which triggers signal with fixed interval.

  • « Swoole\Process
  • Swoole\Process::close »
  • PHP Manual
  • Swoole\Process
  • High precision timer which triggers signal with fixed interval.

Swoole\Process::alarm

(PECL swoole >= 1.9.0)

Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.

Descripción

public static Swoole\Process::alarm ( int $interval_usec ) : void

Parámetros

interval_usec

Valores devueltos


Close the pipe to the child process.

  • « Swoole\Process::alarm
  • Swoole\Process::__construct »
  • PHP Manual
  • Swoole\Process
  • Close the pipe to the child process.

Swoole\Process::close

(PECL swoole >= 1.9.0)

Swoole\Process::close — Close the pipe to the child process.

Descripción

public Swoole\Process::close ( ) : void

Close the pipe to the child process.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Construct a process.

  • « Swoole\Process::close
  • Swoole\Process::daemon »
  • PHP Manual
  • Swoole\Process
  • Construct a process.

Swoole\Process::__construct

(PECL swoole >= 1.9.0)

Swoole\Process::__construct — Construct a process.

Descripción

public Swoole\Process::__construct ( callable $callback , bool $redirect_stdin_and_stdout = ? , int $pipe_type = ? )

Parámetros

callback

redirect_stdin_and_stdout

pipe_type


Change the process to be a daemon process.

  • « Swoole\Process::__construct
  • Swoole\Process::__destruct »
  • PHP Manual
  • Swoole\Process
  • Change the process to be a daemon process.

Swoole\Process::daemon

(PECL swoole >= 1.9.0)

Swoole\Process::daemon — Change the process to be a daemon process.

Descripción

public static Swoole\Process::daemon ( bool $nochdir = ? , bool $noclose = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

nochdir

noclose

Valores devueltos


Destory the process.

  • « Swoole\Process::daemon
  • Swoole\Process::exec »
  • PHP Manual
  • Swoole\Process
  • Destory the process.

Swoole\Process::__destruct

(PECL swoole >= 1.9.0)

Swoole\Process::__destruct — Destory the process.

Descripción

public Swoole\Process::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Execute system commands.

  • « Swoole\Process::__destruct
  • Swoole\Process::exit »
  • PHP Manual
  • Swoole\Process
  • Execute system commands.

Swoole\Process::exec

(PECL swoole >= 1.9.0)

Swoole\Process::exec — Execute system commands.

Descripción

public Swoole\Process::exec ( string $exec_file , string $args ) : ReturnType

The process will be replaced to be the system command process, but the pipe to the parent process will be kept.

Parámetros

exec_file

args

Valores devueltos


Stop the child processes.

  • « Swoole\Process::exec
  • Swoole\Process::freeQueue »
  • PHP Manual
  • Swoole\Process
  • Stop the child processes.

Swoole\Process::exit

(PECL swoole >= 1.9.0)

Swoole\Process::exit — Stop the child processes.

Descripción

public Swoole\Process::exit ( string $exit_code = ? ) : void

Parámetros

exit_code

Valores devueltos


Destroy the message queue created by swoole_process::useQueue.

  • « Swoole\Process::exit
  • Swoole\Process::kill »
  • PHP Manual
  • Swoole\Process
  • Destroy the message queue created by swoole_process::useQueue.

Swoole\Process::freeQueue

(PECL swoole >= 1.9.0)

Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.

Descripción

public Swoole\Process::freeQueue ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Send signal to the child process.

  • « Swoole\Process::freeQueue
  • Swoole\Process::name »
  • PHP Manual
  • Swoole\Process
  • Send signal to the child process.

Swoole\Process::kill

(PECL swoole >= 1.9.0)

Swoole\Process::kill — Send signal to the child process.

Descripción

public static Swoole\Process::kill ( int $pid , string $signal_no = ? ) : void

Send signal to the child process.

Parámetros

pid

signal_no

Valores devueltos


Set name of the process.

  • « Swoole\Process::kill
  • Swoole\Process::pop »
  • PHP Manual
  • Swoole\Process
  • Set name of the process.

Swoole\Process::name

(PECL swoole >= 1.9.0)

Swoole\Process::name — Set name of the process.

Descripción

public Swoole\Process::name ( string $process_name ) : void

Parámetros

process_name

Valores devueltos


Read and pop data from the message queue.

  • « Swoole\Process::name
  • Swoole\Process::push »
  • PHP Manual
  • Swoole\Process
  • Read and pop data from the message queue.

Swoole\Process::pop

(PECL swoole >= 1.9.0)

Swoole\Process::pop — Read and pop data from the message queue.

Descripción

public Swoole\Process::pop ( int $maxsize = ? ) : mixed

Parámetros

maxsize

Valores devueltos


Write and push data into the message queue.

  • « Swoole\Process::pop
  • Swoole\Process::read »
  • PHP Manual
  • Swoole\Process
  • Write and push data into the message queue.

Swoole\Process::push

(PECL swoole >= 1.9.0)

Swoole\Process::push — Write and push data into the message queue.

Descripción

public Swoole\Process::push ( string $data ) : bool

Parámetros

data

Valores devueltos


Read data sending to the process.

  • « Swoole\Process::push
  • Swoole\Process::signal »
  • PHP Manual
  • Swoole\Process
  • Read data sending to the process.

Swoole\Process::read

(PECL swoole >= 1.9.0)

Swoole\Process::read — Read data sending to the process.

Descripción

public Swoole\Process::read ( int $maxsize = ? ) : string

Parámetros

maxsize

Valores devueltos


Send signal to the child processes.

  • « Swoole\Process::read
  • Swoole\Process::start »
  • PHP Manual
  • Swoole\Process
  • Send signal to the child processes.

Swoole\Process::signal

(PECL swoole >= 1.9.0)

Swoole\Process::signal — Send signal to the child processes.

Descripción

public static Swoole\Process::signal ( string $signal_no , callable $callback ) : void

Parámetros

signal_no

callback

Valores devueltos

If signal sent successfully, it returns TRUE, otherwise it returns FALSE.


Start the process.

  • « Swoole\Process::signal
  • Swoole\Process::statQueue »
  • PHP Manual
  • Swoole\Process
  • Start the process.

Swoole\Process::start

(PECL swoole >= 1.9.0)

Swoole\Process::start — Start the process.

Descripción

public Swoole\Process::start ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the stats of the message queue used as the communication method between processes.

  • « Swoole\Process::start
  • Swoole\Process::useQueue »
  • PHP Manual
  • Swoole\Process
  • Get the stats of the message queue used as the communication method between processes.

Swoole\Process::statQueue

(PECL swoole >= 1.9.0)

Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.

Descripción

public Swoole\Process::statQueue ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The array of status of the message queue.


Create a message queue as the communication method between the parent process and child processes.

  • « Swoole\Process::statQueue
  • Swoole\Process::wait »
  • PHP Manual
  • Swoole\Process
  • Create a message queue as the communication method between the parent process and child processes.

Swoole\Process::useQueue

(PECL swoole >= 1.9.0)

Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.

Descripción

public Swoole\Process::useQueue ( int $key , int $mode = ? ) : bool

Parámetros

key

mode

Valores devueltos


Wait for the events of child processes.

  • « Swoole\Process::useQueue
  • Swoole\Process::write »
  • PHP Manual
  • Swoole\Process
  • Wait for the events of child processes.

Swoole\Process::wait

(PECL swoole >= 1.9.0)

Swoole\Process::wait — Wait for the events of child processes.

Descripción

public static Swoole\Process::wait ( bool $blocking = ? ) : array

Parámetros

blocking

Valores devueltos


Write data into the pipe and communicate with the parent process or child processes.

  • « Swoole\Process::wait
  • Swoole\Redis\Server »
  • PHP Manual
  • Swoole\Process
  • Write data into the pipe and communicate with the parent process or child processes.

Swoole\Process::write

(PECL swoole >= 1.9.0)

Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.

Descripción

public Swoole\Process::write ( string $data ) : int

Parámetros

data

Valores devueltos


The Swoole\Redis\Server class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Redis\Server extends Swoole\Server {
/* Constants */
const int NIL = 1 ;
const int ERROR = 0 ;
const int STATUS = 2 ;
const int INT = 3 ;
const int STRING = 4 ;
const int SET = 5 ;
const int MAP = 6 ;
/* Métodos */
public static format ( string $type , string $value = ? ) : ReturnType
public setHandler ( string $command , string $callback , string $number_of_string_param = ? , string $type_of_array_param = ? ) : ReturnType
public start ( ) : ReturnType
/* Métodos heredados */
public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void
public Swoole\Server::addProcess ( swoole_process $process ) : bool
public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public Swoole\Server::bind ( int $fd , int $uid ) : bool
public Swoole\Server::clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool
public Swoole\Server::confirm ( int $fd ) : bool
public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array
public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public Swoole\Server::exist ( int $fd ) : bool
public Swoole\Server::finish ( string $data ) : void
public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::getLastError ( ) : int
public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed
public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool
public Swoole\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Server::pause ( int $fd ) : void
public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void
public Swoole\Server::reload ( ) : bool
public Swoole\Server::resume ( int $fd ) : void
public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool
public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool
public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public Swoole\Server::sendwait ( int $fd , string $data ) : bool
public Swoole\Server::set ( array $settings ) : ReturnType
public Swoole\Server::shutdown ( ) : void
public Swoole\Server::start ( ) : void
public Swoole\Server::stats ( ) : array
public Swoole\Server::stop ( int $worker_id = ? ) : bool
public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void
}

Constantes predefinidas

Swoole\Redis\Server::NIL

Swoole\Redis\Server::ERROR

Swoole\Redis\Server::STATUS

Swoole\Redis\Server::INT

Swoole\Redis\Server::STRING

Swoole\Redis\Server::SET

Swoole\Redis\Server::MAP

Tabla de contenidos

  • Swoole\Redis\Server::format — Description
  • Swoole\Redis\Server::setHandler — Description
  • Swoole\Redis\Server::start — Description


Description

  • « Swoole\Redis\Server
  • Swoole\Redis\Server::setHandler »
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::format

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::format — Description

Descripción

public static Swoole\Redis\Server::format ( string $type , string $value = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

type

value

Valores devueltos


Description

  • « Swoole\Redis\Server::format
  • Swoole\Redis\Server::start »
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::setHandler

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::setHandler — Description

Descripción

public Swoole\Redis\Server::setHandler ( string $command , string $callback , string $number_of_string_param = ? , string $type_of_array_param = ? ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

command

callback

number_of_string_param

type_of_array_param

Valores devueltos


Description

  • « Swoole\Redis\Server::setHandler
  • Swoole\Serialize »
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::start

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::start — Description

Descripción

public Swoole\Redis\Server::start ( ) : ReturnType

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Serialize class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Serialize {
/* Métodos */
public static pack ( string $data , int $is_fast = ? ) : ReturnType
public static unpack ( string $data , string $args = ? ) : ReturnType
}

Tabla de contenidos

  • Swoole\Serialize::pack — Serialize the data.
  • Swoole\Serialize::unpack — Unserialize the data.


Serialize the data.

  • « Swoole\Serialize
  • Swoole\Serialize::unpack »
  • PHP Manual
  • Swoole\Serialize
  • Serialize the data.

Swoole\Serialize::pack

(PECL swoole >= 1.9.0)

Swoole\Serialize::pack — Serialize the data.

Descripción

public static Swoole\Serialize::pack ( string $data , int $is_fast = ? ) : ReturnType

Swoole provides a fast and high performance serialization module.

Parámetros

data

is_fast

Valores devueltos


Unserialize the data.

  • « Swoole\Serialize::pack
  • Swoole\Server »
  • PHP Manual
  • Swoole\Serialize
  • Unserialize the data.

Swoole\Serialize::unpack

(PECL swoole >= 1.9.0)

Swoole\Serialize::unpack — Unserialize the data.

Descripción

public static Swoole\Serialize::unpack ( string $data , string $args = ? ) : ReturnType

Unserialize the data.

Parámetros

string

args

Valores devueltos


The Swoole\Server class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Server {
/* Métodos */
public addlistener ( string $host , int $port , string $socket_type ) : void
public addProcess ( swoole_process $process ) : bool
public after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public bind ( int $fd , int $uid ) : bool
public clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public close ( int $fd , bool $reset = ? ) : bool
public confirm ( int $fd ) : bool
public connection_info ( int $fd , int $reactor_id = ? ) : array
public connection_list ( int $start_fd , int $pagesize = ? ) : array
public defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public exist ( int $fd ) : bool
public finish ( string $data ) : void
public getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public getClientList ( int $start_fd , int $pagesize = ? ) : array
public getLastError ( ) : int
public heartbeat ( bool $if_close_connection ) : mixed
public listen ( string $host , int $port , string $socket_type ) : bool
public on ( string $event_name , callable $callback ) : void
public pause ( int $fd ) : void
public protect ( int $fd , bool $is_protected = ? ) : void
public reload ( ) : bool
public resume ( int $fd ) : void
public send ( int $fd , string $data , int $reactor_id = ? ) : bool
public sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public sendMessage ( int $worker_id , string $data ) : bool
public sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public sendwait ( int $fd , string $data ) : bool
public set ( array $settings ) : ReturnType
public shutdown ( ) : void
public start ( ) : void
public stats ( ) : array
public stop ( int $worker_id = ? ) : bool
public task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public tick ( int $interval_ms , callable $callback ) : void
}

Tabla de contenidos

  • Swoole\Server::addlistener — Add a new listener to the server.
  • Swoole\Server::addProcess — Add a user defined swoole_process to the server.
  • Swoole\Server::after — Trigger a callback function after a period of time.
  • Swoole\Server::bind — Bind the connection to a user defined user ID.
  • Swoole\Server::clearTimer — Stop and destory a timer.
  • Swoole\Server::close — Close a connection to the client.
  • Swoole\Server::confirm — Check status of the connection.
  • Swoole\Server::connection_info — Get the connection info by file description.
  • Swoole\Server::connection_list — Get all of the established connections.
  • Swoole\Server::__construct — Construct a Swoole server.
  • Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.
  • Swoole\Server\Port::__construct — Construct a server port
  • Swoole\Server\Port::__destruct — Destory server port
  • Swoole\Server\Port::on — Register callback functions by event.
  • Swoole\Server\Port::set — Set protocol of the server port.
  • Swoole\Server::exist — Check if the connection is existed.
  • Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.
  • Swoole\Server::getClientInfo — Get the connection info by file description.
  • Swoole\Server::getClientList — Get all of the established connections.
  • Swoole\Server::getLastError — Get the error code of the most recent error.
  • Swoole\Server::heartbeat — Check all the connections on the server.
  • Swoole\Server::listen — Listen on the given IP and port, socket type.
  • Swoole\Server::on — Register a callback function by event name.
  • Swoole\Server::pause — Stop receiving data from the connection.
  • Swoole\Server::protect — Set the connection to be protected mode.
  • Swoole\Server::reload — Restart all the worker process.
  • Swoole\Server::resume — Start receving data from the connection.
  • Swoole\Server::send — Send data to the client.
  • Swoole\Server::sendfile — Send file to the connection.
  • Swoole\Server::sendMessage — Send message to worker processes by ID.
  • Swoole\Server::sendto — Send data to the remote UDP address.
  • Swoole\Server::sendwait — Send data to the remote socket in the blocking way.
  • Swoole\Server::set — Set the runtime settings of the swoole server.
  • Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.
  • Swoole\Server::start — Start the Swoole server.
  • Swoole\Server::stats — Get the stats of the Swoole server.
  • Swoole\Server::stop — Stop the Swoole server.
  • Swoole\Server::task — Send data to the task worker processes.
  • Swoole\Server::taskwait — Send data to the task worker processes in blocking way.
  • Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.
  • Swoole\Server::tick — Repeats a given function at every given time-interval.


Add a new listener to the server.

  • « Swoole\Server
  • Swoole\Server::addProcess »
  • PHP Manual
  • Swoole\Server
  • Add a new listener to the server.

Swoole\Server::addlistener

(PECL swoole >= 1.9.0)

Swoole\Server::addlistener — Add a new listener to the server.

Descripción

public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void

Parámetros

host

port

socket_type

Valores devueltos


Add a user defined swoole_process to the server.

  • « Swoole\Server::addlistener
  • Swoole\Server::after »
  • PHP Manual
  • Swoole\Server
  • Add a user defined swoole_process to the server.

Swoole\Server::addProcess

(PECL swoole >= 1.9.0)

Swoole\Server::addProcess — Add a user defined swoole_process to the server.

Descripción

public Swoole\Server::addProcess ( swoole_process $process ) : bool

Parámetros

process

Valores devueltos


Trigger a callback function after a period of time.

  • « Swoole\Server::addProcess
  • Swoole\Server::bind »
  • PHP Manual
  • Swoole\Server
  • Trigger a callback function after a period of time.

Swoole\Server::after

(PECL swoole >= 1.9.0)

Swoole\Server::after — Trigger a callback function after a period of time.

Descripción

public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType

Parámetros

after_time_ms

callback

param

Valores devueltos


Bind the connection to a user defined user ID.

  • « Swoole\Server::after
  • Swoole\Server::clearTimer »
  • PHP Manual
  • Swoole\Server
  • Bind the connection to a user defined user ID.

Swoole\Server::bind

(PECL swoole >= 1.9.0)

Swoole\Server::bind — Bind the connection to a user defined user ID.

Descripción

public Swoole\Server::bind ( int $fd , int $uid ) : bool

Parámetros

fd

uid

Valores devueltos


Stop and destory a timer.

  • « Swoole\Server::bind
  • Swoole\Server::close »
  • PHP Manual
  • Swoole\Server
  • Stop and destory a timer.

Swoole\Server::clearTimer

swoole_timer_clear

(PECL swoole >= 1.9.0)

Swoole\Server::clearTimer -- swoole_timer_clear — Stop and destory a timer.

Descripción

Estilo orientado a objetos (method):

public Swoole\Server::clearTimer ( int $timer_id ) : void

Estilo por procedimientos:

swoole_timer_clear ( int $timer_id ) : void

Stop and destory a timer

Parámetros

timer_id

Valores devueltos


Close a connection to the client.

  • « Swoole\Server::clearTimer
  • Swoole\Server::confirm »
  • PHP Manual
  • Swoole\Server
  • Close a connection to the client.

Swoole\Server::close

(PECL swoole >= 1.9.0)

Swoole\Server::close — Close a connection to the client.

Descripción

public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool

Parámetros

fd

reset

Valores devueltos


Check status of the connection.

  • « Swoole\Server::close
  • Swoole\Server::connection_info »
  • PHP Manual
  • Swoole\Server
  • Check status of the connection.

Swoole\Server::confirm

(PECL swoole >= 1.9.0)

Swoole\Server::confirm — Check status of the connection.

Descripción

public Swoole\Server::confirm ( int $fd ) : bool

Parámetros

fd

Valores devueltos


Get the connection info by file description.

  • « Swoole\Server::confirm
  • Swoole\Server::connection_list »
  • PHP Manual
  • Swoole\Server
  • Get the connection info by file description.

Swoole\Server::connection_info

(PECL swoole >= 1.9.0)

Swoole\Server::connection_info — Get the connection info by file description.

Descripción

public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array

Parámetros

fd

reactor_id

Valores devueltos


Get all of the established connections.

  • « Swoole\Server::connection_info
  • Swoole\Server::__construct »
  • PHP Manual
  • Swoole\Server
  • Get all of the established connections.

Swoole\Server::connection_list

(PECL swoole >= 1.9.0)

Swoole\Server::connection_list — Get all of the established connections.

Descripción

public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array

Parámetros

start_fd

pagesize

Valores devueltos


Construct a Swoole server.

  • « Swoole\Server::connection_list
  • Swoole\Server::defer »
  • PHP Manual
  • Swoole\Server
  • Construct a Swoole server.

Swoole\Server::__construct

(PECL swoole >= 1.9.0)

Swoole\Server::__construct — Construct a Swoole server.

Descripción

public Swoole\Server::__construct ( string $host , int $port = ? , integr $mode = ? , int $sock_type = ? )

Parámetros

host

port

mode

sock_type


Delay execution of the callback function at the end of current EventLoop.

  • « Swoole\Server::__construct
  • Swoole\Server\Port::__construct »
  • PHP Manual
  • Swoole\Server
  • Delay execution of the callback function at the end of current EventLoop.

Swoole\Server::defer

(PECL swoole >= 1.9.0)

Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.

Descripción

public Swoole\Server::defer ( callable $callback ) : void

Parámetros

callback

Valores devueltos


Construct a server port

  • « Swoole\Server::defer
  • Swoole\Server\Port::__destruct »
  • PHP Manual
  • Swoole\Server
  • Construct a server port

Swoole\Server\Port::__construct

(PECL swoole >= 1.9.0)

Swoole\Server\Port::__construct — Construct a server port

Descripción

private Swoole\Server\Port::__construct ( )

Parámetros

Esta función no tiene parámetros.


Destory server port

  • « Swoole\Server\Port::__construct
  • Swoole\Server\Port::on »
  • PHP Manual
  • Swoole\Server
  • Destory server port

Swoole\Server\Port::__destruct

(PECL swoole >= 1.9.0)

Swoole\Server\Port::__destruct — Destory server port

Descripción

public Swoole\Server\Port::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Register callback functions by event.

  • « Swoole\Server\Port::__destruct
  • Swoole\Server\Port::set »
  • PHP Manual
  • Swoole\Server
  • Register callback functions by event.

Swoole\Server\Port::on

(PECL swoole >= 1.9.0)

Swoole\Server\Port::on — Register callback functions by event.

Descripción

public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType

Parámetros

event_name

callback

Valores devueltos


Set protocol of the server port.

  • « Swoole\Server\Port::on
  • Swoole\Server::exist »
  • PHP Manual
  • Swoole\Server
  • Set protocol of the server port.

Swoole\Server\Port::set

(PECL swoole >= 1.9.0)

Swoole\Server\Port::set — Set protocol of the server port.

Descripción

public Swoole\Server\Port::set ( array $settings ) : void

Parámetros

settings

Valores devueltos


Check if the connection is existed.

  • « Swoole\Server\Port::set
  • Swoole\Server::finish »
  • PHP Manual
  • Swoole\Server
  • Check if the connection is existed.

Swoole\Server::exist

(PECL swoole >= 1.9.0)

Swoole\Server::exist — Check if the connection is existed.

Descripción

public Swoole\Server::exist ( int $fd ) : bool

Parámetros

fd

Valores devueltos


Used in task process for sending result to the worker process when the task is finished.

  • « Swoole\Server::exist
  • Swoole\Server::getClientInfo »
  • PHP Manual
  • Swoole\Server
  • Used in task process for sending result to the worker process when the task is finished.

Swoole\Server::finish

(PECL swoole >= 1.9.0)

Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.

Descripción

public Swoole\Server::finish ( string $data ) : void

Parámetros

data

Valores devueltos


Get the connection info by file description.

  • « Swoole\Server::finish
  • Swoole\Server::getClientList »
  • PHP Manual
  • Swoole\Server
  • Get the connection info by file description.

Swoole\Server::getClientInfo

(PECL swoole >= 1.9.0)

Swoole\Server::getClientInfo — Get the connection info by file description.

Descripción

public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType

Parámetros

fd

reactor_id

Valores devueltos


Get all of the established connections.

  • « Swoole\Server::getClientInfo
  • Swoole\Server::getLastError »
  • PHP Manual
  • Swoole\Server
  • Get all of the established connections.

Swoole\Server::getClientList

(PECL swoole >= 1.9.0)

Swoole\Server::getClientList — Get all of the established connections.

Descripción

public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

start_fd

pagesize

Valores devueltos


Get the error code of the most recent error.

  • « Swoole\Server::getClientList
  • Swoole\Server::heartbeat »
  • PHP Manual
  • Swoole\Server
  • Get the error code of the most recent error.

Swoole\Server::getLastError

(PECL swoole >= 1.9.0)

Swoole\Server::getLastError — Get the error code of the most recent error.

Descripción

public Swoole\Server::getLastError ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Check all the connections on the server.

  • « Swoole\Server::getLastError
  • Swoole\Server::listen »
  • PHP Manual
  • Swoole\Server
  • Check all the connections on the server.

Swoole\Server::heartbeat

(PECL swoole >= 1.9.0)

Swoole\Server::heartbeat — Check all the connections on the server.

Descripción

public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed

Parámetros

if_close_connection

Valores devueltos


Listen on the given IP and port, socket type.

  • « Swoole\Server::heartbeat
  • Swoole\Server::on »
  • PHP Manual
  • Swoole\Server
  • Listen on the given IP and port, socket type.

Swoole\Server::listen

(PECL swoole >= 1.9.0)

Swoole\Server::listen — Listen on the given IP and port, socket type.

Descripción

public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool

Parámetros

host

port

socket_type

Valores devueltos


Register a callback function by event name.

  • « Swoole\Server::listen
  • Swoole\Server::pause »
  • PHP Manual
  • Swoole\Server
  • Register a callback function by event name.

Swoole\Server::on

(PECL swoole >= 1.9.0)

Swoole\Server::on — Register a callback function by event name.

Descripción

public Swoole\Server::on ( string $event_name , callable $callback ) : void

Parámetros

event_name

callback

Valores devueltos


Stop receiving data from the connection.

  • « Swoole\Server::on
  • Swoole\Server::protect »
  • PHP Manual
  • Swoole\Server
  • Stop receiving data from the connection.

Swoole\Server::pause

(PECL swoole >= 1.9.0)

Swoole\Server::pause — Stop receiving data from the connection.

Descripción

public Swoole\Server::pause ( int $fd ) : void

Parámetros

fd

Valores devueltos


Set the connection to be protected mode.

  • « Swoole\Server::pause
  • Swoole\Server::reload »
  • PHP Manual
  • Swoole\Server
  • Set the connection to be protected mode.

Swoole\Server::protect

(PECL swoole >= 1.9.0)

Swoole\Server::protect — Set the connection to be protected mode.

Descripción

public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void

Parámetros

fd

is_protected

Valores devueltos


Restart all the worker process.

  • « Swoole\Server::protect
  • Swoole\Server::resume »
  • PHP Manual
  • Swoole\Server
  • Restart all the worker process.

Swoole\Server::reload

(PECL swoole >= 1.9.0)

Swoole\Server::reload — Restart all the worker process.

Descripción

public Swoole\Server::reload ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Start receving data from the connection.

  • « Swoole\Server::reload
  • Swoole\Server::send »
  • PHP Manual
  • Swoole\Server
  • Start receving data from the connection.

Swoole\Server::resume

(PECL swoole >= 1.9.0)

Swoole\Server::resume — Start receving data from the connection.

Descripción

public Swoole\Server::resume ( int $fd ) : void

Parámetros

fd

Valores devueltos


Send data to the client.

  • « Swoole\Server::resume
  • Swoole\Server::sendfile »
  • PHP Manual
  • Swoole\Server
  • Send data to the client.

Swoole\Server::send

(PECL swoole >= 1.9.0)

Swoole\Server::send — Send data to the client.

Descripción

public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fd

data

reactor_id

Valores devueltos


Send file to the connection.

  • « Swoole\Server::send
  • Swoole\Server::sendMessage »
  • PHP Manual
  • Swoole\Server
  • Send file to the connection.

Swoole\Server::sendfile

(PECL swoole >= 1.9.0)

Swoole\Server::sendfile — Send file to the connection.

Descripción

public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fd

filename

offset

Valores devueltos


Send message to worker processes by ID.

  • « Swoole\Server::sendfile
  • Swoole\Server::sendto »
  • PHP Manual
  • Swoole\Server
  • Send message to worker processes by ID.

Swoole\Server::sendMessage

(PECL swoole >= 1.9.0)

Swoole\Server::sendMessage — Send message to worker processes by ID.

Descripción

public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool

Parámetros

dst_worker_id

data

Valores devueltos


Send data to the remote UDP address.

  • « Swoole\Server::sendMessage
  • Swoole\Server::sendwait »
  • PHP Manual
  • Swoole\Server
  • Send data to the remote UDP address.

Swoole\Server::sendto

(PECL swoole >= 1.9.0)

Swoole\Server::sendto — Send data to the remote UDP address.

Descripción

public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool

Parámetros

ip

port

data

server_socket

Valores devueltos


Send data to the remote socket in the blocking way.

  • « Swoole\Server::sendto
  • Swoole\Server::set »
  • PHP Manual
  • Swoole\Server
  • Send data to the remote socket in the blocking way.

Swoole\Server::sendwait

(PECL swoole >= 1.9.0)

Swoole\Server::sendwait — Send data to the remote socket in the blocking way.

Descripción

public Swoole\Server::sendwait ( int $fd , string $data ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fd

data

Valores devueltos


Set the runtime settings of the swoole server.

  • « Swoole\Server::sendwait
  • Swoole\Server::shutdown »
  • PHP Manual
  • Swoole\Server
  • Set the runtime settings of the swoole server.

Swoole\Server::set

(PECL swoole >= 1.9.0)

Swoole\Server::set — Set the runtime settings of the swoole server.

Descripción

public Swoole\Server::set ( array $settings ) : ReturnType

Set the runtime settings of the swoole server. The settings can be accessed by $server->setting when the swoole server has started.

Parámetros

settings

Valores devueltos


Shutdown the master server process, this function can be called in worker processes.

  • « Swoole\Server::set
  • Swoole\Server::start »
  • PHP Manual
  • Swoole\Server
  • Shutdown the master server process, this function can be called in worker processes.

Swoole\Server::shutdown

(PECL swoole >= 1.9.0)

Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.

Descripción

public Swoole\Server::shutdown ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Start the Swoole server.

  • « Swoole\Server::shutdown
  • Swoole\Server::stats »
  • PHP Manual
  • Swoole\Server
  • Start the Swoole server.

Swoole\Server::start

(PECL swoole >= 1.9.0)

Swoole\Server::start — Start the Swoole server.

Descripción

public Swoole\Server::start ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the stats of the Swoole server.

  • « Swoole\Server::start
  • Swoole\Server::stop »
  • PHP Manual
  • Swoole\Server
  • Get the stats of the Swoole server.

Swoole\Server::stats

(PECL swoole >= 1.9.0)

Swoole\Server::stats — Get the stats of the Swoole server.

Descripción

public Swoole\Server::stats ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Stop the Swoole server.

  • « Swoole\Server::stats
  • Swoole\Server::task »
  • PHP Manual
  • Swoole\Server
  • Stop the Swoole server.

Swoole\Server::stop

(PECL swoole >= 1.9.0)

Swoole\Server::stop — Stop the Swoole server.

Descripción

public Swoole\Server::stop ( int $worker_id = ? ) : bool

Parámetros

worker_id

Valores devueltos


Send data to the task worker processes.

  • « Swoole\Server::stop
  • Swoole\Server::taskwait »
  • PHP Manual
  • Swoole\Server
  • Send data to the task worker processes.

Swoole\Server::task

(PECL swoole >= 1.9.0)

Swoole\Server::task — Send data to the task worker processes.

Descripción

public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

dst_worker_id

callback

Valores devueltos


Send data to the task worker processes in blocking way.

  • « Swoole\Server::task
  • Swoole\Server::taskWaitMulti »
  • PHP Manual
  • Swoole\Server
  • Send data to the task worker processes in blocking way.

Swoole\Server::taskwait

(PECL swoole >= 1.9.0)

Swoole\Server::taskwait — Send data to the task worker processes in blocking way.

Descripción

public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

data

timeout

worker_id

Valores devueltos


Execute multiple tasks concurrently.

  • « Swoole\Server::taskwait
  • Swoole\Server::tick »
  • PHP Manual
  • Swoole\Server
  • Execute multiple tasks concurrently.

Swoole\Server::taskWaitMulti

(PECL swoole >= 1.9.0)

Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.

Descripción

public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void

Parámetros

tasks

timeout_ms

Valores devueltos


Repeats a given function at every given time-interval.

  • « Swoole\Server::taskWaitMulti
  • Swoole\Table »
  • PHP Manual
  • Swoole\Server
  • Repeats a given function at every given time-interval.

Swoole\Server::tick

(PECL swoole >= 1.9.0)

Swoole\Server::tick — Repeats a given function at every given time-interval.

Descripción

public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void

Parámetros

interval_ms

callback

Valores devueltos


The Swoole\Table class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Table implements Iterator , Countable {
/* Constants */
const int TYPE_INT = 1 ;
const int TYPE_STRING = 7 ;
const int TYPE_FLOAT = 6 ;
/* Métodos */
public column ( string $name , string $type , int $size = ? ) : ReturnType
public count ( ) : int
public create ( ) : void
public current ( ) : array
public decr ( string $key , string $column , int $decrby = ? ) : ReturnType
public del ( string $key ) : void
public destroy ( ) : void
public exist ( string $key ) : bool
public get ( string $row_key , string $column_key ) : int
public incr ( string $key , string $column , int $incrby = ? ) : void
public key ( ) : string
public next ( ) : ReturnType
public rewind ( ) : void
public set ( string $key , array $value ) : VOID
public valid ( ) : bool
}

Constantes predefinidas

Swoole\Table::TYPE_INT

Swoole\Table::TYPE_STRING

Swoole\Table::TYPE_FLOAT

Tabla de contenidos

  • Swoole\Table::column — Set the data type and size of the columns.
  • Swoole\Table::__construct — Construct a Swoole memory table with fixed size.
  • Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.
  • Swoole\Table::create — Create the swoole memory table.
  • Swoole\Table::current — Get the current row.
  • Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.
  • Swoole\Table::del — Delete a row in the Swoole table by $row_key.
  • Swoole\Table::destroy — Destroy the Swoole table.
  • Swoole\Table::exist — Check if a row is existed by $row_key.
  • Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.
  • Swoole\Table::incr — Increment the value by $row_key and $column_key.
  • Swoole\Table::key — Get the key of current row.
  • Swoole\Table::next — Iterator the next row.
  • Swoole\Table::rewind — Rewind the iterator.
  • Swoole\Table::set — Update a row of the table by $row_key.
  • Swoole\Table::valid — Check current if the current row is valid.


Set the data type and size of the columns.

  • « Swoole\Table
  • Swoole\Table::__construct »
  • PHP Manual
  • Swoole\Table
  • Set the data type and size of the columns.

Swoole\Table::column

(PECL swoole >= 1.9.0)

Swoole\Table::column — Set the data type and size of the columns.

Descripción

public Swoole\Table::column ( string $name , string $type , int $size = ? ) : ReturnType

Parámetros

name

type

size

Valores devueltos


Construct a Swoole memory table with fixed size.

  • « Swoole\Table::column
  • Swoole\Table::count »
  • PHP Manual
  • Swoole\Table
  • Construct a Swoole memory table with fixed size.

Swoole\Table::__construct

(PECL swoole >= 1.9.0)

Swoole\Table::__construct — Construct a Swoole memory table with fixed size.

Descripción

public Swoole\Table::__construct ( int $table_size )

Parámetros

table_size


Count the rows in the table, or count all the elements in the table if $mode = 1.

  • « Swoole\Table::__construct
  • Swoole\Table::create »
  • PHP Manual
  • Swoole\Table
  • Count the rows in the table, or count all the elements in the table if $mode = 1.

Swoole\Table::count

(PECL swoole >= 1.9.0)

Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.

Descripción

public Swoole\Table::count ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Create the swoole memory table.

  • « Swoole\Table::count
  • Swoole\Table::current »
  • PHP Manual
  • Swoole\Table
  • Create the swoole memory table.

Swoole\Table::create

(PECL swoole >= 1.9.0)

Swoole\Table::create — Create the swoole memory table.

Descripción

public Swoole\Table::create ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get the current row.

  • « Swoole\Table::create
  • Swoole\Table::decr »
  • PHP Manual
  • Swoole\Table
  • Get the current row.

Swoole\Table::current

(PECL swoole >= 1.9.0)

Swoole\Table::current — Get the current row.

Descripción

public Swoole\Table::current ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Decrement the value in the Swoole table by $row_key and $column_key.

  • « Swoole\Table::current
  • Swoole\Table::del »
  • PHP Manual
  • Swoole\Table
  • Decrement the value in the Swoole table by $row_key and $column_key.

Swoole\Table::decr

(PECL swoole >= 1.9.0)

Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.

Descripción

public Swoole\Table::decr ( string $key , string $column , int $decrby = ? ) : ReturnType

Parámetros

key

column

decrby

Valores devueltos


Delete a row in the Swoole table by $row_key.

  • « Swoole\Table::decr
  • Swoole\Table::destroy »
  • PHP Manual
  • Swoole\Table
  • Delete a row in the Swoole table by $row_key.

Swoole\Table::del

(PECL swoole >= 1.9.0)

Swoole\Table::del — Delete a row in the Swoole table by $row_key.

Descripción

public Swoole\Table::del ( string $key ) : void

Parámetros

key

Valores devueltos


Destroy the Swoole table.

  • « Swoole\Table::del
  • Swoole\Table::exist »
  • PHP Manual
  • Swoole\Table
  • Destroy the Swoole table.

Swoole\Table::destroy

(PECL swoole >= 1.9.0)

Swoole\Table::destroy — Destroy the Swoole table.

Descripción

public Swoole\Table::destroy ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Check if a row is existed by $row_key.

  • « Swoole\Table::destroy
  • Swoole\Table::get »
  • PHP Manual
  • Swoole\Table
  • Check if a row is existed by $row_key.

Swoole\Table::exist

(PECL swoole >= 1.9.0)

Swoole\Table::exist — Check if a row is existed by $row_key.

Descripción

public Swoole\Table::exist ( string $key ) : bool

Parámetros

key

Valores devueltos


Get the value in the Swoole table by $row_key and $column_key.

  • « Swoole\Table::exist
  • Swoole\Table::incr »
  • PHP Manual
  • Swoole\Table
  • Get the value in the Swoole table by $row_key and $column_key.

Swoole\Table::get

(PECL swoole >= 1.9.0)

Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.

Descripción

public Swoole\Table::get ( string $row_key , string $column_key ) : int

Parámetros

row_key

column_key

Valores devueltos


Increment the value by $row_key and $column_key.

  • « Swoole\Table::get
  • Swoole\Table::key »
  • PHP Manual
  • Swoole\Table
  • Increment the value by $row_key and $column_key.

Swoole\Table::incr

(PECL swoole >= 1.9.0)

Swoole\Table::incr — Increment the value by $row_key and $column_key.

Descripción

public Swoole\Table::incr ( string $key , string $column , int $incrby = ? ) : void

Parámetros

key

column

incrby

Valores devueltos


Get the key of current row.

  • « Swoole\Table::incr
  • Swoole\Table::next »
  • PHP Manual
  • Swoole\Table
  • Get the key of current row.

Swoole\Table::key

(PECL swoole >= 1.9.0)

Swoole\Table::key — Get the key of current row.

Descripción

public Swoole\Table::key ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Iterator the next row.

  • « Swoole\Table::key
  • Swoole\Table::rewind »
  • PHP Manual
  • Swoole\Table
  • Iterator the next row.

Swoole\Table::next

(PECL swoole >= 1.9.0)

Swoole\Table::next — Iterator the next row.

Descripción

public Swoole\Table::next ( ) : ReturnType

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Rewind the iterator.

  • « Swoole\Table::next
  • Swoole\Table::set »
  • PHP Manual
  • Swoole\Table
  • Rewind the iterator.

Swoole\Table::rewind

(PECL swoole >= 1.9.0)

Swoole\Table::rewind — Rewind the iterator.

Descripción

public Swoole\Table::rewind ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Update a row of the table by $row_key.

  • « Swoole\Table::rewind
  • Swoole\Table::valid »
  • PHP Manual
  • Swoole\Table
  • Update a row of the table by $row_key.

Swoole\Table::set

(PECL swoole >= 1.9.0)

Swoole\Table::set — Update a row of the table by $row_key.

Descripción

public Swoole\Table::set ( string $key , array $value ) : VOID

Parámetros

key

value

Valores devueltos


Check current if the current row is valid.

  • « Swoole\Table::set
  • Swoole\Timer »
  • PHP Manual
  • Swoole\Table
  • Check current if the current row is valid.

Swoole\Table::valid

(PECL swoole >= 1.9.0)

Swoole\Table::valid — Check current if the current row is valid.

Descripción

public Swoole\Table::valid ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The Swoole\Timer class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\Timer {
/* Métodos */
public static after ( int $after_time_ms , callable $callback ) : void
public static clear ( int $timer_id ) : void
public static exists ( int $timer_id ) : bool
public static tick ( int $interval_ms , callable $callback , string $param = ? ) : void
}

Tabla de contenidos

  • Swoole\Timer::after — Trigger a callback function after a period of time.
  • Swoole\Timer::clear — Delete a timer by timer ID.
  • Swoole\Timer::exists — Check if a timer is existed.
  • Swoole\Timer::tick — Repeats a given function at every given time-interval.


Trigger a callback function after a period of time.

  • « Swoole\Timer
  • Swoole\Timer::clear »
  • PHP Manual
  • Swoole\Timer
  • Trigger a callback function after a period of time.

Swoole\Timer::after

(PECL swoole >= 1.9.0)

Swoole\Timer::after — Trigger a callback function after a period of time.

Descripción

public static Swoole\Timer::after ( int $after_time_ms , callable $callback ) : void

Trigger a callback function after a period of time.

Parámetros

after_time_ms

callback

Valores devueltos


Delete a timer by timer ID.

  • « Swoole\Timer::after
  • Swoole\Timer::exists »
  • PHP Manual
  • Swoole\Timer
  • Delete a timer by timer ID.

Swoole\Timer::clear

(PECL swoole >= 1.9.0)

Swoole\Timer::clear — Delete a timer by timer ID.

Descripción

public static Swoole\Timer::clear ( int $timer_id ) : void

Delete a timer by timer ID.

Parámetros

timer_id

Valores devueltos


Check if a timer is existed.

  • « Swoole\Timer::clear
  • Swoole\Timer::tick »
  • PHP Manual
  • Swoole\Timer
  • Check if a timer is existed.

Swoole\Timer::exists

(PECL swoole >= 1.9.0)

Swoole\Timer::exists — Check if a timer is existed.

Descripción

public static Swoole\Timer::exists ( int $timer_id ) : bool

Check if a timer is existed.

Parámetros

timer_id

Valores devueltos


Repeats a given function at every given time-interval.

  • « Swoole\Timer::exists
  • Swoole\WebSocket\Frame »
  • PHP Manual
  • Swoole\Timer
  • Repeats a given function at every given time-interval.

Swoole\Timer::tick

(PECL swoole >= 1.9.0)

Swoole\Timer::tick — Repeats a given function at every given time-interval.

Descripción

public static Swoole\Timer::tick ( int $interval_ms , callable $callback , string $param = ? ) : void

Parámetros

interval_ms

callback

param

Valores devueltos


The Swoole\WebSocket\Frame class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\WebSocket\Frame {
/* Métodos */
}


The Swoole\WebSocket\Server class

(PECL swoole >= 1.9.0)

Introducción

Sinopsis de la Clase

Swoole\WebSocket\Server extends Swoole\Http\Server {
/* Métodos */
public exist ( int $fd ) : bool
public on ( string $event_name , callable $callback ) : ReturnType
public static pack ( string $data , string $opcode = ? , string $finish = ? , string $mask = ? ) : binary
public push ( string $fd , string $data , string $opcode = ? , string $finish = ? ) : void
public static unpack ( binary $data ) : string
/* Métodos heredados */
public Swoole\Http\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Http\Server::start ( ) : void
}

Tabla de contenidos

  • Swoole\WebSocket\Server::exist — Check if the file descriptor exists.
  • Swoole\WebSocket\Server::on — Register event callback function
  • Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.
  • Swoole\WebSocket\Server::push — Push data to the remote client.
  • Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.


Check if the file descriptor exists.

  • « Swoole\WebSocket\Server
  • Swoole\WebSocket\Server::on »
  • PHP Manual
  • Swoole\WebSocket\Server
  • Check if the file descriptor exists.

Swoole\WebSocket\Server::exist

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::exist — Check if the file descriptor exists.

Descripción

public Swoole\WebSocket\Server::exist ( int $fd ) : bool

Parámetros

fd

Valores devueltos


Register event callback function

  • « Swoole\WebSocket\Server::exist
  • Swoole\WebSocket\Server::pack »
  • PHP Manual
  • Swoole\WebSocket\Server
  • Register event callback function

Swoole\WebSocket\Server::on

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::on — Register event callback function

Descripción

public Swoole\WebSocket\Server::on ( string $event_name , callable $callback ) : ReturnType

Register event callback function

Parámetros

event_name

callback

Valores devueltos


Get a pack of binary data to send in a single frame.

  • « Swoole\WebSocket\Server::on
  • Swoole\WebSocket\Server::push »
  • PHP Manual
  • Swoole\WebSocket\Server
  • Get a pack of binary data to send in a single frame.

Swoole\WebSocket\Server::pack

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.

Descripción

public static Swoole\WebSocket\Server::pack ( string $data , string $opcode = ? , string $finish = ? , string $mask = ? ) : binary

Parámetros

data

opcode

finish

mask

Valores devueltos


Push data to the remote client.

  • « Swoole\WebSocket\Server::pack
  • Swoole\WebSocket\Server::unpack »
  • PHP Manual
  • Swoole\WebSocket\Server
  • Push data to the remote client.

Swoole\WebSocket\Server::push

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::push — Push data to the remote client.

Descripción

public Swoole\WebSocket\Server::push ( string $fd , string $data , string $opcode = ? , string $finish = ? ) : void

Parámetros

fd

data

opcode

finish

Valores devueltos


Unpack the binary data received from the client.

  • « Swoole\WebSocket\Server::push
  • Tidy »
  • PHP Manual
  • Swoole\WebSocket\Server
  • Unpack the binary data received from the client.

Swoole\WebSocket\Server::unpack

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.

Descripción

public static Swoole\WebSocket\Server::unpack ( binary $data ) : string

Parámetros

data

Valores devueltos


Tidy

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ejemplos de Tidy
  • Tidy — La clase tidy
    • tidy::body — Devuelve un objeto tidyNode empezando con la etiqueta <body>
    • tidy::cleanRepair — Ejecuta una operación de limpieza y reparación de las etiquetas HTML
    • tidy::__construct — Construye un nuevo objeto tidy
    • tidy::diagnose — Ejecuta un diagnóstico sobre documento analizado y reparado
    • tidy::$errorBuffer — Devuelve advertencias y errores que ocurrieron al analizar el documento especificado
    • tidy::getConfig — Obtiene la configuración actual de Tidy
    • tidy::getHtmlVer — Obtiene la versión detectada de HTML en un documento especificado
    • tidy::getOpt — Devuelve el valor de la opción de configuración especificada para el documento tidy
    • tidy::getOptDoc — Devuelve la documentación correspondiente a un nombre de opción dado
    • tidy::getRelease — Obtiene la fecha de lanzamiento (versión) de la librería Tidy
    • tidy::getStatus — Obtiene el status de un documento especificado
    • tidy::head — Devuelve un objeto tidyNode empezando con la etiqueta <head>
    • tidy::html — Devuelve un objeto tidyNode empezando con la etiqueta <html>
    • tidy::isXhtml — Indica si el documento es XHTML
    • tidy::isXml — Indica si el documento es XML (no HTML/XHTML)
    • tidy::parseFile — Analiza las etiquetas de un fichero o URI
    • tidy::parseString — Analiza un documento almacenado en una cadena
    • tidy::repairFile — Repara un archivo y lo devuelve como una cadena
    • tidy::repairString — Repara una cadena HTML usando un archivo de configuración opcional
    • tidy::root — Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy
  • tidyNode — La clase tidyNode
    • tidyNode::__construct — Private constructor to disallow direct instantiation
    • tidyNode::getParent — Devuelve el nodo padre del nodo actual
    • tidyNode::hasChildren — Indica si un nodo tiene hijos
    • tidyNode::hasSiblings — Indica si un nodo tiene hermanos
    • tidyNode::isAsp — Comprueba si el nodo es ASP
    • tidyNode::isComment — Comprueba el nodo actual es un comentario
    • tidyNode::isHtml — Comprueba si el nodo es parte de un documento HTML
    • tidyNode::isJste — Comprueba si el nodo es JSTE
    • tidyNode::isPhp — Comprueba si el nodo es PHP
    • tidyNode::isText — Comprueba si un nodo representa un texto (no HTML)
  • Funciones de Tidy
    • ob_tidyhandler — Función callback de ob_start para reparar el buffer
    • tidy_access_count — Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado
    • tidy_config_count — Devuelve el número de errores de configuración Tidy encontrados en un documento dado
    • tidy_error_count — Devuelve el número de errores Tidy encontrados en un documento dado
    • tidy_get_output — Devuelve una cadena que contiene las etiquetas analizadas por Tidy
    • tidy_warning_count — Devuelve el número de alertas encontradas en un documendo dado


Introducción

Tidy es una envoltura para la utilidad de limpieza y reparación de HTML Tidy, la cual permite no sólo la limpieza y manipulación de documentos HTML, sino también recorrer el árbol del documento.


Requerimientos

Para usar Tidy, se necesita tener la librería libtidy instalada, disponible en la página oficial » http://tidy.sourceforge.net/.


Instalación

Esta extensión está ligada con PHP 5 y superiores, y se instala usando la opción de configuración --with-tidy.

Lo usuarios de PHP 4 pueden usar la (vieja) extensión PECL aquí: » https://pecl.php.net/package/tidy.

Nota:

Tidy 1.0 es para PHP 4, mientras que las versiones más recientes de la extensión Tidy son para PHP 5 y superiores.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración de Tidy
Nombre | Por defecto | Cambiable | Historial de cambios
tidy.default_config | "" | PHP_INI_SYSTEM |
tidy.clean_output | "0" | PHP_INI_USER | PHP_INI_PERDIR antes de PHP 5.4.0
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

tidy.default_config string

Ruta por defecto al archivo de configuración tidy.

tidy.clean_output boolean

Activa/Desactiva la reparación del HTML por Tidy.

Advertencia

No active tidy.clean_output si usted está generando contenido distinto al html, como por ejemplo imágenes dinámicas.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Cada TIDY_TAG_XXX representa una etiqueta HTML. Por ejemplo, TIDY_TAG_A representa una etiqueta "<a href="XX">link</a>". Cada TIDY_ATTR_XXX representa un atributo HTML. Por ejemplo TIDY_ATTR_HREF representaría al atributo href en el ejemplo anterior.

Las siguientes constantes son definidas:

Constantes de etiquetas tidy
constant
TIDY_TAG_UNKNOWN
TIDY_TAG_A
TIDY_TAG_ABBR
TIDY_TAG_ACRONYM
TIDY_TAG_ALIGN
TIDY_TAG_APPLET
TIDY_TAG_AREA
TIDY_TAG_B
TIDY_TAG_BASE
TIDY_TAG_BASEFONT
TIDY_TAG_BDO
TIDY_TAG_BGSOUND
TIDY_TAG_BIG
TIDY_TAG_BLINK
TIDY_TAG_BLOCKQUOTE
TIDY_TAG_BODY
TIDY_TAG_BR
TIDY_TAG_BUTTON
TIDY_TAG_CAPTION
TIDY_TAG_CENTER
TIDY_TAG_CITE
TIDY_TAG_CODE
TIDY_TAG_COL
TIDY_TAG_COLGROUP
TIDY_TAG_COMMENT
TIDY_TAG_DD
TIDY_TAG_DEL
TIDY_TAG_DFN
TIDY_TAG_DIR
TIDY_TAG_DIV
TIDY_TAG_DL
TIDY_TAG_DT
TIDY_TAG_EM
TIDY_TAG_EMBED
TIDY_TAG_FIELDSET
TIDY_TAG_FONT
TIDY_TAG_FORM
TIDY_TAG_FRAME
TIDY_TAG_FRAMESET
TIDY_TAG_H1
TIDY_TAG_H2
TIDY_TAG_H3
TIDY_TAG_H4
TIDY_TAG_H5
TIDY_TAG_H6
TIDY_TAG_HEAD
TIDY_TAG_HR
TIDY_TAG_HTML
TIDY_TAG_I
TIDY_TAG_IFRAME
TIDY_TAG_ILAYER
TIDY_TAG_IMG
TIDY_TAG_INPUT
TIDY_TAG_INS
TIDY_TAG_ISINDEX
TIDY_TAG_KBD
TIDY_TAG_KEYGEN
TIDY_TAG_LABEL
TIDY_TAG_LAYER
TIDY_TAG_LEGEND
TIDY_TAG_LI
TIDY_TAG_LINK
TIDY_TAG_LISTING
TIDY_TAG_MAP
TIDY_TAG_MARQUEE
TIDY_TAG_MENU
TIDY_TAG_META
TIDY_TAG_MULTICOL
TIDY_TAG_NOBR
TIDY_TAG_NOEMBED
TIDY_TAG_NOFRAMES
TIDY_TAG_NOLAYER
TIDY_TAG_NOSAVE
TIDY_TAG_NOSCRIPT
TIDY_TAG_OBJECT
TIDY_TAG_OL
TIDY_TAG_OPTGROUP
TIDY_TAG_OPTION
TIDY_TAG_P
TIDY_TAG_PARAM
TIDY_TAG_PLAINTEXT
TIDY_TAG_PRE
TIDY_TAG_Q
TIDY_TAG_RP
TIDY_TAG_RT
TIDY_TAG_RTC
TIDY_TAG_RUBY
TIDY_TAG_S
TIDY_TAG_SAMP
TIDY_TAG_SCRIPT
TIDY_TAG_SELECT
TIDY_TAG_SERVER
TIDY_TAG_SERVLET
TIDY_TAG_SMALL
TIDY_TAG_SPACER
TIDY_TAG_SPAN
TIDY_TAG_STRIKE
TIDY_TAG_STRONG
TIDY_TAG_STYLE
TIDY_TAG_SUB
TIDY_TAG_TABLE
TIDY_TAG_TBODY
TIDY_TAG_TD
TIDY_TAG_TEXTAREA
TIDY_TAG_TFOOT
TIDY_TAG_TH
TIDY_TAG_THEAD
TIDY_TAG_TITLE
TIDY_TAG_TR
TIDY_TAG_TT
TIDY_TAG_U
TIDY_TAG_UL
TIDY_TAG_VAR
TIDY_TAG_WBR
TIDY_TAG_XMP

tidy attribute constants
constant
TIDY_ATTR_UNKNOWN
TIDY_ATTR_ABBR
TIDY_ATTR_ACCEPT
TIDY_ATTR_ACCEPT_CHARSET
TIDY_ATTR_ACCESSKEY
TIDY_ATTR_ACTION
TIDY_ATTR_ADD_DATE
TIDY_ATTR_ALIGN
TIDY_ATTR_ALINK
TIDY_ATTR_ALT
TIDY_ATTR_ARCHIVE
TIDY_ATTR_AXIS
TIDY_ATTR_BACKGROUND
TIDY_ATTR_BGCOLOR
TIDY_ATTR_BGPROPERTIES
TIDY_ATTR_BORDER
TIDY_ATTR_BORDERCOLOR
TIDY_ATTR_BOTTOMMARGIN
TIDY_ATTR_CELLPADDING
TIDY_ATTR_CELLSPACING
TIDY_ATTR_CHAR
TIDY_ATTR_CHAROFF
TIDY_ATTR_CHARSET
TIDY_ATTR_CHECKED
TIDY_ATTR_CITE
TIDY_ATTR_CLASS
TIDY_ATTR_CLASSID
TIDY_ATTR_CLEAR
TIDY_ATTR_CODE
TIDY_ATTR_CODEBASE
TIDY_ATTR_CODETYPE
TIDY_ATTR_COLOR
TIDY_ATTR_COLS
TIDY_ATTR_COLSPAN
TIDY_ATTR_COMPACT
TIDY_ATTR_CONTENT
TIDY_ATTR_COORDS
TIDY_ATTR_DATA
TIDY_ATTR_DATAFLD
TIDY_ATTR_DATAPAGESIZE
TIDY_ATTR_DATASRC
TIDY_ATTR_DATETIME
TIDY_ATTR_DECLARE
TIDY_ATTR_DEFER
TIDY_ATTR_DIR
TIDY_ATTR_DISABLED
TIDY_ATTR_ENCODING
TIDY_ATTR_ENCTYPE
TIDY_ATTR_FACE
TIDY_ATTR_FOR
TIDY_ATTR_FRAME
TIDY_ATTR_FRAMEBORDER
TIDY_ATTR_FRAMESPACING
TIDY_ATTR_GRIDX
TIDY_ATTR_GRIDY
TIDY_ATTR_HEADERS
TIDY_ATTR_HEIGHT
TIDY_ATTR_HREF
TIDY_ATTR_HREFLANG
TIDY_ATTR_HSPACE
TIDY_ATTR_HTTP_EQUIV
TIDY_ATTR_ID
TIDY_ATTR_ISMAP
TIDY_ATTR_LABEL
TIDY_ATTR_LANG
TIDY_ATTR_LANGUAGE
TIDY_ATTR_LAST_MODIFIED
TIDY_ATTR_LAST_VISIT
TIDY_ATTR_LEFTMARGIN
TIDY_ATTR_LINK
TIDY_ATTR_LONGDESC
TIDY_ATTR_LOWSRC
TIDY_ATTR_MARGINHEIGHT
TIDY_ATTR_MARGINWIDTH
TIDY_ATTR_MAXLENGTH
TIDY_ATTR_MEDIA
TIDY_ATTR_METHOD
TIDY_ATTR_MULTIPLE
TIDY_ATTR_NAME
TIDY_ATTR_NOHREF
TIDY_ATTR_NORESIZE
TIDY_ATTR_NOSHADE
TIDY_ATTR_NOWRAP
TIDY_ATTR_OBJECT
TIDY_ATTR_OnAFTERUPDATE
TIDY_ATTR_OnBEFOREUNLOAD
TIDY_ATTR_OnBEFOREUPDATE
TIDY_ATTR_OnBLUR
TIDY_ATTR_OnCHANGE
TIDY_ATTR_OnCLICK
TIDY_ATTR_OnDATAAVAILABLE
TIDY_ATTR_OnDATASETCHANGED
TIDY_ATTR_OnDATASETCOMPLETE
TIDY_ATTR_OnDBLCLICK
TIDY_ATTR_OnERRORUPDATE
TIDY_ATTR_OnFOCUS
TIDY_ATTR_OnKEYDOWN
TIDY_ATTR_OnKEYPRESS
TIDY_ATTR_OnKEYUP
TIDY_ATTR_OnLOAD
TIDY_ATTR_OnMOUSEDOWN
TIDY_ATTR_OnMOUSEMOVE
TIDY_ATTR_OnMOUSEOUT
TIDY_ATTR_OnMOUSEOVER
TIDY_ATTR_OnMOUSEUP
TIDY_ATTR_OnRESET
TIDY_ATTR_OnROWENTER
TIDY_ATTR_OnROWEXIT
TIDY_ATTR_OnSELECT
TIDY_ATTR_OnSUBMIT
TIDY_ATTR_OnUNLOAD
TIDY_ATTR_PROFILE
TIDY_ATTR_PROMPT
TIDY_ATTR_RBSPAN
TIDY_ATTR_READONLY
TIDY_ATTR_REL
TIDY_ATTR_REV
TIDY_ATTR_RIGHTMARGIN
TIDY_ATTR_ROWS
TIDY_ATTR_ROWSPAN
TIDY_ATTR_RULES
TIDY_ATTR_SCHEME
TIDY_ATTR_SCOPE
TIDY_ATTR_SCROLLING
TIDY_ATTR_SELECTED
TIDY_ATTR_SHAPE
TIDY_ATTR_SHOWGRID
TIDY_ATTR_SHOWGRIDX
TIDY_ATTR_SHOWGRIDY
TIDY_ATTR_SIZE
TIDY_ATTR_SPAN
TIDY_ATTR_SRC
TIDY_ATTR_STANDBY
TIDY_ATTR_START
TIDY_ATTR_STYLE
TIDY_ATTR_SUMMARY
TIDY_ATTR_TABINDEX
TIDY_ATTR_TARGET
TIDY_ATTR_TEXT
TIDY_ATTR_TITLE
TIDY_ATTR_TOPMARGIN
TIDY_ATTR_TYPE
TIDY_ATTR_USEMAP
TIDY_ATTR_VALIGN
TIDY_ATTR_VALUE
TIDY_ATTR_VALUETYPE
TIDY_ATTR_VERSION
TIDY_ATTR_VLINK
TIDY_ATTR_VSPACE
TIDY_ATTR_WIDTH
TIDY_ATTR_WRAP
TIDY_ATTR_XML_LANG
TIDY_ATTR_XML_SPACE
TIDY_ATTR_XMLNS

tidy nodetype constants
constant | description
TIDY_NODETYPE_ROOT | root node
TIDY_NODETYPE_DOCTYPE | doctype
TIDY_NODETYPE_COMMENT | HTML comment
TIDY_NODETYPE_PROCINS | Processing Instruction
TIDY_NODETYPE_TEXT | Text
TIDY_NODETYPE_START | start tag
TIDY_NODETYPE_END | end tag
TIDY_NODETYPE_STARTEND | empty tag
TIDY_NODETYPE_CDATA | CDATA
TIDY_NODETYPE_SECTION | XML section
TIDY_NODETYPE_ASP | ASP code
TIDY_NODETYPE_JSTE | JSTE code
TIDY_NODETYPE_PHP | PHP code
TIDY_NODETYPE_XMLDECL | XML declaration


  • « Constantes predefinidas
  • Ejemplos de Tidy »
  • PHP Manual
  • Tidy
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplos de Tidy


Ejemplos de Tidy

Este simple ejemplo muestra el uso básico de Tidy.

Ejemplo #1 Uso Básico Tidy

<?php
ob_start();
?>
<html>a html document</html>
<?php
$html = ob_get_clean();

// Specify configuration
$config = array(
           'indent'         => true,
           'output-xhtml'   => true,
           'wrap'           => 200);

// Tidy
$tidy = new tidy;
$tidy->parseString($html, $config, 'utf8');
$tidy->cleanRepair();

// Output
echo $tidy;
?>


La clase tidy

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

Introducción

Un nodo HTML en un fichero HTML, como es detectado por tidy.

Sinopsis de la Clase

tidy {
/* Propiedades */
string $errorBuffer;
/* Métodos */
public body ( ) : tidyNode
cleanRepair ( ) : bool
__construct ( string $filename = ? , mixed $config = ? , string $encoding = ? , bool $use_include_path = ? )
diagnose ( ) : bool
getConfig ( ) : array
getHtmlVer ( ) : int
getOpt ( string $option ) : mixed
getOptDoc ( string $optname ) : string
getRelease ( ) : string
getStatus ( ) : int
public head ( ) : tidyNode
public html ( ) : tidyNode
isXhtml ( ) : bool
isXml ( ) : bool
public parseFile ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : bool
public parseString ( string $input , mixed $config = ? , string $encoding = ? ) : bool
public repairFile ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : string
public repairString ( string $data , mixed $config = ? , string $encoding = ? ) : string
public root ( ) : tidyNode
}

Tabla de contenidos

  • tidy::body — Devuelve un objeto tidyNode empezando con la etiqueta <body>
  • tidy::cleanRepair — Ejecuta una operación de limpieza y reparación de las etiquetas HTML
  • tidy::__construct — Construye un nuevo objeto tidy
  • tidy::diagnose — Ejecuta un diagnóstico sobre documento analizado y reparado
  • tidy::$errorBuffer — Devuelve advertencias y errores que ocurrieron al analizar el documento especificado
  • tidy::getConfig — Obtiene la configuración actual de Tidy
  • tidy::getHtmlVer — Obtiene la versión detectada de HTML en un documento especificado
  • tidy::getOpt — Devuelve el valor de la opción de configuración especificada para el documento tidy
  • tidy::getOptDoc — Devuelve la documentación correspondiente a un nombre de opción dado
  • tidy::getRelease — Obtiene la fecha de lanzamiento (versión) de la librería Tidy
  • tidy::getStatus — Obtiene el status de un documento especificado
  • tidy::head — Devuelve un objeto tidyNode empezando con la etiqueta <head>
  • tidy::html — Devuelve un objeto tidyNode empezando con la etiqueta <html>
  • tidy::isXhtml — Indica si el documento es XHTML
  • tidy::isXml — Indica si el documento es XML (no HTML/XHTML)
  • tidy::parseFile — Analiza las etiquetas de un fichero o URI
  • tidy::parseString — Analiza un documento almacenado en una cadena
  • tidy::repairFile — Repara un archivo y lo devuelve como una cadena
  • tidy::repairString — Repara una cadena HTML usando un archivo de configuración opcional
  • tidy::root — Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy


Devuelve un objeto tidyNode empezando con la etiqueta <body>

  • « Tidy
  • tidy::cleanRepair »
  • PHP Manual
  • Tidy
  • Devuelve un objeto tidyNode empezando con la etiqueta <body>

tidy::body

tidy_get_body

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0)

tidy::body -- tidy_get_body — Devuelve un objeto tidyNode empezando con la etiqueta <body>

Descripción

Estilo orientado a objetos

public tidy::body ( ) : tidyNode

Estilo por procedimientos

tidy_get_body ( tidy $object ) : tidyNode

Devuelve un objeto tidyNode empezando por la etiqueta <body>.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve un objeto tidyNode empezando por la etiqueta <body> del árbol analizado por tidy.

Ejemplos

Ejemplo #1 Ejemplo de tidy::getBody()

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$body = $tidy->Body();
echo $body->value;
?>

El resultado del ejemplo sería:

<body>
<p>paragraph</p>
</body>

Ver también

  • tidy::head() - Devuelve un objeto tidyNode empezando con la etiqueta <head>
  • tidy::html() - Devuelve un objeto tidyNode empezando con la etiqueta <html>


Ejecuta una operación de limpieza y reparación de las etiquetas HTML

  • « tidy::body
  • tidy::__construct »
  • PHP Manual
  • Tidy
  • Ejecuta una operación de limpieza y reparación de las etiquetas HTML

tidy::cleanRepair

tidy_clean_repair

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::cleanRepair -- tidy_clean_repair — Ejecuta una operación de limpieza y reparación de las etiquetas HTML

Descripción

Estilo orientado a objetos

tidy::cleanRepair ( ) : bool

Estilo por procedimientos

tidy_clean_repair ( tidy $object ) : bool

Esta función limpia y repara el objeto object pasado como argumento.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de tidy::cleanrepair()

<?php
$html = '<p>test</I>';

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

echo $tidy;
?>

El resultado del ejemplo sería:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

Ver también

  • tidy::repairFile() - Repara un archivo y lo devuelve como una cadena
  • tidy::repairString() - Repara una cadena HTML usando un archivo de configuración opcional


Construye un nuevo objeto tidy

  • « tidy::cleanRepair
  • tidy::diagnose »
  • PHP Manual
  • Tidy
  • Construye un nuevo objeto tidy

tidy::__construct

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::__construct — Construye un nuevo objeto tidy

Descripción

tidy::__construct ( string $filename = ? , mixed $config = ? , string $encoding = ? , bool $use_include_path = ? )

Contruye un nuevo objeto tidy.

Parámetros

filename

Si el parámetro filename es indicado, esta función también leerá ese archivo e iniciará el objeto con el archivo, actuando como tidy_parse_file().

config

La configuración config puede ser pasada en forma de un array o una cadena. Si una cadena es pasada, será interpretada como el el nombre del archivo de configuración, de otra forma, será interpretada como opciones en sí mismas.

Para una explicación de cada opción, consulte » http://api.html-tidy.org/#quick-reference.

encoding

El parámetro encoding establece la codificación para entarda/salida de los documentos. Los posibles valores de codificación son: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, y shiftjis.

use_include_path

Busca el archivo en la ruta include_path.

Valores devueltos

Devuelve una nueva instancia de tidy.

Ejemplos

Ejemplo #1 Ejemplo de tidy::__construct()

<?php

$html = <<< HTML

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title>title</title></head>
<body>
<p>paragraph <bt />
text</p>
</body></html>

HTML;

$tidy = new tidy();
$tidy->ParseString($html);

$tidy->cleanRepair();

if ($tidy->errorBuffer) {
    echo "Los siguientes errores han sido detectados:\n";
    echo $tidy->errorBuffer;
}

?>

El resultado del ejemplo sería:

Los siguientes errores han sido detectados:
line 8 column 14 - Error: <bt> is not recognized!
line 8 column 14 - Warning: discarding unexpected <bt>

Ver también

  • tidy::parseFile() - Analiza las etiquetas de un fichero o URI
  • tidy::parseString() - Analiza un documento almacenado en una cadena


Ejecuta un diagnóstico sobre documento analizado y reparado

  • « tidy::__construct
  • tidy::$errorBuffer »
  • PHP Manual
  • Tidy
  • Ejecuta un diagnóstico sobre documento analizado y reparado

tidy::diagnose

tidy_diagnose

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::diagnose -- tidy_diagnose — Ejecuta un diagnóstico sobre documento analizado y reparado

Descripción

Estilo orientado a objetos

tidy::diagnose ( ) : bool

Estilo por procedimientos

tidy_diagnose ( tidy $object ) : bool

Ejecuta un diagnóstico sobre el objeto object tidy, añadiendo alguna información adicional sobre el documento en un buffer de errores.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de tidy::diagnose()

<?php

$html = <<< HTML
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<p>parrafo</p>
HTML;

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

// note the difference between the two outputs
echo $tidy->errorBuffer . "\n";

$tidy->diagnose();
echo $tidy->errorBuffer;

?>

El resultado del ejemplo sería:

line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
Info: Doctype given is "-//W3C//DTD XHTML 1.0 Strict//EN"
Info: Document content looks like XHTML 1.0 Strict
2 warnings, 0 errors were found!

Ver también

  • tidy::errorBuffer()


Devuelve advertencias y errores que ocurrieron al analizar el documento especificado

  • « tidy::diagnose
  • tidy::getConfig »
  • PHP Manual
  • Tidy
  • Devuelve advertencias y errores que ocurrieron al analizar el documento especificado

tidy::$errorBuffer

tidy_get_error_buffer

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::$errorBuffer -- tidy_get_error_buffer — Devuelve advertencias y errores que ocurrieron al analizar el documento especificado

Descripción

Estilo orientado a objetos (property):

string $tidy->errorBuffer;

Estilo por procedimientos:

tidy_get_error_buffer ( tidy $tidy ) : string

Devuelve advertencias y errores que ocurrieron al analizar el documento especificado.

Parámetros

tidy

El objeto Tidy.

Valores devueltos

Devuelve el búfer de errores como cadena.

Ejemplos

Ejemplo #1 Ejemplo de tidy_get_error_buffer()

<?php
$html = '<p>párrafo</p>';

$tidy = tidy_parse_string($html);

echo tidy_get_error_buffer($tidy);
/* o utilizando OO: */
echo $tidy->errorBuffer;
?>

El resultado del ejemplo sería:

line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 1 - Warning: inserting missing 'title' element

Ver también

  • tidy_access_count() - Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado
  • tidy_error_count() - Devuelve el número de errores Tidy encontrados en un documento dado
  • tidy_warning_count() - Devuelve el número de alertas encontradas en un documendo dado


Obtiene la configuración actual de Tidy

  • « tidy::$errorBuffer
  • tidy::getHtmlVer »
  • PHP Manual
  • Tidy
  • Obtiene la configuración actual de Tidy

tidy::getConfig

tidy_get_config

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::getConfig -- tidy_get_config — Obtiene la configuración actual de Tidy

Descripción

Estilo orientado a objetos

tidy::getConfig ( ) : array

Estilo por procedimientos

tidy_get_config ( tidy $object ) : array

Obtiene la lista de las opciones de configuración en uso de un objeto object tidy.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve un array con las opciones de configuación.

Para una explicación de cada opción, consulte » http://api.html-tidy.org/#quick-reference.

Ejemplos

Ejemplo #1 Ejemplo de tidy::getConfig()

<?php
$html = '<p>test</p>';
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($html, $config);

print_r($tidy->getConfig());
?>

El resultado del ejemplo sería:

Array
(
    [indent-spaces] => 2
    [wrap] => 200
    [tab-size] => 8
    [char-encoding] => 1
    [input-encoding] => 3
    [output-encoding] => 1
    [newline] => 1
    [doctype-mode] => 1
    [doctype] =>
    [repeated-attributes] => 1
    [alt-text] =>
    [slide-style] =>
    [error-file] =>
    [output-file] =>
    [write-back] =>
    [markup] => 1
    [show-warnings] => 1
    [quiet] =>
    [indent] => 1
    [hide-endtags] =>
    [input-xml] =>
    [output-xml] => 1
    [output-xhtml] => 1
    [output-html] =>
    [add-xml-decl] =>
    [uppercase-tags] =>
    [uppercase-attributes] =>
    [bare] =>
    [clean] =>
    [logical-emphasis] =>
    [drop-proprietary-attributes] =>
    [drop-font-tags] =>
    [drop-empty-paras] => 1
    [fix-bad-comments] => 1
    [break-before-br] =>
    [split] =>
    [numeric-entities] =>
    [quote-marks] =>
    [quote-nbsp] => 1
    [quote-ampersand] => 1
    [wrap-attributes] =>
    [wrap-script-literals] =>
    [wrap-sections] => 1
    [wrap-asp] => 1
    [wrap-jste] => 1
    [wrap-php] => 1
    [fix-backslash] => 1
    [indent-attributes] =>
    [assume-xml-procins] =>
    [add-xml-space] =>
    [enclose-text] =>
    [enclose-block-text] =>
    [keep-time] =>
    [word-2000] =>
    [tidy-mark] =>
    [gnu-emacs] =>
    [gnu-emacs-file] =>
    [literal-attributes] =>
    [show-body-only] =>
    [fix-uri] => 1
    [lower-literals] => 1
    [hide-comments] =>
    [indent-cdata] =>
    [force-output] => 1
    [show-errors] => 6
    [ascii-chars] => 1
    [join-classes] =>
    [join-styles] => 1
    [escape-cdata] =>
    [language] =>
    [ncr] => 1
    [output-bom] => 2
    [replace-color] =>
    [css-prefix] =>
    [new-inline-tags] =>
    [new-blocklevel-tags] =>
    [new-empty-tags] =>
    [new-pre-tags] =>
    [accessibility-check] => 0
    [vertical-space] =>
    [punctuation-wrap] =>
    [merge-divs] => 1
)

Ver también

  • tidy_reset_config()
  • tidy_save_config()


Obtiene la versión detectada de HTML en un documento especificado

  • « tidy::getConfig
  • tidy::getOpt »
  • PHP Manual
  • Tidy
  • Obtiene la versión detectada de HTML en un documento especificado

tidy::getHtmlVer

tidy_get_html_ver

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getHtmlVer -- tidy_get_html_ver — Obtiene la versión detectada de HTML en un documento especificado

Descripción

Estilo orientado a objetos

tidy::getHtmlVer ( ) : int

Estilo por procedimientos

tidy_get_html_ver ( tidy $object ) : int

Devuelve la versión detectada HTML de un objeto object especificado.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve la versión detectada HTML.

Advertencia

Esta función aún no está implementada en la librería Tidylib, por tanto siempre devolverá 0.


Devuelve el valor de la opción de configuración especificada para el documento tidy

  • « tidy::getHtmlVer
  • tidy::getOptDoc »
  • PHP Manual
  • Tidy
  • Devuelve el valor de la opción de configuración especificada para el documento tidy

tidy::getOpt

tidy_getopt

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getOpt -- tidy_getopt — Devuelve el valor de la opción de configuración especificada para el documento tidy

Descripción

Estilo orientado a objetos

tidy::getOpt ( string $option ) : mixed

Estilo por procedimientos

tidy_getopt ( tidy $object , string $option ) : mixed

Devuelve el valor de la opción option de configuración del objeto object tidy especificado.

Parámetros

object

El objeto Tidy.

option

Encontrará una lista con cada opción de configuración y sus tipos en: » http://api.html-tidy.org/#quick-reference.

Valores devueltos

Devuelve el valor de la opción option especificada. El tipo de valor depende de la opción.

Ejemplos

Ejemplo #1 Ejemplo de tidy_getopt()

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

$config = array('accessibility-check' => 3,
                'alt-text' => 'some text');

$tidy = new tidy();
$tidy->parseString($html, $config);

var_dump($tidy->getOpt('accessibility-check')); //integer
var_dump($tidy->getOpt('lower-literals')); //boolean
var_dump($tidy->getOpt('alt-text')); //string

?>

El resultado del ejemplo sería:

int(3)
bool(true)
string(9) "some text"


Devuelve la documentación correspondiente a un nombre de opción dado

  • « tidy::getOpt
  • tidy::getRelease »
  • PHP Manual
  • Tidy
  • Devuelve la documentación correspondiente a un nombre de opción dado

tidy::getOptDoc

tidy_get_opt_doc

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

tidy::getOptDoc -- tidy_get_opt_doc — Devuelve la documentación correspondiente a un nombre de opción dado

Descripción

Estilo orientado a objetos

tidy::getOptDoc ( string $optname ) : string

Estilo por procedimientos

tidy_get_opt_doc ( tidy $object , string $optname ) : string

Devuelve la documentación tidy_get_opt_doc() para el nombre de opción dado.

Nota:

Se requiere al menos la librería libtidy del 25 April del 2005 paa que la función esté disponible.

Parámetros

object

El objeto Tidy.

optname

El nombre de la opción

Valores devueltos

Devuelve una cadena si la opción existe y tiene documentación disponible, o false de otro modo.

Ejemplos

Ejemplo #1 Imprimir todas las opciones, junto con su documentación y sus valores por omisión

<?php

$tidy = new tidy;
$config = $tidy->getConfig();

ksort($config);

foreach ($config as $opt => $val) {

    if (!$doc = $tidy->getOptDoc($opt))
        $doc = 'no documentation available!';

    $val = ($tidy->getOpt($opt) === true)  ? 'true'  : $val;
    $val = ($tidy->getOpt($opt) === false) ? 'false' : $val;

    echo "<p><b>$opt</b> (default: '$val')<br />".
         "$doc</p><hr />\n";
}

?>

Ver también

  • tidy::getconfig() - Obtiene la configuración actual de Tidy
  • tidy::getopt() - Devuelve el valor de la opción de configuración especificada para el documento tidy


Obtiene la fecha de lanzamiento (versión) de la librería Tidy

  • « tidy::getOptDoc
  • tidy::getStatus »
  • PHP Manual
  • Tidy
  • Obtiene la fecha de lanzamiento (versión) de la librería Tidy

tidy::getRelease

tidy_get_release

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getRelease -- tidy_get_release — Obtiene la fecha de lanzamiento (versión) de la librería Tidy

Descripción

Estilo orientado a objetos

tidy::getRelease ( ) : string

Estilo por procedimientos

tidy_get_release ( ) : string

Obtiene la fecha de lanzamiento de la librería Tidy.

Valores devueltos

Devuelve una cadena con la fecha de lanzamiento de la librería Tidy.


Obtiene el status de un documento especificado

  • « tidy::getRelease
  • tidy::head »
  • PHP Manual
  • Tidy
  • Obtiene el status de un documento especificado

tidy::getStatus

tidy_get_status

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getStatus -- tidy_get_status — Obtiene el status de un documento especificado

Descripción

Estilo orientado a objetos

tidy::getStatus ( ) : int

Estilo por procedimientos

tidy_get_status ( tidy $object ) : int

Devuelve el status del objeto object tidy especificado.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve 0 si no hay errores/alertas, 1 para alertas de accesibilidad, o 2 para los errores.

Ejemplos

Ejemplo #1 Ejemplo de tidy::getStatus()

<?php
$html = '<p>paragraph</i>';
$tidy = new tidy();
$tidy->parseString($html);

$tidy2 = new tidy();
$html2 = '<bogus>test</bogus>';
$tidy2->parseString($html2);

echo $tidy->getStatus(); //1

echo $tidy2->getStatus(); //2
?>


Devuelve un objeto tidyNode empezando con la etiqueta <head>

  • « tidy::getStatus
  • tidy::html »
  • PHP Manual
  • Tidy
  • Devuelve un objeto tidyNode empezando con la etiqueta <head>

tidy::head

tidy_get_head

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::head -- tidy_get_head — Devuelve un objeto tidyNode empezando con la etiqueta <head>

Descripción

Estilo orientado a objetos

public tidy::head ( ) : tidyNode

Estilo por procedimientos

tidy_get_head ( tidy $object ) : tidyNode

Devuelve un objeto tidyNode empezando por la etiqueta <head>.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el objeto tidyNode.

Ejemplos

Ejemplo #1 Ejemplo de tidy::head()

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>parrafo</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$head = $tidy->head();
echo $head->value;
?>

El resultado del ejemplo sería:

<head>
<title>test</title>
</head>

Ver también

  • tidy::body() - Devuelve un objeto tidyNode empezando con la etiqueta <body>
  • tidy::html() - Devuelve un objeto tidyNode empezando con la etiqueta <html>


Devuelve un objeto tidyNode empezando con la etiqueta <html>

  • « tidy::head
  • tidy::isXhtml »
  • PHP Manual
  • Tidy
  • Devuelve un objeto tidyNode empezando con la etiqueta <html>

tidy::html

tidy_get_html

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::html -- tidy_get_html — Devuelve un objeto tidyNode empezando con la etiqueta <html>

Descripción

Estilo orientado a objetos

public tidy::html ( ) : tidyNode

Estilo por procedimientos

tidy_get_html ( tidy $object ) : tidyNode

Devuelve un objeto tidyNode empezando por la etiqueta <html>.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el objeto tidyNode.

Ejemplos

Ejemplo #1 Ejemplo de tidy::html()

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>parrafo</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$html = $tidy->html();
echo $html->value;
?>

El resultado del ejemplo sería:

<html>
<head>
<title>test</title>
</head>
<body>
<p>parrafo</p>
</body>
</html>

Ver también

  • tidy::body() - Devuelve un objeto tidyNode empezando con la etiqueta <body>
  • tidy::head() - Devuelve un objeto tidyNode empezando con la etiqueta <head>


Indica si el documento es XHTML

  • « tidy::html
  • tidy::isXml »
  • PHP Manual
  • Tidy
  • Indica si el documento es XHTML

tidy::isXhtml

tidy_is_xhtml

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::isXhtml -- tidy_is_xhtml — Indica si el documento es XHTML

Descripción

Estilo orientado a objetos

tidy::isXhtml ( ) : bool

Estilo por procedimientos

tidy_is_xhtml ( tidy $object ) : bool

Dice si el documento es XHTML.

Parámetros

object

El objeto Tidy.

Valores devueltos

Esta función devuelve true si el objeto object tidy especificado es XHTML, o false de otra forma.

Advertencia

Esta función no está implementada aún en Tidylib, por lo que siempre devolverá false.


Indica si el documento es XML (no HTML/XHTML)

  • « tidy::isXhtml
  • tidy::parseFile »
  • PHP Manual
  • Tidy
  • Indica si el documento es XML (no HTML/XHTML)

tidy::isXml

tidy_is_xml

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::isXml -- tidy_is_xml — Indica si el documento es XML (no HTML/XHTML)

Descripción

Estilo orientado a objetos

tidy::isXml ( ) : bool

Estilo por procedimientos

tidy_is_xml ( tidy $object ) : bool

Dice si el documento es un XML genérico (no HTML/XHTML).

Parámetros

object

El objeto Tidy.

Valores devueltos

Esta función devuelve true si el objeto object tidy especificado es un documento XML (no HTML/XHTML), o false de otra forma.

Advertencia

Esta función no está implementada aún en Tidylib, por lo que siempre devolverá false.


Analiza las etiquetas de un fichero o URI

  • « tidy::isXml
  • tidy::parseString »
  • PHP Manual
  • Tidy
  • Analiza las etiquetas de un fichero o URI

tidy::parseFile

tidy_parse_file

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::parseFile -- tidy_parse_file — Analiza las etiquetas de un fichero o URI

Descripción

Estilo orientado a objetos

public tidy::parseFile ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : bool

Estilo por procedimientos

tidy_parse_file ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : tidy

Analiza el fichero especificado.

Parámetros

filename

Si el parámetro filename es indicado, esta función también leerá ese fichero e iniciará el objeto con el fichero, actuando como tidy_parse_file().

config

La configuración config puede ser pasada en forma de un array o un string. Si un string es pasado, será interpretado como el el nombre del fichero de configuración, de otra forma, será interpretado como opciones en sí mismas.

Para una explicación de cada opción, consulte » http://api.html-tidy.org/#quick-reference.

encoding

El parámetro encoding establece la codificación para entarda/salida de los documentos. Los posibles valores de codificación son: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, y shiftjis.

use_include_path

Busca el fichero en el include_path.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de tidy::parseFile()

<?php
$tidy = new tidy();
$tidy->parseFile('file.html');

$tidy->cleanRepair();

if(!empty($tidy->errorBuffer)) {
    echo "Los siguientes errores o advertencias ocurrieron:\n";
    echo $tidy->errorBuffer;
}
?>

Ver también

  • tidy::parsestring() - Analiza un documento almacenado en una cadena
  • tidy::repairfile() - Repara un archivo y lo devuelve como una cadena
  • tidy::repairstring() - Repara una cadena HTML usando un archivo de configuración opcional


Analiza un documento almacenado en una cadena

  • « tidy::parseFile
  • tidy::repairFile »
  • PHP Manual
  • Tidy
  • Analiza un documento almacenado en una cadena

tidy::parseString

tidy_parse_string

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::parseString -- tidy_parse_string — Analiza un documento almacenado en una cadena

Descripción

Estilo orientado a objetos

public tidy::parseString ( string $input , mixed $config = ? , string $encoding = ? ) : bool

Estilo por procedimientos

tidy_parse_string ( string $input , mixed $config = ? , string $encoding = ? ) : tidy

Analiza un documento almacenado en una cadena.

Parámetros

input

Los datos a ser analizados.

config

La configuración config puede ser pasada en forma de un array o una cadena. Si una cadena es pasada, será interpretada como el el nombre del archivo de configuración, de otra forma, será interpretada como opciones en sí mismas.

Para una explicación de cada opción, consulte » http://api.html-tidy.org/#quick-reference.

encoding

El parámetro encoding establece la codificación para entarda/salida de los documentos. Los posibles valores de codificación son: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, y shiftjis.

Valores devueltos

Devuelve una nueva instancia de tidy.

Ejemplos

Ejemplo #1 Ejemplo de tidy::parseString()

<?php
ob_start();
?>

<html>
  <head>
   <title>test</title>
  </head>
  <body>
   <p>error<br>otra linea</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($buffer, $config, 'UTF8');

$tidy->cleanRepair();
echo $tidy;
?>

El resultado del ejemplo sería:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>
      test
    </title>
  </head>
  <body>
    <p>
      error<br />
      otra linea
    </p>
  </body>
</html>

Ver también

  • tidy::parseFile() - Analiza las etiquetas de un fichero o URI
  • tidy::repairFile() - Repara un archivo y lo devuelve como una cadena
  • tidy::repairString() - Repara una cadena HTML usando un archivo de configuración opcional


Repara un archivo y lo devuelve como una cadena

  • « tidy::parseString
  • tidy::repairString »
  • PHP Manual
  • Tidy
  • Repara un archivo y lo devuelve como una cadena

tidy::repairFile

tidy_repair_file

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::repairFile -- tidy_repair_file — Repara un archivo y lo devuelve como una cadena

Descripción

Estilo orientado a objetos

public tidy::repairFile ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : string

Estilo por procedimientos

tidy_repair_file ( string $filename , mixed $config = ? , string $encoding = ? , bool $use_include_path = false ) : string

Repara un archivo dado y devuelve el resultado como una cadena.

Parámetros

filename

El archivo a ser reparado.

config

La configuración config puede ser pasada en forma de un array o una cadena. Si una cadena es pasada, será interpretada como el el nombre del archivo de configuración, de otra forma, será interpretada como opciones en sí mismas.

Revise http://tidy.sourceforge.net/docs/quickref.html para una explicación detallada de cada opción.

encoding

El parámetro encoding establece la codificación para entarda/salida de los documentos. Los posibles valores de codificación son: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, y shiftjis.

use_include_path

Búsca el archivo en la ruta include_path.

Valores devueltos

Devuelve el contenido reparado como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de tidy::repairFile()

<?php
$file = 'file.html';

$tidy = new tidy();
$repaired = $tidy->repairfile($file);
rename($file, $file . '.bak');

file_put_contents($file, $repaired);
?>

Ver también

  • tidy::parseFile() - Analiza las etiquetas de un fichero o URI
  • tidy::parseString() - Analiza un documento almacenado en una cadena
  • tidy::repairString() - Repara una cadena HTML usando un archivo de configuración opcional


Repara una cadena HTML usando un archivo de configuración opcional

  • « tidy::repairFile
  • tidy::root »
  • PHP Manual
  • Tidy
  • Repara una cadena HTML usando un archivo de configuración opcional

tidy::repairString

tidy_repair_string

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::repairString -- tidy_repair_string — Repara una cadena HTML usando un archivo de configuración opcional

Descripción

Estilo orientado a objetos

public tidy::repairString ( string $data , mixed $config = ? , string $encoding = ? ) : string

Estilo por procedimientos

tidy_repair_string ( string $data , mixed $config = ? , string $encoding = ? ) : string

Repara una cadena dada.

Parámetros

data

Los datos a ser reparados.

config

La configuración config puede ser pasada en forma de un array o una cadena. Si una cadena es pasada, será interpretada como el el nombre del archivo de configuración, de otra forma, será interpretada como opciones en sí mismas.

Revise » http://api.html-tidy.org/#quick-reference para una explicación detallada sobre cada opción.

encoding

El parámetro encoding establece la codificación para entarda/salida de los documentos. Los posibles valores de codificación son: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, y shiftjis.

Valores devueltos

Devuelve la cadena reparada.

Ejemplos

Ejemplo #1 Ejemplo de tidy::repairString()

<?php
ob_start();
?>

<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>error</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$tidy = new tidy();
$clean = $tidy->repairString($buffer);

echo $clean;
?>

El resultado del ejemplo sería:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title>test</title>
</head>
<body>
<p>error</p>
</body>
</html>

Ver también

  • tidy::parseFile() - Analiza las etiquetas de un fichero o URI
  • tidy::parseString() - Analiza un documento almacenado en una cadena
  • tidy::repairFile() - Repara un archivo y lo devuelve como una cadena


Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy

  • « tidy::repairString
  • tidyNode »
  • PHP Manual
  • Tidy
  • Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy

tidy::root

tidy_get_root

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::root -- tidy_get_root — Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy

Descripción

Estilo orientado a objetos

public tidy::root ( ) : tidyNode

Estilo por procedimientos

tidy_get_root ( tidy $object ) : tidyNode

Devuelve un objeto tidyNode que representa la raíz del arbol a ser analizada por tidy.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el objeto tidyNode.

Ejemplos

Ejemplo #1 tidy::root() ejemplo

<?php

$html = <<< HTML
<html><body>

<p>paragraph</p>
<br/>

</body></html>
HTML;

$tidy = tidy_parse_string($html);
dump_nodes($tidy->root(), 1);

function dump_nodes($node, $indent) {

    if($node->hasChildren()) {
        foreach($node->child as $child) {
            echo str_repeat('.', $indent*2) . ($child->name ? $child->name : '"'.$child->value.'"'). "\n";

            dump_nodes($child, $indent+1);
        }
    }
}
?>

El resultado del ejemplo sería:

..html
....head
......title
....body
......p
........"paragraph"
......br


La clase tidyNode

(PHP 5, PHP 7, PHP 8)

Introducción

Un nodo HTML en un archivo HTML, detectado por tidy.

Sinopsis de la Clase

TidyNode {
/* Propiedades */
string $value;
string $name;
int $type;
int $line;
int $column;
bool $proprietary;
int $id;
array $attribute;
array $child;
/* Métodos */
getParent ( ) : tidyNode
hasChildren ( ) : bool
hasSiblings ( ) : bool
isAsp ( ) : bool
isComment ( ) : bool
isHtml ( ) : bool
isJste ( ) : bool
isPhp ( ) : bool
isText ( ) : bool
}

Propiedades

value

La representación HTML del nodo, incluyendo las etiquetas de los alrededores.

name

El nombre del nodo HTML

type

El tipo de etiqueta (una de las constantes más arriba. Por ejemplo, TIDY_NODETYPE_PHP)

line

el número de línea en la que la etiqueta está ubicada en el archivo

column

El número de columna en la que la etiqueta está ubicada en el archivo

proprietary

Indica si el nodo es una etiqueta de propiedad

id

EL ID de la etiqueta (una de las constantes más arriba. Por ejemplo, TIDY_TAG_FRAME)

attribute

Un array de cadena, representando los nombres de atributos (como las claves) del nodo actual.

child

Un array de tidyNode, representando el hijo del nodo actual.

Versión | Descripción
5.1.0 | line, column y proprietary fueron añadidos

Tabla de contenidos

  • tidyNode::__construct — Private constructor to disallow direct instantiation
  • tidyNode::getParent — Devuelve el nodo padre del nodo actual
  • tidyNode::hasChildren — Indica si un nodo tiene hijos
  • tidyNode::hasSiblings — Indica si un nodo tiene hermanos
  • tidyNode::isAsp — Comprueba si el nodo es ASP
  • tidyNode::isComment — Comprueba el nodo actual es un comentario
  • tidyNode::isHtml — Comprueba si el nodo es parte de un documento HTML
  • tidyNode::isJste — Comprueba si el nodo es JSTE
  • tidyNode::isPhp — Comprueba si el nodo es PHP
  • tidyNode::isText — Comprueba si un nodo representa un texto (no HTML)


Private constructor to disallow direct instantiation

  • « tidyNode
  • tidyNode::getParent »
  • PHP Manual
  • tidyNode
  • Private constructor to disallow direct instantiation

tidyNode::__construct

(PHP 5, PHP 7, PHP 8)

tidyNode::__construct — Private constructor to disallow direct instantiation

Descripción

private tidyNode::__construct ( )

Parámetros

Esta función no tiene parámetros.


Devuelve el nodo padre del nodo actual

  • « tidyNode::__construct
  • tidyNode::hasChildren »
  • PHP Manual
  • tidyNode
  • Devuelve el nodo padre del nodo actual

tidyNode::getParent

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

tidyNode::getParent — Devuelve el nodo padre del nodo actual

Descripción

tidyNode::getParent ( ) : tidyNode

Devuelve el nodo padre del nodo actualReturns the parent node of the current node.

Ejemplos

Ejemplo #1 Ejemplo de tidyNode::hasChildren()

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
 </head>
 <body>
 Hola Mundo
 </body>
</html>

HTML;

$tidy = tidy_parse_string($html);
$num = 0;

$node = $tidy->html()->child[0]->child[0];

var_dump($node->getparent()->name);
?>

El resultado del ejemplo sería:

string(4) "head"

Valores devueltos

Devuelve un tidyNode si el nodo tiene padre, o null de lo contrario.


Indica si un nodo tiene hijos

  • « tidyNode::getParent
  • tidyNode::hasSiblings »
  • PHP Manual
  • tidyNode
  • Indica si un nodo tiene hijos

tidyNode::hasChildren

(PHP 5, PHP 7, PHP 8)

tidyNode::hasChildren — Indica si un nodo tiene hijos

Descripción

tidyNode::hasChildren ( ) : bool

Indica si el nodo tiene hijos.

Valores devueltos

Devuelve true si el nodo tiene hijos, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de tidyNode::hasChildren()

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'Hola Mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// La etiqueta HEAD
var_dump($tidy->html()->child[0]->hasChildren());

// El código PHP dentro de la etiqueta HEAD
var_dump($tidy->html()->child[0]->child[0]->hasChildren());

?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Notas

Nota:

Esta función fue nombrada tidy_node::has_children() en PHP 4/Tidy 1.


Indica si un nodo tiene hermanos

  • « tidyNode::hasChildren
  • tidyNode::isAsp »
  • PHP Manual
  • tidyNode
  • Indica si un nodo tiene hermanos

tidyNode::hasSiblings

(PHP 5, PHP 7, PHP 8)

tidyNode::hasSiblings — Indica si un nodo tiene hermanos

Descripción

tidyNode::hasSiblings ( ) : bool

Indica si un nodo tiene hermanos.

Valores devueltos

Devuelve true si un nodo tiene hermanos, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de tidyNode::hasSiblings()

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'Hola Mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// La etiqueta HTML
var_dump($tidy->html()->hasSiblings());

// La etiqueta HEAD
var_dump($tidy->html()->child[0]->hasSiblings());

?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Notas

Nota:

Esta función fue nombrada tidy_node::has_siblings() en PHP 4/Tidy 1.


Comprueba si el nodo es ASP

  • « tidyNode::hasSiblings
  • tidyNode::isComment »
  • PHP Manual
  • tidyNode
  • Comprueba si el nodo es ASP

tidyNode::isAsp

(PHP 5, PHP 7, PHP 8)

tidyNode::isAsp — Comprueba si el nodo es ASP

Descripción

tidyNode::isAsp ( ) : bool

Indica cuando el nodo actual es ASP.

Valores devueltos

Devuelve true si el nodo es código ASP, false de lo contrario.

Ejemplos

Ejemplo #1 Extraer el código ASP embebido en un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'Hola Mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // Verifica si el nodo actual es del tipo requerido
    if($node->isAsp()) {
        echo "\n\n# asp node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# asp node #1
<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

Notas

Nota:

Esta función fue nombrada tidy_node::is_asp() en PHP 4/Tidy 1.


Comprueba el nodo actual es un comentario

  • « tidyNode::isAsp
  • tidyNode::isHtml »
  • PHP Manual
  • tidyNode
  • Comprueba el nodo actual es un comentario

tidyNode::isComment

(PHP 5, PHP 7, PHP 8)

tidyNode::isComment — Comprueba el nodo actual es un comentario

Descripción

tidyNode::isComment ( ) : bool

Indica el nodo actual es un comentario.

Valores devueltos

Devuelve true si el nodo es un comentario, false de lo contrario.

Ejemplos

Ejemplo #1 Extraer los comentarios de un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'Hola Mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // Verifica si el nodo actual es del tipo requerido
    if($node->isComment()) {
        echo "\n\n# comment node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# jste node #1
<#
  /* código JSTE */
  alert('Hola Mundo');
#>

/*
var_dump($tidy->html()->child[0]->hasChildren());
var_dump($tidy->html()->child[0]->child[0]->hasChildren());
*/

Notas

Nota:

Esta función fue nombrada tidy_node::is_comment() en PHP 4/Tidy 1.


Comprueba si el nodo es parte de un documento HTML

  • « tidyNode::isComment
  • tidyNode::isJste »
  • PHP Manual
  • tidyNode
  • Comprueba si el nodo es parte de un documento HTML

tidyNode::isHtml

(PHP 5, PHP 7, PHP 8)

tidyNode::isHtml — Comprueba si el nodo es parte de un documento HTML

Descripción

tidyNode::isHtml ( ) : bool

Indica si el nodo es parte de un documento HTML.

Valores devueltos

Devuelve true si el nodo es parte de un documento HTML, false de lo contrario.

Ejemplos

Ejemplo #1 Extraer el código HTML de un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'hola mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {
    // Verifica si el nodo actual es del tipo requerido
    if($node->isHtml()) {
        echo "\n\n# html node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# html node #1
<html>
<head>
<?php echo '<title>titulo</title>'; ?><#
  /* código JSTE */
  alert('Hola Mundo');
#>
<title></title>
</head>
<body>
<?php
  // código PHP
  echo 'hola mundo!';
?><%
  /* código ASP */
  response.write("Hola Mundo!")
%><!-- Comentarios -->
HolaMundoFuera del HTML
</body>
</html>

# html node #2
<head>
<?php echo '<title>titulo</title>'; ?><#
  /* código JSTE code */
  alert('Hola Mundo');
#>
<title></title>
</head>

# html node #3
<?php echo '<title>titulo</title>'; ?>

# html node #4
<#
  /* código JSTE */
  alert('Hola Mundo');
#>

# html node #5
<title></title>

# html node #6
<body>
<?php
  // código PHP
  echo 'hola mundo!';
?><%
  /* código ASP */
  response.write("Hola Mundo!")
%><!-- Comentarios -->
Hola MundoFuera del HTML
</body>

# html node #7
<?php
  // código PHP
  echo 'hola mundo!';
?>

# html node #8
<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

# html node #9
<!-- Comentarios -->

# html node #10
Hola Mundo

# html node #11
Fuera del HTML

Notas

Nota:

Esta función fue nombrada tidy_node::is_html() en PHP 4/Tidy 1.


Comprueba si el nodo es JSTE

  • « tidyNode::isHtml
  • tidyNode::isPhp »
  • PHP Manual
  • tidyNode
  • Comprueba si el nodo es JSTE

tidyNode::isJste

(PHP 5, PHP 7, PHP 8)

tidyNode::isJste — Comprueba si el nodo es JSTE

Descripción

tidyNode::isJste ( ) : bool

Indica si el nodo es JSTE.

Valores devueltos

Devuelve true si el nodo es código JSTE, false de lo contrario.

Ejemplos

Ejemplo #1 Extrer el código JSTE de un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'hola mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // Verifica si el nodo actual es del tipo requerido
    if($node->isJste()) {
        echo "\n\n# jste node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# jste node #1
<#
  /* código JSTE */
  alert('Hola Mundo');
#>

/*
var_dump($tidy->html()->child[0]->hasChildren());
var_dump($tidy->html()->child[0]->child[0]->hasChildren());
*/

Notas

Nota:

This function was named tidy_node::is_jste() in PHP 4/Tidy 1.


Comprueba si el nodo es PHP

  • « tidyNode::isJste
  • tidyNode::isText »
  • PHP Manual
  • tidyNode
  • Comprueba si el nodo es PHP

tidyNode::isPhp

(PHP 5, PHP 7, PHP 8)

tidyNode::isPhp — Comprueba si el nodo es PHP

Descripción

tidyNode::isPhp ( ) : bool

Indica cuando el nodo actual es PHP.

Valores devueltos

Devuelve true si el nodo es código PHP, false de lo contrario.

Ejemplos

Ejemplo #1 Extraer el código PHP embebido en un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'hola mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // Verifica si el nodo actual es del tipo requerido
    if($node->isPhp()) {
        echo "\n\n# php node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# php node #1
<?php echo '<title>titulo</title>'; ?>

# php node #2
<?php
  // código PHP
  echo 'hola mundo!';
?>

Notas

Nota:

Esta función fue nombrada tidy_node::is_php() en PHP 4/Tidy 1.


Comprueba si un nodo representa un texto (no HTML)

  • « tidyNode::isPhp
  • Funciones de Tidy »
  • PHP Manual
  • tidyNode
  • Comprueba si un nodo representa un texto (no HTML)

tidyNode::isText

(PHP 5, PHP 7, PHP 8)

tidyNode::isText — Comprueba si un nodo representa un texto (no HTML)

Descripción

tidyNode::isText ( ) : bool

Indica si un nodo representa sólo texto (sin nada de HTML).

Valores devueltos

Devuelve true si un nodo representa un texto, false de lo contrario.

Ejemplos

Ejemplo #1 Extraer el texto de un documento HTML

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>titulo</title>'; ?>
<#
  /* código JSTE */
  alert('Hola Mundo');
#>
</head>
<body>

<?php
  // código PHP
  echo 'hola mundo!';
?>

<%
  /* código ASP */
  response.write("Hola Mundo!")
%>

<!-- Comentarios -->
Hola Mundo
</body></html>
Fuera del HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // Verifica si el nodo actual es del tipo requerido
    if($node->isText()) {
        echo "\n\n# text node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Verifica si el nodo actual tiene hijos
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

El resultado del ejemplo sería:

# text node #1
Hola Mundo

# text node #2
Fuera del HTML

Notas

Nota:

Esta función fue nombrada tidy_node::is_text() en PHP 4/Tidy 1.


Funciones de Tidy

Tabla de contenidos

  • ob_tidyhandler — Función callback de ob_start para reparar el buffer
  • tidy_access_count — Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado
  • tidy_config_count — Devuelve el número de errores de configuración Tidy encontrados en un documento dado
  • tidy_error_count — Devuelve el número de errores Tidy encontrados en un documento dado
  • tidy_get_output — Devuelve una cadena que contiene las etiquetas analizadas por Tidy
  • tidy_warning_count — Devuelve el número de alertas encontradas en un documendo dado


Función callback de ob_start para reparar el buffer

  • « Funciones de Tidy
  • tidy_access_count »
  • PHP Manual
  • Funciones de Tidy
  • Función callback de ob_start para reparar el buffer

ob_tidyhandler

(PHP 5, PHP 7, PHP 8)

ob_tidyhandler — Función callback de ob_start para reparar el buffer

Descripción

ob_tidyhandler ( string $input , int $mode = ? ) : string

Función callback para la función ob_start() con el fin de reparar el buffer.

Parámetros

input

EL buffer.

mode

El modo del buffer.

Valores devueltos

Devuelve el buffer modificado.

Ejemplos

Ejemplo #1 Ejemplo de ob_tidyhandler()

<?php
ob_start('ob_tidyhandler');

echo '<p>test</i>';
?>

El resultado del ejemplo sería:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida


Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado

  • « ob_tidyhandler
  • tidy_config_count »
  • PHP Manual
  • Funciones de Tidy
  • Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado

tidy_access_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_access_count — Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado

Descripción

tidy_access_count ( tidy $object ) : int

tidy_access_count() devuelve el número de alertas de accesibilidad encontradas en un documento específico.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el número de alertas.

Ejemplos

Ejemplo #1 Ejemplo de la función tidy_access_count()

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

// Seleccione el nivel de accesibilidad a revisar: 1, 2 o 3
$config = array('accessibility-check' => 3);

$tidy = new tidy();
$tidy->parseString($html, $config);
$tidy->cleanRepair();

/* No olvide ejecutar esto! */
$tidy->diagnose();

echo tidy_access_count($tidy); //5

?>

Notas

Nota:

Dado el diseño de TidyLib, se debe ejecutar tidy_diagnose() antes de tidy_access_count() o siempre devolverá 0. También se necesita habilitar la opción accessibility-check.

Ver también

  • tidy_error_count() - Devuelve el número de errores Tidy encontrados en un documento dado
  • tidy_warning_count() - Devuelve el número de alertas encontradas en un documendo dado


Devuelve el número de errores de configuración Tidy encontrados en un documento dado

  • « tidy_access_count
  • tidy_error_count »
  • PHP Manual
  • Funciones de Tidy
  • Devuelve el número de errores de configuración Tidy encontrados en un documento dado

tidy_config_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_config_count — Devuelve el número de errores de configuración Tidy encontrados en un documento dado

Descripción

tidy_config_count ( tidy $object ) : int

Devuelve el número de errores encontrados en la configuración del objeto object tidy especificado.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el número de errores.

Ejemplos

Ejemplo #1 Ejemplo de la función tidy_config_count()

<?php
$html = '<p>test</I>';

$config = array('doctype' => 'bogus');

$tidy = tidy_parse_string($html, $config);

/* Saldrá 1, porque 'bogus' no es un doctype válido */
echo tidy_config_count($tidy);
?>


Devuelve el número de errores Tidy encontrados en un documento dado

  • « tidy_config_count
  • tidy_get_output »
  • PHP Manual
  • Funciones de Tidy
  • Devuelve el número de errores Tidy encontrados en un documento dado

tidy_error_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_error_count — Devuelve el número de errores Tidy encontrados en un documento dado

Descripción

tidy_error_count ( tidy $object ) : int

Devuelve el número de errores Tidy encontrados en un documento específico.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el número de errores.

Ejemplos

Ejemplo #1 Ejemplo de la función tidy_error_count()

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1

echo $tidy->errorBuffer;
?>

El resultado del ejemplo sería:

1
line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 8 - Warning: discarding unexpected </i>
line 2 column 1 - Error: <bogustag> is not recognized!
line 2 column 1 - Warning: discarding unexpected <bogustag>
line 2 column 16 - Warning: discarding unexpected </bogustag>
line 1 column 1 - Warning: inserting missing 'title' element

Ver también

  • tidy_access_count() - Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado
  • tidy_warning_count() - Devuelve el número de alertas encontradas en un documendo dado


Devuelve una cadena que contiene las etiquetas analizadas por Tidy

  • « tidy_error_count
  • tidy_warning_count »
  • PHP Manual
  • Funciones de Tidy
  • Devuelve una cadena que contiene las etiquetas analizadas por Tidy

tidy_get_output

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_get_output — Devuelve una cadena que contiene las etiquetas analizadas por Tidy

Descripción

tidy_get_output ( tidy $object ) : string

Devuelve una cadena con el HTML reparado.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve las etiquetas analizadas por tidy

Ejemplos

Ejemplo #1 Ejemplo de la función tidy_get_output()

<?php

$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$tidy->cleanRepair();

echo tidy_get_output($tidy);
?>

El resultado del ejemplo sería:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>paragraph</p>
</body>
</html>


Devuelve el número de alertas encontradas en un documendo dado

  • « tidy_get_output
  • Tokenizer »
  • PHP Manual
  • Funciones de Tidy
  • Devuelve el número de alertas encontradas en un documendo dado

tidy_warning_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_warning_count — Devuelve el número de alertas encontradas en un documendo dado

Descripción

tidy_warning_count ( tidy $object ) : int

Devuelve el número de alertas Tidy encontradas en un documento específicado.

Parámetros

object

El objeto Tidy.

Valores devueltos

Devuelve el número de alertas.

Ejemplos

Ejemplo #1 Ejemplo de la función tidy_warning_count()

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1
echo tidy_warning_count($tidy) . "\n"; //5
?>

Ver también

  • tidy_error_count() - Devuelve el número de errores Tidy encontrados en un documento dado
  • tidy_access_count() - Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado


Tokenizer

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones Tokenizer
    • token_get_all — Divide la fuente dada en tokens PHP
    • token_name — Obtiene el nombre simbólico de un token PHP dado


Introducción

Las funciones de la extensión tokenizer proporcionan una interfaz para la creación de tokens de PHP integrada en el Motor Zend. Utilizando estas funciones se pueden escribir herramientas propias de análisis o de modificación de código fuente de PHP, sin tener que hacer frente a las especificaciones del lenguaje a nivel léxico.

Véase también el apéndice sobre tokens.


Instalación

Estas funciones están activadas por defecto. Se puede deshabilitar el soporte del tokenizer con --disable-tokenizer.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Constantes predefinidas

Cuando la extensión ha sido o bien compilada en PHP o dinámicamente cargada durante el tiempo de ejecución, los tokens listados en Lista de componentes léxicos del analizador son definidos como constantes.


Ejemplos

Aquí hay un simple ejemplo de scripts PHP donde se usa el tokenizer para leer en un archivo PHP, quitar todo los comentarios del archivo original y mostrar solamente el código puro.

Ejemplo #1 Quitar comentarios con el tokenizer

<?php

$source = file_get_contents('example.php');
$tokens = token_get_all($source);

foreach ($tokens as $token) {
   if (is_string($token)) {
       // simple 1-character token
       echo $token;
   } else {
       // token array
       list($id, $text) = $token;

       switch ($id) {
           case T_COMMENT:
           case T_DOC_COMMENT:
               // ninguna acción en comentarios
               break;

           default:
               // cualquier otra cosa -> salida "tal cual"
               echo $text;
               break;
       }
   }
}
?>


Funciones Tokenizer

Tabla de contenidos

  • token_get_all — Divide la fuente dada en tokens PHP
  • token_name — Obtiene el nombre simbólico de un token PHP dado


Divide la fuente dada en tokens PHP

  • « Funciones Tokenizer
  • token_name »
  • PHP Manual
  • Funciones Tokenizer
  • Divide la fuente dada en tokens PHP

token_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

token_get_all — Divide la fuente dada en tokens PHP

Descripción

token_get_all ( string $source ) : array

token_get_all() parsea el string de la fuente dada en tokens PHP usando el escaneador de léxico de Zend Engine.

Para ver la lista de los tokens analizados, vea Lista de componentes léxicos del analizador, o use token_name() para traducir un valor token en su representación en string.

Parámetros

source

La fuente PHP a analizar.

Valores devueltos

Un array de tokens identificadores. Cada token identificador individual es al mismo tiempo un carácter único (por ejemplo: ;, ., >, !, etc...), un array de tres elementos conteniendo el índice de token en el elemento 0, el contenido del string del token original en el elemento 1 y el número de línea en el elemento 2.

Ejemplos

Ejemplo #1 token_get_all() ejemplos

<?php
$tokens = token_get_all('<?php echo; ?>'); /* => array(
                                                  array(T_OPEN_TAG, '<?php'),
                                                  array(T_ECHO, 'echo'),
                                                  ';',
                                                  array(T_CLOSE_TAG, '?>') ); */

/* Tenga en cuenta que el siguiente ejemplo tiene el string analizado como T_INLINE_HTML
   en lugar del esperado T_COMMENT (T_ML_COMMENT in PHP <5).
   Esto se debe a que los tags de abierto/cerrado no han sido usados en el "código".
   Esto sería equivalente a poner un comentario fuera de los tags <?php ?> en un fichero normal. */
$tokens = token_get_all('/* comentario */'); // => array(array(T_INLINE_HTML, '/* comentario */'));
?>

Historial de cambios

Versión | Descripción
5.2.2 | Los números de línea son devueltos en el elemento 2


Obtiene el nombre simbólico de un token PHP dado

  • « token_get_all
  • URLs »
  • PHP Manual
  • Funciones Tokenizer
  • Obtiene el nombre simbólico de un token PHP dado

token_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

token_name — Obtiene el nombre simbólico de un token PHP dado

Descripción

token_name ( int $token ) : string

token_name() obtiene el nombre simbólico para un valor de token PHP.

Parámetros

token

El valor token.

Valores devueltos

El nombre simbólico para el token dado.

Ejemplos

Ejemplo #1 token_name() ejemplo

<?php
// 260 es el valor de token para T_EVAL token
echo token_name(260);        // -> "T_EVAL"

// una constante token mapea a su propio nombre
echo token_name(T_FUNCTION); // -> "T_FUNCTION"
?>

Ver también

  • Listado de Tokens Analizadores


URLs

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de URL
    • base64_decode — Decodifica datos codificados con MIME base64
    • base64_encode — Codifica datos con MIME base64
    • get_headers — Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP
    • get_meta_tags — Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array
    • http_build_query — Generar una cadena de consulta codificada estilo URL
    • parse_url — Analiza un URL y devuelve sus componentes
    • rawurldecode — Decodificar cadenas codificadas estilo URL
    • rawurlencode — Codificar estilo URL de acuerdo al RFC 3986
    • urldecode — Decodifica una cadena cifrada como URL
    • urlencode — Codifica como URL una cadena


  • « URLs
  • Instalación/Configuración »
  • PHP Manual
  • URLs
  • Introducción

Introducción

Tratar con cadenas URL: codificación, decodificaicón y conversión.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las siguientes constantes están pensadas para usarse con parse_url() y están disponibles desde PHP 5.1.2.

PHP_URL_SCHEME (integer)
PHP_URL_HOST (integer)
Muestra el nombre del host del URL analizado.
PHP_URL_PORT (integer)
Muestra el puerto del URL analizado.
PHP_URL_USER (integer)
Muestra el usuario del URL analizado.
PHP_URL_PASS (integer)
Muestra la contraseña del URL analizado.
PHP_URL_PATH (integer)
Muestra la ruta del URL analizado.
PHP_URL_QUERY (integer)
Muestra el string de consulta del URL analizado.
PHP_URL_FRAGMENT (integer)
Muestra el fragmento (string después del símbolo #) del URL analizado.

Las siguientes constantes están pensadas para utilizarlas con http_build_query().

PHP_QUERY_RFC1738 (integer)
Codificación realizada por » RFC 1738 y el tipo de media application/x-www-form-urlencoded, lo que implica que los espacios están codificados como signos "más" (+).
PHP_QUERY_RFC3986 (integer)
La codificación se lleva a cabo según el » RFC 3986, y los espacios se cofificarán con porcentajes (%20).


Funciones de URL

Tabla de contenidos

  • base64_decode — Decodifica datos codificados con MIME base64
  • base64_encode — Codifica datos con MIME base64
  • get_headers — Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP
  • get_meta_tags — Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array
  • http_build_query — Generar una cadena de consulta codificada estilo URL
  • parse_url — Analiza un URL y devuelve sus componentes
  • rawurldecode — Decodificar cadenas codificadas estilo URL
  • rawurlencode — Codificar estilo URL de acuerdo al RFC 3986
  • urldecode — Decodifica una cadena cifrada como URL
  • urlencode — Codifica como URL una cadena


Decodifica datos codificados con MIME base64

  • « Funciones de URL
  • base64_encode »
  • PHP Manual
  • Funciones de URL
  • Decodifica datos codificados con MIME base64

base64_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

base64_decode — Decodifica datos codificados con MIME base64

Descripción

base64_decode ( string $data , bool $strict = false ) : string

Decodifica los datos en data codificados en base64.

Parámetros

data

Los datos codificados.

strict

Si el parámetro strict está establecido a true, la función base64_decode() devolverá false si la entrada contiene algún carácter que no es del alfabeto de base64. De lo contrario, los caracteres no válidos serán descartados silenciosamente.

Valores devueltos

Devuelve los datos decodificados o false en caso de error. Los datos devueltos pueden estar en formato binario.

Historial de cambios

Versión | Descripción
5.2.0 | Añadido strict

Ejemplos

Ejemplo #1 Ejemplo de base64_decode()

<?php
$str = 'VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==';
echo base64_decode($str);
?>

El resultado del ejemplo sería:

Estos datos son una cadena codificada.

Ver también

  • base64_encode() - Codifica datos con MIME base64
  • » RFC 2045 section 6.8


Codifica datos con MIME base64

  • « base64_decode
  • get_headers »
  • PHP Manual
  • Funciones de URL
  • Codifica datos con MIME base64

base64_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

base64_encode — Codifica datos con MIME base64

Descripción

base64_encode ( string $data ) : string

Codifica data en base64.

Este tipo de codificación está diseñado para que datos binarios sobrepasen capas de transporte que no son de 8-bits 100%, como por ejemplo el cuerpo de un E-Mail.

La codificación en Base64 hace que los datos sean un 33% más largos que los datos originales.

Parámetros

data

Datos a codificar.

Valores devueltos

Los datos codificados, como un string.

Ejemplos

Ejemplo #1 Ejemplo de base64_encode()

<?php
$str = 'This is an encoded string';
echo base64_encode($str);
?>

El resultado del ejemplo sería:

VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==

Ver también

  • base64_decode() - Decodifica datos codificados con MIME base64
  • chunk_split() - Divide una cadena en trozos más pequeños
  • convert_uuencode() - Codificar mediante uuencode una cadena
  • » RFC 2045 section 6.8


Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP

  • « base64_encode
  • get_meta_tags »
  • PHP Manual
  • Funciones de URL
  • Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP

get_headers

(PHP 5, PHP 7, PHP 8)

get_headers — Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP

Descripción

get_headers ( string $url , int $format = 0 , resource $context = ? ) : array

get_headers() devuelve un Array con las cabeceras enviadas por el servidor en respuesta a una petición HTTP.

Parámetros

url

La URL de destino.

format

Si el parámetro opcional formato es definido como no-cero, get_headers() interpreta la respuesta y define las claves del array.

context

Un recurso de contexto válido creado con stream_context_create().

Valores devueltos

Devuelve un array indexado o asociativo con las cabeceras, o false en caso de fallo.

Historial de cambios

Versión | Descripción
7.1.0 | El parámetro context fue agregado.
5.1.3 | Esta función usa el contexto de secuencia predeterminado, el cual puede ser definido/modificado con la función stream_context_set_default().

Ejemplos

Ejemplo #1 Ejemplo de get_headers()

<?php
$url = 'http://www.example.com';

print_r(get_headers($url));

print_r(get_headers($url, 1));
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => HTTP/1.1 200 OK
    [1] => Date: Sat, 29 May 2004 12:28:13 GMT
    [2] => Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [3] => Last-Modified: Wed, 08 Jan 2003 23:11:55 GMT
    [4] => ETag: "3f80f-1b6-3e1cb03b"
    [5] => Accept-Ranges: bytes
    [6] => Content-Length: 438
    [7] => Connection: close
    [8] => Content-Type: text/html
)

Array
(
    [0] => HTTP/1.1 200 OK
    [Date] => Sat, 29 May 2004 12:28:14 GMT
    [Server] => Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [Last-Modified] => Wed, 08 Jan 2003 23:11:55 GMT
    [ETag] => "3f80f-1b6-3e1cb03b"
    [Accept-Ranges] => bytes
    [Content-Length] => 438
    [Connection] => close
    [Content-Type] => text/html
)

Ejemplo #2 get_headers() using HEAD example

<?php
// Por omisión get_headers utiliza una solicitud GET para recoger las cabeceras. Si se
// desea enviar una solicitud HEAD en su lugar, puede hacerlo usando un contexto de secuencia:
stream_context_set_default(
    array(
        'http' => array(
            'method' => 'HEAD'
        )
    )
);
$headers = get_headers('http://example.com');
?>

Ver también

  • apache_request_headers() - Obtiene todas las cabeceras HTTP


Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array

  • « get_headers
  • http_build_query »
  • PHP Manual
  • Funciones de URL
  • Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array

get_meta_tags

(PHP 4, PHP 5, PHP 7, PHP 8)

get_meta_tags — Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array

Descripción

get_meta_tags ( string $filename , bool $use_include_path = false ) : array

Abre filename y lo procesa línea por línea en busca de etiquetas <meta> en el archivo. El procesamiento se detiene al encontrar </head>.

Parámetros

filename

La ruta al archivo HTML, como una cadena. Éste puede ser un archivo local o una URL.

Ejemplo #1 Lo que procesa get_meta_tags()

<meta name="author" content="name">
<meta name="keywords" content="php documentation">
<meta name="DESCRIPTION" content="a php manual">
<meta name="geo.position" content="49.33;-86.59">
</head> <!-- el procesamiento se detiene aquí -->
(preste atención a los finales de línea, - PHP usa una función nativa para procesar la entrada, así que un archivo Mac no funcionará en Unix).

use_include_path

Definir use_include_path como true producirá que PHP intente abrir el archivo a lo largo de la ruta de inclusión estándar, tal y como se define en la directiva include_path. Éste parámetro es usado para archivos locales, no URLs.

Valores devueltos

Devuelve un array con todas las etiquetas meta procesadas.

El valor de la propiedad 'name' se convierte en la clave, el valor del contenido de la propiedad se convierte en el valor del array devuelto, de modo que es posible usar fácilmente funciones estándar de arrays para recorrerlo o acceder a valores sencillos. Los caracteres especiales en el valor de la propiedad name son sustituidos con '_', el resto es convertido a minúsculas. Si dos etiquetas meta tienen el mismo nombre, sólo se devuelve la última.

Ejemplos

Ejemplo #2 Lo que devuelve get_meta_tags()

<?php
// Asumiendo que las anteriores etiquetas se encuentran en www.example.com
$tags = get_meta_tags('http://www.example.com/');

// Note como las claves están ahora en minúsculas, y como . fue
// reemplazado con _ en la clave.
echo $tags['author'];       // name
echo $tags['keywords'];     // php documentation
echo $tags['description'];  // a php manual
echo $tags['geo_position']; // 49.33;-86.59
?>

Notas

Nota:

Sólo meta tags que contienen el atributo name serán analizados.

Ver también

  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • urlencode() - Codifica como URL una cadena


Generar una cadena de consulta codificada estilo URL

  • « get_meta_tags
  • parse_url »
  • PHP Manual
  • Funciones de URL
  • Generar una cadena de consulta codificada estilo URL

http_build_query

(PHP 5, PHP 7, PHP 8)

http_build_query — Generar una cadena de consulta codificada estilo URL

Descripción

http_build_query ( mixed $query_data , string $numeric_prefix = ? , string $arg_separator = ? , int $enc_type = PHP_QUERY_RFC1738 ) : string

Genera una cadena de consulta codificada estilo URL a partir del array asociativo (o indexado) dado.

Parámetros

query_data

Puede ser un array u objeto que contenga propiedades.

Si query_data es un array, puede ser de una dimensión, o un array de arrays (que a su vez puede contener otros arrays).

Si query_data es un objeto, sólo las propiedades que son públicas serán incorporadas en el resultado.

numeric_prefix

Si se usan índices numéricos en el array base y se provee este parámetro, éste será añadido al comienzo de los índices numéricos para aquellos elementos encontrados sólo en el array base.

Esto significa tener en cuenta los nombres de variables legales cuando los datos sean decodificados por PHP u otra aplicación CGI más adelante.

arg_separator

arg_separator.output se usa para separar argumentos, aunque podría ser sobrescrito especificando este parámetro.

enc_type

Por omisión, PHP_QUERY_RFC1738.

Si enc_type es PHP_QUERY_RFC1738, la codificación se realiza de acuerdo al » RFC 1738 y el tipo de medios application/x-www-form-urlencoded, lo que implica que los espacios son codificados con el signo más (+).

Si enc_type es PHP_QUERY_RFC3986, la codificación se realiza de acuerdo al » RFC 3986, y los espacios serán codificados (%20) más.

Valores devueltos

Devuelve una cadena codificada en forma URL.

Historial de cambios

Versión | Descripción
5.4.0 | Se agregó el parámetro enc_type.
5.1.3 | Los corchetes cuadrados son escapados.
5.1.2 | Se agregó el parámetro arg_separator.

Ejemplos

Ejemplo #1 Uso simple de http_build_query()

<?php
$data = array('foo'=>'bar',
              'baz'=>'boom',
              'cow'=>'milk',
              'php'=>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, '', '&amp;');

?>

El resultado del ejemplo sería:

foo=bar&baz=boom&cow=milk&php=hypertext+processor
foo=bar&amp;baz=boom&amp;cow=milk&amp;php=hypertext+processor

Ejemplo #2 http_build_query() con elementos indexados numéricamente.

<?php
$data = array('foo', 'bar', 'baz', 'boom', 'cow' => 'milk', 'php' =>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, 'myvar_');
?>

El resultado del ejemplo sería:

0=foo&1=bar&2=baz&3=boom&cow=milk&php=hypertext+processor
myvar_0=foo&myvar_1=bar&myvar_2=baz&myvar_3=boom&cow=milk&php=hypertext+processor

Ejemplo #3 con arrays complejos http_build_query()

<?php
$data = array('user'=>array('name'=>'Bob Smith',
                            'age'=>47,
                            'sex'=>'M',
                            'dob'=>'5/12/1956'),
              'pastimes'=>array('golf', 'opera', 'poker', 'rap'),
              'children'=>array('bobby'=>array('age'=>12,
                                               'sex'=>'M'),
                                'sally'=>array('age'=>8,
                                               'sex'=>'F')),
              'CEO');

echo http_build_query($data, 'flags_');
?>

esto generará la salida: (acotada por razones de legibilidad)

user%5Bname%5D=Bob+Smith&user%5Bage%5D=47&user%5Bsex%5D=M&
user%5Bdob%5D=5%2F12%2F1956&pastimes%5B0%5D=golf&pastimes%5B1%5D=opera&
pastimes%5B2%5D=poker&pastimes%5B3%5D=rap&children%5Bbobby%5D%5Bage%5D=12&
children%5Bbobby%5D%5Bsex%5D=M&children%5Bsally%5D%5Bage%5D=8&
children%5Bsally%5D%5Bsex%5D=F&flags_0=CEO

Nota:

Sólo el elemento "CEO" indexado numéricamente el array base recibió un prefijo. Los otros índices numéricos, encontrados bajo los pasatiempos, no requieren un prefijo tipo cadena para ser nombres legales de variables.

Ejemplo #4 Uso de http_build_query() con un objeto

<?php
class parentClass {
    public    $pub      = 'publicParent';
    protected $prot     = 'protectedParent';
    private   $priv     = 'privateParent';
    public    $pub_bar  = Null;
    protected $prot_bar = Null;
    private   $priv_bar = Null;

    public function __construct(){
        $this->pub_bar  = new childClass();
        $this->prot_bar = new childClass();
        $this->priv_bar = new childClass();
    }
}

class childClass {
    public    $pub  = 'publicChild';
    protected $prot = 'protectedChild';
    private   $priv = 'privateChild';
}

$parent = new parentClass();

echo http_build_query($parent);

?>

El resultado del ejemplo sería:

pub=publicParent&pub_bar%5Bpub%5D=publicChild

Ver también

  • parse_str() - Convierte el string en variables
  • parse_url() - Analiza un URL y devuelve sus componentes
  • urlencode() - Codifica como URL una cadena
  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array


Analiza un URL y devuelve sus componentes

  • « http_build_query
  • rawurldecode »
  • PHP Manual
  • Funciones de URL
  • Analiza un URL y devuelve sus componentes

parse_url

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_url — Analiza un URL y devuelve sus componentes

Descripción

parse_url ( string $url , int $component = -1 ) : mixed

Esta función analiza una URL y devuelve un array asociativo que contiene aquellos componentes presentes en la URL.

El propósito de esta función no es validar la URL dada, tan solo la separa en las partes listadas anteriormente. Las URLs parciales son aceptadas también, parse_url() hace lo mejor que puede para procesarlas correctamente.

Parámetros

url

La URL a analizar. Caracteres inválidos son reemplazados por _.

component

Especifique uno de PHP_URL_SCHEME, PHP_URL_HOST, PHP_URL_PORT, PHP_URL_USER, PHP_URL_PASS, PHP_URL_PATH, PHP_URL_QUERY o PHP_URL_FRAGMENT para recibir solo un componente URL específico como un valor tipo string (excepto cuando se da PHP_URL_PORT, en cuyo caso el valor de retorno será un integer).

Valores devueltos

Sobre URLs seriamente malformadas, parse_url() puede devolver false.

Si se omite el parámetro component, un array asociativo es devuelto. Al menos un elemento estará presente en el array. Claves potenciales en este array son:

  • scheme - p.ej. http
  • host
  • port
  • user
  • pass
  • path
  • query - después del signo ?
  • fragment - después del signo #

Si se especifica el parámetro componente, parse_url() devolverá un string (o un integer, para el caso de PHP_URL_PORT) en lugar de un array. Si el componente solicitado no existe en la URL dada, será devuelto null.

Historial de cambios

Versión | Descripción
5.4.7 | Arreglado el reconocimiento de host cuando scheme es omitido y está presente un separador de componentes que lo encabeza.
5.3.3 | Eliminado el E_WARNING que era producido cuando fallaba el análisis de la URL.
5.1.2 | Se agregó el parámetro component.

Ejemplos

Ejemplo #1 Un ejemplo de parse_url()

<?php
$url = 'http://username:password@hostname:9090/path?arg=value#anchor';

var_dump(parse_url($url));
var_dump(parse_url($url, PHP_URL_SCHEME));
var_dump(parse_url($url, PHP_URL_USER));
var_dump(parse_url($url, PHP_URL_PASS));
var_dump(parse_url($url, PHP_URL_HOST));
var_dump(parse_url($url, PHP_URL_PORT));
var_dump(parse_url($url, PHP_URL_PATH));
var_dump(parse_url($url, PHP_URL_QUERY));
var_dump(parse_url($url, PHP_URL_FRAGMENT));
?>

El resultado del ejemplo sería:

array(8) {
  ["scheme"]=>
  string(4) "http"
  ["host"]=>
  string(8) "hostname"
  ["port"]=>
  int(9090)
  ["user"]=>
  string(8) "username"
  ["pass"]=>
  string(8) "password"
  ["path"]=>
  string(5) "/path"
  ["query"]=>
  string(9) "arg=value"
  ["fragment"]=>
  string(6) "anchor"
}
string(4) "http"
string(8) "username"
string(8) "password"
string(8) "hostname"
int(9090)
string(5) "/path"
string(9) "arg=value"
string(6) "anchor"

Ejemplo #2 Un ejemplo de parse_url() con el esquema ausente

<?php
$url = '//www.example.com/path?googleguy=googley';

// Antes de 5.4.7, esto mostraría la ruta como "//www.example.com/path"
var_dump(parse_url($url));
?>

El resultado del ejemplo sería:

array(3) {
  ["host"]=>
  string(15) "www.example.com"
  ["path"]=>
  string(5) "/path"
  ["query"]=>
  string(17) "googleguy=googley"
}

Notas

Nota:

Esta función no funciona con URLs relativas.

Nota:

Esta función tiene el propósito específico de procesar URLs, y no URIs. Sin embargo, para cumplir con los requerimientos de retrocompatibilidad de PHP, hace una excepción para el esquema file:// en donde se permiten tres barras (file:///...). Para cualquier otro esquema, lo anterior es inválido.

Ver también

  • pathinfo() - Devuelve información acerca de la ruta de un fichero
  • parse_str() - Convierte el string en variables
  • http_build_query() - Generar una cadena de consulta codificada estilo URL
  • dirname() - Devuelve la ruta de un directorio padre
  • basename() - Devuelve el último componente de nombre de una ruta
  • » RFC 3986


Decodificar cadenas codificadas estilo URL

  • « parse_url
  • rawurlencode »
  • PHP Manual
  • Funciones de URL
  • Decodificar cadenas codificadas estilo URL

rawurldecode

(PHP 4, PHP 5, PHP 7, PHP 8)

rawurldecode — Decodificar cadenas codificadas estilo URL

Descripción

rawurldecode ( string $str ) : string

Devuelve una cadena en donde las con secuencias con signos de porcentaje (%) seguidos de dos dígitos hexadecimales, son reemplazados con caracteres literales.

Parámetros

str

La URL a ser decodificada.

Valores devueltos

Devuelve la URL decodificada, como una cadena.

Ejemplos

Ejemplo #1 Ejemplo de rawurldecode()

<?php

echo rawurldecode('foo%20bar%40baz'); // foo bar@baz

?>

Notas

Nota:

rawurldecode() no decodifica los símbolos más ('+') como espacios. urldecode() lo hace.

Ver también

  • rawurlencode() - Codificar estilo URL de acuerdo al RFC 3986
  • urldecode() - Decodifica una cadena cifrada como URL
  • urlencode() - Codifica como URL una cadena
  • » RFC 3986


Codificar estilo URL de acuerdo al RFC 3986

  • « rawurldecode
  • urldecode »
  • PHP Manual
  • Funciones de URL
  • Codificar estilo URL de acuerdo al RFC 3986

rawurlencode

(PHP 4, PHP 5, PHP 7, PHP 8)

rawurlencode — Codificar estilo URL de acuerdo al RFC 3986

Descripción

rawurlencode ( string $str ) : string

Codifica la cadena dada de acuerdo al » RFC 3986.

Parámetros

str

La URL a ser codificada.

Valores devueltos

Devuelve una cadena en donde todos los caracteres no-alfanuméricos, excepto -_.~, son reemplazados con un signo de porcentaje (%) seguido de dos dígitos hexadecimales. Este es el tipo de codificación descrito en el » RFC 3986 para evitar que caracteres literales sean interpretados como delimitadores de URL especiales, y para evitar que las URLs sean modificadas por medios de transmisión con conversiones de caracteres (como algunos sistemas de correo electrónico).

Nota:

Anterior a PHP 5.3.0, rawurlencode codificaba las tildes (~) usando » RFC 1738.

Historial de cambios

Versión | Descripción
5.3.4 | Los caracteres con tilde ya no son condificados al usar rawurlencode() con EBCDIC en cadenas.
5.3.0 | Ahora sigue el » RFC 3986.

Ejemplos

Ejemplo #1 Inclusión de una contraseña en una URL FTP

<?php
echo '<a href="ftp://user:', rawurlencode('foo @+%/'),
     '@ftp.example.com/x.txt">';
?>

El resultado del ejemplo sería:

<a href="ftp://user:foo%20%40%2B%25%2F@ftp.example.com/x.txt">

O, si pasa información en un componente PATH_INFO de la URL:

Ejemplo #2 Ejemplo 2 de rawurlencode()

<?php
echo '<a href="http://example.com/department_list_script/',
    rawurlencode('sales and marketing/Miami'), '">';
?>

El resultado del ejemplo sería:

<a href="http://example.com/department_list_script/sales%20and%20marketing%2FMiami">

Ver también

  • rawurldecode() - Decodificar cadenas codificadas estilo URL
  • urldecode() - Decodifica una cadena cifrada como URL
  • urlencode() - Codifica como URL una cadena
  • » RFC 3986


Decodifica una cadena cifrada como URL

  • « rawurlencode
  • urlencode »
  • PHP Manual
  • Funciones de URL
  • Decodifica una cadena cifrada como URL

urldecode

(PHP 4, PHP 5, PHP 7, PHP 8)

urldecode — Decodifica una cadena cifrada como URL

Descripción

urldecode ( string $str ) : string

Decodifica cualquier cifrado tipo %## en la cadena dada. Los símbolos ('+') son decodificados como el caracter espacio.

Parámetros

str

La cadena a ser decodificada.

Valores devueltos

Devuelve la cadena decodificada.

Ejemplos

Ejemplo #1 Ejemplo de urldecode()

<?php
$query = "my=apples&are=green+and+red";

foreach (explode('&', $query) as $chunk) {
    $param = explode("=", $chunk);

    if ($param) {
        printf("Value for parameter \"%s\" is \"%s\"<br/>\n", urldecode($param[0]), urldecode($param[1]));
    }
}
?>

Notas

Advertencia

Las superglobales $_GET y $_REQUEST ya están decodificadas. El uso de urldecode() en un elemento en $_GET o $_REQUEST puede tener resultados inesperados y peligrosos.

Ver también

  • urlencode() - Codifica como URL una cadena
  • rawurlencode() - Codificar estilo URL de acuerdo al RFC 3986
  • rawurldecode() - Decodificar cadenas codificadas estilo URL
  • » RFC 3986


Codifica como URL una cadena

  • « urldecode
  • V8js »
  • PHP Manual
  • Funciones de URL
  • Codifica como URL una cadena

urlencode

(PHP 4, PHP 5, PHP 7, PHP 8)

urlencode — Codifica como URL una cadena

Descripción

urlencode ( string $str ) : string

Esta función es conveniente cuando se codifica una cadena a ser usada como la parte de consulta de una URL, como método práctico para pasar variables a la siguiente página.

Parámetros

str

La cadena a ser codificada.

Valores devueltos

Devuelve una cadena en la que todos los caracteres no-alfanuméricos excepto -_. han sido reemplazados con un signo de porcentaje (%) seguido por dos dígitos hexadecimales y los espacios son codificados como signos de suma (+). Esta es la misma codificación usada en los datos publicados desde un formulario WWW, es decir, el mismo mecanismo usado para el tipo de medios application/x-www-form-urlencoded. Este mecanismo difiere de la codificación en el » RFC 3986 (vea rawurlencode()) en que, por razones históricas, los espacios son codificados como signos de suma (+).

Ejemplos

Ejemplo #1 Ejemplo de urlencode()

<?php
echo '<a href="mycgi?foo=', urlencode($userinput), '">';
?>

Ejemplo #2 Ejemplo de urlencode() y ejemplo de htmlentities()

<?php
$query_string = 'foo=' . urlencode($foo) . '&bar=' . urlencode($bar);
echo '<a href="mycgi?' . htmlentities($query_string) . '">';
?>

Notas

Nota:

Tenga cuidado con las variables que puedan coincidir con entidades HTML. Secuencias como &amp, &copy y &pound son procesadas por el navegador y la entidad real es usada en lugar del nombre de variable deseado. Este es un problema obvio sobre el cual el consorcio W3 ha estado alertando a las personas por años. La referencia esta aquí: » http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2.

PHP soporta la modificación del separador de argumentos al punto-y-coma sugerido por el W3C a través de la directiva .ini arg_separator. Desafortunadamente, la mayoría de agentes de usuario no envían datos de formularios en este formato separado por punto-y-coma. Una forma más portable es usar &amp; en lugar de & como separador. No es necesario modificar el valor arg_separator de PHP para esto. Déjelo como &, y simplemente codifique sus URLs usando htmlentities() o htmlspecialchars().

Ver también

  • urldecode() - Decodifica una cadena cifrada como URL
  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • rawurlencode() - Codificar estilo URL de acuerdo al RFC 3986
  • rawurldecode() - Decodificar cadenas codificadas estilo URL
  • » RFC 3986


Motor de integración V8 Javascript

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Ejemplos
  • V8Js — The V8Js class
    • V8Js::__construct — Construct a new V8Js object
    • V8Js::executeString — Execute a string as Javascript code
    • V8Js::getExtensions — Devolver un array de extensiones registradas
    • V8Js::getPendingException — Return pending uncaught Javascript exception
    • V8Js::registerExtension — Register Javascript extensions for V8Js
  • V8JsException — La clase V8JsException
    • V8JsException::getJsFileName — El propósito getJsFileName
    • V8JsException::getJsLineNumber — El propósito getJsLineNumber
    • V8JsException::getJsSourceLine — El propósito getJsSourceLine
    • V8JsException::getJsTrace — El propósito getJsTrace


  • « V8js
  • Instalación/Configuración »
  • PHP Manual
  • V8js
  • Introducción

Introducción

Esta extensión incorpora el » Motor V8 Javascript en PHP.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

La biblioteca y los encabezados de PHP 5.3.3+ y V8 instalados en las rutas adecuadas.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/v8js


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

V8js Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
v8js.max_disposed_contexts | 25 | PHP_INI_ALL |
v8js.flags |  | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

v8js.max_disposed_contexts integer

Establece límite para contextos dispuestas antes de forzar V8 que hacer la recolección de basura.

v8js.flags string

Establece V8 opciones de la línea de comandos. La lista de los indicadores disponibles se puede obtener en el modo CLI estableciendo este parámetro en --help. Ejemplo:

$ php -r 'ini_set("v8js.flags", "--help"); new V8Js;' | less

Nota:

Por estas banderas para ser eficaz en tiempo de ejecución de la ini_set () llamada se tiene que hacer antes de que los objetos se instancian V8Js!


  • « Configuración en tiempo de ejecución
  • Ejemplos »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Ejemplos

Uso básico

Ejemplo #1 Básica ejecución Javascript

<?php

$v8 = new V8Js();

/* basic.js */
$JS = <<< EOT
len = print('¡Hola' + ' ' + 'Mundo!' + "\\n");
len;
EOT;

try {
  var_dump($v8->executeString($JS, 'basic.js'));
} catch (V8JsException $e) {
  var_dump($e);
}

?>

El resultado del ejemplo sería:

¡Hola Mundo!
int(13)


The V8Js class

(PECL v8js >= 0.1.0)

Introducción

Esta es la clase principal para la extensión de V8Js. Cada instancia creada a partir de esta clase tiene su propio contexto en el que todo el Javascript es compilado y ejecutado.

Véase V8Js::__construct() para más información.

Sinopsis de la Clase

V8Js {
/* Constants */
const string V8_VERSION ;
const integer FLAG_NONE = 1 ;
const integer FLAG_FORCE_ARRAY = 2 ;
/* Methods */
public __construct ( string $object_name = "PHP" , array $variables = array() , array $extensions = array() , bool $report_uncaught_exceptions = true )
public executeString ( string $script , string $identifier = "V8Js::executeString()" , int $flags = V8Js::FLAG_NONE ) : mixed
public static getExtensions ( ) : array
public getPendingException ( ) : V8JsException
public static registerExtension ( string $extension_name , string $script , array $dependencies = array() , bool $auto_enable = false ) : bool
}

Constantes predefinidas

V8Js::V8_VERSION

La versión del motor de Javascript V8.

V8Js::FLAG_NONE

No flags.

V8Js::FLAG_FORCE_ARRAY

Obliga a todos los objetos JS a ser arrays asociativos en PHP.

Tabla de contenidos

  • V8Js::__construct — Construct a new V8Js object
  • V8Js::executeString — Execute a string as Javascript code
  • V8Js::getExtensions — Devolver un array de extensiones registradas
  • V8Js::getPendingException — Return pending uncaught Javascript exception
  • V8Js::registerExtension — Register Javascript extensions for V8Js


Construct a new V8Js object

  • « V8Js
  • V8Js::executeString »
  • PHP Manual
  • V8Js
  • Construct a new V8Js object

V8Js::__construct

(PECL v8js >= 0.1.0)

V8Js::__construct — Construct a new V8Js object

Descripción

public V8Js::__construct
 ( string $object_name = "PHP"
, array $variables = array()
, array $extensions = array()
, bool $report_uncaught_exceptions = true
)

Constructs a new V8Js object.

Parámetros

object_name

The name of the object passed to Javascript.

variables

Map of PHP variables that will be available in Javascript. Must be an associative array in format array("name-for-js" => "name-of-php-variable"). Defaults to empty array.

extensions

List of extensions registered using V8Js::registerExtension() which should be available in the Javascript context of the created V8Js object.

Nota:

Extensions registered to be enabled automatically do not need to be listed in this array. Also if an extension has dependencies, those dependencies can be omitted as well. Defaults to empty array.

report_uncaught_exceptions

Controls whether uncaught Javascript exceptions are reported immediately or not. Defaults to true. If set to false the uncaught exception can be accessed using V8Js::getPendingException().

Valores devueltos

Returns a new V8Js context object.


Execute a string as Javascript code

  • « V8Js::__construct
  • V8Js::getExtensions »
  • PHP Manual
  • V8Js
  • Execute a string as Javascript code

V8Js::executeString

(PECL v8js >= 0.1.0)

V8Js::executeString — Execute a string as Javascript code

Descripción

public V8Js::executeString ( string $script , string $identifier = "V8Js::executeString()" , int $flags = V8Js::FLAG_NONE ) : mixed

Compiles and executes the string passed with script as Javascript code.

Parámetros

script

The code string to be executed.

identifier

Identifier string for the executed code. Used for debugging.

flags

Execution flags. This value must be one of the V8Js::FLAG_* constants, defaulting to V8Js::FLAG_NONE.

  • V8Js::FLAG_NONE: no flags

  • V8Js::FLAG_FORCE_ARRAY: forces all Javascript objects passed to PHP to be associative arrays

Valores devueltos

Returns the last variable instantiated in the Javascript code converted to matching PHP variable type.


Devolver un array de extensiones registradas

  • « V8Js::executeString
  • V8Js::getPendingException »
  • PHP Manual
  • V8Js
  • Devolver un array de extensiones registradas

V8Js::getExtensions

(PECL v8js >= 0.1.0)

V8Js::getExtensions — Devolver un array de extensiones registradas

Descripción

public static V8Js::getExtensions ( ) : array

Esta función devuelve el array de extensiones Javascript registradas mediante V8Js::registerExtension().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array de extensiones registradas o un array vacío si no hay ninguna.


Return pending uncaught Javascript exception

  • « V8Js::getExtensions
  • V8Js::registerExtension »
  • PHP Manual
  • V8Js
  • Return pending uncaught Javascript exception

V8Js::getPendingException

(PECL v8js >= 0.1.0)

V8Js::getPendingException — Return pending uncaught Javascript exception

Descripción

public V8Js::getPendingException ( ) : V8JsException

Returns any pending uncaught Javascript exception as V8JsException left from earlier V8Js::executeString() call(s).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Either V8JsException or null.


Register Javascript extensions for V8Js

  • « V8Js::getPendingException
  • V8JsException »
  • PHP Manual
  • V8Js
  • Register Javascript extensions for V8Js

V8Js::registerExtension

(PECL v8js >= 0.1.0)

V8Js::registerExtension — Register Javascript extensions for V8Js

Descripción

public static V8Js::registerExtension ( string $extension_name , string $script , array $dependencies = array() , bool $auto_enable = false ) : bool

Registers passed Javascript script as extension to be used in V8Js contexts.

Parámetros

extension_name

Name of the extension to be registered.

script

The Javascript code to be registered.

dependencies

Array of extension names the extension to be registered depends on. Any such extension is enabled automatically when this extension is loaded.

Nota:

All extensions, including the dependencies, must be registered before any V8Js are created which use them.

auto_enable

If set to true, the extension will be enabled automatically in all V8Js contexts.

Valores devueltos

Returns true if extension was registered successfully, false otherwise.


La clase V8JsException

(PECL v8js >= 0.1.0)

Introducción

Sinopsis de la Clase

V8JsException extends Exception {
/* Propiedades */
protected $JsFileName ;
protected $JsLineNumber ;
protected $JsSourceLine ;
protected $JsTrace ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
final public getJsFileName ( ) : string
final public getJsLineNumber ( ) : int
final public getJsSourceLine ( ) : string
final public getJsTrace ( ) : string
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

JsFileName

JsLineNumber

JsSourceLine

JsTrace

Tabla de contenidos

  • V8JsException::getJsFileName — El propósito getJsFileName
  • V8JsException::getJsLineNumber — El propósito getJsLineNumber
  • V8JsException::getJsSourceLine — El propósito getJsSourceLine
  • V8JsException::getJsTrace — El propósito getJsTrace


El propósito getJsFileName

  • « V8JsException
  • V8JsException::getJsLineNumber »
  • PHP Manual
  • V8JsException
  • El propósito getJsFileName

V8JsException::getJsFileName

(PECL v8js >= 0.1.0)

V8JsException::getJsFileName — El propósito getJsFileName

Descripción

final public V8JsException::getJsFileName ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito getJsLineNumber

  • « V8JsException::getJsFileName
  • V8JsException::getJsSourceLine »
  • PHP Manual
  • V8JsException
  • El propósito getJsLineNumber

V8JsException::getJsLineNumber

(PECL v8js >= 0.1.0)

V8JsException::getJsLineNumber — El propósito getJsLineNumber

Descripción

final public V8JsException::getJsLineNumber ( ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito getJsSourceLine

  • « V8JsException::getJsLineNumber
  • V8JsException::getJsTrace »
  • PHP Manual
  • V8JsException
  • El propósito getJsSourceLine

V8JsException::getJsSourceLine

(PECL v8js >= 0.1.0)

V8JsException::getJsSourceLine — El propósito getJsSourceLine

Descripción

final public V8JsException::getJsSourceLine ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito getJsTrace

  • « V8JsException::getJsSourceLine
  • Yaml »
  • PHP Manual
  • V8JsException
  • El propósito getJsTrace

V8JsException::getJsTrace

(PECL v8js >= 0.1.0)

V8JsException::getJsTrace — El propósito getJsTrace

Descripción

final public V8JsException::getJsTrace ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Serialización de datos YAML

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Callbacks
    • Análisis de callbacks
    • Emitir callbacks
  • Funciones de Yaml
    • yaml_emit_file — Enviar la representación YAML de un valor a un fichero
    • yaml_emit — Devuelve la representación de un valor YAML
    • yaml_parse_file — Analiza una secuencia de texto en formato YAML desde un fichero
    • yaml_parse_url — Analiza una secuencia de texto Yaml desde una URL
    • yaml_parse — Analiza una secuencia de texto en formato YAML


Introducción

Esta extensión implementa el estándar de serialización de datos » YAML Ain't Markup Language (YAML). El análisis y la creación son manejados por la biblioteca » LibYAML.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta extensión requiere la » LibYAML C library versión 0.1.0 o superior instalada.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yaml.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Yaml
Nombre | Por defecto | Cambiable | Historial de cambios
yaml.decode_binary | 0 | PHP_INI_ALL |
yaml.decode_timestamp | 0 | PHP_INI_ALL |
yaml.output_canonical | 0 | PHP_INI_ALL |
yaml.output_indent | 2 | PHP_INI_ALL |
yaml.output_width | 80 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

yaml.decode_binary boolean

Off por omisión, pero puede estar activado el uso de entidades base64 codificadas binariamente que tenga explicitamente el tag "tag:yaml.org,2002:binary" para ser decodificado.

yaml.decode_timestamp integer

Controla la decodificación tanto implicita y explicita escalar de "tag:yaml.org,2002:timestamp" en documentos YAML. El valor determinado es 0 que no se aplica a ningunca decodificación. Un ajuste de 1 a usar strtotime() para analizar el valor de un Unix timestamp. Un ajuste de 2 debe usar date_create() para analizar el valor del objeto DateTime.

yaml.output_canonical boolean

Off por omisión, pero puede estar activado de manera convencional desde su salida.

yaml.output_indent integer

Números de espacios para la identación. El valor debe comprender entre 1 y 10.

yaml.output_width integer

Establece el ancho de línea de preferencia. -1 significa sin límite.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Estilos de entidad escalar utilizables por los métodos de retrollamada de yaml_parse()
YAML_ANY_SCALAR_STYLE (integer)
YAML_PLAIN_SCALAR_STYLE (integer)
YAML_SINGLE_QUOTED_SCALAR_STYLE (integer)
YAML_DOUBLE_QUOTED_SCALAR_STYLE (integer)
YAML_LITERAL_SCALAR_STYLE (integer)
YAML_FOLDED_SCALAR_STYLE (integer)
Etiquetas comunes utilizables por los métodos de retrollamada de yaml_parse().
YAML_NULL_TAG (string)
"tag:yaml.org,2002:null"
YAML_BOOL_TAG (string)
"tag:yaml.org,2002:bool"
YAML_STR_TAG (string)
"tag:yaml.org,2002:str"
YAML_INT_TAG (string)
"tag:yaml.org,2002:int"
YAML_FLOAT_TAG (string)
"tag:yaml.org,2002:float"
YAML_TIMESTAMP_TAG (string)
"tag:yaml.org,2002:timestamp"
YAML_SEQ_TAG (string)
"tag:yaml.org,2002:seq"
YAML_MAP_TAG (string)
"tag:yaml.org,2002:map"
YAML_PHP_TAG (string)
"!php/object"
Tipos de codificación para yaml_emit()
YAML_ANY_ENCODING (integer)
Dejar que el emisor elija una codificación.
YAML_UTF8_ENCODING (integer)
Codificar como UTF8.
YAML_UTF16LE_ENCODING (integer)
Codificar como UTF16LE.
YAML_UTF16BE_ENCODING (integer)
Codificar como UTF16BE.
Tipos de saltos de línea para yaml_emit()
YAML_ANY_BREAK (integer)
Dejar que el emisor elija el carácter de salto de línea.
YAML_CR_BREAK (integer)
Usar \r como carácter de salto (al estilo de Mac).
YAML_LN_BREAK (integer)
Usar \n como carácter de salto (al estilo de Unix).
YAML_CRLN_BREAK (integer)
Usar \r\n como cáracter de salto (al estilo de DOS).


Ejemplos

Ejemplo #1 Yaml Example

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> "2001-01-23",
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
    );

// genera un representación de la factura en YAML
$yaml = yaml_emit($invoice);
var_dump($yaml);

// convierte lo anterior en YAML a una variable PHP
$parsed = yaml_parse($yaml);

// verifica que la comprobación de ida y vuelta a una extructura equivalente
var_dump($parsed == $invoice);
?>

El resultado del ejemplo sería algo similar a:

string(631) "---
invoice: 34843
date: "2001-01-23"
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"
bool(true)


  • « Ejemplos
  • Análisis de callbacks »
  • PHP Manual
  • Yaml
  • Callbacks

Callbacks

Tabla de contenidos

  • Análisis de callbacks
  • Emitir callbacks


Análisis de callbacks

Los análisis de callbacks son invocados por las funciones yaml_parse(), yaml_parse_file() o yaml_parse_url() cuando encuentran una etiqueta YAML registrada. Al callback se le pasa el valor de la entidad de la etiqueta, la etiqueta, y los flags que indican el estilo escalar de la entidad. El callback debe devolver los datos que el convertidor YAML debe emitir para esta entidad.

Ejemplo #1 Ejemplo de análisis de callback

<?php
/**
 * Análisis de callback para un tag yaml.
 * @param mixed $valor Datos del archivo yaml
 * @param string $tag Etiqueta que desencadenó el callback
 * @param int $flags Estilo escalar de la entidad (ver YAML_*_SCALAR_STYLE)
 * @return mixed Valor que el convertidor YAML debería emitir para el valor dado
 */
function tag_callback ($valor, $tag, $flags) {
  var_dump(func_get_args()); // depurando
  return "Hola {$valor}";
}

$yaml = <<<YAML
saludo: !ejemplo/hola Mundo
YAML;

$resultado = yaml_parse($yaml, 0, $ndocs, array(
    '!ejemplo/hola' => 'tag_callback',
  ));

var_dump($resultado);
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  string(5) "Mundo"
  [1]=>
  string(14) "!ejemplo/hola"
  [2]=>
  int(1)
}
array(1) {
  ["saludo"]=>
  string(11) "Hola Mundo"
}


Emitir callbacks

Las emisiones de callbacks son invocadas cuando una instancia de una clase registrada es emitida por la función yaml_emit() o la función yaml_emit_file(). El callback se pasa al objeto a ser emitido. El callback debe devolver un array que contenga dos claves: "tag" y "data". El valor asociado con la clave "tag" debe ser un string a ser usado como la etiqueta YAML en la salida. El valor asociado con la clave "data" será encodeado como YAML y será emitido en lugar del objeto interceptado.

Ejemplo #1 Ejemplo de emisión de callback

<?php
class EmitExample {
  public $data;    // los datos podrían ser ajustables en cualquier tipo de pecl/yaml

  public function __construct ($d) {
    $this->data = $d;
  }

  /**
   * Yaml emite la función de callback, referida a la llamada yaml_emit por el nombre de la clase.
   *
   * Se espera que devuelva un array con 2 valores:
   *   - 'tag': etiqueta personalizada para esta serialización
   *   - 'data': valor que se convierte a yaml (ya sea array, string, bool, número)
   *
   * @param object $obj Objeto a ser emitido
   * @return array Etiqueta y datos sustitutivos a emitir
   */
  public static function yamlEmit (EmitExample $obj) {
    return array(
      'tag' => '!example/emit',
      'data' => $obj->data,
    );
  }
}

$emit_callbacks = array(
  'EmitExample' => array('EmitExample', 'yamlEmit')
);

$t = new EmitExample(array('a','b','c'));
$yaml = yaml_emit(
  array(
    'example' => $t,
  ),
  YAML_ANY_ENCODING,
  YAML_ANY_BREAK,
  $emit_callbacks
);
var_dump($yaml);
?>

El resultado del ejemplo sería algo similar a:

string(43) "---
example: !example/emit
- a
- b
- c
...
"


Funciones de Yaml

Tabla de contenidos

  • yaml_emit_file — Enviar la representación YAML de un valor a un fichero
  • yaml_emit — Devuelve la representación de un valor YAML
  • yaml_parse_file — Analiza una secuencia de texto en formato YAML desde un fichero
  • yaml_parse_url — Analiza una secuencia de texto Yaml desde una URL
  • yaml_parse — Analiza una secuencia de texto en formato YAML


Enviar la representación YAML de un valor a un fichero

  • « Funciones de Yaml
  • yaml_emit »
  • PHP Manual
  • Funciones de Yaml
  • Enviar la representación YAML de un valor a un fichero

yaml_emit_file

(PECL yaml >= 0.5.0)

yaml_emit_file — Enviar la representación YAML de un valor a un fichero

Descripción

yaml_emit_file ( string $filename , mixed $data , int $encoding = YAML_ANY_ENCODING , int $linebreak = YAML_ANY_BREAK , array $callbacks = null ) : bool

Genera una representación YAML de data proporcionada en el filename.

Parámetros

filename

Ruta a el fichero.

data

La data se codifica. Puede ser de cualquier tipo excepto un resource.

encoding

Salida de codificación de carácteres seleccionando entre YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Salida del estilo de salto de línea seleccionando entre YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Manejadores de contenido para emitir nodos YAML. array asociativo de nombre de clase de asignaciones => callable. Véase emit callbacks para más detalles.

Valores devueltos

Devuelve true en caso de éxito.

Historial de cambios

Versión | Descripción
1.1.0 | El parámetro callbacks fue añadido.

Ver también

  • yaml_emit() - Devuelve la representación de un valor YAML
  • yaml_parse() - Analiza una secuencia de texto en formato YAML


Devuelve la representación de un valor YAML

  • « yaml_emit_file
  • yaml_parse_file »
  • PHP Manual
  • Funciones de Yaml
  • Devuelve la representación de un valor YAML

yaml_emit

(PECL yaml >= 0.5.0)

yaml_emit — Devuelve la representación de un valor YAML

Descripción

yaml_emit ( mixed $data , int $encoding = YAML_ANY_ENCODING , int $linebreak = YAML_ANY_BREAK , array $callbacks = null ) : string

Genera una representación YAML de los datos en data proporcionados.

Parámetros

data

La data se codifica. Puede ser de cualquier tipo excepto un resource.

encoding

Salida de codificación de caracteres elegidos desde YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Estilo de salida de línea de salto desde: YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Gestores de contenido para emitir nodos YAML. array asociativo de referenciaciones de nombres de clase => callable. Véase emitir llamadas de retorno para más detalles.

Valores devueltos

Devuelve un string de YAML codificado si es correcto.

Historial de cambios

Versión | Descripción
1.1.0 | Se añadió el parámetro callbacks.

Ejemplos

Ejemplo #1 Ejemplo de yaml_emit()

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> 980208000,
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
  );
var_dump(yaml_emit($invoice));
?>

El resultado del ejemplo sería algo similar a:

string(628) "---
invoice: 34843
date: 980208000
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"

Ver también

  • yaml_emit_file() - Enviar la representación YAML de un valor a un fichero
  • yaml_parse() - Analiza una secuencia de texto en formato YAML


Analiza una secuencia de texto en formato YAML desde un fichero

  • « yaml_emit
  • yaml_parse_url »
  • PHP Manual
  • Funciones de Yaml
  • Analiza una secuencia de texto en formato YAML desde un fichero

yaml_parse_file

(PECL yaml >= 0.4.0)

yaml_parse_file — Analiza una secuencia de texto en formato YAML desde un fichero

Descripción

yaml_parse_file ( string $filename , int $pos = 0 , int &$ndocs = ? , array $callbacks = null ) : mixed

Convierte toda o parte de una secuencia de texto en YAML a una variable en PHP.

Parámetros

filename

Ruta del nombre del fichero.

pos

Documento YAML a extraer desde la secuencia de texto (-1 para analizar todos los documentos, 0 solo para el primer documento, etc).

ndocs

Si se facilita ndocs, se completará con el número de documentos encontrados en la secuencia de texto.

callbacks

Controlador de contenido para los nodos YAML. Es un array associativo de etiquetas YAML => asociando sus callback correspondientes. Ver Analizar callbacks para más información.

Valores devueltos

Devuelve el valor codificado de input en el formato apropiado de PHP o false en caso de error. Si el valor de pos es -1 devolverá un array con una entrada por cada documento encontrado en el texto.

Notas

Advertencia

El procesamiento de las entradas de los usuarios no confiables con yaml_parse_file() es peligroso si el uso de unserialize() está habilitado para los nodos usando la etiqueta !php/object. Este comportamiento puede ser desactivado por el uso de el ajuste ini yaml.decode_php.

Ver también

  • yaml_parse() - Analiza una secuencia de texto en formato YAML
  • yaml_parse_url() - Analiza una secuencia de texto Yaml desde una URL
  • yaml_emit() - Devuelve la representación de un valor YAML


Analiza una secuencia de texto Yaml desde una URL

  • « yaml_parse_file
  • yaml_parse »
  • PHP Manual
  • Funciones de Yaml
  • Analiza una secuencia de texto Yaml desde una URL

yaml_parse_url

(PECL yaml >= 0.4.0)

yaml_parse_url — Analiza una secuencia de texto Yaml desde una URL

Descripción

yaml_parse_url ( string $url , int $pos = 0 , int &$ndocs = ? , array $callbacks = ? ) : mixed

Convierte toda o parte de una secuencia de texto en YAML a una variable en PHP.

Parámetros

url

La dirección url debe tener el formato "scheme://...". PHP buscará el controlador de protocolos (también conocido como wrapper) para el esquema especificado. Si no hay wrappers registrados para este protocolo, PHP lanzará un aviso para ayudar a indentificar posibles problemas con el script y continuar como si el nombre del fichero hiciera referencia a un fichero normal.

pos

Documento YAML a extraer desde la secuencia de texto (-1 para analizar todos los documentos, 0 solo para el primer documento, etc).

ndocs

Si se facilita ndocs, se completará con el número de documentos encontrados en la secuencia de texto.

callbacks

Controlador de contenido para los nodos YAML. Es un array associativo de etiquetas YAML => asociando sus callback correspondientes. Ver Analizar callbacks para más información

Valores devueltos

Devuelve el valor codificado de input en el formato apropiado de PHP o false en caso de error. Si el valor de pos es -1 devolverá un array con una entrada por cada documento encontrado en el texto.

Ver también

  • yaml_parse() - Analiza una secuencia de texto en formato YAML
  • yaml_parse_file() - Analiza una secuencia de texto en formato YAML desde un fichero
  • yaml_emit() - Devuelve la representación de un valor YAML


Analiza una secuencia de texto en formato YAML

  • « yaml_parse_url
  • Yaf »
  • PHP Manual
  • Funciones de Yaml
  • Analiza una secuencia de texto en formato YAML

yaml_parse

(PECL yaml >= 0.4.0)

yaml_parse — Analiza una secuencia de texto en formato YAML

Descripción

yaml_parse ( string $input , int $pos = 0 , int &$ndocs = ? , array $callbacks = null ) : mixed

Convierte toda o parte de una secuencia de texto en YAML a una variable en PHP.

Parámetros

input

La secuencia de texto (string) a analizar en formato YAML.

pos

Documento YAML a extraer desde la secuencia de texto (-1 para analizar todos los documentos, 0 solo para el primer documento, etc).

ndocs

Si se facilita ndocs, se completará con el número de documentos encontrados en la secuencia de texto.

callbacks

Controlador de contenido para los nodos YAML. Es un array associativo de etiquetas YAML => asociando sus callback correspondientes. Ver Analizar callbacks para más información.

Valores devueltos

Devuelve el valor codificado de input en el formato apropiado de PHP o false en caso de error. Si el valor de pos es -1 devolverá un array con una entrada por cada documento encontrado en el texto.

Ejemplos

Ejemplo #1 Ejemplo de yaml_parse()

<?php
$yaml = <<<EOD
---
invoice: 34843
date: "2001-01-23"
bill-to: &id001
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to: *id001
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
EOD;

$parsed = yaml_parse($yaml);
var_dump($parsed);
?>

El resultado del ejemplo sería algo similar a:

array(8) {
  ["invoice"]=>
  int(34843)
  ["date"]=>
  string(10) "2001-01-23"
  ["bill-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["ship-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["product"]=>
  array(2) {
    [0]=>
    array(4) {
      ["sku"]=>
      string(6) "BL394D"
      ["quantity"]=>
      int(4)
      ["description"]=>
      string(10) "Basketball"
      ["price"]=>
      int(450)
    }
    [1]=>
    array(4) {
      ["sku"]=>
      string(7) "BL4438H"
      ["quantity"]=>
      int(1)
      ["description"]=>
      string(10) "Super Hoop"
      ["price"]=>
      int(2392)
    }
  }
  ["tax"]=>
  float(251.42)
  ["total"]=>
  float(4443.52)
  ["comments"]=>
  string(68) "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338."
}

Notas

Advertencia

El procesamiento de las entradas de los usuarios no confiables con yaml_parse() es peligroso si el uso de unserialize() está habilitado para los nodos usando la etiqueta !php/object. Este comportamiento puede ser desactivado por el uso de el ajuste ini yaml.decode_php.

Ver también

  • yaml_parse_file() - Analiza una secuencia de texto en formato YAML desde un fichero
  • yaml_parse_url() - Analiza una secuencia de texto Yaml desde una URL
  • yaml_emit() - Devuelve la representación de un valor YAML


Yet Another Framework

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Configuración de la Aplicación
  • Yaf_Application — La clase Yaf_Application
    • Yaf_Application::app — Recuperar una instancia de la clase Application
    • Yaf_Application::bootstrap — Llamar al arranque
    • Yaf_Application::clearLastError — Limpiar la información del último error
    • Yaf_Application::__construct — El constructor de la clase Yaf_Application
    • Yaf_Application::__destruct — El propósito de __destruct
    • Yaf_Application::environ — Recuperar el entorno
    • Yaf_Application::execute — Ejecutar una llamada de retorno
    • Yaf_Application::getAppDirectory — Obtener el directorio de la aplicación
    • Yaf_Application::getConfig — Recuperar la instancia de configuración
    • Yaf_Application::getDispatcher — Obtener la instancia de la clase Yaf_Dispatcher
    • Yaf_Application::getLastErrorMsg — Obtener el mensaje del último error ocurrido
    • Yaf_Application::getLastErrorNo — Pbetner el código del último error ocurrido
    • Yaf_Application::getModules — Obtener los nombres de los modulos definidos
    • Yaf_Application::run — Iniciar una instancia de la clase Yaf_Application
    • Yaf_Application::setAppDirectory — Cambiar el directorio de la aplicación
  • Yaf_Bootstrap_Abstract — La clase Yaf_Bootstrap_Abstract
  • Yaf_Dispatcher — La clase Yaf_Dispatcher
    • Yaf_Dispatcher::autoRender — Activa/desactiva la autointerpretación
    • Yaf_Dispatcher::catchException — Activar/desactivar la captura de excepciones
    • Yaf_Dispatcher::__construct — Constructor de la clase Yaf_Dispatcher
    • Yaf_Dispatcher::disableView — Deshabilita la interpretación de vistas
    • Yaf_Dispatcher::dispatch — Despachar una petición
    • Yaf_Dispatcher::enableView — Habilita la interpretación de vistas
    • Yaf_Dispatcher::flushInstantly — Activa/desactiva el vaciado instantáneo
    • Yaf_Dispatcher::getApplication — Recupera la aplicación
    • Yaf_Dispatcher::getDefaultAction — Recupera el nombre de la acción por defecto
    • Yaf_Dispatcher::getDefaultController — Recupera el nombre del controlador predeterminado
    • Yaf_Dispatcher::getDefaultModule — Recupera el nombre del módulo por defecto
    • Yaf_Dispatcher::getInstance — Recupeara la instancia despachadora
    • Yaf_Dispatcher::getRequest — Recupera la instancia de petición
    • Yaf_Dispatcher::getRouter — Recuperar la instancia de envío
    • Yaf_Dispatcher::initView — Inicializa una vista y la devuelve
    • Yaf_Dispatcher::registerPlugin — Registra un complemento
    • Yaf_Dispatcher::returnResponse — El propósito de returnResponse
    • Yaf_Dispatcher::setDefaultAction — Cambia el nombre de la acción predeterminada
    • Yaf_Dispatcher::setDefaultController — Cambia el nombre del controlador predeterminado
    • Yaf_Dispatcher::setDefaultModule — Cambia el nombre del módulo predeterminado
    • Yaf_Dispatcher::setErrorHandler — Establece el gestor de errores
    • Yaf_Dispatcher::setRequest — El propósito de setRequest
    • Yaf_Dispatcher::setView — Establecer un motor de vistas personalizado
    • Yaf_Dispatcher::throwException — Activa/desactiva el lanzamiento de excepciones
  • Yaf_Config_Abstract — La clase Yaf_Config_Abstract
    • Yaf_Config_Abstract::get — Consultor
    • Yaf_Config_Abstract::readonly — Buscar si una configuración es de sólo lectura
    • Yaf_Config_Abstract::set — Modificador
    • Yaf_Config_Abstract::toArray — Convertir en un array
  • Yaf_Config_Ini — La clase Yaf_Config_Ini
    • Yaf_Config_Ini::__construct — Constructor de Yaf_Config_Ini
    • Yaf_Config_Ini::count — Contar todos los elementos en Yaf_Config.ini
    • Yaf_Config_Ini::current — Recuperar el valor actual
    • Yaf_Config_Ini::__get — Recuperar un elemento
    • Yaf_Config_Ini::__isset — Determinar si existe una clave
    • Yaf_Config_Ini::key — Buscar la clave del elemento actual
    • Yaf_Config_Ini::next — Avanzar el puntero interno
    • Yaf_Config_Ini::offsetExists — El propósito de offsetExists
    • Yaf_Config_Ini::offsetGet — El propósito de offsetGet
    • Yaf_Config_Ini::offsetSet — El propósito de offsetSet
    • Yaf_Config_Ini::offsetUnset — El propósito de offsetUnset
    • Yaf_Config_Ini::readonly — El propósito de readonly
    • Yaf_Config_Ini::rewind — El propósito de rewind
    • Yaf_Config_Ini::__set — El propósito de __set
    • Yaf_Config_Ini::toArray — Devuelve la configuración como un array PHP
    • Yaf_Config_Ini::valid — El propósito de valid
  • Yaf_Config_Simple — LA clase Yaf_Config_Simple
    • Yaf_Config_Simple::__construct — El propósito de __construct
    • Yaf_Config_Simple::count — El propósito de count
    • Yaf_Config_Simple::current — El propósito de current
    • Yaf_Config_Simple::__get — El propósito de __get
    • Yaf_Config_Simple::__isset — El propósito de __isset
    • Yaf_Config_Simple::key — El propósito de key
    • Yaf_Config_Simple::next — El propósito de next
    • Yaf_Config_Simple::offsetExists — El propósito de offsetExists
    • Yaf_Config_Simple::offsetGet — El propósito de offsetGet
    • Yaf_Config_Simple::offsetSet — El propósito de offsetSet
    • Yaf_Config_Simple::offsetUnset — El propósito de offsetUnset
    • Yaf_Config_Simple::readonly — El propósito de readonly
    • Yaf_Config_Simple::rewind — El propósito de rewind
    • Yaf_Config_Simple::__set — El propósito de __set
    • Yaf_Config_Simple::toArray — Devuelve un array de PHP
    • Yaf_Config_Simple::valid — El propósito de valid
  • Yaf_Controller_Abstract — La clase Yaf_Controller_Abstract
    • Yaf_Controller_Abstract::__construct — Constructor de Yaf_Controller_Abstract
    • Yaf_Controller_Abstract::display — El propósito de display
    • Yaf_Controller_Abstract::forward — Avanza a la siguiente acción
    • Yaf_Controller_Abstract::getInvokeArg — El propósito de getInvokeArg
    • Yaf_Controller_Abstract::getInvokeArgs — El propósito de getInvokeArgs
    • Yaf_Controller_Abstract::getModuleName — Obtiene el nombre del módulo
    • Yaf_Controller_Abstract::getName — Obtener el nombre propio
    • Yaf_Controller_Abstract::getRequest — Recupera el objeto petición actual
    • Yaf_Controller_Abstract::getResponse — Recupera el objeto respuesta actual
    • Yaf_Controller_Abstract::getView — Recupera el motor de vistas
    • Yaf_Controller_Abstract::getViewpath — El propósito de getViewpath
    • Yaf_Controller_Abstract::init — Inicializador del controlador
    • Yaf_Controller_Abstract::initView — El propósito de initView
    • Yaf_Controller_Abstract::redirect — Redirige a un URL
    • Yaf_Controller_Abstract::render — Interpreta una plantilla de vista
    • Yaf_Controller_Abstract::setViewpath — El propósito de setViewpath
  • Yaf_Action_Abstract — La clase Yaf_Action_Abstract
    • Yaf_Action_Abstract::execute — Punto de entrada de una acción
    • Yaf_Action_Abstract::getController — Recupera el objeto controlador
    • Yaf_Action_Abstract::getControllerName — Obtener el nombre del controlador
  • Yaf_View_Interface — La clase Yaf_View_Interface
    • Yaf_View_Interface::assign — Asignar valores al motor de Vistas
    • Yaf_View_Interface::display — Interpretar e imprimir una plantilla
    • Yaf_View_Interface::getScriptPath — El propósito de getScriptPath
    • Yaf_View_Interface::render — Interpretar una plantilla
    • Yaf_View_Interface::setScriptPath — El propósito de setScriptPath
  • Yaf_View_Simple — La clase Yaf_View_Simple
    • Yaf_View_Simple::assign — Asignar valores
    • Yaf_View_Simple::assignRef — El propósito de assignRef
    • Yaf_View_Simple::clear — Limpiar valores asignados
    • Yaf_View_Simple::__construct — El constructor de Yaf_View_Simple
    • Yaf_View_Simple::display — Interpretar y mostrar
    • Yaf_View_Simple::eval — Interpreta una plantilla
    • Yaf_View_Simple::__get — Recupera una variable asignada
    • Yaf_View_Simple::getScriptPath — Obtiene el directorio de plantillas
    • Yaf_View_Simple::__isset — El propósito de __isset
    • Yaf_View_Simple::render — Interpreta una plantilla
    • Yaf_View_Simple::__set — Establece el valor para el motor
    • Yaf_View_Simple::setScriptPath — Establece el directorio de plantillas
  • Yaf_Loader — La clase Yaf_Loader
    • Yaf_Loader::autoload — El propósito de autoload
    • Yaf_Loader::clearLocalNamespace — El propósito de clearLocalNamespace
    • Yaf_Loader::__construct — El propósito de __construct
    • Yaf_Loader::getInstance — El propósito de getInstance
    • Yaf_Loader::getLibraryPath — Obtener la ruta de la biblioteca
    • Yaf_Loader::getLocalNamespace — El propósito de getLocalNamespace
    • Yaf_Loader::getNamespacePath — Recupera la ruta de un espacio de nombres registrado
    • Yaf_Loader::getLocalNamespace — Recupera toda la información de un espacio de nombre
    • Yaf_Loader::import — El propósito de import
    • Yaf_Loader::isLocalName — El propósito de isLocalName
    • Yaf_Loader::registerLocalNamespace — Registra un prefijo de clase local
    • Yaf_Loader::registerNamespace — Registra un espacio de nombre con ruta de búsqueda
    • Yaf_Loader::setLibraryPath — Cmabiar la ruta de la biblioteca
  • Yaf_Plugin_Abstract — La clase Yaf_Plugin_Abstract
    • Yaf_Plugin_Abstract::dispatchLoopShutdown — El propósito de dispatchLoopShutdown
    • Yaf_Plugin_Abstract::dispatchLoopStartup — Enganchar antes del bucle de envío
    • Yaf_Plugin_Abstract::postDispatch — El propósito de postDispatch
    • Yaf_Plugin_Abstract::preDispatch — El propósito de preDispatch
    • Yaf_Plugin_Abstract::preResponse — El propósito de preResponse
    • Yaf_Plugin_Abstract::routerShutdown — El propósito de routerShutdown
    • Yaf_Plugin_Abstract::routerStartup — Enganche deEl propósito de routerStartup
  • Yaf_Registry — La clase Yaf_Registry
    • Yaf_Registry::__construct — Yaf_Registry implementa «singleton»
    • Yaf_Registry::del — Elimina un elemento del registro
    • Yaf_Registry::get — Recupera un elemento del registro
    • Yaf_Registry::has — Comprueba si existe un elemento
    • Yaf_Registry::set — Añade un elemento al registro
  • Yaf_Request_Abstract — La clase Yaf_Request_Abstract
    • Yaf_Request_Abstract::clearParams — Eliminar todos los parámetros
    • Yaf_Request_Abstract::getActionName — El propósito de getActionName
    • Yaf_Request_Abstract::getBaseUri — El propósito de getBaseUri
    • Yaf_Request_Abstract::getControllerName — El propósito de getControllerName
    • Yaf_Request_Abstract::getEnv — Recupera la variable ENV
    • Yaf_Request_Abstract::getException — El propósito de getException
    • Yaf_Request_Abstract::getLanguage — Recupera el lenguaje preferido del cliente
    • Yaf_Request_Abstract::getMethod — Recupera el método de solicitud
    • Yaf_Request_Abstract::getModuleName — El propósito de getModuleName
    • Yaf_Request_Abstract::getParam — Recupera el parámetro de llamada
    • Yaf_Request_Abstract::getParams — Recupera todos los parámetros de llamada
    • Yaf_Request_Abstract::getRequestUri — El propósito de getRequestUri
    • Yaf_Request_Abstract::getServer — Recupera la variable SERVER
    • Yaf_Request_Abstract::isCli — Determina si la solicitud es una solicitud CLI
    • Yaf_Request_Abstract::isDispatched — Determina si la solicitud es enviada
    • Yaf_Request_Abstract::isGet — Determina si la solicitud es una solicitud GET
    • Yaf_Request_Abstract::isHead — Determina si la solicitud es una solicitud HEAD
    • Yaf_Request_Abstract::isOptions — Determina si la solicitud es una solicitud de OPCIONES
    • Yaf_Request_Abstract::isPost — Determina si la solicitud es una solicitud POST
    • Yaf_Request_Abstract::isPut — Determina si la solicitud es una solicitud PUT
    • Yaf_Request_Abstract::isRouted — Determina si la solicitud ha sido enrutada
    • Yaf_Request_Abstract::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX
    • Yaf_Request_Abstract::setActionName — Establece el nombre de la acción
    • Yaf_Request_Abstract::setBaseUri — Establecer el URI base
    • Yaf_Request_Abstract::setControllerName — El propósito de setControllerName
    • Yaf_Request_Abstract::setDispatched — El propósito de setDispatched
    • Yaf_Request_Abstract::setModuleName — El propósito de setModuleName
    • Yaf_Request_Abstract::setParam — El propósito de setParam
    • Yaf_Request_Abstract::setRequestUri — El propósito de setRequestUri
    • Yaf_Request_Abstract::setRouted — El propósito de setRouted
  • Yaf_Request_Http — La clase Yaf_Request_Http
    • Yaf_Request_Http::__construct — Constructor de Yaf_Request_Http
    • Yaf_Request_Http::get — Recupera una variable del cliente
    • Yaf_Request_Http::getCookie — Recupera una varible de Cookie
    • Yaf_Request_Http::getFiles — El propósito de getFiles
    • Yaf_Request_Http::getPost — Recupera una variable de POST
    • Yaf_Request_Http::getQuery — Obtiene un parámetro de una consulta
    • Yaf_Request_Http::getRaw — Recupera el cuerpo de la solicitud de raw
    • Yaf_Request_Http::getRequest — El propósito de getRequest
    • Yaf_Request_Http::isXmlHttpRequest — Determina si la solicitud es una solicitud de Ajax
  • Yaf_Request_Simple — La clase Yaf_Request_Simple
    • Yaf_Request_Simple::__construct — Constructor de Yaf_Request_Simple
    • Yaf_Request_Simple::get — El propósito de get
    • Yaf_Request_Simple::getCookie — El propósito de getCookie
    • Yaf_Request_Simple::getFiles — El propósito de getFiles
    • Yaf_Request_Simple::getPost — El propósito de getPost
    • Yaf_Request_Simple::getQuery — El propósito de getQuery
    • Yaf_Request_Simple::getRequest — El propósito de getRequest
    • Yaf_Request_Simple::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX
  • Yaf_Response_Abstract — La clase Yaf_Response_Abstract
    • Yaf_Response_Abstract::appendBody — Añadir contenido al cuerpo de respuesta
    • Yaf_Response_Abstract::clearBody — Descarta todo el cuerpo de respuesta existente
    • Yaf_Response_Abstract::clearHeaders — Descarta todas las cabeceras establecidas
    • Yaf_Response_Abstract::__construct — El propósito de __construct
    • Yaf_Response_Abstract::__destruct — El propósito de __destruct
    • Yaf_Response_Abstract::getBody — Recupera un contenido existente
    • Yaf_Response_Abstract::getHeader — El propósito de getHeader
    • Yaf_Response_Abstract::prependBody — El propósito de prependBody
    • Yaf_Response_Abstract::response — Envía una respuesta
    • Yaf_Response_Abstract::setAllHeaders — El propósito de setAllHeaders
    • Yaf_Response_Abstract::setBody — Establece el contenido de una respuesta
    • Yaf_Response_Abstract::setHeader — Establece cabecera de respuesta
    • Yaf_Response_Abstract::setRedirect — El propósito de setRedirect
    • Yaf_Response_Abstract::__toString — Recupera todo el cuerpo como un string
  • Yaf_Route_Interface — La clase Yaf_Route_Interface
    • Yaf_Route_Interface::assemble — Ensamblar una petición
    • Yaf_Route_Interface::route — Enruta una petición
  • Yaf_Route_Map — La clase Yaf_Route_Map
    • Yaf_Route_Map::assemble — Ensamblar un URL
    • Yaf_Route_Map::__construct — El propósito de __construct
    • Yaf_Route_Map::route — El propósito de route
  • Yaf_Route_Regex — La clase Yaf_Route_Regex
    • Yaf_Route_Regex::assemble — Ensamblar un URL
    • Yaf_Route_Regex::__construct — Constructor de Yaf_Route_Regex
    • Yaf_Route_Regex::route — El propósito de route
  • Yaf_Route_Rewrite — La clase Yaf_Route_Rewrite
    • Yaf_Route_Rewrite::assemble — Ensamblar un URL
    • Yaf_Route_Rewrite::__construct — Constructor de Yaf_Route_Rewrite
    • Yaf_Route_Rewrite::route — El propósito de route
  • Yaf_Router — La clase Yaf_Router
    • Yaf_Router::addConfig — Añadir rutas definidas en configuración al Enrutador
    • Yaf_Router::addRoute — Añadir una nueva ruta al Enrutador
    • Yaf_Router::__construct — El constructor de Yaf_Router
    • Yaf_Router::getCurrentRoute — Obtener el nombre de la ruta efectiva
    • Yaf_Router::getRoute — Recupera una ruta por su nombre
    • Yaf_Router::getRoutes — Recupera las rutas registradas
    • Yaf_Router::route — El propósito de route
  • Yaf_Route_Simple — La clase Yaf_Route_Simple
    • Yaf_Route_Simple::assemble — Ensamblar un URL
    • Yaf_Route_Simple::__construct — El constructor de la clase Yaf_Route_Simple
    • Yaf_Route_Simple::route — Enviar una petición
  • Yaf_Route_Static — La clase Yaf_Route_Static
    • Yaf_Route_Static::assemble — Ensamblar un URL
    • Yaf_Route_Static::match — El propósito de match
    • Yaf_Route_Static::route — Enviar una petición
  • Yaf_Route_Supervar — La clase Yaf_Route_Supervar
    • Yaf_Route_Supervar::assemble — Ensamblar un URL
    • Yaf_Route_Supervar::__construct — El propósito de __construct
    • Yaf_Route_Supervar::route — El propósito de route
  • Yaf_Session — La clase Yaf_Session
    • Yaf_Session::__construct — Constructor de Yaf_Session
    • Yaf_Session::count — El propósito de count
    • Yaf_Session::current — El propósito de current
    • Yaf_Session::del — El propósito de del
    • Yaf_Session::__get — El propósito de __get
    • Yaf_Session::getInstance — El propósito de getInstance
    • Yaf_Session::has — El propósito de has
    • Yaf_Session::__isset — El propósito de __isset
    • Yaf_Session::key — El propósito de key
    • Yaf_Session::next — El propósito de next
    • Yaf_Session::offsetExists — El propósito de offsetExists
    • Yaf_Session::offsetGet — El propósito de offsetGet
    • Yaf_Session::offsetSet — El propósito de offsetSet
    • Yaf_Session::offsetUnset — El propósito de offsetUnset
    • Yaf_Session::rewind — El propósito de rewind
    • Yaf_Session::__set — El propósito de __set
    • Yaf_Session::start — El propósito de start
    • Yaf_Session::__unset — El propósito de __unset
    • Yaf_Session::valid — El propósito de valid
  • Yaf_Exception — La clase Yaf_Exception
    • Yaf_Exception::__construct — El propósito de __construct
    • Yaf_Exception::getPrevious — El propósito de getPrevious
  • Yaf_Exception_TypeError — La clase Yaf_Exception_TypeError
  • Yaf_Exception_StartupError — La clase Yaf_Exception_StartupError
  • Yaf_Exception_DispatchFailed — La clase Yaf_Exception_DispatchFailed
  • Yaf_Exception_RouterFailed — La clase Yaf_Exception_RouterFailed
  • Yaf_Exception_LoadFailed — La clase Yaf_Exception_LoadFailed
  • Yaf_Exception_LoadFailed_Module — La clase Yaf_Exception_LoadFailed_Module
  • Yaf_Exception_LoadFailed_Controller — La clase Yaf_Exception_LoadFailed_Controller
  • Yaf_Exception_LoadFailed_Action — La clase Yaf_Exception_LoadFailed_Action
  • Yaf_Exception_LoadFailed_View — La clase Yaf_Exception_LoadFailed_View


Introducción

La extensión Yet Another Framework (Yaf) -Otro Framework Más, en español- es un framework de PHP usado para desarrollar aplicaciones web.

Yaf requiere una versión de PHP superior a la 5.2.1. Las versiones anteriores podrían no funcionar.

Se puede encontrar una comparativa sencilla en » Rendimiento de Yaf.

Para una guía rápida, consulte la sección Turoriales.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yaf.

Los binarios de Windows (ficheros DLL) para esta extensión de PECL están disponibles en el sitio web de PECL.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Yaf
Nombre | Por defecto | Cambiable | Historial de cambios
yaf.library |  | PHP_INI_ALL |
yaf.action_prefer | 0 | PHP_INI_ALL |
yaf.lowcase_path | 0 | PHP_INI_ALL |
yaf.use_spl_autoload | 0 | PHP_INI_ALL |
yaf.forward_limit | 5 | PHP_INI_ALL |
yaf.name_suffix | 1 | PHP_INI_ALL |
yaf.name_separator |  | PHP_INI_ALL |
yaf.cache_config | 0 | PHP_INI_SYSTEM |
yaf.environ | product | PHP_INI_SYSTEM |
yaf.use_namespace | 0 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

yaf.library string

La ruta de la biblioteca global, Yaf_loader buscará la biblioteca global dentro de este directorio.

yaf.action_prefer integer

Si solamente hay una parte en PATH_INFO, debería considerarse como un controlador o una acción.

Si se configura a "On", se considerará como un nombre de una Acción.

yaf.lowcase_path integer

Si transformar a minúsculas todas las rutas durante la autocarga de clases.

yaf.use_spl_autoload integer

Cuando este valor es "On", si Yaf_Loader no puede encontrar una clase, devolverá false, después da la oportunidad de llamar a otra función de autocarga.

Cuando este valor es "Off", si Yaf_Loader no puede encontrar una clase, devolverá true, y hará que la autocarga de la clase falle permanentemente.

Nota:

Yaf registrará su cargador durante la instanciación de Yaf_Application, por lo que cualquier otro autocargador que se registre antes de la instanciación será llamado antes de Yaf_Loader::autoload().

Cuando este valor es "Off" (predeterminado), Yaf_Loader::autoload() devolverá siempre true.

yaf.forward_limit integer

La cuenta hacia adelante máxima, por defecto es 5, lo que significa que se puede tener un valor máximo de 5 en la pila hacia adelante.

Esto es una protección para prevenir Yaf_Controller_Abstract::forward() recursivas.

yaf.name_suffix integer

Cuando es "On", Yaf_Loader identificará una clase por su sufijo para decidir si es una clase MVC.

Cuando es "Off", Yaf_Loader buscará el prefijo del nombre de la clase.

yaf.name_separator string

Cuando no está vacío, Yaf_Loader identificará el sufijo de la clase y el valor de la cadena para ésta.

Por ejemplo, cuando este valor es "_", Yaf_Loader tomará Index_Controller como una clase Controladora, e IndexController como una clase normal.

yaf.cache_config integer

Si es "On", y mientras que se use el archifo de configuración ini como parámetro de Yaf_Application(), el resultado de la compilación del fichero de configuración ini será almacenado en caché en el proceso de PHP.

Nota:

Yaf examina el mtime del fichero ini, y si cambió desde la última compilación, Yaf lo recargará.

Advertencia

Yaf utiliza la ruta del fichero ini como la clave de entrada de caché, por lo que usa la ruta absoluta en la ruta del fichero ini, de otro modo podrían existir conflictos si dos aplicaciones usasen la misma ruta relativa de la configuración ini.

yaf.environ string

Este valor es "product" por omisión, usado por Yaf para obtener la sección de configuración de un fichero de configuración ini.

Es decir, si este valor es "product", Yaf usará la sección llamada "product" en el fichero de configuración ini (el primier parámetro de la clase Yaf_Application) como configuración final de la clase Yaf_Application.

yaf.use_namespace integer

Sólo funciona a partir de PHP 5.3, si este valor es "On", todas las clases de Yaf se nombrarán al estilo del espacio de nombres.

Por ejemplo:

Yaf_Route_Rewrite => \Yaf\Route\Rewrite
Yaf_Request_Http  => \Yaf\Request\Http
Existe una excepción, que es algunas clases como Yaf_Controller_Abstract. El último coponente es una palabra clave de PHP, no podría usarse como nombre de una clase, por lo que para tales clases:
Yaf_Controller_Abstract => \Yaf\Controller_Abstract
Yaf_Route_Static => \Yaf\Route_Static


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

YAF_VERSION (string)
YAF_ENVIRON (string)
YAF_ERR_STARTUP_FAILED (integer)
YAF_ERR_ROUTE_FAILED (integer)
YAF_ERR_DISPATCH_FAILED (integer)
YAF_ERR_AUTOLOAD_FAILED (integer)
YAF_ERR_NOTFOUND_MODULE (integer)
YAF_ERR_NOTFOUND_CONTROLLER (integer)
YAF_ERR_NOTFOUND_ACTION (integer)
YAF_ERR_NOTFOUND_VIEW (integer)
YAF_ERR_CALL_FAILED (integer)
YAF_ERR_TYPE_ERROR (integer)


Ejemplos

Ejemplo #1 Distribución clásica del directorio Application

- index.php
- .htaccess
+ conf
  |- application.ini //configuración de la aplicación
- application/
  - Bootstrap.php
  + controllers
     - Index.php //controlador predeterminado
  + views
     |+ index
        - index.phtml //plantilla de vistas para la acción predeterminada
  + modules
  - library
  - models
  - plugins

Ejemplo #2 Entrada

index.php en el directorio superior es la única forma de entrada de la aplicación, se deberían reescribir todas las peticiones al mismo (se puede emplear .htaccess de Apache+php_mod)

<?php
define("APPLICATION_PATH",  dirname(__FILE__));

$app  = new Yaf_Application(APPLICATION_PATH . "/conf/application.ini");
$app->bootstrap() //llamar a los métodos de arranque definidos en Bootstrap.php
 ->run();
?>

Ejemplo #3 Regla de sobrescritura

#para apache (.htaccess)
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* index.php

#para nginx
server {
  listen ****;
  server_name  domain.com;
  root   document_root;
  index  index.php index.html index.htm;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php/$1 last;
  }
}

#para lighttpd
$HTTP["host"] =~ "(www.)?domain.com$" {
  url.rewrite = (
     "^/(.+)/?$"  => "/index.php/$1",
  )
}

Ejemplo #4 Configuración de la aplicación

[yaf]
;APPLICATION_PATH es la constante definida en index.php
application.directory=APPLICATION_PATH "/application/"

;la sección 'product' hereda de las sección 'yaf'
[product:yaf]
foo=bar

Ejemplo #5 Controlador predeterminado

<?php
class IndexController extends Yaf_Controller_Abstract {
   /* acción predeterminada */
   public function indexAction() {
       $this->_view->word = "hola mundo";
       //or
       // $this->getView()->word = "hola mundo";
   }
}
?>

Ejemplo #6 Plantilla de vistas predeterminada

<html>
 <head>
   <title>Hola Mundo</title>
 </head>
 <body>
   <?php echo $word;?>
 </body>
</html>

Ejemplo #7 Ejecutar la aplicación

El resultado del ejemplo sería algo similar a:

<html>
 <head>
   <title>Hola Mundo</title>
 </head>
 <body>
   hola mundo
 </body>
</html>

Nota:

También se puede generar el ejemplo de arriba usando el generado de código de Yaf, el cual se puede encontrar en yaf@github.


Configuración de la Aplicación

Se debería proporcionar una array de configuración o una ruta a un fichero de configuración ini (véase Yaf_Config_Ini) a Yaf_Application::__construct().

Yaf fusionará las configuraciones de la aplicación y del usuario automáticamente. Las configuraciones de la aplicación tienen el prefijo "yaf." o "application.". Si existen ambos prefijos, "yaf." y "application.", "application." tendrá preferencia.

Ejemplo #1 Un ejemplo de array de PHP

<?php
    $configs = array(
            "application" => array(
                "directory" => dirname(__FILE__),
                "dispatcher" => array(
                      "catchException" => 0,
                    ),
                "view" => array(
                       "ext" => "phtml",
                    ),
                ),
           );
    $app = new Yaf_Application($configs);
?>

Ejemplo #2 Un ejemplo de un fichero ini

[yaf]
yaf.directory = APPLICATION_PATH "/appliation"
yaf.dispatcher.catchException = 0

[product : yaf]
; user configuration list here

Configuración de la Aplicación Yaf
Nombre | Por defecto | Historial de cambios
application.directory |  |
application.ext | "php" |
application.view.ext | "phtml" |
application.modules | "index" |
application.library | application.directory . "/library" |
application.library.directory | application.directory . "/library" |
application.library.namespace | "" |
application.bootstrap | application.directory . "/Bootstrap" . application.ext |
application.baseUri | "" |
application.dispatcher.defaultRoute |  |
application.dispatcher.throwException | 1 |
application.dispatcher.catchException | 0 |
application.dispatcher.defaultModule | "index" |
application.dispatcher.defaultController | "index" |
application.dispatcher.defaultAction | "index" |
application.system |  |

He aquí una breve explicación de las directivas de configuración.

application.directory string

El directorio de la aplicación, que es la caperta que contiene las carpetas "controllers", "views", "models", "plugins".

Nota:

Esta entrada de configuración es la única que no tiene un valor predeterminado Se debería definir siempre manualmente.

application.ext string

La extensión de fichero del script de PHP, usado en la autocarga de clases (Yaf_Loader).

application.view.ext string

La extensión de fichero de los script de plantilla de vistas.

application.modules string

Una lista separada por comas de los módulos registrados, usada en el proceso de enrutamiento, especialmente mientras existan más de tres segmentos en PATH_INFO,

Yaf necesita una forma de averiguar si el primer segmento es un nombre de módulo o no.

application.library string

El directorio de bibliotecas local, véase Yaf_Loader y yaf.library.

Nota:

Después de Yaf 2.1.6, esta entrada de configuración puede ser un array. La ruta de la biblioteca intentará emplear los ítems establecidos en application.library.directory

application.library.directory string

Alias de application.library. Introducido en Yaf 2.1.6

application.library.namespace string

Un prefijo separado por comas de nombres de espacios de bibliotecas locales.

Introducido en Yaf 2.1.6

application.bootstrap string

Una ruta absoluta del script de la clase Bootstrap.

application.baseUri string

Usado para eliminar un prefijo fijo de un uri de petición en el proceso de enrutamiento. Como ejemplo, una petición con la uri de petición "/prefix/controller/action". Si se establece application.baseUri a "/prefix", solamente se tomará "/controller/action" como PATH_INFO en el proceso de enrutamiento.

En general, no hay necesidad de establecer este valor.

application.dispatcher.throwException bool

Si es On, Yaf lanzará una excepción mientras ocurra algún error. Véase también Yaf_Dispatcher::throwException().

application.dispatcher.catchException bool

Si es On, Yaf remitirá al controlador/acción de errores mientras exista una excepción no capturada. Véase también Yaf_Dispatcher::catchException().

application.dispatcher.defaultRoute string

El enrutamiento por defecto, si no se especifica se usará un enrutamiento estático como predeterminado. Véase Yaf_Router::addRoute().

application.dispatcher.defaultModule string

El nombre de módulo predeterminado, véase también Yaf_Dispatcher::setDefaultModule().

application.dispatcher.defaultController string

El nombre de controlador predeterminado, véase también Yaf_Dispatcher::setDefaultController().

application.dispatcher.defaultAction string

El nombre de acción predeterminado, véase también Yaf_Dispatcher::setDefaultAction().

application.system string

Establecer la configuración en tiempo de ejecuc de yaf en application.ini, como: application.system.lowcase_path

Nota:

Solamente las configuraciones de PHP_INI_ALL se pueden establecer de esta manera.


La clase Yaf_Application

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Yaf_Application proporciona una característica de arranque de aplicaciones que provee de recursos reusables, clases de arranque comunes y basadas en módulos y verificación de dependencia.

Nota:

Yaf_Application implementa el patrón singleton, y Yaf_Application no puede ser serializada o deserializada, lo que causará problemas al intentar usar PHPUnit para escribir algún caso de prueba para Yaf.

Se puede usar la anotación @backupGlobals de PHPUnit para controlar las operaciones de copia de respaldo y restauración de variables globales. De este modo se puede solucionar este problema.

Sinopsis de la Clase

final Yaf_Application {
/* Propiedades */
protected $config ;
protected $dispatcher ;
protected static $_app ;
protected $_modules ;
protected $_running ;
protected $_environ ;
/* Métodos */
public staticapp ( ) : mixed
public bootstrap ( Yaf_Bootstrap_Abstract $bootstrap = ? ) : void
public clearLastError ( ) : Yaf_Application
public __construct ( mixed $config , string $envrion = ? )
public __destruct ( ) : void
public environ ( ) : void
public execute ( callable $entry , string $... ) : void
public getAppDirectory ( ) : Yaf_Application
public getConfig ( ) : Yaf_Config_Abstract
public getDispatcher ( ) : Yaf_Dispatcher
public getLastErrorMsg ( ) : string
public getLastErrorNo ( ) : int
public getModules ( ) : array
public run ( ) : void
public setAppDirectory ( string $directory ) : Yaf_Application
}

Propiedades

config

dispatcher

_app

_modules

_running

_environ

Tabla de contenidos

  • Yaf_Application::app — Recuperar una instancia de la clase Application
  • Yaf_Application::bootstrap — Llamar al arranque
  • Yaf_Application::clearLastError — Limpiar la información del último error
  • Yaf_Application::__construct — El constructor de la clase Yaf_Application
  • Yaf_Application::__destruct — El propósito de __destruct
  • Yaf_Application::environ — Recuperar el entorno
  • Yaf_Application::execute — Ejecutar una llamada de retorno
  • Yaf_Application::getAppDirectory — Obtener el directorio de la aplicación
  • Yaf_Application::getConfig — Recuperar la instancia de configuración
  • Yaf_Application::getDispatcher — Obtener la instancia de la clase Yaf_Dispatcher
  • Yaf_Application::getLastErrorMsg — Obtener el mensaje del último error ocurrido
  • Yaf_Application::getLastErrorNo — Pbetner el código del último error ocurrido
  • Yaf_Application::getModules — Obtener los nombres de los modulos definidos
  • Yaf_Application::run — Iniciar una instancia de la clase Yaf_Application
  • Yaf_Application::setAppDirectory — Cambiar el directorio de la aplicación


Recuperar una instancia de la clase Application

  • « Yaf_Application
  • Yaf_Application::bootstrap »
  • PHP Manual
  • Yaf_Application
  • Recuperar una instancia de la clase Application

Yaf_Application::app

(Yaf >=1.0.0)

Yaf_Application::app — Recuperar una instancia de la clase Application

Descripción

public staticYaf_Application::app ( ) : mixed

Recuperar la instancia de la clase Yaf_Application. De forma alternativa se podría utilizar el método Yaf_Dispatcher::getApplication().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de la clase Yaf_Application, o null si no se inicializó antes ninguna instancia de Yaf_Application.

Ver también

  • Yaf_Dispatcher::getApplication() - Recupera la aplicación


Llamar al arranque

  • « Yaf_Application::app
  • Yaf_Application::clearLastError »
  • PHP Manual
  • Yaf_Application
  • Llamar al arranque

Yaf_Application::bootstrap

(Yaf >=1.0.0)

Yaf_Application::bootstrap — Llamar al arranque

Descripción

public Yaf_Application::bootstrap ( Yaf_Bootstrap_Abstract $bootstrap = ? ) : void

Ejecuta un Arranque, todos los métodos definidos en el Arranque y prefijados con "_init" serán llamados según su orden de declaración. Si no se proporciona el parámetro bootstrap, Yaf buscará un Arranque en application.directory.

Parámetros

bootstrap

Una instancia de la clase Yaf_Bootstrap_Abstract

Valores devueltos

Una instancia de la clase Yaf_Application

Ejemplos

Ejemplo #1 Un ejemplo de A Bootstrap()

<?php
/**
 * Este fichero debería estar en la ruta APPLICATION_PATH . "/application/" (la cual estaría definida en la configuración pasada a Yaf_Application),
 * y llamarse Bootstrap.php, para que la instancia de Yaf_Application lo pueda encontrar
 */
class Bootstrap extends Yaf_Bootstrap_Abstract {
    function _initConfig(Yaf_Dispatcher $dispatcher) {
        echo "Primera llamada\n";
    }

    function _initPlugin($dispatcher) {
        echo "Segunda llamada\n";
    }
}
?>

Ejemplo #2 Ejemplo de Yaf_Application::bootstrap()

<?php

defined('APPLICATION_PATH')                  // APPLICATION_PATH será usada en el fichero ini de configuración
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ fue introducido después de PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap();
?>

El resultado del ejemplo sería algo similar a:

Primera llamada
Segunda llamada

Ver también

  • Yaf_Bootstrap_Abstract


Limpiar la información del último error

  • « Yaf_Application::bootstrap
  • Yaf_Application::__construct »
  • PHP Manual
  • Yaf_Application
  • Limpiar la información del último error

Yaf_Application::clearLastError

(Yaf >=2.1.2)

Yaf_Application::clearLastError — Limpiar la información del último error

Descripción

public Yaf_Application::clearLastError ( ) : Yaf_Application

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::clearLastError()

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   Yaf_Application::app()->clearLastError();
   var_dump(Yaf_Application::app()->getLastErrorNo());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/noexiste",
     "dispatcher" => array(
       "throwException" => 0, //provocar un error en vez de lanzar una excepción cuando ocurra un error
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

El resultado del ejemplo sería algo similar a:

int(0)


El constructor de la clase Yaf_Application

  • « Yaf_Application::clearLastError
  • Yaf_Application::__destruct »
  • PHP Manual
  • Yaf_Application
  • El constructor de la clase Yaf_Application

Yaf_Application::__construct

(Yaf >=1.0.0)

Yaf_Application::__construct — El constructor de la clase Yaf_Application

Descripción

public Yaf_Application::__construct ( mixed $config , string $envrion = ? )

Instancia un objeto de la clase Yaf_Application.

Parámetros

config

La ruta de un fichero de configuración ini, o un array de configuración

Si es un fichero ini de configuración, debería existir una sección con el mismo nombre que una definida por yaf.environ, la cual es "product" por omisión.

Nota:

Si se está usando un fichero de configuración ini como contenedor de configuración de la aplicación, se debería abrir yaf.cache_config para mejorar el rendimiento.

Y la entrada de configuración (y el valor predeterminado) listada abajo:

Ejemplo #1 A ini config file example

[product]
;esta siempre debería ser definida y no tener un valor predeterminado
application.directory=APPLICATION_PATH

;las siguientes configuraciones tienen un valor predeterminados, no se necesitan definirlas
application.library = APPLICATION_PATH . "/library"
application.dispatcher.throwException=1
application.dispatcher.catchException=1

application.baseUri=""

;el nombre de la extensión de script de php
ap.ext=php

;el nombre de la extensión de la plantilla de vista
ap.view.ext=phtml

ap.dispatcher.defaultModuel=Index
ap.dispatcher.defaultController=Index
ap.dispatcher.defaultAction=index

;módulos definidos
ap.modules=Index

envrion

Qué sección se cargará como configuración final

Valores devueltos

Ejemplos

Ejemplo #2 Ejemplo de Yaf_Application::__construct()

<?php
defined('APPLICATION_PATH')                  // APPLICATION_PATH será usada en el archivo de configuración ini
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ fue introducido después de PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap()->run();
?>

El resultado del ejemplo sería algo similar a:

Ejemplo #3 Ejemplo de Yaf_Application::__construct()

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->bootstrap()->run();
?>

El resultado del ejemplo
sería algo similar a:

Ver también

  • Yaf_Config_Ini
    •


El propósito de __destruct

  • « Yaf_Application::__construct
  • Yaf_Application::environ »
  • PHP Manual
  • Yaf_Application
  • El propósito de __destruct

Yaf_Application::__destruct

(Yaf >=1.0.0)

Yaf_Application::__destruct — El propósito de __destruct

Descripción

public Yaf_Application::__destruct ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recuperar el entorno

  • « Yaf_Application::__destruct
  • Yaf_Application::execute »
  • PHP Manual
  • Yaf_Application
  • Recuperar el entorno

Yaf_Application::environ

(Yaf >=1.0.0)

Yaf_Application::environ — Recuperar el entorno

Descripción

public Yaf_Application::environ ( ) : void

Recupera el entorno que fue definido en yaf.environ, el cual tiene el valor predeterminado "product".

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::environ()

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->environ());
?>

El resultado del ejemplo sería algo similar a:

product


Ejecutar una llamada de retorno

  • « Yaf_Application::environ
  • Yaf_Application::getAppDirectory »
  • PHP Manual
  • Yaf_Application
  • Ejecutar una llamada de retorno

Yaf_Application::execute

(Yaf >=1.0.0)

Yaf_Application::execute — Ejecutar una llamada de retorno

Descripción

public Yaf_Application::execute ( callable $entry , string $... ) : void

Este método normalmente se usa para ejecutar Yaf_Application en un trabajo de crontab. Hacer el trabajo de contrab también puede usar el autocargador y el mecanismo de arranque.

Parámetros

entry

Una llamada de retorno válida

...

Los parámetros de se le pasarán a la llamada de retorno

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::execute()

<?php
function main($argc, $argv) {
}

$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->execute("main", $argc,  $argv);
?>

El resultado del ejemplo sería algo similar a:


Obtener el directorio de la aplicación

  • « Yaf_Application::execute
  • Yaf_Application::getConfig »
  • PHP Manual
  • Yaf_Application
  • Obtener el directorio de la aplicación

Yaf_Application::getAppDirectory

(Yaf >=2.1.4)

Yaf_Application::getAppDirectory — Obtener el directorio de la aplicación

Descripción

public Yaf_Application::getAppDirectory ( ) : Yaf_Application

Parámetros

directory

Valores devueltos


Recuperar la instancia de configuración

  • « Yaf_Application::getAppDirectory
  • Yaf_Application::getDispatcher »
  • PHP Manual
  • Yaf_Application
  • Recuperar la instancia de configuración

Yaf_Application::getConfig

(Yaf >=1.0.0)

Yaf_Application::getConfig — Recuperar la instancia de configuración

Descripción

public Yaf_Application::getConfig ( ) : Yaf_Config_Abstract

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de la clase Yaf_Config_Abstract

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::getConfig()

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getConfig());
?>

El resultado del ejemplo sería algo similar a:

Yaf_Config_Simple Object
(
    [_config:protected] => Array
        (
            [application] => Array
                (
                    [directory] => /home/laruence/local/www/htdocs/application
                )

        )

    [_readonly:protected] => 1
)


Obtener la instancia de la clase Yaf_Dispatcher

  • « Yaf_Application::getConfig
  • Yaf_Application::getLastErrorMsg »
  • PHP Manual
  • Yaf_Application
  • Obtener la instancia de la clase Yaf_Dispatcher

Yaf_Application::getDispatcher

(Yaf >=1.0.0)

Yaf_Application::getDispatcher — Obtener la instancia de la clase Yaf_Dispatcher

Descripción

public Yaf_Application::getDispatcher ( ) : Yaf_Dispatcher

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::getDispatcher()

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getDispatcher());
?>

El resultado del ejemplo sería algo similar a:

Yaf_Dispatcher Object
(
    [_router:protected] => Yaf_Router Object
        (
            [_routes:protected] => Array
                (
                    [_default] => Yaf_Route_Static Object
                        (
                        )

                )

            [_current:protected] =>
        )

    [_view:protected] =>
    [_request:protected] => Yaf_Request_Http Object
        (
            [module] =>
            [controller] =>
            [action] =>
            [method] => Cli
            [params:protected] => Array
                (
                )

            [language:protected] =>
            [_exception:protected] =>
            [_base_uri:protected] =>
            [uri:protected] =>
            [dispatched:protected] =>
            [routed:protected] =>
        )

    [_plugins:protected] => Array
        (
        )

    [_auto_render:protected] => 1
    [_return_response:protected] =>
    [_instantly_flush:protected] =>
    [_default_module:protected] => Index
    [_default_controller:protected] => Index
    [_default_action:protected] => index
    [_response] => Yaf_Response_Cli Object
        (
            [_header:protected] => Array
                (
                )

            [_body:protected] =>
            [_sendheader:protected] =>
        )

)


Obtener el mensaje del último error ocurrido

  • « Yaf_Application::getDispatcher
  • Yaf_Application::getLastErrorNo »
  • PHP Manual
  • Yaf_Application
  • Obtener el mensaje del último error ocurrido

Yaf_Application::getLastErrorMsg

(Yaf >=2.1.2)

Yaf_Application::getLastErrorMsg — Obtener el mensaje del último error ocurrido

Descripción

public Yaf_Application::getLastErrorMsg ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::getLastErrorMsg()

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorMsg());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //provocar un error en lugar de lanzar una excepción cuando ocurra un error
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

El resultado del ejemplo sería algo similar a:

string(69) "Could not find controller script /tmp/notexists/controllers/Index.php"


Pbetner el código del último error ocurrido

  • « Yaf_Application::getLastErrorMsg
  • Yaf_Application::getModules »
  • PHP Manual
  • Yaf_Application
  • Pbetner el código del último error ocurrido

Yaf_Application::getLastErrorNo

(Yaf >=2.1.2)

Yaf_Application::getLastErrorNo — Pbetner el código del último error ocurrido

Descripción

public Yaf_Application::getLastErrorNo ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::getLastErrorNo()

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorNo());
   var_dump(Yaf_Application::app()->getLastErrorNo() == YAF_ERR_NOTFOUND_CONTROLLER);
}

$config = array(
  "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //provocar un error en lugar de lanzar una excepción cuando ocurra un error
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

El resultado del ejemplo sería algo similar a:

int(516)
bool(true)


Obtener los nombres de los modulos definidos

  • « Yaf_Application::getLastErrorNo
  • Yaf_Application::run »
  • PHP Manual
  • Yaf_Application
  • Obtener los nombres de los modulos definidos

Yaf_Application::getModules

(Yaf >=1.0.0)

Yaf_Application::getModules — Obtener los nombres de los modulos definidos

Descripción

public Yaf_Application::getModules ( ) : array

Obtiene la lista de módulos definidos en config, si no se han definido siempre habrá un módulo llamado "Index".

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Application::getModules()

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getModules());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Index
)


Iniciar una instancia de la clase Yaf_Application

  • « Yaf_Application::getModules
  • Yaf_Application::setAppDirectory »
  • PHP Manual
  • Yaf_Application
  • Iniciar una instancia de la clase Yaf_Application

Yaf_Application::run

(Yaf >=1.0.0)

Yaf_Application::run — Iniciar una instancia de la clase Yaf_Application

Descripción

public Yaf_Application::run ( ) : void

Ejecuta una instancia de la clase Yaf_Application, permite a esta instancia aceptar una petición, y enviar dicha petición, despacha el controlador/acción, e interpreta la respuesta. Finalmente devuelve la respuesta al cliente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Cambiar el directorio de la aplicación

  • « Yaf_Application::run
  • Yaf_Bootstrap_Abstract »
  • PHP Manual
  • Yaf_Application
  • Cambiar el directorio de la aplicación

Yaf_Application::setAppDirectory

(Yaf >=2.1.4)

Yaf_Application::setAppDirectory — Cambiar el directorio de la aplicación

Descripción

public Yaf_Application::setAppDirectory ( string $directory ) : Yaf_Application

Parámetros

directory

Valores devueltos


La clase Yaf_Bootstrap_Abstract

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

El arranque (bootstrap) es un mecanismo usado para realizar una configuración inicial antes de ejecutar una Aplicación.

Los usuarios puede definir su propia clase Bootstrap heredando la clase Yaf_Bootstrap_Abstract

Cualquier método declarado en la clase Arranque al que se le anteponga "_init" será llamado uno a uno por el método Yaf_Application::bootstrap() según su orden de definición.

Ejemplos

Ejemplo #1 Ejemplo de arranque

<?php
   /* la clase de arranque debería estar definida bajo ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initConfig(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap();
?>

El resultado del ejemplo sería algo similar a:

string(22) "Bootstrap::_initConfig"
string(22) "Bootstrap::_initPlugin"

Sinopsis de la Clase

abstract Yaf_Bootstrap_Abstract {
/* Propiedades */
/* Métodos */
}


La clase Yaf_Dispatcher

(Yaf >=1.0.0)

Introducción

El propósito de la clase Yaf_Dispatcher es inicializar el entorno de peticiones, enrutar las peticiones entrantes, y despachar cuanlquier acción encontrada; agrega cualesquiera respuestas y las devuelve cuando el proceso está completado.

Yaf_Dispatcher también implementa el patrón Singleton, lo que significa que solamente puede estar disponible una instancia de la misma a la vez. Esto le permite también actuar como un registro en el que se puede establecer el orden de los objetos del proceso de despachamiento.

Sinopsis de la Clase

final Yaf_Dispatcher {
/* Propiedades */
protected $_router ;
protected $_view ;
protected $_request ;
protected $_plugins ;
protected static $_instance ;
protected $_auto_render ;
protected $_return_response ;
protected $_instantly_flush ;
protected $_default_module ;
protected $_default_controller ;
protected $_default_action ;
/* Métodos */
public autoRender ( bool $flag = ? ) : Yaf_Dispatcher
public catchException ( bool $flag = ? ) : Yaf_Dispatcher
public __construct ( )
public disableView ( ) : bool
public dispatch ( Yaf_Request_Abstract $request ) : Yaf_Response_Abstract
public enableView ( ) : Yaf_Dispatcher
public flushInstantly ( bool $flag = ? ) : Yaf_Dispatcher
public getApplication ( ) : Yaf_Application
public getDefaultAction ( ) : string
public getDefaultController ( ) : string
public getDefaultModule ( ) : string
public static getInstance ( ) : Yaf_Dispatcher
public getRequest ( ) : Yaf_Request_Abstract
public getRouter ( ) : Yaf_Router
public initView ( string $templates_dir , array $options = ? ) : Yaf_View_Interface
public registerPlugin ( Yaf_Plugin_Abstract $plugin ) : Yaf_Dispatcher
public returnResponse ( bool $flag ) : Yaf_Dispatcher
public setDefaultAction ( string $action ) : Yaf_Dispatcher
public setDefaultController ( string $controller ) : Yaf_Dispatcher
public setDefaultModule ( string $module ) : Yaf_Dispatcher
public setErrorHandler ( call $callback , int $error_types ) : Yaf_Dispatcher
public setRequest ( Yaf_Request_Abstract $request ) : Yaf_Dispatcher
public setView ( Yaf_View_Interface $view ) : Yaf_Dispatcher
public throwException ( bool $flag = ? ) : Yaf_Dispatcher
}

Propiedades

_router

_view

_request

_plugins

_instance

_auto_render

_return_response

_instantly_flush

_default_module

_default_controller

_default_action

Tabla de contenidos

  • Yaf_Dispatcher::autoRender — Activa/desactiva la autointerpretación
  • Yaf_Dispatcher::catchException — Activar/desactivar la captura de excepciones
  • Yaf_Dispatcher::__construct — Constructor de la clase Yaf_Dispatcher
  • Yaf_Dispatcher::disableView — Deshabilita la interpretación de vistas
  • Yaf_Dispatcher::dispatch — Despachar una petición
  • Yaf_Dispatcher::enableView — Habilita la interpretación de vistas
  • Yaf_Dispatcher::flushInstantly — Activa/desactiva el vaciado instantáneo
  • Yaf_Dispatcher::getApplication — Recupera la aplicación
  • Yaf_Dispatcher::getDefaultAction — Recupera el nombre de la acción por defecto
  • Yaf_Dispatcher::getDefaultController — Recupera el nombre del controlador predeterminado
  • Yaf_Dispatcher::getDefaultModule — Recupera el nombre del módulo por defecto
  • Yaf_Dispatcher::getInstance — Recupeara la instancia despachadora
  • Yaf_Dispatcher::getRequest — Recupera la instancia de petición
  • Yaf_Dispatcher::getRouter — Recuperar la instancia de envío
  • Yaf_Dispatcher::initView — Inicializa una vista y la devuelve
  • Yaf_Dispatcher::registerPlugin — Registra un complemento
  • Yaf_Dispatcher::returnResponse — El propósito de returnResponse
  • Yaf_Dispatcher::setDefaultAction — Cambia el nombre de la acción predeterminada
  • Yaf_Dispatcher::setDefaultController — Cambia el nombre del controlador predeterminado
  • Yaf_Dispatcher::setDefaultModule — Cambia el nombre del módulo predeterminado
  • Yaf_Dispatcher::setErrorHandler — Establece el gestor de errores
  • Yaf_Dispatcher::setRequest — El propósito de setRequest
  • Yaf_Dispatcher::setView — Establecer un motor de vistas personalizado
  • Yaf_Dispatcher::throwException — Activa/desactiva el lanzamiento de excepciones


Activa/desactiva la autointerpretación

  • « Yaf_Dispatcher
  • Yaf_Dispatcher::catchException »
  • PHP Manual
  • Yaf_Dispatcher
  • Activa/desactiva la autointerpretación

Yaf_Dispatcher::autoRender

(Yaf >=1.0.0)

Yaf_Dispatcher::autoRender — Activa/desactiva la autointerpretación

Descripción

public Yaf_Dispatcher::autoRender ( bool $flag = ? ) : Yaf_Dispatcher

Ya que Yaf_Dispatcher realizará la interpretación automáticamente después de despachar una petición entrante, se puede prevenir la interpretación llamando a este método con el parámetro flag establecido a true.

Nota:

Se puede devolver simplemente false en una acción para evitar la autointerpretación de dicha acción.

Parámetros

flag

bool

Nota:

Desde 2.2.0, si no se proporciona este parámetro, será devuelto el estado actual

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Dispatcher::autoRender()

<?php
class IndexController extends Yaf_Controller_Abstract {
     /* El método init será llamado tan pronto como se inicialice un controlador */
     public function init() {
         if ($this->getRequest()->isXmlHttpRequest()) {
             //do not call render for ajax request
             //we will outpu a json string
             Yaf_Dispatcher::getInstance()->autoRender(FALSE);
         }
     }

}
?>

El resultado del ejemplo sería algo similar a:


Activar/desactivar la captura de excepciones

  • « Yaf_Dispatcher::autoRender
  • Yaf_Dispatcher::__construct »
  • PHP Manual
  • Yaf_Dispatcher
  • Activar/desactivar la captura de excepciones

Yaf_Dispatcher::catchException

(Yaf >=1.0.0)

Yaf_Dispatcher::catchException — Activar/desactivar la captura de excepciones

Descripción

public Yaf_Dispatcher::catchException ( bool $flag = ? ) : Yaf_Dispatcher

Mientras que application.dispatcher.throwException esté activado (también se puede llamar al método Yaf_Dispatcher::throwException(TRUE)() para habilitarlo), Yaf lanzará una excepción en lugar de emitir un error cuando ocurren errores.

Entonces, si se habilita Yaf_Dispatcher::catchException() (también se puede habilitar estableciendo application.dispatcher.catchException), todas las excepciones no capturadas lo serán por ErrorController::error si se ha definido una.

Parámetros

flag

bool

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Dispatcher::catchException()

/* si se define una clase ErrorController como la siguiente */
<?php
class ErrorController extends Yaf_Controller_Abstract {
     /**
      * también se puede llamar a Yaf_Request_Abstract::getException para obtener
      * la excepción no capturada.
      */
     public function errorAction($excepción) {
        /* error occurs */
        switch ($excepción->getCode()) {
            case YAF_ERR_NOTFOUND_MODULE:
            case YAF_ERR_NOTFOUND_CONTROLLER:
            case YAF_ERR_NOTFOUND_ACTION:
            case YAF_ERR_NOTFOUND_VIEW:
                echo 404, ":", $excepción->getMessage();
                break;
            default :
                $message = $excepción->getMessage();
                echo 0, ":", $excepción->getMessage();
                break;
        }
     }
}
?>

El resultado del ejemplo sería algo similar a:

/* ahora, si ocurre algún error, se asume el acceso a un controlador no existente (o uno mismo puede lanzar una excepción): */
404:Could not find controller script **/application/controllers/Controlador-no-existente.php

Ver también

  • Yaf_Dispatcher::throwException() - Activa/desactiva el lanzamiento de excepciones
  • Yaf_Dispatcher::setErrorHandler() - Establece el gestor de errores


Constructor de la clase Yaf_Dispatcher

  • « Yaf_Dispatcher::catchException
  • Yaf_Dispatcher::disableView »
  • PHP Manual
  • Yaf_Dispatcher
  • Constructor de la clase Yaf_Dispatcher

Yaf_Dispatcher::__construct

(Yaf >=1.0.0)

Yaf_Dispatcher::__construct — Constructor de la clase Yaf_Dispatcher

Descripción

public Yaf_Dispatcher::__construct ( )

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Deshabilita la interpretación de vistas

  • « Yaf_Dispatcher::__construct
  • Yaf_Dispatcher::dispatch »
  • PHP Manual
  • Yaf_Dispatcher
  • Deshabilita la interpretación de vistas

Yaf_Dispatcher::disableView

(Yaf >=1.0.0)

Yaf_Dispatcher::disableView — Deshabilita la interpretación de vistas

Descripción

public Yaf_Dispatcher::disableView ( ) : bool

Deshabilita lel motor de vistas, usado en algunas aplicaciones donde se generan por sí mismas.

Nota:

Se puede devolver simplemente false en una acción para evitar la autointerpretación de dicha acción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Despachar una petición

  • « Yaf_Dispatcher::disableView
  • Yaf_Dispatcher::enableView »
  • PHP Manual
  • Yaf_Dispatcher
  • Despachar una petición

Yaf_Dispatcher::dispatch

(Yaf >=1.0.0)

Yaf_Dispatcher::dispatch — Despachar una petición

Descripción

public Yaf_Dispatcher::dispatch ( Yaf_Request_Abstract $request ) : Yaf_Response_Abstract

Este método realiza el trabajo duro de la clase Yaf_Dispatcher. Toma un objeto de petición.

El proceso de despachamiento posee tres eventos distintos:

  • Enrutamiento
  • Despachamiento
  • Respuesta
El enrutamiento ocurre exactamente una vez, usando los valores del objeto de petición al llamar a dispatch(). El despachamiento tiene lugar en un bucle; una petición puede indicar o múltiples acciones a despachar, o el controlador, o un complemento puede reiniciar el objeto de petición para forzar acciones adicionales a despachar (véase la clase Yaf_Plugin_Abstract. Cuando todo ha sido realizado, la clase Yaf_Dispatcher devuelve una respuesta.

Parámetros

request

Valores devueltos


Habilita la interpretación de vistas

  • « Yaf_Dispatcher::dispatch
  • Yaf_Dispatcher::flushInstantly »
  • PHP Manual
  • Yaf_Dispatcher
  • Habilita la interpretación de vistas

Yaf_Dispatcher::enableView

(Yaf >=1.0.0)

Yaf_Dispatcher::enableView — Habilita la interpretación de vistas

Descripción

public Yaf_Dispatcher::enableView ( ) : Yaf_Dispatcher

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Activa/desactiva el vaciado instantáneo

  • « Yaf_Dispatcher::enableView
  • Yaf_Dispatcher::getApplication »
  • PHP Manual
  • Yaf_Dispatcher
  • Activa/desactiva el vaciado instantáneo

Yaf_Dispatcher::flushInstantly

(Yaf >=1.0.0)

Yaf_Dispatcher::flushInstantly — Activa/desactiva el vaciado instantáneo

Descripción

public Yaf_Dispatcher::flushInstantly ( bool $flag = ? ) : Yaf_Dispatcher

Parámetros

flag

Booleano

Nota:

Desde 2.2.0, si no se proporciona este parámetro, será devuelto el estado actual

Valores devueltos


Recupera la aplicación

  • « Yaf_Dispatcher::flushInstantly
  • Yaf_Dispatcher::getDefaultAction »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupera la aplicación

Yaf_Dispatcher::getApplication

(Yaf >=1.0.0)

Yaf_Dispatcher::getApplication — Recupera la aplicación

Descripción

public Yaf_Dispatcher::getApplication ( ) : Yaf_Application

Recupera la instancia de la clase Yaf_Application. Hace lo mismo que el método Yaf_Application::app().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Application::app() - Recuperar una instancia de la clase Application


Recupera el nombre de la acción por defecto

  • « Yaf_Dispatcher::getApplication
  • Yaf_Dispatcher::getDefaultController »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupera el nombre de la acción por defecto

Yaf_Dispatcher::getDefaultAction

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultAction — Recupera el nombre de la acción por defecto

Descripción

public Yaf_Dispatcher::getDefaultAction ( ) : string

obtiene el nombre de la acción por defecto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string, nombre de la acción por defecto, por defecto es "index"


Recupera el nombre del controlador predeterminado

  • « Yaf_Dispatcher::getDefaultAction
  • Yaf_Dispatcher::getDefaultModule »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupera el nombre del controlador predeterminado

Yaf_Dispatcher::getDefaultController

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultController — Recupera el nombre del controlador predeterminado

Descripción

public Yaf_Dispatcher::getDefaultController ( ) : string

obtiene el nombre del controlador predeterminado

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string, nombre del controlador por defecto, por defecto es "Index"


Recupera el nombre del módulo por defecto

  • « Yaf_Dispatcher::getDefaultController
  • Yaf_Dispatcher::getInstance »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupera el nombre del módulo por defecto

Yaf_Dispatcher::getDefaultModule

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultModule — Recupera el nombre del módulo por defecto

Descripción

public Yaf_Dispatcher::getDefaultModule ( ) : string

obtiene el nombre del módulo por defecto

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string, nombre del módulo, por defecto es "Index"


Recupeara la instancia despachadora

  • « Yaf_Dispatcher::getDefaultModule
  • Yaf_Dispatcher::getRequest »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupeara la instancia despachadora

Yaf_Dispatcher::getInstance

(Yaf >=1.0.0)

Yaf_Dispatcher::getInstance — Recupeara la instancia despachadora

Descripción

public static Yaf_Dispatcher::getInstance ( ) : Yaf_Dispatcher

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera la instancia de petición

  • « Yaf_Dispatcher::getInstance
  • Yaf_Dispatcher::getRouter »
  • PHP Manual
  • Yaf_Dispatcher
  • Recupera la instancia de petición

Yaf_Dispatcher::getRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::getRequest — Recupera la instancia de petición

Descripción

public Yaf_Dispatcher::getRequest ( ) : Yaf_Request_Abstract

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recuperar la instancia de envío

  • « Yaf_Dispatcher::getRequest
  • Yaf_Dispatcher::initView »
  • PHP Manual
  • Yaf_Dispatcher
  • Recuperar la instancia de envío

Yaf_Dispatcher::getRouter

(Yaf >=1.0.0)

Yaf_Dispatcher::getRouter — Recuperar la instancia de envío

Descripción

public Yaf_Dispatcher::getRouter ( ) : Yaf_Router

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Inicializa una vista y la devuelve

  • « Yaf_Dispatcher::getRouter
  • Yaf_Dispatcher::registerPlugin »
  • PHP Manual
  • Yaf_Dispatcher
  • Inicializa una vista y la devuelve

Yaf_Dispatcher::initView

(Yaf >=1.0.0)

Yaf_Dispatcher::initView — Inicializa una vista y la devuelve

Descripción

public Yaf_Dispatcher::initView ( string $templates_dir , array $options = ? ) : Yaf_View_Interface

Parámetros

templates_dir

options

Valores devueltos


Registra un complemento

  • « Yaf_Dispatcher::initView
  • Yaf_Dispatcher::returnResponse »
  • PHP Manual
  • Yaf_Dispatcher
  • Registra un complemento

Yaf_Dispatcher::registerPlugin

(Yaf >=1.0.0)

Yaf_Dispatcher::registerPlugin — Registra un complemento

Descripción

public Yaf_Dispatcher::registerPlugin ( Yaf_Plugin_Abstract $plugin ) : Yaf_Dispatcher

Registra un complemento (véase Yaf_Plugin_Abstract). Generalmente se registran complementos en el Arranque (véase la clase Yaf_Bootstrap_Abstract).

Parámetros

plugin

Valores devueltos

Ejemplos

Ejemplo #1 Yaf_Dispatcher::registerPlugin()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
  public function _initPlugin(Yaf_Dispatcher $despachador) {
    /**
    * Yaf asume que los scripts de complementos están en [application.directory] .  "/plugins"
    * para este caso, será:
    * [application.directory] . "/plugins/" . "User" . [application.ext]
    */
    $usuario = new UserPlugin();
    $despachador->registerPlugin($usuario);
 }

Ver también

  • Yaf_Plugin_Abstract
  • Yaf_Bootstrap_Abstract


El propósito de returnResponse

  • « Yaf_Dispatcher::registerPlugin
  • Yaf_Dispatcher::setDefaultAction »
  • PHP Manual
  • Yaf_Dispatcher
  • El propósito de returnResponse

Yaf_Dispatcher::returnResponse

(Yaf >=1.0.0)

Yaf_Dispatcher::returnResponse — El propósito de returnResponse

Descripción

public Yaf_Dispatcher::returnResponse ( bool $flag ) : Yaf_Dispatcher

Parámetros

flag

Valores devueltos


Cambia el nombre de la acción predeterminada

  • « Yaf_Dispatcher::returnResponse
  • Yaf_Dispatcher::setDefaultController »
  • PHP Manual
  • Yaf_Dispatcher
  • Cambia el nombre de la acción predeterminada

Yaf_Dispatcher::setDefaultAction

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultAction — Cambia el nombre de la acción predeterminada

Descripción

public Yaf_Dispatcher::setDefaultAction ( string $action ) : Yaf_Dispatcher

Parámetros

action

Valores devueltos


Cambia el nombre del controlador predeterminado

  • « Yaf_Dispatcher::setDefaultAction
  • Yaf_Dispatcher::setDefaultModule »
  • PHP Manual
  • Yaf_Dispatcher
  • Cambia el nombre del controlador predeterminado

Yaf_Dispatcher::setDefaultController

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultController — Cambia el nombre del controlador predeterminado

Descripción

public Yaf_Dispatcher::setDefaultController ( string $controller ) : Yaf_Dispatcher

Parámetros

controller

Valores devueltos


Cambia el nombre del módulo predeterminado

  • « Yaf_Dispatcher::setDefaultController
  • Yaf_Dispatcher::setErrorHandler »
  • PHP Manual
  • Yaf_Dispatcher
  • Cambia el nombre del módulo predeterminado

Yaf_Dispatcher::setDefaultModule

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultModule — Cambia el nombre del módulo predeterminado

Descripción

public Yaf_Dispatcher::setDefaultModule ( string $module ) : Yaf_Dispatcher

Parámetros

module

Valores devueltos


Establece el gestor de errores

  • « Yaf_Dispatcher::setDefaultModule
  • Yaf_Dispatcher::setRequest »
  • PHP Manual
  • Yaf_Dispatcher
  • Establece el gestor de errores

Yaf_Dispatcher::setErrorHandler

(Yaf >=1.0.0)

Yaf_Dispatcher::setErrorHandler — Establece el gestor de errores

Descripción

public Yaf_Dispatcher::setErrorHandler ( call $callback , int $error_types ) : Yaf_Dispatcher

Establece el gestor de errores de Yaf. Cuando application.dispatcher.throwException está desactivada, Yaf provocará errores capturables mientras ocurran errores inesperados.

Por lo tanto, este gestor de errores será invocado mientras se produce el error.

Parámetros

callback

Una llamada de retorno de tipo callable.

error_types

Valores devueltos

Ver también

  • Yaf_Dispatcher::throwException() - Activa/desactiva el lanzamiento de excepciones
  • Yaf_Application::getLastErrorNo() - Pbetner el código del último error ocurrido
  • Yaf_Application::getLastErrorMsg() - Obtener el mensaje del último error ocurrido


El propósito de setRequest

  • « Yaf_Dispatcher::setErrorHandler
  • Yaf_Dispatcher::setView »
  • PHP Manual
  • Yaf_Dispatcher
  • El propósito de setRequest

Yaf_Dispatcher::setRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::setRequest — El propósito de setRequest

Descripción

public Yaf_Dispatcher::setRequest ( Yaf_Request_Abstract $request ) : Yaf_Dispatcher

Parámetros

plugin

Valores devueltos


Establecer un motor de vistas personalizado

  • « Yaf_Dispatcher::setRequest
  • Yaf_Dispatcher::throwException »
  • PHP Manual
  • Yaf_Dispatcher
  • Establecer un motor de vistas personalizado

Yaf_Dispatcher::setView

(Yaf >=1.0.0)

Yaf_Dispatcher::setView — Establecer un motor de vistas personalizado

Descripción

public Yaf_Dispatcher::setView ( Yaf_View_Interface $view ) : Yaf_Dispatcher

Este método proporciona una solución para aquellos que quieran utilizar un motor de vistas personalizado en lugar de la clase Yaf_View_Simple

Parámetros

view

Una instancia de la clase Yaf_View_Interface

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de un motor de Vistas personalizado()

<?php
require "/path/to/smarty/Smarty.class.php";

class Smarty_Adapter implements Yaf_View_Interface
{
    /**
     * Smarty object
     * @var Smarty
     */
    public $_smarty;

    /**
     * Constructor
     *
     * @param string $tmplPath
     * @param array $extraParams
     * @return void
     */
    public function __construct($tmplPath = null, $extraParams = array()) {
        $this->_smarty = new Smarty;

        if (null !== $tmplPath) {
            $this->setScriptPath($tmplPath);
        }

        foreach ($extraParams as $clave => $valor) {
            $this->_smarty->$clave = $valor;
        }
    }

    /**
     * Establecer la ruta a las plantillas
     *
     * @param string $ruta El directorio a establecer como ruta.
     * @return void
     */
    public function setScriptPath($ruta)
    {
        if (is_readable($ruta)) {
            $this->_smarty->template_dir = $ruta;
            return;
        }

        throw new Exception('La ruta proporcionada no es válida');
    }

    /**
     * Asignar una variable a la plantilla
     *
     * @param string $clave El nombre de la variable.
     * @param mixed $valor El valor de la variable.
     * @return void
     */
    public function __set($clave, $valor)
    {
        $this->_smarty->assign($clave, $valor);
    }

    /**
     * Permite que funcionen las pruebas con empty() y isset()
     *
     * @param string $clave
     * @return boolean
     */
    public function __isset($clave)
    {
        return (null !== $this->_smarty->get_template_vars($clave));
    }

    /**
     * Permite que funcione unset() con las porpiedades de los objetos
     *
     * @param string $clave
     * @return void
     */
    public function __unset($clave)
    {
        $this->_smarty->clear_assign($clave);
    }

    /**
     * Asignar variables a la plantilla
     *
     * Permite establecer una clave específica para el valor especificado, O pasar
     * un array de parejas clave => valor para establecer masivamente.
     *
     * @see __set()
     * @param string|array $spec La estrategia de asignación a utilizar (clave o
     * array de parejas clave => valor)
     * @param mixed $valor (Opcional) Si se asignan variables nominadas,
     * utilice este como el valor.
     * @return void
     */
    public function assign($spec, $valor = null) {
        if (is_array($spec)) {
            $this->_smarty->assign($spec);
            return;
        }

        $this->_smarty->assign($spec, $valor);
    }

    /**
     * Limpiar todas las variables asignadas
     *
     * Limpia todas las variables asignadas a Yaf_View mediante
     * {@link assign()} o con sobrecarga de propiedades
     * ({@link __get()}/{@link __set()}).
     *
     * @return void
     */
    public function clearVars() {
        $this->_smarty->clear_all_assign();
    }

    /**
     * Procesa una plantilla y devuelve la salida.
     *
     * @param string $nombre La plantilla a procesar.
     * @return string La salida.
     */
    public function render($nombre, $valor = NULL) {
        return $this->_smarty->fetch($nombre);
    }

    public function display($nombre, $valor = NULL) {
        echo $this->_smarty->fetch($nombre);
    }

}
?>

Ejemplo #2 Ejemplo de Yaf_Dispatcher::setView()

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract {

    /**
     * existen configuraciones para smarty en la configuración:
     *
     * smarty.left_delimiter   = "{{"
     * smarty.right_delimiter  = "}}"
     * smarty.template_dir     = APPLICATION_PATH "/views/scripts/"
     * smarty.compile_dir      = APPLICATION_PATH "/views/templates_c/"
     * smarty.cache_dir        = APPLICATION_PATH "/views/templates_d/"
     *
     */
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initLocalName() {
        /** ponemos la clase Smarty_Adapter bajo el directorio de bibliotecas local */
        Yaf_Loader::getInstance()->registerLocalNamespace('Smarty');
    }

    public function _initSmarty(Yaf_Dispatcher $despachador) {
        $smarty = new Smarty_Adapter(null, Yaf_Registry::get("config")->get("smarty"));
        $despachador->setView($smarty);
        /* ahora el motor de vistas de Smarty se convierte en el motor de vistas predeterminado de Yaf */
    }
}
?>

Ver también

  • Yaf_View_Interface
  • Yaf_View_Simple


Activa/desactiva el lanzamiento de excepciones

  • « Yaf_Dispatcher::setView
  • Yaf_Config_Abstract »
  • PHP Manual
  • Yaf_Dispatcher
  • Activa/desactiva el lanzamiento de excepciones

Yaf_Dispatcher::throwException

(Yaf >=1.0.0)

Yaf_Dispatcher::throwException — Activa/desactiva el lanzamiento de excepciones

Descripción

public Yaf_Dispatcher::throwException ( bool $flag = ? ) : Yaf_Dispatcher

Activa/desactiva el lanzamiento de excepciones mientras ocurran errores inesperados. Cuando está activado, Yaf lanzará excepciones en lugar de provocar errores capturables.

También se puede usar application.dispatcher.throwException para el mismo propósito.

Parámetros

flag

Booleano

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Dispatcher::throwexception()

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(true);

try {
    $app->run();
} catch (Yaf_Exception $e) {
    var_dump($e->getMessage());
}
?>

El resultado del ejemplo sería algo similar a:

string(59) "Could not find controller script /tmp/controllers/Index.php"

Ejemplo #2 Ejemplo de Yaf_Dispatcher::throwexception()

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(false);

$app->run();
?>

El resultado del ejemplo sería algo similar a:

PHP Catchable fatal error:  Yaf_Application::run(): Could not find controller script /tmp/controllers/Index.php in /tmp/1.php on line 12

Ver también

  • Yaf_Dispatcher::catchException() - Activar/desactivar la captura de excepciones
  • Yaf_Exception


La clase Yaf_Config_Abstract

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

abstract Yaf_Config_Abstract {
/* Propiedades */
protected $_config ;
protected $_readonly ;
/* Métodos */
abstract public get ( string $name , mixed $value ) : mixed
abstract public readonly ( ) : bool
abstract public set ( ) : Yaf_Config_Abstract
abstract public toArray ( ) : array
}

Propiedades

_config

_readonly

Tabla de contenidos

  • Yaf_Config_Abstract::get — Consultor
  • Yaf_Config_Abstract::readonly — Buscar si una configuración es de sólo lectura
  • Yaf_Config_Abstract::set — Modificador
  • Yaf_Config_Abstract::toArray — Convertir en un array


Consultor

  • « Yaf_Config_Abstract
  • Yaf_Config_Abstract::readonly »
  • PHP Manual
  • Yaf_Config_Abstract
  • Consultor

Yaf_Config_Abstract::get

(Yaf >=1.0.0)

Yaf_Config_Abstract::get — Consultor

Descripción

abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Buscar si una configuración es de sólo lectura

  • « Yaf_Config_Abstract::get
  • Yaf_Config_Abstract::set »
  • PHP Manual
  • Yaf_Config_Abstract
  • Buscar si una configuración es de sólo lectura

Yaf_Config_Abstract::readonly

(Yaf >=1.0.0)

Yaf_Config_Abstract::readonly — Buscar si una configuración es de sólo lectura

Descripción

abstract public Yaf_Config_Abstract::readonly ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Modificador

  • « Yaf_Config_Abstract::readonly
  • Yaf_Config_Abstract::toArray »
  • PHP Manual
  • Yaf_Config_Abstract
  • Modificador

Yaf_Config_Abstract::set

(Yaf >=1.0.0)

Yaf_Config_Abstract::set — Modificador

Descripción

abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Convertir en un array

  • « Yaf_Config_Abstract::set
  • Yaf_Config_Ini »
  • PHP Manual
  • Yaf_Config_Abstract
  • Convertir en un array

Yaf_Config_Abstract::toArray

(Yaf >=1.0.0)

Yaf_Config_Abstract::toArray — Convertir en un array

Descripción

abstract public Yaf_Config_Abstract::toArray ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Config_Ini

(Yaf >=1.0.0)

Introducción

La clase Yaf_Config_Ini permite a los desarrolladores almacenar la información de configuración en un formato INI familiar y leerla en la aplicación utilizando una sintaxis apropiada de objetos anidados. El formato INI está especializado en proporcionar la capacidad de tener una jerarquía de claves de información de configuación y herencia entre secciones de información de configuración. Las jerarquías de información de configuración está soportadas separando las claves con el carácter punto ("."). Una sección puede extender o heredar de otra sección añadiendo al nombre de la sección el carácter dos puntos(":") y el nombre de la sección desde la que se hereda la información.

Nota:

Yaf_Config_Ini utiliza la función » parse_ini_file() de PHP. Revise esta documentación para conocer sus comportamientos específicos, los cuales propaga a la clase Yaf_Config_Ini, tales como el manejo de valores especiales como "true", "false", "yes", "no", y "null".

Sinopsis de la Clase

Yaf_Config_Ini extends Yaf_Config_Abstract implements Iterator , ArrayAccess , Countable {
/* Propiedades */
/* Métodos */
public __construct ( string $config_file , string $section = ? )
public count ( ) : void
public current ( ) : void
public __get ( string $name = ? ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public readonly ( ) : void
public rewind ( ) : void
public __set ( string $name , mixed $value ) : void
public toArray ( ) : array
public valid ( ) : void
/* Métodos heredados */
abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed
abstract public Yaf_Config_Abstract::readonly ( ) : bool
abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract
abstract public Yaf_Config_Abstract::toArray ( ) : array
}

Propiedades

_config

_readonly

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Config_Ini()

Este ejemplo ilustra el uso básico de la clase Yaf_Config_Ini para cargar la información de configuración desde un fichero INI. En este ejemplo existe información de configuración para el sistema de producción y el sistema de pruebas (staging). Ya que la información de configuración del sistema de pruebas es similar a la de producción, la sección de pruebas hereda de la sección de producción. En este caso, la decisión es arbitraria y podría haber sido escrito a la inversa, con la sección de producción heredando de la sección de pruebas, aunque este puede no ser el caso para situaciones más complejas. Suponga que la información de configuración siguiente está contenida en /ruta/a/config.ini:

; Información de configuración del sitio de producción
[production]
webhost                  = www.example.com
database.adapter         = pdo_mysql
database.params.host     = db.example.com
database.params.username = dbuser
database.params.password = secret
database.params.dbname   = dbname

; La información de configuración del sitio de pruebas hereda del de producción y
; sobrescribe los valores según sea necesario
[staging : production]
database.params.host     = dev.example.com
database.params.username = devuser
database.params.password = devsecret
<?php
$config = new Yaf_Config_Ini('/ruta/a/config.ini', 'staging');

var_dump($config->database->params->host);
var_dump($config->database->params->dbname);
var_dump($config->get("database.params.username"));
?>

El resultado del ejemplo sería algo similar a:

string(15) "dev.example.com"
string(6) "dbname"
string(7) "devuser

Tabla de contenidos

  • Yaf_Config_Ini::__construct — Constructor de Yaf_Config_Ini
  • Yaf_Config_Ini::count — Contar todos los elementos en Yaf_Config.ini
  • Yaf_Config_Ini::current — Recuperar el valor actual
  • Yaf_Config_Ini::__get — Recuperar un elemento
  • Yaf_Config_Ini::__isset — Determinar si existe una clave
  • Yaf_Config_Ini::key — Buscar la clave del elemento actual
  • Yaf_Config_Ini::next — Avanzar el puntero interno
  • Yaf_Config_Ini::offsetExists — El propósito de offsetExists
  • Yaf_Config_Ini::offsetGet — El propósito de offsetGet
  • Yaf_Config_Ini::offsetSet — El propósito de offsetSet
  • Yaf_Config_Ini::offsetUnset — El propósito de offsetUnset
  • Yaf_Config_Ini::readonly — El propósito de readonly
  • Yaf_Config_Ini::rewind — El propósito de rewind
  • Yaf_Config_Ini::__set — El propósito de __set
  • Yaf_Config_Ini::toArray — Devuelve la configuración como un array PHP
  • Yaf_Config_Ini::valid — El propósito de valid


Constructor de Yaf_Config_Ini

  • « Yaf_Config_Ini
  • Yaf_Config_Ini::count »
  • PHP Manual
  • Yaf_Config_Ini
  • Constructor de Yaf_Config_Ini

Yaf_Config_Ini::__construct

(Yaf >=1.0.0)

Yaf_Config_Ini::__construct — Constructor de Yaf_Config_Ini

Descripción

public Yaf_Config_Ini::__construct ( string $config_file , string $section = ? )

El constructor de Yaf_Config_Ini

Parámetros

config_file

Ruta al fichero de configuración INI

section

Qué sección en cual fichero INI se quiere analizar

Valores devueltos


Contar todos los elementos en Yaf_Config.ini

  • « Yaf_Config_Ini::__construct
  • Yaf_Config_Ini::current »
  • PHP Manual
  • Yaf_Config_Ini
  • Contar todos los elementos en Yaf_Config.ini

Yaf_Config_Ini::count

(Yaf >=1.0.0)

Yaf_Config_Ini::count — Contar todos los elementos en Yaf_Config.ini

Descripción

public Yaf_Config_Ini::count ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recuperar el valor actual

  • « Yaf_Config_Ini::count
  • Yaf_Config_Ini::__get »
  • PHP Manual
  • Yaf_Config_Ini
  • Recuperar el valor actual

Yaf_Config_Ini::current

(Yaf >=1.0.0)

Yaf_Config_Ini::current — Recuperar el valor actual

Descripción

public Yaf_Config_Ini::current ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recuperar un elemento

  • « Yaf_Config_Ini::current
  • Yaf_Config_Ini::__isset »
  • PHP Manual
  • Yaf_Config_Ini
  • Recuperar un elemento

Yaf_Config_Ini::__get

(Yaf >=1.0.0)

Yaf_Config_Ini::__get — Recuperar un elemento

Descripción

public Yaf_Config_Ini::__get ( string $name = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


Determinar si existe una clave

  • « Yaf_Config_Ini::__get
  • Yaf_Config_Ini::key »
  • PHP Manual
  • Yaf_Config_Ini
  • Determinar si existe una clave

Yaf_Config_Ini::__isset

(Yaf >=1.0.0)

Yaf_Config_Ini::__isset — Determinar si existe una clave

Descripción

public Yaf_Config_Ini::__isset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


Buscar la clave del elemento actual

  • « Yaf_Config_Ini::__isset
  • Yaf_Config_Ini::next »
  • PHP Manual
  • Yaf_Config_Ini
  • Buscar la clave del elemento actual

Yaf_Config_Ini::key

(Yaf >=1.0.0)

Yaf_Config_Ini::key — Buscar la clave del elemento actual

Descripción

public Yaf_Config_Ini::key ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Avanzar el puntero interno

  • « Yaf_Config_Ini::key
  • Yaf_Config_Ini::offsetExists »
  • PHP Manual
  • Yaf_Config_Ini
  • Avanzar el puntero interno

Yaf_Config_Ini::next

(Yaf >=1.0.0)

Yaf_Config_Ini::next — Avanzar el puntero interno

Descripción

public Yaf_Config_Ini::next ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de offsetExists

  • « Yaf_Config_Ini::next
  • Yaf_Config_Ini::offsetGet »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de offsetExists

Yaf_Config_Ini::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetExists — El propósito de offsetExists

Descripción

public Yaf_Config_Ini::offsetExists ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetGet

  • « Yaf_Config_Ini::offsetExists
  • Yaf_Config_Ini::offsetSet »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de offsetGet

Yaf_Config_Ini::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetGet — El propósito de offsetGet

Descripción

public Yaf_Config_Ini::offsetGet ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetSet

  • « Yaf_Config_Ini::offsetGet
  • Yaf_Config_Ini::offsetUnset »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de offsetSet

Yaf_Config_Ini::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetSet — El propósito de offsetSet

Descripción

public Yaf_Config_Ini::offsetSet ( string $name , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


El propósito de offsetUnset

  • « Yaf_Config_Ini::offsetSet
  • Yaf_Config_Ini::readonly »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de offsetUnset

Yaf_Config_Ini::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetUnset — El propósito de offsetUnset

Descripción

public Yaf_Config_Ini::offsetUnset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de readonly

  • « Yaf_Config_Ini::offsetUnset
  • Yaf_Config_Ini::rewind »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de readonly

Yaf_Config_Ini::readonly

(Yaf >=1.0.0)

Yaf_Config_Ini::readonly — El propósito de readonly

Descripción

public Yaf_Config_Ini::readonly ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de rewind

  • « Yaf_Config_Ini::readonly
  • Yaf_Config_Ini::__set »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de rewind

Yaf_Config_Ini::rewind

(Yaf >=1.0.0)

Yaf_Config_Ini::rewind — El propósito de rewind

Descripción

public Yaf_Config_Ini::rewind ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __set

  • « Yaf_Config_Ini::rewind
  • Yaf_Config_Ini::toArray »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de __set

Yaf_Config_Ini::__set

(Yaf >=1.0.0)

Yaf_Config_Ini::__set — El propósito de __set

Descripción

public Yaf_Config_Ini::__set ( string $name , mixed $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


Devuelve la configuración como un array PHP

  • « Yaf_Config_Ini::__set
  • Yaf_Config_Ini::valid »
  • PHP Manual
  • Yaf_Config_Ini
  • Devuelve la configuración como un array PHP

Yaf_Config_Ini::toArray

(Yaf >=1.0.0)

Yaf_Config_Ini::toArray — Devuelve la configuración como un array PHP

Descripción

public Yaf_Config_Ini::toArray ( ) : array

Devuelve un array de PHP desde el Yaf_Config_Ini

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de valid

  • « Yaf_Config_Ini::toArray
  • Yaf_Config_Simple »
  • PHP Manual
  • Yaf_Config_Ini
  • El propósito de valid

Yaf_Config_Ini::valid

(Yaf >=1.0.0)

Yaf_Config_Ini::valid — El propósito de valid

Descripción

public Yaf_Config_Ini::valid ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


LA clase Yaf_Config_Simple

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Config_Simple extends Yaf_Config_Abstract implements Iterator , ArrayAccess , Countable {
/* Propiedades */
protected $_readonly ;
/* Métodos */
public __construct ( array $configs , bool $readonly = false )
public count ( ) : void
public current ( ) : void
public __get ( string $name = ? ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public readonly ( ) : void
public rewind ( ) : void
public __set ( string $name , string $value ) : void
public toArray ( ) : array
public valid ( ) : void
/* Métodos heredados */
abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed
abstract public Yaf_Config_Abstract::readonly ( ) : bool
abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract
abstract public Yaf_Config_Abstract::toArray ( ) : array
}

Propiedades

_config

_readonly

Tabla de contenidos

  • Yaf_Config_Simple::__construct — El propósito de __construct
  • Yaf_Config_Simple::count — El propósito de count
  • Yaf_Config_Simple::current — El propósito de current
  • Yaf_Config_Simple::__get — El propósito de __get
  • Yaf_Config_Simple::__isset — El propósito de __isset
  • Yaf_Config_Simple::key — El propósito de key
  • Yaf_Config_Simple::next — El propósito de next
  • Yaf_Config_Simple::offsetExists — El propósito de offsetExists
  • Yaf_Config_Simple::offsetGet — El propósito de offsetGet
  • Yaf_Config_Simple::offsetSet — El propósito de offsetSet
  • Yaf_Config_Simple::offsetUnset — El propósito de offsetUnset
  • Yaf_Config_Simple::readonly — El propósito de readonly
  • Yaf_Config_Simple::rewind — El propósito de rewind
  • Yaf_Config_Simple::__set — El propósito de __set
  • Yaf_Config_Simple::toArray — Devuelve un array de PHP
  • Yaf_Config_Simple::valid — El propósito de valid


El propósito de __construct

  • « Yaf_Config_Simple
  • Yaf_Config_Simple::count »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de __construct

Yaf_Config_Simple::__construct

(Yaf >=1.0.0)

Yaf_Config_Simple::__construct — El propósito de __construct

Descripción

public Yaf_Config_Simple::__construct ( array $configs , bool $readonly = false )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

configs

readonly

Valores devueltos


El propósito de count

  • « Yaf_Config_Simple::__construct
  • Yaf_Config_Simple::current »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de count

Yaf_Config_Simple::count

(Yaf >=1.0.0)

Yaf_Config_Simple::count — El propósito de count

Descripción

public Yaf_Config_Simple::count ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de current

  • « Yaf_Config_Simple::count
  • Yaf_Config_Simple::__get »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de current

Yaf_Config_Simple::current

(Yaf >=1.0.0)

Yaf_Config_Simple::current — El propósito de current

Descripción

public Yaf_Config_Simple::current ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __get

  • « Yaf_Config_Simple::current
  • Yaf_Config_Simple::__isset »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de __get

Yaf_Config_Simple::__get

(Yaf >=1.0.0)

Yaf_Config_Simple::__get — El propósito de __get

Descripción

public Yaf_Config_Simple::__get ( string $name = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de __isset

  • « Yaf_Config_Simple::__get
  • Yaf_Config_Simple::key »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de __isset

Yaf_Config_Simple::__isset

(Yaf >=1.0.0)

Yaf_Config_Simple::__isset — El propósito de __isset

Descripción

public Yaf_Config_Simple::__isset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de key

  • « Yaf_Config_Simple::__isset
  • Yaf_Config_Simple::next »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de key

Yaf_Config_Simple::key

(Yaf >=1.0.0)

Yaf_Config_Simple::key — El propósito de key

Descripción

public Yaf_Config_Simple::key ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de next

  • « Yaf_Config_Simple::key
  • Yaf_Config_Simple::offsetExists »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de next

Yaf_Config_Simple::next

(Yaf >=1.0.0)

Yaf_Config_Simple::next — El propósito de next

Descripción

public Yaf_Config_Simple::next ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de offsetExists

  • « Yaf_Config_Simple::next
  • Yaf_Config_Simple::offsetGet »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de offsetExists

Yaf_Config_Simple::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetExists — El propósito de offsetExists

Descripción

public Yaf_Config_Simple::offsetExists ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetGet

  • « Yaf_Config_Simple::offsetExists
  • Yaf_Config_Simple::offsetSet »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de offsetGet

Yaf_Config_Simple::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetGet — El propósito de offsetGet

Descripción

public Yaf_Config_Simple::offsetGet ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetSet

  • « Yaf_Config_Simple::offsetGet
  • Yaf_Config_Simple::offsetUnset »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de offsetSet

Yaf_Config_Simple::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetSet — El propósito de offsetSet

Descripción

public Yaf_Config_Simple::offsetSet ( string $name , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


El propósito de offsetUnset

  • « Yaf_Config_Simple::offsetSet
  • Yaf_Config_Simple::readonly »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de offsetUnset

Yaf_Config_Simple::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetUnset — El propósito de offsetUnset

Descripción

public Yaf_Config_Simple::offsetUnset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de readonly

  • « Yaf_Config_Simple::offsetUnset
  • Yaf_Config_Simple::rewind »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de readonly

Yaf_Config_Simple::readonly

(Yaf >=1.0.0)

Yaf_Config_Simple::readonly — El propósito de readonly

Descripción

public Yaf_Config_Simple::readonly ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de rewind

  • « Yaf_Config_Simple::readonly
  • Yaf_Config_Simple::__set »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de rewind

Yaf_Config_Simple::rewind

(Yaf >=1.0.0)

Yaf_Config_Simple::rewind — El propósito de rewind

Descripción

public Yaf_Config_Simple::rewind ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __set

  • « Yaf_Config_Simple::rewind
  • Yaf_Config_Simple::toArray »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de __set

Yaf_Config_Simple::__set

(Yaf >=1.0.0)

Yaf_Config_Simple::__set — El propósito de __set

Descripción

public Yaf_Config_Simple::__set ( string $name , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


Devuelve un array de PHP

  • « Yaf_Config_Simple::__set
  • Yaf_Config_Simple::valid »
  • PHP Manual
  • Yaf_Config_Simple
  • Devuelve un array de PHP

Yaf_Config_Simple::toArray

(Yaf >=1.0.0)

Yaf_Config_Simple::toArray — Devuelve un array de PHP

Descripción

public Yaf_Config_Simple::toArray ( ) : array

Devuelve un array de PHP desde el Yaf_Config_Simple

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de valid

  • « Yaf_Config_Simple::toArray
  • Yaf_Controller_Abstract »
  • PHP Manual
  • Yaf_Config_Simple
  • El propósito de valid

Yaf_Config_Simple::valid

(Yaf >=1.0.0)

Yaf_Config_Simple::valid — El propósito de valid

Descripción

public Yaf_Config_Simple::valid ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Controller_Abstract

(Yaf >=1.0.0)

Introducción

Yaf_Controller_Abstract es el corazón del sistema de Yaf. MVC significa Modelo Vista Controlador (Model-View-Controller en inglés) y es un patrón de diseño cuyo objetivo es separa la lógica de aplicación de la lógica de vista.

Cada controlador personalizado heredará de la clase Yaf_Controller_Abstract.

Se encontrará con que no se pude definir la función __construct en los controladores personalizados, y por esto Yaf_Controller_Abstract proporciona un método mágico: Yaf_Controller_Abstract::init()().

Si se ha definido un método init() en el controlador personalizado, será llamado en cuanto el controlador se instancie.

Las acciones pueden tener argumentos, al hacerle una petición, si en los parámetros de la petición existen los mismos nombres de variables (véase Yaf_Request_Abstract::getParam()) después del enrutamiento, Yaf los pasará al método de acción (véase Yaf_Action_Abstract::execute()).

Nota:

Estos argumentos se obtienen directamente sin filtración, se deberían porcesar con cuidado antes de usarlos.

Sinopsis de la Clase

abstract Yaf_Controller_Abstract {
/* Propiedades */
public $actions ;
protected $_module ;
protected $_name ;
protected $_request ;
protected $_response ;
protected $_invoke_args ;
protected $_view ;
/* Métodos */
final private __construct ( )
protected display ( string $tpl , array $parameters = ? ) : bool
public forward ( string $action , array $paramters = ? ) : void
public getInvokeArg ( string $name ) : void
public getInvokeArgs ( ) : void
public getModuleName ( ) : string
public getName ( ) : string
public getRequest ( ) : Yaf_Request_Abstract
public getResponse ( ) : Yaf_Response_Abstract
public getView ( ) : Yaf_View_Interface
public getViewpath ( ) : string
public init ( ) : void
public initView ( array $options = ? ) : void
public redirect ( string $url ) : bool
protected render ( string $tpl , array $parameters = ? ) : string
public setViewpath ( string $view_directory ) : void
}

Propiedades

actions

También se puede definir un método de acción en un script de PHP por separado usando esta propiedad y la clase Yaf_Action_Abstract.

Ejemplo #1 Definir una acción en un fichero aparte

<?php
class IndexController extends Yaf_Controller_Abstract {
    protected $acciones = array(
        /** ahora dummyAction está definida en un fichero aparte */
        "dummy" => "actions/Dummy_action.php",
    );

    /* el método de acción puede tener argumentos */
    public indexAction($nombre, $id) {
       /* $name e $id son datos no seguros sin tratar */
       assert($nombre == $this->getRequest()->getParam("nombre"));
       assert($id   == $this->_request->getParam("id"));
    }
}
?>

Ejemplo #2 Dummy_action.php

<?php
class DummyAction extends Yaf_Action_Abstract {
    /* una clase de acción definirá este método como el punto de entrada */
    public execute() {
    }
}
?>

_module

El nombre del módulo

_name

El nombre del controlador

_request

El objeto de petición actual

_response

El objeto respuesta actual

_invoke_args

_view

El objeto de motor de vistas

Tabla de contenidos

  • Yaf_Controller_Abstract::__construct — Constructor de Yaf_Controller_Abstract
  • Yaf_Controller_Abstract::display — El propósito de display
  • Yaf_Controller_Abstract::forward — Avanza a la siguiente acción
  • Yaf_Controller_Abstract::getInvokeArg — El propósito de getInvokeArg
  • Yaf_Controller_Abstract::getInvokeArgs — El propósito de getInvokeArgs
  • Yaf_Controller_Abstract::getModuleName — Obtiene el nombre del módulo
  • Yaf_Controller_Abstract::getName — Obtener el nombre propio
  • Yaf_Controller_Abstract::getRequest — Recupera el objeto petición actual
  • Yaf_Controller_Abstract::getResponse — Recupera el objeto respuesta actual
  • Yaf_Controller_Abstract::getView — Recupera el motor de vistas
  • Yaf_Controller_Abstract::getViewpath — El propósito de getViewpath
  • Yaf_Controller_Abstract::init — Inicializador del controlador
  • Yaf_Controller_Abstract::initView — El propósito de initView
  • Yaf_Controller_Abstract::redirect — Redirige a un URL
  • Yaf_Controller_Abstract::render — Interpreta una plantilla de vista
  • Yaf_Controller_Abstract::setViewpath — El propósito de setViewpath


Constructor de Yaf_Controller_Abstract

  • « Yaf_Controller_Abstract
  • Yaf_Controller_Abstract::display »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Constructor de Yaf_Controller_Abstract

Yaf_Controller_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Controller_Abstract::__construct — Constructor de Yaf_Controller_Abstract

Descripción

final private Yaf_Controller_Abstract::__construct ( )

Yaf_Controller_Abstract::__construct() es final, lo que significa que no puede ser sobrescrito. Véase en su lugar Yaf_Controller_Abstract::init().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Controller_Abstract::init() - Inicializador del controlador


El propósito de display

  • « Yaf_Controller_Abstract::__construct
  • Yaf_Controller_Abstract::forward »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de display

Yaf_Controller_Abstract::display

(Yaf >=1.0.0)

Yaf_Controller_Abstract::display — El propósito de display

Descripción

protected Yaf_Controller_Abstract::display ( string $tpl , array $parameters = ? ) : bool

Parámetros

tpl

parameters

Valores devueltos


Avanza a la siguiente acción

  • « Yaf_Controller_Abstract::display
  • Yaf_Controller_Abstract::getInvokeArg »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Avanza a la siguiente acción

Yaf_Controller_Abstract::forward

(Yaf >=1.0.0)

Yaf_Controller_Abstract::forward — Avanza a la siguiente acción

Descripción

public Yaf_Controller_Abstract::forward ( string $action , array $paramters = ? ) : void
public Yaf_Controller_Abstract::forward ( string $controller , string $action , array $paramters = ? ) : void
public Yaf_Controller_Abstract::forward ( string $module , string $controller , string $action , array $paramters = ? ) : void

Avanza el proceso de ejecución actual a otra acción.

Nota:

Este método no cambia a la acción destino de inmediato, toma lugar después de la finalización del flujo actual.

Parámetros

module

El nombre del módulo destino. Si es NULL, se asume el nombre del módulo predeterminado

controller

El nombre del controlador destino

action

El nombre de la acción destino

paramters

Argumentos de llamada

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Controller_Abstract::forward()

<?php
class IndexController extends Yaf_Controller_Abstract
{
    public function indexAction(){
         $logined = $_SESSION["login"];
         if (!$logined) {
             $this->forward("login", array("from" => "Index")); // forward to login action
             return FALSE;  // this is important, this finish current working flow
                            // and tell the Yaf do not doing auto-render
         }

         // otros procesos
    }

    public function loginAction() {
         echo "login, redirected from ", $this->getInvokeArg("from") , " action";
    }
}
?>

El resultado del ejemplo sería algo similar a:

   login, redirected from Index action

Valores devueltos

Devuelve FALSE en caso de fallo

Ver también

  • Yaf_Request_Abstrace::getParam()


El propósito de getInvokeArg

  • « Yaf_Controller_Abstract::forward
  • Yaf_Controller_Abstract::getInvokeArgs »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de getInvokeArg

Yaf_Controller_Abstract::getInvokeArg

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArg — El propósito de getInvokeArg

Descripción

public Yaf_Controller_Abstract::getInvokeArg ( string $name ) : void

Parámetros

name

Valores devueltos


El propósito de getInvokeArgs

  • « Yaf_Controller_Abstract::getInvokeArg
  • Yaf_Controller_Abstract::getModuleName »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de getInvokeArgs

Yaf_Controller_Abstract::getInvokeArgs

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArgs — El propósito de getInvokeArgs

Descripción

public Yaf_Controller_Abstract::getInvokeArgs ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene el nombre del módulo

  • « Yaf_Controller_Abstract::getInvokeArgs
  • Yaf_Controller_Abstract::getName »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Obtiene el nombre del módulo

Yaf_Controller_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getModuleName — Obtiene el nombre del módulo

Descripción

public Yaf_Controller_Abstract::getModuleName ( ) : string

Obtiene el nombre del módulo del controlador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el nombre propio

  • « Yaf_Controller_Abstract::getModuleName
  • Yaf_Controller_Abstract::getRequest »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Obtener el nombre propio

Yaf_Controller_Abstract::getName

(Yaf >=3.2.0)

Yaf_Controller_Abstract::getName — Obtener el nombre propio

Descripción

public Yaf_Controller_Abstract::getName ( ) : string

obtiene el nombre del controlador

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string, nombre del controlador


Recupera el objeto petición actual

  • « Yaf_Controller_Abstract::getName
  • Yaf_Controller_Abstract::getResponse »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Recupera el objeto petición actual

Yaf_Controller_Abstract::getRequest

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getRequest — Recupera el objeto petición actual

Descripción

public Yaf_Controller_Abstract::getRequest ( ) : Yaf_Request_Abstract

Recupera el objeto petición actual

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de Yaf_Request_Abstract


Recupera el objeto respuesta actual

  • « Yaf_Controller_Abstract::getRequest
  • Yaf_Controller_Abstract::getView »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Recupera el objeto respuesta actual

Yaf_Controller_Abstract::getResponse

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getResponse — Recupera el objeto respuesta actual

Descripción

public Yaf_Controller_Abstract::getResponse ( ) : Yaf_Response_Abstract

Recupera el objeto respuesta actual

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de Yaf_Response_Abstract


Recupera el motor de vistas

  • « Yaf_Controller_Abstract::getResponse
  • Yaf_Controller_Abstract::getViewpath »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Recupera el motor de vistas

Yaf_Controller_Abstract::getView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getView — Recupera el motor de vistas

Descripción

public Yaf_Controller_Abstract::getView ( ) : Yaf_View_Interface

Recupera el motor de vistas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getViewpath

  • « Yaf_Controller_Abstract::getView
  • Yaf_Controller_Abstract::init »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de getViewpath

Yaf_Controller_Abstract::getViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getViewpath — El propósito de getViewpath

Descripción

public Yaf_Controller_Abstract::getViewpath ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Inicializador del controlador

  • « Yaf_Controller_Abstract::getViewpath
  • Yaf_Controller_Abstract::initView »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Inicializador del controlador

Yaf_Controller_Abstract::init

(Yaf >=1.0.0)

Yaf_Controller_Abstract::init — Inicializador del controlador

Descripción

public Yaf_Controller_Abstract::init ( ) : void

Yaf_Controller_Abstract::__construct() es final, lo que significa que los usuarios no puede sobrescribirlo, aunque pueden definir Yaf_Controller_Abstract::init(), que será invocado después de que el objeto controlador sea instanciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Controller_Abstract::__construct() - Constructor de Yaf_Controller_Abstract


El propósito de initView

  • « Yaf_Controller_Abstract::init
  • Yaf_Controller_Abstract::redirect »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de initView

Yaf_Controller_Abstract::initView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::initView — El propósito de initView

Descripción

public Yaf_Controller_Abstract::initView ( array $options = ? ) : void

Parámetros

options

Valores devueltos


Redirige a un URL

  • « Yaf_Controller_Abstract::initView
  • Yaf_Controller_Abstract::render »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Redirige a un URL

Yaf_Controller_Abstract::redirect

(Yaf >=1.0.0)

Yaf_Controller_Abstract::redirect — Redirige a un URL

Descripción

public Yaf_Controller_Abstract::redirect ( string $url ) : bool

Redirige a un URL enviando una cabecera 302

Parámetros

url

Un URL

Valores devueltos

bool


Interpreta una plantilla de vista

  • « Yaf_Controller_Abstract::redirect
  • Yaf_Controller_Abstract::setViewpath »
  • PHP Manual
  • Yaf_Controller_Abstract
  • Interpreta una plantilla de vista

Yaf_Controller_Abstract::render

(Yaf >=1.0.0)

Yaf_Controller_Abstract::render — Interpreta una plantilla de vista

Descripción

protected Yaf_Controller_Abstract::render ( string $tpl , array $parameters = ? ) : string

Parámetros

tpl

parameters

Valores devueltos


El propósito de setViewpath

  • « Yaf_Controller_Abstract::render
  • Yaf_Action_Abstract »
  • PHP Manual
  • Yaf_Controller_Abstract
  • El propósito de setViewpath

Yaf_Controller_Abstract::setViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::setViewpath — El propósito de setViewpath

Descripción

public Yaf_Controller_Abstract::setViewpath ( string $view_directory ) : void

Parámetros

view_directory

Valores devueltos


La clase Yaf_Action_Abstract

(Yaf >=1.0.0)

Introducción

Una acción puede ser definida en un fichero aparte en Yaf (véase Yaf_Controller_Abstract). Es decir, un método de acción también puede ser una clase Yaf_Action_Abstract.

Ya que debería existir un punto de entrada el cual pueda ser llamado por Yaf (a partir de PHP 5.3, existe un nuevo método mágico, __invoke, pero Yaf no sólo funciona con PHP 5.3+, Yaf elige otro método mágico de ejecución), se debe implementar el método abstracto Yaf_Action_Abstract::execute() en la clase de acción personalizada.

Sinopsis de la Clase

Yaf_Action_Abstract extends Yaf_Controller_Abstract {
/* Propiedades */
protected $_controller ;
/* Métodos */
abstract publicexecute ( mixed $arg = ? , mixed $... = ? ) : mixed
publicgetController ( ) : Yaf_Controller_Abstract
public getControllerName ( ) : string
/* Métodos heredados */
final private Yaf_Controller_Abstract::__construct ( )
protected Yaf_Controller_Abstract::display ( string $tpl , array $parameters = ? ) : bool
public Yaf_Controller_Abstract::forward ( string $action , array $paramters = ? ) : void
public Yaf_Controller_Abstract::getInvokeArg ( string $name ) : void
public Yaf_Controller_Abstract::getInvokeArgs ( ) : void
public Yaf_Controller_Abstract::getModuleName ( ) : string
public Yaf_Controller_Abstract::getName ( ) : string
public Yaf_Controller_Abstract::getRequest ( ) : Yaf_Request_Abstract
public Yaf_Controller_Abstract::getResponse ( ) : Yaf_Response_Abstract
public Yaf_Controller_Abstract::getView ( ) : Yaf_View_Interface
public Yaf_Controller_Abstract::getViewpath ( ) : string
public Yaf_Controller_Abstract::init ( ) : void
public Yaf_Controller_Abstract::initView ( array $options = ? ) : void
public Yaf_Controller_Abstract::redirect ( string $url ) : bool
protected Yaf_Controller_Abstract::render ( string $tpl , array $parameters = ? ) : string
public Yaf_Controller_Abstract::setViewpath ( string $view_directory ) : void
}

Propiedades

_module

_name

_request

_response

_invoke_args

_view

_controller

Tabla de contenidos

  • Yaf_Action_Abstract::execute — Punto de entrada de una acción
  • Yaf_Action_Abstract::getController — Recupera el objeto controlador
  • Yaf_Action_Abstract::getControllerName — Obtener el nombre del controlador


Punto de entrada de una acción

  • « Yaf_Action_Abstract
  • Yaf_Action_Abstract::getController »
  • PHP Manual
  • Yaf_Action_Abstract
  • Punto de entrada de una acción

Yaf_Action_Abstract::execute

(Yaf >=1.0.0)

Yaf_Action_Abstract::execute — Punto de entrada de una acción

Descripción

abstract publicYaf_Action_Abstract::execute ( mixed $arg = ? , mixed $... = ? ) : mixed

El usuario debería definir siempre este método para un acción, este es el punto de entrada de la misma. Yaf_Action_Abstract::execute() podría tener argumentos.

Nota:

El valor recuperado desde la petición no es seguro. Se debería filtrar el trabajo antes de usarlo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Action_Abstract::execute()

<?php
/**
 * Un ejemplo de controlador
 */
class ProductController extends Yaf_Controller_Abstract {
      protected $actions = array(
          "index" => "actions/Index.php",
      );
}
?>

Ejemplo #2 Ejemplo de Yaf_Action_Abstract::execute()

<?php
/**
 * ListAction
 */
class ListAction extends Yaf_Action_Abstract {
     public function execute ($name, $id) {
         assert($name == $this->getRequest()->getParam("name"));
         assert($id   == $this->getRequest()->getParam("id"));
     }
}
?>

El resultado del ejemplo sería algo similar a:

/**
 * Ahora asumimos que estamos usando la ruta Yaf_Route_Static
 * para la petición: http://yourdomain/product/list/name/yaf/id/22
 * resultará:
 */
 bool(true)
 bool(true)

Ver también


Recupera el objeto controlador

  • « Yaf_Action_Abstract::execute
  • Yaf_Action_Abstract::getControllerName »
  • PHP Manual
  • Yaf_Action_Abstract
  • Recupera el objeto controlador

Yaf_Action_Abstract::getController

(Yaf >=1.0.0)

Yaf_Action_Abstract::getController — Recupera el objeto controlador

Descripción

publicYaf_Action_Abstract::getController ( ) : Yaf_Controller_Abstract

Recupera el objeto controlador actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de Yaf_Controller_Abstract


Obtener el nombre del controlador

  • « Yaf_Action_Abstract::getController
  • Yaf_View_Interface »
  • PHP Manual
  • Yaf_Action_Abstract
  • Obtener el nombre del controlador

Yaf_Action_Abstract::getControllerName

(No hay información de versión disponible, podría estar únicamente en Git)

Yaf_Action_Abstract::getControllerName — Obtener el nombre del controlador

Descripción

public Yaf_Action_Abstract::getControllerName ( ) : string

obtener el nombre del controlador

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string, nombre del controlador


La clase Yaf_View_Interface

(Yaf >=1.0.0)

Introducción

Yaf proporciona a los desarrolladores la capacidad de usar un motor de vistas personalizado en lugar del motor integrado Yaf_View_Simple. Hay un ejemplo que explica cómo realizar esto, por favor, veáse Yaf_Dispatcher::setView().

Sinopsis de la Clase

Yaf_View_Interface {
/* Métodos */
abstract public assign ( string $name , string $value = ? ) : bool
abstract public display ( string $tpl , array $tpl_vars = ? ) : bool
abstract public getScriptPath ( ) : void
abstract public render ( string $tpl , array $tpl_vars = ? ) : string
abstract public setScriptPath ( string $template_dir ) : void
}

Tabla de contenidos

  • Yaf_View_Interface::assign — Asignar valores al motor de Vistas
  • Yaf_View_Interface::display — Interpretar e imprimir una plantilla
  • Yaf_View_Interface::getScriptPath — El propósito de getScriptPath
  • Yaf_View_Interface::render — Interpretar una plantilla
  • Yaf_View_Interface::setScriptPath — El propósito de setScriptPath


Asignar valores al motor de Vistas

  • « Yaf_View_Interface
  • Yaf_View_Interface::display »
  • PHP Manual
  • Yaf_View_Interface
  • Asignar valores al motor de Vistas

Yaf_View_Interface::assign

(Yaf >=1.0.0)

Yaf_View_Interface::assign — Asignar valores al motor de Vistas

Descripción

abstract public Yaf_View_Interface::assign ( string $name , string $value = ? ) : bool

Asigna valores al motor de Vistas, después se pueden acceder a los valores directamente mediante su nombre en la plantilla.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


Interpretar e imprimir una plantilla

  • « Yaf_View_Interface::assign
  • Yaf_View_Interface::getScriptPath »
  • PHP Manual
  • Yaf_View_Interface
  • Interpretar e imprimir una plantilla

Yaf_View_Interface::display

(Yaf >=1.0.0)

Yaf_View_Interface::display — Interpretar e imprimir una plantilla

Descripción

abstract public Yaf_View_Interface::display ( string $tpl , array $tpl_vars = ? ) : bool

Interpreta e imprime el resultado inmediatamente.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

tpl

tpl_vars

Valores devueltos


El propósito de getScriptPath

  • « Yaf_View_Interface::display
  • Yaf_View_Interface::render »
  • PHP Manual
  • Yaf_View_Interface
  • El propósito de getScriptPath

Yaf_View_Interface::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::getScriptPath — El propósito de getScriptPath

Descripción

abstract public Yaf_View_Interface::getScriptPath ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Interpretar una plantilla

  • « Yaf_View_Interface::getScriptPath
  • Yaf_View_Interface::setScriptPath »
  • PHP Manual
  • Yaf_View_Interface
  • Interpretar una plantilla

Yaf_View_Interface::render

(Yaf >=1.0.0)

Yaf_View_Interface::render — Interpretar una plantilla

Descripción

abstract public Yaf_View_Interface::render ( string $tpl , array $tpl_vars = ? ) : string

Interpreta una plantilla y devuelve el resultado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

tpl

tpl_vars

Valores devueltos


El propósito de setScriptPath

  • « Yaf_View_Interface::render
  • Yaf_View_Simple »
  • PHP Manual
  • Yaf_View_Interface
  • El propósito de setScriptPath

Yaf_View_Interface::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::setScriptPath — El propósito de setScriptPath

Descripción

abstract public Yaf_View_Interface::setScriptPath ( string $template_dir ) : void

Establece el directorio base de plantillas. Normalmente es llamado por Yaf_Dispatcher

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

template_dir

Una ruta absoluta al directorio de plantillas, por omisión, Yaf_Dispatcher usa application.directory . "/views" como este parámetro.

Valores devueltos


La clase Yaf_View_Simple

(Yaf >=1.0.0)

Introducción

Yaf_View_Simple es el motor de plantillas incorporade de Yaf. Es un motor de plantillas sencillo pero rápido, y sólo soporta plantillas de script de PHP.

Sinopsis de la Clase

Yaf_View_Simple implements Yaf_View_Interface {
/* Propiedades */
protected $_tpl_vars ;
protected $_tpl_dir ;
/* Métodos */
public assign ( string $name , mixed $value = ? ) : bool
public assignRef ( string $name , mixed &$value ) : bool
public clear ( string $name = ? ) : bool
final public __construct ( string $template_dir , array $options = ? )
public display ( string $tpl , array $tpl_vars = ? ) : bool
public eval ( string $tpl_content , array $tpl_vars = ? ) : string
public __get ( string $name = ? ) : void
public getScriptPath ( ) : string
public __isset ( string $name ) : void
public render ( string $tpl , array $tpl_vars = ? ) : string
public __set ( string $name , mixed $value ) : void
public setScriptPath ( string $template_dir ) : bool
}

Propiedades

_tpl_vars

_tpl_dir

Tabla de contenidos

  • Yaf_View_Simple::assign — Asignar valores
  • Yaf_View_Simple::assignRef — El propósito de assignRef
  • Yaf_View_Simple::clear — Limpiar valores asignados
  • Yaf_View_Simple::__construct — El constructor de Yaf_View_Simple
  • Yaf_View_Simple::display — Interpretar y mostrar
  • Yaf_View_Simple::eval — Interpreta una plantilla
  • Yaf_View_Simple::__get — Recupera una variable asignada
  • Yaf_View_Simple::getScriptPath — Obtiene el directorio de plantillas
  • Yaf_View_Simple::__isset — El propósito de __isset
  • Yaf_View_Simple::render — Interpreta una plantilla
  • Yaf_View_Simple::__set — Establece el valor para el motor
  • Yaf_View_Simple::setScriptPath — Establece el directorio de plantillas


Asignar valores

  • « Yaf_View_Simple
  • Yaf_View_Simple::assignRef »
  • PHP Manual
  • Yaf_View_Simple
  • Asignar valores

Yaf_View_Simple::assign

(Yaf >=1.0.0)

Yaf_View_Simple::assign — Asignar valores

Descripción

public Yaf_View_Simple::assign ( string $name , mixed $value = ? ) : bool

Asigna una variable al motor de vistas.

Parámetros

name

Una cadena o un array.

Si es una cadena se requiere el argumento $value siguiente.

value

Valor mixto

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_View_Simple::assign()

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->assign("foo", "bar");
        $this->_view->assign( array( "key" => "value", "name" => "value"));
    }
?>

Ejemplo #2 Ejemplo de template()

<html>
 <head>
  <title><?php echo $foo; ?></title>
 </head>
<body>
  <?php
    foreach ($this->_tpl_vars as $name => value) {
         echo $$name; // o echo $this->_tpl_vars[$name];
    }
  ?>
</body>
</html>

Ver también

  • Yaf_View_Simple::assignRef() - El propósito de assignRef
  • Yaf_View_Interface::clear()
  • Yaf_View_Simple::__set() - Establece el valor para el motor


El propósito de assignRef

  • « Yaf_View_Simple::assign
  • Yaf_View_Simple::clear »
  • PHP Manual
  • Yaf_View_Simple
  • El propósito de assignRef

Yaf_View_Simple::assignRef

(Yaf >=1.0.0)

Yaf_View_Simple::assignRef — El propósito de assignRef

Descripción

public Yaf_View_Simple::assignRef ( string $name , mixed &$value ) : bool

A diferencia de Yaf_View_Simple::assign(), este método asigna un valor de referencia al motor.

Parámetros

name

Un nombre como cadena que será usado para acceder al valor de la plantilla.

value

Valor mixto

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_View_Simple::assignRef()

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $value = "bar";
        $this->getView()->assign("foo", $value);

        /* por favor, observe que existía un error antes de Yaf 2.1.4,
         * que hacía que lo siguiente imprimiera "bar";
         */
        $dummy = $this->getView()->render("index/index.phtml");
        echo $value;

        //prevenir la autointerpretación
        Yaf_Dispatcher::getInstance()->autoRender(FALSE);
    }
?>

Ejemplo #2 Ejemplo de template()

<html>
 <head>
  <title><?php echo $foo;  $foo = "cambiado"; ?></title>
 </head>
<body>
</body>
</html>

El resultado del ejemplo sería algo similar a:

/* el acceso al controlador index resultará en: */
cambiado

Ver también

  • Yaf_View_Simple::assign() - Asignar valores
  • Yaf_View_Simple::__set() - Establece el valor para el motor


Limpiar valores asignados

  • « Yaf_View_Simple::assignRef
  • Yaf_View_Simple::__construct »
  • PHP Manual
  • Yaf_View_Simple
  • Limpiar valores asignados

Yaf_View_Simple::clear

(Yaf >=2.2.0)

Yaf_View_Simple::clear — Limpiar valores asignados

Descripción

public Yaf_View_Simple::clear ( string $name = ? ) : bool

Limpia una variable asignada

Parámetros

name

El nombre de la variable asignada

Si está vacía, limpiará todas las variables asignadas

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_View_Simple::clear()

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->clear("foo")->clear("bar"); // clear "foo" and "bar"
        $this->_view->clear(); //clear all assigned variables
    }
?>

Ver también

  • Yaf_View_Simple::assignRef() - El propósito de assignRef
  • Yaf_View_Interface::assign() - Asignar valores al motor de Vistas
  • Yaf_View_Simple::__set() - Establece el valor para el motor


El constructor de Yaf_View_Simple

  • « Yaf_View_Simple::clear
  • Yaf_View_Simple::display »
  • PHP Manual
  • Yaf_View_Simple
  • El constructor de Yaf_View_Simple

Yaf_View_Simple::__construct

(Yaf >=1.0.0)

Yaf_View_Simple::__construct — El constructor de Yaf_View_Simple

Descripción

final public Yaf_View_Simple::__construct ( string $template_dir , array $options = ? )

Parámetros

template_dir

El directorio base de las plantillas, por omisión es APPLICATOIN . "/views" para Yaf.

options

Opciones para el motor, a partir de Yaf 2.1.13, se pueden usar etiquetas cortas
      "<?=$var?>" en las plantillas (sin tener en cuenta "short_open_tag"),
      por lo que viene una opción llamada "short_tag", se puede desactivar
      para prevenir el uso de short_tag en las plantillas.

Ejemplos

Ejemplo #1 Ejemplo de Yaf_View_Simple::__constructor()

<?php
   define ("TEMPLATE_DIRECTORY", APPLICATOIN_PATH . '/views');
   $view = new Yaf_View_Simple(TEMPLATE_DIRECTORY, array(
                           'short_tag' => false //no se permite el uso de etiquetas cortas en las plantillas
   ));
?>

Valores devueltos


Interpretar y mostrar

  • « Yaf_View_Simple::__construct
  • Yaf_View_Simple::eval »
  • PHP Manual
  • Yaf_View_Simple
  • Interpretar y mostrar

Yaf_View_Simple::display

(Yaf >=1.0.0)

Yaf_View_Simple::display — Interpretar y mostrar

Descripción

public Yaf_View_Simple::display ( string $tpl , array $tpl_vars = ? ) : bool

Interpreta una plantilla y muestra el resultado inmediatamente.

Parámetros

tpl

tpl_vars

Valores devueltos


Interpreta una plantilla

  • « Yaf_View_Simple::display
  • Yaf_View_Simple::__get »
  • PHP Manual
  • Yaf_View_Simple
  • Interpreta una plantilla

Yaf_View_Simple::eval

(Yaf >=2.2.0)

Yaf_View_Simple::eval — Interpreta una plantilla

Descripción

public Yaf_View_Simple::eval ( string $tpl_content , array $tpl_vars = ? ) : string

Interpreta una plantilla de tipo string y devuelve el resultado.

Parámetros

tpl_content

La plantilla de tipo string

tpl_vars

Valores devueltos


Recupera una variable asignada

  • « Yaf_View_Simple::eval
  • Yaf_View_Simple::getScriptPath »
  • PHP Manual
  • Yaf_View_Simple
  • Recupera una variable asignada

Yaf_View_Simple::__get

(Yaf >=1.0.0)

Yaf_View_Simple::__get — Recupera una variable asignada

Descripción

public Yaf_View_Simple::__get ( string $name = ? ) : void

Recupera una variable asignada.

Nota:

El parámetro puede estar vacío desde la versión 2.1.11.

Parámetros

name

El nombre de la variable asignada.

Si este parámetro está vacío serán devueltas todas las variables asignadas.

Valores devueltos


Obtiene el directorio de plantillas

  • « Yaf_View_Simple::__get
  • Yaf_View_Simple::__isset »
  • PHP Manual
  • Yaf_View_Simple
  • Obtiene el directorio de plantillas

Yaf_View_Simple::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::getScriptPath — Obtiene el directorio de plantillas

Descripción

public Yaf_View_Simple::getScriptPath ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __isset

  • « Yaf_View_Simple::getScriptPath
  • Yaf_View_Simple::render »
  • PHP Manual
  • Yaf_View_Simple
  • El propósito de __isset

Yaf_View_Simple::__isset

(Yaf >=1.0.0)

Yaf_View_Simple::__isset — El propósito de __isset

Descripción

public Yaf_View_Simple::__isset ( string $name ) : void

Parámetros

name

Valores devueltos


Interpreta una plantilla

  • « Yaf_View_Simple::__isset
  • Yaf_View_Simple::__set »
  • PHP Manual
  • Yaf_View_Simple
  • Interpreta una plantilla

Yaf_View_Simple::render

(Yaf >=1.0.0)

Yaf_View_Simple::render — Interpreta una plantilla

Descripción

public Yaf_View_Simple::render ( string $tpl , array $tpl_vars = ? ) : string

Interpreta una plantilla y devuelve el resultado.

Parámetros

tpl

tpl_vars

Valores devueltos


Establece el valor para el motor

  • « Yaf_View_Simple::render
  • Yaf_View_Simple::setScriptPath »
  • PHP Manual
  • Yaf_View_Simple
  • Establece el valor para el motor

Yaf_View_Simple::__set

(Yaf >=1.0.0)

Yaf_View_Simple::__set — Establece el valor para el motor

Descripción

public Yaf_View_Simple::__set ( string $name , mixed $value ) : void

Esta es una manera alternativa y más sencilla de usar Yaf_View_Simple::assign().

Parámetros

name

Un nombre de valor de tipo string.

value

Valor mixto.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_View_Simple::__set()

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->foo = "bar"; // es lo mismo que assign("foo", "bar");
    }
?>

Ver también

  • Yaf_View_Simple::assignRef() - El propósito de assignRef
  • Yaf_View_Interface::assign() - Asignar valores al motor de Vistas


Establece el directorio de plantillas

  • « Yaf_View_Simple::__set
  • Yaf_Loader »
  • PHP Manual
  • Yaf_View_Simple
  • Establece el directorio de plantillas

Yaf_View_Simple::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::setScriptPath — Establece el directorio de plantillas

Descripción

public Yaf_View_Simple::setScriptPath ( string $template_dir ) : bool

Parámetros

template_dir

Valores devueltos


La clase Yaf_Loader

(Yaf >=1.0.0)

Introducción

Yaf_Loader introduce una solución completa de autocarga para Yaf.

La primera vez que se recupera una instancia de la clase Yaf_Application, Yaf_Loader instanciará un singleton, y se registrará a sí mismo con spl_autoload. Se recupera una instancia usando el método Yaf_Loader::getInstance()

Yaf_Loader intenta cargar una clase sólo una vez, y si falla, dependiendo de yaf.use_spl_auload, si esta configuración es "On" Yaf_Loader::autoload() devolverá false, y así dará otra oportunidad a otra función de autocarga; si es "Off" (por omisión), Yaf_Loader::autoload() devolverá true, y lo que es más importante: emitirá una advertencia muy útil (muy útil para averiguar por qué no se cargó una clase).

Nota:

Por favor, mantenga yaf.use_spl_autoload en "Off" a menos que exista una biblioteca que tenga su propio mecanismo de autocarga y sea imposible reescribirlo.

Por defecto, Yaf_Loader asume que todas las bibliotecas (las clases definidas en el script) se almacenan en el directorio de clases global, el cual está definido en php.ini (yaf.library).

Si quiere que Yaf_Loader busque algunas clases (bibliotecas) en el directorio de clases local (el cual está definido en application.ini, y por omisión es application.directory . "/libraray"), debería registrar el prefijo de clases usando el método Yaf_Loader::registerLocalNameSpace()

Veamos algunos ejemplos (asumiendo que APPLICATION_PATH es application.directory):

Ejemplo #1 Ejemplo de configuración

// Se asume la siguiente configuración en php.ini:
yaf.library = "/global_dir"

// Se asume la siguiente configuración en application.ini
application.library = APPLICATION_PATH "/library"
Se asume que el siguiente espacio de nombres local está registrado:

Ejemplo #2 Registrar el espacio de nombres local

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
     public function _initLoader($dispatcher) {
          Yaf_Loader::getInstance()->registerLocalNameSpace(array("Foo", "Bar"));
     }
?>
Ahora los ejemplos de autocarga:

Ejemplo #3 Load class example

class Foo_Bar_Test =>
  // APPLICATION_PATH/library/Foo/Bar/Test.php

class GLO_Name  =>
  // /global_dir/Glo/Name.php

class BarNon_Test
  // /global_dir/Barnon/Test.php
A partir de PHP 5.3 se pueden usar espacios de nombres:

Ejemplo #4 Ejemplo de carga de una clase en el espacio de nombres

class \Foo\Bar\Dummy =>
   // APPLICATION_PATH/library/Foo/Bar/Dummy.php

class \FooBar\Bar\Dummy =>
   // /global_dir/FooBar/Bar/Dummy.php

Se puede observar que todas las carpetas tienen la primera letra en mayúsculas, se pueden ponerlas en minúsculas estableciendo yaf.lowcase_path = On en php.ini

Yaf_Loader también está diseñada para cargar las clases MVC, y la regla es:

Ejemplo #5 Ejemplo de carga de clase MVC

Controller Classes =>
// APPLICATION_PATH/controllers/

Model Classes =>
// APPLICATION_PATH/models/

Plugin Classes =>
// APPLICATION_PATH/plugins/
Yaf identifica un sufijo de clases (por omisión, se puede cambiar el sufijo cambiando la opción de configuración yaf.name_suffix) para decidir si es una clase MVC:

Ejemplo #6 Distinciones de clases MVC

Controller Classes =>
    // ***Controller

Model Classes =>
    // ***Model

Plugin Classes =>
    // ***Plugin
algunos ejemplos:

Ejemplo #7 Ejemplo de carga MVC

class IndexController
    // APPLICATION_PATH/controllers/Index.php

class DataModel =>
   // APPLICATION_PATH/models/Data.php

class DummyPlugin =>
  // APPLICATION_PATH/plugins/Dummy.php

class A_B_TestModel =>
  // APPLICATION_PATH/models/A/B/Test.php

Nota:

A partir de 2.1.18, Yaf admite que los Controllers se autocarguen para el lado del scrpt cliente, (lo que significa que la autocarga se desencadena por el script del usuario de php, p.ej., acceder a una propiedad de un Controller estático en Bootstrap o Plugins), aunque el autocargador solamente intenta localizar el controlador bajo la carpeta del módulo predeterminado, que es "APPLICATION_PATH/controllers/".

también, el directorio será afectado por yaf.lowcase_path.

Sinopsis de la Clase

Yaf_Loader {
/* Propiedades */
protected $_local_ns ;
protected $_library ;
protected $_global_library ;
static $_instance ;
/* Métodos */
public autoload ( ) : void
public clearLocalNamespace ( ) : void
private __construct ( )
public static getInstance ( ) : void
public getLibraryPath ( bool $is_global = false ) : Yaf_Loader
public getLocalNamespace ( ) : void
public getNamespacePath ( string $namespaces ) : string
public getNamespaces ( ) : array
public static import ( ) : void
public isLocalName ( ) : void
public registerLocalNamespace ( mixed $prefix ) : void
public registerNamespace ( string|array $namespaces , string $path = ? ) : bool
public setLibraryPath ( string $directory , bool $is_global = false ) : Yaf_Loader
}

Propiedades

_local_ns

_library

Por omisión, este valor es application.directory . "/library", se puede cambiar en application.ini (application.library) o llamando al método Yaf_Loader::setLibraryPath()

_global_library

_instance

Tabla de contenidos

  • Yaf_Loader::autoload — El propósito de autoload
  • Yaf_Loader::clearLocalNamespace — El propósito de clearLocalNamespace
  • Yaf_Loader::__construct — El propósito de __construct
  • Yaf_Loader::getInstance — El propósito de getInstance
  • Yaf_Loader::getLibraryPath — Obtener la ruta de la biblioteca
  • Yaf_Loader::getLocalNamespace — El propósito de getLocalNamespace
  • Yaf_Loader::getNamespacePath — Recupera la ruta de un espacio de nombres registrado
  • Yaf_Loader::getLocalNamespace — Recupera toda la información de un espacio de nombre
  • Yaf_Loader::import — El propósito de import
  • Yaf_Loader::isLocalName — El propósito de isLocalName
  • Yaf_Loader::registerLocalNamespace — Registra un prefijo de clase local
  • Yaf_Loader::registerNamespace — Registra un espacio de nombre con ruta de búsqueda
  • Yaf_Loader::setLibraryPath — Cmabiar la ruta de la biblioteca


El propósito de autoload

  • « Yaf_Loader
  • Yaf_Loader::clearLocalNamespace »
  • PHP Manual
  • Yaf_Loader
  • El propósito de autoload

Yaf_Loader::autoload

(Yaf >=1.0.0)

Yaf_Loader::autoload — El propósito de autoload

Descripción

public Yaf_Loader::autoload ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de clearLocalNamespace

  • « Yaf_Loader::autoload
  • Yaf_Loader::__construct »
  • PHP Manual
  • Yaf_Loader
  • El propósito de clearLocalNamespace

Yaf_Loader::clearLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::clearLocalNamespace — El propósito de clearLocalNamespace

Descripción

public Yaf_Loader::clearLocalNamespace ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __construct

  • « Yaf_Loader::clearLocalNamespace
  • Yaf_Loader::getInstance »
  • PHP Manual
  • Yaf_Loader
  • El propósito de __construct

Yaf_Loader::__construct

(Yaf >=1.0.0)

Yaf_Loader::__construct — El propósito de __construct

Descripción

private Yaf_Loader::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getInstance

  • « Yaf_Loader::__construct
  • Yaf_Loader::getLibraryPath »
  • PHP Manual
  • Yaf_Loader
  • El propósito de getInstance

Yaf_Loader::getInstance

(Yaf >=1.0.0)

Yaf_Loader::getInstance — El propósito de getInstance

Descripción

public static Yaf_Loader::getInstance ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener la ruta de la biblioteca

  • « Yaf_Loader::getInstance
  • Yaf_Loader::getLocalNamespace »
  • PHP Manual
  • Yaf_Loader
  • Obtener la ruta de la biblioteca

Yaf_Loader::getLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::getLibraryPath — Obtener la ruta de la biblioteca

Descripción

public Yaf_Loader::getLibraryPath ( bool $is_global = false ) : Yaf_Loader

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getLocalNamespace

  • « Yaf_Loader::getLibraryPath
  • Yaf_Loader::getNamespacePath »
  • PHP Manual
  • Yaf_Loader
  • El propósito de getLocalNamespace

Yaf_Loader::getLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::getLocalNamespace — El propósito de getLocalNamespace

Descripción

public Yaf_Loader::getLocalNamespace ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera la ruta de un espacio de nombres registrado

  • « Yaf_Loader::getLocalNamespace
  • Yaf_Loader::getLocalNamespace »
  • PHP Manual
  • Yaf_Loader
  • Recupera la ruta de un espacio de nombres registrado

Yaf_Loader::getNamespacePath

(Yaf >=3.2.0)

Yaf_Loader::getNamespacePath — Recupera la ruta de un espacio de nombres registrado

Descripción

public Yaf_Loader::getNamespacePath ( string $namespaces ) : string

recupera la ruta de un espacio de nombre registrado

Parámetros

namespace

un string de espacio de nombre.

Valores devueltos

ruta string, si el espacio de nombre no está registrado, entonces null la biblioteca por defecto será devuelta

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Loader::registerNamespace()

<?php
$loader = Yaf_Loader::getInstance("/var/application/lib");
$loader->registerNamespace("\Vendor\PHP", "/var/lib/php");

$loader->getNamespacePath("\Vendor\PHP"); // '/var/lib/php'
$loader->getNamespacePath("\Vendor\JSP"); // '/var/application/lib'

?>


Recupera toda la información de un espacio de nombre

  • « Yaf_Loader::getNamespacePath
  • Yaf_Loader::import »
  • PHP Manual
  • Yaf_Loader
  • Recupera toda la información de un espacio de nombre

Yaf_Loader::getLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::getLocalNamespace — Recupera toda la información de un espacio de nombre

Descripción

public Yaf_Loader::getNamespaces ( ) : array

obtener información de espacio de nombre registrados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

array


El propósito de import

  • « Yaf_Loader::getLocalNamespace
  • Yaf_Loader::isLocalName »
  • PHP Manual
  • Yaf_Loader
  • El propósito de import

Yaf_Loader::import

(Yaf >=1.0.0)

Yaf_Loader::import — El propósito de import

Descripción

public static Yaf_Loader::import ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de isLocalName

  • « Yaf_Loader::import
  • Yaf_Loader::registerLocalNamespace »
  • PHP Manual
  • Yaf_Loader
  • El propósito de isLocalName

Yaf_Loader::isLocalName

(Yaf >=1.0.0)

Yaf_Loader::isLocalName — El propósito de isLocalName

Descripción

public Yaf_Loader::isLocalName ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Registra un prefijo de clase local

  • « Yaf_Loader::isLocalName
  • Yaf_Loader::registerNamespace »
  • PHP Manual
  • Yaf_Loader
  • Registra un prefijo de clase local

Yaf_Loader::registerLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::registerLocalNamespace — Registra un prefijo de clase local

Descripción

public Yaf_Loader::registerLocalNamespace ( mixed $prefix ) : void

Registra un nombre de prefijo de clase local. Yaf_Loader busca clases en dos directorios de bibliotecas, uno se configura mediante application.library.directory (en application.ini) al que se le llama directorio de bibliotecas local; el otro se configura mediante yaf.library (en php.ini) al que se llamma le directorio de bibliotecas global, ya que puede ser compartido mediante muchas apliacionies en el mismo servidor.

Al desencadenar una autocarga, Yaf_Loader determinará en que directorio de bibliotecas debería buscar examinando el nombre de prefijo del nombre de clase faltante. Si el nombre de prefijo está registrado como un paquete de nombres local, entonces se le buscará en el directorio de bibliotecas local, si no, se buscará en el directorio de bibliotecas global.

Nota:

Si yaf.library no está configurado, se asume que el directorio de bibliotecas global es el directorio de bibliotecas local. En este caso, todas las auto cargas buscarán en el directorio de bibliotecas local. Aunque si se quiere que una aplicación Yaf sea fuerte, se han de registrar siempre las propias clases como clases locales.

Parámetros

prefix

Un string o un a array con el prefijo del nombre de la clase. Todas las clases con este prefijo se cargarán en la ruta de la biblioteca local.

Valores devueltos

Devuelve un booleano.

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Loader::registerLocalNamespace()

<?php
$loader = Yaf_Loader::getInstance('/local/library/', '/global/library');
$loader->registerLocalNamespace("Baidu");
$loader->registerLocalNamespace(array("Sina", "Weibo"));

$loader->autoload("Baidu_Name"); // buscar en '/local/library/'
$loader->autoload("Sina");       // buscar en '/local/library/'
$loader->autoload("Global_Name");// buscar en '/global/library/'
$loader->autoload("Foo_Bar");    // buscar en '/global/library/'

?>


Registra un espacio de nombre con ruta de búsqueda

  • « Yaf_Loader::registerLocalNamespace
  • Yaf_Loader::setLibraryPath »
  • PHP Manual
  • Yaf_Loader
  • Registra un espacio de nombre con ruta de búsqueda

Yaf_Loader::registerNamespace

(Yaf >=3.2.0)

Yaf_Loader::registerNamespace — Registra un espacio de nombre con ruta de búsqueda

Descripción

public Yaf_Loader::registerNamespace ( string|array $namespaces , string $path = ? ) : bool

Registra un espacio de nombres con una ruta de búsqueda, Yaf_Loader busca clases bajo este espacio de nombres en la ruta, el uno es también podría ser configurado vía application.library.directory.namespace(in application.ini);

Nota:

Yaf sigue pensando que el subrayado es un separador de carpetas.

Parámetros

namespace

un string de espacio de nombre, o un array de espacio de nombres con rutas.

path

un string de ruta, es mejor usar la ruta abosoluta aquí para la ejecución.

Valores devueltos

bool

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Loader::registerNamespace()

<?php
$loader = Yaf_Loader::getInstance();
$loader->registerNamespace("\Vendor\PHP", "/var/lib/php");
$loader->registerNamespace(array(
     "\Vendor\ASP" => "/var/lib/asp",
     "\Vendor\JSP" => "/usr/lib/vendor/",
));

$loader->autoload("\Vendor\PHP\Dummy");   //load '/var/lib/php/Dummy.php'
$loader->autoload("\Vendor\PHP\Foo_Bar"); //load '/var/lib/php/Foo/Bar.php'
$loader->autoload("\Vendor\JSP\Dummy");   //load '/usr/lib/vendor/Dummy.php'

?>


Cmabiar la ruta de la biblioteca

  • « Yaf_Loader::registerNamespace
  • Yaf_Plugin_Abstract »
  • PHP Manual
  • Yaf_Loader
  • Cmabiar la ruta de la biblioteca

Yaf_Loader::setLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::setLibraryPath — Cmabiar la ruta de la biblioteca

Descripción

public Yaf_Loader::setLibraryPath ( string $directory , bool $is_global = false ) : Yaf_Loader

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Plugin_Abstract

(Yaf >=1.0.0)

Introducción

Los complementos tienen en cuenta una extensibilidad y personalización sencillas del framework.

Los complementos son clases. La definición real de una clase variará según el componente -- se puede necesitar implementar esta interfaz, pero de hecho el complemento es en sí mismo una clase.

Un complemento podría cargarse dentro de Yaf utilizando el método Yaf_Dispatcher::registerPlugin(), después de registrarlo. Todos los métodos que implementa el complemento según esta interfaz, serán llamados a su debido tiempo.

Ejemplos

Ejemplo #1 Plugin example

<?php
   /* la clase de arranque debería estar definida bajo ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            /* register a plugin */
            $dispatcher->registerPlugin(new TestPlugin());
        }
   }

   /* la clase complemento debería estar ubicada bajo ./application/plugins/ */
   class TestPlugin extends Yaf_Plugin_Abstract {
        public function routerStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* before router
               en este hook, el usuario puede hacer alguna reescritura de la url */
            var_dump("routerStartup");
        }
        public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* router complete
               en este hook, el usuario puede hacer un control de acceso */
            var_dump("routerShutdown");
        }
        public function dispatchLoopStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("dispatchLoopStartup");
        }
        public function preDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("preDispatch");
        }
        public function postDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("postDispatch");
        }
        public function dispatchLoopShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* final hook
               en este hook el usuario puede hacer el registro o implementar el diseño */
            var_dump("dispatchLoopShutdown");
        }
   }

   Class IndexController extends Yaf_Controller_Abstract {
        public function indexAction() {
            return FALSE; //prevent rendering
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap()->run();
?>

El resultado del ejemplo sería algo similar a:

string(13) "routerStartup"
string(14) "routerShutdown"
string(19) "dispatchLoopStartup"
string(11) "preDispatch"
string(12) "postDispatch"
string(20) "dispatchLoopShutdown"

Sinopsis de la Clase

Yaf_Plugin_Abstract {
/* Métodos */
public dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
}

Tabla de contenidos

  • Yaf_Plugin_Abstract::dispatchLoopShutdown — El propósito de dispatchLoopShutdown
  • Yaf_Plugin_Abstract::dispatchLoopStartup — Enganchar antes del bucle de envío
  • Yaf_Plugin_Abstract::postDispatch — El propósito de postDispatch
  • Yaf_Plugin_Abstract::preDispatch — El propósito de preDispatch
  • Yaf_Plugin_Abstract::preResponse — El propósito de preResponse
  • Yaf_Plugin_Abstract::routerShutdown — El propósito de routerShutdown
  • Yaf_Plugin_Abstract::routerStartup — Enganche deEl propósito de routerStartup


El propósito de dispatchLoopShutdown

  • « Yaf_Plugin_Abstract
  • Yaf_Plugin_Abstract::dispatchLoopStartup »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • El propósito de dispatchLoopShutdown

Yaf_Plugin_Abstract::dispatchLoopShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopShutdown — El propósito de dispatchLoopShutdown

Descripción

public Yaf_Plugin_Abstract::dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Este es el último enganche del sistema de enganches de complementos de Yaf. Si un complemento personalizado implementa este método, será llamado después de que finalice el bucle de despachamientos.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos

Ver también

  • Yaf_Plugin_Abstract::routerStartup() - Enganche deEl propósito de routerStartup
  • Yaf_Plugin_Abstract::routerShutdown() - El propósito de routerShutdown
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - Enganchar antes del bucle de envío
  • Yaf_Plugin_Abstract::preDispatch() - El propósito de preDispatch
  • Yaf_Plugin_Abstract::postDispatch() - El propósito de postDispatch


Enganchar antes del bucle de envío

  • « Yaf_Plugin_Abstract::dispatchLoopShutdown
  • Yaf_Plugin_Abstract::postDispatch »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • Enganchar antes del bucle de envío

Yaf_Plugin_Abstract::dispatchLoopStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopStartup — Enganchar antes del bucle de envío

Descripción

public Yaf_Plugin_Abstract::dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Parámetros

request

response

Valores devueltos


El propósito de postDispatch

  • « Yaf_Plugin_Abstract::dispatchLoopStartup
  • Yaf_Plugin_Abstract::preDispatch »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • El propósito de postDispatch

Yaf_Plugin_Abstract::postDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::postDispatch — El propósito de postDispatch

Descripción

public Yaf_Plugin_Abstract::postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos


El propósito de preDispatch

  • « Yaf_Plugin_Abstract::postDispatch
  • Yaf_Plugin_Abstract::preResponse »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • El propósito de preDispatch

Yaf_Plugin_Abstract::preDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preDispatch — El propósito de preDispatch

Descripción

public Yaf_Plugin_Abstract::preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos


El propósito de preResponse

  • « Yaf_Plugin_Abstract::preDispatch
  • Yaf_Plugin_Abstract::routerShutdown »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • El propósito de preResponse

Yaf_Plugin_Abstract::preResponse

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preResponse — El propósito de preResponse

Descripción

public Yaf_Plugin_Abstract::preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos


El propósito de routerShutdown

  • « Yaf_Plugin_Abstract::preResponse
  • Yaf_Plugin_Abstract::routerStartup »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • El propósito de routerShutdown

Yaf_Plugin_Abstract::routerShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerShutdown — El propósito de routerShutdown

Descripción

public Yaf_Plugin_Abstract::routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Este enganche será provocado después de que finalice el proceso de enrutamiento. Este enganche se usa normalmente para la verificación de identificación.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Plugin_Abstract::routerShutdown()

<?php
class UserInitPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $petición, Yaf_Response_Abstract $respuesta) {
        $controlador = $petición->getControllerName();

        /**
         * El uso de accesos a controladores no es necesario para APIs
         */
        if (in_array(strtolower($controlador), array(
            'api',
        ))) {
            return TRUE;
        }

        if (Yaf_Session::getInstance()->has("login")) {
            return TRUE;
        }

        /* El uso de verificación de acceso falló, se necesita identificarse */
        $respuesta->redirect("http://sudominio.com/login/");
        return FALSE;
    }
?>

Ver también

  • Yaf_Plugin_Abstract::routerStartup() - Enganche deEl propósito de routerStartup
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - Enganchar antes del bucle de envío
  • Yaf_Plugin_Abstract::preDispatch() - El propósito de preDispatch
  • Yaf_Plugin_Abstract::postDispatch() - El propósito de postDispatch
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - El propósito de dispatchLoopShutdown


Enganche deEl propósito de routerStartup

  • « Yaf_Plugin_Abstract::routerShutdown
  • Yaf_Registry »
  • PHP Manual
  • Yaf_Plugin_Abstract
  • Enganche deEl propósito de routerStartup

Yaf_Plugin_Abstract::routerStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerStartup — Enganche deEl propósito de routerStartup

Descripción

public Yaf_Plugin_Abstract::routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Este es el primer enchanche del sistema de enganches de complementos de Yaf. Si un complemento personalizado implementa este método, será llamado antes de enrutar una petición.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

response

Valores devueltos

Ver también

  • Yaf_Plugin_Abstract::routerShutdown() - El propósito de routerShutdown
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - Enganchar antes del bucle de envío
  • Yaf_Plugin_Abstract::preDispatch() - El propósito de preDispatch
  • Yaf_Plugin_Abstract::postDispatch() - El propósito de postDispatch
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - El propósito de dispatchLoopShutdown


La clase Yaf_Registry

(Yaf >=1.0.0)

Introducción

Todos los métodos de la clase Yaf_Registry están declarados estáticos, haciéndolos universalmente accesibles. Esto proporciona la capacidad de obtener o establecer cualquier información personalizada de cualquier modo en el código como sea necesario.

Sinopsis de la Clase

Yaf_Registry {
/* Propiedades */
static $_instance ;
protected $_entries ;
/* Métodos */
private __construct ( )
public static del ( string $name ) : void
public static get ( string $name ) : mixed
public static has ( string $name ) : bool
public static set ( string $name , string $value ) : bool
}

Propiedades

_instance

_entries

Tabla de contenidos

  • Yaf_Registry::__construct — Yaf_Registry implementa «singleton»
  • Yaf_Registry::del — Elimina un elemento del registro
  • Yaf_Registry::get — Recupera un elemento del registro
  • Yaf_Registry::has — Comprueba si existe un elemento
  • Yaf_Registry::set — Añade un elemento al registro


Yaf_Registry implementa «singleton»

  • « Yaf_Registry
  • Yaf_Registry::del »
  • PHP Manual
  • Yaf_Registry
  • Yaf_Registry implementa «singleton»

Yaf_Registry::__construct

(Yaf >=1.0.0)

Yaf_Registry::__construct — Yaf_Registry implementa «singleton»

Descripción

private Yaf_Registry::__construct ( )

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Elimina un elemento del registro

  • « Yaf_Registry::__construct
  • Yaf_Registry::get »
  • PHP Manual
  • Yaf_Registry
  • Elimina un elemento del registro

Yaf_Registry::del

(Yaf >=1.0.0)

Yaf_Registry::del — Elimina un elemento del registro

Descripción

public static Yaf_Registry::del ( string $name ) : void

Elimina un elemento del registro.

Parámetros

name

Valores devueltos


Recupera un elemento del registro

  • « Yaf_Registry::del
  • Yaf_Registry::has »
  • PHP Manual
  • Yaf_Registry
  • Recupera un elemento del registro

Yaf_Registry::get

(Yaf >=1.0.0)

Yaf_Registry::get — Recupera un elemento del registro

Descripción

public static Yaf_Registry::get ( string $name ) : mixed

Recupera un elemento del registro.

Parámetros

name

Valores devueltos


Comprueba si existe un elemento

  • « Yaf_Registry::get
  • Yaf_Registry::set »
  • PHP Manual
  • Yaf_Registry
  • Comprueba si existe un elemento

Yaf_Registry::has

(Yaf >=1.0.0)

Yaf_Registry::has — Comprueba si existe un elemento

Descripción

public static Yaf_Registry::has ( string $name ) : bool

Comprueba si existe un elemento.

Parámetros

name

Valores devueltos


Añade un elemento al registro

  • « Yaf_Registry::has
  • Yaf_Request_Abstract »
  • PHP Manual
  • Yaf_Registry
  • Añade un elemento al registro

Yaf_Registry::set

(Yaf >=1.0.0)

Yaf_Registry::set — Añade un elemento al registro

Descripción

public static Yaf_Registry::set ( string $name , string $value ) : bool

Añade un elemento al registro.

Parámetros

name

value

Valores devueltos


La clase Yaf_Request_Abstract

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Request_Abstract {
/* Constantes */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* Propiedades */
public $module ;
public $controller ;
public $action ;
public $method ;
protected $params ;
protected $language ;
protected $_exception ;
protected $_base_uri ;
protected $uri ;
protected $dispatched ;
protected $routed ;
/* Métodos */
public clearParams ( ) : bool
public getActionName ( ) : void
public getBaseUri ( ) : void
public getControllerName ( ) : void
public getEnv ( string $name , string $default = ? ) : void
public getException ( ) : void
public getLanguage ( ) : void
public getMethod ( ) : string
public getModuleName ( ) : void
public getParam ( string $name , string $default = ? ) : mixed
public getParams ( ) : array
public getRequestUri ( ) : void
public getServer ( string $name , string $default = ? ) : void
public isCli ( ) : bool
public isDispatched ( ) : bool
public isGet ( ) : bool
public isHead ( ) : bool
public isOptions ( ) : bool
public isPost ( ) : bool
public isPut ( ) : bool
public isRouted ( ) : bool
public isXmlHttpRequest ( ) : bool
public setActionName ( string $action , bool $format_name = true ) : void
public setBaseUri ( string $uir ) : bool
public setControllerName ( string $controller ) : void
public setDispatched ( ) : void
public setModuleName ( string $module ) : void
public setParam ( string $name , string $value = ? ) : void
public setRequestUri ( string $uir ) : void
public setRouted ( string $flag = ? ) : void
}

Propiedades

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Constantes predefinidas

Yaf_Request_Abstract::SCHEME_HTTP

Yaf_Request_Abstract::SCHEME_HTTPS

Tabla de contenidos

  • Yaf_Request_Abstract::clearParams — Eliminar todos los parámetros
  • Yaf_Request_Abstract::getActionName — El propósito de getActionName
  • Yaf_Request_Abstract::getBaseUri — El propósito de getBaseUri
  • Yaf_Request_Abstract::getControllerName — El propósito de getControllerName
  • Yaf_Request_Abstract::getEnv — Recupera la variable ENV
  • Yaf_Request_Abstract::getException — El propósito de getException
  • Yaf_Request_Abstract::getLanguage — Recupera el lenguaje preferido del cliente
  • Yaf_Request_Abstract::getMethod — Recupera el método de solicitud
  • Yaf_Request_Abstract::getModuleName — El propósito de getModuleName
  • Yaf_Request_Abstract::getParam — Recupera el parámetro de llamada
  • Yaf_Request_Abstract::getParams — Recupera todos los parámetros de llamada
  • Yaf_Request_Abstract::getRequestUri — El propósito de getRequestUri
  • Yaf_Request_Abstract::getServer — Recupera la variable SERVER
  • Yaf_Request_Abstract::isCli — Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isDispatched — Determina si la solicitud es enviada
  • Yaf_Request_Abstract::isGet — Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isHead — Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isOptions — Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isPost — Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut — Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isRouted — Determina si la solicitud ha sido enrutada
  • Yaf_Request_Abstract::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX
  • Yaf_Request_Abstract::setActionName — Establece el nombre de la acción
  • Yaf_Request_Abstract::setBaseUri — Establecer el URI base
  • Yaf_Request_Abstract::setControllerName — El propósito de setControllerName
  • Yaf_Request_Abstract::setDispatched — El propósito de setDispatched
  • Yaf_Request_Abstract::setModuleName — El propósito de setModuleName
  • Yaf_Request_Abstract::setParam — El propósito de setParam
  • Yaf_Request_Abstract::setRequestUri — El propósito de setRequestUri
  • Yaf_Request_Abstract::setRouted — El propósito de setRouted


Eliminar todos los parámetros

  • « Yaf_Request_Abstract
  • Yaf_Request_Abstract::getActionName »
  • PHP Manual
  • Yaf_Request_Abstract
  • Eliminar todos los parámetros

Yaf_Request_Abstract::clearParams

(No hay información de versión disponible, podría estar únicamente en Git)

Yaf_Request_Abstract::clearParams — Eliminar todos los parámetros

Descripción

public Yaf_Request_Abstract::clearParams ( ) : bool

Eliminar todos los parámetros establecidos por el router, o Yaf_Request_Abstract::setParam()

Parámetros

Esta función no tiene parámetros.

Valores devueltos

bool

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


El propósito de getActionName

  • « Yaf_Request_Abstract::clearParams
  • Yaf_Request_Abstract::getBaseUri »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getActionName

Yaf_Request_Abstract::getActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getActionName — El propósito de getActionName

Descripción

public Yaf_Request_Abstract::getActionName ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getBaseUri

  • « Yaf_Request_Abstract::getActionName
  • Yaf_Request_Abstract::getControllerName »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getBaseUri

Yaf_Request_Abstract::getBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getBaseUri — El propósito de getBaseUri

Descripción

public Yaf_Request_Abstract::getBaseUri ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getControllerName

  • « Yaf_Request_Abstract::getBaseUri
  • Yaf_Request_Abstract::getEnv »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getControllerName

Yaf_Request_Abstract::getControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getControllerName — El propósito de getControllerName

Descripción

public Yaf_Request_Abstract::getControllerName ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera la variable ENV

  • « Yaf_Request_Abstract::getControllerName
  • Yaf_Request_Abstract::getException »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera la variable ENV

Yaf_Request_Abstract::getEnv

(Yaf >=1.0.0)

Yaf_Request_Abstract::getEnv — Recupera la variable ENV

Descripción

public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void

Recupera la variable ENV.

Parámetros

name

El nombre de la varaible.

default

Si se proporciona este parámetro, se devolverá si la variable no puede ser encontrada.

Valores devueltos

Devuelve un string

Ver también

  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


El propósito de getException

  • « Yaf_Request_Abstract::getEnv
  • Yaf_Request_Abstract::getLanguage »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getException

Yaf_Request_Abstract::getException

(Yaf >=1.0.0)

Yaf_Request_Abstract::getException — El propósito de getException

Descripción

public Yaf_Request_Abstract::getException ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera el lenguaje preferido del cliente

  • « Yaf_Request_Abstract::getException
  • Yaf_Request_Abstract::getMethod »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera el lenguaje preferido del cliente

Yaf_Request_Abstract::getLanguage

(Yaf >=1.0.0)

Yaf_Request_Abstract::getLanguage — Recupera el lenguaje preferido del cliente

Descripción

public Yaf_Request_Abstract::getLanguage ( ) : void

Recuperar el lenguaje preferido del cliente

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string


Recupera el método de solicitud

  • « Yaf_Request_Abstract::getLanguage
  • Yaf_Request_Abstract::getModuleName »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera el método de solicitud

Yaf_Request_Abstract::getMethod

(Yaf >=1.0.0)

Yaf_Request_Abstract::getMethod — Recupera el método de solicitud

Descripción

public Yaf_Request_Abstract::getMethod ( ) : string

Recuperar el método de solicitud

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string, como "POST", "GET", etc.

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


El propósito de getModuleName

  • « Yaf_Request_Abstract::getMethod
  • Yaf_Request_Abstract::getParam »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getModuleName

Yaf_Request_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getModuleName — El propósito de getModuleName

Descripción

public Yaf_Request_Abstract::getModuleName ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera el parámetro de llamada

  • « Yaf_Request_Abstract::getModuleName
  • Yaf_Request_Abstract::getParams »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera el parámetro de llamada

Yaf_Request_Abstract::getParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParam — Recupera el parámetro de llamada

Descripción

public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : mixed

Recuperar el parámetro de llamada

Parámetros

name

default

Valores devueltos

Ver también

  • Yaf_Request_Abstract::setParam() - El propósito de setParam


Recupera todos los parámetros de llamada

  • « Yaf_Request_Abstract::getParam
  • Yaf_Request_Abstract::getRequestUri »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera todos los parámetros de llamada

Yaf_Request_Abstract::getParams

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParams — Recupera todos los parámetros de llamada

Descripción

public Yaf_Request_Abstract::getParams ( ) : array

Recuperar todos los parámetros de llamada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Request_Abstract::setParam() - El propósito de setParam


El propósito de getRequestUri

  • « Yaf_Request_Abstract::getParams
  • Yaf_Request_Abstract::getServer »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de getRequestUri

Yaf_Request_Abstract::getRequestUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getRequestUri — El propósito de getRequestUri

Descripción

public Yaf_Request_Abstract::getRequestUri ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera la variable SERVER

  • « Yaf_Request_Abstract::getRequestUri
  • Yaf_Request_Abstract::isCli »
  • PHP Manual
  • Yaf_Request_Abstract
  • Recupera la variable SERVER

Yaf_Request_Abstract::getServer

(Yaf >=1.0.0)

Yaf_Request_Abstract::getServer — Recupera la variable SERVER

Descripción

public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void

Recupera la variable SERVER.

Parámetros

name

El nombre de la variable

default

Si se proporciona este parámetro, se devolverá si la variable no puede ser encontrada.

Valores devueltos

Ver también

  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada
  • Yaf_Request_Abstract::getEnv() - Recupera la variable ENV


Determina si la solicitud es una solicitud CLI

  • « Yaf_Request_Abstract::getServer
  • Yaf_Request_Abstract::isDispatched »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud CLI

Yaf_Request_Abstract::isCli

(Yaf >=1.0.0)

Yaf_Request_Abstract::isCli — Determina si la solicitud es una solicitud CLI

Descripción

public Yaf_Request_Abstract::isCli ( ) : bool

Determinar si la solicitud es una solicitud CLI

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


Determina si la solicitud es enviada

  • « Yaf_Request_Abstract::isCli
  • Yaf_Request_Abstract::isGet »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es enviada

Yaf_Request_Abstract::isDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::isDispatched — Determina si la solicitud es enviada

Descripción

public Yaf_Request_Abstract::isDispatched ( ) : bool

Determinar si la solicitud es enviada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Dispatcher::dispatch() - Despachar una petición


Determina si la solicitud es una solicitud GET

  • « Yaf_Request_Abstract::isDispatched
  • Yaf_Request_Abstract::isHead »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud GET

Yaf_Request_Abstract::isGet

(Yaf >=1.0.0)

Yaf_Request_Abstract::isGet — Determina si la solicitud es una solicitud GET

Descripción

public Yaf_Request_Abstract::isGet ( ) : bool

Determinar si la solicitud es una solicitud GET

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


Determina si la solicitud es una solicitud HEAD

  • « Yaf_Request_Abstract::isGet
  • Yaf_Request_Abstract::isOptions »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud HEAD

Yaf_Request_Abstract::isHead

(Yaf >=1.0.0)

Yaf_Request_Abstract::isHead — Determina si la solicitud es una solicitud HEAD

Descripción

public Yaf_Request_Abstract::isHead ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


Determina si la solicitud es una solicitud de OPCIONES

  • « Yaf_Request_Abstract::isHead
  • Yaf_Request_Abstract::isPost »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud de OPCIONES

Yaf_Request_Abstract::isOptions

(Yaf >=1.0.0)

Yaf_Request_Abstract::isOptions — Determina si la solicitud es una solicitud de OPCIONES

Descripción

public Yaf_Request_Abstract::isOptions ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean


Determina si la solicitud es una solicitud POST

  • « Yaf_Request_Abstract::isOptions
  • Yaf_Request_Abstract::isPut »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud POST

Yaf_Request_Abstract::isPost

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPost — Determina si la solicitud es una solicitud POST

Descripción

public Yaf_Request_Abstract::isPost ( ) : bool

Determinar si la solicitud es una solicitud POST

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


Determina si la solicitud es una solicitud PUT

  • « Yaf_Request_Abstract::isPost
  • Yaf_Request_Abstract::isRouted »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud PUT

Yaf_Request_Abstract::isPut

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPut — Determina si la solicitud es una solicitud PUT

Descripción

public Yaf_Request_Abstract::isPut ( ) : bool

Determinar si la solicitud es una solicitud PUT

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX


Determina si la solicitud ha sido enrutada

  • « Yaf_Request_Abstract::isPut
  • Yaf_Request_Abstract::isXmlHttpRequest »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud ha sido enrutada

Yaf_Request_Abstract::isRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::isRouted — Determina si la solicitud ha sido enrutada

Descripción

public Yaf_Request_Abstract::isRouted ( ) : bool

Determinar si la solicitud ha sido enrutada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean


Determina si la solicitud es una solicitud AJAX

  • « Yaf_Request_Abstract::isRouted
  • Yaf_Request_Abstract::setActionName »
  • PHP Manual
  • Yaf_Request_Abstract
  • Determina si la solicitud es una solicitud AJAX

Yaf_Request_Abstract::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Abstract::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX

Descripción

public Yaf_Request_Abstract::isXmlHttpRequest ( ) : bool

Determinar si la solicitud es una solicitud AJAX

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ver también

  • Yaf_Request_Abstract::isHead() - Determina si la solicitud es una solicitud HEAD
  • Yaf_Request_Abstract::isCli() - Determina si la solicitud es una solicitud CLI
  • Yaf_Request_Abstract::isPost() - Determina si la solicitud es una solicitud POST
  • Yaf_Request_Abstract::isPut() - Determina si la solicitud es una solicitud PUT
  • Yaf_Request_Abstract::isOptions() - Determina si la solicitud es una solicitud de OPCIONES
  • Yaf_Request_Abstract::isGet() - Determina si la solicitud es una solicitud GET


Establece el nombre de la acción

  • « Yaf_Request_Abstract::isXmlHttpRequest
  • Yaf_Request_Abstract::setBaseUri »
  • PHP Manual
  • Yaf_Request_Abstract
  • Establece el nombre de la acción

Yaf_Request_Abstract::setActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setActionName — Establece el nombre de la acción

Descripción

public Yaf_Request_Abstract::setActionName ( string $action , bool $format_name = true ) : void

Establecer el nombre de la acción a solicitar, esto es usualmente usado por el enrutador personalizado para establecer el nombre del controlador de resultado de ruta.

Parámetros

action

nombre de la acción como string, debe ser en minúsculas, como "index" o "foo_bar"

format_name

esto se introduce en Yaf 3.2.0, por omisión Yaf formateará el nombre en minúsculas, si este se establece a false , Yaf pondrá el nombre original a la petición.

Valores devueltos


Establecer el URI base

  • « Yaf_Request_Abstract::setActionName
  • Yaf_Request_Abstract::setControllerName »
  • PHP Manual
  • Yaf_Request_Abstract
  • Establecer el URI base

Yaf_Request_Abstract::setBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::setBaseUri — Establecer el URI base

Descripción

public Yaf_Request_Abstract::setBaseUri ( string $uir ) : bool

Establece el URI base. El URI base se usa al enrutar. En la fase de enrutamiento, el URI solicitado se usa para enrutar una petición, mientras que es URI base para saltar la parte anterior(URI base) del URI solicitado. Esto es, si viene una petición con un URI solicitado como a/b/c, si se establece el URI base a "a/b", se usará solamente "/c" en la fase de enrutamiento.

Nota:

Generalmente, no es necesario establecer esto, Yaf lo determinará automáticamente.

Parámetros

uir

El URI base

Valores devueltos

booleano


El propósito de setControllerName

  • « Yaf_Request_Abstract::setBaseUri
  • Yaf_Request_Abstract::setDispatched »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setControllerName

Yaf_Request_Abstract::setControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setControllerName — El propósito de setControllerName

Descripción

public Yaf_Request_Abstract::setControllerName ( string $controller ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

controller

Valores devueltos


El propósito de setDispatched

  • « Yaf_Request_Abstract::setControllerName
  • Yaf_Request_Abstract::setModuleName »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setDispatched

Yaf_Request_Abstract::setDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::setDispatched — El propósito de setDispatched

Descripción

public Yaf_Request_Abstract::setDispatched ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de setModuleName

  • « Yaf_Request_Abstract::setDispatched
  • Yaf_Request_Abstract::setParam »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setModuleName

Yaf_Request_Abstract::setModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setModuleName — El propósito de setModuleName

Descripción

public Yaf_Request_Abstract::setModuleName ( string $module ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

module

Valores devueltos


El propósito de setParam

  • « Yaf_Request_Abstract::setModuleName
  • Yaf_Request_Abstract::setRequestUri »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setParam

Yaf_Request_Abstract::setParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::setParam — El propósito de setParam

Descripción

public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


El propósito de setRequestUri

  • « Yaf_Request_Abstract::setParam
  • Yaf_Request_Abstract::setRouted »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setRequestUri

Yaf_Request_Abstract::setRequestUri

(Yaf >=2.1.0)

Yaf_Request_Abstract::setRequestUri — El propósito de setRequestUri

Descripción

public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

uir

Valores devueltos


El propósito de setRouted

  • « Yaf_Request_Abstract::setRequestUri
  • Yaf_Request_Http »
  • PHP Manual
  • Yaf_Request_Abstract
  • El propósito de setRouted

Yaf_Request_Abstract::setRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::setRouted — El propósito de setRouted

Descripción

public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

flag

Valores devueltos


La clase Yaf_Request_Http

(Yaf >=1.0.0)

Introducción

Cualquier petición de un cliente se inicializa como un Yaf_Request_Http. Se puede obtener la información de la petición, como la consulta de URI y los parámetros de POST, mediante los métodos de esta clase.

Nota:

Por seguridad, $_GET/$_POST son de solo lectura en Yaf, lo que significa que si se establece un valor en esta variables globales, este no se podrá obtener desde Yaf_Request_Http::getQuery() o Yaf_Request_Http::getPost().

Aunque si fuera necesaria tal característica, como en las pruebas unitarias, Yaf se puede construir con --enable-yaf-debug, la cual permite a Yaf leer el valor establecido por el usuario mediante script.

En tal caso, Yaf lanzará un aviso E_STRICT para recordarlo: Strict Standards: you are running yaf in debug mode

Sinopsis de la Clase

Yaf_Request_Http extends Yaf_Request_Abstract {
/* Propiedades */
/* Métodos */
public __construct ( string $request_uri = ? , string $base_uri = ? )
public get ( string $name , string $default = ? ) : mixed
public getCookie ( string $name , string $default = ? ) : mixed
public getFiles ( ) : void
public getPost ( string $name , string $default = ? ) : mixed
public getQuery ( string $name , string $default = ? ) : mixed
public getRaw ( ) : mixed
public getRequest ( ) : void
public isXmlHttpRequest ( ) : bool
/* Métodos heredados */
public Yaf_Request_Abstract::clearParams ( ) : bool
public Yaf_Request_Abstract::getActionName ( ) : void
public Yaf_Request_Abstract::getBaseUri ( ) : void
public Yaf_Request_Abstract::getControllerName ( ) : void
public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getException ( ) : void
public Yaf_Request_Abstract::getLanguage ( ) : void
public Yaf_Request_Abstract::getMethod ( ) : string
public Yaf_Request_Abstract::getModuleName ( ) : void
public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : mixed
public Yaf_Request_Abstract::getParams ( ) : array
public Yaf_Request_Abstract::getRequestUri ( ) : void
public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::isCli ( ) : bool
public Yaf_Request_Abstract::isDispatched ( ) : bool
public Yaf_Request_Abstract::isGet ( ) : bool
public Yaf_Request_Abstract::isHead ( ) : bool
public Yaf_Request_Abstract::isOptions ( ) : bool
public Yaf_Request_Abstract::isPost ( ) : bool
public Yaf_Request_Abstract::isPut ( ) : bool
public Yaf_Request_Abstract::isRouted ( ) : bool
public Yaf_Request_Abstract::isXmlHttpRequest ( ) : bool
public Yaf_Request_Abstract::setActionName ( string $action , bool $format_name = true ) : void
public Yaf_Request_Abstract::setBaseUri ( string $uir ) : bool
public Yaf_Request_Abstract::setControllerName ( string $controller ) : void
public Yaf_Request_Abstract::setDispatched ( ) : void
public Yaf_Request_Abstract::setModuleName ( string $module ) : void
public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void
public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void
public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void
}

Propiedades

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Tabla de contenidos

  • Yaf_Request_Http::__construct — Constructor de Yaf_Request_Http
  • Yaf_Request_Http::get — Recupera una variable del cliente
  • Yaf_Request_Http::getCookie — Recupera una varible de Cookie
  • Yaf_Request_Http::getFiles — El propósito de getFiles
  • Yaf_Request_Http::getPost — Recupera una variable de POST
  • Yaf_Request_Http::getQuery — Obtiene un parámetro de una consulta
  • Yaf_Request_Http::getRaw — Recupera el cuerpo de la solicitud de raw
  • Yaf_Request_Http::getRequest — El propósito de getRequest
  • Yaf_Request_Http::isXmlHttpRequest — Determina si la solicitud es una solicitud de Ajax


Constructor de Yaf_Request_Http

  • « Yaf_Request_Http
  • Yaf_Request_Http::get »
  • PHP Manual
  • Yaf_Request_Http
  • Constructor de Yaf_Request_Http

Yaf_Request_Http::__construct

(Yaf >=1.0.0)

Yaf_Request_Http::__construct — Constructor de Yaf_Request_Http

Descripción

public Yaf_Request_Http::__construct ( string $request_uri = ? , string $base_uri = ? )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera una variable del cliente

  • « Yaf_Request_Http::__construct
  • Yaf_Request_Http::getCookie »
  • PHP Manual
  • Yaf_Request_Http
  • Recupera una variable del cliente

Yaf_Request_Http::get

(Yaf >=1.0.0)

Yaf_Request_Http::get — Recupera una variable del cliente

Descripción

public Yaf_Request_Http::get ( string $name , string $default = ? ) : mixed

Recupera una variable del cliente. Este método buscará el nombre dado por name en los parámetros de solicitud, y si no se encuetra el nombre, buscará en POST, GET, Cookie, Server

Parámetros

name

El nombre de la variable.

default

Si se proporciona este parámetro, será devuelto si no se pudo encontrar la variable.

Valores devueltos

Ver también

  • Yaf_Request_Http::getQuery() - Obtiene un parámetro de una consulta
  • Yaf_Request_Http::getPost() - Recupera una variable de POST
  • Yaf_Request_Http::getCookie() - Recupera una varible de Cookie
  • Yaf_Request_Http::getRaw() - Recupera el cuerpo de la solicitud de raw
  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


Recupera una varible de Cookie

  • « Yaf_Request_Http::get
  • Yaf_Request_Http::getFiles »
  • PHP Manual
  • Yaf_Request_Http
  • Recupera una varible de Cookie

Yaf_Request_Http::getCookie

(Yaf >=1.0.0)

Yaf_Request_Http::getCookie — Recupera una varible de Cookie

Descripción

public Yaf_Request_Http::getCookie ( string $name , string $default = ? ) : mixed

Recupera una varible de Cookie.

Parámetros

name

El nombre de la cookie.

default

Si se proporciona este parámetro, será devuelto si no se pudo encontrar la cookie.

Valores devueltos

Ver también

  • Yaf_Request_Http::get() - Recupera una variable del cliente
  • Yaf_Request_Http::getQuery() - Obtiene un parámetro de una consulta
  • Yaf_Request_Http::getPost() - Recupera una variable de POST
  • Yaf_Request_Http::getRaw() - Recupera el cuerpo de la solicitud de raw
  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


El propósito de getFiles

  • « Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getPost »
  • PHP Manual
  • Yaf_Request_Http
  • El propósito de getFiles

Yaf_Request_Http::getFiles

(Yaf >=1.0.0)

Yaf_Request_Http::getFiles — El propósito de getFiles

Descripción

public Yaf_Request_Http::getFiles ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera una variable de POST

  • « Yaf_Request_Http::getFiles
  • Yaf_Request_Http::getQuery »
  • PHP Manual
  • Yaf_Request_Http
  • Recupera una variable de POST

Yaf_Request_Http::getPost

(Yaf >=1.0.0)

Yaf_Request_Http::getPost — Recupera una variable de POST

Descripción

public Yaf_Request_Http::getPost ( string $name , string $default = ? ) : mixed

Recupera una variable de POST.

Parámetros

name

El nombre de la variable.

default

Si se proporciona este parámetro, será devuelto si no se pudo encontrar la variable.

Valores devueltos

Ver también

  • Yaf_Request_Http::get() - Recupera una variable del cliente
  • Yaf_Request_Http::getQuery() - Obtiene un parámetro de una consulta
  • Yaf_Request_Http::getCookie() - Recupera una varible de Cookie
  • Yaf_Request_Http::getRaw() - Recupera el cuerpo de la solicitud de raw
  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


Obtiene un parámetro de una consulta

  • « Yaf_Request_Http::getPost
  • Yaf_Request_Http::getRaw »
  • PHP Manual
  • Yaf_Request_Http
  • Obtiene un parámetro de una consulta

Yaf_Request_Http::getQuery

(Yaf >=1.0.0)

Yaf_Request_Http::getQuery — Obtiene un parámetro de una consulta

Descripción

public Yaf_Request_Http::getQuery ( string $name , string $default = ? ) : mixed

Recupera una variable de GET.

Parámetros

name

El nombre de la variable.

default

Si se proporciona este parámetro, será devuelto si no se pudo encontrar la variable.

Valores devueltos

Ver también

  • Yaf_Request_Http::get() - Recupera una variable del cliente
  • Yaf_Request_Http::getPost() - Recupera una variable de POST
  • Yaf_Request_Http::getCookie() - Recupera una varible de Cookie
  • Yaf_Request_Http::getRaw() - Recupera el cuerpo de la solicitud de raw
  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


Recupera el cuerpo de la solicitud de raw

  • « Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getRequest »
  • PHP Manual
  • Yaf_Request_Http
  • Recupera el cuerpo de la solicitud de raw

Yaf_Request_Http::getRaw

(Yaf >=3.0.7)

Yaf_Request_Http::getRaw — Recupera el cuerpo de la solicitud de raw

Descripción

public Yaf_Request_Http::getRaw ( ) : mixed

Recupera el cuerpo de la solicitud de raw

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string en caso de éxito, FALSE en caso de error.

Ver también

  • Yaf_Request_Http::get() - Recupera una variable del cliente
  • Yaf_Request_Http::getPost() - Recupera una variable de POST
  • Yaf_Request_Http::getCookie() - Recupera una varible de Cookie
  • Yaf_Request_Http::getQuery() - Obtiene un parámetro de una consulta
  • Yaf_Request_Abstract::getServer() - Recupera la variable SERVER
  • Yaf_Request_Abstract::getParam() - Recupera el parámetro de llamada


El propósito de getRequest

  • « Yaf_Request_Http::getRaw
  • Yaf_Request_Http::isXmlHttpRequest »
  • PHP Manual
  • Yaf_Request_Http
  • El propósito de getRequest

Yaf_Request_Http::getRequest

(Yaf >=1.0.0)

Yaf_Request_Http::getRequest — El propósito de getRequest

Descripción

public Yaf_Request_Http::getRequest ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Determina si la solicitud es una solicitud de Ajax

  • « Yaf_Request_Http::getRequest
  • Yaf_Request_Simple »
  • PHP Manual
  • Yaf_Request_Http
  • Determina si la solicitud es una solicitud de Ajax

Yaf_Request_Http::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Http::isXmlHttpRequest — Determina si la solicitud es una solicitud de Ajax

Descripción

public Yaf_Request_Http::isXmlHttpRequest ( ) : bool

Comprueba si la petición es una consulta Ajax.

Nota:

Este método depende de la cabecera de petición: HTTP_X_REQUESTED_WITH, algunas bibliotecas de Javascript no establecen esta cabecera mientras se realiza una petición Ajax.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean


La clase Yaf_Request_Simple

(Yaf >=1.0.0)

Introducción

Yaf_Request_Simple se utiliza en particular para propósitos de pruebas. Es decir, simula alguna petición especial bajo el modo CLI.

Sinopsis de la Clase

Yaf_Request_Simple extends Yaf_Request_Abstract {
/* Constantes */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* Propiedades */
/* Métodos */
public __construct ( string $method = ? , string $module = ? , string $controller = ? , string $action = ? , array $params = ? )
public get ( ) : void
public getCookie ( ) : void
public getFiles ( ) : void
public getPost ( ) : void
public getQuery ( ) : void
public getRequest ( ) : void
public isXmlHttpRequest ( ) : void
/* Métodos heredados */
public Yaf_Request_Abstract::clearParams ( ) : bool
public Yaf_Request_Abstract::getActionName ( ) : void
public Yaf_Request_Abstract::getBaseUri ( ) : void
public Yaf_Request_Abstract::getControllerName ( ) : void
public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getException ( ) : void
public Yaf_Request_Abstract::getLanguage ( ) : void
public Yaf_Request_Abstract::getMethod ( ) : string
public Yaf_Request_Abstract::getModuleName ( ) : void
public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : mixed
public Yaf_Request_Abstract::getParams ( ) : array
public Yaf_Request_Abstract::getRequestUri ( ) : void
public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::isCli ( ) : bool
public Yaf_Request_Abstract::isDispatched ( ) : bool
public Yaf_Request_Abstract::isGet ( ) : bool
public Yaf_Request_Abstract::isHead ( ) : bool
public Yaf_Request_Abstract::isOptions ( ) : bool
public Yaf_Request_Abstract::isPost ( ) : bool
public Yaf_Request_Abstract::isPut ( ) : bool
public Yaf_Request_Abstract::isRouted ( ) : bool
public Yaf_Request_Abstract::isXmlHttpRequest ( ) : bool
public Yaf_Request_Abstract::setActionName ( string $action , bool $format_name = true ) : void
public Yaf_Request_Abstract::setBaseUri ( string $uir ) : bool
public Yaf_Request_Abstract::setControllerName ( string $controller ) : void
public Yaf_Request_Abstract::setDispatched ( ) : void
public Yaf_Request_Abstract::setModuleName ( string $module ) : void
public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void
public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void
public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void
}

Propiedades

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Constantes predefinidas

Yaf_Request_Simple::SCHEME_HTTP

Yaf_Request_Simple::SCHEME_HTTPS

Tabla de contenidos

  • Yaf_Request_Simple::__construct — Constructor de Yaf_Request_Simple
  • Yaf_Request_Simple::get — El propósito de get
  • Yaf_Request_Simple::getCookie — El propósito de getCookie
  • Yaf_Request_Simple::getFiles — El propósito de getFiles
  • Yaf_Request_Simple::getPost — El propósito de getPost
  • Yaf_Request_Simple::getQuery — El propósito de getQuery
  • Yaf_Request_Simple::getRequest — El propósito de getRequest
  • Yaf_Request_Simple::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX


Constructor de Yaf_Request_Simple

  • « Yaf_Request_Simple
  • Yaf_Request_Simple::get »
  • PHP Manual
  • Yaf_Request_Simple
  • Constructor de Yaf_Request_Simple

Yaf_Request_Simple::__construct

(Yaf >=1.0.0)

Yaf_Request_Simple::__construct — Constructor de Yaf_Request_Simple

Descripción

public Yaf_Request_Simple::__construct ( string $method = ? , string $module = ? , string $controller = ? , string $action = ? , array $params = ? )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de get

  • « Yaf_Request_Simple::__construct
  • Yaf_Request_Simple::getCookie »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de get

Yaf_Request_Simple::get

(Yaf >=1.0.0)

Yaf_Request_Simple::get — El propósito de get

Descripción

public Yaf_Request_Simple::get ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getCookie

  • « Yaf_Request_Simple::get
  • Yaf_Request_Simple::getFiles »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de getCookie

Yaf_Request_Simple::getCookie

(Yaf >=1.0.0)

Yaf_Request_Simple::getCookie — El propósito de getCookie

Descripción

public Yaf_Request_Simple::getCookie ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getFiles

  • « Yaf_Request_Simple::getCookie
  • Yaf_Request_Simple::getPost »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de getFiles

Yaf_Request_Simple::getFiles

(Yaf >=1.0.0)

Yaf_Request_Simple::getFiles — El propósito de getFiles

Descripción

public Yaf_Request_Simple::getFiles ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getPost

  • « Yaf_Request_Simple::getFiles
  • Yaf_Request_Simple::getQuery »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de getPost

Yaf_Request_Simple::getPost

(Yaf >=1.0.0)

Yaf_Request_Simple::getPost — El propósito de getPost

Descripción

public Yaf_Request_Simple::getPost ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getQuery

  • « Yaf_Request_Simple::getPost
  • Yaf_Request_Simple::getRequest »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de getQuery

Yaf_Request_Simple::getQuery

(Yaf >=1.0.0)

Yaf_Request_Simple::getQuery — El propósito de getQuery

Descripción

public Yaf_Request_Simple::getQuery ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getRequest

  • « Yaf_Request_Simple::getQuery
  • Yaf_Request_Simple::isXmlHttpRequest »
  • PHP Manual
  • Yaf_Request_Simple
  • El propósito de getRequest

Yaf_Request_Simple::getRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::getRequest — El propósito de getRequest

Descripción

public Yaf_Request_Simple::getRequest ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Determina si la solicitud es una solicitud AJAX

  • « Yaf_Request_Simple::getRequest
  • Yaf_Response_Abstract »
  • PHP Manual
  • Yaf_Request_Simple
  • Determina si la solicitud es una solicitud AJAX

Yaf_Request_Simple::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::isXmlHttpRequest — Determina si la solicitud es una solicitud AJAX

Descripción

public Yaf_Request_Simple::isXmlHttpRequest ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Siempre devuelve false para Yaf_Request_Simple

Ver también

  • Yaf_Request_Abstract::isXmlHTTPRequest() - Determina si la solicitud es una solicitud AJAX
  • Yaf_Request_Http::isXmlHTTPRequest() - Determina si la solicitud es una solicitud de Ajax


La clase Yaf_Response_Abstract

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Response_Abstract {
/* Constants */
const string DEFAULT_BODY = "content" ;
/* Propiedades */
protected $_header ;
protected $_body ;
protected $_sendheader ;
/* Métodos */
public appendBody ( string $content , string $key = ? ) : bool
public clearBody ( string $key = ? ) : bool
public clearHeaders ( ) : void
public __construct ( )
public __destruct ( ) : void
public getBody ( string $key = ? ) : mixed
public getHeader ( ) : void
public prependBody ( string $content , string $key = ? ) : bool
public response ( ) : void
protected setAllHeaders ( ) : void
public setBody ( string $content , string $key = ? ) : bool
public setHeader ( string $name , string $value , bool $replace = ? ) : bool
public setRedirect ( ) : void
private __toString ( ) : string
}

Propiedades

_header

_body

_sendheader

Tabla de contenidos

  • Yaf_Response_Abstract::appendBody — Añadir contenido al cuerpo de respuesta
  • Yaf_Response_Abstract::clearBody — Descarta todo el cuerpo de respuesta existente
  • Yaf_Response_Abstract::clearHeaders — Descarta todas las cabeceras establecidas
  • Yaf_Response_Abstract::__construct — El propósito de __construct
  • Yaf_Response_Abstract::__destruct — El propósito de __destruct
  • Yaf_Response_Abstract::getBody — Recupera un contenido existente
  • Yaf_Response_Abstract::getHeader — El propósito de getHeader
  • Yaf_Response_Abstract::prependBody — El propósito de prependBody
  • Yaf_Response_Abstract::response — Envía una respuesta
  • Yaf_Response_Abstract::setAllHeaders — El propósito de setAllHeaders
  • Yaf_Response_Abstract::setBody — Establece el contenido de una respuesta
  • Yaf_Response_Abstract::setHeader — Establece cabecera de respuesta
  • Yaf_Response_Abstract::setRedirect — El propósito de setRedirect
  • Yaf_Response_Abstract::__toString — Recupera todo el cuerpo como un string


Añadir contenido al cuerpo de respuesta

  • « Yaf_Response_Abstract
  • Yaf_Response_Abstract::clearBody »
  • PHP Manual
  • Yaf_Response_Abstract
  • Añadir contenido al cuerpo de respuesta

Yaf_Response_Abstract::appendBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::appendBody — Añadir contenido al cuerpo de respuesta

Descripción

public Yaf_Response_Abstract::appendBody ( string $content , string $key = ? ) : bool

Añade contenido a un bloque de contenido existente.

Parámetros

body

La cadena con el contenido.

key

La clave del contenido, se puede establecer un contenido con una clave, y si no se especifica, se usará Yaf_Response_Abstract::DEFAULT_BODY.

Nota:

Este parámetro se introdujo a partir de la versión 2.2.0

Valores devueltos

Un valor de tipo booleano.

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Response_Abstract::appendBody()

<?php
$respuesta = new Yaf_Response_Http();

$respuesta->setBody("Hola")->prependBody(" Mundo");

echo $respuesta;
?>

El resultado del ejemplo sería algo similar a:

Hola Mundo

Ver también

  • Yaf_Config_Ini

Ver también

  • Yaf_Response_Abstract::getBody() - Recupera un contenido existente
  • Yaf_Response_Abstract::setBody() - Establece el contenido de una respuesta
  • Yaf_Response_Abstract::prependBody() - El propósito de prependBody
  • Yaf_Response_Abstract::clearBody() - Descarta todo el cuerpo de respuesta existente


Descarta todo el cuerpo de respuesta existente

  • « Yaf_Response_Abstract::appendBody
  • Yaf_Response_Abstract::clearHeaders »
  • PHP Manual
  • Yaf_Response_Abstract
  • Descarta todo el cuerpo de respuesta existente

Yaf_Response_Abstract::clearBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearBody — Descarta todo el cuerpo de respuesta existente

Descripción

public Yaf_Response_Abstract::clearBody ( string $key = ? ) : bool

Limpia el contenido existente.

Parámetros

key

La clave del contenido, si no se especifica, todo el contenido será limpiado.

Nota:

Este parámetro se introdujo a partir de la versión 2.2.0

Valores devueltos

Ver también

  • Yaf_Response_Abstract::setBody() - Establece el contenido de una respuesta
  • Yaf_Response_Abstract::appendBody() - Añadir contenido al cuerpo de respuesta
  • Yaf_Response_Abstract::prependBody() - El propósito de prependBody
  • Yaf_Response_Abstract::getBody() - Recupera un contenido existente


Descarta todas las cabeceras establecidas

  • « Yaf_Response_Abstract::clearBody
  • Yaf_Response_Abstract::__construct »
  • PHP Manual
  • Yaf_Response_Abstract
  • Descarta todas las cabeceras establecidas

Yaf_Response_Abstract::clearHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearHeaders — Descarta todas las cabeceras establecidas

Descripción

public Yaf_Response_Abstract::clearHeaders ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Response_Abstract::getHeader() - El propósito de getHeader
  • Yaf_Response_Abstract::setHeader() - Establece cabecera de respuesta


El propósito de __construct

  • « Yaf_Response_Abstract::clearHeaders
  • Yaf_Response_Abstract::__destruct »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de __construct

Yaf_Response_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__construct — El propósito de __construct

Descripción

public Yaf_Response_Abstract::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __destruct

  • « Yaf_Response_Abstract::__construct
  • Yaf_Response_Abstract::getBody »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de __destruct

Yaf_Response_Abstract::__destruct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__destruct — El propósito de __destruct

Descripción

public Yaf_Response_Abstract::__destruct ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera un contenido existente

  • « Yaf_Response_Abstract::__destruct
  • Yaf_Response_Abstract::getHeader »
  • PHP Manual
  • Yaf_Response_Abstract
  • Recupera un contenido existente

Yaf_Response_Abstract::getBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::getBody — Recupera un contenido existente

Descripción

public Yaf_Response_Abstract::getBody ( string $key = ? ) : mixed

Recupera un contenido existente.

Parámetros

key

La clave del contenido, si no se especifica, se usará Yaf_Response_Abstract::DEFAULT_BODY. Si se pasa null, todos el contenido será devuelto como un array.

Nota:

Este parámetro se introdujo en la versión 2.2.0

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Response_Abstract::getBody()

<?php
$respuesta = new Yaf_Response_Http();

$respuesta->setBody("Hola")->setBody(" Mundo", "footer");

var_dump($respuesta->getBody()); // predeterminado
var_dump($respuesta->getBody(Yaf_Response_Abstract::DEFAULT_BODY)); // lo mismo que arriba
var_dump($respuesta->getBody("footer"));
var_dump($respuesta->getBody(NULL)); // obtener todo
?>

El resultado del ejemplo sería algo similar a:

string(4) "Hola"
string(4) "Hola"
string(6) " Mundo"
array(2) {
  ["content"]=>
  string(4) "Hola"
  ["footer"]=>
  string(6) " Mundo"
}

Ver también

  • Yaf_Response_Abstract::setBody() - Establece el contenido de una respuesta
  • Yaf_Response_Abstract::appendBody() - Añadir contenido al cuerpo de respuesta
  • Yaf_Response_Abstract::prependBody() - El propósito de prependBody
  • Yaf_Response_Abstract::clearBody() - Descarta todo el cuerpo de respuesta existente


El propósito de getHeader

  • « Yaf_Response_Abstract::getBody
  • Yaf_Response_Abstract::prependBody »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de getHeader

Yaf_Response_Abstract::getHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::getHeader — El propósito de getHeader

Descripción

public Yaf_Response_Abstract::getHeader ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Response_Abstract::setHeader() - Establece cabecera de respuesta
  • Yaf_Response_Abstract::cleanHeaders()


El propósito de prependBody

  • « Yaf_Response_Abstract::getHeader
  • Yaf_Response_Abstract::response »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de prependBody

Yaf_Response_Abstract::prependBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::prependBody — El propósito de prependBody

Descripción

public Yaf_Response_Abstract::prependBody ( string $content , string $key = ? ) : bool

Antepone un contenido a un bloque de contenido existente

Parámetros

body

La cadena con el contenido.

key

La clave del contenido, se puede establecer una clave, y so no se especifica, se usará Yaf_Response_Abstract::DEFAULT_BODY.

Nota:

Este parámetro se introdujo a partir de la versión 2.2.0.

Valores devueltos

Un valor de tipo booleano.

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Response_Abstract::prependBody()

<?php
$respuesta = new Yaf_Response_Http();

$respuesta->setBody("Mundo")->prependBody("Hola ");

echo $respuesta;
?>

El resultado del ejemplo sería algo similar a:

Hola Mundo

Ver también

  • Yaf_Response_Abstract::getBody() - Recupera un contenido existente
  • Yaf_Response_Abstract::setBody() - Establece el contenido de una respuesta
  • Yaf_Response_Abstract::appendBody() - Añadir contenido al cuerpo de respuesta
  • Yaf_Response_Abstract::clearBody() - Descarta todo el cuerpo de respuesta existente


Envía una respuesta

  • « Yaf_Response_Abstract::prependBody
  • Yaf_Response_Abstract::setAllHeaders »
  • PHP Manual
  • Yaf_Response_Abstract
  • Envía una respuesta

Yaf_Response_Abstract::response

(Yaf >=1.0.0)

Yaf_Response_Abstract::response — Envía una respuesta

Descripción

public Yaf_Response_Abstract::response ( ) : void

Envía una respuesta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Response_Abstract::response()

<?php
$respuesta = new Yaf_Response_Http();

$respuesta->setBody("Hola")->setBody(" Mundo", "footer");

$respuesta->respuesta();
?>

El resultado del ejemplo sería algo similar a:

Hola Mundo

Ver también

  • Yaf_Response_Abstract::setBody() - Establece el contenido de una respuesta
  • Yaf_Response_Abstract::clearBody() - Descarta todo el cuerpo de respuesta existente


El propósito de setAllHeaders

  • « Yaf_Response_Abstract::response
  • Yaf_Response_Abstract::setBody »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de setAllHeaders

Yaf_Response_Abstract::setAllHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::setAllHeaders — El propósito de setAllHeaders

Descripción

protected Yaf_Response_Abstract::setAllHeaders ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Establece el contenido de una respuesta

  • « Yaf_Response_Abstract::setAllHeaders
  • Yaf_Response_Abstract::setHeader »
  • PHP Manual
  • Yaf_Response_Abstract
  • Establece el contenido de una respuesta

Yaf_Response_Abstract::setBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::setBody — Establece el contenido de una respuesta

Descripción

public Yaf_Response_Abstract::setBody ( string $content , string $key = ? ) : bool

Establece el contenido de una respuesta.

Parámetros

body

La cadena con el contenido.

key

La clave del contenido, se puede establecer una clave, y so no se especifica, se usará Yaf_Response_Abstract::DEFAULT_BODY.

Nota:

Este parámetro se introdujo a partir de la versión 2.2.0.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Response_Abstract::setBody()

<?php
$respuesta = new Yaf_Response_Http();

$respuesta->setBody("Hola")->setBody(" Mundo", "footer");

print_r($respuesta);
echo $respuesta;
?>

El resultado del ejemplo sería algo similar a:

Yaf_Response_Http Object
(
    [_header:protected] => Array
        (
        )

    [_body:protected] => Array
        (
            [content] => Hola
            [footer] =>  Mundo
        )

    [_sendheader:protected] => 1
    [_response_code:protected] => 200
)
Hola Mundo

Ver también

  • Yaf_Response_Abstract::getBody() - Recupera un contenido existente
  • Yaf_Response_Abstract::appendBody() - Añadir contenido al cuerpo de respuesta
  • Yaf_Response_Abstract::prependBody() - El propósito de prependBody
  • Yaf_Response_Abstract::clearBody() - Descarta todo el cuerpo de respuesta existente


Establece cabecera de respuesta

  • « Yaf_Response_Abstract::setBody
  • Yaf_Response_Abstract::setRedirect »
  • PHP Manual
  • Yaf_Response_Abstract
  • Establece cabecera de respuesta

Yaf_Response_Abstract::setHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::setHeader — Establece cabecera de respuesta

Descripción

public Yaf_Response_Abstract::setHeader ( string $name , string $value , bool $replace = ? ) : bool

Se utiliza para enviar un encabezado HTTP

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Response_Abstract::getHeader() - El propósito de getHeader
  • Yaf_Response_Abstract::cleanHeaders()


El propósito de setRedirect

  • « Yaf_Response_Abstract::setHeader
  • Yaf_Response_Abstract::__toString »
  • PHP Manual
  • Yaf_Response_Abstract
  • El propósito de setRedirect

Yaf_Response_Abstract::setRedirect

(Yaf >=1.0.0)

Yaf_Response_Abstract::setRedirect — El propósito de setRedirect

Descripción

public Yaf_Response_Abstract::setRedirect ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera todo el cuerpo como un string

  • « Yaf_Response_Abstract::setRedirect
  • Yaf_Route_Interface »
  • PHP Manual
  • Yaf_Response_Abstract
  • Recupera todo el cuerpo como un string

Yaf_Response_Abstract::__toString

(Yaf >=1.0.0)

Yaf_Response_Abstract::__toString — Recupera todo el cuerpo como un string

Descripción

private Yaf_Response_Abstract::__toString ( ) : string

Recuperar todo el cuerpo como un string

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Route_Interface

(Yaf >=1.0.0)

Introducción

Yaf_Route_Interface se usa para que los desarrolladores definan sus enrutamientos personalizados.

Sinopsis de la Clase

Yaf_Route_Interface {
/* Métodos */
abstract public assemble ( array $info , array $query = ? ) : string
abstract public route ( Yaf_Request_Abstract $request ) : bool
}

Tabla de contenidos

  • Yaf_Route_Interface::assemble — Ensamblar una petición
  • Yaf_Route_Interface::route — Enruta una petición


Ensamblar una petición

  • « Yaf_Route_Interface
  • Yaf_Route_Interface::route »
  • PHP Manual
  • Yaf_Route_Interface
  • Ensamblar una petición

Yaf_Route_Interface::assemble

(Yaf >=2.3.0)

Yaf_Route_Interface::assemble — Ensamblar una petición

Descripción

abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string

Este método devuelve un URL según el argumento info info, y pospone los string de consultas al URL según el argumento query.

Una ruta debería implementar este método según sus propias reglas de ruta, y realizar un progreso inverso.

Parámetros

info

query

Valores devueltos


Enruta una petición

  • « Yaf_Route_Interface::assemble
  • Yaf_Route_Map »
  • PHP Manual
  • Yaf_Route_Interface
  • Enruta una petición

Yaf_Route_Interface::route

(Yaf >=1.0.0)

Yaf_Route_Interface::route — Enruta una petición

Descripción

abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool

Yaf_Route_Interface::route() es el único método que debería implementar un enrutamiento personalizado.

Nota:

Desde la 2.3.0, hay otro método que también debería ser implementado, ver Yaf_Route_Interface::assemble().

Si este método devuelve true, el proceso de enrutamiento terminará, de otro modo Yaf_Router llamará a la siguiente ruta de la pila de enrutamiento para enrutar la petición.

Este método establecería el resultado del enrutamiento al parámetro request,
llamando a los métodos Yaf_Request_Abstract::setControllerName(),
Yaf_Request_Abstract::setActionName() y
Yaf_Request_Abstract::setModuleName().

Este método debería también llamar al método Yaf_Request_Abstract::setRouted() para realizar al fin la petición enrutada.

Parámetros

request

Una instancia de la clase Yaf_Request_Abstract.

Valores devueltos


La clase Yaf_Route_Map

(Yaf >=1.0.0)

Introducción

Yaf_Route_Map es una ruta interna, simplemente convierte el extremo de un URI (la parte del URI que va después del URI base: véase Yaf_Request_Abstract::setBaseUri()) a un nombre de controlador o acción (dependen del parámetro pasado a Yaf_Route_Map::__construct()) en la siguiente regla: A => controlador A. A/B/C => controlador A_B_C. A/B/C/D/E => controlador A_B_C_D_E.

Si se especifica el segundo parámetro de Yaf_Route_Map::__construct(), solamente la parte de antes del delimitador del URI se usará para enrutar, la parte de después se usa para enrutar parámetros de petición (véase la sección de ejemplos de Yaf_Route_Map::__construct()).

Sinopsis de la Clase

Yaf_Route_Map implements Yaf_Route_Interface {
/* Propiedades */
protected $_ctl_router ;
protected $_delimiter ;
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $controller_prefer = false , string $delimiter = "" )
public route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

_ctl_router

_delimiter

Tabla de contenidos

  • Yaf_Route_Map::assemble — Ensamblar un URL
  • Yaf_Route_Map::__construct — El propósito de __construct
  • Yaf_Route_Map::route — El propósito de route


Ensamblar un URL

  • « Yaf_Route_Map
  • Yaf_Route_Map::__construct »
  • PHP Manual
  • Yaf_Route_Map
  • Ensamblar un URL

Yaf_Route_Map::assemble

(Yaf >=2.3.0)

Yaf_Route_Map::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Map::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL.

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Map::assemble()

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Map();

$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':c' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

$route = new Yaf_Route_Map(true, '_');
$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':a' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

El resultado del ejemplo sería algo similar a:

string(%d) "/foo/bar?tkey1=tval1&tkey2=tval2"
string(%d) "/foo/bar/_/tkey1/tval1/tkey2/tval2"

Valores devueltos


El propósito de __construct

  • « Yaf_Route_Map::assemble
  • Yaf_Route_Map::route »
  • PHP Manual
  • Yaf_Route_Map
  • El propósito de __construct

Yaf_Route_Map::__construct

(Yaf >=1.0.0)

Yaf_Route_Map::__construct — El propósito de __construct

Descripción

public Yaf_Route_Map::__construct ( string $controller_prefer = false , string $delimiter = "" )

Parámetros

controller_prefer

Si el resultado debería considerarse un controlador o una acción

delimiter

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Map()

<?php
   /**
    * Añadir una ruta de mapas a la pila de enrutamiento de Yaf_Router
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map());
?>

El resultado del ejemplo sería algo similar a:

/* para http://sudominio.com/producto/foo/bar
 * la ruta resultará en los siguiente valores:
 */
array(
  "controller" => "producto_foo_bar",
)

Ejemplo #2 Ejemplo de Yaf_Route_Map()

<?php
   /**
    * Añadir una ruta de mapas a la pila de enrutamiento de Yaf_Router
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map(true, "_"));
?>

El resultado del ejemplo sería algo similar a:

/* para http://sudominio.com/user/list/_/foo/22
 * la ruta resultará en los siguientes valores:
 */
array(
    "action" => "user_list",
)

/**
 * y los parámetros de petición:
 */
array(
  "foo"   => 22,
)

Ejemplo #3 Yaf_Route_Map()example

<?php
   /**
    * Añadir una ruta de mapas a la pila de enrutamiento de Yaf_Router llamando a addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "map",         //Yaf_Route_Map route
           "controllerPrefer" => FALSE,
           "delimiter"        => "#!",
           ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Ver también

  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite


El propósito de route

  • « Yaf_Route_Map::__construct
  • Yaf_Route_Regex »
  • PHP Manual
  • Yaf_Route_Map
  • El propósito de route

Yaf_Route_Map::route

(Yaf >=1.0.0)

Yaf_Route_Map::route — El propósito de route

Descripción

public Yaf_Route_Map::route ( Yaf_Request_Abstract $request ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

Valores devueltos


La clase Yaf_Route_Regex

(Yaf >=1.0.0)

Introducción

Yaf_Route_Regex es la ruta más flexible entre las rutas integradas de Yaf.

Sinopsis de la Clase

Yaf_Route_Regex extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* Propiedades */
protected $_route ;
protected $_default ;
protected $_maps ;
protected $_verify ;
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $match , array $route , array $map = ? , array $verify = ? , string $reverse = ? )
public route ( Yaf_Request_Abstract $request ) : bool
/* Métodos heredados */
abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string
abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

_route

_default

_maps

_verify

Tabla de contenidos

  • Yaf_Route_Regex::assemble — Ensamblar un URL
  • Yaf_Route_Regex::__construct — Constructor de Yaf_Route_Regex
  • Yaf_Route_Regex::route — El propósito de route


Ensamblar un URL

  • « Yaf_Route_Regex
  • Yaf_Route_Regex::__construct »
  • PHP Manual
  • Yaf_Route_Regex
  • Ensamblar un URL

Yaf_Route_Regex::assemble

(Yaf >=2.3.0)

Yaf_Route_Regex::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Regex::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Regex::assemble()

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Regex(
            "#^/product/([^/]+)/([^/])+#",
            array(
                'controller' => "product",  //route to product controller,
                ),
            array(),
            array(),
            '/:m/:c/:a'
        );

$router->addRoute("regex", $route);

var_dump($router->getRoute('regex')->assemble(
            array(
                ':m' => 'module',
                ':c' => 'controller',
                ':a' => 'action'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' =>
                'tval2'
                )
            )
        );

El resultado del ejemplo sería algo similar a:

string(49) "/module/controller/action?tkey1=tval1&tkey2=tval2"

Valores devueltos


Constructor de Yaf_Route_Regex

  • « Yaf_Route_Regex::assemble
  • Yaf_Route_Regex::route »
  • PHP Manual
  • Yaf_Route_Regex
  • Constructor de Yaf_Route_Regex

Yaf_Route_Regex::__construct

(Yaf >=1.0.0)

Yaf_Route_Regex::__construct — Constructor de Yaf_Route_Regex

Descripción

public Yaf_Route_Regex::__construct ( string $match , array $route , array $map = ? , array $verify = ? , string $reverse = ? )

Parámetros

match

Un patrón de expresión regular completo, se usará para comparar un URI solicitado, si no coincide, Yaf_Route_Regex devolverá false.

route

Cuando el patrón de comparación coincida con el URI solicitado, Yaf_Route_Regex lo usará para decidir qué m/c/a enrutar.

m/c/a en este array son opcionales, si no se asigna un valor específico, será enrutada al valor predeterminado.

map

Un array para asignar nombres a las capturas del resultado de comparación.

reverse

una cadena, usado para ensamblar url, ver Yaf_Route_Regex::assemble().

Nota:

este parametro se introdujo en 2.3.0

verify

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Regex()

<?php
   /**
    * Añade una ruta de expresión regular a la pila de enrutamiento de Yaf_Router
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#", //comparar los URI solicitados que empiecen por "/product"
           array(
               'controller' => "product",  //ruta al controlador product,
           ),
           array(
              1 => "name",   // ahora se puede llamar a $request->getParam("name")
              2 => "id",     // para obtener la primera captura del patrón de comparación.
           )
        )
    );
?>

Ejemplo #2 Ejemplo de Yaf_Route_Regex(como en 2.3.0)()

<?php
   /**
    * Usar el resultado de la busqueda como nombre MVC
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#i", //buscar primera peticion uri "/product"
           array(
              'controller' => ":name", // ruta a :name, el cual es $1 en el resultado de busqueda como nombre de controllador
           ),
           array(
              1 => "name",   // ahora puede llamar a $request->getParam("name")
              2 => "id",     // para obtener la primera coincidencia en el patron de busqueda.
           )
        )
    );
?>

Ejemplo #3 Ejemplo de Yaf_Route_Regex y el nombre de la zona de captura (a partir de 2.3.0)()

<?php
   /**
    * Usar el resultado de la coincidencia como nombre del MVC
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/(?<name>[^/]+)/([^/])+#i", //solicitud de coincidencia uri leading "/product"
           array(
           'controller' => ":name", // ruta a :name,
                                    // que se denomina "nombre" del grupo de captura en el resultado de la coincidencia como nombre del controlador
           ),
           array(
              2 => "id",     // para obtener la primera captura en el patrón de coincidencia.
           )
        )
    );
?>

Ejemplo #4 Ejemplo de Yaf_Route_Regex()

<?php
   /**
    * Add a regex route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "regex",          //ruta Yaf_Route_Regex
           "match" => "#(.*)#",         //comparar URIs solicitados arbitrarios
           "route" => array(
               'controller' => "product",  //ruta al controlador product,
               'action'     => "dummy",    //ruta a una acción sin sentido
           ),
           "map" => array(
              1 => "uri",   // ahora se puede llamar a $request->getParam("uri")
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Ver también

  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Router::addConfig() - Añadir rutas definidas en configuración al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


El propósito de route

  • « Yaf_Route_Regex::__construct
  • Yaf_Route_Rewrite »
  • PHP Manual
  • Yaf_Route_Regex
  • El propósito de route

Yaf_Route_Regex::route

(Yaf >=1.0.0)

Yaf_Route_Regex::route — El propósito de route

Descripción

public Yaf_Route_Regex::route ( Yaf_Request_Abstract $request ) : bool

Enruta una petición entrante.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

Valores devueltos

Si el patrón dado por el primer parámetro de Yaf_Route_Regex::_construct() coincide con el URI solicitado, devuelve true, si no devuelve false.


La clase Yaf_Route_Rewrite

(Yaf >=1.0.0)

Introducción

Para su uso, veáse la sección de ejemplos de Yaf_Route_Rewrite::__construct()

Sinopsis de la Clase

Yaf_Route_Rewrite extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* Propiedades */
protected $_route ;
protected $_default ;
protected $_verify ;
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $match , array $route , array $verify = ? )
public route ( Yaf_Request_Abstract $request ) : bool
/* Métodos heredados */
abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string
abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

_route

_default

_verify

Tabla de contenidos

  • Yaf_Route_Rewrite::assemble — Ensamblar un URL
  • Yaf_Route_Rewrite::__construct — Constructor de Yaf_Route_Rewrite
  • Yaf_Route_Rewrite::route — El propósito de route


Ensamblar un URL

  • « Yaf_Route_Rewrite
  • Yaf_Route_Rewrite::__construct »
  • PHP Manual
  • Yaf_Route_Rewrite
  • Ensamblar un URL

Yaf_Route_Rewrite::assemble

(Yaf >=2.3.0)

Yaf_Route_Rewrite::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Rewrite::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL.

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Rewrite::assemble()

router = new Yaf_Router();

$route  = new Yaf_Route_Rewrite(
                "/product/:name/:id/*",
                array(
                        'controller' => "product",
                ),
                array()
);

$router->addRoute("rewrite", $route);

var_dump($router->getRoute('rewrite')->assemble(
                        array(
                                ':name' => 'foo',
                                ':id' => 'bar',
                                ':tmpkey1' => 'tmpval1'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                             )
                        )
);

El resultado del ejemplo sería algo similar a:

string(57) "/product/foo/bar/tmpkey1/tmpval1/?tkey1=tval1&tkey2=tval2"

Valores devueltos


Constructor de Yaf_Route_Rewrite

  • « Yaf_Route_Rewrite::assemble
  • Yaf_Route_Rewrite::route »
  • PHP Manual
  • Yaf_Route_Rewrite
  • Constructor de Yaf_Route_Rewrite

Yaf_Route_Rewrite::__construct

(Yaf >=1.0.0)

Yaf_Route_Rewrite::__construct — Constructor de Yaf_Route_Rewrite

Descripción

public Yaf_Route_Rewrite::__construct ( string $match , array $route , array $verify = ? )

Parámetros

match

Un patrón de expresión regular completo, se usará para comparar un URI solicitado, si no coincide, Yaf_Route_Regex devolverá false.

Se puede usar el stilo :name para nombrar segmentos a buscar. y * para encontrar el resto de segmentos.

route

Cuando el patrón de comparación coincida con el URI solicitado, Yaf_Route_Regex lo usará para decidir qué módulo/ccontrolador/acción enrutar.

Cada módulo/ccontrolador/acción en este array es opcional, si no se asigna un valor específico, será enrutada al valor predeterminado.

verify

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Rewrite()

<?php
   /**
    * Añadir una ruta de reescritura a la pila de rutas de Yaf_Router
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_rewrite(
           "/product/:name/:id/*", //match request uri leading "/product"
           array(
               'controller' => "product",  //route to product controller,
           ),
        )
    );
?>

El resultado del ejemplo sería algo similar a:

/* para http://yourdomain.com/product/foo/22/foo/bar
 * la ruta resultará en los siguientes valores:
 */
array(
  "controller" => "product",
  "module"     => "index", //(default)
  "action"     => "index", //(default)
)

/**
 * y los parámetros de petición:
 */
array(
  "name" => "foo",
  "id"   => 22,
  "foo"  => bar
)

Ejemplo #2 Ejemplo de Yaf_Route_Rewrite()

<?php
   /**
    * Añadir una ruta de reescritura a la pila de rutas de Yaf_Router llamando a addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",        //Yaf_Route_Rewrite route
           "match" => "/user-list/:id", //match only /user/list/?/
           "route" => array(
               'controller' => "user",  //route to user controller,
               'action'     => "list",  //route to list action
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

El resultado del ejemplo sería algo similar a:

/* para http://yourdomain.com/user-list/22
 * la ruta resultará en los siguientes valores:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * y los parámetros de petición:
 */
array(
  "id"   => 22,
)

Ejemplo #3 Ejemplo de Yaf_Route_Rewrite (como en 2.3.0)()

<?php
   /**
    * Añadir una ruta de reescritura para usar el resultado de comparar m/c/a como un nombre
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",
           "match" => "/user-list/:a/:id", //coincidir solo /user-list/*
           "route" => array(
               'controller' => "user",   //ruta a user controller,
               'action'     => ":a",     //ruta a acción :a
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

El resultado del ejemplo sería algo similar a:

/* para http://yourdomain.com/user-list/list/22
 * la ruta resultará en los siguientes valores:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * y los parámetros de petición:
 */
array(
  "id"   => 22,
)

Ver también

  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Router::addConfig() - Añadir rutas definidas en configuración al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Map


El propósito de route

  • « Yaf_Route_Rewrite::__construct
  • Yaf_Router »
  • PHP Manual
  • Yaf_Route_Rewrite
  • El propósito de route

Yaf_Route_Rewrite::route

(Yaf >=1.0.0)

Yaf_Route_Rewrite::route — El propósito de route

Descripción

public Yaf_Route_Rewrite::route ( Yaf_Request_Abstract $request ) : bool

Parámetros

request

Valores devueltos


La clase Yaf_Router

(Yaf >=1.0.0)

Introducción

Yaf_Router es el enrutador estándar del framework. Enrutar es el proceso de tomar un extremo de un URI (la parte del URI que va antes del URL base: véase Yaf_Request_Abstract::setBaseUri()) y descomponerlo en parámetros para determinar qué módulo, controlador, y acción de ese controlador deberían recibir la petición. Estos valores de módulo, controlador, acción y demás parámetros, son empaquetados en un objeto Yaf_Request_Abstract que es procesado por Yaf_Dispatcher. El enrutamiento sucede sólo una vez: cuando la petición es recibida inicialmente y antes de que el primer controlador sea despachado. La clase Yaf_Router está diseñada para tener en cuenta una funcionalidad parecida a la directiva mod_rewrite usando simples estructuras de PHP. Está basada indirectamente en el enrutamiento de Ruby on Rails y no requiere ningún conocimiento previo de la reescritura de URL del servidor web. Está diseñada para funcionar con una simple regla de la directiva mod_rewrite de Apache (una de):

Ejemplo #1 Regla de reescritura para Apache

RewriteEngine on
RewriteRule !\.(js|ico|gif|jpg|png|css|html)$ index.php
o (preferible):

Ejemplo #2 Regla de reescritura para Apache

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
Si se usa Lighttpd, la siguiente regla de reescritura es válida:

Ejemplo #3 Regla de reescritura para Lighttpd

url.rewrite-once = (
  ".*\?(.*)$" => "/index.php?$1",
  ".*\.(js|ico|gif|jpg|png|css|html)$" => "$0",
  "" => "/index.php"
)
Si se usa Nginx, utilice la siguiente regla de reescritura:

Ejemplo #4 Regla de reescritura para Nginx

server {
  listen ****;
  server_name  yourdomain.com;
  root   document_root;
  index  index.php index.html;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php/$1 last;
  }
}

Enrutamiento predeterminado

Yaf_Router comes viene preconfigurada con un enrutamiento Yaf_Route_Static predeterminado, el cual comparará URIs en la forma de controlador/acción. Además, se puede especificar un nombre de módulo como el primer elemento de la ruta, permitiendo URIs de la forma módulo/controlador/acción. Finalmente, también comparará cualquier parámetro adicional añadido al URI por omisión - controlador/acción/variable1/valor1/variable2/valor2.

Nota:

El nombre del módulo debe estar definido en la configuración, considerando application.module="Index,Foo,Bar", en este caso, solamente index, foo y bar pueden ser considerados como un nombre de módulo; si no está configurado, sólo existe un nombre de módulo llamado "Index".

Algunos ejemplos de cómo tales enrutamientos son comparados:

Ejemplo #5 Ejemplo de Yaf_Route_Static (ruta predeterminada)

// Se asume la siguiente configuración:
$conf = array(
   "application" => array(
      "modules" => "Index,Blog",
   ),
);

Solamente el controlador:
http://example/news
    controller == news
Solamente la acción (al definir yaf.action_prefer=1 en php.ini)
    action  == news

Un módulo inválido mapea el nombre del controlador:
http://example/foo
    controller == foo

Módulo + controlador:
http://example/blog/archive
    module     == blog
    controller == archive

Módulo + controlador + acción:
http://example/blog/archive/list
    module     == blog
    controller == archive
    action     == list

Módulo + controlador + acción + parámetros:
http://example/blog/archive/list/sort/alpha/date/desc
    module     == blog
    controller == archive
    action     == list
    sort       == alpha
    date       == desc

Sinopsis de la Clase

Yaf_Router {
/* Propiedades */
protected $_routes ;
protected $_current ;
/* Métodos */
public addConfig ( Yaf_Config_Abstract $config ) : bool
public addRoute ( string $name , Yaf_Route_Abstract $route ) : bool
public __construct ( )
public getCurrentRoute ( ) : string
public getRoute ( string $name ) : Yaf_Route_Interface
public getRoutes ( ) : mixed
public route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

_routes

Pila de rutas registradas

_current

Después de la fase de enrutamiento, esto indica el nombre de la ruta a usar para enrutar la petición actual. Se puede obtener este nombre mediante Yaf_Router::getCurrentRoute().

Tabla de contenidos

  • Yaf_Router::addConfig — Añadir rutas definidas en configuración al Enrutador
  • Yaf_Router::addRoute — Añadir una nueva ruta al Enrutador
  • Yaf_Router::__construct — El constructor de Yaf_Router
  • Yaf_Router::getCurrentRoute — Obtener el nombre de la ruta efectiva
  • Yaf_Router::getRoute — Recupera una ruta por su nombre
  • Yaf_Router::getRoutes — Recupera las rutas registradas
  • Yaf_Router::route — El propósito de route


Añadir rutas definidas en configuración al Enrutador

  • « Yaf_Router
  • Yaf_Router::addRoute »
  • PHP Manual
  • Yaf_Router
  • Añadir rutas definidas en configuración al Enrutador

Yaf_Router::addConfig

(Yaf >=1.0.0)

Yaf_Router::addConfig — Añadir rutas definidas en configuración al Enrutador

Descripción

public Yaf_Router::addConfig ( Yaf_Config_Abstract $config ) : bool

Añade rutas definidas mediante configuraciones en la pila de rutas de Yaf_Router

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una instancia de Yaf_Config_Abstract, la cual debería contener una o más configuraciones de rutas válidas.

Ejemplos

Ejemplo #1 Ejemplo de application.ini()

;el orden es muy importante, el primero será llamado en primer lugar

;a rewrite route match request /product/*/*
routes.route_name.type="rewrite"
routes.route_name.match="/product/:name/:value"
routes.route_name.route.controller=product
routes.route_name.route.action=info

;a regex route match request /list/*/*
routes.route_name1.type="regex"
routes.route_name1.match="#^list/([^/]*)/([^/]*)#"
routes.route_name1.route.controller=Index
routes.route_name1.route.action=action
routes.route_name1.map.1=name
routes.route_name1.map.2=value

;a simple route match /**?c=controller&a=action&m=module
routes.route_name2.type="simple"
routes.route_name2.controller=c
routes.route_name2.module=m
routes.route_name2.action=a

;a simple router match /**?r=PATH_INFO
routes.route_name3.type="supervar"
routes.route_name3.varname=r

;a map route match any request to controller
routes.route_name4.type="map"
routes.route_name4.controllerPrefer=TRUE
routes.route_namer.delimiter="#!"

Ejemplo #2 Ejemplo de Yaf_Dispatcher::autoConfig()

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * podemos añadir algunas rutas predefinidas en application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
    }
?>

Ver también

  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


Añadir una nueva ruta al Enrutador

  • « Yaf_Router::addConfig
  • Yaf_Router::__construct »
  • PHP Manual
  • Yaf_Router
  • Añadir una nueva ruta al Enrutador

Yaf_Router::addRoute

(Yaf >=1.0.0)

Yaf_Router::addRoute — Añadir una nueva ruta al Enrutador

Descripción

public Yaf_Router::addRoute ( string $name , Yaf_Route_Abstract $route ) : bool

Por defecto, Yaf_Router usa un Yaf_Route_Static como su ruta predeterminada. Se pueden añadir nuevas rutas a la pila de rutas del Enrutador llamando a este método.

La ruta más nueva será llamada antes que la más antigua (pila de rutas), y si la ruta más nueva devuelve true, el proceso de enrutamiento finalizará. De otro modo, será llamada la ruta más antigua.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Dispatcher::autoRender()

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * podemos añadir algunas rutas predefinidas en application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
        /**
         * add a Rewrite route, then for a request uri:
         * http://***/product/list/22/foo
         * will be matched by this route, and result:
         *
         *  [module] =>
         *  [controller] => product
         *  [action] => info
         *  [method] => GET
         *  [params:protected] => Array
         *      (
         *          [id] => 22
         *          [name] => foo
         *      )
         *
         */
        $route  = new Yaf_Route_Rewrite(
            "/product/list/:id/:name",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('dummy', $route);
    }
?>

Ver también

  • Yaf_Router::addConfig() - Añadir rutas definidas en configuración al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


El constructor de Yaf_Router

  • « Yaf_Router::addRoute
  • Yaf_Router::getCurrentRoute »
  • PHP Manual
  • Yaf_Router
  • El constructor de Yaf_Router

Yaf_Router::__construct

(Yaf >=1.0.0)

Yaf_Router::__construct — El constructor de Yaf_Router

Descripción

public Yaf_Router::__construct ( )

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtener el nombre de la ruta efectiva

  • « Yaf_Router::__construct
  • Yaf_Router::getRoute »
  • PHP Manual
  • Yaf_Router
  • Obtener el nombre de la ruta efectiva

Yaf_Router::getCurrentRoute

(Yaf >=1.0.0)

Yaf_Router::getCurrentRoute — Obtener el nombre de la ruta efectiva

Descripción

public Yaf_Router::getCurrentRoute ( ) : string

Obtiene el nombre de la ruta efectiva del proceso de enrutamiento.

Nota:

Se debería llamar a este método después de que finalice el proceso de enrutamiento, ya que si se hace antes, este método devolverá siempre null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una cadena, el nombre de la ruta efectiva.

Ejemplos

Ejemplo #1 Registrar algunas rutas en el Arranque

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        $rewrite_route  = new Yaf_Route_Rewrite(
            "/product/list/:page",
            array(
                "controller" => "product",
                "action"     => "list",
            )
        );

        $regex_route  = new Yaf_Route_Rewrite(
            "#^/product/info/(\d+)",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('rewrite', $rewrite_route)->addRoute('regex', $regex_route);
    }

    /**
     * registrar un complemento
     */
    public function __initPlugins(Yaf_Dispatcher $dispatcher) {
        $dispatcher->registerPlugin(new DummyPlugin());
    }
?>

Ejemplo #2 Complemento Dummy.php (bajo application.directory/plugins)

<?php
class DummyPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
         var_dump(Yaf_Dispatcher::getInstance()->getRouter()->getCurrentRoute());
    }
?>
?>

El resultado del ejemplo sería algo similar a:

/* para http://yourdomain.com/product/list/1
 * DummyPlugin imprimirá:
 */
string(7) "rewrite"

/* para http://yourdomain.com/product/info/34
 * DummyPlugin imprimirá:
 */
string(5) "regex"

/* para otros URIs solicitados
 * DummyPlugin imprimirá:
 */
string(8) "_default"

Ver también

  • Yaf_Bootstrap_Abstract
  • Yaf_Plugin_Abstract
  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador


Recupera una ruta por su nombre

  • « Yaf_Router::getCurrentRoute
  • Yaf_Router::getRoutes »
  • PHP Manual
  • Yaf_Router
  • Recupera una ruta por su nombre

Yaf_Router::getRoute

(Yaf >=1.0.0)

Yaf_Router::getRoute — Recupera una ruta por su nombre

Descripción

public Yaf_Router::getRoute ( string $name ) : Yaf_Route_Interface

Recupera una ruta por su nombre. Véase también Yaf_Router::getCurrentRoute()

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Yaf_Bootstrap_Abstract
  • Yaf_Plugin_Abstract
  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Router::getCurrentRoute() - Obtener el nombre de la ruta efectiva


Recupera las rutas registradas

  • « Yaf_Router::getRoute
  • Yaf_Router::route »
  • PHP Manual
  • Yaf_Router
  • Recupera las rutas registradas

Yaf_Router::getRoutes

(Yaf >=1.0.0)

Yaf_Router::getRoutes — Recupera las rutas registradas

Descripción

public Yaf_Router::getRoutes ( ) : mixed

Recupera las rutas registradas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de route

  • « Yaf_Router::getRoutes
  • Yaf_Route_Simple »
  • PHP Manual
  • Yaf_Router
  • El propósito de route

Yaf_Router::route

(Yaf >=1.0.0)

Yaf_Router::route — El propósito de route

Descripción

public Yaf_Router::route ( Yaf_Request_Abstract $request ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Route_Simple

(Yaf >=1.0.0)

Introducción

Yaf_Route_Simple comparará la cadena de consulta, y buscará la información de enrutamiento.

Todo lo que se necesita es indicar a Yaf_Route_Simple qué clave de la variable $_GET es un módulo, qué clave es un controlador, y qué clave es una acción.

Yaf_Route_Simple::route() siempre devuelve true, por lo que es importante poner Yaf_Route_Simple al frente de la pila de enrutamiento, de otro modo todas las otras rutas no serán llamadas.

Sinopsis de la Clase

Yaf_Route_Simple implements Yaf_Route_Interface {
/* Propiedades */
protected $controller ;
protected $module ;
protected $action ;
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $module_name , string $controller_name , string $action_name )
public route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

controller

module

action

Tabla de contenidos

  • Yaf_Route_Simple::assemble — Ensamblar un URL
  • Yaf_Route_Simple::__construct — El constructor de la clase Yaf_Route_Simple
  • Yaf_Route_Simple::route — Enviar una petición


Ensamblar un URL

  • « Yaf_Route_Simple
  • Yaf_Route_Simple::__construct »
  • PHP Manual
  • Yaf_Route_Simple
  • Ensamblar un URL

Yaf_Route_Simple::assemble

(Yaf >=2.3.0)

Yaf_Route_Simple::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Simple::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL.

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Simple::assemble()

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Simple('m', 'c', 'a');

$router->addRoute("simple", $route);

var_dump($router->getRoute('simple')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
                )
            ));

El resultado del ejemplo sería algo similar a:

string(64) "?m=yafmodule&c=yafcontroller&a=yafaction&tkey1=tval1&tkey2=tval2"

Valores devueltos


El constructor de la clase Yaf_Route_Simple

  • « Yaf_Route_Simple::assemble
  • Yaf_Route_Simple::route »
  • PHP Manual
  • Yaf_Route_Simple
  • El constructor de la clase Yaf_Route_Simple

Yaf_Route_Simple::__construct

(Yaf >=1.0.0)

Yaf_Route_Simple::__construct — El constructor de la clase Yaf_Route_Simple

Descripción

public Yaf_Route_Simple::__construct ( string $module_name , string $controller_name , string $action_name )

Yaf_Route_Simple obtendrá la información de la ruta desde una cadena de consulta. Los parámetros de este constructor se usarán como claves mientras se busca la información de la ruta en $_GET.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

module_name

El nombre de la clave de la información del módulo.

controller_name

El nombre de la clave de la información del controlador.

action_name

El nombre de la clave de la información de la acción.

Valores devueltos

Siempre devuelve true.

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Simple::route()

<?php
   $route = new Yaf_Route_Simple("m", "controller", "act");
   Yaf_Router::getInstance()->addRoute("simple", $route);
?>

Ejemplo #2 Ejemplo de Yaf_Route_Simple::route()

Request: http://yourdomain.com/path/?controller=a&act=b
=> module = default(index), controller = a, action = b

Request: http://yourdomain.com/path
=> module = default(index), controller = default(index), action = default(index)

Ver también

  • Yaf_Route_Supervar::route() - El propósito de route
  • Yaf_Route_Static::route() - Enviar una petición
  • Yaf_Route_Regex::route() - El propósito de route
  • Yaf_Route_Rewrite::route() - El propósito de route
  • Yaf_Route_Map::route() - El propósito de route


Enviar una petición

  • « Yaf_Route_Simple::__construct
  • Yaf_Route_Static »
  • PHP Manual
  • Yaf_Route_Simple
  • Enviar una petición

Yaf_Route_Simple::route

(Yaf >=1.0.0)

Yaf_Route_Simple::route — Enviar una petición

Descripción

public Yaf_Route_Simple::route ( Yaf_Request_Abstract $request ) : bool

Véase Yaf_Route_Simple::__construct()

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

Valores devueltos

Siempre es true

Ver también

  • Yaf_Route_Supervar::route() - El propósito de route
  • Yaf_Route_Static::route() - Enviar una petición
  • Yaf_Route_Regex::route() - El propósito de route
  • Yaf_Route_Rewrite::route() - El propósito de route
  • Yaf_Route_Map::route() - El propósito de route


La clase Yaf_Route_Static

(Yaf >=1.0.0)

Introducción

Por defecto, Yaf_Router sólo tiene un Yaf_Route_Static como su ruta predeterminada.

Y Yaf_Route_Static está diseñada para manejar el 80% de los requisitos.

Por favor, *OBSERVE* que no es necesario instanciar un objeto de la clase Yaf_Route_Static, y que también es innecesario añadirlo a la pila de enrutamientos de Yaf_Router, ya que siempre hay una en la pila de enrutamiento de Yaf_Router, y que siempre será llamada en el último momento.

Sinopsis de la Clase

Yaf_Route_Static implements Yaf_Router {
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public match ( string $uri ) : void
public route ( Yaf_Request_Abstract $request ) : bool
}

Tabla de contenidos

  • Yaf_Route_Static::assemble — Ensamblar un URL
  • Yaf_Route_Static::match — El propósito de match
  • Yaf_Route_Static::route — Enviar una petición


Ensamblar un URL

  • « Yaf_Route_Static
  • Yaf_Route_Static::match »
  • PHP Manual
  • Yaf_Route_Static
  • Ensamblar un URL

Yaf_Route_Static::assemble

(Yaf >=2.3.0)

Yaf_Route_Static::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Static::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL.

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Static::assemble()

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Static();

$router->addRoute("static", $route);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
        )
);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
            )
        )
);

El resultado del ejemplo sería algo similar a:

string(%d) "/yafmodule/yafcontroller/yafaction"
string(%d) "/yafmodule/yafcontroller/yafaction?tkey1=tval1&tkey2=tval2"

Valores devueltos


El propósito de match

  • « Yaf_Route_Static::assemble
  • Yaf_Route_Static::route »
  • PHP Manual
  • Yaf_Route_Static
  • El propósito de match

Yaf_Route_Static::match

(Yaf >=1.0.0)

Yaf_Route_Static::match — El propósito de match

Descripción

public Yaf_Route_Static::match ( string $uri ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

uri

Valores devueltos


Enviar una petición

  • « Yaf_Route_Static::match
  • Yaf_Route_Supervar »
  • PHP Manual
  • Yaf_Route_Static
  • Enviar una petición

Yaf_Route_Static::route

(Yaf >=1.0.0)

Yaf_Route_Static::route — Enviar una petición

Descripción

public Yaf_Route_Static::route ( Yaf_Request_Abstract $request ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

Valores devueltos

Siempre es true

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Static::route()

// se asume que sólo existe un módulo definido: Index
Request: http://yourdomain.com/a/b
=> module = index, controller=a, action=b

//se asume ap.action_prefer = On
Request: http://yourdomain.com/b
=> module = default(index), controller = default(index), action = b

//se asume ap.action_prefer = Off
Request: http://yourdomain.com/b
=> module = default(index), controller = b, action = default(index)

Request: http://yourdomain.com/a/b/foo/bar/test/a/id/4
=> module = default(index), controller = a, action = b, request parameters: foo = bar, test = a, id = 4

Ver también

  • Yaf_Route_Supervar::route() - El propósito de route
  • Yaf_Route_Simple::route() - Enviar una petición
  • Yaf_Route_Regex::route() - El propósito de route
  • Yaf_Route_Rewrite::route() - El propósito de route
  • Yaf_Route_Map::route() - El propósito de route


La clase Yaf_Route_Supervar

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Route_Supervar implements Yaf_Route_Interface {
/* Propiedades */
protected $_var_name ;
/* Métodos */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $supervar_name )
public route ( Yaf_Request_Abstract $request ) : bool
}

Propiedades

_var_name

Tabla de contenidos

  • Yaf_Route_Supervar::assemble — Ensamblar un URL
  • Yaf_Route_Supervar::__construct — El propósito de __construct
  • Yaf_Route_Supervar::route — El propósito de route


Ensamblar un URL

  • « Yaf_Route_Supervar
  • Yaf_Route_Supervar::__construct »
  • PHP Manual
  • Yaf_Route_Supervar
  • Ensamblar un URL

Yaf_Route_Supervar::assemble

(Yaf >=2.3.0)

Yaf_Route_Supervar::assemble — Ensamblar un URL

Descripción

public Yaf_Route_Supervar::assemble ( array $info , array $query = ? ) : string

Ensamblar un URL.

Parámetros

info

query

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Supervar::assemble()

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Supervar('r');

$router->addRoute("supervar", $route);

var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':c' => 'yafcontroller',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2'
        )
));

try {
var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2',
              1 => array(),
        )
));
} catch (Exception $e) {
    var_dump($e->getMessage());
}

El resultado del ejemplo sería algo similar a:

string(%d) "?r=/yafmodule/yafcontroller/yafaction&tkey1=tval1&tkey2=tval2"
string(%d) "You need to specify the controller by ':c'"

Valores devueltos


El propósito de __construct

  • « Yaf_Route_Supervar::assemble
  • Yaf_Route_Supervar::route »
  • PHP Manual
  • Yaf_Route_Supervar
  • El propósito de __construct

Yaf_Route_Supervar::__construct

(Yaf >=1.0.0)

Yaf_Route_Supervar::__construct — El propósito de __construct

Descripción

public Yaf_Route_Supervar::__construct ( string $supervar_name )

Yaf_Route_Supervar es similar a Yaf_Route_Static, con la diferencia de que Yaf_Route_Supervar buscará información de ruta en la cadena de consulta, y el parámetro supervar_name es la clave.

Parámetros

supervar_name

El nombre de la clave

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yaf_Route_Supervar()

<?php
   /**
    * Añadir una ruta supervar a la pila de rutas de Yaf_Router
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Supervar("r"));
    );
?>

El resultado del ejemplo sería algo similar a:

/** para la petición: http://yourdomain.com/xx/oo/?r=/ctr/act/var/value
  * resultará en lo siguiente:
  */
  array (
    "module"   => index(default),
    "controller" => ctr,
    "action"     => act,
    "params"     => array(
          "var" => value,
     )
  )

Ver también

  • Yaf_Router::addRoute() - Añadir una nueva ruta al Enrutador
  • Yaf_Router::addConfig() - Añadir rutas definidas en configuración al Enrutador
  • Yaf_Route_Static
  • Yaf_Route_Regex
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


El propósito de route

  • « Yaf_Route_Supervar::__construct
  • Yaf_Session »
  • PHP Manual
  • Yaf_Route_Supervar
  • El propósito de route

Yaf_Route_Supervar::route

(Yaf >=1.0.0)

Yaf_Route_Supervar::route — El propósito de route

Descripción

public Yaf_Route_Supervar::route ( Yaf_Request_Abstract $request ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

request

Valores devueltos

Si existe una clave (la cual fue definida en Yaf_Route_Supervar::__construct()) en $_GET, devuelve true, si no devuelve false.


La clase Yaf_Session

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Session implements Iterator , ArrayAccess , Countable {
/* Propiedades */
protected static $_instance ;
protected $_session ;
protected $_started ;
/* Métodos */
private __construct ( )
public count ( ) : void
public current ( ) : void
public del ( string $name ) : void
public __get ( string $name ) : void
public static getInstance ( ) : void
public has ( string $name ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public rewind ( ) : void
public __set ( string $name , string $value ) : void
public start ( ) : void
public __unset ( string $name ) : void
public valid ( ) : void
}

Propiedades

_instance

_session

_started

Tabla de contenidos

  • Yaf_Session::__construct — Constructor de Yaf_Session
  • Yaf_Session::count — El propósito de count
  • Yaf_Session::current — El propósito de current
  • Yaf_Session::del — El propósito de del
  • Yaf_Session::__get — El propósito de __get
  • Yaf_Session::getInstance — El propósito de getInstance
  • Yaf_Session::has — El propósito de has
  • Yaf_Session::__isset — El propósito de __isset
  • Yaf_Session::key — El propósito de key
  • Yaf_Session::next — El propósito de next
  • Yaf_Session::offsetExists — El propósito de offsetExists
  • Yaf_Session::offsetGet — El propósito de offsetGet
  • Yaf_Session::offsetSet — El propósito de offsetSet
  • Yaf_Session::offsetUnset — El propósito de offsetUnset
  • Yaf_Session::rewind — El propósito de rewind
  • Yaf_Session::__set — El propósito de __set
  • Yaf_Session::start — El propósito de start
  • Yaf_Session::__unset — El propósito de __unset
  • Yaf_Session::valid — El propósito de valid


Constructor de Yaf_Session

  • « Yaf_Session
  • Yaf_Session::count »
  • PHP Manual
  • Yaf_Session
  • Constructor de Yaf_Session

Yaf_Session::__construct

(Yaf >=1.0.0)

Yaf_Session::__construct — Constructor de Yaf_Session

Descripción

private Yaf_Session::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de count

  • « Yaf_Session::__construct
  • Yaf_Session::current »
  • PHP Manual
  • Yaf_Session
  • El propósito de count

Yaf_Session::count

(Yaf >=1.0.0)

Yaf_Session::count — El propósito de count

Descripción

public Yaf_Session::count ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de current

  • « Yaf_Session::count
  • Yaf_Session::del »
  • PHP Manual
  • Yaf_Session
  • El propósito de current

Yaf_Session::current

(Yaf >=1.0.0)

Yaf_Session::current — El propósito de current

Descripción

public Yaf_Session::current ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de del

  • « Yaf_Session::current
  • Yaf_Session::__get »
  • PHP Manual
  • Yaf_Session
  • El propósito de del

Yaf_Session::del

(Yaf >=1.0.0)

Yaf_Session::del — El propósito de del

Descripción

public Yaf_Session::del ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de __get

  • « Yaf_Session::del
  • Yaf_Session::getInstance »
  • PHP Manual
  • Yaf_Session
  • El propósito de __get

Yaf_Session::__get

(Yaf >=1.0.0)

Yaf_Session::__get — El propósito de __get

Descripción

public Yaf_Session::__get ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de getInstance

  • « Yaf_Session::__get
  • Yaf_Session::has »
  • PHP Manual
  • Yaf_Session
  • El propósito de getInstance

Yaf_Session::getInstance

(Yaf >=1.0.0)

Yaf_Session::getInstance — El propósito de getInstance

Descripción

public static Yaf_Session::getInstance ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de has

  • « Yaf_Session::getInstance
  • Yaf_Session::__isset »
  • PHP Manual
  • Yaf_Session
  • El propósito de has

Yaf_Session::has

(Yaf >=1.0.0)

Yaf_Session::has — El propósito de has

Descripción

public Yaf_Session::has ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de __isset

  • « Yaf_Session::has
  • Yaf_Session::key »
  • PHP Manual
  • Yaf_Session
  • El propósito de __isset

Yaf_Session::__isset

(Yaf >=1.0.0)

Yaf_Session::__isset — El propósito de __isset

Descripción

public Yaf_Session::__isset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de key

  • « Yaf_Session::__isset
  • Yaf_Session::next »
  • PHP Manual
  • Yaf_Session
  • El propósito de key

Yaf_Session::key

(Yaf >=1.0.0)

Yaf_Session::key — El propósito de key

Descripción

public Yaf_Session::key ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de next

  • « Yaf_Session::key
  • Yaf_Session::offsetExists »
  • PHP Manual
  • Yaf_Session
  • El propósito de next

Yaf_Session::next

(Yaf >=1.0.0)

Yaf_Session::next — El propósito de next

Descripción

public Yaf_Session::next ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de offsetExists

  • « Yaf_Session::next
  • Yaf_Session::offsetGet »
  • PHP Manual
  • Yaf_Session
  • El propósito de offsetExists

Yaf_Session::offsetExists

(Yaf >=1.0.0)

Yaf_Session::offsetExists — El propósito de offsetExists

Descripción

public Yaf_Session::offsetExists ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetGet

  • « Yaf_Session::offsetExists
  • Yaf_Session::offsetSet »
  • PHP Manual
  • Yaf_Session
  • El propósito de offsetGet

Yaf_Session::offsetGet

(Yaf >=1.0.0)

Yaf_Session::offsetGet — El propósito de offsetGet

Descripción

public Yaf_Session::offsetGet ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de offsetSet

  • « Yaf_Session::offsetGet
  • Yaf_Session::offsetUnset »
  • PHP Manual
  • Yaf_Session
  • El propósito de offsetSet

Yaf_Session::offsetSet

(Yaf >=1.0.0)

Yaf_Session::offsetSet — El propósito de offsetSet

Descripción

public Yaf_Session::offsetSet ( string $name , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


El propósito de offsetUnset

  • « Yaf_Session::offsetSet
  • Yaf_Session::rewind »
  • PHP Manual
  • Yaf_Session
  • El propósito de offsetUnset

Yaf_Session::offsetUnset

(Yaf >=1.0.0)

Yaf_Session::offsetUnset — El propósito de offsetUnset

Descripción

public Yaf_Session::offsetUnset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de rewind

  • « Yaf_Session::offsetUnset
  • Yaf_Session::__set »
  • PHP Manual
  • Yaf_Session
  • El propósito de rewind

Yaf_Session::rewind

(Yaf >=1.0.0)

Yaf_Session::rewind — El propósito de rewind

Descripción

public Yaf_Session::rewind ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __set

  • « Yaf_Session::rewind
  • Yaf_Session::start »
  • PHP Manual
  • Yaf_Session
  • El propósito de __set

Yaf_Session::__set

(Yaf >=1.0.0)

Yaf_Session::__set — El propósito de __set

Descripción

public Yaf_Session::__set ( string $name , string $value ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

value

Valores devueltos


El propósito de start

  • « Yaf_Session::__set
  • Yaf_Session::__unset »
  • PHP Manual
  • Yaf_Session
  • El propósito de start

Yaf_Session::start

(Yaf >=1.0.0)

Yaf_Session::start — El propósito de start

Descripción

public Yaf_Session::start ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de __unset

  • « Yaf_Session::start
  • Yaf_Session::valid »
  • PHP Manual
  • Yaf_Session
  • El propósito de __unset

Yaf_Session::__unset

(Yaf >=1.0.0)

Yaf_Session::__unset — El propósito de __unset

Descripción

public Yaf_Session::__unset ( string $name ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


El propósito de valid

  • « Yaf_Session::__unset
  • Yaf_Exception »
  • PHP Manual
  • Yaf_Session
  • El propósito de valid

Yaf_Session::valid

(Yaf >=1.0.0)

Yaf_Session::valid — El propósito de valid

Descripción

public Yaf_Session::valid ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Exception

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public __construct ( )
public getPrevious ( ) : void
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Tabla de contenidos

  • Yaf_Exception::__construct — El propósito de __construct
  • Yaf_Exception::getPrevious — El propósito de getPrevious


El propósito de __construct

  • « Yaf_Exception
  • Yaf_Exception::getPrevious »
  • PHP Manual
  • Yaf_Exception
  • El propósito de __construct

Yaf_Exception::__construct

(Yaf >=1.0.0)

Yaf_Exception::__construct — El propósito de __construct

Descripción

public Yaf_Exception::__construct ( )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


El propósito de getPrevious

  • « Yaf_Exception::__construct
  • Yaf_Exception_TypeError »
  • PHP Manual
  • Yaf_Exception
  • El propósito de getPrevious

Yaf_Exception::getPrevious

(Yaf >=1.0.0)

Yaf_Exception::getPrevious — El propósito de getPrevious

Descripción

public Yaf_Exception::getPrevious ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase Yaf_Exception_TypeError

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_TypeError extends Yaf_Exception {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_StartupError

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_StartupError extends Yaf_Exception {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_DispatchFailed

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_DispatchFailed extends Yaf_Exception {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_RouterFailed

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_RouterFailed extends Yaf_Exception {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_LoadFailed

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_LoadFailed extends Yaf_Exception {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_LoadFailed_Module

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_LoadFailed_Module extends Yaf_Exception_LoadFailed {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_LoadFailed_Controller

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_LoadFailed_Controller extends Yaf_Exception_LoadFailed {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_LoadFailed_Action

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_LoadFailed_Action extends Yaf_Exception_LoadFailed {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


La clase Yaf_Exception_LoadFailed_View

(Yaf >=1.0.0)

Introducción

Sinopsis de la Clase

Yaf_Exception_LoadFailed_View extends Yaf_Exception_LoadFailed {
/* Propiedades */
/* Métodos */
/* Métodos heredados */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


Yaconf

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Yaconf — La clase Yaconf
    • Yaconf::get — Recuperar un elemento
    • Yaconf::has — Determinar si un elemento existe


Introducción

Otro contenedor de configuraciones (Yaconf) es un contenedor de configuraciones, analiza los archivos INI, y almacena el resultado en PHP cuando se inicia PHP, el resultado vive con el todo el ciclo de vida de PHP.

Yaconf almacena todas las configuraciones como string interno o array inmutable, eso significa que no se pueden devolver, por lo que al recuperar las configuraciones de yaconf, podría considerarse como una copia cero, muy rápido.

Yaconf soporta secciones y secciones herencia en los archivos del INI. si PHP se construye como una construcción no-ZTS, Yaconf también soporta la recarga automática después de que se cambien los archivos del INI.

Yaconf requiere PHP 7.0 o superior.

Ejemplo #1 INI example

;simple key val
key=val
;hash
hash.a=val
;array
arr.0=val
;or
arr[]=val
;use PHP constants
version=PHP_VERION
;use enviroment
env=${PATH}

Ejemplo #2 Ejemplo de secciones INI

[SectionA]
key=val
hash.a=val

;SectionB hereda SectionA
[SectionB:SectionA]
;reemplazar la clave de configuración en SectionA
key=new_val


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Yaconf requiere PHP 7.0 y superior.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yaconf.

Los binarios de Windows (ficheros DLL) para esta extensión de PECL están disponibles en el sitio web de PECL.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Yaconf Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
yaconf.check_delay | 300 | PHP_INI_SYSTEM |
yaconf.directory | /tmp/conf/ | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

yaconf.check_delay integer

En que intervalo Yaconf detectará el cambio del archivo ini (por el directorio mtime), si se pone a cero, hay que reiniciar el php para recargar las configuraciones.

yaconf.directory string

Ruta al directorio en el que se encuentran todos los archivos de configuración INI.


  • « Tipos de recursos
  • Yaconf »
  • PHP Manual
  • Yaconf
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


La clase Yaconf

(PECL yaconf >= 1.0.0)

Introducción

Yaconf es un contenedor de configuraciones, analiza los archivos del INI, almacena el resultado en cuando PHP se inicia, el resultado vive con todo el ciclo de vida de PHP.

Sinopsis de la Clase

Yaconf {
/* Métodos */
public static get ( string $name , mixed $default_value = NULL ) : mixed
public static has ( string $name ) : bool
}

Tabla de contenidos

  • Yaconf::get — Recuperar un elemento
  • Yaconf::has — Determinar si un elemento existe


Recuperar un elemento

  • « Yaconf
  • Yaconf::has »
  • PHP Manual
  • Yaconf
  • Recuperar un elemento

Yaconf::get

(PECL yaconf >= 1.0.0)

Yaconf::get — Recuperar un elemento

Descripción

public static Yaconf::get ( string $name , mixed $default_value = NULL ) : mixed

Parámetros

name

Clave de configuración, la clave se ve como "filename.key", o "filename.sectionName,key".

default_value

si la clave no existe, Yaconf::get devolverá esto como resultado.

Valores devueltos

Devuelve el resultado de configuración (string o array) si la clave existe, devuelve default_value si no.

Ejemplos

Ejemplo #1 Ejemplo de INI()

;filenmame foo.ini, colocado en el directorio que es yaconf.directoy
[SectionA]
;key value pair
key=val
;hash[a]=val
hash.a=val
;arr[0]=val
arr.0=val
;or
arr[]=val

;SectionB hereda SectionA
[SectionB:SectionA]
;reemplazar la clave de configuración en SectionA
key=new_val

El resultado del ejemplo sería algo similar a:

php7 -r 'var_dump(Yaconf::get("foo.SectionA.key"));'
//string(3) "val"

php7 -r 'var_dump(Yaconf::get("foo.SectionB.key"));'
//string(7) "new_val"

php7 -r 'var_dump(Yaconf::get("foo")["SectionA"]["hash"]);'
//array(1)


Determinar si un elemento existe

  • « Yaconf::get
  • Taint »
  • PHP Manual
  • Yaconf
  • Determinar si un elemento existe

Yaconf::has

(PECL yaconf >= 1.0.0)

Yaconf::has — Determinar si un elemento existe

Descripción

public static Yaconf::has ( string $name ) : bool

Parámetros

name

Valores devueltos


Taint

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Más detalles
    • Funciones y sentencias que propagarán la marca de corrupción de una cadena corrupta
    • Funciones y sentencias que comprobarán cadenas corrompidas
    • Funciones que sanean cadenas corruptas
  • Funciones de taint
    • is_tainted — Comprobar si un string está corrompido
    • taint — Corrompe un string
    • untaint — Sanea un string


Introducción

Taint es una extensión que sirve para detectar código XSS (cadenas de caracteres corrompidas, «tainted»). También se puede utilizar para localizar vulnerabilidades a inyecciones SQL, inyecciones «shell», etc.

Si taint está habilitada, advertirá de si se ha proporcionado una cadena corrompida (que venga de $_GET, $_POST o $_COOKIE) a alguna función.

Ejemplo #1 Ejemplo de taint()

<?php
$a = trim($_GET['a']);

$nombre_fichero = '/tmp' .  $a;
$salida    = "¡¡¡Bienvenido, {$a} !!!";
$var       = "salida";
$sql       = "Select *  from " . $a;
$sql      .= "ooxx";

echo $salida;

print $$var;

include($nombre_fichero);

mysql_query($sql);
?>

El resultado del ejemplo sería algo similar a:

Warning: main() [function.echo]: Attempt to echo a string that might be tainted

Warning: main() [function.echo]: Attempt to print a string that might be tainted

Warning: include() [function.include]: File path contains data that might be tainted

Warning: mysql_query() [function.mysql-query]: SQL statement contains data that might be tainted


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/taint.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de taint
Nombre | Por defecto | Cambiable | Historial de cambios
taint.enable | 0 | its PHP_INI_SYS value |
taint.error_level | E_WARNING | its PHP_INI_ALL value |

He aquí una breve explicación de las directivas de configuración.

taint.enable integer

Si habilitar taint.

taint.error_level integer

El tipo del error del que taint informará cuando encuentre una cadena corrupta.


  • « Configuración en tiempo de ejecución
  • Más detalles »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Más detalles

Tabla de contenidos

  • Funciones y sentencias que propagarán la marca de corrupción de una cadena corrupta
  • Funciones y sentencias que comprobarán cadenas corrompidas
  • Funciones que sanean cadenas corruptas


Funciones y sentencias que propagarán la marca de corrupción de una cadena corrupta

Función/Sentencia | Desde
= (asignación) | 0.1.0
. (concatenación) | 0.1.0
"{$var}" (sustitución de variables) | 0.1.0
.= (concatenación de asignación) | 0.1.0
strval | 0.3.0
explode | 0.3.0
implode | 0.3.0
sprintf | 0.3.0
vsprintf | 0.3.0
trim | 0.4.0
rtrim | 0.4.0
ltrim | 0.4.0


Funciones y sentencias que comprobarán cadenas corrompidas

Función/Sentencia | Desde
Sentencias básicas
eval | 0.1.0
include/include_once | 0.1.0
require/require_once | 0.1.0
Funciones de salida
echo | 0.1.0
print | 0.1.0
printf | 0.1.0
file_put_contents | 0.1.0
Funciones del sistema de ficheros
fopen | 0.2.0
opendir | 0.2.0
basename | 0.2.0
dirname | 0.2.0
file | 0.2.0
pathinfo | 0.2.0
Funciones relacionadas con bases de datos
mysql_query | 0.2.0
mysqli_query/MySQLi::query | 0.2.0
sqlite_query/SqliteDataBase::query | 0.3.0
sqlite_single_query/SqliteDataBase::singleQuery | 0.3.0
oci_parse | 0.3.0
PDO::query | 0.3.0
PDO::prepare | 0.3.0
Funciones relacionadas con la línea de comandos
system | 0.1.0
exec | 0.1.0
proc_open | 0.1.0
passthru | 0.1.0
shell_exec | 0.3.0


Funciones que sanean cadenas corruptas

Función | Desde
addslashes | 0.1.0
addcslashes | 0.1.0
htmlspecialchars | 0.1.0
htmlentities | 0.1.0
escapeshellcmd | 0.1.0
mysql_escape_string | 0.1.0
mysql_real_escape_string | 0.1.0
mysqli_escape_string/MySQLi::escape_string | 0.1.0
mysqli_real_escape_string/MySQLi::real_escape_string | 0.1.0
sqlite_escape_string/SqliteDataBase::escapeString | 0.3.0
PDO::quote | 0.3.0


Funciones de taint

Tabla de contenidos

  • is_tainted — Comprobar si un string está corrompido
  • taint — Corrompe un string
  • untaint — Sanea un string


Comprobar si un string está corrompido

  • « Funciones de taint
  • taint »
  • PHP Manual
  • Funciones de taint
  • Comprobar si un string está corrompido

is_tainted

(PECL taint >=0.1.0)

is_tainted — Comprobar si un string está corrompido

Descripción

is_tainted ( string $string ) : bool

Comprueba si un string está corrompido

Parámetros

string

Valores devueltos

Devuelve TRUE si el string está corrompido, FALSE en caso contrario.


Corrompe un string

  • « is_tainted
  • untaint »
  • PHP Manual
  • Funciones de taint
  • Corrompe un string

taint

(PECL taint >=0.1.0)

taint — Corrompe un string

Descripción

taint ( string &$string , string $... = ? ) : bool

Crea un string corrompido. Solamente se usa para realizar pruebas.

Parámetros

string

...

Valores devueltos

Devuelve TRUE si la transformación se lleva a cabo. Siempre devuelve TRUE si la extensión taint no esta activada.


Sanea un string

  • « taint
  • Data Structures »
  • PHP Manual
  • Funciones de taint
  • Sanea un string

untaint

(PECL taint >=0.1.0)

untaint — Sanea un string

Descripción

untaint ( string &$string , string $... = ? ) : bool

Sanea un string

Parámetros

string

...

Valores devueltos


Data Structures

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • Constantes predefinidas
  • Ejemplos
  • Collection — The Collection interface
    • Ds\Collection::clear — Removes all values
    • Ds\Collection::copy — Returns a shallow copy of the collection
    • Ds\Collection::isEmpty — Returns whether the collection is empty
    • Ds\Collection::toArray — Converts the collection to an array
  • Hashable — La interface Hashable
    • Ds\Hashable::equals — Determines whether an object is equal to the current instance
    • Ds\Hashable::hash — Returns a scalar value to be used as a hash value
  • Sequence — The Sequence interface
    • Ds\Sequence::allocate — Allocates enough memory for a required capacity
    • Ds\Sequence::apply — Updates all values by applying a callback function to each value
    • Ds\Sequence::capacity — Returns the current capacity
    • Ds\Sequence::contains — Determines if the sequence contains given values
    • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include
    • Ds\Sequence::find — Attempts to find a value's index
    • Ds\Sequence::first — Returns the first value in the sequence
    • Ds\Sequence::get — Returns the value at a given index
    • Ds\Sequence::insert — Inserts values at a given index
    • Ds\Sequence::join — Joins all values together as a string
    • Ds\Sequence::last — Returns the last value
    • Ds\Sequence::map — Returns the result of applying a callback to each value
    • Ds\Sequence::merge — Returns the result of adding all given values to the sequence
    • Ds\Sequence::pop — Removes and returns the last value
    • Ds\Sequence::push — Adds values to the end of the sequence
    • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function
    • Ds\Sequence::remove — Removes and returns a value by index
    • Ds\Sequence::reverse — Reverses the sequence in-place
    • Ds\Sequence::reversed — Returns a reversed copy
    • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations
    • Ds\Sequence::set — Updates a value at a given index
    • Ds\Sequence::shift — Removes and returns the first value
    • Ds\Sequence::slice — Returns a sub-sequence of a given range
    • Ds\Sequence::sort — Sorts the sequence in-place
    • Ds\Sequence::sorted — Returns a sorted copy
    • Ds\Sequence::sum — Returns the sum of all values in the sequence
    • Ds\Sequence::unshift — Adds values to the front of the sequence
  • Vector — La clase Vector
    • Ds\Vector::allocate — Allocates enough memory for a required capacity
    • Ds\Vector::apply — Updates all values by applying a callback function to each value
    • Ds\Vector::capacity — Returns the current capacity
    • Ds\Vector::clear — Removes all values
    • Ds\Vector::__construct — Creates a new instance
    • Ds\Vector::contains — Determines if the vector contains given values
    • Ds\Vector::copy — Returns a shallow copy of the vector
    • Ds\Vector::count — Returns the number of values in the collection
    • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include
    • Ds\Vector::find — Attempts to find a value's index
    • Ds\Vector::first — Returns the first value in the vector
    • Ds\Vector::get — Returns the value at a given index
    • Ds\Vector::insert — Inserts values at a given index
    • Ds\Vector::isEmpty — Returns whether the vector is empty
    • Ds\Vector::join — Joins all values together as a string
    • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Vector::last — Returns the last value
    • Ds\Vector::map — Returns the result of applying a callback to each value
    • Ds\Vector::merge — Returns the result of adding all given values to the vector
    • Ds\Vector::pop — Removes and returns the last value
    • Ds\Vector::push — Adds values to the end of the vector
    • Ds\Vector::reduce — Reduces the vector to a single value using a callback function
    • Ds\Vector::remove — Removes and returns a value by index
    • Ds\Vector::reverse — Reverses the vector in-place
    • Ds\Vector::reversed — Returns a reversed copy
    • Ds\Vector::rotate — Rotates the vector by a given number of rotations
    • Ds\Vector::set — Updates a value at a given index
    • Ds\Vector::shift — Removes and returns the first value
    • Ds\Vector::slice — Returns a sub-vector of a given range
    • Ds\Vector::sort — Sorts the vector in-place
    • Ds\Vector::sorted — Returns a sorted copy
    • Ds\Vector::sum — Returns the sum of all values in the vector
    • Ds\Vector::toArray — Converts the vector to an array
    • Ds\Vector::unshift — Adds values to the front of the vector
  • Deque — La clase Deque
    • Ds\Deque::allocate — Allocates enough memory for a required capacity
    • Ds\Deque::apply — Updates all values by applying a callback function to each value
    • Ds\Deque::capacity — Returns the current capacity
    • Ds\Deque::clear — Removes all values from the deque
    • Ds\Deque::__construct — Creates a new instance
    • Ds\Deque::contains — Determines if the deque contains given values
    • Ds\Deque::copy — Returns a shallow copy of the deque
    • Ds\Deque::count — Returns the number of values in the collection
    • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include
    • Ds\Deque::find — Attempts to find a value's index
    • Ds\Deque::first — Returns the first value in the deque
    • Ds\Deque::get — Returns the value at a given index
    • Ds\Deque::insert — Inserts values at a given index
    • Ds\Deque::isEmpty — Returns whether the deque is empty
    • Ds\Deque::join — Joins all values together as a string
    • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Deque::last — Returns the last value
    • Ds\Deque::map — Returns the result of applying a callback to each value
    • Ds\Deque::merge — Returns the result of adding all given values to the deque
    • Ds\Deque::pop — Removes and returns the last value
    • Ds\Deque::push — Adds values to the end of the deque
    • Ds\Deque::reduce — Reduces the deque to a single value using a callback function
    • Ds\Deque::remove — Removes and returns a value by index
    • Ds\Deque::reverse — Reverses the deque in-place
    • Ds\Deque::reversed — Returns a reversed copy
    • Ds\Deque::rotate — Rotates the deque by a given number of rotations
    • Ds\Deque::set — Updates a value at a given index
    • Ds\Deque::shift — Removes and returns the first value
    • Ds\Deque::slice — Returns a sub-deque of a given range
    • Ds\Deque::sort — Sorts the deque in-place
    • Ds\Deque::sorted — Returns a sorted copy
    • Ds\Deque::sum — Returns the sum of all values in the deque
    • Ds\Deque::toArray — Converts the deque to an array
    • Ds\Deque::unshift — Adds values to the front of the deque
  • Map — La clase Map
    • Ds\Map::allocate — Allocates enough memory for a required capacity
    • Ds\Map::apply — Updates all values by applying a callback function to each value
    • Ds\Map::capacity — Returns the current capacity
    • Ds\Map::clear — Removes all values
    • Ds\Map::__construct — Creates a new instance
    • Ds\Map::copy — Returns a shallow copy of the map
    • Ds\Map::count — Returns the number of values in the map
    • Ds\Map::diff — Creates a new map using keys that aren't in another map
    • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include
    • Ds\Map::first — Returns the first pair in the map
    • Ds\Map::get — Returns the value for a given key
    • Ds\Map::hasKey — Determines whether the map contains a given key
    • Ds\Map::hasValue — Determines whether the map contains a given value
    • Ds\Map::intersect — Creates a new map by intersecting keys with another map
    • Ds\Map::isEmpty — Returns whether the map is empty
    • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Map::keys — Returns a set of the map's keys
    • Ds\Map::ksort — Sorts the map in-place by key
    • Ds\Map::ksorted — Returns a copy, sorted by key
    • Ds\Map::last — Returns the last pair of the map
    • Ds\Map::map — Returns the result of applying a callback to each value
    • Ds\Map::merge — Returns the result of adding all given associations
    • Ds\Map::pairs — Returns a sequence containing all the pairs of the map
    • Ds\Map::put — Associates a key with a value
    • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array
    • Ds\Map::reduce — Reduces the map to a single value using a callback function
    • Ds\Map::remove — Removes and returns a value by key
    • Ds\Map::reverse — Reverses the map in-place
    • Ds\Map::reversed — Returns a reversed copy
    • Ds\Map::skip — Returns the pair at a given positional index
    • Ds\Map::slice — Returns a subset of the map defined by a starting index and length
    • Ds\Map::sort — Sorts the map in-place by value
    • Ds\Map::sorted — Returns a copy, sorted by value
    • Ds\Map::sum — Returns the sum of all values in the map
    • Ds\Map::toArray — Converts the map to an array
    • Ds\Map::union — Creates a new map using values from the current instance and another map
    • Ds\Map::values — Returns a sequence of the map's values
    • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both
  • Pair — La clase Pair
    • Ds\Pair::clear — Removes all values
    • Ds\Pair::__construct — Creates a new instance
    • Ds\Pair::copy — Returns a shallow copy of the pair
    • Ds\Pair::isEmpty — Returns whether the pair is empty
    • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Pair::toArray — Converts the pair to an array
  • Set — The Set class
    • Ds\Set::add — Adds values to the set
    • Ds\Set::allocate — Allocates enough memory for a required capacity
    • Ds\Set::capacity — Returns the current capacity
    • Ds\Set::clear — Removes all values
    • Ds\Set::__construct — Creates a new instance
    • Ds\Set::contains — Determines if the set contains all values
    • Ds\Set::copy — Returns a shallow copy of the set
    • Ds\Set::count — Returns the number of values in the set
    • Ds\Set::diff — Creates a new set using values that aren't in another set
    • Ds\Set::filter — Creates a new set using a callable to determine which values to include
    • Ds\Set::first — Returns the first value in the set
    • Ds\Set::get — Returns the value at a given index
    • Ds\Set::intersect — Creates a new set by intersecting values with another set
    • Ds\Set::isEmpty — Returns whether the set is empty
    • Ds\Set::join — Joins all values together as a string
    • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Set::last — Returns the last value in the set
    • Ds\Set::merge — Returns the result of adding all given values to the set
    • Ds\Set::reduce — Reduces the set to a single value using a callback function
    • Ds\Set::remove — Removes all given values from the set
    • Ds\Set::reverse — Reverses the set in-place
    • Ds\Set::reversed — Returns a reversed copy
    • Ds\Set::slice — Returns a sub-set of a given range
    • Ds\Set::sort — Sorts the set in-place
    • Ds\Set::sorted — Returns a sorted copy
    • Ds\Set::sum — Returns the sum of all values in the set
    • Ds\Set::toArray — Converts the set to an array
    • Ds\Set::union — Creates a new set using values from the current instance and another set
    • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both
  • Stack — The Stack class
    • Ds\Stack::allocate — Allocates enough memory for a required capacity
    • Ds\Stack::capacity — Returns the current capacity
    • Ds\Stack::clear — Removes all values
    • Ds\Stack::__construct — Creates a new instance
    • Ds\Stack::copy — Returns a shallow copy of the stack
    • Ds\Stack::count — Returns the number of values in the stack
    • Ds\Stack::isEmpty — Returns whether the stack is empty
    • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Stack::peek — Returns the value at the top of the stack
    • Ds\Stack::pop — Removes and returns the value at the top of the stack
    • Ds\Stack::push — Pushes values onto the stack
    • Ds\Stack::toArray — Converts the stack to an array
  • Queue — The Queue class
    • Ds\Queue::allocate — Allocates enough memory for a required capacity
    • Ds\Queue::capacity — Returns the current capacity
    • Ds\Queue::clear — Removes all values
    • Ds\Queue::__construct — Creates a new instance
    • Ds\Queue::copy — Returns a shallow copy of the queue
    • Ds\Queue::count — Returns the number of values in the queue
    • Ds\Queue::isEmpty — Returns whether the queue is empty
    • Ds\Queue::jsonSerialize — Regresa una representacion que puede ser convertida a JSON
    • Ds\Queue::peek — Returns the value at the front of the queue
    • Ds\Queue::pop — Removes and returns the value at the front of the queue
    • Ds\Queue::push — Añade un elemento a la cola
    • Ds\Queue::toArray — Convierte la cola en un array
  • PriorityQueue — The PriorityQueue class
    • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity
    • Ds\PriorityQueue::capacity — Returns the current capacity
    • Ds\PriorityQueue::clear — Removes all values
    • Ds\PriorityQueue::__construct — Creates a new instance
    • Ds\PriorityQueue::copy — Returns a shallow copy of the queue
    • Ds\PriorityQueue::count — Returns the number of values in the queue
    • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\PriorityQueue::peek — Returns the value at the front of the queue
    • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority
    • Ds\PriorityQueue::push — Pushes values into the queue
    • Ds\PriorityQueue::toArray — Converts the queue to an array


Introducción

Efficient data structures for PHP 7, provided as an alternative to the array.

See » this blog post for benchmarks, discussion and frequently asked questions.


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • Data Structures
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

PHP 7 is required by both the extension and the compatibility polyfill.


Instalación

The easiest way to install the extension is via » PECL

pecl install ds

You can also build directly from source:

# Dependencies you might need to install
# sudo apt-get install git build-essential php7.0-dev

git clone https://github.com/php-ds/extension "php-ds"
cd php-ds

# Build and install the extension
phpize
./configure
make
make install

# Clean up the build files
make clean
phpize --clean

If you're on Windows, you can » download a compiled .dll on PECL

Nota:

If you're using Composer, it's highly recommended that you include » php-ds/php-ds in your project so that your code is still functional in an environment where the extension is not installed. The extension will take priority if installed.


  • « Instalación
  • Ejemplos »
  • PHP Manual
  • Data Structures
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Ejemplo #1 Vector

<?php

$vector = new \Ds\Vector();

$vector->push('a');
$vector->push('b', 'c');

$vector[] = 'd';

print_r($vector);

?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
)

Ejemplo #2 Map

<?php

$map = new \Ds\Map();

$map->put('a', 1);
$map->put('b', 2);

$map['c'] = 3;

print_r($map);

?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


The Collection interface

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Collection is the base interface which covers functionality common to all the data structures in this library. It guarantees that all structures are traversable, countable, and can be converted to json using json_encode().

Sinopsis de la Interfaz

Ds\Collection implements Traversable , Countable , JsonSerializable {
/* Métodos */
abstract public clear ( ) : void
abstract public copy ( ) : Ds\Collection
abstract public isEmpty ( ) : bool
abstract public toArray ( ) : array
}

Tabla de contenidos

  • Ds\Collection::clear — Removes all values
  • Ds\Collection::copy — Returns a shallow copy of the collection
  • Ds\Collection::isEmpty — Returns whether the collection is empty
  • Ds\Collection::toArray — Converts the collection to an array


Removes all values

  • « Collection
  • Ds\Collection::copy »
  • PHP Manual
  • Collection
  • Removes all values

Ds\Collection::clear

(PECL ds >= 1.0.0)

Ds\Collection::clear — Removes all values

Descripción

abstract public Ds\Collection::clear ( ) : void

Removes all values from the collection.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Collection::clear() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);
print_r($collection);

$collection->clear();
print_r($collection);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)


Returns a shallow copy of the collection

  • « Ds\Collection::clear
  • Ds\Collection::isEmpty »
  • PHP Manual
  • Collection
  • Returns a shallow copy of the collection

Ds\Collection::copy

(PECL ds >= 1.0.0)

Ds\Collection::copy — Returns a shallow copy of the collection

Descripción

abstract public Ds\Collection::copy ( ) : Ds\Collection

Returns a shallow copy of the collection.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the collection.

Ejemplos

Ejemplo #1 Ds\Collection::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns whether the collection is empty

  • « Ds\Collection::copy
  • Ds\Collection::toArray »
  • PHP Manual
  • Collection
  • Returns whether the collection is empty

Ds\Collection::isEmpty

(PECL ds >= 1.0.0)

Ds\Collection::isEmpty — Returns whether the collection is empty

Descripción

abstract public Ds\Collection::isEmpty ( ) : bool

Returns whether the collection is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the collection is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Collection::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Converts the collection to an array

  • « Ds\Collection::isEmpty
  • Hashable »
  • PHP Manual
  • Collection
  • Converts the collection to an array

Ds\Collection::toArray

(PECL ds >= 1.0.0)

Ds\Collection::toArray — Converts the collection to an array

Descripción

abstract public Ds\Collection::toArray ( ) : array

Converts the collection to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the collection.

Ejemplos

Ejemplo #1 Ds\Collection::toArray() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);

var_dump($collection->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


La interface Hashable

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Hashable es una interface que permite a los objetos ser usados como claves. Esta es una alternativa a spl_object_hash(), la cual determina el hash de un objeto basado en su gestor: estos significa que dos objetos que son considerados iguales por una implícita definición no serán tratados como iguales debido a que no son la misma instancia.

hash() es utilizada para devolver un valor escalar para ser usado como el valor hash del objeto, el cual determina donde este va en la tabla hash. Aunque este valor no tiene que ser único, los objetos los cuales son iguales deben tener el mismo valor hash.

equals() es utilizada para determinar si dos objetos son iguales. Está garantizado que el objeto de comparación será una instancia de la misma clase que el sujeto.

Sinopsis de la Interfaz

Ds\Hashable {
/* Métodos */
abstract public equals ( object $obj ) : bool
abstract public hash ( ) : mixed
}

Tabla de contenidos

  • Ds\Hashable::equals — Determines whether an object is equal to the current instance
  • Ds\Hashable::hash — Returns a scalar value to be used as a hash value


Determines whether an object is equal to the current instance

  • « Hashable
  • Ds\Hashable::hash »
  • PHP Manual
  • Hashable
  • Determines whether an object is equal to the current instance

Ds\Hashable::equals

(PECL ds >= 1.0.0)

Ds\Hashable::equals — Determines whether an object is equal to the current instance

Descripción

abstract public Ds\Hashable::equals ( object $obj ) : bool

Determines whether another object is equal to the current instance.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Nota:

It's guaranteed that obj is an instance of the same class.

Precaución

It's important that objects which are equal also have the same hash value. See Ds\Hashable::hash().

Parámetros

obj

The object to compare the current instance to, which is always an instance of the same class.

Valores devueltos

true if equal, false otherwise.


Returns a scalar value to be used as a hash value

  • « Ds\Hashable::equals
  • Sequence »
  • PHP Manual
  • Hashable
  • Returns a scalar value to be used as a hash value

Ds\Hashable::hash

(PECL ds >= 1.0.0)

Ds\Hashable::hash — Returns a scalar value to be used as a hash value

Descripción

abstract public Ds\Hashable::hash ( ) : mixed

Returns a scalar value to be used as the hash value of the objects.

While the hash value does not define equality, all objects that are equal according to Ds\Hashable::equals() must have the same hash value. Hash values of equal objects don't have to be unique, for example you could just return true for all objects and nothing would break - the only implication would be that hash tables then turn into linked lists because all your objects will be hashed to the same bucket. It's therefore very important that you pick a good hash value, such as an ID or email address.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Precaución

Do not pick a value that might change within the object, such as a public property. Hash table lookups would fail because the hash has changed.

Precaución

All objects that are equal must have the same hash value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A scalar value to be used as this object's hash value.

Ejemplos

Ejemplo #1 Ds\Hashable::hash() example

<?php
class HashableObject implements \Ds\Hashable
{
    private $name;
    private $email;

    public function __construct($name, $email)
    {
        $this->name  = $name;
        $this->email = $email;
    }

    /**
     * Should return the same value for all equal objects, but doesn't have to
     * be unique. This value will not be used to determine equality.
     */
    public function hash()
    {
        return $this->email;
    }

    /**
     * This determines equality, usually during a hash table lookup to determine
     * if the bucket's key matches the lookup key. The hash has to be equal if
     * the objects are equal, otherwise this determination wouldn't be reached.
     */
    public function equals($obj): bool
    {
        return $this->name  === $obj->name
            && $this->email === $obj->email;
    }
}
?>


The Sequence interface

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

A Sequence describes the behaviour of values arranged in a single, linear dimension. Some languages refer to this as a "List". It’s similar to an array that uses incremental integer keys, with the exception of a few characteristics:

  • Values will always be indexed as [0, 1, 2, …, size - 1].
  • Only allowed to access values by index in the range [0, size - 1].

Use cases:

  • Wherever you would use an array as a list (not concerned with keys).
  • A more efficient alternative to SplDoublyLinkedList and SplFixedArray.

Sinopsis de la Interfaz

Ds\Sequence implements Ds\Collection , ArrayAccess {
/* Métodos */
abstract public allocate ( int $capacity ) : void
abstract public apply ( callable $callback ) : void
abstract public capacity ( ) : int
abstract public contains ( mixed ...$values ) : bool
abstract public filter ( callable $callback = ? ) : Ds\Sequence
abstract public find ( mixed $value ) : mixed
abstract public first ( ) : mixed
abstract public get ( int $index ) : mixed
abstract public insert ( int $index , mixed ...$values ) : void
abstract public join ( string $glue = ? ) : string
abstract public last ( ) : mixed
abstract public map ( callable $callback ) : Ds\Sequence
abstract public merge ( mixed $values ) : Ds\Sequence
abstract public pop ( ) : mixed
abstract public push ( mixed ...$values ) : void
abstract public reduce ( callable $callback , mixed $initial = ? ) : mixed
abstract public remove ( int $index ) : mixed
abstract public reverse ( ) : void
abstract public reversed ( ) : Ds\Sequence
abstract public rotate ( int $rotations ) : void
abstract public set ( int $index , mixed $value ) : void
abstract public shift ( ) : mixed
abstract public slice ( int $index , int $length = ? ) : Ds\Sequence
abstract public sort ( callable $comparator = ? ) : void
abstract public sorted ( callable $comparator = ? ) : Ds\Sequence
abstract public sum ( ) : int|float
abstract public unshift ( mixed $values = ? ) : void
}

Historial de cambios

Versión | Descripción
PECL ds 1.3.0 | The interface now extends ArrayAccess.

Tabla de contenidos

  • Ds\Sequence::allocate — Allocates enough memory for a required capacity
  • Ds\Sequence::apply — Updates all values by applying a callback function to each value
  • Ds\Sequence::capacity — Returns the current capacity
  • Ds\Sequence::contains — Determines if the sequence contains given values
  • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include
  • Ds\Sequence::find — Attempts to find a value's index
  • Ds\Sequence::first — Returns the first value in the sequence
  • Ds\Sequence::get — Returns the value at a given index
  • Ds\Sequence::insert — Inserts values at a given index
  • Ds\Sequence::join — Joins all values together as a string
  • Ds\Sequence::last — Returns the last value
  • Ds\Sequence::map — Returns the result of applying a callback to each value
  • Ds\Sequence::merge — Returns the result of adding all given values to the sequence
  • Ds\Sequence::pop — Removes and returns the last value
  • Ds\Sequence::push — Adds values to the end of the sequence
  • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function
  • Ds\Sequence::remove — Removes and returns a value by index
  • Ds\Sequence::reverse — Reverses the sequence in-place
  • Ds\Sequence::reversed — Returns a reversed copy
  • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations
  • Ds\Sequence::set — Updates a value at a given index
  • Ds\Sequence::shift — Removes and returns the first value
  • Ds\Sequence::slice — Returns a sub-sequence of a given range
  • Ds\Sequence::sort — Sorts the sequence in-place
  • Ds\Sequence::sorted — Returns a sorted copy
  • Ds\Sequence::sum — Returns the sum of all values in the sequence
  • Ds\Sequence::unshift — Adds values to the front of the sequence


Allocates enough memory for a required capacity

  • « Sequence
  • Ds\Sequence::apply »
  • PHP Manual
  • Sequence
  • Allocates enough memory for a required capacity

Ds\Sequence::allocate

(PECL ds >= 1.0.0)

Ds\Sequence::allocate — Allocates enough memory for a required capacity

Descripción

abstract public Ds\Sequence::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::allocate() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$vector->allocate(100);
var_dump($sequence->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(100)


Updates all values by applying a callback function to each value

  • « Ds\Sequence::allocate
  • Ds\Sequence::capacity »
  • PHP Manual
  • Sequence
  • Updates all values by applying a callback function to each value

Ds\Sequence::apply

(PECL ds >= 1.0.0)

Ds\Sequence::apply — Updates all values by applying a callback function to each value

Descripción

abstract public Ds\Sequence::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the sequence.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the sequence.

The callback should return what the value should be replaced by.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::apply() example

<?php
$sequence = new \Ds\Sequence([1, 2, 3]);
$sequence->apply(function($value) { return $value * 2; });

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • « Ds\Sequence::apply
  • Ds\Sequence::contains »
  • PHP Manual
  • Sequence
  • Returns the current capacity

Ds\Sequence::capacity

(PECL ds >= 1.0.0)

Ds\Sequence::capacity — Returns the current capacity

Descripción

abstract public Ds\Sequence::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Sequence::capacity() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$sequence->push(...range(1, 50));
var_dump($sequence->capacity());

$sequence[] = "a";
var_dump($sequence->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(50)
int(75)


Determines if the sequence contains given values

  • « Ds\Sequence::capacity
  • Ds\Sequence::filter »
  • PHP Manual
  • Sequence
  • Determines if the sequence contains given values

Ds\Sequence::contains

(PECL ds >= 1.0.0)

Ds\Sequence::contains — Determines if the sequence contains given values

Descripción

abstract public Ds\Sequence::contains ( mixed ...$values ) : bool

Determines if the sequence contains all values.

Parámetros

values

Values to check.

Valores devueltos

false if any of the provided values are not in the sequence, true otherwise.

Ejemplos

Ejemplo #1 Ds\Sequence::contains() example

<?php
$sequence = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($sequence->contains('a'));                // true
var_dump($sequence->contains('a', 'b'));           // true
var_dump($sequence->contains('c', 'd'));           // false

var_dump($sequence->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($sequence->contains(1));                  // true
var_dump($sequence->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Creates a new sequence using a callable to determine which values to include

  • « Ds\Sequence::contains
  • Ds\Sequence::find »
  • PHP Manual
  • Sequence
  • Creates a new sequence using a callable to determine which values to include

Ds\Sequence::filter

(PECL ds >= 1.0.0)

Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include

Descripción

abstract public Ds\Sequence::filter ( callable $callback = ? ) : Ds\Sequence

Creates a new sequence using a callable to determine which values to include.

Parámetros

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

Valores devueltos

A new sequence containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

Ejemplos

Ejemplo #1 Ds\Sequence::filter() example using callback function

<?php
$sequence = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($sequence->filter(function($value) {
    return $value % 2 == 0;
}));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Ejemplo #2 Ds\Sequence::filter() example without a callback function

<?php
$sequence = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($sequence->filter());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • « Ds\Sequence::filter
  • Ds\Sequence::first »
  • PHP Manual
  • Sequence
  • Attempts to find a value's index

Ds\Sequence::find

(PECL ds >= 1.0.0)

Ds\Sequence::find — Attempts to find a value's index

Descripción

abstract public Ds\Sequence::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

Parámetros

value

The value to find.

Valores devueltos

The index of the value, or false if not found.

Nota:

Values will be compared by value and by type.

Ejemplos

Ejemplo #1 Ds\Sequence::find() example

<?php
$sequence = new \Ds\Vector(["a", 1, true]);

var_dump($sequence->find("a")); // 0
var_dump($sequence->find("b")); // false
var_dump($sequence->find("1")); // false
var_dump($sequence->find(1));   // 1
?>

El resultado del ejemplo sería algo similar a:

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the sequence

  • « Ds\Sequence::find
  • Ds\Sequence::get »
  • PHP Manual
  • Sequence
  • Returns the first value in the sequence

Ds\Sequence::first

(PECL ds >= 1.0.0)

Ds\Sequence::first — Returns the first value in the sequence

Descripción

abstract public Ds\Sequence::first ( ) : mixed

Returns the first value in the sequence.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value in the sequence.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Sequence::first() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->first());
?>

El resultado del ejemplo sería algo similar a:

int(1)


Returns the value at a given index

  • « Ds\Sequence::first
  • Ds\Sequence::insert »
  • PHP Manual
  • Sequence
  • Returns the value at a given index

Ds\Sequence::get

(PECL ds >= 1.0.0)

Ds\Sequence::get — Returns the value at a given index

Descripción

abstract public Ds\Sequence::get ( int $index ) : mixed

Returns the value at a given index.

Parámetros

index

The index to access, starting at 0.

Valores devueltos

The value at the requested index.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Sequence::get() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->get(0));
var_dump($sequence->get(1));
var_dump($sequence->get(2));
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"

Ejemplo #2 Ds\Sequence::get() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence[0]);
var_dump($sequence[1]);
var_dump($sequence[2]);
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • « Ds\Sequence::get
  • Ds\Sequence::join »
  • PHP Manual
  • Sequence
  • Inserts values at a given index

Ds\Sequence::insert

(PECL ds >= 1.0.0)

Ds\Sequence::insert — Inserts values at a given index

Descripción

abstract public Ds\Sequence::insert ( int $index , mixed ...$values ) : void

Inserts values into the sequence at a given index.

Parámetros

index

The index at which to insert. 0 <= index <= count

Nota:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Sequence::insert() example

<?php
$sequence = new \Ds\Vector();

$sequence->insert(0, "e");             // [e]
$sequence->insert(1, "f");             // [e, f]
$sequence->insert(2, "g");             // [e, f, g]
$sequence->insert(0, "a", "b");        // [a, b, e, f, g]
$sequence->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($sequence);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Joins all values together as a string

  • « Ds\Sequence::insert
  • Ds\Sequence::last »
  • PHP Manual
  • Sequence
  • Joins all values together as a string

Ds\Sequence::join

(PECL ds >= 1.0.0)

Ds\Sequence::join — Joins all values together as a string

Descripción

abstract public Ds\Sequence::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

Parámetros

glue

An optional string to separate each value.

Valores devueltos

All values of the sequence joined together as a string.

Ejemplos

Ejemplo #1 Ds\Sequence::join() example using a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join("|"));
?>

El resultado del ejemplo sería algo similar a:

string(11) "a|b|c|1|2|3"

Ejemplo #2 Ds\Sequence::join() example without a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join());
?>

El resultado del ejemplo sería algo similar a:

string(11) "abc123"


Returns the last value

  • « Ds\Sequence::join
  • Ds\Sequence::map »
  • PHP Manual
  • Sequence
  • Returns the last value

Ds\Sequence::last

(PECL ds >= 1.0.0)

Ds\Sequence::last — Returns the last value

Descripción

abstract public Ds\Sequence::last ( ) : mixed

Returns the last value in the sequence.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The last value in the sequence.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Sequence::last() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->last());
?>

El resultado del ejemplo sería algo similar a:

int(3)


Returns the result of applying a callback to each value

  • « Ds\Sequence::last
  • Ds\Sequence::merge »
  • PHP Manual
  • Sequence
  • Returns the result of applying a callback to each value

Ds\Sequence::map

(PECL ds >= 1.0.0)

Ds\Sequence::map — Returns the result of applying a callback to each value

Descripción

abstract public Ds\Sequence::map ( callable $callback ) : Ds\Sequence

Returns the result of applying a callback function to each value in the sequence.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the sequence.

The callable should return what the new value will be in the new sequence.

Valores devueltos

The result of applying a callback to each value in the sequence.

Nota:

The values of the current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Sequence::map() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

print_r($sequence->map(function($value) { return $value * 2; }));
print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the sequence

  • « Ds\Sequence::map
  • Ds\Sequence::pop »
  • PHP Manual
  • Sequence
  • Returns the result of adding all given values to the sequence

Ds\Sequence::merge

(PECL ds >= 1.0.0)

Ds\Sequence::merge — Returns the result of adding all given values to the sequence

Descripción

abstract public Ds\Sequence::merge ( mixed $values ) : Ds\Sequence

Returns the result of adding all given values to the sequence.

Parámetros

values

A traversable object or an array.

Valores devueltos

The result of adding all given values to the sequence, effectively the same as adding the values to a copy, then returning that copy.

Nota:

The current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Sequence::merge() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->merge([4, 5, 6]));
var_dump($sequence);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • « Ds\Sequence::merge
  • Ds\Sequence::push »
  • PHP Manual
  • Sequence
  • Removes and returns the last value

Ds\Sequence::pop

(PECL ds >= 1.0.0)

Ds\Sequence::pop — Removes and returns the last value

Descripción

abstract public Ds\Sequence::pop ( ) : mixed

Removes and returns the last value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed last value.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Sequence::pop() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->pop());
var_dump($sequence->pop());
var_dump($sequence->pop());
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(2)
int(1)


Adds values to the end of the sequence

  • « Ds\Sequence::pop
  • Ds\Sequence::reduce »
  • PHP Manual
  • Sequence
  • Adds values to the end of the sequence

Ds\Sequence::push

(PECL ds >= 1.0.0)

Ds\Sequence::push — Adds values to the end of the sequence

Descripción

abstract public Ds\Sequence::push ( mixed ...$values ) : void

Adds values to the end of the sequence.

Parámetros

values

The values to add.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::push() example

<?php
$sequence = new \Ds\Vector();

$sequence->push("a");
$sequence->push("b");
$sequence->push("c", "d");
$sequence->push(...["e", "f"]);

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the sequence to a single value using a callback function

  • « Ds\Sequence::push
  • Ds\Sequence::remove »
  • PHP Manual
  • Sequence
  • Reduces the sequence to a single value using a callback function

Ds\Sequence::reduce

(PECL ds >= 1.0.0)

Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function

Descripción

abstract public Ds\Sequence::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the sequence to a single value using a callback function.

Parámetros

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

Valores devueltos

The return value of the final callback.

Ejemplos

Ejemplo #1 Ds\Sequence::reduce() with initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($sequence->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

El resultado del ejemplo sería algo similar a:

int(30)

Ejemplo #2 Ds\Sequence::reduce() without an initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

El resultado del ejemplo sería algo similar a:

int(21)


Removes and returns a value by index

  • « Ds\Sequence::reduce
  • Ds\Sequence::reverse »
  • PHP Manual
  • Sequence
  • Removes and returns a value by index

Ds\Sequence::remove

(PECL ds >= 1.0.0)

Ds\Sequence::remove — Removes and returns a value by index

Descripción

abstract public Ds\Sequence::remove ( int $index ) : mixed

Removes and returns a value by index.

Parámetros

index

The index of the value to remove.

Valores devueltos

The value that was removed.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Sequence::remove() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->remove(1));
var_dump($sequence->remove(0));
var_dump($sequence->remove(0));
?>

El resultado del ejemplo sería algo similar a:

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the sequence in-place

  • « Ds\Sequence::remove
  • Ds\Sequence::reversed »
  • PHP Manual
  • Sequence
  • Reverses the sequence in-place

Ds\Sequence::reverse

(PECL ds >= 1.0.0)

Ds\Sequence::reverse — Reverses the sequence in-place

Descripción

abstract public Ds\Sequence::reverse ( ) : void

Reverses the sequence in-place.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::reverse() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);
$sequence->reverse();

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • « Ds\Sequence::reverse
  • Ds\Sequence::rotate »
  • PHP Manual
  • Sequence
  • Returns a reversed copy

Ds\Sequence::reversed

(PECL ds >= 1.0.0)

Ds\Sequence::reversed — Returns a reversed copy

Descripción

abstract public Ds\Sequence::reversed ( ) : Ds\Sequence

Returns a reversed copy of the sequence.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A reversed copy of the sequence.

Nota:

The current instance is not affected.

Ejemplos

Ejemplo #1 Ds\Sequence::reversed() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

print_r($sequence->reversed());
print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the sequence by a given number of rotations

  • « Ds\Sequence::reversed
  • Ds\Sequence::set »
  • PHP Manual
  • Sequence
  • Rotates the sequence by a given number of rotations

Ds\Sequence::rotate

(PECL ds >= 1.0.0)

Ds\Sequence::rotate — Rotates the sequence by a given number of rotations

Descripción

abstract public Ds\Sequence::rotate ( int $rotations ) : void

Rotates the sequence by a given number of rotations, which is equivalent to successively calling $sequence->push($sequence->shift()) if the number of rotations is positive, or $sequence->unshift($sequence->pop()) if negative.

Parámetros

rotations

The number of times the sequence should be rotated.

Valores devueltos

No devuelve ningún valor.. The sequence of the current instance will be rotated.

Ejemplos

Ejemplo #1 Ds\Sequence::rotate() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d"]);

$sequence->rotate(1);  // "a" is shifted, then pushed.
print_r($sequence);

$sequence->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • « Ds\Sequence::rotate
  • Ds\Sequence::shift »
  • PHP Manual
  • Sequence
  • Updates a value at a given index

Ds\Sequence::set

(PECL ds >= 1.0.0)

Ds\Sequence::set — Updates a value at a given index

Descripción

abstract public Ds\Sequence::set ( int $index , mixed $value ) : void

Updates a value at a given index.

Parámetros

index

The index of the value to update.

value

The new value.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Sequence::set() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence->set(1, "_");
print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Ejemplo #2 Ds\Sequence::set() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence[1] = "_";
print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • « Ds\Sequence::set
  • Ds\Sequence::slice »
  • PHP Manual
  • Sequence
  • Removes and returns the first value

Ds\Sequence::shift

(PECL ds >= 1.0.0)

Ds\Sequence::shift — Removes and returns the first value

Descripción

abstract public Ds\Sequence::shift ( ) : mixed

Removes and returns the first value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value, which was removed.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Sequence::shift() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->shift());
var_dump($sequence->shift());
var_dump($sequence->shift());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-sequence of a given range

  • « Ds\Sequence::shift
  • Ds\Sequence::sort »
  • PHP Manual
  • Sequence
  • Returns a sub-sequence of a given range

Ds\Sequence::slice

(PECL ds >= 1.0.0)

Ds\Sequence::slice — Returns a sub-sequence of a given range

Descripción

abstract public Ds\Sequence::slice ( int $index , int $length = ? ) : Ds\Sequence

Creates a sub-sequence of a given range.

Parámetros

index

The index at which the sub-sequence starts.

If positive, the sequence will start at that index in the sequence. If negative, the sequence will start that far from the end.

length

If a length is given and is positive, the resulting sequence will have up to that many values in it. If the length results in an overflow, only values up to the end of the sequence will be included. If a length is given and is negative, the sequence will stop that many values from the end. If a length is not provided, the resulting sequence will contain all values between the index and the end of the sequence.

Valores devueltos

A sub-sequence of the given range.

Ejemplos

Ejemplo #1 Ds\Sequence::slice() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($sequence->slice(2));

// Slice from 1, for a length of 3
print_r($sequence->slice(1, 3));

// Slice from 1 onwards
print_r($sequence->slice(1));

// Slice from 2 from the end onwards
print_r($sequence->slice(-2));

// Slice from 1 to 1 from the end
print_r($sequence->slice(1, -1));
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the sequence in-place

  • « Ds\Sequence::slice
  • Ds\Sequence::sorted »
  • PHP Manual
  • Sequence
  • Sorts the sequence in-place

Ds\Sequence::sort

(PECL ds >= 1.0.0)

Ds\Sequence::sort — Sorts the sequence in-place

Descripción

abstract public Ds\Sequence::sort ( callable $comparator = ? ) : void

Sorts the sequence in-place, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::sort() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);
$sequence->sort();

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Sequence::sort() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sequence->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • « Ds\Sequence::sort
  • Ds\Sequence::sum »
  • PHP Manual
  • Sequence
  • Returns a sorted copy

Ds\Sequence::sorted

(PECL ds >= 1.0.0)

Ds\Sequence::sorted — Returns a sorted copy

Descripción

abstract public Ds\Sequence::sorted ( callable $comparator = ? ) : Ds\Sequence

Returns a sorted copy, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a sorted copy of the sequence.

Ejemplos

Ejemplo #1 Ds\Sequence::sorted() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($sequence->sorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Sequence::sorted() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $sequence->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the sequence

  • « Ds\Sequence::sorted
  • Ds\Sequence::unshift »
  • PHP Manual
  • Sequence
  • Returns the sum of all values in the sequence

Ds\Sequence::sum

(PECL ds >= 1.0.0)

Ds\Sequence::sum — Returns the sum of all values in the sequence

Descripción

abstract public Ds\Sequence::sum ( ) : int|float

Returns the sum of all values in the sequence.

Nota:

Arrays and objects are considered equal to zero when calculating the sum.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The sum of all the values in the sequence as either a float or int depending on the values in the sequence.

Ejemplos

Ejemplo #1 Ds\Sequence::sum() integer example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->sum());
?>

El resultado del ejemplo sería algo similar a:

int(6)

Ejemplo #2 Ds\Sequence::sum() float example

<?php
$sequence = new \Ds\Vector([1, 2.5, 3]);
var_dump($sequence->sum());
?>

El resultado del ejemplo sería algo similar a:

float(6.5)


Adds values to the front of the sequence

  • « Ds\Sequence::sum
  • Vector »
  • PHP Manual
  • Sequence
  • Adds values to the front of the sequence

Ds\Sequence::unshift

(PECL ds >= 1.0.0)

Ds\Sequence::unshift — Adds values to the front of the sequence

Descripción

abstract public Ds\Sequence::unshift ( mixed $values = ? ) : void

Adds values to the front of the sequence, moving all the current values forward to make room for the new values.

Parámetros

values

The values to add to the front of the sequence.

Nota:

Multiple values will be added in the same order that they are passed.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Sequence::unshift() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$sequence->unshift("a");
$sequence->unshift("b", "c");

print_r($sequence);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


La clase Vector

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Un Vector es una secuencia de valores en un buffer que crece y se encoge automáticamente. Esta es la más eficiente estructura secuencial debido a que el índice de un valor es un mapeo directo a su índice en el buffer, y el factor de crecimiento no está ligado a un multiplo o exponente específico.

Fortalezas

  • Soporta la sintaxis array (corchetes).
  • Usa menos memoria general que un array para el mismo número de valores.
  • Automáticamente libera la memoria asignada cuando su tamaño cae lo suficientemente bajo.
  • La capacidad no tiene que ser una potencia de 2.
  • get(),
set(),
push(),
pop() son todos O(1).

Debilidades

  • shift(),
unshift(),
insert() y
remove() son todos O(n).

Sinopsis de la Clase

Ds\Vector implements Ds\Sequence {
/* Constantes */
const int MIN_CAPACITY = 10 ;
/* Métodos */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Vector
public filter ( callable $callback = ? ) : Ds\Vector
public find ( mixed $value ) : mixed
public first ( ) : mixed
public get ( int $index ) : mixed
public insert ( int $index , mixed ...$values ) : void
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public map ( callable $callback ) : Ds\Vector
public merge ( mixed $values ) : Ds\Vector
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( int $index ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Vector
public rotate ( int $rotations ) : void
public set ( int $index , mixed $value ) : void
public shift ( ) : mixed
public slice ( int $index , int $length = ? ) : Ds\Vector
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Vector
public sum ( ) : int|float
public toArray ( ) : array
public unshift ( mixed $values = ? ) : void
}

Constantes predefinidas

Ds\Vector::MIN_CAPACITY

Tabla de contenidos

  • Ds\Vector::allocate — Allocates enough memory for a required capacity
  • Ds\Vector::apply — Updates all values by applying a callback function to each value
  • Ds\Vector::capacity — Returns the current capacity
  • Ds\Vector::clear — Removes all values
  • Ds\Vector::__construct — Creates a new instance
  • Ds\Vector::contains — Determines if the vector contains given values
  • Ds\Vector::copy — Returns a shallow copy of the vector
  • Ds\Vector::count — Returns the number of values in the collection
  • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include
  • Ds\Vector::find — Attempts to find a value's index
  • Ds\Vector::first — Returns the first value in the vector
  • Ds\Vector::get — Returns the value at a given index
  • Ds\Vector::insert — Inserts values at a given index
  • Ds\Vector::isEmpty — Returns whether the vector is empty
  • Ds\Vector::join — Joins all values together as a string
  • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Vector::last — Returns the last value
  • Ds\Vector::map — Returns the result of applying a callback to each value
  • Ds\Vector::merge — Returns the result of adding all given values to the vector
  • Ds\Vector::pop — Removes and returns the last value
  • Ds\Vector::push — Adds values to the end of the vector
  • Ds\Vector::reduce — Reduces the vector to a single value using a callback function
  • Ds\Vector::remove — Removes and returns a value by index
  • Ds\Vector::reverse — Reverses the vector in-place
  • Ds\Vector::reversed — Returns a reversed copy
  • Ds\Vector::rotate — Rotates the vector by a given number of rotations
  • Ds\Vector::set — Updates a value at a given index
  • Ds\Vector::shift — Removes and returns the first value
  • Ds\Vector::slice — Returns a sub-vector of a given range
  • Ds\Vector::sort — Sorts the vector in-place
  • Ds\Vector::sorted — Returns a sorted copy
  • Ds\Vector::sum — Returns the sum of all values in the vector
  • Ds\Vector::toArray — Converts the vector to an array
  • Ds\Vector::unshift — Adds values to the front of the vector


Allocates enough memory for a required capacity

  • « Vector
  • Ds\Vector::apply »
  • PHP Manual
  • Vector
  • Allocates enough memory for a required capacity

Ds\Vector::allocate

(PECL ds >= 1.0.0)

Ds\Vector::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Vector::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::allocate() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->allocate(100);
var_dump($vector->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(100)


Updates all values by applying a callback function to each value

  • « Ds\Vector::allocate
  • Ds\Vector::capacity »
  • PHP Manual
  • Vector
  • Updates all values by applying a callback function to each value

Ds\Vector::apply

(PECL ds >= 1.0.0)

Ds\Vector::apply — Updates all values by applying a callback function to each value

Descripción

public Ds\Vector::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the vector.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the vector.

The callback should return what the value should be replaced by.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::apply() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
$vector->apply(function($value) { return $value * 2; });

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • « Ds\Vector::apply
  • Ds\Vector::clear »
  • PHP Manual
  • Vector
  • Returns the current capacity

Ds\Vector::capacity

(PECL ds >= 1.0.0)

Ds\Vector::capacity — Returns the current capacity

Descripción

public Ds\Vector::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Vector::capacity() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->push(...range(1, 50));
var_dump($vector->capacity());

$vector[] = "a";
var_dump($vector->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(10)
int(50)
int(75)


Removes all values

  • « Ds\Vector::capacity
  • Ds\Vector::__construct »
  • PHP Manual
  • Vector
  • Removes all values

Ds\Vector::clear

(PECL ds >= 1.0.0)

Ds\Vector::clear — Removes all values

Descripción

public Ds\Vector::clear ( ) : void

Removes all values from the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::clear() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
print_r($vector);

$vector->clear();
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)


Creates a new instance

  • « Ds\Vector::clear
  • Ds\Vector::contains »
  • PHP Manual
  • Vector
  • Creates a new instance

Ds\Vector::__construct

(PECL ds >= 1.0.0)

Ds\Vector::__construct — Creates a new instance

Descripción

public Ds\Vector::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Vector::__construct() example

<?php
$vector = new \Ds\Vector();
var_dump($vector);

$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (0) {
}
object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the vector contains given values

  • « Ds\Vector::__construct
  • Ds\Vector::copy »
  • PHP Manual
  • Vector
  • Determines if the vector contains given values

Ds\Vector::contains

(PECL ds >= 1.0.0)

Ds\Vector::contains — Determines if the vector contains given values

Descripción

public Ds\Vector::contains ( mixed ...$values ) : bool

Determines if the vector contains all values.

Parámetros

values

Values to check.

Valores devueltos

false if any of the provided values are not in the vector, true otherwise.

Ejemplos

Ejemplo #1 Ds\Vector::contains() example

<?php
$vector = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($vector->contains('a'));                // true
var_dump($vector->contains('a', 'b'));           // true
var_dump($vector->contains('c', 'd'));           // false

var_dump($vector->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($vector->contains(1));                  // true
var_dump($vector->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Returns a shallow copy of the vector

  • « Ds\Vector::contains
  • Ds\Vector::count »
  • PHP Manual
  • Vector
  • Returns a shallow copy of the vector

Ds\Vector::copy

(PECL ds >= 1.0.0)

Ds\Vector::copy — Returns a shallow copy of the vector

Descripción

public Ds\Vector::copy ( ) : Ds\Vector

Returns a shallow copy of the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the vector.

Ejemplos

Ejemplo #1 Ds\Vector::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the collection

  • « Ds\Vector::copy
  • Ds\Vector::filter »
  • PHP Manual
  • Vector
  • Returns the number of values in the collection

Ds\Vector::count

(PECL ds >= 1.0.0)

Ds\Vector::count — Returns the number of values in the collection

See Countable::count()


Creates a new vector using a callable to determine which values to include

  • « Ds\Vector::count
  • Ds\Vector::find »
  • PHP Manual
  • Vector
  • Creates a new vector using a callable to determine which values to include

Ds\Vector::filter

(PECL ds >= 1.0.0)

Ds\Vector::filter — Creates a new vector using a callable to determine which values to include

Descripción

public Ds\Vector::filter ( callable $callback = ? ) : Ds\Vector

Creates a new vector using a callable to determine which values to include.

Parámetros

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

Valores devueltos

A new vector containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

Ejemplos

Ejemplo #1 Ds\Vector::filter() example using callback function

<?php
$vector = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($vector->filter(function($value) {
    return $value % 2 == 0;
}));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Ejemplo #2 Ds\Vector::filter() example without a callback function

<?php
$vector = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($vector->filter());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • « Ds\Vector::filter
  • Ds\Vector::first »
  • PHP Manual
  • Vector
  • Attempts to find a value's index

Ds\Vector::find

(PECL ds >= 1.0.0)

Ds\Vector::find — Attempts to find a value's index

Descripción

public Ds\Vector::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

Parámetros

value

The value to find.

Valores devueltos

The index of the value, or false if not found.

Nota:

Values will be compared by value and by type.

Ejemplos

Ejemplo #1 Ds\Vector::find() example

<?php
$vector = new \Ds\Vector(["a", 1, true]);

var_dump($vector->find("a")); // 0
var_dump($vector->find("b")); // false
var_dump($vector->find("1")); // false
var_dump($vector->find(1));   // 1
?>

El resultado del ejemplo sería algo similar a:

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the vector

  • « Ds\Vector::find
  • Ds\Vector::get »
  • PHP Manual
  • Vector
  • Returns the first value in the vector

Ds\Vector::first

(PECL ds >= 1.0.0)

Ds\Vector::first — Returns the first value in the vector

Descripción

public Ds\Vector::first ( ) : mixed

Returns the first value in the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value in the vector.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Vector::first() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->first());
?>

El resultado del ejemplo sería algo similar a:

int(1)


Returns the value at a given index

  • « Ds\Vector::first
  • Ds\Vector::insert »
  • PHP Manual
  • Vector
  • Returns the value at a given index

Ds\Vector::get

(PECL ds >= 1.0.0)

Ds\Vector::get — Returns the value at a given index

Descripción

public Ds\Vector::get ( int $index ) : mixed

Returns the value at a given index.

Parámetros

index

The index to access, starting at 0.

Valores devueltos

The value at the requested index.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Vector::get() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->get(0));
var_dump($vector->get(1));
var_dump($vector->get(2));
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"

Ejemplo #2 Ds\Vector::get() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector[0]);
var_dump($vector[1]);
var_dump($vector[2]);
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • « Ds\Vector::get
  • Ds\Vector::isEmpty »
  • PHP Manual
  • Vector
  • Inserts values at a given index

Ds\Vector::insert

(PECL ds >= 1.0.0)

Ds\Vector::insert — Inserts values at a given index

Descripción

public Ds\Vector::insert ( int $index , mixed ...$values ) : void

Inserts values into the vector at a given index.

Parámetros

index

The index at which to insert. 0 <= index <= count

Nota:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Vector::insert() example

<?php
$vector = new \Ds\Vector();

$vector->insert(0, "e");             // [e]
$vector->insert(1, "f");             // [e, f]
$vector->insert(2, "g");             // [e, f, g]
$vector->insert(0, "a", "b");        // [a, b, e, f, g]
$vector->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($vector);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Returns whether the vector is empty

  • « Ds\Vector::insert
  • Ds\Vector::join »
  • PHP Manual
  • Vector
  • Returns whether the vector is empty

Ds\Vector::isEmpty

(PECL ds >= 1.0.0)

Ds\Vector::isEmpty — Returns whether the vector is empty

Descripción

public Ds\Vector::isEmpty ( ) : bool

Returns whether the vector is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the vector is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Vector::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Joins all values together as a string

  • « Ds\Vector::isEmpty
  • Ds\Vector::jsonSerialize »
  • PHP Manual
  • Vector
  • Joins all values together as a string

Ds\Vector::join

(PECL ds >= 1.0.0)

Ds\Vector::join — Joins all values together as a string

Descripción

public Ds\Vector::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

Parámetros

glue

An optional string to separate each value.

Valores devueltos

All values of the vector joined together as a string.

Ejemplos

Ejemplo #1 Ds\Vector::join() example using a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join("|"));
?>

El resultado del ejemplo sería algo similar a:

string(11) "a|b|c|1|2|3"

Ejemplo #2 Ds\Vector::join() example without a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join());
?>

El resultado del ejemplo sería algo similar a:

string(11) "abc123"


Returns a representation that can be converted to JSON

  • « Ds\Vector::join
  • Ds\Vector::last »
  • PHP Manual
  • Vector
  • Returns a representation that can be converted to JSON

Ds\Vector::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns the last value

  • « Ds\Vector::jsonSerialize
  • Ds\Vector::map »
  • PHP Manual
  • Vector
  • Returns the last value

Ds\Vector::last

(PECL ds >= 1.0.0)

Ds\Vector::last — Returns the last value

Descripción

public Ds\Vector::last ( ) : mixed

Returns the last value in the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The last value in the vector.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Vector::last() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->last());
?>

El resultado del ejemplo sería algo similar a:

int(3)


Returns the result of applying a callback to each value

  • « Ds\Vector::last
  • Ds\Vector::merge »
  • PHP Manual
  • Vector
  • Returns the result of applying a callback to each value

Ds\Vector::map

(PECL ds >= 1.0.0)

Ds\Vector::map — Returns the result of applying a callback to each value

Descripción

public Ds\Vector::map ( callable $callback ) : Ds\Vector

Returns the result of applying a callback function to each value in the vector.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the vector.

The callable should return what the new value will be in the new vector.

Valores devueltos

The result of applying a callback to each value in the vector.

Nota:

The values of the current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Vector::map() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

print_r($vector->map(function($value) { return $value * 2; }));
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the vector

  • « Ds\Vector::map
  • Ds\Vector::pop »
  • PHP Manual
  • Vector
  • Returns the result of adding all given values to the vector

Ds\Vector::merge

(PECL ds >= 1.0.0)

Ds\Vector::merge — Returns the result of adding all given values to the vector

Descripción

public Ds\Vector::merge ( mixed $values ) : Ds\Vector

Returns the result of adding all given values to the vector.

Parámetros

values

A traversable object or an array.

Valores devueltos

The result of adding all given values to the vector, effectively the same as adding the values to a copy, then returning that copy.

Nota:

The current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Vector::merge() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->merge([4, 5, 6]));
var_dump($vector);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • « Ds\Vector::merge
  • Ds\Vector::push »
  • PHP Manual
  • Vector
  • Removes and returns the last value

Ds\Vector::pop

(PECL ds >= 1.0.0)

Ds\Vector::pop — Removes and returns the last value

Descripción

public Ds\Vector::pop ( ) : mixed

Removes and returns the last value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed last value.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Vector::pop() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->pop());
var_dump($vector->pop());
var_dump($vector->pop());
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(2)
int(1)


Adds values to the end of the vector

  • « Ds\Vector::pop
  • Ds\Vector::reduce »
  • PHP Manual
  • Vector
  • Adds values to the end of the vector

Ds\Vector::push

(PECL ds >= 1.0.0)

Ds\Vector::push — Adds values to the end of the vector

Descripción

public Ds\Vector::push ( mixed ...$values ) : void

Adds values to the end of the vector.

Parámetros

values

The values to add.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::push() example

<?php
$vector = new \Ds\Vector();

$vector->push("a");
$vector->push("b");
$vector->push("c", "d");
$vector->push(...["e", "f"]);

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the vector to a single value using a callback function

  • « Ds\Vector::push
  • Ds\Vector::remove »
  • PHP Manual
  • Vector
  • Reduces the vector to a single value using a callback function

Ds\Vector::reduce

(PECL ds >= 1.0.0)

Ds\Vector::reduce — Reduces the vector to a single value using a callback function

Descripción

public Ds\Vector::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the vector to a single value using a callback function.

Parámetros

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

Valores devueltos

The return value of the final callback.

Ejemplos

Ejemplo #1 Ds\Vector::reduce() with initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($vector->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

El resultado del ejemplo sería algo similar a:

int(30)

Ejemplo #2 Ds\Vector::reduce() without an initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

El resultado del ejemplo sería algo similar a:

int(21)


Removes and returns a value by index

  • « Ds\Vector::reduce
  • Ds\Vector::reverse »
  • PHP Manual
  • Vector
  • Removes and returns a value by index

Ds\Vector::remove

(PECL ds >= 1.0.0)

Ds\Vector::remove — Removes and returns a value by index

Descripción

public Ds\Vector::remove ( int $index ) : mixed

Removes and returns a value by index.

Parámetros

index

The index of the value to remove.

Valores devueltos

The value that was removed.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Vector::remove() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->remove(1));
var_dump($vector->remove(0));
var_dump($vector->remove(0));
?>

El resultado del ejemplo sería algo similar a:

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the vector in-place

  • « Ds\Vector::remove
  • Ds\Vector::reversed »
  • PHP Manual
  • Vector
  • Reverses the vector in-place

Ds\Vector::reverse

(PECL ds >= 1.0.0)

Ds\Vector::reverse — Reverses the vector in-place

Descripción

public Ds\Vector::reverse ( ) : void

Reverses the vector in-place.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::reverse() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);
$vector->reverse();

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • « Ds\Vector::reverse
  • Ds\Vector::rotate »
  • PHP Manual
  • Vector
  • Returns a reversed copy

Ds\Vector::reversed

(PECL ds >= 1.0.0)

Ds\Vector::reversed — Returns a reversed copy

Descripción

public Ds\Vector::reversed ( ) : Ds\Vector

Returns a reversed copy of the vector.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A reversed copy of the vector.

Nota:

The current instance is not affected.

Ejemplos

Ejemplo #1 Ds\Vector::reversed() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

print_r($vector->reversed());
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the vector by a given number of rotations

  • « Ds\Vector::reversed
  • Ds\Vector::set »
  • PHP Manual
  • Vector
  • Rotates the vector by a given number of rotations

Ds\Vector::rotate

(PECL ds >= 1.0.0)

Ds\Vector::rotate — Rotates the vector by a given number of rotations

Descripción

public Ds\Vector::rotate ( int $rotations ) : void

Rotates the vector by a given number of rotations, which is equivalent to successively calling $vector->push($vector->shift()) if the number of rotations is positive, or $vector->unshift($vector->pop()) if negative.

Parámetros

rotations

The number of times the vector should be rotated.

Valores devueltos

No devuelve ningún valor.. The vector of the current instance will be rotated.

Ejemplos

Ejemplo #1 Ds\Vector::rotate() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d"]);

$vector->rotate(1);  // "a" is shifted, then pushed.
print_r($vector);

$vector->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • « Ds\Vector::rotate
  • Ds\Vector::shift »
  • PHP Manual
  • Vector
  • Updates a value at a given index

Ds\Vector::set

(PECL ds >= 1.0.0)

Ds\Vector::set — Updates a value at a given index

Descripción

public Ds\Vector::set ( int $index , mixed $value ) : void

Updates a value at a given index.

Parámetros

index

The index of the value to update.

value

The new value.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Vector::set() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector->set(1, "_");
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Ejemplo #2 Ds\Vector::set() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector[1] = "_";
print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • « Ds\Vector::set
  • Ds\Vector::slice »
  • PHP Manual
  • Vector
  • Removes and returns the first value

Ds\Vector::shift

(PECL ds >= 1.0.0)

Ds\Vector::shift — Removes and returns the first value

Descripción

public Ds\Vector::shift ( ) : mixed

Removes and returns the first value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value, which was removed.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Vector::shift() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->shift());
var_dump($vector->shift());
var_dump($vector->shift());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-vector of a given range

  • « Ds\Vector::shift
  • Ds\Vector::sort »
  • PHP Manual
  • Vector
  • Returns a sub-vector of a given range

Ds\Vector::slice

(PECL ds >= 1.0.0)

Ds\Vector::slice — Returns a sub-vector of a given range

Descripción

public Ds\Vector::slice ( int $index , int $length = ? ) : Ds\Vector

Creates a sub-vector of a given range.

Parámetros

index

The index at which the sub-vector starts.

If positive, the vector will start at that index in the vector. If negative, the vector will start that far from the end.

length

If a length is given and is positive, the resulting vector will have up to that many values in it. If the length results in an overflow, only values up to the end of the vector will be included. If a length is given and is negative, the vector will stop that many values from the end. If a length is not provided, the resulting vector will contain all values between the index and the end of the vector.

Valores devueltos

A sub-vector of the given range.

Ejemplos

Ejemplo #1 Ds\Vector::slice() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($vector->slice(2));

// Slice from 1, for a length of 3
print_r($vector->slice(1, 3));

// Slice from 1 onwards
print_r($vector->slice(1));

// Slice from 2 from the end onwards
print_r($vector->slice(-2));

// Slice from 1 to 1 from the end
print_r($vector->slice(1, -1));
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the vector in-place

  • « Ds\Vector::slice
  • Ds\Vector::sorted »
  • PHP Manual
  • Vector
  • Sorts the vector in-place

Ds\Vector::sort

(PECL ds >= 1.0.0)

Ds\Vector::sort — Sorts the vector in-place

Descripción

public Ds\Vector::sort ( callable $comparator = ? ) : void

Sorts the vector in-place, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::sort() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);
$vector->sort();

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Vector::sort() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$vector->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • « Ds\Vector::sort
  • Ds\Vector::sum »
  • PHP Manual
  • Vector
  • Returns a sorted copy

Ds\Vector::sorted

(PECL ds >= 1.0.0)

Ds\Vector::sorted — Returns a sorted copy

Descripción

public Ds\Vector::sorted ( callable $comparator = ? ) : Ds\Vector

Returns a sorted copy, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a sorted copy of the vector.

Ejemplos

Ejemplo #1 Ds\Vector::sorted() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($vector->sorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Vector::sorted() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $vector->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the vector

  • « Ds\Vector::sorted
  • Ds\Vector::toArray »
  • PHP Manual
  • Vector
  • Returns the sum of all values in the vector

Ds\Vector::sum

(PECL ds >= 1.0.0)

Ds\Vector::sum — Returns the sum of all values in the vector

Descripción

public Ds\Vector::sum ( ) : int|float

Returns the sum of all values in the vector.

Nota:

Arrays and objects are considered equal to zero when calculating the sum.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The sum of all the values in the vector as either a float or int depending on the values in the vector.

Ejemplos

Ejemplo #1 Ds\Vector::sum() integer example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->sum());
?>

El resultado del ejemplo sería algo similar a:

int(6)

Ejemplo #2 Ds\Vector::sum() float example

<?php
$vector = new \Ds\Vector([1, 2.5, 3]);
var_dump($vector->sum());
?>

El resultado del ejemplo sería algo similar a:

float(6.5)


Converts the vector to an array

  • « Ds\Vector::sum
  • Ds\Vector::unshift »
  • PHP Manual
  • Vector
  • Converts the vector to an array

Ds\Vector::toArray

(PECL ds >= 1.0.0)

Ds\Vector::toArray — Converts the vector to an array

Descripción

public Ds\Vector::toArray ( ) : array

Converts the vector to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the vector.

Ejemplos

Ejemplo #1 Ds\Vector::toArray() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Adds values to the front of the vector

  • « Ds\Vector::toArray
  • Deque »
  • PHP Manual
  • Vector
  • Adds values to the front of the vector

Ds\Vector::unshift

(PECL ds >= 1.0.0)

Ds\Vector::unshift — Adds values to the front of the vector

Descripción

public Ds\Vector::unshift ( mixed $values = ? ) : void

Adds values to the front of the vector, moving all the current values forward to make room for the new values.

Parámetros

values

The values to add to the front of the vector.

Nota:

Multiple values will be added in the same order that they are passed.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Vector::unshift() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$vector->unshift("a");
$vector->unshift("b", "c");

print_r($vector);
?>

El resultado del ejemplo sería algo similar a:

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


La clase Deque

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Un Deque (pronunciado “deck”) es una secuencia de valores en un búfer contiguo que crece y se contrae automáticamente. El nombre es una abreviación inglesa común de “double-ended queue” (cola de doble final) y es usado internamente por Ds\Queue.

Dos punteros son usados para mantener el seguimiento de una cabecera y una cola. Los punteros pueden “envolver alrededor” el final del búfer, lo cual evita la necesidad de mover otros valores alrededor para hacer un espacio. Esto permite que hacer cambios y deshacer cambios sean muy rápidos?—? algo en que Ds\Vector no puede competir.

Accediendo a un valor por el índice requiere una traducción entre el índice y su posición correspondiente en el búfer: ((cabecera + posición) % capacidad).

Fortalezas

  • Soporta la sintaxis array (corchetes).
  • Utiliza menos memoria total que un array para el mismo número de valores.
  • Automáticamente libera la memoria asignada cuando su tamaño cae lo suficientemente bajo.
  • get(),
set(),
push(),
pop(),
shift(), y
unshift() son todos O(1).

Debilidades

  • La capacidad debe ser una potencia de 2.
  • insert() y remove() son O(n).

Sinopsis de la Clase

Ds\Deque implements Ds\Sequence {
/* Constantes */
const int MIN_CAPACITY = 8 ;
/* Métodos */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Deque
public filter ( callable $callback = ? ) : Ds\Deque
public find ( mixed $value ) : mixed
public first ( ) : mixed
public get ( int $index ) : mixed
public insert ( int $index , mixed ...$values ) : void
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public map ( callable $callback ) : Ds\Deque
public merge ( mixed $values ) : Ds\Deque
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( int $index ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Deque
public rotate ( int $rotations ) : void
public set ( int $index , mixed $value ) : void
public shift ( ) : mixed
public slice ( int $index , int $length = ? ) : Ds\Deque
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Deque
public sum ( ) : int|float
public toArray ( ) : array
public unshift ( mixed $values = ? ) : void
}

Constantes predefinidas

Ds\Deque::MIN_CAPACITY

Tabla de contenidos

  • Ds\Deque::allocate — Allocates enough memory for a required capacity
  • Ds\Deque::apply — Updates all values by applying a callback function to each value
  • Ds\Deque::capacity — Returns the current capacity
  • Ds\Deque::clear — Removes all values from the deque
  • Ds\Deque::__construct — Creates a new instance
  • Ds\Deque::contains — Determines if the deque contains given values
  • Ds\Deque::copy — Returns a shallow copy of the deque
  • Ds\Deque::count — Returns the number of values in the collection
  • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include
  • Ds\Deque::find — Attempts to find a value's index
  • Ds\Deque::first — Returns the first value in the deque
  • Ds\Deque::get — Returns the value at a given index
  • Ds\Deque::insert — Inserts values at a given index
  • Ds\Deque::isEmpty — Returns whether the deque is empty
  • Ds\Deque::join — Joins all values together as a string
  • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Deque::last — Returns the last value
  • Ds\Deque::map — Returns the result of applying a callback to each value
  • Ds\Deque::merge — Returns the result of adding all given values to the deque
  • Ds\Deque::pop — Removes and returns the last value
  • Ds\Deque::push — Adds values to the end of the deque
  • Ds\Deque::reduce — Reduces the deque to a single value using a callback function
  • Ds\Deque::remove — Removes and returns a value by index
  • Ds\Deque::reverse — Reverses the deque in-place
  • Ds\Deque::reversed — Returns a reversed copy
  • Ds\Deque::rotate — Rotates the deque by a given number of rotations
  • Ds\Deque::set — Updates a value at a given index
  • Ds\Deque::shift — Removes and returns the first value
  • Ds\Deque::slice — Returns a sub-deque of a given range
  • Ds\Deque::sort — Sorts the deque in-place
  • Ds\Deque::sorted — Returns a sorted copy
  • Ds\Deque::sum — Returns the sum of all values in the deque
  • Ds\Deque::toArray — Converts the deque to an array
  • Ds\Deque::unshift — Adds values to the front of the deque


Allocates enough memory for a required capacity

  • « Deque
  • Ds\Deque::apply »
  • PHP Manual
  • Deque
  • Allocates enough memory for a required capacity

Ds\Deque::allocate

(PECL ds >= 1.0.0)

Ds\Deque::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Deque::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::allocate() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->allocate(100);
var_dump($deque->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)
int(128)


Updates all values by applying a callback function to each value

  • « Ds\Deque::allocate
  • Ds\Deque::capacity »
  • PHP Manual
  • Deque
  • Updates all values by applying a callback function to each value

Ds\Deque::apply

(PECL ds >= 1.0.0)

Ds\Deque::apply — Updates all values by applying a callback function to each value

Descripción

public Ds\Deque::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the deque.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the deque.

The callback should return what the value should be replaced by.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::apply() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
$deque->apply(function($value) { return $value * 2; });

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • « Ds\Deque::apply
  • Ds\Deque::clear »
  • PHP Manual
  • Deque
  • Returns the current capacity

Ds\Deque::capacity

(PECL ds >= 1.0.0)

Ds\Deque::capacity — Returns the current capacity

Descripción

public Ds\Deque::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Deque::capacity() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->push(...range(1, 50));
var_dump($deque->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)
int(64)


Removes all values from the deque

  • « Ds\Deque::capacity
  • Ds\Deque::__construct »
  • PHP Manual
  • Deque
  • Removes all values from the deque

Ds\Deque::clear

(PECL ds >= 1.0.0)

Ds\Deque::clear — Removes all values from the deque

Descripción

public Ds\Deque::clear ( ) : void

Removes all values from the deque.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::clear() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
print_r($deque);

$deque->clear();
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
)


Creates a new instance

  • « Ds\Deque::clear
  • Ds\Deque::contains »
  • PHP Manual
  • Deque
  • Creates a new instance

Ds\Deque::__construct

(PECL ds >= 1.0.0)

Ds\Deque::__construct — Creates a new instance

Descripción

public Ds\Deque::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Deque::__construct() example

<?php
$deque = new \Ds\Deque();
var_dump($deque);

$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Deque)#2 (0) {
}
object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the deque contains given values

  • « Ds\Deque::__construct
  • Ds\Deque::copy »
  • PHP Manual
  • Deque
  • Determines if the deque contains given values

Ds\Deque::contains

(PECL ds >= 1.0.0)

Ds\Deque::contains — Determines if the deque contains given values

Descripción

public Ds\Deque::contains ( mixed ...$values ) : bool

Determines if the deque contains all values.

Parámetros

values

Values to check.

Valores devueltos

false if any of the provided values are not in the deque, true otherwise.

Ejemplos

Ejemplo #1 Ds\Deque::contains() example

<?php
$deque = new \Ds\Deque(['a', 'b', 'c', 1, 2, 3]);

var_dump($deque->contains('a'));                // true
var_dump($deque->contains('a', 'b'));           // true
var_dump($deque->contains('c', 'd'));           // false

var_dump($deque->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($deque->contains(1));                  // true
var_dump($deque->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Returns a shallow copy of the deque

  • « Ds\Deque::contains
  • Ds\Deque::count »
  • PHP Manual
  • Deque
  • Returns a shallow copy of the deque

Ds\Deque::copy

(PECL ds >= 1.0.0)

Ds\Deque::copy — Returns a shallow copy of the deque

Descripción

public Ds\Deque::copy ( ) : Ds\Deque

Returns a shallow copy of the deque.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A shallow copy of the deque.

Ejemplos

Ejemplo #1 Ds\Deque::copy() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the collection

  • « Ds\Deque::copy
  • Ds\Deque::filter »
  • PHP Manual
  • Deque
  • Returns the number of values in the collection

Ds\Deque::count

(PECL ds >= 1.0.0)

Ds\Deque::count — Returns the number of values in the collection

See Countable::count()


Creates a new deque using a callable to determine which values to include

  • « Ds\Deque::count
  • Ds\Deque::find »
  • PHP Manual
  • Deque
  • Creates a new deque using a callable to determine which values to include

Ds\Deque::filter

(PECL ds >= 1.0.0)

Ds\Deque::filter — Creates a new deque using a callable to determine which values to include

Descripción

public Ds\Deque::filter ( callable $callback = ? ) : Ds\Deque

Creates a new deque using a callable to determine which values to include.

Parámetros

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

Valores devueltos

A new deque containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

Ejemplos

Ejemplo #1 Ds\Deque::filter() example using callback function

<?php
$deque = new \Ds\Deque([1, 2, 3, 4, 5]);

var_dump($deque->filter(function($value) {
    return $value % 2 == 0;
}));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Deque)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Ejemplo #2 Ds\Deque::filter() example without a callback function

<?php
$deque = new \Ds\Deque([0, 1, 'a', true, false]);

var_dump($deque->filter());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • « Ds\Deque::filter
  • Ds\Deque::first »
  • PHP Manual
  • Deque
  • Attempts to find a value's index

Ds\Deque::find

(PECL ds >= 1.0.0)

Ds\Deque::find — Attempts to find a value's index

Descripción

public Ds\Deque::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

Parámetros

value

The value to find.

Valores devueltos

The index of the value, or false if not found.

Nota:

Values will be compared by value and by type.

Ejemplos

Ejemplo #1 Ds\Deque::find() example

<?php
$deque = new \Ds\Deque(["a", 1, true]);

var_dump($deque->find("a")); // 0
var_dump($deque->find("b")); // false
var_dump($deque->find("1")); // false
var_dump($deque->find(1));   // 1
?>

El resultado del ejemplo sería algo similar a:

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the deque

  • « Ds\Deque::find
  • Ds\Deque::get »
  • PHP Manual
  • Deque
  • Returns the first value in the deque

Ds\Deque::first

(PECL ds >= 1.0.0)

Ds\Deque::first — Returns the first value in the deque

Descripción

public Ds\Deque::first ( ) : mixed

Returns the first value in the deque.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value in the deque.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Deque::first() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->first());
?>

El resultado del ejemplo sería algo similar a:

int(1)


Returns the value at a given index

  • « Ds\Deque::first
  • Ds\Deque::insert »
  • PHP Manual
  • Deque
  • Returns the value at a given index

Ds\Deque::get

(PECL ds >= 1.0.0)

Ds\Deque::get — Returns the value at a given index

Descripción

public Ds\Deque::get ( int $index ) : mixed

Returns the value at a given index.

Parámetros

index

The index to access, starting at 0.

Valores devueltos

The value at the requested index.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Deque::get() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->get(0));
var_dump($deque->get(1));
var_dump($deque->get(2));
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"

Ejemplo #2 Ds\Deque::get() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque[0]);
var_dump($deque[1]);
var_dump($deque[2]);
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • « Ds\Deque::get
  • Ds\Deque::isEmpty »
  • PHP Manual
  • Deque
  • Inserts values at a given index

Ds\Deque::insert

(PECL ds >= 1.0.0)

Ds\Deque::insert — Inserts values at a given index

Descripción

public Ds\Deque::insert ( int $index , mixed ...$values ) : void

Inserts values into the deque at a given index.

Parámetros

index

The index at which to insert. 0 <= index <= count

Nota:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Deque::insert() example

<?php
$deque = new \Ds\Deque();

$deque->insert(0, "e");             // [e]
$deque->insert(1, "f");             // [e, f]
$deque->insert(2, "g");             // [e, f, g]
$deque->insert(0, "a", "b");        // [a, b, e, f, g]
$deque->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($deque);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Deque)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Returns whether the deque is empty

  • « Ds\Deque::insert
  • Ds\Deque::join »
  • PHP Manual
  • Deque
  • Returns whether the deque is empty

Ds\Deque::isEmpty

(PECL ds >= 1.0.0)

Ds\Deque::isEmpty — Returns whether the deque is empty

Descripción

public Ds\Deque::isEmpty ( ) : bool

Returns whether the deque is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the deque is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Deque::isEmpty() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = new \Ds\Deque();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Joins all values together as a string

  • « Ds\Deque::isEmpty
  • Ds\Deque::jsonSerialize »
  • PHP Manual
  • Deque
  • Joins all values together as a string

Ds\Deque::join

(PECL ds >= 1.0.0)

Ds\Deque::join — Joins all values together as a string

Descripción

public Ds\Deque::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

Parámetros

glue

An optional string to separate each value.

Valores devueltos

All values of the deque joined together as a string.

Ejemplos

Ejemplo #1 Ds\Deque::join() example using a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join("|"));
?>

El resultado del ejemplo sería algo similar a:

string(11) "a|b|c|1|2|3"

Ejemplo #2 Ds\Deque::join() example without a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join());
?>

El resultado del ejemplo sería algo similar a:

string(11) "abc123"


Returns a representation that can be converted to JSON

  • « Ds\Deque::join
  • Ds\Deque::last »
  • PHP Manual
  • Deque
  • Returns a representation that can be converted to JSON

Ds\Deque::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns the last value

  • « Ds\Deque::jsonSerialize
  • Ds\Deque::map »
  • PHP Manual
  • Deque
  • Returns the last value

Ds\Deque::last

(PECL ds >= 1.0.0)

Ds\Deque::last — Returns the last value

Descripción

public Ds\Deque::last ( ) : mixed

Returns the last value in the deque.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The last value in the deque.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Deque::last() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->last());
?>

El resultado del ejemplo sería algo similar a:

int(3)


Returns the result of applying a callback to each value

  • « Ds\Deque::last
  • Ds\Deque::merge »
  • PHP Manual
  • Deque
  • Returns the result of applying a callback to each value

Ds\Deque::map

(PECL ds >= 1.0.0)

Ds\Deque::map — Returns the result of applying a callback to each value

Descripción

public Ds\Deque::map ( callable $callback ) : Ds\Deque

Returns the result of applying a callback function to each value in the deque.

Parámetros

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the deque.

The callable should return what the new value will be in the new deque.

Valores devueltos

The result of applying a callback to each value in the deque.

Nota:

The values of the current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Deque::map() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

print_r($deque->map(function($value) { return $value * 2; }));
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the deque

  • « Ds\Deque::map
  • Ds\Deque::pop »
  • PHP Manual
  • Deque
  • Returns the result of adding all given values to the deque

Ds\Deque::merge

(PECL ds >= 1.0.0)

Ds\Deque::merge — Returns the result of adding all given values to the deque

Descripción

public Ds\Deque::merge ( mixed $values ) : Ds\Deque

Returns the result of adding all given values to the deque.

Parámetros

values

A traversable object or an array.

Valores devueltos

The result of adding all given values to the deque, effectively the same as adding the values to a copy, then returning that copy.

Nota:

The current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Deque::merge() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->merge([4, 5, 6]));
var_dump($deque);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Deque)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Deque)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • « Ds\Deque::merge
  • Ds\Deque::push »
  • PHP Manual
  • Deque
  • Removes and returns the last value

Ds\Deque::pop

(PECL ds >= 1.0.0)

Ds\Deque::pop — Removes and returns the last value

Descripción

public Ds\Deque::pop ( ) : mixed

Removes and returns the last value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed last value.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Deque::pop() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->pop());
var_dump($deque->pop());
var_dump($deque->pop());
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(2)
int(1)


Adds values to the end of the deque

  • « Ds\Deque::pop
  • Ds\Deque::reduce »
  • PHP Manual
  • Deque
  • Adds values to the end of the deque

Ds\Deque::push

(PECL ds >= 1.0.0)

Ds\Deque::push — Adds values to the end of the deque

Descripción

public Ds\Deque::push ( mixed ...$values ) : void

Adds values to the end of the deque.

Parámetros

values

The values to add.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::push() example

<?php
$deque = new \Ds\Deque();

$deque->push("a");
$deque->push("b");
$deque->push("c", "d");
$deque->push(...["e", "f"]);

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the deque to a single value using a callback function

  • « Ds\Deque::push
  • Ds\Deque::remove »
  • PHP Manual
  • Deque
  • Reduces the deque to a single value using a callback function

Ds\Deque::reduce

(PECL ds >= 1.0.0)

Ds\Deque::reduce — Reduces the deque to a single value using a callback function

Descripción

public Ds\Deque::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the deque to a single value using a callback function.

Parámetros

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

Valores devueltos

The return value of the final callback.

Ejemplos

Ejemplo #1 Ds\Deque::reduce() with initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($deque->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

El resultado del ejemplo sería algo similar a:

int(30)

Ejemplo #2 Ds\Deque::reduce() without an initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

El resultado del ejemplo sería algo similar a:

int(21)


Removes and returns a value by index

  • « Ds\Deque::reduce
  • Ds\Deque::reverse »
  • PHP Manual
  • Deque
  • Removes and returns a value by index

Ds\Deque::remove

(PECL ds >= 1.0.0)

Ds\Deque::remove — Removes and returns a value by index

Descripción

public Ds\Deque::remove ( int $index ) : mixed

Removes and returns a value by index.

Parámetros

index

The index of the value to remove.

Valores devueltos

The value that was removed.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Deque::remove() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->remove(1));
var_dump($deque->remove(0));
var_dump($deque->remove(0));
?>

El resultado del ejemplo sería algo similar a:

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the deque in-place

  • « Ds\Deque::remove
  • Ds\Deque::reversed »
  • PHP Manual
  • Deque
  • Reverses the deque in-place

Ds\Deque::reverse

(PECL ds >= 1.0.0)

Ds\Deque::reverse — Reverses the deque in-place

Descripción

public Ds\Deque::reverse ( ) : void

Reverses the deque in-place.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::reverse() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);
$deque->reverse();

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • « Ds\Deque::reverse
  • Ds\Deque::rotate »
  • PHP Manual
  • Deque
  • Returns a reversed copy

Ds\Deque::reversed

(PECL ds >= 1.0.0)

Ds\Deque::reversed — Returns a reversed copy

Descripción

public Ds\Deque::reversed ( ) : Ds\Deque

Returns a reversed copy of the deque.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A reversed copy of the deque.

Nota:

The current instance is not affected.

Ejemplos

Ejemplo #1 Ds\Deque::reversed() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

print_r($deque->reversed());
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the deque by a given number of rotations

  • « Ds\Deque::reversed
  • Ds\Deque::set »
  • PHP Manual
  • Deque
  • Rotates the deque by a given number of rotations

Ds\Deque::rotate

(PECL ds >= 1.0.0)

Ds\Deque::rotate — Rotates the deque by a given number of rotations

Descripción

public Ds\Deque::rotate ( int $rotations ) : void

Rotates the deque by a given number of rotations, which is equivalent to successively calling $deque->push($deque->shift()) if the number of rotations is positive, or $deque->unshift($deque->pop()) if negative.

Parámetros

rotations

The number of times the deque should be rotated.

Valores devueltos

No devuelve ningún valor.. The deque of the current instance will be rotated.

Ejemplos

Ejemplo #1 Ds\Deque::rotate() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d"]);

$deque->rotate(1);  // "a" is shifted, then pushed.
print_r($deque);

$deque->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Deque Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • « Ds\Deque::rotate
  • Ds\Deque::shift »
  • PHP Manual
  • Deque
  • Updates a value at a given index

Ds\Deque::set

(PECL ds >= 1.0.0)

Ds\Deque::set — Updates a value at a given index

Descripción

public Ds\Deque::set ( int $index , mixed $value ) : void

Updates a value at a given index.

Parámetros

index

The index of the value to update.

value

The new value.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Deque::set() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque->set(1, "_");
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)

Ejemplo #2 Ds\Deque::set() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque[1] = "_";
print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • « Ds\Deque::set
  • Ds\Deque::slice »
  • PHP Manual
  • Deque
  • Removes and returns the first value

Ds\Deque::shift

(PECL ds >= 1.0.0)

Ds\Deque::shift — Removes and returns the first value

Descripción

public Ds\Deque::shift ( ) : mixed

Removes and returns the first value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value, which was removed.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Deque::shift() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->shift());
var_dump($deque->shift());
var_dump($deque->shift());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-deque of a given range

  • « Ds\Deque::shift
  • Ds\Deque::sort »
  • PHP Manual
  • Deque
  • Returns a sub-deque of a given range

Ds\Deque::slice

(PECL ds >= 1.0.0)

Ds\Deque::slice — Returns a sub-deque of a given range

Descripción

public Ds\Deque::slice ( int $index , int $length = ? ) : Ds\Deque

Creates a sub-deque of a given range.

Parámetros

index

The index at which the sub-deque starts.

If positive, the deque will start at that index in the deque. If negative, the deque will start that far from the end.

length

If a length is given and is positive, the resulting deque will have up to that many values in it. If the length results in an overflow, only values up to the end of the deque will be included. If a length is given and is negative, the deque will stop that many values from the end. If a length is not provided, the resulting deque will contain all values between the index and the end of the deque.

Valores devueltos

A sub-deque of the given range.

Ejemplos

Ejemplo #1 Ds\Deque::slice() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($deque->slice(2));

// Slice from 1, for a length of 3
print_r($deque->slice(1, 3));

// Slice from 1 onwards
print_r($deque->slice(1));

// Slice from 2 from the end onwards
print_r($deque->slice(-2));

// Slice from 1 to 1 from the end
print_r($deque->slice(1, -1));
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Deque Object
(
    [0] => d
    [1] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the deque in-place

  • « Ds\Deque::slice
  • Ds\Deque::sorted »
  • PHP Manual
  • Deque
  • Sorts the deque in-place

Ds\Deque::sort

(PECL ds >= 1.0.0)

Ds\Deque::sort — Sorts the deque in-place

Descripción

public Ds\Deque::sort ( callable $comparator = ? ) : void

Sorts the deque in-place, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::sort() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);
$deque->sort();

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Deque::sort() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$deque->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • « Ds\Deque::sort
  • Ds\Deque::sum »
  • PHP Manual
  • Deque
  • Returns a sorted copy

Ds\Deque::sorted

(PECL ds >= 1.0.0)

Ds\Deque::sorted — Returns a sorted copy

Descripción

public Ds\Deque::sorted ( callable $comparator = ? ) : Ds\Deque

Returns a sorted copy, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a sorted copy of the deque.

Ejemplos

Ejemplo #1 Ds\Deque::sorted() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

print_r($deque->sorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Deque::sorted() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$sorted = $deque->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the deque

  • « Ds\Deque::sorted
  • Ds\Deque::toArray »
  • PHP Manual
  • Deque
  • Returns the sum of all values in the deque

Ds\Deque::sum

(PECL ds >= 1.0.0)

Ds\Deque::sum — Returns the sum of all values in the deque

Descripción

public Ds\Deque::sum ( ) : int|float

Returns the sum of all values in the deque.

Nota:

Arrays and objects are considered equal to zero when calculating the sum.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The sum of all the values in the deque as either a float or int depending on the values in the deque.

Ejemplos

Ejemplo #1 Ds\Deque::sum() integer example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->sum());
?>

El resultado del ejemplo sería algo similar a:

int(6)

Ejemplo #2 Ds\Deque::sum() float example

<?php
$deque = new \Ds\Deque([1, 2.5, 3]);
var_dump($deque->sum());
?>

El resultado del ejemplo sería algo similar a:

float(6.5)


Converts the deque to an array

  • « Ds\Deque::sum
  • Ds\Deque::unshift »
  • PHP Manual
  • Deque
  • Converts the deque to an array

Ds\Deque::toArray

(PECL ds >= 1.0.0)

Ds\Deque::toArray — Converts the deque to an array

Descripción

public Ds\Deque::toArray ( ) : array

Converts the deque to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the deque.

Ejemplos

Ejemplo #1 Ds\Deque::toArray() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Adds values to the front of the deque

  • « Ds\Deque::toArray
  • Map »
  • PHP Manual
  • Deque
  • Adds values to the front of the deque

Ds\Deque::unshift

(PECL ds >= 1.0.0)

Ds\Deque::unshift — Adds values to the front of the deque

Descripción

public Ds\Deque::unshift ( mixed $values = ? ) : void

Adds values to the front of the deque, moving all the current values forward to make room for the new values.

Parámetros

values

The values to add to the front of the deque.

Nota:

Multiple values will be added in the same order that they are passed.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Deque::unshift() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$deque->unshift("a");
$deque->unshift("b", "c");

print_r($deque);
?>

El resultado del ejemplo sería algo similar a:

Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


La clase Map

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Un Map es una colección secuencial de pares clave-valor, casi identico a un array usado en un contexto similar. Las claves pueden ser de cualquier tipo, pero deben ser únicos. Los valores se reemplazan si se agregan al mapa usando la misma clave.

Fortalezas

  • Las claves y valores pueden ser de cualquer tipo, incluyendo objetos.
  • Soporta la sintaxis array (corchetes).
  • Se mantiene el orden de inserción.
  • El rendimiento y la eficiencia de memoria son muy similares al de un array.
  • Automáticamente libera la memoria asignada cuando su tamaño cae lo suficientemente bajo.

Debilidades

  • No puede ser convertido a un array cuando los objetos son usados como claves.

Sinopsis de la Clase

Ds\Map implements Ds\Collection {
/* Constantes */
const int MIN_CAPACITY = 16 ;
/* Métodos */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Map
public diff ( Ds\Map $map ) : Ds\Map
public filter ( callable $callback = ? ) : Ds\Map
public first ( ) : Ds\Pair
public get ( mixed $key , mixed $default = ? ) : mixed
public hasKey ( mixed $key ) : bool
public hasValue ( mixed $value ) : bool
public intersect ( Ds\Map $map ) : Ds\Map
public isEmpty ( ) : bool
public keys ( ) : Ds\Set
public ksort ( callable $comparator = ? ) : void
public ksorted ( callable $comparator = ? ) : Ds\Map
public last ( ) : Ds\Pair
public map ( callable $callback ) : Ds\Map
public merge ( mixed $values ) : Ds\Map
public pairs ( ) : Ds\Sequence
public put ( mixed $key , mixed $value ) : void
public putAll ( mixed $pairs ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( mixed $key , mixed $default = ? ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Map
public skip ( int $position ) : Ds\Pair
public slice ( int $index , int $length = ? ) : Ds\Map
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Map
public sum ( ) : int|float
public toArray ( ) : array
public union ( Ds\Map $map ) : Ds\Map
public values ( ) : Ds\Sequence
public xor ( Ds\Map $map ) : Ds\Map
}

Constantes predefinidas

Ds\Map::MIN_CAPACITY

Tabla de contenidos

  • Ds\Map::allocate — Allocates enough memory for a required capacity
  • Ds\Map::apply — Updates all values by applying a callback function to each value
  • Ds\Map::capacity — Returns the current capacity
  • Ds\Map::clear — Removes all values
  • Ds\Map::__construct — Creates a new instance
  • Ds\Map::copy — Returns a shallow copy of the map
  • Ds\Map::count — Returns the number of values in the map
  • Ds\Map::diff — Creates a new map using keys that aren't in another map
  • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include
  • Ds\Map::first — Returns the first pair in the map
  • Ds\Map::get — Returns the value for a given key
  • Ds\Map::hasKey — Determines whether the map contains a given key
  • Ds\Map::hasValue — Determines whether the map contains a given value
  • Ds\Map::intersect — Creates a new map by intersecting keys with another map
  • Ds\Map::isEmpty — Returns whether the map is empty
  • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Map::keys — Returns a set of the map's keys
  • Ds\Map::ksort — Sorts the map in-place by key
  • Ds\Map::ksorted — Returns a copy, sorted by key
  • Ds\Map::last — Returns the last pair of the map
  • Ds\Map::map — Returns the result of applying a callback to each value
  • Ds\Map::merge — Returns the result of adding all given associations
  • Ds\Map::pairs — Returns a sequence containing all the pairs of the map
  • Ds\Map::put — Associates a key with a value
  • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array
  • Ds\Map::reduce — Reduces the map to a single value using a callback function
  • Ds\Map::remove — Removes and returns a value by key
  • Ds\Map::reverse — Reverses the map in-place
  • Ds\Map::reversed — Returns a reversed copy
  • Ds\Map::skip — Returns the pair at a given positional index
  • Ds\Map::slice — Returns a subset of the map defined by a starting index and length
  • Ds\Map::sort — Sorts the map in-place by value
  • Ds\Map::sorted — Returns a copy, sorted by value
  • Ds\Map::sum — Returns the sum of all values in the map
  • Ds\Map::toArray — Converts the map to an array
  • Ds\Map::union — Creates a new map using values from the current instance and another map
  • Ds\Map::values — Returns a sequence of the map's values
  • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both


Allocates enough memory for a required capacity

  • « Map
  • Ds\Map::apply »
  • PHP Manual
  • Map
  • Allocates enough memory for a required capacity

Ds\Map::allocate

(PECL ds >= 1.0.0)

Ds\Map::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Map::allocate ( int $capacity ) : void

Allocates enough memory for a required capacity.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::allocate() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());

$map->allocate(100);
var_dump($map->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(16)
int(128)


Updates all values by applying a callback function to each value

  • « Ds\Map::allocate
  • Ds\Map::capacity »
  • PHP Manual
  • Map
  • Updates all values by applying a callback function to each value

Ds\Map::apply

(PECL ds >= 1.0.0)

Ds\Map::apply — Updates all values by applying a callback function to each value

Descripción

public Ds\Map::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the map.

Parámetros

callback

callback ( mixed $key , mixed $value ) : mixed

A callable to apply to each value in the map.

The callback should return what the value should be replaced by.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::apply() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->apply(function($key, $value) { return $value * 2; });

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)


Returns the current capacity

  • « Ds\Map::apply
  • Ds\Map::clear »
  • PHP Manual
  • Map
  • Returns the current capacity

Ds\Map::capacity

(PECL ds >= 1.0.0)

Ds\Map::capacity — Returns the current capacity

Descripción

public Ds\Map::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Map::capacity() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(16)


Removes all values

  • « Ds\Map::capacity
  • Ds\Map::__construct »
  • PHP Manual
  • Map
  • Removes all values

Ds\Map::clear

(PECL ds >= 1.0.0)

Ds\Map::clear — Removes all values

Descripción

public Ds\Map::clear ( ) : void

Removes all values from the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::clear() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);
print_r($map);

$map->clear();
print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map Object
(
)


Creates a new instance

  • « Ds\Map::clear
  • Ds\Map::copy »
  • PHP Manual
  • Map
  • Creates a new instance

Ds\Map::__construct

(PECL ds >= 1.0.0)

Ds\Map::__construct — Creates a new instance

Descripción

public Ds\Map::__construct ( mixed ...$values )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Map::__construct() example

<?php
$map = new \Ds\Map();
var_dump($map);

$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#1 (0) {
}
object(Ds\Map)#2 (3) {
  [0]=>
  object(Ds\Pair)#1 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#3 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}


Returns a shallow copy of the map

  • « Ds\Map::__construct
  • Ds\Map::count »
  • PHP Manual
  • Map
  • Returns a shallow copy of the map

Ds\Map::copy

(PECL ds >= 1.0.0)

Ds\Map::copy — Returns a shallow copy of the map

Descripción

public Ds\Map::copy ( ) : Ds\Map

Returns a shallow copy of the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the map.

Ejemplos

Ejemplo #1 Ds\Map::copy() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map->copy());
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Returns the number of values in the map

  • « Ds\Map::copy
  • Ds\Map::diff »
  • PHP Manual
  • Map
  • Returns the number of values in the map

Ds\Map::count

(PECL ds >= 1.0.0)

Ds\Map::count — Returns the number of values in the map

See Countable::count()


Creates a new map using keys that aren't in another map

  • « Ds\Map::count
  • Ds\Map::filter »
  • PHP Manual
  • Map
  • Creates a new map using keys that aren't in another map

Ds\Map::diff

(PECL ds >= 1.0.0)

Ds\Map::diff — Creates a new map using keys that aren't in another map

Descripción

public Ds\Map::diff ( Ds\Map $map ) : Ds\Map

Returns the result of removing all keys from the current instance that are present in a given map.

A \ B = {x ? A | x ? B}

Parámetros

map

The map containing the keys to exclude in the resulting map.

Valores devueltos

The result of removing all keys from the current instance that are present in a given map.

See Also

  • » Compliment on Wikipedia

Ejemplos

Ejemplo #1 Ds\Map::diff() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->diff($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#3 (1) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
}


Creates a new map using a callable to determine which pairs to include

  • « Ds\Map::diff
  • Ds\Map::first »
  • PHP Manual
  • Map
  • Creates a new map using a callable to determine which pairs to include

Ds\Map::filter

(PECL ds >= 1.0.0)

Ds\Map::filter — Creates a new map using a callable to determine which pairs to include

Descripción

public Ds\Map::filter ( callable $callback = ? ) : Ds\Map

Creates a new map using a callable to determine which pairs to include.

Parámetros

callback

callback ( mixed $key , mixed $value ) : bool

Optional callable which returns true if the pair should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

Valores devueltos

A new map containing all the pairs for which either the callback returned true, or all values that convert to true if a callback was not provided.

Ejemplos

Ejemplo #1 Ds\Map::filter() example using callback function

<?php
$map = new \Ds\Map(["a", "b", "c", "d", "e"]);

var_dump($map->filter(function($key, $value) {
    return $key % 2 == 0;
}));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#3 (3) {
  [0]=>
  object(Ds\Pair)#2 (2) {
    ["key"]=>
    int(0)
    ["value"]=>
    string(1) "a"
  }
  [1]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    int(2)
    ["value"]=>
    string(1) "c"
  }
  [2]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    int(4)
    ["value"]=>
    string(1) "e"
  }
}

Ejemplo #2 Ds\Map::filter() example without a callback function

<?php
$map = new \Ds\Map(["a" => 0, "b" => 1, "c" => true, "d" => false]);

var_dump($map->filter());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Returns the first pair in the map

  • « Ds\Map::filter
  • Ds\Map::get »
  • PHP Manual
  • Map
  • Returns the first pair in the map

Ds\Map::first

(PECL ds >= 1.0.0)

Ds\Map::first — Returns the first pair in the map

Descripción

public Ds\Map::first ( ) : Ds\Pair

Returns the first pair in the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first pair in the map.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Map::first() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->first());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}


Returns the value for a given key

  • « Ds\Map::first
  • Ds\Map::hasKey »
  • PHP Manual
  • Map
  • Returns the value for a given key

Ds\Map::get

(PECL ds >= 1.0.0)

Ds\Map::get — Returns the value for a given key

Descripción

public Ds\Map::get ( mixed $key , mixed $default = ? ) : mixed

Returns the value for a given key, or an optional default value if the key could not be found.

Nota:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Nota:

You can also use array syntax to access values by key, eg. $map["key"].

Precaución

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Parámetros

key

The key to look up.

default

The optional default value, returned if the key could not be found.

Valores devueltos

The value mapped to the given key, or the default value if provided and the key could not be found in the map.

Errores/Excepciones

OutOfBoundsException if the key could not be found and a default value was not provided.

Ejemplos

Ejemplo #1 Ds\Map::get() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->get("a"));       // 1
var_dump($map->get("d", 10));   // 10 (default used)
?>

El resultado del ejemplo sería algo similar a:

int(1)
int(10)

Ejemplo #2 Ds\Map::get() example using array syntax

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map["a"])); // 1
?>

El resultado del ejemplo sería algo similar a:

int(1)


Determines whether the map contains a given key

  • « Ds\Map::get
  • Ds\Map::hasValue »
  • PHP Manual
  • Map
  • Determines whether the map contains a given key

Ds\Map::hasKey

(PECL ds >= 1.0.0)

Ds\Map::hasKey — Determines whether the map contains a given key

Descripción

public Ds\Map::hasKey ( mixed $key ) : bool

Determines whether the map contains a given key.

Parámetros

key

The key to look for.

Valores devueltos

Returns true if the key could found, false otherwise.

Ejemplos

Ejemplo #1 Ds\Map::hasKey() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasKey("a")); // true
var_dump($map->hasKey("e")); // false
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)


Determines whether the map contains a given value

  • « Ds\Map::hasKey
  • Ds\Map::intersect »
  • PHP Manual
  • Map
  • Determines whether the map contains a given value

Ds\Map::hasValue

(PECL ds >= 1.0.0)

Ds\Map::hasValue — Determines whether the map contains a given value

Descripción

public Ds\Map::hasValue ( mixed $value ) : bool

Determines whether the map contains a given value.

Parámetros

value

The value to look for.

Valores devueltos

Returns true if the value could found, false otherwise.

Ejemplos

Ejemplo #1 Ds\Map::hasValue() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasValue(1)); // true
var_dump($map->hasValue(4)); // false
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)


Creates a new map by intersecting keys with another map

  • « Ds\Map::hasValue
  • Ds\Map::isEmpty »
  • PHP Manual
  • Map
  • Creates a new map by intersecting keys with another map

Ds\Map::intersect

(PECL ds >= 1.0.0)

Ds\Map::intersect — Creates a new map by intersecting keys with another map

Descripción

public Ds\Map::intersect ( Ds\Map $map ) : Ds\Map

Creates a new map containing the pairs of the current instance whose keys are also present in the given map. In other words, returns a copy of the current instance with all keys removed that are not also in the other map.

A n B = {x : x ? A ? x ? B}

Nota:

Values from the current instance will be kept.

Parámetros

map

The other map, containing the keys to intersect with.

Valores devueltos

The key intersection of the current instance and another map.

See Also

  • » Intersection on Wikipedia

Ejemplos

Ejemplo #1 Ds\Map::intersect() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->intersect($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#3 (2) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}


Returns whether the map is empty

  • « Ds\Map::intersect
  • Ds\Map::jsonSerialize »
  • PHP Manual
  • Map
  • Returns whether the map is empty

Ds\Map::isEmpty

(PECL ds >= 1.0.0)

Ds\Map::isEmpty — Returns whether the map is empty

Descripción

public Ds\Map::isEmpty ( ) : bool

Returns whether the map is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the map is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Map::isEmpty() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • « Ds\Map::isEmpty
  • Ds\Map::keys »
  • PHP Manual
  • Map
  • Returns a representation that can be converted to JSON

Ds\Map::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns a set of the map's keys

  • « Ds\Map::jsonSerialize
  • Ds\Map::ksort »
  • PHP Manual
  • Map
  • Returns a set of the map's keys

Ds\Map::keys

(PECL ds >= 1.0.0)

Ds\Map::keys — Returns a set of the map's keys

Descripción

public Ds\Map::keys ( ) : Ds\Set

Returns a set containing all the keys of the map, in the same order.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A Ds\Set containing all the keys of the map.

Ejemplos

Ejemplo #1 Ds\Map::keys() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->keys());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#2 (3) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
}


Sorts the map in-place by key

  • « Ds\Map::keys
  • Ds\Map::ksorted »
  • PHP Manual
  • Map
  • Sorts the map in-place by key

Ds\Map::ksort

(PECL ds >= 1.0.0)

Ds\Map::ksort — Sorts the map in-place by key

Descripción

public Ds\Map::ksort ( callable $comparator = ? ) : void

Sorts the map in-place by key, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::ksort() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);
$map->ksort();

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Ejemplo #2 Ds\Map::ksort() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$map->ksort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)


Returns a copy, sorted by key

  • « Ds\Map::ksort
  • Ds\Map::last »
  • PHP Manual
  • Map
  • Returns a copy, sorted by key

Ds\Map::ksorted

(No hay información de versión disponible, podría estar únicamente en Git)

Ds\Map::ksorted — Returns a copy, sorted by key

Descripción

public Ds\Map::ksorted ( callable $comparator = ? ) : Ds\Map

Returns a copy sorted by key, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a copy of the map, sorted by key.

Ejemplos

Ejemplo #1 Ds\Map::ksorted() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);

print_r($map->ksorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Ejemplo #2 Ds\Map::ksorted() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$sorted = $map->ksorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)


Returns the last pair of the map

  • « Ds\Map::ksorted
  • Ds\Map::map »
  • PHP Manual
  • Map
  • Returns the last pair of the map

Ds\Map::last

(PECL ds >= 1.0.0)

Ds\Map::last — Returns the last pair of the map

Descripción

public Ds\Map::last ( ) : Ds\Pair

Returns the last pair of the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The last pair of the map.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Map::last() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->last());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "c"
  ["value"]=>
  int(3)
}


Returns the result of applying a callback to each value

  • « Ds\Map::last
  • Ds\Map::merge »
  • PHP Manual
  • Map
  • Returns the result of applying a callback to each value

Ds\Map::map

(PECL ds >= 1.0.0)

Ds\Map::map — Returns the result of applying a callback to each value

Descripción

public Ds\Map::map ( callable $callback ) : Ds\Map

Returns the result of applying a callback function to each value of the map.

Parámetros

callback

callback ( mixed $key , mixed $value ) : mixed

A callable to apply to each value in the map.

The callable should return what the key will be mapped to in the resulting map.

Valores devueltos

The result of applying a callback to each value in the map.

Nota:

The keys and values of the current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Map::map() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->map(function($key, $value) { return $value * 2; }));
print_r($map);
?>

El resultado del ejemplo sería algo similar a:

(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Returns the result of adding all given associations

  • « Ds\Map::map
  • Ds\Map::pairs »
  • PHP Manual
  • Map
  • Returns the result of adding all given associations

Ds\Map::merge

(PECL ds >= 1.0.0)

Ds\Map::merge — Returns the result of adding all given associations

Descripción

public Ds\Map::merge ( mixed $values ) : Ds\Map

Returns the result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Nota:

Values of the current instance will be overwritten by those provided where keys are equal.

Parámetros

values

A traversable object or an array.

Valores devueltos

The result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Nota:

The current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Map::merge() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->merge(["a" => 10, "e" => 50]));
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 10
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [3] => Ds\Pair Object
        (
            [key] => e
            [value] => 50
        )

)


Returns a sequence containing all the pairs of the map

  • « Ds\Map::merge
  • Ds\Map::put »
  • PHP Manual
  • Map
  • Returns a sequence containing all the pairs of the map

Ds\Map::pairs

(PECL ds >= 1.0.0)

Ds\Map::pairs — Returns a sequence containing all the pairs of the map

Descripción

public Ds\Map::pairs ( ) : Ds\Sequence

Returns a Ds\Sequence containing all the pairs of the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ds\Sequence containing all the pairs of the map.

Ejemplos

Ejemplo #1 Ds\Map::pairs() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->pairs());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#8 (3) {
  [0]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#6 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}
p


Associates a key with a value

  • « Ds\Map::pairs
  • Ds\Map::putAll »
  • PHP Manual
  • Map
  • Associates a key with a value

Ds\Map::put

(PECL ds >= 1.0.0)

Ds\Map::put — Associates a key with a value

Descripción

public Ds\Map::put ( mixed $key , mixed $value ) : void

Associates a key with a value, overwriting a previous association if one exists.

Nota:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Nota:

You can also use array syntax to associate values by key, eg. $map["key"] = $value.

Precaución

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Parámetros

key

The key to associate the value with.

value

The value to be associated with the key.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::put() example

<?php
$map = new \Ds\Map();

$map->put("a", 1);
$map->put("b", 2);
$map->put("c", 3);

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Ejemplo #2 Ds\Map::put() example using objects as keys

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$map = new \Ds\Map();

$obj = new \ArrayIterator([]);

// Using the same instance multiple times will overwrite the previous value.
$map->put($obj, 1);
$map->put($obj, 2);

// Using multiple instances of the same object will create new associations.
$map->put(new \stdClass(), 3);
$map->put(new \stdClass(), 4);

// Using multiple instances of equal hashable objects will overwrite previous values.
$map->put(new \HashableObject(1), 5);
$map->put(new \HashableObject(1), 6);
$map->put(new \HashableObject(2), 7);
$map->put(new \HashableObject(2), 8);

var_dump($map);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Map)#1 (5) {
  [0]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    object(ArrayIterator)#2 (1) {
      ["storage":"ArrayIterator":private]=>
      array(0) {
      }
    }
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#8 (2) {
    ["key"]=>
    object(stdClass)#3 (0) {
    }
    ["value"]=>
    int(3)
  }
  [2]=>
  object(Ds\Pair)#9 (2) {
    ["key"]=>
    object(stdClass)#4 (0) {
    }
    ["value"]=>
    int(4)
  }
  [3]=>
  object(Ds\Pair)#10 (2) {
    ["key"]=>
    object(HashableObject)#5 (1) {
      ["value":"HashableObject":private]=>
      int(1)
    }
    ["value"]=>
    int(6)
  }
  [4]=>
  object(Ds\Pair)#11 (2) {
    ["key"]=>
    object(HashableObject)#6 (1) {
      ["value":"HashableObject":private]=>
      int(2)
    }
    ["value"]=>
    int(8)
  }
}


Associates all key-value pairs of a traversable object or array

  • « Ds\Map::put
  • Ds\Map::reduce »
  • PHP Manual
  • Map
  • Associates all key-value pairs of a traversable object or array

Ds\Map::putAll

(PECL ds >= 1.0.2)

Ds\Map::putAll — Associates all key-value pairs of a traversable object or array

Descripción

public Ds\Map::putAll ( mixed $pairs ) : void

Associates all key-value pairs of a traversable object or array.

Nota:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Parámetros

pairs

traversable object or array.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::putAll() example

<?php
$map = new \Ds\Map();

$map->putAll([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Reduces the map to a single value using a callback function

  • « Ds\Map::putAll
  • Ds\Map::remove »
  • PHP Manual
  • Map
  • Reduces the map to a single value using a callback function

Ds\Map::reduce

(PECL ds >= 1.0.0)

Ds\Map::reduce — Reduces the map to a single value using a callback function

Descripción

public Ds\Map::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the map to a single value using a callback function.

Parámetros

callback
callback ( mixed $carry , mixed $key , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

key

The key of the current iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

Valores devueltos

The return value of the final callback.

Ejemplos

Ejemplo #1 Ds\Map::reduce() with initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

$callback = function($carry, $key, $value) {
    return $carry * $value;
};

var_dump($map->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

El resultado del ejemplo sería algo similar a:

int(30)

Ejemplo #2 Ds\Map::reduce() without an initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->reduce(function($carry, $key, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

El resultado del ejemplo sería algo similar a:

int(21)


Removes and returns a value by key

  • « Ds\Map::reduce
  • Ds\Map::reverse »
  • PHP Manual
  • Map
  • Removes and returns a value by key

Ds\Map::remove

(PECL ds >= 1.0.0)

Ds\Map::remove — Removes and returns a value by key

Descripción

public Ds\Map::remove ( mixed $key , mixed $default = ? ) : mixed

Removes and returns a value by key, or return an optional default value if the key could not be found.

Nota:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Nota:

You can also use array syntax to access values by key, eg. $map["key"].

Precaución

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Parámetros

key

The key to remove.

default

The optional default value, returned if the key could not be found.

Valores devueltos

The value that was removed, or the default value if provided and the key could not be found in the map.

Errores/Excepciones

OutOfBoundsException if the key could not be found and a default value was not provided.

Ejemplos

Ejemplo #1 Ds\Map::remove() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->remove("a"));      //  1
var_dump($map->remove("e", 10));  // 10 (default used)
?>

El resultado del ejemplo sería algo similar a:

int(1)
int(10)


Reverses the map in-place

  • « Ds\Map::remove
  • Ds\Map::reversed »
  • PHP Manual
  • Map
  • Reverses the map in-place

Ds\Map::reverse

(PECL ds >= 1.0.0)

Ds\Map::reverse — Reverses the map in-place

Descripción

public Ds\Map::reverse ( ) : void

Reverses the map in-place.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::reverse() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->reverse();

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)


Returns a reversed copy

  • « Ds\Map::reverse
  • Ds\Map::skip »
  • PHP Manual
  • Map
  • Returns a reversed copy

Ds\Map::reversed

(PECL ds >= 1.0.0)

Ds\Map::reversed — Returns a reversed copy

Descripción

public Ds\Map::reversed ( ) : Ds\Map

Returns a reversed copy of the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A reversed copy of the map.

Nota:

The current instance is not affected.

Ejemplos

Ejemplo #1 Ds\Map::reversed() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->reversed());
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)


Returns the pair at a given positional index

  • « Ds\Map::reversed
  • Ds\Map::slice »
  • PHP Manual
  • Map
  • Returns the pair at a given positional index

Ds\Map::skip

(PECL ds >= 1.0.0)

Ds\Map::skip — Returns the pair at a given positional index

Descripción

public Ds\Map::skip ( int $position ) : Ds\Pair

Returns the pair at a given zero-based position.

Parámetros

position

The zero-based positional index to return.

Valores devueltos

Returns the Ds\Pair at the given position.

Errores/Excepciones

OutOfRangeException if the position is not valid.

Ejemplos

Ejemplo #1 Ds\Map::skip() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->skip(1));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "b"
  ["value"]=>
  int(2)
}


Returns a subset of the map defined by a starting index and length

  • « Ds\Map::skip
  • Ds\Map::sort »
  • PHP Manual
  • Map
  • Returns a subset of the map defined by a starting index and length

Ds\Map::slice

(PECL ds >= 1.0.0)

Ds\Map::slice — Returns a subset of the map defined by a starting index and length

Descripción

public Ds\Map::slice ( int $index , int $length = ? ) : Ds\Map

Returns a subset of the map defined by a starting index and length.

Parámetros

index

The index at which the range starts.

If positive, the range will start at that index in the map. If negative, the range will start that far from the end.

length

If a length is given and is positive, the resulting map will have up to that many pairs in it. If a length is given and is negative, the range will stop that many pairs from the end. If the length results in an overflow, only pairs up to the end of the map will be included. If a length is not provided, the resulting map will contain all pairs between the index and the end of the map.

Valores devueltos

A subset of the map defined by a starting index and length.

Ejemplos

Ejemplo #1 Ds\Map::slice() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3, "d" => 4, "e" => 5]);

// Slice from 2 onwards
print_r($map->slice(2)->toArray());

// Slice from 1, for a length of 3
print_r($map->slice(1, 3)->toArray());

// Slice from 1 onwards
print_r($map->slice(1)->toArray());

// Slice from 2 from the end onwards
print_r($map->slice(-2)->toArray());

// Slice from 1 to 1 from the end
print_r($map->slice(1, -1)->toArray());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)


Sorts the map in-place by value

  • « Ds\Map::slice
  • Ds\Map::sorted »
  • PHP Manual
  • Map
  • Sorts the map in-place by value

Ds\Map::sort

(PECL ds >= 1.0.0)

Ds\Map::sort — Sorts the map in-place by value

Descripción

public Ds\Map::sort ( callable $comparator = ? ) : void

Sorts the map in-place by value, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);
$map->sort();

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Ejemplo #2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

$map->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)


Returns a copy, sorted by value

  • « Ds\Map::sort
  • Ds\Map::sum »
  • PHP Manual
  • Map
  • Returns a copy, sorted by value

Ds\Map::sorted

(PECL ds >= 1.0.0)

Ds\Map::sorted — Returns a copy, sorted by value

Descripción

public Ds\Map::sorted ( callable $comparator = ? ) : Ds\Map

Returns a copy, sorted by value using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a copy of the map, sorted by value.

Ejemplos

Ejemplo #1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

print_r($map->sorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Ejemplo #2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

// Reverse
$sorted = $map->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)


Returns the sum of all values in the map

  • « Ds\Map::sorted
  • Ds\Map::toArray »
  • PHP Manual
  • Map
  • Returns the sum of all values in the map

Ds\Map::sum

(No hay información de versión disponible, podría estar únicamente en Git)

Ds\Map::sum — Returns the sum of all values in the map

Descripción

public Ds\Map::sum ( ) : int|float

Returns the sum of all values in the map.

Nota:

Arrays and objects are considered equal to zero when calculating the sum.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The sum of all the values in the map as either a float or int depending on the values in the map.

Ejemplos

Ejemplo #1 Ds\Map::sum() integer example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->sum());
?>

El resultado del ejemplo sería algo similar a:

int(6)

Ejemplo #2 Ds\Map::sum() float example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2.5, "c" => 3]);
var_dump($map->sum());
?>

El resultado del ejemplo sería algo similar a:

float(6.5)


Converts the map to an array

  • « Ds\Map::sum
  • Ds\Map::union »
  • PHP Manual
  • Map
  • Converts the map to an array

Ds\Map::toArray

(PECL ds >= 1.0.0)

Ds\Map::toArray — Converts the map to an array

Descripción

public Ds\Map::toArray ( ) : array

Converts the map to an array.

Precaución

Maps where non-scalar keys are can't be converted to an array.

Precaución

An array will treat all numeric keys as integers, eg. "1" and 1 as keys in the map will only result in 1 being included in the array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the map.

Ejemplos

Ejemplo #1 Ds\Map::toArray() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

var_dump($map->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["a"]=>
  int(1)
  ["b"]=>
  int(2)
  ["c"]=>
  int(3)
}


Creates a new map using values from the current instance and another map

  • « Ds\Map::toArray
  • Ds\Map::values »
  • PHP Manual
  • Map
  • Creates a new map using values from the current instance and another map

Ds\Map::union

(PECL ds >= 1.0.0)

Ds\Map::union — Creates a new map using values from the current instance and another map

Descripción

public Ds\Map::union ( Ds\Map $map ) : Ds\Map

Creates a new map that contains the pairs of the current instance as well as the pairs of another map.

A ? B = {x: x ? A ? x ? B}

Nota:

Values of the current instance will be overwritten by those provided where keys are equal.

Parámetros

map

The other map, to combine with the current instance.

Valores devueltos

A new map containing all the pairs of the current instance as well as another map.

See Also

  • » Union on Wikipedia

Ejemplos

Ejemplo #1 Ds\Map::union() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 3, "c" => 4, "d" => 5]);

print_r($a->union($b));
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 4
        )

    [3] => Ds\Pair Object
        (
            [key] => d
            [value] => 5
        )

)


Returns a sequence of the map's values

  • « Ds\Map::union
  • Ds\Map::xor »
  • PHP Manual
  • Map
  • Returns a sequence of the map's values

Ds\Map::values

(PECL ds >= 1.0.0)

Ds\Map::values — Returns a sequence of the map's values

Descripción

public Ds\Map::values ( ) : Ds\Sequence

Returns a sequence containing all the values of the map, in the same order.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A Ds\Sequence containing all the values of the map.

Ejemplos

Ejemplo #1 Ds\Map::values() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->values());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Creates a new map using keys of either the current instance or of another map, but not of both

  • « Ds\Map::values
  • Pair »
  • PHP Manual
  • Map
  • Creates a new map using keys of either the current instance or of another map, but not of both

Ds\Map::xor

(PECL ds >= 1.0.0)

Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both

Descripción

public Ds\Map::xor ( Ds\Map $map ) : Ds\Map

Creates a new map containing keys of the current instance as well as another map, but not of both.

A ? B = {x : x ? (A \ B) ? (B \ A)}

Parámetros

map

The other map.

Valores devueltos

A new map containing keys in the current instance as well as another map, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

Ejemplos

Ejemplo #1 Ds\Map::xor() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

print_r($a->xor($b));
?>

El resultado del ejemplo sería algo similar a:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => d
            [value] => 6
        )

)


La clase Pair

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Un par es usado por Ds\Map para emparejar las claves con valores.

Sinopsis de la Clase

Ds\Pair implements JsonSerializable {
/* Métodos */
public __construct ( mixed $key = ? , mixed $value = ? )
}

Tabla de contenidos

  • Ds\Pair::clear — Removes all values
  • Ds\Pair::__construct — Creates a new instance
  • Ds\Pair::copy — Returns a shallow copy of the pair
  • Ds\Pair::isEmpty — Returns whether the pair is empty
  • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Pair::toArray — Converts the pair to an array


Removes all values

  • « Pair
  • Ds\Pair::__construct »
  • PHP Manual
  • Pair
  • Removes all values

Ds\Pair::clear

(No hay información de versión disponible, podría estar únicamente en Git)

Ds\Pair::clear — Removes all values

Descripción

public Ds\Pair::clear ( ) : void

Removes all values from the pair.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Pair::clear() example

<?php
$pair = new \Ds\Pair("a", 1);
print_r($pair);

$pair->clear();
print_r($pair);
?>

El resultado del ejemplo sería algo similar a:

Ds\Pair Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Pair Object
(
)


Creates a new instance

  • « Ds\Pair::clear
  • Ds\Pair::copy »
  • PHP Manual
  • Pair
  • Creates a new instance

Ds\Pair::__construct

(PECL ds >= 1.0.0)

Ds\Pair::__construct — Creates a new instance

Descripción

public Ds\Pair::__construct ( mixed $key = ? , mixed $value = ? )

Creates a new instance using a given key and value.

Parámetros

key

The key.

value

The value.


Returns a shallow copy of the pair

  • « Ds\Pair::__construct
  • Ds\Pair::isEmpty »
  • PHP Manual
  • Pair
  • Returns a shallow copy of the pair

Ds\Pair::copy

(No hay información de versión disponible, podría estar únicamente en Git)

Ds\Pair::copy — Returns a shallow copy of the pair

Descripción

public Ds\Pair::copy ( ) : Ds\Pair

Returns a shallow copy of the pair.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the pair.

Ejemplos

Ejemplo #1 Ds\Pair::copy() example

<?php
$a = new \Ds\Pair("a", 1);
$b = $a->copy();

$a->key = "x";

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Pair Object
(
    [key] => x
    [value] => 1
)
Ds\Pair Object
(
    [key] => a
    [value] => 1
)


Returns whether the pair is empty

  • « Ds\Pair::copy
  • Ds\Pair::jsonSerialize »
  • PHP Manual
  • Pair
  • Returns whether the pair is empty

Ds\Pair::isEmpty

(No hay información de versión disponible, podría estar únicamente en Git)

Ds\Pair::isEmpty — Returns whether the pair is empty

Descripción

public Ds\Pair::isEmpty ( ) : bool

Returns whether the pair is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the pair is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Pair::isEmpty() example

<?php
$a = new \Ds\Pair("a", 1);
$b = new \Ds\Pair();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • « Ds\Pair::isEmpty
  • Ds\Pair::toArray »
  • PHP Manual
  • Pair
  • Returns a representation that can be converted to JSON

Ds\Pair::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Converts the pair to an array

  • « Ds\Pair::jsonSerialize
  • Set »
  • PHP Manual
  • Pair
  • Converts the pair to an array

Ds\Pair::toArray

(PECL ds >= 1.0.0)

Ds\Pair::toArray — Converts the pair to an array

Descripción

public Ds\Pair::toArray ( ) : array

Converts the pair to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the pair.

Ejemplos

Ejemplo #1 Ds\Pair::toArray() example

<?php
$pair = new \Ds\Pair("a", 1);

var_dump($pair->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}


The Set class

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

A Set is a sequence of unique values. This implementation uses the same hash table as Ds\Map, where values are used as keys and the mapped value is ignored.

Strengths

  • Values can be any type, including objects.
  • Supports array syntax (square brackets).
  • Insertion order is preserved.
  • Automatically frees allocated memory when its size drops low enough.
  • add(),
remove() and
contains() are all O(1).

Weaknesses

  • Doesn’t support
                push(),
                pop(),
                insert(),
                shift(), or
                unshift().
  • get() is O(n) if there are deleted values in the buffer before the accessed index, O(1) otherwise.

Sinopsis de la Clase

Ds\Set implements Ds\Collection , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 16 ;
/* Métodos */
public add ( mixed ...$values ) : void
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Set
public diff ( Ds\Set $set ) : Ds\Set
public filter ( callable $callback = ? ) : Ds\Set
public first ( ) : mixed
public get ( int $index ) : mixed
public intersect ( Ds\Set $set ) : Ds\Set
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public merge ( mixed $values ) : Ds\Set
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( mixed ...$values ) : void
public reverse ( ) : void
public reversed ( ) : Ds\Set
public slice ( int $index , int $length = ? ) : Ds\Set
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Set
public sum ( ) : int|float
public toArray ( ) : array
public union ( Ds\Set $set ) : Ds\Set
public xor ( Ds\Set $set ) : Ds\Set
}

Constantes predefinidas

Ds\Set::MIN_CAPACITY

Historial de cambios

Versión | Descripción
PECL ds 1.3.0 | The class now implements ArrayAccess.

Tabla de contenidos

  • Ds\Set::add — Adds values to the set
  • Ds\Set::allocate — Allocates enough memory for a required capacity
  • Ds\Set::capacity — Returns the current capacity
  • Ds\Set::clear — Removes all values
  • Ds\Set::__construct — Creates a new instance
  • Ds\Set::contains — Determines if the set contains all values
  • Ds\Set::copy — Returns a shallow copy of the set
  • Ds\Set::count — Returns the number of values in the set
  • Ds\Set::diff — Creates a new set using values that aren't in another set
  • Ds\Set::filter — Creates a new set using a callable to determine which values to include
  • Ds\Set::first — Returns the first value in the set
  • Ds\Set::get — Returns the value at a given index
  • Ds\Set::intersect — Creates a new set by intersecting values with another set
  • Ds\Set::isEmpty — Returns whether the set is empty
  • Ds\Set::join — Joins all values together as a string
  • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Set::last — Returns the last value in the set
  • Ds\Set::merge — Returns the result of adding all given values to the set
  • Ds\Set::reduce — Reduces the set to a single value using a callback function
  • Ds\Set::remove — Removes all given values from the set
  • Ds\Set::reverse — Reverses the set in-place
  • Ds\Set::reversed — Returns a reversed copy
  • Ds\Set::slice — Returns a sub-set of a given range
  • Ds\Set::sort — Sorts the set in-place
  • Ds\Set::sorted — Returns a sorted copy
  • Ds\Set::sum — Returns the sum of all values in the set
  • Ds\Set::toArray — Converts the set to an array
  • Ds\Set::union — Creates a new set using values from the current instance and another set
  • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both


Adds values to the set

  • « Set
  • Ds\Set::allocate »
  • PHP Manual
  • Set
  • Adds values to the set

Ds\Set::add

(PECL ds >= 1.0.0)

Ds\Set::add — Adds values to the set

Descripción

public Ds\Set::add ( mixed ...$values ) : void

Adds all given values to the set that haven't already been added.

Nota:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Precaución

All comparisons are strict (type and value).

Parámetros

values

Values to add to the set.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::add() example using integers

<?php
$set = new \Ds\Set();

$set->add(1);
$set->add(1);
$set->add(2);
$set->add(3);

// Strict comparison would not treat these the same as int(1)
$set->add("1");
$set->add(true);

var_dump($set);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#1 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  string(1) "1"
  [4]=>
  bool(true)
}

Ejemplo #2 Ds\Set::add() example using objects

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$set = new \Ds\Set();

$obj = new \ArrayIterator([]);

// Adding the same instance multiple times will only add the first.
$set->add($obj);
$set->add($obj);

// Adding multiple instances of the same object will add them all.
$set->add(new \stdClass());
$set->add(new \stdClass());

// Adding multiple instances of equal hashable objects will only add the first.
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(2));
$set->add(new \HashableObject(2));

var_dump($set);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#1 (5) {
  [0]=>
  object(ArrayIterator)#2 (1) {
    ["storage":"ArrayIterator":private]=>
    array(0) {
    }
  }
  [1]=>
  object(stdClass)#3 (0) {
  }
  [2]=>
  object(stdClass)#4 (0) {
  }
  [3]=>
  object(HashableObject)#5 (1) {
    ["value":"HashableObject":private]=>
    int(1)
  }
  [4]=>
  object(HashableObject)#6 (1) {
    ["value":"HashableObject":private]=>
    int(2)
  }
}


Allocates enough memory for a required capacity

  • « Ds\Set::add
  • Ds\Set::capacity »
  • PHP Manual
  • Set
  • Allocates enough memory for a required capacity

Ds\Set::allocate

(PECL ds >= 1.0.0)

Ds\Set::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Set::allocate ( int $capacity ) : void

Allocates enough memory for a required capacity.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::allocate() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->allocate(100);
var_dump($set->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(16)
int(128)


Returns the current capacity

  • « Ds\Set::allocate
  • Ds\Set::clear »
  • PHP Manual
  • Set
  • Returns the current capacity

Ds\Set::capacity

(PECL ds >= 1.0.0)

Ds\Set::capacity — Returns the current capacity

Descripción

public Ds\Set::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Set::capacity() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->push(...range(1, 50));
var_dump($set->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(16)
int(64)


Removes all values

  • « Ds\Set::capacity
  • Ds\Set::__construct »
  • PHP Manual
  • Set
  • Removes all values

Ds\Set::clear

(PECL ds >= 1.0.0)

Ds\Set::clear — Removes all values

Descripción

public Ds\Set::clear ( ) : void

Removes all values from the set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::clear() example

<?php
$set = new \Ds\Set([1, 2, 3]);
print_r($set);

$set->clear();
print_r($set);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
)


Creates a new instance

  • « Ds\Set::clear
  • Ds\Set::contains »
  • PHP Manual
  • Set
  • Creates a new instance

Ds\Set::__construct

(PECL ds >= 1.0.0)

Ds\Set::__construct — Creates a new instance

Descripción

public Ds\Set::__construct ( mixed ...$values )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Set::__construct() example

<?php
$set = new \Ds\Set();
var_dump($set);

$set = new \Ds\Set([1, 2, 3]);
var_dump($set);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#1 (0) {
}
object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the set contains all values

  • « Ds\Set::__construct
  • Ds\Set::copy »
  • PHP Manual
  • Set
  • Determines if the set contains all values

Ds\Set::contains

(PECL ds >= 1.0.0)

Ds\Set::contains — Determines if the set contains all values

Descripción

public Ds\Set::contains ( mixed ...$values ) : bool

Determines if the set contains all values.

Nota:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Precaución

All comparisons are strict (type and value).

Parámetros

values

Values to check.

Valores devueltos

false if any of the provided values are not in the set, true otherwise.

Ejemplos

Ejemplo #1 Ds\Set::contains() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->contains(1));                // true
var_dump($set->contains(1, 2));             // true
var_dump($set->contains(...[1, 2]));        // true

var_dump($set->contains("1"));              // false
var_dump($set->contains(...[1, 2, 3, 4]));  // false

var_dump($set->contains(...[]));            // true
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
bool(false)
bool(false)
bool(true)


Returns a shallow copy of the set

  • « Ds\Set::contains
  • Ds\Set::count »
  • PHP Manual
  • Set
  • Returns a shallow copy of the set

Ds\Set::copy

(PECL ds >= 1.0.0)

Ds\Set::copy — Returns a shallow copy of the set

Descripción

public Ds\Set::copy ( ) : Ds\Set

Returns a shallow copy of the set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the set.

Ejemplos

Ejemplo #1 Ds\Set::copy() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->add(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the set

  • « Ds\Set::copy
  • Ds\Set::diff »
  • PHP Manual
  • Set
  • Returns the number of values in the set

Ds\Set::count

(PECL ds >= 1.0.0)

Ds\Set::count — Returns the number of values in the set

See Countable::count()


Creates a new set using values that aren't in another set

  • « Ds\Set::count
  • Ds\Set::filter »
  • PHP Manual
  • Set
  • Creates a new set using values that aren't in another set

Ds\Set::diff

(PECL ds >= 1.0.0)

Ds\Set::diff — Creates a new set using values that aren't in another set

Descripción

public Ds\Set::diff ( Ds\Set $set ) : Ds\Set

Creates a new set using values that aren't in another set.

A \ B = {x ? A | x ? B}

Parámetros

set

Set containing the values to exclude.

Valores devueltos

A new set containing all values that were not in the other set.

See Also

  • » Compliment on Wikipedia

Ejemplos

Ejemplo #1 Ds\Set::diff() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->diff($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#3 (2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}


Creates a new set using a callable to determine which values to include

  • « Ds\Set::diff
  • Ds\Set::first »
  • PHP Manual
  • Set
  • Creates a new set using a callable to determine which values to include

Ds\Set::filter

(PECL ds >= 1.0.0)

Ds\Set::filter — Creates a new set using a callable to determine which values to include

Descripción

public Ds\Set::filter ( callable $callback = ? ) : Ds\Set

Creates a new set using a callable to determine which values to include.

Parámetros

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

Valores devueltos

A new set containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

Ejemplos

Ejemplo #1 Ds\Set::filter() example using callback function

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

var_dump($set->filter(function($value) {
    return $value % 2 == 0;
}));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Ejemplo #2 Ds\Set::filter() example without a callback function

<?php
$set = new \Ds\Set([0, 1, 'a', true, false]);

var_dump($set->filter());
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Returns the first value in the set

  • « Ds\Set::filter
  • Ds\Set::get »
  • PHP Manual
  • Set
  • Returns the first value in the set

Ds\Set::first

(PECL ds >= 1.0.0)

Ds\Set::first — Returns the first value in the set

Descripción

public Ds\Set::first ( ) : mixed

Returns the first value in the set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The first value in the set.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Set::first() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->first());
?>

El resultado del ejemplo sería algo similar a:

int(1)


Returns the value at a given index

  • « Ds\Set::first
  • Ds\Set::intersect »
  • PHP Manual
  • Set
  • Returns the value at a given index

Ds\Set::get

(PECL ds >= 1.0.0)

Ds\Set::get — Returns the value at a given index

Descripción

public Ds\Set::get ( int $index ) : mixed

Returns the value at a given index.

Parámetros

index

The index to access, starting at 0.

Valores devueltos

The value at the requested index.

Errores/Excepciones

OutOfRangeException if the index is not valid.

Ejemplos

Ejemplo #1 Ds\Set::get() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set->get(0));
var_dump($set->get(1));
var_dump($set->get(2));
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"

Ejemplo #2 Ds\Set::get() example using array syntax

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set[0]);
var_dump($set[1]);
var_dump($set[2]);
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Creates a new set by intersecting values with another set

  • « Ds\Set::get
  • Ds\Set::isEmpty »
  • PHP Manual
  • Set
  • Creates a new set by intersecting values with another set

Ds\Set::intersect

(PECL ds >= 1.0.0)

Ds\Set::intersect — Creates a new set by intersecting values with another set

Descripción

public Ds\Set::intersect ( Ds\Set $set ) : Ds\Set

Creates a new set using values common to both the current instance and another set. In other words, returns a copy of the current instance with all values removed that are not in the other set.

A n B = {x : x ? A ? x ? B}

Parámetros

set

The other set.

Valores devueltos

The intersection of the current instance and another set.

See Also

  • » Intersection on Wikipedia

Ejemplos

Ejemplo #1 Ds\Set::intersect() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->intersect($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#3 (1) {
  [0]=>
  int(3)
}


Returns whether the set is empty

  • « Ds\Set::intersect
  • Ds\Set::join »
  • PHP Manual
  • Set
  • Returns whether the set is empty

Ds\Set::isEmpty

(PECL ds >= 1.0.0)

Ds\Set::isEmpty — Returns whether the set is empty

Descripción

public Ds\Set::isEmpty ( ) : bool

Returns whether the set is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the set is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Set::isEmpty() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Joins all values together as a string

  • « Ds\Set::isEmpty
  • Ds\Set::jsonSerialize »
  • PHP Manual
  • Set
  • Joins all values together as a string

Ds\Set::join

(PECL ds >= 1.0.0)

Ds\Set::join — Joins all values together as a string

Descripción

public Ds\Set::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

Parámetros

glue

An optional string to separate each value.

Valores devueltos

All values of the set joined together as a string.

Ejemplos

Ejemplo #1 Ds\Set::join() example using a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join("|"));
?>

El resultado del ejemplo sería algo similar a:

string(11) "a|b|c|1|2|3"

Ejemplo #2 Ds\Set::join() example without a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join());
?>

El resultado del ejemplo sería algo similar a:

string(11) "abc123"


Returns a representation that can be converted to JSON

  • « Ds\Set::join
  • Ds\Set::last »
  • PHP Manual
  • Set
  • Returns a representation that can be converted to JSON

Ds\Set::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns the last value in the set

  • « Ds\Set::jsonSerialize
  • Ds\Set::merge »
  • PHP Manual
  • Set
  • Returns the last value in the set

Ds\Set::last

(PECL ds >= 1.0.0)

Ds\Set::last — Returns the last value in the set

Descripción

public Ds\Set::last ( ) : mixed

Returns the last value in the set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The last value in the set.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Set::last() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->last());
?>

El resultado del ejemplo sería algo similar a:

int(3)


Returns the result of adding all given values to the set

  • « Ds\Set::last
  • Ds\Set::reduce »
  • PHP Manual
  • Set
  • Returns the result of adding all given values to the set

Ds\Set::merge

(PECL ds >= 1.0.3)

Ds\Set::merge — Returns the result of adding all given values to the set

Descripción

public Ds\Set::merge ( mixed $values ) : Ds\Set

Returns the result of adding all given values to the set.

Parámetros

values

A traversable object or an array.

Valores devueltos

The result of adding all given values to the set, effectively the same as adding the values to a copy, then returning that copy.

Nota:

The current instance won't be affected.

Ejemplos

Ejemplo #1 Ds\Set::merge() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->merge([3, 4, 5]));
var_dump($set);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}
object(Ds\Set)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Reduces the set to a single value using a callback function

  • « Ds\Set::merge
  • Ds\Set::remove »
  • PHP Manual
  • Set
  • Reduces the set to a single value using a callback function

Ds\Set::reduce

(PECL ds >= 1.0.0)

Ds\Set::reduce — Reduces the set to a single value using a callback function

Descripción

public Ds\Set::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the set to a single value using a callback function.

Parámetros

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

Valores devueltos

The return value of the final callback.

Ejemplos

Ejemplo #1 Ds\Set::reduce() with initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($set->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

El resultado del ejemplo sería algo similar a:

int(30)

Ejemplo #2 Ds\Set::reduce() without an initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

El resultado del ejemplo sería algo similar a:

int(21)


Removes all given values from the set

  • « Ds\Set::reduce
  • Ds\Set::reverse »
  • PHP Manual
  • Set
  • Removes all given values from the set

Ds\Set::remove

(PECL ds >= 1.0.0)

Ds\Set::remove — Removes all given values from the set

Descripción

public Ds\Set::remove ( mixed ...$values ) : void

Removes all given values from the set, ignoring any that are not in the set.

Parámetros

values

The values to remove.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::remove() example

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

$set->remove(1);            // Remove 1
$set->remove(1, 2);         // Can't find 1, but remove 2
$set->remove(...[3, 4]);    // Remove 3 and 4

var_dump($set);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#1 (1) {
  [0]=>
  int(5)
}


Reverses the set in-place

  • « Ds\Set::remove
  • Ds\Set::reversed »
  • PHP Manual
  • Set
  • Reverses the set in-place

Ds\Set::reverse

(PECL ds >= 1.0.0)

Ds\Set::reverse — Reverses the set in-place

Descripción

public Ds\Set::reverse ( ) : void

Reverses the set in-place.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::reverse() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);
$set->reverse();

print_r($set);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • « Ds\Set::reverse
  • Ds\Set::slice »
  • PHP Manual
  • Set
  • Returns a reversed copy

Ds\Set::reversed

(PECL ds >= 1.0.0)

Ds\Set::reversed — Returns a reversed copy

Descripción

public Ds\Set::reversed ( ) : Ds\Set

Returns a reversed copy of the set.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A reversed copy of the set.

Nota:

The current instance is not affected.

Ejemplos

Ejemplo #1 Ds\Set::reversed() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

print_r($set->reversed());
print_r($set);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Set Object
(
    [0] => a
    [1] => b
    [2] => c
)


Returns a sub-set of a given range

  • « Ds\Set::reversed
  • Ds\Set::sort »
  • PHP Manual
  • Set
  • Returns a sub-set of a given range

Ds\Set::slice

(PECL ds >= 1.0.0)

Ds\Set::slice — Returns a sub-set of a given range

Descripción

public Ds\Set::slice ( int $index , int $length = ? ) : Ds\Set

Creates a sub-set of a given range.

Parámetros

index

The index at which the sub-set starts.

If positive, the set will start at that index in the set. If negative, the set will start that far from the end.

length

If a length is given and is positive, the resulting set will have up to that many values in it. If the length results in an overflow, only values up to the end of the set will be included. If a length is given and is negative, the set will stop that many values from the end. If a length is not provided, the resulting set will contain all values between the index and the end of the set.

Valores devueltos

A sub-set of the given range.

Ejemplos

Ejemplo #1 Ds\Set::slice() example

<?php
$set = new \Ds\Set(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($set->slice(2));

// Slice from 1, for a length of 3
print_r($set->slice(1, 3));

// Slice from 1 onwards
print_r($set->slice(1));

// Slice from 2 from the end onwards
print_r($set->slice(-2));

// Slice from 1 to 1 from the end
print_r($set->slice(1, -1));
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Set Object
(
    [0] => d
    [1] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the set in-place

  • « Ds\Set::slice
  • Ds\Set::sorted »
  • PHP Manual
  • Set
  • Sorts the set in-place

Ds\Set::sort

(PECL ds >= 1.0.0)

Ds\Set::sort — Sorts the set in-place

Descripción

public Ds\Set::sort ( callable $comparator = ? ) : void

Sorts the set in-place, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Set::sort() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);
$set->sort();

print_r($set);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Set::sort() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$set->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($set);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • « Ds\Set::sort
  • Ds\Set::sum »
  • PHP Manual
  • Set
  • Returns a sorted copy

Ds\Set::sorted

(PECL ds >= 1.0.0)

Ds\Set::sorted — Returns a sorted copy

Descripción

public Ds\Set::sorted ( callable $comparator = ? ) : Ds\Set

Returns a sorted copy, using an optional comparator function.

Parámetros

comparator

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Valores devueltos

Returns a sorted copy of the set.

Ejemplos

Ejemplo #1 Ds\Set::sorted() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

print_r($set->sorted());
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Ejemplo #2 Ds\Set::sorted() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$sorted = $set->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

El resultado del ejemplo sería algo similar a:

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the set

  • « Ds\Set::sorted
  • Ds\Set::toArray »
  • PHP Manual
  • Set
  • Returns the sum of all values in the set

Ds\Set::sum

(PECL ds >= 1.0.0)

Ds\Set::sum — Returns the sum of all values in the set

Descripción

public Ds\Set::sum ( ) : int|float

Returns the sum of all values in the set.

Nota:

Arrays and objects are considered equal to zero when calculating the sum.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The sum of all the values in the set as either a float or int depending on the values in the set.

Ejemplos

Ejemplo #1 Ds\Set::sum() integer example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->sum());
?>

El resultado del ejemplo sería algo similar a:

int(6)

Ejemplo #2 Ds\Set::sum() float example

<?php
$set = new \Ds\Set([1, 2.5, 3]);
var_dump($set->sum());
?>

El resultado del ejemplo sería algo similar a:

float(6.5)


Converts the set to an array

  • « Ds\Set::sum
  • Ds\Set::union »
  • PHP Manual
  • Set
  • Converts the set to an array

Ds\Set::toArray

(PECL ds >= 1.0.0)

Ds\Set::toArray — Converts the set to an array

Descripción

public Ds\Set::toArray ( ) : array

Converts the set to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the set.

Ejemplos

Ejemplo #1 Ds\Set::toArray() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Creates a new set using values from the current instance and another set

  • « Ds\Set::toArray
  • Ds\Set::xor »
  • PHP Manual
  • Set
  • Creates a new set using values from the current instance and another set

Ds\Set::union

(PECL ds >= 1.0.0)

Ds\Set::union — Creates a new set using values from the current instance and another set

Descripción

public Ds\Set::union ( Ds\Set $set ) : Ds\Set

Creates a new set that contains the values of the current instance as well as the values of another set.

A ? B = {x: x ? A ? x ? B}

Parámetros

set

The other set, to combine with the current instance.

Valores devueltos

A new set containing all the values of the current instance as well as another set.

See Also

  • » Union on Wikipedia

Ejemplos

Ejemplo #1 Ds\Set::union() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->union($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#3 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}


Creates a new set using values in either the current instance or in another set, but not in both

  • « Ds\Set::union
  • Stack »
  • PHP Manual
  • Set
  • Creates a new set using values in either the current instance or in another set, but not in both

Ds\Set::xor

(PECL ds >= 1.0.0)

Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both

Descripción

public Ds\Set::xor ( Ds\Set $set ) : Ds\Set

Creates a new set containing values in the current instance as well as another set, but not in both.

A ? B = {x : x ? (A \ B) ? (B \ A)}

Parámetros

set

The other set.

Valores devueltos

A new set containing values in the current instance as well as another set, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

Ejemplos

Ejemplo #1 Ds\Set::xor() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->xor($b));
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Set)#3 (4) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(4)
  [3]=>
  int(5)
}


The Stack class

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

A Stack is a “last in, first out” or “LIFO” collection that only allows access to the value at the top of the structure and iterates in that order, destructively.

Uses a Ds\Vector internally.

Sinopsis de la Clase

Ds\Stack implements Ds\Collection , ArrayAccess {
/* Métodos */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Stack
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public toArray ( ) : array
}

Historial de cambios

Versión | Descripción
PECL ds 1.3.0 | The class now implements ArrayAccess.

Tabla de contenidos

  • Ds\Stack::allocate — Allocates enough memory for a required capacity
  • Ds\Stack::capacity — Returns the current capacity
  • Ds\Stack::clear — Removes all values
  • Ds\Stack::__construct — Creates a new instance
  • Ds\Stack::copy — Returns a shallow copy of the stack
  • Ds\Stack::count — Returns the number of values in the stack
  • Ds\Stack::isEmpty — Returns whether the stack is empty
  • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Stack::peek — Returns the value at the top of the stack
  • Ds\Stack::pop — Removes and returns the value at the top of the stack
  • Ds\Stack::push — Pushes values onto the stack
  • Ds\Stack::toArray — Converts the stack to an array


Allocates enough memory for a required capacity

  • « Stack
  • Ds\Stack::capacity »
  • PHP Manual
  • Stack
  • Allocates enough memory for a required capacity

Ds\Stack::allocate

(PECL ds >= 1.0.0)

Ds\Stack::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Stack::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Valores devueltos

No devuelve ningún valor.


Returns the current capacity

  • « Ds\Stack::allocate
  • Ds\Stack::clear »
  • PHP Manual
  • Stack
  • Returns the current capacity

Ds\Stack::capacity

(PECL ds >= 1.0.0)

Ds\Stack::capacity — Returns the current capacity

Descripción

public Ds\Stack::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.


Removes all values

  • « Ds\Stack::capacity
  • Ds\Stack::__construct »
  • PHP Manual
  • Stack
  • Removes all values

Ds\Stack::clear

(PECL ds >= 1.0.0)

Ds\Stack::clear — Removes all values

Descripción

public Ds\Stack::clear ( ) : void

Removes all values from the stack.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Stack::clear() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);

$stack->clear();
print_r($stack);
?>

El resultado del ejemplo sería algo similar a:

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
)


Creates a new instance

  • « Ds\Stack::clear
  • Ds\Stack::copy »
  • PHP Manual
  • Stack
  • Creates a new instance

Ds\Stack::__construct

(PECL ds >= 1.0.0)

Ds\Stack::__construct — Creates a new instance

Descripción

public Ds\Stack::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Stack::__construct() example

<?php
$stack = new \Ds\Stack();
print_r($stack);

$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);
?>

El resultado del ejemplo sería algo similar a:

Ds\Stack Object
(
)
Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)


Returns a shallow copy of the stack

  • « Ds\Stack::__construct
  • Ds\Stack::count »
  • PHP Manual
  • Stack
  • Returns a shallow copy of the stack

Ds\Stack::copy

(PECL ds >= 1.0.0)

Ds\Stack::copy — Returns a shallow copy of the stack

Descripción

public Ds\Stack::copy ( ) : Ds\Stack

Returns a shallow copy of the stack.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the stack.

Ejemplos

Ejemplo #1 Ds\Stack::copy() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
    [0] => 4
    [1] => 3
    [2] => 2
    [3] => 1
)


Returns the number of values in the stack

  • « Ds\Stack::copy
  • Ds\Stack::isEmpty »
  • PHP Manual
  • Stack
  • Returns the number of values in the stack

Ds\Stack::count

(PECL ds >= 1.0.0)

Ds\Stack::count — Returns the number of values in the stack

See Countable::count()


Returns whether the stack is empty

  • « Ds\Stack::count
  • Ds\Stack::jsonSerialize »
  • PHP Manual
  • Stack
  • Returns whether the stack is empty

Ds\Stack::isEmpty

(PECL ds >= 1.0.0)

Ds\Stack::isEmpty — Returns whether the stack is empty

Descripción

public Ds\Stack::isEmpty ( ) : bool

Returns whether the stack is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the stack is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Stack::isEmpty() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = new \Ds\Stack();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • « Ds\Stack::isEmpty
  • Ds\Stack::peek »
  • PHP Manual
  • Stack
  • Returns a representation that can be converted to JSON

Ds\Stack::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns the value at the top of the stack

  • « Ds\Stack::jsonSerialize
  • Ds\Stack::pop »
  • PHP Manual
  • Stack
  • Returns the value at the top of the stack

Ds\Stack::peek

(PECL ds >= 1.0.0)

Ds\Stack::peek — Returns the value at the top of the stack

Descripción

public Ds\Stack::peek ( ) : mixed

Returns the value at the top of the stack, but does not remove it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value at the top of the stack.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Stack::peek() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->peek());
?>

El resultado del ejemplo sería algo similar a:

string(1) "c"


Removes and returns the value at the top of the stack

  • « Ds\Stack::peek
  • Ds\Stack::push »
  • PHP Manual
  • Stack
  • Removes and returns the value at the top of the stack

Ds\Stack::pop

(PECL ds >= 1.0.0)

Ds\Stack::pop — Removes and returns the value at the top of the stack

Descripción

public Ds\Stack::pop ( ) : mixed

Removes and returns the value at the top of the stack.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed value which was at the top of the stack.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Stack::pop() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->pop());
var_dump($stack->pop());
var_dump($stack->pop());
?>

El resultado del ejemplo sería algo similar a:

string(1) "c"
string(1) "b"
string(1) "a"


Pushes values onto the stack

  • « Ds\Stack::pop
  • Ds\Stack::toArray »
  • PHP Manual
  • Stack
  • Pushes values onto the stack

Ds\Stack::push

(PECL ds >= 1.0.0)

Ds\Stack::push — Pushes values onto the stack

Descripción

public Ds\Stack::push ( mixed ...$values ) : void

Pushes values onto the stack.

Parámetros

values

The values to push onto the stack.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Stack::push() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c", "d");
$stack->push(...["e", "f"]);

print_r($stack);
?>

El resultado del ejemplo sería algo similar a:

Ds\Stack Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Converts the stack to an array

  • « Ds\Stack::push
  • Queue »
  • PHP Manual
  • Stack
  • Converts the stack to an array

Ds\Stack::toArray

(PECL ds >= 1.0.0)

Ds\Stack::toArray — Converts the stack to an array

Descripción

public Ds\Stack::toArray ( ) : array

Converts the stack to an array.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the stack.

Ejemplos

Ejemplo #1 Ds\Stack::toArray() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);

var_dump($stack->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}


The Queue class

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

A Queue is a “first in, first out” or “FIFO” collection that only allows access to the value at the front of the queue and iterates in that order, destructively.

Sinopsis de la Clase

Ds\Queue implements Ds\Collection , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* Métodos */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Queue
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed $...values = ? ) : void
public toArray ( ) : array
}

Constantes predefinidas

Ds\Queue::MIN_CAPACITY

Historial de cambios

Versión | Descripción
PECL ds 1.3.0 | The class now implements ArrayAccess.

Tabla de contenidos

  • Ds\Queue::allocate — Allocates enough memory for a required capacity
  • Ds\Queue::capacity — Returns the current capacity
  • Ds\Queue::clear — Removes all values
  • Ds\Queue::__construct — Creates a new instance
  • Ds\Queue::copy — Returns a shallow copy of the queue
  • Ds\Queue::count — Returns the number of values in the queue
  • Ds\Queue::isEmpty — Returns whether the queue is empty
  • Ds\Queue::jsonSerialize — Regresa una representacion que puede ser convertida a JSON
  • Ds\Queue::peek — Returns the value at the front of the queue
  • Ds\Queue::pop — Removes and returns the value at the front of the queue
  • Ds\Queue::push — Añade un elemento a la cola
  • Ds\Queue::toArray — Convierte la cola en un array


Allocates enough memory for a required capacity

  • « Queue
  • Ds\Queue::capacity »
  • PHP Manual
  • Queue
  • Allocates enough memory for a required capacity

Ds\Queue::allocate

(PECL ds >= 1.0.0)

Ds\Queue::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\Queue::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Queue::allocate() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)
int(128)


Returns the current capacity

  • « Ds\Queue::allocate
  • Ds\Queue::clear »
  • PHP Manual
  • Queue
  • Returns the current capacity

Ds\Queue::capacity

(PECL ds >= 1.0.0)

Ds\Queue::capacity — Returns the current capacity

Descripción

public Ds\Queue::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\Queue::capacity() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->push(...range(1, 50));
var_dump($queue->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)
int(64)


Removes all values

  • « Ds\Queue::capacity
  • Ds\Queue::__construct »
  • PHP Manual
  • Queue
  • Removes all values

Ds\Queue::clear

(PECL ds >= 1.0.0)

Ds\Queue::clear — Removes all values

Descripción

public Ds\Queue::clear ( ) : void

Removes all values from the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\Queue::clear() example

<?php
$queue = new \Ds\Queue([1, 2, 3]);
print_r($queue);

$queue->clear();
print_r($queue);
?>

El resultado del ejemplo sería algo similar a:

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
)


Creates a new instance

  • « Ds\Queue::clear
  • Ds\Queue::copy »
  • PHP Manual
  • Queue
  • Creates a new instance

Ds\Queue::__construct

(PECL ds >= 1.0.0)

Ds\Queue::__construct — Creates a new instance

Descripción

public Ds\Queue::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

Parámetros

values

A traversable object or an array to use for the initial values.

Ejemplos

Ejemplo #1 Ds\Queue::__construct() example

<?php
$queue = new \Ds\Queue();
var_dump($queue);

$queue = new \Ds\Queue([1, 2, 3]);
var_dump($queue);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\Queue)#2 (0) {
}
object(Ds\Queue)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Returns a shallow copy of the queue

  • « Ds\Queue::__construct
  • Ds\Queue::count »
  • PHP Manual
  • Queue
  • Returns a shallow copy of the queue

Ds\Queue::copy

(PECL ds >= 1.0.0)

Ds\Queue::copy — Returns a shallow copy of the queue

Descripción

public Ds\Queue::copy ( ) : Ds\Queue

Returns a shallow copy of the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the queue.

Ejemplos

Ejemplo #1 Ds\Queue::copy() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

El resultado del ejemplo sería algo similar a:

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the queue

  • « Ds\Queue::copy
  • Ds\Queue::isEmpty »
  • PHP Manual
  • Queue
  • Returns the number of values in the queue

Ds\Queue::count

(PECL ds >= 1.0.0)

Ds\Queue::count — Returns the number of values in the queue

See Countable::count()


Returns whether the queue is empty

  • « Ds\Queue::count
  • Ds\Queue::jsonSerialize »
  • PHP Manual
  • Queue
  • Returns whether the queue is empty

Ds\Queue::isEmpty

(PECL ds >= 1.0.0)

Ds\Queue::isEmpty — Returns whether the queue is empty

Descripción

public Ds\Queue::isEmpty ( ) : bool

Returns whether the queue is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the queue is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\Queue::isEmpty() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = new \Ds\Queue();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Regresa una representacion que puede ser convertida a JSON

  • « Ds\Queue::isEmpty
  • Ds\Queue::peek »
  • PHP Manual
  • Queue
  • Regresa una representacion que puede ser convertida a JSON

Ds\Queue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Queue::jsonSerialize — Regresa una representacion que puede ser convertida a JSON

Veáse JsonSerializable::jsonSerialize()

Nota:

Nunca debería necesitar llamar esta función directamente.


Returns the value at the front of the queue

  • « Ds\Queue::jsonSerialize
  • Ds\Queue::pop »
  • PHP Manual
  • Queue
  • Returns the value at the front of the queue

Ds\Queue::peek

(PECL ds >= 1.0.0)

Ds\Queue::peek — Returns the value at the front of the queue

Descripción

public Ds\Queue::peek ( ) : mixed

Returns the value at the front of the queue, but does not remove it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value at the front of the queue.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Queue::peek() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->peek());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"


Removes and returns the value at the front of the queue

  • « Ds\Queue::peek
  • Ds\Queue::push »
  • PHP Manual
  • Queue
  • Removes and returns the value at the front of the queue

Ds\Queue::pop

(PECL ds >= 1.0.0)

Ds\Queue::pop — Removes and returns the value at the front of the queue

Descripción

public Ds\Queue::pop ( ) : mixed

Removes and returns the value at the front of the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed value which was at the front of the queue.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\Queue::pop() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->pop());
var_dump($queue->pop());
var_dump($queue->pop());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Añade un elemento a la cola

  • « Ds\Queue::pop
  • Ds\Queue::toArray »
  • PHP Manual
  • Queue
  • Añade un elemento a la cola

Ds\Queue::push

(PECL ds >= 1.0.0)

Ds\Queue::push — Añade un elemento a la cola

Descripción

public Ds\Queue::push ( mixed $...values = ? ) : void

Añade valores en la cola.

Parámetros

values

Los valores a añadir a la cola.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de Ds\Queue::push()

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c", "d");
$queue->push(...["e", "f"]);

print_r($queue);
?>

El resultado del ejemplo sería algo similar a:

Ds\Queue Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Convierte la cola en un array

  • « Ds\Queue::push
  • PriorityQueue »
  • PHP Manual
  • Queue
  • Convierte la cola en un array

Ds\Queue::toArray

(PECL ds >= 1.0.0)

Ds\Queue::toArray — Convierte la cola en un array

Descripción

public Ds\Queue::toArray ( ) : array

Convierte la cola en un array.

Nota:

Un casting a un array no se soporta todavía.

Nota:

Este método no es destructivo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array conteniendo todos los elementos en el mismo orden que la cola.

Ejemplos

Ejemplo #1 Ejemplo de Ds\Queue::toArray()

<?php
$queue = new \Ds\Queue([1, 2, 3]);

var_dump($queue->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


The PriorityQueue class

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

A PriorityQueue is very similar to a Queue. Values are pushed into the queue with an assigned priority, and the value with the highest priority will always be at the front of the queue.

Implemented using a max heap.

Nota:

"First in, first out" ordering is preserved for values with the same priority.

Nota:

Iterating over a PriorityQueue is destructive, equivalent to successive pop operations until the queue is empty.

Sinopsis de la Clase

Ds\PriorityQueue implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* Métodos */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\PriorityQueue
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed $value , int $priority ) : void
public toArray ( ) : array
}

Constantes predefinidas

Ds\PriorityQueue::MIN_CAPACITY

Tabla de contenidos

  • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity
  • Ds\PriorityQueue::capacity — Returns the current capacity
  • Ds\PriorityQueue::clear — Removes all values
  • Ds\PriorityQueue::__construct — Creates a new instance
  • Ds\PriorityQueue::copy — Returns a shallow copy of the queue
  • Ds\PriorityQueue::count — Returns the number of values in the queue
  • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
  • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\PriorityQueue::peek — Returns the value at the front of the queue
  • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority
  • Ds\PriorityQueue::push — Pushes values into the queue
  • Ds\PriorityQueue::toArray — Converts the queue to an array


Allocates enough memory for a required capacity

  • « PriorityQueue
  • Ds\PriorityQueue::capacity »
  • PHP Manual
  • PriorityQueue
  • Allocates enough memory for a required capacity

Ds\PriorityQueue::allocate

(PECL ds >= 1.0.0)

Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity

Descripción

public Ds\PriorityQueue::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Parámetros

capacity

The number of values for which capacity should be allocated.

Nota:

Capacity will stay the same if this value is less than or equal to the current capacity.

Nota:

Capacity will always be rounded up to the nearest power of 2.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::allocate() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)
int(128)


Returns the current capacity

  • « Ds\PriorityQueue::allocate
  • Ds\PriorityQueue::clear »
  • PHP Manual
  • PriorityQueue
  • Returns the current capacity

Ds\PriorityQueue::capacity

(PECL ds >= 1.0.0)

Ds\PriorityQueue::capacity — Returns the current capacity

Descripción

public Ds\PriorityQueue::capacity ( ) : int

Returns the current capacity.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current capacity.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::capacity() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());
?>

El resultado del ejemplo sería algo similar a:

int(8)


Removes all values

  • « Ds\PriorityQueue::capacity
  • Ds\PriorityQueue::__construct »
  • PHP Manual
  • PriorityQueue
  • Removes all values

Ds\PriorityQueue::clear

(PECL ds >= 1.0.0)

Ds\PriorityQueue::clear — Removes all values

Descripción

public Ds\PriorityQueue::clear ( ) : void

Removes all values from the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::clear() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

$queue->clear();
print_r($queue);
?>

El resultado del ejemplo sería algo similar a:

Ds\PriorityQueue Object
(
)


Creates a new instance

  • « Ds\PriorityQueue::clear
  • Ds\PriorityQueue::copy »
  • PHP Manual
  • PriorityQueue
  • Creates a new instance

Ds\PriorityQueue::__construct

(PECL ds >= 1.0.0)

Ds\PriorityQueue::__construct — Creates a new instance

Descripción

public Ds\PriorityQueue::__construct ( )

Creates a new instance.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::__construct() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue);
?>

El resultado del ejemplo sería algo similar a:

object(Ds\PriorityQueue)#1 (0) {
}


Returns a shallow copy of the queue

  • « Ds\PriorityQueue::__construct
  • Ds\PriorityQueue::count »
  • PHP Manual
  • PriorityQueue
  • Returns a shallow copy of the queue

Ds\PriorityQueue::copy

(PECL ds >= 1.0.0)

Ds\PriorityQueue::copy — Returns a shallow copy of the queue

Descripción

public Ds\PriorityQueue::copy ( ) : Ds\PriorityQueue

Returns a shallow copy of the queue.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a shallow copy of the queue.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::copy() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->copy());
?>

El resultado del ejemplo sería algo similar a:

Ds\PriorityQueue Object
(
    [0] => b
    [1] => c
    [2] => a
)


Returns the number of values in the queue

  • « Ds\PriorityQueue::copy
  • Ds\PriorityQueue::isEmpty »
  • PHP Manual
  • PriorityQueue
  • Returns the number of values in the queue

Ds\PriorityQueue::count

(PECL ds >= 1.0.0)

Ds\PriorityQueue::count — Returns the number of values in the queue

See Countable::count()


Returns whether the queue is empty

  • « Ds\PriorityQueue::count
  • Ds\PriorityQueue::jsonSerialize »
  • PHP Manual
  • PriorityQueue
  • Returns whether the queue is empty

Ds\PriorityQueue::isEmpty

(PECL ds >= 1.0.0)

Ds\PriorityQueue::isEmpty — Returns whether the queue is empty

Descripción

public Ds\PriorityQueue::isEmpty ( ) : bool

Returns whether the queue is empty.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the queue is empty, false otherwise.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::isEmpty() example

<?php
$a = new \Ds\PriorityQueue();
$b = new \Ds\PriorityQueue();

$a->push("a",  5);
$a->push("b", 15);
$a->push("c", 10);

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • « Ds\PriorityQueue::isEmpty
  • Ds\PriorityQueue::peek »
  • PHP Manual
  • PriorityQueue
  • Returns a representation that can be converted to JSON

Ds\PriorityQueue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Nota:

You should never need to call this directly.


Returns the value at the front of the queue

  • « Ds\PriorityQueue::jsonSerialize
  • Ds\PriorityQueue::pop »
  • PHP Manual
  • PriorityQueue
  • Returns the value at the front of the queue

Ds\PriorityQueue::peek

(PECL ds >= 1.0.0)

Ds\PriorityQueue::peek — Returns the value at the front of the queue

Descripción

public Ds\PriorityQueue::peek ( ) : mixed

Returns the value at the front of the queue, but does not remove it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value at the front of the queue.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::peek() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->peek());
?>

El resultado del ejemplo sería algo similar a:

string(1) "b"


Removes and returns the value with the highest priority

  • « Ds\PriorityQueue::peek
  • Ds\PriorityQueue::push »
  • PHP Manual
  • PriorityQueue
  • Removes and returns the value with the highest priority

Ds\PriorityQueue::pop

(PECL ds >= 1.0.0)

Ds\PriorityQueue::pop — Removes and returns the value with the highest priority

Descripción

public Ds\PriorityQueue::pop ( ) : mixed

Removes and returns the value at the front of the queue, ie. the value with the highest priority.

Nota:

Values with equal priority fall back to FIFO (first in first out).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The removed value which was at the front of the queue.

Errores/Excepciones

UnderflowException if empty.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::pop() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

El resultado del ejemplo sería algo similar a:

string(1) "a"
string(1) "b"
string(1) "c"


Pushes values into the queue

  • « Ds\PriorityQueue::pop
  • Ds\PriorityQueue::toArray »
  • PHP Manual
  • PriorityQueue
  • Pushes values into the queue

Ds\PriorityQueue::push

(PECL ds >= 1.0.0)

Ds\PriorityQueue::push — Pushes values into the queue

Descripción

public Ds\PriorityQueue::push ( mixed $value , int $priority ) : void

Pushes a value with a given priority into the queue.

Parámetros

value

The value to push into the queue.

priority

The priority associated with the value.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::push() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

El resultado del ejemplo sería algo similar a:

string(1) "b"
string(1) "c"
string(1) "a"


Converts the queue to an array

  • « Ds\PriorityQueue::push
  • Otros servicios »
  • PHP Manual
  • PriorityQueue
  • Converts the queue to an array

Ds\PriorityQueue::toArray

(PECL ds >= 1.0.0)

Ds\PriorityQueue::toArray — Converts the queue to an array

Descripción

public Ds\PriorityQueue::toArray ( ) : array

Converts the queue to an array.

Nota:

This method is not destructive.

Nota:

Casting to an array is not supported yet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array containing all the values in the same order as the queue.

Ejemplos

Ejemplo #1 Ds\PriorityQueue::toArray() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->toArray());
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  string(1) "b"
  [1]=>
  string(1) "c"
  [2]=>
  string(1) "a"
}


Otros servicios

  • cURL — Biblioteca URL cliente
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de cURL
    • CURLFile — La clase CURLFile
  • Event
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • Event flags
    • About event persistence
    • Event callbacks
    • Constructing signal events
    • Event — The Event class
    • EventBase — The EventBase class
    • EventBuffer — The EventBuffer class
    • EventBufferEvent — The EventBufferEvent class
    • About buffer event callbacks
    • EventConfig — The EventConfig class
    • EventDnsBase — The EventDnsBase class
    • EventHttp — The EventHttp class
    • EventHttpConnection — The EventHttpConnection class
    • EventHttpRequest — The EventHttpRequest class
    • EventListener — The EventListener class
    • EventSslContext — The EventSslContext class
    • EventUtil — The EventUtil class
  • FTP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de FTP
  • Gearman
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • GearmanClient — Clase GearmanClient
    • GearmanJob — La clase GearmanJob
    • GearmanTask — La clase GearmanTask
    • GearmanWorker — La clase GearmanWorker
    • GearmanException — La clase GearmanException
  • LDAP — Protocolo Ligero de Acceso a Directorios
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Utilizando las llamadas PHP LDAPs
    • Controles de LDAP
    • Ejemplos
    • LDAP Funciones
  • Memcache
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Memcache — La clase Memcache
    • Funciones de Memcache
  • Memcached
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Tiempos de expiración
    • Retrollamadas
    • Soporte para sesiones
    • Memcached — La clase Memcached
    • MemcachedException — La clase MemcachedException
  • mqseries
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • mqseries Funciones
  • Network
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de red
  • RRD — RRDtool
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones RRD
    • RRDCreator — La clase RRDCreator
    • RRDGraph — La clase RRDGraph
    • RRDUpdater — La clase RRDUpdater
  • ScoutAPM
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Scoutapm Funciones
  • SNMP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones SNMP
    • SNMP — The SNMP class
    • SNMPException — The SNMPException class
  • Sockets
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Errores de Socket
    • Funciones de Socket
  • SSH2 — Secure Shell2
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de SSH2
  • Stomp — Cliente Stomp
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • Funciones Stomp
    • Stomp — La clase Stomp
    • StompFrame — La clase StompFrame
    • StompException — La clase StompException
  • SVM — Soporte Vector Machine
    • Introducción
    • Instalación/Configuración
    • Ejemplos
    • SVM — La clase SVM
    • SVMModel — La clase SVMModel
  • SVN — Subversion
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones SVN
  • TCP — Envolturas TCP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • TCP Funciones
  • Varnish
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • VarnishAdmin — La clase VarnishAdmin
    • VarnishStat — La clase VarnishStat
    • VarnishLog — La clase VarnishLog
  • YAZ
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de YAZ
  • Mensajería de 0MQ — ZMQ
    • Introducción
    • Instalación/Configuración
    • ZMQ — La clase ZMQ
    • ZMQContext — La clase ZMQContext
    • ZMQSocket — La clase ZMQSocket
    • ZMQPoll — La clase ZMQPoll
    • ZMQDevice — La clase ZMQDevice
  • ZooKeeper
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • ZooKeeper Funciones
    • Zookeeper — La clase Zookeeper
    • ZookeeperConfig — La clase ZookeeperConfig
    • ZookeeperException — La clase ZookeeperException
    • ZookeeperAuthenticationException — La clase ZookeeperAuthenticationException
    • ZookeeperConnectionException — La clase ZookeeperConnectionException
    • ZookeeperMarshallingException — La clase ZookeeperMarshallingException
    • ZookeeperNoNodeException — La clase ZookeeperNoNodeException
    • ZookeeperOperationTimeoutException — La clase ZookeeperOperationTimeoutException
    • ZookeeperSessionException — La clase ZookeeperSessionException


Biblioteca URL cliente

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ejemplo de curl básico
  • Funciones de cURL
    • curl_close — Cierra una sesión cURL
    • curl_copy_handle — Copia el recurso cURL junto con todas sus preferencias
    • curl_errno — Devuelve el último número de error
    • curl_error — Devuelve una cadena que contiene el último error de la sesión actual
    • curl_escape — Función URL que codifica el string dado
    • curl_exec — Establece una sesión cURL
    • curl_file_create — Crea un objeto CURLFile
    • curl_getinfo — Obtener información sobre una transferencia específica
    • curl_init — Inicia sesión cURL
    • curl_multi_add_handle — Añade un recurso cURL a un grupo de recursos cURL
    • curl_multi_close — Cierra un grupo de recursos cURL
    • curl_multi_errno — Devuelve el último número de error de cURL múltiple
    • curl_multi_exec — Ejecuta las sub-conexiones del recurso cURL actual
    • curl_multi_getcontent — Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado
    • curl_multi_info_read — Obtiene información de las transferencias en curso
    • curl_multi_init — Devuelve un nuevo multi recurso cURL
    • curl_multi_remove_handle — Elimina un multi recurso de un conjunto de recursos cURL
    • curl_multi_select — Espera actividad en cualquier conexión en curl_multi
    • curl_multi_setopt — Configura una opción para el multi gestor cURL
    • curl_multi_strerror — Devuelve un string con la descripción del código de error
    • curl_pause — Pausa y reanuda una conexión
    • curl_reset — Reinicializa todas las opciones de un gestor de sesión libcurl
    • curl_setopt_array — Configura múltiples opciones para una transferencia cURL
    • curl_setopt — Configura una opción para una transferencia cURL
    • curl_share_close — Cierra un gestor cURL compartido
    • curl_share_errno — Devuelve el último número del error compartido cURL
    • curl_share_init — Inicializar un gestor cURL compartido
    • curl_share_setopt — Configura una opción para un manejador cURL compartido
    • curl_share_strerror — Devuelve string con la descripción del codigo de error dado
    • curl_strerror — Devuelve un string que describe el código de error dado
    • curl_unescape — Descodifica un string codificado de URL
    • curl_version — Obtiene la información de la versión de cURL
  • CURLFile — La clase CURLFile
    • CURLFile::__construct — Crear un objeto CURLFile
    • CURLFile::getFilename — Recupera el nombre de un fichero
    • CURLFile::getMimeType — Recupera el tipo MIME
    • CURLFile::getPostFilename — Recupera el nombre de fichero para POST
    • CURLFile::setMimeType — Configura el tipo MIME
    • CURLFile::setPostFilename — Establecer el nombre de fichero para POST


Introducción

PHP soporta libcurl, una biblioteca creada por Daniel Stenberg que permite conectarse y comunicarse con diferentes tipos de servidores y diferentes tipos de protocolos. Actualmente, libcurl admite los protocolos http, https, ftp, gopher, telnet, dict, file y ldap. libcurl también admite certificados HTTPS, HTTP, POST, HTTP PUT, subidas mediante FTP (también se puede hacer con la extensión FTP de PHP), subidas basadas en formularios HTTP, proxies, cookies, y autenticación usuario+contraseña.


Requerimientos

Para poder usar las funciones de cURL para PHP se debe instalar el paquete » libcurl. PHP requiere la versión de libcurl 7.10.5 o posterior.


Instalación

Para usar el soporte para cURL de PHP, se debe compilar PHP con --with-curl[=DIR], donde DIR es la ubicación del directorio que contiene los directorios lib e include. En el directorio include, debería haber una carpeta llamada curl que debería contener los ficheros easy.h y curl.h. Debería haber un fichero llamado libcurl.a ubicado en el directorio lib. Desde PHP 4.3.0, se puede configurar PHP para usar cURL para los flujos de URL con --with-curlwrappers. Esta característica ha sido movida a PECL a partir de PHP 5.5.0.

Nota: Nota para los usuarios de Win32
Para poder habilitar este módulo en un entorno Windows, los ficheros libeay32.dll y ssleay32.dll deben estar presentes en la PATH. No se require libcurl.dll del sitio de cURL.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de Configuración de cURL
Nombre | Por defecto | Cambiable | Historial de cambios
curl.cainfo | NULL | PHP_INI_SYSTEM | Disponible desde PHP 5.3.7.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

curl.cainfo string

Define un valor predeterminado para la opción CURLOPT_CAINFO. Debe especificarse una ruta absoluta.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define dos tipos de recursos: un gestor cURL y un multigestor cURL.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Las descripciones y usos de estas constantes están descritas en la documentación de curl_setopt(), curl_multi_setopt() y curl_getinfo().

CURLOPT_AUTOREFERER (integer)
Disponible desde PHP 5.1.0
CURLOPT_COOKIESESSION (integer)
Disponible desde PHP 5.1.0
CURLOPT_DNS_USE_GLOBAL_CACHE (integer)
CURLOPT_DNS_CACHE_TIMEOUT (integer)
CURLOPT_FTP_SSL (integer)
Disponible desde PHP 5.2.0
CURLFTPSSL_TRY (integer)
Disponible desde PHP 5.2.0
CURLFTPSSL_ALL (integer)
Disponible desde PHP 5.2.0
CURLFTPSSL_CONTROL (integer)
Disponible desde PHP 5.2.0
CURLFTPSSL_NONE (integer)
Disponible desde PHP 5.2.0
CURLOPT_PRIVATE (integer)
Disponible desde PHP 5.2.4
CURLOPT_FTPSSLAUTH (integer)
Disponible desde PHP 5.1.0
CURLOPT_PORT (integer)
CURLOPT_FILE (integer)
CURLOPT_INFILE (integer)
CURLOPT_INFILESIZE (integer)
CURLOPT_URL (integer)
CURLOPT_PROXY (integer)
CURLOPT_VERBOSE (integer)
CURLOPT_HEADER (integer)
CURLOPT_HTTPHEADER (integer)
CURLOPT_NOPROGRESS (integer)
CURLOPT_NOBODY (integer)
CURLOPT_FAILONERROR (integer)
CURLOPT_UPLOAD (integer)
CURLOPT_POST (integer)
CURLOPT_FTPLISTONLY (integer)
CURLOPT_FTPAPPEND (integer)
CURLOPT_FTP_CREATE_MISSING_DIRS (integer)
CURLOPT_NETRC (integer)
CURLOPT_FOLLOWLOCATION (integer)
Esta constante no está disponible cuando open_basedir está habilitado.
CURLOPT_FTPASCII (integer)
CURLOPT_PUT (integer)
CURLOPT_MUTE (integer)
CURLOPT_USERPWD (integer)
CURLOPT_PROXYUSERPWD (integer)
CURLOPT_RANGE (integer)
CURLOPT_TIMEOUT (integer)
CURLOPT_TIMEOUT_MS (integer)
CURLOPT_TCP_NODELAY (integer)
Disponible desde PHP 5.2.1
CURLOPT_POSTFIELDS (integer)
CURLOPT_PROGRESSFUNCTION (integer)
Disponible desde PHP 5.3.0
CURLOPT_REFERER (integer)
CURLOPT_USERAGENT (integer)
CURLOPT_FTPPORT (integer)
CURLOPT_FTP_USE_EPSV (integer)
CURLOPT_LOW_SPEED_LIMIT (integer)
CURLOPT_LOW_SPEED_TIME (integer)
CURLOPT_RESUME_FROM (integer)
CURLOPT_COOKIE (integer)
CURLOPT_SSLCERT (integer)
CURLOPT_SSLCERTPASSWD (integer)
CURLOPT_WRITEHEADER (integer)
CURLOPT_SSL_VERIFYHOST (integer)
CURLOPT_COOKIEFILE (integer)
CURLOPT_SSLVERSION (integer)
CURL_SSLVERSION_DEFAULT (integer)
CURL_SSLVERSION_TLSv1 (integer)
CURL_SSLVERSION_SSLv2 (integer)
CURL_SSLVERSION_SSLv3 (integer)
CURL_SSLVERSION_TLSv1_0 (integer)
Disponible desde PHP 5.5.19 y 5.6.3
CURL_SSLVERSION_TLSv1_1 (integer)
Disponible desde PHP 5.5.19 y 5.6.3
CURL_SSLVERSION_TLSv1_2 (integer)
ADisponible desde PHP 5.5.19 y 5.6.3
CURLOPT_TIMECONDITION (integer)
CURLOPT_TIMEVALUE (integer)
CURLOPT_CUSTOMREQUEST (integer)
CURLOPT_STDERR (integer)
CURLOPT_TRANSFERTEXT (integer)
CURLOPT_RETURNTRANSFER (integer)
CURLOPT_QUOTE (integer)
CURLOPT_POSTQUOTE (integer)
CURLOPT_INTERFACE (integer)
CURLOPT_KRB4LEVEL (integer)
CURLOPT_HTTPPROXYTUNNEL (integer)
CURLOPT_FILETIME (integer)
CURLOPT_WRITEFUNCTION (integer)
CURLOPT_READFUNCTION (integer)
CURLOPT_PASSWDFUNCTION (integer)
CURLOPT_HEADERFUNCTION (integer)
CURLOPT_MAXREDIRS (integer)
CURLOPT_MAXCONNECTS (integer)
CURLOPT_CLOSEPOLICY (integer)
Eliminada en PHP 5.6.0.
CURLOPT_FRESH_CONNECT (integer)
CURLOPT_FORBID_REUSE (integer)
CURLOPT_RANDOM_FILE (integer)
CURLOPT_EGDSOCKET (integer)
CURLOPT_CONNECTTIMEOUT (integer)
CURLOPT_CONNECTTIMEOUT_MS (integer)
CURLOPT_SSL_VERIFYPEER (integer)
CURLOPT_CAINFO (integer)
CURLOPT_CAPATH (integer)
CURLOPT_COOKIEJAR (integer)
CURLOPT_SSL_CIPHER_LIST (integer)
CURLOPT_BINARYTRANSFER (integer)
CURLOPT_NOSIGNAL (integer)
CURLOPT_PROXYTYPE (integer)
Disponible a partir de cURL 7.10.
CURLOPT_BUFFERSIZE (integer)
CURLOPT_HTTPGET (integer)
CURLOPT_HTTP_VERSION (integer)
CURLOPT_SSLKEY (integer)
CURLOPT_SSLKEYTYPE (integer)
CURLOPT_SSLKEYPASSWD (integer)
CURLOPT_SSLENGINE (integer)
CURLOPT_SSLENGINE_DEFAULT (integer)
CURLOPT_SSLCERTTYPE (integer)
CURLOPT_CRLF (integer)
CURLOPT_ENCODING (integer)
CURLOPT_PROXYPORT (integer)
CURLOPT_UNRESTRICTED_AUTH (integer)
CURLOPT_FTP_USE_EPRT (integer)
CURLOPT_HTTP200ALIASES (integer)
CURLOPT_HTTPAUTH (integer)
CURLAUTH_BASIC (integer)
CURLAUTH_DIGEST (integer)
CURLAUTH_GSSNEGOTIATE (integer)
CURLAUTH_NTLM (integer)
CURLAUTH_ANY (integer)
CURLAUTH_ANYSAFE (integer)
CURLOPT_PROXYAUTH (integer)
CURLOPT_MAX_RECV_SPEED_LARGE (integer)
Disponible desde PHP 5.4.0 y cURL 7.15.5
CURLOPT_MAX_SEND_SPEED_LARGE (integer)
Disponible desde PHP 5.4.0 y cURL 7.15.5
CURLCLOSEPOLICY_LEAST_RECENTLY_USED (integer)
Eliminada en PHP 5.6.0.
CURLCLOSEPOLICY_LEAST_TRAFFIC (integer)
Eliminada en PHP 5.6.0.
CURLCLOSEPOLICY_SLOWEST (integer)
Eliminada en PHP 5.6.0.
CURLCLOSEPOLICY_CALLBACK (integer)
Eliminada en PHP 5.6.0.
CURLCLOSEPOLICY_OLDEST (integer)
Eliminada en PHP 5.6.0.
CURLINFO_PRIVATE (integer)
Disponible desde PHP 5.2.4
CURLINFO_EFFECTIVE_URL (integer)
CURLINFO_HTTP_CODE (integer)
CURLINFO_HEADER_OUT (integer)
Disponible desde PHP 5.1.3
CURLINFO_HEADER_SIZE (integer)
CURLINFO_REQUEST_SIZE (integer)
CURLINFO_TOTAL_TIME (integer)
CURLINFO_NAMELOOKUP_TIME (integer)
CURLINFO_CONNECT_TIME (integer)
CURLINFO_PRETRANSFER_TIME (integer)
CURLINFO_SIZE_UPLOAD (integer)
CURLINFO_SIZE_DOWNLOAD (integer)
CURLINFO_SPEED_DOWNLOAD (integer)
CURLINFO_SPEED_UPLOAD (integer)
CURLINFO_FILETIME (integer)
CURLINFO_SSL_VERIFYRESULT (integer)
CURLINFO_CONTENT_LENGTH_DOWNLOAD (integer)
CURLINFO_CONTENT_LENGTH_UPLOAD (integer)
CURLINFO_STARTTRANSFER_TIME (integer)
CURLINFO_CONTENT_TYPE (integer)
CURLINFO_REDIRECT_TIME (integer)
CURLINFO_REDIRECT_COUNT (integer)
CURLINFO_REDIRECT_URL (string)
Disponible desde PHP 5.3.7
CURLINFO_PRIMARY_IP (string)
Disponible desde PHP 5.4.7
CURLINFO_PRIMARY_PORT (integer)
Disponible desde PHP 5.4.7
CURLINFO_LOCAL_IP (string)
Disponible desde PHP 5.4.7
CURLINFO_LOCAL_PORT (integer)
Disponible desde PHP 5.4.7
CURL_TIMECOND_IFMODSINCE (integer)
CURL_TIMECOND_IFUNMODSINCE (integer)
CURL_TIMECOND_LASTMOD (integer)
CURL_VERSION_IPV6 (integer)
CURL_VERSION_KERBEROS4 (integer)
CURL_VERSION_SSL (integer)
CURL_VERSION_LIBZ (integer)
CURLVERSION_NOW (integer)
CURLE_OK (integer)
CURLE_UNSUPPORTED_PROTOCOL (integer)
CURLE_FAILED_INIT (integer)
CURLE_URL_MALFORMAT (integer)
CURLE_URL_MALFORMAT_USER (integer)
CURLE_COULDNT_RESOLVE_PROXY (integer)
CURLE_COULDNT_RESOLVE_HOST (integer)
CURLE_COULDNT_CONNECT (integer)
CURLE_FTP_WEIRD_SERVER_REPLY (integer)
CURLE_FTP_ACCESS_DENIED (integer)
CURLE_FTP_USER_PASSWORD_INCORRECT (integer)
CURLE_FTP_WEIRD_PASS_REPLY (integer)
CURLE_FTP_WEIRD_USER_REPLY (integer)
CURLE_FTP_WEIRD_PASV_REPLY (integer)
CURLE_FTP_WEIRD_227_FORMAT (integer)
CURLE_FTP_CANT_GET_HOST (integer)
CURLE_FTP_CANT_RECONNECT (integer)
CURLE_FTP_COULDNT_SET_BINARY (integer)
CURLE_PARTIAL_FILE (integer)
CURLE_FTP_COULDNT_RETR_FILE (integer)
CURLE_FTP_WRITE_ERROR (integer)
CURLE_FTP_QUOTE_ERROR (integer)
CURLE_HTTP_NOT_FOUND (integer)
CURLE_WRITE_ERROR (integer)
CURLE_MALFORMAT_USER (integer)
CURLE_FTP_COULDNT_STOR_FILE (integer)
CURLE_READ_ERROR (integer)
CURLE_OUT_OF_MEMORY (integer)
CURLE_OPERATION_TIMEOUTED (integer)
CURLE_FTP_COULDNT_SET_ASCII (integer)
CURLE_FTP_PORT_FAILED (integer)
CURLE_FTP_COULDNT_USE_REST (integer)
CURLE_FTP_COULDNT_GET_SIZE (integer)
CURLE_HTTP_RANGE_ERROR (integer)
CURLE_HTTP_POST_ERROR (integer)
CURLE_SSL_CONNECT_ERROR (integer)
CURLE_FTP_BAD_DOWNLOAD_RESUME (integer)
CURLE_FILE_COULDNT_READ_FILE (integer)
CURLE_LDAP_CANNOT_BIND (integer)
CURLE_LDAP_SEARCH_FAILED (integer)
CURLE_LIBRARY_NOT_FOUND (integer)
CURLE_FUNCTION_NOT_FOUND (integer)
CURLE_ABORTED_BY_CALLBACK (integer)
CURLE_BAD_FUNCTION_ARGUMENT (integer)
CURLE_BAD_CALLING_ORDER (integer)
CURLE_HTTP_PORT_FAILED (integer)
CURLE_BAD_PASSWORD_ENTERED (integer)
CURLE_TOO_MANY_REDIRECTS (integer)
CURLE_UNKNOWN_TELNET_OPTION (integer)
CURLE_TELNET_OPTION_SYNTAX (integer)
CURLE_OBSOLETE (integer)
CURLE_SSL_PEER_CERTIFICATE (integer)
CURLE_GOT_NOTHING (integer)
CURLE_SSL_ENGINE_NOTFOUND (integer)
CURLE_SSL_ENGINE_SETFAILED (integer)
CURLE_SEND_ERROR (integer)
CURLE_RECV_ERROR (integer)
CURLE_SHARE_IN_USE (integer)
CURLE_SSL_CERTPROBLEM (integer)
CURLE_SSL_CIPHER (integer)
CURLE_SSL_CACERT (integer)
CURLE_BAD_CONTENT_ENCODING (integer)
CURLE_LDAP_INVALID_URL (integer)
CURLE_FILESIZE_EXCEEDED (integer)
CURLE_FTP_SSL_FAILED (integer)
CURLE_SSH (integer)
Disponible desde PHP 5.3.0 y cURL 7.16.1.
CURLFTPAUTH_DEFAULT (integer)
Disponible desde PHP 5.1.0
CURLFTPAUTH_SSL (integer)
Disponible desde PHP 5.1.0
CURLFTPAUTH_TLS (integer)
Disponible desde PHP 5.1.0
CURLPROXY_HTTP (integer)
Disponible desde cURL 7.10.
CURLPROXY_SOCKS4 (integer)
Disponible desde PHP 5.2.10 y cURL 7.10.
CURLPROXY_SOCKS5 (integer)
Disponible desde cURL 7.10.
CURL_NETRC_OPTIONAL (integer)
CURL_NETRC_IGNORED (integer)
CURL_NETRC_REQUIRED (integer)
CURL_HTTP_VERSION_NONE (integer)
CURL_HTTP_VERSION_1_0 (integer)
CURL_HTTP_VERSION_1_1 (integer)
CURLM_CALL_MULTI_PERFORM (integer)
CURLM_OK (integer)
CURLM_BAD_HANDLE (integer)
CURLM_BAD_EASY_HANDLE (integer)
CURLM_OUT_OF_MEMORY (integer)
CURLM_INTERNAL_ERROR (integer)
CURLMSG_DONE (integer)
CURLOPT_KEYPASSWD (integer)
CURLOPT_SSH_AUTH_TYPES (integer)
CURLOPT_SSH_HOST_PUBLIC_KEY_MD5 (integer)
CURLOPT_SSH_PRIVATE_KEYFILE (integer)
CURLOPT_SSH_PUBLIC_KEYFILE (integer)
CURLMOPT_PIPELINING (integer)
Disponible desde PHP 5.5.0 y cURL 7.16.0.
CURLMOPT_MAXCONNECTS (integer)
Disponible desde PHP 5.5.0 y cURL 7.16.3.
CURLSSH_AUTH_ANY (integer)
CURLSSH_AUTH_DEFAULT (integer)
CURLSSH_AUTH_HOST (integer)
CURLSSH_AUTH_KEYBOARD (integer)
CURLSSH_AUTH_NONE (integer)
CURLSSH_AUTH_PASSWORD (integer)
CURLSSH_AUTH_PUBLICKEY (integer)
CURL_WRAPPERS_ENABLED (integer)
Definida si PHP fue configurado con --with-curlwrappers. Movido a PECL en PHP 5.5.0.
CURLPAUSE_ALL (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPAUSE_CONT (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPAUSE_RECV (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPAUSE_RECV_CONT (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPAUSE_SEND (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPAUSE_SEND_CONT (integer)
Disponible desde PHP 5.5.0 y cURL 7.18.0.
CURLPIPE_NOTHING (integer)
Disponible desde PHP 7.0.0 y cURL 7.43.0.
CURLPIPE_HTTP1 (integer)
Disponible desde PHP 7.0.0 y cURL 7.43.0.
CURLPIPE_MULTIPLEX (integer)
Disponible desde PHP 7.0.0 y cURL 7.43.0.
CURLPROXY_SOCKS4A (integer)
Disponible desde PHP 5.5.23 y PHP 5.6.7 y cURL 7.18.0.
CURLPROXY_SOCKS5_HOSTNAME (integer)
Disponible desde PHP 5.5.23 y PHP 5.6.7 y cURL 7.18.0.


  • « Constantes predefinidas
  • Ejemplo de curl básico »
  • PHP Manual
  • cURL
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplo de curl básico


Ejemplo de curl básico

Una vez haya compilado PHP con soporte para cURL, puede empezar a usar las funciones cURL. Básicamente debe inicializar una sesión cURL usando curl_init(), establecer todas las opciones para la transferencia usando curl_setopt(), ejecutar la sesión con la función curl_exec() y finalizar la sesión con curl_close()- Aquí tiene un ejemplo donde usamos funciones cURL para capturar el contenido de la página principal de example.com en un fichero:

Ejemplo #1 Uso del módulo cURL de PHP para capturar página principal de example.com

<?php

$ch = curl_init("http://www.example.com/");
$fp = fopen("example_homepage.txt", "w");

curl_setopt($ch, CURLOPT_FILE, $fp);
curl_setopt($ch, CURLOPT_HEADER, 0);

curl_exec($ch);
curl_close($ch);
fclose($fp);
?>


Funciones de cURL

Tabla de contenidos

  • curl_close — Cierra una sesión cURL
  • curl_copy_handle — Copia el recurso cURL junto con todas sus preferencias
  • curl_errno — Devuelve el último número de error
  • curl_error — Devuelve una cadena que contiene el último error de la sesión actual
  • curl_escape — Función URL que codifica el string dado
  • curl_exec — Establece una sesión cURL
  • curl_file_create — Crea un objeto CURLFile
  • curl_getinfo — Obtener información sobre una transferencia específica
  • curl_init — Inicia sesión cURL
  • curl_multi_add_handle — Añade un recurso cURL a un grupo de recursos cURL
  • curl_multi_close — Cierra un grupo de recursos cURL
  • curl_multi_errno — Devuelve el último número de error de cURL múltiple
  • curl_multi_exec — Ejecuta las sub-conexiones del recurso cURL actual
  • curl_multi_getcontent — Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado
  • curl_multi_info_read — Obtiene información de las transferencias en curso
  • curl_multi_init — Devuelve un nuevo multi recurso cURL
  • curl_multi_remove_handle — Elimina un multi recurso de un conjunto de recursos cURL
  • curl_multi_select — Espera actividad en cualquier conexión en curl_multi
  • curl_multi_setopt — Configura una opción para el multi gestor cURL
  • curl_multi_strerror — Devuelve un string con la descripción del código de error
  • curl_pause — Pausa y reanuda una conexión
  • curl_reset — Reinicializa todas las opciones de un gestor de sesión libcurl
  • curl_setopt_array — Configura múltiples opciones para una transferencia cURL
  • curl_setopt — Configura una opción para una transferencia cURL
  • curl_share_close — Cierra un gestor cURL compartido
  • curl_share_errno — Devuelve el último número del error compartido cURL
  • curl_share_init — Inicializar un gestor cURL compartido
  • curl_share_setopt — Configura una opción para un manejador cURL compartido
  • curl_share_strerror — Devuelve string con la descripción del codigo de error dado
  • curl_strerror — Devuelve un string que describe el código de error dado
  • curl_unescape — Descodifica un string codificado de URL
  • curl_version — Obtiene la información de la versión de cURL


Cierra una sesión cURL

  • « Funciones de cURL
  • curl_copy_handle »
  • PHP Manual
  • Funciones de cURL
  • Cierra una sesión cURL

curl_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_close — Cierra una sesión cURL

Descripción

curl_close ( resource $ch ) : void

Esta función cierra una sesión CURL y libera todos sus recursos. El recurso CURL, ch, también es eliminado.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Inicializar una nueva sesión CURL y capturar una página web

<?php
// Se crea un manejador CURL
$ch = curl_init();

// Se establece la URL y algunas opciones
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// Se obtiene la URL indicada y se envía al navegador
curl_exec($ch);

// Se cierra el recurso CURL y se liberan los recursos del sistema
curl_close($ch);
?>

Ver también

  • curl_init() - Inicia sesión cURL
  • curl_multi_close() - Cierra un grupo de recursos cURL


Copia el recurso cURL junto con todas sus preferencias

  • « curl_close
  • curl_errno »
  • PHP Manual
  • Funciones de cURL
  • Copia el recurso cURL junto con todas sus preferencias

curl_copy_handle

(PHP 5, PHP 7, PHP 8)

curl_copy_handle — Copia el recurso cURL junto con todas sus preferencias

Descripción

curl_copy_handle ( resource $ch ) : resource

Copia un recurso de cURL manteniendo las mismas preferencias.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve un nuevo recurso de cURL.

Ejemplos

Ejemplo #1 Copiar un recurso cURL

<?php
// Crea un nuevo recurso de cURL
$ch = curl_init();

// Establece la URL y otras opciones apropiadas
curl_setopt($ch, CURLOPT_URL, 'http://www.example.com/');
curl_setopt($ch, CURLOPT_HEADER, 0);

// Copia el recurso
$ch2 = curl_copy_handle($ch);

// Captura la URL (http://www.example.com/) y la pasa al navegador
curl_exec($ch2);

// Cierra el recurso cURL y libera recursos del sistema
curl_close($ch2);
curl_close($ch);
?>


Devuelve el último número de error

  • « curl_copy_handle
  • curl_error »
  • PHP Manual
  • Funciones de cURL
  • Devuelve el último número de error

curl_errno

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

curl_errno — Devuelve el último número de error

Descripción

curl_errno ( resource $ch ) : int

Devuelve el número de error de la última operación cURL.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve el número de error ó 0 (cero) si no ocurrió ningún error.

Ejemplos

Ejemplo #1 curl_errno() ejemplo

<?php
// Crear un recurso curl en una dirección no existente
$ch = curl_init('http://404.php.net/');

// Ejecutar
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_exec($ch);

// Comprobar si occurió algún error
if(curl_errno($ch))
{
    echo 'Curl error: ' . curl_error($ch);
}

// Cerrar recurso
curl_close($ch);
?>

Ver también

  • curl_error() - Devuelve una cadena que contiene el último error de la sesión actual
  • » Códigos de error Curl


Devuelve una cadena que contiene el último error de la sesión actual

  • « curl_errno
  • curl_escape »
  • PHP Manual
  • Funciones de cURL
  • Devuelve una cadena que contiene el último error de la sesión actual

curl_error

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

curl_error — Devuelve una cadena que contiene el último error de la sesión actual

Descripción

curl_error ( resource $ch ) : string

Devuelve un mesaje claro del error en formato de texto de la última operación cURL.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve el mensaje de error o '' (una cadena vacía) si no ocurrió ningún error.

Ejemplos

Ejemplo #1 Ejemplo de curl_error()

<?php
// Crear un recurso curl en una dirección no existente
$ch = curl_init('http://404.php.net/');
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);

if(curl_exec($ch) === false)
{
    echo 'Curl error: ' . curl_error($ch);
}
else
{
    echo 'Operación completada sin errores';
}

// Cerrar recurso
curl_close($ch);
?>

Ver también

  • curl_errno() - Devuelve el último número de error
  • » Códigos de error curl


Función URL que codifica el string dado

  • « curl_error
  • curl_exec »
  • PHP Manual
  • Funciones de cURL
  • Función URL que codifica el string dado

curl_escape

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_escape — Función URL que codifica el string dado

Descripción

curl_escape ( resource $ch , string $str ) : string

Esta función URL, codifica el string dado de acuerdo con » RFC 3986.

Parámetros

ch

El recurso cURL devuelto por curl_init().

str

El string a ser codificado.

Valores devueltos

Devuelve la cadena codificada o o false en caso de error en caso de error.

Ejemplos

Ejemplo #1 Ejemplo con curl_escape()

<?php
// Crea un gestor curl
$ch = curl_init();

// Codifica un string con caracteres de control utilizado como un parámetro GET
$location = curl_escape($ch, 'Hofbräuhaus / München');
// Result: Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// Compone una URL con el string codificado
$url = "http://example.com/add_location.php?location={$location}";
// Result: http://example.com/add_location.php?location=Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// Envia la solicitud HTTP y cierra el gestor
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_exec($ch);
curl_close($ch);
?>

Ver también

  • curl_unescape() - Descodifica un string codificado de URL
  • urlencode() - Codifica como URL una cadena
  • rawurlencode() - Codificar estilo URL de acuerdo al RFC 3986
  • » RFC 3986


Establece una sesión cURL

  • « curl_escape
  • curl_file_create »
  • PHP Manual
  • Funciones de cURL
  • Establece una sesión cURL

curl_exec

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_exec — Establece una sesión cURL

Descripción

curl_exec ( resource $ch ) : mixed

Ejecuta la sesión cURL que se le pasa como parámetro.

Esta función debe llamarse después de inicializar una sesión cURL y todas las opciones para la sesión están establecidas.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Sin embargo, si la opción CURLOPT_RETURNTRANSFER está establecida, devolverá el resultado si se realizó con éxito, o false si falló.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Nota:

Obsérvese que los códigos de estado de respuesta que indican errores (como 404 Not found) no se consideran un fallo. curl_getinfo() se puede utilizar para comprobar que no hay nada de esto.

Ejemplos

Ejemplo #1 Capturar una página web

<?php
// Crear un nuevo recurso cURL
$ch = curl_init();

// Establecer URL y otras opciones apropiadas
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// Capturar la URL y pasarla al navegador
curl_exec($ch);

// Cerrar el recurso cURL y liberar recursos del sistema
curl_close($ch);
?>

Ver también

  • curl_multi_exec() - Ejecuta las sub-conexiones del recurso cURL actual


Crea un objeto CURLFile

  • « curl_exec
  • curl_getinfo »
  • PHP Manual
  • Funciones de cURL
  • Crea un objeto CURLFile

curl_file_create

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_file_create — Crea un objeto CURLFile

Descripción

Esta función es un alias de: CURLFile::__construct()


Obtener información sobre una transferencia específica

  • « curl_file_create
  • curl_init »
  • PHP Manual
  • Funciones de cURL
  • Obtener información sobre una transferencia específica

curl_getinfo

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

curl_getinfo — Obtener información sobre una transferencia específica

Descripción

curl_getinfo ( resource $ch , int $opt = ? ) : mixed

Obtiene información sobre la última transferencia.

Parámetros

ch

El recurso cURL devuelto por curl_init().

opt

Esta puede ser una de las siguientes constantes:

  • CURLINFO_EFFECTIVE_URL - Última URL efectiva
  • CURLINFO_HTTP_CODE - El último código de respuesta. A partir de PHP 5.5.0 y cURL 7.10.8, este es un alias heredado de CURLINFO_RESPONSE_CODE
  • CURLINFO_FILETIME - Tiempo remoto del documento recuperado, con la constante CURLOPT_FILETIME habilitada; si -1 es devuelto el tiempo del documento es desconocido
  • CURLINFO_TOTAL_TIME - Tiempo total de transacción en segundos para la última transferencia
  • CURLINFO_NAMELOOKUP_TIME - El tiempo en segundos hasta que la resolución del nombre se haya completado
  • CURLINFO_CONNECT_TIME - El tiempo en segundos que tomó establecer la conexión
  • CURLINFO_PRETRANSFER_TIME - Tiempo en segundos desde el inicio hasta justo antes de que comience la transferencia de archivos
  • CURLINFO_STARTTRANSFER_TIME - Tiempo en segundos hasta que el primer byte está a punto de ser transferido
  • CURLINFO_REDIRECT_COUNT - Número de redirecciones, con la opción CURLOPT_FOLLOWLOCATION habilitada
  • CURLINFO_REDIRECT_TIME - Tiempo en segundos de todos los pasos de redireccionamiento antes de que se iniciara la transacción final, con la opción CURLOPT_FOLLOWLOCATION habilitada
  • CURLINFO_REDIRECT_URL - Con la opción CURLOPT_FOLLOWLOCATION deshabilitadad: redirigir la URL encontrada en la última transacción, que debe ser solicitado manualmente a continuación. Con la opción CURLOPT_FOLLOWLOCATION habilitada: esto está vacío. El URL de redireccionamiento en este caso está disponible en CURLINFO_EFFECTIVE_URL
  • CURLINFO_PRIMARY_IP - La dirección IP de la conexión más reciente
  • CURLINFO_PRIMARY_PORT - Puerto de destino de la conexión más reciente
  • CURLINFO_LOCAL_IP - Dirección IP local (fuente) de la conexión más reciente
  • CURLINFO_LOCAL_PORT - Puerto local (fuente) de la conexión más reciente
  • CURLINFO_SIZE_UPLOAD - Número total de bytes cargados
  • CURLINFO_SIZE_DOWNLOAD - Número total de bytes descargados
  • CURLINFO_SPEED_DOWNLOAD - Velocidad media de descarga
  • CURLINFO_SPEED_UPLOAD - Velocidad media de subida
  • CURLINFO_HEADER_SIZE - Tamaño total de todos los encabezados recibidos
  • CURLINFO_HEADER_OUT - El string de solicitud enviado. Para que esto funcione, agregue la opción CURLINFO_HEADER_OUT al manejador llamando curl_setopt()
  • CURLINFO_REQUEST_SIZE - Tamaño total de las solicitudes emitidas, actualmente sólo para las solicitudes HTTP
  • CURLINFO_SSL_VERIFYRESULT - Resultado de la verificación de la certificación SSL solicitada mediante el ajuste CURLOPT_SSL_VERIFYPEER
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD - Longitud del contenido de la descarga, leído desde el campo Content-Length:
  • CURLINFO_CONTENT_LENGTH_UPLOAD - Tamaño especificado de la carga
  • CURLINFO_CONTENT_TYPE - Content-Type: de el documento. NULL indica que el servidor no envió un encabezado válido Content-Type:
  • CURLINFO_PRIVATE - Los datos privados asociados al manejador cURL, previamente establecido con la opción CURLOPT_PRIVATE de curl_setopt()
  • CURLINFO_RESPONSE_CODE - El último código de respuesta
  • CURLINFO_HTTP_CONNECTCODE - El código de respuesta CONNECT
  • CURLINFO_HTTPAUTH_AVAIL - Máscara de bits que indica el(los) método(s) de autenticación disponible(s) según la respuesta anterior
  • CURLINFO_PROXYAUTH_AVAIL - Máscara de bits que indica el(los) método(s) de autenticación del proxy disponible(s) según la respuesta anterior
  • CURLINFO_OS_ERRNO - Número de error de un fallo de conexión. El número es específico del sistema y del sistema operativo.
  • CURLINFO_NUM_CONNECTS - El número de conexiones que Curl tuvo que crear para lograr la transferencia anterior
  • CURLINFO_SSL_ENGINES - Los motores de cifrado OpenSSL soportados
  • CURLINFO_COOKIELIST - Todas las cookies conocidas
  • CURLINFO_FTP_ENTRY_PATH - Ruta de entrada en el servidor FTP
  • CURLINFO_APPCONNECT_TIME - El tiempo en segundos que tomó desde el inicio hasta que la conexión SSL/SSH al host remoto se completó
  • CURLINFO_CERTINFO - Cadena de certificados TLS
  • CURLINFO_CONDITION_UNMET - Información sobre el tiempo condicional no cumplido
  • CURLINFO_RTSP_CLIENT_CSEQ - Próximo cliente de RTSP CSeq
  • CURLINFO_RTSP_CSEQ_RECV - Recién recibido CSeq
  • CURLINFO_RTSP_SERVER_CSEQ - Próximo servidor RTSP CSeq
  • CURLINFO_RTSP_SESSION_ID - ID de la sesión RTSP
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD_T - El contenido de la descarga. Este es el valor leído de el campo Content-Type:. -1 si el tamaño no es conocido
  • CURLINFO_CONTENT_LENGTH_UPLOAD_T - El tamaño especificado de la carga. -1 si no se conoce el tamaño
  • CURLINFO_HTTP_VERSION - La versión usada en la última conexión HTTP. El valor devuelto será una de las constantes CURL_HTTP_VERSION_* constants o 0 si la versión no puede ser determinada
  • CURLINFO_PROTOCOL - El protocolo utilizado en la última conexión HTTP. El valor devuelto será exactamente uno de los valores CURLPROTO_*
  • CURLINFO_PROXY_SSL_VERIFYRESULT - El resultado de la verificación del certificado que se solicitó (usando la opción CURLOPT_PROXY_SSL_VERIFYPEER). Sólo se utiliza para los proxies HTTPS
  • CURLINFO_SCHEME - El esquema de URL usado para la conexión más reciente
  • CURLINFO_SIZE_DOWNLOAD_T - Número total de bytes que se descargaron. El número es sólo para la última transferencia y se restablecerá de nuevo para cada nueva transferencia
  • CURLINFO_SIZE_UPLOAD_T - Número total de bytes que se cargaron
  • CURLINFO_SPEED_DOWNLOAD_T - La velocidad media de descarga en bytes/segundo que cURL midió para la descarga completa
  • CURLINFO_SPEED_UPLOAD_T - La velocidad media de subida en bytes/segundo que cURL midió para la subida completa
  • CURLINFO_APPCONNECT_TIME_T - Tiempo, en microsegundos, que tomó desde el principio hasta que la conexión SSL/SSH al host remoto se completó
  • CURLINFO_CONNECT_TIME_T - Tiempo total tomado, en microsegundos, desde el inicio hasta que se completó la conexión con el host remoto (o proxy)
  • CURLINFO_FILETIME_T - Hora remota del documento recuperado (como la marca de tiempo de Unix), una alternativa a CURLINFO_FILETIME para permitir que los sistemas con variables de 32 bits de largo extraigan fechas fuera del rango de 32 bits de la marca de tiempo
  • CURLINFO_NAMELOOKUP_TIME_T - Tiempo en microsegundos desde el comienzo hasta que el nombre es resuelto.
  • CURLINFO_PRETRANSFER_TIME_T - El tiempo transcurrido desde el inicio hasta la transferencia de archivos está a punto de comenzar, en microsegundos
  • CURLINFO_REDIRECT_TIME_T - El tiempo total, en microsegundos, que tomó para todos los pasos de redireccionamiento incluyen la búsqueda del nombre, la conexión, la pretransferencia y la transferencia antes de que se iniciara la transacción final
  • CURLINFO_STARTTRANSFER_TIME_T - El tiempo, en microsegundos, que tomó desde el inicio hasta que se recibe el primer byte
  • CURLINFO_TOTAL_TIME_T - Tiempo total en microsegundos para la transferencia anterior, incluyendo la resolución de nombres, la conexión TCP, etc.

Valores devueltos

Si se da opt, devuelve este valor. En caso contrario, devuelve un array asociativo con los siguientes valores (que corresponden a opt), o false en caso de error:

  • "url"
  • "content_type"
  • "http_code"
  • "header_size"
  • "request_size"
  • "filetime"
  • "ssl_verify_result"
  • "redirect_count"
  • "total_time"
  • "namelookup_time"
  • "connect_time"
  • "pretransfer_time"
  • "size_upload"
  • "size_download"
  • "speed_download"
  • "speed_upload"
  • "download_content_length"
  • "upload_content_length"
  • "starttransfer_time"
  • "redirect_time"
  • "certinfo"
  • "primary_ip"
  • "primary_port"
  • "local_ip"
  • "local_port"
  • "redirect_url"
  • "request_header" (Esto sólo se establece si CURLINFO_HEADER_OUT se establece por una llamada previa a curl_setopt())
Nótese que los datos privados no están incluidos en el conjunto asociativo y deben recuperarse individualmente con la opción CURLINFO_PRIVATE.

Historial de cambios

Versión | Descripción
7.3.0 | Introdujo CURLINFO_CONTENT_LENGTH_DOWNLOAD_T, CURLINFO_CONTENT_LENGTH_UPLOAD_T, CURLINFO_HTTP_VERSION, CURLINFO_PROTOCOL, CURLINFO_PROXY_SSL_VERIFYRESULT, CURLINFO_SCHEME, CURLINFO_SIZE_DOWNLOAD_T, CURLINFO_SIZE_UPLOAD_T, CURLINFO_SPEED_DOWNLOAD_T, CURLINFO_SPEED_UPLOAD_T, CURLINFO_APPCONNECT_TIME_T, CURLINFO_CONNECT_TIME_T, CURLINFO_FILETIME_T, CURLINFO_NAMELOOKUP_TIME_T, CURLINFO_PRETRANSFER_TIME_T, CURLINFO_REDIRECT_TIME_T, CURLINFO_STARTTRANSFER_TIME_T, CURLINFO_TOTAL_TIME_T.
5.5.0 | Introdujo CURLINFO_RESPONSE_CODE, CURLINFO_HTTP_CONNECTCODE, CURLINFO_HTTPAUTH_AVAIL, CURLINFO_PROXYAUTH_AVAIL, CURLINFO_OS_ERRNO, CURLINFO_NUM_CONNECTS, CURLINFO_SSL_ENGINES, CURLINFO_COOKIELIST, CURLINFO_FTP_ENTRY_PATH, CURLINFO_APPCONNECT_TIME, CURLINFO_CONDITION_UNMET, CURLINFO_RTSP_CLIENT_CSEQ, CURLINFO_RTSP_CSEQ_RECV, CURLINFO_RTSP_SERVER_CSEQ y CURLINFO_RTSP_SESSION_ID.
5.4.7 | Introdujo CURLINFO_PRIMARY_IP, CURLINFO_PRIMARY_PORT, CURLINFO_LOCAL_IP y CURLINFO_LOCAL_PORT.
5.3.7 | Introdujo CURLINFO_REDIRECT_URL.
5.3.0 | Introdujo CURLINFO_CERTINFO.
5.2.4 | Introdujo CURLINFO_PRIVATE.
5.1.3 | Introdujo CURLINFO_HEADER_OUT.

Ejemplos

Ejemplo #1 Ejemplo de curl_getinfo()

<?php
// Crear un manejador cURL
$ch = curl_init('http://www.example.com/');

// Ejecutar
curl_exec($ch);

// Verificar si ocurrió algún error
if (!curl_errno($ch)) {
  $info = curl_getinfo($ch);
  echo 'Took ', $info['total_time'], ' seconds to send a request to ', $info['url'], "\n";
}

// Close handle
curl_close($ch);
?>

Ejemplo #2 Ejemplo de curl_getinfo() con el parámetro opt

<?php
// Crear un manejador cURL
$ch = curl_init('http://www.example.com/');

// Ejecutar
curl_exec($ch);

// Comprueba el código de estado HTTP
if (!curl_errno($ch)) {
  switch ($http_code = curl_getinfo($ch, CURLINFO_HTTP_CODE)) {
    case 200:  # OK
      break;
    default:
      echo 'Unexpected HTTP code: ', $http_code, "\n";
  }
}

// Close handle
curl_close($ch);
?>

Notas

Nota:

La información recogida por esta función se guarda si el manejador se reutiliza. Esto significa que a menos que una estadística sea anulada internamente por esta función, la información anterior es devuelta.


Inicia sesión cURL

  • « curl_getinfo
  • curl_multi_add_handle »
  • PHP Manual
  • Funciones de cURL
  • Inicia sesión cURL

curl_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_init — Inicia sesión cURL

Descripción

curl_init ( string|null $url = null ) : CurlHandle|false

Inicia una nueva sesión y devuelve el manipulador curl para el uso de las funciones curl_setopt(), curl_exec(), y curl_close().

Parámetros

url

Si se proporciona, se estabecerá en el valor de la opción CURLOPT_URL. Se puede establecer manualmente esta opción usando la función curl_setopt().

Nota:

El protocolo file es deshabilitado por cURL si open_basedir está establecido.

Valores devueltos

Devuelve un manipulador de cURL si todo fué bien, false si hay errores.

Historial de cambios

Versión | Descripción
8.0.0 | En caso de éxito, esta función devuelve una instancia CurlHandle ahora; anteriormente, se devolvía un resource.
8.0.0 | url es ahora nullable.

Ejemplos

Ejemplo #1 Inicia una nueva sesión cURL y captura una página web

<?php
// Crea un nuevo recurso cURL
$ch = curl_init();

// Establece la URL y otras opciones apropiadas
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// Captura la URL y la envía al navegador
curl_exec($ch);

// Cierrar el recurso cURL y libera recursos del sistema
curl_close($ch);
?>

Ver también

  • curl_close() - Cierra una sesión cURL
  • curl_multi_init() - Devuelve un nuevo multi recurso cURL


Añade un recurso cURL a un grupo de recursos cURL

  • « curl_init
  • curl_multi_close »
  • PHP Manual
  • Funciones de cURL
  • Añade un recurso cURL a un grupo de recursos cURL

curl_multi_add_handle

(PHP 5, PHP 7, PHP 8)

curl_multi_add_handle — Añade un recurso cURL a un grupo de recursos cURL

Descripción

curl_multi_add_handle ( resource $mh , resource $ch ) : int

Añade el recuso ch al grupo de recursos mh

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

En caso de éxito devuelve 0, sino devuelve alguno de los códigos de error CURLM_XXX

Ejemplos

Ejemplo #1 curl_multi_add_handle() example

Este ejemplo creará dos recursos cURL, los añadirá a un grupo de recursos y entoces los ejecutará de forma asíncrona.

<?php
// Crea los dos recursos cURL
$ch1 = curl_init();
$ch2 = curl_init();

// Establecer la URL y otras opciones apropiadas
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// Crea el recurso cURL múltiple
$mh = curl_multi_init();

// Añade los dos recursos
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

// Ejecuta los recursos múltiples
do {
    $status = curl_multi_exec($mh, $active);
    if ($active) {
        curl_multi_select($mh);
    }
} while ($active && $status == CURLM_OK);

// Cierra todos los recursos
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);
?>

Ver también

  • curl_multi_remove_handle() - Elimina un multi recurso de un conjunto de recursos cURL
  • curl_multi_init() - Devuelve un nuevo multi recurso cURL
  • curl_init() - Inicia sesión cURL


Cierra un grupo de recursos cURL

  • « curl_multi_add_handle
  • curl_multi_errno »
  • PHP Manual
  • Funciones de cURL
  • Cierra un grupo de recursos cURL

curl_multi_close

(PHP 5, PHP 7, PHP 8)

curl_multi_close — Cierra un grupo de recursos cURL

Descripción

curl_multi_close ( resource $mh ) : void

Cierra un grupo de recursos cURL.

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 curl_multi_close() example

Este ejemplo creará dos recursos cURL, los añadirá a un grupo de recursos y entoces los ejecutará de forma asíncrona.

<?php
// Crea los dos recursos cURL
$ch1 = curl_init();
$ch2 = curl_init();

// Establecer la URL y otras opciones apropiadas
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// Crea el recurso cURL múltiple
$mh = curl_multi_init();

// Añade los dos recursos
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

// Ejecuta los recursos múltiples
do {
    $status = curl_multi_exec($mh, $active);
    if ($active) {
        curl_multi_select($mh);
    }
} while ($active && $status == CURLM_OK);

// Cierra todos los recursos
curl_multi_remove_handle($mh, $ch1);
curl_close($ch1);
curl_multi_remove_handle($mh, $ch2);
curl_close($ch2);
curl_multi_close($mh);

?>

Ver también

  • curl_multi_init() - Devuelve un nuevo multi recurso cURL
  • curl_close() - Cierra una sesión cURL


Devuelve el último número de error de cURL múltiple

  • « curl_multi_close
  • curl_multi_exec »
  • PHP Manual
  • Funciones de cURL
  • Devuelve el último número de error de cURL múltiple

curl_multi_errno

(PHP 7 >= 7.1.0, PHP 8)

curl_multi_errno — Devuelve el último número de error de cURL múltiple

Descripción

curl_multi_errno ( resource $mh ) : int

Devuelve un integer que contiene el último número de error de cURL múltiple.

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

Valores devueltos

Devuelve un integer que contiene el último número de error de cURL múltiple, o false en caso de error.

Ver también

  • curl_errno() - Devuelve el último número de error


Ejecuta las sub-conexiones del recurso cURL actual

  • « curl_multi_errno
  • curl_multi_getcontent »
  • PHP Manual
  • Funciones de cURL
  • Ejecuta las sub-conexiones del recurso cURL actual

curl_multi_exec

(PHP 5, PHP 7, PHP 8)

curl_multi_exec — Ejecuta las sub-conexiones del recurso cURL actual

Descripción

curl_multi_exec ( resource $mh , int &$still_running ) : int

Procesa cada uno de los recursos del grupo. Este método puede ser llamado cuando el recurso tenga o no tenga que leer o escribir datos.

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

still_running

Hace referencia a una bandera que dice cuando las operaciones siguen ejecutándose.

Valores devueltos

Código cURL definido en las Constantes predefinidas cURL.

Nota:

Solo devuelve errores en relación con el grupo. Es posible que hayan ocurrido problemas en transferencias individuales aunque esta función devuelva CURLM_OK.

Ejemplos

Ejemplo #1 curl_multi_exec() example

Este ejemplo creará dos recursos cURL, los añadirá al grupo de recursos y los ejecutará de forma asíncrona.

<?php
// Crea los dos recursos cURL
$ch1 = curl_init();
$ch2 = curl_init();

// Establecer la URL y otras opciones apropiadas
curl_setopt($ch1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// Crea el recurso cURL múltiple
$mh = curl_multi_init();

// Añade los dos recursos
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$active = null;
// Ejecuta los recursos
do {
    $mrc = curl_multi_exec($mh, $active);
} while ($mrc == CURLM_CALL_MULTI_PERFORM);

while ($active && $mrc == CURLM_OK) {
    if (curl_multi_select($mh) != -1) {
        do {
            $mrc = curl_multi_exec($mh, $active);
        } while ($mrc == CURLM_CALL_MULTI_PERFORM);
    }
}

// Cierra los recursos
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

Ver también

  • curl_multi_init() - Devuelve un nuevo multi recurso cURL
  • curl_multi_select() - Espera actividad en cualquier conexión en curl_multi
  • curl_exec() - Establece una sesión cURL


Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado

  • « curl_multi_exec
  • curl_multi_info_read »
  • PHP Manual
  • Funciones de cURL
  • Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado

curl_multi_getcontent

(PHP 5, PHP 7, PHP 8)

curl_multi_getcontent — Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado

Descripción

curl_multi_getcontent ( resource $ch ) : string

Si la opción CURLOPT_RETURNTRANSFER está activada para uno de los recursos, entonces esta función devolverá el contenido del recurso cURL en formato string.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve el contenido de cURL si la opción CURLOPT_RETURNTRANSFER está activada en el recurso cURL.

Ver también

  • curl_multi_init() - Devuelve un nuevo multi recurso cURL


Obtiene información de las transferencias en curso

  • « curl_multi_getcontent
  • curl_multi_init »
  • PHP Manual
  • Funciones de cURL
  • Obtiene información de las transferencias en curso

curl_multi_info_read

(PHP 5, PHP 7, PHP 8)

curl_multi_info_read — Obtiene información de las transferencias en curso

Descripción

curl_multi_info_read ( resource $mh , int &$msgs_in_queue = null ) : array

Pregunta al multi recurso si hay algún mensaje o información de cada una de las transferencias. Los mensajes quizá incluyen información como códigos de error de la transferencia o simplemente que la transferencia ha sido completada.

Cada vez que se llame a esta función devolverá un nuevo resultado, hasta que se devuelva false como indicador de que no hay nada más que obtener por el momento. El integer que devuelve msgs_in_queue contendrá el número de mensajes que quedan después de que la función sea llamada.

Advertencia

Los datos que devuelve el recurso no permanecerán si se llama a la función curl_multi_remove_handle().

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

msgs_in_queue

Número de mensajes que todavía están en la cola

Valores devueltos

Si funciona, devuelve un array asociativo como mensaje, si falla devuelve false.

Contenido del array devuelto
Clave: | Valor:
msg | La constante CURLMSG_DONE. Otros valores devueltos no están actualmente disponibles.
result | Una de las constantes CURLE_*. Si todo es OK, se devolverá CURLE_OK.
handle | Recurso de tipo curl que indica el controlador en cuestión.

Ejemplos

Ejemplo #1 Un ejemplo de curl_multi_info_read()

<?php

$urls = array(
   "http://www.cnn.com/",
   "http://www.bbc.co.uk/",
   "http://www.yahoo.com/"
);

$mh = curl_multi_init();

foreach ($urls as $i => $url) {
    $conn[$i] = curl_init($url);
    curl_setopt($conn[$i], CURLOPT_RETURNTRANSFER, 1);
    curl_multi_add_handle($mh, $conn[$i]);
}

do {
    $status = curl_multi_exec($mh, $active);
    if ($active) {
        curl_multi_select($mh);
    }
    $info = curl_multi_info_read($mh);
    if (false !== $info) {
        var_dump($info);
    }
} while ($active && $status == CURLM_OK);

foreach ($urls as $i => $url) {
    $res[$i] = curl_multi_getcontent($conn[$i]);
    curl_close($conn[$i]);
}

var_dump(curl_multi_info_read($mh));

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(5) of type (curl)
}
array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(7) of type (curl)
}
array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(6) of type (curl)
}
bool(false)

Historial de cambios

Versión | Descripción
5.2.0 | msgs_in_queue fue añadido.

Ver también

  • curl_multi_init() - Devuelve un nuevo multi recurso cURL


Devuelve un nuevo multi recurso cURL

  • « curl_multi_info_read
  • curl_multi_remove_handle »
  • PHP Manual
  • Funciones de cURL
  • Devuelve un nuevo multi recurso cURL

curl_multi_init

(PHP 5, PHP 7, PHP 8)

curl_multi_init — Devuelve un nuevo multi recurso cURL

Descripción

curl_multi_init ( ) : resource

Permite procesar múltiples recursos cURL de forma asíncrona.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un multi recurso cURL si funciona, false si falla.

Ejemplos

Ejemplo #1 curl_multi_init() example

Este ejemplo crea dos recursos cURL, los añade a un multi recurso, y los ejectua de forma asíncrona.

<?php
// Crea dos recursos cURL
$ch1 = curl_init();
$ch2 = curl_init();

// Establece la URL y otras opciones apropiadas
curl_setopt($ch1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// Crea el multi recurso cURL
$mh = curl_multi_init();

// Añade los dos recursos
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$active=null;
// Ejecuta los recursos
do {
    $mrc = curl_multi_exec($mh, $active);
} while ($mrc == CURLM_CALL_MULTI_PERFORM);

while ($active && $mrc == CURLM_OK) {
    if (curl_multi_select($mh) != -1) {
        do {
            $mrc = curl_multi_exec($mh, $active);
        } while ($mrc == CURLM_CALL_MULTI_PERFORM);
    }
}

// Cierra los recursos
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

Ver también

  • curl_init() - Inicia sesión cURL
  • curl_multi_close() - Cierra un grupo de recursos cURL


Elimina un multi recurso de un conjunto de recursos cURL

  • « curl_multi_init
  • curl_multi_select »
  • PHP Manual
  • Funciones de cURL
  • Elimina un multi recurso de un conjunto de recursos cURL

curl_multi_remove_handle

(PHP 5, PHP 7, PHP 8)

curl_multi_remove_handle — Elimina un multi recurso de un conjunto de recursos cURL

Descripción

curl_multi_remove_handle ( resource $mh , resource $ch ) : int

Eliminia un recurso ch dado de un recurso mh dado. Cuando el recurso ch es eliminado, se puede volver a ejecutar curl_exec() en el mismo recurso. Eliminar el recurso cuando está en uso, cortará todas las transferencias en curso.

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

Devuelve 0 en caso de éxito, o uno de los códigos de error CURLM_XXX.

Ver también

  • curl_init() - Inicia sesión cURL
  • curl_multi_init() - Devuelve un nuevo multi recurso cURL
  • curl_multi_add_handle() - Añade un recurso cURL a un grupo de recursos cURL


Espera actividad en cualquier conexión en curl_multi

  • « curl_multi_remove_handle
  • curl_multi_setopt »
  • PHP Manual
  • Funciones de cURL
  • Espera actividad en cualquier conexión en curl_multi

curl_multi_select

(PHP 5, PHP 7, PHP 8)

curl_multi_select — Espera actividad en cualquier conexión en curl_multi

Descripción

curl_multi_select ( resource $mh , float $timeout = 1.0 ) : int

Permanece bloqueado hasta que haya algún tipo de actividad en conexiones curl_multi.

Parámetros

mh

El multi recurso cURL multi devuelto por curl_multi_init().

timeout

Tiempo, en segundos, para esperar por una respuesta.

Valores devueltos

Si funciona, devuelve el número de descripciones que hay en los conjuntos de descripciones. Esto puede ser 0 si no hay actividad en cualquiera de los descriptores. Si falla, esta función devolverá -1 si la selección falla (desde la llamada al sistema subyacente).

Ver también

  • curl_multi_init() - Devuelve un nuevo multi recurso cURL


Configura una opción para el multi gestor cURL

  • « curl_multi_select
  • curl_multi_strerror »
  • PHP Manual
  • Funciones de cURL
  • Configura una opción para el multi gestor cURL

curl_multi_setopt

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_multi_setopt — Configura una opción para el multi gestor cURL

Descripción

curl_multi_setopt ( resource $mh , int $option , mixed $value ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

mh

option

Una de las constantes CURLMOPT_* .

value

El valor a configurar para el parámetro option.

value debe ser un int para los siguientes valores del parámetro option :

Opción | Definir parámetro value con
CURLMOPT_PIPELINING | 1 para activar o 0 para desactivar. Activar el pipelining en un multi gestor hará que intente realizar Pipelining HTTP siempre que sea posible para transferencias que utilicen ese gestor. Esto significa que si se añade una segunda petición que puede usar una conexión ya existente, la segunda petición será canalizada en la misma conexión. A partir de cURL 7.43.0, se puede pasar 2 para probar multiplexar la nueva transferencia en una conexión HTTP/2 existente, si es posible. Se pueden utilizar las constantes CURLPIPE_* en lugar de literales de números enteros si están dispoinbles.
CURLMOPT_MAXCONNECTS | Número máximo de conexiones abiertas simultáneamente que libcurl puede guardar en la cache. Por defecto es 10. Cuando la caché está llena, curl elige el más antiguo de la caché para que no se incremente el número de conexiones abiertas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve un string con la descripción del código de error

  • « curl_multi_setopt
  • curl_pause »
  • PHP Manual
  • Funciones de cURL
  • Devuelve un string con la descripción del código de error

curl_multi_strerror

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_multi_strerror — Devuelve un string con la descripción del código de error

Descripción

curl_multi_strerror ( int $errornum ) : string

Devuelve un mensaje de error que describe el código de error CURLM dado.

Parámetros

errornum

Una de las constantes de » códigos de error CURLM .

Valores devueltos

Devuelve un string con la descripción del código de error válido, null si no lo es.

Ejemplos

Ejemplo #1 Ejemplo con curl_multi_strerror()

<?php
// Crea gestores cURL
$ch1 = curl_init("http://example.com"/);
$ch2 = curl_init("http://php.net/");

// Crea un multi gestor cURL
$mh = curl_multi_init();

// Añade los gestores al multi gestor
curl_multi_add_handle($mh, $ch1);
curl_multi_add_handle($mh, $ch2);

// Ejecuta el multi gestor
do {
    $status = curl_multi_exec($mh, $active);
    // Revisa si se ha producido errores
    if($status > 0) {
        // Muestra mensaje de error
        echo "ERROR!\n " . curl_multi_strerror($status);
    }
} while ($status === CURLM_CALL_MULTI_PERFORM || $active);
?>

Ver también

  • curl_strerror() - Devuelve un string que describe el código de error dado
  • » códigos de error cURL


Pausa y reanuda una conexión

  • « curl_multi_strerror
  • curl_reset »
  • PHP Manual
  • Funciones de cURL
  • Pausa y reanuda una conexión

curl_pause

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_pause — Pausa y reanuda una conexión

Descripción

curl_pause ( resource $ch , int $bitmask ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ch

El recurso cURL devuelto por curl_init().

bitmask

Una de las constantes CURLPAUSE_* .

Valores devueltos

Devuelve un código de error, (CURLE_OK si no hay error).


Reinicializa todas las opciones de un gestor de sesión libcurl

  • « curl_pause
  • curl_setopt_array »
  • PHP Manual
  • Funciones de cURL
  • Reinicializa todas las opciones de un gestor de sesión libcurl

curl_reset

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_reset — Reinicializa todas las opciones de un gestor de sesión libcurl

Descripción

curl_reset ( resource $ch ) : void

Esta función reinicializa a sus valores por defecto, todas las opciones de un gestor cURL dado.

Parámetros

ch

El recurso cURL devuelto por curl_init().

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo con curl_reset()

<?php
// Crear un gestor cURL
$ch = curl_init();

// Definir la opción CURLOPT_USERAGENT
curl_setopt($ch, CURLOPT_USERAGENT, "My test user-agent");

// Reinicializar todas las opciones ya configuradas
curl_reset($ch);

// Enviar la solicitud HTTP
curl_setopt($ch, CURLOPT_URL, 'http://example.com/');
curl_exec($ch); // el gestor de usuario definido previamente no será enviado, puesto que ha sido reseteado por curl_reset

// Cerrar el gestor
curl_close($ch);
?>

Notas

Nota:

curl_reset() también reinicia la URL dada como el parámetro de la función curl_init() .

Ver también

  • curl_setopt() - Configura una opción para una transferencia cURL


Configura múltiples opciones para una transferencia cURL

  • « curl_reset
  • curl_setopt »
  • PHP Manual
  • Funciones de cURL
  • Configura múltiples opciones para una transferencia cURL

curl_setopt_array

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

curl_setopt_array — Configura múltiples opciones para una transferencia cURL

Descripción

curl_setopt_array ( resource $ch , array $options ) : bool

Configura multiples opciones para una sesión cURL. Esta función es muy útil para configurar gran cantidad de opciones cURL sin tener que llamar cada vez curl_setopt().

Parámetros

ch

El recurso cURL devuelto por curl_init().

opciones

Un array especificando que opciones a configurar y con que valores. Las keys deben contener constantes curl_setopt() válidas o sus integer equivalentes.

Valores devueltos

Devuelve true si todas las opciones se configuraron satisfactoriamente. Si una opción no se pudo configurar devolverá false inmediatamente. Ignorando cualquier otra opción en el array de opciones.

Ejemplos

Ejemplo #1 Iniciando una nueva sesión cURL y capturando una página web

<?php
// Crea un nuevo recurso cURL
$ch = curl_init();

// set URL and other appropriate options
$options = array(CURLOPT_URL => 'http://www.example.com/',
                 CURLOPT_HEADER => false
                );

curl_setopt_array($ch, $options);

// grab URL and pass it to the browser
curl_exec($ch);

// close cURL resource, and free up system resources
curl_close($ch);
?>

Anterior a PHP 5.1.3 esta función puede ser simulada con:

Ejemplo #2 O nuestra implementación de curl_setopt_array()

<?php
if (!function_exists('curl_setopt_array')) {
   function curl_setopt_array(&$ch, $curl_options)
   {
       foreach ($curl_options as $option => $value) {
           if (!curl_setopt($ch, $option, $value)) {
               return false;
           }
       }
       return true;
   }
}
?>

Notas

Nota:

Igual que curl_setopt(), si se pasa un array a CURLOPT_POST codificará los datos como multipart/form-data, mientras que si pasa una cadena URL-encoded codificará los datos como application/x-www-form-urlencoded.

Ver también

  • curl_setopt() - Configura una opción para una transferencia cURL


Configura una opción para una transferencia cURL

  • « curl_setopt_array
  • curl_share_close »
  • PHP Manual
  • Funciones de cURL
  • Configura una opción para una transferencia cURL

curl_setopt

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_setopt — Configura una opción para una transferencia cURL

Descripción

curl_setopt ( resource $ch , int $option , mixed $value ) : bool

Establece una opción en la sesión del recurso cURL.

Parámetros

ch

El recurso cURL devuelto por curl_init().

option

La opción CURLOPT_XXX a configurar.

value

Valor a configurar en la option.

value debe ser un bool para los siguientes valores del parámetro option:

Opción | Establecer value a | Notas
CURLOPT_AUTOREFERER | true para automáticamente establecer el valor del campo Referer: en peticiones que siguen una redireción Location:.
CURLOPT_BINARYTRANSFER | true para devolver el resultado sin tratar CURLOPT_RETURNTRANSFER está activado. | Desde PHP 5.1.3, esta opción no tiene efecto: el resultado sin tratar será siempre retornado cuando CURLOPT_RETURNTRANSFER sea usado.
CURLOPT_COOKIESESSION | true para usarse como una nueva cookie de "sesión". Forzará libcurl a ignorar todas las cookies, se trata de cargar estas "cookies de sesión" de la sesión anterior. Por defecto, libcurl siempre guarda y carga todas las cookies, independientemente si hay cookies de sesión o no. Las cookies de sesión son cookies sin fecha de caducidad y estan pensadas para mantenerse activas y solo existir para esta "sesión".
CURLOPT_CERTINFO | true para mostrar información sobre certificación SSL al STDERR en transferencias seguras. | Añadido en cURL 7.19.1 Disponible desde PHP 5.3.2. Requiere CURLOPT_VERBOSE activado para que tenga efecto.
CURLOPT_CONNECT_ONLY | true le dice a la biblioteca que realice todas las autenticaciones de proxy requeridas y la configuración de la conexión, pero no la transferencia de datos. Esta opción se implementa para HTTP, SMTP y POP3. | Aladida en 7.15.2. Disponbible desde PHP 5.5.0.
CURLOPT_CRLF | true para convertir nuevas líneas Unix a nuevas líneas CRLF en transferencias.
CURLOPT_DNS_USE_GLOBAL_CACHE | true para usar caché DNS global. Esta opción no es thread-safe y está activada por defecto.
CURLOPT_FAILONERROR | true para fallar con verbosidad si el código HTTP devuelto es mayor o igual que 400. El comportamiento por defecto es devolver la página normalmente, ignornado el código.
CURLOPT_SSL_FALSESTART | true para habilitar el inicio falso de TLS. | Añadida en cURL 7.42.0. Disponible desde PHP 7.0.7.
CURLOPT_FILETIME | true para intentar obtener la fecha de modificación del documento. Este valor puede obtenerse usando la opción CURLINFO_FILETIME con curl_getinfo().
CURLOPT_FOLLOWLOCATION | true para seguir cualquier encabezado "Location: " que el servidor envíe como parte del encabezado HTTP (observe la recursividad, PHP seguirá tantos header "Location: " como se envíen, a no ser que la opción CURLOPT_MAXREDIRS esté establecida).
CURLOPT_FORBID_REUSE | true para forzar a cerrar explicitamente la conexión cuando se finalice el proceso y no guardarla para su reuso.
CURLOPT_FRESH_CONNECT | true para forzar el uso de una nueva conexión en lugar de usar una en caché.
CURLOPT_FTP_USE_EPRT | true para usar EPRT (y LPRT) cuando se hacen descargas FTP activas. Use false para desactivar EPRT y LPRT y usar PORT solamente.
CURLOPT_FTP_USE_EPSV | true para probar primero el comando EPSV para transferencias FTP antes de volver a PASV. Establezca la opción a false para desactivar EPSV.
CURLOPT_FTP_CREATE_MISSING_DIRS | true para crear directorios faltantes cuando una operación se encuentra con una ruta que actualmente no existe.
CURLOPT_FTPAPPEND | true para añadir al fichero remoto en lugar de sobreescribirlo.
CURLOPT_TCP_NODELAY | true para deshabilitar el algoritmo de TCP de Nagle, el cual intenta minimizar el número de paquetes pequeños en la red. | Disponible desde PHP 5.2.1 para versiones compiladas con libcurl 7.11.2 o superior.
CURLOPT_FTPASCII | Un alias de CURLOPT_TRANSFERTEXT. Para usar en su lugar.
CURLOPT_FTPLISTONLY | true para solo listar los nombres de un directorio FTP directorio.
CURLOPT_HEADER | true para incluir el header en el output.
CURLINFO_HEADER_OUT | true para seguir la cadena de la petición del recurso. | Disponible desde PHP 5.1.3. El prefijo CURLINFO_ es intencionado.
CURLOPT_HTTPGET | true para resetear la petición HTTP a GET. Puesto que GET es el método por defecto, solo es necesario si el método fue cambiado.
CURLOPT_HTTPPROXYTUNNEL | true para usar un tunel a través de un proxy HTTP.
CURLOPT_MUTE | true para completar silenciosamente en lo que se refiere a las funciones cURL. | Eliminado en cURL 7.15.5 (Se puede usar CURLOPT_RETURNTRANSFER en su lugar)
CURLOPT_NETRC | true para escanear el fichero ~/.netrc y buscar un usuario y contraseña para establecer una conexión con el sitio remoto.
CURLOPT_NOBODY | true para excluir el body del output. El método de petición es establecido a HEAD. Si se cambia a false no cambia el método a GET.
CURLOPT_NOPROGRESS

true para desactivar medidor de progreso para transferencias cURL.

Nota:

PHP automáticamente establece esta opción a true, solo debería cambiarse para razones de testing.

CURLOPT_NOSIGNAL | true para ignorar cualquier función cURL que cause una señal a ser enviada al proceso PHP. Esta opción está activada por defecto en multi-hilo SAPI, entonces las opciones de timeout pueden ser usadas. | Añadido en cURL 7.10.
CURLOPT_PATH_AS_IS | true para no manejar secuencias de puntos. | Añadida en cURL 7.42.0. Disponible desde PHP 7.0.7.
CURLOPT_PIPEWAIT | true para esperar por 'pipelining'/multiplexación. | Añadida en cURL 7.43.0. Disponible desde PHP 7.0.7.
CURLOPT_POST | true para hacer un HTTP POST normal. Este POST del tipo application/x-www-form-urlencoded, el más común en formularios HTML.
CURLOPT_PUT | true para hacer un HTTP PUT de un fichero. El fichero a subir debe establecerse en CURLOPT_INFILE y CURLOPT_INFILESIZE.
CURLOPT_RETURNTRANSFER | true para devolver el resultado de la transferencia como string del valor de curl_exec() en lugar de mostrarlo directamente.
CURLOPT_SAFE_UPLOAD | true para deshabilitar el soporta para el prefijo @ para cargar ficheros en CURLOPT_POSTFIELDS, lo que significa que los valores que empiecen por @ pueden ser pasados de forma segura como campos. Se podría usar CURLFile en su lugar para las cargas. | Añadido en PHP 5.5.0 con false como valor predeterminado. PHP 5.6.0 cabia este valor predeterminado a true. PHP 7 elimina esta opción; la interfaz de CURLFile debe emplearse para subir ficheros.
CURLOPT_SASL_IR | true para habilitar el envío de la respuesta inicial en el primer paquete. | Añadida en cURL 7.31.10. Disponible desde PHP 7.0.7.
CURLOPT_SSL_ENABLE_ALPN | false para inhabilitar ALPN en la negociación de SSL (si libcurl del «backend» de SSL está construido para admitirla), lo cual se puede usar para negiaciar http2. | Añadida en cURL 7.36.0. Disponible desde PHP 7.0.7.
CURLOPT_SSL_ENABLE_NPN | false para inhabilitar NPN en la negociación de SSL (si libcurl del «backend» de SSL está construido para admitirla), lo cual se puede usar para negiaciar http2. | Añadida en cURL 7.36.0. Disponible desde PHP 7.0.7.
CURLOPT_SSL_VERIFYPEER | false para que cURL no verifique el peer del certificado. Para usar diferentes certificados para la verificación se pueden especificar con la opción CURLOPT_CAINFO o se puede especificar el directorio donde se encuentra el certificado con la opción CURLOPT_CAPATH. | true por omisión desde cURL 7.10. Paquete instalado por defecto en la versión CURL 7.10.
CURLOPT_SSL_VERIFYSTATUS | true para verificar el estado del certificado. | Añadida en cURL 7.41.0. Disponible desde PHP 7.0.7.
CURLOPT_TCP_FASTOPEN | true Para habilitar la Apertura Rápida de TCP (TCP Fast Open). | Añadida en cURL 7.49.0. Disponible desde PHP 7.0.7.
CURLOPT_TFTP_NO_OPTIONS | true para no enviar peticiones de opciones de TFTP. | Añadida en cURL 7.48.0. Disponible desde PHP 7.0.7.
CURLOPT_TRANSFERTEXT | true para usar modo ASCII para transferencias FTP. En LDAP, obtiene los datos en texto plano en lugar de HTML. En sistemas Windows, no estabecerá STDOUT en modo binario.
CURLOPT_UNRESTRICTED_AUTH | true para prevenir el envio de usuario y contraseña cuando se siguen locations (usando CURLOPT_FOLLOWLOCATION), incluso cuando el hostname es diferente.
CURLOPT_UPLOAD | true preparar cURL para subir un fichero.
CURLOPT_VERBOSE | true para mostrar información verbose. Escribe la salida en STDERR, o el fichero especificado usando CURLOPT_STDERR.

value debe ser un integer para los siguientes valores del parámetro option:

Opción | Establecer value a | Notas
CURLOPT_BUFFERSIZE | Tamaño del búfer a usar por cada lectura. De todas formas, no hay ninguna garantía de que la petición usará todo el búfer. | Añadido en cURL 7.10.
CURLOPT_CLOSEPOLICY Uno de los valores de CURLCLOSEPOLICY_*.

Nota:

Esta opción está obsoleta, ya que nunca se ha implementado en cURL, por lo que nunca ha tenido ningún efecto.

Eliminada en PHP 5.6.0.
CURLOPT_CONNECTTIMEOUT | Número de segundos a esperar cuando se está intentado conectar. Use 0 para esperar indefinidamente.
CURLOPT_CONNECTTIMEOUT_MS | Número de milisegundos a esperar cuando se está intentado conectar. Use 0 para esperar indefinidamente. Si se ha compilado libcurl para utilizar el sistema estándar de resolución de nombres, esta porción de conexión utilizará una resolución completa de un segundo en tiempos de expiración, con un mínimo permitido de un segundo. | Añadido en cURL 7.16.2. Disponible desde PHP 5.2.3.
CURLOPT_DNS_CACHE_TIMEOUT | Número de segundos a mantener las entradas DNS en memoria. Esta opción está establecida a 120 (2 minutos) por defecto.
CURLOPT_EXPECT_100_TIMEOUT_MS | El tiempo de espera para respuestas «Expect: 100-continue», en milisegundos. El valor predeterminado es 1000 milisegundos. | Añadida en cURL 7.36.0. Disponible desde PHP 7.0.7.
CURLOPT_FTPSSLAUTH | Método de autenticación FTP (cuando está activado): CURLFTPAUTH_SSL (prueba SSL primero), CURLFTPAUTH_TLS (prueba TLS primero), o CURLFTPAUTH_DEFAULT (hacer que cURL decida). | Añadido en cURL 7.12.2.
CURLOPT_HEADEROPT | Cómo tratar con cabeceras. una de las siguientes constantes: CURLHEADER_UNIFIED: las cabeceras especificadas en CURLOPT_HTTPHEADER se usarán en peticiones tanto a servidores como a proxies. Con esta opción habilitada, CURLOPT_PROXYHEADER no tendrá efecto. CURLHEADER_SEPARATE: hace que las cabeceras CURLOPT_HTTPHEADER solamente sean enviadas a un servidor y no a un proxy. Las cabeceras de proxies deben establecerse con CURLOPT_PROXYHEADER para poder usarlas. Observe que si se envía una petición no CONNECT a un proxy, libcurl enviará tanto las cabeceras de servidor como del proxy. Al realizar CONNECT, libcurl enviará cabeceras CURLOPT_PROXYHEADER solamente al proxy y luego cabeceeras CURLOPT_HTTPHEADER solamente al servidor. Lo predeterminado es CURLHEADER_SEPARATE a partir de cURL 7.42.1, y CURLHEADER_UNIFIED anteriormente. | Añadida en cURL 7.37.0. Disponible desde PHP 7.0.7.
CURLOPT_HTTP_VERSION | CURL_HTTP_VERSION_NONE (por defecto, hacer que CURL decida que versión a usar), CURL_HTTP_VERSION_1_0 (fuerza HTTP/1.0), or CURL_HTTP_VERSION_1_1 (fuerza HTTP/1.1).
CURLOPT_HTTPAUTH

Los métodos de autenticación HTTP. Las opciones son: CURLAUTH_BASIC, CURLAUTH_DIGEST, CURLAUTH_GSSNEGOTIATE, CURLAUTH_NTLM, CURLAUTH_ANY, y CURLAUTH_ANYSAFE.

El separador | o operador puede ser usado para combinar más de un método. Si se utiliza, cURL comprobará en el servidor remoto que métodos soporta y utilizará el más adecuado.

CURLAUTH_ANY es un alias para CURLAUTH_BASIC | CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM.

CURLAUTH_ANYSAFE es un alias para CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM.

CURLOPT_INFILESIZE | El tamaño esperado en bytes, del fichero cuando se está subiendo un fichero al sitio remoto. Téngase en cuenta que el uso de esta opción no detendrá libcurl a la hora de enviar más datos, exactamente lo que se envía depende de CURLOPT_READFUNCTION.
CURLOPT_LOW_SPEED_LIMIT | La velocidad de transferencia, en bytes por segundo, que la transferencia debería estar por debajo durante CURLOPT_LOW_SPEED_TIME segundos para PHP a considerar que la transferencia es demasiado lenta y debe abortarse.
CURLOPT_LOW_SPEED_TIME | Número en segundos en que la velocidad de transferencia debería estar debajo de CURLOPT_LOW_SPEED_LIMIT antes que PHP considere que la transferencia es demasiado lenta y debe abortarse.
CURLOPT_MAXCONNECTS | Número máximo de conexiones persistentes que están permitidas. Cuando se llega al límite, se utiliza CURLOPT_CLOSEPOLICY para determinar que conexión debe cerrarse.
CURLOPT_MAXREDIRS | Número máximo de redirecciones HTTP a seguir. Use esta opción con CURLOPT_FOLLOWLOCATION.
CURLOPT_PORT | Puerto alternativo a conectarse.
CURLOPT_POSTREDIR | Una máscara de bit de 1 (301 Movido permanentemente), 2 (302 Encontrado) y 4 (303 Ver otro) si el método POST de HTTP debería ser mantenido cuando CURLOPT_FOLLOWLOCATION está establecido y ocurre un tipo específico o una redirección. | Añadido en cURL 7.19.1. Disponible des PHP 5.3.2.
CURLOPT_PROTOCOLS

Máscara de los valores CURLPROTO_*. Si se utiliza, esta máscara limitará que protocolos utilizará libcurl en transferencias. Permite que libcurl utilice cualquiera de los protocolos pero limita que grupo de protocolos a usar en específicas transferencias. Por defecto libcurl acepta todos los protocolos. Vea también: CURLOPT_REDIR_PROTOCOLS.

Las opciones para válidos procolos son: CURLPROTO_HTTP, CURLPROTO_HTTPS, CURLPROTO_FTP, CURLPROTO_FTPS, CURLPROTO_SCP, CURLPROTO_SFTP, CURLPROTO_TELNET, CURLPROTO_LDAP, CURLPROTO_LDAPS, CURLPROTO_DICT, CURLPROTO_FILE, CURLPROTO_TFTP, CURLPROTO_ALL

Añadido en cURL 7.19.4.
CURLOPT_PROXYAUTH | Método de autenticación HTTP para usar conexiones vía proxy. Usa el mismo tipo de máscaras descritas en CURLOPT_HTTPAUTH. Para autenticación proxy, solamente CURLAUTH_BASIC y CURLAUTH_NTLM están actualmente soportadas. | Añadido en cURL 7.10.7.
CURLOPT_PROXYPORT | Número del puerto para usar en la conexión proxy. Este puerto también puede configurase en CURLOPT_PROXY.
CURLOPT_PROXYTYPE | Puede ser CURLPROXY_HTTP (por defecto), CURLPROXY_SOCKS4, CURLPROXY_SOCKS5, CURLPROXY_SOCKS4A o CURLPROXY_SOCKS5_HOSTNAME. | Añadido en cURL 7.10.
CURLOPT_REDIR_PROTOCOLS | Máscara de valores CURLPROTO_*. Si se usa, esta máscara limitará que protocolos usará libcurl en una transferencia que sigue una redireción cuando CURLOPT_FOLLOWLOCATION está activado. Esto permite limitar a específicas transferencias que grupo de protocolos utilizar en redireciones. Por defecto libcurl aceptará todos los protocolos excepto FILE y SCP. Esto es nuevo si se compara con versiones anteriores a 7.19.4 donde se seguían incodicionalmente todos los protocolos soportados. Vea también CURLOPT_PROTOCOLS para los valores de las constantes. | Añadido en cURL 7.19.4.
CURLOPT_RESUME_FROM | El punto, en bytes desde donde continuar una transferencia.
CURLOPT_SSL_OPTIONS | Establecer las opciones de funcionamento de SSL, las cuales son una máscara de bits de las siguientes constantes: CURLSSLOPT_ALLOW_BEAST: no intentar usar ningún método alternativo para defectos de seguridad en los protocolos SSL3 y TLS1.0. CURLSSLOPT_NO_REVOKE: inhabilitar la comprobación de revocación de certificados para aquellos «backends» de SSL donde tal funcionamiento está presente. | Añadida en cURL 7.25.0. Disponible desde PHP 7.0.7.
CURLOPT_SSL_VERIFYHOST | 1 para comprobar que existe un nombre común en el peer del certificado SSL. 2 para comprobar que existe un nombre común y también para verificar que el hostname coinicide con el proporcionado. 0 para no comprobar nombres. En entornos de producción el valor de esta opción debe mantenerse a 2 (valor predeterminado). | Soporte para el valor 1 eliminado en cURL 7.28.1
CURLOPT_SSLVERSION Una de las constantes CURL_SSLVERSION_DEFAULT (0), CURL_SSLVERSION_TLSv1 (1), CURL_SSLVERSION_SSLv2 (2), CURL_SSLVERSION_SSLv3 (3), CURL_SSLVERSION_TLSv1_0 (4), CURL_SSLVERSION_TLSv1_1 (5) o CURL_SSLVERSION_TLSv1_2 (6).

Nota:

Lo mejor es no establecerlo y dejar el valor predeterminado. Establecerlo a 2 o 3 es muy peligroso dadas las vulnerabilidades conocidas en SSLv2 y SSLv3.

CURLOPT_STREAM_WEIGHT | Establecer el peso del flujo numérico (un número entre 1 y 256). | Añadida en cURL 7.46.0. Disponible desde PHP 7.0.7.
CURLOPT_TIMECONDITION | Como se trata CURLOPT_TIMEVALUE. Utilice CURL_TIMECOND_IFMODSINCE para devolver la página solamente si fue modificada desde el tiempo especificado en CURLOPT_TIMEVALUE. Si no fué modificada, se devolverá "304 Not Modified" en el header asumiendo que CURLOPT_HEADER es true. Utilice CURL_TIMECOND_IFUNMODSINCE para el efecto contrario. CURL_TIMECOND_IFMODSINCE está activado por defecto.
CURLOPT_TIMEOUT | Número máximo de segundos permitido para ejectuar funciones cURL.
CURLOPT_TIMEOUT_MS | Número máximo en milisegundos permitido para ejecutar funciones cURL. Si se ha compilado libcurl para utilizar el sistema estándar de resolución de nombres, esta porción de conexión utilizará una resolución completa de un segundo en tiempos de expiración, con un mínimo permitido de un segundo. | Añadido en cURL 7.16.2. Disponible desde PHP 5.2.3.
CURLOPT_TIMEVALUE | Tiempo en segundos desde el 1 de enero de 1970. El tiempo será usado por CURLOPT_TIMECONDITION. Por defecto, se utiliza CURL_TIMECOND_IFMODSINCE.
CURLOPT_MAX_RECV_SPEED_LARGE | Si una descarga supera esta velocidad (en bytes por segundo) en su tasa media de transferencia, ésta se detendrá temporalmente para mantener la media igual o inferior al valor del parámetro. Por omisión, la velocidad es ilimitada. | Añadido en cURL 7.15.5. Disponible desde PHP 5.4.0.
CURLOPT_MAX_SEND_SPEED_LARGE | Si una subida supera esta velocidad (en bytes por segundo) en su tasa media de transferencia, ésta se detendrá temporalmente para mantener la media igual o inferior al valor del parámetro. Por omisión, la velocidad es ilimitada. | Añadido en cURL 7.15.5. Disponible desde PHP 5.4.0.
CURLOPT_SSH_AUTH_TYPES | Una máscara de bits que consta de una o más de CURLSSH_AUTH_PUBLICKEY, CURLSSH_AUTH_PASSWORD, CURLSSH_AUTH_HOST, CURLSSH_AUTH_KEYBOARD. Establece a CURLSSH_AUTH_ANY para que libcurl elija uno. | Añadido en cURL 7.16.1.
CURLOPT_IPRESOLVE | Permite a una aplicación seleccionar el tipo de dirección IP a usar cuando se resuelven nombres de host. Esto es interesante solamente al usar nombres de host que resuelven direcciones usando más de una versión de IP. Los valores posibles son CURL_IPRESOLVE_WHATEVER, CURL_IPRESOLVE_V4, CURL_IPRESOLVE_V6; el predeterminado es CURL_IPRESOLVE_WHATEVER. | Añadida en cURL 7.10.8.
CURLOPT_FTP_FILEMETHOD | Indicar a curl qué método empelar para alcanzar un fichero en un servidor FTP(S). Los valores posibles son CURLFTPMETHOD_MULTICWD, CURLFTPMETHOD_NOCWD y CURLFTPMETHOD_SINGLECWD. | Añadida en cURL 7.15.1. Disponible desde PHP 5.3.0.

El value debe ser una string para los siguientes valores del parámetro option:

Opción | Configurar value a | Notas
CURLOPT_CAINFO | Nombre del fichero que contiene uno o más certificados para verificar el peer. Solo tiene sentido cuando se utiliza en combinación de CURLOPT_SSL_VERIFYPEER. | Podría requerir una ruta absoluta.
CURLOPT_CAPATH | Directorio que contiene múltiple certificados CA. Utilice esta opción junto con CURLOPT_SSL_VERIFYPEER.
CURLOPT_COOKIE | Contenido de "Cookie: " del header para ser usado en la petición HTTP. Observe que múltiples cookies van separadas con punto y coma seguidas por un espacio (ej., "fruit=apple; colour=red")
CURLOPT_COOKIEFILE | Nombre del fichero que contiene datos de las cookies. El fichero de cookies puede estar en formato Netscape, o simplemente tipo HTTP plano dentro de un fichero. Si el nombre es una cadena vacía, no se cargarán cookies, aunque el manejo de cookies aún está habilitado.
CURLOPT_COOKIEJAR | Nombre del fichero donde guardar cookies internas cuando se cierra se cierra, por e.j. después de llamar a curl_close.
CURLOPT_CUSTOMREQUEST

Método de petición personalizado a usar en lugar de "GET" o "HEAD" cuando se realiza una petición HTTP. Es útil para hacer "DELETE" o otros tipos de peticiones HTTP menos comunes. "GET", "POST", "CONNECT" y otros, son valores válidos. Ej. No introduzca toda la petición HTTP aquí, seria incorrecto introducir: "GET /index.html HTTP/1.0\r\n\r\n".

Nota:

No cambie este valor sin antes asegurarse que el servidor soporta el método de petición personalizado.

CURLOPT_DEFAULT_PROTOCOL

El protocolo predeterminado a usar si al URL le falta un nombre de esquema.

Añadida en cURL 7.45.0. Disponible desde PHP 7.0.7.
CURLOPT_DNS_INTERFACE

Establecer el nombre de la interfaz de red a la que el resolvente de DNS debe vincularse. Debe ser un nombre de interfaz (no una dirección).

Añadida en cURL 7.33.0. Disponible desde PHP 7.0.7.
CURLOPT_DNS_LOCAL_IP4

Establecer la dirección IPv4 local a la que debe vincularse el resolvente. El argumento debe contener una dirección IPv4 numérica dada como cadena.

Añadida en cURL 7.33.0. Disponible desde PHP 7.0.7.
CURLOPT_DNS_LOCAL_IP6

Establecer la dirección IPv6 local a la que debe vincularse el resolvente. El argumento debe contener una dirección IPv6 numérica dada como cadena.

Añadida en cURL 7.33.0. Disponible desde PHP 7.0.7.
CURLOPT_EGDSOCKET | Es como CURLOPT_RANDOM_FILE, con excepción que en lugar de un fichero se utiliza un Entropy Gathering Daemon socket.
CURLOPT_ENCODING | Contenido del valor "Accept-Encoding: " en el header. Esto permite decodificar la respuesta. Los formatos de codificación disponibles son "identity", "deflate", y "gzip". Si el valor se envía vacío, "", se enviarán todos los tipos de condificación soportados. | Añadido en cURL 7.10.
CURLOPT_FTPPORT | El valor que será usando para obtener la dirección IP a usar para la instrucción FTP "PORT". La instrucción "PORT" dice al servidor remoto a qué dirección IP se debe conectar. La cadena puede ser una dirección IP, el nombre de un servidor o un interfaz de red (bajo Unix), o simplemente '-' para usar la dirección IP por defecto del sistema.
CURLOPT_INTERFACE | Nombre del interfaz de salida a usar. Puede ser el nombre del interfaz, una dirección IP o el nombre de un servidor.
CURLOPT_KEYPASSWD | El password requerido para usar la clave privada CURLOPT_SSLKEY o CURLOPT_SSH_PRIVATE_KEYFILE. | Añadido en cURL 7.16.1.
CURLOPT_KRB4LEVEL | Nivel de seguridad KRB4 (Kerberos 4). Cualquiera de los siguientes valores (en orden de menos a más potentes) son válidos: "clear", "safe", "confidential", "private".. Si la cadena no coincide con alguno de estos valores, será usado "private". Configure esta opción a null para desactivar seguridad KRB4. Actualmente la seguridad KRB4 solo funciona con transaciones FTP.
CURLOPT_LOGIN_OPTIONS | Se puede usar para establecer las opciones de inicio de sesión específicas del protocolo, tales como el mecanismoe de autenticación preferido mediante "AUTH=NTLM" o "AUTH=*", debiéndose ser usada junto con la opción CURLOPT_USERNAME. | Añadida en cURL 7.34.0. Disponible desde PHP 7.0.7.
CURLOPT_PINNEDPUBLICKEY | Establecer la clave pública fijada. La cadena puede ser el nombre de fichero de la clave pública fijada. El formato de fichero esperado es "PEM" o "DER". La cadena también puede ser cualquier númbero de «hashes» sha256 codificados en base64 precedidos de "sha256//" y separados por ";". | Añadida en cURL 7.39.0. Disponible desde PHP 7.0.7.
CURLOPT_POSTFIELDS | Todos los datos para enviar vía HTTP "POST". para enviar un fichero, prefija el nombre del fichero con @ y utiliza la ruta completa. Se puede especificar explícitamente el tipo de fichero añadiendo el tipo al nombre del fichero, en el formato ';type=mimetype'. Se puede enviar una cadena urlencoded como 'para1=val1&para2=val2&...' o también como un array con el nombre del campo como key y los datos como value. Si value es un array, el encabezado Content-Type será definido como multipart/form-data. A partir de PHP 5.2.0, value debe ser un array si los archivos son pasados a esta opción con el prefijo @. A partir de PHP 5.5.0, el prefijo @ está obsoleto, por lo que los ficheros se pueden enviar usando CURLFile. El prefijo @ puede ser deshabilitado por seguridad de proporcionar valores que comienzan con @ estableciendo la opción CURLOPT_SAFE_UPLOAD a true.
CURLOPT_PRIVATE | Cualquier dato que debería estar asociado con este manejador de cURL. Estos datos puede ser recuperados posteriormente con la opción CURLINFO_PRIVATE de curl_getinfo(). cURL no hace nada con estos datos. Al emplear un multimanejador de cURL, estos datos privados son típicamente una clave única para identificar un manejador estándar de cURL. | Añadida en cURL 7.10.3.
CURLOPT_PROXY | El proxy HTTP para enviar peticiones a través de tunel.
CURLOPT_PROXY_SERVICE_NAME | El nombre del servicio de autenticación del proxy. | Añadida en cURL 7.34.0. Disponible desde PHP 7.0.7.
CURLOPT_PROXYUSERPWD | Usuario y contraseña con el siguiente formato "[username]:[password]" para usarse en la conexión al proxy.
CURLOPT_RANDOM_FILE | Nombre del fichero a ser usado para generar números aleatorios para el SSL.
CURLOPT_RANGE | Rango(s) de datos para obtener en el formato "X-Y" donde X y Y son opcionales. Transferencias HTTP también soportan varios intérvalos, separados por comas en el formato "X-Y,N-M".
CURLOPT_REFERER | Contenido del Header "Referer: " para ser usado en la petición HTTP.
CURLOPT_SERVICE_NAME | El nombre del servicio de autenticación. | Añadida en cURL 7.43.0. Disponible desde PHP 7.0.7.
CURLOPT_SSH_HOST_PUBLIC_KEY_MD5 | Un string que contiene 32 dígitos hexadecimales. El string debe ser el MD5 checksum de la clave pública del host remoto, y libcurl rechazará la conexión a el host a menos que el md5sums coincida. Esta opción es sólo para las transferencias SCP y SFTP. | Añadido en cURL 7.17.1.
CURLOPT_SSH_PUBLIC_KEYFILE | El nombre de el fichero de la clave pública. Si no se utiliza, libcurl por omisión usa $HOME/.ssh/id_dsa.pub si la variable de entorno HOME es establecida, y "id_dsa.pub" en el directorio actual si HOME no está establecida. | Añadido en cURL 7.16.1.
CURLOPT_SSH_PRIVATE_KEYFILE | El nombre de el fichero de la clave privada. Si no se utiliza, libcurl por omisión usa $HOME/.ssh/id_dsa si la variable de entorno HOME es establecida, y "id_dsa" en el directorio actual si HOME no está establecida. Si el fichero está protegido con contraseña, establecer la contraseña con la constante CURLOPT_KEYPASSWD. | Añadido en cURL 7.16.1.
CURLOPT_SSL_CIPHER_LIST | Lista de ciphers a ser usados por SSL. Por ejemplo, RC4-SHA y TLSv1 es una lista válida de ciphers.
CURLOPT_SSLCERT | Nombre del fichero que contiene un certificado con formato PEM.
CURLOPT_SSLCERTPASSWD | Contraseña requerida para usar el certificado CURLOPT_SSLCERT.
CURLOPT_SSLCERTTYPE | Formato del certificado. Los formatos soportados son "PEM" (por defecto), "DER", y "ENG". | Añadido en cURL 7.9.3.
CURLOPT_SSLENGINE | El identificador para el crypto engine de la clave privada SSL especificada en CURLOPT_SSLKEY.
CURLOPT_SSLENGINE_DEFAULT | Identificador para el crypto engine usado para operaciones crypto asimétricas.
CURLOPT_SSLKEY | Nombre del fichero que contiene la clave privada SSL.
CURLOPT_SSLKEYPASSWD

Contraseña secreta requerida para usar la clave privada SSL especificada en CURLOPT_SSLKEY.

Nota:

Como esta opción contiene una contraseña, recuerde mantener el PHP script en un sitio seguro.

CURLOPT_SSLKEYTYPE | Tipo de llave privada SSL especificada en CURLOPT_SSLKEY. Los tipos de claves soportadas son "PEM" (default), "DER", y "ENG".
CURLOPT_UNIX_SOCKET_PATH | Habilita el uso de sockets de dominio Unix como extremos de conexión y establece la ruta al string dado. | Añadida en cURL 7.40.0. Disponible desde PHP 7.0.7.
CURLOPT_URL | Dirección URL a capturar. Este valor también puede ser configurado cuando se inicia una sesión con curl_init().
CURLOPT_USERAGENT | Contenido del header "User-Agent: " a ser usado en la petición HTTP.
CURLOPT_USERNAME | El nombre de usuario a emplear en la autenticación. | Añadida en cURL 7.19.0. Disponible desde PHP 5.5.0.
CURLOPT_USERPWD | Nombre de usuario y contraseña siguiendo el formato "[username]:[password]" para ser usado en la conexión.
CURLOPT_XOAUTH2_BEARER | Especifica el «token» de acceso de OAuth 2.0. | Añadida en cURL 7.33.0. Disponible desde PHP 7.0.7.

El value debe ser un array para los siguientes valores del parámetro option:

Opción | Configurar value a | Notas
CURLOPT_CONNECT_TO | Se conecta a un puerto y host específicos en lugar del puerto y host del URL. Acepta un array de cadenas con el formato HOST:PORT:CONNECT-TO-HOST:CONNECT-TO-PORT. | Añadida en cURL 7.49.0. Disponible desde PHP 7.0.7.
CURLOPT_HTTP200ALIASES | Array de respuestas HTTP 200 que serán tratadas como respuestas válidas y no como errores. | Añadido en cURL 7.10.3.
CURLOPT_HTTPHEADER | Un array de campos a configurar para el header HTTP, en el formato: array('Content-type: text/plain', 'Content-length: 100')
CURLOPT_POSTQUOTE | Un array de comandos FTP a ejecutar en el servidor después de que se realice la petición FTP.
CURLOPT_PROXYHEADER | Un array de cabeceras HTTP personalizadas a pasar a los proxies. | Añadida en cURL 7.37.0. Disponible desde PHP 7.0.7.
CURLOPT_QUOTE | Un array de comandos FTP a ejecutar en el servidor antes de que se realice la petición FTP.

El value debe ser un recurso de flujo (usando fopen(), por ejemplo) para los siguientes valores del parámetro option:

Opción | Configurar value a
CURLOPT_FILE | El fichero en el que el proceso de transferencia guardará el resultado. Por defecto es STDOUT (la ventana del navegador).
CURLOPT_INFILE | El fichero que el proceso de transferencia debe leer a la hora de subir un fichero.
CURLOPT_STDERR | Localización alternativa para mostrar los errores en lugar de STDERR.
CURLOPT_WRITEHEADER | El fichero donde guardar la parte del header durante la transferencia.

value debería ser el nombre de una función válida o un objeto Closure para los siguientes valores del parámetro option:

Opción | Configurar value a
CURLOPT_HEADERFUNCTION | Una llamada de retorno que acepta dos parámetros. El primero es el recurso cURL, el segundo es un string con los datos de la cabecera a escribir. Los datos de la cabecera deben ser escritos por esta llamada de retorno. Devuelve el número de bytes escritos.
CURLOPT_PASSWDFUNCTION | Una llamada de retorno que acepta tres parámetros. El primero es el recurso cURL, el segundo es un string que contiene la contraseña, y el tercero es la longitud máxima para la contraseña. Devuelve un string que contiene la contraseña.
CURLOPT_PROGRESSFUNCTION

Una llamada de retorno que acepta cinco parámetros. El primero es el recurso cURL, el segundo es el número total de bytes que se espera descargar en esta transferencia, el tercero es el número de bytes descargados hasta ahora, el cuarto es el número total de bytes que se espera subir en esta transferencia, y el quinto es el número de bytes subidos hasta ahora.

Nota:

La llamada de retorno solamente se invoca cuando la opción CURLOPT_NOPROGRESS está establecida a false.

Devuelve un valor distinto de cero para abortar la transferencia. En este caso, la transferencia establecerá un error CURLE_ABORTED_BY_CALLBACK.

CURLOPT_READFUNCTION | Una llamada de retorno que acepta tres parámetros. El primero es el recurso cURL, el segundo es un recurso de flujo de datos proporcionado a través de la opción CURLOPT_INFILE, y el tercero es la máxima cantidad de datos a leer. La llamada de retorno debe devolver un string con la misma longitud o menor que la cantidad de datos pedidos, normalmente leyéndolos del recurso de flujo de datos pasado. Debe devolver una cadena vacía para marcar el EOF.
CURLOPT_WRITEFUNCTION | Una llamada de retorno que acepta dos parámetros. El primero es el recurso cURL, el segundo es un string con los datos a escribir. Los datos deben ser guardados por esta llamada de retorno. Debe devolver el número exacto de bytes escritos o la transferencia será abortada con un error.

Otros valores:

Opción | Establecer value a
CURLOPT_SHARE | Un resultado de curl_share_init(). Hace que el gestor de cURL use los datos del gestor compartido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.0.7 | Se introdujeron CURL_HTTP_VERSION_2, CURL_HTTP_VERSION_2_PRIOR_KNOWLEDGE, CURL_HTTP_VERSION_2TLS, CURL_REDIR_POST_301, CURL_REDIR_POST_302, CURL_REDIR_POST_303, CURL_REDIR_POST_ALL, CURL_VERSION_KERBEROS5, CURL_VERSION_PSL, CURL_VERSION_UNIX_SOCKETS, CURLAUTH_NEGOTIATE, CURLAUTH_NTLM_WB, CURLFTP_CREATE_DIR, CURLFTP_CREATE_DIR_NONE, CURLFTP_CREATE_DIR_RETRY, CURLHEADER_SEPARATE, CURLHEADER_UNIFIED, CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE, CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE, CURLMOPT_MAX_HOST_CONNECTIONS, CURLMOPT_MAX_PIPELINE_LENGTH, CURLMOPT_MAX_TOTAL_CONNECTIONS, CURLOPT_CONNECT_TO, CURLOPT_DEFAULT_PROTOCOL, CURLOPT_DNS_INTERFACE, CURLOPT_DNS_LOCAL_IP4, CURLOPT_DNS_LOCAL_IP6, CURLOPT_EXPECT_100_TIMEOUT_MS, CURLOPT_HEADEROPT, CURLOPT_LOGIN_OPTIONS, CURLOPT_PATH_AS_IS, CURLOPT_PINNEDPUBLICKEY, CURLOPT_PIPEWAIT, CURLOPT_PROXY_SERVICE_NAME, CURLOPT_PROXYHEADER, CURLOPT_SASL_IR, CURLOPT_SERVICE_NAME, CURLOPT_SSL_ENABLE_ALPN, CURLOPT_SSL_ENABLE_NPN, CURLOPT_SSL_FALSESTART, CURLOPT_SSL_VERIFYSTATUS, CURLOPT_STREAM_WEIGHT, CURLOPT_TCP_FASTOPEN, CURLOPT_TFTP_NO_OPTIONS, CURLOPT_UNIX_SOCKET_PATH, CURLOPT_XOAUTH2_BEARER, CURLPROTO_SMB, CURLPROTO_SMBS, CURLPROXY_HTTP_1_0, CURLSSH_AUTH_AGENT y CURLSSLOPT_NO_REVOKE.
7.0.0 | Se ha eliminado el soporte para inhabilitar la opción CURLOPT_SAFE_UPLOAD. Todas las subidas de ficheros de curl deben emplear CURLFile.
5.6.0 | CURLOPT_SAFE_UPLOAD ahore es true de forma predeterminada.
5.6.0 | Se eliminó CURLOPT_CLOSEPOLICY y sus valores asociados.
5.5.0 | Se añadió el recurso cURL como el primer parámetro de la llamada de retorno CURLOPT_PROGRESSFUNCTION.
5.5.0 | Se introdujo CURLOPT_SHARE.
5.3.0 | Se introdujo CURLOPT_PROGRESSFUNCTION.
5.2.10 | Se introdujo CURLOPT_PROTOCOLS, y CURLOPT_REDIR_PROTOCOLS.
5.2.4 | Se introdujo CURLOPT_PRIVATE.
5.1.0 | Se introdujo CURLOPT_AUTOREFERER, CURLOPT_BINARYTRANSFER, CURLOPT_FTPSSLAUTH, CURLOPT_PROXYAUTH, y CURLOPT_TIMECONDITION.
5.0.0 | Se introdujo CURLOPT_FTP_USE_EPRT, CURLOPT_NOSIGNAL, CURLOPT_UNRESTRICTED_AUTH, CURLOPT_BUFFERSIZE, CURLOPT_HTTPAUTH, CURLOPT_PROXYPORT, CURLOPT_PROXYTYPE, CURLOPT_SSLCERTTYPE, y CURLOPT_HTTP200ALIASES.

Ejemplos

Ejemplo #1 Inicializar una nueva sesión de cURL y obtener una página web

<?php
// Crear un nuevo recurso cURL
$ch = curl_init();

// Configurar URL y otras opciones apropiadas
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, false);

// Capturar la URL y pasarla al navegador
curl_exec($ch);

// Cerrar el recurso cURL y liberar recursos del sistema
curl_close($ch);
?>

Ejemplo #2 Subir un fichero (obsoleto a partir de PHP 5.5.0)

<?php

/* http://localhost/upload.php:
print_r($_POST);
print_r($_FILES);
*/

$ch = curl_init();

$data = array('name' => 'Foo', 'file' => '@/home/user/test.png');

curl_setopt($ch, CURLOPT_URL, 'http://localhost/upload.php');
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_SAFE_UPLOAD, false); // requerido a partir de PHP 5.6.0
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

curl_exec($ch);
?>

El resultado del ejemplo sería:

Array
(
    [name] => Foo
)
Array
(
    [file] => Array
        (
            [name] => test.png
            [type] => image/png
            [tmp_name] => /tmp/phpcpjNeQ
            [error] => 0
            [size] => 279
        )

)

Notas

Nota:

Si pasamos un array a CURLOPT_POSTFIELDS codificará los datos como multipart/form-data, pero si pasamos una cadena URL-encoded codificará los datos como application/x-www-form-urlencoded.

Ver también

  • curl_setopt_array() - Configura múltiples opciones para una transferencia cURL


Cierra un gestor cURL compartido

  • « curl_setopt
  • curl_share_errno »
  • PHP Manual
  • Funciones de cURL
  • Cierra un gestor cURL compartido

curl_share_close

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_close — Cierra un gestor cURL compartido

Descripción

curl_share_close ( resource $sh ) : void

Cierra un gestor cURL compartido y libera todos los recursos.

Parámetros

sh

Un gestor compartido cURL devuelto por la función curl_share_init()

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo con curl_share_setopt()

Este ejemplo creará un gestor cURL compartido, y dos gestores cURL en el, y entonces los ejecutará con cookies de compartición de datos.

<?php
// Crear el gestor compartido cURL y configurarlo para compartir cookies
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Inicializar el primer gestor cURL handle y asignarle el gestor compartido
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Ejecutar el primer gestor cURL
curl_exec($ch1);

// Inicializar el segundo gestor cURL handle y asignarle el gestor compartido
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Ejecutar el segundo gestor cURL
// todas las cookies del gestor $ch1 son compartidas con el gestor $ch2
curl_exec($ch2);

// Cerrar el gestor compartido cURL
curl_share_close($sh);

// Cerrar los gestores cURL
curl_close($ch1);
curl_close($ch2);
?>

Ver también

  • curl_share_init() - Inicializar un gestor cURL compartido


Devuelve el último número del error compartido cURL

  • « curl_share_close
  • curl_share_init »
  • PHP Manual
  • Funciones de cURL
  • Devuelve el último número del error compartido cURL

curl_share_errno

(PHP 7 >= 7.1.0, PHP 8)

curl_share_errno — Devuelve el último número del error compartido cURL

Descripción

curl_share_errno ( resource $sh ) : int

Devuelve un integer conteniendo el último número de error del gestor cURL compartido.

Parámetros

sh

Un gestor cURL compartido retornado por curl_share_init().

Valores devueltos

Devuelve un integer conteniendo el último número de error del gestor cURL compartido, o false en caso de error.

Ver también

  • curl_errno() - Devuelve el último número de error


Inicializar un gestor cURL compartido

  • « curl_share_errno
  • curl_share_setopt »
  • PHP Manual
  • Funciones de cURL
  • Inicializar un gestor cURL compartido

curl_share_init

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_init — Inicializar un gestor cURL compartido

Descripción

curl_share_init ( ) : resource

Permite la compartición de datos entre gestores cURL.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un recurso del tipo "cURL Share Handle".

Ejemplos

Ejemplo #1 Ejemplo con curl_share_init()

Este ejemplo creará un gestor compartido cURL, añadirá dos gestores cURL en él, y entonces los ejecuta con compartición de datos con cookie.

<?php
// Crear gestor compartido cURL y configurarlo para compartir datos con cookie
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Inicializar el primer gestor cURL y asignarlo al gestor compartido
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Ejecutar el primer gestor cURL
curl_exec($ch1);

// Inicializar el segundo gestor cURL y asignarlo al gestor compartido
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Ejecutar el segundo gestor cURL
// todas las cookies del gestor $ch1 son compartidas con el gestor $ch2
curl_exec($ch2);

// Cerrar el gestor compartido cURL
curl_share_close($sh);

// Cerrar los gestores cURL
curl_close($ch1);
curl_close($ch2);
?>

Ver también

  • curl_share_setopt() - Configura una opción para un manejador cURL compartido
  • curl_share_close() - Cierra un gestor cURL compartido


Configura una opción para un manejador cURL compartido

  • « curl_share_init
  • curl_share_strerror »
  • PHP Manual
  • Funciones de cURL
  • Configura una opción para un manejador cURL compartido

curl_share_setopt

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_setopt — Configura una opción para un manejador cURL compartido

Descripción

curl_share_setopt ( resource $sh , int $option , string $value ) : bool

Configura una opción en el manejador cURL compartido dado.

Parámetros

sh

Un manejador cURL compartido devuelto por curl_share_init().

option

Opción | Descripción
CURLSHOPT_SHARE | Especifica un tipo de datos que debe ser compartido.
CURLSHOPT_UNSHARE | Especifica un tipo de datos que no debe ser compartido.

value

Valor | Descripción
CURL_LOCK_DATA_COOKIE | Comparte cookies.
CURL_LOCK_DATA_DNS | Comparte la caché DNS. Tener en cuenta que cuando se usan multimanejadores cURL , todos los manejadores añadidos al mismo multimanejador compartirán la caché DNS por defecto.
CURL_LOCK_DATA_SSL_SESSION | Comparte IDs de sesiones SSL session, reduciendo el tiempo gastado en la negociación SSL cuando se reconecta al mismo servidor. Notar que los IDs de sesión SSL se reutilizan por defecto dentro del mismo manejador.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de curl_share_setopt()

Este ejemplo creará un manejador cURL compartido, añade dos manejadores cURL en él, y los ejecuta con compartición de datos con cookie.

<?php
// Crea un manejador cURL compartido y lo configura para compartir cookies
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Inicializa el primer manejador cURL y lo asigna el manejador compartido
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Ejecuta el primer manejador cURL
curl_exec($ch1);

// Inicializa el segundo manejador cURL y lo asigna al manejador compartido
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Ejecuta el segundo manejador cURL
// todas las cookies del manejador $ch1 se comparten con el manejador $ch2
curl_exec($ch2);

// Cierra el manejador compartido cURL
curl_share_close($sh);

// Cierra los manejadores cURL
curl_close($ch1);
curl_close($ch2);
?>


Devuelve string con la descripción del codigo de error dado

  • « curl_share_setopt
  • curl_strerror »
  • PHP Manual
  • Funciones de cURL
  • Devuelve string con la descripción del codigo de error dado

curl_share_strerror

(PHP 7 >= 7.1.0, PHP 8)

curl_share_strerror — Devuelve string con la descripción del codigo de error dado

Descripción

curl_share_strerror ( int $errornum ) : string

Devuelve un texto describiendo el mensaje de error del código de error dado.

Parámetros

errornum

Una de las constantes de los » códigos de error cURL.

Valores devueltos

Devuelve la descripción del error o null si el código de error es inválido.

Ver también

  • curl_share_errno() - Devuelve el último número del error compartido cURL
  • curl_strerror() - Devuelve un string que describe el código de error dado


Devuelve un string que describe el código de error dado

  • « curl_share_strerror
  • curl_unescape »
  • PHP Manual
  • Funciones de cURL
  • Devuelve un string que describe el código de error dado

curl_strerror

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_strerror — Devuelve un string que describe el código de error dado

Descripción

curl_strerror ( int $errornum ) : string

Devuelve un mensaje de texto describiendo el código de error dado.

Parámetros

errornum

Una de las constantes de » código de error cURL .

Valores devueltos

Devuelve la descripción de error o null para códigos de error inválidos.

Ejemplos

Ejemplo #1 Ejemplo de curl_errno()

<?php
// Crea un gestor curl con un protocolo con nombre erróneo en una URL
$ch = curl_init("htp://example.com/");

// Envía solicitud
curl_exec($ch);

// Valida si se ha producido errores y muestra el mensaje de error
if($errno = curl_errno($ch)) {
    $error_message = curl_strerror($errno);
    echo "cURL error ({$errno}):\n {$error_message}";
}

// Cierra el gestor
curl_close($ch);
?>

El resultado del ejemplo sería:

cURL error (1):
 Unsupported protocol

Ver también

  • curl_errno() - Devuelve el último número de error
  • curl_error() - Devuelve una cadena que contiene el último error de la sesión actual
  • » códigos de error Curl


Descodifica un string codificado de URL

  • « curl_strerror
  • curl_version »
  • PHP Manual
  • Funciones de cURL
  • Descodifica un string codificado de URL

curl_unescape

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_unescape — Descodifica un string codificado de URL

Descripción

curl_unescape ( resource $ch , string $str ) : string

Esta función descodifica un string codificado de URL.

Parámetros

ch

El recurso cURL devuelto por curl_init().

str

El string de URL codificado a ser descodificado.

Valores devueltos

Devuelve el string descodificado o o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de curl_escape()

<?php
// Crea un gestor cURL
$ch = curl_init('http://example.com/redirect.php');

// Envia una solicitud HTTP y sigue las redirecciones
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);
curl_exec($ch);

// Obtiene la última URL efectiva
$effective_url = curl_getinfo($ch, CURLINFO_EFFECTIVE_URL);
// ie. "http://example.com/show_location.php?loc=M%C3%BCnchen"

// Descodifica la URL
$effective_url_decoded = curl_unescape($ch, $effective_url);
// "http://example.com/show_location.php?loc=München"

// Cierra el gestor
curl_close($ch);
?>

Notas

Nota:

curl_unescape() no descodifica los símbolos de suma (+)en espacios, este es el comportamiento de la función urldecode() .

Ver también

  • curl_escape() - Función URL que codifica el string dado
  • urlencode() - Codifica como URL una cadena
  • urldecode() - Decodifica una cadena cifrada como URL
  • rawurlencode() - Codificar estilo URL de acuerdo al RFC 3986
  • rawurldecode() - Decodificar cadenas codificadas estilo URL


Obtiene la información de la versión de cURL

  • « curl_unescape
  • CURLFile »
  • PHP Manual
  • Funciones de cURL
  • Obtiene la información de la versión de cURL

curl_version

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_version — Obtiene la información de la versión de cURL

Descripción

curl_version ( int $age = CURLVERSION_NOW ) : array

Devuelve información acerca de la versión de cURL.

Parámetros

age

Valores devueltos

Devuelve un array asociativo con los siguientes elementos:

Índice | Valor descriptivo
version_number | -Número de versión cURL 24 bits
version | Número de versión cURL, como string
ssl_version_number | Número de versión OpenSSL 24 bits
ssl_version | Número de versión OpenSSL, como string
libz_version | Número de versión zlib version, como cadena
host | Información acerca del host donde se compiló cURL
age |
features | Un máscara de las constantes CURL_VERSION_XXX
protocols | Un array de los nombres de protocolos soportados por cURL

Ejemplos

Ejemplo #1 ejemplo de curl_version()

Este ejemplo comprueba que características están disponibles en esta versión de cURL usando la máscara 'features' devuelta por curl_version().

<?php
// Obtener array de la versión de curl
$version = curl_version();

// Estos son los campos que se pueden usar para
// comprobar ciertas caracerísticas para esta versión de curl
$bitfields = Array(
            'CURL_VERSION_IPV6',
            'CURL_VERSION_KERBEROS4',
            'CURL_VERSION_SSL',
            'CURL_VERSION_LIBZ'
   );

foreach($bitfields as $feature)
{
    echo $feature . ($version['features'] & constant($feature) ? ' coincide' : ' no coincide');
    echo PHP_EOL;
}
?>


La clase CURLFile

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Introducción

CURLFile debería emplearse para subir un fichero con CURLOPT_POSTFIELDS.

Sinopsis de la Clase

CURLFile {
/* Propiedades */
public $name ;
public $mime ;
public $postname ;
/* Métodos */
public __construct ( string $filename , string $mimetype = ? , string $postname = ? )
public getFilename ( ) : string
public getMimeType ( ) : string
public getPostFilename ( ) : string
public setMimeType ( string $mime ) : void
public setPostFilename ( string $postname ) : void
}

Propiedades

name

Nombrte del fichero a subir.

mime

Tipo MIME del fichero (el predeterminado es application/octet-stream).

postname

El nombre del fichero en los datos de subida (lo predeterminado es la propiedad name).

Ver también

  • curl_setopt()

Tabla de contenidos

  • CURLFile::__construct — Crear un objeto CURLFile
  • CURLFile::getFilename — Recupera el nombre de un fichero
  • CURLFile::getMimeType — Recupera el tipo MIME
  • CURLFile::getPostFilename — Recupera el nombre de fichero para POST
  • CURLFile::setMimeType — Configura el tipo MIME
  • CURLFile::setPostFilename — Establecer el nombre de fichero para POST


Crear un objeto CURLFile

  • « CURLFile
  • CURLFile::getFilename »
  • PHP Manual
  • CURLFile
  • Crear un objeto CURLFile

CURLFile::__construct

curl_file_create

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::__construct -- curl_file_create — Crear un objeto CURLFile

Descripción

Estilo orientado a objetos

public CURLFile::__construct ( string $filename , string $mimetype = ? , string $postname = ? )

Estilo por procedimientos

curl_file_create ( string $filename , string $mimetype = ? , string $postname = ? ) : CURLFile

Crea un objeto CURLFile , utilizado para transferir (upload) un fichero con CURLOPT_POSTFIELDS.

Parámetros

filename

Ruta de acceso al fichero a ser transferido.

mimetype

Tipo MIME del fichero.

postname

Nombre del fichero para los datos de subida.

Valores devueltos

Devuelve un objeto CURLFile .

Ejemplos

Ejemplo #1 Ejemplo con CURLFile::__construct()

Estilo orientado a objetos

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Crea un gestor cURL
$ch = curl_init('http://example.com/upload.php');

// Crea un objeto CURLFile
$cfile = new CURLFile('cats.jpg','image/jpeg','test_name');

// Asigna los datos POST
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Ejecuta el gestor
curl_exec($ch);
?>

Estilo por procedimientos

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Crea un gestor cURL
$ch = curl_init('http://example.com/upload.php');

// Crea un objeto CURLFile
$cfile = curl_file_create('cats.jpg','image/jpeg','test_name');

// Asigna los datos POST
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Ejecuta el gestor
curl_exec($ch);
?>

El resultado del ejemplo sería:

array(1) {
  ["test_file"]=>
  array(5) {
    ["name"]=>
    string(9) "test_name"
    ["type"]=>
    string(10) "image/jpeg"
    ["tmp_name"]=>
    string(14) "/tmp/phpPC9Kbx"
    ["error"]=>
    int(0)
    ["size"]=>
    int(46334)
  }
}

Ver también

  • curl_setopt() - Configura una opción para una transferencia cURL


Recupera el nombre de un fichero

  • « CURLFile::__construct
  • CURLFile::getMimeType »
  • PHP Manual
  • CURLFile
  • Recupera el nombre de un fichero

CURLFile::getFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getFilename — Recupera el nombre de un fichero

Descripción

public CURLFile::getFilename ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de fichero.


Recupera el tipo MIME

  • « CURLFile::getFilename
  • CURLFile::getPostFilename »
  • PHP Manual
  • CURLFile
  • Recupera el tipo MIME

CURLFile::getMimeType

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getMimeType — Recupera el tipo MIME

Descripción

public CURLFile::getMimeType ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el tipo MIME.


Recupera el nombre de fichero para POST

  • « CURLFile::getMimeType
  • CURLFile::setMimeType »
  • PHP Manual
  • CURLFile
  • Recupera el nombre de fichero para POST

CURLFile::getPostFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getPostFilename — Recupera el nombre de fichero para POST

Descripción

public CURLFile::getPostFilename ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Recupera el nombre de fichero para POST.


Configura el tipo MIME

  • « CURLFile::getPostFilename
  • CURLFile::setPostFilename »
  • PHP Manual
  • CURLFile
  • Configura el tipo MIME

CURLFile::setMimeType

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::setMimeType — Configura el tipo MIME

Descripción

public CURLFile::setMimeType ( string $mime ) : void

Parámetros

mime

Tipo MIME para los datos de POST.

Valores devueltos

No devuelve ningún valor.


Establecer el nombre de fichero para POST

  • « CURLFile::setMimeType
  • Event »
  • PHP Manual
  • CURLFile
  • Establecer el nombre de fichero para POST

CURLFile::setPostFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::setPostFilename — Establecer el nombre de fichero para POST

Descripción

public CURLFile::setPostFilename ( string $postname ) : void

Parámetros

postname

El nombre de fichero para los datos de POST.

Valores devueltos

No devuelve ningún valor.


Event

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Ejemplos
  • Event flags
  • About event persistence
  • Event callbacks
  • Constructing signal events
  • Event — The Event class
    • Event::add — Makes event pending
    • Event::addSignal — Makes signal event pending
    • Event::addTimer — Makes timer event pending
    • Event::__construct — Constructs Event object
    • Event::del — Makes event non-pending
    • Event::delSignal — Makes signal event non-pending
    • Event::delTimer — Makes timer event non-pending
    • Event::free — Make event non-pending and free resources allocated for this event
    • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending — Detects whether event is pending or scheduled
    • Event::set — Re-configures event
    • Event::setPriority — Set event priority
    • Event::setTimer — Re-configures timer event
    • Event::signal — Constructs signal event object
    • Event::timer — Constructs timer event object
  • EventBase — The EventBase class
    • EventBase::__construct — Construye un objeto EventBase
    • EventBase::dispatch — Despacha eventos pendientes
    • EventBase::exit — Detiene el envío de los eventos
    • EventBase::free — Free resources allocated for this event base
    • EventBase::getFeatures — Devuelve una máscara de bits de funcionalidades soportadas
    • EventBase::getMethod — Devuelve el método de evento utilizado
    • EventBase::getTimeOfDayCached — Devuelve el tiempo del evento base actual
    • EventBase::gotExit — Verifica si se ha indicado al bucle del evento de salir
    • EventBase::gotStop — Verifica si se ha indicado al bucle del evento de salir
    • EventBase::loop — Despacha eventos pendientes
    • EventBase::priorityInit — Define el número de prioridades por evento base
    • EventBase::reInit — Reinicializa el evento base (después de un 'fork')
    • EventBase::stop — Solicita a event_base que detenga la emisión de eventos
  • EventBuffer — The EventBuffer class
    • EventBuffer::add — Añade datos al final de un buffer de eventos
    • EventBuffer::addBuffer — Mueve todos los datos de un buffer a la instancia actual de EventBuffer
    • EventBuffer::appendFrom — Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual
    • EventBuffer::__construct — Construye el objeto EventBuffer
    • EventBuffer::copyout — Copia un número específico de bytes del principio del buffer
    • EventBuffer::drain — Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
    • EventBuffer::enableLocking — Descripción
    • EventBuffer::expand — Reserva espacio en el buffer
    • EventBuffer::freeze — Evita que las llamadas puedan modificar un buffer de eventos
    • EventBuffer::lock — Bloquea un buffer
    • EventBuffer::prepend — Prepend data to the front of the buffer
    • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read — Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom — Read data from a file onto the end of the buffer
    • EventBuffer::readLine — Extracts a line from the front of the buffer
    • EventBuffer::search — Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr — Substracts a portion of the buffer data
    • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
    • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
    • EventBuffer::write — Write contents of the buffer to a file or socket
  • EventBufferEvent — The EventBufferEvent class
    • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::__construct — Constructs EventBufferEvent object
    • EventBufferEvent::createPair — Creates two buffer events connected to each other
    • EventBufferEvent::disable — Disable events read, write, or both on a buffer event
    • EventBufferEvent::enable — Enable events read, write, or both on a buffer event
    • EventBufferEvent::free — Free a buffer event
    • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read — Read buffer's data
    • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority — Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
    • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter — Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer
    • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher
    • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection
    • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection
    • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection
    • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation
    • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write — Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer
  • About buffer event callbacks
  • EventConfig — The EventConfig class
    • EventConfig::avoidMethod — Tells libevent to avoid specific event method
    • EventConfig::__construct — Constructs EventConfig object
    • EventConfig::requireFeatures — Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval — Prevents priority inversion
  • EventDnsBase — The EventDnsBase class
    • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
    • EventDnsBase::addSearch — Adds a domain to the list of search domains
    • EventDnsBase::clearSearch — Removes all current search suffixes
    • EventDnsBase::__construct — Constructs EventDnsBase object
    • EventDnsBase::countNameservers — Gets the number of configured nameservers
    • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
    • EventDnsBase::setOption — Set the value of a configuration option
    • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches
  • EventHttp — The EventHttp class
    • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
    • EventHttp::bind — Binds an HTTP server on the specified address and port
    • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
    • EventHttp::removeServerAlias — Removes server alias
    • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback — Sets a callback for specified URI
    • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize — Sets maximum request body size
    • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
    • EventHttp::setTimeout — Sets the timeout for an HTTP request
  • EventHttpConnection — The EventHttpConnection class
    • EventHttpConnection::__construct — Constructs EventHttpConnection object
    • EventHttpConnection::getBase — Returns event base associated with the connection
    • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback — Set callback for connection close
    • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
    • EventHttpConnection::setRetries — Sets the retry limit for the connection
    • EventHttpConnection::setTimeout — Sets the timeout for the connection
  • EventHttpRequest — The EventHttpRequest class
    • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel — Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection — Closes associated HTTP connection
    • EventHttpRequest::__construct — Constructs EventHttpRequest object
    • EventHttpRequest::findHeader — Finds the value belonging a header
    • EventHttpRequest::free — Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
    • EventHttpRequest::getCommand — Returns the request command(method)
    • EventHttpRequest::getConnection — Returns EventHttpConnection object
    • EventHttpRequest::getHost — Returns the request host
    • EventHttpRequest::getInputBuffer — Returns the input buffer
    • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
    • EventHttpRequest::getResponseCode — Returns the response code
    • EventHttpRequest::getUri — Returns the request URI
    • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError — Send an HTML error message to the client
    • EventHttpRequest::sendReply — Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart — Initiate a chunked reply
  • EventListener — The EventListener class
    • EventListener::__construct — Creates new connection listener associated with an event base
    • EventListener::disable — Disables an event connect listener object
    • EventListener::enable — Enables an event connect listener object
    • EventListener::getBase — Returns event base associated with the event listener
    • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound
    • EventListener::setCallback — The setCallback purpose
    • EventListener::setErrorCallback — Set event listener's error callback
  • EventSslContext — The EventSslContext class
    • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes
  • EventUtil — The EventUtil class
    • EventUtil::__construct — The abstract constructor
    • EventUtil::getLastSocketErrno — Returns the most recent socket error number
    • EventUtil::getLastSocketError — Returns the most recent socket error
    • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName — Retreives the current address to which the socket is bound
    • EventUtil::setSocketOption — Sets socket options
    • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()


Introducción

Esta es una extensión para planificar eficientemente los eventos basados en las Entradas/Salidas, el tiempo y las señales; usando el mejor mecanismo de notificación Entrada/Salida disponible para una plataforma especifica. Es un puerto de “libevent” para la infraestructura de PHP.

Nota:

Note, Windows support introduced in event-1.9.0 .

Version 1.0.0 Introduce una nueva API orientada a Objetos (rompiendo la compatibilidad con versiones anteriores) y soporte de libevent 2+ incluyendo HTTP, DNS, OpenSSL y el event listener

Nota:

Nota, event-1.0.0 y superiores no son compatibles con las versiones previas


Requerimientos

This extension requires » libevent library. Most modern distributions provide packages for libevent.

OpenSSL features require » OpenSSL library.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/event .


Ejemplos

Ejemplo #1 Simple HTTP client

<?php
// Read callback
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

if ($argc != 3) {
    echo <<<EOS
Trivial HTTP 0.x client
Syntax: php {$argv[0]} [hostname] [resource]
Example: php {$argv[0]} www.google.com /

EOS;
    exit();
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb"
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

El resultado del ejemplo sería algo similar a:

Connected.
HTTP/1.1 301 Moved Permanently
Date: Fri, 01 Mar 2013 18:47:48 GMT
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1252
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Age: 133438
Expires: Sat, 30 Mar 2013 05:39:28 GMT
Connection: close

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=Windows-1252">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

Ejemplo #2 HTTP client using asynchronous DNS resolver

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

// Read callback
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
// Send request
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

// Dispatch pending events
$base->dispatch();
?>

Ejemplo #3 Echo server

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>

Ejemplo #4 SSL echo server

<?php
/*
 * SSL echo server
 *
 * To test:
 * 1) Run:
 * $ php examples/ssl-echo-server/server.php 9998
 *
 * 2) in another terminal window run:
 * $ socat - SSL:127.0.0.1:9998,verify=1,cafile=examples/ssl-echo-server/cert.pem
 */

class MySslEchoServer {
    public $port,
        $base,
        $bev,
        $listener,
        $ctx;

    function __construct ($port, $host = "127.0.0.1") {
        $this->port = $port;
        $this->ctx = $this->init_ssl();
        if (!$this->ctx) {
            exit("Failed creating SSL context\n");
        }

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        $this->listener = new EventListener($this->base,
            array($this, "ssl_accept_cb"), $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, "$host:$port");
        if (!$this->listener) {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }
    function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev.
    function ssl_read_cb($bev, $ctx) {
        $in = $bev->input; //$bev->getInput();

        printf("Received %zu bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $bev->writeBuffer($in);
    }

    // This callback is invoked when some even occurs on the event listener,
    // e.g. connection closed, or an error occurred
    function ssl_event_cb($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            // Fetch errors from the SSL error stack
            while ($err = $bev->sslError()) {
                fprintf(STDERR, "Bufferevent error %s.\n", $err);
            }
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
        }
    }

    // This callback is invoked when a client accepts new connection
    function ssl_accept_cb($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it.
        $this->bev = EventBufferEvent::sslSocket($this->base, $fd, $this->ctx,
            EventBufferEvent::SSL_ACCEPTING, EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->bev) {
            echo "Failed creating ssl buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->bev->enable(Event::READ);
        $this->bev->setCallbacks(array($this, "ssl_read_cb"), NULL,
            array($this, "ssl_event_cb"), NULL);
    }

    // This callback is invoked when we failed to setup new connection for a client
    function accept_error_cb($listener, $ctx) {
        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $this->base->exit(NULL);
    }

    // Initialize SSL structures, create an EventSslContext
    // Optionally create self-signed certificates
    function init_ssl() {
        // We *must* have entropy. Otherwise there's no point to crypto.
        if (!EventUtil::sslRandPoll()) {
            exit("EventUtil::sslRandPoll failed\n");
        }

        $local_cert = __DIR__."/cert.pem";
        $local_pk   = __DIR__."/privkey.pem";

        if (!file_exists($local_cert) || !file_exists($local_pk)) {
            echo "Couldn't read $local_cert or $local_pk file.  To generate a key\n",
                "and self-signed certificate, run:\n",
                "  openssl genrsa -out $local_pk 2048\n",
                "  openssl req -new -key $local_pk -out cert.req\n",
                "  openssl x509 -req -days 365 -in cert.req -signkey $local_pk -out $local_cert\n";

            return FALSE;
        }

        $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
             EventSslContext::OPT_LOCAL_CERT  => $local_cert,
             EventSslContext::OPT_LOCAL_PK    => $local_pk,
             //EventSslContext::OPT_PASSPHRASE  => "echo server",
             EventSslContext::OPT_VERIFY_PEER => true,
             EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
        ));

        return $ctx;
    }
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}

$l = new MySslEchoServer($port);
$l->dispatch();
?>

Ejemplo #5 Signal handler

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base;

    function __construct($base) {
        $this->base = $base;
    }

    function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        event_base_loopexit($c->base);
    }
}

$base = event_base_new();
$c    = new MyEventSignal($base);
$no   = SIGTERM;
$ev   = evsignal_new($base, $no, array($c,'eventSighandler'), $c);

evsignal_add($ev);

event_base_loop($base);
?>

Ejemplo #6 Use libevent's loop to process requests of `eio' extension

<?php
// Callback for eio_nop()
function my_nop_cb($d, $r) {
    echo "step 6\n";
}

$dir = "/tmp/abc-eio-temp";
if (file_exists($dir)) {
    rmdir($dir);
}

echo "step 1\n";

$base = new EventBase();

echo "step 2\n";

eio_init();

eio_mkdir($dir, 0750, EIO_PRI_DEFAULT, "my_nop_cb");

$event = new Event($base, eio_get_event_stream(),
    Event::READ | Event::PERSIST, function ($fd, $events, $base) {
    echo "step 5\n";

    while (eio_nreqs()) {
        eio_poll();
    }

    $base->stop();
}, $base);

echo "step 3\n";

$event->add();

echo "step 4\n";

$base->dispatch();

echo "Done\n";
?>

Ejemplo #7 Miscellaneous

<?php
/* {{{ Config & supported stuff */
echo "Supported methods:\n";
foreach (Event::getSupportedMethods() as $m) {
    echo $m, PHP_EOL;
}

// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);
echo "Event method used: ", $base->getMethod(), PHP_EOL;

echo "Features:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
/* }}} */

/* {{{ Base */
$base = new EventBase();
$event = new Event($base, STDIN, Event::READ | Event::PERSIST, function ($fd, $events, $arg) {
    static $max_iterations = 0;

    if (++$max_iterations >= 5) {
        /* exit after 5 iterations with timeout of 2.33 seconds */
        echo "Stopping...\n";
        $arg[0]->exit(2.33);
    }

    echo fgets($fd);
}, array (&$base));

$event->add();
$base->loop();
/* Base }}} */
?>

Ejemplo #8 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

El resultado del ejemplo sería algo similar a:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Ejemplo #9 Simple HTTPS server

<?php
/*
 * Simple HTTPS server.
 *
 * 1) Run the server: `php examples/https.php 9999`
 * 2) Test it: `php examples/ssl-connection.php 9999`
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 200;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    $buf = $req->getInputBuffer();
    echo "\n >> Reading input buffer (", $buf->length, ") ...\n";
    while ($s = $buf->read(1024)) {
        echo $s;
    }
    echo "\nNo more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_400($req) {
    $req->sendError(400);
}

function _init_ssl() {
    $local_cert = __DIR__."/ssl-echo-server/cert.pem";
    $local_pk   = __DIR__."/ssl-echo-server/privkey.pem";

    $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
        EventSslContext::OPT_LOCAL_CERT  => $local_cert,
        EventSslContext::OPT_LOCAL_PK    => $local_pk,
        //EventSslContext::OPT_PASSPHRASE  => "test",
        EventSslContext::OPT_ALLOW_SELF_SIGNED => true,
    ));

    return $ctx;
}

$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}
$ip = '0.0.0.0';

$base = new EventBase();
$ctx  = _init_ssl();
$http = new EventHttp($base, $ctx);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setCallback("/err400", "_http_400");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind($ip, $port);
$base->dispatch();

Ejemplo #10 OpenSSL connection

<?php
/*
 * Sample OpenSSL client.
 *
 * Usage:
 * 1) Launch a server, e.g.:
 * $ php examples/https.php 9999
 *
 * 2) Launch the client in another terminal:
 * $ php examples/ssl-connection.php 9999
 */

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

function _init_ssl() {
    $ctx = new EventSslContext(EventSslContext::SSLv3_CLIENT_METHOD, array ());

    return $ctx;
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}
$host = '127.0.0.1';

$ctx = _init_ssl();
if (!$ctx) {
    trigger_error("Failed creating SSL context", E_USER_ERROR);
}

$base = new EventBase();
if (!$base) {
    trigger_error("Failed to initialize event base", E_USER_ERROR);
}

$conn = new EventHttpConnection($base, NULL, $host, $port, $ctx);
$conn->setTimeout(50);

$req = new EventHttpRequest("_request_handler", $base);
$req->addHeader("Host", $host, EventHttpRequest::OUTPUT_HEADER);
$buf = $req->getOutputBuffer();
$buf->add("<html>HTML TEST</html>");
//$req->addHeader("Content-Length", $buf->length, EventHttpRequest::OUTPUT_HEADER);
//$req->addHeader("Connection", "close", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_POST, "/dump");

$base->dispatch();
echo "END\n";
?>

Ejemplo #11 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

El resultado del ejemplo sería algo similar a:

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

Ejemplo #12 Connection listener based on a UNIX domain socket

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php unix-domain-listener.php [path-to-socket]
 *
 * 2) In another terminal window open up connection
 * to the socket, e.g.:
 *
 * $ socat - GOPEN:/tmp/1.sock
 *
 * 3) Start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        if ($this->bev) {
            $this->bev->free();
        }
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer
        $bev->output->addBuffer($bev->input);
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($sock_path) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        if (file_exists($sock_path)) {
            unlink($sock_path);
        }

         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "unix:$sock_path");

        if (!$this->listener) {
            trigger_error("Couldn't create listener", E_USER_ERROR);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$l = new MyListener($sock_path);
$l->dispatch();
?>

Ejemplo #13 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();


Event flags

Event::READ This flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for reading.

Event::WRITE flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for writing.

Event::SIGNAL used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT indicates an event that becomes active after a timeout elapses. The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

See also » Fast portable non-blocking network programming with Libevent, Working with events, Event flags


About event persistence

By default, whenever a pending event becomes active (because its file descriptor is ready to read or write, or because its timeout expires), it becomes non-pending right before its callback is executed. Thus, to make the event pending again one may call Event::add() on it again from inside the callback function.

If the Event::PERSIST flag is set on an event, however, the event is persistent . This means that event remains pending even when its callback is activated. Event::del() method can be called to make it non-pending.

The timeout on a persistent event resets whenever the event's callback runs. Thus, if one has an event with flags Event::READ | Event::PERSIST and a timeout of five seconds, the event will become active:

  1. Whenever the socket or file descriptor is ready for reading.

  2. Whenever five seconds have passed since the event last became active.

See also » Fast portable non-blocking network programming with Libevent, About Event Persistence


Event callbacks

If a callback is registered for an event, it will be called when the event becomes active. To associate a callback with event one can pass a callable to either Event::__construct() , or Event::set() , or one of the factory methods like Event::timer() .

An event callback should match the following prototype:

callback ( mixed $fd = null , int $what = ? , mixed $arg = null ) : void

fd

The file descriptor, stream resource or socket associated with the event. For signal event fd is equal to the signal number.

what

Bit mask of all events triggered.

arg

User custom data.

Event::timer() expects the callback to match the following prototype:

callback ( mixed $arg = null ) : void

arg

User custom data.

Event::signal() expects the callback to match the following prototype:

callback ( int $signum = ? , mixed $arg = null ) : void

signum

The number of the triggered signal(e.g. SIGTERM ).

arg

User custom data.


Constructing signal events

Event can also watch for POSIX-style signals. To construct a handler for a signal, use Event::__construct() constructor with Event::SIGNAL flag, or Event::signal() factory method.

Ejemplo #1 Handling SIGTERM signal

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->add();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

Note that signal callbacks are run in the event loop after the signal occurs, so it is safe for them to call functions that you are not supposed to call from a regular POSIX signal handler.

See also » Fast portable non-blocking network programming with Libevent, Constructing Signal Events .


The Event class

(PECL event >= 1.2.6-beta)

Introducción

Event class represents and event firing on a file descriptor being ready to read from or write to; a file descriptor becoming ready to read from or write to(edge-triggered I/O only); a timeout expiring; a signal occuring; a user-triggered event.

Every event is associated with EventBase . However, event will never fire until it is added (via Event::add() ). An added event remains in pending state until the registered event occurs, thus turning it to active state. To handle events user may register a callback which is called when event becomes active. If event is configured persistent , it remains pending. If it is not persistent, it stops being pending when it's callback runs. Event::del() method deletes event, thus making it non-pending. By means of Event::add() method it could be added again.

Sinopsis de la Clase

final Event {
/* Constants */
const int ET = 32 ;
const int PERSIST = 16 ;
const int READ = 2 ;
const int WRITE = 4 ;
const int SIGNAL = 8 ;
const int TIMEOUT = 1 ;
/* Propiedades */
public readonly bool $pending ;
/* Métodos */
public add ( float $timeout = ? ) : bool
public addSignal ( float $timeout = ? ) : bool
public addTimer ( float $timeout = ? ) : bool
public __construct ( EventBase $base , mixed $fd , int $what , callable $cb , mixed $arg = NULL )
public del ( ) : bool
public delSignal ( ) : bool
public delTimer ( ) : bool
public free ( ) : void
public static getSupportedMethods ( ) : array
public pending ( int $flags ) : bool
public set ( EventBase $base , mixed $fd , int $what = ? , callable $cb = ? , mixed $arg = ? ) : bool
public setPriority ( int $priority ) : bool
public setTimer ( EventBase $base , callable $cb , mixed $arg = ? ) : bool
public static signal ( EventBase $base , int $signum , callable $cb , mixed $arg = ? ) : Event
public static timer ( EventBase $base , callable $cb , mixed $arg = ? ) : Event
}

Propiedades

pending

Whether event is pending. See About event persistence .

Constantes predefinidas

Event::ET

Indicates that the event should be edge-triggered, if the underlying event base backend supports edge-triggered events. This affects the semantics of Event::READ and Event::WRITE .

Event::PERSIST

Indicates that the event is persistent. See About event persistence .

Event::READ

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::WRITE

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::SIGNAL

Used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT

This flag indicates an event that becomes active after a timeout elapses.

The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

Tabla de contenidos

  • Event::add — Makes event pending
  • Event::addSignal — Makes signal event pending
  • Event::addTimer — Makes timer event pending
  • Event::__construct — Constructs Event object
  • Event::del — Makes event non-pending
  • Event::delSignal — Makes signal event non-pending
  • Event::delTimer — Makes timer event non-pending
  • Event::free — Make event non-pending and free resources allocated for this event
  • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
  • Event::pending — Detects whether event is pending or scheduled
  • Event::set — Re-configures event
  • Event::setPriority — Set event priority
  • Event::setTimer — Re-configures timer event
  • Event::signal — Constructs signal event object
  • Event::timer — Constructs timer event object


Makes event pending

  • « Event
  • Event::addSignal »
  • PHP Manual
  • Event
  • Makes event pending

Event::add

(PECL event >= 1.2.6-beta)

Event::add — Makes event pending

Descripción

public Event::add ( float $timeout = ? ) : bool

Marks event pending. Non-pending event will never occur, and the event callback will never be called. In conjuction with Event::del() an event could be re-scheduled by user at any time.

If Event::add() is called on an already pending event, libevent will leave it pending and re-schedule it with the given timeout(if specified). If in this case timeout is not specified, Event::add() has no effect.

Parámetros

timeout

Timeout in seconds.

Valores devueltos

Returns true on success. Otherwise false

Ver también

  • Event::addSignal() - Makes signal event pending
  • Event::addTimer() - Makes timer event pending
  • Event::del() - Makes event non-pending


Makes signal event pending

  • « Event::add
  • Event::addTimer »
  • PHP Manual
  • Event
  • Makes signal event pending

Event::addSignal

(PECL event >= 1.2.6-beta)

Event::addSignal — Makes signal event pending

Descripción

public Event::addSignal ( float $timeout = ? ) : bool

Event::addSignal() is an alias of Event::add()

Ejemplos

Ejemplo #1 Event::addSignal() example

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->addSignal();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

El resultado del ejemplo sería algo similar a:

Caught signal 15

Ver también

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delSignal() - Makes signal event non-pending
  • Event::signal() - Constructs signal event object


Makes timer event pending

  • « Event::addSignal
  • Event::__construct »
  • PHP Manual
  • Event
  • Makes timer event pending

Event::addTimer

(PECL event >= 1.2.6-beta)

Event::addTimer — Makes timer event pending

Descripción

public Event::addTimer ( float $timeout = ? ) : bool

Event::addTimer() is an alias of Event::add()

Valores devueltos

Ejemplos

Ejemplo #1 Event::addTimer() example

<?php
$base = new EventBase();
$n = 2;
$e = Event::timer($base, function($n) use (&$e) {
    echo "$n seconds elapsed\n";
    $e->delTimer();
}, $n);
$e->addTimer($n);
$base->loop();
?>

El resultado del ejemplo sería algo similar a:

2 seconds elapsed

Ver también

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delTimer() - Makes timer event non-pending


Constructs Event object

  • « Event::addTimer
  • Event::del »
  • PHP Manual
  • Event
  • Constructs Event object

Event::__construct

(PECL event >= 1.2.6-beta)

Event::__construct — Constructs Event object

Descripción

public Event::__construct ( EventBase $base , mixed $fd , int $what , callable $cb , mixed $arg = NULL )

Constructs Event object.

Parámetros

base

The event base to associate with.

fd

stream resource, socket resource, or numeric file descriptor. For timer events pass -1 . For signal events pass the signal number, e.g. SIGHUP .

what

Event flags. See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Valores devueltos

Returns Event object.

Ver también

  • Event::signal() - Constructs signal event object
  • Event::timer() - Constructs timer event object


Makes event non-pending

  • « Event::__construct
  • Event::delSignal »
  • PHP Manual
  • Event
  • Makes event non-pending

Event::del

(PECL event >= 1.2.6-beta)

Event::del — Makes event non-pending

Descripción

public Event::del ( ) : bool

Removes an event from the set of monitored events, i.e. makes it non-pending.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true on success. Otherwise false

Ver también

  • Event::add() - Makes event pending


Makes signal event non-pending

  • « Event::del
  • Event::delTimer »
  • PHP Manual
  • Event
  • Makes signal event non-pending

Event::delSignal

(PECL event >= 1.2.6-beta)

Event::delSignal — Makes signal event non-pending

Descripción

public Event::delSignal ( ) : bool

Event::delSignal() is an alias of Event::del()

Ver también

  • Event::del() - Makes event non-pending


Makes timer event non-pending

  • « Event::delSignal
  • Event::free »
  • PHP Manual
  • Event
  • Makes timer event non-pending

Event::delTimer

(PECL event >= 1.2.6-beta)

Event::delTimer — Makes timer event non-pending

Descripción

public Event::delTimer ( ) : bool

Event::delTimer() is an alias of Event::del() .

Ver también

  • Event::del() - Makes event non-pending


Make event non-pending and free resources allocated for this event

  • « Event::delTimer
  • Event::getSupportedMethods »
  • PHP Manual
  • Event
  • Make event non-pending and free resources allocated for this event

Event::free

(PECL event >= 1.2.6-beta)

Event::free — Make event non-pending and free resources allocated for this event

Descripción

public Event::free ( ) : void

Removes event from the list of events monitored by libevent, and free resources allocated for the event.

Advertencia

The Event::free() method currently doesn't destruct the object itself. To destruct the object completely call unset() , or assign null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • Event::__construct() - Constructs Event object


Returns array with of the names of the methods supported in this version of Libevent

  • « Event::free
  • Event::pending »
  • PHP Manual
  • Event
  • Returns array with of the names of the methods supported in this version of Libevent

Event::getSupportedMethods

(PECL event >= 1.2.6-beta)

Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent

Descripción

public static Event::getSupportedMethods ( ) : array

Returns array with of the names of the methods(backends) supported in this version of Libevent.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns array.

Ver también

  • EventConfig


Detects whether event is pending or scheduled

  • « Event::getSupportedMethods
  • Event::set »
  • PHP Manual
  • Event
  • Detects whether event is pending or scheduled

Event::pending

(PECL event >= 1.2.6-beta)

Event::pending — Detects whether event is pending or scheduled

Descripción

public Event::pending ( int $flags ) : bool

Detects whether event is pending or scheduled

Parámetros

flags

One of, or a composition of the following constants: Event::READ , Event::WRITE , Event::TIMEOUT , Event::SIGNAL .

Valores devueltos

Returns true if event is pending or scheduled. Otherwise false.


Re-configures event

  • « Event::pending
  • Event::setPriority »
  • PHP Manual
  • Event
  • Re-configures event

Event::set

(PECL event >= 1.2.6-beta)

Event::set — Re-configures event

Descripción

public Event::set ( EventBase $base , mixed $fd , int $what = ? , callable $cb = ? , mixed $arg = ? ) : bool

Re-configures event. Note, this function doesn't invoke obsolete libevent's event_set. It calls event_assign instead.

Parámetros

base

The event base to associate the event with.

fd

Stream resource, socket resource, or numeric file descriptor. For timer events pass -1 . For signal events pass the signal number, e.g. SIGHUP .

what

See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data associated with the event. It will be passed to the callback when the event becomes active.

Valores devueltos

Returns true on success. Otherwise false.


Set event priority

  • « Event::set
  • Event::setTimer »
  • PHP Manual
  • Event
  • Set event priority

Event::setPriority

(PECL event >= 1.2.6-beta)

Event::setPriority — Set event priority

Descripción

public Event::setPriority ( int $priority ) : bool

Set event priority.

Parámetros

priority

The event priority.

Valores devueltos

Returns true on success. Otherwise false.


Re-configures timer event

  • « Event::setPriority
  • Event::signal »
  • PHP Manual
  • Event
  • Re-configures timer event

Event::setTimer

(PECL event >= 1.2.6-beta)

Event::setTimer — Re-configures timer event

Descripción

public Event::setTimer ( EventBase $base , callable $cb , mixed $arg = ? ) : bool

Re-configures timer event. Note, this function doesn't invoke obsolete libevent's event_set . It calls event_assign instead.

Parámetros

base

The event base to associate with.

cb

The timer event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • Event::__construct() - Constructs Event object
  • Event::timer() - Constructs timer event object


Constructs signal event object

  • « Event::setTimer
  • Event::timer »
  • PHP Manual
  • Event
  • Constructs signal event object

Event::signal

(PECL event >= 1.2.6-beta)

Event::signal — Constructs signal event object

Descripción

public static Event::signal ( EventBase $base , int $signum , callable $cb , mixed $arg = ? ) : Event

Constructs signal event object. This is a straightforward method to create a signal event. Note, the generic Event::__construct() method can contruct signal event objects too.

Parámetros

base

The associated event base object.

signum

The signal number.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Valores devueltos

Returns Event object on success. Otherwise false.

Ver también

  • Constructing signal events


Constructs timer event object

  • « Event::signal
  • EventBase »
  • PHP Manual
  • Event
  • Constructs timer event object

Event::timer

(PECL event >= 1.2.6-beta)

Event::timer — Constructs timer event object

Descripción

public static Event::timer ( EventBase $base , callable $cb , mixed $arg = ? ) : Event

Constructs timer event object. This is a straightforward method to create a timer event. Note, the generic Event::__construct() method can contruct signal event objects too.

Parámetros

base

The associated event base object.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Valores devueltos

Returns Event object on success. Otherwise false.


The EventBase class

(PECL event >= 1.2.6-beta)

Introducción

EventBase class represents libevent's event base structure. It holds a set of events and can poll to determine which events are active.

Each event base has a method , or a backend that it uses to determine which events are ready. The recognized methods are: select , poll , epoll , kqueue , devpoll , evport and win32 .

To configure event base to use, or avoid specific backend EventConfig class can be used.

Advertencia

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Sinopsis de la Clase

final EventBase {
/* Constants */
const int LOOP_ONCE = 1 ;
const int LOOP_NONBLOCK = 2 ;
const int NOLOCK = 1 ;
const int STARTUP_IOCP = 4 ;
const int NO_CACHE_TIME = 8 ;
const int EPOLL_USE_CHANGELIST = 16 ;
/* Métodos */
public __construct ( EventConfig $cfg = ? )
public dispatch ( ) : void
public exit ( double $timeout = ? ) : bool
public free ( ) : void
public getFeatures ( ) : int
public getMethod ( EventConfig $cfg = ? ) : string
public getTimeOfDayCached ( ) : double
public gotExit ( ) : bool
public gotStop ( ) : bool
public loop ( int $flags = ? ) : bool
public priorityInit ( int $n_priorities ) : bool
public reInit ( ) : bool
public stop ( ) : bool
}

Constantes predefinidas

EventBase::LOOP_ONCE

Flag used with EventBase::loop() method which means: "block until libevent has an active event, then exit once all active events have had their callbacks run".

EventBase::LOOP_NONBLOCK

Flag used with EventBase::loop() method which means: "do not block: see which events are ready now, run the callbacks of the highest-priority ones, then exit".

EventBase::NOLOCK

Configuration flag. Do not allocate a lock for the event base, even if we have locking set up".

EventBase::STARTUP_IOCP

Windows-only configuration flag. Enables the IOCP dispatcher at startup.

EventBase::NO_CACHE_TIME

Configuration flag. Instead of checking the current time every time the event loop is ready to run timeout callbacks, check after each timeout callback.

EventBase::EPOLL_USE_CHANGELIST

If we are using the epoll backend, this flag says that it is safe to use Libevent's internal change-list code to batch up adds and deletes in order to try to do as few syscalls as possible.

Setting this flag can make code run faster, but it may trigger a Linux bug: it is not safe to use this flag if one has any fds cloned by dup(), or its variants. Doing so will produce strange and hard-to-diagnose bugs.

This flag can also be activated by settnig the EVENT_EPOLL_USE_CHANGELIST environment variable.

This flag has no effect if one winds up using a backend other than epoll .

Tabla de contenidos

  • EventBase::__construct — Construye un objeto EventBase
  • EventBase::dispatch — Despacha eventos pendientes
  • EventBase::exit — Detiene el envío de los eventos
  • EventBase::free — Free resources allocated for this event base
  • EventBase::getFeatures — Devuelve una máscara de bits de funcionalidades soportadas
  • EventBase::getMethod — Devuelve el método de evento utilizado
  • EventBase::getTimeOfDayCached — Devuelve el tiempo del evento base actual
  • EventBase::gotExit — Verifica si se ha indicado al bucle del evento de salir
  • EventBase::gotStop — Verifica si se ha indicado al bucle del evento de salir
  • EventBase::loop — Despacha eventos pendientes
  • EventBase::priorityInit — Define el número de prioridades por evento base
  • EventBase::reInit — Reinicializa el evento base (después de un 'fork')
  • EventBase::stop — Solicita a event_base que detenga la emisión de eventos


Construye un objeto EventBase

  • « EventBase
  • EventBase::dispatch »
  • PHP Manual
  • EventBase
  • Construye un objeto EventBase

EventBase::__construct

(PECL event >= 1.2.6-beta)

EventBase::__construct — Construye un objeto EventBase

Descripción

public EventBase::__construct ( EventConfig $cfg = ? )

Construye un objeto EventBase

Parámetros

cfg

Opcional Un objeto EventConfig .

Valores devueltos

Devuelve un objeto EventBase.

Ver también

  • EventConfig


Despacha eventos pendientes

  • « EventBase::__construct
  • EventBase::exit »
  • PHP Manual
  • EventBase
  • Despacha eventos pendientes

EventBase::dispatch

(PECL event >= 1.2.6-beta)

EventBase::dispatch — Despacha eventos pendientes

Descripción

public EventBase::dispatch ( ) : void

Espara a que los eventos estén activos y ejecuta sus llamadas de retorno. Hace lo mismo que EventBase::loop() pero sin flags definidas.

Advertencia

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito. false de lo contrario.

Ver también

  • EventBase::loop() - Despacha eventos pendientes


Detiene el envío de los eventos

  • « EventBase::dispatch
  • EventBase::free »
  • PHP Manual
  • EventBase
  • Detiene el envío de los eventos

EventBase::exit

(PECL event >= 1.2.6-beta)

EventBase::exit — Detiene el envío de los eventos

Descripción

public EventBase::exit ( double $timeout = ? ) : bool

Le indica al evento base que pare el envío de los eventos, opcionamente después de un número de segundos dado.

Parámetros

timeout

Número opcional de segundos después de los cuales el evento base deberá parar el envío de eventos.

Valores devueltos

Devuelve true en caso de éxito. Devuelve false en el resto de casos.

Ver también

  • EventBase::stop() - Solicita a event_base que detenga la emisión de eventos


Free resources allocated for this event base

  • « EventBase::exit
  • EventBase::getFeatures »
  • PHP Manual
  • EventBase
  • Free resources allocated for this event base

EventBase::free

(PECL event >= 1.10.0)

EventBase::free — Free resources allocated for this event base

Descripción

public EventBase::free ( ) : void

Deallocates resources allocated by libevent for the EventBase object.

Advertencia

The EventBase::free() method doesn't destruct the object itself. To destruct the object completely call unset() , or assign null.

This method does not deallocate or detach any of the events that are currently associated with the EventBase object, or close any of their sockets - beware.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventBase::__construct() - Construye un objeto EventBase


Devuelve una máscara de bits de funcionalidades soportadas

  • « EventBase::free
  • EventBase::getMethod »
  • PHP Manual
  • EventBase
  • Devuelve una máscara de bits de funcionalidades soportadas

EventBase::getFeatures

(PECL event >= 1.2.6-beta)

EventBase::getFeatures — Devuelve una máscara de bits de funcionalidades soportadas

Descripción

public EventBase::getFeatures ( ) : int

Devuelve una máscara de bits de funcionalidades soportadas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero que representa una máscara de bits de funcionalidades soportadas. Ver las constantes EventConfig::FEATURE_* .

Ejemplos

Ejemplo #1 Ejemplo con EventBase::getFeatures()

<?php
// Evitando el método "select"
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "Método `select' evitado\n";
}

$base = new EventBase($cfg);

echo "Funcionalidades:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");
?>

Ver también

  • EventBase::getMethod() - Devuelve el método de evento utilizado
  • EventConfig


Devuelve el método de evento utilizado

  • « EventBase::getFeatures
  • EventBase::getTimeOfDayCached »
  • PHP Manual
  • EventBase
  • Devuelve el método de evento utilizado

EventBase::getMethod

(PECL event >= 1.2.6-beta)

EventBase::getMethod — Devuelve el método de evento utilizado

Descripción

public EventBase::getMethod ( EventConfig $cfg = ? ) : string

Parámetros

cfg

Objeto EventConfig opcional.

Valores devueltos

String que representa el método de evento utilizado (backend).

Ejemplos

Ejemplo #1 Ejemplo con EventBase::getMethod()

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "Método `select' evitado\n";
}

// Crear un evento base asociado con el config
$base = new EventBase($cfg);
echo "Método de evento utilizado: ", $base->getMethod(), PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

método `select' evitado
Método de evento utilizado: epoll

Ver también

  • EventBase::getFeatures() - Devuelve una máscara de bits de funcionalidades soportadas


Devuelve el tiempo del evento base actual

  • « EventBase::getMethod
  • EventBase::gotExit »
  • PHP Manual
  • EventBase
  • Devuelve el tiempo del evento base actual

EventBase::getTimeOfDayCached

(PECL event >= 1.2.6-beta)

EventBase::getTimeOfDayCached — Devuelve el tiempo del evento base actual

Descripción

public EventBase::getTimeOfDayCached ( ) : double

En caso de éxito devuelve el tiempo actual(como el devuelto por gettimeofday() ), mirando el valor en la caché dentro de base si es posible, y llamando a gettimeofday() o clock_gettime() si no hay tiempo disponible en la caché.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el actual tiempo de event base . En caso de error devuelve null.


Verifica si se ha indicado al bucle del evento de salir

  • « EventBase::getTimeOfDayCached
  • EventBase::gotStop »
  • PHP Manual
  • EventBase
  • Verifica si se ha indicado al bucle del evento de salir

EventBase::gotExit

(PECL event >= 1.2.6-beta)

EventBase::gotExit — Verifica si se ha indicado al bucle del evento de salir

Descripción

public EventBase::gotExit ( ) : bool

Verifica si se ha indicado al bucle del evento de salir con el método EventBase::exit() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se ha indicado al bucle de salir con el método EventBase::exit() . false en caso contrario.

Ver también

  • EventBase::exit() - Detiene el envío de los eventos
  • EventBase::stop() - Solicita a event_base que detenga la emisión de eventos
  • EventBase::gotStop() - Verifica si se ha indicado al bucle del evento de salir


Verifica si se ha indicado al bucle del evento de salir

  • « EventBase::gotExit
  • EventBase::loop »
  • PHP Manual
  • EventBase
  • Verifica si se ha indicado al bucle del evento de salir

EventBase::gotStop

(PECL event >= 1.2.6-beta)

EventBase::gotStop — Verifica si se ha indicado al bucle del evento de salir

Descripción

public EventBase::gotStop ( ) : bool

Verifica si se ha indicado al bucle del evento de salir con EventBase::stop() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se indicó al bucle del evento de salir con EventBase::stop() . false en caso contrario .

Ver también

  • EventBase::exit() - Detiene el envío de los eventos
  • EventBase::stop() - Solicita a event_base que detenga la emisión de eventos
  • EventBase::gotExit() - Verifica si se ha indicado al bucle del evento de salir


Despacha eventos pendientes

  • « EventBase::gotStop
  • EventBase::priorityInit »
  • PHP Manual
  • EventBase
  • Despacha eventos pendientes

EventBase::loop

(PECL event >= 1.2.6-beta)

EventBase::loop — Despacha eventos pendientes

Descripción

public EventBase::loop ( int $flags = ? ) : bool

Espara a que los eventos estén activos y ejecuta sus llamadas de retorno.

Advertencia

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Parámetros

flags

Flags opcionales. Puede ser una de las constantes EventBase::LOOP_*. Véase constantes EventBase .

Valores devueltos

Devuelve true en caso de éxito. false de lo contrario.

Ver también

  • EventBase::dispatch() - Despacha eventos pendientes


Define el número de prioridades por evento base

  • « EventBase::loop
  • EventBase::reInit »
  • PHP Manual
  • EventBase
  • Define el número de prioridades por evento base

EventBase::priorityInit

(PECL event >= 1.2.6-beta)

EventBase::priorityInit — Define el número de prioridades por evento base

Descripción

public EventBase::priorityInit ( int $n_priorities ) : bool

Define el número de prioridades por evento base.

Parámetros

n_priorities

El número de prioridades por evento base.

Valores devueltos

Devuelve true en caso de éxito, false en cualquier otro caso.

Ver también

  • Event::setPriority() - Set event priority


Reinicializa el evento base (después de un 'fork')

  • « EventBase::priorityInit
  • EventBase::stop »
  • PHP Manual
  • EventBase
  • Reinicializa el evento base (después de un 'fork')

EventBase::reInit

(PECL event >= 1.2.6-beta)

EventBase::reInit — Reinicializa el evento base (después de un 'fork')

Descripción

public EventBase::reInit ( ) : bool

Reinicializa el evento base. Debe ser llamado después de un 'fork'.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito. false en cualquier otro caso.


Solicita a event_base que detenga la emisión de eventos

  • « EventBase::reInit
  • EventBuffer »
  • PHP Manual
  • EventBase
  • Solicita a event_base que detenga la emisión de eventos

EventBase::stop

(PECL event >= 1.2.6-beta)

EventBase::stop — Solicita a event_base que detenga la emisión de eventos

Descripción

public EventBase::stop ( ) : bool

Solicita a event_base que detenga la emisión de eventos

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito. false en cualquier otro caso.

Ver también

  • EventBase::exit() - Detiene el envío de los eventos
  • EventBase::gotStop() - Verifica si se ha indicado al bucle del evento de salir


The EventBuffer class

(PECL event >= 1.5.0)

Introducción

EventBuffer represents Libevent's "evbuffer", an utility functionality for buffered I/O.

Event buffers are meant to be generally useful for doing the "buffer" part of buffered network I/O.

Sinopsis de la Clase

EventBuffer {
/* Constants */
const int EOL_ANY = 0 ;
const int EOL_CRLF = 1 ;
const int EOL_CRLF_STRICT = 2 ;
const int EOL_LF = 3 ;
const int PTR_SET = 0 ;
const int PTR_ADD = 1 ;
/* Propiedades */
public readonly int $length ;
public readonly int $contiguous_space ;
/* Métodos */
public add ( string $data ) : bool
public addBuffer ( EventBuffer $buf ) : bool
public appendFrom ( EventBuffer $buf , int $len ) : int
public __construct ( )
public copyout ( string &$data , int $max_bytes ) : int
public drain ( int $len ) : bool
public enableLocking ( ) : void
public expand ( int $len ) : bool
public freeze ( bool $at_front ) : bool
public lock ( ) : void
public prepend ( string $data ) : bool
public prependBuffer ( EventBuffer $buf ) : bool
public pullup ( int $size ) : string
public read ( int $max_bytes ) : string
public read ( mixed $fd , int $howmuch ) : int
public readLine ( int $eol_style ) : string
public search ( string $what , int $start = -1 , int $end = -1 ) : mixed
public searchEol ( int $start = -1 , int $eol_style = EventBuffer::EOL_ANY ) : mixed
public substr ( int $start , int $length = ? ) : string
public unfreeze ( bool $at_front ) : bool
public unlock ( ) : bool
public write ( mixed $fd , int $howmuch = ? ) : int
}

Propiedades

length

The number of bytes stored in an event buffer.

contiguous_space

The number of bytes stored contiguously at the front of the buffer. The bytes in a buffer may be stored in multiple separate chunks of memory; the property returns the number of bytes currently stored in the first chunk.

Constantes predefinidas

EventBuffer::EOL_ANY

The end of line is any sequence of any number of carriage return and linefeed characters. This format is not very useful; it exists mainly for backward compatibility.

EventBuffer::EOL_CRLF

The end of the line is an optional carriage return, followed by a linefeed. (In other words, it is either a "\r\n" or a "\n" .) This format is useful in parsing text-based Internet protocols, since the standards generally prescribe a "\r\n" line-terminator, but nonconformant clients sometimes say just "\n" .

EventBuffer::EOL_CRLF_STRICT

The end of a line is a single carriage return, followed by a single linefeed. (This is also known as "\r\n" . The ASCII values are 0x0D 0x0A ).

EventBuffer::EOL_LF

The end of a line is a single linefeed character. (This is also known as "\n" . It is ASCII value is 0x0A .)

EventBuffer::PTR_SET

Flag used as argument of EventBuffer::setPosition() method. If this flag specified, the position pointer is moved to an absolute position within the buffer.

EventBuffer::PTR_ADD

The same as EventBuffer::PTR_SET , except this flag causes EventBuffer::setPosition() method to move position forward up to the specified number of bytes(instead of setting absolute position).

Tabla de contenidos

  • EventBuffer::add — Añade datos al final de un buffer de eventos
  • EventBuffer::addBuffer — Mueve todos los datos de un buffer a la instancia actual de EventBuffer
  • EventBuffer::appendFrom — Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual
  • EventBuffer::__construct — Construye el objeto EventBuffer
  • EventBuffer::copyout — Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain — Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::enableLocking — Descripción
  • EventBuffer::expand — Reserva espacio en el buffer
  • EventBuffer::freeze — Evita que las llamadas puedan modificar un buffer de eventos
  • EventBuffer::lock — Bloquea un buffer
  • EventBuffer::prepend — Prepend data to the front of the buffer
  • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
  • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read — Read data from an evbuffer and drain the bytes read
  • EventBuffer::readFrom — Read data from a file onto the end of the buffer
  • EventBuffer::readLine — Extracts a line from the front of the buffer
  • EventBuffer::search — Scans the buffer for an occurrence of a string
  • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
  • EventBuffer::substr — Substracts a portion of the buffer data
  • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
  • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
  • EventBuffer::write — Write contents of the buffer to a file or socket


Añade datos al final de un buffer de eventos

  • « EventBuffer
  • EventBuffer::addBuffer »
  • PHP Manual
  • EventBuffer
  • Añade datos al final de un buffer de eventos

EventBuffer::add

(PECL event >= 1.2.6-beta)

EventBuffer::add — Añade datos al final de un buffer de eventos

Descripción

public EventBuffer::add ( string $data ) : bool

Añade datos al final de un buffer de eventos.

Parámetros

data

String que se añadirá al final del buffer.

Valores devueltos

Devuelve true en caso de éxito. De otro modo, devuelve false.

Ver también

  • EventBuffer::addBuffer() - Mueve todos los datos de un buffer a la instancia actual de EventBuffer


Mueve todos los datos de un buffer a la instancia actual de EventBuffer

  • « EventBuffer::add
  • EventBuffer::appendFrom »
  • PHP Manual
  • EventBuffer
  • Mueve todos los datos de un buffer a la instancia actual de EventBuffer

EventBuffer::addBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::addBuffer — Mueve todos los datos de un buffer a la instancia actual de EventBuffer

Descripción

public EventBuffer::addBuffer ( EventBuffer $buf ) : bool

Mueve todos los datos del buffer indicado en el parámetro buf al final del actual EventBuffer . Es un movimiento de datos destructivo. Los datos de un buffer se mueven al otro buffer. Sin embargo, no se realizan copias innecesarias.

Parámetros

buf

El objeto EventBuffer.

Valores devueltos

Devuelve true en caso de éxito. De otro modo, devuelve false.

Ver también

  • EventBuffer::add() - Añade datos al final de un buffer de eventos


Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual

  • « EventBuffer::addBuffer
  • EventBuffer::__construct »
  • PHP Manual
  • EventBuffer
  • Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual

EventBuffer::appendFrom

(PECL event >= 1.6.0)

EventBuffer::appendFrom — Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual

Descripción

public EventBuffer::appendFrom ( EventBuffer $buf , int $len ) : int

Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual. Si hay menos bytes, mueve todos los bytes disponibles del buffer fuente.

Parámetros

buf

Buffer fuente.

len

Valores devueltos

Devuelve el número de bytes leídos.

Historial de cambios

Versión | Descripción
1.6.0 | Renombrado de EventBuffer::appendFrom()(nombre antiguo del método) a EventBuffer::appendFrom().

Ver también

  • EventBuffer::copyout() - Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain() - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


Construye el objeto EventBuffer

  • « EventBuffer::appendFrom
  • EventBuffer::copyout »
  • PHP Manual
  • EventBuffer
  • Construye el objeto EventBuffer

EventBuffer::__construct

(PECL event >= 1.2.6-beta)

EventBuffer::__construct — Construye el objeto EventBuffer

Descripción

public EventBuffer::__construct ( )

Construye el objeto EventBuffer

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el objeto EventBuffer.


Copia un número específico de bytes del principio del buffer

  • « EventBuffer::__construct
  • EventBuffer::drain »
  • PHP Manual
  • EventBuffer
  • Copia un número específico de bytes del principio del buffer

EventBuffer::copyout

(PECL event >= 1.2.6-beta)

EventBuffer::copyout — Copia un número específico de bytes del principio del buffer

Descripción

public EventBuffer::copyout ( string &$data , int $max_bytes ) : int

Funciona del mismo modo que EventBuffer::read() , pero no vacía ningún dato del buffer. p.ej. copia los primeros max_bytes bytes del principio del buffer en data . Si hay menos de max_bytes bytes disponibles, la función copia todos los bytes que haya.

Parámetros

data

String de salida.

max_bytes

El número de bytes a copiar.

Valores devueltos

Devuelve el número de bytes copiados, o -1 en caso de error.

Ver también

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar

  • « EventBuffer::copyout
  • EventBuffer::enableLocking »
  • PHP Manual
  • EventBuffer
  • Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar

EventBuffer::drain

(PECL event >= 1.2.6-beta)

EventBuffer::drain — Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar

Descripción

public EventBuffer::drain ( int $len ) : bool

Funciona del mismo modo que EventBuffer::read() , excepto que no copia los datos: únicamente los elimina del principio del buffer.

Parámetros

len

El número de bytes a eliminar del buffer.

Valores devueltos

Devuelve true en caso de éxito. Devuelve false en el resto de casos.

Ver también

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Descripción

  • « EventBuffer::drain
  • EventBuffer::expand »
  • PHP Manual
  • EventBuffer
  • Descripción

EventBuffer::enableLocking

(PECL event >= 1.2.6-beta)

EventBuffer::enableLocking —

Descripción

public EventBuffer::enableLocking ( ) : void

Activa el bloqueo de EventBuffer de tal forma que puede utilizarse de forma segura por múltiples líneas de ejecución a la vez. Cuando se activa el bloqueo, éste se mantiene cuando se invoquen las llamadas de vuelta. Esto puede dar lugar a un punto muerto (o 'deadlock') si no se es cuidadoso. Planificar de forma adecuada!

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • » Evbuffers and Thread-safety


Reserva espacio en el buffer

  • « EventBuffer::enableLocking
  • EventBuffer::freeze »
  • PHP Manual
  • EventBuffer
  • Reserva espacio en el buffer

EventBuffer::expand

(PECL event >= 1.2.6-beta)

EventBuffer::expand — Reserva espacio en el buffer

Descripción

public EventBuffer::expand ( int $len ) : bool

Modifica el último bloque de memoria del buffer, o añade un nuevo bloque, de modo que el buffer es ahora suficientemente grande para contener len bytes sin añadir espacios suplementarios.

Parámetros

len

El número de bytes a reservar del buffer

Valores devueltos

Devuelve true en caso de éxito. Devuelve false en el resto de casos.


Evita que las llamadas puedan modificar un buffer de eventos

  • « EventBuffer::expand
  • EventBuffer::lock »
  • PHP Manual
  • EventBuffer
  • Evita que las llamadas puedan modificar un buffer de eventos

EventBuffer::freeze

(PECL event >= 1.2.6-beta)

EventBuffer::freeze — Evita que las llamadas puedan modificar un buffer de eventos

Descripción

public EventBuffer::freeze ( bool $at_front ) : bool

Evita que las llamadas puedan modificar un buffer de eventos

Parámetros

at_front

Permite desactivar cambios en el principio o final del buffer.

Valores devueltos

Devuelve true en caso de éxito. Devuelve false en caso de error.

Ver también

  • EventBuffer::unfreeze() - Re-enable calls that modify an event buffer


Bloquea un buffer

  • « EventBuffer::freeze
  • EventBuffer::prepend »
  • PHP Manual
  • EventBuffer
  • Bloquea un buffer

EventBuffer::lock

(PECL event >= 1.2.6-beta)

EventBuffer::lock — Bloquea un buffer

Descripción

public EventBuffer::lock ( ) : void

Bloquea un buffer. Puede ser utilizado junto con EventBuffer::unlock() para que un conjunto de operaciones sean atómicas, p.e. thread-safe. Notar que no se necesita bloquear buffers para operaciones individuales . Cuando el bloqueo está activo (ver EventBuffer::enableLocking() ), las operaciones individuales en buffers de eventos ya son atómicas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventBuffer::unlock() - Releases lock acquired by EventBuffer::lock


Prepend data to the front of the buffer

  • « EventBuffer::lock
  • EventBuffer::prependBuffer »
  • PHP Manual
  • EventBuffer
  • Prepend data to the front of the buffer

EventBuffer::prepend

(PECL event >= 1.2.6-beta)

EventBuffer::prepend — Prepend data to the front of the buffer

Descripción

public EventBuffer::prepend ( string $data ) : bool

Prepend data to the front of the buffer.

Parámetros

data

String to be prepended to the front of the buffer.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBuffer::prependBuffer() - Moves all data from source buffer to the front of current buffer
  • EventBuffer::add() - Añade datos al final de un buffer de eventos
  • EventBuffer::addBuffer() - Mueve todos los datos de un buffer a la instancia actual de EventBuffer


Moves all data from source buffer to the front of current buffer

  • « EventBuffer::prepend
  • EventBuffer::pullup »
  • PHP Manual
  • EventBuffer
  • Moves all data from source buffer to the front of current buffer

EventBuffer::prependBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer

Descripción

public EventBuffer::prependBuffer ( EventBuffer $buf ) : bool

Behaves as EventBuffer::addBuffer() , except that it moves data to the front of the buffer.

Parámetros

buf

Source buffer.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBuffer::add() - Añade datos al final de un buffer de eventos
  • EventBuffer::addBuffer() - Mueve todos los datos de un buffer a la instancia actual de EventBuffer
  • EventBuffer::prepend() - Prepend data to the front of the buffer


Linearizes data within buffer and returns it's contents as a string

  • « EventBuffer::prependBuffer
  • EventBuffer::read »
  • PHP Manual
  • EventBuffer
  • Linearizes data within buffer and returns it's contents as a string

EventBuffer::pullup

(PECL event >= 1.2.6-beta)

EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string

Descripción

public EventBuffer::pullup ( int $size ) : string

"Linearizes" the first size bytes of the buffer, copying or moving them as needed to ensure that they are all contiguous and occupying the same chunk of memory. If size is negative, the function linearizes the entire buffer.

Advertencia

Calling EventBuffer::pullup() with a large size can be quite slow, since it potentially needs to copy the entire buffer's contents.

Parámetros

size

The number of bytes required to be contiguous within the buffer.

Valores devueltos

If size is greater than the number of bytes in the buffer, the function returns null. Otherwise, EventBuffer::pullup() returns string.

Ver también

  • EventBuffer::copyout() - Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain() - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Read data from an evbuffer and drain the bytes read

  • « EventBuffer::pullup
  • EventBuffer::readFrom »
  • PHP Manual
  • EventBuffer
  • Read data from an evbuffer and drain the bytes read

EventBuffer::read

(PECL event >= 1.6.0)

EventBuffer::read — Read data from an evbuffer and drain the bytes read

Descripción

public EventBuffer::read ( int $max_bytes ) : string

Read the first max_bytes from the buffer and drain the bytes read. If more max_bytes are requested than are available in the buffer, it only extracts as many bytes as available.

Parámetros

max_bytes

Maxmimum number of bytes to read from the buffer.

Valores devueltos

Returns string read, or false on failure.

Historial de cambios

Versión | Descripción
PECL event 1.6.0 | Renamed EventBuffer::read()(the old method name) to EventBuffer::read(). EventBuffer::read() now takes only max_bytes argument; returns string instead of integer.

Ver también

  • EventBuffer::copyout() - Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain() - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Read data from a file onto the end of the buffer

  • « EventBuffer::read
  • EventBuffer::readLine »
  • PHP Manual
  • EventBuffer
  • Read data from a file onto the end of the buffer

EventBuffer::readFrom

(PECL event >= 1.7.0)

EventBuffer::readFrom — Read data from a file onto the end of the buffer

Descripción

public EventBuffer::read ( mixed $fd , int $howmuch ) : int

Read data from the file specified by fd onto the end of the buffer.

Parámetros

fd

Socket resource, stream, or numeric file descriptor.

howmuch

Maxmimum number of bytes to read.

Valores devueltos

Returns the number of bytes read, or false on failure.

Ver también

  • EventBuffer::copyout() - Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain() - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Extracts a line from the front of the buffer

  • « EventBuffer::readFrom
  • EventBuffer::search »
  • PHP Manual
  • EventBuffer
  • Extracts a line from the front of the buffer

EventBuffer::readLine

(PECL event >= 1.2.6-beta)

EventBuffer::readLine — Extracts a line from the front of the buffer

Descripción

public EventBuffer::readLine ( int $eol_style ) : string

Extracts a line from the front of the buffer and returns it in a newly allocated string. If there is not a whole line to read, the function returns null. The line terminator is not included in the copied string.

Parámetros

eol_style

One of EventBuffer:EOL_* constants .

Valores devueltos

On success returns the line read from the buffer, otherwise null.

Ver también

  • EventBuffer::copyout() - Copia un número específico de bytes del principio del buffer
  • EventBuffer::drain() - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual


Scans the buffer for an occurrence of a string

  • « EventBuffer::readLine
  • EventBuffer::searchEol »
  • PHP Manual
  • EventBuffer
  • Scans the buffer for an occurrence of a string

EventBuffer::search

(PECL event >= 1.2.6-beta)

EventBuffer::search — Scans the buffer for an occurrence of a string

Descripción

public EventBuffer::search ( string $what , int $start = -1 , int $end = -1 ) : mixed

Scans the buffer for an occurrence of the string what . It returns numeric position of the string, or false if the string was not found.

If the start argument is provided, it points to the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

Parámetros

what

String to search.

start

Start search position.

end

End search position.

Valores devueltos

Returns numeric position of the first occurance of the string in the buffer, or false if string is not found.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 EventBuffer::search() example

<?php
// Count total occurances of 'str' in 'buf'
function count_instances($buf, $str) {
    $total = 0;
    $p     = 0;
    $i     = 0;

    while (1) {
        $p = $buf->search($str, $p);
        if ($p === FALSE) {
            break;
        }
        ++$total;
        ++$p;
    }

    return $total;
}

$buf = new EventBuffer();
$buf->add("Some string within a string inside another string");
var_dump(count_instances($buf, "str"));
?>

El resultado del ejemplo sería algo similar a:

int(3)

Ver también

  • EventBuffer::searchEol() - Scans the buffer for an occurrence of an end of line


Scans the buffer for an occurrence of an end of line

  • « EventBuffer::search
  • EventBuffer::substr »
  • PHP Manual
  • EventBuffer
  • Scans the buffer for an occurrence of an end of line

EventBuffer::searchEol

(PECL event >= 1.5.0)

EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line

Descripción

public EventBuffer::searchEol ( int $start = -1 , int $eol_style = EventBuffer::EOL_ANY ) : mixed

Scans the buffer for an occurrence of an end of line specified by eol_style parameter . It returns numeric position of the string, or false if the string was not found.

If the start argument is provided, it represents the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

Parámetros

start

Start search position.

eol_style

One of EventBuffer:EOL_* constants .

Valores devueltos

Returns numeric position of the first occurance of end-of-line symbol in the buffer, or false if not found.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ver también

  • EventBuffer::search() - Scans the buffer for an occurrence of a string


Substracts a portion of the buffer data

  • « EventBuffer::searchEol
  • EventBuffer::unfreeze »
  • PHP Manual
  • EventBuffer
  • Substracts a portion of the buffer data

EventBuffer::substr

(PECL event >= 1.6.0)

EventBuffer::substr — Substracts a portion of the buffer data

Descripción

public EventBuffer::substr ( int $start , int $length = ? ) : string

Substracts up to length bytes of the buffer data beginning at start position.

Parámetros

start

The start position of data to be substracted.

length

Maximum number of bytes to substract.

Valores devueltos

Returns the data substracted as a string on success, or false on failure.

Ver también

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


Re-enable calls that modify an event buffer

  • « EventBuffer::substr
  • EventBuffer::unlock »
  • PHP Manual
  • EventBuffer
  • Re-enable calls that modify an event buffer

EventBuffer::unfreeze

(PECL event >= 1.2.6-beta)

EventBuffer::unfreeze — Re-enable calls that modify an event buffer

Descripción

public EventBuffer::unfreeze ( bool $at_front ) : bool

Re-enable calls that modify an event buffer.

Parámetros

at_front

Whether to enable events at the front or at the end of the buffer.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBuffer::freeze() - Evita que las llamadas puedan modificar un buffer de eventos


Releases lock acquired by EventBuffer::lock

  • « EventBuffer::unfreeze
  • EventBuffer::write »
  • PHP Manual
  • EventBuffer
  • Releases lock acquired by EventBuffer::lock

EventBuffer::unlock

(PECL event >= 1.2.6-beta)

EventBuffer::unlock — Releases lock acquired by EventBuffer::lock

Descripción

public EventBuffer::unlock ( ) : bool

Releases lock acquired by EventBuffer::lock() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBuffer::lock() - Bloquea un buffer


Write contents of the buffer to a file or socket

  • « EventBuffer::unlock
  • EventBufferEvent »
  • PHP Manual
  • EventBuffer
  • Write contents of the buffer to a file or socket

EventBuffer::write

(PECL event >= 1.6.0)

EventBuffer::write — Write contents of the buffer to a file or socket

Descripción

public EventBuffer::write ( mixed $fd , int $howmuch = ? ) : int

Write contents of the buffer to a file descriptor. The buffer will be drained after the bytes have been successfully written.

Parámetros

fd

Socket resource, stream or numeric file descriptor associated normally associated with a socket.

howmuch

The maximum number of bytes to write.

Valores devueltos

Returns the number of bytes written, or false on error.

Ver también

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


The EventBufferEvent class

(PECL event >= 1.2.6-beta)

Introducción

Represents Libevent's buffer event.

Usually an application wants to perform some amount of data buffering in addition to just responding to events. When we want to write data, for example, the usual pattern looks like:

  1. Decide that we want to write some data to a connection; put that data in a buffer.

  2. Wait for the connection to become writable

  3. Write as much of the data as we can

  4. Remember how much we wrote, and if we still have more data to write, wait for the connection to become writable again.

This buffered I/O pattern is common enough that Libevent provides a generic mechanism for it. A "buffer event" consists of an underlying transport (like a socket), a read buffer, and a write buffer. Instead of regular events, which give callbacks when the underlying transport is ready to be read or written, a buffer event invokes its user-supplied callbacks when it has read or written enough data.

Sinopsis de la Clase

final EventBufferEvent {
/* Constants */
const int READING = 1 ;
const int WRITING = 2 ;
const int EOF = 16 ;
const int ERROR = 32 ;
const int TIMEOUT = 64 ;
const int CONNECTED = 128 ;
const int OPT_CLOSE_ON_FREE = 1 ;
const int OPT_THREADSAFE = 2 ;
const int OPT_DEFER_CALLBACKS = 4 ;
const int OPT_UNLOCK_CALLBACKS = 8 ;
const int SSL_OPEN = 0 ;
const int SSL_CONNECTING = 1 ;
const int SSL_ACCEPTING = 2 ;
/* Propiedades */
public int $fd ;
public int $priority ;
public readonly EventBuffer $input ;
public readonly EventBuffer $output ;
/* Métodos */
public close ( ) : void
public connect ( string $addr ) : bool
public connectHost ( EventDnsBase $dns_base , string $hostname , int $port , int $family = EventUtil::AF_UNSPEC ) : bool
public __construct ( EventBase $base , mixed $socket = null , int $options = 0 , callable $readcb = null , callable $writecb = null , callable $eventcb = null )
public static createPair ( EventBase $base , int $options = 0 ) : array
public disable ( int $events ) : bool
public enable ( int $events ) : bool
public free ( ) : void
public getDnsErrorString ( ) : string
public getEnabled ( ) : int
public getInput ( ) : EventBuffer
public getOutput ( ) : EventBuffer
public read ( int $size ) : string
public readBuffer ( EventBuffer $buf ) : bool
public setCallbacks ( callable $readcb , callable $writecb , callable $eventcb , string $arg = ? ) : void
public setPriority ( int $priority ) : bool
public setTimeouts ( float $timeout_read , float $timeout_write ) : bool
public setWatermark ( int $events , int $lowmark , int $highmark ) : void
public sslError ( ) : string
public static sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state , int $options = 0 ) : EventBufferEvent
public sslGetCipherInfo ( ) : string
public sslGetCipherName ( ) : string
public sslGetCipherVersion ( ) : string
public sslGetProtocol ( ) : string
public sslRenegotiate ( ) : void
public static sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state , int $options = ? ) : EventBufferEvent
public write ( string $data ) : bool
public writeBuffer ( EventBuffer $buf ) : bool
}

Propiedades

fd

Numeric file descriptor associated with the buffer event. Normally represents a bound socket. Equals to null, if there is no file descriptor(socket) associated with the buffer event.

priority

The priority of the events used to implement the buffer event.

input

Underlying input buffer object( EventBuffer )

output

Underlying output buffer object( EventBuffer )

Constantes predefinidas

EventBufferEvent::READING

An event occurred during a read operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::WRITING

An event occurred during a write operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::EOF

Got an end-of-file indication on the buffer event.

EventBufferEvent::ERROR

An error occurred during a bufferevent operation. For more information on what the error was, call EventUtil::getLastSocketErrno() and/or EventUtil::getLastSocketError() .

EventBufferEvent::TIMEOUT

EventBufferEvent::CONNECTED

Finished a requested connection on the bufferevent.

EventBufferEvent::OPT_CLOSE_ON_FREE

When the buffer event is freed, close the underlying transport. This will close an underlying socket, free an underlying buffer event, etc.

EventBufferEvent::OPT_THREADSAFE

Automatically allocate locks for the bufferevent, so that it’s safe to use from multiple threads.

EventBufferEvent::OPT_DEFER_CALLBACKS

When this flag is set, the bufferevent defers all of its callbacks. See » Fast portable non-blocking network programming with Libevent, Deferred callbacks .

EventBufferEvent::OPT_UNLOCK_CALLBACKS

By default, when the bufferevent is set up to be threadsafe, the buffer event’s locks are held whenever the any user-provided callback is invoked. Setting this option makes Libevent release the buffer event’s lock when it’s invoking the callbacks.

EventBufferEvent::SSL_OPEN

The SSL handshake is done

EventBufferEvent::SSL_CONNECTING

SSL is currently performing negotiation as a client

EventBufferEvent::SSL_ACCEPTING

SSL is currently performing negotiation as a server

Tabla de contenidos

  • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
  • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
  • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
  • EventBufferEvent::__construct — Constructs EventBufferEvent object
  • EventBufferEvent::createPair — Creates two buffer events connected to each other
  • EventBufferEvent::disable — Disable events read, write, or both on a buffer event
  • EventBufferEvent::enable — Enable events read, write, or both on a buffer event
  • EventBufferEvent::free — Free a buffer event
  • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
  • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
  • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
  • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
  • EventBufferEvent::read — Read buffer's data
  • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
  • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
  • EventBufferEvent::setPriority — Assign a priority to a bufferevent
  • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
  • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
  • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
  • EventBufferEvent::sslFilter — Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer
  • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher
  • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection
  • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection
  • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection
  • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation
  • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
  • EventBufferEvent::write — Adds data to a buffer event's output buffer
  • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer


Closes file descriptor associated with the current buffer event

  • « EventBufferEvent
  • EventBufferEvent::connect »
  • PHP Manual
  • EventBufferEvent
  • Closes file descriptor associated with the current buffer event

EventBufferEvent::close

(PECL event >= 1.10.0)

EventBufferEvent::close — Closes file descriptor associated with the current buffer event

Descripción

public EventBufferEvent::close ( ) : void

Closes file descriptor associated with the current buffer event.

This method may be used in cases when the EventBufferEvent::OPT_CLOSE_ON_FREE option is not appropriate.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Connect buffer event's file descriptor to given address or UNIX socket

  • « EventBufferEvent::close
  • EventBufferEvent::connectHost »
  • PHP Manual
  • EventBufferEvent
  • Connect buffer event's file descriptor to given address or UNIX socket

EventBufferEvent::connect

(PECL event >= 1.2.6-beta)

EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket

Descripción

public EventBufferEvent::connect ( string $addr ) : bool

Connect buffer event's file descriptor to given address(optionally with port), or a UNIX domain socket.

If socket is not assigned to the buffer event, this function allocates a new socket and makes it non-blocking internally.

To resolve DNS names(asyncronously), use EventBufferEvent::connectHost() method.

Parámetros

addr

Should contain an IP address with optional port number, or a path to UNIX domain socket. Recognized formats are:

[IPv6Address]:port
[IPv6Address]
IPv6Address
IPv4Address:port
IPv4Address
unix:path
Note, 'unix:' prefix is currently not case sensitive.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventBufferEvent::connect() example

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

/* Read callback */
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
/* Send request */
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
 * We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

/* Dispatch pending events */
$base->dispatch();

El resultado del ejemplo sería algo similar a:

step 1
step 2
step 3
Connected.
HTTP/1.1 200 OK
Server: nginx/1.2.6
Date: Sat, 09 Mar 2013 10:06:58 GMT
Content-Type: text/html; CHARSET=Windows-1252
Connection: close
X-Powered-By: PHP/5.4.11--pl2-gentoo

sdfsdfsf
Closing
Done

Ejemplo #2 Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console

<?php
class MyUnixSocketClient {
    private $base, $bev;

    function __construct($base, $sock_path) {
        $this->base = $base;
        $this->bev = new EventBufferEvent($base, NULL, EventBufferEvent::OPT_CLOSE_ON_FREE,
            array ($this, "read_cb"), NULL, array ($this, "event_cb"));

        if (!$this->bev->connect("unix:$sock_path")) {
            trigger_error("Failed to connect to socket `$sock_path'", E_USER_ERROR);
        }

        $this->bev->enable(Event::READ);
    }

    function __destruct() {
        if ($this->bev) {
            $this->bev->free();
            $this->bev = NULL;
        }
    }

    function dispatch() {
        $this->base->dispatch();
    }

    function read_cb($bev, $unused) {
        $in = $bev->input;

        printf("Received %ld bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $this->bev->free();
        $this->bev = NULL;
        $this->base->exit(NULL);
    }

    function event_cb($bev, $events, $unused) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        } elseif ($events & EventBufferEvent::CONNECTED) {
            $bev->output->add("test\n");
        }
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$base = new EventBase();
$cl = new MyUnixSocketClient($base, $sock_path);
$cl->dispatch();
?>

El resultado del ejemplo sería algo similar a:

Received 5 bytes
----- data ----
5:  test

Ver también

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving


Connects to a hostname with optionally asyncronous DNS resolving

  • « EventBufferEvent::connect
  • EventBufferEvent::__construct »
  • PHP Manual
  • EventBufferEvent
  • Connects to a hostname with optionally asyncronous DNS resolving

EventBufferEvent::connectHost

(PECL event >= 1.2.6-beta)

EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving

Descripción

public EventBufferEvent::connectHost ( EventDnsBase $dns_base , string $hostname , int $port , int $family = EventUtil::AF_UNSPEC ) : bool

Resolves the DNS name hostname, looking for addresses of type family ( EventUtil::AF_* constants). If the name resolution fails, it invokes the event callback with an error event. If it succeeds, it launches a connection attempt just as EventBufferEvent::connect() would.

dns_base is optional. May be null, or an object created with EventDnsBase::__construct() . For asyncronous hostname resolving pass a valid event dns base resource. Otherwise the hostname resolving will block.

Nota:

EventDnsBase is available only if Event configured --with-event-extra ( event_extra library, libevent protocol-specific functionality support including HTTP, DNS, and RPC ).

Nota:

EventBufferEvent::connectHost() requires libevent-2.0.3-alpha or greater.

Parámetros

dns_base

Object of EventDnsBase in case if DNS is to be resolved asyncronously. Otherwise null.

hostname

Hostname to connect to. Recognized formats are:

www.example.com (hostname)
 1.2.3.4 (ipv4address)
 ::1 (ipv6address)
[::1] ([ipv6address])

port

Port number

family

Address family. EventUtil::AF_UNSPEC , EventUtil::AF_INET , or EventUtil::AF_INET6 . See EventUtil constants .

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventBufferEvent::connectHost() example

<?php
/* Read callback */
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

El resultado del ejemplo sería algo similar a:

Connected.
HTTP/1.0 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1252
Date: Sat, 09 Mar 2013 12:21:19 GMT
Expires: Mon, 08 Apr 2013 12:21:19 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=Windows-1252">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

Ver también

  • EventBufferEvent::connect() - Connect buffer event's file descriptor to given address or UNIX socket


Constructs EventBufferEvent object

  • « EventBufferEvent::connectHost
  • EventBufferEvent::createPair »
  • PHP Manual
  • EventBufferEvent
  • Constructs EventBufferEvent object

EventBufferEvent::__construct

(PECL event >= 1.2.6-beta)

EventBufferEvent::__construct — Constructs EventBufferEvent object

Descripción

public EventBufferEvent::__construct ( EventBase $base , mixed $socket = null , int $options = 0 , callable $readcb = null , callable $writecb = null , callable $eventcb = null )

Create a buffer event on a socket, stream or a file descriptor. Passing null to socket means that the socket should be created later, e.g. by means of EventBufferEvent::connect() .

Parámetros

base

Event base that should be associated with the new buffer event.

socket

May be created as a stream(not necessarily by means of sockets extension)

options

One of EventBufferEvent::OPT_* constants , or 0 .

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

Valores devueltos

Returns buffer event resource optionally associated with socket resource. */

Ver también

  • EventBufferEvent::sslFilter() - Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer
  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket


Creates two buffer events connected to each other

  • « EventBufferEvent::__construct
  • EventBufferEvent::disable »
  • PHP Manual
  • EventBufferEvent
  • Creates two buffer events connected to each other

EventBufferEvent::createPair

(PECL event >= 1.2.6-beta)

EventBufferEvent::createPair — Creates two buffer events connected to each other

Descripción

public static EventBufferEvent::createPair ( EventBase $base , int $options = 0 ) : array

Returns array of two EventBufferEvent objects connected to each other. All the usual options are supported, except for EventBufferEvent::OPT_CLOSE_ON_FREE , which has no effect, and EventBufferEvent::OPT_DEFER_CALLBACKS , which is always on.

Parámetros

base

Associated event base

options

EventBufferEvent::OPT_* constants combined with bitwise OR operator.

Valores devueltos

Returns array of two EventBufferEvent objects connected to each other.

Historial de cambios

Versión | Descripción
PECL event 1.9.0 | Method made static.


Disable events read, write, or both on a buffer event

  • « EventBufferEvent::createPair
  • EventBufferEvent::enable »
  • PHP Manual
  • EventBufferEvent
  • Disable events read, write, or both on a buffer event

EventBufferEvent::disable

(PECL event >= 1.2.6-beta)

EventBufferEvent::disable — Disable events read, write, or both on a buffer event

Descripción

public EventBufferEvent::disable ( int $events ) : bool

Disable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Parámetros

events

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event


Enable events read, write, or both on a buffer event

  • « EventBufferEvent::disable
  • EventBufferEvent::free »
  • PHP Manual
  • EventBufferEvent
  • Enable events read, write, or both on a buffer event

EventBufferEvent::enable

(PECL event >= 1.2.6-beta)

EventBufferEvent::enable — Enable events read, write, or both on a buffer event

Descripción

public EventBufferEvent::enable ( int $events ) : bool

Enable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Parámetros

events

Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event


Free a buffer event

  • « EventBufferEvent::enable
  • EventBufferEvent::getDnsErrorString »
  • PHP Manual
  • EventBufferEvent
  • Free a buffer event

EventBufferEvent::free

(PECL event >= 1.2.6-beta)

EventBufferEvent::free — Free a buffer event

Descripción

public EventBufferEvent::free ( ) : void

Free resources allocated by buffer event.

Usually there is no need to call this method, since normally it is done within internal object destructors. However, sometimes we have a long-time script allocating lots of instances, or a script with a heavy memory usage, where we need to free resources as soon as possible. In such cases EventBufferEvent::free() may be used to protect the script against running up to the memory_limit .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Returns string describing the last failed DNS lookup attempt

  • « EventBufferEvent::free
  • EventBufferEvent::getEnabled »
  • PHP Manual
  • EventBufferEvent
  • Returns string describing the last failed DNS lookup attempt

EventBufferEvent::getDnsErrorString

(PECL event >= 1.2.6-beta)

EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt

Descripción

public EventBufferEvent::getDnsErrorString ( ) : string

Returns string describing the last failed DNS lookup attempt made by EventBufferEvent::connectHost() , or an empty string, if there is no DNS error detected.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a string describing DNS lookup error, or an empty string for no error.

Ver también

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving


Returns bitmask of events currently enabled on the buffer event

  • « EventBufferEvent::getDnsErrorString
  • EventBufferEvent::getInput »
  • PHP Manual
  • EventBufferEvent
  • Returns bitmask of events currently enabled on the buffer event

EventBufferEvent::getEnabled

(PECL event >= 1.2.6-beta)

EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event

Descripción

public EventBufferEvent::getEnabled ( ) : int

Returns bitmask of events currently enabled on the buffer event

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns integer representing a bitmask of events currently enabled on the buffer event

Ver también

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event
  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event


Returns underlying input buffer associated with current buffer event

  • « EventBufferEvent::getEnabled
  • EventBufferEvent::getOutput »
  • PHP Manual
  • EventBufferEvent
  • Returns underlying input buffer associated with current buffer event

EventBufferEvent::getInput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event

Descripción

public EventBufferEvent::getInput ( ) : EventBuffer

Returns underlying input buffer associated with current buffer event. An input buffer is a storage for data to read.

Note, there is also input property of EventBufferEvent class.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns instance of EventBuffer input buffer associated with current buffer event.

Ejemplos

Ejemplo #1 Buffer event's read callback

<?php
function readcb($bev, $base) {
    $input = $bev->input; //$bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}
?>

Ver también

  • EventBufferEvent::getOutput() - Returns underlying output buffer associated with current buffer event


Returns underlying output buffer associated with current buffer event

  • « EventBufferEvent::getInput
  • EventBufferEvent::read »
  • PHP Manual
  • EventBufferEvent
  • Returns underlying output buffer associated with current buffer event

EventBufferEvent::getOutput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event

Descripción

public EventBufferEvent::getOutput ( ) : EventBuffer

Returns underlying output buffer associated with current buffer event. An output buffer is a storage for data to be written.

Note, there is also output property of EventBufferEvent class.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns instance of EventBuffer output buffer associated with current buffer event.

Ejemplos

Ejemplo #1 EventBufferEvent::getOutput() example

<?php
$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // Use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

$bev->enable(Event::READ | Event::WRITE);

$output = $bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* ... */
?>

Ver también

  • EventBufferEvent::getInput() - Returns underlying input buffer associated with current buffer event


Read buffer's data

  • « EventBufferEvent::getOutput
  • EventBufferEvent::readBuffer »
  • PHP Manual
  • EventBufferEvent
  • Read buffer's data

EventBufferEvent::read

(PECL event >= 1.2.6-beta)

EventBufferEvent::read — Read buffer's data

Descripción

public EventBufferEvent::read ( int $size ) : string

Removes up to size bytes from the input buffer. Returns a string of data read from the input buffer.

Parámetros

size

Maximum number of bytes to read

Valores devueltos

Returns string of data read from the input buffer.

Ver también

  • EventBufferEvent::readBuffer() - Drains the entire contents of the input buffer and places them into buf


Drains the entire contents of the input buffer and places them into buf

  • « EventBufferEvent::read
  • EventBufferEvent::setCallbacks »
  • PHP Manual
  • EventBufferEvent
  • Drains the entire contents of the input buffer and places them into buf

EventBufferEvent::readBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf

Descripción

public EventBufferEvent::readBuffer ( EventBuffer $buf ) : bool

Drains the entire contents of the input buffer and places them into buf .

Parámetros

buf

Target buffer

Valores devueltos

Returns true on success; Otherwise false.

Ver también

  • EventBufferEvent::read() - Read buffer's data


Assigns read, write and event(status) callbacks

  • « EventBufferEvent::readBuffer
  • EventBufferEvent::setPriority »
  • PHP Manual
  • EventBufferEvent
  • Assigns read, write and event(status) callbacks

EventBufferEvent::setCallbacks

(PECL event >= 1.2.6-beta)

EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks

Descripción

public EventBufferEvent::setCallbacks ( callable $readcb , callable $writecb , callable $eventcb , string $arg = ? ) : void

Assigns read, write and event(status) callbacks.

Parámetros

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventBufferEvent::__construct() - Constructs EventBufferEvent object


Assign a priority to a bufferevent

  • « EventBufferEvent::setCallbacks
  • EventBufferEvent::setTimeouts »
  • PHP Manual
  • EventBufferEvent
  • Assign a priority to a bufferevent

EventBufferEvent::setPriority

(PECL event >= 1.2.6-beta)

EventBufferEvent::setPriority — Assign a priority to a bufferevent

Descripción

public EventBufferEvent::setPriority ( int $priority ) : bool

Assign a priority to a bufferevent

Advertencia

Only supported for socket buffer events

Parámetros

priority

Priority value.

Valores devueltos

Returns true on success. Otherwise false.


Set the read and write timeout for a buffer event

  • « EventBufferEvent::setPriority
  • EventBufferEvent::setWatermark »
  • PHP Manual
  • EventBufferEvent
  • Set the read and write timeout for a buffer event

EventBufferEvent::setTimeouts

(PECL event >= 1.2.6-beta)

EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event

Descripción

public EventBufferEvent::setTimeouts ( float $timeout_read , float $timeout_write ) : bool

Set the read and write timeout for a buffer event

Parámetros

timeout_read

Read timeout

timeout_write

Write timeout

Valores devueltos

Returns true on success. Otherwise false.


Adjusts read and/or write watermarks

  • « EventBufferEvent::setTimeouts
  • EventBufferEvent::sslError »
  • PHP Manual
  • EventBufferEvent
  • Adjusts read and/or write watermarks

EventBufferEvent::setWatermark

(PECL event >= 1.2.6-beta)

EventBufferEvent::setWatermark — Adjusts read and/or write watermarks

Descripción

public EventBufferEvent::setWatermark ( int $events , int $lowmark , int $highmark ) : void

Adjusts the read watermarks, the write watermarks , or both, of a single buffer event.

A buffer event watermark is an edge, a value specifying number of bytes to be read or written before callback is invoked. By default every read/write event triggers a callback invokation. See » Fast portable non-blocking network programming with Libevent: Callbacks and watermarks

Parámetros

events

Bitmask of Event::READ , Event::WRITE , or both.

lowmark

Minimum watermark value.

highmark

Maximum watermark value. 0 means "unlimited".

Valores devueltos

No devuelve ningún valor.


Returns most recent OpenSSL error reported on the buffer event

  • « EventBufferEvent::setWatermark
  • EventBufferEvent::sslFilter »
  • PHP Manual
  • EventBufferEvent
  • Returns most recent OpenSSL error reported on the buffer event

EventBufferEvent::sslError

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event

Descripción

public EventBufferEvent::sslError ( ) : string

Returns most recent OpenSSL error reported on the buffer event.

Nota:

This function is available only if Event is compiled with OpenSSL support.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns OpenSSL error string reported on the buffer event, or false, if there is no more error to return.

Ejemplos

Ejemplo #1 EventBufferEvent::sslError() example

<?php
// This callback is invoked when some even occurs on the event listener,
// e.g. connection closed, or an error occured
function ssl_event_cb($bev, $events, $ctx) {
    if ($events & EventBufferEvent::ERROR) {
        // Fetch errors from the SSL error stack
        while ($err = $bev->sslError()) {
            fprintf(STDERR, "Bufferevent error %s.\n", $err);
        }
    }

    if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
        $bev->free();
    }
}
?>

Ver también

  • EventBufferEvent::sslRenegotiate() - Tells a bufferevent to begin SSL renegotiation


Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer

  • « EventBufferEvent::sslError
  • EventBufferEvent::sslGetCipherInfo »
  • PHP Manual
  • EventBufferEvent
  • Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer

EventBufferEvent::sslFilter

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslFilter — Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer

Descripción

public static EventBufferEvent::sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state , int $options = 0 ) : EventBufferEvent

Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer

Nota:

Esta función está disponible solo si This function is available only if Event es compilado con suporte para OpenSSL.

Parámetros

base

Evento base asociado.

underlying

El socket evento búfer para usar en esta SSL.

ctx

Objecto de la clase EventSslContext.

state

El estado actual de la conexión SSL: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING o EventBufferEvent::SSL_CONNECTING .

options

Una o más opciones del evento búfer.

Valores devueltos

Devuelve un nuevo objecto SSL EventBufferEvent.

Ejemplos

Ejemplo #1 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();

Ver también

  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket


Returns a textual description of the cipher

  • « EventBufferEvent::sslFilter
  • EventBufferEvent::sslGetCipherName »
  • PHP Manual
  • EventBufferEvent
  • Returns a textual description of the cipher

EventBufferEvent::sslGetCipherInfo

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher

Descripción

public EventBufferEvent::sslGetCipherInfo ( ) : string

Retrieves description of the current cipher by means of the SSL_CIPHER_description SSL API function (see SSL_CIPHER_get_name(3) man page).

Nota:

This function is available only if Event is compiled with OpenSSL support.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a textual description of the cipher on success, or false on error.


Returns the current cipher name of the SSL connection

  • « EventBufferEvent::sslGetCipherInfo
  • EventBufferEvent::sslGetCipherVersion »
  • PHP Manual
  • EventBufferEvent
  • Returns the current cipher name of the SSL connection

EventBufferEvent::sslGetCipherName

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection

Descripción

public EventBufferEvent::sslGetCipherName ( ) : string

Retrieves name of cipher used by current SSL connection.

Nota:

This function is available only if Event is compiled with OpenSSL support.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current cipher name of the SSL connection, or false on error.


Returns version of cipher used by current SSL connection

  • « EventBufferEvent::sslGetCipherName
  • EventBufferEvent::sslGetProtocol »
  • PHP Manual
  • EventBufferEvent
  • Returns version of cipher used by current SSL connection

EventBufferEvent::sslGetCipherVersion

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection

Descripción

public EventBufferEvent::sslGetCipherVersion ( ) : string

Retrieves version of cipher used by current SSL connection.

Nota:

This function is available only if Event is compiled with OpenSSL support.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current cipher version of the SSL connection, or false on error.


Returns the name of the protocol used for current SSL connection

  • « EventBufferEvent::sslGetCipherVersion
  • EventBufferEvent::sslRenegotiate »
  • PHP Manual
  • EventBufferEvent
  • Returns the name of the protocol used for current SSL connection

EventBufferEvent::sslGetProtocol

(PECL event >= 1.10.0)

EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection

Descripción

public EventBufferEvent::sslGetProtocol ( ) : string

Returns the name of the protocol used for current SSL connection.

Nota:

This function is available only if Event is compiled with OpenSSL support.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the name of the protocol used for current SSL connection.


Tells a bufferevent to begin SSL renegotiation

  • « EventBufferEvent::sslGetProtocol
  • EventBufferEvent::sslSocket »
  • PHP Manual
  • EventBufferEvent
  • Tells a bufferevent to begin SSL renegotiation

EventBufferEvent::sslRenegotiate

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation

Descripción

public EventBufferEvent::sslRenegotiate ( ) : void

Tells a bufferevent to begin SSL renegotiation.

Advertencia

Calling this function tells the SSL to renegotiate, and the buffer event to invoke appropriate callbacks. This is an advanced topic; this should be generally avoided unless one really knows what he/she does, especially since many SSL versions have had known security issues related to renegotiation.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Creates a new SSL buffer event to send its data over an SSL on a socket

  • « EventBufferEvent::sslRenegotiate
  • EventBufferEvent::write »
  • PHP Manual
  • EventBufferEvent
  • Creates a new SSL buffer event to send its data over an SSL on a socket

EventBufferEvent::sslSocket

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket

Descripción

public static EventBufferEvent::sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state , int $options = ? ) : EventBufferEvent

Creates a new SSL buffer event to send its data over an SSL on a socket.

Parámetros

base

Associated event base.

socket

Socket to use for this SSL. Can be stream or socket resource, numeric file descriptor, or null. If socket is null, it is assumed that the file descriptor for the socket will be assigned later, for instance, by means of EventBufferEvent::connectHost() method.

ctx

Object of EventSslContext class.

state

The current state of SSL connection: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING or EventBufferEvent::SSL_CONNECTING .

options

The buffer event options.

Valores devueltos

Returns EventBufferEvent object.

Ver también

  • EventBufferEvent::sslFilter() - Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer


Adds data to a buffer event's output buffer

  • « EventBufferEvent::sslSocket
  • EventBufferEvent::writeBuffer »
  • PHP Manual
  • EventBufferEvent
  • Adds data to a buffer event's output buffer

EventBufferEvent::write

(PECL event >= 1.2.6-beta)

EventBufferEvent::write — Adds data to a buffer event's output buffer

Descripción

public EventBufferEvent::write ( string $data ) : bool

Adds data to a buffer event's output buffer

Parámetros

data

Data to be added to the underlying buffer.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBufferEvent::writeBuffer() - Adds contents of the entire buffer to a buffer event's output buffer


Adds contents of the entire buffer to a buffer event's output buffer

  • « EventBufferEvent::write
  • About buffer event callbacks »
  • PHP Manual
  • EventBufferEvent
  • Adds contents of the entire buffer to a buffer event's output buffer

EventBufferEvent::writeBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer

Descripción

public EventBufferEvent::writeBuffer ( EventBuffer $buf ) : bool

Adds contents of the entire buffer to a buffer event's output buffer

Parámetros

buf

Source EventBuffer object.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventBufferEvent::write() - Adds data to a buffer event's output buffer


About buffer event callbacks

An object of EventBufferEvent class represents a buffer event . The asynchronous nature of I/O performed by Libevent implies that a socket(or other kind of file descriptor) is not always available. Event invokes corresponding callbacks when the resource becomes available for reading or writing, or when some event occurs(e.g. error, "end of line" etc.).

Read and write callbacks should match the following prototype:

callback ( EventBufferEvent $bev = null , mixed $arg = null ) : void

bev

Associated EventBufferEvent object.

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .

Event callback should match the following prototype:

callback ( EventBufferEvent $bev = null , int $events = 0 , mixed $arg = null ) : void

bev

Associated EventBufferEvent object.

events

Bit mask of events: EventBufferEvent::READING , EventBufferEvent::WRITING , EventBufferEvent::EOL , EventBufferEvent::ERROR and EventBufferEvent::TIMEOUT . See EventBufferEvent constants

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .


The EventConfig class

(PECL event >= 1.2.6-beta)

Introducción

Represents configuration structure which could be used in construction of the EventBase .

Sinopsis de la Clase

final EventConfig {
/* Constants */
const int FEATURE_ET = 1 ;
const int FEATURE_O1 = 2 ;
const int FEATURE_FDS = 4 ;
/* Métodos */
public avoidMethod ( string $method ) : bool
public __construct ( )
public requireFeatures ( int $feature ) : bool
public setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority ) : void
}

Constantes predefinidas

EventConfig::FEATURE_ET

Requires a backend method that supports edge-triggered I/O.

EventConfig::FEATURE_O1

Requires a backend method where adding or deleting a single event, or having a single event become active, is an O(1) operation.

EventConfig::FEATURE_FDS

Requires a backend method that can support arbitrary file descriptor types, and not just sockets.

Tabla de contenidos

  • EventConfig::avoidMethod — Tells libevent to avoid specific event method
  • EventConfig::__construct — Constructs EventConfig object
  • EventConfig::requireFeatures — Enters a required event method feature that the application demands
  • EventConfig::setMaxDispatchInterval — Prevents priority inversion


Tells libevent to avoid specific event method

  • « EventConfig
  • EventConfig::__construct »
  • PHP Manual
  • EventConfig
  • Tells libevent to avoid specific event method

EventConfig::avoidMethod

(PECL event >= 1.2.6-beta)

EventConfig::avoidMethod — Tells libevent to avoid specific event method

Descripción

public EventConfig::avoidMethod ( string $method ) : bool

Tells libevent to avoid specific event method(backend). See » Creating an event base .

Parámetros

method

The backend method to avoid. See EventConfig constants .

Valores devueltos

Returns true on success, otherwise false.

Ejemplos

Ejemplo #1 EventConfig::avoidMethod() example

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}
?>

Ver también

  • EventBase::__construct() - Construye un objeto EventBase


Constructs EventConfig object

  • « EventConfig::avoidMethod
  • EventConfig::requireFeatures »
  • PHP Manual
  • EventConfig
  • Constructs EventConfig object

EventConfig::__construct

(PECL event >= 1.2.6-beta)

EventConfig::__construct — Constructs EventConfig object

Descripción

public EventConfig::__construct ( )

Constructs EventConfig object which could be passed to EventBase::__construct() constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns EventConfig object.

Ejemplos

Ejemplo #1 EventConfig::__construct() example

<?php
// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);

/* Now $base is configured to avoid select backend(method) */
?>

Ver también

  • EventBase::__construct() - Construye un objeto EventBase


Enters a required event method feature that the application demands

  • « EventConfig::__construct
  • EventConfig::setMaxDispatchInterval »
  • PHP Manual
  • EventConfig
  • Enters a required event method feature that the application demands

EventConfig::requireFeatures

(PECL event >= 1.2.6-beta)

EventConfig::requireFeatures — Enters a required event method feature that the application demands

Descripción

public EventConfig::requireFeatures ( int $feature ) : bool

Enters a required event method feature that the application demands

Parámetros

feature

Bitmask of required features. See EventConfig::FEATURE_* constants

Valores devueltos

Ejemplos

Ejemplo #1 EventConfig::requireFeatures() example

<?php
$cfg = new EventConfig();

// Create event_base associated with the config
$base = new EventBase($cfg);

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
?>

El resultado del ejemplo sería algo similar a:

FDS feature is now requried
FDS - arbitrary file descriptor types, and not just sockets

Ver también

  • EventBase::getFeatures() - Devuelve una máscara de bits de funcionalidades soportadas


Prevents priority inversion

  • « EventConfig::requireFeatures
  • EventDnsBase »
  • PHP Manual
  • EventConfig
  • Prevents priority inversion

EventConfig::setMaxDispatchInterval

(No hay información de versión disponible, podría estar únicamente en Git)

EventConfig::setMaxDispatchInterval — Prevents priority inversion

Descripción

public EventConfig::setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority ) : void

Prevents priority inversion by limiting how many low-priority event callbacks can be invoked before checking for more high-priority events.

Nota:

Available since libevent 2.1.0-alpha .

Parámetros

max_interval

An interval after which Libevent should stop running callbacks and check for more events, or 0 , if there should be no such interval.

max_callbacks

A number of callbacks after which Libevent should stop running callbacks and check for more events, or -1 , if there should be no such limit.

min_priority

A priority below which max_interval and max_callbacks should not be enforced. If this is set to 0 , they are enforced for events of every priority; if it's set to 1 , they're enforced for events of priority 1 and above, and so on.

Valores devueltos

Returns true on success, otherwise false.


The EventDnsBase class

(PECL event >= 1.2.6-beta)

Introducción

Represents Libevent's DNS base structure. Used to resolve DNS asyncronously, parse configuration files like resolv.conf etc.

Sinopsis de la Clase

final EventDnsBase {
/* Constants */
const int OPTION_SEARCH = 1 ;
const int OPTION_NAMESERVERS = 2 ;
const int OPTION_MISC = 4 ;
const int OPTION_HOSTSFILE = 8 ;
const int OPTIONS_ALL = 15 ;
/* Métodos */
public addNameserverIp ( string $ip ) : bool
public addSearch ( string $domain ) : void
public clearSearch ( ) : void
public __construct ( EventBase $base , bool $initialize )
public countNameservers ( ) : int
public loadHosts ( string $hosts ) : bool
public parseResolvConf ( int $flags , string $filename ) : bool
public setOption ( string $option , string $value ) : bool
public setSearchNdots ( int $ndots ) : bool
}

Constantes predefinidas

EventDnsBase::OPTION_SEARCH

Tells to read the domain and search fields from the resolv.conf file and the ndots option, and use them to decide which domains(if any) to search for hostnames that aren’t fully-qualified.

EventDnsBase::OPTION_NAMESERVERS

Tells to learn the nameservers from the resolv.conf file.

EventDnsBase::OPTION_MISC

EventDnsBase::OPTION_HOSTSFILE

Tells to read a list of hosts from /etc/hosts as part of loading the resolv.conf file.

EventDnsBase::OPTIONS_ALL

Tells to learn as much as it can from the resolv.conf file.

Tabla de contenidos

  • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
  • EventDnsBase::addSearch — Adds a domain to the list of search domains
  • EventDnsBase::clearSearch — Removes all current search suffixes
  • EventDnsBase::__construct — Constructs EventDnsBase object
  • EventDnsBase::countNameservers — Gets the number of configured nameservers
  • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
  • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
  • EventDnsBase::setOption — Set the value of a configuration option
  • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches


Adds a nameserver to the DNS base

  • « EventDnsBase
  • EventDnsBase::addSearch »
  • PHP Manual
  • EventDnsBase
  • Adds a nameserver to the DNS base

EventDnsBase::addNameserverIp

(PECL event >= 1.2.6-beta)

EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base

Descripción

public EventDnsBase::addNameserverIp ( string $ip ) : bool

Adds a nameserver to the evdns_base.

Parámetros

ip

The nameserver string, either as an IPv4 address, an IPv6 address, an IPv4 address with a port ( IPv4:Port ), or an IPv6 address with a port ( [IPv6]:Port ).

Valores devueltos

Returns true on success. Otherwise false.


Adds a domain to the list of search domains

  • « EventDnsBase::addNameserverIp
  • EventDnsBase::clearSearch »
  • PHP Manual
  • EventDnsBase
  • Adds a domain to the list of search domains

EventDnsBase::addSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::addSearch — Adds a domain to the list of search domains

Descripción

public EventDnsBase::addSearch ( string $domain ) : void

Adds a domain to the list of search domains

Parámetros

domain

Search domain.

Valores devueltos

No devuelve ningún valor.


Removes all current search suffixes

  • « EventDnsBase::addSearch
  • EventDnsBase::__construct »
  • PHP Manual
  • EventDnsBase
  • Removes all current search suffixes

EventDnsBase::clearSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::clearSearch — Removes all current search suffixes

Descripción

public EventDnsBase::clearSearch ( ) : void

Removes all current search suffixes from the DNS base; the EventDnsBase::addSearch() function adds a suffix.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventDnsBase::addSearch() - Adds a domain to the list of search domains


Constructs EventDnsBase object

  • « EventDnsBase::clearSearch
  • EventDnsBase::countNameservers »
  • PHP Manual
  • EventDnsBase
  • Constructs EventDnsBase object

EventDnsBase::__construct

(PECL event >= 1.2.6-beta)

EventDnsBase::__construct — Constructs EventDnsBase object

Descripción

public EventDnsBase::__construct ( EventBase $base , bool $initialize )

Constructs EventDnsBase object.

Parámetros

base

Event base.

initialize

If the initialize argument is true, it tries to configure the DNS base sensibly given your operating system’s default. Otherwise, it leaves the event DNS base empty, with no nameservers or options configured. In the latter case DNS base should be configured manually, e.g. with EventDnsBase::parseResolvConf() .

Valores devueltos

Returns EventDnsBase object.


Gets the number of configured nameservers

  • « EventDnsBase::__construct
  • EventDnsBase::loadHosts »
  • PHP Manual
  • EventDnsBase
  • Gets the number of configured nameservers

EventDnsBase::countNameservers

(PECL event >= 1.2.6-beta)

EventDnsBase::countNameservers — Gets the number of configured nameservers

Descripción

public EventDnsBase::countNameservers ( ) : int

Gets the number of configured nameservers

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of configured nameservers(not necessarily the number of running nameservers). This is useful for double-checking whether our calls to the various nameserver configuration functions have been successful.


Loads a hosts file (in the same format as /etc/hosts) from hosts file

  • « EventDnsBase::countNameservers
  • EventDnsBase::parseResolvConf »
  • PHP Manual
  • EventDnsBase
  • Loads a hosts file (in the same format as /etc/hosts) from hosts file

EventDnsBase::loadHosts

(PECL event >= 1.2.6-beta)

EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file

Descripción

public EventDnsBase::loadHosts ( string $hosts ) : bool

Loads a hosts file (in the same format as /etc/hosts ) from hosts file.

Parámetros

hosts

Path to the hosts' file.

Valores devueltos

Returns true on success. Otherwise false.


Scans the resolv.conf-formatted file

  • « EventDnsBase::loadHosts
  • EventDnsBase::setOption »
  • PHP Manual
  • EventDnsBase
  • Scans the resolv.conf-formatted file

EventDnsBase::parseResolvConf

(PECL event >= 1.2.6-beta)

EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file

Descripción

public EventDnsBase::parseResolvConf ( int $flags , string $filename ) : bool

Scans the resolv.conf-formatted file stored in filename, and read in all the options from it that are listed in flags

Parámetros

flags

Determines what information is parsed from the resolv.conf file. See the man page for resolv.conf for the format of this file.

The following directives are not parsed from the file: sortlist, rotate, no-check-names, inet6, debug .

If this function encounters an error, the possible return values are:

  • 1 = failed to open file
  • 2 = failed to stat file
  • 3 = file too large
  • 4 = out of memory
  • 5 = short read from file
  • 6 = no nameservers listed in the file

filename

Path to resolv.conf file.

Valores devueltos

Returns true on success. Otherwise false.


Set the value of a configuration option

  • « EventDnsBase::parseResolvConf
  • EventDnsBase::setSearchNdots »
  • PHP Manual
  • EventDnsBase
  • Set the value of a configuration option

EventDnsBase::setOption

(PECL event >= 1.2.6-beta)

EventDnsBase::setOption — Set the value of a configuration option

Descripción

public EventDnsBase::setOption ( string $option , string $value ) : bool

Set the value of a configuration option.

Parámetros

option

The currently available configuration options are: "ndots" , "timeout" , "max-timeouts" , "max-inflight" , and "attempts" .

value

Option value.

Valores devueltos

Returns true on success. Otherwise false.


Set the 'ndots' parameter for searches

  • « EventDnsBase::setOption
  • EventHttp »
  • PHP Manual
  • EventDnsBase
  • Set the 'ndots' parameter for searches

EventDnsBase::setSearchNdots

(PECL event >= 1.2.6-beta)

EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches

Descripción

public EventDnsBase::setSearchNdots ( int $ndots ) : bool

Set the 'ndots' parameter for searches. Sets the number of dots which, when found in a name, causes the first query to be without any search domain.

Parámetros

ndots

The number of dots.

Valores devueltos

Returns true on success. Otherwise false.


The EventHttp class

(PECL event >= 1.4.0-beta)

Introducción

Represents HTTP server.

Sinopsis de la Clase

final EventHttp {
/* Métodos */
public accept ( mixed $socket ) : bool
public addServerAlias ( string $alias ) : bool
public bind ( string $address , int $port ) : void
public __construct ( EventBase $base , EventSslContext $ctx = null )
public removeServerAlias ( string $alias ) : bool
public setAllowedMethods ( int $methods ) : void
public setCallback ( string $path , string $cb , string $arg = ? ) : void
public setDefaultCallback ( string $cb , string $arg = ? ) : void
public setMaxBodySize ( int $value ) : void
public setMaxHeadersSize ( int $value ) : void
public setTimeout ( int $value ) : void
}

Tabla de contenidos

  • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
  • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
  • EventHttp::bind — Binds an HTTP server on the specified address and port
  • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
  • EventHttp::removeServerAlias — Removes server alias
  • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
  • EventHttp::setCallback — Sets a callback for specified URI
  • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
  • EventHttp::setMaxBodySize — Sets maximum request body size
  • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
  • EventHttp::setTimeout — Sets the timeout for an HTTP request


Makes an HTTP server accept connections on the specified socket stream or resource

  • « EventHttp
  • EventHttp::addServerAlias »
  • PHP Manual
  • EventHttp
  • Makes an HTTP server accept connections on the specified socket stream or resource

EventHttp::accept

(PECL event >= 1.2.6-beta)

EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource

Descripción

public EventHttp::accept ( mixed $socket ) : bool

Makes an HTTP server accept connections on the specified socket stream or resource. The socket should be ready to accept connections.

Can be called multiple times to accept connections on different sockets.

Nota:

To bind a socket, listen , and accept connections on the socket in s single call use EventHttp::bind() . EventHttp::accept() is needed only if one already has a socket ready to accept connections.

Parámetros

socket

Socket resource, stream or numeric file descriptor representing a socket ready to accept connections.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttp::accept() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$addresses = array (
     8091 => "127.0.0.1",
     8092 => "127.0.0.2",
);
$i = 0;

$socket = array();

foreach ($addresses as $port => $ip) {
    echo $ip, " ", $port, PHP_EOL;
    $socket[$i] = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
    if (!socket_bind($socket[$i], $ip, $port)) {
        exit("socket_bind failed\n");
    }
    socket_listen($socket[$i], 0);
    socket_set_nonblock($socket[$i]);

    if (!$http->accept($socket[$i])) {
        echo "Accept failed\n";
        exit(1);
    }

    ++$i;
}

$http->setCallback("/some-page", function() {
 echo "(some-page)\n";
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$signal = Event::signal($base, SIGINT, function () use ($base) {
    echo "Caught SIGINT. Stopping...\n";
    $base->stop();
});
$signal->add();

$base->dispatch();
echo "END\n";
// We didn't close sockets, since Libevent already sets
// CLOSE_ON_FREE and CLOSE_ON_EXEC flags on the file
// descriptor associated with the sockets.
?>

El resultado del ejemplo sería algo similar a:

Client:
$ nc 127.0.0.1 8091
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Server:
127.0.0.1 8091
127.0.0.2 8092
URI: /about
OK

Ver también

  • EventHttp::bind() - Binds an HTTP server on the specified address and port


Adds a server alias to the HTTP server object

  • « EventHttp::accept
  • EventHttp::bind »
  • PHP Manual
  • EventHttp
  • Adds a server alias to the HTTP server object

EventHttp::addServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::addServerAlias — Adds a server alias to the HTTP server object

Descripción

public EventHttp::addServerAlias ( string $alias ) : bool

Adds a server alias to the HTTP server object.

Parámetros

alias

The alias to add.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttp::addServerAlias() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

if (!$http->addServerAlias("local.net")) {
    exit("Failed to add server alias\n");
}

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});
$base->dispatch();
?>

Ver también

  • EventHttp::removeServerAlias() - Removes server alias


Binds an HTTP server on the specified address and port

  • « EventHttp::addServerAlias
  • EventHttp::__construct »
  • PHP Manual
  • EventHttp
  • Binds an HTTP server on the specified address and port

EventHttp::bind

(PECL event >= 1.2.6-beta)

EventHttp::bind — Binds an HTTP server on the specified address and port

Descripción

public EventHttp::bind ( string $address , int $port ) : void

Binds an HTTP server on the specified address and port.

Can be called multiple times to bind the same HTTP server to multiple different ports.

Parámetros

address

A string containing the IP address to listen(2) on.

port

The port number to listen on.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttp::bind() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};
if (!$http->bind("127.0.0.1", 8089)) {
    exit("bind(2) failed\n");
};

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$base->dispatch();
?>

El resultado del ejemplo sería algo similar a:

Client:

$ nc 127.0.0.1 8088
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

$ nc 127.0.0.1 8089
GET /unknown HTTP/1.0
Connection: close

HTTP/1.1 404 Not Found
Content-Type: text/html
Date: Wed, 13 Mar 2013 04:14:41 GMT
Content-Length: 149
Connection: close

<html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The requested URL /unknown was not found on this server.</p></body></html>

Server:
URI: /about
OK

Ver también

  • EventHttp::accept() - Makes an HTTP server accept connections on the specified socket stream or resource


Constructs EventHttp object(the HTTP server)

  • « EventHttp::bind
  • EventHttp::removeServerAlias »
  • PHP Manual
  • EventHttp
  • Constructs EventHttp object(the HTTP server)

EventHttp::__construct

(PECL event >= 1.2.6-beta)

EventHttp::__construct — Constructs EventHttp object(the HTTP server)

Descripción

public EventHttp::__construct ( EventBase $base , EventSslContext $ctx = null )

Constructs the HTTP server object.

Parámetros

base

Associated event base.

ctx

EventSslContext class object. Turns plain HTTP server into HTTPS server. It means that if ctx is configured correctly, then the underlying buffer events will be based on OpenSSL sockets. Thus, all traffic will pass through the SSL or TLS.

Nota:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

Valores devueltos

Returns EventHttp object.

Historial de cambios

Versión | Descripción
PECL event 1.9.0 | OpenSSL support (ctx) added.

Ejemplos

Ejemplo #1 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

El resultado del ejemplo sería algo similar a:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close


Removes server alias

  • « EventHttp::__construct
  • EventHttp::setAllowedMethods »
  • PHP Manual
  • EventHttp
  • Removes server alias

EventHttp::removeServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::removeServerAlias — Removes server alias

Descripción

public EventHttp::removeServerAlias ( string $alias ) : bool

Removes server alias added with EventHttp::addServerAlias()

Parámetros

alias

The alias to remove.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventHttp::addServerAlias() - Adds a server alias to the HTTP server object


Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

  • « EventHttp::removeServerAlias
  • EventHttp::setCallback »
  • PHP Manual
  • EventHttp
  • Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

EventHttp::setAllowedMethods

(PECL event >= 1.4.0-beta)

EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

Descripción

public EventHttp::setAllowedMethods ( int $methods ) : void

Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

If not supported they will generate a "405 Method not allowed" response.

By default this includes the following methods: GET , POST , HEAD , PUT , DELETE . See EventHttpRequest::CMD_* constants.

Parámetros

methods

A bit mask of EventHttpRequest::CMD_* constants .

Valores devueltos

No devuelve ningún valor.


Sets a callback for specified URI

  • « EventHttp::setAllowedMethods
  • EventHttp::setDefaultCallback »
  • PHP Manual
  • EventHttp
  • Sets a callback for specified URI

EventHttp::setCallback

(PECL event >= 1.4.0-beta)

EventHttp::setCallback — Sets a callback for specified URI

Descripción

public EventHttp::setCallback ( string $path , string $cb , string $arg = ? ) : void

Sets a callback for specified URI.

Parámetros

path

The path for which to invoke the callback.

cb

The callback callable that gets invoked on requested path . It should match the following prototype:

callback ( EventHttpRequest $req = NULL , mixed $arg = NULL ) : void

req

EventHttpRequest object.

arg

Custom data.

arg

Custom data.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttp::setCallback() example

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

El resultado del ejemplo sería algo similar a:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Ver también

  • EventHttp::setDefaultCallback() - Sets default callback to handle requests that are not caught by specific callbacks


Sets default callback to handle requests that are not caught by specific callbacks

  • « EventHttp::setCallback
  • EventHttp::setMaxBodySize »
  • PHP Manual
  • EventHttp
  • Sets default callback to handle requests that are not caught by specific callbacks

EventHttp::setDefaultCallback

(PECL event >= 1.4.0-beta)

EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks

Descripción

public EventHttp::setDefaultCallback ( string $cb , string $arg = ? ) : void

Sets default callback to handle requests that are not caught by specific callbacks

Parámetros

cb

The callback callable . It should match the following prototype:

callback ( EventHttpRequest $req = NULL , mixed $arg = NULL ) : void

req

EventHttpRequest object.

arg

Custom data.

arg

User custom data passed to the callback.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttp::setDefaultCallback() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});

$base->dispatch();
?>

Ver también

  • EventHttp::setCallback() - Sets a callback for specified URI


Sets maximum request body size

  • « EventHttp::setDefaultCallback
  • EventHttp::setMaxHeadersSize »
  • PHP Manual
  • EventHttp
  • Sets maximum request body size

EventHttp::setMaxBodySize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxBodySize — Sets maximum request body size

Descripción

public EventHttp::setMaxBodySize ( int $value ) : void

Sets maximum request body size.

Parámetros

value

The body size in bytes.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttp::setMaxHeadersSize() - Sets maximum HTTP header size


Sets maximum HTTP header size

  • « EventHttp::setMaxBodySize
  • EventHttp::setTimeout »
  • PHP Manual
  • EventHttp
  • Sets maximum HTTP header size

EventHttp::setMaxHeadersSize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxHeadersSize — Sets maximum HTTP header size

Descripción

public EventHttp::setMaxHeadersSize ( int $value ) : void

Sets maximum HTTP header size.

Parámetros

value

The header size in bytes.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttp::setMaxHeadersSize()


Sets the timeout for an HTTP request

  • « EventHttp::setMaxHeadersSize
  • EventHttpConnection »
  • PHP Manual
  • EventHttp
  • Sets the timeout for an HTTP request

EventHttp::setTimeout

(PECL event >= 1.4.0-beta)

EventHttp::setTimeout — Sets the timeout for an HTTP request

Descripción

public EventHttp::setTimeout ( int $value ) : void

Sets the timeout for an HTTP request.

Parámetros

value

The timeout in seconds.

Valores devueltos

No devuelve ningún valor.


The EventHttpConnection class

(PECL event >= 1.4.0-beta)

Introducción

Represents an HTTP connection.

Sinopsis de la Clase

EventHttpConnection {
/* Métodos */
public __construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port , EventSslContext $ctx = null )
public getBase ( ) : EventBase
public getPeer ( string &$address , int &$port ) : void
public makeRequest ( EventHttpRequest $req , int $type , string $uri ) : bool
public setCloseCallback ( callable $callback , mixed $data = ? ) : void
public setLocalAddress ( string $address ) : void
public setLocalPort ( int $port ) : void
public setMaxBodySize ( string $max_size ) : void
public setMaxHeadersSize ( string $max_size ) : void
public setRetries ( int $retries ) : void
public setTimeout ( int $timeout ) : void
}

Tabla de contenidos

  • EventHttpConnection::__construct — Constructs EventHttpConnection object
  • EventHttpConnection::getBase — Returns event base associated with the connection
  • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
  • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
  • EventHttpConnection::setCloseCallback — Set callback for connection close
  • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
  • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
  • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
  • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
  • EventHttpConnection::setRetries — Sets the retry limit for the connection
  • EventHttpConnection::setTimeout — Sets the timeout for the connection


Constructs EventHttpConnection object

  • « EventHttpConnection
  • EventHttpConnection::getBase »
  • PHP Manual
  • EventHttpConnection
  • Constructs EventHttpConnection object

EventHttpConnection::__construct

(PECL event >= 1.2.6-beta)

EventHttpConnection::__construct — Constructs EventHttpConnection object

Descripción

public EventHttpConnection::__construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port , EventSslContext $ctx = null )

Constructs EventHttpConnection object.

Parámetros

base

Associated event base.

dns_base

If dns_base is null, hostname resolution will block.

address

The address to connect to.

port

The port to connect to.

ctx

EventSslContext class object. Enables OpenSSL.

Nota:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

Valores devueltos

Returns EventHttpConnection object.

Historial de cambios

Versión | Descripción
PECL event 1.9.0 | OpenSSL support (ctx) added.


Returns event base associated with the connection

  • « EventHttpConnection::__construct
  • EventHttpConnection::getPeer »
  • PHP Manual
  • EventHttpConnection
  • Returns event base associated with the connection

EventHttpConnection::getBase

(PECL event >= 1.2.6-beta)

EventHttpConnection::getBase — Returns event base associated with the connection

Descripción

public EventHttpConnection::getBase ( ) : EventBase

Returns event base associated with the connection.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

On success returns EventBase object associated with the connection. Otherwise false.


Gets the remote address and port associated with the connection

  • « EventHttpConnection::getBase
  • EventHttpConnection::makeRequest »
  • PHP Manual
  • EventHttpConnection
  • Gets the remote address and port associated with the connection

EventHttpConnection::getPeer

(PECL event >= 1.2.6-beta)

EventHttpConnection::getPeer — Gets the remote address and port associated with the connection

Descripción

public EventHttpConnection::getPeer ( string &$address , int &$port ) : void

Gets the remote address and port associated with the connection

Parámetros

address

Address of the peer.

port

Port of the peer.

Valores devueltos

No devuelve ningún valor.


Makes an HTTP request over the specified connection

  • « EventHttpConnection::getPeer
  • EventHttpConnection::setCloseCallback »
  • PHP Manual
  • EventHttpConnection
  • Makes an HTTP request over the specified connection

EventHttpConnection::makeRequest

(PECL event >= 1.4.0-beta)

EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection

Descripción

public EventHttpConnection::makeRequest ( EventHttpRequest $req , int $type , string $uri ) : bool

Makes an HTTP request over the specified connection. type is one of EventHttpRequest::CMD_* constants.

Parámetros

req

The connection object over which to send the request.

type

One of EventHttpRequest::CMD_* constants .

uri

The URI associated with the request.

Valores devueltos

Returns true on success. Otherwise false.

Ejemplos

Ejemplo #1 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

El resultado del ejemplo sería algo similar a:

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

Ver también

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Set callback for connection close

  • « EventHttpConnection::makeRequest
  • EventHttpConnection::setLocalAddress »
  • PHP Manual
  • EventHttpConnection
  • Set callback for connection close

EventHttpConnection::setCloseCallback

(PECL event >= 1.8.0)

EventHttpConnection::setCloseCallback — Set callback for connection close

Descripción

public EventHttpConnection::setCloseCallback ( callable $callback , mixed $data = ? ) : void

Sets callback for connection close.

Parámetros

callback

Callback which is called when connection is closed. Should match the following prototype:

callback ( EventHttpConnection $conn = null , mixed $arg = null ) : void

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 EventHttpConnection::setCloseCallback() example

<?php
/*
 * Setting up close-connection callback
 *
 * The script handles closed connections using HTTP API.
 *
 * Usage:
 * 1) Launch the server:
 * $ php examples/http_closecb.php 4242
 *
 * 2) Launch a client in another terminal. Telnet-like
 * session should look like the following:
 *
 * $ nc -t 127.0.0.1 4242
 * GET / HTTP/1.0
 * Connection: close
 *
 * The server will output something similar to the following:
 *
 * HTTP/1.0 200 OK
 * Content-Type: multipart/x-mixed-replace;boundary=boundarydonotcross
 * Connection: close
 *
 * <html>
 *
 * 3) Terminate the client connection abruptly,
 * i.e. kill the process, or just press Ctrl-C.
 *
 * 4) Check if the server called _close_callback.
 * The script should output "_close_callback" string to standard output.
 *
 * 5) Check if the server's process has no orphaned connections,
 * e.g. with `lsof` utility.
 */

function _close_callback($conn)
{
    echo __FUNCTION__, PHP_EOL;
}

function _http_default($req, $dummy)
{
    $conn = $req->getConnection();
    $conn->setCloseCallback('_close_callback', NULL);

    /*
    By enabling Event::READ we protect the server against unclosed conections.
    This is a peculiarity of Libevent. The library disables Event::READ events
     on this connection, and the server is not notified about terminated
    connections.

    So each time client terminates connection abruptly, we get an orphaned
    connection. For instance, the following is a part of `lsof -p $PID | grep TCP`
    command after client has terminated connection:

    57-php     15057 ruslan  6u  unix 0xffff8802fb59c780   0t0  125187 socket
    58:php     15057 ruslan  7u  IPv4             125189   0t0     TCP *:4242 (LISTEN)
    59:php     15057 ruslan  8u  IPv4             124342   0t0     TCP localhost:4242->localhost:37375 (CLOSE_WAIT)

    where $PID is our process ID.

    The following block of code fixes such kind of orphaned connections.
     */
    $bev = $req->getBufferEvent();
    $bev->enable(Event::READ);
    // We have to free it explicitly. See
EventHttpRequest::getConnection()
$bev->free(); // we have to free it explicitly

    $req->addHeader(
        'Content-Type',
        'multipart/x-mixed-replace;boundary=boundarydonotcross',
        EventHttpRequest::OUTPUT_HEADER
    );

    $buf = new EventBuffer();
    $buf->add('<html>');

    $req->sendReply(200, "OK");
    $req->sendReplyChunk($buf);
}

$port = 4242;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setDefaultCallback("_http_default", NULL);
$http->bind("0.0.0.0", $port);
$base->loop();

?>


Sets the IP address from which HTTP connections are made

  • « EventHttpConnection::setCloseCallback
  • EventHttpConnection::setLocalPort »
  • PHP Manual
  • EventHttpConnection
  • Sets the IP address from which HTTP connections are made

EventHttpConnection::setLocalAddress

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made

Descripción

public EventHttpConnection::setLocalAddress ( string $address ) : void

Sets the IP address from which http connections are made.

Parámetros

address

The IP address from which HTTP connections are made.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpConnection::setLocalPort() - Sets the local port from which connections are made


Sets the local port from which connections are made

  • « EventHttpConnection::setLocalAddress
  • EventHttpConnection::setMaxBodySize »
  • PHP Manual
  • EventHttpConnection
  • Sets the local port from which connections are made

EventHttpConnection::setLocalPort

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalPort — Sets the local port from which connections are made

Descripción

public EventHttpConnection::setLocalPort ( int $port ) : void

Sets the local port from which connections are made.

Parámetros

port

The port number.

Valores devueltos

Ver también

  • EventHttpConnection::setLocalAddress() - Sets the IP address from which HTTP connections are made


Sets maximum body size for the connection

  • « EventHttpConnection::setLocalPort
  • EventHttpConnection::setMaxHeadersSize »
  • PHP Manual
  • EventHttpConnection
  • Sets maximum body size for the connection

EventHttpConnection::setMaxBodySize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection

Descripción

public EventHttpConnection::setMaxBodySize ( string $max_size ) : void

Sets maximum body size for the connection.

Parámetros

max_size

The maximum body size in bytes.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpConnection::setMaxHeadersSize() - Sets maximum header size


Sets maximum header size

  • « EventHttpConnection::setMaxBodySize
  • EventHttpConnection::setRetries »
  • PHP Manual
  • EventHttpConnection
  • Sets maximum header size

EventHttpConnection::setMaxHeadersSize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxHeadersSize — Sets maximum header size

Descripción

public EventHttpConnection::setMaxHeadersSize ( string $max_size ) : void

Sets maximum header size for the connection.

Parámetros

max_size

The maximum header size in bytes.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpConnection::setMaxBodySize() - Sets maximum body size for the connection


Sets the retry limit for the connection

  • « EventHttpConnection::setMaxHeadersSize
  • EventHttpConnection::setTimeout »
  • PHP Manual
  • EventHttpConnection
  • Sets the retry limit for the connection

EventHttpConnection::setRetries

(PECL event >= 1.2.6-beta)

EventHttpConnection::setRetries — Sets the retry limit for the connection

Descripción

public EventHttpConnection::setRetries ( int $retries ) : void

Sets the retry limit for the connection

Parámetros

retries

The retry limit. -1 means infinity.

Valores devueltos

No devuelve ningún valor.


Sets the timeout for the connection

  • « EventHttpConnection::setRetries
  • EventHttpRequest »
  • PHP Manual
  • EventHttpConnection
  • Sets the timeout for the connection

EventHttpConnection::setTimeout

(PECL event >= 1.2.6-beta)

EventHttpConnection::setTimeout — Sets the timeout for the connection

Descripción

public EventHttpConnection::setTimeout ( int $timeout ) : void

Sets the timeout for the connection

Parámetros

timeout

Timeout in seconds.

Valores devueltos

No devuelve ningún valor.


The EventHttpRequest class

(PECL event >= 1.4.0-beta)

Introducción

Represents an HTTP request.

Sinopsis de la Clase

EventHttpRequest {
/* Constants */
const int CMD_GET = 1 ;
const int CMD_POST = 2 ;
const int CMD_HEAD = 4 ;
const int CMD_PUT = 8 ;
const int CMD_DELETE = 16 ;
const int CMD_OPTIONS = 32 ;
const int CMD_TRACE = 64 ;
const int CMD_CONNECT = 128 ;
const int CMD_PATCH = 256 ;
const int INPUT_HEADER = 1 ;
const int OUTPUT_HEADER = 2 ;
/* Métodos */
public addHeader ( string $key , string $value , int $type ) : bool
public cancel ( ) : void
public clearHeaders ( ) : void
public closeConnection ( ) : void
public __construct ( callable $callback , mixed $data = null )
public findHeader ( string $key , string $type ) : void
public free ( ) : void
public closeConnection ( ) : EventBufferEvent
public getCommand ( ) : void
public closeConnection ( ) : EventHttpConnection
public getHost ( ) : string
public getInputBuffer ( ) : EventBuffer
public getInputHeaders ( ) : array
public getOutputBuffer ( ) : EventBuffer
public getOutputHeaders ( ) : void
public getResponseCode ( ) : int
public getUri ( ) : string
public removeHeader ( string $key , string $type ) : void
public sendError ( int $error , string $reason = null ) : void
public sendReply ( int $code , string $reason , EventBuffer $buf = ? ) : void
public sendReplyChunk ( EventBuffer $buf ) : void
public sendReplyEnd ( ) : void
public sendReplyStart ( int $code , string $reason ) : void
}

Constantes predefinidas

EventHttpRequest::CMD_GET

GET method(command)

EventHttpRequest::CMD_POST

POST method(command)

EventHttpRequest::CMD_HEAD

HEAD method(command)

EventHttpRequest::CMD_PUT

PUT method(command)

EventHttpRequest::CMD_DELETE

DELETE command(method)

EventHttpRequest::CMD_OPTIONS

OPTIONS method(command)

EventHttpRequest::CMD_TRACE

TRACE method(command)

EventHttpRequest::CMD_CONNECT

CONNECT method(command)

EventHttpRequest::CMD_PATCH

PATCH method(command)

EventHttpRequest::INPUT_HEADER

Request input header type.

EventHttpRequest::OUTPUT_HEADER

Request output header type.

Tabla de contenidos

  • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
  • EventHttpRequest::cancel — Cancels a pending HTTP request
  • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
  • EventHttpRequest::closeConnection — Closes associated HTTP connection
  • EventHttpRequest::__construct — Constructs EventHttpRequest object
  • EventHttpRequest::findHeader — Finds the value belonging a header
  • EventHttpRequest::free — Frees the object and removes associated events
  • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
  • EventHttpRequest::getCommand — Returns the request command(method)
  • EventHttpRequest::getConnection — Returns EventHttpConnection object
  • EventHttpRequest::getHost — Returns the request host
  • EventHttpRequest::getInputBuffer — Returns the input buffer
  • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
  • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
  • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
  • EventHttpRequest::getResponseCode — Returns the response code
  • EventHttpRequest::getUri — Returns the request URI
  • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
  • EventHttpRequest::sendError — Send an HTML error message to the client
  • EventHttpRequest::sendReply — Send an HTML reply to the client
  • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
  • EventHttpRequest::sendReplyStart — Initiate a chunked reply


Adds an HTTP header to the headers of the request

  • « EventHttpRequest
  • EventHttpRequest::cancel »
  • PHP Manual
  • EventHttpRequest
  • Adds an HTTP header to the headers of the request

EventHttpRequest::addHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request

Descripción

public EventHttpRequest::addHeader ( string $key , string $value , int $type ) : bool

Adds an HTTP header to the headers of the request.

Parámetros

key

Header name.

value

Header value.

type

One of EventHttpRequest::*_HEADER constants .

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventHttpRequest::removeHeader() - Removes an HTTP header from the headers of the request


Cancels a pending HTTP request

  • « EventHttpRequest::addHeader
  • EventHttpRequest::clearHeaders »
  • PHP Manual
  • EventHttpRequest
  • Cancels a pending HTTP request

EventHttpRequest::cancel

(PECL event >= 1.4.0-beta)

EventHttpRequest::cancel — Cancels a pending HTTP request

Descripción

public EventHttpRequest::cancel ( ) : void

Cancels a pending HTTP request.

Cancels an ongoing HTTP request. The callback associated with this request is not executed and the request object is freed. If the request is currently being processed, e.g. it is ongoing, the corresponding EventHttpConnection object is going to get reset.

A request cannot be canceled if its callback has executed already. A request may be canceled reentrantly from its chunked callback.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Removes all output headers from the header list of the request

  • « EventHttpRequest::cancel
  • EventHttpRequest::closeConnection »
  • PHP Manual
  • EventHttpRequest
  • Removes all output headers from the header list of the request

EventHttpRequest::clearHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request

Descripción

public EventHttpRequest::clearHeaders ( ) : void

Removes all output headers from the header list of the request.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Closes associated HTTP connection

  • « EventHttpRequest::clearHeaders
  • EventHttpRequest::__construct »
  • PHP Manual
  • EventHttpRequest
  • Closes associated HTTP connection

EventHttpRequest::closeConnection

(PECL event >= 1.8.0)

EventHttpRequest::closeConnection — Closes associated HTTP connection

Descripción

public EventHttpRequest::closeConnection ( ) : void

Closes HTTP connection associated with the request.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Constructs EventHttpRequest object

  • « EventHttpRequest::closeConnection
  • EventHttpRequest::findHeader »
  • PHP Manual
  • EventHttpRequest
  • Constructs EventHttpRequest object

EventHttpRequest::__construct

(PECL event >= 1.4.0-beta)

EventHttpRequest::__construct — Constructs EventHttpRequest object

Descripción

public EventHttpRequest::__construct ( callable $callback , mixed $data = null )

Constructs EventHttpRequest object.

Parámetros

callback

Gets invoked on requesting path. Should match the following prototype:

callback ( EventHttpRequest $req = null , mixed $arg = null ) : void
data

User custom data passed to the callback.

Valores devueltos

Returns EventHttpRequest object.

Ejemplos

Ejemplo #1 EventHttpRequest::__construct() example

<?php

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

Ver también

  • EventHttpRequest::cancel() - Cancels a pending HTTP request
  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Finds the value belonging a header

  • « EventHttpRequest::__construct
  • EventHttpRequest::free »
  • PHP Manual
  • EventHttpRequest
  • Finds the value belonging a header

EventHttpRequest::findHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::findHeader — Finds the value belonging a header

Descripción

public EventHttpRequest::findHeader ( string $key , string $type ) : void

Finds the value belonging a header.

Parámetros

key

The header name.

type

One of EventHttpRequest::*_HEADER constants .

Valores devueltos

Returns null if header not found.

Ver también

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Frees the object and removes associated events

  • « EventHttpRequest::findHeader
  • EventHttpRequest::getBufferEvent »
  • PHP Manual
  • EventHttpRequest
  • Frees the object and removes associated events

EventHttpRequest::free

(PECL event >= 1.4.0-beta)

EventHttpRequest::free — Frees the object and removes associated events

Descripción

public EventHttpRequest::free ( ) : void

Frees the object and removes associated events.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Returns EventBufferEvent object

  • « EventHttpRequest::free
  • EventHttpRequest::getCommand »
  • PHP Manual
  • EventHttpRequest
  • Returns EventBufferEvent object

EventHttpRequest::getBufferEvent

(PECL event >= 1.8.0)

EventHttpRequest::getBufferEvent — Returns EventBufferEvent object

Descripción

public EventHttpRequest::closeConnection ( ) : EventBufferEvent

Returns EventBufferEvent object which represents buffer event that the connection is using.

Advertencia

The reference counter of the returned object will be incremented by one to protect internal structures against premature destruction when the method is called from a user callback. So the EventBufferEvent object should be freed explicitly with EventBufferEvent::free() method. Otherwise memory will leak.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns EventBufferEvent object.

Ver también

  • EventHttpRequest::getConnection() - Returns EventHttpConnection object


Returns the request command(method)

  • « EventHttpRequest::getBufferEvent
  • EventHttpRequest::getConnection »
  • PHP Manual
  • EventHttpRequest
  • Returns the request command(method)

EventHttpRequest::getCommand

(PECL event >= 1.4.0-beta)

EventHttpRequest::getCommand — Returns the request command(method)

Descripción

public EventHttpRequest::getCommand ( ) : void

Returns the request command, one of EventHttpRequest::CMD_* constants.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the request command, one of EventHttpRequest::CMD_* constants.


Returns EventHttpConnection object

  • « EventHttpRequest::getCommand
  • EventHttpRequest::getHost »
  • PHP Manual
  • EventHttpRequest
  • Returns EventHttpConnection object

EventHttpRequest::getConnection

(PECL event >= 1.8.0)

EventHttpRequest::getConnection — Returns EventHttpConnection object

Descripción

public EventHttpRequest::closeConnection ( ) : EventHttpConnection

Returns EventHttpConnection object which represents HTTP connection associated with the request.

Advertencia

Libevent API allows HTTP request objects to be not bound to any HTTP connection. Therefore we can't unambiguously associate EventHttpRequest with EventHttpConnection . Thus, we construct EventHttpConnection object on-the-fly. Having no information about the event base, DNS base and connection-close callback, we just leave these fields unset.

EventHttpRequest::getConnection() method is usually useful when we need to set up a callback on connection close. See EventHttpConnection::setCloseCallback() .

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns EventHttpConnection object.

Ver también

  • EventHttpConnection::setCloseCallback() - Set callback for connection close
  • EventHttpRequest::getBufferEvent() - Returns EventBufferEvent object


Returns the request host

  • « EventHttpRequest::getConnection
  • EventHttpRequest::getInputBuffer »
  • PHP Manual
  • EventHttpRequest
  • Returns the request host

EventHttpRequest::getHost

(PECL event >= 1.4.0-beta)

EventHttpRequest::getHost — Returns the request host

Descripción

public EventHttpRequest::getHost ( ) : string

Returns the request host.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the request host.

Ver también

  • EventHttpRequest::getUri() - Returns the request URI
  • EventHttpRequest::getCommand() - Returns the request command(method)


Returns the input buffer

  • « EventHttpRequest::getHost
  • EventHttpRequest::getInputHeaders »
  • PHP Manual
  • EventHttpRequest
  • Returns the input buffer

EventHttpRequest::getInputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputBuffer — Returns the input buffer

Descripción

public EventHttpRequest::getInputBuffer ( ) : EventBuffer

Returns the input buffer.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the input buffer.

Ver también

  • EventHttpRequest::getOutputBuffer() - Returns the output buffer of the request


Returns associative array of the input headers

  • « EventHttpRequest::getInputBuffer
  • EventHttpRequest::getOutputBuffer »
  • PHP Manual
  • EventHttpRequest
  • Returns associative array of the input headers

EventHttpRequest::getInputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputHeaders — Returns associative array of the input headers

Descripción

public EventHttpRequest::getInputHeaders ( ) : array

Returns associative array of the input headers.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns associative array of the input headers.

Ver también

  • EventHttpRequest::getOutputHeaders() - Returns associative array of the output headers


Returns the output buffer of the request

  • « EventHttpRequest::getInputHeaders
  • EventHttpRequest::getOutputHeaders »
  • PHP Manual
  • EventHttpRequest
  • Returns the output buffer of the request

EventHttpRequest::getOutputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputBuffer — Returns the output buffer of the request

Descripción

public EventHttpRequest::getOutputBuffer ( ) : EventBuffer

Returns the output buffer of the request.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the output buffer of the request.

Ver también

  • EventHttpRequest::getInputBuffer() - Returns the input buffer


Returns associative array of the output headers

  • « EventHttpRequest::getOutputBuffer
  • EventHttpRequest::getResponseCode »
  • PHP Manual
  • EventHttpRequest
  • Returns associative array of the output headers

EventHttpRequest::getOutputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputHeaders — Returns associative array of the output headers

Descripción

public EventHttpRequest::getOutputHeaders ( ) : void

Returns associative array of the output headers.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • EventHttpRequest::getInputHeaders() - Returns associative array of the input headers


Returns the response code

  • « EventHttpRequest::getOutputHeaders
  • EventHttpRequest::getUri »
  • PHP Manual
  • EventHttpRequest
  • Returns the response code

EventHttpRequest::getResponseCode

(PECL event >= 1.4.0-beta)

EventHttpRequest::getResponseCode — Returns the response code

Descripción

public EventHttpRequest::getResponseCode ( ) : int

Returns the response code.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the response code of the request.

Ver también

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getUri() - Returns the request URI


Returns the request URI

  • « EventHttpRequest::getResponseCode
  • EventHttpRequest::removeHeader »
  • PHP Manual
  • EventHttpRequest
  • Returns the request URI

EventHttpRequest::getUri

(PECL event >= 1.4.0-beta)

EventHttpRequest::getUri — Returns the request URI

Descripción

public EventHttpRequest::getUri ( ) : string

Returns the request URI

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the request URI

Ver también

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getResponseCode() - Returns the response code


Removes an HTTP header from the headers of the request

  • « EventHttpRequest::getUri
  • EventHttpRequest::sendError »
  • PHP Manual
  • EventHttpRequest
  • Removes an HTTP header from the headers of the request

EventHttpRequest::removeHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request

Descripción

public EventHttpRequest::removeHeader ( string $key , string $type ) : void

Removes an HTTP header from the headers of the request.

Parámetros

key

The header name.

type

type is one of EventHttpRequest::*_HEADER constants.

Valores devueltos

Removes an HTTP header from the headers of the request.

Ver también

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Send an HTML error message to the client

  • « EventHttpRequest::removeHeader
  • EventHttpRequest::sendReply »
  • PHP Manual
  • EventHttpRequest
  • Send an HTML error message to the client

EventHttpRequest::sendError

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendError — Send an HTML error message to the client

Descripción

public EventHttpRequest::sendError ( int $error , string $reason = null ) : void

Send an HTML error message to the client.

Parámetros

error

The HTTP error code.

reason

A brief explanation ofthe error. If null, the standard meaning of the error code will be used.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 EventHttpRequest::sendError() example

<?php
function _http_400($req) {
    $req->sendError(400);
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setCallback("/err400", "_http_400");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

Ver también

  • EventHttpRequest::sendReply() - Send an HTML reply to the client


Send an HTML reply to the client

  • « EventHttpRequest::sendError
  • EventHttpRequest::sendReplyChunk »
  • PHP Manual
  • EventHttpRequest
  • Send an HTML reply to the client

EventHttpRequest::sendReply

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReply — Send an HTML reply to the client

Descripción

public EventHttpRequest::sendReply ( int $code , string $reason , EventBuffer $buf = ? ) : void

Send an HTML reply to the client. The body of the reply consists of data in optional buf parameter.

Parámetros

code

The HTTP response code to send.

reason

A brief message to send with the response code.

buf

The body of the response.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpRequest::sendError() - Send an HTML error message to the client
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply


Send another data chunk as part of an ongoing chunked reply

  • « EventHttpRequest::sendReply
  • EventHttpRequest::sendReplyEnd »
  • PHP Manual
  • EventHttpRequest
  • Send another data chunk as part of an ongoing chunked reply

EventHttpRequest::sendReplyChunk

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply

Descripción

public EventHttpRequest::sendReplyChunk ( EventBuffer $buf ) : void

Send another data chunk as part of an ongoing chunked reply. After calling this method buf will be empty.

Parámetros

buf

The data chunk to send as part of the reply.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate


Complete a chunked reply, freeing the request as appropriate

  • « EventHttpRequest::sendReplyChunk
  • EventHttpRequest::sendReplyStart »
  • PHP Manual
  • EventHttpRequest
  • Complete a chunked reply, freeing the request as appropriate

EventHttpRequest::sendReplyEnd

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate

Descripción

public EventHttpRequest::sendReplyEnd ( ) : void

Complete a chunked reply, freeing the request as appropriate.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply


Initiate a chunked reply

  • « EventHttpRequest::sendReplyEnd
  • EventListener »
  • PHP Manual
  • EventHttpRequest
  • Initiate a chunked reply

EventHttpRequest::sendReplyStart

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyStart — Initiate a chunked reply

Descripción

public EventHttpRequest::sendReplyStart ( int $code , string $reason ) : void

Initiate a reply that uses Transfer-Encoding chunked .

This allows the caller to stream the reply back to the client and is useful when either not all of the reply data is immediately available or when sending very large replies.

The caller needs to supply data chunks with EventHttpRequest::sendReplyChunk() and complete the reply by calling EventHttpRequest::sendReplyEnd() .

Parámetros

code

The HTTP response code to send.

reason

A brief message to send with the response code.

Valores devueltos

No devuelve ningún valor.

Ver también

  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate


The EventListener class

(PECL event >= 1.5.0)

Introducción

Represents a connection listener.

Sinopsis de la Clase

final EventListener {
/* Constants */
const int OPT_LEAVE_SOCKETS_BLOCKING = 1 ;
const int OPT_CLOSE_ON_FREE = 2 ;
const int OPT_CLOSE_ON_EXEC = 4 ;
const int OPT_REUSEABLE = 8 ;
const int OPT_THREADSAFE = 16 ;
/* Propiedades */
public readonly int $fd ;
/* Métodos */
public __construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )
public disable ( ) : bool
public enable ( ) : bool
public getBase ( ) : void
public static getSocketName ( string &$address , mixed &$port = ? ) : bool
public setCallback ( callable $cb , mixed $arg = null ) : void
public setErrorCallback ( string $cb ) : void
}

Propiedades

fd

Numeric file descriptor of the underlying socket. (Added in event-1.6.0 .)

Constantes predefinidas

EventListener::OPT_LEAVE_SOCKETS_BLOCKING

By default Libevent turns underlying file descriptors, or sockets, to non-blocking mode. This flag tells Libevent to leave them in blocking mode.

EventListener::OPT_CLOSE_ON_FREE

If this option is set, the connection listener closes its underlying socket when the EventListener object is freed.

EventListener::OPT_CLOSE_ON_EXEC

If this option is set, the connection listener sets the close-on-exec flag on the underlying listener socket. See platform documentation for fcntl and FD_CLOEXEC for more information.

EventListener::OPT_REUSEABLE

By default on some platforms, once a listener socket is closed, no other socket can bind to the same port until a while has passed. Setting this option makes Libevent mark the socket as reusable, so that once it is closed, another socket can be opened to listen on the same port.

EventListener::OPT_THREADSAFE

Allocate locks for the listener, so that it’s safe to use it from multiple threads.

Tabla de contenidos

  • EventListener::__construct — Creates new connection listener associated with an event base
  • EventListener::disable — Disables an event connect listener object
  • EventListener::enable — Enables an event connect listener object
  • EventListener::getBase — Returns event base associated with the event listener
  • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound
  • EventListener::setCallback — The setCallback purpose
  • EventListener::setErrorCallback — Set event listener's error callback


Creates new connection listener associated with an event base

  • « EventListener
  • EventListener::disable »
  • PHP Manual
  • EventListener
  • Creates new connection listener associated with an event base

EventListener::__construct

(PECL event >= 1.2.6-beta)

EventListener::__construct — Creates new connection listener associated with an event base

Descripción

public EventListener::__construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )

Creates new connection listener associated with an event base.

Parámetros

base

Associated event base.

cb

A callable that will be invoked when new connection received.

data

Custom user data attached to cb .

flags

Bit mask of EventListener::OPT_* constants. See EventListener constants .

backlog

Controls the maximum number of pending connections that the network stack should allow to wait in a not-yet-accepted state at any time; see documentation for your system’s listen function for more details. If backlog is negative, Libevent tries to pick a good value for the backlog ; if it is zero, Event assumes that listen is already called on the socket( target )

target

May be string, socket resource, or a stream associated with a socket. In case if target is a string, the string will be parsed as network address. It will be interpreted as a UNIX domain socket path, if prefixed with 'unix:' , e.g. 'unix:/tmp/my.sock' .

Valores devueltos

Returns EventListener object representing the event connection listener.

Historial de cambios

Versión | Descripción
PECL event 1.5.0 | UNIX domain sockets' support added.

Ejemplos

Ejemplo #1 EventListener::__construct() example

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>


Disables an event connect listener object

  • « EventListener::__construct
  • EventListener::enable »
  • PHP Manual
  • EventListener
  • Disables an event connect listener object

EventListener::disable

(PECL event >= 1.2.6-beta)

EventListener::disable — Disables an event connect listener object

Descripción

public EventListener::disable ( ) : bool

Disables an event connect listener object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventListener::enable() - Enables an event connect listener object


Enables an event connect listener object

  • « EventListener::disable
  • EventListener::getBase »
  • PHP Manual
  • EventListener
  • Enables an event connect listener object

EventListener::enable

(PECL event >= 1.2.6-beta)

EventListener::enable — Enables an event connect listener object

Descripción

public EventListener::enable ( ) : bool

Enables an event connect listener object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • EventListener::disable() - Disables an event connect listener object


Returns event base associated with the event listener

  • « EventListener::enable
  • EventListener::getSocketName »
  • PHP Manual
  • EventListener
  • Returns event base associated with the event listener

EventListener::getBase

(PECL event >= 1.2.6-beta)

EventListener::getBase — Returns event base associated with the event listener

Descripción

public EventListener::getBase ( ) : void

Returns event base associated with the event listener.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns event base associated with the event listener.


Retreives the current address to which the listener's socket is bound

  • « EventListener::getBase
  • EventListener::setCallback »
  • PHP Manual
  • EventListener
  • Retreives the current address to which the listener's socket is bound

EventListener::getSocketName

(PECL event >= 1.5.0)

EventListener::getSocketName — Retreives the current address to which the listener's socket is bound

Descripción

public static EventListener::getSocketName ( string &$address , mixed &$port = ? ) : bool

Retreives the current address to which the listener's socket is bound.

Parámetros

address

Output parameter. IP-address depending on the socket address family.

port

Output parameter. The port the socket is bound to.

Valores devueltos

Returns true on success. Otherwise false.


The setCallback purpose

  • « EventListener::getSocketName
  • EventListener::setErrorCallback »
  • PHP Manual
  • EventListener
  • The setCallback purpose

EventListener::setCallback

(PECL event >= 1.2.6-beta)

EventListener::setCallback — The setCallback purpose

Descripción

public EventListener::setCallback ( callable $cb , mixed $arg = null ) : void

Adjust event connect listener's callback and optionally the callback argument.

Parámetros

cb

The new callback for new connections. Ignored if null.

Should match the following prototype:

callback ( EventListener $listener = null , mixed $fd = null , array $address = null , mixed $arg = null ) : void

listener

The EventListener object.

fd

The file descriptor or a resource associated with the listener.

address

Array of two elements: IP address and the server port.

arg

User custom data attached to the callback.

arg

Custom user data attached to the callback. Ignored if null.

Valores devueltos

No devuelve ningún valor.


Set event listener's error callback

  • « EventListener::setCallback
  • EventSslContext »
  • PHP Manual
  • EventListener
  • Set event listener's error callback

EventListener::setErrorCallback

(PECL event >= 1.2.6-beta)

EventListener::setErrorCallback — Set event listener's error callback

Descripción

public EventListener::setErrorCallback ( string $cb ) : void

Set event listener's error callback

Parámetros

cb

The error callback. Should match the following prototype:

callback ( EventListener $listener = null , mixed $data = null ) : void

listener

The EventListener object.

data

User custom data attached to the callback.

Valores devueltos

Ver también

  • EventListener::setCallback() - The setCallback purpose


The EventSslContext class

(PECL event >= 1.2.6-beta)

Introducción

Represents SSL_CTX structure. Provides methods and properties to configure the SSL context.

Sinopsis de la Clase

final EventSslContext {
/* Constants */
const int SSLv2_CLIENT_METHOD = 1 ;
const int SSLv3_CLIENT_METHOD = 2 ;
const int SSLv23_CLIENT_METHOD = 3 ;
const int TLS_CLIENT_METHOD = 4 ;
const int SSLv2_SERVER_METHOD = 5 ;
const int SSLv3_SERVER_METHOD = 6 ;
const int SSLv23_SERVER_METHOD = 7 ;
const int TLS_SERVER_METHOD = 8 ;
const int OPT_LOCAL_CERT = 1 ;
const int OPT_LOCAL_PK = 2 ;
const int OPT_PASSPHRASE = 3 ;
const int OPT_CA_FILE = 4 ;
const int OPT_CA_PATH = 5 ;
const int OPT_ALLOW_SELF_SIGNED = 6 ;
const int OPT_VERIFY_PEER = 7 ;
const int OPT_VERIFY_DEPTH = 8 ;
const int OPT_CIPHERS = 9 ;
/* Propiedades */
public string $local_cert ;
public string $local_pk ;
/* Métodos */
public __construct ( string $method , string $options )
}

Propiedades

local_cert

Path to local certificate file on filesystem. It must be a PEM-encoded file which contains certificate. It can optionally contain the certificate chain of issuers.

local_pk

Path to local private key file

Constantes predefinidas

EventSslContext::SSLv2_CLIENT_METHOD

SSLv2 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_CLIENT_METHOD

SSLv3 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_CLIENT_METHOD

SSLv23 client method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_CLIENT_METHOD

TLS client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv2_SERVER_METHOD

SSLv2 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_SERVER_METHOD

SSLv3 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_SERVER_METHOD

SSLv23 server method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_SERVER_METHOD

TLS server method. See SSL_CTX_new(3) man page.

EventSslContext::OPT_LOCAL_CERT

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of local certificate.

EventSslContext::OPT_LOCAL_PK

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of the private key.

EventSslContext::OPT_PASSPHRASE

Key for an item of the options' array used in EventSslContext::__construct() . Represents passphrase of the certificate.

EventSslContext::OPT_CA_FILE

Key for an item of the options' array used in EventSslContext::__construct() . Represents path of the certificate authority file.

EventSslContext::OPT_CA_PATH

Key for an item of the options' array used in EventSslContext::__construct() . Represents path where the certificate authority file should be searched for.

EventSslContext::OPT_ALLOW_SELF_SIGNED

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that allows self-signed certificates.

EventSslContext::OPT_VERIFY_PEER

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that tells Event to verify peer.

EventSslContext::OPT_VERIFY_DEPTH

Key for an item of the options' array used in EventSslContext::__construct() . Represents maximum depth for the certificate chain verification that shall be allowed for the SSL context.

EventSslContext::OPT_CIPHERS

Key for an item of the options' array used in EventSslContext::__construct() . Represents the cipher list for the SSL context.

Tabla de contenidos

  • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes


Constructs an OpenSSL context for use with Event classes

  • « EventSslContext
  • EventUtil »
  • PHP Manual
  • EventSslContext
  • Constructs an OpenSSL context for use with Event classes

EventSslContext::__construct

(PECL event >= 1.2.6-beta)

EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes

Descripción

public EventSslContext::__construct ( string $method , string $options )

Creates SSL context holding pointer to SSL_CTX (see the system manual).

Parámetros

method

One of EventSslContext::*_METHOD constants .

options

Associative array of SSL context options One of EventSslContext::OPT_* constants .

Valores devueltos

Returns EventSslContext object.

Ejemplos

Ejemplo #1 EventSslContext::__construct() example

<?php
$ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array(
     EventSslContext::OPT_LOCAL_CERT        => $local_cert,
     EventSslContext::OPT_LOCAL_PK          => $local_pk,
     EventSslContext::OPT_PASSPHRASE        => "echo server",
     EventSslContext::OPT_VERIFY_PEER       => true,
     EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
));
?>


The EventUtil class

(PECL event >= 1.5.0)

Introducción

EventUtil is a singleton with supplimentary methods and constants.

Sinopsis de la Clase

final EventUtil {
/* Constants */
const int AF_INET = 2 ;
const int AF_INET6 = 10 ;
const int AF_UNSPEC = 0 ;
const int LIBEVENT_VERSION_NUMBER = 33559808 ;
const int SO_DEBUG = 1 ;
const int SO_REUSEADDR = 2 ;
const int SO_KEEPALIVE = 9 ;
const int SO_DONTROUTE = 5 ;
const int SO_LINGER = 13 ;
const int SO_BROADCAST = 6 ;
const int SO_OOBINLINE = 10 ;
const int SO_SNDBUF = 7 ;
const int SO_RCVBUF = 8 ;
const int SO_SNDLOWAT = 19 ;
const int SO_RCVLOWAT = 18 ;
const int SO_SNDTIMEO = 21 ;
const int SO_RCVTIMEO = 20 ;
const int SO_TYPE = 3 ;
const int SO_ERROR = 4 ;
const int SOL_SOCKET = 1 ;
const int SOL_TCP = 6 ;
const int SOL_UDP = 17 ;
const int IPPROTO_IP = 0 ;
const int IPPROTO_IPV6 = 41 ;
/* Métodos */
abstract public __construct ( )
public static getLastSocketErrno ( mixed $socket = null ) : int
public static getLastSocketError ( mixed $socket = ? ) : string
public static getSocketFd ( mixed $socket ) : int
public static getSocketName ( mixed $socket , string &$address , mixed &$port = ? ) : bool
public static setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval ) : bool
public static sslRandPoll ( ) : void
}

Constantes predefinidas

EventUtil::AF_INET

IPv4 address family

EventUtil::AF_INET6

IPv6 address family

EventUtil::AF_UNSPEC

Unspecified IP address family

EventUtil::SO_DEBUG

Socket option. Enable socket debugging. Only allowed for processes with the CAP_NET_ADMIN capability or an effective user ID of 0 . (Added in event-1.6.0.)

EventUtil::SO_REUSEADDR

Socket option. Indicates that the rules used in validating addresses supplied in a bind(2) call should allow reuse of local addresses. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_KEEPALIVE

Socket option. Enable sending of keep-alive messages on connection-oriented sockets. Expects an integer boolean flag. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_DONTROUTE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_LINGER

Socket option. When enabled, a close(2) or shutdown(2) will not return until all queued messages for the socket have been successfully sent or the linger timeout has been reached. Otherwise, the call returns immediately and the closing is done in the background. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_BROADCAST

Socket option. Reports whether transmission of broadcast messages is supported. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_OOBINLINE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_TYPE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_ERROR

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_SOCKET

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_TCP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_UDP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IP

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IPV6

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::LIBEVENT_VERSION_NUMBER

Libevent' version number at the time when Event extension had been compiled with the library.

Tabla de contenidos

  • EventUtil::__construct — The abstract constructor
  • EventUtil::getLastSocketErrno — Returns the most recent socket error number
  • EventUtil::getLastSocketError — Returns the most recent socket error
  • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
  • EventUtil::getSocketName — Retreives the current address to which the socket is bound
  • EventUtil::setSocketOption — Sets socket options
  • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()


The abstract constructor

  • « EventUtil
  • EventUtil::getLastSocketErrno »
  • PHP Manual
  • EventUtil
  • The abstract constructor

EventUtil::__construct

(PECL event >= 1.2.6-beta)

EventUtil::__construct — The abstract constructor

Descripción

abstract public EventUtil::__construct ( )

EventUtil is a singleton. Therefore the constructor is abstract, and it is impossible to create objects based on this class.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Returns the most recent socket error number

  • « EventUtil::__construct
  • EventUtil::getLastSocketError »
  • PHP Manual
  • EventUtil
  • Returns the most recent socket error number

EventUtil::getLastSocketErrno

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketErrno — Returns the most recent socket error number

Descripción

public static EventUtil::getLastSocketErrno ( mixed $socket = null ) : int

Returns the most recent socket error number( errno ).

Parámetros

socket

Socket resource, stream or a file descriptor of a socket.

Valores devueltos

Returns the most recent socket error number( errno ).

Ver también

  • EventUtil::getLastSocketError() - Returns the most recent socket error


Returns the most recent socket error

  • « EventUtil::getLastSocketErrno
  • EventUtil::getSocketFd »
  • PHP Manual
  • EventUtil
  • Returns the most recent socket error

EventUtil::getLastSocketError

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketError — Returns the most recent socket error

Descripción

public static EventUtil::getLastSocketError ( mixed $socket = ? ) : string

Returns the most recent socket error.

Parámetros

socket

Socket resource, stream or a file descriptor of a socket.

Valores devueltos

Returns the most recent socket error.

Ver también

  • EventUtil::getLastSocketErrno() - Returns the most recent socket error number


Returns numeric file descriptor of a socket, or stream

  • « EventUtil::getLastSocketError
  • EventUtil::getSocketName »
  • PHP Manual
  • EventUtil
  • Returns numeric file descriptor of a socket, or stream

EventUtil::getSocketFd

(PECL event >= 1.7.0)

EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream

Descripción

public static EventUtil::getSocketFd ( mixed $socket ) : int

Returns numeric file descriptor of a socket or stream specified by socket argument just like the Event extension does it internally for all methods accepting socket resource or stream.

Parámetros

socket

Socket resource or stream.

Valores devueltos

Returns numeric file descriptor of a socket, or stream. EventUtil::getSocketFd() returns false in case if it is whether failed to recognize the type of the underlying file, or detected that the file descriptor associated with socket is not valid.


Retreives the current address to which the socket is bound

  • « EventUtil::getSocketFd
  • EventUtil::setSocketOption »
  • PHP Manual
  • EventUtil
  • Retreives the current address to which the socket is bound

EventUtil::getSocketName

(PECL event >= 1.5.0)

EventUtil::getSocketName — Retreives the current address to which the socket is bound

Descripción

public static EventUtil::getSocketName ( mixed $socket , string &$address , mixed &$port = ? ) : bool

Retreives the current address to which the socket is bound.

Parámetros

socket

Socket resource, stream or a file descriptor of a socket.

address

Output parameter. IP-address, or the UNIX domain socket path depending on the socket address family.

port

Output parameter. The port the socket is bound to. Has no meaning for UNIX domain sockets.

Valores devueltos

Returns true on success. Otherwise false.


Sets socket options

  • « EventUtil::getSocketName
  • EventUtil::sslRandPoll »
  • PHP Manual
  • EventUtil
  • Sets socket options

EventUtil::setSocketOption

(PECL event >= 1.6.0)

EventUtil::setSocketOption — Sets socket options

Descripción

public static EventUtil::setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval ) : bool

Sets socket options.

Parámetros

socket

Socket resource, stream, or numeric file descriptor associated with the socket.

level

One of EventUtil::SOL_* constants. Specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of EventUtil::SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function. See EventUtil constants .

optname

Option name(type). Has the same meaning as corresponding parameter of socket_get_option() function. See EventUtil constants .

optval

Accepts the same values as optval parameter of the socket_get_option() function.

Valores devueltos

Returns true on success. Otherwise false.

Ver también

  • socket_get_option() - Obtiene las opciones de socket para el socket
  • socket_set_option() - Establece las opciones de socket para el socket


Generates entropy by means of OpenSSL's RAND_poll()

  • « EventUtil::setSocketOption
  • FTP »
  • PHP Manual
  • EventUtil
  • Generates entropy by means of OpenSSL's RAND_poll()

EventUtil::sslRandPoll

(PECL event >= 1.2.6-beta)

EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()

Descripción

public static EventUtil::sslRandPoll ( ) : void

Generates entropy by means of OpenSSL's RAND_poll() (see the system manual).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


FTP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Funciones de FTP
    • ftp_alloc — Reserva espacio para que un archivo sea cargado
    • ftp_append — Append the contents of a file to another file on the FTP server
    • ftp_cdup — Vuelve al directorio padre
    • ftp_chdir — Cambia el directorio actual en un servidor FTP
    • ftp_chmod — Establecer permisos en un archivo via FTP
    • ftp_close — Cierra una conexión FTP
    • ftp_connect — Abre una conexión FTP
    • ftp_delete — Elimina un archivo en el servidor FTP
    • ftp_exec — Solicita la ejecución de un comando en el servidor FTP
    • ftp_fget — Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
    • ftp_fput — Carga un archivo abierto en el servidor FTP
    • ftp_get_option — Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual
    • ftp_get — Descarga un archivo desde el servidor FTP
    • ftp_login — Inicia sesión en una conexión FTP
    • ftp_mdtm — Devuelve el tiempo de la última modificación del archivo dado
    • ftp_mkdir — Crea un directorio
    • ftp_mlsd — Returns a list of files in the given directory
    • ftp_nb_continue — Continúa recuperando/enviando un archivo (modo no-bloqueo)
    • ftp_nb_fget — Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)
    • ftp_nb_fput — Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
    • ftp_nb_get — Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
    • ftp_nb_put — Almacena un archivo en el servidor FTP (modo no-bloqueo)
    • ftp_nlist — Devuelve una lista de los archivos que se encuentran en el directorio especificado
    • ftp_pasv — Activa o desactiva el modo pasivo
    • ftp_put — Carga un archivo al servidor FTP
    • ftp_pwd — Devuelve el nombre del directorio actual
    • ftp_quit — Alias de ftp_close
    • ftp_raw — Envía un comando arbitrario a un servidor FTP
    • ftp_rawlist — Devuelve una lista detallada de archivos en el directorio especificado
    • ftp_rename — Renombra un archivo o un directorio en el servidor FTP
    • ftp_rmdir — Elimina un directorio
    • ftp_set_option — Establecer varias opciones FTP de tiempo de ejecución
    • ftp_site — Envía un comando SITE al servidor
    • ftp_size — Devuelve el tamaño del archivo dado
    • ftp_ssl_connect — Abre una conexión segura SSL-FTP
    • ftp_systype — Devuelve el identificador del tipo de sistema del servidor FTP remoto


Introducción

Las funciones en esta extensión implementan el acceso por parte del cliente a los servidores de ficheros que "hablen" el Protocolo de Transferencia de Ficheros (FTP) como se define en » http://www.faqs.org/rfcs/rfc959. Esta extensión tiene como propósito el acceso detallado a un servidor FTP proporcionando una amplia gama de controles para el script en ejecución. Si sólo desea leer o escribir un fichero en un servidor FTP, considere el uso de las envolturas ftp:// con las funciones de sistema de ficheros, las cuales proporcionan una interfaz más sencilla e intuitiva.


Instalación

Para usar las funciones FTP con su configuración de PHP, debe agregar la opción --enable-ftp cuando instale PHP.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Tipos de recursos

Esta extensión usa un tipo de recurso, que es el identificador de enlace de la conexión FTP, devuelto por ftp_connect() o ftp_ssl_connect().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

FTP_ASCII (integer)

FTP_TEXT (integer)

FTP_BINARY (integer)

FTP_IMAGE (integer)

FTP_TIMEOUT_SEC (integer)

Vea ftp_set_option() para más información.

Las siguientes constantes fueron introducidas en PHP 4.3.0.

FTP_AUTOSEEK (integer)

Vea ftp_set_option() para más información.

FTP_AUTORESUME (integer)

Determina automáticamente la posición de continuación y la posición de comienzo para peticiones GET y PUT (sólo funciona si FTP_AUTOSEEK está habilitado)

FTP_FAILED (integer)

La transferencia asincrónica ha fallado

FTP_FINISHED (integer)

La transferencia asincrónica ha terminado

FTP_MOREDATA (integer)

La transferencia asincrónica está aun activa


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • FTP
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo #1 Ejemplo FTP

<?php
// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar una sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// verificar la conexión
if ((!$conn_id) || (!$login_result)) {
    echo "¡La conexión FTP ha fallado!";
    echo "Se intentó conectar al $ftp_server por el usuario $ftp_user_name";
    exit;
} else {
    echo "Conexión a $ftp_server realizada con éxito, por el usuario $ftp_user_name";
}

// subir un archivo
$upload = ftp_put($conn_id, $destination_file, $source_file, FTP_BINARY);

// comprobar el estado de la subida
if (!$upload) {
    echo "¡La subida FTP ha fallado!";
} else {
    echo "Subida de $source_file a $ftp_server como $destination_file";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>


Funciones de FTP

Tabla de contenidos

  • ftp_alloc — Reserva espacio para que un archivo sea cargado
  • ftp_append — Append the contents of a file to another file on the FTP server
  • ftp_cdup — Vuelve al directorio padre
  • ftp_chdir — Cambia el directorio actual en un servidor FTP
  • ftp_chmod — Establecer permisos en un archivo via FTP
  • ftp_close — Cierra una conexión FTP
  • ftp_connect — Abre una conexión FTP
  • ftp_delete — Elimina un archivo en el servidor FTP
  • ftp_exec — Solicita la ejecución de un comando en el servidor FTP
  • ftp_fget — Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
  • ftp_fput — Carga un archivo abierto en el servidor FTP
  • ftp_get_option — Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual
  • ftp_get — Descarga un archivo desde el servidor FTP
  • ftp_login — Inicia sesión en una conexión FTP
  • ftp_mdtm — Devuelve el tiempo de la última modificación del archivo dado
  • ftp_mkdir — Crea un directorio
  • ftp_mlsd — Returns a list of files in the given directory
  • ftp_nb_continue — Continúa recuperando/enviando un archivo (modo no-bloqueo)
  • ftp_nb_fget — Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)
  • ftp_nb_fput — Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
  • ftp_nb_get — Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
  • ftp_nb_put — Almacena un archivo en el servidor FTP (modo no-bloqueo)
  • ftp_nlist — Devuelve una lista de los archivos que se encuentran en el directorio especificado
  • ftp_pasv — Activa o desactiva el modo pasivo
  • ftp_put — Carga un archivo al servidor FTP
  • ftp_pwd — Devuelve el nombre del directorio actual
  • ftp_quit — Alias de ftp_close
  • ftp_raw — Envía un comando arbitrario a un servidor FTP
  • ftp_rawlist — Devuelve una lista detallada de archivos en el directorio especificado
  • ftp_rename — Renombra un archivo o un directorio en el servidor FTP
  • ftp_rmdir — Elimina un directorio
  • ftp_set_option — Establecer varias opciones FTP de tiempo de ejecución
  • ftp_site — Envía un comando SITE al servidor
  • ftp_size — Devuelve el tamaño del archivo dado
  • ftp_ssl_connect — Abre una conexión segura SSL-FTP
  • ftp_systype — Devuelve el identificador del tipo de sistema del servidor FTP remoto


Reserva espacio para que un archivo sea cargado

  • « Funciones de FTP
  • ftp_append »
  • PHP Manual
  • Funciones de FTP
  • Reserva espacio para que un archivo sea cargado

ftp_alloc

(PHP 5, PHP 7, PHP 8)

ftp_alloc — Reserva espacio para que un archivo sea cargado

Descripción

ftp_alloc ( resource $ftp_stream , int $filesize , string &$result = ? ) : bool

Envía un comando ALLO al servidor FTP remoto para reservar espacio para la carga de un archivo.

Nota:

Muchos servidores FTP no son compatibles con este comando. Estos servidores pueden devolver un código de error (false) indicando que el comando no es compatible o un código de éxito (true) para indicar que la preubicación no es necesaria y el cliente debe continuar como si la operación hubiese sido exitosa. Debido a esto, puede ser mejor reservar esta función para servidores que requieren explícitamente la preubicación.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

filesize

El número de bytes a reservar.

result

Una representación textual de la respuesta de los servidores será devuelta por referencia en result si se proporciona una variable.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_alloc()

<?php

$file = "/home/user/myfile";

// conexión al servidor
$conn_id = ftp_connect('ftp.example.com');
$login_result = ftp_login($conn_id, 'anonymous', 'user@example.com');

if (ftp_alloc($conn_id, filesize($file), $result)) {
  echo "El espacio fue reservado satisfactoriamente en el servidor. Enviando $file.\n";
  ftp_put($conn_id, '/incomming/myfile', $file, FTP_BINARY);
} else {
  echo "No fue posible reservar espacio en el servidor. El servidor dijo: $result\n";
}

ftp_close($conn_id);

?>

Ver también

  • ftp_put() - Carga un archivo al servidor FTP
  • ftp_fput() - Carga un archivo abierto en el servidor FTP


Append the contents of a file to another file on the FTP server

  • « ftp_alloc
  • ftp_cdup »
  • PHP Manual
  • Funciones de FTP
  • Append the contents of a file to another file on the FTP server

ftp_append

(PHP 7 >= 7.2.0, PHP 8)

ftp_append — Append the contents of a file to another file on the FTP server

Descripción

ftp_append ( resource $ftp , string $remote_filename , string $local_filename , int $mode = FTP_BINARY ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ftp

remote_filename

local_filename

mode

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Vuelve al directorio padre

  • « ftp_append
  • ftp_chdir »
  • PHP Manual
  • Funciones de FTP
  • Vuelve al directorio padre

ftp_cdup

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_cdup — Vuelve al directorio padre

Descripción

ftp_cdup ( resource $ftp_stream ) : bool

Vuelve al directorio padre.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_cdup()

<?php
// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// cambiar el directorio actual a HTML
ftp_chdir($conn_id, 'html');

echo ftp_pwd($conn_id); // /html

// volver al directorio padre
if (ftp_cdup($conn_id)) {
  echo "cdup tuvo éxito\n";
} else {
  echo "cdup no tuvo éxito\n";
}

echo ftp_pwd($conn_id); // /

ftp_close($conn_id);
?>

Ver también

  • ftp_chdir() - Cambia el directorio actual en un servidor FTP
  • ftp_pwd() - Devuelve el nombre del directorio actual


Cambia el directorio actual en un servidor FTP

  • « ftp_cdup
  • ftp_chmod »
  • PHP Manual
  • Funciones de FTP
  • Cambia el directorio actual en un servidor FTP

ftp_chdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_chdir — Cambia el directorio actual en un servidor FTP

Descripción

ftp_chdir ( resource $ftp_stream , string $directory ) : bool

Cambia el directorio actual al especificado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

directory

El directorio de destino.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si al cambiar de directorio falla, PHP también lanzará una advertencia.

Ejemplos

Ejemplo #1 Ejemplo de ftp_chdir()

<?php

// configurar conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
    die("La conexión FTP ha fallado!");
}

echo "Directorio actual: " . ftp_pwd($conn_id) . "\n";

// intenta cambiar el directorio a somedir
if (ftp_chdir($conn_id, "somedir")) {
    echo "El directorio actual es: " . ftp_pwd($conn_id) . "\n";
} else {
    echo "No se pudo cambiar al directorio\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>

Ver también

  • ftp_cdup() - Vuelve al directorio padre
  • ftp_pwd() - Devuelve el nombre del directorio actual


Establecer permisos en un archivo via FTP

  • « ftp_chdir
  • ftp_close »
  • PHP Manual
  • Funciones de FTP
  • Establecer permisos en un archivo via FTP

ftp_chmod

(PHP 5, PHP 7, PHP 8)

ftp_chmod — Establecer permisos en un archivo via FTP

Descripción

ftp_chmod ( resource $ftp_stream , int $mode , string $filename ) : int

Establece los permisos en el archivo remoto especificado en mode.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

mode

Los nuevos permisos, dados como un valor octal.

filename

El archivo remoto.

Valores devueltos

Devuelve los nuevos permisos del archivo en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_chmod()

<?php
$file = 'public_html/index.php';

// configurar conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar cambiar el chmod del archivo $file a 644
if (ftp_chmod($conn_id, 0644, $file) !== false) {
 echo "El chmod del archivo $file fué satisfactoriamente cambiado a 644\n";
} else {
 echo "No se pudo cambiar el chmod del archivo $file\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>

Ver también

  • chmod() - Cambia el modo de un fichero


Cierra una conexión FTP

  • « ftp_chmod
  • ftp_connect »
  • PHP Manual
  • Funciones de FTP
  • Cierra una conexión FTP

ftp_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_close — Cierra una conexión FTP

Descripción

ftp_close ( resource $ftp_stream ) : bool

ftp_close() cierra el identificador de enlace especificado y libera el resource.

Nota:

Después de llamar a esta función, ya no puede seguir utilizando la conexión FTP y debe crear una nueva con una nueva función ftp_connect().

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_close()

<?php

// configurar conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesion con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// imprimir el directorio actual
echo ftp_pwd($conn_id); // /

// cerrar la conexión ftp
ftp_close($conn_id);
?>

Ver también

  • ftp_connect() - Abre una conexión FTP


Abre una conexión FTP

  • « ftp_close
  • ftp_delete »
  • PHP Manual
  • Funciones de FTP
  • Abre una conexión FTP

ftp_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_connect — Abre una conexión FTP

Descripción

ftp_connect ( string $host , int $port = 21 , int $timeout = 90 ) : resource

ftp_connect() abre una conexión FTP al host especificado.

Parámetros

host

La dirección del servidor FTP. Este parámetro no debe tener barras al final y no debe estar precedido de ftp://.

port

Este parámetro especifica un puerto alternativo al que conectarse. Si es omitido o es definido como cero, entonces el puerto FTP predeterminado, 21, será utilizado.

timeout

Este parámetro especifica el tiempo de espera para todas las operaciones de red subsiguientes. Si se omite, el valor predeterminado es 90 segundos. El tiempo de espera puede ser cambiado y consultado en cualquier momento con las funciones ftp_set_option() y ftp_get_option().

Valores devueltos

Devuelve una secuencia FTP en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_connect()

<?php

$ftp_server = "ftp.example.com";

// establecer una conexión o finalizarla
$conn_id = ftp_connect($ftp_server) or die("No se pudo conectar a $ftp_server");

?>

Ver también

  • ftp_close() - Cierra una conexión FTP
  • ftp_ssl_connect() - Abre una conexión segura SSL-FTP


Elimina un archivo en el servidor FTP

  • « ftp_connect
  • ftp_exec »
  • PHP Manual
  • Funciones de FTP
  • Elimina un archivo en el servidor FTP

ftp_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_delete — Elimina un archivo en el servidor FTP

Descripción

ftp_delete ( resource $ftp_stream , string $path ) : bool

ftp_delete() borra el archivo especificado por path desde el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

path

El archivo a eliminar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_delete()

<?php
$file = 'public_html/old.txt';

// establecer conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar eliminar el archivo $file
if (ftp_delete($conn_id, $file)) {
 echo "$file se ha eliminado satisfactoriamente\n";
} else {
 echo "No se pudo eliminar $file\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>


Solicita la ejecución de un comando en el servidor FTP

  • « ftp_delete
  • ftp_fget »
  • PHP Manual
  • Funciones de FTP
  • Solicita la ejecución de un comando en el servidor FTP

ftp_exec

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

ftp_exec — Solicita la ejecución de un comando en el servidor FTP

Descripción

ftp_exec ( resource $ftp_stream , string $command ) : bool

Envía un command de solicitud SITE EXEC al servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

command

El comando a ejecutar.

Valores devueltos

Devuelve true si el comando se ha realizado correctamente (el servidor envía el código de respuesta: 200); en caso contrario devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de ftp_exec()

<?php

// inicialización de variable
$command = 'ls -al >files.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// ejecutar comando
if (ftp_exec($conn_id, $command)) {
    echo "$command ejecutado con éxito\n";
} else {
    echo "no se pudo ejecutar $command\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);

?>

Ver también

  • ftp_raw() - Envía un comando arbitrario a un servidor FTP


Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto

  • « ftp_exec
  • ftp_fput »
  • PHP Manual
  • Funciones de FTP
  • Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto

ftp_fget

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_fget — Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto

Descripción

ftp_fget ( resource $ftp_stream , resource $handle , string $remote_file , int $mode , int $resumepos = 0 ) : bool

ftp_fget() recupera un remote_file desde el servidor FTP, y lo escribe en el apuntador del archivo especificado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

handle

Un apuntador del archivo abierto en el cual almacenar los datos.

remote_file

La ruta del archivo remoto.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

resumepos

La posición desde la cual se empieza a descargar el archivo remoto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_fget()

<?php

// ruta al archivo remoto
$remote_file = 'somefile.txt';
$local_file = 'localfile.txt';

// abrir un archivo para escribir
$handle = fopen($local_file, 'w');

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intenta descargar un $remote_file y guardarlo en $handle
if (ftp_fget($conn_id, $handle, $remote_file, FTP_ASCII, 0)) {
 echo "Se ha escrito satisfactoriamente sobre $local_file\n";
} else {
 echo "Ha habido un problema durante la descarga de $remote_file en $local_file\n";
}

// cerrar la conexión ftp y el gestor de archivo
ftp_close($conn_id);
fclose($handle);
?>

Ver también

  • ftp_get() - Descarga un archivo desde el servidor FTP
  • ftp_nb_get() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
  • ftp_nb_fget() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)


Carga un archivo abierto en el servidor FTP

  • « ftp_fget
  • ftp_get_option »
  • PHP Manual
  • Funciones de FTP
  • Carga un archivo abierto en el servidor FTP

ftp_fput

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_fput — Carga un archivo abierto en el servidor FTP

Descripción

ftp_fput ( resource $ftp_stream , string $remote_file , resource $handle , int $mode , int $startpos = 0 ) : bool

ftp_fput() carga los datos desde un puntero de archivo a un archivo remoto en el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

La ruta del archivo remoto.

handle

Un apuntador de archivo abierto en el archivo local. La lectura se detiene al final del archivo.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

startpos

La posición en el archivo remoto para empezar a subirlo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_fput()

<?php

// abrir un archivo para su lectura
$file = 'somefile.txt';
$fp = fopen($file, 'r');

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesion con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar cargar $file
if (ftp_fput($conn_id, $file, $fp, FTP_ASCII)) {
    echo "Cargado correctamente $file\n";
} else {
    echo "Ha habido un problema al cargar $file\n";
}

// cerrar la conexion ftp y el gestor de archivo
ftp_close($conn_id);
fclose($fp);

?>

Ver también

  • ftp_put() - Carga un archivo al servidor FTP
  • ftp_nb_fput() - Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
  • ftp_nb_put() - Almacena un archivo en el servidor FTP (modo no-bloqueo)


Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual

  • « ftp_fput
  • ftp_get »
  • PHP Manual
  • Funciones de FTP
  • Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual

ftp_get_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_get_option — Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual

Descripción

ftp_get_option ( resource $ftp_stream , int $option ) : mixed

Esta función devuelve el valor para la option solicitada de la conexión FTP especificada.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

option

Actualmente, se admiten las siguientes opciones:

Opciones FTP de tiempo de ejecución soportadas
FTP_TIMEOUT_SEC | Devuelve el tiempo de espera se utiliza actualmente para las operaciones de red.
FTP_AUTOSEEK | Devuelve true si esta opción está activada, false de lo contrario.

Valores devueltos

Devuelve el valor en caso de tener éxito false si el option especificado no es soportado. En este último caso, un mensaje de advertencia es también lanzado.

Ejemplos

Ejemplo #1 Ejemplo de ftp_get_option()

<?php
// Obtener el tiempo de espera de la secuencia FTP dada
$timeout = ftp_get_option($conn_id, FTP_TIMEOUT_SEC);
?>

Ver también

  • ftp_set_option() - Establecer varias opciones FTP de tiempo de ejecución


Descarga un archivo desde el servidor FTP

  • « ftp_get_option
  • ftp_login »
  • PHP Manual
  • Funciones de FTP
  • Descarga un archivo desde el servidor FTP

ftp_get

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_get — Descarga un archivo desde el servidor FTP

Descripción

ftp_get ( resource $ftp_stream , string $local_file , string $remote_file , int $mode , int $resumepos = 0 ) : bool

ftp_get() recupera un archivo remoto desde el servidor FTP, y lo guarda en un archivo local.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

local_file

La ruta del archivo local (será reemplazado si el archivo ya existe).

remote_file

La ruta del archivo remoto.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

resumepos

La posición para el comienzo de la descarga en el archivo remoto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_get()

<?php

// definir algunas variables
$local_file = 'local.zip';
$server_file = 'server.zip';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intenta descargar $server_file y guardarlo en $local_file
if (ftp_get($conn_id, $local_file, $server_file, FTP_BINARY)) {
    echo "Se ha guardado satisfactoriamente en $local_file\n";
} else {
    echo "Ha habido un problema\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);

?>

Ver también

  • ftp_pasv() - Activa o desactiva el modo pasivo
  • ftp_fget() - Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
  • ftp_nb_get() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
  • ftp_nb_fget() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)


Inicia sesión en una conexión FTP

  • « ftp_get
  • ftp_mdtm »
  • PHP Manual
  • Funciones de FTP
  • Inicia sesión en una conexión FTP

ftp_login

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_login — Inicia sesión en una conexión FTP

Descripción

ftp_login ( resource $ftp_stream , string $username , string $password ) : bool

Inicia la sesión en la secuencia FTP determinada.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

username

El nombre de usuario (USER).

password

La contraseña (PASS).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si el inicio de sesión falla, PHP también lanzará una advertencia.

Ejemplos

Ejemplo #1 Ejemplo de ftp_login()

<?php

$ftp_server = "ftp.example.com";
$ftp_user = "foo";
$ftp_pass = "bar";

// establecer una conexión o finalizarla
$conn_id = ftp_connect($ftp_server) or die("No se pudo conectar a $ftp_server");

// intentar iniciar sesión
if (@ftp_login($conn_id, $ftp_user, $ftp_pass)) {
    echo "Conectado como $ftp_user@$ftp_server\n";
} else {
    echo "No se pudo conectar como $ftp_user\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>


Devuelve el tiempo de la última modificación del archivo dado

  • « ftp_login
  • ftp_mkdir »
  • PHP Manual
  • Funciones de FTP
  • Devuelve el tiempo de la última modificación del archivo dado

ftp_mdtm

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_mdtm — Devuelve el tiempo de la última modificación del archivo dado

Descripción

ftp_mdtm ( resource $ftp_stream , string $remote_file ) : int

ftp_mdtm() obtiene el tiempo de la última modificación de un archivo remoto.

Nota:

¡No todos los servidores soportan esta característica!

Nota:

ftp_mdtm() no funciona con directorios.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

El archivo de la que extraer el tiempo de la última modificación.

Valores devueltos

Devuelve el tiempo de la última modificación como una marca de tiempo Unix en caso de tener éxito, o -1 si se produce un error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_mdtm()

<?php

$file = 'somefile.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

//  obtener el tiempo de la última modificación
$buff = ftp_mdtm($conn_id, $file);

if ($buff != -1) {
    // somefile.txt fue modificado por última vez en: March 26 2003 14:16:41.
    echo "$file fue modificado por última vez en : " . date("F d Y H:i:s.", $buff);
} else {
    echo "No se pudo obtener mdtime";
}

// cerrar la conexión ftp
ftp_close($conn_id);

?>


Crea un directorio

  • « ftp_mdtm
  • ftp_mlsd »
  • PHP Manual
  • Funciones de FTP
  • Crea un directorio

ftp_mkdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_mkdir — Crea un directorio

Descripción

ftp_mkdir ( resource $ftp_stream , string $directory ) : string

Crea el especificado directory en el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

directory

El nombre del directorio que se creará.

Valores devueltos

Devuelve el nombre del directorio recién creado en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_mkdir()

<?php

$dir = 'www';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar crear el directorio $dir
if (ftp_mkdir($conn_id, $dir)) {
 echo "creado con éxito $dir\n";
} else {
 echo "Ha habido un problema durante la creación de $dir\n";
}

// close the connection
ftp_close($conn_id);
?>

Ver también

  • ftp_rmdir() - Elimina un directorio


Returns a list of files in the given directory

  • « ftp_mkdir
  • ftp_nb_continue »
  • PHP Manual
  • Funciones de FTP
  • Returns a list of files in the given directory

ftp_mlsd

(PHP 7 >= 7.2.0, PHP 8)

ftp_mlsd — Returns a list of files in the given directory

Descripción

ftp_mlsd ( resource $ftp , string $directory ) : array|false

Parámetros

ftp

The link identifier of the FTP connection.

directory

The directory to be listed.

Valores devueltos

Returns an array of arrays with file infos from the specified directory on success or false on error.

Ejemplos

Ejemplo #1 ftp_mlsd() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get contents of the current directory
$contents = ftp_mlsd($conn_id, ".");

// output $contents
var_dump($contents);

?>

El resultado del ejemplo sería algo similar a:

array(5) {
  [0]=>
  array(8) {
    ["name"]=>
    string(1) "."
    ["modify"]=>
    string(14) "20171212154511"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(4) "cdir"
    ["unique"]=>
    string(11) "811U5740002"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [1]=>
  array(8) {
    ["name"]=>
    string(2) ".."
    ["modify"]=>
    string(14) "20171212154511"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(4) "pdir"
    ["unique"]=>
    string(11) "811U5740002"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [2]=>
  array(8) {
    ["name"]=>
    string(11) "public_html"
    ["modify"]=>
    string(14) "20171211171525"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U5740525"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [3]=>
  array(8) {
    ["name"]=>
    string(10) "public_ftp"
    ["modify"]=>
    string(14) "20171211174536"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U57405EE"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [4]=>
  array(8) {
    ["name"]=>
    string(3) "www"
    ["modify"]=>
    string(14) "www"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U5740780"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
}

Ver también

  • ftp_rawlist() - Devuelve una lista detallada de archivos en el directorio especificado
  • ftp_nlist() - Devuelve una lista de los archivos que se encuentran en el directorio especificado


Continúa recuperando/enviando un archivo (modo no-bloqueo)

  • « ftp_mlsd
  • ftp_nb_fget »
  • PHP Manual
  • Funciones de FTP
  • Continúa recuperando/enviando un archivo (modo no-bloqueo)

ftp_nb_continue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_continue — Continúa recuperando/enviando un archivo (modo no-bloqueo)

Descripción

ftp_nb_continue ( resource $ftp_stream ) : int

CContinúa recuperando/enviando un archivo en modo de no-bloqueo.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

Valores devueltos

Devuelve FTP_FAILED o FTP_FINISHED o FTP_MOREDATA.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nb_continue()

<?php

// Iniciar la descarga
$ret = ftp_nb_get($my_connection, "prueba", "LEAME", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Continuar la descarga ...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al descargar el archivo...";
   exit(1);
}
?>


Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)

  • « ftp_nb_continue
  • ftp_nb_fput »
  • PHP Manual
  • Funciones de FTP
  • Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)

ftp_nb_fget

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_fget — Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)

Descripción

ftp_nb_fget ( resource $ftp_stream , resource $handle , string $remote_file , int $mode , int $resumepos = 0 ) : int

ftp_nb_fget() recupera un archivo remoto desde el servidor FTP.

La diferencia entre esta función y ftp_fget() es que esta función recupera el archivo de forma asincrónica, de modo que su programa puede realizar otras operaciones mientras el archivo está siendo descargado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

handle

Un apuntador de archivo abierto en el cual almacenar los datos.

remote_file

La ruta del archivo remoto.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

resumepos

Posición en el fichero remoto en donde empezar la descarga

Valores devueltos

Devuelve FTP_FAILED o FTP_FINISHED o FTP_MOREDATA.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nb_fget()

<?php

// abrir un archivo para lectura
$file = 'index.php';
$fp = fopen($file, 'w');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Iniciar la descarga
$ret = ftp_nb_fget($conn_id, $fp, $file, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la descarga ...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al descargar el archivo...";
   exit(1);
}

// cerrar el apuntador de archivo
fclose($fp);
?>

Ver también

  • ftp_nb_get() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
  • ftp_nb_continue() - Continúa recuperando/enviando un archivo (modo no-bloqueo)
  • ftp_fget() - Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
  • ftp_get() - Descarga un archivo desde el servidor FTP


Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)

  • « ftp_nb_fget
  • ftp_nb_get »
  • PHP Manual
  • Funciones de FTP
  • Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)

ftp_nb_fput

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_fput — Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)

Descripción

ftp_nb_fput ( resource $ftp_stream , string $remote_file , resource $handle , int $mode , int $startpos = 0 ) : int

ftp_nb_fput() carga los datos desde un apuntador de archivo a un archivo remoto en el servidor FTP.

La diferencia entre esta función y ftp_fput() es que esta función carga el archivo de forma asincrónica, de modo que su programa puede realizar otras operaciones mientras el archivo está siendo cargado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

La ruta del archivo remoto.

handle

Un apuntador de archivo abierto en el archivo local. La lectura se detiene al final del archivo.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

startpos

La posición en el archivo remoto para empezar a subirlo.

Valores devueltos

Devuelve FTP_FAILED o FTP_FINISHED o FTP_MOREDATA.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nb_fput()

<?php

$file = 'index.php';

$fp = fopen($file, 'r');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Iniciar la carga
$ret = ftp_nb_fput($conn_id, $file, $fp, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la carga...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al subir el archivo...";
   exit(1);
}

fclose($fp);
?>

Ver también

  • ftp_nb_put() - Almacena un archivo en el servidor FTP (modo no-bloqueo)
  • ftp_nb_continue() - Continúa recuperando/enviando un archivo (modo no-bloqueo)
  • ftp_put() - Carga un archivo al servidor FTP
  • ftp_fput() - Carga un archivo abierto en el servidor FTP


Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)

  • « ftp_nb_fput
  • ftp_nb_put »
  • PHP Manual
  • Funciones de FTP
  • Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)

ftp_nb_get

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_get — Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)

Descripción

ftp_nb_get ( resource $ftp_stream , string $local_file , string $remote_file , int $mode , int $resumepos = 0 ) : int

ftp_nb_get() recupera un archivo remoto desde el servidor FTP, y lo guarda en un archivo local.

La diferencia entre esta función y ftp_get() es que esta función recupera el archivo de forma asincrónica, de modo que su programa puede realizar otras operaciones mientras el archivo está siendo descargado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

local_file

La ruta del archivo local (se sobrescribirá si el archivo ya existe).

remote_file

La ruta del archivo remoto.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

resumepos

Posición en el fichero remoto en donde empezar la descarga

Valores devueltos

Devuelve FTP_FAILED o FTP_FINISHED o FTP_MOREDATA.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nb_get()

<?php

// Iniciar la descarga
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la descarga...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al descargar el archivo...";
   exit(1);
}
?>

Ejemplo #2 Reanudar una descarga con ftp_nb_get()

<?php

// Iniciar
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY,
                      filesize("test"));
// O: $ret = ftp_nb_get($my_connection, "test", "README",
//                           FTP_BINARY, FTP_AUTORESUME);
while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la descarga...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al descargar el archivo...";
   exit(1);
}
?>

Ejemplo #3 Reanudar una descarga en la posición 100 a un nuevo archivo con ftp_nb_get()

<?php

// Deshabilitar Autoseek
ftp_set_option($my_connection, FTP_AUTOSEEK, false);

// Iniciar
$ret = ftp_nb_get($my_connection, "newfile", "README", FTP_BINARY, 100);
while ($ret == FTP_MOREDATA) {

   /* ... */

   // Continuar la descarga...
   $ret = ftp_nb_continue($my_connection);
}
?>

En el ejemplo anterior, newfile es 100 bytes menor que README en el servidor FTP por eso comenzamos la lectura en la posición 100. Si no hubiesemos deshabilitado FTP_AUTOSEEK, los primeros 100 bytes de newfile serían '\0'.

Ver también

  • ftp_nb_fget() - Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)
  • ftp_nb_continue() - Continúa recuperando/enviando un archivo (modo no-bloqueo)
  • ftp_fget() - Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
  • ftp_get() - Descarga un archivo desde el servidor FTP


Almacena un archivo en el servidor FTP (modo no-bloqueo)

  • « ftp_nb_get
  • ftp_nlist »
  • PHP Manual
  • Funciones de FTP
  • Almacena un archivo en el servidor FTP (modo no-bloqueo)

ftp_nb_put

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_put — Almacena un archivo en el servidor FTP (modo no-bloqueo)

Descripción

ftp_nb_put ( resource $ftp_stream , string $remote_file , string $local_file , int $mode , int $startpos = 0 ) : int

ftp_nb_put() almacena un archivo local en el servidor FTP.

La diferencia entre esta función y ftp_put() es que esta función carga el archivo de forma asincrónica, de modo que su programa puede realizar otras operaciones mientras el archivo está siendo cargado.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

La ruta del archivo remoto.

local_file

La ruta del archivo local.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

startpos

La posición en el archivo remoto para empezar a subirlo.

Valores devueltos

Devuelve FTP_FAILED o FTP_FINISHED o FTP_MOREDATA.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nb_put()

<?php

// Iniciar la Carga
$ret = ftp_nb_put($my_connection, "test.remote", "test.local", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la carga...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al cargar el archivo...";
   exit(1);
}
?>

Ejemplo #2 Reanudación de un proceso de carga con ftp_nb_put()

<?php

// Iniciar
$ret = ftp_nb_put($my_connection, "test.remote", "test.local",
                      FTP_BINARY, ftp_size("test.remote"));
// O: $ret = ftp_nb_put($my_connection, "test.remote", "test.local",
//                           FTP_BINARY, FTP_AUTORESUME);

while ($ret == FTP_MOREDATA) {

   // Haga lo que quiera
   echo ".";

   // Continuar la carga...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Hubo un error al cargar el archivo...";
   exit(1);
}
?>

Ver también

  • ftp_nb_fput() - Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
  • ftp_nb_continue() - Continúa recuperando/enviando un archivo (modo no-bloqueo)
  • ftp_put() - Carga un archivo al servidor FTP
  • ftp_fput() - Carga un archivo abierto en el servidor FTP


Devuelve una lista de los archivos que se encuentran en el directorio especificado

  • « ftp_nb_put
  • ftp_pasv »
  • PHP Manual
  • Funciones de FTP
  • Devuelve una lista de los archivos que se encuentran en el directorio especificado

ftp_nlist

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_nlist — Devuelve una lista de los archivos que se encuentran en el directorio especificado

Descripción

ftp_nlist ( resource $ftp_stream , string $directory ) : array

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

directory

El directorio a ser listado. Este parámetro también puede incluir argumentos, por ejemplo, ftp_nlist($conn_id, "-la /your/dir"); Tenga en cuenta que este parámetro no es escapado, lo que puede provocar algunos problemas con nombres de archivos que contengan espacios y otros caracteres.

Valores devueltos

Devuelve una matriz con los nombres de archivo del directorio especificado en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_nlist()

<?php

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Obtener los archivos contenidos en el directorio actual
$contents = ftp_nlist($conn_id, ".");

// output $contents
var_dump($contents);

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  string(11) "public_html"
  [1]=>
  string(10) "public_ftp"
  [2]=>
  string(3) "www"

Ver también

  • ftp_rawlist() - Devuelve una lista detallada de archivos en el directorio especificado


Activa o desactiva el modo pasivo

  • « ftp_nlist
  • ftp_put »
  • PHP Manual
  • Funciones de FTP
  • Activa o desactiva el modo pasivo

ftp_pasv

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_pasv — Activa o desactiva el modo pasivo

Descripción

ftp_pasv ( resource $ftp_stream , bool $pasv ) : bool

ftp_pasv() activa o desactiva el modo pasivo. En modo pasivo, las conexiones de datos son iniciadas por el cliente, en lugar de por el servidor. Puede ser necesaria si el cliente está detrás de un firewall.

Tenga en cuenta que ftp_pasv() sólo puede ser llamado después de un inicio de sesión correcto o de lo contrario fallará.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

pasv

Si true, el modo pasivo está activado, de lo contrario estará desactivado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_pasv()

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// activar modo pasivo
ftp_pasv($conn_id, true);

// cargar un archivo
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "se ha cargado $file con éxito\n";
} else {
 echo "Hubo un problema al cargar $file\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>


Carga un archivo al servidor FTP

  • « ftp_pasv
  • ftp_pwd »
  • PHP Manual
  • Funciones de FTP
  • Carga un archivo al servidor FTP

ftp_put

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_put — Carga un archivo al servidor FTP

Descripción

ftp_put ( resource $ftp_stream , string $remote_file , string $local_file , int $mode , int $startpos = 0 ) : bool

ftp_put() almacena un archivo local en el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

La ruta del archivo remoto.

local_file

La ruta del archivo local.

mode

El modo de transferencia. Debe ser FTP_ASCII o FTP_BINARY.

startpos

La posición en el archivo remoto para empezar a subirlo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_put()

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// cargar un archivo
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "se ha cargado $file con éxito\n";
} else {
 echo "Hubo un problema durante la transferencia de $file\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>

Ver también

  • ftp_pasv() - Activa o desactiva el modo pasivo
  • ftp_fput() - Carga un archivo abierto en el servidor FTP
  • ftp_nb_fput() - Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
  • ftp_nb_put() - Almacena un archivo en el servidor FTP (modo no-bloqueo)


Devuelve el nombre del directorio actual

  • « ftp_put
  • ftp_quit »
  • PHP Manual
  • Funciones de FTP
  • Devuelve el nombre del directorio actual

ftp_pwd

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_pwd — Devuelve el nombre del directorio actual

Descripción

ftp_pwd ( resource $ftp_stream ) : string

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

Valores devueltos

Devuelve el nombre del directorio actual o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_pwd()

<?php

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// cambiar al directorio public_html
ftp_chdir($conn_id, 'public_html');

// imprimir el directorio actual
echo ftp_pwd($conn_id); // /public_html

// cerrar la conexión ftp
ftp_close($conn_id);
?>

Ver también

  • ftp_chdir() - Cambia el directorio actual en un servidor FTP
  • ftp_cdup() - Vuelve al directorio padre


Alias de ftp_close

  • « ftp_pwd
  • ftp_raw »
  • PHP Manual
  • Funciones de FTP
  • Alias de ftp_close

ftp_quit

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_quit — Alias de ftp_close()

Descripción

Esta función es un alias de: ftp_close().


Envía un comando arbitrario a un servidor FTP

  • « ftp_quit
  • ftp_rawlist »
  • PHP Manual
  • Funciones de FTP
  • Envía un comando arbitrario a un servidor FTP

ftp_raw

(PHP 5, PHP 7, PHP 8)

ftp_raw — Envía un comando arbitrario a un servidor FTP

Descripción

ftp_raw ( resource $ftp_stream , string $command ) : array

Envía un command arbitrario al servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

command

El comando a ejecutar.

Valores devueltos

Devuelve la respuesta del servidor como una matriz de cadenas. No se realiza procesamiento alguno con la cadena de respuesta, ni ftp_raw() determina si el comando tuvo éxito.

Ejemplos

Ejemplo #1 Uso de ftp_raw() para iniciar sesión en un servidor FTP de forma manual.

<?php
$fp = ftp_connect("ftp.example.com");

/* Esto es lo mismo que:
ftp_login($fp, "joeblow", "secreto"); */
ftp_raw($fp, "USER joeblow");
ftp_raw($fp, "PASS secreto");
?>

Ver también

  • ftp_exec() - Solicita la ejecución de un comando en el servidor FTP


Devuelve una lista detallada de archivos en el directorio especificado

  • « ftp_raw
  • ftp_rename »
  • PHP Manual
  • Funciones de FTP
  • Devuelve una lista detallada de archivos en el directorio especificado

ftp_rawlist

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rawlist — Devuelve una lista detallada de archivos en el directorio especificado

Descripción

ftp_rawlist ( resource $ftp_stream , string $directory , bool $recursive = false ) : mixed

ftp_rawlist() ejecuta el comando FTP LIST, y devuelve el resultado como un array.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

directory

La ruta del directorio. Puede incluir argumentos para el comando LIST.

recursive

Si se establece a true, el comando emitido será LIST -R.

Valores devueltos

Devuelve un array donde cada elemento corresponde a una línea de texto. Devuelve false al pasar un directory no válido.

La salida no se analiza de forma alguna. El identificador del tipo de sistema devuelto por ftp_systype() se puede utilizar para determinar cómo los resultados deben ser interpretados.

Ejemplos

Ejemplo #1 Ejemplo de ftp_rawlist()

<?php

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// obtener la lista de archivos de /
$buff = ftp_rawlist($conn_id, '/');

// cerrar la conexión ftp
ftp_close($conn_id);

// imprimir el contenido del buffer
var_dump($buff);
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  [0]=>
  string(65) "drwxr-x---   3 vincent  vincent      4096 Jul 12 12:16 public_ftp"
  [1]=>
  string(66) "drwxr-x---  15 vincent  vincent      4096 Nov  3 21:31 public_html"
  [2]=>
  string(73) "lrwxrwxrwx   1 vincent  vincent        11 Jul 12 12:16 www -> public_html"
}

Ver también

  • ftp_nlist() - Devuelve una lista de los archivos que se encuentran en el directorio especificado


Renombra un archivo o un directorio en el servidor FTP

  • « ftp_rawlist
  • ftp_rmdir »
  • PHP Manual
  • Funciones de FTP
  • Renombra un archivo o un directorio en el servidor FTP

ftp_rename

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rename — Renombra un archivo o un directorio en el servidor FTP

Descripción

ftp_rename ( resource $ftp_stream , string $oldname , string $newname ) : bool

ftp_rename() renombra un archivo o un directorio en el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

oldname

El nombre del archivo/directorio viejo.

newname

El nuevo nombre.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_rename()

<?php
$old_file = 'somefile.txt.bak';
$new_file = 'somefile.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar renombrar el archivo $old_file a $new_file
if (ftp_rename($conn_id, $old_file, $new_file)) {
 echo "se ha renombrado $old_file a $new_file con éxito\n";
} else {
 echo "Hubo un problema al renombrar $old_file a $new_file\n";
}

// cerrar la conexión ftp
ftp_close($conn_id);
?>


Elimina un directorio

  • « ftp_rename
  • ftp_set_option »
  • PHP Manual
  • Funciones de FTP
  • Elimina un directorio

ftp_rmdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rmdir — Elimina un directorio

Descripción

ftp_rmdir ( resource $ftp_stream , string $directory ) : bool

Elimina el directory especificado en el servidor FTP.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

directory

El directorio a borrar. Este debe ser una ruta absoluta o relativa a un directorio vacío.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_rmdir()

<?php

$dir = 'www/';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// intentar eliminar el directorio $dir
if (ftp_rmdir($conn_id, $dir)) {
    echo "Se ha eliminado correctamente el directorio $dir\n";
} else {
    echo "Hubo un problema al eliminar el directorio $dir\n";
}

ftp_close($conn_id);

?>

Ver también

  • ftp_mkdir() - Crea un directorio


Establecer varias opciones FTP de tiempo de ejecución

  • « ftp_rmdir
  • ftp_site »
  • PHP Manual
  • Funciones de FTP
  • Establecer varias opciones FTP de tiempo de ejecución

ftp_set_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_set_option — Establecer varias opciones FTP de tiempo de ejecución

Descripción

ftp_set_option ( resource $ftp_stream , int $option , mixed $value ) : bool

Esta función controla diversas opciones de tiempo de ejecución para la secuencia FTP especificada.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

option

Actualmente, se admiten las siguientes opciones:

Opciones FTP de tiempo de ejecución soportadas
FTP_TIMEOUT_SEC | Cambia el tiempo de espera en segundos usado para todas las funciones de red. value debe ser un número entero mayor que 0. El tiempo de espera predeterminado es 90 segundos.
FTP_AUTOSEEK | Cuando se activa, las peticiones GET o PUT con un parámetro resumepos o startpos buscarán primero la posición solicitada dentro del archivo. Este parámetro es activado por defecto.

value

Este parámetro depende de qué option se elige para ser alterado.

Valores devueltos

Devuelve true si la opción pudo ser establecida; false de lo contrario. Un mensaje de advertencia será lanzado si la option no es soportada o el value pasado no coincide con el valor esperado para la option especificada.

Ejemplos

Ejemplo #1 Ejemplo de ftp_set_option()

<?php
// Establecer el tiempo de espera de red a 10 segundos
ftp_set_option($conn_id, FTP_TIMEOUT_SEC, 10);
?>

Ver también

  • ftp_get_option() - Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual


Envía un comando SITE al servidor

  • « ftp_set_option
  • ftp_size »
  • PHP Manual
  • Funciones de FTP
  • Envía un comando SITE al servidor

ftp_site

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_site — Envía un comando SITE al servidor

Descripción

ftp_site ( resource $ftp_stream , string $command ) : bool

ftp_site() envía el comando SITE especificado al servidor FTP.

Los comandos SITE no están estandarizados, y varían de un servidor a otro. Son útiles para la gestión de cosas como los permisos de archivos y la membresía de grupos.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

command

El comando SITE. Tenga en cuenta que este parámetro no es escapado, lo que puede provocar algunos problemas con nombres de archivos que contengan espacios y otros caracteres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Envío de un comando SITE a un servidor FTP

<?php
// Conectar con el servidor FTP
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('No se puede conectar al servidor ftp.example.com');

// Iniciar sesion como "user" con la contraseña "pass"
if (!ftp_login($conn, 'user', 'pass')) die('Error al iniciar sesión en ftp.example.com');

// Aplicar el comando: "SITE CHMOD 0600 /home/user/privatefile" al servidor ftp
if (ftp_site($conn, 'CHMOD 0600 /home/user/privatefile')) {
   echo "Comando ejecutado con éxito.\n";
} else {
   die('El comando ha fallado.');
}
?>

Ver también

  • ftp_raw() - Envía un comando arbitrario a un servidor FTP


Devuelve el tamaño del archivo dado

  • « ftp_site
  • ftp_ssl_connect »
  • PHP Manual
  • Funciones de FTP
  • Devuelve el tamaño del archivo dado

ftp_size

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_size — Devuelve el tamaño del archivo dado

Descripción

ftp_size ( resource $ftp_stream , string $remote_file ) : int

ftp_size() devuelve el tamaño del archivo dado en bytes.

Nota:

No todos los servidores soportan esta característica.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

remote_file

El archivo remoto.

Valores devueltos

Devuelve el tamaño del archivo en caso de éxito, o -1 en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_size()

<?php

$file = 'somefile.txt';

// establecer una conexión básica
$conn_id = ftp_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// obtener el tamaño de archivo de $file
$res = ftp_size($conn_id, $file);

if ($res != -1) {
    echo "tamaño de $file es $res bytes";
} else {
    echo "no se pudo obtener el tamaño";
}

// cerrar la conexión ftp
ftp_close($conn_id);

?>

Ver también

  • ftp_rawlist() - Devuelve una lista detallada de archivos en el directorio especificado


Abre una conexión segura SSL-FTP

  • « ftp_size
  • ftp_systype »
  • PHP Manual
  • Funciones de FTP
  • Abre una conexión segura SSL-FTP

ftp_ssl_connect

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_ssl_connect — Abre una conexión segura SSL-FTP

Descripción

ftp_ssl_connect ( string $host , int $port = 21 , int $timeout = 90 ) : resource

ftp_ssl_connect() abre una conexión explícita SSL-FTP al host especificado.

Nota: Por qué puede que esta función no exista

ftp_ssl_connect() sólo está disponible si ambos, el módulo de FTP y el soporte de OpenSSL, están construidos de forma estática en PHP, esto significa que en Windows esta función no estará disponible en las compilaciones oficiales de PHP. Para hacer esta función disponible en Windows, debe compilar sus propios binarios de PHP.

Nota:

ftp_ssl_connect() no está pensada para su uso con SFTP. Para utilizar sFTP con PHP, por favor, consulte ssh2_sftp().

Parámetros

host

La dirección del servidor FTP. Este parámetro no debe tener barras al final y no debe estar precedido de ftp://.

port

Este parámetro especifica un puerto alternativo al que conectarse. Si se omite o se define como cero, entonces el puerto por defecto FTP, 21, será utilizado.

timeout

Este parámetro especifica el tiempo de espera para todas las operaciones de red posteriores. Si se omite, el valor predeterminado es 90 segundos. El tiempo de espera puede ser cambiado y consultado en cualquier momento con ftp_set_option() y ftp_get_option().

Valores devueltos

Devuelve una secuencia SSL-FTP en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.2.2 | La función se ha cambiado para devolver false cuando no se puede utilizar una conexión SSL, en lugar de recurrir a una conexión no-SSL como hacía en versiones anteriores.

Ejemplos

Ejemplo #1 Ejemplo de ftp_ssl_connect()

<?php

// establecer la conexión SSL básica
$conn_id = ftp_ssl_connect($ftp_server);

// iniciar sesión con nombre de usuario y contraseña
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

echo ftp_pwd($conn_id); // /

// cerrar la conexión SSL
ftp_close($conn_id);
?>

Ver también

  • ftp_connect() - Abre una conexión FTP


Devuelve el identificador del tipo de sistema del servidor FTP remoto

  • « ftp_ssl_connect
  • Gearman »
  • PHP Manual
  • Funciones de FTP
  • Devuelve el identificador del tipo de sistema del servidor FTP remoto

ftp_systype

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_systype — Devuelve el identificador del tipo de sistema del servidor FTP remoto

Descripción

ftp_systype ( resource $ftp_stream ) : string

Devuelve el identificador del tipo de sistema del servidor FTP remoto.

Parámetros

ftp_stream

El identificador de enlace de la conexión FTP.

Valores devueltos

Devuelve el tipo de sistema remoto, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ftp_systype()

<?php

// conexión FTP
$ftp = ftp_connect('ftp.example.com');
ftp_login($ftp, 'user', 'password');

// obtener el tipo de sistema
if ($type = ftp_systype($ftp)) {
    echo "Example.com es motorizado por $type\n";
} else {
    echo "No se pudo obtener el tipo de sistema";
}

?>

El resultado del ejemplo sería algo similar a:

Example.com is powered by UNIX


Gearman

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
    • Cliente y trabajador básicos en Gearman, trabajo en segundo plano
  • GearmanClient — Clase GearmanClient
    • GearmanClient::addOptions — Añade opciones al cliente
    • GearmanClient::addServer — Añade un servidor de trabajos al cliente
    • GearmanClient::addServers — Añade una lista de servidores de trabajos al cliente
    • GearmanClient::addTask — Añade una tarea para ser ejecutada en paralelo
    • GearmanClient::addTaskBackground — Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
    • GearmanClient::addTaskHigh — Añade una tarea de alta prioridad para ser ejecutada en paralelo
    • GearmanClient::addTaskHighBackground — Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
    • GearmanClient::addTaskLow — Añade una tarea de baja prioridad para ejecutar en paralelo
    • GearmanClient::addTaskLowBackground — Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
    • GearmanClient::addTaskStatus — Añade una tarea para obtener el estado
    • GearmanClient::clearCallbacks — Elimina todas las funciones de retorno de llamada
    • GearmanClient::clone — Crea una copia de un objeto GearmanClient
    • GearmanClient::__construct — Crea una instancia de GearmanClient
    • GearmanClient::context — Obtiene el contexto de la aplicación
    • GearmanClient::data — Retorna los datos de aplicación (obsoleto)
    • GearmanClient::do — Ejecuta una sola tarea y retorna el resultado [obsoleto]
    • GearmanClient::doBackground — Ejecuta una tarea en segundo plano
    • GearmanClient::doHigh — Ejecuta una tarea de prioridad alta
    • GearmanClient::doHighBackground — Ejecuta una tarea de alta prioridad en segundo plano
    • GearmanClient::doJobHandle — Obtiene el manejador de trabajo para la tarea en ejecución
    • GearmanClient::doLow — Ejecuta una tarea de baja prioridad
    • GearmanClient::doLowBackground — Ejecuta una tarea de prioridad baja en segundo plano
    • GearmanClient::doNormal — Ejecutar una única tarea y devolver un resultado
    • GearmanClient::doStatus — Obtiene el estado de la tarea en ejecución
    • GearmanClient::echo — Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]
    • GearmanClient::error — Retorna un string con el último error encontrado
    • GearmanClient::getErrno — Obtiene un valor errno
    • GearmanClient::jobStatus — Obtiene el estado de un trabajo en segundo plano
    • GearmanClient::ping — Envar datos a todos los servidores de trabajo para ver si los repiten
    • GearmanClient::removeOptions — Elimina opciones del cliente
    • GearmanClient::returnCode — Obtiene el último código de retorno de Gearman
    • GearmanClient::runTasks — Ejecuta una lista de tareas en paralelo
    • GearmanClient::setClientCallback — Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)
    • GearmanClient::setCompleteCallback — Especifica una función a ser llamada cuando se complete una tarea
    • GearmanClient::setContext — Establece el contexto de la aplicación
    • GearmanClient::setCreatedCallback — Establece una llamada de retornopara cuando se encola una tarea
    • GearmanClient::setData — Establece los datos de aplicación (obsoleto)
    • GearmanClient::setDataCallback — Función de llamada de retorno para cuando hay un paquete de datos para la tarea
    • GearmanClient::setExceptionCallback — Establece una llamada de retorno para excepciones del trabajador
    • GearmanClient::setFailCallback — Establece una llamada de retorno para cuando falla un trabajo
    • GearmanClient::setOptions — Establece opciones del cliente
    • GearmanClient::setStatusCallback — Establece una llamada de retorno para obtener el estado de una tarea
    • GearmanClient::setTimeout — Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket
    • GearmanClient::setWarningCallback — Establece una llamada de retorno para los warnings del trabajador
    • GearmanClient::setWorkloadCallback — Establece una llamada de retorno para aceptar actualizaciones incrementales de datos
    • GearmanClient::timeout — Obtiene el tiempo máximo de inactividad de entrada/salida para el socket
    • GearmanClient::wait — Wait for I/O activity on all connections in a client
  • GearmanJob — La clase GearmanJob
    • GearmanJob::complete — Envía el resultado y el estado completo (obsoleto)
    • GearmanJob::__construct — Crea una instancia de GearmanJob
    • GearmanJob::data — Envía datos para un trabajo en ejecución (obsoleto)
    • GearmanJob::exception — Envía una excepción para un trabajo en ejecución (obsoleto)
    • GearmanJob::fail — Envía el estado de fallo (obsoleto)
    • GearmanJob::functionName — Retorna el nombre de la función
    • GearmanJob::handle — Retorna el manejador para el trabajo
    • GearmanJob::returnCode — Obtiene el último código de retorno
    • GearmanJob::sendComplete — Envía el resultado y el estado completado
    • GearmanJob::sendData — Envía datos para un trabajo en ejecución
    • GearmanJob::sendException — Envía una excepción para un trabajo en ejecución
    • GearmanJob::sendFail — Envía el estado de fallo
    • GearmanJob::sendStatus — Envía el estado
    • GearmanJob::sendWarning — Envía una advertencia
    • GearmanJob::setReturn — Establece el valor de retorno
    • GearmanJob::status — Envía el estado (obsoleto)
    • GearmanJob::unique — Obtiene el identificador único
    • GearmanJob::warning — Envía un aviso (obsoleto)
    • GearmanJob::workload — Obtiene la carga de trabajo
    • GearmanJob::workloadSize — Obtiene el tamaño de la carga de trabajo
  • GearmanTask — La clase GearmanTask
    • GearmanTask::__construct — Crea una instancia de GearmanTask
    • GearmanTask::create — Crea una tarea (obsoleto)
    • GearmanTask::data — Obtiene los datos retornados para una tarea
    • GearmanTask::dataSize — Obtiene el tamaño de la información retornada
    • GearmanTask::function — Obtiene el nombre de la función asociada (obsoleto)
    • GearmanTask::functionName — Retorna el nombre de la función asociada
    • GearmanTask::isKnown — Determina si la tarea es conocida
    • GearmanTask::isRunning — Comprueba si la tarea está siendo ejecutada
    • GearmanTask::jobHandle — Retorna el manejador del trabajo
    • GearmanTask::recvData — Guarda un trabajo o los datos resultantes de una tarea en un buffer
    • GearmanTask::returnCode — Retorna el último código de error
    • GearmanTask::sendData — Envía datos a una tarea (obsoleto)
    • GearmanTask::sendWorkload — Envía datos a una tarea
    • GearmanTask::taskDenominator — Obtiene el denominador del porcentaje de tarea completada
    • GearmanTask::taskNumerator — Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción
    • GearmanTask::unique — Obtiene el identificador único de una tarea
    • GearmanTask::uuid — Obtiene el identificador único de una tarea (obsoleto)
  • GearmanWorker — La clase GearmanWorker
    • GearmanWorker::addFunction — Registra y añade una función de retorno
    • GearmanWorker::addOptions — Añade opciones al trabajador
    • GearmanWorker::addServer — Añade un servidor de trabajo
    • GearmanWorker::addServers — Añade servidores de trabajo
    • GearmanWorker::clone — Crea una copia del trabajador
    • GearmanWorker::__construct — Crea una instancia GearmanWorker
    • GearmanWorker::echo — Comprueba la respuesta de un servidor de trabajo
    • GearmanWorker::error — Retorna el último error que ha ocurrido
    • GearmanWorker::getErrno — Obtiene el código de error
    • GearmanWorker::options — Retorna las opciones del trabajador
    • GearmanWorker::register — Registra una función en el servidor de trabajo
    • GearmanWorker::removeOptions — Elimina las opciones del trabajador
    • GearmanWorker::returnCode — Obtiene el último código de retorno de Gearman
    • GearmanWorker::setId — Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles
    • GearmanWorker::setOptions — Establece las opciones del trabajador
    • GearmanWorker::setTimeout — Establece un tiempo de espera máximo para actividad de entrada/salida del socket
    • GearmanWorker::timeout — Retorna el tiempo máximo de espera para actividad de entrada/salida del socket
    • GearmanWorker::unregister — Elimina el registro del nombre de una función en los servidores de trabajo
    • GearmanWorker::unregisterAll — Elimina el registro de todas los nombres de funciones en los servidores de trabajo
    • GearmanWorker::wait — Espera cualquier actividad de uno de los servidores de trabajo
    • GearmanWorker::work — Espera y realiza un trabajo
  • GearmanException — La clase GearmanException


Introducción

» Gearman es un framework de aplicaciones genéricas que da trabajo a múltiples máquinas o procesos. Permite que las aplicaciones completen tareas en paralelo, balanceen la carga de proceso y llamen a funciones entre diferentes lenguajes. El framework puede ser usado en gran variedad de aplicaciones, desde sitios webs de alta disponibilidad hasta los eventos de transporte de eventos de replicación de bases de datos.

Esta extensión proporciona clases para escribir clientes y trabajadores Gearman.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta extensión requiere la librería » libgearman y un servidor Gearman en ejecución.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/gearman


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Valores de retorno. Comprobar siempre GearmanClient::error() o GearmanWorker() para obtener los errores ya que pueden contener más detalles:

GEARMAN_SUCCESS (integer)
La acción fue realizada con éxito.
GEARMAN_IO_WAIT (integer)
En modo no bloqueante, se lanza un evento que podría bloquear.
GEARMAN_ERRNO (integer)
Error del sistema. Comprobar GearmanClient::errno() o GearmanWorker::errno() para obtener el código de error del sistema que se ha retornado.
GEARMAN_NO_ACTIVE_FDS (integer)
Se ha llamado a GearmanClient::wait() o GearmanWorker() sin una conexión.
GEARMAN_UNEXPECTED_PACKET (integer)
Indica que algo ha ido mal en gearmand. Se aplica sólo a GearmanWorker.
GEARMAN_GETADDRINFO (integer)
Falló la resolución DNS (host no válido, puerto, etc).
GEARMAN_NO_SERVERS (integer)
No se ha llamado a GearmanClient::addServer() antes de enviar trabajos o tareas.
GEARMAN_LOST_CONNECTION (integer)
Se perdió la conexión durante una petición.
GEARMAN_MEMORY_ALLOCATION_FAILURE (integer)
No se pudo reservar memoria (sin memoria).
GEARMAN_SERVER_ERROR (integer)
Algo ha fallado en el servidor Gearman y no ha podido manejar la petición correctamente.
GEARMAN_WORK_DATA (integer)
Código de error de tipo Notice obtenido con GearmanClient::returnCode() cuando se usa GearmanClient::do(). Enviado para actualizar el cliente con datos del trabajo que se está ejecutando. Un trabajador lo usa cuando necesita enviar actualizaciones, enviar resultandos parciales o enviar datos en trabajos de larga duración.
GEARMAN_WORK_WARNING (integer)
Código de error de tipo Notice obtenido con GearmanClient::returnCode() cuando se usa GearmanClient::do(). Actualiza el cliente con un warning. Este comportamiento es como GEARMAN_WORK_DATA pero debe ser tratado como un warning en vez de datos de respuesta.
GEARMAN_WORK_STATUS (integer)
Código de error de tipo Notice obtenido con GearmanClient::returnCode() cuando se usa GearmanClient::do(). Enviado para actualizar el estado de un proceso de larga duración. Usar GearmanClient::doStatus() para obtener el porcentaje de tarea completada.
GEARMAN_WORK_EXCEPTION (integer)
Código de error de tipo Notice obtenido con GearmanClient::returnCode() cuando se usa GearmanClient::do(). Indica que el trabajo ha fallado dando una excepción. with a given exception.
GEARMAN_WORK_FAIL (integer)
Código de error de tipo Notice obtenido con GearmanClient::returnCode() cuando se usa GearmanClient::do(). Indica que el trabajo ha fallado.
GEARMAN_COULD_NOT_CONNECT (integer)
Fallo en la conexión a los servidores.
GEARMAN_INVALID_FUNCTION_NAME (integer)
Intento de registrar el nombre de una función como NULL o uso de funciones de llamadas de retorno sin especificarlas correctamente.
GEARMAN_INVALID_WORKER_FUNCTION (integer)
Intento de registrar una funcionón con un NULL en la función de llamada de retorno.
GEARMAN_NO_REGISTERED_FUNCTIONS (integer)
Cuando un trabajador obtiene un trabajo para una función que no registró.
GEARMAN_NO_JOBS (integer)
Para un trabajador no bloqueante, cuando GearmanWorker::work() no tiene ningún trabajo activo.
GEARMAN_ECHO_DATA_CORRUPTION (integer)
Tras GearmanClient::echo() o GearmanWorker::echo(), los datos retornados no coinciden con los datos enviados.
GEARMAN_NEED_WORKLOAD_FN (integer)
Cuando el cliente optó por enviar la carga de trabajo de una tarea pero no especificó la función de retorno para la carga de trabajo.
GEARMAN_PAUSE (integer)
Para el interfaz de tarea no bloqueante, puede ser retornada por la tarea para "pausar" la llamada y retornar de GearmanClient::runTasks(). Debe llamarse a GearmanClient::runTasks() de nuevo para continuar.
GEARMAN_UNKNOWN_STATE (integer)
Error interno de estado en el cliente/trabajador.
GEARMAN_SEND_BUFFER_TOO_SMALL (integer)
Error interno: intento de enviar más información de la que es posible en un trozo atómico debido a los tamaños (definidos en código) de los buffers.
GEARMAN_TIMEOUT (integer)
Se alcazó el límite te tiempo establecido por el cliente/trabajador.

Opciones de GearmanClient:

GEARMAN_CLIENT_NON_BLOCKING (integer)
Ejecutar el cliente en modo no bloqueante.
GEARMAN_CLIENT_UNBUFFERED_RESULT (integer)
Permite al cliente leer datos en bloques en vez de tener en el buffer el resultado completo y pasarlo.
GEARMAN_CLIENT_FREE_TASKS (integer)
Liberar automáticamente objetos una vez que se han completado. Esta es la opción por defecto en esta extensión para intentar evitar pérdidas de memoria.

Opciones de GearmanWorker:

GEARMAN_WORKER_NON_BLOCKING (integer)
Ejecuta el trabajador en modo no bloqueante.
GEARMAN_WORKER_GRAB_UNIQ (integer)
Retirna el identificador único asignado al cliente además del manejador del trabajo.

Configuración base de Gearman:

GEARMAN_DEFAULT_TCP_HOST (string)
GEARMAN_DEFAULT_TCP_PORT (integer)
GEARMAN_DEFAULT_SOCKET_TIMEOUT (integer)
GEARMAN_DEFAULT_SOCKET_SEND_SIZE (integer)
GEARMAN_DEFAULT_SOCKET_RECV_SIZE (integer)
GEARMAN_MAX_ERROR_SIZE (integer)
GEARMAN_PACKET_HEADER_SIZE (integer)
GEARMAN_JOB_HANDLE_SIZE (integer)
GEARMAN_OPTION_SIZE (integer)
GEARMAN_UNIQUE_SIZE (integer)
GEARMAN_MAX_COMMAND_ARGS (integer)
GEARMAN_ARGS_BUFFER_SIZE (integer)
GEARMAN_SEND_BUFFER_SIZE (integer)
GEARMAN_RECV_BUFFER_SIZE (integer)
GEARMAN_WORKER_WAIT_TIMEOUT (integer)


Ejemplos

Tabla de contenidos

  • Uso básico
  • Cliente y trabajador básicos en Gearman, trabajo en segundo plano


Uso básico

Ejemplo #1 Cliente y trabajador básicos en Gearman

Este ejemplo muestra un cliente y un trabajador muy sencillo. El cliente envía un string al servidor de trabajos, y el trabajador da la vuelta al string y lo envía de vuelta. El trabajo se realiza de forma síncrona.

<?php

# Se crea el objeto cliente
$gmclient= new GearmanClient();

# Se añade el servidor por defecto (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Enviamos trabajo "reverse"
do
{
  $result = $gmclient->do("reverse", "Hello!");

  # Comprobación de varios paquetes de retorno y errores
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

?>
<?php

echo "Starting\n";

# Se crea el objeto del trabajador
$gmworker= new GearmanWorker();

# Se añade el servidor por defecto (localhost).
$gmworker->addServer();

# Registro de la función "reverse" en el servidor. Cambiar la función del
# trabajador a "reverse_fn_fast" para un trabajo más rápido sin mensajes de
# estado.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # Este bucle de estado no es necesario, sólo es para mostrar cómo funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Retornamos lo que hay que enviar de vuelta al cliente
  return $result;
}

# Una forma mucho más sencilla y que da menos información sería:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

El resultado del ejemplo sería algo similar a:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:36
Workload: Hello! (6)
Sending status: 1/6 complete
Sending status: 2/6 complete
Sending status: 3/6 complete
Sending status: 4/6 complete
Sending status: 5/6 complete
Sending status: 6/6 complete
Result: !olleH

% php reverse_client.php
Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH


Cliente y trabajador básicos en Gearman, trabajo en segundo plano

Ejemplo #1 Cliente y trabajador básicos en Gearman, trabajo en segundo plano

Este ejemplo muestra un trabajador y un cliente muy sencillos. El cliente envía un string al servidor de trabajos como trabajo en segundo plano, y el trabajador da la vuelta al string. Notar que como el trabajo se realiza de forma asíncrona, el cliente no espera a que se complete el trabajo y termina (y, por tanto, el cliente nunca recibe los resultados).

<?php

# Creación del objeto cliente
$gmclient= new GearmanClient();

# Se añade el servidor por defecto (localhost)
$gmclient->addServer();

# Ejecutar el cliente "reverse" en segundo plano
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

echo "done!\n";

?>
<?php

echo "Starting\n";

# Creación del objeto trabajador
$gmworker= new GearmanWorker();

# Se añade el servidor por defecto (localhost).
$gmworker->addServer();

# Registro de la función "reverse" en el servidor. Cambiar la funcion del
# trabajador a "reverse_fn_fast" para usar un trabajador más rápido sin
# mostrar mensajes de estado
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # Este bucle de estado no es necesario, únicamente muestra cómo funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Retorna lo que se quiere enviar de vuelta al cliente
  return $result;
}

# Una versión mucho más sencilla y que muestra menos información del proceso sería:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

El resultado del ejemplo sería algo similar a:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:41
Workload: this is a test (14)
1/14 complete
2/14 complete
3/14 complete
4/14 complete
5/14 complete
6/14 complete
7/14 complete
8/14 complete
9/14 complete
10/14 complete
11/14 complete
12/14 complete
13/14 complete
14/14 complete
Result: tset a si siht

% php reverse_client_bg.php
done!


  • « Cliente y trabajador básicos en Gearman, trabajo en segundo plano
  • GearmanClient »
  • PHP Manual
  • Ejemplos

Ejemplo #1 Cliente y trabajador básicos, enviando tareas

En este ejemplo, se extiende el cliente básico que da la vuelta al texto para ejecutar dos tareas en paralelo. El trabajador "reverse" es idéntico excepto la parte del envío del datos durante el proceso.

<?php

# Creación del cliente Gearman
$gmc= new GearmanClient();

# Añade el servidor por defecto (localhost)
$gmc->addServer();

# Registra alguna llamadas de retorno
$gmc->setCreatedCallback("reverse_created");
$gmc->setDataCallback("reverse_data");
$gmc->setStatusCallback("reverse_status");
$gmc->setCompleteCallback("reverse_complete");
$gmc->setFailCallback("reverse_fail");

# Asignación de datos arbitrarios para la aplicación
$data['foo'] = 'bar';

# Añade dos tareas
$task= $gmc->addTask("reverse", "foo", $data);
$task2= $gmc->addTaskLow("reverse", "bar", NULL);

#  Ejecuta las tareas en paralelo (se asumen múltiples trabajadores)
if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_created($task)
{
    echo "CREATED: " . $task->jobHandle() . "\n";
}

function reverse_status($task)
{
    echo "STATUS: " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->jobHandle() . ", " . $task->data() . "\n";
}

function reverse_fail($task)
{
    echo "FAILED: " . $task->jobHandle() . "\n";
}

function reverse_data($task)
{
    echo "DATA: " . $task->data() . "\n";
}

?>
<?php

echo "Starting\n";

# Creación del objeto trabajador
$gmworker= new GearmanWorker();

# Añade el servidor por defecto (localhost).
$gmworker->addServer();

# Registra la función "reverse" en el servidor. Cambiar la función a
# "reverse_fn_fast" para obtener un worker más rápido que no genera
# informacion del proceso
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # Este bucle de estado no es necesario, sólo es para mostrar cómo funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Retornamos lo que queremos enviar de vuelta al cliente
  return $result;
}

# Una versión mucho más sencilla y que muestra menos información del proceso sería:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

El resultado del ejemplo sería algo similar a:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:45
Workload: foo (3)
1/3 complete
2/3 complete
3/3 complete
Result: oof
Received job: H:foo.local:44
Workload: bar (3)
1/3 complete
2/3 complete
3/3 complete
Result: rab

% php reverse_client_task.php
CREATED: H:foo.local:44
CREATED: H:foo.local:45
STATUS: H:foo.local:45 - 1/3
DATA: f
STATUS: H:foo.local:45 - 2/3
DATA: o
STATUS: H:foo.local:45 - 3/3
DATA: o
COMPLETE: H:foo.local:45, oof
STATUS: H:foo.local:44 - 1/3
DATA: b
STATUS: H:foo.local:44 - 2/3
DATA: a
STATUS: H:foo.local:44 - 3/3
DATA: r
COMPLETE: H:foo.local:44, rab
DONE


Clase GearmanClient

(PECL gearman >= 0.5.0)

Introducción

Representa una clase para conectar a un servidor de trabajos Gearman y realizar peticiones para ejecutar alguna función con los datos proporcionados. La función ejecutada debe ser una de las registradas por un trabajador Gearman y los datos que se pasan son opacos al servidor de trabajos.

Sinopsis de la Clase

GearmanClient {
/* Métodos */
public addOptions ( int $options ) : bool
public addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool
public addServers ( string $servers = 127.0.0.1:4730 ) : bool
public addTask ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskHigh ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskHighBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskLow ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskLowBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskStatus ( string $job_handle , string &$context = ? ) : GearmanTask
public clearCallbacks ( ) : bool
public clone ( ) : GearmanClient
public __construct ( )
public context ( ) : string
public data ( ) : string
public do ( string $function_name , string $workload , string $unique = ? ) : string
public doBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doHigh ( string $function_name , string $workload , string $unique = ? ) : string
public doHighBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doJobHandle ( ) : string
public doLow ( string $function_name , string $workload , string $unique = ? ) : string
public doLowBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doNormal ( string $function_name , string $workload , string $unique = ? ) : string
public doStatus ( ) : array
public echo ( string $workload ) : bool
public error ( ) : string
public getErrno ( ) : int
public jobStatus ( string $job_handle ) : array
public ping ( string $workload ) : bool
public removeOptions ( int $options ) : bool
public returnCode ( ) : int
public runTasks ( ) : bool
public setClientCallback ( callable $callback ) : void
public setCompleteCallback ( callable $callback ) : bool
public setContext ( string $context ) : bool
public setCreatedCallback ( string $callback ) : bool
public setData ( string $data ) : bool
public setDataCallback ( callable $callback ) : bool
public setExceptionCallback ( callable $callback ) : bool
public setFailCallback ( callable $callback ) : bool
public setOptions ( int $options ) : bool
public setStatusCallback ( callable $callback ) : bool
public setTimeout ( int $timeout ) : bool
public setWarningCallback ( callable $callback ) : bool
public setWorkloadCallback ( callable $callback ) : bool
public timeout ( ) : int
public wait ( ) : bool
}

Tabla de contenidos

  • GearmanClient::addOptions — Añade opciones al cliente
  • GearmanClient::addServer — Añade un servidor de trabajos al cliente
  • GearmanClient::addServers — Añade una lista de servidores de trabajos al cliente
  • GearmanClient::addTask — Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskBackground — Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskHigh — Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskHighBackground — Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::addTaskLow — Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskLowBackground — Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskStatus — Añade una tarea para obtener el estado
  • GearmanClient::clearCallbacks — Elimina todas las funciones de retorno de llamada
  • GearmanClient::clone — Crea una copia de un objeto GearmanClient
  • GearmanClient::__construct — Crea una instancia de GearmanClient
  • GearmanClient::context — Obtiene el contexto de la aplicación
  • GearmanClient::data — Retorna los datos de aplicación (obsoleto)
  • GearmanClient::do — Ejecuta una sola tarea y retorna el resultado [obsoleto]
  • GearmanClient::doBackground — Ejecuta una tarea en segundo plano
  • GearmanClient::doHigh — Ejecuta una tarea de prioridad alta
  • GearmanClient::doHighBackground — Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doJobHandle — Obtiene el manejador de trabajo para la tarea en ejecución
  • GearmanClient::doLow — Ejecuta una tarea de baja prioridad
  • GearmanClient::doLowBackground — Ejecuta una tarea de prioridad baja en segundo plano
  • GearmanClient::doNormal — Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doStatus — Obtiene el estado de la tarea en ejecución
  • GearmanClient::echo — Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]
  • GearmanClient::error — Retorna un string con el último error encontrado
  • GearmanClient::getErrno — Obtiene un valor errno
  • GearmanClient::jobStatus — Obtiene el estado de un trabajo en segundo plano
  • GearmanClient::ping — Envar datos a todos los servidores de trabajo para ver si los repiten
  • GearmanClient::removeOptions — Elimina opciones del cliente
  • GearmanClient::returnCode — Obtiene el último código de retorno de Gearman
  • GearmanClient::runTasks — Ejecuta una lista de tareas en paralelo
  • GearmanClient::setClientCallback — Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)
  • GearmanClient::setCompleteCallback — Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setContext — Establece el contexto de la aplicación
  • GearmanClient::setCreatedCallback — Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setData — Establece los datos de aplicación (obsoleto)
  • GearmanClient::setDataCallback — Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setExceptionCallback — Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback — Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setOptions — Establece opciones del cliente
  • GearmanClient::setStatusCallback — Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setTimeout — Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket
  • GearmanClient::setWarningCallback — Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback — Establece una llamada de retorno para aceptar actualizaciones incrementales de datos
  • GearmanClient::timeout — Obtiene el tiempo máximo de inactividad de entrada/salida para el socket
  • GearmanClient::wait — Wait for I/O activity on all connections in a client


Añade opciones al cliente

  • « GearmanClient
  • GearmanClient::addServer »
  • PHP Manual
  • GearmanClient
  • Añade opciones al cliente

GearmanClient::addOptions

(PECL gearman >= 0.6.0)

GearmanClient::addOptions — Añade opciones al cliente

Descripción

public GearmanClient::addOptions ( int $options ) : bool

Añade una o más opciones a las que hay actualmente.

Parámetros

options

Opciones a añadir

Valores devueltos

Siempre retorna true.


Añade un servidor de trabajos al cliente

  • « GearmanClient::addOptions
  • GearmanClient::addServers »
  • PHP Manual
  • GearmanClient
  • Añade un servidor de trabajos al cliente

GearmanClient::addServer

(PECL gearman >= 0.5.0)

GearmanClient::addServer — Añade un servidor de trabajos al cliente

Descripción

public GearmanClient::addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool

Añade un servidor de trabajos a la lista de servidores que pueden usarse para ejecutar una tarea. No hay tráfico de entrada y salida vía socket en este punto; el servidor simplemente es añadido a la lista.

Parámetros

host

Nombre del host del job server.

port

Puerto del job server.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añadir dos servidores de trabajos

<?php

# Creación del objeto cliente
$gmclient= new GearmanClient();

# Añadimos dos servidores, el primero en el puerto por defecto: 4730
$gmclient->addServer("10.0.0.1");
$gmclient->addServer("10.0.0.2", 7003);

?>

Ver también

  • GearmanClient::addServers() - Añade una lista de servidores de trabajos al cliente


Añade una lista de servidores de trabajos al cliente

  • « GearmanClient::addServer
  • GearmanClient::addTask »
  • PHP Manual
  • GearmanClient
  • Añade una lista de servidores de trabajos al cliente

GearmanClient::addServers

(PECL gearman >= 0.5.0)

GearmanClient::addServers — Añade una lista de servidores de trabajos al cliente

Descripción

public GearmanClient::addServers ( string $servers = 127.0.0.1:4730 ) : bool

Añade una lista de servidores de trabajos que puede usarse para ejecutar una tarea. No se realiza ninguna actividad de entrada y salida sobre el socket; los servidores únicamente se añaden a la lista completa de servidores.

Parámetros

servers

Una lista separadas por comas de servidores, cada servidor especificado en el formato 'host:port'.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añade dos servidores de trabajos

<?php

# Creamos el objeto con el cliente
$gmclient= new GearmanClient();

# Añadimos múltiples servidores, el primero en el puerto por defecto: 4730
$gmclient->addServers("10.0.0.1,10.0.0.2:7003");

?>

Ver también

  • GearmanClient::addServer() - Añade un servidor de trabajos al cliente


Añade una tarea para ser ejecutada en paralelo

  • « GearmanClient::addServers
  • GearmanClient::addTaskBackground »
  • PHP Manual
  • GearmanClient
  • Añade una tarea para ser ejecutada en paralelo

GearmanClient::addTask

(PECL gearman >= 0.5.0)

GearmanClient::addTask — Añade una tarea para ser ejecutada en paralelo

Descripción

public GearmanClient::addTask ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea para ser ejecutada en paralelo con otras tareas. Debe llamarse a este método en todas las tareas que van a ejecutarse en paralelo y, entonces, llamar a GearmanClient::runTasks() para realizar el trabajo. Notar que se necesitan al menos tantos trabajadores como tareas para que puedan ejecutarse todos en paralelo de forma simultánea.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si no se puede añadir la tarea.

Ejemplos

Ejemplo #1 Envío básico de dos tareas

<?php

# Crear el servidor Gearman
$gmclient= new GearmanClient();

# Establece una función a ser llamada cuando se complete el trabajo
$gmclient->setCompleteCallback("complete");

# Añade el servidor por defecto
$gmclient->addServer();

# Añade una tarea que ejecuta la función "reverse" al string "Hello World!"
$gmclient->addTask("reverse", "Hello World!", null, "1");

# Añade otra tarea para ejecutar la función "reverse" en el string "!dlroW olleH"
$gmclient->addTask("reverse", "!dlroW olleH", null, "2");

# Ejecuta las tareas
$gmclient->runTasks();

function complete($task)
{
  print "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

El resultado del ejemplo sería algo similar a:

COMPLETE: 2, Hello World!
COMPLETE: 1, !dlroW olleH

Ejemplo #2 Envío básico de dos tareas pasando contexto de la aplicación

<?php

$client = new GearmanClient();
$client->addServer();

# Establece una función a ser llamada cuando se complete el trabajo
$client->setCompleteCallback("reverse_complete");

# Añade algunas tareas y provee de un lugar donde poner los resultados
$results = array();
$client->addTask("reverse", "Hello World!", &$results, "t1");
$client->addTask("reverse", "!dlroW olleH", &$results, "t2");

$client->runTasks();

# Los resultados deberían estar rellenos
foreach ($results as $id => $result)
   echo $id . ": " . $result['handle'] . ", " . $result['data'] . "\n";

function reverse_complete($task, $results)
{
   $results[$task->unique()] = array("handle"=>$task->jobHandle(), "data"=>$task->data());
}

?>

El resultado del ejemplo sería algo similar a:

t2: H.foo:21, Hello World!
t1: H:foo:22, !dlroW olleH

Ver también

  • GearmanClient::addTaskHigh() - Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskLow() - Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskBackground() - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskHighBackground() - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::addTaskLowBackground() - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Ejecuta una tarea en segundo plano para ser ejecutada en paralelo

  • « GearmanClient::addTask
  • GearmanClient::addTaskHigh »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea en segundo plano para ser ejecutada en paralelo

GearmanClient::addTaskBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskBackground — Ejecuta una tarea en segundo plano para ser ejecutada en paralelo

Descripción

public GearmanClient::addTaskBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea en segundo plano para ser ejecutada en paralelo junto con otras tareas. Este método debe llamarse para todas las tareas que deben ejecutarse en paralelo y entonces llamar a GearmanClient::runTasks() para realizar el trabajo.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si la tarea no pudo ser añadida.

Ejemplos

Ejemplo #1 Dos tareas, una en segundo plano y la otra no

Este ejemplo ilustra la diferencia entre ejecutar una tarea en segundo plano y una tarea normal. El cliente añade dos tareas para que ejecuten la misma función, pero una se añade con addTaskBackground(). Se establece una llamada de retorno de modo que se puede hacer seguimiento del progreso del trabajo. Un trajabador muy simple con un retardo artificial informa sobre el progreso del trabajo y el cliente obtiene esta información a través de la llamada de retorno. En este ejemplo se ejecutan dos trabajadores. Notar que la tarea en segundo plano no se muestra en la información de salida del cliente.

<?php

# El script del cliente

# Creamos el cliente gearman
$gmc= new GearmanClient();

# Añade el servidor de trabajos por defecto
$gmc->addServer();

# Establece un par de llamadas de retorno de modo que pueda seguirse el progreso
$gmc->setCompleteCallback("reverse_complete");
$gmc->setStatusCallback("reverse_status");

# Añade una tarea para la función "reverse"
$task= $gmc->addTask("reverse", "Hello World!", null, "1");

# Añade otra tarea, pero esta se ejecuta en segundo plano
$task= $gmc->addTaskBackground("reverse", "!dlroW olleH", null, "2");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_status($task)
{
    echo "STATUS: " . $task->unique() . ", " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>
<?php

# El script del trabajador

echo "Starting\n";

# Creamos el objeto trabajador
$gmworker= new GearmanWorker();

# Añade el servidor por defecto (localhost)
$gmworker->addServer();

# Registra la función "reverse" en el servidor
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # Este bucle de estado no es neceasario, únicamente muestra cómo funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Retorna lo que se quiere enviar al cliente
  return $result;
}

?>

Salida del trabajador para dos trabajadores en funcionamiento:

Received job: H:foo.local:65
Workload: !dlroW olleH (12)
1/12 complete
Received job: H:foo.local:66
Workload: Hello World! (12)
Sending status: 1/12 complete
Sending status: 2/12 complete
Sending status: 2/12 complete
Sending status: 3/12 complete
Sending status: 3/12 complete
Sending status: 4/12 complete
Sending status: 4/12 complete
Sending status: 5/12 complete
Sending status: 5/12 complete
Sending status: 6/12 complete
Sending status: 6/12 complete
Sending status: 7/12 complete
Sending status: 7/12 complete
Sending status: 8/12 complete
Sending status: 8/12 complete
Sending status: 9/12 complete
Sending status: 9/12 complete
Sending status: 10/12 complete
Sending status: 10/12 complete
Sending status: 11/12 complete
Sending status: 11/12 complete
Sending status: 12/12 complete
Sending status: 12/12 complete
Result: !dlroW olleH
Result: Hello World!

Salida del cliente:

STATUS: 1, H:foo.local:66 - 1/12
STATUS: 1, H:foo.local:66 - 2/12
STATUS: 1, H:foo.local:66 - 3/12
STATUS: 1, H:foo.local:66 - 4/12
STATUS: 1, H:foo.local:66 - 5/12
STATUS: 1, H:foo.local:66 - 6/12
STATUS: 1, H:foo.local:66 - 7/12
STATUS: 1, H:foo.local:66 - 8/12
STATUS: 1, H:foo.local:66 - 9/12
STATUS: 1, H:foo.local:66 - 10/12
STATUS: 1, H:foo.local:66 - 11/12
STATUS: 1, H:foo.local:66 - 12/12
COMPLETE: 1, !dlroW olleH
DONE

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskHigh() - Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskLow() - Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskHighBackground() - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::addTaskLowBackground() - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Añade una tarea de alta prioridad para ser ejecutada en paralelo

  • « GearmanClient::addTaskBackground
  • GearmanClient::addTaskHighBackground »
  • PHP Manual
  • GearmanClient
  • Añade una tarea de alta prioridad para ser ejecutada en paralelo

GearmanClient::addTaskHigh

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHigh — Añade una tarea de alta prioridad para ser ejecutada en paralelo

Descripción

public GearmanClient::addTaskHigh ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea de alta prioridad para ser ejecutada en paralelo junto con otras tareas. Este método debe llamarse para todas las tareas de alta prioridad que se deben ejecutar en paralelo y entonces llamar a GearmanClient::runTasks() para realizar el trabajo. Tareas con una alta prioridad se seleccionarán de la cola antes de las que tienen prioridad normal o baja.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si no se puedo añadir la tarea

Ejemplos

Ejemplo #1 Una tarea de prioridad alta junto con dos tareas de prioridad normal

Se incluye una tarea de alta prioridad entre otras dos tareas. Sólo está disponible un trabajador, de modo que se ejecuta una única tarea cada vez y la tarea de alta prioridad se ejecuta primero.

<?php

# Creamos el cliente gearman
$gmc= new GearmanClient();

# Añade el servidor de trabajos por defecto
$gmc->addServer();

# Establece la llamada de retorno para cuando el trabajo esté completado
$gmc->setCompleteCallback("reverse_complete");

# Añade tareas, una de ellas de alta prioridad
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskHigh("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

El resultado del ejemplo sería algo similar a:

COMPLETE: 2, Hello World!
COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
DONE

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskLow() - Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskBackground() - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskHighBackground() - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::addTaskLowBackground() - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo

  • « GearmanClient::addTaskHigh
  • GearmanClient::addTaskLow »
  • PHP Manual
  • GearmanClient
  • Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo

GearmanClient::addTaskHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHighBackground — Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo

Descripción

public GearmanClient::addTaskHighBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea de alta prioridad en segundo plano para ejecutar en paralelo junto con otras tareas. Debe llamarse a este método para todas las tareas que se ejecutan en paralelo y entonces llamar a GearmanClient::runTasks() para realizar el trabajo. Tareas con una alta prioridad se seleccionarán de la cola antes que las tareas de prioridad normal o baja.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si la tarea no puede ser añadida.

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskHigh() - Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskLow() - Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskBackground() - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskLowBackground() - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Añade una tarea de baja prioridad para ejecutar en paralelo

  • « GearmanClient::addTaskHighBackground
  • GearmanClient::addTaskLowBackground »
  • PHP Manual
  • GearmanClient
  • Añade una tarea de baja prioridad para ejecutar en paralelo

GearmanClient::addTaskLow

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLow — Añade una tarea de baja prioridad para ejecutar en paralelo

Descripción

public GearmanClient::addTaskLow ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea de baja prioridad en segundo plano para ejecutar en paralelo junto con otras tareas. Debe llamarse a este método para todas las tareas que se ejecutan en paralelo y entonces llamar a GearmanClient::runTasks() para realizar el trabajo. Tareas con una baja prioridad se seleccionarán de la cola después de las tareas de prioridad normal o alta.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si la tarea no puede ser añadida.

Ejemplos

Ejemplo #1 Una tarea de baja prioridad junto con dos tareas de prioridad normal

Se incluye una tarea de prioridad baja junto a otras dos tareas. Se dispone de un solo trabajador, de modo que únicamente se ejecuta una tarea por vez y la tarea de baja prioridad la última.

<?php

# Crea el cliente gearman
$gmc= new GearmanClient();

# Añade el servidor de trabajos por defecto
$gmc->addServer();

# Establece la llamada de retorno para cuando el trabajo ha terminado
$gmc->setCompleteCallback("reverse_complete");

# Añade tareas, una de ellas de baja prioridad
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskLow("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

El resultado del ejemplo sería algo similar a:

COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
COMPLETE: 2, Hello World!
DONE

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskHigh() - Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskBackground() - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskHighBackground() - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::addTaskLowBackground() - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo

  • « GearmanClient::addTaskLow
  • GearmanClient::addTaskStatus »
  • PHP Manual
  • GearmanClient
  • Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo

GearmanClient::addTaskLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLowBackground — Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo

Descripción

public GearmanClient::addTaskLowBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Añade una tarea de prioridad baja en segundo plano para ser ejecutada en paralelo junto a otras tareas. Debe llamarse a este método para todas las tareas que se ejecutan en paralelo y entonces llamar a GearmanClient::runTasks() para realizar el trabajo. Tareas con una baja prioridad se seleccionarán de la cola después de las tareas de prioridad normal o alta.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

context

Aplicación context a asociar con la tarea

unique

ID único para identificar una tarea en particular

Valores devueltos

Un objeto GearmanTask o false si la tarea no puede ser añadida.

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo
  • GearmanClient::addTaskHigh() - Añade una tarea de alta prioridad para ser ejecutada en paralelo
  • GearmanClient::addTaskLow() - Añade una tarea de baja prioridad para ejecutar en paralelo
  • GearmanClient::addTaskBackground() - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
  • GearmanClient::addTaskHighBackground() - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
  • GearmanClient::runTasks() - Ejecuta una lista de tareas en paralelo


Añade una tarea para obtener el estado

  • « GearmanClient::addTaskLowBackground
  • GearmanClient::clearCallbacks »
  • PHP Manual
  • GearmanClient
  • Añade una tarea para obtener el estado

GearmanClient::addTaskStatus

(PECL gearman >= 0.5.0)

GearmanClient::addTaskStatus — Añade una tarea para obtener el estado

Descripción

public GearmanClient::addTaskStatus ( string $job_handle , string &$context = ? ) : GearmanTask

Usado para pedir información de estado del servidor Gearman que llamará a la función de retorno especificada (usando el método GearmanClient::setStatusCallback()).

Parámetros

job_handle

Manejador de la tarea a obtener el estado

context

Datos a pasar en la llamada a la función de retorno para el estado, generalmente una referencia a un array u objeto.

Valores devueltos

Un objeto GearmanTask.

Ejemplos

Ejemplo #1 Monitor para el estado de finalización de múltiples tareas en segundo plano

Se introduce un retardo artificial en el trabajador del ejemplo para simular un proceso de larga duración. Únicamente se ejecuta un trabajador para este ejemplo.

<?php

/* Creamos el objeto */
$gmclient= new GearmanClient();

/* Añadimos el servidor por defecto */
$gmclient->addServer();

/* Iniciamos varios trabajos en segundo plano y grabamos los manejadores */
$handles = array();
$handles[0] = $gmclient->doBackground("reverse", "Hello World!");
$handles[1] = $gmclient->doBackground("reverse", "!dlroW olleH");

$gmclient->setStatusCallback("reverse_status");

/* Preguntamos constantemente al servidor para ver cuándo terminan los trabajos.
/* mejor método sería usar llamadas de retorno en los eventos */
do
{
   /* Usar la variable en contexto para seguir cuántas tareas han finalizado */
   $done = 0;
   $gmclient->addTaskStatus($handles[0], &$done);
   $gmclient->addTaskStatus($handles[1], &$done);
   $gmclient->runTasks();
   echo "Done: $done\n";
   sleep(1);
}
while ($done != 2);

function reverse_status($task, $done)
{
   if (!$task->isKnown())
      $done++;
}

?>

El resultado del ejemplo sería algo similar a:

Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 2

Ver también

  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea


Elimina todas las funciones de retorno de llamada

  • « GearmanClient::addTaskStatus
  • GearmanClient::clone »
  • PHP Manual
  • GearmanClient
  • Elimina todas las funciones de retorno de llamada

GearmanClient::clearCallbacks

(PECL gearman >= 0.5.0)

GearmanClient::clearCallbacks — Elimina todas las funciones de retorno de llamada

Descripción

public GearmanClient::clearCallbacks ( ) : bool

Elimina todas las funciones de retorno de llamada establecidas anteriormente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Retorna siempre true.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Crea una copia de un objeto GearmanClient

  • « GearmanClient::clearCallbacks
  • GearmanClient::__construct »
  • PHP Manual
  • GearmanClient
  • Crea una copia de un objeto GearmanClient

GearmanClient::clone

(PECL gearman >= 0.5.0)

GearmanClient::clone — Crea una copia de un objeto GearmanClient

Descripción

public GearmanClient::clone ( ) : GearmanClient

Crea una copia de un objeto GearmanClient.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un GearmanClient en caso de éxito, false si hay fallo.


Crea una instancia de GearmanClient

  • « GearmanClient::clone
  • GearmanClient::context »
  • PHP Manual
  • GearmanClient
  • Crea una instancia de GearmanClient

GearmanClient::__construct

(PECL gearman >= 0.5.0)

GearmanClient::__construct — Crea una instancia de GearmanClient

Descripción

public GearmanClient::__construct ( )

Crea una instancia de GearmanClient que representa un cliente que conecta al servidor de trabajos y envía tareas para que sean completadas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanClient.

Ver también

  • GearmanClient::clone() - Crea una copia de un objeto GearmanClient


Obtiene el contexto de la aplicación

  • « GearmanClient::__construct
  • GearmanClient::data »
  • PHP Manual
  • GearmanClient
  • Obtiene el contexto de la aplicación

GearmanClient::context

(PECL gearman >= 0.6.0)

GearmanClient::context — Obtiene el contexto de la aplicación

Descripción

public GearmanClient::context ( ) : string

Obtiene el contexto de la aplicación anteriormente establecido con GearmanClient::setContext().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La misma estructura de datos de contexto establecida con GearmanClient::setContext()

Ver también

  • GearmanClient::setContext() - Establece el contexto de la aplicación


Retorna los datos de aplicación (obsoleto)

  • « GearmanClient::context
  • GearmanClient::do »
  • PHP Manual
  • GearmanClient
  • Retorna los datos de aplicación (obsoleto)

GearmanClient::data

(PECL gearman <= 0.5.0)

GearmanClient::data — Retorna los datos de aplicación (obsoleto)

Descripción

public GearmanClient::data ( ) : string

Obtiene los datos de aplicación fijados anteriormente con GearmanClient::setData().

Nota:

Este método fue reemplazado por GearmanClient::setContext() en la versión 0.6.0 de la extensión Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El mismo string de datos que fue establecido con GearmanClient::setData()

Ver también

  • GearmanClient::setData() - Establece los datos de aplicación (obsoleto)


Ejecuta una sola tarea y retorna el resultado [obsoleto]

  • « GearmanClient::data
  • GearmanClient::doBackground »
  • PHP Manual
  • GearmanClient
  • Ejecuta una sola tarea y retorna el resultado [obsoleto]

GearmanClient::do

(PECL gearman >= 0.5.0)

GearmanClient::do — Ejecuta una sola tarea y retorna el resultado [obsoleto]

Descripción

public GearmanClient::do ( string $function_name , string $workload , string $unique = ? ) : string

El método GearmanClient::do() es obsoleto desde pecl/gearman 1.0.0. Use GearmanClient::doNormal().

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

Un string representando el resultado de la tarea ejecutada.

Ejemplos

Ejemplo #1 Envío de un trabajo con retorno inmediato

<?php

# Código del cliente

echo "Starting\n";

# Creación del objeto cliente
$gmclient= new GearmanClient();

# Adición del servidor por defecto (localhost).
$gmclient->addServer();

echo "Sending job\n";

$result = $gmclient->doNormal("reverse", "Hello!");

echo "Success: $result\n";

?>
<?php

echo "Starting\n";

# Creación del objeto trabajador
$gmworker= new GearmanWorker();

# Adición del servidor por defecto (localhost).
$gmworker->addServer();

# Registra la función "reverse" en el servidor. Cambiar la función del trabajador
# a "reverse_fn_fast" para usar un trabajar más rápido que no genera salida.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

El resultado del ejemplo sería algo similar a:

Starting
Sending job
Success: !olleH

Ejemplo #2 Envío de un trabajo y obtención del estado incremental

Se envía un trabajo y el script comprueba constantemente mediante un bucle la información de estado. El trabajador tiene un retardo artificial que provoca un trabajo de larga duración y envía el estado y datos según se van procesando. Cada llamada a GearmanClient::do() produce información de estado del trabajo en ejecución.

<?php

# Código del cliente

# Creamos el objeto cliente
$gmclient= new GearmanClient();

# Añadimos el servidor por defecto (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Enviamos trabajo "reverse"
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");
  # Comprobamos llegada de posibles paquetes y errores

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>
<?php

# Código del trabajador

echo "Starting\n";

# Creamos el objeto trabajador
$gmworker= new GearmanWorker();

# Añadimos servidor por defecto (localhost).
$gmworker->addServer();

# Registramos la función "reverse" en el servidor
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # Este bucle para comprobar el estado no es necesario, tan sólo muestra como funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " + $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Retornamos lo que queremos enviar al cliente
  return $result;
}

?>

El resultado del ejemplo sería algo similar a:

Worker output:

Starting
Waiting for job...
Received job: H:foo.local:106
Workload: Hello! (6)
1/6 complete
2/6 complete
3/6 complete
4/6 complete
5/6 complete
6/6 complete
Result: !olleH

Client output:

Starting
Sending job
Status: 1/6 complete
Data: H
Status: 2/6 complete
Data: e
Status: 3/6 complete
Data: l
Status: 4/6 complete
Data: l
Status: 5/6 complete
Data: o
Status: 6/6 complete
Data: !
Success: !olleH

Ver también

  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Ejecuta una tarea en segundo plano

  • « GearmanClient::do
  • GearmanClient::doHigh »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea en segundo plano

GearmanClient::doBackground

(PECL gearman >= 0.5.0)

GearmanClient::doBackground — Ejecuta una tarea en segundo plano

Descripción

public GearmanClient::doBackground ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una tarea en segundo plano, retornando el manejador del trabajo que puede ser usado para obtener el estado de la tarea en ejecución.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

El manejador de la tarea enviada.

Ejemplos

Ejemplo #1 Envío y monitorización de un trabajo en segundo plano

El trabajador de este ejemplo tiene un retardo artificial introducido para imitar un trabajo de larga duración. El script cliente comprueba periódicamente el estado del trabajo en ejecución.

<?php

/* Creamos nuestro objeto */
$gmclient= new GearmanClient();

/* Añade el servidor por defecto */
$gmclient->addServer();

/* Ejecuta un cliente "reverse" */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // el trabajo se conoce, así que no se hace
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denominator: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

El resultado del ejemplo sería algo similar a:

Running: true, numerator: 3, denominator: 14
Running: true, numerator: 6, denominator: 14
Running: true, numerator: 9, denominator: 14
Running: true, numerator: 12, denominator: 14
Running: false, numerator: 0, denominator: 0
done!

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Ejecuta una tarea de prioridad alta

  • « GearmanClient::doBackground
  • GearmanClient::doHighBackground »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea de prioridad alta

GearmanClient::doHigh

(PECL gearman >= 0.5.0)

GearmanClient::doHigh — Ejecuta una tarea de prioridad alta

Descripción

public GearmanClient::doHigh ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una tarea de prioridad alta y retorna un string con el resultado. Depende de GearmanClient y GearmanWorker aceptar el formato del resultado Las tareas de alta prioridad se ejecutan antes que las de prioridad normal o baja en la cola de trabajos.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

Un string representando el resultado de la tarea en ejecución.

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Ejecuta una tarea de alta prioridad en segundo plano

  • « GearmanClient::doHigh
  • GearmanClient::doJobHandle »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea de alta prioridad en segundo plano

GearmanClient::doHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::doHighBackground — Ejecuta una tarea de alta prioridad en segundo plano

Descripción

public GearmanClient::doHighBackground ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una tarea del alta prioridad en segundo plano, retornando el manejador del trabajo que puede ser usado para obtener el estado de la tarea en ejecución. Las tareas de alta prioridad tienen preferencia sobre las de prioridad normal o baja en la cola de tareas.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

El manejador del trabajo para la tarea enviada.

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Obtiene el manejador de trabajo para la tarea en ejecución

  • « GearmanClient::doHighBackground
  • GearmanClient::doLow »
  • PHP Manual
  • GearmanClient
  • Obtiene el manejador de trabajo para la tarea en ejecución

GearmanClient::doJobHandle

(PECL gearman >= 0.5.0)

GearmanClient::doJobHandle — Obtiene el manejador de trabajo para la tarea en ejecución

Descripción

public GearmanClient::doJobHandle ( ) : string

Retorna el manejador de trabajo para la tarea en ejecución. Debería usarse entre llamadas repetidas a GearmanClient::doNormal(). El manejador puede ser usado para obtener información de la tarea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El manejador de trabajo para la tarea en ejecución.

Ver también

  • GearmanClient::jobStatus() - Obtiene el estado de un trabajo en segundo plano


Ejecuta una tarea de baja prioridad

  • « GearmanClient::doJobHandle
  • GearmanClient::doLowBackground »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea de baja prioridad

GearmanClient::doLow

(PECL gearman >= 0.5.0)

GearmanClient::doLow — Ejecuta una tarea de baja prioridad

Descripción

public GearmanClient::doLow ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una tarea de baja prioridad y retorna un string con el resultado. Depende de GearmanClient y GearmanWorker aceptar el formato del resultado. Las tareas de prioridad normal o algo tienen preferencia sobre las de baja prioridad en la cola de trabajos.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

Un string representando el resultado de la tarea en ejecución.

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Ejecuta una tarea de prioridad baja en segundo plano

  • « GearmanClient::doLow
  • GearmanClient::doNormal »
  • PHP Manual
  • GearmanClient
  • Ejecuta una tarea de prioridad baja en segundo plano

GearmanClient::doLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::doLowBackground — Ejecuta una tarea de prioridad baja en segundo plano

Descripción

public GearmanClient::doLowBackground ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una tarea de prioridad baja en segundo plano, retornando el manejador del trabajo que puede ser usado para obtener el estado de la tarea en ejecución. Las tareas de prioridad normal o alta tienen preferencia sobre las de baja prioridad en la cola de trabajos.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

El manejador de trabajo para la tarea enviada.

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano


Ejecutar una única tarea y devolver un resultado

  • « GearmanClient::doLowBackground
  • GearmanClient::doStatus »
  • PHP Manual
  • GearmanClient
  • Ejecutar una única tarea y devolver un resultado

GearmanClient::doNormal

(No hay información de versión disponible, podría estar únicamente en Git)

GearmanClient::doNormal — Ejecutar una única tarea y devolver un resultado

Descripción

public GearmanClient::doNormal ( string $function_name , string $workload , string $unique = ? ) : string

Ejecuta una única tarea y devuelve una representación de tipo string del resultado. Es responsabilidad de GearmanClient y GearmanWorker ponerse de acuerdo en le formato del resultado.

Parámetros

function_name

Función registrada que ejecutará el worker

workload

Datos serializados a ser procesados

unique

ID único para identificar una tarea en particular

Valores devueltos

Una representación de tipo string de los resultados de ejecutar una tarea.

Ejemplos

Ejemplo #1 Envío de un trabajo sencillo con retorno inmediato

<?php

?>
<?php

# Código del cliente

echo "Iniciando\n";

# Crear el objeto cliente.
$gmclient= new GearmanClient();

# Añadir un servidor predeterminado (localhost).
$gmclient->addServer();

echo "Enviando el trabajo\n";

$result = $gmclient->doNormal("reverse", "Hola!");

echo "Éxito: $result\n";

?>
<?php

echo "Iniciando\n";

# Crear el objeto trabajador.
$gmworker= new GearmanWorker();

# Añadir un servidor predeterminado (localhost).
$gmworker->addServer();

# Registrar la función "reverse" con el servidor. Cambiar la función trabajadora a
# "reverse_fn_fast" para un trabajador más rápido sin salida.
$gmworker->addFunction("reverse", "reverse_fn");

print "Esperando al trabajo...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

El resultado del ejemplo sería algo similar a:

Iniciando
Enviando el trabajo
Éxito: !aloH¡

Ejemplo #2 Enviar un trabajo y recuperar el estado incremental

Se envía un trabajo y el script itera para recuperar la información del estado. El trabajador posee una demora artificial que resulta en una ejecución más larga del trabajo y envía el estado y los datos durante el procesamiento. Cada llamada subsiguiente a GearmanClient::doNormal() producirá información de estado sobre el trabajo en ejecución.

<?php

# Código del cliente

# Crear el objeto cliente.
$gmclient= new GearmanClient();

# Añadir un servidor predeterminado (localhost).
$gmclient->addServer();

echo "Enviando el trabajo\n";

# Enviar el trabajo al revés
do
{
  $result = $gmclient->doNormal("reverse", "¡Hola!");
  # Verificar los paquetes devueltos y los errores.

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Datos: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Estado: $numerator/$denominator completo\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Falló\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Éxito: $result\n";

?>
<?php

# Código del trabajador

echo "Iniciando\n";

# Crear el objeto trabajador.
$gmworker= new GearmanWorker();

# Añadir un servidor predeterminado (localhost).
$gmworker->addServer();

# Registrar la función "reverse" con el servidor.
$gmworker->addFunction("reverse", "reverse_fn");

print "Esperando el trabajo...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Trabajo recibido: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Cantidad de trabajo: $workload ($workload_size)\n";

  # Este bucle de estado no es necesario, simplemente muestra cómo funciona
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Enviando el estado: " + $x + 1 . "/$workload_size completo\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Resultado: $result\n";

  # Devolver lo que queremos volver a enviar al cliente.
  return $result;
}

?>

El resultado del ejemplo sería algo similar a:

Salida del trabajador:

Iniciando
Esperando el trabajo...
Trabajo recibido: H:foo.local:106
Cantidad de trabajo: ¡Hola! (6)
1/6 completo
2/6 completo
3/6 completo
4/6 completo
5/6 completo
6/6 completo
Resultado: !aloH!

Client output:

Iniciando
Enviando el trabajo
Estado: 1/6 completo
Data: ¡
Estado: 2/6 completo
Data: H
Estado: 3/6 completo
Data: o
Estado: 4/6 completo
Data: l
Estado: 5/6 completo
Data: a
Estado: 6/6 completo
Data: !
Éxito: !aloH!

Ver también

  • GearmanClient::doHigh() - Ejecuta una tarea de prioridad alta
  • GearmanClient::doLow() - Ejecuta una tarea de baja prioridad
  • GearmanClient::doBackground() - Ejecuta una tarea en segundo plano
  • GearmanClient::doHighBackground() - Ejecuta una tarea de alta prioridad en segundo plano
  • GearmanClient::doLowBackground() - Ejecuta una tarea de prioridad baja en segundo plano


Obtiene el estado de la tarea en ejecución

  • « GearmanClient::doNormal
  • GearmanClient::echo »
  • PHP Manual
  • GearmanClient
  • Obtiene el estado de la tarea en ejecución

GearmanClient::doStatus

(PECL gearman >= 0.5.0)

GearmanClient::doStatus — Obtiene el estado de la tarea en ejecución

Descripción

public GearmanClient::doStatus ( ) : array

Retorna el estado para la tarea en ejecución. Debería usarse entre llamadas repetidas a GearmanClient::doNormal().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array representando el porcentaje completado dado como una fracción, el primer elemento es el numerador y el segundo es el denominador.

Ejemplos

Ejemplo #1 Obtiene el estado de un trabajo en ejecución de larga duración

El trabajador de este ejemplo tiene un retardo artificial añadido durante el procesado del string a dar la vuelta. Tras cada retardo, se llama a GearmanJob::status() que el cliente recoge.

<?php

echo "Starting\n";

# Crea el objeto del cliente
$gmclient= new GearmanClient();

# Añade el servidor por defecto (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Envía el trabajo "reverse"
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");

  # Comprueba retorno de posibles paquetes y errores
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      break;
    case GEARMAN_WORK_STATUS:
      # Obtiene el estado del trabajo actual
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>

El resultado del ejemplo sería algo similar a:

Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH

Ver también

  • GearmanClient::doNormal() - Ejecutar una única tarea y devolver un resultado
  • GearmanJob::status() - Envía el estado (obsoleto)


Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]

  • « GearmanClient::doStatus
  • GearmanClient::error »
  • PHP Manual
  • GearmanClient
  • Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]

GearmanClient::echo

(PECL gearman >= 0.5.0)

GearmanClient::echo — Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]

Descripción

public GearmanClient::echo ( string $workload ) : bool

El método GearmanClient::echo() es obsoleto desde pecl/gearman 1.0.0. Use GearmanClient::ping().

Parámetros

workload

Datos arbitrarios serializados a ser retornados

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Retorna un string con el último error encontrado

  • « GearmanClient::echo
  • GearmanClient::getErrno »
  • PHP Manual
  • GearmanClient
  • Retorna un string con el último error encontrado

GearmanClient::error

(PECL gearman >= 0.5.0)

GearmanClient::error — Retorna un string con el último error encontrado

Descripción

public GearmanClient::error ( ) : string

Retorna un string con el último error encontrado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un string de error entendible.

Ver también

  • GearmanClient::getErrno() - Obtiene un valor errno


Obtiene un valor errno

  • « GearmanClient::error
  • GearmanClient::jobStatus »
  • PHP Manual
  • GearmanClient
  • Obtiene un valor errno

GearmanClient::getErrno

(PECL gearman >= 0.5.0)

GearmanClient::getErrno — Obtiene un valor errno

Descripción

public GearmanClient::getErrno ( ) : int

Valor de errno en el caso de retornar un valor GEARMAN_ERRNO.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un errno de Gearman válido.

Ver también

  • GearmanClient::error() - Retorna un string con el último error encontrado


Obtiene el estado de un trabajo en segundo plano

  • « GearmanClient::getErrno
  • GearmanClient::ping »
  • PHP Manual
  • GearmanClient
  • Obtiene el estado de un trabajo en segundo plano

GearmanClient::jobStatus

gearman_job_status

(PECL gearman >= 0.5.0)

GearmanClient::jobStatus -- gearman_job_status — Obtiene el estado de un trabajo en segundo plano

Descripción

Estilo orientado a objetos (método):

public GearmanClient::jobStatus ( string $job_handle ) : array

Obtiene el estado de un trabajo en segundo plano para un manejador de trabajo dado. La información de estado estecifica si el trabajo es conocido, si está ejecutandose actualmente y el porcentaje completado.

Parámetros

job_handle

El manipulador de la tarea asignado por el servidor Gearman

Valores devueltos

Un array que contiene la información del estado para el trabajo correspondiente al manejador de trabajo indicado. El primer elemento del array es un boolean indicando si el trabajo es conocido, el segundo es un boolean indicando si el trabajo se está ejecutando y el tercer y cuarto elemento corresponden al numerador y denonimador del porcenaje de trabajo completado, respectivamente.

Ejemplos

Ejemplo #1 Monitorización del estado de un trabajo ejecutandose en segundo plano

<?php

/* Creamos el objeto */
$gmclient= new GearmanClient();

/* Añadimos el servidor por defecto */
$gmclient->addServer();

/* Ejecutamos el cliente "reverse" */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // the job is known so it is not done
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denomintor: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

El resultado del ejemplo sería algo similar a:

Running: true, numerator: 3, denomintor: 14
Running: true, numerator: 6, denomintor: 14
Running: true, numerator: 9, denomintor: 14
Running: true, numerator: 12, denomintor: 14
Running: false, numerator: 0, denomintor: 0
done!

Ver también

  • GearmanClient::doStatus() - Obtiene el estado de la tarea en ejecución


Envar datos a todos los servidores de trabajo para ver si los repiten

  • « GearmanClient::jobStatus
  • GearmanClient::removeOptions »
  • PHP Manual
  • GearmanClient
  • Envar datos a todos los servidores de trabajo para ver si los repiten

GearmanClient::ping

(No hay información de versión disponible, podría estar únicamente en Git)

GearmanClient::ping — Envar datos a todos los servidores de trabajo para ver si los repiten

Descripción

public GearmanClient::ping ( string $workload ) : bool

Envía datos arbitrarios a todos los servidores de trabajo para ver si los repiten. Los datos enviados no se usan o se procesan de ninguna manera. Se utilizan principalmente para pruebas y depuración.

Parámetros

workload

Algunos datos serializados arbitrarios para que sean repetidos

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Elimina opciones del cliente

  • « GearmanClient::ping
  • GearmanClient::returnCode »
  • PHP Manual
  • GearmanClient
  • Elimina opciones del cliente

GearmanClient::removeOptions

(PECL gearman >= 0.6.0)

GearmanClient::removeOptions — Elimina opciones del cliente

Descripción

public GearmanClient::removeOptions ( int $options ) : bool

Elimina una o más opciones.

Parámetros

options

Las opciones a ser eliminadas

Valores devueltos

Siempre retorna true.


Obtiene el último código de retorno de Gearman

  • « GearmanClient::removeOptions
  • GearmanClient::runTasks »
  • PHP Manual
  • GearmanClient
  • Obtiene el último código de retorno de Gearman

GearmanClient::returnCode

(PECL gearman >= 0.5.0)

GearmanClient::returnCode — Obtiene el último código de retorno de Gearman

Descripción

public GearmanClient::returnCode ( ) : int

Retorna el último código de retorno de Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un código de retorno válido de Gearman.


Ejecuta una lista de tareas en paralelo

  • « GearmanClient::returnCode
  • GearmanClient::setClientCallback »
  • PHP Manual
  • GearmanClient
  • Ejecuta una lista de tareas en paralelo

GearmanClient::runTasks

(PECL gearman >= 0.5.0)

GearmanClient::runTasks — Ejecuta una lista de tareas en paralelo

Descripción

public GearmanClient::runTasks ( ) : bool

Para un set de tareas previamente añadidas con GearmanClient::addTask(),
GearmanClient::addTaskHigh(), GearmanClient::addTaskLow(),
GearmanClient::addTaskBackground(), GearmanClient::addTaskHighBackground(), or
GearmanClient::addTaskLowBackground(), esta llamada
ordena comenzar la ejecución de las tareas en paralelo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo


Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)

  • « GearmanClient::runTasks
  • GearmanClient::setCompleteCallback »
  • PHP Manual
  • GearmanClient
  • Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)

GearmanClient::setClientCallback

(PECL gearman <= 0.5.0)

GearmanClient::setClientCallback — Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)

Descripción

public GearmanClient::setClientCallback ( callable $callback ) : void

Establece la función de llamada de retorno que acepta paquetes de datos para una tarea. La función de llamada de retorno debe tener un solo argumento, un objeto GearmanTask.

Nota:

Este método ha sido reemplazado por GearmanClient::setDataCallback() en la versión 0.6.0 de la extensión Gearman..

Parámetros

callback

Una función o método a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Especifica una función a ser llamada cuando se complete una tarea

  • « GearmanClient::setClientCallback
  • GearmanClient::setContext »
  • PHP Manual
  • GearmanClient
  • Especifica una función a ser llamada cuando se complete una tarea

GearmanClient::setCompleteCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCompleteCallback — Especifica una función a ser llamada cuando se complete una tarea

Descripción

public GearmanClient::setCompleteCallback ( callable $callback ) : bool

Especifica una función a ser llamada cuando se complete una tarea. La función de llamada de retorno acepta un único argument, un objeto GearmanTask.

Parámetros

callback

Función a ser llamada

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece el contexto de la aplicación

  • « GearmanClient::setCompleteCallback
  • GearmanClient::setCreatedCallback »
  • PHP Manual
  • GearmanClient
  • Establece el contexto de la aplicación

GearmanClient::setContext

(PECL gearman >= 0.6.0)

GearmanClient::setContext — Establece el contexto de la aplicación

Descripción

public GearmanClient::setContext ( string $context ) : bool

Establece un string arbitrario para dar contexto a la aplicación que pueda ser posteriormente recuperado por GearmanClient::context().

Parámetros

context

Datos arbitrarios para el contexto

Valores devueltos

Retorna siempre true.

Ver también

  • GearmanClient::context() - Obtiene el contexto de la aplicación


Establece una llamada de retornopara cuando se encola una tarea

  • « GearmanClient::setContext
  • GearmanClient::setData »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retornopara cuando se encola una tarea

GearmanClient::setCreatedCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCreatedCallback — Establece una llamada de retornopara cuando se encola una tarea

Descripción

public GearmanClient::setCreatedCallback ( string $callback ) : bool

Establece una función a ser llamada cuando se recibe una tarea y es encolada por el servidor de trabajos Gearman. La función acepta un único parámetro, un objeto GearmanClient.

Parámetros

callback

Función a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece los datos de aplicación (obsoleto)

  • « GearmanClient::setCreatedCallback
  • GearmanClient::setDataCallback »
  • PHP Manual
  • GearmanClient
  • Establece los datos de aplicación (obsoleto)

GearmanClient::setData

(PECL gearman <= 0.5.0)

GearmanClient::setData — Establece los datos de aplicación (obsoleto)

Descripción

public GearmanClient::setData ( string $data ) : bool

Establece datos arbitrarios para la aplicación que pueden ser leídos posteriormente con GearmanClient::data().

Nota:

Este método ha sido reemplazado por GearmanCient::setContext() en la versión 0.6.0 de la extensión Gearman.

Parámetros

data

Valores devueltos

Siempre retorna true.

Ver también

  • GearmanClient::data() - Retorna los datos de aplicación (obsoleto)


Función de llamada de retorno para cuando hay un paquete de datos para la tarea

  • « GearmanClient::setData
  • GearmanClient::setExceptionCallback »
  • PHP Manual
  • GearmanClient
  • Función de llamada de retorno para cuando hay un paquete de datos para la tarea

GearmanClient::setDataCallback

(PECL gearman >= 0.6.0)

GearmanClient::setDataCallback — Función de llamada de retorno para cuando hay un paquete de datos para la tarea

Descripción

public GearmanClient::setDataCallback ( callable $callback ) : bool

Establece la función de llamada de retorno para aceptar paquetes de datos para una tarea. La función acepta un único argumento, un objeto GearmanTask.

Parámetros

callback

Función o método a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece una llamada de retorno para excepciones del trabajador

  • « GearmanClient::setDataCallback
  • GearmanClient::setFailCallback »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retorno para excepciones del trabajador

GearmanClient::setExceptionCallback

(PECL gearman >= 0.5.0)

GearmanClient::setExceptionCallback — Establece una llamada de retorno para excepciones del trabajador

Descripción

public GearmanClient::setExceptionCallback ( callable $callback ) : bool

Especifica una función a llamar cuando un trabajador envía una excepción.

Parámetros

callback

Función a llamar cuando un trabajador lanza una excepción

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece una llamada de retorno para cuando falla un trabajo

  • « GearmanClient::setExceptionCallback
  • GearmanClient::setOptions »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retorno para cuando falla un trabajo

GearmanClient::setFailCallback

(PECL gearman >= 0.5.0)

GearmanClient::setFailCallback — Establece una llamada de retorno para cuando falla un trabajo

Descripción

public GearmanClient::setFailCallback ( callable $callback ) : bool

Establece una función de retorno a usar cuando una tarea no es completada satisfactoriamente. La función acepta un argumento, un objeto GearmanTask.

Parámetros

callback

Función a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece opciones del cliente

  • « GearmanClient::setFailCallback
  • GearmanClient::setStatusCallback »
  • PHP Manual
  • GearmanClient
  • Establece opciones del cliente

GearmanClient::setOptions

(PECL gearman >= 0.5.0)

GearmanClient::setOptions — Establece opciones del cliente

Descripción

public GearmanClient::setOptions ( int $options ) : bool

Establece una o más opciones del cliente.

Parámetros

options

Las opciones a fijar

Valores devueltos

Siempre retorna true.


Establece una llamada de retorno para obtener el estado de una tarea

  • « GearmanClient::setOptions
  • GearmanClient::setTimeout »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retorno para obtener el estado de una tarea

GearmanClient::setStatusCallback

(PECL gearman >= 0.5.0)

GearmanClient::setStatusCallback — Establece una llamada de retorno para obtener el estado de una tarea

Descripción

public GearmanClient::setStatusCallback ( callable $callback ) : bool

Establece una función de llamada de retorno usada para obtener el estado actualizado de un trabajador.. La función acepta un único argumento, un objeto GearmanTask.

Parámetros

callback

Función a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket

  • « GearmanClient::setStatusCallback
  • GearmanClient::setWarningCallback »
  • PHP Manual
  • GearmanClient
  • Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket

GearmanClient::setTimeout

(PECL gearman >= 0.6.0)

GearmanClient::setTimeout — Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket

Descripción

public GearmanClient::setTimeout ( int $timeout ) : bool

Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket

Parámetros

timeout

Un intervalo de tiempo en milisegundos

Valores devueltos

Siempre retorna true.


Establece una llamada de retorno para los warnings del trabajador

  • « GearmanClient::setTimeout
  • GearmanClient::setWorkloadCallback »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retorno para los warnings del trabajador

GearmanClient::setWarningCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWarningCallback — Establece una llamada de retorno para los warnings del trabajador

Descripción

public GearmanClient::setWarningCallback ( callable $callback ) : bool

Establece una función a ser llamada cuando un trabajador envía un warning. La función acepta un único argumento, un objeto GearmanTask.

Parámetros

callback

Función a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWorkloadCallback() - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos


Establece una llamada de retorno para aceptar actualizaciones incrementales de datos

  • « GearmanClient::setWarningCallback
  • GearmanClient::timeout »
  • PHP Manual
  • GearmanClient
  • Establece una llamada de retorno para aceptar actualizaciones incrementales de datos

GearmanClient::setWorkloadCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWorkloadCallback — Establece una llamada de retorno para aceptar actualizaciones incrementales de datos

Descripción

public GearmanClient::setWorkloadCallback ( callable $callback ) : bool

Establece una función a ser llamada cuando un trabajador necesita enviar datos antes de completar el trabajo. Un trabajador puede realizar esta acción cuando necesita enviar actualizaciones, enviar resultados parciales o enviar datos durante trabajados de larga duración. La función acepta un único argumento, un objeto GearmanTask.

Parámetros

callback

Función a llamar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::setDataCallback() - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
  • GearmanClient::setCompleteCallback() - Especifica una función a ser llamada cuando se complete una tarea
  • GearmanClient::setCreatedCallback() - Establece una llamada de retornopara cuando se encola una tarea
  • GearmanClient::setExceptionCallback() - Establece una llamada de retorno para excepciones del trabajador
  • GearmanClient::setFailCallback() - Establece una llamada de retorno para cuando falla un trabajo
  • GearmanClient::setStatusCallback() - Establece una llamada de retorno para obtener el estado de una tarea
  • GearmanClient::setWarningCallback() - Establece una llamada de retorno para los warnings del trabajador


Obtiene el tiempo máximo de inactividad de entrada/salida para el socket

  • « GearmanClient::setWorkloadCallback
  • GearmanClient::wait »
  • PHP Manual
  • GearmanClient
  • Obtiene el tiempo máximo de inactividad de entrada/salida para el socket

GearmanClient::timeout

(PECL gearman >= 0.6.0)

GearmanClient::timeout — Obtiene el tiempo máximo de inactividad de entrada/salida para el socket

Descripción

public GearmanClient::timeout ( ) : int

Retorna el tiempo máximo de inactividad de entrada/salida en milisegundos para el socket.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Tiempo máximo en milisegundos a esperar para actividad de entrada/salida. Un valor negativo significa tiempo infinito.

Ver también

  • GearmanClient::setTimeout() - Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket


Wait for I/O activity on all connections in a client

  • « GearmanClient::timeout
  • GearmanJob »
  • PHP Manual
  • GearmanClient
  • Wait for I/O activity on all connections in a client

GearmanClient::wait

(PECL gearman >= 0.6.0)

GearmanClient::wait — Wait for I/O activity on all connections in a client

Descripción

public GearmanClient::wait ( ) : bool

This waits for activity from any one of the connected servers.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true on success false on an error.

Ver también

  • GearmanWorker::wait() - Espera cualquier actividad de uno de los servidores de trabajo


La clase GearmanJob

(PECL gearman >= 0.5.0)

Introducción

Sinopsis de la Clase

GearmanJob {
/* Métodos */
public complete ( string $result ) : bool
public __construct ( )
public data ( string $data ) : bool
public exception ( string $exception ) : bool
public fail ( ) : bool
public functionName ( ) : string
public handle ( ) : string
public returnCode ( ) : int
public sendComplete ( string $result ) : bool
public sendData ( string $data ) : bool
public sendException ( string $exception ) : bool
public sendFail ( ) : bool
public sendStatus ( int $numerator , int $denominator ) : bool
public sendWarning ( string $warning ) : bool
public setReturn ( int $gearman_return_t ) : bool
public status ( int $numerator , int $denominator ) : bool
public unique ( ) : string
public warning ( string $warning ) : bool
public workload ( ) : string
public workloadSize ( ) : int
}

Tabla de contenidos

  • GearmanJob::complete — Envía el resultado y el estado completo (obsoleto)
  • GearmanJob::__construct — Crea una instancia de GearmanJob
  • GearmanJob::data — Envía datos para un trabajo en ejecución (obsoleto)
  • GearmanJob::exception — Envía una excepción para un trabajo en ejecución (obsoleto)
  • GearmanJob::fail — Envía el estado de fallo (obsoleto)
  • GearmanJob::functionName — Retorna el nombre de la función
  • GearmanJob::handle — Retorna el manejador para el trabajo
  • GearmanJob::returnCode — Obtiene el último código de retorno
  • GearmanJob::sendComplete — Envía el resultado y el estado completado
  • GearmanJob::sendData — Envía datos para un trabajo en ejecución
  • GearmanJob::sendException — Envía una excepción para un trabajo en ejecución
  • GearmanJob::sendFail — Envía el estado de fallo
  • GearmanJob::sendStatus — Envía el estado
  • GearmanJob::sendWarning — Envía una advertencia
  • GearmanJob::setReturn — Establece el valor de retorno
  • GearmanJob::status — Envía el estado (obsoleto)
  • GearmanJob::unique — Obtiene el identificador único
  • GearmanJob::warning — Envía un aviso (obsoleto)
  • GearmanJob::workload — Obtiene la carga de trabajo
  • GearmanJob::workloadSize — Obtiene el tamaño de la carga de trabajo


Envía el resultado y el estado completo (obsoleto)

  • « GearmanJob
  • GearmanJob::__construct »
  • PHP Manual
  • GearmanJob
  • Envía el resultado y el estado completo (obsoleto)

GearmanJob::complete

(PECL gearman <= 0.5.0)

GearmanJob::complete — Envía el resultado y el estado completo (obsoleto)

Descripción

public GearmanJob::complete ( string $result ) : bool

Envía los datos que han resultado del proceso y actualiza el estado a completo para este trabajo.

Nota:

Este método ha sido reemplazado por GearmanJob::sendComplete() en la versión 0.6.0 de la extensión Gearman.

Parámetros

result

Los datos que han resultado en formato serializado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendFail() - Envía el estado de fallo
  • GearmanJob::setReturn() - Establece el valor de retorno


Crea una instancia de GearmanJob

  • « GearmanJob::complete
  • GearmanJob::data »
  • PHP Manual
  • GearmanJob
  • Crea una instancia de GearmanJob

GearmanJob::__construct

(PECL gearman >= 0.5.0)

GearmanJob::__construct — Crea una instancia de GearmanJob

Descripción

public GearmanJob::__construct ( )

Crea una instancia de GearmanJob que representa un trabajo que un trabajador debe completar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanJob.


Envía datos para un trabajo en ejecución (obsoleto)

  • « GearmanJob::__construct
  • GearmanJob::exception »
  • PHP Manual
  • GearmanJob
  • Envía datos para un trabajo en ejecución (obsoleto)

GearmanJob::data

(PECL gearman <= 0.5.0)

GearmanJob::data — Envía datos para un trabajo en ejecución (obsoleto)

Descripción

public GearmanJob::data ( string $data ) : bool

Envía datos al servidor de trabajos (y a cualquier cliente a la escucha) para este trabajo.

Nota:

Este método ha sido reemplazado por GearmanJob::sendData() en la versión 0.6.0 de la extensión Gearman.

Parámetros

data

Datos arbitrarios serializados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::workload() - Obtiene la carga de trabajo
  • GearmanTask::data() - Obtiene los datos retornados para una tarea


Envía una excepción para un trabajo en ejecución (obsoleto)

  • « GearmanJob::data
  • GearmanJob::fail »
  • PHP Manual
  • GearmanJob
  • Envía una excepción para un trabajo en ejecución (obsoleto)

GearmanJob::exception

(PECL gearman <= 0.5.0)

GearmanJob::exception — Envía una excepción para un trabajo en ejecución (obsoleto)

Descripción

public GearmanJob::exception ( string $exception ) : bool

Envía la excepción indicada cuando este trabajo está siendo ejecutado.

Nota:

Este método ha sido reemplazado por GearmanJob::sendException() en la versión 0.6.0 de la extensión Gearman.

Parámetros

exception

Descripción de la excepción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::setReturn() - Establece el valor de retorno
  • GearmanJob::sendStatus() - Envía el estado
  • GearmanJob::sendWarning() - Envía una advertencia


Envía el estado de fallo (obsoleto)

  • « GearmanJob::exception
  • GearmanJob::functionName »
  • PHP Manual
  • GearmanJob
  • Envía el estado de fallo (obsoleto)

GearmanJob::fail

(PECL gearman <= 0.5.0)

GearmanJob::fail — Envía el estado de fallo (obsoleto)

Descripción

public GearmanJob::fail ( ) : bool

Envía el estado de fallo para este trabajo, indicando que el trabajo ha fallado por razones conocidas (en contraposición a un fallo debido al lanzamiento de una excepción).

Nota:

Este método ha sido reemplazado por GearmanJob::sendFail() en la versión 0.6.0 de la extensión Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendException() - Envía una excepción para un trabajo en ejecución
  • GearmanJob::setReturn() - Establece el valor de retorno
  • GearmanJob::sendStatus() - Envía el estado
  • GearmanJob::sendWarning() - Envía una advertencia


Retorna el nombre de la función

  • « GearmanJob::fail
  • GearmanJob::handle »
  • PHP Manual
  • GearmanJob
  • Retorna el nombre de la función

GearmanJob::functionName

(PECL gearman >= 0.5.0)

GearmanJob::functionName — Retorna el nombre de la función

Descripción

public GearmanJob::functionName ( ) : string

Retorna el nombre de la función para este trabajo. Esta es la función que se ejecutará para realizar el trabajo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre de la función.

Ver también

  • GearmanTask::function() - Obtiene el nombre de la función asociada (obsoleto)


Retorna el manejador para el trabajo

  • « GearmanJob::functionName
  • GearmanJob::returnCode »
  • PHP Manual
  • GearmanJob
  • Retorna el manejador para el trabajo

GearmanJob::handle

(PECL gearman >= 0.5.0)

GearmanJob::handle — Retorna el manejador para el trabajo

Descripción

public GearmanJob::handle ( ) : string

Retorna el manejador de trabajo asignado por el servidor de trabajos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un manejador de trabajo.

Ver también

  • GearmanTask::jobHandle() - Retorna el manejador del trabajo


Obtiene el último código de retorno

  • « GearmanJob::handle
  • GearmanJob::sendComplete »
  • PHP Manual
  • GearmanJob
  • Obtiene el último código de retorno

GearmanJob::returnCode

(PECL gearman >= 0.5.0)

GearmanJob::returnCode — Obtiene el último código de retorno

Descripción

public GearmanJob::returnCode ( ) : int

Retorna el último código de retorno dado por el servidor de trabajos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un código de retorno válido de Gearman.

Ver también

  • GearmanTask::returnCode() - Retorna el último código de error


Envía el resultado y el estado completado

  • « GearmanJob::returnCode
  • GearmanJob::sendData »
  • PHP Manual
  • GearmanJob
  • Envía el resultado y el estado completado

GearmanJob::sendComplete

(PECL gearman >= 0.6.0)

GearmanJob::sendComplete — Envía el resultado y el estado completado

Descripción

public GearmanJob::sendComplete ( string $result ) : bool

Envía los datos que han resultado y la actualización a estado completado para este trabajo.

Parámetros

result

Resultado en formato serializado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendFail() - Envía el estado de fallo
  • GearmanJob::setReturn() - Establece el valor de retorno


Envía datos para un trabajo en ejecución

  • « GearmanJob::sendComplete
  • GearmanJob::sendException »
  • PHP Manual
  • GearmanJob
  • Envía datos para un trabajo en ejecución

GearmanJob::sendData

(PECL gearman >= 0.6.0)

GearmanJob::sendData — Envía datos para un trabajo en ejecución

Descripción

public GearmanJob::sendData ( string $data ) : bool

Envía datos al servidor de trabajos (y a cualquier cliente a la escucha) para este trabajo.

Parámetros

data

Datos arbitrarios serializados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::workload() - Obtiene la carga de trabajo
  • GearmanTask::data() - Obtiene los datos retornados para una tarea


Envía una excepción para un trabajo en ejecución

  • « GearmanJob::sendData
  • GearmanJob::sendFail »
  • PHP Manual
  • GearmanJob
  • Envía una excepción para un trabajo en ejecución

GearmanJob::sendException

(PECL gearman >= 0.6.0)

GearmanJob::sendException — Envía una excepción para un trabajo en ejecución

Descripción

public GearmanJob::sendException ( string $exception ) : bool

Envía la excepción indicada cuando este trabajo está en ejecución.

Parámetros

exception

Descripción de la excepción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::setReturn() - Establece el valor de retorno
  • GearmanJob::sendStatus() - Envía el estado
  • GearmanJob::sendWarning() - Envía una advertencia


Envía el estado de fallo

  • « GearmanJob::sendException
  • GearmanJob::sendStatus »
  • PHP Manual
  • GearmanJob
  • Envía el estado de fallo

GearmanJob::sendFail

(PECL gearman >= 0.6.0)

GearmanJob::sendFail — Envía el estado de fallo

Descripción

public GearmanJob::sendFail ( ) : bool

Envía el estado de fallo para este trabajo, indicando que el trabajo ha fallado de forma conocida (al contrario que un fallo debido una excepción).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendException() - Envía una excepción para un trabajo en ejecución
  • GearmanJob::setReturn() - Establece el valor de retorno
  • GearmanJob::sendStatus() - Envía el estado
  • GearmanJob::sendWarning() - Envía una advertencia


Envía el estado

  • « GearmanJob::sendFail
  • GearmanJob::sendWarning »
  • PHP Manual
  • GearmanJob
  • Envía el estado

GearmanJob::sendStatus

(PECL gearman >= 0.6.0)

GearmanJob::sendStatus — Envía el estado

Descripción

public GearmanJob::sendStatus ( int $numerator , int $denominator ) : bool

Envía información de estado al servidor de trabajo y a cualquier cliente a la escucha. Usar para especificar qué porcentaje del trabajo ha sido completado.

Parámetros

numerator

El numerador del porcentaje completado, expresado como una fracción.

denominator

El denominador del porcentaje completado, expresado como una fracción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::jobStatus() - Obtiene el estado de un trabajo en segundo plano
  • GearmanTask::taskDenominator() - Obtiene el denominador del porcentaje de tarea completada
  • GearmanTask::taskNumerator() - Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción


Envía una advertencia

  • « GearmanJob::sendStatus
  • GearmanJob::setReturn »
  • PHP Manual
  • GearmanJob
  • Envía una advertencia

GearmanJob::sendWarning

(PECL gearman >= 0.6.0)

GearmanJob::sendWarning — Envía una advertencia

Descripción

public GearmanJob::sendWarning ( string $warning ) : bool

Envía una advertencia para este trabajo mientras está en ejecución.

Parámetros

warning

Un mensaje de advertencia.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendComplete() - Envía el resultado y el estado completado
  • GearmanJob::sendException() - Envía una excepción para un trabajo en ejecución
  • GearmanJob::sendFail() - Envía el estado de fallo


Establece el valor de retorno

  • « GearmanJob::sendWarning
  • GearmanJob::status »
  • PHP Manual
  • GearmanJob
  • Establece el valor de retorno

GearmanJob::setReturn

(PECL gearman >= 0.5.0)

GearmanJob::setReturn — Establece el valor de retorno

Descripción

public GearmanJob::setReturn ( int $gearman_return_t ) : bool

Establece el valor de retorno para este trabajo, indica cómo se ha completado el trabajo.

Parámetros

gearman_return_t

Un valor de retorno válido de Gearman.

Valores devueltos

Descripción...


Envía el estado (obsoleto)

  • « GearmanJob::setReturn
  • GearmanJob::unique »
  • PHP Manual
  • GearmanJob
  • Envía el estado (obsoleto)

GearmanJob::status

(PECL gearman <= 0.5.0)

GearmanJob::status — Envía el estado (obsoleto)

Descripción

public GearmanJob::status ( int $numerator , int $denominator ) : bool

Envía información de estado al servidor de trabajo y a cualquier cliente a la escucha. Usar para especificar qué porcentaje del trabajo ha sido completado.

Nota:

Este método ha sido reemplazado por GearmanJob::sendStatus() en la versión 0.6.0 de la extensión Gearman.

Parámetros

numerator

El numerador del porcentaje completado, expresado como una fracción.

denominator

El denominador del porcentaje completado, expresado como una fracción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanClient::jobStatus() - Obtiene el estado de un trabajo en segundo plano
  • GearmanTask::taskDenominator() - Obtiene el denominador del porcentaje de tarea completada
  • GearmanTask::taskNumerator() - Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción


Obtiene el identificador único

  • « GearmanJob::status
  • GearmanJob::warning »
  • PHP Manual
  • GearmanJob
  • Obtiene el identificador único

GearmanJob::unique

(PECL gearman >= 0.5.0)

GearmanJob::unique — Obtiene el identificador único

Descripción

public GearmanJob::unique ( ) : string

Retorna el identificador único para este trabajo. El identificador es asignado por el cliente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un identificador único.

Ver también

  • GearmanClient::do() - Ejecuta una sola tarea y retorna el resultado [obsoleto]
  • GearmanTask::uuid() - Obtiene el identificador único de una tarea (obsoleto)


Envía un aviso (obsoleto)

  • « GearmanJob::unique
  • GearmanJob::workload »
  • PHP Manual
  • GearmanJob
  • Envía un aviso (obsoleto)

GearmanJob::warning

(PECL gearman <= 0.5.0)

GearmanJob::warning — Envía un aviso (obsoleto)

Descripción

public GearmanJob::warning ( string $warning ) : bool

Envía un aviso para el trabajo mientras está en ejecución.

Nota:

Este método ha sido reemplazado por GearmanJob::sendWarning() en la versión 0.6.0 de la extensión Gearman.

Parámetros

warning

Un mensaje de aviso.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • GearmanJob::sendComplete() - Envía el resultado y el estado completado
  • GearmanJob::sendException() - Envía una excepción para un trabajo en ejecución
  • GearmanJob::sendFail() - Envía el estado de fallo


Obtiene la carga de trabajo

  • « GearmanJob::warning
  • GearmanJob::workloadSize »
  • PHP Manual
  • GearmanJob
  • Obtiene la carga de trabajo

GearmanJob::workload

(PECL gearman >= 0.5.0)

GearmanJob::workload — Obtiene la carga de trabajo

Descripción

public GearmanJob::workload ( ) : string

Retorna la carga de trabajo. Es información serializada que debe ser procesada por el trabajador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Datos serializados.

Ver también

  • GearmanClient::do() - Ejecuta una sola tarea y retorna el resultado [obsoleto]
  • GearmanJob::workloadSize() - Obtiene el tamaño de la carga de trabajo


Obtiene el tamaño de la carga de trabajo

  • « GearmanJob::workload
  • GearmanTask »
  • PHP Manual
  • GearmanJob
  • Obtiene el tamaño de la carga de trabajo

GearmanJob::workloadSize

(PECL gearman >= 0.5.0)

GearmanJob::workloadSize — Obtiene el tamaño de la carga de trabajo

Descripción

public GearmanJob::workloadSize ( ) : int

Retorna el tamaño de la carga de trabajo (datos que el trabajador tiene que procesar) en bytes.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El tamaño en bytes.

Ver también

  • GearmanJob::workload() - Obtiene la carga de trabajo


La clase GearmanTask

(PECL gearman >= 0.5.0)

Introducción

Sinopsis de la Clase

GearmanTask {
/* Métodos */
public __construct ( )
public create ( ) : GearmanTask
public data ( ) : string
public dataSize ( ) : int
public function ( ) : string
public functionName ( ) : string
public isKnown ( ) : bool
public isRunning ( ) : bool
public jobHandle ( ) : string
public recvData ( int $data_len ) : array
public returnCode ( ) : int
public sendData ( string $data ) : int
public sendWorkload ( string $data ) : int
public taskDenominator ( ) : int
public taskNumerator ( ) : int
public unique ( ) : string
public uuid ( ) : string
}

Tabla de contenidos

  • GearmanTask::__construct — Crea una instancia de GearmanTask
  • GearmanTask::create — Crea una tarea (obsoleto)
  • GearmanTask::data — Obtiene los datos retornados para una tarea
  • GearmanTask::dataSize — Obtiene el tamaño de la información retornada
  • GearmanTask::function — Obtiene el nombre de la función asociada (obsoleto)
  • GearmanTask::functionName — Retorna el nombre de la función asociada
  • GearmanTask::isKnown — Determina si la tarea es conocida
  • GearmanTask::isRunning — Comprueba si la tarea está siendo ejecutada
  • GearmanTask::jobHandle — Retorna el manejador del trabajo
  • GearmanTask::recvData — Guarda un trabajo o los datos resultantes de una tarea en un buffer
  • GearmanTask::returnCode — Retorna el último código de error
  • GearmanTask::sendData — Envía datos a una tarea (obsoleto)
  • GearmanTask::sendWorkload — Envía datos a una tarea
  • GearmanTask::taskDenominator — Obtiene el denominador del porcentaje de tarea completada
  • GearmanTask::taskNumerator — Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción
  • GearmanTask::unique — Obtiene el identificador único de una tarea
  • GearmanTask::uuid — Obtiene el identificador único de una tarea (obsoleto)


Crea una instancia de GearmanTask

  • « GearmanTask
  • GearmanTask::create »
  • PHP Manual
  • GearmanTask
  • Crea una instancia de GearmanTask

GearmanTask::__construct

(PECL gearman >= 0.5.0)

GearmanTask::__construct — Crea una instancia de GearmanTask

Descripción

public GearmanTask::__construct ( )

Crea una instancia GearmanTask que representa una tarea para enviar al servidor de trabajos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanTask.


Crea una tarea (obsoleto)

  • « GearmanTask::__construct
  • GearmanTask::data »
  • PHP Manual
  • GearmanTask
  • Crea una tarea (obsoleto)

GearmanTask::create

(PECL gearman <= 0.5.0)

GearmanTask::create — Crea una tarea (obsoleto)

Descripción

public GearmanTask::create ( ) : GearmanTask

Retorna un nuevo objeto GearmanTask.

Nota:

Este método fue eliminado en la versión 0.6.0 de la extensión Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanTask o false en caso de error.


Obtiene los datos retornados para una tarea

  • « GearmanTask::create
  • GearmanTask::dataSize »
  • PHP Manual
  • GearmanTask
  • Obtiene los datos retornados para una tarea

GearmanTask::data

(PECL gearman >= 0.5.0)

GearmanTask::data — Obtiene los datos retornados para una tarea

Descripción

public GearmanTask::data ( ) : string

Obtiene los datos retornados para una tarea por un trabajador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los datos serialziados, o false en caso de no haberlos.

Ver también

  • GearmanTask::dataSize() - Obtiene el tamaño de la información retornada


Obtiene el tamaño de la información retornada

  • « GearmanTask::data
  • GearmanTask::function »
  • PHP Manual
  • GearmanTask
  • Obtiene el tamaño de la información retornada

GearmanTask::dataSize

(PECL gearman >= 0.5.0)

GearmanTask::dataSize — Obtiene el tamaño de la información retornada

Descripción

public GearmanTask::dataSize ( ) : int

Retorna el tamaño de los datos que serán devueltos por una tarea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El tamaño de los datos, o false en caso de no haberlos.

Ver también

  • GearmanTask::data() - Obtiene los datos retornados para una tarea


Obtiene el nombre de la función asociada (obsoleto)

  • « GearmanTask::dataSize
  • GearmanTask::functionName »
  • PHP Manual
  • GearmanTask
  • Obtiene el nombre de la función asociada (obsoleto)

GearmanTask::function

(PECL gearman <= 0.5.0)

GearmanTask::function — Obtiene el nombre de la función asociada (obsoleto)

Descripción

public GearmanTask::function ( ) : string

Retorna el nombre de la función que esta tarea tiene asociada con, por ejemplo, la función que el trabajador de Gearman llama.

Nota:

Este método ha sido reemplazado por GearmanTask::functionName() en la versión 0.6.0 de la extensión Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre de la función.


Retorna el nombre de la función asociada

  • « GearmanTask::function
  • GearmanTask::isKnown »
  • PHP Manual
  • GearmanTask
  • Retorna el nombre de la función asociada

GearmanTask::functionName

(PECL gearman >= 0.6.0)

GearmanTask::functionName — Retorna el nombre de la función asociada

Descripción

public GearmanTask::functionName ( ) : string

Retorna el nombre de la función con la que esta tarea está asociada, por ejemplo la función que llama el trabajador Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un nombre de función.


Determina si la tarea es conocida

  • « GearmanTask::functionName
  • GearmanTask::isRunning »
  • PHP Manual
  • GearmanTask
  • Determina si la tarea es conocida

GearmanTask::isKnown

(PECL gearman >= 0.5.0)

GearmanTask::isKnown — Determina si la tarea es conocida

Descripción

public GearmanTask::isKnown ( ) : bool

Retorna información sobre el estado para una tarea, sea o no conocida por el servidor de trabajos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la tarea es conocida, false en otro caso.


Comprueba si la tarea está siendo ejecutada

  • « GearmanTask::isKnown
  • GearmanTask::jobHandle »
  • PHP Manual
  • GearmanTask
  • Comprueba si la tarea está siendo ejecutada

GearmanTask::isRunning

(PECL gearman >= 0.5.0)

GearmanTask::isRunning — Comprueba si la tarea está siendo ejecutada

Descripción

public GearmanTask::isRunning ( ) : bool

Indica si la tarea está actualmente siendo ejecutada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la tarea está siendo ejecutada, false en otro caso.


Retorna el manejador del trabajo

  • « GearmanTask::isRunning
  • GearmanTask::recvData »
  • PHP Manual
  • GearmanTask
  • Retorna el manejador del trabajo

GearmanTask::jobHandle

gearman_job_handle

(PECL gearman >= 0.5.0)

GearmanTask::jobHandle -- gearman_job_handle — Retorna el manejador del trabajo

Descripción

public GearmanTask::jobHandle ( ) : string

Retorna el manejador del trabajo para esta tarea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El manejador del trabajo.

Ver también

  • GearmanClient::doJobHandle() - Obtiene el manejador de trabajo para la tarea en ejecución


Guarda un trabajo o los datos resultantes de una tarea en un buffer

  • « GearmanTask::jobHandle
  • GearmanTask::returnCode »
  • PHP Manual
  • GearmanTask
  • Guarda un trabajo o los datos resultantes de una tarea en un buffer

GearmanTask::recvData

(PECL gearman >= 0.5.0)

GearmanTask::recvData — Guarda un trabajo o los datos resultantes de una tarea en un buffer

Descripción

public GearmanTask::recvData ( int $data_len ) : array

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

data_len

Longitud de datos a leer.

Valores devueltos

Un array cuyo primer elemento es la longitud de los datos leídos y el segundo son los datos. Retorna false si falla la lectura.

Ver también

  • GearmanTask::sendData() - Envía datos a una tarea (obsoleto)


Retorna el último código de error

  • « GearmanTask::recvData
  • GearmanTask::sendData »
  • PHP Manual
  • GearmanTask
  • Retorna el último código de error

GearmanTask::returnCode

(PECL gearman >= 0.5.0)

GearmanTask::returnCode — Retorna el último código de error

Descripción

public GearmanTask::returnCode ( ) : int

Retorna el último código de error de Gearman para esta tarea.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un código de retorno de Gearman válido.

Ver también

  • GearmanClient::returnCode() - Obtiene el último código de retorno de Gearman


Envía datos a una tarea (obsoleto)

  • « GearmanTask::returnCode
  • GearmanTask::sendWorkload »
  • PHP Manual
  • GearmanTask
  • Envía datos a una tarea (obsoleto)

GearmanTask::sendData

(PECL gearman <= 0.5.0)

GearmanTask::sendData — Envía datos a una tarea (obsoleto)

Descripción

public GearmanTask::sendData ( string $data ) : int

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

data

Datos a enviar al trabajador.

Valores devueltos

Longitud de los datos a enviar o false si falla el envío.

Ver también

  • GearmanTask::recvData() - Guarda un trabajo o los datos resultantes de una tarea en un buffer


Envía datos a una tarea

  • « GearmanTask::sendData
  • GearmanTask::taskDenominator »
  • PHP Manual
  • GearmanTask
  • Envía datos a una tarea

GearmanTask::sendWorkload

(PECL gearman >= 0.6.0)

GearmanTask::sendWorkload — Envía datos a una tarea

Descripción

public GearmanTask::sendWorkload ( string $data ) : int

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

data

Datos a enviar al trabajador.

Valores devueltos

Longitud de los datos enviados o false si falla el envío.

Ver también

  • GearmanTask::recvData() - Guarda un trabajo o los datos resultantes de una tarea en un buffer


Obtiene el denominador del porcentaje de tarea completada

  • « GearmanTask::sendWorkload
  • GearmanTask::taskNumerator »
  • PHP Manual
  • GearmanTask
  • Obtiene el denominador del porcentaje de tarea completada

GearmanTask::taskDenominator

(PECL gearman >= 0.5.0)

GearmanTask::taskDenominator — Obtiene el denominador del porcentaje de tarea completada

Descripción

public GearmanTask::taskDenominator ( ) : int

Retorna el denominador del tanto por ciento completado de la tarea, expresado como una fracción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un número entre 0 y 100 o false si no puede ser determinado.

Ver también

  • GearmanTask::taskNumerator() - Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción


Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción

  • « GearmanTask::taskDenominator
  • GearmanTask::unique »
  • PHP Manual
  • GearmanTask
  • Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción

GearmanTask::taskNumerator

(PECL gearman >= 0.5.0)

GearmanTask::taskNumerator — Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción

Descripción

public GearmanTask::taskNumerator ( ) : int

Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un número entre 0 y 100 o false si no se puede determinar.

Ver también

  • GearmanTask::taskDenominator() - Obtiene el denominador del porcentaje de tarea completada


Obtiene el identificador único de una tarea

  • « GearmanTask::taskNumerator
  • GearmanTask::uuid »
  • PHP Manual
  • GearmanTask
  • Obtiene el identificador único de una tarea

GearmanTask::unique

(PECL gearman >= 0.6.0)

GearmanTask::unique — Obtiene el identificador único de una tarea

Descripción

public GearmanTask::unique ( ) : string

Retorna el identificador única para esta tarea. Este se asigna por GearmanClient, a diferencia del manejador de trabajo que es asignado por el servidor de trabajos Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El identificador único, o false si no tiene asignado identificador.

Ver también

  • GearmanClient::do() - Ejecuta una sola tarea y retorna el resultado [obsoleto]
  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo


Obtiene el identificador único de una tarea (obsoleto)

  • « GearmanTask::unique
  • GearmanWorker »
  • PHP Manual
  • GearmanTask
  • Obtiene el identificador único de una tarea (obsoleto)

GearmanTask::uuid

(PECL gearman <= 0.5.0)

GearmanTask::uuid — Obtiene el identificador único de una tarea (obsoleto)

Descripción

public GearmanTask::uuid ( ) : string

Retorna el identificador único de una tarea. Este es asignado por GearmanClient, a diferencia del manejador de trabajo que lo define el servidor de trabajos Gearman.

Nota:

Este método ha sido reemplazado por GearmanTask::unique() en la versión 0.6.0 de la extensión Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El identificador único o false si no tiene identificador asignado.

Ver también

  • GearmanClient::do() - Ejecuta una sola tarea y retorna el resultado [obsoleto]
  • GearmanClient::addTask() - Añade una tarea para ser ejecutada en paralelo


La clase GearmanWorker

(PECL gearman >= 0.5.0)

Introducción

Sinopsis de la Clase

GearmanWorker {
/* Métodos */
public addFunction ( string $function_name , callable $function , mixed &$context = ? , int $timeout = ? ) : bool
public addOptions ( int $option ) : bool
public addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool
public addServers ( string $servers = 127.0.0.1:4730 ) : bool
public clone ( ) : void
public __construct ( )
public echo ( string $workload ) : bool
public error ( ) : string
public getErrno ( ) : int
public options ( ) : int
public register ( string $function_name , int $timeout = ? ) : bool
public removeOptions ( int $option ) : bool
public returnCode ( ) : int
public setId ( string $id ) : bool
public setOptions ( int $option ) : bool
public setTimeout ( int $timeout ) : bool
public timeout ( ) : int
public unregister ( string $function_name ) : bool
public unregisterAll ( ) : bool
public wait ( ) : bool
public work ( ) : bool
}

Tabla de contenidos

  • GearmanWorker::addFunction — Registra y añade una función de retorno
  • GearmanWorker::addOptions — Añade opciones al trabajador
  • GearmanWorker::addServer — Añade un servidor de trabajo
  • GearmanWorker::addServers — Añade servidores de trabajo
  • GearmanWorker::clone — Crea una copia del trabajador
  • GearmanWorker::__construct — Crea una instancia GearmanWorker
  • GearmanWorker::echo — Comprueba la respuesta de un servidor de trabajo
  • GearmanWorker::error — Retorna el último error que ha ocurrido
  • GearmanWorker::getErrno — Obtiene el código de error
  • GearmanWorker::options — Retorna las opciones del trabajador
  • GearmanWorker::register — Registra una función en el servidor de trabajo
  • GearmanWorker::removeOptions — Elimina las opciones del trabajador
  • GearmanWorker::returnCode — Obtiene el último código de retorno de Gearman
  • GearmanWorker::setId — Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles
  • GearmanWorker::setOptions — Establece las opciones del trabajador
  • GearmanWorker::setTimeout — Establece un tiempo de espera máximo para actividad de entrada/salida del socket
  • GearmanWorker::timeout — Retorna el tiempo máximo de espera para actividad de entrada/salida del socket
  • GearmanWorker::unregister — Elimina el registro del nombre de una función en los servidores de trabajo
  • GearmanWorker::unregisterAll — Elimina el registro de todas los nombres de funciones en los servidores de trabajo
  • GearmanWorker::wait — Espera cualquier actividad de uno de los servidores de trabajo
  • GearmanWorker::work — Espera y realiza un trabajo


Registra y añade una función de retorno

  • « GearmanWorker
  • GearmanWorker::addOptions »
  • PHP Manual
  • GearmanWorker
  • Registra y añade una función de retorno

GearmanWorker::addFunction

(PECL gearman >= 0.5.0)

GearmanWorker::addFunction — Registra y añade una función de retorno

Descripción

public GearmanWorker::addFunction ( string $function_name , callable $function , mixed &$context = ? , int $timeout = ? ) : bool

Registra el nombre de una función en el servidor de trabajos y especifica la llamada de retorno quer corresponde a esa función. Opcionalmente se puede especificar datos extra del contexto de aplicación para que sean usados cuando se realiza la llamada a la función de retorno o expira el tiempo máximo permitido.

Parámetros

function_name

Nombre de la función a registrar en el servidor de trabajos

function

Función de retorno a llamar cuando el trabajo para el nombre de función registrado es enviado

context

Referencia a datos de contexto de la aplicación que pueden ser modificados por la la función del trabajador

timeout

Intervalo de tiempo en segundos

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Sencillo trabajador que usa los datos de contexto de aplicación

<?php

# obtiene un trabajador gearman
$worker= new GearmanWorker();

# añade el servidor por defecto (localhost)
$worker->addServer();

# define una variable en la que mantener los datos de aplicación
$count= 0;

# añade la función "reverse"
$worker->addFunction("reverse", "reverse_cb", $count);

# inicia el trabajador
while ($worker->work());

function reverse_cb($job, &$count)
{
  $count++;
  return "$count: " . strrev($job->workload());
}

?>

Ejecutando un cliente que envía dos trabajos para la función "reverse", tendrá un resultado similar a este:

1: olleh
2: dlrow

Ver también

  • GearmanClient::do() - Ejecuta una sola tarea y retorna el resultado [obsoleto]


Añade opciones al trabajador

  • « GearmanWorker::addFunction
  • GearmanWorker::addServer »
  • PHP Manual
  • GearmanWorker
  • Añade opciones al trabajador

GearmanWorker::addOptions

(PECL gearman >= 0.6.0)

GearmanWorker::addOptions — Añade opciones al trabajador

Descripción

public GearmanWorker::addOptions ( int $option ) : bool

Añade una o más opciones a las establecidas anteriormente.

Parámetros

option

Opciones a añadir

Valores devueltos

Siempre retorna true.

Ver también

  • GearmanWorker::options() - Retorna las opciones del trabajador
  • GearmanClient::setOptions() - Establece opciones del cliente
  • GearmanClient::removeOptions() - Elimina opciones del cliente


Añade un servidor de trabajo

  • « GearmanWorker::addOptions
  • GearmanWorker::addServers »
  • PHP Manual
  • GearmanWorker
  • Añade un servidor de trabajo

GearmanWorker::addServer

(PECL gearman >= 0.5.0)

GearmanWorker::addServer — Añade un servidor de trabajo

Descripción

public GearmanWorker::addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool

Añade un servidor de trabajo a este trabajador. Se añade a una lista de servidores que pueden ser usados para ejecutar trabajos. No se realiza ninguna acción de entrada/salida con sockets.

Parámetros

host

Nombre del host del job server.

port

Puerto del job server.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añade servidores Gearman alternativos

<?php
$worker= new GearmanWorker();
$worker->addServer("10.0.0.1");
$worker->addServer("10.0.0.2", 7003);
?>

Ver también

  • GearmanWorker::addServers() - Añade servidores de trabajo


Añade servidores de trabajo

  • « GearmanWorker::addServer
  • GearmanWorker::clone »
  • PHP Manual
  • GearmanWorker
  • Añade servidores de trabajo

GearmanWorker::addServers

(PECL gearman >= 0.5.0)

GearmanWorker::addServers — Añade servidores de trabajo

Descripción

public GearmanWorker::addServers ( string $servers = 127.0.0.1:4730 ) : bool

Añade uno o más servidores de trabajos a este trabajador. Se añaden a una lista de servidores que pueden ser usados para ejecutar trabajos. No se realiza ninguna acción de entrada/salida con sockets.

Parámetros

servers

Una lista de servidores de trabajo separadas por comas en el formato servidor:puerto. Si no se especifica puerto, se usa el puerto por defecto 4730.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añade dos servidores de trabajo

<?php

$worker= new GearmanWorker();
$worker->addServers("10.0.0.1,10.0.0.2:7003");

?>

Ver también

  • GearmanWorker::addServer() - Añade un servidor de trabajo


Crea una copia del trabajador

  • « GearmanWorker::addServers
  • GearmanWorker::__construct »
  • PHP Manual
  • GearmanWorker
  • Crea una copia del trabajador

GearmanWorker::clone

(PECL gearman >= 0.5.0)

GearmanWorker::clone — Crea una copia del trabajador

Descripción

public GearmanWorker::clone ( ) : void

Crea una copia del trabajador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanWorker


Crea una instancia GearmanWorker

  • « GearmanWorker::clone
  • GearmanWorker::echo »
  • PHP Manual
  • GearmanWorker
  • Crea una instancia GearmanWorker

GearmanWorker::__construct

(PECL gearman >= 0.5.0)

GearmanWorker::__construct — Crea una instancia GearmanWorker

Descripción

public GearmanWorker::__construct ( )

Crea una instancia GearmanWorker que representa a un trabajador que se conecta a un servidor de trabajo y acepta tareas a ejecutar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto GearmanWorker

Ver también

  • GearmanWorker::clone() - Crea una copia del trabajador


Comprueba la respuesta de un servidor de trabajo

  • « GearmanWorker::__construct
  • GearmanWorker::error »
  • PHP Manual
  • GearmanWorker
  • Comprueba la respuesta de un servidor de trabajo

GearmanWorker::echo

(PECL gearman >= 0.6.0)

GearmanWorker::echo — Comprueba la respuesta de un servidor de trabajo

Descripción

public GearmanWorker::echo ( string $workload ) : bool

Envía datos a todos los servidores de trabajo para comprobar si los retornan. Esta es una función de prueba para ver si los servidores de trabajo están respondiendo de forma adecuada.

Parámetros

workload

Datos arbitrarios serializados

Valores devueltos

Valor de retorno estándar de Gearman.

Ver también

  • GearmanClient::echo() - Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]


Retorna el último error que ha ocurrido

  • « GearmanWorker::echo
  • GearmanWorker::getErrno »
  • PHP Manual
  • GearmanWorker
  • Retorna el último error que ha ocurrido

GearmanWorker::error

(PECL gearman >= 0.5.0)

GearmanWorker::error — Retorna el último error que ha ocurrido

Descripción

public GearmanWorker::error ( ) : string

Retorna una cadena de error para el último error que ha ocurrido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El string de error.

Ver también

  • GearmanWorker::getErrno() - Obtiene el código de error


Obtiene el código de error

  • « GearmanWorker::error
  • GearmanWorker::options »
  • PHP Manual
  • GearmanWorker
  • Obtiene el código de error

GearmanWorker::getErrno

(PECL gearman >= 0.5.0)

GearmanWorker::getErrno — Obtiene el código de error

Descripción

public GearmanWorker::getErrno ( ) : int

Retorna el valor del código de error (errno) en caso de que se obtenga un GEARMAN_ERRNO.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un errno válido.

Ver también

  • GearmanWorker::error() - Retorna el último error que ha ocurrido


Retorna las opciones del trabajador

  • « GearmanWorker::getErrno
  • GearmanWorker::register »
  • PHP Manual
  • GearmanWorker
  • Retorna las opciones del trabajador

GearmanWorker::options

(PECL gearman >= 0.6.0)

GearmanWorker::options — Retorna las opciones del trabajador

Descripción

public GearmanWorker::options ( ) : int

Retorna las opciones que han sido establecidas con anterioridad en el trabajador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Las opciones que tiene actualmente el trabajador.

Ver también

  • GearmanWorker::setOptions() - Establece las opciones del trabajador


Registra una función en el servidor de trabajo

  • « GearmanWorker::options
  • GearmanWorker::removeOptions »
  • PHP Manual
  • GearmanWorker
  • Registra una función en el servidor de trabajo

GearmanWorker::register

(PECL gearman >= 0.6.0)

GearmanWorker::register — Registra una función en el servidor de trabajo

Descripción

public GearmanWorker::register ( string $function_name , int $timeout = ? ) : bool

Registra el nombre de una función en el servidor de trabajo con un tiempo máximo de espera opcional. El tiempo de espera indica cuantos segundos debe esperar el servidor antes de marcar el trabajo como fallo. Indicar un tiempo de espera de cero implica deshabilitar la espera.

Parámetros

function_name

El nombre de una función a registrar en el servidor de trabajo

timeout

Un intervalo de tiempo en segundos

Valores devueltos

Un valor de retorno estándar de Gearman.

Ver también

  • GearmanWorker::unregister() - Elimina el registro del nombre de una función en los servidores de trabajo
  • GearmanWorker::unregisterAll() - Elimina el registro de todas los nombres de funciones en los servidores de trabajo


Elimina las opciones del trabajador

  • « GearmanWorker::register
  • GearmanWorker::returnCode »
  • PHP Manual
  • GearmanWorker
  • Elimina las opciones del trabajador

GearmanWorker::removeOptions

(PECL gearman >= 0.6.0)

GearmanWorker::removeOptions — Elimina las opciones del trabajador

Descripción

public GearmanWorker::removeOptions ( int $option ) : bool

Elimina una o más opciones del trabajador.

Parámetros

option

Opciones a ser eliminadas

Valores devueltos

Retorna siempre true.

Ver también

  • GearmanWorker::options() - Retorna las opciones del trabajador
  • GearmanWorker::setOptions() - Establece las opciones del trabajador
  • GearmanWorker::addOptions() - Añade opciones al trabajador


Obtiene el último código de retorno de Gearman

  • « GearmanWorker::removeOptions
  • GearmanWorker::setId »
  • PHP Manual
  • GearmanWorker
  • Obtiene el último código de retorno de Gearman

GearmanWorker::returnCode

(PECL gearman >= 0.5.0)

GearmanWorker::returnCode — Obtiene el último código de retorno de Gearman

Descripción

public GearmanWorker::returnCode ( ) : int

Retorna el último código de retorno de Gearman.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un código de retorno válido de Gearman.

Ver también

  • GearmanWorker::error() - Retorna el último error que ha ocurrido
  • GearmanWorker::getErrno() - Obtiene el código de error


Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles

  • « GearmanWorker::returnCode
  • GearmanWorker::setOptions »
  • PHP Manual
  • GearmanWorker
  • Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles

GearmanWorker::setId

(No hay información de versión disponible, podría estar únicamente en Git)

GearmanWorker::setId — Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles

Descripción

public GearmanWorker::setId ( string $id ) : bool

Asigna un identificador al trabajador.

Parámetros

id

Un identificador de tipo string.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de GearmanWorker::setId()

Define un identificador para un trabajador simple.

<?php
$worker= new GearmanWorker();
$worker->setId('test');
?>

El resultado del ejemplo sería algo similar a:

Ejecutar el comando siguiente:
gearadmin --workers

Salida:
30 ::3a3a:3361:3361:3a33%976303667 - : test


Establece las opciones del trabajador

  • « GearmanWorker::setId
  • GearmanWorker::setTimeout »
  • PHP Manual
  • GearmanWorker
  • Establece las opciones del trabajador

GearmanWorker::setOptions

(PECL gearman >= 0.5.0)

GearmanWorker::setOptions — Establece las opciones del trabajador

Descripción

public GearmanWorker::setOptions ( int $option ) : bool

Establece una o más opciones para el valor dado.

Parámetros

option

Las opciones a establecer

Valores devueltos

Siempre retorna true.

Ver también

  • GearmanWorker::options() - Retorna las opciones del trabajador
  • GearmanWorker::addOptions() - Añade opciones al trabajador
  • GearmanWorker::removeOptions() - Elimina las opciones del trabajador
  • GearmanClient::setOptions() - Establece opciones del cliente


Establece un tiempo de espera máximo para actividad de entrada/salida del socket

  • « GearmanWorker::setOptions
  • GearmanWorker::timeout »
  • PHP Manual
  • GearmanWorker
  • Establece un tiempo de espera máximo para actividad de entrada/salida del socket

GearmanWorker::setTimeout

(PECL gearman >= 0.6.0)

GearmanWorker::setTimeout — Establece un tiempo de espera máximo para actividad de entrada/salida del socket

Descripción

public GearmanWorker::setTimeout ( int $timeout ) : bool

Establece el intervalo de tiempo a esperar actividad de entrada/salida del socket. Sets the interval of time to wait for socket I/O activity.

Parámetros

timeout

Un intervalo de tiempo en milisegundos. Un valor negativo indica un tiempo de espera infinito.

Valores devueltos

Retorna siempre true.

Ejemplos

Ejemplo #1 Un trabajador sencillo con un tiempo de espera de 5 segundos

<?php

echo "Empezando\n";

# Crea el objeto trabajador
$gmworker= new GearmanWorker();

# Añade el servidor por defecto (localhost).
$gmworker->addServer();

# Registra la función "reverse" en el servidor.
$gmworker->addFunction("reverse", "reverse_fn");

# Establece el tiempo de espera a 5 segundos
$gmworker->setTimeout(5000);

echo "Esperando trabajo...\n";
while(@$gmworker->work() || $gmworker->returnCode() == GEARMAN_TIMEOUT)
{
  if ($gmworker->returnCode() == GEARMAN_TIMEOUT)
  {
    # Normalmente se espera hacer algo útil aquí...
    echo "Timeout. Esperando al siguiente trabajo...\n";
    continue;
  }

  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

echo "Listo!\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Ejecutar el trabajador sin enviar trabajos genera una salida que es parecida a:

Empezando
Esperando trabajo...
Timeout. Esperando al siguiente trabajo...
Timeout. Esperando al siguiente trabajo...
Timeout. Esperando al siguiente trabajo...

Ver también

  • GearmanWorker::timeout() - Retorna el tiempo máximo de espera para actividad de entrada/salida del socket


Retorna el tiempo máximo de espera para actividad de entrada/salida del socket

  • « GearmanWorker::setTimeout
  • GearmanWorker::unregister »
  • PHP Manual
  • GearmanWorker
  • Retorna el tiempo máximo de espera para actividad de entrada/salida del socket

GearmanWorker::timeout

(PECL gearman >= 0.6.0)

GearmanWorker::timeout — Retorna el tiempo máximo de espera para actividad de entrada/salida del socket

Descripción

public GearmanWorker::timeout ( ) : int

Retorna el tiempo actual a esperar, en milisegundos, para actividad de entrada/salida del socket.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un período de tiempo en milisegundos. Un valor negativo indica un tiempo de espera infinito.

Ver también

  • GearmanWorker::setTimeout() - Establece un tiempo de espera máximo para actividad de entrada/salida del socket


Elimina el registro del nombre de una función en los servidores de trabajo

  • « GearmanWorker::timeout
  • GearmanWorker::unregisterAll »
  • PHP Manual
  • GearmanWorker
  • Elimina el registro del nombre de una función en los servidores de trabajo

GearmanWorker::unregister

(PECL gearman >= 0.6.0)

GearmanWorker::unregister — Elimina el registro del nombre de una función en los servidores de trabajo

Descripción

public GearmanWorker::unregister ( string $function_name ) : bool

Elimina el registro del nombre de una función en los servidores de trabajo asegurando que no se envían (para esa función y ese trabajador) más trabajos.

Parámetros

function_name

El nombre de una función registrada en el servidor de trabajo

Valores devueltos

Un valor de retorno estándar de Gearman.

Ver también

  • GearmanWorker::register() - Registra una función en el servidor de trabajo
  • GearmanWorker::unregisterAll() - Elimina el registro de todas los nombres de funciones en los servidores de trabajo


Elimina el registro de todas los nombres de funciones en los servidores de trabajo

  • « GearmanWorker::unregister
  • GearmanWorker::wait »
  • PHP Manual
  • GearmanWorker
  • Elimina el registro de todas los nombres de funciones en los servidores de trabajo

GearmanWorker::unregisterAll

(PECL gearman >= 0.6.0)

GearmanWorker::unregisterAll — Elimina el registro de todas los nombres de funciones en los servidores de trabajo

Descripción

public GearmanWorker::unregisterAll ( ) : bool

Elimina cualquier función que estuviese registrada con anterioridad, asegurando que que no se envían más trabajos a ese trabajador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un valor de retorno estándar de Gearman.

Ver también

  • GearmanWorker::register() - Registra una función en el servidor de trabajo
  • GearmanWorker::unregister() - Elimina el registro del nombre de una función en los servidores de trabajo


Espera cualquier actividad de uno de los servidores de trabajo

  • « GearmanWorker::unregisterAll
  • GearmanWorker::work »
  • PHP Manual
  • GearmanWorker
  • Espera cualquier actividad de uno de los servidores de trabajo

GearmanWorker::wait

(PECL gearman >= 0.6.0)

GearmanWorker::wait — Espera cualquier actividad de uno de los servidores de trabajo

Descripción

public GearmanWorker::wait ( ) : bool

Provoca que el trabajador espere a cualquier actividad desde uno de los servidores de trabajo Gearman cuando trabaja en modo entrada/salida no bloqueante. En caso de fallo, envía un E_WARNING con el último error Gearman encontrado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Running worker in non-blocking mode

<?php

echo "Inicializando\n";

# Crea el objeto trabajador
$worker= new GearmanWorker();

# Define el trabajador como no bloqueante
$worker->addOptions(GEARMAN_WORKER_NON_BLOCKING);

# Añade el servidor por defecto (localhost, puerto 4730)
$worker->addServer();

# Añade la función reverse
$worker->addFunction('reverse', 'reverse_fn');

# Intenta obtener un trabajo
while (@$worker->work() ||
       $worker->returnCode() == GEARMAN_IO_WAIT ||
       $worker->returnCode() == GEARMAN_NO_JOBS)
{
  if ($worker->returnCode() == GEARMAN_SUCCESS)
    continue;

  echo "Esperando al siguiente trabajo...\n";
  if (!@$worker->wait())
  {
    if ($worker->returnCode() == GEARMAN_NO_ACTIVE_FDS)
    {
      # No estamos conectados a ningún servidor, esperamos antes
      # de reconectar.
      sleep(5);
      continue;
    }
    break;
  }
}

echo "Error en el trabajador: " . $worker->error() . "\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Ver también

  • GearmanWorker::work() - Espera y realiza un trabajo


Espera y realiza un trabajo

  • « GearmanWorker::wait
  • GearmanException »
  • PHP Manual
  • GearmanWorker
  • Espera y realiza un trabajo

GearmanWorker::work

(PECL gearman >= 0.5.0)

GearmanWorker::work — Espera y realiza un trabajo

Descripción

public GearmanWorker::work ( ) : bool

Espera a que se asigne un trabajo y llama a la función de retorno apropiada. Envía un E_WARNING con el último error Gearman si el resultado no es GEARMAN_SUCCESS, GEARMAN_IO_WAIT, o GEARMAN_WORK_FAIL.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 GearmanWorker::work() example

<?php

# Crea el trabajador
$worker = new GearmanWorker();

# Añade el servidor por defecto (localhost)
$worker->addServer();

# Añade la función "reverse"
$worker->addFunction("reverse", "my_reverse_function");

# Inicia el trabajador escuchando trabajos entrantes
while ($worker->work());

function my_reverse_function($job)
{
  return strrev($job->workload());
}

?>

Ver también

  • GearmanWorker::addFunction() - Registra y añade una función de retorno


La clase GearmanException

(PECL gearman >= 0.5.0)

Introducción

Sinopsis de la Clase

GearmanException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Protocolo Ligero de Acceso a Directorios

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Utilizando las llamadas PHP LDAPs
  • Controles de LDAP
  • Ejemplos
    • Uso básico
  • LDAP Funciones
    • ldap_8859_to_t61 — Traducir caracteres 8859 a caracteres t61
    • ldap_add_ext — Add entries to LDAP directory
    • ldap_add — Agregar entradas al directorio de LDAP
    • ldap_bind_ext — Bind to LDAP directory
    • ldap_bind — Realiza la autenticación con un servidor LDAP
    • ldap_close — Alias de ldap_unbind
    • ldap_compare — Comparar el valor del atributo encontrado en la entrada que se especificó con un DN
    • ldap_connect — Abre una conexión a un servidor LDAP
    • ldap_control_paged_result_response — Recuperar la cookie de paginación LDAP
    • ldap_control_paged_result — Enviar el control de paginación LDAP
    • ldap_count_entries — Contar el número de entradas en una búsqueda
    • ldap_delete_ext — Delete an entry from a directory
    • ldap_delete — Eliminar una entrada de un directorio
    • ldap_dn2ufn — Convertir un DN a un formato de nombramiento amigable al usuario
    • ldap_err2str — Convertir un número de error de LDAP a una cadena con un mensaje de error
    • ldap_errno — Devuelve el número de error LDAP del último comando LDAP
    • ldap_error — Devuelve el mensaje de error de LDAP del último comando LDAP
    • ldap_escape — Escapa una cadena de texto para su uso en un filtro LDAP o DN
    • ldap_exop_passwd — PASSWD extended operation helper
    • ldap_exop_refresh — Refresh extended operation helper
    • ldap_exop_whoami — WHOAMI extended operation helper
    • ldap_exop — Performs an extended operation
    • ldap_explode_dn — Divide un DN en sus partes componentes
    • ldap_first_attribute — Devolver el primer atributo
    • ldap_first_entry — Devolver el primer resultado de identificación
    • ldap_first_reference — Devolver la primera referencia
    • ldap_free_result — Liberar la memoria de resultado
    • ldap_get_attributes — Obtener atributos de una entrada de búsqueda de resultados
    • ldap_get_dn — Get the DN of a result entry
    • ldap_get_entries — Obtener todas las entradas de los resultados
    • ldap_get_option — Obtener el valor actual para la opción dada
    • ldap_get_values_len — Obtener todos los valores binarios desde una entrada de resultados
    • ldap_get_values — Obtener todos los valores de una entrada de resultados
    • ldap_list — Búsqueda de un solo nivel
    • ldap_mod_add_ext — Add attribute values to current attributes
    • ldap_mod_add — Agregar valores de atributo a los atributos actuales
    • ldap_mod_del_ext — Delete attribute values from current attributes
    • ldap_mod_del — Borrar valores de atributo de los atributos actuales
    • ldap_mod_replace_ext — Replace attribute values with new ones
    • ldap_mod_replace — Reemplazar valores de atributos con valores nuevos
    • ldap_modify_batch — Batch and execute modifications on an LDAP entry
    • ldap_modify — Modificar una entrada de LDAP
    • ldap_next_attribute — Obtener el siguiente atributo en un resultado
    • ldap_next_entry — Obtener el siguiente resultado de entrada
    • ldap_next_reference — Obtener la siguiente referencia
    • ldap_parse_exop — Parse result object from an LDAP extended operation
    • ldap_parse_reference — Extraer información de la entrada de referencia
    • ldap_parse_result — Extraer información del resultado
    • ldap_read — Leer una entrada
    • ldap_rename_ext — Modify the name of an entry
    • ldap_rename — Modificar el nombre de una entrada
    • ldap_sasl_bind — Unirse a un directorio LDAP utilizando SASL
    • ldap_search — Buscar el árbol LDAP
    • ldap_set_option — Establecer el valor de la opción proporcionada
    • ldap_set_rebind_proc — Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial
    • ldap_sort — Clasificar entradas de resultados de LDAP en el lado del cliente
    • ldap_start_tls — Inciar TLS
    • ldap_t61_to_8859 — Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859
    • ldap_unbind — Desenlazar de directorio LDAP


Introducción

El Protocolo Ligero de Acceso a Directorios (LDAP, por sus siglas en inglés), se utiliza para acceder a "Servidores de Directorio". Un Directorio es un tipo especial de base de datos que mantiene información en una estructura de árbol.

El concepto es similar a la estructura de directorios de un disco duro, excepto que, en este contexto, el directorio raíz es "El mundo" y el primer nivel de subdirectorios son los "países". Los niveles más bajos de la estructura de directorios contienen entradas para compañías, organizaciones o lugares, y aún en los niveles más bajos encontraremos entradas de directorio para personas, y tal vez, para equipamiento o documentos.

Para refererirse a un fichero en un subdirectorio del disco duro, se podría utilizar algo como:

   /usr/local/myapp/docs

Las barras hacia delante marcan cada división de la referencia, y la secuencia se lee de izquierda a derecha.

En LDAP, el equivalente a la referencia de un fichero completamente cualificado es el "nombre distinguido", conocido simplemente como "dn" (por las iniciales en inglés de 'distinguished name'). Un ejemplo de dn podría ser:

   cn=John Smith,ou=Accounts,o=My Company,c=US

La coma marca cada división de la referencia, y la secuencia se lee de derecha a izquierda. Se podría leer este dn como:

   country = US
   organization = My Company
   organizationalUnit = Accounts
   commonName = John Smith

De la misma manera que no existen reglas fijas sobre cómo organizar la estructura de directorios de un disco duro, un administrador del servidor de directorios puede establecer cualquier estructura que sea de utilidad para el propósito que se utilice. Sin embargo, hay algunas convenciones que deben usarse. El mensaje es que no se puede escribir código para acceder a un servidor de directorios a menos que se sepa algo sobre su estructura; nadie más que el creador de la base de datos puede utilizar la misma sin tener algún conocimiento de qué es lo que está disponible.

Se puede encontrar mucha información sobre LDAP en

  • » Mozilla

  • » Proyecto OpenLDAP

  • Las RFC de Internet Engineering Taskforce » 4510 hasta » 4519.

El SDK de Netscape contiene una útil » Guía del Programador en formato HTML.


Requerimientos

Necesitará obtener y compilar las librerías clientes LDAP ya sea desde » OpenLDAP o » Bind9.net para compilar PHP con soporte LDAP. Para PHP 5.6 o posterior, será necesario OpenLDAP 2.4 o superior.


Instalación

El soporte para LDAP en PHP no está habilitado de forma predeterminada. Necesitará utilizar la opción de configuración --with-ldap[=DIR] cuando esté compilando PHP para habilitar el soporte de LDAP. DIR es la base del directorio de instalación de LDAP. Para habilitar el soporte SASL, asegúrese que la opción --with-ldap-sasl[=DIR] sea utilizada, y que sasl.h exista en el sistema.

Nota: Nota para los usuarios de Win32

Para que esta extensión funcione, hay unos ficheros DLL que deben estar disponibles en el PATH del sistema de Windows. Para obtener más información sobre esto, vea la FAQ titulada "Como añadir mi directorio de PHP al PATH de Windows". Aunque copiar los ficheros DLL desde el directorio PHP al directorio del sistema de Windows también funciona (porque el directorio del sistema está de manera predeterminada en el PATH del sistema), no se recomienda. Esta extensión requiere que los siguientes ficheros esten en el PATH: libeay32.dll y ssleay32.dll

Las versiones anteriores de PHP 4.3.0 requieren adicionalmente libsasl.dll.

Para utilizar adecuadamente las librerías LDAP, el entorno de Oracle tiene que ser configurados.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de LDAP
Nombre | Por defecto | Cambiable | Historial de cambios
ldap.max_links | "-1" | PHP_INI_SYSTEM |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

ldap.max_links integer

El número máximo de conexiones LDAP por proceso.


Tipos de recursos

La mayoría de funciones LDAP operan o devuelven recursos (por ejemplo, ldap_connect() devuelve un enlace identificador LDAP positivo que es requerido por la mayoría de funciones LDAP).


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

LDAP_DEREF_NEVER (integer)
LDAP_DEREF_SEARCHING (integer)
LDAP_DEREF_FINDING (integer)
LDAP_DEREF_ALWAYS (integer)
LDAP_OPT_DEREF (integer)
Especifica reglas alternativas para el seguimiento de aliases en el servidor.
LDAP_OPT_SIZELIMIT (integer)

Especifica el número máximo de entradas que pueden ser devueltas en una operación de búsqueda.

Nota: El límite de tamaño actual de las operaciones también está delimitado por el número máximo de entradas de retorno configuradas en el servidor. El menor de estos dos valores es el límite de tamaño actual.

LDAP_OPT_TIMELIMIT (integer)
Especifica el número de segundos de espera para la búsqueda de resultados.

Nota: El límite de tiempo para las operaciones también está delimitado por el tiempo máximo configurado en el servidor. El menor de estos dos valores es el límite de tiempo actual.

LDAP_OPT_NETWORK_TIMEOUT (integer)
Opción para ldap_set_option() que permite ajustar el tiempo de espera de la red. (Disponible a partir de PHP 5.3.0)
LDAP_OPT_PROTOCOL_VERSION (integer)
Especifica el protocolo LDAP a ser utilizado (V2 ó V3).
LDAP_OPT_ERROR_NUMBER (integer)
LDAP_OPT_REFERRALS (integer)
Especifica si se deben seguir automáticamente las referencias devueltas por el servidor LDAP.
LDAP_OPT_RESTART (integer)
LDAP_OPT_HOST_NAME (integer)
LDAP_OPT_ERROR_STRING (integer)
LDAP_OPT_DIAGNOSTIC_MESSAGE (integer)
LDAP_OPT_MATCHED_DN (integer)
LDAP_OPT_SERVER_CONTROLS (integer)
Especifica una lista predeterminada de controles de servidor que se envía con cada solicitud.
LDAP_OPT_CLIENT_CONTROLS (integer)
Especifica una lista predeterminada de controles de cliente a ser procesada con cada solicitud.
LDAP_OPT_DEBUG_LEVEL (integer)
Especifica un nivel de bit por bit para depurar trazas.
LDAP_OPT_X_KEEPALIVE_IDLE (integer)
Especifica el número de segundos que necesita una conexión para mantenerse en estado desocupado antes que TCP comience a enviar pruebas de que la conexión se mantiene activa.
LDAP_OPT_X_KEEPALIVE_PROBES (integer)
Especifica el número máximo de pruebas de conexión activa que TCP debería enviar antes de terminar la conexión.
LDAP_OPT_X_KEEPALIVE_INTERVAL (integer)
Especifica el intervalo en segundos entre cada prueba individual donde verifica que la conexión se mantiene activa.
LDAP_OPT_X_TLS_CACERTDIR (string)
Especifica la ruta del directorio que contiene los certificados de la CA (Autoridad Certificadora).
LDAP_OPT_X_TLS_CACERTFILE (string)
Especifica la ruta completa del fichero de certificado de la la CA (Autoridad Certificadora).
LDAP_OPT_X_TLS_CERTFILE (string)
Especifica la ruta completa del fichero de certificado.
LDAP_OPT_X_TLS_CIPHER_SUITE (string)
Especifica el conjunto de cifrado permitido.
LDAP_OPT_X_TLS_CRLCHECK (integer)
Especifica la estrategia de evaluación CRL. Esta debe ser una de las siguientes: LDAP_OPT_X_TLS_CRL_NONE,LDAP_OPT_X_TLS_CRL_PEER, LDAP_OPT_X_TLS_CRL_ALL.

Nota: Esta opción es válida solamente para OpenSSL.

LDAP_OPT_X_TLS_CRLFILE (string)
Especifica la ruta completa del fichero CRL.

Nota: Esta opción es válida solamente para GnuTLS.

LDAP_OPT_X_TLS_DHFILE (string)
Especifica la ruta completa del fichero que contiene los parámetros para el intercambio de claves efímero de Diffie-Hellman.

Nota: Esta opción es ignorada por GnuTLS y Mozilla NSS.

LDAP_OPT_X_TLS_KEYFILE (string)
Especifica la ruta completa del fichero clave de certificado.
LDAP_OPT_X_TLS_PROTOCOL_MIN (integer)
Especifica la versión mínima del protocolo. Esta puede ser una de las siguientes: LDAP_OPT_X_TLS_PROTOCOL_SSL2,LDAP_OPT_X_TLS_PROTOCOL_SSL3, LDAP_OPT_X_TLS_PROTOCOL_TLS1_0, LDAP_OPT_X_TLS_PROTOCOL_TLS1_1, LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
LDAP_OPT_X_TLS_RANDOM_FILE (string)
LDAP_OPT_X_TLS_REQUIRE_CERT (integer)
Especifica el certificado que comprueba la estrategia de comprobación. Esta debe ser una de las siguientes: LDAP_OPT_X_TLS_NEVER,LDAP_OPT_X_TLS_HARD, LDAP_OPT_X_TLS_DEMAND, LDAP_OPT_X_TLS_ALLOW, LDAP_OPT_X_TLS_TRY.
GSLC_SSL_NO_AUTH (integer)
GSLC_SSL_ONEWAY_AUTH (integer)
GSLC_SSL_TWOWAY_AUTH (integer)
LDAP_EXOP_START_TLS (string)
LDAP_EXOP_MODIFY_PASSWD (string)
LDAP_EXOP_REFRESH (string)
LDAP_EXOP_WHO_AM_I (string)
LDAP_EXOP_TURN (string)


Utilizando las llamadas PHP LDAPs

Antes de que pueda utilizar las llamadas LDAP necesitará saber ...

  • El nombre o dirección del servidor de directorio que utilizará

  • El "dn base" del servidor (la parte del directorio del mundo que es mantenida en este servidor, la que podría ser "o=Mi Compañía,c=US")

  • Puede ser que necesite una contraseña para acceder al servidor (muchos servidores le proveerán acceso de lectura para una "vinculación anónima" pero requieren una contraseña para cualquier otra cosa)

La secuencia típica de llamadas LDAP que hará en una aplicación va a seguir este patrón:

  ldap_connect()    // Establecer una conexión al servidor
     |
  ldap_bind()       // Una "entrada" anónima o autenticada
     |
  Realizar algo como una búsqueda o actualizar el directorio
  y mostrar los resultados
     |
  ldap_close()      // "Cerrar la sesión"


Controles de LDAP

Los controles son objetos especiales que podrían ser enviados junto a una petición de LDAP para alterar el comportamiento del servidor LDAP mientras se lleva a cabo dicha petición. Tambíen podría haber controles enviados por el servidor junto a la respuesta para proveer de más información, normalmente para responder a un objeto control desde la petición.

Nota:

No todos los controles se admiten en todos los servidores LDAP. Para saber qué controles están admitidos en un servidor, es necesario consultar el DSE raíz leyendo un dn vacío con el filtro (objectClass=*).

Ejemplo #1 Testing support for paged result control

<?php

// $ds is a valid link identifier for a directory server

$result = ldap_read($ds, '', '(objectClass=*)', ['supportedControl']);
if (!in_array(LDAP_CONTROL_PAGEDRESULTS, ldap_get_entries($ds, $result)[0]['supportedcontrol'])) {
  die("This server does not support paged result control");
}

?>

As of PHP 7.3, you can send controls with your request in all request functions using the serverctrls parameter. When a ext version of a function exists, you should use it if you want to get access to the full response object and be able to parse response controls from it using ldap_parse_result().

serverctrls must be an array containing an array for each control to send, containing the following keys:

oid (string)
The OID of the control. You should use constants starting with LDAP_CONTROL_ for this. See LDAP Constants.
iscritical (boolean)
If a control is noted as critical, the request will fail if the control is not supported by the server, or if it fails to be applied. Note that some controls should always be marked as critical as noted in the RFC introducing them. Defaults to false.
value (mixed)
If applicable, the value of the control. Read below for more information.

Most control values are sent to the server BER-encoded. You may either BER-encode the value yourself, or you can instead pass an array with the correct keys so that the encoding is done for you. Supported controls to be passed as an array are:

  • LDAP_CONTROL_PAGEDRESULTS Expected keys are [size] and [cookie]

  • LDAP_CONTROL_ASSERT Expected key is filter

  • LDAP_CONTROL_VALUESRETURNFILTER Expected key is filter

  • LDAP_CONTROL_PRE_READ Expected key is attrs

  • LDAP_CONTROL_POST_READ Expected key is attrs

  • LDAP_CONTROL_SORTREQUEST Expects an array of arrays with keys attr, [oid], [reverse].

  • LDAP_CONTROL_VLVREQUEST Expected keys are before, after, attrvalue|(offset, count), [context]

The following controls do not need any value:

  • LDAP_CONTROL_PASSWORDPOLICYREQUEST

  • LDAP_CONTROL_MANAGEDSAIT

  • LDAP_CONTROL_DONTUSECOPY

The control LDAP_CONTROL_PROXY_AUTHZ is a special case as its value is not expected to be BER-encoded, so you can directly use a string for its value.

When controls are parsed by ldap_parse_result(), values are turned into an array if supported. This is supported for:

  • LDAP_CONTROL_PASSWORDPOLICYRESPONSE Keys are expire, grace, [error]

  • LDAP_CONTROL_PAGEDRESULTS Keys are size, cookie

  • LDAP_CONTROL_PRE_READ Keys are dn and LDAP attributes names

  • LDAP_CONTROL_POST_READ Keys are dn and LDAP attributes names

  • LDAP_CONTROL_SORTRESPONSE Keys are errcode, [attribute]

  • LDAP_CONTROL_VLVRESPONSE Keys are target, count, errcode, context


  • « Controles de LDAP
  • Uso básico »
  • PHP Manual
  • LDAP
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Recuperar información para todas las entradas donde el apellido inicia con "S" desde un servidor de directorio, mostrando un extracto con el nombre y la dirección de correo electrónico.

Ejemplo #1 Ejemplo de búsqueda LDAP

<?php
// La secuencia básica con LDAP es conectar, amarrar, buscar, interpretar el resultado
// de la búsqueda, y cerrar la conexión.

echo "<h3>Consulta de prueba LDAP</h3>";
echo "Conectando ...";
$ds=ldap_connect("localhost");  // Debe ser un servidor LDAP válido!
echo "El resultado de la conexión es " . $ds . "<br />";

if ($ds) {
    echo "Vinculando ...";
    $r=ldap_bind($ds);     // Esta es una vinculación "anónima", tipicamente
                           // con acceso de sólo lectura.
    echo "El resultado de la vinculación es " . $r . "<br />";

    echo "Buscando (sn=S*) ...";
    // Busca la entrada de apellidos
    $sr=ldap_search($ds, "o=My Company, c=US", "sn=S*");
    echo "El resultado de la búsqueda es " . $sr . "<br />";

    echo "El número de entradas devueltas es " . ldap_count_entries($ds, $sr) . "<br />";

    echo "Obteniendo entradas ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Los datos para " . $info["count"] . " objetos devueltos:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "El dn es: " . $info[$i]["dn"] . "<br />";
        echo "La primera entrada cn es: " . $info[$i]["cn"][0] . "<br />";
        echo "La primera entrada de correo electrónico es: " . $info[$i]["mail"][0] . "<br /><hr />";
    }

    echo "Cerando la conexión";
    ldap_close($ds);

} else {
    echo "<h4>No se puede conectar al servidor LDAP</h4>";
}
?>


LDAP Funciones

Tabla de contenidos

  • ldap_8859_to_t61 — Traducir caracteres 8859 a caracteres t61
  • ldap_add_ext — Add entries to LDAP directory
  • ldap_add — Agregar entradas al directorio de LDAP
  • ldap_bind_ext — Bind to LDAP directory
  • ldap_bind — Realiza la autenticación con un servidor LDAP
  • ldap_close — Alias de ldap_unbind
  • ldap_compare — Comparar el valor del atributo encontrado en la entrada que se especificó con un DN
  • ldap_connect — Abre una conexión a un servidor LDAP
  • ldap_control_paged_result_response — Recuperar la cookie de paginación LDAP
  • ldap_control_paged_result — Enviar el control de paginación LDAP
  • ldap_count_entries — Contar el número de entradas en una búsqueda
  • ldap_delete_ext — Delete an entry from a directory
  • ldap_delete — Eliminar una entrada de un directorio
  • ldap_dn2ufn — Convertir un DN a un formato de nombramiento amigable al usuario
  • ldap_err2str — Convertir un número de error de LDAP a una cadena con un mensaje de error
  • ldap_errno — Devuelve el número de error LDAP del último comando LDAP
  • ldap_error — Devuelve el mensaje de error de LDAP del último comando LDAP
  • ldap_escape — Escapa una cadena de texto para su uso en un filtro LDAP o DN
  • ldap_exop_passwd — PASSWD extended operation helper
  • ldap_exop_refresh — Refresh extended operation helper
  • ldap_exop_whoami — WHOAMI extended operation helper
  • ldap_exop — Performs an extended operation
  • ldap_explode_dn — Divide un DN en sus partes componentes
  • ldap_first_attribute — Devolver el primer atributo
  • ldap_first_entry — Devolver el primer resultado de identificación
  • ldap_first_reference — Devolver la primera referencia
  • ldap_free_result — Liberar la memoria de resultado
  • ldap_get_attributes — Obtener atributos de una entrada de búsqueda de resultados
  • ldap_get_dn — Get the DN of a result entry
  • ldap_get_entries — Obtener todas las entradas de los resultados
  • ldap_get_option — Obtener el valor actual para la opción dada
  • ldap_get_values_len — Obtener todos los valores binarios desde una entrada de resultados
  • ldap_get_values — Obtener todos los valores de una entrada de resultados
  • ldap_list — Búsqueda de un solo nivel
  • ldap_mod_add_ext — Add attribute values to current attributes
  • ldap_mod_add — Agregar valores de atributo a los atributos actuales
  • ldap_mod_del_ext — Delete attribute values from current attributes
  • ldap_mod_del — Borrar valores de atributo de los atributos actuales
  • ldap_mod_replace_ext — Replace attribute values with new ones
  • ldap_mod_replace — Reemplazar valores de atributos con valores nuevos
  • ldap_modify_batch — Batch and execute modifications on an LDAP entry
  • ldap_modify — Modificar una entrada de LDAP
  • ldap_next_attribute — Obtener el siguiente atributo en un resultado
  • ldap_next_entry — Obtener el siguiente resultado de entrada
  • ldap_next_reference — Obtener la siguiente referencia
  • ldap_parse_exop — Parse result object from an LDAP extended operation
  • ldap_parse_reference — Extraer información de la entrada de referencia
  • ldap_parse_result — Extraer información del resultado
  • ldap_read — Leer una entrada
  • ldap_rename_ext — Modify the name of an entry
  • ldap_rename — Modificar el nombre de una entrada
  • ldap_sasl_bind — Unirse a un directorio LDAP utilizando SASL
  • ldap_search — Buscar el árbol LDAP
  • ldap_set_option — Establecer el valor de la opción proporcionada
  • ldap_set_rebind_proc — Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial
  • ldap_sort — Clasificar entradas de resultados de LDAP en el lado del cliente
  • ldap_start_tls — Inciar TLS
  • ldap_t61_to_8859 — Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859
  • ldap_unbind — Desenlazar de directorio LDAP


Traducir caracteres 8859 a caracteres t61

  • « LDAP Funciones
  • ldap_add_ext »
  • PHP Manual
  • LDAP Funciones
  • Traducir caracteres 8859 a caracteres t61

ldap_8859_to_t61

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_8859_to_t61 — Traducir caracteres 8859 a caracteres t61

Descripción

ldap_8859_to_t61 ( string $value ) : string

Traducir caracteres ISO-8859 a caracteres t61.

Esta función es útil si tienes que hablarle a un legado de servidor LDAPv2.

Parámetros

value

El texto a ser traducido.

Valores devueltos

Devuelve la traducción t61 de el value.

Ver también

  • ldap_t61_to_8859() - Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859


Add entries to LDAP directory

  • « ldap_8859_to_t61
  • ldap_add »
  • PHP Manual
  • LDAP Funciones
  • Add entries to LDAP directory

ldap_add_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_add_ext — Add entries to LDAP directory

Descripción

ldap_add_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_add() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_add()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].

Notas

Nota: Esta función es segura binariamente.

Ver también

  • ldap_add() - Agregar entradas al directorio de LDAP
  • ldap_parse_result() - Extraer información del resultado


Agregar entradas al directorio de LDAP

  • « ldap_add_ext
  • ldap_bind_ext »
  • PHP Manual
  • LDAP Funciones
  • Agregar entradas al directorio de LDAP

ldap_add

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_add — Agregar entradas al directorio de LDAP

Descripción

ldap_add ( resource $link_identifier , string $dn , array $entry ) : bool

Agregar entradas en el directorio de LDAP.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

entry

Un array que especifica la información acerca de la entrada. Los valores en las entradas están indexados por atributos individuales. En el caso de valores múltiples para un atributo, estos se indexan utilizando números enteros comenzando desde 0.

<?php
$entry["attribute1"] = "valor";
$entry["attribute2"][0] = "valor1";
$entry["attribute2"][1] = "valor2";
?>

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo completo con enlace autenticado

<?php
$ds = ldap_connect("localhost");  // Asumiendo que el servidor de LDAP está en el mismo host

if ($ds) {
    // Asociar con el dn apropiado para dar acceso de actualización
    $r = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");

    // Preparar los datos
    $info["cn"] = "John Jones";
    $info["sn"] = "Jones";
    $info["objectclass"] = "person";

    // Agregar datos al directorio
    $r = ldap_add($ds, "cn=John Jones, o=My Company, c=US", $info);

    ldap_close($ds);
} else {
    echo "No se pudo conectar al servidor LDAP";
}
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • ldap_delete() - Eliminar una entrada de un directorio


Bind to LDAP directory

  • « ldap_add
  • ldap_bind »
  • PHP Manual
  • LDAP Funciones
  • Bind to LDAP directory

ldap_bind_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_bind_ext — Bind to LDAP directory

Descripción

ldap_bind_ext ( resource $ldap , string|null $dn = null , string|null $password = null , array|null $controls = null ) : resource|false

Does the same thing as ldap_bind() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_bind()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].

Ver también

  • ldap_bind() - Realiza la autenticación con un servidor LDAP
  • ldap_parse_result() - Extraer información del resultado


Realiza la autenticación con un servidor LDAP

  • « ldap_bind_ext
  • ldap_close »
  • PHP Manual
  • LDAP Funciones
  • Realiza la autenticación con un servidor LDAP

ldap_bind

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_bind — Realiza la autenticación con un servidor LDAP

Descripción

ldap_bind ( resource $link_identifier , string $bind_rdn = null , string $bind_password = null ) : bool

Autentica contra un servidor LDAP tomando un RDN y contraseña especificados.

Parámetros

link_identifier

El identificador de enlace LDAP, devuelto por la función ldap_connect().

bind_rdn

bind_password

Si los parámetros bind_rdn y bind_password no son especificados, se intentará autenticar en forma anónima.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de autenticación

<?php

// ejemplo de autenticación
$ldaprdn  = 'uname';     // ldap rdn or dn
$ldappass = 'password';  // associated password

// conexión al servidor LDAP
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // realizando la autenticación
    $ldapbind = ldap_bind($ldapconn, $ldaprdn, $ldappass);

    // verificación del enlace
    if ($ldapbind) {
        echo "LDAP bind successful...";
    } else {
        echo "LDAP bind failed...";
    }

}

?>

Ejemplo #2 Ejemplo de autenticación anónima

<?php

// Ejemplo de autenticación anónima

// conexión al servidor LDAP
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // autenticación anónima
    $ldapbind = ldap_bind($ldapconn);

    if ($ldapbind) {
        echo "LDAP bind anonymous successful...";
    } else {
        echo "LDAP bind anonymous failed...";
    }

}

?>

Ver también

  • ldap_unbind() - Desenlazar de directorio LDAP


Alias de ldap_unbind

  • « ldap_bind
  • ldap_compare »
  • PHP Manual
  • LDAP Funciones
  • Alias de ldap_unbind

ldap_close

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_close — Alias de ldap_unbind()

Descripción

Esta función es un alias de: ldap_unbind().


Comparar el valor del atributo encontrado en la entrada que se especificó con un DN

  • « ldap_close
  • ldap_connect »
  • PHP Manual
  • LDAP Funciones
  • Comparar el valor del atributo encontrado en la entrada que se especificó con un DN

ldap_compare

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_compare — Comparar el valor del atributo encontrado en la entrada que se especificó con un DN

Descripción

ldap_compare ( resource $link_identifier , string $dn , string $attribute , string $value ) : mixed

Comparar el value del attribute con el valor del mismo atributo en una entrada del directorio de LDAP.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

attribute

El nombre del atributo.

value

El valor comparado.

Valores devueltos

Devuelve true si value es similar de otra forma devuelve false. Devuelve -1 en caso de error.

Ejemplos

El siguiente ejemplo demuestra como revisar si una contraseña proporcionada es igual o no a la que está definida en una entrada DN específica.

Ejemplo #1 Ejemplo completo de revisión de contraseña

<?php

$ds=ldap_connect("localhost");  // Asumiendo que el servidor de LDAP está en este mismo ordenador

if ($ds) {

    // enlazar
    if (ldap_bind($ds)) {

        // preparar los datos
        $dn = "cn=Matti Meikku, ou=Mi Departamento, o=Mi Compañía, c=FI";
        $value = "contraseñasecreta";
        $attr = "contraseña";

        // comparar el valor
        $r=ldap_compare($ds, $dn, $attr, $value);

        if ($r === -1) {
            echo "Error: " . ldap_error($ds);
        } elseif ($r === true) {
            echo "Contraseña correcta.";
        } elseif ($r === false) {
            echo "Supongo que falló! Contraseña incorrecta.";
        }

    } else {
        echo "No se puede enlazar al servidor de LDAP.";
    }

    ldap_close($ds);

} else {
    echo "No se puede conectar al servidor de LDAP.";
}
?>

Notas

Advertencia

ldap_compare() NO puede ser utilizado para comparar valores BINARIOS!


Abre una conexión a un servidor LDAP

  • « ldap_compare
  • ldap_control_paged_result_response »
  • PHP Manual
  • LDAP Funciones
  • Abre una conexión a un servidor LDAP

ldap_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_connect — Abre una conexión a un servidor LDAP

Descripción

ldap_connect ( string $hostname = null , int $port = 389 ) : resource

Establece una conexión con un servidor LDAP en un determinado hostname and port.

Parámetros

hostname

Si se está usando OpenLDAP 2.x.x se puede especificar una URL en lugar del host. Para usar LDAP con SSL, se debe compilar OpenLDAP 2.x.x con soporte para SSL, configurar PHP con SSL y colocar este parámetro como ldaps://hostname/.

port

El puerto al cual debe conectarse. No se usa cuando se está usando URLs.

Valores devueltos

Devuelve un identificador de enlace al LDAP en caso de éxito o false en caso de error. Cuando se está usando OpenLDAP 2.x.x, ldap_connect() devolverá siempre un resource que no es la conexión en sí sino solo inicialización de los parámetros de conexión. La conexión real se realizará en la siguiente llamada a las funciones ldap_*, por lo general ldap_bind().

Si no se especificaron parámetros, será retornado el identificador de enlace de la conexión activa.

Ejemplos

Ejemplo #1 Ejemplo de conexión a un servidor LDAP.

<?php

// Variables del servidor LDAP
$ldaphost = "ldap.example.com";  // servidor LDAP
$ldapport = 389;                 // puerto del servidor LDAP

// Conexión al servidor LDAP
$ldapconn = ldap_connect($ldaphost, $ldapport)
          or die("Could not connect to $ldaphost");

?>

Ejemplo #2 Ejemplo de conexión segura a un servidor LDAP.

<?php

// Asegúrese de que el host sea el que fue publicado
// con su certificado
$ldaphost = "ldaps://ldap.example.com/";

// Conexión al servidor LDAP
$ldapconn = ldap_connect($ldaphost)
          or die("Could not connect to {$ldaphost}");

?>

Ver también

  • ldap_bind() - Realiza la autenticación con un servidor LDAP


Recuperar la cookie de paginación LDAP

  • « ldap_connect
  • ldap_control_paged_result »
  • PHP Manual
  • LDAP Funciones
  • Recuperar la cookie de paginación LDAP

ldap_control_paged_result_response

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result_response — Recuperar la cookie de paginación LDAP

Descripción

ldap_control_paged_result_response ( resource $link , resource $result , string &$cookie = ? , int &$estimated = ? ) : bool

Recuperar la información de paginación enviada por el servidor.

Parámetros

link

Un identificador de enlace LDAP, devuelto por ldap_connect().

result

cookie

Una estructura opaca enviada por el servidor.

estimated

El número estimado de entradas a recuperar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ldap_control_paged_result() - Enviar el control de paginación LDAP
  • » RFC2696 : Extensión de Control LDAP para la Manipulación Simple de Resultados Paginados


Enviar el control de paginación LDAP

  • « ldap_control_paged_result_response
  • ldap_count_entries »
  • PHP Manual
  • LDAP Funciones
  • Enviar el control de paginación LDAP

ldap_control_paged_result

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result — Enviar el control de paginación LDAP

Descripción

ldap_control_paged_result ( resource $link , int $pagesize , bool $iscritical = false , string $cookie = "" ) : bool

Activa la paginación LDAP enviando el control de paginación (tamaño de página, cookie...).

Parámetros

link

Un identificador de enlace LDAP, devuelto por ldap_connect().

pagesize

El número de entradas por página.

iscritical

Indica si la paginación es crítica o no. Si es crítica y el servidor no soporta paginación, la búsqueda no devolverá ningún resultado.

cookie

Una estructura opaca enviada por el servidor (ldap_control_paged_result_response()).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

El siguiente ejemplo muestra la recuperación de la primera página de una búsqueda paginada con una entrada por página.

Ejemplo #1 Paginación LDAP

<?php
     // $ds es un identificador de enlace válido (véase ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Fer*)(givenname=Juan*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // activar la paginación con un tamaño de página de 1.
     ldap_control_paged_result($ds, 1);

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     $info = ldap_get_entries($ds, $sr);

     echo $info['count'] . ' entradas devueltas' . PHP_EOL;

El siguiente ejemplo muestra la recuperación de todos los resultados paginados con 100 entradas por página.

Ejemplo #2 Paginación LDAP

<?php
     // $ds es un identificador de enlace válido (véase ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Fer*)(givenname=Juan*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // activar la paginación con un tamaño de página de 100.
     $pageSize = 100;

     $cookie = '';
     do {
         ldap_control_paged_result($ds, $pageSize, true, $cookie);

         $result  = ldap_search($ds, $dn, $filter, $justthese);
         $entries = ldap_get_entries($ds, $result);

         foreach ($entries as $e) {
             echo $e['dn'] . PHP_EOL;
         }

         ldap_control_paged_result_response($ds, $result, $cookie);

     } while($cookie !== null && $cookie != '');

Notas

Nota:

El control de paginación es una característica del protocolo LDAPv3.

Ver también

  • ldap_control_paged_result_response() - Recuperar la cookie de paginación LDAP
  • » RFC2696 : Extensión de Control LDAP para la Manipulación Simple de Resultados Paginados


Contar el número de entradas en una búsqueda

  • « ldap_control_paged_result
  • ldap_delete_ext »
  • PHP Manual
  • LDAP Funciones
  • Contar el número de entradas en una búsqueda

ldap_count_entries

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_count_entries — Contar el número de entradas en una búsqueda

Descripción

ldap_count_entries ( resource $link_identifier , resource $result_identifier ) : int

Devuelve el número de entradas almacenadas en el resultado de previas operaciones de búsqueda.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_identifier

El resultado interno de LDAP.

Valores devueltos

Devuelve el número de entradas en el resultado o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ldap-count-entries()

Recuperar el número de entradas del resultado.

// $ds es un identificador de enlace válido (véase ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     var_dump(ldap_count_entries($ds, $sr));

El resultado del ejemplo sería algo similar a:

     int(1)


Delete an entry from a directory

  • « ldap_count_entries
  • ldap_delete »
  • PHP Manual
  • LDAP Funciones
  • Delete an entry from a directory

ldap_delete_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_delete_ext — Delete an entry from a directory

Descripción

ldap_delete_ext ( resource $ldap , string $dn , array|null $controls = null ) : resource|false

Does the same thing as ldap_delete() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_delete()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].

Ver también

  • ldap_delete() - Eliminar una entrada de un directorio
  • ldap_parse_result() - Extraer información del resultado


Eliminar una entrada de un directorio

  • « ldap_delete_ext
  • ldap_dn2ufn »
  • PHP Manual
  • LDAP Funciones
  • Eliminar una entrada de un directorio

ldap_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_delete — Eliminar una entrada de un directorio

Descripción

ldap_delete ( resource $link_identifier , string $dn ) : bool

Elimina una entrada en particular en un directorio de LDAP.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ldap_add() - Agregar entradas al directorio de LDAP


Convertir un DN a un formato de nombramiento amigable al usuario

  • « ldap_delete
  • ldap_err2str »
  • PHP Manual
  • LDAP Funciones
  • Convertir un DN a un formato de nombramiento amigable al usuario

ldap_dn2ufn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_dn2ufn — Convertir un DN a un formato de nombramiento amigable al usuario

Descripción

ldap_dn2ufn ( string $dn ) : string

Convierte un dn específico, a un formato más amigable al usuario, mostrando los tipos de nombre.

Parámetros

dn

El nombre distinguido de una entidad de LDAP.

Valores devueltos

Devuelve el nombre amigable al usuario.


Convertir un número de error de LDAP a una cadena con un mensaje de error

  • « ldap_dn2ufn
  • ldap_errno »
  • PHP Manual
  • LDAP Funciones
  • Convertir un número de error de LDAP a una cadena con un mensaje de error

ldap_err2str

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_err2str — Convertir un número de error de LDAP a una cadena con un mensaje de error

Descripción

ldap_err2str ( int $errno ) : string

Devuelve una cadena con un mensaje de error explicando el número de error de errno. Mientras que los números errno de LDAP están estandarizados, diferentes bibliotecas devuelven aún mensajes de error textuales localizados. Nunca busque un texto con un mensaje de error específico, pero siempre busque un número de error que revisar.

Parámetros

errno

El número de error.

Valores devueltos

Devuelve el mensaje de error como una cadena.

Ejemplos

Ejemplo #1 Enumerando todos los mensajes de error de LDAP

<?php
  for ($i=0; $i<100; $i++) {
    printf("Error $i: %s<br />\n", ldap_err2str($i));
  }
?>

Ver también

  • ldap_errno() - Devuelve el número de error LDAP del último comando LDAP
  • ldap_error() - Devuelve el mensaje de error de LDAP del último comando LDAP


Devuelve el número de error LDAP del último comando LDAP

  • « ldap_err2str
  • ldap_error »
  • PHP Manual
  • LDAP Funciones
  • Devuelve el número de error LDAP del último comando LDAP

ldap_errno

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_errno — Devuelve el número de error LDAP del último comando LDAP

Descripción

ldap_errno ( resource $link_identifier ) : int

Devuelve el número de error estándar devuelto por el último comando LDAP. Este número se puede convertir a un mensaje de error textual utilizando ldap_err2str().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

Valores devueltos

Devolver el número de error de LDAP del último comando LDAP para este enlace.

Ejemplos

A menos que reduzca suficientemente el nivel de advertencia en su php.ini o le anteponga una arroba (@) a sus comandos LDAP para suprimir la salida de advertencia, los errores generados también se mostrarán en la salida HTML.

Ejemplo #1 Generación y captura de un error

<?php
// Este ejemplo contiene un error, el cual capturaremos.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// Error de sintáxis en la expresión de filtro (errno 87),
// debe ser un "objectclass=*" para que funcione.
$res =  @ldap_search($ld, "o=Myorg, c=DE", "objectclass");
if (!$res) {
    echo "Errno de LDAP: " . ldap_errno($ld) . "<br />\n";
    echo "Errno de LDAP: " . ldap_error($ld) . "<br />\n";
    die("Ouch!<br />\n");
}
$info = ldap_get_entries($ld, $res);
echo $info["count"] . " pareando entradas.<br />\n";
?>

Ver también

  • ldap_err2str() - Convertir un número de error de LDAP a una cadena con un mensaje de error
  • ldap_error() - Devuelve el mensaje de error de LDAP del último comando LDAP


Devuelve el mensaje de error de LDAP del último comando LDAP

  • « ldap_errno
  • ldap_escape »
  • PHP Manual
  • LDAP Funciones
  • Devuelve el mensaje de error de LDAP del último comando LDAP

ldap_error

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_error — Devuelve el mensaje de error de LDAP del último comando LDAP

Descripción

ldap_error ( resource $link_identifier ) : string

Devuelve la cadena de mensaje de error que explica el error generado por el último comando LDAP para el link_identifier proporcionado. Mientras que los números errno de LDAP están estandarizados, distintas bibliotecas devuelven aún mensajes de error textuales localizados. Nunca busque un texto con un mensaje de error específico, pero siempre busque un número de error que revisar.

A menos que reduzca suficientemente el nivel de advertencias en su php.ini o anteponga a sus comandos LDAP con el caracter @ (arroba) para suprimir la salida de advertencia, los errores generados también se mostrarán en la salida HTML.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

Valores devueltos

Devuelve una cadena de mensaje de error.

Ver también

  • ldap_err2str() - Convertir un número de error de LDAP a una cadena con un mensaje de error
  • ldap_errno() - Devuelve el número de error LDAP del último comando LDAP


Escapa una cadena de texto para su uso en un filtro LDAP o DN

  • « ldap_error
  • ldap_exop_passwd »
  • PHP Manual
  • LDAP Funciones
  • Escapa una cadena de texto para su uso en un filtro LDAP o DN

ldap_escape

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

ldap_escape — Escapa una cadena de texto para su uso en un filtro LDAP o DN

Descripción

ldap_escape ( string $value , string $ignore = ? , int $flags = ? ) : string

Escapa value para su uso en el contexto implicado por flags.

Parámetros

value

El valor a escapar.

ignore

Caracteres a ignorar en el escapado.

flags

El contexto la cadena escapado se utilizará en: LDAP_ESCAPE_FILTER para filtros para ser utilizado con ldap_search(), o LDAP_ESCAPE_DN para DNs.

Valores devueltos

Retorna la cadena escapada.


PASSWD extended operation helper

  • « ldap_escape
  • ldap_exop_refresh »
  • PHP Manual
  • LDAP Funciones
  • PASSWD extended operation helper

ldap_exop_passwd

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop_passwd — PASSWD extended operation helper

Descripción

ldap_exop_passwd ( resource $ldap , string $user = "" , string $old_password = "" , string $new_password = "" , array &$controls = null ) : string|bool

Performs a PASSWD extended operation.

Parámetros

ldap

An LDAP link identifier, returned by ldap_connect().

user

dn of the user to change the password of.

old_password

The old password of this user. May be ommited depending of server configuration.

new_password

The new password for this user. May be omitted or empty to have a generated password.

controls

If provided, a password policy request control is send with the request and this is filled with an array of LDAP Controls returned with the request.

Valores devueltos

Returns the generated password if new_password is empty or omitted. Otherwise returns true on success and false on failure.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Ejemplos

Ejemplo #1 PASSWD extended operation

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");
    if (!$bind) {
      echo "Unable to bind to LDAP server";
      exit;
    }

    // use PASSWD EXOP to change the user password for a generated one
    $genpw = ldap_exop_passwd($ds, "cn=root, o=My Company, c=US", "secret");
    if ($genpw) {
      // use the generated password to bind
      $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", $genpw);
    }

    // set the password back to "secret"
    ldap_exop_passwd($ds, "cn=root, o=My Company, c=US", $genpw, "secret");

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

Ver también

  • ldap_exop() - Performs an extended operation
  • ldap_parse_exop() - Parse result object from an LDAP extended operation


Refresh extended operation helper

  • « ldap_exop_passwd
  • ldap_exop_whoami »
  • PHP Manual
  • LDAP Funciones
  • Refresh extended operation helper

ldap_exop_refresh

(PHP 7 >= 7.3.0, PHP 8)

ldap_exop_refresh — Refresh extended operation helper

Descripción

ldap_exop_refresh ( resource $ldap , string $dn , int $ttl ) : int|false

Performs a Refresh extended operation and returns the data.

Parámetros

ldap

An LDAP link identifier, returned by ldap_connect().

dn

dn of the entry to refresh.

ttl

Time in seconds (between 1 and 31557600) that the client requests that the entry exists in the directory before being automatically removed.

Valores devueltos

From RFC: The responseTtl field is the time in seconds which the server chooses to have as the time-to-live field for that entry. It must not be any smaller than that which the client requested, and it may be larger. However, to allow servers to maintain a relatively accurate directory, and to prevent clients from abusing the dynamic extensions, servers are permitted to shorten a client-requested time-to-live value, down to a minimum of 86400 seconds (one day). false will be returned on error.

Ver también

  • ldap_exop() - Performs an extended operation


WHOAMI extended operation helper

  • « ldap_exop_refresh
  • ldap_exop »
  • PHP Manual
  • LDAP Funciones
  • WHOAMI extended operation helper

ldap_exop_whoami

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop_whoami — WHOAMI extended operation helper

Descripción

ldap_exop_whoami ( resource $ldap ) : string|false

Performs a WHOAMI extended operation and returns the data.

Parámetros

ldap

An LDAP link identifier, returned by ldap_connect().

Valores devueltos

The data returned by the server, or false on error.

Ver también

  • ldap_exop() - Performs an extended operation


Performs an extended operation

  • « ldap_exop_whoami
  • ldap_explode_dn »
  • PHP Manual
  • LDAP Funciones
  • Performs an extended operation

ldap_exop

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop — Performs an extended operation

Descripción

ldap_exop ( resource $link , string $reqoid , string $reqdata = null , array $serverctrls = null , string &$retdata = ? , string &$retoid = ? ) : mixed

Performs an extended operation on the specified link with reqoid the OID of the operation and reqdata the data.

Parámetros

link

An LDAP link identifier, returned by ldap_connect().

reqoid

The extended operation request OID. You may use one of LDAP_EXOP_START_TLS, LDAP_EXOP_MODIFY_PASSWD, LDAP_EXOP_REFRESH, LDAP_EXOP_WHO_AM_I, LDAP_EXOP_TURN, or a string with the OID of the operation you want to send.

reqdata

The extended operation request data. May be NULL for some operations like LDAP_EXOP_WHO_AM_I, may also need to be BER encoded.

serverctrls

Array of LDAP Controls to send with the request.

retdata

Will be filled with the extended operation response data if provided. If not provided you may use ldap_parse_exop on the result object later to get this data.

retoid

Will be filled with the response OID if provided, usually equal to the request OID.

Valores devueltos

When used with retdata, returns true on success or false on error. When used without retdata, returns a result identifier or false on error.

Historial de cambios

Versión | Descripción
7.3 | Support for serverctrls added

Ejemplos

Ejemplo #1 Whoami extended operation

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");
    if (!$bind) {
      echo "Unable to bind to LDAP server";
      exit;
    }

    // Call WHOAMI EXOP
    $r = ldap_exop($ds, LDAP_EXOP_WHO_AM_I);

    // Parse the result object
    ldap_parse_exop($ds, $r, $retdata);
    // Output: string(31) "dn:cn=root, o=My Company, c=US"
    var_dump($retdata);

    // Same thing using $retdata parameter
    $success = ldap_exop($ds, LDAP_EXOP_WHO_AM_I, NULL, NULL, $retdata, $retoid);
    if ($success) {
      var_dump($retdata);
    }

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

Ver también

  • ldap_parse_result() - Extraer información del resultado
  • ldap_parse_exop() - Parse result object from an LDAP extended operation
  • ldap_exop_whoami() - WHOAMI extended operation helper
  • ldap_exop_refresh() - Refresh extended operation helper
  • ldap_exop_passwd() - PASSWD extended operation helper


Divide un DN en sus partes componentes

  • « ldap_exop
  • ldap_first_attribute »
  • PHP Manual
  • LDAP Funciones
  • Divide un DN en sus partes componentes

ldap_explode_dn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_explode_dn — Divide un DN en sus partes componentes

Descripción

ldap_explode_dn ( string $dn , int $with_attrib ) : array

Divide el DN devuelto por ldap_get_dn() y lo rompe en sus partes componentes. Cada parte es conocida como Nombre Relativo Distinguido, o RDN por sus siglas en inglés.

Parámetros

dn

El nombre distinguido de una entidad de LDAP.

with_attrib

Utilizado para petición si los RDNs son devueltos con valores únicos o con sus atributos. Para obtener RDNs con los atributos (por ejemplo, en el formato atributo=valor) establecer with_attrib en 0 y obtener solamente los valores establecidos en 1.

Valores devueltos

Devuelve un array de todos los componente de un DN, o false en caso de error. El primer elemento en el array tiene la clave count y representa el número de valores devueltos, los siguientes elementos son componentes DN numéricamente indexados.


Devolver el primer atributo

  • « ldap_explode_dn
  • ldap_first_entry »
  • PHP Manual
  • LDAP Funciones
  • Devolver el primer atributo

ldap_first_attribute

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_first_attribute — Devolver el primer atributo

Descripción

ldap_first_attribute ( resource $link_identifier , resource $result_entry_identifier ) : string

Obtiene el primer atributo de la entrada proporcionada. Los atributos restantes son devueltos al invocar ldap_next_attribute() sucesivamente.

Similar a la lectura de las entradas, los atributos son leídos uno por uno desde una entrada en particular.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

result_entry_identifier

ber_identifier

ber_identifier es el identificador hacia la ubicación del puntero de memoria interna. Este se pasa por referencia. El mismo ber_identifier se pasa a ldap_next_attribute(), el cual modifica ese puntero.

Nota:

Este parámetro ya no se utiliza ya que ahora es manejado automáticamente por PHP. Por compatibilidad con versiones anteriores PHP no lanzará un error si se pasa este parámetro.

Valores devueltos

Devuelve el primer atributo de la entrada en caso de éxito y false en caso de error.

Historial de cambios

Versión | Descripción
5.2.4 | ber_identifier ha sido retirado. Este ahora es manejado automáticamente por PHP.

Ver también

  • ldap_next_attribute() - Obtener el siguiente atributo en un resultado
  • ldap_get_attributes() - Obtener atributos de una entrada de búsqueda de resultados


Devolver el primer resultado de identificación

  • « ldap_first_attribute
  • ldap_first_reference »
  • PHP Manual
  • LDAP Funciones
  • Devolver el primer resultado de identificación

ldap_first_entry

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_first_entry — Devolver el primer resultado de identificación

Descripción

ldap_first_entry ( resource $link_identifier , resource $result_identifier ) : resource

Devuelve el identificador de entrada para la primera entrada en el resultado. Este identificador de entrada se provee a la rutina ldap_next_entry() para obtener entradas sucesivas a partir del resultado.

Las entradas en el resultado de LDAP son leídas secuencialmente utilizando las funciones ldap_first_entry() y ldap_next_entry().

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

result_identifier

Valores devueltos

Devuelve el identificador de la entrada de resultados para la primera entrada en caso de éxito, y false en caso de error.

Ver también

  • ldap_get_entries() - Obtener todas las entradas de los resultados


Devolver la primera referencia

  • « ldap_first_entry
  • ldap_free_result »
  • PHP Manual
  • LDAP Funciones
  • Devolver la primera referencia

ldap_first_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_first_reference — Devolver la primera referencia

Descripción

ldap_first_reference ( resource $link , resource $result ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Liberar la memoria de resultado

  • « ldap_first_reference
  • ldap_get_attributes »
  • PHP Manual
  • LDAP Funciones
  • Liberar la memoria de resultado

ldap_free_result

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_free_result — Liberar la memoria de resultado

Descripción

ldap_free_result ( resource $result_identifier ) : bool

Libera la memoria ubicada internamente para almacenar los resultados. Toda la memoria de resultado será liberada automáticamente cuando termine el script de ejecutarse.

Típicamente, toda la memoria ubicada para el resultado de LDAP se libera al final del script. En caso que el script esté haciendo búsquedas sucesivas lo cual devuelve conjuntos de resultados largos, ldap_free_result() podría ser llamado para mantener bajo el uso de la memoria en tiempo de ejecución por el script.

Parámetros

result_identifier

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener atributos de una entrada de búsqueda de resultados

  • « ldap_free_result
  • ldap_get_dn »
  • PHP Manual
  • LDAP Funciones
  • Obtener atributos de una entrada de búsqueda de resultados

ldap_get_attributes

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_attributes — Obtener atributos de una entrada de búsqueda de resultados

Descripción

ldap_get_attributes ( resource $link_identifier , resource $result_entry_identifier ) : array

Lee atributos y valores desde una entrada en la búsqueda de resultados.

Teniendo ubicada una entrada específica en el el directorio, puedes encontrar qué información es mantenida para esa entrada utilizando esta llamada. Podrías utilizar esta llamada para una aplicación la cual "navegue" entre entradas de directorio y/o donde no conozcas la estructura de las entradas de directorio. En muchas aplicaciones estarás buscando un atributo específico tal como una dirección de correo electrónico o un apellido, y no tendrás cuidado de qué otro datos sean mantenidos en esa búsqueda.

return_value["count"] = número de atributos en la entrada
return_value[0] = el primero atributo
return_value[n] = el enésimo atributo

return_value["attribute"]["count"] = número de valores para un atributo
return_value["attribute"][0] = el primero valor del atributo
return_value["attribute"][i] = el valor (i+1) del atributo

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

result_entry_identifier

Valores devueltos

Devuelve una entrada completa de información en un arreglo multi-dimensional en caso de éxito y false en caso de error.

Ejemplos

Ejemplo #1 Mostrar la lista de atributos mantenida por una entrada de directorio en particular

<?php
// $ds es el enlace identificador para el directorio

// $sr es un resultado de búsqueda válido desde una llamada previa hacia
// una de las llamadas de búsqueda de directorio de ldap

$entry = ldap_first_entry($ds, $sr);

$attrs = ldap_get_attributes($ds, $entry);

echo $attrs["count"] . " atributos mantenidos por esta entrada:<p>";

for ($i=0; $i < $attrs["count"]; $i++) {
    echo $attrs[$i] . "<br />";
}
?>

Ver también

  • ldap_first_attribute() - Devolver el primer atributo
  • ldap_next_attribute() - Obtener el siguiente atributo en un resultado


Get the DN of a result entry

  • « ldap_get_attributes
  • ldap_get_entries »
  • PHP Manual
  • LDAP Funciones
  • Get the DN of a result entry

ldap_get_dn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_dn — Get the DN of a result entry

Descripción

ldap_get_dn ( resource $link_identifier , resource $result_entry_identifier ) : string

Finds out the DN of an entry in the result.

Parámetros

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Valores devueltos

Returns the DN of the result entry and false on error.


Obtener todas las entradas de los resultados

  • « ldap_get_dn
  • ldap_get_option »
  • PHP Manual
  • LDAP Funciones
  • Obtener todas las entradas de los resultados

ldap_get_entries

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_entries — Obtener todas las entradas de los resultados

Descripción

ldap_get_entries ( resource $link_identifier , resource $result_identifier ) : array

Lee múltiples entradas de los resultados porporcionados, luego lee los atributos y valores múltiples.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

result_identifier

Valores devueltos

Devuelve un resultado completo de información en un array multi-dimensional en caso de éxito y false en caso de error.

La estructura del array es como sigue. El índice del atributo se convierte a minúsculas. (Los atributos son insensibles a mayúsculas o minúsculas para los servidores de directorio, pero no cuando se usan como índices de array.)

return_value["count"] = número de entradas en el en el resultado
return_value[0] : se refiere a los detalles de la primer entrada

return_value[i]["dn"] =  DN de la i-ésima en el resultado

return_value[i]["count"] = Número de atributos en la i-ésima entrada
return_value[i][j] = NOMBRE del j-ésimo atributo en la i-ésima entrada en el resultado

return_value[i]["attribute"]["count"] = número de valores para
                                        el atributo en la i-ésima entrada
return_value[i]["attribute"][j] = j-ésimo valor del atributo en la i-ésima entrada

Ver también

  • ldap_first_entry() - Devolver el primer resultado de identificación
  • ldap_next_entry() - Obtener el siguiente resultado de entrada


Obtener el valor actual para la opción dada

  • « ldap_get_entries
  • ldap_get_values_len »
  • PHP Manual
  • LDAP Funciones
  • Obtener el valor actual para la opción dada

ldap_get_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ldap_get_option — Obtener el valor actual para la opción dada

Descripción

ldap_get_option ( resource $link_identifier , int $option , mixed &$retval ) : bool

Establece retval hacia el valor de la opción especificada.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

option

El parámetro option puede ser uno de estos:

Option | Type
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int
LDAP_OPT_X_KEEPALIVE_PROBES | int
LDAP_OPT_X_KEEPALIVE_INTERVAL | int
LDAP_OPT_X_TLS_CACERTDIR | string
LDAP_OPT_X_TLS_CACERTFILE | string
LDAP_OPT_X_TLS_CERTFILE | string
LDAP_OPT_X_TLS_CIPHER_SUITE | string
LDAP_OPT_X_TLS_CRLCHECK | integer
LDAP_OPT_X_TLS_CRLFILE | string
LDAP_OPT_X_TLS_DHFILE | string
LDAP_OPT_X_TLS_KEYILE | string
LDAP_OPT_X_TLS_PACKAGE | string
LDAP_OPT_X_TLS_PROTOCOL_MIN | integer
LDAP_OPT_X_TLS_RANDOM_FILE | string
LDAP_OPT_X_TLS_REQUIRE_CERT | integer
LDAP_OPT_CLIENT_CONTROLS | array

retval

Este será establecido al valor de la opción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Revisar la versión del protocolo

<?php
// $ds es un enlace identificador válido para un servidor de directorio
if (ldap_get_option($ds, LDAP_OPT_PROTOCOL_VERSION, $version)) {
    echo "Utilizando el protocolo en su versión: $version\n";
} else {
    echo "Imposible determinar la versión del protocolo\n";
}
?>

Notas

Nota:

Esta función solamente está disponible cuando se utiliza OpenLDAP 2.x.x ó Netscape Directory SDK x.x.

Ver también

  • ldap_set_option() - Establecer el valor de la opción proporcionada


Obtener todos los valores binarios desde una entrada de resultados

  • « ldap_get_option
  • ldap_get_values »
  • PHP Manual
  • LDAP Funciones
  • Obtener todos los valores binarios desde una entrada de resultados

ldap_get_values_len

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_values_len — Obtener todos los valores binarios desde una entrada de resultados

Descripción

ldap_get_values_len ( resource $link_identifier , resource $result_entry_identifier , string $attribute ) : array

Lee todos los valores del atributo en la entrada en el resultado.

Esta función es utilizada exactamente como ldap_get_values() excepto que esta maneja datos binarios y no datos de cadena.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_entry_identifier

attribute

Valores devueltos

Devuelve un arreglo de valores para el atributo en caso de éxito y false en caso de error. Los valores individuales son accedidos por un índice entero en el arreglo. El índice primero es 0. El número de valores puede ser encontrado indexando "count" en el arreglo resultante.

Ver también

  • ldap_get_values() - Obtener todos los valores de una entrada de resultados


Obtener todos los valores de una entrada de resultados

  • « ldap_get_values_len
  • ldap_list »
  • PHP Manual
  • LDAP Funciones
  • Obtener todos los valores de una entrada de resultados

ldap_get_values

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_values — Obtener todos los valores de una entrada de resultados

Descripción

ldap_get_values ( resource $link_identifier , resource $result_entry_identifier , string $attribute ) : array

Lee todos los valores del atributo en la entrada en el resultado.

Esta llamada necesita un result_entry_identifier, tal que sea precedido por una de las llamadas de búsqueda de ldap y una de las llamadas para obtener una entrada individual.

Su solicitud será fuertemente codificada para buscar ciertos atributos (tales como "apellido" o "correo"), o tendrá que utilizar la llamada ldap_get_attributes() para resolver qué atributos existen para una entrada dada.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_entry_identifier

attribute

Valores devueltos

Devuelve un arreglo de valores para el atributo en caso de éxito y false en caso de error. El número de valores puede ser hallado indexando "count" en el arreglo resultante. Los valores individuales son accedidos por un índice entero en el arreglo. El índice primero es 0.

LDAP permite más de una entrada para un atributo, así que puede, por ejemplo, almacenar un número de direcciones para la entrada de directorio de una persona etiquetado con el atributo "correo"

    return_value["count"] = Número de valores para el atributo
    return_value[0] = Primer valor del atributo
    return_value[i] = i-ésimo valor del atributo

Ejemplos

Ejemplo #1 Listar todos los valores del atributo "correo" para una entrada de directorio

<?php
// $ds es un identificador de enlace válido para un servidor de directorio

// $sr es un resultado de búsqueda válido de una llamada previa a
//     una de las llamadas de búsqueda de directorio ldap

// $entry es un identificador de entrada válido de una llavada previa a
//        una de las llamadas que devuelve una entrada de directorio

$values = ldap_get_values($ds, $entry, "correo");

echo $values["count"] . " direcciones de correo para esta entrada.<br />";

for ($i=0; $i < $values["count"]; $i++) {
    echo $values[$i] . "<br />";
}
?>

Ver también

  • ldap_get_values_len() - Obtener todos los valores binarios desde una entrada de resultados


Búsqueda de un solo nivel

  • « ldap_get_values
  • ldap_mod_add_ext »
  • PHP Manual
  • LDAP Funciones
  • Búsqueda de un solo nivel

ldap_list

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_list — Búsqueda de un solo nivel

Descripción

ldap_list ( resource $link_identifier , string $base_dn , string $filter , array $attributes = ? , int $attrsonly = ? , int $sizelimit = ? , int $timelimit = ? , int $deref = ? ) : resource

Realiza la búsqueda de un filter especificado en el directorio con el alcance de LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL quiere decir que la búsqueda solamente debería devolver información que está en el nivel inmediatamente abajo de el base_dn proporcionado en la llamada. (Equivalente a digitar "ls" y obtener una lista de los ficheros y carpetas en el actual directorio de trabajo.)

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

base_dn

El DN base para el directorio.

filter

attributes

Un array de atributos requeridos, por ejemplo array("correo", "sn", "cn"). Tenga en cuenta que "dn" siempre es devuelto independientemente de qué tipos de atributos lo soliciten.

Utilizando este parámetro es mucho más eficiente que la acción predeterminada (la cual es devolver todos los atributos y sus valores asociados). Por lo tanto, el uso de este parámetro debería ser considerado una buena práctica.

attrsonly

Debería ser establecido a 1 solamente si los tipos de atributo son solicitados. Si se establece a 0 se devuelven los tipos de atributos y los valores de los atributos lo cual es el comportamiento predeterminado.

sizelimit

Te permite limitar el conteo de entradas a devolver. Al establecer esto a 0 significa que no hay límite.

Nota:

Este parámetro NO puede prevalecer sobre el sizelimit preestablecido en el lado del servidor. Puede aún establecerlo a uno más bajo.

Algunos equipos de servidor de directorio serán configurados para devolver no mas que un número preestablecido de entradas. Si esto ocurre, el servidor indicará que sólo ha devuelto un conjunto de resultados parciales. Esto también ocurre si utiliza este parámetro para limitar el conteo de entradas devueltas.

timelimit

Establece el número de segundos de cuánto tiempo pasa en la búsqueda. Poniendo esto a 0 siginifica que no hay límite.

Nota:

Este parámetro NO puede prevalecer sobre el timelimit preestablecido en el lado del servidor. Puede aún establecerlo a uno más bajo.

deref

Especifica cuántos alias deberían ser manejados durante la búsqueda. Este puede ser uno de los siguientes:

  • LDAP_DEREF_NEVER - (predeterminado) Los alias nunca son dereferenciados.
  • LDAP_DEREF_SEARCHING - Los alias deberían ser dereferenciados durante la búsqueda pero no cuando se está ubicando el objeto base de la búsqueda.
  • LDAP_DEREF_FINDING - Los alias deberían ser dereferenciados cuando se está ubicando el objeto base pero no durante la búsqueda.
  • LDAP_DEREF_ALWAYS - Los alias siempre deberían ser dereferenciados.

Valores devueltos

Devuelve un identificador de resultado de búsqueda, o false en caso de error.

Historial de cambios

Versión | Descripción
4.0.5 | Ha sido agregado el soporte de búsquedas en paralelo. Vea ldap_search() para más detalles.

Ejemplos

Ejemplo #1 Producir una lista de todas las unidades organizacionales de una organización

<?php
// $ds es un identificador de enlace válido para un servidor de directorio

$basedn = "o=Mi Compañía, c=US";
$justthese = array("ou");

$sr = ldap_list($ds, $basedn, "ou=*", $justthese);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i < $info["count"]; $i++) {
    echo $info[$i]["ou"][0];
}
?>

Ver también

  • ldap_search() - Buscar el árbol LDAP


Add attribute values to current attributes

  • « ldap_list
  • ldap_mod_add »
  • PHP Manual
  • LDAP Funciones
  • Add attribute values to current attributes

ldap_mod_add_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_add_ext — Add attribute values to current attributes

Descripción

ldap_mod_add_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_add() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_mod_add()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Ver también

  • ldap_mod_add() - Agregar valores de atributo a los atributos actuales
  • ldap_parse_result() - Extraer información del resultado


Agregar valores de atributo a los atributos actuales

  • « ldap_mod_add_ext
  • ldap_mod_del_ext »
  • PHP Manual
  • LDAP Funciones
  • Agregar valores de atributo a los atributos actuales

ldap_mod_add

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_add — Agregar valores de atributo a los atributos actuales

Descripción

ldap_mod_add ( resource $link_identifier , string $dn , array $entry ) : bool

Agrega uno o más atributos al dn específico. Se realiza la modificación a nivel de atributo en lugar de realizarce a nivel de Objeto. Las adiciones a nivel de Objeto son hechas por la función ldap_add().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelta por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

entry

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Esta función es segura binariamente.

Ver también

  • ldap_mod_del() - Borrar valores de atributo de los atributos actuales
  • ldap_mod_replace() - Reemplazar valores de atributos con valores nuevos


Delete attribute values from current attributes

  • « ldap_mod_add
  • ldap_mod_del »
  • PHP Manual
  • LDAP Funciones
  • Delete attribute values from current attributes

ldap_mod_del_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_del_ext — Delete attribute values from current attributes

Descripción

ldap_mod_del_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_del() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_mod_del()

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Valores devueltos

Returns an LDAP result identifier or false on error.

Ver también

  • ldap_mod_del() - Borrar valores de atributo de los atributos actuales
  • ldap_parse_result() - Extraer información del resultado


Borrar valores de atributo de los atributos actuales

  • « ldap_mod_del_ext
  • ldap_mod_replace_ext »
  • PHP Manual
  • LDAP Funciones
  • Borrar valores de atributo de los atributos actuales

ldap_mod_del

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_del — Borrar valores de atributo de los atributos actuales

Descripción

ldap_mod_del ( resource $link_identifier , string $dn , array $entry ) : bool

Remueve uno o más atributos de un dn específico. Realiza la modificación a nivel de atributo en lugar de hacerlo a nivel de Objeto. Las eliminaciones a nivel de Objeto son hechas por la función ldap_delete().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

entry

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ldap_mod_add() - Agregar valores de atributo a los atributos actuales
  • ldap_mod_replace() - Reemplazar valores de atributos con valores nuevos


Replace attribute values with new ones

  • « ldap_mod_del
  • ldap_mod_replace »
  • PHP Manual
  • LDAP Funciones
  • Replace attribute values with new ones

ldap_mod_replace_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_replace_ext — Replace attribute values with new ones

Descripción

ldap_mod_replace_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_replace() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_mod_replace()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Ver también

  • ldap_mod_replace() - Reemplazar valores de atributos con valores nuevos
  • ldap_parse_result() - Extraer información del resultado


Reemplazar valores de atributos con valores nuevos

  • « ldap_mod_replace_ext
  • ldap_modify_batch »
  • PHP Manual
  • LDAP Funciones
  • Reemplazar valores de atributos con valores nuevos

ldap_mod_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_replace — Reemplazar valores de atributos con valores nuevos

Descripción

ldap_mod_replace ( resource $link_identifier , string $dn , array $entry ) : bool

Reemplaza uno o más atributos de un dn específico. Realiza la modificación a nivel de atributo en lugar de hacerlo a nivel de Objeto. Las modificaciones a nivel de Objeto son hechas por la función ldap_modify().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

entry

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Esta función es segura binariamente.

Ver también

  • ldap_mod_del() - Borrar valores de atributo de los atributos actuales
  • ldap_mod_add() - Agregar valores de atributo a los atributos actuales


Batch and execute modifications on an LDAP entry

  • « ldap_mod_replace
  • ldap_modify »
  • PHP Manual
  • LDAP Funciones
  • Batch and execute modifications on an LDAP entry

ldap_modify_batch

(PHP 5.4 >= 5.4.26, PHP 5.5 >= 5.5.10, PHP 5.6 >= 5.6.0, PHP 7, PHP 8)

ldap_modify_batch — Batch and execute modifications on an LDAP entry

Descripción

ldap_modify_batch ( resource $ldap , string $dn , array $modifications_info , array|null $controls = null ) : bool

Modifies an existing entry in the LDAP directory. Allows detailed specification of the modifications to perform.

Parámetros

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

modifications_info

An array that specifies the modifications to make. Each entry in this array is an associative array with two or three keys: attrib maps to the name of the attribute to modify, modtype maps to the type of modification to perform, and (depending on the type of modification) values maps to an array of attribute values relevant to the modification.

Possible values for modtype include:

LDAP_MODIFY_BATCH_ADD

Each value specified through values is added (as an additional value) to the attribute named by attrib.

LDAP_MODIFY_BATCH_REMOVE

Each value specified through values is removed from the attribute named by attrib. Any value of the attribute not contained in the values array will remain untouched.

LDAP_MODIFY_BATCH_REMOVE_ALL

All values are removed from the attribute named by attrib. A values entry must not be provided.

LDAP_MODIFY_BATCH_REPLACE

All current values of the attribute named by attrib are replaced with the values specified through values.

Note that any value for attrib must be a string, any value for values must be an array of strings, and any value for modtype must be one of the LDAP_MODIFY_BATCH_* constants listed above.

controls

Array of LDAP Controls to send with the request.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Ejemplos

Ejemplo #1 Add a telephone number to a contact

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "telephoneNumber",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["+1 555 555 1717"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Ejemplo #2 Rename a user

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "sn",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Smith-Jones"],
    ],
    [
        "attrib"  => "givenName",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Jack"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
ldap_rename($connection, $dn, "cn=Jack Smith-Jones", NULL, TRUE);
?>

Ejemplo #3 Add two e-mail addresses to a user

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "mail",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [
            "jack.smith@example.com",
            "jack.smith-jones@example.com",
        ],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Ejemplo #4 Change a user's password

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => ["Tr0ub4dor&3"],
    ],
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["correct horse battery staple"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Ejemplo #5 Change a user's password (Active Directory)

<?php
function adifyPw($pw)
{
    return iconv("UTF-8", "UTF-16LE", '"' . $pw . '"');
}

$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=ad,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => [adifyPw("Tr0ub4dor&3")],
    ],
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [adifyPw("correct horse battery staple")],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);


Modificar una entrada de LDAP

  • « ldap_modify_batch
  • ldap_next_attribute »
  • PHP Manual
  • LDAP Funciones
  • Modificar una entrada de LDAP

ldap_modify

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_modify — Modificar una entrada de LDAP

Descripción

ldap_modify ( resource $link_identifier , string $dn , array $entry ) : bool

Modificar las entradas existentes en el directorio de LDAP. La estructura de la entrada es la misma como en ldap_add().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

entry

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Esta función es segura binariamente.

Ver también

  • ldap_rename() - Modificar el nombre de una entrada


Obtener el siguiente atributo en un resultado

  • « ldap_modify
  • ldap_next_entry »
  • PHP Manual
  • LDAP Funciones
  • Obtener el siguiente atributo en un resultado

ldap_next_attribute

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_next_attribute — Obtener el siguiente atributo en un resultado

Descripción

ldap_next_attribute ( resource $link_identifier , resource $result_entry_identifier ) : string

Devuelve los atributos en una entrada. La primer llamada a la función ldap_next_attribute() es hecha con el parámetro result_entry_identifier que es devuelto por la función ldap_first_attribute().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_entry_identifier

ber_identifier

El estado interno del puntero es mantenido por este parámetro.

Nota:

Este parámetro ya no se utiliza debido a que ahora es manipulado automáticamente por PHP. Por compatibilidades previas, PHP no lanzará un error si se pasa este parámetro.

Valores devueltos

Devuelve el siguiente atributo en una entrada en caso de éxito y false en caso de error.

Historial de cambios

Versión | Descripción
5.2.4 | El parámetro ber_identifier fue removido. Este se maneja ahora automáticamente por PHP.

Ver también

  • ldap_get_attributes() - Obtener atributos de una entrada de búsqueda de resultados


Obtener el siguiente resultado de entrada

  • « ldap_next_attribute
  • ldap_next_reference »
  • PHP Manual
  • LDAP Funciones
  • Obtener el siguiente resultado de entrada

ldap_next_entry

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_next_entry — Obtener el siguiente resultado de entrada

Descripción

ldap_next_entry ( resource $link_identifier , resource $result_entry_identifier ) : resource

Devuelve las entradas almacenadas en el resultado. Las llamadas sucesivas a ldap_next_entry() devuelven etradas de a una por una hasta que no hayan más entradas. La primer llamada a la función ldap_next_entry() es hecha después de llamar a ldap_first_entry() con el parámetro result_entry_identifier que es devuelto por la función ldap_first_entry().

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_entry_identifier

Valores devueltos

Devuelve un identificador de entrada para la entrada siguiente en el resultado, cuyas entradas son leídas desde el comienzo con ldap_first_entry(). Si no hay más entradas en el resultado entonces devuelve false.

Ver también

  • ldap_get_entries() - Obtener todas las entradas de los resultados


Obtener la siguiente referencia

  • « ldap_next_entry
  • ldap_parse_exop »
  • PHP Manual
  • LDAP Funciones
  • Obtener la siguiente referencia

ldap_next_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_next_reference — Obtener la siguiente referencia

Descripción

ldap_next_reference ( resource $link , resource $entry ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Parse result object from an LDAP extended operation

  • « ldap_next_reference
  • ldap_parse_reference »
  • PHP Manual
  • LDAP Funciones
  • Parse result object from an LDAP extended operation

ldap_parse_exop

(PHP 7 >= 7.2.0, PHP 8)

ldap_parse_exop — Parse result object from an LDAP extended operation

Descripción

ldap_parse_exop ( resource $ldap , resource $result , string &$response_data = null , string &$response_oid = null ) : bool

Parse LDAP extended operation data from result object result

Parámetros

ldap

An LDAP link identifier, returned by ldap_connect().

result

An LDAP result resource, returned by ldap_exop().

response_data

Will be filled by the response data.

response_oid

Will be filled by the response OID.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ldap_exop() - Performs an extended operation


Extraer información de la entrada de referencia

  • « ldap_parse_exop
  • ldap_parse_result »
  • PHP Manual
  • LDAP Funciones
  • Extraer información de la entrada de referencia

ldap_parse_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_parse_reference — Extraer información de la entrada de referencia

Descripción

ldap_parse_reference ( resource $link , resource $entry , array &$referrals ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Extraer información del resultado

  • « ldap_parse_reference
  • ldap_read »
  • PHP Manual
  • LDAP Funciones
  • Extraer información del resultado

ldap_parse_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_parse_result — Extraer información del resultado

Descripción

ldap_parse_result ( resource $link , resource $result , int &$errcode , string &$matcheddn = ? , string &$errmsg = ? , array &$referrals = ? ) : bool

Analiza un resultado de búsqueda de LDAP.

Parámetros

link

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result_identifier

Es un recurso de resultado de LDAP, devuelto por ldap_list() o ldap_search().

errcode

Es una referencia a una variable que será establecida en el código de error de LDAP en el resultado, o 0 si no hubo un error.

matcheddn

Es una referencia a una variable que será establecida a un DN que coincidió si alguno fue reconocido dentro de la solicitud, de otro modo este será establecido a null.

errmsg

Es una referencia a una variable que será establecida al mensaje de error de LDAP en el resultado, o será una cadena vacía si no hubo error.

referrals

Es una referencia a una variable que será establecida a un conjunto de array para todas las cadenas de referencia en el resultado, o un array vacío si no se devuelven referencias.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ldap_parse_result()

<?php
$result = ldap_search($link, "cn=userref,dc=my-domain,dc=com", "(cn=user*)");
$errcode = $dn = $errmsg = $refs =  null;
if (ldap_parse_result($link, $result, $errcode, $dn, $errmsg, $refs)) {
    // hacer algo con $errcode, $dn, $errmsg y $refs
}
?>


Leer una entrada

  • « ldap_parse_result
  • ldap_rename_ext »
  • PHP Manual
  • LDAP Funciones
  • Leer una entrada

ldap_read

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_read — Leer una entrada

Descripción

ldap_read ( resource $link_identifier , string $base_dn , string $filter , array $attributes = ? , int $attrsonly = ? , int $sizelimit = ? , int $timelimit = ? , int $deref = ? ) : resource

Realiza la búsqueda de un filter en específico en el directorio con el alcance de LDAP_SCOPE_BASE. Lo que es equivalente a leer una entrada del directorio.

Parámetros

link_identifier

Un enlace identificador de LDAP, devuelto por ldap_connect().

base_dn

El DN base para el directorio.

filter

No se permite un filtro vacío. Si quieres devolver absolutamente toda la información de esta entrada, utiliza un filtro como este objectClass=*. Si sabes qué tipos de entradas se utilizan en el servidor de directorio, podrías utilizar un filtro apropiado tal como objectClass=inetOrgPerson.

attributes

Un array de los atributos requeridos, por ejemplo, array("mail", "sn", "cn"). Nótese que el "dn" siempre se devuelve independientemente de qué tipos de atributos son requeridos.

Utilizar este parámetro es mucho más eficiente que la acción predeterminada (la cual es devolver todos los atributos y sus valores asociados). El uso de este parámetro debería ser, por lo tanto, considerado una buena práctica.

attrsonly

Debería ser establecido a 1 si solamente se buscan los tipos de atributos. Si se establece a 0, ambos los tipos de atributos y los valores de los atributos son extraídos como es el comportamiento predeterminado.

sizelimit

Permite limitar la cuenta de entradas extraídas. Establecer esto a 0 significa que no hay límite.

Nota:

Este parámetro NO puede prevalecer al límite de tamaño preestablecido en el lado del servidor. Aunque puedes establecerlo al más bajo.

Algunos equipos servidores de directorio serán configurados para devovler no más de un determinado número predefinido de entradas. Si esto sucede, el servidor indicará que solamente ha devuelto un conjunto parcial de resultados. Esto también sucede si utilizas este parámetro para limitar la cuenta de las entradas extraídas.

timelimit

Establece el número de segundos de cuan larga será la búsqueda. Al establecer esto a 0 significa que no hay límite.

Nota:

Este parámetro NO puede prevalecer al límite de tiempo preestablecido en el lado del servidor. Aunque puedes establecerlo al más bajo.

deref

Especifica cuantos alias deberían ser manejados durante la búsqueda. Este puede ser uno de los siguientes:

  • LDAP_DEREF_NEVER - (predeterminado) Los alias nunca son desreferenciados.
  • LDAP_DEREF_SEARCHING - Los alias deberían ser desreferenciados durante la búsqueda pero no cuando se quiere ubicar el objeto base.
  • LDAP_DEREF_FINDING - Los alias deberían ser desreferenciados cuando se quiere ubicar el objeto base pero no durante la búsqueda.
  • LDAP_DEREF_ALWAYS - Los alias deberían ser siempre desreferenciados.

Valores devueltos

Devuelve un identificador del resultado de la búsqueda o false en caso de error.

Historial de cambios

Versión | Descripción
4.0.5 | Se añadió soporte para búsquedas en paralelo. Para más detalles vea ldap_search().


Modify the name of an entry

  • « ldap_read
  • ldap_rename »
  • PHP Manual
  • LDAP Funciones
  • Modify the name of an entry

ldap_rename_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_rename_ext — Modify the name of an entry

Descripción

ldap_rename_ext ( resource $ldap , string $dn , string $new_rdn , string $new_parent , bool $delete_old_rdn , array|null $controls = null ) : resource|false

Does the same thing as ldap_rename() but returns the LDAP result resource to be parsed with ldap_parse_result().

Parámetros

See ldap_rename()

Valores devueltos

Returns an LDAP result identifier or false on error.

Historial de cambios

Versión | Descripción
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

Ver también

  • ldap_rename() - Modificar el nombre de una entrada
  • ldap_parse_result() - Extraer información del resultado


Modificar el nombre de una entrada

  • « ldap_rename_ext
  • ldap_sasl_bind »
  • PHP Manual
  • LDAP Funciones
  • Modificar el nombre de una entrada

ldap_rename

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_rename — Modificar el nombre de una entrada

Descripción

ldap_rename ( resource $link_identifier , string $dn , string $newrdn , string $newparent , bool $deleteoldrdn ) : bool

La entrada que se especifica por dn se renombra/mueve.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

dn

El nombre distinguido de una entidad de LDAP.

newrdn

El RDN nuevo.

newparent

La nueva entrada padre/superior.

deleteoldrdn

Si es true se remueve el valor o valores antigüos del RDN, sino dichos valores del RDN se retienen como valores no distinguidos de la entrada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Actualmente esta función sólo trabaja con LDAPv3. Podría tener que utilizar la función ldap_set_option() previo a unirse a utilizar LDAPv3. Esta función está disponible solamente cuando se está utilizando OpenLDAP 2.x.x ó Netscape Directory SDK x.x.

Ver también

  • ldap_modify() - Modificar una entrada de LDAP


Unirse a un directorio LDAP utilizando SASL

  • « ldap_rename
  • ldap_search »
  • PHP Manual
  • LDAP Funciones
  • Unirse a un directorio LDAP utilizando SASL

ldap_sasl_bind

(PHP 5, PHP 7, PHP 8)

ldap_sasl_bind — Unirse a un directorio LDAP utilizando SASL

Descripción

ldap_sasl_bind ( resource $link , string $binddn = null , string $password = null , string $sasl_mech = null , string $sasl_realm = null , string $sasl_authc_id = null , string $sasl_authz_id = null , string $props = null ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: Requerimiento
ldap_sasl_bind() requiere soporte de SASL (sasl.h). Asegúrese de que --with-ldap-sasl sea utilizado cuando configure PHP de otra manera, esta función estará indefinida.

Historial de cambios

Versión | Descripción
5.3.3 | Se añadió soporte en Windows.


Buscar el árbol LDAP

  • « ldap_sasl_bind
  • ldap_set_option »
  • PHP Manual
  • LDAP Funciones
  • Buscar el árbol LDAP

ldap_search

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_search — Buscar el árbol LDAP

Descripción

ldap_search ( resource $link_identifier , string $base_dn , string $filter , array $attributes = array("*") , int $attrsonly = 0 , int $sizelimit = -1 , int $timelimit = -1 , int $deref = LDAP_DEREF_NEVER , array $serverctrls = array() ) : resource

Realiza la búsqueda de un filtro específico sobre el directorio con el alcance de LDAP_SCOPE_SUBTREE. Esto es equivalente a buscar en el directorio completo.

Desde la versión 4.0.5 en adelante, también es posible hacer búsquedas paralelas. Para hacer esto se utiliza un array de identificadores de enlace, en lugar de un simple identificador, como el primer argumento. Si no quieres el mismo DN y el mismo filtro para todas las búsquedas, puedes utilizar también un array de DNs base y/o un array de filtros. Esos arrays deben ser del mismo tamaño como el de el array del identificador de enlace ya que, las primeras entradas de los arrays son utilizadas por una búsqueda, las segundas entradas son utilizadas para otra, y así. Cuando se hacen búsquedas en paralelo se devuelve un array de identificadores del resultado de la búsqueda, exceptuando en caso de error, la entrada que corresponde a la búsqueda será false. Esto es muy parecido a los valores que normalmente se devuelven, excepto que un identificador de resultado siempre es devuelto cuando se hace una búsqueda. Hay algunos casos raros donde el resultado normal de la búsqueda devuelve false mientras que la búsqueda paralela devuelve un identificador.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

base_dn

El DN base para el directorio.

filter

El filtro de búsqueda puede ser simple o avanzado, utilizando operadores booleanos en el formato descrito en la documentación de LDAP (ver el » Directorio del SDK Netscape o el » RFC4515 para la información completa sobre filtros).

attributes

Un array de los atributos requeridos, por ejemplo, array("mail", "sn", "cn"). Nótese que el "dn" siempre es devuelto independientemente de qué tipos de atributos sean requeridos.

Utilizando este parámetro es mucho más eficiente que la acción predeterminada (la cual es devolver todos los atributos y sus valores asociados). El uso de este parámetro debería ser considerado una buena práctica.

attrsonly

Debería ser establecido a 1 si sólo se buscan tipos de atributos. Si se establece a 0 los valores de atributos y los tipos de atributos se muestran tal cual es el comportamiento predeterminado.

sizelimit

Te permite limitar la cantidad de entradas a mostrar. Al establecer esto a 0 siginifica que no hay límite.

Nota:

Este parámetro NO puede prevalecer sobre el sizelimit preestablecido en el lado del servidor. Puede aún establecerlo a uno más bajo.

Algunos equipos de servidor de directorio serán configurados para devolver no mas que un número preestablecido de entradas. Si esto ocurre, el servidor indicará que sólo ha devuelto un conjunto de resultados parciales. Esto también ocurre si utiliza este parámetro para limitar el conteo de entradas devueltas.

timelimit

Establece el número de segundos de cuánto tiempo pasa en la búsqueda. Poniendo esto a 0 siginifica que no hay límite.

Nota:

Este parámetro NO puede prevalecer sobre el timelimit preestablecido en el lado del servidor. Puede aún establecerlo a uno más bajo.

deref

Especifica cuántos alias deberían ser manejados durante la búsqueda. Este puede ser uno de los siguientes:

  • LDAP_DEREF_NEVER - (predeterminado) Los alias nunca son dereferenciados.
  • LDAP_DEREF_SEARCHING - Los alias deberían ser dereferenciados durante la búsqueda pero no cuando se está ubicando el objeto base de la búsqueda.
  • LDAP_DEREF_FINDING - Los alias deberían ser dereferenciados cuando se está ubicando el objeto base pero no durante la búsqueda.
  • LDAP_DEREF_ALWAYS - Los alias siempre deberían ser dereferenciados.

serverctrls

Array de Controles de LDAP a enviar con la petición.

Valores devueltos

Devuelve un identificador de resultado de búsqueda, o false en caso de error.

Historial de cambios

Versión | Descripción
7.3 | Se añadión soporte para serverctrls

Ejemplos

En el ejemplo de abajo se devuelve la unidad organizacional, apellido, el nombre proporcionado y la dirección de correo electrónico para todas las personas en "My Company" donde el apellido o el nombre proporcionado contiene la subcadena $person. Este ejemplo utiliza un filtro booleano para decirle al servidor que busque información en más de un atributo.

Ejemplo #1 Búsqueda LDAP

<?php
// $ds es un identificador de enlace válido para un servidor de directorio

// $person es todo o parte del nobre de una persona, por ejemplo "Jo"

$dn = "o=My Company, c=US";
$filter="(|(sn=$person*)(givenname=$person*))";
$justthese = array("ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filter, $justthese);

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entradas devueltas\n";
?>


Establecer el valor de la opción proporcionada

  • « ldap_search
  • ldap_set_rebind_proc »
  • PHP Manual
  • LDAP Funciones
  • Establecer el valor de la opción proporcionada

ldap_set_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ldap_set_option — Establecer el valor de la opción proporcionada

Descripción

ldap_set_option ( resource $link_identifier , int $option , mixed $newval ) : bool

Establece el valor de la opción especificada a newval.

Parámetros

link_identifier

Un identificador de enlace de LDAP, devuelto por ldap_connect().

option

El parámetro option puede ser uno de estos:

Option | Type | Available since
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer | PHP 5.3.0
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_DIAGNOSTIC_MESSAGE | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int | PHP 7.1.0
LDAP_OPT_X_KEEPALIVE_PROBES | int | PHP 7.1.0
LDAP_OPT_X_KEEPALIVE_INTERVAL | int | PHP 7.1.0
LDAP_OPT_X_TLS_CACERTDIR | string | PHP 7.1.0
LDAP_OPT_X_TLS_CACERTFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_CERTFILE | PHP 7.1.0
LDAP_OPT_X_TLS_CIPHER_SUITE | string | PHP 7.1.0
LDAP_OPT_X_TLS_CRLCHECK | integer | PHP 7.1.0
LDAP_OPT_X_TLS_CRLFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_DHFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_KEYFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_PROTOCOL_MIN | integer | PHP 7.1.0
LDAP_OPT_X_TLS_RANDOM_FILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_REQUIRE_CERT | integer | PHP 7.0.5

LDAP_OPT_SERVER_CONTROLS y LDAP_OPT_CLIENT_CONTROLS solicitan una lista de controles, lo que significa que el valor debe ser un array de controles. Un control consiste en un oid identificando el control, un value opcional, y un indicador opcional representado por criticality. En PHP un control es proporcionado por un array que contiene un elemento con la clave oid, una cadena de valor, y dos elementos opcionales. Los elementos opcionales son la clave value con un valor de tipo cadena, y la clave iscritical con un valor de tipo booleano. El valor de la clave iscritical de forma predeterminada es false si no es provisto. Vea » draft-ietf-ldapext-ldap-c-api-xx.txt para más detalles. Vea también el segundo ejemplo a continuación.

newval

El nuevo valor para el option especificado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer la versión del protocolo

<?php
// $ds es un identificador de enlace válido para un servidor de directorio
if (ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)) {
    echo "Utilizando LDAPv3";
} else {
    echo "Falló al establcer la versión 3 del protocolo";
}
?>

Ejemplo #2 Establecer controles del servidor

<?php
// $ds es un identificador de enlace válido para un servidor de directorio
// control sin valor
$ctrl1 = array("oid" => "1.2.752.58.10.1", "iscritical" => true);
// iscritical de forma predeterminada está en FALSE
$ctrl2 = array("oid" => "1.2.752.58.1.10", "value" => "magic");
// intentar establecer ambos controles
if (!ldap_set_option($ds, LDAP_OPT_SERVER_CONTROLS, array($ctrl1, $ctrl2))) {
    echo "Falló al establecer los controles del servidor";
}
?>

Notas

Nota:

Esta función está disponible solamente cuando se utiliza OpenLDAP 2.x.x ó Netscape Directory SDK x.x.

Ver también

  • ldap_get_option() - Obtener el valor actual para la opción dada


Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial

  • « ldap_set_option
  • ldap_sort »
  • PHP Manual
  • LDAP Funciones
  • Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial

ldap_set_rebind_proc

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ldap_set_rebind_proc — Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial

Descripción

ldap_set_rebind_proc ( resource $link , callable $callback ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Clasificar entradas de resultados de LDAP en el lado del cliente

  • « ldap_set_rebind_proc
  • ldap_start_tls »
  • PHP Manual
  • LDAP Funciones
  • Clasificar entradas de resultados de LDAP en el lado del cliente

ldap_sort

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ldap_sort — Clasificar entradas de resultados de LDAP en el lado del cliente

Descripción

ldap_sort ( resource $link , resource $result , string $sortfilter ) : bool

Clasificar el resultado de una búsqueda LDAP, devuelta por ldap_search().

Como esta función clasifica los valores devueltos en el lado del cliente, es posible que no pueda obtener los resultados esperados en caso que alcance el tamaño de límite sizelimit ya sea del servidor o el que está definido dentro de ldap_search().

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.0.0. Su uso está totalmente desaconsejado.

Parámetros

link

Un identificador de enlace de LDAP, devuelto por ldap_connect().

result

Un identificador de resultado de búsqueda, devuelto por ldap_search().

sortfilter

El atributo a utilizar como clave en la clasificación.

Ejemplos

Clasificando el resultado de una búsqueda.

Ejemplo #1 Clasificador de LDAP

<?php
     // $ds es un identificador de enlace válido (ver ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     // Clasificar
     ldap_sort($ds, $sr, 'sn');

     // Devolviendo los datos
     $info = ldap_get_entries($ds, $sr);


Inciar TLS

  • « ldap_sort
  • ldap_t61_to_8859 »
  • PHP Manual
  • LDAP Funciones
  • Inciar TLS

ldap_start_tls

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ldap_start_tls — Inciar TLS

Descripción

ldap_start_tls ( resource $link ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859

  • « ldap_start_tls
  • ldap_unbind »
  • PHP Manual
  • LDAP Funciones
  • Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859

ldap_t61_to_8859

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_t61_to_8859 — Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859

Descripción

ldap_t61_to_8859 ( string $value ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Desenlazar de directorio LDAP

  • « ldap_t61_to_8859
  • Memcache »
  • PHP Manual
  • LDAP Funciones
  • Desenlazar de directorio LDAP

ldap_unbind

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_unbind — Desenlazar de directorio LDAP

Descripción

ldap_unbind ( resource $link_identifier ) : bool

Desenlace de directorio LDAP.

Parámetros

link_identifier

Un identificador de enlace LDAP, devuelto por ldap_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ldap_bind() - Realiza la autenticación con un servidor LDAP


Memcache

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
  • Memcache — La clase Memcache
    • Memcache::add — Añadir un valor en el servidor
    • Memcache::addServer — Añadir servidor memcache al grupo de conexiones
    • Memcache::close — Cierra la conexión al servidor memcached
    • Memcache::connect — Abre una conexión al servidor memcached
    • Memcache::decrement — Decrementa numéricamente un valor
    • Memcache::delete — Elimina un valor del servidor
    • Memcache::flush — Limpia todos los valores existentes en el servidor
    • Memcache::get — Obtener valor del servidor
    • Memcache::getExtendedStats — Obtener estadísticas de todos los servidores en el grupo
    • Memcache::getServerStatus — Devuelve el estado del servidor
    • Memcache::getStats — Obtiene estadísticas del servidor
    • Memcache::getVersion — Devuelve la versión del servidor
    • Memcache::increment — Incrementa numéricamente un valor
    • Memcache::pconnect — Abre una conexión persistente a memcached
    • Memcache::replace — Reemplaza el valor de un valor existente
    • Memcache::set — Guarda datos en el servidor
    • Memcache::setCompressThreshold — Activa compresión automática de valores con datos largos
    • Memcache::setServerParams — Cambia parámetros del servidor y estado en tiempo de ejecucción
  • Funciones de Memcache
    • memcache_debug — Activa/desactiva debug output


Introducción

El módulo de Memcache proporciona acceso a un altamente efectivo demonio caché a través de una interfaz por procedimientos u orientada a objetos, que fué especialmente diseñada para disminuir la carga en base de datos en páginas web dinámicas.

El módulo de memcache también proporciona un gestor de sessiones (memcache).

Más información de memcache puede encontrarse en » http://www.memcached.org/.


Requerimientos

Este módulo utiliza funciones de » zlib para soportar compresión de datos al momento. Se require Zlib para instalar este módulo.

Se requiere PHP 4.3.3 o superior para utilizar la extensión de memcache.


Instalación

Esta extensión » PECL no se distribuye con PHP. Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/memcache.

Nota:

Es posible desactivar el gestor de sesiones memcache. La opción 'pecl install' pregunta por esta opción (por defecto está activada) de todas formas cuando se compila estáticamente en PHP se puede utilizar la opción de configuración --disable-memcache-session.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Memcache
Nombre | Por defecto | Cambiable | Historial de cambios
memcache.allow_failover | "1" | PHP_INI_ALL | Disponible desde memcache 2.0.2.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | Disponible desde memcache 2.1.0.
memcache.chunk_size | "8192" | PHP_INI_ALL | Disponible desde memcache 2.0.2.
memcache.default_port | "11211" | PHP_INI_ALL | Disponible desde memcache 2.0.2.
memcache.hash_strategy | "standard" | PHP_INI_ALL | Disponible desde memcache 2.2.0.
memcache.hash_function | "crc32" | PHP_INI_ALL | Disponible desde memcache 2.2.0.
session.save_handler | "files" | PHP_INI_ALL | Soportado desde memcache 2.1.2
session.save_path | "" | PHP_INI_ALL | Soportado desde memcache 2.1.2
memcache.protocol | ascii | >PHP_INI_ALL | Soportado desde memcache 3.0.0
memcache.redundancy | 1 | >PHP_INI_ALL | Soportado desde memcache 3.0.0
memcache.session_redundancy | 2 | >PHP_INI_ALL | Soportado desde memcache 3.0.0
memcache.compress_threshold | 20000 | >PHP_INI_ALL | Soportado desde memcache 3.0.3
memcache.lock_timeout | 15 | >PHP_INI_ALL | Soportado desde memcache 3.0.4
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

memcache.allow_failover boolean

Si se quiere hacer visible los failover en otros servidores en caso de errores.

memcache.max_failover_attempts integer

Define el número de servidores a probar cuando se añade y se obtiene información. Úsese solamente en conjunción con memcache.allow_failover.

memcache.chunk_size integer

La información será transferida en bloques del tamaño indicado, definir este valor a un número más pequeño requerirá más escrituras de red. Pruebe de incrementar este valor a 32768 si se nota una lentitud inexplicable.

memcache.default_port string

El puerto TCP por defecto a usar cuando se conecta a el servidor memcached si no se especifica otro puerto.

memcache.hash_strategy string

Controla el tipo de estrategia a usar cuando se mapean claves en los servidores. Definir este valor como consistent para habilitar hashing consistente que permite a los servidores ser añadidos o eliminados del grupo sin causar que las claves sean remapeadas. Si se define este valor como standard se usará la antigua estrategia.

memcache.hash_function string

Controla que tipo de función hash se utiliza cuando se mapean claves a los servidores, crc32 utiliza el stándar hash CRC32 hash mientras que fnv utiliza FNV-1a.

session.save_handler string

Si define esta opción como memcache podrá usar memcache como manejador de sesiones.

session.save_path string

Define una lista de urls de servidores separados por comas para el almacenamiento de sesiones, por ejemplo "tcp://host1:11211, tcp://host2:11211".

Cada url puede contener parámetros que son aplicados al servidor, son los mismos que en el método Memcache::addServer(). Por ejemplo "tcp://host1:11211?persistent=1&weight=1&timeout=1&retry_interval=15"

memcache.protocol string

memcache.redundancy integer

memcache.session_redundancy integer

memcache.compress_threshold integer

memcache.lock_timeout integer


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

There is only one resource type used in memcache module - it's the link identifier for a cache server connection.


Constantes predefinidas

Constantes Memcache
Nombre | Descripción
MEMCACHE_COMPRESSED (integer) | Sirve para activar compresión de datos al vuelo con Memcache::set(), Memcache::add() y Memcache::replace().
MEMCACHE_HAVE_SESSION (integer) | 1 si el gestor de sesiones de Memcache está disponible, 0 si no.
MEMCACHE_USER1 (integer) | Sirve para activar la bandera de aplicación definida por el usuario con Memcache::set(), Memcache::add() y Memcache::replace().
MEMCACHE_USER2 (integer) | Sirve para activar la bandera de aplicación definida por el usuario con Memcache::set(), Memcache::add() y Memcache::replace().
MEMCACHE_USER3 (integer) | Sirve para activar la bandera de aplicación definida por el usuario con Memcache::set(), Memcache::add() y Memcache::replace().
MEMCACHE_USER4 (integer) | Sirve para activar la bandera de aplicación definida por el usuario con Memcache::set(), Memcache::add() y Memcache::replace().


  • « Constantes predefinidas
  • Uso básico »
  • PHP Manual
  • Memcache
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico


Uso básico

Ejemplo #1 Ejemplos de la extensión memcache extension

En este ejemplo, se guarda un objeto en cache y luego se devuelve de nuevo. Objetos y otros tipos no escalares se serializan antes de guardarse, por lo tanto es imposible guardar recursos. (ej. identificadores de conexión y otros tipos) en caché.

<?php

$memcache = new Memcache;
$memcache->connect('localhost', 11211) or die ("No se pudo contectar");

$version = $memcache->getVersion();
echo "Versión del servidor: ".$version."<br/>\n";

$tmp_object = new stdClass;
$tmp_object->str_attr = 'test';
$tmp_object->int_attr = 123;

$memcache->set('key', $tmp_object, false, 10) or die ("Falló al intentar guardar datos en el servidor");
echo "Guarda datos en caché (los datos expirarán en 10 segundos)<br/>\n";

$get_result = $memcache->get('key');
echo "Datos desde la caché:<br/>\n";

var_dump($get_result);

?>

Ejemplo #2 Usando el gestor de sesiones de memcache

<?php

$session_save_path = "tcp://$host:$port?persistent=1&weight=2&timeout=2&retry_interval=10,  ,tcp://$host:$port  ";
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', $session_save_path);

?>


La clase Memcache

(PECL memcache >= 0.2.0)

Introducción

Representa una conexión a un conjunto de servidores memcache.

Sinopsis de la Clase

Memcache {
add ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
addServer ( string $host , int $port = 11211 , bool $persistent = ? , int $weight = ? , int $timeout = ? , int $retry_interval = ? , bool $status = ? , callable $failure_callback = ? , int $timeoutms = ? ) : bool
close ( ) : bool
connect ( string $host , int $port = ? , int $timeout = ? ) : bool
decrement ( string $key , int $value = 1 ) : int
delete ( string $key , int $timeout = 0 ) : bool
flush ( ) : bool
get ( string $key , int &$flags = ? ) : string
getExtendedStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array
getServerStatus ( string $host , int $port = 11211 ) : int
getStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array
getVersion ( ) : string
increment ( string $key , int $value = 1 ) : int
pconnect ( string $host , int $port = ? , int $timeout = ? ) : mixed
replace ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
set ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
setCompressThreshold ( int $threshold , float $min_savings = ? ) : bool
setServerParams ( string $host , int $port = 11211 , int $timeout = ? , int $retry_interval = false , bool $status = ? , callable $failure_callback = ? ) : bool
}

Tabla de contenidos

  • Memcache::add — Añadir un valor en el servidor
  • Memcache::addServer — Añadir servidor memcache al grupo de conexiones
  • Memcache::close — Cierra la conexión al servidor memcached
  • Memcache::connect — Abre una conexión al servidor memcached
  • Memcache::decrement — Decrementa numéricamente un valor
  • Memcache::delete — Elimina un valor del servidor
  • Memcache::flush — Limpia todos los valores existentes en el servidor
  • Memcache::get — Obtener valor del servidor
  • Memcache::getExtendedStats — Obtener estadísticas de todos los servidores en el grupo
  • Memcache::getServerStatus — Devuelve el estado del servidor
  • Memcache::getStats — Obtiene estadísticas del servidor
  • Memcache::getVersion — Devuelve la versión del servidor
  • Memcache::increment — Incrementa numéricamente un valor
  • Memcache::pconnect — Abre una conexión persistente a memcached
  • Memcache::replace — Reemplaza el valor de un valor existente
  • Memcache::set — Guarda datos en el servidor
  • Memcache::setCompressThreshold — Activa compresión automática de valores con datos largos
  • Memcache::setServerParams — Cambia parámetros del servidor y estado en tiempo de ejecucción


Añadir un valor en el servidor

  • « Memcache
  • Memcache::addServer »
  • PHP Manual
  • Memcache
  • Añadir un valor en el servidor

Memcache::add

(PECL memcache >= 0.2.0)

Memcache::add — Añadir un valor en el servidor

Descripción

Memcache::add ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::add() guarda la variable var con la clave key solamente si la clave no existe todavía en el servidor. También se puede usar la función memcache_add().

Parámetros

key

La clave que quedará asociada con el valor.

var

La variable a guardar. Cadenas y enteros se guardan tal y como son, otros tipos se guardan serializados.

flag

Use MEMCACHE_COMPRESSED para guardar datos comprimidos (usa zlib).

expire

Tiempo de expiración del valor. Si es iqual a cero, el valor nunca expirará. También puedes usar Unix timestamp o el número de segundos empezando desde la fecha actual, el valor no puede exceder de 2592000 segundos (30 días).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Devuelve false si la clave ya existe. Por el resto Memcache::add() se comporta similar a Memcache::set().

Ejemplos

Ejemplo #1 Ejemplo Memcache::add()

<?php

$memcache_obj = memcache_connect("localhost", 11211);

/* procedural API */
memcache_add($memcache_obj, 'var_key', 'test variable', false, 30);

/* OO API */
$memcache_obj->add('var_key', 'test variable', false, 30);

?>

Ver también

  • Memcache::set() - Guarda datos en el servidor
  • Memcache::replace() - Reemplaza el valor de un valor existente


Añadir servidor memcache al grupo de conexiones

  • « Memcache::add
  • Memcache::close »
  • PHP Manual
  • Memcache
  • Añadir servidor memcache al grupo de conexiones

Memcache::addServer

(PECL memcache >= 2.0.0)

Memcache::addServer — Añadir servidor memcache al grupo de conexiones

Descripción

Memcache::addServer ( string $host , int $port = 11211 , bool $persistent = ? , int $weight = ? , int $timeout = ? , int $retry_interval = ? , bool $status = ? , callable $failure_callback = ? , int $timeoutms = ? ) : bool

Memcache::addServer() añade un servidor al grupo de conexiones. También se puede usar la función memcache_add_server().

Cuando se usa este método (opuestamente a Memcache::connect() y Memcache::pconnect()) la conexión no se establece hasta que es necesaria. De esta forma no hay sobrecarga al añadir un gran número de servidores en el grupo de conexiones, aunque no todos van a ser utilizados.

La conexión puede caer en cualquier momento usando cualquiera de los métodos, mientras otros servidores estén disponibles para hacer la petición el usuario no notará nada. Cualquier tipo de errores de socket o servidor Memcached (excepto out-of-memory) seguramente harán caer la conexión. Errores en el cliente como añadir una llave que ya existe no provocará la caida de la conexión.

Nota:

Esta función fué añadida en Memcache versión 2.0.0.

Parámetros

host

Apunta al host donde memcached está esperando conexiones. Este parámetro también se puede especificar con otros transportes como unix:///path/to/memcached.sock para usar domain UNIX sockets, en este caso port debe también establecerse a 0.

port

Apunta al puerto donde memcache está esperando para conexiones. Establece este parámetro a 0 cuando se usan UNIX domain sockets.

Por favor note: port será por defecto memcache.default_port en caso de no especificarse. Por esta razón, se recomienda especificar el puerto explícitamente en la llamada a este método.

persistent

Controla el uso de una conexión persistente. Por defecto true.

weight

Número de segmentos para crear de este servidor, que a su vez controlan la probabilidad de que sea seleccionado. La probabilidad es relativa a la de peso total de todos los servidores.

timeout

Valor en segundos que se utilizará para conectar con el demonio. Piense dos veces antes de cambiar el valor predeterminado de 1 segundo - se puede perder todas las ventajas de la caché si su conexión es demasiado lenta.

retry_interval

Controla la frecuencia de reintentos cuando falla la conexión, el valor por defecto es 15 segundos. Si establece este parámetro a -1 desactivará el reintento automático. Ni esta opción ni el parámetro persistent tienen ningún efecto cuando la extensión se carga dinámicamente a través de dl().

Cada conexión struct fallida tiene su propio timeout y antes de que caduque, el struct será omitido cuando se selecionen backends para servir una petición.Cuando caduque la conexión se reconectará satisfactoriamente o se marcará como fallida por otros retry_interval segundos. El típico efecto es que cada servidor web hijo reintentará la conexión cada retry_interval cuando se sirven páginas.

status

Controla si el servidor debe ser marcado como online. Estableciendo este parámetro a false y retry_interval a -1 permite a un servidor que falle a ser mantenido en el grupo para no afectar el algoritmo de distribución de llaves. Las peticiones a este servidor fallarán inmediatamente dependiendo en la opción memcache.allow_failover. Por defecto to true, que significa que el servidor se considera online.

failure_callback

Permite al usuario a especificar la llamada a una función de retorno a ejectuar cuando se encuentre un error. La llamada de retorno se ejecuta antes de que se produzca la caída en la conexión. La función toma dos parámetros, el hostname y el puerto del puerto que ha fallado.

timeoutms

Notas

Advertencia

Cuando no se especifica port, este método usará el valor establecido en la directiva ini memcache.default_port de PHP. Si este valor se cambiara en cualquier lugar de la aplicación podría conducir a resultados inesperados; por esta razón, es prudente especificar el puerto explícitamente en la llamada a este método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo Memcache::addServer()

<?php

/* OO API */

$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
$memcache->addServer('memcache_host2', 11211);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_add_server($memcache_obj, 'memcache_host2', 11211);

?>

Ver también

  • Memcache::connect() - Abre una conexión al servidor memcached
  • Memcache::pconnect() - Abre una conexión persistente a memcached
  • Memcache::close() - Cierra la conexión al servidor memcached
  • Memcache::setServerParams() - Cambia parámetros del servidor y estado en tiempo de ejecucción
  • Memcache::getServerStatus() - Devuelve el estado del servidor


Cierra la conexión al servidor memcached

  • « Memcache::addServer
  • Memcache::connect »
  • PHP Manual
  • Memcache
  • Cierra la conexión al servidor memcached

Memcache::close

(PECL memcache >= 0.4.0)

Memcache::close — Cierra la conexión al servidor memcached

Descripción

Memcache::close ( ) : bool

Memcache::close() cierra la conexión al servidor memcached. Esta función no cierra conexiones persistentes, que solo son cerradas durante apagado/reinicio del servidor web. También se puede usar la función memcache_close().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo Memcache::close()

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/*
Algo aquí ....
*/
memcache_close($memcache_obj);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/*
Algo aquí..
*/
$memcache_obj->close();

?>

Ver también

  • Memcache::connect() - Abre una conexión al servidor memcached
  • Memcache::pconnect() - Abre una conexión persistente a memcached


Abre una conexión al servidor memcached

  • « Memcache::close
  • Memcache::decrement »
  • PHP Manual
  • Memcache
  • Abre una conexión al servidor memcached

Memcache::connect

(PECL memcache >= 0.2.0)

Memcache::connect — Abre una conexión al servidor memcached

Descripción

Memcache::connect ( string $host , int $port = ? , int $timeout = ? ) : bool

Memcache::connect() establece una conexión al servidor memcached. La conexión, que fue abierta usando Memcache::connect() será automáticamente cerrada al finalizar la ejecucción del script. También se puede cerrar con Memcache::close(). También puede usar la función memcache_connect().

Parámetros

host

El host donde el memcached está esperando conexiones. En este parámetro también se puede especificar otros transporte como unix:///path/to/memcached.sock para usar UNIX domain sockets. En este caso port debe ser establecido a 0.

port

El puerto donde memcached está esperando conexiones. Establezca este parámetro a 0 cuando se usan UNIX domain sockets.

Por favor note: port será por defecto memcache.default_port en caso de no especificarse. Por esta razón, se recomienda especificar el puerto explícitamente en la llamada a este método.

timeout

Valor en segundos que se utilizarán para conectarse al demonio. Piensa dos veces antes de cambiar el valor por defecto de 1 segundo, puedes perder todas la ventajas del caché si tus conexiones son muy lentas.

Notas

Advertencia

Cuando no se especifica port, este método usará el valor establecido en la directiva ini memcache.default_port de PHP. Si este valor se cambiara en cualquier lugar de la aplicación podría conducir a resultados inesperados; por esta razón, es prudente especificar el puerto explícitamente en la llamada a este método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Memcache::connect() example

<?php

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);

/* OO API */

$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);

?>

Ver también

  • Memcache::pconnect() - Abre una conexión persistente a memcached
  • Memcache::close() - Cierra la conexión al servidor memcached


Decrementa numéricamente un valor

  • « Memcache::connect
  • Memcache::delete »
  • PHP Manual
  • Memcache
  • Decrementa numéricamente un valor

Memcache::decrement

(PECL memcache >= 0.2.0)

Memcache::decrement — Decrementa numéricamente un valor

Descripción

Memcache::decrement ( string $key , int $value = 1 ) : int

Memcache::decrement() decrementa numéricamente el valor según el value. Es similar a Memcache::increment(), después de que el value sea extraído el valor es convertido a numérico.

Nota:

El nuevo valor del objecto no será inferior a cero.

Nota:

No use Memcache::decrement() en un valor, que fué guardado con compresión, porque en este caso Memcache::get() no funcionará.

Memcache::decrement() no genera un valor si no existía previamente. También se puede usar la función memcache_decrement().

Parámetros

key

Clave del valor a decrementar.

value

Decrementar el valor según el value.

Valores devueltos

Devuelve el nuevo valor éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo Memcache::decrement()

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* decrement item by 2 */
$new_value = memcache_decrement($memcache_obj, 'test_item', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* decrement item by 3 */
$new_value = $memcache_obj->decrement('test_item', 3);
?>

Ver también

  • Memcache::increment() - Incrementa numéricamente un valor
  • Memcache::replace() - Reemplaza el valor de un valor existente


Elimina un valor del servidor

  • « Memcache::decrement
  • Memcache::flush »
  • PHP Manual
  • Memcache
  • Elimina un valor del servidor

Memcache::delete

(PECL memcache >= 0.2.0)

Memcache::delete — Elimina un valor del servidor

Descripción

Memcache::delete ( string $key , int $timeout = 0 ) : bool

Memcache::delete() elimina el valor según la clave key.

Parámetros

key

La clave asociada con el valor a eliminar.

timeout

Este parámetro ya no está soportado, y su valor por omisión es 0 segundos. No se debe usar este parámetro.

Historial de cambios

Versión | Descripción
Desconocido | No se recomienda utilizar el parámetro timeout. Su comportamiento no es consistente entre las versiones de memcached, pero sí es seguro utilizar 0. El uso de otros valores puede provocar que la función delete de memcache falle.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::delete()

<?php

/* API por procedimientos */
$memcache_obj = memcache_connect('memcache_host', 11211);

/* el valor será eliminado por el servidor */
memcache_delete($memcache_obj, 'key_to_delete');

/* API OO */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->delete('key_to_delete');

?>

Ver también

  • Memcache::set() - Guarda datos en el servidor
  • Memcache::replace() - Reemplaza el valor de un valor existente


Limpia todos los valores existentes en el servidor

  • « Memcache::delete
  • Memcache::get »
  • PHP Manual
  • Memcache
  • Limpia todos los valores existentes en el servidor

Memcache::flush

(PECL memcache >= 1.0.0)

Memcache::flush — Limpia todos los valores existentes en el servidor

Descripción

Memcache::flush ( ) : bool

Memcache::flush() invalida inmediatamente todos los valores existentes. Memcache::flush() no libera recursos del sistema, solamente marca los valores como expirados, la memoria que ahora se ocupa será sobreescrita por los nuevos valores. También se puede usar la función memcache_flush().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::flush()

<?php

/* API por procedimientos */
$memcache_obj = memcache_connect('memcache_host', 11211);

memcache_flush($memcache_obj);

/* API OO */

$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->flush();

?>


Obtener valor del servidor

  • « Memcache::flush
  • Memcache::getExtendedStats »
  • PHP Manual
  • Memcache
  • Obtener valor del servidor

Memcache::get

(PECL memcache >= 0.2.0)

Memcache::get — Obtener valor del servidor

Descripción

Memcache::get ( string $key , int &$flags = ? ) : string
Memcache::get ( array $keys , array &$flags = ? ) : array

Memcache::get() devuelve los datos previamente almacenados si el valor con la key existe en el servidor en este momento.

Se puede pasar un array de llaves a Memcache::get() para obtener un array de valores. El resultado del array contendrá solamente las parejas llave-valor encontradas.

Parámetros

key

La llave o array de llaves a capturar.

flags

Si está presente, las flags capturadas juntamente con los valores serán escritas en este parámetro. Estas flags son las mismas que las dadas por ejemplo en Memcache::set(). El byte más bajo del entero está reservado para uso interno de pecl/memcache (ej. para estado de compresión y serialización).

Valores devueltos

Devuelve la cadena asociada con la clave dada por key o un array de pares clave-valor cuando key es un array. Devuelve false en caso de error, key no se encuentra, o key es un array vacío.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::get()

<?php

/* API por procedimientos */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, 'some_key');

/* API OO */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get('some_key');

/*
También se puede usar array de keys como parámetro.
Si el valor no fue encontrado en el servidor, el
resultado del array simplemente no contendrá dicha
clave.
*/

/* API por procedimientos */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, Array('some_key', 'another_key'));

/* API OO */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get(Array('some_key', 'second_key'));

?>


Obtener estadísticas de todos los servidores en el grupo

  • « Memcache::get
  • Memcache::getServerStatus »
  • PHP Manual
  • Memcache
  • Obtener estadísticas de todos los servidores en el grupo

Memcache::getExtendedStats

(PECL memcache >= 2.0.0)

Memcache::getExtendedStats — Obtener estadísticas de todos los servidores en el grupo

Descripción

Memcache::getExtendedStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array

Memcache::getExtendedStats() devuelve un array asociativo de dos dimensiones con estadísticas del servidor(es). Las llaves del array corresponden al servidor:puerto y los valores contienen las estadísticas de cada servidor. En caso de error el servidor tendrá su correspondiente entrada asignada a false. También puede usar la función memcache_get_extended_stats().

Nota:

Esta función fue añadida en la versión 2.0.0. de Memcache.

Parámetros

type

Tipo de estadísticas a capturar. Valores válidos son {reset, malloc, maps, cachedump, slabs, items, sizes}. Según la especificación del protocolo de memcached estos son los argumentos adicionales "pueden estar sujetos a cambios por conveniencia de los desarrolladores de memcache".

slabid

Usado en conjunto con cachedump en el type para identificar el slap desde donde volcar. El comando cachedump va en conjunto con el servidor y debe ser usado estrictamente para propósitos de depuración.

limit

Usado en conjunto con cachedump en el type para limitar el número de entradas a volcar.

Advertencia

El tipo cachedump stat ha sido eliminado del demonio memcached por razones de seguridad.

Valores devueltos

Devuelve un array asociativo de dos dimensiones con las estadísticas o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::getExtendedStats()

<?php
    $memcache_obj = new Memcache;
    $memcache_obj->addServer('memcache_host', 11211);
    $memcache_obj->addServer('failed_host', 11211);

    $stats = $memcache_obj->getExtendedStats();
    print_r($stats);
?>

El resultado del ejemplo sería:

Array
(
    [memcache_host:11211] => Array
        (
            [pid] => 3756
            [uptime] => 603011
            [time] => 1133810435
            [version] => 1.1.12
            [rusage_user] => 0.451931
            [rusage_system] => 0.634903
            [curr_items] => 2483
            [total_items] => 3079
            [bytes] => 2718136
            [curr_connections] => 2
            [total_connections] => 807
            [connection_structures] => 13
            [cmd_get] => 9748
            [cmd_set] => 3096
            [get_hits] => 5976
            [get_misses] => 3772
            [bytes_read] => 3448968
            [bytes_written] => 2318883
            [limit_maxbytes] => 33554432
        )

    [failed_host:11211] => false
)

Ver también

  • Memcache::getVersion() - Devuelve la versión del servidor
  • Memcache::getStats() - Obtiene estadísticas del servidor


Devuelve el estado del servidor

  • « Memcache::getExtendedStats
  • Memcache::getStats »
  • PHP Manual
  • Memcache
  • Devuelve el estado del servidor

Memcache::getServerStatus

(PECL memcache >= 2.1.0)

Memcache::getServerStatus — Devuelve el estado del servidor

Descripción

Memcache::getServerStatus ( string $host , int $port = 11211 ) : int

Memcache::getServerStatus() devuelve el estado online/offline del servidor. También se puede usar la función memcache_get_server_status().

Nota:

Esta función fue añadida en la versión 2.1.0. de Memcache.

Parámetros

host

Apunta al servidor donde memcached está esperando conexiones.

port

Apunta al puerto donde mecached está esperando conexiones.

Valores devueltos

Devuelve el estado del servidor. 0 si el servidor devolvió un error, de lo contrario no devolverá cero.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::getServerStatus()

<?php

/* API OO */
$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
echo $memcache->getServerStatus('memcache_host', 11211);

/* API por procedimientos */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_server_status($memcache, 'memcache_host', 11211);

?>

Ver también

  • Memcache::addServer() - Añadir servidor memcache al grupo de conexiones
  • Memcache::setServerParams() - Cambia parámetros del servidor y estado en tiempo de ejecucción


Obtiene estadísticas del servidor

  • « Memcache::getServerStatus
  • Memcache::getVersion »
  • PHP Manual
  • Memcache
  • Obtiene estadísticas del servidor

Memcache::getStats

(PECL memcache >= 0.2.0)

Memcache::getStats — Obtiene estadísticas del servidor

Descripción

Memcache::getStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array

Memcache::getStats() devuelve un array asociativo con las estadísticas del servidor. Las llaves del array corresponden a los parámetros de las estadísticas y los valores a los valores de los parámetros. También se puede usar la función memcache_get_stats().

Parámetros

type

Tipo de estadísticas a capturar. Valores válidos son {reset, malloc, maps, cachedump, slabs, items, sizes}. Según la especificación del protocolo de memcached estos son los argumentos adicionales "pueden estar sujetos a cambios por conveniencia de los desarrolladores de memcache".

slabid

Usado en conjunto con cachedump en el type para identificar el slap desde donde volcar. El comando cachedump va en conjunto con el servidor y debe ser usado estrictamente para propósitos de depuración.

limit

Usado en conjunto con cachedump en el type para limitar el número de entradas a volcar.

Valores devueltos

Devuelve un array asociativo con las estadísticas del servidor o false en caso de error.

Ver también

  • Memcache::getVersion() - Devuelve la versión del servidor
  • Memcache::getExtendedStats() - Obtener estadísticas de todos los servidores en el grupo


Devuelve la versión del servidor

  • « Memcache::getStats
  • Memcache::increment »
  • PHP Manual
  • Memcache
  • Devuelve la versión del servidor

Memcache::getVersion

(PECL memcache >= 0.2.0)

Memcache::getVersion — Devuelve la versión del servidor

Descripción

Memcache::getVersion ( ) : string

Memcache::getVersion() devuelve una cadena con el número de la versión del servidor. También puede usar la función memcache_get_version().

Valores devueltos

Devuelve una cadena con el número de la versión del servidor o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::getVersion()

<?php

/* API OO */
$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);
echo $memcache->getVersion();

/* API por procedimientos */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_version($memcache);

?>

Ver también

  • Memcache::getExtendedStats() - Obtener estadísticas de todos los servidores en el grupo
  • Memcache::getStats() - Obtiene estadísticas del servidor


Incrementa numéricamente un valor

  • « Memcache::getVersion
  • Memcache::pconnect »
  • PHP Manual
  • Memcache
  • Incrementa numéricamente un valor

Memcache::increment

(PECL memcache >= 0.2.0)

Memcache::increment — Incrementa numéricamente un valor

Descripción

Memcache::increment ( string $key , int $value = 1 ) : int

Memcache::increment() incrementa el valor según el value. Si el valor con la key no es numérico y no se puede convertir a número, cambiará su valor a value. Memcache::increment() no creará el valor si no existe.

Nota:

No use Memcache::increment() en un valor, que fué guardado con compresión, porque en este caso Memcache::get() no funcionará.

También se puede usar la función memcache_increment().

Parámetros

key

Clave del valor a incrementar.

value

Incrementar el valor por value.

Valores devueltos

Devuelve el nuevo valor en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::increment()

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* increment counter by 2 */
$current_value = memcache_increment($memcache_obj, 'counter', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* increment counter by 3 */
$current_value = $memcache_obj->increment('counter', 3);

?>

Ver también

  • Memcache::decrement() - Decrementa numéricamente un valor
  • Memcache::replace() - Reemplaza el valor de un valor existente


Abre una conexión persistente a memcached

  • « Memcache::increment
  • Memcache::replace »
  • PHP Manual
  • Memcache
  • Abre una conexión persistente a memcached

Memcache::pconnect

(PECL memcache >= 0.4.0)

Memcache::pconnect — Abre una conexión persistente a memcached

Descripción

Memcache::pconnect ( string $host , int $port = ? , int $timeout = ? ) : mixed

Memcache::pconnect() es similar a Memcache::connect() con la diferencia que la conexión que establece es persistente. La conexión no se cierra al finalizar el script o usando la función Memcache::close(). También se puede usar la función memcache_pconnect().

Parámetros

host

Apunta al host donde memcache está esperando conexiones. En este parámetro quizá puede especificar otros transportes como unix:///path/to/memcached.sock para usar UNIX domain sockets, en este caso. port debe establecerse a 0.

port

Apunta al puerto donde memcache está esperando conexiones. Estableza este parámetro a 0 cuando se use UNIX domain sockets.

timeout

Valor en segundos que serán usandos para conectar al demonio. Piénselo dos veces antes de cambiar el valor por defecto a 1 segundo. Se pueden perder todas las ventajas del caché si la conexión es muy lenta.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::pconnect()

<?php

/* API por procedimientos */
$memcache_obj = memcache_pconnect('memcache_host', 11211);

/* API OO  */

$memcache_obj = new Memcache;
$memcache_obj->pconnect('memcache_host', 11211);

?>

Ver también

  • Memcache::connect() - Abre una conexión al servidor memcached


Reemplaza el valor de un valor existente

  • « Memcache::pconnect
  • Memcache::set »
  • PHP Manual
  • Memcache
  • Reemplaza el valor de un valor existente

Memcache::replace

(PECL memcache >= 0.2.0)

Memcache::replace — Reemplaza el valor de un valor existente

Descripción

Memcache::replace ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::replace() debe ser usado para reemplazar el valor de un valor existente en una key determinada. En caso que la llave no exista, Memcache::replace() devolverá false. Por lo demás Memcache::replace() funciona similar a Memcache::set(). También se puede usar la función memcache_replace().

Parámetros

key

La clave que será asociada con el valor.

var

La variable a guardar. Cadenas y enteros son guardados tal y como son, otros tipos son guardados de forma serializada.

flag

Utilice MEMCACHE_COMPRESSED para guardar el valor de forma comprimida (utiliza zlib).

expire

Tiempo de expiración del valor. Si es igual a cero, el valor nunca expirará. También se puede usar Unix timestamp o el número de segundos empezando desde de hora actual, pero como máximo el número de segundos no debe exceder de 2592000 (30 días).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::replace()

<?php

$memcache_obj = memcache_connect('memcache_host', 11211);

/* API por procedimientos */
memcache_replace($memcache_obj, "test_key", "some variable", false, 30);

/* API OO */
$memcache_obj->replace("test_key", "some variable", false, 30);

?>

Ver también

  • Memcache::set() - Guarda datos en el servidor
  • Memcache::add() - Añadir un valor en el servidor


Guarda datos en el servidor

  • « Memcache::replace
  • Memcache::setCompressThreshold »
  • PHP Manual
  • Memcache
  • Guarda datos en el servidor

Memcache::set

(PECL memcache >= 0.2.0)

Memcache::set — Guarda datos en el servidor

Descripción

Memcache::set ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::set() guarda un valor var con una key en el servidor memcached. El parámetro expire es el tiempo de expiración en segundos. Si es 0, el valor nunca expira (pero el servidor memcached no garantiza que este valor será guardado para siempre, puede ser eliminado de la caché para hacer espacio para otros valores). Se puede usar la constante MEMCACHE_COMPRESSED en el valor del flag si quiere utilizar compresión al momento (usando zlib).

Nota:

Recuerde que variables de recursos (ej. ficheros y descriptores de conexiones) no pueden guardarse en caché, porque no pueden ser representados adecuadamente de forma serializada.

También se puede usar la función memcache_set().

Parámetros

key

La clave que quedará asociada con el valor.

var

La variable a guardar. Cadenas y enteros se guardan tal y como son, otros tipos se guardan serializados.

flag

Use MEMCACHE_COMPRESSED para guardar datos comprimidos (usa zlib).

expire

Tiempo de expiración del valor. Si es iqual a cero, el valor nunca expirará. También puedes usar Unix timestamp o el número de segundos empezando desde la fecha actual, el valor no puede exceder de 2592000 segundos (30 días).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::set()

<?php
/* API por procedimientos */

/* Conectar al servidor memcached */
$memcache_obj = memcache_connect('memcache_host', 11211);

/*
Establecer el valor según la key 'var_key'
usando 0 como valor del flag, no será usada compresión
el tiempo de expiración es de 30 segundos
*/
memcache_set($memcache_obj, 'var_key', 'some variable', 0, 30);

echo memcache_get($memcache_obj, 'var_key');

?>

Ejemplo #2 Ejemplo de Memcache::set()

<?php
/* API OO */

$memcache_obj = new Memcache;

/* connect to memcached server */
$memcache_obj->connect('memcache_host', 11211);

/*
Establece el valor según la llave 'var_key', usando compresión al momento
expira en 50 segundos
*/
$memcache_obj->set('var_key', 'some really big variable', MEMCACHE_COMPRESSED, 50);

echo $memcache_obj->get('var_key');

?>

Ver también

  • Memcache::add() - Añadir un valor en el servidor
  • Memcache::replace() - Reemplaza el valor de un valor existente


Activa compresión automática de valores con datos largos

  • « Memcache::set
  • Memcache::setServerParams »
  • PHP Manual
  • Memcache
  • Activa compresión automática de valores con datos largos

Memcache::setCompressThreshold

(PECL memcache >= 2.0.0)

Memcache::setCompressThreshold — Activa compresión automática de valores con datos largos

Descripción

Memcache::setCompressThreshold ( int $threshold , float $min_savings = ? ) : bool

Memcache::setCompressThreshold() activa compresión automática de valores largos. También se puede usar la función memcache_set_compress_threshold().

Nota:

Esta función fue añadida en la versión 2.0.0. de Memcache.

Parámetros

threshold

Controla la longitud valor mínimo antes de intentar comprimir automáticamente.

min_saving

Especifica la cantidad mínima del ratio de compresión para guardar el valor. El valor debe ser entre 0 y 1. Por defecto es de 0,2 un mínimo de 20% de ratio de compresión.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::setCompressThreshold()

<?php

/* API OO */

$memcache_obj = new Memcache;
$memcache_obj->addServer('memcache_host', 11211);
$memcache_obj->setCompressThreshold(20000, 0.2);

/* API por procedimientos */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_compress_threshold($memcache_obj, 20000, 0.2);

?>


Cambia parámetros del servidor y estado en tiempo de ejecucción

  • « Memcache::setCompressThreshold
  • Funciones de Memcache »
  • PHP Manual
  • Memcache
  • Cambia parámetros del servidor y estado en tiempo de ejecucción

Memcache::setServerParams

(PECL memcache >= 2.1.0)

Memcache::setServerParams — Cambia parámetros del servidor y estado en tiempo de ejecucción

Descripción

Memcache::setServerParams ( string $host , int $port = 11211 , int $timeout = ? , int $retry_interval = false , bool $status = ? , callable $failure_callback = ? ) : bool

Memcache::setServerParams() cambia parámetros del servidor en tiempo de ejecucción. También se puede usar la función memcache_set_server_params().

Nota:

Esta función fue añadida en la versión 2.1.0. de Memcache.

Parámetros

host

Apunta al host donde memcached está esperando conexiones.

port

Apunta al puerto donde memcached está esperando conexiones.

timeout

Valor en segundos que se utilizarán para conectarse al demonio. Piensa dos veces antes de cambiar el valor por defecto de 1 segundo, puedes perder todas la ventajas del caché si tus conexiones son muy lentas.

retry_interval

Controla la frecuencia de reintentos cuando falla la conexión, el valor por defecto es 15 segundos. Si establece este parámetro a -1 desactivará el reintento automático. Ni esta opción ni el parámetro persistent tienen ningún efecto cuando la extensión se carga dinámicamente a través de dl().

status

Controla si el servidor debe ser marcado como online. Estableciendo este parámetro a false y retry_interval a -1 permite a un servidor que falle a ser mantenido en el grupo para no afectar el algoritmo de distribución de llaves. Las peticiones a este servidor fallarán inmediatamente dependiendo en la opción memcache.allow_failover. Por defecto to true, que significa que el servidor se considera online.

failure_callback

Permite al usuario a especificar la llamada a una función de retorno a ejectuar cuando se encuentre un error. La llamada de retorno se ejecuta antes de que se produzca la caída en la conexión. La función toma dos parámetros, el hostname y el puerto del puerto que ha fallado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcache::setServerParams()

<?php

function _callback_memcache_failure($host, $port) {
    print "memcache '$host:$port' failed";
}

/* API OO */

$memcache = new Memcache;

// Añadir servidor en modo offline.
$memcache->addServer('memcache_host', 11211, false, 1, 1, -1, false);

// Establecer el servidor de offline a online.
$memcache->setServerParams('memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

/* API por procedimientos */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_server_params($memcache_obj, 'memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

?>

Ver también

  • Memcache::addServer() - Añadir servidor memcache al grupo de conexiones
  • Memcache::getServerStatus() - Devuelve el estado del servidor


  • « Memcache::setServerParams
  • memcache_debug »
  • PHP Manual
  • Memcache
  • Funciones de Memcache

Funciones de Memcache

Tabla de contenidos

  • memcache_debug — Activa/desactiva debug output


Activa/desactiva debug output

  • « Funciones de Memcache
  • Memcached »
  • PHP Manual
  • Funciones de Memcache
  • Activa/desactiva debug output

memcache_debug

(PECL memcache >= 0.2.0)

memcache_debug — Activa/desactiva debug output

Descripción

memcache_debug ( bool $on_off ) : bool

memcache_debug() activa el debug output si el parámetro on_off es igual a true y lo desactiva si es igual a false.

Nota:

Solamente se puede acceder a memcache_debug() si PHP fue compilado con la opción --enable-debug y en este caso siempre retorna true. De lo contrario, esta función no tiene ningún efecto y siempre devuelve false.

Parámetros

on_off

Activa debug output si es igual a true. Desactiva debug output si es igual a false.

Valores devueltos

Devuelve true si PHP fue compilado con la opción --enable-debug, de lo contrario devuelve false.


Memcached

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Tiempos de expiración
  • Retrollamadas
    • Retrollamadas de resultados
    • Retrollamadas de caché de lectura previa
  • Soporte para sesiones
  • Memcached — La clase Memcached
    • Memcached::add — Añade un ítem asociado a una nueva clave
    • Memcached::addByKey — Añade un ítem asociado a una nueva clave en un servidor específico
    • Memcached::addServer — Añade un servidor a la provisión de servidores
    • Memcached::addServers — Añadir varios servidores a la agrupación de servidores
    • Memcached::append — Añadir datos a un ítem existente
    • Memcached::appendByKey — Añadir datos a un ítem existente en un servidor específico
    • Memcached::cas — Comparar e intercambiar un ítem
    • Memcached::casByKey — Comparar e intercambiar un ítem en un servidor específico
    • Memcached::__construct — Crear una instancia de Memcached
    • Memcached::decrement — Decrementar un valor numérico de un ítem
    • Memcached::decrementByKey — Decrementar un valor numérico de un ítem almacenado en un servidor específico
    • Memcached::delete — Eliminar un ítem
    • Memcached::deleteByKey — Eliminar un ítem de un servidor específico
    • Memcached::deleteMulti — Eliminar varios ítems
    • Memcached::deleteMultiByKey — Eliminar varios ítems de un servidor específico
    • Memcached::fetch — Obtener el siguiente resultado
    • Memcached::fetchAll — Obtener todos los resultados restantes
    • Memcached::flush — Invalidar todos los ítems de la caché
    • Memcached::get — Obtener un ítem
    • Memcached::getAllKeys — Obtiene las claves almacenadas en todos los servidores
    • Memcached::getByKey — Obtiene un ítem de un servidor específico
    • Memcached::getDelayed — Obtener varios ítems
    • Memcached::getDelayedByKey — Solicitar varios ítems de un servidor específico
    • Memcached::getMulti — Obtener varios ítems
    • Memcached::getMultiByKey — Recuperar varios ítems de un servidor específico
    • Memcached::getOption — Obtener el valor de una opción de Memcached
    • Memcached::getResultCode — Devuelve el código resultante de la última operación
    • Memcached::getResultMessage — Devolver un mensaje que describe el resultado de la última operación
    • Memcached::getServerByKey — Hacer corresponder una clave con un servidor
    • Memcached::getServerList — Obtener la lista de servidores de la agrupación
    • Memcached::getStats — Obtener las estadísticas de la agrupación de servidores
    • Memcached::getVersion — Obtener la información de la versión de la agrupación de servidores
    • Memcached::increment — Incrementar un valor numérico de un ítem
    • Memcached::incrementByKey — Incrementar un valor numérico de un ítem, almacenado en un servidor específico
    • Memcached::isPersistent — Comprueba si se está utilizando una conexión persistente a memcache
    • Memcached::isPristine — Comprobar si la instancia se creó recientemente
    • Memcached::prepend — Anteponer datos a un ítem existente
    • Memcached::prependByKey — Anteponer datos a un ítem existente en un servidor específico
    • Memcached::quit — Cierra cualquier conexión abierta
    • Memcached::replace — Reemplaza un ítem asociado a una clave existente
    • Memcached::replaceByKey — Reemplazar un ítem bajo una clave existente en un servidor específico
    • Memcached::resetServerList — Limpia todos los servidores de la lista de servidores
    • Memcached::set — Guardar un ítem
    • Memcached::setByKey — Guardar un ítem en un servidor específico
    • Memcached::setMulti — Almacenar varios ítems
    • Memcached::setMultiByKey — Almacena varios ítems en un servidor específico
    • Memcached::setOption — Establecer una opción de Memcached
    • Memcached::setOptions — Establecer opciones de Memcached
    • Memcached::setSaslAuthData — Establecer las credenciales para la autenticación
    • Memcached::touch — Establecer una nueva expiración para un ítem
    • Memcached::touchByKey — Establecer una nueva expiración para un ítem de un servidor específico
  • MemcachedException — La clase MemcachedException


Introducción

» memcached es un sistema de alto rendimiento para el almacenamiento de objetos en caché de memoria distribuida, genérico por naturaleza, aunque pensado principalmente para acelerar aplicaciones web dinámicas aliviando la carga de bases de datos.

Esta extensión utiliza la biblioteca libmemcached para proveer una API de comunicación con servidores de memcached. También proporciona un gestor de sesiones (memcached).

Puede encontrarse más información acerca de libmemcached en » http://libmemcached.org/libMemcached.html.


Requerimientos

Esta extensión requiere la biblioteca cliente » libmemcached (versión 1.0.0 o posterior). Para el soporte de autenticación SASL, libmemcached debe estar construida con SASL habilitado.

Desde la versión 0.2.0, esta extensión requiere la versión 5.2.0 o superior de PHP.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/memcached.

Si libmemcached está instalada en una ubicación no estándar, use la opción --with-libmemcached-dir=DIR, siendo DIR el prefijo de instalación de libmemcached. Este directorio debe contener el fichero include/libmemcached/memcached.h.

Se requiere Zlib para el soporte de compresión. Para especificar una instalación no estándar de Zlib, use la opción --with-zlib-dir=DIR siendo DIR el prefijo de instalación de Zlib.

El soporte para el controlador de sesiones está activado de manera predeterminada. Para desactivarlo, use la opción --disable-memcached-session.

El soporte para la autenticación SASL está deshabilitado de forma predeterminada. Para habilitarlo, use la opción --enable-memcached-sasl. Esto requiere que haya sido instalada libsasl2 y que libmemcached haya sido construida con el soporte para SASL habilitado.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de Memcached
Nombre | Por defecto | Cambiable | Historial de cambios
memcached.sess_locking | 1 | PHP_INI_ALL |
memcached.sess_consistent_hash | 0 | PHP_INI_ALL |
memcached.sess_binary | 0 | PHP_INI_ALL |
memcached.sess_lock_wait | 150000 | PHP_INI_ALL |
memcached.sess_prefix | memc.sess.key. | PHP_INI_ALL |
memcached.sess_number_of_replicas | 0 | PHP_INI_ALL |
memcached.sess_randomize_replica_read | 0 | PHP_INI_ALL |
memcached.sess_remove_failed | 0 | PHP_INI_ALL |
memcached.compression_type | fastlz | PHP_INI_ALL |
memcached.compression_factor | 1.3 | PHP_INI_ALL |
memcached.compression_threshold | 2000 | PHP_INI_ALL |
memcached.serializer | php | PHP_INI_ALL |
memcached.use_sasl | 0 | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

memcached.sess_locking integer

Emplear el bloqueo de sesiones. Valores válidos: On, Off; el predeterminado es On.

memcached.sess_consistent_hash integer

Modo de hash consistente de sesiones de memcached. Si se establece a On, se emplea el hash consistente para el manejador de sesiones. Al utilizar el hash consistente se pueden añadir o eliminar nodos sin desordenar demasiado las claves existentes. El valor predeterminado es Off.

memcached.sess_binary integer

Emplear el modo binario de sesiones de memcached. Las réplicas de libmemcached solamente funcionan si el modo binario está habilitado. El valor predeterminado es Off.

memcached.sess_lock_wait integer

Tiempo de espera entre reintentos de adquirir el bloqueo de una sesión, en microsegundos. Se ha de tener cuidado al establecer este valor. Los valores válidos son enteros, donde 0 se interpreta como el valor predeterminado. Los valores negativos resultan en una reducción en el intento de obtener el bloqueo. El valor predeterminado es 150000.

memcached.sess_prefix string

Prefijo de clave de sesión de memcached. Los valores válidos son string de menos de 219 bytes de longitud. El valor predeterminado es "memc.sess.key."

memcached.sess_number_of_replicas integer

El número de réplicas de sesiones de memcached.

memcached.sess_randomize_replica_read integer

Aleatorizar la lectura de réplicas de sesiones de memcached.

memcached.sess_remove_failed integer

Permitir que sean eliminados automáticamente los servidores de memcached fallidos.

memcached.compression_type string

Establecer el tipo de compresión. Los valores válidos son: fastlz, zlib. El predeterminado es fastlz.

memcached.compression_factor float

Factor de compresión. Almacenar valores comprimidos solamente si el factor de compresión (ahorro) excede el límite establecido. Emplear el almacenamiento comprimido si: longitud_normal > longitud_comprimida * factor. El valor predeterminado es 1.3 (23% de ahorro de espacio).

memcached.compression_threshold integer

El umbral de compresión. No comprime valores serializados por debajo de este umbral. El valor predeterminado es 2000 bytes.

memcached.serializer string

Establecer el serializador predeterminado para nuevos objetos de memcached. Los valores válidos son: php, igbinary, json, json_array.

json

Codificación JSON estándar de PHP. Este serializador es rápido y compacto, pero solamente funciona con datos codificados con UTF-8 y no implementa completamente la serialización. Ver la extensión JSON.

json_array

Como json, pero decodifica en array.

php

El serializador estándar de PHP.

igbinary

Un serializador binario

El predeterminado es igbinary, si está disponible, o de lo contrario php.

memcached.use_sasl integer

Emplear la autenticación SASL para conexiones. Los valores válidos son: On, Off. El predeterminado es Off.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Memcached::OPT_COMPRESSION

Activa o desactiva la compresión de la carga. Cuando está activada, los valores de ítems mayores que cierto umbral (actualmente 100 bytes) serán comprimidos durante el almacenamiento y descomprimidos durante su recuperación de forma transparente.

Tipo: boolean, predeterminado: true.

Memcached::OPT_SERIALIZER

Especifica el serializador a emplear para serializar valores no escalares. Los serializadores válidos son Memcached::SERIALIZER_PHP o Memcached::SERIALIZER_IGBINARY. Este último solo se admite cuando memcached está configurada con la opción --enable-memcached-igbinary y la extensión igbinary está cargada.

Tipo: integer, predeterminado: Memcached::SERIALIZER_PHP.

Memcached::SERIALIZER_PHP

El serializador de PHP predeterminado.

Memcached::SERIALIZER_IGBINARY

El serializador de » igbinary. En lugar de una representación textual, almacena estructuras de datos de PHP de una forma binaria compacta, lo que resulta en mejoras de espacio y tiempo.

Memcached::SERIALIZER_JSON

El serializador de JSON. Requiere PHP 5.2.10+.

Memcached::OPT_PREFIX_KEY

Puede emplearse para crear un "dominio" para las claves de ítems. El valor especificado será utilizado para prefijar cada una de las claves. No puede ser mayor que 128 caracteres y reducirá el tamaño máximo disponible de la clave. El prefijo se aplica solamente a las claves de los ítems, no en las claves de servidores.

Tipo: string, predeterminado: "".

Memcached::OPT_HASH

Especifica el algoritmo hash utilizado por las claves de ítems. Los valores válidos se proporcionan mediante las constantes Memcached::HASH_*. Cada algoritmo hash tiene sus ventajas y desventajas. Se deberá utilizar el predeterminado si no se tiene conocimiento o no tiene relevancia.

Tipo: integer, predeterminado: Memcached::HASH_DEFAULT

Memcached::HASH_DEFAULT

Algoritmo hash predeterminado (Jenkins una-cada-vez) de claves de ítems.

Memcached::HASH_MD5

Algoritmo hash para claves de ítems MD5.

Memcached::HASH_CRC

Algoritmo hash para claves de ítems CRC.

Memcached::HASH_FNV1_64

Algoritmo hash para claves de ítems FNV1_64.

Memcached::HASH_FNV1A_64

Algoritmo hash para claves de ítems FNV1_64A.

Memcached::HASH_FNV1_32

Algoritmo hash para claves de ítems FNV1_32.

Memcached::HASH_FNV1A_32

Algoritmo hash para claves de ítems FNV1_32A.

Memcached::HASH_HSIEH

Algoritmo hash para claves de ítems Hsieh.

Memcached::HASH_MURMUR

Algoritmo hash para claves de ítems Murmur

Memcached::OPT_DISTRIBUTION

Especifica el método para distribuir claves de ítems en los servidores. Actualmente, los métodos admitidos son módulo y hash consistente. El hash consistente proporciona una mejor distribución y permite que los servidores sean añadidos al clúster con el mínimo de pérdidas de caché.

Tipo: integer, predeterminado: Memcached::DISTRIBUTION_MODULA.

Memcached::DISTRIBUTION_MODULA

Algoritmo de distribución de claves basado en módulo.

Memcached::DISTRIBUTION_CONSISTENT

Algoritmo de distribución de claves hash consistentes (basado en libketama).

Memcached::OPT_LIBKETAMA_COMPATIBLE

Activa o desactiva la compatibilidad con el comportamiento de libketama. Cuando está activada, el algoritmo hash de claves de ítems se establece a MD5 y la distribución se establece a la distribución de hash consistente compensada. Esto es útil debido a que otros clientes basados en libketama (Python, Ruby, etc.) con la misma configuración de servidor serán capaces de acceder a las claves de forma transparente.

Nota:

Es muy recomendable activar esta opción para el empleo de hash consistente, y seguramente estará activada de forma predeterminada en futuras versiones.

Tipo: boolean, predeterminado: false.

Memcached::OPT_BUFFER_WRITES

Activa o desactiva la E/S en búfer. Activar la E/S en búfer hace que los comandos de almacenamiento usen el búfer en lugar de ser enviados. Cualquier acción que obtenga datos hace que la información del búfer sea enviada a la conexión remota. El quitar o cerrar la conexión también ocasionará que los datos del búfer sean enviados a la conexión remota.

Tipo: boolean, predeterminado: false.

Memcached::OPT_BINARY_PROTOCOL

Activa el empleo del protocolo binario. Observe que no se puede cambiar esta opción cuando una conexión está abierta.

Tipo: boolean, predeterminado: false.

Memcached::OPT_NO_BLOCK

Activa o desactiva la E/S asíncrona. Es el transporte más rápido disponible para funciones de almacenamiento.

Tipo: boolean, predeterminado: false.

Memcached::OPT_TCP_NODELAY

Activa o desactiva la característica de no retraso para conectar a un socket (podría ser más rápida en algunos entornos).

Tipo: boolean, predeterminado: false.

Memcached::OPT_SOCKET_SEND_SIZE

El búfer máximo de envío de socket, en bytes.

Tipo: integer, predeterminado: varía según la plataforma/configuración del kernel.

Memcached::OPT_SOCKET_RECV_SIZE

El búfer máximo de recepción de socket, en bytes.

Tipo: integer, predeterminado: varía según la plataforma/configuración del kernel.

Memcached::OPT_CONNECT_TIMEOUT

En el modo de no bloqueo, establecer el valor del tiempo de espera durante la conexión al socket, en milisengundos.

Tipo: integer, predeterminado: 1000.

Memcached::OPT_RETRY_TIMEOUT

La cantidad de tiempo, en segundos, a esperar para reintentar la conexión en caso que haya fallado.

Tipo: integer, predeterminado: 0.

Memcached::OPT_SEND_TIMEOUT

Tiempo de espera para el envío al socket, en microsegundos. En los casos donde no se puede emplear E/S de no bloqueo, permitirá tener tiempos de espera al enviar datos.

Tipo: integer, predeterminado: 0.

Memcached::OPT_RECV_TIMEOUT

Tiempo de espera para la lectura del socket, en microsegundos. En los casos donde no se puede emplear E/S de no bloqueo, permitirá tener tiempos de espera al leer datos.

Tipo: integer, predeterminado: 0.

Memcached::OPT_POLL_TIMEOUT

Tiempo de espera para el agrupamiento de conexiones, en milisegundos.

Tipo: integer, predeterminado: 1000.

Memcached::OPT_CACHE_LOOKUPS

Activa o desactiva caché para resoluciones DNS.

Tipo: boolean, predeterminado: false.

Memcached::OPT_SERVER_FAILURE_LIMIT

Especifica el límite de intentos de conexión al servidor. El servidor será eliminado después del número indicado de fallos continuos de conexión.

Tipo: integer, predeterminado: 0.

Memcached::HAVE_IGBINARY

Indica si está disponible el soporte para el serializador igbinary.

Tipo: boolean.

Memcached::HAVE_JSON

Indica si está disponible el soporte para el serializador JSON.

Tipo: boolean.

Memcached::GET_PRESERVE_ORDER

Opción para Memcached::getMulti() y Memcached::getMultiByKey() para garantizar que las claves son devueltas en el mismo orden que fueron solicitadas. Las claves no existentes obtienen un valor predeterminado de NULL.

Memcached::RES_SUCCESS

La operación se completó satisfactoriamente.

Memcached::RES_FAILURE

La operación falló de algún modo.

Memcached::RES_HOST_LOOKUP_FAILURE

Falló la resolución DNS.

Memcached::RES_UNKNOWN_READ_FAILURE

Fallo al leer datos de la red.

Memcached::RES_PROTOCOL_ERROR

Comando erróneo del protocolo memcached.

Memcached::RES_CLIENT_ERROR

Error en el lado del cliente.

Memcached::RES_SERVER_ERROR

Error en el lado del servidor.

Memcached::RES_WRITE_FAILURE

Fallo al escribir datos en la red.

Memcached::RES_DATA_EXISTS

Fallo al comparar e intercambiar: el ítem que se intenta guardar ha sido modificado desde la última vez que se obtuvo.

Memcached::RES_NOTSTORED

El ítem no fue guardado: pero no a causa de un error. Normalmente significa que no se cumplió la condición para un comando "add" o "replace", o que el ítem está en una cola para su eliminación.

Memcached::RES_NOTFOUND

No se encontró el ítem con esta clave (mediante la operación "get" o "cas").

Memcached::RES_PARTIAL_READ

Error de lectura parcial de datos en la red.

Memcached::RES_SOME_ERRORS

Algunos errores sucedieron durante una obtención múltiple.

Memcached::RES_NO_SERVERS

La lista de servidores está vacía.

Memcached::RES_END

Final del conjunto de resultados.

Memcached::RES_ERRNO

Error del sistema.

Memcached::RES_BUFFERED

La operación estaba almacenada en búfer.

Memcached::RES_TIMEOUT

La operación expiró.

Memcached::RES_BAD_KEY_PROVIDED

Clave errónea.

Memcached::RES_CONNECTION_SOCKET_CREATE_FAILURE

Fallo al crear el socket de red.

Memcached::RES_PAYLOAD_FAILURE

Error de carga: no se pudo comprimir/descomprimir o serializar/deserializar el valor.


Tiempos de expiración

Algunos comandos de almacenamiento implican el envío de un valor de expiración (relativo a un ítem o a una operación solicitada por el cliente) al servidor. En todos los casos, el valor real enviado podría ser en tiempo Unix (un valor de tipo integer con el número de segundos transcurridos desde el 1 de enero de 1970), o el número de segundos comenzando desde el instante actual. En este caso, el número no debe exceder de 60*60*24*30 (que corresponde al número de segundos en 30 días); si se excede el valor del tiempo de expiración, el servidor lo considerará como tiempo Unix en lugar del número de segundos desde el instante actual.

Si el valor de la expiración es 0 (el predeterminado), el ítem nunca caducará (aunque puede ser eliminado del servidor para hacer sitio a otros ítems).


Retrollamadas

Tabla de contenidos

  • Retrollamadas de resultados
  • Retrollamadas de caché de lectura previa


Retrollamadas de resultados

Las retrollamadas (callback) de resultados son invocadas por los métodos Memcached::getDelayed() o Memcached::getDelayedBykey() por cada ítem del conjunto de resultados. A la retrollamada se le proporciona el objeto Memcached y el array con la información del ítem. La retrollamada no tiene que devolver nada.

Ejemplo #1 Ejemplo retrollamada de resultados

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$items = array(
    'clave1' => 'valor1',
    'clave2' => 'valor2',
    'clave3' => 'valor3'
);
$m->setMulti($items);
$m->getDelayed(array('clave1', 'clave3'), true, 'rll_resultados');

function rll_resultados($memc, $item)
{
    var_dump($item);
}
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["key"]=>
  string(6) "clave1"
  ["value"]=>
  string(6) "valor1"
  ["cas"]=>
  float(49)
}
array(3) {
  ["key"]=>
  string(6) "clave3"
  ["value"]=>
  string(6) "valor3"
  ["cas"]=>
  float(50)
}


Retrollamadas de caché de lectura previa

Las retrollamadas de caché de lectura previa son invocadas cuando un ítem no puede ser obtenido de un servidor. A la retrollamada se le proporciona el objecto Memcached, la clave solicitada y el valor por referencia de la variable. La retrollamada se encarga de definir el valor y devolver true o false. Si la retrollamada devuelve true, Memcached guardará el valor en el servidor y lo devolverá a la función de llamada original. Solamente Memcached::get() y Memcached::getByKey() admiten estas retrollamadas, ya que el protocolo memcache no provee información sobre las claves que no fueron encontradas en la petición de varias claves.

Ejemplo #1 Ejemplo de lectura de retrollamada

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$info_perfil = $m->get('user:'.$id_usuario, 'rll_info_usuario');

function rll_info_usuario($memc, $clave, &$valor)
{
    $id_usuario = substr($clave, 5);
    /* buscar el prefil en la BD */
    /* ... */
    $valor = $info_perfil;
    return true;
}
?>


Soporte para sesiones

Memcached proporciona un controlador personalizado de sesiones que puede emplearse para almacenar sesiones de usuario en memcache. Utiliza internamente una instancia diferente para este propósito, por lo que se puede utilizar una agrupación de servidores diferente si fuera necesario. Las claves de sesiones se almacenan bajo el prefijo memc.sess.key., por lo que hay que considerar esto si se utiliza la misma agrupación de servidores para caché de sesiones y caché genérica.

session.save_handler string

Establecer a memcached para activar el soporte para sesiones.

session.save_path string

Define entradas nombre_host:puerto separadas por comas para utilizarlas en agrupaciones de servidores de sesiones, por ejemplo "sess1:11211, sess2:11211".


La clase Memcached

(PECL memcached >= 0.1.0)

Introducción

Representa una conexión a un conjunto de servidores de memcached.

Sinopsis de la Clase

Memcached {
public __construct ( string $persistent_id = ? )
public add ( string $key , mixed $value , int $expiration = ? ) : bool
public addByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public addServer ( string $host , int $port , int $weight = 0 ) : bool
public addServers ( array $servers ) : bool
public append ( string $key , string $value ) : bool
public appendByKey ( string $server_key , string $key , string $value ) : bool
public cas ( float $cas_token , string $key , mixed $value , int $expiration = ? ) : bool
public casByKey ( float $cas_token , string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public decrement ( string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int
public decrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int
public delete ( string $key , int $time = 0 ) : bool
public deleteByKey ( string $server_key , string $key , int $time = 0 ) : bool
public deleteMulti ( array $keys , int $time = 0 ) : bool
public deleteMultiByKey ( string $server_key , array $keys , int $time = 0 ) : bool
public fetch ( ) : array
public fetchAll ( ) : array
public flush ( int $delay = 0 ) : bool
public get ( string $key , callable $cache_cb = ? , float &$cas_token = ? ) : mixed
public getAllKeys ( ) : array
public getByKey ( string $server_key , string $key , callable $cache_cb = ? , float &$cas_token = ? ) : mixed
public getDelayed ( array $keys , bool $with_cas = ? , callable $value_cb = ? ) : bool
public getDelayedByKey ( string $server_key , array $keys , bool $with_cas = ? , callable $value_cb = ? ) : bool
public getMulti ( array $keys , array &$cas_tokens = ? , int $flags = ? ) : mixed
public getMultiByKey ( string $server_key , array $keys , string &$cas_tokens = ? , int $flags = ? ) : array
public getOption ( int $option ) : mixed
public getResultCode ( ) : int
public getResultMessage ( ) : string
public getServerByKey ( string $server_key ) : array
public getServerList ( ) : array
public getStats ( ) : array
public getVersion ( ) : array
public increment ( string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int
public incrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int
public isPersistent ( ) : bool
public isPristine ( ) : bool
public prepend ( string $key , string $value ) : bool
public prependByKey ( string $server_key , string $key , string $value ) : bool
public quit ( ) : bool
public replace ( string $key , mixed $value , int $expiration = ? ) : bool
public replaceByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public resetServerList ( ) : bool
public set ( string $key , mixed $value , int $expiration = ? ) : bool
public setByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public setMulti ( array $items , int $expiration = ? ) : bool
public setMultiByKey ( string $server_key , array $items , int $expiration = ? ) : bool
public setOption ( int $option , mixed $value ) : bool
public setOptions ( array $options ) : bool
public setSaslAuthData ( string $username , string $password ) : void
public touch ( string $key , int $expiration ) : bool
public touchByKey ( string $server_key , string $key , int $expiration ) : bool
}

Tabla de contenidos

  • Memcached::add — Añade un ítem asociado a una nueva clave
  • Memcached::addByKey — Añade un ítem asociado a una nueva clave en un servidor específico
  • Memcached::addServer — Añade un servidor a la provisión de servidores
  • Memcached::addServers — Añadir varios servidores a la agrupación de servidores
  • Memcached::append — Añadir datos a un ítem existente
  • Memcached::appendByKey — Añadir datos a un ítem existente en un servidor específico
  • Memcached::cas — Comparar e intercambiar un ítem
  • Memcached::casByKey — Comparar e intercambiar un ítem en un servidor específico
  • Memcached::__construct — Crear una instancia de Memcached
  • Memcached::decrement — Decrementar un valor numérico de un ítem
  • Memcached::decrementByKey — Decrementar un valor numérico de un ítem almacenado en un servidor específico
  • Memcached::delete — Eliminar un ítem
  • Memcached::deleteByKey — Eliminar un ítem de un servidor específico
  • Memcached::deleteMulti — Eliminar varios ítems
  • Memcached::deleteMultiByKey — Eliminar varios ítems de un servidor específico
  • Memcached::fetch — Obtener el siguiente resultado
  • Memcached::fetchAll — Obtener todos los resultados restantes
  • Memcached::flush — Invalidar todos los ítems de la caché
  • Memcached::get — Obtener un ítem
  • Memcached::getAllKeys — Obtiene las claves almacenadas en todos los servidores
  • Memcached::getByKey — Obtiene un ítem de un servidor específico
  • Memcached::getDelayed — Obtener varios ítems
  • Memcached::getDelayedByKey — Solicitar varios ítems de un servidor específico
  • Memcached::getMulti — Obtener varios ítems
  • Memcached::getMultiByKey — Recuperar varios ítems de un servidor específico
  • Memcached::getOption — Obtener el valor de una opción de Memcached
  • Memcached::getResultCode — Devuelve el código resultante de la última operación
  • Memcached::getResultMessage — Devolver un mensaje que describe el resultado de la última operación
  • Memcached::getServerByKey — Hacer corresponder una clave con un servidor
  • Memcached::getServerList — Obtener la lista de servidores de la agrupación
  • Memcached::getStats — Obtener las estadísticas de la agrupación de servidores
  • Memcached::getVersion — Obtener la información de la versión de la agrupación de servidores
  • Memcached::increment — Incrementar un valor numérico de un ítem
  • Memcached::incrementByKey — Incrementar un valor numérico de un ítem, almacenado en un servidor específico
  • Memcached::isPersistent — Comprueba si se está utilizando una conexión persistente a memcache
  • Memcached::isPristine — Comprobar si la instancia se creó recientemente
  • Memcached::prepend — Anteponer datos a un ítem existente
  • Memcached::prependByKey — Anteponer datos a un ítem existente en un servidor específico
  • Memcached::quit — Cierra cualquier conexión abierta
  • Memcached::replace — Reemplaza un ítem asociado a una clave existente
  • Memcached::replaceByKey — Reemplazar un ítem bajo una clave existente en un servidor específico
  • Memcached::resetServerList — Limpia todos los servidores de la lista de servidores
  • Memcached::set — Guardar un ítem
  • Memcached::setByKey — Guardar un ítem en un servidor específico
  • Memcached::setMulti — Almacenar varios ítems
  • Memcached::setMultiByKey — Almacena varios ítems en un servidor específico
  • Memcached::setOption — Establecer una opción de Memcached
  • Memcached::setOptions — Establecer opciones de Memcached
  • Memcached::setSaslAuthData — Establecer las credenciales para la autenticación
  • Memcached::touch — Establecer una nueva expiración para un ítem
  • Memcached::touchByKey — Establecer una nueva expiración para un ítem de un servidor específico


Añade un ítem asociado a una nueva clave

  • « Memcached
  • Memcached::addByKey »
  • PHP Manual
  • Memcached
  • Añade un ítem asociado a una nueva clave

Memcached::add

(PECL memcached >= 0.1.0)

Memcached::add — Añade un ítem asociado a una nueva clave

Descripción

public Memcached::add ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::add() es similar a Memcached::set(), pero la operación fallará si key ya existe en el servidor.

Parámetros

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave ya existe.

Ver también

  • Memcached::addByKey() - Añade un ítem asociado a una nueva clave en un servidor específico
  • Memcached::set() - Guardar un ítem
  • Memcached::replace() - Reemplaza un ítem asociado a una clave existente


Añade un ítem asociado a una nueva clave en un servidor específico

  • « Memcached::add
  • Memcached::addServer »
  • PHP Manual
  • Memcached
  • Añade un ítem asociado a una nueva clave en un servidor específico

Memcached::addByKey

(PECL memcached >= 0.1.0)

Memcached::addByKey — Añade un ítem asociado a una nueva clave en un servidor específico

Descripción

public Memcached::addByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

La funcionalidad de Memcached::addByKey() es equivalente a la de Memcached::add(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico. Es útil si se necesita relacionar cierta cantidad de claves a un servidor determinado.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave ya existe.

Ver también

  • Memcached::add() - Añade un ítem asociado a una nueva clave
  • Memcached::set() - Guardar un ítem
  • Memcached::replace() - Reemplaza un ítem asociado a una clave existente


Añade un servidor a la provisión de servidores

  • « Memcached::addByKey
  • Memcached::addServers »
  • PHP Manual
  • Memcached
  • Añade un servidor a la provisión de servidores

Memcached::addServer

(PECL memcached >= 0.1.0)

Memcached::addServer — Añade un servidor a la provisión de servidores

Descripción

public Memcached::addServer ( string $host , int $port , int $weight = 0 ) : bool

Memcached::addServer() añade el servidor especificado a la provisión de servidores. En esta operación no se establece una conexión al servidor, aunque si se emplea la opción de distribución de claves (a través de Memcached::DISTRIBUTION_CONSISTENT o Memcached::OPT_LIBKETAMA_COMPATIBLE), algunas de las estructuras de datos internas deberán ser actualizadas. Así, si fuera necesario añadir varios servidores, es mejor utilizar Memcached::addServers(), ya que la actualización se realiza una única vez.

El mismo servidor podría aparecer varias veces en la provisión de servidores, debido a que no se realiza ninguna comprobación de duplicados. Esta característica no es aconsejable; emplee en su lugar la opción weight para aumentar el peso de selección (importancia) de dicho servidor.

Parámetros

host

El nombre de host del servidor de memcache. Si el nombre de host no es válido, las operaciones relacinadas con datos establecerán el código de resultado Memcached::RES_HOST_LOOKUP_FAILURE. A partir de la versión 2.0.0b1, este parámetro puede también especificar la ruta de un socket de unix, p.ej., /ruta/a/memcached.sock, para emplear socket de dominio de UNIX; en este caso también se debe establecer port a 0.

port

El puerto en que memcache está funcionado. Normalmente es 11211. A partir de la versión 2.0.0b1, se debe establecer este parámetro a 0 al utilizar socket de dominio UNIX.

weight

El peso (importancia) del servidor relativo al peso total de todos los servidores en la provisión. Controla la probabilidad de que un servidor sea elegido para realizar operaciones. Solamente se utiliza para la opción de distribución consistente y normalmente corresponde a la cantidad de memoria disponible para memcache en dicho servidor.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::addServer()

<?php
$m = new Memcached();

/* Añadir 2 servidores, de forma que el segundo
   tiene el doble de probabilidades de ser seleccionado. */
$m->addServer('mem1.dominio.com', 11211, 33);
$m->addServer('mem2.dominio.com', 11211, 67);
?>

Ver también

  • Memcached::addServers() - Añadir varios servidores a la agrupación de servidores
  • Memcached::resetServerList() - Limpia todos los servidores de la lista de servidores


Añadir varios servidores a la agrupación de servidores

  • « Memcached::addServer
  • Memcached::append »
  • PHP Manual
  • Memcached
  • Añadir varios servidores a la agrupación de servidores

Memcached::addServers

(PECL memcached >= 0.1.1)

Memcached::addServers — Añadir varios servidores a la agrupación de servidores

Descripción

public Memcached::addServers ( array $servers ) : bool

Memcached::addServers() añade servers a la agrupación de servidores. Cada entrada de servers debe ser un array que contenga el nombre de host, el puerto y, opcionalmente, el peso (importancia) del servidor. No se establecerá ninguna conexión a los servidores en este proceso.

El mismo servidor podría aparecer varias veces en la agrupación de servidores, debido a que no se realiza ninguna comprobación de duplicados. Esta característica no es aconsejable; emplee en su lugar la opción weight para aumentar el peso de selección (importancia) de dicho servidor.

Parámetros

array

Array de servidores a añadir a la agrupación de servidores.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::addServers()

<?php
$m = new Memcached();

$servidores = array(
    array('mem1.dominio.com', 11211, 33),
    array('mem2.dominio.com', 11211, 67)
);
$m->addServers($servidores);
?>

Ver también

  • Memcached::addServer() - Añade un servidor a la provisión de servidores
  • Memcached::resetServerList() - Limpia todos los servidores de la lista de servidores


Añadir datos a un ítem existente

  • « Memcached::addServers
  • Memcached::appendByKey »
  • PHP Manual
  • Memcached
  • Añadir datos a un ítem existente

Memcached::append

(PECL memcached >= 0.1.0)

Memcached::append — Añadir datos a un ítem existente

Descripción

public Memcached::append ( string $key , string $value ) : bool

Memcached::append() añade el string dado por value al valor del ítem existente. La razón por la que se fuerza a value a ser un string es debido a que no está bien definida la adición de tipos mixtos.

Nota:

Si Memcached::OPT_COMPRESSION está activado, la operación fallará y se emitirá una advertencia, ya que no es posible añadir datos comprimidos a un valor que potencialmente ya está comprimido.

Parámetros

key

La clave en la que se guardará el valor.

value

El string a añadir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave no existe.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::append()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->append('foo', 'def');
var_dump($m->get('foo'));
?>

El resultado del ejemplo sería:

string(6) "abcdef"

Ver también

  • Memcached::appendByKey() - Añadir datos a un ítem existente en un servidor específico
  • Memcached::prepend() - Anteponer datos a un ítem existente


Añadir datos a un ítem existente en un servidor específico

  • « Memcached::append
  • Memcached::cas »
  • PHP Manual
  • Memcached
  • Añadir datos a un ítem existente en un servidor específico

Memcached::appendByKey

(PECL memcached >= 0.1.0)

Memcached::appendByKey — Añadir datos a un ítem existente en un servidor específico

Descripción

public Memcached::appendByKey ( string $server_key , string $key , string $value ) : bool

La funcionalidad de Memcached::appendByKey() es equivalente a la de Memcached::append(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

value

El string a añadir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si clave no existe.

Ver también

  • Memcached::append() - Añadir datos a un ítem existente
  • Memcached::prepend() - Anteponer datos a un ítem existente


Comparar e intercambiar un ítem

  • « Memcached::appendByKey
  • Memcached::casByKey »
  • PHP Manual
  • Memcached
  • Comparar e intercambiar un ítem

Memcached::cas

(PECL memcached >= 0.1.0)

Memcached::cas — Comparar e intercambiar un ítem

Descripción

public Memcached::cas ( float $cas_token , string $key , mixed $value , int $expiration = ? ) : bool

Memcached::cas() realiza una operación "comprobar y establecer" ('cas' por sus siglas en inglés), de forma que el ítem será guardado solamente si ningún otro cliente lo actualizó desde la última vez que este cliente lo obtuvo. La comprobación se realiza mediante el parámetro cas_token, el cual es un valor único de 64 bit asignado al ítem existente por memcache. Ver la documentación de los métodos Memcached::get*() para saber cómo obtener este token. Observar que el token está representado como un valor de tipo double debido a las limitaciones de espacio para valores integer de PHP.

Parámetros

cas_token

El valor único asociado con el ítem existente. Generado por memcache.

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_DATA_EXISTS si el ítem que se trata de guardar ha sido modificado desde la última vez que se obtuvo.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::cas()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

do {
    /* obtener la lista de direcciones IP y sus token */
    $ips = $m->get('ip_block', null, $cas);
    /* si la lista no existe aún, crear una y realizar
       un añadido atómico que fallará si alguien ya añadió un valor */
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ips = array($_SERVER['REMOTE_ADDR']);
        $m->add('ip_block', $ips);
    /* en caso contrario, añadir la IP a la lista y guardar vía comparar-e-intercambiar
       con el token, que fallará si alguien ya actualizó la lista */
    } else {
        $ips[] = $_SERVER['REMOTE_ADDR'];
        $m->cas($cas, 'ip_block', $ips);
    }
} while ($m->getResultCode() != Memcached::RES_SUCCESS);

?>

Ver también

  • Memcached::casByKey() - Comparar e intercambiar un ítem en un servidor específico


Comparar e intercambiar un ítem en un servidor específico

  • « Memcached::cas
  • Memcached::__construct »
  • PHP Manual
  • Memcached
  • Comparar e intercambiar un ítem en un servidor específico

Memcached::casByKey

(PECL memcached >= 0.1.0)

Memcached::casByKey — Comparar e intercambiar un ítem en un servidor específico

Descripción

public Memcached::casByKey ( float $cas_token , string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

La funcionalidad de Memcached::casByKey() es equivalente a la de Memcached::cas(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico. Es útil si se necesita relacionar cierta cantidad de claves a un servidor determinado.

Parámetros

cas_token

Valor único asociado con el ítem existente. Generado por memcache.

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_DATA_EXISTS si el ítem que se trata de guardar ha sido modificado desde la última vez que se obtuvo.

Ver también

  • Memcached::cas() - Comparar e intercambiar un ítem


Crear una instancia de Memcached

  • « Memcached::casByKey
  • Memcached::decrement »
  • PHP Manual
  • Memcached
  • Crear una instancia de Memcached

Memcached::__construct

(PECL memcached >= 0.1.0)

Memcached::__construct — Crear una instancia de Memcached

Descripción

public Memcached::__construct ( string $persistent_id = ? )

Crea una instancia de Memcached que representa la conexión a los servidores de memcache.

Parámetros

persistent_id

Por defecto, las instancias de Memcached son destruidas al final de la petición. Para crear una instancia que persista entre peticiones, use persistent_id para especificar un ID único para la instancia. Todas las instancias creadas con el mismo persistent_id compartirán la misma conexión.

Valores devueltos

Un objeto Memcached.

Ejemplos

Ejemplo #1 Crear un objeto Memcached

<?php
/* Crear una instancia normal */
$m = new Memcached();
echo get_class($m);

/* Crear una instancia persistente */
$m2 = new Memcached('story_pool');
$m3 = new Memcached('story_pool');

/* Ahora $m2 y $m3 comparten la misma conexión */
?>


Decrementar un valor numérico de un ítem

  • « Memcached::__construct
  • Memcached::decrementByKey »
  • PHP Manual
  • Memcached
  • Decrementar un valor numérico de un ítem

Memcached::decrement

(PECL memcached >= 0.1.0)

Memcached::decrement — Decrementar un valor numérico de un ítem

Descripción

public Memcached::decrement ( string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int

Memcached::decrement() decrementa un valor numérico de un ítem por el offset especificado. Si el valor del ítem no es numérico, generará un error. Si la operación requiere decrementar un valor inferior a 0, el nuevo valor será 0. Memcached::decrement() establecerá el ítem al parámetro initial_value si la clave no existe.

Parámetros

key

La clave del ítem a decrementar.

offset

La cantidad por la que decrementar el valor del ítem.

initial_value

El valor para establecer el ítem si actualmente no existe.

expiry

El periodo de expiración a establecer para el ítem.

Valores devueltos

Devuelve el nuevo valor del ítem en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::decrement()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 5);
$n = $m->decrement('counter');
var_dump($n);

$n = $m->decrement('counter', 10);
var_dump($n);

var_dump($m->get('counter'));

$m->set('counter', 'abc');
$n = $m->increment('counter');
// ^ fallará debido a que el valor del ítem no es numérico
var_dump($n);
?>

El resultado del ejemplo sería:

int(4)
int(0)
int(0)
bool(false)

Ver también

  • Memcached::increment() - Incrementar un valor numérico de un ítem
  • Memcached::incrementByKey() - Incrementar un valor numérico de un ítem, almacenado en un servidor específico
  • Memcached::decrementByKey() - Decrementar un valor numérico de un ítem almacenado en un servidor específico


Decrementar un valor numérico de un ítem almacenado en un servidor específico

  • « Memcached::decrement
  • Memcached::delete »
  • PHP Manual
  • Memcached
  • Decrementar un valor numérico de un ítem almacenado en un servidor específico

Memcached::decrementByKey

(PECL memcached >= 2.0.0)

Memcached::decrementByKey — Decrementar un valor numérico de un ítem almacenado en un servidor específico

Descripción

public Memcached::decrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int

Memcached::decrementByKey() decrementa un valor numérico de un ítem por el offset especificado. Si el valor del ítem no es numérico, generará un error. Si la operación requiere decrementar un valor inferior a 0, el nuevo valor será 0. Memcached::decrement() establecerá el ítem al parámetro initial_value si la clave no existe.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave del ítem a decrementar.

offset

La cantidad por la que decrementar el valor del ítem.

initial_value

El valor para establecer el ítem si actualmente no existe.

expiry

El periodo de expiración a establecer para el ítem.

Valores devueltos

Devuelve el nuevo valor del ítem en caso de éxito o false en caso de error.

Ver también

  • Memcached::decrement() - Decrementar un valor numérico de un ítem
  • Memcached::increment() - Incrementar un valor numérico de un ítem
  • Memcached::incrementByKey() - Incrementar un valor numérico de un ítem, almacenado en un servidor específico


Eliminar un ítem

  • « Memcached::decrementByKey
  • Memcached::deleteByKey »
  • PHP Manual
  • Memcached
  • Eliminar un ítem

Memcached::delete

(PECL memcached >= 0.1.0)

Memcached::delete — Eliminar un ítem

Descripción

public Memcached::delete ( string $key , int $time = 0 ) : bool

Memcached::delete() elimina el array de claves dado por keys del servidor. El parámetro time es la cantidad de tiempo en segundos (o el instante Unix a sobrepasar) por el cual el cliente quiere que el servidor rechace los comandos add y replace para estas claves. El ítem es puesto en una cola de eliminación por esta cantidad de tiempo, los que significa que no será posible recuperarlo por el comando get, y que el empleo de los comandos add y replace con tales claves también fallarán (aunque el comando set sí funcionará). Finalizado el tiempo, el ítem es por fin eliminado de la memoria del servidor. El parámetro time es por defecto 0 (lo que significa que el ítem será eliminado de inmediato y que tendrán éxito los comandos de almacenamiento posteriores con estas claves).

Parámetros

key

La clave a eliminar.

time

La cantidad de tiempo que el servidor esperará para borrar el ítem.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si la clave no existe.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::delete()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->delete('key1');
?>

Ver también

  • Memcached::deleteByKey() - Eliminar un ítem de un servidor específico
  • Memcached::deleteMulti() - Eliminar varios ítems


Eliminar un ítem de un servidor específico

  • « Memcached::delete
  • Memcached::deleteMulti »
  • PHP Manual
  • Memcached
  • Eliminar un ítem de un servidor específico

Memcached::deleteByKey

(PECL memcached >= 0.1.0)

Memcached::deleteByKey — Eliminar un ítem de un servidor específico

Descripción

public Memcached::deleteByKey ( string $server_key , string $key , int $time = 0 ) : bool

La funcionalidad de Memcached::deleteByKey() es equivalente a la de Memcached::delete(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave a eliminar.

time

La cantidad de tiempo que el servidor esperará para eliminar el ítem.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si la clave no existe.

Ver también

  • Memcached::delete() - Eliminar un ítem
  • Memcached::deleteMulti() - Eliminar varios ítems
  • Memcached::deleteMultiByKey() - Eliminar varios ítems de un servidor específico


Eliminar varios ítems

  • « Memcached::deleteByKey
  • Memcached::deleteMultiByKey »
  • PHP Manual
  • Memcached
  • Eliminar varios ítems

Memcached::deleteMulti

(PECL memcached >= 2.0.0)

Memcached::deleteMulti — Eliminar varios ítems

Descripción

public Memcached::deleteMulti ( array $keys , int $time = 0 ) : bool

Memcached::deleteMulti() elimina el array de claves dado por keys del servidor. El parámetro time es la cantidad de tiempo en segundos (o el instante Unix a sobrepasar) por el cual el cliente quiere que el servidor rechace los comandos add y replace para estas claves. El ítem es puesto en una cola de eliminación por esta cantidad de tiempo, los que significa que no será posible recuperarlo por el comando get, y que el empleo de los comandos add y replace con tales claves también fallarán (aunque el comando set sí funcionará). Finalizado el tiempo, el ítem es por fin eliminado de la memoria del servidor. El parámetro time es por defecto 0 (lo que significa que el ítem será eliminado de inmediato y que tendrán éxito los comandos de almacenamiento posteriores con estas claves).

Parámetros

keys

Las claves a eliminar.

time

La cantidad de tiempo que el servidor esperará para borrar los ítems.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si la clave no existe.

Ver también

  • Memcached::delete() - Eliminar un ítem
  • Memcached::deleteByKey() - Eliminar un ítem de un servidor específico
  • Memcached::deleteMultiByKey() - Eliminar varios ítems de un servidor específico


Eliminar varios ítems de un servidor específico

  • « Memcached::deleteMulti
  • Memcached::fetch »
  • PHP Manual
  • Memcached
  • Eliminar varios ítems de un servidor específico

Memcached::deleteMultiByKey

(PECL memcached >= 2.0.0)

Memcached::deleteMultiByKey — Eliminar varios ítems de un servidor específico

Descripción

public Memcached::deleteMultiByKey ( string $server_key , array $keys , int $time = 0 ) : bool

La funcionalidad de Memcached::deleteMultiByKey() es equivalente a la de Memcached::deleteMulti(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

keys

Las claves a eliminar.

time

La cantidad de tiempo que esperará el servidor para eliminar los ítems.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si clave no existe.

Ver también

  • Memcached::delete() - Eliminar un ítem
  • Memcached::deleteByKey() - Eliminar un ítem de un servidor específico
  • Memcached::deleteMulti() - Eliminar varios ítems


Obtener el siguiente resultado

  • « Memcached::deleteMultiByKey
  • Memcached::fetchAll »
  • PHP Manual
  • Memcached
  • Obtener el siguiente resultado

Memcached::fetch

(PECL memcached >= 0.1.0)

Memcached::fetch — Obtener el siguiente resultado

Descripción

public Memcached::fetch ( ) : array

Memcached::fetch() obtiene el siguiente resultado de la última petición.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el siguiente resultado o false en caso contrario. Memcached::getResultCode() devolverá Memcached::RES_END si el conjunto de resultados se ha agotado.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::fetch()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'un string sencillo');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
while ($resultado = $m->fetch()) {
    var_dump($resultado);
}
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["key"]=>
  string(3) "int"
  "value"]=>
  int(99)
  ["cas"]=>
  float(2363)
}
array(3) {
  ["key"]=>
  string(5) "array"
  ["value"]=>
  array(2) {
    [0]=>
    int(11)
    [1]=>
    int(12)
  }
  ["cas"]=>
  float(2365)
}

Ver también

  • Memcached::fetchAll() - Obtener todos los resultados restantes
  • Memcached::getDelayed() - Obtener varios ítems


Obtener todos los resultados restantes

  • « Memcached::fetch
  • Memcached::flush »
  • PHP Manual
  • Memcached
  • Obtener todos los resultados restantes

Memcached::fetchAll

(PECL memcached >= 0.1.0)

Memcached::fetchAll — Obtener todos los resultados restantes

Descripción

public Memcached::fetchAll ( ) : array

Memcached::fetchAll() obtiene todos los resultados restantes de la última petición.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve los resultados o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getDelayed()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'un string sencillo');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
var_dump($m->fetchAll());
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

Ver también

  • Memcached::fetch() - Obtener el siguiente resultado
  • Memcached::getDelayed() - Obtener varios ítems


Invalidar todos los ítems de la caché

  • « Memcached::fetchAll
  • Memcached::get »
  • PHP Manual
  • Memcached
  • Invalidar todos los ítems de la caché

Memcached::flush

(PECL memcached >= 0.1.0)

Memcached::flush — Invalidar todos los ítems de la caché

Descripción

public Memcached::flush ( int $delay = 0 ) : bool

Memcached::flush() invalida todos los ítems existentes en la caché de forma inmediata (lo predeterminado) o después de una demora especificada por delay. Después de la invalidación, no se devolverá ninún ítem en respuesta a un comando de obtención (a no ser que se haya guardado de nuevo bajo la misma clave después de que Memcached::flush() haya invalidado los ítems). El vaciado no libera la memoria ocupada por todos los ítems existentes; esto irá sucediendo a medida que se vayan guardando nuevos ítems.

Parámetros

delay

El número de segundos a esperar antes de invalidar los ítems.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::flush()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* vaciar todos los ítems en 10 segundos */
$m->flush(10);
?>


Obtener un ítem

  • « Memcached::flush
  • Memcached::getAllKeys »
  • PHP Manual
  • Memcached
  • Obtener un ítem

Memcached::get

(PECL memcached >= 0.1.0)

Memcached::get — Obtener un ítem

Descripción

public Memcached::get ( string $key , callable $cache_cb = ? , float &$cas_token = ? ) : mixed

Memcached::get() devuelve el ítem que fue previamente guardado bajo la clave dada por key. Si se encuentra el ítem y se proporciona la variable cas_token, esta contendrá el valor del token CAS para el ítem. Ver Memcached::cas() para saber cómo utilizar los token CAS. Se podrían especificar Retrollamadas de caché de lectura previa mediante el parámetro cache_cb.

Parámetros

key

La clave del ítem a obtener.

cache_cb

La retrollamada de caché de lectura previa o null.

cas_token

La variable donde guardar el token CAS.

Valores devueltos

Devuelve el valor almacenado en caché o false en caso contrario. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si la clave no existe.

Ejemplos

Ejemplo #1 Ejemplo 1 Memcached::get()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('foo', 100);
var_dump($m->get('foo'));
?>

El resultado del ejemplo sería:

int(100)

Ejemplo #2 Otro ejemplo de Memcached::get()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

if (!($ip = $m->get('ip_block'))) {
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ip = array();
        $m->set('ip_block', $ip);
    } else {
        /* registrar el error */
        /* ...       */
    }
}
?>

Ver también

  • Memcached::getByKey() - Obtiene un ítem de un servidor específico
  • Memcached::getMulti() - Obtener varios ítems
  • Memcached::getDelayed() - Obtener varios ítems


Obtiene las claves almacenadas en todos los servidores

  • « Memcached::get
  • Memcached::getByKey »
  • PHP Manual
  • Memcached
  • Obtiene las claves almacenadas en todos los servidores

Memcached::getAllKeys

(PECL memcached >= 2.0.0)

Memcached::getAllKeys — Obtiene las claves almacenadas en todos los servidores

Descripción

public Memcached::getAllKeys ( ) : array

Memcached::getAllKeys() consulta cada servidor de memcache y recupera un array con todas las claves almacenadas en ellos en ese instante. Esta no es una operación atómica, por lo que no es una instantánea realmente consistente de las claves en ese momento. Debido a que memcache no garantiza la devolución de todas las claves, no se podrá asumir que han sido devueltas en su totalidad.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las claves almacenadas en todos los servidores en caso de éxito o false en caso de error.


Obtiene un ítem de un servidor específico

  • « Memcached::getAllKeys
  • Memcached::getDelayed »
  • PHP Manual
  • Memcached
  • Obtiene un ítem de un servidor específico

Memcached::getByKey

(PECL memcached >= 0.1.0)

Memcached::getByKey — Obtiene un ítem de un servidor específico

Descripción

public Memcached::getByKey ( string $server_key , string $key , callable $cache_cb = ? , float &$cas_token = ? ) : mixed

La funcionalidad de Memcached::getByKey() es equivalente a la de Memcached::get(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave del ítem a obtener.

cache_cb

La retrollamada de caché de lectura previa o null.

cas_token

La variable donde guardar el token CAS.

Valores devueltos

Devuelve el valor guardado en caché o false en caso contrario. Memcached::getResultCode() devolverá Memcached::RES_NOTFOUND si la clave no existe.

Ver también

  • Memcached::get() - Obtener un ítem
  • Memcached::getMulti() - Obtener varios ítems
  • Memcached::getDelayed() - Obtener varios ítems


Obtener varios ítems

  • « Memcached::getByKey
  • Memcached::getDelayedByKey »
  • PHP Manual
  • Memcached
  • Obtener varios ítems

Memcached::getDelayed

(PECL memcached >= 0.1.0)

Memcached::getDelayed — Obtener varios ítems

Descripción

public Memcached::getDelayed ( array $keys , bool $with_cas = ? , callable $value_cb = ? ) : bool

Memcached::getDelayed() envía una petición a memcache de varios ítems con las claves que se especifican en el array keys. El método no espera una respuesta y devuelve inmediatamente. En cuanto se puedan obtener los ítems, se ha de llamar a Memcached::fetch() o Memcached::fetchAll(). Si with_cas es true, los valores del token CAS también serán solicitados.

En lugar de obtener los resultados explícitamente, se puede especificar una retrollamada de resultados mediante el parámetro value_cb.

Parámetros

keys

Array de claves a solicitar.

with_cas

Si solicitar también los valores del token CAS.

value_cb

La retrollamada de resultados o null.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getDelayed()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'un string sencillo');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
var_dump($m->fetchAll());
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

Ver también

  • Memcached::getDelayedByKey() - Solicitar varios ítems de un servidor específico
  • Memcached::fetch() - Obtener el siguiente resultado
  • Memcached::fetchAll() - Obtener todos los resultados restantes


Solicitar varios ítems de un servidor específico

  • « Memcached::getDelayed
  • Memcached::getMulti »
  • PHP Manual
  • Memcached
  • Solicitar varios ítems de un servidor específico

Memcached::getDelayedByKey

(PECL memcached >= 0.1.0)

Memcached::getDelayedByKey — Solicitar varios ítems de un servidor específico

Descripción

public Memcached::getDelayedByKey ( string $server_key , array $keys , bool $with_cas = ? , callable $value_cb = ? ) : bool

La funcionalidad de Memcached::getDelayedByKey() es equivalente a la de Memcached::getDelayed(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

keys

Array de claves a solicitar.

with_cas

Si solicitar también los valores del token CAS.

value_cb

La retrollamada de resultados o null.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ver también

  • Memcached::getDelayed() - Obtener varios ítems
  • Memcached::fetch() - Obtener el siguiente resultado
  • Memcached::fetchAll() - Obtener todos los resultados restantes


Obtener varios ítems

  • « Memcached::getDelayedByKey
  • Memcached::getMultiByKey »
  • PHP Manual
  • Memcached
  • Obtener varios ítems

Memcached::getMulti

(PECL memcached >= 0.1.0)

Memcached::getMulti — Obtener varios ítems

Descripción

public Memcached::getMulti ( array $keys , array &$cas_tokens = ? , int $flags = ? ) : mixed

Memcached::getMulti() es similar a Memcached::get(), pero en lugar de un único ítem de clave, obtiene varios ítems cuyas claves se especifican en el array keys. Si se proporciona la variable cas_tokens, esta contendrá los token CAS para los ítems que se hayan encontrado.

Nota:

A diferencia de Memcached::get() no es posible especificar una retrollamada de caché de lectura previa para Memcached::getMulti(), porque el protocolo memcache no provee información de las claves que no se encontraron en la petición de claves múltiple.

El parámetro flags se puede emplear para especificar opciones adicionales para Memcached::getMulti(). Actualmente, la única opción disponible es Memcached::GET_PRESERVE_ORDER, que garantiza que las claves sean devueltas en el mismo orden en que fueron solicitadas.

Parámetros

keys

Array de claves a obtener.

cas_tokens

La variable donde guardar los token CAS de los ítems encontrados.

flags

Los indicadores para la operación de obtención (get).

Valores devueltos

Devuelve el array de ítems encontrados o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getMulti()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$ítems = array(
    'clave1' => 'valor1',
    'clave2' => 'valor2',
    'clave3' => 'valor3'
);
$m->setMulti($ítems);
$resultado = $m->getMulti(array('clave1', 'clave3', 'clave_errónea'), $cas);
var_dump($resultado, $cas);
?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["clave1"]=>
  string(6) "valor1"
  ["clave3"]=>
  string(6) "valor3"
}
array(2) {
  ["clave1"]=>
  float(2360)
  ["clave3"]=>
  float(2362)
}

Ejemplo #2 Ejemplo de Memcached::GET_PRESERVE_ORDER

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$data = array(
    'foo' => 'foo-data',
    'bar' => 'bar-data',
    'baz' => 'baz-data',
    'lol' => 'lol-data',
    'kek' => 'kek-data',
);

$m->setMulti($data, 3600);

$null = null;
$claves = array_keys($data);
$claves[] = 'zoo';
$obtenidas = $m->getMulti($claves, $null, Memcached::GET_PRESERVE_ORDER);

foreach ($obtenidas as $c => $v) {
    echo "$c $v\n";
}
?>

El resultado del ejemplo sería algo similar a:

foo foo-data
bar bar-data
baz baz-data
lol lol-data
kek kek-data
zoo

Ver también

  • Memcached::getMultiByKey() - Recuperar varios ítems de un servidor específico
  • Memcached::get() - Obtener un ítem
  • Memcached::getDelayed() - Obtener varios ítems


Recuperar varios ítems de un servidor específico

  • « Memcached::getMulti
  • Memcached::getOption »
  • PHP Manual
  • Memcached
  • Recuperar varios ítems de un servidor específico

Memcached::getMultiByKey

(PECL memcached >= 0.1.0)

Memcached::getMultiByKey — Recuperar varios ítems de un servidor específico

Descripción

public Memcached::getMultiByKey ( string $server_key , array $keys , string &$cas_tokens = ? , int $flags = ? ) : array

La funcionalidad de Memcached::getMultiByKey() es equivalente a la de Memcached::getMulti(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

keys

Array de claves a obtener.

cas_tokens

La variables donde almacenar los token CAS de los ítems encontrados.

flags

Los indicadores para la operación de obtención (get).

Valores devueltos

Devuelve el array de ítems encontrados o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ver también

  • Memcached::getMulti() - Obtener varios ítems
  • Memcached::get() - Obtener un ítem
  • Memcached::getDelayed() - Obtener varios ítems


Obtener el valor de una opción de Memcached

  • « Memcached::getMultiByKey
  • Memcached::getResultCode »
  • PHP Manual
  • Memcached
  • Obtener el valor de una opción de Memcached

Memcached::getOption

(PECL memcached >= 0.1.0)

Memcached::getOption — Obtener el valor de una opción de Memcached

Descripción

public Memcached::getOption ( int $option ) : mixed

Este método devuelve el valor de la opción de Memcached dada por option. Algunas opciones se corresonden con las definidas por libmemcached, y otras son específicas de la extensión. Ver Constantes de Memcached para más información.

Parámetros

option

Una de las constantes Memcached::OPT_*.

Valores devueltos

Devuelve el valor de la opción solicitada, o false en caso de error.

Ejemplos

Ejemplo #1 Obtener opciones de Memcached

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_COMPRESSION));
var_dump($m->getOption(Memcached::OPT_POLL_TIMEOUT));
?>

El resultado del ejemplo sería algo similar a:

bool(true)
int(1000)

Ver también

  • Memcached::getOption()
  • Memcached::setOption() - Establecer una opción de Memcached
  • Constantes de Memcached


Devuelve el código resultante de la última operación

  • « Memcached::getOption
  • Memcached::getResultMessage »
  • PHP Manual
  • Memcached
  • Devuelve el código resultante de la última operación

Memcached::getResultCode

(PECL memcached >= 0.1.0)

Memcached::getResultCode — Devuelve el código resultante de la última operación

Descripción

public Memcached::getResultCode ( ) : int

Memcached::getResultCode() devuelve una de las constantes Memcached::RES_*, la cual es el resultado del último método de Memcached ejecutado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El código resultante de la última operación de Memcached.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getResultCode()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar');
if ($m->getResultCode() == Memcached::RES_NOTSTORED) {
    /* ... */
}
?>


Devolver un mensaje que describe el resultado de la última operación

  • « Memcached::getResultCode
  • Memcached::getServerByKey »
  • PHP Manual
  • Memcached
  • Devolver un mensaje que describe el resultado de la última operación

Memcached::getResultMessage

(PECL memcached >= 1.0.0)

Memcached::getResultMessage — Devolver un mensaje que describe el resultado de la última operación

Descripción

public Memcached::getResultMessage ( ) : string

Memcached::getResultMessage() devuelve un string que describe el código resultante del último método de Memcached ejecutado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un mensaje que describe el resultado de la última operación Memcached.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getResultMessage()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar'); // la primera vez debería funcionar
$m->add('foo', 'bar');
echo $m->getResultMessage(),"\n";
?>

El resultado del ejemplo sería:

NOT STORED


Hacer corresponder una clave con un servidor

  • « Memcached::getResultMessage
  • Memcached::getServerList »
  • PHP Manual
  • Memcached
  • Hacer corresponder una clave con un servidor

Memcached::getServerByKey

(PECL memcached >= 0.1.0)

Memcached::getServerByKey — Hacer corresponder una clave con un servidor

Descripción

public Memcached::getServerByKey ( string $server_key ) : array

Memcached::getServerByKey() devuelve el servidor que será seleccionado por una clave dada por server_key en particular para todas las operaciones Memcached::*ByKey().

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

Valores devueltos

Devuelve un array que contiene tres claves: host, port, y weight en caso de éxito, o false en case de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getServerByKey()

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.dominio.com', 11211, 40),
    array('mem2.dominio.com', 11211, 40),
    array('mem3.dominio.com', 11211, 20),
));

$m->setOption(Memcached::OPT_LIBKETAMA_COMPATIBLE, true);

var_dump($m->getServerByKey('user'));
var_dump($m->getServerByKey('log'));
var_dump($m->getServerByKey('ip'));
?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["host"]=>
  string(16) "mem3.dominio.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(20)
}
array(3) {
  ["host"]=>
  string(16) "mem2.dominio.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}
array(3) {
  ["host"]=>
  string(16) "mem2.dominio.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}


Obtener la lista de servidores de la agrupación

  • « Memcached::getServerByKey
  • Memcached::getStats »
  • PHP Manual
  • Memcached
  • Obtener la lista de servidores de la agrupación

Memcached::getServerList

(PECL memcached >= 0.1.0)

Memcached::getServerList — Obtener la lista de servidores de la agrupación

Descripción

public Memcached::getServerList ( ) : array

Memcached::getServerList() devuelve la lista de todos los servidores de la agrupación de servidores.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La lista de todos los servidores de la agrupación de servidores.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getServerList()

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.dominio.com', 11211, 20),
    array('mem2.dominio.com', 11311, 80),
));
var_dump($m->getServerList());
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  array(3) {
    ["host"]=>
    string(16) "mem1.dominio.com"
    ["port"]=>
    int(11211)
    ["weight"]=>
    int(20)
  }
  [1]=>
  array(3) {
    ["host"]=>
    string(16) "mem2.dominio.com"
    ["port"]=>
    int(11311)
    ["weight"]=>
    int(80)
  }
}


Obtener las estadísticas de la agrupación de servidores

  • « Memcached::getServerList
  • Memcached::getVersion »
  • PHP Manual
  • Memcached
  • Obtener las estadísticas de la agrupación de servidores

Memcached::getStats

(PECL memcached >= 0.1.0)

Memcached::getStats — Obtener las estadísticas de la agrupación de servidores

Descripción

public Memcached::getStats ( ) : array

Memcached::getStats() devuelve un array que contiene el estado de todos los servidores de memcache disponibles. Ver la especificación del » protocolo de memcache para más información sobre estas estadísticas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array de estadísticas de servidores, una entrada por servidor.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getStats()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getStats());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [localhost:11211] => Array
        (
            [pid] => 4933
            [uptime] => 786123
            [threads] => 1
            [time] => 1233868010
            [pointer_size] => 32
            [rusage_user_seconds] => 0
            [rusage_user_microseconds] => 140000
            [rusage_system_seconds] => 23
            [rusage_system_microseconds] => 210000
            [curr_items] => 145
            [total_items] => 2374
            [limit_maxbytes] => 67108864
            [curr_connections] => 2
            [total_connections] => 151
            [connection_structures] => 3
            [bytes] => 20345
            [cmd_get] => 213343
            [cmd_set] => 2381
            [get_hits] => 204223
            [get_misses] => 9120
            [evictions] => 0
            [bytes_read] => 9092476
            [bytes_written] => 15420512
            [version] => 1.2.6
        )

)


Obtener la información de la versión de la agrupación de servidores

  • « Memcached::getStats
  • Memcached::increment »
  • PHP Manual
  • Memcached
  • Obtener la información de la versión de la agrupación de servidores

Memcached::getVersion

(PECL memcached >= 0.1.5)

Memcached::getVersion — Obtener la información de la versión de la agrupación de servidores

Descripción

public Memcached::getVersion ( ) : array

Memcached::getVersion() devuelve un array que contine la información de la versión de todos los servidores de memcache disponibles.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array de las versiones de los servidores, una entrada por servidor.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::getVersion()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getVersion());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [localhost:11211] => 1.2.6
)


Incrementar un valor numérico de un ítem

  • « Memcached::getVersion
  • Memcached::incrementByKey »
  • PHP Manual
  • Memcached
  • Incrementar un valor numérico de un ítem

Memcached::increment

(PECL memcached >= 0.1.0)

Memcached::increment — Incrementar un valor numérico de un ítem

Descripción

public Memcached::increment ( string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int

Memcached::increment() incrementa un valor numérico de un ítem por el offset especificado. Si el valor del ítem no es numérico, generará un error. Memcached::increment() establecerá el ítem al parámetro initial_value si la clave no existe.

Parámetros

key

La clave del ítem a incrementar.

offset

La cantidad por la que incrementar el valor del ítem.

initial_value

El valor para establecer el ítem si actualmente no existe.

expiry

El periodo de expiración a establecer para el ítem.

Valores devueltos

Devuelve el nuevo valor del ítem en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::increment()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 0);
$m->increment('counter');
$n = $m->increment('counter', 10);
var_dump($n);

$m->set('counter', 'abc');
$n = $m->increment('counter');
// ^ fallará debido a que el valor del ítem no es numérico
var_dump($n);
?>

El resultado del ejemplo sería:

int(11)
bool(false)

Ver también

  • Memcached::decrement() - Decrementar un valor numérico de un ítem
  • Memcached::decrementByKey() - Decrementar un valor numérico de un ítem almacenado en un servidor específico
  • Memcached::incrementByKey() - Incrementar un valor numérico de un ítem, almacenado en un servidor específico


Incrementar un valor numérico de un ítem, almacenado en un servidor específico

  • « Memcached::increment
  • Memcached::isPersistent »
  • PHP Manual
  • Memcached
  • Incrementar un valor numérico de un ítem, almacenado en un servidor específico

Memcached::incrementByKey

(PECL memcached >= 2.0.0)

Memcached::incrementByKey — Incrementar un valor numérico de un ítem, almacenado en un servidor específico

Descripción

public Memcached::incrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int

Memcached::incrementByKey() incrementa un valor numérico de un ítem por el offset especificado. Si el valor del ítem no es numérico, generará un error. Memcached::incrementByKey() establecerá el ítem al parámetro initial_value si la clave no existe.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave del ítem a incrementar.

offset

La cantidad por la que incrementar el valor del ítem.

initial_value

El valor para establecer el ítem si actualmente no existe.

expiry

El periodo de expiración a establecer para el ítem.

Valores devueltos

Devuelve el nuevo valor del ítem en caso de éxito o false en caso de error.

Ver también

  • Memcached::decrement() - Decrementar un valor numérico de un ítem
  • Memcached::decrementByKey() - Decrementar un valor numérico de un ítem almacenado en un servidor específico
  • Memcached::increment() - Incrementar un valor numérico de un ítem


Comprueba si se está utilizando una conexión persistente a memcache

  • « Memcached::incrementByKey
  • Memcached::isPristine »
  • PHP Manual
  • Memcached
  • Comprueba si se está utilizando una conexión persistente a memcache

Memcached::isPersistent

(PECL memcached >= 2.0.0)

Memcached::isPersistent — Comprueba si se está utilizando una conexión persistente a memcache

Descripción

public Memcached::isPersistent ( ) : bool

Memcached::isPersistent() comprueba si las conexiones a los servidores de memcache son conexiones persistentes.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la instancia de Memcache usa una conexión persistente, de lo contrario devuelve false.

Ver también

  • Memcached::isPristine() - Comprobar si la instancia se creó recientemente


Comprobar si la instancia se creó recientemente

  • « Memcached::isPersistent
  • Memcached::prepend »
  • PHP Manual
  • Memcached
  • Comprobar si la instancia se creó recientemente

Memcached::isPristine

(PECL memcached >= 2.0.0)

Memcached::isPristine — Comprobar si la instancia se creó recientemente

Descripción

public Memcached::isPristine ( ) : bool

Memcached::isPristine() comprueba si la instancia de Memcached se creó recientemente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la instancia se creó recientemente, de lo contrario devuelve false.

Ver también

  • Memcached::isPersistent() - Comprueba si se está utilizando una conexión persistente a memcache


Anteponer datos a un ítem existente

  • « Memcached::isPristine
  • Memcached::prependByKey »
  • PHP Manual
  • Memcached
  • Anteponer datos a un ítem existente

Memcached::prepend

(PECL memcached >= 0.1.0)

Memcached::prepend — Anteponer datos a un ítem existente

Descripción

public Memcached::prepend ( string $key , string $value ) : bool

Memcached::prepend() antepone el string dado por value al valor del ítem existente. La razón por la que se fuerza a value a ser un string es debido a que no está bien definida la adición de tipos mixtos.

Nota:

Si Memcached::OPT_COMPRESSION está activado, la operación fallará y se emitirá una advertencia, ya que no es posible anteponer datos comprimidos a un valor que potencialmente ya está comprimido.

Parámetros

key

La clave del ítem en el que anteponer datos.

value

El string a anteponer.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave no existe.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::prepend()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->prepend('foo', 'def');
var_dump($m->get('foo'));
?>

El resultado del ejemplo sería:

string(6) "defabc"

Ver también

  • Memcached::prependByKey() - Anteponer datos a un ítem existente en un servidor específico
  • Memcached::append() - Añadir datos a un ítem existente


Anteponer datos a un ítem existente en un servidor específico

  • « Memcached::prepend
  • Memcached::quit »
  • PHP Manual
  • Memcached
  • Anteponer datos a un ítem existente en un servidor específico

Memcached::prependByKey

(PECL memcached >= 0.1.0)

Memcached::prependByKey — Anteponer datos a un ítem existente en un servidor específico

Descripción

public Memcached::prependByKey ( string $server_key , string $key , string $value ) : bool

La funcionalidad de Memcached::prependByKey() es equivalente a la de Memcached::prepend(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave del ítem en el que anteponer datos.

value

El string a anteponer.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave no existe.

Ver también

  • Memcached::prepend() - Anteponer datos a un ítem existente
  • Memcached::append() - Añadir datos a un ítem existente


Cierra cualquier conexión abierta

  • « Memcached::prependByKey
  • Memcached::replace »
  • PHP Manual
  • Memcached
  • Cierra cualquier conexión abierta

Memcached::quit

(PECL memcached >= 2.0.0)

Memcached::quit — Cierra cualquier conexión abierta

Descripción

public Memcached::quit ( ) : bool

Memcached::quit() cierra las conexiones abiertas a los servidores de memcache.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Reemplaza un ítem asociado a una clave existente

  • « Memcached::quit
  • Memcached::replaceByKey »
  • PHP Manual
  • Memcached
  • Reemplaza un ítem asociado a una clave existente

Memcached::replace

(PECL memcached >= 0.1.0)

Memcached::replace — Reemplaza un ítem asociado a una clave existente

Descripción

public Memcached::replace ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::replace() es similar a Memcached::set(), pero la operación fallará si la clave dada por key no existe en el servidor.

Parámetros

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave no existe.

Ver también

  • Memcached::replaceByKey() - Reemplazar un ítem bajo una clave existente en un servidor específico
  • Memcached::set() - Guardar un ítem
  • Memcached::add() - Añade un ítem asociado a una nueva clave


Reemplazar un ítem bajo una clave existente en un servidor específico

  • « Memcached::replace
  • Memcached::resetServerList »
  • PHP Manual
  • Memcached
  • Reemplazar un ítem bajo una clave existente en un servidor específico

Memcached::replaceByKey

(PECL memcached >= 0.1.0)

Memcached::replaceByKey — Reemplazar un ítem bajo una clave existente en un servidor específico

Descripción

public Memcached::replaceByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

La funcionalidad de Memcached::replaceByKey() es equivalente a la de Memcached::replace(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico. Es útil si se necesita relacionar cierta cantidad de claves a un servidor determinado.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Memcached::getResultCode() devolverá Memcached::RES_NOTSTORED si la clave no existe.

Ver también

  • Memcached::replace() - Reemplaza un ítem asociado a una clave existente
  • Memcached::set() - Guardar un ítem
  • Memcached::add() - Añade un ítem asociado a una nueva clave


Limpia todos los servidores de la lista de servidores

  • « Memcached::replaceByKey
  • Memcached::set »
  • PHP Manual
  • Memcached
  • Limpia todos los servidores de la lista de servidores

Memcached::resetServerList

(PECL memcached >= 2.0.0)

Memcached::resetServerList — Limpia todos los servidores de la lista de servidores

Descripción

public Memcached::resetServerList ( ) : bool

Memcached::resetserverlist() elimina todos los servidores de memcache de la lista de servidores conocidos, dejándola vacía de nuevo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • Memcached::addServer() - Añade un servidor a la provisión de servidores
  • Memcached::addServers() - Añadir varios servidores a la agrupación de servidores


Guardar un ítem

  • « Memcached::resetServerList
  • Memcached::setByKey »
  • PHP Manual
  • Memcached
  • Guardar un ítem

Memcached::set

(PECL memcached >= 0.1.0)

Memcached::set — Guardar un ítem

Descripción

public Memcached::set ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::set() guarda el valor dado por value en un servidor de memcached bajo la clave especificada por key. El parámetro expiration se puede emplear para controlar cuándo se considera que ha expirado el valor.

El valor puede ser cualquier tipo de PHP válido excepto recursos, ya que estos no se pueden representar de forma serializada. Si la opción Memcached::OPT_COMPRESSION está activada, el valor serializado será además comprimido antes de guardarlo.

Parámetros

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::set()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'una cadena sencilla');
$m->set('array', array(11, 12));
/* la clave 'object' expirará en 5 minutos */
$m->set('object', new stdclass, time() + 300);

var_dump($m->get('int'));
var_dump($m->get('string'));
var_dump($m->get('array'));
var_dump($m->get('object'));
?>

El resultado del ejemplo sería algo similar a:

int(99)
string(19) "una cadena sencilla"
array(2) {
  [0]=>
  int(11)
  [1]=>
  int(12)
}
object(stdClass)#1 (0) {
}

Ver también

  • Memcached::setByKey() - Guardar un ítem en un servidor específico
  • Memcached::add() - Añade un ítem asociado a una nueva clave
  • Memcached::replace() - Reemplaza un ítem asociado a una clave existente


Guardar un ítem en un servidor específico

  • « Memcached::set
  • Memcached::setMulti »
  • PHP Manual
  • Memcached
  • Guardar un ítem en un servidor específico

Memcached::setByKey

(PECL memcached >= 0.1.0)

Memcached::setByKey — Guardar un ítem en un servidor específico

Descripción

public Memcached::setByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

La funcionalidad de Memcached::setByKey() es equivalente a la de Memcached::set(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico. Es útil si se necesita relacionar cierta cantidad de claves a un servidor determinado.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

value

El valor a guardar.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::setByKey()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* mantener los bloques de IP en un servidor determinado */
$m->setByKey('api-cache', 'block-ip:169.254.253.252', 1);
$m->setByKey('api-cache', 'block-ip:169.127.127.202', 1);
?>

Ver también

  • Memcached::set() - Guardar un ítem


Almacenar varios ítems

  • « Memcached::setByKey
  • Memcached::setMultiByKey »
  • PHP Manual
  • Memcached
  • Almacenar varios ítems

Memcached::setMulti

(PECL memcached >= 0.1.0)

Memcached::setMulti — Almacenar varios ítems

Descripción

public Memcached::setMulti ( array $items , int $expiration = ? ) : bool

Memcached::setMulti() es similar a Memcached::set(), pero en lugar de almacenar un único ítem de clave/valor, funciona con múltiples ítems especificados en items. El tiempo de expiration se aplica a todos los ítems a la vez.

Parámetros

items

Un array de pares de clave/valor a almacenar en el servidor.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ejemplos

Ejemplo #1 Ejemplo de Memcached::setMulti()

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items, time() + 300);
?>

Ver también

  • Memcached::setMultiByKey() - Almacena varios ítems en un servidor específico
  • Memcached::set() - Guardar un ítem


Almacena varios ítems en un servidor específico

  • « Memcached::setMulti
  • Memcached::setOption »
  • PHP Manual
  • Memcached
  • Almacena varios ítems en un servidor específico

Memcached::setMultiByKey

(PECL memcached >= 0.1.0)

Memcached::setMultiByKey — Almacena varios ítems en un servidor específico

Descripción

public Memcached::setMultiByKey ( string $server_key , array $items , int $expiration = ? ) : bool

La funcionalidad de Memcached::setMultiByKey() es equivalente a la de Memcached::setMulti(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico. Es útil si se necesita relacionar cierta cantidad de claves a un servidor determinado.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

items

Un array de pares de clave/valor a almacenar en el servidor.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ver también

  • Memcached::setMulti() - Almacenar varios ítems
  • Memcached::set() - Guardar un ítem


Establecer una opción de Memcached

  • « Memcached::setMultiByKey
  • Memcached::setOptions »
  • PHP Manual
  • Memcached
  • Establecer una opción de Memcached

Memcached::setOption

(PECL memcached >= 0.1.0)

Memcached::setOption — Establecer una opción de Memcached

Descripción

public Memcached::setOption ( int $option , mixed $value ) : bool

Este método establece el valor de una opción de Memcached dada por option. Algunas opciones corresponden a las definidas por libmemcached y otras son específicas a la extensión. Vea las Constantes de Memcached para más información.

Las opciones enumeradas más abajo requieren valores especificados mediante constantes.

  • Memcached::OPT_HASH require valores Memcached::HASH_*.

  • Memcached::OPT_DISTRIBUTION requiere valores Memcached::DISTRIBUTION_*.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer una opción de Memcached

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
$m->setOption(Memcached::OPT_HASH, Memcached::HASH_MURMUR);
$m->setOption(Memcached::OPT_PREFIX_KEY, "widgets");
echo "El prefijo de las claves ahora es: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

El resultado del ejemplo sería:

bool(true)
El prefijo de las claves ahora es: widgets

Ver también

  • Memcached::getOption() - Obtener el valor de una opción de Memcached
  • Memcached::setOptions() - Establecer opciones de Memcached
  • Constantes de Memcached


Establecer opciones de Memcached

  • « Memcached::setOption
  • Memcached::setSaslAuthData »
  • PHP Manual
  • Memcached
  • Establecer opciones de Memcached

Memcached::setOptions

(PECL memcached >= 2.0.0)

Memcached::setOptions — Establecer opciones de Memcached

Descripción

public Memcached::setOptions ( array $options ) : bool

Memcached::setOptions() es una variación de Memcached::setOption() que toma un array de opciones a establecer.

Parámetros

options

Un array asociativo de opciones donde la clave es la opción a establecer y el valor es el nuevo valor para dicha opción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Establecer opciones de Memcached

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);

$m->setOptions(array(Memcached::OPT_HASH => Memcached::HASH_MURMUR, Memcached::OPT_PREFIX_KEY => "widgets"));

var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
echo "El prefijo de las claves ahora es: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
El prefijo de las claves ahora es: widgets

Ver también

  • Memcached::getOption() - Obtener el valor de una opción de Memcached
  • Memcached::setOption() - Establecer una opción de Memcached
  • Constantes de Memcached


Establecer las credenciales para la autenticación

  • « Memcached::setOptions
  • Memcached::touch »
  • PHP Manual
  • Memcached
  • Establecer las credenciales para la autenticación

Memcached::setSaslAuthData

(PECL memcached >= 2.0.0)

Memcached::setSaslAuthData — Establecer las credenciales para la autenticación

Descripción

public Memcached::setSaslAuthData ( string $username , string $password ) : void

Memcached::setSaslAuthData() establece el nombre de usuario y la contraseña que deberían utilizarse para la autenticación SASL con los servidores de memcache.

Este método solamente está disponible cuando la extensión memcached está construida con soporte para SASL. Consulte la Configuración de memcached para saber cómo se hace esto.

Parámetros

username

El nombre de usuario para la autenticación.

password

La contraseña para la autenticación.

Valores devueltos

No devuelve ningún valor.


Establecer una nueva expiración para un ítem

  • « Memcached::setSaslAuthData
  • Memcached::touchByKey »
  • PHP Manual
  • Memcached
  • Establecer una nueva expiración para un ítem

Memcached::touch

(PECL memcached >= 2.0.0)

Memcached::touch — Establecer una nueva expiración para un ítem

Descripción

public Memcached::touch ( string $key , int $expiration ) : bool

Memcached::touch() establece un nuevo valor de expiración para la clave dada.

Parámetros

key

La clave en la que se guardará el valor.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ver también

  • Memcached::touchByKey() - Establecer una nueva expiración para un ítem de un servidor específico


Establecer una nueva expiración para un ítem de un servidor específico

  • « Memcached::touch
  • MemcachedException »
  • PHP Manual
  • Memcached
  • Establecer una nueva expiración para un ítem de un servidor específico

Memcached::touchByKey

(PECL memcached >= 2.0.0)

Memcached::touchByKey — Establecer una nueva expiración para un ítem de un servidor específico

Descripción

public Memcached::touchByKey ( string $server_key , string $key , int $expiration ) : bool

La funcionalidad de Memcached::touchByKey() es equivalente a la de Memcached::touch(), con la excepción de que server_key se puede utilizar para que la clave dada por key corresponda a un servidor específico.

Parámetros

server_key

La clave que identifica al servidor donde guardar o recuperar el valor. En lugar de realizar un hash en la clave real para el ítem, se realiza en la clave del servidor cuando se decide con qué servidor de memcached conversar. Esto permite que los ítems relacionados sean agrupados en un único servidor para una mayor eficacia con operaciones múltiples.

key

La clave en la que se guardará el valor.

expiration

Tiempo de expiración, que por defecto es 0. Ver Tiempos de expiración para más información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Emplee Memcached::getResultCode() si fuera necesario.

Ver también

  • Memcached::touch() - Establecer una nueva expiración para un ítem


La clase MemcachedException

(PECL memcached >= 0.1.0)

Introducción

Sinopsis de la Clase

MemcachedException extends RuntimeException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


mqseries

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • mqseries Funciones
    • mqseries_back — MQSeries MQBACK
    • mqseries_begin — MQseries MQBEGIN
    • mqseries_close — MQSeries MQCLOSE
    • mqseries_cmit — MQSeries MQCMIT
    • mqseries_conn — MQSeries MQCONN
    • mqseries_connx — MQSeries MQCONNX
    • mqseries_disc — MQSeries MQDISC
    • mqseries_get — MQSeries MQGET
    • mqseries_inq — MQSeries MQINQ
    • mqseries_open — MQSeries MQOPEN
    • mqseries_put1 — MQSeries MQPUT1
    • mqseries_put — MQSeries MQPUT
    • mqseries_set — MQSeries MQSET
    • mqseries_strerror — Returns the error message corresponding to a result code (MQRC)


Introducción

This extension aims to provide an interface for communicating with IBMs WebSphere MQ series Queue managers.

The interface mimics the C-API client interface of WebSphere MQ Series as close as possible. Using the same naming conventions and possibilities of the C-API. In order to understand the workings of this extension some level of understanding the C-API is required.

For MQ-options, MQ-structures, MQ-results etc. please read the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference.


Requerimientos

A working IBM WebSphere MQ installation. If building the extension the SDK for IBM WebSphere MQ is also required.

Nota: Be aware that when running against a IBM WebSphere MQ Client installation some methods are not available. This is not a problem of the extension but just the way the WebSphere MQ Client Interface works.

Installation requirements on non windows platforms

Build the extension and put it in the PHP extension directory.

Installation requirements on Windows

No additional requirements.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/mqseries.

Nota: The official name of this extension is mqseries.

There are two ways to connect to a queue manager. These depend on the way the extension is compiled and linked.

  • First one and also the default one is using the mqic libraries. Compiling and linking the extension against these IBM WebSphere MQSeries libraries allows the extension to connect to the Queue manager using the client interface. Remote connections are possible this way.

  • The other way is to compile and link against the mqm libraries. Using these libraries it is possible to make use of the transaction management of a queue manager.

Currently selecting the libraries to use is done by changing the config.m4 file.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

There are no extra configuration parameters.


Tipos de recursos

This extension defines a connection and object_handle resources.

The mqseries_conn() and mqseries_connx() define the connectionn handles.

The mqseries_open() defines the object handle.


Constantes predefinidas

For each WebSphere MQ Constant there is a mqseries counterpart.

For definitions and usage see the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference red books.

The name of the mqseries counterpart is made by appending the WebSphere MQ constant with MQSERIES_, for example the CompletionCode constants are:

mqseries constants
PHP Constant | MQ Constant
MQSERIES_MQCC_OK | MQCC_OK
MQSERIES_MQCC_WARNING | MQCC_WARNING
MQSERIES_MQCC_FAILED | MQCC_FAILED
MQSERIES_MQCC_UNKNOWN | MQCC_UNKNOWN


mqseries Funciones

Tabla de contenidos

  • mqseries_back — MQSeries MQBACK
  • mqseries_begin — MQseries MQBEGIN
  • mqseries_close — MQSeries MQCLOSE
  • mqseries_cmit — MQSeries MQCMIT
  • mqseries_conn — MQSeries MQCONN
  • mqseries_connx — MQSeries MQCONNX
  • mqseries_disc — MQSeries MQDISC
  • mqseries_get — MQSeries MQGET
  • mqseries_inq — MQSeries MQINQ
  • mqseries_open — MQSeries MQOPEN
  • mqseries_put1 — MQSeries MQPUT1
  • mqseries_put — MQSeries MQPUT
  • mqseries_set — MQSeries MQSET
  • mqseries_strerror — Returns the error message corresponding to a result code (MQRC)


MQSeries MQBACK

  • « mqseries Funciones
  • mqseries_begin »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQBACK

mqseries_back

(PECL mqseries >= 0.10.0)

mqseries_back — MQSeries MQBACK

Descripción

mqseries_back ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_back() (MQBACK) call indicates to the queue manager that all the message gets and puts that have occurred since the last syncpoint are to be backed out. Messages put as part of a unit of work are deleted; messages retrieved as part of a unit of work are reinstated on the queue.

Using mqseries_back() only works in conjunction with mqseries_begin() and only function when connecting directly to a Queueu manager. Not via the mqclient interface.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_back() example

<?php
    mqseries_back($conn, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Notas

Nota:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_begin() - MQseries MQBEGIN


MQseries MQBEGIN

  • « mqseries_back
  • mqseries_close »
  • PHP Manual
  • mqseries Funciones
  • MQseries MQBEGIN

mqseries_begin

(PECL mqseries >= 0.10.0)

mqseries_begin — MQseries MQBEGIN

Descripción

mqseries_begin ( resource $hconn , array $beginOptions , resource &$compCode , resource &$reason ) : void

The mqseries_begin() (MQBEGIN) call begins a unit of work that is coordinated by the queue manager, and that may involve external resource managers.

Using mqseries_begin() starts the unit of work. Either mqseries_back() or mqseries_cmit() ends the unit of work.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_begin() example

<?php
    $mqbo = array();
    mqseries_begin( $conn,
                    $mqbo,
                    $comp_code,
                    $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        /* reason code 2121 is a warning for more information see MQSeries reference manual.*/
        if ($reason !== 2121) {
            printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        }
    }
?>

Notas

Nota:

mqseries_begin() will not function when using MQSeries Client to connect to a Queueu Manager.

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_back() - MQSeries MQBACK
  • mqseries_cmit() - MQSeries MQCMIT


MQSeries MQCLOSE

  • « mqseries_begin
  • mqseries_cmit »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQCLOSE

mqseries_close

(PECL mqseries >= 0.10.0)

mqseries_close — MQSeries MQCLOSE

Descripción

mqseries_close ( resource $hconn , resource $hobj , int $options , resource &$compCode , resource &$reason ) : void

The mqseries_close() (MQCLOSE) call relinquishes access to an object, and is the inverse of the mqseries_open() (MQOPEN) call.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

options

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_close() example

<?php
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("close CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Ver también

  • mqseries_open() - MQSeries MQOPEN
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQCMIT

  • « mqseries_close
  • mqseries_conn »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQCMIT

mqseries_cmit

(PECL mqseries >= 0.10.0)

mqseries_cmit — MQSeries MQCMIT

Descripción

mqseries_cmit ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_cmit() (MQCMIT) call indicates to the queue manager that the application has reached a syncpoint, and that all of the message gets and puts that have occurred since the last syncpoint are to be made permanent. Messages put as part of a unit of work are made available to other applications; messages retrieved as part of a unit of work are deleted.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_cmit() example

<?php
    mqseries_cmit($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("cmit CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Notas

Nota:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

Ver también

  • mqseries_begin() - MQseries MQBEGIN
  • mqseries_back() - MQSeries MQBACK
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQCONN

  • « mqseries_cmit
  • mqseries_connx »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQCONN

mqseries_conn

(PECL mqseries >= 0.10.0)

mqseries_conn — MQSeries MQCONN

Descripción

mqseries_conn ( string $qManagerName , resource &$hconn , resource &$compCode , resource &$reason ) : void

The mqseries_conn() (MQCONN) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent message queuing calls.

Parámetros

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_conn() example

<?php
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("conn CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

Ver también

  • mqseries_disc() - MQSeries MQDISC


MQSeries MQCONNX

  • « mqseries_conn
  • mqseries_disc »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQCONNX

mqseries_connx

(PECL mqseries >= 0.10.0)

mqseries_connx — MQSeries MQCONNX

Descripción

mqseries_connx ( string $qManagerName , array &$connOptions , resource &$hconn , resource &$compCode , resource &$reason ) : void

The mqseries_connx() (MQCONNX) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent MQ calls.

The mqseries_connx() call is like the mqseries_conn() (MQCONN) call, except that MQCONNX allows options to be specified to control the way that the call works.

Parámetros

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

connOps

Options that control the action of function

See also the MQCNO structure.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_connx() example

<?php
    $mqcno = array(
        'Version' => MQSERIES_MQCNO_VERSION_2,
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array('ChannelName' => 'MQNX9420.CLIENT',
        'ConnectionName' => 'localhost',
        'TransportType' => MQSERIES_MQXPT_TCP)
    );

    mqseries_connx('MQNX9420', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

Ejemplo #2 mqseries_connx() example using SSL connection & OCSP Responder URL

<?php
    $mqcno = array(
        'Version' => 4, //MQCNO_VERSION_4
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array(
            'Version' => 7, //MQCD_VERSION_7
            'ConnectionName' => 'localhost',
            'TransportType' => MQSERIES_MQXPT_TCP,
            'ChannelName' => 'CONNECTIONCHANNEL',
            'SSLCipherSpec' => 'NULL_SHA'
        ),
        'MQSCO' => array(
            'KeyRepository' => '/var/mqm/qmgrs/QUEUEMGR/ssl/key', //Local path where the SSL key repository can be found
            'MQAIR' => array(
                'Version' => 2, //MQAIR_VERSION_2
                'AuthInfoType' => 2, //MQAIT_OCSP
                'OCSPResponderURL' => 'http://dummy.OCSP.responder'
            )
        )
    );

    mqseries_connx('QUEUEMGR', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

Ver también

  • mqseries_disc() - MQSeries MQDISC


MQSeries MQDISC

  • « mqseries_connx
  • mqseries_get »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQDISC

mqseries_disc

(PECL mqseries >= 0.10.0)

mqseries_disc — MQSeries MQDISC

Descripción

mqseries_disc ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_disc() (MQDISC) call breaks the connection between the queue manager and the application program, and is the inverse of the mqseries_conn() (MQCONN) or mqseries_connx() (MQCONNX) call.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_disc() example

<?php
    mqseries_disc($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("disc CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQGET

  • « mqseries_disc
  • mqseries_inq »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQGET

mqseries_get

(PECL mqseries >= 0.10.0)

mqseries_get — MQSeries MQGET

Descripción

mqseries_get ( resource $hConn , resource $hObj , array &$md , array &$gmo , int &$bufferLength , string &$msg , int &$data_length , resource &$compCode , resource &$reason ) : void

The mqseries_get() (MQGET) call retrieves a message from a local queue that has been opened using the mqseries_open() (MQOPEN) call

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

gmo

Get message options (MQGMO).

bufferLength

Expected length of the result buffer

msg

Buffer holding the message that was retrieved from the object.

data_length

Actual buffer length

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_get() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connection to the testq queue
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup empty message descriptor.
    $mdg = array();
// setup get message options
    $gmo = array('Options' => MQSERIES_MQGMO_FAIL_IF_QUIESCING | MQSERIES_MQGMO_WAIT, 'WaitInterval' => 3000);

// get the message from the queue
    mqseries_get($conn, $obj, $mdg, $gmo, 255, $msg, $data_length, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("GET CompCode:%d Reason:%d Text:%s<br>", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_put() - MQSeries MQPUT


MQSeries MQINQ

  • « mqseries_get
  • mqseries_open »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQINQ

mqseries_inq

(PECL mqseries >= 0.10.0)

mqseries_inq — MQSeries MQINQ

Descripción

mqseries_inq ( resource $hconn , resource $hobj , int $selectorCount , array $selectors , int $intAttrCount , resource &$intAttr , int $charAttrLength , resource &$charAttr , resource &$compCode , resource &$reason ) : void

The mqseries_inq() (MQINQ) call returns an array of integers and a set of character strings containing the attributes of an object.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrLength

Count of integer attributes.

intAttr

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttr

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_inq() example

<?php
    $int_attr = array();
    $char_attr = "";

    mqseries_inq($conn, $obj, 1, array(MQSERIES_MQCA_Q_MGR_NAME), 0, $int_attr, 48, $char_attr, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("INQ CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    } else {
        echo "INQ QManager name result ".$char_attr."<br>\n";
    }
?>

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN


MQSeries MQOPEN

  • « mqseries_inq
  • mqseries_put1 »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQOPEN

mqseries_open

(PECL mqseries >= 0.10.0)

mqseries_open — MQSeries MQOPEN

Descripción

mqseries_open ( resource $hconn , array &$objDesc , int $option , resource &$hobj , resource &$compCode , resource &$reason ) : void

The mqseries_open() (MQOPEN) call establishes access to an object.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

options

Options that control the action of the function.

hObj

Object handle.

This handle represents the object to be used.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_open() example

<?php
    $mqods = array('ObjectName' => 'TESTQ');
    mqseries_open(
                $conn,
                $mqods,
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

Ver también

  • mqseries_close() - MQSeries MQCLOSE


MQSeries MQPUT1

  • « mqseries_open
  • mqseries_put »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQPUT1

mqseries_put1

(PECL mqseries >= 0.10.0)

mqseries_put1 — MQSeries MQPUT1

Descripción

mqseries_put1 ( resource $hconn , resource &$objDesc , resource &$msgDesc , resource &$pmo , string $buffer , resource &$compCode , resource &$reason ) : void

The mqseries_put1() (MQPUT1) call puts one message on a queue. The queue need not be open.

You can use both the mqseries_put() and mqseries_put1() calls to put messages on a queue; which call to use depends on the circumstances. Use the mqseries_put() (MQPUT) call to place multiple messages on the same queue. Use the mqseries_put1() (MQPUT1) call to put only one message on a queue. This call encapsulates the MQOPEN, MQPUT, and MQCLOSE calls into a single call, minimizing the number of calls that must be issued.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

This is a structure which identifies the queue to which the message is added.

msgDesc

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET


MQSeries MQPUT

  • « mqseries_put1
  • mqseries_set »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQPUT

mqseries_put

(PECL mqseries >= 0.10.0)

mqseries_put — MQSeries MQPUT

Descripción

mqseries_put ( resource $hConn , resource $hObj , array &$md , array &$pmo , string $message , resource &$compCode , resource &$reason ) : void

The mqseries_put() (MQPUT) call puts a message on a queue or distribution list. The queue or distribution list must already be open.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

message

The actual message to put onto the queue.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 mqseries_put() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connectio to the testq queueu
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup the message descriptor array. Check MQSeries reference manuals.
    $md = array(
                'Version' => MQSERIES_MQMD_VERSION_1,
                'Expiry' => MQSERIES_MQEI_UNLIMITED,
                'Report' => MQSERIES_MQRO_NONE,
                'MsgType' => MQSERIES_MQMT_DATAGRAM,
                'Format' => MQSERIES_MQFMT_STRING,
                'Priority' => 1,
                'Persistence' => MQSERIES_MQPER_PERSISTENT);

// setup the put message options.
    $pmo = array('Options' => MQSERIES_MQPMO_NEW_MSG_ID|MQSERIES_MQPMO_SYNCPOINT);

// put the message 'Ping' on the queueu.
    mqseries_put($conn, $obj, $md, $pmo, 'Ping', $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("put CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

Ver también

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET


MQSeries MQSET

  • « mqseries_put
  • mqseries_strerror »
  • PHP Manual
  • mqseries Funciones
  • MQSeries MQSET

mqseries_set

(PECL mqseries >= 0.10.0)

mqseries_set — MQSeries MQSET

Descripción

mqseries_set ( resource $hConn , resource $hObj , int $selectorCount , array $selectors , int $intAttrCount , array $intAttrs , int $charAttrLength , array $charAttrs , resource &$compCode , resource &$reason ) : void

The mqseries_set() (MQSET) call is used to change the attributes of an object represented by a handle. The object must be a queue.

Parámetros

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrCount

Count of integer attributes.

intAttrs

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttrs

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Valores devueltos

No devuelve ningún valor.

Ver también

  • mqseries_inq() - MQSeries MQINQ


Returns the error message corresponding to a result code (MQRC)

  • « mqseries_set
  • Network »
  • PHP Manual
  • mqseries Funciones
  • Returns the error message corresponding to a result code (MQRC)

mqseries_strerror

(PECL mqseries >= 0.10.0)

mqseries_strerror — Returns the error message corresponding to a result code (MQRC)

Descripción

mqseries_strerror ( int $reason ) : string

mqseries_strerror() returns the message that correspond to the reason result code.

Parámetros

reason

Reason code qualifying the compCode.

Valores devueltos

string representation of the reason code message.

Ejemplos

Ejemplo #1 mqseries_strerror() example

<?php
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

El resultado del ejemplo sería:

Connx CompCode:2 Reason:2059 Text:Queue manager not available for connection.


Network

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de red
    • checkdnsrr — Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP
    • closelog — Cerrar conexión al log del sistema
    • dns_check_record — Alias de checkdnsrr
    • dns_get_mx — Alias de getmxrr
    • dns_get_record — Fetch DNS Resource Records associated with a hostname
    • fsockopen — Abre una conexión vía sockets a Internet o a un dominio Unix
    • gethostbyaddr — Obtener el nombre del host de Internet correspondiente a una dirección IP dada
    • gethostbyname — Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
    • gethostbynamel — Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
    • gethostname — Obtiene el nombre de host
    • getmxrr — Obtener los registros MX correspondientes a un nombre de host de Internet
    • getprotobyname — Obtener el número de protocolo asociado con el nombre de protocolo
    • getprotobynumber — Obtiene el nombre de protocolo asociado con un número de protocolo
    • getservbyname — Obtener el número de puerto asociado con un servicio y protocolo de Internet
    • getservbyport — Obtener el servicio de Internet que corresponde con el puerto y protocolo
    • header_register_callback — Llamar a una función de cabecera
    • header_remove — Elimina encabezados previamente establecidos
    • header — Enviar encabezado sin formato HTTP
    • headers_list — Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)
    • headers_sent — Comprueba si o donde han enviado cabeceras
    • http_response_code — Obtener u establecer el código de respuesta HTTP
    • inet_ntop — Convertir una dirección de internet empaquetada en una representación legible por humanos
    • inet_pton — Convertir una dirección IP legible por humanos a su representación in_addr empaquetada
    • ip2long — Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada
    • long2ip — Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
    • openlog — Open connection to system logger
    • pfsockopen — Abre Internet persistente o conexión de socket de dominio Unix
    • setcookie — Enviar una cookie
    • setrawcookie — Enviar una cookie sin codificar su valor
    • socket_get_status — Alias de stream_get_meta_data
    • socket_set_blocking — Alias de stream_set_blocking
    • socket_set_timeout — Alias de stream_set_timeout
    • syslog — Genera un mensaje log de sistema


  • « Network
  • Instalación/Configuración »
  • PHP Manual
  • Network
  • Introducción

Introducción

Provee diversas funciones de red.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Las funciones checkdnsrr(), getmxrr() y dns_get_record() requieren Bind en Linux.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Network Configuration Options
Nombre | Por defecto | Cambiable | Historial de cambios
define_syslog_variables | "0" | PHP_INI_ALL | Obsoleto en PHP 5.3.0. Removido en PHP 5.4.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

define_syslog_variables boolean

Si define o no las diversas variables syslog (por ej., $LOG_PID, $LOG_CRON, etc.). Setearla a off es una buena idea en cuanto a rendimiento se trate. Al momento de ejecución, se pueden definir estas variables al invocar a la función define_syslog_variables().


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un puntero de fichero de tipo resource devuelto por las funciones fsockopen() y pfsockopen().


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

Opciones openlog()
Constante | Descripción
LOG_CONS | Si hay un error mientras se envían datos al registro del sistema, escribir directamente en la consola del sistema
LOG_NDELAY | Abrir la conexión con el registro inmediatamente
LOG_ODELAY | (Predeterminado) Retrasar la apertura de la conexión hasta que el primer mensaje sea registrado
LOG_NOWAIT |
LOG_PERROR | Imprimir también mensajes de registro a la salida de error estándar
LOG_PID | Incluir el PID con cada mensaje
Comodidades de openlog()
Constante | Descripción
LOG_AUTH | Mensajes de seguridad/autorización (utilice en su lugar LOG_AUTHPRIV en sistemas donde esa constante esté definida)
LOG_AUTHPRIV | Mensajes de seguridad/autorización (privados)
LOG_CRON | Servicio de reloj (cron y at)
LOG_DAEMON | Otros servicios del sistema
LOG_KERN | Mensajes del kernel
LOG_LOCAL0 ... LOG_LOCAL7 | Reservado para uso local, estos no están disponibles en Windows
LOG_LPR | Subsistema de línea de la impresora
LOG_MAIL | Subsistema de correo
LOG_NEWS | Subsistema de noticias USENET
LOG_SYSLOG | Mensajes internamente generados por syslogd
LOG_USER | Mensajes genéricos de nivel de usuario
LOG_UUCP | Subsistema de UUCP
Prioridades de syslog() (en orden descendente)
Constante | Descripción
LOG_EMERG | El sistema es inutilizable
LOG_ALERT | Una acción debe ser tomada immediatamente
LOG_CRIT | Condiciones críticas
LOG_ERR | Condiciones de error
LOG_WARNING | Condiciones de alerta
LOG_NOTICE | Condición normal, pero significativa
LOG_INFO | Mensaje informativo
LOG_DEBUG | Mensaje de nivel de depuración
dns_get_record() Options
Constante | Descripción
DNS_A | Recursos de dirección IPv4
DNS_MX | Recurso de intercambiador de correo
DNS_CNAME | Recurso de Alias (Nombre Canónico)
DNS_NS | Recurso de Nombre de Servidor Autorizador
DNS_PTR | Recurso de puntero
DNS_HINFO | Host Info Resource (See IANA's » Operating System Names for the meaning of these values)
DNS_SOA | Start of Authority Resource
DNS_TXT | Text Resource
DNS_ANY | Any Resource Record. On most systems this returns all resource records, however it should not be counted upon for critical uses. Try DNS_ALL instead.
DNS_AAAA | IPv6 Address Resource
DNS_ALL | Iteratively query the name server for each available record type.


Funciones de red

Tabla de contenidos

  • checkdnsrr — Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP
  • closelog — Cerrar conexión al log del sistema
  • dns_check_record — Alias de checkdnsrr
  • dns_get_mx — Alias de getmxrr
  • dns_get_record — Fetch DNS Resource Records associated with a hostname
  • fsockopen — Abre una conexión vía sockets a Internet o a un dominio Unix
  • gethostbyaddr — Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • gethostbyname — Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbynamel — Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
  • gethostname — Obtiene el nombre de host
  • getmxrr — Obtener los registros MX correspondientes a un nombre de host de Internet
  • getprotobyname — Obtener el número de protocolo asociado con el nombre de protocolo
  • getprotobynumber — Obtiene el nombre de protocolo asociado con un número de protocolo
  • getservbyname — Obtener el número de puerto asociado con un servicio y protocolo de Internet
  • getservbyport — Obtener el servicio de Internet que corresponde con el puerto y protocolo
  • header_register_callback — Llamar a una función de cabecera
  • header_remove — Elimina encabezados previamente establecidos
  • header — Enviar encabezado sin formato HTTP
  • headers_list — Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)
  • headers_sent — Comprueba si o donde han enviado cabeceras
  • http_response_code — Obtener u establecer el código de respuesta HTTP
  • inet_ntop — Convertir una dirección de internet empaquetada en una representación legible por humanos
  • inet_pton — Convertir una dirección IP legible por humanos a su representación in_addr empaquetada
  • ip2long — Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada
  • long2ip — Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
  • openlog — Open connection to system logger
  • pfsockopen — Abre Internet persistente o conexión de socket de dominio Unix
  • setcookie — Enviar una cookie
  • setrawcookie — Enviar una cookie sin codificar su valor
  • socket_get_status — Alias de stream_get_meta_data
  • socket_set_blocking — Alias de stream_set_blocking
  • socket_set_timeout — Alias de stream_set_timeout
  • syslog — Genera un mensaje log de sistema


Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP

  • « Funciones de red
  • closelog »
  • PHP Manual
  • Funciones de red
  • Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP

checkdnsrr

(PHP 4, PHP 5, PHP 7, PHP 8)

checkdnsrr — Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP

Descripción

checkdnsrr ( string $host , string $type = "MX" ) : bool

Busca DNS de registros de tipo type que corresponde a un host.

Parámetros

host

host puede ser la dirección IP en notación decimal con puntos o el nombre de host.

type

type puede ser cualquiera de: A, MX, NS, SOA, PTR, CNAME, AAAA, A6, SRV, NAPTR, TXT o ANY.

Valores devueltos

Devuelve true si los registros se encuentran; devuelve false si no se encuentran registros o si ocurre un error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función está disponible en plataformas Windows.
5.2.4 | Se añadió el type TXT.

Notas

Nota:

Por razones de compatibilidad con Windows antes de que esto fuera implementado, se puede intentar con la clase » Net_DNS de » PEAR.

Ver también

  • dns_get_record() - Fetch DNS Resource Records associated with a hostname
  • getmxrr() - Obtener los registros MX correspondientes a un nombre de host de Internet
  • gethostbyaddr() - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • gethostbyname() - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbynamel() - Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
  • the named(8) manual page


Cerrar conexión al log del sistema

  • « checkdnsrr
  • dns_check_record »
  • PHP Manual
  • Funciones de red
  • Cerrar conexión al log del sistema

closelog

(PHP 4, PHP 5, PHP 7, PHP 8)

closelog — Cerrar conexión al log del sistema

Descripción

closelog ( ) : bool

closelog() cierra el descriptor que se utiliza para escribir en el registro del sistema. El uso de closelog() es opcional.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • syslog() - Genera un mensaje log de sistema
  • openlog() - Open connection to system logger


Alias de checkdnsrr

  • « closelog
  • dns_get_mx »
  • PHP Manual
  • Funciones de red
  • Alias de checkdnsrr

dns_check_record

(PHP 5, PHP 7, PHP 8)

dns_check_record — Alias de checkdnsrr()

Descripción

Esta función es un alias de: checkdnsrr().


Alias de getmxrr

  • « dns_check_record
  • dns_get_record »
  • PHP Manual
  • Funciones de red
  • Alias de getmxrr

dns_get_mx

(PHP 5, PHP 7, PHP 8)

dns_get_mx — Alias de getmxrr()

Descripción

Esta función es un alias de: getmxrr().


Fetch DNS Resource Records associated with a hostname

  • « dns_get_mx
  • fsockopen »
  • PHP Manual
  • Funciones de red
  • Fetch DNS Resource Records associated with a hostname

dns_get_record

(PHP 5, PHP 7, PHP 8)

dns_get_record — Fetch DNS Resource Records associated with a hostname

Descripción

dns_get_record ( string $hostname , int $type = DNS_ANY , array &$authoritative_name_servers = null , array &$additional_records = null , bool $raw = false ) : array|false

Fetch DNS Resource Records associated with the given hostname.

Parámetros

hostname

hostname should be a valid DNS hostname such as "www.example.com". Reverse lookups can be generated using in-addr.arpa notation, but gethostbyaddr() is more suitable for the majority of reverse lookups.

Nota:

Per DNS standards, email addresses are given in user.host format (for example: hostmaster.example.com as opposed to hostmaster@example.com), be sure to check this value and modify if necessary before using it with a functions such as mail().

type

By default, dns_get_record() will search for any resource records associated with hostname. To limit the query, specify the optional type parameter. May be any one of the following: DNS_A, DNS_CNAME, DNS_HINFO, DNS_CAA, DNS_MX, DNS_NS, DNS_PTR, DNS_SOA, DNS_TXT, DNS_AAAA, DNS_SRV, DNS_NAPTR, DNS_A6, DNS_ALL or DNS_ANY.

Nota:

Because of eccentricities in the performance of libresolv between platforms, DNS_ANY will not always return every record, the slower DNS_ALL will collect all records more reliably.

Nota:

DNS_CAA is not supported on Windows.

authoritative_name_servers

Passed by reference and, if given, will be populated with Resource Records for the Authoritative Name Servers.

additional_records

Passed by reference and, if given, will be populated with any Additional Records.

raw

The type will be interpreted as a raw DNS type ID (the DNS_* constants cannot be used). The return value will contain a data key, which needs to be manually parsed.

Valores devueltos

This function returns an array of associative arrays, o false en caso de error. Each associative array contains at minimum the following keys:

Basic DNS attributes
Attribute | Meaning
host | The record in the DNS namespace to which the rest of the associated data refers.
class | dns_get_record() only returns Internet class records and as such this parameter will always return IN.
type | String containing the record type. Additional attributes will also be contained in the resulting array dependant on the value of type. See table below.
ttl | "Time To Live" remaining for this record. This will not equal the record's original ttl, but will rather equal the original ttl minus whatever length of time has passed since the authoritative name server was queried.

Other keys in associative arrays dependant on 'type'
Type | Extra Columns
A | ip: An IPv4 addresses in dotted decimal notation.
MX | pri: Priority of mail exchanger. Lower numbers indicate greater priority. target: FQDN of the mail exchanger. See also dns_get_mx().
CNAME | target: FQDN of location in DNS namespace to which the record is aliased.
NS | target: FQDN of the name server which is authoritative for this hostname.
PTR | target: Location within the DNS namespace to which this record points.
TXT | txt: Arbitrary string data associated with this record.
HINFO | cpu: IANA number designating the CPU of the machine referenced by this record. os: IANA number designating the Operating System on the machine referenced by this record. See IANA's » Operating System Names for the meaning of these values.
CAA | flags: A one-byte bitfield; currently only bit 0 is defined, meaning 'critical'; other bits are reserved and should be ignored. tag: The CAA tag name (alphanumeric ASCII string). value: The CAA tag value (binary string, may use subformats). For additional information see: » RFC 6844
SOA | mname: FQDN of the machine from which the resource records originated. rname: Email address of the administrative contact for this domain. serial: Serial # of this revision of the requested domain. refresh: Refresh interval (seconds) secondary name servers should use when updating remote copies of this domain. retry: Length of time (seconds) to wait after a failed refresh before making a second attempt. expire: Maximum length of time (seconds) a secondary DNS server should retain remote copies of the zone data without a successful refresh before discarding. minimum-ttl: Minimum length of time (seconds) a client can continue to use a DNS resolution before it should request a new resolution from the server. Can be overridden by individual resource records.
AAAA | ipv6: IPv6 address
A6(PHP >= 5.1.0) | masklen: Length (in bits) to inherit from the target specified by chain. ipv6: Address for this specific record to merge with chain. chain: Parent record to merge with ipv6 data.
SRV | pri: (Priority) lowest priorities should be used first. weight: Ranking to weight which of commonly prioritized targets should be chosen at random. target and port: hostname and port where the requested service can be found. For additional information see: » RFC 2782
NAPTR | order and pref: Equivalent to pri and weight above. flags, services, regex, and replacement: Parameters as defined by » RFC 2915.

Historial de cambios

Versión | Descripción
7.0.16, 7.1.2 | Added support for CAA record type.

Ejemplos

Ejemplo #1 Using dns_get_record()

<?php
$result = dns_get_record("php.net");
print_r($result);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)

Ejemplo #2 Using dns_get_record() and DNS_ANY

Since it's very common to want the IP address of a mail server once the MX record has been resolved, dns_get_record() also returns an array in additional_records which contains associate records. authoritative_name_servers is returned as well containing a list of authoritative name servers.

<?php
/* Request "ANY" record for php.net,
   and create $authns and $addtl arrays
   containing list of name servers and
   any additional records which go with
   them */
$result = dns_get_record("php.net", DNS_ANY, $authns, $addtl);
echo "Result = ";
print_r($result);
echo "Auth NS = ";
print_r($authns);
echo "Additional = ";
print_r($addtl);
?>

El resultado del ejemplo sería algo similar a:

Result = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)
Auth NS = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [1] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [2] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [3] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

)
Additional = Array
(
    [0] => Array
        (
            [host] => pair2.php.net
            [type] => A
            [ip] => 216.92.131.5
            [class] => IN
            [ttl] => 6766
        )

    [1] => Array
        (
            [host] => remote1.easydns.com
            [type] => A
            [ip] => 64.39.29.212
            [class] => IN
            [ttl] => 100384
        )

    [2] => Array
        (
            [host] => remote2.easydns.com
            [type] => A
            [ip] => 212.100.224.80
            [class] => IN
            [ttl] => 81241
        )

    [3] => Array
        (
            [host] => ns1.easydns.com
            [type] => A
            [ip] => 216.220.40.243
            [class] => IN
            [ttl] => 81241
        )

    [4] => Array
        (
            [host] => ns2.easydns.com
            [type] => A
            [ip] => 216.220.40.244
            [class] => IN
            [ttl] => 81241
        )

)

Notas

Nota:

For compatibility with versions before PHP 5.3.0 on some operating systems, try the » PEAR class » Net_DNS.

Ver también

  • dns_get_mx() - Alias de getmxrr
  • dns_check_record() - Alias de checkdnsrr


Abre una conexión vía sockets a Internet o a un dominio Unix

  • « dns_get_record
  • gethostbyaddr »
  • PHP Manual
  • Funciones de red
  • Abre una conexión vía sockets a Internet o a un dominio Unix

fsockopen

(PHP 4, PHP 5, PHP 7, PHP 8)

fsockopen — Abre una conexión vía sockets a Internet o a un dominio Unix

Descripción

fsockopen ( string $hostname , int $port = -1 , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") ) : resource

Inicia una conexión vía sockets al recurso especificado por hostname.

PHP soporta objetivos Internet y dominios Unix tal y como se describe en Lista de Transportes de Sockets Soportados. También se puede obtener una lista de los transportes soportados utilizando stream_get_transports().

El socket será abierto por defecto en modo de bloqueo. Es posible cambiarlo a modo de no bloqueo utilizando stream_set_blocking().

La función stream_socket_client() es similar, pero provee un conjunto más amplio de opciones, incluyendo conexión no bloqueante y la posibilidad de proporcionar contexto a una secuencia.

Parámetros

hostname

Si el soporte a OpenSSL está instalado, puedes añadir al principio del hostname tanto ssl:// como tls:// para utilizar una conexión de cliente SSL o TLS sobre TCP/IP para conectar al host remoto.

port

El número de puerto. Se puede omitir con -1 para transportes que no empleen puertos, como unix://.

errno

Si se proporciona, contiene el número de error a nivel de sistema que se ha producido en la llamada a connect() a nivel de sistema.

Si el valor devuelto en errno es 0 y la función devuelve false, esto indica que el error ocurrió antes de la llamada a connect(). Probablemente se deba a un problema al inicializar el socket.

errstr

El mensaje de error como string.

timeout

El tiempo límite de la conexión, en segundos.

Nota:

Si fuera necesario definir un tiempo de límite para leer/escribir datos a través del socket, se deberá utilizar stream_set_timeout(), ya que el parámetro timeout de fsockopen() sólo se aplica al realizar la conexión del socket.

Valores devueltos

fsockopen() devuelve un puntero a fichero que puede ser utilizado junto a otras funciones de fichero (como fgets(), fgetss(), fwrite(), fclose(), y feof()). Si la llamada falla, devolverá false

Errores/Excepciones

Lanza E_WARNING si el hostname no es un dominio válido.

Ejemplos

Ejemplo #1 Ejemplo de fsockopen()

<?php
$fp = fsockopen("www.example.com", 80, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    $out = "GET / HTTP/1.1\r\n";
    $out .= "Host: www.example.com\r\n";
    $out .= "Connection: Close\r\n\r\n";
    fwrite($fp, $out);
    while (!feof($fp)) {
        echo fgets($fp, 128);
    }
    fclose($fp);
}
?>

Ejemplo #2 Utilización de una conexión UDP

El ejemplo inferior muestra cómo obtener el día y la hora del servicio UDP "daytime" (puerto 13) en el servidor local.

<?php
$fp = fsockopen("udp://127.0.0.1", 13, $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Notas

Nota:

Dependiendo del entorno, el dominio Unix o el tiempo de expiración opcional pueden no estar disponibles.

Advertencia

Los sockets UDP pueden en ocasiones aparecerán como abiertos sin errores, incluso aunque el servidor remoto no esté disponible. El error sólo aparecerá una vez se lean o escriban datos del/al socket. Esto es debido a que UDP es un protoclo "sin conexión", lo que significa que el sistema operativo no trata de establecer un enlace con el socket hasta que realmente necesita enviar o recibir datos.

Nota: Cuando se especifique una dirección numérica IPv6 (por ej., fe80::1), la IP debe ser encerrada entre corchetes — por ejemplo, tcp://[fe80::1]:80.

Ver también

  • pfsockopen() - Abre Internet persistente o conexión de socket de dominio Unix
  • stream_socket_client() - Abrir una conexión de socket de dominio de Internet o Unix
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo
  • stream_set_timeout() - Establecer un perido de tiempo de espera en un flujo
  • fgets() - Obtiene una línea desde el puntero a un fichero
  • fgetss() - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
  • fwrite() - Escritura de un archivo en modo binario seguro
  • fclose() - Cierra un puntero a un archivo abierto
  • feof() - Comprueba si el puntero a un archivo está al final del archivo
  • socket_connect() - Inicia una conexión sobre un socket
  • La extensión Curl


Obtener el nombre del host de Internet correspondiente a una dirección IP dada

  • « fsockopen
  • gethostbyname »
  • PHP Manual
  • Funciones de red
  • Obtener el nombre del host de Internet correspondiente a una dirección IP dada

gethostbyaddr

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbyaddr — Obtener el nombre del host de Internet correspondiente a una dirección IP dada

Descripción

gethostbyaddr ( string $ip_address ) : string

Devuelve el nombre del host de Internet especificado por ip_address.

Parámetros

ip_address

La dirección IP del servidor huésped.

Valores devueltos

Devuelve el nombre de host en caso de éxito, la ip_address sin modificar en caso de fallo, o false en caso de que la entrada tenga un formato incorrecto.

Ejemplos

Ejemplo #1 Un ejemplo sencillo de gethostbyaddr()

<?php
$nombre_host = gethostbyaddr($_SERVER['REMOTE_ADDR']);

echo $nombre_host;
?>

Ver también

  • gethostbyname() - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbynamel() - Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado


Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado

  • « gethostbyaddr
  • gethostbynamel »
  • PHP Manual
  • Funciones de red
  • Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado

gethostbyname

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbyname — Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado

Descripción

gethostbyname ( string $hostname ) : string

Devuelve la dirección IPv4 del host de Internet especificado por hostname.

Parámetros

hostname

El nombre de host.

Valores devueltos

Devuelve la dirección IPv4 o un string que contiene el hostname sin modificar en caso de error.

Ejemplos

Ejemplo #1 Ejemplo simple de gethostbyname()

<?php
$ip = gethostbyname('www.example.com');

echo $ip;
?>

Ver también

  • gethostbyaddr() - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • gethostbynamel() - Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
  • inet_pton() - Convertir una dirección IP legible por humanos a su representación in_addr empaquetada
  • inet_ntop() - Convertir una dirección de internet empaquetada en una representación legible por humanos


Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado

  • « gethostbyname
  • gethostname »
  • PHP Manual
  • Funciones de red
  • Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado

gethostbynamel

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbynamel — Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado

Descripción

gethostbynamel ( string $hostname ) : array

Devuelve una lista de direcciones IPv4 a la que el host de Internet especificado por hostname resuelve.

Parámetros

hostname

El nombre de host.

Valores devueltos

Devuelve un array de direcciones IPv4 o false si hostname no se pudo resolver.

Ejemplos

Ejemplo #1 Ejemplo de gethostbynamel()

<?php
$hosts = gethostbynamel('www.example.com');
print_r($hosts);
?>

El resultado del ejemplo sería:

Array
(
    [0] => 192.0.34.166
)

Ver también

  • gethostbyname() - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbyaddr() - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • checkdnsrr() - Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP
  • getmxrr() - Obtener los registros MX correspondientes a un nombre de host de Internet
  • the named(8) manual page


Obtiene el nombre de host

  • « gethostbynamel
  • getmxrr »
  • PHP Manual
  • Funciones de red
  • Obtiene el nombre de host

gethostname

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gethostname — Obtiene el nombre de host

Descripción

gethostname ( ) : string

gethostname() obtiene el nombre de host estándar para el equipo local.

Valores devueltos

Devuelve un string con el nombre de host en caso de éxito, false en caso contrario.

Ejemplos

Ejemplo #1 Un ejemplo simple de gethostname()

<?php
echo gethostname(); //puede imprimir: sandie

// O, una opción que también funciona antes de PHP 5.3
echo php_uname('n'); //puede imprimir: sandie
?>

Ver también

  • gethostbyname() - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbyaddr() - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • php_uname() - Devuelve información sobre el sistema operativo en que se está ejecutando PHP


Obtener los registros MX correspondientes a un nombre de host de Internet

  • « gethostname
  • getprotobyname »
  • PHP Manual
  • Funciones de red
  • Obtener los registros MX correspondientes a un nombre de host de Internet

getmxrr

(PHP 4, PHP 5, PHP 7, PHP 8)

getmxrr — Obtener los registros MX correspondientes a un nombre de host de Internet

Descripción

getmxrr ( string $hostname , array &$mxhosts , array &$weight = ? ) : bool

Busca DNS para registros MX correspondientes a hostname.

Parámetros

hostname

El nombre de host de Internet.

mxhosts

Una lista de los registros MX encontrados se coloca en el array mxhosts.

weight

Si se proporciona el array weight, será rellenado con el peso de la información recopilada.

Valores devueltos

Devuelve true si se encuentra cualquier registro; false si no se encuentran registros o si ocurre un error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Notas

Nota:

Esto función no debería utilizarse con propósitos de verificación de direcciones. Solamente se devuelven los intercambiadores de correo en contrados en DNS, sin embargo, según el » RFC 2821 cuando no se enumera ningún intercambiador de correo, debería utlizarse el mismo hostname como el único intercambiador de correo con una prioridad de 0.

Nota:

Por compatibilidad con Windows antes de que fuera implementada, se puede intentar con las clase » Net_DNS de » PEAR.

Ver también

  • checkdnsrr() - Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP
  • dns_get_record() - Fetch DNS Resource Records associated with a hostname
  • gethostbyname() - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbynamel() - Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
  • gethostbyaddr() - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
  • La página named(8) del manual


Obtener el número de protocolo asociado con el nombre de protocolo

  • « getmxrr
  • getprotobynumber »
  • PHP Manual
  • Funciones de red
  • Obtener el número de protocolo asociado con el nombre de protocolo

getprotobyname

(PHP 4, PHP 5, PHP 7, PHP 8)

getprotobyname — Obtener el número de protocolo asociado con el nombre de protocolo

Descripción

getprotobyname ( string $name ) : int

getprotobyname() devuelve el número de protocolo asociado con el name de protocolo, indicado por /etc/protocols.

Parámetros

name

El nombre del protocolo.

Valores devueltos

Devuelve el número del protocolo, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de getprotobyname()

<?php
$protocolo = 'tcp';
$obtener_prot = getprotobyname($protocolo);
if ($get_prot === FALSE) {
    echo 'Protocolo Inválido';
} else {
    echo 'Protocolo #' . $obtener_prot;
}
?>

Ver también

  • getprotobynumber() - Obtiene el nombre de protocolo asociado con un número de protocolo


Obtiene el nombre de protocolo asociado con un número de protocolo

  • « getprotobyname
  • getservbyname »
  • PHP Manual
  • Funciones de red
  • Obtiene el nombre de protocolo asociado con un número de protocolo

getprotobynumber

(PHP 4, PHP 5, PHP 7, PHP 8)

getprotobynumber — Obtiene el nombre de protocolo asociado con un número de protocolo

Descripción

getprotobynumber ( int $number ) : string

getprotobynumber() devuelve el nombre de protocolo asociado con el numero de procotolo, como lo indica /etc/protocols.

Parámetros

number

El número del protocolo.

Valores devueltos

Devuelve el nombre del protocolo como una cadena, o false en caso de error.

Ver también

  • getprotobyname() - Obtener el número de protocolo asociado con el nombre de protocolo


Obtener el número de puerto asociado con un servicio y protocolo de Internet

  • « getprotobynumber
  • getservbyport »
  • PHP Manual
  • Funciones de red
  • Obtener el número de puerto asociado con un servicio y protocolo de Internet

getservbyname

(PHP 4, PHP 5, PHP 7, PHP 8)

getservbyname — Obtener el número de puerto asociado con un servicio y protocolo de Internet

Descripción

getservbyname ( string $service , string $protocol ) : int

getservbyname() devuelve el puerto de Internet que corresponde a service para el protocol especificado, de acuerdo a /etc/services.

Parámetros

service

El nombre del servicio de Internet, como una cadena.

protocol

protocol es un valor entre "tcp" o "udp" (es minúsculas).

Valores devueltos

Devuelve el número de puerto, o false si service o protocol no son encontrados.

Ejemplos

Ejemplo #1 Ejemplo de getservbyname()

<?php
$servicios = array('http', 'ftp', 'ssh', 'telnet', 'imap',
'smtp', 'nicname', 'gopher', 'finger', 'pop3', 'www');

foreach ($servicios as $servicio) {
    $puerto = getservbyname($servicio, 'tcp');
    echo $servicio . ": " . $puerto . "<br />\n";
}
?>

Ver también

  • getservbyport() - Obtener el servicio de Internet que corresponde con el puerto y protocolo
  • » http://www.iana.org/assignments/port-numbers para una lista completa de números de puerto.


Obtener el servicio de Internet que corresponde con el puerto y protocolo

  • « getservbyname
  • header_register_callback »
  • PHP Manual
  • Funciones de red
  • Obtener el servicio de Internet que corresponde con el puerto y protocolo

getservbyport

(PHP 4, PHP 5, PHP 7, PHP 8)

getservbyport — Obtener el servicio de Internet que corresponde con el puerto y protocolo

Descripción

getservbyport ( int $port , string $protocol ) : string

getservbyport() devuelve el servicio de Internet asociado con port para el protocol especificado, de acuerdo a /etc/services.

Parámetros

port

El número de puerto.

protocol

protocol es un valor entre "tcp" o "udp" (en minúsculas).

Valores devueltos

Devuelve el nombre del servicio de Internet como una cadena.

Ver también

  • getservbyname() - Obtener el número de puerto asociado con un servicio y protocolo de Internet


Llamar a una función de cabecera

  • « getservbyport
  • header_remove »
  • PHP Manual
  • Funciones de red
  • Llamar a una función de cabecera

header_register_callback

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

header_register_callback — Llamar a una función de cabecera

Descripción

header_register_callback ( callable $callback ) : bool

Registra una función que será llamada cuando PHP comienza a enviar la salida.

El callback se ejecuta inmediatamente después de PHP prepara todos los encabezados que van a ser enviados, y antes de cualquier otra salida es enviado, crea una ventana para manipular las cabeceras de salida antes de ser enviado.

Parámetros

callback

Función llamada justo antes de que se envíen los encabezados. No tiene parámetros y el valor de retorno se ignora.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 header_register_callback() example

<?php

header('Content-Type: text/plain');
header('X-Test: foo');

function foo() {
 foreach (headers_list() as $header) {
   if (strpos($header, 'X-Powered-By:') !== false) {
     header_remove('X-Powered-By');
   }
   header_remove('X-Test');
 }
}

$result = header_register_callback('foo');
echo "a";
?>

El resultado del ejemplo sería algo similar a:

Content-Type: text/plain

a

Notas

La función header_register_callback() es ejecutada cuando las cabeceras están a punto de ser enviadas, por lo que cualquier salida de esta función puede romper de salida.

Nota:

Las cabeceras sólo serán accesibles y mostradas si se utiliza un SAPI que lo soporte.

Ver también

  • headers_list() - Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)
  • header_remove() - Elimina encabezados previamente establecidos
  • header() - Enviar encabezado sin formato HTTP


Elimina encabezados previamente establecidos

  • « header_register_callback
  • header »
  • PHP Manual
  • Funciones de red
  • Elimina encabezados previamente establecidos

header_remove

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

header_remove — Elimina encabezados previamente establecidos

Descripción

header_remove ( string $name = ? ) : void

Elimina un encabezado HTTP previamente establecido con header().

Parámetros

name

El nombre del encabezado a ser eliminado.

Nota: Este parámetro es insensible a mayúsculas y minúsculas.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Eliminar un encabezado específico.

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove("X-Foo");
?>

El resultado del ejemplo sería algo similar a:

X-Bar: Baz

Ejemplo #2 Eliminar todos los encabezados previamente establecidos.

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove();
?>

El resultado del ejemplo sería algo similar a:

Notas

Precaución

    Esta función elimina todos los encabezados establecidos por PHP,
    incluyendo las cookies, las sesiones y las cabeceras X-Powered-By.

Nota:

 Las cabeceras sólo serán accesibles y mostradas si se utiliza un SAPI
 que lo soporte.

Ver también

  • header() - Enviar encabezado sin formato HTTP
    •

  • headers_sent() - Comprueba si o donde han enviado cabeceras
    •


Enviar encabezado sin formato HTTP

  • « header_remove
  • headers_list »
  • PHP Manual
  • Funciones de red
  • Enviar encabezado sin formato HTTP

header

(PHP 4, PHP 5, PHP 7, PHP 8)

header — Enviar encabezado sin formato HTTP

Descripción

header ( string $string , bool $replace = true , int $http_response_code = ? ) : void

header() es usado para enviar encabezados HTTP sin formato. Ver la especificación » HTTP/1.1 specification para más información sobre encabezados HTTP.

Recuerde que header() debe ser llamado antes de mostrar nada por pantalla, etiquetas HTML, líneas en blanco desde un fichero o desde PHP. Es un error muy común leer código con funciones como include o require, u otro tipo de funciones de acceso de ficheros que incluyen espacios o líneas en blanco que se muestran antes de llamar a la función header(). Sucede el mismo problema cuando se utiliza un solo fichero PHP/HTML.

<html>
<?php
/* Esto producirá un error. Fíjese en el html
 * que se muestra antes que la llamada a header() */
header('Location: http://www.example.com/');
exit;
?>

Parámetros

string

El encabezado en formato cadena.

Existen dos casos especiales en el uso de header. El primero el encabezado que empieza con la cadena "HTTP/" (las mayúsculas no son importantes), es utilizado para averiguar el código de status HTTP a enviar. Por ejemplo, si se tiene Apache configurado para usar un script en PHP para controlar las peticiones a ficheros no encontrados (usando la directiva ErrorDocument), querrá asegurarse de que el script genera el código de status que corresponde.

<?php
header("HTTP/1.0 404 Not Found");
?>

El segundo caso especial es el encabezado "Location:" No solamente envía el encabezado al navegador, sino que también devuelve el código de status (302) REDIRECT al navegador a no ser que el código de status 201 o 3xx ya haya sido enviado.

<?php
header("Location: http://www.example.com/"); /* Redirección del navegador */

/* Asegurándonos de que el código interior no será ejecutado cuando se realiza la redirección. */
exit;
?>

replace

El parámetro opcional replace indica cuando el encabezado debe reemplazar un encabezado previo similar o añadir un segundo encabezado del mismo tipo. Por defecto lo reemplazará, pero si se pasa false como segundo argumento se puede forzar múltiples encabezados del mismo tipo. Por ejemplo:

<?php
header('WWW-Authenticate: Negotiate');
header('WWW-Authenticate: NTLM', false);
?>

http_response_code

Fuerza el código de respuesta HTTP a un valor específico. Observe que este parámetro solamente tiene efecto si string no está vacío.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.1.2 | Esta función ahora previene que se pueda enviar más de un encabezado a la vez como protección en contra de ataques de inyección de encabezados.

Ejemplos

Ejemplo #1 Diálogo de descarga

Si se quiere preguntar al usuario si quiere guardar los datos que se están enviando, como un fichero PDF generado, puede usarse el encabezado » Content-Disposition para proporcionar un nombre de fichero recomendado y forzar al navegador a mostrar el diálogo para guardar el fichero.

<?php
// Vamos a mostrar un PDF
header('Content-type: application/pdf');

// Se llamará downloaded.pdf
header('Content-Disposition: attachment; filename="downloaded.pdf"');

// La fuente de PDF se encuentra en original.pdf
readfile('original.pdf');
?>

Ejemplo #2 Directivas caché

Scripts PHP normalmente generan contenido dinámico que no debe ser puesto en caché por el navegador cliente o por ningún proxy caché entre el servidor y el navegador cliente. En muchos proxies y clientes se puede forzar la desactivación de la caché con:

<?php
header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Fecha en el pasado
?>

Nota:

Seguramente encontrará que sus páginas no están en caché incluso si no se usan los encabezados mencionados más arriba. Existen varias opciones que los usuarios pueden cambiar en sus navegadores para cambiar el comportamiento por defecto de la caché. Al enviar los encabezados mencionados más arriba, se sobreescrirán cualquiera de las opciones que intentan guardar en caché lo que muestre su script.

Adicionalmente, las opciones de configuración de session_cache_limiter() y session.cache_limiter pueden ser usadas para generar automáticamente encabezados caché cuando se están usando sesiones.

Notas

Nota:

Las cabeceras sólo serán accesibles y mostradas si se utiliza un SAPI que lo soporte.

Nota:

Se puede usar búfer de salida para evitar este problema, procesando en el servidor todo el contenido a mostrar en el navegador antes de ser enviado. Se puede hacer esto usando ob_start() y ob_end_flush() en el script, o definiendo la directiva output_buffering en el php.ini o en los ficheros de configuración del servidor.

Nota:

El encabezado con el status HTTP siempre será el primero a ser enviado al cliente, sin tener en cuenta si está usando header() con el status en primer lugar o no. El status puede ser sobreescrito pasando a header() un nuevo status en cualquier momento a no ser que los encabezados HTTP ya hayan sido enviados.

Nota:

Existe un bug en Microsoft Internet Explorer 4.01 que hace que no funcione. No existe una solución. También hay un bug en Microsoft Internet Explorer 5.5 que también sucede lo mismo, puede ser resuelto actualizando a Service Pack 2 o superior.

Nota:

HTTP/1.1 require una URI absoluta como argumento para » Location: incluyendo el esquema, nombre del host y ruta absoluta, pero algunos clientes aceptan también URIs relativas. Se puede usar $_SERVER['HTTP_HOST'], $_SERVER['PHP_SELF'] y dirname() para crear una URI absoluta desde una relativa:

<?php
/* Redirecciona a una página diferente en el mismo directorio el cual se hizo la petición */
$host  = $_SERVER['HTTP_HOST'];
$uri   = rtrim(dirname($_SERVER['PHP_SELF']), '/\\');
$extra = 'mypage.php';
header("Location: http://$host$uri/$extra");
exit;
?>

Nota:

El ID de sesión no es pasado con el encabezado Location incluso si session.use_trans_sid está habilitado. Debe ser pasado manualmente usando la constante SID.

Ver también

  • headers_sent() - Comprueba si o donde han enviado cabeceras
  • setcookie() - Enviar una cookie
  • http_response_code() - Obtener u establecer el código de respuesta HTTP
  • La secciónAutenticación HTTP


Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)

  • « header
  • headers_sent »
  • PHP Manual
  • Funciones de red
  • Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)

headers_list

(PHP 5, PHP 7, PHP 8)

headers_list — Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)

Descripción

headers_list ( ) : array

headers_list() devolverá una lista de encabezados a ser enviados al navegador / cliente. Para determinar si se han enviado o no estos encabezados, use headers_sent().

Valores devueltos

Devuelve un array indexado numéricamente de encabezados.

Ejemplos

Ejemplo #1 Ejemplos usando headers_list()

<?php

/* setcookie() agrega una cabecera de respuesta propia */
setcookie('foo', 'bar');

/* Definir un encabezado de respuesta personalizado
   Este será ignorado por la mayoría de los clientes */
header("X-Sample-Test: foo");

/* Especificar el contenido de texto plano en nuestra respuesta */
header('Content-type: text/plain');

/* ¿Qué encabezados se van a enviar? */
var_dump(headers_list());

?>

El resultado del ejemplo sería:

array(4) {
  [0]=>
  string(23) "X-Powered-By: PHP/5.1.3"
  [1]=>
  string(19) "Set-Cookie: foo=bar"
  [2]=>
  string(18) "X-Sample-Test: foo"
  [3]=>
  string(24) "Content-type: text/plain"
}

Notas

Nota:

Las cabeceras sólo serán accesibles y mostradas si se utiliza un SAPI que lo soporte.

Ver también

  • headers_sent() - Comprueba si o donde han enviado cabeceras
  • header() - Enviar encabezado sin formato HTTP
  • setcookie() - Enviar una cookie
  • apache_response_headers() - Obtiene todas las cabeceras HTTP de respuesta
  • http_response_code() - Obtener u establecer el código de respuesta HTTP


Comprueba si o donde han enviado cabeceras

  • « headers_list
  • http_response_code »
  • PHP Manual
  • Funciones de red
  • Comprueba si o donde han enviado cabeceras

headers_sent

(PHP 4, PHP 5, PHP 7, PHP 8)

headers_sent — Comprueba si o donde han enviado cabeceras

Descripción

headers_sent ( string &$file = ? , int &$line = ? ) : bool

Comprueba si o donde han enviado cabeceras.

No se puede agregar más líneas de cabecera con la función header() una vez que el bloque de cabecera ya ha sido enviado. Con esta función se puede evitar recibir mensajes de error relacionados con cabecera HTTP. Otra opción es utilizar Output Buffering.

Parámetros

file

Si los parámetros opcionales file y line se establecen, headers_sent() pondrá el nombre del archivo PHP y número de línea donde la producción se inició en las variables file y line.

line

El número de línea donde inició la salida.

Valores devueltos

headers_sent() retornará false Si no se han enviado encabezados HTTP o de lo contrario true.

Ejemplos

Ejemplo #1 Ejemplos usando headers_sent()

<?php

// Si no se han enviado encabezados, enviar uno
if (!headers_sent()) {
    header('Location: http://www.example.com/');
    exit;
}

// Un ejemplo usando los parámetros opcionales file y line
// Tenga en cuenta que $filename y $linenum se pasan para su posterior uso.
// No asigne los valores de antemano.
if (!headers_sent($filename, $linenum)) {
    header('Location: http://www.example.com/');
    exit;

// Lo más probable es generar un error aquí.
} else {

    echo "Headers already sent in $filename on line $linenum\n" .
          "Cannot redirect, for now please click this <a " .
          "href=\"http://www.example.com\">link</a> instead\n";
    exit;
}

?>

Notas

Nota:

Las cabeceras sólo serán accesibles y mostradas si se utiliza un SAPI que lo soporte.

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • trigger_error() - Generar un mensaje de error/advertencia/aviso de nivel de usuario
  • headers_list() - Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)
  • header() - Enviar encabezado sin formato HTTP para una discusión más detallada de los asuntos planteados.


Obtener u establecer el código de respuesta HTTP

  • « headers_sent
  • inet_ntop »
  • PHP Manual
  • Funciones de red
  • Obtener u establecer el código de respuesta HTTP

http_response_code

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

http_response_code — Obtener u establecer el código de respuesta HTTP

Descripción

http_response_code ( int $response_code = ? ) : mixed

Obtener u establecer el código de estado de la respuesta HTTP.

Parámetros

response_code

El parámetro opcional response_code establecerá el código de respuesta.

Valores devueltos

Si se proporciona response_code, se devolverá el código de estado anterior. Si no se proporciona response_code, se devolverá el código de estado actual. El valor predeterminado de estos dos valores será un código de estado 200 si se emplea en un entorno de servidor web.

Se devolverá false si response_code no se proporciona y no se invoca en un entorno de servidor web (tal como desde una aplicación CLI). Se devolverá true si se proporciona response_code y no se invoca en un entorno de servidor web (aunque solamente cuando no haya sido establecido ningún estado de respuesta anterior).

Ejemplos

Ejemplo #1 Empleo de http_response_code() en un entorno de servidor web

<?php

// Obtener el código de la respuesta actual y establecer uno nuevo
var_dump(http_response_code(404));

// Obtener el nuevo código de respuesta
var_dump(http_response_code());
?>

El resultado del ejemplo sería:

int(200)
int(404)

Ejemplo #2 Empleo de http_response_code() en un entorno CLI

<?php

// Obtener el código de respuesta predeterminado actual
var_dump(http_response_code());

// Establece un código de respuesta
var_dump(http_response_code(201));

// Obtener el nuevo cógido de respuesta
var_dump(http_response_code());
?>

El resultado del ejemplo sería:

bool(false)
bool(true)
int(201)

Ver también

  • header() - Enviar encabezado sin formato HTTP
  • headers_list() - Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)


Convertir una dirección de internet empaquetada en una representación legible por humanos

  • « http_response_code
  • inet_pton »
  • PHP Manual
  • Funciones de red
  • Convertir una dirección de internet empaquetada en una representación legible por humanos

inet_ntop

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

inet_ntop — Convertir una dirección de internet empaquetada en una representación legible por humanos

Descripción

inet_ntop ( string $in_addr ) : string

Esta función convierte una dirección IPv4 de 32 bit, o una dirección IPv6 de 128 bit (si PHP se construyó con soporte habilitado para IPv6) a una representación de string apropiada para ser legible por humanos.

Parámetros

in_addr

Una dirección IPv4 de 32 bit, o una dirección IPv6 de 128 bit.

Valores devueltos

Devuelve una representación de string de la dirección o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de inet_ntop()

<?php
$empaquetada = chr(127) . chr(0) . chr(0) . chr(1);
$expandida = inet_ntop($empaquetada);

/* Salida: 127.0.0.1 */
echo $expandida;

$empaquetada = str_repeat(chr(0), 15) . chr(1);
$expandida = inet_ntop($empaquetada);

/* Salida: ::1 */
echo $expandida;
?>

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Ver también

  • long2ip() - Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
  • ip2long() - Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada
  • inet_pton() - Convertir una dirección IP legible por humanos a su representación in_addr empaquetada


Convertir una dirección IP legible por humanos a su representación in_addr empaquetada

  • « inet_ntop
  • ip2long »
  • PHP Manual
  • Funciones de red
  • Convertir una dirección IP legible por humanos a su representación in_addr empaquetada

inet_pton

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

inet_pton — Convertir una dirección IP legible por humanos a su representación in_addr empaquetada

Descripción

inet_pton ( string $address ) : string

Esta función convierte una dirección IPv4 o IPv6 legible por humanos (si PHP se construyó con soporte habilitado para IPv6) a una estructura binaria de 32 o 128 bit apropiada.

Parámetros

address

Una dirección IPv4 o IPv6 legible por humanos.

Valores devueltos

Devuelve la representación in_addr de la dirección dada por address, o false si se prorpocionó address sintácticamente inválido (por ejemplo, una dirección IPv4 sin puntos o una dirección IPv6 si dos puntos).

Ejemplos

Ejemplo #1 Ejemplo de inet_pton()

<?php
$in_addr = inet_pton('127.0.0.1');

$in6_addr = inet_pton('::1');
?>

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora está disponible en plataformas Windows.

Ver también

  • ip2long() - Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada
  • long2ip() - Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
  • inet_ntop() - Convertir una dirección de internet empaquetada en una representación legible por humanos


Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada

  • « inet_pton
  • long2ip »
  • PHP Manual
  • Funciones de red
  • Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada

ip2long

(PHP 4, PHP 5, PHP 7, PHP 8)

ip2long — Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada

Descripción

ip2long ( string $ip_address ) : int

La función ip2long() genera una dirección de red Internet IPv4 desde su representación en formato estándar de Internet (cadena con puntos).

ip2long() trabajará también con direcciones IP no-completas. Lea » http://publibn.boulder.ibm.com/doc_link/en_US/a_doc_lib/libs/commtrf2/inet_addr.htm para más información.

Parámetros

ip_address

Una dirección en formato estándar.

Valores devueltos

Devuelve la dirección IPv4 o false si direccion_ip es un valor inválido.

Historial de cambios

Versión | Descripción
5.2.10 | Antes de esta versión, ip2long() según como devolverá un número válido incluso si el valor no es una dirección con puntos (IPv4) Internet Protocol.

Ejemplos

Ejemplo #1 Ejemplo de ip2long()

<?php
$ip = gethostbyname('www.example.com');
$salida = "Las siguientes URLs son equivalentes:<br />\n";
$salida .= 'http://www.example.com/, http://' . $ip . '/, y http://' . sprintf("%u", ip2long($ip)) . "/<br />\n";
echo $salida;
?>

Ejemplo #2 Desplegar una dirección IP

Este segundo ejemplo muestra cómo imprimir una dirección convertida con la función printf() tanto en PHP 4 como en PHP 5:

<?php
$ip   = gethostbyname('www.example.com');
$long = ip2long($ip);

if ($long == -1 || $long === FALSE) {
    echo 'IP inválida, por favor intente de nuevo';
} else {
    echo $ip   . "\n";           // 192.0.34.166
    echo $long . "\n";           // -1073732954
    printf("%u\n", ip2long($ip)); // 3221234342
}
?>

Notas

Nota:

Ya que los tipos integer en PHP tiene signo, y muchas direcciones IP resultarán en enteros negativos en arquitecturas de 32 bits, necesita usar el especificador de formato "%u" de sprintf() o printf() para obtener la representación en forma de cadena de la dirección IP sin signo.

Nota:

ip2long() devolverá false para la IP 255.255.255.255 en PHP 5 <= 5.0.2. Fue corregido en PHP 5.0.3 cuando devolvía -1 (al igual que en PHP 4).

Ver también

  • long2ip() - Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
  • sprintf() - Devuelve un string formateado


Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet

  • « ip2long
  • openlog »
  • PHP Manual
  • Funciones de red
  • Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet

long2ip

(PHP 4, PHP 5, PHP 7, PHP 8)

long2ip — Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet

Descripción

long2ip ( int $proper_address ) : string

La función long2ip() genera una dirección de internet en formato de puntos (por ejemplo.: aaa.bbb.ccc.ddd) a partir de una correcta representación de la dirección.

Parámetros

proper_address

Correcta representación de la dirección.

Valores devueltos

Devuelve una dirección IP de internet como cadena de texto.

Ver también

  • ip2long() - Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada


Open connection to system logger

  • « long2ip
  • pfsockopen »
  • PHP Manual
  • Funciones de red
  • Open connection to system logger

openlog

(PHP 4, PHP 5, PHP 7, PHP 8)

openlog — Open connection to system logger

Descripción

openlog ( string $prefix , int $flags , int $facility ) : bool

openlog() opens a connection to the system logger for a program.

The use of openlog() is optional. It will automatically be called by syslog() if necessary, in which case prefix will default to false.

Parámetros

prefix

The string prefix is added to each message.

flags

The flags argument is used to indicate what logging options will be used when generating a log message.

openlog() Options
Constant | Description
LOG_CONS | if there is an error while sending data to the system logger, write directly to the system console
LOG_NDELAY | open the connection to the logger immediately
LOG_ODELAY | (default) delay opening the connection until the first message is logged
LOG_PERROR | print log message also to standard error
LOG_PID | include PID with each message
You can use one or more of these options. When using multiple options you need to OR them, i.e. to open the connection immediately, write to the console and include the PID in each message, you will use: LOG_CONS | LOG_NDELAY | LOG_PID

facility

The facility argument is used to specify what type of program is logging the message. This allows you to specify (in your machine's syslog configuration) how messages coming from different facilities will be handled.

openlog() Facilities
Constant | Description
LOG_AUTH | security/authorization messages (use LOG_AUTHPRIV instead in systems where that constant is defined)
LOG_AUTHPRIV | security/authorization messages (private)
LOG_CRON | clock daemon (cron and at)
LOG_DAEMON | other system daemons
LOG_KERN | kernel messages
LOG_LOCAL0 ... LOG_LOCAL7 | reserved for local use, these are not available in Windows
LOG_LPR | line printer subsystem
LOG_MAIL | mail subsystem
LOG_NEWS | USENET news subsystem
LOG_SYSLOG | messages generated internally by syslogd
LOG_USER | generic user-level messages
LOG_UUCP | UUCP subsystem

Nota:

LOG_USER is the only valid log type under Windows operating systems

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • syslog() - Genera un mensaje log de sistema
  • closelog() - Cerrar conexión al log del sistema


Abre Internet persistente o conexión de socket de dominio Unix

  • « openlog
  • setcookie »
  • PHP Manual
  • Funciones de red
  • Abre Internet persistente o conexión de socket de dominio Unix

pfsockopen

(PHP 4, PHP 5, PHP 7, PHP 8)

pfsockopen — Abre Internet persistente o conexión de socket de dominio Unix

Descripción

pfsockopen ( string $hostname , int $port = -1 , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") ) : resource

Esta función se comporta exactamente como fsockopen() con la diferencia de que la conexión no se cierra después de que el script termina. Esta es la versión persistente de fsockopen().

Parámetros

Para información de los parámetros, consulte la documentación de la función fsockopen()

Ver también

  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix


Enviar una cookie

  • « pfsockopen
  • setrawcookie »
  • PHP Manual
  • Funciones de red
  • Enviar una cookie

setcookie

(PHP 4, PHP 5, PHP 7, PHP 8)

setcookie — Enviar una cookie

Descripción

setcookie ( string $name , string $value = "" , int $expires = 0 , string $path = "" , string $domain = "" , bool $secure = false , bool $httponly = false ) : bool
setcookie ( string $name , string $value = "" , array $options = [] ) : bool

setcookie() define una cookie para ser enviada junto con el resto de cabeceras HTTP. Como otros encabezados, cookies deben ser enviadas antes de cualquier salida en el script (este es un protocolo de restricción). Esto requiere que hagas llamadas a esta función antes de cualquier salida, incluyendo etiquetas <html> y <head> así como cualquier espacio en blanco.

Una vez que las cookies se han establecido, se puede acceder a ellas en la siguiente página de carga con el array $_COOKIE. valores Cookie también pueden existir en $_REQUEST.

Parámetros

» RFC 6265 proporciona la referencia normativa como cada parámetro setcookie() es interpretado.

name

El nombre de la cookie.

value

El valor de la cookie. Este valor se almacena en el ordenador del cliente; no almacenar información sensible. Asumiendo que el name es 'cookiename', este valor es recuperado a través de $_COOKIE['cookiename']

expires

El tiempo en que la cookie expira. Esta es una marca de tiempo Unix en número de segundos desde la época. En otras palabras, lo más probable es que se haga con la función time() más el número de segundos antes de que quiera que expire. O se podría usar mktime(). time()+60*60*24*30 hará que la cookie establecida expire en 30 días. Si se establece a 0, o es omitido, la cookie expirará al final de la sesión (cuando el navegador es cerrado).

Nota:

Puede notar que el parámetro expires toma una marca de tiempo Unix, en lugar de formato de fecha Wdy, DD-Mon-YYYY HH:MM:SS GMT, esto es porque PHP hace la conversión internamente.

path

La ruta dentro del servidor en la que la cookie estará disponible. Si se utiliza '/', la cookie estará disponible en la totalidad del domain. Si se configura como '/foo/', la cookie sólo estará disponible dentro del directorio /foo/ y todos sus sub-directorios en el domain, tales como /foo/bar/. El valor por defecto es el directorio actual en donde se está configurando la cookie.

domain

El (sub)dominio al que la cookie está disponible. Estableciendo esto a un subdominio (como 'www.example.com') hará que la cookie esté disponible para ese subdominio y todos los demás subdominios del mismo (p.e. w2.www.example.com). Para que la cookie esté disponible para todo el dominio (incluyendo todos sus subdominios), simplemente establezca el nombre de domonio ('example.com', en este caso).

Los navegadores más antiguos todavía implementan la obsoleta » RFC 2109 pueden necesitar un . para comparar todos los subdominios.

secure

Indica que la cookie sólo debiera transmitirse por una conexión segura HTTPS desde el cliente. Cuando se configura como true, la cookie sólo se creará si es que existe una conexión segura. Del lado del servidor, depende del programador el enviar este tipo de cookies solamente a través de conexiones seguras (por ejemplo, con $_SERVER["HTTPS"]).

httponly

Cuando es true la cookie será accesible sólo a través del protocolo HTTP. Esto significa que la cookie no será accesible por lenguajes de scripting, como JavaScript. Se ha indicado que esta configuración ayuda efectivamente a reducir el robo de identidad a través de ataques XSS (aunque no es soportada por todos los navegadores). pero esa afirmación se disputa a menudo. Agregado en PHP 5.2.0. Puede ser true o false

options

Un array asociativo que puede tener cualquiera de las claves expires, path, domain, secure, httponly y samesite. Los valores tienen el mismo significado que se describe para los parámetros con el mismo nombre. El valor de el elemento samesite debería ser None, Lax o Strict. Si no se da ninguna de las opciones permitidas, sus valores por defecto son los mismos que los valores por defecto de los parámetros explícitos. Si el elemento samesite es omitido, no se establece ningún atributo de la cookie SameSite.

Valores devueltos

Si existe algún tipo de output anterior a la llamada de esta función, setcookie() fallará y retornará false. Si setcookie() ejecuta satisfactoriamente, retornará true. Esto no indica si es que el usuario ha aceptado la cookie o no.

Ejemplos

A continuación se presentan algunos ejemplos de cómo enviar cookies:

Ejemplo #1 Ejemplo de envío con setcookie()

<?php
$value = 'something from somewhere';

setcookie("TestCookie", $value);
setcookie("TestCookie", $value, time()+3600);  /* expira en 1 hora */
setcookie("TestCookie", $value, time()+3600, "/~rasmus/", "example.com", 1);
?>

Nótese que la parte del valor de la cookie será automáticamente codificada con urlencode al enviar la cookie, y al ser recibida será automáticamente decodificada y asignada a una variable con el mismo nombre que el nombre de la cookie. Si no se desea ésto, se puede usar setrawcookie() si es que se está utilizando PHP 5. Para ver el contenido de nuestra cookie de prueba en un script, simplemente siga uno de los ejemplo siguientes:

<?php
// Imprime una cookie individual
echo $_COOKIE["TestCookie"];

// Otra forma de depurar/prueba es ver todas las cookies
print_r($_COOKIE);
?>

Ejemplo #2 Ejemplo de eliminación con setcookie()

Al borrar una cookie debe asegurarse que la fecha de expiración ya ha pasado, de modo a detonar el mecanismo de eliminación del navegador. El siguiente ejemplo muestra cómo borrar las cookies enviadas en el ejemplo anterior:

<?php
// establecer la fecha de expiración a una hora atrás
setcookie("TestCookie", "", time() - 3600);
setcookie("TestCookie", "", time() - 3600, "/~rasmus/", "example.com", 1);
?>

Ejemplo #3 setcookie() y los arrays

También puede crear arrays de cookies utilizando la notación de arrays en el nombre de la cookie. El efecto de esto es de crear tantas cookies como elementos hay en el array, pero al recibir el script la cookie, todos los valores son colocados en un array con el nombre de la cookie:

<?php
// set the cookies
setcookie("cookie[three]", "cookiethree");
setcookie("cookie[two]", "cookietwo");
setcookie("cookie[one]", "cookieone");

// después de que la página se recargue, imprime
if (isset($_COOKIE['cookie'])) {
    foreach ($_COOKIE['cookie'] as $name => $value) {
        $name = htmlspecialchars($name);
        $value = htmlspecialchars($value);
        echo "$name : $value <br />\n";
    }
}
?>

El resultado del ejemplo sería:

three : cookiethree
two : cookietwo
one : cookieone

Historial de cambios

Versión | Descripción
7.3.0 | Una alternativa que soporta un array options ha sido añadida. Esta alternativa soporta también la configuración del atributo de la cookie de SameSite.
5.5.0 | Ahora se incluye un atributo Max-Age en la cabecera Set-Cookie enviada al cliente.
5.2.0 | Se añadió el parámetro httponly.

Notas

Nota:

Se puede utilizar buffering de salida para enviar output anterior a la llamada a esta función, de modo que todo el output hacia el browser sea almacenado en el servidor hasta que lo envíe. Para hacer ésto invoque en su script a ob_start() y ob_end_flush(), o active la directiva de configuración output_buffering en el archivo php.ini o en los archivos de configuración del servidor.

Common Pitfalls:

  • Las cookies no se volverán visibles hasta la próxima carga de la página en la que debieran serlo. Para probar si se ha creado correctamente una cookie, se debe buscar la cookie en alguna página cargada posteriormente y antes que la cookie expire. El tiempo de expiración se establece con el parámetro expires. Una forma sencilla de verificar la existencia de cookies es invocando print_r($_COOKIE);.
  • Las cookies deben ser borradas usando los mismos parámetros con que fueron creadas. Si el argumento del valor es un string vacío o false, y todos los demás argumentos coinciden con una llamada anterior a setcookie, entonces la cookie con el nombre especificado será eliminada del cliente remoto. Internamente ésto se logra estableciendo el valor a 'deleted' y el tiempo de expiración a un año atrás.
  • Ya que configurar el valor de una cookie como false intentará eliminar la cookie, no se debieran utilizar valores booleanos. En su lugar, use 0 como false y 1 como true.
  • Los nombres de las cookies pueden declararse como nombres de arrays y estarán disponibles en sus scripts PHP como arrays, pero en el sistema del usuario se guardarán como cookies separadas. Considere la función explode() para crear una sola cookie con nombres y valores múltiples. No se recomienda utilizar la función serialize() para este propósito, pues puede significar vulnerabilidades en la seguridad.

Múltiples llamadas a setcookie() se efectúan en el orden de llamada.

Ver también

  • header() - Enviar encabezado sin formato HTTP
  • setrawcookie() - Enviar una cookie sin codificar su valor
  • cookies section
  • » RFC 6265
  • » RFC 2109


Enviar una cookie sin codificar su valor

  • « setcookie
  • socket_get_status »
  • PHP Manual
  • Funciones de red
  • Enviar una cookie sin codificar su valor

setrawcookie

(PHP 5, PHP 7, PHP 8)

setrawcookie — Enviar una cookie sin codificar su valor

Descripción

setrawcookie ( string $name , string $value = ? , int $expires = 0 , string $path = ? , string $domain = ? , bool $secure = false , bool $httponly = false ) : bool
setrawcookie ( string $name , string $value = ? , array $options = [] ) : bool

setrawcookie() es exactamente el mismo que setcookie() excepto que el valor de la cookie no será automáticamente codificado cuando se envía al navegador.

Parámetros

Para información sobre los parámetros, consulte la función setcookie().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.3.0 | Una alternativa que soporta un array options ha sido añadida. Esta alternativa soporta también la configuración del atributo de la cookie de SameSite.
5.5.0 | Ahora se incluye un atributo Max-Age en la cabecera Set-Cookie enviada al cliente.
5.2.0 | Se añadió el parámetro httponly.

Ver también

  • setcookie() - Enviar una cookie


Alias de stream_get_meta_data

  • « setrawcookie
  • socket_set_blocking »
  • PHP Manual
  • Funciones de red
  • Alias de stream_get_meta_data

socket_get_status

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_get_status — Alias de stream_get_meta_data()

Descripción

Esta función es un alias de: stream_get_meta_data().


Alias de stream_set_blocking

  • « socket_get_status
  • socket_set_timeout »
  • PHP Manual
  • Funciones de red
  • Alias de stream_set_blocking

socket_set_blocking

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_set_blocking — Alias de stream_set_blocking()

Descripción

Esta función es un alias de: stream_set_blocking().


Alias de stream_set_timeout

  • « socket_set_blocking
  • syslog »
  • PHP Manual
  • Funciones de red
  • Alias de stream_set_timeout

socket_set_timeout

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_set_timeout — Alias de stream_set_timeout()

Descripción

Esta función es un alias de: stream_set_timeout().


Genera un mensaje log de sistema

  • « socket_set_timeout
  • RRD »
  • PHP Manual
  • Funciones de red
  • Genera un mensaje log de sistema

syslog

(PHP 4, PHP 5, PHP 7, PHP 8)

syslog — Genera un mensaje log de sistema

Descripción

syslog ( int $priority , string $message ) : bool

syslog() genera un mensaje log que será distribuido por el logger del sistema.

Para información de como configurar un usuario definido como controlador del log, ver syslog.conf (5) del manual de Unix. Más información sobre los recursos y opciones de syslog pueden encontrarse en las páginas del manual de syslog (3) en entornos Unix.

Parámetros

priority

priority es una combinación del tipo y el nivel. Posibles valores:

Prioridades syslog() (en orden descendente)
Constante | Descripción
LOG_EMERG | sistema inservible
LOG_ALERT | se debe tomar acción de forma inmediata
LOG_CRIT | condiciones críticas
LOG_ERR | condiciones de error
LOG_WARNING | condiciones de alerta
LOG_NOTICE | condición normal, pero relevante
LOG_INFO | mensaje de información
LOG_DEBUG | mensaje de testeo

message

El mensaje a enviar a excepción de dos caracteres %m serán reemplazados con el mensaje de error (strerror) correspondiente con el valor presente de errno.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso de syslog()

<?php
// abre syslog, incluyendo el ID del proceso. También envia al
// log el error estándar y el mecanismo de logging
// definido por el usuario
openlog("myScriptLog", LOG_PID | LOG_PERROR, LOG_LOCAL0);

// algún código

if (authorized_client()) {
    // hace algo
} else {
    // Cliente no autorizado!
    // Se logea el intento
    $access = date("Y/m/d H:i:s");
    syslog(LOG_WARNING, "Cliente no autorizado: $access {$_SERVER['REMOTE_ADDR']} ({$_SERVER['HTTP_USER_AGENT']})");
}

closelog();
?>

Notas

En Windows NT, el servicio syslog es emulado usando el Event Log.

Nota:

El uso de LOG_LOCAL0 a través de LOG_LOCAL7 para el parámetro facility de openlog() no está disponible en Windows.

Ver también

  • openlog() - Open connection to system logger
  • closelog() - Cerrar conexión al log del sistema


RRDtool

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ejemplo procedural PECL/rrd
    • Ejemplo OOP PECL/rrd
  • Funciones RRD
    • rrd_create — Crea un archivo de base de datos rrd
    • rrd_error — Obtener el último mensaje de error
    • rrd_fetch — Recuperar los datos de gráfico como un array
    • rrd_first — Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd
    • rrd_graph — Crea la imagen de un conjunto de datos
    • rrd_info — Obtiene información sobre el archivo rrd
    • rrd_last — Obtiene la marca de tiempo UNIX de la última muestra
    • rrd_lastupdate — Obtiene información sobre los últimos datos actualizados
    • rrd_restore — Restaura el archivo RRD desde el XML dump
    • rrd_tune — Cambia algunas opciones de cabecera del archivo de base de datos RRD database
    • rrd_update — Actualizar la base de datos RRD
    • rrd_version — Obtiene información acerca de la biblioteca subyacente rrdtool
    • rrd_xport — Exporta la información acerca de la base de datos RRD
    • rrdc_disconnect — Close any outstanding connection to rrd caching daemon
  • RRDCreator — La clase RRDCreator
    • RRDCreator::addArchive — Añade RRA - archivo de valores de datos para cada fuente de datos
    • RRDCreator::addDataSource — Añade definición de origen de datos para la base de datos RRD
    • RRDCreator::__construct — Crea una nueva instancia RRDCreator
    • RRDCreator::save — Guarda la base de datos RRD en un archivo
  • RRDGraph — La clase RRDGraph
    • RRDGraph::__construct — Crea una nueva instancia RRDGraph
    • RRDGraph::save — Guarda el resultado de la consulta en la imagen
    • RRDGraph::saveVerbose — Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.
    • RRDGraph::setOptions — Establece las opciones para la exportación gráfica rrd
  • RRDUpdater — La clase RRDUpdater
    • RRDUpdater::__construct — Crea una nueva instancia RRDUpdater
    • RRDUpdater::update — Actualiza el archivo de base de datos RRD


Introducción

La extensión PECL/rrd proporciona enlaces a la biblioteca en C RRDtool. RRDtool es el estándar de código abierto de la industria, datos de registro de alto rendimiento y la representación gráfica del sistema para datos de series de tiempo.

La página principal de RRDtool es » http://www.mrtg.org/rrdtool/.


Requerimientos

Es necesario instalar librrd antes de poder utilizar PECL/rrd. La opción más común es utilizando el paquete librrd-dev de su distribución Linux favorita. PECL/rrd ha sido testeado con librrd 1.4.3, versiones más antiguas o más recientes quizás podrían no funcionarle. La instalación de PECL/rrd ha sido testeada con PHP 5.3.2 o superior.

Advertencia

Librrd y por lo tanto la extensión en sí no son en general seguro para subprocesos. Hay muchos estados globales y compartidos en librrd. Puede ser peligroso utilizar esta extensión en múltiples entornos multihilo como Apache2 mpm worker. Si hay muchas solicitudes paralelas, una solicitud puede modificar algún estado global librrd de otras solicitudes que se estén ejecutando.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/rrd.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • RRD
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Ejemplo procedural PECL/rrd »
  • PHP Manual
  • RRD
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplo procedural PECL/rrd
  • Ejemplo OOP PECL/rrd


Ejemplo procedural PECL/rrd

Ejemplo #1 Procedimiento de utilización de rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";

//crear el archivo rrd
rrd_create($rrdFile,
 array(
  "--start",920804400,
  "DS:speed:COUNTER:600:U:U",
  "RRA:AVERAGE:0.5:1:24",
  "RRA:AVERAGE:0.5:6:10"
  )
);

//actualizar el archivo rrd
rrd_update($rrdFile,
 array(
  "920804700:12345",
  "920805000:12357"
  )
);

//gráfico de salida
rrd_graph(dirname(__FILE__) . "/speed.png",
 array(
  "--start", "920804400",
  "--end", "920808000",
  "--vertical-label", "m/s",
  "DEF:myspeed=$rrdFile:speed:AVERAGE",
  "CDEF:realspeed=myspeed,1000,*",
  "LINE2:realspeed#FF0000"
 )
);
?>


Ejemplo OOP PECL/rrd

Ejemplo #1 Procedimiento de utilización de OOP rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";
$outputPngFile = dirname(__FILE__) . "/speed.png";

$creator = new RRDCreator($rrdFile, "now -10d", 500);
$creator->addDataSource("speed:COUNTER:600:U:U");
$creator->addArchive("AVERAGE:0.5:1:24");
$creator->addArchive("AVERAGE:0.5:6:10");
$creator->save();

$updater = new RRDUpdater($rrdFile);
$updater->update(array("speed" => "12345"), "920804700");
$updater->update(array("speed" => "12357"), "920805000");

$graphObj = new RRDGraph($outputPngFile);
$graphObj->setOptions(
    array(
        "--start" => "920804400",
        "--end" => 920808000,
        "--vertical-label" => "m/s",
        "DEF:myspeed=$rrdFile:speed:AVERAGE",
        "CDEF:realspeed=myspeed,1000,*",
        "LINE2:realspeed#FF0000"
    )
);
$graphObj->save();
?>


Funciones RRD

Tabla de contenidos

  • rrd_create — Crea un archivo de base de datos rrd
  • rrd_error — Obtener el último mensaje de error
  • rrd_fetch — Recuperar los datos de gráfico como un array
  • rrd_first — Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd
  • rrd_graph — Crea la imagen de un conjunto de datos
  • rrd_info — Obtiene información sobre el archivo rrd
  • rrd_last — Obtiene la marca de tiempo UNIX de la última muestra
  • rrd_lastupdate — Obtiene información sobre los últimos datos actualizados
  • rrd_restore — Restaura el archivo RRD desde el XML dump
  • rrd_tune — Cambia algunas opciones de cabecera del archivo de base de datos RRD database
  • rrd_update — Actualizar la base de datos RRD
  • rrd_version — Obtiene información acerca de la biblioteca subyacente rrdtool
  • rrd_xport — Exporta la información acerca de la base de datos RRD
  • rrdc_disconnect — Close any outstanding connection to rrd caching daemon


Crea un archivo de base de datos rrd

  • « Funciones RRD
  • rrd_error »
  • PHP Manual
  • Funciones RRD
  • Crea un archivo de base de datos rrd

rrd_create

(PECL rrd >= 0.9.0)

rrd_create — Crea un archivo de base de datos rrd

Descripción

rrd_create ( string $filename , array $options ) : bool

Crea el archivo de base de datos RDD.

Parámetros

filename

Nombre de archivo para el nuevo archivo de base de datos rrd.

options

Opciones para la creación del archivo de base de datos rrd - lista de cadenas. Ver página de manual de creación de archivos de base de datos rrd para obtener una lista completa de opciones.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener el último mensaje de error

  • « rrd_create
  • rrd_fetch »
  • PHP Manual
  • Funciones RRD
  • Obtener el último mensaje de error

rrd_error

(PECL rrd >= 0.9.0)

rrd_error — Obtener el último mensaje de error

Descripción

rrd_error ( ) : string

Devuelve el último mensaje de error global rrd.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Último mensaje de error.


Recuperar los datos de gráfico como un array

  • « rrd_error
  • rrd_first »
  • PHP Manual
  • Funciones RRD
  • Recuperar los datos de gráfico como un array

rrd_fetch

(PECL rrd >= 0.9.0)

rrd_fetch — Recuperar los datos de gráfico como un array

Descripción

rrd_fetch ( string $filename , array $options ) : array

Obtiene datos para la salida gráfica del archivo desde la base de datos RRD como un array. Esta función tiene el mismo resultado que rrd_graph(), pero los datos obtenidos son devueltos como una matriz, no se crea el archivo de imagen.

Parámetros

filename

Nombre de archivo de la base de datos RRD.

options

Array de opciones para la resolución solicitada.

Valores devueltos

Devuelve información acerca de los datos del gráfico recuperados.


Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd

  • « rrd_fetch
  • rrd_graph »
  • PHP Manual
  • Funciones RRD
  • Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd

rrd_first

(PECL rrd >= 0.9.0)

rrd_first — Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd

Descripción

rrd_first ( string $file , int $raaindex = 0 ) : int

Devuelve la primera muestra de datos desde la especificada RRA del archivo RRD.

Parámetros

file

Nombre del archivo de la base de datos RRD.

raaindex

El índice numérico de la RRA que se va a examinar. El valor por defecto es 0.

Valores devueltos

Número entero de marca de tiempo Unix, false Si se produce algún error.


Crea la imagen de un conjunto de datos

  • « rrd_first
  • rrd_info »
  • PHP Manual
  • Funciones RRD
  • Crea la imagen de un conjunto de datos

rrd_graph

(PECL rrd >= 0.9.0)

rrd_graph — Crea la imagen de un conjunto de datos

Descripción

rrd_graph ( string $filename , array $options ) : array

Crea la imagen de un conjunto de datos particulares desde el archivo de RRD.

Parámetros

filename

El nombre del archivo de salida del gráfico. Este generalmente tiene una terminación .png, .svg o .eps, dependiendo del formato de salida que desee.

options

Las opciones para la generación de la imagen. Consulte la página del manual de gráficos rrd para conocer todas las posibles opciones. Todas las opciones (definiciones de datos, definiciones de variables, etc.) son permitidas.

Valores devueltos

Se devolverá un array con información acerca de la imagen generada, false cuando se produzca un error.


Obtiene información sobre el archivo rrd

  • « rrd_graph
  • rrd_last »
  • PHP Manual
  • Funciones RRD
  • Obtiene información sobre el archivo rrd

rrd_info

(PECL rrd >= 0.9.0)

rrd_info — Obtiene información sobre el archivo rrd

Descripción

rrd_info ( string $filename ) : array

Devuelve información acerca sobre determinado archivo de base de datos RRD.

Parámetros

file

Nombre del archivo de base de datos RRD.

Valores devueltos

Array con información sobre el archivo RRD solicitado, false cuando ocurra un error.


Obtiene la marca de tiempo UNIX de la última muestra

  • « rrd_info
  • rrd_lastupdate »
  • PHP Manual
  • Funciones RRD
  • Obtiene la marca de tiempo UNIX de la última muestra

rrd_last

(PECL rrd >= 0.9.0)

rrd_last — Obtiene la marca de tiempo UNIX de la última muestra

Descripción

rrd_last ( string $filename ) : int

Devuelve la marca de tiempo UNIX (UNIX timestamp) de la actualización más reciente de la base de datos RRD.

Parámetros

filename

Nombre de archivo de la base de datos RRD.

Valores devueltos

Devuelve un número entero como marca de tiempo Unix de los datos más recientes de la base de datos RRD.


Obtiene información sobre los últimos datos actualizados

  • « rrd_last
  • rrd_restore »
  • PHP Manual
  • Funciones RRD
  • Obtiene información sobre los últimos datos actualizados

rrd_lastupdate

(PECL rrd >= 0.9.0)

rrd_lastupdate — Obtiene información sobre los últimos datos actualizados

Descripción

rrd_lastupdate ( string $filename ) : array

Obtiene un array de la marca de tiempo UNIX y de los valores almacenados para cada fecha en la actualización más reciente del archivo de base de datos RRD.

Parámetros

file

Nombre del archivo de la base de datos RRD.

Valores devueltos

Array de información sobre la última actualización, false cuando ocurra un error.


Restaura el archivo RRD desde el XML dump

  • « rrd_lastupdate
  • rrd_tune »
  • PHP Manual
  • Funciones RRD
  • Restaura el archivo RRD desde el XML dump

rrd_restore

(PECL rrd >= 0.9.0)

rrd_restore — Restaura el archivo RRD desde el XML dump

Descripción

rrd_restore ( string $xml_file , string $rrd_file , array $options = ? ) : bool

Restaura el archivo RRD desde el XML dump.

Parámetros

xml_file

Nombre del archivo XML con el dump del archivo de la base de datos RRD original.

rrd_file

Nombre del archivo de la base de datos RRD restaurada.

options

Array de opciones para la restauración. Consulte la página de manual de restauración rrd.

Valores devueltos

Devuelve true en caso de éxito, false en caso de error.


Cambia algunas opciones de cabecera del archivo de base de datos RRD database

  • « rrd_restore
  • rrd_update »
  • PHP Manual
  • Funciones RRD
  • Cambia algunas opciones de cabecera del archivo de base de datos RRD database

rrd_tune

(PECL rrd >= 0.9.0)

rrd_tune — Cambia algunas opciones de cabecera del archivo de base de datos RRD database

Descripción

rrd_tune ( string $filename , array $options ) : bool

Cambia algunas opciones de cabecera del archivo de base de datos RRD. Por ejemplo, cambia el nombre de la fuente de los datos, etc

Parámetros

filename

Nombre de archivo de la base de datos RRD.

options

Opciones con las propiedades del archivo de la base de datos RDD que serán cambiadas. Consulte la página del manual rrd tune para mayor detalle.

Valores devueltos

Devuelve true en caso de éxito, false en caso contrario.


Actualizar la base de datos RRD

  • « rrd_tune
  • rrd_version »
  • PHP Manual
  • Funciones RRD
  • Actualizar la base de datos RRD

rrd_update

(PECL rrd >= 0.9.0)

rrd_update — Actualizar la base de datos RRD

Descripción

rrd_update ( string $filename , array $options ) : bool

Actualiza el archivo de base de datos RRD. Los datos de entrada es el tiempo interpolado de acuerdo con las propiedades del archivo de base de datos RRD.

Parámetros

filename

Nombre de archivo de la base de datos RRD. Esta base de datos será actualizada.

options

Opciones para actualizar la base de datos RRD. Esta es una lista de cadenas. Ver página del manual de actualización rrd para conocer el listado de opciones.

Valores devueltos

Returns true on success, false when error occurs.


Obtiene información acerca de la biblioteca subyacente rrdtool

  • « rrd_update
  • rrd_xport »
  • PHP Manual
  • Funciones RRD
  • Obtiene información acerca de la biblioteca subyacente rrdtool

rrd_version

(PECL rrd >= 1.0.0)

rrd_version — Obtiene información acerca de la biblioteca subyacente rrdtool

Descripción

rrd_version ( ) : string

Devuelve información acerca de la biblioteca subyacente rrdtool.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

String con el número de versión, por ejemplo, rrdtool "1.4.3".


Exporta la información acerca de la base de datos RRD

  • « rrd_version
  • rrdc_disconnect »
  • PHP Manual
  • Funciones RRD
  • Exporta la información acerca de la base de datos RRD

rrd_xport

(PECL rrd >= 0.9.0)

rrd_xport — Exporta la información acerca de la base de datos RRD

Descripción

rrd_xport ( array $options ) : array

Exporta la información sobre el archivo de base de datos RRD. Estos datos se pueden convertir a archivo XML a través del espacio de usuario PHP script y posteriormente restaurarlo de nuevo como un archivo de base de datos RRD.

Parámetros

options

Array de opciones para la exportación, consulte la página del manual rrd xport.

Valores devueltos

Array con información sobre el archivo de base de datos RRD, false cuando se produzca un error.


Close any outstanding connection to rrd caching daemon

  • « rrd_xport
  • RRDCreator »
  • PHP Manual
  • Funciones RRD
  • Close any outstanding connection to rrd caching daemon

rrdc_disconnect

(PECL rrd >= 1.1.2)

rrdc_disconnect — Close any outstanding connection to rrd caching daemon

Descripción

rrdc_disconnect ( ) : void

Close any outstanding connection to rrd caching daemon.

This function is automatically called when the whole PHP process is terminated. It depends on used SAPI. For example, it's called automatically at the end of command line script.

It's up user whether he wants to call this function at the end of every request or otherwise.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


La clase RRDCreator

(PECL rrd >= 0.9.0)

Introducción

Clase para la creación del archivo de base de datos RRD.

Sinopsis de la Clase

RRDCreator {
/* Métodos */
public addArchive ( string $description ) : void
public addDataSource ( string $description ) : void
public __construct ( string $path , string $startTime = ? , int $step = 0 )
public save ( ) : bool
}

Tabla de contenidos

  • RRDCreator::addArchive — Añade RRA - archivo de valores de datos para cada fuente de datos
  • RRDCreator::addDataSource — Añade definición de origen de datos para la base de datos RRD
  • RRDCreator::__construct — Crea una nueva instancia RRDCreator
  • RRDCreator::save — Guarda la base de datos RRD en un archivo


Añade RRA - archivo de valores de datos para cada fuente de datos

  • « RRDCreator
  • RRDCreator::addDataSource »
  • PHP Manual
  • RRDCreator
  • Añade RRA - archivo de valores de datos para cada fuente de datos

RRDCreator::addArchive

(PECL rrd >= 0.9.0)

RRDCreator::addArchive — Añade RRA - archivo de valores de datos para cada fuente de datos

Descripción

public RRDCreator::addArchive ( string $description ) : void

Añade definición RRA por descripción de archivo. Archivo consta de un número de valores de datos o estadísticas para cada una de las fuentes de datos definidas (DS). Las fuentes de datos son definidos a través del método RRDCreator::addDataSource(). Es necesario llamar a este método para cada archivo solicitado.

Parámetros

description

Definición del archivo - RRA. Esta tiene el mismo formato que la definición RRA en el comando rrd create. Ver página de manual de rrd create para obtener más detalles.

Valores devueltos

No devuelve ningún valor.


Añade definición de origen de datos para la base de datos RRD

  • « RRDCreator::addArchive
  • RRDCreator::__construct »
  • PHP Manual
  • RRDCreator
  • Añade definición de origen de datos para la base de datos RRD

RRDCreator::addDataSource

(PECL rrd >= 0.9.0)

RRDCreator::addDataSource — Añade definición de origen de datos para la base de datos RRD

Descripción

public RRDCreator::addDataSource ( string $description ) : void

RRD puede aceptar la entrada desde varias fuentes de datos (DS), por ejemplo, tráfico entrante y saliente. Este método añade fuente de datos por descripción. Necesita llamar a este método para cada fuente de datos.

Parámetros

description

Definición de origen de datos - DS. Esta tiene el mismo formato como la definición DS en el comando rrd create. Ver página de manual de rrd create para obtener más detalles.

Valores devueltos

No devuelve ningún valor.


Crea una nueva instancia RRDCreator

  • « RRDCreator::addDataSource
  • RRDCreator::save »
  • PHP Manual
  • RRDCreator
  • Crea una nueva instancia RRDCreator

RRDCreator::__construct

(PECL rrd >= 0.9.0)

RRDCreator::__construct — Crea una nueva instancia RRDCreator

Descripción

public RRDCreator::__construct ( string $path , string $startTime = ? , int $step = 0 )

Crea una nueva instancia RRDCreator.

Parámetros

path

Ruta de acceso para el archivo de base de datos recién creada RRD.

startTime

Tiempo para el primer valor en la base de datos RRD.Parámetro soporta todos los formatos que son soportados por la llamada a rrd create.

intstep

Base de intervalo en segundos con que los datos se introducen en la base de datos RRD.

Valores devueltos

No devuelve ningún valor.


Guarda la base de datos RRD en un archivo

  • « RRDCreator::__construct
  • RRDGraph »
  • PHP Manual
  • RRDCreator
  • Guarda la base de datos RRD en un archivo

RRDCreator::save

(PECL rrd >= 0.9.0)

RRDCreator::save — Guarda la base de datos RRD en un archivo

Descripción

public RRDCreator::save ( ) : bool

Guarda la base de datos RRD en un archivo, cuyo nombre es definido por RRDCreator::__construct().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


La clase RRDGraph

(PECL rrd >= 0.9.0)

Introducción

Clase para exportar datos de la bases de datos RRD al archivo de imagen.

Sinopsis de la Clase

RRDGraph {
/* Métodos */
public __construct ( string $path )
public save ( ) : array
public saveVerbose ( ) : array
public setOptions ( array $options ) : void
}

Tabla de contenidos

  • RRDGraph::__construct — Crea una nueva instancia RRDGraph
  • RRDGraph::save — Guarda el resultado de la consulta en la imagen
  • RRDGraph::saveVerbose — Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.
  • RRDGraph::setOptions — Establece las opciones para la exportación gráfica rrd


Crea una nueva instancia RRDGraph

  • « RRDGraph
  • RRDGraph::save »
  • PHP Manual
  • RRDGraph
  • Crea una nueva instancia RRDGraph

RRDGraph::__construct

(PECL rrd >= 0.9.0)

RRDGraph::__construct — Crea una nueva instancia RRDGraph

Descripción

public RRDGraph::__construct ( string $path )

Crea una nueva instancia RRDGraph. Esta instancia es la encargada de mostrar el resultado de la consulta de base de datos RRD en la imagen.

Parámetros

path

Ruta completa de la imagen recién creada.

Valores devueltos

No devuelve ningún valor.


Guarda el resultado de la consulta en la imagen

  • « RRDGraph::__construct
  • RRDGraph::saveVerbose »
  • PHP Manual
  • RRDGraph
  • Guarda el resultado de la consulta en la imagen

RRDGraph::save

(PECL rrd >= 0.9.0)

RRDGraph::save — Guarda el resultado de la consulta en la imagen

Descripción

public RRDGraph::save ( ) : array

Guarda el resultado de la consulta de base de datos RRD en la imagen definida por RRDGraph::__construct().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Se devuelve un array con información acerca de la imagen generada, false si se produce un error.


Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.

  • « RRDGraph::save
  • RRDGraph::setOptions »
  • PHP Manual
  • RRDGraph
  • Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.

RRDGraph::saveVerbose

(PECL rrd >= 0.9.0)

RRDGraph::saveVerbose — Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.

Descripción

public RRDGraph::saveVerbose ( ) : array

Guarda la consulta de bases de datos RRD en el archivo de imagen definido por el método RRDGraph::__construct() y devuelve la información detallada acerca de gráfico generado, si "-" se utiliza como nombre de archivo de imagen, los datos de la imagen también se devolverán en el array de resultados.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Se devuelve un array con información detallada acerca de la imagen generada, opcionalmente con datos de imagen, false si se produce un error.


Establece las opciones para la exportación gráfica rrd

  • « RRDGraph::saveVerbose
  • RRDUpdater »
  • PHP Manual
  • RRDGraph
  • Establece las opciones para la exportación gráfica rrd

RRDGraph::setOptions

(PECL rrd >= 0.9.0)

RRDGraph::setOptions — Establece las opciones para la exportación gráfica rrd

Descripción

public RRDGraph::setOptions ( array $options ) : void

Parámetros

options

Lista de las opciones para la generación de imágenes a partir del archivo de base de datos RRD. Esta puede ser una lista de cadenas o lista de cadenas con claves para una mejor legibilidad. Consulte las páginas del manual rrd graph para conocer la lista de opciones disponibles.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de RRDGraph::setOptions()

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

Ejemplo #2 Establecer varias opciones de color

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "--color=BACK#00000000",
    "--color=GRID#00000000",
    "--color=MGRID#00000000",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

No emplee la sintaxis de valor de clave para la misma opción rrd. Es más legible, pero no fucniona.

<?php
$graphObj->setOptions(array(
    "--color" => "BACK#00000000",
    "--color" => "GRID#00000000",
    "--color" => "MGRID#00000000"
));
?>

En PHP es lo mismo que

<?php
$graphObj->setOptions(array(
    "--color" => "MGRID#00000000"
));
?>


La clase RRDUpdater

(PECL rrd >= 0.9.0)

Introducción

Clase para actualizar el archivo de base de datos RDD.

Sinopsis de la Clase

RRDUpdater {
/* Métodos */
public __construct ( string $path )
public update ( array $values , string $time = time() ) : bool
}

Tabla de contenidos

  • RRDUpdater::__construct — Crea una nueva instancia RRDUpdater
  • RRDUpdater::update — Actualiza el archivo de base de datos RRD


Crea una nueva instancia RRDUpdater

  • « RRDUpdater
  • RRDUpdater::update »
  • PHP Manual
  • RRDUpdater
  • Crea una nueva instancia RRDUpdater

RRDUpdater::__construct

(PECL rrd >= 0.9.0)

RRDUpdater::__construct — Crea una nueva instancia RRDUpdater

Descripción

public RRDUpdater::__construct ( string $path )

Crea una nueva instancia RRDUpdater. Esta instancia es responsable de actualizar el archivo de base de datos RRD.

Parámetros

path

Ruta de archivo del sistema para el archivo de base de datos RRD, que se actualizará.

Valores devueltos

No devuelve ningún valor.


Actualiza el archivo de base de datos RRD

  • « RRDUpdater::__construct
  • ScoutAPM »
  • PHP Manual
  • RRDUpdater
  • Actualiza el archivo de base de datos RRD

RRDUpdater::update

(PECL rrd >= 0.9.0)

RRDUpdater::update — Actualiza el archivo de base de datos RRD

Descripción

public RRDUpdater::update ( array $values , string $time = time() ) : bool

Actualiza el archivo RRD definido a través de RRDUpdater::__construct(). El archivo se actualiza con un valor específico.

Parámetros

values

Los datos de actualización. Key del array es el nombre del origen de datos.

time

Valor del tiempo para la actualización del RRD con unos datos particulares. El valor predeterminado es la hora actual.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Throws a Exception on error.

Ejemplos

Ejemplo #1 Ejemplos de RRDUpdater::update()

<?php
$updator = new RRDUpdater("speed.rrd");
//actualiza el dato de origen "speed" con el valor "12411"
//para un tiempo definido por timestamp "920807700"
$updator->update(array("speed" => "12411"), "920807700");
?>


ScoutAPM

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Scoutapm Funciones
    • scoutapm_get_calls — Returns a list of instrumented calls that have occurred
    • scoutapm_list_instrumented_functions — List functions scoutapm will instrument.


Introducción

Nota: Esta extensión no está disponible en plataformas Windows.

ScoutAPM's extension for PHP provides additional capabilities to application monitoring over just using the base PHP userland library.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

  • PHP >= 7.1.0
  • Windows is not currently supported


Instalación

This extension is available on PECL. Run:

$ sudo pecl install scoutapm
You may need to add Scout to your php.ini, for example:
extension=scoutapm.so


  • « Configuración en tiempo de ejecución
  • Scoutapm Funciones »
  • PHP Manual
  • ScoutAPM
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Scoutapm Funciones

Tabla de contenidos

  • scoutapm_get_calls — Returns a list of instrumented calls that have occurred
  • scoutapm_list_instrumented_functions — List functions scoutapm will instrument.


Returns a list of instrumented calls that have occurred

  • « Scoutapm Funciones
  • scoutapm_list_instrumented_functions »
  • PHP Manual
  • Scoutapm Funciones
  • Returns a list of instrumented calls that have occurred

scoutapm_get_calls

(PECL scoutapm >= 1.0.0)

scoutapm_get_calls — Returns a list of instrumented calls that have occurred

Descripción

scoutapm_get_calls ( ) : array

Returns a list of any instrumented function calls since scoutapm_get_calls() was last called. The list is cleared each time the function is called.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

scoutapm_get_calls() returns an array containing a list of all recorded calls to instrumented function calls.

Ejemplos

Ejemplo #1 Fetch instrumented calls

<?php

file_get_contents('a.txt');
file_get_contents('b.txt');

print_r(scoutapm_get_calls());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [function] => file_get_contents
            [entered] => 1576839727.7934
            [exited] => 1576839727.7935
            [time_taken] => 2.7894973754883E-5
            [argv] => Array
                (
                    [0] => a.txt
                )

        )

    [1] => Array
        (
            [function] => file_get_contents
            [entered] => 1576839727.7935
            [exited] => 1576839727.7935
            [time_taken] => 7.8678131103516E-6
            [argv] => Array
                (
                    [0] => b.txt
                )

        )

)


List functions scoutapm will instrument.

  • « scoutapm_get_calls
  • SNMP »
  • PHP Manual
  • Scoutapm Funciones
  • List functions scoutapm will instrument.

scoutapm_list_instrumented_functions

(PECL scoutapm >= 1.0.2)

scoutapm_list_instrumented_functions — List functions scoutapm will instrument.

Descripción

scoutapm_list_instrumented_functions ( ) : array

Returns a list of the functions the extension will instrument.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

scoutapm_list_instrumented_functions() returns an array containing a list of all functions that the scoutapm extension is able to instrument in the current installation.

Ejemplos

Ejemplo #1 Fetch the list of functions scoutapm will instrument

<?php
print_r(scoutapm_list_instrumented_functions());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => file_get_contents
    [1] => file_put_contents
    [2] => fopen
    [3] => fread
    [4] => fwrite
    [5] => pdo->exec
    [6] => pdo->query
    [7] => pdo->prepare
    [8] => pdostatement->execute
)


SNMP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones SNMP
    • snmp_get_quick_print — Fetches the current value of the NET-SNMP library's quick_print setting
    • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
    • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print — Set the OID output format
    • snmp_set_oid_output_format — Set the OID output format
    • snmp_set_quick_print — Set the value of enable within the NET-SNMP library
    • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
    • snmp2_get — Fetch an SNMP object
    • snmp2_getnext — Fetch the SNMP object which follows the given object id
    • snmp2_real_walk — Return all objects including their respective object ID within the specified one
    • snmp2_set — Set the value of an SNMP object
    • snmp2_walk — Fetch all the SNMP objects from an agent
    • snmp3_get — Fetch an SNMP object
    • snmp3_getnext — Fetch the SNMP object which follows the given object id
    • snmp3_real_walk — Return all objects including their respective object ID within the specified one
    • snmp3_set — Set the value of an SNMP object
    • snmp3_walk — Fetch all the SNMP objects from an agent
    • snmpget — Fetch an SNMP object
    • snmpgetnext — Fetch the SNMP object which follows the given object id
    • snmprealwalk — Return all objects including their respective object ID within the specified one
    • snmpset — Set the value of an SNMP object
    • snmpwalk — Fetch all the SNMP objects from an agent
    • snmpwalkoid — Query for a tree of information about a network entity
  • SNMP — The SNMP class
    • SNMP::close — Cerrar sesión SNMP
    • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
    • SNMP::get — Fetch an SNMP object
    • SNMP::getErrno — Get last error code
    • SNMP::getError — Obtiene el último mensaje de error
    • SNMP::getnext — Fetch an SNMP object which follows the given object id
    • SNMP::set — Set the value of an SNMP object
    • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
    • SNMP::walk — Fetch SNMP object subtree
  • SNMPException — The SNMPException class


Introducción

The SNMP extension provides a very simple and easily usable toolset for managing remote devices via the Simple Network Management Protocol.

As it is a wrapper around the underlying Net-SNMP library, all basic concepts are the same and the PHP functions change their behaviour depending on the Net-SNMP configuration files and environment variables.

More information about Net-SNMP can be found at » http://www.net-snmp.org/


Requerimientos

Para usar las funciones SNMP se requiere la instalación del paquete » Net-SNMP. Las funciones SNMPv3 solo están disponibles si el paquete » OpenSSL está instalado también.

Desde PHP 5.4.0, Net-SNMP versión 5.3+ es necesaria para instalaciones Unix y Net-SNMP versión 5.4+ para Windows.


Instalación

The Windows distribution of Net-SNMP contains support files for SNMP in the mibs directory. This directory should added to Windows' environment variables, as MIBDIRS, with the value being the full path to the mibs directory: e.g. c:\usr\mibs.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

For the snmp_set_oid_output_format()
SNMP_OID_OUTPUT_SUFFIX (int)
SNMP_OID_OUTPUT_MODULE (int)
SNMP_OID_OUTPUT_FULL (int)
SNMP_OID_OUTPUT_NUMERIC (int)
SNMP_OID_OUTPUT_UCD (int)
SNMP_OID_OUTPUT_NONE (int)
For the snmp_set_valueretrieval()
SNMP_VALUE_LIBRARY (int)
SNMP_VALUE_PLAIN (int)
SNMP_VALUE_OBJECT (int)
SNMP types as returned if SNMP_VALUE_OBJECT was used with snmp_set_valueretrieval()
SNMP_BIT_STR (int)
SNMP_OCTET_STR (int)
SNMP_OPAQUE (int)
SNMP_NULL (int)
SNMP_OBJECT_ID (int)
SNMP_IPADDRESS (int)
SNMP_COUNTER (int)
SNMP_UNSIGNED (int)
SNMP_TIMETICKS (int)
SNMP_UINTEGER (int)
SNMP_INTEGER (int)
SNMP_COUNTER64 (int)


Funciones SNMP

Tabla de contenidos

  • snmp_get_quick_print — Fetches the current value of the NET-SNMP library's quick_print setting
  • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
  • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
  • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
  • snmp_set_oid_numeric_print — Set the OID output format
  • snmp_set_oid_output_format — Set the OID output format
  • snmp_set_quick_print — Set the value of enable within the NET-SNMP library
  • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
  • snmp2_get — Fetch an SNMP object
  • snmp2_getnext — Fetch the SNMP object which follows the given object id
  • snmp2_real_walk — Return all objects including their respective object ID within the specified one
  • snmp2_set — Set the value of an SNMP object
  • snmp2_walk — Fetch all the SNMP objects from an agent
  • snmp3_get — Fetch an SNMP object
  • snmp3_getnext — Fetch the SNMP object which follows the given object id
  • snmp3_real_walk — Return all objects including their respective object ID within the specified one
  • snmp3_set — Set the value of an SNMP object
  • snmp3_walk — Fetch all the SNMP objects from an agent
  • snmpget — Fetch an SNMP object
  • snmpgetnext — Fetch the SNMP object which follows the given object id
  • snmprealwalk — Return all objects including their respective object ID within the specified one
  • snmpset — Set the value of an SNMP object
  • snmpwalk — Fetch all the SNMP objects from an agent
  • snmpwalkoid — Query for a tree of information about a network entity


Fetches the current value of the NET-SNMP library's quick_print setting

  • « Funciones SNMP
  • snmp_get_valueretrieval »
  • PHP Manual
  • Funciones SNMP
  • Fetches the current value of the NET-SNMP library's quick_print setting

snmp_get_quick_print

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp_get_quick_print — Fetches the current value of the NET-SNMP library's quick_print setting

Descripción

snmp_get_quick_print ( ) : bool

Returns the current value stored in the NET-SNMP Library for quick_print. quick_print is off by default.

Valores devueltos

Returns true if quick_print is on, false otherwise.

Ejemplos

Ejemplo #1 snmp_get_quick_print() example

<?php
$quickprint = snmp_get_quick_print();
?>

Ver también

  • snmp_set_quick_print() - Set the value of enable within the NET-SNMP library for a full description of what quick_print does.


Return the method how the SNMP values will be returned

  • « snmp_get_quick_print
  • snmp_read_mib »
  • PHP Manual
  • Funciones SNMP
  • Return the method how the SNMP values will be returned

snmp_get_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

snmp_get_valueretrieval — Return the method how the SNMP values will be returned

Descripción

snmp_get_valueretrieval ( ) : int

Valores devueltos

OR-ed combitantion of constants ( SNMP_VALUE_LIBRARY or SNMP_VALUE_PLAIN ) with possible SNMP_VALUE_OBJECT set.

Ejemplos

Ejemplo #1 Using snmp_get_valueretrieval

<?php
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 if (snmp_get_valueretrieval() & SNMP_VALUE_OBJECT) {
   echo $ret->value;
 } else {
   echo $ret;
 }
?>

Ver también

  • snmp_set_valueretrieval() - Specify the method how the SNMP values will be returned
  • Constantes predefinidas


Reads and parses a MIB file into the active MIB tree

  • « snmp_get_valueretrieval
  • snmp_set_enum_print »
  • PHP Manual
  • Funciones SNMP
  • Reads and parses a MIB file into the active MIB tree

snmp_read_mib

(PHP 5, PHP 7, PHP 8)

snmp_read_mib — Reads and parses a MIB file into the active MIB tree

Descripción

snmp_read_mib ( string $filename ) : bool

This function is used to load additional, e.g. vendor specific, MIBs so that human readable OIDs like VENDOR-MIB::foo.1 instead of error prone numeric OIDs can be used.

The order in which the MIBs are loaded does matter as the underlying Net-SNMP libary will print warnings if referenced objects cannot be resolved.

Parámetros

filename

The filename of the MIB.

Ejemplos

Ejemplo #1 Using snmp_read_mib()

<?php
 print_r( snmprealwalk('localhost', 'public', '.1.3.6.1.2.1.2.3.4.5') );

 snmp_read_mib('./FOO-BAR-MIB.txt');
 print_r( snmprealwalk('localhost', 'public', 'FOO-BAR-MIB::someTable' );
?>

The above example is made up but the results would look like:

Array
(
    [iso.3.6.1.2.1.2.3.4.5.0] => Gauge32: 6
)
Array
(
    [FOO-BAR-MIB::someTable.0] => Gauge32: 6
)


Return all values that are enums with their enum value instead of the raw integer

  • « snmp_read_mib
  • snmp_set_oid_numeric_print »
  • PHP Manual
  • Funciones SNMP
  • Return all values that are enums with their enum value instead of the raw integer

snmp_set_enum_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer

Descripción

snmp_set_enum_print ( bool $enable ) : bool

This function toggles if snmpwalk/snmpget etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

Parámetros

enable

As the value is interpreted as boolean by the Net-SNMP library, it can only be "0" or "1".

Ejemplos

Ejemplo #1 Using snmp_set_enum_print()

<?php
 snmp_set_enum_print(0);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
 snmp_set_enum_print(1);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
?>

The above would return

 INTEGER: up(1)
 INTEGER: 1


Set the OID output format

  • « snmp_set_enum_print
  • snmp_set_oid_output_format »
  • PHP Manual
  • Funciones SNMP
  • Set the OID output format

snmp_set_oid_numeric_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

snmp_set_oid_numeric_print — Set the OID output format

Descripción

snmp_set_oid_numeric_print ( int $format ) : bool

Esta función es un alias de: snmp_set_oid_output_format().

Ver también

  • snmp_set_oid_output_format() - Set the OID output format


Set the OID output format

  • « snmp_set_oid_numeric_print
  • snmp_set_quick_print »
  • PHP Manual
  • Funciones SNMP
  • Set the OID output format

snmp_set_oid_output_format

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

snmp_set_oid_output_format — Set the OID output format

Descripción

snmp_set_oid_output_format ( int $format ) : bool

snmp_set_oid_output_format() sets the output format to be full or numeric.

Parámetros

format
OID .1.3.6.1.2.1.1.3.0 representation for various format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0

Begining from PHP 5.4.0 four additional constants available:

SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Using snmprealwalk()

<?php

 snmp_read_mib("/usr/share/mibs/netsnmp/NET-SNMP-TC");

 // default or SNMP_OID_OUTPUT_MODULE in PHP >= 5.3.6
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_NUMERIC);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_FULL);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );
?>

The above would output:

 Array
 (
    [RFC1213-MIB::sysObjectID.0] => OID: NET-SNMP-TC::linux
 )
 Array
 (
    [.1.3.6.1.2.1.1.2.0] => OID: .1.3.6.1.4.1.8072.3.2.10
 )
 Array
 (
    [.iso.org.dod.internet.mgmt.mib-2.system.sysObjectID.0] => OID: .iso.org.dod.internet.private.enterprises.netSnmp.netSnmpEnumerations.netSnmpAgentOIDs.linux
 )


Set the value of enable within the NET-SNMP library

  • « snmp_set_oid_output_format
  • snmp_set_valueretrieval »
  • PHP Manual
  • Funciones SNMP
  • Set the value of enable within the NET-SNMP library

snmp_set_quick_print

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp_set_quick_print — Set the value of enable within the NET-SNMP library

Descripción

snmp_set_quick_print ( bool $enable ) : bool

Sets the value of enable within the NET-SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When enable is not enabled (default) the NET-SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

By default the NET-SNMP library returns verbose values, quick_print is used to return only the value.

Currently strings are still returned with extra quotes, this will be corrected in a later release.

Parámetros

enable

Valores devueltos

No devuelve ningún valor.

Ejemplos

Setting quick_print is often used when using the information returned rather than displaying it.

Ejemplo #1 Using snmp_set_quick_print()

<?php
snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
?>

El resultado del ejemplo sería algo similar a:

'Timeticks: (0) 0:00:00.00'
'0:00:00.00'

Ver también

  • snmp_get_quick_print() - Fetches the current value of the NET-SNMP library's quick_print setting


Specify the method how the SNMP values will be returned

  • « snmp_set_quick_print
  • snmp2_get »
  • PHP Manual
  • Funciones SNMP
  • Specify the method how the SNMP values will be returned

snmp_set_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

snmp_set_valueretrieval — Specify the method how the SNMP values will be returned

Descripción

snmp_set_valueretrieval ( int $method ) : bool

Parámetros

method
types
SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of constants SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set.

Ejemplos

Ejemplo #1 Using snmp_set_valueretrieval()

<?php
 snmp_set_valueretrieval(SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "STRING: lo"

 snmp_set_valueretrieval(SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "lo";

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 // PHP 5.4+ examples
 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => STRING: lo
 // )

?>

Ver también

  • snmp_get_valueretrieval() - Return the method how the SNMP values will be returned
  • Constantes predefinidas


Fetch an SNMP object

  • « snmp_set_valueretrieval
  • snmp2_getnext »
  • PHP Manual
  • Funciones SNMP
  • Fetch an SNMP object

snmp2_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

snmp2_get — Fetch an SNMP object

Descripción

snmp2_get ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp2_get() function is used to read the value of an SNMP object specified by the object_id.

Parámetros

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error.

Ejemplos

Ejemplo #1 Using snmp2_get()

<?php
$syscontact = snmp2_get("127.0.0.1", "public", "system.SysContact.0");
?>

Ver también

  • snmp2_set() - Set the value of an SNMP object


Fetch the SNMP object which follows the given object id

  • « snmp2_get
  • snmp2_real_walk »
  • PHP Manual
  • Funciones SNMP
  • Fetch the SNMP object which follows the given object id

snmp2_getnext

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_getnext — Fetch the SNMP object which follows the given object id

Descripción

snmp2_getnext ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp2_get_next() function is used to read the value of the SNMP object that follows the specified object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmp2_get_next()

<?php
$nameOfSecondInterface = snmp2_get_next('localhost', 'public', 'IF-MIB::ifName.1';
?>

Ver también

  • snmp2_get() - Fetch an SNMP object
  • snmp2_walk() - Fetch all the SNMP objects from an agent


Return all objects including their respective object ID within the specified one

  • « snmp2_getnext
  • snmp2_set »
  • PHP Manual
  • Funciones SNMP
  • Return all objects including their respective object ID within the specified one

snmp2_real_walk

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_real_walk — Return all objects including their respective object ID within the specified one

Descripción

snmp2_real_walk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

The snmp2_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmp2_real_walk()

<?php
 print_r(snmp2_real_walk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

Ver también

  • snmp2_walk() - Fetch all the SNMP objects from an agent


Set the value of an SNMP object

  • « snmp2_real_walk
  • snmp2_walk »
  • PHP Manual
  • Funciones SNMP
  • Set the value of an SNMP object

snmp2_set

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_set — Set the value of an SNMP object

Descripción

snmp2_set ( string $hostname , string $community , array|string $object_id , array|string $type , array|string $value , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp2_set() is used to set the value of an SNMP object specified by the object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The write community.

object_id

The SNMP object id.

type

MIB define el tipo de cada identificador de objeto. Debe indicarse con un único carácter de la siguiente lista.

tipos
= Tipo adquirido a partir de MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

Si se definió OPAQUE_SPECIAL_TYPES al compilar la biblioteca SNMP, los siguientes valores serán también válidos:

tipos
U | int64 sin signo
I | int64 con signo
F | float
D | double

La mayoría, utilizarán su correspondiente tipo ASN.1. 's', 'x', 'd' y 'b' son diferentes formas de especificar un valor de OCTET STRING, y el tipo sin signo 'u' se usa también para manejar valores Gauge32.

Si se cargan los ficheros MIB en el árbol MIB con "snmp_read_mib" o con la configuración de libsnmp, se puede usar '=' como parámetro type para todos los id de objetos, ya que se podrá leer automáticamente el tipo a partir del MIB.

Tenga presente que hay dos formas de asigar a una variable los tipos BITS, como por ejemplo. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Usando el tipo "b" y una lista numérica de bits. No se recomienda usar este método, ya que una consulta GET para un mismo OID devolvería, por ejemplo 0xF8.
  • Usando el tipo "x" y un número hexadecimal, pero si el prefijo "0x".

Revise el apartado de ejemplos para más detalles.

value

The new value.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Ejemplos

Ejemplo #1 Using snmp2_set()

<?php
  snmp2_set("localhost", "public", "IF-MIB::ifAlias.3", "s", "foo");
?>

Ejemplo #2 Using snmp2_set() for setting BITS SNMP object id

<?php
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'x', 'F0');
?>

Ver también

  • snmp2_get() - Fetch an SNMP object


Fetch all the SNMP objects from an agent

  • « snmp2_set
  • snmp3_get »
  • PHP Manual
  • Funciones SNMP
  • Fetch all the SNMP objects from an agent

snmp2_walk

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_walk — Fetch all the SNMP objects from an agent

Descripción

snmp2_walk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp2_walk() function is used to read all the values from an SNMP agent specified by the hostname.

Parámetros

hostname

The SNMP agent (server).

community

The read community.

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an array of SNMP object values starting from the object_id as root or false on error.

Ejemplos

Ejemplo #1 snmp2_walk() Example

<?php
$a = snmp2_walk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ver también

  • snmp2_real_walk() - Return all objects including their respective object ID within the specified one


Fetch an SNMP object

  • « snmp2_walk
  • snmp3_getnext »
  • PHP Manual
  • Funciones SNMP
  • Fetch an SNMP object

snmp3_get

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_get — Fetch an SNMP object

Descripción

snmp3_get ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp3_get() function is used to read the value of an SNMP object specified by the object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error.

Ejemplos

Ejemplo #1 Using snmp3_get()

<?php
$nameOfSecondInterface = snmp3_get('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.2');
?>

Ver también

  • snmp3_set() - Set the value of an SNMP object


Fetch the SNMP object which follows the given object id

  • « snmp3_get
  • snmp3_real_walk »
  • PHP Manual
  • Funciones SNMP
  • Fetch the SNMP object which follows the given object id

snmp3_getnext

(PHP 5, PHP 7, PHP 8)

snmp3_getnext — Fetch the SNMP object which follows the given object id

Descripción

snmp3_getnext ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp3_getnext() function is used to read the value of the SNMP object that follows the specified object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmp3_getnext()

<?php
$nameOfSecondInterface = snmp3_getnext('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.1');
?>

Ver también

  • snmp3_get() - Fetch an SNMP object
  • snmp3_walk() - Fetch all the SNMP objects from an agent


Return all objects including their respective object ID within the specified one

  • « snmp3_getnext
  • snmp3_set »
  • PHP Manual
  • Funciones SNMP
  • Return all objects including their respective object ID within the specified one

snmp3_real_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_real_walk — Return all objects including their respective object ID within the specified one

Descripción

snmp3_real_walk ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

The snmp3_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Parámetros

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmp3_real_walk()

<?php
 var_export(snmp3_real_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName'));
?>

The above will output something like:

array (
  'IF-MIB::ifName.1' => 'STRING: lo',
  'IF-MIB::ifName.2' => 'STRING: eth0',
  'IF-MIB::ifName.3' => 'STRING: eth2',
  'IF-MIB::ifName.4' => 'STRING: sit0',
  'IF-MIB::ifName.5' => 'STRING: sixxs',
)

Ver también

  • snmpwalk() - Fetch all the SNMP objects from an agent


Set the value of an SNMP object

  • « snmp3_real_walk
  • snmp3_walk »
  • PHP Manual
  • Funciones SNMP
  • Set the value of an SNMP object

snmp3_set

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_set — Set the value of an SNMP object

Descripción

snmp3_set ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , array|string $type , array|string $value , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp3_set() is used to set the value of an SNMP object specified by the object_id.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

Parámetros

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

type

MIB define el tipo de cada identificador de objeto. Debe indicarse con un único carácter de la siguiente lista.

tipos
= Tipo adquirido a partir de MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

Si se definió OPAQUE_SPECIAL_TYPES al compilar la biblioteca SNMP, los siguientes valores serán también válidos:

tipos
U | int64 sin signo
I | int64 con signo
F | float
D | double

La mayoría, utilizarán su correspondiente tipo ASN.1. 's', 'x', 'd' y 'b' son diferentes formas de especificar un valor de OCTET STRING, y el tipo sin signo 'u' se usa también para manejar valores Gauge32.

Si se cargan los ficheros MIB en el árbol MIB con "snmp_read_mib" o con la configuración de libsnmp, se puede usar '=' como parámetro type para todos los id de objetos, ya que se podrá leer automáticamente el tipo a partir del MIB.

Tenga presente que hay dos formas de asigar a una variable los tipos BITS, como por ejemplo. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Usando el tipo "b" y una lista numérica de bits. No se recomienda usar este método, ya que una consulta GET para un mismo OID devolvería, por ejemplo 0xF8.
  • Usando el tipo "x" y un número hexadecimal, pero si el prefijo "0x".

Revise el apartado de ejemplos para más detalles.

value

The new value

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Ejemplos

Ejemplo #1 Using snmp3_set()

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifAlias.3', 's', "foo");
?>

Ejemplo #2 Using snmp3_set() for setting BITS SNMP object id

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'x', 'F0');
?>


Fetch all the SNMP objects from an agent

  • « snmp3_set
  • snmpget »
  • PHP Manual
  • Funciones SNMP
  • Fetch all the SNMP objects from an agent

snmp3_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_walk — Fetch all the SNMP objects from an agent

Descripción

snmp3_walk ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp3_walk() function is used to read all the values from an SNMP agent specified by the hostname.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

Parámetros

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an array of SNMP object values starting from the object_id as root or false on error.

Ejemplos

Ejemplo #1 snmp3_walk() Example

<?php
$ret = snmp3_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName');
var_export($ret);
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost:

array (
  0 => 'STRING: lo',
  1 => 'STRING: eth0',
  2 => 'STRING: eth2',
  3 => 'STRING: sit0',
  4 => 'STRING: sixxs',
)

Ver también

  • snmp3_real_walk() - Return all objects including their respective object ID within the specified one


Fetch an SNMP object

  • « snmp3_walk
  • snmpgetnext »
  • PHP Manual
  • Funciones SNMP
  • Fetch an SNMP object

snmpget

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpget — Fetch an SNMP object

Descripción

snmpget ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmpget() function is used to read the value of an SNMP object specified by the object_id.

Parámetros

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error.

Ejemplos

Ejemplo #1 Using snmpget()

<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>

Ver también

  • snmpset() - Set the value of an SNMP object


Fetch the SNMP object which follows the given object id

  • « snmpget
  • snmprealwalk »
  • PHP Manual
  • Funciones SNMP
  • Fetch the SNMP object which follows the given object id

snmpgetnext

(PHP 5, PHP 7, PHP 8)

snmpgetnext — Fetch the SNMP object which follows the given object id

Descripción

snmpgetnext ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmpgetnext() function is used to read the value of the SNMP object that follows the specified object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmpgetnext()

<?php
$nameOfSecondInterface = snmpgetnetxt('localhost', 'public', 'IF-MIB::ifName.1';
?>

Ver también

  • snmpget() - Fetch an SNMP object
  • snmpwalk() - Fetch all the SNMP objects from an agent


Return all objects including their respective object ID within the specified one

  • « snmpgetnext
  • snmpset »
  • PHP Manual
  • Funciones SNMP
  • Return all objects including their respective object ID within the specified one

snmprealwalk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmprealwalk — Return all objects including their respective object ID within the specified one

Descripción

snmprealwalk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

The snmprealwalk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

Ejemplos

Ejemplo #1 Using snmprealwalk()

<?php
 print_r(snmprealwalk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

Ver también

  • snmpwalk() - Fetch all the SNMP objects from an agent


Set the value of an SNMP object

  • « snmprealwalk
  • snmpwalk »
  • PHP Manual
  • Funciones SNMP
  • Set the value of an SNMP object

snmpset

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpset — Set the value of an SNMP object

Descripción

snmpset ( string $hostname , string $community , array|string $object_id , array|string $type , array|string $value , int $timeout = -1 , int $retries = -1 ) : array|bool

snmpset() is used to set the value of an SNMP object specified by the object_id.

Parámetros

hostname

The hostname of the SNMP agent (server).

community

The write community.

object_id

The SNMP object id.

type

MIB define el tipo de cada identificador de objeto. Debe indicarse con un único carácter de la siguiente lista.

tipos
= Tipo adquirido a partir de MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

Si se definió OPAQUE_SPECIAL_TYPES al compilar la biblioteca SNMP, los siguientes valores serán también válidos:

tipos
U | int64 sin signo
I | int64 con signo
F | float
D | double

La mayoría, utilizarán su correspondiente tipo ASN.1. 's', 'x', 'd' y 'b' son diferentes formas de especificar un valor de OCTET STRING, y el tipo sin signo 'u' se usa también para manejar valores Gauge32.

Si se cargan los ficheros MIB en el árbol MIB con "snmp_read_mib" o con la configuración de libsnmp, se puede usar '=' como parámetro type para todos los id de objetos, ya que se podrá leer automáticamente el tipo a partir del MIB.

Tenga presente que hay dos formas de asigar a una variable los tipos BITS, como por ejemplo. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Usando el tipo "b" y una lista numérica de bits. No se recomienda usar este método, ya que una consulta GET para un mismo OID devolvería, por ejemplo 0xF8.
  • Usando el tipo "x" y un número hexadecimal, pero si el prefijo "0x".

Revise el apartado de ejemplos para más detalles.

value

The new value.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Ejemplos

Ejemplo #1 Using snmpset()

<?php
  snmpset("localhost", "public", "IF-MIB::ifAlias.3", "s", "foo");
?>

Ejemplo #2 Using snmpset() for setting BITS SNMP object id

<?php
  snmpset("localhost", "public", 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmpset("localhost", "public", 'FOO-MIB::bar.42', 'x', 'F0');
?>

Ver también

  • snmpget() - Fetch an SNMP object


Fetch all the SNMP objects from an agent

  • « snmpset
  • snmpwalkoid »
  • PHP Manual
  • Funciones SNMP
  • Fetch all the SNMP objects from an agent

snmpwalk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpwalk — Fetch all the SNMP objects from an agent

Descripción

snmpwalk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmpwalk() function is used to read all the values from an SNMP agent specified by the hostname.

Parámetros

hostname

The SNMP agent (server).

community

The read community.

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an array of SNMP object values starting from the object_id as root or false on error.

Ejemplos

Ejemplo #1 snmpwalk() Example

<?php
$a = snmpwalk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ver también

  • snmprealwalk() - Return all objects including their respective object ID within the specified one


Query for a tree of information about a network entity

  • « snmpwalk
  • SNMP »
  • PHP Manual
  • Funciones SNMP
  • Query for a tree of information about a network entity

snmpwalkoid

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpwalkoid — Query for a tree of information about a network entity

Descripción

snmpwalkoid ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmpwalkoid() function is used to read all object ids and their respective values from an SNMP agent specified by hostname.

The existence of snmpwalkoid() and snmpwalk() has historical reasons. Both functions are provided for backward compatibility. Use snmprealwalk() instead.

Parámetros

hostname

The SNMP agent.

community

The read community.

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Valores devueltos

Returns an associative array with object ids and their respective object value starting from the object_id as root or false on error.

Ejemplos

Ejemplo #1 snmpwalkoid() Example

<?php
$a = snmpwalkoid("127.0.0.1", "public", "");
for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br />\n";
}
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ver también

  • snmpwalk() - Fetch all the SNMP objects from an agent


The SNMP class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Introducción

Represents SNMP session.

Sinopsis de la Clase

SNMP {
/* Propiedades */
public int $max_oids ;
public int $valueretrieval ;
public bool $quick_print ;
public bool $enum_print ;
public int $oid_output_format ;
public bool $oid_increasing_check ;
public int $exceptions_enabled ;
public array $info ;
/* Métodos */
public __construct ( int $version , string $hostname , string $community , int $timeout = -1 , int $retries = -1 )
public close ( ) : bool
public get ( array|string $objectId , bool $preserveKeys = false ) : array|bool
public getErrno ( ) : int
public getError ( ) : string
public getnext ( array|string $objectId ) : array|bool
public set ( array|string $objectId , array|string $type , array|string $value ) : array|bool
public setSecurity
 ( string $securityLevel
, string $authProtocol = ""
, string $authPassphrase = ""
, string $privacyProtocol = ""
, string $privacyPassphrase = ""
, string $contextName = ""
, string $contextEngineId = ""
) : bool
public walk ( array|string $objectId , bool $suffixAsKey = false , int $maxRepetitions = -1 , int $nonRepeaters = -1 ) : array|bool
/* Constantes */
const int ERRNO_NOERROR = 0 ;
const int ERRNO_GENERIC = 2 ;
const int ERRNO_TIMEOUT = 4 ;
const int ERRNO_ERROR_IN_REPLY = 8 ;
const int ERRNO_OID_NOT_INCREASING = 16 ;
const int ERRNO_OID_PARSING_ERROR = 32 ;
const int ERRNO_MULTIPLE_SET_QUERIES = 64 ;
const int ERRNO_ANY = 126 ;
const int VERSION_1 = 0 ;
const int VERSION_2C = 1 ;
const int VERSION_2c = 1 ;
const int VERSION_3 = 3 ;
}

Propiedades

max_oids

Maximum OID per GET/SET/GETBULK request

valueretrieval

Controls the method how the SNMP values will be returned

SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set
quick_print

Value of quick_print within the NET-SNMP library

Sets the value of quick_print within the NET-SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the NET-SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

enum_print

Controls the way enum values are printed

Parameter toggles if walk/get etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

oid_output_format

Controls OID output format

OID .1.3.6.1.2.1.1.3.0 representation for various oid_output_format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0
SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined
oid_increasing_check

Controls disabling check for increasing OID while walking OID tree

Some SNMP agents are known for returning OIDs out of order but can complete the walk anyway. Other agents return OIDs that are out of order and can cause SNMP::walk() to loop indefinitely until memory limit will be reached. PHP SNMP library by default performs OID increasing check and stops walking on OID tree when it detects possible loop with issuing warning about non-increasing OID faced. Set oid_increasing_check to false to disable this check.

exceptions_enabled

Controls which failures will raise SNMPException instead of warning. Use bitwise OR'ed SNMP::ERRNO_* constants. By default all SNMP exceptions are disabled.

info

Read-only property with remote agent configuration: hostname, port, default timeout, default retries count

Constantes predefinidas

SNMP Error Types

SNMP::ERRNO_NOERROR

No SNMP-specific error occurred.

SNMP::ERRNO_GENERIC

A generic SNMP error occurred.

SNMP::ERRNO_TIMEOUT

Request to SNMP agent timed out.

SNMP::ERRNO_ERROR_IN_REPLY

SNMP agent returned an error in reply.

SNMP::ERRNO_OID_NOT_INCREASING

SNMP agent faced OID cycling reporning non-increasing OID while executing (BULK)WALK command. This indicates bogus remote SNMP agent.

SNMP::ERRNO_OID_PARSING_ERROR

Library failed while parsing OID (and/or type for SET command). No queries has been made.

SNMP::ERRNO_MULTIPLE_SET_QUERIES

Library will use multiple queries for SET operation requested. That means that operation will be performed in a non-transaction manner and second or subsequent chunks may fail if a type or value failure will be faced.

SNMP::ERRNO_ANY

All SNMP::ERRNO_* codes bitwise OR'ed.

SNMP Protocol Versions

SNMP::VERSION_1

SNMP::VERSION_2C, SNMP::VERSION_2c

SNMP::VERSION_3

Tabla de contenidos

  • SNMP::close — Cerrar sesión SNMP
  • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
  • SNMP::get — Fetch an SNMP object
  • SNMP::getErrno — Get last error code
  • SNMP::getError — Obtiene el último mensaje de error
  • SNMP::getnext — Fetch an SNMP object which follows the given object id
  • SNMP::set — Set the value of an SNMP object
  • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
  • SNMP::walk — Fetch SNMP object subtree


Cerrar sesión SNMP

  • « SNMP
  • SNMP::__construct »
  • PHP Manual
  • SNMP
  • Cerrar sesión SNMP

SNMP::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::close — Cerrar sesión SNMP

Descripción

public SNMP::close ( ) : bool

Libera previamente asignado un objeto de sesión SNMP.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SNMP::close()

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  # ...
  # get, walk, etc va aquí
  # ...
  $session->close();
?>

Ver también

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent


Creates SNMP instance representing session to remote SNMP agent

  • « SNMP::close
  • SNMP::get »
  • PHP Manual
  • SNMP
  • Creates SNMP instance representing session to remote SNMP agent

SNMP::__construct

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent

Descripción

public SNMP::__construct ( int $version , string $hostname , string $community , int $timeout = -1 , int $retries = -1 )

The function description goes here.

Parámetros

version

SNMP protocol version:
SNMP::VERSION_1,
SNMP::VERSION_2C,
SNMP::VERSION_3.

hostname

The SNMP agent. hostname may be suffixed with optional SNMP agent port after colon. IPv6 addresses must be enclosed in square brackets if used with port. If FQDN is used for hostname it will be resolved by php-snmp library, not by Net-SNMP engine. Usage of IPv6 addresses when specifying FQDN may be forced by enclosing FQDN into square brackets. Here it is some examples:

IPv4 with default port | 127.0.0.1
IPv6 with default port | ::1 or [::1]
IPv4 with specific port | 127.0.0.1:1161
IPv6 with specific port | [::1]:1161
FQDN with default port | host.domain
FQDN with specific port | host.domain:1161
FQDN with default port, force usage of IPv6 address | [host.domain]
FQDN with specific port, force usage of IPv6 address | [host.domain]:1161

community

The purpuse of community is SNMP version specific:

SNMP::VERSION_1 | SNMP community
SNMP::VERSION_2C | SNMP community
SNMP::VERSION_3 | SNMPv3 securityName
timeout

The number of microseconds until the first timeout.

retries

The number of retries in case timeout occurs.

Valores devueltos

Returns SNMP object representing remote SNMP agent.

Errores/Excepciones

SNMP::__construct() throws an exception when parameters count or types are wrong or unknown SNMP protocol version specified.

Ejemplos

Ejemplo #1 Fetching sysLocation

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
?>

El resultado del ejemplo sería algo similar a:

STRING: Test server

Ver también

  • SNMP::close() - Cerrar sesión SNMP


Fetch an SNMP object

  • « SNMP::__construct
  • SNMP::getErrno »
  • PHP Manual
  • SNMP
  • Fetch an SNMP object

SNMP::get

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::get — Fetch an SNMP object

Descripción

public SNMP::get ( array|string $objectId , bool $preserveKeys = false ) : array|bool

Fetch an SNMP object specified in objectId using GET query.

Parámetros

If objectId is a string, then SNMP::get() will return SNMP object as string. If objectId is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

objectId

The SNMP object (OID) or objects

preserveKeys

When objectId is a array and preserveKeys set to true keys in results will be taken exactly as in objectId, otherwise SNMP::oid_output_format property is used to determinate the form of keys.

Valores devueltos

Returns SNMP objects requested as string or array depending on objectId type or false on error.

Errores/Excepciones

Este método no lanza ninguna excepción de manera predeterminada. Para poder lanzar una excepción SNMPException cuando ocurre alguno de los errores de la biblioteca el parámetro exceptions_enabled de la clase SNMP se debería establecer al valor correspondiente. Véase la explicación de SNMP::$exceptions_enabled para más detalles.

Ejemplos

Ejemplo #1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
  $sysdescr = $session->get(array("sysDescr.0"));
  print_r($sysdescr);
?>

El resultado del ejemplo sería algo similar a:

STRING: Test server
Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
)

Ejemplo #2 Multiple SNMP objects

$session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->get(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();

El resultado del ejemplo sería algo similar a:

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysName.0] => STRING: myhost.nodomain
)

Ver también

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Obtiene el último mensaje de error


Get last error code

  • « SNMP::get
  • SNMP::getError »
  • PHP Manual
  • SNMP
  • Get last error code

SNMP::getErrno

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getErrno — Get last error code

Descripción

public SNMP::getErrno ( ) : int

Devuelve código de error de la última solicitud SNMP.

Valores devueltos

Devuelve uno de los valores de error que se describe en el capítulo constantes.

Ejemplos

Ejemplo #1 Ejemplo de SNMP::getErrno()

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getErrno() == SNMP::ERRNO_TIMEOUT);
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • SNMP::getError() - Obtiene el último mensaje de error


Obtiene el último mensaje de error

  • « SNMP::getErrno
  • SNMP::getnext »
  • PHP Manual
  • SNMP
  • Obtiene el último mensaje de error

SNMP::getError

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getError — Obtiene el último mensaje de error

Descripción

public SNMP::getError ( ) : string

Devuelve un string con el error de la última solicitud SNMP.

Valores devueltos

String describing error from last SNMP request. String que describe el error de la última solicitud SNMP.

Ejemplos

Ejemplo #1 Ejemplo de SNMP::getError()

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getError());
?>

El resultado del ejemplo sería:

bool(false)
string(26) "No response from 127.0.0.1"

Ver también

  • SNMP::getErrno() - Get last error code


Fetch an SNMP object which follows the given object id

  • « SNMP::getError
  • SNMP::set »
  • PHP Manual
  • SNMP
  • Fetch an SNMP object which follows the given object id

SNMP::getnext

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getnext — Fetch an SNMP object which follows the given object id

Descripción

public SNMP::getnext ( array|string $objectId ) : array|bool

Fetch an SNMP object that follows specified objectId.

Parámetros

If objectId is a string, then SNMP::getnext() will return SNMP object as string. If objectId is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

objectId

The SNMP object (OID) or objects

Valores devueltos

Returns SNMP objects requested as string or array depending on objectId type or false on error.

Errores/Excepciones

Este método no lanza ninguna excepción de manera predeterminada. Para poder lanzar una excepción SNMPException cuando ocurre alguno de los errores de la biblioteca el parámetro exceptions_enabled de la clase SNMP se debería establecer al valor correspondiente. Véase la explicación de SNMP::$exceptions_enabled para más detalles.

Ejemplos

Ejemplo #1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $nsysdescr = $session->getnext("sysDescr.0");
  echo "$nsysdescr\n";
  $nsysdescr = $session->getnext(array("sysDescr.0"));
  print_r($nsysdescr);
?>

El resultado del ejemplo sería algo similar a:

OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
)

Ejemplo #2 Miltiple SNMP objects

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->getnext(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [SNMPv2-MIB::sysLocation.0] => STRING: Nowhere
)

Ver también

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Obtiene el último mensaje de error


Set the value of an SNMP object

  • « SNMP::getnext
  • SNMP::setSecurity »
  • PHP Manual
  • SNMP
  • Set the value of an SNMP object

SNMP::set

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::set — Set the value of an SNMP object

Descripción

public SNMP::set ( array|string $objectId , array|string $type , array|string $value ) : array|bool

Requests remote SNMP agent setting the value of one or more SNMP objects specified by the objectId.

Parámetros

If objectId is string, both type and value must be string too. If objectId is array value must be equal-sized array containing corresponding values, type may be either string (it's value will be used for all objectId-value pairs) or equal-sized array with per-OID value. When any other parameters' combinations are used, a number of E_WARNING messages may be shown with detailed description.

objectId

The SNMP object id

When count of OIDs in object_id array is greater than max_oids object property set method will have to use multiple queries to perform requested value updates. In this case type and value checks are made per-chunk so second or subsequent requests may fail due to wrong type or value for OID requested. To mark this a warning is raised when count of OIDs in object_id array is greater than max_oids.

type

MIB define el tipo de cada identificador de objeto. Debe indicarse con un único carácter de la siguiente lista.

tipos
= Tipo adquirido a partir de MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

Si se definió OPAQUE_SPECIAL_TYPES al compilar la biblioteca SNMP, los siguientes valores serán también válidos:

tipos
U | int64 sin signo
I | int64 con signo
F | float
D | double

La mayoría, utilizarán su correspondiente tipo ASN.1. 's', 'x', 'd' y 'b' son diferentes formas de especificar un valor de OCTET STRING, y el tipo sin signo 'u' se usa también para manejar valores Gauge32.

Si se cargan los ficheros MIB en el árbol MIB con "snmp_read_mib" o con la configuración de libsnmp, se puede usar '=' como parámetro type para todos los id de objetos, ya que se podrá leer automáticamente el tipo a partir del MIB.

Tenga presente que hay dos formas de asigar a una variable los tipos BITS, como por ejemplo. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Usando el tipo "b" y una lista numérica de bits. No se recomienda usar este método, ya que una consulta GET para un mismo OID devolvería, por ejemplo 0xF8.
  • Usando el tipo "x" y un número hexadecimal, pero si el prefijo "0x".

Revise el apartado de ejemplos para más detalles.

value

The new value.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Este método no lanza ninguna excepción de manera predeterminada. Para poder lanzar una excepción SNMPException cuando ocurre alguno de los errores de la biblioteca el parámetro exceptions_enabled de la clase SNMP se debería establecer al valor correspondiente. Véase la explicación de SNMP::$exceptions_enabled para más detalles.

Ejemplos

Ejemplo #1 Set single SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('SNMPv2-MIB::sysContact.0', 's', "Nobody");
?>

Ejemplo #2 Set multiple values using single SNMP::set() call

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), array('s', 's'), array("Nobody", "Nowhere"));
// or
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), 's', array("Nobody", "Nowhere"));
?>

Ejemplo #3 Using SNMP::set() for setting BITS SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  $session->set('FOO-MIB::bar.42', 'x', 'F0');
?>

Ver también

  • SNMP::get() - Fetch an SNMP object


Configures security-related SNMPv3 session parameters

  • « SNMP::set
  • SNMP::walk »
  • PHP Manual
  • SNMP
  • Configures security-related SNMPv3 session parameters

SNMP::setSecurity

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::setSecurity — Configures security-related SNMPv3 session parameters

Descripción

public SNMP::setSecurity
 ( string $securityLevel
, string $authProtocol = ""
, string $authPassphrase = ""
, string $privacyProtocol = ""
, string $privacyPassphrase = ""
, string $contextName = ""
, string $contextEngineId = ""
) : bool

setSecurity configures security-related session parameters used in SNMP protocol version 3

Parámetros

securityLevel

the security level (noAuthNoPriv|authNoPriv|authPriv)

authProtocol

the authentication protocol (MD5 or SHA)

authPassphrase

the authentication pass phrase

privacyProtocol

the privacy protocol (DES or AES)

privacyPassphrase

the privacy pass phrase

contextName

the context name

contextEngineId

the context EngineID

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 SNMP::setSecurity() example

<?php
  $session = new SNMP(SNMP::VERSION_3, $hostname, $rwuser, $timeout, $retries);
  $session->setSecurity('authPriv', 'MD5', $auth_pass, 'AES', $priv_pass, '', 'aeeeff');
?>

Ver también

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent


Fetch SNMP object subtree

  • « SNMP::setSecurity
  • SNMPException »
  • PHP Manual
  • SNMP
  • Fetch SNMP object subtree

SNMP::walk

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::walk — Fetch SNMP object subtree

Descripción

public SNMP::walk ( array|string $objectId , bool $suffixAsKey = false , int $maxRepetitions = -1 , int $nonRepeaters = -1 ) : array|bool

SNMP::walk() is used to read SNMP subtree rooted at specified objectId.

Parámetros

objectId

Root of subtree to be fetched

suffixAsKey

By default full OID notation is used for keys in output array. If set to true subtree prefix will be removed from keys leaving only suffix of object_id.

nonRepeaters

This specifies the number of supplied variables that should not be iterated over. The default is to use this value from SNMP object.

maxRepetitions

This specifies the maximum number of iterations over the repeating variables. The default is to use this value from SNMP object.

Valores devueltos

Returns an associative array of the SNMP object ids and their values on success or false on error. When a SNMP error occures SNMP::getErrno() and SNMP::getError() can be used for retrieving error number (specific to SNMP extension, see class constants) and error message respectively.

Errores/Excepciones

Este método no lanza ninguna excepción de manera predeterminada. Para poder lanzar una excepción SNMPException cuando ocurre alguno de los errores de la biblioteca el parámetro exceptions_enabled de la clase SNMP se debería establecer al valor correspondiente. Véase la explicación de SNMP::$exceptions_enabled para más detalles.

Ejemplos

Ejemplo #1 SNMP::walk() example

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $fulltree = $session->walk(".");
  print_r($fulltree);
  $session->close();
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [DISMAN-EVENT-MIB::sysUpTimeInstance] => Timeticks: (1150681750) 133 days, 4:20:17.50
    [SNMPv2-MIB::sysContact.0] => STRING: Nobody
    [SNMPv2-MIB::sysName.0] => STRING: server.localdomain
    ...
)

Ejemplo #2 suffixAsKey example

suffixAsKey may be used when merging multiple SNMP subtrees into one. This example maps interface names to their type.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $session->valueretrieval = SNMP_VALUE_PLAIN;
  $ifDescr = $session->walk(".1.3.6.1.2.1.2.2.1.2", TRUE);
  $session->valueretrieval = SNMP_VALUE_LIBRARY;
  $ifType = $session->walk(".1.3.6.1.2.1.2.2.1.3", TRUE);
  print_r($ifDescr);
  print_r($ifType);
  $result = array();
  foreach($ifDescr as $i => $n) {
    $result[$n] = $ifType[$i];
  }
  print_r($result);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [1] => igb0
    [2] => igb1
    [3] => ipfw0
    [4] => lo0
    [5] => lagg0
)
Array
(
    [1] => INTEGER: ieee8023adLag(161)
    [2] => INTEGER: ieee8023adLag(161)
    [3] => INTEGER: ethernetCsmacd(6)
    [4] => INTEGER: softwareLoopback(24)
    [5] => INTEGER: ethernetCsmacd(6)
)
Array
(
    [igb0] => INTEGER: ieee8023adLag(161)
    [igb1] => INTEGER: ieee8023adLag(161)
    [ipfw0] => INTEGER: ethernetCsmacd(6)
    [lo0] => INTEGER: softwareLoopback(24)
    [lagg0] => INTEGER: ethernetCsmacd(6)
)

Ver también

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Obtiene el último mensaje de error


The SNMPException class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Introducción

Represents an error raised by SNMP. You should not throw a SNMPException from your own code. See Exceptions for more information about Exceptions in PHP.

Sinopsis de la Clase

SNMPException extends RuntimeException {
/* Propiedades */
protected string $code ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

code

SNMPlibrary error code. Use Exception::getCode() to access it.


Sockets

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Errores de Socket
  • Funciones de Socket
    • socket_accept — Acepta una conexión de un socket
    • socket_addrinfo_bind — Create and bind to a socket from a given addrinfo
    • socket_addrinfo_connect — Create and connect to a socket from a given addrinfo
    • socket_addrinfo_explain — Get information about addrinfo
    • socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname
    • socket_bind — Vincula un nombre a un socket
    • socket_clear_error — Limpia el error del socket o el último código de error
    • socket_close — Cierra un recurso socket
    • socket_cmsg_space — Calcular el tamaño del búfer de mensajes
    • socket_connect — Inicia una conexión sobre un socket
    • socket_create_listen — Abre un socket en un puerto para aceptar conexiones
    • socket_create_pair — Crea un par de sockets indistinguibles y los almacena en una matriz
    • socket_create — Crear un socket (extremo de comunicación)
    • socket_export_stream — Export a socket into a stream that encapsulates a socket
    • socket_get_option — Obtiene las opciones de socket para el socket
    • socket_getopt — Alias de socket_get_option
    • socket_getpeername — Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
    • socket_getsockname — Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
    • socket_import_stream — Importar un flujo a stream
    • socket_last_error — Devuelve el último error sobre un socket
    • socket_listen — Escucha una conexión sobre un socket
    • socket_read — Lee un máximo de longitud de bytes desde un socket
    • socket_recv — Recibe información desde un socket conectado
    • socket_recvfrom — Recibe información desde un socket que esté o no orientado a conexión
    • socket_recvmsg — Leer un mensaje
    • socket_select — Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado
    • socket_send — Envía información a un socket conectado
    • socket_sendmsg — Enviar un mensaje
    • socket_sendto — Envía un mensaje a un socket, ya esté conectado o no
    • socket_set_block — Establece el modo de bloqueo de un recurso socket
    • socket_set_nonblock — Establece el modo de no-bloqueo para el descriptor de archivo fd
    • socket_set_option — Establece las opciones de socket para el socket
    • socket_setopt — Alias de socket_set_option
    • socket_shutdown — Cierra un socket para dejar de recibir, enviar, o ambos
    • socket_strerror — Devuelve una cadena que describe un error de socket
    • socket_write — Escribir en un socket
    • socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure
    • socket_wsaprotocol_info_import — Imports a Socket from another Process
    • socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure


Introducción

La extensión socket implementa una interfaz de bajo nivel para las funciones de comunicación de sockets basadas en los populares sockets de BSD, proporcionando la posibilidad de actuar tanto como servidor como cliente del socket.

Para una interfaz de sockets del lado del cliente más genérica, véase
stream_socket_client(),
stream_socket_server(),
fsockopen(), y
pfsockopen().

Cuando se usan estas funciones es importante recordar que, mientras muchas de ellas tienen nombres idénticos a sus equivalentes en C, a menudo tienen declaraciones diferentes. Por favor, asegúrese de leer las descripciones para evitar confusiones.

Aquellos que no estén familiarizados con la programación de sockets pueden encontrar un montón de material útil en las páginas de manual apropiadas de Unix, y existe mucha información en forma de tutorial sobre la programación de sockets en C en la web, muchos de los cuales se pueden aplicar, con ligeras modificaciones, a la programación de sockets en PHP. La » FAQ de Sockets de Unix podría ser un buen comienzo.


Instalación

Las funciones de socket descritas aquí son parte de una extensión de PHP que debe ser habilitada en tiempo de compilación dando la opción --enable-sockets a configure.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Los recursos socket devueltos por socket_accept(),
socket_create_listen() y
socket_create().


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

AF_UNIX (integer)
AF_INET (integer)
AF_INET6 (integer)
Sólo disponible si se compila con soporte para IPv6.
SOCK_STREAM (integer)
SOCK_DGRAM (integer)
SOCK_RAW (integer)
SOCK_SEQPACKET (integer)
SOCK_RDM (integer)
MSG_OOB (integer)
MSG_WAITALL (integer)
MSG_PEEK (integer)
MSG_DONTROUTE (integer)
MSG_EOR (integer)
No disponible en plataformas Windows.
MSG_EOF (integer)
No disponible en plataformas Windows.
SO_DEBUG (integer)
SO_REUSEADDR (integer)
SO_REUSEPORT (integer)
Esta constante únicamente está disponible en PHP 5.4.10 o posterior en plataformas que admiten la opción de socket SO_REUSEPORT : esto incluye macOS y FreeBSD, pero no incluye Linux o Windows.
SO_KEEPALIVE (integer)
SO_DONTROUTE (integer)
SO_LINGER (integer)
SO_BROADCAST (integer)
SO_OOBINLINE (integer)
SO_SNDBUF (integer)
SO_RCVBUF (integer)
SO_SNDLOWAT (integer)
SO_RCVLOWAT (integer)
SO_SNDTIMEO (integer)
SO_RCVTIMEO (integer)
SO_TYPE (integer)
SO_ERROR (integer)
TCP_NODELAY (integer)
Usada para deshabilitar el algoritmo Nagle TCP. Añadido en PHP 5.2.7.
SOL_SOCKET (integer)
PHP_NORMAL_READ (integer)
PHP_BINARY_READ (integer)
SOL_TCP (integer)
SOL_UDP (integer)

Las siguientes constantes están definidas bajo plataformas Windows y similares a UNIX. Cada constante sólo está definida si su equivalente está disponible en la plataforma.

SOCKET_EINTR (integer)
Llamada al sistema interrumpida
SOCKET_EBADF (integer)
Número de fichero corrupto.
SOCKET_EACCES (integer)
Permiso denegado.
SOCKET_EFAULT (integer)
Dirección corrupta.
SOCKET_EINVAL (integer)
Argumento no válido
SOCKET_EMFILE (integer)
Demasiados ficheros abiertos.
SOCKET_ENAMETOOLONG (integer)
Nombre de fichero demasiado largo.
SOCKET_ENOTEMPTY (integer)
Directorio no vacío.
SOCKET_ELOOP (integer)
Demasiados enlaces simbólicos encontrados.
SOCKET_EWOULDBLOCK (integer)
La operación podría bloquear.
SOCKET_EREMOTE (integer)
El objeto es remoto.
SOCKET_EUSERS (integer)
Demasiados usuarios.
SOCKET_ENOTSOCK (integer)
Operación de socket en algo que no es socket.
SOCKET_EDESTADDRREQ (integer)
Se requiere la dirección de destino.
SOCKET_EMSGSIZE (integer)
Mensaje demasiado largo.
SOCKET_EPROTOTYPE (integer)
Tipo erróneo de protocolo para el socket.
SOCKET_EPROTONOSUPPORT (integer)
Tipo de socket no soportado.
SOCKET_ESOCKTNOSUPPORT (integer)
Tipo de socket no soportado.
SOCKET_EOPNOTSUPP (integer)
Operación no soportada en el extremo del transporte.
SOCKET_EPFNOSUPPORT (integer)
Familia de protocolos no soportada.
SOCKET_EAFNOSUPPORT (integer)
Familia de direcciones no soportada por el protocolo.
SOCKET_EADDRNOTAVAIL (integer)
No se puede asignar la dirección solicitada.
SOCKET_ENETDOWN (integer)
La red está caída.
SOCKET_ENETUNREACH (integer)
La red es inalcanzable.
SOCKET_ENETRESET (integer)
La conexión a la red se cayó a causa de un reinicio.
SOCKET_ECONNABORTED (integer)
Algún software causó el aborto de conexión.
SOCKET_ECONNRESET (integer)
Conexión reiniciada por un par.
SOCKET_ENOBUFS (integer)
No hay espacio de buffer disponible.
SOCKET_EISCONN (integer)
El extremo de transporte ya está conectado.
SOCKET_ENOTCONN (integer)
El extremo de transporte no está conectado.
SOCKET_ESHUTDOWN (integer)
No se puede enviar después del cierre del extremo de transporte.
SOCKET_ETIMEDOUT (integer)
La conexión agotó su tiempo.
SOCKET_ECONNREFUSED (integer)
Conexión rechazada.
SOCKET_EHOSTDOWN (integer)
El host está caído.
SOCKET_EHOSTUNREACH (integer)
No hay ruta hacia el host.
SOCKET_EALREADY (integer)
La operación ya está en progreso.
SOCKET_EINPROGRESS (integer)
La operación ahora está en progreso.

Las siguientes constantes sólo están definidas bajo Windows.

SOCKET_ENOPROTOOPT (integer)
SOCKET_EADDRINUSE (integer)
SOCKET_ETOOMYREFS (integer)
SOCKET_EPROCLIM (integer)
SOCKET_EDUOT (integer)
SOCKET_ESTALE (integer)
SOCKET_EDISCON (integer)
SOCKET_SYSNOTREADY (integer)
SOCKET_VERNOTSUPPORTED (integer)
SOCKET_NOTINITIALISED (integer)
SOCKET_HOST_NOT_FOUND (integer)
SOCKET_TRY_AGAIN (integer)
SOCKET_NO_RECOVERY (integer)
SOCKET_NO_DATA (integer)
SOCKET_NO_ADDRESS (integer)

Las siguientes constantes sólo están disponibles en plataformas similares a UNIX. Cada constante sólo está definida si su equivalente está disponible en la plataforma.

SOCKET_EPERM (integer)
Operación no permitida.
SOCKET_ENOENT (integer)
No existe el archivo o directorio.
SOCKET_EIO (integer)
Error I/O (Entrada/Salida).
SOCKET_ENXIO (integer)
No existe el dispositivo o dirección.
SOCKET_E2BIG (integer)
Lista de argumentos demasiado larga.
SOCKET_EAGAIN (integer)
Intentar de nuevo.
SOCKET_ENOMEM (integer)
Memoria insuficiente.
SOCKET_ENOTBLK (integer)
Se requiere un dispositivo de bloque.
SOCKET_EBUSY (integer)
Dispositivo o recurso ocupado.
SOCKET_EEXIST (integer)
El archivo ya exite.
SOCKET_EXDEV (integer)
Vínculo de dispositivo cruzado.
SOCKET_ENODEV (integer)
No existe el dispositivo.
SOCKET_ENOTDIR (integer)
No es un directorio.
SOCKET_EISDIR (integer)
Es un directorio.
SOCKET_ENFILE (integer)
Desbordamiento de la tabla de archivos.
SOCKET_ENOTTY (integer)
No es un terminal informático.
SOCKET_ENOSPC (integer)
No queda espacio en el dispositivo.
SOCKET_ESPIPE (integer)
Búsqueda ilegal.
SOCKET_EROFS (integer)
Sistema de archivos de sólo lectura.
SOCKET_EMLINK (integer)
Demasiados enlaces.
SOCKET_EPIPE (integer)
Tubería rota.
SOCKET_ENOLCK (integer)
No hay disponibles bloqueos de registro.
SOCKET_ENOSYS (integer)
Función no implementada.
SOCKET_ENOMSG (integer)
No hay mensaje del tipo deseado.
SOCKET_EIDRM (integer)
Identificador eliminado.
SOCKET_ECHRNG (integer)
Número de canal fuera de rango.
SOCKET_EL2NSYNC (integer)
Nivel 2 no sincronizado.
SOCKET_EL3HLT (integer)
Nivel 3 detenido.
SOCKET_EL3RST (integer)
Nivel 3 reiniciado.
SOCKET_ELNRNG (integer)
Número de enlace fuera de rango.
SOCKET_EUNATCH (integer)
Controlador de protocolo no adjunto.
SOCKET_ENOCSI (integer)
No hay disponible una estructura CSI.
SOCKET_EL2HLT (integer)
Nivel 2 detenido.
SOCKET_EBADE (integer)
Intercambio no válido.
SOCKET_EBADR (integer)
Descriptor de solicitud no válido.
SOCKET_EXFULL (integer)
Intercambio lleno.
SOCKET_ENOANO (integer)
Sin ánodo.
SOCKET_EBADRQC (integer)
Código de solicitud no válido.
SOCKET_EBADSLT (integer)
Ranura no válida.
SOCKET_ENOSTR (integer)
El dispositivo no es un flujo.
SOCKET_ENODATA (integer)
No hay información disponible.
SOCKET_ETIME (integer)
Temporizador caducado.
SOCKET_ENOSR (integer)
Sin recursos de flujos.
SOCKET_ENONET (integer)
La máquina no está en la red.
SOCKET_ENOLINK (integer)
El enlace ha sido servido.
SOCKET_EADV (integer)
Error de anuncio.
SOCKET_ESRMNT (integer)
Error de Srmount.
SOCKET_ECOMM (integer)
Error de comunicación al enviar.
SOCKET_EPROTO (integer)
Error de protocolo.
SOCKET_EMULTIHOP (integer)
Se intentó un multi-salto (hop).
SOCKET_EBADMSG (integer)
No es un mensaje de datos.
SOCKET_ENOTUNIQ (integer)
El nombre no es único en la red.
SOCKET_EBADFD (integer)
Descriptor de archivo en mal estado.
SOCKET_EREMCHG (integer)
Dirección remota cambiada.
SOCKET_ERESTART (integer)
La llamada al sistema interrumpida debería ser reiniciada.
SOCKET_ESTRPIPE (integer)
Error de tubería de flujos.
SOCKET_EPROTOOPT (integer)
Protocolo no disponible.
SOCKET_ADDRINUSE (integer)
La dirección ya está en uso.
SOCKET_ETOOMANYREFS (integer)
Demasiadas referencias: unión no posible.
SOCKET_EISNAM (integer)
Es un archivo de tipo nominado.
SOCKET_EREMOTEIO (integer)
Error de E/S remoto.
SOCKET_EDQUOT (integer)
Cuota excedida.
SOCKET_ENOMEDIUM (integer)
No se encontró el medio.
SOCKET_EMEDIUMTYPE (integer)
Tipo de medio erróneo.


Ejemplos

Ejemplo #1 Ejemplo de socket: Servidor TCP/IP sencillo

Este ejemplo muestra una respuesta de servidor simple. Cambie las variables address y port para ajustar su configuración y ejecútelo. Debe después conectar el servidor con un comando similar a: telnet 192.168.1.53 10000 (donde la dirección y el puerto deben coincidir con su cofiguración). Cualquier cosa que escriba será impresa en el lado del servidor, y vuelta a repetir (echo) para usted. Para desconectar, introduzca 'quit'.

#!/usr/local/bin/php -q
<?php
error_reporting(E_ALL);

/* Permitir al script esperar para conexiones. */
set_time_limit(0);

/* Activar el volcado de salida implícito, así veremos lo que estamos obteniendo
 * mientras llega. */
ob_implicit_flush();

$address = '192.168.1.53';
$port = 10000;

if (($sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP)) === false) {
    echo "socket_create() falló: razón: " . socket_strerror(socket_last_error()) . "\n";
}

if (socket_bind($sock, $address, $port) === false) {
    echo "socket_bind() falló: razón: " . socket_strerror(socket_last_error($sock)) . "\n";
}

if (socket_listen($sock, 5) === false) {
    echo "socket_listen() falló: razón: " . socket_strerror(socket_last_error($sock)) . "\n";
}

do {
    if (($msgsock = socket_accept($sock)) === false) {
        echo "socket_accept() falló: razón: " . socket_strerror(socket_last_error($sock)) . "\n";
        break;
    }
    /* Enviar instrucciones. */
    $msg = "\nBienvenido al Servidor De Prueba de PHP. \n" .
        "Para salir, escriba 'quit'. Para cerrar el servidor escriba 'shutdown'.\n";
    socket_write($msgsock, $msg, strlen($msg));

    do {
        if (false === ($buf = socket_read($msgsock, 2048, PHP_NORMAL_READ))) {
            echo "socket_read() falló: razón: " . socket_strerror(socket_last_error($msgsock)) . "\n";
            break 2;
        }
        if (!$buf = trim($buf)) {
            continue;
        }
        if ($buf == 'quit') {
            break;
        }
        if ($buf == 'shutdown') {
            socket_close($msgsock);
            break 2;
        }
        $talkback = "PHP: Usted dijo '$buf'.\n";
        socket_write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    socket_close($msgsock);
} while (true);

socket_close($sock);
?>

Ejemplo #2 Ejemplo de socket: Cliente TCP/IP sencillo

Este ejemplo muestra un simple, único cliente HTTP. Simplemente se conecta a una página, envía una petición HEAD, repite la réplica, y sale.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Obtener el puerto para el servicio WWW. */
$service_port = getservbyname('www', 'tcp');

/* Obtener la dirección IP para el host objetivo. */
$address = gethostbyname('www.example.com');

/* Crear un socket TCP/IP. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() falló: razón: " . socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "Intentando conectar a '$address' en el puerto '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() falló.\nRazón: ($result) " . socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Enviando petición HTTP HEAD ...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Leyendo respuesta:\n\n";
while ($out = socket_read($socket, 2048)) {
    echo $out;
}

echo "Cerrando socket...";
socket_close($socket);
echo "OK.\n\n";
?>


Errores de Socket

La extensión socket fue escrita para proporcionar una interfaz utilizable para los poderosos sockets de BSD. Se ha tenido cuidado en hacer que las funciones trabajen igualmente bien en implementaciones de Win32 y Unix. Casi todas las funciones de sockets pueden fallar bajo ciertas condiciones y por lo tanto emitir un mensaje E_WARNING describiendo el error. Algunas veces esto no ocurre para los deseos del desarrollador. Por ejemplo, la función socket_read() puede de pronto emitir un mensaje E_WARNING porque la conexión se quebró de improvisto. Es común suprimir la advertencia con el operador @ y capturar el código de error dentro de la aplicación con la función socket_last_error(). Se puede llamar a la función socket_strerror() con este código de error para recuperar una cadena describiendo el error. Vea su descripción para más información.

Nota:

Los mensajes E_WARNING generados por la extensión socket están en inglés aunque el mensaje de error recuperado aparecéra según la configuración regional actual (LC_MESSAGES):

Warning - socket_bind() unable to bind address [98]: Die Adresse wird bereits verwendet


Funciones de Socket

Tabla de contenidos

  • socket_accept — Acepta una conexión de un socket
  • socket_addrinfo_bind — Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect — Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain — Get information about addrinfo
  • socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname
  • socket_bind — Vincula un nombre a un socket
  • socket_clear_error — Limpia el error del socket o el último código de error
  • socket_close — Cierra un recurso socket
  • socket_cmsg_space — Calcular el tamaño del búfer de mensajes
  • socket_connect — Inicia una conexión sobre un socket
  • socket_create_listen — Abre un socket en un puerto para aceptar conexiones
  • socket_create_pair — Crea un par de sockets indistinguibles y los almacena en una matriz
  • socket_create — Crear un socket (extremo de comunicación)
  • socket_export_stream — Export a socket into a stream that encapsulates a socket
  • socket_get_option — Obtiene las opciones de socket para el socket
  • socket_getopt — Alias de socket_get_option
  • socket_getpeername — Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
  • socket_getsockname — Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
  • socket_import_stream — Importar un flujo a stream
  • socket_last_error — Devuelve el último error sobre un socket
  • socket_listen — Escucha una conexión sobre un socket
  • socket_read — Lee un máximo de longitud de bytes desde un socket
  • socket_recv — Recibe información desde un socket conectado
  • socket_recvfrom — Recibe información desde un socket que esté o no orientado a conexión
  • socket_recvmsg — Leer un mensaje
  • socket_select — Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado
  • socket_send — Envía información a un socket conectado
  • socket_sendmsg — Enviar un mensaje
  • socket_sendto — Envía un mensaje a un socket, ya esté conectado o no
  • socket_set_block — Establece el modo de bloqueo de un recurso socket
  • socket_set_nonblock — Establece el modo de no-bloqueo para el descriptor de archivo fd
  • socket_set_option — Establece las opciones de socket para el socket
  • socket_setopt — Alias de socket_set_option
  • socket_shutdown — Cierra un socket para dejar de recibir, enviar, o ambos
  • socket_strerror — Devuelve una cadena que describe un error de socket
  • socket_write — Escribir en un socket
  • socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure
  • socket_wsaprotocol_info_import — Imports a Socket from another Process
  • socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure


Acepta una conexión de un socket

  • « Funciones de Socket
  • socket_addrinfo_bind »
  • PHP Manual
  • Funciones de Socket
  • Acepta una conexión de un socket

socket_accept

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_accept — Acepta una conexión de un socket

Descripción

socket_accept ( resource $socket ) : resource

Después de que se haya creado el socket socket usando socket_create(), vinculado a un nombre con socket_bind(), e indicado que escuche conexiones con socket_listen(), esta función aceptará conexiones entrantes sobre ese socket. Una vez que se realice una conexión con éxito, se devolverá un nuevo recurso socket, que puede ser usado para comunicación. Si hay múltiples conexiones en cola sobre el socket se usará el primero. Si no hay conexiones pendientes, socket_accept() bloqueará hasta que que esté presente una conexión. Si socket ha sido hecho como de no-bloqueo usando socket_set_blocking() o socket_set_nonblock(), se devolverá false.

El recurso socket devuelto por socket_accept() puede no ser usado para aceptar nuevas conexiones. Sin embargo, el socket de escucha original, socket, permanece abierto y puede ser reutilizado.

Parámetros

socket

Un recurso socket válido creado con socket_create().

Valores devueltos

Devuelve un nuevo recurso socket en caso de éxito, o false en caso de error. El código de error real se puede recuperar llamanado a socket_last_error(). Este código de error se puede pasar a socket_strerror() para obtener una explicación textual del error.

Ver también

  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_bind() - Vincula un nombre a un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Create and bind to a socket from a given addrinfo

  • « socket_accept
  • socket_addrinfo_connect »
  • PHP Manual
  • Funciones de Socket
  • Create and bind to a socket from a given addrinfo

socket_addrinfo_bind

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_bind — Create and bind to a socket from a given addrinfo

Descripción

socket_addrinfo_bind ( AddressInfo $address ) : Socket|false

Create a Socket instance, and bind it to the provided AddressInfo. The return value of this function may be used with socket_listen().

Parámetros

address

AddressInfo instance created from socket_addrinfo_lookup().

Valores devueltos

Returns a Socket instance on success or false on failure.

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

Ver también

  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname
  • socket_listen() - Escucha una conexión sobre un socket


Create and connect to a socket from a given addrinfo

  • « socket_addrinfo_bind
  • socket_addrinfo_explain »
  • PHP Manual
  • Funciones de Socket
  • Create and connect to a socket from a given addrinfo

socket_addrinfo_connect

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_connect — Create and connect to a socket from a given addrinfo

Descripción

socket_addrinfo_connect ( AddressInfo $address ) : Socket|false

Create a Socket instance, and connect it to the provided AddressInfo instance. The return value of this function may be used with the rest of the socket functions.

Parámetros

address

AddressInfo instance created from socket_addrinfo_lookup()

Valores devueltos

Returns a Socket instance on success or false on failure.

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

Ver también

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname


Get information about addrinfo

  • « socket_addrinfo_connect
  • socket_addrinfo_lookup »
  • PHP Manual
  • Funciones de Socket
  • Get information about addrinfo

socket_addrinfo_explain

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_explain — Get information about addrinfo

Descripción

socket_addrinfo_explain ( AddressInfo $address ) : array

socket_addrinfo_explain() exposed the underlying addrinfo structure.

Parámetros

address

AddressInfo instance created from socket_addrinfo_lookup()

Valores devueltos

Returns an array containing the fields in the addrinfo structure.

Historial de cambios

Versión | Descripción
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

Ver también

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname


Get array with contents of getaddrinfo about the given hostname

  • « socket_addrinfo_explain
  • socket_bind »
  • PHP Manual
  • Funciones de Socket
  • Get array with contents of getaddrinfo about the given hostname

socket_addrinfo_lookup

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname

Descripción

socket_addrinfo_lookup ( string $host , string|null $service = null , array $hints = [] ) : array|false

Lookup different ways we can connect to host. The returned array contains a set of AddressInfo instances that we can bind to using socket_addrinfo_bind().

Parámetros

host

Hostname to search.

service

The service to connect to. If service is a name, it is translated to the corresponding port number.

hints

Hints provide criteria for selecting addresses returned. You may specify the hints as defined by getadrinfo.

Valores devueltos

Returns an array of AddressInfo instances that can be used with the other socket_addrinfo functions. On failure, false is returned.

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns a array of AddressInfo instances now; previously, an array of resources was returned.
8.0.0 | service is nullable now.

Ver también

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo


Vincula un nombre a un socket

  • « socket_addrinfo_lookup
  • socket_clear_error »
  • PHP Manual
  • Funciones de Socket
  • Vincula un nombre a un socket

socket_bind

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_bind — Vincula un nombre a un socket

Descripción

socket_bind ( resource $socket , string $address , int $port = 0 ) : bool

Vincula el nombre dado en address al socket descrito por socket. Esto tiene que ser hecho antes de establecer una conexión usando socket_connect() o socket_listen().

Parámetros

socket

Un recurso socket válido creado con socket_create().

address

Si el socket es de la familia AF_INET, address es una IP en notación decimal con puntos (p.ej. 127.0.0.1).

Si el socket es de la familia AF_UNIX, address es una ruta de un socket de dominio Unix (p.ej. /tmp/my.sock).

port (Optional)

El parámetro port sólo se usa cuando se vincula un socket AF_INET, y designa el puerto en el que escuchar conexiones.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

El código de error se puede recuperar con socket_last_error(). Este código puede pasarse a socket_strerror() para obtener una explicación textual del error.

Ejemplos

Ejemplo #1 Usar socket_bind() para establecer la dirección de origen

<?php
// Crear un nuevo socket
$sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

// Una lista de ejemplo de direcciones IP pertenecientes al ordenador
$sourceips['kevin']    = '127.0.0.1';
$sourceips['madcoder'] = '127.0.0.2';

// Vincular la dirección de origen
socket_bind($sock, $sourceips['madcoder']);

// Conectar a la dirección de destino
socket_connect($sock, '127.0.0.1', 80);

// Escribir
$request = 'GET / HTTP/1.1' . "\r\n" .
           'Host: example.com' . "\r\n\r\n";
socket_write($sock, $request);

// Cerrar
socket_close($sock);

?>

Notas

Nota:

ESta función se debe usar sobre el socket antes de socket_connect().

Nota:

Observación de compatibilidad con Windows 9x/ME: socket_last_error() puede devolver un código de error no válido si intenta vincular el socket a una dirección errónea que no pertenece a su máquina.

Ver también

  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Limpia el error del socket o el último código de error

  • « socket_bind
  • socket_close »
  • PHP Manual
  • Funciones de Socket
  • Limpia el error del socket o el último código de error

socket_clear_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

socket_clear_error — Limpia el error del socket o el último código de error

Descripción

socket_clear_error ( resource $socket = ? ) : void

Esta función limpia el código de error del socket dado o el último error global de socket si no se especifica un socket.

Esta función permite reiniciar explícitamente el valor del código de error de un socket o del último código de error global de extensión. Puede ser útil para detectar si ocurrió un error dentro de una parte de la aplicación.

Parámetros

socket

Un recurso socket válido creado con socket_create().

Valores devueltos

No devuelve ningún valor.

Ver también

  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Cierra un recurso socket

  • « socket_clear_error
  • socket_cmsg_space »
  • PHP Manual
  • Funciones de Socket
  • Cierra un recurso socket

socket_close

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_close — Cierra un recurso socket

Descripción

socket_close ( resource $socket ) : void

socket_close() cierra el recurso socket dado por socket. Esta función es específica para sockets y no se puede usar en otros tipos de recursos.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

Valores devueltos

No devuelve ningún valor.

Ver también

  • socket_bind() - Vincula un nombre a un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Calcular el tamaño del búfer de mensajes

  • « socket_close
  • socket_connect »
  • PHP Manual
  • Funciones de Socket
  • Calcular el tamaño del búfer de mensajes

socket_cmsg_space

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_cmsg_space — Calcular el tamaño del búfer de mensajes

Descripción

socket_cmsg_space ( int $level , int $type , int $n = 0 ) : int

Calcula el tamaño del búfer que debería ser asignado para recibir datos subordinados.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

level

type

Valores devueltos

Ver también

  • socket_recvmsg() - Leer un mensaje
  • socket_sendmsg() - Enviar un mensaje


Inicia una conexión sobre un socket

  • « socket_cmsg_space
  • socket_create_listen »
  • PHP Manual
  • Funciones de Socket
  • Inicia una conexión sobre un socket

socket_connect

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_connect — Inicia una conexión sobre un socket

Descripción

socket_connect ( resource $socket , string $address , int $port = 0 ) : bool

Inicia una conexión hacia address usando el recurso socket socket, el cual debe ser un recurso socket válido creado con socket_create().

Parámetros

socket

address

El parámetro address es una dirección IPv4 en notación decimal con puntos (p.ej. 127.0.0.1) si socket es AF_INET, una dirección IPv6 válida (p.ej. ::1) si está habilitado el soporte para IPv6 y socket es AF_INET6 o el nombre de ruta de un socket de dominio Unix, si la familia de sockets es AF_UNIX.

port

El parámetro port sólo se usa y es obligatoria al conectarse a un socket AF_INET o a un socket AF_INET6, y desgina el puerto del host remoto al que debería de hacerse una conexión.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. El código de error se puede recurperar con socket_last_error(). Este código se puede pasar a socket_strerror() para obtener una explicación textual del error.

Nota:

Si el socket es de no-bloqueo, esta función devolverá false con un error Operation now in progress (La operación está en progreso).

Ver también

  • socket_bind() - Vincula un nombre a un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Abre un socket en un puerto para aceptar conexiones

  • « socket_connect
  • socket_create_pair »
  • PHP Manual
  • Funciones de Socket
  • Abre un socket en un puerto para aceptar conexiones

socket_create_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create_listen — Abre un socket en un puerto para aceptar conexiones

Descripción

socket_create_listen ( int $port , int $backlog = 128 ) : resource

socket_create_listen() crea un nuevo recurso socket de tipo AF_INET que escucha en todas las interfaces locales del puerto dado esperando para nuevas conexiones.

Esta función tiene la intención de facilitar la tarea de crear un nuevo socket que sólo escuche para aceptar nuevas conexiones.

Parámetros

port

El puerto en el que escuchar todas las interfaces.

backlog

El parámetro backlog define la longitud máxima a la que puede aumentar la cola de conexiones pendientes. Se puede pasar SOMAXCONN como el parámetro backlog, véase socket_listen() para más información.

Valores devueltos

socket_create_listen() devuelve un nuevo recurso socket en caso de éxito o false en caso de error. El código de error de puede recuperar con socket_last_error(). Este código se puede pasar a socket_strerror() para obtener una explicación textual del error.

Notas

Nota:

Si quiere crear un socket que sólo escuche una cierta interfaz tiene que usar socket_create(), socket_bind() y socket_listen().

Ver también

  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_create_pair() - Crea un par de sockets indistinguibles y los almacena en una matriz
  • socket_bind() - Vincula un nombre a un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Crea un par de sockets indistinguibles y los almacena en una matriz

  • « socket_create_listen
  • socket_create »
  • PHP Manual
  • Funciones de Socket
  • Crea un par de sockets indistinguibles y los almacena en una matriz

socket_create_pair

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create_pair — Crea un par de sockets indistinguibles y los almacena en una matriz

Descripción

socket_create_pair ( int $domain , int $type , int $protocol , array &$fd ) : bool

socket_create_pair() crea dos sockets conectados e indistinguibles y los almacena en fd. Esta función se usa comúnmente en IPC (InterProcess Communication - Comunicación entre procesos).

Parámetros

domain

El parámetro domain especifica la familia de protocolos que se va a usar en el socket. Véase socket_create() para la lista completa.

type

El parámetro type selecciona el tipo de comunicación que va a usar el socket. Véase socket_create() para la lista completa.

protocol

El parámetro protocol establece el protocolo específico dentro del domain especificado a usar cuando se comunica con el socket devuelto. El valor apropiado se puede recuperar por nombre usando getprotobyname(). Si el protocolo deseado es TCP, o UDP, se pueden usar también las constantes SOL_TCP, y SOL_UDP correspondientes.

Véase socket_create() para la lista completa de protocolos soportados.

fd

Referencia a una matriz en la cuál los dos recursos socket serán insertados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ya está disponible en las plataformas de Windows.

Ejemplos

Ejemplo #1 Ejemplo de socket_create_pair()

<?php
$sockets = array();

/* En Windows necesitamos usar AF_INET */
$domain = (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN' ? AF_INET : AF_UNIX);

/* Configurar el par de sockets */
if (socket_create_pair($domain, SOCK_STREAM, 0, $sockets) === false) {
    echo "socket_create_pair failed. Reason: ".socket_strerror(socket_last_error());
}
/* Enviar y Recibir Información */
if (socket_write($sockets[0], "ABCdef123\n", strlen("ABCdef123\n")) === false) {
    echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($sockets[0]));
}
if (($data = socket_read($sockets[1], strlen("ABCdef123\n"), PHP_BINARY_READ)) === false) {
    echo "socket_read() failed. Reason: ".socket_strerror(socket_last_error($sockets[1]));
}
var_dump($data);

/* Cerrar los sockets */
socket_close($sockets[0]);
socket_close($sockets[1]);
?>

Ejemplo #2 Ejemplo IPC de socket_create_pair()

<?php
$ary = array();
$strone = 'Mensaje del Padre.';
$strtwo = 'Mensaje del Hijo.';

if (socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $ary) === false) {
    echo "socket_create_pair() failed. Reason: ".socket_strerror(socket_last_error());
}
$pid = pcntl_fork();
if ($pid == -1) {
    echo 'Could not fork Process.';
} elseif ($pid) {
    /*padre*/
    socket_close($ary[0]);
    if (socket_write($ary[1], $strone, strlen($strone)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[1]));
    }
    if (socket_read($ary[1], strlen($strtwo), PHP_BINARY_READ) == $strtwo) {
        echo "Recieved $strtwo\n";
    }
    socket_close($ary[1]);
} else {
    /*hijo*/
    socket_close($ary[1]);
    if (socket_write($ary[0], $strtwo, strlen($strtwo)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[0]));
    }
    if (socket_read($ary[0], strlen($strone), PHP_BINARY_READ) == $strone) {
        echo "Received $strone\n";
    }
    socket_close($ary[0]);
}
?>

Ver también

  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_create_listen() - Abre un socket en un puerto para aceptar conexiones
  • socket_bind() - Vincula un nombre a un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Crear un socket (extremo de comunicación)

  • « socket_create_pair
  • socket_export_stream »
  • PHP Manual
  • Funciones de Socket
  • Crear un socket (extremo de comunicación)

socket_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create — Crear un socket (extremo de comunicación)

Descripción

socket_create ( int $domain , int $type , int $protocol ) : resource

Crea y devuelve un recurso socket, también referido como un extremo de comunicación. Una conexión típica de red está constituida por 2 sockets, uno realizando el papel del cliente, y otro realizando el papel del servidor.

Parámetros

domain

El parámetro domain especifica la familia de protocolos que va a usar por el socket.

Available address/protocol families
Dominio | Descripción
AF_INET | Protocolos basados en Internet IPv4. TCP y UDP son protocolos comunes de esta familia de protocolos.
AF_INET6 | Protocolos basados en Internet IPv6. TCP y UDP son protocolos comunes de esta familia de protocolos.
AF_UNIX | Familia de protocolos de comunicación local. Alta eficacia y baja sobrecarga la hacen una gran forma de IPC (Interprocess Communication - Comunicación entre procesos).
type

El parámetro type selecciona el tipo de comunicación que va a usar el socket.

Tipos de sockets disponibles
Tipo | Descripción
SOCK_STREAM | Proporciona flujos de bytes orientados a conexión, secuenciados, fiables y full-duplex. Puede soportar un mecanismo de transmisión fuera de banda. El protocolo TCP está basado en este tipo de socket.
SOCK_DGRAM | Soporta datagramas (no orientado a conexión, mensajes no fiables de una longitud máxima). El protocolo UDP está basado en este tipo de socket.
SOCK_SEQPACKET | Proporciona una ruta de transmisión de datos orientada a conexión secuenciada, fiable, de dos direcciones para datagramas de longitud máxima fija; se requiere un consumidor para leer un paquete entero con cada llamada de lectura.
SOCK_RAW | Proporciona acceso al protocolo de red sin formato. Este tipo especial de socket se puede usar para construir manualmente cualquier tipo de protocolo. Un uso común para este socket es realizar solicitudes ICMP (como ping).
SOCK_RDM | Proporcional una capa de datagramas fiable que no garantiza el orden. Lo más seguro es que esto no esté implementado en su sistema operativo.
protocol

El parámetro protocol establece el protocolo específico dentro del domain especificado a usar al comunicarse con el socket devuelto. El valor apropiado puede ser recuperado por su nombre usando getprotobyname(). Si el protocolo deseado es TCP o UDP, también se pueden usar las constantes SOL_TCP, y SOL_UDP correspondientes.

Protocolos comunes
Nombre | Descripción
icmp | Internet Control Message Protocol (Protocolo de Mensajes de Control de Internet) es usado principalmente por pasarelas y hosts para notificar errores en la comunicación por datagramas. El comando "ping" (presente en la mayoría de los sistemas operativos modernos) es un ejemplo de la aplicación del ICMP.
udp | User Datagram Protocol (Protocolo de Datagramas de Usuario) es un protocolo no orientado a conexión, no fiable, con longitud de registros fija. A causa de estos aspectos, UDP requiere una cantidad mínima de sobrecarga del protocolo.
tcp | Transmission Control Protocol (Protocolo de Control de Transmisión) es un protocolo fiable orientado a conexión, orientado a flujo, full duplex. TCP garantiza que todos los paquetes de datos serán recibidos en el orden en el que fueron enviados. Si algún paquete se pierde por alguna razón durante la comunicación, TCP automáticamente retransmitirá el paquete hasta que el host destino adminta ese paquete. Por razones de fiabilidad y rendimiento, la implementación de TCP decide por sí misma los límites apropiados de los octetos de la capa de comunicación de datagramas subyacente. Por lo tanto, las aplicaciones TCP deben tener en cuenta la posibilidad de transmisión de resgistros parciales.

Valores devueltos

socket_create() devuelve un recurso socket en caso de éxito, o false en caso de error. El código de error real se puede recuperar llamando a socket_last_error(). Este código de error se puede pasar a socket_strerror() para obtener una explicación textual del error.

Errores/Excepciones

Si se da un domain o type no válido, socket_create() los pone por defecto a AF_INET y SOCK_STREAM respectivamente y además emite un mensaje E_WARNING.

Ver también

  • socket_accept() - Acepta una conexión de un socket
  • socket_bind() - Vincula un nombre a un socket
  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Export a socket into a stream that encapsulates a socket

  • « socket_create
  • socket_get_option »
  • PHP Manual
  • Funciones de Socket
  • Export a socket into a stream that encapsulates a socket

socket_export_stream

(PHP 7 >= 7.0.7, PHP 8)

socket_export_stream — Export a socket into a stream that encapsulates a socket

Descripción

socket_export_stream ( Socket $socket ) : resource|false

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

socket

Valores devueltos

Return resource o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | socket is a Socket instance now; previously, it was a resource.


Obtiene las opciones de socket para el socket

  • « socket_export_stream
  • socket_getopt »
  • PHP Manual
  • Funciones de Socket
  • Obtiene las opciones de socket para el socket

socket_get_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

socket_get_option — Obtiene las opciones de socket para el socket

Descripción

socket_get_option ( resource $socket , int $level , int $optname ) : mixed

La función socket_get_option() recupera el valor de la opción especificada por el parámetro optname para el socket especificado.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

level

El parámetro level especifica el nivel de protcolo en el que reside la opción. Por ejemplo, para recuperar las opciones al nivel de socket se usaría un parámetro level de SOL_SOCKET. Se puden usar otros niveles como TCP especificando el número de protocolo de ese nivel. Los números de protocolo se pueden averiguar usando la función getprotobyname().

optname
Opciones de Socket Disponibles
Opción | Descripción | Tipo
SO_DEBUG | Informa si la información de depuración está siendo registrada. | int
SO_BROADCAST | Informa si la transmisión de mensajes de emisión está soportada. | int
SO_REUSEADDR | Informa si las direcciones locales pueden ser rechazadas. | int
SO_REUSEPORT | Informa si los puertos locales pueden ser reutilizados. | int
SO_KEEPALIVE | Informa si las conexiones se mantienen activas con transmisiones periódicas de mensajes. Si el socket conectado falla al responder a estos mensajes, la conexión es interrumpida y los procesos que escriben en ese socket son notificados con una señal SIGPIPE. | int
SO_LINGER

Informa si el socket perdura en socket_close() si la información está presente. Por omisión, cuando el socket se cierra, se intenta enviar toda la información no enviada. En el caso de un socket orientado a conexión, socket_close() esperará a su par para admitir la información.

Si l_onoff no es cero y l_linger es cero, toda la información no enviada será desechada y se envía RST (reinicio) al par en el caso de un socker orientado a conexión.

Por otro lado, si l_onoff no es cero y l_linger no es cero, socket_close() bloqueará hasta que toda la información sea enviada o transcurra el tiempo especificado en l_linger. Si el socket es de no-bloqueo, socket_close() fallará y devolverá un error.

array. La matriz contendrá dos claves: l_onoff y l_linger.
SO_OOBINLINE | Informa si el socket deja información fuera de banda en línea. | int
SO_SNDBUF | Informa del tamaño del buffer de envío. | int
SO_RCVBUF | Informa del tamaño del buffer de recepción. | int
SO_ERROR | Da información sobre el estado de error y lo limpia. | int (no puede ser establecido por la función socket_set_option())
SO_TYPE | Informa del tipo socket (p.ej. SOCK_STREAM). | int (no puede ser establecido mediante socket_set_option())
SO_DONTROUTE | Informa si los mensajes salientes se desvían de los mecanismos de ruta estándar. | int
SO_RCVLOWAT | Informa del número mínimo de bytes a procesar para operaciones de entrada del socket. | int
SO_RCVTIMEO | Informa del valor del tiempo de espera para operaciones de entrada. | array. La matriz contendrá dos claves: sec que es la parte de segundos del valor del tiempo límite y usec que es la parte de microsegundos del valor del tiempo límite.
SO_SNDTIMEO | Informa del valor del tiempo de espera especificando la cantidad de tiempo que una función de salida bloquea porque el control de flujo evita el envío de información. | array. La matriz contendrá dos claves: sec que es la parte de segundos del valor del tiempo límite y usec que es la parte de microsegundos del valor del tiempo límite.
SO_SNDLOWAT | Informa del número mínimo de bytes a procesar por operaciones de salida del socket. | int
TCP_NODELAY | Informa si el algoritmo Nagle TCP está deshabilitado. | int
MCAST_JOIN_GROUP | Unirse a un grupo multidifusión. (añadido en PHP 5.4) | Un array con claves "group", especificando un string con la dirección de la multidifusión IPv4 o IPv6 e "interface", especificando o un número de intefaz (de tipo int) o un string con el nombre de la interfaz, como "eth0". Se puede especificar 0 para indicar que la interfaz debería ser seleccionada usando las normas de enrutamiento. (Sólo se puede usar en la función socket_set_option())
MCAST_LEAVE_GROUP | Abandonar un grupo multidifusión. (añadido en PHP 5.4) | array. Véase MCAST_JOIN_GROUP para más información. (Sólo se puede usar en la función socket_set_option())
MCAST_BLOCK_SOURCE | Bloquea los paquetes enviados desde un origen específico a un grupo multidifusión específico, al cual se ha tenido que unir previamente. (añadido en PHP 5.4) | Un array con las mismas claves que en MCAST_JOIN_GROUP, más una clave extra, source, que hace referencia a un string que especifica una dirección IPv4 o IPv6 del origen a ser bloqueado. (Sólo se puede usar en la función socket_set_option())
MCAST_UNBLOCK_SOURCE | Desbloquea (empieza a recibir de nuevo) paquetes enviados desde una dirección origen especificada a un grupo multidifusión especificado, al cual se ha tenido que unir previamente. (añadido en PHP 5.4) | Un array con el mismo formato que MCAST_BLOCK_SOURCE. (Sólo se puede usar en la función socket_set_option())
MCAST_JOIN_SOURCE_GROUP | Recibir paquetes destinados aun grupo multidifusión específico cuya dirección de origen coincide con un valor específico. (añadido en PHP 5.4) | Un array con el mismo formato que MCAST_BLOCK_SOURCE. (Sólo se puede usar en la función socket_set_option())
MCAST_LEAVE_SOURCE_GROUP | Dejar de recibir paquetes destinados a un grupo multidifusión específico cuya dirección de origen coincide con un valor específico. (añadido en PHP 5.4) | Un array con el mismo formato que MCAST_BLOCK_SOURCE. (Sólo se puede usar en la función socket_set_option())
IP_MULTICAST_IF | La interfaz saliente para paquetes multidifusión IPv4. (añadido en PHP 5.4) | O un valor de tipo int especificando el número de la interfaz o un string con el nombre de la interfaz, como eth0. Se puede usar el valor 0 para indicar que la tabla de enrutamiento se usa en la selección de la interfaz. La función socket_get_option() devuelve un índice de interfaz. Observe que, a diferencia de la API de C, esta opción NO toma una dirección IP. Esto elimina las diferencias de interfaz entre IP_MULTICAST_IF y IPV6_MULTICAST_IF.
IPV6_MULTICAST_IF | La interfaz saliente para paquetes multidifusión IPv6. (añadido en PHP 5.4) | El mismo que IP_MULTICAST_IF.
IP_MULTICAST_LOOP | La política de loopback multidifusión para paquetes IPv4, la cual determina si los paquetes enviados por este socket también alcanzan los receptores del mismo host al que se ha unidoal mismo grupo multidifusión en la interfaz saliente usada por este socket. Este es el caso por omisión. (añadido en PHP 5.4) | Un valor de tipo int (0 ó 1). Para la función socket_set_option() será aceptado cualquier valor y será convertido a un booleano siguiendo la reglas habituales de PHP.
IPV6_MULTICAST_LOOP | Análoga aIP_MULTICAST_LOOP, pero para IPv6. (añadido en PHP 5.4) | Un valor de tipo int. Véase IP_MULTICAST_LOOP.
IP_MULTICAST_TTL | El tiemp de vida de los paquetes multidifusión IPv4 salientes. Debería ser un valor entre 0 (no abandonar la interfaz) y 255. El valor predeterminado es 1 (sólo se alcanza la red local). (añadido en PHP 5.4) | Un valor de tipo int entre 0 y 255.
IPV6_MULTICAST_HOPS | Análoga a IP_MULTICAST_TTL, pero para paquetes IPv6. También se acepta el valor -1, lo que significa que debería usarse la ruta predeterminada. (añadido en PHP 5.4) | Un valor de tipo int entre -1 y 255.

Valores devueltos

Devuelve el valor de la opción dada, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de socket_get_option()

<?php
$socket = socket_create_listen(1223);

$linger = array('l_linger' => 1, 'l_onoff' => 1);
socket_set_option($socket, SOL_SOCKET, SO_LINGER, $linger);

var_dump(socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR));
?>

Ver también

  • socket_create_listen() - Abre un socket en un puerto para aceptar conexiones
  • socket_set_option() - Establece las opciones de socket para el socket


Alias de socket_get_option

  • « socket_get_option
  • socket_getpeername »
  • PHP Manual
  • Funciones de Socket
  • Alias de socket_get_option

socket_getopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getopt — Alias de socket_get_option()

Descripción

Esta función es un alias de: socket_get_option().


Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

  • « socket_getopt
  • socket_getsockname »
  • PHP Manual
  • Funciones de Socket
  • Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

socket_getpeername

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getpeername — Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

Descripción

socket_getpeername ( resource $socket , string &$address , int &$port = ? ) : bool

Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

address

Si el socket dado es de tipo AF_INET o AF_INET6, socket_getpeername() devolverá la dirección IP de los pares (remotos) en la notación apropiada (p.ej. 127.0.0.1 o fe80::1) en el parámetro address, y si el parámetro opcional port está presente, también el puerto asociado.

Si el socket dado es de tipo AF_UNIX, socket_getpeername() devolverá la ruta del sistema de archivos Unix (p.ej. /var/run/daemon.sock) en el parámetro address.

port

Si se da, contendrá el puerto asociado a address.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. socket_getpeername() puede también devolver false si el tipo de socket no es ni AF_INET, AF_INET6, ni AF_UNIX, en cuyo caso no se actualiza el último código de error de socket.

Notas

Nota:

socket_getpeername() no debería usarse con sockets AF_UNIX creados con socket_accept(). Sólo los sockets creados con socket_connect() o un socket principal de servidor seguido de una llamada a socket_bind() devolverán valores con sentido.

Nota:

Para hacer que socket_getpeername() devuelva un valor con sentido, el socket sobre el que es aplicado debe ser, por supuesto, uno cuyo concepto de "par" tenga sentido.

Ver también

  • socket_getsockname() - Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

  • « socket_getpeername
  • socket_import_stream »
  • PHP Manual
  • Funciones de Socket
  • Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

socket_getsockname

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getsockname — Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo

Descripción

socket_getsockname ( resource $socket , string &$addr , int &$port = ? ) : bool

Nota: socket_getsockname() no debería usarse con sockets AF_UNIX creados con socket_connect(). Sólo los sockets creados con socket_accept() o con un socket servidor primario seguido de una llamda a socket_bind() devolverá resultados significativos.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

addr

Si el socket dado es de tipo AF_INET o AF_INET6, socket_getsockname() devolverá la dirección IP local en la notación apropiada (p.ej. 127.0.0.1 o fe80::1) en el parámetro address, y si el parámetro opcional port está presente, tmbién el puerto asociado.

Si el socket dado es de tipo AF_UNIX, socket_getsockname() devolverá la ruta del sistema de archivos Unix (p.ej. /var/run/daemon.sock) en el parámetro address.

port

Si se proporciona, contendrá el puerto asociado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. socket_getsockname() también puede devolver false si el tipo de socket no de tipo AF_INET, AF_INET6, o AF_UNIX, en cuyo caso no se actualiza el último código de error de socket.

Ver también

  • socket_getpeername() - Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Importar un flujo a stream

  • « socket_getsockname
  • socket_last_error »
  • PHP Manual
  • Funciones de Socket
  • Importar un flujo a stream

socket_import_stream

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

socket_import_stream — Importar un flujo a stream

Descripción

socket_import_stream ( resource $stream ) : resource

Importa un flujo que encapsula un socket en un recurso de extensión de socket.

Parámetros

stream

El recurso de socket a importar.

Valores devueltos

Devuelve false o null en caso de fallo.

Ejemplos

Ejemplo #1 Ejemplo de socket_import_stream()

<?php
$stream = stream_socket_server("udp://0.0.0.0:58380", $errno, $errstr, STREAM_SERVER_BIND);
$sock   = socket_import_stream($stream);
?>

Ver también

  • stream_socket_server() - Crear un socket de servidor de dominio de Internet o de Unix


Devuelve el último error sobre un socket

  • « socket_import_stream
  • socket_listen »
  • PHP Manual
  • Funciones de Socket
  • Devuelve el último error sobre un socket

socket_last_error

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_last_error — Devuelve el último error sobre un socket

Descripción

socket_last_error ( resource $socket = ? ) : int

Si un recurso socket es pasado a esta función, devuelve el último error que ocurrió en este socket en particular. Si el recurso socket se omite, devuelve el código de error de la última función de socket que falló. El segundo es particularmente útil para funciones como socket_create() que no devuelve un socket en caso de error y socket_select() que puede fallar por razones no directamente vinculadas con un socket en particular. El código de error es apropiado para ser introducido en socket_strerror(), que devuelve una cadena describiendo el código de error dado.

Si no se hubiera producido ningún error, o el error se hubiera eliminado con socket_clear_error(), la función devuelve 0.

Parámetros

socket

Un recurso socket válido creado con socket_create().

Valores devueltos

Esta función devuelve un código de error de un socket.

Ejemplos

Ejemplo #1 Un ejemplo de socket_last_error()

<?php
$socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if ($socket === false) {
    $errorcode = socket_last_error();
    $errormsg = socket_strerror($errorcode);

    die("No se pudo crear el socket: [$errorcode] $errormsg");
}
?>

Notas

Nota:

socket_last_error() no limpia el código de error, use socket_clear_error() para este propósito.


Escucha una conexión sobre un socket

  • « socket_last_error
  • socket_read »
  • PHP Manual
  • Funciones de Socket
  • Escucha una conexión sobre un socket

socket_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_listen — Escucha una conexión sobre un socket

Descripción

socket_listen ( resource $socket , int $backlog = 0 ) : bool

Después de que el socket socket haya sido creado usando socket_create() y vinculado a un nombre con socket_bind(), se le puede indicar que escuche conexiones entrantes sobre socket.

socket_listen() sólo es aplicable a sockets de tipo SOCK_STREAM o SOCK_SEQPACKET.

Parámetros

socket

Un recurso socket creado con socket_create() o socket_addrinfo_bind()

backlog

Se pondrán en cola un máximo de conexiones entrantes backlog para su procesamiento. Si una petición de conexión llega con la cola llena, el cliente puede recibir un error con una indicación de ECONNREFUSED, o, si el protocolo subyacente soporta retransmisiones, la petición puede ser ignorada, por lo que este reintento puede surtir efecto.

Nota:

El número máximo pasado al parámtro backlog depende mayormente en la plataforma subyacente. En Linux, se trunca de forma silenciosa a SOMAXCONN. En win32, Si se pasó SOMAXCONN, el proveedor del servicio responsable del socket establecerá el backlog a un valor máximo razonable. No existe una disposicón estándar para encontrar el valor del backlog real en esta plataforma.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. El código de error real se puede recuperar llamando a socket_last_error(). Este código se puede pasar a socket_strerror() para obtener una explicación textual del error.

Ver también

  • socket_accept() - Acepta una conexión de un socket
  • socket_bind() - Vincula un nombre a un socket
  • socket_connect() - Inicia una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_strerror() - Devuelve una cadena que describe un error de socket
  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo


Lee un máximo de longitud de bytes desde un socket

  • « socket_listen
  • socket_recv »
  • PHP Manual
  • Funciones de Socket
  • Lee un máximo de longitud de bytes desde un socket

socket_read

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_read — Lee un máximo de longitud de bytes desde un socket

Descripción

socket_read ( resource $socket , int $length , int $type = PHP_BINARY_READ ) : string

La función socket_read() lee desde un recurso socket socket creado por las funciones socket_create() o socket_accept().

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

length

El número máximo de bytes leidos es especificado por el parámetro length. Por lo demás se puede usar \r, \n, o \0 para finalizar la lectura (dependiendo del parámetro type, véase abajo).

type

El parámetro opcional type es una constante nominada:

  • PHP_BINARY_READ (Predeterminada) - usa la función del sistema recv(). Segura para la lectura de información binaria.
  • PHP_NORMAL_READ - la lectura se detiene en \n o \r.

Valores devueltos

socket_read() devuelve la información como cadena en caso de éxito, o false en caso de error (incluyendo si el host remoto cerró la conexión). El código de error real se puede recuperar llamando a socket_last_error(). Este código se puede pasar a socket_strerror() para obtener una explicación textual del error.

Nota:

socket_read() devuelve una cadena de longitud cero ("") cuando no hay más información que leer.

Ver también

  • socket_accept() - Acepta una conexión de un socket
  • socket_bind() - Vincula un nombre a un socket
  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket
  • socket_write() - Escribir en un socket


Recibe información desde un socket conectado

  • « socket_read
  • socket_recvfrom »
  • PHP Manual
  • Funciones de Socket
  • Recibe información desde un socket conectado

socket_recv

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_recv — Recibe información desde un socket conectado

Descripción

socket_recv ( resource $socket , string &$buf , int $len , int $flags ) : int

La función socket_recv() recibe len bytes de información en buf desde socket. socket_recv() se puede usar para reunir información desde sockets conectados. Además, se pueden especificar una o más banderas para modificar el comportamiento de la función.

buf es pasado por referencia, por lo que debe ser especificado como una variable en la lista de argumentos. La información leída desde socket por socket_recv() será devuelta en buf.

Parámetros

socket

socket debe ser un recurso socket previamente creado por socket_create().

buf

La información recibida será traida a la variable especifivada por buf. Si ocurre un error, si la conexión es reiniciada, o si no hay información disponible, buf será establecido a null.

len

Se obtendrán hasta len bytes desde el host remoto.

flags

El valor de flags puede ser una combinación de las siguientes banderas, unidas con el operador binario OR (|).

Valores posibles de flags
Bandera | Descripción
MSG_OOB | Procesar información fuera de banda.
MSG_PEEK | Recibir informaicón desde el inicio de la cola recibida sin eliminarla de la cola.
MSG_WAITALL | Bloquea hasta que al menos se reciba len bytes. Sin embargo, si se captura una señal o el host remoto se desconecta, la función puede devolver menos información.
MSG_DONTWAIT | Con esta bandera establecida, la función devuelve incluso si normalmente habría bloqueado.

Valores devueltos

socket_recv() devuelve el número de bytes recibidos, o false si hubo un error. El código de error real se puede recuperar llamando a socket_last_error(). Este código de error se puede pasar a socket_strerror() para obtener una explicación textual del error.

Ejemplos

Ejemplo #1 Un ejemplo de socket_recv()

Este ejemplo es un reescrito sencillo del primer ejemplo de Ejemplos para usar socket_recv().

<?php
error_reporting(E_ALL);

echo "<h2>Conexión TCP/IP</h2>\n";

/* Obtener el puerto del servicio WWW. */
$service_port = getservbyname('www', 'tcp');

/* Obtener la dirección IP del host objetivo. */
$address = gethostbyname('www.example.com');

/* Crear un socket TCP/IP. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() falló: razón: " . socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "Intentando conectar a '$address' en el puerto '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() falló.\nRazón: ($result) " . socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Enviando petición HTTP HEAD...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Leyendo la respuesta:\n\n";
$buf = 'Este es mi buffer.';
if (false !== ($bytes = socket_recv($socket, $buf, 2048, MSG_WAITALL))) {
    echo "Leídos $bytes bytes desde socket_recv(). Cerrando el socket...";
} else {
    echo "socket_recv() falló; razón: " . socket_strerror(socket_last_error($socket)) . "\n";
}
socket_close($socket);

echo $buf . "\n";
echo "OK.\n\n";
?>

El ejemplo de arriba producirá algo parecido a esto:

<h2>Conexión TCP/IP</h2>
OK.
Intentando conectar a '208.77.188.166' en el puerto '80'...OK.
Enviando petición HTTP HEAD...OK.
Leyendo la respuesta:

Leídos 123 bytes desde socket_recv(). Cerrando el socket...HTTP/1.1 200 OK
Date: Mon, 14 Sep 2009 08:56:36 GMT
Server: Apache/2.2.3 (Red Hat)
Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT
ETag: "b80f4-1b6-80bfd280"
Accept-Ranges: bytes
Content-Length: 438
Connection: close
Content-Type: text/html; CHARSET=Windows-1252

OK.


Recibe información desde un socket que esté o no orientado a conexión

  • « socket_recv
  • socket_recvmsg »
  • PHP Manual
  • Funciones de Socket
  • Recibe información desde un socket que esté o no orientado a conexión

socket_recvfrom

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_recvfrom — Recibe información desde un socket que esté o no orientado a conexión

Descripción

socket_recvfrom ( resource $socket , string &$buf , int $len , int $flags , string &$name , int &$port = ? ) : int

La función socket_recvfrom() recibe len bytes de información en buf desde name en el puerto port (si el socket no es del tipo AF_UNIX) usando socket. socket_recvfrom() se puede usar para reunir información tanto desde socket conectados como de no conectados. Además, se pueden especificar una o más banderas para modificar el comportamiento de la función.

name y port deben ser pasados por referencia. Si el socket no está orientado a conexión, name será establecido a la dirección del protocolo de internet del host remoto o a la ruta del socket UNIX. Si el socket está orientado a conxión, name es null. Además, port contendrá el puerto del host remoto en el caso de un socket AF_INET o AF_INET6 no conectado.

Nota: Esta función es segura binariamente.

Parámetros

socket

socket debe ser un recurso socket previamente creado por socket_create().

buf

La información recibida será recuperada a la variable especificada por buf.

len

Se obtendrán hasta len bytes desde el host remoto.

flags

El valor de flags puede ser una combinación de las siguientes banderas, unidas con el operador binario OR (|).

Valores posibles de flags
Bandera | Descripción
MSG_OOB | Procesar información fuera de banda.
MSG_PEEK | Recibir informaicón desde el inicio de la cola recibida sin eliminarla de la cola.
MSG_WAITALL | Bloquea hasta que al menos se reciba len bytes. Sin embargo, si se captura una señal o el host remoto se desconecta, la función puede devolver menos información.
MSG_DONTWAIT | Con esta bandera establecida, la función devuelve incluso si normalmente habría bloqueado.
name

Si el socket es de tipo AF_UNIX, name es la ruta del archivo. Por lo demás, para sockets no conectados, name es la dirección IP del host remoto, o null si el socket está orientado a conexion.

port

Este argumento sólo se aplica a sockets AF_INET y AF_INET6, y especifica el puerto remoto desde el que la información es recibida. Si el socket está orientado a conexión, port será null.

Valores devueltos

socket_recvfrom() devuelve el número de bytes recibidos, o false si hubo un error. El código de error real se puede recuperar llamando a socket_last_error(). Este código de error se puede pasar a socket_strerror() para obtener una explicación textual del error.

Ejemplos

Ejemplo #1 Un ejemplo de socket_recvfrom()

<?php
error_reporting(E_ALL | E_STRICT);

$socket = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);
socket_bind($socket, '127.0.0.1', 1223);

$from = '';
$port = 0;
socket_recvfrom($socket, $buf, 12, 0, $from, $port);

echo "Se recibió $buf desde la dirección remota $from y el puerto remoto $port" . PHP_EOL;
?>

Este ejemplo iniciará un socket UDP en el puerto 1223 de 127.0.0.1 e imprimirá al menos 12 caracteres recibidos desde un host remoto.

Ver también

  • socket_recv() - Recibe información desde un socket conectado
  • socket_send() - Envía información a un socket conectado
  • socket_sendto() - Envía un mensaje a un socket, ya esté conectado o no
  • socket_create() - Crear un socket (extremo de comunicación)


Leer un mensaje

  • « socket_recvfrom
  • socket_select »
  • PHP Manual
  • Funciones de Socket
  • Leer un mensaje

socket_recvmsg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_recvmsg — Leer un mensaje

Descripción

socket_recvmsg ( resource $socket , array &$message , int $flags = 0 ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

socket

message

flags

Valores devueltos

Ver también

  • socket_sendmsg() - Enviar un mensaje
  • socket_cmsg_space() - Calcular el tamaño del búfer de mensajes


Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado

  • « socket_recvmsg
  • socket_send »
  • PHP Manual
  • Funciones de Socket
  • Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado

socket_select

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_select — Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado

Descripción

socket_select ( array &$read , array &$write , array &$except , int $tv_sec , int $tv_usec = 0 ) : int

socket_select() acepta matrices de sockets y las espera para cambiar el estado. Aquellas que vienen con un fondo de sockets BSD reconocerán que aquellas matrices de recursos socket son de hecho los también llamados conjuntos descriptores de archivos. Se observan tres matrices de recursos socket independientes.

Parámetros

read

Los sockets listados en la matriz read serán observados para ver si los caracteres están disponibles para lectura (más precisamente, para ver si una lectura no bloqueará - en particular, un recurso socket también está listo al final del archivo, en cuyo caso un socket_read() devolverá una cadena de longitud cero).

write

Los sockets listados en la matriz write serán observados para ver si una escritura no bloqueará.

except

Los sockets listados en la matriz except serán observados para excepciones.

tv_sec

tv_sec y tv_usec forman juntos el parámetros timeout. timeout es un límite superior de la cantidad de tiempo trancurrido antes de que socket_select() devuelva. tv_sec puede ser cero, causando que socket_select() devuelva inmediatamente. Esto es útil para consultas constantes (polling). Si tv_sec es null (sin tiempo línmite), socket_select() puede bloquear indefinidamente.

tv_usec

Advertencia

Al salir, las matrices son modificadas para indicar que recurso socket realmente cambió el estado.

No es necesario pasar cada matriz a socket_select(). En su lugar, se puede omitir y usar una matriz vacía o null. No olvide también que esas matrices son pasadas por referencia y serán modificadas después de que socket_select() devuelva.

Nota:

A causa de una limitación en el Motor Zend actual no es posible pasar una constante como null directamente como un parámetro a una función que espera que este parámetro sea pasado por referencia. En su lugar use una variable temporal o una expresión que su miembro más a la izquierda sea una variable temporal:

Ejemplo #1 Usar null con socket_select()

<?php
$e = NULL;
socket_select($r, $w, $e, 0);
?>

Valores devueltos

En caso de éxtio, socket_select() devuelve el número de recursos socket contenidos en las matrices modificadas, lo que puede ser cero si el tiempo límite expira antes de que ocurra algo interesante. En caso de error se devuelve false. El código de error se puede recuperar con socket_last_error().

Nota:

Asegúrese de usar el operador === cuando verifique un error. Ya que socket_select() puede devolver 0 la comparación con == será evaluada a true:

Ejemplo #2 Comprender el resultado de socket_select()

<?php
$e = NULL;
if (false === socket_select($r, $w, $e, 0)) {
    echo "falló socket_select(), razón: " .
        socket_strerror(socket_last_error()) . "\n";
}
?>

Ejemplos

Ejemplo #3 Un ejemplo de socket_select()

<?php
/* Preparar la matriz de lectura */
$read   = array($socket1, $socket2);
$write  = NULL;
$except = NULL;
$núm_sockets_cambiados = socket_select($read, $write, $except, 0);

if ($núm_sockets_cambiados === false) {
    /* Manejo de errores */
} else if ($núm_sockets_cambiados > 0) {
    /* Ocurrió algo interesante en al menos uno de los sockets */
}
?>

Notas

Nota:

Tenga en cuenta que algunas implementaciones de sockets necesitan ser tratadas con mucho cuidado. Unas cuantas reglas básicas:

  • Debería siempre intentar usar socket_select() sin tiempo límite. Su programa no debería de hacer nada si no hay información disponible. El código que depende de tiempos límite normalmente no es portable y es difícil de depurar.
  • No se deben añadir recursos socket a ningún conjunto si no se pretende verificar su resultado después de la llamada a socket_select(), y responder apropiadamente. Después de que socket_select() devuelva, todos los recursos socket en todas las matrices deben ser verificados. Cualquier recurso socket que esté disponible para escritura debe ser escrito, y cualquier recurso socket disponible para lectura debe ser leído.
  • Si lee/escribe en un socket devuelto en las matrices, tenga en cuenta que no necesariamente leerán/escribirán la cantidad de información que solicitó. Esté preparado para que incluso sea capaz de leer/escrir sólo un único byte.
  • En la mayoría de las implementaciones de sockets es común que la única expcepción capturada con la matriz except sea información fuera de banda recibida en un socket.

Ver también

  • socket_read() - Lee un máximo de longitud de bytes desde un socket
  • socket_write() - Escribir en un socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Envía información a un socket conectado

  • « socket_select
  • socket_sendmsg »
  • PHP Manual
  • Funciones de Socket
  • Envía información a un socket conectado

socket_send

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_send — Envía información a un socket conectado

Descripción

socket_send ( resource $socket , string $buf , int $len , int $flags ) : int

La función socket_send() envía len bytes al socket socket desde buf.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

buf

Un buffer que contiene la información que será enviada al host remoto.

len

El número de bytes que serán enviados al host remoto desde buf.

flags

El valor de flags puede ser cualquier combinación de las siguientes banderas, unidas con el operador binario OR (|).

Valores posibles de flags
MSG_OOB | Enviar información OOB (fuera de banda).
MSG_EOR | Indicar una marca de registro. La información enviada completa el registro.
MSG_EOF | Cerra la parte enviadora del socket e incluir una notificación apropiada de éste al final de la información enviada. La información enviada completa la transacción.
MSG_DONTROUTE | Evitar la ruta, usar la interfaz directa.

Valores devueltos

socket_send() devuelve el número de bytes enviados, o false en caso de error.

Ver también

  • socket_sendto() - Envía un mensaje a un socket, ya esté conectado o no


Enviar un mensaje

  • « socket_send
  • socket_sendto »
  • PHP Manual
  • Funciones de Socket
  • Enviar un mensaje

socket_sendmsg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_sendmsg — Enviar un mensaje

Descripción

socket_sendmsg ( resource $socket , array $message , int $flags = 0 ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

socket

message

flags

Valores devueltos

Devuelve el número de bytes enviados, o false en caso de error.

Ver también

  • socket_recvmsg() - Leer un mensaje
  • socket_cmsg_space() - Calcular el tamaño del búfer de mensajes


Envía un mensaje a un socket, ya esté conectado o no

  • « socket_sendmsg
  • socket_set_block »
  • PHP Manual
  • Funciones de Socket
  • Envía un mensaje a un socket, ya esté conectado o no

socket_sendto

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_sendto — Envía un mensaje a un socket, ya esté conectado o no

Descripción

socket_sendto ( resource $socket , string $buf , int $len , int $flags , string $addr , int $port = 0 ) : int

La función socket_sendto() envía len bytes desde buf a través del socket socket al puerto port en la dirección addr.

Parámetros

socket

Un recurso socket válido creado usando socket_create().

buf

La información enviada será tomada desde el buffer buf.

len

Se enviarán len bytes desde buf.

flags

El valor de flags puede ser una combinación de las siguientes banderas, unidas con el operador binario OR (|).

Valores posibles de flags
MSG_OOB | Enviar información OOB (fuera de banda).
MSG_EOR | Indicar una marca de registro. La información enviada completa el registro.
MSG_EOF | Cerra la parte enviadora del socket e incluir una notificación apropiada de éste al final de la información enviada. La información enviada completa la transacción.
MSG_DONTROUTE | Evitar la ruta, usar la interfaz directa.

addr

La dirección IP del host remoto.

port

port es el número de puerto remoto al que se enviará la información.

Valores devueltos

socket_sendto() devuelve el número de bytes enviados al host remoto, o false si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de socket_sendto()

<?php
    $sock = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);

    $msg = "Ping !";
    $len = strlen($msg);

    socket_sendto($sock, $msg, $len, 0, '127.0.0.1', 1223);
    socket_close($sock);
?>

Ver también

  • socket_send() - Envía información a un socket conectado


Establece el modo de bloqueo de un recurso socket

  • « socket_sendto
  • socket_set_nonblock »
  • PHP Manual
  • Funciones de Socket
  • Establece el modo de bloqueo de un recurso socket

socket_set_block

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

socket_set_block — Establece el modo de bloqueo de un recurso socket

Descripción

socket_set_block ( resource $socket ) : bool

La función socket_set_block() elimina la bandera O_NONBLOCK del socket especificado por el parámetro socket.

Cuando una operación (p.ej. recibir, enviar, conectar, aceptar, ...) se lleva a cabo sobre un socket de bloqueo, el script pausará su ejecución hasta que reciba una señal o pueda realizar la operación.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de socket_set_block()

<?php
$socket = socket_create_listen(1223);
socket_set_block($socket);

socket_accept($socket);
?>

Este ejemplo crea un socket de escucha en todas las interfaces en el puerto 1223 y establece el socket al modo O_BLOCK. socket_accept() se colgará hasta que haya una conexión que aceptar.

Ver también

  • socket_set_nonblock() - Establece el modo de no-bloqueo para el descriptor de archivo fd
  • socket_set_option() - Establece las opciones de socket para el socket


Establece el modo de no-bloqueo para el descriptor de archivo fd

  • « socket_set_block
  • socket_set_option »
  • PHP Manual
  • Funciones de Socket
  • Establece el modo de no-bloqueo para el descriptor de archivo fd

socket_set_nonblock

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_set_nonblock — Establece el modo de no-bloqueo para el descriptor de archivo fd

Descripción

socket_set_nonblock ( resource $socket ) : bool

La funciòn socket_set_nonblock() establece la bandera O_NONBLOCK en el socket especificado por el parámetro socket.

Cuando una operación (p.ej. recibir, enviar, conectar, aceptar, ...) se lleva a cabo sobre un socket de no-bloqueo, el script no pausará su ejecución hasta que reciba una señal o pueda realizar la operación. Más bien, si la operacion resultaría en un bloqueo, la llamada a la función fallará.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de socket_set_nonblock()

<?php
$socket = socket_create_listen(1223);
socket_set_nonblock($socket);

socket_accept($socket);
?>

Este ejemplo crea un socket de escucha en todas las interfaces en el puerto 1223 y establece el socket al modo O_NONBLOCK. socket_accept() fallará inmediantamente a menos que haya una conexión pendiente en ese preciso momento.

Ver también

  • socket_set_block() - Establece el modo de bloqueo de un recurso socket
  • socket_set_option() - Establece las opciones de socket para el socket
  • stream_set_blocking() - Establecer el modo bloqueo/no-bloqueo en un flujo


Establece las opciones de socket para el socket

  • « socket_set_nonblock
  • socket_setopt »
  • PHP Manual
  • Funciones de Socket
  • Establece las opciones de socket para el socket

socket_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

socket_set_option — Establece las opciones de socket para el socket

Descripción

socket_set_option ( resource $socket , int $level , int $optname , mixed $optval ) : bool

La función socket_set_option() establece la opción especificada por el parámetro optname, al nivel (level) del protocolo especificado, al valor apuntado por el parámetro optval para el socket.

Parámetros

socket

Un recurso socket válido creado con socket_create() o socket_accept().

level

El parámetro level especifica el nivel de protocolo en el que reside la opción. Por ejemplo, para recuperar opciones a nivel de socket, se debería usar un parámetro level de SOL_SOCKET. Otros niveles, como TCP, se pueden usar para especificar el número de protocolo de ese nivel. Los números de protocolo se pueden encontrar usando la función getprotobyname().

optname

Las opciones de socket dispobibles son las mismas que las de la función socket_get_option().

optval

El valor opcional.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de socket_set_option()

<?php
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!is_resource($socket)) {
    echo 'No se pudo crear elsocket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo 'No se pudo establecer la opción del socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_bind($socket, '127.0.0.1', 1223)) {
    echo 'No se pudo vincular el socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

$rval = socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR);

if ($rval === false) {
    echo 'No se pudo obtener la opción del option: '. socket_strerror(socket_last_error()) . PHP_EOL;
} else if ($rval !== 0) {
    echo 'SO_REUSEADDR está establecido en el socket !' . PHP_EOL;
}
?>

Ver también

  • socket_create() - Crear un socket (extremo de comunicación)
  • socket_bind() - Vincula un nombre a un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket
  • socket_last_error() - Devuelve el último error sobre un socket
  • socket_get_option() - Obtiene las opciones de socket para el socket


Alias de socket_set_option

  • « socket_set_option
  • socket_shutdown »
  • PHP Manual
  • Funciones de Socket
  • Alias de socket_set_option

socket_setopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_setopt — Alias de socket_set_option()

Descripción

Esta función es un alias de: socket_set_option().


Cierra un socket para dejar de recibir, enviar, o ambos

  • « socket_setopt
  • socket_strerror »
  • PHP Manual
  • Funciones de Socket
  • Cierra un socket para dejar de recibir, enviar, o ambos

socket_shutdown

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_shutdown — Cierra un socket para dejar de recibir, enviar, o ambos

Descripción

socket_shutdown ( resource $socket , int $how = 2 ) : bool

La función socket_shutdown() permite detener la entrada y salida de toda la información (lo predeterminado) que está siendo enviada a través del socket

Nota:

El búfer o búferes podrían o no estar vaciados.

Parámetros

socket

Un recurso socket válido creado con socket_create().

how

El valor de how puede ser uno de los siguientes:

Valores posibles de how
0 | Cierra el socket para dejar de leer
1 | Cierra el socket para dejar de escribir
2 | Cierra el socket para dejar de leer y escribir

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve una cadena que describe un error de socket

  • « socket_shutdown
  • socket_write »
  • PHP Manual
  • Funciones de Socket
  • Devuelve una cadena que describe un error de socket

socket_strerror

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_strerror — Devuelve una cadena que describe un error de socket

Descripción

socket_strerror ( int $errno ) : string

socket_strerror() toma su parámetro errno como un código de error de socket devuelto por socket_last_error() y devuelve el correspondiente texto explicativo.

Nota:

Aunque los mensajes de error generados por la extensión socket están en inglés, los mensajes del sistema recupeardos con esta función aparecerán depenediendo de la configuración regional (LC_MESSAGES).

Parámetros

errno

Un número de error de socket válido, como los producidos por socket_last_error().

Valores devueltos

Devuelve el mensaje de error asociado con el parámetro errno.

Ejemplos

Ejemplo #1 Ejemplo de socket_strerror()

<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
   echo "socket_create() falló: razón: " . socket_strerror(socket_last_error()) . "\n";
}

if (false == (@socket_bind($socket, '127.0.0.1', 80))) {
   echo "socket_bind() falló: razón: " . socket_strerror(socket_last_error($socket)) . "\n";
}
?>

La salida esperada del ejemplo de arriba (asumiendo que el script no está ejecutándose con privilegios):

socket_bind() falló: razón: Permission denied

Ver también

  • socket_accept() - Acepta una conexión de un socket
  • socket_bind() - Vincula un nombre a un socket
  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_create() - Crear un socket (extremo de comunicación)


Escribir en un socket

  • « socket_strerror
  • socket_wsaprotocol_info_export »
  • PHP Manual
  • Funciones de Socket
  • Escribir en un socket

socket_write

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_write — Escribir en un socket

Descripción

socket_write ( resource $socket , string $buffer , int $length = 0 ) : int

La función socket_write() escribe en el socket desde el buffer dado.

Parámetros

socket

buffer

El buffer a ser escrito.

length

El parámetro opcional length puede especificar una longitud alternativa de bytes escritos en el socket. Si esta longitud es mayor que la longitud del buffer se trunca de forma silenciosa a la longitud del buffer.

Valores devueltos

Devuelve el número de bytes escritos con éxito en el socket o false en caso de error. El código de error se puede recuperar con socket_last_error(). Este código se puede pasar a socket_strerror() para obtener una explicación textual del error.

Nota:

Es perfectamente válido que socket_write() devuelva cero, lo que significa que no se han escrito bytes. Asegúrese de usar el operador === para verificar false en caso de un error.

Notas

Nota:

socket_write() no escribe necesariamente todos los bytes desde el buffer dado. Esto es válido ya que depende de los búferes de red, etc., sólo se escribe una cierta cantidad de informaicón, incluso un byte, aunque su buffer sea mayor. Debe tener cuidado de no olvidar inintencionadamente de transmitir el resto de la información.

Ver también

  • socket_accept() - Acepta una conexión de un socket
  • socket_bind() - Vincula un nombre a un socket
  • socket_connect() - Inicia una conexión sobre un socket
  • socket_listen() - Escucha una conexión sobre un socket
  • socket_read() - Lee un máximo de longitud de bytes desde un socket
  • socket_strerror() - Devuelve una cadena que describe un error de socket


Exports the WSAPROTOCOL_INFO Structure

  • « socket_write
  • socket_wsaprotocol_info_import »
  • PHP Manual
  • Funciones de Socket
  • Exports the WSAPROTOCOL_INFO Structure

socket_wsaprotocol_info_export

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure

Descripción

socket_wsaprotocol_info_export ( Socket $socket , int $process_id ) : string|false

Exports the WSAPROTOCOL_INFO structure into shared memory and returns an identifier to be used with socket_wsaprotocol_info_import(). The exported ID is only valid for the given process_id.

Nota: This function is available only on Windows.

Parámetros

socket

A Socket instance.

process_id

The ID of the process which will import the socket.

Valores devueltos

Returns an identifier to be used for the import, o false en caso de error

Historial de cambios

Versión | Descripción
8.0.0 | socket is a Socket instance now; previously, it was a resource.

Ver también

  • socket_wsaprotocol_info_import() - Imports a Socket from another Process
  • socket_wsaprotocol_info_release() - Releases an exported WSAPROTOCOL_INFO Structure


Imports a Socket from another Process

  • « socket_wsaprotocol_info_export
  • socket_wsaprotocol_info_release »
  • PHP Manual
  • Funciones de Socket
  • Imports a Socket from another Process

socket_wsaprotocol_info_import

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_import — Imports a Socket from another Process

Descripción

socket_wsaprotocol_info_import ( string $info_id ) : Socket|false

Imports a socket which has formerly been exported from another process.

Nota: This function is available only on Windows.

Parámetros

info_id

The ID which has been returned by a former call to socket_wsaprotocol_info_export().

Valores devueltos

Returns a Socket instance on success, o false en caso de error

Historial de cambios

Versión | Descripción
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.

Ver también

  • socket_wsaprotocol_info_export() - Exports the WSAPROTOCOL_INFO Structure


Releases an exported WSAPROTOCOL_INFO Structure

  • « socket_wsaprotocol_info_import
  • SSH2 »
  • PHP Manual
  • Funciones de Socket
  • Releases an exported WSAPROTOCOL_INFO Structure

socket_wsaprotocol_info_release

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure

Descripción

socket_wsaprotocol_info_release ( string $info_id ) : bool

Releases the shared memory corresponding to the given info_id.

Nota: This function is available only on Windows.

Parámetros

info_id

The ID which has been returned by a former call to socket_wsaprotocol_info_export().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • socket_wsaprotocol_info_export() - Exports the WSAPROTOCOL_INFO Structure


Secure Shell2

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de SSH2
    • ssh2_auth_agent — Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file — Authenticate using a public hostkey
    • ssh2_auth_none — Authenticate as "none"
    • ssh2_auth_password — Authenticate over SSH using a plain password
    • ssh2_auth_pubkey_file — Authenticate using a public key
    • ssh2_connect — Conecta a un servidor SSH
    • ssh2_disconnect — Close a connection to a remote SSH server
    • ssh2_exec — Execute a command on a remote server
    • ssh2_fetch_stream — Fetch an extended data stream
    • ssh2_fingerprint — Retrieve fingerprint of remote server
    • ssh2_forward_accept — Accept a connection created by a listener
    • ssh2_forward_listen — Bind a port on the remote server and listen for connections
    • ssh2_methods_negotiated — Return list of negotiated methods
    • ssh2_poll — Poll the channels/listeners/streams for events
    • ssh2_publickey_add — Add an authorized publickey
    • ssh2_publickey_init — Initialize Publickey subsystem
    • ssh2_publickey_list — List currently authorized publickeys
    • ssh2_publickey_remove — Remove an authorized publickey
    • ssh2_scp_recv — Solicita un fichero mediante SCP
    • ssh2_scp_send — Envía un fichero mediante SCP
    • ssh2_sftp_chmod — Changes file mode
    • ssh2_sftp_lstat — Stat a symbolic link
    • ssh2_sftp_mkdir — Create a directory
    • ssh2_sftp_readlink — Return the target of a symbolic link
    • ssh2_sftp_realpath — Resolve the realpath of a provided path string
    • ssh2_sftp_rename — Rename a remote file
    • ssh2_sftp_rmdir — Remove a directory
    • ssh2_sftp_stat — Stat a file on a remote filesystem
    • ssh2_sftp_symlink — Create a symlink
    • ssh2_sftp_unlink — Delete a file
    • ssh2_sftp — Inicializar el subsistema SFTP
    • ssh2_shell — Request an interactive shell
    • ssh2_tunnel — Open a tunnel through a remote server


Introducción

Se enlaza a la biblioteca » libssh2 que provee acceso a recursos (shell, ejecución remota, tunneling, transferencia de archivos) sobre una máquina remota utilizando una vía de transporte criptográfica segura.


Requerimientos

Las librerías » OpenSSL y » libssh2 son obligatorias. Asegúrese que las librerías de desarrollo estan instaladas, donde el nombre típico del paquete podría ser openssl-dev.

Es necesaria la versión 1.2 o posterior de libssh2 , aunque es posible que nuevos lanzamientos de pecl/ssh2 pueden requerir versiones posteriores (consultar las notas de lanzamiento)

La función ssh2_auth_agent() estará disponible únicamente con libssh >= 1.2.3.

El soporte para stream_set_timeout() para canalizar secuencias sólo estará disponible con libssh >= 1.2.9.

libssh2 viene en dos versiones: gcrypt y openssl. Algunas distribuciones de Linux compilan libssh2 contra la librería gcrypt, y otras utilizan openssl. libssh2 tiene algunos problemas cuando se compila contra gcrypt, por favor, utilice openssl.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ssh2.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SSH2_FINGERPRINT_MD5 (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an MD5 hash.
SSH2_FINGERPRINT_SHA1 (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an SHA1 hash.
SSH2_FINGERPRINT_HEX (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a string of hexits.
SSH2_FINGERPRINT_RAW (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a raw string of 8-bit characters.
SSH2_TERM_UNIT_CHARS (int)
Flag to ssh2_shell() specifying that width and height are provided as character sizes.
SSH2_TERM_UNIT_PIXELS (int)
Flag to ssh2_shell() specifying that width and height are provided in pixel units.
SSH2_DEFAULT_TERM_WIDTH (int)
Default terminal width requested by ssh2_shell().
SSH2_DEFAULT_TERM_HEIGHT (int)
Default terminal height requested by ssh2_shell().
SSH2_DEFAULT_TERM_UNIT (int)
Default terminal units requested by ssh2_shell().
SSH2_STREAM_STDIO (int)
Flag to ssh2_fetch_stream() requesting STDIO subchannel.
SSH2_STREAM_STDERR (int)
Flag to ssh2_fetch_stream() requesting STDERR subchannel.
SSH2_DEFAULT_TERMINAL (string)
Default terminal type (e.g. vt102, ansi, xterm, vanilla) requested by ssh2_shell().
SSH2_POLLIN (int)
SSH2_POLLEXT (int)
SSH2_POLLOUT (int)
SSH2_POLLERR (int)
SSH2_POLLHUP (int)
SSH2_POLLNVAL (int)
SSH2_POLL_SESSION_CLOSED (int)
SSH2_POLL_CHANNEL_CLOSED (int)
SSH2_POLL_LISTENER_CLOSED (int)


Funciones de SSH2

Tabla de contenidos

  • ssh2_auth_agent — Authenticate over SSH using the ssh agent
  • ssh2_auth_hostbased_file — Authenticate using a public hostkey
  • ssh2_auth_none — Authenticate as "none"
  • ssh2_auth_password — Authenticate over SSH using a plain password
  • ssh2_auth_pubkey_file — Authenticate using a public key
  • ssh2_connect — Conecta a un servidor SSH
  • ssh2_disconnect — Close a connection to a remote SSH server
  • ssh2_exec — Execute a command on a remote server
  • ssh2_fetch_stream — Fetch an extended data stream
  • ssh2_fingerprint — Retrieve fingerprint of remote server
  • ssh2_forward_accept — Accept a connection created by a listener
  • ssh2_forward_listen — Bind a port on the remote server and listen for connections
  • ssh2_methods_negotiated — Return list of negotiated methods
  • ssh2_poll — Poll the channels/listeners/streams for events
  • ssh2_publickey_add — Add an authorized publickey
  • ssh2_publickey_init — Initialize Publickey subsystem
  • ssh2_publickey_list — List currently authorized publickeys
  • ssh2_publickey_remove — Remove an authorized publickey
  • ssh2_scp_recv — Solicita un fichero mediante SCP
  • ssh2_scp_send — Envía un fichero mediante SCP
  • ssh2_sftp_chmod — Changes file mode
  • ssh2_sftp_lstat — Stat a symbolic link
  • ssh2_sftp_mkdir — Create a directory
  • ssh2_sftp_readlink — Return the target of a symbolic link
  • ssh2_sftp_realpath — Resolve the realpath of a provided path string
  • ssh2_sftp_rename — Rename a remote file
  • ssh2_sftp_rmdir — Remove a directory
  • ssh2_sftp_stat — Stat a file on a remote filesystem
  • ssh2_sftp_symlink — Create a symlink
  • ssh2_sftp_unlink — Delete a file
  • ssh2_sftp — Inicializar el subsistema SFTP
  • ssh2_shell — Request an interactive shell
  • ssh2_tunnel — Open a tunnel through a remote server


Authenticate over SSH using the ssh agent

  • « Funciones de SSH2
  • ssh2_auth_hostbased_file »
  • PHP Manual
  • Funciones de SSH2
  • Authenticate over SSH using the ssh agent

ssh2_auth_agent

(PECL ssh2 >= 0.12)

ssh2_auth_agent — Authenticate over SSH using the ssh agent

Descripción

ssh2_auth_agent ( resource $session , string $username ) : bool

Authenticate over SSH using the ssh agent

Nota: The ssh2_auth_agent() function will only be available when the ssh2 extension is compiled with libssh >= 1.2.3.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Authenticating with a ssh agent

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_agent($connection, 'username')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>


Authenticate using a public hostkey

  • « ssh2_auth_agent
  • ssh2_auth_none »
  • PHP Manual
  • Funciones de SSH2
  • Authenticate using a public hostkey

ssh2_auth_hostbased_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_hostbased_file — Authenticate using a public hostkey

Descripción

ssh2_auth_hostbased_file ( resource $session , string $username , string $hostname , string $pubkeyfile , string $privkeyfile , string $passphrase = ? , string $local_username = ? ) : bool

Authenticate using a public hostkey read from a file.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

hostname

pubkeyfile

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

local_username

If local_username is omitted, then the value for username will be used for it.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Authentication using a public hostkey

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_hostbased_file($connection, 'remoteusername', 'myhost.example.com',
                             '/usr/local/etc/hostkey_rsa.pub',
                             '/usr/local/etc/hostkey_rsa', 'secret',
                             'localusername')) {
  echo "Public Key Hostbased Authentication Successful\n";
} else {
  die('Public Key Hostbased Authentication Failed');
}
?>

Notas

Nota:

ssh2_auth_hostbased_file() requires libssh2 >= 0.7 and PHP/SSH2 >= 0.7


Authenticate as "none"

  • « ssh2_auth_hostbased_file
  • ssh2_auth_password »
  • PHP Manual
  • Funciones de SSH2
  • Authenticate as "none"

ssh2_auth_none

(PECL ssh2 >= 0.9.0)

ssh2_auth_none — Authenticate as "none"

Descripción

ssh2_auth_none ( resource $session , string $username ) : mixed

Attempt "none" authentication which usually will (and should) fail. As part of the failure, this function will return an array of accepted authentication methods.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

Valores devueltos

Returns true if the server does accept "none" as an authentication method, or an array of accepted authentication methods on failure.

Ejemplos

Ejemplo #1 Retrieving a list of authentication methods

<?php
$connection = ssh2_connect('shell.example.com', 22);

$auth_methods = ssh2_auth_none($connection, 'user');

if (in_array('password', $auth_methods)) {
  echo "Server supports password based authentication\n";
}
?>


Authenticate over SSH using a plain password

  • « ssh2_auth_none
  • ssh2_auth_pubkey_file »
  • PHP Manual
  • Funciones de SSH2
  • Authenticate over SSH using a plain password

ssh2_auth_password

(PECL ssh2 >= 0.9.0)

ssh2_auth_password — Authenticate over SSH using a plain password

Descripción

ssh2_auth_password ( resource $session , string $username , string $password ) : bool

Authenticate over SSH using a plain password. Since version 0.12 this function also supports keyboard_interactive method.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

password

Password for username

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Authenticating with a password

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_password($connection, 'username', 'secret')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>


Authenticate using a public key

  • « ssh2_auth_password
  • ssh2_connect »
  • PHP Manual
  • Funciones de SSH2
  • Authenticate using a public key

ssh2_auth_pubkey_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_pubkey_file — Authenticate using a public key

Descripción

ssh2_auth_pubkey_file ( resource $session , string $username , string $pubkeyfile , string $privkeyfile , string $passphrase = ? ) : bool

Authenticate using a public key read from a file.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

pubkeyfile

The public key file needs to be in OpenSSH's format. It should look something like:

ssh-rsa AAAAB3NzaC1yc2EAAA....NX6sqSnHA8= rsa-key-20121110

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Authentication using a public key

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_pubkey_file($connection, 'username',
                          '/home/username/.ssh/id_rsa.pub',
                          '/home/username/.ssh/id_rsa', 'secret')) {
  echo "Public Key Authentication Successful\n";
} else {
  die('Public Key Authentication Failed');
}
?>

Notas

Nota:

The underlying libssh library doesn't support partial auths very cleanly That is, if you need to supply both a public key and a password it will appear as if this function has failed. In this particular case a failure from this call may just mean that auth hasn't been completed yet. You would need to ignore this failure and continue on and call ssh2_auth_password() in order to complete authentication.


Conecta a un servidor SSH

  • « ssh2_auth_pubkey_file
  • ssh2_disconnect »
  • PHP Manual
  • Funciones de SSH2
  • Conecta a un servidor SSH

ssh2_connect

(PECL ssh2 >= 0.9.0)

ssh2_connect — Conecta a un servidor SSH

Descripción

ssh2_connect ( string $host , int $port = 22 , array $methods = ? , array $callbacks = ? ) : resource

Establece una conexión a un servidor SSH remoto.

Una vez conectado, el cliente debería verificar la clave de host del servidor usando ssh2_fingerprint(), y entonces, autenticarse usando la contreseña o la clave pública.

Parámetros

host

port

methods

methods puede ser un array asociativo con, hasta 4 parámetros descritos aquí abajo.

methods puede ser un array asociativo con todos o alguno de los siguientes parámetros.
Índice | Significado | Valores aceptados*
kex | Lista de métodos de intercambio de claves a revelar, separados por comas en orden de preferencia. | diffie-hellman-group1-sha1, diffie-hellman-group14-sha1, y diffie-hellman-group-exchange-sha1
hostkey | Lista de métodos clave-host a desvelar, separados por comas en orden de preferencia. | ssh-rsa y ssh-dss
client_to_server | Associative array containing crypt, compression, and message authentication code (MAC) method preferences for messages sent from client to server.
server_to_client | Array asociativo que contiene el cifrado, la compresión, y las preferencias del método de código de autenticación de mensajes (MAC) para mensajes enviados del servidor al cliente.

* - Los valores soportados dependen de los métodos soportados por la librería subyacente. Mirar la documentación » libssh2 para obtener información adicional.

client_to_server y server_to_client pueden ser un array asociativo con todos o algunos de los siguientes parámetros.
Índice | Significado | Valores soportados*
crypt | Lista de métodos de cifrado a desvelar, separados por comas y en orden de preferencia. | rijndael-cbc@lysator.liu.se, aes256-cbc, aes192-cbc, aes128-cbc, 3des-cbc, blowfish-cbc, cast128-cbc, arcfour, y none**
comp | Lista de los métodos de compresión a desvelar, separados por comas y en orden de preferencia. | zlib y none
mac | Lista de métodos MAC a desvelar, separados por comas y en orden de preferencia. | hmac-sha1, hmac-sha1-96, hmac-ripemd160, hmac-ripemd160@openssh.com, y none**

Nota: Método de encriptación y MAC "none"

Por razones de seguridad, none está deshabilitado por la librería subyacente » libssh2 a menos que esté habilitado explícitamente durante el tiempo de construcción usando la optión apropiada de ./configure. Lea la documentación de dicha librería para más información.

callbacks

callbacks puede ser un array asociativo con todos o alguno de los siguientes parámtros.

Parámetros de devolución
Índice | Significado | Prototipo
ignore | Nombre de la función a llamar cuando el paquete SSH2_MSG_IGNORE es recibido | void ignore_cb($message)
debug | Nombre de la función a llamar cuando el paquete SSH2_MSG_DEBUG es recibido | void debug_cb($message, $language, $always_display)
macerror | Name of function to call when a packet is received but the message authentication code failed. If the callback returns true, the mismatch will be ignored, otherwise the connection will be terminated. | bool macerror_cb($packet)
disconnect | Nombre de la función a llamar cuando el paquete SSH2_MSG_DISCONNECT es recibido | void disconnect_cb($reason, $message, $language)

Valores devueltos

Devuelve un recurso en caso de éxito, o false en caso de error.

Ejemplos

Ejemplo #1 ssh2_connect()

Abre una conexión forzando 3des-cbc cuando envía paquetes, cualquier grado de cifrado aes cuando se reciben paquetes, sin comprensión ni dirección, y Group1 como clave de cambio.

<?php
/* Notifica al usuario si el servidor ha terminado la conexión */
function my_ssh_disconnect($reason, $message, $language) {
  printf("Servidor desconectado con el siguiente código [%d] y mensaje: %s\n",
         $reason, $message);
}

$methods = array(
  'kex' => 'diffie-hellman-group1-sha1',
  'client_to_server' => array(
    'crypt' => '3des-cbc',
    'comp' => 'none'),
  'server_to_client' => array(
    'crypt' => 'aes256-cbc,aes192-cbc,aes128-cbc',
    'comp' => 'none'));

$callbacks = array('disconnect' => 'my_ssh_disconnect');

$connection = ssh2_connect('shell.example.com', 22, $methods, $callbacks);
if (!$connection) die('Conexión fallida');
?>

Ver también

  • ssh2_fingerprint() - Retrieve fingerprint of remote server
  • ssh2_auth_none() - Authenticate as "none"
  • ssh2_auth_password() - Authenticate over SSH using a plain password
  • ssh2_auth_pubkey_file() - Authenticate using a public key


Close a connection to a remote SSH server

  • « ssh2_connect
  • ssh2_exec »
  • PHP Manual
  • Funciones de SSH2
  • Close a connection to a remote SSH server

ssh2_disconnect

(PECL ssh2 >= 1.0)

ssh2_disconnect — Close a connection to a remote SSH server

Descripción

ssh2_disconnect ( resource $session ) : bool

Close a connection to a remote SSH server.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ssh2_connect() - Conecta a un servidor SSH


Execute a command on a remote server

  • « ssh2_disconnect
  • ssh2_fetch_stream »
  • PHP Manual
  • Funciones de SSH2
  • Execute a command on a remote server

ssh2_exec

(PECL ssh2 >= 0.9.0)

ssh2_exec — Execute a command on a remote server

Descripción

ssh2_exec ( resource $session , string $command , string $pty = ? , array $env = ? , int $width = 80 , int $height = 25 , int $width_height_type = SSH2_TERM_UNIT_CHARS ) : resource|false

Execute a command at the remote end and allocate a channel for it.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

command

pty

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

Valores devueltos

Returns a stream on success o false en caso de error.

Ejemplos

Ejemplo #1 Executing a command

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_exec($connection, '/usr/local/bin/php -i');
?>

Ver también

  • ssh2_connect() - Conecta a un servidor SSH
  • ssh2_shell() - Request an interactive shell
  • ssh2_tunnel() - Open a tunnel through a remote server


Fetch an extended data stream

  • « ssh2_exec
  • ssh2_fingerprint »
  • PHP Manual
  • Funciones de SSH2
  • Fetch an extended data stream

ssh2_fetch_stream

(PECL ssh2 >= 0.9.0)

ssh2_fetch_stream — Fetch an extended data stream

Descripción

ssh2_fetch_stream ( resource $channel , int $streamid ) : resource

Fetches an alternate substream associated with an SSH2 channel stream. The SSH2 protocol currently defines only one substream, STDERR, which has a substream ID of SSH2_STREAM_STDERR (defined as 1).

Parámetros

channel

streamid

An SSH2 channel stream.

Valores devueltos

Returns the requested stream resource.

Ejemplos

Ejemplo #1 Opening a shell and retrieving the stderr stream associated with it

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stdio_stream = ssh2_shell($connection);
$stderr_stream = ssh2_fetch_stream($stdio_stream, SSH2_STREAM_STDERR);
?>

Ver también

  • ssh2_shell() - Request an interactive shell
  • ssh2_exec() - Execute a command on a remote server
  • ssh2_connect() - Conecta a un servidor SSH


Retrieve fingerprint of remote server

  • « ssh2_fetch_stream
  • ssh2_forward_accept »
  • PHP Manual
  • Funciones de SSH2
  • Retrieve fingerprint of remote server

ssh2_fingerprint

(PECL ssh2 >= 0.9.0)

ssh2_fingerprint — Retrieve fingerprint of remote server

Descripción

ssh2_fingerprint ( resource $session , int $flags = SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX ) : string

Returns a server hostkey hash from an active session.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

flags

flags may be either of SSH2_FINGERPRINT_MD5 or SSH2_FINGERPRINT_SHA1 logically ORed with SSH2_FINGERPRINT_HEX or SSH2_FINGERPRINT_RAW.

Valores devueltos

Returns the hostkey hash as a string.

Ejemplos

Ejemplo #1 Checking the fingerprint against a known value

<?php
$known_host = '6F89C2F0A719B30CC38ABDF90755F2E4';

$connection = ssh2_connect('shell.example.com', 22);

$fingerprint = ssh2_fingerprint($connection,
               SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX);

if ($fingerprint != $known_host) {
  die("HOSTKEY MISMATCH!\n" .
      "Possible Man-In-The-Middle Attack?");
}
?>


Accept a connection created by a listener

  • « ssh2_fingerprint
  • ssh2_forward_listen »
  • PHP Manual
  • Funciones de SSH2
  • Accept a connection created by a listener

ssh2_forward_accept

(PECL ssh2 >= 0.9.0)

ssh2_forward_accept — Accept a connection created by a listener

Descripción

ssh2_forward_accept ( resource $listener ) : resource|false

Accepts a connection created by a listener.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

desc

An SSH2 Listener resource, obtained from a call to ssh2_forward_listen().

Valores devueltos

Returns a stream resource, o false en caso de error.


Bind a port on the remote server and listen for connections

  • « ssh2_forward_accept
  • ssh2_methods_negotiated »
  • PHP Manual
  • Funciones de SSH2
  • Bind a port on the remote server and listen for connections

ssh2_forward_listen

(PECL ssh2 >= 0.9.0)

ssh2_forward_listen — Bind a port on the remote server and listen for connections

Descripción

ssh2_forward_listen ( resource $session , int $port , string $host = ? , int $max_connections = 16 ) : resource|false

Binds a port on the remote server and listen for connections.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

session

An SSH Session resource, obtained from a call to ssh2_connect().

port

The port of the remote server.

host

max_connections

Valores devueltos

Returns an SSH2 Listener, o false en caso de error.

Ver también

  • ssh2_forward_accept() - Accept a connection created by a listener


Return list of negotiated methods

  • « ssh2_forward_listen
  • ssh2_poll »
  • PHP Manual
  • Funciones de SSH2
  • Return list of negotiated methods

ssh2_methods_negotiated

(PECL ssh2 >= 0.9.0)

ssh2_methods_negotiated — Return list of negotiated methods

Descripción

ssh2_methods_negotiated ( resource $session ) : array

Returns list of negotiated methods.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

Valores devueltos

Ejemplos

Ejemplo #1 Determining what methods were negotiated

<?php
$connection = ssh2_connect('shell.example.com', 22);
$methods = ssh2_methods_negotiated($connection);

echo "Encryption keys were negotiated using: {$methods['kex']}\n";
echo "Server identified using an {$methods['hostkey']} with ";
echo "fingerprint: " . ssh2_fingerprint($connection) . "\n";

echo "Client to Server packets will use methods:\n";
echo "\tCrypt: {$methods['client_to_server']['crypt']}\n";
echo "\tComp: {$methods['client_to_server']['comp']}\n";
echo "\tMAC: {$methods['client_to_server']['mac']}\n";

echo "Server to Client packets will use methods:\n";
echo "\tCrypt: {$methods['server_to_client']['crypt']}\n";
echo "\tComp: {$methods['server_to_client']['comp']}\n";
echo "\tMAC: {$methods['server_to_client']['mac']}\n";

?>

Ver también

  • ssh2_connect() - Conecta a un servidor SSH


Poll the channels/listeners/streams for events

  • « ssh2_methods_negotiated
  • ssh2_publickey_add »
  • PHP Manual
  • Funciones de SSH2
  • Poll the channels/listeners/streams for events

ssh2_poll

(PECL ssh2 >= 0.9.0)

ssh2_poll — Poll the channels/listeners/streams for events

Descripción

ssh2_poll ( array &$desc , int $timeout = 30 ) : int

Polls the channels/listeners/streams for events, and returns the number of descriptors which returned non-zero revents.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

desc

An indexed array of subarrays with the keys 'resource' and 'events'. The value of the resource is a (channel) stream or an SSH2 Listener resource. The value of the event are SSH2_POLL* flags bitwise ORed together. Each subarray will be populated with an 'revents' element on return, whose values are SSH2_POLL* flags bitwise ORed together of the events that occurred.

timeout

The timeout in seconds.

Valores devueltos

Returns the number of descriptors which returned non-zero revents.


Add an authorized publickey

  • « ssh2_poll
  • ssh2_publickey_init »
  • PHP Manual
  • Funciones de SSH2
  • Add an authorized publickey

ssh2_publickey_add

(PECL ssh2 >= 0.10)

ssh2_publickey_add — Add an authorized publickey

Descripción

ssh2_publickey_add ( resource $pkey , string $algoname , string $blob , bool $overwrite = false , array $attributes = ? ) : bool

Nota: El subsistema de clave pública es utilizado para administrar claves públicas en un servidor al que el cliente ya está autenticado. Para autenticar a un sistema remoto usando autenticación de clave pública, use la función ssh2_auth_pubkey_file() en cambio.

Parámetros

pkey

Publickey Subsystem resource created by ssh2_publickey_init().

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

overwrite

If the specified key already exists, should it be overwritten?

attributes

Associative array of attributes to assign to this public key. Refer to ietf-secsh-publickey-subsystem for a list of supported attributes. To mark an attribute as mandatory, precede its name with an asterisk. If the server is unable to support an attribute marked mandatory, it will abort the add process.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Adding a publickey with ssh2_publickey_add()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'password');
$pkey = ssh2_publickey_init($ssh2);

$keyblob = base64_decode('
AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5PTrLRdjNONxXH1tVFGn0
Bd26BF0aCP9qyJRlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xj
zaLpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VEHYckxQ16CjSTibI5X
69GmnYC9PNqEYq/1TP+HF10=');

ssh2_publickey_add($pkey, 'ssh-rsa', $keyblob, false, array('comment'=>"John's Key"));
?>

Ver también

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_remove() - Remove an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


Initialize Publickey subsystem

  • « ssh2_publickey_add
  • ssh2_publickey_list »
  • PHP Manual
  • Funciones de SSH2
  • Initialize Publickey subsystem

ssh2_publickey_init

(PECL ssh2 >= 0.10)

ssh2_publickey_init — Initialize Publickey subsystem

Descripción

ssh2_publickey_init ( resource $session ) : resource|false

Request the Publickey subsystem from an already connected SSH2 server.

The publickey subsystem allows an already connected and authenticated client to manage the list of authorized public keys stored on the target server in an implementation agnostic manner. If the remote server does not support the publickey subsystem, the ssh2_publickey_init() function will return false.

Parámetros

session

Valores devueltos

Returns an SSH2 Publickey Subsystem resource for use with all other ssh2_publickey_*() methods o false en caso de error.

Notas

Nota: El subsistema de clave pública es utilizado para administrar claves públicas en un servidor al que el cliente ya está autenticado. Para autenticar a un sistema remoto usando autenticación de clave pública, use la función ssh2_auth_pubkey_file() en cambio.

Ver también

  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_remove() - Remove an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


List currently authorized publickeys

  • « ssh2_publickey_init
  • ssh2_publickey_remove »
  • PHP Manual
  • Funciones de SSH2
  • List currently authorized publickeys

ssh2_publickey_list

(PECL ssh2 >= 0.10)

ssh2_publickey_list — List currently authorized publickeys

Descripción

ssh2_publickey_list ( resource $pkey ) : array

List currently authorized publickeys.

Parámetros

pkey

Publickey Subsystem resource

Valores devueltos

Returns a numerically indexed array of keys, each of which is an associative array containing: name, blob, and attrs elements.

Publickey elements
Array Key | Meaning
name | Name of algorithm used by this publickey, for example: ssh-dss or ssh-rsa.
blob | Publickey blob as raw binary data.
attrs | Attributes assigned to this publickey. The most common attribute, and the only one supported by publickey version 1 servers, is comment, which may be any freeform string.

Ejemplos

Ejemplo #1 Listing authorized keys with ssh2_publickey_list()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'secret');
$pkey = ssh2_publickey_init($ssh2);

$list = ssh2_publickey_list($pkey);

foreach($list as $key) {
  echo "Key: {$key['name']}\n";
  echo "Blob: " . chunk_split(base64_encode($key['blob']), 40, "\n") . "\n";
  echo "Comment: {$key['attrs']['comment']}\n\n";
}
?>

El resultado del ejemplo sería:

Key: ssh-rsa
Blob: AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5P
TrLRdjNONxXH1tVFGn0Bd26BF0aCP9qyJRlvdJ3j
4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xjza
Lpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VE
HYckxQ16CjSTibI5X69GmnYC9PNqEYq/1TP+HF10
Comment: John's Key

Key: ssh-rsa
Blob: AAAAB3NzaHVt6VqSGd5C1yc2EAAAABIwA232dnJA
AIEA5HVt6VqSGd5PTrLRdjNONxX/1TP+HF1HVt6V
qSGd50H1tVFGn0BB3NzaC1yc2EAd26BF0aCP9qyJ
RlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26HVt6Vq
SGd5sDHwfL351xjzaLpipu\BGB3NzaC1yc2EA/1T
Comment: Alice's Key

Notas

Nota: El subsistema de clave pública es utilizado para administrar claves públicas en un servidor al que el cliente ya está autenticado. Para autenticar a un sistema remoto usando autenticación de clave pública, use la función ssh2_auth_pubkey_file() en cambio.

Ver también

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_remove() - Remove an authorized publickey


Remove an authorized publickey

  • « ssh2_publickey_list
  • ssh2_scp_recv »
  • PHP Manual
  • Funciones de SSH2
  • Remove an authorized publickey

ssh2_publickey_remove

(PECL ssh2 >= 0.10)

ssh2_publickey_remove — Remove an authorized publickey

Descripción

ssh2_publickey_remove ( resource $pkey , string $algoname , string $blob ) : bool

Removes an authorized publickey.

Parámetros

pkey

Publickey Subsystem Resource

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota: El subsistema de clave pública es utilizado para administrar claves públicas en un servidor al que el cliente ya está autenticado. Para autenticar a un sistema remoto usando autenticación de clave pública, use la función ssh2_auth_pubkey_file() en cambio.

Ver también

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


Solicita un fichero mediante SCP

  • « ssh2_publickey_remove
  • ssh2_scp_send »
  • PHP Manual
  • Funciones de SSH2
  • Solicita un fichero mediante SCP

ssh2_scp_recv

(PECL ssh2 >= 0.9.0)

ssh2_scp_recv — Solicita un fichero mediante SCP

Descripción

ssh2_scp_recv ( resource $session , string $remote_file , string $local_file ) : bool

Copia un fichero desde el servidor remoto al sistema de ficheros local usando el protocolo SCP.

Parámetros

session

Un identificador de enlace de conexión a SSH, obtenido desde una llamada a ssh2_connect().

remote_file

Ruta del fichero remoto.

local_file

Ruta del fichero local.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Descargar un fichero mediante SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_recv($connection, '/remote/filename', '/local/filename');
?>

Ver también

  • ssh2_scp_send() - Envía un fichero mediante SCP
  • copy() - Copia un fichero


Envía un fichero mediante SCP

  • « ssh2_scp_recv
  • ssh2_sftp_chmod »
  • PHP Manual
  • Funciones de SSH2
  • Envía un fichero mediante SCP

ssh2_scp_send

(PECL ssh2 >= 0.9.0)

ssh2_scp_send — Envía un fichero mediante SCP

Descripción

ssh2_scp_send ( resource $session , string $local_file , string $remote_file , int $create_mode = 0644 ) : bool

Copia un fichero desde el sistema de ficheros local a un servidor remoto usando el protocolo SCP.

Parámetros

session

Un identificador de enlace de conexión a SSH, obtenido desde una llamada a ssh2_connect().

local_file

Ruta del fichero local.

remote_file

Ruta del fichero remoto.

create_mode

El fichero debe ser creado con el modo especificado por create_mode.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Cargar un fichero via SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_send($connection, '/local/filename', '/remote/filename', 0644);
?>

Ver también

  • ssh2_scp_recv() - Solicita un fichero mediante SCP
  • copy() - Copia un fichero


Changes file mode

  • « ssh2_scp_send
  • ssh2_sftp_lstat »
  • PHP Manual
  • Funciones de SSH2
  • Changes file mode

ssh2_sftp_chmod

(PECL ssh2 >= 0.12)

ssh2_sftp_chmod — Changes file mode

Descripción

ssh2_sftp_chmod ( resource $sftp , string $filename , int $mode ) : bool

Attempts to change the mode of the specified file to that given in mode.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Path to the file.

mode

Permissions on the file. See the chmod() for more details on this parameter.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Changing the mode of a file on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_chmod($sftp, '/somedir/somefile', 0755);
?>

Ver también

  • chmod() - Cambia el modo de un fichero
  • ssh2_sftp() - Inicializar el subsistema SFTP
  • ssh2_connect() - Conecta a un servidor SSH


Stat a symbolic link

  • « ssh2_sftp_chmod
  • ssh2_sftp_mkdir »
  • PHP Manual
  • Funciones de SSH2
  • Stat a symbolic link

ssh2_sftp_lstat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_lstat — Stat a symbolic link

Descripción

ssh2_sftp_lstat ( resource $sftp , string $path ) : array

Stats a symbolic link on the remote filesystem without following the link.

This function is similar to using the lstat() function with the ssh2.sftp:// wrapper in PHP 5 and returns the same values.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

path

Path to the remote symbolic link.

Valores devueltos

See the documentation for stat() for details on the values which may be returned.

Ejemplos

Ejemplo #1 Stating a symbolic link via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_lstat($sftp, '/path/to/symlink');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

Ver también

  • ssh2_sftp_stat() - Stat a file on a remote filesystem
  • lstat() - Da información acerca de un archivo o enlace simbólico
  • stat() - Da información acerca de un fichero


Create a directory

  • « ssh2_sftp_lstat
  • ssh2_sftp_readlink »
  • PHP Manual
  • Funciones de SSH2
  • Create a directory

ssh2_sftp_mkdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_mkdir — Create a directory

Descripción

ssh2_sftp_mkdir ( resource $sftp , string $dirname , int $mode = 0777 , bool $recursive = false ) : bool

Creates a directory on the remote file server with permissions set to mode.

This function is similar to using mkdir() with the ssh2.sftp:// wrapper.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

Path of the new directory.

mode

Permissions on the new directory. The actual mode is affected by the current umask.

recursive

If recursive is true any parent directories required for dirname will be automatically created as well.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Creating a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_mkdir($sftp, '/home/username/newdir');
/* Or:  mkdir("ssh2.sftp://$sftp/home/username/newdir"); */
?>

Ver también

  • mkdir() - Crea un directorio
  • ssh2_sftp_rmdir() - Remove a directory


Return the target of a symbolic link

  • « ssh2_sftp_mkdir
  • ssh2_sftp_realpath »
  • PHP Manual
  • Funciones de SSH2
  • Return the target of a symbolic link

ssh2_sftp_readlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_readlink — Return the target of a symbolic link

Descripción

ssh2_sftp_readlink ( resource $sftp , string $link ) : string

Returns the target of a symbolic link.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

link

Path of the symbolic link.

Valores devueltos

Returns the target of the symbolic link.

Ejemplos

Ejemplo #1 Reading a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$target = ssh2_sftp_readlink($sftp, '/tmp/mysql.sock');
/* $target is now (e.g.): '/var/run/mysql.sock' */
?>

Ver también

  • readlink() - Devuelve el objetivo de un enlace simbólico
  • ssh2_sftp_symlink() - Create a symlink


Resolve the realpath of a provided path string

  • « ssh2_sftp_readlink
  • ssh2_sftp_rename »
  • PHP Manual
  • Funciones de SSH2
  • Resolve the realpath of a provided path string

ssh2_sftp_realpath

(PECL ssh2 >= 0.9.0)

ssh2_sftp_realpath — Resolve the realpath of a provided path string

Descripción

ssh2_sftp_realpath ( resource $sftp , string $filename ) : string

Translates filename into the effective real path on the remote filesystem.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Valores devueltos

Returns the real path as a string.

Ejemplos

Ejemplo #1 Resolving a pathname

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$realpath = ssh2_sftp_realpath($sftp, '/home/username/../../../..//./usr/../etc/passwd');
/* $realpath is now: '/etc/passwd' */
?>

Ver también

  • realpath() - Devuelve el nombre de la ruta absoluta canonizado
  • ssh2_sftp_symlink() - Create a symlink
  • ssh2_sftp_readlink() - Return the target of a symbolic link


Rename a remote file

  • « ssh2_sftp_realpath
  • ssh2_sftp_rmdir »
  • PHP Manual
  • Funciones de SSH2
  • Rename a remote file

ssh2_sftp_rename

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rename — Rename a remote file

Descripción

ssh2_sftp_rename ( resource $sftp , string $from , string $to ) : bool

Renames a file on the remote filesystem.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

from

The current file that is being renamed.

to

The new file name that replaces from.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Renaming a file via sftp

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rename($sftp, '/home/username/oldname', '/home/username/newname');
?>

Ver también

  • rename() - Renombra un fichero o directorio


Remove a directory

  • « ssh2_sftp_rename
  • ssh2_sftp_stat »
  • PHP Manual
  • Funciones de SSH2
  • Remove a directory

ssh2_sftp_rmdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rmdir — Remove a directory

Descripción

ssh2_sftp_rmdir ( resource $sftp , string $dirname ) : bool

Removes a directory from the remote file server.

This function is similar to using rmdir() with the ssh2.sftp:// wrapper.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Removing a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rmdir($sftp, '/home/username/deltodel');
/* Or:  rmdir("ssh2.sftp://$sftp/home/username/dirtodel"); */
?>

Ver también

  • rmdir() - Elimina un directorio
  • ssh2_sftp_mkdir() - Create a directory


Stat a file on a remote filesystem

  • « ssh2_sftp_rmdir
  • ssh2_sftp_symlink »
  • PHP Manual
  • Funciones de SSH2
  • Stat a file on a remote filesystem

ssh2_sftp_stat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_stat — Stat a file on a remote filesystem

Descripción

ssh2_sftp_stat ( resource $sftp , string $path ) : array

Stats a file on the remote filesystem following any symbolic links.

This function is similar to using the stat() function with the ssh2.sftp:// wrapper in PHP 5 and returns the same values.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

path

Valores devueltos

See the documentation for stat() for details on the values which may be returned.

Ejemplos

Ejemplo #1 Stating a file via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_stat($sftp, '/path/to/file');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

Ver también

  • ssh2_sftp_lstat() - Stat a symbolic link
  • lstat() - Da información acerca de un archivo o enlace simbólico
  • stat() - Da información acerca de un fichero


Create a symlink

  • « ssh2_sftp_stat
  • ssh2_sftp_unlink »
  • PHP Manual
  • Funciones de SSH2
  • Create a symlink

ssh2_sftp_symlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_symlink — Create a symlink

Descripción

ssh2_sftp_symlink ( resource $sftp , string $target , string $link ) : bool

Creates a symbolic link named link on the remote filesystem pointing to target.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

target

Target of the symbolic link.

link

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Creating a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_symlink($sftp, '/var/run/mysql.sock', '/tmp/mysql.sock');
?>

Ver también

  • ssh2_sftp_readlink() - Return the target of a symbolic link
  • symlink() - Crea un enlace simbólico


Delete a file

  • « ssh2_sftp_symlink
  • ssh2_sftp »
  • PHP Manual
  • Funciones de SSH2
  • Delete a file

ssh2_sftp_unlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_unlink — Delete a file

Descripción

ssh2_sftp_unlink ( resource $sftp , string $filename ) : bool

Deletes a file on the remote filesystem.

Parámetros

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Deleting a file

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_unlink($sftp, '/home/username/stale_file');
?>

Ver también

  • unlink() - Borra un fichero


Inicializar el subsistema SFTP

  • « ssh2_sftp_unlink
  • ssh2_shell »
  • PHP Manual
  • Funciones de SSH2
  • Inicializar el subsistema SFTP

ssh2_sftp

(PECL ssh2 >= 0.9.0)

ssh2_sftp — Inicializar el subsistema SFTP

Descripción

ssh2_sftp ( resource $session ) : resource

Solicita el subsistema SFTP desde un servidor SSH2 ya conectado.

Parámetros

session

Un identificador de enlace de conexión SSH obtenido a partir de una llamada a ssh2_connect().

Valores devueltos

Este método devuelve un recurso SFTP de SSH2 para emplearlo con todos los demás métodos ssh2_sftp_*() y la envoltura ssh2.sftp:// de fopen.

Ejemplos

Ejemplo #1 Abrir un fichero a través de SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);

$stream = fopen("ssh2.sftp://$sftp/path/to/file", 'r');
?>

Ver también

  • ssh2_scp_recv() - Solicita un fichero mediante SCP
  • ssh2_scp_send() - Envía un fichero mediante SCP


Request an interactive shell

  • « ssh2_sftp
  • ssh2_tunnel »
  • PHP Manual
  • Funciones de SSH2
  • Request an interactive shell

ssh2_shell

(PECL ssh2 >= 0.9.0)

ssh2_shell — Request an interactive shell

Descripción

ssh2_shell ( resource $session , string $term_type = "vanilla" , array|null $env = null , int $width = 80 , int $height = 25 , int $width_height_type = SSH2_TERM_UNIT_CHARS ) : resource|false

Open a shell at the remote end and allocate a stream for it.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

term_type

term_type should correspond to one of the entries in the target system's /etc/termcap file.

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

Valores devueltos

Returns a stream recurso on success, o false en caso de error.

Ejemplos

Ejemplo #1 Requesting an interactive shell

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_shell($connection, 'vt102', null, 80, 24, SSH2_TERM_UNIT_CHARS);
?>

Ver también

  • ssh2_exec() - Execute a command on a remote server
  • ssh2_tunnel() - Open a tunnel through a remote server
  • ssh2_fetch_stream() - Fetch an extended data stream


Open a tunnel through a remote server

  • « ssh2_shell
  • Stomp »
  • PHP Manual
  • Funciones de SSH2
  • Open a tunnel through a remote server

ssh2_tunnel

(PECL ssh2 >= 0.9.0)

ssh2_tunnel — Open a tunnel through a remote server

Descripción

ssh2_tunnel ( resource $session , string $host , int $port ) : resource

Open a socket stream to an arbitrary host/port by way of the currently connected SSH server.

Parámetros

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

host

port

Valores devueltos

Ejemplos

Ejemplo #1 Opening a tunnel to an arbitrary host

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_pubkey_file($connection, 'username', 'id_dsa.pub', 'id_dsa');

$tunnel = ssh2_tunnel($connection, '10.0.0.101', 12345);
?>

Ver también

  • ssh2_connect() - Conecta a un servidor SSH
  • fsockopen() - Abre una conexión vía sockets a Internet o a un dominio Unix


Cliente Stomp

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Ejemplos
  • Funciones Stomp
    • stomp_connect_error — Devuelve una cadena descripción de el último error al conectar
    • stomp_version — Obtiene la versión actual de la extensión stomp
  • Stomp — La clase Stomp
    • Stomp::abort — Deshacer una transacción en curso
    • Stomp::ack — Confirmar la recepción y el consumo de un mensaje
    • Stomp::begin — Iniciar una transacción
    • Stomp::commit — Validar una transacción en curso
    • Stomp::__construct — Abre una conexión
    • Stomp::__destruct — Cierra una conexión stomp
    • Stomp::error — Obtiene el último error stomp
    • Stomp::getReadTimeout — Obtener la lectura del tiempo de espera de la solicitud
    • Stomp::getSessionId — Obtiene el identificador de sesión actual stomp
    • Stomp::hasFrame — Indica si existe o no una trama lista para leer
    • Stomp::readFrame — Leer la siguiente trama
    • Stomp::send — Envía un mensaje
    • Stomp::setReadTimeout — Establecer el tiempo de espera de lectura
    • Stomp::subscribe — Registrarse para escuchar a un destino dado
    • Stomp::unsubscribe — Dar de baja una suscripción existente
  • StompFrame — La clase StompFrame
    • StompFrame::__construct — Constructor
  • StompException — La clase StompException
    • StompException::getDetails — Obtener detalles de la excepción


Introducción

Esta extensión permite a aplicaciones php comunicarse con cualquier Message Brokers compatible con el protocolo STOMP, a través de sencillas interfaces procedurales orientadas a objetos. » Stomp official site


Requerimientos

PECL/stomp requires PHP 5.2.2 or newer.

El paquete » OpenSSL >= 0.9.6 y la extensión openssl pueden ser también requeridos para utilizar stomp a través de SSL.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/stomp


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración Stomp
Nombre | Por defecto | Cambiable | Historial de cambios
stomp.default_broker | tcp://localhost:61613 | PHP_INI_ALL |
stomp.default_connection_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_connection_timeout_usec | 0 | PHP_INI_ALL |
stomp.default_read_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_read_timeout_usec | 0 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

stomp.default_broker string

La URI broker por defecto a utilizar cuando conectemos a el message broker si otra URI no es especificada.

stomp.default_connection_timeout_sec integer

Los segundos parte del tiempo de espera de la solicitud de conexión por defecto.

stomp.default_connection_timeout_usec integer

Los microsegundos parte del tiempo de espera de la solicitud de conexión por defecto.

stomp.default_read_timeout_sec integer

Los segundos parte del tiempo de espera de lectura por defecto.

stomp.default_read_timeout_usec integer

Los microsegundos parte del tiempo de espera de lectura por defecto.


Tipos de recursos

Sólo hay un tipo de recurso utilizado en la extensión stomp - este es el identificador de enlace para una conexión stomp.


Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* Enviar un mensaje a la cola 'foo' */
$stomp->send($queue, $msg);

/* suscribirse a mensajes de la cola 'foo' */
$stomp->subscribe($queue);

/* leer una trama (frame) */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    var_dump($frame);

    /* reconocer que la trama (frame) fue recibida */
    $stomp->ack($frame);
}

/* cerrar conexión */
unset($stomp);

?>

El resultado del ejemplo sería algo similar a:

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Ejemplo #2 Estilo por procedimientos

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* iniciar una transacción */
stomp_begin($link, 't1');

/* Enviar un mensaje a la cola 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* confirmar una transacción */
stomp_commit($link, 't1');

/* suscribirse a mensajes de la cola 'foo' */
stomp_subscribe($link, $queue);

/* leer una trama (frame) */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    var_dump($frame);

    /* reconocer que la trama fue recibida */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* cerrar conexión */
stomp_close($link);

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}


Funciones Stomp

Tabla de contenidos

  • stomp_connect_error — Devuelve una cadena descripción de el último error al conectar
  • stomp_version — Obtiene la versión actual de la extensión stomp


Devuelve una cadena descripción de el último error al conectar

  • « Funciones Stomp
  • stomp_version »
  • PHP Manual
  • Funciones Stomp
  • Devuelve una cadena descripción de el último error al conectar

stomp_connect_error

(PECL stomp >= 0.3.0)

stomp_connect_error — Devuelve una cadena descripción de el último error al conectar

Descripción

stomp_connect_error ( ) : string

Devuelve una cadena descripción de el último error al conectar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una cadena que describe el error, o null si no hay errores.

Ejemplos

Ejemplo #1 Ejemplo de stomp_connect_error()

<?php
$link = stomp_connect('http://localhost:61613');

if(!$link) {
    die('Connection failed: ' . stomp_connect_error());
}
?>

El resultado del ejemplo sería algo similar a:

Connection failed: Invalid Broker URI scheme


Obtiene la versión actual de la extensión stomp

  • « stomp_connect_error
  • Stomp »
  • PHP Manual
  • Funciones Stomp
  • Obtiene la versión actual de la extensión stomp

stomp_version

(PECL stomp >= 0.1.0)

stomp_version — Obtiene la versión actual de la extensión stomp

Descripción

stomp_version ( ) : string

Devuelve una cadena que contiene la versión actual de la extensión stomp.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Esta devuelve la versión actual de la extensión stomp

Ejemplos

Ejemplo #1 Ejemplo de stomp_version()

<?php

var_dump(stomp_version());

?>

El resultado del ejemplo sería algo similar a:

string(5) "0.2.0"


La clase Stomp

(PECL stomp >= 0.1.0)

Introducción

Representa una conexión entre PHP y un Message Brokers que cumpla con las normas del protocolo Stomp.

Sinopsis de la Clase

Stomp {
/* Métodos */
public abort ( string $transaction_id , array $headers = ? ) : bool
public ack ( mixed $msg , array $headers = ? ) : bool
public begin ( string $transaction_id , array $headers = ? ) : bool
public commit ( string $transaction_id , array $headers = ? ) : bool
public __construct ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? )
public __destruct ( ) : bool
public error ( ) : string
public getReadTimeout ( ) : array
public getSessionId ( ) : string
public hasFrame ( ) : bool
public readFrame ( string $class_name = "stompFrame" ) : stompframe
public send ( string $destination , mixed $msg , array $headers = ? ) : bool
public setReadTimeout ( int $seconds , int $microseconds = ? ) : void
public subscribe ( string $destination , array $headers = ? ) : bool
public unsubscribe ( string $destination , array $headers = ? ) : bool
}

Tabla de contenidos

  • Stomp::abort — Deshacer una transacción en curso
  • Stomp::ack — Confirmar la recepción y el consumo de un mensaje
  • Stomp::begin — Iniciar una transacción
  • Stomp::commit — Validar una transacción en curso
  • Stomp::__construct — Abre una conexión
  • Stomp::__destruct — Cierra una conexión stomp
  • Stomp::error — Obtiene el último error stomp
  • Stomp::getReadTimeout — Obtener la lectura del tiempo de espera de la solicitud
  • Stomp::getSessionId — Obtiene el identificador de sesión actual stomp
  • Stomp::hasFrame — Indica si existe o no una trama lista para leer
  • Stomp::readFrame — Leer la siguiente trama
  • Stomp::send — Envía un mensaje
  • Stomp::setReadTimeout — Establecer el tiempo de espera de lectura
  • Stomp::subscribe — Registrarse para escuchar a un destino dado
  • Stomp::unsubscribe — Dar de baja una suscripción existente


Deshacer una transacción en curso

  • « Stomp
  • Stomp::ack »
  • PHP Manual
  • Stomp
  • Deshacer una transacción en curso

Stomp::abort

stomp_abort

(PECL stomp >= 0.1.0)

Stomp::abort -- stomp_abort — Deshacer una transacción en curso

Descripción

Estilo orientado a objetos (método):

public Stomp::abort ( string $transaction_id , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_abort ( resource $link , string $transaction_id , array $headers = ? ) : bool

Deshacer una transacción en curso.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

transaction_id

La transacción a abortar.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* iniciar una transacción */
$stomp->begin('t1');

/* enviar un mensaje a la cola */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* deshacer/abortar */
$stomp->abort('t1');

/* cerrar la conexión */
unset($stomp);
?>

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('tcp://localhost:61613');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* iniciar una transacción */
stomp_begin($link, 't1');

/* enviar un mensaje a la cola 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* deshacer/abortar */
stomp_abort($link, 't1');

/* cerrar la conexión */
stomp_close($link);

?>


Confirmar la recepción y el consumo de un mensaje

  • « Stomp::abort
  • Stomp::begin »
  • PHP Manual
  • Stomp
  • Confirmar la recepción y el consumo de un mensaje

Stomp::ack

stomp_ack

(PECL stomp >= 0.1.0)

Stomp::ack -- stomp_ack — Confirmar la recepción y el consumo de un mensaje

Descripción

Estilo orientado a objetos (método):

public Stomp::ack ( mixed $msg , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_ack ( resource $link , mixed $msg , array $headers = ? ) : bool

Confirmar el consumo de un mensaje desde una suscripción enviando el cliente una trama ACK de confirmación.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

msg

El mensaje/Id del mensaje a ser confirmado.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Un header de transacción puede ser especificado, indicando que el mensaje de Acknowledgment debería formar parte del nombre de la transacción.

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* enviar un mensaje a la cola 'foo' */
$stomp->send($queue, $msg);

/* suscribirse a mensajes de la cola 'foo' */
$stomp->subscribe($queue);

/* leer una trama */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    /* confirmar que la trama fue recibida */
    $stomp->ack($frame);
}

/* eliminar la suscripción */
$stomp->unsubscribe($queue);

/* cerrar la conexión */
unset($stomp);

?>

Ejemplo #2 Estilo por procedimientos

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* iniciar una transacción */
stomp_begin($link, 't1');

/* enviar un mensaje a la cola 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* validar una transacción */
stomp_commit($link, 't1');

/* suscribirse a mensajes de la cola 'foo' */
stomp_subscribe($link, $queue);

/* leer una trama */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    /* confirmar que la trama fue recibida */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* eliminar la suscripción */
stomp_unsubscribe($link, $queue);

/* cerrar la conexión */
stomp_close($link);

?>


Iniciar una transacción

  • « Stomp::ack
  • Stomp::commit »
  • PHP Manual
  • Stomp
  • Iniciar una transacción

Stomp::begin

stomp_begin

(PECL stomp >= 0.1.0)

Stomp::begin -- stomp_begin — Iniciar una transacción

Descripción

Estilo orientado a objetos (método):

public Stomp::begin ( string $transaction_id , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_begin ( resource $link , string $transaction_id , array $headers = ? ) : bool

Inicia una transacción.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

transaction_id

La identificación de la transacción.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Vea stomp_commit() o stomp_abort().


Validar una transacción en curso

  • « Stomp::begin
  • Stomp::__construct »
  • PHP Manual
  • Stomp
  • Validar una transacción en curso

Stomp::commit

stomp_commit

(PECL stomp >= 0.1.0)

Stomp::commit -- stomp_commit — Validar una transacción en curso

Descripción

Estilo orientado a objetos (método):

public Stomp::commit ( string $transaction_id , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_commit ( resource $link , string $transaction_id , array $headers = ? ) : bool

Valida una transacción en curso.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

transaction_id

La identificación de la transacción.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* iniciar una transacción */
$stomp->begin('t1');

/* enviar un mensaje a la cola */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* validar */
$stomp->commit('t1');

/* cerrar la conexión */
unset($stomp);

?>

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('tcp://localhost:61613');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* iniciar una transacción */
stomp_begin($link, 't1');

/* enviar un mensaje a la cola 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* validar */
stomp_commit($link, 't1');

/* cerrar la conexión */
stomp_close($link);

?>


Abre una conexión

  • « Stomp::commit
  • Stomp::__destruct »
  • PHP Manual
  • Stomp
  • Abre una conexión

Stomp::__construct

stomp_connect

(PECL stomp >= 0.1.0)

Stomp::__construct -- stomp_connect — Abre una conexión

Descripción

Estilo orientado a objetos (constructor):

public Stomp::__construct ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? )

Estilo por procedimientos:

stomp_connect ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? ) : resource

Abre una conexión con un Message Broker compatible con el protocolo STOMP.

Parámetros

broker

La URI broker

username

El nombre de usuario.

password

La contraseña.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Nota:

Un header de transacción puede ser especificado, indicando que el mensaje de Acknowledgment debería formar parte del nombre de la transacción.

Historial de cambios

Versión | Descripción
1.0.1 | El paramétro headers fue añadido

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* cerrar la conexión */
unset($stomp);

?>

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* cerrar la conexión */
stomp_close($link);

?>


Cierra una conexión stomp

  • « Stomp::__construct
  • Stomp::error »
  • PHP Manual
  • Stomp
  • Cierra una conexión stomp

Stomp::__destruct

stomp_close

(PECL stomp >= 0.1.0)

Stomp::__destruct -- stomp_close — Cierra una conexión stomp

Descripción

Estilo orientado a objetos (destructor):

public Stomp::__destruct ( ) : bool

Estilo por procedimientos:

stomp_close ( resource $link ) : bool

Cierra una conexión previamente abierta.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Vea stomp_connect().


Obtiene el último error stomp

  • « Stomp::__destruct
  • Stomp::getReadTimeout »
  • PHP Manual
  • Stomp
  • Obtiene el último error stomp

Stomp::error

stomp_error

(PECL stomp >= 0.1.0)

Stomp::error -- stomp_error — Obtiene el último error stomp

Descripción

Estilo orientado a objetos (método):

public Stomp::error ( ) : string

Estilo por procedimientos:

stomp_error ( resource $link ) : string

Obtiene el último error stomp.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

Valores devueltos

Devuelve una cadena de error o false si no hay errores.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->error());

if (!$stomp->abort('unknown-transaction', array('receipt' => 'foo'))) {
    var_dump($stomp->error());
}

/* cerrar la conexión */
unset($stomp);

?>

El resultado del ejemplo sería algo similar a:

bool(false)
string(43) "Invalid transaction id: unknown-transaction"

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_error($link));

if (!stomp_abort($link, 'unknown-transaction', array('receipt' => 'foo'))) {
    var_dump(stomp_error($link));
}

/* cerrar la conexión */
stomp_close($link);

?>

El resultado del ejemplo sería algo similar a:

bool(false)
string(43) "Invalid transaction id: unknown-transaction"


Obtener la lectura del tiempo de espera de la solicitud

  • « Stomp::error
  • Stomp::getSessionId »
  • PHP Manual
  • Stomp
  • Obtener la lectura del tiempo de espera de la solicitud

Stomp::getReadTimeout

stomp_get_read_timeout

(PECL stomp >= 0.3.0)

Stomp::getReadTimeout -- stomp_get_read_timeout — Obtener la lectura del tiempo de espera de la solicitud

Descripción

Estilo orientado a objetos (método):

public Stomp::getReadTimeout ( ) : array

Estilo por procedimientos:

stomp_get_read_timeout ( resource $link ) : array

Obtiene la lectura del tiempo de espera de la solicitud

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

Valores devueltos

Devuelve un array con dos elementos: sec y usec.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getReadTimeout());

/* cerrar la conexión */
unset($stomp);

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_read_timeout($link));

/* cerrar la conexión */
stomp_close($link);

?>

El resultado del ejemplo sería algo similar a:

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}


Obtiene el identificador de sesión actual stomp

  • « Stomp::getReadTimeout
  • Stomp::hasFrame »
  • PHP Manual
  • Stomp
  • Obtiene el identificador de sesión actual stomp

Stomp::getSessionId

stomp_get_session_id

(PECL stomp >= 0.1.0)

Stomp::getSessionId -- stomp_get_session_id — Obtiene el identificador de sesión actual stomp

Descripción

Estilo orientado a objetos (método):

public Stomp::getSessionId ( ) : string

Estilo por procedimientos:

stomp_get_session_id ( resource $link ) : string

Obtiene el identificador de sesión actual stomp.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

Valores devueltos

string session id on success o false en caso de error.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getSessionId());

/* cerrar la conexión */
unset($stomp);

?>

El resultado del ejemplo sería algo similar a:

string(35) "ID:php.net-52873-1257291895530-4:14"

Ejemplo #2 Estilo procedural

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_session_id($link));

/* cerrar la conexión */
stomp_close($link);

?>

El resultado del ejemplo sería algo similar a:

string(35) "ID:php.net-52873-1257291895530-4:14"


Indica si existe o no una trama lista para leer

  • « Stomp::getSessionId
  • Stomp::readFrame »
  • PHP Manual
  • Stomp
  • Indica si existe o no una trama lista para leer

Stomp::hasFrame

stomp_has_frame

(PECL stomp >= 0.1.0)

Stomp::hasFrame -- stomp_has_frame — Indica si existe o no una trama lista para leer

Descripción

Estilo orientado a objetos (método):

public Stomp::hasFrame ( ) : bool

Estilo por procedimientos:

stomp_has_frame ( resource $link ) : bool

Indica si existe o no una trama lista para leer.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

Valores devueltos

Devuelve true si hay una trama lista para leer, o false en caso contrario.


Leer la siguiente trama

  • « Stomp::hasFrame
  • Stomp::send »
  • PHP Manual
  • Stomp
  • Leer la siguiente trama

Stomp::readFrame

stomp_read_frame

(PECL stomp >= 0.1.0)

Stomp::readFrame -- stomp_read_frame — Leer la siguiente trama

Descripción

Estilo orientado a objetos (método):

public Stomp::readFrame ( string $class_name = "stompFrame" ) : stompframe

Estilo por procedimientos:

stomp_read_frame ( resource $link ) : array

Lee la siguiente trama. Es posible crear una instancia de un objeto de una clase específica, y pasar parámetros al constructor de esa clase.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

class_name

El nombre de la clase a instanciar. Si no se especifica, un objeto stompFrame es devuelto.

Valores devueltos

Nota:

Un header de transacción puede ser especificado, indicando que el mensaje de Acknowledgment debería formar parte del nombre de la transacción.

Historial de cambios

Versión | Descripción
Stomp 0.4.0 | El parámentro class_name fue añadido.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* suscribirse a mensajes de la cola 'foo' */
$stomp->subscribe('/queue/foo');

/* leer una trama */
var_dump($stomp->readFrame());

/* cerrar la conexión */
unset($stomp);

?>

El resultado del ejemplo sería algo similar a:

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* suscribirse a mensajes de la cola 'foo' */
stomp_subscribe($link, '/queue/foo');

/* leer una trama */
$frame = stomp_read_frame($link);

/* cerrar la conexión */
stomp_close($link);

?>

El resultado del ejemplo sería algo similar a:

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}


Envía un mensaje

  • « Stomp::readFrame
  • Stomp::setReadTimeout »
  • PHP Manual
  • Stomp
  • Envía un mensaje

Stomp::send

stomp_send

(PECL stomp >= 0.1.0)

Stomp::send -- stomp_send — Envía un mensaje

Descripción

Estilo orientado a objetos (método):

public Stomp::send ( string $destination , mixed $msg , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_send ( resource $link , string $destination , mixed $msg , array $headers = ? ) : bool

Envía un mensaje a el Message Broker.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

destination

A dónde eenviar el mensaje

msg

Mensaje a enviar.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Un header de transacción puede ser especificado, indicando que el mensaje de Acknowledgment debería formar parte del nombre de la transacción.

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Vea stomp_ack().


Establecer el tiempo de espera de lectura

  • « Stomp::send
  • Stomp::subscribe »
  • PHP Manual
  • Stomp
  • Establecer el tiempo de espera de lectura

Stomp::setReadTimeout

stomp_set_read_timeout

(PECL stomp >= 0.3.0)

Stomp::setReadTimeout -- stomp_set_read_timeout — Establecer el tiempo de espera de lectura

Descripción

Estilo orientado a objetos (método):

public Stomp::setReadTimeout ( int $seconds , int $microseconds = ? ) : void

Estilo por procedimientos:

stomp_set_read_timeout ( resource $link , int $seconds , int $microseconds = ? ) : void

Establece el tiempo de espera de lectura.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

seconds

Los segundos parte de el tiempo de espera a ser establecido.

microseconds

Los microsegundos parte de el tiempo de espera a ser establecido.

Ejemplos

Ejemplo #1 Estilo orientado a objetos

<?php

/* conexión */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

$stomp->setReadTimeout(10);

/* cerrar la conexión */
unset($stomp);

?>

Ejemplo #2 Estilo por procedimientos

<?php

/* conexión */
$link = stomp_connect('ssl://localhost:61612');

/* comprobar la conexión */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

stomp_set_read_timeout($link, 10);

/* cerrar la conexión */
stomp_close($link);

?>


Registrarse para escuchar a un destino dado

  • « Stomp::setReadTimeout
  • Stomp::unsubscribe »
  • PHP Manual
  • Stomp
  • Registrarse para escuchar a un destino dado

Stomp::subscribe

stomp_subscribe

(PECL stomp >= 0.1.0)

Stomp::subscribe -- stomp_subscribe — Registrarse para escuchar a un destino dado

Descripción

Estilo orientado a objetos (método):

public Stomp::subscribe ( string $destination , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_subscribe ( resource $link , string $destination , array $headers = ? ) : bool

Registrarse para escuchar a un destino dado.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

destination

Destino al que suscribirse.

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Vea stomp_ack().


Dar de baja una suscripción existente

  • « Stomp::subscribe
  • StompFrame »
  • PHP Manual
  • Stomp
  • Dar de baja una suscripción existente

Stomp::unsubscribe

stomp_unsubscribe

(PECL stomp >= 0.1.0)

Stomp::unsubscribe -- stomp_unsubscribe — Dar de baja una suscripción existente

Descripción

Estilo orientado a objetos (método):

public Stomp::unsubscribe ( string $destination , array $headers = ? ) : bool

Estilo por procedimientos:

stomp_unsubscribe ( resource $link , string $destination , array $headers = ? ) : bool

Dar de baja una suscripción existente.

Parámetros

link

Sólo estilo por procediminetos: El identificador de enlace Stomp devuelto por stomp_connect().

destination

Suscripción a eliminar

headers

Array asociativo conteniendo los headers adicionales (ejemplo: receipt).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Sugerencia

Stomp es inherentemente asíncrono. Comunicación sincrónica puede ser implementada agregando un header receipt. Esto ocasionará métodos para no devolver nada hasta que el servidor haya recibido un Acknowledgment del mensaje o hasta que el tiempo de espera para lectura se agote.

Ejemplos

Vea stomp_ack().


La clase StompFrame

(PECL stomp >= 0.1.0)

Introducción

Representa un mensaje el cual fue enviado o recibido desde un Message Brokers que cumple con las normas del protocolo Stomp.

Sinopsis de la Clase

StompFrame {
/* Propiedades */
public $command ;
public $headers ;
public $body ;
/* Métodos */
__construct ( string $command = ? , array $headers = ? , string $body = ? )
}

Propiedades

command

Frame command.

headers

Frame headers (array).

body

Frame body.

Tabla de contenidos

  • StompFrame::__construct — Constructor


Constructor

  • « StompFrame
  • StompException »
  • PHP Manual
  • StompFrame
  • Constructor

StompFrame::__construct

(PECL stomp >= 0.1.0)

StompFrame::__construct — Constructor

Descripción

StompFrame::__construct ( string $command = ? , array $headers = ? , string $body = ? )

Constructor.

Parámetros

command

Comando del frame

headers

encabezados del frame (array).

body

cuerpo del frame


La clase StompException

(PECL stomp >= 0.1.0)

Introducción

Representa un error proveniente desde la extensión stomp. Vea Exceptions para obtener más información acerca de las excepciones en PHP.

Sinopsis de la Clase

StompException extends Exception {
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
/* Métodos */
public getDetails ( ) : string
}

Tabla de contenidos

  • StompException::getDetails — Obtener detalles de la excepción


Obtener detalles de la excepción

  • « StompException
  • SVM »
  • PHP Manual
  • StompException
  • Obtener detalles de la excepción

StompException::getDetails

(PECL stomp >= 0.1.0)

StompException::getDetails — Obtener detalles de la excepción

Descripción

public StompException::getDetails ( ) : string

Obtener detalles de la excepción.

Valores devueltos

string que contiene los detalles del error.


Soporte Vector Machine

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Ejemplos
  • SVM — La clase SVM
    • SVM::__construct — Construir un nuevo objeto SVM
    • SVM::crossvalidate — Test training params on subsets of the training data
    • SVM::getOptions — Return the current training parameters
    • SVM::setOptions — Set training parameters
    • SVM::train — Create a SVMModel based on training data
  • SVMModel — La clase SVMModel
    • SVMModel::checkProbabilityModel — Returns true if the model has probability information
    • SVMModel::__construct — Construct a new SVMModel
    • SVMModel::getLabels — Get the labels the model was trained on
    • SVMModel::getNrClass — Returns the number of classes the model was trained with
    • SVMModel::getSvmType — Get the SVM type the model was trained with
    • SVMModel::getSvrProbability — Get the sigma value for regression types
    • SVMModel::load — Cargar un modelo SVM guardado
    • SVMModel::predict_probability — Return class probabilities for previous unseen data
    • SVMModel::predict — Predict a value for previously unseen data
    • SVMModel::save — Guardar un modelo en un archivo


Introducción

LIBSVM es un solucionador de eficiencia para la clasificación de SVM y los problemas de retroceso. La extensión de este svm se envuelve en una interfaz PHP para facilitar el uso de scripts PHP.


Requerimientos

LIBSVM es requerido, y está disponible a través de algunos gestores de paquetes - libsvm-devel para el sistema basado en RPM o libsvm-dev para los basados en Debian. Como alternativa, está disponible directamente desde el sitio web. Si está instalando desde el » Website Oficial algunos pasos son necesarios ya que el paquete no se instala automáticamente. Por ejemplo, suponiendo que la última versión es la 3.1:

wget http://www.csie.ntu.edu.tw/~cjlin/cgi-bin/libsvm.cgi?+http://www.csie.ntu.edu.tw/~cjlin/libsvm+tar.gz
tar xvzf libsvm-3.1.tar.gz
cd libsvm-3.1
make lib
cp libsvm.so.1 /usr/lib
ln -s libsvm.so.1 libsvm.so
ldconfig
ldconfig --print | grep libsvm

Este último paso debe mostrar LIBSVM está instalado.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/svm


Ejemplos

The basic process is to define parameters, supply training data to generate a model on, then make predictions based on the model. There are a default set of parameters that should get some results with most any input, so we'll start by looking at the data.

Data is supplied in either a file, a stream, or as an array. If supplied in a file or a stream, it must contain one line per training example, which must be formatted as an integer class (usually 1 and -1) followed by a series of feature/value pairs, in increasing feature order. The features are integers, the values floats, usually scaled 0-1. For example:

-1 1:0.43 3:0.12 9284:0.2

In a document classification problem, say a spam checker, each line would represent a document. There would be two classes, -1 for spam, 1 for ham. Each feature would represent some word, and the value would represent that importance of that word to the document (perhaps the frequency count, with the total scaled to unit length). Features that were 0 (e.g. the word did not appear in the document at all) would simply not be included.

In array mode, the data must be passed as an array of arrays. Each sub-array must have the class as the first element, then key => value sets for the feature values pairs.

This data is passed to the SVM class's train function, which will return an SVM model is successful.

Once a model has been generated, it can be used to make predictions about previously unseen data. This can be passed as an array to the model's predict function, in the same format as before, but without the label. The response will be the class.

Models can be saved and restored as required, using the save and load functions, which both take a file location.

Ejemplo #1 Train from array

<?php
$data = array(
    array(-1, 1 => 0.43, 3 => 0.12, 9284 => 0.2),
    array(1, 1 => 0.22, 5 => 0.01, 94 => 0.11),
);

$svm = new SVM();
$model = $svm->train($data);

$data = array(1 => 0.43, 3 => 0.12, 9284 => 0.2);
$result = $model->predict($data);
var_dump($result);
$model->save('model.svm');
?>

El resultado del ejemplo sería algo similar a:

int(-1)

Ejemplo #2 Train from a file

<?php
$svm = new SVM();
$model = $svm->train("traindata.txt");
?>


La clase SVM

(PECL svm >= 0.1.0)

Introducción

Sinopsis de la Clase

SVM {
/* Constants */
const integer C_SVC = 0 ;
const integer NU_SVC = 1 ;
const integer ONE_CLASS = 2 ;
const integer EPSILON_SVR = 3 ;
const integer NU_SVR = 4 ;
const integer KERNEL_LINEAR = 0 ;
const integer KERNEL_POLY = 1 ;
const integer KERNEL_RBF = 2 ;
const integer KERNEL_SIGMOID = 3 ;
const integer KERNEL_PRECOMPUTED = 4 ;
const integer OPT_TYPE = 101 ;
const integer OPT_KERNEL_TYPE = 102 ;
const integer OPT_DEGREE = 103 ;
const integer OPT_SHRINKING = 104 ;
const integer OPT_PROPABILITY = 105 ;
const integer OPT_GAMMA = 201 ;
const integer OPT_NU = 202 ;
const integer OPT_EPS = 203 ;
const integer OPT_P = 204 ;
const integer OPT_COEF_ZERO = 205 ;
const integer OPT_C = 206 ;
const integer OPT_CACHE_SIZE = 207 ;
/* Methods */
public __construct ( )
public svm::crossvalidate ( array $problem , int $number_of_folds ) : float
public getOptions ( ) : array
public setOptions ( array $params ) : bool
public svm::train ( array $problem , array $weights = ? ) : SVMModel
}

Constantes predefinidas

SVM Constants

SVM::C_SVC

El tipo básico C_SVC SVM. Es el tipo por defecto. Un buen punto de partida.

SVM::NU_SVC

El tipo NU_SVC usa una diferente y más flexible ponderación de errores.

SVM::ONE_CLASS

Una clase de tipo SVM. Guía simplemente a una clase, usando valores extremos como ejemplos negativos.

SVM::EPSILON_SVR

Un tipo SVM para regresión (prediciento un valor más que símplemente una clase)

SVM::NU_SVR

Un tipo de regresión SVM al estilo NU.

SVM::KERNEL_LINEAR

Un núcleo muy simple, puede funcionar bien con problemas de clasificación de documentos grandes.

SVM::KERNEL_POLY

Un núcleo polinómico

SVM::KERNEL_RBF

El común nucleo Gaussiano RBD. Maneja bien problemas no lineales y es un buen estándar para la clasificación.

SVM::KERNEL_SIGMOID

Un núcleo basado en la función sigmoid. Usando esta, SVM se hace muy similar a sigmoid de dos capas basado en redes neuronales.

SVM::KERNEL_PRECOMPUTED

Un núcleo precalculado - actualmente sin soporte.

SVM::OPT_TYPE

La clave de opciones para el tipo SVM

SVM::OPT_KERNEL_TYPE

La clave opcional para el tipo de núcleo

SVM::OPT_DEGREE

SVM::OPT_SHRINKING

Parámetro de formación, booleano, para cualquier uso de reducciones heurísticas.

SVM::OPT_PROBABILITY

Parámetro de formación, booleano, para recaudar y estimar el uso de probabilidades.

SVM::OPT_GAMMA

Parámetro algorítmico para usar Poly, RBF y Sigmoid como tipos de núcleo.

SVM::OPT_NU

La clave de opción para el parámetro NU, solo usado en tipos NU_ SVM.

SVM::OPT_EPS

La clave para la opción del parámetro Epsilon, Usada en regresiones epsilon.

SVM::OPT_P

Parámetro de formación usado por regresiones Episilon SVR

SVM::OPT_COEF_ZERO

Parámetro para el algoritmo de núcleos poly y sigmoid

SVM::OPT_C

La opción para el parámetro de coste que controla la compensación entre errores y generalidad - efectivamente la sanción por la clasificación errónea de los ejemplos de formación.

SVM::OPT_CACHE_SIZE

Tamaño de la memoria caché, en MB.

Tabla de contenidos

  • SVM::__construct — Construir un nuevo objeto SVM
  • SVM::crossvalidate — Test training params on subsets of the training data
  • SVM::getOptions — Return the current training parameters
  • SVM::setOptions — Set training parameters
  • SVM::train — Create a SVMModel based on training data


Construir un nuevo objeto SVM

  • « SVM
  • SVM::crossvalidate »
  • PHP Manual
  • SVM
  • Construir un nuevo objeto SVM

SVM::__construct

(PECL svm >= 0.1.0)

SVM::__construct — Construir un nuevo objeto SVM

Descripción

public SVM::__construct ( )

Construye un nuevo objeto SVM listo para aceptar datos de entrenamiento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

lanza una SVMException si la libreria libsvm no puede ser cargada.


Test training params on subsets of the training data

  • « SVM::__construct
  • SVM::getOptions »
  • PHP Manual
  • SVM
  • Test training params on subsets of the training data

SVM::crossvalidate

(PECL svm >= 0.1.0)

SVM::crossvalidate — Test training params on subsets of the training data

Descripción

public svm::crossvalidate ( array $problem , int $number_of_folds ) : float

Crossvalidate can be used to test the effectiveness of the current parameter set on a subset of the training data. Given a problem set and a n "folds", it separates the problem set into n subsets, and the repeatedly trains on one subset and tests on another. While the accuracy will generally be lower than a SVM trained on the enter data set, the accuracy score returned should be relatively useful, so it can be used to test different training parameters.

Parámetros

problem

The problem data. This can either be in the form of an array, the URL of an SVMLight formatted file, or a stream to an opened SVMLight formatted datasource.

number_of_folds

The number of sets the data should be divided into and cross tested. A higher number means smaller training sets and less reliability. 5 is a good number to start with.

Valores devueltos

The correct percentage, expressed as a floating point number from 0-1. In the case of NU_SVC or EPSILON_SVR kernels the mean squared error will returned instead.

Ver también

  • SVM::train() - Create a SVMModel based on training data


Return the current training parameters

  • « SVM::crossvalidate
  • SVM::setOptions »
  • PHP Manual
  • SVM
  • Return the current training parameters

SVM::getOptions

(PECL svm >= 0.1.0)

SVM::getOptions — Return the current training parameters

Descripción

public SVM::getOptions ( ) : array

Retrieve an array containing the training parameters. The parameters will be keyed on the predefined SVM constants.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an array of configuration settings.


Set training parameters

  • « SVM::getOptions
  • SVM::train »
  • PHP Manual
  • SVM
  • Set training parameters

SVM::setOptions

(PECL svm >= 0.1.0)

SVM::setOptions — Set training parameters

Descripción

public SVM::setOptions ( array $params ) : bool

Set one or more training parameters.

Parámetros

params

An array of training parameters, keyed on the SVM constants.

Valores devueltos

Return true on success, throws SVMException on error.


Create a SVMModel based on training data

  • « SVM::setOptions
  • SVMModel »
  • PHP Manual
  • SVM
  • Create a SVMModel based on training data

SVM::train

(PECL svm >= 0.1.0)

SVM::train — Create a SVMModel based on training data

Descripción

public svm::train ( array $problem , array $weights = ? ) : SVMModel

Train a support vector machine based on the supplied training data.

Parámetros

problem

The problem can be provided in three different ways. An array, where the data should start with the class label (usually 1 or -1) then followed by a sparse data set of dimension => data pairs. A URL to a file containing a SVM Light formatted problem, with the each line being a new training example, the start of each line containing the class (1, -1) then a series of tab separated data values shows as key:value. A opened stream pointing to a data source formatted as in the file above.

weights

Weights are an optional set of weighting parameters for the different classes, to help account for unbalanced training sets. For example, if the classes were 1 and -1, and -1 had significantly more example than one, the weight for -1 could be 0.5. Weights should be in the range 0-1.

Valores devueltos

Returns an SVMModel that can be used to classify previously unseen data. Throws SVMException on error


La clase SVMModel

(PECL svm >= 0.1.0)

Introducción

El SVMModel es el resultado final del proceso de formación. Puede ser utilizado para clasificar los datos nunca antes vistos.

Sinopsis de la Clase

SVMModel {
/* Methods */
public checkProbabilityModel ( ) : bool
public __construct ( string $filename = ? )
public getLabels ( ) : array
public getNrClass ( ) : int
public getSvmType ( ) : int
public getSvrProbability ( ) : float
public load ( string $filename ) : bool
public predict_probability ( array $data ) : float
public predict ( array $data ) : float
public save ( string $filename ) : bool
}

Tabla de contenidos

  • SVMModel::checkProbabilityModel — Returns true if the model has probability information
  • SVMModel::__construct — Construct a new SVMModel
  • SVMModel::getLabels — Get the labels the model was trained on
  • SVMModel::getNrClass — Returns the number of classes the model was trained with
  • SVMModel::getSvmType — Get the SVM type the model was trained with
  • SVMModel::getSvrProbability — Get the sigma value for regression types
  • SVMModel::load — Cargar un modelo SVM guardado
  • SVMModel::predict_probability — Return class probabilities for previous unseen data
  • SVMModel::predict — Predict a value for previously unseen data
  • SVMModel::save — Guardar un modelo en un archivo


Returns true if the model has probability information

  • « SVMModel
  • SVMModel::__construct »
  • PHP Manual
  • SVMModel
  • Returns true if the model has probability information

SVMModel::checkProbabilityModel

(PECL svm >= 0.1.5)

SVMModel::checkProbabilityModel — Returns true if the model has probability information

Descripción

public SVMModel::checkProbabilityModel ( ) : bool

Returns true if the model contains probability information.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return a boolean value


Construct a new SVMModel

  • « SVMModel::checkProbabilityModel
  • SVMModel::getLabels »
  • PHP Manual
  • SVMModel
  • Construct a new SVMModel

SVMModel::__construct

(PECL svm >= 0.1.0)

SVMModel::__construct — Construct a new SVMModel

Descripción

public SVMModel::__construct ( string $filename = ? )

Build a new SVMModel. Models will usually be created from the SVM::train function, but then saved models may be restored directly.

Parámetros

filename

The filename for the saved model file this model should load.

Valores devueltos

Throws SVMException on error

Ver también

  • SVMModel::load() - Cargar un modelo SVM guardado


Get the labels the model was trained on

  • « SVMModel::__construct
  • SVMModel::getNrClass »
  • PHP Manual
  • SVMModel
  • Get the labels the model was trained on

SVMModel::getLabels

(PECL svm >= 0.1.5)

SVMModel::getLabels — Get the labels the model was trained on

Descripción

public SVMModel::getLabels ( ) : array

Return an array of labels that the model was trained on. For regression and one class models an empty array is returned.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return an array of labels

Ver también

  • SVMModel::getNrClass() - Returns the number of classes the model was trained with


Returns the number of classes the model was trained with

  • « SVMModel::getLabels
  • SVMModel::getSvmType »
  • PHP Manual
  • SVMModel
  • Returns the number of classes the model was trained with

SVMModel::getNrClass

(PECL svm >= 0.1.5)

SVMModel::getNrClass — Returns the number of classes the model was trained with

Descripción

public SVMModel::getNrClass ( ) : int

Returns the number of classes the model was trained with, will return 2 for one class and regression models.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return an integer number of classes


Get the SVM type the model was trained with

  • « SVMModel::getNrClass
  • SVMModel::getSvrProbability »
  • PHP Manual
  • SVMModel
  • Get the SVM type the model was trained with

SVMModel::getSvmType

(PECL svm >= 0.1.5)

SVMModel::getSvmType — Get the SVM type the model was trained with

Descripción

public SVMModel::getSvmType ( ) : int

Returns an integer value representing the type of the SVM model used, e.g SVM::C_SVC.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Return an integer SVM type


Get the sigma value for regression types

  • « SVMModel::getSvmType
  • SVMModel::load »
  • PHP Manual
  • SVMModel
  • Get the sigma value for regression types

SVMModel::getSvrProbability

(PECL svm >= 0.1.5)

SVMModel::getSvrProbability — Get the sigma value for regression types

Descripción

public SVMModel::getSvrProbability ( ) : float

For regression models, returns a sigma value. If there is no probability information or the model is not SVR, 0 is returned.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a sigma value


Cargar un modelo SVM guardado

  • « SVMModel::getSvrProbability
  • SVMModel::predict_probability »
  • PHP Manual
  • SVMModel
  • Cargar un modelo SVM guardado

SVMModel::load

(PECL svm >= 0.1.00.1.0)

SVMModel::load — Cargar un modelo SVM guardado

Descripción

public SVMModel::load ( string $filename ) : bool

Cargar un archivo de un modelo listo para la clasificación o regresión.

Parámetros

filename

El nombre del modelo.

Valores devueltos

Lanza SVMException en caso de error. Devuelve true en caso de éxito.

Ver también

  • SVMModel::save() - Guardar un modelo en un archivo


Return class probabilities for previous unseen data

  • « SVMModel::load
  • SVMModel::predict »
  • PHP Manual
  • SVMModel
  • Return class probabilities for previous unseen data

SVMModel::predict_probability

(PECL svm >= 0.1.4)

SVMModel::predict_probability — Return class probabilities for previous unseen data

Descripción

public SVMModel::predict_probability ( array $data ) : float

This function accepts an array of data and attempts to predict the class, as with the predict function. Additionally, however, this function returns an array of probabilities, one per class in the model, which represent the estimated chance of the data supplied being a member of that class. Requires that the model to be used has been trained with the probability parameter set to true.

Parámetros

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

probabilities

The supplied value will be filled with the probabilities. This will be either null, in the case of a model without probability information, or an array where the index is the class name and the value the predicted probability.

Valores devueltos

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

Ver también

  • SVM::predict()


Predict a value for previously unseen data

  • « SVMModel::predict_probability
  • SVMModel::save »
  • PHP Manual
  • SVMModel
  • Predict a value for previously unseen data

SVMModel::predict

(PECL svm >= 0.1.0)

SVMModel::predict — Predict a value for previously unseen data

Descripción

public SVMModel::predict ( array $data ) : float

This function accepts an array of data and attempts to predict the class or regression value based on the model extracted from previously trained data.

Parámetros

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

Valores devueltos

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

Ver también

  • SVM::train() - Create a SVMModel based on training data


Guardar un modelo en un archivo

  • « SVMModel::predict
  • SVN »
  • PHP Manual
  • SVMModel
  • Guardar un modelo en un archivo

SVMModel::save

(PECL svm >= 0.1.0)

SVMModel::save — Guardar un modelo en un archivo

Descripción

public SVMModel::save ( string $filename ) : bool

Guardar los datos del modelo en un archivo, para su uso posterior.

Parámetros

filename

El archivo para guardar el modelo.

Valores devueltos

Lanza SVMException en caso de error. Devuelve true en caso de éxito.

Ver también

  • SVMModel::load() - Cargar un modelo SVM guardado


Subversion

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones SVN
    • svn_add — Programa la adición de un artículo en un directorio de trabajo
    • svn_auth_get_parameter — Recupera un parámetros de autenticación
    • svn_auth_set_parameter — Establece un parámetro de autenticación
    • svn_blame — Obtiene las acusaciones SVN de un archivo
    • svn_cat — Devuelve el contenido de un fichero en un repositorio
    • svn_checkout — Descarga una copia de trabajo desde el repositorio
    • svn_cleanup — Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos
    • svn_client_version — Devuelve la versión de las librerias del cliente SVN
    • svn_commit — Envía los cambios desde el directorio local de trabajo al repositorio
    • svn_delete — Elimina ítems de una copia de trabajo o repositorio
    • svn_diff — Compara dos rutas de acceso recursivamente
    • svn_export — Exporta el contenido de un directorio SVN
    • svn_fs_abort_txn — Cancelar una transacción, devuelve true si todo está bien, false de lo contrario
    • svn_fs_apply_text — Crea y devuelve una secuencia que se utilizará para reemplazar
    • svn_fs_begin_txn2 — Crear una nueva transacción
    • svn_fs_change_node_prop — Retorna verdadero si todo está ok, falso en caso contrario
    • svn_fs_check_path — Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot
    • svn_fs_contents_changed — Devuelve verdadero si el contenido es diferente, falso en caso contrario
    • svn_fs_copy — Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false
    • svn_fs_delete — Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false
    • svn_fs_dir_entries — Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios
    • svn_fs_file_contents — Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada
    • svn_fs_file_length — Devuelve la longitud de un fichero para una versión dada de sistema de ficheros
    • svn_fs_is_dir — Devuelve true si la ruta apunta a un directorio, false en caso contrario
    • svn_fs_is_file — Devuelve true si la ruta apunta a un fichero, falso en caso contrario
    • svn_fs_make_dir — Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false
    • svn_fs_make_file — Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario
    • svn_fs_node_created_rev — Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado
    • svn_fs_node_prop — Devuelve el valor de una propiedad de un nodo
    • svn_fs_props_changed — Devuelve verdadero si las propiedades son diferentes, falso en caso contrario
    • svn_fs_revision_prop — Recupera el valor de una propiedad con determinado nombre
    • svn_fs_revision_root — Obtiene un gestor en una versión específica del repositorio 'root'
    • svn_fs_txn_root — Crea y retorna una transacción 'root'
    • svn_fs_youngest_rev — Devuelve el número de la revisión más reciente del sistema de ficheros
    • svn_import — Importa una ruta de acceso sin versión, dentro de un repositorio
    • svn_log — Devuelve el log histórico de mensajes de un repositorio URL
    • svn_ls — Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión
    • svn_mkdir — Crea un directorio en la copia de trabajo actual o repositorio
    • svn_repos_create — Crea un nuevo repositorio de subversión
    • svn_repos_fs_begin_txn_for_commit — Crea una nueva transacción
    • svn_repos_fs_commit_txn — Consolida una transacción y devuelve la nueva revisión
    • svn_repos_fs — Obtiene un gestor del sistema de ficheros para un repositorio
    • svn_repos_hotcopy — Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath
    • svn_repos_open — Abre una cerradura compartida en un repositorio
    • svn_repos_recover — Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado
    • svn_revert — Deshace los cambios en la copia de trabajo
    • svn_status — Devuelve el estado de la copia de trabajo de los ficheros y directorios
    • svn_update — Actualiza la copia de trabajo


Introducción

Esta extensión de PHP implementa enlaces para » Subversion (SVN), un sistema de control de versiones, permitiendo a los scripts PHP comunicarse con repositorios SVN y trabajar con copias sin llamar al ejecutable svn en la línea de comandos.

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.


Requerimientos

Los binarios de Subversion no son necesarios para usar esta extensión. Sin embargo, cuando compile la extensión, libsvn (las cabeceras de Subversion) debe estar disponible.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/svn

Si ./configure está teniendo problemas para encontrar los archivos SVN (Por ejemplo, Subversion fue instalado con un prefijo de directorio diferente), use ./configure --with-svn=$USR_PATH para especificar el directorio donde include/subversion-1/ está ubicado.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .

Advertencia

Si la extensión es compilada contra libsvn 1.3, las funciones que trabajan con copias fallarán cuando trabaje en copias creadas por Subversion 1.4.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SVN_REVISION_HEAD (integer)
Número mágico (-1) especificando la revisión HEAD
Constantes usables con svn_auth_set_parameter()
SVN_AUTH_PARAM_DEFAULT_USERNAME (string)
Proiedad para el nombre de usuario por omisión a ser usada cuando realice una autenticación básica
SVN_AUTH_PARAM_DEFAULT_PASSWORD (string)
Propiedad para la clave por omisión a ser usada cuando realice una autenticación básica
SVN_AUTH_PARAM_NON_INTERACTIVE (string)
SVN_AUTH_PARAM_DONT_STORE_PASSWORDS (string)
SVN_AUTH_PARAM_NO_AUTH_CACHE (string)
SVN_AUTH_PARAM_SSL_SERVER_FAILURES (string)
SVN_AUTH_PARAM_SSL_SERVER_CERT_INFO (string)
SVN_AUTH_PARAM_CONFIG (string)
SVN_AUTH_PARAM_SERVER_GROUP (string)
SVN_AUTH_PARAM_CONFIG_DIR (string)
PHP_SVN_AUTH_PARAM_IGNORE_SSL_VERIFY_ERRORS (string)
Propiedad personalizada para ignorar los errores de verificación del certificado SSL
Constantes del sistema de archivos
SVN_FS_CONFIG_FS_TYPE (string)
Llave de configuración que determina el tipo de sistema de archivos
SVN_FS_TYPE_BDB (string)
Sistema de archivos es una implemetación Berkeley-DB
SVN_FS_TYPE_FSFS (string)
Implementación del sistema de ficheros nativo
Constantes de propiedad reservadas
SVN_PROP_REVISION_DATE (string)
svn:date
SVN_PROP_REVISION_ORIG_DATE (string)
svn:original-date
SVN_PROP_REVISION_AUTHOR (string)
svn:author
SVN_PROP_REVISION_LOG (string)
svn:log
constantes de trabajo con status de copias
SVN_WC_STATUS_NONE (int)
Status no existe
SVN_WC_STATUS_UNVERSIONED (int)
El artículo no está versionado en la copia de trabajo
SVN_WC_STATUS_NORMAL (int)
El artículo existe, nada más está ocurriendo
SVN_WC_STATUS_ADDED (int)
El artículo está programado para su adición
SVN_WC_STATUS_MISSING (int)
El artículo está versionado pero la copia de trabajo está ausante
SVN_WC_STATUS_DELETED (int)
El artículo está programado para ser borrado
SVN_WC_STATUS_REPLACED (int)
El artículo fue borrado y luego re-agregado
SVN_WC_STATUS_MODIFIED (int)
El artículo (texto o propiedades) fue modificado
SVN_WC_STATUS_MERGED (int)
Las modificaciones locales del artículo fueron unidas con las modificaciones del repositorio
SVN_WC_STATUS_CONFLICTED (int)
Las modificaciones locales del artículo discreparon con las modificaciones de repositorio
SVN_WC_STATUS_IGNORED (int)
El artículo está desversionado pero configurado para ser ignorado
SVN_WC_STATUS_OBSTRUCTED (int)
Artículo desversionado está en el camino de un recurso versionado
SVN_WC_STATUS_EXTERNAL (int)
Rura desversionada que está poblada usando svn:externals
SVN_WC_STATUS_INCOMPLETE (int)
El directorio no contiene la lista completa de entradas
Node type constants
SVN_NODE_NONE (int)
Ausente
SVN_NODE_FILE (int)
Archivo
SVN_NODE_DIR (int)
Directorio
SVN_NODE_UNKNOWN (int)
Algo que la subversión no puede identificar


Funciones SVN

Tabla de contenidos

  • svn_add — Programa la adición de un artículo en un directorio de trabajo
  • svn_auth_get_parameter — Recupera un parámetros de autenticación
  • svn_auth_set_parameter — Establece un parámetro de autenticación
  • svn_blame — Obtiene las acusaciones SVN de un archivo
  • svn_cat — Devuelve el contenido de un fichero en un repositorio
  • svn_checkout — Descarga una copia de trabajo desde el repositorio
  • svn_cleanup — Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos
  • svn_client_version — Devuelve la versión de las librerias del cliente SVN
  • svn_commit — Envía los cambios desde el directorio local de trabajo al repositorio
  • svn_delete — Elimina ítems de una copia de trabajo o repositorio
  • svn_diff — Compara dos rutas de acceso recursivamente
  • svn_export — Exporta el contenido de un directorio SVN
  • svn_fs_abort_txn — Cancelar una transacción, devuelve true si todo está bien, false de lo contrario
  • svn_fs_apply_text — Crea y devuelve una secuencia que se utilizará para reemplazar
  • svn_fs_begin_txn2 — Crear una nueva transacción
  • svn_fs_change_node_prop — Retorna verdadero si todo está ok, falso en caso contrario
  • svn_fs_check_path — Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot
  • svn_fs_contents_changed — Devuelve verdadero si el contenido es diferente, falso en caso contrario
  • svn_fs_copy — Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false
  • svn_fs_delete — Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false
  • svn_fs_dir_entries — Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios
  • svn_fs_file_contents — Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada
  • svn_fs_file_length — Devuelve la longitud de un fichero para una versión dada de sistema de ficheros
  • svn_fs_is_dir — Devuelve true si la ruta apunta a un directorio, false en caso contrario
  • svn_fs_is_file — Devuelve true si la ruta apunta a un fichero, falso en caso contrario
  • svn_fs_make_dir — Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false
  • svn_fs_make_file — Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario
  • svn_fs_node_created_rev — Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado
  • svn_fs_node_prop — Devuelve el valor de una propiedad de un nodo
  • svn_fs_props_changed — Devuelve verdadero si las propiedades son diferentes, falso en caso contrario
  • svn_fs_revision_prop — Recupera el valor de una propiedad con determinado nombre
  • svn_fs_revision_root — Obtiene un gestor en una versión específica del repositorio 'root'
  • svn_fs_txn_root — Crea y retorna una transacción 'root'
  • svn_fs_youngest_rev — Devuelve el número de la revisión más reciente del sistema de ficheros
  • svn_import — Importa una ruta de acceso sin versión, dentro de un repositorio
  • svn_log — Devuelve el log histórico de mensajes de un repositorio URL
  • svn_ls — Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión
  • svn_mkdir — Crea un directorio en la copia de trabajo actual o repositorio
  • svn_repos_create — Crea un nuevo repositorio de subversión
  • svn_repos_fs_begin_txn_for_commit — Crea una nueva transacción
  • svn_repos_fs_commit_txn — Consolida una transacción y devuelve la nueva revisión
  • svn_repos_fs — Obtiene un gestor del sistema de ficheros para un repositorio
  • svn_repos_hotcopy — Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath
  • svn_repos_open — Abre una cerradura compartida en un repositorio
  • svn_repos_recover — Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado
  • svn_revert — Deshace los cambios en la copia de trabajo
  • svn_status — Devuelve el estado de la copia de trabajo de los ficheros y directorios
  • svn_update — Actualiza la copia de trabajo


Programa la adición de un artículo en un directorio de trabajo

  • « Funciones SVN
  • svn_auth_get_parameter »
  • PHP Manual
  • Funciones SVN
  • Programa la adición de un artículo en un directorio de trabajo

svn_add

(PECL svn >= 0.1.0)

svn_add — Programa la adición de un artículo en un directorio de trabajo

Descripción

svn_add ( string $path , bool $recursive = true , bool $force = false ) : bool

Agrega el archivo, directorio o enlace simbólico en path al directorio de trabajo. El artículo será agregado al repositorio la próxima vez que se llame a svn_commit() sobre la copia de trabajo.

Parámetros

path

Ruta al artículo a ser agregado.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

recursive

Si el artículo es un directorio, si desea o no añadir de forma recursiva todos sus contenidos. Por omisión es true

force

Si es true, Subversion recorrerá recursivamente en los directorios ya versionados a fin de agregar archivos no versionados que pueden estar ocultos en esos directorios. Por omisión es false

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo de svn_add()

En un directorio de trabajo donde svn status devuelve:

$ svn status
?      foobar.txt

...este código:

<?php
svn_add('foobar.txt');
?>

... se programará foobar.txt para agregarse al repositorio.

Ver también

  • » Documentación SVN sobre svn add


Recupera un parámetros de autenticación

  • « svn_add
  • svn_auth_set_parameter »
  • PHP Manual
  • Funciones SVN
  • Recupera un parámetros de autenticación

svn_auth_get_parameter

(PECL svn >= 0.1.0)

svn_auth_get_parameter — Recupera un parámetros de autenticación

Descripción

svn_auth_get_parameter ( string $key ) : string

Recupera un parámetro de autenticación donde la clave es key. Para obtener una lista de claves válidas y sus significados, consulte la lista de constantes de autenticación.

Parámetros

key

Nombre de la clave. Utilice una constante de autenticación definidas por esta extensión para especificar una clave.

Valores devueltos

Devuelve el valor de cadena del parámetro en key; devuelve null si el parámetro no existe.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • svn_auth_set_parameter() - Establece un parámetro de autenticación
  • Constantes de autenticación


Establece un parámetro de autenticación

  • « svn_auth_get_parameter
  • svn_blame »
  • PHP Manual
  • Funciones SVN
  • Establece un parámetro de autenticación

svn_auth_set_parameter

(PECL svn >= 0.1.0)

svn_auth_set_parameter — Establece un parámetro de autenticación

Descripción

svn_auth_set_parameter ( string $key , string $value ) : void

Establece un parámetro de autenticación en la clave key con el valor value. Para obtener una lista de claves válidas y sus significado, consulte la lista de constantes de autenticación.

Parámetros

key

Nombre de la clave. Utilice una constante de autenticación definidas por esta extensión para especificar una clave.

value

Valor de la cadena a establecer como parámetro en la clave. El formato del valor varía con el n parámetro.

Valores devueltos

No devuelve ningún valor.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo de autenticación por omisión

Este ejemplo configura a SVN para que el nombre de usuario por omisión sea 'Bob' y la contraseña por omisión sea 'abc123':

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
?>

Ver también

  • svn_auth_get_parameter() - Recupera un parámetros de autenticación
  • Constantes de autenticación


Obtiene las acusaciones SVN de un archivo

  • « svn_auth_set_parameter
  • svn_cat »
  • PHP Manual
  • Funciones SVN
  • Obtiene las acusaciones SVN de un archivo

svn_blame

(PECL svn >= 0.3.0)

svn_blame — Obtiene las acusaciones SVN de un archivo

Descripción

svn_blame ( string $repository_url , int $revision_no = SVN_REVISION_HEAD ) : array

Obtiene las acusaciones SVN de un archivo desde una URL de repositorio.

Parámetros

repository_url

La URL del repositorio.

revision_no

El número de revisión.

Valores devueltos

Un array con la información de acuses SVN separados por línea incluyendo los números de revisión, número de línea, línea de codigo, autor, y fecha.

Ejemplos

Ejemplo #1 Ejemplo de svn_blame()

<?php
$svnurl = 'http://svn.example.org/svnroot/foo/trunk/index.php';

print_r( svn_blame($svnurl) );

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] = Array
          (
           [rev] = 1
           [line_no] = 1
           [line] = Hello World
           [author] = joesmith
           [date] = 2007-07-02T05:51:26.628396Z
          )
    [1] = Array
          ...

Ver también

  • svn_diff() - Compara dos rutas de acceso recursivamente
  • svn_logs()
  • svn_status() - Devuelve el estado de la copia de trabajo de los ficheros y directorios


Devuelve el contenido de un fichero en un repositorio

  • « svn_blame
  • svn_checkout »
  • PHP Manual
  • Funciones SVN
  • Devuelve el contenido de un fichero en un repositorio

svn_cat

(PECL svn >= 0.1.0)

svn_cat — Devuelve el contenido de un fichero en un repositorio

Descripción

svn_cat ( string $repos_url , int $revision_no = ? ) : string

Devuelve el contenido del fichero de un repositorio indicado en repos_url, de forma opcional se puede indicar opcionalmente el número de revisión en revision_no.

Parámetros

repos_url

La ruta URL del ítem en el repositorio (cadena).

revision_no

Número de revisión del ítem a obtener, por defecto es la última revisión (entero).

Valores devueltos

Devuelve el contenido del ítem del repositorio en caso de éxito, y false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo devuelve el contenido de un fichero en su revisión 28:

<?php
$contents = svn_cat('http://www.example.com/svnroot/calc/gui.c', 28)
?>

Ver también

  • svn_list()
  • » Documentación SVN de svn cat


Descarga una copia de trabajo desde el repositorio

  • « svn_cat
  • svn_cleanup »
  • PHP Manual
  • Funciones SVN
  • Descarga una copia de trabajo desde el repositorio

svn_checkout

(PECL svn >= 0.1.0)

svn_checkout — Descarga una copia de trabajo desde el repositorio

Descripción

svn_checkout ( string $repos , string $targetpath , int $revision = ? , int $flags = 0 ) : bool

Descarga una copia de trabajo desde el repositorio en repos a targetpath con la revisión revision.

Parámetros

repos

Cadena URL con la ruta al directorio en el repositorio a descargar.

targetpath

Cadena con la ruta local del directorio en donde descargar.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

revision

Número de la revisión del repositorio a descargar. Por defecto es HEAD, la más reciente.

flags

Cualquier combinación de SVN_NON_RECURSIVE y SVN_IGNORE_EXTERNALS.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo demustra como descargar un directorio desde un repositorio a un directorio llamado calc:

<?php
svn_checkout('http://www.example.com/svnroot/calc/trunk', dirname(__FILE__) . '/calc');
?>

La llamada a dirname(__FILE__) es necesaria para poder convertir la ruta relativa de path en una ruta absoluta. Si calc existe, también se puede usar realpath() para obtener la ruta absoluta.

Ver también

  • svn_add() - Programa la adición de un artículo en un directorio de trabajo
  • svn_commit() - Envía los cambios desde el directorio local de trabajo al repositorio
  • svn_status() - Devuelve el estado de la copia de trabajo de los ficheros y directorios
  • svn_update() - Actualiza la copia de trabajo
  • » Documentación SVN para descargas svn


Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos

  • « svn_checkout
  • svn_client_version »
  • PHP Manual
  • Funciones SVN
  • Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos

svn_cleanup

(PECL svn >= 0.1.0)

svn_cleanup — Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos

Descripción

svn_cleanup ( string $workingdir ) : bool

Limpieza recursiva del directorio de trabajo workingdir, finalizando cualquier operación no completada y eliminando bloqueos que existan en la copia de trabajo. Utilícese cuando la copia de trabajo no funcione y necesite ser arreglada.

Parámetros

workingdir

Ruta local del directorio de trabajo a limpiar

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo demuestra como hacer limpieza en un directorio de trabajo llamado help-me:

<?php
svn_cleanup(realpath('help-me'));
?>

La llamada al realpath() (ruta absoluta) es necesaria debido a que SVN's no maneja muy bien rutas relativas.

Ver también

  • update()
  • » Documentación SVN del comando svn cleanup


Devuelve la versión de las librerias del cliente SVN

  • « svn_cleanup
  • svn_commit »
  • PHP Manual
  • Funciones SVN
  • Devuelve la versión de las librerias del cliente SVN

svn_client_version

(PECL svn >= 0.1.0)

svn_client_version — Devuelve la versión de las librerias del cliente SVN

Descripción

svn_client_version ( ) : string

Devuelve la versión de las librerías del cliente SVN

Valores devueltos

Cadena de texto con el número de versión, normalmente con el formato x.y.z.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

<?php
echo svn_client_version();
?>

El resultado del ejemplo sería algo similar a:

1.3.1


Envía los cambios desde el directorio local de trabajo al repositorio

  • « svn_client_version
  • svn_delete »
  • PHP Manual
  • Funciones SVN
  • Envía los cambios desde el directorio local de trabajo al repositorio

svn_commit

(PECL svn >= 0.1.0)

svn_commit — Envía los cambios desde el directorio local de trabajo al repositorio

Descripción

svn_commit ( string $log , array $targets , bool $recursive = true ) : array

Hace commit a los cambios hechos en local enumerados en el targets array en el repositorio, con el mensaje de loglog. Los directorios del targets array se confirmarán recursivamente a menos que recursive sea establecido a false.

Nota: Esta función no tiene ningún parámetro para especificar la autenticación, por lo que usuario y contraseña tienen que ponerse usando svn_auth_set_parameter()

Parámetros

log

String del log para el commit

targets

Array de rutas locales de archivos para hacer commit

Advertencia

Este parámetro tiene que ser un array, no será aceptada un String para un único target.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

recursive

Flag para desactivar el commit recursivo de directorios en el targets array. Por defecto es true.

Valores devueltos

Se devuelve un array con la siguiente estructura:

array(
    0 => integer revision number of commit
    1 => string ISO 8601 date and time of commit
    2 => name of committer
)

Devuelve false en caso de fallo.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo hace commit, usando el usuario Bob y la contraseña abc123 (esperemos que su contraseña sea más segura):

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
var_dump(svn_commit('Log message of Bob\'s commit', array(realpath('calculator'))));
?>

El resultado del ejemplo sería:

array(
  0 => 1415,
  1 => '2007-05-26T01:44:28.453125Z',
  2 => 'Bob'
)

Ver también

  • svn_auth_set_parameter() - Establece un parámetro de autenticación
  • » Documentación de SVN para svn commit


Elimina ítems de una copia de trabajo o repositorio

  • « svn_commit
  • svn_diff »
  • PHP Manual
  • Funciones SVN
  • Elimina ítems de una copia de trabajo o repositorio

svn_delete

(PECL svn >= 0.4.0)

svn_delete — Elimina ítems de una copia de trabajo o repositorio

Descripción

svn_delete ( string $path , bool $force = false ) : bool

Elimina el fichero, directorio o enlace simbólico en el path del directorio de trabajo. El ítem será eliminado del repositorio la próxima vez que se use svn_commit() en la copia de trabajo.

Parámetros

path

Ruta o ítem a eliminar.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

force

En caso que sea true, el fichero será eliminado incluso si se han hecho modificaciones en local. En caso contrario, el haber hecho modificaciones en local causará un error. El valor por omisión es false

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ver también

  • » SVN documentation on svn delete


Compara dos rutas de acceso recursivamente

  • « svn_delete
  • svn_export »
  • PHP Manual
  • Funciones SVN
  • Compara dos rutas de acceso recursivamente

svn_diff

(PECL svn >= 0.1.0)

svn_diff — Compara dos rutas de acceso recursivamente

Descripción

svn_diff ( string $path1 , int $rev1 , string $path2 , int $rev2 ) : array

Compara dos rutas de acceso recursivamente, path1 y path2.

Nota:

No es una utilidad general de comparación. Únicamente se pueden comparar ficheros locales que estan versionados: los otros ficheros fallarán.

Parámetros

path1

La primera ruta de acceso a comparar. Puede ser una URL a un fichero/directorio en un repositorio SVN o una ruta de acceso a un fichero/directorio local.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

Advertencia

Si la ruta de acceso a un fichero local únicamente tiene el caracter de barra invertida '\' y no la barra '/', esta extensión no podrá encontrar la ruta de acceso. Se debe reemplazar siempre la barra invertida '\' con la barra '/' cuando se utilice esta función.

rev1

Número de revisión de la primera ruta de acceso. Utilizar SVN_REVISION_HEAD para especificar la versión más reciente.

path2

Segunda ruta de acceso a comparar. Ver path1para descripción.

rev2

Número de revisión de la segunda ruta de acceso. Ver rev1 para descripción.

Valores devueltos

Devuelve un array consistente en dos flujos: el primero es la salida de la comparación y el segundo contiene el flujo de salida de error. El flujo se puede leer utilizando fread(). Devuelve false o null en caso de error.

Por defecto, la salida de la comparación tendrá el formato Subversión de cliente unificado, pero un » motor externo de comparativa puede ser utilizado dependiendo de la configuración de la Subversión.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo demuestra el uso básico de esta función, y la obtención de contenidos del flujo:

<?php
list($diff, $errors) = svn_diff(
    'http://www.example.com/svnroot/trunk/foo', SVN_REVISION_HEAD,
    'http://www.example.com/svnroot/branches/dev/foo', SVN_REVISION_HEAD
);
if (!$diff) exit;
$contents = '';
while (!feof($diff)) {
  $contents .= fread($diff, 8192);
}
fclose($diff);
fclose($errors);
var_dump($contents);
?>

El resultado del ejemplo sería:

Index: http://www.example.com/svnroot/trunk/foo
===================================================================
--- http://www.example.com/svnroot/trunk/foo        (.../foo) (revision 23)
+++ http://www.example.com/svnroot/branches/dev/foo (.../foo) (revision 27)
 // further diff output

Ejemplo #2 Comparando dos revisiones de una ruta de acceso a repositorio

Este ejemplo implementa una función de envoltorio que permite a un usuario comparar fácilmente dos revisiones del mismo elemento utilizando un camino de acceso externo al repositorio (la sintaxis por defecto es detallada):

<?php
function svn_diff_same_item($path, $rev1, $rev2) {
    return svn_diff($path, $rev1, $path, $rev2);
}
?>

Ejemplo #3 Comparativa portable de dos ficheros locales

Este ejemplo implementa una función envoltorio que compara de forma portable dos ficheros locales, compensando el problema realpath() y el de las barras invertidas '\':

<?php
function svn_diff_local($path1, $rev1, $path2, $rev2) {
    $path1 = str_replace('\\', '/', realpath($path1));
    $path2 = str_replace('\\', '/', realpath($path2));
    return svn_diff($path1, $rev1, $path2, $rev2);
}
?>

Ver también

  • » documentación SVN bajo el comando "svn diff"


Exporta el contenido de un directorio SVN

  • « svn_diff
  • svn_fs_abort_txn »
  • PHP Manual
  • Funciones SVN
  • Exporta el contenido de un directorio SVN

svn_export

(PECL svn >= 0.3.0)

svn_export — Exporta el contenido de un directorio SVN

Descripción

svn_export ( string $frompath , string $topath , bool $working_copy = true , int $revision_no = -1 ) : bool

Exporta el contenido de una copia de trabajo o un repositorio en un directorio 'limpio'.

Parámetros

frompath

La ruta del repositorio actual.

topath

La ruta del nuevo repositorio.

working_copy

Si es true, exportará ficheros no cometidos de la copia de trabajo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de svn_export()

<?php
$working_dir     = '../';
$new_working_dir = '/home/user/devel/foo/trunk';

svn_export($working_dir, $new_working_dir);
?>

Ver también

  • svn_import() - Importa una ruta de acceso sin versión, dentro de un repositorio


Cancelar una transacción, devuelve true si todo está bien, false de lo contrario

  • « svn_export
  • svn_fs_apply_text »
  • PHP Manual
  • Funciones SVN
  • Cancelar una transacción, devuelve true si todo está bien, false de lo contrario

svn_fs_abort_txn

(PECL svn >= 0.2.0)

svn_fs_abort_txn — Cancelar una transacción, devuelve true si todo está bien, false de lo contrario

Descripción

svn_fs_abort_txn ( resource $txn ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Cancelar una transacción, devuelve true si todo está bien, false de lo contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea y devuelve una secuencia que se utilizará para reemplazar

  • « svn_fs_abort_txn
  • svn_fs_begin_txn2 »
  • PHP Manual
  • Funciones SVN
  • Crea y devuelve una secuencia que se utilizará para reemplazar

svn_fs_apply_text

(PECL svn >= 0.2.0)

svn_fs_apply_text — Crea y devuelve una secuencia que se utilizará para reemplazar

Descripción

svn_fs_apply_text ( resource $root , string $path ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea y devuelve una secuencia que se utilizará para reemplazar

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crear una nueva transacción

  • « svn_fs_apply_text
  • svn_fs_change_node_prop »
  • PHP Manual
  • Funciones SVN
  • Crear una nueva transacción

svn_fs_begin_txn2

(PECL svn >= 0.2.0)

svn_fs_begin_txn2 — Crear una nueva transacción

Descripción

svn_fs_begin_txn2 ( resource $repos , int $rev ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crear una nueva transacción

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Retorna verdadero si todo está ok, falso en caso contrario

  • « svn_fs_begin_txn2
  • svn_fs_check_path »
  • PHP Manual
  • Funciones SVN
  • Retorna verdadero si todo está ok, falso en caso contrario

svn_fs_change_node_prop

(PECL svn >= 0.2.0)

svn_fs_change_node_prop — Retorna verdadero si todo está ok, falso en caso contrario

Descripción

svn_fs_change_node_prop ( resource $root , string $path , string $name , string $value ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Retorna verdadero si todo está ok, falso en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot

  • « svn_fs_change_node_prop
  • svn_fs_contents_changed »
  • PHP Manual
  • Funciones SVN
  • Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot

svn_fs_check_path

(PECL svn >= 0.1.0)

svn_fs_check_path — Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot

Descripción

svn_fs_check_path ( resource $fsroot , string $path ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve verdadero si el contenido es diferente, falso en caso contrario

  • « svn_fs_check_path
  • svn_fs_copy »
  • PHP Manual
  • Funciones SVN
  • Devuelve verdadero si el contenido es diferente, falso en caso contrario

svn_fs_contents_changed

(PECL svn >= 0.2.0)

svn_fs_contents_changed — Devuelve verdadero si el contenido es diferente, falso en caso contrario

Descripción

svn_fs_contents_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve verdadero si el contenido es diferente, falso en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false

  • « svn_fs_contents_changed
  • svn_fs_delete »
  • PHP Manual
  • Funciones SVN
  • Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false

svn_fs_copy

(PECL svn >= 0.2.0)

svn_fs_copy — Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false

Descripción

svn_fs_copy ( resource $from_root , string $from_path , resource $to_root , string $to_path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false

  • « svn_fs_copy
  • svn_fs_dir_entries »
  • PHP Manual
  • Funciones SVN
  • Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false

svn_fs_delete

(PECL svn >= 0.2.0)

svn_fs_delete — Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false

Descripción

svn_fs_delete ( resource $root , string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuelve false

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios

  • « svn_fs_delete
  • svn_fs_file_contents »
  • PHP Manual
  • Funciones SVN
  • Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios

svn_fs_dir_entries

(PECL svn >= 0.1.0)

svn_fs_dir_entries — Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios

Descripción

svn_fs_dir_entries ( resource $fsroot , string $path ) : array
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada

  • « svn_fs_dir_entries
  • svn_fs_file_length »
  • PHP Manual
  • Funciones SVN
  • Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada

svn_fs_file_contents

(PECL svn >= 0.1.0)

svn_fs_file_contents — Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada

Descripción

svn_fs_file_contents ( resource $fsroot , string $path ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve la longitud de un fichero para una versión dada de sistema de ficheros

  • « svn_fs_file_contents
  • svn_fs_is_dir »
  • PHP Manual
  • Funciones SVN
  • Devuelve la longitud de un fichero para una versión dada de sistema de ficheros

svn_fs_file_length

(PECL svn >= 0.1.0)

svn_fs_file_length — Devuelve la longitud de un fichero para una versión dada de sistema de ficheros

Descripción

svn_fs_file_length ( resource $fsroot , string $path ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la longitud de un fichero para una versión dada de sistema de ficheros

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve true si la ruta apunta a un directorio, false en caso contrario

  • « svn_fs_file_length
  • svn_fs_is_file »
  • PHP Manual
  • Funciones SVN
  • Devuelve true si la ruta apunta a un directorio, false en caso contrario

svn_fs_is_dir

(PECL svn >= 0.2.0)

svn_fs_is_dir — Devuelve true si la ruta apunta a un directorio, false en caso contrario

Descripción

svn_fs_is_dir ( resource $root , string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve true si la ruta apunta a un directorio, falso en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve true si la ruta apunta a un fichero, falso en caso contrario

  • « svn_fs_is_dir
  • svn_fs_make_dir »
  • PHP Manual
  • Funciones SVN
  • Devuelve true si la ruta apunta a un fichero, falso en caso contrario

svn_fs_is_file

(PECL svn >= 0.2.0)

svn_fs_is_file — Devuelve true si la ruta apunta a un fichero, falso en caso contrario

Descripción

svn_fs_is_file ( resource $root , string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve true si la ruta apunta a un fichero, falso en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false

  • « svn_fs_is_file
  • svn_fs_make_file »
  • PHP Manual
  • Funciones SVN
  • Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false

svn_fs_make_dir

(PECL svn >= 0.2.0)

svn_fs_make_dir — Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false

Descripción

svn_fs_make_dir ( resource $root , string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario

  • « svn_fs_make_dir
  • svn_fs_node_created_rev »
  • PHP Manual
  • Funciones SVN
  • Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario

svn_fs_make_file

(PECL svn >= 0.2.0)

svn_fs_make_file — Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario

Descripción

svn_fs_make_file ( resource $root , string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado

  • « svn_fs_make_file
  • svn_fs_node_prop »
  • PHP Manual
  • Funciones SVN
  • Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado

svn_fs_node_created_rev

(PECL svn >= 0.1.0)

svn_fs_node_created_rev — Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado

Descripción

svn_fs_node_created_rev ( resource $fsroot , string $path ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve el valor de una propiedad de un nodo

  • « svn_fs_node_created_rev
  • svn_fs_props_changed »
  • PHP Manual
  • Funciones SVN
  • Devuelve el valor de una propiedad de un nodo

svn_fs_node_prop

(PECL svn >= 0.1.0)

svn_fs_node_prop — Devuelve el valor de una propiedad de un nodo

Descripción

svn_fs_node_prop ( resource $fsroot , string $path , string $propname ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el valor de una propiedad de un nodo

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve verdadero si las propiedades son diferentes, falso en caso contrario

  • « svn_fs_node_prop
  • svn_fs_revision_prop »
  • PHP Manual
  • Funciones SVN
  • Devuelve verdadero si las propiedades son diferentes, falso en caso contrario

svn_fs_props_changed

(PECL svn >= 0.2.0)

svn_fs_props_changed — Devuelve verdadero si las propiedades son diferentes, falso en caso contrario

Descripción

svn_fs_props_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve verdadero si las propiedades son diferentes, falso en caso contrario

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Recupera el valor de una propiedad con determinado nombre

  • « svn_fs_props_changed
  • svn_fs_revision_root »
  • PHP Manual
  • Funciones SVN
  • Recupera el valor de una propiedad con determinado nombre

svn_fs_revision_prop

(PECL svn >= 0.1.0)

svn_fs_revision_prop — Recupera el valor de una propiedad con determinado nombre

Descripción

svn_fs_revision_prop ( resource $fs , int $revnum , string $propname ) : string
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Recupera el valor de una propiedad con determinado nombre

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtiene un gestor en una versión específica del repositorio 'root'

  • « svn_fs_revision_prop
  • svn_fs_txn_root »
  • PHP Manual
  • Funciones SVN
  • Obtiene un gestor en una versión específica del repositorio 'root'

svn_fs_revision_root

(PECL svn >= 0.1.0)

svn_fs_revision_root — Obtiene un gestor en una versión específica del repositorio 'root'

Descripción

svn_fs_revision_root ( resource $fs , int $revnum ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene un gestor en una versión específica del repositorio 'root'

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea y retorna una transacción 'root'

  • « svn_fs_revision_root
  • svn_fs_youngest_rev »
  • PHP Manual
  • Funciones SVN
  • Crea y retorna una transacción 'root'

svn_fs_txn_root

(PECL svn >= 0.2.0)

svn_fs_txn_root — Crea y retorna una transacción 'root'

Descripción

svn_fs_txn_root ( resource $txn ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea y retorna una transacción 'root'

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Devuelve el número de la revisión más reciente del sistema de ficheros

  • « svn_fs_txn_root
  • svn_import »
  • PHP Manual
  • Funciones SVN
  • Devuelve el número de la revisión más reciente del sistema de ficheros

svn_fs_youngest_rev

(PECL svn >= 0.1.0)

svn_fs_youngest_rev — Devuelve el número de la revisión más reciente del sistema de ficheros

Descripción

svn_fs_youngest_rev ( resource $fs ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Devuelve el número de la revisión más reciente del sistema de ficheros

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Importa una ruta de acceso sin versión, dentro de un repositorio

  • « svn_fs_youngest_rev
  • svn_log »
  • PHP Manual
  • Funciones SVN
  • Importa una ruta de acceso sin versión, dentro de un repositorio

svn_import

(PECL svn >= 0.2.0)

svn_import — Importa una ruta de acceso sin versión, dentro de un repositorio

Descripción

svn_import ( string $path , string $url , bool $nonrecursive ) : bool

Consolida un path no versionado dentro de un repositorio en url. Si path es un directorio y nonrecursive es false, el directorio será importado recursivamente.

Parámetros

path

Ruta de acceso al fichero o directorio a importar.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

url

Repositorio URL dentro del que se importa.

nonrecursive

Si se realiza o no, el procesamiento recursivo de los directorios.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo muestra un caso de uso básico para esta función. Para importar un directorio llamado new-files dentro de un repositorio en la url http://www.example.com/svnroot/incoming/abc, utilizar:

<?php
svn_import(realpath('new-files'), 'http://www.example.com/svnroot/incoming/abc', false);
?>

Ver también

  • svn_add() - Programa la adición de un artículo en un directorio de trabajo
  • » Documentación SVN para importación svn


Devuelve el log histórico de mensajes de un repositorio URL

  • « svn_import
  • svn_ls »
  • PHP Manual
  • Funciones SVN
  • Devuelve el log histórico de mensajes de un repositorio URL

svn_log

(PECL svn >= 0.1.0)

svn_log — Devuelve el log histórico de mensajes de un repositorio URL

Descripción

svn_log ( string $repos_url , int $start_revision = ? , int $end_revision = ? , int $limit = 0 , int $flags = SVN_DISCOVER_CHANGED_PATHS | SVN_STOP_ON_COPY ) : array

svn_log() devuelve el histórico completo de un elemento del repositorio URL repos_url, o el histórico de una revisión específica si start_revision se ha especificado. Esta función es equivalente a svn log --verbose -r $start_revision $repos_url.

Parámetros

repos_url

Repositorio URL del elemento del que se obtendrá el log histórico.

start_revision

Número de revisión del primer log a obtener. Usar SVN_REVISION_HEAD para obtener el log de la revisión más reciente.

end_revision

Número de revisión del último log a obtener. Por defecto es start_revision si se especifica, o SVN_REVISION_INITIAL en caso contrario.

limit

Número de logs a obtener.

flags

Cualquier combinación de SVN_OMIT_MESSAGES, SVN_DISCOVER_CHANGED_PATHS y SVN_STOP_ON_COPY.

Valores devueltos

En caso de éxito, esta función devuelve un array con el siguiente formato :

[0] => Array, ordenado mostrando la revisión más reciente (la mayor) primero
(
    [rev] => integer número de revisión
    [author] => string nombre del autor
    [msg] => string log del mensaje
    [date] => string fecha formateada por ISO 8601, p.e. date('c')
    [paths] => Array, descripción de los ficheros cambiados
        (
            [0] => Array
                (
                    [action] => string letra que indica el cambio
                    [path] =>  path absoluto del repositorio de un fichero cambiado
                )
            [1] => ...
        )
)
[1] => ...

Nota:

La salida siempre será un array de arrays indexado numéricamente, incluso cuando no haya ninguno o sólo un log de mensaje(s).

El valor de action es un subconjunto de » con el estado de salida en la primer columna, donde los valores posibles son:

Actions
Letter | Description
M | Elemento/propiedad fue modificada
A | Elemento fue añadido
D | Elemento fue borrado
R | Elemento fue reemplazado

Si no se hizo ningún cambio al elemento, se devolverá un array vacío.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 svn_log() example

<?php
print_r( svn_log('http://www.example.com/', 23) );
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
    (
        [rev] => 23
        [author] => 'joe'
        [msg] => 'Add cheese and salami to our sandwich.'
        [date] => '2007-04-06T16:00:27-04:00'
        [paths] => Array
            (
                [0] => Array
                    (
                        [action] => 'M'
                        [path] =>  '/sandwich.txt'
                    )
            )
    )
)

Ver también

  • » Documentación SVN para svn log


Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión

  • « svn_log
  • svn_mkdir »
  • PHP Manual
  • Funciones SVN
  • Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión

svn_ls

(PECL svn >= 0.1.0)

svn_ls — Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión

Descripción

svn_ls ( string $repos_url , int $revision_no = SVN_REVISION_HEAD , bool $recurse = false , bool $peg = false ) : array

Esta función consulta el repositorio URL y devuelve una lista de ficheros y directorios, opcionalmente de una revisión específica. Es equivalente a svn list $repos_url[@$revision_no]

Nota:

Esta función no funciona con copias de trabajo. repos_url debe ser un repositorio URL.

Parámetros

url

URL del repositorio, p.e. http://www.example.com/svnroot. Para acceder a la subversión local del repositorio vía sistema de ficheros, utilizar el esquema de ficheros URI, p.e. file:///home/user/svn-repos

revision

Entero con el número de la revisión de la que se obtendrá el listado. Si se omite, se utilizará la revisión HEAD.

recurse

Activa la recursividad.

Valores devueltos

En caso de éxito, esta función devuelve un fichero con arrays con el siguiente formato :

[0] => Array
    (
        [created_rev] => integer número de revisión de la última edición
        [last_author] => string nombre del autor de la última edición
        [size] => integer tamaño del fichero en bytes
        [time] => string fecha de la última edición en el formato 'M d H:i'
                  o 'M d Y', dependiendo de la antiguedad del fichero
        [time_t] => integer timestamp de unix de la última edición
        [name] => nombre del fichero/directorio
        [type] => tipo, puede ser 'file' o 'dir'
    )
[1] => ...

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 svn_ls() example

<?php
print_r( svn_ls('http://www.example.com/svnroot/') );
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Array
        (
            [created_rev] => 20
            [last_author] => Joe
            [size] => 0
            [time] => Apr 02 09:28
            [time_t] => 1175520529
            [name] => tags
            [type] => dir
        )
    [1] => Array
        (
            [created_rev] => 23
            [last_author] => Bob
            [size] => 0
            [time] => Apr 02 15:15
            [time_t] => 1175541322
            [name] => trunk
            [type] => dir
        )
)

Ver también

  • » Documentación SVN de svn list


Crea un directorio en la copia de trabajo actual o repositorio

  • « svn_ls
  • svn_repos_create »
  • PHP Manual
  • Funciones SVN
  • Crea un directorio en la copia de trabajo actual o repositorio

svn_mkdir

(PECL svn >= 0.4.0)

svn_mkdir — Crea un directorio en la copia de trabajo actual o repositorio

Descripción

svn_mkdir ( string $path , string $log_message = ? ) : bool

Crea un directorio en la copia de trabajo o repositorio.

Parámetros

path

La ruta a la copia de trabajo o repositorio.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • svn_add() - Programa la adición de un artículo en un directorio de trabajo
  • svn_copy()


Crea un nuevo repositorio de subversión

  • « svn_mkdir
  • svn_repos_fs_begin_txn_for_commit »
  • PHP Manual
  • Funciones SVN
  • Crea un nuevo repositorio de subversión

svn_repos_create

(PECL svn >= 0.1.0)

svn_repos_create — Crea un nuevo repositorio de subversión

Descripción

svn_repos_create ( string $path , array $config = ? , array $fsconfig = ? ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea un nuevo repositorio de subversión en un path determinado.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Crea una nueva transacción

  • « svn_repos_create
  • svn_repos_fs_commit_txn »
  • PHP Manual
  • Funciones SVN
  • Crea una nueva transacción

svn_repos_fs_begin_txn_for_commit

(PECL svn >= 0.2.0)

svn_repos_fs_begin_txn_for_commit — Crea una nueva transacción

Descripción

svn_repos_fs_begin_txn_for_commit ( resource $repos , int $rev , string $author , string $log_msg ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Crea una nueva transacción

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Consolida una transacción y devuelve la nueva revisión

  • « svn_repos_fs_begin_txn_for_commit
  • svn_repos_fs »
  • PHP Manual
  • Funciones SVN
  • Consolida una transacción y devuelve la nueva revisión

svn_repos_fs_commit_txn

(PECL svn >= 0.2.0)

svn_repos_fs_commit_txn — Consolida una transacción y devuelve la nueva revisión

Descripción

svn_repos_fs_commit_txn ( resource $txn ) : int
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Consolida una transacción y devuelve la nueva revisión

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Obtiene un gestor del sistema de ficheros para un repositorio

  • « svn_repos_fs_commit_txn
  • svn_repos_hotcopy »
  • PHP Manual
  • Funciones SVN
  • Obtiene un gestor del sistema de ficheros para un repositorio

svn_repos_fs

(PECL svn >= 0.1.0)

svn_repos_fs — Obtiene un gestor del sistema de ficheros para un repositorio

Descripción

svn_repos_fs ( resource $repos ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Obtiene un gestor del sistema de ficheros para un repositorio

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath

  • « svn_repos_fs
  • svn_repos_open »
  • PHP Manual
  • Funciones SVN
  • Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath

svn_repos_hotcopy

(PECL svn >= 0.1.0)

svn_repos_hotcopy — Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath

Descripción

svn_repos_hotcopy ( string $repospath , string $destpath , bool $cleanlogs ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Abre una cerradura compartida en un repositorio

  • « svn_repos_hotcopy
  • svn_repos_recover »
  • PHP Manual
  • Funciones SVN
  • Abre una cerradura compartida en un repositorio

svn_repos_open

(PECL svn >= 0.1.0)

svn_repos_open — Abre una cerradura compartida en un repositorio

Descripción

svn_repos_open ( string $path ) : resource
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Abre una cerradura compartida en un repositorio.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado

  • « svn_repos_open
  • svn_revert »
  • PHP Manual
  • Funciones SVN
  • Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado

svn_repos_recover

(PECL svn >= 0.1.0)

svn_repos_recover — Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado

Descripción

svn_repos_recover ( string $path ) : bool
Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.


Deshace los cambios en la copia de trabajo

  • « svn_repos_recover
  • svn_status »
  • PHP Manual
  • Funciones SVN
  • Deshace los cambios en la copia de trabajo

svn_revert

(PECL svn >= 0.3.0)

svn_revert — Deshace los cambios en la copia de trabajo

Descripción

svn_revert ( string $path , bool $recursive = false ) : bool

Deshace cualquier cambio local de la ruta en la copia de trabajo.

Parámetros

path

La ruta del repositorio de trabajo.

recursive

Hacer cambios de forma recursiva, opcional.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • svn_delete() - Elimina ítems de una copia de trabajo o repositorio
  • svn_export() - Exporta el contenido de un directorio SVN


Devuelve el estado de la copia de trabajo de los ficheros y directorios

  • « svn_revert
  • svn_update »
  • PHP Manual
  • Funciones SVN
  • Devuelve el estado de la copia de trabajo de los ficheros y directorios

svn_status

(PECL svn >= 0.1.0)

svn_status — Devuelve el estado de la copia de trabajo de los ficheros y directorios

Descripción

svn_status ( string $path , int $flags = 0 ) : array

Devuelve el estado de la copia de trabajo de los ficheros y directorios, dando las modificaciones, adiciones, borrados y otros cambios a los elementos de la copia de trabajo.

Parámetros

path

Path local al fichero o directorio del que se obtendrá el estado.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

flags

Cualquier combinación de SVN_NON_RECURSIVE, SVN_ALL (independientemente del estado de modificación), SVN_SHOW_UPDATES (se añadirán entradas para los elementos que estan desactualizados), SVN_NO_IGNORE (ignorar svn:ignore las propiedades cuando se busquen nuevos ficheros) y SVN_IGNORE_EXTERNALS.

Valores devueltos

Devuelve un array de arrays asociativos indexado numéricamente, detallando el estado de los elementos del repositorio:

Array (
    [0] => Array (
        // información del elemento
    )
    [1] => ...
)

La información del elemento es un array asociativo que puede contener las siguientes claves:

path
String con el path al fichero/directorio de esta entrada en el sistema de ficheros local.
text_status
Estado del texto del elemento. Referirse a constantes de estado para posibles valores.
repos_text_status
Estado del texto del elemento en el repositorio. Sólo es exacto si update se definió a true. Referirse a constantes de estado para posibles valores.
prop_status
Estado de las propiedades del elemento. Referirse a constantes de estado para posibles valores.
repos_prop_status
Estado de la propiedad del elemento en el repositorio. Sólo exacto si update se definió a true. Referirse a constantes de estado para posibles valores.
locked
Si el elemento está bloqueado o no. (Sólo definido si true.)
copied
Si el elemento fue copiado o no (planificado para adición con histórico). (Sólo definido si true.)
switched
Si el elemento fue intercambiado con el comando switch. (Sólo definido si true)

Estas claves sólo estan definidas si el elemento está versionado:

name
Nombre de base del elemento en el repositorio.
url
URL del elemento en el repositorio.
repos
URL base del repositorio.
revision
Entero con la revisión del elemento en la copia de trabajo.
kind
Tipo de elemento, p.e. fichero o directorio. Referirse a constantes de tipo para posibles valores.
schedule
Acción planificada para el elemento, p.e. adición o eliminación. Las constantes para estos números mágicos no estan disponibles, pueden ser emuladas utilizando:
<?php
if (!defined('svn_wc_schedule_normal')) {
    define('svn_wc_schedule_normal',  0); // nada especial
    define('svn_wc_schedule_add',     1); // elemento será añadido
    define('svn_wc_schedule_delete',  2); // elemento será eliminado
    define('svn_wc_schedule_replace', 3); // elemento será reemplazado
}
?>
deleted
Si el elemento fue eliminado o no, pero las revisiones previas existen todavía. (Sólo definido si true.)
absent
Si el elemento está ausente o no, es decir, Subversion sabe que debería haber algo pero no está. (Sólo definido si true.)
incomplete
Si las entradas del fichero o directorio están incompletas o no. (Sólo definido si true.)
cmt_date
Entero con el timestamp de Unix con la última fecha de commit. (No afectado por el parámetro update.)
cmt_rev
Entero con la revisión del último commit. (No afectado por el parámetro update.)
cmt_author
String con el autor del último commit. (No afectado por el parámetro update.)
prop_time
Entero con el timestamp de Unix con el último tiempo de actualización de las propiedades
text_time
Entero con el timestamp de Unix del último tiempo de actualización para el texto

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo muestra un uso básico, teórico de esta función.

<?php
print_r(svn_status(realpath('wc')));
?>

El resultado del ejemplo sería algo similar a:

Array (
    [0] => Array (
        [path] => /home/bob/wc/sandwich.txt
        [text_status] => 8 // elemento que fue modificado
        [repos_text_status] => 1 // sin información disponible, usar update
        [prop_status] => 3 // sin cambios
        [repos_prop_status] => 1 // sin información disponible, usar update
        [name] => sandwich.txt
        [url] => http://www.example.com/svnroot/deli/trunk/sandwich.txt
        [repos] => http://www.example.com/svnroot/
        [revision] => 123
        [kind] => 1 // fichero
        [schedule] => 0 // sin acciones especiales planificadas
        [cmt_date] => 1165543135
        [cmt_rev] => 120
        [cmt_author] => Alice
        [prop_time] => 1180201728
        [text_time] => 1180201729
    )
)

Ver también

  • svn_update() - Actualiza la copia de trabajo
  • svn_log() - Devuelve el log histórico de mensajes de un repositorio URL
  • » Documentación SVN para svn status


Actualiza la copia de trabajo

  • « svn_status
  • TCP »
  • PHP Manual
  • Funciones SVN
  • Actualiza la copia de trabajo

svn_update

(PECL svn >= 0.1.0)

svn_update — Actualiza la copia de trabajo

Descripción

svn_update ( string $path , int $revno = SVN_REVISION_HEAD , bool $recurse = true ) : int

Actualiza la copia de trabajo en path a la revisión revno. Si recurse es true, los directorios serán actualizados recursivamente.

Parámetros

path

Ruta a la copia de trabajo local.

Nota: Las rutas relativas se resolverán como si el directorio de trabajo actual es el que contiene el binario de PHP. Para utilizar el directorio de trabajo que contiene el script a llamar, use realpath() o dirname(__FILE__).

revno

Número de revisión a actualziar, por omisión es SVN_REVISION_HEAD.

recurse

Si se actualizan o no recursivamente directorios.

Valores devueltos

Devuelve un nuevo número de revisión en caso de tener éxito, devuelve false al fallar.

Notas

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ejemplos

Ejemplo #1 Ejemplo básico

Este ejemplo demuestra el uso básico de esta función:

<?php
echo svn_update(realpath('working-copy'));
?>

El resultado del ejemplo sería algo similar a:

234

Ver también

  • svn_checkout() - Descarga una copia de trabajo desde el repositorio
  • svn_commit() - Envía los cambios desde el directorio local de trabajo al repositorio
  • » SVN documentation for svn update


Envolturas TCP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • TCP Funciones
    • tcpwrap_check — Realiza una comprobación tcpwrap


Introducción

Las envolturas de TCP proporciona un mecanismo clásico de Unix que ha sido diseñado para comprobar si el cliente remoto es capaz de conectarse a la dirección IP dada.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/tcpwrap.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


  • « Tipos de recursos
  • TCP Funciones »
  • PHP Manual
  • TCP
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • tcpwrap_check »
  • PHP Manual
  • TCP
  • TCP Funciones

TCP Funciones

Tabla de contenidos

  • tcpwrap_check — Realiza una comprobación tcpwrap


Realiza una comprobación tcpwrap

  • « TCP Funciones
  • Varnish »
  • PHP Manual
  • TCP Funciones
  • Realiza una comprobación tcpwrap

tcpwrap_check

(PECL tcpwrap >= 0.1.0)

tcpwrap_check — Realiza una comprobación tcpwrap

Descripción

tcpwrap_check ( string $daemon , string $address , string $user = ? , bool $nodns = false ) : bool

Esta función consulta los ficheros /etc/hosts.allow y /etc/hosts.deny para comprobar si el acceso al servicio daemon debería permitirse o denegarse a un cliente.

Parámetros

daemon

El nombre del servicio.

address

La dirección remota del cliente. Puede ser una dirección IP o un nombre de dominio.

user

Un nombre de usuario opcional.

nodns

Si address es un nombre de dominio, se empleará el DNS para resolverlo a una dirección IP; establezca nodns a true para evitar este comportamiento.

Valores devueltos

Esta función devuelve true si se debería permitir el acceso, false si no.

Ejemplos

Ejemplo #1 Denegar todas las conexiones desde localhost

Si el fichero /etc/hosts.deny contiene:

php: 127.0.0.1

Y el código es silmiar al siguiente:

<?php
if (!tcpwrap_check('php', $_SERVER['REMOTE_ADDR'])) {
  die('No es bienvenido aquí');
}
?>

Ver también

Para más detalles, consulte la página del manual de hosts_access(3).


Varnish

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso Básico de VarnishAdmin
    • Uso básico de VarnishStat
    • Uso básico de VarnishLog
  • VarnishAdmin — La clase VarnishAdmin
    • VarnishAdmin::auth — Autentificar en una instancia de varnish
    • VarnishAdmin::ban — Prohibe URLs usando una expresión VCL
    • VarnishAdmin::banUrl — Prohibe una URL usando una expresión VCL
    • VarnishAdmin::clearPanic — Limpia mensajes de pánico de la instancia varnish
    • VarnishAdmin::connect — Conectarse a una interfaz de administración de instancias de varnish
    • VarnishAdmin::__construct — VarnishAdmin constructor
    • VarnishAdmin::disconnect — Desconecta interfaz de administración de la instancia de varnish
    • VarnishAdmin::getPanic — Obtener el último mensaje de pánico en una instancia varnish
    • VarnishAdmin::getParams — Busca los parámetros de configuración de la instancia varnish actual
    • VarnishAdmin::isRunning — Comprueba si el proceso varnish esclavo está actualmente en marcha
    • VarnishAdmin::setCompat — Establece el parámetro de configuración de la clase compacta
    • VarnishAdmin::setHost — Establece el parámetro de configuración del host de la clase
    • VarnishAdmin::setIdent — Establece el parámetro de configuración de la identificación de la clase
    • VarnishAdmin::setParam — Establece los parámetros de configuración en la instancia varnish actual
    • VarnishAdmin::setPort — Establece el parámetro de configuración del puerto de clase
    • VarnishAdmin::setSecret — Establece los parámetros secretos de configuración de la clase
    • VarnishAdmin::setTimeout — Configura el parámetro de tiempo de espera de la clase
    • VarnishAdmin::start — Iniciar el proceso de varnish
    • VarnishAdmin::stop — Detener el proceso de varnish
  • VarnishStat — La clase VarnishStat
    • VarnishStat::__construct — Constructor VarnishStat
    • VarnishStat::getSnapshot — Obtener la instantánea actual de las estadísticas de instancia varnish
  • VarnishLog — La clase VarnishLog
    • VarnishLog::__construct — Constructor de Varnishlog
    • VarnishLog::getLine — Obtiene la siguiente línea de registro
    • VarnishLog::getTagName — Obtener la etiqueta de registro representada por su índice


Introducción

Varnish Cache es un acelerador de aplicaciones web de última generación de código abierto. La extensión permite interactuar con una instancia de varnish en ejecución a través de un socket TCP o de memoria compartida.


Requerimientos

Para utilizar esta extensión, es necesario tener instalada la versión >=3.0 de Varnish Cache, disponible en la » página principal Varnish Cache


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/varnish.

Está disponible una DLL para esta extensión de PECL en » http://windows.php.net/downloads/pecl/releases/varnish/.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

VARNISH_STATUS_SYNTAX (integer)
VARNISH_STATUS_UNKNOWN (integer)
VARNISH_STATUS_UNIMPL (integer)
VARNISH_STATUS_TOOFEW (integer)
VARNISH_STATUS_TOOMANY (integer)
VARNISH_STATUS_PARAM (integer)
VARNISH_STATUS_AUTH (integer)
VARNISH_STATUS_OK (integer)
VARNISH_STATUS_CANT (integer)
VARNISH_STATUS_COMMS (integer)
VARNISH_STATUS_CLOSE (integer)
VARNISH_CONFIG_IDENT (string)
VARNISH_CONFIG_HOST (string)
VARNISH_CONFIG_PORT (string)
VARNISH_CONFIG_TIMEOUT (string)
VARNISH_CONFIG_SECRET (string)
VARNISH_CONFIG_COMPAT (string)
VARNISH_COMPAT_2 (integer)
VARNISH_COMPAT_3 (integer)


Ejemplos

Tabla de contenidos

  • Uso Básico de VarnishAdmin
  • Uso básico de VarnishStat
  • Uso básico de VarnishLog


Uso Básico de VarnishAdmin

El ejemplo muestra un uso sencillo de la funcionalidad de prohibición

Ejemplo #1 Prohibición de una URL

<?php

$args = array(
    VARNISH_CONFIG_HOST    => "::1",
    VARNISH_CONFIG_PORT    => 6082,
    VARNISH_CONFIG_SECRET  => "5174826b-8595-4958-aa7a-0609632ad7ca",
    VARNISH_CONFIG_TIMEOUT => 300,
);

$va = new VarnishAdmin($args);

try {
    if(!$va->connect()) {
        throw new VarnishException("Conexión fallida\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    if(!$va->auth()) {
        throw new VarnishException("Autorización fallida\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    $estado = $va->ban('req.url ~ "^/$"');
    if (VARNISH_STATUS_OK != $estado) {
        throw new VarnishException("El método ban devolvió el estado $estado\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);

?>


Uso básico de VarnishStat

El ejemplo muestra la obtención de una instantánea de las estadísticas de varnish de memoria compartida

Ejemplo #1 Obtención de una instantánea de las estadísticas

<?php

$vs = new VarnishStat;

try {
    $data = $vs->getSnapshot();
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);
?>


Uso básico de VarnishLog

El ejemplo muestra la lectura de líneas del registro de varnish de memoria compartida

Ejemplo #1 Lectura del log de varnish en la memoria compartida

<?php

$vl = new VarnishLog;
while(1) {
    $line = $vl->getLine();
    printf("%s %d %s", VarnishLog::getTagName($line['tag'], $line['id'],
    $line['data']);
}

exit(0);
?>


La clase VarnishAdmin

(PECL varnish >= 0.3)

Introducción

Sinopsis de la Clase

VarnishAdmin {
/* Métodos */
public auth ( ) : bool
public ban ( string $vcl_regex ) : int
public banUrl ( string $vcl_regex ) : int
public clearPanic ( ) : int
public connect ( ) : bool
public __construct ( array $args = ? )
public disconnect ( ) : bool
public getPanic ( ) : string
public getParams ( ) : array
public isRunning ( ) : bool
public setCompat ( int $compat ) : void
public setHost ( string $host ) : void
public setIdent ( string $ident ) : void
public setParam ( string $name , string|integer $value ) : int
public setPort ( int $port ) : void
public setSecret ( string $secret ) : void
public setTimeout ( int $timeout ) : void
public start ( ) : int
public stop ( ) : int
}

Tabla de contenidos

  • VarnishAdmin::auth — Autentificar en una instancia de varnish
  • VarnishAdmin::ban — Prohibe URLs usando una expresión VCL
  • VarnishAdmin::banUrl — Prohibe una URL usando una expresión VCL
  • VarnishAdmin::clearPanic — Limpia mensajes de pánico de la instancia varnish
  • VarnishAdmin::connect — Conectarse a una interfaz de administración de instancias de varnish
  • VarnishAdmin::__construct — VarnishAdmin constructor
  • VarnishAdmin::disconnect — Desconecta interfaz de administración de la instancia de varnish
  • VarnishAdmin::getPanic — Obtener el último mensaje de pánico en una instancia varnish
  • VarnishAdmin::getParams — Busca los parámetros de configuración de la instancia varnish actual
  • VarnishAdmin::isRunning — Comprueba si el proceso varnish esclavo está actualmente en marcha
  • VarnishAdmin::setCompat — Establece el parámetro de configuración de la clase compacta
  • VarnishAdmin::setHost — Establece el parámetro de configuración del host de la clase
  • VarnishAdmin::setIdent — Establece el parámetro de configuración de la identificación de la clase
  • VarnishAdmin::setParam — Establece los parámetros de configuración en la instancia varnish actual
  • VarnishAdmin::setPort — Establece el parámetro de configuración del puerto de clase
  • VarnishAdmin::setSecret — Establece los parámetros secretos de configuración de la clase
  • VarnishAdmin::setTimeout — Configura el parámetro de tiempo de espera de la clase
  • VarnishAdmin::start — Iniciar el proceso de varnish
  • VarnishAdmin::stop — Detener el proceso de varnish


Autentificar en una instancia de varnish

  • « VarnishAdmin
  • VarnishAdmin::ban »
  • PHP Manual
  • VarnishAdmin
  • Autentificar en una instancia de varnish

VarnishAdmin::auth

(PECL varnish >= 0.3)

VarnishAdmin::auth — Autentificar en una instancia de varnish

Descripción

public VarnishAdmin::auth ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Prohibe URLs usando una expresión VCL

  • « VarnishAdmin::auth
  • VarnishAdmin::banUrl »
  • PHP Manual
  • VarnishAdmin
  • Prohibe URLs usando una expresión VCL

VarnishAdmin::ban

(PECL varnish >= 0.3)

VarnishAdmin::ban — Prohibe URLs usando una expresión VCL

Descripción

public VarnishAdmin::ban ( string $vcl_regex ) : int

Parámetros

vcl_regex

expresión VCL de Varnish. Se basa en el comando de prohibición de varnish.

Valores devueltos

Devuelve el estado de comando de varnish.


Prohibe una URL usando una expresión VCL

  • « VarnishAdmin::ban
  • VarnishAdmin::clearPanic »
  • PHP Manual
  • VarnishAdmin
  • Prohibe una URL usando una expresión VCL

VarnishAdmin::banUrl

(PECL varnish >= 0.3)

VarnishAdmin::banUrl — Prohibe una URL usando una expresión VCL

Descripción

public VarnishAdmin::banUrl ( string $vcl_regex ) : int

Parámetros

vcl_regex

Expresión regular de URL en sintaxis compatible con PCRE. Está basado en el comando de varnish ban.url.

Valores devueltos

Devuelve el estado de comando varnish.


Limpia mensajes de pánico de la instancia varnish

  • « VarnishAdmin::banUrl
  • VarnishAdmin::connect »
  • PHP Manual
  • VarnishAdmin
  • Limpia mensajes de pánico de la instancia varnish

VarnishAdmin::clearPanic

(PECL varnish >= 0.4)

VarnishAdmin::clearPanic — Limpia mensajes de pánico de la instancia varnish

Descripción

public VarnishAdmin::clearPanic ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el estado de comando varnish.


Conectarse a una interfaz de administración de instancias de varnish

  • « VarnishAdmin::clearPanic
  • VarnishAdmin::__construct »
  • PHP Manual
  • VarnishAdmin
  • Conectarse a una interfaz de administración de instancias de varnish

VarnishAdmin::connect

(PECL varnish >= 0.3)

VarnishAdmin::connect — Conectarse a una interfaz de administración de instancias de varnish

Descripción

public VarnishAdmin::connect ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


VarnishAdmin constructor

  • « VarnishAdmin::connect
  • VarnishAdmin::disconnect »
  • PHP Manual
  • VarnishAdmin
  • VarnishAdmin constructor

VarnishAdmin::__construct

(PECL varnish >= 0.3)

VarnishAdmin::__construct — VarnishAdmin constructor

Descripción

public VarnishAdmin::__construct ( array $args = ? )

Parámetros

args

Argumentos de configuración. Las posibles claves son:

VARNISH_CONFIG_IDENT - local varnish instance ident
VARNISH_CONFIG_HOST - varnish instance ip
VARNISH_CONFIG_PORT - varnish instance port
VARNISH_CONFIG_SECRET - varnish instance secret
VARNISH_CONFIG_TIMEOUT - connection read timeout
VARNISH_CONFIG_COMPAT - varnish major version compatibility

Valores devueltos

Ejemplos

Ejemplo #1 ejemplo de VarnishAdmin::__construct()

<?php
    $args = array(
        VARNISH_CONFIG_HOST => "::1",
        VARNISH_CONFIG_PORT => 6082,
        VARNISH_CONFIG_SECRET => "5174826b-8595-4958-aa7a-0609632ad7ca",
        VARNISH_CONFIG_TIMEOUT => 300,
    );
    $va = new VarnishAdmin($args);
?>


Desconecta interfaz de administración de la instancia de varnish

  • « VarnishAdmin::__construct
  • VarnishAdmin::getPanic »
  • PHP Manual
  • VarnishAdmin
  • Desconecta interfaz de administración de la instancia de varnish

VarnishAdmin::disconnect

(PECL varnish >= 1.0.0)

VarnishAdmin::disconnect — Desconecta interfaz de administración de la instancia de varnish

Descripción

public VarnishAdmin::disconnect ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener el último mensaje de pánico en una instancia varnish

  • « VarnishAdmin::disconnect
  • VarnishAdmin::getParams »
  • PHP Manual
  • VarnishAdmin
  • Obtener el último mensaje de pánico en una instancia varnish

VarnishAdmin::getPanic

(PECL varnish >= 0.4)

VarnishAdmin::getPanic — Obtener el último mensaje de pánico en una instancia varnish

Descripción

public VarnishAdmin::getPanic ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el último mensaje de pánico en la instancia varnish actual.


Busca los parámetros de configuración de la instancia varnish actual

  • « VarnishAdmin::getPanic
  • VarnishAdmin::isRunning »
  • PHP Manual
  • VarnishAdmin
  • Busca los parámetros de configuración de la instancia varnish actual

VarnishAdmin::getParams

(PECL varnish >= 0.4)

VarnishAdmin::getParams — Busca los parámetros de configuración de la instancia varnish actual

Descripción

public VarnishAdmin::getParams ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con los parámetros de configuración varnish.


Comprueba si el proceso varnish esclavo está actualmente en marcha

  • « VarnishAdmin::getParams
  • VarnishAdmin::setCompat »
  • PHP Manual
  • VarnishAdmin
  • Comprueba si el proceso varnish esclavo está actualmente en marcha

VarnishAdmin::isRunning

(PECL varnish >= 0.3)

VarnishAdmin::isRunning — Comprueba si el proceso varnish esclavo está actualmente en marcha

Descripción

public VarnishAdmin::isRunning ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece el parámetro de configuración de la clase compacta

  • « VarnishAdmin::isRunning
  • VarnishAdmin::setHost »
  • PHP Manual
  • VarnishAdmin
  • Establece el parámetro de configuración de la clase compacta

VarnishAdmin::setCompat

(PECL varnish >= 0.9.2)

VarnishAdmin::setCompat — Establece el parámetro de configuración de la clase compacta

Descripción

public VarnishAdmin::setCompat ( int $compat ) : void

Parámetros

compat

Opción de compatibilidad de varnish.

Valores devueltos


Establece el parámetro de configuración del host de la clase

  • « VarnishAdmin::setCompat
  • VarnishAdmin::setIdent »
  • PHP Manual
  • VarnishAdmin
  • Establece el parámetro de configuración del host de la clase

VarnishAdmin::setHost

(PECL varnish >= 0.8)

VarnishAdmin::setHost — Establece el parámetro de configuración del host de la clase

Descripción

public VarnishAdmin::setHost ( string $host ) : void

Parámetros

host

Parámetro de configuración del host de la conexión.

Valores devueltos


Establece el parámetro de configuración de la identificación de la clase

  • « VarnishAdmin::setHost
  • VarnishAdmin::setParam »
  • PHP Manual
  • VarnishAdmin
  • Establece el parámetro de configuración de la identificación de la clase

VarnishAdmin::setIdent

(PECL varnish >= 0.8)

VarnishAdmin::setIdent — Establece el parámetro de configuración de la identificación de la clase

Descripción

public VarnishAdmin::setIdent ( string $ident ) : void

Parámetros

ident

Parámetro de configuración de la identificación de la conexión.

Valores devueltos


Establece los parámetros de configuración en la instancia varnish actual

  • « VarnishAdmin::setIdent
  • VarnishAdmin::setPort »
  • PHP Manual
  • VarnishAdmin
  • Establece los parámetros de configuración en la instancia varnish actual

VarnishAdmin::setParam

(PECL varnish >= 0.4)

VarnishAdmin::setParam — Establece los parámetros de configuración en la instancia varnish actual

Descripción

public VarnishAdmin::setParam ( string $name , string|integer $value ) : int

Parámetros

name

Nombre del parámetro de configuración varnish.

value

Valor del parámetro de configuración varnish.

Valores devueltos

Devuelve el estado de comando varnish.


Establece el parámetro de configuración del puerto de clase

  • « VarnishAdmin::setParam
  • VarnishAdmin::setSecret »
  • PHP Manual
  • VarnishAdmin
  • Establece el parámetro de configuración del puerto de clase

VarnishAdmin::setPort

(PECL varnish >= 0.8)

VarnishAdmin::setPort — Establece el parámetro de configuración del puerto de clase

Descripción

public VarnishAdmin::setPort ( int $port ) : void

Parámetros

port

Parámetro de configuración del puerto de conexión.

Valores devueltos


Establece los parámetros secretos de configuración de la clase

  • « VarnishAdmin::setPort
  • VarnishAdmin::setTimeout »
  • PHP Manual
  • VarnishAdmin
  • Establece los parámetros secretos de configuración de la clase

VarnishAdmin::setSecret

(PECL varnish >= 0.8)

VarnishAdmin::setSecret — Establece los parámetros secretos de configuración de la clase

Descripción

public VarnishAdmin::setSecret ( string $secret ) : void

Parámetros

secret

Parámetro secreto de configuración de la conexión.

Valores devueltos


Configura el parámetro de tiempo de espera de la clase

  • « VarnishAdmin::setSecret
  • VarnishAdmin::start »
  • PHP Manual
  • VarnishAdmin
  • Configura el parámetro de tiempo de espera de la clase

VarnishAdmin::setTimeout

(PECL varnish >= 0.8)

VarnishAdmin::setTimeout — Configura el parámetro de tiempo de espera de la clase

Descripción

public VarnishAdmin::setTimeout ( int $timeout ) : void

Parámetros

timeout

Parámetro de configuración del tiempo de espera de la conexión.

Valores devueltos


Iniciar el proceso de varnish

  • « VarnishAdmin::setTimeout
  • VarnishAdmin::stop »
  • PHP Manual
  • VarnishAdmin
  • Iniciar el proceso de varnish

VarnishAdmin::start

(PECL varnish >= 0.3)

VarnishAdmin::start — Iniciar el proceso de varnish

Descripción

public VarnishAdmin::start ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el estado de comando varnish.


Detener el proceso de varnish

  • « VarnishAdmin::start
  • VarnishStat »
  • PHP Manual
  • VarnishAdmin
  • Detener el proceso de varnish

VarnishAdmin::stop

(PECL varnish >= 0.3)

VarnishAdmin::stop — Detener el proceso de varnish

Descripción

public VarnishAdmin::stop ( ) : int

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el estado de comando de varnish.


La clase VarnishStat

(PECL varnish >= 0.3)

Introducción

Sinopsis de la Clase

VarnishStat {
/* Métodos */
public __construct ( array $args = ? )
public getSnapshot ( ) : array
}

Tabla de contenidos

  • VarnishStat::__construct — Constructor VarnishStat
  • VarnishStat::getSnapshot — Obtener la instantánea actual de las estadísticas de instancia varnish


Constructor VarnishStat

  • « VarnishStat
  • VarnishStat::getSnapshot »
  • PHP Manual
  • VarnishStat
  • Constructor VarnishStat

VarnishStat::__construct

(PECL varnish >= 0.3)

VarnishStat::__construct — Constructor VarnishStat

Descripción

public VarnishStat::__construct ( array $args = ? )

Parámetros

args

Argumentos de configuración. Las claves posibles son:

VARNISH_CONFIG_IDENT - local varnish instance ident path

Valores devueltos


Obtener la instantánea actual de las estadísticas de instancia varnish

  • « VarnishStat::__construct
  • VarnishLog »
  • PHP Manual
  • VarnishStat
  • Obtener la instantánea actual de las estadísticas de instancia varnish

VarnishStat::getSnapshot

(PECL varnish >= 0.3)

VarnishStat::getSnapshot — Obtener la instantánea actual de las estadísticas de instancia varnish

Descripción

public VarnishStat::getSnapshot ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array con la instantánea de las estadísticas varnish. Las claves del array son idénticas a los la herramienta varnishstat.


La clase VarnishLog

(PECL varnish >= 0.6)

Introducción

Sinopsis de la Clase

VarnishLog {
/* Constants */
const integer TAG_Debug = 0 ;
const integer TAG_Error = 1 ;
const integer TAG_CLI = 2 ;
const integer TAG_StatSess = 3 ;
const integer TAG_ReqEnd = 4 ;
const integer TAG_SessionOpen = 5 ;
const integer TAG_SessionClose = 6 ;
const integer TAG_BackendOpen = 7 ;
const integer TAG_BackendXID = 8 ;
const integer TAG_BackendReuse = 9 ;
const integer TAG_BackendClose = 10 ;
const integer TAG_HttpGarbage = 11 ;
const integer TAG_Backend = 12 ;
const integer TAG_Length = 13 ;
const integer TAG_FetchError = 14 ;
const integer TAG_RxRequest = 15 ;
const integer TAG_RxResponse = 16 ;
const integer TAG_RxStatus = 17 ;
const integer TAG_RxURL = 18 ;
const integer TAG_RxProtocol = 19 ;
const integer TAG_RxHeader = 20 ;
const integer TAG_TxRequest = 21 ;
const integer TAG_TxResponse = 22 ;
const integer TAG_TxStatus = 23 ;
const integer TAG_TxURL = 24 ;
const integer TAG_TxProtocol = 25 ;
const integer TAG_TxHeader = 26 ;
const integer TAG_ObjRequest = 27 ;
const integer TAG_ObjResponse = 28 ;
const integer TAG_ObjStatus = 29 ;
const integer TAG_ObjURL = 30 ;
const integer TAG_ObjProtocol = 31 ;
const integer TAG_ObjHeader = 32 ;
const integer TAG_LostHeader = 33 ;
const integer TAG_TTL = 34 ;
const integer TAG_Fetch_Body = 35 ;
const integer TAG_VCL_acl = 36 ;
const integer TAG_VCL_call = 37 ;
const integer TAG_VCL_trace = 38 ;
const integer TAG_VCL_return = 39 ;
const integer TAG_VCL_error = 40 ;
const integer TAG_ReqStart = 41 ;
const integer TAG_Hit = 42 ;
const integer TAG_HitPass = 43 ;
const integer TAG_ExpBan = 44 ;
const integer TAG_ExpKill = 45 ;
const integer TAG_WorkThread = 46 ;
const integer TAG_ESI_xmlerror = 47 ;
const integer TAG_Hash = 48 ;
const integer TAG_Backend_health = 49 ;
const integer TAG_VCL_Log = 50 ;
const integer TAG_Gzip = 51 ;
/* Métodos */
public __construct ( array $args = ? )
public getLine ( ) : array
public static getTagName ( int $index ) : string
}

Constantes predefinidas

VarnishLog::TAG_Debug

VarnishLog::TAG_Error

VarnishLog::TAG_CLI

VarnishLog::TAG_StatSess

VarnishLog::TAG_ReqEnd

VarnishLog::TAG_SessionOpen

VarnishLog::TAG_SessionClose

VarnishLog::TAG_BackendOpen

VarnishLog::TAG_BackendXID

VarnishLog::TAG_BackendReuse

VarnishLog::TAG_BackendClose

VarnishLog::TAG_HttpGarbage

VarnishLog::TAG_Backend

VarnishLog::TAG_Length

VarnishLog::TAG_FetchError

VarnishLog::TAG_RxRequest

VarnishLog::TAG_RxResponse

VarnishLog::TAG_RxStatus

VarnishLog::TAG_RxURL

VarnishLog::TAG_RxProtocol

VarnishLog::TAG_RxHeader

VarnishLog::TAG_TxRequest

VarnishLog::TAG_TxResponse

VarnishLog::TAG_TxStatus

VarnishLog::TAG_TxURL

VarnishLog::TAG_TxProtocol

VarnishLog::TAG_TxHeader

VarnishLog::TAG_ObjRequest

VarnishLog::TAG_ObjResponse

VarnishLog::TAG_ObjStatus

VarnishLog::TAG_ObjURL

VarnishLog::TAG_ObjProtocol

VarnishLog::TAG_ObjHeader

VarnishLog::TAG_LostHeader

VarnishLog::TAG_TTL

VarnishLog::TAG_Fetch_Body

VarnishLog::TAG_VCL_acl

VarnishLog::TAG_VCL_call

VarnishLog::TAG_VCL_trace

VarnishLog::TAG_VCL_return

VarnishLog::TAG_VCL_error

VarnishLog::TAG_ReqStart

VarnishLog::TAG_Hit

VarnishLog::TAG_HitPass

VarnishLog::TAG_ExpBan

VarnishLog::TAG_ExpKill

VarnishLog::TAG_WorkThread

VarnishLog::TAG_ESI_xmlerror

VarnishLog::TAG_Hash

VarnishLog::TAG_Backend_health

VarnishLog::TAG_VCL_Log

VarnishLog::TAG_Gzip

Tabla de contenidos

  • VarnishLog::__construct — Constructor de Varnishlog
  • VarnishLog::getLine — Obtiene la siguiente línea de registro
  • VarnishLog::getTagName — Obtener la etiqueta de registro representada por su índice


Constructor de Varnishlog

  • « VarnishLog
  • VarnishLog::getLine »
  • PHP Manual
  • VarnishLog
  • Constructor de Varnishlog

VarnishLog::__construct

(PECL varnish >= 0.6)

VarnishLog::__construct — Constructor de Varnishlog

Descripción

public VarnishLog::__construct ( array $args = ? )

Parámetros

args

Argumentos de configuración. Las posibles claves son:

VARNISH_CONFIG_IDENT - local varnish instance ident path

Valores devueltos


Obtiene la siguiente línea de registro

  • « VarnishLog::__construct
  • VarnishLog::getTagName »
  • PHP Manual
  • VarnishLog
  • Obtiene la siguiente línea de registro

VarnishLog::getLine

(PECL varnish >= 0.6)

VarnishLog::getLine — Obtiene la siguiente línea de registro

Descripción

public VarnishLog::getLine ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con los datos de la línea de registro.


Obtener la etiqueta de registro representada por su índice

  • « VarnishLog::getLine
  • YAZ »
  • PHP Manual
  • VarnishLog
  • Obtener la etiqueta de registro representada por su índice

VarnishLog::getTagName

(PECL varnish >= 0.6)

VarnishLog::getTagName — Obtener la etiqueta de registro representada por su índice

Descripción

public static VarnishLog::getTagName ( int $index ) : string

Parámetros

index

Índice de etiqueta de registro.

Valores devueltos

Devuelve el nombre de la etiqueta de registro como un string.


YAZ

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de YAZ
    • yaz_addinfo — Devuelve un error adicional de información
    • yaz_ccl_conf — Configura el analizador CCL
    • yaz_ccl_parse — Inviocar el analizador Invoke CCL
    • yaz_close — Close YAZ connection
    • yaz_connect — Prepara una conexión a un servidor Z39.50
    • yaz_database — Especifica las bases de datos dentro de una sesión
    • yaz_element — Especifica el nombre del elemento establecido para recuperar
    • yaz_errno — Devuelve el número de error
    • yaz_error — Devuelve la descripción del error
    • yaz_es_result — Resulados de Servicios Extendidos de Inspección
    • yaz_es — Prepara para una solicitud de servicio extendido
    • yaz_get_option — Devuelve el valor de opción para la conexión
    • yaz_hits — Devuelve el número de éxitos de la última búsqueda
    • yaz_itemorder — Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request
    • yaz_present — Se prepara para la recuperación (Z39.50 presente)
    • yaz_range — Específica un rango de registros a recuperar
    • yaz_record — Devuelve un registro
    • yaz_scan_result — Devuelve el resultado de un escaneado
    • yaz_scan — Prepara para un escaneo YAZ
    • yaz_schema — Especifica el esquema para la recuperación
    • yaz_search — Prepara una búsqueda
    • yaz_set_option — Configura una o más opciones de la conexión
    • yaz_sort — Configura los criterios de búsqueda
    • yaz_syntax — Especifica la sintaxis de registro preferida para la recuperación
    • yaz_wait — Espera que las peticiones Z39.50 se completeten


Introducción

Esta extensión ofrece una interface PHP a el kit de herramientas YAZ que implementa el » Protocolo Z39.50 para Recuperación de Información. Con esta extensión se puede fácilmente implementar un origen Z39.50 (clientes) que busca o escanea objetivos Z39.50 (servidores) en paralelo.

El modulo esconde la mayor parte de la complejidad de Z39.50 así que debería ser bastante fácil a usar. Apoya de manera persistente conexiones apátridas muy similares a esas ofrecidas por varias APIs RDB que están disponibles para PHP. Significa que las sesiones son apátridas pero se comparten entre usuarios, por lo tanto salvando la fase de pasos para la conexión e inicialización en más casos.

YAZ está disponible » http://www.indexdata.dk/yaz/. Se puede encontrar nuevas noticias, ejemplos de códigos, etc. Para esta extensión en » http://www.indexdata.dk/phpyaz/.

Nota:

Esta extensión se ha movido al repositorio de » PECL y ya no se distribuye con PHP a partir de PHP 5.0.0.


Requerimientos

Obtenga YAZ (admite ANSI/NISO Z39.50) e instálelo. YAZ se puede obtener desde el código fuente o en varios paquetes preconstruidos desde el » archivo YAZ. Los sistemas como Debian GNU/Linux, Suse Linux, FreeBSD también tienen YAZ como parte de su distribución.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yaz

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .

Nota: Información específica para usuarios Windows

php_yaz.dll depende de yaz.dll. El yaz.dll es parte del ZIP Win32 del sitio de PHP. También es parte de la instalación de Windows YAZ disponible del área » WIN32 YAZ.

En Windows, no se debe olvidar agregar al PATH el directorio de PHP, para que el sistema pueda encontrar el fichero yaz.dll.

Advertencia

Las extensiones IMAP, recode y YAZ no se pueden usar en conjunto, debido a que ambas utilizan el mismo símbolo interno. Anotación: Yaz 2.0 y versiones superiores no tienen este problema..


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • YAZ
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

PHP/YAZ mantiene la vía de conexión con los objetivos de las (Asociaciones-Z). Un recurso representa una conexión a objetivo.

El código debajo demuestra las características de la búsqueda en paralelo del API. Cuando se invoca sin argumentos imprime una consulta de formulario; sino (los argumentos son suministrados) busca los objetivos como son dados en el arreglo del anfitrión.

Ejemplo #1 Busqueda Paralela usando YAZ

<?php
$host=$_REQUEST[anfitrion];
$query=$_REQUEST[consulta];
$num_hosts = count($host);
if (empty($query) || count($host) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="host[]" value="bagel.indexdata.dk/gils" />
        Prueba GILS
    <input type="checkbox"
    name="host[]" value="localhost:9999/Default" />
        Prueba local
    <input type="checkbox" checked="checked"
    name="host[]" value="z3950.loc.gov:7090/voyager" />
        Congresos de librería
    <br />
    RPN Query:
    <input type="text" size="30" name="query" />
    <input type="submit" name="action" value="Buscar" />
    </form>
    ';
} else {
    echo 'Se encontro para ' . htmlspecialchars($query) . '<br />';
    for ($i = 0; $i < $num_hosts; $i++) {
        $id[] = yaz_connect($host[$i]);
        yaz_syntax($id[$i], "usmarc");
        yaz_range($id[$i], 1, 10);
        yaz_search($id[$i], "rpn", $query);
    }
    yaz_wait();
    for ($i = 0; $i < $num_hosts; $i++) {
        echo '<hr />' . $host[$i] . ':';
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Error: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Conteo de Resultado $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i], $p, "string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo nl2br($rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}
?>


Funciones de YAZ

Tabla de contenidos

  • yaz_addinfo — Devuelve un error adicional de información
  • yaz_ccl_conf — Configura el analizador CCL
  • yaz_ccl_parse — Inviocar el analizador Invoke CCL
  • yaz_close — Close YAZ connection
  • yaz_connect — Prepara una conexión a un servidor Z39.50
  • yaz_database — Especifica las bases de datos dentro de una sesión
  • yaz_element — Especifica el nombre del elemento establecido para recuperar
  • yaz_errno — Devuelve el número de error
  • yaz_error — Devuelve la descripción del error
  • yaz_es_result — Resulados de Servicios Extendidos de Inspección
  • yaz_es — Prepara para una solicitud de servicio extendido
  • yaz_get_option — Devuelve el valor de opción para la conexión
  • yaz_hits — Devuelve el número de éxitos de la última búsqueda
  • yaz_itemorder — Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request
  • yaz_present — Se prepara para la recuperación (Z39.50 presente)
  • yaz_range — Específica un rango de registros a recuperar
  • yaz_record — Devuelve un registro
  • yaz_scan_result — Devuelve el resultado de un escaneado
  • yaz_scan — Prepara para un escaneo YAZ
  • yaz_schema — Especifica el esquema para la recuperación
  • yaz_search — Prepara una búsqueda
  • yaz_set_option — Configura una o más opciones de la conexión
  • yaz_sort — Configura los criterios de búsqueda
  • yaz_syntax — Especifica la sintaxis de registro preferida para la recuperación
  • yaz_wait — Espera que las peticiones Z39.50 se completeten


Devuelve un error adicional de información

  • « Funciones de YAZ
  • yaz_ccl_conf »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve un error adicional de información

yaz_addinfo

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_addinfo — Devuelve un error adicional de información

Descripción

yaz_addinfo ( resource $id ) : string

Devuelve un error adicional de información para el ultimo requerimiento al servidor.

Con algunos servidores, Ésta función puede devolver la misma cadena como yaz_error().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

Valores devueltos

Una cadena contiene el error adicional de información o una cadena vacia si la ultima operación fue satisfactoria o si ninguna información fue proporcionada por el servidor.

Ver también

  • yaz_error() - Devuelve la descripción del error
  • yaz_errno() - Devuelve el número de error


Configura el analizador CCL

  • « yaz_addinfo
  • yaz_ccl_parse »
  • PHP Manual
  • Funciones de YAZ
  • Configura el analizador CCL

yaz_ccl_conf

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_conf — Configura el analizador CCL

Descripción

yaz_ccl_conf ( resource $id , array $config ) : void

Ésta función configura la consulta analizadora CCL para un servidor con definiciones de puntos de acceso (Calificadores CCL) y su asignación al RPN.

Para asignar una consulta especifica CCL al RPN después se llama la función yaz_ccl_parse().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

config

Un arreglo de configuración. Cada clave del arreglo es el nombre de un campo CCL y el correspondiente valor que mantiene una cadena que especifica una asignación al RPN.

La asignación es una secuencia de el tipo de atributo, de los valores de los atributos pares. El tipo de atributo y el valor del atributo Attribute-type es separado por un signo (=). Cada par es separado por un epacio en blanco.

La información adicional la puede encontrar en la página » CCL.

Valores devueltos

No devuelve ningún valor.

Ejemplos

En cada ejemplo a continuación, el analizador CCL está configurado para soportar el árbol de los campos CCL: ti, au y isbn. Cada campo es asignado a su equivalente BIB-1. Es asumida que la variable $id es la conexión ID.

Ejemplo #1 Configuración del CCL

<?php
$fields = array(
  "ti" => "1=4",
  "au"   => "1=1",
  "isbn" => "1=7"
);
yaz_ccl_conf($id, $fields);
?>

Ver también

  • yaz_ccl_parse() - Inviocar el analizador Invoke CCL


Inviocar el analizador Invoke CCL

  • « yaz_ccl_conf
  • yaz_close »
  • PHP Manual
  • Funciones de YAZ
  • Inviocar el analizador Invoke CCL

yaz_ccl_parse

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_parse — Inviocar el analizador Invoke CCL

Descripción

yaz_ccl_parse ( resource $id , string $query , array &$result ) : bool

Esta función invoca un analizador CCL. Convierte una consulta dada CCL FIND a una consulta RPN la cual puede ser pasada también a la función yaz_search() para ejecutar la búsqueda.

Para definir un conjunto de campos validos CCL llaman preferiblemente a yaz_ccl_conf() para definirlo en la función.

Parámetros

id

El recurso de la conexión retornado por yaz_connect().

query

La consulta CCL FIND.

result

Si la función fue ejecutada con éxito, Va a ser un arreglo conteniendo la consulta RPN valida dentro de la clave rpn.

En caso de fallo, tres índices son establecidos en este arreglo para indicar la causa del fallo:

  • errorcode - El código de error CCL (entero)

  • errorstring - El error CCL de cadena

  • errorpos - aproxima la posición en una consulta de fallo (el entero es el carácter de posición)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Análisis CCL

Se va a intentar hacer una búsqueda con CCL. En el ejemplo de abajo, $ccl es una consulta CCL.

<?php

yaz_ccl_conf($id, $fields);  // ver el ejemplo para yaz_ccl_conf
if (!yaz_ccl_parse($id, $ccl, &$cclresult)) {
    echo 'Error: ' . $cclresult["errorstring"];
} else {
    $rpn = $cclresult["rpn"];
    yaz_search($id, "rpn", $rpn);
}
?>


Close YAZ connection

  • « yaz_ccl_parse
  • yaz_connect »
  • PHP Manual
  • Funciones de YAZ
  • Close YAZ connection

yaz_close

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_close — Close YAZ connection

Descripción

yaz_close ( resource $id ) : bool

Cierra la conexión dada por un parámetro id.

Nota:

Esta función va solo a cerrar una conexión no persistente abierta por estableciendo la opción de persistent a false con yaz_connect().

Parámetros

id

El recurso de conexión retornado por yaz_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • yaz_connect() - Prepara una conexión a un servidor Z39.50


Prepara una conexión a un servidor Z39.50

  • « yaz_close
  • yaz_database »
  • PHP Manual
  • Funciones de YAZ
  • Prepara una conexión a un servidor Z39.50

yaz_connect

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_connect — Prepara una conexión a un servidor Z39.50

Descripción

yaz_connect ( string $zurl , mixed $options = ? ) : mixed

Esta función devuelve un recurso de conexión en caso de éxito, cero en caso de fallo.

yaz_connect() prepara una conexión a un servidor Z39.50 . Esta función es no bloqueante y no intenta establecer una conexión - únicamente prepara la conexión para que pueda ser realizada posteriormente cuando se llame a la función yaz_wait().

Nota:

El proxy » YAZ es un proxy Z39.50 disponible gratuitamente.

Parámetros

zurl

Un string que toma la forma host[:port][/database]. Si se omite el port, se utilizará el port 210. Si se omite database se utilizará Default .

options

Si se trata de un string, éste se trata como el string de autenticación Z39.50 V2 (OpenAuth).

Si se trata de un array, el contenido del array sirve como opciones.

user

Nombre de usuario para la autenticación.

group

Grupo para la autenticación.

password

Contraseña para la autenticación.

cookie

Cookie para la sesión (proxy YAZ).

proxy

Proxy para la conexión (proxy YAZ).

persistent

Un booleano. Si es true la conexión es persistente; Si es false la conexión no es persistente. Por defecto las conexiones son persistentes.

Nota:

Si se abre una conexión persistente, no se podrá cerrar posteriormente con la función yaz_close().

piggyback

Un booleano. Si es true piggyback está activado para las búsquedas; Si es false piggyback está desactivado. Por defecto piggyback está activado.

Activar piggyback es más eficiente y normalmente ahorra una ruta de ida y vuelta en la red para las cargas de los registros por primera vez. Sin embargo, unos pocos servidores Z39.50 no soportan piggyback o ignoran los nombres de los elementos configurados. Para ellos, se debe desactivar piggyback.

charset

Un string que especifica el mapa de caracteres que será utilizado como lenguaje y mapa de caracteres en la negociación Z39.50. Utilizar strings como: ISO-8859-1, UTF-8, UTF-16.

Muchos servidores Z39.50 no soportan esta funcionalidad (y por ello, ésta es ignorada). Muchos servidores utilizan la codificación ISO-8859-1 para consultas y mensajes. Los registros MARC21/USMARC no están afectados por este parámetro

preferredMessageSize

Un entero que especifica el tamaño máximo de byte para todos los registros que se devolverán por el objetivo durante la recuperación. Ver el estandard » Z39.50 para más información.

Nota:

Esta opción está soportada en PECL YAZ 1.0.5 o posteriores.

maximumRecordSize

Un entero que especifica el tamaño máximo de byte de un único registro a ser devuelto por un objetivo durante la recuperación. Esta entidad se denomina como un Exceptional-record-size en el standard » Z39.50.

Nota:

Esta opción está soportada en PECL YAZ 1.0.5 o posteriores.

Valores devueltos

Un recurso de conexión en caso de éxito, false en caso de error.

Historial de cambios

Versión | Descripción
4.1.0 | Se añadió el parámetro options .

Ver también

  • yaz_close() - Close YAZ connection


Especifica las bases de datos dentro de una sesión

  • « yaz_connect
  • yaz_element »
  • PHP Manual
  • Funciones de YAZ
  • Especifica las bases de datos dentro de una sesión

yaz_database

(PHP 4 >= 4.0.6, PECL yaz >= 0.9.0)

yaz_database — Especifica las bases de datos dentro de una sesión

Descripción

yaz_database ( resource $id , string $databases ) : bool

Esta función permite cambiar las bases de datos dentro de una sesión por una o más bases de datos especificadas a ser usadas en la búsqueda, recuperación, etc. - primordialmente a las bases de datos especificadas a ser llamadas yaz_connect().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

databases

Una cadena conteniendo una o más bases de datos. Múltiple bases de datos son separadas por un signo de más+.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Especifica el nombre del elemento establecido para recuperar

  • « yaz_database
  • yaz_errno »
  • PHP Manual
  • Funciones de YAZ
  • Especifica el nombre del elemento establecido para recuperar

yaz_element

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_element — Especifica el nombre del elemento establecido para recuperar

Descripción

yaz_element ( resource $id , string $elementset ) : bool

Esta función especifica el nombre del elemento establecido para recuperar.

Llama esta función antes de yaz_search() o yaz_present() para especificar el nombre del elemento establecido para los registros a ser recuperados.

Nota:

Si la función parece no tener efecto, ve la descripción de la opción piggybacking en yaz_connect().

Parámetros

id

El recurso de conexión retornado por yaz_connect().

elementset

Más servidores soportan F (para registros completos) y B (para registros breves).

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve el número de error

  • « yaz_element
  • yaz_error »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve el número de error

yaz_errno

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_errno — Devuelve el número de error

Descripción

yaz_errno ( resource $id ) : int

Devuelve un número de error del servidor (la última solicitud) identificado por id.

yaz_errno() debe ser llamado después de la actividad de red para cada servidor - (después del retorno de yaz_wait()) para determinar el éxito o el fracaso de la última operación (p. e.j. search).

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

Valores devueltos

Devuelve un código de error. El código de error es un código de diagnóstico Z39.50 (por lo general un diagnóstico de Bib-1) o el código de error del lado del cliente que es generado por PHP/YAZ, como "Error de conexión", "Init rechazado", etc

Ver también

  • yaz_error() - Devuelve la descripción del error
  • yaz_addinfo() - Devuelve un error adicional de información


Devuelve la descripción del error

  • « yaz_errno
  • yaz_es_result »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve la descripción del error

yaz_error

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_error — Devuelve la descripción del error

Descripción

yaz_error ( resource $id ) : string

yaz_error() retorna un mensaje textual en Inglés correspondiente al último error numérico como devuelto por yaz_errno().

Parámetros

id

El recurso de conexión retornado por yaz_connect().

Valores devueltos

Devuelve un mensaje textual por el servidor (último requerimiento), identificado por el parámetro id. Una cadenma vacia es retornada si la última operación fue satisfactoria.

Ver también

  • yaz_errno() - Devuelve el número de error
  • yaz_addinfo() - Devuelve un error adicional de información


Resulados de Servicios Extendidos de Inspección

  • « yaz_error
  • yaz_es »
  • PHP Manual
  • Funciones de YAZ
  • Resulados de Servicios Extendidos de Inspección

yaz_es_result

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_es_result — Resulados de Servicios Extendidos de Inspección

Descripción

yaz_es_result ( resource $id ) : array

Esta función inspecciona el último resultado de servicio extendido retornado de un servidor. Un servicio extendido es iniciado por cualquier yaz_item_order() o yaz_es().

Parámetros

id

El resultado de conexión retornado por yaz_connect().

Valores devueltos

Devuelve un arreglo con targetReference elemento para la referencia en la operación del servicio extendido (generado y retornado del servidor).

Ver también

  • yaz_es() - Prepara para una solicitud de servicio extendido


Prepara para una solicitud de servicio extendido

  • « yaz_es_result
  • yaz_get_option »
  • PHP Manual
  • Funciones de YAZ
  • Prepara para una solicitud de servicio extendido

yaz_es

(PECL yaz >= 0.9.0)

yaz_es — Prepara para una solicitud de servicio extendido

Descripción

yaz_es ( resource $id , string $type , array $args ) : void

Esta función prepara para una solicitud de servicio extendido. Los servicios extendidos es la familia de diversas facilidades Z39.50, tales como actualización de registros, ordenado de ítem, administración de base de datos, etc.

Nota:

Muchos servidores Z39.50 no soportan servicios extendidos.

La yaz_es() crea un paquete de solicitud de servicio extendido y la pone en una cola de operaciones. Se utiliza yaz_wait() para enviar la(s) solicitud(es) al servidor. Después de completar yaz_wait() el resultado de la operación del servicio extendido se debe esperar con una llamada a yaz_es_result().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

type

Una string que representa el tipo de servicio extendido: itemorder (Ordenado de ítem), create (Crear base de datos), drop (Descartar base de datos), commit (Operación de cometer), update (Actualizar registro), xmlupdate (Actualizar XML). Cada tipo se especifica en la sección siguiente.

args

Un array con las opciones de servicio extendido, más opciones específicas del paquete. Las opciones son idénticas a las ofrecidas en la API C de ZOOM C. Consulte a los » servicios extendidos de ZOOM.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Actualizar registro

<?php
$con = yaz_connect("myhost/database");
$args = array (
    "record" => "<gils><title>some title</title></gils>",
    "syntax" => "xml",
    "action" => "specialUpdate"
);
yaz_es($con, "update", $args);
yaz_wait();
$result = yaz_es_result($id);
?>

Ver también

  • yaz_es_result() - Resulados de Servicios Extendidos de Inspección


Devuelve el valor de opción para la conexión

  • « yaz_es
  • yaz_hits »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve el valor de opción para la conexión

yaz_get_option

(PECL yaz >= 0.9.0)

yaz_get_option — Devuelve el valor de opción para la conexión

Descripción

yaz_get_option ( resource $id , string $name ) : string

Devuelve el valor de la opción especificada con name.

Parámetros

id

El recurso de conexión retornado por yaz_connect().

name

La opción del nombre.

Valores devueltos

Devuelve el valor de la opción especificada o una cadena vacía si la opción wno está establecida.

Ver también

  • La descripción de yaz_set_option() - Configura una o más opciones de la conexión para las opciones disponibles


Devuelve el número de éxitos de la última búsqueda

  • « yaz_get_option
  • yaz_itemorder »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve el número de éxitos de la última búsqueda

yaz_hits

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_hits — Devuelve el número de éxitos de la última búsqueda

Descripción

yaz_hits ( resource $id , array &$searchresult = ? ) : int

yaz_hits()Devuelve el número de éxitos de la última búsqueda.

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

searchresult

Array de resultados para obtener información de resultados de búsqueda detallada.

Valores devueltos

Devuelve el número de éxitos de la última búsqueda o 0 si no se ha realizado ninguna búsqueda.

La matriz de resultados de búsqueda (si se suministra) contiene información que es devuelta por un servidor Z39.50 en el formato SearchResult-1 parte de una respuesta de búsqueda. El formato SearchResult-1 puede utilizarse para obtener información acerca de recuentos de éxitos para varias partes de la consulta (subconsulta). En particular, es posible obtener recuentos de éxitos para los términos de búsqueda individuales en una consulta. Información para la primer subconsulta está en $array[0], segunda subconsulta en $array[1], y así sucesivamente.

searchresult members
Elemento | Descripción
id | Sub consulta ID2 (string)
count | Conteo resultados / éxitos (integer)
subquery.term | Término sub consulta(string)
interpretation.term | Interpretación de término de sub consulta (string)
recommendation.term | Término recomendado de sub consulta (string)

Nota:

El centro de SearchResult requiere PECL YAZ 1.0.5 o posterior y YAZ 2.1.9 o posterior.

Nota:

Muy pocas implementaciones Z39.50 soportan la instalación de SearchResult.


Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request

  • « yaz_hits
  • yaz_present »
  • PHP Manual
  • Funciones de YAZ
  • Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request

yaz_itemorder

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_itemorder — Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request

Descripción

yaz_itemorder ( resource $id , array $args ) : void

Esta función prepara para una petición de tipo "Extended Services" utilizando el "Profile" para "Use of Z39.50 Item Order Extended Service to Transport ILL (Profile/1)". Ver » aquí y la » especificación.

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

args

Debe ser un array asociativo con información sobre la solicitud de los elementos que serán enviados. La clave de la tabla hash es el nombre del camino de acceso ASN.1 correspondiente. Por ejemplo, el ISBN bajo el Item-ID tiene la clave item-id,ISBN.

Los parámetros de la petición ILL son:

protocol-version-num
transaction-id,initial-requester-id,person-or-institution-symbol,person
transaction-id,initial-requester-id,person-or-institution-symbol,institution
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-person
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-institution
transaction-id,transaction-group-qualifier
transaction-id,transaction-qualifier
transaction-id,sub-transaction-qualifier
service-date-time,this,date
service-date-time,this,time
service-date-time,original,date
service-date-time,original,time
requester-id,person-or-institution-symbol,person
requester-id,person-or-institution-symbol,institution
requester-id,name-of-person-or-institution,name-of-person
requester-id,name-of-person-or-institution,name-of-institution
responder-id,person-or-institution-symbol,person
responder-id,person-or-institution-symbol,institution
responder-id,name-of-person-or-institution,name-of-person
responder-id,name-of-person-or-institution,name-of-institution
transaction-type
delivery-address,postal-address,name-of-person-or-institution,name-of-person
delivery-address,postal-address,name-of-person-or-institution,name-of-institution
delivery-address,postal-address,extended-postal-delivery-address
delivery-address,postal-address,street-and-number
delivery-address,postal-address,post-office-box
delivery-address,postal-address,city
delivery-address,postal-address,region
delivery-address,postal-address,country
delivery-address,postal-address,postal-code
delivery-address,electronic-address,telecom-service-identifier
delivery-address,electronic-address,telecom-service-addreess
billing-address,postal-address,name-of-person-or-institution,name-of-person
billing-address,postal-address,name-of-person-or-institution,name-of-institution
billing-address,postal-address,extended-postal-delivery-address
billing-address,postal-address,street-and-number
billing-address,postal-address,post-office-box
billing-address,postal-address,city
billing-address,postal-address,region
billing-address,postal-address,country
billing-address,postal-address,postal-code
billing-address,electronic-address,telecom-service-identifier
billing-address,electronic-address,telecom-service-addreess
ill-service-type
requester-optional-messages,can-send-RECEIVED
requester-optional-messages,can-send-RETURNED
requester-optional-messages,requester-SHIPPED
requester-optional-messages,requester-CHECKED-IN
search-type,level-of-service
search-type,need-before-date
search-type,expiry-date
search-type,expiry-flag
place-on-hold
client-id,client-name
client-id,client-status
client-id,client-identifier
item-id,item-type
item-id,call-number
item-id,author
item-id,title
item-id,sub-title
item-id,sponsoring-body
item-id,place-of-publication
item-id,publisher
item-id,series-title-number
item-id,volume-issue
item-id,edition
item-id,publication-date
item-id,publication-date-of-component
item-id,author-of-article
item-id,title-of-article
item-id,pagination
item-id,ISBN
item-id,ISSN
item-id,additional-no-letters
item-id,verification-reference-source
copyright-complicance
retry-flag
forward-flag
requester-note
forward-note

También hay unos pocos parámetros que son parte del Paquete de Solicitud de Servicios Extendidos y el paquete ItemOrder:

package-name
user-id
contact-name
contact-phone
contact-email
itemorder-item

Valores devueltos

No devuelve ningún valor.


Se prepara para la recuperación (Z39.50 presente)

  • « yaz_itemorder
  • yaz_range »
  • PHP Manual
  • Funciones de YAZ
  • Se prepara para la recuperación (Z39.50 presente)

yaz_present

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_present — Se prepara para la recuperación (Z39.50 presente)

Descripción

yaz_present ( resource $id ) : bool

Esta función se prepara para la recuperación de archivos después de una búsqueda exitosa.

La función yaz_range() debe ser llamado antes de esta función para especificar el rango de registros a ser recuperados.

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Específica un rango de registros a recuperar

  • « yaz_present
  • yaz_record »
  • PHP Manual
  • Funciones de YAZ
  • Específica un rango de registros a recuperar

yaz_range

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_range — Específica un rango de registros a recuperar

Descripción

yaz_range ( resource $id , int $start , int $number ) : void

Específica un rango de registros a recuperar.

Esta función debería ser llamada antes de yaz_search() o yaz_present().

Parámetros

id

El recurso de conexión retornado por yaz_connect().

start

Especifíca la posición del primer registro a ser recuperado. Los registros numéricos van de 1 a yaz_hits().

number

Específica un rango de registros a recuperar.

Valores devueltos

No devuelve ningún valor.


Devuelve un registro

  • « yaz_range
  • yaz_scan_result »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve un registro

yaz_record

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_record — Devuelve un registro

Descripción

yaz_record ( resource $id , int $pos , string $type ) : string

La función yaz_record() inspecciona un registro del conjunto resultado actual que está en la posición especificada por el parámetro pos.

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

pos

La posición del registro. Las posiciones de los registros en el conjunto resultado están numeradas con 1, 2, ... $hits donde $hits es el contador devuelto por yaz_hits().

type

El parámetro type especifica la forma del registro devuelto.

Nota:

Es la aplicación responsable de asegurar realmente que los registros son devueltos en el formato correcto por el servidor Z39.50/SRW. El type indicado únicamente especifica una conversión que se realizará en el lado cliente (en PHP/YAZ).

Además de la conversion del registro transferido a un string/array, PHP/YAZ también puede realizar una conversión de mapa de caracteres del registro. Esto es recomendado especialmente para USMARC/MARC21 puesto que éstos se devuelven habitualmente en el mapa de caracteres MARC-8 que no está soportado por navegadores, etc. Para especificar una conversión, añadir ; charset=from, to donde from es el mapa de caracteres original del registro y to es el mapa de caracteres resultante (desde el punto de vista PHP).

string

El registro se devuelve como un string de visualización simple. En este modo, todos los registros MARC se convierten a un formato línea a línea ya que ISO2709 es difícilmente legible. Los registros XML y SUTRS se devuelven en su formato original. GRS-1 se devuelve en un (feo) formato línea a línea.

Este formato es adecuado si los registros se mostrarán de forma rápida - para depuración - o porque no es factible realizar una visualización adecuada.

xml

El registro se devuelve como un string XML si es posible. En este modo, todos los registros MARC se convierten en » MARCXML. Los registros XML y SUTRS se devuelven en su formato original. GRS-1 no está soportado.

Este formato es parecido a string excepto por los registros MARC que se convierten a MARCXML

Este formato es adecuado si los registros se procesan posteriormente por un interpretador XML o un procesador XSLT .

raw

El registro se devuelve como un string en su formato original. Este tipo es adecuado para MARC, XML y SUTRS. No funciona con GRS-1.

Los registros MARC se devuelven como un string ISO2709. XML y SUTRS son devueltos como strings.

syntax

La sintaxis del registro se devuelve como un string, p.e. USmarc, GRS-1, XML, etc.

database

El nombre de la base de datos asociada con el registro en la posición, se devuelve como un string.

array

El registro se devuelve como un array que refleja la estructura GRS-1. Este tipo es adecuado para MARC y GRS-1. XML, SUTRS no están soportados y si el registro actual es XML o SUTRS se devolverá un string vacío.

El array devuelto consiste en una lista correspondiente a cada hoja/nodo interno de GRS-1. Cada lista de elementos consiste en una sublista con el primer elemento path y data (si los datos están disponibles).

El camino de acceso, que es un string, contiene una lista de tres componentes (del registro estructurado GRS-1) de la raíz a la hoja. Cada componente es un par de tipo etiqueta/valor de etiqueta de la forma (type, value

Las etiguqetas normalmente tienen un tipo tag 3. MARC también puede ser devuelto como un array (se convierten a GRS-1 internamente).

Valores devueltos

Devuelve el registro que se encuentra en la posición pos o un string vacío si no existe ningún registro en la posición indicada.

Si no hay registro en la posición indicada en la base de datos, se devolverá un string vacío.

Ejemplos

Ejemplo #1 Array para registro GRS-1

Considerar este registro GRS-1 :

(4,52)Robert M. Pirsig
(4,70)
      (4,90)
            (2,7)Transworld Publishers, ltd.
Este registro tiene dos nodos a nivel de raíz. El primer elemento del nivel raíz es (4,52) [tipo tag 4, valor de tag 52], y tiene datos Robert M. Pirsig. El segundo elemento en el nivel raíz (4,70) tiene un subárbol con un elemento simple (4,90). (4,90) tiene a su vez otro subárbol (2,7) con datos Transworld Publishers, ltd..

Si este registro está presente en la posición $p, entonces

<?php

$ar = yaz_record($id, $p, "array");
print_r($ar);

?>
will output:
Array
(
    [0] => Array
        (
            [0] => (4,52)
            [1] => Robert M. Pirsig
        )
    [1] => Array
        (
            [0] => (4,70)
        )
    [2] => Array
        (
            [0] => (4,70)(4,90)
        )
    [3] => Array
        (
            [0] => (4,70)(4,90)(2,7)
            [1] => Transworld Publishers, ltd.
        )
)

Ejemplo #2 Trabajar con MARCXML

El siguiente fragmento de PHP devuelve un registro MARC21/USMARC como MARCXML. El registro original se devuelve en marc-8 (desconocido para muchos interpretadores XML), así que lo convertimos a UTF-8 (que todos los interpretadores XML deben soportar).

<?php
$rec = yaz_record($id, $p, "xml; charset=marc-8,utf-8");
?>

El registro $rec puede ser procesado con el procesador Sablotron XSLT de la forma siguiente:

<?php

$xslfile = 'display.xsl';
$processor = xslt_create();
$parms = array('/_xml' => $rec);
$res = xslt_process($processor, 'arg:/_xml', $xslfile, NULL, $parms);
xslt_free($processor);
$res = preg_replace("'</?html[^>]*>'", '', $res);
echo $res;

?>

Para PHP 5 la extensión XSL debe ser utilizada en vez de Sablotron XSLT.


Devuelve el resultado de un escaneado

  • « yaz_record
  • yaz_scan »
  • PHP Manual
  • Funciones de YAZ
  • Devuelve el resultado de un escaneado

yaz_scan_result

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan_result — Devuelve el resultado de un escaneado

Descripción

yaz_scan_result ( resource $id , array &$result = ? ) : array

yaz_scan_result() devuelve una tabla con los términos y la información asociada tal y como fue recibida del servidor en la última función yaz_scan() realizada.

Parámetros

id

El recurso de conexión asociado por yaz_connect().

result

Si se indica, este array será modificado para contener información adicional tomada de la respuesta del scan:

  • number - Número de entradas devueltas

  • stepsize - Tamaño del paso

  • position - Posición del término

  • status - Estado del escaneo

Valores devueltos

Devuelve un array (0..n-1) donde n es el número de elementos devuetos. Cada valor es un par donde el primer elemento es el término, y el segundo es el contador de resultados.


Prepara para un escaneo YAZ

  • « yaz_scan_result
  • yaz_schema »
  • PHP Manual
  • Funciones de YAZ
  • Prepara para un escaneo YAZ

yaz_scan

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan — Prepara para un escaneo YAZ

Descripción

yaz_scan ( resource $id , string $type , string $startterm , array $flags = ? ) : void

Esta función prepara para una solicitud "Z39.50 Scan Request" en la conexión YAZ especificada.

Para transferir realmente la "Scan Request" del servidor y recibir la "Scan Response", debe llamarse yaz_wait(). Después de la finalización de la llamada a yaz_wait(), llamar a yaz_error() y yaz_scan_result() para gestionar la respuesta.

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

type

Actualmente sólo está soportado el tipo rpn .

startterm

Punto de partida del escaneo.

La forma en la que el punto de partida es especificado, viene dado por el parámetro type.

La sintaxis de este parámetro es parecido al de la consulta RPN tal y como se describe en yaz_search(). Consiste en cero o más especificaciones del operador @attr, seguido de exactamente un token.

flags

Este parámetro opcional describe información adicional para controlar el comportamiento de la solicitud de escaneo. Tres índices se leen actualmente del array de marcas: number (número de términos solicitados), position (posición preferida del término) y stepSize (tamaño preferido del paso).

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 función PHP que escanea títulos

<?php
function scan_titles($id, $startterm)
{
  yaz_scan($id, "rpn", "@attr 1=4 " . $startterm);
  yaz_wait();
  $errno = yaz_errno($id);
  if ($errno == 0) {
    $ar = yaz_scan_result($id, $options);
    echo 'Scan ok; ';
    foreach ($options as $key => $val) {
      echo "$key = $val ";
    }
    echo '<br /><table>';
    while (list($key, list($k, $term, $tcount)) = each($ar)) {
      if (empty($k)) continue;
      echo "<tr><td>$term</td><td>$tcount</td></tr>";
    }
    echo '</table>';
  } else {
    echo "Error de escaneo. Error: " . yaz_error($id) . "<br />";
  }
}
?>


Especifica el esquema para la recuperación

  • « yaz_scan
  • yaz_search »
  • PHP Manual
  • Funciones de YAZ
  • Especifica el esquema para la recuperación

yaz_schema

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_schema — Especifica el esquema para la recuperación

Descripción

yaz_schema ( resource $id , string $schema ) : void

yaz_schema() especifica el esquema para la recuperación.

Esta función debe ser llamada antes de yaz_search() o yaz_present().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

schema

Debe ser especificado como un OID (identificador de objeto) notación de puntos sin tratar (como 1.2.840.10003.13.4 ) o como uno de los esquemas conocidos registrados: GILS-schema, Holdings, Zthes, ...

Valores devueltos

No devuelve ningún valor.


Prepara una búsqueda

  • « yaz_schema
  • yaz_set_option »
  • PHP Manual
  • Funciones de YAZ
  • Prepara una búsqueda

yaz_search

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_search — Prepara una búsqueda

Descripción

yaz_search ( resource $id , string $type , string $query ) : bool

yaz_search() prepara una búsqueda en la conexión dada.

Como yaz_connect() esta función es no bloqueante y únicamente prepara una búsqueda para ser ejecutada posteriormente cuando se llame a la función yaz_wait() .

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

type

Este parámetro representa el tipo de la consulta - únicamente "rpn" está soportado ahora, en cuyo caso el tercer argumento especifica una consulta de tipo Type-1 en notación de prefijo de consulta.

query

La consulta RPN es una representación textual de la consulta Type-1 tal y como está definida por el estandard Z39.50 . Sin embargo, en la representación del texto utilizada por YAZ se necesita una notación de prefijo, es decir que el operador precede a los operandos. El string de la consulta es una secuencia de tokens donde se ignora el espacio en blanco a menos que esté rodeado de dobles comillas. Los Tokens que empiecen con una arroba (@) se considerarán operadores, de otro modo, se tratarán como términos de búsqueda.

Operadores RPN
Sintaxis | Descripción
@and query1 query2 | intersección de las consultas query1 y query2
@or query1 query2 | unión de las consultas query1 y query2
@not query1 query2 | query1 y no query2
@set name | conjunto resultado de referencia
@attrset set query | especifica el conjunto de atributos para la consulta. Esta construcción sólo se permite una sola vez - en el inicio de la consulta
@attr [set] type=value query | aplica atributos a la consulta. El tipo y valor son enteros especificando el tipo del atributo y valor del atributo respectivamente. El conjunto, si se informa, especifica el conjunto atributo.

Se muestra más información sobre atributos en el link » Z39.50 Maintenance Agency site.

Nota:

Si se desea utilizar una notación más amigable, utilizar el interpretador CCL - functiones yaz_ccl_conf() y yaz_ccl_parse().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Query Examples

Se puede buscar por términos sencillos, como en el caso siguiente:

computer
que busca documentos donde aparece "computer" . No se han especificado atributos.

La consulta

"knuth donald"
busca documentos donde aparece "knuth donald" (suponiendo que el servidor soporta búsqueda de frases).

Esta consulta aplica dos atributos para la misma frase.

@attr 1=1003 @attr 4=1 "knuth donald"
El primer atributo es de tipo type 1 (usa Bib-1), el valor del atributo es 1003 (Autor). El segundo atributo es de tipo type 4 (estructura), valor 1 (frase), así que debe buscar documentos donde Donald Knuth es el autor.

La consulta

@and @or a b @not @or c d e
en notación infija tendría el aspecto: (a or b) and ((c or d) not e).

Otro ejemplo, más complejo:

@attrset gils @and @attr 1=4 art @attr 1=2000 company
La consulta utiliza el conjunto de atributos GILS . La consulta busca documentos en los que art aparece en el título (GILS,BIB-1) y en los que company aparece como Distributor (GILS).


Configura una o más opciones de la conexión

  • « yaz_search
  • yaz_sort »
  • PHP Manual
  • Funciones de YAZ
  • Configura una o más opciones de la conexión

yaz_set_option

(PECL yaz >= 0.9.0)

yaz_set_option — Configura una o más opciones de la conexión

Descripción

yaz_set_option ( resource $id , string $name , string $value ) : void
yaz_set_option ( resource $id , array $options ) : void

Configura una o más opciones de la conexión dada.

Parámetros

id

El recurso de conexión devuelta por yaz_connect().

name o options

Puede ser un string o un array.

Si se informa un string, será el nombre de la opción a configurar. Será necesario especificar su value.

Si se informa un array, será un array asociativo (nombre opción => valor opción).

Opciones de Conexión PHP/YAZ
Nombre | Descripción
implementationName | nombre de la implementación del servidor
implementationVersion | versión de implementación del servidor
implementationId | ID de implementación del servidor
schema | esquema de recuperación. Por defecto, no se utiliza ningún esquema. Configurar esta opción es equivalente a utilizar la función yaz_schema()
preferredRecordSyntax | sintaxis del registro para la recuperación. Por defecto, no se utiliza sintaxis. Configurar esta opción es equivalente a utilizar la función yaz_syntax()
start | desplazamiento para el primer registro a ser obtenido vía yaz_search() o yaz_present(). El primer registro está numerado con un valor inicial de 0. El segundo registro tiene valor de inicio 1. Configurar esta opción en combinación con la opción count tiene el mismo efecto que llamar a yaz_range() excepto que los registros están numerados a partir de de 1 con yaz_range()
count | número máximo de registros a recuperar vía yaz_search() o yaz_present().
elementSetName | nombre del conjunto de elementos para la recuperación. Configurar esta opción es equivalente a llamar a yaz_element().
value

El nuevo valor de la opción. Utilizar este parámetro únicamente si el argumento previo es un string.

Valores devueltos

No devuelve ningún valor.


Configura los criterios de búsqueda

  • « yaz_set_option
  • yaz_syntax »
  • PHP Manual
  • Funciones de YAZ
  • Configura los criterios de búsqueda

yaz_sort

(PHP 4 >= 4.0.7, PECL yaz >= 0.9.0)

yaz_sort — Configura los criterios de búsqueda

Descripción

yaz_sort ( resource $id , string $criteria ) : void

Esta función configura los criterios de búsqueda y activa la ordenación Z39.50 .

LLamar a esta función antes de yaz_search(). Utilizar esta función por si sola no tiene ningún efecto. Cuando se usa en conjunción con yaz_search(), una ordenación Z39.50 se enviará después de que la respuesta de la búsqueda ha sido recibida y antes de que cualquier registro sea recuperado con Z39.50 Present (yaz_present().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

criteria

Un string que toma la forma field1 flags1 field2 flags2 donde field1 especifica los atributos primarios para ordenar, field2 los secundarios, etc..

El campo especifica ya sea combinaciones de atributos numéricos consistentes de pares type=value separados por una coma (p.e. 1=4,2=1) ; o el campo debe especificar un string con el criterio (p.e. título). Los flags son secuencias de los caracteres siguientes que no pueden estar separados por ningún espacio.

Sort Flags
a

Ordenar de forma ascendente

d

Ordenar de forma descendente

i

No diferenciar entre mayúsculas o minúsculas en la ordenación

s

Diferenciar entre mayúsculas o minúsculas en la ordenación

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Criterios de Ordenación

Para ordenar con el título de atributo Bib1e, sin diferenciar mayúsculas o minúsculas, y de forma ascendente, utilizar el siguiente criterio de ordenación:

1=4 ia

Si el criterio de ordenación secundario fuera el autor, diferenciando mayúsculas y minúsculas y de forma ascendente, se usaría:

1=4 ia 1=1003 sa


Especifica la sintaxis de registro preferida para la recuperación

  • « yaz_sort
  • yaz_wait »
  • PHP Manual
  • Funciones de YAZ
  • Especifica la sintaxis de registro preferida para la recuperación

yaz_syntax

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_syntax — Especifica la sintaxis de registro preferida para la recuperación

Descripción

yaz_syntax ( resource $id , string $syntax ) : void

yaz_syntax() especifica la sintaxis de registro preferida para la recuperación

Esta función debe ser llamada antes de yaz_search() o yaz_present().

Parámetros

id

El recurso de conexión devuelto por yaz_connect().

syntax

La sintaxis debe especificarse como un OID (identificador de objeto) en una notación de puntos sin tratar (como 1.2.840.10003.5.10) o como una de las sintaxis conocidas (sutrs, usmarc, grs1, xml, etc.).

Valores devueltos

No devuelve ningún valor.


Espera que las peticiones Z39.50 se completeten

  • « yaz_syntax
  • Mensajería de 0MQ »
  • PHP Manual
  • Funciones de YAZ
  • Espera que las peticiones Z39.50 se completeten

yaz_wait

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_wait — Espera que las peticiones Z39.50 se completeten

Descripción

yaz_wait ( array &$options = ? ) : mixed

Esta función lleva a cabo en red (bloqueada) la actividad para la
solicitudes pendientes que han sido preparados por las funciones
yaz_connect(), yaz_search(),
yaz_present(), yaz_scan() y
yaz_itemorder().

yaz_wait() devuelve cuando todos los servidores han completado todas las solicitudes o abortado (en caso de error).

Parámetros

options

Un array asociativo de opciones:

timeout

Establece el tiempo de espera en segundos. Si un servidor no ha respondido en el tiempo de espera se considera muerto y retorna yaz_wait(). El valor por omisión de tiempo de espera es de 15 segundos.

event

Un boolean.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. En modo event, retorna un recource o false en caso de error.


ZMQ

  • Introducción
  • Instalación/Configuración
    • Requerimientos
  • ZMQ — La clase ZMQ
    • ZMQ::__construct — El constructor de ZMQ
  • ZMQContext — La clase ZMQContext
    • ZMQContext::__construct — Construir un nuevo objeto ZMQContext
    • ZMQContext::getOpt — Obtener la opción de contexto
    • ZMQContext::getSocket — Crear un nuevo socket
    • ZMQContext::isPersistent — Indicar si el contexto es persistente
    • ZMQContext::setOpt — Establecer una opción de socket
  • ZMQSocket — La clase ZMQSocket
    • ZMQSocket::bind — Vincular el socket
    • ZMQSocket::connect — Contectar el socket
    • ZMQSocket::__construct — Construir un nuevo ZMQSocket
    • ZMQSocket::disconnect — Desconectar un socket
    • ZMQSocket::getEndpoints — Obtener una lista de los extremos
    • ZMQSocket::getPersistentId — Obtener el ID de persistencia
    • ZMQSocket::getSocketType — Obtener el tipo de socket
    • ZMQSocket::getSockOpt — Obtener la opción de un socket
    • ZMQSocket::isPersistent — Comprobrar si un socket es persistente
    • ZMQSocket::recv — Recibir un mensaje
    • ZMQSocket::recvMulti — Recibir un mensaje multiparte
    • ZMQSocket::send — Enviar un mensaje
    • ZMQSocket::sendmulti — Enviar un mensaje multiparte
    • ZMQSocket::setSockOpt — Establecer una opción de socket
    • ZMQSocket::unbind — Desvincular el socket
  • ZMQPoll — La clase ZMQPoll
    • ZMQPoll::add — Añadir un elemento al conjunto de sondeo
    • ZMQPoll::clear — Limpiar el conjunto de sondeo
    • ZMQPoll::count — Contar los elementos del conjunto de sondeo
    • ZMQPoll::getLastErrors — Obtener los errores del sondeo
    • ZMQPoll::poll — Sondear los elementos
    • ZMQPoll::remove — Eliminar un elemento del conjunto de sondeo
  • ZMQDevice — La clase ZMQDevice
    • ZMQDevice::__construct — Construir un nuevo dispositivo
    • ZMQDevice::getIdleTimeout — Obtener el tiempo de espera de inactividad
    • ZMQDevice::getTimerTimeout — Obtener el tiempo de espera del temporizador
    • ZMQDevice::run — Ejecutar el nuevo dispositivo
    • ZMQDevice::setIdleCallback — Establecer la función de retrollamada de inactividad
    • ZMQDevice::setIdleTimeout — Establecer el tiempo de espera para la inactividad
    • ZMQDevice::setTimerCallback — Establecer la función de retrollamada del temporizador
    • ZMQDevice::setTimerTimeout — Establecer el tiempo de espera del temporizador


Introducción

"ØMQ es una biblioteca software que permite diseñar e implementar rápidamente una aplicación basada en mensajes." --Sitio web de 0MQ

Para más información acerca de 0MQ, visite » http://zeromq.org/.


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • Mensajería de 0MQ
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos


Requerimientos

La extensión ZMQ requiere la version 2.0.7 o superior de 0MQ. 0MQ se puede adquirir en » http://zeromq.org/area:download.

Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/zmq


La clase ZMQ

(PECL zmq >= 0.5.0)

Introducción

Sinopsis de la Clase

ZMQ {
/* Constantes */
const integer SOCKET_PAIR ;
const integer SOCKET_PUB ;
const integer SOCKET_SUB ;
const integer SOCKET_REQ ;
const integer SOCKET_REP ;
const integer SOCKET_XREQ ;
const integer SOCKET_XREP ;
const integer SOCKET_PUSH ;
const integer SOCKET_PULL ;
const integer SOCKET_ROUTER ;
const integer SOCKET_DEALER ;
const integer SOCKET_XPUB ;
const integer SOCKET_XSUB ;
const integer SOCKET_STREAM ;
const integer SOCKOPT_HWM ;
const integer SOCKOPT_SNDHWM ;
const integer SOCKOPT_RCVHWM ;
const integer SOCKOPT_AFFINITY ;
const integer SOCKOPT_IDENTITY ;
const integer SOCKOPT_SUBSCRIBE ;
const integer SOCKOPT_UNSUBSCRIBE ;
const integer SOCKOPT_RATE ;
const integer SOCKOPT_RECOVERY_IVL ;
const integer SOCKOPT_RECONNECT_IVL ;
const integer SOCKOPT_RECONNECT_IVL_MAX ;
const integer SOCKOPT_MCAST_LOOP ;
const integer SOCKOPT_SNDBUF ;
const integer SOCKOPT_RCVBUF ;
const integer SOCKOPT_RCVMORE ;
const integer SOCKOPT_TYPE ;
const integer SOCKOPT_LINGER ;
const integer SOCKOPT_BACKLOG ;
const integer SOCKOPT_MAXMSGSIZE ;
const integer SOCKOPT_SNDTIMEO ;
const integer SOCKOPT_RCVTIMEO ;
const integer SOCKOPT_IPV4ONLY ;
const integer SOCKOPT_LAST_ENDPOINT ;
const integer SOCKOPT_TCP_KEEPALIVE_IDLE ;
const integer SOCKOPT_TCP_KEEPALIVE_CNT ;
const integer SOCKOPT_TCP_KEEPALIVE_INTVL ;
const integer SOCKOPT_TCP_ACCEPT_FILTER ;
const integer SOCKOPT_TCP_ACCEPT_FILTER ;
const integer SOCKOPT_DELAY_ATTACH_ON_CONNECT ;
const integer SOCKOPT_XPUB_VERBOSE ;
const integer SOCKOPT_ROUTER_RAW ;
const integer SOCKOPT_IPV6 ;
const integer CTXOPT_MAX_SOCKETS ;
const integer POLL_IN ;
const integer POLL_OUT ;
const integer MODE_NOBLOCK ;
const integer MODE_DONTWAIT ;
const integer MODE_SNDMORE ;
const integer ERR_INTERNAL ;
const integer ERR_EAGAIN ;
const integer ERR_ENOTSUP ;
const integer ERR_EFSM ;
const integer ERR_ETERM ;
/* Methods */
private__construct ( )
}

Constantes predefinidas

Tipos de constantes de ZMQ

ZMQ::SOCKET_PAIR

Patrón de par exclusivo

ZMQ::SOCKET_PUB

Socket publicador

ZMQ::SOCKET_SUB

Socket suscriptor

ZMQ::SOCKET_REQ

Socket de petición

ZMQ::SOCKET_REP

Socket de respuesta

ZMQ::SOCKET_XREQ

Alias de SOCKET_DEALER

ZMQ::SOCKET_XREP

Alias de SOCKET_ROUTER

ZMQ::SOCKET_PUSH

Socket "push" ascendente de tubería

ZMQ::SOCKET_PULL

Socket "pull" descendente de tubería

ZMQ::SOCKET_ROUTER

Socket REP ampliado que puede dirigir réplicas a solicitantes

ZMQ::SOCKET_DEALER

Sokect REQ ampliado que equilibra a todos los pares conectados

ZMQ::SOCKET_XPUB

Similar to SOCKET_PUB, except you can receive subscriptions as messages. The subscription message is 0 (unsubscribe) or 1 (subscribe) followed by the topic.

ZMQ::SOCKET_XSUB

Similar a SOCKET_SUB, excepto que se puede enviar suscripciones como mensajes. Véase SOCKET_XPUB para el formato.

ZMQ::SOCKET_STREAM

Utilizada para enviar y recibir datos TCP de un par que no sea ØMQ. Disponible si se compila con ZeroMQ 4.0 o superior (Value: int).

ZMQ::SOCKOPT_HWM

La marca de agua para mensajes entrantes y salientes es un límite firme sobre el número máximo de mensajes salientes que ØMQ pondrá en cola en la memoria para cualquier único par con que se comunique el socket especificado. Establecer esta opción en un socket solamente afectará a las conexiones realizadas después de haber establecido esta opción. En ZeroMQ 3.x esto es una envoltura para establecer tanto SNDHWM como RCVHWM. (Valor: int).

ZMQ::SOCKOPT_SNDHWM

La opción ZMQ_SNDHWM establece la marca de agua alta para mensajes salientes en el socket especificado. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int).

ZMQ::SOCKOPT_RCVHWM

La opción SOCKOPT_RCVHWM establece la marca de agua alta para mensajes entrantes en el socket especificado. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int).

ZMQ::SOCKOPT_AFFINITY

Establecer la afinidad del hilo de E/S (Valor: int)

ZMQ::SOCKOPT_IDENTITY

Establecer la identidad del socket identity (Valor: string)

ZMQ::SOCKOPT_SUBSCRIBE

Establecer un filtro para mensajes. Válido para socket suscriptores socket (Valor: string)

ZMQ::SOCKOPT_UNSUBSCRIBE

Eliminar un filtro para mensajes. Válido para socket suscriptores (Valor: string)

ZMQ::SOCKOPT_RATE

Establecer la tasa para los socket de multidifusión (pgm) (Valor: int >= 0)

ZMQ::SOCKOPT_RECOVERY_IVL

Establecer el intervalo de recuperación de la multidifusión (Valor: int >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL

Establecer el intervañp de reconexión inicial (Valor: int >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL_MAX

Establecer el intervalo de reconexión máximo (Valor: int >= 0)

ZMQ::SOCKOPT_MCAST_LOOP

Controlar el loopback de la multidifusión (Valor: int >= 0)

ZMQ::SOCKOPT_SNDBUF

Establecer el tamaño del buffer de transmisión del kernel (Valor: int >= 0)

ZMQ::SOCKOPT_RCVBUF

Establecer el tamaño del buffer de recepción del kernel (Valor: int >= 0)

ZMQ::SOCKOPT_RCVMORE

Recibir mensajes multiparte (Valor: int)

ZMQ::SOCKOPT_TYPE

Obtener el tipo de socket. Válido para getSockOpt (Valor: int)

ZMQ::SOCKOPT_LINGER

El valor de permanencia ("linger") del socket. Especifica cuánto quedará esperando el socket intentando volcar mensajes después de haber sido cerrado (Valor: int)

ZMQ::SOCKOPT_BACKLOG

La opción SOCKOPT_BACKLOG establece la longitud máxima de la cola de las conexiones de pares salientes para el socket especificado; esto solamente se aplica a transportes orientados a conexión. (Valor: int)

ZMQ::SOCKOPT_MAXMSGSIZE

Limita el tamaño máximo del mensaje entrante. Un valor de -1 significa sin límite. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_SNDTIMEO

Establecer el tiempo de espera para la operación de envío del socket. Un valor de -1 significa sin límite. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_RCVTIMEO

Establecer el tiempo de espera para la operación de recepción del socket. Un valor de -1 significa sin límite. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_IPV4ONLY

Deshabilitar el soporte para IPV6 si es 1. Disponible si se compila con ZeroMQ 3.x (Valor: int)

ZMQ::SOCKOPT_LAST_ENDPOINT

Obtener el último extremo conectado - para emplear con puertos comodín *. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: string)

ZMQ::SOCKOPT_TCP_KEEPALIVE_IDLE

Tiempo de inactividad para el mensaje "keepalive" de TCP. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_TCP_KEEPALIVE_CNT

Cuante de tiempo para el mensaje "keepalive" de TCP. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_TCP_KEEPALIVE_INTVL

Intervalo para el mensaje "keepalive" de TCP. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: int)

ZMQ::SOCKOPT_DELAY_ATTACH_ON_CONNECT

Establecer un string CIDR para comparar con conexiones TCP entrantes. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: string)

ZMQ::SOCKOPT_TCP_ACCEPT_FILTER

Establecer un string CIDR para comparar con conexioines TCP entrantes. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: string)

ZMQ::SOCKOPT_XPUB_VERBOSE

Establcer el XPUB para recibir un mensaje de aplicación en cada instancia de una subscripción. Disponible si se compila con ZeroMQ 3.0 o superior (Valor: string)

ZMQ::SOCKOPT_ROUTER_RAW

Establece el modo puro ("raw") del ROUTER, cuando se establece a 1. En el modo puro, al usar el transporte tcp://, el socket leerá y escribirá sin el encuadrre de ZeroMQ. Disponible si se compila con ZeroMQ 4.0 o superior (Valor: string)

ZMQ::SOCKOPT_IPV6

Habilitar IPV6. Disponible si se compila con ZeroMQ 4.0 o superior (Valor: string)

ZMQ::CTXOPT_MAX_SOCKETS

El límite de socket para este contexto. Disponible si se compila con ZeroMQ 3.x o superior (Valor: int)

ZMQ::POLL_IN

Sondeo para datos entrantes

ZMQ::POLL_OUT

Sondeo para datos salientes

ZMQ::MODE_NOBLOCK

Operación de no espera. Obsoleta, emplee ZMQ::MODE_DONTWAIT en su lugar

ZMQ::MODE_DONTWAIT

Operación de no espera

ZMQ::MODE_SNDMORE

Enviar un mensaje multiparte

ZMQ::DEVICE_FORWARDER

Dispositivo reenviador

ZMQ::DEVICE_QUEUE

Dispositivo de cola

ZMQ::DEVICE_STREAMER

Dispositivo de flujo

ZMQ::ERR_INTERNAL

Error interno de la extensión ZMQ

ZMQ::ERR_EAGAIN

Implica que la operación debería esperar esperar cuando se emplee ZMQ::MODE_DONTWAIT

ZMQ::ERR_ENOTSUP

La operación no está soportada por el tipo de socket

ZMQ::ERR_EFSM

La operación no se pudo ejecutar debido a que el socket no está en un estado correcto

ZMQ::ERR_ETERM

El contexto ha sido finalizado

Tabla de contenidos

  • ZMQ::__construct — El constructor de ZMQ


El constructor de ZMQ

  • « ZMQ
  • ZMQContext »
  • PHP Manual
  • ZMQ
  • El constructor de ZMQ

ZMQ::__construct

(PECL zmq >= 0.5.0)

ZMQ::__construct — El constructor de ZMQ

Descripción

privateZMQ::__construct ( )

Constructor privado para evitar la inicialización directa. Esta clase mantiene las constantes para la extensión ZMQ.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase ZMQContext

(PECL zmq >= 0.5.0)

Introducción

Sinopsis de la Clase

ZMQContext {
/* Métodos */
__construct ( int $io_threads = 1 , bool $is_persistent = true )
public getOpt ( string $key ) : mixed
public getSocket ( int $type , string $persistent_id = null , callback $on_new_socket = null ) : ZMQSocket
public isPersistent ( ) : bool
public setOpt ( int $key , mixed $value ) : ZMQContext
}

Tabla de contenidos

  • ZMQContext::__construct — Construir un nuevo objeto ZMQContext
  • ZMQContext::getOpt — Obtener la opción de contexto
  • ZMQContext::getSocket — Crear un nuevo socket
  • ZMQContext::isPersistent — Indicar si el contexto es persistente
  • ZMQContext::setOpt — Establecer una opción de socket


Construir un nuevo objeto ZMQContext

  • « ZMQContext
  • ZMQContext::getOpt »
  • PHP Manual
  • ZMQContext
  • Construir un nuevo objeto ZMQContext

ZMQContext::__construct

(PECL zmq >= 0.5.0)

ZMQContext::__construct — Construir un nuevo objeto ZMQContext

Descripción

ZMQContext::__construct ( int $io_threads = 1 , bool $is_persistent = true )

Construye un nuevo contexto ZMQ. Este se emplea para inicializar sockets. Se requiere una conexión persistente para inicializar sockets persistentes.

Parámetros

io_threads

Número de hilos de entrada/salida del contexto.

is_persistent

Si el contexto es persistente. Los contextos persistentes se almacenan durante múltiples peticiones, por lo que son un requisito para los sockets persistentes.

Ejemplos

Ejemplo #1 Un ejemplo de ZMQContext()

Construir un nuevo contexto y asignarle un socket de petición

<?php
/* Asignar un nuevo contexto */
$context = new ZMQContext();

/* Crear un nuevo socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Conectar con el socket */
$socket->connect("tcp://example.com:1234");

/* Enviar una petición */
$socket->send("Hello there");

/* Recibir la respuesta */
$message = $socket->recv();
?>

Valores devueltos

Lanza una ZMQContextException si la inicialización del contexto falla.


Obtener la opción de contexto

  • « ZMQContext::__construct
  • ZMQContext::getSocket »
  • PHP Manual
  • ZMQContext
  • Obtener la opción de contexto

ZMQContext::getOpt

(PECL zmq >= 1.0.4)

ZMQContext::getOpt — Obtener la opción de contexto

Descripción

public ZMQContext::getOpt ( string $key ) : mixed

Devuelve el valor de una opción de contexto.

Parámetros

key

Un entero que representa la opción. Véanse las constantes ZMQ::CTXOPT_*.

Valores devueltos

Devuelve un string o un int, dependiendo de key. Lanza una ZMQContextException en caso de error.


Crear un nuevo socket

  • « ZMQContext::getOpt
  • ZMQContext::isPersistent »
  • PHP Manual
  • ZMQContext
  • Crear un nuevo socket

ZMQContext::getSocket

(PECL zmq >= 0.5.0)

ZMQContext::getSocket — Crear un nuevo socket

Descripción

public ZMQContext::getSocket ( int $type , string $persistent_id = null , callback $on_new_socket = null ) : ZMQSocket

Método rápido para crear nuevos sockets desde un contexto. Si el contexto no es persistente, el parámetro persistent_id es ignorado y el socket se convierte en no persistente. on_new_socket solamente se invoca cuando se crea una estructura de socket subyacente.

Parámetros

type

Constante ZMQ::SOCKET_* para especificar el tipo de socket.

persistent_id

Si se especifica persistent_id, el socket será persistente durante varias peticiones.

on_new_socket

Función de retrollamada que es ejecutada cuando se crea una nueva estrucutra de socket. Esta función no es invocada si la conexión persistente subyacente es reutilizada. La retrollamada toma ZMQSocket y persistent_id como dos argumentos.

Ejemplos

Ejemplo #1 Un ejemplo de ZMQContext()

Basic usage

<?php
/* Asignar un nuevo contexto */
$context = new ZMQContext();

/* Crear un nuevo socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Conectar con el socket */
$socket->connect("tcp://example.com:1234");

/* Enviar una petición */
$socket->send("Hello there");

/* Recibir la respuesta */
$message = $socket->recv();
echo "Received message: {$message}\n";
?>

Valores devueltos

Devuelve un objeto ZMQSocket en caso de éxito. Lanza una ZMQSocketException en caso de error.


Indicar si el contexto es persistente

  • « ZMQContext::getSocket
  • ZMQContext::setOpt »
  • PHP Manual
  • ZMQContext
  • Indicar si el contexto es persistente

ZMQContext::isPersistent

(PECL zmq >= 0.5.0)

ZMQContext::isPersistent — Indicar si el contexto es persistente

Descripción

public ZMQContext::isPersistent ( ) : bool

Indica si el contexto es persistente. Un contexto persistente es necesario para conexiones persistentes, ya que cada socket se asigna a partir de un contexto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el contexto es persistente y false si no lo es.


Establecer una opción de socket

  • « ZMQContext::isPersistent
  • ZMQSocket »
  • PHP Manual
  • ZMQContext
  • Establecer una opción de socket

ZMQContext::setOpt

(PECL zmq >= 1.0.4)

ZMQContext::setOpt — Establecer una opción de socket

Descripción

public ZMQContext::setOpt ( int $key , mixed $value ) : ZMQContext

Establece una opción de contexto de ZMQ. El tipo del valor value depende de key. Véanse los Tipos de constantes de ZMQ para más información.

Parámetros

key

Una de las constantes ZMQ::CTXOPT_*.

value

El valor del parámetro.

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQContextException en caso de error.


La clase ZMQSocket

(PECL zmq >= 0.5.0)

Introducción

Sinopsis de la Clase

ZMQSocket {
/* Métodos */
public bind ( string $dsn , bool $force = false ) : ZMQSocket
public connect ( string $dsn , bool $force = false ) : ZMQSocket
__construct ( ZMQContext $context , int $type , string $persistent_id = null , callback $on_new_socket = null )
public disconnect ( string $dsn ) : ZMQSocket
public getEndpoints ( ) : array
public getPersistentId ( ) : string
public getSocketType ( ) : int
public getSockOpt ( string $key ) : mixed
public isPersistent ( ) : bool
public recv ( int $mode = 0 ) : string
public recvMulti ( int $mode = 0 ) : array
public send ( string $message , int $mode = 0 ) : ZMQSocket
public sendmulti ( array $message , int $mode = 0 ) : ZMQSocket
public setSockOpt ( int $key , mixed $value ) : ZMQSocket
public unbind ( string $dsn ) : ZMQSocket
}

Tabla de contenidos

  • ZMQSocket::bind — Vincular el socket
  • ZMQSocket::connect — Contectar el socket
  • ZMQSocket::__construct — Construir un nuevo ZMQSocket
  • ZMQSocket::disconnect — Desconectar un socket
  • ZMQSocket::getEndpoints — Obtener una lista de los extremos
  • ZMQSocket::getPersistentId — Obtener el ID de persistencia
  • ZMQSocket::getSocketType — Obtener el tipo de socket
  • ZMQSocket::getSockOpt — Obtener la opción de un socket
  • ZMQSocket::isPersistent — Comprobrar si un socket es persistente
  • ZMQSocket::recv — Recibir un mensaje
  • ZMQSocket::recvMulti — Recibir un mensaje multiparte
  • ZMQSocket::send — Enviar un mensaje
  • ZMQSocket::sendmulti — Enviar un mensaje multiparte
  • ZMQSocket::setSockOpt — Establecer una opción de socket
  • ZMQSocket::unbind — Desvincular el socket


Vincular el socket

  • « ZMQSocket
  • ZMQSocket::connect »
  • PHP Manual
  • ZMQSocket
  • Vincular el socket

ZMQSocket::bind

(PECL zmq >= 0.5.0)

ZMQSocket::bind — Vincular el socket

Descripción

public ZMQSocket::bind ( string $dsn , bool $force = false ) : ZMQSocket

Vincula el socket a un extremo. El extremo está definido en formato transporte://dirección donde transporte es uno de los siguientes: inproc, ipc, tcp, pgm o epgm.

Parámetros

dsn

El DSN del vículo, por ejemplo transporte://dirección.

force

Intenta el vínculo incluso si elm socket ya ha sido vinculado al extremo dado.

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQSocketException en caso de error.


Contectar el socket

  • « ZMQSocket::bind
  • ZMQSocket::__construct »
  • PHP Manual
  • ZMQSocket
  • Contectar el socket

ZMQSocket::connect

(PECL zmq >= 0.5.0)

ZMQSocket::connect — Contectar el socket

Descripción

public ZMQSocket::connect ( string $dsn , bool $force = false ) : ZMQSocket

Contecta el socket a un extremo remoto. El extremo está definido en formato transporte://dirección donde transporte es uno de los siguientes: inproc, ipc, tcp, pgm o epgm.

Parámetros

dsn

El DSN de la conexión, por ejemplo transporte://dirección.

force

Intenta la conexión incluso si elm socket ya ha sido conectado al extremo dado.

Ejemplos

Ejemplo #1 Un ejemplo de ZMQContext()

Construir un nuevo contexto y asignar un socket de petición

<?php
/* Nombre de host del servidor */
$dsn = "tcp://127.0.0.1:5555";

/* Crear un socket */
$socket = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ, 'my socket');

/* Obtener una lista de los extremos conectados */
$endpoints = $socket->getEndpoints();

/* Comprobar si el socket está conectado */
if (!in_array($dsn, $endpoints['connect'])) {
    echo "<p>Conectando a $dsn</p>";
    $socket->connect($dsn);
} else {
    echo "<p>Ya se ha contectado a $dsn</p>";
}

/* Enviar y recibir */
$socket->send("¡Hola!");
$message = $socket->recv();

echo "<p>El servidor dice: {$message}</p>";
?>

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQSocketException en caso de error.


Construir un nuevo ZMQSocket

  • « ZMQSocket::connect
  • ZMQSocket::disconnect »
  • PHP Manual
  • ZMQSocket
  • Construir un nuevo ZMQSocket

ZMQSocket::__construct

(PECL zmq >= 0.5.0)

ZMQSocket::__construct — Construir un nuevo ZMQSocket

Descripción

ZMQSocket::__construct ( ZMQContext $context , int $type , string $persistent_id = null , callback $on_new_socket = null )

Construye un objeto ZMQSocket. Se puede utilizar el parámetro persistent_id para asignar un socket persistente. Un socket persistente tiene que ser asignado desde un contexto persistente, por lo que permanece conectado durante múltiples peticiones. Se puede emplear el parámetro persistent_id para recordar el mismo socket durante múltiples peticiones. on_new_socket es llamado solamente cuando se crea un nueva estructura de socket subyacente.

Parámetros

context

Un objeto ZMQContext.

type

El tipo de socket. Véanse las constantes ZMQ::SOCKET_*.

persistent_id

Si se especifica persistent_id, el socket será persistente durante múltiples peticiones. Si context no es persistente, el socket recurrirá al modo no persistente.

on_new_socket

Función de retrollamada que es ejecutada cuando se crea una nueva estrucutra de socket. Esta función no es invocada si la conexión persistente subyacente es reutilizada.

Ejemplos

Ejemplo #1 Un ejemplo de ZMQSocket()

Utilizar una callback the bind/connect socket

<?php

/*
  El socket es persistente, por lo que esta función es llamada solamente en la
  primera petición del script.
*/
function on_new_socket_cb(ZMQSocket $socket, $persistent_id = null)
{
    if ($persistent_id === 'server') {
        $socket->bind("tcp://localhost:12122");
    } else {
        $socket->connect("tcp://localhost:12122");
    }
}

/* Asignar un nuevo contexto */
$context = new ZMQContext();

/* Crear un nuevo socket */
$socket = $context->getSocket(ZMQ::SOCKET_REP, 'server', 'on_new_socket_cb');

$message = $socket->recv();
echo "Mensaje recibido: {$message}\n";
?>

La función de la retrollamada

Nota:

function on_new_socket_cb(ZMQSocket $socket, string $persistent_id = null);

Valores devueltos

Lanza una ZMQSocketException en caso de error.


Desconectar un socket

  • « ZMQSocket::__construct
  • ZMQSocket::getEndpoints »
  • PHP Manual
  • ZMQSocket
  • Desconectar un socket

ZMQSocket::disconnect

(PECL zmq >= 1.0.4)

ZMQSocket::disconnect — Desconectar un socket

Descripción

public ZMQSocket::disconnect ( string $dsn ) : ZMQSocket

Desconectar el socket de un extremo remoto conectado previamente. El extremo está definido con el formato transporte://dirección, donde transporte es uno de los siguientes: inproc, ipc, tcp, pgm o epgm.

Parámetros

dsn

El DSN de conexión, por ejemplo transporte://dirección.

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQSocketException en caso de error.


Obtener una lista de los extremos

  • « ZMQSocket::disconnect
  • ZMQSocket::getPersistentId »
  • PHP Manual
  • ZMQSocket
  • Obtener una lista de los extremos

ZMQSocket::getEndpoints

(PECL zmq >= 0.5.0)

ZMQSocket::getEndpoints — Obtener una lista de los extremos

Descripción

public ZMQSocket::getEndpoints ( ) : array

Devuelve una lista de los extremos donde el socket está conectado o vinculado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array que contiene los elementos 'bind' y 'connect'.


Obtener el ID de persistencia

  • « ZMQSocket::getEndpoints
  • ZMQSocket::getSocketType »
  • PHP Manual
  • ZMQSocket
  • Obtener el ID de persistencia

ZMQSocket::getPersistentId

(PECL zmq >= 0.5.0)

ZMQSocket::getPersistentId — Obtener el ID de persistencia

Descripción

public ZMQSocket::getPersistentId ( ) : string

Devuelve el ID de persistencia del socket.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el ID de persistencia asignado al objeto, y null si el socket no es persistente.


Obtener el tipo de socket

  • « ZMQSocket::getPersistentId
  • ZMQSocket::getSockOpt »
  • PHP Manual
  • ZMQSocket
  • Obtener el tipo de socket

ZMQSocket::getSocketType

(PECL zmq >= 0.5.0)

ZMQSocket::getSocketType — Obtener el tipo de socket

Descripción

public ZMQSocket::getSocketType ( ) : int

Obtiene el tipo de socket.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un número entero que representa el tipo de socket. El número entero puede ser comparado con las constantes ZMQ::SOCKET_*.


Obtener la opción de un socket

  • « ZMQSocket::getSocketType
  • ZMQSocket::isPersistent »
  • PHP Manual
  • ZMQSocket
  • Obtener la opción de un socket

ZMQSocket::getSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::getSockOpt — Obtener la opción de un socket

Descripción

public ZMQSocket::getSockOpt ( string $key ) : mixed

Devuelve el valor de la opción de un socket.

Parámetros

key

Un número entero que representa la opción. Véanse las constantes ZMQ::SOCKOPT_*.

Valores devueltos

Devuelve un string o un int dependiendo de key. Lanza una ZMQSocketException en caso de error.


Comprobrar si un socket es persistente

  • « ZMQSocket::getSockOpt
  • ZMQSocket::recv »
  • PHP Manual
  • ZMQSocket
  • Comprobrar si un socket es persistente

ZMQSocket::isPersistent

(PECL zmq >= 0.5.0)

ZMQSocket::isPersistent — Comprobrar si un socket es persistente

Descripción

public ZMQSocket::isPersistent ( ) : bool

Comprueba si el socket es persistente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un bool basado en si el socket es persistente o no.


Recibir un mensaje

  • « ZMQSocket::isPersistent
  • ZMQSocket::recvMulti »
  • PHP Manual
  • ZMQSocket
  • Recibir un mensaje

ZMQSocket::recv

(PECL zmq >= 0.5.0)

ZMQSocket::recv — Recibir un mensaje

Descripción

public ZMQSocket::recv ( int $mode = 0 ) : string

Recibe un mensaje de un socket. Por defecto, la recepción quedará en espera hasta que haya disponible un mensaje, a menos que se emplee la bandera ZMQ::MODE_DONTWAIT. Se puede emplear la opción de socket ZMQ::SOCKOPT_RCVMORE para recibir mensajes multiparte. Véase ZMQSocket::setSockOpt() para más información.

Parámetros

mode

Proporcionar banderas de modo para recibir mensajes multiparte o hacer que la operación no quede en espera. Véanse las constantes ZMQ::MODE_*.

Ejemplos

Ejemplo #1 Un ejemplo de send/recv

Envío / respuesta sin esperas

<?php

/* Crear un nuevo objeto cola, debe existir un servidor en el otro extremo */
$cola = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ);
$cola->connect("tcp://127.0.0.1:5555");

/* Asginar el socket 1 a la cola, enviar y recibir */
$reintentos = 5;
$sending = true;

/* Iniciar y recorrer */
do {
    try {
        /* Intentar enviar / recibir */
        if ($sending) {
            echo "Enviando el mensaje\n";
            $cola->send("Este es un mensaje", ZMQ::MODE_DONTWAIT);
            $sending = false;
        } else {
            echo "Respuesta obtenida: " . $cola->recv(ZMQ::MODE_DONTWAIT) . "\n";
            break;
        }
    } catch (ZMQSocketException $e) {
        /* EAGAIN significa que la operación tendrá que esperar, reintentar */
        if ($e->getCode() === ZMQ::ERR_EAGAIN) {
            echo " - EAGAIN, reintentando ($reintentos)\n";
        } else {
            die(" - Error: " . $e->getMessage());
        }
    }
    /* Dormir un poco entre operaciones */
    usleep(5);
} while (--$reintentos);
?>

El resultado del ejemplo sería algo similar a:

Enviando el mensaje
 - Unable to execute operation, retrying (4)
Respuesta obtenida: Este es un mensaje

Valores devueltos

Devuelve el mensaje. Lanza una ZMQSocketException en caso de error. Si se emplea ZMQ::MODE_DONTWAIT y la operación debería quedar en espera, se devolverá el bool false.


Recibir un mensaje multiparte

  • « ZMQSocket::recv
  • ZMQSocket::send »
  • PHP Manual
  • ZMQSocket
  • Recibir un mensaje multiparte

ZMQSocket::recvMulti

(PECL zmq >= 0.8.0)

ZMQSocket::recvMulti — Recibir un mensaje multiparte

Descripción

public ZMQSocket::recvMulti ( int $mode = 0 ) : array

Recibe un array con el mensaje multiparte de un socket. Por defecto, la recepción quedará en espera hasta que haya disponible un mensaje, a menos que se emplee la bandera ZMQ::MODE_NOBLOCK.

Parámetros

mode

Proporcionar banderas de modo para recibir mensajes multiparte o hacer que la operación no quede en espera. Véanse las constantes ZMQ::MODE_*.

Valores devueltos

Devuelve el array con las partes del mensaje. Lanza una ZMQSocketException en caso de error. Si se emplea ZMQ::MODE_NOBLOCK y la operación debería quedar en espera, se devolverá el bool false.


Enviar un mensaje

  • « ZMQSocket::recvMulti
  • ZMQSocket::sendmulti »
  • PHP Manual
  • ZMQSocket
  • Enviar un mensaje

ZMQSocket::send

(PECL zmq >= 0.5.0)

ZMQSocket::send — Enviar un mensaje

Descripción

public ZMQSocket::send ( string $message , int $mode = 0 ) : ZMQSocket

Envía un mensaje mediante el socket. La operación puede quedar en espera, a menos que se emplee ZMQ::MODE_NOBLOCK.

Parámetros

message

El mensaje a enviar.

mode

Proporcionar banderas de modo para recibir mensajes multiparte o hacer que la operación no quede en espera. Véanse las constantes ZMQ::MODE_*.

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQSocketException en caso de error. Si se emplea ZMQ::MODE_NOBLOCK y la operación debería quedar en espera, se devolverá el bool false.


Enviar un mensaje multiparte

  • « ZMQSocket::send
  • ZMQSocket::setSockOpt »
  • PHP Manual
  • ZMQSocket
  • Enviar un mensaje multiparte

ZMQSocket::sendmulti

(PECL zmq >= 0.8.0)

ZMQSocket::sendmulti — Enviar un mensaje multiparte

Descripción

public ZMQSocket::sendmulti ( array $message , int $mode = 0 ) : ZMQSocket

Envía un mensaje multiparte mediante el socket. La operación puede quedar en espera, a menos que se emplee ZMQ::MODE_NOBLOCK.

Parámetros

message

El mensaje a enviar - un array de cadenas

mode

Proporcionar banderas de modo para recibir mensajes multiparte o hacer que la operación no quede en espera. Véanse las constantes ZMQ::MODE_*.

Valores devueltos

Devuelve el objeto actual. Lanza una ZMQSocketException en caso de error. Si se emplea ZMQ::MODE_NOBLOCK y la operación debería quedar en espera, se devolverá el bool false.


Establecer una opción de socket

  • « ZMQSocket::sendmulti
  • ZMQSocket::unbind »
  • PHP Manual
  • ZMQSocket
  • Establecer una opción de socket

ZMQSocket::setSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::setSockOpt — Establecer una opción de socket

Descripción

public ZMQSocket::setSockOpt ( int $key , mixed $value ) : ZMQSocket

Establece una opción de socket de ZMQ. El tipo del valor value depende de la clave key. Véanse los Tipos de constantes de ZMQ para más información.

Parámetros

key

Uno de las constantes ZMQ::SOCKOPT_*.

value

El valor del parámetro.

Valores devueltos

Devuelve el objeto actual. Lanaza una ZMQSocketException en caso de error.


Desvincular el socket

  • « ZMQSocket::setSockOpt
  • ZMQPoll »
  • PHP Manual
  • ZMQSocket
  • Desvincular el socket

ZMQSocket::unbind

(PECL zmq >= 1.0.4)

ZMQSocket::unbind — Desvincular el socket

Descripción

public ZMQSocket::unbind ( string $dsn ) : ZMQSocket

Desvincula el socket de un extremo. El extremo está definido con el formato transporte://dirección, donde transporte es uno de los siguientes: inproc, ipc, tcp, pgm o epgm.

Parámetros

dsn

El DSN vinculado previamente, por ejemplo transporte://dirección.

Valores devueltos

Devuelve el objeto actual. Lanaza una ZMQSocketException en caso de error.


La clase ZMQPoll

(PECL zmq >= 0.5.0)

Introducción

Sinopsis de la Clase

ZMQPoll {
/* Métodos */
public add ( mixed $entry , int $type ) : string
public clear ( ) : ZMQPoll
public count ( ) : int
public getLastErrors ( ) : array
public poll ( array &$readable , array &$writable , int $timeout = -1 ) : int
public remove ( mixed $item ) : bool
}

Tabla de contenidos

  • ZMQPoll::add — Añadir un elemento al conjunto de sondeo
  • ZMQPoll::clear — Limpiar el conjunto de sondeo
  • ZMQPoll::count — Contar los elementos del conjunto de sondeo
  • ZMQPoll::getLastErrors — Obtener los errores del sondeo
  • ZMQPoll::poll — Sondear los elementos
  • ZMQPoll::remove — Eliminar un elemento del conjunto de sondeo


Añadir un elemento al conjunto de sondeo

  • « ZMQPoll
  • ZMQPoll::clear »
  • PHP Manual
  • ZMQPoll
  • Añadir un elemento al conjunto de sondeo

ZMQPoll::add

(PECL zmq >= 0.5.0)

ZMQPoll::add — Añadir un elemento al conjunto de sondeo

Descripción

public ZMQPoll::add ( mixed $entry , int $type ) : string

Añade un nuevo elemento al conjunto de sondeo y devuelve el ID interno de dicho elemento. El elemento puede ser eliminado del conjunto de sondeo utilizando el ID devuelto.

Parámetros

entry

Un objeto ZMQSocket o un recursode de flujo de PHP

type

Defina la actidad para la que es sondeado el socket Véanse las constantes ZMQ::POLL_IN y ZMQ::POLL_OUT.

Valores devueltos

Devuelve el ID del elemento añadido, el cual puede ser empleado más adelante para eliminar el elemento. Lanza una ZMQPollException en caso de error.


Limpiar el conjunto de sondeo

  • « ZMQPoll::add
  • ZMQPoll::count »
  • PHP Manual
  • ZMQPoll
  • Limpiar el conjunto de sondeo

ZMQPoll::clear

(PECL zmq >= 0.5.0)

ZMQPoll::clear — Limpiar el conjunto de sondeo

Descripción

public ZMQPoll::clear ( ) : ZMQPoll

Limpia todos los elementos del conjuntos de sondeo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current object.


Contar los elementos del conjunto de sondeo

  • « ZMQPoll::clear
  • ZMQPoll::getLastErrors »
  • PHP Manual
  • ZMQPoll
  • Contar los elementos del conjunto de sondeo

ZMQPoll::count

(PECL zmq >= 0.5.0)

ZMQPoll::count — Contar los elementos del conjunto de sondeo

Descripción

public ZMQPoll::count ( ) : int

Cuenta los elementos del conjunto de sondeo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un int que representa la cantidad de elementos del conjunto de sondeo.


Obtener los errores del sondeo

  • « ZMQPoll::count
  • ZMQPoll::poll »
  • PHP Manual
  • ZMQPoll
  • Obtener los errores del sondeo

ZMQPoll::getLastErrors

(PECL zmq >= 0.5.0)

ZMQPoll::getLastErrors — Obtener los errores del sondeo

Descripción

public ZMQPoll::getLastErrors ( ) : array

Devuelve los ID de los objetos que poseen errores en el último sondeo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devueve un array que contiene los ID de los elementos que poseen errores en el último sondeo. Se devuelve un array vacío si no hay errores.


Sondear los elementos

  • « ZMQPoll::getLastErrors
  • ZMQPoll::remove »
  • PHP Manual
  • ZMQPoll
  • Sondear los elementos

ZMQPoll::poll

(PECL zmq >= 0.5.0)

ZMQPoll::poll — Sondear los elementos

Descripción

public ZMQPoll::poll ( array &$readable , array &$writable , int $timeout = -1 ) : int

Sondea los elementos en el conjunto de sondeo actual. Los elementos legibles y escribibles son devueltos en los parámetros readable y writable respectivamente. Se puede utilizar ZMQPoll::getLastErrors() para comprobar si existen errores.

Parámetros

readable

Un array donde se sevuelven los flujos de PHP/ZMQSockets legibles. El array se limpiará al inicio de la operación.

writable

Un array donde se sevuelven los flujos de PHP/ZMQSockets escribibles. El array se limpiará al inicio de la operación.

timeout

Tiempo de espera de la operación. -1 significa que el sondeo esperará hasta que al menos un elemento tenga actividad. Observe que desde la versión 1.0.0, el tiempo de espera del sondeo está definido en milisegundos, en lugar de en microsegundos.

Ejemplos

Ejemplo #1 Un ejemplo de ZMQPoll()

Crear un servidor de sondeos sencillo

<?php

/* Crear un socket, patrón de petición-respuesta (socket de respuesta) */
$context = new ZMQContext();
$server  = $context->getSocket(ZMQ::SOCKET_REP);

/* Vincular al puerta 5555 en 127.0.0.1 */
$server->bind("tcp://127.0.0.1:5555");

/* Crear un conjunto de sondeo nuevo para mensajes entrantes/salientes */
$poll = new ZMQPoll();

/* Añadir el objeto y escuchar la entrada/salida del sondeo */
$id = $poll->add($server, ZMQ::POLL_IN | ZMQ::POLL_OUT);
echo "Se añaió el objeto con id " . $id . "\n";

/* Inicializar los arrays readable y writable */
$readable = array();
$writable = array();

while (true) {
   /* Cantidad de eventos recuperados */
   $events = 0;

   try {
       /* Sondear hasta que haya algo que hacer */
       $events = $poll->poll($readable, $writable, -1);
       $errors = $poll->getLastErrors();

       if (count($errors) > 0) {
           foreach ($errors as $error) {
               echo "Error al sondear el objeto " . $error . "\n";
           }
       }
   } catch (ZMQPollException $e) {
       echo "Fallón el sondeo: " . $e->getMessage() . "\n";
   }

   if ($events > 0) {
       /* Recorrer los objetos legibles y los mensajes recibidos */
       foreach ($readable as $r) {
           try {
               echo "Mensaje recibido: " . $r->recv() . "\n";
           } catch (ZMQException $e) {
               echo "Falló la recepción: " . $e->getMessage() . "\n";
           }
       }

       /* Recorrer los objetos escribibles y enviar de vuelta los mensajes */
       foreach ($writable as $w) {
           try {
               $w->send("Got it!");
           } catch (ZMQException $e) {
               echo "Falló el envío: " . $e->getMessage() . "\n";
           }
       }
   }
}
?>

Valores devueltos

Devuelve un número entero que representa la cantidad de elementos con actividad. Lanza una ZMQPollException en caso de error.


Eliminar un elemento del conjunto de sondeo

  • « ZMQPoll::poll
  • ZMQDevice »
  • PHP Manual
  • ZMQPoll
  • Eliminar un elemento del conjunto de sondeo

ZMQPoll::remove

(PECL zmq >= 0.5.0)

ZMQPoll::remove — Eliminar un elemento del conjunto de sondeo

Descripción

public ZMQPoll::remove ( mixed $item ) : bool

Elimina un elemento del conjunto de sondeo. El parámetro item puede ser un objeto ZMQSocket, un recurso de flujo o el ID devuelto por el método ZMQPoll::add().

Parámetros

item

El objeto ZMQSocket, flujo de PHP o string con el ID del elemento.

Valores devueltos

Devuelve true si el objeto se eliminó y false si el objeto con el ID dado no existe en el conjunto de sondeo.


La clase ZMQDevice

(PECL zmq >= 0.5.0)

Introducción

Sinopsis de la Clase

ZMQDevice {
/* Métodos */
__construct ( ZMQSocket $frontend , ZMQSocket $backend , ZMQSocket $listener = ? )
public getIdleTimeout ( ) : ZMQDevice
public getTimerTimeout ( ) : ZMQDevice
public run ( ) : void
public setIdleCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice
public setIdleTimeout ( int $timeout ) : ZMQDevice
public setTimerCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice
public setTimerTimeout ( int $timeout ) : ZMQDevice
}

Tabla de contenidos

  • ZMQDevice::__construct — Construir un nuevo dispositivo
  • ZMQDevice::getIdleTimeout — Obtener el tiempo de espera de inactividad
  • ZMQDevice::getTimerTimeout — Obtener el tiempo de espera del temporizador
  • ZMQDevice::run — Ejecutar el nuevo dispositivo
  • ZMQDevice::setIdleCallback — Establecer la función de retrollamada de inactividad
  • ZMQDevice::setIdleTimeout — Establecer el tiempo de espera para la inactividad
  • ZMQDevice::setTimerCallback — Establecer la función de retrollamada del temporizador
  • ZMQDevice::setTimerTimeout — Establecer el tiempo de espera del temporizador


Construir un nuevo dispositivo

  • « ZMQDevice
  • ZMQDevice::getIdleTimeout »
  • PHP Manual
  • ZMQDevice
  • Construir un nuevo dispositivo

ZMQDevice::__construct

(PECL zmq >= 0.5.0)

ZMQDevice::__construct — Construir un nuevo dispositivo

Descripción

ZMQDevice::__construct ( ZMQSocket $frontend , ZMQSocket $backend , ZMQSocket $listener = ? )

"Los dispositivos de ØMQ pueden hacer de intermediarios de direcciones, servicios, colas o cualquier abstracción que se defina sobre las capas de mensaje y socket." -- zguide

Parámetros

frontend

Parámetro "frontend" para los dispositivos. Normalmente donde llegan los mensajes.

backend

Parámetro "backend" para los dispositivos. Normalmente donde van los mensajes.

listener

Socket escuchador, el cual recibe una copia de todos los mensajes en ambas direcciones. El tipo de este socket debería ser SUB, PULL o DEALER.

Valores devueltos

Una llamada a este método preparará el dispositivo. Normalmente, los dispositivos son procesos de larga ejecución, por lo que no se recomienda la ejecución de este método desde un script interactivo. Este método lanza una ZMQDeviceException si el dispositivo no puede iniciarse.


Obtener el tiempo de espera de inactividad

  • « ZMQDevice::__construct
  • ZMQDevice::getTimerTimeout »
  • PHP Manual
  • ZMQDevice
  • Obtener el tiempo de espera de inactividad

ZMQDevice::getIdleTimeout

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::getIdleTimeout — Obtener el tiempo de espera de inactividad

Descripción

public ZMQDevice::getIdleTimeout ( ) : ZMQDevice

Obtiene el valor del tiempo de espera para la retrollamada de inactividad. Añadido en la versión 1.1.0 de la extensión ZMQ.

Valores devueltos

Este método devuelve el valor del tiempo de espera de la retrollamada del temporizador.


Obtener el tiempo de espera del temporizador

  • « ZMQDevice::getIdleTimeout
  • ZMQDevice::run »
  • PHP Manual
  • ZMQDevice
  • Obtener el tiempo de espera del temporizador

ZMQDevice::getTimerTimeout

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::getTimerTimeout — Obtener el tiempo de espera del temporizador

Descripción

public ZMQDevice::getTimerTimeout ( ) : ZMQDevice

Obtiene el valor del tiempo de espera para la retrollamada del temporizador. Añadido en la versión 1.1.0 de la extensión ZMQ.

Valores devueltos

Este método devuelve el valor del tiempo de espera del temporizador.


Ejecutar el nuevo dispositivo

  • « ZMQDevice::getTimerTimeout
  • ZMQDevice::setIdleCallback »
  • PHP Manual
  • ZMQDevice
  • Ejecutar el nuevo dispositivo

ZMQDevice::run

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::run — Ejecutar el nuevo dispositivo

Descripción

public ZMQDevice::run ( ) : void

Ejecuta el dispositivo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una llamada a este método hará que quede en espera hasta que el dispositivo esté en ejecución. No se recomienda que los dispositivos se utilicen desde script interactivos. En caso de fallo, este método lanzará una ZMQDeviceException.


Establecer la función de retrollamada de inactividad

  • « ZMQDevice::run
  • ZMQDevice::setIdleTimeout »
  • PHP Manual
  • ZMQDevice
  • Establecer la función de retrollamada de inactividad

ZMQDevice::setIdleCallback

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::setIdleCallback — Establecer la función de retrollamada de inactividad

Descripción

public ZMQDevice::setIdleCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice

Sets the idle callback function. If idle timeout is defined the idle callback function shall be called if the internal poll loop times out without events. If the callback function returns false or a value that evaluates to false the device is stopped. The callback function signature is callback (mixed $user_data). Establece la función de retrollamada de inactividad. Si el tiempo de espera está definido, la función de retrollamada de inactividad será invocada si el bucle de sondeo interno expira sin eventos. Si la función de retrollamada devuelve false o un valor que se evalúa como false, el dispositivo se detendrá. La firma de la función de retrollamada es callback (mixed $datos_usuario).

Parámetros

cb_func

Función de retrollamada a invocar cuando el dispositivo está inactivo. La devolución de false o de un valor que se evalú como false por parte de esta función causará la detención del dispositivo.

timeout

Frecuencia con la que se invoca la retrollamada de inactividad en milisegundos. La retrollamada de inactividad se invoca periódicamente cuando no hay actividad en el dispositivo. El valor del tiempo de espera garantiza que haya al menos dicha cantidad de milisegundos entre invocaciones a la función de retrollamada.

user_data

Datos adcionales a pasar a la función de retrollamada.

Valores devueltos

En caso de éxito, este método devuelve el objeto actual.


Establecer el tiempo de espera para la inactividad

  • « ZMQDevice::setIdleCallback
  • ZMQDevice::setTimerCallback »
  • PHP Manual
  • ZMQDevice
  • Establecer el tiempo de espera para la inactividad

ZMQDevice::setIdleTimeout

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::setIdleTimeout — Establecer el tiempo de espera para la inactividad

Descripción

public ZMQDevice::setIdleTimeout ( int $timeout ) : ZMQDevice

Establece el valor del tiempo de espera de la retrollamada de inactividad. La retrollamada de inactividad se invoca periódicamente invoked cuando el dispositivo está inactivo.

Parámetros

timeout

El valor del tiempo de espera de la retrollamada de inactividad.

Valores devueltos

En caso de éxito, este método devuelve el objeto actual.


Establecer la función de retrollamada del temporizador

  • « ZMQDevice::setIdleTimeout
  • ZMQDevice::setTimerTimeout »
  • PHP Manual
  • ZMQDevice
  • Establecer la función de retrollamada del temporizador

ZMQDevice::setTimerCallback

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::setTimerCallback — Establecer la función de retrollamada del temporizador

Descripción

public ZMQDevice::setTimerCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice

Establece la función de retrollamada del temporizador. La retrollamada del temporizador será invocada después de haber pasado el tiempo de espera. La diferencia entre las retrollamadas de inactividad y del temporizador es que la de inactividad es invocada solamente cuando el dispositivo está inactivo. La firma de la función de retrollamada es callback (mixed $datos_usuario). Se añadió en la verisón 1.1.0 de la extensión ZMQ.

Parámetros

cb_func

Función de retrollamada a invocar cuando el dispositivo está inactivo. La devolución de false o de un valor que se evalú como false por parte de esta función causará la detención del dispositivo.

timeout

Frecuencia con la que se invoca la retrollamada de inactividad en milisegundos. La retrollamada de inactividad se invoca periódicamente cuando no hay actividad en el dispositivo. El valor del tiempo de espera garantiza que haya al menos dicha cantidad de milisegundos entre invocaciones a la función de retrollamada.

user_data

Datos adcionales a pasar a la función de retrollamada.

Valores devueltos

En caso de éxito, este método devuelve el objeto actual.


Establecer el tiempo de espera del temporizador

  • « ZMQDevice::setTimerCallback
  • ZooKeeper »
  • PHP Manual
  • ZMQDevice
  • Establecer el tiempo de espera del temporizador

ZMQDevice::setTimerTimeout

(No hay información de versión disponible, podría estar únicamente en Git)

ZMQDevice::setTimerTimeout — Establecer el tiempo de espera del temporizador

Descripción

public ZMQDevice::setTimerTimeout ( int $timeout ) : ZMQDevice

Establece el valor de tiempo de espera de la retrollamada del temporizador. La retrollamada del temporizador se invoca periódicamente si está establecida. Se añadion en la versión 1.1.0 de la extensión ZMQ.

Parámetros

timeout

El valor del tiempo de espera de la retrollamada del temporizador.

Valores devueltos

En caso de éxito, este método devuelve el objeto actual.


ZooKeeper

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • ZooKeeper Funciones
    • zookeeper_dispatch — Calls callbacks for pending operations
  • Zookeeper — La clase Zookeeper
    • Zookeeper::addAuth — Specify application credentials
    • Zookeeper::close — Close the zookeeper handle and free up any resources
    • Zookeeper::connect — Create a handle to used communicate with zookeeper
    • Zookeeper::__construct — Create a handle to used communicate with zookeeper
    • Zookeeper::create — Create a node synchronously
    • Zookeeper::delete — Delete a node in zookeeper synchronously
    • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously
    • Zookeeper::get — Gets the data associated with a node synchronously
    • Zookeeper::getAcl — Gets the acl associated with a node synchronously
    • Zookeeper::getChildren — Lists the children of a node synchronously
    • Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getConfig — Get instance of ZookeeperConfig
    • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
    • Zookeeper::getState — Get the state of the zookeeper connection
    • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered
    • Zookeeper::set — Sets the data associated with a node
    • Zookeeper::setAcl — Sets the acl associated with a node synchronously
    • Zookeeper::setDebugLevel — Sets the debugging level for the library
    • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization
    • Zookeeper::setLogStream — Sets the stream to be used by the library for logging
    • Zookeeper::setWatcher — Set a watcher function
  • ZookeeperConfig — La clase ZookeeperConfig
    • ZookeeperConfig::add — Add servers to the ensemble
    • ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
    • ZookeeperConfig::remove — Remove servers from the ensemble
    • ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperException — La clase ZookeeperException
  • ZookeeperAuthenticationException — La clase ZookeeperAuthenticationException
  • ZookeeperConnectionException — La clase ZookeeperConnectionException
  • ZookeeperMarshallingException — La clase ZookeeperMarshallingException
  • ZookeeperNoNodeException — La clase ZookeeperNoNodeException
  • ZookeeperOperationTimeoutException — La clase ZookeeperOperationTimeoutException
  • ZookeeperSessionException — La clase ZookeeperSessionException


Introducción

Esta extensión utiliza la biblioteca libzookeeper para proporcionar una API para comunicarse con el servicio ZooKeeper.

ZooKeeper es un proyecto Apache que permite un servicio centralizado para mantener la información de configuración, nombrar, proporcionar sincronización distribuida y proporcionar servicios de grupo.


Requerimientos

Esta extensión requiere » ZooKeeper C Binding (version 3.4.1 o superior). Para más información, véase » Guía del programador de ZooKeeper.

Esta extensión requiere PHP version 5.2.0 o superior. Desde 0.6.0, esta requiere PHP version 7.0.0 o superior.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/zookeeper.

Para habilitar el soporte de zookeeper, configure con --with-libzookeeper-dir=DIR. DIR es el prefijo de instalación de ZooKeeper C Binding, que debe contener el include/zookeeper/zookeeper.h

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Zookeeper Opciones de configuración
Nombre | Por defecto | Cambiable | Changelog
zookeeper.recv_timeout | 10000 | PHP_INI_ALL |
zookeeper.session_lock | 1 | PHP_INI_SYSTEM |
zookeeper.sess_lock_wait | 150000 | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

zookeeper.recv_timeout integer

El tiempo de espera por defecto para cualquier sesión de ZooKeeper.

zookeeper.session_lock integer

Activar bloqueo de sesión PHP.

zookeeper.sess_lock_wait integer

El bloqueo de giro de la sesión PHP a reintentar el tiempo de espera en microsegundos. Tenga cuidado al establecer este valor. Los valores válidos son enteros, donde 0 se interpreta como el valor por defecto. Los valores negativos resultan en un bloqueo reducido a un bloqueo de prueba.


  • « Tipos de recursos
  • ZooKeeper Funciones »
  • PHP Manual
  • ZooKeeper
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • zookeeper_dispatch »
  • PHP Manual
  • ZooKeeper
  • ZooKeeper Funciones

ZooKeeper Funciones

Tabla de contenidos

  • zookeeper_dispatch — Calls callbacks for pending operations


Calls callbacks for pending operations

  • « ZooKeeper Funciones
  • Zookeeper »
  • PHP Manual
  • ZooKeeper Funciones
  • Calls callbacks for pending operations

zookeeper_dispatch

(PECL zookeeper >= 0.4.0)

zookeeper_dispatch — Calls callbacks for pending operations

Descripción

zookeeper_dispatch ( ) : void

The zookeeper_dispatch() function calls the callbacks passwd by operations like Zookeeper::get() or Zookeeper::exists().

Precaución

Since version 0.4.0, this function must be called manually to achieve asynchronous operations. If you want that to be done automatically, you also can declare ticks at the beginning of your program.

After PHP 7.1, you can ignore this function. This extension uses EG(vm_interrupt) to implement async dispatch.

Errores/Excepciones

This method emits PHP warning when callback could not be invoked.

Ejemplos

Ejemplo #1 zookeeper_dispatch() example #1

Dispatch callbacks manually.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->get('/zookeeper', function() {
    echo "Callback was called".PHP_EOL;
});
while(true) {
    sleep(1);
    zookeeper_dispatch();
}
?>

Ejemplo #2 zookeeper_dispatch() example #2

Declare ticks.

<?php
declare(ticks=1);

$client = new Zookeeper();
$client->connect('localhost:2181');
$client->get('/zookeeper', function() {
    echo "Callback was called".PHP_EOL;
});
while(true) {
    sleep(1);
}
?>

Ver también

  • Zookeeper::addAuth() - Specify application credentials
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::exists() - Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • Zookeeper::setWatcher() - Set a watcher function


La clase Zookeeper

(PECL zookeeper >= 0.1.0)

Introducción

Representa la sesión de ZooKeeper.

Sinopsis de la Clase

Zookeeper {
/* Métodos */
public __construct ( string $host = '' , callable $watcher_cb = null , int $recv_timeout = 10000 )
public addAuth ( string $scheme , string $cert , callable $completion_cb = null ) : bool
public close ( ) : void
public connect ( string $host , callable $watcher_cb = null , int $recv_timeout = 10000 ) : void
public create ( string $path , string $value , array $acls , int $flags = null ) : string
public delete ( string $path , int $version = -1 ) : bool
public exists ( string $path , callable $watcher_cb = null ) : array
public get ( string $path , callable $watcher_cb = null , array &$stat = null , int $max_size = 0 ) : string
public getAcl ( string $path ) : array
public getChildren ( string $path , callable $watcher_cb = null ) : array
public getClientId ( ) : int
public getConfig ( ) : ZookeeperConfig
public getRecvTimeout ( ) : int
public getState ( ) : int
public isRecoverable ( ) : bool
public set ( string $path , string $value , int $version = -1 , array &$stat = null ) : bool
public setAcl ( string $path , int $version , array $acl ) : bool
public static setDebugLevel ( int $logLevel ) : bool
public static setDeterministicConnOrder ( bool $yesOrNo ) : bool
public setLogStream ( resource $stream ) : bool
public setWatcher ( callable $watcher_cb ) : bool
/* Constantes */
const integer PERM_READ = 1 ;
const integer PERM_WRITE = 2 ;
const integer PERM_CREATE = 4 ;
const integer PERM_DELETE = 8 ;
const integer PERM_ADMIN = 16 ;
const integer PERM_ALL = 31 ;
const integer EPHEMERAL = 1 ;
const integer SEQUENCE = 2 ;
const integer LOG_LEVEL_ERROR = 1 ;
const integer LOG_LEVEL_WARN = 2 ;
const integer LOG_LEVEL_INFO = 3 ;
const integer LOG_LEVEL_DEBUG = 4 ;
const integer EXPIRED_SESSION_STATE = -112 ;
const integer AUTH_FAILED_STATE = -113 ;
const integer CONNECTING_STATE = 1 ;
const integer ASSOCIATING_STATE = 2 ;
const integer CONNECTED_STATE = 3 ;
const integer READONLY_STATE = 5 ;
const integer NOTCONNECTED_STATE = 999 ;
const integer CREATED_EVENT = 1 ;
const integer DELETED_EVENT = 2 ;
const integer CHANGED_EVENT = 3 ;
const integer CHILD_EVENT = 4 ;
const integer SESSION_EVENT = -1 ;
const integer NOTWATCHING_EVENT = -2 ;
const integer SYSTEMERROR = -1 ;
const integer RUNTIMEINCONSISTENCY = -2 ;
const integer DATAINCONSISTENCY = -3 ;
const integer CONNECTIONLOSS = -4 ;
const integer MARSHALLINGERROR = -5 ;
const integer UNIMPLEMENTED = -6 ;
const integer OPERATIONTIMEOUT = -7 ;
const integer BADARGUMENTS = -8 ;
const integer INVALIDSTATE = -9 ;
const integer NEWCONFIGNOQUORUM = -13 ;
const integer RECONFIGINPROGRESS = -14 ;
const integer OK = 0 ;
const integer APIERROR = -100 ;
const integer NONODE = -101 ;
const integer NOAUTH = -102 ;
const integer BADVERSION = -103 ;
const integer NOCHILDRENFOREPHEMERALS = -108 ;
const integer NODEEXISTS = -110 ;
const integer NOTEMPTY = -111 ;
const integer SESSIONEXPIRED = -112 ;
const integer INVALIDCALLBACK = -113 ;
const integer INVALIDACL = -114 ;
const integer AUTHFAILED = -115 ;
const integer CLOSING = -116 ;
const integer NOTHING = -117 ;
const integer SESSIONMOVED = -118 ;
const integer NOTREADONLY = -119 ;
const integer EPHEMERALONLOCALSESSION = -120 ;
const integer NOWATCHER = -121 ;
const integer RECONFIGDISABLED = -122 ;
}

Constantes predefinidas

Permisos ZooKeeper

Zookeeper::PERM_READ

Puede leer el valor de los nodos y enumerar sus hijos

Zookeeper::PERM_WRITE

Puede establecer el valor de los nodos

Zookeeper::PERM_CREATE

Puede crear hijos

Zookeeper::PERM_DELETE

Puede eliminar hijos

Zookeeper::PERM_ADMIN

Puede ejecutar set_acl()

Zookeeper::PERM_ALL

Todas las flags anteriores ORd together

ZooKeeper Create Flags

Zookeeper::EPHEMERAL

Si la flag Zookeeper::EPHEMERAL es establecida, el nodo se eliminará automáticamente si la sesión del cliente desaparece.

Zookeeper::SEQUENCE

Si la flag Zookeeper::SEQUENCE flag es establecida, un número de secuencia ascendente único se añade al nombre de la ruta. El número de secuencia es siempre de longitud fija de 10 dígitos, 0 relleno.

ZooKeeper Log Levels

Zookeeper::LOG_LEVEL_ERROR

Emite sólo mensajes de error

Zookeeper::LOG_LEVEL_WARN

Emite errores/advertencias

Zookeeper::LOG_LEVEL_INFO

Emite grandes mensajes de acción además de errores/advertencias

Zookeeper::LOG_LEVEL_DEBUG

Emite todo

ZooKeeper States

Zookeeper::EXPIRED_SESSION_STATE

Conectado pero la sesión expiró

Zookeeper::AUTH_FAILED_STATE

Conectado pero la autentificación falló

Zookeeper::CONNECTING_STATE

Conectando

Zookeeper::ASSOCIATING_STATE

Asociando

Zookeeper::CONNECTED_STATE

Conectado

Zookeeper::READONLY_STATE

TODO: Ayúdanos a mejorar esta extensión.

Zookeeper::NOTCONNECTED_STATE

La conexión falló

Tipos de relojes ZooKeeper

Zookeeper::CREATED_EVENT

Se ha creado un nodo

Esto sólo se genera por los relojes en nodos inexistentes. Estos relojes se ajustan usando Zookeeper::exists.

Zookeeper::DELETED_EVENT

Se ha eliminado un nodo

Esto sólo se genera por los relojes de los nodos. Estos relojes se ajustan usando Zookeeper::exists and Zookeeper::get.

Zookeeper::CHANGED_EVENT

Un nodo ha cambiado

Esto sólo lo generan los relojes de los nodos. Estos relojes se ajustan usando Zookeeper::exists and Zookeeper::get.

Zookeeper::CHILD_EVENT

Un cambio como el ocurrido en la lista de hijos

Esto sólo se genera por los relojes en la lista de hijos de un nodo. Estos relojes se ajustan usando Zookeeper::getChildren.

Zookeeper::SESSION_EVENT

Se ha perdido una sesión

Esto se genera cuando un cliente pierde el contacto o se reconecta con un servidor.

Zookeeper::NOTWATCHING_EVENT

Se ha quitado un reloj

Esto se genera cuando el servidor, por alguna razón, probablemente una limitación de recursos, ya no vigila un nodo para un cliente.

Errores del sistema y del servidor ZooKeeper

Zookeeper::SYSTEMERROR

Esto nunca es lanzado por el servidor, no debe ser usado más que para indicar un rango. Específicamente códigos de error mayores que este valor, pero menores que Zookeeper::APIERROR, son errores del sistema.

Zookeeper::RUNTIMEINCONSISTENCY

Se encontró una inconsistencia en el tiempo de ejecución.

Zookeeper::DATAINCONSISTENCY

Se encontró una inconsistencia en los datos.

Zookeeper::CONNECTIONLOSS

Se ha perdido la conexión con el servidor.

Zookeeper::MARSHALLINGERROR

Error al ordenar o desordenar los datos.

Zookeeper::UNIMPLEMENTED

La operación no se ha llevado a cabo.

Zookeeper::OPERATIONTIMEOUT

Tiempo de espera de la operación.

Zookeeper::BADARGUMENTS

Argumentos inválidos.

Zookeeper::INVALIDSTATE

Estado de zhandle inválido.

Zookeeper::NEWCONFIGNOQUORUM

Ningún grupo de nueva configuración está conectado y actualizado con el líder de la última configuración realizada. - intente invocar la reconfiguración después de que los nuevos servidores estén conectados y sincronizados.

Disponible a partir de ZooKeeper 3.5.0

Zookeeper::RECONFIGINPROGRESS

Se solicita una reconfiguración mientras se está llevando a cabo otra reconfiguración. Esto no se soporta actualmente. Por favor, vuelva a intentarlo..

Disponible a partir de ZooKeeper 3.5.0

Errores de la API ZooKeeper

Zookeeper::OK

Todo está bien.

Zookeeper::APIERROR

Esto nunca es lanzado por el servidor, no debe usarse más que para indicar un rango. Específicamente los códigos de error mayores que este valor son errores de la API (mientras que los valores inferiores a éste indican una Zookeeper::SYSTEMERROR).

Zookeeper::NONODE

El nodo no existe.

Zookeeper::NOAUTH

No está autentificado.

Zookeeper::BADVERSION

Conflicto de versiones.

Zookeeper::NOCHILDRENFOREPHEMERALS

Los nodos efímeros pueden no tener hijos.

Zookeeper::NODEEXISTS

El nodo ya existe.

Zookeeper::NOTEMPTY

El nodo tiene hijos.

Zookeeper::SESSIONEXPIRED

La sesión ha expirado por el servidor.

Zookeeper::INVALIDCALLBACK

Se especificó una devolución de llamada inválida.

Zookeeper::INVALIDACL

Se especificó un LCA inválido.

Zookeeper::AUTHFAILED

La autentificación del cliente falló.

Zookeeper::CLOSING

ZooKeeper está cerrando.

Zookeeper::NOTHING

(no error) No hay respuestas del servidor al proceso.

Zookeeper::SESSIONMOVED

La sesión se movió a otro servidor, así que la operación es ignorada.

Zookeeper::NOTREADONLY

La solicitud de cambio de estado se pasa al servidor de sólo lectura.

Zookeeper::EPHEMERALONLOCALSESSION

Intentar crear un nodo efímero en una sesión local.

Zookeeper::NOWATCHER

El observador no pudo ser encontrado.

Zookeeper::RECONFIGDISABLED

Intentar realizar una operación de reconfiguración cuando la función de reconfiguración está desactivada.

Tabla de contenidos

  • Zookeeper::addAuth — Specify application credentials
  • Zookeeper::close — Close the zookeeper handle and free up any resources
  • Zookeeper::connect — Create a handle to used communicate with zookeeper
  • Zookeeper::__construct — Create a handle to used communicate with zookeeper
  • Zookeeper::create — Create a node synchronously
  • Zookeeper::delete — Delete a node in zookeeper synchronously
  • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get — Gets the data associated with a node synchronously
  • Zookeeper::getAcl — Gets the acl associated with a node synchronously
  • Zookeeper::getChildren — Lists the children of a node synchronously
  • Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • Zookeeper::getConfig — Get instance of ZookeeperConfig
  • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
  • Zookeeper::getState — Get the state of the zookeeper connection
  • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered
  • Zookeeper::set — Sets the data associated with a node
  • Zookeeper::setAcl — Sets the acl associated with a node synchronously
  • Zookeeper::setDebugLevel — Sets the debugging level for the library
  • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization
  • Zookeeper::setLogStream — Sets the stream to be used by the library for logging
  • Zookeeper::setWatcher — Set a watcher function


Specify application credentials

  • « Zookeeper
  • Zookeeper::close »
  • PHP Manual
  • Zookeeper
  • Specify application credentials

Zookeeper::addAuth

(PECL zookeeper >= 0.1.0)

Zookeeper::addAuth — Specify application credentials

Descripción

public Zookeeper::addAuth ( string $scheme , string $cert , callable $completion_cb = null ) : bool

The application calls this function to specify its credentials for purposes of authentication. The server will use the security provider specified by the scheme parameter to authenticate the client connection. If the authentication request has failed: - the server connection is dropped. - the watcher is called with the ZOO_AUTH_FAILED_STATE value as the state parameter.

Parámetros

scheme

The id of authentication scheme. Natively supported: "digest" password-based authentication

cert

Application credentials. The actual value depends on the scheme.

completion_cb

The routine to invoke when the request completes. One of the following result codes may be passed into the completion callback: - ZOK operation completed successfully - ZAUTHFAILED authentication failed

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::addAuth() example

Add auth before requesting node value.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$zookeeper->addAuth('digest', 'user0:passwd0');
$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

nodevalue

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously
  • ZooKeeper States
  • ZookeeperException


Close the zookeeper handle and free up any resources

  • « Zookeeper::addAuth
  • Zookeeper::connect »
  • PHP Manual
  • Zookeeper
  • Close the zookeeper handle and free up any resources

Zookeeper::close

(PECL zookeeper >= 0.5.0)

Zookeeper::close — Close the zookeeper handle and free up any resources

Descripción

public Zookeeper::close ( ) : void

Errores/Excepciones

This method emits ZookeeperException and it's derivatives when closing an uninitialized instance.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a handle to used communicate with zookeeper

  • « Zookeeper::close
  • Zookeeper::__construct »
  • PHP Manual
  • Zookeeper
  • Create a handle to used communicate with zookeeper

Zookeeper::connect

(PECL zookeeper >= 0.2.0)

Zookeeper::connect — Create a handle to used communicate with zookeeper

Descripción

public Zookeeper::connect ( string $host , callable $watcher_cb = null , int $recv_timeout = 10000 ) : void

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

Parámetros

host

Comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

The global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

The timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a handle to used communicate with zookeeper

  • « Zookeeper::connect
  • Zookeeper::create »
  • PHP Manual
  • Zookeeper
  • Create a handle to used communicate with zookeeper

Zookeeper::__construct

(PECL zookeeper >= 0.1.0)

Zookeeper::__construct — Create a handle to used communicate with zookeeper

Descripción

public Zookeeper::__construct ( string $host = '' , callable $watcher_cb = null , int $recv_timeout = 10000 )

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

Parámetros

host

comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

the global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a node synchronously

  • « Zookeeper::__construct
  • Zookeeper::delete »
  • PHP Manual
  • Zookeeper
  • Create a node synchronously

Zookeeper::create

(PECL zookeeper >= 0.1.0)

Zookeeper::create — Create a node synchronously

Descripción

public Zookeeper::create ( string $path , string $value , array $acls , int $flags = null ) : string

This method will create a node in ZooKeeper. A node can only be created if it does not already exists. The Create Flags affect the creation of nodes. If ZOO_EPHEMERAL flag is set, the node will automatically get removed if the client session goes away. If the ZOO_SEQUENCE flag is set, a unique monotonically increasing sequence number is appended to the path name.

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

acls

The initial ACL of the node. The ACL must not be null or empty.

flags

this parameter can be set to 0 for normal create or an OR of the Create Flags

Valores devueltos

Returns the path of the new node (this might be different than the supplied path because of the ZOO_SEQUENCE flag) on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to create node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::create() example

Create a new node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$realPath = $zookeeper->create($path, null, $aclArray);
if ($realPath)
  echo $realPath;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

/path/to/newnode

Ver también

  • Zookeeper::delete() - Delete a node in zookeeper synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Delete a node in zookeeper synchronously

  • « Zookeeper::create
  • Zookeeper::exists »
  • PHP Manual
  • Zookeeper
  • Delete a node in zookeeper synchronously

Zookeeper::delete

(PECL zookeeper >= 0.2.0)

Zookeeper::delete — Delete a node in zookeeper synchronously

Descripción

public Zookeeper::delete ( string $path , int $version = -1 ) : bool

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to delete node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::delete() example

Delete a existing node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->delete($path);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

SUCCESS

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • ZookeeperException


Checks the existence of a node in zookeeper synchronously

  • « Zookeeper::delete
  • Zookeeper::get »
  • PHP Manual
  • Zookeeper
  • Checks the existence of a node in zookeeper synchronously

Zookeeper::exists

(PECL zookeeper >= 0.1.0)

Zookeeper::exists — Checks the existence of a node in zookeeper synchronously

Descripción

public Zookeeper::exists ( string $path , callable $watcher_cb = null ) : array

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

if nonzero, a watch will be set at the server to notify the client if the node changes. The watch will be set even if the node does not

Valores devueltos

Returns the value of stat for the path if the given node exists, otherwise false.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to check the existence of a node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::exists() example

Check the existence of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->exists($path);
if ($r)
  echo 'EXISTS';
else
  echo 'N/A or ERR';
?>

El resultado del ejemplo sería:

EXISTS

Ver también

  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


Gets the data associated with a node synchronously

  • « Zookeeper::exists
  • Zookeeper::getAcl »
  • PHP Manual
  • Zookeeper
  • Gets the data associated with a node synchronously

Zookeeper::get

(PECL zookeeper >= 0.1.0)

Zookeeper::get — Gets the data associated with a node synchronously

Descripción

public Zookeeper::get ( string $path , callable $watcher_cb = null , array &$stat = null , int $max_size = 0 ) : string

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

stat

If not NULL, will hold the value of stat for the path on return.

max_size

Max size of the data. If 0 is used, this method will return the whole data.

Valores devueltos

Returns the data on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to get value from node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::get() example

Get value from node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

nodevalue

Ejemplo #2 Zookeeper::get() stat example

Get node stat info.

<?php
$zookeeper = new Zookeeper('localhost:2181');
$path = '/path/to/node';
$stat = [];
$zookeeper->get($path, null, $stat);
var_dump($stat);
?>

El resultado del ejemplo sería:

array(11) {
  ["czxid"]=>
  float(0)
  ["mzxid"]=>
  float(0)
  ["ctime"]=>
  float(0)
  ["mtime"]=>
  float(0)
  ["version"]=>
  int(0)
  ["cversion"]=>
  int(-2)
  ["aversion"]=>
  int(0)
  ["ephemeralOwner"]=>
  float(0)
  ["dataLength"]=>
  int(0)
  ["numChildren"]=>
  int(2)
  ["pzxid"]=>
  float(0)
}

Ver también

  • Zookeeper::set() - Sets the data associated with a node
  • ZookeeperException


Gets the acl associated with a node synchronously

  • « Zookeeper::get
  • Zookeeper::getChildren »
  • PHP Manual
  • Zookeeper
  • Gets the acl associated with a node synchronously

Zookeeper::getAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::getAcl — Gets the acl associated with a node synchronously

Descripción

public Zookeeper::getAcl ( string $path ) : array

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

Valores devueltos

Return acl array on success and false on failure.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to get ACL of a node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::getAcl() example

Get ACL of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Lists the children of a node synchronously

  • « Zookeeper::getAcl
  • Zookeeper::getClientId »
  • PHP Manual
  • Zookeeper
  • Lists the children of a node synchronously

Zookeeper::getChildren

(PECL zookeeper >= 0.1.0)

Zookeeper::getChildren — Lists the children of a node synchronously

Descripción

public Zookeeper::getChildren ( string $path , callable $watcher_cb = null ) : array

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

Valores devueltos

Returns an array with children paths on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to list children of a node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::getChildren() example

Lists children of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/zookeeper';
$r = $zookeeper->getchildren($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  string(6) "config"
}

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::delete() - Delete a node in zookeeper synchronously
  • ZookeeperException


Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

  • « Zookeeper::getChildren
  • Zookeeper::getConfig »
  • PHP Manual
  • Zookeeper
  • Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

Zookeeper::getClientId

(PECL zookeeper >= 0.1.0)

Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

Descripción

public Zookeeper::getClientId ( ) : int

Valores devueltos

Returns the client session id on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when it could not get client session id.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getState() - Get the state of the zookeeper connection
  • ZooKeeper States
  • ZookeeperException


Get instance of ZookeeperConfig

  • « Zookeeper::getClientId
  • Zookeeper::getRecvTimeout »
  • PHP Manual
  • Zookeeper
  • Get instance of ZookeeperConfig

Zookeeper::getConfig

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

Zookeeper::getConfig — Get instance of ZookeeperConfig

Descripción

public Zookeeper::getConfig ( ) : ZookeeperConfig

Valores devueltos

Returns instance of ZookeeperConfig.

Ver también

  • ZookeeperConfig


Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

  • « Zookeeper::getConfig
  • Zookeeper::getState »
  • PHP Manual
  • Zookeeper
  • Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

Zookeeper::getRecvTimeout

(PECL zookeeper >= 0.1.0)

Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

Descripción

public Zookeeper::getRecvTimeout ( ) : int

Valores devueltos

Returns the timeout for this session on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when operation fails.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Get the state of the zookeeper connection

  • « Zookeeper::getRecvTimeout
  • Zookeeper::isRecoverable »
  • PHP Manual
  • Zookeeper
  • Get the state of the zookeeper connection

Zookeeper::getState

(PECL zookeeper >= 0.1.0)

Zookeeper::getState — Get the state of the zookeeper connection

Descripción

public Zookeeper::getState ( ) : int

Valores devueltos

Returns the state of zookeeper connection on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when it fails to get state of zookeeper connection.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getClientId() - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
  • ZookeeperException


Checks if the current zookeeper connection state can be recovered

  • « Zookeeper::getState
  • Zookeeper::set »
  • PHP Manual
  • Zookeeper
  • Checks if the current zookeeper connection state can be recovered

Zookeeper::isRecoverable

(PECL zookeeper >= 0.1.0)

Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered

Descripción

public Zookeeper::isRecoverable ( ) : bool

The application must close the handle and try to reconnect.

Valores devueltos

Returns true/false on success, and false on failure.

Errores/Excepciones

This method emits PHP error/warning when operation fails.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getClientId() - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
  • ZookeeperException


Sets the data associated with a node

  • « Zookeeper::isRecoverable
  • Zookeeper::setAcl »
  • PHP Manual
  • Zookeeper
  • Sets the data associated with a node

Zookeeper::set

(PECL zookeeper >= 0.1.0)

Zookeeper::set — Sets the data associated with a node

Descripción

public Zookeeper::set ( string $path , string $value , int $version = -1 , array &$stat = null ) : bool

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to save value to node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::set() example

Save value to node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$r = $zookeeper->set($path, $value);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

SUCCESS

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


Sets the acl associated with a node synchronously

  • « Zookeeper::set
  • Zookeeper::setDebugLevel »
  • PHP Manual
  • Zookeeper
  • Sets the acl associated with a node synchronously

Zookeeper::setAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::setAcl — Sets the acl associated with a node synchronously

Descripción

public Zookeeper::setAcl ( string $path , int $version , array $acl ) : bool

Parámetros

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the path.

acl

The acl to be set on the path.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to set ACL for a node.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::setAcl() example

Set ACL for a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

Ver también

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Sets the debugging level for the library

  • « Zookeeper::setAcl
  • Zookeeper::setDeterministicConnOrder »
  • PHP Manual
  • Zookeeper
  • Sets the debugging level for the library

Zookeeper::setDebugLevel

(PECL zookeeper >= 0.1.0)

Zookeeper::setDebugLevel — Sets the debugging level for the library

Descripción

public static Zookeeper::setDebugLevel ( int $logLevel ) : bool

Parámetros

logLevel

ZooKeeper log level constants.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to set debug level.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ejemplos

Ejemplo #1 Zookeeper::setDebugLevel() example

Set debugl level.

<?php
$r = Zookeeper::setDebugLevel(Zookeeper::LOG_LEVEL_WARN);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>
?>

El resultado del ejemplo sería:

SUCCESS

Ver también

  • ZooKeeper Log Levels
  • ZookeeperException


Enable/disable quorum endpoint order randomization

  • « Zookeeper::setDebugLevel
  • Zookeeper::setLogStream »
  • PHP Manual
  • Zookeeper
  • Enable/disable quorum endpoint order randomization

Zookeeper::setDeterministicConnOrder

(PECL zookeeper >= 0.1.0)

Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization

Descripción

public static Zookeeper::setDeterministicConnOrder ( bool $yesOrNo ) : bool

If passed a true value, will make the client connect to quorum peers in the order as specified in the zookeeper_init() call. A false value causes zookeeper_init() to permute the peer endpoints which is good for more even client connection distribution among the quorum peers. ZooKeeper C Client uses false by default.

Parámetros

yesOrNo

Disable/enable quorum endpoint order randomization.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Sets the stream to be used by the library for logging

  • « Zookeeper::setDeterministicConnOrder
  • Zookeeper::setWatcher »
  • PHP Manual
  • Zookeeper
  • Sets the stream to be used by the library for logging

Zookeeper::setLogStream

(PECL zookeeper >= 0.1.0)

Zookeeper::setLogStream — Sets the stream to be used by the library for logging

Descripción

public Zookeeper::setLogStream ( resource $stream ) : bool

The zookeeper library uses stderr as its default log stream. Application must make sure the stream is writable. Passing in NULL resets the stream to its default value (stderr).

Parámetros

stream

The stream to be used by the library for logging.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::setDebugLevel() - Sets the debugging level for the library
  • ZookeeperException


Set a watcher function

  • « Zookeeper::setLogStream
  • ZookeeperConfig »
  • PHP Manual
  • Zookeeper
  • Set a watcher function

Zookeeper::setWatcher

(PECL zookeeper >= 0.1.0)

Zookeeper::setWatcher — Set a watcher function

Descripción

public Zookeeper::setWatcher ( callable $watcher_cb ) : bool

Parámetros

watcher_cb

A watch will be set at the server to notify the client if the node changes.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

This method emits PHP error/warning when parameters count or types are wrong or fail to set watcher.

Precaución

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

Ver también

  • Zookeeper::exists() - Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


La clase ZookeeperConfig

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

Introducción

La clase de manejo de configuración de ZooKeeper.

Sinopsis de la Clase

ZookeeperConfig {
/* Métodos */
public add ( string $members , int $version = -1 , array &$stat = null ) : void
public get ( callable $watcher_cb = null , array &$stat = null ) : string
public remove ( string $id_list , int $version = -1 , array &$stat = null ) : void
public set ( string $members , int $version = -1 , array &$stat = null ) : void
}

Tabla de contenidos

  • ZookeeperConfig::add — Add servers to the ensemble
  • ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::remove — Remove servers from the ensemble
  • ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers


Add servers to the ensemble

  • « ZookeeperConfig
  • ZookeeperConfig::get »
  • PHP Manual
  • ZookeeperConfig
  • Add servers to the ensemble

ZookeeperConfig::add

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::add — Add servers to the ensemble

Descripción

public ZookeeperConfig::add ( string $members , int $version = -1 , array &$stat = null ) : void

Parámetros

members

Comma separated list of servers to be added to the ensemble. Each has a configuration line for a server to be added (as would appear in a configuration file), only for maj. quorums.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

Errores/Excepciones

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

Ejemplos

Ejemplo #1 ZookeeperConfig::add() example

Add members.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181");
$zkConfig->add("server.2=localhost:2889:3889:participant;0.0.0.0:2182");
$r = $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

server.1=localhost:2888:3888:participant;0.0.0.0:2181
server.2=localhost:2889:3889:participant;0.0.0.0:2182
version=0xca01e881a2

Ver también

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

  • « ZookeeperConfig::add
  • ZookeeperConfig::remove »
  • PHP Manual
  • ZookeeperConfig
  • Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

ZookeeperConfig::get

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

Descripción

public ZookeeperConfig::get ( callable $watcher_cb = null , array &$stat = null ) : string

Parámetros

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

stat

If not NULL, will hold the value of stat for the path on return.

Valores devueltos

Returns the configuration string on success, and false on failure.

Errores/Excepciones

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to get configuration.

Ejemplos

Ejemplo #1 ZookeeperConfig::get() example

Get configuration.

<?php
$zk = new Zookeeper();
$zk->connect('localhost:2181');
$zk->addAuth('digest', 'timandes:timandes');
$zkConfig = $zk->getConfig();
$r = $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

server.1=localhost:2888:3888:participant;0.0.0.0:2181
version=0xca01e881a2

Ver también

  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


Remove servers from the ensemble

  • « ZookeeperConfig::get
  • ZookeeperConfig::set »
  • PHP Manual
  • ZookeeperConfig
  • Remove servers from the ensemble

ZookeeperConfig::remove

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::remove — Remove servers from the ensemble

Descripción

public ZookeeperConfig::remove ( string $id_list , int $version = -1 , array &$stat = null ) : void

Parámetros

id_list

Comma separated list of server IDs to be removed from the ensemble. Each has an id of a server to be removed, only for maj. quorums.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

Errores/Excepciones

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

Ejemplos

Ejemplo #1 ZookeeperConfig::remove() example

Remove members.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181,server.2=localhost:2889:3889:participant;0.0.0.0:2182");
$zkConfig->remove("2");
echo $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

El resultado del ejemplo sería:

server.1=localhost:2888:3888:participant;0.0.0.0:2181
version=0xca01e881a2

Ver también

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperException


Change ZK cluster ensemble membership and roles of ensemble peers

  • « ZookeeperConfig::remove
  • ZookeeperException »
  • PHP Manual
  • ZookeeperConfig
  • Change ZK cluster ensemble membership and roles of ensemble peers

ZookeeperConfig::set

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers

Descripción

public ZookeeperConfig::set ( string $members , int $version = -1 , array &$stat = null ) : void

Parámetros

members

Comma separated list of new membership (e.g., contents of a membership configuration file) - for use only with a non-incremental reconfiguration.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

Errores/Excepciones

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

Ejemplos

Ejemplo #1 ZookeeperConfig::set() example

Reconfig.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181");
?>

Ver también

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


La clase ZookeeperException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones de ZooKeeper.

Sinopsis de la Clase

ZookeeperException extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperAuthenticationException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones de autenticación de ZooKeeper.

Sinopsis de la Clase

ZookeeperAuthenticationException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperConnectionException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones de la conexión de ZooKeeper.

Sinopsis de la Clase

ZookeeperConnectionException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperMarshallingException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de la excepción ZooKeeper (mientras se marcan o desmarcan los datos).

Sinopsis de la Clase

ZookeeperMarshallingException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperNoNodeException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones ZooKeeper (cuando el nodo no existe).

Sinopsis de la Clase

ZookeeperNoNodeException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperOperationTimeoutException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones de la operación de ZooKeeper.

Sinopsis de la Clase

ZookeeperOperationTimeoutException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


La clase ZookeeperSessionException

(PECL zookeeper >= 0.3.0)

Introducción

La clase de manejo de excepciones de la sesión de ZooKeeper.

Sinopsis de la Clase

ZookeeperSessionException extends ZookeeperException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Extensiones para motores de búsqueda

  • Solr — Solr de Apache
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Solr
    • Ejemplos
    • SolrUtils — La clase SolrUtils
    • SolrInputDocument — La clase SolrInputDocument
    • SolrDocument — La clase SolrDocument
    • SolrDocumentField — La clase SolrDocumentField
    • SolrObject — La clase SolrObject
    • SolrClient — La clase SolrClient
    • SolrResponse — La clase SolrResponse
    • SolrQueryResponse — La clase SolrQueryResponse
    • SolrUpdateResponse — La clase SolrUpdateResponse
    • SolrPingResponse — La clase SolrPingResponse
    • SolrGenericResponse — La clase SolrGenericResponse
    • SolrParams — La clase SolrParams
    • SolrModifiableParams — La clase SolrModifiableParams
    • SolrQuery — La clase SolrQuery
    • SolrDisMaxQuery — La clase SolrDisMaxQuery
    • SolrCollapseFunction — La clase SolrCollapseFunction
    • SolrException — La clase SolrException
    • SolrClientException — La clase SolrClientException
    • SolrServerException — La clase SolrServerException
    • SolrIllegalArgumentException — La clase SolrIllegalArgumentException
    • SolrIllegalOperationException — La clase SolrIllegalOperationException
    • SolrMissingMandatoryParameterException — La clase SolrMissingMandatoryParameterException
  • Sphinx — Cliente Sphinx
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • SphinxClient — Clase SphinxClient


Solr de Apache

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Solr
    • solr_get_version — Devuelve la versión actual de la extensión Apache Solr
  • Ejemplos
  • SolrUtils — La clase SolrUtils
    • SolrUtils::digestXmlResponse — Convierte una cadena de respuesta XML a un objeto SolrObject
    • SolrUtils::escapeQueryChars — Escapa un string de consulta lucene
    • SolrUtils::getSolrVersion — Devuelve la versión actual de la extensión Solr
    • SolrUtils::queryPhrase — Prepara una frase desde una cadena lucene sin escapar
  • SolrInputDocument — La clase SolrInputDocument
    • SolrInputDocument::addChildDocument — Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments — Adds an array of child documents
    • SolrInputDocument::addField — Añade un campo al documento
    • SolrInputDocument::clear — Restablece el documento de entrada
    • SolrInputDocument::__clone — Crea una copia de un objeto SolrDocument
    • SolrInputDocument::__construct — Constructor
    • SolrInputDocument::deleteField — Elimina un campo del documento
    • SolrInputDocument::__destruct — Destructor
    • SolrInputDocument::fieldExists — Comprueba si existe un campo
    • SolrInputDocument::getBoost — Recupera el valor boost actual del documento
    • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrInputDocument::getField — Recupera un campo por su nombre
    • SolrInputDocument::getFieldBoost — Recupera el valor boost de un campo en particular
    • SolrInputDocument::getFieldCount — Devuelve el número de campos del documento
    • SolrInputDocument::getFieldNames — Devuelve una matriz que contiene todos los campos del documento
    • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
    • SolrInputDocument::merge — Fusiona un documento con otro
    • SolrInputDocument::reset — Este es un alias de SolrInputDocument::clear
    • SolrInputDocument::setBoost — Establece el valor boost de este documento
    • SolrInputDocument::setFieldBoost — Establece el valor boost de tiempo del índice de un campo
    • SolrInputDocument::sort — Ordena los campos dentro de un documento
    • SolrInputDocument::toArray — Devuelve una matriz como representación del documento de entrada
  • SolrDocument — La clase SolrDocument
    • SolrDocument::addField — añade un campo al documento
    • SolrDocument::clear — Borra todos los campos del documento
    • SolrDocument::__clone — Crea una copia de un objeto SolrDocument
    • SolrDocument::__construct — Constructor
    • SolrDocument::current — Recupera el campo actual
    • SolrDocument::deleteField — Elimina un campo del documento
    • SolrDocument::__destruct — Destructor
    • SolrDocument::fieldExists — Comprueba si existe un campo en el documento
    • SolrDocument::__get — Acceder al campo como una propiedad
    • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrDocument::getField — Recupera un campo según su nombre
    • SolrDocument::getFieldCount — Devuelve el número de campos de este documento
    • SolrDocument::getFieldNames — Devuelve una matriz con los nombres de campos del documento
    • SolrDocument::getInputDocument — Devuelve un SolrInputDocument equivalente al objeto
    • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
    • SolrDocument::__isset — Comprueba si existe un campo
    • SolrDocument::key — Recupera la clave actual
    • SolrDocument::merge — Fusiona la fuente con el objeto SolrDocument actual
    • SolrDocument::next — Mueve el puntero interno al siguiente campo
    • SolrDocument::offsetExists — Comprueba si existe un campo en particular
    • SolrDocument::offsetGet — Recupera un campo
    • SolrDocument::offsetSet — Añade un campo al documento
    • SolrDocument::offsetUnset — Elimina un campo
    • SolrDocument::reset — Este es un alias de SolrDocument::clear()
    • SolrDocument::rewind — Reinicia el puntero interno al principio
    • SolrDocument::serialize — Usado para serialización personalizada
    • SolrDocument::__set — Añade otro campo al documento
    • SolrDocument::sort — Ordena los campos del documento
    • SolrDocument::toArray — Devuelve una matriz como representación de un documento
    • SolrDocument::unserialize — Serialización personalizada de objetos SolrDocument
    • SolrDocument::__unset — Elimina un campo del documento
    • SolrDocument::valid — Comprueba si la posición actual del puntero interno es aún válida
  • SolrDocumentField — La clase SolrDocumentField
    • SolrDocumentField::__construct — Constructor
    • SolrDocumentField::__destruct — Destructor
  • SolrObject — La clase SolrObject
    • SolrObject::__construct — Crea un objeto Solr
    • SolrObject::__destruct — Destructor
    • SolrObject::getPropertyNames — Devuelve una matriz de todos los nombres de las propiedades
    • SolrObject::offsetExists — Comprueba si la propiedad existe
    • SolrObject::offsetGet — Usado para recuperar una propiedad
    • SolrObject::offsetSet — Establece el valor de una propiedad
    • SolrObject::offsetUnset — Desestablece el valor de la propiedad
  • SolrClient — La clase SolrClient
    • SolrClient::addDocument — Añade un documento al índice
    • SolrClient::addDocuments — Añade una colección de instancias de SolrInputDocument al índice
    • SolrClient::commit — Finaliza todas las añadiduras/eliminaciones hechas al índice
    • SolrClient::__construct — Constructor para el objeto SolrClient
    • SolrClient::deleteById — Eliminar por Id
    • SolrClient::deleteByIds — Elimina mediante Ids
    • SolrClient::deleteByQueries — Elimina todos los documentos que coincidan con cualquiera de las consultas
    • SolrClient::deleteByQuery — Elimina todos los documentos que coincidan con la consulta dada
    • SolrClient::__destruct — Destructor para SolrClient
    • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getDebug — Devuelve la información de depuración para el último intento de conexión
    • SolrClient::getOptions — Devuelve las opciones de cliente establecidas internamente
    • SolrClient::optimize — Defragmenta el índice
    • SolrClient::ping — Comprueba si el servidor Solr está todavía activo
    • SolrClient::query — Envía una consulta al servidor
    • SolrClient::request — Envía una petición de actualización sin formato
    • SolrClient::rollback — Revierte todos los añadidos/eliminados hechos en el índice desde el último envío
    • SolrClient::setResponseWriter — Establece el autor de la respuesta usado para preparar la respuesta de Solr
    • SolrClient::setServlet — Cambia el servlet especificado a un nuevo valor
    • SolrClient::system — Obtener información del Servidor Solr
    • SolrClient::threads — Verifica el estado de los hilos
  • SolrResponse — La clase SolrResponse
    • SolrResponse::getDigestedResponse — Devuelve la respueste XML como información de PHP serializada
    • SolrResponse::getHttpStatus — Devuelve el estado HTTP de la respuesta
    • SolrResponse::getHttpStatusMessage — Devuelve más detalles del estado HTTP
    • SolrResponse::getRawRequest — Devuelve la respuesta en bruto enviada al servidor Solr
    • SolrResponse::getRawRequestHeaders — Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr
    • SolrResponse::getRawResponse — Devuelve la respuesta sin tratar del servidor
    • SolrResponse::getRawResponseHeaders — Devuelve las cabeceras de respuesta sin tratar del servidor
    • SolrResponse::getRequestUrl — Devuelve la URL completa a la que se envió la respuesta
    • SolrResponse::getResponse — Devuelve un objeto SolrObject que representa la respuesta XML del servidor
    • SolrResponse::setParseMode — Establece el modo de análisis
    • SolrResponse::success — ¿Tuvo éxito la petición?
  • SolrQueryResponse — La clase SolrQueryResponse
    • SolrQueryResponse::__construct — Constructor
    • SolrQueryResponse::__destruct — Destructor
  • SolrUpdateResponse — La clase SolrUpdateResponse
    • SolrUpdateResponse::__construct — Constructor
    • SolrUpdateResponse::__destruct — Destructor
  • SolrPingResponse — La clase SolrPingResponse
    • SolrPingResponse::__construct — Constructor
    • SolrPingResponse::__destruct — Destructor
    • SolrPingResponse::getResponse — Devuelve la respuesta del servidor
  • SolrGenericResponse — La clase SolrGenericResponse
    • SolrGenericResponse::__construct — Constructor
    • SolrGenericResponse::__destruct — Destructor
  • SolrParams — La clase SolrParams
    • SolrParams::add — Esto es un alias de SolrParams::addParam
    • SolrParams::addParam — Añade un parámetro al objeto
    • SolrParams::get — Este es una alias de SolrParams::getParam
    • SolrParams::getParam — Devuelve el valor de un parámetro
    • SolrParams::getParams — Devuelve una matriz de parámetros URL no codificados
    • SolrParams::getPreparedParams — Devuelve una matriz de parámetros URL codificados
    • SolrParams::serialize — Usado para serialización personalizada
    • SolrParams::set — Un alas de SolrParams::setParam
    • SolrParams::setParam — Establece el parámetro al valor especificado
    • SolrParams::toString — Devuelve todos los parámetros de los pares nombre-valor del objeto
    • SolrParams::unserialize — Usado para serialización personalizada
  • SolrModifiableParams — La clase SolrModifiableParams
    • SolrModifiableParams::__construct — Constructor
    • SolrModifiableParams::__destruct — Destructor
  • SolrQuery — La clase SolrQuery
    • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group
    • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)
    • SolrQuery::addFacetDateField — Mapea a facet.date
    • SolrQuery::addFacetDateOther — Añade otro parámetro facet.date.other
    • SolrQuery::addFacetField — Añade otro campo a la faceta
    • SolrQuery::addFacetQuery — Añade una consulta de faceta
    • SolrQuery::addField — Especifica qué campos devolver en el resultado
    • SolrQuery::addFilterQuery — Especifica una consulta de filtro
    • SolrQuery::addGroupField — Add a field to be used to group results
    • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)
    • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query
    • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)
    • SolrQuery::addHighlightField — Mapea a hl.fl
    • SolrQuery::addMltField — Establece un campo para usarlo para similitud
    • SolrQuery::addMltQueryField — Mapea a mlt.qf
    • SolrQuery::addSortField — Usado para controlar cómo deberían ordenarse los resultados
    • SolrQuery::addStatsFacet — Recupera una devolución de subresultados para valores dentro de la faceta dada
    • SolrQuery::addStatsField — Mapea al parámetro stats.field
    • SolrQuery::collapse — Collapses the result set to a single document per group
    • SolrQuery::__construct — Constructor
    • SolrQuery::__destruct — Destructor
    • SolrQuery::getExpand — Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
    • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields — Returns an array of fields
    • SolrQuery::getFacet — Devuelve el valor del parámetro facet
    • SolrQuery::getFacetDateEnd — Devuelve el valor del parámetro facet.date.end
    • SolrQuery::getFacetDateFields — Devuelve todos los campos de facet.date
    • SolrQuery::getFacetDateGap — Devuelve el valor del parámetro facet.date.gap
    • SolrQuery::getFacetDateHardEnd — Devuelve el valor del parámetro facet.date.hardend
    • SolrQuery::getFacetDateOther — Devuelve el valor del parámetro facet.date.other
    • SolrQuery::getFacetDateStart — Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo
    • SolrQuery::getFacetFields — Devuelve todos los campos facet
    • SolrQuery::getFacetLimit — Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet
    • SolrQuery::getFacetMethod — Devuelve el valor del parámetro facet.method
    • SolrQuery::getFacetMinCount — Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta
    • SolrQuery::getFacetMissing — Devuelve el estado acutual del parámetro facet.missing
    • SolrQuery::getFacetOffset — Devuelve un índice dentro de la lista de restricciones para ser usado en paginación
    • SolrQuery::getFacetPrefix — Devuelve el prefijo de faceta
    • SolrQuery::getFacetQueries — Devuelve todas las consultas de facetas
    • SolrQuery::getFacetSort — Devuelve el tipo de ordenación de la faceta
    • SolrQuery::getFields — Devuelve la lista de campos que serán devueltos en la respuesta
    • SolrQuery::getFilterQueries — Devuelve una matriz de consultas de filtro
    • SolrQuery::getGroup — Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent — Returns group cache percent value
    • SolrQuery::getGroupFacet — Returns the group.facet parameter value
    • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat — Returns the group.format value
    • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit — Returns the group.limit value
    • SolrQuery::getGroupMain — Returns the group.main value
    • SolrQuery::getGroupNGroups — Returns the group.ngroups value
    • SolrQuery::getGroupOffset — Returns the group.offset value
    • SolrQuery::getGroupQueries — Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields — Returns the group.sort value
    • SolrQuery::getGroupTruncate — Returns the group.truncate value
    • SolrQuery::getHighlight — Devuelve el estado del parámtero hl
    • SolrQuery::getHighlightAlternateField — Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado
    • SolrQuery::getHighlightFields — Devuelve todos los campos que Solr debería generar para remarcación de trozos
    • SolrQuery::getHighlightFormatter — Devuelve el formateador de la salida remarcada
    • SolrQuery::getHighlightFragmenter — Devuelve el generador de trozos de texto para el texto remarcado
    • SolrQuery::getHighlightFragsize — Devuelve el número de caracteres de fragmentos a considerar para remarcación
    • SolrQuery::getHighlightHighlightMultiTerm — Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix
    • SolrQuery::getHighlightMaxAlternateFieldLength — Devuelve el número máximo de caracteres del campo a devolver
    • SolrQuery::getHighlightMaxAnalyzedChars — Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados
    • SolrQuery::getHighlightMergeContiguous — Devuelve si colapsar o no fragmentos contiguos en un único fragmento
    • SolrQuery::getHighlightRegexMaxAnalyzedChars — Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares
    • SolrQuery::getHighlightRegexPattern — Devuelve la expresión regular para la fragmentación
    • SolrQuery::getHighlightRegexSlop — Devuelve el factor de desviación del tamaño de fragmento ideal
    • SolrQuery::getHighlightRequireFieldMatch — Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular
    • SolrQuery::getHighlightSimplePost — Devuelve el texto que aparece después de un término remarcado
    • SolrQuery::getHighlightSimplePre — Devuelve el texto que aparece antes de un término remarcado
    • SolrQuery::getHighlightSnippets — Devuelve el número máximo de trozos remarcados a generar por campo
    • SolrQuery::getHighlightUsePhraseHighlighter — Devuelve el estado del parámetro hl.usePhraseHighlighter
    • SolrQuery::getMlt — Devuelve si los resultados MoreLikeThis deberían o no ser habilitados
    • SolrQuery::getMltBoost — Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés
    • SolrQuery::getMltCount — Devuelve el número de documentos similares a devolver para cada resultado
    • SolrQuery::getMltFields — Devuelve todos los campos a usar para similitud
    • SolrQuery::getMltMaxNumQueryTerms — Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada
    • SolrQuery::getMltMaxNumTokens — Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector
    • SolrQuery::getMltMaxWordLength — Devuelve la longitud máxima de palabra de las palabras que serán ignoradas
    • SolrQuery::getMltMinDocFrequency — Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas
    • SolrQuery::getMltMinTermFrequency — Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente
    • SolrQuery::getMltMinWordLength — Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas
    • SolrQuery::getMltQueryFields — Devuelve los campos de consultas y sus boosts
    • SolrQuery::getQuery — Devuelve la consulta principal
    • SolrQuery::getRows — Devuelve el número máximo de documentos
    • SolrQuery::getSortFields — Devuelve todos los campos de ordenación
    • SolrQuery::getStart — Devuelve el índice del conjunto de resultados completo
    • SolrQuery::getStats — Devuelve si están habilitadas o no las estadísticas
    • SolrQuery::getStatsFacets — Devuelve todas las estadísticas de las facetas que fueron establecidas
    • SolrQuery::getStatsFields — Devuelve todas las estadísticas de los campos
    • SolrQuery::getTerms — Devuelve si está habilitado o no TermsComponent
    • SolrQuery::getTermsField — Devuelve el campo desde el cuál los términos son recuperados
    • SolrQuery::getTermsIncludeLowerBound — Devuelve si incluir o no el límite inferior en el conjunto de resultados
    • SolrQuery::getTermsIncludeUpperBound — Devuelve si incluir o no el término de límite superior en el conjunto de resultados
    • SolrQuery::getTermsLimit — Devuelve el número máximo de términos que debería devolver Solr
    • SolrQuery::getTermsLowerBound — Devuelve el término en el que comenzar
    • SolrQuery::getTermsMaxCount — Devuelve la frecuencia de documento máxima
    • SolrQuery::getTermsMinCount — Devuelve la frecuencia de documento mínima a devolver para ser incluido
    • SolrQuery::getTermsPrefix — Devuelve el prefijo del término
    • SolrQuery::getTermsReturnRaw — Si devolver o no caracteres en bruto
    • SolrQuery::getTermsSort — Devuelve un entero indicando cómo son ordenados los términos
    • SolrQuery::getTermsUpperBound — Devuelve el término en donde parar
    • SolrQuery::getTimeAllowed — Devuelve el tiempo en milisegundos permitido para que la consulta finalice
    • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
    • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter
    • SolrQuery::removeFacetDateField — Elimina uno de los campos de faceta de fecha
    • SolrQuery::removeFacetDateOther — Elimina uno de los parámetros facet.date.other
    • SolrQuery::removeFacetField — Elimina uno de los parámetros facet.date
    • SolrQuery::removeFacetQuery — Elimina uno de los parámetros facet.query
    • SolrQuery::removeField — Elimina un campo de la lista de campos
    • SolrQuery::removeFilterQuery — Elimina una consulta de filtro
    • SolrQuery::removeHighlightField — Elimina uno de los campos usados para remarcación
    • SolrQuery::removeMltField — Elimina uno de los campos moreLikeThis
    • SolrQuery::removeMltQueryField — Elimina uno de los campos de consulta moreLikeThis
    • SolrQuery::removeSortField — Elimina uno de los campos de ordenación
    • SolrQuery::removeStatsFacet — Elimina uno de los parámetros stats.facet
    • SolrQuery::removeStatsField — Elimina uno de los parámetros stats.field
    • SolrQuery::setEchoHandler — Conmuta el parámetro echoHandler
    • SolrQuery::setEchoParams — Determina qué tipo de parámetros incluir en la respuesta
    • SolrQuery::setExpand — Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery — Sets the expand.q parameter
    • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther — Establece el parámetro de consulta común explainOther
    • SolrQuery::setFacet — Mapea al parámetro facet. Habilita o deshabilta las facetas
    • SolrQuery::setFacetDateEnd — Mapea a facet.date.end
    • SolrQuery::setFacetDateGap — Mapea a facet.date.gap
    • SolrQuery::setFacetDateHardEnd — Mapea a facet.date.hardend
    • SolrQuery::setFacetDateStart — Mapea a facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Establece la frecuencia de documento mínima usada para determinar la cuenta de términos
    • SolrQuery::setFacetLimit — Mapea a facet.limit
    • SolrQuery::setFacetMethod — Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo
    • SolrQuery::setFacetMinCount — Mapea a facet.mincount
    • SolrQuery::setFacetMissing — Mapea a facet.missing
    • SolrQuery::setFacetOffset — Establece el índice de la lista de restricciones para tener en cuenta la paginación
    • SolrQuery::setFacetPrefix — Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta
    • SolrQuery::setFacetSort — Determina el orden de las restricciones de campos de faceta
    • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent — Enables caching for result grouping
    • SolrQuery::setGroupFacet — Sets group.facet parameter
    • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)
    • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1
    • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
    • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results
    • SolrQuery::setGroupOffset — Sets the group.offset parameter
    • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query
    • SolrQuery::setHighlight — Habilita o deshabilita la remarcación
    • SolrQuery::setHighlightAlternateField — Especifica el campo de copia de seguridad a usar
    • SolrQuery::setHighlightFormatter — Especifica un formateador para la salida remarcada
    • SolrQuery::setHighlightFragmenter — Establece el generador de trozos de código para texto remarcado
    • SolrQuery::setHighlightFragsize — El tamaño de los fragmentos a considerara para remarcación
    • SolrQuery::setHighlightHighlightMultiTerm — Usa SpanScorer para remarcar términos de frases
    • SolrQuery::setHighlightMaxAlternateFieldLength — Establece el número máximo de caracteres del campo a devolver
    • SolrQuery::setHighlightMaxAnalyzedChars — Especifica el número de caracteres de un documento para buscar trozos apropiados
    • SolrQuery::setHighlightMergeContiguous — Si colapsar o no fragmentos contiguos en un único fragmento
    • SolrQuery::setHighlightRegexMaxAnalyzedChars — Especifica el número máximo de caracteres a analizar
    • SolrQuery::setHighlightRegexPattern — Especifica la expresión regular para la fragmentación
    • SolrQuery::setHighlightRegexSlop — Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal
    • SolrQuery::setHighlightRequireFieldMatch — Requerir la coincicencia de campos durante el remarcado
    • SolrQuery::setHighlightSimplePost — Establece el texto que aparece antes de un término remarcado
    • SolrQuery::setHighlightSimplePre — Establece el texto que aparece antes de un término remarcado
    • SolrQuery::setHighlightSnippets — Establece el número máximo de trozos remarcados para generar por campo
    • SolrQuery::setHighlightUsePhraseHighlighter — Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta
    • SolrQuery::setMlt — Habilita o deshabilita moreLikeThis
    • SolrQuery::setMltBoost — Establecer si la consulta será impulsada (boost) por la relevancia del término de interés
    • SolrQuery::setMltCount — Establece el número de documentos similares a devolver en cada resultado
    • SolrQuery::setMltMaxNumQueryTerms — Establece el número máximo de términos de consulta incluidos
    • SolrQuery::setMltMaxNumTokens — Especifica el número máximo de tokens a analizar
    • SolrQuery::setMltMaxWordLength — Establece la longitud de palabra máxima
    • SolrQuery::setMltMinDocFrequency — Establece la frecuencia de mltMinDoc
    • SolrQuery::setMltMinTermFrequency — Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente
    • SolrQuery::setMltMinWordLength — Establece la longitud de palabra mínima
    • SolrQuery::setOmitHeader — Excluye la cabecera de los resultados devueltos
    • SolrQuery::setQuery — Establece la consulta de búsqueda
    • SolrQuery::setRows — Especifica el número máximo de filas a devolver en el resultado
    • SolrQuery::setShowDebugInfo — Bandera para mostrar información de depuración
    • SolrQuery::setStart — Especifica el número de filas que se van a saltar
    • SolrQuery::setStats — Habilita o deshablita el componente de estadísticas
    • SolrQuery::setTerms — Habilita o deshablita TermsComponent
    • SolrQuery::setTermsField — Establece el nombre del campo del que obtener los términos
    • SolrQuery::setTermsIncludeLowerBound — Incluir el término de límite inferior en el conjunto de resultados
    • SolrQuery::setTermsIncludeUpperBound — Incluir el término de límite superior en el conjunto de resultados
    • SolrQuery::setTermsLimit — Establece el número máximo de términos a devolver
    • SolrQuery::setTermsLowerBound — Especifica el término de donde empezar
    • SolrQuery::setTermsMaxCount — Establece la frecuencia máxima de documentos
    • SolrQuery::setTermsMinCount — Establece la frecuencia mínima de documentos
    • SolrQuery::setTermsPrefix — Restringe las coincidencias de términos que comienzan con el prefijo
    • SolrQuery::setTermsReturnRaw — Devuelve los caracteres en bruto del término indexado
    • SolrQuery::setTermsSort — Especifica cómo ordenar los términos devueltos
    • SolrQuery::setTermsUpperBound — Establece el término en el que parar
    • SolrQuery::setTimeAllowed — El tiempo permitido para que la búsqueda finalice
  • SolrDisMaxQuery — La clase SolrDisMaxQuery
    • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::__construct — Class Constructor
    • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)
    • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax
  • SolrCollapseFunction — La clase SolrCollapseFunction
    • SolrCollapseFunction::__construct — Constructor
    • SolrCollapseFunction::getField — Returns the field that is being collapsed on
    • SolrCollapseFunction::getHint — Returns collapse hint
    • SolrCollapseFunction::getMax — Returns max parameter
    • SolrCollapseFunction::getMin — Returns min parameter
    • SolrCollapseFunction::getNullPolicy — Returns null policy
    • SolrCollapseFunction::getSize — Returns size parameter
    • SolrCollapseFunction::setField — Sets the field to collapse on
    • SolrCollapseFunction::setHint — Sets collapse hint
    • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query
    • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
    • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function
  • SolrException — La clase SolrException
    • SolrException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción
  • SolrClientException — La clase SolrClientException
    • SolrClientException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción
  • SolrServerException — La clase SolrServerException
    • SolrServerException::getInternalInfo — Devuelve información interna de dónde fue lanzada la excepción
  • SolrIllegalArgumentException — La clase SolrIllegalArgumentException
    • SolrIllegalArgumentException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción
  • SolrIllegalOperationException — La clase SolrIllegalOperationException
    • SolrIllegalOperationException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción
  • SolrMissingMandatoryParameterException — La clase SolrMissingMandatoryParameterException


Introducción

La extensión Solr permite comunicarse de manera efectiva con el servidor Solr de Apache en PHP.

La extensión Solr es una biblioteca extremadamente rápida, de pequeño tamaño, y con abundantes características que permite a los desarrolladores de PHP comunicarse de manera efectiva con las instancias del servidor Solr.

Las versiones 1.x de la Extensión PECL soportan el Servidor Solr de Apache 1.3-3.x

Las versiones 2.x de la Extensión PECL soportan el Servidor Solr de Apache 4.0+

Hay herramientas internas para añadir documentos y realizar actualizaciones al servidor solr.

También contiene herramientas que permiten realizar consultas avanzadas al servidor cuando se buscan documentos.


Requerimientos

Se requiere la versión de PHP 5.2.11 o superior.

Las bibliotecas libxml y curl también deben estar habilitadas para que esté disponible la extensión Apache Solr.

Se requiere libxml2 2.6.31 o posterior.

También se requiere libcurl 7.18.0 o posterior.

Las versiones de las bibliotecas de arriba son necesarias y se recomienda encarecidamente no intentar hackear el código para hacerlo compilar. Fallará, posiblemente con errores que podrían ser difíciles de depurar


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/solr.

Para obtener ayuda y soporte, visite la extensión en el grupo de Google. » Extensión PHP Apache Solr

Los binarios de Windows (ficheros DLL) para esta extensión de PECL están disponibles en el sitio web de PECL.

Nota:

El módulo solr se puede compilar en modo depuración pasando la bandera --enable-solr-debug a la configuración

Cuando se construya manualmente, asegúrese de incluir soporta para curl y libxml dentro de la construcción.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SOLR_MAJOR_VERSION (integer)
SOLR_MINOR_VERSION (integer)
SOLR_PATCH_VERSION (integer)
SOLR_EXTENSION_VERSION (string)


Funciones de Solr

Tabla de contenidos

  • solr_get_version — Devuelve la versión actual de la extensión Apache Solr


Devuelve la versión actual de la extensión Apache Solr

  • « Funciones de Solr
  • Ejemplos »
  • PHP Manual
  • Funciones de Solr
  • Devuelve la versión actual de la extensión Apache Solr

solr_get_version

(PECL solr >= 0.9.1)

solr_get_version — Devuelve la versión actual de la extensión Apache Solr

Descripción

solr_get_version ( ) : string

Esta función devuelve la versión actual de la extensión como una cadena.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y false en caso de fallo.

Errores/Excepciones

Esta función no lanza errores o excepciones.

Ejemplos

Ejemplo #1 Ejemplo de solr_get_version()

<?php

$versión_solr = solr_get_version();

print $versión_solr;

?>

El resultado del ejemplo sería algo similar a:

0.9.6

Ver también

  • SolrUtils::getSolrVersion() - Devuelve la versión actual de la extensión Solr


Ejemplos

Ejemplos de cómo usar la extensión Apache Solr de PHP

Ejemplo #1 Contenido del archivo BootStrap

<?php

/* Nombre de dominio del servidor Solr */
define('SOLR_SERVER_HOSTNAME', 'solr.example.com');

/* Si ejecutar en modo seguro */
define('SOLR_SECURE', true);

/* Puerto HTTP para la conexión */
define('SOLR_SERVER_PORT', ((SOLR_SECURE) ? 8443 : 8983));

/* Nomre de Usuario de Autenticación Básica de HTTP */
define('SOLR_SERVER_USERNAME', 'admin');

/* Contraseña de Autenticación Básica de HTTP */
define('SOLR_SERVER_PASSWORD', 'changeit');

/* Tiempo límite de conexión de HTTP */
/* Es el tiempo máximo en segundos permitido para la operación de transferencia de datos de http. El valor predeterminado es 30 seg. */
define('SOLR_SERVER_TIMEOUT', 10);

/* Nombre de archivo a una clave + certificado privados con formato PEM (concatenado en ese ornden */
define('SOLR_SSL_CERT', 'certs/combo.pem');

/* Nombre de archivo a un certificado privado con formato PEM */
define('SOLR_SSL_CERT_ONLY', 'certs/solr.crt');

/* Nombre de archivo a una clave privada con formato PEM */
define('SOLR_SSL_KEY', 'certs/solr.key');

/* Contraseña para el archivo de clave privada con formato PEM */
define('SOLR_SSL_KEYPASSWORD', 'StrongAndSecurePassword');

/* Nombre del archivo que mantiene uno o más certificados CA para ser verificados con su par */
define('SOLR_SSL_CAINFO', 'certs/cacert.crt');

/* Nombre del directorio que mantiene múltiples certificados CA para ser verificados con su par */
define('SOLR_SSL_CAPATH', 'certs/');

?>

Ejemplo #2 Añadir un documento al índice

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$respuestaActualización = $cliente->addDocument($doc);

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 446
        )

)

Ejemplo #3 Fusionar un documento con otro documento

<?php

include "bootstrap.php";

$doc = new SolrDocument();

$segundo_doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

$segundo_doc->addField('cat', 'Lucene Search');

$segundo_doc->merge($doc, true);

print_r($segundo_doc->toArray());

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

        )

)

Ejemplo #4 Buscar documentos - respuestas de SolrObject

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setQuery('lucene');

$consulta->setStart(0);

$consulta->setRows(50);

$consulta->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$respuesta_consulta = $cliente->query($consulta);

$respuesta = $respuesta_consulta->getResponse();

print_r($respuesta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334456
                        )

                    [1] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334455
                        )

                    [2] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                            [id] => SOLR1000
                            [timestamp] => 2009-09-04T20:38:55.906
                        )

                )

        )

)

Ejemplo #5 Buscar documentos - respuestas de SolrDocument

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setQuery('lucene');

$consulta->setStart(0);

$consulta->setRows(50);

$consulta->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$respuesta_consulta = $cliente->query($consulta);

$respuesta_consulta->setParseMode(SolrQueryResponse::PARSE_SOLR_DOC);

$respuesta = $respuesta_consulta->getResponse();

print_r($respuesta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 19740
                        )

                    [1] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25485
                        )

                    [2] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25052
                        )

                )

        )

)

Ejemplo #6 Ejemplo sencillo de TermsComponent - básico

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setTerms(true);

$consulta->setTermsField('cat');

$respuestaActualización = $cliente->query($consulta);

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [electronics] => 14
                    [Lucene] => 4
                    [Software] => 4
                    [memory] => 3
                    [card] => 2
                    [connector] => 2
                    [drive] => 2
                    [graphics] => 2
                    [hard] => 2
                    [monitor] => 2
                )

        )

)

Ejemplo #7 Ejemplo sencillo de TermsComponent - usar un prefijo

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setTerms(true);

/* Devolver sólo los términos que empiecen con $prefijo */
$prefijo = 'c';

$consulta->setTermsField('cat')->setTermsPrefix($prefijo);

$respuestaActualización = $cliente->query($consulta);

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                    [camera] => 1
                    [copier] => 1
                )

        )

)

Ejemplo #8 Ejemplo sencillo de TermsComponent - especificar una frecuencia mínima

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setTerms(true);

/* Devolver sólo los términos que empiecen con $prefijo */
$prefijo = 'c';

/* Devolver sólo los términos con una frecuencia de 2 o mayor */
$frecuencia_mín = 2;

$consulta->setTermsField('cat')->setTermsPrefix($prefijo)->setTermsMinCount($frecuencia_mín);

$respuestaActualización = $cliente->query($consulta);

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 0
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                )

        )

)

Ejemplo #9 Ejemplo sencillo de Facet

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery('*:*');

$consulta->setFacet(true);

$consulta->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2);

$respuestaActualización = $cliente->query($consulta);

$array_respuesta = $respuestaActualización->getResponse();

$datos_faceta = $array_respuesta->facet_counts->facet_fields;

print_r($datos_faceta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
            [1] => 3
            [184] => 3
            [2] => 3
            [3200] => 3
            [400] => 3
            [500] => 3
            [ddr] => 3
            [i] => 3
            [ipod] => 3
            [memori] => 3
            [pc] => 3
            [pin] => 3
            [pod] => 3
            [sdram] => 3
            [system] => 3
            [unbuff] => 3
            [canon] => 2
            [corsair] => 2
            [drive] => 2
            [hard] => 2
            [mb] => 2
            [n] => 2
            [power] => 2
            [retail] => 2
            [video] => 2
            [x] => 2
        )

)

Ejemplo #10 Ejemplo sencillo de Facet - con sobrescritura de campo opcional para mincount

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery('*:*');

$consulta->setFacet(true);

$consulta->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$respuestaActualización = $cliente->query($consulta);

$array_respuesta = $respuestaActualización->getResponse();

$datos_faceta = $array_respuesta->facet_counts->facet_fields;

print_r($datos_faceta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Ejemplo #11 Ejemplo de fecha de faceta

<?php

include "bootstrap.php";

$opciones = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($opciones);

$consulta = new SolrQuery('*:*');

$consulta->setFacet(true);

$consulta->addFacetDateField('manufacturedate_dt');

$consulta->setFacetDateStart('2006-02-13T00:00:00Z');

$consulta->setFacetDateEnd('2012-02-13T00:00:00Z');

$consulta->setFacetDateGap('+1YEAR');

$consulta->setFacetDateHardEnd(1);

$consulta->addFacetDateOther('before');

$respuestaActualización = $client->query($consulta);

$array_respuesta = $respuestaActualización->getResponse();

$datos_faceta = $array_respuesta->facet_counts->facet_dates;

print_r($datos_faceta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [manufacturedate_dt] => SolrObject Object
        (
            [2006-02-13T00:00:00Z] => 9
            [2007-02-13T00:00:00Z] => 0
            [2008-02-13T00:00:00Z] => 0
            [2009-02-13T00:00:00Z] => 0
            [2010-02-13T00:00:00Z] => 0
            [2011-02-13T00:00:00Z] => 0
            [gap] => +1YEAR
            [start] => 2006-02-13T00:00:00Z
            [end] => 2012-02-13T00:00:00Z
            [before] => 2
        )

)

Ejemplo #12 Conectar a un Servidor con SSL Habilitado

<?php

include "bootstrap.php";

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'timeout'  => SOLR_SERVER_TIMEOUT,
    'secure'   => SOLR_SECURE,
    'ssl_cert' => SOLR_SSL_CERT_ONLY,
    'ssl_key'  => SOLR_SSL_KEY,
    'ssl_keypassword' => SOLR_SSL_KEYPASSWORD,
    'ssl_cainfo' => SOLR_SSL_CAINFO,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery('*:*');

$consulta->setFacet(true);

$consulta->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$respuestaActualización = $cliente->query($consulta);

$array_respuesta = $respuestaActualización->getResponse();

$datos_faceta = $array_respuesta->facet_counts->facet_fields;

print_r($datos_faceta);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Ejemplo #13 Colapsar un SolrQuery

<?php
include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);
?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)

Ejemplo #14 Ejemplo de conseguir el tiempo real Solr(RTG) SolrClient::getById()

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => ??????
                    [2] => This is a feature (translated)
                    [3] => ?????????
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)


La clase SolrUtils

(PECL solr >= 0.9.2)

Introducción

Contiene métodos de utilidad para recuperar la versión de la extensión actual y preparar frases de consultas.

También contiene métodos para escapar cadenas de consultas y analizar respuestas XML.

Sinopsis de la Clase

abstract SolrUtils {
/* Métodos */
public static digestXmlResponse ( string $xmlresponse , int $parse_mode = 0 ) : SolrObject
public static escapeQueryChars ( string $str ) : string
public static getSolrVersion ( ) : string
public static queryPhrase ( string $str ) : string
}

Tabla de contenidos

  • SolrUtils::digestXmlResponse — Convierte una cadena de respuesta XML a un objeto SolrObject
  • SolrUtils::escapeQueryChars — Escapa un string de consulta lucene
  • SolrUtils::getSolrVersion — Devuelve la versión actual de la extensión Solr
  • SolrUtils::queryPhrase — Prepara una frase desde una cadena lucene sin escapar


Convierte una cadena de respuesta XML a un objeto SolrObject

  • « SolrUtils
  • SolrUtils::escapeQueryChars »
  • PHP Manual
  • SolrUtils
  • Convierte una cadena de respuesta XML a un objeto SolrObject

SolrUtils::digestXmlResponse

(PECL solr >= 0.9.2)

SolrUtils::digestXmlResponse — Convierte una cadena de respuesta XML a un objeto SolrObject

Descripción

public static SolrUtils::digestXmlResponse ( string $xmlresponse , int $parse_mode = 0 ) : SolrObject

Este método convierte una cadena de respuesta XML del servidor Apache Solr a un objeto SolrObject. Lanza una excepción SolrException si hubo un error.

Parámetros

xmlresponse

La cadena de respuesta XML del servidor Solr.

parse_mode

Use SolrResponse::PARSE_SOLR_OBJ o SolrResponse::PARSE_SOLR_DOC

Valores devueltos

Devuelve el objeto SolrObject que representa la respuesta XML.

Si el parámetro parse_mode setá establecido a SolrResponse::PARSE_SOLR_OBJ Solr los documentos serán analizados como instancias de SolrObject.

si está establecido a SolrResponse::PARSE_SOLR_DOC, serán analizados como instancias de SolrDocument.


Escapa un string de consulta lucene

  • « SolrUtils::digestXmlResponse
  • SolrUtils::getSolrVersion »
  • PHP Manual
  • SolrUtils
  • Escapa un string de consulta lucene

SolrUtils::escapeQueryChars

(PECL solr >= 0.9.2)

SolrUtils::escapeQueryChars — Escapa un string de consulta lucene

Descripción

public static SolrUtils::escapeQueryChars ( string $str ) : string

Lucene soporta el escape de caracteres especiales que son parte de la sintaxis de la consulta.

La lista actual de caracteres especiales es:

+ - && || ! ( ) { } [ ] ^ " ~ * ? : \ /

Estos caracteres son parte de la sintaxis de la consulta y deben ser escapados

Parámetros

str

Este es el string de consulta a ser escapda.

Valores devueltos

Devuelve el string escapado o false en caso de error.


Devuelve la versión actual de la extensión Solr

  • « SolrUtils::escapeQueryChars
  • SolrUtils::queryPhrase »
  • PHP Manual
  • SolrUtils
  • Devuelve la versión actual de la extensión Solr

SolrUtils::getSolrVersion

(PECL solr >= 0.9.2)

SolrUtils::getSolrVersion — Devuelve la versión actual de la extensión Solr

Descripción

public static SolrUtils::getSolrVersion ( ) : string

Devuelve la versión actual de Solr.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La versión actual de la extensión Apache Solr.


Prepara una frase desde una cadena lucene sin escapar

  • « SolrUtils::getSolrVersion
  • SolrInputDocument »
  • PHP Manual
  • SolrUtils
  • Prepara una frase desde una cadena lucene sin escapar

SolrUtils::queryPhrase

(PECL solr >= 0.9.2)

SolrUtils::queryPhrase — Prepara una frase desde una cadena lucene sin escapar

Descripción

public static SolrUtils::queryPhrase ( string $str ) : string

Prepara una frase desde una cadena lucene sin escapar.

Parámetros

str

La frase lucene.

Valores devueltos

Devuelve la frase entre comillas dobles.


La clase SolrInputDocument

(PECL solr >= 0.9.2)

Introducción

Esta clase representa un documento Solr que está a punto de ser enviado al índice de Solr.

Sinopsis de la Clase

final SolrInputDocument {
/* Constantes */
const integer SORT_DEFAULT = 1 ;
const integer SORT_ASC = 1 ;
const integer SORT_DESC = 2 ;
const integer SORT_FIELD_NAME = 1 ;
const integer SORT_FIELD_VALUE_COUNT = 2 ;
const integer SORT_FIELD_BOOST_VALUE = 4 ;
/* Métodos */
public addChildDocument ( SolrInputDocument $child ) : void
public addChildDocuments ( array &$docs ) : void
public addField ( string $fieldName , string $fieldValue , float $fieldBoostValue = 0.0 ) : bool
public clear ( ) : bool
public __clone ( ) : void
public __construct ( )
public deleteField ( string $fieldName ) : bool
public __destruct ( ) : void
public fieldExists ( string $fieldName ) : bool
public getBoost ( ) : float
public getChildDocuments ( ) : array
public getChildDocumentsCount ( ) : int
public getField ( string $fieldName ) : SolrDocumentField
public getFieldBoost ( string $fieldName ) : float
public getFieldCount ( ) : int
public getFieldNames ( ) : array
public hasChildDocuments ( ) : bool
public merge ( SolrInputDocument $sourceDoc , bool $overwrite = true ) : bool
public reset ( ) : bool
public setBoost ( float $documentBoostValue ) : bool
public setFieldBoost ( string $fieldName , float $fieldBoostValue ) : bool
public sort ( int $sortOrderBy , int $sortDirection = SolrInputDocument::SORT_ASC ) : bool
public toArray ( ) : array
}

Constantes predefinidas

Constantes de la Clase SolrInputDocument

SolrInputDocument::SORT_DEFAULT

Ordena los campos de forma ascendente.

SolrInputDocument::SORT_ASC

Ordena los campos de forma ascendente.

SolrInputDocument::SORT_DESC

Ordena los campos de forma descendente

SolrInputDocument::SORT_FIELD_NAME

Ordena los campos por nombre

SolrInputDocument::SORT_FIELD_VALUE_COUNT

Ordena los campos según el número de valores.

SolrInputDocument::SORT_FIELD_BOOST_VALUE

Ordena los campos según el valor de boost.

Tabla de contenidos

  • SolrInputDocument::addChildDocument — Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments — Adds an array of child documents
  • SolrInputDocument::addField — Añade un campo al documento
  • SolrInputDocument::clear — Restablece el documento de entrada
  • SolrInputDocument::__clone — Crea una copia de un objeto SolrDocument
  • SolrInputDocument::__construct — Constructor
  • SolrInputDocument::deleteField — Elimina un campo del documento
  • SolrInputDocument::__destruct — Destructor
  • SolrInputDocument::fieldExists — Comprueba si existe un campo
  • SolrInputDocument::getBoost — Recupera el valor boost actual del documento
  • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrInputDocument::getField — Recupera un campo por su nombre
  • SolrInputDocument::getFieldBoost — Recupera el valor boost de un campo en particular
  • SolrInputDocument::getFieldCount — Devuelve el número de campos del documento
  • SolrInputDocument::getFieldNames — Devuelve una matriz que contiene todos los campos del documento
  • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
  • SolrInputDocument::merge — Fusiona un documento con otro
  • SolrInputDocument::reset — Este es un alias de SolrInputDocument::clear
  • SolrInputDocument::setBoost — Establece el valor boost de este documento
  • SolrInputDocument::setFieldBoost — Establece el valor boost de tiempo del índice de un campo
  • SolrInputDocument::sort — Ordena los campos dentro de un documento
  • SolrInputDocument::toArray — Devuelve una matriz como representación del documento de entrada


Adds a child document for block indexing

  • « SolrInputDocument
  • SolrInputDocument::addChildDocuments »
  • PHP Manual
  • SolrInputDocument
  • Adds a child document for block indexing

SolrInputDocument::addChildDocument

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocument — Adds a child document for block indexing

Descripción

public SolrInputDocument::addChildDocument ( SolrInputDocument $child ) : void

Adds a child document to construct a document block with nested documents.

Parámetros

child

A SolrInputDocument object.

Errores/Excepciones

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

Valores devueltos

Ejemplos

Ejemplo #1 SolrInputDocument::addChildDocument() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$product->addChildDocument($small);
$product->addChildDocument($medium);
$product->addChildDocument($large);

// add product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

Ver también

  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Adds an array of child documents

  • « SolrInputDocument::addChildDocument
  • SolrInputDocument::addField »
  • PHP Manual
  • SolrInputDocument
  • Adds an array of child documents

SolrInputDocument::addChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocuments — Adds an array of child documents

Descripción

public SolrInputDocument::addChildDocuments ( array &$docs ) : void

Adds an array of child documents to the current input document.

Parámetros

docs

An array of SolrInputDocument objects.

Errores/Excepciones

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

Valores devueltos

Ejemplos

Ejemplo #1 SolrInputDocument::addChildDocuments() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$skus = [$small, $medium, $large];
$product->addChildDocuments($skus);

// add the product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

Ver también

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Añade un campo al documento

  • « SolrInputDocument::addChildDocuments
  • SolrInputDocument::clear »
  • PHP Manual
  • SolrInputDocument
  • Añade un campo al documento

SolrInputDocument::addField

(PECL solr >= 0.9.2)

SolrInputDocument::addField — Añade un campo al documento

Descripción

public SolrInputDocument::addField ( string $fieldName , string $fieldValue , float $fieldBoostValue = 0.0 ) : bool

Para múltiples campos, si se especifica un valor boost válido, el valor especificado será multiplicado por el valor boost actual para este campo.

Parámetros

fieldName

El nombre del campo

fieldValue

El valor del campo

fieldBoostValue

El boost de tiempo del índice. Ya que este valor no puede ser negativo, se pueden pasar aún valores menores que 1.0 pero deben ser mayores que cero.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Restablece el documento de entrada

  • « SolrInputDocument::addField
  • SolrInputDocument::__clone »
  • PHP Manual
  • SolrInputDocument
  • Restablece el documento de entrada

SolrInputDocument::clear

(PECL solr >= 0.9.2)

SolrInputDocument::clear — Restablece el documento de entrada

Descripción

public SolrInputDocument::clear ( ) : bool

Restablece el documento borrando todos los campos y restableciendo el boost del documento a cero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Crea una copia de un objeto SolrDocument

  • « SolrInputDocument::clear
  • SolrInputDocument::__construct »
  • PHP Manual
  • SolrInputDocument
  • Crea una copia de un objeto SolrDocument

SolrInputDocument::__clone

(PECL solr >= 0.9.2)

SolrInputDocument::__clone — Crea una copia de un objeto SolrDocument

Descripción

public SolrInputDocument::__clone ( ) : void

No se debería llamar directamente. Se usa para crear una copia profunda de un objeto SolrInputDocument.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Crea una nueva instancia de SolrInputDocument.


Constructor

  • « SolrInputDocument::__clone
  • SolrInputDocument::deleteField »
  • PHP Manual
  • SolrInputDocument
  • Constructor

SolrInputDocument::__construct

(PECL solr >= 0.9.2)

SolrInputDocument::__construct — Constructor

Descripción

public SolrInputDocument::__construct ( )

Constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Elimina un campo del documento

  • « SolrInputDocument::__construct
  • SolrInputDocument::__destruct »
  • PHP Manual
  • SolrInputDocument
  • Elimina un campo del documento

SolrInputDocument::deleteField

(PECL solr >= 0.9.2)

SolrInputDocument::deleteField — Elimina un campo del documento

Descripción

public SolrInputDocument::deleteField ( string $fieldName ) : bool

Elimina un campo del documento.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Destructor

  • « SolrInputDocument::deleteField
  • SolrInputDocument::fieldExists »
  • PHP Manual
  • SolrInputDocument
  • Destructor

SolrInputDocument::__destruct

(PECL solr >= 0.9.2)

SolrInputDocument::__destruct — Destructor

Descripción

public SolrInputDocument::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Comprueba si existe un campo

  • « SolrInputDocument::__destruct
  • SolrInputDocument::getBoost »
  • PHP Manual
  • SolrInputDocument
  • Comprueba si existe un campo

SolrInputDocument::fieldExists

(PECL solr >= 0.9.2)

SolrInputDocument::fieldExists — Comprueba si existe un campo

Descripción

public SolrInputDocument::fieldExists ( string $fieldName ) : bool

Comprueba si existe un campo

Parámetros

fieldName

Nombre del campo.

Valores devueltos

Devuelve true si se encontró el campo y false si no se encontró.


Recupera el valor boost actual del documento

  • « SolrInputDocument::fieldExists
  • SolrInputDocument::getChildDocuments »
  • PHP Manual
  • SolrInputDocument
  • Recupera el valor boost actual del documento

SolrInputDocument::getBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getBoost — Recupera el valor boost actual del documento

Descripción

public SolrInputDocument::getBoost ( ) : float

Recupera el valor boost actual del documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el valor boost en caso de éxito y false en caso de fallo.


Returns an array of child documents (SolrInputDocument)

  • « SolrInputDocument::getBoost
  • SolrInputDocument::getChildDocumentsCount »
  • PHP Manual
  • SolrInputDocument
  • Returns an array of child documents (SolrInputDocument)

SolrInputDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)

Descripción

public SolrInputDocument::getChildDocuments ( ) : array

Returns an array of child documents (SolrInputDocument)

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Returns the number of child documents

  • « SolrInputDocument::getChildDocuments
  • SolrInputDocument::getField »
  • PHP Manual
  • SolrInputDocument
  • Returns the number of child documents

SolrInputDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocumentsCount — Returns the number of child documents

Descripción

public SolrInputDocument::getChildDocumentsCount ( ) : int

Returns the number of child documents

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)


Recupera un campo por su nombre

  • « SolrInputDocument::getChildDocumentsCount
  • SolrInputDocument::getFieldBoost »
  • PHP Manual
  • SolrInputDocument
  • Recupera un campo por su nombre

SolrInputDocument::getField

(PECL solr >= 0.9.2)

SolrInputDocument::getField — Recupera un campo por su nombre

Descripción

public SolrInputDocument::getField ( string $fieldName ) : SolrDocumentField

Recupera un campo del documento.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve un objeto SolrDocumentField en caso de éxito y false en caso de error.


Recupera el valor boost de un campo en particular

  • « SolrInputDocument::getField
  • SolrInputDocument::getFieldCount »
  • PHP Manual
  • SolrInputDocument
  • Recupera el valor boost de un campo en particular

SolrInputDocument::getFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldBoost — Recupera el valor boost de un campo en particular

Descripción

public SolrInputDocument::getFieldBoost ( string $fieldName ) : float

Recupera el valor boost de un campo en particular.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve el valor boost del campo o false si hubo un error.


Devuelve el número de campos del documento

  • « SolrInputDocument::getFieldBoost
  • SolrInputDocument::getFieldNames »
  • PHP Manual
  • SolrInputDocument
  • Devuelve el número de campos del documento

SolrInputDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldCount — Devuelve el número de campos del documento

Descripción

public SolrInputDocument::getFieldCount ( ) : int

Devuelve el número de campos del documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito o false en caso de error.


Devuelve una matriz que contiene todos los campos del documento

  • « SolrInputDocument::getFieldCount
  • SolrInputDocument::hasChildDocuments »
  • PHP Manual
  • SolrInputDocument
  • Devuelve una matriz que contiene todos los campos del documento

SolrInputDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldNames — Devuelve una matriz que contiene todos los campos del documento

Descripción

public SolrInputDocument::getFieldNames ( ) : array

Devuelve una matriz que contiene todos los campos del documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y false en caso de fallo.


Returns true if the document has any child documents

  • « SolrInputDocument::getFieldNames
  • SolrInputDocument::merge »
  • PHP Manual
  • SolrInputDocument
  • Returns true if the document has any child documents

SolrInputDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents

Descripción

public SolrInputDocument::hasChildDocuments ( ) : bool

Checks whether the document has any child documents

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Fusiona un documento con otro

  • « SolrInputDocument::hasChildDocuments
  • SolrInputDocument::reset »
  • PHP Manual
  • SolrInputDocument
  • Fusiona un documento con otro

SolrInputDocument::merge

(PECL solr >= 0.9.2)

SolrInputDocument::merge — Fusiona un documento con otro

Descripción

public SolrInputDocument::merge ( SolrInputDocument $sourceDoc , bool $overwrite = true ) : bool

Fusiona un documento con otro.

Parámetros

sourceDoc

El documento fuente.

overwrite

Si esto es true reemplazará los campos coincidentes del documento destino.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. En el futuro, esto será modificado para que devuelva el número de campos del documento nuevo.


Este es un alias de SolrInputDocument::clear

  • « SolrInputDocument::merge
  • SolrInputDocument::setBoost »
  • PHP Manual
  • SolrInputDocument
  • Este es un alias de SolrInputDocument::clear

SolrInputDocument::reset

(PECL solr >= 0.9.2)

SolrInputDocument::reset — Este es un alias de SolrInputDocument::clear

Descripción

public SolrInputDocument::reset ( ) : bool

Este es un alias de SolrInputDocument::clear

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece el valor boost de este documento

  • « SolrInputDocument::reset
  • SolrInputDocument::setFieldBoost »
  • PHP Manual
  • SolrInputDocument
  • Establece el valor boost de este documento

SolrInputDocument::setBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setBoost — Establece el valor boost de este documento

Descripción

public SolrInputDocument::setBoost ( float $documentBoostValue ) : bool

Establece el valor boost de este documento.

Parámetros

documentBoostValue

El valor boost de tiempo del índice de este documento.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece el valor boost de tiempo del índice de un campo

  • « SolrInputDocument::setBoost
  • SolrInputDocument::sort »
  • PHP Manual
  • SolrInputDocument
  • Establece el valor boost de tiempo del índice de un campo

SolrInputDocument::setFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setFieldBoost — Establece el valor boost de tiempo del índice de un campo

Descripción

public SolrInputDocument::setFieldBoost ( string $fieldName , float $fieldBoostValue ) : bool

Establece el valor boost de tiempo del índice de un campo. Esto reemplaza el valor boost acutal de este campo.

Parámetros

fieldName

El nombre del campo.

fieldBoostValue

El valor boost de tiempo del índice.


Ordena los campos dentro de un documento

  • « SolrInputDocument::setFieldBoost
  • SolrInputDocument::toArray »
  • PHP Manual
  • SolrInputDocument
  • Ordena los campos dentro de un documento

SolrInputDocument::sort

(PECL solr >= 0.9.2)

SolrInputDocument::sort — Ordena los campos dentro de un documento

Descripción

public SolrInputDocument::sort ( int $sortOrderBy , int $sortDirection = SolrInputDocument::SORT_ASC ) : bool

Los campos se cambian de lugar según el criterio y la dirección de ordenación especificados

   Los campos pueden ser ordenados por valor boost, nombre de campo y número de valores.

   El parámetro $order_by debe ser:

   * SolrInputDocument::SORT_FIELD_NAME
   * SolrInputDocument::SORT_FIELD_BOOST_VALUE
   * SolrInputDocument::SORT_FIELD_VALUE_COUNT

   La dirección de ordenación puede ser:

   * SolrInputDocument::SORT_DEFAULT
   * SolrInputDocument::SORT_ASC
   * SolrInputDocument::SORT_DESC

Parámetros

sortOrderBy

El criterio de ordenación

sortDirection

La dirección de ordenación

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve una matriz como representación del documento de entrada

  • « SolrInputDocument::sort
  • SolrDocument »
  • PHP Manual
  • SolrInputDocument
  • Devuelve una matriz como representación del documento de entrada

SolrInputDocument::toArray

(PECL solr >= 0.9.2)

SolrInputDocument::toArray — Devuelve una matriz como representación del documento de entrada

Descripción

public SolrInputDocument::toArray ( ) : array

Devuelve una matriz como representación del documento de entrada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene los campos. Devuelve false en caso de error.


La clase SolrDocument

(PECL solr >= 0.9.2)

Introducción

Representa un documento Solr recuperado de una respuesta a una consulta.

Sinopsis de la Clase

final SolrDocument implements ArrayAccess , Iterator , Serializable {
/* Constantes */
const integer SORT_DEFAULT = 1 ;
const integer SORT_ASC = 1 ;
const integer SORT_DESC = 2 ;
const integer SORT_FIELD_NAME = 1 ;
const integer SORT_FIELD_VALUE_COUNT = 2 ;
const integer SORT_FIELD_BOOST_VALUE = 4 ;
/* Métodos */
public addField ( string $fieldName , string $fieldValue ) : bool
public clear ( ) : bool
public __clone ( ) : void
public __construct ( )
public current ( ) : SolrDocumentField
public deleteField ( string $fieldName ) : bool
public __destruct ( ) : void
public fieldExists ( string $fieldName ) : bool
public __get ( string $fieldName ) : SolrDocumentField
public getChildDocuments ( ) : array
public getChildDocumentsCount ( ) : int
public getField ( string $fieldName ) : SolrDocumentField
public getFieldCount ( ) : int
public getFieldNames ( ) : array
public getInputDocument ( ) : SolrInputDocument
public hasChildDocuments ( ) : bool
public __isset ( string $fieldName ) : bool
public key ( ) : string
public merge ( SolrDocument $sourceDoc , bool $overwrite = true ) : bool
public next ( ) : void
public offsetExists ( string $fieldName ) : bool
public offsetGet ( string $fieldName ) : SolrDocumentField
public offsetSet ( string $fieldName , string $fieldValue ) : void
public offsetUnset ( string $fieldName ) : void
public reset ( ) : bool
public rewind ( ) : void
public serialize ( ) : string
public __set ( string $fieldName , string $fieldValue ) : bool
public sort ( int $sortOrderBy , int $sortDirection = SolrDocument::SORT_ASC ) : bool
public toArray ( ) : array
public unserialize ( string $serialized ) : void
public __unset ( string $fieldName ) : bool
public valid ( ) : bool
}

Constantes predefinidas

SolrDocument::SORT_DEFAULT

Modo predeterminado para ordenar los campos dentro de un documento.

SolrDocument::SORT_ASC

Ordena los campos de forma ascendente

SolrDocument::SORT_DESC

Ordena los campos de forma descendente

SolrDocument::SORT_FIELD_NAME

Ordena los campos por nombre de campo.

SolrDocument::SORT_FIELD_VALUE_COUNT

Ordena los campos según el número de valores de cada campo.

SolrDocument::SORT_FIELD_BOOST_VALUE

Ordena los campos según sus valores boost.

Tabla de contenidos

  • SolrDocument::addField — añade un campo al documento
  • SolrDocument::clear — Borra todos los campos del documento
  • SolrDocument::__clone — Crea una copia de un objeto SolrDocument
  • SolrDocument::__construct — Constructor
  • SolrDocument::current — Recupera el campo actual
  • SolrDocument::deleteField — Elimina un campo del documento
  • SolrDocument::__destruct — Destructor
  • SolrDocument::fieldExists — Comprueba si existe un campo en el documento
  • SolrDocument::__get — Acceder al campo como una propiedad
  • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrDocument::getField — Recupera un campo según su nombre
  • SolrDocument::getFieldCount — Devuelve el número de campos de este documento
  • SolrDocument::getFieldNames — Devuelve una matriz con los nombres de campos del documento
  • SolrDocument::getInputDocument — Devuelve un SolrInputDocument equivalente al objeto
  • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
  • SolrDocument::__isset — Comprueba si existe un campo
  • SolrDocument::key — Recupera la clave actual
  • SolrDocument::merge — Fusiona la fuente con el objeto SolrDocument actual
  • SolrDocument::next — Mueve el puntero interno al siguiente campo
  • SolrDocument::offsetExists — Comprueba si existe un campo en particular
  • SolrDocument::offsetGet — Recupera un campo
  • SolrDocument::offsetSet — Añade un campo al documento
  • SolrDocument::offsetUnset — Elimina un campo
  • SolrDocument::reset — Este es un alias de SolrDocument::clear()
  • SolrDocument::rewind — Reinicia el puntero interno al principio
  • SolrDocument::serialize — Usado para serialización personalizada
  • SolrDocument::__set — Añade otro campo al documento
  • SolrDocument::sort — Ordena los campos del documento
  • SolrDocument::toArray — Devuelve una matriz como representación de un documento
  • SolrDocument::unserialize — Serialización personalizada de objetos SolrDocument
  • SolrDocument::__unset — Elimina un campo del documento
  • SolrDocument::valid — Comprueba si la posición actual del puntero interno es aún válida


añade un campo al documento

  • « SolrDocument
  • SolrDocument::clear »
  • PHP Manual
  • SolrDocument
  • añade un campo al documento

SolrDocument::addField

(PECL solr >= 0.9.2)

SolrDocument::addField — añade un campo al documento

Descripción

public SolrDocument::addField ( string $fieldName , string $fieldValue ) : bool

Este método añade un campo a la instancia de SolrDocument.

Parámetros

fieldName

El nombre del campo

fieldValue

El valor del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Borra todos los campos del documento

  • « SolrDocument::addField
  • SolrDocument::__clone »
  • PHP Manual
  • SolrDocument
  • Borra todos los campos del documento

SolrDocument::clear

(PECL solr >= 0.9.2)

SolrDocument::clear — Borra todos los campos del documento

Descripción

public SolrDocument::clear ( ) : bool

Reinicia el objeto actual. Deshecha todos los campos y reinicia el boost del documento a cero.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Crea una copia de un objeto SolrDocument

  • « SolrDocument::clear
  • SolrDocument::__construct »
  • PHP Manual
  • SolrDocument
  • Crea una copia de un objeto SolrDocument

SolrDocument::__clone

(PECL solr >= 0.9.2)

SolrDocument::__clone — Crea una copia de un objeto SolrDocument

Descripción

public SolrDocument::__clone ( ) : void

Crea una copia de un objeto SolrDocument. No se debe llamar directamente.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Constructor

  • « SolrDocument::__clone
  • SolrDocument::current »
  • PHP Manual
  • SolrDocument
  • Constructor

SolrDocument::__construct

(PECL solr >= 0.9.2)

SolrDocument::__construct — Constructor

Descripción

public SolrDocument::__construct ( )

Constructor de SolrDocument

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Recupera el campo actual

  • « SolrDocument::__construct
  • SolrDocument::deleteField »
  • PHP Manual
  • SolrDocument
  • Recupera el campo actual

SolrDocument::current

(PECL solr >= 0.9.2)

SolrDocument::current — Recupera el campo actual

Descripción

public SolrDocument::current ( ) : SolrDocumentField

Recupera el campo actual

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el campo


Elimina un campo del documento

  • « SolrDocument::current
  • SolrDocument::__destruct »
  • PHP Manual
  • SolrDocument
  • Elimina un campo del documento

SolrDocument::deleteField

(PECL solr >= 0.9.2)

SolrDocument::deleteField — Elimina un campo del documento

Descripción

public SolrDocument::deleteField ( string $fieldName ) : bool

Elimina un campo del documento.

Parámetros

fieldName

Nombre del campo

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Destructor

  • « SolrDocument::deleteField
  • SolrDocument::fieldExists »
  • PHP Manual
  • SolrDocument
  • Destructor

SolrDocument::__destruct

(PECL solr >= 0.9.2)

SolrDocument::__destruct — Destructor

Descripción

public SolrDocument::__destruct ( ) : void

Destructor de SolrDocument.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Comprueba si existe un campo en el documento

  • « SolrDocument::__destruct
  • SolrDocument::__get »
  • PHP Manual
  • SolrDocument
  • Comprueba si existe un campo en el documento

SolrDocument::fieldExists

(PECL solr >= 0.9.2)

SolrDocument::fieldExists — Comprueba si existe un campo en el documento

Descripción

public SolrDocument::fieldExists ( string $fieldName ) : bool

Comprueba si el campo solicitado es un nombre de campo válido del documento.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve true si el campo está presente y false si no lo está.


Acceder al campo como una propiedad

  • « SolrDocument::fieldExists
  • SolrDocument::getChildDocuments »
  • PHP Manual
  • SolrDocument
  • Acceder al campo como una propiedad

SolrDocument::__get

(PECL solr >= 0.9.2)

SolrDocument::__get — Acceder al campo como una propiedad

Descripción

public SolrDocument::__get ( string $fieldName ) : SolrDocumentField

Método mágico para acceder al campo como si fuera una propiedad.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve una instancia de SolrDocumentField.


Returns an array of child documents (SolrDocument)

  • « SolrDocument::__get
  • SolrDocument::getChildDocumentsCount »
  • PHP Manual
  • SolrDocument
  • Returns an array of child documents (SolrDocument)

SolrDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)

Descripción

public SolrDocument::getChildDocuments ( ) : array

Returns an array of child documents (SolrDocument)

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents


Returns the number of child documents

  • « SolrDocument::getChildDocuments
  • SolrDocument::getField »
  • PHP Manual
  • SolrDocument
  • Returns the number of child documents

SolrDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrDocument::getChildDocumentsCount — Returns the number of child documents

Descripción

public SolrDocument::getChildDocumentsCount ( ) : int

Returns the number of child documents

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)


Recupera un campo según su nombre

  • « SolrDocument::getChildDocumentsCount
  • SolrDocument::getFieldCount »
  • PHP Manual
  • SolrDocument
  • Recupera un campo según su nombre

SolrDocument::getField

(PECL solr >= 0.9.2)

SolrDocument::getField — Recupera un campo según su nombre

Descripción

public SolrDocument::getField ( string $fieldName ) : SolrDocumentField

Recupera un campo según su nombre.

Parámetros

fieldName

Nombre del campo.

Valores devueltos

Devuelve un objeto SolrDocumentField en caso de éxito y false en caso de fallo.


Devuelve el número de campos de este documento

  • « SolrDocument::getField
  • SolrDocument::getFieldNames »
  • PHP Manual
  • SolrDocument
  • Devuelve el número de campos de este documento

SolrDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrDocument::getFieldCount — Devuelve el número de campos de este documento

Descripción

public SolrDocument::getFieldCount ( ) : int

Devuelve el número de campos de este documento. Los campo multi valor sólo se cuentan una vez.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y false en caso de fallo.


Devuelve una matriz con los nombres de campos del documento

  • « SolrDocument::getFieldCount
  • SolrDocument::getInputDocument »
  • PHP Manual
  • SolrDocument
  • Devuelve una matriz con los nombres de campos del documento

SolrDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrDocument::getFieldNames — Devuelve una matriz con los nombres de campos del documento

Descripción

public SolrDocument::getFieldNames ( ) : array

Devuelve una matriz con los nombres de campos del documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene los nombres de los campos de este documento.


Devuelve un SolrInputDocument equivalente al objeto

  • « SolrDocument::getFieldNames
  • SolrDocument::hasChildDocuments »
  • PHP Manual
  • SolrDocument
  • Devuelve un SolrInputDocument equivalente al objeto

SolrDocument::getInputDocument

(PECL solr >= 0.9.2)

SolrDocument::getInputDocument — Devuelve un SolrInputDocument equivalente al objeto

Descripción

public SolrDocument::getInputDocument ( ) : SolrInputDocument

Devuelve un SolrInputDocument equivalente al objeto. Esto es útil si se desea reenviar/actualizar un documento recuperado desde una consulta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrInputDocument en caso de éxito y null en caso de fallo.


Checks whether the document has any child documents

  • « SolrDocument::getInputDocument
  • SolrDocument::__isset »
  • PHP Manual
  • SolrDocument
  • Checks whether the document has any child documents

SolrDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::hasChildDocuments — Checks whether the document has any child documents

Descripción

public SolrDocument::hasChildDocuments ( ) : bool

Checks whether the document has any child documents

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents


Comprueba si existe un campo

  • « SolrDocument::hasChildDocuments
  • SolrDocument::key »
  • PHP Manual
  • SolrDocument
  • Comprueba si existe un campo

SolrDocument::__isset

(PECL solr >= 0.9.2)

SolrDocument::__isset — Comprueba si existe un campo

Descripción

public SolrDocument::__isset ( string $fieldName ) : bool

Comprueba si existe un campo

Parámetros

fieldName

Nombre del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Recupera la clave actual

  • « SolrDocument::__isset
  • SolrDocument::merge »
  • PHP Manual
  • SolrDocument
  • Recupera la clave actual

SolrDocument::key

(PECL solr >= 0.9.2)

SolrDocument::key — Recupera la clave actual

Descripción

public SolrDocument::key ( ) : string

Recupera la clave actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clave actual.


Fusiona la fuente con el objeto SolrDocument actual

  • « SolrDocument::key
  • SolrDocument::next »
  • PHP Manual
  • SolrDocument
  • Fusiona la fuente con el objeto SolrDocument actual

SolrDocument::merge

(PECL solr >= 0.9.2)

SolrDocument::merge — Fusiona la fuente con el objeto SolrDocument actual

Descripción

public SolrDocument::merge ( SolrDocument $sourceDoc , bool $overwrite = true ) : bool

Fusiona la fuente con el objeto SolrDocument actual.

Parámetros

sourceDoc

El documento fuente.

overwrite

Si esto es true los campos con el mismo nombre que los del documento destino serán sobrescritos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Mueve el puntero interno al siguiente campo

  • « SolrDocument::merge
  • SolrDocument::offsetExists »
  • PHP Manual
  • SolrDocument
  • Mueve el puntero interno al siguiente campo

SolrDocument::next

(PECL solr >= 0.9.2)

SolrDocument::next — Mueve el puntero interno al siguiente campo

Descripción

public SolrDocument::next ( ) : void

Mueve el puntero interno al siguiente campo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este método no devuelve ningún valor.


Comprueba si existe un campo en particular

  • « SolrDocument::next
  • SolrDocument::offsetGet »
  • PHP Manual
  • SolrDocument
  • Comprueba si existe un campo en particular

SolrDocument::offsetExists

(PECL solr >= 0.9.2)

SolrDocument::offsetExists — Comprueba si existe un campo en particular

Descripción

public SolrDocument::offsetExists ( string $fieldName ) : bool

Comprueba si existe un campo en particular. Se usa cuando un objeto es tratado como una matriz.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Recupera un campo

  • « SolrDocument::offsetExists
  • SolrDocument::offsetSet »
  • PHP Manual
  • SolrDocument
  • Recupera un campo

SolrDocument::offsetGet

(PECL solr >= 0.9.2)

SolrDocument::offsetGet — Recupera un campo

Descripción

public SolrDocument::offsetGet ( string $fieldName ) : SolrDocumentField

Se usa para recuperar un campo cuando el objeto es tratado como una matriz.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve un objeto SolrDocumentField.


Añade un campo al documento

  • « SolrDocument::offsetGet
  • SolrDocument::offsetUnset »
  • PHP Manual
  • SolrDocument
  • Añade un campo al documento

SolrDocument::offsetSet

(PECL solr >= 0.9.2)

SolrDocument::offsetSet — Añade un campo al documento

Descripción

public SolrDocument::offsetSet ( string $fieldName , string $fieldValue ) : void

Se usa cuando el objeto es tratado como una matriz para añadir un campo al documento.

Parámetros

fieldName

El nombre del campo.

fieldValue

El valor del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Elimina un campo

  • « SolrDocument::offsetSet
  • SolrDocument::reset »
  • PHP Manual
  • SolrDocument
  • Elimina un campo

SolrDocument::offsetUnset

(PECL solr >= 0.9.2)

SolrDocument::offsetUnset — Elimina un campo

Descripción

public SolrDocument::offsetUnset ( string $fieldName ) : void

Elimina un campo del documento.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

No se devuelve ningún valor.


Este es un alias de SolrDocument::clear()

  • « SolrDocument::offsetUnset
  • SolrDocument::rewind »
  • PHP Manual
  • SolrDocument
  • Este es un alias de SolrDocument::clear()

SolrDocument::reset

(PECL solr >= 0.9.2)

SolrDocument::reset — Este es un alias de SolrDocument::clear()

Descripción

public SolrDocument::reset ( ) : bool

Este es un alias de SolrDocument::clear()

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Reinicia el puntero interno al principio

  • « SolrDocument::reset
  • SolrDocument::serialize »
  • PHP Manual
  • SolrDocument
  • Reinicia el puntero interno al principio

SolrDocument::rewind

(PECL solr >= 0.9.2)

SolrDocument::rewind — Reinicia el puntero interno al principio

Descripción

public SolrDocument::rewind ( ) : void

Reinicia el puntero interno al principio.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Este método no devuelve ningún valor.


Usado para serialización personalizada

  • « SolrDocument::rewind
  • SolrDocument::__set »
  • PHP Manual
  • SolrDocument
  • Usado para serialización personalizada

SolrDocument::serialize

(PECL solr >= 0.9.2)

SolrDocument::serialize — Usado para serialización personalizada

Descripción

public SolrDocument::serialize ( ) : string

Usado para serialización personalizada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena que representa el documento Solr serializado.


Añade otro campo al documento

  • « SolrDocument::serialize
  • SolrDocument::sort »
  • PHP Manual
  • SolrDocument
  • Añade otro campo al documento

SolrDocument::__set

(PECL solr >= 0.9.2)

SolrDocument::__set — Añade otro campo al documento

Descripción

public SolrDocument::__set ( string $fieldName , string $fieldValue ) : bool

Añade otro campo al documento. Se usa para establecer el campo como propiedades nuevas.

Parámetros

fieldName

Nombre del campo.

fieldValue

Valor del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Ordena los campos del documento

  • « SolrDocument::__set
  • SolrDocument::toArray »
  • PHP Manual
  • SolrDocument
  • Ordena los campos del documento

SolrDocument::sort

(PECL solr >= 0.9.2)

SolrDocument::sort — Ordena los campos del documento

Descripción

public SolrDocument::sort ( int $sortOrderBy , int $sortDirection = SolrDocument::SORT_ASC ) : bool

Los campos se cambian de lugar según el criterio y la dirección de ordenación especificados

   Los campos pueden ser ordenados por valor boost, nombre de campo y número de valores.

   El parámetro sortOrderBy debe ser:

   * SolrDocument::SORT_FIELD_NAME
   * SolrDocument::SORT_FIELD_BOOST_VALUE
   * SolrDocument::SORT_FIELD_VALUE_COUNT

   El parámetro sortDirection puede ser:

   * SolrDocument::SORT_DEFAULT
   * SolrDocument::SORT_ASC
   * SolrDocument::SORT_DESC

   La ordenación predeterminada es de manera ascendente.

Parámetros

sortOrderBy

El criterio de ordenación.

sortDirection

La dirección de ordenación.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Devuelve una matriz como representación de un documento

  • « SolrDocument::sort
  • SolrDocument::unserialize »
  • PHP Manual
  • SolrDocument
  • Devuelve una matriz como representación de un documento

SolrDocument::toArray

(PECL solr >= 0.9.2)

SolrDocument::toArray — Devuelve una matriz como representación de un documento

Descripción

public SolrDocument::toArray ( ) : array

Devuelve una matriz como representación de un documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz como representación de un documento.

Ejemplos

Ejemplo #1 Ejemplo de SolrDocument::toArray()

<?php

$doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

print_r($doc->toArray());

?>

El resultado del ejemplo sería algo similar a:

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

        )

)


Serialización personalizada de objetos SolrDocument

  • « SolrDocument::toArray
  • SolrDocument::__unset »
  • PHP Manual
  • SolrDocument
  • Serialización personalizada de objetos SolrDocument

SolrDocument::unserialize

(PECL solr >= 0.9.2)

SolrDocument::unserialize — Serialización personalizada de objetos SolrDocument

Descripción

public SolrDocument::unserialize ( string $serialized ) : void

Serialización personalizada de objetos SolrDocument

Parámetros

serialized

Una representación XML del documento.

Valores devueltos

Nada.


Elimina un campo del documento

  • « SolrDocument::unserialize
  • SolrDocument::valid »
  • PHP Manual
  • SolrDocument
  • Elimina un campo del documento

SolrDocument::__unset

(PECL solr >= 0.9.2)

SolrDocument::__unset — Elimina un campo del documento

Descripción

public SolrDocument::__unset ( string $fieldName ) : bool

Elimina un campo del documento cuando al campo se accede como una propiedad del objeto.

Parámetros

fieldName

El nombre del campo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Comprueba si la posición actual del puntero interno es aún válida

  • « SolrDocument::__unset
  • SolrDocumentField »
  • PHP Manual
  • SolrDocument
  • Comprueba si la posición actual del puntero interno es aún válida

SolrDocument::valid

(PECL solr >= 0.9.2)

SolrDocument::valid — Comprueba si la posición actual del puntero interno es aún válida

Descripción

public SolrDocument::valid ( ) : bool

Comprueba si la posición actual del puntero interno es aún válida. Se usa durante operaciones foreach.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito y false si la posición actual ya no es válida.


La clase SolrDocumentField

(PECL solr >= 0.9.2)

Introducción

Representa un campo de un documento Solr. Todas sus propiedades son de sólo lectura.

Sinopsis de la Clase

final SolrDocumentField {
/* Propiedades */
public readonly string $name ;
public readonly float $boost ;
public readonly array $values ;
/* Métodos */
public __construct ( )
public __destruct ( ) : void
}

Propiedades

name

El nombre del campo.

boost

El valor de boost del campo

values

Una matriz de valores para este campo

Tabla de contenidos

  • SolrDocumentField::__construct — Constructor
  • SolrDocumentField::__destruct — Destructor


Constructor

  • « SolrDocumentField
  • SolrDocumentField::__destruct »
  • PHP Manual
  • SolrDocumentField
  • Constructor

SolrDocumentField::__construct

(PECL solr >= 0.9.2)

SolrDocumentField::__construct — Constructor

Descripción

public SolrDocumentField::__construct ( )

Constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Destructor

  • « SolrDocumentField::__construct
  • SolrObject »
  • PHP Manual
  • SolrDocumentField
  • Destructor

SolrDocumentField::__destruct

(PECL solr >= 0.9.2)

SolrDocumentField::__destruct — Destructor

Descripción

public SolrDocumentField::__destruct ( ) : void

Destructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


La clase SolrObject

(PECL solr >= 0.9.2)

Introducción

Es un objeto a cuyas propiedades también se pueden acceder usando la sintaxis de array. Todas sus propiedades son de sólo lectura.

Sinopsis de la Clase

final SolrObject implements ArrayAccess {
/* Métodos */
public __construct ( )
public __destruct ( ) : void
public getPropertyNames ( ) : array
public offsetExists ( string $property_name ) : bool
public offsetGet ( string $property_name ) : mixed
public offsetSet ( string $property_name , string $property_value ) : void
public offsetUnset ( string $property_name ) : void
}

Tabla de contenidos

  • SolrObject::__construct — Crea un objeto Solr
  • SolrObject::__destruct — Destructor
  • SolrObject::getPropertyNames — Devuelve una matriz de todos los nombres de las propiedades
  • SolrObject::offsetExists — Comprueba si la propiedad existe
  • SolrObject::offsetGet — Usado para recuperar una propiedad
  • SolrObject::offsetSet — Establece el valor de una propiedad
  • SolrObject::offsetUnset — Desestablece el valor de la propiedad


Crea un objeto Solr

  • « SolrObject
  • SolrObject::__destruct »
  • PHP Manual
  • SolrObject
  • Crea un objeto Solr

SolrObject::__construct

(PECL solr >= 0.9.2)

SolrObject::__construct — Crea un objeto Solr

Descripción

public SolrObject::__construct ( )

Crea un objeto Solr.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada

Ejemplos

Ejemplo #1 Ejemplo de SolrObject::__construct()

<?php
/* ... */
?>

El resultado del ejemplo sería algo similar a:

...

Ver también

  • Classname::Method()


Destructor

  • « SolrObject::__construct
  • SolrObject::getPropertyNames »
  • PHP Manual
  • SolrObject
  • Destructor

SolrObject::__destruct

(PECL solr >= 0.9.2)

SolrObject::__destruct — Destructor

Descripción

public SolrObject::__destruct ( ) : void

El destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Devuelve una matriz de todos los nombres de las propiedades

  • « SolrObject::__destruct
  • SolrObject::offsetExists »
  • PHP Manual
  • SolrObject
  • Devuelve una matriz de todos los nombres de las propiedades

SolrObject::getPropertyNames

(PECL solr >= 0.9.2)

SolrObject::getPropertyNames — Devuelve una matriz de todos los nombres de las propiedades

Descripción

public SolrObject::getPropertyNames ( ) : array

Devuelve una matriz de todos los nombres de las propiedades.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz.


Comprueba si la propiedad existe

  • « SolrObject::getPropertyNames
  • SolrObject::offsetGet »
  • PHP Manual
  • SolrObject
  • Comprueba si la propiedad existe

SolrObject::offsetExists

(PECL solr >= 0.9.2)

SolrObject::offsetExists — Comprueba si la propiedad existe

Descripción

public SolrObject::offsetExists ( string $property_name ) : bool

Comprueba si la propiedad existe. Se usa cuando el objeto es tratado como una matriz.

Parámetros

property_name

El nombre de la propiedad.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Usado para recuperar una propiedad

  • « SolrObject::offsetExists
  • SolrObject::offsetSet »
  • PHP Manual
  • SolrObject
  • Usado para recuperar una propiedad

SolrObject::offsetGet

(PECL solr >= 0.9.2)

SolrObject::offsetGet — Usado para recuperar una propiedad

Descripción

public SolrObject::offsetGet ( string $property_name ) : mixed

Usado para obtener el valor de una propiedad. Se utiliza cuando un objeto es tratado como una matriz.

Parámetros

property_name

Nombre de la propiedad.

Valores devueltos

Devuelve el valor de la propiedad.


Establece el valor de una propiedad

  • « SolrObject::offsetGet
  • SolrObject::offsetUnset »
  • PHP Manual
  • SolrObject
  • Establece el valor de una propiedad

SolrObject::offsetSet

(PECL solr >= 0.9.2)

SolrObject::offsetSet — Establece el valor de una propiedad

Descripción

public SolrObject::offsetSet ( string $property_name , string $property_value ) : void

Establece el valor de una propiedad. Se usa cuando el objeto es tratado como una matriz. Este objeto es de sólo lectura. Esto nunva debería intentarse.

Parámetros

property_name

El nombre de la propiedad.

property_value

El nuevo valor.

Valores devueltos

Nada.


Desestablece el valor de la propiedad

  • « SolrObject::offsetSet
  • SolrClient »
  • PHP Manual
  • SolrObject
  • Desestablece el valor de la propiedad

SolrObject::offsetUnset

(PECL solr >= 0.9.2)

SolrObject::offsetUnset — Desestablece el valor de la propiedad

Descripción

public SolrObject::offsetUnset ( string $property_name ) : void

Desestablece el valor de la propiedad. Se emplea cuando el objeto es tratado como un array. Este objeto es de sólo lectura. Esto nunca debe intentarse.

Parámetros

property_name

El nombre de la propiedad.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SolrObject::offsetUnset()

<?php
/* ... */
?>

El resultado del ejemplo sería algo similar a:

...

Ver también

  • Classname::Method()


La clase SolrClient

(PECL solr >= 0.9.2)

Introducción

Usada para enviar solicitudes al servidor Solr. Actualmente no está soportado clonar y serializar instancias de SolrClient.

Sinopsis de la Clase

final SolrClient {
/* Constantes */
const integer SEARCH_SERVLET_TYPE = 1 ;
const integer UPDATE_SERVLET_TYPE = 2 ;
const integer THREADS_SERVLET_TYPE = 4 ;
const integer PING_SERVLET_TYPE = 8 ;
const integer TERMS_SERVLET_TYPE = 16 ;
const integer SYSTEM_SERVLET_TYPE = 32 ;
const string DEFAULT_SEARCH_SERVLET = select ;
const string DEFAULT_UPDATE_SERVLET = update ;
const string DEFAULT_THREADS_SERVLET = admin/threads ;
const string DEFAULT_PING_SERVLET = admin/ping ;
const string DEFAULT_TERMS_SERVLET = terms ;
const string DEFAULT_SYSTEM_SERVLET = admin/system ;
/* Métodos */
public addDocument ( SolrInputDocument $doc , bool $overwrite = true , int $commitWithin = 0 ) : SolrUpdateResponse
public addDocuments ( array $docs , bool $overwrite = true , int $commitWithin = 0 ) : void
public commit ( bool $softCommit = false , bool $waitSearcher = true , bool $expungeDeletes = false ) : SolrUpdateResponse
public __construct ( array $clientOptions )
public deleteById ( string $id ) : SolrUpdateResponse
public deleteByIds ( array $ids ) : SolrUpdateResponse
public deleteByQueries ( array $queries ) : SolrUpdateResponse
public deleteByQuery ( string $query ) : SolrUpdateResponse
public __destruct ( ) : void
public getById ( string $id ) : SolrQueryResponse
public getByIds ( array $ids ) : SolrQueryResponse
public getDebug ( ) : string
public getOptions ( ) : array
public optimize ( int $maxSegments = 1 , bool $softCommit = true , bool $waitSearcher = true ) : SolrUpdateResponse
public ping ( ) : SolrPingResponse
public query ( SolrParams $query ) : SolrQueryResponse
public request ( string $raw_request ) : SolrUpdateResponse
public rollback ( ) : SolrUpdateResponse
public setResponseWriter ( string $responseWriter ) : void
public setServlet ( int $type , string $value ) : bool
public system ( ) : void
public threads ( ) : void
}

Constantes predefinidas

SolrClient::SEARCH_SERVLET_TYPE

Usado cuando se actualiza servlet de búsqueda.

SolrClient::UPDATE_SERVLET_TYPE

Usado cuando se actualiza el servlet de actualización.

SolrClient::THREADS_SERVLET_TYPE

Usado cuando se actualiza el servlet de hilos.

SolrClient::PING_SERVLET_TYPE

Usado cuando se actualiza el servlet de ping.

SolrClient::TERMS_SERVLET_TYPE

Usado cuando se actualiza el servlet de términos.

SolrClient::SYSTEM_SERVLET_TYPE

Usado cuando se obtiene información del sistema desde el servlet de sistema.

SolrClient::DEFAULT_SEARCH_SERVLET

Este es el valor inicial del servlet de búsqueda.

SolrClient::DEFAULT_UPDATE_SERVLET

Este es el valor inicial del servlet de actualizacion.

SolrClient::DEFAULT_THREADS_SERVLET

Este es el valor inicial del servlet de hilos.

SolrClient::DEFAULT_PING_SERVLET

Este es el valor inicial del servlet de ping.

SolrClient::DEFAULT_TERMS_SERVLET

Este es el valor inicial del servlet de términos usados por TermsComponent

SolrClient::DEFAULT_SYSTEM_SERVLET

Este es el valor inicial del servlet del sistema usado para obtener información de Solr Server

Tabla de contenidos

  • SolrClient::addDocument — Añade un documento al índice
  • SolrClient::addDocuments — Añade una colección de instancias de SolrInputDocument al índice
  • SolrClient::commit — Finaliza todas las añadiduras/eliminaciones hechas al índice
  • SolrClient::__construct — Constructor para el objeto SolrClient
  • SolrClient::deleteById — Eliminar por Id
  • SolrClient::deleteByIds — Elimina mediante Ids
  • SolrClient::deleteByQueries — Elimina todos los documentos que coincidan con cualquiera de las consultas
  • SolrClient::deleteByQuery — Elimina todos los documentos que coincidan con la consulta dada
  • SolrClient::__destruct — Destructor para SolrClient
  • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)
  • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
  • SolrClient::getDebug — Devuelve la información de depuración para el último intento de conexión
  • SolrClient::getOptions — Devuelve las opciones de cliente establecidas internamente
  • SolrClient::optimize — Defragmenta el índice
  • SolrClient::ping — Comprueba si el servidor Solr está todavía activo
  • SolrClient::query — Envía una consulta al servidor
  • SolrClient::request — Envía una petición de actualización sin formato
  • SolrClient::rollback — Revierte todos los añadidos/eliminados hechos en el índice desde el último envío
  • SolrClient::setResponseWriter — Establece el autor de la respuesta usado para preparar la respuesta de Solr
  • SolrClient::setServlet — Cambia el servlet especificado a un nuevo valor
  • SolrClient::system — Obtener información del Servidor Solr
  • SolrClient::threads — Verifica el estado de los hilos


Añade un documento al índice

  • « SolrClient
  • SolrClient::addDocuments »
  • PHP Manual
  • SolrClient
  • Añade un documento al índice

SolrClient::addDocument

(PECL solr >= 0.9.2)

SolrClient::addDocument — Añade un documento al índice

Descripción

public SolrClient::addDocument ( SolrInputDocument $doc , bool $overwrite = true , int $commitWithin = 0 ) : SolrUpdateResponse

Este método añade un documento al índice.

Parámetros

doc

La instancia de SolrInputDocument.

overwrite

Si sobrescribir el documento existente o no. Si es false existirán duplicados (varios documento con el mismo ID).

Advertencia

En Solr < 2.0 de PECL se usó $allowDups en lugar de $overwrite, que tiene la misma funcionalidad con la bandera booleana opuesta.

$allowDups = false es lo mismo que $overwrite = true

commitWithin

Número de milisegundos dentro de los que autoconsignar este documento. Disponible desde Solr 1.4. El valor predeterminado (0) significa deshabilitado.

Cuando se especifica este valor, deja el control de cúando realizar la consignación al mismo Solr, optimizando el número de consignaciones a un mínimo mientras aún se cumple con los requisitos de latencia de actualizaciones, por lo que Solr realizará automáticamente una consignación cuando la agregación más antigua en el búfer venza.

Valores devueltos

Devuelve un objeto SolrUpdateResponse o lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el servidor de Solr falló al procesar la petición.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::addDocument()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$respuestaActualización = $cliente->addDocument($doc);

// se ha de consignar los cambios a escribir is no se usó $commitWithin
$client->commit();

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

Ejemplo #2 Ejemplo 2 de SolrClient::addDocument()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

// No es necesario llamar a commit() ya que se proporciona $commitWithin, por lo que Solr Server autoconsignará en 10 segundos
$respuestaActualización = $cliente->addDocument($doc, false, 10000);

print_r($updateResponse->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

Ver también

  • SolrClient::addDocuments() - Añade una colección de instancias de SolrInputDocument al índice
  • SolrClient::commit() - Finaliza todas las añadiduras/eliminaciones hechas al índice


Añade una colección de instancias de SolrInputDocument al índice

  • « SolrClient::addDocument
  • SolrClient::commit »
  • PHP Manual
  • SolrClient
  • Añade una colección de instancias de SolrInputDocument al índice

SolrClient::addDocuments

(PECL solr >= 0.9.2)

SolrClient::addDocuments — Añade una colección de instancias de SolrInputDocument al índice

Descripción

public SolrClient::addDocuments ( array $docs , bool $overwrite = true , int $commitWithin = 0 ) : void

Añade una colección de documentos al índice.

Parámetros

docs

Una array que contiene la colección de instancias de SolrInputDocument. Este array debe ser una variable real.

overwrite

Si sobrescribir el documento existente o no. Si es false existirán duplicados (varios documento con el mismo ID).

Advertencia

En Solr < 2.0 de PECL se usó $allowDups en lugar de $overwrite, que tiene la misma funcionalidad con la bandera booleana opuesta.

$allowDups = false es lo mismo que $overwrite = true

commitWithin

Número de milisegundos dentro de los que autoconsignar este documento. Disponible desde Solr 1.4. El valor predeterminado (0) significa deshabilitado.

Cuando se especifica este valor, deja el control de cúando realizar la consignación al mismo Solr, optimizando el número de consignaciones a un mínimo mientras aún se cumple con los requisitos de latencia de actualizaciones, por lo que Solr realizará automáticamente una consignación cuando la agregación más antigua en el búfer venza.

Valores devueltos

Devuelve un objeto SolrUpdateResponse o lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::addDocuments()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$doc2 = clone $doc;

$doc2->deleteField('id');
$doc2->addField('id', 334456);

$docs = array($doc, $doc2);

$respuestaActualización = $cliente->addDocuments($docs);

// no se escribirán los cambios en disco hasta que se proporcione $commitWithin o se llame a SolrClient::commit

print_r($respuestaActualización->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

)

Ver también

  • SolrClient::addDocument() - Añade un documento al índice
  • SolrClient::commit() - Finaliza todas las añadiduras/eliminaciones hechas al índice


Finaliza todas las añadiduras/eliminaciones hechas al índice

  • « SolrClient::addDocuments
  • SolrClient::__construct »
  • PHP Manual
  • SolrClient
  • Finaliza todas las añadiduras/eliminaciones hechas al índice

SolrClient::commit

(PECL solr >= 0.9.2)

SolrClient::commit — Finaliza todas las añadiduras/eliminaciones hechas al índice

Descripción

public SolrClient::commit ( bool $softCommit = false , bool $waitSearcher = true , bool $expungeDeletes = false ) : SolrUpdateResponse

Este método finaliza todas las añadiduras/eliminaciones hechas al índice.

Parámetros

softCommit

Refresca la 'vista' del índice para un mayor rendimiento, pero si sin garantizar "on-disk". (Solr4.0+)

Una consignación suave es mucho más rápida ya que solamente hace visibles los cabios de índices y usa fsync con los ficheros de índices o escribe un nuevo descriptor de índice. Si la JVM falla o hay una bajada de tensión, los cambios acaecidos después de la úlitma consignación dura se perderán. Las búsquedas que tengan requisitos cercanos al tiempo real (que requieren que los cambios de índices estén rápidamente visibles para búsquedas) necesitarán más a menudo consignas suaves, y menos frecuentemente duras.

waitSearcher

Bloqueo hasta que un nuevo buscador sea abierto y registrado como el buscador de consultas principal, haciendo los cambios visibles.

expungeDeletes

Mezcla segmentos con eliminaciones para desechar. (Solr1.4+)

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito o lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Historial de cambios

Versión | Descripción
1.1.0, 2.0.0 | Se eliminó el parámetro $maxSegments.
2.0.0b | Cambio en la API: SolrClient::commit ([ int $maxSegments = 0 [, bool $softCommit = false [, bool $waitSearcher = true[, bool $expungeDeletes = false ]]] )
0.9.2 | Firma: SolrClient::commit ([ int $maxSegments = 1 [, bool $waitFlush = true [, bool $waitSearcher = true ]]] ). $waitFlush: Bloquea hasta que los cambios de índices sean volcados a disco.

Notas

Advertencia

Solr >= 2.0 de PECL solamente soporta Solr Server >= 4.0

Ver también

  • SolrClient::optimize() - Defragmenta el índice
  • SolrClient::rollback() - Revierte todos los añadidos/eliminados hechos en el índice desde el último envío


Constructor para el objeto SolrClient

  • « SolrClient::commit
  • SolrClient::deleteById »
  • PHP Manual
  • SolrClient
  • Constructor para el objeto SolrClient

SolrClient::__construct

(PECL solr >= 0.9.2)

SolrClient::__construct — Constructor para el objeto SolrClient

Descripción

public SolrClient::__construct ( array $clientOptions )

Constructor para el objeto SolrClient

Parámetros

clientOptions

Esto es una matriz que contiene una de las siguientes claves:

- secure          (Valor booleano que indica si conectarse o no en modo seguro)
 - hostname        (El nombre del host para el servidor Solr)
 - port            (El número de puerto)
 - path            (La ruta del servidor solr)
 - wt              (El nombre del autor de la respuesta p.ej. xml, json)
 - login           (EL nombre de usuario para la Autenticación HTTP, si la hubiera)
 - password        (La contraseña de la Autenticación HTTP)
 - proxy_host      (El nombre del host para el servidor proxy, si lo hubiera)
 - proxy_port      (El puerto del servidor proxy)
 - proxy_login     (El nombre de usuario del proxy)
 - proxy_password  (La contraseña del proxy)
 - timeout         (El tiempo máximo en segundos permitido para la operación de transferencia de datos http. Por defecto es 30 segundos)
 - ssl_cert        (Nombre de fichero a un archvio con formato PEM que contiene la clave + certificado privados (concatenado en ese orden) )
 - ssl_key         (Nombre de fichero a un fichero de clave privada con formato PEM)
 - ssl_keypassword (Contraseña para la clave privada)
 - ssl_cainfo      (Nombre del fichero que mantiene uno o más certificados CA para ser verificados con su par)
 - ssl_capath      (Nombre del directorio que mantiene múltiples certificados CA para ser verificados con su par)

 Por favor, observe que si el fichero ssl_cert solamente contiene el certificado privado, se tiene que especificar un fichero ssl_key distinto

 La opción ssl_keypassword es necesaria si las opciones ssl_cert o ssl_key están establecidas.

Errores/Excepciones

Lanza una SolrIllegalArgumentException en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::__construct()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_PATH_TO_SOLR,
    'wt'       => 'xml',
);

$cliente = new SolrClient($opciones);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$respuestaActualización = $cliente->addDocument($doc);

?>

El resultado del ejemplo sería algo similar a:

Ver también

  • SolrClient::getOptions() - Devuelve las opciones de cliente establecidas internamente


Eliminar por Id

  • « SolrClient::__construct
  • SolrClient::deleteByIds »
  • PHP Manual
  • SolrClient
  • Eliminar por Id

SolrClient::deleteById

(PECL solr >= 0.9.2)

SolrClient::deleteById — Eliminar por Id

Descripción

public SolrClient::deleteById ( string $id ) : SolrUpdateResponse

Elimina el documento con el ID especificado, donde ID es el valor del campo uniqueKey declarado en el esquema.

Parámetros

id

El valor del campo uniqueKey declarado en el esquema

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito y lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Ver también

  • SolrClient::deleteByIds() - Elimina mediante Ids
  • SolrClient::deleteByQuery() - Elimina todos los documentos que coincidan con la consulta dada
  • SolrClient::deleteByQueries() - Elimina todos los documentos que coincidan con cualquiera de las consultas


Elimina mediante Ids

  • « SolrClient::deleteById
  • SolrClient::deleteByQueries »
  • PHP Manual
  • SolrClient
  • Elimina mediante Ids

SolrClient::deleteByIds

(PECL solr >= 0.9.2)

SolrClient::deleteByIds — Elimina mediante Ids

Descripción

public SolrClient::deleteByIds ( array $ids ) : SolrUpdateResponse

Elimina una colección de documentos con el conjunto de ids especificado.

Parámetros

ids

Una matriz de IDs que representa el campo uniqueKey declarado en el esquema para cada documento a ser eliminado. Debe ser una variable de PHP real.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito y lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Ver también

  • SolrClient::deleteById() - Eliminar por Id
  • SolrClient::deleteByQuery() - Elimina todos los documentos que coincidan con la consulta dada
  • SolrClient::deleteByQueries() - Elimina todos los documentos que coincidan con cualquiera de las consultas


Elimina todos los documentos que coincidan con cualquiera de las consultas

  • « SolrClient::deleteByIds
  • SolrClient::deleteByQuery »
  • PHP Manual
  • SolrClient
  • Elimina todos los documentos que coincidan con cualquiera de las consultas

SolrClient::deleteByQueries

(PECL solr >= 0.9.2)

SolrClient::deleteByQueries — Elimina todos los documentos que coincidan con cualquiera de las consultas

Descripción

public SolrClient::deleteByQueries ( array $queries ) : SolrUpdateResponse

Elimina todos los documentos que coincidan con cualquiera de las consultas

Parámetros

queries

La matriz de consultas. Debe ser una variable de php real.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito y lanza una SolrClientException en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Ver también

  • SolrClient::deleteById() - Eliminar por Id
  • SolrClient::deleteByIds() - Elimina mediante Ids
  • SolrClient::deleteByQuery() - Elimina todos los documentos que coincidan con la consulta dada


Elimina todos los documentos que coincidan con la consulta dada

  • « SolrClient::deleteByQueries
  • SolrClient::__destruct »
  • PHP Manual
  • SolrClient
  • Elimina todos los documentos que coincidan con la consulta dada

SolrClient::deleteByQuery

(PECL solr >= 0.9.2)

SolrClient::deleteByQuery — Elimina todos los documentos que coincidan con la consulta dada

Descripción

public SolrClient::deleteByQuery ( string $query ) : SolrUpdateResponse

Elimina todos los documentos que coincidan con la consulta dada.

Parámetros

query

La consulta

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito y lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Ejemplos

Ejemplo #1 Ejemplo de SolrQuery::deleteByQuery()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

//Esto borrará el índice por completo
$cliente->deleteByQuery("*:*");
$cliente->commit();

?>

Ver también

  • SolrClient::deleteById() - Eliminar por Id
  • SolrClient::deleteByIds() - Elimina mediante Ids
  • SolrClient::deleteByQueries() - Elimina todos los documentos que coincidan con cualquiera de las consultas


Destructor para SolrClient

  • « SolrClient::deleteByQuery
  • SolrClient::getById »
  • PHP Manual
  • SolrClient
  • Destructor para SolrClient

SolrClient::__destruct

(PECL solr >= 0.9.2)

SolrClient::__destruct — Destructor para SolrClient

Descripción

public SolrClient::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Destructor para SolrClient

Ver también

  • SolrClient::__construct() - Constructor para el objeto SolrClient


Get Document By Id. Utilizes Solr Realtime Get (RTG)

  • « SolrClient::__destruct
  • SolrClient::getByIds »
  • PHP Manual
  • SolrClient
  • Get Document By Id. Utilizes Solr Realtime Get (RTG)

SolrClient::getById

(PECL solr >= 2.2.0)

SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)

Descripción

public SolrClient::getById ( string $id ) : SolrQueryResponse

Get Document By Id. Utilizes Solr Realtime Get (RTG).

Parámetros

id

Document ID

Valores devueltos

SolrQueryResponse

Ejemplos

Ejemplo #1 SolrClient::getById() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => ??????
                    [2] => This is a feature (translated)
                    [3] => ?????????
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)

Ver también

  • SolrClient::getByIds() - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)


Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

  • « SolrClient::getById
  • SolrClient::getDebug »
  • PHP Manual
  • SolrClient
  • Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

SolrClient::getByIds

(PECL solr >= 2.2.0)

SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

Descripción

public SolrClient::getByIds ( array $ids ) : SolrQueryResponse

Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).

Parámetros

ids

Document ids

Valores devueltos

SolrQueryResponse

Ejemplos

Ejemplo #1 SolrClient::getByIds() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getByIds(['GB18030TEST', '6H500F0']);

print_r($response->getResponse());

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [response] => SolrObject Object
        (
            [numFound] => 2
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => GB18030TEST
                            [name] => Array
                                (
                                    [0] => Test with some GB18030 encoded characters
                                )

                            [features] => Array
                                (
                                    [0] => No accents here
                                    [1] => ??????
                                    [2] => This is a feature (translated)
                                    [3] => ?????????
                                    [4] => This document is very shiny (translated)
                                )

                            [price] => Array
                                (
                                    [0] => 0
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [_version_] => 1510294336239042560
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                )

        )

)

Ver también

  • SolrClient::getById() - Get Document By Id. Utilizes Solr Realtime Get (RTG)


Devuelve la información de depuración para el último intento de conexión

  • « SolrClient::getByIds
  • SolrClient::getOptions »
  • PHP Manual
  • SolrClient
  • Devuelve la información de depuración para el último intento de conexión

SolrClient::getDebug

(PECL solr >= 0.9.7)

SolrClient::getDebug — Devuelve la información de depuración para el último intento de conexión

Descripción

public SolrClient::getDebug ( ) : string

Devuelve la información de depuración para el último intento de conexión

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no hay nada que devolver.


Devuelve las opciones de cliente establecidas internamente

  • « SolrClient::getDebug
  • SolrClient::optimize »
  • PHP Manual
  • SolrClient
  • Devuelve las opciones de cliente establecidas internamente

SolrClient::getOptions

(PECL solr >= 0.9.6)

SolrClient::getOptions — Devuelve las opciones de cliente establecidas internamente

Descripción

public SolrClient::getOptions ( ) : array

Devuelve las opciones de cliente establecidas internamente. Muy útil para depurar. Los valores devueltos son de sólo lectura y sólo se pueden establecer cuando el objeto es instanciado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene todas las opciones para el objeto SolrClient establecido internamente.

Ver también

  • SolrClient::__construct() - Constructor para el objeto SolrClient


Defragmenta el índice

  • « SolrClient::getOptions
  • SolrClient::ping »
  • PHP Manual
  • SolrClient
  • Defragmenta el índice

SolrClient::optimize

(PECL solr >= 0.9.2)

SolrClient::optimize — Defragmenta el índice

Descripción

public SolrClient::optimize ( int $maxSegments = 1 , bool $softCommit = true , bool $waitSearcher = true ) : SolrUpdateResponse

Defragmenta el índice para un rendimiento de búsquda más rápido.

Parámetros

maxSegments

Optimiza como máximo este número de segmentos. Desde Solr 1.3

softCommit

Refresca la 'vista' del índice para un mayor rendimiento, pero si sin garantizar "on-disk". (Solr4.0+)

waitSearcher

Bloqueo hasta que un nuevo buscador sea abierto y registrado como el buscador de consultas principal, haciendo los cambios visibles.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito y lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.

Notas

Advertencia

Solr >= 2.0 de PECL solamente soporta Solr Server >= 4.0

Antes de Solr 2.0 de PECL, este método solía aceptar estos argumentos: "int $maxSegments, bool $waitFlush, bool $waitSearcher".

Ver también

  • SolrClient::commit() - Finaliza todas las añadiduras/eliminaciones hechas al índice
  • SolrClient::rollback() - Revierte todos los añadidos/eliminados hechos en el índice desde el último envío


Comprueba si el servidor Solr está todavía activo

  • « SolrClient::optimize
  • SolrClient::query »
  • PHP Manual
  • SolrClient
  • Comprueba si el servidor Solr está todavía activo

SolrClient::ping

(PECL solr >= 0.9.2)

SolrClient::ping — Comprueba si el servidor Solr está todavía activo

Descripción

public SolrClient::ping ( ) : SolrPingResponse

Comprueba si el servidor Solr está todavía activo. Envía una petición HEAD al servidor Apache Solr.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrPingResponse en caso de éxito y lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al satisfacer la petición.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::ping()

<?php
$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$pingresponse = $client->ping();

?>

El resultado del ejemplo sería algo similar a:


Envía una consulta al servidor

  • « SolrClient::ping
  • SolrClient::request »
  • PHP Manual
  • SolrClient
  • Envía una consulta al servidor

SolrClient::query

(PECL solr >= 0.9.2)

SolrClient::query — Envía una consulta al servidor

Descripción

public SolrClient::query ( SolrParams $query ) : SolrQueryResponse

Envía una consulta al servidor.

Parámetros

query

Un objeto SolrParam. Se recomienda usar SolrQuery para consultas avanzadas.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito o lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al satisfacer la consulta.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::query()

<?php

$opciones = array
(
    'hostname' => 'localhost',
    'login'    => 'username',
    'password' => 'password',
    'port'     => '8983',
);

$cliente = new Solrç($opciones);

$consulta = new SolrQuery();

$consulta->setQuery('lucene');

$consulta->setStart(0);

$consulta->setRows(50);

$consulta->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$respuesta_consulta = $cliente->query($consulta);

$response = $respuesta_consulta->getResponse();

print_r($response);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 3
            [params] => SolrObject Object
                (
                    [fl] => cat,features,id,timestamp
                    [indent] => on
                    [start] => 0
                    [q] => lucene
                    [wt] => xml
                    [version] => 2.2
                    [rows] => 50
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 1
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SOLR1000
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                        )

                )

        )

)


Envía una petición de actualización sin formato

  • « SolrClient::query
  • SolrClient::rollback »
  • PHP Manual
  • SolrClient
  • Envía una petición de actualización sin formato

SolrClient::request

(PECL solr >= 0.9.2)

SolrClient::request — Envía una petición de actualización sin formato

Descripción

public SolrClient::request ( string $raw_request ) : SolrUpdateResponse

Envía una petición de actualización XML sin formato al servidor

Parámetros

raw_request

Una cadena XML con la solicitud sin formato al servidor.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito. Lanza una excepción en caso de error.

Errores/Excepciones

Lanza una SolrIllegalArgumentException si raw_request es un string vacío.

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al satisfacer la consulta.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::request()

<?php
$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$respuesta_actualización = $cliente->request("<commit/>");

$respuesta = $respuesta_actualización->getResponse();

print_r($respuesta);
?>

El resultado del ejemplo sería algo similar a:

...


Revierte todos los añadidos/eliminados hechos en el índice desde el último envío

  • « SolrClient::request
  • SolrClient::setResponseWriter »
  • PHP Manual
  • SolrClient
  • Revierte todos los añadidos/eliminados hechos en el índice desde el último envío

SolrClient::rollback

(PECL solr >= 0.9.2)

SolrClient::rollback — Revierte todos los añadidos/eliminados hechos en el índice desde el último envío

Descripción

public SolrClient::rollback ( ) : SolrUpdateResponse

Revierte todos los añadidos/eliminados hechos en el índice desde el último envío. No llama a ningún escuchador de eventos ni crea un buscador nuevo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrUpdateResponse en caso de éxito o lanza una excepción SolrClientException en caso de fallo.

Ver también

  • SolrClient::commit() - Finaliza todas las añadiduras/eliminaciones hechas al índice
  • SolrClient::optimize() - Defragmenta el índice


Establece el autor de la respuesta usado para preparar la respuesta de Solr

  • « SolrClient::rollback
  • SolrClient::setServlet »
  • PHP Manual
  • SolrClient
  • Establece el autor de la respuesta usado para preparar la respuesta de Solr

SolrClient::setResponseWriter

(PECL solr >= 0.9.11)

SolrClient::setResponseWriter — Establece el autor de la respuesta usado para preparar la respuesta de Solr

Descripción

public SolrClient::setResponseWriter ( string $responseWriter ) : void

Establece el autor de la respuesta usado para preparar la respuesta de Solr

Parámetros

responseWriter

Uno de los siguientes autores:

  • json
  • phps
  • xml

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SolrClient::setResponseWriter()

<?php

// Esta es mi clase personalizada para los objetos
class SolrClass
{
   public $_propiedades = array();

   public function __get($nombre_propiedad) {

      if (property_exists($this, $nombre_propiedad)) {

          return $this->$nombre_propiedad;

      } else if (isset($_propiedades[$nombre_propiedad])) {

          return $_propiedades[$nombre_propiedad];
      }

      return null;
   }
}

$opciones = array
(
  'hostname' => 'localhost',
  'port' => 8983,
  'path' => '/solr/core1'
);

$cliente = new SolrClient($opciones);

$cliente->setResponseWriter("json");

//$respuesta = $cliente->ping();

$consulta = new SolrQuery();

$consulta->setQuery("*:*");

$consulta->set("objectClassName", "SolrClass");

$consulta->set("objectPropertiesStorageMode", 1); // 0 para propiedades independientes, 1 para combinadas

try
{

$respuesta = $cliente->query($consulta);

$resp = $respuesta->getResponse();

print_r($respuesta);

print_r($resp);

} catch (Exception $e) {

print_r($e);

}

?>


Cambia el servlet especificado a un nuevo valor

  • « SolrClient::setResponseWriter
  • SolrClient::system »
  • PHP Manual
  • SolrClient
  • Cambia el servlet especificado a un nuevo valor

SolrClient::setServlet

(PECL solr >= 0.9.2)

SolrClient::setServlet — Cambia el servlet especificado a un nuevo valor

Descripción

public SolrClient::setServlet ( int $type , string $value ) : bool

Cambia el servlet especificado a un nuevo valor

Parámetros

type

Uno de los siguientes tipos:

- SolrClient::SEARCH_SERVLET_TYPE
 - SolrClient::UPDATE_SERVLET_TYPE
 - SolrClient::THREADS_SERVLET_TYPE
 - SolrClient::PING_SERVLET_TYPE
 - SolrClient::TERMS_SERVLET_TYPE

value

El nuevo valor para el servlet

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Obtener información del Servidor Solr

  • « SolrClient::setServlet
  • SolrClient::threads »
  • PHP Manual
  • SolrClient
  • Obtener información del Servidor Solr

SolrClient::system

(PECL solr >= 2.0.0)

SolrClient::system — Obtener información del Servidor Solr

Descripción

public SolrClient::system ( ) : void

Obtener información del Servidor Solr

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrGenericResponse en caso de éxito.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló, o si hubo un problema con la conexión.

Lanza una SolrServerException si el Servidor Solr falló al satisfacer la consulta.


Verifica el estado de los hilos

  • « SolrClient::system
  • SolrResponse »
  • PHP Manual
  • SolrClient
  • Verifica el estado de los hilos

SolrClient::threads

(PECL solr >= 0.9.2)

SolrClient::threads — Verifica el estado de los hilos

Descripción

public SolrClient::threads ( ) : void

Verifica el estado de los hilos

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrGenericResponse.

Errores/Excepciones

Lanza una SolrClientException si el cliente falló o hubo un problema de conexión.

Lanza una SolrServerException si el Servidor de Solr falló al procesar la petición.


La clase SolrResponse

(PECL solr >= 0.9.2)

Introducción

Representa una respuesta del servidor Solr.

Sinopsis de la Clase

abstract SolrResponse {
/* Constantes */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Propiedades */
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Métodos */
public getDigestedResponse ( ) : string
public getHttpStatus ( ) : int
public getHttpStatusMessage ( ) : string
public getRawRequest ( ) : string
public getRawRequestHeaders ( ) : string
public getRawResponse ( ) : string
public getRawResponseHeaders ( ) : string
public getRequestUrl ( ) : string
public getResponse ( ) : SolrObject
public setParseMode ( int $parser_mode = 0 ) : bool
public success ( ) : bool
}

Propiedades

http_status

El estado http de la resupuesta.

parser_mode

Modo de analizar los documentos, si como instancias de SolrObject o de SolrDocument.

success

¿Ocurrió un error durante la solicitud?

http_status_message

Messaje detallado del estado http

http_request_url

La URL solicitada

http_raw_request_headers

Una cadena de cabeceras en bruto enviada durante la solicitud

http_raw_request

La solicitud en bruto enviada al servidor

http_raw_response_headers

Las cabeceras de resupuesta del servidor Solr

http_raw_response

El mensaje de respuesta del servidor

http_digested_response

La respuesta en formato serializado de PHP.

Constantes predefinidas

Constantes de la Clase SolrResponse

SolrResponse::PARSE_SOLR_OBJ

Los documentos deberían ser analizados como instancias de SolrObject

SolrResponse::PARSE_SOLR_DOC

Los documentos deberían ser analizados como instancias de SolrDocument.

Tabla de contenidos

  • SolrResponse::getDigestedResponse — Devuelve la respueste XML como información de PHP serializada
  • SolrResponse::getHttpStatus — Devuelve el estado HTTP de la respuesta
  • SolrResponse::getHttpStatusMessage — Devuelve más detalles del estado HTTP
  • SolrResponse::getRawRequest — Devuelve la respuesta en bruto enviada al servidor Solr
  • SolrResponse::getRawRequestHeaders — Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr
  • SolrResponse::getRawResponse — Devuelve la respuesta sin tratar del servidor
  • SolrResponse::getRawResponseHeaders — Devuelve las cabeceras de respuesta sin tratar del servidor
  • SolrResponse::getRequestUrl — Devuelve la URL completa a la que se envió la respuesta
  • SolrResponse::getResponse — Devuelve un objeto SolrObject que representa la respuesta XML del servidor
  • SolrResponse::setParseMode — Establece el modo de análisis
  • SolrResponse::success — ¿Tuvo éxito la petición?


Devuelve la respueste XML como información de PHP serializada

  • « SolrResponse
  • SolrResponse::getHttpStatus »
  • PHP Manual
  • SolrResponse
  • Devuelve la respueste XML como información de PHP serializada

SolrResponse::getDigestedResponse

(PECL solr >= 0.9.2)

SolrResponse::getDigestedResponse — Devuelve la respueste XML como información de PHP serializada

Descripción

public SolrResponse::getDigestedResponse ( ) : string

Devuelve la respueste XML como información de PHP serializada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respueste XML como información de PHP serializada


Devuelve el estado HTTP de la respuesta

  • « SolrResponse::getDigestedResponse
  • SolrResponse::getHttpStatusMessage »
  • PHP Manual
  • SolrResponse
  • Devuelve el estado HTTP de la respuesta

SolrResponse::getHttpStatus

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatus — Devuelve el estado HTTP de la respuesta

Descripción

public SolrResponse::getHttpStatus ( ) : int

Devuelve el estado HTTP de la respuesta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el estado HTTP de la respuesta.


Devuelve más detalles del estado HTTP

  • « SolrResponse::getHttpStatus
  • SolrResponse::getRawRequest »
  • PHP Manual
  • SolrResponse
  • Devuelve más detalles del estado HTTP

SolrResponse::getHttpStatusMessage

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatusMessage — Devuelve más detalles del estado HTTP

Descripción

public SolrResponse::getHttpStatusMessage ( ) : string

Devuelve más detalles del estado HTTP.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve más detalles del estado HTTP


Devuelve la respuesta en bruto enviada al servidor Solr

  • « SolrResponse::getHttpStatusMessage
  • SolrResponse::getRawRequestHeaders »
  • PHP Manual
  • SolrResponse
  • Devuelve la respuesta en bruto enviada al servidor Solr

SolrResponse::getRawRequest

(PECL solr >= 0.9.2)

SolrResponse::getRawRequest — Devuelve la respuesta en bruto enviada al servidor Solr

Descripción

public SolrResponse::getRawRequest ( ) : string

Devuelve la respuesta en bruto enviada al servidor Solr.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta en bruto enviada al servidor Solr


Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr

  • « SolrResponse::getRawRequest
  • SolrResponse::getRawResponse »
  • PHP Manual
  • SolrResponse
  • Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr

SolrResponse::getRawRequestHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawRequestHeaders — Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr

Descripción

public SolrResponse::getRawRequestHeaders ( ) : string

Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr,

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr


Devuelve la respuesta sin tratar del servidor

  • « SolrResponse::getRawRequestHeaders
  • SolrResponse::getRawResponseHeaders »
  • PHP Manual
  • SolrResponse
  • Devuelve la respuesta sin tratar del servidor

SolrResponse::getRawResponse

(PECL solr >= 0.9.2)

SolrResponse::getRawResponse — Devuelve la respuesta sin tratar del servidor

Descripción

public SolrResponse::getRawResponse ( ) : string

Devuelve la respuesta sin tratar del servidor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la respuesta sin tratar del servidor.


Devuelve las cabeceras de respuesta sin tratar del servidor

  • « SolrResponse::getRawResponse
  • SolrResponse::getRequestUrl »
  • PHP Manual
  • SolrResponse
  • Devuelve las cabeceras de respuesta sin tratar del servidor

SolrResponse::getRawResponseHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawResponseHeaders — Devuelve las cabeceras de respuesta sin tratar del servidor

Descripción

public SolrResponse::getRawResponseHeaders ( ) : string

Devuelve las cabeceras de respuesta sin tratar del servidor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve las cabeceras de respuesta sin tratar del servidor.


Devuelve la URL completa a la que se envió la respuesta

  • « SolrResponse::getRawResponseHeaders
  • SolrResponse::getResponse »
  • PHP Manual
  • SolrResponse
  • Devuelve la URL completa a la que se envió la respuesta

SolrResponse::getRequestUrl

(PECL solr >= 0.9.2)

SolrResponse::getRequestUrl — Devuelve la URL completa a la que se envió la respuesta

Descripción

public SolrResponse::getRequestUrl ( ) : string

Devuelve la URL completa a la que se envió la respuesta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la URL completa a la que se envió la respuesta


Devuelve un objeto SolrObject que representa la respuesta XML del servidor

  • « SolrResponse::getRequestUrl
  • SolrResponse::setParseMode »
  • PHP Manual
  • SolrResponse
  • Devuelve un objeto SolrObject que representa la respuesta XML del servidor

SolrResponse::getResponse

(PECL solr >= 0.9.2)

SolrResponse::getResponse — Devuelve un objeto SolrObject que representa la respuesta XML del servidor

Descripción

public SolrResponse::getResponse ( ) : SolrObject

Devuelve un objeto SolrObject que representa la respuesta XML del servidor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SolrObject que representa la respuesta XML del servidor


Establece el modo de análisis

  • « SolrResponse::getResponse
  • SolrResponse::success »
  • PHP Manual
  • SolrResponse
  • Establece el modo de análisis

SolrResponse::setParseMode

(PECL solr >= 0.9.2)

SolrResponse::setParseMode — Establece el modo de análisis

Descripción

public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool

Establece el modo de análisis.

Parámetros

parser_mode

SolrResponse::PARSE_SOLR_DOC analiza los documentos en instancias de SolrDocument. SolrResponse::PARSE_SOLR_OBJ convierte un documento a un objeto SolrObjects.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


¿Tuvo éxito la petición?

  • « SolrResponse::setParseMode
  • SolrQueryResponse »
  • PHP Manual
  • SolrResponse
  • ¿Tuvo éxito la petición?

SolrResponse::success

(PECL solr >= 0.9.2)

SolrResponse::success — ¿Tuvo éxito la petición?

Descripción

public SolrResponse::success ( ) : bool

Se usa para verificar si la petición al servidor tuvo éxito.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si se tuvo éxito y false si no lo tuvo.


La clase SolrQueryResponse

(PECL solr >= 0.9.2)

Introducción

Representa una respuesta a una solicitud de consulta.

Sinopsis de la Clase

final SolrQueryResponse extends SolrResponse {
/* Constantes */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Propiedades heredadas */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Métodos */
public __construct ( )
public __destruct ( ) : void
/* Métodos heredados */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

Constantes predefinidas

Constantes de la Clase SolrQueryResponse

SolrQueryResponse::PARSE_SOLR_OBJ

Los documentos deberían ser analizados como instancias de SolrObject

SolrQueryResponse::PARSE_SOLR_DOC

Los documentos deberían ser analizados como instancias de SolrDocument.

Tabla de contenidos

  • SolrQueryResponse::__construct — Constructor
  • SolrQueryResponse::__destruct — Destructor


Constructor

  • « SolrQueryResponse
  • SolrQueryResponse::__destruct »
  • PHP Manual
  • SolrQueryResponse
  • Constructor

SolrQueryResponse::__construct

(PECL solr >= 0.9.2)

SolrQueryResponse::__construct — Constructor

Descripción

public SolrQueryResponse::__construct ( )

Constructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Destructor

  • « SolrQueryResponse::__construct
  • SolrUpdateResponse »
  • PHP Manual
  • SolrQueryResponse
  • Destructor

SolrQueryResponse::__destruct

(PECL solr >= 0.9.2)

SolrQueryResponse::__destruct — Destructor

Descripción

public SolrQueryResponse::__destruct ( ) : void

Destructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


La clase SolrUpdateResponse

(PECL solr >= 0.9.2)

Introducción

Representa una respuesta de una solicitud de actualización.

Sinopsis de la Clase

final SolrUpdateResponse extends SolrResponse {
/* Constantes */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Propiedades heredadas */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Métodos */
public __construct ( )
public __destruct ( ) : void
/* Métodos heredados */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

Constantes predefinidas

Constantes de la Clase SolrUpdateResponse

SolrUpdateResponse::PARSE_SOLR_OBJ

Los documentos deberían ser analizados como instancias de SolrObject

SolrUpdateResponse::PARSE_SOLR_DOC

Los documentos deberían ser analizados como instancias de SolrDocument.

Tabla de contenidos

  • SolrUpdateResponse::__construct — Constructor
  • SolrUpdateResponse::__destruct — Destructor


Constructor

  • « SolrUpdateResponse
  • SolrUpdateResponse::__destruct »
  • PHP Manual
  • SolrUpdateResponse
  • Constructor

SolrUpdateResponse::__construct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__construct — Constructor

Descripción

public SolrUpdateResponse::__construct ( )

Constructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Destructor

  • « SolrUpdateResponse::__construct
  • SolrPingResponse »
  • PHP Manual
  • SolrUpdateResponse
  • Destructor

SolrUpdateResponse::__destruct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__destruct — Destructor

Descripción

public SolrUpdateResponse::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


La clase SolrPingResponse

(PECL solr >= 0.9.2)

Introducción

Representa una respuesta a una petición ping al servidor

Sinopsis de la Clase

final SolrPingResponse extends SolrResponse {
/* Constantes */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Propiedades */
/* Métodos */
public __construct ( )
public __destruct ( ) : void
public getResponse ( ) : string
/* Métodos heredados */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

Propiedades

http_status

El estado http de la resupuesta.

parser_mode

Modo de analizar los documentos, si como instancias de SolrObject o de SolrDocument.

success

¿Ocurrió un error durante la solicitud?

http_status_message

Messaje detallado del estado http

http_request_url

La URL solicitada

http_raw_request_headers

Una cadena de cabeceras en bruto enviada durante la solicitud

http_raw_request

La solicitud en bruto enviada al servidor

http_raw_response_headers

Las cabeceras de resupuesta del servidor Solr

http_raw_response

El mensaje de respuesta del servidor

http_digested_response

La respuesta en formato serializado de PHP.

Constantes predefinidas

Constantes de la Clase SolrPingResponse

SolrPingResponse::PARSE_SOLR_OBJ

Los documentos deberían ser analizados como instancias de SolrObject

SolrPingResponse::PARSE_SOLR_DOC

Los documentos deberían ser analizados como instancias de SolrDocument.

Tabla de contenidos

  • SolrPingResponse::__construct — Constructor
  • SolrPingResponse::__destruct — Destructor
  • SolrPingResponse::getResponse — Devuelve la respuesta del servidor


Constructor

  • « SolrPingResponse
  • SolrPingResponse::__destruct »
  • PHP Manual
  • SolrPingResponse
  • Constructor

SolrPingResponse::__construct

(PECL solr >= 0.9.2)

SolrPingResponse::__construct — Constructor

Descripción

public SolrPingResponse::__construct ( )

Constructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Destructor

  • « SolrPingResponse::__construct
  • SolrPingResponse::getResponse »
  • PHP Manual
  • SolrPingResponse
  • Destructor

SolrPingResponse::__destruct

(PECL solr >= 0.9.2)

SolrPingResponse::__destruct — Destructor

Descripción

public SolrPingResponse::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Devuelve la respuesta del servidor

  • « SolrPingResponse::__destruct
  • SolrGenericResponse »
  • PHP Manual
  • SolrPingResponse
  • Devuelve la respuesta del servidor

SolrPingResponse::getResponse

(PECL solr >= 0.9.2)

SolrPingResponse::getResponse — Devuelve la respuesta del servidor

Descripción

public SolrPingResponse::getResponse ( ) : string

Devuelve la respuesta del servidor. Esto debería estar vacío ya que la petición es una petición HEAD.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena vacía.


La clase SolrGenericResponse

(PECL solr >= 0.9.2)

Introducción

Representa una respuesta del servidor Solr.

Sinopsis de la Clase

final SolrGenericResponse extends SolrResponse {
/* Constantes */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Propiedades heredadas */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Métodos */
public __construct ( )
public __destruct ( ) : void
/* Métodos heredados */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

Constantes predefinidas

Constantes de la Clase SolrGenericResponse

SolrGenericResponse::PARSE_SOLR_OBJ

Los documentos deberían ser analizados como instancias de SolrObject

SolrGenericResponse::PARSE_SOLR_DOC

Los documentos deberían ser analizados como instancias de SolrDocument.

Tabla de contenidos

  • SolrGenericResponse::__construct — Constructor
  • SolrGenericResponse::__destruct — Destructor


Constructor

  • « SolrGenericResponse
  • SolrGenericResponse::__destruct »
  • PHP Manual
  • SolrGenericResponse
  • Constructor

SolrGenericResponse::__construct

(PECL solr >= 0.9.2)

SolrGenericResponse::__construct — Constructor

Descripción

public SolrGenericResponse::__construct ( )

Constructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Destructor

  • « SolrGenericResponse::__construct
  • SolrParams »
  • PHP Manual
  • SolrGenericResponse
  • Destructor

SolrGenericResponse::__destruct

(PECL solr >= 0.9.2)

SolrGenericResponse::__destruct — Destructor

Descripción

public SolrGenericResponse::__destruct ( ) : void

Destructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


La clase SolrParams

(PECL solr >= 0.9.2)

Introducción

Representa una colección de pares nombre-valor enviado al servidor Solr durante una petición.

Sinopsis de la Clase

abstract SolrParams implements Serializable {
/* Métodos */
final public add ( string $name , string $value ) : SolrParams
public addParam ( string $name , string $value ) : SolrParams
final public get ( string $param_name ) : mixed
final public getParam ( string $param_name = ? ) : mixed
final public getParams ( ) : array
final public getPreparedParams ( ) : array
final public serialize ( ) : string
final public set ( string $name , string $value ) : void
public setParam ( string $name , string $value ) : SolrParams
final public toString ( bool $url_encode = false ) : string
final public unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • SolrParams::add — Esto es un alias de SolrParams::addParam
  • SolrParams::addParam — Añade un parámetro al objeto
  • SolrParams::get — Este es una alias de SolrParams::getParam
  • SolrParams::getParam — Devuelve el valor de un parámetro
  • SolrParams::getParams — Devuelve una matriz de parámetros URL no codificados
  • SolrParams::getPreparedParams — Devuelve una matriz de parámetros URL codificados
  • SolrParams::serialize — Usado para serialización personalizada
  • SolrParams::set — Un alas de SolrParams::setParam
  • SolrParams::setParam — Establece el parámetro al valor especificado
  • SolrParams::toString — Devuelve todos los parámetros de los pares nombre-valor del objeto
  • SolrParams::unserialize — Usado para serialización personalizada


Esto es un alias de SolrParams::addParam

  • « SolrParams
  • SolrParams::addParam »
  • PHP Manual
  • SolrParams
  • Esto es un alias de SolrParams::addParam

SolrParams::add

(PECL solr >= 0.9.2)

SolrParams::add — Esto es un alias de SolrParams::addParam

Descripción

final public SolrParams::add ( string $name , string $value ) : SolrParams

Esto es un alias de SolrParams::addParam

Parámetros

name

El nombre del parámetro

value

El valor del parámetro

Valores devueltos

Devuelve una instancia de SolrParams en caso de éxito


Añade un parámetro al objeto

  • « SolrParams::add
  • SolrParams::get »
  • PHP Manual
  • SolrParams
  • Añade un parámetro al objeto

SolrParams::addParam

(PECL solr >= 0.9.2)

SolrParams::addParam — Añade un parámetro al objeto

Descripción

public SolrParams::addParam ( string $name , string $value ) : SolrParams

Añade un parámetro al objeto. Se usa para parámetros que pueden ser especificados múltiples veces.

Parámetros

name

Nombre del parámetro

value

alor del parámetro

Valores devueltos

Devuelve un objeto SolrParam an caso de éxito y false en caso de error.


Este es una alias de SolrParams::getParam

  • « SolrParams::addParam
  • SolrParams::getParam »
  • PHP Manual
  • SolrParams
  • Este es una alias de SolrParams::getParam

SolrParams::get

(PECL solr >= 0.9.2)

SolrParams::get — Este es una alias de SolrParams::getParam

Descripción

final public SolrParams::get ( string $param_name ) : mixed

Este es una alias de SolrParams::getParam

Parámetros

param_name

El nombre del parámetro

Valores devueltos

Devuelve una matriz o una cadena, dependiendo del tipo de parámetro


Devuelve el valor de un parámetro

  • « SolrParams::get
  • SolrParams::getParams »
  • PHP Manual
  • SolrParams
  • Devuelve el valor de un parámetro

SolrParams::getParam

(PECL solr >= 0.9.2)

SolrParams::getParam — Devuelve el valor de un parámetro

Descripción

final public SolrParams::getParam ( string $param_name = ? ) : mixed

Devuelve un parámetro dado con el nombre param_name

Parámetros

param_name

El nombre del parámetro

Valores devueltos

Devuelve una cadena o una matriz dependiendo del tipo del parámetro


Devuelve una matriz de parámetros URL no codificados

  • « SolrParams::getParam
  • SolrParams::getPreparedParams »
  • PHP Manual
  • SolrParams
  • Devuelve una matriz de parámetros URL no codificados

SolrParams::getParams

(PECL solr >= 0.9.2)

SolrParams::getParams — Devuelve una matriz de parámetros URL no codificados

Descripción

final public SolrParams::getParams ( ) : array

Devuelve una matriz de parámetros URL no codificados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz de parámetros URL no codificados


Devuelve una matriz de parámetros URL codificados

  • « SolrParams::getParams
  • SolrParams::serialize »
  • PHP Manual
  • SolrParams
  • Devuelve una matriz de parámetros URL codificados

SolrParams::getPreparedParams

(PECL solr >= 0.9.2)

SolrParams::getPreparedParams — Devuelve una matriz de parámetros URL codificados

Descripción

final public SolrParams::getPreparedParams ( ) : array

Devuelve una matriz de parámetros URL codificados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz de parámetros URL codificados


Usado para serialización personalizada

  • « SolrParams::getPreparedParams
  • SolrParams::set »
  • PHP Manual
  • SolrParams
  • Usado para serialización personalizada

SolrParams::serialize

(PECL solr >= 0.9.2)

SolrParams::serialize — Usado para serialización personalizada

Descripción

final public SolrParams::serialize ( ) : string

Usado para serialización personalizada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Usado para serialización personalizada


Un alas de SolrParams::setParam

  • « SolrParams::serialize
  • SolrParams::setParam »
  • PHP Manual
  • SolrParams
  • Un alas de SolrParams::setParam

SolrParams::set

(PECL solr >= 0.9.2)

SolrParams::set — Un alas de SolrParams::setParam

Descripción

final public SolrParams::set ( string $name , string $value ) : void

Un alas de SolrParams::setParam

Parámetros

name

El nombre del parámetro

value

El valor del parámatro

Valores devueltos

Devuelve una instancia del objeto SolrParams en caso de éxito


Establece el parámetro al valor especificado

  • « SolrParams::set
  • SolrParams::toString »
  • PHP Manual
  • SolrParams
  • Establece el parámetro al valor especificado

SolrParams::setParam

(PECL solr >= 0.9.2)

SolrParams::setParam — Establece el parámetro al valor especificado

Descripción

public SolrParams::setParam ( string $name , string $value ) : SolrParams

Establece el parámetro de consulta al valor especificado. Es usado para parámetros que sólo pueden ser especificados una vez. Subsiguientes llamadas con el mismo parámetro sobrescribirá el valor existente.

Parámetros

name

Nomvre del parámetro

value

Valor del parámetro

Valores devueltos

Devuelve un objeto SolrParam en caso de éxito y false sobre el valor.

Ejemplos

Ejemplo #1 Ejemplo de SolrParams::setParam()

<?php

$parámetro = new SolrParams();

$parámetro->setParam('q', 'solr')->setParam('rows', 2);

?>

El resultado del ejemplo sería algo similar a:


Devuelve todos los parámetros de los pares nombre-valor del objeto

  • « SolrParams::setParam
  • SolrParams::unserialize »
  • PHP Manual
  • SolrParams
  • Devuelve todos los parámetros de los pares nombre-valor del objeto

SolrParams::toString

(PECL solr >= 0.9.2)

SolrParams::toString — Devuelve todos los parámetros de los pares nombre-valor del objeto

Descripción

final public SolrParams::toString ( bool $url_encode = false ) : string

Devuelve todos los parámetros de los pares nombre-valor del objeto.

Parámetros

url_encode

Si devolver o no valores de URL codificados

Valores devueltos

Devuelve un string en caso de éxito y false en caso de fallo.


Usado para serialización personalizada

  • « SolrParams::toString
  • SolrModifiableParams »
  • PHP Manual
  • SolrParams
  • Usado para serialización personalizada

SolrParams::unserialize

(PECL solr >= 0.9.2)

SolrParams::unserialize — Usado para serialización personalizada

Descripción

final public SolrParams::unserialize ( string $serialized ) : void

Usado para serialización personalizada

Parámetros

serialized

La representación serializada del objeto

Valores devueltos

Nada


La clase SolrModifiableParams

(PECL solr >= 0.9.2)

Introducción

Representa una colección de pares nombre-valore enviados al servidor Solr durante una petición.

Sinopsis de la Clase

SolrModifiableParams extends SolrParams implements Serializable {
/* Métodos */
public __construct ( )
public __destruct ( ) : void
/* Métodos heredados */
final public SolrParams::add ( string $name , string $value ) : SolrParams
public SolrParams::addParam ( string $name , string $value ) : SolrParams
final public SolrParams::get ( string $param_name ) : mixed
final public SolrParams::getParam ( string $param_name = ? ) : mixed
final public SolrParams::getParams ( ) : array
final public SolrParams::getPreparedParams ( ) : array
final public SolrParams::serialize ( ) : string
final public SolrParams::set ( string $name , string $value ) : void
public SolrParams::setParam ( string $name , string $value ) : SolrParams
final public SolrParams::toString ( bool $url_encode = false ) : string
final public SolrParams::unserialize ( string $serialized ) : void
}

Tabla de contenidos

  • SolrModifiableParams::__construct — Constructor
  • SolrModifiableParams::__destruct — Destructor


Constructor

  • « SolrModifiableParams
  • SolrModifiableParams::__destruct »
  • PHP Manual
  • SolrModifiableParams
  • Constructor

SolrModifiableParams::__construct

(PECL solr >= 0.9.2)

SolrModifiableParams::__construct — Constructor

Descripción

public SolrModifiableParams::__construct ( )

Constructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


Destructor

  • « SolrModifiableParams::__construct
  • SolrQuery »
  • PHP Manual
  • SolrModifiableParams
  • Destructor

SolrModifiableParams::__destruct

(PECL solr >= 0.9.2)

SolrModifiableParams::__destruct — Destructor

Descripción

public SolrModifiableParams::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada


La clase SolrQuery

(PECL solr >= 0.9.2)

Introducción

Representa una colección de pares nombre-valor enviados al servidor Solr durante una petición.

Sinopsis de la Clase

SolrQuery extends SolrModifiableParams implements Serializable {
/* Constantes */
const integer ORDER_ASC = 0 ;
const integer ORDER_DESC = 1 ;
const integer FACET_SORT_INDEX = 0 ;
const integer FACET_SORT_COUNT = 1 ;
const integer TERMS_SORT_INDEX = 0 ;
const integer TERMS_SORT_COUNT = 1 ;
/* Propiedades */
/* Métodos */
public addExpandFilterQuery ( string $fq ) : SolrQuery
public addExpandSortField ( string $field , string $order = ? ) : SolrQuery
public addFacetDateField ( string $dateField ) : SolrQuery
public addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public addFacetField ( string $field ) : SolrQuery
public addFacetQuery ( string $facetQuery ) : SolrQuery
public addField ( string $field ) : SolrQuery
public addFilterQuery ( string $fq ) : SolrQuery
public addGroupField ( string $value ) : SolrQuery
public addGroupFunction ( string $value ) : SolrQuery
public addGroupQuery ( string $value ) : SolrQuery
public addGroupSortField ( string $field , int $order = ? ) : SolrQuery
public addHighlightField ( string $field ) : SolrQuery
public addMltField ( string $field ) : SolrQuery
public addMltQueryField ( string $field , float $boost ) : SolrQuery
public addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery
public addStatsFacet ( string $field ) : SolrQuery
public addStatsField ( string $field ) : SolrQuery
public collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery
public __construct ( string $q = ? )
public __destruct ( ) : void
public getExpand ( ) : bool
public getExpandFilterQueries ( ) : array
public getExpandQuery ( ) : array
public getExpandRows ( ) : int
public getExpandSortFields ( ) : array
public getFacet ( ) : bool
public getFacetDateEnd ( string $field_override = ? ) : string
public getFacetDateFields ( ) : array
public getFacetDateGap ( string $field_override = ? ) : string
public getFacetDateHardEnd ( string $field_override = ? ) : string
public getFacetDateOther ( string $field_override = ? ) : array
public getFacetDateStart ( string $field_override = ? ) : string
public getFacetFields ( ) : array
public getFacetLimit ( string $field_override = ? ) : int
public getFacetMethod ( string $field_override = ? ) : string
public getFacetMinCount ( string $field_override = ? ) : int
public getFacetMissing ( string $field_override = ? ) : bool
public getFacetOffset ( string $field_override = ? ) : int
public getFacetPrefix ( string $field_override = ? ) : string
public getFacetQueries ( ) : array
public getFacetSort ( string $field_override = ? ) : int
public getFields ( ) : array
public getFilterQueries ( ) : array
public getGroup ( ) : bool
public getGroupCachePercent ( ) : int
public getGroupFacet ( ) : bool
public getGroupFields ( ) : array
public getGroupFormat ( ) : string
public getGroupFunctions ( ) : array
public getGroupLimit ( ) : int
public getGroupMain ( ) : bool
public getGroupNGroups ( ) : bool
public getGroupOffset ( ) : int
public getGroupQueries ( ) : array
public getGroupSortFields ( ) : array
public getGroupTruncate ( ) : bool
public getHighlight ( ) : bool
public getHighlightAlternateField ( string $field_override = ? ) : string
public getHighlightFields ( ) : array
public getHighlightFormatter ( string $field_override = ? ) : string
public getHighlightFragmenter ( string $field_override = ? ) : string
public getHighlightFragsize ( string $field_override = ? ) : int
public getHighlightHighlightMultiTerm ( ) : bool
public getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int
public getHighlightMaxAnalyzedChars ( ) : int
public getHighlightMergeContiguous ( string $field_override = ? ) : bool
public getHighlightRegexMaxAnalyzedChars ( ) : int
public getHighlightRegexPattern ( ) : string
public getHighlightRegexSlop ( ) : float
public getHighlightRequireFieldMatch ( ) : bool
public getHighlightSimplePost ( string $field_override = ? ) : string
public getHighlightSimplePre ( string $field_override = ? ) : string
public getHighlightSnippets ( string $field_override = ? ) : int
public getHighlightUsePhraseHighlighter ( ) : bool
public getMlt ( ) : bool
public getMltBoost ( ) : bool
public getMltCount ( ) : int
public getMltFields ( ) : array
public getMltMaxNumQueryTerms ( ) : int
public getMltMaxNumTokens ( ) : int
public getMltMaxWordLength ( ) : int
public getMltMinDocFrequency ( ) : int
public getMltMinTermFrequency ( ) : int
public getMltMinWordLength ( ) : int
public getMltQueryFields ( ) : array
public getQuery ( ) : string
public getRows ( ) : int
public getSortFields ( ) : array
public getStart ( ) : int
public getStats ( ) : bool
public getStatsFacets ( ) : array
public getStatsFields ( ) : array
public getTerms ( ) : bool
public getTermsField ( ) : string
public getTermsIncludeLowerBound ( ) : bool
public getTermsIncludeUpperBound ( ) : bool
public getTermsLimit ( ) : int
public getTermsLowerBound ( ) : string
public getTermsMaxCount ( ) : int
public getTermsMinCount ( ) : int
public getTermsPrefix ( ) : string
public getTermsReturnRaw ( ) : bool
public getTermsSort ( ) : int
public getTermsUpperBound ( ) : string
public getTimeAllowed ( ) : int
public removeExpandFilterQuery ( string $fq ) : SolrQuery
public removeExpandSortField ( string $field ) : SolrQuery
public removeFacetDateField ( string $field ) : SolrQuery
public removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public removeFacetField ( string $field ) : SolrQuery
public removeFacetQuery ( string $value ) : SolrQuery
public removeField ( string $field ) : SolrQuery
public removeFilterQuery ( string $fq ) : SolrQuery
public removeHighlightField ( string $field ) : SolrQuery
public removeMltField ( string $field ) : SolrQuery
public removeMltQueryField ( string $queryField ) : SolrQuery
public removeSortField ( string $field ) : SolrQuery
public removeStatsFacet ( string $value ) : SolrQuery
public removeStatsField ( string $field ) : SolrQuery
public setEchoHandler ( bool $flag ) : SolrQuery
public setEchoParams ( string $type ) : SolrQuery
public setExpand ( bool $value ) : SolrQuery
public setExpandQuery ( string $q ) : SolrQuery
public setExpandRows ( int $value ) : SolrQuery
public setExplainOther ( string $query ) : SolrQuery
public setFacet ( bool $flag ) : SolrQuery
public setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery
public setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery
public setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery
public setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery
public setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery
public setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery
public setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery
public setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery
public setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery
public setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery
public setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery
public setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery
public setGroup ( bool $value ) : SolrQuery
public setGroupCachePercent ( int $percent ) : SolrQuery
public setGroupFacet ( bool $value ) : SolrQuery
public setGroupFormat ( string $value ) : SolrQuery
public setGroupLimit ( int $value ) : SolrQuery
public setGroupMain ( string $value ) : SolrQuery
public setGroupNGroups ( bool $value ) : SolrQuery
public setGroupOffset ( int $value ) : SolrQuery
public setGroupTruncate ( bool $value ) : SolrQuery
public setHighlight ( bool $flag ) : SolrQuery
public setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery
public setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery
public setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery
public setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery
public setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery
public setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery
public setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery
public setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery
public setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery
public setHighlightRegexPattern ( string $value ) : SolrQuery
public setHighlightRegexSlop ( float $factor ) : SolrQuery
public setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery
public setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery
public setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery
public setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery
public setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery
public setMlt ( bool $flag ) : SolrQuery
public setMltBoost ( bool $flag ) : SolrQuery
public setMltCount ( int $count ) : SolrQuery
public setMltMaxNumQueryTerms ( int $value ) : SolrQuery
public setMltMaxNumTokens ( int $value ) : SolrQuery
public setMltMaxWordLength ( int $maxWordLength ) : SolrQuery
public setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery
public setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery
public setMltMinWordLength ( int $minWordLength ) : SolrQuery
public setOmitHeader ( bool $flag ) : SolrQuery
public setQuery ( string $query ) : SolrQuery
public setRows ( int $rows ) : SolrQuery
public setShowDebugInfo ( bool $flag ) : SolrQuery
public setStart ( int $start ) : SolrQuery
public setStats ( bool $flag ) : SolrQuery
public setTerms ( bool $flag ) : SolrQuery
public setTermsField ( string $fieldname ) : SolrQuery
public setTermsIncludeLowerBound ( bool $flag ) : SolrQuery
public setTermsIncludeUpperBound ( bool $flag ) : SolrQuery
public setTermsLimit ( int $limit ) : SolrQuery
public setTermsLowerBound ( string $lowerBound ) : SolrQuery
public setTermsMaxCount ( int $frequency ) : SolrQuery
public setTermsMinCount ( int $frequency ) : SolrQuery
public setTermsPrefix ( string $prefix ) : SolrQuery
public setTermsReturnRaw ( bool $flag ) : SolrQuery
public setTermsSort ( int $sortType ) : SolrQuery
public setTermsUpperBound ( string $upperBound ) : SolrQuery
public setTimeAllowed ( int $timeAllowed ) : SolrQuery
/* Métodos heredados */
public SolrModifiableParams::__construct ( )
public SolrModifiableParams::__destruct ( ) : void
}

Constantes predefinidas

SolrQuery::ORDER_ASC

Se usa para especificar la forma de ordenación debería se ascendente

SolrQuery::ORDER_DESC

Se usa para especificar la forma de ordenación debería se descendente

SolrQuery::FACET_SORT_INDEX

Se usa para especificar que la faceta debería ordenarse según el índice

SolrQuery::FACET_SORT_COUNT

Se usa para especificar que la faceta debería ordenarse según la cuenta

SolrQuery::TERMS_SORT_INDEX

Usado en TermsComponent

SolrQuery::TERMS_SORT_COUNT

Usado en TermsComponent

Tabla de contenidos

  • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::addFacetDateField — Mapea a facet.date
  • SolrQuery::addFacetDateOther — Añade otro parámetro facet.date.other
  • SolrQuery::addFacetField — Añade otro campo a la faceta
  • SolrQuery::addFacetQuery — Añade una consulta de faceta
  • SolrQuery::addField — Especifica qué campos devolver en el resultado
  • SolrQuery::addFilterQuery — Especifica una consulta de filtro
  • SolrQuery::addGroupField — Add a field to be used to group results
  • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)
  • SolrQuery::addHighlightField — Mapea a hl.fl
  • SolrQuery::addMltField — Establece un campo para usarlo para similitud
  • SolrQuery::addMltQueryField — Mapea a mlt.qf
  • SolrQuery::addSortField — Usado para controlar cómo deberían ordenarse los resultados
  • SolrQuery::addStatsFacet — Recupera una devolución de subresultados para valores dentro de la faceta dada
  • SolrQuery::addStatsField — Mapea al parámetro stats.field
  • SolrQuery::collapse — Collapses the result set to a single document per group
  • SolrQuery::__construct — Constructor
  • SolrQuery::__destruct — Destructor
  • SolrQuery::getExpand — Returns true if group expanding is enabled
  • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
  • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
  • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
  • SolrQuery::getExpandSortFields — Returns an array of fields
  • SolrQuery::getFacet — Devuelve el valor del parámetro facet
  • SolrQuery::getFacetDateEnd — Devuelve el valor del parámetro facet.date.end
  • SolrQuery::getFacetDateFields — Devuelve todos los campos de facet.date
  • SolrQuery::getFacetDateGap — Devuelve el valor del parámetro facet.date.gap
  • SolrQuery::getFacetDateHardEnd — Devuelve el valor del parámetro facet.date.hardend
  • SolrQuery::getFacetDateOther — Devuelve el valor del parámetro facet.date.other
  • SolrQuery::getFacetDateStart — Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo
  • SolrQuery::getFacetFields — Devuelve todos los campos facet
  • SolrQuery::getFacetLimit — Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet
  • SolrQuery::getFacetMethod — Devuelve el valor del parámetro facet.method
  • SolrQuery::getFacetMinCount — Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta
  • SolrQuery::getFacetMissing — Devuelve el estado acutual del parámetro facet.missing
  • SolrQuery::getFacetOffset — Devuelve un índice dentro de la lista de restricciones para ser usado en paginación
  • SolrQuery::getFacetPrefix — Devuelve el prefijo de faceta
  • SolrQuery::getFacetQueries — Devuelve todas las consultas de facetas
  • SolrQuery::getFacetSort — Devuelve el tipo de ordenación de la faceta
  • SolrQuery::getFields — Devuelve la lista de campos que serán devueltos en la respuesta
  • SolrQuery::getFilterQueries — Devuelve una matriz de consultas de filtro
  • SolrQuery::getGroup — Returns true if grouping is enabled
  • SolrQuery::getGroupCachePercent — Returns group cache percent value
  • SolrQuery::getGroupFacet — Returns the group.facet parameter value
  • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
  • SolrQuery::getGroupFormat — Returns the group.format value
  • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
  • SolrQuery::getGroupLimit — Returns the group.limit value
  • SolrQuery::getGroupMain — Returns the group.main value
  • SolrQuery::getGroupNGroups — Returns the group.ngroups value
  • SolrQuery::getGroupOffset — Returns the group.offset value
  • SolrQuery::getGroupQueries — Returns all the group.query parameter values
  • SolrQuery::getGroupSortFields — Returns the group.sort value
  • SolrQuery::getGroupTruncate — Returns the group.truncate value
  • SolrQuery::getHighlight — Devuelve el estado del parámtero hl
  • SolrQuery::getHighlightAlternateField — Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado
  • SolrQuery::getHighlightFields — Devuelve todos los campos que Solr debería generar para remarcación de trozos
  • SolrQuery::getHighlightFormatter — Devuelve el formateador de la salida remarcada
  • SolrQuery::getHighlightFragmenter — Devuelve el generador de trozos de texto para el texto remarcado
  • SolrQuery::getHighlightFragsize — Devuelve el número de caracteres de fragmentos a considerar para remarcación
  • SolrQuery::getHighlightHighlightMultiTerm — Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix
  • SolrQuery::getHighlightMaxAlternateFieldLength — Devuelve el número máximo de caracteres del campo a devolver
  • SolrQuery::getHighlightMaxAnalyzedChars — Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados
  • SolrQuery::getHighlightMergeContiguous — Devuelve si colapsar o no fragmentos contiguos en un único fragmento
  • SolrQuery::getHighlightRegexMaxAnalyzedChars — Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares
  • SolrQuery::getHighlightRegexPattern — Devuelve la expresión regular para la fragmentación
  • SolrQuery::getHighlightRegexSlop — Devuelve el factor de desviación del tamaño de fragmento ideal
  • SolrQuery::getHighlightRequireFieldMatch — Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular
  • SolrQuery::getHighlightSimplePost — Devuelve el texto que aparece después de un término remarcado
  • SolrQuery::getHighlightSimplePre — Devuelve el texto que aparece antes de un término remarcado
  • SolrQuery::getHighlightSnippets — Devuelve el número máximo de trozos remarcados a generar por campo
  • SolrQuery::getHighlightUsePhraseHighlighter — Devuelve el estado del parámetro hl.usePhraseHighlighter
  • SolrQuery::getMlt — Devuelve si los resultados MoreLikeThis deberían o no ser habilitados
  • SolrQuery::getMltBoost — Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés
  • SolrQuery::getMltCount — Devuelve el número de documentos similares a devolver para cada resultado
  • SolrQuery::getMltFields — Devuelve todos los campos a usar para similitud
  • SolrQuery::getMltMaxNumQueryTerms — Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada
  • SolrQuery::getMltMaxNumTokens — Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector
  • SolrQuery::getMltMaxWordLength — Devuelve la longitud máxima de palabra de las palabras que serán ignoradas
  • SolrQuery::getMltMinDocFrequency — Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas
  • SolrQuery::getMltMinTermFrequency — Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente
  • SolrQuery::getMltMinWordLength — Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas
  • SolrQuery::getMltQueryFields — Devuelve los campos de consultas y sus boosts
  • SolrQuery::getQuery — Devuelve la consulta principal
  • SolrQuery::getRows — Devuelve el número máximo de documentos
  • SolrQuery::getSortFields — Devuelve todos los campos de ordenación
  • SolrQuery::getStart — Devuelve el índice del conjunto de resultados completo
  • SolrQuery::getStats — Devuelve si están habilitadas o no las estadísticas
  • SolrQuery::getStatsFacets — Devuelve todas las estadísticas de las facetas que fueron establecidas
  • SolrQuery::getStatsFields — Devuelve todas las estadísticas de los campos
  • SolrQuery::getTerms — Devuelve si está habilitado o no TermsComponent
  • SolrQuery::getTermsField — Devuelve el campo desde el cuál los términos son recuperados
  • SolrQuery::getTermsIncludeLowerBound — Devuelve si incluir o no el límite inferior en el conjunto de resultados
  • SolrQuery::getTermsIncludeUpperBound — Devuelve si incluir o no el término de límite superior en el conjunto de resultados
  • SolrQuery::getTermsLimit — Devuelve el número máximo de términos que debería devolver Solr
  • SolrQuery::getTermsLowerBound — Devuelve el término en el que comenzar
  • SolrQuery::getTermsMaxCount — Devuelve la frecuencia de documento máxima
  • SolrQuery::getTermsMinCount — Devuelve la frecuencia de documento mínima a devolver para ser incluido
  • SolrQuery::getTermsPrefix — Devuelve el prefijo del término
  • SolrQuery::getTermsReturnRaw — Si devolver o no caracteres en bruto
  • SolrQuery::getTermsSort — Devuelve un entero indicando cómo son ordenados los términos
  • SolrQuery::getTermsUpperBound — Devuelve el término en donde parar
  • SolrQuery::getTimeAllowed — Devuelve el tiempo en milisegundos permitido para que la consulta finalice
  • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
  • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter
  • SolrQuery::removeFacetDateField — Elimina uno de los campos de faceta de fecha
  • SolrQuery::removeFacetDateOther — Elimina uno de los parámetros facet.date.other
  • SolrQuery::removeFacetField — Elimina uno de los parámetros facet.date
  • SolrQuery::removeFacetQuery — Elimina uno de los parámetros facet.query
  • SolrQuery::removeField — Elimina un campo de la lista de campos
  • SolrQuery::removeFilterQuery — Elimina una consulta de filtro
  • SolrQuery::removeHighlightField — Elimina uno de los campos usados para remarcación
  • SolrQuery::removeMltField — Elimina uno de los campos moreLikeThis
  • SolrQuery::removeMltQueryField — Elimina uno de los campos de consulta moreLikeThis
  • SolrQuery::removeSortField — Elimina uno de los campos de ordenación
  • SolrQuery::removeStatsFacet — Elimina uno de los parámetros stats.facet
  • SolrQuery::removeStatsField — Elimina uno de los parámetros stats.field
  • SolrQuery::setEchoHandler — Conmuta el parámetro echoHandler
  • SolrQuery::setEchoParams — Determina qué tipo de parámetros incluir en la respuesta
  • SolrQuery::setExpand — Enables/Disables the Expand Component
  • SolrQuery::setExpandQuery — Sets the expand.q parameter
  • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExplainOther — Establece el parámetro de consulta común explainOther
  • SolrQuery::setFacet — Mapea al parámetro facet. Habilita o deshabilta las facetas
  • SolrQuery::setFacetDateEnd — Mapea a facet.date.end
  • SolrQuery::setFacetDateGap — Mapea a facet.date.gap
  • SolrQuery::setFacetDateHardEnd — Mapea a facet.date.hardend
  • SolrQuery::setFacetDateStart — Mapea a facet.date.start
  • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Establece la frecuencia de documento mínima usada para determinar la cuenta de términos
  • SolrQuery::setFacetLimit — Mapea a facet.limit
  • SolrQuery::setFacetMethod — Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo
  • SolrQuery::setFacetMinCount — Mapea a facet.mincount
  • SolrQuery::setFacetMissing — Mapea a facet.missing
  • SolrQuery::setFacetOffset — Establece el índice de la lista de restricciones para tener en cuenta la paginación
  • SolrQuery::setFacetPrefix — Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta
  • SolrQuery::setFacetSort — Determina el orden de las restricciones de campos de faceta
  • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
  • SolrQuery::setGroupCachePercent — Enables caching for result grouping
  • SolrQuery::setGroupFacet — Sets group.facet parameter
  • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupOffset — Sets the group.offset parameter
  • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setHighlight — Habilita o deshabilita la remarcación
  • SolrQuery::setHighlightAlternateField — Especifica el campo de copia de seguridad a usar
  • SolrQuery::setHighlightFormatter — Especifica un formateador para la salida remarcada
  • SolrQuery::setHighlightFragmenter — Establece el generador de trozos de código para texto remarcado
  • SolrQuery::setHighlightFragsize — El tamaño de los fragmentos a considerara para remarcación
  • SolrQuery::setHighlightHighlightMultiTerm — Usa SpanScorer para remarcar términos de frases
  • SolrQuery::setHighlightMaxAlternateFieldLength — Establece el número máximo de caracteres del campo a devolver
  • SolrQuery::setHighlightMaxAnalyzedChars — Especifica el número de caracteres de un documento para buscar trozos apropiados
  • SolrQuery::setHighlightMergeContiguous — Si colapsar o no fragmentos contiguos en un único fragmento
  • SolrQuery::setHighlightRegexMaxAnalyzedChars — Especifica el número máximo de caracteres a analizar
  • SolrQuery::setHighlightRegexPattern — Especifica la expresión regular para la fragmentación
  • SolrQuery::setHighlightRegexSlop — Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal
  • SolrQuery::setHighlightRequireFieldMatch — Requerir la coincicencia de campos durante el remarcado
  • SolrQuery::setHighlightSimplePost — Establece el texto que aparece antes de un término remarcado
  • SolrQuery::setHighlightSimplePre — Establece el texto que aparece antes de un término remarcado
  • SolrQuery::setHighlightSnippets — Establece el número máximo de trozos remarcados para generar por campo
  • SolrQuery::setHighlightUsePhraseHighlighter — Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta
  • SolrQuery::setMlt — Habilita o deshabilita moreLikeThis
  • SolrQuery::setMltBoost — Establecer si la consulta será impulsada (boost) por la relevancia del término de interés
  • SolrQuery::setMltCount — Establece el número de documentos similares a devolver en cada resultado
  • SolrQuery::setMltMaxNumQueryTerms — Establece el número máximo de términos de consulta incluidos
  • SolrQuery::setMltMaxNumTokens — Especifica el número máximo de tokens a analizar
  • SolrQuery::setMltMaxWordLength — Establece la longitud de palabra máxima
  • SolrQuery::setMltMinDocFrequency — Establece la frecuencia de mltMinDoc
  • SolrQuery::setMltMinTermFrequency — Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente
  • SolrQuery::setMltMinWordLength — Establece la longitud de palabra mínima
  • SolrQuery::setOmitHeader — Excluye la cabecera de los resultados devueltos
  • SolrQuery::setQuery — Establece la consulta de búsqueda
  • SolrQuery::setRows — Especifica el número máximo de filas a devolver en el resultado
  • SolrQuery::setShowDebugInfo — Bandera para mostrar información de depuración
  • SolrQuery::setStart — Especifica el número de filas que se van a saltar
  • SolrQuery::setStats — Habilita o deshablita el componente de estadísticas
  • SolrQuery::setTerms — Habilita o deshablita TermsComponent
  • SolrQuery::setTermsField — Establece el nombre del campo del que obtener los términos
  • SolrQuery::setTermsIncludeLowerBound — Incluir el término de límite inferior en el conjunto de resultados
  • SolrQuery::setTermsIncludeUpperBound — Incluir el término de límite superior en el conjunto de resultados
  • SolrQuery::setTermsLimit — Establece el número máximo de términos a devolver
  • SolrQuery::setTermsLowerBound — Especifica el término de donde empezar
  • SolrQuery::setTermsMaxCount — Establece la frecuencia máxima de documentos
  • SolrQuery::setTermsMinCount — Establece la frecuencia mínima de documentos
  • SolrQuery::setTermsPrefix — Restringe las coincidencias de términos que comienzan con el prefijo
  • SolrQuery::setTermsReturnRaw — Devuelve los caracteres en bruto del término indexado
  • SolrQuery::setTermsSort — Especifica cómo ordenar los términos devueltos
  • SolrQuery::setTermsUpperBound — Establece el término en el que parar
  • SolrQuery::setTimeAllowed — El tiempo permitido para que la búsqueda finalice


Overrides main filter query, determines which documents to include in the main group

  • « SolrQuery
  • SolrQuery::addExpandSortField »
  • PHP Manual
  • SolrQuery
  • Overrides main filter query, determines which documents to include in the main group

SolrQuery::addExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group

Descripción

public SolrQuery::addExpandFilterQuery ( string $fq ) : SolrQuery

Overrides main filter query, determines which documents to include in the main group.

Parámetros

fq

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Orders the documents within the expanded groups (expand.sort parameter)

  • « SolrQuery::addExpandFilterQuery
  • SolrQuery::addFacetDateField »
  • PHP Manual
  • SolrQuery
  • Orders the documents within the expanded groups (expand.sort parameter)

SolrQuery::addExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)

Descripción

public SolrQuery::addExpandSortField ( string $field , string $order = ? ) : SolrQuery

Orders the documents within the expanded groups (expand.sort parameter).

Parámetros

field

field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants.

Default: SolrQuery::ORDER_DESC

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Mapea a facet.date

  • « SolrQuery::addExpandSortField
  • SolrQuery::addFacetDateOther »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.date

SolrQuery::addFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateField — Mapea a facet.date

Descripción

public SolrQuery::addFacetDateField ( string $dateField ) : SolrQuery

Este método permite especificar un campo que debería ser tratado como una faceta.

Se puede usar mútiples veces con diferentes nombres de campos para indicar mútiples campos de facetas

Parámetros

dateField

El nombre del campo de fecha.

Valores devueltos

Devuelve un objeto SolrQuery.


Añade otro parámetro facet.date.other

  • « SolrQuery::addFacetDateField
  • SolrQuery::addFacetField »
  • PHP Manual
  • SolrQuery
  • Añade otro parámetro facet.date.other

SolrQuery::addFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateOther — Añade otro parámetro facet.date.other

Descripción

public SolrQuery::addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery

Establece el parámetro facet.date.other. Acepta la sobrescritura opcional de campos

Parámetros

value

El valor a usar.

field_override

El nombre del campo para la sobrescritura.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Añade otro campo a la faceta

  • « SolrQuery::addFacetDateOther
  • SolrQuery::addFacetQuery »
  • PHP Manual
  • SolrQuery
  • Añade otro campo a la faceta

SolrQuery::addFacetField

(PECL solr >= 0.9.2)

SolrQuery::addFacetField — Añade otro campo a la faceta

Descripción

public SolrQuery::addFacetField ( string $field ) : SolrQuery

Añade otro campo a la faceta

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.

Ejemplos

Ejemplo #1 Ejemplo de SolrQuery::addFacetField()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setQuery($consulta);

$consulta->addField('price')->addField('color');

$consulta->setFacet(true);

$consulta->addFacetField('price')->addFacetField('color');

$respuesta_consulta = $cliente->query($consulta);

$respuesta = $respuesta_consulta->getResponse();

print_r($respuesta['facet_counts']['facet_fields']);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [color] => SolrObject Object
        (
            [blue] => 20
            [green] => 100
        )

)


Añade una consulta de faceta

  • « SolrQuery::addFacetField
  • SolrQuery::addField »
  • PHP Manual
  • SolrQuery
  • Añade una consulta de faceta

SolrQuery::addFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::addFacetQuery — Añade una consulta de faceta

Descripción

public SolrQuery::addFacetQuery ( string $facetQuery ) : SolrQuery

Añade una consulta de faceta

Parámetros

facetQuery

La consulta de faceta

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.

Ejemplos

Ejemplo #1 Ejemplo de SolrQuery::addFacetField()

<?php

$opciones = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery('*:*');

$consulta->setFacet(true);

$consulta->addFacetQuery('price:[* TO 500]')->addFacetQuery('price:[500 TO *]');

$respuesta_consulta = $cliente->query($consulta);

$respuesta = $respuesta_consulta->getResponse();

print_r($respuesta->facet_counts->facet_queries);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [price:[* TO 500]] => 14
    [price:[500 TO *]] => 2
)


Especifica qué campos devolver en el resultado

  • « SolrQuery::addFacetQuery
  • SolrQuery::addFilterQuery »
  • PHP Manual
  • SolrQuery
  • Especifica qué campos devolver en el resultado

SolrQuery::addField

(PECL solr >= 0.9.2)

SolrQuery::addField — Especifica qué campos devolver en el resultado

Descripción

public SolrQuery::addField ( string $field ) : SolrQuery

Este método se usa para especificar un conjunto de campos a devolver, restingiendo así la cantidad de información en la respuesta.

Puede ser llamado múltiples veces, una por cada nombre de campo.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual


Especifica una consulta de filtro

  • « SolrQuery::addField
  • SolrQuery::addGroupField »
  • PHP Manual
  • SolrQuery
  • Especifica una consulta de filtro

SolrQuery::addFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::addFilterQuery — Especifica una consulta de filtro

Descripción

public SolrQuery::addFilterQuery ( string $fq ) : SolrQuery

Especifica una consulta de filtro

Parámetros

fq

La consulta de filtro

Valores devueltos

Devuelve el objeto SolrQuery actual.

Ejemplos

Ejemplo #1 Ejemplo de SolrQuery::addFilterQuery()

<?php

$opciones = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$cliente = new SolrClient($opciones);

$consulta = new SolrQuery();

$consulta->setQuery('*:*');

$consulta->addFilterQuery('color:blue,green');

$respuesta_consulta = $cliente->query($consulta);

$respuesta = $respuesta_consulta->getResponse();

print_r($respuesta['facet_counts']['facet_fields']);

?>

El resultado del ejemplo sería algo similar a:

 &fq=color:blue,green


Add a field to be used to group results

  • « SolrQuery::addFilterQuery
  • SolrQuery::addGroupFunction »
  • PHP Manual
  • SolrQuery
  • Add a field to be used to group results

SolrQuery::addGroupField

(PECL solr >= 2.2.0)

SolrQuery::addGroupField — Add a field to be used to group results

Descripción

public SolrQuery::addGroupField ( string $value ) : SolrQuery

The name of the field by which to group results. The field must be single-valued, and either be indexed or a field type that has a value source and works in a function query, such as ExternalFileField. It must also be a string-based field, such as StrField or TextField Uses group.field parameter

Parámetros

value

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Allows grouping results based on the unique values of a function query (group.func parameter)

  • « SolrQuery::addGroupField
  • SolrQuery::addGroupQuery »
  • PHP Manual
  • SolrQuery
  • Allows grouping results based on the unique values of a function query (group.func parameter)

SolrQuery::addGroupFunction

(PECL solr >= 2.2.0)

SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)

Descripción

public SolrQuery::addGroupFunction ( string $value ) : SolrQuery

Adds a group function (group.func parameter) Allows grouping results based on the unique values of a function query.

Parámetros

value

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Allows grouping of documents that match the given query

  • « SolrQuery::addGroupFunction
  • SolrQuery::addGroupSortField »
  • PHP Manual
  • SolrQuery
  • Allows grouping of documents that match the given query

SolrQuery::addGroupQuery

(PECL solr >= 2.2.0)

SolrQuery::addGroupQuery — Allows grouping of documents that match the given query

Descripción

public SolrQuery::addGroupQuery ( string $value ) : SolrQuery

Allows grouping of documents that match the given query. Adds query to the group.query parameter

Parámetros

value

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Add a group sort field (group.sort parameter)

  • « SolrQuery::addGroupQuery
  • SolrQuery::addHighlightField »
  • PHP Manual
  • SolrQuery
  • Add a group sort field (group.sort parameter)

SolrQuery::addGroupSortField

(PECL solr >= 2.2.0)

SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)

Descripción

public SolrQuery::addGroupSortField ( string $field , int $order = ? ) : SolrQuery

Allow sorting group documents, using group sort field (group.sort parameter).

Parámetros

field

Field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants

Valores devueltos

Ejemplos

Ejemplo #1 SolrQuery::addGroupSortField() example

<?php

$solrQuery = new SolrQuery('*:*');
$solrQuery
    ->setGroup(true)
    ->addGroupSortField('price', SolrQuery::ORDER_ASC);

echo $solrQuery;
?>

El resultado del ejemplo sería algo similar a:

q=*:*&group=true&group.sort=price asc

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Mapea a hl.fl

  • « SolrQuery::addGroupSortField
  • SolrQuery::addMltField »
  • PHP Manual
  • SolrQuery
  • Mapea a hl.fl

SolrQuery::addHighlightField

(PECL solr >= 0.9.2)

SolrQuery::addHighlightField — Mapea a hl.fl

Descripción

public SolrQuery::addHighlightField ( string $field ) : SolrQuery

Mapea a hl.fl. Se usa para especificar que los trozos resaltados deberían ser generados para un campo en particular

Parámetros

field

Nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Establece un campo para usarlo para similitud

  • « SolrQuery::addHighlightField
  • SolrQuery::addMltQueryField »
  • PHP Manual
  • SolrQuery
  • Establece un campo para usarlo para similitud

SolrQuery::addMltField

(PECL solr >= 0.9.2)

SolrQuery::addMltField — Establece un campo para usarlo para similitud

Descripción

public SolrQuery::addMltField ( string $field ) : SolrQuery

Mapea a mlt.fl. Especifica que un campo debería ser usado para similitud.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Mapea a mlt.qf

  • « SolrQuery::addMltField
  • SolrQuery::addSortField »
  • PHP Manual
  • SolrQuery
  • Mapea a mlt.qf

SolrQuery::addMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::addMltQueryField — Mapea a mlt.qf

Descripción

public SolrQuery::addMltQueryField ( string $field , float $boost ) : SolrQuery

Mapea a mlt.qf. Se usa para especificar campos de consultas y sus boosts

Parámetros

field

El nombre del campo

boost

Su valor boost

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Usado para controlar cómo deberían ordenarse los resultados

  • « SolrQuery::addMltQueryField
  • SolrQuery::addStatsFacet »
  • PHP Manual
  • SolrQuery
  • Usado para controlar cómo deberían ordenarse los resultados

SolrQuery::addSortField

(PECL solr >= 0.9.2)

SolrQuery::addSortField — Usado para controlar cómo deberían ordenarse los resultados

Descripción

public SolrQuery::addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery

Usado para controlar cómo deberían ordenarse los resultados.

Parámetros

field

El nombre del campo

order

La dirección de ordenación. Debería ser SolrQuery::ORDER_ASC o SolrQuery::ORDER_DESC.

Valores devueltos

Devuelve el objeto SolrQuery actual.


Recupera una devolución de subresultados para valores dentro de la faceta dada

  • « SolrQuery::addSortField
  • SolrQuery::addStatsField »
  • PHP Manual
  • SolrQuery
  • Recupera una devolución de subresultados para valores dentro de la faceta dada

SolrQuery::addStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::addStatsFacet — Recupera una devolución de subresultados para valores dentro de la faceta dada

Descripción

public SolrQuery::addStatsFacet ( string $field ) : SolrQuery

Recupera una devolución de subresultados para valores dentro de la faceta dada. Mapea al campo stats.facet

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Mapea al parámetro stats.field

  • « SolrQuery::addStatsFacet
  • SolrQuery::collapse »
  • PHP Manual
  • SolrQuery
  • Mapea al parámetro stats.field

SolrQuery::addStatsField

(PECL solr >= 0.9.2)

SolrQuery::addStatsField — Mapea al parámetro stats.field

Descripción

public SolrQuery::addStatsField ( string $field ) : SolrQuery

Mapea al parámetro stats.field. Este método añade otro parámetro stats.field.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usa el valor de retorno.


Collapses the result set to a single document per group

  • « SolrQuery::addStatsField
  • SolrQuery::__construct »
  • PHP Manual
  • SolrQuery
  • Collapses the result set to a single document per group

SolrQuery::collapse

(No hay información de versión disponible, podría estar únicamente en Git)

SolrQuery::collapse — Collapses the result set to a single document per group

Descripción

public SolrQuery::collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery

Collapses the result set to a single document per group before it forwards the result set to the rest of the search components.

So all downstream components (faceting, highlighting, etc...) will work with the collapsed result set.

Parámetros

collapseFunction

Valores devueltos

Returns the current SolrQuery object

Ejemplos

Ejemplo #1 SolrQuery::collapse() example

<?php

include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

El resultado del ejemplo sería algo similar a:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)


Constructor

  • « SolrQuery::collapse
  • SolrQuery::__destruct »
  • PHP Manual
  • SolrQuery
  • Constructor

SolrQuery::__construct

(PECL solr >= 0.9.2)

SolrQuery::__construct — Constructor

Descripción

public SolrQuery::__construct ( string $q = ? )

Constructor.

Parámetros

q

Consulta de búsqueda opcional

Valores devueltos

Ninguno.

Errores/Excepciones

Emite una SolrIllegalArgumentException en caso de proporcionar un parámetro no válido.

Historial de cambios

Versión | Descripción
2.0.0 | Si q fuera inválido, se lanza una SolrIllegalArgumentException. Anteriormente se emitía un error.


Destructor

  • « SolrQuery::__construct
  • SolrQuery::getExpand »
  • PHP Manual
  • SolrQuery
  • Destructor

SolrQuery::__destruct

(PECL solr >= 0.9.2)

SolrQuery::__destruct — Destructor

Descripción

public SolrQuery::__destruct ( ) : void

Destructor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nada.


Returns true if group expanding is enabled

  • « SolrQuery::__destruct
  • SolrQuery::getExpandFilterQueries »
  • PHP Manual
  • SolrQuery
  • Returns true if group expanding is enabled

SolrQuery::getExpand

(PECL solr >= 2.2.0)

SolrQuery::getExpand — Returns true if group expanding is enabled

Descripción

public SolrQuery::getExpand ( ) : bool

Returns true if group expanding is enabled


Returns the expand filter queries

  • « SolrQuery::getExpand
  • SolrQuery::getExpandQuery »
  • PHP Manual
  • SolrQuery
  • Returns the expand filter queries

SolrQuery::getExpandFilterQueries

(PECL solr >= 2.2.0)

SolrQuery::getExpandFilterQueries — Returns the expand filter queries

Descripción

public SolrQuery::getExpandFilterQueries ( ) : array

Returns the expand filter queries


Returns the expand query expand.q parameter

  • « SolrQuery::getExpandFilterQueries
  • SolrQuery::getExpandRows »
  • PHP Manual
  • SolrQuery
  • Returns the expand query expand.q parameter

SolrQuery::getExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::getExpandQuery — Returns the expand query expand.q parameter

Descripción

public SolrQuery::getExpandQuery ( ) : array

Returns the expand query expand.q parameter


Returns The number of rows to display in each group (expand.rows)

  • « SolrQuery::getExpandQuery
  • SolrQuery::getExpandSortFields »
  • PHP Manual
  • SolrQuery
  • Returns The number of rows to display in each group (expand.rows)

SolrQuery::getExpandRows

(PECL solr >= 2.2.0)

SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)

Descripción

public SolrQuery::getExpandRows ( ) : int

Returns The number of rows to display in each group (expand.rows)


Returns an array of fields

  • « SolrQuery::getExpandRows
  • SolrQuery::getFacet »
  • PHP Manual
  • SolrQuery
  • Returns an array of fields

SolrQuery::getExpandSortFields

(PECL solr >= 2.2.0)

SolrQuery::getExpandSortFields — Returns an array of fields

Descripción

public SolrQuery::getExpandSortFields ( ) : array

Returns an array of fields


Devuelve el valor del parámetro facet

  • « SolrQuery::getExpandSortFields
  • SolrQuery::getFacetDateEnd »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet

SolrQuery::getFacet

(PECL solr >= 0.9.2)

SolrQuery::getFacet — Devuelve el valor del parámetro facet

Descripción

public SolrQuery::getFacet ( ) : bool

Devuelve el valor del parámetro facet.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un boolean en caso de éxito y null si no se estableció


Devuelve el valor del parámetro facet.date.end

  • « SolrQuery::getFacet
  • SolrQuery::getFacetDateFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet.date.end

SolrQuery::getFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateEnd — Devuelve el valor del parámetro facet.date.end

Descripción

public SolrQuery::getFacetDateEnd ( string $field_override = ? ) : string

Devuelve el valor del parámetro facet.date.end. Este método acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció


Devuelve todos los campos de facet.date

  • « SolrQuery::getFacetDateEnd
  • SolrQuery::getFacetDateGap »
  • PHP Manual
  • SolrQuery
  • Devuelve todos los campos de facet.date

SolrQuery::getFacetDateFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateFields — Devuelve todos los campos de facet.date

Descripción

public SolrQuery::getFacetDateFields ( ) : array

Devuelve todos los campos de facet.date

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve todos los campos de facet.date como matriz o null si no se estableció nada


Devuelve el valor del parámetro facet.date.gap

  • « SolrQuery::getFacetDateFields
  • SolrQuery::getFacetDateHardEnd »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet.date.gap

SolrQuery::getFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateGap — Devuelve el valor del parámetro facet.date.gap

Descripción

public SolrQuery::getFacetDateGap ( string $field_override = ? ) : string

Devuelve el valor del parámetro facet.date.gap. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estabelció


Devuelve el valor del parámetro facet.date.hardend

  • « SolrQuery::getFacetDateGap
  • SolrQuery::getFacetDateOther »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet.date.hardend

SolrQuery::getFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateHardEnd — Devuelve el valor del parámetro facet.date.hardend

Descripción

public SolrQuery::getFacetDateHardEnd ( string $field_override = ? ) : string

Devuelve el valor del parámetro facet.date.hardend. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció


Devuelve el valor del parámetro facet.date.other

  • « SolrQuery::getFacetDateHardEnd
  • SolrQuery::getFacetDateStart »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet.date.other

SolrQuery::getFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateOther — Devuelve el valor del parámetro facet.date.other

Descripción

public SolrQuery::getFacetDateOther ( string $field_override = ? ) : array

Devuelve el valor del parámetro facet.date.other. Este método acepta una sobrescritura opcional de campos.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un array en caso de éxito y null si no se estableció.


Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo

  • « SolrQuery::getFacetDateOther
  • SolrQuery::getFacetFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo

SolrQuery::getFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateStart — Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo

Descripción

public SolrQuery::getFacetDateStart ( string $field_override = ? ) : string

Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció


Devuelve todos los campos facet

  • « SolrQuery::getFacetDateStart
  • SolrQuery::getFacetLimit »
  • PHP Manual
  • SolrQuery
  • Devuelve todos los campos facet

SolrQuery::getFacetFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetFields — Devuelve todos los campos facet

Descripción

public SolrQuery::getFacetFields ( ) : array

Devuelve todos los campos facet

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz de todos los campos y null si no se estableció nada


Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet

  • « SolrQuery::getFacetFields
  • SolrQuery::getFacetMethod »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet

SolrQuery::getFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::getFacetLimit — Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet

Descripción

public SolrQuery::getFacetLimit ( string $field_override = ? ) : int

Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet. Este método acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo a sobrescribir.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció


Devuelve el valor del parámetro facet.method

  • « SolrQuery::getFacetLimit
  • SolrQuery::getFacetMinCount »
  • PHP Manual
  • SolrQuery
  • Devuelve el valor del parámetro facet.method

SolrQuery::getFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::getFacetMethod — Devuelve el valor del parámetro facet.method

Descripción

public SolrQuery::getFacetMethod ( string $field_override = ? ) : string

Devuelve el valor del parámetro facet.method. Acepta una sobrescritura opcional de campos.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se establece


Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta

  • « SolrQuery::getFacetMethod
  • SolrQuery::getFacetMissing »
  • PHP Manual
  • SolrQuery
  • Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta

SolrQuery::getFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::getFacetMinCount — Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta

Descripción

public SolrQuery::getFacetMinCount ( string $field_override = ? ) : int

Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció


Devuelve el estado acutual del parámetro facet.missing

  • « SolrQuery::getFacetMinCount
  • SolrQuery::getFacetOffset »
  • PHP Manual
  • SolrQuery
  • Devuelve el estado acutual del parámetro facet.missing

SolrQuery::getFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::getFacetMissing — Devuelve el estado acutual del parámetro facet.missing

Descripción

public SolrQuery::getFacetMissing ( string $field_override = ? ) : bool

Devuelve el estado acutual del parámetro facet.missing. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció


Devuelve un índice dentro de la lista de restricciones para ser usado en paginación

  • « SolrQuery::getFacetMissing
  • SolrQuery::getFacetPrefix »
  • PHP Manual
  • SolrQuery
  • Devuelve un índice dentro de la lista de restricciones para ser usado en paginación

SolrQuery::getFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::getFacetOffset — Devuelve un índice dentro de la lista de restricciones para ser usado en paginación

Descripción

public SolrQuery::getFacetOffset ( string $field_override = ? ) : int

Devuelve un índice dentro de la lista de restricciones para ser usado en paginación. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo a sobrescribir.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció


Devuelve el prefijo de faceta

  • « SolrQuery::getFacetOffset
  • SolrQuery::getFacetQueries »
  • PHP Manual
  • SolrQuery
  • Devuelve el prefijo de faceta

SolrQuery::getFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::getFacetPrefix — Devuelve el prefijo de faceta

Descripción

public SolrQuery::getFacetPrefix ( string $field_override = ? ) : string

Devuelve el prefijo de faceta

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve todas las consultas de facetas

  • « SolrQuery::getFacetPrefix
  • SolrQuery::getFacetSort »
  • PHP Manual
  • SolrQuery
  • Devuelve todas las consultas de facetas

SolrQuery::getFacetQueries

(PECL solr >= 0.9.2)

SolrQuery::getFacetQueries — Devuelve todas las consultas de facetas

Descripción

public SolrQuery::getFacetQueries ( ) : array

Devuelve todas las consultas de facetas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve el tipo de ordenación de la faceta

  • « SolrQuery::getFacetQueries
  • SolrQuery::getFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el tipo de ordenación de la faceta

SolrQuery::getFacetSort

(PECL solr >= 0.9.2)

SolrQuery::getFacetSort — Devuelve el tipo de ordenación de la faceta

Descripción

public SolrQuery::getFacetSort ( string $field_override = ? ) : int

Devuelve un entero (SolrQuery::FACET_SORT_INDEX o SolrQuery::FACET_SORT_COUNT)

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un entero (SolrQuery::FACET_SORT_INDEX o SolrQuery::FACET_SORT_COUNT) en caso de éxito o null si no se estableció.


Devuelve la lista de campos que serán devueltos en la respuesta

  • « SolrQuery::getFacetSort
  • SolrQuery::getFilterQueries »
  • PHP Manual
  • SolrQuery
  • Devuelve la lista de campos que serán devueltos en la respuesta

SolrQuery::getFields

(PECL solr >= 0.9.2)

SolrQuery::getFields — Devuelve la lista de campos que serán devueltos en la respuesta

Descripción

public SolrQuery::getFields ( ) : array

Devuelve la lista de campos que serán devueltos en la respuesta

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve una matriz de consultas de filtro

  • « SolrQuery::getFields
  • SolrQuery::getGroup »
  • PHP Manual
  • SolrQuery
  • Devuelve una matriz de consultas de filtro

SolrQuery::getFilterQueries

(PECL solr >= 0.9.2)

SolrQuery::getFilterQueries — Devuelve una matriz de consultas de filtro

Descripción

public SolrQuery::getFilterQueries ( ) : array

Devuelve una matriz de consultas de filtro. Éstas son consultas que se pueden usar para restringir el superconjunto de documentos que pueden ser devueltos, sin influenciar en el resutlado

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Returns true if grouping is enabled

  • « SolrQuery::getFilterQueries
  • SolrQuery::getGroupCachePercent »
  • PHP Manual
  • SolrQuery
  • Returns true if grouping is enabled

SolrQuery::getGroup

(PECL solr >= 2.2.0)

SolrQuery::getGroup — Returns true if grouping is enabled

Descripción

public SolrQuery::getGroup ( ) : bool

Returns true if grouping is enabled

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)


Returns group cache percent value

  • « SolrQuery::getGroup
  • SolrQuery::getGroupFacet »
  • PHP Manual
  • SolrQuery
  • Returns group cache percent value

SolrQuery::getGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::getGroupCachePercent — Returns group cache percent value

Descripción

public SolrQuery::getGroupCachePercent ( ) : int

Returns group cache percent value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Returns the group.facet parameter value

  • « SolrQuery::getGroupCachePercent
  • SolrQuery::getGroupFields »
  • PHP Manual
  • SolrQuery
  • Returns the group.facet parameter value

SolrQuery::getGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::getGroupFacet — Returns the group.facet parameter value

Descripción

public SolrQuery::getGroupFacet ( ) : bool

Returns the group.facet parameter value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupFacet() - Sets group.facet parameter


Returns group fields (group.field parameter values)

  • « SolrQuery::getGroupFacet
  • SolrQuery::getGroupFormat »
  • PHP Manual
  • SolrQuery
  • Returns group fields (group.field parameter values)

SolrQuery::getGroupFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupFields — Returns group fields (group.field parameter values)

Descripción

public SolrQuery::getGroupFields ( ) : array

Returns group fields (group.field parameter values)

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::addGroupField() - Add a field to be used to group results


Returns the group.format value

  • « SolrQuery::getGroupFields
  • SolrQuery::getGroupFunctions »
  • PHP Manual
  • SolrQuery
  • Returns the group.format value

SolrQuery::getGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::getGroupFormat — Returns the group.format value

Descripción

public SolrQuery::getGroupFormat ( ) : string

Returns the group.format value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)


Returns group functions (group.func parameter values)

  • « SolrQuery::getGroupFormat
  • SolrQuery::getGroupLimit »
  • PHP Manual
  • SolrQuery
  • Returns group functions (group.func parameter values)

SolrQuery::getGroupFunctions

(PECL solr >= 2.2.0)

SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)

Descripción

public SolrQuery::getGroupFunctions ( ) : array

Returns group functions (group.func parameter values)

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)


Returns the group.limit value

  • « SolrQuery::getGroupFunctions
  • SolrQuery::getGroupMain »
  • PHP Manual
  • SolrQuery
  • Returns the group.limit value

SolrQuery::getGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::getGroupLimit — Returns the group.limit value

Descripción

public SolrQuery::getGroupLimit ( ) : int

Returns the group.limit value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1


Returns the group.main value

  • « SolrQuery::getGroupLimit
  • SolrQuery::getGroupNGroups »
  • PHP Manual
  • SolrQuery
  • Returns the group.main value

SolrQuery::getGroupMain

(PECL solr >= 2.2.0)

SolrQuery::getGroupMain — Returns the group.main value

Descripción

public SolrQuery::getGroupMain ( ) : bool

Returns the group.main value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple


Returns the group.ngroups value

  • « SolrQuery::getGroupMain
  • SolrQuery::getGroupOffset »
  • PHP Manual
  • SolrQuery
  • Returns the group.ngroups value

SolrQuery::getGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::getGroupNGroups — Returns the group.ngroups value

Descripción

public SolrQuery::getGroupNGroups ( ) : bool

Returns the group.ngroups value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results


Returns the group.offset value

  • « SolrQuery::getGroupNGroups
  • SolrQuery::getGroupQueries »
  • PHP Manual
  • SolrQuery
  • Returns the group.offset value

SolrQuery::getGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::getGroupOffset — Returns the group.offset value

Descripción

public SolrQuery::getGroupOffset ( ) : int

Returns the group.offset value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupOffset() - Sets the group.offset parameter


Returns all the group.query parameter values

  • « SolrQuery::getGroupOffset
  • SolrQuery::getGroupSortFields »
  • PHP Manual
  • SolrQuery
  • Returns all the group.query parameter values

SolrQuery::getGroupQueries

(PECL solr >= 2.2.0)

SolrQuery::getGroupQueries — Returns all the group.query parameter values

Descripción

public SolrQuery::getGroupQueries ( ) : array

Returns all the group.query parameter values

Parámetros

Esta función no tiene parámetros.

Valores devueltos

array

Ver también

  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query


Returns the group.sort value

  • « SolrQuery::getGroupQueries
  • SolrQuery::getGroupTruncate »
  • PHP Manual
  • SolrQuery
  • Returns the group.sort value

SolrQuery::getGroupSortFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupSortFields — Returns the group.sort value

Descripción

public SolrQuery::getGroupSortFields ( ) : array

Returns the group.sort value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)


Returns the group.truncate value

  • « SolrQuery::getGroupSortFields
  • SolrQuery::getHighlight »
  • PHP Manual
  • SolrQuery
  • Returns the group.truncate value

SolrQuery::getGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::getGroupTruncate — Returns the group.truncate value

Descripción

public SolrQuery::getGroupTruncate ( ) : bool

Returns the group.truncate value

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query


Devuelve el estado del parámtero hl

  • « SolrQuery::getGroupTruncate
  • SolrQuery::getHighlightAlternateField »
  • PHP Manual
  • SolrQuery
  • Devuelve el estado del parámtero hl

SolrQuery::getHighlight

(PECL solr >= 0.9.2)

SolrQuery::getHighlight — Devuelve el estado del parámtero hl

Descripción

public SolrQuery::getHighlight ( ) : bool

Devuelve un booleano que indica si habilitar o no la generación de trozos remarcados en la respuesta de la consulta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció


Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado

  • « SolrQuery::getHighlight
  • SolrQuery::getHighlightFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado

SolrQuery::getHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::getHighlightAlternateField — Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado

Descripción

public SolrQuery::getHighlightAlternateField ( string $field_override = ? ) : string

Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado. Acepta una sobrescritura opcional.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve todos los campos que Solr debería generar para remarcación de trozos

  • « SolrQuery::getHighlightAlternateField
  • SolrQuery::getHighlightFormatter »
  • PHP Manual
  • SolrQuery
  • Devuelve todos los campos que Solr debería generar para remarcación de trozos

SolrQuery::getHighlightFields

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFields — Devuelve todos los campos que Solr debería generar para remarcación de trozos

Descripción

public SolrQuery::getHighlightFields ( ) : array

Devuelve todos los campos que Solr debería generar para remarcación de trozos

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve el formateador de la salida remarcada

  • « SolrQuery::getHighlightFields
  • SolrQuery::getHighlightFragmenter »
  • PHP Manual
  • SolrQuery
  • Devuelve el formateador de la salida remarcada

SolrQuery::getHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFormatter — Devuelve el formateador de la salida remarcada

Descripción

public SolrQuery::getHighlightFormatter ( string $field_override = ? ) : string

Devuelve el formateador de la salida remarcada

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el generador de trozos de texto para el texto remarcado

  • « SolrQuery::getHighlightFormatter
  • SolrQuery::getHighlightFragsize »
  • PHP Manual
  • SolrQuery
  • Devuelve el generador de trozos de texto para el texto remarcado

SolrQuery::getHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragmenter — Devuelve el generador de trozos de texto para el texto remarcado

Descripción

public SolrQuery::getHighlightFragmenter ( string $field_override = ? ) : string

Devuelve el generador de trozos de texto para el texto remarcado. Acepta una sobrescritura opcional de campos.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el número de caracteres de fragmentos a considerar para remarcación

  • « SolrQuery::getHighlightFragmenter
  • SolrQuery::getHighlightHighlightMultiTerm »
  • PHP Manual
  • SolrQuery
  • Devuelve el número de caracteres de fragmentos a considerar para remarcación

SolrQuery::getHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragsize — Devuelve el número de caracteres de fragmentos a considerar para remarcación

Descripción

public SolrQuery::getHighlightFragsize ( string $field_override = ? ) : int

Devuelve el número de caracteres de fragmentos a considerar para remarcación. Cero implica que no hay fragmentos. Debería usarse el camplo completo.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un entero en caso de éxito o null si no se estableció


Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix

  • « SolrQuery::getHighlightFragsize
  • SolrQuery::getHighlightMaxAlternateFieldLength »
  • PHP Manual
  • SolrQuery
  • Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix

SolrQuery::getHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::getHighlightHighlightMultiTerm — Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix

Descripción

public SolrQuery::getHighlightHighlightMultiTerm ( ) : bool

Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció


Devuelve el número máximo de caracteres del campo a devolver

  • « SolrQuery::getHighlightHighlightMultiTerm
  • SolrQuery::getHighlightMaxAnalyzedChars »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de caracteres del campo a devolver

SolrQuery::getHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAlternateFieldLength — Devuelve el número máximo de caracteres del campo a devolver

Descripción

public SolrQuery::getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int

Devuelve el número máximo de caracteres del campo a devolver

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados

  • « SolrQuery::getHighlightMaxAlternateFieldLength
  • SolrQuery::getHighlightMergeContiguous »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados

SolrQuery::getHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAnalyzedChars — Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados

Descripción

public SolrQuery::getHighlightMaxAnalyzedChars ( ) : int

Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve si colapsar o no fragmentos contiguos en un único fragmento

  • « SolrQuery::getHighlightMaxAnalyzedChars
  • SolrQuery::getHighlightRegexMaxAnalyzedChars »
  • PHP Manual
  • SolrQuery
  • Devuelve si colapsar o no fragmentos contiguos en un único fragmento

SolrQuery::getHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMergeContiguous — Devuelve si colapsar o no fragmentos contiguos en un único fragmento

Descripción

public SolrQuery::getHighlightMergeContiguous ( string $field_override = ? ) : bool

Devuelve si colapsar o no fragmentos contiguos en un único fragmento. Acepta una sobrescritura opcional de campos.

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares

  • « SolrQuery::getHighlightMergeContiguous
  • SolrQuery::getHighlightRegexPattern »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares

SolrQuery::getHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexMaxAnalyzedChars — Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares

Descripción

public SolrQuery::getHighlightRegexMaxAnalyzedChars ( ) : int

Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve la expresión regular para la fragmentación

  • « SolrQuery::getHighlightRegexMaxAnalyzedChars
  • SolrQuery::getHighlightRegexSlop »
  • PHP Manual
  • SolrQuery
  • Devuelve la expresión regular para la fragmentación

SolrQuery::getHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexPattern — Devuelve la expresión regular para la fragmentación

Descripción

public SolrQuery::getHighlightRegexPattern ( ) : string

Devuelve la expresión regular para la fragmentación

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el factor de desviación del tamaño de fragmento ideal

  • « SolrQuery::getHighlightRegexPattern
  • SolrQuery::getHighlightRequireFieldMatch »
  • PHP Manual
  • SolrQuery
  • Devuelve el factor de desviación del tamaño de fragmento ideal

SolrQuery::getHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexSlop — Devuelve el factor de desviación del tamaño de fragmento ideal

Descripción

public SolrQuery::getHighlightRegexSlop ( ) : float

Devuelve el factor por el que el fragmentador de expresiones regulares puede desviar desde el tamaño de fragmeto ideal para acomodar la expresión regular

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un doble en caso de éxito y null si no se estableció.


Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular

  • « SolrQuery::getHighlightRegexSlop
  • SolrQuery::getHighlightSimplePost »
  • PHP Manual
  • SolrQuery
  • Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular

SolrQuery::getHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRequireFieldMatch — Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular

Descripción

public SolrQuery::getHighlightRequireFieldMatch ( ) : bool

Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve el texto que aparece después de un término remarcado

  • « SolrQuery::getHighlightRequireFieldMatch
  • SolrQuery::getHighlightSimplePre »
  • PHP Manual
  • SolrQuery
  • Devuelve el texto que aparece después de un término remarcado

SolrQuery::getHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePost — Devuelve el texto que aparece después de un término remarcado

Descripción

public SolrQuery::getHighlightSimplePost ( string $field_override = ? ) : string

Devuelve el texto que aparece después de un término remarcado. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el texto que aparece antes de un término remarcado

  • « SolrQuery::getHighlightSimplePost
  • SolrQuery::getHighlightSnippets »
  • PHP Manual
  • SolrQuery
  • Devuelve el texto que aparece antes de un término remarcado

SolrQuery::getHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePre — Devuelve el texto que aparece antes de un término remarcado

Descripción

public SolrQuery::getHighlightSimplePre ( string $field_override = ? ) : string

Devuelve el texto que aparece antes de un término remarcado. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el número máximo de trozos remarcados a generar por campo

  • « SolrQuery::getHighlightSimplePre
  • SolrQuery::getHighlightUsePhraseHighlighter »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de trozos remarcados a generar por campo

SolrQuery::getHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSnippets — Devuelve el número máximo de trozos remarcados a generar por campo

Descripción

public SolrQuery::getHighlightSnippets ( string $field_override = ? ) : int

Devuelve el número máximo de trozos remarcados a generar por campo. Acepta una sobrescritura opcional de campos

Parámetros

field_override

El nombre del campo

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el estado del parámetro hl.usePhraseHighlighter

  • « SolrQuery::getHighlightSnippets
  • SolrQuery::getMlt »
  • PHP Manual
  • SolrQuery
  • Devuelve el estado del parámetro hl.usePhraseHighlighter

SolrQuery::getHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightUsePhraseHighlighter — Devuelve el estado del parámetro hl.usePhraseHighlighter

Descripción

public SolrQuery::getHighlightUsePhraseHighlighter ( ) : bool

Devuelve si usar o no SpanScorer para remarcar términos de frases sólo cuando aparezcan dentro de la frase de consulta en el documento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve si los resultados MoreLikeThis deberían o no ser habilitados

  • « SolrQuery::getHighlightUsePhraseHighlighter
  • SolrQuery::getMltBoost »
  • PHP Manual
  • SolrQuery
  • Devuelve si los resultados MoreLikeThis deberían o no ser habilitados

SolrQuery::getMlt

(PECL solr >= 0.9.2)

SolrQuery::getMlt — Devuelve si los resultados MoreLikeThis deberían o no ser habilitados

Descripción

public SolrQuery::getMlt ( ) : bool

Devuelve si los resultados MoreLikeThis deberían o no ser habilitados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés

  • « SolrQuery::getMlt
  • SolrQuery::getMltCount »
  • PHP Manual
  • SolrQuery
  • Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés

SolrQuery::getMltBoost

(PECL solr >= 0.9.2)

SolrQuery::getMltBoost — Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés

Descripción

public SolrQuery::getMltBoost ( ) : bool

Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve el número de documentos similares a devolver para cada resultado

  • « SolrQuery::getMltBoost
  • SolrQuery::getMltFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el número de documentos similares a devolver para cada resultado

SolrQuery::getMltCount

(PECL solr >= 0.9.2)

SolrQuery::getMltCount — Devuelve el número de documentos similares a devolver para cada resultado

Descripción

public SolrQuery::getMltCount ( ) : int

Devuelve el número de documentos similares a devolver para cada resultado

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve todos los campos a usar para similitud

  • « SolrQuery::getMltCount
  • SolrQuery::getMltMaxNumQueryTerms »
  • PHP Manual
  • SolrQuery
  • Devuelve todos los campos a usar para similitud

SolrQuery::getMltFields

(PECL solr >= 0.9.2)

SolrQuery::getMltFields — Devuelve todos los campos a usar para similitud

Descripción

public SolrQuery::getMltFields ( ) : array

Devuelve todos los campos a usar para similitud

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada

  • « SolrQuery::getMltFields
  • SolrQuery::getMltMaxNumTokens »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada

SolrQuery::getMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumQueryTerms — Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada

Descripción

public SolrQuery::getMltMaxNumQueryTerms ( ) : int

Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector

  • « SolrQuery::getMltMaxNumQueryTerms
  • SolrQuery::getMltMaxWordLength »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector

SolrQuery::getMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumTokens — Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector

Descripción

public SolrQuery::getMltMaxNumTokens ( ) : int

Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve la longitud máxima de palabra de las palabras que serán ignoradas

  • « SolrQuery::getMltMaxNumTokens
  • SolrQuery::getMltMinDocFrequency »
  • PHP Manual
  • SolrQuery
  • Devuelve la longitud máxima de palabra de las palabras que serán ignoradas

SolrQuery::getMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxWordLength — Devuelve la longitud máxima de palabra de las palabras que serán ignoradas

Descripción

public SolrQuery::getMltMaxWordLength ( ) : int

Devuelve la longitud máxima de palabra de las palabras que serán ignoradas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas

  • « SolrQuery::getMltMaxWordLength
  • SolrQuery::getMltMinTermFrequency »
  • PHP Manual
  • SolrQuery
  • Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas

SolrQuery::getMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinDocFrequency — Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas

Descripción

public SolrQuery::getMltMinDocFrequency ( ) : int

Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente

  • « SolrQuery::getMltMinDocFrequency
  • SolrQuery::getMltMinWordLength »
  • PHP Manual
  • SolrQuery
  • Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente

SolrQuery::getMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinTermFrequency — Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente

Descripción

public SolrQuery::getMltMinTermFrequency ( ) : int

Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas

  • « SolrQuery::getMltMinTermFrequency
  • SolrQuery::getMltQueryFields »
  • PHP Manual
  • SolrQuery
  • Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas

SolrQuery::getMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMinWordLength — Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas

Descripción

public SolrQuery::getMltMinWordLength ( ) : int

Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve los campos de consultas y sus boosts

  • « SolrQuery::getMltMinWordLength
  • SolrQuery::getQuery »
  • PHP Manual
  • SolrQuery
  • Devuelve los campos de consultas y sus boosts

SolrQuery::getMltQueryFields

(PECL solr >= 0.9.2)

SolrQuery::getMltQueryFields — Devuelve los campos de consultas y sus boosts

Descripción

public SolrQuery::getMltQueryFields ( ) : array

Devuelve los campos de consultas y sus boosts

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve la consulta principal

  • « SolrQuery::getMltQueryFields
  • SolrQuery::getRows »
  • PHP Manual
  • SolrQuery
  • Devuelve la consulta principal

SolrQuery::getQuery

(PECL solr >= 0.9.2)

SolrQuery::getQuery — Devuelve la consulta principal

Descripción

public SolrQuery::getQuery ( ) : string

Devuelve la consulta de búsqueda principal

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el número máximo de documentos

  • « SolrQuery::getQuery
  • SolrQuery::getSortFields »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de documentos

SolrQuery::getRows

(PECL solr >= 0.9.2)

SolrQuery::getRows — Devuelve el número máximo de documentos

Descripción

public SolrQuery::getRows ( ) : int

Devuelve el número máximo de documentos del conjunto de resultados completo del cliente para cada consulta

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve todos los campos de ordenación

  • « SolrQuery::getRows
  • SolrQuery::getStart »
  • PHP Manual
  • SolrQuery
  • Devuelve todos los campos de ordenación

SolrQuery::getSortFields

(PECL solr >= 0.9.2)

SolrQuery::getSortFields — Devuelve todos los campos de ordenación

Descripción

public SolrQuery::getSortFields ( ) : array

Devuelve todos los campos de ordenación

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció ningún parámetro.


Devuelve el índice del conjunto de resultados completo

  • « SolrQuery::getSortFields
  • SolrQuery::getStats »
  • PHP Manual
  • SolrQuery
  • Devuelve el índice del conjunto de resultados completo

SolrQuery::getStart

(PECL solr >= 0.9.2)

SolrQuery::getStart — Devuelve el índice del conjunto de resultados completo

Descripción

public SolrQuery::getStart ( ) : int

Devuelve el índice del conjunto de resultados completo para las consultas donde el conjunto de documentos devueltos debería comenzar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve si están habilitadas o no las estadísticas

  • « SolrQuery::getStart
  • SolrQuery::getStatsFacets »
  • PHP Manual
  • SolrQuery
  • Devuelve si están habilitadas o no las estadísticas

SolrQuery::getStats

(PECL solr >= 0.9.2)

SolrQuery::getStats — Devuelve si están habilitadas o no las estadísticas

Descripción

public SolrQuery::getStats ( ) : bool

Devuelve si están habilitadas o no las estadísticas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve todas las estadísticas de las facetas que fueron establecidas

  • « SolrQuery::getStats
  • SolrQuery::getStatsFields »
  • PHP Manual
  • SolrQuery
  • Devuelve todas las estadísticas de las facetas que fueron establecidas

SolrQuery::getStatsFacets

(PECL solr >= 0.9.2)

SolrQuery::getStatsFacets — Devuelve todas las estadísticas de las facetas que fueron establecidas

Descripción

public SolrQuery::getStatsFacets ( ) : array

Devuelve todas las estadísticas de las facetas que fueron establecidas

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve todas las estadísticas de los campos

  • « SolrQuery::getStatsFacets
  • SolrQuery::getTerms »
  • PHP Manual
  • SolrQuery
  • Devuelve todas las estadísticas de los campos

SolrQuery::getStatsFields

(PECL solr >= 0.9.2)

SolrQuery::getStatsFields — Devuelve todas las estadísticas de los campos

Descripción

public SolrQuery::getStatsFields ( ) : array

Devuelve todas las estadísticas de los campos

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz en caso de éxito y null si no se estableció.


Devuelve si está habilitado o no TermsComponent

  • « SolrQuery::getStatsFields
  • SolrQuery::getTermsField »
  • PHP Manual
  • SolrQuery
  • Devuelve si está habilitado o no TermsComponent

SolrQuery::getTerms

(PECL solr >= 0.9.2)

SolrQuery::getTerms — Devuelve si está habilitado o no TermsComponent

Descripción

public SolrQuery::getTerms ( ) : bool

Devuelve si está habilitado o no TermsComponent

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve el campo desde el cuál los términos son recuperados

  • « SolrQuery::getTerms
  • SolrQuery::getTermsIncludeLowerBound »
  • PHP Manual
  • SolrQuery
  • Devuelve el campo desde el cuál los términos son recuperados

SolrQuery::getTermsField

(PECL solr >= 0.9.2)

SolrQuery::getTermsField — Devuelve el campo desde el cuál los términos son recuperados

Descripción

public SolrQuery::getTermsField ( ) : string

Devuelve el campo desde el cuál los términos son recuperados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve si incluir o no el límite inferior en el conjunto de resultados

  • « SolrQuery::getTermsField
  • SolrQuery::getTermsIncludeUpperBound »
  • PHP Manual
  • SolrQuery
  • Devuelve si incluir o no el límite inferior en el conjunto de resultados

SolrQuery::getTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeLowerBound — Devuelve si incluir o no el límite inferior en el conjunto de resultados

Descripción

public SolrQuery::getTermsIncludeLowerBound ( ) : bool

Devuelve si incluir o no el límite inferior en el conjunto de resultados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve si incluir o no el término de límite superior en el conjunto de resultados

  • « SolrQuery::getTermsIncludeLowerBound
  • SolrQuery::getTermsLimit »
  • PHP Manual
  • SolrQuery
  • Devuelve si incluir o no el término de límite superior en el conjunto de resultados

SolrQuery::getTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeUpperBound — Devuelve si incluir o no el término de límite superior en el conjunto de resultados

Descripción

public SolrQuery::getTermsIncludeUpperBound ( ) : bool

Devuelve si incluir o no el término de límite superior en el conjunto de resultados

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve el número máximo de términos que debería devolver Solr

  • « SolrQuery::getTermsIncludeUpperBound
  • SolrQuery::getTermsLowerBound »
  • PHP Manual
  • SolrQuery
  • Devuelve el número máximo de términos que debería devolver Solr

SolrQuery::getTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::getTermsLimit — Devuelve el número máximo de términos que debería devolver Solr

Descripción

public SolrQuery::getTermsLimit ( ) : int

Devuelve el número máximo de términos que debería devolver Solr

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el término en el que comenzar

  • « SolrQuery::getTermsLimit
  • SolrQuery::getTermsMaxCount »
  • PHP Manual
  • SolrQuery
  • Devuelve el término en el que comenzar

SolrQuery::getTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsLowerBound — Devuelve el término en el que comenzar

Descripción

public SolrQuery::getTermsLowerBound ( ) : string

Devuelve el término en el que comenzar

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve la frecuencia de documento máxima

  • « SolrQuery::getTermsLowerBound
  • SolrQuery::getTermsMinCount »
  • PHP Manual
  • SolrQuery
  • Devuelve la frecuencia de documento máxima

SolrQuery::getTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMaxCount — Devuelve la frecuencia de documento máxima

Descripción

public SolrQuery::getTermsMaxCount ( ) : int

Devuelve la frecuencia de documento máxima

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve la frecuencia de documento mínima a devolver para ser incluido

  • « SolrQuery::getTermsMaxCount
  • SolrQuery::getTermsPrefix »
  • PHP Manual
  • SolrQuery
  • Devuelve la frecuencia de documento mínima a devolver para ser incluido

SolrQuery::getTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMinCount — Devuelve la frecuencia de documento mínima a devolver para ser incluido

Descripción

public SolrQuery::getTermsMinCount ( ) : int

Devuelve la frecuencia de documento mínima a devolver para ser incluido

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el prefijo del término

  • « SolrQuery::getTermsMinCount
  • SolrQuery::getTermsReturnRaw »
  • PHP Manual
  • SolrQuery
  • Devuelve el prefijo del término

SolrQuery::getTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::getTermsPrefix — Devuelve el prefijo del término

Descripción

public SolrQuery::getTermsPrefix ( ) : string

Devuelve el prefijo por el que los términos coincedentes deben ser restringidos. Restringirá las coincidencias sólo de los términos que empiecen con el prefijo

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Si devolver o no caracteres en bruto

  • « SolrQuery::getTermsPrefix
  • SolrQuery::getTermsSort »
  • PHP Manual
  • SolrQuery
  • Si devolver o no caracteres en bruto

SolrQuery::getTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::getTermsReturnRaw — Si devolver o no caracteres en bruto

Descripción

public SolrQuery::getTermsReturnRaw ( ) : bool

Devuelve un booleano indicando si devolver o no caracteres en bruto del término indexado, sin tener en cuenta si es legible por humanos

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un booleano en caso de éxito y null si no se estableció.


Devuelve un entero indicando cómo son ordenados los términos

  • « SolrQuery::getTermsReturnRaw
  • SolrQuery::getTermsUpperBound »
  • PHP Manual
  • SolrQuery
  • Devuelve un entero indicando cómo son ordenados los términos

SolrQuery::getTermsSort

(PECL solr >= 0.9.2)

SolrQuery::getTermsSort — Devuelve un entero indicando cómo son ordenados los términos

Descripción

public SolrQuery::getTermsSort ( ) : int

SolrQuery::TERMS_SORT_INDEX indica que los términos son devueltos por orden de índice. SolrQuery::TERMS_SORT_COUNT implica que los términos son ordenados según la frecuencia del término (la más alta cuenta como la primera)

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Devuelve el término en donde parar

  • « SolrQuery::getTermsSort
  • SolrQuery::getTimeAllowed »
  • PHP Manual
  • SolrQuery
  • Devuelve el término en donde parar

SolrQuery::getTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsUpperBound — Devuelve el término en donde parar

Descripción

public SolrQuery::getTermsUpperBound ( ) : string

Devuelve el término en donde parar

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una cadena en caso de éxito y null si no se estableció.


Devuelve el tiempo en milisegundos permitido para que la consulta finalice

  • « SolrQuery::getTermsUpperBound
  • SolrQuery::removeExpandFilterQuery »
  • PHP Manual
  • SolrQuery
  • Devuelve el tiempo en milisegundos permitido para que la consulta finalice

SolrQuery::getTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::getTimeAllowed — Devuelve el tiempo en milisegundos permitido para que la consulta finalice

Descripción

public SolrQuery::getTimeAllowed ( ) : int

Devuelve el tiempo en milisegundos permitido para que la consulta finalice.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un entero en caso de éxito y null si no se estableció.


Removes an expand filter query

  • « SolrQuery::getTimeAllowed
  • SolrQuery::removeExpandSortField »
  • PHP Manual
  • SolrQuery
  • Removes an expand filter query

SolrQuery::removeExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::removeExpandFilterQuery — Removes an expand filter query

Descripción

public SolrQuery::removeExpandFilterQuery ( string $fq ) : SolrQuery

Removes an expand filter query.

Parámetros

fq

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group


Removes an expand sort field from the expand.sort parameter

  • « SolrQuery::removeExpandFilterQuery
  • SolrQuery::removeFacetDateField »
  • PHP Manual
  • SolrQuery
  • Removes an expand sort field from the expand.sort parameter

SolrQuery::removeExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter

Descripción

public SolrQuery::removeExpandSortField ( string $field ) : SolrQuery

Removes an expand sort field from the expand.sort parameter.

Parámetros

field

field name

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Elimina uno de los campos de faceta de fecha

  • « SolrQuery::removeExpandSortField
  • SolrQuery::removeFacetDateOther »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los campos de faceta de fecha

SolrQuery::removeFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateField — Elimina uno de los campos de faceta de fecha

Descripción

public SolrQuery::removeFacetDateField ( string $field ) : SolrQuery

El nombre del campo

Parámetros

field

El nombre del campo de fecha a eliminar

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los parámetros facet.date.other

  • « SolrQuery::removeFacetDateField
  • SolrQuery::removeFacetField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los parámetros facet.date.other

SolrQuery::removeFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateOther — Elimina uno de los parámetros facet.date.other

Descripción

public SolrQuery::removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery

Elimina uno de los parámetros facet.date.other.

Parámetros

value

El valor

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los parámetros facet.date

  • « SolrQuery::removeFacetDateOther
  • SolrQuery::removeFacetQuery »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los parámetros facet.date

SolrQuery::removeFacetField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetField — Elimina uno de los parámetros facet.date

Descripción

public SolrQuery::removeFacetField ( string $field ) : SolrQuery

Elimina uno de los parámetros facet.date.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los parámetros facet.query

  • « SolrQuery::removeFacetField
  • SolrQuery::removeField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los parámetros facet.query

SolrQuery::removeFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFacetQuery — Elimina uno de los parámetros facet.query

Descripción

public SolrQuery::removeFacetQuery ( string $value ) : SolrQuery

Elimina uno de los parámetros facet.query.

Parámetros

value

El valor

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina un campo de la lista de campos

  • « SolrQuery::removeFacetQuery
  • SolrQuery::removeFilterQuery »
  • PHP Manual
  • SolrQuery
  • Elimina un campo de la lista de campos

SolrQuery::removeField

(PECL solr >= 0.9.2)

SolrQuery::removeField — Elimina un campo de la lista de campos

Descripción

public SolrQuery::removeField ( string $field ) : SolrQuery

Elimina un campo de la lista de campos

Parámetros

field

Nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina una consulta de filtro

  • « SolrQuery::removeField
  • SolrQuery::removeHighlightField »
  • PHP Manual
  • SolrQuery
  • Elimina una consulta de filtro

SolrQuery::removeFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFilterQuery — Elimina una consulta de filtro

Descripción

public SolrQuery::removeFilterQuery ( string $fq ) : SolrQuery

Elimina una consulta de filtro.

Parámetros

fq

La consulta de filtro a eliminar

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los campos usados para remarcación

  • « SolrQuery::removeFilterQuery
  • SolrQuery::removeMltField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los campos usados para remarcación

SolrQuery::removeHighlightField

(PECL solr >= 0.9.2)

SolrQuery::removeHighlightField — Elimina uno de los campos usados para remarcación

Descripción

public SolrQuery::removeHighlightField ( string $field ) : SolrQuery

Elimina uno de los campos usados para remarcación.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los campos moreLikeThis

  • « SolrQuery::removeHighlightField
  • SolrQuery::removeMltQueryField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los campos moreLikeThis

SolrQuery::removeMltField

(PECL solr >= 0.9.2)

SolrQuery::removeMltField — Elimina uno de los campos moreLikeThis

Descripción

public SolrQuery::removeMltField ( string $field ) : SolrQuery

Elimina uno de los campos moreLikeThis.

Parámetros

field

Nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los campos de consulta moreLikeThis

  • « SolrQuery::removeMltField
  • SolrQuery::removeSortField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los campos de consulta moreLikeThis

SolrQuery::removeMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::removeMltQueryField — Elimina uno de los campos de consulta moreLikeThis

Descripción

public SolrQuery::removeMltQueryField ( string $queryField ) : SolrQuery

Elimina uno de los campos de consulta moreLikeThis.

Parámetros

queryField

El campo de consulta

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los campos de ordenación

  • « SolrQuery::removeMltQueryField
  • SolrQuery::removeStatsFacet »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los campos de ordenación

SolrQuery::removeSortField

(PECL solr >= 0.9.2)

SolrQuery::removeSortField — Elimina uno de los campos de ordenación

Descripción

public SolrQuery::removeSortField ( string $field ) : SolrQuery

Elimina uno de los campos de ordenación.

Parámetros

field

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los parámetros stats.facet

  • « SolrQuery::removeSortField
  • SolrQuery::removeStatsField »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los parámetros stats.facet

SolrQuery::removeStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::removeStatsFacet — Elimina uno de los parámetros stats.facet

Descripción

public SolrQuery::removeStatsFacet ( string $value ) : SolrQuery

Elimina uno de los parámetros stats.facet

Parámetros

value

El valor

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Elimina uno de los parámetros stats.field

  • « SolrQuery::removeStatsFacet
  • SolrQuery::setEchoHandler »
  • PHP Manual
  • SolrQuery
  • Elimina uno de los parámetros stats.field

SolrQuery::removeStatsField

(PECL solr >= 0.9.2)

SolrQuery::removeStatsField — Elimina uno de los parámetros stats.field

Descripción

public SolrQuery::removeStatsField ( string $field ) : SolrQuery

Elimina uno de los parámetros stats.field

Parámetros

field

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Conmuta el parámetro echoHandler

  • « SolrQuery::removeStatsField
  • SolrQuery::setEchoParams »
  • PHP Manual
  • SolrQuery
  • Conmuta el parámetro echoHandler

SolrQuery::setEchoHandler

(PECL solr >= 0.9.2)

SolrQuery::setEchoHandler — Conmuta el parámetro echoHandler

Descripción

public SolrQuery::setEchoHandler ( bool $flag ) : SolrQuery

Si está establecido a true, Solr coloca los nombres de los gestores usados en la respuesta al cliente para propósitos de depuración.

Parámetros

flag

true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Determina qué tipo de parámetros incluir en la respuesta

  • « SolrQuery::setEchoHandler
  • SolrQuery::setExpand »
  • PHP Manual
  • SolrQuery
  • Determina qué tipo de parámetros incluir en la respuesta

SolrQuery::setEchoParams

(PECL solr >= 0.9.2)

SolrQuery::setEchoParams — Determina qué tipo de parámetros incluir en la respuesta

Descripción

public SolrQuery::setEchoParams ( string $type ) : SolrQuery

Ordena a Solr qué tipos de parámetros de solicitud deberían ser incluidos en la respuesta para propósitos de depuración, valores legales incluidos:

- none - no incluir ningún parámetro de solicitud para la depuración
- explicit - incluir los parámetros explícitamete especificados por el cliente en la solicitud
- all - incluir todos los parámetros involucrados en esta solicitud, los especificados explícitamente por el cliente, o los implícitos debido a la configuración del gestor de solicitudes.

Parámetros

type

El tipo de parámetros a incluir

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Enables/Disables the Expand Component

  • « SolrQuery::setEchoParams
  • SolrQuery::setExpandQuery »
  • PHP Manual
  • SolrQuery
  • Enables/Disables the Expand Component

SolrQuery::setExpand

(PECL solr >= 2.2.0)

SolrQuery::setExpand — Enables/Disables the Expand Component

Descripción

public SolrQuery::setExpand ( bool $value ) : SolrQuery

Enables/Disables the Expand Component.

Parámetros

value

Bool flag

Valores devueltos

SolrQuery

Ejemplos

Ejemplo #1 SolrQuery::setExpand() example

<?php

$query = new SolrQuery('lucene');

$query
    ->setExpand(true)
    ->setExpandRows(50)
    ->setExpandQuery('text:product')
    ->addExpandFilterQuery('manu:apple')
    ->addExpandFilterQuery('inStock:true')
    ->addExpandSortField('score', SolrQuery::ORDER_DESC)
    ->addExpandSortField('title', SolrQuery::ORDER_ASC);

echo $query.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&expand=true&expand.rows=50&expand.q=text:product&expand.fq=manu:apple&expand.fq=inStock:true&expand.sort=score desc,title asc

Ver también

  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Sets the expand.q parameter

  • « SolrQuery::setExpand
  • SolrQuery::setExpandRows »
  • PHP Manual
  • SolrQuery
  • Sets the expand.q parameter

SolrQuery::setExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::setExpandQuery — Sets the expand.q parameter

Descripción

public SolrQuery::setExpandQuery ( string $q ) : SolrQuery

Sets the expand.q parameter.

Overrides the main q parameter, determines which documents to include in the main group.

Parámetros

q

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Sets the number of rows to display in each group (expand.rows). Server Default 5

  • « SolrQuery::setExpandQuery
  • SolrQuery::setExplainOther »
  • PHP Manual
  • SolrQuery
  • Sets the number of rows to display in each group (expand.rows). Server Default 5

SolrQuery::setExpandRows

(PECL solr >= 2.2.0)

SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5

Descripción

public SolrQuery::setExpandRows ( int $value ) : SolrQuery

Sets the number of rows to display in each group (expand.rows). Server Default 5

Parámetros

value

Valores devueltos

SolrQuery

Ver también

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Establece el parámetro de consulta común explainOther

  • « SolrQuery::setExpandRows
  • SolrQuery::setFacet »
  • PHP Manual
  • SolrQuery
  • Establece el parámetro de consulta común explainOther

SolrQuery::setExplainOther

(PECL solr >= 0.9.2)

SolrQuery::setExplainOther — Establece el parámetro de consulta común explainOther

Descripción

public SolrQuery::setExplainOther ( string $query ) : SolrQuery

Establece el parámetro de consulta común explainOther

Parámetros

query

La consulta Lucene para identificar un conjuntos de documentos

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea al parámetro facet. Habilita o deshabilta las facetas

  • « SolrQuery::setExplainOther
  • SolrQuery::setFacetDateEnd »
  • PHP Manual
  • SolrQuery
  • Mapea al parámetro facet. Habilita o deshabilta las facetas

SolrQuery::setFacet

(PECL solr >= 0.9.2)

SolrQuery::setFacet — Mapea al parámetro facet. Habilita o deshabilta las facetas

Descripción

public SolrQuery::setFacet ( bool $flag ) : SolrQuery

Habilita o deshabilta las facetas.

Parámetros

value

true habilita las facetas y false las deshabilita.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.date.end

  • « SolrQuery::setFacet
  • SolrQuery::setFacetDateGap »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.date.end

SolrQuery::setFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateEnd — Mapea a facet.date.end

Descripción

public SolrQuery::setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery

Mapea a facet.date.end

Parámetros

value

Véase facet.date.end

field_override

Nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.date.gap

  • « SolrQuery::setFacetDateEnd
  • SolrQuery::setFacetDateHardEnd »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.date.gap

SolrQuery::setFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateGap — Mapea a facet.date.gap

Descripción

public SolrQuery::setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery

Mapea a facet.date.gap

Parámetros

value

Véase facet.date.gap

field_override

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.date.hardend

  • « SolrQuery::setFacetDateGap
  • SolrQuery::setFacetDateStart »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.date.hardend

SolrQuery::setFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateHardEnd — Mapea a facet.date.hardend

Descripción

public SolrQuery::setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery

Mapea a facet.date.hardend

Parámetros

value

Véase facet.date.hardend

field_override

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.date.start

  • « SolrQuery::setFacetDateHardEnd
  • SolrQuery::setFacetEnumCacheMinDefaultFrequency »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.date.start

SolrQuery::setFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateStart — Mapea a facet.date.start

Descripción

public SolrQuery::setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery

Mapea a facet.date.start

Parámetros

value

Véase facet.date.start

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la frecuencia de documento mínima usada para determinar la cuenta de términos

  • « SolrQuery::setFacetDateStart
  • SolrQuery::setFacetLimit »
  • PHP Manual
  • SolrQuery
  • Establece la frecuencia de documento mínima usada para determinar la cuenta de términos

SolrQuery::setFacetEnumCacheMinDefaultFrequency

(PECL solr >= 0.9.2)

SolrQuery::setFacetEnumCacheMinDefaultFrequency — Establece la frecuencia de documento mínima usada para determinar la cuenta de términos

Descripción

public SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery

Establece la frecuencia de documento mínima usada para determinar la cuenta de términos

Parámetros

value

La frecuencia mínima

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.limit

  • « SolrQuery::setFacetEnumCacheMinDefaultFrequency
  • SolrQuery::setFacetMethod »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.limit

SolrQuery::setFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::setFacetLimit — Mapea a facet.limit

Descripción

public SolrQuery::setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery

Mapea a facet.limit. Establece el número máximo de restricciones que deberían ser devueltas por los campos de facetas.

Parámetros

limit

El número máximo de restricciones

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo

  • « SolrQuery::setFacetLimit
  • SolrQuery::setFacetMinCount »
  • PHP Manual
  • SolrQuery
  • Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo

SolrQuery::setFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::setFacetMethod — Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo

Descripción

public SolrQuery::setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery

Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo. Este método acepta la sobrescritura opcional de campos.

Parámetros

method

El método a usar.

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.mincount

  • « SolrQuery::setFacetMethod
  • SolrQuery::setFacetMissing »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.mincount

SolrQuery::setFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::setFacetMinCount — Mapea a facet.mincount

Descripción

public SolrQuery::setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery

Establece el mínimo de campos de faceta que deberían ser incluidos en la respuesta

Parámetros

mincount

El mínimo

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Mapea a facet.missing

  • « SolrQuery::setFacetMinCount
  • SolrQuery::setFacetOffset »
  • PHP Manual
  • SolrQuery
  • Mapea a facet.missing

SolrQuery::setFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::setFacetMissing — Mapea a facet.missing

Descripción

public SolrQuery::setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery

Usado para indicar que además de las restricciones basdas en términos de un campo de faceta, debería ser computada una cuenta de todos los resultados coincidentes que no tienen valor para el campo

Parámetros

flag

true activa esta característica. false la desactiva.

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el índice de la lista de restricciones para tener en cuenta la paginación

  • « SolrQuery::setFacetMissing
  • SolrQuery::setFacetPrefix »
  • PHP Manual
  • SolrQuery
  • Establece el índice de la lista de restricciones para tener en cuenta la paginación

SolrQuery::setFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::setFacetOffset — Establece el índice de la lista de restricciones para tener en cuenta la paginación

Descripción

public SolrQuery::setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery

Establece el índice de la lista de restricciones para tener en cuenta la paginación.

Parámetros

offset

El índice

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta

  • « SolrQuery::setFacetOffset
  • SolrQuery::setFacetSort »
  • PHP Manual
  • SolrQuery
  • Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta

SolrQuery::setFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::setFacetPrefix — Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta

Descripción

public SolrQuery::setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery

Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta.

Parámetros

prefix

La cadena de prefijo

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Determina el orden de las restricciones de campos de faceta

  • « SolrQuery::setFacetPrefix
  • SolrQuery::setGroup »
  • PHP Manual
  • SolrQuery
  • Determina el orden de las restricciones de campos de faceta

SolrQuery::setFacetSort

(PECL solr >= 0.9.2)

SolrQuery::setFacetSort — Determina el orden de las restricciones de campos de faceta

Descripción

public SolrQuery::setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery

Determina el orden de las restricciones de campos de faceta

Parámetros

facetSort

Use SolrQuery::FACET_SORT_INDEX para ordenar por índice o SolrQuery::FACET_SORT_COUNT para ordenar por cuenta.

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Enable/Disable result grouping (group parameter)

  • « SolrQuery::setFacetSort
  • SolrQuery::setGroupCachePercent »
  • PHP Manual
  • SolrQuery
  • Enable/Disable result grouping (group parameter)

SolrQuery::setGroup

(PECL solr >= 2.2.0)

SolrQuery::setGroup — Enable/Disable result grouping (group parameter)

Descripción

public SolrQuery::setGroup ( bool $value ) : SolrQuery

Enable/Disable result grouping (group parameter)

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::getGroup() - Returns true if grouping is enabled
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Enables caching for result grouping

  • « SolrQuery::setGroup
  • SolrQuery::setGroupFacet »
  • PHP Manual
  • SolrQuery
  • Enables caching for result grouping

SolrQuery::setGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::setGroupCachePercent — Enables caching for result grouping

Descripción

public SolrQuery::setGroupCachePercent ( int $percent ) : SolrQuery

Setting this parameter to a number greater than 0 enables caching for result grouping. Result Grouping executes two searches; this option caches the second search. The server default value is 0. Testing has shown that group caching only improves search time with Boolean, wildcard, and fuzzy queries. For simple queries like term or "match all" queries, group caching degrades performance. group.cache.percent parameter

Parámetros

percent

Valores devueltos

Errores/Excepciones

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)


Sets group.facet parameter

  • « SolrQuery::setGroupCachePercent
  • SolrQuery::setGroupFormat »
  • PHP Manual
  • SolrQuery
  • Sets group.facet parameter

SolrQuery::setGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::setGroupFacet — Sets group.facet parameter

Descripción

public SolrQuery::setGroupFacet ( bool $value ) : SolrQuery

Determines whether to compute grouped facets for the field facets specified in facet.field parameters. Grouped facets are computed based on the first specified group.

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Sets the group format, result structure (group.format parameter)

  • « SolrQuery::setGroupFacet
  • SolrQuery::setGroupLimit »
  • PHP Manual
  • SolrQuery
  • Sets the group format, result structure (group.format parameter)

SolrQuery::setGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)

Descripción

public SolrQuery::setGroupFormat ( string $value ) : SolrQuery

Sets the group.format parameter. If this parameter is set to simple, the grouped documents are presented in a single flat list, and the start and rows parameters affect the numbers of documents instead of groups. Accepts: grouped/simple

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Specifies the number of results to return for each group. The server default value is 1

  • « SolrQuery::setGroupFormat
  • SolrQuery::setGroupMain »
  • PHP Manual
  • SolrQuery
  • Specifies the number of results to return for each group. The server default value is 1

SolrQuery::setGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1

Descripción

public SolrQuery::setGroupLimit ( int $value ) : SolrQuery

Specifies the number of results to return for each group. The server default value is 1.

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

  • « SolrQuery::setGroupLimit
  • SolrQuery::setGroupNGroups »
  • PHP Manual
  • SolrQuery
  • If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

SolrQuery::setGroupMain

(PECL solr >= 2.2.0)

SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

Descripción

public SolrQuery::setGroupMain ( string $value ) : SolrQuery

If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.

Parámetros

value

Valores devueltos

Ver también

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupMain()
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, Solr includes the number of groups that have matched the query in the results

  • « SolrQuery::setGroupMain
  • SolrQuery::setGroupOffset »
  • PHP Manual
  • SolrQuery
  • If true, Solr includes the number of groups that have matched the query in the results

SolrQuery::setGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results

Descripción

public SolrQuery::setGroupNGroups ( bool $value ) : SolrQuery

If true, Solr includes the number of groups that have matched the query in the results.

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Sets the group.offset parameter

  • « SolrQuery::setGroupNGroups
  • SolrQuery::setGroupTruncate »
  • PHP Manual
  • SolrQuery
  • Sets the group.offset parameter

SolrQuery::setGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::setGroupOffset — Sets the group.offset parameter

Descripción

public SolrQuery::setGroupOffset ( int $value ) : SolrQuery

Sets the group.offset parameter.

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, facet counts are based on the most relevant document of each group matching the query

  • « SolrQuery::setGroupOffset
  • SolrQuery::setHighlight »
  • PHP Manual
  • SolrQuery
  • If true, facet counts are based on the most relevant document of each group matching the query

SolrQuery::setGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query

Descripción

public SolrQuery::setGroupTruncate ( bool $value ) : SolrQuery

If true, facet counts are based on the most relevant document of each group matching the query. The server default value is false. group.truncate parameter

Parámetros

value

Valores devueltos

Ver también

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Habilita o deshabilita la remarcación

  • « SolrQuery::setGroupTruncate
  • SolrQuery::setHighlightAlternateField »
  • PHP Manual
  • SolrQuery
  • Habilita o deshabilita la remarcación

SolrQuery::setHighlight

(PECL solr >= 0.9.2)

SolrQuery::setHighlight — Habilita o deshabilita la remarcación

Descripción

public SolrQuery::setHighlight ( bool $flag ) : SolrQuery

Establecerlo a true habilita los trozos remarcados para ser generados en la respuesta de consulta.

Establecerlo a false deshabilita la remarcación

Parámetros

flag

Habilita o deshabilita la remarcación

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el campo de copia de seguridad a usar

  • « SolrQuery::setHighlight
  • SolrQuery::setHighlightFormatter »
  • PHP Manual
  • SolrQuery
  • Especifica el campo de copia de seguridad a usar

SolrQuery::setHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::setHighlightAlternateField — Especifica el campo de copia de seguridad a usar

Descripción

public SolrQuery::setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery

Si un trozo no se puede generar debido a que no hay términos coincidentes, se puede especificar un campo para usarlo como copia de seguridad del sumario predeterminado

Parámetros

field

El nombre del campo de copia de seguridad

field_override

El nombre del campo que se va a sobrescribir.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica un formateador para la salida remarcada

  • « SolrQuery::setHighlightAlternateField
  • SolrQuery::setHighlightFragmenter »
  • PHP Manual
  • SolrQuery
  • Especifica un formateador para la salida remarcada

SolrQuery::setHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFormatter — Especifica un formateador para la salida remarcada

Descripción

public SolrQuery::setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery

Especifica un formateador para la salida remarcada.

Parámetros

formatter

Actualemte, el único valor legal es "simple"

field_override

El nombre del campo.


Establece el generador de trozos de código para texto remarcado

  • « SolrQuery::setHighlightFormatter
  • SolrQuery::setHighlightFragsize »
  • PHP Manual
  • SolrQuery
  • Establece el generador de trozos de código para texto remarcado

SolrQuery::setHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragmenter — Establece el generador de trozos de código para texto remarcado

Descripción

public SolrQuery::setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery

Especifica un generador de trozos de código para texto remarcado.

Parámetros

fragmenter

El fragmentador estándar es el hueco. Otra opción son las expresiones regulares, que intentan crear fragmentos que se parecen a ciertas expresiones regulares

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


El tamaño de los fragmentos a considerara para remarcación

  • « SolrQuery::setHighlightFragmenter
  • SolrQuery::setHighlightHighlightMultiTerm »
  • PHP Manual
  • SolrQuery
  • El tamaño de los fragmentos a considerara para remarcación

SolrQuery::setHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragsize — El tamaño de los fragmentos a considerara para remarcación

Descripción

public SolrQuery::setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery

Establece el tamaño, en caracteres, de los fragmentos a considerara para remarcación. "0" indica que debería usarse el campo completo (sin fragmentación).

Parámetros

size

El tamaño, en caracteres, de los fragmentos a considerara para remarcación

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Usa SpanScorer para remarcar términos de frases

  • « SolrQuery::setHighlightFragsize
  • SolrQuery::setHighlightMaxAlternateFieldLength »
  • PHP Manual
  • SolrQuery
  • Usa SpanScorer para remarcar términos de frases

SolrQuery::setHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::setHighlightHighlightMultiTerm — Usa SpanScorer para remarcar términos de frases

Descripción

public SolrQuery::setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery

Usa SpanScorer para remarcar términos de frases sólo cuando aparecen dentro de la frase de consulta del documento.

Parámetros

flag

Si usar o no SpanScorer para remarcar términos de frases sólo cuando aparecen dentro de la frase de consulta del documento.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el número máximo de caracteres del campo a devolver

  • « SolrQuery::setHighlightHighlightMultiTerm
  • SolrQuery::setHighlightMaxAnalyzedChars »
  • PHP Manual
  • SolrQuery
  • Establece el número máximo de caracteres del campo a devolver

SolrQuery::setHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAlternateFieldLength — Establece el número máximo de caracteres del campo a devolver

Descripción

public SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery

Si SolrQuery::setHighlightAlternateField() se le pasó el valor true, este parámetro especifica el número máximo de caracteres del campo a devolver

Cualquier valor menor o igual que 0 significa ilimitado.

Parámetros

fieldLength

La longitud del campo

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el número de caracteres de un documento para buscar trozos apropiados

  • « SolrQuery::setHighlightMaxAlternateFieldLength
  • SolrQuery::setHighlightMergeContiguous »
  • PHP Manual
  • SolrQuery
  • Especifica el número de caracteres de un documento para buscar trozos apropiados

SolrQuery::setHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAnalyzedChars — Especifica el número de caracteres de un documento para buscar trozos apropiados

Descripción

public SolrQuery::setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery

Especifica el número de caracteres de un documento para buscar trozos apropiados

Parámetros

value

El número de caracteres de un documento para buscar trozos apropiados

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Si colapsar o no fragmentos contiguos en un único fragmento

  • « SolrQuery::setHighlightMaxAnalyzedChars
  • SolrQuery::setHighlightRegexMaxAnalyzedChars »
  • PHP Manual
  • SolrQuery
  • Si colapsar o no fragmentos contiguos en un único fragmento

SolrQuery::setHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMergeContiguous — Si colapsar o no fragmentos contiguos en un único fragmento

Descripción

public SolrQuery::setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery

Si colapsar o no fragmentos contiguos en un único fragmento.

Parámetros

value

Si colapsar o no fragmentos contiguos en un único fragmento

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el número máximo de caracteres a analizar

  • « SolrQuery::setHighlightMergeContiguous
  • SolrQuery::setHighlightRegexPattern »
  • PHP Manual
  • SolrQuery
  • Especifica el número máximo de caracteres a analizar

SolrQuery::setHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexMaxAnalyzedChars — Especifica el número máximo de caracteres a analizar

Descripción

public SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery

Especifica el número máximo de caracteres a analizar de un campo cuando se usa el fragmentador de expresiones regulares

Parámetros

maxAnalyzedChars

El número máximo de caracteres a analizar de un campo cuando se usa el fragmentador de expresiones regulares

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica la expresión regular para la fragmentación

  • « SolrQuery::setHighlightRegexMaxAnalyzedChars
  • SolrQuery::setHighlightRegexSlop »
  • PHP Manual
  • SolrQuery
  • Especifica la expresión regular para la fragmentación

SolrQuery::setHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexPattern — Especifica la expresión regular para la fragmentación

Descripción

public SolrQuery::setHighlightRegexPattern ( string $value ) : SolrQuery

Especifica la expresión regular para la fragmentación. Esto podría usarse para extraer sentencias

Parámetros

value

La expresión regular para la fragmentación. Esto podría usarse para extraer sentencias

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal

  • « SolrQuery::setHighlightRegexPattern
  • SolrQuery::setHighlightRequireFieldMatch »
  • PHP Manual
  • SolrQuery
  • Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal

SolrQuery::setHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexSlop — Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal

Descripción

public SolrQuery::setHighlightRegexSlop ( float $factor ) : SolrQuery

El factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal (especificado por SolrQuery::setHighlightFragsize) para acomodar la expresión regular

Parámetros

factor

El factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal

Valores devueltos

Devuelve el objeto SolrQuery actual si se usó el valor de retorno.


Requerir la coincicencia de campos durante el remarcado

  • « SolrQuery::setHighlightRegexSlop
  • SolrQuery::setHighlightSimplePost »
  • PHP Manual
  • SolrQuery
  • Requerir la coincicencia de campos durante el remarcado

SolrQuery::setHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRequireFieldMatch — Requerir la coincicencia de campos durante el remarcado

Descripción

public SolrQuery::setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery

Si es true, un campo sólo será remarcado si la consulta coincide con este campo en particular.

Esto sólo funciona si SolrQuery::setHighlightUsePhraseHighlighter() se estableció a true

Parámetros

flag

true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el texto que aparece antes de un término remarcado

  • « SolrQuery::setHighlightRequireFieldMatch
  • SolrQuery::setHighlightSimplePre »
  • PHP Manual
  • SolrQuery
  • Establece el texto que aparece antes de un término remarcado

SolrQuery::setHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePost — Establece el texto que aparece antes de un término remarcado

Descripción

public SolrQuery::setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery

Establece el texto que aparece después de un término remarcado

Parámetros

simplePost

Establece el texto que aparece después de un término remarcado

The default is </em>

field_override

El nombre del campo.


Establece el texto que aparece antes de un término remarcado

  • « SolrQuery::setHighlightSimplePost
  • SolrQuery::setHighlightSnippets »
  • PHP Manual
  • SolrQuery
  • Establece el texto que aparece antes de un término remarcado

SolrQuery::setHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePre — Establece el texto que aparece antes de un término remarcado

Descripción

public SolrQuery::setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery

Establece el texto que aparece antes de un término remarcado.

The default is <em>

Parámetros

simplePre

El texto que aparece antes de un término remarcado

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el número máximo de trozos remarcados para generar por campo

  • « SolrQuery::setHighlightSimplePre
  • SolrQuery::setHighlightUsePhraseHighlighter »
  • PHP Manual
  • SolrQuery
  • Establece el número máximo de trozos remarcados para generar por campo

SolrQuery::setHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSnippets — Establece el número máximo de trozos remarcados para generar por campo

Descripción

public SolrQuery::setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery

Establece el número máximo de trozos remarcados para generar por campo

Parámetros

value

El número máximo de trozos remarcados para generar por campo

field_override

El nombre del campo.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta

  • « SolrQuery::setHighlightSnippets
  • SolrQuery::setMlt »
  • PHP Manual
  • SolrQuery
  • Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta

SolrQuery::setHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightUsePhraseHighlighter — Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta

Descripción

public SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery

Establece si usar o no SpanScorer para remarcar o no términos de frases sólo cuando aparecen en la frase de consulta del documento

Parámetros

value

Si usar o no SpanScorer para remarcar o no términos de frases sólo cuando aparecen en la frase de consulta del documento

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Habilita o deshabilita moreLikeThis

  • « SolrQuery::setHighlightUsePhraseHighlighter
  • SolrQuery::setMltBoost »
  • PHP Manual
  • SolrQuery
  • Habilita o deshabilita moreLikeThis

SolrQuery::setMlt

(PECL solr >= 0.9.2)

SolrQuery::setMlt — Habilita o deshabilita moreLikeThis

Descripción

public SolrQuery::setMlt ( bool $flag ) : SolrQuery

Habilita o deshabilita moreLikeThis

Parámetros

flag

true lo habilita y false lo desactiva.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establecer si la consulta será impulsada (boost) por la relevancia del término de interés

  • « SolrQuery::setMlt
  • SolrQuery::setMltCount »
  • PHP Manual
  • SolrQuery
  • Establecer si la consulta será impulsada (boost) por la relevancia del término de interés

SolrQuery::setMltBoost

(PECL solr >= 0.9.2)

SolrQuery::setMltBoost — Establecer si la consulta será impulsada (boost) por la relevancia del término de interés

Descripción

public SolrQuery::setMltBoost ( bool $flag ) : SolrQuery

Establecer si la consulta será impulsada (boost) por la relevancia del término de interés

Parámetros

value

Establece a true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el número de documentos similares a devolver en cada resultado

  • « SolrQuery::setMltBoost
  • SolrQuery::setMltMaxNumQueryTerms »
  • PHP Manual
  • SolrQuery
  • Establece el número de documentos similares a devolver en cada resultado

SolrQuery::setMltCount

(PECL solr >= 0.9.2)

SolrQuery::setMltCount — Establece el número de documentos similares a devolver en cada resultado

Descripción

public SolrQuery::setMltCount ( int $count ) : SolrQuery

Establece el número de documentos similares a devolver en cada resultado

Parámetros

count

El número de documentos similares a devolver en cada resultado

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el número máximo de términos de consulta incluidos

  • « SolrQuery::setMltCount
  • SolrQuery::setMltMaxNumTokens »
  • PHP Manual
  • SolrQuery
  • Establece el número máximo de términos de consulta incluidos

SolrQuery::setMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumQueryTerms — Establece el número máximo de términos de consulta incluidos

Descripción

public SolrQuery::setMltMaxNumQueryTerms ( int $value ) : SolrQuery

Establece el número máximo de términos de consulta que serán incluidos en cualquier consulta generada.

Parámetros

value

El número máximo de términos de consulta que serán incluidos en cualquier consulta generada

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el número máximo de tokens a analizar

  • « SolrQuery::setMltMaxNumQueryTerms
  • SolrQuery::setMltMaxWordLength »
  • PHP Manual
  • SolrQuery
  • Especifica el número máximo de tokens a analizar

SolrQuery::setMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumTokens — Especifica el número máximo de tokens a analizar

Descripción

public SolrQuery::setMltMaxNumTokens ( int $value ) : SolrQuery

Especifica el número máximo de tokens a analizar en cada campo de documento de ejemplo que no esté almacenado con soporte TermVector.

Parámetros

value

El número máximo de tokens a analizar

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la longitud de palabra máxima

  • « SolrQuery::setMltMaxNumTokens
  • SolrQuery::setMltMinDocFrequency »
  • PHP Manual
  • SolrQuery
  • Establece la longitud de palabra máxima

SolrQuery::setMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxWordLength — Establece la longitud de palabra máxima

Descripción

public SolrQuery::setMltMaxWordLength ( int $maxWordLength ) : SolrQuery

Establece la longitud de palabra máxima sobre la que las palabras serán ignoradas.

Parámetros

maxWordLength

La longitud de palabra máxima sobre la que las palabras serán ignoradas

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la frecuencia de mltMinDoc

  • « SolrQuery::setMltMaxWordLength
  • SolrQuery::setMltMinTermFrequency »
  • PHP Manual
  • SolrQuery
  • Establece la frecuencia de mltMinDoc

SolrQuery::setMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinDocFrequency — Establece la frecuencia de mltMinDoc

Descripción

public SolrQuery::setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery

La frecuencia en la que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas.

Parámetros

minDocFrequency

Establece la frecuencia en la que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente

  • « SolrQuery::setMltMinDocFrequency
  • SolrQuery::setMltMinWordLength »
  • PHP Manual
  • SolrQuery
  • Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente

SolrQuery::setMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinTermFrequency — Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente

Descripción

public SolrQuery::setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery

Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente

Parámetros

minTermFrequency

La frecuencia bajo la cual los términos serán ignorados en los documentos fuente

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la longitud de palabra mínima

  • « SolrQuery::setMltMinTermFrequency
  • SolrQuery::setOmitHeader »
  • PHP Manual
  • SolrQuery
  • Establece la longitud de palabra mínima

SolrQuery::setMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMinWordLength — Establece la longitud de palabra mínima

Descripción

public SolrQuery::setMltMinWordLength ( int $minWordLength ) : SolrQuery

Establece la longitud de palabra mínima bajo la cual las palabras serán ignoradas.

Parámetros

minWordLength

La longitud de palabra mínima bajo la cual las palabras serán ignoradas.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Excluye la cabecera de los resultados devueltos

  • « SolrQuery::setMltMinWordLength
  • SolrQuery::setQuery »
  • PHP Manual
  • SolrQuery
  • Excluye la cabecera de los resultados devueltos

SolrQuery::setOmitHeader

(PECL solr >= 0.9.2)

SolrQuery::setOmitHeader — Excluye la cabecera de los resultados devueltos

Descripción

public SolrQuery::setOmitHeader ( bool $flag ) : SolrQuery

Excluye la cabecera de los resultados devueltos.

Parámetros

flag

true excluye la cabecera del resultado

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la consulta de búsqueda

  • « SolrQuery::setOmitHeader
  • SolrQuery::setRows »
  • PHP Manual
  • SolrQuery
  • Establece la consulta de búsqueda

SolrQuery::setQuery

(PECL solr >= 0.9.2)

SolrQuery::setQuery — Establece la consulta de búsqueda

Descripción

public SolrQuery::setQuery ( string $query ) : SolrQuery

Establece la consulta de búsqueda.

Parámetros

query

La consulta de búsqueda

Valores devueltos

Devuelve el objeto SolrQuery actual


Especifica el número máximo de filas a devolver en el resultado

  • « SolrQuery::setQuery
  • SolrQuery::setShowDebugInfo »
  • PHP Manual
  • SolrQuery
  • Especifica el número máximo de filas a devolver en el resultado

SolrQuery::setRows

(PECL solr >= 0.9.2)

SolrQuery::setRows — Especifica el número máximo de filas a devolver en el resultado

Descripción

public SolrQuery::setRows ( int $rows ) : SolrQuery

Especifica el número máximo de filas a devolver en el resultado

Parámetros

rows

El número máximo de filas a devolver

Valores devueltos

Devuelve el objeto SolrQuery actual.


Bandera para mostrar información de depuración

  • « SolrQuery::setRows
  • SolrQuery::setStart »
  • PHP Manual
  • SolrQuery
  • Bandera para mostrar información de depuración

SolrQuery::setShowDebugInfo

(PECL solr >= 0.9.2)

SolrQuery::setShowDebugInfo — Bandera para mostrar información de depuración

Descripción

public SolrQuery::setShowDebugInfo ( bool $flag ) : SolrQuery

Si mostrar o no información de depuración

Parámetros

flag

Si mostrar o no información de depuración. true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el número de filas que se van a saltar

  • « SolrQuery::setShowDebugInfo
  • SolrQuery::setStats »
  • PHP Manual
  • SolrQuery
  • Especifica el número de filas que se van a saltar

SolrQuery::setStart

(PECL solr >= 0.9.2)

SolrQuery::setStart — Especifica el número de filas que se van a saltar

Descripción

public SolrQuery::setStart ( int $start ) : SolrQuery

Especifica el número de filas que se van a saltar. Útil en paginación de resultados.

Parámetros

start

El número de filas a saltar.

Valores devueltos

Devuelve el objeto SolrQuery actual.


Habilita o deshablita el componente de estadísticas

  • « SolrQuery::setStart
  • SolrQuery::setTerms »
  • PHP Manual
  • SolrQuery
  • Habilita o deshablita el componente de estadísticas

SolrQuery::setStats

(PECL solr >= 0.9.2)

SolrQuery::setStats — Habilita o deshablita el componente de estadísticas

Descripción

public SolrQuery::setStats ( bool $flag ) : SolrQuery

Habilita o deshablita el componente de estadísticas.

Parámetros

flag

true habilita el componente de estadísticas y false lo deshabilita.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Habilita o deshablita TermsComponent

  • « SolrQuery::setStats
  • SolrQuery::setTermsField »
  • PHP Manual
  • SolrQuery
  • Habilita o deshablita TermsComponent

SolrQuery::setTerms

(PECL solr >= 0.9.2)

SolrQuery::setTerms — Habilita o deshablita TermsComponent

Descripción

public SolrQuery::setTerms ( bool $flag ) : SolrQuery

Habilita o deshablita TermsComponent

Parámetros

flag

true lo habilita. false lo desactiva

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el nombre del campo del que obtener los términos

  • « SolrQuery::setTerms
  • SolrQuery::setTermsIncludeLowerBound »
  • PHP Manual
  • SolrQuery
  • Establece el nombre del campo del que obtener los términos

SolrQuery::setTermsField

(PECL solr >= 0.9.2)

SolrQuery::setTermsField — Establece el nombre del campo del que obtener los términos

Descripción

public SolrQuery::setTermsField ( string $fieldname ) : SolrQuery

Establece el nombre del campo del que obtener los términos

Parámetros

fieldname

El nombre del campo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Incluir el término de límite inferior en el conjunto de resultados

  • « SolrQuery::setTermsField
  • SolrQuery::setTermsIncludeUpperBound »
  • PHP Manual
  • SolrQuery
  • Incluir el término de límite inferior en el conjunto de resultados

SolrQuery::setTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeLowerBound — Incluir el término de límite inferior en el conjunto de resultados

Descripción

public SolrQuery::setTermsIncludeLowerBound ( bool $flag ) : SolrQuery

Incluir el término de límite inferior en el conjunto de resultados.

Parámetros

flag

Incluir el término de límite inferior en el conjunto de resultados

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Incluir el término de límite superior en el conjunto de resultados

  • « SolrQuery::setTermsIncludeLowerBound
  • SolrQuery::setTermsLimit »
  • PHP Manual
  • SolrQuery
  • Incluir el término de límite superior en el conjunto de resultados

SolrQuery::setTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeUpperBound — Incluir el término de límite superior en el conjunto de resultados

Descripción

public SolrQuery::setTermsIncludeUpperBound ( bool $flag ) : SolrQuery

Incluir el término de límite superior en el conjunto de resultados.

Parámetros

flag

true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el número máximo de términos a devolver

  • « SolrQuery::setTermsIncludeUpperBound
  • SolrQuery::setTermsLowerBound »
  • PHP Manual
  • SolrQuery
  • Establece el número máximo de términos a devolver

SolrQuery::setTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::setTermsLimit — Establece el número máximo de términos a devolver

Descripción

public SolrQuery::setTermsLimit ( int $limit ) : SolrQuery

Establece el número máximo de términos a devolver

Parámetros

limit

El número máximo de términos a devolver. Si el límite es negativo se devolverán todos los términos.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica el término de donde empezar

  • « SolrQuery::setTermsLimit
  • SolrQuery::setTermsMaxCount »
  • PHP Manual
  • SolrQuery
  • Especifica el término de donde empezar

SolrQuery::setTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsLowerBound — Especifica el término de donde empezar

Descripción

public SolrQuery::setTermsLowerBound ( string $lowerBound ) : SolrQuery

Especifica el término de donde empezar

Parámetros

lowerBound

El término límite inferior

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la frecuencia máxima de documentos

  • « SolrQuery::setTermsLowerBound
  • SolrQuery::setTermsMinCount »
  • PHP Manual
  • SolrQuery
  • Establece la frecuencia máxima de documentos

SolrQuery::setTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMaxCount — Establece la frecuencia máxima de documentos

Descripción

public SolrQuery::setTermsMaxCount ( int $frequency ) : SolrQuery

Establece la frecuencia máxima de documentos.

Parámetros

frequency

La frecuencia máxima de documentos.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece la frecuencia mínima de documentos

  • « SolrQuery::setTermsMaxCount
  • SolrQuery::setTermsPrefix »
  • PHP Manual
  • SolrQuery
  • Establece la frecuencia mínima de documentos

SolrQuery::setTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMinCount — Establece la frecuencia mínima de documentos

Descripción

public SolrQuery::setTermsMinCount ( int $frequency ) : SolrQuery

Establece la frecuencia mínima de documentos a devolver para ser incluidos

Parámetros

frequency

La frecuencia mínima

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Restringe las coincidencias de términos que comienzan con el prefijo

  • « SolrQuery::setTermsMinCount
  • SolrQuery::setTermsReturnRaw »
  • PHP Manual
  • SolrQuery
  • Restringe las coincidencias de términos que comienzan con el prefijo

SolrQuery::setTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::setTermsPrefix — Restringe las coincidencias de términos que comienzan con el prefijo

Descripción

public SolrQuery::setTermsPrefix ( string $prefix ) : SolrQuery

Restringe las coincidencias de términos que comienzan con el prefijo

Parámetros

prefix

Restringe las coincidencias de términos que comienzan con el prefijo

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Devuelve los caracteres en bruto del término indexado

  • « SolrQuery::setTermsPrefix
  • SolrQuery::setTermsSort »
  • PHP Manual
  • SolrQuery
  • Devuelve los caracteres en bruto del término indexado

SolrQuery::setTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::setTermsReturnRaw — Devuelve los caracteres en bruto del término indexado

Descripción

public SolrQuery::setTermsReturnRaw ( bool $flag ) : SolrQuery

Si es true, devuelve los caracteres en bruto del término indexado, sin tener en cuenta si es legible por humanos.

Parámetros

value

true o false

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Especifica cómo ordenar los términos devueltos

  • « SolrQuery::setTermsReturnRaw
  • SolrQuery::setTermsUpperBound »
  • PHP Manual
  • SolrQuery
  • Especifica cómo ordenar los términos devueltos

SolrQuery::setTermsSort

(PECL solr >= 0.9.2)

SolrQuery::setTermsSort — Especifica cómo ordenar los términos devueltos

Descripción

public SolrQuery::setTermsSort ( int $sortType ) : SolrQuery

Si se usa SolrQuery::TERMS_SORT_COUNT, ordena los términos según la frecuencia del término (la mayor primero). Si se usa SolrQuery::TERMS_SORT_INDEX, devuelve los términos ordenados por índice

Parámetros

sortType

SolrQuery::TERMS_SORT_INDEX o SolrQuery::TERMS_SORT_COUNT

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


Establece el término en el que parar

  • « SolrQuery::setTermsSort
  • SolrQuery::setTimeAllowed »
  • PHP Manual
  • SolrQuery
  • Establece el término en el que parar

SolrQuery::setTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsUpperBound — Establece el término en el que parar

Descripción

public SolrQuery::setTermsUpperBound ( string $upperBound ) : SolrQuery

Establece el término en el que parar

Parámetros

upperBound

El término en el que parar

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


El tiempo permitido para que la búsqueda finalice

  • « SolrQuery::setTermsUpperBound
  • SolrDisMaxQuery »
  • PHP Manual
  • SolrQuery
  • El tiempo permitido para que la búsqueda finalice

SolrQuery::setTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::setTimeAllowed — El tiempo permitido para que la búsqueda finalice

Descripción

public SolrQuery::setTimeAllowed ( int $timeAllowed ) : SolrQuery

El tiempo permitido para que la búsqueda finalice. Este valor sólo se aplica a la búsqueda y no a las solicitudes en general. Se mide en milisegundos. Los valores menores o iguales a cero implican la no restricción de tiempo. Se pueden devolver resultados parciales, si los hubiera.

Parámetros

timeAllowed

El tiempo permitido para que la búsqueda finalice.

Valores devueltos

Devuelve el objeto SolrQuery actual, si se usó el valor de retorno.


La clase SolrDisMaxQuery

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

SolrDisMaxQuery extends SolrQuery implements Serializable {
/* Propiedades heredadas */
const integer SolrQuery::ORDER_ASC = 0 ;
const integer SolrQuery::ORDER_DESC = 1 ;
const integer SolrQuery::FACET_SORT_INDEX = 0 ;
const integer SolrQuery::FACET_SORT_COUNT = 1 ;
const integer SolrQuery::TERMS_SORT_INDEX = 0 ;
const integer SolrQuery::TERMS_SORT_COUNT = 1 ;
/* Métodos */
public addBigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addBoostQuery ( string $field , string $value , string $boost = ? ) : SolrDisMaxQuery
public addPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addQueryField ( string $field , string $boost = ? ) : SolrDisMaxQuery
public addTrigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addUserField ( string $field ) : SolrDisMaxQuery
public __construct ( string $q = ? )
public removeBigramPhraseField ( string $field ) : SolrDisMaxQuery
public removeBoostQuery ( string $field ) : SolrDisMaxQuery
public removePhraseField ( string $field ) : SolrDisMaxQuery
public removeQueryField ( string $field ) : SolrDisMaxQuery
public removeTrigramPhraseField ( string $field ) : SolrDisMaxQuery
public removeUserField ( string $field ) : SolrDisMaxQuery
public setBigramPhraseFields ( string $fields ) : SolrDisMaxQuery
public setBigramPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setBoostFunction ( string $function ) : SolrDisMaxQuery
public setBoostQuery ( string $q ) : SolrDisMaxQuery
public setMinimumMatch ( string $value ) : SolrDisMaxQuery
public setPhraseFields ( string $fields ) : SolrDisMaxQuery
public setPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setQueryAlt ( string $q ) : SolrDisMaxQuery
public setQueryPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setTieBreaker ( string $tieBreaker ) : SolrDisMaxQuery
public setTrigramPhraseFields ( string $fields ) : SolrDisMaxQuery
public setTrigramPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setUserFields ( string $fields ) : SolrDisMaxQuery
public useDisMaxQueryParser ( ) : SolrDisMaxQuery
public useEDisMaxQueryParser ( ) : SolrDisMaxQuery
/* Métodos heredados */
public SolrQuery::addExpandFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::addExpandSortField ( string $field , string $order = ? ) : SolrQuery
public SolrQuery::addFacetDateField ( string $dateField ) : SolrQuery
public SolrQuery::addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::addFacetField ( string $field ) : SolrQuery
public SolrQuery::addFacetQuery ( string $facetQuery ) : SolrQuery
public SolrQuery::addField ( string $field ) : SolrQuery
public SolrQuery::addFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::addGroupField ( string $value ) : SolrQuery
public SolrQuery::addGroupFunction ( string $value ) : SolrQuery
public SolrQuery::addGroupQuery ( string $value ) : SolrQuery
public SolrQuery::addGroupSortField ( string $field , int $order = ? ) : SolrQuery
public SolrQuery::addHighlightField ( string $field ) : SolrQuery
public SolrQuery::addMltField ( string $field ) : SolrQuery
public SolrQuery::addMltQueryField ( string $field , float $boost ) : SolrQuery
public SolrQuery::addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery
public SolrQuery::addStatsFacet ( string $field ) : SolrQuery
public SolrQuery::addStatsField ( string $field ) : SolrQuery
public SolrQuery::collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery
public SolrQuery::__construct ( string $q = ? )
public SolrQuery::__destruct ( ) : void
public SolrQuery::getExpand ( ) : bool
public SolrQuery::getExpandFilterQueries ( ) : array
public SolrQuery::getExpandQuery ( ) : array
public SolrQuery::getExpandRows ( ) : int
public SolrQuery::getExpandSortFields ( ) : array
public SolrQuery::getFacet ( ) : bool
public SolrQuery::getFacetDateEnd ( string $field_override = ? ) : string
public SolrQuery::getFacetDateFields ( ) : array
public SolrQuery::getFacetDateGap ( string $field_override = ? ) : string
public SolrQuery::getFacetDateHardEnd ( string $field_override = ? ) : string
public SolrQuery::getFacetDateOther ( string $field_override = ? ) : array
public SolrQuery::getFacetDateStart ( string $field_override = ? ) : string
public SolrQuery::getFacetFields ( ) : array
public SolrQuery::getFacetLimit ( string $field_override = ? ) : int
public SolrQuery::getFacetMethod ( string $field_override = ? ) : string
public SolrQuery::getFacetMinCount ( string $field_override = ? ) : int
public SolrQuery::getFacetMissing ( string $field_override = ? ) : bool
public SolrQuery::getFacetOffset ( string $field_override = ? ) : int
public SolrQuery::getFacetPrefix ( string $field_override = ? ) : string
public SolrQuery::getFacetQueries ( ) : array
public SolrQuery::getFacetSort ( string $field_override = ? ) : int
public SolrQuery::getFields ( ) : array
public SolrQuery::getFilterQueries ( ) : array
public SolrQuery::getGroup ( ) : bool
public SolrQuery::getGroupCachePercent ( ) : int
public SolrQuery::getGroupFacet ( ) : bool
public SolrQuery::getGroupFields ( ) : array
public SolrQuery::getGroupFormat ( ) : string
public SolrQuery::getGroupFunctions ( ) : array
public SolrQuery::getGroupLimit ( ) : int
public SolrQuery::getGroupMain ( ) : bool
public SolrQuery::getGroupNGroups ( ) : bool
public SolrQuery::getGroupOffset ( ) : int
public SolrQuery::getGroupQueries ( ) : array
public SolrQuery::getGroupSortFields ( ) : array
public SolrQuery::getGroupTruncate ( ) : bool
public SolrQuery::getHighlight ( ) : bool
public SolrQuery::getHighlightAlternateField ( string $field_override = ? ) : string
public SolrQuery::getHighlightFields ( ) : array
public SolrQuery::getHighlightFormatter ( string $field_override = ? ) : string
public SolrQuery::getHighlightFragmenter ( string $field_override = ? ) : string
public SolrQuery::getHighlightFragsize ( string $field_override = ? ) : int
public SolrQuery::getHighlightHighlightMultiTerm ( ) : bool
public SolrQuery::getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int
public SolrQuery::getHighlightMaxAnalyzedChars ( ) : int
public SolrQuery::getHighlightMergeContiguous ( string $field_override = ? ) : bool
public SolrQuery::getHighlightRegexMaxAnalyzedChars ( ) : int
public SolrQuery::getHighlightRegexPattern ( ) : string
public SolrQuery::getHighlightRegexSlop ( ) : float
public SolrQuery::getHighlightRequireFieldMatch ( ) : bool
public SolrQuery::getHighlightSimplePost ( string $field_override = ? ) : string
public SolrQuery::getHighlightSimplePre ( string $field_override = ? ) : string
public SolrQuery::getHighlightSnippets ( string $field_override = ? ) : int
public SolrQuery::getHighlightUsePhraseHighlighter ( ) : bool
public SolrQuery::getMlt ( ) : bool
public SolrQuery::getMltBoost ( ) : bool
public SolrQuery::getMltCount ( ) : int
public SolrQuery::getMltFields ( ) : array
public SolrQuery::getMltMaxNumQueryTerms ( ) : int
public SolrQuery::getMltMaxNumTokens ( ) : int
public SolrQuery::getMltMaxWordLength ( ) : int
public SolrQuery::getMltMinDocFrequency ( ) : int
public SolrQuery::getMltMinTermFrequency ( ) : int
public SolrQuery::getMltMinWordLength ( ) : int
public SolrQuery::getMltQueryFields ( ) : array
public SolrQuery::getQuery ( ) : string
public SolrQuery::getRows ( ) : int
public SolrQuery::getSortFields ( ) : array
public SolrQuery::getStart ( ) : int
public SolrQuery::getStats ( ) : bool
public SolrQuery::getStatsFacets ( ) : array
public SolrQuery::getStatsFields ( ) : array
public SolrQuery::getTerms ( ) : bool
public SolrQuery::getTermsField ( ) : string
public SolrQuery::getTermsIncludeLowerBound ( ) : bool
public SolrQuery::getTermsIncludeUpperBound ( ) : bool
public SolrQuery::getTermsLimit ( ) : int
public SolrQuery::getTermsLowerBound ( ) : string
public SolrQuery::getTermsMaxCount ( ) : int
public SolrQuery::getTermsMinCount ( ) : int
public SolrQuery::getTermsPrefix ( ) : string
public SolrQuery::getTermsReturnRaw ( ) : bool
public SolrQuery::getTermsSort ( ) : int
public SolrQuery::getTermsUpperBound ( ) : string
public SolrQuery::getTimeAllowed ( ) : int
public SolrQuery::removeExpandFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::removeExpandSortField ( string $field ) : SolrQuery
public SolrQuery::removeFacetDateField ( string $field ) : SolrQuery
public SolrQuery::removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::removeFacetField ( string $field ) : SolrQuery
public SolrQuery::removeFacetQuery ( string $value ) : SolrQuery
public SolrQuery::removeField ( string $field ) : SolrQuery
public SolrQuery::removeFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::removeHighlightField ( string $field ) : SolrQuery
public SolrQuery::removeMltField ( string $field ) : SolrQuery
public SolrQuery::removeMltQueryField ( string $queryField ) : SolrQuery
public SolrQuery::removeSortField ( string $field ) : SolrQuery
public SolrQuery::removeStatsFacet ( string $value ) : SolrQuery
public SolrQuery::removeStatsField ( string $field ) : SolrQuery
public SolrQuery::setEchoHandler ( bool $flag ) : SolrQuery
public SolrQuery::setEchoParams ( string $type ) : SolrQuery
public SolrQuery::setExpand ( bool $value ) : SolrQuery
public SolrQuery::setExpandQuery ( string $q ) : SolrQuery
public SolrQuery::setExpandRows ( int $value ) : SolrQuery
public SolrQuery::setExplainOther ( string $query ) : SolrQuery
public SolrQuery::setFacet ( bool $flag ) : SolrQuery
public SolrQuery::setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery
public SolrQuery::setGroup ( bool $value ) : SolrQuery
public SolrQuery::setGroupCachePercent ( int $percent ) : SolrQuery
public SolrQuery::setGroupFacet ( bool $value ) : SolrQuery
public SolrQuery::setGroupFormat ( string $value ) : SolrQuery
public SolrQuery::setGroupLimit ( int $value ) : SolrQuery
public SolrQuery::setGroupMain ( string $value ) : SolrQuery
public SolrQuery::setGroupNGroups ( bool $value ) : SolrQuery
public SolrQuery::setGroupOffset ( int $value ) : SolrQuery
public SolrQuery::setGroupTruncate ( bool $value ) : SolrQuery
public SolrQuery::setHighlight ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery
public SolrQuery::setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery
public SolrQuery::setHighlightRegexPattern ( string $value ) : SolrQuery
public SolrQuery::setHighlightRegexSlop ( float $factor ) : SolrQuery
public SolrQuery::setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery
public SolrQuery::setMlt ( bool $flag ) : SolrQuery
public SolrQuery::setMltBoost ( bool $flag ) : SolrQuery
public SolrQuery::setMltCount ( int $count ) : SolrQuery
public SolrQuery::setMltMaxNumQueryTerms ( int $value ) : SolrQuery
public SolrQuery::setMltMaxNumTokens ( int $value ) : SolrQuery
public SolrQuery::setMltMaxWordLength ( int $maxWordLength ) : SolrQuery
public SolrQuery::setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery
public SolrQuery::setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery
public SolrQuery::setMltMinWordLength ( int $minWordLength ) : SolrQuery
public SolrQuery::setOmitHeader ( bool $flag ) : SolrQuery
public SolrQuery::setQuery ( string $query ) : SolrQuery
public SolrQuery::setRows ( int $rows ) : SolrQuery
public SolrQuery::setShowDebugInfo ( bool $flag ) : SolrQuery
public SolrQuery::setStart ( int $start ) : SolrQuery
public SolrQuery::setStats ( bool $flag ) : SolrQuery
public SolrQuery::setTerms ( bool $flag ) : SolrQuery
public SolrQuery::setTermsField ( string $fieldname ) : SolrQuery
public SolrQuery::setTermsIncludeLowerBound ( bool $flag ) : SolrQuery
public SolrQuery::setTermsIncludeUpperBound ( bool $flag ) : SolrQuery
public SolrQuery::setTermsLimit ( int $limit ) : SolrQuery
public SolrQuery::setTermsLowerBound ( string $lowerBound ) : SolrQuery
public SolrQuery::setTermsMaxCount ( int $frequency ) : SolrQuery
public SolrQuery::setTermsMinCount ( int $frequency ) : SolrQuery
public SolrQuery::setTermsPrefix ( string $prefix ) : SolrQuery
public SolrQuery::setTermsReturnRaw ( bool $flag ) : SolrQuery
public SolrQuery::setTermsSort ( int $sortType ) : SolrQuery
public SolrQuery::setTermsUpperBound ( string $upperBound ) : SolrQuery
public SolrQuery::setTimeAllowed ( int $timeAllowed ) : SolrQuery
}

Constantes predefinidas

SolrDisMaxQuery::ORDER_ASC

Empleada para especificar que la ordenación debería ser ascendente (Duplicada para una migración sencilla)

SolrDisMaxQuery::ORDER_DESC

Empleada para especificar que la ordenación debería ser descendente (Duplicada para una migración sencilla)

SolrDisMaxQuery::FACET_SORT_INDEX

Empleada para especificar que la faceta debería ordenarse por índice (Duplicada para una migración sencilla)

SolrDisMaxQuery::FACET_SORT_COUNT

Empleada para especificar que la faceta debería ordenarse por cuenta (Duplicada para una migración sencilla)

SolrDisMaxQuery::TERMS_SORT_INDEX

Empleada en TermsComponent (Duplicada para una migración sencilla)

SolrDisMaxQuery::TERMS_SORT_COUNT

Empleada en TermsComponent (Duplicada para una migración sencilla)

Tabla de contenidos

  • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
  • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::__construct — Class Constructor
  • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)
  • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
  • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
  • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
  • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
  • SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
  • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
  • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
  • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
  • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax


Adds a Phrase Bigram Field (pf2 parameter)

  • « SolrDisMaxQuery
  • SolrDisMaxQuery::addBoostQuery »
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Phrase Bigram Field (pf2 parameter)

SolrDisMaxQuery::addBigramPhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)

Descripción

public SolrDisMaxQuery::addBigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Phrase Bigram Field (pf2 parameter) output format: field~slop^boost OR field^boost Slop is optional

Parámetros

field

boost

slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

Ver también

  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)


Adds a boost query field with value and optional boost (bq parameter)

  • « SolrDisMaxQuery::addBigramPhraseField
  • SolrDisMaxQuery::addPhraseField »
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a boost query field with value and optional boost (bq parameter)

SolrDisMaxQuery::addBoostQuery

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)

Descripción

public SolrDisMaxQuery::addBoostQuery ( string $field , string $value , string $boost = ? ) : SolrDisMaxQuery

Adds a Boost Query field with value [and boost] (bq parameter)

Parámetros

field

value

boost

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'clothing', 2)
    ->addBoostQuery('cat', 'electronics', 5.1)
;
echo $dismaxQuery.PHP_EOL;
?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&bq=cat:clothing^2 cat:electronics^5.1

Ver también

  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)


Adds a Phrase Field (pf parameter)

  • « SolrDisMaxQuery::addBoostQuery
  • SolrDisMaxQuery::addQueryField »
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Phrase Field (pf parameter)

SolrDisMaxQuery::addPhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)

Descripción

public SolrDisMaxQuery::addPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Phrase Field (pf parameter)

Parámetros

field

field name

boost

slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addPhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addPhraseField('cat', 3, 1)
    ->addPhraseField('third', 4, 2)
    ->addPhraseField('source', 55)
;
echo $dismaxQuery;
?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf=cat~1^3 third~2^4 source^55

Ver también

  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter


Add a query field with optional boost (qf parameter)

  • « SolrDisMaxQuery::addPhraseField
  • SolrDisMaxQuery::addTrigramPhraseField »
  • PHP Manual
  • SolrDisMaxQuery
  • Add a query field with optional boost (qf parameter)

SolrDisMaxQuery::addQueryField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)

Descripción

public SolrDisMaxQuery::addQueryField ( string $field , string $boost = ? ) : SolrDisMaxQuery

Add a query field with optional boost (qf parameter)

Parámetros

field

field name

boost

Boost value. Boosts documents with matching terms.

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addQueryField("location", 4)
    ->addQueryField("price")
    ->addQueryField("sku")
    ->addQueryField("title",3.4)
;
echo $dismaxQuery;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&qf=location^4 price sku title^3.4

Ver también

  • SolrDisMaxQuery::removeQueryField() - Removes a Query Field (qf parameter)


Adds a Trigram Phrase Field (pf3 parameter)

  • « SolrDisMaxQuery::addQueryField
  • SolrDisMaxQuery::addUserField »
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::addTrigramPhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)

Descripción

public SolrDisMaxQuery::addTrigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Trigram Phrase Field (pf3 parameter)

Parámetros

field

Field Name

boost

Field Boost

slop

Field Slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería:

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5

Ver también

  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Adds a field to User Fields Parameter (uf)

  • « SolrDisMaxQuery::addTrigramPhraseField
  • SolrDisMaxQuery::__construct »
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a field to User Fields Parameter (uf)

SolrDisMaxQuery::addUserField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)

Descripción

public SolrDisMaxQuery::addUserField ( string $field ) : SolrDisMaxQuery

Adds a field to The User Fields Parameter (uf)

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::addUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt');

echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&uf=cat text *_dt

Ver también

  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)


Class Constructor

  • « SolrDisMaxQuery::addUserField
  • SolrDisMaxQuery::removeBigramPhraseField »
  • PHP Manual
  • SolrDisMaxQuery
  • Class Constructor

SolrDisMaxQuery::__construct

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::__construct — Class Constructor

Descripción

public SolrDisMaxQuery::__construct ( string $q = ? )

Class constructor initializes the object and sets the q parameter if passed

Parámetros

q

Search Query (q parameter)

Valores devueltos

Errores/Excepciones

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

Ejemplos

Ejemplo #1 SolrDisMaxQuery::__construct() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
echo $dismaxQuery;

?>

El resultado del ejemplo sería:

q=lucene&defType=edismax

Ver también


Removes phrase bigram field (pf2 parameter)

  • « SolrDisMaxQuery::__construct
  • SolrDisMaxQuery::removeBoostQuery »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes phrase bigram field (pf2 parameter)

SolrDisMaxQuery::removeBigramPhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)

Descripción

public SolrDisMaxQuery::removeBigramPhraseField ( string $field ) : SolrDisMaxQuery

Removes a Bigram Phrase Field (pf2 parameter) that was previously added using SolrDisMaxQuery::addBigramPhraseField()

Parámetros

field

The Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removeBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

// remove cat from pf2
$dismaxQuery
    ->removeBigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5
q=lucene&defType=edismax&pf2=feature^4.5

Ver también

  • SolrDisMaxQuery::addBigramPhraseField() - Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)


Removes a boost query partial by field name (bq)

  • « SolrDisMaxQuery::removeBigramPhraseField
  • SolrDisMaxQuery::removePhraseField »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a boost query partial by field name (bq)

SolrDisMaxQuery::removeBoostQuery

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)

Descripción

public SolrDisMaxQuery::removeBoostQuery ( string $field ) : SolrDisMaxQuery

Removes a boost query partial from the existing query, only if SolrDisMaxQuery::addBoostQuery() was used.

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removeBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'electronics', 5.1)
    ->addBoostQuery('cat', 'hard drive')
;
echo $dismaxQuery.PHP_EOL;
// now remove a query part with field 'cat'
$dismaxQuery
->removeBoostQuery('cat');
echo $dismaxQuery . PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&bq=cat:electronics^5.1 cat:hard drive
q=lucene&defType=edismax&bq=cat:hard drive

Ver también

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)


Removes a Phrase Field (pf parameter)

  • « SolrDisMaxQuery::removeBoostQuery
  • SolrDisMaxQuery::removeQueryField »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Phrase Field (pf parameter)

SolrDisMaxQuery::removePhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)

Descripción

public SolrDisMaxQuery::removePhraseField ( string $field ) : SolrDisMaxQuery

Removes a Phrase Field (pf parameter) that was previously added using SolrDisMaxQuery::addPhraseField

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removePhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addPhraseField('first', 3, 1)
    ->addPhraseField('second', 4, 1)
    ->addPhraseField('cat', 55);
echo $dismaxQuery . PHP_EOL;
echo $dismaxQuery->removePhraseField('second');
?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf=first~1^3 second~1^4 cat^55
q=lucene&defType=edismax&pf=first~1^3 cat^55

Ver también

  • SolrDisMaxQuery::addPhraseField() - Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter


Removes a Query Field (qf parameter)

  • « SolrDisMaxQuery::removePhraseField
  • SolrDisMaxQuery::removeTrigramPhraseField »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Query Field (qf parameter)

SolrDisMaxQuery::removeQueryField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)

Descripción

public SolrDisMaxQuery::removeQueryField ( string $field ) : SolrDisMaxQuery

Removes a Query Field (qf parameter) from the field list added by SolrDisMaxQuery::addQueryField()

qf: When building DisjunctionMaxQueries from the user's query it specifies the fields to search in, and boosts for those fields.

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removeQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addQueryField('first', 3)
    ->addQueryField('second', 0.2)
    ->addQueryField('cat');
echo $dismaxQuery . PHP_EOL;
// remove field 'second'
echo $dismaxQuery->removeQueryField('second');
?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&qf=first^3 second^0.2 cat
q=lucene&defType=edismax&qf=first^3 cat

Ver también

  • SolrDisMaxQuery::addQueryField() - Add a query field with optional boost (qf parameter)


Removes a Trigram Phrase Field (pf3 parameter)

  • « SolrDisMaxQuery::removeQueryField
  • SolrDisMaxQuery::removeUserField »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::removeTrigramPhraseField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)

Descripción

public SolrDisMaxQuery::removeTrigramPhraseField ( string $field ) : SolrDisMaxQuery

Removes a Trigram Phrase Field (pf3 parameter)

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removeTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;
// reverse
$dismaxQuery
->removeTrigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería:

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5
q=lucene&defType=%s&pf3=feature^4.5

Ver también

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Removes a field from The User Fields Parameter (uf)

  • « SolrDisMaxQuery::removeTrigramPhraseField
  • SolrDisMaxQuery::setBigramPhraseFields »
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a field from The User Fields Parameter (uf)

SolrDisMaxQuery::removeUserField

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)

Descripción

public SolrDisMaxQuery::removeUserField ( string $field ) : SolrDisMaxQuery

Removes a field from The User Fields Parameter (uf)

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

field

Field Name

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::removeUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt')
;
echo $dismaxQuery.PHP_EOL;

// remove field named 'text'
$dismaxQuery
->removeUserField('text');
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=%s&uf=cat text *_dt
q=lucene&defType=%s&uf=cat *_dt

Ver también

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)


Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

  • « SolrDisMaxQuery::removeUserField
  • SolrDisMaxQuery::setBigramPhraseSlop »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::setBigramPhraseFields

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

Descripción

public SolrDisMaxQuery::setBigramPhraseFields ( string $fields ) : SolrDisMaxQuery

Sets Bigram Phrase Fields (pf2) and their boosts (and slops)

Parámetros

fields

Fields boosts (slops)

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setBigramPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setBigramPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

Ver también

  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::addBigramPhraseFields()
  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)


Sets Bigram Phrase Slop (ps2 parameter)

  • « SolrDisMaxQuery::setBigramPhraseFields
  • SolrDisMaxQuery::setBoostFunction »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Bigram Phrase Slop (ps2 parameter)

SolrDisMaxQuery::setBigramPhraseSlop

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)

Descripción

public SolrDisMaxQuery::setBigramPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets Bigram Phrase Slop (ps2 parameter). A default slop for Bigram phrase fields.

Parámetros

slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setBigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setBigramPhraseSlop(5);
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&ps2=5

Ver también


Sets a Boost Function (bf parameter)

  • « SolrDisMaxQuery::setBigramPhraseSlop
  • SolrDisMaxQuery::setBoostQuery »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets a Boost Function (bf parameter)

SolrDisMaxQuery::setBoostFunction

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)

Descripción

public SolrDisMaxQuery::setBoostFunction ( string $function ) : SolrDisMaxQuery

Sets Boost Function (bf parameter).

Functions (with optional boosts) that will be included in the user's query to influence the score. Any function supported natively by Solr can be used, along with a boost value. e.g.:

recip(rord(myfield),1,2,3)^1.5

Parámetros

function

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setBoostFunction() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$boostRecentDocsFunction = "recip(ms(NOW,mydatefield),3.16e-11,1,1)";
$dismaxQuery->setBoostFunction($boostRecentDocsFunction);

echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&bf=recip(ms(NOW,mydatefield),3.16e-11,1,1)

Ver también


Directly Sets Boost Query Parameter (bq)

  • « SolrDisMaxQuery::setBoostFunction
  • SolrDisMaxQuery::setMinimumMatch »
  • PHP Manual
  • SolrDisMaxQuery
  • Directly Sets Boost Query Parameter (bq)

SolrDisMaxQuery::setBoostQuery

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)

Descripción

public SolrDisMaxQuery::setBoostQuery ( string $q ) : SolrDisMaxQuery

Sets Boost Query Parameter (bq)

Parámetros

q

query

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setBoostQuery() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");

$dismaxQuery->setBoostQuery('cat:electronics manu:local^2');
echo $dismaxQuery.PHP_EOL;
?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&bq=cat:electronics manu:local^2

Ver también

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)


Set Minimum "Should" Match (mm)

  • « SolrDisMaxQuery::setBoostQuery
  • SolrDisMaxQuery::setPhraseFields »
  • PHP Manual
  • SolrDisMaxQuery
  • Set Minimum "Should" Match (mm)

SolrDisMaxQuery::setMinimumMatch

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)

Descripción

public SolrDisMaxQuery::setMinimumMatch ( string $value ) : SolrDisMaxQuery

Set Minimum "Should" Match parameter (mm). If the default query operator is AND then mm=100%, if the default query operator (q.op) is OR, then mm=0%.

Parámetros

value

Minimum match value/expression

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setMinimumMatch() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
// 75% of the query clauses must match
$dismaxQuery->setMinimumMatch("75%");
echo $dismaxQuery . PHP_EOL;

?>

El resultado del ejemplo sería:

q=lucene&defType=edismax&mm=75%


Sets Phrase Fields and their boosts (and slops) using pf2 parameter

  • « SolrDisMaxQuery::setMinimumMatch
  • SolrDisMaxQuery::setPhraseSlop »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::setPhraseFields

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter

Descripción

public SolrDisMaxQuery::setPhraseFields ( string $fields ) : SolrDisMaxQuery

Sets Phrase Fields (pf) and their boosts (and slops)

Parámetros

fields

Fields, boosts [, slops]

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&pf=cat~5.1^2 feature^4.5

Ver también

  • SolrDisMaxQuery::addPhraseFields()
  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)


Sets the default slop on phrase queries (ps parameter)

  • « SolrDisMaxQuery::setPhraseFields
  • SolrDisMaxQuery::setQueryAlt »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets the default slop on phrase queries (ps parameter)

SolrDisMaxQuery::setPhraseSlop

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)

Descripción

public SolrDisMaxQuery::setPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets the default amount of slop on phrase queries built with "pf", "pf2" and/or "pf3" fields (affects boosting). "ps" parameter

Parámetros

slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setPhraseSlop(4);
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería:

q=lucene&defType=edismax&ps=4

Ver también


Set Query Alternate (q.alt parameter)

  • « SolrDisMaxQuery::setPhraseSlop
  • SolrDisMaxQuery::setQueryPhraseSlop »
  • PHP Manual
  • SolrDisMaxQuery
  • Set Query Alternate (q.alt parameter)

SolrDisMaxQuery::setQueryAlt

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)

Descripción

public SolrDisMaxQuery::setQueryAlt ( string $q ) : SolrDisMaxQuery

Set Query Alternate (q.alt parameter)

When the main q parameter is not specified or is blank. The q.alt parameter is used

Parámetros

q

Query String

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setQueryAlt() example

<?php

$dismaxQuery = new DisMaxQuery();
$dismaxQuery->setQueryAlt('*:*');

?>

El resultado del ejemplo sería algo similar a:

defType=edismax&q.alt=*:*&q=


Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

  • « SolrDisMaxQuery::setQueryAlt
  • SolrDisMaxQuery::setTieBreaker »
  • PHP Manual
  • SolrDisMaxQuery
  • Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

SolrDisMaxQuery::setQueryPhraseSlop

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

Descripción

public SolrDisMaxQuery::setQueryPhraseSlop ( string $slop ) : SolrDisMaxQuery

The Query Phrase Slop is the amount of slop permitted on phrase queries explicitly included in the user's query string with the qf parameter.

slop refers to the number of positions one token needs to be moved in relation to another token in order to match a phrase specified in a query.

Parámetros

slop

Amount of slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setQueryPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setQueryPhraseSlop(3);
echo $dismaxQuery;
?>

El resultado del ejemplo sería algo similar a:

defType=edismax&qs=3


Sets Tie Breaker parameter (tie parameter)

  • « SolrDisMaxQuery::setQueryPhraseSlop
  • SolrDisMaxQuery::setTrigramPhraseFields »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Tie Breaker parameter (tie parameter)

SolrDisMaxQuery::setTieBreaker

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)

Descripción

public SolrDisMaxQuery::setTieBreaker ( string $tieBreaker ) : SolrDisMaxQuery

Sets Tie Breaker parameter (tie parameter)

Parámetros

tieBreaker

The tie parameter specifies a float value (which should be something much less than 1) to use as tiebreaker in DisMax queries.

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setTieBreaker() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setTieBreaker(0.1);

echo $dismaxQuery;

?>

El resultado del ejemplo sería:

defType=edismax&tie=0.1


Directly Sets Trigram Phrase Fields (pf3 parameter)

  • « SolrDisMaxQuery::setTieBreaker
  • SolrDisMaxQuery::setTrigramPhraseSlop »
  • PHP Manual
  • SolrDisMaxQuery
  • Directly Sets Trigram Phrase Fields (pf3 parameter)

SolrDisMaxQuery::setTrigramPhraseFields

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)

Descripción

public SolrDisMaxQuery::setTrigramPhraseFields ( string $fields ) : SolrDisMaxQuery

Directly Sets Trigram Phrase Fields (pf3 parameter)

Parámetros

fields

Trigram Phrase Fields

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setTrigramPhraseFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseFields('cat~5.1^2 feature^4.5');
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería:

q=lucene&defType=edismax&pf3=cat~5.1^2 feature^4.5

Ver también

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Sets Trigram Phrase Slop (ps3 parameter)

  • « SolrDisMaxQuery::setTrigramPhraseFields
  • SolrDisMaxQuery::setUserFields »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Trigram Phrase Slop (ps3 parameter)

SolrDisMaxQuery::setTrigramPhraseSlop

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)

Descripción

public SolrDisMaxQuery::setTrigramPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets Trigram Phrase Slop (ps3 parameter)

Parámetros

slop

Phrase slop

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setTrigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseSlop(2);
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&ps3=2

Ver también

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)


Sets User Fields parameter (uf)

  • « SolrDisMaxQuery::setTrigramPhraseSlop
  • SolrDisMaxQuery::useDisMaxQueryParser »
  • PHP Manual
  • SolrDisMaxQuery
  • Sets User Fields parameter (uf)

SolrDisMaxQuery::setUserFields

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)

Descripción

public SolrDisMaxQuery::setUserFields ( string $fields ) : SolrDisMaxQuery

Sets User Fields parameter (uf)

User Fields: Specifies which schema fields the end user shall be allowed to query.

Parámetros

fields

Fields names separated by space

This parameter supports wildcards.

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::setUserFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setUserFields('field1 field2 *_txt');
echo $dismaxQuery.PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

q=lucene&defType=edismax&uf=field1 field2 *_txt

Ver también

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)


Switch QueryParser to be DisMax Query Parser

  • « SolrDisMaxQuery::setUserFields
  • SolrDisMaxQuery::useEDisMaxQueryParser »
  • PHP Manual
  • SolrDisMaxQuery
  • Switch QueryParser to be DisMax Query Parser

SolrDisMaxQuery::useDisMaxQueryParser

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser

Descripción

public SolrDisMaxQuery::useDisMaxQueryParser ( ) : SolrDisMaxQuery

Switch QueryParser to be DisMax Query Parser

Parámetros

Esta función no tiene parámetros.

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::useDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useDisMaxQueryParser();
echo $dismaxQuery;
?>

El resultado del ejemplo sería algo similar a:

defType=dismax

Ver también

  • SolrDisMaxQuery::useDisMaxQueryParser()


Switch QueryParser to be EDisMax

  • « SolrDisMaxQuery::useDisMaxQueryParser
  • SolrCollapseFunction »
  • PHP Manual
  • SolrDisMaxQuery
  • Switch QueryParser to be EDisMax

SolrDisMaxQuery::useEDisMaxQueryParser

(No hay información de versión disponible, podría estar únicamente en Git)

SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax

Descripción

public SolrDisMaxQuery::useEDisMaxQueryParser ( ) : SolrDisMaxQuery

Switch QueryParser to be EDisMax. By default the query builder uses edismax, if it was switched using SolrDisMaxQuery::useDisMaxQueryParser(), it can be switched back using this method.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

SolrDisMaxQuery

Ejemplos

Ejemplo #1 SolrDisMaxQuery::useEDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useEDisMaxQueryParser();
echo $dismaxQuery;

?>

El resultado del ejemplo sería algo similar a:

defType=edismax

Ver también


La clase SolrCollapseFunction

(PECL solr >= 2.2.0)

Introducción

Sinopsis de la Clase

SolrCollapseFunction {
/* Constantes */
const string NULLPOLICY_IGNORE = ignore ;
const string NULLPOLICY_EXPAND = expand ;
const string NULLPOLICY_COLLAPSE = collapse ;
/* Métodos */
public __construct ( string $field = ? )
public getField ( ) : string
public getHint ( ) : string
public getMax ( ) : string
public getMin ( ) : string
public getNullPolicy ( ) : string
public getSize ( ) : int
public setField ( string $fieldName ) : SolrCollapseFunction
public setHint ( string $hint ) : SolrCollapseFunction
public setMax ( string $max ) : SolrCollapseFunction
public setMin ( string $min ) : SolrCollapseFunction
public setNullPolicy ( string $nullPolicy ) : SolrCollapseFunction
public setSize ( int $size ) : SolrCollapseFunction
public __toString ( ) : string
}

Constantes predefinidas

SolrCollapseFunction::NULLPOLICY_IGNORE

SolrCollapseFunction::NULLPOLICY_EXPAND

SolrCollapseFunction::NULLPOLICY_COLLAPSE

Tabla de contenidos

  • SolrCollapseFunction::__construct — Constructor
  • SolrCollapseFunction::getField — Returns the field that is being collapsed on
  • SolrCollapseFunction::getHint — Returns collapse hint
  • SolrCollapseFunction::getMax — Returns max parameter
  • SolrCollapseFunction::getMin — Returns min parameter
  • SolrCollapseFunction::getNullPolicy — Returns null policy
  • SolrCollapseFunction::getSize — Returns size parameter
  • SolrCollapseFunction::setField — Sets the field to collapse on
  • SolrCollapseFunction::setHint — Sets collapse hint
  • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query
  • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
  • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
  • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only
  • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function


Constructor

  • « SolrCollapseFunction
  • SolrCollapseFunction::getField »
  • PHP Manual
  • SolrCollapseFunction
  • Constructor

SolrCollapseFunction::__construct

(PECL solr >= 2.2.0)

SolrCollapseFunction::__construct — Constructor

Descripción

public SolrCollapseFunction::__construct ( string $field = ? )

Collapse Function constructor

Parámetros

field

The field name to collapse on.

In order to collapse a result. The field type must be a single valued String, Int or Float.

Ejemplos

Ejemplo #1 SolrCollapseFunction::__construct() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_other_field))');
$func->setSize(100);
$func->setNullPolicy(SolrCollapseFunction::NULLPOLICY_EXPAND);

$query->collapse($func);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

Ver también

  • SolrQuery::collapse() - Collapses the result set to a single document per group


Returns the field that is being collapsed on

  • « SolrCollapseFunction::__construct
  • SolrCollapseFunction::getHint »
  • PHP Manual
  • SolrCollapseFunction
  • Returns the field that is being collapsed on

SolrCollapseFunction::getField

(PECL solr >= 2.2.0)

SolrCollapseFunction::getField — Returns the field that is being collapsed on

Descripción

public SolrCollapseFunction::getField ( ) : string

Returns the field that is being collapsed on.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setField() - Sets the field to collapse on


Returns collapse hint

  • « SolrCollapseFunction::getField
  • SolrCollapseFunction::getMax »
  • PHP Manual
  • SolrCollapseFunction
  • Returns collapse hint

SolrCollapseFunction::getHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::getHint — Returns collapse hint

Descripción

public SolrCollapseFunction::getHint ( ) : string

Returns collapse hint

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setHint() - Sets collapse hint


Returns max parameter

  • « SolrCollapseFunction::getHint
  • SolrCollapseFunction::getMin »
  • PHP Manual
  • SolrCollapseFunction
  • Returns max parameter

SolrCollapseFunction::getMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMax — Returns max parameter

Descripción

public SolrCollapseFunction::getMax ( ) : string

Returns max parameter

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setMax() - Selects the group heads by the max value of a numeric field or function query


Returns min parameter

  • « SolrCollapseFunction::getMax
  • SolrCollapseFunction::getNullPolicy »
  • PHP Manual
  • SolrCollapseFunction
  • Returns min parameter

SolrCollapseFunction::getMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMin — Returns min parameter

Descripción

public SolrCollapseFunction::getMin ( ) : string

Returns min parameter

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setMin() - Sets the initial size of the collapse data structures when collapsing on a numeric field only


Returns null policy

  • « SolrCollapseFunction::getMin
  • SolrCollapseFunction::getSize »
  • PHP Manual
  • SolrCollapseFunction
  • Returns null policy

SolrCollapseFunction::getNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::getNullPolicy — Returns null policy

Descripción

public SolrCollapseFunction::getNullPolicy ( ) : string

Returns null policy used or null

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setNullPolicy() - Sets the NULL Policy


Returns size parameter

  • « SolrCollapseFunction::getNullPolicy
  • SolrCollapseFunction::setField »
  • PHP Manual
  • SolrCollapseFunction
  • Returns size parameter

SolrCollapseFunction::getSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::getSize — Returns size parameter

Descripción

public SolrCollapseFunction::getSize ( ) : int

Gets the initial size of the collapse data structures when collapsing on a numeric field only

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • SolrCollapseFunction::setSize() - Sets the initial size of the collapse data structures when collapsing on a numeric field only


Sets the field to collapse on

  • « SolrCollapseFunction::getSize
  • SolrCollapseFunction::setHint »
  • PHP Manual
  • SolrCollapseFunction
  • Sets the field to collapse on

SolrCollapseFunction::setField

(PECL solr >= 2.2.0)

SolrCollapseFunction::setField — Sets the field to collapse on

Descripción

public SolrCollapseFunction::setField ( string $fieldName ) : SolrCollapseFunction

The field name to collapse on. In order to collapse a result. The field type must be a single valued String, Int or Float.

Parámetros

fieldName

Valores devueltos

SolrCollapseFunction


Sets collapse hint

  • « SolrCollapseFunction::setField
  • SolrCollapseFunction::setMax »
  • PHP Manual
  • SolrCollapseFunction
  • Sets collapse hint

SolrCollapseFunction::setHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::setHint — Sets collapse hint

Descripción

public SolrCollapseFunction::setHint ( string $hint ) : SolrCollapseFunction

Sets collapse hint

Parámetros

hint

Currently there is only one hint available "top_fc", which stands for top level FieldCache

Valores devueltos

SolrCollapseFunction

Ejemplos

Ejemplo #1 SolrCollapseFunction::setHint() example

<?php

/* ... */

?>

El resultado del ejemplo sería algo similar a:

...


Selects the group heads by the max value of a numeric field or function query

  • « SolrCollapseFunction::setHint
  • SolrCollapseFunction::setMin »
  • PHP Manual
  • SolrCollapseFunction
  • Selects the group heads by the max value of a numeric field or function query

SolrCollapseFunction::setMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query

Descripción

public SolrCollapseFunction::setMax ( string $max ) : SolrCollapseFunction

Selects the group heads by the max value of a numeric field or function query.

Parámetros

max

Valores devueltos

SolrCollapseFunction

Ejemplos

Ejemplo #1 SolrCollapseFunction::setMax() example

<?php

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_field))');

$query = new SolrQuery('*:*');

$query->collapse($func);

?>


Sets the initial size of the collapse data structures when collapsing on a numeric field only

  • « SolrCollapseFunction::setMax
  • SolrCollapseFunction::setNullPolicy »
  • PHP Manual
  • SolrCollapseFunction
  • Sets the initial size of the collapse data structures when collapsing on a numeric field only

SolrCollapseFunction::setMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only

Descripción

public SolrCollapseFunction::setMin ( string $min ) : SolrCollapseFunction

Sets the initial size of the collapse data structures when collapsing on a numeric field only

Parámetros

min

Valores devueltos

SolrCollapseFunction


Sets the NULL Policy

  • « SolrCollapseFunction::setMin
  • SolrCollapseFunction::setSize »
  • PHP Manual
  • SolrCollapseFunction
  • Sets the NULL Policy

SolrCollapseFunction::setNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::setNullPolicy — Sets the NULL Policy

Descripción

public SolrCollapseFunction::setNullPolicy ( string $nullPolicy ) : SolrCollapseFunction

Sets the NULL Policy. One of the 3 policies defined as class constants shall be passed. Accepts ignore, expand, or collapse policies.

Parámetros

nullPolicy

Valores devueltos

SolrCollapseFunction


Sets the initial size of the collapse data structures when collapsing on a numeric field only

  • « SolrCollapseFunction::setNullPolicy
  • SolrCollapseFunction::__toString »
  • PHP Manual
  • SolrCollapseFunction
  • Sets the initial size of the collapse data structures when collapsing on a numeric field only

SolrCollapseFunction::setSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only

Descripción

public SolrCollapseFunction::setSize ( int $size ) : SolrCollapseFunction

Sets the initial size of the collapse data structures when collapsing on a numeric field only.

Parámetros

size

Valores devueltos

SolrCollapseFunction


Returns a string representing the constructed collapse function

  • « SolrCollapseFunction::setSize
  • SolrException »
  • PHP Manual
  • SolrCollapseFunction
  • Returns a string representing the constructed collapse function

SolrCollapseFunction::__toString

(PECL solr >= 2.2.0)

SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function

Descripción

public SolrCollapseFunction::__toString ( ) : string

Returns a string representing the constructed collapse function

Parámetros

Esta función no tiene parámetros.

Valores devueltos


La clase SolrException

(PECL solr >= 0.9.2)

Introducción

Esta es la clase base para todas las excepciones lanzadas por las clases de la extensión Solr.

Sinopsis de la Clase

SolrException extends Exception {
/* Propiedades */
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
public getInternalInfo ( ) : array
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

sourceline

La línea del archivo del espacio c donde se generó la excepción

sourcefile

El archivo fuente del espacio c donde se generó la excepción

zif_name

La función espacio c donde se generó la excepción

Tabla de contenidos

  • SolrException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción


Devuelve información interna de donde se lanzó la excepción

  • « SolrException
  • SolrClientException »
  • PHP Manual
  • SolrException
  • Devuelve información interna de donde se lanzó la excepción

SolrException::getInternalInfo

(PECL solr >= 0.9.2)

SolrException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción

Descripción

public SolrException::getInternalInfo ( ) : array

Devuelve información interna de donde se lanzó la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene información interna de donde el error fue lanzado. Usado únicamente para depurar por desarrolladores de extensiones.


La clase SolrClientException

(PECL solr >= 0.9.2)

Introducción

Una excepción lanzada cuando existe un error al hacer una solicitud al servidor desde el cliente.

Sinopsis de la Clase

SolrClientException extends SolrException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Métodos */
public getInternalInfo ( ) : array
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Tabla de contenidos

  • SolrClientException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción


Devuelve información interna de donde se lanzó la excepción

  • « SolrClientException
  • SolrServerException »
  • PHP Manual
  • SolrClientException
  • Devuelve información interna de donde se lanzó la excepción

SolrClientException::getInternalInfo

(PECL solr >= 0.9.2)

SolrClientException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción

Descripción

public SolrClientException::getInternalInfo ( ) : array

Devuelve información interna de donde se lanzó la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene información interna de donde el error fue lanzado. Usado únicamente para depurar por desarrolladores de extensiones.


La clase SolrServerException

(PECL Solr >= 1.1.0, >=2.0.0)

Introducción

Una excepción lanzada cuando hay un error producido por el propio servidor Solr.

Sinopsis de la Clase

SolrServerException extends SolrException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Métodos */
public getInternalInfo ( ) : array
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Tabla de contenidos

  • SolrServerException::getInternalInfo — Devuelve información interna de dónde fue lanzada la excepción


Devuelve información interna de dónde fue lanzada la excepción

  • « SolrServerException
  • SolrIllegalArgumentException »
  • PHP Manual
  • SolrServerException
  • Devuelve información interna de dónde fue lanzada la excepción

SolrServerException::getInternalInfo

(PECL solr >= 1.1.0, >=2.0.0)

SolrServerException::getInternalInfo — Devuelve información interna de dónde fue lanzada la excepción

Descripción

public SolrServerException::getInternalInfo ( ) : array

Devuelve información interna de dónde fue lanzada la excepción.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array que contiene información interna de dónde se lanzó la excepción. Utilizado solamente con propósitos de depuración para desarrolladores de extensiones.


La clase SolrIllegalArgumentException

(PECL solr >= 0.9.2)

Introducción

Este objeto es lanzado cuando un argumento ilegal o no válido es pasado al método.

Sinopsis de la Clase

SolrIllegalArgumentException extends SolrException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Métodos */
public getInternalInfo ( ) : array
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Tabla de contenidos

  • SolrIllegalArgumentException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción


Devuelve información interna de donde se lanzó la excepción

  • « SolrIllegalArgumentException
  • SolrIllegalOperationException »
  • PHP Manual
  • SolrIllegalArgumentException
  • Devuelve información interna de donde se lanzó la excepción

SolrIllegalArgumentException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalArgumentException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción

Descripción

public SolrIllegalArgumentException::getInternalInfo ( ) : array

Devuelve información interna de donde se lanzó la excepción.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene información interna de donde el error fue lanzado. Usado únicamente para depurar por desarrolladores de extensiones.


La clase SolrIllegalOperationException

(PECL solr >= 0.9.2)

Introducción

Este objeto es lanzado cuando una operación ilegal o no soportada es realizada sobre un objeto.

Sinopsis de la Clase

SolrIllegalOperationException extends SolrException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Métodos */
public getInternalInfo ( ) : array
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Tabla de contenidos

  • SolrIllegalOperationException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción


Devuelve información interna de donde se lanzó la excepción

  • « SolrIllegalOperationException
  • SolrMissingMandatoryParameterException »
  • PHP Manual
  • SolrIllegalOperationException
  • Devuelve información interna de donde se lanzó la excepción

SolrIllegalOperationException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalOperationException::getInternalInfo — Devuelve información interna de donde se lanzó la excepción

Descripción

public SolrIllegalOperationException::getInternalInfo ( ) : array

Devuelve información interna de donde se lanzó la excepción.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una matriz que contiene información interna de donde el error fue lanzado. Usado únicamente para depurar por desarrolladores de extensiones.


La clase SolrMissingMandatoryParameterException

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

SolrMissingMandatoryParameterException extends SolrException {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}


Cliente Sphinx

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • SphinxClient — Clase SphinxClient
    • SphinxClient::addQuery — Add query to multi-query batch
    • SphinxClient::buildExcerpts — Build text snippets
    • SphinxClient::buildKeywords — Extraer las palabras clave de una consulta
    • SphinxClient::close — Cierra conexión persistente previamente abierta
    • SphinxClient::__construct — Crea un nuevo objeto SphinxClient
    • SphinxClient::escapeString — Escapa caracteres especiales
    • SphinxClient::getLastError — Obtener el último mensaje de error
    • SphinxClient::getLastWarning — Obtener la última advertencia
    • SphinxClient::open — Abre una conexión persistente con el servidor
    • SphinxClient::query — Execute search query
    • SphinxClient::resetFilters — Clear all filters
    • SphinxClient::resetGroupBy — Clear all group-by settings
    • SphinxClient::runQueries — Ejecutar un lote de consultas de búsqueda
    • SphinxClient::setArrayResult — Change the format of result set array
    • SphinxClient::setConnectTimeout — Establecer el tiempo de conexión
    • SphinxClient::setFieldWeights — Set field weights
    • SphinxClient::setFilter — Add new integer values set filter
    • SphinxClient::setFilterFloatRange — Add new float range filter
    • SphinxClient::setFilterRange — Add new integer range filter
    • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy — Set grouping attribute
    • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange — Set a range of accepted document IDs
    • SphinxClient::setIndexWeights — Set per-index weights
    • SphinxClient::setLimits — Set offset and limit of the result set
    • SphinxClient::setMatchMode — Set full-text query matching mode
    • SphinxClient::setMaxQueryTime — Establecer el tiempo máximo de consulta
    • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode — Set ranking mode
    • SphinxClient::setRetries — Set retry count and delay
    • SphinxClient::setSelect — Set select clause
    • SphinxClient::setServer — Set searchd host and port
    • SphinxClient::setSortMode — Set matches sorting mode
    • SphinxClient::status — Queries searchd status
    • SphinxClient::updateAttributes — Actualiza los atributos del documento


Introducción

Esta extensión proporciona enlaces para la biblioteca cliente de Sphinx search. Sphinx es un motor de búsqueda independiente de la intención de proporcionar rápidamente un tamaño eficiente y adecuado para las funciones de búsqueda de texto completo a otras aplicaciones. Sphinx ha sido especialmente diseñado para integrarse muy bien con Bases de datos SQL y lenguajes de scripting. Tanto Sphinx y su biblioteca cliente se pueden obtener del » sitio oficial


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

PECL/sphinx requiere PHP 5.2.2 superior.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/sphinx.

Si el script ./configure generado por phpize tiene problemas encontrando los archivos de libsphinxclient (por ejemplo, fue instalado en una ruta personalizada), use ./configure --with-sphinx=$PREFIX, donde $PREFIX es la ruta de instalación de libsphinxclient.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SEARCHD_OK (integer)
SEARCHD_ERROR (integer)
SEARCHD_RETRY (integer)
SEARCHD_WARNING (integer)
SPH_MATCH_ALL (integer)
SPH_MATCH_ANY (integer)
SPH_MATCH_PHRASE (integer)
SPH_MATCH_BOOLEAN (integer)
SPH_MATCH_EXTENDED (integer)
SPH_MATCH_FULLSCAN (integer)
SPH_MATCH_EXTENDED2 (integer)
SPH_RANK_PROXIMITY_BM25 (integer)
SPH_RANK_BM25 (integer)
SPH_RANK_NONE (integer)
SPH_RANK_WORDCOUNT (integer)
SPH_SORT_RELEVANCE (integer)
SPH_SORT_ATTR_DESC (integer)
SPH_SORT_ATTR_ASC (integer)
SPH_SORT_TIME_SEGMENTS (integer)
SPH_SORT_EXTENDED (integer)
SPH_SORT_EXPR (integer)
SPH_FILTER_VALUES (integer)
SPH_FILTER_RANGE (integer)
SPH_FILTER_FLOATRANGE (integer)
SPH_ATTR_INTEGER (integer)
SPH_ATTR_TIMESTAMP (integer)
SPH_ATTR_ORDINAL (integer)
SPH_ATTR_BOOL (integer)
SPH_ATTR_FLOAT (integer)
SPH_ATTR_MULTI (integer)
SPH_GROUPBY_DAY (integer)
SPH_GROUPBY_WEEK (integer)
SPH_GROUPBY_MONTH (integer)
SPH_GROUPBY_YEAR (integer)
SPH_GROUPBY_ATTR (integer)
SPH_GROUPBY_ATTRPAIR (integer)


Ejemplos

Ejemplo #1 Ejemplo de uso básico

<?php

$s = new SphinxClient;
$s->setServer("localhost", 6712);
$s->setMatchMode(SPH_MATCH_ANY);
$s->setMaxQueryTime(3);

$result = $s->query("test");

var_dump($result);

?>

El resultado del ejemplo sería algo similar a:

array(10) {
  ["error"]=>
  string(0) ""
  ["warning"]=>
  string(0) ""
  ["status"]=>
  int(0)
  ["fields"]=>
  array(3) {
    [0]=>
    string(7) "subject"
    [1]=>
    string(4) "body"
    [2]=>
    string(6) "author"
  }
  ["attrs"]=>
  array(0) {
  }
  ["matches"]=>
  array(1) {
    [3]=>
    array(2) {
      ["weight"]=>
      int(1)
      ["attrs"]=>
      array(0) {
      }
    }
  }
  ["total"]=>
  int(1)
  ["total_found"]=>
  int(1)
  ["time"]=>
  float(0)
  ["words"]=>
  array(1) {
    ["to"]=>
    array(2) {
      ["docs"]=>
      int(1)
      ["hits"]=>
      int(1)
    }
  }
}


Clase SphinxClient

(PECL sphinx >= 0.1.0)

Introducción

La clase SphinxClient proporciona un interfaz orientado a objetos para Sphinx.

Sinopsis de la Clase

SphinxClient {
/* Métodos */
public addQuery ( string $query , string $index = "*" , string $comment = "" ) : int
public buildExcerpts ( array $docs , string $index , string $words , array $opts = ? ) : array|false
public buildKeywords ( string $query , string $index , bool $hits ) : array
public close ( ) : bool
public __construct ( )
public escapeString ( string $string ) : string
public getLastError ( ) : string
public getLastWarning ( ) : string
public open ( ) : bool
public query ( string $query , string $index = "*" , string $comment = "" ) : array
public resetFilters ( ) : void
public resetGroupBy ( ) : void
public runQueries ( ) : array
public setArrayResult ( bool $array_result = false ) : bool
public setConnectTimeout ( float $timeout ) : bool
public setFieldWeights ( array $weights ) : bool
public setFilter ( string $attribute , array $values , bool $exclude = false ) : bool
public setFilterFloatRange ( string $attribute , float $min , float $max , bool $exclude = false ) : bool
public setFilterRange ( string $attribute , int $min , int $max , bool $exclude = false ) : bool
public setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude ) : bool
public setGroupBy ( string $attribute , int $func , string $groupsort = "@group desc" ) : bool
public setGroupDistinct ( string $attribute ) : bool
public setIDRange ( int $min , int $max ) : bool
public setIndexWeights ( array $weights ) : bool
public setLimits ( int $offset , int $limit , int $max_matches = 0 , int $cutoff = 0 ) : bool
public setMatchMode ( int $mode ) : bool
public setMaxQueryTime ( int $qtime ) : bool
public setOverride ( string $attribute , int $type , array $values ) : bool
public setRankingMode ( int $ranker ) : bool
public setRetries ( int $count , int $delay = 0 ) : bool
public setSelect ( string $clause ) : bool
public setServer ( string $server , int $port ) : bool
public setSortMode ( int $mode , string $sortby = ? ) : bool
public status ( ) : array
public updateAttributes ( string $index , array $attributes , array $values , bool $mva = false ) : int
}

Tabla de contenidos

  • SphinxClient::addQuery — Add query to multi-query batch
  • SphinxClient::buildExcerpts — Build text snippets
  • SphinxClient::buildKeywords — Extraer las palabras clave de una consulta
  • SphinxClient::close — Cierra conexión persistente previamente abierta
  • SphinxClient::__construct — Crea un nuevo objeto SphinxClient
  • SphinxClient::escapeString — Escapa caracteres especiales
  • SphinxClient::getLastError — Obtener el último mensaje de error
  • SphinxClient::getLastWarning — Obtener la última advertencia
  • SphinxClient::open — Abre una conexión persistente con el servidor
  • SphinxClient::query — Execute search query
  • SphinxClient::resetFilters — Clear all filters
  • SphinxClient::resetGroupBy — Clear all group-by settings
  • SphinxClient::runQueries — Ejecutar un lote de consultas de búsqueda
  • SphinxClient::setArrayResult — Change the format of result set array
  • SphinxClient::setConnectTimeout — Establecer el tiempo de conexión
  • SphinxClient::setFieldWeights — Set field weights
  • SphinxClient::setFilter — Add new integer values set filter
  • SphinxClient::setFilterFloatRange — Add new float range filter
  • SphinxClient::setFilterRange — Add new integer range filter
  • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
  • SphinxClient::setGroupBy — Set grouping attribute
  • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
  • SphinxClient::setIDRange — Set a range of accepted document IDs
  • SphinxClient::setIndexWeights — Set per-index weights
  • SphinxClient::setLimits — Set offset and limit of the result set
  • SphinxClient::setMatchMode — Set full-text query matching mode
  • SphinxClient::setMaxQueryTime — Establecer el tiempo máximo de consulta
  • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
  • SphinxClient::setRankingMode — Set ranking mode
  • SphinxClient::setRetries — Set retry count and delay
  • SphinxClient::setSelect — Set select clause
  • SphinxClient::setServer — Set searchd host and port
  • SphinxClient::setSortMode — Set matches sorting mode
  • SphinxClient::status — Queries searchd status
  • SphinxClient::updateAttributes — Actualiza los atributos del documento


Add query to multi-query batch

  • « SphinxClient
  • SphinxClient::buildExcerpts »
  • PHP Manual
  • SphinxClient
  • Add query to multi-query batch

SphinxClient::addQuery

(PECL sphinx >= 0.1.0)

SphinxClient::addQuery — Add query to multi-query batch

Descripción

public SphinxClient::addQuery ( string $query , string $index = "*" , string $comment = "" ) : int

Adds query with the current settings to multi-query batch. This method doesn't affect current settings (sorting, filtering, grouping etc.) in any way.

Parámetros

query

Query string.

index

An index name (or names).

comment

Valores devueltos

Returns an index in an array of results that will be returned by SphinxClient::runQueries call or false on error.

Ver también

  • SphinxClient::runQueries
  • SphinxClient::query


Build text snippets

  • « SphinxClient::addQuery
  • SphinxClient::buildKeywords »
  • PHP Manual
  • SphinxClient
  • Build text snippets

SphinxClient::buildExcerpts

(PECL sphinx >= 0.1.0)

SphinxClient::buildExcerpts — Build text snippets

Descripción

public SphinxClient::buildExcerpts ( array $docs , string $index , string $words , array $opts = ? ) : array|false

Connects to searchd, requests it to generate excerpts (snippets) from the given documents, and returns the results.

Parámetros

docs

Array of strings with documents' contents.

index

Index name.

words

Keywords to highlight.

opts

Associative array of additional highlighting options (see below).

Highlighting options
Option | Description
"before_match" | A string to insert before a keyword match. Default is "<b>".
"after_match" | A string to insert after a keyword match. Default is "</b>".
"chunk_separator" | A string to insert between snippet chunks (passages). Default is " ... ".
"limit" | Maximum snippet size, in symbols (codepoints). Integer, default is 256.
"around" | How much words to pick around each matching keywords block. Integer, default is 5.
"exact_phrase" | Whether to highlight exact query phrase matches only instead of individual keywords. Boolean, default is false.
"single_passage" | Whether to extract single best passage only. Boolean, default is false.

Valores devueltos

Returns array of snippets on success o false en caso de error.


Extraer las palabras clave de una consulta

  • « SphinxClient::buildExcerpts
  • SphinxClient::close »
  • PHP Manual
  • SphinxClient
  • Extraer las palabras clave de una consulta

SphinxClient::buildKeywords

(PECL sphinx >= 0.1.0)

SphinxClient::buildKeywords — Extraer las palabras clave de una consulta

Descripción

public SphinxClient::buildKeywords ( string $query , string $index , bool $hits ) : array

Extrae las palabras clave de query con los ajustes para el tokenizer dado index, de forma opcional con las estadísticas de ocurrencia por palabra clave.

Parámetros

query

Una consulta para extraer palabras clave.

index

Un índice para obtener la configuración de tokenización y estadísticas de palabras clave de la ocurrencia.

hits

Marca boolean para activar/desactivar la generación de estadísticas de palabras clave.

Valores devueltos

Devuelve un array de arrays asociativos con la información por palabra clave.


Cierra conexión persistente previamente abierta

  • « SphinxClient::buildKeywords
  • SphinxClient::__construct »
  • PHP Manual
  • SphinxClient
  • Cierra conexión persistente previamente abierta

SphinxClient::close

(PECL sphinx >= 1.0.3)

SphinxClient::close — Cierra conexión persistente previamente abierta

Descripción

public SphinxClient::close ( ) : bool

Cierra conexión persistente previamente abierta.

Parámetros

Esta función no tiene parámetros.

Historial de cambios

PECL/sphinx Versión | Descripción
1.0.3 | Añadido SphinxClient::close(), disponible sólo si se compila con libsphinxclient >= 0.9.9.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::open


Crea un nuevo objeto SphinxClient

  • « SphinxClient::close
  • SphinxClient::escapeString »
  • PHP Manual
  • SphinxClient
  • Crea un nuevo objeto SphinxClient

SphinxClient::__construct

(PECL sphinx >= 0.1.0)

SphinxClient::__construct — Crea un nuevo objeto SphinxClient

Descripción

public SphinxClient::__construct ( )

Crea un nuevo objeto SphinxClient.

Parámetros

Esta función no tiene parámetros.


Escapa caracteres especiales

  • « SphinxClient::__construct
  • SphinxClient::getLastError »
  • PHP Manual
  • SphinxClient
  • Escapa caracteres especiales

SphinxClient::escapeString

(PECL sphinx >= 0.1.0)

SphinxClient::escapeString — Escapa caracteres especiales

Descripción

public SphinxClient::escapeString ( string $string ) : string

Escapa caracteres que se tratan como operadores especiales por el analizador de lenguaje de consulta.

Parámetros

string

String a ser escapado.

Valores devueltos

Devuelve un string escapado.


Obtener el último mensaje de error

  • « SphinxClient::escapeString
  • SphinxClient::getLastWarning »
  • PHP Manual
  • SphinxClient
  • Obtener el último mensaje de error

SphinxClient::getLastError

(PECL sphinx >= 0.1.0)

SphinxClient::getLastError — Obtener el último mensaje de error

Descripción

public SphinxClient::getLastError ( ) : string

Devuelve un string con el último mensaje de error. Si no hubo errores durante la previa llamada API, es retornado un string vacío. Este método no restablece el mensaje de error, lo que con seguridad se puede llamar varias veces.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el último mensaje de error o un string vacío si no hubo errores.

Ver también

  • SphinxClient::getLastWarning


Obtener la última advertencia

  • « SphinxClient::getLastError
  • SphinxClient::open »
  • PHP Manual
  • SphinxClient
  • Obtener la última advertencia

SphinxClient::getLastWarning

(PECL sphinx >= 0.1.0)

SphinxClient::getLastWarning — Obtener la última advertencia

Descripción

public SphinxClient::getLastWarning ( ) : string

Devuelve el último mensaje de advertencia. Si no se generó ninguna advertencia durante la previa llamada API, es retornado un string vacío. Este método no restablece la advertencia, lo que con seguridad se puede llamar varias veces.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el último mensaje de advertencia o un string vacío si no hay advertencias.

Ver también

  • SphinxClient::getLastError


Abre una conexión persistente con el servidor

  • « SphinxClient::getLastWarning
  • SphinxClient::query »
  • PHP Manual
  • SphinxClient
  • Abre una conexión persistente con el servidor

SphinxClient::open

(PECL sphinx >= 1.0.3)

SphinxClient::open — Abre una conexión persistente con el servidor

Descripción

public SphinxClient::open ( ) : bool

Abre una conexión persistente al servidor.

Parámetros

Esta función no tiene parámetros.

Historial de cambios

PECL/sphinx Versión | Descripción
1.0.3 | Añadido SphinxClient::open(), disponible sólo si se compila con libsphinxclient >= 0.9.9.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::close


Execute search query

  • « SphinxClient::open
  • SphinxClient::resetFilters »
  • PHP Manual
  • SphinxClient
  • Execute search query

SphinxClient::query

(PECL sphinx >= 0.1.0)

SphinxClient::query — Execute search query

Descripción

public SphinxClient::query ( string $query , string $index = "*" , string $comment = "" ) : array

Connects to searchd server, runs the given search query with the current settings, obtains and returns the result set.

Parámetros

query

Query string.

index

An index name (or names).

comment

Valores devueltos

On success, SphinxClient::query() returns a list of found matches and additional per-query statistics. The result set is a hash utilize other structures instead of hash) with the following keys and values:

Result set structure
Key | Value description
"matches" | An array with found document IDs as keys and their weight and attributes values as values
"total" | Total number of matches found and retrieved (depends on your settings)
"total_found" | Total number of found documents matching the query
"words" | An array with words (case-folded and stemmed) as keys and per-word statistics as values
"error" | Query error message reported by searchd
"warning" | Query warning reported by searchd

Ver también

  • SphinxClient::runQueries
  • SphinxClient::addQuery


Clear all filters

  • « SphinxClient::query
  • SphinxClient::resetGroupBy »
  • PHP Manual
  • SphinxClient
  • Clear all filters

SphinxClient::resetFilters

(PECL sphinx >= 0.1.0)

SphinxClient::resetFilters — Clear all filters

Descripción

public SphinxClient::resetFilters ( ) : void

Clears all currently set filters. This call is normally required when using multi-queries. You might want to set different filters for different queries in the batch. To do that, you should call SphinxClient::resetFilters() and add new filters using the respective calls.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SphinxClient::resetGroupBy


Clear all group-by settings

  • « SphinxClient::resetFilters
  • SphinxClient::runQueries »
  • PHP Manual
  • SphinxClient
  • Clear all group-by settings

SphinxClient::resetGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::resetGroupBy — Clear all group-by settings

Descripción

public SphinxClient::resetGroupBy ( ) : void

Clears all currently group-by settings, and disables group-by. This call is normally required only when using multi-queries.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SphinxClient::resetGroupBy


Ejecutar un lote de consultas de búsqueda

  • « SphinxClient::resetGroupBy
  • SphinxClient::setArrayResult »
  • PHP Manual
  • SphinxClient
  • Ejecutar un lote de consultas de búsqueda

SphinxClient::runQueries

(PECL sphinx >= 0.1.0)

SphinxClient::runQueries — Ejecutar un lote de consultas de búsqueda

Descripción

public SphinxClient::runQueries ( ) : array

Se conecta a searchd, ejecuta un lote de todas las consultas se agregan utilizando SphinxClient::addQuery, obtiene y devuelve el conjunto de resultados.

Valores devueltos

Devuelve false en caso de error y array de conjuntos de resultados en caso de éxito.

Ver también

  • SphinxClient::addQuery
  • SphinxClient::query


Change the format of result set array

  • « SphinxClient::runQueries
  • SphinxClient::setConnectTimeout »
  • PHP Manual
  • SphinxClient
  • Change the format of result set array

SphinxClient::setArrayResult

(PECL sphinx >= 0.1.0)

SphinxClient::setArrayResult — Change the format of result set array

Descripción

public SphinxClient::setArrayResult ( bool $array_result = false ) : bool

Controls the format of search results set arrays (whether matches should be returned as an array or a hash).

Parámetros

array_result

If array_result is false, matches are returned as a hash with document IDs as keys, and other information (weight, attributes) as values. If array_result is true, matches are returned as a plain array with complete per-match information including document IDs.

Valores devueltos

Always returns true.


Establecer el tiempo de conexión

  • « SphinxClient::setArrayResult
  • SphinxClient::setFieldWeights »
  • PHP Manual
  • SphinxClient
  • Establecer el tiempo de conexión

SphinxClient::setConnectTimeout

(PECL sphinx >= 0.1.0)

SphinxClient::setConnectTimeout — Establecer el tiempo de conexión

Descripción

public SphinxClient::setConnectTimeout ( float $timeout ) : bool

establecer el tiempo de conexión (en segundos) para la conexión searchd.

Parámetros

timeout

Tiempo de espera en segundos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setMaxQueryTime


Set field weights

  • « SphinxClient::setConnectTimeout
  • SphinxClient::setFilter »
  • PHP Manual
  • SphinxClient
  • Set field weights

SphinxClient::setFieldWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setFieldWeights — Set field weights

Descripción

public SphinxClient::setFieldWeights ( array $weights ) : bool

Binds per-field weights by name.

Match ranking can be affected by per-field weights. See » Sphinx documentation for an explanation on how phrase proximity ranking is affected. This call lets you specify non-default weights for full-text fields.

The weights must be positive 32-bit integers, so be careful not to hit 32-bit integer maximum. The final weight is a 32-bit integer too. Default weight value is 1. Unknown field names are silently ignored.

Parámetros

weights

Associative array of field names and field weights.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setIndexWeights


Add new integer values set filter

  • « SphinxClient::setFieldWeights
  • SphinxClient::setFilterFloatRange »
  • PHP Manual
  • SphinxClient
  • Add new integer values set filter

SphinxClient::setFilter

(PECL sphinx >= 0.1.0)

SphinxClient::setFilter — Add new integer values set filter

Descripción

public SphinxClient::setFilter ( string $attribute , array $values , bool $exclude = false ) : bool

Adds new integer values set filter to the existing list of filters.

Parámetros

attribute

An attribute name.

values

Plain array of integer values.

exclude

If set to true, matching documents are excluded from the result set.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::resetFilters


Add new float range filter

  • « SphinxClient::setFilter
  • SphinxClient::setFilterRange »
  • PHP Manual
  • SphinxClient
  • Add new float range filter

SphinxClient::setFilterFloatRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterFloatRange — Add new float range filter

Descripción

public SphinxClient::setFilterFloatRange ( string $attribute , float $min , float $max , bool $exclude = false ) : bool

Adds new float range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is true).

Parámetros

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to true, matching documents are excluded from the result set.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Add new integer range filter

  • « SphinxClient::setFilterFloatRange
  • SphinxClient::setGeoAnchor »
  • PHP Manual
  • SphinxClient
  • Add new integer range filter

SphinxClient::setFilterRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterRange — Add new integer range filter

Descripción

public SphinxClient::setFilterRange ( string $attribute , int $min , int $max , bool $exclude = false ) : bool

Adds new integer range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is true).

Parámetros

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to true, matching documents are excluded from the result set.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Set anchor point for a geosphere distance calculations

  • « SphinxClient::setFilterRange
  • SphinxClient::setGroupBy »
  • PHP Manual
  • SphinxClient
  • Set anchor point for a geosphere distance calculations

SphinxClient::setGeoAnchor

(PECL sphinx >= 0.1.0)

SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations

Descripción

public SphinxClient::setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude ) : bool

Sets anchor point for a geosphere distance (geodistance) calculations and enables them.

Once an anchor point is set, you can use magic "@geodist" attribute name in your filters and/or sorting expressions.

Parámetros

attrlat

Name of a latitude attribute.

attrlong

Name of a longitude attribute.

latitude

Anchor latitude in radians.

longitude

Anchor longitude in radians.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Set grouping attribute

  • « SphinxClient::setGeoAnchor
  • SphinxClient::setGroupDistinct »
  • PHP Manual
  • SphinxClient
  • Set grouping attribute

SphinxClient::setGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupBy — Set grouping attribute

Descripción

public SphinxClient::setGroupBy ( string $attribute , int $func , string $groupsort = "@group desc" ) : bool

Sets grouping attribute, function, and group sorting mode, and enables grouping.

Grouping feature is very similar to GROUP BY clause in SQL. Results produced by this function call are going to be the same as produced by the following pseudo code: SELECT ... GROUP BY $func($attribute) ORDER BY $groupsort.

Parámetros

attribute

A string containing group-by attribute name.

func

Constant, which sets a function applied to the attribute value in order to compute group-by key.

groupsort

An optional clause controlling how the groups are sorted.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::resetGroupBy
  • SphinxClient::setSortMode
  • SphinxClient::setGroupDistinct


Set attribute name for per-group distinct values count calculations

  • « SphinxClient::setGroupBy
  • SphinxClient::setIDRange »
  • PHP Manual
  • SphinxClient
  • Set attribute name for per-group distinct values count calculations

SphinxClient::setGroupDistinct

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations

Descripción

public SphinxClient::setGroupDistinct ( string $attribute ) : bool

Sets attribute name for per-group distinct values count calculations. Only available for grouping queries. For each group, all values of attribute will be stored, then the amount of distinct values will be calculated and returned to the client. This feature is similar to COUNT(DISTINCT) clause in SQL.

Parámetros

attribute

A string containing group-by attribute name.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setSortMode
  • SphinxClient::setGroupBy
  • SphinxClient::resetGroupBy


Set a range of accepted document IDs

  • « SphinxClient::setGroupDistinct
  • SphinxClient::setIndexWeights »
  • PHP Manual
  • SphinxClient
  • Set a range of accepted document IDs

SphinxClient::setIDRange

(PECL sphinx >= 0.1.0)

SphinxClient::setIDRange — Set a range of accepted document IDs

Descripción

public SphinxClient::setIDRange ( int $min , int $max ) : bool

Sets an accepted range of document IDs. Default range is from 0 to 0, i.e. no limit. Only those records that have document ID between min and max (including IDs exactly equal to min or max) will be matched.

Parámetros

min

Minimum ID value.

max

Maximum ID value.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set per-index weights

  • « SphinxClient::setIDRange
  • SphinxClient::setLimits »
  • PHP Manual
  • SphinxClient
  • Set per-index weights

SphinxClient::setIndexWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setIndexWeights — Set per-index weights

Descripción

public SphinxClient::setIndexWeights ( array $weights ) : bool

Sets per-index weights and enables weighted summing of match weights across different indexes.

Parámetros

weights

An associative array mapping string index names to integer weights. Default is empty array, i.e. weighting summing is disabled.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set offset and limit of the result set

  • « SphinxClient::setIndexWeights
  • SphinxClient::setMatchMode »
  • PHP Manual
  • SphinxClient
  • Set offset and limit of the result set

SphinxClient::setLimits

(PECL sphinx >= 0.1.0)

SphinxClient::setLimits — Set offset and limit of the result set

Descripción

public SphinxClient::setLimits ( int $offset , int $limit , int $max_matches = 0 , int $cutoff = 0 ) : bool

Sets offset into server-side result set and amount of matches to return to client starting from that offset (limit). Can additionally control maximum server-side result set size for current query (max_matches) and the threshold amount of matches to stop searching at (cutoff).

Parámetros

offset

Result set offset.

limit

Amount of matches to return.

max_matches

Controls how much matches searchd will keep in RAM while searching.

cutoff

Used for advanced performance control. It tells searchd to forcibly stop search query once cutoff matches have been found and processed.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set full-text query matching mode

  • « SphinxClient::setLimits
  • SphinxClient::setMaxQueryTime »
  • PHP Manual
  • SphinxClient
  • Set full-text query matching mode

SphinxClient::setMatchMode

(PECL sphinx >= 0.1.0)

SphinxClient::setMatchMode — Set full-text query matching mode

Descripción

public SphinxClient::setMatchMode ( int $mode ) : bool

Sets full-text query matching mode. mode is one of the constants listed below.

Match modes
Constant | Description
SPH_MATCH_ALL | Match all query words (default mode).
SPH_MATCH_ANY | Match any of query words.
SPH_MATCH_PHRASE | Match query as a phrase, requiring perfect match.
SPH_MATCH_BOOLEAN | Match query as a boolean expression.
SPH_MATCH_EXTENDED | Match query as an expression in Sphinx internal query language.
SPH_MATCH_FULLSCAN | Enables fullscan.
SPH_MATCH_EXTENDED2 | The same as SPH_MATCH_EXTENDED plus ranking and quorum searching support.

Parámetros

mode

Matching mode.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setRankingMode
  • SphinxClient::setSortMode


Establecer el tiempo máximo de consulta

  • « SphinxClient::setMatchMode
  • SphinxClient::setOverride »
  • PHP Manual
  • SphinxClient
  • Establecer el tiempo máximo de consulta

SphinxClient::setMaxQueryTime

(PECL sphinx >= 0.1.0)

SphinxClient::setMaxQueryTime — Establecer el tiempo máximo de consulta

Descripción

public SphinxClient::setMaxQueryTime ( int $qtime ) : bool

Establece el tiempo máximo de consulta de búsqueda.

Parámetros

qtime

Tiempo de consulta máximo, en milisegundos. Debe ser un integer no negativo. El valor por defecto es 0, es decir, no hay límite.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Sets temporary per-document attribute value overrides

  • « SphinxClient::setMaxQueryTime
  • SphinxClient::setRankingMode »
  • PHP Manual
  • SphinxClient
  • Sets temporary per-document attribute value overrides

SphinxClient::setOverride

(PECL sphinx >= 1.0.3)

SphinxClient::setOverride — Sets temporary per-document attribute value overrides

Descripción

public SphinxClient::setOverride ( string $attribute , int $type , array $values ) : bool

Sets temporary (per-query) per-document attribute value overrides. Override feature lets you "temporary" update attribute values for some documents within a single query, leaving all other queries unaffected. This might be useful for personalized data

Parámetros

attribute

An attribute name.

type

An attribute type. Only supports scalar attributes.

values

Array of attribute values that maps document IDs to overridden attribute values.

Historial de cambios

PECL/sphinx Versión | Descripción
PECL sphinx 1.0.3 | Added SphinxClient::setOverride(), available only if compiled with libsphinxclient >= 0.9.9.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set ranking mode

  • « SphinxClient::setOverride
  • SphinxClient::setRetries »
  • PHP Manual
  • SphinxClient
  • Set ranking mode

SphinxClient::setRankingMode

(PECL sphinx >= 0.1.0)

SphinxClient::setRankingMode — Set ranking mode

Descripción

public SphinxClient::setRankingMode ( int $ranker ) : bool

Sets ranking mode. Only available in SPH_MATCH_EXTENDED2 matching mode.

Ranking modes
Constant | Description
SPH_RANK_PROXIMITY_BM25 | Default ranking mode which uses both proximity and BM25 ranking.
SPH_RANK_BM25 | Statistical ranking mode which uses BM25 ranking only (similar to most of other full-text engines). This mode is faster, but may result in worse quality on queries which contain more than 1 keyword.
SPH_RANK_NONE | Disables ranking. This mode is the fastest. It is essentially equivalent to boolean searching, a weight of 1 is assigned to all matches.

Parámetros

ranker

Ranking mode.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setMatchMode


Set retry count and delay

  • « SphinxClient::setRankingMode
  • SphinxClient::setSelect »
  • PHP Manual
  • SphinxClient
  • Set retry count and delay

SphinxClient::setRetries

(PECL sphinx >= 0.1.0)

SphinxClient::setRetries — Set retry count and delay

Descripción

public SphinxClient::setRetries ( int $count , int $delay = 0 ) : bool

Sets distributed retry count and delay.

On temporary failures searchd will attempt up to count retries per agent. delay is the delay between the retries, in milliseconds. Retries are disabled by default. Note that this call will not make the API itself retry on temporary failure; it only tells searchd to do so.

Parámetros

count

Number of retries.

delay

Delay between retries, in milliseconds.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set select clause

  • « SphinxClient::setRetries
  • SphinxClient::setServer »
  • PHP Manual
  • SphinxClient
  • Set select clause

SphinxClient::setSelect

(PECL sphinx >= 1.0.1)

SphinxClient::setSelect — Set select clause

Descripción

public SphinxClient::setSelect ( string $clause ) : bool

Sets the select clause, listing specific attributes to fetch, and expressions to compute and fetch.

Parámetros

clause

SQL-like clause.

Historial de cambios

PECL/sphinx Versión | Descripción
PECL sphinx 1.0.1 | Added SphinxClient::setSelect(), available only if compiled with libsphinxclient >= 0.9.9.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set searchd host and port

  • « SphinxClient::setSelect
  • SphinxClient::setSortMode »
  • PHP Manual
  • SphinxClient
  • Set searchd host and port

SphinxClient::setServer

(PECL sphinx >= 0.1.0)

SphinxClient::setServer — Set searchd host and port

Descripción

public SphinxClient::setServer ( string $server , int $port ) : bool

Sets searchd host name and TCP port. All subsequent requests will use the new host and port settings. Default host and port are 'localhost' and 3312, respectively.

Parámetros

server

IP or hostname.

port

Port number.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Set matches sorting mode

  • « SphinxClient::setServer
  • SphinxClient::status »
  • PHP Manual
  • SphinxClient
  • Set matches sorting mode

SphinxClient::setSortMode

(PECL sphinx >= 0.1.0)

SphinxClient::setSortMode — Set matches sorting mode

Descripción

public SphinxClient::setSortMode ( int $mode , string $sortby = ? ) : bool

Sets matches sorting mode. See available modes below.

Sorting modes
Constant | Description
SPH_SORT_RELEVANCE | Sort by relevance in descending order (best matches first).
SPH_SORT_ATTR_DESC | Sort by an attribute in descending order (bigger attribute values first).
SPH_SORT_ATTR_ASC | Sort by an attribute in ascending order (smaller attribute values first).
SPH_SORT_TIME_SEGMENTS | Sort by time segments (last hour/day/week/month) in descending order, and then by relevance in descending order.
SPH_SORT_EXTENDED | Sort by SQL-like combination of columns in ASC/DESC order.
SPH_SORT_EXPR | Sort by an arithmetic expression.

Parámetros

mode

Sorting mode.

sortby

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • SphinxClient::setMatchMode
  • SphinxClient::setSortMode


Queries searchd status

  • « SphinxClient::setSortMode
  • SphinxClient::updateAttributes »
  • PHP Manual
  • SphinxClient
  • Queries searchd status

SphinxClient::status

(PECL sphinx >= 1.0.3)

SphinxClient::status — Queries searchd status

Descripción

public SphinxClient::status ( ) : array

Queries searchd status, and returns an array of status variable name and value pairs.

Parámetros

Esta función no tiene parámetros.

Historial de cambios

PECL/sphinx Versión | Descripción
PECL sphinx 1.0.3 | Added SphinxClient::status(), available only if compiled with libsphinxclient >= 0.9.9.

Valores devueltos

Returns an associative array of search server statistics o false en caso de error.


Actualiza los atributos del documento

  • « SphinxClient::status
  • Extensiones específicas para Servidores »
  • PHP Manual
  • SphinxClient
  • Actualiza los atributos del documento

SphinxClient::updateAttributes

(PECL sphinx >= 0.1.0)

SphinxClient::updateAttributes — Actualiza los atributos del documento

Descripción

public SphinxClient::updateAttributes ( string $index , array $attributes , array $values , bool $mva = false ) : int

Actualiza al instante valores de los atributos en documentos dados.

Parámetros

index

Nombre del índice (o índices) para ser actualizado.

attributes

Array de nombres de atributos, lista de atributos que van a ser actualizados.

values

Array asociativo que contiene los ID de documento como claves y array de valores de los atributos como valores.

Valores devueltos

Devuelve el número de documentos actualizados (0 o más) en caso de éxito, o false en caso de error.


Extensiones específicas para Servidores

  • Apache
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Apache
  • FastCGI Process Manager
    • Introducción
    • Instalación/Configuración
    • FPM Funciones


Apache

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Apache
    • apache_child_terminate — Finaliza un proceso de Apache después de esta llamada
    • apache_get_modules — Obtiene una lista de los módulos cargados en el servidor Apache
    • apache_get_version — Obtiene la versión del servidor Apache
    • apache_getenv — Obtiene una variable del entorno subprocess_env de Apache
    • apache_lookup_uri — Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella
    • apache_note — Obtiene y establece las notas de petición de apache
    • apache_request_headers — Obtiene todas las cabeceras HTTP
    • apache_response_headers — Obtiene todas las cabeceras HTTP de respuesta
    • apache_setenv — Establece una variable subprocess_env de Apache
    • getallheaders — Recupera todas las cabeceras de petición HTTP
    • virtual — Realiza una sub-petición de Apache


Introducción

Estas funciones sólo están disponibles cuando se ejecuta PHP como módulo de Apache.


  • « Requerimientos
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

Para instalar PHP en Apache, vea el capítulo de instalación.


Configuración en tiempo de ejecución

El comportamiento del módulo de PHP de Apache está regido por los valores definidos en php.ini. Estos valores de configuración definidos en php.ini pueden ser sobreescritos por la configuración del php_flag definidos en el fichero de configuración del servidor o por los ficheros .htaccess locales.

Ejemplo #1 Desactivar el intérprete de PHP en un directorio utilizando .htaccess

php_flag engine off

Opciones de configuración de Apache
Nombre | Por defecto | Cambiable | Historial de cambios
engine | "1" | PHP_INI_ALL |
child_terminate | "0" | PHP_INI_ALL |
last_modified | "0" | PHP_INI_ALL |
xbithack | "0" | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

engine boolean

Activa o desactiva la ejecución de PHP. Esta directiva se puede utilizar sólo en la versión de PHP como módulo de Apache. Se usa en los sitios que deseen controlar la activación o desactivación del PHP en cada directorio o servidor virtual. Al establecer engine off en los lugares apropiados en el archivo httpd.conf, PHP puede ser activado o desactivado.

child_terminate boolean

Especifica si los scripts PHP pueden solicitar la finalización de los procesos hijos al finalizar la petición, véase también apache_child_terminate().

last_modified boolean

Envía la fecha de modificación de los scripts PHP con la cabecera 'Last-Modified:' para estas peticiones.

xbithack boolean

Analiza los ficheros con bit de ejecución establecido para PHP, con independencia de la extensión del fichero


  • « Tipos de recursos
  • Funciones de Apache »
  • PHP Manual
  • Apache
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Apache

Tabla de contenidos

  • apache_child_terminate — Finaliza un proceso de Apache después de esta llamada
  • apache_get_modules — Obtiene una lista de los módulos cargados en el servidor Apache
  • apache_get_version — Obtiene la versión del servidor Apache
  • apache_getenv — Obtiene una variable del entorno subprocess_env de Apache
  • apache_lookup_uri — Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella
  • apache_note — Obtiene y establece las notas de petición de apache
  • apache_request_headers — Obtiene todas las cabeceras HTTP
  • apache_response_headers — Obtiene todas las cabeceras HTTP de respuesta
  • apache_setenv — Establece una variable subprocess_env de Apache
  • getallheaders — Recupera todas las cabeceras de petición HTTP
  • virtual — Realiza una sub-petición de Apache


Finaliza un proceso de Apache después de esta llamada

  • « Funciones de Apache
  • apache_get_modules »
  • PHP Manual
  • Funciones de Apache
  • Finaliza un proceso de Apache después de esta llamada

apache_child_terminate

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

apache_child_terminate — Finaliza un proceso de Apache después de esta llamada

Descripción

apache_child_terminate ( ) : bool

apache_child_terminate() registrará el proceso Apache que esté ejecutando el requerimiento PHP actual para su finalización una vez que la ejecución del código haya finalizado. Puede ser utilizado para finalizar un proceso una vez que un script con un alto consumo de memoria haya sido ejecutado, dado que la memoria únicamente será liberada de forma interna, pero no será devuelta al sistema operativo.

Valores devueltos

Devuelve true si PHP está corriendo como módulo de Apache 1, la versión de Apache no es multi-hilo, y la directiva de PHP child_terminate está activada (desactivada por defecto). Si estas condiciones no se cumplen, se devuelve false y se genera un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.4.0 | Esta función está disponible bajo FastCGI. Anteriormente, estaba soportada solo cuando había sido instalado un módulo PHP en Apache.

Notas

Nota: Esta función no está implementada en plataformas Windows.

Ver también

  • exit() - Imprime un mensaje y termina el script actual


Obtiene una lista de los módulos cargados en el servidor Apache

  • « apache_child_terminate
  • apache_get_version »
  • PHP Manual
  • Funciones de Apache
  • Obtiene una lista de los módulos cargados en el servidor Apache

apache_get_modules

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

apache_get_modules — Obtiene una lista de los módulos cargados en el servidor Apache

Descripción

apache_get_modules ( ) : array

Obtiene una lista de los módulos cargados en el servidor Apache

Valores devueltos

Devuelve un array con la lista de los módulos cargados.

Ejemplos

Ejemplo #1 Ejemplo de apache_get_modules()

<?php
print_r(apache_get_modules());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)


Obtiene la versión del servidor Apache

  • « apache_get_modules
  • apache_getenv »
  • PHP Manual
  • Funciones de Apache
  • Obtiene la versión del servidor Apache

apache_get_version

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

apache_get_version — Obtiene la versión del servidor Apache

Descripción

apache_get_version ( ) : string

Obtiene la versión del servidor Apache.

Valores devueltos

Devuelve la versión del servidor Apache. o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de apache_get_version()

<?php
$version = apache_get_version();
echo "$version\n";
?>

El resultado del ejemplo sería algo similar a:

Apache/1.3.29 (Unix) PHP/4.3.4

Ver también

  • phpinfo() - Muestra información sobre la configuración de PHP


Obtiene una variable del entorno subprocess_env de Apache

  • « apache_get_version
  • apache_lookup_uri »
  • PHP Manual
  • Funciones de Apache
  • Obtiene una variable del entorno subprocess_env de Apache

apache_getenv

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_getenv — Obtiene una variable del entorno subprocess_env de Apache

Descripción

apache_getenv ( string $variable , bool $walk_to_top = false ) : string

Recupera una variable del entorno de Apache especificada en el parámetro variable.

Esta función requiere el uso de Apache 2, ya que de otra forma no está definida.

Parámetros

variable

La variable del entorno de Apache.

walk_to_top

Indica si se tiene que obtener la variable superior (de más alto nivel) disponible en todos los niveles de Apache.

Valores devueltos

Si tiene éxito devuelve el valor de la variable del entorno de Apache, si falla devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de apache_getenv()

Este ejemplo muestra cómo obtener el valor de la variable SERVER_ADDR del entorno de ejecución de Apache.

<?php
$ret = apache_getenv("SERVER_ADDR");
echo $ret;
?>

El resultado del ejemplo sería algo similar a:

42.24.42.240

Ver también

  • apache_setenv() - Establece una variable subprocess_env de Apache
  • getenv() - Obtiene el valor de una variable de entorno
  • Superglobals


Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella

  • « apache_getenv
  • apache_note »
  • PHP Manual
  • Funciones de Apache
  • Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella

apache_lookup_uri

(PHP 4, PHP 5, PHP 7, PHP 8)

apache_lookup_uri — Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella

Descripción

apache_lookup_uri ( string $filename ) : object

Esta función realiza una petición parcial por una URI. Por si sola no es suficiente para obtener toda la información importante del recurso dado.

Esta función está soportada sólo cuando PHP está instalado como un módulo de Apache.

Parámetros

filename

El nombre de archivo (URI) que está siendo solicitado.

Valores devueltos

Un object con información de la URI solicitada. Las propiedades de este object son:

  • status
  • the_request
  • status_line
  • method
  • content_type
  • handler
  • uri
  • filename
  • path_info
  • args
  • boundary
  • no_cache
  • no_local_copy
  • allowed
  • send_bodyct
  • bytes_sent
  • byterange
  • clength
  • unparsed_uri
  • mtime
  • request_time

Ejemplos

Ejemplo #1 apache_lookup_uri() example

<?php
$info = apache_lookup_uri('index.php?var=value');
print_r($info);

if (file_exists($info->filename)) {
    echo 'file exists!';
}
?>

El resultado del ejemplo sería algo similar a:

stdClass Object
(
    [status] => 200
    [the_request] => GET /dir/file.php HTTP/1.1
    [method] => GET
    [mtime] => 0
    [clength] => 0
    [chunked] => 0
    [content_type] => application/x-httpd-php
    [no_cache] => 0
    [no_local_copy] => 1
    [unparsed_uri] => /dir/index.php?var=value
    [uri] => /dir/index.php
    [filename] => /home/htdocs/dir/index.php
    [args] => var=value
    [allowed] => 0
    [sent_bodyct] => 0
    [bytes_sent] => 0
    [request_time] => 1074282764
)
file exists!


Obtiene y establece las notas de petición de apache

  • « apache_lookup_uri
  • apache_request_headers »
  • PHP Manual
  • Funciones de Apache
  • Obtiene y establece las notas de petición de apache

apache_note

(PHP 4, PHP 5, PHP 7, PHP 8)

apache_note — Obtiene y establece las notas de petición de apache

Descripción

apache_note ( string $note_name ) : string
apache_note ( string $note_name , string $note_value ) : string

Esta función es una envoltura para las instrucciones table_get y table_set de Apache. Edita las tablas de notas que existen durante una petición. El propósito de la tabla es permitir la comunicación entre módulos de Apache.

El principal uso de apache_note() es el paso de información desde un módulo a otro en el interior de la misma petición.

Parámetros

note_name

El nombre de la nota.

note_value

El valor de la nota.

Valores devueltos

Si es llamada con un argumento, devuelve el valor actual de la nota note_name. Si es llamada con dos argumentos, define el valor de la nota note_name to note_value y devuelve el valor previo de la nota note_name. Si la nota no puede ser recuperada, se devuelve false.

Ejemplos

Ejemplo #1 Paso de información entre PHP y Perl

<?php

apache_note('name', 'Fredrik Ekengren');

// Llamada al script de Perl
virtual("/perl/some_script.pl");

$result = apache_note("resultdata");
?>
# Obtiene un objeto de petición de Apache
my $r = Apache->request()->main();

# Obtiene los datos pasados
my $name = $r->notes('name');

# ... proceso de los datos ...

# Devuelve el resultado a PHP
$r->notes('resultdata', $result);

Ejemplo #2 Registro de valores en access.log

<?php

apache_note('sessionID', session_id());

?>
# "%{sessionID}n" puede ser usado en la directiva LogFormat

Ver también

  • virtual() - Realiza una sub-petición de Apache


Obtiene todas las cabeceras HTTP

  • « apache_note
  • apache_response_headers »
  • PHP Manual
  • Funciones de Apache
  • Obtiene todas las cabeceras HTTP

apache_request_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_request_headers — Obtiene todas las cabeceras HTTP

Descripción

apache_request_headers ( ) : array

Obtiene todas las cabeceras de petición HTTP de la llamada actual. Funciona con Apache, FastCGI, CLI, y servidores Web FPM.

Valores devueltos

Devuelve un array asociativo de todas las cabeceras HTTP en la petición actual, o false en caso de fallo.

Historial de cambios

Versión | Descripción
7.3.0 | Esta función se hizo disponible en el SAPI de FPM.

Ejemplos

Ejemplo #1 Ejemplo de apache_request_headers()

<?php
$headers = apache_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

El resultado del ejemplo sería algo similar a:

Accept: */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0
Host: www.example.com
Connection: Keep-Alive

Notas

Nota:

También se puede obtener el valor de las variables CGI comunes a partir de las variables de entorno, lo cual funciona independientemente de que se esté utilizando PHP como un módulo de Apache. Use phpinfo() para ver la lista de todas las variables de entorno disponibles.

Ver también

  • apache_response_headers() - Obtiene todas las cabeceras HTTP de respuesta


Obtiene todas las cabeceras HTTP de respuesta

  • « apache_request_headers
  • apache_setenv »
  • PHP Manual
  • Funciones de Apache
  • Obtiene todas las cabeceras HTTP de respuesta

apache_response_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_response_headers — Obtiene todas las cabeceras HTTP de respuesta

Descripción

apache_response_headers ( ) : array|false

Obtiene todas las cabeceras HTTP de respuesta. Funciona con Apache, FastCGI, CLI, y servidores Web FPM.

Valores devueltos

Devuelve una matriz con todas las cabeceras de respuesta de Apache o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de apache_response_headers()

<?php
print_r(apache_response_headers());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [Accept-Ranges] => bytes
    [X-Powered-By] => PHP/4.3.8
)

Ver también

  • apache_request_headers() - Obtiene todas las cabeceras HTTP
  • headers_sent() - Comprueba si o donde han enviado cabeceras
  • headers_list() - Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)


Establece una variable subprocess_env de Apache

  • « apache_response_headers
  • getallheaders »
  • PHP Manual
  • Funciones de Apache
  • Establece una variable subprocess_env de Apache

apache_setenv

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

apache_setenv — Establece una variable subprocess_env de Apache

Descripción

apache_setenv ( string $variable , string $value , bool $walk_to_top = false ) : bool

apache_setenv() establece el valor de la variable de entorno de Apache especificado por variable.

Nota:

Al establecer una variable de entorno de Apache, la correspondiente variable $_SERVER no se modifica.

Parámetros

variable

La variable de entorno que se desea establecer.

value

El nuevo valor de variable.

walk_to_top

Indica si se va a establecer la variable de nivel superior disponible para todas las capas de Apache.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estableciendo una variable de entorno de Apache usando apache_setenv()

<?php
apache_setenv("VARIABLE_EJEMPLO", "Valor de ejemplo");
?>

Notas

Nota:

apache_setenv() puede ser utilizado con apache_getenv() en páginas separadas o para establecer variables para pasar Server Side Includes (.shtml) que hayan sido incluidos en sprits PHP.

Ver también

  • apache_getenv() - Obtiene una variable del entorno subprocess_env de Apache


Recupera todas las cabeceras de petición HTTP

  • « apache_setenv
  • virtual »
  • PHP Manual
  • Funciones de Apache
  • Recupera todas las cabeceras de petición HTTP

getallheaders

(PHP 4, PHP 5, PHP 7, PHP 8)

getallheaders — Recupera todas las cabeceras de petición HTTP

Descripción

getallheaders ( ) : array

Recupera todas las cabeceras HTTP de la petición actual.

Esta función es un alias de apache_request_headers(). Por favor lea la documentación de apache_request_headers() para obtener más información sobre cómo trabaja esta función.

Valores devueltos

Un array asociativo de todas las cabeceras HTTP en la petición actual, o false en caso de fallo.

Historial de cambios

Versión | Descripción
7.3.0 | Esta función se hizo disponible en el SAPI de FPM.

Ejemplos

Ejemplo #1 Ejemplo de getallheaders()

<?php

foreach (getallheaders() as $nombre => $valor) {
    echo "$nombre: $valor\n";
}

?>

Ver también

  • apache_response_headers() - Obtiene todas las cabeceras HTTP de respuesta


Realiza una sub-petición de Apache

  • « getallheaders
  • FastCGI Process Manager »
  • PHP Manual
  • Funciones de Apache
  • Realiza una sub-petición de Apache

virtual

(PHP 4, PHP 5, PHP 7, PHP 8)

virtual — Realiza una sub-petición de Apache

Descripción

virtual ( string $filename ) : bool

virtual() es una función específica de Apache que es similar a <!--#include virtual...--> en mod_include. Realiza una sub-petición de Apache. Es útil para incluir scripts CGI o archivos .shtml, o cualquier otra cosa que quisiera procesar a través de Apache. Note que para un script CGI, el script debe generar cabeceras CGI válidas. Esto quiere decir que, por lo menos, debe generar una cabecera Content-Type.

Para ejecutar la sub-petición, todos los búferes son terminados y volcados al navegador, y las cabeceras pendientes son enviadas también.

Esta función está soportada sólo cuando PHP está instalado como un módulo de Apache.

Parámetros

filename

El archivo sobre el que se efectuará el comando virtual.

Valores devueltos

Ejecuta el comando virtual en caso de éxito, o devuelve false si ocurre un error.

Ejemplos

Vea apache_note() para un ejemplo.

Notas

Advertencia

La cadena de petición puede ser pasada al archivo incluido pero la variable $_GET es copiada desde el script padre, y solo $_SERVER['QUERY_STRING'] se llena con la cadena de query pasada. Puede que la cadena query sólo pueda ser pasada cuando se usa Apache 2. El archivo solicitado no será listado en el archivo de registro (log) access de Apache.

Nota:

Las variables de entorno definidas en el archivo solicitado no están disponibles desde el script que hace el llamado.

Nota:

Esta función puede utilizarse con ficheros de PHP. Sin embargo, normalmente es mejor emplear include o require para ficheros de PHP.

Ver también

  • apache_note() - Obtiene y establece las notas de petición de apache


FastCGI Process Manager

  • Introducción
  • Instalación/Configuración
  • FPM Funciones
    • fastcgi_finish_request — Flushes all response data to the client


Introducción

FPM (FastCGI Process Manager) is an alternative PHP FastCGI implementation with some additional features (mostly) useful for heavy-loaded sites.

This SAPI is bundled with PHP 5.3.3 and later.


Instalación/Configuración

Information on installing and configuring FPM can be found in the installation and configuration section of the PHP manual.


  • « Instalación/Configuración
  • fastcgi_finish_request »
  • PHP Manual
  • FastCGI Process Manager
  • FPM Funciones

FPM Funciones

Tabla de contenidos

  • fastcgi_finish_request — Flushes all response data to the client


Flushes all response data to the client

  • « FPM Funciones
  • Extensiones de sesiones »
  • PHP Manual
  • FPM Funciones
  • Flushes all response data to the client

fastcgi_finish_request

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

fastcgi_finish_request — Flushes all response data to the client

Descripción

fastcgi_finish_request ( ) : boolean

This function flushes all response data to the client and finishes the request. This allows for time consuming tasks to be performed without leaving the connection to the client open.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Extensiones de sesiones

  • Sesiones — Manejo de sesiones
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Progreso de Subida en Sesiones
    • Sesiones y seguridad
    • Funciones de sesión
    • SessionHandler — La clase SessionHandler
    • SessionHandlerInterface — La clase SessionHandlerInterface
    • SessionIdInterface — The SessionIdInterface interface
    • SessionUpdateTimestampHandlerInterface — The SessionUpdateTimestampHandlerInterface interface


Manejo de sesiones

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico
    • Pasar el ID de Sesión
    • Gestores de Sesión Personalizados
  • Progreso de Subida en Sesiones
  • Sesiones y seguridad
  • Funciones de sesión
    • session_abort — Desecha los cambios en el array de sesión y finaliza la sesión
    • session_cache_expire — Devuelve la caducidad de la caché actual
    • session_cache_limiter — Obtener y/o establecer el limitador de caché actual
    • session_commit — Alias de session_write_close
    • session_create_id — Crear un nuevo ID de sesión
    • session_decode — Decodifica la información de sesión desde una cadena de sesión codificada
    • session_destroy — Destruye toda la información registrada de una sesión
    • session_encode — Codifica los datos de la sesión actual como un string codificado de sesión
    • session_gc — Realizar una recolección de basura de datos de sesión
    • session_get_cookie_params — Obtener los parámetros de la cookie de sesión
    • session_id — Obtener y/o establecer el id de sesión actual
    • session_is_registered — Averiguar si una variable global está registrada en una sesión
    • session_module_name — Obtiene y/o establece el módulo de sesión actual
    • session_name — Obtener y/o establecer el nombre de la sesión actual
    • session_regenerate_id — Actualiza el id de sesión actual con uno generado más reciente
    • session_register_shutdown — Función de cierre de sesiones
    • session_reset — Reinicializar el array de sesión con los valores originales
    • session_save_path — Obtener y/o establecer la ruta de almacenamiento de la sesión actual
    • session_set_cookie_params — Establecer los parámetros de la cookie de sesión
    • session_set_save_handler — Establece funciones de almacenamiento de sesiones a nivel de usuario
    • session_start — Iniciar una nueva sesión o reanudar la existente
    • session_status — Devuelve el estado de la sesión actual
    • session_unregister — Deja de registrar una variable global de la sesión actual
    • session_unset — Libera todas las variables de sesión
    • session_write_close — Escribir información de sesión y finalizar la sesión
  • SessionHandler — La clase SessionHandler
    • SessionHandler::close — Cerrar la sesión
    • SessionHandler::create_sid — Devuelve un nuevo ID de sesión
    • SessionHandler::destroy — Destruir una sesión
    • SessionHandler::gc — Eliminar las sesiones antiguas
    • SessionHandler::open — Inicializar una sesión
    • SessionHandler::read — Leer información de la sesión
    • SessionHandler::write — Escribir información de sesión
  • SessionHandlerInterface — La clase SessionHandlerInterface
    • SessionHandlerInterface::close — Cerrar la sesión
    • SessionHandlerInterface::destroy — Destruir una sesión
    • SessionHandlerInterface::gc — Limpieza de sesiones antiguas
    • SessionHandlerInterface::open — Inicializar una sesión
    • SessionHandlerInterface::read — Leer información de sesión
    • SessionHandlerInterface::write — Escribir información de sesión
  • SessionIdInterface — The SessionIdInterface interface
    • SessionIdInterface::create_sid — Create session ID
  • SessionUpdateTimestampHandlerInterface — The SessionUpdateTimestampHandlerInterface interface
    • SessionUpdateTimestampHandlerInterface::updateTimestamp — Update timestamp
    • SessionUpdateTimestampHandlerInterface::validateId — Validate ID


Introducción

El soporte para sesiones en PHP consiste en una forma de preservar cierta información a lo largo de accesos subsiguientes.

A un visitante que accede a un sitio web se le asigna un id único, también llamado id de sesión. Éste es almacenado en una cookie en la parte del cliente o se propaga en el URL.

El soporte para sesiones permite almacenar los datos entre peticiones en el array superglobal $_SESSION. Cuando un visitante acceda a un sitio web, PHP comprobará automáticamente (si session.auto_start está establecido a 1), o sobre su petición (explícitamete a través de session_start()), si se ha enviado un id de sesión específico con la petición. Si éste es el caso, se recrea el entorno anteriormente guardado.

Precaución

Si se activa session.auto_start, la única manera de colocar objetos en las sesiones es cargar su definición de clase usando auto_prepend_file , en el que, además de cargar la definición de clase, se tendrá que emplear serialize() para serializar el objeto y unserialize() para deserializarlo después.

$_SESSION (y todas las variables registradas) son serializadas internamente por PHP utilizando el gestor de serialización especificado en el ajuste ini session.serialize_handler, una vez finalizada la solicitud. Las variables registradas que están sin definir son marcadas como no definidas. En accesos subsiguientes, éstas no estarán definidas por el módulo de sesión a menos que el usuario las defina después.

Advertencia

Debido a que los datos de sesión son serializados, las variables resource no pueden ser almacenadas en la sesión.

Los gestortes serializados (php y php_binary) heredan las limitaciones de register_globals. Por lo tanto, no se pueden usar índices númericos o de string que contengan los caracteres especiales (| y !). Si se utilizan, se finalizará con errores al cierre del script. php_serialize no tiene tales limitaciones. php_serialize está disponible desde PHP 5.5.4.

Nota:

Por favor, observe que al trabajar con sesiones, no se crea un registro de una sesión hasta que una variable haya sido registrada usando la función session_register() o añadiendo una nueva clave al array superglobal $_SESSION. Esto siempre es así, sin importar si una sesión ha sido iniciada usando la función session_start().

Nota:

PHP 5.2.2 introdujo una característica no documentada para almacenar ficheros de sesiones en "/tmp" incluso si open_basedir estaba habilitado y "/tmp" no estaba explícitamente añadido a la lista de rutas permitidas. Esta característica ha sido eliminada de PHP a partir de PHP 5.3.0.


Requerimientos

No se requiere de ninguna biblioteca externa para compilar esta extensión.

Nota:

Opcionalmente se puede usar asignación de memoria compartida (mm), desarrollada por Ralf S. Engelschall, para el almacenamiento de sesiones. Tiene que descargar » mm e instalarlo. Esta opción no está disponible en plataformas Windows. Observe que el módulo de almacenamiento de sesiones para mm no garantiza que los accesos concurrentes a la misma sesión estén debidamente bloqueados. Podría ser más apropiado usar una memoria compartida basada en sistemas de archivos (como tmpfs en Solaris/Linux, o /dev/md en BSD) para almacenar sesiones en archivos, ya que están debidamente bloqueados. La información de la sesión se almacena en memoria por lo que un reinicio del servidor web la borrará.


Instalación

El soporte para sesiones está habilitado por defecto en PHP. Si no quiere construir su PHP con soporte para sesiones, debería especificar la opción --disable-session para la configuración. Para usar la asignación de memoria compartida (mm) para el almacenamiento de sesiones, configure PHP con --with-mm[=DIR] .

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.

Nota:

Por defecto, toda la información relacionada con una sesión en particular será almacenada en un archivo en el directorio especificado por la opción INI session.save_path. Se creará un archivo para cada sesión (sin tener en cuenta si ninguna información está asociada con esa sesión). Esto es debido al hecho de que una sesión es abierta (se crea un archivo) aunque incluso no se escriba información en ese archivo. Observe que este comportamiento es un efecto secundario de las limitaciones de trabajar con el sistema de archivos y es posible que un gestor de sesión personalizado (tal como uno que use una base de datos) no lleve la cuenta de sesiones que no almacenan información.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de sesión
Nombre | Por defecto | Cambiable | Historial de cambios
session.save_path | "" | PHP_INI_ALL |
session.name | "PHPSESSID" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.auto_start | "0" | PHP_INI_PERDIR |
session.gc_probability | "1" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL | Disponible desde PHP 4.3.2.
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL | Disponible desde PHP 4.0.4.
session.cookie_httponly | "" | PHP_INI_ALL | Disponible desde PHP 5.2.0.
session.use_strict_mode | "0" | PHP_INI_ALL | Disponible desde PHP 5.5.2.
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
session.referer_check | "" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cache_expire | "180" | PHP_INI_ALL |
session.use_trans_sid | "0" | PHP_INI_ALL | PHP_INI_ALL en PHP <= 4.2.3. PHP_INI_PERDIR en PHP < 5. Disponible desde PHP 4.0.3.
session.trans_sid_tags | "a=href,area=href,frame=src,form=" | PHP_INI_ALL | Disponible desde PHP 7.1.0.
session.trans_sid_hosts | $_SERVER['HTTP_HOST'] | PHP_INI_ALL | Disponible desde PHP 7.1.0.
session.sid_length | "32" | PHP_INI_ALL | Disponible desde PHP 7.1.0.
session.sid_bits_per_character | "5" | PHP_INI_ALL | Disponible desde PHP 7.1.0.
session.upload_progress.enabled | "1" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.upload_progress.cleanup | "1" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.upload_progress.prefix | "upload_progress_" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.upload_progress.name | "PHP_SESSION_UPLOAD_PROGRESS" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.upload_progress.freq | "1%" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.upload_progress.min_freq | "1" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0.
session.lazy_write | "1" | PHP_INI_ALL | Disponible desde PHP 7.0.0.
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | Disponible desde PHP 4.0.4. Desde PHP 7.1.0 este INI ya no se utiliza en sesiones.
session.hash_function | "0" | PHP_INI_ALL | Disponible desde PHP 5.0.0. Eliminado en PHP 7.1.0
session.hash_bits_per_character | "4" | PHP_INI_ALL | Disponible desde PHP 5.0.0. Eliminado en PHP 7.1.0
session.entropy_file | "" | PHP_INI_ALL | Eliminado en PHP 7.1.0.
session.entropy_length | "0" | PHP_INI_ALL | Eliminado en PHP 7.1.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

El sistema de administración de sesiones admite varias opciones de configuración que se pueden colocar en el fichero php.ini. Se dará una visión general breve.

session.save_handler string
session.save_handler define el nombre del gestor que se usa para almacenar y recuperar información asociada con una sesión. Por defecto es files. Observe que las extensiones individuales pueden registrar sus propios gestores save_handler; los gestores registrados se pueden obtener a nivel de instalación consultando phpinfo(). Véase también session_set_save_handler().
session.save_path string
session.save_path define el argumento que es pasado al gestor de almacenamiento. Si se elige el gestor de archivos por defecto, éste es la ruta donde los archivos son creados. Véase también session_save_path().

Hay un argumento opcional N para esta directiva que determina el número de niveles de directorios por donde los archivos de sesión se desplegarán. Por ejemplo, establecerlo a '5;/tmp' puede terminar en crear un archivo de sesión y ubicación como /tmp/4/b/1/e/3/sess_4b1e384ad74619bd212e236e52a5a174If . Para usar N se deben crear todos estos directorios antes de utilizarlo. Para realizar esto, existe un pequeño script tipo shell en ext/session que se llama mod_files.sh, con una versión de Windows llamada mod_files.bat. Observe también que si N se usa y es más grande que 0 no se llevará a cabo la recolección de basura automática, vea una copia de php.ini para más información. También, si usa N, asegúrese de encerrar session.save_path entre "comillas" ya que el separador (;) también se usa para comentarios en php.ini.

El módulo de almacenamiento de ficheros crea ficheros usando el modo 600 de forma predeterminada. Este valor se puede cambiar con el argumento opcional MODE: N;MODE;/path, donde MODE es la representación octal del modo. Establecer MODE no afecta al proceso umask.

Advertencia

Si se deja esta configuración para un directorio legilble por todo el mundo, tal como /tmp (por defecto), otros usuarios en el servidor pueden ser capaces de secuestrar sesiones obteniendo la lista de archivos de ese directorio.

Precaución

Al emplear el argumento opcional de nivel de directorio N, como está descrito arriba, observe que al utilizar un valor mayor que 1 o 2 no es apropiado para la mayoría de los sitios debido al gran número de directorios requeridos: por ejemplo, un valor de 3 implica que existen 64^3 directorios en el sistema de ficheros, lo que puede resultar en un gran despredicio de escpacio e inodos.

Utilice solamente N con un valor mayor que 2 si está absolutamente seguro de que el sitio es lo suficientemente grande para requerirlo.

Nota: Antes de PHP 4.3.6, los usuarios de Windows tenían que cambiar esta variable para usar las funciones de sesiones de PHP. Se debe especificar una ruta válida, p.ej.: c:/temp.

session.name string
session.name specifica el nombre de la sesión que se usa como nombre de cookie. Sólo debería contener caracteres alfanuméricos. Por defecto es PHPSESSID. Véase también session_name().
session.auto_start boolean
session.auto_start especifica si el módulo de sesión inicia una sesión automáticamente cuando arranque una petición. Por defecto es 0 (deshabilitado).
session.serialize_handler string
session.serialize_handler define el nombre del manejador que se usa para serializar/deserializar datos. El formato de serialización de PHP (nombre php_serialize), formatos de internos de PHP (nombre php y php_binary) y WDDX son admitidos (nombre wddx). WDDX solamente está disponible si PHP está compilado con soporte para WDDX. php_serialize está disponible desde PHP 5.5.4. php_serialize usa internamente una función pura de serialización/deserialización y no tiene las limitaciones que tienen php y php_binary. Los gestores de serialización más antiguos no pueden almacenar índices numéricos ni de string que contengan caracters especiales (| y !) en $_SESSION. Use php_serialize para evitar errores con índices numéricos o caracteres especiales al cierre del script. Lo predeterminado es php.
session.gc_probability integer
session.gc_probability se usa junto con session.gc_divisor para manejar la probabilidad de que la rutina de gc (garbage collection, recolección de basura) está iniciada. Por defecto es 1. Véase session.gc_divisor para más detalles.
session.gc_divisor integer
session.gc_divisor junto con session.gc_probability define la probabilidad de que el proceso de gc (garbage collection, recolección de basura) esté iniciado en cada inicialización de sesión. La probabilidad se calcula usando gc_probability/gc_divisor, p.ej. 1/100 significa que hay un 1% de probabilidad de que el proceso de GC se inicie en cada petición. session.gc_divisor por defecto es 100.
session.gc_maxlifetime integer
session.gc_maxlifetime especifica el número de segundos después de lo cual la información sea vista como 'basura' y potencialmente limpiada. La recolección de basura puede suceder durante el inicio de sesiones (dependiendo de session.gc_probability y session.gc_divisor).

Nota: Si diferentes scripts tienen diferentes valores de session.gc_maxlifetime pero comparten la misma ubicación para almacenar la información de sesión, la información del script con el mínimo valor será limpiada. En este caso use esta directiva junto con session.save_path.

session.referer_check string
session.referer_check contiene la subcadena para comprobar cada HTTP Referer. Si la Referencia fue enviada por el cliente y la subcadena no se encontró, el id de sesión embebido será marcado como no válido. Por defecto es una cadena vacía.
session.entropy_file string
session.entropy_file da una ruta a un recurso externo (archivo) que será usado como una fuente de entropía adicional en el proceso de creación del id de sesión. Ejemplos: /dev/random o /dev/urandom que están disponibles en la mayoría de sistemas Unix. Esta función está disponible en Windows desde PHP 5.3.3. Si se establece session.entropy_length a un valor que no sea cero hará que PHP use la Windows Random API como fuente entrópica.

Nota: Eliminado en PHP 7.1.0. A partir de PHP 5.4.0 session.entropy_file usa de forma predeterminada /dev/urandom o /dev/arandom si están disponibles. En PHP 5.3.0, esta directiva se deja vacía por omisión.

session.entropy_length integer
session.entropy_length especifica el número de bytes que serán leídos desde el archivo especificado arriba. Por defecto es 32. Eliminado en PHP 7.1.0.
session.use_strict_mode boolean
session.use_strict_mode especifica si el módulo usará el modo de id de sesión estricto. Si este modo está habilitado, el módulo no aceptará IDs de sesioines no inicializados. Si se envia desde el navegador un ID de sesión no inicializado, se envía un nuevo ID de sesión al navegador. Las aplicaciones están protegidas de la fijación de sesiones mediante la adopción de sesión con modo estricto. El valor predeterminado es 0 (deshabilitado).

Nota: Es obligatoria habilitar session.use_strict_mode por seguridad general de sesión. Todos los sitios están advertidos de esto. Véase el código de ejemplo de session_create_id() para más detalles.

session.use_cookies boolean
session.use_cookies especifica si el módulo usará cookies para almacenar el id de sesión en la parte del cliente. Por defecto es 1 (habilitado).
session.use_only_cookies boolean
session.use_only_cookies especifica si el módulo sólo usará cookies para almacenar el id de sesión en la parte del cliente. Habilitar este ajuste previene ataques que implican pasar el id de sesión en la URL. Este ajuste fue añadido en PHP 4.3.0. Por defecto es 1 (habilitado) desde PHP 5.3.0.
session.cookie_lifetime integer
session.cookie_lifetime especifica el tiempo de vida en segundos de la cookie que es enviada al navegador. El valor 0 significa "hasta que el navegador se cierre". Por defecto es 0. Véase también session_get_cookie_params() y session_set_cookie_params().

Nota: La marca de tiempo de caducidad se establece relativa a la hora del servidor, la cúal no es necesariamente la misma que la hora del navegador del cliente.

session.cookie_path string
session.cookie_path especifica la ruta a establecer en la cookie de sesión. Por defecto es /. Véase también session_get_cookie_params() y session_set_cookie_params().
session.cookie_domain string
session.cookie_domain especifica el dominio a establecer en la cookie de sesión. Por defecto es ninguno, significando el nombre de host del servidor que generó la cookie según la especificación de cookies. Véase también session_get_cookie_params() y session_set_cookie_params().
session.cookie_secure boolean
session.cookie_secure especifica si las cookies deberían enviarse sólo sobre conexiones seguras. Por defecto es off. Este ajuste fue añadido en PHP 4.0.4. Véase también session_get_cookie_params() y session_set_cookie_params().
session.cookie_httponly boolean
Marca la cookie como accesible sólo a través del protocolo HTTP. Esto siginifica que la cookie no será accesible por lenguajes de script, tales como JavaScript. Este ajuste puede ayudar de manera efectiva a reducir robos de indentidad a través de ataques (aunque no está soportado por todos los navegadores).
session.cache_limiter string
session.cache_limiter especifica el método de control de caché usado por páginas de sesión. Puede ser uno de los siguientes valores: nocache, private, private_no_expire, o public. Por defecto es nocache. Vea también la documentación de session_cache_limiter() para informarse sobre lo que significan estos valores.
session.cache_expire integer
session.cache_expire especifica el tiempo de vida en minutos para las páginas de sesión examinadas, esto no tiene efecto para el limitador nocache. Por defecto es 180. Véase también session_cache_expire().
session.use_trans_sid boolean
session.use_trans_sid si está habilitado sid transparente o no. Por defecto es 0 (deshabilitado).

Nota: La administración de sesiones basadas en URL tiene riesgos de seguridad adicionales comparada con la administración de sesiones basdas en cookies. Los usuarios pueden enviar una URL que contenga un ID de sesión activo a sus amigos mediante email o los usuarios pueden guardar una URL que contenga una ID de sesión en sus marcadores y acceder a su sitio siempre con el mismo ID de sesión, por ejemplo. Desde PHP 7.1.0, una ruta de URL completa, p.ej. https://php.net/, es manejada por la característa trans sid. Versiones anteriores de PHP manejaban únicamente rutas de URL relativas. Los 'hosts' objetivos de reescritura están definidos por session.trans_sid_hosts.

session.trans_sid_tags string
session.trans_sid_tags especifica cuáles etiquetas HTML son reescritas para incluir el ID de sesión cuando está habilitado el soporte para SID transparente. Las predeterminadas son a=href,area=href,frame=src,input=src,form= form es una etiqueta especial. <input hidden="id_sesión" name="nombre_sesión"> se añade como variable de formulario.

Nota: Antes de PHP 7.1.0, url_rewriter.tags se utilizaba para este propósito. Desde 7.1.0, fieldset ya no se considera una etiqueta especial.

session.trans_sid_hosts string
session.trans_sid_hosts especifica los hosts que se reescriben para incluir el ID de sesión cuando el soporte para SID transparente está habilitado. El predeterminado es $_SERVER['HTTP_HOST'] Se pueden especificar varios hosts mediante ",", y no se permiten espacios entre hosts. P.ej. php.net,wiki.php.net,bugs.php.net
session.sid_length integer
session.sid_length permite especificar la longitud de la cadena del ID de sesión. Esta longitud puede estar entre 22 y 256. El valor predeterminado es 32. Si es necesaria compatibilidad se puede especificar 32, 40, etc. Los ID de sesión más largos son más difíciles de adivinar. Se recomienda al menos 32 caracteres.

Nota sobre la compatibilidad: Use 32 para
session.hash_func=0 (MD5) y
session.hash_bits_per_character=4,
session.hash_func=1 (SHA1) y
session.hash_bits_per_character=6. Use 26 para
session.hash_func=0 (MD5) y
session.hash_bits_per_character=5. Use 22 para
session.hash_func=0 (MD5) y
session.hash_bits_per_character=6. Se deben
cofigurar valores INI para tener al menos 128 bits en ID de sesión. No
olvide establecer el valor apropiado en
session.sid_bits_per_character, de lo contrario se
tendrá un ID de sesión más débil.

Nota: Este ajuste se introdujo en PHP 7.1.0.

session.sid_bits_per_character integer
session.sid_per_character permite especificar el número de bits en caracteres de ID de sesión codificados. Los valores posibles son '4' (0-9, a-f), '5' (0-9, a-v), y '6' (0-9, a-z, A-Z, "-", ","). El predeterminado es 4. Cuantos más bits, más fuerte es el ID de sesión. Se recomienda 5 para la mayoría de entornos.

Nota: Este ajuste se introdujo en PHP 7.1.0.

session.hash_function mixed
session.hash_function permite especificar el algoritmo hash utilizado para generar los ID de sesión. '0' significa MD5 (128 bits) y '1' significa SHA-1 (160 bits).

Desde PHP 5.3.0 también es posible especificar cualquier algoritmo porporcionado por la extensión hash (si está disponible), como sha512 o whirlpool. Una lista completa de los algoritmos soportados se puede obtener con la función hash_algos().

Nota: Este ajuste fue introducido en PHP 5.

session.hash_bits_per_character integer
session.hash_bits_per_character permite definir cuántos bits son almacenados en cada carácter cuando se convierte la información hash binaria a algo legible. Los valores posibles son '4' (0-9, a-f), '5' (0-9, a-v), y '6' (0-9, a-z, A-Z, "-", ",").

Nota: Esto fue introducido en PHP 5. Eliminado en PHP 7.1.0

session.upload_progress.enabled boolean
Habilita el seguimiento del progreso de subida de ficheros, rellenado la variable $_SESSION. Por omisión su valor es 1, habilitado.
session.upload_progress.cleanup boolean
Limpieza de la información del progreso al finalizar la lectura de los datos del POST (p.ej. al finalizar la subida). Por omisión su valor es 1, habilitado.

Nota: Es muy recomendado mantener esta opción habilitada.

session.upload_progress.prefix string
Prefijo usado para la clave del progreso de subida en $_SESSION. Esta clave será concatenada con el valor de $_POST[ini_get("session.upload_progress.name")] para proporcionar un índice único. Por omisión su valor es "upload_progress_".
session.upload_progress.name string
El nombre de la clave a usar en $_SESSION para guardar la información del progreso de subida. Ver también session.upload_progress.prefix. Si no se pasa $_POST[ini_get("session.upload_progress.name")] o no está disponible, el progreso de subida no será grabado. Por omisión su valor es"PHP_SESSION_UPLOAD_PROGRESS".
session.upload_progress.freq mixed
Determina cada cuanto debería actualizarse la información del proceso de subida. Este valor puede ser definido en bytes (p.ej. "actualiza la información del progreso de subida después de cada 100 bytes"), o en porcentajes (p.ej. "actualiza la información del proceso de subida después de recibir el 1% del total del tamaño del fichero"). Por omisión "1%".
session.upload_progress.min-freq integer
El retraso mínimo entre actualizaciones, en segundos. Por omisión su valor es "1" (un segundo).
session.lazy_write boolean
session.lazy_write, cuando está establecida a 1, significa que los datos de sesión solamente son rescritos si cambian. El valor predeterminado es 1, habilitado.

El progreso de subida no será registrado a no ser que session.upload_progress.enabled esté habilitado, y la variable $_POST[ini_get("session.upload_progress.name")] esté definida. Ver Session Upload Progress para más información de como funciona.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SID (string)
Constante que contiene el nombre de la sesión y el ID de sesión en la forma "name=ID" o una cadena vacía si el ID de sesión fue establecido en una cookie de sesión apropiada. Este es el mismo id que uno devuelto por session_id().
PHP_SESSION_DISABLED (int)
Desde PHP 5.4.0. Devolver el valor de la función session_status() si las sesiones están deshabilitadas.
PHP_SESSION_NONE (int)
Desde PHP 5.4.0. Devolver el valor de la función session_status() si las sesiones están habilitadas, pero no existe una sesión.
PHP_SESSION_ACTIVE (int)
Devolver el valor de la función session_status() si las sesiones están habilitadas, y existe una sesión.


Ejemplos

Tabla de contenidos

  • Uso básico
  • Pasar el ID de Sesión
  • Gestores de Sesión Personalizados


Uso básico

Las sesiones son una forma sencilla de almacenar datos para usuarios de manera individual usando un ID de sesión único. Esto se puede usar para hacer persistente la información de estado entre peticiones de páginas. Los ID de sesiones normalmente son enviados al navegador mediante cookies de sesión, y el ID se usa para recuperar los datos de sesión existente. La ausencia de un ID o una cookie de sesión permite saber a PHP para crear una nueva sesión y generar un nuevo ID de sesión.

Las sesiones siguen un flujo de trabajo sencillo. Cuando una sesión se inicia, PHP recuperará una sesión existente usando el ID pasado (normalmente desde una cookie de sesión) o, si no se pasa una sesión, se creará una sesión nueva. PHP rellenará la variable superglobal $_SESSION con cualesquiera datos de la sesión iniciada. Cuando PHP se cierra, automáticamente toma el contenido de la variable superglobal $_SESSION, la serializa, y la envía para almacenarla usando el gestor de almacenamiento de sesiones.

Por omisión, PHP usa el gestor interno de almacenamiento files, el cual se establece mediante session.save_handler. Éste guarda los datos de sesión en el servidor en la ubicación especificada por la directiva de configuración session.save_path.

Las sesiones se puede iniciar manualmente usando la función session_start(), si la directiva session.auto_start se establece a 1, una sesión se iniciará automáticamente ante cualquier petición de arranque.

Las sesiones normalmente se cierran automáticamente cuando PHP termina de ejecutar un script, pero se pueden cerrar manualmente usando la función session_write_close().

Ejemplo #1 Registrar una variable con $_SESSION.

<?php
session_start();
if (!isset($_SESSION['count'])) {
  $_SESSION['count'] = 0;
} else {
  $_SESSION['count']++;
}
?>

Ejemplo #2 Desregistrar una variable con $_SESSION

<?php
session_start();
unset($_SESSION['count']);
?>

Precaución

NO destruya completamente $_SESSION con unset($_SESSION) ya que esto deshabilitará el registro de las variables a través del array superglobal $_SESSION.

Advertencia

No se pueden usar referencias en variables de sesión ya que no hay una manera viable de restarurar una referencia a otra variable.

Nota:

Las sesiones basadas en ficheros (lo predeterminado en PHP) bloquean el fichero de sesión una vez que una sesión se abre vía session_start() o implícitamente vía session.auto_start. Mientras esté bloqueado, ningún otro script puede acceder al mismo fichero de sesión hasta que haya sido cerrado al terminar de ejecutarse el primer script, o llamando a session_write_close().

Esto suele provocar problemas en aquellos sitios Web que realizan muchas peticiones AJAX y tienen solicitudes mútliples ejécutandose a la vez. La manera más fácil de lidiar con esto es llamando a session_write_close() tan pronto como se haya realizado un cambio requeirdo a la sesión, preferiblemente antes de finalizar el script. Alternativamente, se podría utilizar una sesión diferente en segundo plano que admita concurrencia.


Pasar el ID de Sesión

Hay dos métodos para propagar un id de sesión:

  • Cookies
  • Parámetro de URL

El módulo de sesiones soporta ambos métodos. Las cookies son óptimas, pero ya que no están siempre disponibles, también se proporciona una manera alternativa. El segundo método embebe el id de sesión directamente en las URL.

PHP es capaz de transformar enlaces transparentemente. A menos que se use PHP 4.2.0 o posterior, se necesita habilitarlo manualmente cuando se construye PHP. Bajo Unix, pase --enable-trans-sid para la configuración. Si esta opción de construcción y la opción en tiempo de ejecución session.use_trans_sid están habilitadas, las URI relativas se modificarán para contener el id de sesión automáticamente.

Nota:

La directiva de php.ini arg_separator.output permite personalizar el separador de argumentos. Para una conformidad completa con XHTML, especifique &amp; allí.

Alternativamente, se puede usar la constante SID, que está definida si la sesión se inició. Si el cliente no envía una cookie de sesión apropiada, tiene la forma session_name=session_id. De otro modo se desarrolla en una cadena vacía. Así, se puede embeberla incondicionalmente dentro de las URL.

El siguiente ejemplo muestra cómo registrar una variable, y cómo enlazar correctamente a otra página usando SID.

Ejemplo #1 Contar el número de peticiones de un sólo usuario

<?php

session_start();

if (empty($_SESSION['count'])) {
   $_SESSION['count'] = 1;
} else {
   $_SESSION['count']++;
}
?>

<p>
Hola visitante, ha visto esta página <?php echo $_SESSION['count']; ?> veces.
</p>

<p>
Para continuar, <a href="nextpage.php?<?php echo htmlspecialchars(SID); ?>">haga clic
aquí</a>.
</p>

La función htmlspecialchars() se puede usar cuando se imprime SID para prevenir ataques relacionados con XSS.

Imprimir SID, como se mostró arriba, no es necesario si --enable-trans-sid se usó para compilar PHP.

Nota:

Se asume que las URL no relativas apuntan a sitios externos y por lo tanto no añaden SID, ya que sería un riesgo para la seguridad filtrar SID a un servidor diferente.


Gestores de Sesión Personalizados

Para implementar el almacenamiento en bases de datos, o cualquier otro método de almacenamiento, se necesita usar session_set_save_handler() para crear un conjunto de funciones de almacenamiento a nivel de ususario. A partir de PHP 5.4.0 se pueden crear gestores de sesiones usando la clase SessionHandlerInterface o extendiendo los gestores internos de PHP heredando de la clase SessionHandler.

Las llamadas de retorno especificadas en session_set_save_handler() son métodos llamados por PHP durante el ciclo de vida de una sesión: open, read, write y close, y para las tareas domésticas: destroy para borrar una sesión y gc para la recoleción periódica de basura.

Por lo tanto, PHP siempre necesita gestores de almacenamiento de sesiones. El predeterminado normalmente es el gestor de almacenamiento interno 'files'. Se puede establecer un gestor de almacenamiento personalizado usando session_set_save_handler(). Se pueden porporcionar de forma alternativa gestores de almacenamiento interno mediante extensiones de PHP, tales como sqlite, memcache y memcached y pueden establecerse con session.save_handler.

Cuando se inicia la sesión, PHP llamará internamente al gestor open seguido de la llamada de retorno read la cual debería devolver una cadena codificada exactamente como si fuera pasada originalmente para almacenamiento. Una vez que la llamada de retorno read devuelve la cadena codificada, PHP la decodificará y rellenará el array resultante en la variable superglobal $_SESSION.

Cuando PHP se cierra (o se llama a session_write_close()), PHP codificará internamente la variable superglobal $_SESSION y la pasará conjuntamente con el ID de sesión a la llamada de retorno write. Después de finalizada la llamada de retorno write, PHP invocará internamente al gestor de llamada de retorno close.

Cuando una sesión se destruye de forma específica, PHP llamará al gestor destroy con el ID de sesión.

PHP llamará a la llamada de retorno gc de vez en cuando para terminar cualquier registro de sesión según lo establecido en el tiempo de vida máximo de una sesión. Esta rutina debería borrar todos los registros del almacenamiento persistente a los que se accedió por última vez más allá del parámetro $lifetime.


Progreso de Subida en Sesiones

Cuando la opción INI session.upload_progress.enabled está habilitada, PHP podrá rastrear el progreso de subida de ficheros individuales que están siendo subidos. Esta información no es particularmente útil para la petición de subida real en sí misma, pero durante la subida del archivo, una aplicación puede enviar una petición POST a un nodo distinto (mediante XHR por ejemplo) para comprobar el estado.

El progreso de subida estará disponible en la variable superglobal $_SESSION cuando una subida está en progreso, y al usar POST con una variable con el mismo nombre al que está establecido el ajuste INI session.upload_progress.name. Cuando PHP detecta tales peticiones POST, rellenará un array en la variable $_SESSION, donde el índice es un valor concatenado de las opciones INI session.upload_progress.prefix y session.upload_progress.name. La clave se recupera normalmente leyendo estas opciones INI, es decir

<?php
$clave = ini_get("session.upload_progress.prefix") . $_POST[ini_get("session.upload_progress.name")];
var_dump($_SESSION[$clave]);
?>

También es posible cancelar la subida de ficheros que está en progreso, estableciendo la clave $_SESSION[$clave]["cancel_upload"] a true. Cuando se suben múltiples ficheros en la misma petición, esto solamente cancelará la subida de ficheros que está en progreso, y las subidas de ficheros pendientes, pero no eliminará de manera satisfactoria las subidas completadas. Cuando una subida se cancela de esta manera, la clave error del array $_FILES será establecida a UPLOAD_ERR_EXTENSION.

Las opciones INI session.upload_progress.freq y session.upload_progress.min_freq controlan con qué frecuencia debería ser recalculada la información del progreso de subida. Con una cantidad razonable de estos dos ajustes, la sobrecarga de esta característica es casi inexistente

Ejemplo #1 Ejemplo de información

Ejemplo de la esctructura del array del progreso de subida.

<form action="upload.php" method="POST" enctype="multipart/form-data">
 <input type="hidden" name="<?php echo ini_get("session.upload_progress.name"); ?>" value="123" />
 <input type="file" name="file1" />
 <input type="file" name="file2" />
 <input type="submit" />
</form>

La información almacenada en la sesión se parecerá a esta:

<?php
$_SESSION["upload_progress_123"] = array(
 "start_time" => 1234567890,   // El instante de la petición
 "content_length" => 57343257, // longitud del contenido de POST
 "bytes_processed" => 453489,  // Cantidad de bytes recibidos y procesados
 "done" => false,              // True cuando el gestor de POST ha finalizado, satisfactoriamente o no
 "files" => array(
  0 => array(
   "field_name" => "file1",       // nombre del campo <input/>
   // Los siguientes 3 elementos son iguales que aquellos de $_FILES
   "name" => "foo.avi",
   "tmp_name" => "/tmp/phpxxxxxx",
   "error" => 0,
   "done" => true,                // True cuando el gestor de POST ha terminado de manejar este fichero
   "start_time" => 1234567890,    // Cuándo se empezo a procesar este fichero
   "bytes_processed" => 57343250, // Número de bytes recibidos y procesados de este fichero
  ),
  // Otro fichero, no terminado de subir, en la misma petición
  1 => array(
   "field_name" => "file2",
   "name" => "bar.avi",
   "tmp_name" => NULL,
   "error" => 0,
   "done" => false,
   "start_time" => 1234567899,
   "bytes_processed" => 54554,
  ),
 )
);

Advertencia

El almacenamiento en búfer de peticiones del servidor ha sido deshabilitado para que esto funcione apropiadamente, si no, PHP podría ver la subida de ficheros una vez realizada esta completamente. Los servidores como Nginx almacenan en búfer peticiones más grandes.


Sesiones y seguridad

Enlaces externos: » Fijación de sesiones

El administrador de sesiones de HTTP es el núcleo de la seguridad web. Se deberían adoptar todos los atenuantes para garantizar la seguridad de sesiones. Los desarrolladores deberían habilitar/emplear configuraciones relevantes de forma apropiada.

  • session.cookie_lifetime=0. El valor 0 tiene un significado especial. Indica a los navegadores no almacenar permanentemente cookies. Por tanto, cuando un navegador finaliza, la cookie de ID de sesión se elimina inmediatamente. Si el desarrollador establece un valor distinto de 0, podría permitir que otros usuarios empleen ese ID de sesión. La mayoría de las aplicacioines deberían utilizar "0". Si se requiere la autoidentificación, se ha de implementar una característca de autoidentificación segura. No se han de utilizar ID de sesiones para ello.
  • session.use_cookies=On y session.use_only_cookies=On. Aunque las cookies de HTTP tienen algunos problemas, son la manera preferida de administrar ID de sesiones. Use solamente cookies para administrar ID de sesiones cuando sea posible. La mayoría de las aplicaciones deberían utilizar cookies para ID de sesiones.
  • session.use_strict_mode=On. Previene que el módulo de sesiones utilice ID de sesiones no inicializados. En otras palabras, el módulo de sesiones solamente acepta ID de sesiones válidos generados por él mismo. Rechaza ID de sesions proporcionados por los usuarios. Se podría realizar una inyección de ID de sesiones a través de inyecciones de cookies mediante JavaScript de forma permanente o temporal. Cuando están habilitadas las sesiones transparentes, se podría inyectar una ID de sesión mediante un string de consulta o un parámetro de formulario. No hay ninguna razón para aceptar ID de sesiones proporcionados por el usuario, la mayoría de las aplicaciones no deben aceptar ID de sesiones no inicializados proporcionados por el usuario.
  • session.cookie_httponly=On. Denegar el acceso a cookies de sesión a JavaScript. Este ajuste previene del robo de cookies por inyecciones de JavaScript. Es posible utilizar ID de sesiones como claves de protección CSRF, aunque no se recomienda. Por ejemplo, se podría guardar y enviar código fuente HTML a otros usuarios. Para mayor seguridad, los desarrolladores no deberían escribir ID de sesiones en páginas web. Casi todas las aplicaciones deben emplear el atributo httponly para cookies de ID de sesión.
  • session.cookie_secure=On. Permite el acceso a cookies de ID de sesión solamente al protocolo HTTPS. Si un sitio web es un sitio solamente HTTPS, se debe habilitar este ajuste. No debería considerarse el empleo de HSTS para sitios web que sean solamente HTTPS.
  • session.gc_maxlifetime=[elegir el más pequeño posible]. La recolección de basura (GC) se realiza por probabilidades. Este ajuste no garantiza la eliminación de sesiones antiguas. Algunos modulos de gestores de almacenamiento de sesiones no emplean este ajuste. Consulte la documentación de gestores almacenamiento de sesiones para más detalles. Aunque los desarrolladores no pueden depender de este ajuste, se recomienda establecerlo al valor más pequeño posible. Se ha de ajustar session.gc_probability y session.gc_divisor para que las sesiones obsoleta sean eliminadas con la frecuencia apropiada. Si se requiere la autoidentificación, se ha de implementar una característca de autoidentificación segura. No utilice ID de sesiones de vida larga para ello.
  • session.use_trans_sid=Off. El empleo de administradores de ID de sesiones transparentes no está prohibido. Se podría utilizar cuando fuera necesario. Sin embargo, la deshabilitación de la administración de ID de sesiones transparentes mejoraría la seguridad general de ID de sesiones eliminando la posibilidad de inyecciones y filtracioines de ID de sesiones.
  • session.referer_check=[el URL original] Cuando session.use_trans_sid está habilitado, se recomienda el empleo de este ajuste si es posible. Reduce el riesgo de inyecciones de ID de sesión. Si un sitio fuera http://example.com/, se ha de establecer http://example.com/ para ello. Obaservar que al utilizar HTTPS, los navegadores no enviarán la cabecera recomendante. Los navegadores podrían no enviar dicha cabecera debido a su configuración. Por tanto, este ajuste no es una medida de seguridad de confianza.
  • session.cache_limiter=nocache. Garantiza que los contenidos HTTP no se almacenan en caché para sesiones autenticadas. Permite el almacenamiento en caché solamente cuando el contenido no es privado. De lo contrario, el contenido podría quedar expuesto. Se podría emplear "private" si el contenido HTTP no incluye datos sensibles a la seguridad. Observar que "private" podría dejar datos privados en caché por clientes compartidos. Se podría utilizar "public" solamente cuando el contenido HTTP no contenga ningún dato privado en absoluto.
  • session.hash_function="sha256". Las funciones de hash más fuertes generarán ID de sesiones más fuertes. Aunque son improbables las colisiones hash incluso con MD5, los desarrolladores deberían utilizar funciones de hash SHA-2 o posterior para esta tarea. Los desarrolladores podrían emplear hash más fuertes, como sha384 y sha512.

El módulo de sesión no puede garantizar que la información que se almacena en una sesión sea vista sólo por el usuario que creó la sesión. Se necesita tomar medidas adicionales para proteger activamente la confidencialidad de la sesión, dependiendo del valor asociado con ella.

Evalúe la importancia de la información que portan las sesiones y utilice protecciones adicionales; esto normalmente conlleva un precio, reduciendo la comodidad del usuario. Por ejemplo, si se quiere proteger a los usuarios de tácticas de ingeniería social simples, es necesario habilitar session.use_only_cookies. En este caso, las cookies deben estar activas incondicionalmente en el lado del usuario, o las sesiones no funcionarán.

Hay varias maneras de filtrar un ID de sesión existente a terceros. Un ID de sesión filtrado habilita al tercero a acceder a todos los recursos que están asociados con un ID específico. Primero, los URL portan ID de sesiones. Si se enlaza con un sitio externo, el URL que incluye el ID de sesión podría estar almacenado en el registro de consultas del sitio externo. Segundo, un atacante más activo podría escuchar el tráfico de red. Si no están encriptados, los ID de sesión fluirán en texto plano por la red. La solución aquí es implementar SSL en el servidor y hacerlo obligatorio para los usuarios. Se debería emplear HSTS para esto.

Desde PHP 5.5.2, está disponible session.use_strict_mode. Cuando está habilitada y el módulo genstor de almacenamiento lo admite, un ID de sesión no inicializado es rechazado, creando así un nuevo ID de sesión. Es protege contra ataques que fuerzan a los usuarios que empleen ID de sesiones conocidos. El atacante podría pegar enlaces o enviar correos que contengan ID de sesiones, p.ej., http://example.com/page.php?PHPSESSID=123456789. Si session.use_trans_sid está habilitada, las víctimas iniciarán sesión utilizando el ÏD de sesión provisto por el atacante. session.use_strict_mode mitiga este riesgo.

Incluso si session.use_strict_mode mitiga el riesgo de gestores de sesiones adoptivos, el atacante puede forzar a los usuarios a que empleen ID de sesiones inicializados creados por él mismo. Todo lo que tiene que hacer el atacante es inicializar el ID de sesión antes de atacar y mantanerlo vivo.

Se podría establecer una cookie de ID de sesión con los atributos de dominio, ruta, httponly y seguro. Los navegadores definen su propia precedencia. Al emplear la precedencia, el atacante puede establecer un ID de sesión que podría utlizarse permanentemente. El empleo de session.use_only_cookies no resolverá este problema. session.use_strict_mode mitiga este riesgo. Con session.use_strict_mode=On, los ID de sesiones no inicializados no serán aceptados. El módulo de sesiones crea un nuevo ID de sesión siempre que dicho ID no esté inicializado por él midmo. Esto podría resultar en una denegación del servicio, aunque esto es mejor que comprometer la cuenta.

session.use_strict_mode es un buen atenuante, pero no lo suficiente para sesiones autenticadas. Los desarrolladores deben emplear session_regenerate_id() para la autenticación. session_regenerate_id() debe invocarse antes de establecer la información de autentición para $_SESSION. session_regenerate_id() garantiza que las nuevas sesiones contengan información de autenticación almacenada solamente en nuevas sesiones. Es decir, los errores durante el proceso de identificación podrían guardar indicadores autenticados en sesiones antiguas.

Llamar a la función session_regenerate_id() podría resultar en una denegación del servicio personal como con use_strict_mode=On. Sin embargo, esto es mejor que comprometer la cuenta. Un ID de sesión debería ser regenerado cuando el usuario, al menos, sea autenticado. La regeneración de ID de sesiones reduce el riesgo del robo de los mismos, por lo que debería invocarse periódicamente. Los desarrolladores no deberían depender de la expiración de los ID de sesiones. Los atacantes podrían acceder a los ID de sesión de las víctimas periódicamente para evitar la expiración. Los desarrolladores deben implementar su propia utilidad de expiración para sesiones antiguas.

Observar que session_regenerate_id() no elimina sesiones antiguas de forma predeterminada. Podrían estar disponibles las sesiones autenticadas antiguas. Si los desarrolladores quiesieran prevenir que las sesiones autenticadas antiguas sen utilizadas por cualquiera, debe destruir las sesiones estableciendo delete_old_session a true. Sin embargo, la inmediata eliminación de sesiones antigas tiene efectos secundarios no deseados. Las sesiones podrían desaparecer cuando hayan conexiones concurrentes a la aplicación web y/o cuando la red esté inestable. En lugar de eliminar las sesiones antiguas inmediatamente, podría establecerse un tiempo de expiración a corto plazo en $_SESSION por uno mismo. Si el usuario accede a una sesión obsoleta (expirada), se ha de denegar el acceso a ella.

session.use_only_cookies y el uso apropiado de session_regenerate_id() podría ocasionar una denegación del servicio personal. Cuando sea este el caso, se podría preguntar a los usuarios para que eliminen las cookies y advertirles de que podría haber problemas de seguridad. Los atacantes podrían establecer cookies maliciosas mediante una aplicación web vulnerable (es decir, inyección de JavaScript), complementos vulnerables/maliciosos de navegadores, etc.

Los desarrolladores no deben utilizar ID de sesiones de vida larga para la autoidentifiación, ya que aumenta el riego del robo de sesiones. La autoidentificación debería ser implementada por el desarrolador. Emplee la clave de hash de seguridad de una sola vez como clave de autoidentificación utilizando cookies. Emplee un hash de seguridad más fuerte que SHA-2, p.ej., SHA-256 o superior con datos aleatorios de /dev/urandom o similar. Si el usuario no se autentica, compruebe que la clave de autoidentificación de una sola vez es válida. Si la clave es válida, autentique al usuario y establezca una nueva clave de hash de seguridad de una sola vez. La clave de autoidentificación es una clave de vida larga; debería estar lo más protegida posible. Emplee los atributos ruta/httponly/seguridad de las cookies para la protección. Los desarrolladores deben implementar la característca que deshbilite la autoidentificación y elmine las claves de autoidentificación de los usuarios innecesarias.


Funciones de sesión

Tabla de contenidos

  • session_abort — Desecha los cambios en el array de sesión y finaliza la sesión
  • session_cache_expire — Devuelve la caducidad de la caché actual
  • session_cache_limiter — Obtener y/o establecer el limitador de caché actual
  • session_commit — Alias de session_write_close
  • session_create_id — Crear un nuevo ID de sesión
  • session_decode — Decodifica la información de sesión desde una cadena de sesión codificada
  • session_destroy — Destruye toda la información registrada de una sesión
  • session_encode — Codifica los datos de la sesión actual como un string codificado de sesión
  • session_gc — Realizar una recolección de basura de datos de sesión
  • session_get_cookie_params — Obtener los parámetros de la cookie de sesión
  • session_id — Obtener y/o establecer el id de sesión actual
  • session_is_registered — Averiguar si una variable global está registrada en una sesión
  • session_module_name — Obtiene y/o establece el módulo de sesión actual
  • session_name — Obtener y/o establecer el nombre de la sesión actual
  • session_regenerate_id — Actualiza el id de sesión actual con uno generado más reciente
  • session_register_shutdown — Función de cierre de sesiones
  • session_reset — Reinicializar el array de sesión con los valores originales
  • session_save_path — Obtener y/o establecer la ruta de almacenamiento de la sesión actual
  • session_set_cookie_params — Establecer los parámetros de la cookie de sesión
  • session_set_save_handler — Establece funciones de almacenamiento de sesiones a nivel de usuario
  • session_start — Iniciar una nueva sesión o reanudar la existente
  • session_status — Devuelve el estado de la sesión actual
  • session_unregister — Deja de registrar una variable global de la sesión actual
  • session_unset — Libera todas las variables de sesión
  • session_write_close — Escribir información de sesión y finalizar la sesión


Desecha los cambios en el array de sesión y finaliza la sesión

  • « Funciones de sesión
  • session_cache_expire »
  • PHP Manual
  • Funciones de sesión
  • Desecha los cambios en el array de sesión y finaliza la sesión

session_abort

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

session_abort — Desecha los cambios en el array de sesión y finaliza la sesión

Descripción

session_abort ( ) : bool

session_abort() finaliza la sesión sin guardar datos. Por tanto, se mantienen los valores originales de los datos de la sesión.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
7.2.0 | El tipo de retorno de esta función es bool ahora. Anteriormente, ha sido void.

Ver también

  • $_SESSION
  • La directiva de configuración session.auto_start
  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session_reset() - Reinicializar el array de sesión con los valores originales
  • session_commit() - Alias de session_write_close


Devuelve la caducidad de la caché actual

  • « session_abort
  • session_cache_limiter »
  • PHP Manual
  • Funciones de sesión
  • Devuelve la caducidad de la caché actual

session_cache_expire

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

session_cache_expire — Devuelve la caducidad de la caché actual

Descripción

session_cache_expire ( string $new_cache_expire = ? ) : int

session_cache_expire() devuelve la configuración actual de session.cache_expire.

La caducidad de la caché se reinicia al valor predeterminado de 180 almacenado en session.cache_expire en el momento de iniciar una petición. Por lo tanto, se necesita llamar a session_cache_expire() por cada petición (y antes de llamar a session_start()).

Parámetros

new_cache_expire

Si se da new_cache_expire, la nueva caducidad de la caché se reemplaza por new_cache_expire.

Nota: La configuración de new_cache_expire es de valores sólamente, si session.cache_limiter se establece a un valor diferente de nocache.

Valores devueltos

Devuelve la configuración actual de session.cache_expire. El valor devuelto se debería leer en minutos, por defecto es 180.

Ejemplos

Ejemplo #1 Ejemplo de session_cache_expire()

<?php

/* establecer el limitador de caché a 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

/* establecer la caducidad de la caché a 30 minutos */
session_cache_expire(30);
$cache_expire = session_cache_expire();

/* iniciar la sesión */

session_start();

echo "El limitador de caché ahora está establecido a $cache_limiter<br />";
echo "Las páginas de sesión examinadas caducan después de $cache_expire minutos";
?>

Ver también

  • session.cache_expire
  • session.cache_limiter
  • session_cache_limiter() - Obtener y/o establecer el limitador de caché actual


Obtener y/o establecer el limitador de caché actual

  • « session_cache_expire
  • session_commit »
  • PHP Manual
  • Funciones de sesión
  • Obtener y/o establecer el limitador de caché actual

session_cache_limiter

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

session_cache_limiter — Obtener y/o establecer el limitador de caché actual

Descripción

session_cache_limiter ( string $cache_limiter = ? ) : string

session_cache_limiter() devuelve el nombre del limitador de caché actual.

El limitador de caché define cuáles cabeceras HTTP de control de caché son enviadas al cliente. Estas cabeceras determinan las normas por las cuáles el contenido de la página puede ser examinada por el cliente y por los proxies intermediarios. Establecer el limitador de caché a nocache rechaza cualquier examen por parte del cliente/proxy. Un valor de public permite la examen por proxies y el client, mientras que private rechaza la examen por proxies y permite al cliente examinar el contenido.

En modo private, la cabecera Expire enviada al cliente puede causar confusión a algunos navegadores, incluido Mozilla. Se puede evitar este problema usando el modo private_no_expire. La cabecera Expire nunca se envía al cliente en este modo.

Establecer el limitador de caché a '' desactivará el envío automático de las cabeceras de caché completamente.

El limitador de caché se reinicia a su valor predeterminado almacenado en session.cache_limiter en el momento de iniciar una petición. Por lo tanto, se necesita llamar a session_cache_limiter() para cada petición (y antes de llamar a session_start()).

Parámetros

cache_limiter

Si se especifica cache_limiter, el nombre del limitador de caché actual se cambia por el nuevo valor.

Valores posibles
Valor Cabeceras enviadas
public
Expires: (algún momento en el futuro, según session.cache_expire)
Cache-Control: public, max-age=(algún momento en el futuro, según session.cache_expire)
Last-Modified: (la marca de tiempo de cuando la sesión fue guardada por última vez)
private_no_expire
Cache-Control: private, max-age=(session.cache_expire en el futuro), pre-check=(session.cache_expire en el futuro)
Last-Modified: (la marca de tiempo de cuando la sesión fue guardada por última vez)
private
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: private, max-age=(session.cache_expire en el futuro), pre-check=(session.cache_expire en el futuro)
Last-Modified: (la marca de tiempo de cuando la sesión fue guardada por última vez)
nocache
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache

Valores devueltos

Devuelve el nombre del limitador de caché actual.

Ejemplos

Ejemplo #1 Ejemplo de session_cache_limiter()

<?php

/* establecer el limitador de caché a 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "El limitador de caché ahora está establecido a $cache_limiter<br />";
?>

Ver también

  • session.cache_limiter


Alias de session_write_close

  • « session_cache_limiter
  • session_create_id »
  • PHP Manual
  • Funciones de sesión
  • Alias de session_write_close

session_commit

(PHP 4 >= 4.4.0, PHP 5, PHP 7, PHP 8)

session_commit — Alias de session_write_close()

Descripción

Esta función es un alias de: session_write_close().


Crear un nuevo ID de sesión

  • « session_commit
  • session_decode »
  • PHP Manual
  • Funciones de sesión
  • Crear un nuevo ID de sesión

session_create_id

(PHP 7 >= 7.1.0, PHP 8)

session_create_id — Crear un nuevo ID de sesión

Descripción

session_create_id ( string $prefix = ? ) : string

session_create_id() se emplea para crear nuevos ID de sesión para la sesión actual. Devuelve los ID de sesión libres de colisiones.

Si la sesión no está activa, la comprobación de colisiones se omite.

El ID de sesión se crea de acuerdo a los ajustes de php.ini.

Es importante utilizar el mismo ID de usuario del servidor web para las tareas de recolección de basura. De lo contrario, se podrían tener problemas de permisos especialmente con manejadores de guardado de ficheros.

Parámetros

prefix

Si se especifica prefix, el nuevo ID de sesión se prefijará con prefix. No todos los caracteres están permitidos con el ID de sesión. Están permitidos los caracteres del rango a-z A-Z 0-9 , (coma) y - (menos).

Valores devueltos

session_create_id() devuelve el nuevo ID de sesión libre de colisiones para la sesión actual. Si se emplea sin una sesión activa, se omite la comprobación de colisiones.

Ejemplos

Ejemplo #1 Ejemplo de session_create_id() con session_regenerate_id()

<?php
// Mi función de inicio de sesión admite la gestión de marcas de tiempo
function mi_inicio_de_sesión() {
    session_start();
    // No permitir usar un ID de sesión demasiado antiguo
    if (!empty($_SESSION['deleted_time']) && $_SESSION['deleted_time'] < time() - 180) {
        session_destroy();
        session_start();
    }
}

// Mi función de regeneración de ID de sesión
function mi_regeneración_de_id_de_sesión() {
    // Llamar a session_create_id() mientras la sesión está activa para
    // asegurarse de que no haya colisiones.
    if (session_status() != PHP_SESSION_ACTIVE) {
        session_start();
    }
    // ADVERTENCIA: ¡No utilizar nunca cadenas confidenciales para el prefijo!
    $nuevo_id = session_create_id('miprefijo-');
    // Establecer la marca de tiempo de borrado. Los datos de la sesión no deben eliminarse inmediatamente.
    $_SESSION['deleted_time'] = time();
    // Finalizar la sesión
    session_commit();
    // Asegurarse de aceptar ID de sesiones definidas por el usuario
    // NOTA: Se debe habilitar 'use_strict_mode' para operaciones normales.
    ini_set('session.use_strict_mode', 0);
    // Establecer el nuevo ID de sesión personalizado
    session_id($nuevo_id);
    // Empezar la sesión con el ID de sesión personalizado
    session_start();
}

// Asegurarse de que 'use_strict_mode' está habilitado.
// 'use_strict_mode' es obligatorio por razones de seguridad.
ini_set('session.use_strict_mode', 1);
mi_inicio_de_sesión();

// EL ID de sesión debe regenerarse cuando
//  - El usuario inicia la sesión
//  - El usuario cierra la sesión
//  - Ha transcurrido un cierto perido de tiempo
mi_regeneración_de_id_de_sesión();

// Escribir código útil
?>

Ver también

  • session_regenerate_id() - Actualiza el id de sesión actual con uno generado más reciente
  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session.use_strict_mode
  • SessionHandler::create_sid() - Devuelve un nuevo ID de sesión


Decodifica la información de sesión desde una cadena de sesión codificada

  • « session_create_id
  • session_destroy »
  • PHP Manual
  • Funciones de sesión
  • Decodifica la información de sesión desde una cadena de sesión codificada

session_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

session_decode — Decodifica la información de sesión desde una cadena de sesión codificada

Descripción

session_decode ( string $data ) : bool

session_decode() decodifica la información de sesión serializada proporcianda en $data, y rellena la variable superglobal $_SESSION con el resultado.

Por defecto, el método de deserialización usado es interno a PHP, y no es el mismo que unserialize(). El método de serialización se puede establecer con session.serialize_handler.

Parámetros

data

Los datos codificados a alamcenar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • session_encode() - Codifica los datos de la sesión actual como un string codificado de sesión
  • session.serialize_handler


Destruye toda la información registrada de una sesión

  • « session_decode
  • session_encode »
  • PHP Manual
  • Funciones de sesión
  • Destruye toda la información registrada de una sesión

session_destroy

(PHP 4, PHP 5, PHP 7, PHP 8)

session_destroy — Destruye toda la información registrada de una sesión

Descripción

session_destroy ( ) : bool

session_destroy() destruye toda la información asociada con la sesión actual. No destruye ninguna de las variables globales asociadas con la sesión, ni destruye la cookie de sesión. Para volver a utilizar las variables de sesión se debe llamar a session_start().

Para destruir la sesión completamente, como desconectar al usuario, el id de sesión también debe ser destruido. Si se usa una cookie para propagar el id de sesión (comportamiento por defecto), entonces la cookie de sesión se debe borrar. setcookie() se puede usar para eso.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Destruir una sesión con $_SESSION

<?php
// Inicializar la sesión.
// Si está usando session_name("algo"), ¡no lo olvide ahora!
session_start();

// Destruir todas las variables de sesión.
$_SESSION = array();

// Si se desea destruir la sesión completamente, borre también la cookie de sesión.
// Nota: ¡Esto destruirá la sesión, y no la información de la sesión!
if (ini_get("session.use_cookies")) {
    $params = session_get_cookie_params();
    setcookie(session_name(), '', time() - 42000,
        $params["path"], $params["domain"],
        $params["secure"], $params["httponly"]
    );
}

// Finalmente, destruir la sesión.
session_destroy();
?>

Notas

Nota:

Usar sólo session_unset() para códigos antiguos obsoletos que no usan $_SESSION.

Ver también

  • unset() - Destruye una variable especificada
  • setcookie() - Enviar una cookie


Codifica los datos de la sesión actual como un string codificado de sesión

  • « session_destroy
  • session_gc »
  • PHP Manual
  • Funciones de sesión
  • Codifica los datos de la sesión actual como un string codificado de sesión

session_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

session_encode — Codifica los datos de la sesión actual como un string codificado de sesión

Descripción

session_encode ( ) : string

session_encode() devuelve un string serializado del contenido de los datos de la sesión actual almacenados en el array superglobal $_SESSION.

Por defecto, el método de serialización usado es interno a PHP, y no es el mismo que serialize(). El método de serialización se puede establecer con session.serialize_handler.

Valores devueltos

Devuelve el contenido de la sesión actual codificado.

Notas

Advertencia

Se debe llamar a session_start() antes de usar session_encode().

Ver también

  • session_decode() - Decodifica la información de sesión desde una cadena de sesión codificada
  • session.serialize_handler


Realizar una recolección de basura de datos de sesión

  • « session_encode
  • session_get_cookie_params »
  • PHP Manual
  • Funciones de sesión
  • Realizar una recolección de basura de datos de sesión

session_gc

(PHP 7 >= 7.1.0, PHP 8)

session_gc — Realizar una recolección de basura de datos de sesión

Descripción

session_gc ( ) : int

session_gc() se emplea para la RB (recolección de basura) de datos de sesión. PHP hace la RC de sesiones basada en probabilidad de forma predeterminada.

LA RB basada en probabilidad funciona en cierto modo aunque tiene algunos problemas. 1) Los datos de sesión de sitios con tráfico bajo podrían no borrarse con la frecuencia requerida. 2) Los sitios con tráfico alto podrían tener una RB demasiado frecuente. 3) La RB se realiza durante la petición del usuario, por lo que este podría experimentar un retraso en la RB.

Por tanto, se recomienda ejecutar la RB periódicamente para sistemas en produción. P.ej., use "cron" para sistemas como UNIX. Asegúrese de inhabilitar la RB basada en probabilidad estableciendo session.gc_probability a 0.

Valores devueltos

session_gc() devuelve el núermo de datos de sesión eliminados en caso de éxito, o false en caso de fallo.

Los manejadores de guardado antiguos no devuelven el número de datos de sesión eliminados, sino solamente el indicador de éxito/fallo. Si este es el caso, el número de datos de sesión eliminados será 1, sin considerar los datos realmente eliminados.

Ejemplos

Ejemplo #1 Ejemplo de session_gc() para administradores de tareas como cron

<?php
// Nota: Este scriptr debería ejecutarse por el mismo usuario del proceso del servidor web.

// Es necesario una sesión activa para inicializar el accesso al almacén de datos de sesión.
session_start();

// Ejecutar la RB inmediatamente
session_gc();

// Limpiar el ID de sesión creado por session_gc()
session_destroy();
?>

Ejemplo #2 Ejemplo de session_gc() para un script accesible al usuario

<?php
// Nota: Se recomienda usar session_gc() con scripts de administradores de taresas, aunque
// podría utilizarse como sigue.

// Utilizado para la última comprobación de la hora de la última RB
$gc_time = '/tmp/php_session_last_gc';
$gc_period = 1800;

session_start();
// Ejecutar la RB solamente cuando el periodo de RB ha finalizado.
// Esto es, llamar a session_gc() en cada petición es desperdiciar recursos.
if (file_exists($gc_time)) {
    if (filemtime($gc_time) < time() - $gc_period) {
        session_gc();
        touch($gc_period);
    }
} else {
    touch($gc_period);
}
?>

Ver también

  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session_destroy() - Destruye toda la información registrada de una sesión
  • session.gc_probability


Obtener los parámetros de la cookie de sesión

  • « session_gc
  • session_id »
  • PHP Manual
  • Funciones de sesión
  • Obtener los parámetros de la cookie de sesión

session_get_cookie_params

(PHP 4, PHP 5, PHP 7, PHP 8)

session_get_cookie_params — Obtener los parámetros de la cookie de sesión

Descripción

session_get_cookie_params ( ) : array

Obtiene los parámetros de la cookie de sesión.

Valores devueltos

Devuelve una matriz con la información de la cookie de sesión actual, la matriz contiene los siguientes elementos:

  • "lifetime" - El tiempo de vida de la cookie en segundos.
  • "path" - La ruta donde se almacena la información.
  • "domain" - El dominio de la cookie.
  • "secure" - La cookie debería ser enviada solamente sobre conexiones seguras.
  • "httponly" - La cookie sólo puede ser accedida a través del protocolo HTTP.

Historial de cambios

Versión | Descripción
5.2.0 | La entrada "httponly" fue añadida en la matriz devuelta.

Ver también

  • session.cookie_lifetime
  • session.cookie_path
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session_set_cookie_params() - Establecer los parámetros de la cookie de sesión


Obtener y/o establecer el id de sesión actual

  • « session_get_cookie_params
  • session_is_registered »
  • PHP Manual
  • Funciones de sesión
  • Obtener y/o establecer el id de sesión actual

session_id

(PHP 4, PHP 5, PHP 7, PHP 8)

session_id — Obtener y/o establecer el id de sesión actual

Descripción

session_id ( string $id = ? ) : string

session_id() se usa para obtener o establecer el id de sesión para la sesión actual.

La constante SID también se puede usar para recuperar el nombre y la sesión actuales como una cadena apropiada para añadir a las URL. Véase también Manejo de Sesiones.

Parámetros

id

Si se especifica id, reemplazará el id de sesión actual. session_id() necesita ser llamado antes de session_start() para este propósito. Dependiendo del gestor de sesión, no todos los caracteres están permitidos dentro del id de sesión. Por ejemplo, el gestor de archivo de sesión ¡sólo permite caracteres en el rango a-z A-Z 0-9 , (coma) y - (menos)!

Nota: Cuando se usan cookies de sesión, especificar un id para session_id() enviará siempre una nueva cookie cuando se llame a session_start(), sin importar si el id de sesión actual es idéntico al que se va a establecer.

Valores devueltos

session_id() devuelve el id de sesión para la sesión actual o la cadena vacía ("") si no hay sesión actual (no existe id de sesión actual).

Ver también

  • session_regenerate_id() - Actualiza el id de sesión actual con uno generado más reciente
  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session_set_save_handler() - Establece funciones de almacenamiento de sesiones a nivel de usuario
  • session.save_handler


Averiguar si una variable global está registrada en una sesión

  • « session_id
  • session_module_name »
  • PHP Manual
  • Funciones de sesión
  • Averiguar si una variable global está registrada en una sesión

session_is_registered

(No hay información de versión disponible, podría estar únicamente en Git)

session_is_registered — Averiguar si una variable global está registrada en una sesión

Descripción

session_is_registered ( string $name ) : bool

Averigua si una variable global está registrada en una sesión.

Advertencia

Esta función ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

Parámetros

name

El nombre de la variable.

Valores devueltos

session_is_registered() devuelve true si hay una variable global con el nombre name registrada en la sesión actual, false si no.

Notas

Nota:

Si se usa$_SESSION (o $HTTP_SESSION_VARS para PHP 4.0.6 o anterior), utilice isset() para verificar si una variable está registrada en $_SESSION.

Precaución

Si está usando $_SESSION
(o $HTTP_SESSION_VARS), no use
session_register(),
session_is_registered() y
session_unregister().


Obtiene y/o establece el módulo de sesión actual

  • « session_is_registered
  • session_name »
  • PHP Manual
  • Funciones de sesión
  • Obtiene y/o establece el módulo de sesión actual

session_module_name

(PHP 4, PHP 5, PHP 7, PHP 8)

session_module_name — Obtiene y/o establece el módulo de sesión actual

Descripción

session_module_name ( string $module = ? ) : string

session_module_name() obtiene el nombre del módulo de sesión actual.

Parámetros

module

Si se especifica module, ese módulo será usado en su lugar.

Valores devueltos

Devuelve el nombre del módulo de sesión actual.


Obtener y/o establecer el nombre de la sesión actual

  • « session_module_name
  • session_regenerate_id »
  • PHP Manual
  • Funciones de sesión
  • Obtener y/o establecer el nombre de la sesión actual

session_name

(PHP 4, PHP 5, PHP 7, PHP 8)

session_name — Obtener y/o establecer el nombre de la sesión actual

Descripción

session_name ( string $name = ? ) : string

session_name() devuelve el nombre de la sesión actual. Si se da el nombre name, session_name() actualizará el nombre de la sesión y devolverá el nombre antiguo de la sesión.

El nombre de la sesión se reinicia al valor predeterminado almacenado en session.name en el momento de iniciar una petición. Por lo tanto, se necesita llamar a session_name() por cada petición (y antes de llamar a session_start() o session_register()).

Parámetros

name

El nombre de la sesión hace referencia al nombre de la sesión usado cookies y URLs (p.ej. PHPSESSID). Debería contener sólo caracteres alfanuméricos; debería ser corto y descriptivo (esto es, para usuarios con las advertencias de cookies habilitadas). Si se especifica name, el nombre de la sesión actual se cambia por su valor.

Advertencia

El nombre de la sesión no puede consistir en dígitos solamente, debe de estar presente al menos una letra. De otro modo se genera un nuevo id de sesión cada vez.

Valores devueltos

Devuelve el nombre de la sesión actual. Si se proporciona name y una función actualiza el nombre de la sesión, se devolverá el nombre antiguo de la sesión.

Ejemplos

Ejemplo #1 Ejemplo de session_name()

<?php

/* establecer el nombre de la sesión a WebsiteID */

$nombre_anterior = session_name("WebsiteID");

echo "El nombre anterior de la sesión era $nombre_anterior<br />";
?>

Ver también

  • La directiva de configuración session.name


Actualiza el id de sesión actual con uno generado más reciente

  • « session_name
  • session_register_shutdown »
  • PHP Manual
  • Funciones de sesión
  • Actualiza el id de sesión actual con uno generado más reciente

session_regenerate_id

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

session_regenerate_id — Actualiza el id de sesión actual con uno generado más reciente

Descripción

session_regenerate_id ( bool $delete_old_session = false ) : bool

session_regenerate_id() reemplazará el id de sesión actual por uno nuevo, y mantendrá la información de la sesión actual.

Cuando session.use_trans_sid está habilitado, la salida debe estar iniciada después de llamar a session_regenerate_id(). De lo contrario, se usará el ID de sesión antiguo.

Parámetros

delete_old_session

Si se borra el archivo asociado antiguo o no.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
4.3.3 | Desde entonces, si las cookies de sesiones están habilitadas, el uso de session_regenerate_id() también presentará una nueva cookie de sesión con el nuevo id de sesión.
5.1.0 | Añadido el parámetro delete_old_session.

Ejemplos

Ejemplo #1 Un ejemplo de session_regenerate_id()

<?php
session_start();

$id_sesion_antigua = session_id();

session_regenerate_id();

$id_sesion_nueva = session_id();

echo "Sesión Antigua: $id_sesion_antigua<br />";
echo "Sesión Nueva: $id_sesion_nueva<br />";

print_r($_SESSION);
?>

Ver también

  • session_id() - Obtener y/o establecer el id de sesión actual
  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session_name() - Obtener y/o establecer el nombre de la sesión actual


Función de cierre de sesiones

  • « session_regenerate_id
  • session_reset »
  • PHP Manual
  • Funciones de sesión
  • Función de cierre de sesiones

session_register_shutdown

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

session_register_shutdown — Función de cierre de sesiones

Descripción

session_register_shutdown ( ) : void

Registra session_write_close() como una función de cierre.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Emite un error de nivel E_WARNING si la función de cierre falla.


Reinicializar el array de sesión con los valores originales

  • « session_register_shutdown
  • session_save_path »
  • PHP Manual
  • Funciones de sesión
  • Reinicializar el array de sesión con los valores originales

session_reset

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

session_reset — Reinicializar el array de sesión con los valores originales

Descripción

session_reset ( ) : void

session_reset() reinicializa una sesión con los valores originales guardados en el almaceén de sesiones. Esta función requiere una sesión activa ya que descarta los cambios en $_SESSION.

Valores devueltos

No devuelve ningún valor.

Ver también

  • $_SESSION
  • La directiva de configuración session.auto_start
  • session_start() - Iniciar una nueva sesión o reanudar la existente
  • session_abort() - Desecha los cambios en el array de sesión y finaliza la sesión
  • session_commit() - Alias de session_write_close


Obtener y/o establecer la ruta de almacenamiento de la sesión actual

  • « session_reset
  • session_set_cookie_params »
  • PHP Manual
  • Funciones de sesión
  • Obtener y/o establecer la ruta de almacenamiento de la sesión actual

session_save_path

(PHP 4, PHP 5, PHP 7, PHP 8)

session_save_path — Obtener y/o establecer la ruta de almacenamiento de la sesión actual

Descripción

session_save_path ( string $path = ? ) : string

session_save_path() devuelve la ruta del directorio actual usado para guardar la información de sesión.

Parámetros

path

La ruta de la información de sesión. Si se especifica, la ruta de la información guardada se cambiará. session_save_path() necesita ser llamada antes de session_start() para ese propósito.

Nota:

En algunos sistemas operativos, se puede querer especificar una ruta en un sistema de archivos que gestione muchos archivos pequeños de manera eficaz. Por ejemplo, en Linux, reiserfs puede proporcionar un mejor rendimiento que ext2fs.

Valores devueltos

Devuelve la ruta del directorio actual usado para el almacenamiento de información.

Ver también

  • La directiva de configuración session.save_path


Establecer los parámetros de la cookie de sesión

  • « session_save_path
  • session_set_save_handler »
  • PHP Manual
  • Funciones de sesión
  • Establecer los parámetros de la cookie de sesión

session_set_cookie_params

(PHP 4, PHP 5, PHP 7, PHP 8)

session_set_cookie_params — Establecer los parámetros de la cookie de sesión

Descripción

session_set_cookie_params ( int $lifetime , string $path = ? , string $domain = ? , bool $secure = false , bool $httponly = false ) : void

Establece los parámetros de la cookie definidos en el archivo php.ini. El efecto de esta función sólo se mantiene para la duración del script. Por lo tanto, se necesita llamar a session_set_cookie_params() por cada petición y antes de llamar a session_start().

Esta función actualiza los valores ini en tiempo de ejecución de las claves de configuración ini de PHP que pueden ser recuperadas con la función ini_get().

Parámetros

lifetime

Tiempo de vida de la cookie de sesión, definido en segundos.

path

Ruta en el dominio donde la cookie trabajará. Use una barras simple ('/') para todas las rutas en el dominio.

domain

Dominio de la cookie, por ejemplo 'www.php.net'. Para hacer las cookies visibles en todos los sub-dominios, el dominio debe ser prefijado con un punto, como '.php.net'.

secure

Si es true la cookie sólo será enviada sobre conexiones seguras.

httponly

Si es true PHP intentará enviar la bandera httponly cuando se establezca la cookie de sesión.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro httponly.

Ver también

  • session.cookie_lifetime
  • session.cookie_path
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session_get_cookie_params() - Obtener los parámetros de la cookie de sesión


Establece funciones de almacenamiento de sesiones a nivel de usuario

  • « session_set_cookie_params
  • session_start »
  • PHP Manual
  • Funciones de sesión
  • Establece funciones de almacenamiento de sesiones a nivel de usuario

session_set_save_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

session_set_save_handler — Establece funciones de almacenamiento de sesiones a nivel de usuario

Descripción

session_set_save_handler ( callable $open , callable $close , callable $read , callable $write , callable $destroy , callable $gc , callable $create_sid = ? ) : bool

Desde PHP 5.4 es posible registrar el siguiente prototipo:

session_set_save_handler ( SessionHandlerInterface $sessionhandler , bool $register_shutdown = true ) : bool

session_set_save_handler() establece las funciones de almacenamiento de sesiones a nivel de usuario que se usan para almacenar y recuperar información asociada con una sesión. Es más útil cuando se prefiere un método de almacenamiento distinto de aquellos proporcionados por las sesiones de PHP. Esto es, almacenar la información de sesión en una base de datos local.

Parámetros

Esta función tiene dos prototipos.

sessionhandler

Una instancia de una clase que implemente SessionHandlerInterface, tal como SessionHandler, para registrarla como el gestor de sesión. Sólo desde PHP 5.4.

register_shutdown

Registrar la función session_write_close() como una función register_shutdown_function().

o
open(string $savePath, string $sessionName)

La llamada de retorno open funciona como un constructor en las clases y es ejecutada cuando la sesión está siendo abierta. Es la primera función de llamada de retorno ejecutada cuando la sesión se inicia automáticamente o manualmente con session_start(). El valor devuelto es true en caso de éxito, false en caso de error.

close()

La llamada de retorno close funciona como un destructor en las clases y es ejecutada después de haber llamado a la llamada de retorno write de la sesión. También se invoca cuando se llama a session_write_close(). El valor devuelto debería ser true en caso de éxito, false en caso de error.

read(string $sessionId)

La llamada de retorno read debe devolver siempre una cadena de sesión (serializada), o una cadena vacía si no existe información que leer.

Esta llamada de retorno es llamda internamente por PHP cuando se inicia la sesión o cuando se llama a session_start(). Antes de invocar a esta llamada de sesión PHP invocará a la llamda de retorno open.

El valor que devuelve esta llamada de retorno debe estar exactamente en el mismo formato de serialización que fue originalmente pasado para el almacenamiento de la llamada de retorno write. El valor devuelto será deserializado automáticamente por PHP y srá usado para rellenar la variable superglobal $_SESSION. Aunque la información parezca similar a serialize(), observe que está en un formato diferente, el cual está especificado en la configuración ini session.serialize_handler.

write(string $sessionId, string $data)

La llamada de retorno write es llamada cuando la sesión necesita ser almacenada y cerrada. Esta llamada de retorno recibe el ID de sesión actual, una versión serializada de la variable superglobal $_SESSION. El método de serialización usado internamente por PHP está especificado en la configuración ini session.serialize_handler.

La información serializada de sesión pasada a esta llamada de retorno debería ser almacenada junto con el ID de sesión pasado. Al recuperar esta información, la llamada de retorno read debe devolver el valor exacto que fue pasado originalmente a la llamda de retorno write.

Esta llamada de retorno es invocada cuando PHP se cierra o cuando se llamda explícitamente a session_write_close(). Observe que después de ejecutar esta función PHP ejecutará internamente la llamada de retorno close.

Nota:

El gestor "write" no se ejecuta hasta después de que se cierre el flujo de salida. Así, la salida desde declaraciones de depuración en el gestor "write" nunca serán vistas en el navegador. Si es necesaria la salida de depuración, se sugiere que la salida de depuración sea escrita en un archivo en su lugar.

destroy($sessionId)

Esta llamada de retorno es ejecutada cuando una sesión es destruida con session_destroy() o con session_regenerate_id() con el parámetro destroy establecido en true. El valor devuelto debería ser true en caso de éxito, false en caso de error.

gc($lifetime)

La llamada de retorno del recolector de basura (Garbage Collector) es invocada internamente por PHP de manera periódica para destruir información antigua de sesiones. La frecuencia es controlada por session.gc_probability y session.gc_divisor. El valor del tiempo de vida (lifetime) que es pasado a esta llamada de retorno puede establecerse en session.gc_maxlifetime. El valor devuelto debería ser true en caso de éxito, false en caso de error.

create_sid()

Esta retrollamada se ejecuta cuando se requiere un nuevo ID de sesión. No se proporcionan parámetros, y el valor devuelto debería ser un string que sea un ID de sesión válido para el gestor utilizado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Gestor de seseiones personalizado: véase el código completo en la sinopsis de SessionHandlerInterface.

El siguiente código es para la versión 5.4.0 y superiror de PHP. Aquí se muestra la invocación, el código completo puede verse en la sinopsis de SessionHandlerInterface vinculada más arriba.

Observe que usamos el prototipo de POO con session_set_save_handler() y registramos la función de cierre usando la bandera de parámetro de la función. Esto se recomienda generalmente al registrar objetos como gestores de almacenamiento de sesiones.

<?php
class MySessionHandler implements SessionHandlerInterface
{
    // implementar las interfaces aquí
}

$handler = new MySessionHandler();
session_set_save_handler($handler, true);
session_start();

// proceder a estblecer y recuperar valores mediante clave desde $_SESSION

Ejemplo #2 Gestor de almacenamiento de sesiones personalizado usando objetos

El siguiente código es para versiones de PHP inferiores a 5.4.0.

El siguiente ejemplo proporciona un almacenamiento de sesiones basado en fichero similar al gestor de almacenamiento de sesiones de PHP predeterminado files. Este ejemplo podría extenderse fácilmente para cubrir el almacenamiento de bases de datos usando su motor de bases de datos favorito soportado por PHP.

Observe que registramos de forma adicional la función de cierre session_write_close() usando register_shutdown_function() bajo PHP inferior a 5.4.0. Esto se recomienda generalmente al registrar objetos como gestores de almacenamiento de sesiones bajo PHP inferior a 5.4.0.

<?php
class FileSessionHandler
{
    private $savePath;

    function open($savePath, $sessionName)
    {
        $this->savePath = $savePath;
        if (!is_dir($this->savePath)) {
            mkdir($this->savePath, 0777);
        }

        return true;
    }

    function close()
    {
        return true;
    }

    function read($id)
    {
        return (string)@file_get_contents("$this->savePath/sess_$id");
    }

    function write($id, $data)
    {
        return file_put_contents("$this->savePath/sess_$id", $data) === false ? false : true;
    }

    function destroy($id)
    {
        $file = "$this->savePath/sess_$id";
        if (file_exists($file)) {
            unlink($file);
        }

        return true;
    }

    function gc($maxlifetime)
    {
        foreach (glob("$this->savePath/sess_*") as $file) {
            if (filemtime($file) + $maxlifetime < time() && file_exists($file)) {
                unlink($file);
            }
        }

        return true;
    }
}

$handler = new FileSessionHandler();
session_set_save_handler(
    array($handler, 'open'),
    array($handler, 'close'),
    array($handler, 'read'),
    array($handler, 'write'),
    array($handler, 'destroy'),
    array($handler, 'gc')
    );

// lo siguiente previene de efectos inesperados al usar objetos como gestores de almacenamiento
register_shutdown_function('session_write_close');

session_start();
// proceder para establecer y recuperar valores por clave desde $_SESSION

Notas

Advertencia

Cuando se usan objetos como gestores de almacenamiento de sesionea es importante registrar la función de cierre con PHP para evitar efectos secundarios inesperados ya que PHP internamente destruye objetos en el cierre y puede prevenir que write y close sean llamados. Normalmente se debería registrar 'session_write_close' usando la función register_shutdown_function().

A partir de PHP 5.4.0 se puede usar session_register_shutdown() o simplemente la bandera 'register shutdown' al invocar session_set_save_handler() usando el método de POO the OOP y pasando una instancia que implemente SessionHandlerInterface.

Advertencia

A partir de PHP 5.0.5 los gestores write y close son llamados después de la destrucción del objeto y por lo tanto no pueden usar objetos o lanzar excepciones. Las excepciones no pueden ser capturadas ya que no serán capturadas ni cualquier rastro de excepción será mostrado y la ejecución se interrumpirá de improviso. Sin embargo, los destructores de objetos pueden usar sesiones.

Es posible llamar a session_write_close() desde el destructor para solucionar este problema de "quién fue antes, si el huevo o la gallina" pero la forma más fiable es registrar la función de ceirre como está descrito más arraba.

Advertencia

El directorio de trabajo actual es cambiado en algunas SAPI si la sesión se cierra al finalizar el script. Es posible cerrar la sesión antes con session_write_close().

Historial de cambios

Versión | Descripción
5.5.1 | Se añadió el parámetro opcional create_sid.
5.4.0 | Se añadió SessionHandlerInterface para la implementación de gestores de sesión y SessionHandler para exponer gestores de sesión internos de PHP.

Ver también

  • La directiva de configuración session.save_handler.
  • La directiva de configuración session.serialize_handler.
  • La función register_shutdown_function() - Registrar una función para que sea ejecutada al cierre
  • La función session_register_shutdown() - Función de cierre de sesiones para PHP 5.4.0+


Iniciar una nueva sesión o reanudar la existente

  • « session_set_save_handler
  • session_status »
  • PHP Manual
  • Funciones de sesión
  • Iniciar una nueva sesión o reanudar la existente

session_start

(PHP 4, PHP 5, PHP 7, PHP 8)

session_start — Iniciar una nueva sesión o reanudar la existente

Descripción

session_start ( array $options = [] ) : bool

session_start() crea una sesión o reanuda la actual basada en un identificador de sesión pasado mediante una petición GET o POST, o pasado mediante una cookie.

Cuando session_start() es llamada o cuando se autoinicia una sesión, PHP llamará a los gestores de almacenamiento de sesiones open y read. Éstos serán un gestor de almacenamiento proporcionado por omisión o por extensiones de PHP (como SQLite o Memcached); o pueden ser un gestor personalizado como está definido en session_set_save_handler(). La llamada de retorno read recuperará cualquier información se de sesión existente (almacenada en un formato serializado especial) y será deserializada y usada para rellenar automáticamente la variable superglobal $_SESSION cuando la llamada de retorno read devuelva la información de sesión guardada a la gestión de sesiones de PHP.

Para usar una sesión nominada llame a session_name() antes de llamar a session_start().

Cuando session.use_trans_sid está habilidado, la función session_start() registrará un gestor de salida interno para la reescritura de URL.

Si un usuario utiliza ob_gzhandler o similar con ob_start(), el orden de las funciones es importante para la salida adecuada. Por ejemplo, ob_gzhandler se debe registrar antes de iniciar una sesión.

Parámetros

options

Si se proporciona, este array asociativo de opciones sobrescribirá las directivas de configuración de sesiones establecidas actualmente. Las claves no deben incluir el prefijo session..

Además del conjunto habitual de directivas de configuración, también se puede proporcionar la opción read_and_close. Si se establece a true, resultará en el cierre inmediato de la sesión después de haber sido leída, evitando así el bloqueo inncesario si los datos de la sesión no han cambiado.

Valores devueltos

Esta función devuleve true si una sesión fue iniciada satisfactoriamente, si no, devuelve false.

Historial de cambios

Versión | Descripción
7.0.0 | Se añadió el parámetro options.
5.3.0 | Si una sesión falla al iniciarse, se devuelve false. Anteriormente se devolvía true.
4.3.3 | A partir de PHP 4.3.3, llamar a session_start() después de que una sesión estuviera previamente iniciada resultaba en un error de nivel E_NOTICE. También, el segundo inicio de sesión se ignoraba simplemente.

Ejemplos

Un ejemplo de sesión básico

Ejemplo #1 pagina1.php

<?php
// pagina1.php

session_start();

echo 'Bienvenido a la página #1';

$_SESSION['color']  = 'verde';
$_SESSION['animal'] = 'gato';
$_SESSION['instante']   = time();

// Funciona si la cookie de sesión fue aceptada
echo '<br /><a href="pagina2.php">página 2</a>';

// O quizás pasar el id de sesión, si fuera necesario
echo '<br /><a href="pagina2.php?' . SID . '">página 2</a>';
?>

Después de ver pagina1.php, la segunda página pagina2.php contendrá mágicamente la información de la sesión. Consulte la referencia de sesiones para informarse sobre la propagación de los ID de sesiones ya que explica, por ejemplo, en qué consiste la constante SID.

Ejemplo #2 pagina2.php

<?php
// pagina2.php

session_start();

echo 'Bienvenido a la página #2<br />';

echo $_SESSION['color'];  // verde
echo $_SESSION['animal']; // gato
echo date('Y m d H:i:s', $_SESSION['instante']);

// Puede ser conveniente usar el SID aquí, como hicimos en pagina1.php
echo '<br /><a href="pagina1.php">página 1</a>';
?>

Proporcionar opciones a session_start()

Ejemplo #3 Sobrescribir el tiempo de vida de la cookie

<?php
// Esto envía una cookie persistente que dura un día day.
session_start([
    'cookie_lifetime' => 86400,
]);
?>

Ejemplo #4 Leer la sesión y cerrarla

<?php
// Si sabemos que no necesitamos cambiar nada de la sesión,
// podemos simplemente leerla y cerrarla inmediatamente para evitar
// bloquear el fichero de sesión y otras páginas
session_start([
    'cookie_lifetime' => 86400,
    'read_and_close'  => true,
]);

Notas

Nota:

Para usar sesiones basadas en cookies, session_start() debe ser llamada antes de imprimir cualquier cosa en el navegador.

Nota:

Se recomienda el uso de zlib.output_compression en vez de ob_gzhandler()

Nota:

Esta función envía varias cabeceras HTTP dependiendo de la configuración. Véase session_cache_limiter() para personalizar estas cabeceras.

Ver también

  • $_SESSION
  • La directiva de configuarción session.auto_start
  • session_id() - Obtener y/o establecer el id de sesión actual


Devuelve el estado de la sesión actual

  • « session_start
  • session_unregister »
  • PHP Manual
  • Funciones de sesión
  • Devuelve el estado de la sesión actual

session_status

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

session_status — Devuelve el estado de la sesión actual

Descripción

session_status ( ) : int

session_status() se usa para devolver el estado de la sesión actual

Valores devueltos

  • PHP_SESSION_DISABLED si las sesiones están deshabilitadas.
  • PHP_SESSION_NONE si las sesiones están habilitadas, pero no existe ninguna.
  • PHP_SESSION_ACTIVE si las sesiones están habilitadas, y existe una.

Ver también

  • session_start() - Iniciar una nueva sesión o reanudar la existente


Deja de registrar una variable global de la sesión actual

  • « session_status
  • session_unset »
  • PHP Manual
  • Funciones de sesión
  • Deja de registrar una variable global de la sesión actual

session_unregister

(No hay información de versión disponible, podría estar únicamente en Git)

session_unregister — Deja de registrar una variable global de la sesión actual

Descripción

session_unregister ( string $name ) : bool

session_unregister() deja de registrar una variable global name de la sesión actual.

Advertencia

Esta función ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

Parámetros

name

El nombre de la variable.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Si se usa $_SESSION (o $HTTP_SESSION_VARS para PHP 4.0.6 o anterior), utilice unset() para dejar de registrar una variable de sesión. No use unset() con $_SESSION ya que deshabilitará la función especial de la matriz superglobal $_SESSION.

Precaución

Esta función no destruye la variable global correspondiente para name, sólo impide que la variable sea guardada como parte de la sesión. Se debe llamar a unset() para eliminar la variable global correspondiente.

Precaución

Si está usando $_SESSION (o
$HTTP_SESSION_VARS), no use
session_register(),
session_is_registered() y
session_unregister().


Libera todas las variables de sesión

  • « session_unregister
  • session_write_close »
  • PHP Manual
  • Funciones de sesión
  • Libera todas las variables de sesión

session_unset

(PHP 4, PHP 5, PHP 7, PHP 8)

session_unset — Libera todas las variables de sesión

Descripción

session_unset ( ) : void

La función session_unset() libera todas las variables de sesión actualmente registradas.

Valores devueltos

No devuelve ningún valor.

Notas

Nota:

Si se usa $_SESSION (o $HTTP_SESSION_VARS para PHP 4.0.6 o anterior), utilice unset() para dejar de registrar una variable de sesión, esto es, unset ($_SESSION['nombre_variable']);.

Precaución

NO destruya completamente $_SESSION con unset($_SESSION) ya que esto deshabilitará el registro de variables de sesión a través del array superglobal $_SESSION.


Escribir información de sesión y finalizar la sesión

  • « session_unset
  • SessionHandler »
  • PHP Manual
  • Funciones de sesión
  • Escribir información de sesión y finalizar la sesión

session_write_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

session_write_close — Escribir información de sesión y finalizar la sesión

Descripción

session_write_close ( ) : void

Finaliza la sesión actual y almacena la información de la sesión.

La información de la sesión normalmente se almacena después de que el script termine sin la necesidad de llamar a session_write_close(), pero ya que la información de la sesión está bloqueada para prevenir escrituras concurrentes, sólo el script puede operar sobre una sesión cada vez. Cuando se usan sub-ventanas (frames) junto con sesiones, experimentará que las sub-ventanas se cargan de una en una debido a este bloqueo. Puede reducir el tiempo necesario para cargar todas las sub-ventanas finalizando la sesión tan pronto como todos los cambios a las variables de sesión estén hechos.

Valores devueltos

No devuelve ningún valor.

Ver también

  • La función session_register_shutdown() - Función de cierre de sesiones


La clase SessionHandler

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Introducción

SessionHandler es una clase especial que puede usarse para exponer el gestor de almacenamiento de sesiones interno actual de PHP por herencia. Existen siete métodos que envuelven las sietes retrollamadas del gestor de almacenamiento de sesiones (open, close, read, write, destroy, gc y create_sid). Por defecto, esta clase envolverá cualquier gestor de almacenamiento que esté establecido como está definido por la directiva de configuración session.save_handler, el cual normalmente es files por omisión. Otros gestores de almacenamiento de sesión internos son proporcionados por extensiones de PHP tales como SQLite (como sqlite), Memcache (como memcache), y Memcached (como Memcached).

Cuando se establece una simple instancia de SessionHandler como el gestor de almacenamiento usando session_set_save_handler(), envolverá los gestores de almacenamiento actuales. Una clase que extienda de SessionHandler permite sobrescribir los métodos o interceptarlos o filtrarlos llamando a los métodos de la clase madre, los cuales en última instancia envolverán los gestores de sesiones de PHP internos.

Esto permite, por ejemplo, interceptar los métodos read y write para encriptar/desencriptar la información de sesión y luego pasar el resultado hacia y desde la clase madre. De forma alternativa se podría elegir sobrescribir por completo un método como la llamada de retorno del recolector de basura gc.

Ya que SessionHandler envuelve los métodos del gestor de almacenamiento interno actual, el ejemplo de arriba de encriptación puede aplicarse a cualquier gestor de almacenamiento interno sin tener que conocer los entresijos de los gestores.

Para usar esta clase, primero establezca el gestor de almacenamiento que desee exponer usando session.save_handler y luego pasar una instancia de SessionHandler o una que la extienda a session_set_save_handler().

Observe que los métodos de llamda de retorno de esta clase están diseñados para ser llamados internamente por PHP y no para ser llamados desde código de espacio de usuario. Los valores devueltos son igualmente procesados internamente por PHP. Para más información sobre el flujo de trabajo de sesiones consulte session_set_save_handler().

Sinopsis de la Clase

SessionHandler implements SessionHandlerInterface {
/* Métodos */
public close ( ) : bool
public create_sid ( ) : string
public destroy ( string $session_id ) : bool
public gc ( int $maxlifetime ) : int
public open ( string $save_path , string $session_name ) : bool
public read ( string $session_id ) : string
public write ( string $session_id , string $session_data ) : bool
}
Advertencia

Esta clase está diseñada para exponer el gestor de almacenamiento de sesiones interno de PHP, si quiere escribir sus propios gestores de almacenamiento, implemente la interfaz SessionHandlerInterface en lugar de extender desde SessionHandler.

Historial de cambios

Versión | Descripción
5.5.1 | Se añadió SessionHandler::create_sid().

Ejemplo #1 Usar SessionHandler para añadir encriptación a los gestores de almacenamiento internos de PHP.

<?php

 /**
  * decrypt AES 256
  *
  * @param data $edata
  * @param string $password
  * @return decrypted data
  */
function decrypt($edata, $password) {
    $data = base64_decode($edata);
    $salt = substr($data, 0, 16);
    $ct = substr($data, 16);

    $rounds = 3; // depends on key length
    $data00 = $password.$salt;
    $hash = array();
    $hash[0] = hash('sha256', $data00, true);
    $result = $hash[0];
    for ($i = 1; $i < $rounds; $i++) {
        $hash[$i] = hash('sha256', $hash[$i - 1].$data00, true);
        $result .= $hash[$i];
    }
    $key = substr($result, 0, 32);
    $iv  = substr($result, 32,16);

    return openssl_decrypt($ct, 'AES-256-CBC', $key, true, $iv);
  }

/**
 * crypt AES 256
 *
 * @param data $data
 * @param string $password
 * @return base64 encrypted data
 */
function encrypt($data, $password) {
    // Set a random salt
    $salt = openssl_random_pseudo_bytes(16);

    $salted = '';
    $dx = '';
    // Salt the key(32) and iv(16) = 48
    while (strlen($salted) < 48) {
      $dx = hash('sha256', $dx.$password.$salt, true);
      $salted .= $dx;
    }

    $key = substr($salted, 0, 32);
    $iv  = substr($salted, 32,16);

    $encrypted_data = openssl_encrypt($data, 'AES-256-CBC', $key, true, $iv);
    return base64_encode($salt . $encrypted_data);
}

class EncryptedSessionHandler extends SessionHandler
{
    private $key;

    public function __construct($key)
    {
        $this->key = $key;
    }

    public function read($id)
    {
        $data = parent::read($id);

        if (!$data) {
            return "";
        } else {
            return decrypt($data, $this->key);
        }
    }

    public function write($id, $data)
    {
        $data = encrypt($data, $this->key);

        return parent::write($id, $data);
    }
}

// interceptaremos el manejador nativo 'files', pero funcionaría igualmente
// con otros manejadores nativos internos como 'sqlite', 'memcache' o 'memcached'
// que son proporcionados por extensiones de PHP.
ini_set('session.save_handler', 'files');

$key = 'secret_string';
$handler = new EncryptedSessionHandler($key);
session_set_save_handler($handler, true);
session_start();

// proceder para establecer y recuperar valores por clave desde $_SESSION

Nota:

Ya que los métodos de esta clase están diseñados para se llamados internamente por PHP como parte del flujo de trabajo normal, las llamadas de las clases hijas a los métodos padre (es decir, los gestores nativos internos reales) devolverán false a menos que la sesión haya sido iniciada realmente (automáticamente o explícitamente mediante session_start()). Es importante considerar esto cuando se escriben unidades de pruebas donde los métodos de la clase podrían ser invocados manualmente.

Tabla de contenidos

  • SessionHandler::close — Cerrar la sesión
  • SessionHandler::create_sid — Devuelve un nuevo ID de sesión
  • SessionHandler::destroy — Destruir una sesión
  • SessionHandler::gc — Eliminar las sesiones antiguas
  • SessionHandler::open — Inicializar una sesión
  • SessionHandler::read — Leer información de la sesión
  • SessionHandler::write — Escribir información de sesión


Cerrar la sesión

  • « SessionHandler
  • SessionHandler::create_sid »
  • PHP Manual
  • SessionHandler
  • Cerrar la sesión

SessionHandler::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::close — Cerrar la sesión

Descripción

public SessionHandler::close ( ) : bool

Cierra la sesión actual. Este método es ejecutado de forma automática internamente por PHP al cerrar la sesión, o explícitamente mediante la función session_write_close() (la cual llama primero a la función SessionHandler::write()).

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese activado mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre close invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que el método sea sobrescrito y/o interceptado.

Para más información sobre lo que se espera que haga este método, consulte la documentación de SessionHandlerInterface::close().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Devuelve un nuevo ID de sesión

  • « SessionHandler::close
  • SessionHandler::destroy »
  • PHP Manual
  • SessionHandler
  • Devuelve un nuevo ID de sesión

SessionHandler::create_sid

(PHP 5 >= 5.5.1, PHP 7, PHP 8)

SessionHandler::create_sid — Devuelve un nuevo ID de sesión

Descripción

public SessionHandler::create_sid ( ) : string

Genera y devuelve un nuevo ID de sesión

Valores devueltos

Un ID de sesión válido para el manejador de sesión predeterminado.

Ver también

  • session_id() - Obtener y/o establecer el id de sesión actual
  • session_create_id() - Crear un nuevo ID de sesión


Destruir una sesión

  • « SessionHandler::create_sid
  • SessionHandler::gc »
  • PHP Manual
  • SessionHandler
  • Destruir una sesión

SessionHandler::destroy

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::destroy — Destruir una sesión

Descripción

public SessionHandler::destroy ( string $session_id ) : bool

Destruye una sesión. Llamado internamente por PHP con session_regenerate_id() (se asume que $destroy está establecido a true, mediante session_destroy() o cuando session_decode() falla.

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese establecido mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre destroy invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que este método sea sobrescrito y/o interceptado y filtrado.

Para más información sobre lo que se espera que haga este método, consulte la documentación de SessionHandlerInterface::destroy().

Parámetros

session_id

El ID de sesión a ser destruido.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Eliminar las sesiones antiguas

  • « SessionHandler::destroy
  • SessionHandler::open »
  • PHP Manual
  • SessionHandler
  • Eliminar las sesiones antiguas

SessionHandler::gc

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::gc — Eliminar las sesiones antiguas

Descripción

public SessionHandler::gc ( int $maxlifetime ) : int

Elimina las sesiones expiradas. Este método llamado de forma aleatoria internamente por PHP al iniciar una sesión o cuando se invoca a session_start(). La frecuencia con la que es llamado está basada en las directivas de configuración session.gc_divisor y session.gc_probability.

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese establecido mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre gc invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que el método sea sobrescrito y/o interceptado.

Para más información sobre el funcionamiento de este método, consulte la documentación de SessionHandlerInterface::gc().

Parámetros

maxlifetime

Las sesiones que no se han actualizado desde los últimos maxlifetime segundos serán eliminadas.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Inicializar una sesión

  • « SessionHandler::gc
  • SessionHandler::read »
  • PHP Manual
  • SessionHandler
  • Inicializar una sesión

SessionHandler::open

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::open — Inicializar una sesión

Descripción

public SessionHandler::open ( string $save_path , string $session_name ) : bool

Crea una nueva sesión, o reinicializa una sesión existente. Es llamado internamente por PHP cuando se inicia una sesión automáticamente o cuando se invoca a session_start().

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese establecido mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre open invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que este método sea sobrescrito y/o interceptado.

Para más información sobre lo que puede hacer este método, consulte la documentación de SessionHandlerInterface::open().

Parámetros

save_path

La ruta donde almacenar/recuperar la sesión.

session_name

El nombre de la sesión.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.

Ver también

  • La directiva de configuración session.auto-start.


Leer información de la sesión

  • « SessionHandler::open
  • SessionHandler::write »
  • PHP Manual
  • SessionHandler
  • Leer información de la sesión

SessionHandler::read

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::read — Leer información de la sesión

Descripción

public SessionHandler::read ( string $session_id ) : string

Lee la información de la sesión desde el almacén de sesiones, y devuelve los resultados a PHP para su procesamiento interno. Este método es llamado automáticamente por PHP cuando se inicia una sesión (automáticamente o explícitamente con session_start()) y está precedido por una llamada interna a la función SessionHandler::open().

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese establecido mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre read invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que el método sea sobrescrito y/o interceptado y filtrado (por ejemplo, desencriptando el valor de $data devuelto por el método padre read).

Para más información sobre lo que se espera que haga este método, consulte la documentación de SessionHandlerInterface::close().

Parámetros

session_id

El id de sesión de donde leer la información.

Valores devueltos

Devuelve una cadena codificada de la información leída. Si no se leyó nada, debe devolver una cadena vacía. Observe que este valor es devuelto internamente a PHP para su procesamiento.

Ver también

  • La directiva de configuración session.serialize_handler.


Escribir información de sesión

  • « SessionHandler::read
  • SessionHandlerInterface »
  • PHP Manual
  • SessionHandler
  • Escribir información de sesión

SessionHandler::write

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::write — Escribir información de sesión

Descripción

public SessionHandler::write ( string $session_id , string $session_data ) : bool

Escribe la información de la sesión en el almacén de sesiones. Es llamado por el cierre normal de PHP, por session_write_close(), o cuando session_register_shutdown() falla. PHP llamará a SessionHandler::close() inmediatemente después de que este método devuelva.

Este método envuelve el gestor de almacenamiento interno de PHP definido en el ajuste ini session.save_handler que fue establecido antes de que este gestor fuese establecido mediante session_set_save_handler().

Si esta clase se extiende por herencia, al llamar al método padre write invocará a la envoltura para este método y así invocará a la llamada de retorno interna asociada. Esto permite que este método sea sobrescrito y/o interceptado y filtrado (por ejemplo, encriptando el valor de $data antes de enviarlo al método padre write).

Para más información sobre lo que se espera que haga este método, consulte la documentación de SessionHandlerInterface::write().

Parámetros

session_id

El id de la sesión.

session_data

La información de sesión codificada. Esta información es el resultado de codificar internamente la variable superglobal $_SESSION a una cadena serializada y pasarla como este parámetro. Observe que las sesiones usan un método de serialización alternativo.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.

Ver también

  • La directiva de configuración session.serialize_handler.


La clase SessionHandlerInterface

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Introducción

SessionHandlerInterface es una interfaz que define un prototipo para crear un gestor de sesiones personalizado. Para pasar un gestor de sesiones personalizado a session_set_save_handler() usando su invocación de POO, la clase debe implementar esta interfaz.

Observe que los métodos de llamada de retorno de esta clase están diseñados para ser llamados internamente por PHP y no para ser llamados desde código de espacio de usuario.

Sinopsis de la Clase

SessionHandlerInterface {
/* Métodos */
abstract public close ( ) : bool
abstract public destroy ( string $session_id ) : bool
abstract public gc ( int $maxlifetime ) : int
abstract public open ( string $save_path , string $session_name ) : bool
abstract public read ( string $session_id ) : string
abstract public write ( string $session_id , string $session_data ) : bool
}

Ejemplo #1 Ejemplo usando SessionHandlerInterface

El siguiente ejemplo proporciona almacenamiento de sesiones basado en ficheros similar al gestor de almacenamiento de sesiones predeterminado de PHP files. Este ejemplo podría fácilmente ser extendido para cubrir almacenamiento de bases de datos usando su motor de bases de datos favorito soportado por PHP.

Observe que usamos el prototipo de POO con session_set_save_handler() y registramos la función de cierre usando la bandera de parámetro de la función. Esto normalmente es aconsejable al registrar objetos como gestores de almacenamiento de sesiones.

<?php
class MySessionHandler implements SessionHandlerInterface
{
    private $savePath;

    public function open($savePath, $sessionName)
    {
        $this->savePath = $savePath;
        if (!is_dir($this->savePath)) {
            mkdir($this->savePath, 0777);
        }

        return true;
    }

    public function close()
    {
        return true;
    }

    public function read($id)
    {
        return (string)@file_get_contents("$this->savePath/sess_$id");
    }

    public function write($id, $data)
    {
        return file_put_contents("$this->savePath/sess_$id", $data) === false ? false : true;
    }

    public function destroy($id)
    {
        $file = "$this->savePath/sess_$id";
        if (file_exists($file)) {
            unlink($file);
        }

        return true;
    }

    public function gc($maxlifetime)
    {
        foreach (glob("$this->savePath/sess_*") as $file) {
            if (filemtime($file) + $maxlifetime < time() && file_exists($file)) {
                unlink($file);
            }
        }

        return true;
    }
}

$handler = new MySessionHandler();
session_set_save_handler($handler, true);
session_start();

// proceed to set and retrieve values by key from $_SESSION

Tabla de contenidos

  • SessionHandlerInterface::close — Cerrar la sesión
  • SessionHandlerInterface::destroy — Destruir una sesión
  • SessionHandlerInterface::gc — Limpieza de sesiones antiguas
  • SessionHandlerInterface::open — Inicializar una sesión
  • SessionHandlerInterface::read — Leer información de sesión
  • SessionHandlerInterface::write — Escribir información de sesión


Cerrar la sesión

  • « SessionHandlerInterface
  • SessionHandlerInterface::destroy »
  • PHP Manual
  • SessionHandlerInterface
  • Cerrar la sesión

SessionHandlerInterface::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::close — Cerrar la sesión

Descripción

abstract public SessionHandlerInterface::close ( ) : bool

Cierra la sesión actual. Esta función se ejecuta automáticamente al cerrar la sesión, o explícitamente mediante session_write_close().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Destruir una sesión

  • « SessionHandlerInterface::close
  • SessionHandlerInterface::gc »
  • PHP Manual
  • SessionHandlerInterface
  • Destruir una sesión

SessionHandlerInterface::destroy

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::destroy — Destruir una sesión

Descripción

abstract public SessionHandlerInterface::destroy ( string $session_id ) : bool

Destruye una sesión. Llamado por session_regenerate_id() (con $destroy = true), session_destroy() y cuando session_decode() falla.

Parámetros

session_id

El ID de sesión a ser destruido.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Limpieza de sesiones antiguas

  • « SessionHandlerInterface::destroy
  • SessionHandlerInterface::open »
  • PHP Manual
  • SessionHandlerInterface
  • Limpieza de sesiones antiguas

SessionHandlerInterface::gc

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::gc — Limpieza de sesiones antiguas

Descripción

abstract public SessionHandlerInterface::gc ( int $maxlifetime ) : int

Limpia las sesiones expiradas. Llamado por session_start(), basado en las configuraciones session.gc_divisor, session.gc_probability y session.gc_maxlifetime.

Parámetros

maxlifetime

Las sesiones que no han sido actualizadas desde los últimos maxlifetime segundos serán eliminadas.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.


Inicializar una sesión

  • « SessionHandlerInterface::gc
  • SessionHandlerInterface::read »
  • PHP Manual
  • SessionHandlerInterface
  • Inicializar una sesión

SessionHandlerInterface::open

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::open — Inicializar una sesión

Descripción

abstract public SessionHandlerInterface::open ( string $save_path , string $session_name ) : bool

Reinicializa una sesión existente, o crea una nueva. Llamado cuando una sesión se inicia o cuando se invoca a session_start().

Parámetros

save_path

La ruta donde almacenar/recuperar la sesión.

session_name

El nombre de la sesión.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.

Ver también

  • session_name() - Obtener y/o establecer el nombre de la sesión actual
  • La directiva de configuración session.auto-start.


Leer información de sesión

  • « SessionHandlerInterface::open
  • SessionHandlerInterface::write »
  • PHP Manual
  • SessionHandlerInterface
  • Leer información de sesión

SessionHandlerInterface::read

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::read — Leer información de sesión

Descripción

abstract public SessionHandlerInterface::read ( string $session_id ) : string

Lee la información de sesión desde el almacenamiento de sesiones, y devuelve el resultado. Llamado justo después de iniciarse una sesión o cuando es llamada session_start(). Observe que antes de que este método sea llamado SessionHandlerInterface::open() es invocado.

Este método es llmado por PHP cuando la sesión es iniciada. Este método debería recuperar la información de sesión desde el almacenamiento mediante el ID de sesión proporcionado. La cadena devuelta por este método debe estar en el mismo formato serializado que el orgibal pasado a SessionHandlerInterface::write() Si no se encuentra el registro, devuelve una cadena vacía.

La información devuelta por este método será decodificada internamente por PHP usando el método de deserialización especificado en session.serialize_handler. La información resultante será usada para rellenar la variable superglobal $_SESSION.

Observe que el esquema de serialización no es el mismo que unserialize() y pudede accederse a él mediante session_decode().

Parámetros

session_id

El ID de sesión.

Valores devueltos

Devuelve una cadena codificada de la información leída. Si no se leyó nada, debe devolver una cadena vacía. Observe que este valor es devuelto internamente por PHP para procesamiento.

Ver también

  • La directiva de configuración session.serialize_handler.


Escribir información de sesión

  • « SessionHandlerInterface::read
  • SessionIdInterface »
  • PHP Manual
  • SessionHandlerInterface
  • Escribir información de sesión

SessionHandlerInterface::write

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::write — Escribir información de sesión

Descripción

abstract public SessionHandlerInterface::write ( string $session_id , string $session_data ) : bool

Escribe información de sesión al almacenamiento de sesiones. Llamado por session_write_close(), cuando session_register_shutdown() falla, o durante un cierre normal. Nota: SessionHandlerInterface::close() es llamado inmediantamente después de esta función.

PHP llamará a este método cuando la sesión esté lista para ser almacenada y cerrada. Codifica la información de sesión desde la variable superglobal $_SESSION a una cadena serializada y la pasa junto con el ID de sersión a este método para el almacenamiento. El método de serialización usado está especificado en la configuración session.serialize_handler.

Observe que este método normalmente es llamado por PHP después de que los buffers de salida hayan sido cerrados a menos que se llame explícitamente a session_write_close()

Parámetros

session_id

El ID de sesión.

session_data

La información de sesión codificada. Esta información es el resultado de que PHP codifique internamente la variable supergobal $_SESSION a una cadena serializada y pasarla a este parámetro. Observe que las sesiones usan un método de serialización alternativo.

Valores devueltos

El valor devuelto (normalmente true en caso de éxito, false en caso de error). Observe que este valor es devuelto internamente a PHP para su procesamiento.

Ver también

  • La directiva de configuración session.serialize_handler.


The SessionIdInterface interface

(PHP 5 >= 5.5.1, PHP 7, PHP 8)

Introducción

SessionIdInterface is an interface which defines optional methods for creating a custom session handler. In order to pass a custom session handler to session_set_save_handler() using its OOP invocation, the class can implement this interface.

Note that the callback methods of classes implementing this interface are designed to be called internally by PHP and are not meant to be called from user-space code.

Sinopsis de la Clase

SessionIdInterface {
/* Métodos */
abstract public create_sid ( ) : string
}

Tabla de contenidos

  • SessionIdInterface::create_sid — Create session ID


Create session ID

  • « SessionIdInterface
  • SessionUpdateTimestampHandlerInterface »
  • PHP Manual
  • SessionIdInterface
  • Create session ID

SessionIdInterface::create_sid

(PHP 5 >= 5.5.1, PHP 7, PHP 8)

SessionIdInterface::create_sid — Create session ID

Descripción

abstract public SessionIdInterface::create_sid ( ) : string

Creates a new session ID.This function is automatically executed when a new session ID needs to be created.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The new session ID. Note that this value is returned internally to PHP for processing.

Ver también

  • SessionHandler::create_sid() - Devuelve un nuevo ID de sesión


The SessionUpdateTimestampHandlerInterface interface

(PHP 7, PHP 8)

Introducción

SessionUpdateTimestampHandlerInterface is an interface which defines optional methods for creating a custom session handler. In order to pass a custom session handler to session_set_save_handler() using its OOP invocation, the class can implement this interface.

Note that the callback methods of classes implementing this interface are designed to be called internally by PHP and are not meant to be called from user-space code.

Sinopsis de la Clase

SessionUpdateTimestampHandlerInterface {
/* Métodos */
abstract public updateTimestamp ( string $id , string $data ) : bool
abstract public validateId ( string $id ) : bool
}

Tabla de contenidos

  • SessionUpdateTimestampHandlerInterface::updateTimestamp — Update timestamp
  • SessionUpdateTimestampHandlerInterface::validateId — Validate ID


Update timestamp

  • « SessionUpdateTimestampHandlerInterface
  • SessionUpdateTimestampHandlerInterface::validateId »
  • PHP Manual
  • SessionUpdateTimestampHandlerInterface
  • Update timestamp

SessionUpdateTimestampHandlerInterface::updateTimestamp

(PHP 7, PHP 8)

SessionUpdateTimestampHandlerInterface::updateTimestamp — Update timestamp

Descripción

abstract public SessionUpdateTimestampHandlerInterface::updateTimestamp ( string $id , string $data ) : bool

Updates the last modification timestamp of the session. This function is automatically executed when a session is updated.

Parámetros

id

The session ID.

data

The session data.

Valores devueltos

Returns true if the timestamp was updated, false otherwise. Note that this value is returned internally to PHP for processing.


Validate ID

  • « SessionUpdateTimestampHandlerInterface::updateTimestamp
  • Procesamiento de texto »
  • PHP Manual
  • SessionUpdateTimestampHandlerInterface
  • Validate ID

SessionUpdateTimestampHandlerInterface::validateId

(PHP 7, PHP 8)

SessionUpdateTimestampHandlerInterface::validateId — Validate ID

Descripción

abstract public SessionUpdateTimestampHandlerInterface::validateId ( string $id ) : bool

Validates a given session ID. A session ID is valid, if a session with that ID already exists. This function is automatically executed when a session is to be started, a session ID is supplied and session.use_strict_mode is enabled.

Parámetros

id

The session ID.

Valores devueltos

Returns true for valid ID, false otherwise. Note that this value is returned internally to PHP for processing.


Procesamiento de texto

  • CommonMark
    • Introducción
    • Instalación/Configuración
    • CommonMark\Node\Document — Document concrete CommonMark\Node
    • CommonMark\Node\Heading — Heading concrete CommonMark\Node
    • CommonMark\Node\Paragraph — Paragraph concrete CommonMark\Node
    • CommonMark\Node\BlockQuote — BlockQuote concrete CommonMark\Node
    • CommonMark\Node\BulletList — BulletList concrete CommonMark\Node
    • CommonMark\Node\OrderedList — OrderedList concrete CommonMark\Node
    • CommonMark\Node\Item — Item concrete CommonMark\Node
    • CommonMark\Node\Text — Text concrete CommonMark\Node
    • CommonMark\Node\Text\Strong — Strong concrete CommonMark\Node
    • CommonMark\Node\Text\Emphasis — Emphasis concrete CommonMark\Node
    • CommonMark\Node\ThematicBreak — ThematicBreak concrete CommonMark\Node
    • CommonMark\Node\SoftBreak — SoftBreak concrete CommonMark\Node
    • CommonMark\Node\LineBreak — LineBreak concrete CommonMark\Node
    • CommonMark\Node\Code — Code concrete CommonMark\Node
    • CommonMark\Node\CodeBlock — CodeBlock concrete CommonMark\Node
    • CommonMark\Node\HTMLBlock — HTMLBlock concrete CommonMark\Node
    • CommonMark\Node\HTMLInline — HTMLInline concrete CommonMark\Node
    • CommonMark\Node\Image — Image concrete CommonMark\Node
    • CommonMark\Node\Link — Link concrete CommonMark\Node
    • CommonMark\Node\CustomBlock — CustomBlock concrete CommonMark\Node
    • CommonMark\Node\CustomInline — CustomInline concrete CommonMark\Node
    • CommonMark\Node — Abstract CommonMark\Node
    • CommonMark\Interfaces\IVisitor — The CommonMark\Interfaces\IVisitor interface
    • CommonMark\Interfaces\IVisitable — The CommonMark\Interfaces\IVisitable interface
    • CommonMark\Parser — The CommonMark\Parser class
    • CommonMark\CQL — The CommonMark\CQL class
    • CommonMark Funciones
  • Parle — Parsing and lexing
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Pattern matching — Parle pattern matching
    • Ejemplos
    • Parle\Lexer — The Parle\Lexer class
    • Parle\RLexer — The Parle\RLexer class
    • Parle\Parser — The Parle\Parser class
    • Parle\RParser — The Parle\RParser class
    • Parle\Stack — The Parle\Stack class
    • Parle\Token — The Parle\Token class
    • Parle\ErrorInfo — The Parle\ErrorInfo class
    • Parle\LexerException — The Parle\LexerException class
    • Parle\ParserException — The Parle\ParserException class
  • PCRE — Expresiones regulares (compatibles con Perl)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Patrones PCRE
    • Funciones de PCRE
  • Expresiones Regulares de POSIX — Expresiones Regulares (POSIX Extendido)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de expresiones regulares POSIX
  • ssdeep — ssdeep Fuzzy Hashing
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones ssdeep
  • Strings
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de strings
    • Registro de cambios


CommonMark

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • CommonMark\Node\Document — Document concrete CommonMark\Node
  • CommonMark\Node\Heading — Heading concrete CommonMark\Node
    • CommonMark\Node\Heading::__construct — Constructor Heading
  • CommonMark\Node\Paragraph — Paragraph concrete CommonMark\Node
  • CommonMark\Node\BlockQuote — BlockQuote concrete CommonMark\Node
  • CommonMark\Node\BulletList — BulletList concrete CommonMark\Node
    • CommonMark\Node\BulletList::__construct — Construcción BulletList
  • CommonMark\Node\OrderedList — OrderedList concrete CommonMark\Node
    • CommonMark\Node\OrderedList::__construct — Constructor OrderedList
  • CommonMark\Node\Item — Item concrete CommonMark\Node
  • CommonMark\Node\Text — Text concrete CommonMark\Node
    • CommonMark\Node\Text::__construct — Constructor Text
  • CommonMark\Node\Text\Strong — Strong concrete CommonMark\Node
  • CommonMark\Node\Text\Emphasis — Emphasis concrete CommonMark\Node
  • CommonMark\Node\ThematicBreak — ThematicBreak concrete CommonMark\Node
  • CommonMark\Node\SoftBreak — SoftBreak concrete CommonMark\Node
  • CommonMark\Node\LineBreak — LineBreak concrete CommonMark\Node
  • CommonMark\Node\Code — Code concrete CommonMark\Node
  • CommonMark\Node\CodeBlock — CodeBlock concrete CommonMark\Node
    • CommonMark\Node\CodeBlock::__construct — Constructor CodeBlock
  • CommonMark\Node\HTMLBlock — HTMLBlock concrete CommonMark\Node
  • CommonMark\Node\HTMLInline — HTMLInline concrete CommonMark\Node
  • CommonMark\Node\Image — Image concrete CommonMark\Node
    • CommonMark\Node\Image::__construct — Constructor Image
  • CommonMark\Node\Link — Link concrete CommonMark\Node
    • CommonMark\Node\Link::__construct — Constructor Link
  • CommonMark\Node\CustomBlock — CustomBlock concrete CommonMark\Node
  • CommonMark\Node\CustomInline — CustomInline concrete CommonMark\Node
  • CommonMark\Node — Abstract CommonMark\Node
    • CommonMark\Node::appendChild — Manipulación AST
    • CommonMark\Node::prependChild — Manipulación AST
    • CommonMark\Node::insertAfter — Manipulación AST
    • CommonMark\Node::insertBefore — Manipulación AST
    • CommonMark\Node::replace — Manipulación AST
    • CommonMark\Node::unlink — Manipulación AST
    • CommonMark\Node::accept — Visitation
  • CommonMark\Interfaces\IVisitor — The CommonMark\Interfaces\IVisitor interface
    • CommonMark\Interfaces\IVisitor::enter — Visitation
    • CommonMark\Interfaces\IVisitor::leave — Visitation
  • CommonMark\Interfaces\IVisitable — The CommonMark\Interfaces\IVisitable interface
    • CommonMark\Interfaces\IVisitable::accept — Visitation
  • CommonMark\Parser — The CommonMark\Parser class
    • CommonMark\Parser::__construct — Constructor Parser
    • CommonMark\Parser::parse — Parsing
    • CommonMark\Parser::finish — Parsing
  • CommonMark\CQL — The CommonMark\CQL class
    • CommonMark\CQL::__construct — Constructor CQL
    • CommonMark\CQL::__invoke — CQL Execution
  • CommonMark Funciones
    • CommonMark\Parse — Parsing
    • CommonMark\Render — Rendering
    • CommonMark\Render\HTML — Rendering
    • CommonMark\Render\Latex — Rendering
    • CommonMark\Render\Man — Rendering
    • CommonMark\Render\XML — Rendering


Introducción

This extension provides access to the reference implementation of CommonMark, a rationalized version of Markdown syntax with a specification.

Parsing:

The CommonMark extension provides a simple parsing API:

CommonMark\Parse ( string $content , int $options = ? ) : CommonMark\Node

Rendering:

The CommonMark extension provides simple rendering API that supports multiple formats:

CommonMark\Render ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string
CommonMark\Render\HTML ( CommonMark\Node $node , int $options = ? ) : string
CommonMark\Render\XML ( CommonMark\Node $node , int $options = ? ) : string
CommonMark\Render\Man ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string
CommonMark\Render\Latex ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

AST:

The CommonMark extension implements visitation for CommonMark\Node objects:

public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

CQL:

The CommonMark extension provides an interface to CQL, CommonMark Query Language:

public CommonMark\CQL::__construct ( string $query )


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • CommonMark
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

The CommonMark extension requires the (C) reference implementation of » cmark.


Instalación

The CommonMark extension releases are hosted by PECL and source is hosted on » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/cmark.

Windows users can download prebuilt release binaries from the » PECL website.

Precaución

Windows users need to take the additional step of adding cmark.dll (distributed with Windows releases) to their PATH.


Document concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Document extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Heading concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Heading extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public int $level ;
/* Constructor */
public __construct ( )
public __construct ( int $level )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\Heading::__construct — Constructor Heading


Constructor Heading

  • « CommonMark\Node\Heading
  • CommonMark\Node\Paragraph »
  • PHP Manual
  • CommonMark\Node\Heading
  • Constructor Heading

CommonMark\Node\Heading::__construct

(cmark >= 1.0.0)

CommonMark\Node\Heading::__construct — Constructor Heading

Descripción

public CommonMark\Node\Heading::__construct ( )
public CommonMark\Node\Heading::__construct ( int $level )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


Paragraph concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Paragraph extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


BlockQuote concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\BlockQuote extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


BulletList concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\BulletList extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public bool $tight ;
public int $delimiter ;
/* Constructor */
public __construct ( )
public __construct ( int $tight )
public __construct ( int $tight , int $delimiter )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\BulletList::__construct — Construcción BulletList


Construcción BulletList

  • « CommonMark\Node\BulletList
  • CommonMark\Node\OrderedList »
  • PHP Manual
  • CommonMark\Node\BulletList
  • Construcción BulletList

CommonMark\Node\BulletList::__construct

(cmark >= 1.0.0)

CommonMark\Node\BulletList::__construct — Construcción BulletList

Descripción

public CommonMark\Node\BulletList::__construct ( )
public CommonMark\Node\BulletList::__construct ( int $tight )
public CommonMark\Node\BulletList::__construct ( int $tight , int $delimiter )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.


OrderedList concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\OrderedList extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public bool $tight ;
public int $delimiter ;
public int $start ;
/* Constructor */
public __construct ( )
public __construct ( int $tight )
public __construct ( int $tight , int $delimiter )
public __construct ( int $tight , int $delimiter , int $start )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\OrderedList::__construct — Constructor OrderedList


Constructor OrderedList

  • « CommonMark\Node\OrderedList
  • CommonMark\Node\Item »
  • PHP Manual
  • CommonMark\Node\OrderedList
  • Constructor OrderedList

CommonMark\Node\OrderedList::__construct

(cmark >= 1.0.0)

CommonMark\Node\OrderedList::__construct — Constructor OrderedList

Descripción

public CommonMark\Node\OrderedList::__construct ( )
public CommonMark\Node\OrderedList::__construct ( int $tight )
public CommonMark\Node\OrderedList::__construct ( int $tight , int $delimiter )
public CommonMark\Node\OrderedList::__construct ( int $tight , int $delimiter , int $start )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

tight

delimiter

start


Item concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Item extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Text concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Text extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public string|null $literal ;
/* Constructor */
public __construct ( )
public __construct ( string $literal )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\Text::__construct — Constructor Text


Constructor Text

  • « CommonMark\Node\Text
  • CommonMark\Node\Text\Strong »
  • PHP Manual
  • CommonMark\Node\Text
  • Constructor Text

CommonMark\Node\Text::__construct

(cmark >= 1.0.0)

CommonMark\Node\Text::__construct — Constructor Text

Descripción

public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

literal


Strong concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Text\Strong extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Emphasis concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Text\Emphasis extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


ThematicBreak concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\ThematicBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


SoftBreak concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\SoftBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


LineBreak concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\LineBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Code concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Code extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


CodeBlock concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\CodeBlock extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Propiedades */
public string|null $fence ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
public __construct ( string $fence , string $literal )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\CodeBlock::__construct — Constructor CodeBlock


Constructor CodeBlock

  • « CommonMark\Node\CodeBlock
  • CommonMark\Node\HTMLBlock »
  • PHP Manual
  • CommonMark\Node\CodeBlock
  • Constructor CodeBlock

CommonMark\Node\CodeBlock::__construct

(cmark >= 1.0.0)

CommonMark\Node\CodeBlock::__construct — Constructor CodeBlock

Descripción

public CommonMark\Node\CodeBlock::__construct ( string $fence , string $literal )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

fence

literal


HTMLBlock concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\HTMLBlock extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


HTMLInline concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\HTMLInline extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Image concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Image extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public string|null $url ;
public string|null $title ;
/* Constructor */
public __construct ( )
public __construct ( string $url )
public __construct ( string $url , string $title )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\Image::__construct — Constructor Image


Constructor Image

  • « CommonMark\Node\Image
  • CommonMark\Node\Link »
  • PHP Manual
  • CommonMark\Node\Image
  • Constructor Image

CommonMark\Node\Image::__construct

(cmark >= 1.0.0)

CommonMark\Node\Image::__construct — Constructor Image

Descripción

public CommonMark\Node\Image::__construct ( )
public CommonMark\Node\Image::__construct ( string $url )
public CommonMark\Node\Image::__construct ( string $url , string $title )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

url

title


Link concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\Link extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public string|null $url ;
public string|null $title ;
/* Constructor */
public __construct ( )
public __construct ( string $url )
public __construct ( string $url , string $title )
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node\Link::__construct — Constructor Link


Constructor Link

  • « CommonMark\Node\Link
  • CommonMark\Node\CustomBlock »
  • PHP Manual
  • CommonMark\Node\Link
  • Constructor Link

CommonMark\Node\Link::__construct

(cmark >= 1.0.0)

CommonMark\Node\Link::__construct — Constructor Link

Descripción

public CommonMark\Node\Link::__construct ( )
public CommonMark\Node\Link::__construct ( string $url )
public CommonMark\Node\Link::__construct ( string $url , string $title )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

url

title


CustomBlock concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\CustomBlock extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public string|null $onEnter ;
public string|null $onLeave ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


CustomInline concrete CommonMark\Node

(cmark >= 1.0.0)

Sinopsis de la Clase

final CommonMark\Node\CustomInline extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades heredadas */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Propiedades */
public string|null $onEnter ;
public string|null $onLeave ;
/* Métodos heredados */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Abstract CommonMark\Node

(cmark >= 1.0.0)

Introducción

Represents an Abstract Node, this final abstract is not for direct use by the programmer.

Sinopsis de la Clase

final abstract CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* Propiedades */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* Métodos */
public appendChild ( CommonMark\Node $child ) : CommonMark\Node
public prependChild ( CommonMark\Node $child ) : CommonMark\Node
public insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public replace ( CommonMark\Node $target ) : CommonMark\Node
public unlink ( ) : void
public accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Node::appendChild — Manipulación AST
  • CommonMark\Node::prependChild — Manipulación AST
  • CommonMark\Node::insertAfter — Manipulación AST
  • CommonMark\Node::insertBefore — Manipulación AST
  • CommonMark\Node::replace — Manipulación AST
  • CommonMark\Node::unlink — Manipulación AST
  • CommonMark\Node::accept — Visitation


Manipulación AST

  • « CommonMark\Node
  • CommonMark\Node::prependChild »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::appendChild

(cmark >= 1.0.0)

CommonMark\Node::appendChild — Manipulación AST

Descripción

public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

child

Valores devueltos


Manipulación AST

  • « CommonMark\Node::appendChild
  • CommonMark\Node::insertAfter »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::prependChild

(cmark >= 1.0.0)

CommonMark\Node::prependChild — Manipulación AST

Descripción

public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

child

Valores devueltos


Manipulación AST

  • « CommonMark\Node::prependChild
  • CommonMark\Node::insertBefore »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::insertAfter

(cmark >= 1.0.0)

CommonMark\Node::insertAfter — Manipulación AST

Descripción

public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

sibling

Valores devueltos


Manipulación AST

  • « CommonMark\Node::insertAfter
  • CommonMark\Node::replace »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::insertBefore

(cmark >= 1.0.0)

CommonMark\Node::insertBefore — Manipulación AST

Descripción

public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

sibling

Valores devueltos


Manipulación AST

  • « CommonMark\Node::insertBefore
  • CommonMark\Node::unlink »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::replace

(cmark >= 1.0.0)

CommonMark\Node::replace — Manipulación AST

Descripción

public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

target

Valores devueltos


Manipulación AST

  • « CommonMark\Node::replace
  • CommonMark\Node::accept »
  • PHP Manual
  • CommonMark\Node
  • Manipulación AST

CommonMark\Node::unlink

(cmark >= 1.0.0)

CommonMark\Node::unlink — Manipulación AST

Descripción

public CommonMark\Node::unlink ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Visitation

  • « CommonMark\Node::unlink
  • CommonMark\Interfaces\IVisitor »
  • PHP Manual
  • CommonMark\Node
  • Visitation

CommonMark\Node::accept

(cmark >= 1.0.0)

CommonMark\Node::accept — Visitation

Descripción

public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

Parámetros

visitor

Un objeto implementando CommonMark\Interfaces\IVisitor

Ver también

  • CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitor::leave


The CommonMark\Interfaces\IVisitor interface

(cmark >= 1.0.0)

Introducción

Sinopsis de la Clase

final CommonMark\Interfaces\IVisitor {
/* Constants */
const int Done ;
const int Enter ;
const int Leave ;
/* Métodos */
abstract public enter ( IVisitable $visitable ) : int|IVisitable|null
abstract public leave ( IVisitable $visitable ) : int|IVisitable|null
}

Tabla de contenidos

  • CommonMark\Interfaces\IVisitor::enter — Visitation
  • CommonMark\Interfaces\IVisitor::leave — Visitation


Visitation

  • « CommonMark\Interfaces\IVisitor
  • CommonMark\Interfaces\IVisitor::leave »
  • PHP Manual
  • CommonMark\Interfaces\IVisitor
  • Visitation

CommonMark\Interfaces\IVisitor::enter

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitor::enter — Visitation

Descripción

abstract public CommonMark\Interfaces\IVisitor::enter ( IVisitable $visitable ) : int|IVisitable|null

Parámetros

visitable

The current CommonMark\Interfaces\IVisitable being entered

Valores devueltos

Returning CommonMark\Interfaces\IVisitor::Done will cause the backing iterator to exit.

Returning CommonMark\Interfaces\IVisitor::Enter will reset the backing iterator at entering the current IVisitable

Returning CommonMark\Interfaces\IVisitor::Leave will reset the backing iterator at exiting the current IVisitable

Returning an IVisitable will reset the backing iterator at entering the given IVisitable

Returning nothing will allow the backing iterator to continue

Ver también

  • CommonMark\Interfaces\IVisitable::accept


Visitation

  • « CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitable »
  • PHP Manual
  • CommonMark\Interfaces\IVisitor
  • Visitation

CommonMark\Interfaces\IVisitor::leave

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitor::leave — Visitation

Descripción

abstract public CommonMark\Interfaces\IVisitor::leave ( IVisitable $visitable ) : int|IVisitable|null

Parámetros

visitable

The current CommonMark\Interfaces\IVisitable being exited

Valores devueltos

Returning CommonMark\Interfaces\IVisitor::Done will cause the backing iterator to exit.

Returning CommonMark\Interfaces\IVisitor::Enter will reset the backing iterator at entering the current IVisitable

Returning CommonMark\Interfaces\IVisitor::Leave will reset the backing iterator at exiting the current IVisitable

Returning an IVisitable will reset the backing iterator at exiting the given IVisitable

Returning nothing will allow the backing iterator to continue

Ver también

  • CommonMark\Interfaces\IVisitable::accept


The CommonMark\Interfaces\IVisitable interface

(cmark >= 1.0.0)

Introducción

Sinopsis de la Clase

final CommonMark\Interfaces\IVisitable {
abstract public accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Tabla de contenidos

  • CommonMark\Interfaces\IVisitable::accept — Visitation


Visitation

  • « CommonMark\Interfaces\IVisitable
  • CommonMark\Parser »
  • PHP Manual
  • CommonMark\Interfaces\IVisitable
  • Visitation

CommonMark\Interfaces\IVisitable::accept

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitable::accept — Visitation

Descripción

abstract public CommonMark\Interfaces\IVisitable::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

Parámetros

visitor

Un objeto implementando CommonMark\Interfaces\IVisitor

Ver también

  • CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitor::leave


The CommonMark\Parser class

(cmark >= 1.0.0)

Introducción

Provides an incremental parser as an alternative to the simple Parsing API function

Sinopsis de la Clase

final CommonMark\Parser {
/* Constructor */
public __construct ( int $options = ? )
/* Métodos */
public parse ( string $buffer ) : void
public finish ( ) : CommonMark\Node
}

Tabla de contenidos

  • CommonMark\Parser::__construct — Constructor Parser
  • CommonMark\Parser::parse — Parsing
  • CommonMark\Parser::finish — Parsing


Constructor Parser

  • « CommonMark\Parser
  • CommonMark\Parser::parse »
  • PHP Manual
  • CommonMark\Parser
  • Constructor Parser

CommonMark\Parser::__construct

(cmark >= 1.0.0)

CommonMark\Parser::__construct — Constructor Parser

Descripción

public CommonMark\Parser::__construct ( int $options = ? )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

options

Una máscara de:

CommonMark\Parser\Normal (integer)
CommonMark\Parser\Normalize (integer)
CommonMark\Parser\ValidateUTF8 (integer)
CommonMark\Parser\Smart (integer)


Parsing

  • « CommonMark\Parser::__construct
  • CommonMark\Parser::finish »
  • PHP Manual
  • CommonMark\Parser
  • Parsing

CommonMark\Parser::parse

(cmark >= 1.0.0)

CommonMark\Parser::parse — Parsing

Descripción

public CommonMark\Parser::parse ( string $buffer ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

buffer

Valores devueltos


Parsing

  • « CommonMark\Parser::parse
  • CommonMark\CQL »
  • PHP Manual
  • CommonMark\Parser
  • Parsing

CommonMark\Parser::finish

(cmark >= 1.0.0)

CommonMark\Parser::finish — Parsing

Descripción

public CommonMark\Parser::finish ( ) : CommonMark\Node

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


The CommonMark\CQL class

(cmark >= 1.1.0)

Introducción

CommonMark Query Language is a DSL for describing how to travel through a CommonMark Node tree implemented as a parser and compiler for a small set of instructions, and a virtual machine for executing those instructions.

Paths:

In it's most simplistic form, a CQL query combines the following paths and / to describe how to travel through a tree:

  • firstChild
  • lastChild
  • previous
  • next
  • parent
For example, /firstChild/lastChild would travel to the last child node of the first child node.

Loops

CQL can be instructed to loop, for example through the children of, or siblings to a particular node, by using the path children, or siblings. For example, /firstChild/children will travel to all the children of the first child node.

Subqueries

CQL can be instructed how to travel by using a subquery like [/firstChild]. For example, /firstChild/children[/firstChild] will travel to the first child node of all the children of the first child node.

Loop Constraints

While looping, CQL can be instructed to constrict the travelled path to nodes of particular type. For example /children(BlockQuote) will travel to the children of a node where the type is BlockQuote. The following types are recognized (case insensitively):

  • BlockQuote
  • List
  • Item
  • CodeBlock
  • HtmlBlock
  • CustomBlock
  • Paragraph
  • Heading
  • ThematicBreak
  • Text
  • SoftBreak
  • LineBreak
  • Code
  • HtmlInline
  • CustomInline
  • Emphasis
  • Strong
  • Link
  • Image
Types may be used as a union, for example /children(BlockQuote|List) will travel to the children of a node where the type is BlockQuote or List. Types, or unions of types, may be also negated. For example /children(~BlockQuote) will travel to the children of a node where the type is not BlockQuote, and /children(~BlockQuote|Paragraph) will travel to the children of a node where the type is not BlockQuote or Paragraph

Path Constraints

CQL can be instructed to create a loop to travel to a node of a particular type, at a particular path. For example, /firstChild(BlockQuote) will travel to the first child node where the type is BlockQuote. Note that like other loops for children and siblings, this kind of path can only be followed by a subquery.

Implementation Notes

While CQL has been implemented as part of the PHP CommonMark extension, it stands separately from PHP and does not use PHP's virtual machine or internal representation of values.

Sinopsis de la Clase

CommonMark\CQL {
/* Constructor */
public __construct ( string $query )
/* Métodos */
public __invoke ( CommonMark\Node $root , callable $handler )
}

Tabla de contenidos

  • CommonMark\CQL::__construct — Constructor CQL
  • CommonMark\CQL::__invoke — CQL Execution


Constructor CQL

  • « CommonMark\CQL
  • CommonMark\CQL::__invoke »
  • PHP Manual
  • CommonMark\CQL
  • Constructor CQL

CommonMark\CQL::__construct

(cmark >= 1.1.0)

CommonMark\CQL::__construct — Constructor CQL

Descripción

public CommonMark\CQL::__construct ( string $query )

Parámetros

query

un string CQL


CQL Execution

  • « CommonMark\CQL::__construct
  • CommonMark Funciones »
  • PHP Manual
  • CommonMark\CQL
  • CQL Execution

CommonMark\CQL::__invoke

(cmark >= 1.1.0)

CommonMark\CQL::__invoke — CQL Execution

Descripción

public CommonMark\CQL::__invoke ( CommonMark\Node $root , callable $handler )

Shall invoke the current CQL function on the given root, executing the given handler on entry to a CommonMark\Node

Parámetros

root

the root node of a tree

handler

should have the prototype:

handler ( CommonMark\Node $root , CommonMark\Node $entering ) : bool|null
  • Should handler fail to return (void), or return null, CQL will continue executing
  • Should the handler return a truthy value, CQL will continue executing.
  • Should the handler return a falsy value, CQL will stop executing


CommonMark Funciones

Tabla de contenidos

  • CommonMark\Parse — Parsing
  • CommonMark\Render — Rendering
  • CommonMark\Render\HTML — Rendering
  • CommonMark\Render\Latex — Rendering
  • CommonMark\Render\Man — Rendering
  • CommonMark\Render\XML — Rendering


Parsing

  • « CommonMark Funciones
  • CommonMark\Render »
  • PHP Manual
  • CommonMark Funciones
  • Parsing

CommonMark\Parse

(cmark >= 1.0.0)

CommonMark\Parse — Parsing

Descripción

CommonMark\Parse ( string $content , int $options = ? ) : CommonMark\Node

Deberá analizar content

Parámetros

content

reducción de la carga string

options

Una máscara de:

CommonMark\Parser\Normal (integer)
CommonMark\Parser\Normalize (integer)
CommonMark\Parser\ValidateUTF8 (integer)
CommonMark\Parser\Smart (integer)

Valores devueltos

Devolverá la raíz de CommonMark\Node


Rendering

  • « CommonMark\Parse
  • CommonMark\Render\HTML »
  • PHP Manual
  • CommonMark Funciones
  • Rendering

CommonMark\Render

(cmark >= 1.0.0)

CommonMark\Render — Rendering

Descripción

CommonMark\Render ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

node

options

Una máscara de:

CommonMark\Render\Normal (integer)
CommonMark\Render\SourcePos (integer)
CommonMark\Render\HardBreaks (integer)
CommonMark\Render\Safe (integer)
CommonMark\Render\NoBreaks (integer)
width

Valores devueltos


Rendering

  • « CommonMark\Render
  • CommonMark\Render\Latex »
  • PHP Manual
  • CommonMark Funciones
  • Rendering

CommonMark\Render\HTML

(cmark >= 1.0.0)

CommonMark\Render\HTML — Rendering

Descripción

CommonMark\Render\HTML ( CommonMark\Node $node , int $options = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

node

options

Una máscara de:

CommonMark\Render\Normal (integer)
CommonMark\Render\SourcePos (integer)
CommonMark\Render\HardBreaks (integer)
CommonMark\Render\Safe (integer)
CommonMark\Render\NoBreaks (integer)

Valores devueltos


Rendering

  • « CommonMark\Render\HTML
  • CommonMark\Render\Man »
  • PHP Manual
  • CommonMark Funciones
  • Rendering

CommonMark\Render\Latex

(cmark >= 1.0.0)

CommonMark\Render\Latex — Rendering

Descripción

CommonMark\Render\Latex ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

node

options

Una máscara de:

CommonMark\Render\Normal (integer)
CommonMark\Render\SourcePos (integer)
CommonMark\Render\HardBreaks (integer)
CommonMark\Render\Safe (integer)
CommonMark\Render\NoBreaks (integer)
width

Valores devueltos


Rendering

  • « CommonMark\Render\Latex
  • CommonMark\Render\XML »
  • PHP Manual
  • CommonMark Funciones
  • Rendering

CommonMark\Render\Man

(cmark >= 1.0.0)

CommonMark\Render\Man — Rendering

Descripción

CommonMark\Render\Man ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

node

options

Una máscara de:

CommonMark\Render\Normal (integer)
CommonMark\Render\SourcePos (integer)
CommonMark\Render\HardBreaks (integer)
CommonMark\Render\Safe (integer)
CommonMark\Render\NoBreaks (integer)
width

Valores devueltos


Rendering

  • « CommonMark\Render\Man
  • Parle »
  • PHP Manual
  • CommonMark Funciones
  • Rendering

CommonMark\Render\XML

(cmark >= 1.0.0)

CommonMark\Render\XML — Rendering

Descripción

CommonMark\Render\XML ( CommonMark\Node $node , int $options = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

node

options

Una máscara de:

CommonMark\Render\Normal (integer)
CommonMark\Render\SourcePos (integer)
CommonMark\Render\HardBreaks (integer)
CommonMark\Render\Safe (integer)
CommonMark\Render\NoBreaks (integer)

Valores devueltos


Parsing and lexing

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • Constantes predefinidas
  • Pattern matching — Parle pattern matching
    • Character representations
    • Character classes
    • Unicode character classes
    • Alternation and repetition
    • Anchors
    • Grouping
  • Ejemplos
    • Lexer examples
    • Parser examples
  • Parle\Lexer — The Parle\Lexer class
    • Parle\Lexer::advance — Process next lexer rule
    • Parle\Lexer::build — Finalize the lexer rule set
    • Parle\Lexer::callout — Define token callback
    • Parle\Lexer::consume — Pass the data for processing
    • Parle\Lexer::dump — Dump the state machine
    • Parle\Lexer::getToken — Retrieve the current token
    • Parle\Lexer::insertMacro — Insert regex macro
    • Parle\Lexer::push — Add a lexer rule
    • Parle\Lexer::reset — Reset lexer
  • Parle\RLexer — The Parle\RLexer class
    • Parle\RLexer::advance — Process next lexer rule
    • Parle\RLexer::build — Finalize the lexer rule set
    • Parle\RLexer::callout — Define token callback
    • Parle\RLexer::consume — Pass the data for processing
    • Parle\RLexer::dump — Dump the state machine
    • Parle\RLexer::getToken — Retrieve the current token
    • Parle\RLexer::insertMacro — Insert regex macro
    • Parle\RLexer::push — Add a lexer rule
    • Parle\RLexer::pushState — Push a new start state
    • Parle\RLexer::reset — Reset lexer
  • Parle\Parser — The Parle\Parser class
    • Parle\Parser::advance — Process next parser rule
    • Parle\Parser::build — Finalize the grammar rules
    • Parle\Parser::consume — Consume the data for processing
    • Parle\Parser::dump — Dump the grammar
    • Parle\Parser::errorInfo — Retrieve the error information
    • Parle\Parser::left — Declare a token with left-associativity
    • Parle\Parser::nonassoc — Declare a token with no associativity
    • Parle\Parser::precedence — Declare a precedence rule
    • Parle\Parser::push — Add a grammar rule
    • Parle\Parser::reset — Reset parser state
    • Parle\Parser::right — Declare a token with right-associativity
    • Parle\Parser::sigil — Retrieve a matching part of a rule
    • Parle\Parser::token — Declare a token
    • Parle\Parser::tokenId — Get token id
    • Parle\Parser::trace — Trace the parser operation
    • Parle\Parser::validate — Validate input
  • Parle\RParser — The Parle\RParser class
    • Parle\RParser::advance — Process next parser rule
    • Parle\RParser::build — Finalize the grammar rules
    • Parle\RParser::consume — Consume the data for processing
    • Parle\RParser::dump — Dump the grammar
    • Parle\RParser::errorInfo — Retrieve the error information
    • Parle\RParser::left — Declare a token with left-associativity
    • Parle\RParser::nonassoc — Declare a token with no associativity
    • Parle\RParser::precedence — Declare a precedence rule
    • Parle\RParser::push — Add a grammar rule
    • Parle\RParser::reset — Reset parser state
    • Parle\RParser::right — Declare a token with right-associativity
    • Parle\RParser::sigil — Retrieve a matching part of a rule
    • Parle\RParser::token — Declare a token
    • Parle\RParser::tokenId — Get token id
    • Parle\RParser::trace — Trace the parser operation
    • Parle\RParser::validate — Validate input
  • Parle\Stack — The Parle\Stack class
    • Parle\Stack::pop — Pop an item from the stack
    • Parle\Stack::push — Push an item into the stack
  • Parle\Token — The Parle\Token class
  • Parle\ErrorInfo — The Parle\ErrorInfo class
  • Parle\LexerException — The Parle\LexerException class
  • Parle\ParserException — The Parle\ParserException class


Introducción

The parle extension provides general purpose lexing and parsing facilities. The implementation is based on » Ben Hanson's libraries and requires a » C++14 capable compiler. The lexer is based on the regex matching, the parser is LALR(1). Lexers and parsers are generated on the fly and can be used immediately after they've been finalized. Parle deals with parsing and lexing, the appropriate data structures representation and processing are the implementer's task. Serialization and code generation are not supported by the extension, yet.

Lexer analysis is a process of splitting a character sequence into a list of lexemes. The lexeme list can be then used for the syntax analysis against a formal grammar. These operations are also known as lexing and parsing. This documentation doesn't aim to provide an exhaustive information on lexing and parsing. Good information in this regard is available on the numerous resources on the net. Several usage examples are included, to show the functionality. The extension is useful for PHP programmers both willing to learn or to utilize parsing and lexing. State machines and grammar parsing don't have to be implemented manually, these complex tasks are taken away by parle. Thanks to that, the development can be focused on the actual problem solving.

The common use case for parle is, when a data format is too complex to be handled by the regex matching with PCRE. The practical application is herewith wide. Be it a specific data format, a behavior modification of existing functions, even an own programming language and beyond. The helper methods such as Parle\Lexer::dump() to inspect the generated state machine, or Parle\Parser::dump() to inspect the generated grammar, are useful. The method Parle\Parser::trace() can also be used to track the parsing operation.


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • Parle
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


Requerimientos

PHP 7.0 or above is supported. A C++14 capable compiler is required. A successful extension build was produced with at least clang 5.0, GCC 5.0 and Visual Studio 2015.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/parle.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/parle/.

Available configure options
Option | Description
--enable-parle | Enable parle extension.
--enable-parle-utf32 | Enable internal UTF-32 support. Available since parle 0.7.2.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Parle\INTERNAL_UTF32 bool
Flag whether the internal UTF-32 support is compiled in. Available since parle 0.7.2.


Parle pattern matching

Tabla de contenidos

  • Character representations
  • Character classes
  • Unicode character classes
  • Alternation and repetition
  • Anchors
  • Grouping

Parle supports regex matching similar to flex. Also supported are the following POSIX character sets: [:alnum:], [:alpha:], [:blank:], [:cntrl:], [:digit:], [:graph:], [:lower:], [:print:], [:punct:], [:space:], [:upper:] and [:xdigit:].

The Unicode character classes are currently not enabled by default, pass --enable-parle-utf32 to make them available. A particular encoding can be mapped with a correctly constructed regex. For example, to match the EURO symbol encoded in UTF-8, the regular expression [\xe2][\x82][\xac] can be used. The pattern for an UTF-8 encoded string could be [ -\x7f]{+}[\x80-\xbf]{+}[\xc2-\xdf]{+}[\xe0-\xef]{+}[\xf0-\xff]+.


Character representations

Character representations
Sequence | Description
\a | Alert (bell).
\b | Backspace.
\e | ESC character, \x1b.
\n | Newline.
\r | Carriage return.
\f | Form feed, \x0c.
\t | Horizontal tab, \x09.
\v | Vertical tab, \x0b.
\oct | Character specified by a three-digit octal code.
\xhex | Character specified by a hex code.
\cchar | Named control character.


Character classes

Character classes
Sequence | Description
[...] | A single character listed or contained within a listed range. Ranges can be combined with the {+} and {-} operators. For example [a-z]{+}[0-9] is the same as [0-9a-z] and [a-z]{-}[aeiou] is the same as [b-df-hj-np-tv-z].
[^...] | A single character not listed and not contained within a listed range.
. | Any character, default [^\n].
\d | Digit character, [0-9].
\D | Non-digit character, [^0-9].
\s | White space character, [ \t\n\r\f\v].
\S | Non-white space character, [^ \t\n\r\f\v].
\w | Word caracter, [a-zA-Z0-9_].
\W | Non-word caracter, [^a-zA-Z0-9_].


Unicode character classes

Unicode character classes
Sequence | Description
\p{C} | Other.
\p{Cc} | Other, control.
\p{Cf} | Other, format.
\p{Co} | Other, private use.
\p{Cs} | Other, surrogate.
\p{L} | Letter.
\p{LC} | Letter, cased.
\p{Ll} | Letter, lowercase.
\p{Lm} | Letter, modifier.
\p{Lo} | Letter, other.
\p{Lt} | Letter, titlecase.
\p{Lu} | Letter, uppercase.
\p{M} | Mark.
\p{Mc} | Mark, space combining.
\p{Me} | Mark, enclosing.
\p{Mn} | Mark, nonspacing.
\p{N} | Number.
\p{Nd} | Number, decimal digit.
\p{Nl} | Number, letter.
\p{No} | Number, other.
\p{P} | Punctuation.
\p{Pc} | Punctiation, connector.
\p{Pd} | Punctuation, dash.
\p{Pe} | Punctuation, close.
\p{Pf} | Punctuation, final quote.
\p{Pi} | Punctuation, initial quote.
\p{Po} | Punctuation, other.
\p{Ps} | Punctuation, open.
\p{S} | Symbol.
\p{Sc} | Symbol, currency.
\p{Sk} | Symbol, modifier.
\p{Sm} | Symbol, math.
\p{So} | Symbol, other.
\p{Z} | Separator.
\p{Zl} | Separator, line.
\p{Zp} | Separator, paragraph.
\p{Zs} | Separator, space.

These character clasess are only available, if the option --enable-parle-utf32 was passed at the compilation time.


Alternation and repetition

Alternation and repetition
Sequence | Greedy | Description
...|... | - | Try subpatterns in alternation.
* | yes | Match 0 or more times.
+ | yes | Match 1 or more times.
? | yes | Match 0 or 1 times.
{n} | no | Match exactly n times.
{n,} | yes | Match at least n times.
{n,m} | yes | Match at least n times but no more than m times.
*? | no | Match 0 or more times.
+? | no | Match 1 or more times.
?? | no | Match 0 or 1 times.
{n,}? | no | Match at least n times.
{n,m}? | no | Match at least n times but no more than m times.
{MACRO} | - | Include the regex MACRO in the current regex.


Anchors

Anchors
Sequence | Description
^ | Start of string or after a newline.
$ | End of string or before a newline.


Grouping

Grouping
Sequence | Description
(...) Group a regular expression to override default operator precedence.
(?r-s:pattern) Apply option r and omit option s while interpreting pattern. Options may be zero or more of the characters i, s, or x.
Options
Option | Description
i | Case insensitive.
-i | Case sensitive.
s | Alters the meaning of '.' to match any character whatsoever.
-s | "lters the meaning of '.' to match any character except '\n'.
x | Ignores comments and whitespace in patterns. Whitespace is ignored unless it is backslash-escaped, contained within ""s, or appears inside a character range.
These options can be applied globally at the rules level by passing a combination of the bit flags to the lexer.
(?# comment ) | Omit everything within (). The first ) character encountered ends the pattern. It is not possible for the comment to contain a ) character. The comment may span lines.


  • « Grouping
  • Lexer examples »
  • PHP Manual
  • Parle
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Lexer examples
  • Parser examples


Lexer examples

Ejemplo #1 Tokenize comma separated integer list

<?php

use Parle\Token;
use Parle\Lexer;
use Parle\LexerException;

/* name => id */
$token = array(
        "COMMA" => 1,
        "CRLF" => 2,
        "DECIMAL" => 3,
);
/* id => name */
$tokenIdToName = array_flip($token);

$lex = new Lexer;
$lex->push("[\x2c]", $token["COMMA"]);
$lex->push("[\r][\n]", $token["CRLF"]);
$lex->push("[\d]+", $token["DECIMAL"]);
$lex->build();

$in = "0,1,2\r\n3,42,5\r\n6,77,8\r\n";

$lex->consume($in);

do {
        $lex->advance();
        $tok = $lex->getToken();

        if (Token::UNKNOWN == $tok->id) {
                throw new LexerException("Unknown token '{$tok->value}' at offset {$lex->marker}.");
        }

        echo "TOKEN: ", $tokenIdToName[$tok->id], PHP_EOL;
} while (Token::EOI != $tok->id);

Ejemplo #2 Tokenize assign statement

<?php

use Parle\{Token, Lexer};

$lex = new Lexer;

$lex->push("\$[a-zA-Z_][a-zA-Z0-9_]*", 1);
$lex->push("=", 2);
$lex->push("\d+", 3);
$lex->push(";", 4);

$lex->build();

$lex->consume('$x = 42; $y = 24;');

do {
    $lex->advance();
    $tok = $lex->getToken();
    var_dump($tok);
} while (Token::EOI != $tok->id);


Parser examples

Ejemplo #1 Simple calculator

<?php

use Parle\{Parser, ParserException, Lexer, Token};

$p = new Parser;
$p->token("INTEGER");
$p->left("'+' '-' '*' '/'");

$p->push("start", "exp");
$prod_add = $p->push("exp", "exp '+' exp");
$prod_sub = $p->push("exp", "exp '-' exp");
$prod_mul = $p->push("exp", "exp '*' exp");
$prod_div = $p->push("exp", "exp '/' exp");
$p->push("exp", "INTEGER"); /* Production index unused. */

$p->build();

$lex = new Lexer;
$lex->push("[+]", $p->tokenId("'+'"));
$lex->push("[-]", $p->tokenId("'-'"));
$lex->push("[*]", $p->tokenId("'*'"));
$lex->push("[/]", $p->tokenId("'/'"));
$lex->push("\\d+", $p->tokenId("INTEGER"));
$lex->push("\\s+", Token::SKIP);

$lex->build();

$exp = array(
    "1 + 1",
    "33 / 10",
    "100 * 45",
    "17 - 45",
);

foreach ($exp as $in) {
    if (!$p->validate($in, $lex)) {
        throw new ParserException("Failed to validate input");
    }

    $p->consume($in, $lex);

    while (Parser::ACTION_ERROR != $p->action && Parser::ACTION_ACCEPT != $p->action) {
        switch ($p->action) {
            case Parser::ACTION_ERROR:
                throw new ParserException("Parser error");
                break;
            case Parser::ACTION_SHIFT:
            case Parser::ACTION_GOTO:
            case Parser::ACTION_ACCEPT:
                break;
            case Parser::ACTION_REDUCE:
                switch ($p->reduceId) {
                    case $prod_add:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l + $r = " . ($l + $r) . "\n";
                        break;
                    case $prod_sub:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l - $r = " . ($l - $r) . "\n";
                        break;
                    case $prod_mul:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l * $r = " . ($l * $r) . "\n";
                        break;
                    case $prod_div:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                    echo "$l / $r = " . ($l / $r) . "\n";
                        break;
            }
            break;
        }
        $p->advance();
    }
}

Ejemplo #2 Parse words out from a sentence

<?php

use Parle\{Lexer, Token, Parser, ParserException};

$p = new Parser;
$p->token("WORD");
$p->push("START", "SENTENCE");
$p->push("SENTENCE", "WORDS");
$prod_word_0 = $p->push("WORDS", "WORDS WORD");
$prod_word_1 = $p->push("WORDS", "WORD");
$p->build();

$lex = new Lexer;
$lex->push("[^\s]{-}[\.,\:\;\?]+", $p->tokenId("WORD"));
$lex->push("[\s\.,\:\;\?]+", Token::SKIP);
$lex->build();

$in = "Dis-moi où est ton papa?";
$p->consume($in, $lex);
do {
    switch ($p->action) {
    case Parser::ACTION_ERROR:
        throw new ParserException("Error");
        break;
    case Parser::ACTION_SHIFT:
    case Parser::ACTION_GOTO:
        /* var_dump($p->trace());*/
        break;
    case Parser::ACTION_REDUCE:
        $rid = $p->reduceId();
        if ($rid == $prod_word_1) {
            var_dump($p->sigil(0));
        } if ($rid == $prod_word_0) {
            var_dump($p->sigil(1));
        }
        break;
    }
    $p->advance();
} while (Parser::ACTION_ACCEPT != $p->action);


The Parle\Lexer class

(PECL parle >= 0.5.1)

Introducción

Single state lexer class. Lexemes can be defined on the fly. If the particular lexer instance is meant to be used with Parle\Parser, the token IDs need to be taken from there. Otherwise, arbitrary token IDs can be supplied. This lexer can give a certain performance advantage over Parle\RLexer, if no multiple states are required. Note, that Parle\RParser is not compatible with this lexer.

Sinopsis de la Clase

Parle\Lexer {
/* Constants */
const int ICASE = 1 ;
const int DOT_NOT_LF = 2 ;
const int DOT_NOT_CRLF = 4 ;
const int SKIP_WS = 8 ;
const int MATCH_ZERO_LEN = 16 ;
/* Propiedades */
public bool $bol = false ;
public int $flags = 0 ;
public int $state = 0 ;
public int $marker = 0 ;
public int $cursor = 0 ;
/* Métodos */
public advance ( ) : void
public build ( ) : void
public callout ( int $id , callable $callback ) : void
public consume ( string $data ) : void
public dump ( ) : void
public getToken ( ) : Parle\Token
public insertMacro ( string $name , string $regex ) : void
public push ( string $regex , int $id ) : void
public reset ( int $pos ) : void
}

Constantes predefinidas

Parle\Lexer::ICASE

Parle\Lexer::DOT_NOT_LF

Parle\Lexer::DOT_NOT_CRLF

Parle\Lexer::SKIP_WS

Parle\Lexer::MATCH_ZERO_LEN

Propiedades

bol

Start of input flag.

flags

Lexer flags.

state

Current lexer state, readonly.

marker

Position of the latest token match, readonly.

cursor

Current input offset, readonly.

Tabla de contenidos

  • Parle\Lexer::advance — Process next lexer rule
  • Parle\Lexer::build — Finalize the lexer rule set
  • Parle\Lexer::callout — Define token callback
  • Parle\Lexer::consume — Pass the data for processing
  • Parle\Lexer::dump — Dump the state machine
  • Parle\Lexer::getToken — Retrieve the current token
  • Parle\Lexer::insertMacro — Insert regex macro
  • Parle\Lexer::push — Add a lexer rule
  • Parle\Lexer::reset — Reset lexer


Process next lexer rule

  • « Parle\Lexer
  • Parle\Lexer::build »
  • PHP Manual
  • Parle\Lexer
  • Process next lexer rule

Parle\Lexer::advance

(PECL parle >= 0.5.1)

Parle\Lexer::advance — Process next lexer rule

Descripción

public Parle\Lexer::advance ( ) : void

Processes the next rule and prepares the resulting token data.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Finalize the lexer rule set

  • « Parle\Lexer::advance
  • Parle\Lexer::callout »
  • PHP Manual
  • Parle\Lexer
  • Finalize the lexer rule set

Parle\Lexer::build

(PECL parle >= 0.5.1)

Parle\Lexer::build — Finalize the lexer rule set

Descripción

public Parle\Lexer::build ( ) : void

Rules, previously added with Parle\Lexer::push() are finalized. This method call has to be done after all the necessary rules was pushed. The rule set becomes read only. The lexing can begin.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Define token callback

  • « Parle\Lexer::build
  • Parle\Lexer::consume »
  • PHP Manual
  • Parle\Lexer
  • Define token callback

Parle\Lexer::callout

(PECL parle >= 0.7.2)

Parle\Lexer::callout — Define token callback

Descripción

public Parle\Lexer::callout ( int $id , callable $callback ) : void

Define a callback to be invoked once lexer encounters a particular token.

Parámetros

id

Token id.

callback

Callable to be invoked. The callable doesn't receive any arguments and its return value is ignored.

Valores devueltos

No devuelve ningún valor.


Pass the data for processing

  • « Parle\Lexer::callout
  • Parle\Lexer::dump »
  • PHP Manual
  • Parle\Lexer
  • Pass the data for processing

Parle\Lexer::consume

(PECL parle >= 0.5.1)

Parle\Lexer::consume — Pass the data for processing

Descripción

public Parle\Lexer::consume ( string $data ) : void

Consume the data for lexing.

Parámetros

data

Data to be lexed.

Valores devueltos

No devuelve ningún valor.


Dump the state machine

  • « Parle\Lexer::consume
  • Parle\Lexer::getToken »
  • PHP Manual
  • Parle\Lexer
  • Dump the state machine

Parle\Lexer::dump

(PECL parle >= 0.5.1)

Parle\Lexer::dump — Dump the state machine

Descripción

public Parle\Lexer::dump ( ) : void

Dump the current state machine to stdout.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Retrieve the current token

  • « Parle\Lexer::dump
  • Parle\Lexer::insertMacro »
  • PHP Manual
  • Parle\Lexer
  • Retrieve the current token

Parle\Lexer::getToken

(PECL parle >= 0.5.1)

Parle\Lexer::getToken — Retrieve the current token

Descripción

public Parle\Lexer::getToken ( ) : Parle\Token

Retrieve the current token.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an instance of Parle\Token.


Insert regex macro

  • « Parle\Lexer::getToken
  • Parle\Lexer::push »
  • PHP Manual
  • Parle\Lexer
  • Insert regex macro

Parle\Lexer::insertMacro

(PECL parle >= 0.5.1)

Parle\Lexer::insertMacro — Insert regex macro

Descripción

public Parle\Lexer::insertMacro ( string $name , string $regex ) : void

Insert a regex macro, that can be later used as a shortcut and included in other regular expressions.

Parámetros

name

Name of the macros.

regex

Regular expression.

Valores devueltos

No devuelve ningún valor.


Add a lexer rule

  • « Parle\Lexer::insertMacro
  • Parle\Lexer::reset »
  • PHP Manual
  • Parle\Lexer
  • Add a lexer rule

Parle\Lexer::push

(PECL parle >= 0.5.1)

Parle\Lexer::push — Add a lexer rule

Descripción

public Parle\Lexer::push ( string $regex , int $id ) : void

Push a pattern for lexeme recognition.

Parámetros

regex

Regular expression used for token matching.

id

Token id. If the lexer instance is meant to be used standalone, this can be an arbitrary number. If the lexer instance is going to be passed to the parser, it has to be an id returned by Parle\Parser::tokenid().

Valores devueltos

No devuelve ningún valor.


Reset lexer

  • « Parle\Lexer::push
  • Parle\RLexer »
  • PHP Manual
  • Parle\Lexer
  • Reset lexer

Parle\Lexer::reset

(PECL parle >= 0.7.1)

Parle\Lexer::reset — Reset lexer

Descripción

public Parle\Lexer::reset ( int $pos ) : void

Reset lexing optionally supplying the desired offset.

Parámetros

pos

Reset position.

Valores devueltos

No devuelve ningún valor.


The Parle\RLexer class

(PECL parle >= 0.5.1)

Introducción

Multistate lexer class. Lexemes can be defined on the fly. If the particular lexer instance is meant to be used with Parle\RParser, the token IDs need to be taken from there. Otherwise, arbitrary token IDs can be supplied. Note, that Parle\Parser is not compatible with this lexer.

Sinopsis de la Clase

Parle\RLexer {
/* Constants */
const int ICASE = 1 ;
const int DOT_NOT_LF = 2 ;
const int DOT_NOT_CRLF = 4 ;
const int SKIP_WS = 8 ;
const int MATCH_ZERO_LEN = 16 ;
/* Propiedades */
public bool $bol = false ;
public int $flags = 0 ;
public int $state = 0 ;
public int $marker = 0 ;
public int $cursor = 0 ;
/* Métodos */
public advance ( ) : void
public build ( ) : void
public callout ( int $id , callable $callback ) : void
public consume ( string $data ) : void
public dump ( ) : void
public getToken ( ) : Parle\Token
public insertMacro ( string $name , string $regex ) : void
public push ( string $regex , int $id ) : void
public push ( string $state , string $regex , int $id , string $newState ) : void
public push ( string $state , string $regex , string $newState ) : void
public pushState ( string $state ) : int
public reset ( int $pos ) : void
}

Constantes predefinidas

Parle\RLexer::ICASE

Parle\RLexer::DOT_NOT_LF

Parle\RLexer::DOT_NOT_CRLF

Parle\RLexer::SKIP_WS

Parle\RLexer::MATCH_ZERO_LEN

Propiedades

bol

Start of input flag.

flags

Lexer flags.

state

Current lexer state, readonly.

marker

Position of the latest token match, readonly.

cursor

Current input offset, readonly.

Tabla de contenidos

  • Parle\RLexer::advance — Process next lexer rule
  • Parle\RLexer::build — Finalize the lexer rule set
  • Parle\RLexer::callout — Define token callback
  • Parle\RLexer::consume — Pass the data for processing
  • Parle\RLexer::dump — Dump the state machine
  • Parle\RLexer::getToken — Retrieve the current token
  • Parle\RLexer::insertMacro — Insert regex macro
  • Parle\RLexer::push — Add a lexer rule
  • Parle\RLexer::pushState — Push a new start state
  • Parle\RLexer::reset — Reset lexer


Process next lexer rule

  • « Parle\RLexer
  • Parle\RLexer::build »
  • PHP Manual
  • Parle\RLexer
  • Process next lexer rule

Parle\RLexer::advance

(PECL parle >= 0.5.1)

Parle\RLexer::advance — Process next lexer rule

Descripción

public Parle\RLexer::advance ( ) : void

Processes the next rule and prepares the resulting token data.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Finalize the lexer rule set

  • « Parle\RLexer::advance
  • Parle\RLexer::callout »
  • PHP Manual
  • Parle\RLexer
  • Finalize the lexer rule set

Parle\RLexer::build

(PECL parle >= 0.5.1)

Parle\RLexer::build — Finalize the lexer rule set

Descripción

public Parle\RLexer::build ( ) : void

Rules, previously added with Parle\RLexer::push() are finalized. This method call has to be done after all the necessary rules was pushed. The rule set becomes read only. The lexing can begin.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Define token callback

  • « Parle\RLexer::build
  • Parle\RLexer::consume »
  • PHP Manual
  • Parle\RLexer
  • Define token callback

Parle\RLexer::callout

(PECL parle >= 0.7.2)

Parle\RLexer::callout — Define token callback

Descripción

public Parle\RLexer::callout ( int $id , callable $callback ) : void

Define a callback to be invoked once lexer encounters a particular token.

Parámetros

id

Token id.

callback

Callable to be invoked. The callable doesn't receive any arguments and its return value is ignored.

Valores devueltos

No devuelve ningún valor.


Pass the data for processing

  • « Parle\RLexer::callout
  • Parle\RLexer::dump »
  • PHP Manual
  • Parle\RLexer
  • Pass the data for processing

Parle\RLexer::consume

(PECL parle >= 0.5.1)

Parle\RLexer::consume — Pass the data for processing

Descripción

public Parle\RLexer::consume ( string $data ) : void

Consume the data for lexing.

Parámetros

data

Data to be lexed.

Valores devueltos

No devuelve ningún valor.


Dump the state machine

  • « Parle\RLexer::consume
  • Parle\RLexer::getToken »
  • PHP Manual
  • Parle\RLexer
  • Dump the state machine

Parle\RLexer::dump

(PECL parle >= 0.5.1)

Parle\RLexer::dump — Dump the state machine

Descripción

public Parle\RLexer::dump ( ) : void

Dump the current state machine to stdout.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Retrieve the current token

  • « Parle\RLexer::dump
  • Parle\RLexer::insertMacro »
  • PHP Manual
  • Parle\RLexer
  • Retrieve the current token

Parle\RLexer::getToken

(PECL parle >= 0.5.1)

Parle\RLexer::getToken — Retrieve the current token

Descripción

public Parle\RLexer::getToken ( ) : Parle\Token

Retrive the current token.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an instance of Parle\Token.


Insert regex macro

  • « Parle\RLexer::getToken
  • Parle\RLexer::push »
  • PHP Manual
  • Parle\RLexer
  • Insert regex macro

Parle\RLexer::insertMacro

(PECL parle >= 0.5.1)

Parle\RLexer::insertMacro — Insert regex macro

Descripción

public Parle\RLexer::insertMacro ( string $name , string $regex ) : void

Insert a regex macro, that can be later used as a shortcut and included in other regular expressions.

Parámetros

name

Name of the macros.

regex

Regular expression.

Valores devueltos

No devuelve ningún valor.


Add a lexer rule

  • « Parle\RLexer::insertMacro
  • Parle\RLexer::pushState »
  • PHP Manual
  • Parle\RLexer
  • Add a lexer rule

Parle\RLexer::push

(PECL parle >= 0.5.1)

Parle\RLexer::push — Add a lexer rule

Descripción

public Parle\RLexer::push ( string $regex , int $id ) : void
public Parle\RLexer::push ( string $state , string $regex , int $id , string $newState ) : void
public Parle\RLexer::push ( string $state , string $regex , string $newState ) : void

Push a pattern for lexeme recognition.

A 'start state' and 'exit state' can be specified by using a suitable signature.

Parámetros

regex

Regular expression used for token matching.

id

Token id. If the lexer instance is meant to be used standalone, this can be an arbitrary number. If the lexer instance is going to be passed to the parser, it has to be an id returned by Parle\RParser::tokenid().

state

State name. If '*' is used as start state, then the rule is applied to all lexer states.

newState

New state name, after the rule was applied.

If '.' is specified as the exit state, then the lexer state is unchanged when that rule matches. An exit state with '>' before the name means push. Use the signature without id for either continuation or to start matching, when a continuation or recursion is required.

If '<' is specified as exit state, it means pop. In that case, the signature containing the id can be used to identify the match. Note that even in the case an id is specified, the rule will finish first when all the previous pushes popped.

Valores devueltos

No devuelve ningún valor.


Push a new start state

  • « Parle\RLexer::push
  • Parle\RLexer::reset »
  • PHP Manual
  • Parle\RLexer
  • Push a new start state

Parle\RLexer::pushState

(PECL parle >= 0.5.1)

Parle\RLexer::pushState — Push a new start state

Descripción

public Parle\RLexer::pushState ( string $state ) : int

This lexer type can have more than one state machine. This allows you to lex different tokens depending on context, thus allowing simple parsing to take place. Once a state pushed, it can be used with a suitable Parle\RLexer::push() signature variant.

Parámetros

state

Name of the state.

Valores devueltos


Reset lexer

  • « Parle\RLexer::pushState
  • Parle\Parser »
  • PHP Manual
  • Parle\RLexer
  • Reset lexer

Parle\RLexer::reset

(PECL parle >= 0.7.1)

Parle\RLexer::reset — Reset lexer

Descripción

public Parle\RLexer::reset ( int $pos ) : void

Reset lexing optionally supplying the desired offset.

Parámetros

pos

Reset position.

Valores devueltos

No devuelve ningún valor.


The Parle\Parser class

(PECL parle >= 0.5.1)

Introducción

Parser class. Rules can be defined on the fly. Once finalized, a Parle\Lexer instance is required to deliver the token stream.

Sinopsis de la Clase

Parle\Parser {
/* Constants */
const int ACTION_ERROR = 0 ;
const int ACTION_SHIFT = 1 ;
const int ACTION_REDUCE = 2 ;
const int ACTION_GOTO = 3 ;
const int ACTION_ACCEPT = 4 ;
const int ERROR_SYNTAX = 0 ;
const int ERROR_NON_ASSOCIATIVE = 1 ;
const int ERROR_UNKNOWN_TOKEN = 2 ;
/* Propiedades */
public int $action = 0 ;
public int $reduceId = 0 ;
/* Métodos */
public advance ( ) : void
public build ( ) : void
public consume ( string $data , Parle\Lexer $lexer ) : void
public dump ( ) : void
public errorInfo ( ) : Parle\ErrorInfo
public left ( string $tok ) : void
public nonassoc ( string $tok ) : void
public precedence ( string $tok ) : void
public push ( string $name , string $rule ) : int
public reset ( int $tokenId = ? ) : void
public right ( string $tok ) : void
public sigil ( int $idx ) : string
public token ( string $tok ) : void
public tokenId ( string $tok ) : int
public trace ( ) : string
public validate ( string $data , Parle\Lexer $lexer ) : bool
}

Constantes predefinidas

Parle\Parser::ACTION_ERROR

Parle\Parser::ACTION_SHIFT

Parle\Parser::ACTION_REDUCE

Parle\Parser::ACTION_GOTO

Parle\Parser::ACTION_ACCEPT

Parle\Parser::ERROR_SYNTAX

Parle\Parser::ERROR_NON_ASSOCIATIVE

Parle\Parser::ERROR_UNKNOWN_TOKEN

Propiedades

action

Current parser action that matches one of the action class constants, readonly.

reduceId

Grammar rule id just processed in the reduce action. The value corresponds either to a token or to a production id. Readonly.

Tabla de contenidos

  • Parle\Parser::advance — Process next parser rule
  • Parle\Parser::build — Finalize the grammar rules
  • Parle\Parser::consume — Consume the data for processing
  • Parle\Parser::dump — Dump the grammar
  • Parle\Parser::errorInfo — Retrieve the error information
  • Parle\Parser::left — Declare a token with left-associativity
  • Parle\Parser::nonassoc — Declare a token with no associativity
  • Parle\Parser::precedence — Declare a precedence rule
  • Parle\Parser::push — Add a grammar rule
  • Parle\Parser::reset — Reset parser state
  • Parle\Parser::right — Declare a token with right-associativity
  • Parle\Parser::sigil — Retrieve a matching part of a rule
  • Parle\Parser::token — Declare a token
  • Parle\Parser::tokenId — Get token id
  • Parle\Parser::trace — Trace the parser operation
  • Parle\Parser::validate — Validate input


Process next parser rule

  • « Parle\Parser
  • Parle\Parser::build »
  • PHP Manual
  • Parle\Parser
  • Process next parser rule

Parle\Parser::advance

(PECL parle >= 0.5.1)

Parle\Parser::advance — Process next parser rule

Descripción

public Parle\Parser::advance ( ) : void

Process next parser rule.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Finalize the grammar rules

  • « Parle\Parser::advance
  • Parle\Parser::consume »
  • PHP Manual
  • Parle\Parser
  • Finalize the grammar rules

Parle\Parser::build

(PECL parle >= 0.5.1)

Parle\Parser::build — Finalize the grammar rules

Descripción

public Parle\Parser::build ( ) : void

Any tokens and grammar rules previously added are finalized. The rule set becomes readonly and the parser is ready to start.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Consume the data for processing

  • « Parle\Parser::build
  • Parle\Parser::dump »
  • PHP Manual
  • Parle\Parser
  • Consume the data for processing

Parle\Parser::consume

(PECL parle >= 0.5.1)

Parle\Parser::consume — Consume the data for processing

Descripción

public Parle\Parser::consume ( string $data , Parle\Lexer $lexer ) : void

Consume the data for parsing.

Parámetros

data

Data to be parsed.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

Valores devueltos

No devuelve ningún valor.


Dump the grammar

  • « Parle\Parser::consume
  • Parle\Parser::errorInfo »
  • PHP Manual
  • Parle\Parser
  • Dump the grammar

Parle\Parser::dump

(PECL parle >= 0.5.1)

Parle\Parser::dump — Dump the grammar

Descripción

public Parle\Parser::dump ( ) : void

Dump the current grammar to stdout.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Retrieve the error information

  • « Parle\Parser::dump
  • Parle\Parser::left »
  • PHP Manual
  • Parle\Parser
  • Retrieve the error information

Parle\Parser::errorInfo

(PECL parle >= 0.5.1)

Parle\Parser::errorInfo — Retrieve the error information

Descripción

public Parle\Parser::errorInfo ( ) : Parle\ErrorInfo

Retrieve the error information in case Parle\Parser::action() returned the error action.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an instance of Parle\ErrorInfo.


Declare a token with left-associativity

  • « Parle\Parser::errorInfo
  • Parle\Parser::nonassoc »
  • PHP Manual
  • Parle\Parser
  • Declare a token with left-associativity

Parle\Parser::left

(PECL parle >= 0.5.1)

Parle\Parser::left — Declare a token with left-associativity

Descripción

public Parle\Parser::left ( string $tok ) : void

Declare a terminal with left associativity.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Declare a token with no associativity

  • « Parle\Parser::left
  • Parle\Parser::precedence »
  • PHP Manual
  • Parle\Parser
  • Declare a token with no associativity

Parle\Parser::nonassoc

(PECL parle >= 0.5.1)

Parle\Parser::nonassoc — Declare a token with no associativity

Descripción

public Parle\Parser::nonassoc ( string $tok ) : void

Declare a terminal, that cannot appear more than once in the row.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Declare a precedence rule

  • « Parle\Parser::nonassoc
  • Parle\Parser::push »
  • PHP Manual
  • Parle\Parser
  • Declare a precedence rule

Parle\Parser::precedence

(PECL parle >= 0.5.1)

Parle\Parser::precedence — Declare a precedence rule

Descripción

public Parle\Parser::precedence ( string $tok ) : void

Declares a precedence rule for a fictitious terminal symbol. This rule can be later used in the specific grammar rules.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Add a grammar rule

  • « Parle\Parser::precedence
  • Parle\Parser::reset »
  • PHP Manual
  • Parle\Parser
  • Add a grammar rule

Parle\Parser::push

(PECL parle >= 0.5.1)

Parle\Parser::push — Add a grammar rule

Descripción

public Parle\Parser::push ( string $name , string $rule ) : int

Push a grammar rule. The production id returned can be used later in the parsing process to identify the rule matched.

Parámetros

name

Rule name.

rule

The rule to be added. The syntax is Bison compatible.

Valores devueltos

Returns int representing the rule index.


Reset parser state

  • « Parle\Parser::push
  • Parle\Parser::right »
  • PHP Manual
  • Parle\Parser
  • Reset parser state

Parle\Parser::reset

(PECL parle >= 0.7.1)

Parle\Parser::reset — Reset parser state

Descripción

public Parle\Parser::reset ( int $tokenId = ? ) : void

Reset parser state using the given token id.

Parámetros

tokenId

Token id.

Valores devueltos

No devuelve ningún valor.


Declare a token with right-associativity

  • « Parle\Parser::reset
  • Parle\Parser::sigil »
  • PHP Manual
  • Parle\Parser
  • Declare a token with right-associativity

Parle\Parser::right

(PECL parle >= 0.5.1)

Parle\Parser::right — Declare a token with right-associativity

Descripción

public Parle\Parser::right ( string $tok ) : void

Declare a terminal with right associativity.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Retrieve a matching part of a rule

  • « Parle\Parser::right
  • Parle\Parser::token »
  • PHP Manual
  • Parle\Parser
  • Retrieve a matching part of a rule

Parle\Parser::sigil

(PECL parle >= 0.5.1)

Parle\Parser::sigil — Retrieve a matching part of a rule

Descripción

public Parle\Parser::sigil ( int $idx ) : string

Retrieve a part of the match by a rule. This method is equivalent to the pseudo variable functionality in Bison.

Parámetros

idx

Match index, zero based.

Valores devueltos

Returns a string with the matched part.


Declare a token

  • « Parle\Parser::sigil
  • Parle\Parser::tokenId »
  • PHP Manual
  • Parle\Parser
  • Declare a token

Parle\Parser::token

(PECL parle >= 0.5.1)

Parle\Parser::token — Declare a token

Descripción

public Parle\Parser::token ( string $tok ) : void

Declare a terminal to be used in the grammar.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Get token id

  • « Parle\Parser::token
  • Parle\Parser::trace »
  • PHP Manual
  • Parle\Parser
  • Get token id

Parle\Parser::tokenId

(PECL parle >= 0.5.1)

Parle\Parser::tokenId — Get token id

Descripción

public Parle\Parser::tokenId ( string $tok ) : int

Retrieve the id of the named token.

Parámetros

tok

Name of the token as used in Parle\Parser::token().

Valores devueltos

Returns int representing the token id.


Trace the parser operation

  • « Parle\Parser::tokenId
  • Parle\Parser::validate »
  • PHP Manual
  • Parle\Parser
  • Trace the parser operation

Parle\Parser::trace

(PECL parle >= 0.5.1)

Parle\Parser::trace — Trace the parser operation

Descripción

public Parle\Parser::trace ( ) : string

Retrieve the current parser operation description. This can be especially useful for studying the parser and to optimize the grammar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a string with the trace information.


Validate input

  • « Parle\Parser::trace
  • Parle\RParser »
  • PHP Manual
  • Parle\Parser
  • Validate input

Parle\Parser::validate

(PECL parle >= 0.5.1)

Parle\Parser::validate — Validate input

Descripción

public Parle\Parser::validate ( string $data , Parle\Lexer $lexer ) : bool

Validate an input string. The string is parsed internally, thus this method is useful for the quick input validation.

Parámetros

data

String to be validated.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

Valores devueltos

Returns bool witnessing whether the input chimes or not with the defined rules.


The Parle\RParser class

(PECL parle >= 0.7.0)

Introducción

Parser class. Rules can be defined on the fly. Once finalized, a Parle\RLexer instance is required to deliver the token stream.

Sinopsis de la Clase

Parle\RParser {
/* Constants */
const int ACTION_ERROR = 0 ;
const int ACTION_SHIFT = 1 ;
const int ACTION_REDUCE = 2 ;
const int ACTION_GOTO = 3 ;
const int ACTION_ACCEPT = 4 ;
const int ERROR_SYNTAX = 0 ;
const int ERROR_NON_ASSOCIATIVE = 1 ;
const int ERROR_UNKNOWN_TOKEN = 2 ;
/* Propiedades */
public int $action = 0 ;
public int $reduceId = 0 ;
/* Métodos */
public advance ( ) : void
public build ( ) : void
public consume ( string $data , Parle\RLexer $rlexer ) : void
public dump ( ) : void
public errorInfo ( ) : Parle\ErrorInfo
public left ( string $tok ) : void
public nonassoc ( string $tok ) : void
public precedence ( string $tok ) : void
public push ( string $name , string $rule ) : int
public reset ( int $tokenId = ? ) : void
public right ( string $tok ) : void
public sigil ( int $idx = ? ) : string
public token ( string $tok ) : void
public tokenId ( string $tok ) : int
public trace ( ) : string
public validate ( string $data , Parle\RLexer $lexer ) : bool
}

Constantes predefinidas

Parle\RParser::ACTION_ERROR

Parle\RParser::ACTION_SHIFT

Parle\RParser::ACTION_REDUCE

Parle\RParser::ACTION_GOTO

Parle\RParser::ACTION_ACCEPT

Parle\RParser::ERROR_SYNTAX

Parle\RParser::ERROR_NON_ASSOCIATIVE

Parle\RParser::ERROR_UNKNOWN_TOKEN

Propiedades

action

Current parser action that matches one of the action class constants, readonly.

reduceId

Grammar rule id just processed in the reduce action. The value corresponds either to a token or to a production id. Readonly.

Tabla de contenidos

  • Parle\RParser::advance — Process next parser rule
  • Parle\RParser::build — Finalize the grammar rules
  • Parle\RParser::consume — Consume the data for processing
  • Parle\RParser::dump — Dump the grammar
  • Parle\RParser::errorInfo — Retrieve the error information
  • Parle\RParser::left — Declare a token with left-associativity
  • Parle\RParser::nonassoc — Declare a token with no associativity
  • Parle\RParser::precedence — Declare a precedence rule
  • Parle\RParser::push — Add a grammar rule
  • Parle\RParser::reset — Reset parser state
  • Parle\RParser::right — Declare a token with right-associativity
  • Parle\RParser::sigil — Retrieve a matching part of a rule
  • Parle\RParser::token — Declare a token
  • Parle\RParser::tokenId — Get token id
  • Parle\RParser::trace — Trace the parser operation
  • Parle\RParser::validate — Validate input


Process next parser rule

  • « Parle\RParser
  • Parle\RParser::build »
  • PHP Manual
  • Parle\RParser
  • Process next parser rule

Parle\RParser::advance

(PECL parle >= 0.7.0)

Parle\RParser::advance — Process next parser rule

Descripción

public Parle\RParser::advance ( ) : void

Prosess next parser rule.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Finalize the grammar rules

  • « Parle\RParser::advance
  • Parle\RParser::consume »
  • PHP Manual
  • Parle\RParser
  • Finalize the grammar rules

Parle\RParser::build

(PECL parle >= 0.7.0)

Parle\RParser::build — Finalize the grammar rules

Descripción

public Parle\RParser::build ( ) : void

Any tokens and grammar rules previously added are finalized. The rule set becomes readonly and the parser is ready to start.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Consume the data for processing

  • « Parle\RParser::build
  • Parle\RParser::dump »
  • PHP Manual
  • Parle\RParser
  • Consume the data for processing

Parle\RParser::consume

(PECL parle >= 0.7.0)

Parle\RParser::consume — Consume the data for processing

Descripción

public Parle\RParser::consume ( string $data , Parle\RLexer $rlexer ) : void

Consume the data for parsing.

Parámetros

data

Data to be parsed.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

Valores devueltos

No devuelve ningún valor.


Dump the grammar

  • « Parle\RParser::consume
  • Parle\RParser::errorInfo »
  • PHP Manual
  • Parle\RParser
  • Dump the grammar

Parle\RParser::dump

(PECL parle >= 0.7.0)

Parle\RParser::dump — Dump the grammar

Descripción

public Parle\RParser::dump ( ) : void

Dump the current grammar to stdout.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Retrieve the error information

  • « Parle\RParser::dump
  • Parle\RParser::left »
  • PHP Manual
  • Parle\RParser
  • Retrieve the error information

Parle\RParser::errorInfo

(PECL parle >= 0.7.0)

Parle\RParser::errorInfo — Retrieve the error information

Descripción

public Parle\RParser::errorInfo ( ) : Parle\ErrorInfo

Retrieve the error information in case Parle\RParser::action() returned the error action.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns an instance of Parle\ErrorInfo.


Declare a token with left-associativity

  • « Parle\RParser::errorInfo
  • Parle\RParser::nonassoc »
  • PHP Manual
  • Parle\RParser
  • Declare a token with left-associativity

Parle\RParser::left

(PECL parle >= 0.7.0)

Parle\RParser::left — Declare a token with left-associativity

Descripción

public Parle\RParser::left ( string $tok ) : void

Declare a terminal with left associativity.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Declare a token with no associativity

  • « Parle\RParser::left
  • Parle\RParser::precedence »
  • PHP Manual
  • Parle\RParser
  • Declare a token with no associativity

Parle\RParser::nonassoc

(PECL parle >= 0.7.0)

Parle\RParser::nonassoc — Declare a token with no associativity

Descripción

public Parle\RParser::nonassoc ( string $tok ) : void

Declare a terminal, that cannot appear more than once in the row.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Declare a precedence rule

  • « Parle\RParser::nonassoc
  • Parle\RParser::push »
  • PHP Manual
  • Parle\RParser
  • Declare a precedence rule

Parle\RParser::precedence

(PECL parle >= 0.7.0)

Parle\RParser::precedence — Declare a precedence rule

Descripción

public Parle\RParser::precedence ( string $tok ) : void

Declares a precedence rule for a fictious terminal symbol. This rule can be later used in the specific grammar rules.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Add a grammar rule

  • « Parle\RParser::precedence
  • Parle\RParser::reset »
  • PHP Manual
  • Parle\RParser
  • Add a grammar rule

Parle\RParser::push

(PECL parle >= 0.7.0)

Parle\RParser::push — Add a grammar rule

Descripción

public Parle\RParser::push ( string $name , string $rule ) : int

Push a grammar rule. The production id returned can be used later in the parsing process to identify the rule matched.

Parámetros

name

Rule name.

rule

The rule to be added. The syntax is Bison compatible.

Valores devueltos

Returns int representing the rule index.


Reset parser state

  • « Parle\RParser::push
  • Parle\RParser::right »
  • PHP Manual
  • Parle\RParser
  • Reset parser state

Parle\RParser::reset

(PECL parle >= 0.7.1)

Parle\RParser::reset — Reset parser state

Descripción

public Parle\RParser::reset ( int $tokenId = ? ) : void

Reset parser state using the given token id.

Parámetros

tokenId

Token id.

Valores devueltos

No devuelve ningún valor.


Declare a token with right-associativity

  • « Parle\RParser::reset
  • Parle\RParser::sigil »
  • PHP Manual
  • Parle\RParser
  • Declare a token with right-associativity

Parle\RParser::right

(PECL parle >= 0.7.0)

Parle\RParser::right — Declare a token with right-associativity

Descripción

public Parle\RParser::right ( string $tok ) : void

Declare a terminal with right associativity.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Retrieve a matching part of a rule

  • « Parle\RParser::right
  • Parle\RParser::token »
  • PHP Manual
  • Parle\RParser
  • Retrieve a matching part of a rule

Parle\RParser::sigil

(PECL parle >= 0.7.0)

Parle\RParser::sigil — Retrieve a matching part of a rule

Descripción

public Parle\RParser::sigil ( int $idx = ? ) : string

Retrieve a part of the match by a rule. This method is equivalent to the pseudo variable functionality in Bison.

Parámetros

idx

Match index, zero based.

Valores devueltos

Returns a string with the matched part.


Declare a token

  • « Parle\RParser::sigil
  • Parle\RParser::tokenId »
  • PHP Manual
  • Parle\RParser
  • Declare a token

Parle\RParser::token

(PECL parle >= 0.7.0)

Parle\RParser::token — Declare a token

Descripción

public Parle\RParser::token ( string $tok ) : void

Declare a terminal to be used in the grammar.

Parámetros

tok

Token name.

Valores devueltos

No devuelve ningún valor.


Get token id

  • « Parle\RParser::token
  • Parle\RParser::trace »
  • PHP Manual
  • Parle\RParser
  • Get token id

Parle\RParser::tokenId

(PECL parle >= 0.7.0)

Parle\RParser::tokenId — Get token id

Descripción

public Parle\RParser::tokenId ( string $tok ) : int

Retrieve the id of the named token.

Parámetros

tok

Name of the token as used in Parle\RParser::token().

Valores devueltos

Returns int representing the token id.


Trace the parser operation

  • « Parle\RParser::tokenId
  • Parle\RParser::validate »
  • PHP Manual
  • Parle\RParser
  • Trace the parser operation

Parle\RParser::trace

(PECL parle >= 0.7.0)

Parle\RParser::trace — Trace the parser operation

Descripción

public Parle\RParser::trace ( ) : string

Retrieve the current parser operation description. This can be especially useful to study the parser and to optimize the grammar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a string with the trace information.


Validate input

  • « Parle\RParser::trace
  • Parle\Stack »
  • PHP Manual
  • Parle\RParser
  • Validate input

Parle\RParser::validate

(PECL parle >= 0.7.0)

Parle\RParser::validate — Validate input

Descripción

public Parle\RParser::validate ( string $data , Parle\RLexer $lexer ) : bool

Validate an input string. The string is parsed internally, thus this method is useful for the quick input validation.

Parámetros

data

String to be validated.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

Valores devueltos

Returns bool whitnessing whether the input chimes or not with the defined rules.


The Parle\Stack class

(PECL parle >= 0.7.0)

Introducción

Parle\Stack is a LIFO stack. The elements are inserted and removed only from one end.

Sinopsis de la Clase

Parle\Stack {
/* Propiedades */
public bool $empty = true ;
public int $size = 0 ;
public mixed $top ;
/* Métodos */
public pop ( ) : void
public push ( mixed $item ) : void
}

Propiedades

empty

Whether the stack is empty, readonly.

size

Stack size, readonly.

top

Element on the top of the stack.

Tabla de contenidos

  • Parle\Stack::pop — Pop an item from the stack
  • Parle\Stack::push — Push an item into the stack


Pop an item from the stack

  • « Parle\Stack
  • Parle\Stack::push »
  • PHP Manual
  • Parle\Stack
  • Pop an item from the stack

Parle\Stack::pop

(PECL parle >= 0.5.1)

Parle\Stack::pop — Pop an item from the stack

Descripción

public Parle\Stack::pop ( ) : void

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.


Push an item into the stack

  • « Parle\Stack::pop
  • Parle\Token »
  • PHP Manual
  • Parle\Stack
  • Push an item into the stack

Parle\Stack::push

(PECL parle >= 0.5.1)

Parle\Stack::push — Push an item into the stack

Descripción

public Parle\Stack::push ( mixed $item ) : void

Parámetros

item

Variable to be pushed.

Valores devueltos

No devuelve ningún valor.


The Parle\Token class

(PECL parle >= 0.5.2)

Introducción

This class represents a token. Lexer returns instances of this class.

Sinopsis de la Clase

Parle\Token {
/* Constants */
const int EOI = 0 ;
const int UNKNOWN = -1 ;
const int SKIP = -2 ;
/* Propiedades */
public int $id ;
public string $value ;
/* Métodos */
}

Propiedades

id

Token id.

value

Token value.

Constantes predefinidas

Parle\Token::EOI

End of input token id.

Parle\Token::UNKNOWN

Unknown token id.

Parle\Token::SKIP

Skip token id.


The Parle\ErrorInfo class

(PECL parle >= 0.5.2)

Introducción

The class represents detailed error information as supplied by Parle\Parser::errorInfo()

Sinopsis de la Clase

Parle\ErrorInfo {
/* Propiedades */
public int $id ;
public int $position ;
public mixed $token ;
/* Métodos */
}

Propiedades

id

Error id.

position

Position in the input, where the error occurred.

token

If applicable - the Parle\Token related to the error, otherwise null.


The Parle\LexerException class

(PECL parle >= 0.5.1)

Introducción

Sinopsis de la Clase

Parle\LexerException extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The Parle\ParserException class

(PECL parle >= 0.5.1)

Introducción

Sinopsis de la Clase

Parle\ParserException extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Expresiones regulares (compatibles con Perl)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Patrones PCRE
    • Sintaxis de expresiones regulares de PCRE — Sintaxis de Patrón
    • Posibles modificadores en patrones de expresiones regulares — Modificadores de patrones
    • Diferencias con Perl
    • Diferencias con las expresiones regulares POSIX
  • Funciones de PCRE
    • preg_filter — Realiza una búsqueda y sustitución de una expresión regular
    • preg_grep — Devuelve entradas de matriz que coinciden con el patrón
    • preg_last_error_msg — Returns the error message of the last PCRE regex execution
    • preg_last_error — Devuelve el código de error de la última ejecución de expresión regular de PCRE
    • preg_match_all — Realiza una comparación global de una expresión regular
    • preg_match — Realiza una comparación con una expresión regular
    • preg_quote — Escapar caracteres en una expresión regular
    • preg_replace_callback_array — Realizar una búsqueda y sustitución de expresión regular con retrollamadas
    • preg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
    • preg_replace — Realiza una búsqueda y sustitución de una expresión regular
    • preg_split — Divide un string mediante una expresión regular


Introducción

La sintaxis de los patrones empleados en estas funciones se parece mucho a la de Perl. La expresión se debe encerrar entre unos delimitadores, una barra (/), por ejemplo. Los delimitadores pueden ser cualquier carácter no alfanumérico, cualquier carácter ASCII que no sea de tipo espacio en blanco, excepto la barra invertida (\), y el byte null. Si el carácter delimitador se va a emplear en la expresión misma, es necesario escaparlo con la barra invertida. A partir de PHP 4.0.4, se pueden utilizar los delimitadores estilo Perl (), {}, [], y <>. Véase Sintaxis de patrones para una explicación detallada.

Al delimitador final le pueden seguir varios modificadores que afectan a la comparación. Véase Modificadores de patrones.

PHP tambíén admite expresiones regulares empleando una sintaxis POSIX extendido utilzando las Funciones de expresiones regulares POSIX extendido.

Nota:

Estas extensiones mantienen una caché global por hilo de expresiones regulares compiladas (hasta 4096).

Advertencia

Se debería considerar algunas limitaciones de PCRE. Léase » http://www.pcre.org/pcre.txt para más información.

La biblioteca PCRE es un conjunto de funciones que implementan comparaciones de patrones de expresiones regulares empleando la misma sintaxis y semántica que Perl 5, con muy pocas diferencias (véase más adelante). La implementación actual corresponde a Perl 5.005.


Instalación

La extensión PCRE es una extensión del núcleo de PHP, por lo que siempre está habilitada. Por defecto, esta extensión se compila usando la biblioteca PCRE integrada. Alternativamente, se puede usar una biblioteca PCRE externa con la opción de configuración --with-pcre-regex=DIR, donde DIR es la ubicación de los ficheros de inclusión y de la biblioteca de PCRE. Se recomienda utilizar PCRE 8.10 o posterior para PHP 5.6 y 7.0.

A partir de PHP 7.0.0 la compilación «just-in-time» de PCRE está soportada predeterminadamente, aunque se puede inhabilitar, a partir de PHP 7.0.12, con la opción de configuración --without-pcre-jit.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.

Nota:

Antes de PHP 5.3.0, esta extensión se podía inhabilitar con la opción de configuración --without-pcre-regex.

PCRE es un proyecto activo y mientras se va modificando, también lo va haciendo la funcionalidad de PHP que depende de él. Es posible que algunas partes de la documentación de PHP no estén actualizadas, por lo que podrían no cubrir las características más nuevas que proporciona PCRE. Para un listado de cambios, véase el » registro de cambios de la biblioteca PCRE y también el siguiente historial de la biblioteca PCRE integrada:

Historial de actualización de la biblioteca PCRE integrada
Versión de PHP | Versión de PCRE actualizada | Notas
7.0.3 / 5.6.18 / 5.5.32 | 8.38 | Véase CVE-2015-8383, CVE-2015-8386, CVE-2015-8387, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8393, CVE-2015-8394
7.0.0 / 5.6.9 / 5.5.26 / 5.4.41 | 8.37 | Véase CVE-2015-2325, CVE-2015-2326
5.6.0 / 5.5.10 | 8.34 |
5.5.0 / 5.4.14 / 5.3.24 | 8.32 |
5.4.9 / 5.3.19 | 8.31 |
5.3.7 | 8.12 |
5.3.6 | 8.11 |
5.3.4 | 8.10 |
5.3.3 / 5.2.14 | 8.02 |
5.3.2 | 8.00 |
5.3.0 / 5.2.13 | 7.9 |
5.2.7 | 7.8 |
5.2.6 | 7.6 |
5.2.5 | 7.3 |
5.2.4 | 7.2 |
5.2.2 | 7.0 |
5.2.0 | 6.7 |
5.1.3 | 6.6 |
5.1.0 | 6.2 |
5.0.5 | 5.0 |
5.0.0 | 4.5 |
4.4.7 | 7.7 |


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de PCRE
Nombre | Por defecto | Cambiable | Historial de cambios
pcre.backtrack_limit | "1000000" | PHP_INI_ALL | Disponible a partir de PHP 5.2.0.
pcre.recursion_limit | "100000" | PHP_INI_ALL | Disponible a partir de PHP 5.2.0.
pcre.jit | "1" | PHP_INI_ALL | Disponible a partir de PHP 7.0.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

pcre.backtrack_limit integer

Límite de retroceso de PCRE. Por defecto es 100000 para PHP < 5.3.7.

pcre.recursion_limit integer

Límite de recursividad de PCRE. Por favor, observe que si establece este valor con un número alto se podría consumir toda la pila de procesos disponible y provocar finalmente el malfuncionamiento de PHP (a causa de alcanzar el límite del tamaño de la pila impuesto por el sistema operativo).

pcre.jit boolean

Si se va a utilizar la compilacion «just-in-time» de PCRE.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes PREG
Constante | Descripción | Desde
PREG_PATTERN_ORDER | Ordena los resultados de forma que $coincidencias[0] es un array de coincidencias del patrón completo, $coincidencias[1] es un array de cadenas que coinciden con el primer subpatrón entre paréntesis, y así sucesivamente. Esta bandera sólo se usa con preg_match_all(). |
PREG_SET_ORDER | Ordena los resultados de forma que $coincidencias[0] es un array del primer conjunto de coincidencias, $coincidencias[1] es un array del segundo conjunto de coincidencias, y así sucesivamente. Esta bandera sólo se usa con preg_match_all(). |
PREG_OFFSET_CAPTURE | Véase la descripción de PREG_SPLIT_OFFSET_CAPTURE. | 4.3.0
PREG_SPLIT_NO_EMPTY | Esta bandera le indica a preg_split() que devuelva sólo elementos que no estén vacíos. |
PREG_SPLIT_DELIM_CAPTURE | Esta bandera le indica a preg_split() que capture también la expresión entre paréntesis en el patrón delimitador. | 4.0.5
PREG_SPLIT_OFFSET_CAPTURE | Si se establece esta bandera, por cada coincidencia producida, el índice de la cadena añadida también será devuelto. Observe que esto cambia los valores devueltos en un array, donde cada elemento es un array consistente en la cadena coincidente en el índice 0, y su índice dentro de la cadena objetivo en el índice 1. Esta bandera sólo es usada por preg_split(). | 4.3.0
PREG_UNMATCHED_AS_NULL |  | 7.2.0
PREG_NO_ERROR | Devuelto por preg_last_error() si no se produjeron errores. | 5.2.0
PREG_INTERNAL_ERROR | Devuelto por preg_last_error() si se produjo un error interno de PCRE. | 5.2.0
PREG_BACKTRACK_LIMIT_ERROR | Devuelto por preg_last_error() si el límite de marcha atrás fue agotado. | 5.2.0
PREG_RECURSION_LIMIT_ERROR | Devuelto por preg_last_error() si el límite de recursividad fue agotado. | 5.2.0
PREG_BAD_UTF8_ERROR | Devuelto por preg_last_error() si el último error fue causado por datos UTF-8 malformados (sólo cuando se ejecuta una expresión regular en modo UTF-8). | 5.2.0
PREG_BAD_UTF8_OFFSET_ERROR | Devuelto por preg_last_error() si el índice no se correspondió con el inicio de un punto de código UTF-8 válido (sólo cuando se ejecuta una expresión regular en modo UTF-8). | 5.3.0
PREG_JIT_STACKLIMIT_ERROR | Devuelto por preg_last_error() si la última función de PCRE falló debido al espacio limitado de la pila JIT. | 7.0.0
PCRE_VERSION | Versión y fecha de distribución de PCRE (p.ej. "7.0 18-Dec-2006"). | 5.2.4


Ejemplos

Ejemplo #1 Ejemplos de patrones válidos

  • /<\/\w+>/
  • |(\d{3})-\d+|Sm
  • /^(?i)php[34]/
  • {^\s+(\s+)?$}

Ejemplo #2 Ejemplos de patrones no válidos

  • /href='(.*)' - falta el delimitador final
  • /\w+\s*\w+/J - modificador 'J' desconocido
  • 1-\d3-\d3-\d4| - falta el delimitador inicial


Patrones PCRE

Tabla de contenidos

  • Sintaxis de expresiones regulares de PCRE
  • Posibles modificadores en patrones de expresiones regulares
  • Diferencias con Perl
  • Diferencias con las expresiones regulares POSIX


Sintaxis de Patrón

Tabla de contenidos

  • Introducción
  • Delimitadores
  • Metacaracteres
  • Secuencias de escape
  • Propiedades de los caracteres Unicode
  • Anclas
  • Punto
  • Clases carácter
  • Alternancia
  • Ajuste de opciones internas
  • Sub-patrones
  • Repetición
  • Retroreferencias
  • Declaraciones
  • Sub-patrones de una sóla aplicación
  • Sub-patrones condicionales
  • Comentarios
  • Patrones recursivos
  • Rendimiento


Introducción

La sintaxis y semántica de las expresiones regulares admitidas por PCRE están descritas más adelante. Las expresiones regulares también están descritas en la documentación de Perl y en otros libros, algunos de los cuales contienen abundantes ejemplos. El libro de Jeffrey Friedl «Mastering Regular Expressions», publicado por O'Reilly (ISBN 1-56592-257-3), las cubre en gran detalle. La descripción aquí dada está prevista como documentación de referencia.

Una expresión regular es un patrón que se compara con una cadena objetivo de izquierda a derecha. La mayoría de los caracteres se representan a sí mismos en un patrón, y se comparan con el carácter correspondiente en el sujeto. Como ejemplo trivial, el patrón El veloz murciélago hindú coincide con una porción de una cadena objetivo que es idéntica a dicho patrón.


Delimitadores

Cuando se usan funciones PCRE, se requiere que el patrón esté encerrado entre delimitadores. Un delimitador puede ser cualquier carácter no alfanumérico, que no sea una barra invertida, y que no sea un espacio en blanco.

Los delimitadores que se usan a menudo son barras oblícuas (/), signos de número (#) y virgulillas (~). Los siguientes ejemplos son todos patrones delimitados válidos.

/foo bar/
#^[^0-9]$#
+php+
%[a-zA-Z0-9_-]%

También es posible utilizar los delimitadores estilo corchete, donde los corchetes de apertura y cierre son los delimitadores inicial y final, respectivamente. (), {}, [] y <> son todos pares de delimitadores válidos.

(this [is] a (pattern))
{this [is] a (pattern)}
[this [is] a (pattern)]
<this [is] a (pattern)>
Bracket style delimiters do not need to be escaped when they are used as meta characters within the pattern, but as with other delimiters they must be escaped when they are used as literal characters.

Si el delimitador necesita ser comparado dentro del patrón se debe escapar usando una barra invertida. Si el delimitador aparece a menudo dentro del patrón, es una buena idea escoger otro delimitador para aumentar la legibilidad.

/http:\/\//
#http://#
La función preg_quote() se puede usar para escapar una cadena para inyectarla dentro de un patrón y su segundo parámetro opcional de puede usar parar especificar el delimitador a escapar.

Puede añadir modificadores de patrón después del delimitador final. El siguiente es un ejemplo de comparación insensible a mayúsculas-minúsculas:

#[a-z]#i


Metacaracteres

El poder de las expresiones regulares viene dado por la capacidad de incluir alternativas y repeticiones en el patrón. Éstos están codificadoes en el patrón por el uso de metacaracteres, los cuales no se representan a sí mismos, sino que son interpretados de una forma especial.

Hay dos conjuntos diferentes de metacaracteres: aquéllos que son reconocidos en cualquier lugar de un patrón excepto dentro de los corchetes, y aquéllos que son reconocidos dentro de los corchetes. Fuera de los corchetes, los metacaracteres son los siguientes:

Metacaracteres fuera de corchetes
Metacarácter | Descripción
\ | carácter de escape general con varios usos
^ | declaración de inicio de sujeto (o línea, en modo multilínea)
$ | declaración de fin de sujeto o antes de la terminación de nueva línea (o fin línea, en modo multilínea)
. | coincide con cualquier carácter excepto con el de nueva línea (por defecto)
[ | inicio de la definición de la clase carácter
] | fin de la definición de la clase carácter
| | inicio de rama alternativa
( | inicio de sub-patrón
) | fin de sub-patrón
? | amplia el significado de (, también cuantificador 0 o 1, también hace perezosos a los cuantificadores codiciosos (véase repetición)
* | cuantificador 0 o más
+ | cuantificador 1 o más
{ | inicio de cuantificador mín/máx
} | fin de cuantificador mín/máx
La parte de un patrón que está entre corchetes se llama una clase carácter. En una clase carácter los únicos metacaracteres son:
Metacaracteres dentro de corchetes (clases carácter)
Metacarácter | Descripción
\ | carácter de escape general
^ | niega la clase, pero sólo si se trata del primer carácter
- | indica el rango de caracteres
Las siguientes secciones describen el uso de cada metacarácter.


Secuencias de escape

El carácter barra invertida tiene varios usos. El primero es que si está seguido de un carácter no alfanumérico, toma cualquier significado especial que el carácter pueda tener. Este uso de la barra invertida como carácter de escape se aplica tanto dentro como fuera de las clases carácter.

Por ejemplo, si quiere coincidir un carácter "*", escriba "\*" en el patrón. Esto se aplica aunque el siguiente carácter pudiera ser interpretado como un metacarácter, por lo que es mejor asegurarse de preceder un carácter no alfanumérico con "\" para especificar que éste se representa a sí mismo. En particular, si quiere coincidir una barra invertida, escriba "\\".

Nota:

Las cadenas PHP entre comillas simples y dobles tienen un significado especial para la barra invertida. Así, si \ ha de ser comparado con una expresión regular \\, entonces se debe usar "\\\\" o '\\\\' en código PHP.

Si un patrón es compilado con la opción PCRE_EXTENDED, los espacios en blanco en el patrón (distinto de una clase carácter) y los caracteres entre un "#" fuera de una clase carácter y el siguiente carácter de nueva línea se ignoran. Una barra invertida de escape se puede usar para incluir un carácter espacio en blanco o "#" como parte del patrón.

Un segundo uso de la barra invertida proporciona una manera de codificar caracteres no imprimibles en patrones de una forma visible. No hay restricciones en la aparición de los caracteres no imprimibles, excepto para el cero binario el cual finaliza el patrón, pero cuando un patrón está siendo preparado para edición de texto, normalmente es más fácil usar una de las siguientes secuencias de escape en vez del carácter binario que representan:

\a
alarma, es decir, el carácter BEL (07 hex)
\cx
"control-x", donde x es cualquier carácter
\e
escape (1B hex)
\f
salto de página (0C hex)
\n
nueva línea (0A hex)
\p{xx}
un carácter con la propiedad xx, véase propiedades unicode para más información
\P{xx}
un carácter sin la propiedad xx, véase propiedades unicode para más información
\r
retorno de carro (0D hex)
\R
salto de línea: coincide con \n, \r y \r\n
\t
tabulador (09 hex)
\xhh
carácter con el código hexadecimal hh
\ddd
carácter con el código octal ddd, o retroreferencia

El efecto exacto de "\cx" es como sigue: si "x" es una letra minúscula, ésta se convierte a mayúscula. Después se invierte el bit 6 del carácter (40 hex). Así, "\cz" se convierte en 1A hex, pero "\c{" se convierte en 3B hex, mientras que "\c;" se conviente en 7B hex.

Después de "\x", se leen hasta dos dígitos hexadecimales (las letras pueden ser tanto mayúsculas como minúsculas). En modo UTF-8, "\x{...}" es permitido, donde el contenido entre las llaves es una cadena de dígitos hexadecimales. Esto se interpreta como un carácter UTF-8 cuyo número de código es el dado por el número hexadecimal. La secuencia de escape hexadecimal original, \xhh, conincide con un carácter UTF-8 de dos bytes si el valor es mayor que 127.

Después de "\0", se leen hasta dos dígitos octales más. En cualquier caso, si hay menos de dos dígitos, sólo se usan aquéllos que están presentes. Así, la secuencia "\0\x\07" especifica dos ceros binarios seguidos de un carácter BEL. Asegúrese de proporcionar dos dígitos después del cero inicial si el carácter que sigue es también un dígito octal.

El manejo de una barra invertida seguida de un dígito distinto de 0 es complicado. Fuera de una clase carácter, PCRE lee este dígito, así como cualesquiera dígitos siguientes, como un número decimal. Si el número es menor que 10, o si ha habido al menos tantas capturas previas hacia la izquierda en la expresión, la secuencia entera es tomada como una retroreferencia. Una descripción de cómo funciona esto se da más adelante, seguido de una discusión sobre sub-patrones entre paréntesis.

Dentro de una clase carácter, o si el número decimal es mayor que 9 y no han habido tantos sub-patrones de captura, PCRE relee hasta tres dígitos octales siguientes a la barra invertida, y genera un sólo byte de los 8 bits menos significativos del valor. Cualesquiera dígitos subsiguientes se representan a sí mismos. Por ejemplo:

\040
es otra manera de escribir un espacio
\40
es lo mismo, siempre que haya menos de 40 sub-patrones de captura previos
\7
es siempre una retroreferencia
\11
puede ser una retrorefenrencia, u otra manera de escribir una tabulación
\011
es siempre una tabulación
\0113
es una tabulación seguida del carácter "3"
\113
es el carácter con el código octal 113 (ya que no puede haber más de 99 retroreferencias)
\377
es un byte consistente en bits 1 enteramente
\81
es tanto una retroreferencia como un cero binario seguido de los caracteres "8" y "1"

Observe que los valores octales 100 y mayores no deben ser precedidos por un cero inicial, ya que nunca se leen más de tres dígitos octales.

Todas las secuencias que definen un valor de byte único se pueden usar tanto dentro como fuera de las clases carácter. Además, dentro de una clase carácter, la secuencia "\b" se interpreta como el carácter retroceso (08 hex). Fuera de una clase carácter tiene diferentes significados (véase más abajo).

El tercer uso de la barra invertida es parar especificar tipos de caracteres genéricos:

\d
cualquier dígito decimal
\D
cualquier carácter que no es un dígito decimal
\h
cualquier carácter espacio en blanco horizontal (desde PHP 5.2.4)
\H
cualquier carácter que no es un carácter espacio en blanco horizontal (desde PHP 5.2.4)
\s
cualquier carácter espacio en blanco
\S
cualquier carácter que no es un carácter espacio en blanco
\v
cualquier carácter espacio en blanco vertical (desde PHP 5.2.4)
\V
cualquier carácter que no es un carácter espacio en blanco vertical (desde PHP 5.2.4)
\w
cualquier carácter "palabra"
\W
cualquier carácter que no es "palabra"

Cada par de sencuencias de escape divide el conjunto completo de caracteres en dos conjuntos separados. Cualquier carácter dado concide con uno, y sólo uno, de cada par.

Los caracters "espacios en blanco" son HT (9), LF (10), FF (12), CR (13), y el espacio (32). Sin embargo, si ocurre una coincidencia específica de una región, los caracteres con puntos de código en el rango 128-255 podrían también considerarse como caracteres de espacio en blanco, por ejemplo, NBSP (A0).

Un carácter "palabra" es cualquier letra o dígito o el carácter subrayado, es decir, cualquier carácter que pueda ser parte de una "palabra" Perl. La definición de letras y dígitos está controlada por las tablas de caracteres de PCRE, y pueden variar si tiene lugar la comparación de configuraciones regionales específicas. Por ejemplo, en la configuración regional "fr" (Francés), algunos códigos de caracteres mayores que 128 se usan para letras acentuadas, y éstos se comparan por \w.

Estas secuencias de tipo de caracteres puede aparecer tanto dentro como fuera de las clases carácter. Cada una coincide con un carácter del tipo apropiado. Si el punto de coincidencia actual está al final de la cadena objetivo, todas ellas fallarán, ya que no hay caracteres a comparar.

El cuarto uso de la barra invertida es para ciertas declaraciones simples. Una declaración especifica una condición que se debe encontrar en un punto particular de una comparación, sin consumir ningún carácter de la cadena objetivo. El uso de sub-patrones para declaraciones más complicadas se describe después. Las declaraciones de la barra invertida son

\b
límite de palabra
\B
distinto a límite de palabra
\A
comienzo del sujeto (independientemente del modo multilínea)
\Z
fin del sujeto o nueva línea al final (independientemente del modo multilínea)
\z
final del sujeto (independientemente del modo multilínea)
\G
primera posición de coincidencia del sujeto

Estas declaraciones pueden no aparecer en clases carácter (pero observe que "\b" tiene un significado diferente, a saber, el carácter retroceso, dentro de una clase carácter).

Un límite de palabra es una posición en la cadena objetivo donde el carácter actual y el carácter previo no coinciden con \w o \W (es decir, uno coincide con \w y el otro coincice con \W), o el inicio o final de la cadena si el primer o último carácter coincide con \w, respectivamente.

Las declaraciones \A, \Z, y \z difieren de los tradicionales circumflejo y dólar (descritos en anclas) de modo que siempre coinciden con el inicio y final absolutos de la cadena objetivo, sin importar las opciones que se apliquen. No les afectan las opciones PCRE_MULTILINE o PCRE_DOLLAR_ENDONLY. La diferencia entre \Z y \z es que \Z coincide antes de una nueva línea que es el último carácter de la cadena, además de al final de la cadena, mientras que \z coincide sólo con el final.

La declaración \G es verdadera sólo cuando la posición de comparación actual está al principio del punto de coincidencia, tal como se especifica en el argumento offset de preg_match(). Difiere de \A cuando el valor de offset no es cero.

Se puede usar \Q y \E para ignorar metacaracteres de expresiones regulares. Por ejemplo: \w+\Q.$.\E$ coincidirá con uno o más caracteres palabra, seguidos por los literales .$. y anclados al final de la cadena.

A partir de PHP 5.2.4, \K se puede usar para reiniciar el comienzo de comparación. Por ejemplo, el patrón foo\Kbar coincide con "foobar", pero informa de que ha coincidido con "bar". El uso de \K no interfiere con el parámetro de las cadenas capturadas. Por ejemplo, cuando el patrón (foo)\Kbar coincide con "foobar", la primera subcadena está establecida aún a "foo".


Propiedades de los caracteres Unicode

A partir de 5.1.0, están disponibles tres secuencias de escape adicionales para comparar tipos de caracteres genéricos cuando el modo UTF-8 está seleccionado. Son:

\p{xx}
un carácter con la propiedad xx
\P{xx}
un carácter sin la propiedad xx
\X
una secuencia Unicode extendida

Los nombres de las propiedades representadas arriba por xx están limitadas a las propiedades de la categoría general de Unicode. Cada carácter tiene exactamente una propiedad, especificada por una abreviatura de dos letras. Por compatibilidad con Perl, la negación se puede especificar incluyendo un acento circunflejo entre la llave de apertura y el nombre de la propiedad. Por ejemplo, \p{^Lu} es lo mismo que \P{Lu}.

Si sólo se especifica una letra con \p o \P, se incluyen todas las propiedades que comienzan con esa letra. En este caso, en la ausencia de negación, las llaves en la secuencia de escape son opcionales; estos dos ejemplos tienen el mismo efecto:

\p{L}
\pL

Códigos de propiedades admitidos
Propiedad | Coincidencias | Notas
C | Otro |
Cc | Control |
Cf | Formato |
Cn | Sin asignar |
Co | Uso privado |
Cs | Sustituto |
L | Letra | Incluye las siguientes propiedades: Ll, Lm, Lo, Lt y Lu.
Ll | Letra minúscula |
Lm | Letra modificadora |
Lo | Otra letra |
Lt | Letra de título |
Lu | Letra mayúscula |
M | Marca |
Mc | Marca de espacio |
Me | Marca de cierre |
Mn | Marca de no-espacio |
N | Número |
Nd | Número decimal |
Nl | Número letra |
No | Otro número |
P | Puntuación |
Pc | Puntuación de conexión |
Pd | Puntuación guión |
Pe | Puntuación de cierre |
Pf | Puntuación final |
Pi | Puntuación inicial |
Po | Otra puntuación |
Ps | Puntuación de apertura |
S | Símbolo |
Sc | Símbolo de moneda |
Sk | Símbolo modificador |
Sm | Símbolo matemático |
So | Otro símbolo |
Z | Separador |
Zl | Separador de línea |
Zp | Separador de párrafo |
Zs | Separador de espacio |

Las propiedades extendidas tales como InMusicalSymbols no están admitidas por PCRE.

El especificar coincidicencias insensibles a mayúsculas-minúsculas no afecta a estas secuencias de escape. Por ejemplo, \p{Lu} siempre coincide con letras mayúsculas.

Los conjuntos de caracteres Unicode están definidos como pertenecientes a ciertos alfabetos. Se puede hacer coincidir un carácter de uno de estos conjuntos usando un nombre de alfabeto. Por ejemplo:

  • \p{Greek}
  • \P{Han}

Aquellos que no son parte de un alfabeto identificado, son metidos en el mismo saco como Common. La lista actual de alfabetos es:

Supported scripts
Arabic | Armenian | Avestan | Balinese | Bamum
Batak | Bengali | Bopomofo | Brahmi | Braille
Buginese | Buhid | Canadian_Aboriginal | Carian | Chakma
Cham | Cherokee | Common | Coptic | Cuneiform
Cypriot | Cyrillic | Deseret | Devanagari | Egyptian_Hieroglyphs
Ethiopic | Georgian | Glagolitic | Gothic | Greek
Gujarati | Gurmukhi | Han | Hangul | Hanunoo
Hebrew | Hiragana | Imperial_Aramaic | Inherited | Inscriptional_Pahlavi
Inscriptional_Parthian | Javanese | Kaithi | Kannada | Katakana
Kayah_Li | Kharoshthi | Khmer | Lao | Latin
Lepcha | Limbu | Linear_B | Lisu | Lycian
Lydian | Malayalam | Mandaic | Meetei_Mayek | Meroitic_Cursive
Meroitic_Hieroglyphs | Miao | Mongolian | Myanmar | New_Tai_Lue
Nko | Ogham | Old_Italic | Old_Persian | Old_South_Arabian
Old_Turkic | Ol_Chiki | Oriya | Osmanya | Phags_Pa
Phoenician | Rejang | Runic | Samaritan | Saurashtra
Sharada | Shavian | Sinhala | Sora_Sompeng | Sundanese
Syloti_Nagri | Syriac | Tagalog | Tagbanwa | Tai_Le
Tai_Tham | Tai_Viet | Takri | Tamil | Telugu
Thaana | Thai | Tibetan | Tifinagh | Ugaritic
Vai | Yi |  |  |

El escape \X coincide con un cluster de grafemas ampliado de Unicode. Un clúster de grafemas ampliado es uno o más caracteres Unicode que se combinan para formar un único glifo. A todos los efectos, se puede pensar en ello como el equivalente Unicode de . ya que coincidirá con un carácter compuesto, independientemente de cúantos caracteres individuales se usan en realidad para representarlo.

En versiones de PCRE anteriores a la 8.32 (las cuales se corresponden con versiones de PHP anteriores a la 5.4.14 al usar la biblioteca PCRE incluida), \X es equivalente a (?>\PM\pM*). Esto es, coincide con un carácter sin la propiedad "marca", seguido de cero o más caracteres con la propiedad "marca", y trata la secuencia como un grupo atómico (véase más abajo). Los caracteres con la propiedad "marca" son normalmente acentos que afectan al carácter predecente.

La comparación de caracteres por propiedades Unicode no es rápida, porque PCRE ha de buscar una estructura que contiene datos por más de quince mil caracteres. Es por esto por lo que las secuencias de escape tradicionales tales como \d y \w no usan propiedades Unicode en PCRE.


Anclas

Fuera de una clase carácter, en el modo de comparación por defecto, el carácter circunflejo (^) es una declaración que es verdadera sólo si el punto de coincidencia actual está en el inicio de de la cadena objetivo. Dentro de una clase carácter, circunflejo (^) tiene un significado totalmente diferente (véase más adelante).

Circunflejo (^) no necesita ser el primer carácter del patrón si están implicadas varias alternativas, pero debería ser la primera cosa en cada alternativa en la que aparece si el patrón es comparado siempre con esa rama. Si todas las posibles alternativas comienzan con un circunflejo (^), es decir, si el patrón es obligado a coincidir sólo con el comienzo de la cadena objetivo, se dice que el patrón está "anclado". (También hay otras contrucciones que pueden causar que un patrón esté anclado.)

Un carácter dólar ($) es una declaración la cual es true sólo si el punto actual de coincidencia está al final de la cadena objetivo, o inmediatamente antes de un carácter de nueva línea que es el último carácter en la cadena (por defecto). Dólar ($) no necesita ser el último carácter del patrón si están implicadas varias alternativas, pero debería ser el último elemento en cualquier rama en la que aparezca. Dólar no tiene un significado especial en una clase carácter.

El significado de dólar se puede cambiar, de modo que sólo coincida con el final absoluto de la cadena, estableciendo la opción PCRE_DOLLAR_ENDONLY en tiempo de compilación o comparación. Esto no afecta a la declaración \Z.

El significado de los caracteres circunflejo y dólar se cambia si la opción PCRE_MULTILINE es establecida. Cuando este es el caso, conciden inmediatemente después e inmediatamente antes que un carácter "\n" interno, respectivamente, además de coincidir al principio y final de la cadena objetivo. Por ejemplo, el patrón /^abc$/ coincide con la cadena objetivo "def\nabc" en el modo multilínea, y no en otros. Consecuentemente, los patrones que están anclados en el modo de una sóla línea, a causa del inicio de todas las ramas con "^", no están anclados en el modo multilínea. La opción PCRE_DOLLAR_ENDONLY es ignorada si PCRE_MULTILINE está establecida.

Observe que las secuencias \A, \Z, y \z se pueden usar para coincidir el inicio y final de la cadena objetivo en ambos modos, y si todas las ramas de un patrón comienzan con \A, el patrón siempre es anclado, sin tener en cuenta si PCRE_MULTILINE está establecido o no.


Punto

Fuera de una clase carácter, un punto en el patrón coincide con un carácter en el sujeto, incluyendo un carácter no imprimible, pero no (por defecto) con una nueva línea. Si la opción PCRE_DOTALL está establecida, entonces los puntos coinciden con nuevas líneas tambíen. El manejo del punto es totalmente independiente del manejo de circunflejo y dólar, la única relación existente es que ambos implican caracteres de nueva línea. El punto no tiene un significado especial en una clase carácter.

\C se puede usar para comparar un único byte. Tiene sentido en modo UTF-8 donde el punto coincide con el carácter entero, el cual puede consistir en múltiples bytes.


Clases carácter

Un corchete de apertura inicia una clase carácter, finalizada por un corchete de cierre. Un corchete de cierre por sí solo no es especial. Si se requiere un corchete de cierre como un miembro de la clase, éste debería ser el primer carácter de información en la clase (después de un circunflejo inicial, si está presente) o escapado con una barra invertida.

Una clase carácter coincide con un sólo carácter en el sujeto; el carácter debe estar en el conjunto de caracteres definido por la clase, a menos que el primer carácter en la clase sea un circunflejo, en cuyo caso el carácter sujeto no debe de estar en el conjunto definido por la clase. Si un circunflejo es requerido en realidad como un miembro de la clase, asegúrese de que no sea el primer carácter, o escápelo con una barra invertida.

Por ejemplo, la clase carácter [aeiou] coincide con cualquier vocal minúscula, mientras que [^aeiou] con cualquier carácter que no sea una vocal minúscula. Observe que un circunflejo es sólo una notación conveniente para especificar los caracteres que están en la clase enumerando los que no están. Si no es una declaración: aún consume un carácter de la cadena objetivo, y falla si el punto actual está al final de la cadena.

Cuando está establecida la coincidencia insensible a mayúsculas-minúculas, cualquier letra en una clase representa tanto su versión en mayúsculas como minusculas, así, por ejemplo, una clase insensible [aeiou] coincidice con "A" así como con "a", y una clase insensible [^aeiou] no coincide con "A", mientras que una versión sensible lo haría.

El carácter nueva línea nunca es tratado de manera especial en las clases carácter, sin importar el establecimiento de la opción PCRE_DOTALL o PCRE_MULTILINE. Una clase como [^a] siempre coincidirá con una nueva línea.

El carácter menos (guión) se puede usar para especificar un rango de caracteres en una clase carácter. Por ejemplo, [d-m] coincide con cualquier letra entre d y m, inclusive. Si un carácter - (menos) se requiere en una clase, se debe escapar con una barra invertida o aparecer en una posición donde no pueda ser interpretado como indicador de rango, típicamente como el primer o último carácter en una clase.

No es posible tener un carácter literal "]" como el carácter final de un rango. Un patrón como [W-]46] es interpretado como una clase de dos caracteres ("W" y "-") seguido de una cadena literal "46]", por lo que coincidiría con "W46]" o "-46]". Sin embargo, si el "]" es escapado con una barra invertida es interpretado como el final del rango, así [W-\]46] es interpretado como un clase individual que contiene un rango seguido de dos caracteres aparte. La representación octal o hexadecimal de "]" también se puede usar al final del rango.

Los rangos operan en la secuencia de colación de ASCII. También se pueden usar para caracteres especificados numéricamente, por ejemplo [\000-\037]. Si un rango que incluye letras se usa cuando se establece la coincidencia insensible a mayúsculas-minúsculas, coincide con las letras en cualquier caso. Por ejemplo, [W-c] es equivalente a [][\^_`wxyzabc], comparados insensiblemente, y si las tablas de caracteres para la configuración regional "fr" están siendo usadas, [\xc8-\xcb] coincide con caracteres E acentudos en ambos casos.

Los tipos de caracteres \d, \D, \s, \S, \w, y \W también pueden aparecer en la clase carácter, y añaden a la clase los caracteres que ellos representan. Por ejemplo, [\dABCDEF] coincide con cualquier dígito hexadecimal. Un circunflejo se puede usar convenientemente con los tipos de caracteres en mayúsculas para especificar un conjunto de caracteres más restrictivo que el tipo de coincidencia en minúscula. Por ejemplo, la clase [^\W_] coincide con cualquier letra o dígito, excepto con el subrayado.

Todos los caracteres no alfanuméricos distintos de \, -, ^ (al comienzo) y el ] finalizador no son especiales en una clase carácter, pero no es perjudicial si se escapan. El terminador de patrón siempre es especial y debe ser escapado cuando se usa dentro de una expresión.

Perl soporta la notación POSIX para clases carácter. Ésta usa nombres encerrados entre [: y :] dentro de los corchetes. PCRE también soporta esta notación. Por ejemplo, [01[:alpha:]%] coincide con "0", "1", cualquier carácter alfabético, o "%". Los nombres de las clases soportadas son:

Clases carácter
alnum | letras y dígitos
alpha | letras
ascii | códigos de caracteres 0 - 127
blank | espacio o tabulación solamente
cntrl | caracteres de control
digit | dígitos decimales (lo mismo que \d)
graph | caracteres imprimibles, excluyendo el espacio
lower | letras minúsculas
print | caracteres imprimibles, incluyendo el espacio
punct | caracterse imprimibles, excluyendo letras y dígitos
space | escpacio en blanco (casi lo mismo que \s)
upper | letras mayúsculas
word | caracteres "word" (palabra) (lo mismo que \w)
xdigit | dígitos hexadecimales
Los caracteres space son HT (9), LF (10), VT (11), FF (12), CR (13), y espacio (32). Observe que esta lista incluye el caracter VT (código 11). Esto hace que "space" sea diferente de \s, el cuál no incluye VT (por compatibilidad con Perl).

El nombre word es una extensión de Perl, y blank es una extensión de GNU desde Perl 5.8. Otra extensión de Perl es la negación, indicada por un carácter ^ después de los dos puntos. Por ejemplo, [12[:^digit:]] coincide con "1", "2", o cualquier no-digito.

En el modo UTF-8, los caracteres con valores mayores que 128 no coinciden con ninguna de las clases carácter POSIX. A partir de PHP 5.3.0 y libpcre 8.10 se han cambiado algunas características para utilizar propiedades de caracteres Unicode, en cuyo caso la restricción mencionada no se aplica. Consulte el » manual de PCRE(3) para más detalles.

Dentro de una clase de caracteres pueden aparecer propiedades de carácter de Unicode. No pueden ser parte de un rango. El carácter menos (-) después de una clase de caracteres de Unicode se comparará literalmente. Intentar finalizar un rango con una propiedad de carácter Unicode resultará en una advertencia.


Alternancia

Los caracteres barra vertical se usan para separar patrones alternativos. Por ejemplo, el patrón gilbert|sullivan coincide con "gilbert" o con "sullivan". Pueden aparecer cualquier número de alternativas, y se permite una alternativa vacía (coincidiendo con la cadena vacía). El proceso de comparación prueba cada alternativa sucesivamente, de izquierda a derecha, y la primera que tenga éxito se usa. Si las alternativas están dentro de un sub-patrón (definido más adelante), "tener éxito" significa coincidir con el resto del patrón principal así como con la alternativa en el sub-patrón.


Ajuste de opciones internas

Los ajustes de PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, PCRE_UNGREEDY, PCRE_EXTRA, PCRE_EXTENDED y PCRE_DUPNAMES se pueden cambiar desde dentro de un patrón por una secuencia de letras de opciones de Perl encerradas entre "(?" y ")". Las letras de opciones son:

Letras de opciones internas
i | para PCRE_CASELESS
m | para PCRE_MULTILINE
s | para PCRE_DOTALL
x | para PCRE_EXTENDED
U | para PCRE_UNGREEDY
X | para PCRE_EXTRA (ya no es compatible en PHP 7.3.0)
J | para PCRE_INFO_JCHANGED

Por ejemplo, (?im) establece la coincidencia insensible a mayúsculas-minúsculas, y multilínea. También es posible eliminar estas opciones precediendo la letra con un guión, y un establecimiento y eliminación combinados como (?im-sx), el cual establece PCRE_CASELESS y PCRE_MULTILINE mientras que elimina PCRE_DOTALL y PCRE_EXTENDED, también está permitido. Si una letra aparece tanto antes como después del guión, la opción es eliminada.

Cuando un cambio de opción sucede en el nivel superior (es decir, fuera de sub-patrones entre paréntesis), el cambio se aplica al resto del patrón que sigue. Así, /ab(?i)c/ coincide sólo con "abc" y "abC".

Si un cambio de opción sucede dentro de un sub-patrón, el efecto es diferente. Esto es un cambio de comportamiento en Perl 5.005. Un cambio de opción dentro de un sub-patrón afecta sólo a aquella parte del sub-patrón que le sigue, por lo que (a(?i)b)c coincide con abc y aBc y ninguna otra cadena más (asumiendo que no se usa PCRE_CASELESS). Por medio de esto, las opciones pueden ser producidas para tener diferentes ajustes en diferentes partes del patrón. Cualquier cambio hecho en un alternativa continúa en ramas subsiguientes dentro del mismo sub-patrón. Por ejemplo, (a(?i)b|c) coincide con "ab", "aB", "c", y "C", incluso cuando al coincidir con "C" la primera rama es abandonada después de establecer la opción. Esto es porque los efectos del establecimiento de opciones ocurren en tiempo de compilación. De otro modo habría algunos comportamiento extraños.

Las opciones específicas de PCRE PCRE_UNGREEDY y PCRE_EXTRA se pueden cambiar de la misma forma que las opciones compatibles con Perl usando los caracteres U y X respectivamente. La bandera de ajuste (?X) es especial ya que debe producirse siempre antes de que se active cualquier otra característica en el patrón, incluso si está en el nivel superior. Lo mejor es ponerlo al principio.


Sub-patrones

Los sub-patrones están delimitados por paréntesis, los cuales pueden estar anidados. Marcar parte de un patrón como un sub-patrón hace dos cosas:

  1. Localiza un conjunto de alternativas. Por ejemplo, el patrón cata(rata|pulta|) coincide con una de las palabras "cata", "catarata", o "catapulta". Sin los paréntesis, coincidiría con "catarata", "pulta" o la cadena vacía.

  2. Establece el sub-patrón como un sub-patrón de captura (como se definió antes). Cuando el patrón completo coincide, esa porción de la cadena objetivo que coincidió con el sub-patrón es devuelta la llamador mediante el argumento ovector de pcre_exec(). Los paréntesis de apertura se cuentan de izquierda a derecha (comenzando por 1) para obtener el número de los sub-patrones de captura.

Por ejemplo, si la cadena "el rojo amanecer" se compara con el patrón el ((rojo|oscuro) (amanecer|atarceder)) las cadenas capturadas son "rojo amanecer", "rojo", y "amanecer", y son numeradas como 1, 2, y 3.

El hecho de que los simples paréntesis lleven a cabo dos funciones no es siempre útil. Con frecuencia se presenta el caso en el que un sub-patrón de agrupamiento se requiere sin la necesidad de una captura. Si un paréntesis de apertura es seguido por "?:", el sub-patrón no realiza ninguna captura, y no es contado cuando se computa el número de cualquier sub-patrón de captura subsiguiente. Por ejemplo, si la cadena "el oscuro atardecer" se compara con el patrón the ((?:rojo|oscuro) (amanecer|atarceder)) las subcadenas capturadas son "oscuro atardecer" y "atarceder", y son numeradas como 1 y 2. El número máximo de subcadenas capturadas es de 65535. Sin embargo, podría no ser posible compilar patrones tan grandes, dependiendo de las opciones de configuración de libpcre.

Como abreviación conveniente, si se necesita cualquier establecimiento de opciones al inicio de un sub-patrón que no sea de captura, las letras de opciones pueden aparecen entre el "?" y ":". Así lo dos patrones

(?i(?i:lunes|martes)
(?:(?i)lunes|martes)

coinciden exactamente con el mismo conjunto de cadenas. Dado que las ramas alternativas son probadas de izquierda a derecha, y las opciones no se reinician hasta que se alcance el final del sub-patrón, el establecimiento de una opción en una rama afecta a las ramas siguientes, por lo que los patrones de arriba coinciden tanto con "MARTES" como con "Lunes".

Es posible nombrar un sub-patrón usando la sintaxis (?P<nombre>patrón). Este sub-patrón será entonces indexado en el array de coincidencias mediante su posición numérica normal y mediante su nombre también. PHP 5.2.2 introdujo dos sintaxis alternativas (?<nombre>patrón) y (?'nombre'patrón).

A veces es necesario tener múltiples coincidencias, pero alternando subgrupos en una expresión regular. Normalmente, a cada subgrupo se le asignaría su propio número de retroreferencia incluso si sólo uno de ellos coincidiera. Para superar esto, la sintaxis (?| permite tener números duplicados. Considere la siguiente expresión regular comparada con la cadena Sunday:

(?:(Sat)ur|(Sun))day

Aquí Sun se guarda en la retroreferencia 2, mientras que la retroreferencia 1 está vacía. La comparación cede Sat a la retroreferncia 1 mientras que la retroreferncia 2 no existe. Cambiar el patrón para usar (?| corrige este problema:

(?|(Sat)ur|(Sun))day

Al usar este patrón, tanto Sun como Sat serían almacenados en la retroreferencia 1.


Repetición

La repetición se especifica mediante cuantificadores, los cuales pueden ir detrás de cualquiera de los siguientes elementos:

  • un único carácter, posiblemente escapado
  • el metacarácter . (punto)
  • una clase carácter
  • una retroreferencia (véase la siguiente sección)
  • un sub-patrón entre paréntesis (a menos que haya una declaración - véase más adelante)

El cuantificador de repetición general especifíca un mínimo y un máximo del número de coincidencias pertmitidas, dándose los dos números entre llaves, separados por una coma. Los números deben ser menores que 65536, y el primero debe ser menor o igual que el segundo. Por ejemplo: z{2,4} coincide con "zz", "zzz", o "zzzz". Una llave de cierre por sí misma no es un carácter especial. Si se omite el segundo número, pero la coma está presente, no hay límite superior; si el segundo número y la coma se omiten, el cuantificador especifica un número exacto de coincidencias requeridas. Así [aeiou]{3,} coincide al menos con 3 vocales sucesivas, pero puede coincidir con muchas más, mientras que \d{8} coincide exactamente con 8 dígitos. Una llave que aparezca en una posición donde no se permite un cuantificador, o una que no coincida con la sintaxis de un cuantificador, se toma como un carácter literal. Por ejemplo, {,6} no es un cuantificador, sino una cadena literal de cuatro caracteres.

El cuantificador {0} está permitido, lo que provoca que la expresión se comporte como si el elemento anterior y el cuantificador no estuvieran presentes.

Por conveniencia (y compatibilidad histórica) los tres cuantificadores más comunes tiene como abreviatura un carácter simple:

Cuantificadores de carácter simple
* | equivale a {0,}
+ | equivale a {1,}
? | equivale a {0,1}

Es posible construir bucles infinitos mediante un sub-patrón que pueda no coincidir con caracteres, seguido de un cuantificador que no tenga límite superior, por ejemplo: (a?)*

Versiones anteriores de Perl y PCRE solían dar un error en tiempo de ejecución para tales patrones. Sin embargo, ya que hay casos donde esto puede ser útil, tales patrones se aceptan ahora, pero si cualquier repetición de un sub-patrón de hecho no coincide con caracteres, el bucle se abandona a la fuerza.

Por defecto, los cuantificadores son "codiciosos", es decir, comparan todo lo posible (hasta el número máximo de veces permitido), sin provocar que el resto del patrón falle. El ejemplo clásico de cómo esto da problemas es al intentar coincidir comentarios de programas en C. Éstos aparecen entre las secuencias /* y */ y dentro de la secuencia, pueden aparecer caracteres * y / individuales. Un intento de coincidir comentarios en C aplicando el patrón /\*.*\*/ a la cadena /* primer comentario */ no comentado /* segundo comentario */ falla, ya que coincide con la cadena completa debido a que el elemento .* es codicioso.

Sin embargo, si un cuantificador es seguido por un signo de interrogación, entonces se convierte en perezoso, coincidiendo el mínimo número de veces posible, así el patrón /\*.*?\*/ funciona de forma correcta con los comentarios en C. Por lo demás, el significado de los diferentes cuantificadores no varía, sólo el número de coincidencias preferidas. No confunda este uso del signo de interrogación con su uso como un cuantificador por derecho propio. Ya que tiene dos usos, puede aparecer a veces doble, como en \d??\d que coincide con un dígito preferentemente, pero puede coincidir con dos si esa es la única manera de que el resto del patrón coincida.

Si la opción PCRE_UNGREEDY se establece (una opción que no está disponible en Perl), los cuantificadores no son codiciosos por defecto, pero puede hecérselos codiciosos si les sigue un signo de interrogación. En otras palabras, invierte el comportamiento por defecto.

Los cuantificadores seguidos de + son "posesivos". Consumen tantos caracteres como les es posible y no retornan para coincidir con el resto del patrón. Así, .*abc coincide con "aabc" pero .*+abc no, ya que .*+ consume la cadena entera. Se pueden usar los cuantificadores posesivos para acelerar el procesamiento.

Cuando un sub-patrón entre paréntesis es cuantificado con un mínimo de cuenta de repeticiones que es mayor que 1 o con un máximo limitado, se necesita más capacidad de almacenamiento para el patrón compilado, en proporción al tamaño del mínimo o máximo.

Si un patrón comienza con .* o .{0,} y la opción PCRE_DOTALL (equivalente a la de Perl /s) está establecida, así permitiendo al . (punto) coincidir con nuevas líneas, entonces el patrón está implícitamente anclado, ya que cualquier cosa que haya a continuación se seguirá intentando comparar con cada posición de carácter en la cadena objetivo, por lo que no sirve de nada volver a intentar la comparación completa desde cualquier posición después de la primera. PCRE trata estos patrones como si estuvieran precedidos por \A. En los casos donde se sabe que la cadena objetivo no contiene nuevas líneas, vale la pena establecer PCRE_DOTALL cuando el patrón comienza con .* para obtener esta optimización, o alternativamente, usar ^ para indicar explícitamente el anclado.

Cuando se repite un sub-patrón de captura, el valor capturado es la subcadena que coincide con la iteración final. Por ejemplo, después de que (tweedle[dume]{3}\s*)+ se haya comparado con "tweedledum tweedledee" el valor del sub-patrón de captura es "tweedledee". Sin embargo, si hay sub-patrones de captura anidados, los valores capturados correspondientes pueden haber sido establecidos en iteraciones previas. Por ejemplo, después de que /(a|(b))+/ se compare con "aba", el valor del segundo sub-patrón de captura es "b".


Retroreferencias

Fuera de una clase carácter, una barra invertida seguida por un dígito mayor que 0 (y posiblemente más dígitos) es una retroreferencia a un sub-patrón de captura anterior (esto es a su izquierda) del patrón, siempre que hayan habido tantas capturas entre paréntesis previas a la izquierda.

Sin embargo, si el número decimal que sigue a la barra invertida es menor que 10, siempre es tomado como una retroreferencia, y produce un error sólo si no hay tantas capturas anteriores entre paréntesis en el patrón completo. En otras palabras, los paréntesis que son referenciados no necesitan estar a la izquierda de la referencia para números menores que 10. Una "retroreferencia hacia adelante" puede tener sentido cuando está involucrada una repetición y el sub-patrón de la derecha ha participado en una iteración anterior. Véase la sección anterior titulada "Barra invertida" para más detalles acerca del manejo de los dígitos que siguen a una barra invertida.

Una retroreferencia coincide con cualquier cosa que en realidad haya coincidido con el sub-patrón de captura en la cadena objetivo actual, más que con cualquier cosa que coincida en el sub-patrón mismo. Así, el patrón (abraz|apreci)o de un \1ador coindice con "abrazo de un abrazador" y con "aprecio de un apreciador", pero no con "abrazo de un apreciador". Si la coincidencia sensible a mayúsculas-minúsculas está en vigor en el momento de la retroreferencia, la distinción de letras es relevante. Por ejemplo, ((?i)bla)\s+\1 coincide con "bla bla" y "BLA BLA", pero no con "BLA bla", incluso si el patrón de captura original es comparado de forma insensible a mayúsculas-minúsculas.

Puede haber más de una retroreferencia hacia el mismo sub-patrón. Si un sub-patrón no ha sido usado en realidad en una coincidencia en particular, cualquier retroreferencia a él siempre falla. Por ejemplo, el patrón (a|(bc))\2 siempre falla si comienza coincidiendo con "a" en vez de con "bc". Ya que puede haber hasta 99 retroreferencias, todos los dígitos que siguen a la barra invertida se toman como parte de un número posible de retroreferencias. Si el patrón continúa con un carácter dígito, entonces se deben usar algunos delimitadores para finalizar la retroreferencia. Si la opción PCRE_EXTENDED está establecida, éste puede ser un espacio en blanco. De otra manera se puede usar un comentario vacío.

Una retroreferencia que sucede dentro de los paréntesis a los cuales se refiere, falla cuando el sub-patrón se usa primero, así, por ejemplo, (a\1) nunca coincide. Sin embargo, tales referencias pueden ser útiles dentro de sub-patrones repetidos. Por ejemplo, el patrón (a|b\1)+ coincide con cualquier número de "a"es y tambíen con "aba", "ababba", etc. En cada iteración del subpatrón, la retroreferencia coincide con el cadena correspondiente a la iteración anterior. Para que esto funcione, el patrón debe ser tal que la primera iteración no necesite coincidir con la retroreferencia. Esto se puede lograr usando alternancia, como en el ejemplo anterior, o mediante un cuantificador con un mínimo de cero.

A partir de PHP 5.2.2, la secuencia de escape \g se puede usar para referenciar subpatrones de forma absoluta y relativa. Esta secuencia de escape debe estar seguida por un número sin signo o un número negativo, opcionalmente encerrado entre llaves. Las secuencias \1, \g1 y \g{1} son sinónimas unas de otras. El uso de este patrón con un número sin signo puede ayudar a eliminar la ambigüedad inherente al usar dígitos seguidos de una barra invertida. La secuencia ayuda a distinguir retroreferencias de caracteres octales y también hace más fácil tener una retroreferencia seguida por un número literal, p.ej. \g{2}1.

El uso de la secuencia \g con un número negativo significa una referencia relativa. Por ejemplo, (foo)(bar)\g{-1} coincidiría con la secuencia "foobarbar" y (foo)(bar)\g{-2} coincidiría con "foobarfoo". Esto puede ser útil en patrones largos como una alternativa de seguir la pista del número de subpatrones para referenciar un subpatrón previo específico.

Las retroreferencias a sub-patrones nominados se pueden lograr mediante (?P=nombre) o, desde PHP 5.2.2, también mediante \k<nombre> o \k'nombre'. Además, PHP 5.2.4 añadió soporte para \k{nombre} y \g{nombre}, y PHP 5.2.7 para \g<name> y \g'name'.


Declaraciones

Una declaración es una comprobación de los caracteres siguientes o anteriores al punto de coincidencia actual que en realidad no consumen carácter alguno. Las declaraciones simples codificadas como \b, \B, \A, \Z, \z, ^ y $ están descritas en secuencias de escape. Las declaraciones más complicadas están codificadas como sub-patrones. Hay dos tipos: aquéllas que buscan hacia delante desde punto actual de la cadena objetivo, y aquéllas que buscan hacia atrás desde él.

Un patrón declaración es comparado de la forma habitual, excepto que no causa que la posición actual de coincidencia cambie. Las declaraciones de búsqueda hacia delante comienzan con (?= para declaraciones positivas y con (?! para declaraciones negativas. Por ejemplo, \w+(?=;) coincide con una palabra seguida de un punto y coma, pero no incluye el punto y coma en la coincidencia, y foo(?!bar) coincide con cualquier incidencia de "foo" que no esté seguida de "bar". Observe que el patrón aparentemente similar (?!foo)bar no encuentra una incidencia de "bar" que esté precedida por algo distinto de "foo"; no encuentra ninguna incidencia de "bar" en absoluto, ya que la declaración (?!foo) es siempre true cuando los tres caracteres siguientes son "bar". Se necesita una declaración de búsqueda hacia atrás para conseguir este efecto.

Las declaraciones de búsqueda hacia atrás comienzan con (?<= para declaraciones positivas y con (?<! para declaraciones negativas. Por ejemplo, (?<!foo)bar encuentra una incidencia de "bar" que no esté precedida por "foo". El contenido de una declaración de búsqueda hacia atrás está restringido de tal manera que todas las cadenas que se comparen con ella deben tener una longitud fija. Sin embargo, si hay varias alternativas, no es necesario que tengan todas la misma longitud fija. Así, (?<=buey|burro) está permitido, pero (?<!toros?|vacas?) produce un error en tiempo de compilación. Las ramas que se comparan con cadenas de diferente longitud están permitidas sólo en el nivel superior de una declaración de búsqueda hacia atrás. Esto es una extensión comparado con Perl 5.005, la cual requiere que todas las ramas a comparar tengan la misma longitud de cadena. Una declaración como (?<=ab(c|de)) no está permitida porque su rama del nivel superior puede coincidir con dos longitudes diferentes, pero es aceptable si se reescribe para usar dos ramas del nivel superior: (?<=abc|abde) La implementación de las declaraciones de búsqueda hacia atrás es, para cada alternativa, retroceder temporalmente la posición actual por el ancho fijo y después intentar coincidir. Si no hay suficientes caracteres antes de la posición actual, la comparación está condenada a fallar. Las declaraciones de búsqueda hacia atrás junto con los sub-patrones de una sóla aplicación pueden ser particularmente útiles para comparaciones con los finales de las cadenas; se da un ejemplo al final de la sección de sub-patrones de una sóla aplicación.

Varias declaraciones (de cualquier tipo) pueden producirse en suceción. Por ejemplo, (?<=\d{3})(?<!999)foo coincide con "foo" precedido de tres dígitos que no sean "999". Nótese que cada una de las declaraciones es aplicada en el mismo punto de la cadena objetivo. Primero, se verifica que los tres caracteres previos son todos dígitos, depués se verifica que esos mismos tres caracteres no sean "999". Este patrón no coincide con "foo" precedido de seis caracteres, los primeros de los cuales son dígitos y los tres últimos de éllos no son "999". Por ejemplo, no coincide con "123abcfoo". Un patrón que hace eso es (?<=\d{3}...)(?<!999)foo

Esta vez, la primera declaración examina los seis caracteres precedentes, verificando que los tres primeros son dígitos, y después, la segunda declaración verifica que los tres caracteres anteriores no son "999".

Las declaraciones pueden estar anidadas en cualquier combianción. Por ejemplo, (?<=(?<!foo)bar)baz coincide con una incidencia de "baz" que está precedida por "bar", la cual a su vez no está precedida por "foo", mientras que (?<=\d{3}...(?<!999))foo es otro patrón que coincide con "foo" precedido por tres dígitos y otros tres caracteres cualesquiera que no sean "999".

Los sub-patrones declarativos no son sub-patrones de captura, y no se pueden repetir, ya que no tiene sentido declarar la misma cosa varias veces. Si cualquier tipo de declaración contiene sub-patrones de captura dentro de ella, éstos son contados con el propósito de numerar los sub-patrones de captura en el patrón completo. Sin embargo, la captura de subcadenas se realiza sólo para declaraciones positivas, ya que no tiene sentido para declaraciones negativas.

Las declaraciones cuentan para el máximo de 200 sub-patrones entre paréntesis.


Sub-patrones de una sóla aplicación

Con las repeticiones maximizadoras y minimizadoras, el fallo de lo que se encuentra a continuación causa normalmente que la repetición del elemento sea re-evaluada para ver si un número diferente de repeticiones permite que el resto del patrón coincida. A veces es útil prevenir esto, tanto para cambiar la naturaleza de la comparación, como para ocasionar que falle antes (ya que de otra manera ocurriría el fallo después) cuando el autor del patrón sabe que no tiene sentido seguir.

Considere, por ejemplo, el patrón \d+foo cuando se aplica a la línea objetivo 123456bar

Después de coincidir los 6 dígitos y luego fallar al coincidir con "foo", la acción habitual del comparador es volver a intentarlo con sólo 5 dígitos, coincidiendo con el elemento \d+, y después con 4, y así sucesivamente, antes de que, por último, falle. Los sub-patrones de una sóla aplicación proporcionan el medio para especificar que una vez que una porción del patrón ha coincidido, no será re-evaluado de esta forma, por lo que el comparador se rendirá inmediatamente al fallar la comparación de "foo" la primera vez. La notación es otro tipo de paréntesis especiales, comenzando con (?> como en este ejemplo: (?>\d+)bar

Este tipo de paréntesis "bloquea" la parte del patrón que lo contiene una vez haya coincidido, y un fallo dentro del patrón evita que éste retroceda sobre sí mismo. El retroceso hacia elementos previos al sub-patrón funciona normalmente, después de todo.

Una descripción alternativa es que un sub-patrón de este tipo coincide con la cadena de caracteres que coincidiría con un patrón idéntico independiente, si está anclado en el punto actual de la cadena objetivo.

Los sub-patrones de una sóla aplicación no son sub-patrones de captura. Los casos sencillos como el anterior se pueden tomar como una repetición maximizadora que debe tragar todo lo que pueda. Así, mientras que \d+ y \d+? están preparados para adaptarse al número de dígitos que comparan para hacer que el resto del patrón coincida, (?>\d+) sólo puede conincidir una secuencia completa de dígitos.

Esta construcción puede, por supuesto, contener arbitrariamente sub-patrones complicados, y pueden estar anidados.

Los sub-patrones de una sóla aplicación se pueden usar junto con declaraciones de búsqueda hacia atrás para especificar una comparación eficiente al final de la cadena objetivo. Considere un simple patrón como abcd$ cuando se aplica a una cadena larga la cual no coincide. Ya que la comparación se lleva a cabo de izquierda a derecha, PCRE buscará cada "a" en el sujeto y después mirará si lo siguiente coincide con el resto del patrón. Si el patrón se especifica así ^.*abcd$ el .* inicial coincide con la cadena entera primero, pero cuando esto falla (debido a que no hay una "a" siguiente), retrocede para comparar todos los caracteres excepto el último, después todos excepto los dos últimos, y así sucesivamente. Una vez más la búsqueda de "a" cubre la cadena entera, de derecha a izquierda, por lo que no estamos en mejores circunstancias. Sin embargo, si el patrón se escribe así ^(?>.*)(?<=abcd) entonces no puede haber retroceso para el elemento .* ; sólo puede coincidir con la cadena entera. La subsiguiente declaración de búsqueda hacia atrás realiza una única comprobación sobre los últimos cuatro caracteres. Si falla, la comparación falla inmediatamente. Para cadenas largas, este enfoque produce una diferencia significativa en el tiempo de procesamiento.

Cuando un patrón contiene una repetición ilimitada dentro de un sub-patrón que puede repetirse un número ilimitado de veces, el uso de un sub-patrón de una sóla aplicación es la única manera de evitar que algunas comparaciones fallidas tomen mucho tiempo. El patrón (\D+|<\d+>)*[!?] compara un número ilimitado de subcadenas que consisten en algo que no sea un dígito, o dígitos encerrados entre <>, seguido de ! o ?. Cuando coincide, se ejecuta rápidamente. Sin embargo, si se aplica a aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa toma mucho tiempo antes de informar del fallo. Esto es porque la cadena puede ser dividida entre las dos repeticiones de muchas maneras, y todo tiene que ser probado. (En el ejemplo se usó [!?] en vez de un carácter único al final, ya que PCRE y Perl están optimizados de forma que permiten que se falle rápidamente cuando se usa un carácter único. Ambos recuerdan el último carácter único que se requiere para una coincidencia, y falla antes si no está presente en la cadena.) Si el patrón se cambia a ((?>\D+)|<\d+>)*[!?] las secuencias de los "no-dígitos" no pueden romperse, y el fallo ocurre rápidamente.


Sub-patrones condicionales

Es posible hacer que el proceso de comparación obedezca a un sub-patrón condicionalmente o que elija entre dos sub-patrones alternativos, dependiendo del resultado de una declaración o de si un sub-patrón de captura previo coincidió o no. Las dos formas posibles de un sub-patrón condicional son

(?(condición)patrón-sí)
(?(condición)patrón-sí|patrón-no)

Si la condición es satisfecha, se usa el patrón-sí; de otro modo se usa el patrón-no (si está presente). Si hay más de dos alternativas en el sub-patrón, se producirá un error en tiempo de compilación.

Hay dos tipos de condiciones. Si el texto entre los paréntesis consisite en una secuencia de dígitos, la condición es satisfecha si el sub-patrón de captura de ese número ha coincidido anteriormente. Considere el siguiente patrón, el cual contiene espacios en blanco no significativos para hacerlo más legible (se asume la opción PCRE_EXTENDED) y para dividirlo en tres partes para facilitar su análisis:

( \( )?    [^()]+    (?(1) \) )

La primera parte compara un paréntesis de apertura opcional, y si el carácter está presente, lo establece como la primera subcadena capturada. La segunda parte compara uno o más caracteres que no sean paréntesis. La tercera parte es un patrón condicional que examina el primer conjunto de paréntesis coincididos o no. Si lo fueron, es decir, si el sujeto comenzó con un paréntesis de apertura, la condición es true, y así el patrón-sí se ejecuta y es requerido un paréntesis de cierre. De otra manera, ya que el patrón-no no está presente, el subpatrón no coincidirá con nada. En otras palabras, este patrón coincide con una secuencia que no tenga paréntesis, opcionalmente encerrada entre paréntesis.

Si la condición es la cadena (R), se satisface si ha sido hecha una llamada recursiva al patrón o sub-patrón. En el "nivel superior", la condición es falsa.

Si la condición no es una secuencia de dígitos o (R), debe de ser una declaración. Ésta puede ser una declaración de búsqueda hacia delante o hacia atrás, negativa o positiva. Considere este patrón, conteniendo de nuevo espacios en blanco no significativos, y con dos alternativas en la segunda línea:

(?(?=[^a-z]*[a-z])
\d{2}-[a-z]{3}-\d{2}  |  \d{2}-\d{2}-\d{2} )

La condición es una declaración de búsqueda hacia delante positiva que compara una secuencia opcional de algo que no sean letras seguida de una letra. En otras palabras, comprueba la presencia de al menos una letra en el sujeto. Si se encuentra una letra, el sujeto se compara con la primera alternativa; de otro modo se compara con la segunda. Este patrón coincide con cadenas en una de las dos formas dd-aaa-dd o dd-dd-dd, donde aaa son letras y dd son dígitos.


Comentarios

La secuencia (?# marca el inicio de un comentario que continúa hasta el siguiente paréntesis de cierre. Los paréntesis anidados no están permitidos. Los caracteres que componen un comentario no toman parte a la hora de una comparación del patrón.

Si la opción PCRE_EXTENDED está establecida, un carácter # sin escapar fuera de una clase carácter inicia un comentario que continúa hasta el siguiente carácter de nueva línea del patrón.


Patrones recursivos

Considere el problema de comparar una cadena entre paréntesis, permitiendo paréntesis anidados ilimitados. Sin el uso de la recursividad, lo mejor que se puede hacer es usar un patrón que compare hasta alguna profundidad fija de anidamiento. No es posible manejar una profundidad de anidamiento arbitraria. Perl 5.6 ha proporcionado una herramienta experimental que permite a las expresiones regulares actuar recursivamente (entre otras cosas). El elemento especial (?R) es proporcionado para el caso específico de la recursividad. Este patrón de PCRE soluciona el problema de los paréntesis (se asume que la opción PCRE_EXTENDED está establecida por lo que los espacios en blanco se ignoran): \( ( (?>[^()]+) | (?R) )* \)

Primero se compara un paréntesis de apertura. Después compara cualquier número de subcadenas que pueden ser tanto una secuencia de algo que no sean paréntesis como una comparación recursiva del patrón mismo (esto es, una subcadena con los paréntesis correctos). Finalmente hay un paréntesis de cierre.

Este patrón de ejemplo en particular contiene repeticiones anidadas ilimitadas, y así, el uso de un sub-patrón de una sóla aplicación para comparar cadenas que no contengan paréntesis es importante cuando se aplica el patrón a cadenas que no coinciden. Por ejemplo, cuando se aplica a (aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa() produce "no hay conicidencias" rápidamente. Sin embargo, si no se usa un sub-patrón de una sóla aplicación, la comparación se ejecuta realmente durante mucho tiempo ya que hay muchas maneras diferentes de que las repeticiones + y * se puedan repartir el sujeto, y todas tienen que ser comprobadas antes de que se informe del fallo.

El conjunto de valores para cualquier sub-patrón de captura son aquellos del nivel último de la recursión en el cual el valor del sub-patrón es establecido. Si el patrón anterior se compara con (ab(cd)ef) el valor del paréntesis de captura es "ef", el cual es el último valor tomado en el nivel superior. Si se añaden paréntesis adicionales, dando lugar a \( ( ( (?>[^()]+) | (?R) )* ) \) entonces la cadena que capturan es "ab(cd)ef", el contenido de los paréntesis del nivel superior. Si hay más de 15 paréntesis de captura en un patrón, PCRE ha de obtener memoria extra para almacenar la información durante una recursión, lo cual hace usando pcre_malloc, liberándola mediante pcre_free después. Si no se puede obtener memoria, se guarda la información para los primeros 15 paréntesis de captura sólamente, ya que no hay manera de otorgar un error "out-of-memory" desde dentro de una recursión.

Se puede usar también (?1), (?2) y así sucesivamente, para los sub-patrones recursivos. Tamién es posible usar sub-patrones nominados: (?P>nombre) o (?&nombre).

Si la sintaxis para la referencia de un sub-patrón recursivo (tanto como número o como nombre) se usa fuera de los paréntesis a los que hace referencia, opera como una sub-rutina de un lenguaje de programación. Un ejemplo mostrado anteriormente, tal que el patrón (abraz|apreci)o de un \1ador coincide con "abrazo de un abrazador" y con "aprecio de un apreciador", pero no con "abrazo de un apreciador". Si en su lugar se usa (abraz|apreci)o de un (?1)ador, coincide con "abrazo de un apreciador" así como con las otras dos cadenas. Tales referencias deben, sin embargo, seguir al sub-patrón al que hacen referencia.

La longitud máxima de una cadena objetivo es el número positivo más grande que una variable tipo integer pueda tener. Sin embargo, PCRE usa la recursividad para tratar sub-patrones y repetición indefinida. Esto significa que el espacio de pila disponible puede limitar el tamaño de una cadena objetivo que puede ser procesada por ciertos patrones.


Rendimiento

Ciertos elementos que pueden aparecer en patrones son más eficientes que otros. Es más eficiente usar una clase carácter como [aeiou] en vez de un conjunto de alternativas como (a|e|i|o|u). En general, la construcción más simple que proporciona el comportamiento requerido es normalmente la más eficiente. El libro de Jeffrey Friedl contiene muchas discusiones sobre la optimización de expresiones regulares para un rendimiento eficiente.

Cuando un patrón comienza con .* y la opción PCRE_DOTALL está establecida, el patrón es anclado implícitamente por PCRE, ya que sólo puede coincidir con el inicio de una cadena objetivo. Sin embargo, si PCRE_DOTALL no está establecido, PCRE no puede realizar esta optimización, ya que el metacarácter . no coincide entonces con una nueva línea, y si la cadena objetivo contine nuevas líneas, el patrón puede coincidir con el carácter inmediatemente siguiente a ellas en vez de con el inicio absoluto. Por ejemplo, el patrón (.*) segundo coincide con el sujeto "primero\ny segundo" (donde \n significa un carácter de nueva línea), siendo "y" la primera subcadena capturada. Para llevar a cabo esto, PCRE ha de re-intentar la comparación comenzando después de cada nueva línea del sujeto.

Si está usando un patrón similar con cadenas objetivo que no contienen nuevas líneas, el mejor rendimiento se obtiene estableciendo PCRE_DOTALL, o comenzando el patrón con ^.* para indicar el anclado explícito. Esto salva a PCRE de tener que escanear el sujeto buscando una nueva línea desde donde reiniciar.

Tenga cuidado con los patrones que contienen repeticiones anidadas indefinidas. Éstos pueden tomar mucho tiempo al ejecutarse cuando se aplican a cadenas que no coinciden. Considere el fragmento de patrón (a+)*

Esto puede coincidir con "aaaa" de 33 maneras diferentes, y este número se incrementa muy rápidamente mientras la cadena se hace más larga. (La repetición * puede coincidir 0, 1, 2, 3, o 4 veces, y para cada uno de estos casos distintos de 0, las repeticiones de + pueden coincidir diferente número de veces.) Cuando el resto del patrón es tal que la comparación completa falla, PCRE tiene como principio el intentar cada posible variación, y esto puede tomar un tiempo extremadamente largo.

Una optimización toma algunos de los casos más simples como (a+)*b donde sigue un carácter literal. Antes de emprender el procedimiento de comparación estándar, PCRE verifica que hay una "b" posterior en la cadena objetivo, y si no la hay, falla la comparación inmediatamente. Sin embargo, cuando no hay un literal siguiente, no se puede usar esta optimización. Puede ver la diferencia comparando el comportamiento de (a+)*\d con el patrón anterior. El primero otorga un fallo casi instantáneamente cuando se aplica a una línea llena de caracteres "a", mientras que el segundo toma un tiempo apreciable con cadenas con más de de 20 caracteres.


Modificadores de patrones

Los modificadores PCRE disponibles son listados a continuación. Los nombres entre paréntesis se refieren a nombres internos de PCRE para dichos modificadores. Los espacios y nuevas líneas son ignorados en los modificadores, otros caracteres generan error.

i (PCRE_CASELESS)
Si se aplica este modificador, las letras en el patrón coincidirán tanto con letras mayúsculas como minúsculas.
m (PCRE_MULTILINE)
Por defecto, PCRE trata la cadena objetivo como si fuera una única "línea" de caracteres (incluso si en realidad contiene varias nuevas líneas). El meta-carácter "inicio de línea" (^) coincide sólo con el inicio de la cadena, mientras que el meta-carácter "final de línea" ($) coincide sólo con el final de la cadena, o antes del final de una nueva línea (a menos que el modificador D se aplique). Esto es igual que en Perl. Cuando se aplica este modificador, los constructores "inicio de línea" y "final de línea" coinciden inmediatamente después o inmediatamente antes que cualquier nueva línea de la cadena objetivo, respectivamente, así como al inicio y final absolutos. Esto es equivalente al modificador /m de Perl. Si no hay caracteres "\n" en una cadena objetivo, o no hay incidencias de ^ o $ en el patrón, la aplicación de este modificador no tiene efecto.
s (PCRE_DOTALL)
Si se aplica este modificador, un meta-carácter punto en el patrón coincide con todos los caracteres, incluyendo nuevas líneas. Sin él, las nuevas líneas son excluidas. Este modificador es equivalente al modificador /s de Perl. Una clase negativa como [^a] siempre coincidirá con un carácter de nueva línea, independientemente de la aplicación de este modificador.
x (PCRE_EXTENDED)
Si se aplica este modificador, los caracteres de información de espacios en blanco en el patrón se ignoran totalmente excepto cuando están escapados o dentro de una clase carácter, y los caracteres entre un # sin escapar fuera de una clase carácter y el siguiente carácter nueva línea, inclusive, también son ignorados. Esto es equivalente al modificador /x de Perl, y hace posible incluir comentarios dentro de patrones complicados. Observe, sin embargo, que esto se aplica sólo a caracteres de información. Los caracteres espacio en blanco nunca pueden aparecer dentro de secuencias de caracteres especiales en un patrón, por ejemplo dentro de la secuencia (?( la cual inicia un sub-patrón condicional.
e (PREG_REPLACE_EVAL)
Advertencia

Esta característica fue declarada OBSOLETA en PHP 5.5.0 y ELILMINADA a partir de PHP 7.0.0.

Si se aplica este modificador obsoleto, preg_replace() realiza las sustituciones normales de retro-referencias en la cadena a sustituir, la evalúa como código PHP, y usa el resultado para sustituir la cadena de búsqueda. Las comillas simples, comillas dobles, barras invertidas (\) y caracteres NULL serán escapados con barras invertidas en las retro-referencias sustituidas.
Precaución

La función addslashes() se ejecuta en cada retroreferencia que coincida antes de que se realice la sustitución. Por lo tanto, cuando la retroreferencia se usa como una cadena entrecomillada, los caracteres escapados serán convertidos a literales. Sin embargo, los caracteres que son escapados, los cuales normalmente no serían convertidos, mantendrán sus barras. Esto hace que el uso de este modificador sea muy complicado.

Precaución

Asegúrese de que replacement constituye una cadena de código PHP válida; de otro modo PHP responderá con un error de análisis en la línea que contiene preg_replace().

Precaución

El uso de este modificador está desaconsejado, ya que puede introducir fácilmente vulnerabilidades de seguridad:

<?php
$html = $_POST['html'];

// cabeceras en mayúsculas
$html = preg_replace(
    '(<h([1-6])>(.*?)</h\1>)e',
    '"<h$1>" . strtoupper("$2") . "</h$1>"',
    $html
);

En el código de ejemplo de arriba puede ser explotado fácilmente pasando una cadena de texto como <h1>{${eval($_GET[php_code])}}</h1>. Esto proporciona al atacante la capacidad de ejecutar código de PHP arbitrario y tener acceso casi completo al servidor.

Para evitar este tipo de vulnerabilidad de ejecución de código remoto, se debería usar la función preg_replace_callback() en su lugar:

<?php
$html = $_POST['html'];

// cabeceras en mayúsculas
$html = preg_replace_callback(
    '(<h([1-6])>(.*?)</h\1>)',
    function ($m) {
        return "<h$m[1]>" . strtoupper($m[2]) . "</h$m[1]>";
    },
    $html
);

Nota:

Sólamente preg_replace() utiliza este modificador; es ingnorado por otras funciones PCRE.

A (PCRE_ANCHORED)
Si se aplica este modificador, el patrón es forzado a ser "anclado", es decir, se le obliga a coincidir sólo con el inicio de la cadena que está siendo buscada (la "cadena objetivo"). Este efecto también se puede lograr mediante construcciones apropiadas en el patrón mismo, lo cual es la única manera de hacerlo en Perl.
D (PCRE_DOLLAR_ENDONLY)
Si se aplica este modificador, un meta-carácter dólar en el patrón coincidirá sólo con el final de la cadena objetivo. Sin este modificador, un dólar coincide también inmediatamente antes del carácter final si éste es una nueva línea (pero no antes de cualquier otra nueva línea). Este modificador es ignorado si el modificadr m se aplica. No existe equivalente a este modificador en Perl.
S
Cuando un patrón se va a usar varias veces, merece la pena dedicar más tiempo a analizarlo a fin de acelerar el tiempo tomado para las comparaciones. Si se aplica este modificador, se realiza este análisis extra. Actualmente, estudiar un patrón es útil sólamente para patrones no anclados que no tienen un carácter de inicio único fijo.
U (PCRE_UNGREEDY)
Este modificador invierte la "codicia" de los cuantificadores de modo que no sean codiciosos por defecto, pero se vuelven codiciosos si son seguidos por ?. Esto no es compatible con Perl. También se puede aplicar por un modificador de ajuste dentro del patrón (?U) o por un signo de interrogación detrás del cuantificador (p.ej. .*?).

Nota:

Normalmente no es posible hacer coincidir más de pcre.backtrack_limit caracteres en el modo no codicioso.

X (PCRE_EXTRA)
Este modificador pone en marcha funcionalidad adicional de PCRE que es incompatible con Perl. Cualquier barra invertida en un patrón que esté seguida por una letra que no tenga un significado especial causa un error, por lo que se reservan estas combinaciones para futuras expansiones. Por defecto, como en Perl, una barra invertida seguida de una letra que no tenga un significado especial se trata como un literal. No hay en la actualidad otras características controladas por este modificador.
J (PCRE_INFO_JCHANGED)
El ajuste de opción interna (?J) cambia la opción local PCRE_DUPNAMES. Permite nombres duplicados para sub-patrones.
u (PCRE_UTF8)
Este modificador pone en marcha funcionalidad adicional de PCRE que es incompatible con Perl. Los string de patrones y objetivos son tratados como UTF-8. Este modificador está disponible a partir de PHP 4.1.0 o posterior en Unix y desde PHP 4.2.3 en win32. La validez de UTF-8 del patrón y del objetivo es verificada desde PHP 4.3.5. Un objetivo inválido causará que la función preg_* no haga coincidir nada; un patrón inválido desencadenará un error de nivel E_WARNING. Las secuencias UTF-8 de cinco o seis octetos se consideran como no válidas desde PHP 5.3.4 (resp. PCRE 7.3 2007-08-28); anteriormente se consideraban como UTF-8 válido.


Diferencias con Perl

Las diferencias descritas aquí se refieren a las que hay con Perl 5.005.

  1. Por defecto, un carácter espacio en blanco es cualquier carácter que la función isspace() de la biblioteca C reconoce, aunque es posible compilar PCRE con tablas de tipo de caracteres alternativas. Normalmente isspace() coincide con un espacio, salto de página, nueva línea, retorno de carro, tabulador horizontal y tabulador vertical. Perl 5 ya no incluye el tabulador vertical en su juego caracteres de espacios en blanco. De hecho, el carácter de escape \v, el cual estuvo en la documentación de Perl durante mucho tiempo, nunca fue reconocido. Sin embargo, el carácter mismo fue tratado como espacio en blanco al menos hasta 5.002. En 5.004 y 5.005 no coincide con \s.
  2. PCRE no permite los cuantificadores de repetición en declaraciones de búsqueda hacia delante. Perl las permite, pero no significan lo que se puede estar pensando. Por ejemplo, (?!a){3} no afirma que los tres caracteres siguientes no son "a". Simplemente afirma que el siguiente carácter no es "a" tres veces.
  3. Los sub-patrones de captura que tienen lugar dentro de declaraciones de búsqueda hacia delante negativas se cuentan, pero sus entradas en los índices del vector nunca se establecen. Perl establece sus variables numéricas desde cualquiera de los patrones que han coincidido antes de que la declaración falle al coincidir con algo (de ese modo teniendo éxito), pero sólo si la declaración de búsqueda hacia delante negativa contiene sólo una rama.
  4. Aunque los caracteres cero binario están soportados en la cadena objetivo, no están permitidos en un patrón de cadena porque es pasado como una cadena C normal, finalizada por cero. La secuencia de escape "\x00" se puede usar para representar un cero binario en un patrón.
  5. Las siguientes secuencias de escape de Perl no estás soportadas: \l, \u, \L, \U. De hecho, éstas están implementadas por el manejo de cadenas general de Perl y no son parte de su motor de comparación de patrones.
  6. La declaración \G de Perl no está soportada y no es relevante para las comparaciones de patrones individuales.
  7. Obviamente, PCRE no soporta la construcción de (?{código}) y (??{código}). Sin embargo, tiene soporte para patrones recursivos.
  8. Hay, a la hora de escribir, algunas singularidades en Perl 5.005_02 concernientes con la configuración de las cadenas capturadas cuando una parte de un patrón se repite. Por ejemplo, al comparar "aba" con el patrón /^(a(b)?)+$/ establece $2 con el valor "b", pero al comparar "aabbaa" con /^(aa(bb)?)+$/ deja $2 sin establecer. Sin embargo, si el patrón se cambia a /^(aa(b(b))?)+$/ entonces $2 (y $3) se establecen. En Perl 5.004 $2 es establecido en ambos casos, y esto también es true en PCRE. Si en el futuro Perl cambia a un estado de consistencia que es diferente, PCRE puede cambiar para seguir su ejemplo.
  9. Una discrepancia todavía no resuelta es que en Perl 5.005_02 el patrón /^(a)?(?(1)a|b)+$/ coincide con la cadena "a", mientras que en PCRE no lo hace. Sin embargo, en Perl y en PCRE /^(a)?a/ coincide con "a" dejando $1 sin establecer.

  10. PCRE proporciona algunas extensiones para las herramientas de expresiones regulares de Perl:

    1. Aunque las declaraciones de búsqueda hacia atrás deben coincidir con cadenas de longitud fija, cada rama alternativa de una declaración de búsqueda hacia atrás puede coincidir con una longitud de cadena diferente. Perl 5.005 requiere que todas ellas tengan la misma longitud.
    2. Si se aplica PCRE_DOLLAR_ENDONLY y no se aplica PCRE_MULTILINE, el meta-carácter $ coincide sólo con el final absoluto de la cadena.
    3. Si se aplica PCRE_EXTRA, una barra invertida seguida de una letra sin ningún significado especial fallará.
    4. Si se aplica PCRE_UNGREEDY, la codicia de los cuantificadores de repetición se invierte, es decir, por defecto dejan de ser codiciosos, pero si son seguidos por un signo de interrogación lo serán.


Diferencias con las expresiones regulares POSIX

A partir de PHP 5.3.0, la extensión Expresiones Regulares POSIX está obsoleta. Hay varias diferencias entre las expresiones regulares POSIX y las expresiones regulares de PCRE. Esta página lista las más notables que son necesarias conocer cuando se convierten a PCRE.

  1. Las funciones de PCRE requieren que el patrón esté encerrado por delimitadores.
  2. A diferencia de POSIX, la extensión PCRE no tiene funciones dedicadas para comparación insensible a mayúsculas-minúsculas. En su lugar, esto está soportado por el uso del i (PCRE_CASELESS) modificador de patrón. También están disponibles otros modificadores de patrón para cambiar la estrategia de comparación.
  3. Las funciones POSIX buscan la más larga de las coincidencias del extremo izquierdo, pero PCRE se detiene en la primera coincidencia válida. Si la cadena no coincide en absoluto no hay diferencia, pero si coincide puede tener efectos dramáticos sobre la coincidencia resultante y la velocidad de comparación. Para ilustrar esta diferencia considere el siguiente ejemplo de "Mastering Regular Expressions" por Jeffrey Friedl. Usar el patrón one(self)?(selfsufficient)? sobre la cadena oneselfsufficient con PCRE resultará en la coincidencia de oneself, pero usando POSIX el resultado será la cadena completa oneselfsufficient. Ambas (sub)cadenas coinciden con la cadena origianl, pero POSIX requiere que la más larga sea el resultado.
  4. La definición de POSIX de una "clase carácter" difiere de la de PCRE. Las expresiones simples entre corchetes para comparar un conjunto de caracters explícito está soportado en la forma de clases carácter de PCRE, pero los elementos de cotejamiento, las clases carácter, y las equivalencias de caracters de POSIX no están soportadas. Proporcionar a PCRE una expresión con una clase carácter que empiece y finalice con los caracters :, . o = se interpreta como un intento de usar una de las características no soportadas, y causará un error de compilación.

Sustituciones de funciones
POSIX | PCRE
ereg_replace() | preg_replace()
ereg() | preg_match()
eregi_replace() | preg_replace()
eregi() | preg_match()
split() | preg_split()
spliti() | preg_split()
sql_regcase() | No hay equivalente


Funciones de PCRE

Tabla de contenidos

  • preg_filter — Realiza una búsqueda y sustitución de una expresión regular
  • preg_grep — Devuelve entradas de matriz que coinciden con el patrón
  • preg_last_error_msg — Returns the error message of the last PCRE regex execution
  • preg_last_error — Devuelve el código de error de la última ejecución de expresión regular de PCRE
  • preg_match_all — Realiza una comparación global de una expresión regular
  • preg_match — Realiza una comparación con una expresión regular
  • preg_quote — Escapar caracteres en una expresión regular
  • preg_replace_callback_array — Realizar una búsqueda y sustitución de expresión regular con retrollamadas
  • preg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
  • preg_replace — Realiza una búsqueda y sustitución de una expresión regular
  • preg_split — Divide un string mediante una expresión regular


Realiza una búsqueda y sustitución de una expresión regular

  • « Funciones de PCRE
  • preg_grep »
  • PHP Manual
  • Funciones de PCRE
  • Realiza una búsqueda y sustitución de una expresión regular

preg_filter

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

preg_filter — Realiza una búsqueda y sustitución de una expresión regular

Descripción

preg_filter ( mixed $pattern , mixed $replacement , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

preg_filter() es idéntica a preg_replace() excepto que sólo devuelve los sujetos (posiblemente tranformados) donde hubo una coincidencia. Los detalles de cómo trabaja esta función se encuentra en la documentación de preg_replace().

Valores devueltos

Devuelve un array si el parámetro subject es un array, de lo contrario devuelve un string.

Si no se encontraron coincidencias u ocurrió un error, se devuelve un array vacío cuando subject es un array o null de otro modo.

Ejemplos

Ejemplo #1 Ejemplo comparando preg_filter() con preg_replace()

<?php
$sujeto = array('1', 'a', '2', 'b', '3', 'A', 'B', '4');
$patrón = array('/\d/', '/[a-z]/', '/[1a]/');
$sustitución = array('A:$0', 'B:$0', 'C:$0');

echo "preg_filter devuelve\n";
print_r(preg_filter($patrón, $sustitución, $sujeto));

echo "preg_replace devuelve\n";
print_r(preg_replace($patrón, $sustitución, $sujeto));
?>

El resultado del ejemplo sería:

preg_filter devuelve
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [7] => A:4
)
preg_replace devuelve
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [5] => A
    [6] => B
    [7] => A:4
)

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_replace_callback() - Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
  • preg_grep() - Devuelve entradas de matriz que coinciden con el patrón
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Devuelve entradas de matriz que coinciden con el patrón

  • « preg_filter
  • preg_last_error_msg »
  • PHP Manual
  • Funciones de PCRE
  • Devuelve entradas de matriz que coinciden con el patrón

preg_grep

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_grep — Devuelve entradas de matriz que coinciden con el patrón

Descripción

preg_grep ( string $pattern , array $input , int $flags = 0 ) : array

Devuelve la matriz consistente en los elementos de la matriz input que coinciden con pattern.

Parámetros

pattern

El patrón de búsqueda, como cadena.

input

La matriz de entrada.

flags

Si se establece a PREG_GREP_INVERT, esta función devuelve los elementos de la matriz de entrada que no coinciden con pattern.

Valores devueltos

Devuelve una matriz indexada usando las claves de la matriz input.

Ejemplos

Ejemplo #1 Ejemplo de preg_grep()

<?php
// devuelve todos los elementos de la matriz
// que contienen números de coma (punto) flotante
$matriz_fl = preg_grep("/^(\d+)?\.\d+$/", $matriz);
?>

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_match_all() - Realiza una comparación global de una expresión regular
  • preg_filter() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Returns the error message of the last PCRE regex execution

  • « preg_grep
  • preg_last_error »
  • PHP Manual
  • Funciones de PCRE
  • Returns the error message of the last PCRE regex execution

preg_last_error_msg

(PHP 8)

preg_last_error_msg — Returns the error message of the last PCRE regex execution

Descripción

preg_last_error_msg ( ) : string

Returns the error message of the last PCRE regex execution.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the error message on success, or "No error" if no error has occurred.

Ejemplos

Ejemplo #1 preg_last_error_msg() example

<?php

preg_match('/(?:\D+|<\d+>)*[!?]/', 'foobar foobar foobar');

if (preg_last_error() !== PREG_NO_ERROR) {
    echo preg_last_error_msg();
}

?>

El resultado del ejemplo sería:

Backtrack limit exhausted

Ver también

  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Devuelve el código de error de la última ejecución de expresión regular de PCRE

  • « preg_last_error_msg
  • preg_match_all »
  • PHP Manual
  • Funciones de PCRE
  • Devuelve el código de error de la última ejecución de expresión regular de PCRE

preg_last_error

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

preg_last_error — Devuelve el código de error de la última ejecución de expresión regular de PCRE

Descripción

preg_last_error ( ) : int

Devuelve el código de error de la última ejecución de expresión regular de PCRE.

Ejemplo #1 Ejemplo de preg_last_error()

<?php

preg_match('/(?:\D+|<\d+>)*[!?]/', 'foobar foobar foobar');

if (preg_last_error() == PREG_BACKTRACK_LIMIT_ERROR) {
    print '¡El límite de marcha atrás se agotó!';
}

?>

El resultado del ejemplo sería:

¡El límite de marcha atrás se agotó!

Valores devueltos

Devuelve una de las siguientes constantes (explicadas en su propia página):

  • PREG_NO_ERROR
  • PREG_INTERNAL_ERROR
  • PREG_BACKTRACK_LIMIT_ERROR (vea también pcre.backtrack_limit)
  • PREG_RECURSION_LIMIT_ERROR (vea también pcre.recursion_limit)
  • PREG_BAD_UTF8_ERROR
  • PREG_BAD_UTF8_OFFSET_ERROR (desde PHP 5.3.0)
  • PREG_JIT_STACKLIMIT_ERROR (since PHP 7.0.0)


Realiza una comparación global de una expresión regular

  • « preg_last_error
  • preg_match »
  • PHP Manual
  • Funciones de PCRE
  • Realiza una comparación global de una expresión regular

preg_match_all

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_match_all — Realiza una comparación global de una expresión regular

Descripción

preg_match_all ( string $pattern , string $subject , array &$matches = ? , int $flags = PREG_PATTERN_ORDER , int $offset = 0 ) : int

Busca en subject todas las coincidencias de la expresión regular dada en pattern y las introduce en matches en el orden especificado por flags.

Después haber encontrado la primera coincidencia, las búsquedas subsiguientes continuarán desde el final de la dicha coincidencia.

Parámetros

pattern

El patrón de búsqueda, dado como string.

subject

La cadena de entrada.

matches

Un array con todas las coincidencias en un array multi-dimensional ordenadas según flags.

flags

Puede ser una combinación de las siguientes banderas (observe que no tiene sentido usar PREG_PATTERN_ORDER junto con PREG_SET_ORDER):

PREG_PATTERN_ORDER

Ordena los resultados de forma que $matches[0] es un array de coincidencias del patrón completo, $matches[1] es un array de cadenas coincidentes por el primer subpatrón entre paréntesis, y así sucesivamente.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>ejemplo: </b><div align=left>esto es una prueba</div>",
    $salida, PREG_PATTERN_ORDER);
echo $salida[0][0] . ", " . $salida[0][1] . "\n";
echo $salida[1][0] . ", " . $salida[1][1] . "\n";
?>

El resultado del ejemplo sería:

<b>ejemplo: </b>, <div align=left>esto es una prueba</div>
ejemplo: , esto es una prueba

Así, $salida[0] contiene un array de cadenas que coinciden con el patrón completo, y $salida[1] contiene un array de cadenas encerradas entre etiquetas.

Si el patrón contiene subpatrones con nombre, $matches contendrá además entradas para claves con el nombre del subpatrón.

Si el subpatrón contiene subpatrones con nombres duplicados, solamente se almacenará en $matches[NAME] el último subpatrón de la derecha.

<?php
preg_match_all(
    '/(?J)(?<match>foo)|(?<match>bar)/',
    'foo bar',
    $matches,
    PREG_PATTERN_ORDER
);
print_r($matches['match']);
?>

El resultado del ejemplo sería:

Array
(
    [0] =>
    [1] => bar
)

PREG_SET_ORDER

Ordena los resultados de forma que $matches[0] es un array del primer conjunto de coincidencias, $matches[1] es un array del segundo conjunto de coincidencias, y así sucesivamente.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>ejemplo: </b><div align=\"left\">esto es una prueba</div>",
    $salida, PREG_SET_ORDER);
echo $salida[0][0] . ", " . $salida[0][1] . "\n";
echo $salida[1][0] . ", " . $salida[1][1] . "\n";
?>

El resultado del ejemplo sería:

<b>ejemplo: </b>, ejemplo:
<div align="left">esto es una prueba</div>, esto es una prueba

PREG_OFFSET_CAPTURE

Si se pasa esta bandera, por cada coincidencia producida, el índice de la cadena añadida también será devuelto. Observe que esto cambia el valor de matches dentro de un array de arrays donde cada elemento es un array consistente en la cadena coincidente en el índice 0 y su índice de cadena dentro de subject en el índice 1.

<?php
preg_match_all('/(foo)(bar)(baz)/', 'foobarbaz', $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => Array
                (
                    [0] => foobarbaz
                    [1] => 0
                )

        )

    [1] => Array
        (
            [0] => Array
                (
                    [0] => foo
                    [1] => 0
                )

        )

    [2] => Array
        (
            [0] => Array
                (
                    [0] => bar
                    [1] => 3
                )

        )

    [3] => Array
        (
            [0] => Array
                (
                    [0] => baz
                    [1] => 6
                )

        )

)

Si no se da un orden de bandera, se asume PREG_PATTERN_ORDER.

offset

Normalmente, la búsqueda comienza por el principio de la cadena objetivo. El parámetro opcional offset se puede usar para especificar el lugar alternativo desde el cual comenzar la búsqueda (en bytes).

Nota:

Usar offset no es equivalente a pasar substr($sujeto, $índice) a preg_match() en lugar de la cadena objetivo, ya que pattern puede contener declaraciones como ^, $ o (?<=x). Véase preg_match() para los ejemplos.

Valores devueltos

Devuelve el número de coincidencias del patrón completo (el cual puede ser cero), o false si se produjo un error.

Historial de cambios

Versión | Descripción
5.4.0 | El parámetro matches ahora es opcional.
5.3.6 | Devuelve false si offset es mayor que la longitud de subject.
5.2.2 | Los sub-patrones nominados ahora aceptan la sintaxis (?<nombre>) y (?'nombre') así como (?P<nombre>). Versiones anteriores sólo aceptaban (?P<nombre>).

Ejemplos

Ejemplo #1 Obtener todos los números de teléfono de algún texto.

<?php
preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
                "Llame al 555-1212 o al 1-800-555-1212", $teléfonos);
?>

Ejemplo #2 Buscar coincidencias de etiquetas HTML (codicioso)

<?php
// El \\2 es un ejemplo de retro-referencia. Esto le dice a pcre que
// debe coincidir el segundo conjunto de paréntesis en la expresión regular
// misma, el cual sería el ([\w]+) en este caso. La barra invertida extra es
// necesaria ya que la cadena está entre comilla dobles.
$html = "<b>texto en negrita</b><a href=hola.html>Haz clic sobre mí</a>";

preg_match_all("/(<([\w]+)[^>]*>)(.*?)(<\/\\2>)/", $html, $coincidencias, PREG_SET_ORDER);

foreach ($coincidencias as $valor) {
    echo "coindicido: " . $valor[0] . "\n";
    echo "parte 1: " . $valor[1] . "\n";
    echo "parte 2: " . $valor[2] . "\n";
    echo "parte 3: " . $valor[3] . "\n";
    echo "parte 4: " . $valor[4] . "\n\n";
}
?>

El resultado del ejemplo sería:

coindicido: <b>texto en negrita</b>
parte 1: <b>
parte 2: b
parte 3: texto en negrita
parte 4: </b>

coindicido: <a href=hola.html>Haz clic sobre mí</a>
parte 1: <a href=hola.html>
parte 2: a
parte 3: Haz clic sobre mí
parte 4: </a>

Ejemplo #3 Usar sub-patrones nominados

<?php

$cadena = <<<FOO
a: 1
b: 2
c: 3
FOO;

preg_match_all('/(?P<nombre>\w+): (?P<dígito>\d+)/', $cadena, $coincidencias);

/* Esto también funciona en PHP 5.2.2 (PCRE 7.0) y posteriores, sin embargo
 * la forma de arriba es la recomendada por compatibilidad con versiones anteriores */
// preg_match_all('/(?<nombre>\w+): (?<dígito>\d+)/', $cadena, $coincidencias);

print_r($coincidencias);

?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => a: 1
            [1] => b: 2
            [2] => c: 3
        )

    [nombre] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [1] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [dígito] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

    [2] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

)

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_match() - Realiza una comparación con una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_split() - Divide un string mediante una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Realiza una comparación con una expresión regular

  • « preg_match_all
  • preg_quote »
  • PHP Manual
  • Funciones de PCRE
  • Realiza una comparación con una expresión regular

preg_match

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_match — Realiza una comparación con una expresión regular

Descripción

preg_match ( string $pattern , string $subject , array &$matches = ? , int $flags = 0 , int $offset = 0 ) : int

Busca en subject una coincidencia con la expresión regular dada en pattern.

Parámetros

pattern

El patrón de búsqueda, como cadena.

subject

La cadena de entrada.

matches

Si se proporciona matches, entonces éste se llena con los resultados de la búsqueda. $matches[0] contendrá el texto que coincidió con el patrón completo, $matches[1] tendrá el texto que coincidió con el primer sub-patrón entre paréntesis capturado, y así sucesivamente.

flags

flags puede estar seguido de la siguiente bandera:

PREG_OFFSET_CAPTURE

Si se pasa esta bandera, por cada coincidencia producida, el índice de la cadena añadida también será devuelto. Observe que esto cambia el valor de matches dentro de una matriz donde cada elemento es una matriz consistente en la cadena coincidente en el índice 0 y su índice dentro de la cadena subject en el índice 1.

<?php
preg_match('/(foo)(bar)(baz)/', 'foobarbaz', $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => foobarbaz
            [1] => 0
        )

    [1] => Array
        (
            [0] => foo
            [1] => 0
        )

    [2] => Array
        (
            [0] => bar
            [1] => 3
        )

    [3] => Array
        (
            [0] => baz
            [1] => 6
        )

)

offset

Normalmente, la búsqueda comienza por el principio de la cadena objetivo. El parámetro opcional offset se puede usar para especificar el lugar alternativo desde el cual comenzar la búsqueda (en bytes).

Nota:

Usar offset no es equivalente a pasar substr($sujeto, $índice) a preg_match() en lugar de la cadena objetivo, ya que pattern puede contener declaraciones como ^, $ o (?<=x). Compare:

<?php
$sujeto = "abcdef";
$patrón = '/^def/';
preg_match($patrón, $sujeto, $coincidencias, PREG_OFFSET_CAPTURE, 3);
print_r($coincidencias);
?>

El resultado del ejemplo sería:

Array
(
)

mientras que este ejemplo

<?php
$sujeto = "abcdef";
$patrón = '/^def/';
preg_match($patrón, substr($sujeto,3), $coincidencias, PREG_OFFSET_CAPTURE);
print_r($coincidencias);
?>

producirá

Array
(
    [0] => Array
        (
            [0] => def
            [1] => 0
        )

)

Valores devueltos

preg_match() devuelve 1 si pattern coincide con el subject dado, 0 si no, o false si ocurrió un error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
5.3.6 | Devuelve false si offset es mayor que la longitud de subject.
5.2.2 | Los sub-patrones nominados ahora aceptan la sintaxis (?<nombre>) y (?'nombre') así como (?P<nombre>). Las versiones anteriores sólo aceptaban (?P<nombre>).

Ejemplos

Ejemplo #1 Busca la cadena de texto "php"

<?php
// La "i" después del delimitador de patrón indica una búsqueda
// sin tener en cuenta mayúsculas/minúsculas
if (preg_match("/php/i", "PHP es el lenguaje de secuencias de comandos web preferido.")) {
    echo "Se encontró una coincidencia.";
} else {
    echo "No se encontró ninguna coincidencia.";
}
?>

Ejemplo #2 Busca la palabra "web"

<?php
/* El \b en el patrón indica un límite de palabra, por lo que sólo la palabra
 * definida "web" se compara, y no una palabra parcial como "webbing" o "cobweb" */
if (preg_match("/\bweb\b/i", "PHP es el lenguaje de secuencias de comandos web preferido.")) {
    echo "Se encontró una coincidencia.";
} else {
    echo "No se encontró ninguna coincidencia.";
}

if (preg_match("/\bweb\b/i", "PHP es el lenguaje de secuencias de comandos website preferido.")) {
    echo "Se encontró una coincidencia.";
} else {
    echo "No se encontró ninguna coincidencia.";
}
?>

Ejemplo #3 Obtener el nombre de dominio de una URL

<?php
// obtiene el nombre del host de la URL
preg_match('@^(?:http://)?([^/]+)@i',
    "http://www.php.net/index.html", $coincidencias);
$host = $coincidencias[1];

// obtiene los dos últimos segmentos del nombre del host
preg_match('/[^.]+\.[^.]+$/', $host, $coincidencias);
echo "El nombre de dominio es: {$coincidencias[0]}\n";
?>

El resultado del ejemplo sería:

El nombre de dominio es: php.net

Ejemplo #4 Usar sub-patrones nominados

<?php

$cadena = 'foobar: 2008';

preg_match_all('/(?P<nombre>\w+): (?P<dígito>\d+)/', $cadena, $coincidencias);

/* Esto también funciona en PHP 5.2.2 (PCRE 7.0) y posteriores, sin embargo
 * la forma de arriba es la recomendada por compatibilidad con versiones anteriores */
// preg_match_all('/(?<nombre>\w+): (?<dígito>\d+)/', $cadena, $coincidencias);

print_r($coincidencias);

?>

El resultado del ejemplo sería:

Array
(
    [0] => foobar: 2008
    [name] => foobar
    [1] => foobar
    [digit] => 2008
    [2] => 2008
)

Notas

Sugerencia

No use preg_match() si solo quiere comprobar si una cadena está contenida en otra cadena. Use strpos() en su lugar ya que será más rápida.

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_match_all() - Realiza una comparación global de una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_split() - Divide un string mediante una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Escapar caracteres en una expresión regular

  • « preg_match
  • preg_replace_callback_array »
  • PHP Manual
  • Funciones de PCRE
  • Escapar caracteres en una expresión regular

preg_quote

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_quote — Escapar caracteres en una expresión regular

Descripción

preg_quote ( string $str , string $delimiter = null ) : string

preg_quote() toma string y pone una barra invertida delante de cada carácter que es parte de la sintaxis de la expresión regular. Esto es útil si tiene una cadena en tiempo de ejecución que necesite comparar con algún texto, y la cadena pueda contener caracteres de expresiones regulares especiales.

Los caracteres de expresiones regulares especiales son: . \ + * ? [ ^ ] $ ( ) { } = ! < > | : -

Observe que / no es un carácter especial de expresión regular.

Nota:

Observe que preg_quote() no está pensada para que sea apliaca a los strings de preg_replace() etc.

Parámetros

string

La cadena de entrada.

delimiter

Si se especifica el parámetro opcional delimiter, éste también será escapado. Esto es útil para escapar el delimitador que es necesario para las funciones PCRE. El delimitador /es el que se usa comúnmente.

Valores devueltos

Devuelve el string entrecomillado (escapado).

Historial de cambios

Versión | Descripción
5.3.0 | El carácter - ahora es escapado

Ejemplos

Ejemplo #1 Ejemplo de preg_quote()

<?php
$claves = '$40 por un a g3/400';
$claves = preg_quote($claves, '/');
echo $claves; // devuelve \$40 por un g3\/400
?>

Ejemplo #2 Poner en cursiva una palabra dentro de un texto

<?php
// En este ejemplo, preg_quote($palabra) se usa para que los
// asteriscos sigan teniendo un significado especial en la
// expresión regular.

$texto = "Este libro es *muy* difícil de encontrar.";
$palabra = "*muy*";
$texto = preg_replace ("/" . preg_quote($palabra, '/') . "/",
                       "<i>" . $palabra . "</i>",
                       $texto);
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • Patrones de PCRE
  • escapeshellcmd() - Escapar meta-caracteres del intérprete de comandos


Realizar una búsqueda y sustitución de expresión regular con retrollamadas

  • « preg_quote
  • preg_replace_callback »
  • PHP Manual
  • Funciones de PCRE
  • Realizar una búsqueda y sustitución de expresión regular con retrollamadas

preg_replace_callback_array

(PHP 7, PHP 8)

preg_replace_callback_array — Realizar una búsqueda y sustitución de expresión regular con retrollamadas

Descripción

preg_replace_callback_array ( array $patterns_and_callbacks , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

El comportamiento de esta función es similar a la de preg_replace_callback(), excepto que las retrollamadas se ejecutan en función de cada patrón.

Parámetros

patterns_and_callbacks

Un array asociativo con correspondencias entre patrones (claves) y retrollamadas (valores).

subject

El sujeto. Un string o array con varios strings para la búsqueda y sustitución.

limit

Las sustituciones máximas posibles para cada patrón en cada string de subject. Su valor predeterminado es de -1 (sin límite).

count

La cuenta. Si se especifica, esta variable contrendrá el número de sustituciones hechas.

Valores devueltos

preg_replace_callback_array() devuelve un array si el parámetro subject es un array, o un string en caso contrario. En caso de error devuelve null

Si se encuentran coincidencias, será devuelto el nuevo sujeto; si no, subject será devuelto sin cambios.

Ejemplos

Ejemplo #1 Ejemplo de preg_replace_callback_array()

<?php
$subject = 'Aaaaaa Bbb';

preg_replace_callback_array(
    [
        '~[a]+~i' => function ($match) {
            echo strlen($match[0]), ' coincidencias de "a" encontradas', PHP_EOL;
        },
        '~[b]+~i' => function ($match) {
            echo strlen($match[0]), ' coincidencias de "b" encontradas', PHP_EOL;
        }
    ],
    $subject
);
?>

El resultado del ejemplo sería:

6 coincidencias de "a" encontradas
3 coincidencias de "b" encontradas

Ver también

  • Patrones de PCRE
  • preg_replace_callback() - Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE
  • Funciones anónimas


Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno

  • « preg_replace_callback_array
  • preg_replace »
  • PHP Manual
  • Funciones de PCRE
  • Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno

preg_replace_callback

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

preg_replace_callback — Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno

Descripción

preg_replace_callback ( mixed $pattern , callable $callback , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

El comportamiento de esta función es casi idéntico al de preg_replace(), excepto por el hecho de que en vez del parámetro replacement, se debería especificar callback.

Parámetros

pattern

El patron de búsqueda. Puede ser tanto un cadena como un array de cadenas.

callback

Una llamada de retorno que será llamada y pasada a un array de elementos coincidentes en la cadena subject. La llamada de retorno debería devolver la cadena de sustitución. Esta es la firma de la llamada de retorno:

handler ( array $matches ) : string

A menudo se necesitará la función de callback para usar preg_replace_callback() únicamente en un lugar. En este caso se puede usar una función anónima para declarar una llamada de retorno dentro de la llamada a preg_replace_callback(). Al hacerlo de este modo, se tiene toda la información de la llamada en un único lugar y no abarrota el espacio de nombres de funciones con un nombre de función de llamada de retorno que no se usa en ningún otro sitio.

Ejemplo #1 preg_replace_callback() y función anónima

<?php
/* un filtro de línea de comandos estilo unix para convertir letras
 * mayúsculas a minúsculas al principio de párrafos */
$fp = fopen("php://stdin", "r") or die("no se puede leer stdin");
while (!feof($fp)) {
    $línea = fgets($fp);
    $línea = preg_replace_callback(
        '|<p>\s*\w|',
        function ($coincidencias) {
            return strtolower($coincidencias[0]);
        },
        $línea
    );
    echo $línea;
}
fclose($fp);
?>

subject

La cadena o un array de cadenas a buscar y reemplazar.

limit

Las sustituciones máximas posibles por cada patrón en cada cadena subject. Por defecto -1 (sin límite).

count

Si se especifica, esta variable será rellenada con el número de sustituciones hechas.

Valores devueltos

preg_replace_callback() devuelve un array si el parámetro subject es un array, o, por el contrario una cadena. Si se producen errores, el valor devuleto es null

Si se encontraron coincidencias, el nuevo sujeto será devuelto, de lo contrario subject será devuelto sin cambios.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro count

Ejemplos

Ejemplo #2 Ejemplo de preg_replace_callback()

<?php
// este texto se usó en 2002
// queremos actualizarlo al 2003
$texto = "El Día de los Inocentes es el 28/12/2002\n";
$texto.= "Las últimas Navidades fueron el 24/12/2001\n";
// la función de llamada de retorno
function añoSiguiente($coincidencias)
{
  // como es usual: $coincidencias[0] es la coincidencia completa
  // $coincidencias[1] la coincidencia del primer sub-patrón
  // encerrado entre '(...)' y así sucesivamente
  return $coincidencias[1].($coincidencias[2]+1);
}
echo preg_replace_callback(
            "|(\d{2}/\d{2}/)(\d{4})|",
            "añoSiguiente",
            $texto);

?>

El resultado del ejemplo sería:

El Día de los Inocentes es el 28/12/2003
Las últimas Navidades fueron el 24/12/2002

Ejemplo #3 preg_replace_callback() usando una estructura recursiva para manejar el código BB encapsulado

<?php
$entrada = "nivel 1 [indent] nivel 2 [indent] nivel 3 [/indent] nivel 2 [/indent] nivel 1";

function analizarEtiquetasRecursivo($entrada)
{

    $regex = '#\[indent]((?:[^[]|\[(?!/?indent])|(?R))+)\[/indent]#';

    if (is_array($entrada)) {
        $entrada = '<div style="margin-left: 10px">'.$entrada[1].'</div>';
    }

    return preg_replace_callback($regex, 'analizarEtiquetasRecursivo', $entrada);
}

$salida = analizarEtiquetasRecursivo($entrada);

echo $salida;
?>

Ver también

  • Patrones de PCRE
  • preg_replace_callback_array() - Realizar una búsqueda y sustitución de expresión regular con retrollamadas
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE
  • Funciones anónimas


Realiza una búsqueda y sustitución de una expresión regular

  • « preg_replace_callback
  • preg_split »
  • PHP Manual
  • Funciones de PCRE
  • Realiza una búsqueda y sustitución de una expresión regular

preg_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_replace — Realiza una búsqueda y sustitución de una expresión regular

Descripción

preg_replace ( mixed $pattern , mixed $replacement , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

Busca en subject coincidencias de pattern y las reemplaza con replacement.

Parámetros

pattern

El patrón de búsqueda. Puede ser tanto una cadena como un array de cadenas.

También hay disponibles varios modificadores de PCRE.

replacement

La cadena o array de cadenas a reemplazar. Si este parámetro es una cadena y el parámetro pattern es un array, todos los patrones serán sustituidos por esa cadena. Si ambos parámetros, pattern y replacement, son arrays, cada pattern será reemplazado por el replacement equivalente. Si hay menos elementos en el array replacement que en el array pattern, cualquier pattern extra será reemplazado por una cadena vacía.

replacement puede contener referencias de la forma \\n o $n, siendo preferida la última forma. Cada referencia de este tipo será sustituida por el texto capturado por el n-simo patrón entre paréntesis. n puede ser desde 0 a 99, y \\0 o $0 se refiere al texto coincidido por el patrón completo. Los paréntesis de apertura se cuentan de izquierda a derecha (comenzando por 1) para obtener el número de sub-patrones de captura. Se debe doblar la barra invertida para poder usarla en la sustitución (cadena PHP "\\\\").

Cuando se trabaja con un patrón de sustitución donde una retroreferencia es immediatamente seguida de otro número (p.ej.: colocar un número literal immediatamente después de un patrón coincidido), no puede usar la notación familiar \\1 para sus retroreferencias. \\11, por ejemplo, confundiría a preg_replace() ya que no sabe si quiere que la retroreferencia \\1 esté seguida por un literal 1, o que la retroreferencia \\11 esté seguida de nada. En este caso la solución es usar ${1}1. Esto crea una retroreferencia $1 aislada, dejando el 1 como un literal.

Cuando se usa el modificador obsoleto e, esta función escapa algunos caracteres (a saber, ', ", \ y NULL) en la cadena que sustituye a las retroreferencias. Esto está hecho para asegurarse de que no surjan errores de sintaxis en el uso de retroreferencias con comillas simples o dobles (p.ej. 'strlen(\'$1\')+strlen("$2")'). Asegúrese de que conoce la sintaxis de cadena para saber cómo se asemejarán las cadenas interpretadas.

subject

La cadena o array de cadenas a buscar y sustituir.

Si subject es un array, entonces la búsqueda y sustitución se llevan a cabo para cada entrada de subject, y el valor devuelto también es un array.

limit

Las sustituciones máximas posibles por cada patrón en cada cadena subject. Por defecto es -1 (sin límite).

count

Si se especifica, esta variable será rellenada con el número de sustituciones hechas.

Valores devueltos

preg_replace() devuelve un array si el parámetro subject es un array, o, de lo contrario, una cadena.

Si se encuentran coincidencias, el nuevo subject será devuelto, de lo contrario, subject será devuelto sin cambios o null si se produjo un error.

Errores/Excepciones

A partir de PHP 5.5.0 se emite un error de nivel E_DEPRECATED al pasar el modificador "\e". A partir de PHP 7.0.0, en este caso se emite un E_WARNING y el modificador "\e" no tiene efecto.

Historial de cambios

Versión | Descripción
7.0.0 | Se ha eliminado el soporte para el modificador /e. Emplee preg_replace_callback() en su lugar.
5.5.0 | El modificador /e está obsoleto. Utilice preg_replace_callback() en su lugar. Véase la documentación de PREG_REPLACE_EVAL para obtener información adicional sobre riesgos de seguridad.
5.1.0 | Añadido el parámetro count

Ejemplos

Ejemplo #1 Usar retroreferencias seguidas de literales numéricos

<?php
$cadena = 'Abril 15, 2003';
$patrón = '/(\w+) (\d+), (\d+)/i';
$sustitución = '${1}1,$3';
echo preg_replace($patrón, $sustitución, $cadena);
?>

El resultado del ejemplo sería:

Abril1,2003

Ejemplo #2 Emplear arrays indexados con preg_replace()

<?php
$cadena = 'El veloz murciélago hindú comía feliz cardillo y kiwi.';
$patrones = array();
$patrones[0] = '/veloz/';
$patrones[1] = '/hindú/';
$patrones[2] = '/murciélago/';
$sustituciones = array();
$sustituciones[2] = 'galápago';
$sustituciones[1] = 'africano';
$sustituciones[0] = 'lento';
echo preg_replace($patrones, $sustituciones, $cadena);
?>

El resultado del ejemplo sería:

El galápago lento africano comía feliz cardillo y kiwi.

Al usar ksort en patrones y sustituciones, podríamos obtener lo que buscábamos.

<?php
ksort($patrones);
ksort($sustituciones);
echo preg_replace($patrones, $sustituciones, $cadena);
?>

El resultado del ejemplo sería:

El lento galápago africano comía feliz cardillo y kiwi.

Ejemplo #3 Sustituir varios valores

<?php
$patrones = array ('/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/',
                   '/^\s*{(\w+)}\s*=/');
$sustitución = array ('\4/\3/\1\2', '$\1 =');
echo preg_replace($patrones, $sustitución, '{fechaInicio} = 1999-5-27');
?>

El resultado del ejemplo sería:

$fechaInicio = 27/5/1999

Ejemplo #4 Quitar los espacios en blanco

Este ejemplo quita los espacios en blanco en exceso de una cadena.

<?php
$cadena = 'foo   o';
$cadena = preg_replace('/\s\s+/', ' ', $cadena);
// Ahora esto será 'foo o'
echo $cadena;
?>

Ejemplo #5 Usar el parámetro count

<?php
$cuenta = 0;

echo preg_replace(array('/\d/', '/\s/'), '*', 'xp 4 to', -1 , $cuenta);
echo $cuenta; //3
?>

El resultado del ejemplo sería:

xp***to
3

Notas

Nota:

Cuando se usan arrays con pattern y replacement, las claves se procesan en el orden en que aparecen en el array. Éste no es necesariamente el mismo que el orden de índice numérico. Si usa índices para identificar qué pattern debería ser sustituido por cuál replacement, debería usar ksort() en cada array antes de llamar a preg_replace().

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • preg_filter() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_match() - Realiza una comparación con una expresión regular
  • preg_replace_callback() - Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
  • preg_split() - Divide un string mediante una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Divide un string mediante una expresión regular

  • « preg_replace
  • Expresiones Regulares de POSIX »
  • PHP Manual
  • Funciones de PCRE
  • Divide un string mediante una expresión regular

preg_split

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_split — Divide un string mediante una expresión regular

Descripción

preg_split ( string $pattern , string $subject , int $limit = -1 , int $flags = 0 ) : array

Divide el string dado mediante una expresión regular.

Parámetros

pattern

El patrón de búsqueda, dado como string.

subject

El string de entrada.

limit

Si se especifica, son devueltos únicamente los substrings hasta limit, con el resto del string colocado en el último substring. Si limit vale -1, 0 o null, significa "sin límite" y, como es un estándar en PHP, se puede usar null para saltar hacia el parámetro flags.

flags

flags puede ser una combinación de las siguientes banderas (combinadas con el operador | de bits):

PREG_SPLIT_NO_EMPTY
Si se aplica esta bandera, solo serán devueltos los elementos no vacíos por preg_split().
PREG_SPLIT_DELIM_CAPTURE
Si se aplica esta bandera, las expresiones entre paréntesis en el patrón delimitador serán capturadas y devueltas.
PREG_SPLIT_OFFSET_CAPTURE

Si se aplica esta bandera, por cada coincidencia producida, el índice del string añadido también será devuelto. Observe que esto cambia el valor devuelto dentro de un array donde cada elemento es un array consistente en el string coincidente en el índice 0 y su índice de string dentro de subject en el índice 1.

Valores devueltos

Devuelve un array que contiene substrings de subject dividido por los límites coincidentes de pattern, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de preg_split() : Obtener las partes de un string de búsqueda

<?php
// divide la frase mediante cualquier número de comas o caracteres de espacio,
// lo que incluye " ", \r, \t, \n y \f
$claves = preg_split("/[\s,]+/", "hypertext language, programming");
print_r($claves);
?>

El resultado del ejemplo sería:

Array
(
    [0] => hypertext
    [1] => language
    [2] => programming
)

Ejemplo #2 Dividir un string en sus caracteres constituyentes

<?php
$str = 'string';
$caracteres = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);
print_r($caracteres);
?>

El resultado del ejemplo sería:

Array
(
    [0] => s
    [1] => t
    [2] => r
    [3] => i
    [4] => n
    [5] => g
)

Ejemplo #3 Dividir un string mediante coincidencias y sus índices

<?php
$str = 'hypertext language programming';
$caracteres = preg_split('/ /', $str, -1, PREG_SPLIT_OFFSET_CAPTURE);
print_r($caracteres);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => hypertext
            [1] => 0
        )

    [1] => Array
        (
            [0] => language
            [1] => 10
        )

    [2] => Array
        (
            [0] => programming
            [1] => 19
        )

)

Notas

Sugerencia

Si no necesita la potencia de expresiones regulares, puede optar por alternativas más rápidas (no obstante más sencillas) como explode() o str_split().

Sugerencia

Si la comparación falla, será devuelto un array con un único elemento que contiene el string de entrada.

Ver también

  • Patrones de PCRE
  • preg_quote() - Escapar caracteres en una expresión regular
  • implode() - Une elementos de un array en un string
  • preg_match() - Realiza una comparación con una expresión regular
  • preg_match_all() - Realiza una comparación global de una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • preg_last_error() - Devuelve el código de error de la última ejecución de expresión regular de PCRE


Expresiones Regulares (POSIX Extendido)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de expresiones regulares POSIX
    • ereg_replace — Sustituye una expresión regular
    • ereg — Comparación de una expresión regular
    • eregi_replace — Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
    • eregi — Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
    • split — Divide una cadena en una matriz mediante una expresión regular
    • spliti — Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas
    • sql_regcase — Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas


Introducción

Advertencia

Esta característica está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta característica son:

  • PCRE (para soporte completo de expresiones regulares)
  • fnmatch() (para búsquedas más sencillas de patrones de comodín al estilo consola)
Sugerencia

PHP también admite expresiones regulares empleando una sintaxis compatible con Perl utilizando las funciones PCRE. Estas funciones admiten comparaciones no codiciosas, declaraciones, patrones condicionales y varias características no soportadas por la sintaxis de las expresiones regulares POSIX extendido.

Advertencia

Estas funciones de expresiones regulares no son seguras al trabajar con datos binarios. Las funciones PCRE sí lo son.

Las expresiones regulares se usan para la manipulación de strings complejos. PHP usa las expresiones regulares de POSIX extendido tal como está definido por POSIX 1003.2. Para una descripción completa de las expresiones regulares POSIX, véase el » manual de expresiones regulares incluido en el directorio regex de la distribución de PHP. Este manual está en formato "man", por lo que será necesaria una orden como man /usr/local/src/regex/regex.7 para poder leerlo.


Instalación

Advertencia

No cambie TYPE a menos que sepa lo que está haciendo.

Para habilitar el soporte de expresiones regulares configure PHP con --with-regex[=TYPE]. TYPE puede ser system, apache, php. El valor por defecto es php.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Expresiones Regulares de POSIX
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Ejemplo #1 Ejemplos de Expresiones Regulares

<?php
// Devuelve true si "abc" se encuentra en cualquier lugar de $cadena.
ereg("abc", $cadena);

// Devuelve true si "abc" se encuentra al comienzo de $cadena.
ereg("^abc", $cadena);

// Devuelve true si "abc" se encuentra al final de $cadena.
ereg("abc$", $cadena);

// Devuelve true si el navegador del cliente es Netscape 2, 3 o MSIE 3.
eregi("(ozilla.[23]|MSIE.3)", $_SERVER["HTTP_USER_AGENT"]);

// Coloca tres palabras separadas por un espacio dento de $registros[1], $registros[2] y $registros[3].
ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)", $cadena, $registros);

// Pone una etiqueta <br /> al principio de $cadena.
$cadena = ereg_replace("^", "<br />", $cadena);

// Pone una etiqueta <br /> al final de $cadena.
$cadena = ereg_replace("$", "<br />", $cadena);

// Se deshace de cualquier carácter de nueva línea en $cadena.
$cadena = ereg_replace("\n", "", $cadena);
?>


Funciones de expresiones regulares POSIX

Ver también

Advertencia

Esta característica está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta característica son:

  • PCRE (para soporte completo de expresiones regulares)
  • fnmatch() (para búsquedas más sencillas de patrones de comodín al estilo consola)

Tabla de contenidos

  • ereg_replace — Sustituye una expresión regular
  • ereg — Comparación de una expresión regular
  • eregi_replace — Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
  • eregi — Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
  • split — Divide una cadena en una matriz mediante una expresión regular
  • spliti — Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas
  • sql_regcase — Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas


Sustituye una expresión regular

  • « Funciones de expresiones regulares POSIX
  • ereg »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Sustituye una expresión regular

ereg_replace

(PHP 4, PHP 5)

ereg_replace — Sustituye una expresión regular

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_replace()

Descripción

ereg_replace ( string $pattern , string $replacement , string $string ) : string

Esta función busca en string coincidencias de pattern, después reemplaza el texto coincidido con replacement.

Parámetros

pattern

Una expresión regular POSIX extendido.

replacement

Si pattern contiene sub-cadenas entre paréntesis, replacement puede contener sub-cadenas de la forma \dígito, las cuales serán sustituidas por el texto que coincida con la sub-cadena entre paréntesis que coincida con el número marcado por dígito; \0 producirá el contenido completo de la cadena. Se pueden usar hasta nueve sub-cadenas. Los paréntesis se pueden anidar, en cuyo caso son contados por los paréntesis de apertura.

string

La cadena de entrada.

Valores devueltos

Se devuelve la cadena modificada. Si no se encontraron coincidencias en string, éste será devuelto sin cambios.

Ejemplos

Por ejemplo, el siguiente trozo de código imprime "Esto era una prueba" tres veces:

Ejemplo #1 Ejemplo de ereg_replace()

<?php

$cadena = "Esto es una prueba";
echo str_replace(" es", " era", $cadena);
echo ereg_replace("( )es", "\\1era", $cadena);
echo ereg_replace("(( )es)", "\\2era", $cadena);

?>

Una cosa a tener en cuenta es que si se usa un valor entero como el parámetro replacement, puede no obtenerse los resultados que se esperaban. Esto es a causa de que ereg_replace() interpretará el número como el valor ordinal de un carácter, y lo aplica. Por ejemplo:

Ejemplo #2 Ejemplo de ereg_replace()

<?php
/* Esto no funcionará como se esperaba. */
$número = 4;
$cadena = "Esta cadena tiene cuatro palabras.";
$cadena = ereg_replace('cuatro', $número, $cadena);
echo $cadena;   /* Salida: 'Esta cadena tiene   palabras.' */

/* Estó funcionará. */
$número = '4';
$cadena = "Esta cadena tiene cuatro palabras.";
$cadena = ereg_replace('cuatro', $número, $cadena);
echo $cadena;   /* Salida: 'Esta cadena tiene 4 palabras.' */
?>

Ejemplo #3 Sustituye URLs por vínculos

<?php
$texto = ereg_replace("[[:alpha:]]+://[^<>[:space:]]+[[:alnum:]/]",
                     "<a href=\"\0\">\0</a>", $texto);
?>

Ver también

  • ereg() - Comparación de una expresión regular
  • eregi() - Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
  • eregi_replace() - Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • quotemeta() - Escapa meta caracteres


Comparación de una expresión regular

  • « ereg_replace
  • eregi_replace »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Comparación de una expresión regular

ereg

(PHP 4, PHP 5)

ereg — Comparación de una expresión regular

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_match()

Descripción

ereg ( string $pattern , string $string , array &$regs = ? ) : int

Busca en string coincidencias con la expresión regular dada en pattern de una forma sensible a mayúsculas-minúsculas.

Parámetros

pattern

Expresión regular sensible a mayúsculas-minúsculas.

string

La cadena de entrada.

regs

Si se encontraron coincidencias con las sub-cadenas entre paréntesis de pattern y la función es llamada con el tercer argumento regs, las coincidencias serán almacenadas en los elementos de la matriz regs.

$registros[1] contendrá la sub-cadena que comienza con el primer paréntesis de la izquierda; $registros[2] contendrá la segunda sub-cadena, y así sucesivamente. $registros[0] contendrá una copia de la cadena coincidente completa.

Valores devueltos

Devuelve la longitud de la cadena coincidente si una coincidencia de pattern se encontró en string, o false si no se encontraron coincidencias o se produjo un error.

Si el parámetro opcional regs no fue pasado o la longitud de la cadena coincidente es 0, esta función devuelve 1.

Historial de cambios

Versión | Descripción
4.1.0 | Hasta PHP 4.1.0 (inclusive) $registros será rellenado con exactamente diez elementos, incluso si en realidad se pueden haber comparado más o menos de diez sub-cadenas entre paréntesis. Esto no tiene efecto en la capacidad que tiene ereg() de comparar más sub-cadenas. Si no se encontraron coincidencias, $registros no será modificado por ereg().

Ejemplos

Ejemplo #1 Ejemplo de ereg()

El siguiente trozo de código toma una fecha en formato ISO (AAAA-MM-DD) y la imprime en formato DD.MM.AAAA:

<?php
if (ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $fecha, $registros)) {
    echo "$registros[3].$registros[2].$registros[1]";
} else {
    echo "Formato de fecha no válido: $fecha";
}
?>

Ver también

  • eregi() - Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
  • ereg_replace() - Sustituye una expresión regular
  • eregi_replace() - Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
  • preg_match() - Realiza una comparación con una expresión regular
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • strstr() - Encuentra la primera aparición de un string
  • quotemeta() - Escapa meta caracteres


Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas

  • « ereg
  • eregi »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas

eregi_replace

(PHP 4, PHP 5)

eregi_replace — Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_replace() (con el modificador i (PCRE_CASELESS))

Descripción

eregi_replace ( string $pattern , string $replacement , string $string ) : string

Esta función es idéntica a ereg_replace() excepto que ignora la distinción de mayúsculas-minúsculas cuando se comparan caracteres alfanuméricos.

Parámetros

pattern

Una expresión regular POSIX extendido.

replacement

Si pattern contiene sub-cadenas entre paréntesis, replacement puede contener sub-cadenas de la forma \dígito, las cuales serán sustituidas por el texto que coincida con la sub-cadena entre paréntesis que coincida con el número marcado por dígito; \0 producirá el contenido completo de la cadena. Se pueden usar hasta nueve sub-cadenas. Los paréntesis se pueden anidar, en cuyo caso son contados por los paréntesis de apertura.

string

La cadena de entrada.

Valores devueltos

Se devuelve la cadena modificada. Si no se encontraron coincidencias en string, éste será devuelto sin cambios.

Ejemplos

Ejemplo #1 Destaca los resultados buscados

<?php
$patrón = '(>[^<]*)('. quotemeta($_GET['buscados']) .')';
$sustitución = '\\1<span class="buscados">\\2</span>';
$body = eregi_replace($patrón, $sustitución, $body);
?>

Ver también

  • ereg() - Comparación de una expresión regular
  • eregi() - Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
  • ereg_replace() - Sustituye una expresión regular
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • quotemeta() - Escapa meta caracteres


Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas

  • « eregi_replace
  • split »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas

eregi

(PHP 4, PHP 5)

eregi — Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_match() (con el modificador i (PCRE_CASELESS))

Descripción

eregi ( string $pattern , string $string , array &$regs = ? ) : int

Esta función es idéntica a ereg() excepto que ignora la distinción de mayúsculas-minúsculas cuando se comparan caracteres alfanuméricos.

Parámetros

pattern

Expresión regular insensible a mayúsculas-minúsculas.

string

La cadena de entrada.

regs

Si se encontraron coincidencias con las sub-cadenas entre paréntesis de pattern y la función es llamada con el tercer argumento regs, las coincidencias serán almacenadas en los elementos de la matriz regs.

$regs[1] contendrá la sub-cadena que comienza con el primer paréntesis de la izquierda; $regs[2] contendrá la segunda sub-cadena, y así sucesivamente. $regs[0] contendrá una copia de la cadena coincidente completa.

Valores devueltos

Devuelve la longitud de la cadena coincidente si una coincidencia de pattern se encontró en string, o false si no se encontraron coincidencias o se produjo un error.

Si el parámetro opcional regs no fue pasado o la longitud de la cadena coincidente es 0, esta función devuelve 1.

Ejemplos

Ejemplo #1 Ejemplo de eregi()

<?php
$cadena = 'XYZ';
if (eregi('z', $cadena)) {
    echo "¡'$cadena' contiene una 'z' o 'Z'!";
}
?>

Ver también

  • ereg() - Comparación de una expresión regular
  • ereg_replace() - Sustituye una expresión regular
  • eregi_replace() - Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
  • preg_match() - Realiza una comparación con una expresión regular
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • quotemeta() - Escapa meta caracteres


Divide una cadena en una matriz mediante una expresión regular

  • « eregi
  • spliti »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Divide una cadena en una matriz mediante una expresión regular

split

(PHP 4, PHP 5)

split — Divide una cadena en una matriz mediante una expresión regular

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_split()
  • explode()
  • str_split()

Descripción

split ( string $pattern , string $string , int $limit = -1 ) : array

Divide un string en una matriz mediante una expresión regular.

Parámetros

pattern

Expresión regular sensible a mayúsculas-minúsculas.

Si quiere dividir cualesquiera caracteres que están considerados especiales por las expresiones regulares, necesitará escaparlos primero. Si piensa que split() (o, de hecho, cualquier otra función de expresión regular) está haciendo algo extraño, por favor, lea el archivo regex.7, incluido en el subdirectorio regex/ de la distribución de PHP. Estas páginas de ayuda están en formato "man", por lo que será necesaria una orden como man /usr/local/src/regex/regex.7 para poder leerlo.

string

La cadena de entrada.

limit

Si se establece limit, la matriz devuelta contendrá un máximo de limit elementos con el último elemento conteniendo el resto completo de string.

Valores devueltos

Devuelve una matriz de cadenas, siendo cada una de ellas una sub-cadena de string formada al dividir éste con los límites establecidos mediante la expresión regular sensible a mayúsculas-minúsculas pattern.

Si hay n incidencias de pattern, la matriz devuelta contentrá n+1 elementos. Por ejemplo, si no hay incidencias de pattern, será devuelta una matriz con sólo un elemento. Por supuesto, esto también es verdadero si string está vacío. Si se produce un error, split() devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de split()

Para obtener los cinco primeros campos de una línea de /etc/passwd:

<?php
list($usuario, $contraseña, $uid, $gid, $extra) =
    split(":", $línea_passwd, 5);
?>

Ejemplo #2 Ejemplo de split()

Para analizar una fecha que puede estar delimitada por barras, puntos o guiones:

<?php
// Los delimitadores pueden ser barra, punto o guión
$fecha = "04/30/1973";
list($mes, $día, $año) = split('[/.-]', $fecha);
echo "Mes: $mes; Día: $día; Año: $año<br />\n";
?>

Notas

Sugerencia

split() está obsoleta a partir de PHP 5.3.0. preg_split() es la alternativa sugerida a esta función. Si no necesita la potencia de expresiones regulares, es más rápido usar explode(), que no provoca el overhead del motor de expresiones regulares.

Sugerencia

Para usuarios que buscan un manera de emular el comportamiento de Perl @chars = split('', $str), por favor, vea los ejemplos de preg_split() o str_split().

Ver también

  • preg_split() - Divide un string mediante una expresión regular
  • spliti() - Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas
  • str_split() - Convierte un string en un array
  • explode() - Divide un string en varios string
  • implode() - Une elementos de un array en un string
  • chunk_split() - Divide una cadena en trozos más pequeños
  • wordwrap() - Ajusta un string hasta un número dado de caracteres


Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas

  • « split
  • sql_regcase »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas

spliti

(PHP 4 >= 4.0.1, PHP 5)

spliti — Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_split() (con el modificador i (PCRE_CASELESS))

Descripción

spliti ( string $pattern , string $string , int $limit = -1 ) : array

Divide un string en una matriz mediante una expresión regular.

Esta función es idéntica a split() excepto que ignora la distinción de mayúsculas-minúsculas cuando se comparan caracteres alfanuméricos.

Parámetros

pattern

Expresión regular insensible a mayúsculas-minúsculas.

Si quiere dividir cualesquiera caracteres que están considerados especiales por las expresiones regulares, necesitará escaparlos primero. Si piensa que spliti() (o, de hecho, cualquier otra función de expresión regular) está haciendo algo extraño, por favor, lea el archivo regex.7, incluido en el subdirectorio regex/ de la distribución de PHP. Estas páginas de ayuda están en formato "man", por lo que será necesaria una orden como man /usr/local/src/regex/regex.7 para poder leerlo.

string

La cadena de entrada.

limit

Si se establece limit, la matriz devuelta contendrá un máximo de limit elementos con el último elemento conteniendo el resto completo de string.

Valores devueltos

Devuelve una matriz de cadenas, siendo cada una de ellas una sub-cadena de string formada al dividir éste con los límites establecidos mediante la expresión regular insensible a mayúsculas-minúsculas pattern.

Si hay n incidencias de pattern, la matriz devuelta contentrá n+1 elementos. Por ejemplo, si no hay incidencias de pattern, será devuelta una matriz con sólo un elemento. Por supuesto, esto también es verdadero si string está vacío. Si se produce un error, spliti() devuelve false.

Ejemplos

Este ejemplo divide una cadena usando 'a' como separador :

Ejemplo #1 Ejemplo de spliti()

<?php
$cadena = "aBBBaCCCADDDaEEEaGGGA";
$trozos = spliti ("a", $cadena, 5);
print_r($trozos);
?>

El resultado del ejemplo sería:

Array
(
  [0] =>
  [1] => BBB
  [2] => CCC
  [3] => DDD
  [4] => EEEaGGGA
)

Ver también

  • preg_split() - Divide un string mediante una expresión regular
  • split() - Divide una cadena en una matriz mediante una expresión regular
  • explode() - Divide un string en varios string
  • implode() - Une elementos de un array en un string


Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas

  • « spliti
  • ssdeep »
  • PHP Manual
  • Funciones de expresiones regulares POSIX
  • Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas

sql_regcase

(PHP 4, PHP 5)

sql_regcase — Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas

Advertencia

Esta función está OBSOLETA en PHP 5.3.0, por lo tanto, será ELIMINADA en PHP 7.0.0.

Las alternativas a esta función son:

  • preg_match()
  • preg_quote()

Descripción

sql_regcase ( string $string ) : string

Crea una expresión regular para la comparación insensible a mayúscuas-minúsculas.

Parámetros

string

La cadena de entrada.

Valores devueltos

Devuelve una expresión regular válida que coincidirá con string, ignorando las mayúsculas y minúsculas. Esta expresión es string con cada carácter alfabético convertido en una expresión entre corchetes; esta expresión contiene tanto la forma mayúscula como minúscula del carácter. Los demás caracteres permanecen inalterados.

Ejemplos

Ejemplo #1 Ejemplo de sql_regcase()

<?php
echo sql_regcase("Foo - bar.");
?>

El resultado del ejemplo sería:

[Ff][Oo][Oo] - [Bb][Aa][Rr].

Esto se puede usar para llevar a cabo una comparación de un patrón insensible a mayúsculas-minúsculas en productos que soporten sólo expresiones regulares sensibles a mayúsculas-minúsculas.


ssdeep Fuzzy Hashing

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones ssdeep
    • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
    • ssdeep_fuzzy_hash — Create a fuzzy hash from a string


Introducción

ssdeep is a utility for creating and comparing fuzzy hashes or » context-triggered piecewise hashing.

Fuzzy hashing can match signatures which have "...sequences of identical bytes in the same order, although bytes in between these sequences may be different in both content and length". (» ssdeep project page)

This extension provides functions for creating and comparing fuzzy hashes.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta extensión requiere la librería » ssdeep.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ssdeep.


  • « Tipos de recursos
  • Funciones ssdeep »
  • PHP Manual
  • ssdeep
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones ssdeep

Tabla de contenidos

  • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
  • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
  • ssdeep_fuzzy_hash — Create a fuzzy hash from a string


Calculates the match score between two fuzzy hash signatures

  • « Funciones ssdeep
  • ssdeep_fuzzy_hash_filename »
  • PHP Manual
  • Funciones ssdeep
  • Calculates the match score between two fuzzy hash signatures

ssdeep_fuzzy_compare

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures

Descripción

ssdeep_fuzzy_compare ( string $signature1 , string $signature2 ) : int

Calculates the match score between signature1 and signature2 using » context-triggered piecewise hashing, and returns the match score.

Parámetros

signature1

The first fuzzy hash signature string.

signature2

The second fuzzy hash signature string.

Valores devueltos

Returns an integer from 0 to 100 on success, false otherwise.


Create a fuzzy hash from a file

  • « ssdeep_fuzzy_compare
  • ssdeep_fuzzy_hash »
  • PHP Manual
  • Funciones ssdeep
  • Create a fuzzy hash from a file

ssdeep_fuzzy_hash_filename

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file

Descripción

ssdeep_fuzzy_hash_filename ( string $file_name ) : string

ssdeep_fuzzy_hash_filename() calculates the hash of the file specified by file_name using » context-triggered piecewise hashing, and returns that hash.

Parámetros

file_name

The filename of the file to hash.

Valores devueltos

Returns a string on success, false otherwise.


Create a fuzzy hash from a string

  • « ssdeep_fuzzy_hash_filename
  • Strings »
  • PHP Manual
  • Funciones ssdeep
  • Create a fuzzy hash from a string

ssdeep_fuzzy_hash

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash — Create a fuzzy hash from a string

Descripción

ssdeep_fuzzy_hash ( string $to_hash ) : string

ssdeep_fuzzy_hash() calculates the hash of to_hash using » context-triggered piecewise hashing, and returns that hash.

Parámetros

to_hash

The input string.

Valores devueltos

Returns a string on success, false otherwise.


Strings

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de strings
    • addcslashes — Escapa una cadena al estilo de C
    • addslashes — Escapa un string con barras invertidas
    • bin2hex — Convierte datos binarios en su representación hexadecimal
    • chop — Alias de rtrim
    • chr — Devuelve un caracter específico
    • chunk_split — Divide una cadena en trozos más pequeños
    • convert_cyr_string — Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico
    • convert_uudecode — Descodifica una cadena codificada mediante uuencode
    • convert_uuencode — Codificar mediante uuencode una cadena
    • count_chars — Devuelve información sobre los caracteres usados en una cadena
    • crc32 — Calcula el polinomio crc32 de una cadena
    • crypt — Hash de cadenas de un sólo sentido
    • echo — Muestra una o más cadenas
    • explode — Divide un string en varios string
    • fprintf — Escribir una cadena con formato a una secuencia
    • get_html_translation_table — Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
    • hebrev — Convierte texto hebreo lógico a texto visual
    • hebrevc — Convertir texto de hebreo lógico a texto visual con conversión de línea nueva
    • hex2bin — Decodifica una cadena binaria codificada hexadecimalmente
    • html_entity_decode — Convierte todas las entidades HTML a sus caracteres correspondientes
    • htmlentities — Convierte todos los caracteres aplicables a entidades HTML
    • htmlspecialchars_decode — Convierte entidades HTML especiales de nuevo en caracteres
    • htmlspecialchars — Convierte caracteres especiales en entidades HTML
    • implode — Une elementos de un array en un string
    • join — Alias de implode
    • lcfirst — Pasa a minúscula el primer caracter de un string
    • levenshtein — Cálculo de la distancia Levenshtein entre dos strings
    • localeconv — Obtener información sobre el formato numérico
    • ltrim — Retira espacios en blanco (u otros caracteres) del inicio de un string
    • md5_file — Calcula el resumen criptográfico md5 de un archivo dado
    • md5 — Calcula el 'hash' md5 de un string
    • metaphone — Calcula la clave metaphone de un string
    • money_format — Da formato a un número como un string de moneda
    • nl_langinfo — Consulta información sobre el idioma y la configuración regional
    • nl2br — Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
    • number_format — Formatear un número con los millares agrupados
    • ord — Convierte el primer byte de un string a un valor entre 0 y 255
    • parse_str — Convierte el string en variables
    • print — Mostrar una cadena
    • printf — Imprimir una cadena con formato
    • quoted_printable_decode — Convierte un string quoted-printable en un string de 8 bits
    • quoted_printable_encode — Convierte un string de 8 bits en un string quoted-printable
    • quotemeta — Escapa meta caracteres
    • rtrim — Retira los espacios en blanco (u otros caracteres) del final de un string
    • setlocale — Establecer la información del localismo
    • sha1_file — Calcula el hash sha1 de un archivo
    • sha1 — Calcula el 'hash' sha1 de un string
    • similar_text — Calcula la similitud entre dos strings
    • soundex — Calcula la clave soundex de un string
    • sprintf — Devuelve un string formateado
    • sscanf — Interpreta un string de entrada de acuerdo con un formato
    • str_contains — Determine if a string contains a given substring
    • str_ends_with — Checks if a string ends with a given substring
    • str_getcsv — Convierte un string con formato CSV a un array
    • str_ireplace — Versión insensible a mayúsculas y minúsculas de str_replace
    • str_pad — Rellena un string hasta una longitud determinada con otro string
    • str_repeat — Repite un string
    • str_replace — Reemplaza todas las apariciones del string buscado con el string de reemplazo
    • str_rot13 — Realizar la transformación rot13 sobre una cadena
    • str_shuffle — Reordena aleatoriamente una cadena
    • str_split — Convierte un string en un array
    • str_starts_with — Checks if a string starts with a given substring
    • str_word_count — Devuelve información sobre las palabras utilizadas en un string
    • strcasecmp — Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
    • strchr — Alias de strstr
    • strcmp — Comparación de string segura a nivel binario
    • strcoll — Comparación de cadenas basada en la localidad
    • strcspn — Averiguar la longitud del segmento inicial que no coincida con una máscara
    • strip_tags — Retira las etiquetas HTML y PHP de un string
    • stripcslashes — Desmarca la cadena marcada con addcslashes
    • stripos — Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
    • stripslashes — Quita las barras de un string con comillas escapadas
    • stristr — strstr insensible a mayúsculas y minúsculas
    • strlen — Obtiene la longitud de un string
    • strnatcasecmp — Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"
    • strnatcmp — Comparación de strings utilizando un algoritmo de "orden natural"
    • strncasecmp — Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
    • strncmp — Comparación segura a nivel binario de los primeros n caracteres entre strings
    • strpbrk — Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
    • strpos — Encuentra la posición de la primera ocurrencia de un substring en un string
    • strrchr — Encuentra la última aparición de un caracter en un string
    • strrev — Invierte una string
    • strripos — Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
    • strrpos — Encuentra la posición de la última aparición de un substring en un string
    • strspn — Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada
    • strstr — Encuentra la primera aparición de un string
    • strtok — Tokeniza string
    • strtolower — Convierte un string a minúsculas
    • strtoupper — Convierte un string a mayúsculas
    • strtr — Convierte caracteres o reemplaza substrings
    • substr_compare — Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
    • substr_count — Cuenta el número de apariciones del substring
    • substr_replace — Reemplaza el texto dentro de una porción de un string
    • substr — Devuelve parte de una cadena
    • trim — Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
    • ucfirst — Convierte el primer caracter de una cadena a mayúsculas
    • ucwords — Convierte a mayúsculas el primer caracter de cada palabra de una cadena
    • vfprintf — Escribe un string con formato en un flujo
    • vprintf — Muestra una cadena con formato
    • vsprintf — Devuelve una cadena con formato
    • wordwrap — Ajusta un string hasta un número dado de caracteres
  • Registro de cambios


Introducción

Estas funciones manipulan strings de varias maneras. Existen algunas secciones más especializadas, como la de expresiones regulares y la de Manipulación de URLs.

Para obtener información sobre cómo funcionan los strings, especialmente en relación con el uso de comillas simples, comillas dobles, y secuencias de escape, véase la entrada Strings en la sección Tipos del manual.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

CRYPT_SALT_LENGTH integer
CRYPT_STD_DES integer
CRYPT_EXT_DES integer
CRYPT_MD5 integer
CRYPT_BLOWFISH integer
HTML_SPECIALCHARS (integer)
HTML_ENTITIES (integer)
ENT_COMPAT (integer)
ENT_QUOTES (integer)
ENT_NOQUOTES (integer)
ENT_IGNORE (integer)
ENT_SUBSTITUTE (integer)
ENT_DISALLOWED (integer)
ENT_HTML401 (integer)
ENT_XML1 (integer)
ENT_XHTML (integer)
ENT_HTML5 (integer)
CHAR_MAX (integer)
LC_CTYPE (integer)
LC_NUMERIC (integer)
LC_TIME (integer)
LC_COLLATE (integer)
LC_MONETARY (integer)
LC_ALL (integer)
LC_MESSAGES (integer)
STR_PAD_LEFT (integer)
STR_PAD_RIGHT (integer)
STR_PAD_BOTH (integer)


Funciones de strings

Ver también

Para un mejor manejo de cadenas y manipulacion de funciones revisar a las funciones de expresiones regulares del POSIX y las Funciones de expresiones regulares compatibles con Perl .

Tabla de contenidos

  • addcslashes — Escapa una cadena al estilo de C
  • addslashes — Escapa un string con barras invertidas
  • bin2hex — Convierte datos binarios en su representación hexadecimal
  • chop — Alias de rtrim
  • chr — Devuelve un caracter específico
  • chunk_split — Divide una cadena en trozos más pequeños
  • convert_cyr_string — Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico
  • convert_uudecode — Descodifica una cadena codificada mediante uuencode
  • convert_uuencode — Codificar mediante uuencode una cadena
  • count_chars — Devuelve información sobre los caracteres usados en una cadena
  • crc32 — Calcula el polinomio crc32 de una cadena
  • crypt — Hash de cadenas de un sólo sentido
  • echo — Muestra una o más cadenas
  • explode — Divide un string en varios string
  • fprintf — Escribir una cadena con formato a una secuencia
  • get_html_translation_table — Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
  • hebrev — Convierte texto hebreo lógico a texto visual
  • hebrevc — Convertir texto de hebreo lógico a texto visual con conversión de línea nueva
  • hex2bin — Decodifica una cadena binaria codificada hexadecimalmente
  • html_entity_decode — Convierte todas las entidades HTML a sus caracteres correspondientes
  • htmlentities — Convierte todos los caracteres aplicables a entidades HTML
  • htmlspecialchars_decode — Convierte entidades HTML especiales de nuevo en caracteres
  • htmlspecialchars — Convierte caracteres especiales en entidades HTML
  • implode — Une elementos de un array en un string
  • join — Alias de implode
  • lcfirst — Pasa a minúscula el primer caracter de un string
  • levenshtein — Cálculo de la distancia Levenshtein entre dos strings
  • localeconv — Obtener información sobre el formato numérico
  • ltrim — Retira espacios en blanco (u otros caracteres) del inicio de un string
  • md5_file — Calcula el resumen criptográfico md5 de un archivo dado
  • md5 — Calcula el 'hash' md5 de un string
  • metaphone — Calcula la clave metaphone de un string
  • money_format — Da formato a un número como un string de moneda
  • nl_langinfo — Consulta información sobre el idioma y la configuración regional
  • nl2br — Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
  • number_format — Formatear un número con los millares agrupados
  • ord — Convierte el primer byte de un string a un valor entre 0 y 255
  • parse_str — Convierte el string en variables
  • print — Mostrar una cadena
  • printf — Imprimir una cadena con formato
  • quoted_printable_decode — Convierte un string quoted-printable en un string de 8 bits
  • quoted_printable_encode — Convierte un string de 8 bits en un string quoted-printable
  • quotemeta — Escapa meta caracteres
  • rtrim — Retira los espacios en blanco (u otros caracteres) del final de un string
  • setlocale — Establecer la información del localismo
  • sha1_file — Calcula el hash sha1 de un archivo
  • sha1 — Calcula el 'hash' sha1 de un string
  • similar_text — Calcula la similitud entre dos strings
  • soundex — Calcula la clave soundex de un string
  • sprintf — Devuelve un string formateado
  • sscanf — Interpreta un string de entrada de acuerdo con un formato
  • str_contains — Determine if a string contains a given substring
  • str_ends_with — Checks if a string ends with a given substring
  • str_getcsv — Convierte un string con formato CSV a un array
  • str_ireplace — Versión insensible a mayúsculas y minúsculas de str_replace
  • str_pad — Rellena un string hasta una longitud determinada con otro string
  • str_repeat — Repite un string
  • str_replace — Reemplaza todas las apariciones del string buscado con el string de reemplazo
  • str_rot13 — Realizar la transformación rot13 sobre una cadena
  • str_shuffle — Reordena aleatoriamente una cadena
  • str_split — Convierte un string en un array
  • str_starts_with — Checks if a string starts with a given substring
  • str_word_count — Devuelve información sobre las palabras utilizadas en un string
  • strcasecmp — Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • strchr — Alias de strstr
  • strcmp — Comparación de string segura a nivel binario
  • strcoll — Comparación de cadenas basada en la localidad
  • strcspn — Averiguar la longitud del segmento inicial que no coincida con una máscara
  • strip_tags — Retira las etiquetas HTML y PHP de un string
  • stripcslashes — Desmarca la cadena marcada con addcslashes
  • stripos — Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • stripslashes — Quita las barras de un string con comillas escapadas
  • stristr — strstr insensible a mayúsculas y minúsculas
  • strlen — Obtiene la longitud de un string
  • strnatcasecmp — Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"
  • strnatcmp — Comparación de strings utilizando un algoritmo de "orden natural"
  • strncasecmp — Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • strncmp — Comparación segura a nivel binario de los primeros n caracteres entre strings
  • strpbrk — Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • strpos — Encuentra la posición de la primera ocurrencia de un substring en un string
  • strrchr — Encuentra la última aparición de un caracter en un string
  • strrev — Invierte una string
  • strripos — Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strrpos — Encuentra la posición de la última aparición de un substring en un string
  • strspn — Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada
  • strstr — Encuentra la primera aparición de un string
  • strtok — Tokeniza string
  • strtolower — Convierte un string a minúsculas
  • strtoupper — Convierte un string a mayúsculas
  • strtr — Convierte caracteres o reemplaza substrings
  • substr_compare — Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
  • substr_count — Cuenta el número de apariciones del substring
  • substr_replace — Reemplaza el texto dentro de una porción de un string
  • substr — Devuelve parte de una cadena
  • trim — Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
  • ucfirst — Convierte el primer caracter de una cadena a mayúsculas
  • ucwords — Convierte a mayúsculas el primer caracter de cada palabra de una cadena
  • vfprintf — Escribe un string con formato en un flujo
  • vprintf — Muestra una cadena con formato
  • vsprintf — Devuelve una cadena con formato
  • wordwrap — Ajusta un string hasta un número dado de caracteres


Escapa una cadena al estilo de C

  • « Funciones de strings
  • addslashes »
  • PHP Manual
  • Funciones de strings
  • Escapa una cadena al estilo de C

addcslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

addcslashes — Escapa una cadena al estilo de C

Descripción

addcslashes ( string $str , string $charlist ) : string

Devuelve un string con barras invertidas antes de los caracteres que aparecen en el parámetro charlist

Parámetros

str

El string a escapar.

charlist

Una lista de caracteres que serán escapados. Si charlist contiene caracteres como \n, \r etc., serán convertidos al estilo de C, mientras que otros caracteres no alfanuméricos con código ASCII inferior a 32 y superior a 126 serán convertidos a representación octal.

Cuando se defina una secuencia de caracteres en el argumento charlist, asegúrese de conocer los caracteres que hay entre los caracteres de inicio y final del rango establecido.

<?php
echo addcslashes('foo[ ]', 'A..z');
// salida:  \f\o\o\[ \]
// Serán escapadas todas las letras mayúsculas y minúsculas
// ... pero también [\]^_`
?>
Además, si el primer carácter del rango tiene un valor ASCII superior al segundo carácter del rango, este no se podrá construir. Solamente serán escapados los caracteres de inicio, fin y el punto. Use la función ord() para encontrar el valor ASCII de un carácter.
<?php
echo addcslashes("zoo['.']", 'z..A');
// salida:  \zoo['\.']
?>

Ojo si se opta por escapar los caracteres 0, a, b, f, n, r, t y v. Estos se convertirán en \0, \a, \b, \f, \n, \r, \t and \v, que son todos secuencias de escape predefinidas en C. Muchas de estas secuencias tambíen están definidas en otros lenguajes derivados de C, incluyendo PHP, lo que significa que no se podría obtener el resultado deseado si se usa la salida de addcslashes() para generar código en tales lenguajes con los caracteres definidos en charlist.

Valores devueltos

Devuelve el string escapado.

Historial de cambios

Versión | Descripción
5.2.5 | Se añadieron las secuencias de escape \v y \f.

Ejemplos

Un rango en charlist como "\0..\37", escaparía a todos los caracteres con código ASCII entre 0 y 31.

Ejemplo #1 Ejemplo de addcslashes()

<?php
$escapado = addcslashes($no_escapado, "\0..\37!@\177..\377");
?>

Ver también

  • stripcslashes() - Desmarca la cadena marcada con addcslashes
  • stripslashes() - Quita las barras de un string con comillas escapadas
  • addslashes() - Escapa un string con barras invertidas
  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • quotemeta() - Escapa meta caracteres


Escapa un string con barras invertidas

  • « addcslashes
  • bin2hex »
  • PHP Manual
  • Funciones de strings
  • Escapa un string con barras invertidas

addslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

addslashes — Escapa un string con barras invertidas

Descripción

addslashes ( string $str ) : string

Devuelve un string con barras invertidas delante de los caracteres que necesitan ser escapados. Estos caracteres son la comilla simple ('), comilla doble ("), barra invertida (\) y NUL (el byte null).

Un ejemplo del uso de addslashes() es cuando se introducen datos en un string que es evaluado por PHP. Por ejemplo, si O'Reilly se almacena en $str, es necesario escapar $str. (p.ej. eval("echo '".addslashes($str)."';"); )

Para escapar parámetros de bases de datos, deberían usarse funciones de escape específicas de cada SGBD por razones de seguridad (p.ej. mysqli_real_escape_string() para MySQL o pg_escape_literal(), pg_escape_string() para PostgreSQL). Los SGBD poseen una especificación de escape diferente para identificadores (p.ej. Nombre de tabla, nombre de campo) que para parámetros. Algunos SGBD como PostgreSQL proporcionan una función es escape de identificadores, pg_escape_identifier(), pero no todos los SGBD proporcionan una API de escape de identificadores. Si este es el caso, consulte el manual del sistema de base de datos para el método apropiado de escape.

Si un SGBD no posee una función de escape y dicho SGBD usa \ para escapar caracteres especiales, podría ser posible usar esta función únicamente cuando este método de escape es adecuado para la base de datos. Por favor, observe que el uso de addslashes() para el escape de parámetros de bases de datos puede ser la causa de problemas de seguridad en la mayoría de las bases de datos.

La directiva de PHP magic_quotes_gpc estaba activada (on) por defecto antes de PHP 5.4, y básicamente ejecutaba la función addslashes() en todos los datos GET, POST y COOKIE. No utilizar addslashes() en las cadenas que ya se han escapado con magic_quotes_gpc ya que se hará un doble escape. La función get_magic_quotes_gpc() podría ser útil para comprobar esto.

Parámetros

str

El string a escapar.

Valores devueltos

Devuelve un string escapado.

Ejemplos

Ejemplo #1 Un ejemplo de addslashes()

<?php
$str = "Is your name O'Reilly?";

// Outputs: Is your name O\'Reilly?
echo addslashes($str);
?>

Ver también

  • stripcslashes() - Desmarca la cadena marcada con addcslashes
  • stripslashes() - Quita las barras de un string con comillas escapadas
  • addcslashes() - Escapa una cadena al estilo de C
  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • quotemeta() - Escapa meta caracteres
  • get_magic_quotes_gpc() - Obtiene el valor actual de configuración de magic_quotes_gpc


Convierte datos binarios en su representación hexadecimal

  • « addslashes
  • chop »
  • PHP Manual
  • Funciones de strings
  • Convierte datos binarios en su representación hexadecimal

bin2hex

(PHP 4, PHP 5, PHP 7, PHP 8)

bin2hex — Convierte datos binarios en su representación hexadecimal

Descripción

bin2hex ( string $str ) : string

Devuelve una cadena ASCII que contiene la representación hexadecimal de str. La conversión se realiza byte a byte, con los 4 bits superiores primero.

Parámetros

str

Un string.

Valores devueltos

Devuelve la representación hexadecimal de la cadena dada.

Ver también

  • hex2bin() - Decodifica una cadena binaria codificada hexadecimalmente
  • pack() - Empaqueta información a una cadena binaria


Alias de rtrim

  • « bin2hex
  • chr »
  • PHP Manual
  • Funciones de strings
  • Alias de rtrim

chop

(PHP 4, PHP 5, PHP 7, PHP 8)

chop — Alias de rtrim()

Descripción

Esta función es un alias de: rtrim().

Notas

Nota:

El comportamiento de la función chop() no es el mismo que el de la función chop() de Perl, que elimina el último caracter de la cadena.


Devuelve un caracter específico

  • « chop
  • chunk_split »
  • PHP Manual
  • Funciones de strings
  • Devuelve un caracter específico

chr

(PHP 4, PHP 5, PHP 7, PHP 8)

chr — Devuelve un caracter específico

Descripción

chr ( int $ascii ) : string

Devuelve una cadena de un caracter que contiene el carácter especificado por ascii

Esta función complementa a ord().

Parámetros

ascii

El código ASCII.

Valores devueltos

Devuelve el carácter especificado.

Ejemplos

Ejemplo #1 chr() Ejemplo

<?php
$str = "La cadena termina en un escape: ";
$str .= chr(27); /* añade un carácter de escape al final de  $str */

/* A menudo esto es más útil */

$str = sprintf("TLa cadena termina en un escape: %c", 27);
?>

Ver también

  • sprintf() - Devuelve un string formateado Devuelve una cadena con formato con un formato de %c
  • ord()
  • Una » ASCII-tabla


Divide una cadena en trozos más pequeños

  • « chr
  • convert_cyr_string »
  • PHP Manual
  • Funciones de strings
  • Divide una cadena en trozos más pequeños

chunk_split

(PHP 4, PHP 5, PHP 7, PHP 8)

chunk_split — Divide una cadena en trozos más pequeños

Descripción

chunk_split ( string $body , int $chunklen = 76 , string $end = "\r\n" ) : string

Puede ser utilizado para dividir una cadena en trozos más pequeños, lo que es útil, por ejemplo, para convertir la salida de la función base64_encode() y hacer que coincida con la semántica del RFC 2045. Inserta la cadena end cada chunklen caracteres.

Parámetros

body

La cadena que será fragmentada.

chunklen

La longitud del trozo.

end

La secuencia de final de línea.

Valores devueltos

Devuelve la cadena fragmentada.

Ejemplos

Ejemplo #1 Ejemplo de chunk_split()

<?php
// formatea $datos usando la semántica del RFC 2045
$nueva_cadena = chunk_split(base64_encode($datos));
?>

Ver también

  • str_split() - Convierte un string en un array
  • explode() - Divide un string en varios string
  • split() - Divide una cadena en una matriz mediante una expresión regular
  • wordwrap() - Ajusta un string hasta un número dado de caracteres
  • » RFC 2045


Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico

  • « chunk_split
  • convert_uudecode »
  • PHP Manual
  • Funciones de strings
  • Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico

convert_cyr_string

(PHP 4, PHP 5, PHP 7)

convert_cyr_string — Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico

Descripción

convert_cyr_string ( string $str , string $from , string $to ) : string

Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico

Parámetros

str

Cadena que será convertida

from

Fuente del juego de caracteres cirílicos, como un único caracter.

to

Objetivo o destino del juego de caracteres cirílicos, como un único caracter.

Los caracteres admitidos son:

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

Valores devueltos

Devuelve la cadena convertida.

Notas

Nota: Esta función es segura binariamente.

Ver también

  • mb_convert_encoding() - Convierte una codificación de caracteres
  • iconv() - Convierte un string a la codificación de caracteres indicada


Descodifica una cadena codificada mediante uuencode

  • « convert_cyr_string
  • convert_uuencode »
  • PHP Manual
  • Funciones de strings
  • Descodifica una cadena codificada mediante uuencode

convert_uudecode

(PHP 5, PHP 7, PHP 8)

convert_uudecode — Descodifica una cadena codificada mediante uuencode

Descripción

convert_uudecode ( string $data ) : string

convert_uudecode() descodifica una cadena codificada mediante uuencode.

Parámetros

data

Los datos codificados mediante uuencode.

Valores devueltos

Devuelve los datos descodificados como una cadena o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de convert_uudecode()

<?php
/* Can you imagine what this will print? :) */
echo convert_uudecode("+22!L;W9E(%!(4\"$`\n`");
?>

Ver también

  • convert_uuencode() - Codificar mediante uuencode una cadena


Codificar mediante uuencode una cadena

  • « convert_uudecode
  • count_chars »
  • PHP Manual
  • Funciones de strings
  • Codificar mediante uuencode una cadena

convert_uuencode

(PHP 5, PHP 7, PHP 8)

convert_uuencode — Codificar mediante uuencode una cadena

Descripción

convert_uuencode ( string $data ) : string

convert_uuencode() codifica una cadena usando el algoritmo uuencode.

Uuencode traduce todas las cadenas (incluyendo las binarias) a caracteres imprimibles, haciéndolas seguras para transmisiones de red. Los datos codificados de esta forma son aproximadamente un 35% más grandes que el original.

Parámetros

data

Los datos a codificar.

Valores devueltos

Devuelve los datos codificados mediante uuencode o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de convert_uuencode()

<?php
$cadena = "prueba\ntexto texto\r\n";

echo convert_uuencode($cadena);
?>

Ver también

  • convert_uudecode() - Descodifica una cadena codificada mediante uuencode
  • base64_encode() - Codifica datos con MIME base64


Devuelve información sobre los caracteres usados en una cadena

  • « convert_uuencode
  • crc32 »
  • PHP Manual
  • Funciones de strings
  • Devuelve información sobre los caracteres usados en una cadena

count_chars

(PHP 4, PHP 5, PHP 7, PHP 8)

count_chars — Devuelve información sobre los caracteres usados en una cadena

Descripción

count_chars ( string $string , int $mode = 0 ) : mixed

Cuenta el número de apariciones de cada byte-value (0..255) en string y lo devuelve de varias maneras.

Parámetros

string

La cadena a examinar

mode

Ver los valores a retornar.

Valores devueltos

Dependiendo de mode count_chars() devuelve uno de los siguientes:

  • 0 - un array con el byte-value como clave y la frecuencia de cada uno como valor.
  • 1 - Como el 0, pero listando únicamente los byte-values con frecuencia superior a cero.
  • 2 - Como el 0, pero listando únicamente los byte-values con frecuencia igual a 0.
  • 3 - devuelve una cadena que contiene todos los caracteres únicos.
  • 4 - devuelve una cadena que contiene todos los caracteres no utilizados.

Ejemplos

Ejemplo #1 count_chars() example

<?php
$data = "Two Ts and one F.";

foreach (count_chars($data, 1) as $i => $val) {
   echo "Se ha encontrado $val instancia (s) de \"" , chr($i) , "\" en la cadena.\n";
}
?>

El resultado del ejemplo sería:

Hubo 4  instancia(s) de " " en la cadena.
Hubo 1  instancia(s) de "." en la cadena.
Hubo 1  instancia(s) de "F" en la cadena.
Hubo 2  instancia(s) de "T" en la cadena.
Hubo 1  instancia(s) de "a" en la cadena.
Hubo 1  instancia(s) de "d" en la cadena.
Hubo 1  instancia(s) de "e" en la cadena.
Hubo 2  instancia(s) de "n" en la cadena.
Hubo 2  instancia(s) de "o" en la cadena.
Hubo 1  instancia(s) de "s" en la cadena.
Hubo 1  instancia(s) de "w" en la cadena.

Ver también

  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • substr_count() - Cuenta el número de apariciones del substring


Calcula el polinomio crc32 de una cadena

  • « count_chars
  • crypt »
  • PHP Manual
  • Funciones de strings
  • Calcula el polinomio crc32 de una cadena

crc32

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

crc32 — Calcula el polinomio crc32 de una cadena

Descripción

crc32 ( string $str ) : int

Genera el polinomio de comprobación de redundancia cíclica de 32 bits de longitud de str. Este valor se usa por lo general para validar la integridad de los datos transmitidos.

Advertencia

Dado que el tipo integer de PHP es con signo, muchas comprobaciones de suma de crc32 resultarán en números enteros negativos en plataformas de 32 bits. Aunque en instalaciones de 64 bits, todos los resultados de crc32() serán enteros positivos.

Por lo tanto, es necesario usar el formateador "%u" de sprintf() o printf() para obtener la representación de cadena de la comprobación de suma de crc32() sin signo en formato decimal.

Para una representación hexadecimal de la comprobación de suma se puede usar el formateador "%x" de sprintf() o printf() , o las funciones de conversión de dechex(), en donde se ha de tener cuidado en ambos casos de convertir el resultado de crc32() a un entero sin signo.

Las instalaciones de 64 bits también devuelven enteros negativos para resultados de valores mayores que los considerados, aunque rompería la conversión a hexadecimal ya que los valores negativos tendrían un índice 0xFFFFFFFF######## extra. Ya que las representaciones hexadecimales parecen ser el caso de uso más común, hemos decidido no deshacernos de ellas incluso si rompe la comparación decimal directa en alrededor del 59% de los casos donde se convierten de 32 a 64 bits.

Mirando atrás, el tener una función que devolvía un entero quizás no era la mejor idea y el devolver una representación de cadena hexadecimal de inmediato (como lo hace, p.ej., md5()) podría haber sido un plan mejor con el que comenzar.

Para una solución más portable se podría considerar también el hash() genérico. hash("crc32b", $str) devolverá la misma cadena que str_pad(dechex(crc32($str)), 8, '0', STR_PAD_LEFT).

Parámetros

str

Los datos.

Valores devueltos

Devuelve la suma de verificación CRC32 de str como un integer.

Ejemplos

Ejemplo #1 Mostrar una suma de verificación crc32

Este ejemplo muestro cómo imprimir una suma de verificación convertida con la función printf():

<?php
$suma = crc32("El veloz murcielago hindu comia feliz cardillo y kiwi.");
printf("%u\n", $suma);
?>

Ver también

  • hash() - Generar un valor hash (resumen de mensaje)
  • md5() - Calcula el 'hash' md5 de un string
  • sha1() - Calcula el 'hash' sha1 de un string


Hash de cadenas de un sólo sentido

  • « crc32
  • echo »
  • PHP Manual
  • Funciones de strings
  • Hash de cadenas de un sólo sentido

crypt

(PHP 4, PHP 5, PHP 7, PHP 8)

crypt — Hash de cadenas de un sólo sentido

Descripción

crypt ( string $str , string $salt = ? ) : string

crypt() devolverá el hash de un string utilizando el algoritmo estándar basado en DES de Unix o algoritmos alternativos que puedan estar disponibles en el sistema.

El parámetro salt es opcional. Sin embargo, crypt() crea una contraseña débil sin salt. PHP 5.6 o posterior emiten un error de nivel E_NOTICE sin él. Asegúrese de especificar una sal lo suficientemente fuerte para mayor seguridad.

password_hash() utiliza un hash fuerte, genera una sal fuerte, y aplica los redondeos necesarios automáticamente. password_hash() es una envoltura simple de crypt() compatible con los hash de contraseñas existentes. Se aconseja el uso de password_hash().

Algunos sistemas operativos soportan más de un tipo de hash. De hecho, a veces el algoritmo estándar basado en DES es sustituído por un algoritmo basado en MD5. El tipo de hash se dispara mediante el argumento salt. Antes de la versión 5.3, PHP determinaba los algoritmos disponibles durante la instalación, basándose en la función crypt() del sistema. Si no se proporciona una sal, PHP autogenerará o una sal estándar de dos caracteres (DES), o una de doce caracteres (MD5), dependiendo de la disponibilidad de la función crypt() de MD5. PHP establece una constante llamada CRYPT_SALT_LENGTH la cual indica la sal de mayor longitud permitida por los hash disponibles.

La función crypt() estándar basada en DES devuelve la sal como los primeros dos caracteres de la salida. También utiliza solamente los primeros ocho caracteres de str, por lo que cadenas más largas que empiecen con los mismos ocho caracteres, generarán el mismo resultado (cuando se utiliza la misma sal).

En sistemas donde la función crypt() soporta múltiples tipos de hash, las siguientes contantes se establecen en 0 o 1, dependiendo de que si el tipo dado está disponible:

  • CRYPT_STD_DES - Hash estándar basado en DES con un salt de dos caracteres del alfabeto "./0-9A-Za-z". Utilizar caracteres no válidos en el salt causará que crypt() falle.
  • CRYPT_EXT_DES - Hash extendido basado en DES. El "salt" es un string de 9 caracteres que consiste en un guión bajo seguido de 4 bytes del conteo de iteraciones y 4 bytes del salt. Estos están codificados como caracteres imprimibles, 6 bits por caracter, por lo menos, el carácter significativo primero. Los valores del 0 al 63 son codificados como "./0-9A-Za-z". Utilizar caracteres no válidos en el salt causará que crypt() falle.
  • CRYPT_MD5 - Hash MD5 con un salt de doce caracteres comenzando con $1$
  • CRYPT_BLOWFISH - Hash con Blowfish con un salt como sigue: "$2a$", "$2x$" o "$2y$", un parámetro de coste de dos dígitos, "$", y 22 caracteres del alfabeto "./0-9A-Za-z". Utilizar caracteres fuera de este rango en el salt causará que crypt() devuelva una cadena de longitud cero. El parámetro de coste de dos dígitos es el logaritmo en base 2 de la cuenta de la iteración del algoritmo hach basado en Blowfish subyacente, y debe estar en el rango 04-31; los valores fuera de este rango causarán que crypt() falle. Las versiones de PHP anteriores a 5.3.7 únicamente admitían "$2a$" como el prefijo para salt: PHP 5.3.7 introdujo los nuevos prefijos para corregir un problema de seguridad en la implementación de Blowfish. Por favor, consulte » este documento para detalles copletos de la corrección de seguridad, pero para resumir, los desarrolladores que se oriente por PHP 5.3.7 y posteriores deberían usar "$2y$" en vez de "$2a$".
  • CRYPT_SHA256 - Hash SHA-256 con un salt de dieciséis caracteres prefijado con $5$. Si el strig del salt inicia con 'rounds=<N>$', el valor numérico de N se utiliza para indicar cuantas veces el bucle del hash se debe ejecutar, muy similar al parámetro de costo en Blowfish. El número de rondas por defecto es 5000, hay un mínimo de 1000 y un máximo de 999,999,999. Cualquier selección de N por fuera de este rango será truncada al límite más cercano.
  • CRYPT_SHA512 - Hash SHA-512 con un salt de dieciséis caracteres prefijado con $6$. Si el strig del salt inicia con 'rounds=<N>$', el valor numérico de N se utiliza para indicar cuantas veces el bucle del hash se debe ejecutar, muy similar al parámetro de costo en Blowfish. El número de rondas por defecto es 5000, hay un mínimo de 1000 y un máximo de 999,999,999. Cualquier selección de N por fuera de este rango será truncada al límite más cercano.

Nota:

A partir de PHP 5.3.0, PHP contiene su propia implementación y la utilizará si el sistema carece de soporte para uno o varios de los algoritmos.

Parámetros

str

El string al que realizarle el hash.

Precaución

El uso del algoritmo CRYPT_BLOWFISH resultará en que el parámetro str sea truncado a una longitud máxima de 72 caracteres.

salt

Un string opcional de salt para la base del hash. Si no se proporciona, el comportamiento se define por la aplicación del algoritmo y puede conducir a resultados inesperados.

Valores devueltos

Devuelve un string con el hash o un string que es más corto que 13 caracteres y que se garantiza que difiere del salt en caso de fallo.

Advertencia

Cuando se validan contraseñas, se debería usar una función de comparación de strings que no sea vulnerable a ataques de temporización para comparar la salida de crypt() con el hash conocido anteriormente. PHP 5.6 y siguientes proporcionan hash_equals() para este propósito.

Historial de cambios

Versión | Descripción
5.6.5 | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.6 devolvía incorrectamente un hash DES.
5.6.0 | Se emite una advertencia de seguridad E_NOTICE si se omite salt.
5.5.21 | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.5 (y ramificaciones anteriores) devolvía incorrectamente un hash DES.
5.3.7 | Se añadieron los modos de Blowfish $2x$ y $2y$ para tratar con ataques de bit alto potenciales.
5.3.2 | Agregado el crypt SHA-256 y SHA-512 basado en la » implementación de Ulrich Drepper.
5.3.2 | Corregido el comportamiento de Blowfish sobre rondas no válidas para devolver el string "failure" ("*0" or "*1"), en lugar de caer al DES.
5.3.0 | PHP ahora contiene su propia implementación de los algoritmos MD5, DES estándar, DES extendido y Blowfish y los utilizará si el sistema carece de soporte para uno o varios de los algoritmos.

Ejemplos

Ejemplo #1 crypt() examples

<?php
$hashed_password = crypt('mypassword'); // dejar que el salt se genera automáticamente

/* Se deben pasar todos los resultados de crypt() como el salt para la comparación de una
   contraseña, para evitar problemas cuando diferentes algoritmos hash son utilizados. (Como
   se dice arriba, el hash estándar basado en DES utiliza un salt de 2
   caracteres, pero el hash basado en MD5 utiliza 12.) */
if (hash_equals($hashed_password, crypt($user_input, $hashed_password))) {
   echo "¡Contraseña verificada!";
}
?>

Ejemplo #2 Using crypt() with htpasswd

<?php
// Establece la contraseña
$password = 'mypassword';

// Obtiene el hash, dejando que el salt sea generado be automáticamente
$hash = crypt($password);
?>

Ejemplo #3 Using crypt() with different hash types

<?php
/* Estas sales son solamente ejemplos, y no deberían usarse textualmente en su código.
   Debería generar una sal distinta correctamente formada para cada contraseña.
*/
if (CRYPT_STD_DES == 1) {
    echo 'Standard DES: ' . crypt('rasmuslerdorf', 'rl') . "\n";
}

if (CRYPT_EXT_DES == 1) {
    echo 'Extended DES: ' . crypt('rasmuslerdorf', '_J9..rasm') . "\n";
}

if (CRYPT_MD5 == 1) {
    echo 'MD5:          ' . crypt('rasmuslerdorf', '$1$rasmusle$') . "\n";
}

if (CRYPT_BLOWFISH == 1) {
    echo 'Blowfish:     ' . crypt('rasmuslerdorf', '$2a$07$usesomesillystringforsalt$') . "\n";
}

if (CRYPT_SHA256 == 1) {
    echo 'SHA-256:      ' . crypt('rasmuslerdorf', '$5$rounds=5000$usesomesillystringforsalt$') . "\n";
}

if (CRYPT_SHA512 == 1) {
    echo 'SHA-512:      ' . crypt('rasmuslerdorf', '$6$rounds=5000$usesomesillystringforsalt$') . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Standard DES: rl.3StKT.4T8M
Extended DES: _J9..rasmBYk8r9AiWNc
MD5:          $1$rasmusle$rISCgZzpwk3UhDidwXvin0
Blowfish:     $2a$07$usesomesillystringfore2uDLvp1Ii2e./U9C8sBjqp8I90dH6hi
SHA-256:      $5$rounds=5000$usesomesillystri$KqJWpanXZHKq2BOB43TSaYhEWsQ1Lr5QNyPCDH/Tp.6
SHA-512:      $6$rounds=5000$usesomesillystri$D4IrlXatmP7rx3P3InaxBeoomnAihCKRVQP22JZ6EY47Wc6BkroIuUUBOov1i.S5KPgErtP/EN5mcO.ChWQW21

Notas

Nota: No hay función de descifrado, ya que crypt() utiliza un algoritmo de un solo sentido.

Ver también

  • hash_equals() - Comparación de strings segura contra ataques de temporización
  • password_hash() - Crea un hash de contraseña
  • md5() - Calcula el 'hash' md5 de un string
  • La extensión Mcrypt
  • La página man de la función crypt de Unix para más información


Muestra una o más cadenas

  • « crypt
  • explode »
  • PHP Manual
  • Funciones de strings
  • Muestra una o más cadenas

echo

(PHP 4, PHP 5, PHP 7, PHP 8)

echo — Muestra una o más cadenas

Descripción

echo ( string $arg1 , string $... = ? ) : void

Muestra todos los parámetros. No se pospone ningua nueva línea adicional.

echo no es realmente una función (es una construcción del lenguaje), por lo que no se requiere el uso de paréntesis con él. echo (a diferencia de otras construcciones del lenguaje) no se comporta como una función, es decir no siempre se puede usar en el contexto de una función. Además, si se quiere pasar más de un parámetro a echo, éstos no deben estar entre paréntesis.

echo también posee una sintaxis abreviada, donde se puede poner el símbolo igual justo después de la etiqueta de apertura de PHP. Antes de PHP 5.4.0, este tipo de sintaxis abreviada únicamente funciona con la opción de configuración short_open_tag activada.

I have <?=$foo?> foo.

Parámetros

arg1

El parámetro a mostrar.

...

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplos de echo

<?php
echo "Hola mundo";

echo "Esto abarca
multiple líneas. Los saltos de línea también
se mostrarán";

echo "Esto abarca\nmúltiples líneas. Los saltos de línea también\nse mostrarán.";

echo "Para escapar caracteres se hace \"así\".";

// Se pueden usar variables dentro de una sentencia echo
$foo = "foobar";
$bar = "barbaz";

echo "foo es $foo"; // foo es foobar

// También se pueden usar arrays
$baz = array("valor" => "foo");

echo "Esto es {$baz['valor']} !"; // Esto es foo !

// Si se utilizan comillas simples, se mostrará el nombre de la variable, no su valor
echo 'foo es $foo'; // foo es $foo

// Si no usan otros caracteres, se puede utilizar echo para mostrar el valor de las variables.
echo $foo;          // foobar
echo $foo,$bar;     // foobarbarbaz

// Las cadenas pueden ser pasadas individualmente como varios argumentos o
// concatenadas como un único argumento
echo 'Esta ', 'cadena ', 'está ', 'hecha ', 'con múltiple parámetros.', chr(10);
echo 'Esta ' . 'cadena ' . 'está ' . 'hecha ' . 'con concatenación.' . "\n";

echo <<<END
Aquí se utiliza la sintaxis de "here document" para mostrar
múltiples líneas con interpolación de $variable. Nótese
que el finalizador de here document debe aparecer en una
línea con solamente un punto y coma. ¡Nada de espacios extra!
END;

// Ya que echo no se comporta como una función, el siguiente código no es válido.
($variable) ? echo 'true' : echo 'false';

// Sin embargo, el siguiente código funcionará:
($variable) ? print 'true' : print 'false'; // print también es una construcción, pero
                                            // se comporta como una función, por lo que
                                            // puede usarse en este contexto.
echo $variable ? 'true': 'false'; // dando la vuelta a la declaración
?>

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Sugerencia

Un beneficio de pasar varios argumentos sobre la concatenación en echo es la precedencia del operador punto en PHP. Si se pasan varios argumentos, no serán necesarios paréntesis para forzar la precedencia:

<?php
echo "Sum: ", 1 + 2;
echo "Hello ", isset($name) ? $name : "John Doe", "!";

Con la concatenación, el operador punto tiene mayor precedencia que los operadores de adición y ternario, por lo que se deben utilizar paréntesis para un correcto funcionamiento:

<?php
echo 'Sum: ' . (1 + 2);
echo 'Hello ' . (isset($name) ? $name : 'John Doe') . '!';

Ver también

  • print - Mostrar una cadena
  • printf() - Imprimir una cadena con formato
  • flush() - Vaciar el búfer de salida del sistema
  • Sintaxis de Heredoc


Divide un string en varios string

  • « echo
  • fprintf »
  • PHP Manual
  • Funciones de strings
  • Divide un string en varios string

explode

(PHP 4, PHP 5, PHP 7, PHP 8)

explode — Divide un string en varios string

Descripción

explode ( string $delimiter , string $string , int $limit = PHP_INT_MAX ) : array

Devuelve un array de string, siendo cada uno un substring del parámetro string formado por la división realizada por los delimitadores indicados en el parámetro delimiter.

Parámetros

delimiter

El string delimitador.

string

El string de entrada.

limit

Si el parámetro limit es positivo, el array devuelto contendrá el máximo de limit elementos, y el último elemento contendrá el resto del string.

Si el parámetro limit es negativo, se devolverán todos los componentes a excepción del último -limit.

Si el parámetro limit es cero,se tratará como 1.

Nota:

Aunque implode(), por razones históricas, puede aceptar los parámetros en cualquier orden, explode() no. Debe asegurarse de que el argumento delimiter vaya antes que el argumento string.

Valores devueltos

Devuelve un array de string creados por la división del parámetro string usando los delimitadores indicados en el parámetro delimiter.

Si delimiter es un string vacío (""), explode() devolverá false. Si delimiter contiene un valor que no forma parte del parámetro string y se utiliza un limit negativo, entonces devolverá un array vacío, en caso contrario se devolverá un array que contiene el valor de string.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió soporte para limit negativo.

Ejemplos

Ejemplo #1 Ejemplo de explode()

<?php
// Ejemplo 1
$pizza  = "porción1 porción2 porción3 porción4 porción5 porción6";
$porciones = explode(" ", $pizza);
echo $porciones[0]; // porción1
echo $porciones[1]; // porción2

// Ejemplo 2
$datos = "foo:*:1023:1000::/home/foo:/bin/sh";
list($user, $pass, $uid, $gid, $gecos, $home, $shell) = explode(":", $datos);
echo $user; // foo
echo $pass; // *

?>

Ejemplo #2 Ejemplos de la devolución de explode()

<?php
/*
   Un string que no contiene el delimitador simplemente
   devolverá un array de longitud uno con el string original.
*/
$entrada1 = "hola";
$entrada2 = "hola,qué tal";
var_dump( explode( ',', $entrada1 ) );
var_dump( explode( ',', $entrada2 ) );

?>

El resultado del ejemplo sería:

array(1)
(
    [0] => string(4) "hola"
)
array(2)
(
    [0] => string(4) "hola"
    [1] => string(8) "qué tal"
)

Ejemplo #3 Ejemplos del parámetro limit

<?php
$str = 'uno|dos|tres|cuatro';

// límite positivo
print_r(explode('|', $str, 2));

// líimte negativo (desde PHP 5.1)
print_r(explode('|', $str, -1));
?>

El resultado del ejemplo sería:

Array
(
    [0] => uno
    [1] => dos|tres|cuatro
)
Array
(
    [0] => uno
    [1] => dos
    [2] => tres
)

Notas

Nota: Esta función es segura binariamente.

Ver también

  • preg_split() - Divide un string mediante una expresión regular
  • str_split() - Convierte un string en un array
  • mb_split() - Divide cadenas de caracteres multibyte usando una expresión regular
  • str_word_count() - Devuelve información sobre las palabras utilizadas en un string
  • strtok() - Tokeniza string
  • implode() - Une elementos de un array en un string


Escribir una cadena con formato a una secuencia

  • « explode
  • get_html_translation_table »
  • PHP Manual
  • Funciones de strings
  • Escribir una cadena con formato a una secuencia

fprintf

(PHP 5, PHP 7, PHP 8)

fprintf — Escribir una cadena con formato a una secuencia

Descripción

fprintf ( resource $handle , string $format , mixed $args = ? , mixed $... = ? ) : int

Escribe una cadena producida de acuerdo a format al recurso de secuencia especificado por handle.

Parámetros

handle

Resource que apunta a un fichero del sitema que normalmente es creado usando fopen().

format

Vea sprintf() para una descripción de format.

args

...

Valores devueltos

Devuelve la longitud de la cadena impresa.

Ejemplos

Ejemplo #1 fprintf(): enteros con relleno de ceros

<?php
if (!($da = fopen('fecha.txt', 'w')))
    return;

fprintf($da, "%04d-%02d-%02d", $anyo, $mes, $dia);
// escribe la fecha en formato ISO a fecha.txt
?>

Ejemplo #2 fprintf(): dando formato a valores monetarios

<?php
if (!($da = fopen('monetario.txt', 'w')))
    return;

$dinero1 = 68.75;
$dinero2 = 54.35;
$dinero = $dinero1 + $dinero2;
// echo $dinero producirá la salida "123.1";
$long = fprintf($da, '%01.2f', $dinero);
// escribe "123.10" en monetario.txt

echo "se escribieron $long bytes a monetario.txt";
// usar el valor de retorno para determinar cuántos bytes se escribieron
?>

Ver también

  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • vsprintf() - Devuelve una cadena con formato
  • number_format() - Formatear un número con los millares agrupados


Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities

  • « fprintf
  • hebrev »
  • PHP Manual
  • Funciones de strings
  • Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities

get_html_translation_table

(PHP 4, PHP 5, PHP 7, PHP 8)

get_html_translation_table — Devuelve la tabla de traducción utilizada por htmlspecialchars() y htmlentities()

Descripción

get_html_translation_table ( int $table = HTML_SPECIALCHARS , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = "UTF-8" ) : array

get_html_translation_table() devolverá la tabla de traducción que es utilizada internamente para htmlspecialchars() y htmlentities().

Nota:

Los caracteres especiales se pueden codificar de varias maneras. Por ejemplo, " puede ser codificado como &quot;, &#34; o &#x22. get_html_translation_table() devuelve sólo la forma utilizada por htmlspecialchars() y htmlentities().

Parámetros

table

Qué tabla devolver. Puede ser HTML_ENTITIES o HTML_SPECIALCHARS).

flags

Una máscara de bits de uno o más de los siguientes indicadores especificando qué comillas contendrá la tabla, así como para qué tipo de documento será la tabla. El valor por defecto es ENT_COMPAT | ENT_HTML401.

Constantes disponibles para flags
Nombre de la constante | Descripción
ENT_COMPAT | La tabla contendrá entidades para comillas dobles, pero no para comillas simples.
ENT_QUOTES | La tabla contendrá entidades para comillas dobles y simples.
ENT_NOQUOTES | La tabla no contendrá entidades para comillas simples ni para comillas dobles.
ENT_HTML401 | Tabla para HTML 4.01.
ENT_XML1 | Tabla para XML 1.
ENT_XHTML | Tabla para XHTML.
ENT_HTML5 | Tabla para HTML 5.

encoding

La codificación a usar. Si se omite, el valor por defecto para este argumento es ISO-8859-1 en versiones de PHP anteriores a 5.4.0, y UTF-8 a partir de PHP 5.4.0 en adelante.

Están soportados los siguientes juegos de caracteres:

Juegos de caracteres soportados
Juego de caracteres | Alias | Descripción
ISO-8859-1 | ISO8859-1 | Europeo occidental, Latin-1.
ISO-8859-5 | ISO8859-5 | Juego de caracteres cirílicos poco usado (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | Europeo occidental, Latin-9. Añade el signo de euro, y letras del francés y finlandés ausentes en Latin-1 (ISO-8859-1).
UTF-8 | Unicode de 8 bit multibyte compatible con ASCII.
cp866 | ibm866, 866 | Juego de caracteres cirílico específico de DOS.
cp1251 | Windows-1251, win-1251, 1251 | Juego de caracteres cirílico específico de Windows.
cp1252 | Windows-1252, 1252 | Juego de caracteres específico de Windows para Europa occidental.
KOI8-R | koi8-ru, koi8r | Ruso.
BIG5 | 950 | Chino tradicional, usado principalmente en Taiwán.
GB2312 | 936 | Chino simplificado, juego de caracteres estándar nacional.
BIG5-HKSCS | Big5 con extensiones de Hong Kong, chino tradicional.
Shift_JIS | SJIS, SJIS-win, cp932, 932 | Japonés
EUC-JP | EUCJP, eucJP-win | Japonés
MacRoman | Juego de caracteres que fue utilizado por Mac OS.
'' Un string vacío activa la detección desde la codificación del script (Zend multibyte), default_charset y la actual configuración regional (véase nl_langinfo() y setlocale()), en este orden. No se recomienda.

Nota: No se reconoce cualquier otro juego de caracteres. Será utilizada en su lugar la codificación por defecto y se emitirá una advertencia.

Valores devueltos

Devuelve la tabla de traducción como un array, con los caracteres originales como claves y las entidades como valores.

Historial de cambios

Versión | Descripción
5.4.0 | El valor por defecto para el parámetro encoding se cambió a UTF-8.
5.4.0 | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
5.3.4 | Se añadió el parámetro encoding.

Ejemplos

Ejemplo #1 Ejemplo de tabla de traducción

<?php
var_dump(get_html_translation_table(HTML_ENTITIES, ENT_QUOTES | ENT_HTML5));
?>

El resultado del ejemplo sería algo similar a:

array(1510) {
  ["
"]=>
  string(9) "&NewLine;"
  ["!"]=>
  string(6) "&excl;"
  ["""]=>
  string(6) "&quot;"
  ["#"]=>
  string(5) "&num;"
  ["$"]=>
  string(8) "&dollar;"
  ["%"]=>
  string(8) "&percnt;"
  ["&"]=>
  string(5) "&amp;"
  ["'"]=>
  string(6) "&apos;"
  // ...
}

Ver también

  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • html_entity_decode() - Convierte todas las entidades HTML a sus caracteres correspondientes


Convierte texto hebreo lógico a texto visual

  • « get_html_translation_table
  • hebrevc »
  • PHP Manual
  • Funciones de strings
  • Convierte texto hebreo lógico a texto visual

hebrev

(PHP 4, PHP 5, PHP 7, PHP 8)

hebrev — Convierte texto hebreo lógico a texto visual

Descripción

hebrev ( string $hebrew_text , int $max_chars_per_line = 0 ) : string

Convierte el texto hebreo lógico a texto visual.

La función trata de evitar el corte de las palabras.

Parámetros

hebrew_text

Una cadena Hebrea de entrada.

max_chars_per_line

Este parámetro opcional indica el número máximo de caracteres por línea que será devuelta.

Valores devueltos

Devuelve la cadena visual.

Ver también

  • hebrevc() - Convertir texto de hebreo lógico a texto visual con conversión de línea nueva


Convertir texto de hebreo lógico a texto visual con conversión de línea nueva

  • « hebrev
  • hex2bin »
  • PHP Manual
  • Funciones de strings
  • Convertir texto de hebreo lógico a texto visual con conversión de línea nueva

hebrevc

(PHP 4, PHP 5, PHP 7)

hebrevc — Convertir texto de hebreo lógico a texto visual con conversión de línea nueva

Descripción

hebrevc ( string $hebrew_text , int $max_chars_per_line = 0 ) : string

Esta función es parecida a hebrev() con la diferencia que esta convierte líneas nuevas (\n) a "<br>\n".

Esta función intenta evitar la separación de palabras.

Parámetros

hebrew_text

Una cadena de entrada en hebreo.

max_chars_per_line

Este parámetro es opcional, e indica el número máximo de caracteres por línea que serán devueltos.

Valores devueltos

Devuelve la cadena visual.

Ver también

  • hebrev() - Convierte texto hebreo lógico a texto visual


Decodifica una cadena binaria codificada hexadecimalmente

  • « hebrevc
  • html_entity_decode »
  • PHP Manual
  • Funciones de strings
  • Decodifica una cadena binaria codificada hexadecimalmente

hex2bin

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

hex2bin — Decodifica una cadena binaria codificada hexadecimalmente

Descripción

hex2bin ( string $data ) : string

Decodifica una cadena binaria codificada hexadecimalmente.

Precaución

Esta función NO convierte un número hexadecimal en un número binario. Esto se puede realizar usando la función base_convert().

Parámetros

data

La representación hexadecimal de datos.

Valores devueltos

Devuelve la representación binaria de los datos dados o false en caso de error.

Errores/Excepciones

Si la cadena de entrada hexadecimal tiene una longitud impar o es una cadena hexadecimal no válida se emite un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.5.1 | Se emite una advertencia si el string de entrada es un string hexadecimal no válido.
5.4.4 | Se emite una advertencia si la cadena de entrada tiene una longitud impar. En PHP 5.4.0 la cadena era aceptada de forma silenciosa, pero el último byte era truncado.

Ejemplos

Ejemplo #1 Ejemplo de hex2bin()

<?php
$hex = hex2bin("6578616d706c65206865782064617461");
var_dump($hex);
?>

El resultado del ejemplo sería algo similar a:

string(16) "example hex data"

Ver también

  • bin2hex() - Convierte datos binarios en su representación hexadecimal
  • unpack() - Desempaqueta datos de una cadena binaria


Convierte todas las entidades HTML a sus caracteres correspondientes

  • « hex2bin
  • htmlentities »
  • PHP Manual
  • Funciones de strings
  • Convierte todas las entidades HTML a sus caracteres correspondientes

html_entity_decode

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

html_entity_decode — Convierte todas las entidades HTML a sus caracteres correspondientes

Descripción

html_entity_decode ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = ini_get("default_charset") ) : string

html_entity_decode() es el opuesto de htmlentities() en el sentido de que convierte todas las entidades HTML del string a sus caracteres correspondientes.

Para ser más precisos, esta función decodifica todas las entidades (incluyendo todas las entidades numéricas) que a) sean necesariamente válidas para el tipo de documento elegido — es decir, para XML, esta función no decodifica las entidades con nombres que podrían estar definidas en algunos DTD — y b) aquellos caracteres que están en el conjunto de caracteres codificado asociado con la codificación elegida y que están permitidos en el tipo de documento elegido. Todas las demás entidades se dejan tal cual.

Parámetros

string

El string de entrada.

flags

Una máscara de bits de uno o más de los siguientes indicadores, los cuales especifican cómo manejar las comillas y el tipo de documento utilizado. El valor predeterminado es ENT_COMPAT | ENT_HTML401.

Constantes disponibles para flags
Nombre de constante | Descripción
ENT_COMPAT | Convertirá las comillas dobles y sólo dejará las comillas simples.
ENT_QUOTES | Convertirá tanto las comillas dobles como las simples.
ENT_NOQUOTES | Dejará tanto las comillas dobles como las simples sin convertir.
ENT_HTML401 | Manejar el código como HTML 4.01.
ENT_XML1 | Manejar el código como XML 1.
ENT_XHTML | Manejar el código como XHTML.
ENT_HTML5 | Manejar el código como HTML 5.

encoding

Un argumento opcional que define la codificación empleada al convertir caracteres.

Si se omite, el valor predeterminado de encoding varía según la versión de PHP en uso. En PHP 5.6 y posterior, la opción de configuración default_charset se emplea como valor predeterminado. PHP 5.4 y 5.5 utilizarán UTF-8 como valor predeterminado. Las versiones anteriores de PHP emplean ISO-8859-1.

Aunque este argumento es técnicamente opcional, se recomienda especificar el valor correcto para el código si se utiliza PHP 5.5 o anterior, o si la opción de configuración default_charset podría estar establecida incorrectamente para la entrada dada.

Están soportados los siguientes juegos de caracteres:

Juegos de caracteres soportados
Juego de caracteres | Alias | Descripción
ISO-8859-1 | ISO8859-1 | Europeo occidental, Latin-1.
ISO-8859-5 | ISO8859-5 | Juego de caracteres cirílicos poco usado (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | Europeo occidental, Latin-9. Añade el signo de euro, y letras del francés y finlandés ausentes en Latin-1 (ISO-8859-1).
UTF-8 | Unicode de 8 bit multibyte compatible con ASCII.
cp866 | ibm866, 866 | Juego de caracteres cirílico específico de DOS.
cp1251 | Windows-1251, win-1251, 1251 | Juego de caracteres cirílico específico de Windows.
cp1252 | Windows-1252, 1252 | Juego de caracteres específico de Windows para Europa occidental.
KOI8-R | koi8-ru, koi8r | Ruso.
BIG5 | 950 | Chino tradicional, usado principalmente en Taiwán.
GB2312 | 936 | Chino simplificado, juego de caracteres estándar nacional.
BIG5-HKSCS | Big5 con extensiones de Hong Kong, chino tradicional.
Shift_JIS | SJIS, SJIS-win, cp932, 932 | Japonés
EUC-JP | EUCJP, eucJP-win | Japonés
MacRoman | Juego de caracteres que fue utilizado por Mac OS.
'' Un string vacío activa la detección desde la codificación del script (Zend multibyte), default_charset y la actual configuración regional (véase nl_langinfo() y setlocale()), en este orden. No se recomienda.

Nota: No se reconoce cualquier otro juego de caracteres. Será utilizada en su lugar la codificación por defecto y se emitirá una advertencia.

Valores devueltos

Devuelve el string descodificado.

Historial de cambios

Versión | Descripción
5.6.0 | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
5.4.0 | La codificación predeterminada se cambió de ISO-8859-1 a UTF-8.
5.4.0 | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.

Ejemplos

Ejemplo #1 Decodificación de entidades HTML

<?php
$orig = "I'll \"walk\" the <b>dog</b> now";

$a = htmlentities($orig);

$b = html_entity_decode($a);

echo $a; // I'll &quot;walk&quot; the &lt;b&gt;dog&lt;/b&gt; now

echo $b; // I'll "walk" the <b>dog</b> now
?>

Notas

Nota:

Puede que se pregunte por qué trim(html_entity_decode('&nbsp;')); no reduce el string a un string vacío. Esto es porque la entidad '&nbsp;' no es el código ASCII 32 (el cual es eliminado por trim()), sino el código ASCII 160 (0xa0) en la codificación ISO 8859-1.

Ver también

  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • get_html_translation_table() - Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
  • urldecode() - Decodifica una cadena cifrada como URL


Convierte todos los caracteres aplicables a entidades HTML

  • « html_entity_decode
  • htmlspecialchars_decode »
  • PHP Manual
  • Funciones de strings
  • Convierte todos los caracteres aplicables a entidades HTML

htmlentities

(PHP 4, PHP 5, PHP 7, PHP 8)

htmlentities — Convierte todos los caracteres aplicables a entidades HTML

Descripción

htmlentities ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = ini_get("default_charset") , bool $double_encode = true ) : string

Esta función es idéntica a htmlspecialchars() en todos los aspectos, excepto que con htmlentities(), todos los caracteres que tienen su equivalente HTML son convertidos a estas entidades.

Si en su lugar se desea decodificar (lo inverso), se puede utilizar html_entity_decode().

Parámetros

string

El string de entrada.

flags

Una máscara de bits de uno o más de los siguientes indicadores, los cuales especifican como manejar las comillas, secuencias de unidad de código inválidas y el tipo de documento utilizado. Por defecto es ENT_COMPAT | ENT_HTML401.

Constantes disponibles para flags
Nombre de la constante | Descripción
ENT_COMPAT | Convertirá las comillas dobles y deja solo las comillas simples.
ENT_QUOTES | Convertirá tanto las comillas dobles como las simples.
ENT_NOQUOTES | Dejará tanto las comillas dobles como las simples sin convertir.
ENT_IGNORE | Descartar silenciosamente unidades de secuencia de código no válidas en lugar de devolver un string vacío. El uso de este indicador se desaconseja debido a que » podría tener implicaciones de seguridad.
ENT_SUBSTITUTE | Reemplazar las secuencias de unidad de código inválidas con un Caracter Unicode de Reemplazo U+FFFD (UTF-8) o &#FFFD; (no UTF-8) en lugar de devolver un string vacío.
ENT_DISALLOWED | Reemplazar los puntos de código no válidos para el tipo de documento dado con un Caracter de Reemplazo Unicode U+FFFD (UTF-8) o &#FFFD; (no UTF-8) en lugar de dejarlos tal cual. Esto puede ser útil, por ejemplo, para asegurar la formación correcta de documentos XML con contenido externo incrustado.
ENT_HTML401 | Manejar el código como HTML 4.01.
ENT_XML1 | Manejar el código como XML 1.
ENT_XHTML | Manejar el código como XHTML.
ENT_HTML5 | Manejar el código como HTML 5.

encoding

Un argumento opcional que define la codificación empleada al convertir caracteres.

Si se omite, el valor predeterminado de encoding varía según la versión de PHP en uso. En PHP 5.6 y posterior, la opción de configuración default_charset se emplea como valor predeterminado. PHP 5.4 y 5.5 utilizarán UTF-8 como valor predeterminado. Las versiones anteriores de PHP emplean ISO-8859-1.

Aunque este argumento es técnicamente opcional, se recomienda especificar el valor correcto para el código si se utiliza PHP 5.5 o anterior, o si la opción de configuración default_charset podría estar establecida incorrectamente para la entrada dada.

Están soportados los siguientes juegos de caracteres:

Juegos de caracteres soportados
Juego de caracteres | Alias | Descripción
ISO-8859-1 | ISO8859-1 | Europeo occidental, Latin-1.
ISO-8859-5 | ISO8859-5 | Juego de caracteres cirílicos poco usado (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | Europeo occidental, Latin-9. Añade el signo de euro, y letras del francés y finlandés ausentes en Latin-1 (ISO-8859-1).
UTF-8 | Unicode de 8 bit multibyte compatible con ASCII.
cp866 | ibm866, 866 | Juego de caracteres cirílico específico de DOS.
cp1251 | Windows-1251, win-1251, 1251 | Juego de caracteres cirílico específico de Windows.
cp1252 | Windows-1252, 1252 | Juego de caracteres específico de Windows para Europa occidental.
KOI8-R | koi8-ru, koi8r | Ruso.
BIG5 | 950 | Chino tradicional, usado principalmente en Taiwán.
GB2312 | 936 | Chino simplificado, juego de caracteres estándar nacional.
BIG5-HKSCS | Big5 con extensiones de Hong Kong, chino tradicional.
Shift_JIS | SJIS, SJIS-win, cp932, 932 | Japonés
EUC-JP | EUCJP, eucJP-win | Japonés
MacRoman | Juego de caracteres que fue utilizado por Mac OS.
'' Un string vacío activa la detección desde la codificación del script (Zend multibyte), default_charset y la actual configuración regional (véase nl_langinfo() y setlocale()), en este orden. No se recomienda.

Nota: No se reconoce cualquier otro juego de caracteres. Será utilizada en su lugar la codificación por defecto y se emitirá una advertencia.

double_encode

Cuando se desactiva double_encode, PHP no codificará las entidades html existentes. El valor por defecto es convertir todo.

Valores devueltos

Devuelve el string codificado.

Si el string de entrada contiene una secuencia de unidad de código no válida dentro de encoding, será devuelto un string vacío, a menos que se definan los indicadores ENT_IGNORE o ENT_SUBSTITUTE.

Historial de cambios

Versión | Descripción
5.6.0 | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
5.4.0 | El valor por defecto del parámetro encoding se cambió a UTF-8.
5.4.0 | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
5.3.0 | Se añadió la constante ENT_IGNORE.
5.2.3 | Se añadió el parámetro double_encode.

Ejemplos

Ejemplo #1 Un ejemplo de htmlentities()

<?php
$str = "A 'quote' is <b>bold</b>";

// Produce: A 'quote' is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str);

// Produce: A &#039;quote&#039; is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str, ENT_QUOTES);
?>

Ejemplo #2 Uso de ENT_IGNORE

<?php
$str = "\x8F!!!";

// Produce un string vacío
echo htmlentities($str, ENT_QUOTES, "UTF-8");

// Produce "!!!"
echo htmlentities($str, ENT_QUOTES | ENT_IGNORE, "UTF-8");
?>

Ver también

  • html_entity_decode() - Convierte todas las entidades HTML a sus caracteres correspondientes
  • get_html_translation_table() - Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • nl2br() - Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
  • urlencode() - Codifica como URL una cadena


Convierte entidades HTML especiales de nuevo en caracteres

  • « htmlentities
  • htmlspecialchars »
  • PHP Manual
  • Funciones de strings
  • Convierte entidades HTML especiales de nuevo en caracteres

htmlspecialchars_decode

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

htmlspecialchars_decode — Convierte entidades HTML especiales de nuevo en caracteres

Descripción

htmlspecialchars_decode ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 ) : string

Esta función es la opuesta a htmlspecialchars(). Convierte entidades HTML especiales de nuevo en los caracteres.

Las entidades convertidas son: &amp;, &quot; (cuando ENT_NOQUOTES no se ha establecido), &#039; (cuando ENT_QUOTES se ha establecido), &lt; y &gt;.

Parámetros

string

El string a decodificar.

flags

Una máscara de bits de uno o más de los siguientes indicadores, que especifican cómo manejar las comillas y que tipo de documento utilizar. Por defecto es ENT_COMPAT | ENT_HTML401.

Contantes disponibles para flags
Nombre de la Constante | Descripción
ENT_COMPAT | Convertirá las comillas dobles y dejará solamente las comillas sencillas.
ENT_QUOTES | Convertirá tanto las comillas dobles como las sencillas.
ENT_NOQUOTES | Dejará tanto las comillas dobles como las sencillas sin convertir.
ENT_HTML401 | Maneja el código como HTML 4.01.
ENT_XML1 | Maneja el código como XML 1.
ENT_XHTML | Maneja el código como XHTML.
ENT_HTML5 | Maneja el código como HTML 5.

Valores devueltos

Devuelve el string decodificado.

Historial de cambios

Versión | Descripción
5.4.0 | Fueron agregadas las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.

Ejemplos

Ejemplo #1 Un ejemplo de htmlspecialchars_decode()

<?php
$str = "<p>this -&gt; &quot;</p>\n";

echo htmlspecialchars_decode($str);

// tenga en cuenta que aquí las comillas no se convierten
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

El resultado del ejemplo sería:

<p>this -> "</p>
<p>this -> &quot;</p>

Ver también

  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • html_entity_decode() - Convierte todas las entidades HTML a sus caracteres correspondientes
  • get_html_translation_table() - Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities


Convierte caracteres especiales en entidades HTML

  • « htmlspecialchars_decode
  • implode »
  • PHP Manual
  • Funciones de strings
  • Convierte caracteres especiales en entidades HTML

htmlspecialchars

(PHP 4, PHP 5, PHP 7, PHP 8)

htmlspecialchars — Convierte caracteres especiales en entidades HTML

Descripción

htmlspecialchars ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = ini_get("default_charset") , bool $double_encode = true ) : string

Ciertos caracteres tienen un significado especial en HTML y deben ser representados por entidades HTML si se desea preservar su significado. Esta función devuelve un string con estas conversiones realizadas. Si se requiere que todas las subcadenas de entrada tengan asociadas entidades con nombre para que sean traducidas, use htmlentities() en su lugar.

Si el string de entrada pasado a esta función y el documento final comparten el mismo conjunto de carcteres, esta función es suficiente para preparar entradas para su inclusión en la mayoría de los contextos de un documento HTML. Sin embargo, si la entrada puede representar caracteres que no están codificados en el conjunto de caracteres del documento final, y es necesario conservar dichos caracteres (tales como números o entidades con nombre), esta función y htmlentities() (la cual solamente codifica subcadenas que tienen equivalentes de entidades con nombre) podrían ser insuficientes. Se podria usar mb_encode_numericentity() en su lugar.

Traducciones realizadas
Carácter | Sustitución
& (et) | &amp;
" (comilla doble) | &quot; excepto cuando ENT_NOQUOTES está activado
' (single quote) | &#039; (para ENT_HTML401) o &apos; (para ENT_XML1, ENT_XHTML o ENT_HTML5), pero solamente cuando ENT_QUOTES está activado
< (menor que) | &lt;
> (mayor que) | &gt;

Parámetros

string

El string a convertir.

flags

Una máscara de bits de una o más de los siguientes indicadores, los cuales especifican cómo manejar las comillas, las secuencias de unidad de código inválidas y el tipo de documento utilizado. El valor predeterminado es ENT_COMPAT | ENT_HTML401.

Constantes disponibles para flags
Nombre de la constante | Descripción
ENT_COMPAT | Convertirá las comillas dobles y sólo dejará las comillas simples.
ENT_QUOTES | Convertirá tanto las comillas dobles como las simples.
ENT_NOQUOTES | Dejará tanto las comillas dobles como las simples sin convertir.
ENT_IGNORE | Descartar silenciosamente unidades de secuencia de código no válidas en lugar de devolver un string vacío. No se recomienda el uso de este indicador, ya que » puede tener implicaciones de seguridad.
ENT_SUBSTITUTE | Reemplazar las secuencias de unidad de código inválidas con un Carácter de Reemplazo Unicode U+FFFD (UTF-8) o &#xFFFD; (no UTF-8) en lugar de devolver un string vacío.
ENT_DISALLOWED | Reemplazar los puntos de código no válidos para el tipo de documento dado con un Carácter de Reemplazo Unicode U+FFFD (UTF-8) o &#xFFFD; (no UTF-8) en lugar de dejarlos tal cual. Esto puede ser útil, por ejemplo, para asegurar que los documentos XML estén bien formados con contenido externo incrustado.
ENT_HTML401 | Maneja el código como HTML 4.01.
ENT_XML1 | Maneja el código como XML 1.
ENT_XHTML | Maneja el código como XHTML.
ENT_HTML5 | Maneja el código como HTML 5.

encoding

Un argumento opcional que define la codificación empleada al convertir caracteres.

Si se omite, el valor predeterminado de encoding varía según la versión de PHP en uso. En PHP 5.6 y posterior, la opción de configuración default_charset se emplea como valor predeterminado. PHP 5.4 y 5.5 utilizarán UTF-8 como valor predeterminado. Las versiones anteriores de PHP emplean ISO-8859-1.

Aunque este argumento es técnicamente opcional, se recomienda especificar el valor correcto para el código si se utiliza PHP 5.5 o anterior, o si la opción de configuración default_charset podría estar establecida incorrectamente para la entrada dada.

Para el propósito de ésta función, los juegos de caracteres ISO-8859-1, ISO-8859-15, UTF-8, cp866, cp1251, cp1252 y KOI8-R son realmente equivalentes, siempre y cuando el string sea válido para la codificación, ya que los caracteres afectados por htmlspecialchars() ocupan las mismas posiciones en todas estas codificaciones.

Están soportados los siguientes juegos de caracteres:

Juegos de caracteres soportados
Juego de caracteres | Alias | Descripción
ISO-8859-1 | ISO8859-1 | Europeo occidental, Latin-1.
ISO-8859-5 | ISO8859-5 | Juego de caracteres cirílicos poco usado (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | Europeo occidental, Latin-9. Añade el signo de euro, y letras del francés y finlandés ausentes en Latin-1 (ISO-8859-1).
UTF-8 | Unicode de 8 bit multibyte compatible con ASCII.
cp866 | ibm866, 866 | Juego de caracteres cirílico específico de DOS.
cp1251 | Windows-1251, win-1251, 1251 | Juego de caracteres cirílico específico de Windows.
cp1252 | Windows-1252, 1252 | Juego de caracteres específico de Windows para Europa occidental.
KOI8-R | koi8-ru, koi8r | Ruso.
BIG5 | 950 | Chino tradicional, usado principalmente en Taiwán.
GB2312 | 936 | Chino simplificado, juego de caracteres estándar nacional.
BIG5-HKSCS | Big5 con extensiones de Hong Kong, chino tradicional.
Shift_JIS | SJIS, SJIS-win, cp932, 932 | Japonés
EUC-JP | EUCJP, eucJP-win | Japonés
MacRoman | Juego de caracteres que fue utilizado por Mac OS.
'' Un string vacío activa la detección desde la codificación del script (Zend multibyte), default_charset y la actual configuración regional (véase nl_langinfo() y setlocale()), en este orden. No se recomienda.

Nota: No se reconoce cualquier otro juego de caracteres. Será utilizada en su lugar la codificación por defecto y se emitirá una advertencia.

double_encode

Cuando double_encode se desactiva, PHP no codificará las entidades HTML existentes. El valor predeterminado es convertirlo todo.

Valores devueltos

El string convertido.

Si el string de entrada contiene una secuencia de unidad de código no válida en encoding, devolverá un string vacío, a menos que cualquiera de los indicadores ENT_IGNORE o ENT_SUBSTITUTE estén establecidos.

Historial de cambios

Versión | Descripción
5.6.0 | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
5.4.0 | El valor predeterminado del parámetro encoding se cambió a UTF-8.
5.4.0 | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
5.3.0 | Se añadió la constante ENT_IGNORE.
5.2.3 | Se añadió el parámetro double_encode.

Ejemplos

Ejemplo #1 Ejemplo de htmlspecialchars()

<?php
$nuevo = htmlspecialchars("<a href='test'>Test</a>", ENT_QUOTES);
echo $nuevo; // &lt;a href=&#039;test&#039;&gt;Test&lt;/a&gt;
?>

Notas

Nota:

Se ha de tener en cuenta que esta función no traduce nada más de lo que aparece en la lista de arriba. Para la traducción completa de entidades, véase htmlentities().

Nota:

En caso de valores de flags ambiguos, se aplican las siguintes reglas:

  • Cuando no están presentes ENT_COMPAT, ENT_QUOTES ni ENT_NOQUOTES, el valor predeterminado es ENT_NOQUOTES.
  • Cuando están presentes más de una de ENT_COMPAT, ENT_QUOTES o ENT_NOQUOTES, ENT_QUOTES toma la mayor precedencia, seguido de ENT_COMPAT.
  • Cuando no están presentes ENT_HTML401, ENT_HTML5, ENT_XHTML ni ENT_XML1, el valor predeterminado es ENT_HTML401.
  • Cuando están presentes más de una de ENT_HTML401, ENT_HTML5, ENT_XHTML, ENT_XML1 o ENT_HTML5 toma la mayor precedencia, seguido de ENT_XHTML, ENT_XML1 y ENT_HTML401.
  • Cuando están presentes más de una de ENT_DISALLOWED, ENT_IGNORE o ENT_SUBSTITUTE, ENT_IGNORE toma la mayor precedencia, seguido de ENT_SUBSTITUTE.

Ver también

  • get_html_translation_table() - Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
  • htmlspecialchars_decode() - Convierte entidades HTML especiales de nuevo en caracteres
  • strip_tags() - Retira las etiquetas HTML y PHP de un string
  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • nl2br() - Inserta saltos de línea HTML antes de todas las nuevas líneas de un string


Une elementos de un array en un string

  • « htmlspecialchars
  • join »
  • PHP Manual
  • Funciones de strings
  • Une elementos de un array en un string

implode

(PHP 4, PHP 5, PHP 7, PHP 8)

implode — Une elementos de un array en un string

Descripción

implode ( string $glue , array $pieces ) : string
implode ( array $pieces ) : string

Une elementos de un array en un string con glue (pegamento).

Nota:

Por razones históricas implode() puede aceptar parámetros en cualquier orden. Para mantener una consistencia respecto a explode(), sin embargo, es obsoleto no utilizar el orden documentado de los argumentos.

Parámetros

glue

Por defecto es un string vacío.

pieces

El array de strings a ser usados por implode.

Valores devueltos

Devuelve un string que contiene la representación de todos los elementos del array en el mismo orden, con el string 'glue' entre cada elemento.

Historial de cambios

Versión | Descripción
7.4.0 | Pasar el parámetro glue después de el parámetro pieces (es decir, sin utilizar el orden documentado de los parámetros) es obsoleto.

Ejemplos

Ejemplo #1 Ejemplo de implode()

<?php

$array = array('apellido', 'email', 'teléfono');
$separado_por_comas = implode(",", $array);

echo $separado_por_comas; // apellido,email,teléfono

// Devuelve un string vacío si se usa un array vacío:
var_dump(implode('hola', array())); // string(0) ""

?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • explode() - Divide un string en varios string
  • preg_split() - Divide un string mediante una expresión regular
  • http_build_query() - Generar una cadena de consulta codificada estilo URL


Alias de implode

  • « implode
  • lcfirst »
  • PHP Manual
  • Funciones de strings
  • Alias de implode

join

(PHP 4, PHP 5, PHP 7, PHP 8)

join — Alias de implode()

Descripción

Esta función es un alias de: implode().


Pasa a minúscula el primer caracter de un string

  • « join
  • levenshtein »
  • PHP Manual
  • Funciones de strings
  • Pasa a minúscula el primer caracter de un string

lcfirst

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

lcfirst — Pasa a minúscula el primer caracter de un string

Descripción

lcfirst ( string $str ) : string

Devuelve un string con el primer caracter de str en minúscula si ese caracter es alfabético.

Tener en cuenta que 'alfabético' está determinado por la configuración regional actual. Por ejemplo, en la configuración regional por defecto "C" caracteres como la a con diéresis (ä) no serán convertidos.

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve el string resultante.

Ejemplos

Ejemplo #1 Ejemplo de lcfirst()

<?php
$foo = 'HelloWorld';
$foo = lcfirst($foo);             // helloWorld

$bar = 'HELLO WORLD!';
$bar = lcfirst($bar);             // hELLO WORLD!
$bar = lcfirst(strtoupper($bar)); // hELLO WORLD!
?>

Ver también

  • ucfirst() - Convierte el primer caracter de una cadena a mayúsculas
  • strtolower() - Convierte un string a minúsculas
  • strtoupper() - Convierte un string a mayúsculas
  • ucwords() - Convierte a mayúsculas el primer caracter de cada palabra de una cadena


Cálculo de la distancia Levenshtein entre dos strings

  • « lcfirst
  • localeconv »
  • PHP Manual
  • Funciones de strings
  • Cálculo de la distancia Levenshtein entre dos strings

levenshtein

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

levenshtein — Cálculo de la distancia Levenshtein entre dos strings

Descripción

levenshtein ( string $str1 , string $str2 ) : int
levenshtein ( string $str1 , string $str2 , int $cost_ins , int $cost_rep , int $cost_del ) : int

La distancia Levenshtein se define como el número mínimo de caracteres que se tienen que sustituir, insertar o borrar para transformar str1 en str2. La complejidad del algoritmo es O(m*n), donde n y m son la longitud de str1 y str2 (bastante bueno en comparación con similar_text(), la cual es O(max(n,m)**3), pero sigue siendo costoso).

En su forma más simple la función tomará sólo los dos strings como parámetros y calculará sólo el número de operaciones de insertar, reemplazar y eliminar, necesarias para transformar str1 en str2.

Una segunda variante tomará tres parámetros adicionales que definen el costo de las operaciones de insertar, reemplazar y eliminar. Esto es más general y adaptable que la primera variante, pero no tan eficiente.

Parámetros

str1

Uno de los strings a ser evaluados para la distancia Levenshtein.

str2

Uno de los strings a ser evaluados para la distancia Levenshtein.

cost_ins

Define el costo de inserción.

cost_rep

Define el costo de reemplazo.

cost_del

Define el costo de eliminación.

Valores devueltos

Esta función devuelve la distancia Levenshtein entre los dos strings argumentos ó -1, si uno de los strings argumentos es mayor que el límite de 255 caracteres.

Ejemplos

Ejemplo #1 Ejemplo de levenshtein()

<?php
// palabra de entrada mal escrita
$input = 'carrrot';

// array de palabras contra las cuales verificar
$words  = array('apple','pineapple','banana','orange',
                'radish','carrot','pea','bean','potato');

// no se ha encontrado la distancia más corta, aun
$shortest = -1;

// bucle a través de las palabras para encontrar la más cercana
foreach ($words as $word) {

    // calcula la distancia entre la palabra de entrada
    // y la palabra actual
    $lev = levenshtein($input, $word);

    // verifica por una coincidencia exacta
    if ($lev == 0) {

        // la palabra más cercana es esta (coincidencia exacta)
        $closest = $word;
        $shortest = 0;

        // salir del bucle, se ha encontrado una coincidencia exacta
        break;
    }

    // si esta distancia es menor que la siguiente distancia
    // más corta o si una siguiente palabra más corta aun no se ha encontrado
    if ($lev <= $shortest || $shortest < 0) {
        // establece la coincidencia más cercana y la distancia más corta
        $closest  = $word;
        $shortest = $lev;
    }
}

echo "Input word: $input\n";
if ($shortest == 0) {
    echo "Exact match found: $closest\n";
} else {
    echo "Did you mean: $closest?\n";
}

?>

El resultado del ejemplo sería:

Input word: carrrot
Did you mean: carrot?

Ver también

  • soundex() - Calcula la clave soundex de un string
  • similar_text() - Calcula la similitud entre dos strings
  • metaphone() - Calcula la clave metaphone de un string


Obtener información sobre el formato numérico

  • « levenshtein
  • ltrim »
  • PHP Manual
  • Funciones de strings
  • Obtener información sobre el formato numérico

localeconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

localeconv — Obtener información sobre el formato numérico

Descripción

localeconv ( ) : array

Devuelve una matriz asociativa que contiene información de los formatos numérico y monetario, localizados.

Valores devueltos

localeconv() devuelve información basada en la localidad actual, tal y como haya sido definida mediante setlocale(). La matriz asociativa que devuelve contiene los siguientes campos:

Elemento de la matriz | Descripción
decimal_point | Caracter de punto decimal
thousands_sep | Separador de miles
grouping | Matriz que contiene agrupaciones numéricas
int_curr_symbol | Símbolo internacional de moneda (i.e. USD)
currency_symbol | Símbolo local de moneda (i.e. $)
mon_decimal_point | Caracter de punto decimal monetario
mon_thousands_sep | Separador de miles monetario
mon_grouping | Matriz que contiene agrupaciones de moneda
positive_sign | Signo para valores positivos
negative_sign | Signo para valores negativos
int_frac_digits | Dígitos fraccionarios internacionales
frac_digits | Dígitos fraccionarios locales
p_cs_precedes | true si currency_symbol precede un valor positivo, false si lo sucede
p_sep_by_space | true si un espacio separa currency_symbol de un valor positivo, false de lo contrario
n_cs_precedes | true si currency_symbol precede un valor negativo, false si lo sucede
n_sep_by_space | true si un espacio separa currency_symbol de un valor negativo, false de lo contrario
p_sign_posn
  • 0 - Paréntesis rodean la cantidad y currency_symbol
  • 1 - La cadena de signo precede la cantidad y currency_symbol
  • 2 - La cadena de signo sucede la cantidad y currency_symbol
  • 3 - La cadena de signo precede inmediatamente currency_symbol
  • 4 - La cadena de signo sucede inmediatamente currency_symbol
n_sign_posn
  • 0 - Paréntesis rodean la cantidad y currency_symbol
  • 1 - La cadena de signo precede la cantidad y currency_symbol
  • 2 - La cadena de signo sucede la cantidad y currency_symbol
  • 3 - La cadena de signo precede inmediatamente currency_symbol
  • 4 - La cadena de signo sucede inmediatamente currency_symbol

Los valores de p_sign_posn y n_sign_posn contienen una cadena de opciones de formato. Cada número representa una de las condiciones listadas anteriormente.

Los campos de agrupamiento contienen matrices que definen el modo en que los números deben ser agrupados. Por ejemplo, el campo de agrupamiento monetario para la localidad nl_NL (en modo UTF-8 con el signo de euro), tendría una matriz de 2 elementos con los valores 3 y 3. Entre más alto sea el índice dentro de la matriz, lo más lejos hacia la izquierda se encuentra el agrupamiento. Si un elemento de la matriz es igual a CHAR_MAX, no se realiza ningún agrupamiento posterior. Si un elemento de la matriz es igual a 0, el elemento anterior deberá ser usado.

Ejemplos

Ejemplo #1 Ejemplo de localeconv()

<?php
if (false !== setlocale(LC_ALL, 'nl_NL.UTF-8@euro')) {
    $info_localidad = localeconv();
    print_r($info_localidad);
}
?>

El resultado del ejemplo sería:

Array
(
    [decimal_point] => .
    [thousands_sep] =>
    [int_curr_symbol] => EUR
    [currency_symbol] => €
    [mon_decimal_point] => ,
    [mon_thousands_sep] =>
    [positive_sign] =>
    [negative_sign] => -
    [int_frac_digits] => 2
    [frac_digits] => 2
    [p_cs_precedes] => 1
    [p_sep_by_space] => 1
    [n_cs_precedes] => 1
    [n_sep_by_space] => 1
    [p_sign_posn] => 1
    [n_sign_posn] => 2
    [grouping] => Array
        (
        )

    [mon_grouping] => Array
        (
            [0] => 3
            [1] => 3
        )

)

Ver también

  • setlocale() - Establecer la información del localismo


Retira espacios en blanco (u otros caracteres) del inicio de un string

  • « localeconv
  • md5_file »
  • PHP Manual
  • Funciones de strings
  • Retira espacios en blanco (u otros caracteres) del inicio de un string

ltrim

(PHP 4, PHP 5, PHP 7, PHP 8)

ltrim — Retira espacios en blanco (u otros caracteres) del inicio de un string

Descripción

ltrim ( string $str , string $character_mask = ? ) : string

Retira espacios en blanco (u otros caracteres) del inicio de un string.

Parámetros

str

El string de entrada.

character_mask

Se puede también especificar los caracteres que se desean retirar por medio del parámetro character_mask. Simplemente se listan todos los caracteres que se quieren retirar. Con .. se puede especificar un rango de caracteres.

Valores devueltos

Esta función devuelve un string con los espacios en blanco retirados del inicio de str. Sin el segundo parámetro, ltrim() retirará estos caracteres:

  • " " (ASCII 32 (0x20)), un espacio ordinario.
  • "\t" (ASCII 9 (0x09)), un tabulador.
  • "\n" (ASCII 10 (0x0A)), una nueva línea (line feed).
  • "\r" (ASCII 13 (0x0D)), un retorno de carro.
  • "\0" (ASCII 0 (0x00)), el byte NULL.
  • "\x0B" (ASCII 11 (0x0B)), un tabulador vertical.

Ejemplos

Ejemplo #1 Ejemplo de uso de ltrim()

<?php

$text = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = ltrim($text);
var_dump($trimmed);

$trimmed = ltrim($text, " \t.");
var_dump($trimmed);

$trimmed = ltrim($hello, "Hdle");
var_dump($trimmed);

// retira los caracteres ASCII de control al inicio de $binary
// (de 0 a 31 inclusive)
$clean = ltrim($binary, "\x00..\x1F");
var_dump($clean);

?>

El resultado del ejemplo sería:

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(30) "These are a few words :) ...  "
string(30) "These are a few words :) ...  "
string(7) "o World"
string(15) "Example string
"

Ver también

  • trim() - Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
  • rtrim() - Retira los espacios en blanco (u otros caracteres) del final de un string


Calcula el resumen criptográfico md5 de un archivo dado

  • « ltrim
  • md5 »
  • PHP Manual
  • Funciones de strings
  • Calcula el resumen criptográfico md5 de un archivo dado

md5_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

md5_file — Calcula el resumen criptográfico md5 de un archivo dado

Descripción

md5_file ( string $filename , bool $raw_output = false ) : string

Calcula el resumen criptográfico MD5 del archivo especificado por el parámetro filename usando el » Algoritmo de resumen de mensajes MD5 de RSA Data Security, Inc., y devuelve ese resumen. El resumen criptográfico es un número hexadecimal de 32 caracteres.

Parámetros

nombre_archivo

El nombre de archivo

raw_output

Cuando es true, devuelve el resumen en un formato binario primitivo con una longitud de 16.

Valores devueltos

Devuelve una cadena en caso de éxito, false de lo contrario.

Historial de cambios

Versión | Descripción
5.1.0 | Se modificó la función para usar la API de secuencias. Esto quiere decir que se puede usar con envolturas, como md5_file('http://example.com/..')

Ejemplos

Ejemplo #1 Ejemplo de uso de md5_file()

<?php
$file = 'php-5.3.0alpha2-Win32-VC9-x64.zip';

echo 'MD5 file hash of ' . $file . ': ' . md5_file($file);
?>

Ver también

  • md5() - Calcula el 'hash' md5 de un string
  • sha1_file() - Calcula el hash sha1 de un archivo
  • crc32() - Calcula el polinomio crc32 de una cadena


Calcula el 'hash' md5 de un string

  • « md5_file
  • metaphone »
  • PHP Manual
  • Funciones de strings
  • Calcula el 'hash' md5 de un string

md5

(PHP 4, PHP 5, PHP 7, PHP 8)

md5 — Calcula el 'hash' md5 de un string

Advertencia

No se recomienda utilizar esta función para contraseñas seguras debido a la naturaleza rápida de este algoritmo de «hashing». Véase las Preguntas más frecuentes de «hash» de contraseñas para más detalles y el empleo de mejores prácticas.

Descripción

md5 ( string $str , bool $raw_output = false ) : string

Calcula el hash MD5 de str utilizando el » Algoritmo MD5 Message-Digest de RSA Data Security, Inc. y devuelve ese hash.

Parámetros

str

El string.

raw_output

Si se establece el raw_output opcional en true, el resumen md5 será devuelto en formato binario sin tratar con una longitud de 16.

Valores devueltos

Devuelve el hash como un número hexadecimal de 32 caracteres.

Ejemplos

Ejemplo #1 Ejemplo de md5()

<?php
$str = 'apple';

if (md5($str) === '1f3870be274f6c49b3e31a0c6728957f') {
    echo "Would you like a green or red apple?";
}
?>

Ver también

  • md5_file() - Calcula el resumen criptográfico md5 de un archivo dado
  • sha1_file() - Calcula el hash sha1 de un archivo
  • crc32() - Calcula el polinomio crc32 de una cadena
  • sha1() - Calcula el 'hash' sha1 de un string
  • hash() - Generar un valor hash (resumen de mensaje)
  • crypt() - Hash de cadenas de un sólo sentido
  • password_hash() - Crea un hash de contraseña


Calcula la clave metaphone de un string

  • « md5
  • money_format »
  • PHP Manual
  • Funciones de strings
  • Calcula la clave metaphone de un string

metaphone

(PHP 4, PHP 5, PHP 7, PHP 8)

metaphone — Calcula la clave metaphone de un string

Descripción

metaphone ( string $str , int $phonemes = 0 ) : string

Calcula la clave metaphone de str.

De manera similar a soundex(), metaphone crea la misma clave para palabras que suenan parecido. Es más precisa que soundex() ya que conoce las reglas básicas de la pronunciación del inglés. Las claves generadas por metaphone son de longitud variable.

Metaphone fue desarrollado por Lawrence Philips <lphilips at verity dot com>. Se describe en ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995].

Parámetros

str

El string de entrada.

phonemes

Este parámetro restringe la clave devuelta por metaphone a lo indicado en phonemes en caracteres de longitud. El valor por defecto es 0 lo que significa que no hay restricción

Valores devueltos

Devuelve la clave metaphone un string, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo básico de metaphone()

<?php
var_dump(metaphone('programming'));
var_dump(metaphone('programmer'));
?>

El resultado del ejemplo sería algo similar a:

string(7) "PRKRMNK"
string(6) "PRKRMR"

Ejemplo #2 Utilizando el parámetro phonemes

<?php
var_dump(metaphone('programming', 5));
var_dump(metaphone('programmer', 5));
?>

El resultado del ejemplo sería algo similar a:

string(5) "PRKRM"
string(5) "PRKRM"


Da formato a un número como un string de moneda

  • « metaphone
  • nl_langinfo »
  • PHP Manual
  • Funciones de strings
  • Da formato a un número como un string de moneda

money_format

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

money_format — Da formato a un número como un string de moneda

Descripción

money_format ( string $format , float $number ) : string

money_format() devuelve una versión de number con formato. Esta función se ajusta a la función strfmon() de la librería de C, con la diferencia de que esta aplicación convierte sólo un número a la vez.

Parámetros

format

La especificación del formato se compone de la siguiente secuencia:

  • un caracter %

  • indicadores opcionales

  • ancho de campo opcional

  • precisión a la izquierda opcional

  • precisión a la derecha opcional

  • un caracter de conversión obligatorio

Indicadores

Uno o más de los siguientes indicadores opcionales pueden ser utilizados:

=f

El caracter = seguido de un caracter f (byte único) que se utilizará como el caracter de relleno numérico. El carácter de relleno por defecto es el espacio.

^

Deshabilita el uso de caracteres de agrupamiento (según la definición de la configuración regional actual).

+ o (

Especifica el estilo de formato para los números positivos y negativos. Si se utiliza +, el equivalente de la configuración regional para + y - será usado. Si se utiliza (, las cantidades negativas serán encerradas entre paréntesis. Si no se da ninguna especificación, el valor por defecto es +.

!

Suprime el símbolo de moneda del string producido.

-

Si está presente, hará todos los campos justificados a la izquierda (con relleno a la derecha), contrario al valor por defecto que es para que los campos se justifiquen a la derecha (con relleno a la izquierda).

Ancho de campo

w

Un string de dígito decimal que especifica un ancho mínimo de campo. El campo será justificado a la derecha a menos que el indicador - sea utilizado. El valor por defecto es 0 (cero).

Precisión a la izquierda

#n

El número máximo de dígitos (n) que se espera a la izquierda del caracter decimal (por ejemplo, el punto decimal). Es utilizado generalmente para mantener la salida con formato alineada en las mismas columnas, usando el caracter de relleno si el número de dígitos sea menor que n. Si el número de dígitos real es mayor que n, entonces esta especificación es ignorada.

Si la agrupación no ha sido suprimida mediante el indicador ^, los separadores de agrupamiento serán insertados antes de que los caracteres de relleno (si los hay) sean agregados. Los separadores de agrupamiento no se aplicarán a los caracteres de relleno, aunque el carácter de relleno sea un dígito.

Para asegurar la alineación, cualquier caracter que aparezca antes o después del número en la salida con formato, tales como símbolos de moneda o de signo, son rellenados cuando sea necesario con caracteres de espacio para hacer sus formatos positivos y negativos de una longitud igual.

Precisión a la derecha

.p

Un punto seguido por el número de dígitos (p) después del carácter decimal. Si el valor de p es 0 (cero), el carácter decimal y los dígitos a su derecha serán omitidos. Si no se incluye la precisión al la derecha, el valor por defecto será dictado por la configuración regional actual en uso. La cantidad que se está formateando se redondea al número especificado de dígitos antes de formatearla.

Conversion characters

i

El número se formatea de acuerdo al formato internacional de moneda de la configuración regional (por ejemplo, para la configuración regional de EE.UU.: USD $ 1,234.56).

n

El número se formatea de acuerdo al formato nacional de moneda de la configuración regional (por ejemplo, para la configuración regional de_DE: EU1.234,56).

%

Devuelve el caracter %.

number

El número a ser formateado.

Valores devueltos

Devuelve el string con formato. Los caracteres antes y después del string de formato se devolverán sin cambios. Un number no numérico causa que se devuelva null y se emite un E_WARNING.

Notas

Nota:

La función money_format() sólo está definida si el sistema tiene capacidad strfmon. Por ejemplo, Windows no lo hace, así que money_format() no está definido en Windows.

Nota:

La categoría LC_MONETARY de la configuración regional, afecta el comportamiento de esta función. Utilizar setlocale() para establecer la configuración regional predeterminada apropiada antes de usar esta función.

Ejemplos

Ejemplo #1 Ejemplos de money_format()

Se utilizan diferentes configuraciones regionales y especificaciones de formato para ilustrar el uso de esta función.

<?php

$number = 1234.56;

// muestra el formato internacional para la configuración regional en_US
setlocale(LC_MONETARY, 'en_US');
echo money_format('%i', $number) . "\n";
// USD 1,234.56

// formato nacional italiano con 2 decimales`
setlocale(LC_MONETARY, 'it_IT');
echo money_format('%.2n', $number) . "\n";
// Eu 1.234,56

// utilizando un número negativo
$number = -1234.5672;

// formato nacional US, utilizando () para los números negativos
// y 10 dígitos de precisión a la izquierda
setlocale(LC_MONETARY, 'en_US');
echo money_format('%(#10n', $number) . "\n";
// ($        1,234.57)

// formato similar que el anterior, agregando el uso de 2 dígitos de precisión
// a la derecha y '*' como caracter de relleno
echo money_format('%=*(#10.2n', $number) . "\n";
// ($********1,234.57)

// justificado a la izquierda, con 14 posiciones de ancho, 8 dígitos de
// precisión a la izquierda, 2 de precisión a la derecha, sin caracter de agrupamiento
// y utilizando el formato internacional para la configuración regional de_DE.
setlocale(LC_MONETARY, 'de_DE');
echo money_format('%=*^-14#8.2i', 1234.56) . "\n";
// Eu 1234,56****

// añadir un poco de propaganda antes y después los especificación de conversión
setlocale(LC_MONETARY, 'en_GB');
$fmt = 'The final value is %i (after a 10%% discount)';
echo money_format($fmt, 1234.56) . "\n";
// The final value is  GBP 1,234.56 (after a 10% discount)

?>

Ver también

  • setlocale() - Establecer la información del localismo
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • sprintf() - Devuelve un string formateado
  • printf() - Imprimir una cadena con formato
  • number_format() - Formatear un número con los millares agrupados


Consulta información sobre el idioma y la configuración regional

  • « money_format
  • nl2br »
  • PHP Manual
  • Funciones de strings
  • Consulta información sobre el idioma y la configuración regional

nl_langinfo

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

nl_langinfo — Consulta información sobre el idioma y la configuración regional

Descripción

nl_langinfo ( int $item ) : string

nl_langinfo() se utiliza para acceder elementos individuales de las categorías de la configuración regional. A diferencia de localeconv(), que devuelve todos los elementos, nl_langinfo() permite seleccionar cualquier elemento específico.

Parámetros

item

item puede ser un valor integer del elemento o el nombre de la constante del elemento. La siguiente es una lista de los nombres de las constantes que pueden ser utilizadas para item y su descripción. Algunas de estas constantes pueden no estar definidas o no tienen valor para ciertas configuraciones regionales.

Constantes de nl_langinfo
Constante | Descripción
Constantes de la Categoría LC_TIME
ABDAY_(1-7) | Nombre abreviado del día n-ésimo de la semana.
DAY_(1-7) | Nombre del día n-ésimo de la semana (DAY_1 = domingo).
ABMON_(1-12) | Nombre abreviado del mes n-ésimo del año.
MON_(1-12) | Nombre del mes n-ésimo del año.
AM_STR | String para ante meridiano.
PM_STR | String para post meridiano.
D_T_FMT | String que puede ser usado como el string de formato de strftime() para representar la hora y fecha.
D_FMT | String que puede ser usado como el string de formato de strftime() para representar la fecha.
T_FMT | String que puede ser usado como el string de formato de strftime() para representar la hora.
T_FMT_AMPM | String que puede ser usado como el string de formato de strftime() para representar la hora en formato de 12 horas con el ante/post meridiano.
ERA | Era alterna.
ERA_YEAR | Año en formato de era alterna.
ERA_D_T_FMT | Fecha y hora en formato de era alterna (el string se puede utilizar en strftime()).
ERA_D_FMT | Fecha en formato de era alterna (el string se puede utilizar en strftime()).
ERA_T_FMT | Hora en formato de era alterna (el string se puede utilizar en strftime()).
Constantes de la Categoría LC_MONETARY
INT_CURR_SYMBOL | Símbolo internacional de moneda.
CURRENCY_SYMBOL | Símbolo local de moneda.
CRNCYSTR | El mismo valor que CURRENCY_SYMBOL.
MON_DECIMAL_POINT | Caracter de punto decimal.
MON_THOUSANDS_SEP | Separador de miles (grupos de tres dígitos).
MON_GROUPING | Como el elemento "grouping".
POSITIVE_SIGN | Signo para valores positivos.
NEGATIVE_SIGN | Signo para valores negativos.
INT_FRAC_DIGITS | Dígitos fraccionarios internacionales.
FRAC_DIGITS | Dígitos fraccionarios locales.
P_CS_PRECEDES | Devuelve 1 si CURRENCY_SYMBOL precede a un valor positivo.
P_SEP_BY_SPACE | Devuelve 1 si un espacio separa CURRENCY_SYMBOL de un valor positivo.
N_CS_PRECEDES | Devuelve 1 si CURRENCY_SYMBOL precede a un valor negativo.
N_SEP_BY_SPACE | Devuelve 1 si un espacio separa CURRENCY_SYMBOL de un valor negativo.
P_SIGN_POSN
  • Devuelve 0 si hay paréntesis alrededor de la cantidad y CURRENCY_SYMBOL.
  • Devuelve 1 si el string de signo precede la cantidad y CURRENCY_SYMBOL.
  • Devuelve 2 si el string de signo sigue a la cantidad y CURRENCY_SYMBOL.
  • Devuelve 3 si el string de signo precede inmediatamente al CURRENCY_SYMBOL.
  • Devuelve 4 si el string de signo sigue inmediatamente al CURRENCY_SYMBOL.
N_SIGN_POSN
Constantes de la Categoría LC_NUMERIC
DECIMAL_POINT | Caracter de punto decimal.
RADIXCHAR | Mismo valor que DECIMAL_POINT.
THOUSANDS_SEP | Caracter separador de miles (grupos de tres dígitos).
THOUSEP | Mismo valor que THOUSANDS_SEP.
GROUPING
Constantes de la Categoría LC_MESSAGES
YESEXPR | String de expresión regular para coincidir con la entrada "yes".
NOEXPR | String de expresión regular para coincidir con la entrada "no".
YESSTR | String de salida para "yes".
NOSTR | String de salida para "no".
Constantes de la Categoría LC_CTYPE
CODESET | Devuelve un string con el nombre de la codificación de caracteres.

Valores devueltos

Devuelve el elemento como un string, o false si item no es válido.

Notas

Nota: Esta función no está implementada en plataformas Windows.

Ver también

  • setlocale() - Establecer la información del localismo
  • localeconv() - Obtener información sobre el formato numérico


Inserta saltos de línea HTML antes de todas las nuevas líneas de un string

  • « nl_langinfo
  • number_format »
  • PHP Manual
  • Funciones de strings
  • Inserta saltos de línea HTML antes de todas las nuevas líneas de un string

nl2br

(PHP 4, PHP 5, PHP 7, PHP 8)

nl2br — Inserta saltos de línea HTML antes de todas las nuevas líneas de un string

Descripción

nl2br ( string $string , bool $is_xhtml = true ) : string

Devuelve el parámetro string con un <br /> o <br> insertado antes de cada nueva línea. (\r\n, \n\r, \n y \r).

Parámetros

string

El string de entrada.

is_xhtml

Si utilizar saltos de línea compatibles con XHTML o no.

Valores devueltos

Devuelve el string alterado.

Ejemplos

Ejemplo #1 Usar nl2br()

<?php
echo nl2br("foo no es\n bar");
?>

El resultado del ejemplo sería:

foo no es<br />
 bar

Ejemplo #2 Generar marcado HTML válido utilizando el parámetro is_xhtml

<?php
echo nl2br("Bienvenido\r\nEste es mi documento HTML", false);
?>

El resultado del ejemplo sería:

Bienvenido<br>
Este es mi documento HTML

Ejemplo #3 Varios separadores de nueva línea

<?php
$cadena = "Esto\r\nes\n\runa\ncadena\r";
echo nl2br($cadena);
?>

El resultado del ejemplo sería:

Esto<br />
es<br />
una<br />
cadena<br />

Historial de cambios

Versión | Descripción
5.3.0 | Se agregó el parámetro opcional is_xhtml. Antes de esta versión, siempre se insertaba '<br />'.

Ver también

  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • wordwrap() - Ajusta un string hasta un número dado de caracteres
  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo


Formatear un número con los millares agrupados

  • « nl2br
  • ord »
  • PHP Manual
  • Funciones de strings
  • Formatear un número con los millares agrupados

number_format

(PHP 4, PHP 5, PHP 7, PHP 8)

number_format — Formatear un número con los millares agrupados

Descripción

number_format ( float $number , int $decimals = 0 ) : string
number_format ( float $number , int $decimals = 0 , string $dec_point = "." , string $thousands_sep = "," ) : string

Esta función acepta uno, dos, o cuatro parámetros (no tres):

Si solo se proporciona un parámetro, number será formateado sin decimales, pero con una coma (",") entre cada grupo de millares.

Si se proporcionan dos parámetros, number será formateado con tantos decimales como se hayan definido en decimals colocando un punto (".") delante, y una coma (",") entre cada grupo de millares.

Si se proporcionan los cuatro parámetros, number será formateado con tantos decimales como hayamos definido en decimals, dec_point sustituirá al punto (".") como seperador de los decimales y el separador por defecto de los millares, la coma (","), será sustituida por thousands_sep.

Parámetros

number

El número al que dar formato.

decimals

Establece el número de puntos decimales.

dec_point

Establece el separador para los decimales.

thousands_sep

Establece el separador para los millares.

Valores devueltos

Una versión formateada de number.

Historial de cambios

Versión | Descripción
5.4.0 | Esta función ahora admite múltiples bytes en dec_point y thousands_sep. En versiones anteriors solamente se utilizaba el primer byte de cada separador.

Ejemplos

Ejemplo #1 Ejemplo de number_format()

Por ejemplo, la notación francesa suele utilizar dos decimales, una coma (',') como separador decimal y el espacio (' ') como separador de millares. Esto consigue esto mediante las siguientes líneas:

<?php

$número = 1234.56;

// notación inglesa (por defecto)
$número_formato_inglés = number_format($número);
// 1,235

// notación francesa
$nombre_format_francais = number_format($número, 2, ',', ' ');
// 1 234,56

$número = 1234.5678;

// notación inglesa sin separador de millares
$english_format_number = number_format($número, 2, '.', '');
// 1234.57

?>

Ver también

  • money_format() - Da formato a un número como un string de moneda
  • sprintf() - Devuelve un string formateado
  • printf() - Imprimir una cadena con formato
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato


Convierte el primer byte de un string a un valor entre 0 y 255

  • « number_format
  • parse_str »
  • PHP Manual
  • Funciones de strings
  • Convierte el primer byte de un string a un valor entre 0 y 255

ord

(PHP 4, PHP 5, PHP 7, PHP 8)

ord — Convierte el primer byte de un string a un valor entre 0 y 255

Descripción

ord ( string $string ) : int

Interpreta el valor binario del primer byte de string como un entero sin signo entre 0 y 255.

Si el string está en codificación de byte único, como ASCII, ISO-8859 o Windows 1252, esto es equivalente a devolver la posición del carácter de la tabla de correspondencia del conjunto de caracteres. Sin embargo, observe que esta función no conoce la codificación del string, por lo que nunca identificará un punto de código Unicode en una codificación multibyte tal como UTF-8 o UTF-16.

Esta función complementa a chr().

Parámetros

string

Un carácter.

Valores devueltos

Un entero entre 0 y 255.

Ejemplos

Ejemplo #1 Ejemplo de ord()

<?php
$str = "\n";
if (ord($str) == 10) {
    echo "El primer caracter de \$str es un salto de linea.\n";
}
?>

Ejemplo #2 Examinar los bytes individuales de un string UTF-8

<?php
declare(encoding='UTF-8');
$str = "??";
for ( $pos=0; $pos < strlen($str); $pos ++ ) {
 $byte = substr($str, $pos);
 echo 'El byte ' . $pos . ' de $str tiene el valor ' . ord($byte) . PHP_EOL;
}
?>

El resultado del ejemplo sería:

El byte 0 de $str tiene el valor 240
El byte 1 de $str tiene el valor 159
El byte 2 de $str tiene el valor 144
El byte 3 de $str tiene el valor 152

Ver también

  • chr() - Devuelve un caracter específico
  • An » ASCII-table
  • mb_ord() - Get code point of character


Convierte el string en variables

  • « ord
  • print »
  • PHP Manual
  • Funciones de strings
  • Convierte el string en variables

parse_str

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_str — Convierte el string en variables

Descripción

parse_str ( string $str , array &$arr = ? ) : void

Analiza str como si fuera un string de consulta pasado por medio de un URL y establece variables en el ámbito actual.

Nota:

Para obtener el QUERY_STRING actual, se puede utilizar la variable $_SERVER['QUERY_STRING']. También se puede consultar la sección sobre variables a partir de fuentes externas.

Nota:

La configuración magic_quotes_gpc afecta la salida de esta función, ya que parse_str() usa el mismo mecanismo que PHP utiliza para poblar las variables $_GET, $_POST, etc.

Parámetros

str

El string de entrada.

arr

Si el segundo parámetro arr está presente, es su lugar las variables serán almacenadas en esta variable como elementos de array.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Utilizando parse_str()

<?php
$str = "first=value&arr[]=foo+bar&arr[]=baz";
parse_str($str);
echo $first;  // value
echo $arr[0]; // foo bar
echo $arr[1]; // baz

parse_str($str, $output);
echo $output['first'];  // value
echo $output['arr'][0]; // foo bar
echo $output['arr'][1]; // baz

?>

Ver también

  • parse_url() - Analiza un URL y devuelve sus componentes
  • pathinfo() - Devuelve información acerca de la ruta de un fichero
  • http_build_query() - Generar una cadena de consulta codificada estilo URL
  • get_magic_quotes_gpc() - Obtiene el valor actual de configuración de magic_quotes_gpc
  • urldecode() - Decodifica una cadena cifrada como URL


Mostrar una cadena

  • « parse_str
  • printf »
  • PHP Manual
  • Funciones de strings
  • Mostrar una cadena

print

(PHP 4, PHP 5, PHP 7, PHP 8)

print — Mostrar una cadena

Descripción

print ( string $arg ) : int

Muestra el parámetro arg.

print no es realmente una función (es un constructor de lenguaje) por lo tanto no es necesario usar paréntesis para indicar su lista de argumentos.

Parámetros

arg

Los datos de entrada.

Valores devueltos

Siempre devuelve 1.

Ejemplos

Ejemplo #1 Ejemplos de print

<?php
print("Hola mundo");

print "print() también funciona sin paréntesis.";

print "Esto separa
múltiples líneas. Los saltos de línea también
se mostrarán";

print "Esto separa\nmúltiples líneas. Los salos de línea también\nse mostrarán.";

print "para escapar caracteres se \"hace así\".";

// También se puede usar variables usando print
$foo = "foobar";
$bar = "barbaz";

print "foo es $foo"; // foo es foobar

// También se pueden usar arrays
$bar = array("value" => "foo");

print "Esto es {$bar['value']} !"; // Esto es foo !

// Al usar comillas simples se mostrará el nombre de la variable, no su valor
print 'foo is $foo'; // foo is $foo

// Si no se necesita mostrar otros caracteres, se puede simplemente mostrar variables
print $foo;          // foobar

print <<<END
Este párrafo utiliza la sintaxis "here document" para mostrar
múltiples líneas con la interpolación de $variable. Nótese
que el terminador de here document debe aparecer al final
de la línea con punto y coma y ¡ningún espacio en blanco extra!
END;
?>

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Ver también

  • echo - Muestra una o más cadenas
  • printf() - Imprimir una cadena con formato
  • flush() - Vaciar el búfer de salida del sistema
  • Sintaxis de Heredoc


Imprimir una cadena con formato

  • « print
  • quoted_printable_decode »
  • PHP Manual
  • Funciones de strings
  • Imprimir una cadena con formato

printf

(PHP 4, PHP 5, PHP 7, PHP 8)

printf — Imprimir una cadena con formato

Descripción

printf ( string $format , mixed $args = ? , mixed $... = ? ) : int

Produce una salida de acuerdo con el format.

Parámetros

format

Vea sprintf() para una descripción de format.

args

...

Valores devueltos

Devuelve la longitud de la cadena impresa.

Ver también

  • print - Mostrar una cadena
  • sprintf() - Devuelve un string formateado
  • vprintf() - Muestra una cadena con formato
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • flush() - Vaciar el búfer de salida del sistema


Convierte un string quoted-printable en un string de 8 bits

  • « printf
  • quoted_printable_encode »
  • PHP Manual
  • Funciones de strings
  • Convierte un string quoted-printable en un string de 8 bits

quoted_printable_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

quoted_printable_decode — Convierte un string quoted-printable en un string de 8 bits

Descripción

quoted_printable_decode ( string $str ) : string

Esta función devuelve un string binario de 8 bits que corresponde al string quoted printable decodificado (de acuerdo con el » RFC2045, sección 6.7, no el » RFC2821, sección 4.5.2, así que puntos adicionales no son retirados del principio de línea).

Esta función es similar a imap_qprint(), excepto que no requiere del módulo IMAP para funcionar.

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve el string binario de 8 bits.

Ver también

  • quoted_printable_encode() - Convierte un string de 8 bits en un string quoted-printable


Convierte un string de 8 bits en un string quoted-printable

  • « quoted_printable_decode
  • quotemeta »
  • PHP Manual
  • Funciones de strings
  • Convierte un string de 8 bits en un string quoted-printable

quoted_printable_encode

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

quoted_printable_encode — Convierte un string de 8 bits en un string quoted-printable

Descripción

quoted_printable_encode ( string $str ) : string

Devuelve un string quoted printable creado de acuerdo con su definición en » RFC2045, sección 6.7.

Esta función es similar a imap_8bit(), excepto que no requiere el módulo IMAP para funcionar.

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve el string codificado.

Ver también

  • quoted_printable_decode() - Convierte un string quoted-printable en un string de 8 bits
  • iconv_mime_encode() - Compone un campo de cabecera MIME


Escapa meta caracteres

  • « quoted_printable_encode
  • rtrim »
  • PHP Manual
  • Funciones de strings
  • Escapa meta caracteres

quotemeta

(PHP 4, PHP 5, PHP 7, PHP 8)

quotemeta — Escapa meta caracteres

Descripción

quotemeta ( string $str ) : string

Devuelve una versión de str con una barra invertida (\) antes de cada caracter que sea uno de los siguientes:

. \ + * ? [ ^ ] ( $ )

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve el string con los meta caracteres escapados o false si un string vacío es dado como str.

Notas

Nota: Esta función es segura binariamente.

Ver también

  • addslashes() - Escapa un string con barras invertidas
  • addcslashes() - Escapa una cadena al estilo de C
  • htmlentities() - Convierte todos los caracteres aplicables a entidades HTML
  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML
  • nl2br() - Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
  • stripslashes() - Quita las barras de un string con comillas escapadas
  • stripcslashes() - Desmarca la cadena marcada con addcslashes
  • ereg() - Comparación de una expresión regular
  • preg_quote() - Escapar caracteres en una expresión regular


Retira los espacios en blanco (u otros caracteres) del final de un string

  • « quotemeta
  • setlocale »
  • PHP Manual
  • Funciones de strings
  • Retira los espacios en blanco (u otros caracteres) del final de un string

rtrim

(PHP 4, PHP 5, PHP 7, PHP 8)

rtrim — Retira los espacios en blanco (u otros caracteres) del final de un string

Descripción

rtrim ( string $str , string $character_mask = ? ) : string

Esta función devuelve un string con los espacios en blanco retirados del final de str.

Sin el segundo parámetro, rtrim() retirará estos caracteres:

  • " " (ASCII 32 (0x20)), un espacio ordinario.
  • "\t" (ASCII 9 (0x09)), un tabulador.
  • "\n" (ASCII 10 (0x0A)), una nueva línea (line feed).
  • "\r" (ASCII 13 (0x0D)), un retorno de carro.
  • "\0" (ASCII 0 (0x00)), el byte NULL.
  • "\x0B" (ASCII 11 (0x0B)), un tabulador vertical.

Parámetros

str

El string de entrada.

character_mask

Se puede también especificar los caracteres que se desean retirar por medio del parámetro character_mask. Simplemente se listan todos los caracteres que se quieren retirar. Con .. se puede especificar un rango de caracteres.

Valores devueltos

Devuelve el string modificado.

Ejemplos

Ejemplo #1 Ejemplo de uso de rtrim()

<?php

$text = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = rtrim($text);
var_dump($trimmed);

$trimmed = rtrim($text, " \t.");
var_dump($trimmed);

$trimmed = rtrim($hello, "Hdle");
var_dump($trimmed);

// retira los caracteres ASCII de control al inicio de $binary
// (de 0 a 31 inclusive)
$clean = rtrim($binary, "\x00..\x1F");
var_dump($clean);

?>

El resultado del ejemplo sería:

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(30) "        These are a few words :) ..."
string(26) "        These are a few words :)"
string(9) "Hello Wor"
string(15) "    Example string"

Ver también

  • trim() - Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
  • ltrim() - Retira espacios en blanco (u otros caracteres) del inicio de un string


Establecer la información del localismo

  • « rtrim
  • sha1_file »
  • PHP Manual
  • Funciones de strings
  • Establecer la información del localismo

setlocale

(PHP 4, PHP 5, PHP 7, PHP 8)

setlocale — Establecer la información del localismo

Descripción

setlocale ( int $category , string $locale , string $... = ? ) : string
setlocale ( int $category , array $locale ) : string

Establece la información del localismo.

Parámetros

category

category es una constante con nombre que especifica la categoría de las funciones afectadas por el localismo:

  • LC_ALL para establecer todas las siguientes
  • LC_COLLATE para la comparación de cadenas; véase strcoll()
  • LC_CTYPE para la clasificación y conversión de caracteres, por ejemplo strtoupper()
  • LC_MONETARY para localeconv()
  • LC_NUMERIC para el separador decimal (véase también localeconv())
  • LC_TIME para el formato de fecha y hora con strftime()
  • LC_MESSAGES para las respuestas del sistema (disponible si PHP fue compilado con libintl)

locale

Si locale es null o el string vacío "", los nombres de los localismos se establecerán a partir de los valores de las variables de entorno con los mismos nombres que las categorías anteriores, o desde "LANG".

Si locale es "0", el localismo no se ve afectado, solamente devuelve la configuración actual.

Si locale es un array o le siguen parámetros adicionales, cada elemento del array o parámetro se intenta establecer como nuevo localismo hasta que se tenga éxito. Esto es útil si un localismo se conoce con diferentes nombres en diferentes sistemas, o para proporcionar un respaldo para un localismo posiblemente no disponible.

...

(String opcional o array de parámetros para probarlos como localismos hasta que se tenga éxito.)

Nota:

En Windows, setlocale(LC_ALL, '') establece los nombres del localismo desde la configuración regional o del lenguaje del sistema (accesible por medio del Panel de Control).

Valores devueltos

Devuelve el nuevo localismo actual o false si la funcionalidad del localismo no está implementada en la plataforma, el localismo especificado no existe, o el nombre de la categoría no es válido.

Un nombre de categoría no válido también produce un mensaje de advertencia. Se pueden encontrar los nombres de las categorías/localismos en la » RFC 1766 y en la » ISO 639. Diferentes sistemas tienen diferentes nomenclaturas para los localismos.

Nota:

El valor de retorno de setlocale() depende del sistema donde se está ejecutando PHP. Devuelve exactamente lo que la función setlocale del sistema devuelve.

Historial de cambios

Versión | Descripción
7.0.0 | Se ha eliminado el soporte para el parámetro category pasado como string. En esta versión, solamente se pueden utilizar las constantes LC_*.
5.3.0 | Está función ahora emite un aviso E_DEPRECATED si se pasa un string al parámetro category en lugar de una de las constantes LC_*.

Ejemplos

Ejemplo #1 Ejemplos de setlocale()

<?php
/* Establecer el localismo al holandés */
setlocale(LC_ALL, 'nl_NL');

/* Muestra: vrijdag 22 december 1978 */
echo strftime("%A %e %B %Y", mktime(0, 0, 0, 12, 22, 1978));

/* Probar diferentes nombres posibles de localismos para el alemán */
$loc_de = setlocale(LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');
echo "El localismo preferido para el alemán en este sistema es '$loc_de'";
?>

Ejemplo #2 Ejemplos para Windows de setlocale()

<?php
/* Establecer el localismo al holandés */
setlocale(LC_ALL, 'nld_nld');

/* Muestra: vrijdag 22 december 1978 */
echo strftime("%A %d %B %Y", mktime(0, 0, 0, 12, 22, 1978));

/* Probar diferentes nombres posibles de localismos para el alemán */
$loc_de = setlocale(LC_ALL, 'de_DE@euro', 'de_DE', 'deu_deu');
echo "El localismo preferido para el alemán en este sistema es '$loc_de'";
?>

Notas

Advertencia

La información del localismo se mantiene por proceso, no por hilo. Si se está ejecutanto PHP en una API de servidor multihilo como IIS, HHVM o Apache sobre Windows, se pueden experimentar cambios repentinos en la configuración local mientras se esté ejecutando un script, aunque el propio script nunca llame a setlocale(). Esto ocurre debido a que otros scripts ejecutándose en diferentes hilos de un mismo proceso, al mismo tiempo, cambian el localismo de todo el proceso con setlocale().

Sugerencia

Los usuarios de Windows encontrarán información útil sobre string de locale en el sitio web MSDN de Microsoft. Los string de los idiomas soportados se pueden encontrar en la » documentación de string de idiomas y los string de paises/regiones en la » documentación de string de países/regiones.


Calcula el hash sha1 de un archivo

  • « setlocale
  • sha1 »
  • PHP Manual
  • Funciones de strings
  • Calcula el hash sha1 de un archivo

sha1_file

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

sha1_file — Calcula el hash sha1 de un archivo

Descripción

sha1_file ( string $filename , bool $raw_output = false ) : string

Calcula el hash sha1 del archivo especificado mediante filename utilizando el » algoritmo de hash seguro 1 de US y devuelve ese hash. El hash es un número hexadecimal de 40 caracteres.

Parámetros

filename

El nombre del archivo para el hash.

raw_output

Cuando es true, devuelve el resumen en formato binario sin tratar con una longitud de 20.

Valores devueltos

Devuelve un string cuando es exitoso o false si no es así.

Ejemplos

Ejemplo #1 Ejemplo de sha1_file()

<?php
foreach(glob('/home/Kalle/myproject/*.php') as $ent)
{
    if(is_dir($ent))
    {
        continue;
    }

    echo $ent . ' (SHA1: ' . sha1_file($ent) . ')', PHP_EOL;
}
?>

Historial de cambios

Versión | Descripción
5.1.0 | Cambiada la función para utilizar el API de flujo de datos. Esto significa que se puede utilizar con envolturas, como en sha1_file('http://ejemplo.com/..')

Ver también

  • sha1() - Calcula el 'hash' sha1 de un string
  • md5_file() - Calcula el resumen criptográfico md5 de un archivo dado
  • crc32() - Calcula el polinomio crc32 de una cadena


Calcula el 'hash' sha1 de un string

  • « sha1_file
  • similar_text »
  • PHP Manual
  • Funciones de strings
  • Calcula el 'hash' sha1 de un string

sha1

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

sha1 — Calcula el 'hash' sha1 de un string

Advertencia

No se recomienda utilizar esta función para contraseñas seguras debido a la naturaleza rápida de este algoritmo de «hashing». Véase las Preguntas más frecuentes de «hash» de contraseñas para más detalles y el empleo de mejores prácticas.

Descripción

sha1 ( string $str , bool $raw_output = false ) : string

Calcula el hash sha1 de str utilizando el » Algoritmo 1 US Secure Hash Algorithm 1.

Parámetros

str

El string de entrada.

raw_output

Si el raw_output opcional se establece en true, el resumen sha1 será devuelto en formato binario sin tratar con una longitud de 20; de lo contrario, el valor retornado será un número hexadecimal de 40 caracteres.

Valores devueltos

Devuelve el hash sha1 como un string.

Ejemplos

Ejemplo #1 Ejemplo de sha1()

<?php
$str = 'apple';

if (sha1($str) === 'd0be2dc421be4fcd0172e5afceea3970e2f3d940') {
    echo "Would you like a green or red apple?";
}
?>

Ver también

  • sha1_file() - Calcula el hash sha1 de un archivo
  • crc32() - Calcula el polinomio crc32 de una cadena
  • md5() - Calcula el 'hash' md5 de un string
  • hash() - Generar un valor hash (resumen de mensaje)
  • crypt() - Hash de cadenas de un sólo sentido
  • password_hash() - Crea un hash de contraseña


Calcula la similitud entre dos strings

  • « sha1
  • soundex »
  • PHP Manual
  • Funciones de strings
  • Calcula la similitud entre dos strings

similar_text

(PHP 4, PHP 5, PHP 7, PHP 8)

similar_text — Calcula la similitud entre dos strings

Descripción

similar_text ( string $first , string $second , float &$percent = ? ) : int

Esta función calcula la similitud entre dos strings según se describe en Programming Classics: Implementing the World's Best Algorithms by Oliver (ISBN 0-131-00413-1). Nótese que esta implementación no utiliza una pila como en el pseudo código de Oliver, sino llamadas recursivas que pueden o no pueden acelerar todo el proceso. También tener en cuenta que la complejidad de este algoritmo es O(N**3) donde N es la longitud del string más largo.

Parámetros

first

El primer string.

second

El segundo string.

percent

Mediante el paso de una referencia como tercer argumento, similar_text() calculará la similitud en porcentaje.

Valores devueltos

Devuelve el número de caracteres coincidentes en ambos strings.

Ver también

  • levenshtein() - Cálculo de la distancia Levenshtein entre dos strings
  • soundex() - Calcula la clave soundex de un string


Calcula la clave soundex de un string

  • « similar_text
  • sprintf »
  • PHP Manual
  • Funciones de strings
  • Calcula la clave soundex de un string

soundex

(PHP 4, PHP 5, PHP 7, PHP 8)

soundex — Calcula la clave soundex de un string

Descripción

soundex ( string $str ) : string

Calcula la clave soundex de str.

Las claves soundex tienen la propiedad que palabras pronunciadas de forma similar producen la misma clave soundex y por lo tanto puede ser usada para simplificar búsquedas en bases de datos donde se conoce la pronunciación pero no la ortografía. Esta función soundex devuelve un string de 4 caracteres de longitud, que inicia con una letra.

Esta función particular de soundex es la descrita por Donald Knuth en "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), pp. 391-392.

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve la clave soundex como un string.

Ejemplos

Ejemplo #1 Ejemplos de soundex

<?php
soundex("Euler")       == soundex("Ellery");    // E460
soundex("Gauss")       == soundex("Ghosh");     // G200
soundex("Hilbert")     == soundex("Heilbronn"); // H416
soundex("Knuth")       == soundex("Kant");      // K530
soundex("Lloyd")       == soundex("Ladd");      // L300
soundex("Lukasiewicz") == soundex("Lissajous"); // L222
?>

Ver también

  • levenshtein() - Cálculo de la distancia Levenshtein entre dos strings
  • metaphone() - Calcula la clave metaphone de un string
  • similar_text() - Calcula la similitud entre dos strings


Devuelve un string formateado

  • « soundex
  • sscanf »
  • PHP Manual
  • Funciones de strings
  • Devuelve un string formateado

sprintf

(PHP 4, PHP 5, PHP 7, PHP 8)

sprintf — Devuelve un string formateado

Descripción

sprintf ( string $format , mixed $args = ? , mixed $... = ? ) : string

Devuelve un string producido según el string de formateo dado por format.

Parámetros

format

El string de formateo está compuesto de cero o más directivas: caracteres ordinarios (excluyendo %) que son copiados directamente al resultado, y especificaciones de conversión, donde cada una de las cuales da lugar a extraer su propio parámetro. Esto se aplica tanto para sprintf() como para printf().

Cada especificación de conversión consiste en un signo de porcentaje (%), seguido por uno o más de estos elementos, en orden:

  1. Un especificador de signo opcional que fuerza a usar un signo (- o +) en un número. Por defecto, sólo el signo - se utiliza en un número si es negativo. Esta especificación fuerza números positivos para que también tengan adjunto el signo + (agregado en PHP 4.3.0).
  2. Un especificador de relleno opcional que indica qué carácter se utiliza para rellenar el resultado hasta el tamaño justo del string. Este puede ser un carácter de espacio o un 0 (el carácter cero). El valor por defecto es rellenar con espacios. Un carácter de relleno alternativo se puede especificar prefijándolo con una comilla simple ('). Ver los ejemplos más adelante.
  3. Un especificador de alineación opcional que indica si el resultado debe ser alineado a la izquierda o a la derecha. El valor por defecto es justificado a la derecha, un carácter - lo justificará a la izquierda.
  4. Un número opcional, un especificador de ancho que indica de cuántos caracteres (mínimo) resultará esta conversión.
  5. Un especificador de precisión opcional en la forma de un punto (.) seguido de un string opcional de dígitos decimales que indica cuántos dígitos decimales deben mostrarse para los números de punto flotante. Cuando se utiliza este especificador con un string, actúa como un punto de corte, estableciendo un límite máximo de caracteres al string. Además, el carácter para empleado cuando se rellena un número podría especificarse opcionalmente entre el punto y el dígito.

  6. Un especificador de tipo que indica con qué tipo deben ser tratados los datos del argumento. Los tipos posibles son:

    • % - un carácter de porcentaje literal. No se requiere argumento.
    • b - el argumento es tratado como un valor de tipo integer y presentado como un número binario.
    • c - el argumento es tratado como un valor de tipo integer y presentado como el carácter con ese valor ASCII.
    • d - el argumento es tratado como un valor de tipo integer y presentado como un número decimal (con signo).
    • e - el argumento es tratado con notación científica (e.g. 1.2e+2). El especificador de precisión indica el número de dígitos después del punto decimal a partir de PHP 5.2.1. En versiones anteriores, se tomó como el número de dígitos significativos (menos uno).
    • E - como %e pero utiliza la letra mayúscula (e.g. 1.2E+2).
    • f - el argumento es tratado como un valor de tipo float y presentado como un número de punto flotante (considerando la configuración regional).
    • F - el argumento es tratado como un valor de tipo float y presentado como un número de punto flotante (no considerando la configuración regional). Disponible desde PHP 4.3.10 y PHP 5.0.3.
    • g - lo mismo que %e y %f.
    • G - lo mismo que %E y %f.
    • o - el argumento es tratado como un valor de tipo integer y presentado como un número octal.
    • s - el argumento es tratado y presentado como un string.
    • u - el argumento es tratado como un valor de tipo integer y presentado como un número decimal sin signo.
    • x - el argumento es tratado como un valor de tipo integer y presentado como un número hexadecimal (con las letras en minúsculas).
    • X - el argumento es tratado como un valor de tipo integer y presentado como un número hexadecimal (con las letras en mayúsculas).

Las variables serán forzadas por el especificador a un tipo adecuado:

Manejo de tipos
Tipo | Especificador
string | s
integer | d, u, c, o, x, X, b
double | g, G, e, E, f, F

Advertencia

Intentar usar una combinación de especificadores de string y ancho con conjuntos de caracteres que requieran más de un byte por carácter podría tener resultados inesperados.

El string de formato soporta la numeración/intercambio de argumentos. Aquí está un ejemplo:

Ejemplo #1 Intercambio de argumentos

<?php
$num = 5;
$ubicación = 'árbol';

$formato = 'Hay %d monos en el %s';
echo sprintf($formato, $num, $ubicación);
?>
Esto producirá " Hay 5 monos en el árbol". Pero imaginemos que estamos creando un string de formato en un fichero aparte, generalmente por que nos gustaría internacionalizarlo, reescribiéndolo así:

Ejemplo #2 Intercambio de argumentos

<?php
$formato = 'El %s contiene %d monos';
echo sprintf($formato, $num, $ubicación);
?>
Ahora tenemos un problema. El orden de los marcadores de posición en el string de formato no coincide con el orden de los argumentos en el código. Nos gustaría dejar el código tal cual y simplemente indicar en el string de formato a cuáles argumentos de los marcadores de posición se refieren. Tendríamos que escribir el string de formato de esta forma:

Ejemplo #3 Intercambio de argumentos

<?php
$formato = 'El %2$s contiene %1$d monos';
echo sprintf($formato, $num, $ubicación);
?>
Un beneficio adicional es que se pueden repetir los marcadores de posición sin agregar más argumentos en el código. Por ejemplo:

Ejemplo #4 Intercambio de argumentos

<?php
$formato = 'El %2$s contiene %1$d monos.
            Es un bonito %2$s con %1$d monos.';
echo sprintf($formato, $num, $ubicación);
?>
Cuando se utiliza el intercambio de argumentos, el especificador de posición n$ debe ir inmediatamente después del signo de porcentaje (%), antes de cualquier otro especificador, tal como se muestra en el ejemplo siguiente.

Ejemplo #5 Especificar un carácter de relleno

<?php
echo sprintf("%'.9d\n", 123);
echo sprintf("%'.09d\n", 123);
?>

El resultado del ejemplo sería:

......123
000000123

Ejemplo #6 Especificador de posición con otros especificadores

<?php
$formato = 'El %2$s contiene %1$04d monos';
echo sprintf($formato, $num, $ubicación);
?>

El resultado del ejemplo sería:

 El árbol contiene 0005 monos

Nota:

Tratar de utilizar marcadores de posición mayores que PHP_INT_MAX provocará que sprintf() genere mensajes de advertencia.

Advertencia

El especificador de tipo c ignora el relleno y el ancho

args

...

Valores devueltos

Devuelve un string producido de acuerdo con el string de formato format.

Ejemplos

Ejemplo #7 printf(): ejemplos varios

<?php
$n =  43951789;
$u = -43951789;
$c = 65; // ASCII 65 es 'A'

// observar el doble %%, esto muestra un carácter '%' literal
printf("%%b = '%b'\n", $n); // representación binaria
printf("%%c = '%c'\n", $c); // muestra el carácter ascii, igual que la función chr()
printf("%%d = '%d'\n", $n); // representación estándar de un entero
printf("%%e = '%e'\n", $n); // notación científica
printf("%%u = '%u'\n", $n); // representación sin signo de un entero positivo
printf("%%u = '%u'\n", $u); // representación sin signo de un entero negativo
printf("%%f = '%f'\n", $n); // representación de punto flotante
printf("%%o = '%o'\n", $n); // representación octal
printf("%%s = '%s'\n", $n); // representación en una cadena
printf("%%x = '%x'\n", $n); // representación hexadecimal (minúsculas)
printf("%%X = '%X'\n", $n); // representación hexadecimal (mayúsculas)

printf("%%+d = '%+d'\n", $n); // especificador de signo sobre un entero positivo
printf("%%+d = '%+d'\n", $u); // especificador de signo sobre un entero negativo
?>

El resultado del ejemplo sería:

%b = '10100111101010011010101101'
%c = 'A'
%d = '43951789'
%e = '4.39518e+7'
%u = '43951789'
%u = '4251015507'
%f = '43951789.000000'
%o = '247523255'
%s = '43951789'
%x = '29ea6ad'
%X = '29EA6AD'
%+d = '+43951789'
%+d = '-43951789'

Ejemplo #8 printf(): especificadores de string

<?php
$s = 'mono';
$t = 'muchos monos';

printf("[%s]\n",      $s); // salida estándar de string
printf("[%10s]\n",    $s); // justificación a la derecha con espacios
printf("[%-10s]\n",   $s); // justificación a la izquierda con espacios
printf("[%010s]\n",   $s); // rellenado con ceros también funciona con strings
printf("[%'#10s]\n",  $s); // utiliza el carácter de relleno personalizado '#'
printf("[%10.10s]\n", $t); // justificación a la izquierda pero con un corte a los 10 caracteres
?>

El resultado del ejemplo sería:

[mono]
[      mono]
[mono      ]
[000000mono]
[######mono]
[muchos mon]

Ejemplo #9 sprintf(): valores de tipo integer rellenados con ceros

<?php
$fecha_iso = sprintf("%04d-%02d-%02d", $año, $mes, $día);
?>

Ejemplo #10 sprintf(): formato de moneda

<?php
$dinero1 = 68.75;
$dinero2 = 54.35;
$dinero = $dinero1 + $dinero2;
// echo $dinero producirá "123.1";
$formateado = sprintf("%01.2f", $dinero);
// echo $formateado producirá "123.10"
?>

Ejemplo #11 sprintf(): notación científica

<?php
$número = 362525200;

echo sprintf("%.3e", $número); // produce 3.625e+8
?>

Ver también

  • printf() - Imprimir una cadena con formato
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • vsprintf() - Devuelve una cadena con formato
  • number_format() - Formatear un número con los millares agrupados
  • date() - Dar formato a la fecha/hora local


Interpreta un string de entrada de acuerdo con un formato

  • « sprintf
  • str_contains »
  • PHP Manual
  • Funciones de strings
  • Interpreta un string de entrada de acuerdo con un formato

sscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

sscanf — Interpreta un string de entrada de acuerdo con un formato

Descripción

sscanf ( string $str , string $format , mixed &$... = ? ) : mixed

La función sscanf() es la entrada análoga de printf(). sscanf() lee del string str y lo interpreta de acuerdo con el format especificado, el cual está descrito en la documentación para sprintf().

Cualquier espacio en blanco en el string de formato coincide con cualquier espacio en blanco en string de entrada. Esto significa que incluso un tabulador \t en el string de formato puede coincidir con un caracter simple de espacio en el string de entrada.

Parámetros

str

El string de entrada para ser interpretado.

format

El formato interpretado str, el cual está descrito en la documentación para sprintf() con las siguientes diferencia:

  • La función no es consciente de la configuración regional.
  • F, g, G y b no están soportados.
  • D representa número decimal.
  • i representa integer con detección de base.
  • n representa el número de caracteres procesados hasta el momento.

...

Opcionalmente variables pasadas por referencia que contendrán los valores interpretados.

Valores devueltos

Si sólo se pasan dos parámetros a esta función, los valores interpretados se devolverán como una matriz. De lo contrario, si se pasan parámetros opcionales, la función devolverá el número de valores asignados. Los parámetros opcionales se deben pasar por referencia.

Si hay más substrings esperados en el format que los que hay disponibles en str, será devuelto -1.

Ejemplos

Ejemplo #1 Ejemplo de sscanf()

<?php
// obtener el número serial
list($serial) = sscanf("SN/2350001", "SN/%d");
// y la fecha de manufactura
$mandate = "January 01 2000";
list($month, $day, $year) = sscanf($mandate, "%s %d %d");
echo "Item $serial was manufactured on: $year-" . substr($month, 0, 3) . "-$day\n";
?>

Si se pasan parámetros opcionales, la función devolverá el número de valores asignados.

Ejemplo #2 sscanf() - using optional parameters

<?php
// obtener la información del autor y generar entrada DocBook
$auth = "24\tLewis Carroll";
$n = sscanf($auth, "%d\t%s %s", $id, $first, $last);
echo "<author id='$id'>
    <firstname>$first</firstname>
    <surname>$last</surname>
</author>\n";
?>

Ver también

  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado


Determine if a string contains a given substring

  • « sscanf
  • str_ends_with »
  • PHP Manual
  • Funciones de strings
  • Determine if a string contains a given substring

str_contains

(PHP 8)

str_contains — Determine if a string contains a given substring

Descripción

str_contains ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if needle is contained in haystack.

Parámetros

haystack

The string to search in.

needle

The substring to search for in the haystack.

Valores devueltos

Returns true if needle is in haystack, false otherwise.

Ejemplos

Ejemplo #1 Using the empty string ''

<?php
if (str_contains('abc', '')) {
    echo "Checking the existence of the empty string will always return true";
}
?>

El resultado del ejemplo sería:

Checking the existence of the empty string will always return true

Ejemplo #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_contains($string, 'lazy')) {
    echo "The string 'lazy' was found in the string\n";
}

if (str_contains($string, 'Lazy')) {
    echo 'The string "Lazy" was found in the string';
} else {
    echo '"Lazy" was not found because the case does not match';
}

?>

El resultado del ejemplo sería:

The string 'lazy' was found in the string
"Lazy" was not found because the case does not match

Notas

Nota: Esta función es segura binariamente.

Ver también

  • str_ends_with() - Checks if a string ends with a given substring
  • str_starts_with() - Checks if a string starts with a given substring
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strstr() - Encuentra la primera aparición de un string
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • substr() - Devuelve parte de una cadena
  • preg_match() - Realiza una comparación con una expresión regular


Checks if a string ends with a given substring

  • « str_contains
  • str_getcsv »
  • PHP Manual
  • Funciones de strings
  • Checks if a string ends with a given substring

str_ends_with

(PHP 8)

str_ends_with — Checks if a string ends with a given substring

Descripción

str_ends_with ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if haystack ends with needle.

Parámetros

haystack

The string to search in.

needle

The substring to search for in the haystack.

Valores devueltos

Returns true if haystack ends with needle, false otherwise.

Ejemplos

Ejemplo #1 Using the empty string ''

<?php
if (str_ends_with('abc', '')) {
    echo "All strings end with the empty string";
}
?>

El resultado del ejemplo sería:

All strings end with the empty string

Ejemplo #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_ends_with($string, 'fence')) {
    echo "The string ends with 'fence'\n";
}

if (str_ends_with($string, 'Fence')) {
    echo 'The string ends with "fence"';
} else {
    echo '"fence" was not found because the case does not match';
}

?>

El resultado del ejemplo sería:

The string ends with 'fence'
"fence" was not found because the case does not match

Notas

Nota: Esta función es segura binariamente.

Ver también

  • str_contains() - Determine if a string contains a given substring
  • str_starts_with() - Checks if a string starts with a given substring
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strstr() - Encuentra la primera aparición de un string
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • substr() - Devuelve parte de una cadena
  • preg_match() - Realiza una comparación con una expresión regular


Convierte un string con formato CSV a un array

  • « str_ends_with
  • str_ireplace »
  • PHP Manual
  • Funciones de strings
  • Convierte un string con formato CSV a un array

str_getcsv

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

str_getcsv — Convierte un string con formato CSV a un array

Descripción

str_getcsv ( string $input , string $delimiter = "," , string $enclosure = '"' , string $escape = "\\" ) : array

Convierte el string dado por input con campos en formato CSV y devuelve un array que contiene los campos leídos.

Parámetros

input

El string a convertir.

delimiter

Establece el delimitador de campos (sólo un carácter).

enclosure

Establece el carácter circundante de cada campo (sólo un carácter).

escape

Establece el carácter de escape (sólo un carácter). Por defecto, es una barra invertida. (\)

Valores devueltos

Devuelve un array indexado que contiene los campos leídos.

Ver también

  • fgetcsv() - Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV


Versión insensible a mayúsculas y minúsculas de str_replace

  • « str_getcsv
  • str_pad »
  • PHP Manual
  • Funciones de strings
  • Versión insensible a mayúsculas y minúsculas de str_replace

str_ireplace

(PHP 5, PHP 7, PHP 8)

str_ireplace — Versión insensible a mayúsculas y minúsculas de str_replace()

Descripción

str_ireplace ( mixed $search , mixed $replace , mixed $subject , int &$count = ? ) : mixed

Esta función devuelve un string o un array con todas las apariciones de search en subject (ignorando mayúsculas y minúsculas) reemplazadas con el valor dado de replace. Si no se necesitan reglas complicadas de reemplazo, en general se puede utilizar esta función en lugar de preg_replace() con el modificador i.

Parámetros

Sisearch y replace son matrices, entonces str_ireplace() toma un valor de cada array y lo utiliza para buscar y reemplazar en subject. Si replace tiene menos valores que search, entonces un string vacío es usado para el resto de los valores de reemplazo. Si search es un array y replace es un string, entonces este string de reemplazo es usado para cada valor de search. Sin embargo, lo contrario no tendría sentido.

Si search o replace son arrays, sus elementos son procesados del primero al último.

search

El valor a ser buscado, también conocida como la aguja. Un array puede ser utilizado para designar varias agujas.

replace

El valor de reemplazo que sustituye los valores encontrados de search. Un array puede ser utilizado para designar reemplazos múltiples.

subject

El string o array sobre el que se busca y se sustituye, también conocido como el pajar.

Si subject es un array, entonces la búsqueda y reemplazo se realiza con cada entrada de subject y el valor devuelto también es un array.

count

Si es pasado, con éste parámetro se establece el número de reemplazos realizados.

Valores devueltos

Devuelve un string o un array de sustituciones.

Ejemplos

Ejemplo #1 Ejemplo de str_ireplace()

<?php
$bodytag = str_ireplace("%body%", "black", "<body text=%BODY%>");
echo $bodytag; // <body text=black>
?>

Notas

Nota: Esta función es segura binariamente.

Precaución

Trampa en que se puede caer por el orden de reemplazo

Debido a que str_ireplace() reemplaza de izquierda a derecha, podría sustituir a un valor previamente insertado cuando se hacen sustituciones múltiples. El ejemplo #2 en la documentación de str_replace() demuestra como esto puede afectar en la práctica.

Ver también

  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • strtr() - Convierte caracteres o reemplaza substrings


Rellena un string hasta una longitud determinada con otro string

  • « str_ireplace
  • str_repeat »
  • PHP Manual
  • Funciones de strings
  • Rellena un string hasta una longitud determinada con otro string

str_pad

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

str_pad — Rellena un string hasta una longitud determinada con otro string

Descripción

str_pad ( string $input , int $pad_length , string $pad_string = " " , int $pad_type = STR_PAD_RIGHT ) : string

Esta función devuelve el string input rellenado por la izquierda, la derecha, o en ambos lados hasta la longitud especificada. Si el argumento opcional pad_string no se suministra, el input se rellena con espacios, de lo contrario, se rellena con los caracteres de pad_string hasta el límite.

Parámetros

input

El string de entrada.

pad_length

La longitud del relleno. Si el valor de pad_length es negativo, inferior o igual a la longitud del string de entrada, no se realizará ningún relleno, devolviendo así input.

pad_string

Nota:

El pad_string se puede truncar si el número necesario de caracteres de relleno no pueden ser divididos uniformemente por la longitud de pad_string.

pad_type

El argumento opcional pad_type puede ser STR_PAD_RIGHT, STR_PAD_LEFT, o STR_PAD_BOTH. Si no se especifica pad_type se asume como STR_PAD_RIGHT.

Valores devueltos

Devuelve el string rellenado.

Ejemplos

Ejemplo #1 Ejemplo de str_pad()

<?php
$input = "Alien";
echo str_pad($input, 10);                      // produce "Alien     "
echo str_pad($input, 10, "-=", STR_PAD_LEFT);  // produce "-=-=-Alien"
echo str_pad($input, 10, "_", STR_PAD_BOTH);   // produce "__Alien___"
echo str_pad($input,  6, "___");               // produces "Alien_"
echo str_pad($input,  3, "*");                 // produces "Alien"
?>


Repite un string

  • « str_pad
  • str_replace »
  • PHP Manual
  • Funciones de strings
  • Repite un string

str_repeat

(PHP 4, PHP 5, PHP 7, PHP 8)

str_repeat — Repite un string

Descripción

str_repeat ( string $input , int $multiplier ) : string

Devuelve el input repetido multiplier veces.

Parámetros

input

El string a ser repetido.

multiplier

El número de veces que el string input debe ser repetido.

multiplier debe ser mayor o igual a 0. Si el multiplier se establece en 0, la función devolverá un string vacío.

Valores devueltos

Devuelve el string repetido.

Ejemplos

Ejemplo #1 Ejemplo de str_repeat()

<?php
echo str_repeat("-=", 10);
?>

El resultado del ejemplo sería:

-=-=-=-=-=-=-=-=-=-=

Ver también

  • for
  • str_pad() - Rellena un string hasta una longitud determinada con otro string
  • substr_count() - Cuenta el número de apariciones del substring


Reemplaza todas las apariciones del string buscado con el string de reemplazo

  • « str_repeat
  • str_rot13 »
  • PHP Manual
  • Funciones de strings
  • Reemplaza todas las apariciones del string buscado con el string de reemplazo

str_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

str_replace — Reemplaza todas las apariciones del string buscado con el string de reemplazo

Descripción

str_replace ( mixed $search , mixed $replace , mixed $subject , int &$count = ? ) : mixed

Esta función devuelve un string o un array con todas las apariciones de search en subject reemplazadas con el valor dado de replace.

Si no se necesitan reglas complicadas de reemplazo (como expresiones regulares), se puede utilizar siempre esta función en lugar de preg_replace().

Parámetros

Si search y replace son arrays, entonces str_replace() toma un valor de cada array y lo utiliza para buscar y reemplazar en subject. Si replace tiene menos valores que search, entonces un string vacío es usado para el resto de los valores de reemplazo. Si search es un array y replace es un string, entonces este string de reemplazo es usado para cada valor de search. Sin embargo, lo contrario no tendría sentido.

Si search o replace son arrays, sus elementos son procesados del primero al último.

search

El valor a ser buscado, también conocida como la aguja. Un array puede ser utilizado para designar varias agujas.

replace

El valor de reemplazo que sustituye los valores encontrados de search. Un array puede ser utilizado para designar reemplazos múltiples.

subject

El string o array sobre el que se busca y se sustituye, también conocido como el pajar.

Si subject es un array, entonces la búsqueda y reemplazo se realiza con cada entrada de subject y el valor devuelto también es un array.

count

Si es pasado, con este se establece el número de reemplazos realizados.

Valores devueltos

Esta función devuelve un string o un array con los valores sustituidos.

Ejemplos

Ejemplo #1 Ejemplos básicos de str_replace()

<?php
// Produce: <body text='black'>
$bodytag = str_replace("%body%", "black", "<body text='%body%'>");

// Produce: Hll Wrld f PHP
$vowels = array("a", "e", "i", "o", "u", "A", "E", "I", "O", "U");
$onlyconsonants = str_replace($vowels, "", "Hello World of PHP");

// Produce: You should eat pizza, beer, and ice cream every day
$phrase  = "You should eat fruits, vegetables, and fiber every day.";
$healthy = array("fruits", "vegetables", "fiber");
$yummy   = array("pizza", "beer", "ice cream");

$newphrase = str_replace($healthy, $yummy, $phrase);

// Produce: 2
$str = str_replace("ll", "", "good golly miss molly!", $count);
echo $count;
?>

Ejemplo #2 Ejemplos de trampas potenciales con str_replace()

<?php
// Orden del reemplazo
$str     = "Line 1\nLine 2\rLine 3\r\nLine 4\n";
$order   = array("\r\n", "\n", "\r");
$replace = '<br />';

// Procesa primero \r\n así no es convertido dos veces.
$newstr = str_replace($order, $replace, $str);

// La salida es F debido a que A es reemplazada con B, entonces B es reemplazada con C, y así sucesivamente...
// Finalmente E se reemplaza con F, debido a los reemplazos de izquierda a derecha.
$search  = array('A', 'B', 'C', 'D', 'E');
$replace = array('B', 'C', 'D', 'E', 'F');
$subject = 'A';
echo str_replace($search, $replace, $subject);

// La salida es: apearpearle pear
// Por la misma razón mencionada arriba
$letters = array('a', 'p');
$fruit   = array('apple', 'pear');
$text    = 'a p';
$output  = str_replace($letters, $fruit, $text);
echo $output;
?>

Notas

Nota: Esta función es segura binariamente.

Precaución

Trampa del orden de reemplazo

Debido a que str_replace() reemplaza de izquierda a derecha, podría sustituir a un valor previamente insertado al hacer sustituciones múltiples. Ver también los ejemplos de este documento.

Nota:

Esta función es sensible a mayúsculas y minúsculas. Utilice Use str_ireplace() para reemplazos insensibles a mayúsculas y minúsculas.

Ver también

  • str_ireplace() - Versión insensible a mayúsculas y minúsculas de str_replace
  • substr_replace() - Reemplaza el texto dentro de una porción de un string
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular
  • strtr() - Convierte caracteres o reemplaza substrings


Realizar la transformación rot13 sobre una cadena

  • « str_replace
  • str_shuffle »
  • PHP Manual
  • Funciones de strings
  • Realizar la transformación rot13 sobre una cadena

str_rot13

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

str_rot13 — Realizar la transformación rot13 sobre una cadena

Descripción

str_rot13 ( string $str ) : string

Aplica la codificación ROT13 sobre el argumento str y devuelve la cadena resultante.

La codificación ROT13 simplemente desplaza cada letra en 13 posiciones en el alfabeto, mientras que deja todos los caracteres no-alfabéticos intactos. La codificación y la decodificación se realizan con la misma función, pasar una cadena codificada como argumento devolverá la versión original.

Parámetros

str

La cadena de entrada.

Valores devueltos

Devuelve la versión ROT13 de la cadena dada.

Ejemplos

Ejemplo #1 Ejemplo de str_rot13()

<?php

echo str_rot13('PHP 4.3.0'); // CUC 4.3.0

?>


Reordena aleatoriamente una cadena

  • « str_rot13
  • str_split »
  • PHP Manual
  • Funciones de strings
  • Reordena aleatoriamente una cadena

str_shuffle

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

str_shuffle — Reordena aleatoriamente una cadena

Descripción

str_shuffle ( string $str ) : string

str_shuffle() baraja una cadena. Es creada una permutación de todas las posibles.

Parámetros

str

La cadena de entrada.

Valores devueltos

Devuelve la cadena barajada.

Ejemplos

Ejemplo #1 Ejemplo de str_shuffle()

<?php
$cadena = 'abcdef';
$desordenada = str_shuffle($cadena);

// Esto imprime algo como: bfdaec
echo $desordenada;
?>

Ver también

  • shuffle() - Mezcla un array
  • rand() - Genera un número entero aleatorio


Convierte un string en un array

  • « str_shuffle
  • str_starts_with »
  • PHP Manual
  • Funciones de strings
  • Convierte un string en un array

str_split

(PHP 5, PHP 7, PHP 8)

str_split — Convierte un string en un array

Descripción

str_split ( string $string , int $split_length = 1 ) : array

Convierte un string en un array.

Parámetros

string

El string de entrada.

split_length

Longitud máxima del fragmento.

Valores devueltos

Si el parámetro opcional split_length se específica, el array devuelto será separado en fragmentos los cuales cada uno tendrá una longitud de split_length, de otra manera cada fragmento tendrá una longitud de un caracter.

Se devuelve false si split_length es menor que 1. Si la longitud split_length excede la longitud de string, el string entero es devuelto como el primero (y único) elemento del array.

Ejemplos

Ejemplo #1 Ejemplos de uso de str_split()

<?php

$str = "Hello Friend";

$arr1 = str_split($str);
$arr2 = str_split($str, 3);

print_r($arr1);
print_r($arr2);

?>

El resultado del ejemplo sería:

Array
(
    [0] => H
    [1] => e
    [2] => l
    [3] => l
    [4] => o
    [5] =>
    [6] => F
    [7] => r
    [8] => i
    [9] => e
    [10] => n
    [11] => d
)

Array
(
    [0] => Hel
    [1] => lo
    [2] => Fri
    [3] => end
)

Notas

Nota:

str_split() realizará la división en bytes en lugar de en caracteres cuando trata con un string codificado en multibyte.

Ver también

  • chunk_split() - Divide una cadena en trozos más pequeños
  • preg_split() - Divide un string mediante una expresión regular
  • explode() - Divide un string en varios string
  • count_chars() - Devuelve información sobre los caracteres usados en una cadena
  • str_word_count() - Devuelve información sobre las palabras utilizadas en un string
  • for


Checks if a string starts with a given substring

  • « str_split
  • str_word_count »
  • PHP Manual
  • Funciones de strings
  • Checks if a string starts with a given substring

str_starts_with

(PHP 8)

str_starts_with — Checks if a string starts with a given substring

Descripción

str_starts_with ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if haystack begins with needle.

Parámetros

haystack

The string to search in.

needle

The substring to search for in the haystack.

Valores devueltos

Returns true if haystack begins with needle, false otherwise.

Ejemplos

Ejemplo #1 Using the empty string ''

<?php
if (str_starts_with('abc', '')) {
    echo "All strings start with the empty string";
}
?>

El resultado del ejemplo sería:

All strings start with the empty string

Ejemplo #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_starts_with($string, 'The')) {
    echo "The string starts with 'The'\n";
}

if (str_starts_with($string, 'the')) {
    echo 'The string starts with "the"';
} else {
    echo '"the" was not found because the case does not match';
}

?>

El resultado del ejemplo sería:

The string starts with 'The'
"the" was not found because the case does not match

Notas

Nota: Esta función es segura binariamente.

Ver también

  • str_contains() - Determine if a string contains a given substring
  • str_ends_with() - Checks if a string ends with a given substring
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strstr() - Encuentra la primera aparición de un string
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • substr() - Devuelve parte de una cadena
  • preg_match() - Realiza una comparación con una expresión regular


Devuelve información sobre las palabras utilizadas en un string

  • « str_starts_with
  • strcasecmp »
  • PHP Manual
  • Funciones de strings
  • Devuelve información sobre las palabras utilizadas en un string

str_word_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

str_word_count — Devuelve información sobre las palabras utilizadas en un string

Descripción

str_word_count ( string $string , int $format = 0 , string $charlist = ? ) : mixed

Cuenta el número de palabras dentro de string. Si no se especifica el format opcional, entonces el valor devuelto será un integer representando el número de palabras encontradas. En el caso en que se especifique format, el valor devuelto será un array cuyo contenido depende de format. Los posibles valores para format y las salidas resultantes están listadas más abajo.

Para los propósitos de esta función, 'palabra' se define como un string dependiente de la configuración regional que contiene caracteres alfabéticos, el cual también puede contener, pero no iniciar con los caracteres "'" y "-".

Parámetros

string

El string

format

Especifica el valor devuelto de esta función. Los valores soportados actualmente son:

  • 0 - devuelve el número de palabras encontradas
  • 1 - devuelve un array que contiene todas las palabras encontradas dentro del string
  • 2 - devuelve un array asociativo, donde la clave es la posición numérica de una palabra dentro del string y el valor es la palabra en sí.

charlist

Una lista de caracteres adicionales los cuales serán considerados como de 'palabra'.

Valores devueltos

Devuelve un array o un integer, dependiendo del format seleccionado.

Historial de cambios

Versión | Descripción
5.1.0 | Agregado el parámetro charlist

Ejemplos

Ejemplo #1 Ejemplo de str_word_count()

<?php

$str = "Hello fri3nd, you're
       looking          good today!";

print_r(str_word_count($str, 1));
print_r(str_word_count($str, 2));
print_r(str_word_count($str, 1, 'àáãç3'));

echo str_word_count($str);

?>

El resultado del ejemplo sería:

Array
(
    [0] => Hello
    [1] => fri
    [2] => nd
    [3] => you're
    [4] => looking
    [5] => good
    [6] => today
)

Array
(
    [0] => Hello
    [6] => fri
    [10] => nd
    [14] => you're
    [29] => looking
    [46] => good
    [51] => today
)

Array
(
    [0] => Hello
    [1] => fri3nd
    [2] => you're
    [3] => looking
    [4] => good
    [5] => today
)

7

Ver también

  • explode() - Divide un string en varios string
  • preg_split() - Divide un string mediante una expresión regular
  • split() - Divide una cadena en una matriz mediante una expresión regular
  • count_chars() - Devuelve información sobre los caracteres usados en una cadena
  • substr_count() - Cuenta el número de apariciones del substring


Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas

  • « str_word_count
  • strchr »
  • PHP Manual
  • Funciones de strings
  • Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas

strcasecmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strcasecmp — Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas

Descripción

strcasecmp ( string $str1 , string $str2 ) : int

Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas.

Parámetros

str1

El primer string

str2

El segundo string

Valores devueltos

Devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2 y 0 si son iguales.

Ejemplos

Ejemplo #1 Ejemplo de strcasecmp()

<?php
$var1 = "Hello";
$var2 = "hello";
if (strcasecmp($var1, $var2) == 0) {
    echo '$var1 is equal to $var2 in a case-insensitive string comparison';
}
?>

Ver también

  • strcmp() - Comparación de string segura a nivel binario
  • preg_match() - Realiza una comparación con una expresión regular
  • substr_compare() - Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
  • strncasecmp() - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena


Alias de strstr

  • « strcasecmp
  • strcmp »
  • PHP Manual
  • Funciones de strings
  • Alias de strstr

strchr

(PHP 4, PHP 5, PHP 7, PHP 8)

strchr — Alias de strstr()

Descripción

Esta función es un alias de: strstr().


Comparación de string segura a nivel binario

  • « strchr
  • strcoll »
  • PHP Manual
  • Funciones de strings
  • Comparación de string segura a nivel binario

strcmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strcmp — Comparación de string segura a nivel binario

Descripción

strcmp ( string $str1 , string $str2 ) : int

Tenga en cuenta que esta comparación considera mayúsculas y minúsculas.

Parámetros

str1

El primer string.

str2

El segundo string.

Valores devueltos

Devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2 y 0 si son iguales.

Ejemplos

Ejemplo #1 Ejemplo de strcmp()

<?php
$var1 = "Hola";
$var2 = "hola";
if (strcmp($var1, $var2) !== 0) {
    echo '$var1 no es igual a $var2 en una comparación que considera mayúsculas y minúsculas';
}
?>

Ver también

  • strcasecmp() - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • preg_match() - Realiza una comparación con una expresión regular
  • substr_compare() - Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings
  • strstr() - Encuentra la primera aparición de un string
  • substr() - Devuelve parte de una cadena


Comparación de cadenas basada en la localidad

  • « strcmp
  • strcspn »
  • PHP Manual
  • Funciones de strings
  • Comparación de cadenas basada en la localidad

strcoll

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

strcoll — Comparación de cadenas basada en la localidad

Descripción

strcoll ( string $str1 , string $str2 ) : int

Note que esta comparación es sensible a mayúsculas y minúsculas, y a diferencia de strcmp(), esta función no es segura con material binario.

strcoll() usa la localidad actual para realizar las comparaciones. Si la localidad actual es C o POSIX, esta función es equivalente a strcmp().

Parámetros

str1

La primera cadena.

str2

La segunda cadena.

Valores devueltos

Devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2, y 0 si son equivalentes.

Historial de cambios

Versión | Descripción
4.2.3 | Esta función trabaja ahora en win32.

Ver también

  • preg_match() - Realiza una comparación con una expresión regular
  • strcmp() - Comparación de string segura a nivel binario
  • strcasecmp() - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strncasecmp() - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings
  • strstr() - Encuentra la primera aparición de un string
  • setlocale() - Establecer la información del localismo


Averiguar la longitud del segmento inicial que no coincida con una máscara

  • « strcoll
  • strip_tags »
  • PHP Manual
  • Funciones de strings
  • Averiguar la longitud del segmento inicial que no coincida con una máscara

strcspn

(PHP 4, PHP 5, PHP 7, PHP 8)

strcspn — Averiguar la longitud del segmento inicial que no coincida con una máscara

Descripción

strcspn ( string $subject , string $mask , int $start = ? , int $length = ? ) : int

Devuelve la longitud del segmento inicial de subject, el cual no contiene ningún caracter de mask.

Si se omiten start y length, se examinará subject al completo. Si se incluyen, el efecto será el mismo que una llamada a strcspn(substr($subject, $start, $length), $mask) (véase substr para más información).

Parámetros

subject

El string a examinar.

mask

El string que contiene cada caracter no permitido.

start

La posición en subject donde comenzar la búsqueda.

Si se proporciona start y no es negativo, strcspn() comenzará a examinar subject en la posición start-ésima. Por ejemplo, en el 'abcdef', el caracter en la posición 0 es 'a', el caracter en la posición 2 es 'c', etc.

Si se proporciona start y es negativo, strcspn() comenzará a examinar subject en la start-ésima a partir del final de subject.

length

La longitud del segmento de subject a examinar.

Si se proporcina length y no es negativo, subject será examinado desde length caracteres después de la posición inicial.

Si se proporcina length y es negativo, subject será examinado desde la posición inicial hasta length caracteres a partir del final de subject.

Valores devueltos

Devuelve la longitud del segmento inicial de subject, el cual consiste en todos los caracteres no presentes en mask.

Nota:

Cuando se establece el parámetro start, la longitud devuelta se cuenta a partir de esta posición, no desde el comienzo de subject.

Ejemplos

Ejemplo #1 Ejemplo de strcspn()

<?php
$a = strcspn('abcd',  'apple');
$b = strcspn('abcd',  'banana');
$c = strcspn('hello', 'l');
$d = strcspn('hello', 'world');
$e = strcspn('abcdhelloabcd', 'abcd', -9);
$f = strcspn('abcdhelloabcd', 'abcd', -9, -5);

var_dump($a);
var_dump($b);
var_dump($c);
var_dump($d);
var_dump($e);
var_dump($f);
?>

El resultado del ejemplo sería:

int(0)
int(0)
int(2)
int(2)
int(5)
int(4)

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strspn() - Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada


Retira las etiquetas HTML y PHP de un string

  • « strcspn
  • stripcslashes »
  • PHP Manual
  • Funciones de strings
  • Retira las etiquetas HTML y PHP de un string

strip_tags

(PHP 4, PHP 5, PHP 7, PHP 8)

strip_tags — Retira las etiquetas HTML y PHP de un string

Descripción

strip_tags ( string $str , string $allowable_tags = ? ) : string

Esta función intenta devolver un string con todos los bytes NULL y las etiquetas HTML y PHP retirados de un str dado. Se utiliza la misma máquina de estado de retirado de etiquetas que la función fgetss().

Parámetros

str

El string de entrada.

allowable_tags

Se puede usar el segundo parámetro opcional para especificar cuales etiquetas no deben ser retiradas.

Nota:

Los comentarios HTML y etiquetas PHP también son retirados. Esto está en el código y no puede ser cambiado mediante allowable_tags.

Nota:

En PHP 5.3.4 y posterior, la etiquetas de autocierre de XHTML son ignoradas, por lo que solamente deberían utilizarse etiquetas sin autocierre en allowable_tags. Por ejemplo, para permitir tanto <br> como <br/>, se debería utilizar:

<?php
strip_tags($input, '<br>');
?>

Valores devueltos

Devuelve el string con las etiquetas retiradas.

Historial de cambios

Versión | Descripción
5.3.4 | strip_tags() ignora las etiquetas de autocierre de XHTML en allowable_tags.
5.0.0 | strip_tags() ahora es segura a nivel binario.

Ejemplos

Ejemplo #1 Ejemplo de strip_tags()

<?php
$text = '<p>Test paragraph.</p><!-- Comment --> <a href="#fragment">Other text</a>';
echo strip_tags($text);
echo "\n";

// Permite <p> y <a>
echo strip_tags($text, '<p><a>');
?>

El resultado del ejemplo sería:

Test paragraph. Other text
<p>Test paragraph.</p> <a href="#fragment">Other text</a>

Notas

Advertencia

Debido a que strip_tags() en realidad no valida el HTML, etiquetas parciales o rotas, pueden resultar en la eliminación de más texto/datos de lo que se espera.

Advertencia

Esta función no modifica los atributos de las etiquetas que se permitan mediante allowable_tags, incluyendo los los atributos style y onmouseover que un usuario malicioso puede abusar al postear texto que se mostrará a otros usuarios.

Nota:

Los nombres de etiquetas en de la entrada HTML que sean mayores que 1023 bytes de longitud, serán tratados como no válidos, independientemente del parámetro allowable_tags.

Ver también

  • htmlspecialchars() - Convierte caracteres especiales en entidades HTML


Desmarca la cadena marcada con addcslashes

  • « strip_tags
  • stripos »
  • PHP Manual
  • Funciones de strings
  • Desmarca la cadena marcada con addcslashes

stripcslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

stripcslashes — Desmarca la cadena marcada con addcslashes()

Descripción

stripcslashes ( string $str ) : string

Devuelve una cadena con las barras invertidas eliminadas Reconoce las marcas tipo C \n, \r ..., y la representación octal y hexadecimal.

Parámetros

str

The string to be unescaped.

Valores devueltos

Devuelve la cadena sin escapar.

Ver también

  • addcslashes() - Escapa una cadena al estilo de C


Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas

  • « stripcslashes
  • stripslashes »
  • PHP Manual
  • Funciones de strings
  • Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas

stripos

(PHP 5, PHP 7, PHP 8)

stripos — Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas

Descripción

stripos ( string $haystack , string $needle , int $offset = 0 ) : mixed

Encuentra la posición numérica de la primera aparición de needle (aguja) en el string haystack (pajar).

A diferencia de strpos(), stripos() no considera las mayúsculas ni las minúsculas.

Parámetros

haystack

El string donde buscar.

needle

Observe que needle puede ser un string de uno o más caracteres.

Si needle no es un string, será convertido a un valor de tipo integer y se aplicará como el valor ordinal de un carácter.

offset

Si se específica, la búsqueda se iniciará en éste número de caracteres contados desde el inicio del string. A diferencia de strrpos() y strripos(), offset no puede ser negativo.

Valores devueltos

Devuelve la posición donde está la aguja, en relación al inicio del string haystack (independiente de offset). Observe también que las posiciones de inicio de los string empiezan en 0, y no en 1.

Devuelve false si no se encontró la aguja.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplos de stripos()

<?php
$findme    = 'a';
$mystring1 = 'xyz';
$mystring2 = 'ABC';

$pos1 = stripos($mystring1, $findme);
$pos2 = stripos($mystring2, $findme);

// No, 'a' sin duda no está en 'xyz'
if ($pos1 === false) {
    echo "El string '$findme' no se encontró en el strng '$mystring1'";
}

// Observe el uso de ===.  Usar solamente == no funcionará como se espera
// debido a que la posición de 'a' es el 0º (primer) caracter.
if ($pos2 !== false) {
    echo "Se encontró '$findme' en '$mystring2' en la posición $pos2";
}
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • mb_stripos() - Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena
  • str_ireplace() - Versión insensible a mayúsculas y minúsculas de str_replace


Quita las barras de un string con comillas escapadas

  • « stripos
  • stristr »
  • PHP Manual
  • Funciones de strings
  • Quita las barras de un string con comillas escapadas

stripslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

stripslashes — Quita las barras de un string con comillas escapadas

Descripción

stripslashes ( string $str ) : string

Quita las barras de un string con comillas escapadas.

Un ejemplo de uso de stripslashes() es cuando la directiva de PHP magic_quotes_gpc es on (estaba activado por defecto antes de PHP 5.4) y no se están insertando estos datos en un lugar (como una base de datos) que requiera escapado. Por ejemplo, si simplemente se le da salida a los datos directamente desde un formulario HTML.

Parámetros

str

El string de entrada.

Valores devueltos

Devuelve un string con las barras invertidas retiradas. (\' se convierte en ' y así sucesivamente.) Barras invertidas dobles (\\) se convierten en una sencilla (\).

Ejemplos

Ejemplo #1 Un ejemplo de stripslashes()

<?php
$str = "Is your name O\'reilly?";

// Salida: Is your name O'reilly?
echo stripslashes($str);
?>

Nota:

stripslashes() no es recursiva. Si se desea aplicar esta función a un array multi-dimensional, se necesita utilizar una función recursiva.

Ejemplo #2 Utilizando stripslashes() en un array

<?php
function stripslashes_deep($value)
{
    $value = is_array($value) ?
                array_map('stripslashes_deep', $value) :
                stripslashes($value);

    return $value;
}

// Ejemplo
$array = array("f\\'oo", "b\\'ar", array("fo\\'o", "b\\'ar"));
$array = stripslashes_deep($array);

// Salida
print_r($array);
?>

El resultado del ejemplo sería:

Array
(
    [0] => f'oo
    [1] => b'ar
    [2] => Array
        (
            [0] => fo'o
            [1] => b'ar
        )

)

Ver también

  • addslashes() - Escapa un string con barras invertidas
  • get_magic_quotes_gpc() - Obtiene el valor actual de configuración de magic_quotes_gpc


strstr insensible a mayúsculas y minúsculas

  • « stripslashes
  • strlen »
  • PHP Manual
  • Funciones de strings
  • strstr insensible a mayúsculas y minúsculas

stristr

(PHP 4, PHP 5, PHP 7, PHP 8)

stristr — strstr() insensible a mayúsculas y minúsculas

Descripción

stristr ( string $haystack , mixed $needle , bool $before_needle = false ) : string

Devuelve todo de haystack iniciando desde e incluyendo la primera aparición de needle hasta el final.

Parámetros

haystack

El string en donde buscar

needle

Si needle no es una cadena, se convierte a un entero y se aplica como el valor ordinal de un carácter. Este comportamiento está obsoleto a partir de PHP 7.3.0, por lo que su uso está totalmente desaconsejado. Dependiendo del comportamiento previsto, needle deberá ser convertido explícitamente a string, o realizar una llamada explícita a chr().

before_needle

Si es true, stristr() devuelve la parte del haystack anterior a la primera aparición del needle (excluyendo el needle).

needle y haystack se examinan de una manera insensible a mayúsculas y minúsculas.

Valores devueltos

Devuelve el substring coincidente. Si no se encuentra needle, devuelve false.

Historial de cambios

Versión | Descripción
5.3.0 | Agregado el parámetro opcional before_needle.
4.3.0 | stristr() se hizo seguro a nivel binario.

Ejemplos

Ejemplo #1 Ejemplo de stristr()

<?php
  $email = 'USER@EXAMPLE.com';
  echo stristr($email, 'e'); // salida ER@EXAMPLE.com
  echo stristr($email, 'e', true); // A partir de PHP 5.3.0, salida US
?>

Ejemplo #2 Probando si un string se encuentra o no

<?php
  $string = 'Hello World!';
  if(stristr($string, 'earth') === FALSE) {
    echo '"earth" not found in string';
  }
// salida: "earth" not found in string
?>

Ejemplo #3 Utilizando un needle no "string"

<?php
  $string = 'APPLE';
  echo stristr($string, 97); // 97 = a minúscula
// salida: APPLE
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strstr() - Encuentra la primera aparición de un string
  • strrchr() - Encuentra la última aparición de un caracter en un string
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • preg_match() - Realiza una comparación con una expresión regular


Obtiene la longitud de un string

  • « stristr
  • strnatcasecmp »
  • PHP Manual
  • Funciones de strings
  • Obtiene la longitud de un string

strlen

(PHP 4, PHP 5, PHP 7, PHP 8)

strlen — Obtiene la longitud de un string

Descripción

strlen ( string $string ) : int

Devuelve la longitud del string dado.

Parámetros

string

El string del cual medir su longitud.

Valores devueltos

La longitud del string en caso de éxito, y 0 si el string esta vacío.

Historial de cambios

Versión | Descripción
5.3.0 | Las versiones anteriores trataban los arrays como el string Array, devolviendo así una longitud de string de 5 y emitiendo un error de nivel E_NOTICE.

Ejemplos

Ejemplo #1 Un ejemplo destrlen()

<?php
$str = 'abcdef';
echo strlen($str); // 6

$str = ' ab cd ';
echo strlen($str); // 7
?>

Notas

Nota:

strlen() devuelve el número de bytes en lugar del número de caracteres de un string.

Nota:

strlen() devuelve null cuando se ejecuta sobre arrays, y emite un error de nivel E_WARNING.

Ver también

  • count() - Cuenta todos los elementos de un array o algo de un objeto
  • grapheme_strlen() - Obtener la longitud de un string en unidades de grafema
  • iconv_strlen() - Retorna el número de caracteres de un string
  • mb_strlen() - Obtiene la longitud de una cadena de caracteres


Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"

  • « strlen
  • strnatcmp »
  • PHP Manual
  • Funciones de strings
  • Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"

strnatcasecmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strnatcasecmp — Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"

Descripción

strnatcasecmp ( string $str1 , string $str2 ) : int

Esta función implementa un algoritmo de comparación que ordena strings alfanuméricos de la manera en que un humano lo haría. El comportamiento de ésta función es similar a strnatcmp(), excepto que la comparación no es sensible a mayúsculas y minúscula. Para más información ver la página de Martin Pool: » Natural Order String Comparison.

Parámetros

str1

El primer string.

str2

El segundo string.

Valores devueltos

De forma similar a otras funciones de comparación, esta devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2 y 0 si son iguales.

Ver también

  • preg_match() - Realiza una comparación con una expresión regular
  • strcmp() - Comparación de string segura a nivel binario
  • strcasecmp() - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strncasecmp() - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings
  • strstr() - Encuentra la primera aparición de un string
  • setlocale() - Establecer la información del localismo


Comparación de strings utilizando un algoritmo de "orden natural"

  • « strnatcasecmp
  • strncasecmp »
  • PHP Manual
  • Funciones de strings
  • Comparación de strings utilizando un algoritmo de "orden natural"

strnatcmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strnatcmp — Comparación de strings utilizando un algoritmo de "orden natural"

Descripción

strnatcmp ( string $str1 , string $str2 ) : int

Esta función implementa un algoritmo de comparación que ordena strings alfanuméricos de la manera en que un humano lo haría, lo cual se describe como "orden natural". Tener en cuenta que esta comparación es sensible a mayúsculas y minúsculas.

Parámetros

str1

El primer string.

str2

El segundo string.

Valores devueltos

De forma similar a otras funciones de comparación, esta devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2 y 0 si son iguales.

Ejemplos

Un ejemplo de la diferencia entre éste algoritmo y los algoritmos normales de clasificación del computador (usados en strcmp()), se puede ver a continuación

<?php
$arr1 = $arr2 = array("img12.png", "img10.png", "img2.png", "img1.png");
echo "Standard string comparison\n";
usort($arr1, "strcmp");
print_r($arr1);
echo "\nNatural order string comparison\n";
usort($arr2, "strnatcmp");
print_r($arr2);
?>

El resultado del ejemplo sería:

Standard string comparison
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Natural order string comparison
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)
Para más información ver la página de Martin Pool: » Natural Order String Comparison.

Ver también

  • preg_match() - Realiza una comparación con una expresión regular
  • strcasecmp() - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strcmp() - Comparación de string segura a nivel binario
  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings
  • strncasecmp() - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • strnatcasecmp() - Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"
  • strstr() - Encuentra la primera aparición de un string
  • natsort() - Ordena un array usando un algoritmo de "orden natural"
  • natcasesort() - Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas


Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas

  • « strnatcmp
  • strncmp »
  • PHP Manual
  • Funciones de strings
  • Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas

strncasecmp

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

strncasecmp — Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas

Descripción

strncasecmp ( string $str1 , string $str2 , int $len ) : int

Esta función es similar a strcasecmp(), con la diferencia de que puede especificar el (límite superior de) número de caracteres de cada cadena a ser usado en la comparación.

Parámetros

str1

La primera cadena.

str2

La segunda cadena.

len

La longitud de cadenas a ser usada en la comparación.

Valores devueltos

Devuelve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2, y 0 si son equivalentes.

Ver también

  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings
  • preg_match() - Realiza una comparación con una expresión regular
  • substr_compare() - Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
  • strcasecmp() - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena


Comparación segura a nivel binario de los primeros n caracteres entre strings

  • « strncasecmp
  • strpbrk »
  • PHP Manual
  • Funciones de strings
  • Comparación segura a nivel binario de los primeros n caracteres entre strings

strncmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strncmp — Comparación segura a nivel binario de los primeros n caracteres entre strings

Descripción

strncmp ( string $str1 , string $str2 , int $len ) : int

Esta función es similar a strcmp(), con la diferencia de que se puede especificar el (limite superior del) número de caracteres desde cada string a ser usado en la comparación.

Nótese que esta comparación es sensible a mayúsculas y minúsculas.

Parámetros

str1

El primer string.

str2

El segundo string.

len

El número de caracteres para usar en la comparación.

Valores devueltos

Devueleve < 0 si str1 es menor que str2; > 0 si str1 es mayor que str2 y 0 si son iguales.

Ver también

  • strncasecmp() - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
  • preg_match() - Realiza una comparación con una expresión regular
  • substr_compare() - Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
  • strcmp() - Comparación de string segura a nivel binario
  • strstr() - Encuentra la primera aparición de un string
  • substr() - Devuelve parte de una cadena


Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres

  • « strncmp
  • strpos »
  • PHP Manual
  • Funciones de strings
  • Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres

strpbrk

(PHP 5, PHP 7, PHP 8)

strpbrk — Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres

Descripción

strpbrk ( string $haystack , string $char_list ) : string

strpbrk() busca la cadena haystack por una char_list.

Parámetros

haystack

La cadena en donde char_list es buscada.

char_list

Este parámetro es sensible a mayúsculas y minúsculas.

Valores devueltos

Devuelve una cadena que empieza desde el caracter encontrado, o false si no se encuentra.

Ejemplos

Ejemplo #1 Ejemplo de strpbrk()

<?php

$texto = 'Este es un texto Simple.';

// esto imprime "e es un texto Simple." ya que 'e' coincide primero
echo strpbrk($texto, 'me');

// esto imprime "Simple." ya que los caracteres son sensibles a mayúsculas/minúsculas
echo strpbrk($texto, 'S');
?>

Ver también

  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • strstr() - Encuentra la primera aparición de un string
  • preg_match() - Realiza una comparación con una expresión regular


Encuentra la posición de la primera ocurrencia de un substring en un string

  • « strpbrk
  • strrchr »
  • PHP Manual
  • Funciones de strings
  • Encuentra la posición de la primera ocurrencia de un substring en un string

strpos

(PHP 4, PHP 5, PHP 7, PHP 8)

strpos — Encuentra la posición de la primera ocurrencia de un substring en un string

Descripción

strpos ( string $haystack , mixed $needle , int $offset = 0 ) : mixed

Encuentra la posición numérica de la primera ocurrencia del needle (aguja) en el string haystack (pajar).

Parámetros

haystack

El string en donde buscar.

needle

Si la needle no es una cadena, es convertida a integer y se interpreta como el valor ordinal de un carácter.

offset

Si se específica, la búsqueda iniciará en éste número de caracteres contados desde el inicio del string. A diferencia de strrpos() y strripos(), el offset no puede ser negativo.

Valores devueltos

Devuelve la posición donde la aguja existe, en relación al inicio del string haystack (independiente del offset). También tener en cuenta que las posiciones de inicio de los string empiezan en 0 y no 1.

Devuelve false si no fue encontrada la aguja.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Usando ===

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// Nótese el uso de ===. Puesto que == simple no funcionará como se espera
// porque la posición de 'a' está en el 1° (primer) caracter.
if ($pos === false) {
    echo "La cadena '$findme' no fue encontrada en la cadena '$mystring'";
} else {
    echo "La cadena '$findme' fue encontrada en la cadena '$mystring'";
    echo " y existe en la posición $pos";
}
?>

Ejemplo #2 Usando !==

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// El operador !== también puede ser usado. Puesto que != no funcionará como se espera
// porque la posición de 'a' es 0. La declaración (0 != false) se evalúa a
// false.
if ($pos !== false) {
     echo "La cadena '$findme' fue encontrada en la cadena '$mystring'";
         echo " y existe en la posición $pos";
} else {
     echo "La cadena '$findme' no fue encontrada en la cadena '$mystring'";
}
?>

Ejemplo #3 Uso de offset

<?php
// Se puede buscar por el caracter, ignorando cualquier cosa antes del offset
$newstring = 'abcdef abcdef';
$pos = strpos($newstring, 'a', 1); // $pos = 7, no 0
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strstr() - Encuentra la primera aparición de un string
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • substr() - Devuelve parte de una cadena
  • preg_match() - Realiza una comparación con una expresión regular


Encuentra la última aparición de un caracter en un string

  • « strpos
  • strrev »
  • PHP Manual
  • Funciones de strings
  • Encuentra la última aparición de un caracter en un string

strrchr

(PHP 4, PHP 5, PHP 7, PHP 8)

strrchr — Encuentra la última aparición de un caracter en un string

Descripción

strrchr ( string $haystack , mixed $needle ) : string

Esta función devuelve la porción de haystack la cual comienza en la última aparición de needle y que va hasta el final de haystack.

Parámetros

haystack

El string en donde buscar

needle

Si needle contiene más de un caracter, sólo se utiliza el primero. Este comportamiento es diferente que el de strstr().

Si needle no es una cadena, se convierte a un entero y se aplica como el valor ordinal de un carácter. Este comportamiento está obsoleto a partir de PHP 7.3.0, por lo que su uso está totalmente desaconsejado. Dependiendo del comportamiento previsto, needle deberá ser convertido explícitamente a string, o realizar una llamada explícita a chr().

Valores devueltos

Esta función devuelve la porción de string o false si no se encuentra needle.

Historial de cambios

Versión | Descripción
4.3.0 | Ahora esta función es segura a nivel binario.

Ejemplos

Ejemplo #1 Ejemplo de strrchr()

<?php
// obtiene el último directorio en $PATH
$dir = substr(strrchr($PATH, ":"), 1);

// obtiene todo lo que está después de la última nueva línea
$text = "Line 1\nLine 2\nLine 3";
$last = substr(strrchr($text, 10), 1 );
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strstr() - Encuentra la primera aparición de un string
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string


Invierte una string

  • « strrchr
  • strripos »
  • PHP Manual
  • Funciones de strings
  • Invierte una string

strrev

(PHP 4, PHP 5, PHP 7, PHP 8)

strrev — Invierte una string

Descripción

strrev ( string $string ) : string

devuelve la cadena, invertida.

Parámetros

cadena

La cadena que será invertida

Valores devueltos

devuelve la cadena invertida.

Ejemplos

Ejemplo #1 Invertir una cadena con strrev()

<?php
echo strrev("Hello world!"); // outputs "!dlrow olleH"
?>


Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string

  • « strrev
  • strrpos »
  • PHP Manual
  • Funciones de strings
  • Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string

strripos

(PHP 5, PHP 7, PHP 8)

strripos — Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string

Descripción

strripos ( string $haystack , mixed $needle , int $offset = 0 ) : int

Encuentra la posición de la última aparición de needle (aguja) en el string haystack (pajar).

A diferencia de strrpos(), strripos() es insensible a mayúsculas y minúsculas.

Parámetros

haystack

El string en donde buscar.

needle

Si needle no es una cadena, se convierte a un entero y se aplica como el valor ordinal de un carácter. Este comportamiento está obsoleto a partir de PHP 7.3.0, por lo que su uso está totalmente desaconsejado. Dependiendo del comportamiento previsto, needle deberá ser convertido explícitamente a string, o realizar una llamada explícita a chr().

offset

Si se especifica, la búsqueda iniciará en éste número de caracteres contados desde el comienzo del string. Si el valor es negativo, entonces la búsqueda iniciará desde esa cantidad de caracteres desde el final del string, buscando hacia atrás.

Valores devueltos

Devuelve la posición donde la aguja existe, en relación al inicio del string haystack (independiente de la dirección de la búsqueda o del offset). También tener en cuenta que las posiciones de inicio de los string empiezan en 0 y no 1.

Devuelve false si no fue encontrada la aguja.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Un ejemplo simple de strripos()

<?php
$haystack = 'ababcd';
$needle   = 'aB';

$pos      = strripos($haystack, $needle);

if ($pos === false) {
    echo "Sorry, we did not find ($needle) in ($haystack)";
} else {
    echo "Congratulations!\n";
    echo "We found the last ($needle) in ($haystack) at position ($pos)";
}
?>

El resultado del ejemplo sería:

   Congratulations!
   We found the last (aB) in (ababcd) at position (2)

Ver también

  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strrpos() - Encuentra la posición de la última aparición de un substring en un string
  • strrchr() - Encuentra la última aparición de un caracter en un string
  • stristr() - strstr insensible a mayúsculas y minúsculas
  • substr() - Devuelve parte de una cadena


Encuentra la posición de la última aparición de un substring en un string

  • « strripos
  • strspn »
  • PHP Manual
  • Funciones de strings
  • Encuentra la posición de la última aparición de un substring en un string

strrpos

(PHP 4, PHP 5, PHP 7, PHP 8)

strrpos — Encuentra la posición de la última aparición de un substring en un string

Descripción

strrpos ( string $haystack , mixed $needle , int $offset = 0 ) : int

Encuentra la posición númerica de la última aparición de needle (aguja) en el string haystack (pajar).

Parámetros

haystack

El string donde buscar.

needle

Si needle no es una cadena, se convierte a un entero y se aplica como el valor ordinal de un carácter. Este comportamiento está obsoleto a partir de PHP 7.3.0, por lo que su uso está totalmente desaconsejado. Dependiendo del comportamiento previsto, needle deberá ser convertido explícitamente a string, o realizar una llamada explícita a chr().

offset

Si se especifica, la búsqueda iniciará en éste número de caracteres contados desde el comienzo del string. Si el valor es negativo, entonces la búsqueda iniciará desde esa cantidad de caracteres desde el final del string, buscando hacia atrás.

Valores devueltos

Devuelve la posición donde la aguja existe en relación al inicio del string haystack (independiente de la dirección de la búsqueda o del offset). También tener en cuenta que las posiciones de inicio de los string empiezan en 0 y no 1.

Devuelve false si no fue encontrada la aguja.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
5.0.0 | needle puede ser ahora un string de más de un carácter.

Ejemplos

Ejemplo #1 Verificando si hay una aguja en el pajar

Es fácil confundir el valor devuelto por "caracter encontrado en la posición 0" y "caracter no encontrado". Aquí está la forma de detectar la diferencia:

<?php

$pos = strrpos($mystring, "b");
if ($pos === false) { // nota: tres signos de igual
    // no encontrado...
}

?>

Ejemplo #2 Buscando con desplazamientos

<?php
$foo = "0123456789a123456789b123456789c";

var_dump(strrpos($foo, '7', -5));  // Comienza mirando hacia atrás cinco posiciones
                                   // desde el final. Resultado: int(17)

var_dump(strrpos($foo, '7', 20));  // Inicia la búsqueda 20 posiciones en el
                                   // string. Resultado: int(27)

var_dump(strrpos($foo, '7', 28));  // Resultado: bool(false)
?>

Ver también

  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • stripos() - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
  • strripos() - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
  • strrchr() - Encuentra la última aparición de un caracter en un string
  • substr() - Devuelve parte de una cadena


Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada

  • « strrpos
  • strstr »
  • PHP Manual
  • Funciones de strings
  • Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada

strspn

(PHP 4, PHP 5, PHP 7, PHP 8)

strspn — Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada

Descripción

strspn ( string $subject , string $mask , int $start = ? , int $length = ? ) : int

Encuentra la longitud del segmento inicial de subject que contiene solamente caracteres de mask.

Si start y length son omitidos, entonces la totalidad de subject será examinada. Si son incluidos, entonces el efecto será el mismo que llamando strspn(substr($subject, $start, $length), $mask) (ver substr para más información).

La línea de código:

<?php
$var = strspn("42 is the answer to the 128th question.", "1234567890");
?>
asignará 2 a $var, debido a que el string "42" es el segmento inicial de subject que consiste solamente en caracteres contenidos dentro de "1234567890".

Parámetros

subject

El string a examinar.

mask

La lista de caracteres permitidos.

start

La posición en subject donde iniciar la búsqueda.

Si start es dado y no es negativo, entonces strspn() comenzará a examinar a subject en la posición startésima. Por ejemplo, en el string 'abcdef', el caracter en la posición 0 es 'a', el caracter en la posición 2 es 'c' y así sucesivamente.

Si start es dado y es negativo, entonces strspn() comenzará a examinar subject desde la startésima posición desde el final de subject.

length

La longitud del segmento de subject a examinar.

Si se proporciona length y no es negativo, entonces subject será examinado por el número length de caracteres después de la posición de inicio.

Si se proporciona length y es negativo, entonces subject sera examinado desde la posición de inicio hasta el número length de caracteres desde el final de subject.

Valores devueltos

Devuelve la longitud del segmento inicial de subject el cual enteramente consiste en caracteres en mask.

Nota:

Cuando se establece el parámetro start, la longitud devuelta se cuenta a partir de esta posición, no desde el comienzo de subject.

Ejemplos

Ejemplo #1 Ejemplo de strspn()

<?php
// subject no inicia con ningún caracter de mask
var_dump(strspn("foo", "o"));

// examina dos caracteres de subject iniciando en el offset 1
var_dump(strspn("foo", "o", 1, 2));

// examina un caracter de subject iniciando en el offset 1
var_dump(strspn("foo", "o", 1, 1));
?>

El resultado del ejemplo sería:

int(0)
int(2)
int(1)

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strcspn() - Averiguar la longitud del segmento inicial que no coincida con una máscara


Encuentra la primera aparición de un string

  • « strspn
  • strtok »
  • PHP Manual
  • Funciones de strings
  • Encuentra la primera aparición de un string

strstr

(PHP 4, PHP 5, PHP 7, PHP 8)

strstr — Encuentra la primera aparición de un string

Descripción

strstr ( string $haystack , mixed $needle , bool $before_needle = false ) : string

Devuelve parte del string haystack iniciando desde e incluyendo la primera aparición de needle (aguja) hasta el final del haystack (pajar).

Nota:

Esta función es sensible a mayúsculas. Para búsquedas sin importar las mayúsculas, use stristr().

Nota:

Si solo se quiere saber si un needle determinado aparece en un haystack, se utiliza la función strpos() que es más rápida y requiere menos memoria.

Parámetros

haystack

El string en donde buscar.

needle

Si needle no es una cadena, se convierte a un entero y se aplica como el valor ordinal de un carácter. Este comportamiento está obsoleto a partir de PHP 7.3.0, por lo que su uso está totalmente desaconsejado. Dependiendo del comportamiento previsto, needle deberá ser convertido explícitamente a string, o realizar una llamada explícita a chr().

before_needle

Si se define como true, strstr() devolverá la parte del haystack antes de la primera ocurrencia de needle (excluyendo el needle).

Valores devueltos

Devuelve una parte de un string o false si no se encuentra el needle.

Historial de cambios

Versión | Descripción
5.3.0 | Se añadió el parámetro opcional before_needle.
4.3.0 | strstr() se hizo segura binariamente.

Ejemplos

Ejemplo #1 Ejemplo de strstr()

<?php
$email  = 'name@example.com';
$domain = strstr($email, '@');
echo $domain; // mostrará @example.com

$user = strstr($email, '@', true); // Desde PHP 5.3.0
echo $user; // mostrará name
?>

Ver también

  • stristr() - strstr insensible a mayúsculas y minúsculas
  • strrchr() - Encuentra la última aparición de un caracter en un string
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • strpbrk() - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
  • preg_match() - Realiza una comparación con una expresión regular


Tokeniza string

  • « strstr
  • strtolower »
  • PHP Manual
  • Funciones de strings
  • Tokeniza string

strtok

(PHP 4, PHP 5, PHP 7, PHP 8)

strtok — Tokeniza string

Descripción

strtok ( string $str , string $token ) : string
strtok ( string $token ) : string

strtok() divide un string (str) en strings más pequeños (tokens), con cada token delimitado por cualquier caracter de token. Es decir, si se tiene un string como "Este es un string de ejemplo", se puede tokenizar en sus palabras individuales utilizando el caracter de espacio como el token.

Nótese que sólo la primera llamada a strtok utiliza el argumento string. Cada llamada subsecuente a strtok sólo necesita el token a utilizar, ya que realiza un seguimiento del lugar en que se encuentra en el string actual. Para volver a empezar, o para dividir una cadena nueva, simplemente se llama a strtok de nuevo con el argumento string para inicializarlo. Tener en cuenta que se pueden poner tokens múltiples como parámetro. El string será tokenizado cuando cualquiera de los caracteres en el argumento sea encontrado.

Parámetros

str

El string a ser dividido en strings más pequeños (tokens).

token

El delimitador usado cuando se divide str.

Valores devueltos

Un token de string.

Ejemplos

Ejemplo #1 Ejemplo de strtok()

<?php
$string = "This is\tan example\nstring";
/* Utiliza tabulador y nueva línea como caracteres de tokenización, así  */
$tok = strtok($string, " \n\t");

while ($tok !== false) {
    echo "Word=$tok<br />";
    $tok = strtok(" \n\t");
}
?>

El comportamiento cuando se encuentra una parte vacía, cambió con PHP 4.1.0. El comportamiento anterior devolvía una cadena vacía, mientras que el comportamiento nuevo y correcto simplemente se salta esa parte del string:

Ejemplo #2 Comportamiento anterior de strtok()

<?php
$first_token  = strtok('/something', '/');
$second_token = strtok('/');
var_dump($first_token, $second_token);
?>

El resultado del ejemplo sería:

    string(0) ""
    string(9) "something"

Ejemplo #3 Comportamiento nuevo de strtok()

<?php
$first_token  = strtok('/something', '/');
$second_token = strtok('/');
var_dump($first_token, $second_token);
?>

El resultado del ejemplo sería:

    string(9) "something"
    bool(false)

Notas

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ver también

  • split() - Divide una cadena en una matriz mediante una expresión regular
  • explode() - Divide un string en varios string


Convierte un string a minúsculas

  • « strtok
  • strtoupper »
  • PHP Manual
  • Funciones de strings
  • Convierte un string a minúsculas

strtolower

(PHP 4, PHP 5, PHP 7, PHP 8)

strtolower — Convierte un string a minúsculas

Descripción

strtolower ( string $string ) : string

Devuelve un string con todos los caracteres alfabéticos convertidos a minúsculas.

Note que "alfabético" está determinado por la ubicación actual. Esto significa que por ejemplo, en la localidad "C" predeterminada, los caracteres como la diéresis-A (Ä) no serán convertidos.

Parámetros

string

El string de entrada.

Valores devueltos

Devuelve el string en minúsculas.

Ejemplos

Ejemplo #1 Ejemplo de strtolower()

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtolower($str);
echo $str; // Imprime Mary Had A Little Lamb and She LOVED It So
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strtoupper() - Convierte un string a mayúsculas
  • ucfirst() - Convierte el primer caracter de una cadena a mayúsculas
  • ucwords() - Convierte a mayúsculas el primer caracter de cada palabra de una cadena
  • mb_strtolower() - Convierte una cadena de caracteres a minúsculas


Convierte un string a mayúsculas

  • « strtolower
  • strtr »
  • PHP Manual
  • Funciones de strings
  • Convierte un string a mayúsculas

strtoupper

(PHP 4, PHP 5, PHP 7, PHP 8)

strtoupper — Convierte un string a mayúsculas

Descripción

strtoupper ( string $string ) : string

Devuelve el string con todos los caracteres alfabéticos convertidos a mayúsculas.

Notar que ser 'alfabético' está determinado por la configuración regional actual. Por ejemplo, en la configuración regional por defecto "C" caracteres como la diéresis-a (ä) no se convertirán.

Parámetros

string

El string de entrada.

Valores devueltos

Devuelve el string en mayúsculas.

Ejemplos

Ejemplo #1 Ejemplo de strtoupper()

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtoupper($str);
echo $str; // muestra: MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strtolower() - Convierte un string a minúsculas
  • ucfirst() - Convierte el primer caracter de una cadena a mayúsculas
  • ucwords() - Convierte a mayúsculas el primer caracter de cada palabra de una cadena
  • mb_strtoupper() - Convierte un string en mayúsculas


Convierte caracteres o reemplaza substrings

  • « strtoupper
  • substr_compare »
  • PHP Manual
  • Funciones de strings
  • Convierte caracteres o reemplaza substrings

strtr

(PHP 4, PHP 5, PHP 7, PHP 8)

strtr — Convierte caracteres o reemplaza substrings

Descripción

strtr ( string $str , string $from , string $to ) : string
strtr ( string $str , array $replace_pairs ) : string

Si se dan tres argumentos, esta función devuelve una copia de str, donde todas las apariciones de cada carácter (byte simple) en from han sido convertidas al carácter correspondiente en to, es decir, todas las apariciones de $from[$n] han sido reemplazadas con $to[$n], donde $n es un índice válido en ambos argumentos.

Si from y to tienen distinta logitud, se ignoran los caracteres extra del string más largo. La longitud de str será la misma que la del valor devuelto.

Si se dan dos argumentos, el segundo debería ser un array en la forma array('from' => 'to', ...). El valor devuelto es un string donde todas las apariciones de las claves del array han sido reemplazadas por los valores correspondientes. Las claves más largas se probarán primero. Una vez un substring ha sido reemplazado, su nuevo valor no se buscará de nuevo.

En este caso, las claves y los valores pueden tener cualquier longitud, siempre que no haya claves vacías; además, la longitud del valor devuelto podría diferir de la de str. Sin embargo, esta función será la más eficiente cuando todas las claves tienen el mismo tamaño.

Parámetros

string

El string a convertir.

from

El string a convertir a to.

to

El string que reemplaza a from.

replace_pairs

El parámetro replace_pairs se podría usar en lugar de to y from, en cuyo caso sería un array en la forma array('from' => 'to', ...).

Valores devueltos

Devuelve el string convertido.

Si replace_pairs contiene una clave que es un string vacío (""), devolverá false. Si str no es un escalar, no será convertido a un string, se emitirá una advertencia y devolverá null.

Ejemplos

Ejemplo #1 Ejemplo de strtr()

<?php
//De esta forma, strtr() hace una conversión byte a byte
//Por lo tanto, aquí se asume una codificación de un solo byte:
$addr = strtr($addr, "äåö", "aao");
?>

El siguiente ejemplo muestra el comportamiento de strtr() cuando se llama con sólo dos argumentos. Observe la preferencia de los reemplazos ("h" no se toma porque hay coincidencias más largas) y cómo el texto remplazado no se busca de nuevo.

Ejemplo #2 Ejemplo de strtr() con dos argumentos

<?php
$conv = array("h" => "-", "hola" => "hey", "hey" => "hola");
echo strtr("hey, dije hola", $conv);
?>

El resultado del ejemplo sería:

hola, dije hey

Los dos modos de comportamiento son muy diferentes. Con tres argumentos, strtr() reemplazará bytes; con dos, podría reemplazar substrings más largos.

Ejemplo #3 Comparación del comportamiento de strtr()

<?php
echo strtr("baab", "ab", "01"),"\n";

$conv = array("ab" => "01");
echo strtr("baab", $conv);
?>

El resultado del ejemplo sería:

1001
ba01

Ver también

  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo
  • preg_replace() - Realiza una búsqueda y sustitución de una expresión regular


Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada

  • « strtr
  • substr_count »
  • PHP Manual
  • Funciones de strings
  • Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada

substr_compare

(PHP 5, PHP 7, PHP 8)

substr_compare — Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada

Descripción

substr_compare ( string $main_str , string $str , int $offset , int $length = ? , bool $case_insensitivity = false ) : int

substr_compare() compara main_str desde la posición offset con str hasta la cantidad length de caracteres.

Parámetros

main_str

El string principal a comparar.

str

El string secundario a comparar.

offset

La posición de inicio para la comparación. Si es negativa, se comienza a contar desde el final del string.

length

La longitud de la comparación. El valor predeterminado es el que sea mayor entre la longitud de str comparado con la longitud de main_str menos el offset.

case_insensitivity

Si case_insensitivity es true, la comparación no considera el uso de mayúsculas y minúsculas.

Valores devueltos

Devuelve < 0 si main_str, desde la posición offset, es menor que str, > 0 si es mayor que str, y 0 si son iguales. Si offset es igual o mayor que la longitud de main_str, o length se establece y es menor que 1 (antes de PHP 5.5.11), substr_compare() muestra una advertencia y devuelve false.

Historial de cambios

Versión | Descripción
5.5.11 | length ahora puede ser 0.
5.1.0 | Se añadió la posibilidad de usar un offset negativo.

Ejemplos

Ejemplo #1 Un ejemplo de substr_compare()

<?php
echo substr_compare("abcde", "bc", 1, 2); // 0
echo substr_compare("abcde", "de", -2, 2); // 0
echo substr_compare("abcde", "bcg", 1, 2); // 0
echo substr_compare("abcde", "BC", 1, 2, true); // 0
echo substr_compare("abcde", "bc", 1, 3); // 1
echo substr_compare("abcde", "cd", 1, 2); // -1
echo substr_compare("abcde", "abc", 5, 1); // advertencia
?>

Ver también

  • strncmp() - Comparación segura a nivel binario de los primeros n caracteres entre strings


Cuenta el número de apariciones del substring

  • « substr_compare
  • substr_replace »
  • PHP Manual
  • Funciones de strings
  • Cuenta el número de apariciones del substring

substr_count

(PHP 4, PHP 5, PHP 7, PHP 8)

substr_count — Cuenta el número de apariciones del substring

Descripción

substr_count ( string $haystack , string $needle , int $offset = 0 , int $length = ? ) : int

substr_count() devuelve el número de veces en que el substring needle aparece en el string haystack. Por favor nótese que needle es sensible a mayúsculas y minúsculas.

Nota:

Esta función no cuenta las subcadenas que se traslapan. Véase el ejemplo de abajo!

Parámetros

haystack

El string dentro del cual buscar

needle

El substring a buscar

offset

El desplazamiento por dónde empezar a contar

length

La longitud máxima después del desplazamiento especificado para buscar el substring. Se emite una advertencia si offset más length es mayor que la longitud de haystack.

Valores devueltos

Esta función devuelve un integer.

Historial de cambios

Versión | Descripción
5.1.0 | Los parámetros offset y length fueron agregados

Ejemplos

Ejemplo #1 Ejemplo de substr_count()

<?php
$text = 'This is a test';
echo strlen($text); // 14

echo substr_count($text, 'is'); // 2

// el string es reducido a 's is a test', así que muestra 1
echo substr_count($text, 'is', 3);

// el texto es reducido a 's i', así que muestra 0
echo substr_count($text, 'is', 3, 3);

// genera una advertencia debido a que 5+10 > 14
echo substr_count($text, 'is', 5, 10);

// muestra sólo 1, debido a que no cuenta subcadenas traslapadas.
$text2 = 'gcdgcdgcd';
echo substr_count($text2, 'gcdgcd');
?>

Ver también

  • count_chars() - Devuelve información sobre los caracteres usados en una cadena
  • strpos() - Encuentra la posición de la primera ocurrencia de un substring en un string
  • substr() - Devuelve parte de una cadena
  • strstr() - Encuentra la primera aparición de un string


Reemplaza el texto dentro de una porción de un string

  • « substr_count
  • substr »
  • PHP Manual
  • Funciones de strings
  • Reemplaza el texto dentro de una porción de un string

substr_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

substr_replace — Reemplaza el texto dentro de una porción de un string

Descripción

substr_replace ( mixed $string , mixed $replacement , mixed $start , mixed $length = ? ) : mixed

substr_replace() reemplaza una copia de string delimitada por los parámetros start y (opcionalmente) length con el string dado en replacement.

Parámetros

string

El string de entrada.

Un array de strings puede ser proporcionado, en el caso de que las sustituciones ocurran, a su vez, en cada string. En este caso, los parámetros replacement, start y length pueden ser proporcionados ya sea como valores escalares que serán aplicados a cada string de entrada, a su vez, o como arrays, en cuyo caso el correspondiente elemento del array será usado para cada string de entrada.

replacement

El string de reemplazo.

start

Si start es positivo, el reemplazo iniciará en el startésimo desplazamiento dentro del string.

Si start es negativo, el reemplazo iniciará en el startésimo caracter desde el final del string.

length

Si se da y es positivo, representa la longitud de la porción de string que se va a reemplazar. Si es negativo, representa el número de caracteres desde el final del string en el cual se deja de sustituir. Si no se da, entonces se usará por defecto strlen( string ); es decir que la sustitución terminará en el final de string. Por supuesto, si length es cero, entonces esta función tendrá el efecto de la inserción de replacement dentro de string en el desplazamiento dado por start.

Valores devueltos

El string del resultado es devuelto. Si string es un array entonces un array es devuelto.

Ejemplos

Ejemplo #1 Ejemplo desubstr_replace()

<?php
$var = 'ABCDEFGH:/MNRPQR/';
echo "Original: $var<hr />\n";

/* Estos dos ejemplos reemplazan todo $var por 'bob'. */
echo substr_replace($var, 'bob', 0) . "<br />\n";
echo substr_replace($var, 'bob', 0, strlen($var)) . "<br />\n";

/* Inserta 'bob' justo al comienzo de $var. */
echo substr_replace($var, 'bob', 0, 0) . "<br />\n";

/* Estos dos siguientes reemplazan 'MNRPQR' en $var por 'bob'. */
echo substr_replace($var, 'bob', 10, -1) . "<br />\n";
echo substr_replace($var, 'bob', -7, -1) . "<br />\n";

/* Elimina 'MNRPQR' de $var. */
echo substr_replace($var, '', 10, -1) . "<br />\n";
?>

Ejemplo #2 Usando substr_replace() para reemplazar múltiples strings de una vez

<?php
$input = array('A: XXX', 'B: XXX', 'C: XXX');

// Un caso simple: remplazar XXX en cada string con YYY.
echo implode('; ', substr_replace($input, 'YYY', 3, 3))."\n";

// Un caso más complicado donde cada remplazo es diferente.
$replace = array('AAA', 'BBB', 'CCC');
echo implode('; ', substr_replace($input, $replace, 3, 3))."\n";

// Remplaza un número diferente de caracteres cada vez.
$length = array(1, 2, 3);
echo implode('; ', substr_replace($input, $replace, 3, $length))."\n";
?>

El resultado del ejemplo sería:

A: YYY; B: YYY; C: YYY
A: AAA; B: BBB; C: CCC
A: AAAXX; B: BBBX; C: CCC

Notas

Nota: Esta función es segura binariamente.

Ver también

  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo
  • substr() - Devuelve parte de una cadena
  • String access and modification by character


Devuelve parte de una cadena

  • « substr_replace
  • trim »
  • PHP Manual
  • Funciones de strings
  • Devuelve parte de una cadena

substr

(PHP 4, PHP 5, PHP 7, PHP 8)

substr — Devuelve parte de una cadena

Descripción

substr ( string $string , int $start , int $length = ? ) : string

Devuelve una parte del string definida por los parámetros start y length.

Parámetros

string

La cadena de entrada. Debe ser de almenos de un caracter.

start

Si start no es negativo, la cadena devuelta comenzará en el start de la posición del string empezando desde cero. Por ejemplo, en la cadena 'abcdef', el carácter en la posición 0 es 'a', el carácter en la posición 2 es 'c', y así sucesivamente.

Si start es negativo, la cadena devuelta empezará en start contando desde el final de string.

Si la longitud del string es menor que start, la función devolverá false.

Ejemplo #1 Usando un start negativo

<?php
$rest = substr("abcdef", -1);    // devuelve "f"
$rest = substr("abcdef", -2);    // devuelve "ef"
$rest = substr("abcdef", -3, 1); // devuelve "d"
?>

length

Si se especifica el length y es positivo, la cadena devuelta contendrá como máximo de caracteres de la cantidad dada por length que comienza en start (dependiedo de la longitud del string).

Si se especifica length es negativo, entonces ese número de caracteres se omiten al final del string (después de la posición inicial se ha calculado a start es negativo). Si start indica la posición de su truncamiento o más allá, se devolverá false.

Si se omite el length, la subcadena empezará por start hasta el final de la cadena donde será devuelta.

Si se especifica length y es 0, false o null devolverá una cadena vacía.

Ejemplo #2 Usando un length negativo

<?php
$rest = substr("abcdef", 0, -1);  // devuelve "abcde"
$rest = substr("abcdef", 2, -1);  // devuelve "cde"
$rest = substr("abcdef", 4, -4);  // devuelve false
$rest = substr("abcdef", -3, -1); // devuelve "de"
?>

Valores devueltos

Devuelve la parte extraída de string; o false en caso de error o un string vacío.

Historial de cambios

Versión | Descripción
7.0.0 | Si la longitud de caracteres de string es igual a start, se devolverá una cadena vacía. Antes de esta versión, en este caso se devolvía false.
5.2.2 - 5.2.6 | Si el parámetro start indica una posición negativa de truncamiento o más allá, se devolverá false. En otras versiones de PHP obtienen la cadena desde el principio.

Ejemplos

Ejemplo #3 Uso básico de substr()

<?php
echo substr('abcdef', 1);     // bcdef
echo substr('abcdef', 1, 3);  // bcd
echo substr('abcdef', 0, 4);  // abcd
echo substr('abcdef', 0, 8);  // abcdef
echo substr('abcdef', -1, 1); // f

// El acceso a caracteres específicos en una cadena
// se puede conseguir usando "corchetes"
$string = 'abcdef';
echo $string[0];                 // a
echo $string[3];                 // d
echo $string[strlen($string)-1]; // f

?>

Ejemplo #4 Comportamiento de casting de substr()

<?php
class apple {
    public function __toString() {
        return "green";
    }
}

echo "1) ".var_export(substr("pear", 0, 2), true).PHP_EOL;
echo "2) ".var_export(substr(54321, 0, 2), true).PHP_EOL;
echo "3) ".var_export(substr(new apple(), 0, 2), true).PHP_EOL;
echo "4) ".var_export(substr(true, 0, 1), true).PHP_EOL;
echo "5) ".var_export(substr(false, 0, 1), true).PHP_EOL;
echo "6) ".var_export(substr("", 0, 1), true).PHP_EOL;
echo "7) ".var_export(substr(1.2e3, 0, 4), true).PHP_EOL;
?>

Salida del ejemplo anterior en PHP 7:

1) 'pe'
2) '54'
3) 'gr'
4) '1'
5) ''
6) ''
7) '1200'

Salida del ejemplo anterior en PHP 5:

1) 'pe'
2) '54'
3) 'gr'
4) '1'
5) false
6) false
7) '1200'

Errores/Excepciones

Devuelve false en caso de error.

<?php
var_dump(substr('a', 2)); // bool(false)
?>

Ver también

  • strrchr() - Encuentra la última aparición de un caracter en un string
  • substr_replace() - Reemplaza el texto dentro de una porción de un string
  • preg_match() - Realiza una comparación con una expresión regular
  • trim() - Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
  • mb_substr() - Obtiene parte de una cadena de caracteres
  • wordwrap() - Ajusta un string hasta un número dado de caracteres
  • Acceso a cadenas y modificación por caracter


Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena

  • « substr
  • ucfirst »
  • PHP Manual
  • Funciones de strings
  • Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena

trim

(PHP 4, PHP 5, PHP 7, PHP 8)

trim — Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena

Descripción

trim ( string $str , string $character_mask = " \t\n\r\0\x0B" ) : string

Esta función devuelve una cadena con los espacios en blanco eliminados del inicio y final del str. sin el segundo parámetro, trim() eliminará estos caracteres:

  • " " (ASCII 32 (0x20)), espacio simple.
  • "\t" (ASCII 9 (0x09)), tabulación.
  • "\n" (ASCII 10 (0x0A)), salto de línea.
  • "\r" (ASCII 13 (0x0D)), retorno de carro.
  • "\0" (ASCII 0 (0x00)), el byte NUL.
  • "\x0B" (ASCII 11 (0x0B)), tabulación vertical.

Parámetros

str

La cadena que será recortada.

character_mask

De manera opcional, los caracteres a ser eliminados pueden ser especificados usando el parámetro character_mask. Simplemente lista todos los caracteres que se quieran eliminar. Se puede especificar un rango de caracteres usando ...

Valores devueltos

La cadena recortada.

Ejemplos

Ejemplo #1 Ejemplo de uso de trim()

<?php

$text   = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = trim($text);
var_dump($trimmed);

$trimmed = trim($text, " \t.");
var_dump($trimmed);

$trimmed = trim($hello, "Hdle");
var_dump($trimmed);

$trimmed = trim($hello, 'HdWr');
var_dump($trimmed);

// Elimina los caracteres de control ASCII al inicio y final de $binary
// (from 0 to 31 inclusive)
$clean = trim($binary, "\x00..\x1F");
var_dump($clean);

?>

El resultado del ejemplo sería:

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(28) "These are a few words :) ..."
string(24) "These are a few words :)"
string(5) "o Wor"
string(9) "ello Worl"
string(14) "Example string"

Ejemplo #2 Uso de trim() en valores de un array

<?php
function trim_value(&$value)
{
    $value = trim($value);
}

$fruit = array('apple','banana ', ' cranberry ');
var_dump($fruit);

array_walk($fruit, 'trim_value');
var_dump($fruit);

?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  string(5) "apple"
  [1]=>
  string(7) "banana "
  [2]=>
  string(11) " cranberry "
}
array(3) {
  [0]=>
  string(5) "apple"
  [1]=>
  string(6) "banana"
  [2]=>
  string(9) "cranberry"
}

Notas

Nota: Posible trampa: eliminando caracteres de en medio

Debido a que trim() recorta los caracteres del principio y el final de un string, puede ser confuso cuando caracteres son (o no son) removidos del medio. trim('abc', 'bad') remueve tanto 'a' como 'b' debido a que cuando recorta 'a' entonces 'b' se mueve al inicio para también ser recortado. Por lo tanto, es por eso que "funciona", mientras que en trim('abc', 'b'), aparentemente no es así.

Ver también

  • ltrim() - Retira espacios en blanco (u otros caracteres) del inicio de un string
  • rtrim() - Retira los espacios en blanco (u otros caracteres) del final de un string
  • str_replace() - Reemplaza todas las apariciones del string buscado con el string de reemplazo


Convierte el primer caracter de una cadena a mayúsculas

  • « trim
  • ucwords »
  • PHP Manual
  • Funciones de strings
  • Convierte el primer caracter de una cadena a mayúsculas

ucfirst

(PHP 4, PHP 5, PHP 7, PHP 8)

ucfirst — Convierte el primer caracter de una cadena a mayúsculas

Descripción

ucfirst ( string $str ) : string

Devuelve una cadena con el primer caracter str en máyusculas, si el caracter es alfabético.

Nótese que 'alfabético' se determina por la localización actual. Por ejemplo, los carácteres de localización "C" como umlaut-a (ä) no serán convertidos.

Parámetros

str

La cadena de entrada.

Valores devueltos

Devuelve la cadena resultante.

Ejemplos

Ejemplo #1 Ejemplo de ucfirst()

<?php
$foo = 'hello world!';
$foo = ucfirst($foo);             // Hello world!

$bar = 'HELLO WORLD!';
$bar = ucfirst($bar);             // HELLO WORLD!
$bar = ucfirst(strtolower($bar)); // Hello world!
?>

Ver también

  • lcfirst() - Pasa a minúscula el primer caracter de un string
  • strtolower() - Convierte un string a minúsculas
  • strtoupper() - Convierte un string a mayúsculas
  • ucwords() - Convierte a mayúsculas el primer caracter de cada palabra de una cadena


Convierte a mayúsculas el primer caracter de cada palabra de una cadena

  • « ucfirst
  • vfprintf »
  • PHP Manual
  • Funciones de strings
  • Convierte a mayúsculas el primer caracter de cada palabra de una cadena

ucwords

(PHP 4, PHP 5, PHP 7, PHP 8)

ucwords — Convierte a mayúsculas el primer caracter de cada palabra de una cadena

Descripción

ucwords ( string $str , string $delimiters = " \t\r\n\f\v" ) : string

Devuelve una cadena con la primera letra de cada palabra de str convertida a mayúsculas, si el caracter es alfanumérico.

La definición de una palabra es una cadena de caracteres que está inmediatamente después de cualquier carácter enumerado en el parámetro delimiters (Por defecto son: espacio, avance de página, nueva línea, retorno de carro, tabulación horizonal y tabulación vertical).

Parámetros

str

La cadena de entrada.

delimiters

El parámetro opcional delimiters contiene los caracteres separadores de palabras.

Valores devueltos

Devuelve la cadena modificada.

Historial de cambios

Versión | Descripción
5.4.32, 5.5.16 | Se añadió el parámetro delimiters.

Ejemplos

Ejemplo #1 Ejemplo de ucwords()

<?php
$foo = 'hello world!';
$foo = ucwords($foo);             // Hello World!

$bar = 'HELLO WORLD!';
$bar = ucwords($bar);             // HELLO WORLD!
$bar = ucwords(strtolower($bar)); // Hello World!
?>

Ejemplo #2 Ejemplo de ucwords() con delimitadores personalizados

<?php
$foo = 'hello|world!';
$bar = ucwords($foo);             // Hello|world!

$baz = ucwords($foo, "|");        // Hello|World!
?>

Notas

Nota: Esta función es segura binariamente.

Ver también

  • strtoupper() - Convierte un string a mayúsculas
  • strtolower() - Convierte un string a minúsculas
  • ucfirst() - Convierte el primer caracter de una cadena a mayúsculas
  • mb_convert_case() - Realiza una conversión a mayúsculas/minúsculas de un string


Escribe un string con formato en un flujo

  • « ucwords
  • vprintf »
  • PHP Manual
  • Funciones de strings
  • Escribe un string con formato en un flujo

vfprintf

(PHP 5, PHP 7, PHP 8)

vfprintf — Escribe un string con formato en un flujo

Descripción

vfprintf ( resource $handle , string $format , array $args ) : int

Escribe un string producido de acuerdo con el format en el recurso del flujo especificado mediante handle.

Opera como fprintf() pero acepta un array de argumentos, en lugar de un número variable de argumentos.

Parámetros

handle

format

Ver sprintf() para una descripción de format.

args

Valores devueltos

Devuelve la longitud del string de salida.

Ejemplos

Ejemplo #1 vfprintf(): números extendidos con ceros

<?php
if (!($fp = fopen('date.txt', 'w')))
    return;

vfprintf($fp, "%04d-%02d-%02d", array($year, $month, $day));
// escribirá la fecha con formato ISO en date.txt
?>

Ver también

  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado
  • sscanf() - Interpreta un string de entrada de acuerdo con un formato
  • fscanf() - Analiza la entrada desde un archivo de acuerdo a un formato
  • vsprintf() - Devuelve una cadena con formato
  • number_format() - Formatear un número con los millares agrupados


Muestra una cadena con formato

  • « vfprintf
  • vsprintf »
  • PHP Manual
  • Funciones de strings
  • Muestra una cadena con formato

vprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

vprintf — Muestra una cadena con formato

Descripción

vprintf ( string $format , array $args ) : int

Despliega los valores de un array como una cadena con formato de acuerdo al formato (el cual es descrito en la documentación de sprintf()).

Opera como printf() pero acepta un array como sus argumentos, en lugar de un número variable de argumentos.

Parámetros

format

Ver sprintf() para una descripción de format.

args

Valores devueltos

Devuelve la longitud de la cadena mostrada.

Ejemplos

Ejemplo #1 vprintf(): zero-padded integers

<?php
vprintf("%04d-%02d-%02d", explode('-', '1988-8-1')); // 1988-08-01
?>

Ver también

  • printf() - Imprimir una cadena con formato
  • sprintf() - Devuelve un string formateado
  • vsprintf() - Devuelve una cadena con formato


Devuelve una cadena con formato

  • « vprintf
  • wordwrap »
  • PHP Manual
  • Funciones de strings
  • Devuelve una cadena con formato

vsprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

vsprintf — Devuelve una cadena con formato

Descripción

vsprintf ( string $format , array $args ) : string

Opera como sprintf() pero acepta un array de argumentos, en lugar de un número variable de argumentos.

Parámetros

format

Ver sprintf() para una descripción de format.

args

Valores devueltos

Devuelve los valores de un array como una cadena con formato de acuerdo a format (el cual es descrito en la documentación de sprintf()).

Ejemplos

Ejemplo #1 vsprintf(): zero-padded integers

<?php
print vsprintf("%04d-%02d-%02d", explode('-', '1988-8-1')); // 1988-08-01
?>

Ver también

  • sprintf() - Devuelve un string formateado
  • vprintf() - Muestra una cadena con formato


Ajusta un string hasta un número dado de caracteres

  • « vsprintf
  • Registro de cambios »
  • PHP Manual
  • Funciones de strings
  • Ajusta un string hasta un número dado de caracteres

wordwrap

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

wordwrap — Ajusta un string hasta un número dado de caracteres

Descripción

wordwrap ( string $str , int $width = 75 , string $break = "\n" , bool $cut = false ) : string

Ajusta un string hasta un número dado de caracteres utilizando un caracter de salto de string.

Parámetros

str

El string de entrada.

width

El número de caracteres en el cual el string se verá envuelto.

break

La línea se rompe utilizando el parámetro opcional break.

cut

Si cut se establece en true, el string siempre será ajustado en o antes del width especificado. De tal forma que si se tiene una palabra que es más larga que el ancho dado, será dividida (ver segundo ejemplo). Cuando es false la función no divide la palabra incluso si width es menor que el ancho de la palabra.

Valores devueltos

Devuelve el string dado ajustado a la longitud especificada.

Ejemplos

Ejemplo #1 Ejemplo de wordwrap()

<?php
$text = "The quick brown fox jumped over the lazy dog.";
$newtext = wordwrap($text, 20, "<br />\n");

echo $newtext;
?>

El resultado del ejemplo sería:

The quick brown fox<br />
jumped over the lazy<br />
dog.

Ejemplo #2 Ejemplo de wordwrap()

<?php
$text = "A very long woooooooooooord.";
$newtext = wordwrap($text, 8, "\n", true);

echo "$newtext\n";
?>

El resultado del ejemplo sería:

A very
long
wooooooo
ooooord.

Ejemplo #3 Ejemplo de wordwrap()

<?php
$texto = "A very long woooooooooooooooooord. and something";
$nuevo_texto = wordwrap($texto, 8, "\n", false);

echo "$nuevo_texto\n";
?>

El resultado del ejemplo sería:

A very
long
woooooooooooooooooord.
and
something

Ver también

  • nl2br() - Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
  • chunk_split() - Divide una cadena en trozos más pequeños


Registro de cambios

A las clases/funciones/métodos de esta extensión se han realizado los siguientes cambios.

Version | Function | Description
7.4.0 | implode | Pasar el parámetro glue después de el parámetro pieces (es decir, sin utilizar el orden documentado de los parámetros) es obsoleto.
7.0.0 | setlocale | Se ha eliminado el soporte para el parámetro category pasado como string. En esta versión, solamente se pueden utilizar las constantes LC_*.
 | substr | Si la longitud de caracteres de string es igual a start, se devolverá una cadena vacía. Antes de esta versión, en este caso se devolvía false.
5.6.5 | crypt | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.6 devolvía incorrectamente un hash DES.
5.6.0 | crypt | Se emite una advertencia de seguridad E_NOTICE si se omite salt.
 | html_entity_decode | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
 | htmlentities | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
 | htmlspecialchars | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
5.5.21 | crypt | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.5 (y ramificaciones anteriores) devolvía incorrectamente un hash DES.
5.5.11 | substr_compare | length ahora puede ser 0.
5.5.1 | hex2bin | Se emite una advertencia si el string de entrada es un string hexadecimal no válido.
5.4.32, 5.5.16 | ucwords | Se añadió el parámetro delimiters.
5.4.4 | hex2bin | Se emite una advertencia si la cadena de entrada tiene una longitud impar. En PHP 5.4.0 la cadena era aceptada de forma silenciosa, pero el último byte era truncado.
5.4.0 | get_html_translation_table | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
 | get_html_translation_table | El valor por defecto para el parámetro encoding se cambió a UTF-8.
 | html_entity_decode | La codificación predeterminada se cambió de ISO-8859-1 a UTF-8.
 | html_entity_decode | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
 | htmlentities | El valor por defecto del parámetro encoding se cambió a UTF-8.
 | htmlentities | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
 | htmlspecialchars | El valor predeterminado del parámetro encoding se cambió a UTF-8.
 | htmlspecialchars | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
 | htmlspecialchars_decode | Fueron agregadas las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
 | number_format | Esta función ahora admite múltiples bytes en dec_point y thousands_sep. En versiones anteriors solamente se utilizaba el primer byte de cada separador.
5.3.7 | crypt | Se añadieron los modos de Blowfish $2x$ y $2y$ para tratar con ataques de bit alto potenciales.
5.3.4 | get_html_translation_table | Se añadió el parámetro encoding.
 | strip_tags | strip_tags ignora las etiquetas de autocierre de XHTML en allowable_tags.
5.3.2 | crypt | Corregido el comportamiento de Blowfish sobre rondas no válidas para devolver el string "failure" ("*0" or "*1"), en lugar de caer al DES.
 | crypt | Agregado el crypt SHA-256 y SHA-512 basado en la implementación de Ulrich Drepper.
5.3.0 | crypt | PHP ahora contiene su propia implementación de los algoritmos MD5, DES estándar, DES extendido y Blowfish y los utilizará si el sistema carece de soporte para uno o varios de los algoritmos.
 | htmlentities | Se añadió la constante ENT_IGNORE.
 | htmlspecialchars | Se añadió la constante ENT_IGNORE.
 | nl2br | Se agregó el parámetro opcional is_xhtml. Antes de esta versión, siempre se insertaba '<br />'.
 | setlocale | Está función ahora emite un aviso E_DEPRECATED si se pasa un string al parámetro category en lugar de una de las constantes LC_*.
 | stristr | Agregado el parámetro opcional before_needle.
 | strlen | Las versiones anteriores trataban los arrays como el string Array, devolviendo así una longitud de string de 5 y emitiendo un error de nivel E_NOTICE.
 | strstr | Se añadió el parámetro opcional before_needle.
5.2.5 | addcslashes | Se añadieron las secuencias de escape \v y \f.
5.2.3 | htmlentities | Se añadió el parámetro double_encode.
 | htmlspecialchars | Se añadió el parámetro double_encode.
5.2.2 - 5.2.6 | substr | Si el parámetro start indica una posición negativa de truncamiento o más allá, se devolverá false. En otras versiones de PHP obtienen la cadena desde el principio.
5.1.0 | explode | Se añadió soporte para limit negativo.
 | md5_file | Se modificó la función para usar la API de secuencias. Esto quiere decir que se puede usar con envolturas, como md5_file('http://example.com/..')
 | sha1_file | Cambiada la función para utilizar el API de flujo de datos. Esto significa que se puede utilizar con envolturas, como en sha1_file('http://ejemplo.com/..')
 | str_word_count | Agregado el parámetro charlist
 | substr_compare | Se añadió la posibilidad de usar un offset negativo.
 | substr_count | Los parámetros offset y length fueron agregados
5.0.0 | strip_tags | strip_tags ahora es segura a nivel binario.
 | strrpos | needle puede ser ahora un string de más de un carácter.
4.3.0 | stristr | stristr se hizo seguro a nivel binario.
 | strrchr | Ahora esta función es segura a nivel binario.
 | strstr | strstr se hizo segura binariamente.
4.2.3 | strcoll | Esta función trabaja ahora en win32.


Extensiones relacionadas con variable y tipo

  • Arrays
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ordenamiento de arrays
    • Funciones de Arrays
  • Clases/Objetos — Información de Clases/Objetos
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Clases/Objetos
  • Classkit
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Classkit
  • Ctype — Comprobación del tipo de carácter
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Ctype
  • Filter — Filtrado de datos
    • Introducción
    • Instalación/Configuración
    • Tipos de filtros
    • Constantes predefinidas
    • Ejemplos
    • Funciones de Filter
  • Manejo de Funciones
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de Manejo de Funciones
  • Quickhash
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • QuickHashIntSet — La clase QuickHashIntSet
    • QuickHashIntHash — La clase QuickHashIntHash
    • QuickHashStringIntHash — La clase QuickHashStringIntHash
    • QuickHashIntStringHash — La clase QuickHashIntStringHash
  • Reflection
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Extensión
    • Reflection — Clase Reflection
    • ReflectionClass — Clase ReflectionClass
    • ReflectionClassConstant — The ReflectionClassConstant class
    • ReflectionZendExtension — Clase ReflectionZendExtension
    • ReflectionExtension — Clase ReflectionExtension
    • ReflectionFunction — Clase ReflectionFunction
    • ReflectionFunctionAbstract — Clase ReflectionFunctionAbstract
    • ReflectionMethod — La clase ReflectionMethod
    • ReflectionNamedType — The ReflectionNamedType class
    • ReflectionObject — Clase ReflectionObject
    • ReflectionParameter — La clase ReflectionParameter
    • ReflectionProperty — Clase ReflectionProperty
    • ReflectionType — The ReflectionType class
    • ReflectionUnionType — The ReflectionUnionType class
    • ReflectionGenerator — The ReflectionGenerator class
    • ReflectionReference — The ReflectionReference class
    • Reflector — La interfaz Reflector
    • ReflectionException — La clase ReflectionException
  • Manejo de variables
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de manejo de variables


Arrays

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ordenamiento de arrays
  • Funciones de Arrays
    • array_change_key_case — Cambia a mayúsculas o minúsculas todas las claves en un array
    • array_chunk — Divide un array en fragmentos
    • array_column — Devuelve los valores de una sola columna del array de entrada
    • array_combine — Crea un nuevo array, usando una matriz para las claves y otra para sus valores
    • array_count_values — Cuenta todos los valores de un array
    • array_diff_assoc — Calcula la diferencia entre arrays con un chequeo adicional de índices
    • array_diff_key — Calcula la diferencia entre arrays empleando las claves para la comparación
    • array_diff_uassoc — Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
    • array_diff_ukey — Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
    • array_diff — Calcula la diferencia entre arrays
    • array_fill_keys — Llena un array con valores, especificando las keys
    • array_fill — Llena un array con valores
    • array_filter — Filtra elementos de un array usando una función de devolución de llamada
    • array_flip — Intercambia todas las claves de un array con sus valores asociados
    • array_intersect_assoc — Calcula la intersección de arrays con un chequeo adicional de índices
    • array_intersect_key — Calcula la intersección de arrays usando sus claves para la comparación
    • array_intersect_uassoc — Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
    • array_intersect_ukey — Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación
    • array_intersect — Calcula la intersección de arrays
    • array_key_exists — Verifica si el índice o clave dada existe en el array
    • array_key_first — Obtiene la primera clave de un array
    • array_key_last — Obtiene la última clave de un array
    • array_keys — Devuelve todas las claves de un array o un subconjunto de claves de un array
    • array_map — Aplica la retrollamada a los elementos de los arrays dados
    • array_merge_recursive — Une dos o más arrays recursivamente
    • array_merge — Combina dos o más arrays
    • array_multisort — Ordena varios arrays, o arrays multidimensionales
    • array_pad — Rellena un array a la longitud especificada con un valor
    • array_pop — Extrae el último elemento del final del array
    • array_product — Calcula el producto de los valores de un array
    • array_push — Inserta uno o más elementos al final de un array
    • array_rand — Seleccionar una o más claves aleatorias de un array
    • array_reduce — Reduce iterativamente un array a un solo valor usando una función llamada de retorno
    • array_replace_recursive — Reemplaza los elementos de los arrays pasados al primer array de forma recursiva
    • array_replace — Reemplaza los elementos del array original con elementos de array adicionales
    • array_reverse — Devuelve un array con los elementos en orden inverso
    • array_search — Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito
    • array_shift — Quita un elemento del principio del array
    • array_slice — Extraer una parte de un array
    • array_splice — Elimina una porción del array y la reemplaza con otra cosa
    • array_sum — Calcular la suma de los valores de un array
    • array_udiff_assoc — Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
    • array_udiff_uassoc — Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
    • array_udiff — Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
    • array_uintersect_assoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
    • array_uintersect_uassoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado
    • array_uintersect — Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
    • array_unique — Elimina valores duplicados de un array
    • array_unshift — Añadir al inicio de un array uno a más elementos
    • array_values — Devuelve todos los valores de un array
    • array_walk_recursive — Aplicar una función de usuario recursivamente a cada miembro de un array
    • array_walk — Aplicar una función proporcionada por el usuario a cada miembro de un array
    • array — Crea un array
    • arsort — Ordena un array en orden inverso y mantiene la asociación de índices
    • asort — Ordena un array y mantiene la asociación de índices
    • compact — Crear un array que contiene variables y sus valores
    • count — Cuenta todos los elementos de un array o algo de un objeto
    • current — Devuelve el elemento actual en un array
    • each — Devolver el par clave/valor actual de un array y avanzar el cursor del array
    • end — Establece el puntero interno de un array a su último elemento
    • extract — Importar variables a la tabla de símbolos actual desde un array
    • in_array — Comprueba si un valor existe en un array
    • key_exists — Alias de array_key_exists
    • key — Obtiene una clave de un array
    • krsort — Ordena un array por clave en orden inverso
    • ksort — Ordena un array por clave
    • list — Asignar variables como si fueran un array
    • natcasesort — Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas
    • natsort — Ordena un array usando un algoritmo de "orden natural"
    • next — Avanza el puntero interno de un array
    • pos — Alias de current
    • prev — Rebobina el puntero interno del array
    • range — Crear un array que contiene un rango de elementos
    • reset — Establece el puntero interno de un array a su primer elemento
    • rsort — Ordena un array en orden inverso
    • shuffle — Mezcla un array
    • sizeof — Alias de count
    • sort — Ordena un array
    • uasort — Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices
    • uksort — Ordena un array según sus claves usando una función de comparación definida por el usuario
    • usort — Ordena un array según sus valores usando una función de comparación definida por el usuario


Introducción

Estas funciones permiten interactuar con y manipular arrays (matrices) de varias maneras. Los arrays son esenciales para almacenar, manejar y operar sobre conjuntos de variables.

Se admiten arrays simples y multidimensionales, y pueden ser creados tanto por el usuario como por otra función. Existen funciones específicas de manejo de bases de datos para llenar arrays desde las consultas a bases de datos, y varias funciones devuelven arrays.

Por favor, vea la sección Arrays del manual para obtener una explicación detallada de cómo están implementados y cómo se utilizan los arrays en PHP. Vea también Operadores de arrays para concocer otras formas de manipular los arrays.


Constantes predefinidas

Estas constantes están disponibles siempre ya que forman parte del núcleo de PHP.

CASE_LOWER (integer)
CASE_LOWER junto con array_change_key_case() se utiliza para convertir claves de array a minúsculas. Es también la constante predefinida para array_change_key_case().
CASE_UPPER (integer)
CASE_UPPER junto con array_change_key_case() se utiliza para convertir claves de array a mayúsculas.

Indicadores de ordenado:

SORT_ASC (integer)
SORT_ASC se utiliza con array_multisort() para ordenar ascendentemente.
SORT_DESC (integer)
SORT_DESC se utiliza con array_multisort() para ordenar descendentemente.

Indicadores de tipo de orden: utilizadas por varias funciones de ordenación

SORT_REGULAR (integer)
SORT_REGULAR se utiliza para comparar elementos normalmente.
SORT_NUMERIC (integer)
SORT_NUMERIC se utiliza para comparar elementos numéricamente.
SORT_STRING (integer)
SORT_STRING se utiliza para comparar elementos como cadenas.
SORT_LOCALE_STRING (integer)
SORT_LOCALE_STRING se utiliza para comparar elementos como cadenas, basado en la localización actual. Agregada en PHP 5.0.2.
SORT_NATURAL (integer)
SORT_NATURAL se utiliza para comparar elementos como cadenas utilizando "orden natural", como natsort(). Agregado en PHP 5.4.0.
SORT_FLAG_CASE (integer)
SORT_FLAG_CASE puede ser combinada (OR binario) con SORT_STRING o SORT_NATURAL para ordenar cadenas sin diferenciar mayúsculas y minúsculas. Agregado en PHP 5.4.0.

Opciones de filtrado:

ARRAY_FILTER_USE_KEY (integer)
ARRAY_FILTER_USE_KEY se utiliza con array_filter() para pasar cada clave como el primer parámetro a la llamada de retorno proporcionada. Agregado en PHP 5.6.0.
ARRAY_FILTER_USE_BOTH (integer)
ARRAY_FILTER_USE_BOTH se utiliza con array_filter() para pasar tanto el valor como la clave a la llamada de retorno proporcionada. Agregado en PHP 5.6.0.

COUNT_NORMAL (integer)
COUNT_RECURSIVE (integer)
EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_IF_EXISTS (integer)
EXTR_REFS (integer)


Ordenamiento de arrays

PHP tiene varias funciones que se ocupan de ordenar arrays (matrices) y este documento existe para ayudar a aclararlo todo.

Las principales diferencias son:

  • Algunas ordenan basados en las key de la array, mientras que otras por los valores: $array['key'] = 'valor';
  • Si se mantiene o no la correlación entre las key y los valores después de la clasificación, lo cual puede significar que las key se restablecen numéricamente (0,1,2 ...)
  • El orden de la clasificación: alfabético, de menor a mayor (ascendente), de mayor a menor (descendente), numérico, natural, aleatorio o definido por el usuario
  • Nota: Todas estas funciones de clasificación actúan directamente sobre la variable de array misma, en lugar de devolver un nuevo array ordenado.
  • Si alguna de estas funciones de clasificación evalúa a dos miembros como iguales, entonces el orden no queda definido (la clasificación no es estable).

Atributos de las funciones de clasificación
Nombre de la función | Ordena por | Mantiene asociación con las key | Orden de la clasificación | Funciones relacionadas
array_multisort() | valor | sí si es asociativa, no si es númerica | primer array u opciones de clasificación | array_walk()
asort() | valor | sí | menor a mayor | arsort()
arsort() | valor | sí | mayor a menor | asort()
krsort() | key | sí | mayor a menor | ksort()
ksort() | key | sí | menor a mayor | asort()
natcasesort() | valores | sí | natural, insensible a mayúsculas y minúsculas | natsort()
natsort() | valor | sí | natural | natcasesort()
rsort() | valor | no | mayor a menor | sort()
shuffle() | valor | no | aleatorio | array_rand()
sort() | valor | no | menor a mayor | rsort()
uasort() | valor | sí | definido por el usuario | uksort()
uksort() | key | sí | definido por el usuario | uasort()
usort() | valor | no | definido por el usuario | uasort()


Funciones de Arrays

Ver también

Ver también is_array(), explode(),
implode(), split(),
preg_split(), and unset().

Tabla de contenidos

  • array_change_key_case — Cambia a mayúsculas o minúsculas todas las claves en un array
  • array_chunk — Divide un array en fragmentos
  • array_column — Devuelve los valores de una sola columna del array de entrada
  • array_combine — Crea un nuevo array, usando una matriz para las claves y otra para sus valores
  • array_count_values — Cuenta todos los valores de un array
  • array_diff_assoc — Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_key — Calcula la diferencia entre arrays empleando las claves para la comparación
  • array_diff_uassoc — Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_diff_ukey — Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
  • array_diff — Calcula la diferencia entre arrays
  • array_fill_keys — Llena un array con valores, especificando las keys
  • array_fill — Llena un array con valores
  • array_filter — Filtra elementos de un array usando una función de devolución de llamada
  • array_flip — Intercambia todas las claves de un array con sus valores asociados
  • array_intersect_assoc — Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_key — Calcula la intersección de arrays usando sus claves para la comparación
  • array_intersect_uassoc — Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_intersect_ukey — Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación
  • array_intersect — Calcula la intersección de arrays
  • array_key_exists — Verifica si el índice o clave dada existe en el array
  • array_key_first — Obtiene la primera clave de un array
  • array_key_last — Obtiene la última clave de un array
  • array_keys — Devuelve todas las claves de un array o un subconjunto de claves de un array
  • array_map — Aplica la retrollamada a los elementos de los arrays dados
  • array_merge_recursive — Une dos o más arrays recursivamente
  • array_merge — Combina dos o más arrays
  • array_multisort — Ordena varios arrays, o arrays multidimensionales
  • array_pad — Rellena un array a la longitud especificada con un valor
  • array_pop — Extrae el último elemento del final del array
  • array_product — Calcula el producto de los valores de un array
  • array_push — Inserta uno o más elementos al final de un array
  • array_rand — Seleccionar una o más claves aleatorias de un array
  • array_reduce — Reduce iterativamente un array a un solo valor usando una función llamada de retorno
  • array_replace_recursive — Reemplaza los elementos de los arrays pasados al primer array de forma recursiva
  • array_replace — Reemplaza los elementos del array original con elementos de array adicionales
  • array_reverse — Devuelve un array con los elementos en orden inverso
  • array_search — Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito
  • array_shift — Quita un elemento del principio del array
  • array_slice — Extraer una parte de un array
  • array_splice — Elimina una porción del array y la reemplaza con otra cosa
  • array_sum — Calcular la suma de los valores de un array
  • array_udiff_assoc — Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc — Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_udiff — Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_uintersect_assoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado
  • array_uintersect — Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_unique — Elimina valores duplicados de un array
  • array_unshift — Añadir al inicio de un array uno a más elementos
  • array_values — Devuelve todos los valores de un array
  • array_walk_recursive — Aplicar una función de usuario recursivamente a cada miembro de un array
  • array_walk — Aplicar una función proporcionada por el usuario a cada miembro de un array
  • array — Crea un array
  • arsort — Ordena un array en orden inverso y mantiene la asociación de índices
  • asort — Ordena un array y mantiene la asociación de índices
  • compact — Crear un array que contiene variables y sus valores
  • count — Cuenta todos los elementos de un array o algo de un objeto
  • current — Devuelve el elemento actual en un array
  • each — Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • end — Establece el puntero interno de un array a su último elemento
  • extract — Importar variables a la tabla de símbolos actual desde un array
  • in_array — Comprueba si un valor existe en un array
  • key_exists — Alias de array_key_exists
  • key — Obtiene una clave de un array
  • krsort — Ordena un array por clave en orden inverso
  • ksort — Ordena un array por clave
  • list — Asignar variables como si fueran un array
  • natcasesort — Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas
  • natsort — Ordena un array usando un algoritmo de "orden natural"
  • next — Avanza el puntero interno de un array
  • pos — Alias de current
  • prev — Rebobina el puntero interno del array
  • range — Crear un array que contiene un rango de elementos
  • reset — Establece el puntero interno de un array a su primer elemento
  • rsort — Ordena un array en orden inverso
  • shuffle — Mezcla un array
  • sizeof — Alias de count
  • sort — Ordena un array
  • uasort — Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices
  • uksort — Ordena un array según sus claves usando una función de comparación definida por el usuario
  • usort — Ordena un array según sus valores usando una función de comparación definida por el usuario


Cambia a mayúsculas o minúsculas todas las claves en un array

  • « Funciones de Arrays
  • array_chunk »
  • PHP Manual
  • Funciones de Arrays
  • Cambia a mayúsculas o minúsculas todas las claves en un array

array_change_key_case

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_change_key_case — Cambia a mayúsculas o minúsculas todas las claves en un array

Descripción

array_change_key_case ( array $array , int $case = CASE_LOWER ) : array

Devuelve un array a partir de array con todas las claves convertidas a minúsculas o mayúsculas. Los índices numerados son dejados como están.

Parámetros

array

Array para trabajar en

case

Entre CASE_UPPER o CASE_LOWER (por defecto)

Valores devueltos

Devuelve un array con sus keys converitdas en minúsculas o mayúsculas, o false si array no es una matriz.

Errores/Excepciones

Lanza un E_WARNING si array no es un array.

Ejemplos

Ejemplo #1 Ejemplo de array_change_key_case()

<?php
$input_array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($input_array, CASE_UPPER));
?>

El resultado del ejemplo sería:

Array
(
    [FIRST] => 1
    [SECOND] => 4
)

Notas

Nota:

Si un array tiene índices que queden iguales una vez se aplique ésta función (ej. "claVE" y "cLAve"), el valor que esté después en la matriz anulará los otros índices.


Divide un array en fragmentos

  • « array_change_key_case
  • array_column »
  • PHP Manual
  • Funciones de Arrays
  • Divide un array en fragmentos

array_chunk

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_chunk — Divide un array en fragmentos

Descripción

array_chunk ( array $array , int $size , bool $preserve_keys = false ) : array

Divide un array en arrays con elementos del tamaño definido en size. El último fragmento puede contener menos elementos que size.

Parámetros

array

Array para trabajar en

size

El tamaño de cada fragmento.

preserve_keys

Cuando se establece en true las keys serán preservadas. El valor por defecto es false lo cual reindexará los fragmentos numéricamente.

Valores devueltos

Retorna un array multidimensional indexado numéricamente, comenzando desde cero, en el cual cada dimensión contiene la cantidad de elementos definida en size.

Errores/Excepciones

Si size es inferior a 1, una E_WARNING será arrojada y null será retornado.

Ejemplos

Ejemplo #1 Ejemplo de array_chunk()

<?php
$input_array = array('a', 'b', 'c', 'd', 'e');
print_r(array_chunk($input_array, 2));
print_r(array_chunk($input_array, 2, true));
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [0] => c
            [1] => d
        )

    [2] => Array
        (
            [0] => e
        )

)
Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [2] => c
            [3] => d
        )

    [2] => Array
        (
            [4] => e
        )

)

Ver también

  • array_slice() - Extraer una parte de un array


Devuelve los valores de una sola columna del array de entrada

  • « array_chunk
  • array_combine »
  • PHP Manual
  • Funciones de Arrays
  • Devuelve los valores de una sola columna del array de entrada

array_column

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

array_column — Devuelve los valores de una sola columna del array de entrada

Descripción

array_column ( array $input , mixed $column_key , mixed $index_key = null ) : array

array_column() devuelve los valores de una sola columna de input, identificado por la clave de columna column_key. Opcionalmente, se podría proporcionar una clave de índice, index_key, para indexar los valores del array devuelto por los valores de la columna index_key del array de entrada.

Parámetros

input

Un array multidimensional o un array de objetos desde el que extraer una columna de valores. Si se proporciona un array de objetos, entonces se podrá extraer directamente las propiedades públicas. Para poder extraer las proiedades protegidas o privadas, la clase debe implementar los métodos mágicos __get() y __isset().

column_key

La columna de valores a devolver. Este valor podría ser una clave de tipo integer de la columna de la cual obtener los datos, o podría ser una clave de tipo string para un array asociativo o nombre de propiedad. También prodría ser null para devolver array completos u objetos (útil junto con index_key para reindexar el array).

index_key

La columna a usar como los índices/claves para el array devuelto. Este valor podría ser la clave de tipo integer de la columna, o podría ser el nombre de la clave de tipo string. El valor es cast como es habitual para las claves de array (Sin embargo, también se permiten los objetos que soportan la conversión a string).

Valores devueltos

Devuelve un array de valores que representa una sola columna del array de entrada.

Historial de cambios

Versión | Descripción
7.0.0 | Se añadió la capacidad de que el parámetro input sea un array de objetos.

Ejemplos

Ejemplo #1 Obtener la columna de nombres del conjunto de resultados

<?php
// Array representando un conjunto de registros posibles devueltos desde una base de datos
$registros = array(
    array(
        'id' => 2135,
        'nombre' => 'John',
        'apellido' => 'Doe',
    ),
    array(
        'id' => 3245,
        'nombre' => 'Sally',
        'apellido' => 'Smith',
    ),
    array(
        'id' => 5342,
        'nombre' => 'Jane',
        'apellido' => 'Jones',
    ),
    array(
        'id' => 5623,
        'nombre' => 'Peter',
        'apellido' => 'Doe',
    )
);

$nombres = array_column($registros, 'nombre');
print_r($nombres);
?>

El resultado del ejemplo sería:

Array
(
    [0] => John
    [1] => Sally
    [2] => Jane
    [3] => Peter
)

Ejemplo #2 Obtener la columna de apellidos del conjunto de resultados, indexada por la columna "id"

<?php
// Se emplea el array $registros del Ejemplo #1
$apellidos = array_column($registros, 'apellido', 'id');
print_r($apellidos);
?>

El resultado del ejemplo sería:

Array
(
    [2135] => Doe
    [3245] => Smith
    [5342] => Jones
    [5623] => Doe
)

Ejemplo #3 Obtener la columna de nombres de usuarios de la propiedad pública "nombre_usuario" de un objeto

<?php

class Usuario
{
    public $nombre_usuario;

    public function __construct(string $nombre_usuario)
    {
        $this->nombre_usuario = $nombre_usuario;
    }
}

$usuarios = [
    new Usuario('usuario 1'),
    new Usuario('usuario 2'),
    new Usuario('usuario 3'),
];

print_r(array_column($usuarios, 'nombre_usuario'));
?>

El resultado del ejemplo sería:

Array
(
    [0] => usuario 1
    [1] => usuario 2
    [2] => usuario 3
)

Ejemplo #4 Obtener la columna de nombres de la propiedad privada "nombre" de un objeto empleando el método mágico __get().

<?php

class Persona
{
    private $name;

    public function __construct(string $nombre)
    {
        $this->nombre = $nombre;
    }

    public function __get($prop)
    {
        return $this->$prop;
    }

    public function __isset($prop) : bool
    {
        return isset($this->$prop);
    }
}

$gente = [
    new Persona('Fred'),
    new Persona('Jane'),
    new Persona('John'),
];

print_r(array_column($gente, 'nombre'));
?>

El resultado del ejemplo sería:

Array
(
    [0] => Fred
    [1] => Jane
    [2] => John
)
Si no se proporciona __isset(), será devuelto un array vacío.

Ver también

  • » Implementación del espacio de usuario recomendada para PHP menor que 5.5


Crea un nuevo array, usando una matriz para las claves y otra para sus valores

  • « array_column
  • array_count_values »
  • PHP Manual
  • Funciones de Arrays
  • Crea un nuevo array, usando una matriz para las claves y otra para sus valores

array_combine

(PHP 5, PHP 7, PHP 8)

array_combine — Crea un nuevo array, usando una matriz para las claves y otra para sus valores

Descripción

array_combine ( array $keys , array $values ) : array

Crea un array usando los valores del array keys como las keys y los valores del array values como los valores correspondientes.

Parámetros

keys

Array de las keys a usar. Cualquier valor inválido para la key será convertido a string.

values

Array de valores a usar

Valores devueltos

Retorna el array combinado, false si el número de elementos de cada array no es igual.

Errores/Excepciones

Arroja un E_WARNING si el número de elementos en keys y values no coincide.

Historial de cambios

Versión | Descripción
5.4.0 | Versiones previas emiten un E_WARNING y devuelven false para arrays vacíos.

Ejemplos

Ejemplo #1 Ejemplo simple de array_combine()

<?php
$a = array('green', 'red', 'yellow');
$b = array('avocado', 'apple', 'banana');
$c = array_combine($a, $b);

print_r($c);
?>

El resultado del ejemplo sería:

Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)

Ver también

  • array_merge() - Combina dos o más arrays
  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array
  • array_values() - Devuelve todos los valores de un array


Cuenta todos los valores de un array

  • « array_combine
  • array_diff_assoc »
  • PHP Manual
  • Funciones de Arrays
  • Cuenta todos los valores de un array

array_count_values

(PHP 4, PHP 5, PHP 7, PHP 8)

array_count_values — Cuenta todos los valores de un array

Descripción

array_count_values ( array $array ) : array

array_count_values() retorna un array usando los valores de la matriz array como keys y su frecuencia en array como valores.

Parámetros

array

Array de valores a contar

Valores devueltos

Retorna un array asociativo de valores a partir de array como keys y su respectivo recuento como valores.

Errores/Excepciones

Arroja un E_WARNING por cada elemento el cual no sea string o integer.

Ejemplos

Ejemplo #1 Ejemplo de array_count_values()

<?php
$array = array(1, "hello", 1, "world", "hello");
print_r(array_count_values($array));
?>

El resultado del ejemplo sería:

Array
(
    [1] => 2
    [hello] => 2
    [world] => 1
)

Ver también

  • count() - Cuenta todos los elementos de un array o algo de un objeto
  • array_unique() - Elimina valores duplicados de un array
  • array_values() - Devuelve todos los valores de un array
  • count_chars() - Devuelve información sobre los caracteres usados en una cadena


Calcula la diferencia entre arrays con un chequeo adicional de índices

  • « array_count_values
  • array_diff_key »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la diferencia entre arrays con un chequeo adicional de índices

array_diff_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

array_diff_assoc — Calcula la diferencia entre arrays con un chequeo adicional de índices

Descripción

array_diff_assoc ( array $array1 , array $array2 , array $... = ? ) : array

Compara array1 con array2 y devuelve la diferencia. A diferencia de array_diff(), también se usan las claves de los arrays en la comparación.

Parámetros

array1

El array a comparar.

array2

Un array con el que comparar

...

Más arrays con los que comparar

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que no están presentes en ninguno de los otros arrays.

Ejemplos

Ejemplo #1 Ejemplo de array_diff_assoc()

En este ejemplo se ve que el par "a" => "green" está presente en ambos arrays y, por lo tanto, no está en la salida de la función. Al contrario, el par 0 => "red" está en la salida ya que en el segundo argumento "red" tiene una clave que es 1.

<?php
$array1    = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2    = array("a" => "green", "yellow", "red");
$resultado = array_diff_assoc($array1, $array2);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

Ejemplo #2 Ejemplo de array_diff_assoc()

Dos valores de pares clave => valor son considerados iguales sólo si (string) $elem1 === (string) $elem2 . En otras palabras, se realiza un un chequeo estricto de tal forma que las representaciones de string debe ser las mismas.

<?php
$array1 = array(0, 1, 2);
$array2 = array("00", "01", "2");
$resultado = array_diff_assoc($array1, $array2);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [0] => 0
    [1] => 1
    )

Notas

Nota: Esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar arrays de más dimensiones usando, por ejemplo, array_diff_assoc($array1[0], $array2[0]);.

Nota: Asegúrese de proporcionar los argumentos en el orden corrector al comparar arrays similares con más claves. El nuev array debería ser el primero de la lista.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices


Calcula la diferencia entre arrays empleando las claves para la comparación

  • « array_diff_assoc
  • array_diff_uassoc »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la diferencia entre arrays empleando las claves para la comparación

array_diff_key

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_diff_key — Calcula la diferencia entre arrays empleando las claves para la comparación

Descripción

array_diff_key ( array $array1 , array $array2 , array $... = ? ) : array

Compara las claves de array1 con las claves de array2 y devuelve la diferencia. Esta función es como array_diff() excepto que la comparación se hace con las claves en lugar de con los valores.

Parámetros

array1

El array a comparar

array2

Un array con el que comparar

...

Más arrays con los que comparar

Valores devueltos

Devuelve un array que contiene todas las entradas de array1 cuyas claves están ausente en ninguno de los otros arrays.

Ejemplos

Ejemplo #1 Ejemplo de array_diff_key()

Las dos claves de los de pares clave => valor son consideradas iguales solo si (string) $clave1 === (string) $clave2 . En otras palabras, se ejecuta una comprobación de tipos estricta de tal forma que las representaciones de tipo string deben ser las mismas.

<?php
$array1 = array('blue' => 1, 'red' => 2, 'green' => 3, 'purple' => 4);
$array2 = array('green' => 5, 'yellow' => 7, 'cyan' => 8);

var_dump(array_diff_key($array1, $array2));
?>

El resultado del ejemplo sería:

array(3) {
  ["blue"]=>
  int(1)
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}
<?php
$array1 = array('blue' => 1, 'red'  => 2, 'green' => 3, 'purple' => 4);
$array2 = array('green' => 5, 'yellow' => 7, 'cyan' => 8);
$array3 = array('blue' => 6, 'yellow' => 7, 'mauve' => 8);

var_dump(array_diff_key($array1, $array2, $array3));
?>

El resultado del ejemplo sería:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Notas

Nota:

Esta función solamente comprueba una dimensión de un array n-dimensional. Se pueden comprobar dimensiones más profundas mediante array_diff_key($array1[0], $array2[0]);.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_diff_ukey() - Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_intersect_key() - Calcula la intersección de arrays usando sus claves para la comparación
  • array_intersect_ukey() - Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación


Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario

  • « array_diff_key
  • array_diff_ukey »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario

array_diff_uassoc

(PHP 5, PHP 7, PHP 8)

array_diff_uassoc — Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario

Descripción

array_diff_uassoc ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

Compara array1 contra array2 y retorna la diferencia. A diferencia de array_diff() la keys del array se utilizan en la comparación.

A diferencia de array_diff_assoc() una función de devolución de llamada suministrada por el usuario se utiliza para la comparación de los índices, no una función interna.

Parámetros

array1

Array a comparar

array2

Un array contra el cual comparar

...

Más arrays contra los cuales comparar

key_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Retorna un array conteniendo todas las entradas del array1 que no están presentes en ninguno de los otros arrays.

Ejemplos

Ejemplo #1 Ejemplo de array_diff_uassoc()

El par "a" => "green" está presente en ambos arrays y por lo tanto no está en la salida de la función. A diferencia de ésto, el par 0 => "red" está en la salida ya que en el segundo argumento "red" tiene una key que es 1.

<?php
function key_compare_func($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($array1, $array2, "key_compare_func");
print_r($result);
?>

El resultado del ejemplo sería:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

La igualdad de 2 índices es chequeada por la función de devolución de llamada suministrada por el usuario.

Notas

Nota:

Esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar dimensiones más profundas mediante, por ejemplo, array_diff_uassoc($array1[0], $array2[0], "key_compare_func");.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación

  • « array_diff_uassoc
  • array_diff »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación

array_diff_ukey

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_diff_ukey — Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación

Descripción

array_diff_ukey ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

Compara las keys del array1 contra las keys del array2 y retorna la diferencia. Esta función es como array_diff() excepto que la comparación se hace en las keys en lugar de los valores.

A diferencia de array_diff_key() una función de devolución de llamada suministrada por el usuario se utiliza para la comparación de los índices, no una función interna.

Parámetros

array1

Array a comparar

array2

Un array contra el cual comparar

...

Más arrays contra los cuales comparar

key_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Retorna un array conteniendo todas las entradas del array1 que no están presentes en ninguna de los otros array.

Ejemplos

Ejemplo #1 Ejemplo de array_diff_ukey()

<?php
function key_compare_func($key1, $key2)
{
    if ($key1 == $key2)
        return 0;
    else if ($key1 > $key2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_ukey($array1, $array2, 'key_compare_func'));
?>

El resultado del ejemplo sería:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Notas

Nota:

Esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar dimensiones más profundas mediante array_diff_ukey($array1[0], $array2[0], 'callback_func');.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_diff_key() - Calcula la diferencia entre arrays empleando las claves para la comparación
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_intersect_key() - Calcula la intersección de arrays usando sus claves para la comparación
  • array_intersect_ukey() - Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación


Calcula la diferencia entre arrays

  • « array_diff_ukey
  • array_fill_keys »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la diferencia entre arrays

array_diff

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_diff — Calcula la diferencia entre arrays

Descripción

array_diff ( array $array1 , array $array2 , array $... = ? ) : array

Compara array1 con uno o más arrays y devuelve los valores de array1 que no estén presentes en ninguno de los otros arrays.

Parámetros

array1

El array a comparar

array2

Un array con el que comparar

...

Más arrays con los que comparar

Valores devueltos

Devuelve un array que contiene todas las entradas de array1 que no están presentes en ninguna de los otros arrays.

Ejemplos

Ejemplo #1 Ejemplo de array_diff()

<?php
$array1    = array("a" => "green", "red", "blue", "red");
$array2    = array("b" => "green", "yellow", "red");
$resultado = array_diff($array1, $array2);

print_r($resultado);
?>

Todas las múltiples coincidencias en $array1 serán tratadas de la misma manera. Esta será la salida:

Array
(
    [1] => blue
)

Notas

Nota:

Dos elementos son considerandos iguales si y sólo si (string) $elem1 === (string) $elem2. En otras palabras: cuando la representación de string es la misma.

Nota:

Esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar arrays de más dimensiones usando array_diff_assoc($array1[0], $array2[0]);.

Ver también

  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices


Llena un array con valores, especificando las keys

  • « array_diff
  • array_fill »
  • PHP Manual
  • Funciones de Arrays
  • Llena un array con valores, especificando las keys

array_fill_keys

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

array_fill_keys — Llena un array con valores, especificando las keys

Descripción

array_fill_keys ( array $keys , mixed $value ) : array

Llena un array con el valor del parámetro value, usando los valores del array keys como claves.

Parámetros

keys

Array con los valores que serán usados como keys. Valores ilegales para una clave serán convertidos a string.

value

Valor usado para el llenado.

Valores devueltos

Retorna la matriz llenada

Ejemplos

Ejemplo #1 Ejemplo de array_fill_keys()

<?php
$keys = array('foo', 5, 10, 'bar');
$a = array_fill_keys($keys, 'banana');
print_r($a);
?>

El resultado del ejemplo sería:

Array
(
    [foo] => banana
    [5] => banana
    [10] => banana
    [bar] => banana
)

Ver también

  • array_fill() - Llena un array con valores
  • array_combine() - Crea un nuevo array, usando una matriz para las claves y otra para sus valores


Llena un array con valores

  • « array_fill_keys
  • array_filter »
  • PHP Manual
  • Funciones de Arrays
  • Llena un array con valores

array_fill

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_fill — Llena un array con valores

Descripción

array_fill ( int $start_index , int $num , mixed $value ) : array

Llena un array con num entradas del valor del parámetro value, las keys inician en el parámetro start_index.

Parámetros

start_index

El primer índice del array retornado.

Si start_index es negativo, el primer índice del array retornado será start_index y los siguientes indices comenzarán desde cero (ver ejemplo).

num

Número de elementos a insertar. Debe ser mayor o igual que cero.

value

Valor a usar para el llenado.

Valores devueltos

Retorna el array llenado.

Errores/Excepciones

Arroja un E_WARNING si num es menor que cero.

Historial de cambios

Versión | Descripción
5.6.0 | num ahora puede ser cero. Anteriormente, se requería que num fuera maoyor que cero.

Ejemplos

Ejemplo #1 Ejemplo de array_fill()

<?php
$a = array_fill(5, 6, 'banana');
$b = array_fill(-2, 4, 'pear');
print_r($a);
print_r($b);
?>

El resultado del ejemplo sería:

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)
Array
(
    [-2] => pear
    [0] => pear
    [1] => pear
    [2] => pear
)

Notas

Ver también la sección Arrays del manual para una explicación detallada de las claves negativas.

Ver también

  • array_fill_keys() - Llena un array con valores, especificando las keys
  • str_repeat() - Repite un string
  • range() - Crear un array que contiene un rango de elementos


Filtra elementos de un array usando una función de devolución de llamada

  • « array_fill
  • array_flip »
  • PHP Manual
  • Funciones de Arrays
  • Filtra elementos de un array usando una función de devolución de llamada

array_filter

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

array_filter — Filtra elementos de un array usando una función de devolución de llamada

Descripción

array_filter ( array $array , callable $callback = ? , int $flag = 0 ) : array

Recorre cada valor de array, pasándolos a la función callback. Si la función callback devuelve true el valor actual desde array es devuelto al array resultante. Las claves del array se conservan.

Parámetros

array

El array a recorrer.

callback

La función de devolución de llamada a usar.

Si no se proporciona callback, todas las entradas de array iguales a false (véase convetir a boolean) serán eliminadas.

flag

Indicador que determina qué argumentos se envían a callback:

  • ARRAY_FILTER_USE_KEY - pasar la clave como el único argumento a callback en lugar del valor
  • ARRAY_FILTER_USE_BOTH - pasar el valor y la clave como argumentos a callback en lugar del valor
Por omisión es 0 que pasará el valor como el único argumento a callback en su lugar.

Valores devueltos

Devuelve el array filtrado.

Historial de cambios

Versión | Descripción
5.6.0 | Se añadió el parámetro opcional flag y las constantes ARRAY_FILTER_USE_KEY y ARRAY_FILTER_USE_BOTH

Ejemplos

Ejemplo #1 Ejemplo de array_filter()

<?php
function impar($var)
{
    // Retorna siempre que el número entero sea impar
    return $var & 1;
}

function par($var)
{
    // Retorna siempre que el número entero sea par
    return !($var & 1);
}

$array1 = ['a' => 1, 'b' => 2, 'c' => 3, 'd' => 4, 'e' => 5];
$array2 = [6, 7, 8, 9, 10, 11, 12];

echo "Impar :\n";
print_r(array_filter($array1, "impar"));
echo "Par:\n";
print_r(array_filter($array2, "par"));
?>

El resultado del ejemplo sería:

Impar :
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Par:
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

Ejemplo #2 array_filter() sin callback

<?php

$entrada = [
    0 => 'foo',
    1 => false,
    2 => -1,
    3 => null,
    4 => '',
    5 => '0',
    6 => 0,
];

print_r(array_filter($entrada));
?>

El resultado del ejemplo sería:

Array
(
    [0] => foo
    [2] => -1
)

Ejemplo #3 array_filter() con flag

<?php

$arr = ['a' => 1, 'b' => 2, 'c' => 3, 'd' => 4];

var_dump(array_filter($arr, function($k) {
    return $k == 'b';
}, ARRAY_FILTER_USE_KEY));

var_dump(array_filter($arr, function($v, $k) {
    return $k == 'b' || $v == 4;
}, ARRAY_FILTER_USE_BOTH));
?>

El resultado del ejemplo sería:

array(1) {
  ["b"]=>
  int(2)
}
array(2) {
  ["b"]=>
  int(2)
  ["d"]=>
  int(4)
}

Notas

Precaución

Si el array se cambia desde la función de devolución de llamada (p.ej. un elemento añadido, suprimido o desestablecido) el comportamiento de esta función no estará definido.

Ver también

  • array_map() - Aplica la retrollamada a los elementos de los arrays dados
  • array_reduce() - Reduce iterativamente un array a un solo valor usando una función llamada de retorno
  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array


Intercambia todas las claves de un array con sus valores asociados

  • « array_filter
  • array_intersect_assoc »
  • PHP Manual
  • Funciones de Arrays
  • Intercambia todas las claves de un array con sus valores asociados

array_flip

(PHP 4, PHP 5, PHP 7, PHP 8)

array_flip — Intercambia todas las claves de un array con sus valores asociados

Descripción

array_flip ( array $array ) : array

array_flip() devuelve un array dado la vuelta, es decir, las claves de array se convierten en valores y los valores de array se convierten en claves.

Observe que los valores de array tienen que ser ser claves válidas, es decir, que necesitan ser un valor de tipo integer o string. Se emitirá una advertencia si un valor tiene el tipo erróneo, por lo que el par clave/valor en cuestión no será incluido en el resultado

Si un valor tiene varias coincidencias, se usará la última clave como su valor, perdiéndose todas las demás.

Parámetros

array

Un array de pares clave/valor a ser volteados.

Valores devueltos

Devuelve el array volteado en caso de éxito y null si en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de array_flip()

<?php
$entrada = array("naranjas", "manzanas", "peras");
$intercambio = array_flip($entrada);

print_r($intercambio);
?>

El resultado del ejemplo sería:

Array
(
    [naranjas] => 0
    [manzanas] => 1
    [peras] => 2
)

Ejemplo #2 Ejemplo de array_flip() : collision

<?php
$entrada = array("a" => 1, "b" => 1, "c" => 2);
$intercambio = array_flip($entrada);

print_r($intercambio);
?>

El resultado del ejemplo sería:

Array
(
    [1] => b
    [2] => c
)

Ver también

  • array_values() - Devuelve todos los valores de un array
  • array_keys() - Devuelve todas las claves de un array o un subconjunto de claves de un array
  • array_reverse() - Devuelve un array con los elementos en orden inverso


Calcula la intersección de arrays con un chequeo adicional de índices

  • « array_flip
  • array_intersect_key »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays con un chequeo adicional de índices

array_intersect_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

array_intersect_assoc — Calcula la intersección de arrays con un chequeo adicional de índices

Descripción

array_intersect_assoc ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect_assoc() devuelve un array que contiene todos los valores de array1 que están presentes en todos los arguementos. Nótese que las claves también se usan en la comparación, a diferencia de array_intersect().

Parámetros

array1

Array con los valores maestros para verificar.

array2

Un array con el que comparar los valores.

...

Una lista variable de arrays para comparar.

Valores devueltos

Devuelve un array asociativo que contiene todos los valores de array1 que están presentes en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_intersect_assoc()

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "b" => "yellow", "blue", "red");
$result_array = array_intersect_assoc($array1, $array2);
print_r($result_array);
?>

El resultado del ejemplo sería:

Array
(
    [a] => green
)

En el ejemplo se ve que sólo el par "a" => "green" está presente en ambos arrays, por lo que es devuelto. El valor "red" no es devuelto porque en $array1 su clave es 0 mientras que la clave de "red" en $array2 es 1; la clave "b" no es devuelta debido a que sus valores son diferentes en cada array.

Los dos valores del par clave => valor son considerados iguales sólo si (string) $elem1 === (string) $elem2 . En otras palabras, se ejecuta una verificación estricta de tipos, por lo que la representación del string debe ser la misma.

Ver también

  • array_intersect() - Calcula la intersección de arrays
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado
  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices


Calcula la intersección de arrays usando sus claves para la comparación

  • « array_intersect_assoc
  • array_intersect_uassoc »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays usando sus claves para la comparación

array_intersect_key

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_intersect_key — Calcula la intersección de arrays usando sus claves para la comparación

Descripción

array_intersect_key ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect_key() devuelve un array que contiene todos los valores de array1 que tienen claves que están presentes en todos los argumentos.

Parámetros

array1

El array con las claves maestras para verificar.

array2

Un array con el que comparar las claves.

...

Una lista variable de arrays para comparar.

Valores devueltos

Devuelve un array asociativo que contiene todas las entradas de array1 que tienen claves que están presentes en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_intersect_key()

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_key($array1, $array2));
?>

El resultado del ejemplo sería:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

En el ejemplo se puede ver que sólo las claves 'blue' y 'green' están presentes en ambos arrays, por lo que son devueltas. Observe también que los valores de las claves 'blue' y 'green' difieren entre los dos arrays. Sigue habiendo coincidencia porque solamente se verifican las claves. Los valores devueltos son los de array1.

Las dos claves de los pares clave => valor son consideradas iguales sólo si (string) $clave1 === (string) $clave2 . En otras palabras se ejecuta una verificación estricta de tipos, por lo que la representación del string debe ser la misma.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_diff_key() - Calcula la diferencia entre arrays empleando las claves para la comparación
  • array_diff_ukey() - Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_intersect_ukey() - Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación


Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada

  • « array_intersect_key
  • array_intersect_ukey »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada

array_intersect_uassoc

(PHP 5, PHP 7, PHP 8)

array_intersect_uassoc — Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada

Descripción

array_intersect_uassoc ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

array_intersect_uassoc() devuelve un array que contiene todos los valores de array1 que están presentes en todos los argumentos. Nótese que las claves se utilizan en la comparación a diferencia de array_intersect().

Parámetros

array1

El array inicial para la comparación de arrays.

array2

El primer array para comparar claves.

...

Una lista variable de argumentos de arrays para comparar valores.

key_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Devuelve los valores de array1 cuyos valores existen en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_intersect_uassoc()

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_intersect_uassoc($array1, $array2, "strcasecmp"));
?>

El resultado del ejemplo sería:

Array
(
    [b] => brown
)

Ver también

  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado
  • array_intersect_key() - Calcula la intersección de arrays usando sus claves para la comparación
  • array_intersect_ukey() - Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación


Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación

  • « array_intersect_uassoc
  • array_intersect »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación

array_intersect_ukey

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_intersect_ukey — Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación

Descripción

array_intersect_ukey ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

array_intersect_ukey() retorna un array que contiene todos los valores de array1 que tengan tengan que estén presentes en todos los argumentos.

Parámetros

array1

Array inicial para la comparación de los arrays.

array2

Primer array con el que comparar las claves.

...

Una lista variable de argumentos de tipo array con la que comparar claves.

key_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Retorna los valores de array1 cuyas claves existen en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_intersect_ukey()

<?php
function comparar_claves($clave1, $clave2)
{
    if ($clave1 == $clave2)
        return 0;
    else if ($clave1 > $clave2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_ukey($array1, $array2, 'comparar_claves'));
?>

El resultado del ejemplo sería:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

En el ejemplo se puede ver que sólo las claves 'blue' y 'green' están presentes en ambos arrays, por lo que son devueltas. Observe también que los valores de las claves 'blue' y 'green' difieren entre los dos arrays. Sigue habiendo coincidencia porque solamente se verifican las claves. Los valores devueltos son los de array1.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_diff_key() - Calcula la diferencia entre arrays empleando las claves para la comparación
  • array_diff_ukey() - Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_intersect_key() - Calcula la intersección de arrays usando sus claves para la comparación


Calcula la intersección de arrays

  • « array_intersect_ukey
  • array_key_exists »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays

array_intersect

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_intersect — Calcula la intersección de arrays

Descripción

array_intersect ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect() retorna un array que contiene todos los valores de array1 que están presentes en todos los argumentos. Observe que las claves se mantienen.

Parámetros

array1

Array con los valores maestros a verificar.

array2

Un array con el que comparar los valores.

...

Una lista variable de arrays para comparar.

Valores devueltos

Retorna un array que contiene todos los valores de array1 cuyos valores existen en todos los parámetros.

Ejemplos

Ejemplo #1 Ejemplo de array_intersect()

<?php
$array1 = array("a" => "green", "red", "blue");
$array2 = array("b" => "green", "yellow", "red");
$result = array_intersect($array1, $array2);
print_r($result);
?>

El resultado del ejemplo sería:

Array
(
    [a] => green
    [0] => red
)

Notas

Nota: Dos elementos son considerados iguales si y sólo si (string) $elem1 === (string) $elem2. Es decir: cuando la representación de string es la misma.

Ver también

  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices


Verifica si el índice o clave dada existe en el array

  • « array_intersect
  • array_key_first »
  • PHP Manual
  • Funciones de Arrays
  • Verifica si el índice o clave dada existe en el array

array_key_exists

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

array_key_exists — Verifica si el índice o clave dada existe en el array

Descripción

array_key_exists ( mixed $key , array $array ) : bool

array_key_exists() devuelve true si la key dada existe en el array. La key puede ser cualquier valor posible para índice de un array.

Parámetros

key

Valor para verificar.

array

Un array con las claves para verificar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Nota:

array_key_exists() buscará las claves en la primera dimensión solamente. Las claves anidadas en arrays multidimensionales no se encontrarán.

Ejemplos

Ejemplo #1 Ejemplo de array_key_exists()

<?php
$search_array = array('first' => 1, 'second' => 4);
if (array_key_exists('first', $search_array)) {
    echo "The 'first' element is in the array";
}
?>

Ejemplo #2 array_key_exists() vs isset()

isset() no retorna true para claves de array que correspondan a un valor null, mientras que array_key_exists() si lo hace.

<?php
$search_array = array('first' => null, 'second' => 4);

// returns false
isset($search_array['first']);

// returns true
array_key_exists('first', $search_array);
?>

Notas

Nota:

Por razones de retrocompatilibidad, array_key_exists() también devuelve true si key es una propiedad definida dentro de un objeto dado como array. No debería depender de este comportamiento, y se ha tener cuidado para asegurarse de que array es un array.

Para comprobar si una propiedad existe en un objeto, use property_exists().

Ver también

  • isset() - Determina si una variable está definida y no es null
  • array_keys() - Devuelve todas las claves de un array o un subconjunto de claves de un array
  • in_array() - Comprueba si un valor existe en un array
  • property_exists() - Comprueba si el objeto o la clase tienen una propiedad


Obtiene la primera clave de un array

  • « array_key_exists
  • array_key_last »
  • PHP Manual
  • Funciones de Arrays
  • Obtiene la primera clave de un array

array_key_first

(PHP 7 >= 7.3.0, PHP 8)

array_key_first — Obtiene la primera clave de un array

Descripción

array_key_first ( array $array ) : mixed

Consigue la primera clave del array dado sin afectar el puntero de array interno.

Parámetros

array

Un array;

Valores devueltos

Devuelve la primera clave del array si el array no está vacío; null en caso contrario.

Ejemplos

Ejemplo #1 Uso básico de array_key_first()

<?php
$array = ['a' => 1, 'b' => 2, 'c' => 3];

$firstKey = array_key_first($array);

var_dump($firstKey);
?>

El resultado del ejemplo sería:

string(1) "a"

Notas

Sugerencia

Hay varias maneras de proporcionar esta funcionalidad para las versiones anteriores a PHP 7.3.0. Es posible utilizar array_keys(), pero eso puede ser más bien ineficiente. También es posible utilizar reset() y key(), pero eso puede cambiar el puntero del array interno. Una solución eficiente, que no hace cambio del puntero del array interno, escrito como polietileno:

<?php
if (!function_exists('array_key_first')) {
    function array_key_first(array $arr) {
        foreach($arr as $key => $unused) {
            return $key;
        }
        return NULL;
    }
}
?>

Ver también

  • array_key_last() - Obtiene la última clave de un array
  • reset() - Establece el puntero interno de un array a su primer elemento


Obtiene la última clave de un array

  • « array_key_first
  • array_keys »
  • PHP Manual
  • Funciones de Arrays
  • Obtiene la última clave de un array

array_key_last

(PHP 7 >= 7.3.0, PHP 8)

array_key_last — Obtiene la última clave de un array

Descripción

array_key_last ( array $array ) : mixed

Obtener la última clave del array dado sin afectar el puntero del array interno.

Parámetros

array

Un array;

Valores devueltos

Devuelve la última clave del array si el array no está vacío; null en caso contrario.

Ver también

  • array_key_first() - Obtiene la primera clave de un array
  • end() - Establece el puntero interno de un array a su último elemento


Devuelve todas las claves de un array o un subconjunto de claves de un array

  • « array_key_last
  • array_map »
  • PHP Manual
  • Funciones de Arrays
  • Devuelve todas las claves de un array o un subconjunto de claves de un array

array_keys

(PHP 4, PHP 5, PHP 7, PHP 8)

array_keys — Devuelve todas las claves de un array o un subconjunto de claves de un array

Descripción

array_keys ( array $array ) : array
array_keys ( array $array , mixed $search_value , bool $strict = false ) : array

array_keys() devuelve las claves, numéricas y de tipo string, del array.

Si se especifica el parámetro search_value, solamente serán devueltas las claves para ese valor. De lo contrario, son devueltas todas las claves de array.

Parámetros

array

Un array que contiene las claves a devolver.

search_value

Si se especifica, solamente serán devueltas las claves que contengan estos valores.

strict

Determina si debería usarse una comparación estricta (===) durante la búsqueda.

Valores devueltos

Retorna un array con todas las claves de array.

Ejemplos

Ejemplo #1 Ejemplo de array_keys()

<?php
$array = array(0 => 100, "color" => "red");
print_r(array_keys($array));

$array = array("blue", "red", "green", "blue", "blue");
print_r(array_keys($array, "blue"));

$array = array("color" => array("blue", "red", "green"),
               "size"  => array("small", "medium", "large"));
print_r(array_keys($array));
?>

El resultado del ejemplo sería:

Array
(
    [0] => 0
    [1] => color
)
Array
(
    [0] => 0
    [1] => 3
    [2] => 4
)
Array
(
    [0] => color
    [1] => size
)

Ver también

  • array_values() - Devuelve todos los valores de un array
  • array_combine() - Crea un nuevo array, usando una matriz para las claves y otra para sus valores
  • array_key_exists() - Verifica si el índice o clave dada existe en el array
  • array_search() - Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito


Aplica la retrollamada a los elementos de los arrays dados

  • « array_keys
  • array_merge_recursive »
  • PHP Manual
  • Funciones de Arrays
  • Aplica la retrollamada a los elementos de los arrays dados

array_map

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

array_map — Aplica la retrollamada a los elementos de los arrays dados

Descripción

array_map ( callable $callback , array $array1 , array $... = ? ) : array

array_map() devuelve un array que contiene todos los elementos de array1 después de haber aplicado la función callback a cada uno de ellos. El número de parámetros que la función callback acepta debería coincidir con el número de arrays proporcionados a array_map().

Parámetros

callback

Función de retrollamada a ejecutar para cada elemento de cada array.

array1

Un array a recorrer con la función callback.

...

Lista variable de argumentos de tipo array a recorrer con la función callback.

Valores devueltos

Devuelve un array que contiene todos los elementos de array1 después de aplicar la función callback a cada uno de ellos.

Ejemplos

Ejemplo #1 Ejemplo de array_map()

<?php
function cube($n)
{
    return($n * $n * $n);
}

$a = array(1, 2, 3, 4, 5);
$b = array_map("cube", $a);
print_r($b);
?>

Este ejemplo hace que $b contenga:

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

Ejemplo #2 array_map() usando una función lambda (desde PHP 5.3.0)

<?php
$func = function($valor) {
    return $valor * 2;
};

print_r(array_map($func, range(1, 5)));
?>
Array
(
    [0] => 2
    [1] => 4
    [2] => 6
    [3] => 8
    [4] => 10
)

Ejemplo #3 array_map() - usando más arrays

<?php
function mostrar_en_español($n, $m)
{
    return("El número $n se llama $m en español");
}

function correspondencia_en_español($n, $m)
{
    return(array($n => $m));
}

$a = array(1, 2, 3, 4, 5);
$b = array("uno", "dos", "tres", "cuatro", "cinco");

$c = array_map("mostrar_en_español", $a, $b);
print_r($c);

$d = array_map("correspondencia_en_español", $a , $b);
print_r($d);
?>

El resultado del ejemplo sería:

// salida de $c
Array
(
    [0] => El número 1 se llama uno en español
    [1] => El número 2 se llama dos en español
    [2] => El número 3 se llama tres en español
    [3] => El número 4 se llama cuatro en español
    [4] => El número 5 se llama cinco en español
)

// salida of $d
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

Usualmente, cuando se usan dos o más arrays, estos deberían ser de la misma longitud, ya que la retrollamada se aplica en paralelo a los elementos correspondientes. Si los arrays son de longitudes diferentes, los más cortos se extenderán con elementos vacíos para que coincidan con la logintud del más largo.

Un uso interesante de esta función es la construcción de un array de arrays, lo que se puede llevar a cabo usando null como el nombre de la retrollamada.

Ejemplo #4 Crear un array de arrays

<?php
$a = array(1, 2, 3, 4, 5);
$b = array("one", "two", "three", "four", "five");
$c = array("uno", "dos", "tres", "cuatro", "cinco");

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => uno
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => dos
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => tres
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => cuatro
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => cinco
        )

)

El array devuelto conservará las claves del argumento array si y solo si se pasa exactamente un array. Si se pasa más de un array, el array devuelto tendrá claves secuenciales de tipo integer.

Ejemplo #5 array_map() - con claves de tipo string

<?php
$arr = array("stringkey" => "value");
function cb1($a) {
    return array ($a);
}
function cb2($a, $b) {
    return array ($a, $b);
}
var_dump(array_map("cb1", $arr));
var_dump(array_map("cb2", $arr, $arr));
var_dump(array_map(null,  $arr));
var_dump(array_map(null, $arr, $arr));
?>

El resultado del ejemplo sería:

array(1) {
  ["stringkey"]=>
  array(1) {
    [0]=>
    string(5) "value"
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "value"
    [1]=>
    string(5) "value"
  }
}
array(1) {
  ["stringkey"]=>
  string(5) "value"
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "value"
    [1]=>
    string(5) "value"
  }
}

Ver también

  • array_filter() - Filtra elementos de un array usando una función de devolución de llamada
  • array_reduce() - Reduce iterativamente un array a un solo valor usando una función llamada de retorno
  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array


Une dos o más arrays recursivamente

  • « array_map
  • array_merge »
  • PHP Manual
  • Funciones de Arrays
  • Une dos o más arrays recursivamente

array_merge_recursive

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_merge_recursive — Une dos o más arrays recursivamente

Descripción

array_merge_recursive ( array $array1 , array $... = ? ) : array

array_merge_recursive() une los elementos de uno o más arrays de modo tal que los valores de uno sean añadidos al final del anterior. Devuelve el array resultante.

Si los arrays de entrada tienen las mismas claves de tipo string, los valores de estas claves son unidas en un array, y esto se realiza recursivamente, de modo que si uno de los valores es un array mismo, la función unirá también ésta con la correspondiente entrada de otro array. Sin embargo, si los arrays tienen la misma clave numérica, el valor posterior no sobrescribirá el valor original, sino que será añadido al final.

Parámetros

array1

Array inicial a unir.

...

Lista variable de arrays a unir recursivamente.

Valores devueltos

Un array de valores resultante de la unión de los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_merge_recursive()

<?php
$m1 = array("color" => array("favorito" => "rojo"), 5);
$m2 = array(10, "color" => array("favorito" => "verde", "azul"));
$resultado = array_merge_recursive($m1, $m2);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [color] => Array
        (
            [favorito] => Array
                (
                    [0] => rojo
                    [1] => verde
                )

            [0] => azul
        )

    [0] => 5
    [1] => 10
)

Ver también

  • array_merge() - Combina dos o más arrays
  • array_replace_recursive() - Reemplaza los elementos de los arrays pasados al primer array de forma recursiva


Combina dos o más arrays

  • « array_merge_recursive
  • array_multisort »
  • PHP Manual
  • Funciones de Arrays
  • Combina dos o más arrays

array_merge

(PHP 4, PHP 5, PHP 7, PHP 8)

array_merge — Combina dos o más arrays

Descripción

array_merge ( array $array1 , array $... = ? ) : array

Combina los elementos de uno o más arrays juntándolos de modo que los valores de uno se anexan al final del anterior. Retorna el array resultante.

Si los arrays de entrada tienen las mismas claves de tipo string, el último valor para esa clave sobrescribirá al anterior. Sin embargo, los arrays que contengan claves numéricas, el último valor no sobrescribirá el valor original, sino que será añadido al final.

Los valores del array de entrada con claves numéricas serán renumeradas con claves incrementales en el array resultante, comenzando desde cero.

Parámetros

array1

Array inicial a combinar.

...

Lista variable de arrays para combinar.

Valores devueltos

Retorna el array resultante.

Ejemplos

Ejemplo #1 Ejemplo de array_merge()

<?php
$array1    = array("color" => "red", 2, 4);
$array2    = array("a", "b", "color" => "green", "shape" => "trapezoid", 4);
$resultado = array_merge($array1, $array2);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [color] => green
    [0] => 2
    [1] => 4
    [2] => a
    [3] => b
    [shape] => trapezoid
    [4] => 4
)

Ejemplo #2 Ejemplo de sencillo de array_merge()

<?php
$array1    = array();
$array2    = array(1 => "data");
$resultado = array_merge($array1, $array2);
?>

¡No olvidarse de que las claves numéricas serán renumeradas!

Array
(
    [0] => data
)

Para anexar elementos del segundo array al primer array entretanto no se sobrescriban los elementos del primer array y no se reindexe, se ha de utilizar el operador + de unión de arrays.

<?php
$array1    = array(0 => 'zero_a', 2 => 'two_a', 3 => 'three_a');
$array2    = array(1 => 'one_b', 3 => 'three_b', 4 => 'four_b');
$resultado = $array1 + $array2;
var_dump($resultado);
?>

Las claves del primer array se preservaran. Si una clave existe en ambos arrays, se usará el elemento del primer array, y el elemento de la clave coincidente del segundo array será ignorado.

array(5) {
  [0]=>
  string(6) "zero_a"
  [2]=>
  string(5) "two_a"
  [3]=>
  string(7) "three_a"
  [1]=>
  string(5) "one_b"
  [4]=>
  string(6) "four_b"
}

Ejemplo #3 array_merge() con tipos que no son array

<?php
$comienzo = 'foo';
$fin = array(1 => 'bar');
$resultado = array_merge((array)$comienzo, (array)$fin);
print_r($resultado);
?>

El resultado del ejemplo sería:

    Array
    (
        [0] => foo
        [1] => bar
    )

Ver también

  • array_merge_recursive() - Une dos o más arrays recursivamente
  • array_replace() - Reemplaza los elementos del array original con elementos de array adicionales
  • array_combine() - Crea un nuevo array, usando una matriz para las claves y otra para sus valores
  • operadores de arrays


Ordena varios arrays, o arrays multidimensionales

  • « array_merge
  • array_pad »
  • PHP Manual
  • Funciones de Arrays
  • Ordena varios arrays, o arrays multidimensionales

array_multisort

(PHP 4, PHP 5, PHP 7, PHP 8)

array_multisort — Ordena varios arrays, o arrays multidimensionales

Descripción

array_multisort ( array &$array1 , mixed $array1_sort_order = SORT_ASC , mixed $array1_sort_flags = SORT_REGULAR , mixed $... = ? ) : bool

array_multisort() puede usarse para ordenar varios arrays al mismo tiempo, o un array multidimensional por una o más dimensiones.

Las claves asociativas (string) se mantendrán, aunque las claves numéricas serán reindexadas.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array1

Un array a ordenar.

array1_sort_order

El orden usado para ordenar el argumento anterior array. Puede ser SORT_ASC para orden ascendente o SORT_DESC para orden descendente.

Este argumento se puede intercambiar con array1_sort_flags u omitir por completo, en cuyo caso se asume SORT_ASC.

array1_sort_flags

Opciones de ordenación para el argumento previo array:

Banderas de tipo de ordenación:

  • SORT_REGULAR - compara los elementos normalmente (no cambia los tipos)
  • SORT_NUMERIC - compara los elementos numéricamente
  • SORT_STRING - compara los elementos como strings
  • SORT_LOCALE_STRING - compara los elementos como strings, basándose en la configuración regional en uso. Utiliza la configuración regional, la cual se puede cambiar usando setlocale()
  • SORT_NATURAL - compara los elementos como strings usando un "orden natural" como natsort()
  • SORT_FLAG_CASE - puede ser combinado (OR a nivel de bits) con SORT_STRING o SORT_NATURAL para ordenar strings sin considerar mayúsculas/minúsculas

Este argumento puede ser intercambiado con array1_sort_order u omitido por completo, en cuyo caso se asume SORT_REGULAR.

...

Más arrays, opcionalmente seguidos de una opción de ordenación y banderas. Solamente se comparan los elementos correspondientes a elementos equivalentes en arrays previos. En otras palabras, el orden el lexicográfico.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadieron SORT_NATURAL y SORT_FLAG_CASE a array1_sort_flags como posibles banderas de ordenación.
5.3.0 | Se añadió SORT_LOCALE_STRING a array1_sort_flags como posible bandera de ordenación.

Ejemplos

Ejemplo #1 Ordenar varios arrays

<?php
$array1 = array(10, 100, 100, 0);
$array2 = array(1, 3, 2, 4);
array_multisort($array1, $array2);

var_dump($array1);
var_dump($array2);
?>

En este ejemplo, después de la ordenación, el primer array contendrá los valores 0, 10, 100, 100. El segundo array contendrá 4, 1, 2, 3. Las entradas en el segundo array correspondientes a las entradas idénticas del primer array (100 y 100) fueron ordenadas también.

array(4) {
  [0]=> int(0)
  [1]=> int(10)
  [2]=> int(100)
  [3]=> int(100)
}
array(4) {
  [0]=> int(4)
  [1]=> int(1)
  [2]=> int(2)
  [3]=> int(3)
}

Ejemplo #2 Ordenar un array multidimensional

<?php
$ar = array(
       array("10", 11, 100, 100, "a"),
       array(   1,  2, "2",   3,   1)
      );
array_multisort($ar[0], SORT_ASC, SORT_STRING,
                $ar[1], SORT_NUMERIC, SORT_DESC);
var_dump($ar);
?>

En este ejemplo, después de la ordenación, el primer array se transformará en "10", 100, 100, 11, "a" (fue ordenado como string en orden ascendente). El segundo contendrá 1, 3, "2", 2, 1 (ordenada como números, en orden descendiente).

array(2) {
  [0]=> array(5) {
    [0]=> string(2) "10"
    [1]=> int(100)
    [2]=> int(100)
    [3]=> int(11)
    [4]=> string(1) "a"
  }
  [1]=> array(5) {
    [0]=> int(1)
    [1]=> int(3)
    [2]=> string(1) "2"
    [3]=> int(2)
    [4]=> int(1)
  }
}

Ejemplo #3 Ordenar resultados de una base de datos

Para este ejemplo, cada elemento del array datos representa una fila de una tabla. Este tipo de conjunto de datos es típico de los registros en una base de datos.

Datos de ejemplo:

volumen| edición
-------+--------
    67 |       2
    86 |       1
    85 |       6
    98 |       2
    86 |       6
    67 |       7

Los datos como un array, llamados datos. Éste se obtendría normalmente, por ejemplo, mediante un bucle con mysqli_fetch_assoc().

<?php
$datos[] = array('volumen' => 67, 'edición' => 2);
$datos[] = array('volumen' => 86, 'edición' => 1);
$datos[] = array('volumen' => 85, 'edición' => 6);
$datos[] = array('volumen' => 98, 'edición' => 2);
$datos[] = array('volumen' => 86, 'edición' => 6);
$datos[] = array('volumen' => 67, 'edición' => 7);
?>

En este ejemplo, ordenaremos por volumen descendientemente, y por edición ascendentemente.

Tenemos un array de filas, pero array_multisort() requiere un array de columnas, así que usamos el código siguiente para obtener las columnas, y luego realizar la ordenación.

<?php
// Obtener una lista de columnas
foreach ($datos as $clave => $fila) {
    $volumen[$clave] = $fila['volumen'];
    $edición[$clave] = $fila['edición'];
}

// a partir de PHP 5.5.0 puede usar array_column() en lugar del código anterior
$volume  = array_column($data, 'volume');
$edition = array_column($data, 'edition');

// Ordenar los datos con volumen descendiente, edición ascendiente
// Agregar $datos como el último parámetro, para ordenar por la clave común
array_multisort($volumen, SORT_DESC, $edición, SORT_ASC, $datos);
?>

El conjunto de datos ahora está ordenado, y será de este modo:

volumen| edición
-------+--------
    98 |       2
    86 |       1
    86 |       6
    85 |       6
    67 |       2
    67 |       7

Ejemplo #4 Ordenación sin considerar mayúsculas/minúsculas

Tanto SORT_STRING como SORT_REGULAR consideran las mayúsculas/minúsculas, los string que comiencen con una letra mayúscula irán antes que los string que comiencen con una letra minúscula.

Para realizar una ordenación sin considerar mayúsculas y minúsculas, asegúrese de que el orden sea determinado por una copia en minúsculas del array original.

<?php
$array = array('Alpha', 'atomic', 'Beta', 'bank');
$array_lowercase = array_map('strtolower', $array);

array_multisort($array_lowercase, SORT_ASC, SORT_STRING, $array);

print_r($array);
?>

El resultado del ejemplo sería:

Array
(
    [0] => Alpha
    [1] => atomic
    [2] => bank
    [3] => Beta
)

Ver también

  • usort() - Ordena un array según sus valores usando una función de comparación definida por el usuario
  • comparación de funciones de orden de arrays


Rellena un array a la longitud especificada con un valor

  • « array_multisort
  • array_pop »
  • PHP Manual
  • Funciones de Arrays
  • Rellena un array a la longitud especificada con un valor

array_pad

(PHP 4, PHP 5, PHP 7, PHP 8)

array_pad — Rellena un array a la longitud especificada con un valor

Descripción

array_pad ( array $array , int $size , mixed $value ) : array

array_pad() devuelve una copia de array rellenada al tamaño especificado por size con el valor value. Si size es positivo, el array se rellena hacia la derecha, si es negativo hacia la izquierda. Si el valor absoluto de size es menor o igual a la longitud de array, no se lleva a cabo el relleno. Es posible añadir como máximo 1048576 elementos de una sola vez.

Parámetros

array

Array inicial de valores a rellenar.

size

Nuevo tamaño del array.

value

Valor a rellenar si array es menor que size.

Valores devueltos

Devuelve una copia de array rellenada al espacio especificado por size con el valor value. Si size es positivo el array es relleno hacia la derecha, si es negativo hacia la izquierda. Si el valor absoluto de size es menor o igual que la longitud de array, no se lleva a cabo el relleno.

Ejemplos

Ejemplo #1 Ejemplo de array_pad()

<?php
$input = array(12, 10, 9);

$result = array_pad($input, 5, 0);
// el resultado es array(12, 10, 9, 0, 0)

$result = array_pad($input, -7, -1);
// el resultado es array(-1, -1, -1, -1, 12, 10, 9)

$result = array_pad($input, 2, "noop");
// sin relleno
?>

Ver también

  • array_fill() - Llena un array con valores
  • range() - Crear un array que contiene un rango de elementos


Extrae el último elemento del final del array

  • « array_pad
  • array_product »
  • PHP Manual
  • Funciones de Arrays
  • Extrae el último elemento del final del array

array_pop

(PHP 4, PHP 5, PHP 7, PHP 8)

array_pop — Extrae el último elemento del final del array

Descripción

array_pop ( array &$array ) : mixed

array_pop() extrae y devuelve el último elemento del array, acortando el array con un elemento menos.

Nota: Esta función ejecutará un reset() en el puntero de array del array de entrada después de su uso.

Parámetros

array

El array de donde obtener el valor.

Valores devueltos

Devuelve el último elemento del array. Si el array está vacío (o no es un array), se devolverá null.

Errores/Excepciones

Esta función arrojará unerror de nivel E_WARNING cuando se invoca con algo distinto de un array.

Ejemplos

Ejemplo #1 Ejemplo de array_pop()

<?php
$stack = array("naranja", "plátano", "manzana", "frambuesa");
$fruit = array_pop($stack);
print_r($stack);
?>

Después de hacer esto, $stack solo tendrá 3 elementos:

Array
(
    [0] => naranja
    [1] => plátano
    [2] => manzana
)

y frambuesa será asignado a $fruit.

Ver también

  • array_push() - Inserta uno o más elementos al final de un array
  • array_shift() - Quita un elemento del principio del array
  • array_unshift() - Añadir al inicio de un array uno a más elementos


Calcula el producto de los valores de un array

  • « array_pop
  • array_push »
  • PHP Manual
  • Funciones de Arrays
  • Calcula el producto de los valores de un array

array_product

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_product — Calcula el producto de los valores de un array

Descripción

array_product ( array $array ) : number

array_product() devuelve el producto de valores de un array.

Parámetros

array

El array.

Valores devueltos

Devuelve el producto como integer o float.

Historial de cambios

Versión | Descripción
5.3.6 | El producto de un array vacío ahora es 1, mientras que antes esta función devolvía 0 para un array vacío.

Ejemplos

Ejemplo #1 Ejemplo de array_product()

<?php

$a = array(2, 4, 6, 8);
echo "producto(a) = " . array_product($a) . "\n";
echo "producto(array()) = " . array_product(array()) . "\n";

?>

El resultado del ejemplo sería:

producto(a) = 384
producto(array()) = 1


Inserta uno o más elementos al final de un array

  • « array_product
  • array_rand »
  • PHP Manual
  • Funciones de Arrays
  • Inserta uno o más elementos al final de un array

array_push

(PHP 4, PHP 5, PHP 7, PHP 8)

array_push — Inserta uno o más elementos al final de un array

Descripción

array_push ( array &$array , mixed $value1 , mixed $... = ? ) : int

array_push() trata array como si fuera una pila y coloca la variable que se le proporciona al final del array. El tamaño del array será incrementado por el número de variables insertados. Tiene el mismo efecto que:

<?php
$array[] = $var;
?>
repetido por cada valor proporcionado.

Nota: Si se utiliza array_push() para añadir un solo elemento al array, es mejor utilizar $array[] = ya que de esta forma no existe la sobrecarga de llamar a una función.

Nota: array_push() generará una advertencia si el primer argumento no es un array. Esto difiere del comportamiento de $var[] donde se creará un nuevo array.

Parámetros

array

El array de entrada.

value1

El primer valor a colocar al final de array.

Valores devueltos

Devuelve el nuevo número de elementos del array.

Ejemplos

Ejemplo #1 Ejemplo de array_push()

<?php
$pila = array("naranja", "plátano");
array_push($pila, "manzana", "arándano");
print_r($pila);
?>

El resultado del ejemplo sería:

Array
(
    [0] => naranja
    [1] => plátano
    [2] => manzana
    [3] => arándano
)

Ver también

  • array_pop() - Extrae el último elemento del final del array
  • array_shift() - Quita un elemento del principio del array
  • array_unshift() - Añadir al inicio de un array uno a más elementos


Seleccionar una o más claves aleatorias de un array

  • « array_push
  • array_reduce »
  • PHP Manual
  • Funciones de Arrays
  • Seleccionar una o más claves aleatorias de un array

array_rand

(PHP 4, PHP 5, PHP 7, PHP 8)

array_rand — Seleccionar una o más claves aleatorias de un array

Descripción

array_rand ( array $array , int $num = 1 ) : mixed

Selecciona uno o más valores aleatorios de un array y devuelve la clave (o claves) de dichos valores aleatorios. Utiliza un generador de números seudoaleatorios que no es apto para fines criptográficos.

Parámetros

array

El array de entrada.

num

Especifica cuántas entradas deberían seleccionarse.

Valores devueltos

Al seleccionar solamente una entrada, array_rand() devolverá la clave para una entrada aleatoria. De lo contrario, devolverá un array con las claves de las entradas aleatorias. Esto se realiza de tal manera que se pueden seleccionar del array tanto claves como valores aleatorios. Intentar seleccionar más elementos de los que hay en el array resultará en un error de nivel E_WARNING, devolviendo NULL .

Historial de cambios

Versión | Descripción
7.1.0 | El algoritmo de aleatorización interno se ha cambiado para usar el generador de números aleatorios » Mersenne Twister en lugar de la función libc rand.
5.2.10 | El array de claves resultante ya no se mezcla.

Ejemplos

Ejemplo #1 Ejemplo de array_rand()

<?php
$entrada = array("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$claves_aleatorias = array_rand($entrada, 2);
echo $entrada[$claves_aleatorias[0]] . "\n";
echo $entrada[$claves_aleatorias[1]] . "\n";
?>

Ver también

  • shuffle() - Mezcla un array


Reduce iterativamente un array a un solo valor usando una función llamada de retorno

  • « array_rand
  • array_replace_recursive »
  • PHP Manual
  • Funciones de Arrays
  • Reduce iterativamente un array a un solo valor usando una función llamada de retorno

array_reduce

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

array_reduce — Reduce iterativamente un array a un solo valor usando una función llamada de retorno

Descripción

array_reduce ( array $array , callable $callback , mixed $initial = null ) : mixed

array_reduce() aplica iterativamente la función callback a los elementos de array, con el propósito de reducir el array a un solo valor.

Parámetros

array

El array de entrada.

callback
callback ( mixed $carry , mixed $item ) : mixed
carry

Conserva el valor de retorno de la iteración anterior; en el caso de que sea la primera iteración, conservará el valor de initial.

item

Conserva el valor de la iteración actual.

initial

Si el parámetro opcional initial está disponible, será usado al comienzo del proceso, o como un resultado final en caso de que el array esté vacío.

Valores devueltos

Devuelve el valor resultante.

Si el array está vacío y no se proporciona el parámetro initial, array_reduce() devuelve null.

Historial de cambios

Versión | Descripción
5.3.0 | Se cambió el parámetro initial para permitir mixed, anteriormente era integer.

Ejemplos

Ejemplo #1 Ejemplo de array_reduce()

<?php
function suma($carry, $item)
{
    $carry += $item;
    return $carry;
}

function producto($carry, $item)
{
    $carry *= $item;
    return $carry;
}

$a = array(1, 2, 3, 4, 5);
$x = array();

var_dump(array_reduce($a, "suma")); // int(15)
var_dump(array_reduce($a, "producto", 10)); // int(1200), ya que: 10*1*2*3*4*5
var_dump(array_reduce($x, "suma", "No hay datos a reducir")); // string(22) "No hay datos a reducir"
?>

Ver también

  • array_filter() - Filtra elementos de un array usando una función de devolución de llamada
  • array_map() - Aplica la retrollamada a los elementos de los arrays dados
  • array_unique() - Elimina valores duplicados de un array
  • array_count_values() - Cuenta todos los valores de un array


Reemplaza los elementos de los arrays pasados al primer array de forma recursiva

  • « array_reduce
  • array_replace »
  • PHP Manual
  • Funciones de Arrays
  • Reemplaza los elementos de los arrays pasados al primer array de forma recursiva

array_replace_recursive

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

array_replace_recursive — Reemplaza los elementos de los arrays pasados al primer array de forma recursiva

Descripción

array_replace_recursive ( array $array1 , array $... = ? ) : array

array_replace_recursive() reemplaza los valores de array1 con los mismos valores de todos los siguientes arrays. Si una clave del primer array existe en el segundo array, su valor será reemplazado por el valor del segundo array. Si la clave existe en el segundo array, y no en el primero, será creada en el primer array. Si una clave existe únicamente en el primer array, se dejará como está. Si se pasan varios arrays para el reemplazo, serán procesados en orden, el último array sobrescribiendo los valores anteriores.

array_replace_recursive() es recursiva: realizará la recursividad en los arrays y aplicará el mismo proceso al valor interno.

Cuando el valor en el primer array es escalar, será reemplazado por el valor del segundo array, que puede ser escalar o un array. Cuando el valor del primer y el segundo array son arrays, array_replace_recursive() reemplazará sus respectivos valores recursivamente.

Parámetros

array1

El array cuyos elementos son reemplazados.

...

Optional. Arrays de los que se extraerán los elementos.

Valores devueltos

Devuelve un array, o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de array_replace_recursive()

<?php
$base = array('cítricos' => array( "naranja") , 'bayas' => array("mora", "frambuesa"), );
$reemplazos = array('cítricos' => array('piña'), 'bayas' => array('arándano'));

$cesta = array_replace_recursive($base, $reemplazos);
print_r($cesta);

$cesta = array_replace($base, $reemplazos);
print_r($cesta);
?>

El resultado del ejemplo sería:

Array
(
    [cítricos] => Array
        (
            [0] => piña
        )

    [bayas] => Array
        (
            [0] => arándano
            [1] => frambuesa
        )

)
Array
(
    [cítricos] => Array
        (
            [0] => piña
        )

    [bayas] => Array
        (
            [0] => arándano
        )

)

Ejemplo #2 array_replace_recursive() y comportamiento recursivo

<?php
$base = array('cítricos' => array("naranja") , 'bayas' => array("mora", "frambuesa"), 'otros' => 'banana' );
$reemplazos = array('cítricos' => 'piña', 'bayas' => array('arándano'), 'otros' => array('litchis'));
$reemplazos2 = array('cítricos' => array('piña'), 'bayas' => array('arándano'), 'otros' => 'litchis');

$cesta = array_replace_recursive($base, $reemplazos, $reemplazos2);
print_r($cesta);

?>

El resultado del ejemplo sería:

Array
(
    [cítricos] => Array
        (
            [0] => piña
        )

    [bayas] => Array
        (
            [0] => arándano
            [1] => frambuesa
        )

    [otros] => litchis
)

Ver también

  • array_replace() - Reemplaza los elementos del array original con elementos de array adicionales
  • array_merge_recursive() - Une dos o más arrays recursivamente


Reemplaza los elementos del array original con elementos de array adicionales

  • « array_replace_recursive
  • array_reverse »
  • PHP Manual
  • Funciones de Arrays
  • Reemplaza los elementos del array original con elementos de array adicionales

array_replace

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

array_replace — Reemplaza los elementos del array original con elementos de array adicionales

Descripción

array_replace ( array $array1 , array $... = ? ) : array

array_replace() reemplaza los valores de array1 con valores que tienen las mismas claves en cada uno de los siguientes arrays. Si la clave del primer array existe en el segundo array, su valor será reemplazado por el valor del segundo array. Si la clave existe en el segundo array y no en el primero, será creada en el primer array. Si la clave sólo existe en el primer array, se dejará como está. Si se proporcionan varios arrays para el reemplazo, se procederá en orden, los arrays posteriores sobrescribirán los valores anteriores.

array_replace() no es recursivo: reemplazará valores en el primer array por el tipo que esté en el segundo array.

Parámetros

array1

El array cuyos elementos son reemplazados.

...

Arrays de los cuales se extraerán los elementos. Los valores de arrays posteriores sobrescriben los valores anteriores.

Valores devueltos

Devuelve un array, o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de array_replace()

<?php
$base = array("naranja", "plátano", "manzana", "frambuesa");
$reemplazos = array(0 => "piña", 4 => "cereza");
$reemplazos2 = array(0 => "uva");

$cesta = array_replace($base, $reemplazos, $reemplazos2);
print_r($cesta);
?>

El resultado del ejemplo sería:

Array
(
    [0] => uva
    [1] => plátano
    [2] => manzana
    [3] => frambuesa
    [4] => cereza
)

Ver también

  • array_replace_recursive() - Reemplaza los elementos de los arrays pasados al primer array de forma recursiva
  • array_merge() - Combina dos o más arrays


Devuelve un array con los elementos en orden inverso

  • « array_replace
  • array_search »
  • PHP Manual
  • Funciones de Arrays
  • Devuelve un array con los elementos en orden inverso

array_reverse

(PHP 4, PHP 5, PHP 7, PHP 8)

array_reverse — Devuelve un array con los elementos en orden inverso

Descripción

array_reverse ( array $array , bool $preserve_keys = false ) : array

Toma un valor array y devuelve un nuevo array con el orden de los elementos invertido.

Parámetros

array

El array de entrada.

preserve_keys

Si se establece en true las claves numéricas se conservarán. Las claves no numéricas no se ven afectadas por este ajuste y se conservarán siempre.

Valores devueltos

Devuelve el array en orden inverso.

Ejemplos

Ejemplo #1 Ejemplo de array_reverse()

<?php
$input  = array("php", 4.0, array("verde", "rojo"));
$reversed = array_reverse($input);
$preserved = array_reverse($input, true);

print_r($input);
print_r($reversed);
print_r($preserved);
?>

El resultado del ejemplo sería:

Array
(
    [0] => php
    [1] => 4
    [2] => Array
        (
            [0] => verde
            [1] => rojo
        )

)
Array
(
    [0] => Array
        (
            [0] => verde
            [1] => rojo
        )

    [1] => 4
    [2] => php
)
Array
(
    [2] => Array
        (
            [0] => verde
            [1] => rojo
        )

    [1] => 4
    [0] => php
)

Ver también

  • array_flip() - Intercambia todas las claves de un array con sus valores asociados


Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito

  • « array_reverse
  • array_shift »
  • PHP Manual
  • Funciones de Arrays
  • Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito

array_search

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

array_search — Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito

Descripción

array_search ( mixed $needle , array $haystack , bool $strict = false ) : mixed

Busca la needle (aguja) en haystack (pajar).

Parámetros

needle

El valor a buscar.

Nota:

Si needle es una cadena, la comparación es realizada de forma sensible a mayúsculas y minúsculas.

haystack

El array

strict

Si el tercer parámetro, strict, se define como true entonces la función array_search() también buscará elementos idénticos en el haystack. Esto significa que también realizará una comparación estricta de tipos de la needle en el haystack, ya que los objetos deben ser la misma instancia.

Valores devueltos

Devuelve la clave de la needle si se encuentra en el array, o false si no.

Si la needle es encontrada en el haystack más de una vez, se devuelve la primera clave coincidente. Para devolver las claves de todos los valores coincidentes, se ha de usar en su lugar array_keys() con el parámetro opcional search_value.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
5.3.0 | Al igual que con todas las funciones internas de PHP a partir de la versión 5.3.0, array_search() devuelve null si se le pasan parámetros inválidos.

Ejemplos

Ejemplo #1 Ejemplo de array_search()

<?php
$array = array(0 => 'azul', 1 => 'rojo', 2 => 'verde', 3 => 'rojo');

$clave = array_search('verde', $array); // $clave = 2;
$clave = array_search('rojo', $array);  // $clave = 1;
?>

Ver también

  • array_keys() - Devuelve todas las claves de un array o un subconjunto de claves de un array
  • array_values() - Devuelve todos los valores de un array
  • array_key_exists() - Verifica si el índice o clave dada existe en el array
  • in_array() - Comprueba si un valor existe en un array


Quita un elemento del principio del array

  • « array_search
  • array_slice »
  • PHP Manual
  • Funciones de Arrays
  • Quita un elemento del principio del array

array_shift

(PHP 4, PHP 5, PHP 7, PHP 8)

array_shift — Quita un elemento del principio del array

Descripción

array_shift ( array &$array ) : mixed

array_shift() Quita el primer valor del array y lo devuelve, acortando el array un elemento y corriendo el array hacia abajo. Todas la claves del array numéricas serán modificadas para que empiece contando desde cero mientras que las claves literales no se verán afectadas.

Nota: Esta función ejecutará un reset() en el puntero de array del array de entrada después de su uso.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve el valor quitado, o null si el array está vacío o no es un array.

Ejemplos

Ejemplo #1 Ejemplo de array_shift()

<?php
$stack = array("naranja", "plátano", "manzana", "frambuesa");
$fruit = array_shift($stack);
print_r($stack);
?>

El resultado del ejemplo sería:

Array
(
    [0] => plátano
    [1] => manzana
    [2] => frambuesa
)

y naranja será asigando a $fruit.

Ver también

  • array_unshift() - Añadir al inicio de un array uno a más elementos
  • array_push() - Inserta uno o más elementos al final de un array
  • array_pop() - Extrae el último elemento del final del array


Extraer una parte de un array

  • « array_shift
  • array_splice »
  • PHP Manual
  • Funciones de Arrays
  • Extraer una parte de un array

array_slice

(PHP 4, PHP 5, PHP 7, PHP 8)

array_slice — Extraer una parte de un array

Descripción

array_slice ( array $array , int $offset , int $length = null , bool $preserve_keys = false ) : array

array_slice() devuelve la secuencia de elementos del array array tal y como se especifica en los parámetros offset y length.

Parámetros

array

El array de entrada.

offset

Si el índice dado por offset no es negativo, la secuencia empezará en esa posición del array. Si el offset es negativo, la secuencia empezará en esa posición empezando por el final del array.

length

Si la longitud dada por length es positiva, la secuencia tendrá hasta tantos elementos como indique el valor. Si el array es más corto que length, solamente estarán presentes los elementos disponibles del array. Si se proporciona length y es negativo, la secuencia finalizará en tantos elementos empezando por el final del array. Si se omite, entonces la secuencia contendrá todo el contenido desde offset hasta el final del array.

preserve_keys

Observe que array_slice() reordenará y reinicializará los índices numéricos del array de forma predeterminada. Se puede cambiar esta comportamiento estableciendo el parámetro preserve_keys a true.

Valores devueltos

Devuelve la parte del array. Si el índice es mayor que el tamaño del array, devuelve un array vacío.

Historial de cambios

Versión | Descripción
5.2.4 | El valor predeterminado del parámetro length se cambió a NULL. Una length NULL ahora indica a la función que use la longitud de array. Antes de esta versión, una length NULL se tomaba como de longitud cero (no se devolvía nada).
5.0.2 | Se añadió el parámetro opcional preserve_keys.

Ejemplos

Ejemplo #1 Ejemplos de array_slice()

<?php
$entrada = array("a", "b", "c", "d", "e");

$salida = array_slice($entrada, 2);      // devuelve "c", "d", y "e"
$salida = array_slice($entrada, -2, 1);  // devuelve "d"
$salida = array_slice($entrada, 0, 3);   // devuelve "a", "b", y "c"

// observe las diferencias en las claves de los arrays
print_r(array_slice($entrada, 2, -1));
print_r(array_slice($entrada, 2, -1, true));
?>

El resultado del ejemplo sería:

Array
(
    [0] => c
    [1] => d
)
Array
(
    [2] => c
    [3] => d
)

Ver también

  • array_splice() - Elimina una porción del array y la reemplaza con otra cosa
  • unset() - Destruye una variable especificada
  • array_chunk() - Divide un array en fragmentos


Elimina una porción del array y la reemplaza con otra cosa

  • « array_slice
  • array_sum »
  • PHP Manual
  • Funciones de Arrays
  • Elimina una porción del array y la reemplaza con otra cosa

array_splice

(PHP 4, PHP 5, PHP 7, PHP 8)

array_splice — Elimina una porción del array y la reemplaza con otra cosa

Descripción

array_splice ( array &$input , int $offset , int $length = 0 , mixed $replacement = array() ) : array

Elimina los elementos designados por offset y length del array input, y los reemplaza con los elementos del array replacement, si se proporcionan.

Observe que las claves numéricas de input no se preservan.

Nota: Si replacement no es un array, será moldeado a uno (esto es, (array) $replacement). Esto puede resultar en un comportamiento inesperado cuando se usa un objeto o replacement null

Parámetros

input

El array de entrada.

offset

Si el índice dado por offset es positivo, el inicio de la porción eliminada estará en ese índice desde el principio del array input. Si offset es negativo, se comienza desde el final del array input.

length

Si se omite la longitud dada por length, se elimina todo desde offset hasta el final del array. Si se especifica length y es positivo, se eliminarán tantos elementos como indique la longitud. Si se especifica length y es negativo, el final de la porción eliminada será de tantos elementos como indique la longitud desde el final del array. Si se especifica length y es cero, no se eliminará ningún elemento. Consejo: para eliminar todo desde offset hasta el final del array cuando también se especifique replacement, use count($input) para length.

replacement

Si se especifica el array replacement, los elementos eliminados serán reemplazados con los elementos de este array.

Si offset y length son tales que no se elimina nada, los elementos del array replacement serán insertados en el lugar especificado por offset. Observe que las claves del array replacement no se preservan.

Si replacement es sólo un elemento, no es necesario poner array() alrededor de él, a menos que el elemento sea un array, un objeto o null.

Valores devueltos

Devuelve un array que consiste en los elementos extraídos.

Ejemplos

Ejemplo #1 Ejemplos de array_splice()

<?php
$entrada = array("rojo", "verde", "azul", "amarillo");
array_splice($entrada, 2);
// $entrada ahora es array("rojo", "verde")

$entrada = array("rojo", "verde", "azul", "amarillo");
array_splice($entrada, 1, -1);
// $entrada ahora es array("rojo", "amarillo")

$entrada = array("rojo", "verde", "azul", "amarillo");
array_splice($entrada, 1, count($entrada), "naranja");
// $entrada ahora es array("rojo", "naranja")

$entrada = array("rojo", "verde", "azul", "amarillo");
array_splice($entrada, -1, 1, array("negro", "granate"));
// $entrada ahora es array("rojo", "verde",
//          "azul", "negro", "granate")

$entrada = array("rojo", "verde", "azul", "amarillo");
array_splice($entrada, 3, 0, "púpura");
// $entrada ahora es array("rojo", "verde",
//          "azul", "púpura", "amarillo");
?>

Ejemplo #2 Ejemplos de array_splice()

Las siguientes sentencias cambian el valor de $entrada de la misma manera:

<?php
array_push($entrada, $x, $y);
array_splice($entrada, count($entrada), 0, array($x, $y));
array_pop($entrada);
array_splice($entrada, -1);
array_shift($entrada);
array_splice($entrada, 0, 1);
array_unshift($entrada, $x, $y);
array_splice($entrada, 0, 0, array($x, $y));
$entrada[$x] = $y; // para arrays donde la clave es igual al índice
array_splice($entrada, $x, 1, $y);
?>

Ver también

  • array_slice() - Extraer una parte de un array
  • unset() - Destruye una variable especificada
  • array_merge() - Combina dos o más arrays


Calcular la suma de los valores de un array

  • « array_splice
  • array_udiff_assoc »
  • PHP Manual
  • Funciones de Arrays
  • Calcular la suma de los valores de un array

array_sum

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

array_sum — Calcular la suma de los valores de un array

Descripción

array_sum ( array $array ) : number

array_sum() devuelve la suma de los valores de un array.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve la suma de los valores como un valor de tipo integer o float; 0 si el array está vacío.

Ejemplos

Ejemplo #1 Ejemplos de array_sum()

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = " . array_sum($a) . "\n";

$b = array("a" => 1.2, "b" => 2.3, "c" => 3.4);
echo "sum(b) = " . array_sum($b) . "\n";
?>

El resultado del ejemplo sería:

sum(a) = 20
sum(b) = 6.9


Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno

  • « array_sum
  • array_udiff_uassoc »
  • PHP Manual
  • Funciones de Arrays
  • Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno

array_udiff_assoc

(PHP 5, PHP 7, PHP 8)

array_udiff_assoc — Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno

Descripción

array_udiff_assoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno.

Nota: Por favor, observe que esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar dimensiones más profundas usando, por ejemplo, array_udiff_assoc($array1[0], $array2[0], "alguna_func_comparacion");.

Parámetros

array1

El primer array.

array2

El segundo array.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

array_udiff_assoc() devuelve un array que contiene todos los valores de array1 que no están presentes en ninguno de los demás argumentos. Observe que las claves se usan en la comparación a diferencia de array_diff() y array_udiff(). La comparación de la información de los arrays' se lleva a cabo usando una llamada de retorno proporcionada por el usuario. En este aspecto, el comportamiento es opuesto al de array_diff_assoc(), que usa una función interna para la comparación.

Ejemplos

Ejemplo #1 Ejemplo de array_udiff_assoc()

<?php
class cr {
    private $miembro_privado;
    function cr($val)
    {
        $this->miembro_privado = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->miembro_privado === $b->miembro_privado) return 0;
        return ($a->miembro_privado > $b->miembro_privado)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$resultado = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [0.1] => cr Object
        (
            [miembro_privado:private] => 9
        )

    [0.5] => cr Object
        (
            [miembro_privado:private] => 12
        )

    [0] => cr Object
        (
            [miembro_privado:private] => 23
        )
)

En el ejemplo de arriba se ve que el par "1" => new cr(4) está presente en ambos arrays, y que, de esta manera, no está en la salida de la función.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno

  • « array_udiff_assoc
  • array_udiff »
  • PHP Manual
  • Funciones de Arrays
  • Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno

array_udiff_uassoc

(PHP 5, PHP 7, PHP 8)

array_udiff_uassoc — Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno

Descripción

array_udiff_uassoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func , callable $key_compare_func ) : array

Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno.

Observe que las claves son usadas en la comparación, a diferencia de array_diff() y array_udiff().

Parámetros

array1

El primer array.

array2

El segundo array.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
key_compare_func

La comparación de las claves (índices) se hace también mediante la función de llamada de retorno key_compare_func. Este comportamiento es diferente del de array_udiff_assoc(), ya que esta última compara los índices usando una función interna.

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que no están presentes en ningno de los demás argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_udiff_uassoc()

<?php
class cr {
    private $miembro_privado;
    function cr($val)
    {
        $this->miembro_privado = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->miembro_privado === $b->miembro_privado) return 0;
        return ($a->miembro_privado > $b->miembro_privado)? 1:-1;
    }

    static function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$resultado = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"), array("cr", "comp_func_key"));
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [0.1] => cr Object
        (
            [miembro_privado:private] => 9
        )

    [0.5] => cr Object
        (
            [miembro_privado:private] => 12
        )

    [0] => cr Object
        (
            [miembro_privado:private] => 23
        )
)

En el ejemplo de arriba se ve que el par "1" => new cr(4) está presente en ambos arrays, y que, de esta manera, no está en la salida de la función. Recuerde que debe de proporcionar 2 funciones de llamada de retorno.

Notas

Nota: Por favor, observe que esta función sólo comprueba una dimensión de un array n-dimensional. Por supuesto, se pueden comprobar dimensiones más profundas usando, por ejemplo, array_udiff_uassoc($array1[0], $array2[0], "data_compare_func", "key_compare_func");.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_udiff() - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos

  • « array_udiff_uassoc
  • array_uintersect_assoc »
  • PHP Manual
  • Funciones de Arrays
  • Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos

array_udiff

(PHP 5, PHP 7, PHP 8)

array_udiff — Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos

Descripción

array_udiff ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

Computa la diferencia de los arrays usando una función tipo llamada de retorno para la comparación de datos. Esto difiere de array_diff(), la cual usa una función interna para la comparación de datos.

Parámetros

array1

El primer array.

array2

El segundo array

value_compare_func

La función llamada de retorno para la comparación.

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que no están presentes en ninguno de los otros argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_udiff() usando objetos de stdClass

<?php
// Arrays a comparar
$array1 = array(new stdclass, new stdclass,
                new stdclass, new stdclass,
               );

$array2 = array(
                new stdclass, new stdclass,
               );

// Establecer algunas propiedades para cada objeto
$array1[0]->width = 11; $array1[0]->height = 3;
$array1[1]->width = 7;  $array1[1]->height = 1;
$array1[2]->width = 2;  $array1[2]->height = 9;
$array1[3]->width = 5;  $array1[3]->height = 7;

$array2[0]->width = 7;  $array2[0]->height = 5;
$array2[1]->width = 9;  $array2[1]->height = 2;

function compare_by_area($a, $b) {
    $areaA = $a->width * $a->height;
    $areaB = $b->width * $b->height;

    if ($areaA < $areaB) {
        return -1;
    } elseif ($areaA > $areaB) {
        return 1;
    } else {
        return 0;
    }
}

print_r(array_udiff($array1, $array2, 'compare_by_area'));
?>

El resultado del ejemplo sería:

Array
(
    [0] => stdClass Object
        (
            [width] => 11
            [height] => 3
        )

    [1] => stdClass Object
        (
            [width] => 7
            [height] => 1
        )

)

Ejemplo #2 Ejemplo de array_udiff() usando objetos de DateTime

<?php
class MyCalendar {
    public $free = array();
    public $booked = array();

    public function __construct($week = 'now') {
        $start = new DateTime($week);
        $start->modify('Monday this week midnight');
        $end = clone $start;
        $end->modify('Friday this week midnight');
        $interval = new DateInterval('P1D');
        foreach (new DatePeriod($start, $interval, $end) as $freeTime) {
            $this->free[] = $freeTime;
        }
    }

    public function bookAppointment(DateTime $date, $note) {
        $this->booked[] = array('date' => $date->modify('midnight'), 'note' => $note);
    }

    public function checkAvailability() {
        return array_udiff($this->free, $this->booked, array($this, 'customCompare'));
    }

    public function customCompare($free, $booked) {
        if (is_array($free)) $a = $free['date'];
        else $a = $free;
        if (is_array($booked)) $b = $booked['date'];
        else $b = $booked;
        if ($a == $b) {
            return 0;
        } elseif ($a > $b) {
            return 1;
        } else {
            return -1;
        }
    }
}

// Crear un calendario para citas semanales
$myCalendar = new MyCalendar;

// Anotar varias citas para esta semana
$myCalendar->bookAppointment(new DateTime('Monday this week'), "Cleaning GoogleGuy's apartment.");
$myCalendar->bookAppointment(new DateTime('Wednesday this week'), "Going on a snowboarding trip.");
$myCalendar->bookAppointment(new DateTime('Friday this week'), "Fixing buggy code.");

// Comprobar los días disponibles comparando las fechas de $booked con las de $free
echo "I'm available on the following days this week...\n\n";
foreach ($myCalendar->checkAvailability() as $free) {
    echo $free->format('l'), "\n";
}
echo "\n\n";
echo "I'm busy on the following days this week...\n\n";
foreach ($myCalendar->booked as $booked) {
    echo $booked['date']->format('l'), ": ", $booked['note'], "\n";
}
?>

El resultado del ejemplo sería:

I'm available on the following days this week...

Tuesday
Thursday

I'm busy on the following days this week...

Monday: Cleaning GoogleGuy's apartment.
Wednesday: Going on a snowboarding trip.
Friday: Fixing buggy code.

Notas

Nota: Por favor note que esta función sólo analiza una dimensión de un array n-dimensional. Por supuesto, puede analizar dimensiones más profundas usando array_udiff($array1[0], $array2[0], "data_compare_func");.

Ver también

  • array_diff() - Calcula la diferencia entre arrays
  • array_diff_assoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices
  • array_diff_uassoc() - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
  • array_udiff_assoc() - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
  • array_udiff_uassoc() - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada

  • « array_udiff
  • array_uintersect_uassoc »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada

array_uintersect_assoc

(PHP 5, PHP 7, PHP 8)

array_uintersect_assoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada

Descripción

array_uintersect_assoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada.

Observe que las claves se usan en la comparación, a diferencia de array_uintersect(). La información se compara usando una función de retrollamada.

Parámetros

array1

El primer array.

array2

El segundo array.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que están presentes en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_uintersect_assoc()

<?php
$array1 = array("a" => "verde", "b" => "marrón", "c" => "azul", "rojo");
$array2 = array("a" => "VERDE", "B" => "marrón", "amarillo", "rojo");

print_r(array_uintersect_assoc($array1, $array2, "strcasecmp"));
?>

El resultado del ejemplo sería:

Array
(
    [a] => verde
)

Ver también

  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado

  • « array_uintersect_assoc
  • array_uintersect »
  • PHP Manual
  • Funciones de Arrays
  • Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado

array_uintersect_uassoc

(PHP 5, PHP 7, PHP 8)

array_uintersect_uassoc — Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado

Descripción

array_uintersect_uassoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func , callable $key_compare_func ) : array

Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado.

Parámetros

array1

El primer array.

array2

El segundo array.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
key_compare_func

La función de retrollamada de comparación de claves.

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que están presentes en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_uintersect_uassoc()

<?php
$array1 = array("a" => "verde", "b" => "marrón", "c" => "azul", "rojo");
$array2 = array("a" => "VERDE", "B" => "marrón", "amarillo", "rojo");

print_r(array_uintersect_uassoc($array1, $array2, "strcasecmp", "strcasecmp"));
?>

El resultado del ejemplo sería:

Array
(
    [a] => verde
    [b] => marrón
)

Ver también

  • array_uintersect() - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_intersect_uassoc() - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada


Computa una intersección de arrays, compara la información mediante una función de llamada de retorno

  • « array_uintersect_uassoc
  • array_unique »
  • PHP Manual
  • Funciones de Arrays
  • Computa una intersección de arrays, compara la información mediante una función de llamada de retorno

array_uintersect

(PHP 5, PHP 7, PHP 8)

array_uintersect — Computa una intersección de arrays, compara la información mediante una función de llamada de retorno

Descripción

array_uintersect ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

Computa una intersección de arrays, compara la información mediante una función de llamada de retorno.

Parámetros

array1

El primer array.

array2

El segundo array.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Devuelve un array que contiene todos los valores de array1 que están presentes en todos los argumentos.

Ejemplos

Ejemplo #1 Ejemplo de array_uintersect()

<?php
$array1 = array("a" => "verde", "b" => "marrón", "c" => "azul", "rojo");
$array2 = array("a" => "VERDE", "B" => "marrón", "amarillo", "rojo");

print_r(array_uintersect($array1, $array2, "strcasecmp"));
?>

El resultado del ejemplo sería:

Array
(
    [a] => verde
    [b] => marrón
    [0] => rojo
)

Ver también

  • array_intersect() - Calcula la intersección de arrays
  • array_intersect_assoc() - Calcula la intersección de arrays con un chequeo adicional de índices
  • array_uintersect_assoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
  • array_uintersect_uassoc() - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado


Elimina valores duplicados de un array

  • « array_uintersect
  • array_unshift »
  • PHP Manual
  • Funciones de Arrays
  • Elimina valores duplicados de un array

array_unique

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_unique — Elimina valores duplicados de un array

Descripción

array_unique ( array $array , int $sort_flags = SORT_STRING ) : array

Toma un array y devuelve un nuevo array sin valores duplicados.

Tenga en cuenta que las claves se conservan. Si múltiples elementos se comparan bajo el parámetro sort_flags, entonces la clave y el valor del primer elemento igual se conservarán.

Nota: Dos elementos son considerados iguales solo si (string) $elem1 === (string) $elem2, es decir, cuando la representación en formato de string sea la misma, se usará el primer elemento.

Parámetros

array

El array de entrada.

sort_flags

El segundo parámetro opcional sort_flags se puede utilizar para modificar el tipo de orden usando estos valores:

Indicadores de tipos de orden:

  • SORT_REGULAR - compara ítems normalmente (no cambia los tipos)
  • SORT_NUMERIC - compara ítems numéricamente
  • SORT_STRING - compara ítems como strings
  • SORT_LOCALE_STRING - compara ítems como strings, basados en la configuración regional en uso.

Valores devueltos

Devuelve el array filtrado.

Historial de cambios

Versión | Descripción
7.2.0 | Si el parámetro sort_flags es SORT_STRING, el array anterior ha sido copiado y se han eliminado los elementos no únicos (sin empaquetar el array posteriormente), pero ahora se construye un nuevo array añadiendo los elementos únicos. Esto puede dar lugar a diferentes índices numéricos.
5.2.10 | Se volvió a cambiar el valor predeterminado de sort_flags a SORT_STRING.
5.2.9 | Se añadió el parámetro opcional sort_flags con el valor predeterminado SORT_REGULAR. Antes de 5.2.9, esta función se usaba para ordenar el array con SORT_STRING internamente.

Ejemplos

Ejemplo #1 Ejemplo de array_unique()

<?php
$entrada = array("a" => "verde", "rojo", "b" => "verde", "azul", "rojo");
$resultado = array_unique($entrada);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [a] => verde
    [0] => rojo
    [1] => azul
)

Ejemplo #2 array_unique() y tipos

<?php
$entrada = array(4, "4", "3", 4, 3, "3");
$resultado = array_unique($entrada);
var_dump($resultado);
?>

El resultado del ejemplo sería:

array(2) {
  [0] => int(4)
  [2] => string(1) "3"
}

Ver también

  • array_count_values() - Cuenta todos los valores de un array

Notas

Nota: Observe que array_unique() no está pensado para que trabaje con arrays multidimensionales.


Añadir al inicio de un array uno a más elementos

  • « array_unique
  • array_values »
  • PHP Manual
  • Funciones de Arrays
  • Añadir al inicio de un array uno a más elementos

array_unshift

(PHP 4, PHP 5, PHP 7, PHP 8)

array_unshift — Añadir al inicio de un array uno a más elementos

Descripción

array_unshift ( array &$array , mixed $... = ? ) : int

array_unshift() añade los elementos pasados al inicio de array. Observe que la lista de elementos se añade como un todo, por lo que los elementos añadidos permanecen en el mismo orden. Todas las claves numéricas del array serán modificadas empezando a contar desde cero mientras que las claves literales no serán cambiadas.

Parámetros

array

El array de entrada.

...

Los valores a añadir al inicio.

Valores devueltos

Devuelve el nuevo número de elementos del array.

Historial de cambios

Versión | Descripción
7.3.0 | Esta función ahora puede ser llamada con un solo parámetro. Anteriormente, se requerían al menos dos parámetros.

Ejemplos

Ejemplo #1 Ejemplo de array_unshift()

<?php
$cola = array("naranja", "banana");
array_unshift($cola, "manzana", "frambuesa");
print_r($cola);
?>

El resultado del ejemplo sería:

Array
(
    [0] => manzana
    [1] => frambuesa
    [2] => naranja
    [3] => banana
)

Ver también

  • array_shift() - Quita un elemento del principio del array
  • array_push() - Inserta uno o más elementos al final de un array
  • array_pop() - Extrae el último elemento del final del array


Devuelve todos los valores de un array

  • « array_unshift
  • array_walk_recursive »
  • PHP Manual
  • Funciones de Arrays
  • Devuelve todos los valores de un array

array_values

(PHP 4, PHP 5, PHP 7, PHP 8)

array_values — Devuelve todos los valores de un array

Descripción

array_values ( array $array ) : array

array_values() devuelve todos los valores del array array e indexa numéricamente el array.

Parámetros

array

El array.

Valores devueltos

Devuelve un array indexeado de valores.

Ejemplos

Ejemplo #1 Ejemplo de array_values()

<?php
$array = array("size" => "XL", "color" => "gold");
print_r(array_values($array));
?>

El resultado del ejemplo sería:

Array
(
    [0] => XL
    [1] => gold
)

Ver también

  • array_keys() - Devuelve todas las claves de un array o un subconjunto de claves de un array
  • array_combine() - Crea un nuevo array, usando una matriz para las claves y otra para sus valores


Aplicar una función de usuario recursivamente a cada miembro de un array

  • « array_values
  • array_walk »
  • PHP Manual
  • Funciones de Arrays
  • Aplicar una función de usuario recursivamente a cada miembro de un array

array_walk_recursive

(PHP 5, PHP 7, PHP 8)

array_walk_recursive — Aplicar una función de usuario recursivamente a cada miembro de un array

Descripción

array_walk_recursive ( array &$array , callable $callback , mixed $userdata = null ) : bool

Aplica la función definida por el usuario callback a cada elemento del array. Esta función opera de forma recursiva sobre arrays con más niveles.

Parámetros

array

El array de entrada.

callback

Por lo general, callback recibe dos parámetros. El valor del parámetro array es el primero, y la clave/índice es el segundo.

Nota:

Si callback necesita trabajar con los valores reales del array, especifique el primer parámetro de callback como una referencia. Entonces, cualquier cambio realizado sobre esos elementos será efectuado sobre el array original mismo.

userdata

Si se define el parámetro opcional userdata, éste será pasado como el tercer parámetro al callback.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de array_walk_recursive()

<?php
$dulce = array('a' => 'manzana', 'b' => 'banano');
$frutas = array('dulce' => $dulce, 'acido' => 'limón');

function prueba_imprimir($item, $clave)
{
    echo "$clave contiene $item\n";
}

array_walk_recursive($frutas, 'prueba_imprimir');
?>

El resultado del ejemplo sería:

a contiene manzana
b contiene banano
acido contiene limón

Notará que la clave 'dulce' nunca es mostrada. Cualquier clave que contenga un valor array no será pasada a la función.

Ver también

  • array_walk() - Aplicar una función proporcionada por el usuario a cada miembro de un array


Aplicar una función proporcionada por el usuario a cada miembro de un array

  • « array_walk_recursive
  • array »
  • PHP Manual
  • Funciones de Arrays
  • Aplicar una función proporcionada por el usuario a cada miembro de un array

array_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

array_walk — Aplicar una función proporcionada por el usuario a cada miembro de un array

Descripción

array_walk ( array &$array , callable $callback , mixed $userdata = null ) : bool

Aplica la función definida por el usuario dada por callback a cada elemento del array dado por array.

array_walk() no le afecta el puntero de arrays interno de array. array_walk() recorrerá el array completo sin tener en cuenta la posición del puntero.

Parámetros

array

El array de entrada.

callback

Normalmente, callback asume dos parámetros. El primero, los valores de los parámetros de array, y el segundo la clave/índice.

Nota:

Si callback necesita trabajar con los valores reales del array, especifique el primer parámetro de callback como una referencia. Así, cualquier cambio hecho a esos elementos serán hechos al mismo array original.

Nota:

Muchas funciones internas (por ejemplo strtolower()) lanzarán una advertencia si se pasan más argumentos de los esperados y no son utilizables directamente como callback.

Sólo se pueden cambiar potencialmente los valores del parámetro array; no se puede alterar su estructura, esto es, el programador no puede añadir, destruir o reordenar elementos. Si la llamada de retorno no respeta este requisito, el comportamiento de esta función será indefinido e impredecible.

userdata

Si se proporciona el parámetro opcional userdata, éste será pasado como el tercer parámetro de la función dada por callback.

Valores devueltos

Devuelve true.

Errores/Excepciones

A partir de PHP 7.1.0, un ArgumentCountError será lanzado si la función callback requiere más de 2 parámetros (el valor y la clave del miembro del array). Anteriormente, si la función callback requería más de 2 parámetros, se generaba un error de nivel E_WARNING cada vez que array_walk() llamaba a callback.

Ejemplos

Ejemplo #1 Ejemplo de array_walk()

<?php
$frutas = array("d" => "limón", "a" => "naranja", "b" => "banana", "c" => "manzana");

function test_alter(&$elemento1, $clave, $prefijo)
{
    $elemento1 = "$prefijo: $elemento1";
}

function test_print($elemento2, $clave)
{
    echo "$clave. $elemento2<br />\n";
}

echo "Antes ...:\n";
array_walk($frutas, 'test_print');

array_walk($frutas, 'test_alter', 'fruta');
echo "... y después:\n";

array_walk($frutas, 'test_print');
?>

El resultado del ejemplo sería:

Antes ...:
d. limón
a. naranja
b. banana
c. manzana
... y después:
d. fruta: limón
a. fruta: naranja
b. fruta: banana
c. fruta: manzana

Ver también

  • array_walk_recursive() - Aplicar una función de usuario recursivamente a cada miembro de un array
  • iterator_apply() - Llamar a una función para cada elemento de un iterador
  • list() - Asignar variables como si fueran un array
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros
  • array_map() - Aplica la retrollamada a los elementos de los arrays dados
  • foreach


Crea un array

  • « array_walk
  • arsort »
  • PHP Manual
  • Funciones de Arrays
  • Crea un array

array

(PHP 4, PHP 5, PHP 7, PHP 8)

array — Crea un array

Descripción

array ( mixed $... = ? ) : array

Crea un array. Leer la sección el tipo array para más información sobre que es un array.

Parámetros

...

Sintaxis "índice => valores", separados por comas, define índice y valores. El índice puede ser de tipo cadena o numérico. Cuando se omite el índice, se genera un índice numérico automáticamente, empezando por 0. Si el índice es numérico, el siguiente índice generado será el número del índice mayor +1. Nótese que cuando se crean dos índices idénticos, el último sobrescribe el primero.

Tener una coma al final de la última entrada definida en el array, aunque no es usual, sigue siendo sintaxis válida.

Valores devueltos

Devuelve un array de parámetros. Los parámetros puede ser devolver un índice con el operador =>. Leer la sección en El tipo array para más información en que es un array.

Ejemplos

El siguiente ejemplo demuestra como crear un array de dos dimensiones, como especificar claves para un array asociativo y como omitir y continuar índices numéricos en array normales.

Ejemplo #1 Ejemplo de array()

<?php
$fruits = array (
    "frutas"  => array("a" => "naranja", "b" => "plátano", "c" => "manzana"),
    "números" => array(1, 2, 3, 4, 5, 6),
    "hoyos"   => array("primero", 5 => "segundo", "tercero")
);
?>

Ejemplo #2 Array() con índice automático

<?php
$array = array(1, 1, 1, 1,  1, 8 => 1,  4 => 1, 19, 3 => 13);
print_r($array);
?>

El resultado del ejemplo sería:

Array
(
    [0] => 1
    [1] => 1
    [2] => 1
    [3] => 13
    [4] => 1
    [8] => 1
    [9] => 19
)

Nótese que el índice '3' se ha definido en dos ocasiones y mantiene su valor final de 13. El índice 4 se ha definido después del índice 8 y el siguiente índice generado (valor 19) es 9, ya que el índice mayor era 8.

Este ejemplo crea un array de base 1.

Ejemplo #3 array() con índice de base 1

<?php
$firstquarter = array(1 => 'Enero', 'Febrero', 'Marzo');
print_r($firstquarter);
?>

El resultado del ejemplo sería:

Array
(
    [1] => Enero
    [2] => Febrero
    [3] => Marzo
)

Como en perl, se puede acceder al valor del array dentro de comillas dobles. Sin embargo, con PHP se necesita adjuntar el array enter claves.

Ejemplo #4 Accessing an array inside double quotes

<?php

$foo = array('bar' => 'baz');
echo "Hola {$foo['bar']}!"; // Hola baz!

?>

Notas

Nota:

array() es un constructor de lenguaje para representar arrays y no es una función.

Ver también

  • array_pad() - Rellena un array a la longitud especificada con un valor
  • list() - Asignar variables como si fueran un array
  • count() - Cuenta todos los elementos de un array o algo de un objeto
  • range() - Crear un array que contiene un rango de elementos
  • foreach
  • El tipo array


Ordena un array en orden inverso y mantiene la asociación de índices

  • « array
  • asort »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array en orden inverso y mantiene la asociación de índices

arsort

(PHP 4, PHP 5, PHP 7, PHP 8)

arsort — Ordena un array en orden inverso y mantiene la asociación de índices

Descripción

arsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Esta función ordena un array de manera que los índices del array mantienen su correlación con los elementos del array asociados.

Es usado principalmente cuando se ordenan arrays asociativos cuando el orden de los elementos es importante.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

sort_flags

Se puede modificar el comportamiento del ordenado usando el parámetro opcional sort_flags, par más información vea sort().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de arsort()

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
arsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

a = orange
d = lemon
b = banana
c = apple

Las frutas han sido ordenadas en orden inverso alfabético, se ha mantenido el índice asocidado con cada elemento.

Ver también

  • asort() - Ordena un array y mantiene la asociación de índices
  • comparación de funciones de orden de arrays


Ordena un array y mantiene la asociación de índices

  • « arsort
  • compact »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array y mantiene la asociación de índices

asort

(PHP 4, PHP 5, PHP 7, PHP 8)

asort — Ordena un array y mantiene la asociación de índices

Descripción

asort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Esta función ordena un array manteniendo la correlación de los índices del array con los elementos con los que están asociados. Esta función se utiliza principalmente para ordenar arrays asociativos en los que el orden es importante.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

sort_flags

Quizá se necesita cambiar el comportamiento del ordenado usando este parámetro opcional sort_flags, para más información ver sort().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de la función asort()

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
asort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

c = apple
b = banana
d = lemon
a = orange

Las frutas han sido ordenadas alfabeticamente, y se ha mantenido el índice asociado con cada elemento.

Ver también

  • arsort() - Ordena un array en orden inverso y mantiene la asociación de índices
  • comparación de funciones de orden de arrays


Crear un array que contiene variables y sus valores

  • « asort
  • count »
  • PHP Manual
  • Funciones de Arrays
  • Crear un array que contiene variables y sus valores

compact

(PHP 4, PHP 5, PHP 7, PHP 8)

compact — Crear un array que contiene variables y sus valores

Descripción

compact ( mixed $varname1 , mixed $... = ? ) : array

Crea un array que contiene variables y sus valores.

Por cada variable, compact() busca una variable con ese nombre en la tabla de símbolos actual y las añade al array de salida de modo que el nombre de la variable se convierte en la clave y el contenido de la variable se convierte en el valor para esa clave. En pocas palabras, hace lo contrario que extract().

Nota:

Antes de PHP 7.3, cualquier cadena que no esté establecida se omitirá silenciosamente.

Parámetros

varname1

compact() toma un número variable de parámetros. Cada parámetro puede ser una cadena que contiene el nombre de la variable, o un array de nombres de variables. El array puede contener otros arrays de nombres de variables dentro de él; compact() los trata recursivamente.

Valores devueltos

Devuelve un array de salida con todas las variables añadidas a él.

Ejemplos

Ejemplo #1 Ejemplo de compact()

<?php
$ciudad  = "San Francisco";
$estado = "CA";
$evento = "SIGGRAPH";

$vars_región = array("ciudad", "estado");

$resultado = compact("evento", "nada_aquí", $vars_región);
print_r($resultado);
?>

El resultado del ejemplo sería:

Array
(
    [evento] => SIGGRAPH
    [ciudad] => San Francisco
    [estado] => CA
)

Notas

Nota: A tener en consideración

Ya que las variables variables no se pueden usar con Arrays Superglobales de PHP dentro de funciones, los arrays Superglobales no pueden ser pasados a compact().

Ver también

  • extract() - Importar variables a la tabla de símbolos actual desde un array


Cuenta todos los elementos de un array o algo de un objeto

  • « compact
  • current »
  • PHP Manual
  • Funciones de Arrays
  • Cuenta todos los elementos de un array o algo de un objeto

count

(PHP 4, PHP 5, PHP 7, PHP 8)

count — Cuenta todos los elementos de un array o algo de un objeto

Descripción

count ( mixed $array_or_countable , int $mode = COUNT_NORMAL ) : int

Cuenta todos los elementos en un array o algo de un objeto.

En objetos, si se tiene SPL instalado, se puede enganchar a count() implementado la interfaz Countable. Esta interfaz tiene solamente un método, Countable::count(), el cual devuelve el valor retornado por la función count().

Véase la sección Array del manual para una explicación detallada sobre cómo se implementan y usan los arrays en PHP.

Parámetros

array_or_countable

Un array o un objeto Countable.

mode

Si el parámetro opcional mode está establecido a COUNT_RECURSIVE (o 1), count() contará el array de forma recursiva. Esto es particularmente útil para contar todos los elementos de un array multidimensional.

Precaución

count() puede detectar recursividad para evitar un bucle infinito, pero emitirá un mensaje E_WARNING cada vez que lo haga (en caso de que el array se contenga a sí mismo más de una vez) y devolverá una cuenta mayor de la que se podría esperar.

Valores devueltos

Devuelve el número de elementos en array_or_countable, Cuando el parámetro no es un array ni un objecto con la interfaz Countable implementada, devolverá 1. Existe una excepción, si array_or_countable es null, devolverá 0.

Ejemplos

Ejemplo #1 Ejemplo de count()

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
var_dump(count($a));

$b[0]  = 7;
$b[5]  = 9;
$b[10] = 11;
var_dump(count($b));

var_dump(count(null));

var_dump(count(false));
?>

El resultado del ejemplo sería:

int(3)
int(3)

Warning: count(): Parameter must be an array or an object that implements Countable in … on line 12 // as of PHP 7.2
int(0)

Warning: count(): Parameter must be an array or an object that implements Countable in … on line 14 // as of PHP 7.2
int(1)

Ejemplo #2 Ejemplo de count() recursivo

<?php
$comida = array('frutas' => array('naranja', 'plátano', 'manzana'),
                'verduras' => array('zanahoria', 'col', 'guisante'));

// Cuenta recursiva
echo count($comida, COUNT_RECURSIVE); // muestra 8

// Cuenta normal
echo count($comida); // muestra 2

?>

Historial de cambios

Versión | Descripción
7.2.0 | count() generará una advertencia si se pasan tipos contables no válido al parámetro array_or_countable.

Ver también

  • is_array() - Comprueba si una variable es un array
  • isset() - Determina si una variable está definida y no es null
  • empty() - Determina si una variable está vacía
  • strlen() - Obtiene la longitud de un string
  • is_countable() - Verifica que el contenido de una variable es un valor contable


Devuelve el elemento actual en un array

  • « count
  • each »
  • PHP Manual
  • Funciones de Arrays
  • Devuelve el elemento actual en un array

current

(PHP 4, PHP 5, PHP 7, PHP 8)

current — Devuelve el elemento actual en un array

Descripción

current ( array|object $array ) : mixed

Cada array tiene un puntero interno a su elemento "actual", que es iniciado desde el primer elemento insertado en el array.

Parámetros

array

El array.

Valores devueltos

La función current() simplemente devuelve el valor del elemento del array que está siendo apuntado por el puntero interno. No desplaza el puntero de ninguna manera. Si el puntero interno apunta más allá del final de la lista de elementos o el array está vacío, current() devolverá false.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Historial de cambios

Versión | Descripción
7.0.0 | array ahora siempre se pasa por el valor. Antes de esta versión, se pasaba por referencia si era posible, y por el valor de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de uso de current() y similares

<?php
$transport = array('pie', 'bici', 'coche', 'avión');
$mode = current($transport); // $mode = 'pie';
$mode = next($transport);    // $mode = 'bici';
$mode = current($transport); // $mode = 'bici';
$mode = prev($transport);    // $mode = 'pie';
$mode = end($transport);     // $mode = 'avión';
$mode = current($transport); // $mode = 'avión';

$arr = array();
var_dump(current($arr)); // bool(false)

$arr = array(array());
var_dump(current($arr)); // array(0) { }
?>

Notas

Nota: The results of calling current() on an empty array and on an array, whose internal pointer points beyond the end of the elements, are indistinguishable from a bool false element. To properly traverse an array which may contain false elements, see the foreach() function. Los resultados al llamar current() en un array vacío y en un array, cuyo puntero interno apunta más allá del final de los elementos, son indistinguibles de un elemento de tipo bool false. Para recorrer adecuadamente un array que puede contener elementos false, ver la función foreach().

Ver también

  • end() - Establece el puntero interno de un array a su último elemento
  • key() - Obtiene una clave de un array
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • prev() - Rebobina el puntero interno del array
  • reset() - Establece el puntero interno de un array a su primer elemento
  • next() - Avanza el puntero interno de un array


Devolver el par clave/valor actual de un array y avanzar el cursor del array

  • « current
  • end »
  • PHP Manual
  • Funciones de Arrays
  • Devolver el par clave/valor actual de un array y avanzar el cursor del array

each

(PHP 4, PHP 5, PHP 7)

each — Devolver el par clave/valor actual de un array y avanzar el cursor del array

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Descripción

each ( array &$array ) : array

Devuelve el par clave/valor actual de un array y avanza el cursor del array.

Después de que each() haya sido ejecutado, el cursor del array será puesto en el siguiente elemento del array, o pasado el último elemento si alcanza el final del array. Se tiene que usar reset() si se quiere atravesar de nuevo el array usando each.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve el par clave/valor actual del array dado por array. Este par es devuelto en un array de cuatro elementos, con las claves 0, 1, key, y value. Los elementos 0 y key contienen el nombre de la clave del elemento del array, y 1 y value contienen la información.

Si el puntero interno del array apunta al final del contenido de array, each() devuelve false.

Ejemplos

Ejemplo #1 Ejemplo de each()

<?php
$foo = array("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each($foo);
print_r($bar);
?>

$bar ahora contienelos siguientes pares clave/valor:

Array
(
    [1] => bob
    [value] => bob
    [0] => 0
    [key] => 0
)

<?php
$foo = array("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each($foo);
print_r($bar);
?>

$bar ahora contienelos siguientes pares clave/valor:

Array
(
    [1] => Bob
    [value] => Bob
    [0] => Robert
    [key] => Robert
)

each() se usa normalmente junto con list() para atravesar un array. Aquí hay un ejemplo:

Ejemplo #2 Atravesar un array con each()

<?php
$fruta = array('a' => 'manzana', 'b' => 'banana', 'c' => 'arándano');

reset($fruta);
while (list($clave, $valor) = each($fruta)) {
    echo "$clave => $valor\n";
}
?>

El resultado del ejemplo sería:

a => manzana
b => banana
c => arándano

Precaución

Ya que asignar un array a otra variable reinicia el puntero del array original (nuestro ejemplo de arriba causaría un bucle sin fin), hemos asignado $fruta a otra variable dentro del bucle.

Advertencia

each() también aceptará objetos, pero puede devolver resultados inesperados. Por lo tanto, no se recomienda iterar propiedades de objetos con each().

Ver también

  • key() - Obtiene una clave de un array
  • list() - Asignar variables como si fueran un array
  • current() - Devuelve el elemento actual en un array
  • reset() - Establece el puntero interno de un array a su primer elemento
  • next() - Avanza el puntero interno de un array
  • prev() - Rebobina el puntero interno del array
  • foreach
  • Iteración de Objetos


Establece el puntero interno de un array a su último elemento

  • « each
  • extract »
  • PHP Manual
  • Funciones de Arrays
  • Establece el puntero interno de un array a su último elemento

end

(PHP 4, PHP 5, PHP 7, PHP 8)

end — Establece el puntero interno de un array a su último elemento

Descripción

end ( array &$array ) : mixed

end() avanza el puntero interno del array hasta su último elemento y devuelve su valor.

Parámetros

array

El array. Este array es pasado por referencia porque es modificado por la función. Esto significa que se debe pasar una variable real y no una función que devuelve un array porque solamente variables puede ser pasadas por referencia.

Valores devueltos

Devuelve el valor del último elemento o false si el array está vacío.

Ejemplos

Ejemplo #1 Ejemplo de end()

<?php

$fruits = array('manzana', 'plátano', 'arándano');
echo end($fruits); // arándano

?>

Ver también

  • current() - Devuelve el elemento actual en un array
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • prev() - Rebobina el puntero interno del array
  • reset() - Establece el puntero interno de un array a su primer elemento
  • next() - Avanza el puntero interno de un array
  • array_key_last() - Obtiene la última clave de un array


Importar variables a la tabla de símbolos actual desde un array

  • « end
  • in_array »
  • PHP Manual
  • Funciones de Arrays
  • Importar variables a la tabla de símbolos actual desde un array

extract

(PHP 4, PHP 5, PHP 7, PHP 8)

extract — Importar variables a la tabla de símbolos actual desde un array

Descripción

extract ( array &$array , int $flags = EXTR_OVERWRITE , string $prefix = null ) : int

Importa variables desde un array a la tabla de símbolos actual.

Comprueba cada clave para ver si tiene un nombre de variable válido. También comprueba las colisiones con las variables existentes en la tabla de símbolos.

Advertencia

No use extract() sobre datos no confiables, como la entrada del usuario (p.e. $_GET, $_FILES).

Parámetros

array

Un array asociativo. Esta función trata a las claves como nombres de variables y a los valores como valores de variables. Por cada par clave/valor creará una variable en la tabla de símbolos actual, sujeta a los parámetros flags y prefix.

Se debe usar un array asociativo; un array indexado numéricamente no producirá resultados a menos que se use EXTR_PREFIX_ALL o EXTR_PREFIX_INVALID.

flags

La manera en que las claves no-válidas/numéricas y las colisiones son tratadas está determinda por el parámetro flags. Puede ser uno de los valores siguientes:

EXTR_OVERWRITE
Si hay una colisión, sobrescribe la variable existente.
EXTR_SKIP
Si hay una colisión, no sobrescribe la variable existente.
EXTR_PREFIX_SAME
Si hay una colisión, prefija el nombre de la variable con prefix.
EXTR_PREFIX_ALL
Prefija todos los nombres de variables con prefix.
EXTR_PREFIX_INVALID
Sólo prefija los nombres de variables no-válidas/numéricas con prefix.
EXTR_IF_EXISTS
Sobrescribe la variable sólo si ya existe en la tabla de símbolos actual, de otro modo no hace nada. Esto es útil para definir una lista de variables válidas y después extraer sólo aquellas variables que se definieron fuera de $_REQUEST, por ejemplo.
EXTR_PREFIX_IF_EXISTS
Crea nombres de variables con prefijo sólo si la versión no prefijada de la misma variable existe en la tabla de símbolos actual.
EXTR_REFS
Extrae las variables como referencias. Esto significa que los valores de las variables importadas están todavía referenciados por los valores del parámetro array. Se puede usar esta bandera por sí misma o combinarla con cualquier otra bandera usando el operador OR en flags.

Si no se especifica flags, se asume que es EXTR_OVERWRITE.

prefix

Observe que prefix sólo es requerido si flags es EXTR_PREFIX_SAME, EXTR_PREFIX_ALL, EXTR_PREFIX_INVALID o EXTR_PREFIX_IF_EXISTS. Si el resultado prefijado no es un nombre de variable válido, ésta no es importada a la tabla de símbolos actual. Los prefijos son separados de las claves del array mediante un caracter de subrayado.

Valores devueltos

Devuelve el número de variables importadas con éxito a la tabla de símbolos.

Ejemplos

Ejemplo #1 Ejemplo de extract()

Un posible uso de extract() es importar a la tabla de símbolos las variables contenidas en un array asociativo devuelto por wddx_deserialize().

<?php

/* Se supone que $var_array es un array devuelto desde
   wddx_deserialize */

$tamaño = "grande";
$var_array = array("color" => "azul",
                   "tamaño"  => "medio",
                   "forma" => "esfera");
extract($var_array, EXTR_PREFIX_SAME, "wddx");

echo "$color, $tamaño, $forma, $wddx_tamaño\n";

?>

El resultado del ejemplo sería:

azul, grande, esfera, medio

El $tamaño no se ha sobrescrito ya que se especificó EXTR_PREFIX_SAME, lo que resulta en la creación de $wddx_tamaño. Si se hubiera especificado EXTR_SKIP, $wddx_tamaño no se habría creado. EXTR_OVERWRITE causaría que $tamaño tuviera el valor "medio", y EXTR_PREFIX_ALL resultaría en variables nuevas llamadas $wddx_color, $wddx_tamaño, y $wddx_forma.

Notas

Advertencia

No use extract() en datos que no son de confianza, como las entradas de usuario (esto es, $_GET, $_FILES, etc.). Si lo hace, asegúrese de usar uno de los valores de flags que no sobrescriban, como EXTR_SKIP, y sepa que debería realizar la extracción en el mismo orden que fue definido en variables_order dentro de php.ini.

Ver también

  • compact() - Crear un array que contiene variables y sus valores
  • list() - Asignar variables como si fueran un array


Comprueba si un valor existe en un array

  • « extract
  • key_exists »
  • PHP Manual
  • Funciones de Arrays
  • Comprueba si un valor existe en un array

in_array

(PHP 4, PHP 5, PHP 7, PHP 8)

in_array — Comprueba si un valor existe en un array

Descripción

in_array ( mixed $needle , array $haystack , bool $strict = false ) : bool

Busca la aguja (needle) en el pajar (haystack) usando una comparación flexible a menos que esté establecido strict.

Parámetros

needle

El valor a buscar.

Nota:

Si needle es un string, la comparación se realiza considerando las mayúsculas/minúsculas.

haystack

El array.

strict

Si el tercer parámetro strict está establecido a true, la función in_array() también comprobará los tipos de needle en haystack.

Valores devueltos

Devuelve true si needle se encuentra en el array, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de in_array()

<?php
$os = array("Mac", "NT", "Irix", "Linux");
if (in_array("Irix", $os)) {
    echo "Existe Irix";
}
if (in_array("mac", $os)) {
    echo "Existe mac";
}
?>

La segunda condición falla porque in_array() considera las mayúsculas-minúsculas, así que el programa anterior mostrará:

Existe Irix

Ejemplo #2 Ejemplo de in_array() en modo estricto

<?php
$a = array('1.10', 12.4, 1.13);

if (in_array('12.4', $a, true)) {
    echo "Se encontró '12.4' con comprobación estricta\n";
}

if (in_array(1.13, $a, true)) {
    echo "Se encontró 1.13 con comprobación estricta\n";
}
?>

El resultado del ejemplo sería:

Se encontró 1.13 con comprobación estricta

Ejemplo #3 in_array() con un array como aguja

<?php
$a = array(array('p', 'h'), array('p', 'r'), 'o');

if (in_array(array('p', 'h'), $a)) {
    echo "Se encontró 'ph'\n";
}

if (in_array(array('f', 'i'), $a)) {
    echo "Se encontró 'fi'\n";
}

if (in_array('o', $a)) {
    echo "Se encontró 'o'\n";
}
?>

El resultado del ejemplo sería:

  Se encontró 'ph'
  Se encontró 'o'

Ver también

  • array_search() - Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito
  • isset() - Determina si una variable está definida y no es null
  • array_key_exists() - Verifica si el índice o clave dada existe en el array


Alias de array_key_exists

  • « in_array
  • key »
  • PHP Manual
  • Funciones de Arrays
  • Alias de array_key_exists

key_exists

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

key_exists — Alias de array_key_exists()

Descripción

Esta función es un alias de: array_key_exists().


Obtiene una clave de un array

  • « key_exists
  • krsort »
  • PHP Manual
  • Funciones de Arrays
  • Obtiene una clave de un array

key

(PHP 4, PHP 5, PHP 7, PHP 8)

key — Obtiene una clave de un array

Descripción

key ( array $array ) : mixed

key() devuelve el elemento índice de la posición actual del array.

Parámetros

array

El array.

Valores devueltos

La función key() simplemente devuelve la clave del elemento del array que está apuntando actualmente el puntero interno. No desplaza el puntero de ninguna manera. Si el puntero interno señala más allá del final de la lista de elementos o el array está vacío, key() devuelve null.

Historial de cambios

Versión | Descripción
7.0.0 | array ahora siempre se pasa por el valor. Antes de esta versión, se pasaba por referencia si era posible, y por el valor de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de key()

<?php
$array = array(
    'fruta1' => 'manzana',
    'fruta2' => 'naranja',
    'fruta3' => 'uva',
    'fruta4' => 'manzana',
    'fruta5' => 'manzana');

// Este ciclo muestra todas las claves del array asociativo
// donde el valor equivale a "manzana"
while ($nombre_fruta = current($array)) {
    if ($nombre_fruta == 'manzana') {
        echo key($array).'<br />';
    }
    next($array);
}
?>

El resultado del ejemplo sería:

fruta1<br />
fruta4<br />
fruta5<br />

Ver también

  • current() - Devuelve el elemento actual en un array
  • next() - Avanza el puntero interno de un array
  • foreach


Ordena un array por clave en orden inverso

  • « key
  • ksort »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array por clave en orden inverso

krsort

(PHP 4, PHP 5, PHP 7, PHP 8)

krsort — Ordena un array por clave en orden inverso

Descripción

krsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Ordena un array por clave en orden inverso, manteniendo la correlación entre la clave y los datos. Esto es útil principalmente para arrays asociativos.

Parámetros

array

El array de entrada.

sort_flags

Se puede modificar el comportamiento del ordenado usando el parámetro opcional sort_flags, par más información vea sort().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de krsort()

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

d = lemon
c = apple
b = banana
a = orange

Ver también

  • arsort() - Ordena un array en orden inverso y mantiene la asociación de índices
  • ksort() - Ordena un array por clave
  • comparación de funciones de orden de arrays


Ordena un array por clave

  • « krsort
  • list »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array por clave

ksort

(PHP 4, PHP 5, PHP 7, PHP 8)

ksort — Ordena un array por clave

Descripción

ksort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Ordena un array por clave, manteniendo la correlación entre la clave y los datos. Esto es útil principalmente para arrays asociativos.

Parámetros

array

El array de entrada.

sort_flags

Se puede modificar el comportamiento del ordenado usando el parámetro opcional sort_flags, par más información vea sort().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ksort()

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

a = orange
b = banana
c = apple
d = lemon

Ver también

  • asort() - Ordena un array y mantiene la asociación de índices
  • comparación de funciones de orden de arrays


Asignar variables como si fueran un array

  • « ksort
  • natcasesort »
  • PHP Manual
  • Funciones de Arrays
  • Asignar variables como si fueran un array

list

(PHP 4, PHP 5, PHP 7, PHP 8)

list — Asignar variables como si fueran un array

Descripción

list ( mixed $var1 , mixed ...$... = ? ) : array

Al igual que array(), no es realmente una función, es un constructor del lenguaje. list() se utiliza para asignar una lista de variables en una sola operación.

Nota:

list() solo funciona con arrays numéricos y supone que los índices numéricos empiezan en 0.

Advertencia

En PHP 5, list() asigna los valores empezando desde el parámetro más a la derecha. En PHP 7, list() empieza desde el parámetro más a la izquierda.

Si se emplean variables simples, esto no debería ser un problema. Pero se en emplean arrays con índices, normalmente se espera que el orden de los índices sea el mismo que el escrito en list(), de izquierda a derecha, no siendo este el caso en PHP 5, ya que se asignan en orden inverso.

En términos generales, se aconseja evitar depender de un orden específico de operación debido a que este podría cambiar de nuevo en el futuro.

Advertencia

La modificación del array durante la ejecución de list() (p.ej. usando list($a, $b) = $b) resultará en un comportamiento indefinido.

Parámetros

var1

Una variable.

Valores devueltos

Devuelve el array asignado.

Historial de cambios

Versión | Descripción
7.0.0 | El orden en el que se realizan las operaciones de asignación ha cambiado.
7.0.0 | Las expresiones de list() ya no pueden estar completamente vacías.
7.0.0 | Los strings ya no pueden ser desempaquetados.

Ejemplos

Ejemplo #1 Ejemplos de list()

<?php

$info = array('café', 'marrón', 'cafeína');

// Enumerar todas las variables
list($bebida, $color, $energía) = $info;
echo "El $bebida es $color y la $energía lo hace especial.\n";

// Enumerar algunas de ellas
list($bebida, , $energía) = $info;
echo "El $bebida tiene $energía.\n";

// U omitir solo la tercera
list( , , $energía) = $info;
echo "Necesito $energía!\n";

// list() no funciona con cadenas
list($bar) = "abcde";
var_dump($bar); // NULL
?>

Ejemplo #2 Un ejemplo del uso de list()

<table>
 <tr>
  <th>Nombre del empleado</th>
  <th>Salario</th>
 </tr>

<?php

$resultado = $pdo->query("SELECT id, nombre, salario FROM empleados");
while (list($id, $nombre, $salario) = $resultado->fetch(PDO::FETCH_NUM)) {
    echo " <tr>\n" .
          "  <td><a href=\"info.php?id=$id\">$nombre</a></td>\n" .
          "  <td>$salario</td>\n" .
          " </tr>\n";
}

?>

</table>

Ejemplo #3 Empleo de list() anidados

<?php

list($a, list($b, $c)) = array(1, array(2, 3));

var_dump($a, $b, $c);

?>
int(1)
int(2)
int(3)

Ejemplo #4 Uso de list() con índices de array

<?php

$info = array('café', 'marrón', 'cafeína');

list($a[0], $a[1], $a[2]) = $info;

var_dump($a);

?>

Muestra la siguiente salida (nótese el orden de los elementos comparado con el orden escrito en la sintaxis de list()):

array(3) {
  [2]=>
  string(8) "cafeína"
  [1]=>
  string(7) "marrón"
  [0]=>
  string(5) "café"
}

Ejemplo #5 list() y orden de definiciones de índices

El orden en el que están definidos los índices de los arrays que consume list() es irrelevante.

<?php
$foo = array(2 => 'a', 'foo' => 'b', 0 => 'c');
$foo[1] = 'd';
list($x, $y, $z) = $foo;
var_dump($foo, $x, $y, $z);

Da el siguiente resultado (observe el orden de los elementos comparado con el orden en el que están escritos en la sintaxis de list()):

array(4) {
  [2]=>
  string(1) "a"
  ["foo"]=>
  string(1) "b"
  [0]=>
  string(1) "c"
  [1]=>
  string(1) "d"
}
string(1) "c"
string(1) "d"
string(1) "a"

Ver también

  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • array() - Crea un array
  • extract() - Importar variables a la tabla de símbolos actual desde un array


Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas

  • « list
  • natsort »
  • PHP Manual
  • Funciones de Arrays
  • Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas

natcasesort

(PHP 4, PHP 5, PHP 7, PHP 8)

natcasesort — Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas

Descripción

natcasesort ( array &$array ) : bool

natcasesort() es la versión insensible a mayúsculas-minúsculas de natsort().

Esta función implementa un algoritmo de ordenación que ordena las cadenas alfanuméricas en la manera en que lo haría un humano mientras mantiene las asociaciones de clave/valor. Es descrito como "ordenación natural".

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de natcasesort()

<?php
$array1 = $array2 = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png', 'img1.png', 'IMG3.png');

sort($array1);
echo "Ordenación estándar\n";
print_r($array1);

natcasesort($array2);
echo "\nOrdenación de orden natural (insensible a maý-mín)\n";
print_r($array2);
?>

El resultado del ejemplo sería:

Ordenación estándar
Array
(
    [0] => IMG0.png
    [1] => IMG3.png
    [2] => img1.png
    [3] => img10.png
    [4] => img12.png
    [5] => img2.png
)

Ordenación de orden natural (insensible a maý-mín)
Array
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

Para más información véase: la página de Martin Pool » Natural Order String Comparison.

Ver también

  • natsort() - Ordena un array usando un algoritmo de "orden natural"
  • comparación de funciones de orden de arrays
  • strnatcmp() - Comparación de strings utilizando un algoritmo de "orden natural"
  • strnatcasecmp() - Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"


Ordena un array usando un algoritmo de "orden natural"

  • « natcasesort
  • next »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array usando un algoritmo de "orden natural"

natsort

(PHP 4, PHP 5, PHP 7, PHP 8)

natsort — Ordena un array usando un algoritmo de "orden natural"

Descripción

natsort ( array &$array ) : bool

Esta función implementa un algoritmo de ordenación que ordena las cadenas alfanuméricas en la manera en que lo haría un humano mientras mantiene las asociaciones de clave/valor. Es descrito como "ordenación natural". Un ejemplo de la diferencia entre este algoritmo y los algoritmos de ordenación normales de computadora (usados en sort()) se puede ver en el ejemplo de abajo.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.2.10 | Las cadenas numéricas rellenadas con ceros (p.ej., '00005') ahora ignoran el relleno de 0.

Ejemplos

Ejemplo #1 Ejemplos de natsort() demostrando su uso básico

<?php
$array1 = $array2 = array("img12.png", "img10.png", "img2.png", "img1.png");

asort($array1);
echo "Ordenación estándar\n";
print_r($array1);

natsort($array2);
echo "\nOrdenación de orden natural\n";
print_r($array2);
?>

El resultado del ejemplo sería:

Ordenación estándar
Array
(
    [3] => img1.png
    [1] => img10.png
    [0] => img12.png
    [2] => img2.png
)

Ordenación de orden natural
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

Para más información véase: la página de Martin Pool » Natural Order String Comparison.

Ejemplo #2 Ejemplos de natsort() demostrando trampas potenciales

<?php
echo "Números negativos\n";
$negativo = array('-5','3','-2','0','-1000','9','1');
print_r($negativo);
natsort($negativo);
print_r($negativo);

echo "Relleno de ceros\n";
$ceros = array('09', '8', '10', '009', '011', '0');
print_r($ceros);
natsort($ceros);
print_r($ceros);
?>

El resultado del ejemplo sería:

Números negativos
Array
(
    [0] => -5
    [1] => 3
    [2] => -2
    [3] => 0
    [4] => -1000
    [5] => 9
    [6] => 1
)
Array
(
    [2] => -2
    [0] => -5
    [4] => -1000
    [3] => 0
    [6] => 1
    [1] => 3
    [5] => 9
)

Relleno de ceros
Array
(
    [0] => 09
    [1] => 8
    [2] => 10
    [3] => 009
    [4] => 011
    [5] => 0
)
Array
(
    [5] => 0
    [1] => 8
    [3] => 009
    [0] => 09
    [2] => 10
    [4] => 011
)

Ver también

  • natcasesort() - Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas
  • comparación de funciones de orden de arrays
  • strnatcmp() - Comparación de strings utilizando un algoritmo de "orden natural"
  • strnatcasecmp() - Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"


Avanza el puntero interno de un array

  • « natsort
  • pos »
  • PHP Manual
  • Funciones de Arrays
  • Avanza el puntero interno de un array

next

(PHP 4, PHP 5, PHP 7, PHP 8)

next — Avanza el puntero interno de un array

Descripción

next ( array &$array ) : mixed

next() se comporta como current(), con una diferencia. Avanza el puntero interno un lugar a delante antes de devolver el valor del elemento. Esto significa que devuelve el siguiente valor del array y avanza el puntero interno del array un lugar.

Parámetros

array

El array afectado.

Valores devueltos

Devuelve el valor del array en el siguiente lugar que está apuntado por el puntero interno o false si no hay más elementos.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Ejemplo del uso de next() y similares

<?php
$transport = array('pie', 'bici', 'coche', 'avión');
$mode = current($transport); // $mode = 'pie';
$mode = next($transport);    // $mode = 'bici';
$mode = next($transport);    // $mode = 'coche';
$mode = prev($transport);    // $mode = 'bici';
$mode = end($transport);     // $mode = 'avión';
?>

Notas

Nota: No hay manera de distinguir el inicio de un array de un elemento de tipo false boolean. Para recorrer adecuadamente que puede contener elementos false ver la función each().

Ver también

  • current() - Devuelve el elemento actual en un array
  • end() - Establece el puntero interno de un array a su último elemento
  • prev() - Rebobina el puntero interno del array
  • reset() - Establece el puntero interno de un array a su primer elemento
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array


Alias de current

  • « next
  • prev »
  • PHP Manual
  • Funciones de Arrays
  • Alias de current

pos

(PHP 4, PHP 5, PHP 7, PHP 8)

pos — Alias de current()

Descripción

Esta función es un alias de: current()


Rebobina el puntero interno del array

  • « pos
  • range »
  • PHP Manual
  • Funciones de Arrays
  • Rebobina el puntero interno del array

prev

(PHP 4, PHP 5, PHP 7, PHP 8)

prev — Rebobina el puntero interno del array

Descripción

prev ( array &$array ) : mixed

Rebobina el puntero interno del array.

prev() se comporta como next(), a excepción de que rebobina el puntero interno del array una posición en lugar de avanzar.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve el valor del array en la posición anterior que está apuntado por el puntero interno del array o false si no hay más elementos.

Ejemplos

Ejemplo #1 Ejemplo de uso de prev() and friends

<?php
$transport = array('pie', 'bici', 'coche', 'avión');
$mode = current($transport); // $mode = 'pie';
$mode = next($transport);    // $mode = 'bici';
$mode = next($transport);    // $mode = 'coche';
$mode = prev($transport);    // $mode = 'bici';
$mode = end($transport);     // $mode = 'avión';
?>

Notas

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Nota: No hay manera de distinguir el inicio de un array de un elemento de tipo false boolean. Para recorrer adecuadamente que puede contener elementos false ver la función each().

Ver también

  • current() - Devuelve el elemento actual en un array
  • end() - Establece el puntero interno de un array a su último elemento
  • next() - Avanza el puntero interno de un array
  • reset() - Establece el puntero interno de un array a su primer elemento
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array


Crear un array que contiene un rango de elementos

  • « prev
  • reset »
  • PHP Manual
  • Funciones de Arrays
  • Crear un array que contiene un rango de elementos

range

(PHP 4, PHP 5, PHP 7, PHP 8)

range — Crear un array que contiene un rango de elementos

Descripción

range ( mixed $start , mixed $end , number $step = 1 ) : array

Crea un array que contiene un rango de elementos.

Parámetros

start

Primer valor de la secuencia.

end

La secuencia finaliza al alcanzar el valor end.

step

Si se proporciona un valor a step, este será usado como el incremento entre los elementos de la secuencia. step debería darse como número positivo. Si no se especifica, el valor predeterminado de step será 1.

Valores devueltos

Devuelve un array de elementos desde start a end, inclusive.

Ejemplos

Ejemplo #1 Ejemplos de range()

<?php
// array(0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12)
foreach (range(0, 12) as $número) {
    echo $número;
}

// El parámetro step
// array(0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100)
foreach (range(0, 100, 10) as $número) {
    echo $número;
}

// Empleo de las secuencias de caracteres
// array('a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i');
foreach (range('a', 'i') as $letra) {
    echo $letra;
}
// array('c', 'b', 'a');
foreach (range('c', 'a') as $letra) {
    echo $letra;
}
?>

Notas

Nota:

Los valores de las secuencias de caracteres están limitados a una longitud de uno. Si se entra una longitud mayor que uno, solamente se utilizará el primer carácter.

Ver también

  • shuffle() - Mezcla un array
  • array_fill() - Llena un array con valores
  • foreach


Establece el puntero interno de un array a su primer elemento

  • « range
  • rsort »
  • PHP Manual
  • Funciones de Arrays
  • Establece el puntero interno de un array a su primer elemento

reset

(PHP 4, PHP 5, PHP 7, PHP 8)

reset — Establece el puntero interno de un array a su primer elemento

Descripción

reset ( array &$array ) : mixed

reset() rebobina el puntero interno de un array al primer elemento y devuelve el valor del primer elemento del array.

Parámetros

array

El array de entrada.

Valores devueltos

Devuelve el valor del primer elemento de un array o false si el array está vacío.

Ejemplos

Ejemplo #1 Ejemplo de reset()

<?php

$array = array('paso uno', 'paso dos', 'paso tres', 'paso cuatro');

// Por defecto, el puntero está en el primer elemento
echo current($array) . "<br />\n"; // "paso uno"

// Omite dos pasos
next($array);
next($array);
echo current($array) . "<br />\n"; // "paso tres"

// Resetea el puntero, empieza otra vez en paso uno
reset($array);
echo current($array) . "<br />\n"; // "paso uno"

?>

Ver también

  • current() - Devuelve el elemento actual en un array
  • each() - Devolver el par clave/valor actual de un array y avanzar el cursor del array
  • end() - Establece el puntero interno de un array a su último elemento
  • next() - Avanza el puntero interno de un array
  • prev() - Rebobina el puntero interno del array


Ordena un array en orden inverso

  • « reset
  • shuffle »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array en orden inverso

rsort

(PHP 4, PHP 5, PHP 7, PHP 8)

rsort — Ordena un array en orden inverso

Descripción

rsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Esta función ordena un array en orden inverso (mayor a menor).

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

sort_flags

Quizá se necesita cambiar el comportamiento de ordenado usando el parámetro opcional sort_flags, para más información ver sort().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de rsort()

<?php
$fruits = array("limón", "naranja", "plátano", "manzana");
rsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

El resultado del ejemplo sería:

0 = plátano
1 = naranja
2 = manzana
3 = limón

Las frutas han sido ordenadas alfábeticamente pero en orden inverso.

Notas

Nota: Esta función asigna nuevas clave a los elemenos del array. Eliminará cualquier clave existente que haya sido asignada, en lugar de reordenar las claves.

Ver también

  • arsort() - Ordena un array en orden inverso y mantiene la asociación de índices
  • krsort() - Ordena un array por clave en orden inverso
  • comparación de funciones de orden de arrays


Mezcla un array

  • « rsort
  • sizeof »
  • PHP Manual
  • Funciones de Arrays
  • Mezcla un array

shuffle

(PHP 4, PHP 5, PHP 7, PHP 8)

shuffle — Mezcla un array

Descripción

shuffle ( array &$array ) : bool

Esta función mezcla un array (crea un orden aleatorio de sus elementos). Utiliza un generador de números seudoaleatorios que no es apto para fines criptográficos.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de shuffle()

<?php
$números = range(1, 20);
shuffle($números);
foreach ($números as $número) {
    echo "$número ";
}
?>

Notas

Nota: Esta función asigna nuevas clave a los elemenos del array. Eliminará cualquier clave existente que haya sido asignada, en lugar de reordenar las claves.

Ver también

  • array_rand() - Seleccionar una o más claves aleatorias de un array
  • comparación de funciones de orden de arrays


Alias de count

  • « shuffle
  • sort »
  • PHP Manual
  • Funciones de Arrays
  • Alias de count

sizeof

(PHP 4, PHP 5, PHP 7, PHP 8)

sizeof — Alias de count()

Descripción

Esta función es un alias de: count().


Ordena un array

  • « sizeof
  • uasort »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array

sort

(PHP 4, PHP 5, PHP 7, PHP 8)

sort — Ordena un array

Descripción

sort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

Esta función ordena un array. Los elementos estarán ordenados de menor a mayor cuando la función haya terminado.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

sort_flags

El segundo parámetro opcional sort_flags puede ser usado para modificar el modo de ordenación usando estos valores:

Tipos de ordenación:

  • SORT_REGULAR - compara elementos normalmente (no cambia los tipos)
  • SORT_NUMERIC - compara elementos de forma numérica
  • SORT_STRING - compara elementos como cadenas
  • SORT_LOCALE_STRING - compara elementos como cadenas, basándose en la configuración regional en uso. Utiliza la configuración regional, la cual puede cambiarse usando setlocale().
  • SORT_NATURAL - compara elementos como cadenas usando el "orden natural" de la misma forma que natsort().
  • SORT_FLAG_CASE - se puede combinar (OR a nivel de bits) con SORT_STRING o SORT_NATURAL para ordenar cadenas de forma insensible a mayúsculas/minúsculas.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el soporte para SORT_NATURAL y SORT_FLAG_CASE como sort_flags
5.0.2 | Se añadió SORT_LOCALE_STRING

Ejemplos

Ejemplo #1 Ejemplo de sort()

<?php

$frutas = array("limón", "naranja", "banana", "albaricoque");
sort($frutas);
foreach ($frutas as $clave => $valor) {
    echo "frutas[" . $clave . "] = " . $valor . "\n";
}

?>

El resultado del ejemplo sería:

frutas[0] = albaricoque
frutas[1] = banana
frutas[2] = limón
frutas[3] = naranja

Las frutas han sido ordenadas en orden alfabético.

Ejemplo #2 Ejemplo de sort() usando la ordenación insensible a mayúsculas/minúsculas natural

<?php

$frutas = array(
    "Naranja1", "naranja2", "Naranja3", "naranja20"
);
sort($frutas, SORT_NATURAL | SORT_FLAG_CASE);
foreach ($frutas as $clave => $valor) {
    echo "frutas[" . $clave . "] = " . $valor . "\n";
}

?>

El resultado del ejemplo sería:

frutas[0] = Naranja1
frutas[1] = naranja2
frutas[2] = Naranja3
frutas[3] = naranja20

Las frutas han sido ordenadas de la misma forma que natcasesort().

Notas

Nota: Esta función asigna nuevas clave a los elemenos del array. Eliminará cualquier clave existente que haya sido asignada, en lugar de reordenar las claves.

Nota: Como la mayoría de funciones de ordenación de PHP, sort() utiliza una implementación de » Quicksort. El pivote es elegido en la mitad de la partición resultando en un tiempo óptimo para los arrays ya ordenados. Aunque esto es un detalle de implementación con el que no debería contar.

Advertencia

Se ha de tener cuidado cuando se ordenen arrays con valores de tipos mixtos ya que sort() puede producir resultados impredecibles.

Ver también

  • asort() - Ordena un array y mantiene la asociación de índices
  • comparación de funciones de orden de arrays


Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices

  • « sort
  • uksort »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices

uasort

(PHP 4, PHP 5, PHP 7, PHP 8)

uasort — Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices

Descripción

uasort ( array &$array , callable $value_compare_func ) : bool

Esta función ordena un array tal que los índices de array mantienen sus correlaciones con los elementos del array con los que están asociados, usando una función de comparación definida por el usuario.

Se usa pricipalmente cuando se ordenan arrays asociativos donde el orden del elemento mismo es significante.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

value_compare_func

Véase usort() y uksort() para ejemplos de funciones de comparación definidas por el usuario.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo básico de uasort()

<?php
// Función de comparación
function cmp($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Array a ser ordenado
$array = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
print_r($array);

// Ordenar e imprimir el array resultante
uasort($array, 'cmp');
print_r($array);
?>

El resultado del ejemplo sería:

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

Ver también

  • usort() - Ordena un array según sus valores usando una función de comparación definida por el usuario
  • comparación de funciones de orden de arrays


Ordena un array según sus claves usando una función de comparación definida por el usuario

  • « uasort
  • usort »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array según sus claves usando una función de comparación definida por el usuario

uksort

(PHP 4, PHP 5, PHP 7, PHP 8)

uksort — Ordena un array según sus claves usando una función de comparación definida por el usuario

Descripción

uksort ( array &$array , callable $key_compare_func ) : bool

uksort() ordenará las claves de un array usando una función de comparación proporcionada por el usuario. Si el array que se desea ordenar necesita ser ordenado por algún criterio no trivial, debería usar esta función.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Parámetros

array

El array de entrada.

key_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de uksort()

<?php
function cmp($a, $b)
{
    $a = preg_replace('@^(un|una|la) @', '', $a);
    $b = preg_replace('@^(un|una|la) @', '', $b);
    return strcasecmp($a, $b);
}

$a = array("Víctor" => 1, "la Tierra" => 2, "una manzana" => 3, "un plátano" => 4);

uksort($a, "cmp");

foreach ($a as $clave => $valor) {
    echo "$clave: $valor\n";
}
?>

El resultado del ejemplo sería:

una manzana: 3
un plátano: 4
la Tierra: 2
Víctor: 1

Ver también

  • usort() - Ordena un array según sus valores usando una función de comparación definida por el usuario
  • comparación de funciones de orden de arrays


Ordena un array según sus valores usando una función de comparación definida por el usuario

  • « uksort
  • Clases/Objetos »
  • PHP Manual
  • Funciones de Arrays
  • Ordena un array según sus valores usando una función de comparación definida por el usuario

usort

(PHP 4, PHP 5, PHP 7, PHP 8)

usort — Ordena un array según sus valores usando una función de comparación definida por el usuario

Descripción

usort ( array &$array , callable $value_compare_func ) : bool

Esta función ordenará un array según sus valores usando una función de comparación definida por el usuario. Si el array que se desea ordenar necesita ser ordenado por algún criterio no trivial, debería usar esta función.

Nota:

Si dos miembros se comparan como iguales, su orden relativo en el array oredenado será indefinido.

Nota: Esta función asigna nuevas clave a los elemenos del array. Eliminará cualquier clave existente que haya sido asignada, en lugar de reordenar las claves.

Parámetros

array

El array de entrada.

value_compare_func

La función de comparación debe devolver un entero menor, igual o mayor que cero si el primer argumento se considera que sea respectivamente menor, igual o mayor que el segundo. Observe que antes de PHP 7.0.0 este entero debía estar en el rango de -2147483648 a 2147483647.

callback ( mixed $a, mixed $b ) : int
Precaución

La devolución de valores que no sean de tipo integer por parte de la función de comparación, como float, resultará en una conversión interna a integer del valor devuelto por la llamada de retorno. Así, valores como 0.99 y 0.1 serán convertidos al valor de tipo integer 0, lo cual hará que la comparación de tales valores sea igual.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de usort()

<?php
function cmp($a, $b)
{
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

$a = array(3, 2, 5, 6, 1);

usort($a, "cmp");

foreach ($a as $clave => $valor) {
    echo "$clave: $valor\n";
}
?>

El resultado del ejemplo sería:

0: 1
1: 2
2: 3
3: 5
4: 6

Nota:

Obviamente, en este caso tan trivial, la función sort() sería más apropiada.

Ejemplo #2 Ejemplo de usort() usando un array multidimensional

<?php
function cmp($a, $b)
{
    return strcmp($a["fruta"], $b["fruta"]);
}

$frutas[0]["fruta"] = "uvas";
$frutas[1]["fruta"] = "limones";
$frutas[2]["fruta"] = "manzanas";

usort($frutas, "cmp");

while (list($clave, $valor) = each($frutas)) {
    echo "\$frutas[$clave]: " . $valor["fruta"] . "\n";
}
?>

Cuando se ordena un array multidimensional, $a y $b contienen referencias al primer índice del array.

El resultado del ejemplo sería:

$frutas[0]: limones
$frutas[1]: manzanas
$frutas[2]: uvas

Ejemplo #3 Ejemplo de usort() usando una función miembro de un objeto

<?php
class ObjPrueba {
    var $nombre;

    function ObjPrueba($nombre)
    {
        $this->nombre = $nombre;
    }

    /* Ésta es la función de comparación estática: */
    static function cmp_obj($a, $b)
    {
        $al = strtolower($a->nombre);
        $bl = strtolower($b->nombre);
        if ($al == $bl) {
            return 0;
        }
        return ($al > $bl) ? +1 : -1;
    }
}

$a[] = new ObjPrueba("c");
$a[] = new ObjPrueba("b");
$a[] = new ObjPrueba("d");

usort($a, array("ObjPrueba", "cmp_obj"));

foreach ($a as $elemento) {
    echo $elemento->nombre . "\n";
}
?>

El resultado del ejemplo sería:

b
c
d

Ejemplo #4 Ejemplo de usort() usando un cierre para ordenar un array multidimensional

<?php
$array[0] = array('clave_a' => 'z', 'clave_b' => 'c');
$array[1] = array('clave_a' => 'x', 'clave_b' => 'b');
$array[2] = array('clave_a' => 'y', 'clave_b' => 'a');

function build_sorter($clave) {
    return function ($a, $b) use ($clave) {
        return strnatcmp($a[$clave], $b[$clave]);
    };
}

usort($array, build_sorter('clave_b'));

foreach ($array as $item) {
    echo $item['clave_a'] . ', ' . $item['clave_b'] . "\n";
}
?>

El resultado del ejemplo sería:

y, a
x, b
z, c

Ver también

  • uasort() - Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices
  • comparación de funciones de orden de arrays


Información de Clases/Objetos

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Funciones de Clases/Objetos
    • __autoload — Intenta cargar una clase sin definir
    • class_alias — Crea un alias para una clase
    • class_exists — Verifica si la clase ha sido definida
    • get_called_class — El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")
    • get_class_methods — Obtiene los nombres de los métodos de una clase
    • get_class_vars — Obtener las propiedades predeterminadas de una clase
    • get_class — Devuelve el nombre de la clase de un objeto
    • get_declared_classes — Devuelve una matriz con los nombres de las clases definidas
    • get_declared_interfaces — Devuelve un array con todas las interfaces declaradas
    • get_declared_traits — Devuelve un array de todos los traits declarados
    • get_object_vars — Obtiene las propiedades del objeto dado
    • get_parent_class — Recupera el nombre de la clase padre de un objeto o clase
    • interface_exists — Comprueba si una interfaz ha sido definida
    • is_a — Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres
    • is_subclass_of — Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa
    • method_exists — Comprueba si existe un método de una clase
    • property_exists — Comprueba si el objeto o la clase tienen una propiedad
    • trait_exists — Comprobar si el trait existe


Introducción

Estas funciones permiten obtener información sobre clases y objetos. Se puede obtener el nombre de la clase a la que pertenece un objeto, así como sus propiedades y métodos miembro. Al usar estas funciones no sólo se puede averiguar la pertenencia a una clase de un objeto, sino también su vínculo parental (esto es, qué clase es la que extiende la clase del objeto).

Por favor, vea la sección de Objetos del manual para una explicación detallada de cómo están las clases y objetos implementados y de cómo son usados en PHP.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Clases/Objetos
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

En este ejemplo, primero definimos una clase base y una extensión de la misma. La clase base describe una verdura en general, si es comestible o no y cuál es su color. La subclase Espinaca añade un método para cocinarla y otro para averiguar si está cocinada.

Ejemplo #1 classes.inc

<?php

// clase base con propiedades y métodos miembro
class Verdura {

   var $comestible;
   var $color;

   function __construct($comestible, $color="verde")
   {
       $this->comestible = $comestible;
       $this->color = $color;
   }

   function es_comestible()
   {
       return $this->comestible;
   }

   function qué_color()
   {
       return $this->color;
   }

} // fin de la clase Verdura

// ampliar la clase base
class Espinaca extends Verdura {

   var $concinada = false;

   function __construct()
   {
       parent::__construct(true, "verde");
   }

   function cocinarla()
   {
       $this->concinada = true;
   }

   function está_cocinada()
   {
       return $this->concinada;
   }

} // fin de la clase Espinaca

?>

Entonces instanciamos dos objetos de estas clases e imprimimos la información sobre ellos, incluida su linaje de clases. También definimos algunas funciones de utilidad, prinpipalmente para tener una impresión atractiva de las variables.

Ejemplo #2 test_script.php

<pre>
<?php

include "classes.inc";

// funciones de utilidad

function imprimir_vars($obj)
{
foreach (get_object_vars($obj) as $prop => $val) {
    echo "\t$prop = $val\n";
}
}

function imprimir_métodos($obj)
{
$arr = get_class_methods(get_class($obj));
foreach ($arr as $método) {
    echo "\tfunción $método()\n";
}
}

function linaje_de_clases($obj, $clase)
{
if (is_subclass_of($GLOBALS[$obj], $clase)) {
    echo "El objeto $obj pertenece a la clase " . get_class($GLOBALS[$obj]);
    echo ", una subclase de $clase\n";
} else {
    echo "El objeto $obj no pertenece a una subclase de $clase\n";
}
}

// instancias 2 objetos

$vegetariano = new Verdura(true, "blue");
$frondoso = new Espinaca();

// imprimir información sobre los objetos
echo "vegetariano: CLASE " . get_class($vegetariano) . "\n";
echo "frondoso: CLASE " . get_class($frondoso);
echo ", MADRE " . get_parent_class($frondoso) . "\n";

// mostrar las propiedades de vegetariano
echo "\nvegetariano: Propiedades\n";
imprimir_vars($vegetariano);

// y los métodos de frondoso
echo "\nfrondoso: Métodos\n";
imprimir_métodos($frondoso);

echo "\nLinaje:\n";
linaje_de_clases("frondoso", "Espinaca");
linaje_de_clases("frondoso", "Verdura");
?>
</pre>

Una cosa importanete a observar en el ejemplo anterior es que el objeto $frondoso es una instancia de la clase Espinaca que es una subclase de Verdura, por lo tanto, la última parte del script anterior imprimirá:

   [...]
Linaje:
El objeto frondoso no pertenece a una subclase de Espinaca
El objeto frondoso pertenece a la clase Espinaca, una subclase de Verdura


Funciones de Clases/Objetos

Tabla de contenidos

  • __autoload — Intenta cargar una clase sin definir
  • class_alias — Crea un alias para una clase
  • class_exists — Verifica si la clase ha sido definida
  • get_called_class — El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")
  • get_class_methods — Obtiene los nombres de los métodos de una clase
  • get_class_vars — Obtener las propiedades predeterminadas de una clase
  • get_class — Devuelve el nombre de la clase de un objeto
  • get_declared_classes — Devuelve una matriz con los nombres de las clases definidas
  • get_declared_interfaces — Devuelve un array con todas las interfaces declaradas
  • get_declared_traits — Devuelve un array de todos los traits declarados
  • get_object_vars — Obtiene las propiedades del objeto dado
  • get_parent_class — Recupera el nombre de la clase padre de un objeto o clase
  • interface_exists — Comprueba si una interfaz ha sido definida
  • is_a — Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres
  • is_subclass_of — Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa
  • method_exists — Comprueba si existe un método de una clase
  • property_exists — Comprueba si el objeto o la clase tienen una propiedad
  • trait_exists — Comprobar si el trait existe


Intenta cargar una clase sin definir

  • « Funciones de Clases/Objetos
  • class_alias »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Intenta cargar una clase sin definir

__autoload

(PHP 5, PHP 7)

__autoload — Intenta cargar una clase sin definir

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Descripción

__autoload ( string $class ) : void

Puede definir esta función para habilitar la carga de clases.

Parámetros

class

Nombre de la clase a cargar

Valores devueltos

No devuelve ningún valor.

Ver también

  • spl_autoload_register() - Registrar las funciones dadas como implementación de __autoload()


Crea un alias para una clase

  • « __autoload
  • class_exists »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Crea un alias para una clase

class_alias

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

class_alias — Crea un alias para una clase

Descripción

class_alias ( string $original , string $alias , bool $autoload = true ) : bool

Crea un alias dado por alias basado en la clase original definida por el usuario. La clase apodada es exactamente la misma que la clase original.

Parámetros

original

La clase original.

alias

El nombre del alias para la clase.

autoload

Si se realiza la autocarga si la clase original no se encuentra.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de class_alias()

<?php

class foo { }

class_alias('foo', 'bar');

$a = new foo;
$b = new bar;

// los objetos son los mismos
var_dump($a == $b, $a === $b);
var_dump($a instanceof $b);

// las clases son las mismas
var_dump($a instanceof foo);
var_dump($a instanceof bar);

var_dump($b instanceof foo);
var_dump($b instanceof bar);

?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(true)

Ver también

  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa


Verifica si la clase ha sido definida

  • « class_alias
  • get_called_class »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Verifica si la clase ha sido definida

class_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

class_exists — Verifica si la clase ha sido definida

Descripción

class_exists ( string $class_name , bool $autoload = true ) : bool

Esta función verifica si la clase dada ha sido definida o no.

Parámetros

class_name

El nombre de la clase. El nombre es coincidido de manera insensible a mayúsculas y minúsculas.

autoload

Indica si ha de llamarse __autoload o no de forma predeterminada.

Valores devueltos

Devuelve true si class_name es una clase definida, false de lo contrario.

Historial de cambios

Versión | Descripción
5.0.2 | Ya no devuelve true para interfaces definidas. En ese caso se debe usar interface_exists().

Ejemplos

Ejemplo #1 Ejemplo de class_exists()

<?php
// Verificar que la clase exista antes de usarla
if (class_exists('MiClase')) {
    $mi_clase = new MiClase();
}

?>

Ejemplo #2 Ejemplo del parámetro autoload

<?php
function __autoload($clase)
{
    include($clase . '.php');

    // Verificar si la sentencia include declaró la clase
    if (!class_exists($clase, false)) {
        trigger_error("No es posible cargar la clase: $clase", E_USER_WARNING);
    }
}

if (class_exists('MiClase')) {
    $mi_clase = new MiClase();
}

?>

Ver también

  • function_exists() - Devuelve true si la función dada ha sido definida
  • interface_exists() - Comprueba si una interfaz ha sido definida
  • get_declared_classes() - Devuelve una matriz con los nombres de las clases definidas


El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")

  • « class_exists
  • get_class_methods »
  • PHP Manual
  • Funciones de Clases/Objetos
  • El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")

get_called_class

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

get_called_class — El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")

Descripción

get_called_class ( ) : string

Obtiene el nombre de la clase desde la que se llama al método estático.

Valores devueltos

Devuelve el nombre de la clase. Devuelve false si la llamada se hizo desde fuera de la clase.

Ejemplos

Ejemplo #1 Usar get_called_class()

<?php

class foo {
    static public function prueba() {
        var_dump(get_called_class());
    }
}

class bar extends foo {
}

foo::prueba();
bar::prueba();

?>

El resultado del ejemplo sería:

string(3) "foo"
string(3) "bar"

Ver también

  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase
  • get_class() - Devuelve el nombre de la clase de un objeto
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa


Obtiene los nombres de los métodos de una clase

  • « get_called_class
  • get_class_vars »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Obtiene los nombres de los métodos de una clase

get_class_methods

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class_methods — Obtiene los nombres de los métodos de una clase

Descripción

get_class_methods ( mixed $class_name ) : array

Obtiene los nombres de los métodos de una clase.

Parámetros

class_name

El nombre de la clase o una instancia de objeto

Valores devueltos

Devuelve un array con los nombres de los métodos definidos para la clase especificada por class_name. Es caso de error devuelve null.

Ejemplos

Ejemplo #1 Ejemplo de get_class_methods()

<?php

class miclase {
    // constructor
    function __construct()
    {
        return(true);
    }

    // método 1
    function mifunc1()
    {
        return(true);
    }

    // método 2
    function mifunc2()
    {
        return(true);
    }
}

$métodos_clase = get_class_methods('miclase');
// o
$métodos_clase = get_class_methods(new miclase());

foreach ($métodos_clase as $nombre_método) {
    echo "$nombre_método\n";
}

?>

El resultado del ejemplo sería:

miclase
mifunc1
mifunc2

Ver también

  • get_class() - Devuelve el nombre de la clase de un objeto
  • get_class_vars() - Obtener las propiedades predeterminadas de una clase
  • get_object_vars() - Obtiene las propiedades del objeto dado


Obtener las propiedades predeterminadas de una clase

  • « get_class_methods
  • get_class »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Obtener las propiedades predeterminadas de una clase

get_class_vars

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class_vars — Obtener las propiedades predeterminadas de una clase

Descripción

get_class_vars ( string $class_name ) : array

Obtiene las propiedades predeterminadas de la clase dada.

Parámetros

class_name

El nombre de la clase

Valores devueltos

Devuelve una matriz asociativa de las propiedades declaradas visibles desde el ámbito actual, con su valor predeterminado. Los elementos del array resultante están en la forma nombre_variable => valor. En caso de error devuelve false.

Historial de cambios

Versión | Descripción
5.0.3 | get_class_vars() devolverá sólo las propiedades que pueden ser accedidas desde el ámbito actual.
5.0.2 | Al llamar a get_class_vars() ahora se expondrán todas las propiedades como una matriz, a diferencia del comportamiento anterior donde las propieades protected y private eran prefijadas con bytes nul.
5.0.1 | Al llamar a get_class_vars() se expondrán todas las propiedades, como cuando se convierte un objeto en una clase.

Ejemplos

Ejemplo #1 Ejemplo de get_class_vars()

<?php

class miclase {

    var $var1; // esta no tiene valor predeterminado...
    var $var2 = "xyz";
    var $var3 = 100;
    private $var4;

    // constructor
    function __construct() {
        // cambiar algunas propiedades
        $this->var1 = "foo";
        $this->var2 = "bar";
        return true;
    }

}

$mi_clase = new miclase();

$vars_clase = get_class_vars(get_class($mi_clase));

foreach ($vars_clase as $nombre => $valor) {
    echo "$nombre : $valor\n";
}

?>

El resultado del ejemplo sería:

var1 :
var2 : xyz
var3 : 100

Ejemplo #2 get_class_vars() y comportamiento de ámbito

<?php
function formato($matriz)
{
    return implode('|', array_keys($matriz)) . "\r\n";
}

class TestCase
{
    public $a    = 1;
    protected $b = 2;
    private $c   = 3;

    public static function expose()
    {
        echo formato(get_class_vars(__CLASS__));
    }
}

TestCase::expose();
echo formato(get_class_vars('TestCase'));
?>

El resultado del ejemplo sería:

// 5.0.0
a| * b| TestCase c
a| * b| TestCase c

// 5.0.1 - 5.0.2
a|b|c
a|b|c

// 5.0.3 +
a|b|c
a

Ver también

  • get_class_methods() - Obtiene los nombres de los métodos de una clase
  • get_object_vars() - Obtiene las propiedades del objeto dado


Devuelve el nombre de la clase de un objeto

  • « get_class_vars
  • get_declared_classes »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Devuelve el nombre de la clase de un objeto

get_class

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class — Devuelve el nombre de la clase de un objeto

Descripción

get_class ( object $object = null ) : string

Obtiene el nombre de la clase del objeto dado por object.

Parámetros

object

El objeto evaluado. Este parámetro puede omitirse cuando se utiliza dentro de una clase.

Valores devueltos

Devuelve el nombre de la clase de la cual object es una instancia. Devuelve false si object no es un objeto.

Si se omite object al usarse dentro de una clase, devolverá el nombre de la clase.

Errores/Excepciones

Si se llama a la función get_class() con algo que no sea un objeto, se producirá un error de nivel E_WARNING.

Historial de cambios

Versión | Descripción
5.3.0 | El valor predeterminado de object ahora es null, por lo que pasar el valor null a object tiene el mismo resultado que no pasar ningún valor.

Ejemplos

Ejemplo #1 Usar get_class()

<?php

class foo {
    function nombre()
    {
        echo "Mi nombre es " , get_class($this) , "\n";
    }
}

// crear un objeto
$bar = new foo();

// llamada externa
echo "Su nombre es " , get_class($bar) , "\n";

// llamada interna
$bar->nombre();

?>

El resultado del ejemplo sería:

Su nombre es foo
Mi nombre es foo

Ejemplo #2 Usar get_class() en superclass

<?php

abstract class bar {
    public function __construct()
    {
        var_dump(get_class($this));
        var_dump(get_class());
    }
}

class foo extends bar {
}

new foo;

?>

El resultado del ejemplo sería:

string(3) "foo"
string(3) "bar"

Ver también

  • get_called_class() - El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")
  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase
  • gettype() - Obtener el tipo de una variable
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa


Devuelve una matriz con los nombres de las clases definidas

  • « get_class
  • get_declared_interfaces »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Devuelve una matriz con los nombres de las clases definidas

get_declared_classes

(PHP 4, PHP 5, PHP 7, PHP 8)

get_declared_classes — Devuelve una matriz con los nombres de las clases definidas

Descripción

get_declared_classes ( ) : array

Obtiene las clases declaradas.

Valores devueltos

Devuelve una matriz con los nombres de las clases declaradas en el script actual.

Nota:

Observe que, dependiendo de qué extensiones tiene compiladas o cargadas en PHP, las clases adicionales podrían no estar presentes. Esto significa que no será capaz de definir sus propias clases usando estos nombres. Hay una lista de clases predefinidas en la sección Clases Predefinidas de los apéndices.

Ejemplos

Ejemplo #1 Ejemplo de get_declared_classes()

<?php
print_r(get_declared_classes());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => stdClass
    [1] => __PHP_Incomplete_Class
    [2] => Directory
)

Ver también

  • class_exists() - Verifica si la clase ha sido definida
  • get_declared_interfaces() - Devuelve un array con todas las interfaces declaradas
  • get_defined_functions() - Devuelve un array de todas las funciones definidas


Devuelve un array con todas las interfaces declaradas

  • « get_declared_classes
  • get_declared_traits »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Devuelve un array con todas las interfaces declaradas

get_declared_interfaces

(PHP 5, PHP 7, PHP 8)

get_declared_interfaces — Devuelve un array con todas las interfaces declaradas

Descripción

get_declared_interfaces ( ) : array

Obtiene las interfaces declaradas.

Valores devueltos

Devuelve un array con los nombres de las interfaces declaradas en el script actual.

Ejemplos

Ejemplo #1 Ejemplo de get_declared_interfaces()

<?php
print_r(get_declared_interfaces());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Traversable
    [1] => IteratorAggregate
    [2] => Iterator
    [3] => ArrayAccess
    [4] => reflector
    [5] => RecursiveIterator
    [6] => SeekableIterator
)

Ver también

  • interface_exists() - Comprueba si una interfaz ha sido definida
  • get_declared_classes() - Devuelve una matriz con los nombres de las clases definidas
  • class_implements() - Devuelve las interfaces que son implementadas por la clase o interfaz dadas


Devuelve un array de todos los traits declarados

  • « get_declared_interfaces
  • get_object_vars »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Devuelve un array de todos los traits declarados

get_declared_traits

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

get_declared_traits — Devuelve un array de todos los traits declarados

Descripción

get_declared_traits ( ) : array

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con los nombres de todos los traits declarados en valores. Devuelve null en caso de error.

Ver también

  • class_uses() - Devolver los "traits" usados por la clase dada
  • trait_exists() - Comprobar si el trait existe


Obtiene las propiedades del objeto dado

  • « get_declared_traits
  • get_parent_class »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Obtiene las propiedades del objeto dado

get_object_vars

(PHP 4, PHP 5, PHP 7, PHP 8)

get_object_vars — Obtiene las propiedades del objeto dado

Descripción

get_object_vars ( object $object ) : array

Obtiene las propiedades no estáticas accesibles del objeto dado por object según el ámbito.

Parámetros

object

Una instancia de un objeto.

Valores devueltos

Devuelve un array asociativo con las propiedades no estáticas accesibles del objeto especificado por object en el ámbito.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora devuelve null si object no es un objeto. Anteriormente devolvía false

Ejemplos

Ejemplo #1 Uso de get_object_vars()

<?php

class foo {
    private $a;
    public $b = 1;
    public $c;
    private $d;
    static $e;

    public function prueba() {
        var_dump(get_object_vars($this));
    }
}

$prueba = new foo;
var_dump(get_object_vars($prueba));

$prueba->prueba();

?>

El resultado del ejemplo sería:

array(2) {
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
}
array(4) {
  ["a"]=>
  NULL
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
  ["d"]=>
  NULL
}

Ver también

  • get_class_methods() - Obtiene los nombres de los métodos de una clase
  • get_class_vars() - Obtener las propiedades predeterminadas de una clase


Recupera el nombre de la clase padre de un objeto o clase

  • « get_object_vars
  • interface_exists »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Recupera el nombre de la clase padre de un objeto o clase

get_parent_class

(PHP 4, PHP 5, PHP 7, PHP 8)

get_parent_class — Recupera el nombre de la clase padre de un objeto o clase

Descripción

get_parent_class ( mixed $object = ? ) : string

Recupera el nombre de la clase padre de un objeto o clase.

Parámetros

object

El objeto evaluádo o nombre de la clase. Este parámetro es opcional si se invoca desde el método del objeto.

Valores devueltos

Devuelve el nombre de la clase padre de la clase de la cuál object es una instancia o el nombre.

Nota:

Si el objeto no tiene padre o la clase dada no existe devolverá false.

Si se llama sin parámetro fuera del objeto, esta función devolverá false.

Historial de cambios

Versión | Descripción
5.1.0 | Si se llamaba sin parámetro fuera del objeto, está función devolvía null con una advertencia, pero ahora devuelve false.

Ejemplos

Ejemplo #1 Usar get_parent_class()

<?php

class papá {
    function papá()
    {
    // implementar algo lógico
    }
}

class hijo extends papá {
    function hijo()
    {
        echo "Soy hijo de " , get_parent_class($this) , "\n";
    }
}

class hijo2 extends papá {
    function hijo2()
    {
        echo "Yo también soy hijo de " , get_parent_class('hijo2') , "\n";
    }
}

$foo = new hijo();
$bar = new hijo2();

?>

El resultado del ejemplo sería:

I'm dad's son
I'm dad's son too

Ver también

  • get_class() - Devuelve el nombre de la clase de un objeto
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa
  • class_parents() - Devuelve las clases padre de la clase dada.


Comprueba si una interfaz ha sido definida

  • « get_parent_class
  • is_a »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprueba si una interfaz ha sido definida

interface_exists

(PHP 5 >= 5.0.2, PHP 7, PHP 8)

interface_exists — Comprueba si una interfaz ha sido definida

Descripción

interface_exists ( string $interface_name , bool $autoload = true ) : bool

Comprueba si la interfaz dada ha sido definida.

Parámetros

interface_name

El nombre de la interfaz

autoload

Si llamar a __autoload o no por defecto.

Valores devueltos

Devuelve true si la interfaz dada por interface_name ha sido definida, false si no.

Ejemplos

Ejemplo #1 Ejemplo de interface_exists()

<?php
// Comprobar si la interfaz existe antes de intentar usarla
if (interface_exists('MiInterfaz')) {
    class MiClase implements MiInterfaz
    {
        // Métodos
    }
}

?>

Ver también

  • get_declared_interfaces() - Devuelve un array con todas las interfaces declaradas
  • class_implements() - Devuelve las interfaces que son implementadas por la clase o interfaz dadas
  • class_exists() - Verifica si la clase ha sido definida


Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres

  • « interface_exists
  • is_subclass_of »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres

is_a

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_a — Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres

Descripción

is_a ( mixed $object , string $class_name , bool $allow_string = false ) : bool

Comprueba si el objeto dado por object es de esta clase o tiene esta clase como una de sus madres.

Parámetros

object

Un nombre de clase o una instancia de objeto.

class_name

El nombre de la clase

allow_string

Si este parámetro se establece a false, no se permite una cadena de nombre de la clase como object. Esto también evita llamar al autocargador si la clase no existe.

Valores devueltos

Devuelve true si el objeto es de esta clase o tiene esta clase como una de sus madres, false si no.

Historial de cambios

Versión | Descripción
5.3.9 | Se añadió el parámetro allow_string
5.3.0 | Esta función ya no está obsoleta, y por lo tanto ya no lanza advertencias de tipo E_STRICT.
5.0.0 | Esta funcion se volvió obsoleta en favor del operador instanceof. Llamar a esta función resultará en una advertencia de tipo E_STRICT.

Ejemplos

Ejemplo #1 Ejemplo de is_a()

<?php
// definir una clase
class FábricaTrastos
{
  var $oink = 'moo';
}

// crear un nuevo objeto
$WF = new FábricaTrastos();

if (is_a($WF, 'FábricaTrastos')) {
  echo "Sí, \$WF es todavía un FábricaTrastos\n";
}
?>

Ejemplo #2 Usar el operador instanceof en PHP 5

<?php
if ($WF instanceof FábricaTrastos) {
    echo 'Sí, $WF es un FábricaTrastos';
}
?>

Ver también

  • get_class() - Devuelve el nombre de la clase de un objeto
  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa


Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa

  • « is_a
  • method_exists »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa

is_subclass_of

(PHP 4, PHP 5, PHP 7, PHP 8)

is_subclass_of — Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa

Descripción

is_subclass_of ( mixed $object , string $class_name , bool $allow_string = true ) : bool

Comprueba si el object dado tiene la clase class_name como uno de sus padres o si la implementa.

Parámetros

object

Un nombre de clase o una instancia de objeto. No se genera ningún error si la clase no existe.

class_name

El nombre de clase

allow_string

Si se define este parámetro como false, no se permite el uso del nombre de la clase como object. Esto también previene llamar el autoloader si la clase no existe.

Valores devueltos

Esta función devuelve true si el objeto object pertenece a una clase que sea subclase de class_name, false en caso contrario.

Historial de cambios

Versión | Descripción
5.3.9 | Se añadió el parámetro allow_string
5.3.7 | Se añadió el soporte para class_name para trabajar con interfaces
5.0.3 | Es posible especificar también el parámetro object como una cadena (el nombre de la clase)

Ejemplos

Ejemplo #1 Ejemplo de is_subclass_of()

<?php
// definir una clase
class FabricaWidget
{
  var $oink = 'moo';
}

// definir una clase hija
class Hijo_FabricaWidget extends FabricaWidget
{
  var $oink = 'oink';
}

// crear un nuevo objeto
$FW = new FabricaWidget();
$HFW = new Hijo_FabricaWidget();

if (is_subclass_of($HFW, 'FabricaWidget')) {
  echo "si, \$HFW es una sub-clase de FabricaWidget\n";
} else {
  echo "no, \$HFW no es una sub-clase de FabricaWidget\n";
}

if (is_subclass_of($FW, 'FabricaWidget')) {
  echo "si, \$FW es una sub-clase de FabricaWidget\n";
} else {
  echo "no, \$FW no es una sub-clase de FabricaWidget\n";
}

// usable sólo desde PHP 5.0.3
if (is_subclass_of('Hijo_FabricaWidget', 'FabricaWidget')) {
  echo "si, Hijo_FabricaWidget es una sub-clase de FabricaWidget\n";
} else {
  echo "no, Hijo_FabricaWidget no es una sub-clase de FabricaWidget\n";
}
?>

El resultado del ejemplo sería:

si, $HFW es una sub-clase de FabricaWidget
no, $FW no es una sub-clase de FabricaWidget
si, Hijo_FabricaWidget es una sub-clase de FabricaWidget

Ejemplo #2 Ejemplo de is_subclass_of() usando una interfaz

<?php
// Definir la interfaz
interface MiInterfaz
{
  public function MiFunción();
}

// Definir la implementación de la clase de la interfaz
class MiClase implements MiInterfaz
{
  public function MiFunción()
  {
    return "¡MiClase implementa MiInterfaz!";
  }
}

// Instanciar el objeto
$mi_objeto = new MiClase;

// Funciona desde 5.3.7

// Una prueba usando la instancia del objeto de la clase
if (is_subclass_of($mi_objeto, 'MiInterfaz')) {
  echo "Sí, \$mi_objeto es una subclase de MiInterfaz\n";
} else {
  echo "No, \$mi_objeto no es una subclase de MiInterfaz\n";
}

// Una prueba usando una cadena del nombre de la clase
if (is_subclass_of('MiClase', 'MiInterfaz')) {
  echo "Sí, MiClase es una subclase de MiInterfaz\n";
} else {
  echo "No, MiClase no es una subclase de MiInterfaz\n";
}
?>

El resultado del ejemplo sería:

Sí, $mi_objeto es una subclase de MiInterfaz
Sí, MiClase es una subclase de MiInterfaz

Notas

Nota:

Esta función cargará cualquier autocargador registrado si la clase todavía no existe.

Ver también

  • get_class() - Devuelve el nombre de la clase de un objeto
  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase
  • is_a() - Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres
  • class_parents() - Devuelve las clases padre de la clase dada.


Comprueba si existe un método de una clase

  • « is_subclass_of
  • property_exists »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprueba si existe un método de una clase

method_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

method_exists — Comprueba si existe un método de una clase

Descripción

method_exists ( mixed $object , string $method_name ) : bool

Comprueba si existe el método de la clase en el objeto dado por object.

Parámetros

object

Una instancia o un nombre de clase

method_name

El nombre del método

Valores devueltos

Devuelve true si el método dado por method_name ha sido definido para el objeto dado por object, false si no.

Notas

Nota:

Esta función cargará cualquier autocargador registrado si la clase todavía no existe.

Ejemplos

Ejemplo #1 Ejemplo de method_exists()

<?php
$directorio = new Directory('.');
var_dump(method_exists($directorio,'read'));
?>

El resultado del ejemplo sería:

bool(true)

Ejemplo #2 Ejemplo de method_exists() estático

<?php
var_dump(method_exists('Directory','read'));
?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • function_exists() - Devuelve true si la función dada ha sido definida
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función
  • class_exists() - Verifica si la clase ha sido definida


Comprueba si el objeto o la clase tienen una propiedad

  • « method_exists
  • trait_exists »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprueba si el objeto o la clase tienen una propiedad

property_exists

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

property_exists — Comprueba si el objeto o la clase tienen una propiedad

Descripción

property_exists ( mixed $class , string $property ) : bool

Esta función comprueba si la propiedad dada por property existe en la clase especificada.

Nota:

A diferencia de isset(), property_exists() devuelve true incluso si la propiedad tiene el valor null.

Parámetros

class

El nombre de la clase o un objeto de la clase a comprobar

property

El nombre de la propiedad

Valores devueltos

Devuelve true si la propiedad existe, false si no existe, o null en caso de error.

Notas

Nota:

Esta función cargará cualquier autocargador registrado si la clase todavía no existe.

Nota:

La función property_exists() no puede detectar propiedades que son accesibles de forma mágica usando el método mágico __get.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función comprueba la existencia de una propiedad independientemente de su accesibilidad.

Ejemplos

Ejemplo #1 Un ejemplo de property_exists()

<?php

class miClase {
    public $mía;
    private $xpto;
    static protected $prueba;

    static function prueba() {
        var_dump(property_exists('miClase', 'xpto')); //true
    }
}

var_dump(property_exists('miClase', 'mía'));   //true
var_dump(property_exists(new miClase, 'mía')); //true
var_dump(property_exists('miClase', 'xpto'));   //true, desde PHP 5.3.0
var_dump(property_exists('miClase', 'bar'));    //false
var_dump(property_exists('miClase', 'prueba'));   //true, desde PHP 5.3.0
miClase::prueba();

?>

Ver también

  • method_exists() - Comprueba si existe un método de una clase


Comprobar si el trait existe

  • « property_exists
  • Classkit »
  • PHP Manual
  • Funciones de Clases/Objetos
  • Comprobar si el trait existe

trait_exists

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

trait_exists — Comprobar si el trait existe

Descripción

trait_exists ( string $traitname , bool $autoload = ? ) : bool

Parámetros

traitname

Nombre del trait a comprobar

autoload

Si aplicar la autocarga si no está ya cargado.

Valores devueltos

Devuelve true si el trait existe, false si no, null en caso de error.


Classkit

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Classkit
    • classkit_import — Importar nuevas definiciones de métodos de clase desde un archivo
    • classkit_method_add — Añade dinámicamente un nuevo método una clase dada
    • classkit_method_copy — Copia un método de una clase a otra
    • classkit_method_redefine — Cambia dinámicamente el código del método dado
    • classkit_method_remove — Elimina dinámicamente el método dado
    • classkit_method_rename — Cambia dinámicamente el nombre del método dado


Introducción

Estas funciones permiten la manipulación dinámica de clases de PHP en tiempo de ejecución.

Nota:

Esta extensión ha sido reemplazada por runkit, la cual no está limitada solamente a la manipulación de clases, sino también a la manipulación de funciones.


Instalación

Esta extensión se considera no mantenida y abandonada. Sin embargo, el código fuente para esta extensión sigue estando disponible en PECL SVN aquí: » https://svn.php.net/viewvc/pecl/classkit.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

CLASSKIT_ACC_PRIVATE (int)
Marca el método como private
CLASSKIT_ACC_PROTECTED (int)
Marca el método como protected
CLASSKIT_ACC_PUBLIC (int)
Marca el método como public


Funciones de Classkit

Tabla de contenidos

  • classkit_import — Importar nuevas definiciones de métodos de clase desde un archivo
  • classkit_method_add — Añade dinámicamente un nuevo método una clase dada
  • classkit_method_copy — Copia un método de una clase a otra
  • classkit_method_redefine — Cambia dinámicamente el código del método dado
  • classkit_method_remove — Elimina dinámicamente el método dado
  • classkit_method_rename — Cambia dinámicamente el nombre del método dado


Importar nuevas definiciones de métodos de clase desde un archivo

  • « Funciones de Classkit
  • classkit_method_add »
  • PHP Manual
  • Funciones de Classkit
  • Importar nuevas definiciones de métodos de clase desde un archivo

classkit_import

(PECL classkit >= 0.3)

classkit_import — Importar nuevas definiciones de métodos de clase desde un archivo

Descripción

classkit_import ( string $filename ) : array

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

filename

El nombre de archivo de las definiciones del método de clase a importar

Valores devueltos

Matriz asociativa de los métodos importados

Ejemplos

Ejemplo #1 Ejemplo de classkit_import()

<?php
// file: nuevaclase.php
class Ejemplo {
    function foo() {
        return "bar!\n";
    }
}
?>
<?php
// se necesita nuevaclase.php (ver arriba)
class Ejemplo {
    function foo() {
        return "foo!\n";
    }
}

$e = new Ejemplo();

// imprimir el original
echo $e->foo();

// importar el método de remplazo
classkit_import('nuevaclase.php');

// imprimir el importado
echo $e->foo();

?>

El resultado del ejemplo sería:

foo!
bar!

Ver también

  • classkit_method_add() - Añade dinámicamente un nuevo método una clase dada
  • classkit_method_copy() - Copia un método de una clase a otra


Añade dinámicamente un nuevo método una clase dada

  • « classkit_import
  • classkit_method_copy »
  • PHP Manual
  • Funciones de Classkit
  • Añade dinámicamente un nuevo método una clase dada

classkit_method_add

(PECL classkit >= 0.1)

classkit_method_add — Añade dinámicamente un nuevo método una clase dada

Descripción

classkit_method_add ( string $classname , string $methodname , string $args , string $code , int $flags = CLASSKIT_ACC_PUBLIC ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

classname

La clase en la que este método será añadido

methodname

El nombre del método a añadir

args

Lista de argumentos separados por coma para el método recién creado

code

El código a ser evaluado cuando methodname es llamado

flags

El tipo de método a crear, puede ser CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED o CLASSKIT_ACC_PRIVATE

Nota:

Este parámetro se usa sólo a partir de PHP 5, ya que, antes de esta versión, todos los métodos eran públicos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de classkit_method_add()

<?php
class Ejemplo {
    function foo() {
        echo "foo!\n";
    }
}

// crear un objeto de Ejemplo
$e = new Example();

// Añadir un nuevo método público
classkit_method_add(
    'Ejemplo',
    'sumar',
    '$num1, $num2',
    'return $num1 + $num2;',
    CLASSKIT_ACC_PUBLIC
);

// sumar 12 + 4
echo $e->sumar(12, 4);
?>

El resultado del ejemplo sería:

16

Ver también

  • classkit_method_copy() - Copia un método de una clase a otra
  • classkit_method_redefine() - Cambia dinámicamente el código del método dado
  • classkit_method_remove() - Elimina dinámicamente el método dado
  • classkit_method_rename() - Cambia dinámicamente el nombre del método dado
  • create_function() - Crear una función anónima (estilo lambda)


Copia un método de una clase a otra

  • « classkit_method_add
  • classkit_method_redefine »
  • PHP Manual
  • Funciones de Classkit
  • Copia un método de una clase a otra

classkit_method_copy

(PECL classkit >= 0.2)

classkit_method_copy — Copia un método de una clase a otra

Descripción

classkit_method_copy ( string $dClass , string $dMethod , string $sClass , string $sMethod = ? ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

dClass

Clase destino para copiar el método

dMethod

Nombre del método destino

sClass

Clase origen del método a copiar

sMethod

Nombre del método a copiar desde la clase origen. Si se omite este parámetro, se asume el valor de dMethod.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de classkit_method_copy()

<?php
class Foo {
    function ejemplo() {
        return "foo!\n";
    }
}

class Bar {
    // inicialmente sin métodos
}

// copiar el método ejemplo() desde la clase Foo a la clase Bar class, como baz()
classkit_method_copy('Bar', 'baz', 'Foo', 'ejemplo');

// imprimir la función copiada
echo Bar::baz();
?>

El resultado del ejemplo sería:

foo!

Ver también

  • classkit_method_add() - Añade dinámicamente un nuevo método una clase dada
  • classkit_method_redefine() - Cambia dinámicamente el código del método dado
  • classkit_method_remove() - Elimina dinámicamente el método dado
  • classkit_method_rename() - Cambia dinámicamente el nombre del método dado


Cambia dinámicamente el código del método dado

  • « classkit_method_copy
  • classkit_method_remove »
  • PHP Manual
  • Funciones de Classkit
  • Cambia dinámicamente el código del método dado

classkit_method_redefine

(PECL classkit >= 0.1)

classkit_method_redefine — Cambia dinámicamente el código del método dado

Descripción

classkit_method_redefine ( string $classname , string $methodname , string $args , string $code , int $flags = CLASSKIT_ACC_PUBLIC ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

classname

La clase el la que se va a redefinir el método

methodname

El nombre del método a redefinir

args

Lista de argumentos separados por coma para el método redefinido

code

El nuevo código a ser evaluado cuando methodname es llamado

flags

El método redefinido puede ser CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED o CLASSKIT_ACC_PRIVATE

Nota:

Este parámetro sólo se usa a partir de PHP 5, ya que, antes de esta versión, todos los métodos eran públicos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de classkit_method_redefine()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }
}

// crear un objeto de Ejemplo
$e = new Ejemplo();

// imprimir Ejemplo::foo() (antes de redefinir)
echo "Antes: " . $e->foo();

// Redefinir el método 'foo'
classkit_method_redefine(
    'Ejemplo',
    'foo',
    '',
    'return "bar!\n";',
    CLASSKIT_ACC_PUBLIC
);

// imprimir Ejemplo::foo() (después de redefinir)
echo "Después: " . $e->foo();
?>

El resultado del ejemplo sería:

Antes: foo!
Después: bar!

Ver también

  • classkit_method_add() - Añade dinámicamente un nuevo método una clase dada
  • classkit_method_copy() - Copia un método de una clase a otra
  • classkit_method_remove() - Elimina dinámicamente el método dado
  • classkit_method_rename() - Cambia dinámicamente el nombre del método dado


Elimina dinámicamente el método dado

  • « classkit_method_redefine
  • classkit_method_rename »
  • PHP Manual
  • Funciones de Classkit
  • Elimina dinámicamente el método dado

classkit_method_remove

(PECL classkit >= 0.1)

classkit_method_remove — Elimina dinámicamente el método dado

Descripción

classkit_method_remove ( string $classname , string $methodname ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

classname

La clase en la que se va a eliminar el método

methodname

El nombre del método a eliminar

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de classkit_method_remove()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Eliminar el método 'foo'
classkit_method_remove(
    'Ejemplo',
    'foo'
);

echo implode(' ', get_class_methods('Ejemplo'));

?>

El resultado del ejemplo sería:

bar

Ver también

  • classkit_method_add() - Añade dinámicamente un nuevo método una clase dada
  • classkit_method_copy() - Copia un método de una clase a otra
  • classkit_method_redefine() - Cambia dinámicamente el código del método dado
  • classkit_method_rename() - Cambia dinámicamente el nombre del método dado


Cambia dinámicamente el nombre del método dado

  • « classkit_method_remove
  • Ctype »
  • PHP Manual
  • Funciones de Classkit
  • Cambia dinámicamente el nombre del método dado

classkit_method_rename

(PECL classkit >= 0.1)

classkit_method_rename — Cambia dinámicamente el nombre del método dado

Descripción

classkit_method_rename ( string $classname , string $methodname , string $newname ) : bool

Nota: Esta función no puede ser utilizada para manipular el actual método en ejecución (o extendido).

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

classname

La clase en la que se va a renombrar el método

methodname

El nombre del método a renombrar

newname

El nuevo nombre a dar al método renombrado

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de classkit_method_rename()

<?php
class Ejemplo {
    function foo() {
        return "foo!\n";
    }
}

// Renombrar el método 'foo' a 'bar'
classkit_method_rename(
    'Ejemplo',
    'foo',
    'bar'
);

// imprimir la funcón renombrada
echo Ejemplo::bar();
?>

El resultado del ejemplo sería:

foo!

Ver también

  • classkit_method_add() - Añade dinámicamente un nuevo método una clase dada
  • classkit_method_copy() - Copia un método de una clase a otra
  • classkit_method_redefine() - Cambia dinámicamente el código del método dado
  • classkit_method_remove() - Elimina dinámicamente el método dado


Comprobación del tipo de carácter

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Ctype
    • ctype_alnum — Chequear posibles caracteres alfanuméricos
    • ctype_alpha — Chequear posibles caracteres alfabéticos
    • ctype_cntrl — Chequear posibles caracteres de control
    • ctype_digit — Chequear posibles caracteres numéricos
    • ctype_graph — Chequear posibles caracteres imprimibles, con excepción de los espacios
    • ctype_lower — Chequear posibles caracteres en minúscula
    • ctype_print — Chequear posibles caracteres imprimibles
    • ctype_punct — Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos
    • ctype_space — Chequear posibles caracteres de espacio en blanco
    • ctype_upper — Chequear posibles caracteres en mayúscula
    • ctype_xdigit — Chequear posibles caracteres que representen un dígito hexadecimal


Introducción

Las funciones proporcionadas con esta extensión comprueban si un carácter o string caen dentro de una cierta clase de caracteres según la configuración regional en uso (véase también setlocale()).

Cuando estas funciones se invocan con un argumento de tipo integer, se comportan exactamente como sus homólogas en C de ctype.h. Esto significa que si se pasa un valor de tipo integer menor que 256 se usará el valor ASCII del mismo para ver si encaja en el rango especificado (los dígitos están en el rango 0x30-0x39). Si el número está entre -128 y -1 inclusive, se añadirá 256 y la comprobación se hará sobre el resultado.

Cuando se invocan con un argumento de tipo string, comprobarán cada carácter de la cadena y sólo devolverá true si cada carácter de la cadena coincide con el criterio solicitado. Cuando se invocan con un string vacío, el resultado será siempre true en PHP < 5.1 y false desde 5.1.

Pasar cualquier cosa que no sea un valor de tipo string o integer devolverá inmediatamente false.

Se debería observar que siempre son preferibles las funciones de ctype a las expresiones regulares, e incluso a algunas funciones str_* y is_* equivalentes. Esto es así por el hecho de que ctype usa una biblioteca nativa de C y por lo tanto procesa significativamente más rápido.

Nota:

Estas funciones no están relacionadas con la biblioteca "ctypes" de Python de ningún modo. El nombre de la extensión proviene del fichero de cabecera ctype.h de C donde están definidas sus equivalentes.

Esta extensión también es anterior a "ctypes" de Python, por lo que cualquier confusión causada por este nombramiento apenas es por nuestra culpa...


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Nada excepto las funciones de la biblioteca C estándar que están siempre disponibles.


Instalación

El soporte de ctype se puede desactivar con --disable-ctype.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


  • « Tipos de recursos
  • Funciones de Ctype »
  • PHP Manual
  • Ctype
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Ctype

Tabla de contenidos

  • ctype_alnum — Chequear posibles caracteres alfanuméricos
  • ctype_alpha — Chequear posibles caracteres alfabéticos
  • ctype_cntrl — Chequear posibles caracteres de control
  • ctype_digit — Chequear posibles caracteres numéricos
  • ctype_graph — Chequear posibles caracteres imprimibles, con excepción de los espacios
  • ctype_lower — Chequear posibles caracteres en minúscula
  • ctype_print — Chequear posibles caracteres imprimibles
  • ctype_punct — Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos
  • ctype_space — Chequear posibles caracteres de espacio en blanco
  • ctype_upper — Chequear posibles caracteres en mayúscula
  • ctype_xdigit — Chequear posibles caracteres que representen un dígito hexadecimal


Chequear posibles caracteres alfanuméricos

  • « Funciones de Ctype
  • ctype_alpha »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres alfanuméricos

ctype_alnum

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_alnum — Chequear posibles caracteres alfanuméricos

Descripción

ctype_alnum ( string $text ) : bool

Chequea si todos los caracteres en la string entregada, texto, son alfanuméricos.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter de texto es o bien uno letra o un dígito, false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_alnum() (usando la localización predeterminada)

<?php
$cadenas = array('AbCd1zyZ9', 'foo!#$bar');
foreach ($cadenas as $caso_prueba) {
    if (ctype_alnum($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de letras o dígitos.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de letras o dígitos.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena AbCd1zyZ9 consiste completamente de letras o dígitos.
La cadena foo!#$bar no consiste completamente de letras o dígitos.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_alpha() - Chequear posibles caracteres alfabéticos
  • ctype_digit() - Chequear posibles caracteres numéricos
  • setlocale() - Establecer la información del localismo


Chequear posibles caracteres alfabéticos

  • « ctype_alnum
  • ctype_cntrl »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres alfabéticos

ctype_alpha

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_alpha — Chequear posibles caracteres alfabéticos

Descripción

ctype_alpha ( string $text ) : bool

Verifica si todos los caracteres en la string entregada,texto, son alfabéticos. En la localización C estándar las letras se limitan a [A-Za-z] y ctype_alpha() es equivalente a (ctype_upper($texto) || ctype_lower($texto)) si $texto es un caracter sencillo, aunque otros idiomas usan letras que no son consideradas como mayúsculas ni minúsculas.

Parámetros

text

El string de prueba.

Valores devueltos

Devuelve true si cada caracter de texto es una letra de la localización actual, false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_alpha() (usando la localización predeterminada)

<?php
$cadenas = array('KjgWZC', 'arf12');
foreach ($cadenas as $caso_prueba) {
    if (ctype_alpha($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de letras.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de letras.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena KjgWZC consiste completamente de letras.
La cadena arf12 no consiste completamente de letras.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_upper() - Chequear posibles caracteres en mayúscula
  • ctype_lower() - Chequear posibles caracteres en minúscula
  • setlocale() - Establecer la información del localismo


Chequear posibles caracteres de control

  • « ctype_alpha
  • ctype_digit »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres de control

ctype_cntrl

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_cntrl — Chequear posibles caracteres de control

Descripción

ctype_cntrl ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, son caracteres de control. Los caracteres de control son, por ejemplo, la alimentación de línea, el tabulador, escape.

Parámetros

text

El string de prueba.

Valores devueltos

Devuelve true si cada caracter de texto es un caracter de control de la localización actual, false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_cntrl()

<?php
$cadenas = array('cadena1' => "\n\r\t", 'cadena2' => 'arf12');
foreach ($cadenas as $nombre => $caso_prueba) {
    if (ctype_cntrl($caso_prueba)) {
        echo "La cadena '$nombre' consiste completamente de caracteres de control.\n";
    } else {
        echo "La cadena '$nombre' no consiste completamente de caracteres de control.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena 'cadena1' consiste completamente de caracteres de control.
La cadena 'cadena2' no consiste completamente de caracteres de control.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_print() - Chequear posibles caracteres imprimibles


Chequear posibles caracteres numéricos

  • « ctype_cntrl
  • ctype_graph »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres numéricos

ctype_digit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_digit — Chequear posibles caracteres numéricos

Descripción

ctype_digit ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, son numéricos.

Parámetros

text

La cadena probada.

Valores devueltos

Devuelve true si cada caracter del texto es un dígito decimal, o false de lo contrario.

Historial de cambios

Versión | Descripción
5.1.0 | En versiones anteriores a PHP 5.1.0, esta función devolvía true cuando text era una cadena vacía.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_digit()

<?php
$cadenas = array('1820.20', '10002', 'wsl!12');
foreach ($cadenas as $caso_prueba) {
    if (ctype_digit($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de dígitos.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de dígitos.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena 1820.20 no consiste completamente de dígitos.
La cadena 10002 consiste completamente de dígitos.
La cadena wsl!12 no consiste completamente de dígitos.

Ejemplo #2 Un ejemplo de ctype_digit() comparando strings con integers

<?php

$numeric_string = '42';
$integer        = 42;

ctype_digit($numeric_string);  // true
ctype_digit($integer);         // false (ASCII 42 es el caracter *)

is_numeric($numeric_string);   // true
is_numeric($integer);          // true
?>

Notas

Nota:

Esta función espera un string para ser útil, por ejemplo si pasamos un integer no puede devolver el resultado esperado. Sin embargo, nótese también los formularios HTML resultarán en strings numéricos y no en integers. Ver también la sección del manual tipos.

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_alnum() - Chequear posibles caracteres alfanuméricos
  • ctype_xdigit() - Chequear posibles caracteres que representen un dígito hexadecimal
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_string() - Comprueba si una variable es de tipo string


Chequear posibles caracteres imprimibles, con excepción de los espacios

  • « ctype_digit
  • ctype_lower »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres imprimibles, con excepción de los espacios

ctype_graph

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_graph — Chequear posibles caracteres imprimibles, con excepción de los espacios

Descripción

ctype_graph ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, generan una salida visible.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del texto es imprimible y genera alguna salida visible (no incluye los espacios), o false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_graph()

<?php
$cadenas = array('cadena1' => "asdf\n\r\t", 'cadena2' => 'arf12', 'cadena3' => 'LKA#@%.54');
foreach ($cadenas as $nombre => $caso_prueba) {
    if (ctype_graph($caso_prueba)) {
        echo "La cadena '$nombre' consiste completamente de caracteres (visiblemente) imprimibles.\n";
    } else {
        echo "La cadena '$nombre' no consiste completamente de caracteres (visiblemente) imprimibles.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena 'cadena1' no consiste completamente de caracteres (visiblemente) imprimibles.
La cadena 'cadena2' consiste completamente de caracteres (visiblemente) imprimibles.
La cadena 'cadena3' consiste completamente de caracteres (visiblemente) imprimibles.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_alnum() - Chequear posibles caracteres alfanuméricos
  • ctype_print() - Chequear posibles caracteres imprimibles
  • ctype_punct() - Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos


Chequear posibles caracteres en minúscula

  • « ctype_graph
  • ctype_print »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres en minúscula

ctype_lower

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_lower — Chequear posibles caracteres en minúscula

Descripción

ctype_lower ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, son letras minúsculas.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del texto es una letra minúscula en la localidad actual.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_lower() (usando la localidad predeterminada)

<?php
$cadenas = array('aac123', 'qiutoas', 'QASsdks');
foreach ($cadenas as $caso_prueba) {
    if (ctype_lower($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de letras minúsculas.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de letras minúsculas.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena aac123 no consiste completamente de letras minúsculas.
La cadena qiutoas consiste completamente de letras minúsculas.
La cadena QASsdks no consiste completamente de letras minúsculas.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_alpha() - Chequear posibles caracteres alfabéticos
  • ctype_upper() - Chequear posibles caracteres en mayúscula
  • setlocale() - Establecer la información del localismo


Chequear posibles caracteres imprimibles

  • « ctype_lower
  • ctype_punct »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres imprimibles

ctype_print

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_print — Chequear posibles caracteres imprimibles

Descripción

ctype_print ( string $text ) : bool

verifica si todos los caracteres en la string entregada, text, son imprimibles.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del texto genera realmente alguna salida (incluyendo los espacios). Devuelve false si el texto incluye caracteres de control o caracteres que no producen ninguna salida ni realizan función de control alguna después de todo.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_print()

<?php
$cadenas = array('cadena1' => "asdf\n\r\t", 'cadena2' => 'arf12', 'cadena3' => 'LKA#@%.54');
foreach ($cadenas as $nombre => $caso_prueba) {
    if (ctype_print($caso_prueba)) {
        echo "La cadena '$nombre' consiste completamente de caracteres imprimibles.\n";
    } else {
        echo "La cadena '$nombre' no consiste completamente de caracteres imprimibles.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena 'cadena1' no consiste completamente de caracteres imprimibles.
La cadena 'cadena2' consiste completamente de caracteres imprimibles.
La cadena 'cadena3' consiste completamente de caracteres imprimibles.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_cntrl() - Chequear posibles caracteres de control
  • ctype_graph() - Chequear posibles caracteres imprimibles, con excepción de los espacios
  • ctype_punct() - Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos


Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos

  • « ctype_print
  • ctype_space »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos

ctype_punct

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_punct — Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos

Descripción

ctype_punct ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, son caracteres de puntuación.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del text es imprimible, pero no es una letra, dígito o espacio en blanco; o false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_punct()

<?php
$cadenas = array('ABasdk!@!$#', '!@ # $', '*&$()');
foreach ($cadenas as $caso_prueba) {
    if (ctype_punct($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de signos de puntuación.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de signos de puntuación.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena ABasdk!@!$# no consiste completamente de signos de puntuación.
La cadena !@ # $ no consiste completamente de signos de puntuación.
La cadena *&$() consiste completamente de signos de puntuación.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_cntrl() - Chequear posibles caracteres de control
  • ctype_graph() - Chequear posibles caracteres imprimibles, con excepción de los espacios


Chequear posibles caracteres de espacio en blanco

  • « ctype_punct
  • ctype_upper »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres de espacio en blanco

ctype_space

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_space — Chequear posibles caracteres de espacio en blanco

Descripción

ctype_space ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, crean espacios en blanco.

Parámetros

text

El string de prueba.

Valores devueltos

Devuelve true si cada caracter del text genera cierto tipo de espacio en blanco, o false de lo contrario. Junto con el caracter regular de espacio en blanco, también se consideran espacios a los caracteres de tabulación, tabulación vertical, avance de línea, retorno de carro y avance de formulario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_space()

<?php
$strings = array(
    'string1' => "\n\r\t",
    'string2' => "\narf12",
    'string3' => '\n\r\t' // note las comillas simples
);
foreach ($strings as $name => $testcase) {
    if (ctype_space($testcase)) {
        echo "The string '$name' consists of whitespace characters only.\n";
    } else {
        echo "The string '$name' contains non-whitespace characters.\n";
    }
}
?>

El resultado del ejemplo sería:

The string 'string1' consists of whitespace characters only.
The string 'string2' contains non-whitespace characters.
The string 'string3' contains non-whitespace characters.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_cntrl() - Chequear posibles caracteres de control
  • ctype_graph() - Chequear posibles caracteres imprimibles, con excepción de los espacios
  • ctype_punct() - Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos


Chequear posibles caracteres en mayúscula

  • « ctype_space
  • ctype_xdigit »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres en mayúscula

ctype_upper

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_upper — Chequear posibles caracteres en mayúscula

Descripción

ctype_upper ( string $text ) : bool

Verifica si todos los caracteres en la string entregada, text, son caracteres en mayúsculas.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del text es una letra mayúscula en la localidad actual.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_upper() (usando la localidad predeterminada)

<?php
$cadenas = array('AKLWC139', 'LMNSDO', 'akwSKWsm');
foreach ($cadenas as $caso_prueba) {
    if (ctype_upper($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de letras mayúsculas.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de letras mayúsculas.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena AKLWC139 no consiste completamente de signos de letras mayúsculas.
La cadena LMNSDO consiste completamente de signos de letras mayúsculas.
La cadena akwSKWsm no consiste completamente de signos de letras mayúsculas.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_alpha() - Chequear posibles caracteres alfabéticos
  • ctype_lower() - Chequear posibles caracteres en minúscula
  • setlocale() - Establecer la información del localismo


Chequear posibles caracteres que representen un dígito hexadecimal

  • « ctype_upper
  • Filter »
  • PHP Manual
  • Funciones de Ctype
  • Chequear posibles caracteres que representen un dígito hexadecimal

ctype_xdigit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_xdigit — Chequear posibles caracteres que representen un dígito hexadecimal

Descripción

ctype_xdigit ( string $text ) : bool

Verifica si todos los caracteres de la string entregada, text, son 'dígitos' hexadecimales.

Parámetros

text

La cadena de prueba.

Valores devueltos

Devuelve true si cada caracter del text es un 'dígito' hexadecimal, lo que quiere decir un dígito decimal o un caracter del rango [A-Fa-f]; false de lo contrario.

Ejemplos

Ejemplo #1 Un ejemplo de ctype_xdigit()

<?php
$cadenas = array('AB10BC99', 'AR1012', 'ab12bc99');
foreach ($cadenas as $caso_prueba) {
    if (ctype_xdigit($caso_prueba)) {
        echo "La cadena $caso_prueba consiste completamente de dígitos hexadecimales.\n";
    } else {
        echo "La cadena $caso_prueba no consiste completamente de dígitos hexadecimales.\n";
    }
}
?>

El resultado del ejemplo sería:

La cadena AB10BC99 consiste completamente de dígitos hexadecimales.
La cadena AR1012 no consiste completamente de dígitos hexadecimales.
La cadena ab12bc99 consiste completamente de dígitos hexadecimales.

Notas

Nota:

Si se proporciona un integer entre -128 y 255 inclusive, se interpreta como el valor ASCII de un simple caráter (a los valores negativos se le añade 256 para permitir caracteres en el rango ASCII Extendido). Cualquier otro entero se interpreta como una cadena que contiene los dígitos decimales del entero.

Ver también

  • ctype_digit() - Chequear posibles caracteres numéricos


Filtrado de datos

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Tipos de filtros
    • Filtros de validación
    • Filtros de saneamiento
    • Otros filtros
    • Opciones de filtrado
  • Constantes predefinidas
  • Ejemplos
    • Validación
    • Saneamiento
  • Funciones de Filter
    • filter_has_var — Comprueba si existe una variable de un tipo concreto existe
    • filter_id — Indica el ID del nombre de filtro que se indique
    • filter_input_array — Obtiene variables externas y opcionalmente las filtra
    • filter_input — Toma una variable externa concreta por su nombre y opcionalmente la filtra
    • filter_list — Devuelve una lista de todos los filtros soportados
    • filter_var_array — Retorna múltiple variables y opcionalmente las filtra
    • filter_var — Filtra una variable con el filtro que se indique


Introducción

Esta extensión filtra los datos bien sea para validarlos o para sanearlos. Es especialmente útil cuando los datos de origen contienen datos desconocidos (o externos), como entradas facilitadas por el usuario. Por ejemplo, estos datos pueden venir de un formulario HTML.

Principalmente hay dos tipos de filtrado: validación y saneamiento.

La validación se usa para validar o comprobar si los datos cumplen ciertos requisitos. Por ejemplo, pasándole FILTER_VALIDATE_EMAIL determinará si los datos son una dirección de correo válida, pero no realizará ningún cambio en los datos.

El saneamiento limpiará los datos, de modo que los modificará eliminando los caracteres no deseados. Por ejemplo, pasándole FILTER_SANITIZE_EMAIL eliminará los caracteres que no son apropiados para una dirección de correo electrónico. Sin embargo, no valida los datos.

Las banderas se usan opcionalmente tanto con la validación como con el saneamiento para adaptar el comportamiento según las necesidades. Por ejemplo, al pasarle FILTER_FLAG_PATH_REQUIRED mientras se filtra un URL, se obliga a que esté presente una ruta (como /foo en http://example.org/foo).


Instalación

La extensión de filtrado está activada por defecto desde PHP 5.2.0. Anteriormente a esto se usaba una extensión PECL, sin embargo, esta extensión no se actualiza más ni se recomienda su uso.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de filtros
Nombre | Por defecto | Cambiable | Historial de cambios
filter.default | "unsafe_raw" | PHP_INI_PERDIR | PHP_INI_ALL en filter <= 0.9.4. Disponible desde PHP 5.2.0.
filter.default_flags | NULL | PHP_INI_PERDIR | PHP_INI_ALL en filter <= 0.9.4. Disponible desde PHP 5.2.0.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

filter.default string

Filtra todos los datos de $_GET, $_POST, $_COOKIE, $_REQUEST y $_SERVER. Es posible acceder a los datos originales a través de filter_input().

Acepta el nombre del filtro que se desea usar por defecto. Véase la lista de filtros existentes para obtener el nombre de los filtros disponibles.

Nota:

Tenga cuidado con los flags por omisión para los filtros predeterminados. De forma explícita debería establecerse en el valor que desee. Por ejemplo, para configurar el filtro predeterminado para que se comporte exactamente igual que htmlspecialchars() necesita establecer los flags por omisión a 0, como se muestra a continuación.

Ejemplo #1 Configuring the default filter to act like htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

filter.default_flags integer

Flags por omisión a aplicar cuando el filtro por defecto está establecido. Esto es establecido a FILTER_FLAG_NO_ENCODE_QUOTES por omisión por razones de compatibilidad con versiones anteriores. Véase la lista de flags existentes para una lista de todos los nombres de flags.


  • « Configuración en tiempo de ejecución
  • Tipos de filtros »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


Tipos de filtros

Tabla de contenidos

  • Filtros de validación
  • Filtros de saneamiento
  • Otros filtros
  • Opciones de filtrado


Filtros de validación

Listado de filtros para validación
ID | Nombre | Opciones | Banderas | Descripción
FILTER_VALIDATE_BOOLEAN | "boolean" | default | FILTER_NULL_ON_FAILURE | Devuelve true para "1", "true", "on" y "yes". Devuelve false en caso contrario. Si FILTER_NULL_ON_FAILURE está declarado, se devolverá false sólo para "0", "false", "off", "no", y "", y null para cualquier valor no booleano.
FILTER_VALIDATE_EMAIL | "validate_email" | default |  | Valida una dirección de correo electrónico. En general, se valildan direcciones de correo electrónico con la sintaxis de RFC 822, con la excepción de no admitir el plegamiento de comentarios y espacios en blanco.
FILTER_VALIDATE_FLOAT | "float" | default, decimal | FILTER_FLAG_ALLOW_THOUSAND | Valida si el valor es un float.
FILTER_VALIDATE_INT | "int" | default, min_range, max_range | FILTER_FLAG_ALLOW_OCTAL, FILTER_FLAG_ALLOW_HEX | Valida un valor como integer, opcionalmente desde el rango especificado, y lo convierte a int en case de éxito.
FILTER_VALIDATE_IP | "validate_ip" | default | FILTER_FLAG_IPV4, FILTER_FLAG_IPV6, FILTER_FLAG_NO_PRIV_RANGE, FILTER_FLAG_NO_RES_RANGE | Valida si es valor es una dirección IP, opcionalmente se puede indicar que sea sólo IPv4 o IPv6 o que no sea de rangos privados o reservados.
FILTER_VALIDATE_MAC | "validate_mac_address" | default |  | Valida una dirección MAC.
FILTER_VALIDATE_REGEXP | "validate_regexp" | default, regexp |  | Valida el valor contra regexp, una expresión regular Perl-compatible.
FILTER_VALIDATE_URL | "validate_url" | default | FILTER_FLAG_PATH_REQUIRED, FILTER_FLAG_QUERY_REQUIRED | Valida si su valor es una URL (de acuerdo con » http://www.faqs.org/rfcs/rfc2396), opcionalmente con componentes necesarios. Se ha de tener cuidado ya que un URL válida podría no especificar el protocolo HTTP http://, por lo que podrían ser necesarias validaciones posteriores para determinar que el URL utiliza un protocolo esperado, p.ej., ssh:// o mailto:. Nótese que esta función sólo buscará para ser validadas URLs ASCII; los nombres de dominio internacionales (que contienen no-ASCII caracteres) fallarán en la validación.

Nota:

A partir de PHP 5.4.11, los números +0 y -0 se validan tanto como integer y como float (empleando FILTER_VALIDATE_FLOAT y FILTER_VALIDATE_INT). Antes de PHP 5.4.11 solamente se validaban como float (empleando FILTER_VALIDATE_FLOAT).

Cuando default está establecido a option, se utilizará el valor de default si el valor no es validado.

Historial de cambios

Versión | Descripción
5.5.0 | Se añadió FILTER_VALIDATE_MAC


Filtros de saneamiento

Lista de filtros de saneamiento
ID | Nombre | Banderas | Descripción
FILTER_SANITIZE_EMAIL | "email" |  | Elimina todos los caracteres menos letras, dígitos y !#$%&'*+-=?^_`{|}~@.[].
FILTER_SANITIZE_ENCODED | "encoded" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH | String URL-encode, opcionalmente elimina o codifica caracteres especiales.
FILTER_SANITIZE_MAGIC_QUOTES | "magic_quotes" |  | Aplica addslashes().
FILTER_SANITIZE_NUMBER_FLOAT | "number_float" | FILTER_FLAG_ALLOW_FRACTION, FILTER_FLAG_ALLOW_THOUSAND, FILTER_FLAG_ALLOW_SCIENTIFIC | Elimina todos los caracteres a excepción de los dígitos, +- y, opcionalmente, .,eE.
FILTER_SANITIZE_NUMBER_INT | "number_int" |  | Elimina todos los caracteres excepto dígitos y los signos de suma y resta.
FILTER_SANITIZE_SPECIAL_CHARS | "special_chars" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_HIGH | Escapa caracteres HTML '"<>& y caracteres con valores ASCII menores que 32, opcionalmente elimina o codifica caracteres especiales.
FILTER_SANITIZE_FULL_SPECIAL_CHARS | "full_special_chars" | FILTER_FLAG_NO_ENCODE_QUOTES, | Equivalente a llamar a htmlspecialchars() con ENT_QUOTES establecido. Las comillas de codificación pueden ser desactivadas mediante el establecimiento de FILTER_FLAG_NO_ENCODE_QUOTES. Al igual que htmlspecialchars(), este filtro tiene en cuenta el default_charset y si en una secuencia de bytes se detecta que contiene un carácter no válido en el conjunto de caracteres actual entonces el string completo es rechazado lo que resulta en un string de longitud 0. Cuando se utiliza este filtro como un filtro predeterminado, vea la advertiencia de abajo sobre establecer las banderas predeterminadas a 0.
FILTER_SANITIZE_STRING | "string" | FILTER_FLAG_NO_ENCODE_QUOTES, FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Elimina etiquetas, opcionalmente elimina o codifica caracteres especiales.
FILTER_SANITIZE_STRIPPED | "stripped" |  | Alias del filtro "string".
FILTER_SANITIZE_URL | "url" |  | Elimina todos los caracteres excepto letras, dígitos y $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=.
FILTER_UNSAFE_RAW | "unsafe_raw" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | No hace nada, opcionalmente eliminar o codificar caracteres. Este filtro es un alias de FILTER_DEFAULT.

Advertencia

Cuando se utiliza uno de estos tres filtros como un filtro predetermindo a través de fichero ini o de la configuración del servidor web, las banderas predeterminadas son establecidas a FILTER_FLAG_NO_ENCODE_QUOTES. Se necesita establecer explícitamente filter.default_flags a 0 para tener la codificación de comillas por omisión. Como esto:

Ejemplo #1 Configurar el filtro predeterminado para que actúe como htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

Historial de cambios

Versión | Descripción
5.2.11/5.3.1 | Las barras (/) son eliminadas por FILTER_SANITIZE_EMAIL. Antes se mantenían.


Otros filtros

Lista de filtros varios
ID | Nombre | Opciones | Banderas | Descripción
FILTER_CALLBACK | "callback" | Función o método callable |  | Llamadas a funciones definidas por el usuario para filtrar datos.


Opciones de filtrado

Lista de opciones de los filtros
ID | Usado con | Descripción
FILTER_FLAG_STRIP_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Elimina caracteres que tienen un valor numérico <32.
FILTER_FLAG_STRIP_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Elimina caracteres que tienen un valor numérico >127.
FILTER_FLAG_ALLOW_FRACTION | FILTER_SANITIZE_NUMBER_FLOAT | Permite usar un punto (.) como separador de decimales en los números.
FILTER_FLAG_ALLOW_THOUSAND | FILTER_SANITIZE_NUMBER_FLOAT, FILTER_VALIDATE_FLOAT | Permite usar una coma (,) como separador de miles en los números.
FILTER_FLAG_ALLOW_SCIENTIFIC | FILTER_SANITIZE_NUMBER_FLOAT | Permite usar una e o E para la notación científica de números.
FILTER_FLAG_NO_ENCODE_QUOTES | FILTER_SANITIZE_STRING | Si se indica esta opción, las comillas simples (') y las dobles (") no se codificarán.
FILTER_FLAG_ENCODE_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Codifica todos los caracteres con valor numérico <32.
FILTER_FLAG_ENCODE_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Codifica todos los caracteres con valor numérico >127.
FILTER_FLAG_ENCODE_AMP | FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Codifica ampersands (&).
FILTER_NULL_ON_FAILURE | FILTER_VALIDATE_BOOLEAN | Devuelve null para valores boolean que no se reconozcan.
FILTER_FLAG_ALLOW_OCTAL | FILTER_VALIDATE_INT | Permite datos de entrada que comiencen por un cero (0) como número octal. Esto obliga a que los siguientes dígitos sean únicamente 0-7.
FILTER_FLAG_ALLOW_HEX | FILTER_VALIDATE_INT | Permite datos de entrada que comiencen por 0x o 0X como número hexadecimal. Esto obliga a que los siguientes dígitos sean únicamente a-fA-F0-9.
FILTER_FLAG_IPV4 | FILTER_VALIDATE_IP | Permite direcciones IP en formato IPv4.
FILTER_FLAG_IPV6 | FILTER_VALIDATE_IP | Permite direcciones IP en formato IPv6.
FILTER_FLAG_NO_PRIV_RANGE | FILTER_VALIDATE_IP | Falla si se intenta validar alguna de los siguientes rangos privados de IPv4: 10.0.0.0/8, 172.16.0.0/12 y 192.168.0.0/16. Falla si se intenta validad direcciones IPv6 que empiecen por FD o FC.
FILTER_FLAG_NO_RES_RANGE | FILTER_VALIDATE_IP | Falla si se intenta validad alguno de los siguientes rangos IPv4 reservados: 0.0.0.0/8, 169.254.0.0/16, 192.0.2.0/24 y 224.0.0.0/4. Este flag no se aplica a direcciones IPv6.
FILTER_FLAG_PATH_REQUIRED | FILTER_VALIDATE_URL | Requiere que el URL contenga parte de la ruta.
FILTER_FLAG_QUERY_REQUIRED | FILTER_VALIDATE_URL | Requiere que el URL contenga un query string.
FILTER_REQUIRE_SCALAR |  | Requiere que el valor sea escalar.
FILTER_REQUIRE_ARRAY |  | Requiere que el valor sea un array.
FILTER_FORCE_ARRAY |  | Si el valor es un escalar, es tratado como un array con el valor escalar cómo único elemento.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

INPUT_POST (integer)
Variables POST.
INPUT_GET (integer)
Variables GET.
INPUT_COOKIE (integer)
Variables COOKIE.
INPUT_ENV (integer)
Variables ENV.
INPUT_SERVER (integer)
Variables SERVER.
INPUT_SESSION (integer)
Variables SESSION. (no implementado aún)
INPUT_REQUEST (integer)
Variables REQUEST. (no implementada aún)
FILTER_FLAG_NONE (integer)
Sin banderas.
FILTER_REQUIRE_SCALAR (integer)
Bandera usada para requerir un escalar como entrada.
FILTER_REQUIRE_ARRAY (integer)
Requerir un array como entrada.
FILTER_FORCE_ARRAY (integer)
Devolver siempre un array.
FILTER_NULL_ON_FAILURE (integer)
Usar NULL en vez de FALSE en caso de fallo.
FILTER_VALIDATE_INT (integer)
ID del filtro "int".
FILTER_VALIDATE_BOOLEAN (integer)
ID del filtro "boolean".
FILTER_VALIDATE_FLOAT (integer)
ID del filtro "float".
FILTER_VALIDATE_REGEXP (integer)
ID del filtro "validate_regexp".
FILTER_VALIDATE_URL (integer)
ID del filtro "validate_url".
FILTER_VALIDATE_EMAIL (integer)
ID del filtro "validate_email".
FILTER_VALIDATE_IP (integer)
ID del filtro "validate_ip".
FILTER_VALIDATE_MAC (integer)
ID del filtro "validate_mac_address". (Disponible a partir de PHP 5.5.0)
FILTER_DEFAULT (integer)
ID del filtro ("unsafe_raw"). Equivale a FILTER_UNSAFE_RAW.
FILTER_UNSAFE_RAW (integer)
ID del filtro "unsafe_raw".
FILTER_SANITIZE_STRING (integer)
ID del filtro "string".
FILTER_SANITIZE_STRIPPED (integer)
ID del filtro "stripped".
FILTER_SANITIZE_ENCODED (integer)
ID del filtro "encoded".
FILTER_SANITIZE_SPECIAL_CHARS (integer)
ID del filtro "special_chars".
FILTER_SANITIZE_EMAIL (integer)
ID del filtro "email".
FILTER_SANITIZE_URL (integer)
ID del filtro "url".
FILTER_SANITIZE_NUMBER_INT (integer)
ID del filtro "number_int".
FILTER_SANITIZE_NUMBER_FLOAT (integer)
ID del filtro "number_float".
FILTER_SANITIZE_MAGIC_QUOTES (integer)
ID del filtro "magic_quotes".
FILTER_CALLBACK (integer)
ID del filtro "callback".
FILTER_FLAG_ALLOW_OCTAL (integer)
Permitir la notación octal (0[0-7]+) en el filtro "int".
FILTER_FLAG_ALLOW_HEX (integer)
Permitir la notación hexadecimal (0x[0-9a-fA-F]+) en el filtro "int".
FILTER_FLAG_STRIP_LOW (integer)
Eliminar caracteres con un valor ASCII inferior a 32.
FILTER_FLAG_STRIP_HIGH (integer)
Eliminar caracteres con un valor ASCII superior a 127.
FILTER_FLAG_ENCODE_LOW (integer)
Codificar caracteres con un valor ASCII inferior a 32.
FILTER_FLAG_ENCODE_HIGH (integer)
Codificar caracteres con un valor ASCII superior a 127.
FILTER_FLAG_ENCODE_AMP (integer)
Codificar el signo &.
FILTER_FLAG_NO_ENCODE_QUOTES (integer)
No codificar ' ni ".
FILTER_FLAG_EMPTY_STRING_NULL (integer)
(No usada por ahora.)
FILTER_FLAG_ALLOW_FRACTION (integer)
Permitir la parte decimal en el filtro "number_float".
FILTER_FLAG_ALLOW_THOUSAND (integer)
Permitir el separador de miles (,) en el filtro "number_float".
FILTER_FLAG_ALLOW_SCIENTIFIC (integer)
Permitir la notación científica (e, E) en el filtro "number_float".
FILTER_FLAG_PATH_REQUIRED (integer)
Requerir la ruta en el filtro "validate_url".
FILTER_FLAG_QUERY_REQUIRED (integer)
Requerir la consulta en el filtro "validate_url".
FILTER_FLAG_IPV4 (integer)
Permitir solamente direcciones IPv4 en el filtro "validate_ip".
FILTER_FLAG_IPV6 (integer)
Permitir solamente direcciones IPv6 en el filtro "validate_ip".
FILTER_FLAG_NO_RES_RANGE (integer)
Prohibir direcciones reservadas en el filtro "validate_ip".
FILTER_FLAG_NO_PRIV_RANGE (integer)
Prohibir direcciones privadas en el filtro "validate_ip".


  • « Constantes predefinidas
  • Validación »
  • PHP Manual
  • Filter
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Validación
  • Saneamiento


Validación

Ejemplo #1 Validación de direcciones de correo con filter_var()

<?php
$email_a = 'joe@example.com';
$email_b = 'bogus';

if (filter_var($email_a, FILTER_VALIDATE_EMAIL)) {
    echo "Esta dirección de correo ($email_a) es válida.";
}
if (filter_var($email_b, FILTER_VALIDATE_EMAIL)) {
    echo "Esta dirección de correo ($email_b) es válida.";
}
?>

El resultado del ejemplo sería:

Esta dirección de correo (joe@example.com) es válida.

Ejemplo #2 Validación de direcciones IP con filter_var()

<?php
$ip_a = '127.0.0.1';
$ip_b = '42.42';

if (filter_var($ip_a, FILTER_VALIDATE_IP)) {
    echo "Esta dirección IP (ip_a) es válida.";
}
if (filter_var($ip_b, FILTER_VALIDATE_IP)) {
    echo "Esta dirección IP (ip_b) es válida.";
}
?>

El resultado del ejemplo sería:

Esta dirección IP (ip_b) es válida.

Ejemplo #3 Pasando opciones a filter_var()

<?php
$int_a = '1';
$int_b = '-1';
$int_c = '4';
$options = array(
    'options' => array(
                      'min_range' => 0,
                      'max_range' => 3,
                      )
);
if (filter_var($int_a, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Este entero (int_a) es válido (entre 0 y 3).\n";
}
if (filter_var($int_b, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Este entero (int_b) es válido (entre 0 y 3).\n";
}
if (filter_var($int_c, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Este entero (int_c) es válido (entre 0 y 3).\n";
}

$options['options']['default'] = 1;
if (($int_c = filter_var($int_c, FILTER_VALIDATE_INT, $options)) !== FALSE) {
    echo "Este entero (int_c) es válido (entre 0 y 3) y es $int_c.";
}
?>

El resultado del ejemplo sería:

Este entero (int_a) es válido (entre 0 y 3).
Este entero (int_c) es válido (entre 0 y 3) y es 1.


Saneamiento

Ejemplo #1 Saneando y validando direcciones de correo

<?php
$a = 'joe@example.org';
$b = 'bogus - at - example dot org';
$c = '(bogus@example.org)';

$sanitized_a = filter_var($a, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_a, FILTER_VALIDATE_EMAIL)) {
    echo "Esta dirección de correo saneada (a) es válida.\n";
}

$sanitized_b = filter_var($b, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_b, FILTER_VALIDATE_EMAIL)) {
    echo "Esta dirección de correo saneada (b) es válida.\n";
} else {
    echo "Esta dirección de correo saneada (b) no es válida.\n";
}

$sanitized_c = filter_var($c, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_c, FILTER_VALIDATE_EMAIL)) {
    echo "Esta dirección de correo saneada (c) es válida.\n";
    echo "Antes: $c\n";
    echo "Después:  $sanitized_c\n";
}
?>

El resultado del ejemplo sería:

Esta dirección de correo saneada (a) es válida.
Esta dirección de correo saneada (b) no es válida.
Esta dirección de correo saneada (c) es válida.
Antes: (bogus@example.org)
Después: bogus@example.org

Ejemplo #2 Configuración de un filtro por omisión

filter.default = full_special_chars
filter.default_flags = 0


Funciones de Filter

Tabla de contenidos

  • filter_has_var — Comprueba si existe una variable de un tipo concreto existe
  • filter_id — Indica el ID del nombre de filtro que se indique
  • filter_input_array — Obtiene variables externas y opcionalmente las filtra
  • filter_input — Toma una variable externa concreta por su nombre y opcionalmente la filtra
  • filter_list — Devuelve una lista de todos los filtros soportados
  • filter_var_array — Retorna múltiple variables y opcionalmente las filtra
  • filter_var — Filtra una variable con el filtro que se indique


Comprueba si existe una variable de un tipo concreto existe

  • « Funciones de Filter
  • filter_id »
  • PHP Manual
  • Funciones de Filter
  • Comprueba si existe una variable de un tipo concreto existe

filter_has_var

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_has_var — Comprueba si existe una variable de un tipo concreto existe

Descripción

filter_has_var ( int $type , string $variable_name ) : bool

Parámetros

type

Una de estas posibilidades: INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER o INPUT_ENV.

variable_name

Nombre de la variable a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Indica el ID del nombre de filtro que se indique

  • « filter_has_var
  • filter_input_array »
  • PHP Manual
  • Funciones de Filter
  • Indica el ID del nombre de filtro que se indique

filter_id

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_id — Indica el ID del nombre de filtro que se indique

Descripción

filter_id ( string $filtername ) : int

Parámetros

filtername

Nombre del filtro a obtener el ID.

Valores devueltos

ID del filtro en caso de éxito o false si el filtro no existe.

Ver también

  • filter_list() - Devuelve una lista de todos los filtros soportados


Obtiene variables externas y opcionalmente las filtra

  • « filter_id
  • filter_input »
  • PHP Manual
  • Funciones de Filter
  • Obtiene variables externas y opcionalmente las filtra

filter_input_array

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_input_array — Obtiene variables externas y opcionalmente las filtra

Descripción

filter_input_array ( int $type , mixed $definition = ? , bool $add_empty = true ) : mixed

Esta función es útil para recuperar muchos valores sin necesidad de hacer repetidas llamadas a filter_input().

Parámetros

type

Una de las siguientes: INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER o INPUT_ENV.

definition

Un array definiendo los argumentos. Una clave válida será aquella que contiene un string con el nombre de una variable y un valor válido aquel que o bien es un tipo filter type o un array especificando opcionalmente el filtro, flags y opciones. Si el valor es un array, las claves válidas serán: filter que especifica el tipo filter type, flags que define cualquier flag que deba aplicarse a los filtros, y options que establece cualquier opción que se deba aplicar al filtro. Para entender mejor su funcionamiento, vea el ejemplo inferior.

Este parámetro puede ser también un entero que indique una constante de filtro. Entonces todos los valores en el array de entrada son filtrados por ese filtro.

add_empty

Añade claves faltantes como null al valor devuelto.

Valores devueltos

En caso de éxito, un array con los valores de las variables que se han pedido o false en caso de fallo. Un valor del array puede ser false si el filtro falla o null si la variable no está creada. O, si se usa el flag FILTER_NULL_ON_FAILURE y la variable no está definida retorna false y null si el filtro falla.

Ejemplos

Ejemplo #1 Un ejemplo con filter_input_array()

<?php
error_reporting(E_ALL | E_STRICT);
/* Los datos vienen realmente por POST
$_POST = array(
    'id_producto'    => 'libgd<script>',
    'componente'     => '10',
    'version'      => '2.0.33',
    'test_escalar'    => array('2', '23', '10', '12'),
    'test_array'     => '2',
);
*/

$args = array(
    'id_producto'   => FILTER_SANITIZE_ENCODED,
    'componente'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_REQUIRE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'version'     => FILTER_SANITIZE_ENCODED,
    'no_existe' => FILTER_VALIDATE_INT,
    'test_escalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'test_array'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_ARRAY,
                           )

);

$mis_entradas = filter_input_array(INPUT_POST, $args);

var_dump($mis_entradas);
echo "\n";
?>

El resultado del ejemplo sería:

array(6) {
  ["id_producto"]=>
  array(1) {
    [0]=>
    string(17) "libgd%3Cscript%3E"
  }
  ["componente"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["version"]=>
  array(1) {
    [0]=>
    string(6) "2.0.33"
  }
  ["no_existe"]=>
  NULL
  ["test_escalar"]=>
  bool(false)
  ["test_array"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro add_empty.

Notas

Nota:

No existe la clave REQUEST_TIME en la matriz INPUT_SERVER porque este valor se inserta posteriormente en $_SERVER.

Ver también

  • filter_input() - Toma una variable externa concreta por su nombre y opcionalmente la filtra
  • filter_var_array() - Retorna múltiple variables y opcionalmente las filtra
  • Tipos de filtros


Toma una variable externa concreta por su nombre y opcionalmente la filtra

  • « filter_input_array
  • filter_list »
  • PHP Manual
  • Funciones de Filter
  • Toma una variable externa concreta por su nombre y opcionalmente la filtra

filter_input

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_input — Toma una variable externa concreta por su nombre y opcionalmente la filtra

Descripción

filter_input ( int $type , string $variable_name , int $filter = FILTER_DEFAULT , mixed $options = ? ) : mixed

Parámetros

type

Uno de los siguientes: INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER o INPUT_ENV.

variable_name

Nombre de la variable a escoger.

filter

El ID del filtro a aplicar. La página Tipos de filtros del manual enumera los filtros disponibles.

Si se omite, se utilizará FILTER_DEFAULT, que es equivalente a FILTER_UNSAFE_RAW. Esto resultará en que no se realice ningún tipo de filtro de forma predeterminada.

options

Array asociativo de opciones o disyunción lógica de flags. Si el filtro acepta opciones, se pueden añadir flags en el array asociativo bajo la clave "flags".

Valores devueltos

En caso de éxito, valor de la variable pedida, false si el filtro falla o null si la variable variable_name no está definida. Si se usa el flag FILTER_NULL_ON_FAILURE, retorna false si la variable no está definida y null si el filtro falla.

Ejemplos

Ejemplo #1 Un ejemplo de filter_input()

<?php
$buscar_html = filter_input(INPUT_GET, 'buscar', FILTER_SANITIZE_SPECIAL_CHARS);
$buscar_url = filter_input(INPUT_GET, 'buscar', FILTER_SANITIZE_ENCODED);
echo "Has buscado $buscar_html.\n";
echo "<a href='?buscar=$buscar_url'>Buscar de nuevo</a>";
?>

El resultado del ejemplo sería algo similar a:

Has buscado Yo & hijo.
<a href='?buscar=Yo%20%26%20hijo'>Buscar de nuevo</a>

Ver también

  • filter_var() - Filtra una variable con el filtro que se indique
  • filter_input_array() - Obtiene variables externas y opcionalmente las filtra
  • filter_var_array() - Retorna múltiple variables y opcionalmente las filtra
  • Tipos de filtros


Devuelve una lista de todos los filtros soportados

  • « filter_input
  • filter_var_array »
  • PHP Manual
  • Funciones de Filter
  • Devuelve una lista de todos los filtros soportados

filter_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_list — Devuelve una lista de todos los filtros soportados

Descripción

filter_list ( ) : array

Valores devueltos

Retorna un array con los nombres de todos los filtros soportados; el array estará vacío si no hay filtros. Los índices de este array no son los IDs de los filtros, estos se obtienen a partir del nombre y la función filter_id().

Ejemplos

Ejemplo #1 Ejemplo de filter_list()

<?php
print_r(filter_list());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => string
    [8] => stripped
    [9] => encoded
    [10] => special_chars
    [11] => unsafe_raw
    [12] => email
    [13] => url
    [14] => number_int
    [15] => number_float
    [16] => magic_quotes
    [17] => callback
)


Retorna múltiple variables y opcionalmente las filtra

  • « filter_list
  • filter_var »
  • PHP Manual
  • Funciones de Filter
  • Retorna múltiple variables y opcionalmente las filtra

filter_var_array

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_var_array — Retorna múltiple variables y opcionalmente las filtra

Descripción

filter_var_array ( array $data , mixed $definition = ? , bool $add_empty = true ) : mixed

Esta función es útil para recuperar muchos valores sin llamar repetidamente a filter_var().

Parámetros

data

Un array asociativo de claves en formato strings que contiene los datos a filtrar.

definition

Un array definiendo los argumentos. Una clave válida será aquella que contiene un string con el nombre de una variable y un valor válido aquel que o bien es un tipo filter type o un array especificando opcionalmente el filtro, flags y opciones. Si el valor es un array, las claves válidas serán: filter que especifica el tipo filter type, flags que define cualquier flag que deba aplicarse a los filtros, y options que establece cualquier opción que se deba aplicar al filtro. Para entender mejor su funcionamiento, vea el ejemplo inferior.

Este parámetro puede ser tambien un integer indicando una constante de filtro.. Entonces, todos los valores en el array de entrada son filtrados por este filtro.

add_empty

Añade claves faltantes como null al valor devuelto.

Valores devueltos

En caso de éxito un array que contiene los valores de las variables que se han pedido o false en caso de fallo. El valor del array será false si el filtro falla o null si la variable no está definida.

Ejemplos

Ejemplo #1 Ejemplo de filter_var_array()

<?php
error_reporting(E_ALL | E_STRICT);
$data = array(
    'id_producto'    => 'libgd<script>',
    'componente'     => '10',
    'versiones'      => '2.0.33',
    'test_escalar'    => array('2', '23', '10', '12'),
    'test_array'     => '2',
);

$args = array(
    'id_producto'   => FILTER_SANITIZE_ENCODED,
    'componente'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_FORCE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versiones'     => FILTER_SANITIZE_ENCODED,
    'no_existe' => FILTER_VALIDATE_INT,
    'test_scalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'test_array'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_FORCE_ARRAY,
                           )

);

$myinputs = filter_var_array($data, $args);

var_dump($myinputs);
echo "\n";
?>

El resultado del ejemplo sería:

array(6) {
  ["id_producto"]=>
  string(17) "libgd%3Cscript%3E"
  ["componente"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versiones"]=>
  string(6) "2.0.33"
  ["no_existe"]=>
  NULL
  ["test_escalar"]=>
  bool(false)
  ["test_array"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro add_empty.

Ver también

  • filter_input_array() - Obtiene variables externas y opcionalmente las filtra
  • filter_var() - Filtra una variable con el filtro que se indique
  • filter_input() - Toma una variable externa concreta por su nombre y opcionalmente la filtra
  • Tipos de filtros


Filtra una variable con el filtro que se indique

  • « filter_var_array
  • Manejo de Funciones »
  • PHP Manual
  • Funciones de Filter
  • Filtra una variable con el filtro que se indique

filter_var

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_var — Filtra una variable con el filtro que se indique

Descripción

filter_var ( mixed $variable , int $filter = FILTER_DEFAULT , mixed $options = ? ) : mixed

Parámetros

variable

Valor a filtrar

filter

El ID del filtro a aplicar. La página Tipos de filtros del manual enumera los filtros disponibles.

Si se omite, se utilizará FILTER_DEFAULT, que es equivalente a FILTER_UNSAFE_RAW. Esto resultará en que no se realice ningún tipo de filtro de forma predeterminada.

options

Array asociativo de opciones o disyunción lógica de flags. Si un filtro acepta opciones, se pueden indicar flags en el campo "flags" del array. Para el filtro "callback" debería pasarse el tipo callable. La llamada de la función de retorno (callback) debe aceptar un argumento, el valor a ser filtrado y debe retornar el valor tras su filtrado/saneamiento.

<?php
// Para filtros que acepten opciones, usar este formato
$opciones = array(
    'options' => array(
        'default' => 3, // valor a retornar si el filtro falla
        // más opciones aquí
        'min_range' => 0
    ),
    'flags' => FILTER_FLAG_ALLOW_OCTAL,
);
$var = filter_var('0755', FILTER_VALIDATE_INT, $opciones);

// Para filtros que únicamente acepten flags, se pueden pasar directametne
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN, FILTER_NULL_ON_FAILURE);

// Para filtros que únicamente acepten flags, también pueden pasarse como
// array
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN,
                  array('flags' => FILTER_NULL_ON_FAILURE));

// Filtro "callback2
function foo($value)
{
    // Formato esperado: Apellido, Nombre
    if (strpos($value, ", ") === false) return false;
    list($surname, $givennames) = explode(", ", $value, 2);
    $empty = (empty($surname) || empty($givennames));
    $notstrings = (!is_string($surname) || !is_string($givennames));
    if ($empty || $notstrings) {
        return false;
    } else {
        return $value;
    }
}
$var = filter_var('Doe, Jane Sue', FILTER_CALLBACK, array('options' => 'foo'));
?>

Valores devueltos

Retorna los datos filtrados o false si el filtro falla.

Ejemplos

Ejemplo #1 Un ejemplo de filter_var()

<?php
var_dump(filter_var('bob@example.com', FILTER_VALIDATE_EMAIL));
var_dump(filter_var('http://example.com', FILTER_VALIDATE_URL, FILTER_FLAG_PATH_REQUIRED));
?>

El resultado del ejemplo sería:

string(15) "bob@example.com"
bool(false)

Ver también

  • filter_var_array() - Retorna múltiple variables y opcionalmente las filtra
  • filter_input() - Toma una variable externa concreta por su nombre y opcionalmente la filtra
  • filter_input_array() - Obtiene variables externas y opcionalmente las filtra
  • Tipos de filtros


Manejo de Funciones

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de Manejo de Funciones
    • call_user_func_array — Llamar a una llamada de retorno con un array de parámetros
    • call_user_func — Llamar a una llamada de retorno dada por el primer parámetro
    • create_function — Crear una función anónima (estilo lambda)
    • forward_static_call_array — Llamar a un método estático y pasar los argumentos como matriz
    • forward_static_call — Llamar a un método estático
    • func_get_arg — Devuelve un elemento de una lista de argumentos
    • func_get_args — Devuelve un array que se compone de una lista de argumentos de función
    • func_num_args — Devuelve el número de argumentos pasados a la función
    • function_exists — Devuelve true si la función dada ha sido definida
    • get_defined_functions — Devuelve un array de todas las funciones definidas
    • register_shutdown_function — Registrar una función para que sea ejecutada al cierre
    • register_tick_function — Registrar una función para que sea ejecutada en cada tick
    • unregister_tick_function — Dejar de registrar una función para su ejecución en cada tick


  • « Manejo de Funciones
  • Instalación/Configuración »
  • PHP Manual
  • Manejo de Funciones
  • Introducción

Introducción

Todas estas funciones tratan varias operaciones involucradas al trabajar con funciones.


  • « Tipos de recursos
  • Funciones de Manejo de Funciones »
  • PHP Manual
  • Manejo de Funciones
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de Manejo de Funciones

Tabla de contenidos

  • call_user_func_array — Llamar a una llamada de retorno con un array de parámetros
  • call_user_func — Llamar a una llamada de retorno dada por el primer parámetro
  • create_function — Crear una función anónima (estilo lambda)
  • forward_static_call_array — Llamar a un método estático y pasar los argumentos como matriz
  • forward_static_call — Llamar a un método estático
  • func_get_arg — Devuelve un elemento de una lista de argumentos
  • func_get_args — Devuelve un array que se compone de una lista de argumentos de función
  • func_num_args — Devuelve el número de argumentos pasados a la función
  • function_exists — Devuelve true si la función dada ha sido definida
  • get_defined_functions — Devuelve un array de todas las funciones definidas
  • register_shutdown_function — Registrar una función para que sea ejecutada al cierre
  • register_tick_function — Registrar una función para que sea ejecutada en cada tick
  • unregister_tick_function — Dejar de registrar una función para su ejecución en cada tick


Llamar a una llamada de retorno con un array de parámetros

  • « Funciones de Manejo de Funciones
  • call_user_func »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Llamar a una llamada de retorno con un array de parámetros

call_user_func_array

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

call_user_func_array — Llamar a una llamada de retorno con un array de parámetros

Descripción

call_user_func_array ( callable $callback , array $param_arr ) : mixed

Llama a la llamada de retorno dada por el primer parámetro callback con los parámetros de param_arr.

Parámetros

callback

La función llamable (callable) a llamar.

param_arr

Los parámetros a pasar a la llamada de retorno, como matriz indexada.

Valores devueltos

Devuelve el valor devuelto por la llamada de retorno, o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | La interpretación de palabras clave orientadas a objetos como parent y self ha cambiado. Anteriormente al llamarlas usando la sintaxis de dobles dos puntos emitiría una advertencia E_STRICT porque eran interpretadas como estáticas.

Ejemplos

Ejemplo #1 Ejemplo de call_user_func_array()

<?php
function foobar($arg, $arg2) {
    echo __FUNCTION__, " obtuvo $arg y $arg2\n";
}
class foo {
    function bar($arg, $arg2) {
        echo __METHOD__, " obtuvo $arg y $arg2\n";
    }
}

// Llamar a la función foobar() con 2 argumentos
call_user_func_array("foobar", array("uno", "dos"));

// Llamar al método $foo->bar() con 2 argumentos
$foo = new foo;
call_user_func_array(array($foo, "bar"), array("tres", "cuatro"));
?>

El resultado del ejemplo sería algo similar a:

foobar obtuvo uno y dos
foo::bar obtuvo tres y cuatro

Ejemplo #2 call_user_func_array() usando un nombre de espacio de nombres

<?php

namespace Foobar;

class Foo {
    static public function prueba($nombre) {
        print "¡Hola {$nombre}!\n";
    }
}

// A partir de PHP 5.3.0
call_user_func_array(__NAMESPACE__ .'\Foo::prueba', array('Gema'));

// A partir de PHP 5.3.0
call_user_func_array(array(__NAMESPACE__ .'\Foo', 'prueba'), array('Pedro'));

?>

El resultado del ejemplo sería algo similar a:

¡Hola Gema!
¡Hola Pedro!

Ejemplo #3 Usar una función lambda

<?php

$func = function($arg1, $arg2) {
    return $arg1 * $arg2;
};

var_dump(call_user_func_array($func, array(2, 4))); /* A partir de PHP 5.3.0 */

?>

El resultado del ejemplo sería:

int(8)

Notas

Nota:

Antes de PHP 5.4, las variables referenciadas de param_arr son pasadas a la función por referencia, sin tener en cuenta si la función espera que el parámetro respectivo sea pasado por referencia. Esta forma de paso por referncia en tiempo de llamda no emite un aviso de obsolescencia, pero, no obstante, está obsoleta, y ha sido eliminada en PHP 5.4. Además, esto no se aplica a funciones internas, para las que la firma de la funcion es aceptada. Pasar por valor cuando la función espera un parámetro por referencia resulta en una advertencia, y call_user_func() devolverá false (existe, sin embargo, una excepción para valores pasados con cuenta de referencia = 1, como en los literales, ya que pueden convertirse en referencias sin efectos dañinos — aunque también sin escribir que esos valores tengan ningún efecto —; sin embargo, no confíe en este comportamiento, ya que la cuenta de referencia es un detalle de implementación y la solidez de este comportamiento es cuestinable).

Nota:

Las funciones de retorno de llamada que se registran con funciones como call_user_func() y call_user_func_array() no se llamarán si se produce una excepción en la función de retorno previa.

Ver también

  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro
  • ReflectionFunction::invokeArgs() - Invoca a la función con argumentos
  • ReflectionMethod::invokeArgs() - Invoca un método con argumentos


Llamar a una llamada de retorno dada por el primer parámetro

  • « call_user_func_array
  • create_function »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Llamar a una llamada de retorno dada por el primer parámetro

call_user_func

(PHP 4, PHP 5, PHP 7, PHP 8)

call_user_func — Llamar a una llamada de retorno dada por el primer parámetro

Descripción

call_user_func ( callable $callback , mixed $parameter = ? , mixed $... = ? ) : mixed

Llama a la llamada de retorno dada por el primer parámetro callback y pasa los parámetros restantes como argumentos.

Parámetros

callback

La función llamable (callable) a llamar.

parameter

Cero o más parámetros a pasar a la llamda de retorno.

Nota:

Observe que los parámetros para call_user_func() no son pasados por referencia.

Ejemplo #1 Ejemplo de call_user_func() y referencias

<?php
error_reporting(E_ALL);
function incrementar(&$var)
{
    $var++;
}

$a = 0;
call_user_func('incrementar', $a);
echo $a."\n";

// En su lugar se puede usar esto
call_user_func_array('incrementar', array(&$a));
echo $a."\n";
?>

El resultado del ejemplo sería:

0
1

Valores devueltos

Devuelve el valor devuelto por la llamada de retorno, o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | La interpretación de palabras clave orientadas a objetos como parent y self ha cambiado. Anteriormente al llamarlas usando la sintaxis de dobles dos puntos emitiría una advertencia E_STRICT porque eran interpretadas como estáticas.

Ejemplos

Ejemplo #2 Ejemplo de call_user_func()

<?php
function barbero($tipo)
{
    echo "Usted quiere un corte de pelo al estilo $tipo, sin problemas\n";
}
call_user_func('barbero', "seta");
call_user_func('barbero', "rapado");
?>

El resultado del ejemplo sería:

Usted quiere un corte de pelo al estilo seta, sin problemas
Usted quiere un corte de pelo al estilo rapado, sin problemas

Ejemplo #3 call_user_func() usando un nombre de espacios de nombres

<?php

namespace Foobar;

class Foo {
    static public function prueba() {
        print "¡Hola mundo!\n";
    }
}

call_user_func(__NAMESPACE__ .'\Foo::prueba'); // A partir de PHP 5.3.0
call_user_func(array(__NAMESPACE__ .'\Foo', 'prueba')); // A partir de PHP 5.3.0

?>

El resultado del ejemplo sería:

¡Hola mundo!
¡Hola mundo!

Ejemplo #4 Usar un método de clase con call_user_func()

<?php

class miclase {
    static function saludar()
    {
        echo "¡Hola!\n";
    }
}

$nombreclase = "miclase";

call_user_func(array($nombreclase, 'saludar'));
call_user_func($nombreclase .'::saludar'); // A partir de 5.2.3

$miobjeto = new miclase();

call_user_func(array($miobjeto, 'saludar'));

?>

El resultado del ejemplo sería:

¡Hola!
¡Hola!
¡Hola!

Ejemplo #5 Usar una función lambda con call_user_func()

<?php
call_user_func(function($arg) { print "[$arg]\n"; }, 'prueba'); /* A partir de PHP 5.3.0 */
?>

El resultado del ejemplo sería:

[prueba]

Notas

Nota:

Las funciones de retorno de llamada que se registran con funciones como call_user_func() y call_user_func_array() no se llamarán si se produce una excepción en la función de retorno previa.

Ver también

  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función
  • ReflectionFunction::invoke() - Invoca una función
  • ReflectionMethod::invoke() - Invoca un método


Crear una función anónima (estilo lambda)

  • « call_user_func
  • forward_static_call_array »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Crear una función anónima (estilo lambda)

create_function

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

create_function — Crear una función anónima (estilo lambda)

Descripción

create_function ( string $args , string $code ) : string

Crea una función anónima desde los parámetros pasados, y devuelve un nombre único para ella.

Precaución

Esta función realiza internamente un eval() y como tal tiene los mismos problemas de seguridad que eval(). Además posee características malas de rendimiento y uso de memoria.

Si se usa 5.3.0 o superior, se debería usar en su lugar una función anónima nativa.

Parámetros

Normalmente estos parámetros serán pasados como una cadena entre comillas simples. La razón de usar comillas simples es proteger a los nombres de las variables de ser analizados, de otro modo, si se usan comillas dobles habrá necesidad de escapar los nombres de las variables, p.ej. \$avar.

args

Los argumentos de la función.

code

El código de la función.

Valores devueltos

Devuelve un nombre de función único como cadena, o false en caso de error.

Ejemplos

Ejemplo #1 Crear una función anónima con create_function()

Se puede usar esta función para, por ejemplo, crear una función desde información reunida en tiempo de ejecución:

<?php
$nuevafunc = create_function('$a,$b', 'return "ln($a) + ln($b) = " . log($a * $b);');
echo "Nueva función anónima: $nuevafunc\n";
echo $nuevafunc(2, M_E) . "\n";
// imprime
// Nueva función anónima: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599
?>

O quizás para tener una función gestora general que pueda aplicar un conjunto de operaciones a una lista de parámetros:

Ejemplo #2 Hacer una función de proceso general con create_function()

<?php
function procesar($var1, $var2, $farr)
{
    foreach ($farr as $f) {
        echo $f($var1, $var2) . "\n";
    }
}

// crear un puñado de funciones matemáticas
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b; } else { return false; }';
$farr = array(
    create_function('$x,$y', 'return "algo de trigonometría: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "una hipotenusa: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nUsar la primera matriz de funciones anónimas\n";
echo "parámetros: 2.3445, M_PI\n";
procesar(2.3445, M_PI, $farr);

// ahora hacer un puñado de funciones de proceso de cadenas
$garr = array(
    create_function('$b,$a', 'if (strncmp($a, $b, 3) == 0) return "** \"$a\" '.
    'y \"$b\"\n** ¡Para mí se parecen! (mirando los 3 primeros caracteres)";'),
    create_function('$a,$b', '; return "CRCs: " . crc32($a) . ", ".crc32($b);'),
    create_function('$a,$b', '; return "similar(a,b) = " . similar_text($a, $b, &$p) . "($p%)";')
    );
echo "\nUsar la segunda matriz de funciones anónimas\n";
procesar("Cuando los pájaros cantan", "Cuando es de noche", $garr);
?>

El resultado del ejemplo sería:

Usar la primera matriz de funciones anónimas
parámetros: 2.3445, M_PI
algo de trigonometría: -1.6291725057799
una hipotenusa: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a)/b = 0.27122299212594

Usar la segunda matriz de funciones anónimas
** "Cuando es de noche" y "Cuando los pájaros cantan"
** ¡Para mí se parecen! (mirando los 3 primeros caracteres)
CRCs: -725381282, 342550513
similar(a,b) = 11(45.833333333333%)

Pero quizás el uso más común de las funciones estilo lambda (anónimas) sea el de crear funciones de llamada de retorno, por ejemplo cuando se usa array_walk() o usort()

Ejemplo #3 Usar funciones anónimas como funciones de llamada de retorno

<?php
$av = array("el ", "un ", "ese ", "este ");
array_walk($av, create_function('&$v,$k', '$v = $v . "mango";'));
print_r($av);
?>

El resultado del ejemplo sería:

Array
(
  [0] => el mango
  [1] => un mango
  [2] => ese mango
  [3] => este mango
)

una matriz de cadenas ordenada de más corta a más larga

<?php

$sv = array("pequeña", "más larga", "una gran cadena", "esto es una 'señora' cadena");
print_r($sv);

?>

El resultado del ejemplo sería:

Array
(
  [0] => pequeña
  [1] => más larga
  [2] => una gran cadena
  [3] => esto es una 'señora' cadena
)

ordenarla de más larga a más corta

<?php

usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);

?>

El resultado del ejemplo sería:

Array
(
  [0] => esto es una 'señora' cadena
  [1] => una gran cadena
  [2] => más larga
  [3] => pequeña
)

Ver también

  • Funciones anónimas


Llamar a un método estático y pasar los argumentos como matriz

  • « create_function
  • forward_static_call »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Llamar a un método estático y pasar los argumentos como matriz

forward_static_call_array

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

forward_static_call_array — Llamar a un método estático y pasar los argumentos como matriz

Descripción

forward_static_call_array ( callable $function , array $parameters ) : mixed

Llama a una función o método definido por el usuario, dado por el parámetro function. Esta función debe ser llamada dentro del contexto de un método, no se puede usar fuera de una clase. Usa el Enlace estático en tiempo de ejecución. Todos los argumentos del método a llamar se pasan como valores, y como matriz, similar a call_user_func_array().

Parámetros

function

La función o método a ser llamado. Este parámetro puede ser un array, con el nombre de la clase y del método, o un string, con el nombre de una función.

parameter

Un parámetro, reuniendo todos los parámetros del método en una matriz.

Nota:

Observe que los parámetros para forward_static_call_array() no son pasados por referencia.

Valores devueltos

Devuelve el resultado de la función, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de forward_static_call_array()

<?php

class A
{
    const NOMBRE = 'A';
    public static function prueba() {
        $args = func_get_args();
        echo static::NOMBRE, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NOMBRE = 'B';

    public static function prueba() {
        echo self::NOMBRE, "\n";
        forward_static_call_array(array('A', 'prueba'), array('más', 'args'));
        forward_static_call_array( 'prueba', array('otro', 'args'));
    }
}

B::prueba('foo');

function prueba() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

El resultado del ejemplo sería:

B
B más,args
C otro,args

Ver también

  • forward_static_call() - Llamar a un método estático
  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro
  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función


Llamar a un método estático

  • « forward_static_call_array
  • func_get_arg »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Llamar a un método estático

forward_static_call

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

forward_static_call — Llamar a un método estático

Descripción

forward_static_call ( callable $function , mixed $parameter = ? , mixed $... = ? ) : mixed

Llama a una función o método definido por el usuario, dado por el parámetro function, con los siguientes argumentos. Esta función debe ser llamada dentro del contexto de un método, no se puede usar fuera de una clase. Usa el Enlace estático en tiempo de ejecución.

Parámetros

function

La función o método a ser llamado. Este parámetro puede ser una matriz, con el nombre de la clase y del método, o una cadena, con el nombre una función.

parameter

Cero o más parámetros a ser pasados a la función.

Valores devueltos

Devuelve el resultado de la función, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de forward_static_call()

<?php

class A
{
    const NOMBRE = 'A';
    public static function prueba() {
        $args = func_get_args();
        echo static::NOMBRE, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NOMBRE = 'B';

    public static function prueba() {
        echo self::NOMBRE, "\n";
        forward_static_call(array('A', 'prueba'), 'más', 'args');
        forward_static_call( 'prueba', 'otro', 'args');
    }
}

B::prueba('foo');

function prueba() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

El resultado del ejemplo sería:

B
B más,args
C otro,args

Ver también

  • forward_static_call_array() - Llamar a un método estático y pasar los argumentos como matriz
  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros
  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función


Devuelve un elemento de una lista de argumentos

  • « forward_static_call
  • func_get_args »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Devuelve un elemento de una lista de argumentos

func_get_arg

(PHP 4, PHP 5, PHP 7, PHP 8)

func_get_arg — Devuelve un elemento de una lista de argumentos

Descripción

func_get_arg ( int $arg_num ) : mixed

Obtiene el argumento especificado de una lista de argumentos de una función definida por el usuario.

Esta función se puede usar junto con func_get_args() y func_num_args() para permitir a las funciones de usuario aceptar listas de argumentos de longitud variable.

Parámetros

arg_num

El índice del argumento. Los argumentos de las funciones se empiezan a contar desde cero.

Valores devueltos

Devuelve el argumento especificado, o false en caso de error.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora se puede usar en listas de parámetros.
5.3.0 | Si esta función es llamada desde el ámbito último de un archivo que ha sido incluido mediante una llamada a include o require desde dentro de una función en el archivo de llamada, ahora genera una advertencia y devuelve false.

Errores/Excepciones

Genera una advertencia si se llama desde fuera de una función definida por el usuario, o si arg_num es mayor que el número de argumentos pasados actualmente.

Ejemplos

Ejemplo #1 Ejemplo de func_get_arg()

<?php
function foo()
{
     $númargs = func_num_args();
     echo "Número de argumentos: $númargs<br />\n";
     if ($númargs >= 2) {
         echo "El segundo argumento es: " . func_get_arg(1) . "<br />\n";
     }
}

foo (1, 2, 3);
?>

Ejemplo #2 Ejemplo de func_get_arg() antes y después de PHP 5.3

prueba.php
<?php
function foo() {
    include './fga.inc';
}

foo('Primer argumento', 'Segundo argumento');
?>

fga.inc
<?php

$arg = func_get_arg(1);
var_export($arg);

?>

Salida anterior a PHP 5.3:

'Segundo argumento'

Salida en PHP 5.3 y posterior:

Warning: func_get_arg():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Ejemplo #3 func_get_arg() ejemplo de argumentos byref (pasa un objeto como referencia) y byval (pasa un objeto como valor)

<?php
function byVal($arg) {
    echo 'Pasó como     : ', var_export(func_get_arg(0)), PHP_EOL;
    $arg = 'baz';
    echo 'Tras el cambio: ', var_export(func_get_arg(0)), PHP_EOL;
}

function byRef(&$arg) {
    echo 'Pasó como     : ', var_export(func_get_arg(0)), PHP_EOL;
    $arg = 'baz';
    echo 'Tras el cambio: ', var_export(func_get_arg(0)), PHP_EOL;
}

$arg = 'bar';
byVal($arg);
byRef($arg);
?>

El resultado del ejemplo sería:

Pasó como : 'bar'
Tras el cambio: 'bar'
Pasó como : 'bar'
Tras el cambio: 'baz'

Notas

Nota:

Como esta función depende del ámbito actual para determinar los detalles del parámetro, no puede ser usada como parámetro de función en versiones anteriores a 5.3.0. Si se require pasar el valor, los resultados deben ser asignados a una variable y esta variable debería pasarse como parámetro.

Nota:

Si los argumentos se pasan por referencia, cualquier cambio en ellos se verá reflejado en los valores devueltos por esta función. A partir de PHP 7, los valores actuales también serán devueltos si los argumentos son pasados por valor.

Nota: Esta función solamente devuelve una copia de los argumentos pasados, y no rinde cuentas de los argumentos predeterminados (no pasados).

Ver también

  • La sintaxis de ... en PHP 5.6+
  • func_get_args()
  • func_num_args()


Devuelve un array que se compone de una lista de argumentos de función

  • « func_get_arg
  • func_num_args »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Devuelve un array que se compone de una lista de argumentos de función

func_get_args

(PHP 4, PHP 5, PHP 7, PHP 8)

func_get_args — Devuelve un array que se compone de una lista de argumentos de función

Descripción

func_get_args ( ) : array

Obtiene un array de la lista de argumentos de una función.

Esta función se puede usar junto con func_get_arg() y func_num_args() para permitir a las funciones definidas por el usuario aceptar una lista de argumentos de longitud variable.

Valores devueltos

Devuelve un array en el que cada elemento es una copia del miembro correspondiente de la lista de argumentos de la función definida por el usuario.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora se puede usar en listas de parámetros.
5.3.0 | Si esta función es llamada desde el ámbito último de un archivo que ha sido incluido mediante una llamada a include o require desde dentro de una función en el archivo de llamada, ahora genera una advertencia y devuelve false.

Errores/Excepciones

Genera una advertencia si se llama desde fuera de una función definida por el usuario.

Ejemplos

Ejemplo #1 Ejemplo de func_get_args()

<?php
function foo()
{
    $númargs = func_num_args();
    echo "Número de argumentos: $númargs \n";
    if ($númargs >= 2) {
        echo "El segundo argumento es: " . func_get_arg(1) . "\n";
    }
    $arg_list = func_get_args();
    for ($i = 0; $i < $númargs; $i++) {
        echo "El argumento $i es: " . $arg_list[$i] . "\n";
    }
}

foo(1, 2, 3);
?>

El resultado del ejemplo sería:

Número de argumentos: 3
El segundo argumento es: 2
El argumento 0 es: 1
El argumento 1 es: 2
El argumento 2 es: 3

Ejemplo #2 Ejemplo de func_get_args() antes y después de PHP 5.3

prueba.php
<?php
function foo() {
    include './fga.inc';
}

foo('Primer argumento', 'Segundo argumento');
?>

fga.inc
<?php

$args = func_get_args();
var_export($args);

?>

Salida antes de PHP 5.3:

array (
  0 => 'Primer argumento',
  1 => 'Segundo argumento',
)

Salida en PHP 5.3 y posterior:

Warning: func_get_args():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Ejemplo #3 func_get_args() ejemplo de argumentos byref (pasa un objeto como referencia) y byval (pasa un objeto como valor)

<?php
function byVal($arg) {
    echo 'Pasó como     : ', var_export(func_get_args()), PHP_EOL;
    $arg = 'baz';
    echo 'Tras el cambio  : ', var_export(func_get_args()), PHP_EOL;
}

function byRef(&$arg) {
    echo 'Pasó como     : ', var_export(func_get_args()), PHP_EOL;
    $arg = 'baz';
    echo 'Tras el cambio  : ', var_export(func_get_args()), PHP_EOL;
}

$arg = 'bar';
byVal($arg);
byRef($arg);
?>

Salida del ejemplo anterior en PHP 7:

Pasó como : array (
0 => 'bar',
)
Tras el cambio : array (
0 => 'baz',
)
Pasó como : array (
0 => 'bar',
)
Tras el cambio : array (
0 => 'baz',
)

Salida del ejemplo anterior en PHP 5:

Pasó como : array (
0 => 'bar',
)
Tras el cambio : array (
0 => 'bar',
)
Pasó como : array (
0 => 'bar',
)
Tras el cambio : array (
0 => 'baz',
)

Notas

Nota:

Como esta función depende del ámbito actual para determinar los detalles del parámetro, no puede ser usada como parámetro de función en versiones anteriores a 5.3.0. Si se require pasar el valor, los resultados deben ser asignados a una variable y esta variable debería pasarse como parámetro.

Nota:

Si los argumentos se pasan por referencia, cualquier cambio en ellos se verá reflejado en los valores devueltos por esta función. A partir de PHP 7, los valores actuales también serán devueltos si los argumentos son pasados por valor.

Nota: Esta función solamente devuelve una copia de los argumentos pasados, y no rinde cuentas de los argumentos predeterminados (no pasados).

Ver también

  • La sintaxis de ... en PHP 5.6+
  • func_get_arg()
  • func_num_args()
  • ReflectionFunctionAbstract::getParameters()


Devuelve el número de argumentos pasados a la función

  • « func_get_args
  • function_exists »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Devuelve el número de argumentos pasados a la función

func_num_args

(PHP 4, PHP 5, PHP 7, PHP 8)

func_num_args — Devuelve el número de argumentos pasados a la función

Descripción

func_num_args ( ) : int

Obtiene el número de argumentos pasados a la función.

Esta función se puede usar junto con func_get_arg() y func_get_args() para permitir a las funciones definidas por el usuario aceptar listas de argumentos de longitud variable.

Valores devueltos

Devuelve el número de argumentos pasados a la función actual definida por el usuario.

Historial de cambios

Versión | Descripción
5.3.0 | Esta función ahora se puede usar en listas de parámetros.
5.3.0 | Si esta función es llamada desde el ámbito último de un fichero que ha sido incluido mediante una llamada a include o require desde dentro de una función en el fichero de llamada, ahora genera una advertencia y devuelve -1.

Errores/Excepciones

Genera una advertencia si se llama desde fuera de una función definida por el usuario.

Ejemplos

Ejemplo #1 Ejemplo de func_num_args()

<?php
function foo()
{
    $númargs = func_num_args();
    echo "Número de argumentos: $númargs\n";
}

foo(1, 2, 3);
?>

El resultado del ejemplo sería:

Número de argumentos: 3

Ejemplo #2 Ejemplo de func_num_args() antes y después de PHP 5.3

prueba.php
<?php
function foo() {
    include './fna.php';
}

foo('Primer argumento', 'Segundo argumento');
?>

fna.php
<?php

$núm_args = func_num_args();
var_export($núm_args);

?>

Salida antes de PHP 5.3:

2

La salida en PHP 5.3 y posterior será algo similar a:

Warning: func_num_args():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fna.inc on line 3
-1

Notas

Nota:

Como esta función depende del ámbito actual para determinar los detalles del parámetro, no puede ser usada como parámetro de función en versiones anteriores a 5.3.0. Si se require pasar el valor, los resultados deben ser asignados a una variable y esta variable debería pasarse como parámetro.

Ver también

  • La sintaxis ... en PHP 5.6+
  • func_get_arg()
  • func_get_args()
  • ReflectionFunctionAbstract::getNumberOfParameters()


Devuelve true si la función dada ha sido definida

  • « func_num_args
  • get_defined_functions »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Devuelve true si la función dada ha sido definida

function_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

function_exists — Devuelve true si la función dada ha sido definida

Descripción

function_exists ( string $function_name ) : bool

Comprueba la lista de funciones definidas, las incluidas (internas) y las definidas por el usuario, para function_name.

Parámetros

function_name

El nombre de la función, como cadena.

Valores devueltos

Devuelve true si function_name existe y es una función, si no, false.

Nota:

Esta función devolverá false para construcciones, tales como include_once y echo.

Ejemplos

Ejemplo #1 Ejemplo de function_exists()

<?php
if (function_exists('imap_open')) {
    echo "Las funciones de IMAP están disponibles.<br />\n";
} else {
    echo "Las funciones de IMAP no están disponibles.<br />\n";
}
?>

Notas

Nota:

Un nombre de función puede existir incluso si la función misma no es utilizabla a causa de las opciones de configuración o de compilación (siendo un ejemplo las funciones de image).

Ver también

  • method_exists() - Comprueba si existe un método de una clase
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función
  • get_defined_functions() - Devuelve un array de todas las funciones definidas
  • class_exists() - Verifica si la clase ha sido definida
  • extension_loaded() - Encontrar si una extensión está cargada


Devuelve un array de todas las funciones definidas

  • « function_exists
  • register_shutdown_function »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Devuelve un array de todas las funciones definidas

get_defined_functions

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

get_defined_functions — Devuelve un array de todas las funciones definidas

Descripción

get_defined_functions ( bool $exclude_disabled = false ) : array

Obtiene un array de todas las funciones definidas.

Parámetros

exclude_disabled

Si deberían excluirse las funciones inhabilitadas del valor devuelto.

Valores devueltos

Devuelve un array multidimensional que contiene una lista de todas las funciones definidas, tanto de las incluidas (internas) como las definidas por el usuario. Las funciones internas serán accesibles mediante $arr["internal"], y las definidas por el usuario usando $arr["user"] (véase el ejemplo de abajo).

Historial de cambios

Versión | Descripción
PHP 7.0.15, PHP 7.1.1 | Se ha añadido el parámetro exclude_disabled.

Ejemplos

Ejemplo #1 Ejemplo de get_defined_functions()

<?php
function mifila($id, $data)
{
    return "<tr><th>$id</th><td>$data</td></tr>\n";
}

$arr = get_defined_functions();

print_r($arr);
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [internal] => Array
        (
            [0] => zend_version
            [1] => func_num_args
            [2] => func_get_arg
            [3] => func_get_args
            [4] => strlen
            [5] => strcmp
            [6] => strncmp
            ...
            [750] => bcscale
            [751] => bccomp
        )

    [user] => Array
        (
            [0] => mifila
        )

)

Ver también

  • function_exists() - Devuelve true si la función dada ha sido definida
  • get_defined_vars() - Devuelve una matriz con todas las variables definidas
  • get_defined_constants() - Devuelve un array asociativo con los nombres de todas las constantes y sus valores
  • get_declared_classes() - Devuelve una matriz con los nombres de las clases definidas


Registrar una función para que sea ejecutada al cierre

  • « get_defined_functions
  • register_tick_function »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Registrar una función para que sea ejecutada al cierre

register_shutdown_function

(PHP 4, PHP 5, PHP 7, PHP 8)

register_shutdown_function — Registrar una función para que sea ejecutada al cierre

Descripción

register_shutdown_function ( callable $callback , mixed $parameter = ? , mixed $... = ? ) : void

Registra una llamada de retorno dada por callback para ser ejecutada después de que finalice la ejecución del script o se llame a exit().

Se pueden hacer múltiples llamadas a register_shutdown_function(), y cada una será llamada en el mismo orden en el que fueron registradas. Si se llama a exit() dentro de una función de cierre registrada, el procesamiento se detendrá completamente y no se llamarán a otras funciones de cierre registradas.

Parámetros

callback

La llamada de retorno de cierre a registrar.

Las llamadas de retorno de cierre se ejecutan como parte de una petición, por lo que es posible enviar salidas desde ellas y acceder a los buffers de salida.

parameter

Es posible pasar parámetros a la función de cierre pasando parámetros adicionales.

...

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Se generará un error de nivel E_WARNING si no es posible llamar a la llamada de retorno.

Ejemplos

Ejemplo #1 Ejemplo de register_shutdown_function()

<?php
function cierre()
{
    // Esta es nuestra función de cierre,
    // aquí podemos hacer las últimas operaciones
    // antes de que el script sea completado.

    echo 'Script ejecutado con éxito', PHP_EOL;
}

register_shutdown_function('cierre');
?>

Notas

Nota:

El directorio de trabajo del script se puede cambiar dentro de la función de cierre bajo algunos servidores web, p.ej. Apache.

Nota:

Las funciones de cierre no serán ejecutadas si el proceso es terminado por señales SIGTERM o SIGKILL. Pese a que no es posible interceptar una señal SIGKILL, es posible utilizar pcntl_signal() para registrar un manejador para SIGTERM que utilice exit() para terminar limpiamente.

Ver también

  • auto_append_file
  • exit() - Imprime un mensaje y termina el script actual
  • La sección sobre manejo de conexiones


Registrar una función para que sea ejecutada en cada tick

  • « register_shutdown_function
  • unregister_tick_function »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Registrar una función para que sea ejecutada en cada tick

register_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

register_tick_function — Registrar una función para que sea ejecutada en cada tick

Descripción

register_tick_function ( callable $function , mixed $arg = ? , mixed $... = ? ) : bool

Registra la función dada por function para ser ejecutada cuando se llame a un tick.

Parámetros

function

El nombre de la función como cadena, o una matriz que consiste en un objeto y un método.

arg

...

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de register_tick_function()

<?php
declare(ticks=1);

// usar una función como llamada de retorno
register_tick_function('mi_función', true);

// usar un objeto->método
$objeto = new mi_clase();
register_tick_function(array(&$objeto, 'mi_método'), true);
?>

Historial de cambios

Versión | Descripción
5.3.0 | Los ticks ahora están soportados en los módulos de servidores web que usan hilos.

Notas

Advertencia

No debería usarse register_tick_function() con módulos de servidores web que usan hilos con PHP 5.2 o anterior.

Ver también

  • declare
  • unregister_tick_function() - Dejar de registrar una función para su ejecución en cada tick


Dejar de registrar una función para su ejecución en cada tick

  • « register_tick_function
  • Quickhash »
  • PHP Manual
  • Funciones de Manejo de Funciones
  • Dejar de registrar una función para su ejecución en cada tick

unregister_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

unregister_tick_function — Dejar de registrar una función para su ejecución en cada tick

Descripción

unregister_tick_function ( string $function_name ) : void

Deja de registrar la función nominada por function_name por lo que ya no se ejecuta más cuando se llame a un tick.

Parámetros

function_name

El nombre de la función, como cadena.

Valores devueltos

No devuelve ningún valor.

Ver también

  • register_tick_function() - Registrar una función para que sea ejecutada en cada tick


Quickhash

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
  • Constantes predefinidas
  • Ejemplos
  • QuickHashIntSet — La clase QuickHashIntSet
    • QuickHashIntSet::add — Este método añade una nuevas entrada al conjunto
    • QuickHashIntSet::__construct — Crea un nuevo objeto QuickHashIntSet
    • QuickHashIntSet::delete — Este método elimina una entrada de un conjunto
    • QuickHashIntSet::exists — Este método comprueba si una clave es parte de un conjunto
    • QuickHashIntSet::getSize — Devuelve el número de elementos del conjunto
    • QuickHashIntSet::loadFromFile — Este método de fabricación crear un conjunto desde un fichero
    • QuickHashIntSet::loadFromString — Este método de fabricación crea un conjunto desde una cadena de caracteres
    • QuickHashIntSet::saveToFile — Este método almacena un conjunto que está en la memoria en el disco
    • QuickHashIntSet::saveToString — Este método devuelve una versión serializada del conjunto
  • QuickHashIntHash — La clase QuickHashIntHash
    • QuickHashIntHash::add — Este método añade una nueva entrada al hash
    • QuickHashIntHash::__construct — Crea un nuevo objeto QuickHashIntHash
    • QuickHashIntHash::delete — Este método elimina una entrada de un hash
    • QuickHashIntHash::exists — Este método comprueba si la clave es parte del hash
    • QuickHashIntHash::get — Este método recupera un valor a partir del hash por su clave
    • QuickHashIntHash::getSize — Devuelve el número de elementos de un hash
    • QuickHashIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
    • QuickHashIntHash::loadFromString — Este método de fabricación crea un hash dedsde una cadena de caracteres
    • QuickHashIntHash::saveToFile — Este método almacena un hash en memoria en disco
    • QuickHashIntHash::saveToString — Este método devuelve una versión serializada del hash
    • QuickHashIntHash::set — Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashIntHash::update — Este método actualiza una entrada del hash con un nuevo valor
  • QuickHashStringIntHash — La clase QuickHashStringIntHash
    • QuickHashStringIntHash::add — Este método añade una nueva entrada a un hash
    • QuickHashStringIntHash::__construct — Crea un nuevo objeto QuickHashStringIntHash
    • QuickHashStringIntHash::delete — Este método elimina una entrada del hash
    • QuickHashStringIntHash::exists — Este método comprueba si una clave es parte de un hash
    • QuickHashStringIntHash::get — Este método recupera un valor de un hash mediante su clave
    • QuickHashStringIntHash::getSize — Devuelve el número de elementos de un hash
    • QuickHashStringIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
    • QuickHashStringIntHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres
    • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString — Este método devuelve una versión serializada del hash
    • QuickHashStringIntHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashStringIntHash::update — Este método actualiza una entrada de un hash con un nuevo valor
  • QuickHashIntStringHash — La clase QuickHashIntStringHash
    • QuickHashIntStringHash::add — Este método añade una nueva entrada a un hash
    • QuickHashIntStringHash::__construct — Crea un nuevo objeto QuickHashIntStringHash
    • QuickHashIntStringHash::delete — Este método elimina una entrada del hash
    • QuickHashIntStringHash::exists — Este método comprueba si una clave es parte de un hash
    • QuickHashIntStringHash::get — Este método recupera un valor de un hash mediante su clave
    • QuickHashIntStringHash::getSize — Devuelve el número de elementos de un hash
    • QuickHashIntStringHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
    • QuickHashIntStringHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres
    • QuickHashIntStringHash::saveToFile — Este método almacena un hash que esté en memoria en el disco
    • QuickHashIntStringHash::saveToString — Este método devuelve una versión serializada del hash
    • QuickHashIntStringHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashIntStringHash::update — Este método actualiza una entrada de un hash con un nuevo valor


Introducción

La extensión QuickHash contiene un conjunto de clases con establecimiento inflexible de tipos específicas para tratar con conjuntos específicos e implementaciones de hash.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta extensión no requiere bibliotecas adicionales.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/quickhash


  • « Configuración en tiempo de ejecución
  • Ejemplos »
  • PHP Manual
  • Quickhash
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Ejemplo #1 Ejemplo de Quickhash

<?php
$conjunto = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
$conjunto->add( 1 );
$conjunto->add( 3 );

var_dump( $conjunto->exists( 3 ) );
var_dump( $conjunto->exists( 4 ) );

$conjunto->saveToFile( "/tmp/conjunto-prueba.set" );

$conjuntoNuevo = QuickHashIntSet::loadFromFile(
    "/tmp/conjunto-prueba.set"
);

var_dump( $conjuntoNuevo->exists( 3 ) );
var_dump( $conjuntoNuevo->exists( 4 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)
bool(true)
bool(false)

Ejemplo #2 Ejemplo de Quickhash con ArrayAccess

<?php
$hash = new QuickHashIntHash( 64 );

// Agregar y actualizar entradas hash.
$hash[3] = 145926;
$hash[3] = 1415926;
$hash[2] = 72;

// Comprobar si existen las claves
var_dump( isset( $hash[3] ) );

// Eliminación de entradas hash
unset( $hash[2] );

// Recuperar el valor almacenado para un hash
echo $hash[3], "\n";
?>

El resultado del ejemplo sería algo similar a:

bool(true)
1415926

Ejemplo #3 Ejemplo de Quickhash con Iterator

<?php
$hash = new QuickHashIntHash( 64 );

// Añadir entradas hash
$hash[1] = 145926;
$hash[2] = 1415926;
$hash[3] = 72;
$hash[4] = 712314;
$hash[5] = -4234;

foreach( $hash as $clave => $valor )
{
    echo $clave, ' => ', $valor, "\n";
}
?>

El resultado del ejemplo sería algo similar a:

5 => -4234
4 => 712314
1 => 145926
2 => 1415926
3 => 72

Ejemplo #4 Ejemplo de valores de tipo string de Quickhash

<?php
$hash = new QuickHashIntStringHash( 64 );

// Añadir entradas hash
$hash[1] = "un millón cuatrocientos quince mil novecientos ventiseis";
$hash->add( 2, "uno más" );

foreach( $hash as $clave => $valor )
{
    echo $clave, ' => ', $valor, "\n";
}
?>

El resultado del ejemplo sería algo similar a:

1 => un millón cuatrocientos quince mil novecientos ventiseis
2 => uno más


La clase QuickHashIntSet

(PECL quickhash >= Unknown)

Introducción

Esta clase envuelve un conjunto de contiene números enteros.

Se puede iterar sobre los conjuntos con foreach, ya que la interfaz Iterator también está implementada. No se garantiza el orden de los elementos devueltos.

Sinopsis de la Clase

QuickHashIntSet {
/* Constatntes */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Métodos */
public add ( int $key ) : bool
public __construct ( int $size , int $options = ? )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
publicgetSize ( ) : int
public static loadFromFile ( string $filename , int $size = ? , int $options = ? ) : QuickHashIntSet
public static loadFromString ( string $contents , int $size = ? , int $options = ? ) : QuickHashIntSet
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
}

Constantes predefinidas

QuickHashIntSet::CHECK_FOR_DUPES

Si se habilita, la agregación de elementos duplicados a un canjunto (a través de add() o de loadFromFile()) resultará en la eliminación de dichos elementos del conjunto. Esto tomará tiempo extra, por lo que solamente se usa cuando es necesaria.

QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC

Deshabilita es uso del gestor de memoria interno de PHP para las estructuras de conjuntosl Con esta opción habilitada, la asignaciones internas no con respecto a los ajuestes de memory_limit.

QuickHashIntSet::HASHER_NO_HASH

Selecciona el no usar la función de hash, sino que meramente usa un mósulo para buscar el índice de la lista de recipientes. Esto no es más rápido que el uso del hash normal, y se dan más colisiones.

QuickHashIntSet::HASHER_JENKINS1

Esta es la función de hash predeterminada para convertir los hash de tipo integer en índices de lista de recipientes.

QuickHashIntSet::HASHER_JENKINS2

Selecciona un algoritmo de hash alternativo.

Tabla de contenidos

  • QuickHashIntSet::add — Este método añade una nuevas entrada al conjunto
  • QuickHashIntSet::__construct — Crea un nuevo objeto QuickHashIntSet
  • QuickHashIntSet::delete — Este método elimina una entrada de un conjunto
  • QuickHashIntSet::exists — Este método comprueba si una clave es parte de un conjunto
  • QuickHashIntSet::getSize — Devuelve el número de elementos del conjunto
  • QuickHashIntSet::loadFromFile — Este método de fabricación crear un conjunto desde un fichero
  • QuickHashIntSet::loadFromString — Este método de fabricación crea un conjunto desde una cadena de caracteres
  • QuickHashIntSet::saveToFile — Este método almacena un conjunto que está en la memoria en el disco
  • QuickHashIntSet::saveToString — Este método devuelve una versión serializada del conjunto


Este método añade una nuevas entrada al conjunto

  • « QuickHashIntSet
  • QuickHashIntSet::__construct »
  • PHP Manual
  • QuickHashIntSet
  • Este método añade una nuevas entrada al conjunto

QuickHashIntSet::add

(PECL quickhash >= Unknown)

QuickHashIntSet::add — Este método añade una nuevas entrada al conjunto

Descripción

public QuickHashIntSet::add ( int $key ) : bool

Este método añade una nueva entrada al conjunto, y devuelve si la entrada fue añadida o no. Las entradas siempre son añadidas de forma predeterminada a menos que se hubiera pasado QuickHashIntSet::CHECK_FOR_DUPES al crear el conjunto.

Parámetros

key

La clave de la entrada a añadir.

Valores devueltos

true cuando la entrasa fue añadida, y false si la entrada no se añadió.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::add()

<?php
echo "sin comprobación de duplicados\n";
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

echo "\ncon comporbación de duplicados\n";
$set = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
?>

El resultado del ejemplo sería algo similar a:

sin comprobación de duplicados
bool(false)
bool(true)
bool(true)
bool(true)

con comporbación de duplicados
bool(false)
bool(true)
bool(true)
bool(false)


Crea un nuevo objeto QuickHashIntSet

  • « QuickHashIntSet::add
  • QuickHashIntSet::delete »
  • PHP Manual
  • QuickHashIntSet
  • Crea un nuevo objeto QuickHashIntSet

QuickHashIntSet::__construct

(PECL quickhash >= Unknown)

QuickHashIntSet::__construct — Crea un nuevo objeto QuickHashIntSet

Descripción

public QuickHashIntSet::__construct ( int $size , int $options = ? )

Este constructor crea un nuevo objetos QuickHashIntSet. El tamaño es la cantidad de listas de recipientes a crear. Cuantas más listas existan, menos colisiones ocurrirán. También admite opciones.

Parámetros

size

La cantidad de listas de recipientes a configurar. El número que se pase será automáticamente redondeado hacia la siguiente potencia de dos. También será limitado automáticamente a valores entre 64 y 4194304.

options

Las opciones que se pueden pasar son: QuickHashIntSet::CHECK_FOR_DUPES, que se asegura de que no se añadan entradas duplicadas al conjunto; QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC para no usar el gestor de memoria interna de PHP, y tambíen una de las siguientes: QuickHashIntSet::HASHER_NO_HASH, QuickHashIntSet::HASHER_JENKINS1 o QuickHashIntSet::HASHER_JENKINS2. Estas tres últimas configuran el algoritmo hash a usar. Todas las opcioines se pueden combinar usando máscaras de bits.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntSet.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::__construct()

<?php
var_dump( new QuickHashIntSet( 1024 ) );
var_dump( new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntSet(
        1024,
        QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC | QuickHashIntSet::HASHER_JENKINS2
    )
);
?>


Este método elimina una entrada de un conjunto

  • « QuickHashIntSet::__construct
  • QuickHashIntSet::exists »
  • PHP Manual
  • QuickHashIntSet
  • Este método elimina una entrada de un conjunto

QuickHashIntSet::delete

(PECL quickhash >= Unknown)

QuickHashIntSet::delete — Este método elimina una entrada de un conjunto

Descripción

public QuickHashIntSet::delete ( int $key ) : bool

Este método elimina una entrada de un conjunto, y devuelve si la entrada se eliminó o no. Las estructuras de memoria asociadas no serán liberadas inmediatamente, sino cuando el propio conjunto sea liberado.

Parámetros

key

La clave de la entrada a elminiar.

Valores devueltos

true cuando la entrada se eliminó, false si la entrada no se eliminó.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::delete()

<?php
$conjunto = new QuickHashIntSet( 1024 );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->add( 4 ) );
var_dump( $conjunto->delete( 4 ) );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->delete( 4 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


Este método comprueba si una clave es parte de un conjunto

  • « QuickHashIntSet::delete
  • QuickHashIntSet::getSize »
  • PHP Manual
  • QuickHashIntSet
  • Este método comprueba si una clave es parte de un conjunto

QuickHashIntSet::exists

(PECL quickhash >= Unknown)

QuickHashIntSet::exists — Este método comprueba si una clave es parte de un conjunto

Descripción

public QuickHashIntSet::exists ( int $key ) : bool

Este método comprueba si una entrada con la clave proporcionada existe en el. conjunto.

Parámetros

key

La clave de la entrada para comprobar si existe en el conjunto.

Valores devueltos

Devuelve true si la entrada se encuentra en el conjutno, o false si no.

Ejemplos

Ejemplo #1 Ejempl0 de QuickHashIntSet::exists()

<?php
//generar 200000 elementos
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating set: ", microtime( true ), "\n";
$set = new QuickHashIntSet( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $set->add( $key );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $set->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

El resultado del ejemplo sería algo similar a:

Creating set: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897


Devuelve el número de elementos del conjunto

  • « QuickHashIntSet::exists
  • QuickHashIntSet::loadFromFile »
  • PHP Manual
  • QuickHashIntSet
  • Devuelve el número de elementos del conjunto

QuickHashIntSet::getSize

(PECL quickhash >= Unknown)

QuickHashIntSet::getSize — Devuelve el número de elementos del conjunto

Descripción

publicQuickHashIntSet::getSize ( ) : int

Devuelve el número de elementos del conjunto.

Parámetros

key

La clave de la entrada a añadir.

Valores devueltos

El número de elementos del conjunto.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::getSize()

<?php
$set = new QuickHashIntSet( 8 );
var_dump( $set->add( 2 ) );
var_dump( $set->add( 3 ) );
var_dump( $set->getSize() );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
int(2)


Este método de fabricación crear un conjunto desde un fichero

  • « QuickHashIntSet::getSize
  • QuickHashIntSet::loadFromString »
  • PHP Manual
  • QuickHashIntSet
  • Este método de fabricación crear un conjunto desde un fichero

QuickHashIntSet::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromFile — Este método de fabricación crear un conjunto desde un fichero

Descripción

public static QuickHashIntSet::loadFromFile ( string $filename , int $size = ? , int $options = ? ) : QuickHashIntSet

Este método crea un nuevo conjunto desde un fichero de definición del disco. El formato del fichero consiste en número enteros de 32 bits con signo empaquetados juntos en el Endianness que use el sistema donde se ejecute el código.

Parámetros

filename

El nombre de fichero del fichero desde donde leer el conjunto.

size

La cantidad de listas de recipientes a configurar. El número pasado será automáticamente redondeado hacia arriba a la potencia de dos más próxima. También será limitada automáticamente de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del conjunto, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntSet.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::loadFromFile()

<?php
$fichero = dirname( __FILE__ ) . "/simple.set";
$set = QuickHashIntSet::loadFromFile(
    $fichero,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $set->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) ino está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método de fabricación crea un conjunto desde una cadena de caracteres

  • « QuickHashIntSet::loadFromFile
  • QuickHashIntSet::saveToFile »
  • PHP Manual
  • QuickHashIntSet
  • Este método de fabricación crea un conjunto desde una cadena de caracteres

QuickHashIntSet::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromString — Este método de fabricación crea un conjunto desde una cadena de caracteres

Descripción

public static QuickHashIntSet::loadFromString ( string $contents , int $size = ? , int $options = ? ) : QuickHashIntSet

Este método de fabricación crea un nuevo conjunto desde una definición de una cadena de caracteres. El formato del fichero consiste en número enteros de 32 bits con signo empaquetados juntos en el Endianness que use el sistema donde se ejecute el código.

Parámetros

contents

El string que contiene un formato serializado del conjunto.

size

La cantidad de listas de recipientes a configurar. El número pasado será automáticamente redondeado hacia arriba a la potencia de dos más próxima. También será limitada automáticamente de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del conjunto, redondeado hacia arriba a la potencia de dos más próxima con un límite entre 64 y 4194304.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntSet.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::loadFromString()

<?php
$contenido = file_get_contents( dirname( __FILE__ ) . "/simple.set" );
$conjunto = QuickHashIntSet::loadFromString(
    $contenido,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $set->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) ino está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método almacena un conjunto que está en la memoria en el disco

  • « QuickHashIntSet::loadFromString
  • QuickHashIntSet::saveToString »
  • PHP Manual
  • QuickHashIntSet
  • Este método almacena un conjunto que está en la memoria en el disco

QuickHashIntSet::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToFile — Este método almacena un conjunto que está en la memoria en el disco

Descripción

public QuickHashIntSet::saveToFile ( string $filename ) : void

Este método almacena un conjunto existente en un fichero del disco, en el mismo formato que puede leer loadFromFile().

Parámetros

filename

El nombre de fichero del fichero donde almacenar el hash.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::saveToFile()

<?php
$conjunto = new QuickHashIntSet( 1024 );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->add( 4 ) );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->add( 4 ) );

$conjunto->saveToFile( '/tmp/prueba.set' );
?>


Este método devuelve una versión serializada del conjunto

  • « QuickHashIntSet::saveToFile
  • QuickHashIntHash »
  • PHP Manual
  • QuickHashIntSet
  • Este método devuelve una versión serializada del conjunto

QuickHashIntSet::saveToString

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToString — Este método devuelve una versión serializada del conjunto

Descripción

public QuickHashIntSet::saveToString ( ) : string

Este método devuelve una versión serializada del conjunto en el mismo formato que que puede leer loadFromString().

Valores devueltos

Este método de vuelve un string que contiene un formato serializado del conjunto. Cada elementos se almacena como un valor de cuatro bytes en el Endianness que utilice el systema actual.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntSet::saveToString()

<?php
$conjunto = new QuickHashIntSet( 1024 );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->add( 4 ) );
var_dump( $conjunto->exists( 4 ) );
var_dump( $conjunto->add( 4 ) );

var_dump( $conjunto->saveToString() );
?>


La clase QuickHashIntHash

(PECL quickhash >= Unknown)

Introducción

Esta clase envuelve un hash que contiene números enteros, donde los valores también son números enteros. Los hash también están disponibles como implementación de la interfaz ArrayAccess.

También se puede iterar sobre los hash con foreach, ya que la interfaz Iterator también está implementada. No se garantiza el orden de los elementos devueltos.

Sinopsis de la Clase

QuickHashIntHash {
/* Constantes */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Métodos */
public add ( int $key , int $value = ? ) : bool
public __construct ( int $size , int $options = ? )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
public get ( int $key ) : int
public getSize ( ) : int
public static loadFromFile ( string $filename , int $options = ? ) : QuickHashIntHash
public static loadFromString ( string $contents , int $options = ? ) : QuickHashIntHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( int $key , int $value ) : bool
public update ( int $key , int $value ) : bool
}

Constantes predefinidas

QuickHashIntHash::CHECK_FOR_DUPES

Si se habilita, la agregación de elementos duplicados a un canjunto (a través de add() o de loadFromFile()) resultará en la eliminación de dichos elementos del conjunto. Esto tomará tiempo extra, por lo que solamente se usa cuando es necesaria.

QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC

Deshabilita es uso del gestor de memoria interno de PHP para las estructuras de conjuntosl Con esta opción habilitada, la asignaciones internas no con respecto a los ajuestes de memory_limit.

QuickHashIntHash::HASHER_NO_HASH

Selecciona el no usar la función de hash, sino que meramente usa un mósulo para buscar el índice de la lista de recipientes. Esto no es más rápido que el uso del hash normal, y se dan más colisiones.

QuickHashIntHash::HASHER_JENKINS1

Esta es la función de hash predeterminada para convertir los hash de tipo integer en índices de lista de recipientes.

QuickHashIntHash::HASHER_JENKINS2

Selecciona un algoritmo de hash alternativo.

Tabla de contenidos

  • QuickHashIntHash::add — Este método añade una nueva entrada al hash
  • QuickHashIntHash::__construct — Crea un nuevo objeto QuickHashIntHash
  • QuickHashIntHash::delete — Este método elimina una entrada de un hash
  • QuickHashIntHash::exists — Este método comprueba si la clave es parte del hash
  • QuickHashIntHash::get — Este método recupera un valor a partir del hash por su clave
  • QuickHashIntHash::getSize — Devuelve el número de elementos de un hash
  • QuickHashIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
  • QuickHashIntHash::loadFromString — Este método de fabricación crea un hash dedsde una cadena de caracteres
  • QuickHashIntHash::saveToFile — Este método almacena un hash en memoria en disco
  • QuickHashIntHash::saveToString — Este método devuelve una versión serializada del hash
  • QuickHashIntHash::set — Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe
  • QuickHashIntHash::update — Este método actualiza una entrada del hash con un nuevo valor


Este método añade una nueva entrada al hash

  • « QuickHashIntHash
  • QuickHashIntHash::__construct »
  • PHP Manual
  • QuickHashIntHash
  • Este método añade una nueva entrada al hash

QuickHashIntHash::add

(PECL quickhash >= Unknown)

QuickHashIntHash::add — Este método añade una nueva entrada al hash

Descripción

public QuickHashIntHash::add ( int $key , int $value = ? ) : bool

Este método añade una nueva entrada al hash, y devuelve si la entrada se añadió o no. De manera predeterminada, todas las entradas siempre son añadidas a menos que QuickHashIntHash::CHECK_FOR_DUPES fuera pasado al crear el hash.

Parámetros

key

La clave de la entrada a añadir.

value

El valor opcional de la entrada a añadir. Si no se especifica ningún valor, se usará 1.

Valores devueltos

true cuando la entrasa fue añadida, y false si la entrada no se añadió.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::add()

<?php
echo "sin comprobación de duplicados\n";
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 22 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 12 ) );

echo "\ncon comprobación de duplicados\n";
$hash = new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 78 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 9 ) );

echo "\nvalor prederminado\n";
var_dump( $hash->add( 5 ) );
var_dump( $hash->get( 5 ) );
?>

El resultado del ejemplo sería algo similar a:

sin comprobación de duplicados
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

con comprobación de duplicados
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)

valor prederminado
bool(true)
int(1)


Crea un nuevo objeto QuickHashIntHash

  • « QuickHashIntHash::add
  • QuickHashIntHash::delete »
  • PHP Manual
  • QuickHashIntHash
  • Crea un nuevo objeto QuickHashIntHash

QuickHashIntHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntHash::__construct — Crea un nuevo objeto QuickHashIntHash

Descripción

public QuickHashIntHash::__construct ( int $size , int $options = ? )

Este constructor crea un nuevo objeto QuickHashIntHash. El tamaño es la cantidad de listas de recipientes a crear. Cuantas más listas existan, menos colisiones ocurrirán. También admite opciones.

Parámetros

size

La cantidad de listas de recipientes a configurar. El número que se pase será automáticamente redondeado hacia la siguiente potencia de dos. También será limitado automáticamente a valores entre 64 y 4194304.

options

Las opciones que se pueden pasar son: QuickHashIntHash::CHECK_FOR_DUPES, que se asegura de que no se añadan entradas duplicadas al hash; QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC para no usar el gestor de memoria interna de PHP, y tambíen una de las siguientes: QuickHashIntHash::HASHER_NO_HASH, QuickHashIntHash::HASHER_JENKINS1 o QuickHashIntHash::HASHER_JENKINS2. Estas tres últimas configuran el algoritmo hash a usar. Todas las opcioines se pueden combinar usando máscaras de bits.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::__construct()

<?php
var_dump( new QuickHashIntHash( 1024 ) );
var_dump( new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntHash(
        1024,
        QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntHash::HASHER_JENKINS2
    )
);
?>


Este método elimina una entrada de un hash

  • « QuickHashIntHash::__construct
  • QuickHashIntHash::exists »
  • PHP Manual
  • QuickHashIntHash
  • Este método elimina una entrada de un hash

QuickHashIntHash::delete

(PECL quickhash >= Unknown)

QuickHashIntHash::delete — Este método elimina una entrada de un hash

Descripción

public QuickHashIntHash::delete ( int $key ) : bool

Este método elimina una entrada de un hash, y devuelve si la entrada se eliminó o no. Las estructuras de memoria asociadas no serán liberadas inmediatamente, sino cuando el propio hash sea liberado.

Los elementos no se pueden eliminar del hash cuando se use un iterador. El método no lanzará un excepción, sinon que simplemente devolverá false de la misma forma que con cualquier otro fallo de eliminación.

Parámetros

key

La clave de la entrada a eliminar.

Valores devueltos

true cuando la entrada se eliminó, false si la entrada no se eliminó.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::delete()

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 5 ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


Este método comprueba si la clave es parte del hash

  • « QuickHashIntHash::delete
  • QuickHashIntHash::get »
  • PHP Manual
  • QuickHashIntHash
  • Este método comprueba si la clave es parte del hash

QuickHashIntHash::exists

(PECL quickhash >= Unknown)

QuickHashIntHash::exists — Este método comprueba si la clave es parte del hash

Descripción

public QuickHashIntHash::exists ( int $key ) : bool

Este método comprueba si una entrada con la clave proporcionada existe en el hash.

Parámetros

key

La clave de la entrada para comprobar si existe en el hash.

Valores devueltos

Devuelve true cuando la entrada es encontrada, o false si no se encuentra.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::exists()

<?php
//generar 200000 elementos
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating hash: ", microtime( true ), "\n";
$hash = new QuickHashIntHash( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $hash->add( $key, 56 );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $hash->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

El resultado del ejemplo sería algo similar a:

Creating hash: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897


Este método recupera un valor a partir del hash por su clave

  • « QuickHashIntHash::exists
  • QuickHashIntHash::getSize »
  • PHP Manual
  • QuickHashIntHash
  • Este método recupera un valor a partir del hash por su clave

QuickHashIntHash::get

(PECL quickhash >= Unknown)

QuickHashIntHash::get — Este método recupera un valor a partir del hash por su clave

Descripción

public QuickHashIntHash::get ( int $key ) : int

Este método recupera un valor a partir del hash por su clave.

Parámetros

key

La clave de la entrada para añadir.

Valores devueltos

El valor si la clave existe, o null si la clave no era parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::get()

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2 ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
int(1)
bool(true)
int(5)


Devuelve el número de elementos de un hash

  • « QuickHashIntHash::get
  • QuickHashIntHash::loadFromFile »
  • PHP Manual
  • QuickHashIntHash
  • Devuelve el número de elementos de un hash

QuickHashIntHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntHash::getSize — Devuelve el número de elementos de un hash

Descripción

public QuickHashIntHash::getSize ( ) : int

Devuelve el número de elementos de un hash.

Parámetros

key

The key of the entry to add.

Valores devueltos

El número de elementos de un hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::getSize()

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->add( 2 ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
int(2)


Este método de fabricación crea un hash desde un fichero

  • « QuickHashIntHash::getSize
  • QuickHashIntHash::loadFromString »
  • PHP Manual
  • QuickHashIntHash
  • Este método de fabricación crea un hash desde un fichero

QuickHashIntHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero

Descripción

public static QuickHashIntHash::loadFromFile ( string $filename , int $options = ? ) : QuickHashIntHash

Este método de fabricación crea un nuevo hash desde un fichero de definición del disco. El formato del fichero consiste en una signatura 'QH\0x11\0', el número de elementos como un número entero de 32 con signo bits en el Endianness del sistema, seguido de números enteros de 32 con signo empaquetados juntos en el Endianness que use el sistema donde se ejecuta el código. Por cada elemento del hash existen dos números enteros de 32 bits con signo almacenados. El primero de cada elemento es la clave, y el segundo es el valor al que pertenece la clave. Un ejemplo podría ser:

Ejemplo #1 Formato de fichero de IntHash de QuickHash

00000000  51 48 11 00 02 00 00 00  01 00 00 00 01 00 00 00  |QH..............|
00000010  03 00 00 00 09 00 00 00                           |........|
00000018

Ejemplo #2 Formato de fichero de IntHash de QuickHash

signatura de cabecera ('QH'; tipo de clave: 1; tipo de valor: 1; relleno: \0x00)
00000000  51 48 11 00

número de elementos:
00000004  02 00 00 00

data string:
00000000  01 00 00 00 01 00 00 00  03 00 00 00 09 00 00 00

clave/valor 1 (clave = 1, valor = 1)
01 00 00 00  01 00 00 00

clave/valor 2 (clave = 3, valor = 9)
03 00 00 00  09 00 00 00

Parámetros

filename

El nombre de fichero del fichero desde donde leer el hash.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del hash, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntHash.

Ejemplos

Ejemplo #3 Ejemplo de QuickHashIntHash::loadFromFile()

<?php
$fichero = dirname( __FILE__ ) . "/simple.hash";
$hash = QuickHashIntHash::loadFromFile(
    $fichero,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $hash->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) no está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método de fabricación crea un hash dedsde una cadena de caracteres

  • « QuickHashIntHash::loadFromFile
  • QuickHashIntHash::saveToFile »
  • PHP Manual
  • QuickHashIntHash
  • Este método de fabricación crea un hash dedsde una cadena de caracteres

QuickHashIntHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromString — Este método de fabricación crea un hash dedsde una cadena de caracteres

Descripción

public static QuickHashIntHash::loadFromString ( string $contents , int $options = ? ) : QuickHashIntHash

Este método crea un nuevo hash desde una definición de una cadena de caracteres. El formato del fichero consiste en números enteros de 32 con signo empaquetados juntos en el Endianness que use el sistema donde se ejecuta el código. Por cada elemento existen dos números enteros de 32 bits con signo almacenados. El primero de cada elemento es la clave, y el segundo es el valor al que pertenece la clave.

Parámetros

contents

El string que contiene un formato serializado del hash.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del hash, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::loadFromString()

<?php
$contenido = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntHash::loadFromString(
    $contenido,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $hash->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) no está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método almacena un hash en memoria en disco

  • « QuickHashIntHash::loadFromString
  • QuickHashIntHash::saveToString »
  • PHP Manual
  • QuickHashIntHash
  • Este método almacena un hash en memoria en disco

QuickHashIntHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToFile — Este método almacena un hash en memoria en disco

Descripción

public QuickHashIntHash::saveToFile ( string $filename ) : void

Este método almacena un hash existente en un fichero del disco, en el mismo formato que loadFromFile() puede leer.

Parámetros

filename

El nombre de fichero del fichero donde almacenar el hash.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::saveToFile()

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 43 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 52 ) );

$hash->saveToFile( '/tmp/prueba.hash' );
?>


Este método devuelve una versión serializada del hash

  • « QuickHashIntHash::saveToFile
  • QuickHashIntHash::set »
  • PHP Manual
  • QuickHashIntHash
  • Este método devuelve una versión serializada del hash

QuickHashIntHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToString — Este método devuelve una versión serializada del hash

Descripción

public QuickHashIntHash::saveToString ( ) : string

Este método devuelve una versión serializada del hash, en el mismo formato que loadFromString() puede leer.

Valores devueltos

Este método devuelve un string que consitne un formato serializado del hash. Cada elemento se almacena como un valor de cuatro bytes en el Endianness que utilice el sistema en uso.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::saveToString()

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 34 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 55 ) );

var_dump( $hash->saveToString() );
?>


Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe

  • « QuickHashIntHash::saveToString
  • QuickHashIntHash::update »
  • PHP Manual
  • QuickHashIntHash
  • Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe

QuickHashIntHash::set

(PECL quickhash >= Unknown)

QuickHashIntHash::set — Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe

Descripción

public QuickHashIntHash::set ( int $key , int $value ) : bool

Este método intenta actualizar una entrada con un nuevo valor. En caso de que la entrada aún no exista, añadirá una nueva entrada en su lugar. Devuelve si la entrada se añadió o se actualizó. Si existen claves duplicadas, únicamente se actualizará el valor del primer elemento encontrado. Use QuickHashIntHash::CHECK_FOR_DUPES durante la creación de un hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir o actualizar.

value

El nuevo valor con el que establecer la entrada.

Valores devueltos

2 si la entrada se encontró y se actualizó, 1 si la entrada se añadió o 0 si ocurrión un error.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::set()

<?php
$hash = new QuickHashIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, 16091 ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, 29906 ) );
var_dump( $hash->get( 46692 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)


Este método actualiza una entrada del hash con un nuevo valor

  • « QuickHashIntHash::set
  • QuickHashStringIntHash »
  • PHP Manual
  • QuickHashIntHash
  • Este método actualiza una entrada del hash con un nuevo valor

QuickHashIntHash::update

(PECL quickhash >= Unknown)

QuickHashIntHash::update — Este método actualiza una entrada del hash con un nuevo valor

Descripción

public QuickHashIntHash::update ( int $key , int $value ) : bool

Este método actualiza una entrada con un nuevo valor, y devuelve si la entrada fue actualizada. Si update. Si existen claves duplicadas, únicamente se actualizará el valor del primer elemento encontrado. Use QuickHashIntHash::CHECK_FOR_DUPES durante la creación de un hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir.

value

El nuevo valor con el que actualizar la entrada.

Valores devueltos

true cuando la entrada se encontró y se actualizó, y false si la entrada ya no es parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntHash::update()

<?php
$hash = new QuickHashIntHash( 1024 );

var_dump( $hash->add( 141421, 173205 ) );
var_dump( $hash->update( 141421, 223606 ) );
var_dump( $hash->get( 141421 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
int(223606)


La clase QuickHashStringIntHash

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Esta clase envuelve un hash que contiene strings, donde los valores son números enteros. Los hash también están disponibles como implementación de la interfaz ArrayAccess.

También se puede iterar sobre los hash con foreach, ya que la interfaz Iterator también está implementada. No se garantiza el orden de los elementos devueltos.

Sinopsis de la Clase

QuickHashStringIntHash {
/* Constantes */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
/* Métodos */
public add ( string $key , int $value ) : bool
public __construct ( int $size , int $options = 0 )
public delete ( string $key ) : bool
public exists ( string $key ) : bool
public get ( string $key ) : mixed
public getSize ( ) : int
public static loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash
public static loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( string $key , int $value ) : int
public update ( string $key , int $value ) : bool
}

Constantes predefinidas

QuickHashStringIntHash::CHECK_FOR_DUPES

Si se habilita, la agregación de elementos duplicados a un canjunto (a través de add() o de loadFromFile()) resultará en la eliminación de dichos elementos del conjunto. Esto tomará tiempo extra, por lo que solamente se usa cuando es necesaria.

QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC

Deshabilita es uso del gestor de memoria interno de PHP para las estructuras de conjuntosl Con esta opción habilitada, la asignaciones internas no con respecto a los ajuestes de memory_limit.

Tabla de contenidos

  • QuickHashStringIntHash::add — Este método añade una nueva entrada a un hash
  • QuickHashStringIntHash::__construct — Crea un nuevo objeto QuickHashStringIntHash
  • QuickHashStringIntHash::delete — Este método elimina una entrada del hash
  • QuickHashStringIntHash::exists — Este método comprueba si una clave es parte de un hash
  • QuickHashStringIntHash::get — Este método recupera un valor de un hash mediante su clave
  • QuickHashStringIntHash::getSize — Devuelve el número de elementos de un hash
  • QuickHashStringIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
  • QuickHashStringIntHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres
  • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashStringIntHash::saveToString — Este método devuelve una versión serializada del hash
  • QuickHashStringIntHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
  • QuickHashStringIntHash::update — Este método actualiza una entrada de un hash con un nuevo valor


Este método añade una nueva entrada a un hash

  • « QuickHashStringIntHash
  • QuickHashStringIntHash::__construct »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método añade una nueva entrada a un hash

QuickHashStringIntHash::add

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::add — Este método añade una nueva entrada a un hash

Descripción

public QuickHashStringIntHash::add ( string $key , int $value ) : bool

Este método añade una nueva entrada a un hash, y devuelve si la entrada fue añadida o no. Las entradas se añaden siempre de forma predeterminada a menos que se pase QuickHashStringIntHash::CHECK_FOR_DUPES en la creación del hash.

Parámetros

key

La clave de la entrada a añadir.

value

El valor de la entrada a añadir.

Valores devueltos

true cuando la entrada fue añadida, y false si la entrada no se pudo añadir.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::add()

<?php
echo "sin comprobación de duplicados\n";
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 22 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 12 ) );

echo "\ncon comprobación de duplicados\n";
$hash = new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 78 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 9 ) );
?>

El resultado del ejemplo sería algo similar a:

sin comprobación de duplicados
object(QuickHashStringIntHash)#1 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

con comprobación de duplicados
object(QuickHashStringIntHash)#2 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)


Crea un nuevo objeto QuickHashStringIntHash

  • « QuickHashStringIntHash::add
  • QuickHashStringIntHash::delete »
  • PHP Manual
  • QuickHashStringIntHash
  • Crea un nuevo objeto QuickHashStringIntHash

QuickHashStringIntHash::__construct

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::__construct — Crea un nuevo objeto QuickHashStringIntHash

Descripción

public QuickHashStringIntHash::__construct ( int $size , int $options = 0 )

Este constructor crea un nuevo objeto QuickHashStringIntHash. El tamaño es la cantidad de listas de recipientes a crear. Cuantas más listas existan, menos colisiones ocurrirán. También admite opciones.

Parámetros

size

La cantidad de listas de recipientes a configurar. El número que se pase será automáticamente redondeado hacia la siguiente potencia de dos. También será limitado automáticamente a valores entre 64 y 4194304.

options

Las opciones que se pueden pasar son: QuickHashStringIntHash::CHECK_FOR_DUPES, que se asegura de que no se añadan entradas duplicadas al conjunto y QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC para no usar el gestor de memoria interna de PHP.

Valores devueltos

Devuelve un nuevo objeto QuickHashStringIntHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::__construct()

<?php
var_dump( new QuickHashStringIntHash( 1024 ) );
var_dump( new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES ) );
?>


Este método elimina una entrada del hash

  • « QuickHashStringIntHash::__construct
  • QuickHashStringIntHash::exists »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método elimina una entrada del hash

QuickHashStringIntHash::delete

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::delete — Este método elimina una entrada del hash

Descripción

public QuickHashStringIntHash::delete ( string $key ) : bool

Este método elimina una entrada del hash, y devuelve si la entrada fue eliminada o no.Las estructuras de memoria asociadas no serán liberadas inmediatamente, sino cuando el propio hash sea liberado.

Los elementos no se pueden eliminar del hash cuando se use un iterador. El método no lanzará una excepción, sino que simplemente devolverá false de la misma forma que con cualquier otro fallo de eliminación.

Parámetros

key

La clave de la entrada a eliminar.

Valores devueltos

true cuando la entrada fue eliminada, y false si la entrada no se pudo eliminar.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::delete()

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->add( 'four', 5 ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
int(5)
bool(true)
bool(false)
bool(false)
bool(false)


Este método comprueba si una clave es parte de un hash

  • « QuickHashStringIntHash::delete
  • QuickHashStringIntHash::get »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método comprueba si una clave es parte de un hash

QuickHashStringIntHash::exists

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::exists — Este método comprueba si una clave es parte de un hash

Descripción

public QuickHashStringIntHash::exists ( string $key ) : bool

Este método comprueba si una entrada con la clave proporcionada existe en el hash.

Parámetros

key

La clave de la entrada para comprobar si existe en el hash.

Valores devueltos

Devuelve true si la entrada se encuentra en el hash, o false si no.


Este método recupera un valor de un hash mediante su clave

  • « QuickHashStringIntHash::exists
  • QuickHashStringIntHash::getSize »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método recupera un valor de un hash mediante su clave

QuickHashStringIntHash::get

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::get — Este método recupera un valor de un hash mediante su clave

Descripción

public QuickHashStringIntHash::get ( string $key ) : mixed

Este método recupera un valor de un hash mediante su clave.

Parámetros

key

La clave de la entrada a añadir.

Valores devueltos

El valor de la clave si ésta existe, o null si la clave no es parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::get()

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->get( "one" ) );

var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->get( "two" ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
int(2)


Devuelve el número de elementos de un hash

  • « QuickHashStringIntHash::get
  • QuickHashStringIntHash::loadFromFile »
  • PHP Manual
  • QuickHashStringIntHash
  • Devuelve el número de elementos de un hash

QuickHashStringIntHash::getSize

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::getSize — Devuelve el número de elementos de un hash

Descripción

public QuickHashStringIntHash::getSize ( ) : int

Devuelve el número de elementos de un hash.

Parámetros

key

La clave de la entrada a añadir.

Valores devueltos

El número de elementos del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::getSize()

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->add( "three", 5 ) );
var_dump( $hash->getSize() );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
int(2)


Este método de fabricación crea un hash desde un fichero

  • « QuickHashStringIntHash::getSize
  • QuickHashStringIntHash::loadFromString »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método de fabricación crea un hash desde un fichero

QuickHashStringIntHash::loadFromFile

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::loadFromFile — Este método de fabricación crea un hash desde un fichero

Descripción

public static QuickHashStringIntHash::loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash

Este método de fabricación crea un nuevo hash desde un fichero de definición del disco. El formato del fichero consiste en una signatura 'QH\0x12\0', el número de elementos como un número entero de 32 bits con signo en el Endianness del sistema, un número entero de 32 sin signo que contiene el número de datos del elemento a seguir en caracteres. Estos datos del elemento contienen todos los strings. Le sigue otro entero de 32 bits con signo que contiene el número de listas de recipientes. Después de la cabecera y los strings, le siguien los elementos. Están ordenados por lista de recipientes, por lo que a las claves no les tendrá que realizar un hash para poder restablecer el hash. Por cada lista de recipientes, se almacena la siguiente información (todos como enteros de 32 bits): el índeice de la lista de recipientes, el número de elementos de dicha lista, y luego, en parejas de dos enteros de 32 bits sin signo, los elementos, donde el primero es el índice dentro de la lista de cadenas que contiene las claves, y el segundo el valor. Un ejemplo podría ser:

Ejemplo #1 Formato de fichero de StringIntHash de QuickHash

00000000  51 48 21 00 02 00 00 00  09 00 00 00 40 00 00 00  |QH!.........@...|
00000010  4f 4e 45 00 4e 49 4e 45  00 07 00 00 00 01 00 00  |ONE.NINE........|
00000020  00 00 00 00 00 01 00 00  00 2f 00 00 00 01 00 00  |........./......|
00000030  00 04 00 00 00 03 00 00  00                       |.........|
00000039

Ejemplo #2 Formato de fichero de StringIntHash de QuickHash

signatura de la cabecera ('QH'; tipo de clave: 2; tipo de valor: 1; relleno: \0x00)
00000000  51 48 21 00

número de elementos:
00000004  02 00 00 00

longitud de los valores de string (9 caracteres):
00000008  09 00 00 00

número de listas de recipientes (esto normalmente se configura para los hash como
argumento del constructor, 64 en este caso):
0000000C  40 00 00 00

valores de string:
00000010  4f 4e 45 00 4e 49 4e 45  00

lista de recipientes:
  lista de recipientes 1 (con clave 7, y 1 elemento):
    cabecera:
    07 00 00 00 01 00 00 00
    elementos (índice de clave: 0 ('ONE'), valor = 0):
    00 00 00 00 01 00 00 00
  lista de recipientes 2 (con clave 0x2f, y 1 elemento):
    header:
    2f 00 00 00 01 00 00 00
    elementos (índice de clave: 4 ('NINE'), valor = 0):
    04 00 00 00 03 00 00 00

Parámetros

filename

El nombre de fichero del fichero desde donde leer el hash.

size

La cantidad de de listas de recipientes a configurar. El número proporcionado será automáticamente redondeado hacia arriba a la potencia de dos más cercana. Tambíen será automáticamente limitado de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se lee desde el formato de fichero (a diferencia de las clases QuickHashIntHash y QuickHashIntStringHash, donde se calcula automáticamente desde el número de entradas del hash.)

Valores devueltos

Devuelve un nuevo objeto QuickHashStringIntHash.

Ejemplos

Ejemplo #3 Ejemplo de QuickHashStringIntHash::loadFromFile()

<?php
$fichero = dirname( __FILE__ ) . "/simple.hash.string";
$hash = QuickHashStringIntHash::loadFromFile(
    $fichero,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    $i = 48712 + $clave * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

El resultado del ejemplo sería algo similar a:

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177


Este método de fabricación crea un hash desde una cadena de caracteres

  • « QuickHashStringIntHash::loadFromFile
  • QuickHashStringIntHash::saveToFile »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método de fabricación crea un hash desde una cadena de caracteres

QuickHashStringIntHash::loadFromString

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres

Descripción

public static QuickHashStringIntHash::loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash

Este método de fabricación cres un nuevo hash desde un fichero de definición de una cadena de caracteres. El formato es el mismo que el usado en "loadFromFile".

Parámetros

contents

La cadena de caracteres que contiene un formato serializado del hash.

size

La cantidad de listas de recipientes a configurar. El número proporcionado será automáticamente redondeado hacia arriba a la siguiente potencia de dos. También será automáticamente limitado de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del hash, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Deveulve un nuevo objeto QuickHashStringIntHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::loadFromString()

<?php
$contenido = file_get_contents( dirname( __FILE__ ) . "/simple.hash.string" );
$hash = QuickHashStringIntHash::loadFromString(
    $contenido,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    $i = 48712 + $clave * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

El resultado del ejemplo sería algo similar a:

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177


This method stores an in-memory hash to disk

  • « QuickHashStringIntHash::loadFromString
  • QuickHashStringIntHash::saveToString »
  • PHP Manual
  • QuickHashStringIntHash
  • This method stores an in-memory hash to disk

QuickHashStringIntHash::saveToFile

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk

Descripción

public QuickHashStringIntHash::saveToFile ( string $filename ) : void

Este método almacena un hash existente en un fichero del disco, en el mismo formato que puede leer loadFromFile().

Parámetros

filename

El nombre de fichero del fichero donde almacenar el hash.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::saveToFile()

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

$hash->saveToFile( '/tmp/prueba.hash.string' );
?>


Este método devuelve una versión serializada del hash

  • « QuickHashStringIntHash::saveToFile
  • QuickHashStringIntHash::set »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método devuelve una versión serializada del hash

QuickHashStringIntHash::saveToString

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::saveToString — Este método devuelve una versión serializada del hash

Descripción

public QuickHashStringIntHash::saveToString ( ) : string

Este método devuelve una verisón serializada del hash en el mismo formato que puede leer loadFromString().

Valores devueltos

Este método devuelve un formato serializado de un hash existente, en el mismo formato que puede leer loadFromString().

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::saveToString()

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

var_dump( $hash->saveToString() );
?>


Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

  • « QuickHashStringIntHash::saveToString
  • QuickHashStringIntHash::update »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

QuickHashStringIntHash::set

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

Descripción

public QuickHashStringIntHash::set ( string $key , int $value ) : int

Este método intenta actualizar una entrada con un nuevo valor. En caso de que la entrada aún no exista, añadirá una nueva entrada en su lugar. Devuelve si la entrada se añadió o se actualizó. Si existen claves duplicadas, únicamente se actualizará el valor del primer elemento encontrado. Use QuickHashStringIntHash::CHECK_FOR_DUPES durante la creación de un hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir o actualizar.

value

El nuevo valor de la entrada. Si se pasa algo que no sea un string, será convertidoa un string automáticamente, si fuera posible.

Valores devueltos

2 si la entrada se encontró y se actualizó, 1 si la entrada se añadió o 0 si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::set()

<?php
$hash = new QuickHashStringIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 16091 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );

echo "Set->Update\n";
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 29906 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
?>

El resultado del ejemplo sería algo similar a:

Set->Add
bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)


Este método actualiza una entrada de un hash con un nuevo valor

  • « QuickHashStringIntHash::set
  • QuickHashIntStringHash »
  • PHP Manual
  • QuickHashStringIntHash
  • Este método actualiza una entrada de un hash con un nuevo valor

QuickHashStringIntHash::update

(No hay información de versión disponible, podría estar únicamente en Git)

QuickHashStringIntHash::update — Este método actualiza una entrada de un hash con un nuevo valor

Descripción

public QuickHashStringIntHash::update ( string $key , int $value ) : bool

Este método actualiza una entrada un nuevo valor, y devuelve si la entrada fue actualizada o no. Si existen claves duplicadas, solamente se actualizará el valor del primero elemento encontrado. Use QuickHashStringIntHash::CHECK_FOR_DUPES durante la creación del hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir.

value

El nuevo valor de la entrada. Si se pasa algo que no sea un string, será convertidoa un string automáticamente, si fuera posible.

Valores devueltos

true si la entrada se encontró y se actualizó, y false si la entrada no formaba parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashStringIntHash::update()

<?php
$hash = new QuickHashStringIntHash( 1024 );

$hash->add( 'six', 314159265 );
$hash->add( "a lot", 314159265 );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";

var_dump( $hash->update( 'a lot', 314159266 ) );
var_dump( $hash->update( "a lot plus one", 314159999 ) );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";
?>

El resultado del ejemplo sería algo similar a:

314159265
314159265
bool(true)
bool(false)
314159265
314159266


La clase QuickHashIntStringHash

(PECL quickhash >= Unknown)

Introducción

Esta clase envuelve un hash que contiene números enteros, donde los valores son strings. Los hash también están disponibles como implementación de la interfaz ArrayAccess.

También se puede iterar sobre los hash con foreach, ya que la interfaz Iterator también está implementada. No se garantiza el orden de los elementos devueltos.

Sinopsis de la Clase

QuickHashIntStringHash {
/* Constantes */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Métodos */
public add ( int $key , string $value ) : bool
public __construct ( int $size , int $options = 0 )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
public get ( int $key ) : mixed
public getSize ( ) : int
public static loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash
public static loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( int $key , string $value ) : int
public update ( int $key , string $value ) : bool
}

Constantes predefinidas

QuickHashIntStringHash::CHECK_FOR_DUPES

Si se habilita, la agregación de elementos duplicados a un canjunto (a través de add() o de loadFromFile()) resultará en la eliminación de dichos elementos del conjunto. Esto tomará tiempo extra, por lo que solamente se usa cuando es necesaria.

QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntStringHash::HASHER_NO_HASH

Deshabilita es uso del gestor de memoria interno de PHP para las estructuras de conjuntosl Con esta opción habilitada, la asignaciones internas no con respecto a los ajuestes de memory_limit.

QuickHashIntStringHash::HASHER_JENKINS1

Esta es la función de hash predeterminada para convertir los hash de tipo integer en índices de lista de recipientes.

QuickHashIntStringHash::HASHER_JENKINS2

Selecciona un algoritmo de hash alternativo.

Tabla de contenidos

  • QuickHashIntStringHash::add — Este método añade una nueva entrada a un hash
  • QuickHashIntStringHash::__construct — Crea un nuevo objeto QuickHashIntStringHash
  • QuickHashIntStringHash::delete — Este método elimina una entrada del hash
  • QuickHashIntStringHash::exists — Este método comprueba si una clave es parte de un hash
  • QuickHashIntStringHash::get — Este método recupera un valor de un hash mediante su clave
  • QuickHashIntStringHash::getSize — Devuelve el número de elementos de un hash
  • QuickHashIntStringHash::loadFromFile — Este método de fabricación crea un hash desde un fichero
  • QuickHashIntStringHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres
  • QuickHashIntStringHash::saveToFile — Este método almacena un hash que esté en memoria en el disco
  • QuickHashIntStringHash::saveToString — Este método devuelve una versión serializada del hash
  • QuickHashIntStringHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
  • QuickHashIntStringHash::update — Este método actualiza una entrada de un hash con un nuevo valor


Este método añade una nueva entrada a un hash

  • « QuickHashIntStringHash
  • QuickHashIntStringHash::__construct »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método añade una nueva entrada a un hash

QuickHashIntStringHash::add

(PECL quickhash >= Unknown)

QuickHashIntStringHash::add — Este método añade una nueva entrada a un hash

Descripción

public QuickHashIntStringHash::add ( int $key , string $value ) : bool

Este método añade una nueva entrada a un hash, y devuelve si la entrada fue añadida o no. Las entradas se añaden siempre de forma predeterminada a menos que se pase QuickHashIntStringHash::CHECK_FOR_DUPES en la creación del hash.

Parámetros

key

La clave de la entrada a añadir.

value

El valor de la entrada a añadir. Si se pasa algo que no sea un string, será convertido a un string automáticamente, si fuera posible.

Valores devueltos

true cuando la entrada fue añadida, y false si la entrada no se pudo añadir.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::add()

<?php
echo "sin comprobación de duplicados\n";
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twenty two" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twelve" ) );

echo "\ncon comprobación de duplicados\n";
$hash = new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "seventy eight" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "nine" ) );
?>

El resultado del ejemplo sería algo similar a:

sin comprobación de duplicados
bool(false)
bool(false)
bool(true)
bool(true)
string(10) "twenty two"
bool(true)

con comprobación de duplicados
bool(false)
bool(false)
bool(true)
bool(true)
string(13) "seventy eight"
bool(false)


Crea un nuevo objeto QuickHashIntStringHash

  • « QuickHashIntStringHash::add
  • QuickHashIntStringHash::delete »
  • PHP Manual
  • QuickHashIntStringHash
  • Crea un nuevo objeto QuickHashIntStringHash

QuickHashIntStringHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntStringHash::__construct — Crea un nuevo objeto QuickHashIntStringHash

Descripción

public QuickHashIntStringHash::__construct ( int $size , int $options = 0 )

Este constructor crea un nuevo objeto QuickHashIntStringHash. El tamaño es la cantidad de listas de recipientes a crear. Cuantas más listas existan, menos colisiones ocurrirán. También admite opciones.

Parámetros

size

La cantidad de listas de recipientes a configurar. El número que se pase será automáticamente redondeado hacia la siguiente potencia de dos. También será limitado automáticamente a valores entre 64 y 4194304.

options

Las opciones que se pueden pasar son: QuickHashIntStringHash::CHECK_FOR_DUPES, que se asegura de que no se añadan entradas duplicadas al conjunto; QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC para no usar el gestor de memoria interna de PHP, y tambíen una de las siguientes: QuickHashIntStringHash::HASHER_NO_HASH, QuickHashIntStringHash::HASHER_JENKINS1 o QuickHashIntStringHash::HASHER_JENKINS2. Estas tres últimas configuran el algoritmo hash a usar. Todas las opcioines se pueden combinar usando máscaras de bits.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntStringHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::__construct()

<?php
var_dump( new QuickHashIntStringHash( 1024 ) );
var_dump( new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntStringHash(
        1024,
        QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntStringHash::HASHER_JENKINS2
    )
);
?>


Este método elimina una entrada del hash

  • « QuickHashIntStringHash::__construct
  • QuickHashIntStringHash::exists »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método elimina una entrada del hash

QuickHashIntStringHash::delete

(PECL quickhash >= Unknown)

QuickHashIntStringHash::delete — Este método elimina una entrada del hash

Descripción

public QuickHashIntStringHash::delete ( int $key ) : bool

Este método elimina una entrada del hash, y devuelve si la entrada fue eliminada o no.Las estructuras de memoria asociadas no serán liberadas inmediatamente, sino cuando el propio hash sea liberado.

Los elementos no se pueden eliminar del hash cuando se use un iterador. El método no lanzará una excepción, sino que simplemente devolverá false de la misma forma que con cualquier otro fallo de eliminación.

Parámetros

key

La clave de la entrada a eliminar.

Valores devueltos

true cuando la entrada fue eliminada, y false si la entrada no se pudo eliminar.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::delete()

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "five" ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


Este método comprueba si una clave es parte de un hash

  • « QuickHashIntStringHash::delete
  • QuickHashIntStringHash::get »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método comprueba si una clave es parte de un hash

QuickHashIntStringHash::exists

(PECL quickhash >= Unknown)

QuickHashIntStringHash::exists — Este método comprueba si una clave es parte de un hash

Descripción

public QuickHashIntStringHash::exists ( int $key ) : bool

Este método comprueba si una entrada con la clave proporcionada existe en el hash.

Parámetros

key

La clave de la entrada para comprobar si existe en el hash.

Valores devueltos

Devuelve true si la entrada se encuentra en el hash, o false si no.


Este método recupera un valor de un hash mediante su clave

  • « QuickHashIntStringHash::exists
  • QuickHashIntStringHash::getSize »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método recupera un valor de un hash mediante su clave

QuickHashIntStringHash::get

(PECL quickhash >= Unknown)

QuickHashIntStringHash::get — Este método recupera un valor de un hash mediante su clave

Descripción

public QuickHashIntStringHash::get ( int $key ) : mixed

Este método recupera un valor de un hash mediante su clave.

Parámetros

key

La clave de la entrada a añadir.

Valores devueltos

El valor de la clave si ésta existe, o null si la clave no es parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::get()

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

El resultado del ejemplo sería algo similar a:

bool(false)
bool(true)
string(3) "two"
bool(true)
string(1) "5"


Devuelve el número de elementos de un hash

  • « QuickHashIntStringHash::get
  • QuickHashIntStringHash::loadFromFile »
  • PHP Manual
  • QuickHashIntStringHash
  • Devuelve el número de elementos de un hash

QuickHashIntStringHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntStringHash::getSize — Devuelve el número de elementos de un hash

Descripción

public QuickHashIntStringHash::getSize ( ) : int

Devuelve el número de elementos de un hash.

Valores devueltos

El número de elementos del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::getSize()

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
int(2)


Este método de fabricación crea un hash desde un fichero

  • « QuickHashIntStringHash::getSize
  • QuickHashIntStringHash::loadFromString »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método de fabricación crea un hash desde un fichero

QuickHashIntStringHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromFile — Este método de fabricación crea un hash desde un fichero

Descripción

public static QuickHashIntStringHash::loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash

Este método de fabricación crea un nuevo hash desde un fichero de definición del disco. El formato del fichero consiste en una signatura 'QH\0x12\0', el número de elementos como un número entero de 32 bits con signo en el Endianness del sistema, un número entero de 32 sin signo que contiene el número de datos del elemento a seguir en caracteres. Estos datos del elemento contienen todos los strings. Después de la cabecera y los strings, los elementos siguen en parejas de dos enteros de 32 bits sin signo donde el primero es la clave, y el segundo el índice del string de datos del elemento. Un ejemplo podría ser:

Ejemplo #1 Formato de fichero de IntString de QuickHash

00000000  51 48 12 00 02 00 00 00  09 00 00 00 4f 4e 45 00  |QH..........ONE.|
00000010  4e 49 4e 45 00 01 00 00  00 00 00 00 00 03 00 00  |NINE............|
00000020  00 04 00 00 00                                    |.....|
00000025

Ejemplo #2 Formato de fichero de IntString de QuickHash

signatura de la cabecera ('QH'; tipo de clave: 2; tipo de valor: 1; relleno: \0x00)
00000000  51 48 12 00

número de elementos:
00000004  02 00 00 00

longitud de los valores de string (9 caracteres):
00000008  09 00 00 00

valores de string:
0000000C  4f 4e 45 00 4e 49 4e 45  00

string de datos:
00000015  01 00 00 00 00 00 00 00  03 00 00 00 04 00 00 00

clave/valor 1 (clave = 1, índice del string = 0 ("ONE")):
01 00 00 00  00 00 00 00

clave/valor 2 (clave = 3, índice del string = 4 ("NINE")):
03 00 00 00  04 00 00 00

Parámetros

filename

El nombre de fichero del fichero desde donde leer el hash.

size

La cantidad de de listas de recipientes a configurar. El número proporcionado será automáticamente redondeado hacia arriba a la potencia de dos más cercana. Tambíen será automáticamente limitado de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del hash, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Devuelve un nuevo objeto QuickHashIntStringHash.

Ejemplos

Ejemplo #3 Ejemplo de QuickHashIntStringHash::loadFromFile()

<?php
$fichero = dirname( __FILE__ ) . "/simple.string.hash";
$hash = QuickHashIntStringHash::loadFromFile(
    $fichero,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $hash->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) no está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método de fabricación crea un hash desde una cadena de caracteres

  • « QuickHashIntStringHash::loadFromFile
  • QuickHashIntStringHash::saveToFile »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método de fabricación crea un hash desde una cadena de caracteres

QuickHashIntStringHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromString — Este método de fabricación crea un hash desde una cadena de caracteres

Descripción

public static QuickHashIntStringHash::loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash

Este método de fabricación cres un nuevo hash desde un fichero de definición de una cadena de caracteres. El formato es el mismo que el usado en "loadFromFile".

Parámetros

contents

La cadena de caracteres que contiene un formato serializado del hash.

size

La cantidad de listas de recipientes a configurar. El número proporcionado será automáticamente redondeado hacia arriba a la siguiente potencia de dos. También será automáticamente limitado de 4 a 4194304.

options

Las mismas opciones que toma el constructor de la clase; excepto que se ignora la opción 'size'. Ésta se calcula automáticamente para que sea el mismo que el número de entradas del hash, redondeado hacia arriba a la potencia de dos más próxima con un límite máximo de 4194304.

Valores devueltos

Deveulve un nuevo objeto QuickHashIntStringHash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::loadFromString()

<?php
$contenido = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntStringHash::loadFromString(
    $contenido,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $clave )
{
    printf( "La clave %3d (%2x) %s\n",
        $clave, $clave,
        $hash->exists( $clave ) ? 'está establecida' : 'no está establecida'
    );
}
?>

El resultado del ejemplo sería algo similar a:

La clave   0 ( 0) no está establecida
La clave   1 ( 1) está establecida
La clave   2 ( 2) está establecida
La clave   3 ( 3) está establecida
La clave   4 ( 4) no está establecida
La clave   5 ( 5) está establecida
La clave   6 ( 6) no está establecida
La clave   7 ( 7) está establecida
La clave   8 ( 8) no está establecida
La clave   9 ( 9) no está establecida
La clave  10 ( a) no está establecida
La clave  11 ( b) está establecida
La clave  12 ( c) no está establecida
La clave  13 ( d) está establecida
La clave  14 ( e) no está establecida
La clave  15 ( f) no está establecida


Este método almacena un hash que esté en memoria en el disco

  • « QuickHashIntStringHash::loadFromString
  • QuickHashIntStringHash::saveToString »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método almacena un hash que esté en memoria en el disco

QuickHashIntStringHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToFile — Este método almacena un hash que esté en memoria en el disco

Descripción

public QuickHashIntStringHash::saveToFile ( string $filename ) : void

Este método almacena un hash existente en un fichero del disco, en el mismo formato que puede leer loadFromFile().

Parámetros

filename

El nombre de fichero del fichero donde almacenar el hash.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::saveToFile()

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fourty three" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fifty two" ) );

$hash->saveToFile( '/tmp/prueba.string.hash' );
?>


Este método devuelve una versión serializada del hash

  • « QuickHashIntStringHash::saveToFile
  • QuickHashIntStringHash::set »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método devuelve una versión serializada del hash

QuickHashIntStringHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToString — Este método devuelve una versión serializada del hash

Descripción

public QuickHashIntStringHash::saveToString ( ) : string

Este método devuelve una verisón serializada del hash en el mismo formato que puede leer loadFromString().

Valores devueltos

Este método devuelve un string que contiene un formato serializado del hash. Cada elemento se almacena como un valor de cuatro bytes en el Endianness que utilice el sistema en uso.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::saveToString()

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "thirty four" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 5, "fifty five" ) );

var_dump( $hash->saveToString() );
?>


Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

  • « QuickHashIntStringHash::saveToString
  • QuickHashIntStringHash::update »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

QuickHashIntStringHash::set

(PECL quickhash >= Unknown)

QuickHashIntStringHash::set — Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe

Descripción

public QuickHashIntStringHash::set ( int $key , string $value ) : int

Este método intenta actualizar una entrada con un nuevo valor. En caso de que la entrada aún no exista, añadirá una nueva entrada en su lugar. Devuelve si la entrada se añadió o se actualizó. Si existen claves duplicadas, únicamente se actualizará el valor del primer elemento encontrado. Use QuickHashIntStringHash::CHECK_FOR_DUPES durante la creación de un hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir o actualizar.

value

El nuevo valor de la entrada. Si se pasa algo que no sea un string, será convertidoa un string automáticamente, si fuera posible.

Valores devueltos

2 si la entrada se encontró y se actualizó, 1 si la entrada se añadió o 0 si ocurrió un error.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::set()

<?php
$hash = new QuickHashIntStringHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, "sixteen thousand ninety one" ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, "twenty nine thousand nine hundred six" ) );
var_dump( $hash->get( 46692 ) );
?>

El resultado del ejemplo sería algo similar a:

Set->Add
bool(false)
int(2)
string(27) "sixteen thousand ninety one"
Set->Update
int(1)
string(37) "twenty nine thousand nine hundred six"


Este método actualiza una entrada de un hash con un nuevo valor

  • « QuickHashIntStringHash::set
  • Reflection »
  • PHP Manual
  • QuickHashIntStringHash
  • Este método actualiza una entrada de un hash con un nuevo valor

QuickHashIntStringHash::update

(PECL quickhash >= Unknown)

QuickHashIntStringHash::update — Este método actualiza una entrada de un hash con un nuevo valor

Descripción

public QuickHashIntStringHash::update ( int $key , string $value ) : bool

Este método actualiza una entrada un nuevo valor, y devuelve si la entrada fue actualizada o no. Si existen claves duplicadas, solamente se actualizará el valor del primero elemento encontrado. Use QuickHashIntStringHash::CHECK_FOR_DUPES durante la creación del hash para evitar que las claves duplicadas sean parte de un hash.

Parámetros

key

La clave de la entrada a añadir.

value

El nuevo valor de la entrada. Si se pasa algo que no sea un string, será convertidoa un string automáticamente, si fuera posible.

Valores devueltos

true si la entrada se encontró y se actualizó, y false si la entrada no formaba parte del hash.

Ejemplos

Ejemplo #1 Ejemplo de QuickHashIntStringHash::update()

<?php
$hash->add( 161803398, "--" );
$hash->add( 314159265, "a lot" );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";

var_dump( $hash->update( 314159265, "a lot plus one" ) );
var_dump( $hash->update( 314159999, "a lot plus one" ) );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";
?>

El resultado del ejemplo sería algo similar a:

--
a lot
bool(true)
bool(false)
--
a lot plus one


Reflection

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Extensión
  • Reflection — Clase Reflection
    • Reflection::export — Exportar
    • Reflection::getModifierNames — Obtener nombres de modificadores
  • ReflectionClass — Clase ReflectionClass
    • ReflectionClass::__construct — Construye un objeto de tipo ReflectionClass
    • ReflectionClass::export — Exporta una clase
    • ReflectionClass::getConstant — Obtener una constante definida
    • ReflectionClass::getConstants — Obtener constantes
    • ReflectionClass::getConstructor — Obtiene el constructor de una clase
    • ReflectionClass::getDefaultProperties — Obtener propiedades predeterminadas
    • ReflectionClass::getDocComment — Obtener los comentarios de documentación
    • ReflectionClass::getEndLine — Consultar línea final
    • ReflectionClass::getExtension — Obtiene un objeto ReflectionExtension para la extensión que definió la clase
    • ReflectionClass::getExtensionName — Obtiene el nombre de la extensión que definió una clase
    • ReflectionClass::getFileName — Obtiene el nombre de fichero en el que está definida la clase
    • ReflectionClass::getInterfaceNames — Obtiene nombres de las interfaces
    • ReflectionClass::getInterfaces — Obtiene las interfaces
    • ReflectionClass::getMethod — Obtiene un objeto ReflectionMethod para un método de una clase
    • ReflectionClass::getMethods — Obtiene un array de métodos
    • ReflectionClass::getModifiers — Obtiene los modificadores de clase
    • ReflectionClass::getName — Obtiene el nombre de la clase
    • ReflectionClass::getNamespaceName — Obtiene el nombre del espacio de nombres
    • ReflectionClass::getParentClass — Obtiene la clase padre
    • ReflectionClass::getProperties — Obtiene las propiedades
    • ReflectionClass::getProperty — Obtiene un objeto ReflectionProperty para una propiedad de una clase
    • ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant
    • ReflectionClass::getReflectionConstants — Gets class constants
    • ReflectionClass::getShortName — Obtiene el nombre abreviado
    • ReflectionClass::getStartLine — Obtiene el número de linea de inicio
    • ReflectionClass::getStaticProperties — Obtiene las propiedades estáticas
    • ReflectionClass::getStaticPropertyValue — Obtiene el valor de una propiedad estática
    • ReflectionClass::getTraitAliases — Obtiene un array con los alias usados con los traits
    • ReflectionClass::getTraitNames — Devuelve un array con los nombres de los traits usados por esta clase
    • ReflectionClass::getTraits — Obtiene un array con los traits que utiliza esta clase
    • ReflectionClass::hasConstant — Comprueba si una constante está o no definida
    • ReflectionClass::hasMethod — Comprueba si un método está o no definido
    • ReflectionClass::hasProperty — Comprueba si una propiedad está o no definida
    • ReflectionClass::implementsInterface — Comprueba si se implementa una determinada interfaz
    • ReflectionClass::inNamespace — Comprueba si pertenece a un determinado espacio de nombres
    • ReflectionClass::isAbstract — Comprueba si la clase es abstracta
    • ReflectionClass::isAnonymous — Checks if class is anonymous
    • ReflectionClass::isCloneable — Comprueba si la clase es o no clonable
    • ReflectionClass::isFinal — Comprueba si la clase inal
    • ReflectionClass::isInstance — Comprueba si un objeto es instancia de la clase
    • ReflectionClass::isInstantiable — Comprueba si una clase es instanciable
    • ReflectionClass::isInterface — Comprueba una la clase es una interfaz
    • ReflectionClass::isInternal — Comprueba si una clase está definida internamente por una extensión o por el núcleo
    • ReflectionClass::isIterable — Check whether this class is iterable
    • ReflectionClass::isIterateable — Comprueba si es iterable
    • ReflectionClass::isSubclassOf — Comprueba si es una subclase
    • ReflectionClass::isTrait — Comprueba si es un trait
    • ReflectionClass::isUserDefined — Comprueba si es una clase definida por el usuario
    • ReflectionClass::newInstance — Crea una nueva instancia de clase a partir de la lista de parámetros dados
    • ReflectionClass::newInstanceArgs — Crea una nueva instancia de clase a partir de los argumentos dados
    • ReflectionClass::newInstanceWithoutConstructor — Crea una nueva clase sin invocar al constructor
    • ReflectionClass::setStaticPropertyValue — Establece el valor de una propiedad estática
    • ReflectionClass::__toString — Devuelve la representación en forma de string del objeto ReflectionClass
  • ReflectionClassConstant — The ReflectionClassConstant class
    • ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant
    • ReflectionClassConstant::export — Export
    • ReflectionClassConstant::getDeclaringClass — Gets declaring class
    • ReflectionClassConstant::getDocComment — Gets doc comments
    • ReflectionClassConstant::getModifiers — Gets the class constant modifiers
    • ReflectionClassConstant::getName — Get name of the constant
    • ReflectionClassConstant::getValue — Gets value
    • ReflectionClassConstant::isPrivate — Checks if class constant is private
    • ReflectionClassConstant::isProtected — Checks if class constant is protected
    • ReflectionClassConstant::isPublic — Checks if class constant is public
    • ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object
  • ReflectionZendExtension — Clase ReflectionZendExtension
    • ReflectionZendExtension::__clone — Clon de controlador
    • ReflectionZendExtension::__construct — Constructor
    • ReflectionZendExtension::export — Exportar
    • ReflectionZendExtension::getAuthor — Consultar autor
    • ReflectionZendExtension::getCopyright — Consultar los derechos de copia
    • ReflectionZendExtension::getName — Obtiene el nombre
    • ReflectionZendExtension::getURL — Obtiene la URL
    • ReflectionZendExtension::getVersion — Obtiene la versión
    • ReflectionZendExtension::__toString — Convierte a texto
  • ReflectionExtension — Clase ReflectionExtension
    • ReflectionExtension::__clone — Clonar
    • ReflectionExtension::__construct — Constructor de los objetos ReflectionExtension
    • ReflectionExtension::export — Exportar
    • ReflectionExtension::getClasses — Obtiene clases
    • ReflectionExtension::getClassNames — Obtiene nombres de las clases
    • ReflectionExtension::getConstants — Obtiene las constantes
    • ReflectionExtension::getDependencies — Obtiene las dependencias
    • ReflectionExtension::getFunctions — Obtiene las funciones de una extensión
    • ReflectionExtension::getINIEntries — Obtiene las entradas INI de la extensión
    • ReflectionExtension::getName — Obtiene el nombre de la extensión
    • ReflectionExtension::getVersion — Obtiene la versión de una extensión
    • ReflectionExtension::info — Imprime información sobre la extensión
    • ReflectionExtension::isPersistent — Indica si la extensión es persistente
    • ReflectionExtension::isTemporary — Indica si la extensión es temporal
    • ReflectionExtension::__toString — Convertir a string
  • ReflectionFunction — Clase ReflectionFunction
    • ReflectionFunction::__construct — Contruye un objeto de tipo ReflectionFunction
    • ReflectionFunction::export — Exporta una función
    • ReflectionFunction::getClosure — Genera dinámicamente una función anónima de esta función
    • ReflectionFunction::invoke — Invoca una función
    • ReflectionFunction::invokeArgs — Invoca a la función con argumentos
    • ReflectionFunction::isDisabled — Comprueba si una función está desactivada
    • ReflectionFunction::__toString — Convertir a string
  • ReflectionFunctionAbstract — Clase ReflectionFunctionAbstract
    • ReflectionFunctionAbstract::__clone — Clona una función
    • ReflectionFunctionAbstract::getClosureScopeClass — Devuelve el ámbito asociado al cierre
    • ReflectionFunctionAbstract::getClosureThis — Devuelve una función anónima que apunta a esta función
    • ReflectionFunctionAbstract::getDocComment — Obtiene comentarios de documentación
    • ReflectionFunctionAbstract::getEndLine — Obtiene número de linea final
    • ReflectionFunctionAbstract::getExtension — Obtiene información sobre la extensión
    • ReflectionFunctionAbstract::getExtensionName — Obtiene el nombre de la extensión
    • ReflectionFunctionAbstract::getFileName — Obtiene el nombre del fichero
    • ReflectionFunctionAbstract::getName — Obtiene el nombre de la función
    • ReflectionFunctionAbstract::getNamespaceName — Obtiene el nombre del espacio de nombres
    • ReflectionFunctionAbstract::getNumberOfParameters — Obtiene el número total de parámetros
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters — Obtiene el número de parámetros obligatorios
    • ReflectionFunctionAbstract::getParameters — Obtiene los parámetros
    • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName — Obtiene el nombre abreviado de la función
    • ReflectionFunctionAbstract::getStartLine — Obtiene el número de la línea de inicio
    • ReflectionFunctionAbstract::getStaticVariables — Obtiene las variable estáticas
    • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace — Comprueba si pertenece a un espacio de nombres
    • ReflectionFunctionAbstract::isClosure — Comprobar si es un cierre
    • ReflectionFunctionAbstract::isDeprecated — Comprueba si está obsoleta
    • ReflectionFunctionAbstract::isGenerator — Devuelve si la función es un generador
    • ReflectionFunctionAbstract::isInternal — Comprueba si la función es interna
    • ReflectionFunctionAbstract::isUserDefined — Comprueba si es una función definida por un usuario
    • ReflectionFunctionAbstract::isVariadic — Comprueba si la función es varíadica
    • ReflectionFunctionAbstract::returnsReference — Comprueba si devuelve una referencia
    • ReflectionFunctionAbstract::__toString — Convertir a texto
  • ReflectionMethod — La clase ReflectionMethod
    • ReflectionMethod::__construct — Construye un objeto ReflectionMethod
    • ReflectionMethod::export — Exporta un objeto de tipo ReflectionMethod
    • ReflectionMethod::getClosure — Devuelve un cierre creado dinámicamente para este método
    • ReflectionMethod::getDeclaringClass — Obtiene la clase en la que se ha declarado el método
    • ReflectionMethod::getModifiers — Obtiene los modificadores del método
    • ReflectionMethod::getPrototype — Obtiene el prototipo del método (si lo hubiera)
    • ReflectionMethod::invoke — Invoca un método
    • ReflectionMethod::invokeArgs — Invoca un método con argumentos
    • ReflectionMethod::isAbstract — Comprueba si el método es abstracto
    • ReflectionMethod::isConstructor — Comprueba si el método es un constructor
    • ReflectionMethod::isDestructor — Comprueba si el método es un destructor
    • ReflectionMethod::isFinal — Comprueba si el método es final
    • ReflectionMethod::isPrivate — Comprueba si el método es privado
    • ReflectionMethod::isProtected — Comprueba si el método está protegido
    • ReflectionMethod::isPublic — Comprueba si el método es público
    • ReflectionMethod::isStatic — Comprueba si el método es estático
    • ReflectionMethod::setAccessible — Asigna la accesibilidad del método
    • ReflectionMethod::__toString — Devuelve la representación en forma de texto de este objeto
  • ReflectionNamedType — The ReflectionNamedType class
    • ReflectionNamedType::getName — Get the text of the type hint
    • ReflectionNamedType::isBuiltin — Checks if it is a built-in type
  • ReflectionObject — Clase ReflectionObject
    • ReflectionObject::__construct — Construye un ReflectionObject
    • ReflectionObject::export — Exportación
  • ReflectionParameter — La clase ReflectionParameter
    • ReflectionParameter::allowsNull — Comprueba si null es permitido
    • ReflectionParameter::canBePassedByValue — Devuelve si este parámetro de puede pasar por valor
    • ReflectionParameter::__clone — Clon
    • ReflectionParameter::__construct — Construct
    • ReflectionParameter::export — Exportar
    • ReflectionParameter::getClass — Obtener la clase con declaraciones de tipos
    • ReflectionParameter::getDeclaringClass — Obtiene declaración de la clase
    • ReflectionParameter::getDeclaringFunction — Obtiene declaración de función
    • ReflectionParameter::getDefaultValue — Obtiene el valor del parámetro por defecto
    • ReflectionParameter::getDefaultValueConstantName — Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null
    • ReflectionParameter::getName — Obtener el nombre del parámetro
    • ReflectionParameter::getPosition — Obtiene la posición del parámetro
    • ReflectionParameter::getType — Gets a parameter's type
    • ReflectionParameter::hasType — Checks if parameter has a type
    • ReflectionParameter::isArray — Comprueba si el parámetro espera un array
    • ReflectionParameter::isCallable — Devuelve si el parámetro DEBE ser de tipo callable
    • ReflectionParameter::isDefaultValueAvailable — Comprueba si el valor por defecto está disponible
    • ReflectionParameter::isDefaultValueConstant — Devuelve si el valor predeterminado de este parámetro es constante
    • ReflectionParameter::isOptional — Comprueba si es opcional
    • ReflectionParameter::isPassedByReference — Comprueba si es pasado por referencia
    • ReflectionParameter::isVariadic — Comprueba si el parámetro es varíadico
    • ReflectionParameter::__toString — A string
  • ReflectionProperty — Clase ReflectionProperty
    • ReflectionProperty::__clone — Clonar
    • ReflectionProperty::__construct — Construir un objeto ReflectionProperty
    • ReflectionProperty::export — Exportar
    • ReflectionProperty::getDeclaringClass — Obtiene la clase en la que se declaró
    • ReflectionProperty::getDefaultValue — Returns the default value declared for a property
    • ReflectionProperty::getDocComment — Obtiene los comentarios de documentación de una propiedad
    • ReflectionProperty::getModifiers — Obtiene los modificadores
    • ReflectionProperty::getName — Obtiene el nombre de la propiedad
    • ReflectionProperty::getType — Gets a property's type
    • ReflectionProperty::getValue — Obtiene el valor
    • ReflectionProperty::hasDefaultValue — Checks if property has a default value declared
    • ReflectionProperty::hasType — Checks if property has a type
    • ReflectionProperty::isDefault — Comprueba si una propiedad es predeterminada
    • ReflectionProperty::isInitialized — Checks whether a property is initialized
    • ReflectionProperty::isPrivate — Comprueba si una propiedad es privada
    • ReflectionProperty::isProtected — Comprueba si la propiedad es protegida
    • ReflectionProperty::isPublic — Comprueba si la propiedad es pública
    • ReflectionProperty::isStatic — Comprueba si la propiedad es estática
    • ReflectionProperty::setAccessible — Hace accesible una propiedad
    • ReflectionProperty::setValue — Establece el valor de la propiedad
    • ReflectionProperty::__toString — Convertir a texto
  • ReflectionType — The ReflectionType class
    • ReflectionType::allowsNull — Checks if null is allowed
    • ReflectionType::__toString — To string
  • ReflectionUnionType — The ReflectionUnionType class
    • ReflectionUnionType::getTypes — Returns the types included in the union type
  • ReflectionGenerator — The ReflectionGenerator class
    • ReflectionGenerator::__construct — Constructs a ReflectionGenerator object
    • ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator
    • ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object
    • ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator
    • ReflectionGenerator::getFunction — Gets the function name of the generator
    • ReflectionGenerator::getThis — Gets the $this value of the generator
    • ReflectionGenerator::getTrace — Gets the trace of the executing generator
  • ReflectionReference — The ReflectionReference class
    • ReflectionReference::fromArrayElement — Create a ReflectionReference from an array element
    • ReflectionReference::getId — Get unique ID of a reference
  • Reflector — La interfaz Reflector
    • Reflector::export — Exportar
    • Reflector::__toString — Convertir a String
  • ReflectionException — La clase ReflectionException


Introducción

PHP viene con una API de reflexión completa que añade la capacidad para realizar ingeniería inversa de clases, interfaces, funciones, métodos y extensiones. Además, la API de reflexión ofrece varias formas de obtener comentarios de documentación de funciones, clases y métodos.

Tenga en cuenta que ciertas partes de la API interna no contienen el código necesario para trabajar con la extensión Reflection. Por ejemplo, a una clase interna de PHP le pueden faltar datos de reflexión de sus propiedades. Sin embargo, estos pocos casos son considerados como errores, por lo que deberían ser descubiertos y corregidos.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • Reflection
  • Constantes predefinidas

Constantes predefinidas

Cada clase describe sus propias constantes.


Ejemplos

Existen muchos ejemplos en la documentación de Reflection, por lo general dentro de la documentación de __construct de cada clase.

Ejemplo #1 Ejemplo de Reflection desde Shell (un terminal)

$ php --rf strlen
$ php --rc finfo
$ php --re json
$ php --ri dom

El resultado del ejemplo sería algo similar a:

Function [ <internal:Core> function strlen ] {

  - Parameters [1] {
    Parameter #0 [ <required> $str ]
  }
}

Class [ <internal:fileinfo> class finfo ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [4] {
    Method [ <internal:fileinfo, ctor> public method finfo ] {

      - Parameters [2] {
        Parameter #0 [ <optional> $options ]
        Parameter #1 [ <optional> $arg ]
      }
    }

    Method [ <internal:fileinfo> public method set_flags ] {

      - Parameters [1] {
        Parameter #0 [ <required> $options ]
      }
    }

    Method [ <internal:fileinfo> public method file ] {

      - Parameters [3] {
        Parameter #0 [ <required> $filename ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }

    Method [ <internal:fileinfo> public method buffer ] {

      - Parameters [3] {
        Parameter #0 [ <required> $string ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }
  }
}

Extension [ <persistent> extension #23 json version 1.2.1 ] {

  - Constants [10] {
    Constant [ integer JSON_HEX_TAG ] { 1 }
    Constant [ integer JSON_HEX_AMP ] { 2 }
    Constant [ integer JSON_HEX_APOS ] { 4 }
    Constant [ integer JSON_HEX_QUOT ] { 8 }
    Constant [ integer JSON_FORCE_OBJECT ] { 16 }
    Constant [ integer JSON_ERROR_NONE ] { 0 }
    Constant [ integer JSON_ERROR_DEPTH ] { 1 }
    Constant [ integer JSON_ERROR_STATE_MISMATCH ] { 2 }
    Constant [ integer JSON_ERROR_CTRL_CHAR ] { 3 }
    Constant [ integer JSON_ERROR_SYNTAX ] { 4 }
  }

  - Functions {
    Function [ <internal:json> function json_encode ] {

      - Parameters [2] {
        Parameter #0 [ <required> $value ]
        Parameter #1 [ <optional> $options ]
      }
    }
    Function [ <internal:json> function json_decode ] {

      - Parameters [3] {
        Parameter #0 [ <required> $json ]
        Parameter #1 [ <optional> $assoc ]
        Parameter #2 [ <optional> $depth ]
      }
    }
    Function [ <internal:json> function json_last_error ] {

      - Parameters [0] {
      }
    }
  }
}

dom

DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.7.3
HTML Support => enabled
XPath Support => enabled
XPointer Support => enabled
Schema Support => enabled
RelaxNG Support => enabled


Extensión

Si se deseara crear versiones especializadas de las clases que vienen incorporadas (por ejemplo, para crear HTML en color cuando se exportan, parar tener variables de acceso rápido en lugar de usar métodos, o parar crear métodos auxiliares), deberá extender la clase.

Ejemplo #1 Extendiendo las clases incorporadas

<?php
/**
 * Mi clase Reflection_Method
 */
class My_Reflection_Method extends ReflectionMethod
{
    public $visibility = array();

    public function __construct($o, $m)
    {
        parent::__construct($o, $m);
        $this->visibility = Reflection::getModifierNames($this->getModifiers());
    }
}

/**
 * Clase demo #1
 *
 */
class T {
    protected function x() {}
}

/**
 * Clase demo #2
 *
 */
class U extends T {
    function x() {}
}

// Mostrar información
var_dump(new My_Reflection_Method('U', 'x'));
?>

El resultado del ejemplo sería algo similar a:

object(My_Reflection_Method)#1 (3) {
  ["visibility"]=>
  array(1) {
    [0]=>
    string(6) "public"
  }
  ["name"]=>
  string(1) "x"
  ["class"]=>
  string(1) "U"
}
Precaución

Si se sobrescribe el constructor, no hay que olvidar llamar en primer lugar al constructor de la clase padre. Si esto fallara, se lanzará el siguiente error: Fatal error: Internal error: Failed to retrieve the reflection object


Clase Reflection

(PHP 5, PHP 7)

Introducción

Clase reflection.

Sinopsis de la Clase

Reflection {
/* Métodos */
public static export ( Reflector $reflector , bool $return = false ) : string
public static getModifierNames ( int $modifiers ) : array
}

Tabla de contenidos

  • Reflection::export — Exportar
  • Reflection::getModifierNames — Obtener nombres de modificadores


Exportar

  • « Reflection
  • Reflection::getModifierNames »
  • PHP Manual
  • Reflection
  • Exportar

Reflection::export

(PHP 5, PHP 7)

Reflection::export — Exportar

Descripción

public static Reflection::export ( Reflector $reflector , bool $return = false ) : string

Exporta una reflexión.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

reflector

La reflexión a exportar.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ver también

  • Reflection::getModifierNames() - Obtener nombres de modificadores


Obtener nombres de modificadores

  • « Reflection::export
  • ReflectionClass »
  • PHP Manual
  • Reflection
  • Obtener nombres de modificadores

Reflection::getModifierNames

(PHP 5, PHP 7)

Reflection::getModifierNames — Obtener nombres de modificadores

Descripción

public static Reflection::getModifierNames ( int $modifiers ) : array

Obtiene los nombres de los modificadores.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

modifiers

Modificadores que se desean obtener, a partir de un valor numérico.

Valores devueltos

Un array con nombres de modificadores.

Ver también

  • Reflection::export() - Exportar


Clase ReflectionClass

(PHP 5, PHP 7)

Introducción

La clase ReflectionClass devuelve información sobre una clase.

Sinopsis de la Clase

ReflectionClass implements Reflector {
/* Constantes */
const integer IS_IMPLICIT_ABSTRACT = 16 ;
const integer IS_EXPLICIT_ABSTRACT = 32 ;
const integer IS_FINAL = 64 ;
/* Propiedades */
public $name ;
/* Métodos */
public __construct ( mixed $argument )
public static export ( mixed $argument , bool $return = false ) : string
public getConstant ( string $name ) : mixed
public getConstants ( int|null $filter = null ) : array
public getConstructor ( ) : ReflectionMethod
public getDefaultProperties ( ) : array
public getDocComment ( ) : string
public getEndLine ( ) : int
public getExtension ( ) : ReflectionExtension
public getExtensionName ( ) : string
public getFileName ( ) : string
public getInterfaceNames ( ) : array
public getInterfaces ( ) : array
public getMethod ( string $name ) : ReflectionMethod
public getMethods ( int $filter = ? ) : array
public getModifiers ( ) : int
public getName ( ) : string
public getNamespaceName ( ) : string
public getParentClass ( ) : object
public getProperties ( int $filter = ? ) : array
public getProperty ( string $name ) : ReflectionProperty
public getReflectionConstant ( string $name ) : ReflectionClassConstant|false
public getReflectionConstants ( int|null $filter = null ) : array
public getShortName ( ) : string
public getStartLine ( ) : int
public getStaticProperties ( ) : array
public getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed
public getTraitAliases ( ) : array
public getTraitNames ( ) : array
public getTraits ( ) : array
public hasConstant ( string $name ) : bool
public hasMethod ( string $name ) : bool
public hasProperty ( string $name ) : bool
public implementsInterface ( string $interface ) : bool
public inNamespace ( ) : bool
public isAbstract ( ) : bool
public isAnonymous ( ) : bool
public isCloneable ( ) : bool
public isFinal ( ) : bool
public isInstance ( object $object ) : bool
public isInstantiable ( ) : bool
public isInterface ( ) : bool
public isInternal ( ) : bool
public isIterable ( ) : bool
public isIterateable ( ) : bool
public isSubclassOf ( string $class ) : bool
public isTrait ( ) : bool
public isUserDefined ( ) : bool
public newInstance ( mixed $args , mixed $... = ? ) : object
public newInstanceArgs ( array $args = ? ) : object
public newInstanceWithoutConstructor ( ) : object
public setStaticPropertyValue ( string $name , string $value ) : void
public __toString ( ) : string
}

Propiedades

name

Nombre de la clase. De sólo lectura, lanza una ReflectionException en el intento de escribir.

Constantes predefinidas

Modificadores ReflectionClass

ReflectionClass::IS_IMPLICIT_ABSTRACT

Indica que la clase es abstract porque esta tiene algunos métodos abstractos.

ReflectionClass::IS_EXPLICIT_ABSTRACT

Indica que la clase es abstract debido a su definición.

ReflectionClass::IS_FINAL

Indica la clase final.

Tabla de contenidos

  • ReflectionClass::__construct — Construye un objeto de tipo ReflectionClass
  • ReflectionClass::export — Exporta una clase
  • ReflectionClass::getConstant — Obtener una constante definida
  • ReflectionClass::getConstants — Obtener constantes
  • ReflectionClass::getConstructor — Obtiene el constructor de una clase
  • ReflectionClass::getDefaultProperties — Obtener propiedades predeterminadas
  • ReflectionClass::getDocComment — Obtener los comentarios de documentación
  • ReflectionClass::getEndLine — Consultar línea final
  • ReflectionClass::getExtension — Obtiene un objeto ReflectionExtension para la extensión que definió la clase
  • ReflectionClass::getExtensionName — Obtiene el nombre de la extensión que definió una clase
  • ReflectionClass::getFileName — Obtiene el nombre de fichero en el que está definida la clase
  • ReflectionClass::getInterfaceNames — Obtiene nombres de las interfaces
  • ReflectionClass::getInterfaces — Obtiene las interfaces
  • ReflectionClass::getMethod — Obtiene un objeto ReflectionMethod para un método de una clase
  • ReflectionClass::getMethods — Obtiene un array de métodos
  • ReflectionClass::getModifiers — Obtiene los modificadores de clase
  • ReflectionClass::getName — Obtiene el nombre de la clase
  • ReflectionClass::getNamespaceName — Obtiene el nombre del espacio de nombres
  • ReflectionClass::getParentClass — Obtiene la clase padre
  • ReflectionClass::getProperties — Obtiene las propiedades
  • ReflectionClass::getProperty — Obtiene un objeto ReflectionProperty para una propiedad de una clase
  • ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant
  • ReflectionClass::getReflectionConstants — Gets class constants
  • ReflectionClass::getShortName — Obtiene el nombre abreviado
  • ReflectionClass::getStartLine — Obtiene el número de linea de inicio
  • ReflectionClass::getStaticProperties — Obtiene las propiedades estáticas
  • ReflectionClass::getStaticPropertyValue — Obtiene el valor de una propiedad estática
  • ReflectionClass::getTraitAliases — Obtiene un array con los alias usados con los traits
  • ReflectionClass::getTraitNames — Devuelve un array con los nombres de los traits usados por esta clase
  • ReflectionClass::getTraits — Obtiene un array con los traits que utiliza esta clase
  • ReflectionClass::hasConstant — Comprueba si una constante está o no definida
  • ReflectionClass::hasMethod — Comprueba si un método está o no definido
  • ReflectionClass::hasProperty — Comprueba si una propiedad está o no definida
  • ReflectionClass::implementsInterface — Comprueba si se implementa una determinada interfaz
  • ReflectionClass::inNamespace — Comprueba si pertenece a un determinado espacio de nombres
  • ReflectionClass::isAbstract — Comprueba si la clase es abstracta
  • ReflectionClass::isAnonymous — Checks if class is anonymous
  • ReflectionClass::isCloneable — Comprueba si la clase es o no clonable
  • ReflectionClass::isFinal — Comprueba si la clase inal
  • ReflectionClass::isInstance — Comprueba si un objeto es instancia de la clase
  • ReflectionClass::isInstantiable — Comprueba si una clase es instanciable
  • ReflectionClass::isInterface — Comprueba una la clase es una interfaz
  • ReflectionClass::isInternal — Comprueba si una clase está definida internamente por una extensión o por el núcleo
  • ReflectionClass::isIterable — Check whether this class is iterable
  • ReflectionClass::isIterateable — Comprueba si es iterable
  • ReflectionClass::isSubclassOf — Comprueba si es una subclase
  • ReflectionClass::isTrait — Comprueba si es un trait
  • ReflectionClass::isUserDefined — Comprueba si es una clase definida por el usuario
  • ReflectionClass::newInstance — Crea una nueva instancia de clase a partir de la lista de parámetros dados
  • ReflectionClass::newInstanceArgs — Crea una nueva instancia de clase a partir de los argumentos dados
  • ReflectionClass::newInstanceWithoutConstructor — Crea una nueva clase sin invocar al constructor
  • ReflectionClass::setStaticPropertyValue — Establece el valor de una propiedad estática
  • ReflectionClass::__toString — Devuelve la representación en forma de string del objeto ReflectionClass


Construye un objeto de tipo ReflectionClass

  • « ReflectionClass
  • ReflectionClass::export »
  • PHP Manual
  • ReflectionClass
  • Construye un objeto de tipo ReflectionClass

ReflectionClass::__construct

(PHP 5, PHP 7)

ReflectionClass::__construct — Construye un objeto de tipo ReflectionClass

Descripción

public ReflectionClass::__construct ( mixed $argument )

Construye un nuevo objeto ReflectionClass.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

argument

O bien un string con el nombre de la clase a reflexionar, o un object.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Funcionamiento básico de ReflectionClass

<?php
Reflection::export(new ReflectionClass('Exception'));
?>

El resultado del ejemplo sería algo similar a:

Class [ <internal:Core> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [7] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
    Property [ <default> private $previous ]
  }

  - Methods [10] {
    Method [ <internal:Core> final private method __clone ] {
    }

    Method [ <internal:Core, ctor> public method __construct ] {

      - Parameters [3] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
        Parameter #2 [ <optional> $previous ]
      }
    }

    Method [ <internal:Core> final public method getMessage ] {
    }

    Method [ <internal:Core> final public method getCode ] {
    }

    Method [ <internal:Core> final public method getFile ] {
    }

    Method [ <internal:Core> final public method getLine ] {
    }

    Method [ <internal:Core> final public method getTrace ] {
    }

    Method [ <internal:Core> final public method getPrevious ] {
    }

    Method [ <internal:Core> final public method getTraceAsString ] {
    }

    Method [ <internal:Core> public method __toString ] {
    }
  }
}

Ver también

  • ReflectionObject::__construct() - Construye un ReflectionObject
  • Constructores


Exporta una clase

  • « ReflectionClass::__construct
  • ReflectionClass::getConstant »
  • PHP Manual
  • ReflectionClass
  • Exporta una clase

ReflectionClass::export

(PHP 5, PHP 7)

ReflectionClass::export — Exporta una clase

Descripción

public static ReflectionClass::export ( mixed $argument , bool $return = false ) : string

Exporta una clase reflejada.

Parámetros

argument

La reflexión a exportar.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::export()

<?php
class Apple {
    public $var1;
    public $var2 = 'Orange';

    public function type() {
        return 'Apple';
    }
}
ReflectionClass::export('Apple');
?>

El resultado del ejemplo sería algo similar a:

Class [ <user> class Apple ] {
  @@ php shell code 1-8

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [2] {
    Property [ <default> public $var1 ]
    Property [ <default> public $var2 ]
  }

  - Methods [1] {
    Method [ <user> public method type ] {
      @@ php shell code 5 - 7
    }
  }
}

Ver también

  • ReflectionClass::getName() - Obtiene el nombre de la clase


Obtener una constante definida

  • « ReflectionClass::export
  • ReflectionClass::getConstants »
  • PHP Manual
  • ReflectionClass
  • Obtener una constante definida

ReflectionClass::getConstant

(PHP 5, PHP 7)

ReflectionClass::getConstant — Obtener una constante definida

Descripción

public ReflectionClass::getConstant ( string $name ) : mixed

Devuelve la constante definida.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Nombre de la constante.

Valores devueltos

Valor de la constante.

Ver también

  • ReflectionClass::getConstants() - Obtener constantes


Obtener constantes

  • « ReflectionClass::getConstant
  • ReflectionClass::getConstructor »
  • PHP Manual
  • ReflectionClass
  • Obtener constantes

ReflectionClass::getConstants

(PHP 5, PHP 7)

ReflectionClass::getConstants — Obtener constantes

Descripción

public ReflectionClass::getConstants ( int|null $filter = null ) : array

Obtiene todas las constantes definidas de una clase, independientemente de su visibilidad.

Parámetros

filter

El filtro opcional, para filtrar las visibilidades constantes deseadas. Se configura utiliando las constantes de ReflectionClassConstant, y por omisión tiene todas las constantes visibles.

Valores devueltos

Un array de constantes. El nombre de la constante en la clave, y en el valor, el valor de la constante.

Historial de cambios

Versión | Descripción
8.0.0 | Se añadió el parámetro filter.

Ver también

  • ReflectionClass::getConstant() - Obtener una constante definida


Obtiene el constructor de una clase

  • « ReflectionClass::getConstants
  • ReflectionClass::getDefaultProperties »
  • PHP Manual
  • ReflectionClass
  • Obtiene el constructor de una clase

ReflectionClass::getConstructor

(PHP 5, PHP 7)

ReflectionClass::getConstructor — Obtiene el constructor de una clase

Descripción

public ReflectionClass::getConstructor ( ) : ReflectionMethod

Obtiene el constructor de la clase reflejada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto ReflectionMethod que refleja el constructor de la clase, o null si la clase no tiene constructor.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getConstructor()

<?php
$clase = new ReflectionClass('ReflectionClass');
$constructor = $clase->getConstructor();
var_dump($constructor);
?>

El resultado del ejemplo sería:

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(11) "__construct"
  ["class"]=>
  string(15) "ReflectionClass"
}

Ver también

  • ReflectionClass::getName() - Obtiene el nombre de la clase


Obtener propiedades predeterminadas

  • « ReflectionClass::getConstructor
  • ReflectionClass::getDocComment »
  • PHP Manual
  • ReflectionClass
  • Obtener propiedades predeterminadas

ReflectionClass::getDefaultProperties

(PHP 5, PHP 7)

ReflectionClass::getDefaultProperties — Obtener propiedades predeterminadas

Descripción

public ReflectionClass::getDefaultProperties ( ) : array

Devuelve las propiedades predeterminadas de una clase (incluyendo las propiedades heredadas).

Nota:

Este método sólo funciona para las propiedades estáticas cuando se utiliza en las clases internas. El valor por defecto de una propiedad de clase estática no puede ser rastreada utilizando este método sobre las clases definidas por el usuario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de propiedades predeterminadas, donde la clave es el nombre de la propiedad y el valor corresponde con el valor de la propiedad o null si la propiedad no tuviera ningún valor predeterminado. Esta función no hace distinción entre propiedades estáticas y no estáticas, y no tiene en cuenta los modificadores de visibilidad.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getDefaultProperties()

<?php
class Bar {
    protected $propiedadHeredada = 'predeterminadoHeredada';
}

class Foo extends Bar {
    public $propiedad = 'predeterminadoPropiedad';
    private $propiedadPrivada = 'predeterminadoPropiedadPrivada';
    public static $propiedadEstatica = 'propiedadEstatica';
    public $propiedadSinValor;
}

$claseReflexion = new ReflectionClass('Foo');
var_dump($claseReflexion->getDefaultProperties());
?>

El resultado del ejemplo sería:

array(5) {
   ["propiedadEstatica"]=>
   string(14) "propiedadEstatia"
   ["propiedad"]=>
   string(15) "predeterminadoPropiedad"
   ["propiedadPrivada"]=>
   string(22) "predeterminadoPropiedadPrivada"
   ["propiedadSinValor"]=>
   NULL
   ["propiedadHeredada"]=>
   string(16) "predeterminadoHeredada"
}

Ver también

  • ReflectionClass::getProperties() - Obtiene las propiedades
  • ReflectionClass::getStaticProperties() - Obtiene las propiedades estáticas
  • ReflectionClass::getProperty() - Obtiene un objeto ReflectionProperty para una propiedad de una clase


Obtener los comentarios de documentación

  • « ReflectionClass::getDefaultProperties
  • ReflectionClass::getEndLine »
  • PHP Manual
  • ReflectionClass
  • Obtener los comentarios de documentación

ReflectionClass::getDocComment

(PHP 5, PHP 7)

ReflectionClass::getDocComment — Obtener los comentarios de documentación

Descripción

public ReflectionClass::getDocComment ( ) : string

Obtiene los comentarios de documentación de una clase.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los comentarios de documentación, o false si no existiera.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getDocComment()

<?php
/**
* Clase de prueba
*
* @param  foo bar
* @return baz
*/
class ClaseDePrueba { }

$rc = new ReflectionClass('ClaseDePrueba');
var_dump($rc->getDocComment())
?>

El resultado del ejemplo sería:

string(55) "/**
* Clase de prueba
*
* @param  foo bar
* @return baz
*/"

Ver también

  • ReflectionClass::getName() - Obtiene el nombre de la clase


Consultar línea final

  • « ReflectionClass::getDocComment
  • ReflectionClass::getExtension »
  • PHP Manual
  • ReflectionClass
  • Consultar línea final

ReflectionClass::getEndLine

(PHP 5, PHP 7)

ReflectionClass::getEndLine — Consultar línea final

Descripción

public ReflectionClass::getEndLine ( ) : int

Devuelve el número de la línea final de una clase definida por el usuario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Número de la línea final de la clase definida por el usuario, o false si fuera desconocida.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getEndLine()

<?php
// Clase de prueba
class ClaseDePrueba { }

$rc = new ReflectionClass('ClaseDePrueba');

echo $rc->getEndLine();
?>

El resultado del ejemplo sería:

3

Ver también

  • ReflectionClass::getStartLine() - Obtiene el número de linea de inicio


Obtiene un objeto ReflectionExtension para la extensión que definió la clase

  • « ReflectionClass::getEndLine
  • ReflectionClass::getExtensionName »
  • PHP Manual
  • ReflectionClass
  • Obtiene un objeto ReflectionExtension para la extensión que definió la clase

ReflectionClass::getExtension

(PHP 5, PHP 7)

ReflectionClass::getExtension — Obtiene un objeto ReflectionExtension para la extensión que definió la clase

Descripción

public ReflectionClass::getExtension ( ) : ReflectionExtension

Obtiene un objeto ReflectionExtension para la extensión que definió la clase.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto ReflectionExtension que representa la extensión que definió la clase, o null para clases definidas por el usuario.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getExtension()

<?php
$clase = new ReflectionClass('ReflectionClass');
$extensión = $clase->getExtension();
var_dump($extensión);
?>

El resultado del ejemplo sería:

object(ReflectionExtension)#2 (1) {
  ["name"]=>
  string(10) "Reflection"
}

Ver también

  • ReflectionClass::getExtensionName() - Obtiene el nombre de la extensión que definió una clase


Obtiene el nombre de la extensión que definió una clase

  • « ReflectionClass::getExtension
  • ReflectionClass::getFileName »
  • PHP Manual
  • ReflectionClass
  • Obtiene el nombre de la extensión que definió una clase

ReflectionClass::getExtensionName

(PHP 5, PHP 7)

ReflectionClass::getExtensionName — Obtiene el nombre de la extensión que definió una clase

Descripción

public ReflectionClass::getExtensionName ( ) : string

Obtiene el nombre de la extensión que definió una clase.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre de la extensión que definió la clase, o false para clases definidas por el usuario.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getExtensionName()

<?php
$clase = new ReflectionClass('ReflectionClass');
$extensión = $clase->getExtensionName();
var_dump($extensión);
?>

El resultado del ejemplo sería:

string(10) "Reflection"

Ver también

  • ReflectionClass::getExtension() - Obtiene un objeto ReflectionExtension para la extensión que definió la clase


Obtiene el nombre de fichero en el que está definida la clase

  • « ReflectionClass::getExtensionName
  • ReflectionClass::getInterfaceNames »
  • PHP Manual
  • ReflectionClass
  • Obtiene el nombre de fichero en el que está definida la clase

ReflectionClass::getFileName

(PHP 5, PHP 7)

ReflectionClass::getFileName — Obtiene el nombre de fichero en el que está definida la clase

Descripción

public ReflectionClass::getFileName ( ) : string

Devuelve el nombre del fichero en el que está definida la clase.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del fichero en el que está definida la clase. Si la clase estuviera definida en el nucleo de PHP o en una extensión de PHP, se devolvería false.

Ver también

  • ReflectionClass::getExtensionName() - Obtiene el nombre de la extensión que definió una clase


Obtiene nombres de las interfaces

  • « ReflectionClass::getFileName
  • ReflectionClass::getInterfaces »
  • PHP Manual
  • ReflectionClass
  • Obtiene nombres de las interfaces

ReflectionClass::getInterfaceNames

(PHP 5 >= 5.2.0, PHP 7)

ReflectionClass::getInterfaceNames — Obtiene nombres de las interfaces

Descripción

public ReflectionClass::getInterfaceNames ( ) : array

Devuelve los nombres de las interfaces.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array numérico con el nombre de las interfaces en el valor.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getInterfaceNames()

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaceNames());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [0] => Foo
    [1] => Bar
)

Ver también

  • ReflectionClass::getInterfaces() - Obtiene las interfaces


Obtiene las interfaces

  • « ReflectionClass::getInterfaceNames
  • ReflectionClass::getMethod »
  • PHP Manual
  • ReflectionClass
  • Obtiene las interfaces

ReflectionClass::getInterfaces

(PHP 5, PHP 7)

ReflectionClass::getInterfaces — Obtiene las interfaces

Descripción

public ReflectionClass::getInterfaces ( ) : array

Devuelve las interfaces.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

array asociativo de interfaces, donde los nombres se usan como claves, y los objetos ReflectionClass como valor.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getInterfaces()

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaces());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [Foo] => ReflectionClass Object
        (
            [name] => Foo
        )

    [Bar] => ReflectionClass Object
        (
            [name] => Bar
        )

)

Ver también

  • ReflectionClass::getInterfaceNames() - Obtiene nombres de las interfaces


Obtiene un objeto ReflectionMethod para un método de una clase

  • « ReflectionClass::getInterfaces
  • ReflectionClass::getMethods »
  • PHP Manual
  • ReflectionClass
  • Obtiene un objeto ReflectionMethod para un método de una clase

ReflectionClass::getMethod

(PHP 5, PHP 7)

ReflectionClass::getMethod — Obtiene un objeto ReflectionMethod para un método de una clase

Descripción

public ReflectionClass::getMethod ( string $name ) : ReflectionMethod

Obtiene un objeto ReflectionMethod para un método de una clase.

Parámetros

name

El nombre de método a reflejar.

Valores devueltos

Un objeto ReflectionMethod.

Errores/Excepciones

Una excepción ReflectionException si el método no existe.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getMethod()

<?php
$clase = new ReflectionClass('ReflectionClass');
$método = $clase->getMethod('getMethod');
var_dump($método);
?>

El resultado del ejemplo sería:

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(9) "getMethod"
  ["class"]=>
  string(15) "ReflectionClass"
}

Ver también

  • ReflectionClass::getMethods() - Obtiene un array de métodos


Obtiene un array de métodos

  • « ReflectionClass::getMethod
  • ReflectionClass::getModifiers »
  • PHP Manual
  • ReflectionClass
  • Obtiene un array de métodos

ReflectionClass::getMethods

(PHP 5, PHP 7)

ReflectionClass::getMethods — Obtiene un array de métodos

Descripción

public ReflectionClass::getMethods ( int $filter = ? ) : array

Obtiene un array de métodos de una clase.

Parámetros

filter

Filtra los resultados para incluir solamente los métodos con ciertos atributos. Lo predeterminado es no filtrar nada.

Cualquier combinación de ReflectionMethod::IS_STATIC,
ReflectionMethod::IS_PUBLIC,
ReflectionMethod::IS_PROTECTED,
ReflectionMethod::IS_PRIVATE,
ReflectionMethod::IS_ABSTRACT,
ReflectionMethod::IS_FINAL.

Valores devueltos

Un array de objetos ReflectionMethod que reflejan cada método.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getMethods()

<?php
class Apple {
    public function firstMethod() { }
    final protected function secondMethod() { }
    private static function thirdMethod() { }
}

$clase = new ReflectionClass('Apple');
$métodos = $clase->getMethods();
var_dump($métodos);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  &object(ReflectionMethod)#2 (2) {
    ["name"]=>
    string(11) "firstMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [1]=>
  &object(ReflectionMethod)#3 (2) {
    ["name"]=>
    string(12) "secondMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [2]=>
  &object(ReflectionMethod)#4 (2) {
    ["name"]=>
    string(11) "thirdMethod"
    ["class"]=>
    string(5) "Apple"
  }
}

Ejemplo #2 Filtrar los resultados de ReflectionClass::getMethods()

<?php
class Apple {
    public function firstMethod() { }
    final protected function secondMethod() { }
    private static function thirdMethod() { }
}

$clase = new ReflectionClass('Apple');
$métodos = $clase->getMethods(ReflectionMethod::IS_STATIC | ReflectionMethod::IS_FINAL);
var_dump($métodos);
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  &object(ReflectionMethod)#2 (2) {
    ["name"]=>
    string(12) "secondMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [1]=>
  &object(ReflectionMethod)#3 (2) {
    ["name"]=>
    string(11) "thirdMethod"
    ["class"]=>
    string(5) "Apple"
  }
}

Ver también

  • ReflectionClass::getMethod() - Obtiene un objeto ReflectionMethod para un método de una clase


Obtiene los modificadores de clase

  • « ReflectionClass::getMethods
  • ReflectionClass::getName »
  • PHP Manual
  • ReflectionClass
  • Obtiene los modificadores de clase

ReflectionClass::getModifiers

(PHP 5, PHP 7)

ReflectionClass::getModifiers — Obtiene los modificadores de clase

Descripción

public ReflectionClass::getModifiers ( ) : int

Devuelve un campo de bits de los modificadores de acceso para esta clase.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una máscara de bits de constantes modificadoras.

Ver también

  • ReflectionClass::getProperties() - Obtiene las propiedades
  • Reflection::getModifierNames() - Obtener nombres de modificadores


Obtiene el nombre de la clase

  • « ReflectionClass::getModifiers
  • ReflectionClass::getNamespaceName »
  • PHP Manual
  • ReflectionClass
  • Obtiene el nombre de la clase

ReflectionClass::getName

(PHP 5, PHP 7)

ReflectionClass::getName — Obtiene el nombre de la clase

Descripción

public ReflectionClass::getName ( ) : string

Devuelve el nombre de la clase.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre de la clase.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getName()

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

El resultado del ejemplo sería:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ver también

  • ReflectionClass::getNamespaceName() - Obtiene el nombre del espacio de nombres


Obtiene el nombre del espacio de nombres

  • « ReflectionClass::getName
  • ReflectionClass::getParentClass »
  • PHP Manual
  • ReflectionClass
  • Obtiene el nombre del espacio de nombres

ReflectionClass::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getNamespaceName — Obtiene el nombre del espacio de nombres

Descripción

public ReflectionClass::getNamespaceName ( ) : string

Devuelve el nombre del espacio de nombres.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre del espacio de nombres.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getNamespaceName()

<?php
namespace A\B;

class Foo { }

$clase = new \ReflectionClass('stdClass');

var_dump($clase->inNamespace());
var_dump($clase->getName());
var_dump($clase->getNamespaceName());
var_dump($clase->getShortName());

$clase = new \ReflectionClass('A\\B\\Foo');

var_dump($clase->inNamespace());
var_dump($clase->getName());
var_dump($clase->getNamespaceName());
var_dump($clase->getShortName());
?>

El resultado del ejemplo sería:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ver también

  • ReflectionClass::getParentClass() - Obtiene la clase padre
  • Espacios de nombres


Obtiene la clase padre

  • « ReflectionClass::getNamespaceName
  • ReflectionClass::getProperties »
  • PHP Manual
  • ReflectionClass
  • Obtiene la clase padre

ReflectionClass::getParentClass

(PHP 5, PHP 7)

ReflectionClass::getParentClass — Obtiene la clase padre

Descripción

public ReflectionClass::getParentClass ( ) : object

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una clase de tipo ReflectionClass.

Ver también

  • ReflectionClass::__construct() - Construye un objeto de tipo ReflectionClass


Obtiene las propiedades

  • « ReflectionClass::getParentClass
  • ReflectionClass::getProperty »
  • PHP Manual
  • ReflectionClass
  • Obtiene las propiedades

ReflectionClass::getProperties

(PHP 5, PHP 7)

ReflectionClass::getProperties — Obtiene las propiedades

Descripción

public ReflectionClass::getProperties ( int $filter = ? ) : array

Devuelve las propiedades reflexionadas.

Parámetros

filter

Filtro opcional, para filtrar el tipo de propiedades deseadas. Se configura usando las constantes de ReflectionProperty, y de manera predeterminada devuelve todos los tipos de propiedades.

Valores devueltos

Un array de objetos ReflectionProperty.

Ejemplos

Ejemplo #1 Ejemplo de filtrado con ReflectionClass::getProperties()

Este ejemplo muestra el uso del parámetro opcional filter, que esencialmente omite las propiedades privadas.

<?php
class Foo {
    public    $foo  = 1;
    protected $bar  = 2;
    private   $baz  = 3;
}

$foo = new Foo();

$reflect = new ReflectionClass($foo);
$props   = $reflect->getProperties(ReflectionProperty::IS_PUBLIC | ReflectionProperty::IS_PROTECTED);

foreach ($props as $prop) {
    print $prop->getName() . "\n";
}

var_dump($props);

?>

El resultado del ejemplo sería algo similar a:

foo
bar
array(2) {
  [0]=>
  object(ReflectionProperty)#3 (2) {
    ["name"]=>
    string(3) "foo"
    ["class"]=>
    string(3) "Foo"
  }
  [1]=>
  object(ReflectionProperty)#4 (2) {
    ["name"]=>
    string(3) "bar"
    ["class"]=>
    string(3) "Foo"
  }
}

Ver también

  • ReflectionClass::getProperty() - Obtiene un objeto ReflectionProperty para una propiedad de una clase
  • ReflectionProperty
  • Constantes de ReflectionProperty


Obtiene un objeto ReflectionProperty para una propiedad de una clase

  • « ReflectionClass::getProperties
  • ReflectionClass::getReflectionConstant »
  • PHP Manual
  • ReflectionClass
  • Obtiene un objeto ReflectionProperty para una propiedad de una clase

ReflectionClass::getProperty

(PHP 5, PHP 7)

ReflectionClass::getProperty — Obtiene un objeto ReflectionProperty para una propiedad de una clase

Descripción

public ReflectionClass::getProperty ( string $name ) : ReflectionProperty

Obtiene un objeto ReflectionProperty para una propiedad de una clase.

Parámetros

name

El nombre de la propiedad.

Valores devueltos

Un objeto ReflectionProperty.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getProperty()

<?php
$clase = new ReflectionClass('ReflectionClass');
$propiedad = $clase->getProperty('name');
var_dump($propiedad);
?>

El resultado del ejemplo sería:

object(ReflectionProperty)#2 (2) {
  ["name"]=>
  string(4) "name"
  ["class"]=>
  string(15) "ReflectionClass"
}

Ver también

  • ReflectionClass::getProperties() - Obtiene las propiedades


Gets a ReflectionClassConstant for a class's constant

  • « ReflectionClass::getProperty
  • ReflectionClass::getReflectionConstants »
  • PHP Manual
  • ReflectionClass
  • Gets a ReflectionClassConstant for a class's constant

ReflectionClass::getReflectionConstant

(PHP 7 >= 7.1.0)

ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant

Descripción

public ReflectionClass::getReflectionConstant ( string $name ) : ReflectionClassConstant|false

Gets a ReflectionClassConstant for a class's property.

Parámetros

name

The class constant name.

Valores devueltos

A ReflectionClassConstant, o false en caso de error.

Ver también

  • ReflectionClass::getReflectionConstants() - Gets class constants
  • ReflectionClassConstant


Gets class constants

  • « ReflectionClass::getReflectionConstant
  • ReflectionClass::getShortName »
  • PHP Manual
  • ReflectionClass
  • Gets class constants

ReflectionClass::getReflectionConstants

(PHP 7 >= 7.1.0)

ReflectionClass::getReflectionConstants — Gets class constants

Descripción

public ReflectionClass::getReflectionConstants ( int|null $filter = null ) : array

Retrieves reflected constants.

Parámetros

filter

The optional filter, for filtering desired constant visibilities. It's configured using the ReflectionClassConstant constants, and defaults to all constant visibilities.

Valores devueltos

An array of ReflectionClassConstant objects.

Historial de cambios

Versión | Descripción
8.0.0 | filter has been added.

Ejemplos

Ejemplo #1 Basic ReflectionClass::getReflectionConstants() example

<?php
class Foo {
    public    const FOO  = 1;
    protected const BAR  = 2;
    private   const BAZ  = 3;
}

$foo = new Foo();

$reflect = new ReflectionClass($foo);
$consts  = $reflect->getReflectionConstants();

foreach ($consts as $const) {
    print $const->getName() . "\n";
}

var_dump($consts);

?>

El resultado del ejemplo sería algo similar a:

FOO
BAR
BAZ
array(3) {
  [0]=>
  object(ReflectionClassConstant)#3 (2) {
    ["name"]=>
    string(3) "FOO"
    ["class"]=>
    string(3) "Foo"
  }
  [1]=>
  object(ReflectionClassConstant)#4 (2) {
    ["name"]=>
    string(3) "BAR"
    ["class"]=>
    string(3) "Foo"
  }
  [2]=>
  object(ReflectionClassConstant)#5 (2) {
    ["name"]=>
    string(3) "BAZ"
    ["class"]=>
    string(3) "Foo"
  }
}

Ver también

  • ReflectionClass::getReflectionConstant() - Gets a ReflectionClassConstant for a class's constant
  • ReflectionClassConstant


Obtiene el nombre abreviado

  • « ReflectionClass::getReflectionConstants
  • ReflectionClass::getStartLine »
  • PHP Manual
  • ReflectionClass
  • Obtiene el nombre abreviado

ReflectionClass::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getShortName — Obtiene el nombre abreviado

Descripción

public ReflectionClass::getShortName ( ) : string

Devuelve el nombre abreviado de la clase, es decir, sin el espacio de nombres.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre abreviado de la clase.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::getShortName()

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

El resultado del ejemplo sería:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ver también

  • ReflectionClass::getName() - Obtiene el nombre de la clase


Obtiene el número de linea de inicio

  • « ReflectionClass::getShortName
  • ReflectionClass::getStaticProperties »
  • PHP Manual
  • ReflectionClass
  • Obtiene el número de linea de inicio

ReflectionClass::getStartLine

(PHP 5, PHP 7)

ReflectionClass::getStartLine — Obtiene el número de linea de inicio

Descripción

public ReflectionClass::getStartLine ( ) : int

Devuelve el número de la línea de inicio.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de la línea de inicio, en forma de integer.

Ver también

  • ReflectionClass::getEndLine() - Consultar línea final


Obtiene las propiedades estáticas

  • « ReflectionClass::getStartLine
  • ReflectionClass::getStaticPropertyValue »
  • PHP Manual
  • ReflectionClass
  • Obtiene las propiedades estáticas

ReflectionClass::getStaticProperties

(PHP 5, PHP 7)

ReflectionClass::getStaticProperties — Obtiene las propiedades estáticas

Descripción

public ReflectionClass::getStaticProperties ( ) : array

Devuelve las propiedades estáticas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Las propiedades estáticas, en un array.

Ver también

  • ReflectionClass::getStaticPropertyValue() - Obtiene el valor de una propiedad estática
  • ReflectionClass::setStaticPropertyValue() - Establece el valor de una propiedad estática


Obtiene el valor de una propiedad estática

  • « ReflectionClass::getStaticProperties
  • ReflectionClass::getTraitAliases »
  • PHP Manual
  • ReflectionClass
  • Obtiene el valor de una propiedad estática

ReflectionClass::getStaticPropertyValue

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::getStaticPropertyValue — Obtiene el valor de una propiedad estática

Descripción

public ReflectionClass::getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed

Obtiene el valor de una propiedad estática de esta clase.

Parámetros

name

El nombre de la propiedad estática para la que devolver un valor.

def_value

Un valor predeterminado a devolver en caso de que la clase no declare propiedades estáticas con el name dado. Si la propiedad no existe y se omite este argumento, se lanza una ReflectionException.

Valores devueltos

El valor de la propiedad estática.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::getStaticPropertyValue()

<?php
class Apple {
    public static $color = 'Rojo';
}

$class = new ReflectionClass('Apple');
var_dump($class->getStaticPropertyValue('color'));
?>

El resultado del ejemplo sería:

string(4) "Rojo"

Ver también

  • ReflectionClass::getStaticProperties() - Obtiene las propiedades estáticas
  • ReflectionClass::setStaticPropertyValue() - Establece el valor de una propiedad estática


Obtiene un array con los alias usados con los traits

  • « ReflectionClass::getStaticPropertyValue
  • ReflectionClass::getTraitNames »
  • PHP Manual
  • ReflectionClass
  • Obtiene un array con los alias usados con los traits

ReflectionClass::getTraitAliases

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraitAliases — Obtiene un array con los alias usados con los traits

Descripción

public ReflectionClass::getTraitAliases ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array, usando para las claves los nuevos nombres de métodos y para los valores los nombres originales (en el formato "TraitName::original"). En caso de error, devuelve null.


Devuelve un array con los nombres de los traits usados por esta clase

  • « ReflectionClass::getTraitAliases
  • ReflectionClass::getTraits »
  • PHP Manual
  • ReflectionClass
  • Devuelve un array con los nombres de los traits usados por esta clase

ReflectionClass::getTraitNames

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraitNames — Devuelve un array con los nombres de los traits usados por esta clase

Descripción

public ReflectionClass::getTraitNames ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con los nombres de los traits en los valores. En caso de error, devuelve null.


Obtiene un array con los traits que utiliza esta clase

  • « ReflectionClass::getTraitNames
  • ReflectionClass::hasConstant »
  • PHP Manual
  • ReflectionClass
  • Obtiene un array con los traits que utiliza esta clase

ReflectionClass::getTraits

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraits — Obtiene un array con los traits que utiliza esta clase

Descripción

public ReflectionClass::getTraits ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array con los nombres de los traits en las claves, y en el valor las instancias de los objetos ReflectionClass. En caso de error, devuelve null.


Comprueba si una constante está o no definida

  • « ReflectionClass::getTraits
  • ReflectionClass::hasMethod »
  • PHP Manual
  • ReflectionClass
  • Comprueba si una constante está o no definida

ReflectionClass::hasConstant

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasConstant — Comprueba si una constante está o no definida

Descripción

public ReflectionClass::hasConstant ( string $name ) : bool

Comprueba si la constante especificada está o no definida en la clase.

Parámetros

name

Nombre de la constante que se desea comprobar.

Valores devueltos

true si la constante está definida, y en cualquier otro caso false.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::hasConstant()

<?php
class Foo {
    const c1 = 1;
}

$class = new ReflectionClass("Foo");

var_dump($class->hasConstant("c1"));
var_dump($class->hasConstant("c2"));
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)

Ver también

  • ReflectionClass::hasMethod() - Comprueba si un método está o no definido
  • ReflectionClass::hasProperty() - Comprueba si una propiedad está o no definida


Comprueba si un método está o no definido

  • « ReflectionClass::hasConstant
  • ReflectionClass::hasProperty »
  • PHP Manual
  • ReflectionClass
  • Comprueba si un método está o no definido

ReflectionClass::hasMethod

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasMethod — Comprueba si un método está o no definido

Descripción

public ReflectionClass::hasMethod ( string $name ) : bool

Comprueba si el método especificado está o no definido en la clase.

Parámetros

name

Nombre del método que se desea comprobar.

Valores devueltos

true si el método está definido, y en cualquier otro caso false

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::hasMethod()

<?php
Class C {
    public function publicFoo() {
        return true;
    }

    protected function protectedFoo() {
        return true;
    }

    private function privateFoo() {
        return true;
    }

    static function staticFoo() {
        return true;
    }
}

$rc = new ReflectionClass("C");

var_dump($rc->hasMethod('publicFoo'));

var_dump($rc->hasMethod('protectedFoo'));

var_dump($rc->hasMethod('privateFoo'));

var_dump($rc->hasMethod('staticFoo'));

// C should not have method bar
var_dump($rc->hasMethod('bar'));

// Method names are case insensitive
var_dump($rc->hasMethod('PUBLICfOO'));
?>

El resultado del ejemplo sería:

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)

Ver también

  • ReflectionClass::hasConstant() - Comprueba si una constante está o no definida
  • ReflectionClass::hasProperty() - Comprueba si una propiedad está o no definida


Comprueba si una propiedad está o no definida

  • « ReflectionClass::hasMethod
  • ReflectionClass::implementsInterface »
  • PHP Manual
  • ReflectionClass
  • Comprueba si una propiedad está o no definida

ReflectionClass::hasProperty

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasProperty — Comprueba si una propiedad está o no definida

Descripción

public ReflectionClass::hasProperty ( string $name ) : bool

Comprueba si la propiedad especificada está o no definida.

Parámetros

name

Nombre de la propiedad que se desea comprobar.

Valores devueltos

true si la propiedad está definida, y en cualquier otro caso false

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::hasProperty()

<?php
class Foo {
    public    $p1;
    protected $p2;
    private   $p3;

}

$obj = new ReflectionObject(new Foo());

var_dump($obj->hasProperty("p1"));
var_dump($obj->hasProperty("p2"));
var_dump($obj->hasProperty("p3"));
var_dump($obj->hasProperty("p4"));
?>

El resultado del ejemplo sería algo similar a:

bool(true)
bool(true)
bool(true)
bool(false)

Ver también

  • ReflectionClass::hasConstant() - Comprueba si una constante está o no definida
  • ReflectionClass::hasMethod() - Comprueba si un método está o no definido


Comprueba si se implementa una determinada interfaz

  • « ReflectionClass::hasProperty
  • ReflectionClass::inNamespace »
  • PHP Manual
  • ReflectionClass
  • Comprueba si se implementa una determinada interfaz

ReflectionClass::implementsInterface

(PHP 5, PHP 7)

ReflectionClass::implementsInterface — Comprueba si se implementa una determinada interfaz

Descripción

public ReflectionClass::implementsInterface ( string $interface ) : bool

Comprueba si la clase implementa o no una determinada interfaz.

Parámetros

interface

Nombre de la interfaz.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ReflectionClass::isInterface() - Comprueba una la clase es una interfaz
  • ReflectionClass::isSubclassOf() - Comprueba si es una subclase
  • interface_exists() - Comprueba si una interfaz ha sido definida
  • Interfaces de objetos


Comprueba si pertenece a un determinado espacio de nombres

  • « ReflectionClass::implementsInterface
  • ReflectionClass::isAbstract »
  • PHP Manual
  • ReflectionClass
  • Comprueba si pertenece a un determinado espacio de nombres

ReflectionClass::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::inNamespace — Comprueba si pertenece a un determinado espacio de nombres

Descripción

public ReflectionClass::inNamespace ( ) : bool

Comprueba si esta clase está definida en el espacio de nombres especificado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::inNamespace()

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

El resultado del ejemplo sería:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ver también

  • ReflectionClass::getNamespaceName() - Obtiene el nombre del espacio de nombres
  • PHP Namespaces


Comprueba si la clase es abstracta

  • « ReflectionClass::inNamespace
  • ReflectionClass::isAnonymous »
  • PHP Manual
  • ReflectionClass
  • Comprueba si la clase es abstracta

ReflectionClass::isAbstract

(PHP 5, PHP 7)

ReflectionClass::isAbstract — Comprueba si la clase es abstracta

Descripción

public ReflectionClass::isAbstract ( ) : bool

Comprueba si la clase es o no abstracta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::isAbstract()

<?php
class          ClaseDePrueba { }
abstract class ClaseAbstractaDePrueba { }

$claseDePrueba  = new ReflectionClass('ClaseDePrueba');
$claseAbstracta = new ReflectionClass('ClaseAbstractaDePrueba');

var_dump($claseDePrueba->isAbstract());
var_dump($claseAbstracta->isAbstract());
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionClass::isInterface() - Comprueba una la clase es una interfaz
  • Class Abstraction


Checks if class is anonymous

  • « ReflectionClass::isAbstract
  • ReflectionClass::isCloneable »
  • PHP Manual
  • ReflectionClass
  • Checks if class is anonymous

ReflectionClass::isAnonymous

(PHP 7)

ReflectionClass::isAnonymous — Checks if class is anonymous

Descripción

public ReflectionClass::isAnonymous ( ) : bool

Checks if a class is an anonymous class.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 ReflectionClass::isAnonymous() example

<?php
class TestClass {}
$anonClass = new class {};

$normalClass = new ReflectionClass('TestClass');
$anonClass  = new ReflectionClass($anonClass);

var_dump($normalClass->isAnonymous());
var_dump($anonClass->isAnonymous());

?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionClass::isFinal() - Comprueba si la clase inal


Comprueba si la clase es o no clonable

  • « ReflectionClass::isAnonymous
  • ReflectionClass::isFinal »
  • PHP Manual
  • ReflectionClass
  • Comprueba si la clase es o no clonable

ReflectionClass::isCloneable

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::isCloneable — Comprueba si la clase es o no clonable

Descripción

public ReflectionClass::isCloneable ( ) : bool

Comprueba si la clase es o no clonable

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la clase es clonable, o false en caso contrario.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::isCloneable()

<?php
class NoClonable {
    public $var1;

    private function __clone() {
    }
}

class Clonable {
    public $var1;
}

$noClonable = new ReflectionClass('NoClonable');
$clonable = new ReflectionClass('Clonable');

var_dump($noClonable->isCloneable());
var_dump($clonable->isCloneable());
?>

El resultado del ejemplo sería:

bool(false)
bool(true)


Comprueba si la clase inal

  • « ReflectionClass::isCloneable
  • ReflectionClass::isInstance »
  • PHP Manual
  • ReflectionClass
  • Comprueba si la clase inal

ReflectionClass::isFinal

(PHP 5, PHP 7)

ReflectionClass::isFinal — Comprueba si la clase inal

Descripción

public ReflectionClass::isFinal ( ) : bool

Comprueba si la clase es final.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::isFinal()

<?php
class       ClaseDePrueba { }
final class ClaseFinalDePrueba { }

$claseNormal = new ReflectionClass('ClaseDePrueba');
$claseFinal  = new ReflectionClass('ClaseFinalDePrueba');

var_dump($claseNormal->isFinal());
var_dump($claseFinal->isFinal());

?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionClass::isAbstract() - Comprueba si la clase es abstracta
  • La palabra reservada 'final'


Comprueba si un objeto es instancia de la clase

  • « ReflectionClass::isFinal
  • ReflectionClass::isInstantiable »
  • PHP Manual
  • ReflectionClass
  • Comprueba si un objeto es instancia de la clase

ReflectionClass::isInstance

(PHP 5, PHP 7)

ReflectionClass::isInstance — Comprueba si un objeto es instancia de la clase

Descripción

public ReflectionClass::isInstance ( object $object ) : bool

Comprueba si un objeto es una instancia de la clase.

Parámetros

object

Objeto a comparar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo relacionado con ReflectionClass::isInstance()

<?php
// Ejemplo de uso
$class = new ReflectionClass('Foo');

if ($class->isInstance($arg)) {
    echo "Sí";
}

// Equivalente a
if ($arg instanceof Foo) {
    echo "Sí";
}

// Equivalente a
if (is_a($arg, 'Foo')) {
    echo "Sí";
}
?>

El resultado del ejemplo sería algo similar a:

Yes
Yes
Yes

Ver también

  • ReflectionClass::isInterface() - Comprueba una la clase es una interfaz
  • Operadores de tipo (instanceof)
  • Interfaces de objectos
  • is_a() - Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres


Comprueba si una clase es instanciable

  • « ReflectionClass::isInstance
  • ReflectionClass::isInterface »
  • PHP Manual
  • ReflectionClass
  • Comprueba si una clase es instanciable

ReflectionClass::isInstantiable

(PHP 5, PHP 7)

ReflectionClass::isInstantiable — Comprueba si una clase es instanciable

Descripción

public ReflectionClass::isInstantiable ( ) : bool

Comprueba si una clase es instanciable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::isInstantiable()

<?php
class C { }

interface ifaz {
    function f1();
}

class ifazImpl implements ifaz {
    function f1() {}
}

abstract class claseAbstracta {
    function f1() { }
    abstract function f2();
}

class D extends claseAbstracta {
    function f2() { }
}

class constructorPrivado {
    private function __construct() { }
}

$clases = array(
    "C",
    "ifaz",
    "ifazImpl",
    "claseAbstracta",
    "D",
    "constructorPrivado",
);

foreach($clases  as $clase ) {
    $reflectionClass = new ReflectionClass($clase);
    echo "¿Es instanciable la clase $clase?  ";
    var_dump($reflectionClass->IsInstantiable());
}

?>

El resultado del ejemplo sería:

¿Es instanciable la clase C?  bool(true)
¿Es instanciable la clase ifaz?  bool(false)
¿Es instanciable la clase ifazImpl?  bool(true)
¿Es instanciable la clase claseAbstracta?  bool(false)
¿Es instanciable la clase D?  bool(true)
¿Es instanciable la clase constructorPrivado?  bool(false)

Ver también

  • ReflectionClass::isInstance() - Comprueba si un objeto es instancia de la clase


Comprueba una la clase es una interfaz

  • « ReflectionClass::isInstantiable
  • ReflectionClass::isInternal »
  • PHP Manual
  • ReflectionClass
  • Comprueba una la clase es una interfaz

ReflectionClass::isInterface

(PHP 5, PHP 7)

ReflectionClass::isInterface — Comprueba una la clase es una interfaz

Descripción

public ReflectionClass::isInterface ( ) : bool

Comprueba si una clase es una interfaz.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::isInterface()

<?php
interface AlgunaInterfaz {
    public function interfaceMethod();
}

$class = new ReflectionClass('AlgunaInterfaz');
var_dump($class->isInterface());
?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • ReflectionClass::isInstance() - Comprueba si un objeto es instancia de la clase


Comprueba si una clase está definida internamente por una extensión o por el núcleo

  • « ReflectionClass::isInterface
  • ReflectionClass::isIterable »
  • PHP Manual
  • ReflectionClass
  • Comprueba si una clase está definida internamente por una extensión o por el núcleo

ReflectionClass::isInternal

(PHP 5, PHP 7)

ReflectionClass::isInternal — Comprueba si una clase está definida internamente por una extensión o por el núcleo

Descripción

public ReflectionClass::isInternal ( ) : bool

Comprueba si una clase está definida internamente por una extensión o por el núcleo, en oposición a estar definida por el usuario.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::isInternal()

<?php
$claseInterna = new ReflectionClass('ReflectionClass');

class Apple {}
$claseDeUsuario = new ReflectionClass('Apple');

var_dump($claseInterna->isInternal());
var_dump($claseDeUsuario->isInternal());
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ver también

  • ReflectionClass::isUserDefined() - Comprueba si es una clase definida por el usuario


Check whether this class is iterable

  • « ReflectionClass::isInternal
  • ReflectionClass::isIterateable »
  • PHP Manual
  • ReflectionClass
  • Check whether this class is iterable

ReflectionClass::isIterable

(PHP 7 >= 7.2.0)

ReflectionClass::isIterable — Check whether this class is iterable

Descripción

public ReflectionClass::isIterable ( ) : bool

Check whether this class is iterable (i.e. can be used inside foreach).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Basic ReflectionClass::isIterable() Usage

<?php

class IteratorClass implements Iterator {
    public function __construct() { }
    public function key() { }
    public function current() { }
    function next() { }
    function valid() { }
    function rewind() { }
}
class DerivedClass extends IteratorClass { }
class NonIterator { }

function dump_iterable($class) {
    $reflection = new ReflectionClass($class);
    var_dump($reflection->isIterable());
}

$classes = array("ArrayObject", "IteratorClass", "DerivedClass", "NonIterator");

foreach ($classes as $class) {
    echo "Is $class iterable? ";
    dump_iterable($class);
}
?>

El resultado del ejemplo sería:

Is ArrayObject iterable? bool(true)
Is IteratorClass iterable? bool(true)
Is DerivedClass iterable? bool(true)
Is NonIterator iterable? bool(false)

Ver también

  • ReflectionClass::__construct() - Construye un objeto de tipo ReflectionClass


Comprueba si es iterable

  • « ReflectionClass::isIterable
  • ReflectionClass::isSubclassOf »
  • PHP Manual
  • ReflectionClass
  • Comprueba si es iterable

ReflectionClass::isIterateable

(PHP 5, PHP 7)

ReflectionClass::isIterateable — Comprueba si es iterable

Descripción

public ReflectionClass::isIterateable ( ) : bool

Comprueba si la clase es o no iterable.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::isIterateable()

<?php

class ClaseIterable implements Iterator {
    public function __construct() { }
    public function key() { }
    public function current() { }
    function next() { }
    function valid() { }
    function rewind() { }
}
class ClaseDerivada extends ClaseIterable { }
class NoIterable { }

function dump_iterable($clase) {
    $reflection = new ReflectionClass($clase);
    var_dump($reflection->isIterateable());
}

$clases = array("ArrayObject", "ClaseIterable", "ClaseDerivada", "NoIterable");

foreach ($clases as $clase) {
    echo "Es iterable la clase $clase? ";
    dump_iterable($clase);
}
?>

El resultado del ejemplo sería:

Es iterable la clase ArrayObject? bool(true)
Es iterable la clase ClaseIterable? bool(true)
Es iterable la clase ClaseDerivada? bool(true)
Es iterable la clase NoIterable? bool(false)

Ver también

  • ReflectionClass::__construct() - Construye un objeto de tipo ReflectionClass


Comprueba si es una subclase

  • « ReflectionClass::isIterateable
  • ReflectionClass::isTrait »
  • PHP Manual
  • ReflectionClass
  • Comprueba si es una subclase

ReflectionClass::isSubclassOf

(PHP 5, PHP 7)

ReflectionClass::isSubclassOf — Comprueba si es una subclase

Descripción

public ReflectionClass::isSubclassOf ( string $class ) : bool

Comprueba si la clase es una subclase de la clase especificada o implementa una iterfaz específica.

Parámetros

class

Nombre de la clase con la que hacer la comprobación.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ReflectionClass::isInterface() - Comprueba una la clase es una interfaz
  • ReflectionClass::implementsInterface() - Comprueba si se implementa una determinada interfaz
  • is_subclass_of() - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa
  • get_parent_class() - Recupera el nombre de la clase padre de un objeto o clase


Comprueba si es un trait

  • « ReflectionClass::isSubclassOf
  • ReflectionClass::isUserDefined »
  • PHP Manual
  • ReflectionClass
  • Comprueba si es un trait

ReflectionClass::isTrait

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::isTrait — Comprueba si es un trait

Descripción

public ReflectionClass::isTrait ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si es un trait, y si no false. En caso de error, devuelve null.


Comprueba si es una clase definida por el usuario

  • « ReflectionClass::isTrait
  • ReflectionClass::newInstance »
  • PHP Manual
  • ReflectionClass
  • Comprueba si es una clase definida por el usuario

ReflectionClass::isUserDefined

(PHP 5, PHP 7)

ReflectionClass::isUserDefined — Comprueba si es una clase definida por el usuario

Descripción

public ReflectionClass::isUserDefined ( ) : bool

Comprueba si una clase está definida por un usuario, en oposición a una clase interna.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • ReflectionClass::isInternal() - Comprueba si una clase está definida internamente por una extensión o por el núcleo


Crea una nueva instancia de clase a partir de la lista de parámetros dados

  • « ReflectionClass::isUserDefined
  • ReflectionClass::newInstanceArgs »
  • PHP Manual
  • ReflectionClass
  • Crea una nueva instancia de clase a partir de la lista de parámetros dados

ReflectionClass::newInstance

(PHP 5, PHP 7)

ReflectionClass::newInstance — Crea una nueva instancia de clase a partir de la lista de parámetros dados

Descripción

public ReflectionClass::newInstance ( mixed $args , mixed $... = ? ) : object

Crea una nueva instancia de la clase. Los parámetros proporcionados se pasarán al constructor de la clase.

Parámetros

args

Acepta un número variable de argumentos, que se pasarán al constructor de la clase. Similar a como hace call_user_func().

Valores devueltos

Errores/Excepciones

Lanza ReflectionException si el constructor de la clase no fuera público.

Lanza ReflectionException si la clase no tuviera un constructor y el parámetro args tuviera uno o más argumentos.

Ver también

  • ReflectionClass::newInstanceArgs() - Crea una nueva instancia de clase a partir de los argumentos dados
  • ReflectionClass::newInstanceWithoutConstructor() - Crea una nueva clase sin invocar al constructor


Crea una nueva instancia de clase a partir de los argumentos dados

  • « ReflectionClass::newInstance
  • ReflectionClass::newInstanceWithoutConstructor »
  • PHP Manual
  • ReflectionClass
  • Crea una nueva instancia de clase a partir de los argumentos dados

ReflectionClass::newInstanceArgs

(PHP 5 >= 5.1.3, PHP 7)

ReflectionClass::newInstanceArgs — Crea una nueva instancia de clase a partir de los argumentos dados

Descripción

public ReflectionClass::newInstanceArgs ( array $args = ? ) : object

Crea una nueva instancia de la clase, pasando los argumentos al constructor de la clase.

Parámetros

args

Los parámetros a pasar al constructor de la clase, como array.

Valores devueltos

Devuelve una nueva instancia de la clase.

Ejemplos

Ejemplo #1 Uso básico de ReflectionClass::newInstanceArgs()

<?php
$clase = new ReflectionClass('ReflectionFunction');
$instancia = $clase->newInstanceArgs(array('substr'));
var_dump($instancia);
?>

El resultado del ejemplo sería:

object(ReflectionFunction)#2 (1) {
  ["name"]=>
  string(6) "substr"
}

Errores/Excepciones

Lanza una excepción de tipo ReflectionException si el constructor de la clase no es público.

Lanza una excepción de tipo ReflectionException si la clase no tuviera un constructor y el parámetro args contuviera uno o más parámetros.

Ver también

  • ReflectionClass::newInstance() - Crea una nueva instancia de clase a partir de la lista de parámetros dados
  • ReflectionClass::newInstanceWithoutConstructor() - Crea una nueva clase sin invocar al constructor


Crea una nueva clase sin invocar al constructor

  • « ReflectionClass::newInstanceArgs
  • ReflectionClass::setStaticPropertyValue »
  • PHP Manual
  • ReflectionClass
  • Crea una nueva clase sin invocar al constructor

ReflectionClass::newInstanceWithoutConstructor

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::newInstanceWithoutConstructor — Crea una nueva clase sin invocar al constructor

Descripción

public ReflectionClass::newInstanceWithoutConstructor ( ) : object

Crea una nueva instancia de la clase sin llegar a invocar al constructor.

Parámetros

Valores devueltos

Historial de cambios

Versión | Descripción
5.6.0 | Ahora todas las clases internas pueden ser instanciadas, excepto aquellas declaradas final.

Errores/Excepciones

Lanza una ReflectionException si la clase es una clase interna que no puede ser instanciada sin invocar al constructor. En PHP 5.6.0 en adelante, esta excepción está limitada solamente a clases internas que son final.

Ver también

  • ReflectionClass::newInstance() - Crea una nueva instancia de clase a partir de la lista de parámetros dados
  • ReflectionClass::newInstanceArgs() - Crea una nueva instancia de clase a partir de los argumentos dados


Establece el valor de una propiedad estática

  • « ReflectionClass::newInstanceWithoutConstructor
  • ReflectionClass::__toString »
  • PHP Manual
  • ReflectionClass
  • Establece el valor de una propiedad estática

ReflectionClass::setStaticPropertyValue

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::setStaticPropertyValue — Establece el valor de una propiedad estática

Descripción

public ReflectionClass::setStaticPropertyValue ( string $name , string $value ) : void

Establece el valor de una propiedad estática.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Nombre de la propiedad.

value

Nuevo valor de la propiedad.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ReflectionClass::getStaticPropertyValue() - Obtiene el valor de una propiedad estática


Devuelve la representación en forma de string del objeto ReflectionClass

  • « ReflectionClass::setStaticPropertyValue
  • ReflectionClassConstant »
  • PHP Manual
  • ReflectionClass
  • Devuelve la representación en forma de string del objeto ReflectionClass

ReflectionClass::__toString

(PHP 5, PHP 7)

ReflectionClass::__toString — Devuelve la representación en forma de string del objeto ReflectionClass

Descripción

public ReflectionClass::__toString ( ) : string

Devuelve la representación en forma de string del objeto ReflectionClass.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Representación en forma de string de esta instancia de ReflectionClass.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::__toString()

<?php
$reflectionClass = new ReflectionClass('Exception');
echo $reflectionClass->__toString();
?>

El resultado del ejemplo sería:

Class [ <internal:Core> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [7] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
    Property [ <default> private $previous ]
  }

  - Methods [10] {
    Method [ <internal:Core> final private method __clone ] {
    }

    Method [ <internal:Core, ctor> public method __construct ] {

      - Parameters [3] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
        Parameter #2 [ <optional> $previous ]
      }
    }

    Method [ <internal:Core> final public method getMessage ] {
    }

    Method [ <internal:Core> final public method getCode ] {
    }

    Method [ <internal:Core> final public method getFile ] {
    }

    Method [ <internal:Core> final public method getLine ] {
    }

    Method [ <internal:Core> final public method getTrace ] {
    }

    Method [ <internal:Core> final public method getPrevious ] {
    }

    Method [ <internal:Core> final public method getTraceAsString ] {
    }

    Method [ <internal:Core> public method __toString ] {
    }
  }
}

Ver también

  • ReflectionClass::export() - Exporta una clase
  • __toString()


The ReflectionClassConstant class

(PHP 7 >= 7.1.0)

Introducción

The ReflectionClassConstant class reports information about a class constant.

Sinopsis de la Clase

ReflectionClassConstant implements Reflector {
/* Constantes */
const int IS_PUBLIC ;
const int IS_PROTECTED ;
const int IS_PRIVATE ;
/* Propiedades */
public $name ;
public $class ;
/* Métodos */
public __construct ( object|string $class , string $constant )
public static export ( mixed $class , string $name , bool $return = ? ) : string
public getDeclaringClass ( ) : ReflectionClass
public getDocComment ( ) : string|false
public getModifiers ( ) : int
public getName ( ) : string|false
public getValue ( ) : mixed
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public __toString ( ) : string
}

Propiedades

name

Name of the class constant. Read-only, throws ReflectionException in attempt to write.

class

Name of the class where the class constant is defined. Read-only, throws ReflectionException in attempt to write.

Constantes predefinidas

ReflectionClassConstant Modifiers

ReflectionClassConstant::IS_PUBLIC

Indicates public constants.

ReflectionClassConstant::IS_PROTECTED

Indicates protected constants.

ReflectionClassConstant::IS_PRIVATE

Indicates private constants.

Tabla de contenidos

  • ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant
  • ReflectionClassConstant::export — Export
  • ReflectionClassConstant::getDeclaringClass — Gets declaring class
  • ReflectionClassConstant::getDocComment — Gets doc comments
  • ReflectionClassConstant::getModifiers — Gets the class constant modifiers
  • ReflectionClassConstant::getName — Get name of the constant
  • ReflectionClassConstant::getValue — Gets value
  • ReflectionClassConstant::isPrivate — Checks if class constant is private
  • ReflectionClassConstant::isProtected — Checks if class constant is protected
  • ReflectionClassConstant::isPublic — Checks if class constant is public
  • ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object


Constructs a ReflectionClassConstant

  • « ReflectionClassConstant
  • ReflectionClassConstant::export »
  • PHP Manual
  • ReflectionClassConstant
  • Constructs a ReflectionClassConstant

ReflectionClassConstant::__construct

(PHP 7 >= 7.1.0)

ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant

Descripción

public ReflectionClassConstant::__construct ( object|string $class , string $constant )

Constructs a new ReflectionClassConstant object.

Parámetros

class

Either a string containing the name of the class to reflect, or an object.

constant

The name of the class constant.

Valores devueltos

Returns constructed ReflectionClassConstant instance.

Errores/Excepciones

Throws an Exception in case the given class constant does not exist.

Ver también

  • Constructors


Export

  • « ReflectionClassConstant::__construct
  • ReflectionClassConstant::getDeclaringClass »
  • PHP Manual
  • ReflectionClassConstant
  • Export

ReflectionClassConstant::export

(PHP 7 >= 7.1.0)

ReflectionClassConstant::export — Export

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.4.0. Su uso está totalmente desaconsejado

Descripción

public static ReflectionClassConstant::export ( mixed $class , string $name , bool $return = ? ) : string

Exports a reflection.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

class

La reflexión a exportar.

name

The class constant name.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Ver también

  • ReflectionClassConstant::__toString() - Returns the string representation of the ReflectionClassConstant object


Gets declaring class

  • « ReflectionClassConstant::export
  • ReflectionClassConstant::getDocComment »
  • PHP Manual
  • ReflectionClassConstant
  • Gets declaring class

ReflectionClassConstant::getDeclaringClass

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getDeclaringClass — Gets declaring class

Descripción

public ReflectionClassConstant::getDeclaringClass ( ) : ReflectionClass

Gets the declaring class.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A ReflectionClass object.


Gets doc comments

  • « ReflectionClassConstant::getDeclaringClass
  • ReflectionClassConstant::getModifiers »
  • PHP Manual
  • ReflectionClassConstant
  • Gets doc comments

ReflectionClassConstant::getDocComment

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getDocComment — Gets doc comments

Descripción

public ReflectionClassConstant::getDocComment ( ) : string|false

Gets doc comments from a class constant.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The doc comment if it exists, otherwise false


Gets the class constant modifiers

  • « ReflectionClassConstant::getDocComment
  • ReflectionClassConstant::getName »
  • PHP Manual
  • ReflectionClassConstant
  • Gets the class constant modifiers

ReflectionClassConstant::getModifiers

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getModifiers — Gets the class constant modifiers

Descripción

public ReflectionClassConstant::getModifiers ( ) : int

Returns a bitfield of the access modifiers for this class constant.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A numeric representation of the modifiers. The actual meanings of these modifiers are described in the predefined constants.

Ver también

  • Reflection::getModifierNames() - Obtener nombres de modificadores


Get name of the constant

  • « ReflectionClassConstant::getModifiers
  • ReflectionClassConstant::getValue »
  • PHP Manual
  • ReflectionClassConstant
  • Get name of the constant

ReflectionClassConstant::getName

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getName — Get name of the constant

Descripción

public ReflectionClassConstant::getName ( ) : string|false

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the constant's name, o false en caso de error.


Gets value

  • « ReflectionClassConstant::getName
  • ReflectionClassConstant::isPrivate »
  • PHP Manual
  • ReflectionClassConstant
  • Gets value

ReflectionClassConstant::getValue

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getValue — Gets value

Descripción

public ReflectionClassConstant::getValue ( ) : mixed

Gets the class constant's value.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The value of the class constant.


Checks if class constant is private

  • « ReflectionClassConstant::getValue
  • ReflectionClassConstant::isProtected »
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is private

ReflectionClassConstant::isPrivate

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isPrivate — Checks if class constant is private

Descripción

public ReflectionClassConstant::isPrivate ( ) : bool

Checks if the class constant is private.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if the class constant is private, otherwise false

Ver también

  • ReflectionClassConstant::isPublic() - Checks if class constant is public
  • ReflectionClassConstant::isProtected() - Checks if class constant is protected


Checks if class constant is protected

  • « ReflectionClassConstant::isPrivate
  • ReflectionClassConstant::isPublic »
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is protected

ReflectionClassConstant::isProtected

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isProtected — Checks if class constant is protected

Descripción

public ReflectionClassConstant::isProtected ( ) : bool

Checks if the class constant is protected.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if the class constant is protected, otherwise false

Ver también

  • ReflectionClassConstant::isPublic() - Checks if class constant is public
  • ReflectionClassConstant::isPrivate() - Checks if class constant is private


Checks if class constant is public

  • « ReflectionClassConstant::isProtected
  • ReflectionClassConstant::__toString »
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is public

ReflectionClassConstant::isPublic

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isPublic — Checks if class constant is public

Descripción

public ReflectionClassConstant::isPublic ( ) : bool

Checks if the class constant is public.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if the class constant is public, otherwise false

Ver también

  • ReflectionClassConstant::isPrivate() - Checks if class constant is private
  • ReflectionClassConstant::isProtected() - Checks if class constant is protected


Returns the string representation of the ReflectionClassConstant object

  • « ReflectionClassConstant::isPublic
  • ReflectionZendExtension »
  • PHP Manual
  • ReflectionClassConstant
  • Returns the string representation of the ReflectionClassConstant object

ReflectionClassConstant::__toString

(PHP 7 >= 7.1.0)

ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object

Descripción

public ReflectionClassConstant::__toString ( ) : string

Returns the string representation of the ReflectionClassConstant object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A string representation of this ReflectionClassConstant instance.

Ver también

  • ReflectionClassConstant::export() - Export
  • __toString()


Clase ReflectionZendExtension

(PHP 5 >= 5.4.0, PHP 7)

Introducción

Sinopsis de la Clase

ReflectionZendExtension implements Reflector {
/* Propiedades */
public $name ;
/* Métodos */
final private __clone ( ) : void
public __construct ( string $name )
public static export ( string $name , string $return = ? ) : string
public getAuthor ( ) : string
public getCopyright ( ) : string
public getName ( ) : string
public getURL ( ) : string
public getVersion ( ) : string
public __toString ( ) : string
}

Propiedades

name

Nombre de la extensión. De sólo lectura, lanza una ReflectionException en un intento de escribir.

Tabla de contenidos

  • ReflectionZendExtension::__clone — Clon de controlador
  • ReflectionZendExtension::__construct — Constructor
  • ReflectionZendExtension::export — Exportar
  • ReflectionZendExtension::getAuthor — Consultar autor
  • ReflectionZendExtension::getCopyright — Consultar los derechos de copia
  • ReflectionZendExtension::getName — Obtiene el nombre
  • ReflectionZendExtension::getURL — Obtiene la URL
  • ReflectionZendExtension::getVersion — Obtiene la versión
  • ReflectionZendExtension::__toString — Convierte a texto


Clon de controlador

  • « ReflectionZendExtension
  • ReflectionZendExtension::__construct »
  • PHP Manual
  • ReflectionZendExtension
  • Clon de controlador

ReflectionZendExtension::__clone

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__clone — Clon de controlador

Descripción

final private ReflectionZendExtension::__clone ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Constructor

  • « ReflectionZendExtension::__clone
  • ReflectionZendExtension::export »
  • PHP Manual
  • ReflectionZendExtension
  • Constructor

ReflectionZendExtension::__construct

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__construct — Constructor

Descripción

public ReflectionZendExtension::__construct ( string $name )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

Valores devueltos


Exportar

  • « ReflectionZendExtension::__construct
  • ReflectionZendExtension::getAuthor »
  • PHP Manual
  • ReflectionZendExtension
  • Exportar

ReflectionZendExtension::export

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::export — Exportar

Descripción

public static ReflectionZendExtension::export ( string $name , string $return = ? ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

name

return

Valores devueltos


Consultar autor

  • « ReflectionZendExtension::export
  • ReflectionZendExtension::getCopyright »
  • PHP Manual
  • ReflectionZendExtension
  • Consultar autor

ReflectionZendExtension::getAuthor

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getAuthor — Consultar autor

Descripción

public ReflectionZendExtension::getAuthor ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Consultar los derechos de copia

  • « ReflectionZendExtension::getAuthor
  • ReflectionZendExtension::getName »
  • PHP Manual
  • ReflectionZendExtension
  • Consultar los derechos de copia

ReflectionZendExtension::getCopyright

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getCopyright — Consultar los derechos de copia

Descripción

public ReflectionZendExtension::getCopyright ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene el nombre

  • « ReflectionZendExtension::getCopyright
  • ReflectionZendExtension::getURL »
  • PHP Manual
  • ReflectionZendExtension
  • Obtiene el nombre

ReflectionZendExtension::getName

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getName — Obtiene el nombre

Descripción

public ReflectionZendExtension::getName ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene la URL

  • « ReflectionZendExtension::getName
  • ReflectionZendExtension::getVersion »
  • PHP Manual
  • ReflectionZendExtension
  • Obtiene la URL

ReflectionZendExtension::getURL

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getURL — Obtiene la URL

Descripción

public ReflectionZendExtension::getURL ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene la versión

  • « ReflectionZendExtension::getURL
  • ReflectionZendExtension::__toString »
  • PHP Manual
  • ReflectionZendExtension
  • Obtiene la versión

ReflectionZendExtension::getVersion

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getVersion — Obtiene la versión

Descripción

public ReflectionZendExtension::getVersion ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Convierte a texto

  • « ReflectionZendExtension::getVersion
  • ReflectionExtension »
  • PHP Manual
  • ReflectionZendExtension
  • Convierte a texto

ReflectionZendExtension::__toString

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__toString — Convierte a texto

Descripción

public ReflectionZendExtension::__toString ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Clase ReflectionExtension

(PHP 5, PHP 7)

Introducción

La clase ReflectionExtension devuelve información sobre una extensión.

Sinopsis de la Clase

ReflectionExtension implements Reflector {
/* Propiedades */
public $name ;
/* Métodos */
final private __clone ( ) : void
public __construct ( string $name )
public static export ( string $name , string $return = false ) : string
public getClasses ( ) : array
public getClassNames ( ) : array
public getConstants ( ) : array
public getDependencies ( ) : array
public getFunctions ( ) : array
public getINIEntries ( ) : array
public getName ( ) : string
public getVersion ( ) : string
public info ( ) : void
public isPersistent ( ) : void
public isTemporary ( ) : void
public __toString ( ) : string
}

Propiedades

name

Nombre de la extensión, como si se llamara al método ReflectionExtension::getName().

Tabla de contenidos

  • ReflectionExtension::__clone — Clonar
  • ReflectionExtension::__construct — Constructor de los objetos ReflectionExtension
  • ReflectionExtension::export — Exportar
  • ReflectionExtension::getClasses — Obtiene clases
  • ReflectionExtension::getClassNames — Obtiene nombres de las clases
  • ReflectionExtension::getConstants — Obtiene las constantes
  • ReflectionExtension::getDependencies — Obtiene las dependencias
  • ReflectionExtension::getFunctions — Obtiene las funciones de una extensión
  • ReflectionExtension::getINIEntries — Obtiene las entradas INI de la extensión
  • ReflectionExtension::getName — Obtiene el nombre de la extensión
  • ReflectionExtension::getVersion — Obtiene la versión de una extensión
  • ReflectionExtension::info — Imprime información sobre la extensión
  • ReflectionExtension::isPersistent — Indica si la extensión es persistente
  • ReflectionExtension::isTemporary — Indica si la extensión es temporal
  • ReflectionExtension::__toString — Convertir a string


Clonar

  • « ReflectionExtension
  • ReflectionExtension::__construct »
  • PHP Manual
  • ReflectionExtension
  • Clonar

ReflectionExtension::__clone

(PHP 5, PHP 7)

ReflectionExtension::__clone — Clonar

Descripción

final private ReflectionExtension::__clone ( ) : void

Éste metodo previene que se pueda clonar un objeto. Los objetos de reflexión no se pueden clonar.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No se devuelve ningún valor. Al ser llamado, se emitará un error fatal.

Ver también

  • ReflectionExtension::__construct() - Constructor de los objetos ReflectionExtension
  • Clonación de objetos


Constructor de los objetos ReflectionExtension

  • « ReflectionExtension::__clone
  • ReflectionExtension::export »
  • PHP Manual
  • ReflectionExtension
  • Constructor de los objetos ReflectionExtension

ReflectionExtension::__construct

(PHP 5, PHP 7)

ReflectionExtension::__construct — Constructor de los objetos ReflectionExtension

Descripción

public ReflectionExtension::__construct ( string $name )

Construye un objet de la clase ReflectionExtension.

Parámetros

name

Nombre de la extensión.

Valores devueltos

object de la clase ReflectionExtension.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension

<?php
$ext = new ReflectionExtension('Reflection');

printf('Extension: %s (version: %s)', $ext->getName(), $ext->getVersion());
?>

El resultado del ejemplo sería algo similar a:

Extension: Reflection (version: $Revision$)

Ver también

  • ReflectionExtension::info() - Imprime información sobre la extensión
  • Constructores


Exportar

  • « ReflectionExtension::__construct
  • ReflectionExtension::getClasses »
  • PHP Manual
  • ReflectionExtension
  • Exportar

ReflectionExtension::export

(PHP 5, PHP 7)

ReflectionExtension::export — Exportar

Descripción

public static ReflectionExtension::export ( string $name , string $return = false ) : string

Exporta una extensión reflexionada. El formato de salida de esta función coincide con el del argumento --re [extension] usado en la línea de comandos.

Parámetros

name

La reflexión a exportar.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ver también

  • ReflectionExtension::info() - Imprime información sobre la extensión


Obtiene clases

  • « ReflectionExtension::export
  • ReflectionExtension::getClassNames »
  • PHP Manual
  • ReflectionExtension
  • Obtiene clases

ReflectionExtension::getClasses

(PHP 5, PHP 7)

ReflectionExtension::getClasses — Obtiene clases

Descripción

public ReflectionExtension::getClasses ( ) : array

Devuelve la lista de clases que pertenecen a una extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de objetos ReflectionClass, uno por cada clase que incluya la extensión. Si no se hubiera definido ninguna, se devolvería un array vacío.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getClasses()

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClasses());
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  ["XMLWriter"]=>
  &object(ReflectionClass)#2 (1) {
    ["name"]=>
    string(9) "XMLWriter"
  }
}

Ver también

  • ReflectionExtension::getClassNames() - Obtiene nombres de las clases


Obtiene nombres de las clases

  • « ReflectionExtension::getClasses
  • ReflectionExtension::getConstants »
  • PHP Manual
  • ReflectionExtension
  • Obtiene nombres de las clases

ReflectionExtension::getClassNames

(PHP 5, PHP 7)

ReflectionExtension::getClassNames — Obtiene nombres de las clases

Descripción

public ReflectionExtension::getClassNames ( ) : array

Devuelve una lsita de los nombres de las clases que pertenecen a esta extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con los nombres de las clases, tal como estuvieran definidos en la extensión. Si no hubiera ninguna clase, se devolvería un array vacío.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getClassNames()

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClassNames());
?>

El resultado del ejemplo sería algo similar a:

array(1) {
  [0]=>
  string(9) "XMLWriter"
}

Ver también

  • ReflectionExtension::getClasses() - Obtiene clases
  • ReflectionExtension::getName() - Obtiene el nombre de la extensión


Obtiene las constantes

  • « ReflectionExtension::getClassNames
  • ReflectionExtension::getDependencies »
  • PHP Manual
  • ReflectionExtension
  • Obtiene las constantes

ReflectionExtension::getConstants

(PHP 5, PHP 7)

ReflectionExtension::getConstants — Obtiene las constantes

Descripción

public ReflectionExtension::getConstants ( ) : array

Devuelve las constantes definidas dentro de una extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array asociativo utilizando los nombres de constantes en las claves.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getConstants()

<?php
$ext = new ReflectionExtension('DOM');

print_r($ext->getConstants());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [XML_ELEMENT_NODE] => 1
    [XML_ATTRIBUTE_NODE] => 2
    [XML_TEXT_NODE] => 3
    [XML_CDATA_SECTION_NODE] => 4
    [XML_ENTITY_REF_NODE] => 5
    [XML_ENTITY_NODE] => 6
    [XML_PI_NODE] => 7
    [XML_COMMENT_NODE] => 8
    [XML_DOCUMENT_NODE] => 9
    [XML_DOCUMENT_TYPE_NODE] => 10
    [XML_DOCUMENT_FRAG_NODE] => 11
    [XML_NOTATION_NODE] => 12
    [XML_HTML_DOCUMENT_NODE] => 13
    [XML_DTD_NODE] => 14
    [XML_ELEMENT_DECL_NODE] => 15
    [XML_ATTRIBUTE_DECL_NODE] => 16
    [XML_ENTITY_DECL_NODE] => 17
    [XML_NAMESPACE_DECL_NODE] => 18
    [XML_LOCAL_NAMESPACE] => 18
    [XML_ATTRIBUTE_CDATA] => 1
    [XML_ATTRIBUTE_ID] => 2
    [XML_ATTRIBUTE_IDREF] => 3
    [XML_ATTRIBUTE_IDREFS] => 4
    [XML_ATTRIBUTE_ENTITY] => 6
    [XML_ATTRIBUTE_NMTOKEN] => 7
    [XML_ATTRIBUTE_NMTOKENS] => 8
    [XML_ATTRIBUTE_ENUMERATION] => 9
    [XML_ATTRIBUTE_NOTATION] => 10
    [DOM_PHP_ERR] => 0
    [DOM_INDEX_SIZE_ERR] => 1
    [DOMSTRING_SIZE_ERR] => 2
    [DOM_HIERARCHY_REQUEST_ERR] => 3
    [DOM_WRONG_DOCUMENT_ERR] => 4
    [DOM_INVALID_CHARACTER_ERR] => 5
    [DOM_NO_DATA_ALLOWED_ERR] => 6
    [DOM_NO_MODIFICATION_ALLOWED_ERR] => 7
    [DOM_NOT_FOUND_ERR] => 8
    [DOM_NOT_SUPPORTED_ERR] => 9
    [DOM_INUSE_ATTRIBUTE_ERR] => 10
    [DOM_INVALID_STATE_ERR] => 11
    [DOM_SYNTAX_ERR] => 12
    [DOM_INVALID_MODIFICATION_ERR] => 13
    [DOM_NAMESPACE_ERR] => 14
    [DOM_INVALID_ACCESS_ERR] => 15
    [DOM_VALIDATION_ERR] => 16
)

Ver también

  • ReflectionExtension::getINIEntries() - Obtiene las entradas INI de la extensión


Obtiene las dependencias

  • « ReflectionExtension::getConstants
  • ReflectionExtension::getFunctions »
  • PHP Manual
  • ReflectionExtension
  • Obtiene las dependencias

ReflectionExtension::getDependencies

(PHP 5 >= 5.1.3, PHP 7)

ReflectionExtension::getDependencies — Obtiene las dependencias

Descripción

public ReflectionExtension::getDependencies ( ) : array

Devuelve las dependencias, listando tanto aquéllas que sean obligatorias, como las conflictivas.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array asociativo con los nombres de las dependencias como clave, y Required (obligatorio), Optional (opcional) o Conflicts (conflictivo) como valor.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getDependencies()

<?php
$dom = new ReflectionExtension('dom');

print_r($dom->getDependencies());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [libxml] => Required
    [domxml] => Conflicts
)

Ver también

  • ReflectionClass::getVersion()


Obtiene las funciones de una extensión

  • « ReflectionExtension::getDependencies
  • ReflectionExtension::getINIEntries »
  • PHP Manual
  • ReflectionExtension
  • Obtiene las funciones de una extensión

ReflectionExtension::getFunctions

(PHP 5, PHP 7)

ReflectionExtension::getFunctions — Obtiene las funciones de una extensión

Descripción

public ReflectionExtension::getFunctions ( ) : array

Devuelve las funciones definidas en una extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Array asociativo de objetos ReflectionFunction. Para cada función que haya definida en la extensión, se usará su nombre como valor de clave del array. Si no hubiera ninguna función definida, se devolvería un array vacío.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getFunctions()

<?php
$dom = new ReflectionExtension('SimpleXML');

print_r($dom->getFunctions());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [simplexml_load_file] => ReflectionFunction Object
        (
            [name] => simplexml_load_file
        )

    [simplexml_load_string] => ReflectionFunction Object
        (
            [name] => simplexml_load_string
        )

    [simplexml_import_dom] => ReflectionFunction Object
        (
            [name] => simplexml_import_dom
        )

)

Ver también

  • ReflectionExtension::getClasses() - Obtiene clases
  • get_extension_funcs() - Devuelve una matriz con los nombres de funciones de un módulo


Obtiene las entradas INI de la extensión

  • « ReflectionExtension::getFunctions
  • ReflectionExtension::getName »
  • PHP Manual
  • ReflectionExtension
  • Obtiene las entradas INI de la extensión

ReflectionExtension::getINIEntries

(PHP 5, PHP 7)

ReflectionExtension::getINIEntries — Obtiene las entradas INI de la extensión

Descripción

public ReflectionExtension::getINIEntries ( ) : array

Devuelve las entradas INI de la extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array asociativo usando la entrada INI en la clave, y su valor como valor del elemento del array.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getINIEntries()

<?php
$ext = new ReflectionExtension('mysql');

print_r($ext->getINIEntries());
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [mysql.allow_persistent] => 1
    [mysql.max_persistent] => -1
    [mysql.max_links] => -1
    [mysql.default_host] =>
    [mysql.default_user] =>
    [mysql.default_password] =>
    [mysql.default_port] =>
    [mysql.default_socket] =>
    [mysql.connect_timeout] => 60
    [mysql.trace_mode] =>
    [mysql.allow_local_infile] => 1
    [mysql.cache_size] => 2000
)

Ver también

  • ini_get_all() - Obtiene todas las opciones de configuración
  • ReflectionExtension::getConstants() - Obtiene las constantes


Obtiene el nombre de la extensión

  • « ReflectionExtension::getINIEntries
  • ReflectionExtension::getVersion »
  • PHP Manual
  • ReflectionExtension
  • Obtiene el nombre de la extensión

ReflectionExtension::getName

(PHP 5, PHP 7)

ReflectionExtension::getName — Obtiene el nombre de la extensión

Descripción

public ReflectionExtension::getName ( ) : string

Devuelve el nombre de la extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre de la extensión.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getName()

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getName());
?>

El resultado del ejemplo sería algo similar a:

string(6) "mysqli"

Ver también

  • ReflectionExtension::getClassNames() - Obtiene nombres de las clases


Obtiene la versión de una extensión

  • « ReflectionExtension::getName
  • ReflectionExtension::info »
  • PHP Manual
  • ReflectionExtension
  • Obtiene la versión de una extensión

ReflectionExtension::getVersion

(PHP 5, PHP 7)

ReflectionExtension::getVersion — Obtiene la versión de una extensión

Descripción

public ReflectionExtension::getVersion ( ) : string

Devuelve la versión de la extensión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Versión de la extensión.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::getVersion()

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getVersion());
?>

El resultado del ejemplo sería algo similar a:

string(3) "0.1"

Ver también

  • ReflectionExtension::info() - Imprime información sobre la extensión


Imprime información sobre la extensión

  • « ReflectionExtension::getVersion
  • ReflectionExtension::isPersistent »
  • PHP Manual
  • ReflectionExtension
  • Imprime información sobre la extensión

ReflectionExtension::info

(PHP 5 >= 5.2.4, PHP 7)

ReflectionExtension::info — Imprime información sobre la extensión

Descripción

public ReflectionExtension::info ( ) : void

Imprime el bloque de "phpinfo()" correspondiente a la extensión dada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Información sobre la extensión.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionExtension::info()

<?php
$ext = new ReflectionExtension('mysqli');
$ext->info();
?>

El resultado del ejemplo sería algo similar a:

mysqli

MysqlI Support => enabled
Client API library version => mysqlnd 5.0.5-dev - 081106 - $Revision$
Active Persistent Links => 0
Inactive Persistent Links => 0
Active Links => 0
Persistent cache => enabled
put_hits => 0
put_misses => 0
get_hits => 0
get_misses => 0
size => 2000
free_items => 2000
references => 2

Directive => Local Value => Master Value
mysqli.max_links => Unlimited => Unlimited
mysqli.max_persistent => Unlimited => Unlimited
mysqli.allow_persistent => On => On
mysqli.default_host => no value => no value
mysqli.default_user => no value => no value
mysqli.default_pw => no value => no value
mysqli.default_port => 3306 => 3306
mysqli.default_socket => no value => no value
mysqli.reconnect => Off => Off
mysqli.allow_local_infile => On => On
mysqli.cache_size => 2000 => 2000

Ver también

  • ReflectionExtension::getName() - Obtiene el nombre de la extensión
  • phpinfo() - Muestra información sobre la configuración de PHP


Indica si la extensión es persistente

  • « ReflectionExtension::info
  • ReflectionExtension::isTemporary »
  • PHP Manual
  • ReflectionExtension
  • Indica si la extensión es persistente

ReflectionExtension::isPersistent

(PHP 5 >= 5.4.0, PHP 7)

ReflectionExtension::isPersistent — Indica si la extensión es persistente

Descripción

public ReflectionExtension::isPersistent ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la extensión ha sido cargado por extension, o false en caso contrario.

Ver también

  • ReflectionExtension::isTemporary() - Indica si la extensión es temporal


Indica si la extensión es temporal

  • « ReflectionExtension::isPersistent
  • ReflectionExtension::__toString »
  • PHP Manual
  • ReflectionExtension
  • Indica si la extensión es temporal

ReflectionExtension::isTemporary

(PHP 5 >= 5.4.0, PHP 7)

ReflectionExtension::isTemporary — Indica si la extensión es temporal

Descripción

public ReflectionExtension::isTemporary ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true para las extensiones cargadas con dl(), o false en caso contrario.

Ver también

  • ReflectionExtension::isPersistent() - Indica si la extensión es persistente


Convertir a string

  • « ReflectionExtension::isTemporary
  • ReflectionFunction »
  • PHP Manual
  • ReflectionExtension
  • Convertir a string

ReflectionExtension::__toString

(PHP 5, PHP 7)

ReflectionExtension::__toString — Convertir a string

Descripción

public ReflectionExtension::__toString ( ) : string

Exporta una extensión reflexionada devolvíendola en forma de string. Es equivalente al método ReflectionExtension::export() estableciendo en el parámetro return el valor true.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la extensión en forma de string, de la misma forma que haría ReflectionExtension::export().

Ver también

  • ReflectionExtension::__construct() - Constructor de los objetos ReflectionExtension
  • ReflectionExtension::export() - Exportar
  • __toString()


Clase ReflectionFunction

(PHP 5, PHP 7)

Introducción

La ReflectionFunction muestra información sobre una función.

Sinopsis de la Clase

ReflectionFunction extends ReflectionFunctionAbstract implements Reflector {
/* Constantes */
const integer IS_DEPRECATED = 262144 ;
/* Propiedades */
public $name ;
/* Métodos */
public __construct ( mixed $name )
public static export ( string $name , string $return = ? ) : string
public getClosure ( ) : Closure
public invoke ( mixed $... = ? ) : mixed
public invokeArgs ( array $args ) : mixed
public isDisabled ( ) : bool
public __toString ( ) : string
/* Métodos heredados */
final private ReflectionFunctionAbstract::__clone ( ) : void
public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass
public ReflectionFunctionAbstract::getClosureThis ( ) : object
public ReflectionFunctionAbstract::getDocComment ( ) : string
public ReflectionFunctionAbstract::getEndLine ( ) : int
public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension
public ReflectionFunctionAbstract::getExtensionName ( ) : string
public ReflectionFunctionAbstract::getFileName ( ) : string
public ReflectionFunctionAbstract::getName ( ) : string
public ReflectionFunctionAbstract::getNamespaceName ( ) : string
public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int
public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int
public ReflectionFunctionAbstract::getParameters ( ) : array
public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null
public ReflectionFunctionAbstract::getShortName ( ) : string
public ReflectionFunctionAbstract::getStartLine ( ) : int
public ReflectionFunctionAbstract::getStaticVariables ( ) : array
public ReflectionFunctionAbstract::hasReturnType ( ) : bool
public ReflectionFunctionAbstract::inNamespace ( ) : bool
public ReflectionFunctionAbstract::isClosure ( ) : bool
public ReflectionFunctionAbstract::isDeprecated ( ) : bool
public ReflectionFunctionAbstract::isGenerator ( ) : bool
public ReflectionFunctionAbstract::isInternal ( ) : bool
public ReflectionFunctionAbstract::isUserDefined ( ) : bool
public ReflectionFunctionAbstract::isVariadic ( ) : bool
public ReflectionFunctionAbstract::returnsReference ( ) : bool
abstract public ReflectionFunctionAbstract::__toString ( ) : void
}

Propiedades

name

Nombre de la función. De sólo lectura, lanza una ReflectionException en el intento de escribir.

Constantes predefinidas

Modificadores ReflectionFunction

ReflectionFunction::IS_DEPRECATED

Indica las funciones obsoletas.

Tabla de contenidos

  • ReflectionFunction::__construct — Contruye un objeto de tipo ReflectionFunction
  • ReflectionFunction::export — Exporta una función
  • ReflectionFunction::getClosure — Genera dinámicamente una función anónima de esta función
  • ReflectionFunction::invoke — Invoca una función
  • ReflectionFunction::invokeArgs — Invoca a la función con argumentos
  • ReflectionFunction::isDisabled — Comprueba si una función está desactivada
  • ReflectionFunction::__toString — Convertir a string


Contruye un objeto de tipo ReflectionFunction

  • « ReflectionFunction
  • ReflectionFunction::export »
  • PHP Manual
  • ReflectionFunction
  • Contruye un objeto de tipo ReflectionFunction

ReflectionFunction::__construct

(PHP 5, PHP 7)

ReflectionFunction::__construct — Contruye un objeto de tipo ReflectionFunction

Descripción

public ReflectionFunction::__construct ( mixed $name )

Construye un objeto de tipo ReflectionFunction.

Parámetros

name

Nombre de la función que se desea reflexionar, o una función anónima.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza ReflectionException si el parámetro name no contuviera una función válida.

Historial de cambios

Versión | Descripción
5.3.0 | ahora name puede representar una función anónima.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunction::__construct()

<?php
/**
 * Contador sencillo
 *
 * @return    int
 */
function contador1()
{
    static $c = 0;
    return ++$c;
}

/**
 * Otro contador sencillo
 *
 * @return    int
 */
$contador2 = function()
{
    static $d = 0;
    return ++$d;

};

function mostrarFuncionesReflexionadas($func)
{
    // Mostrar información básica
    printf(
        "\n\n===> La función %s '%s'\n".
        "     declarada en %s\n".
        "     líneas %d a %d\n",
        $func->isInternal() ? 'interna' : 'definida por el usuario',
        $func->getName(),
        $func->getFileName(),
        $func->getStartLine(),
        $func->getEndline()
    );

    // Mostrar comentarios de documentación
    printf("---> Documentación:\n %s\n", var_export($func->getDocComment(), 1));

    // Mostrar, si existen, variables estáticas
    if ($statics = $func->getStaticVariables())
    {
        printf("---> Variables estáticas: %s\n", var_export($statics, 1));
    }
}

// Crear una instancia de la clase ReflectionFunction
mostrarFuncionesReflexionadas(new ReflectionFunction('contador1'));
mostrarFuncionesReflexionadas(new ReflectionFunction($contador2));
?>

El resultado del ejemplo sería algo similar a:

===> La función definida por el usuario 'contador1'
     declarada en /Users/chuso/dropme.php
     líneas 7 a 11
---> Documentación:
 '/**
 * Contador sencillo
 *
 * @return    int
 */'
---> Variables estáticas: array (
  'c' => 0,
)

===> La función definida por el usuario '{closure}'
     declarada en /Users/chuso/dropme.php
     líneas 18 a 23
---> Documentación:
 '/**
 * Otro contador sencillo
 *
 * @return    int
 */'
---> Variables estáticas: array (
  'd' => 0,
)

Ver también

  • ReflectionMethod::__construct() - Construye un objeto ReflectionMethod
  • Constructores


Exporta una función

  • « ReflectionFunction::__construct
  • ReflectionFunction::getClosure »
  • PHP Manual
  • ReflectionFunction
  • Exporta una función

ReflectionFunction::export

(PHP 5, PHP 7)

ReflectionFunction::export — Exporta una función

Descripción

public static ReflectionFunction::export ( string $name , string $return = ? ) : string

Exporta una función reflexionada.

Parámetros

name

La reflexión a exportar.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ver también

  • ReflectionFunction::invoke() - Invoca una función


Genera dinámicamente una función anónima de esta función

  • « ReflectionFunction::export
  • ReflectionFunction::invoke »
  • PHP Manual
  • ReflectionFunction
  • Genera dinámicamente una función anónima de esta función

ReflectionFunction::getClosure

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunction::getClosure — Genera dinámicamente una función anónima de esta función

Descripción

public ReflectionFunction::getClosure ( ) : Closure

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto Closure. En caso de error, devuelve null.


Invoca una función

  • « ReflectionFunction::getClosure
  • ReflectionFunction::invokeArgs »
  • PHP Manual
  • ReflectionFunction
  • Invoca una función

ReflectionFunction::invoke

(PHP 5, PHP 7)

ReflectionFunction::invoke — Invoca una función

Descripción

public ReflectionFunction::invoke ( mixed $... = ? ) : mixed

Invoca una función reflejada.

Parámetros

...

Lista de argumentos que se pasan a la función. Acepta un número variabel de argumentos, que se pasan a la función de manera similar a como lo hace call_user_func().

Valores devueltos

Devuelve el resultado de llamar a la función invocada.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunction::invoke() example

<?php
function titule($titule, $nombre)
{
    return sprintf("%s. %s\r\n", $titulo, $nombre);
}

$funcion = new ReflectionFunction('titule');

echo $funcion->invoke('Sr', 'Pedro');
?>

El resultado del ejemplo sería:

Sr. Pedro

Notas

Nota:

Si la función tiene argumentos que necesitan ser referencias, éstos deben ser referencias en la lista de argumentos pasados.

Ver también

  • ReflectionFunction::export() - Exporta una función
  • __invoke()
  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro


Invoca a la función con argumentos

  • « ReflectionFunction::invoke
  • ReflectionFunction::isDisabled »
  • PHP Manual
  • ReflectionFunction
  • Invoca a la función con argumentos

ReflectionFunction::invokeArgs

(PHP 5 >= 5.1.2, PHP 7)

ReflectionFunction::invokeArgs — Invoca a la función con argumentos

Descripción

public ReflectionFunction::invokeArgs ( array $args ) : mixed

Invoca la función y pasa sus argumentos como array.

Parámetros

args

Array con la lista de argumentos que se pasan a la función, similar a cómo funciona call_user_func_array().

Valores devueltos

Devuelve el resultado de la función invocada

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunction::invokeArgs()

<?php
function titulo($titulo, $nombre)
{
    return sprintf("%s. %s\r\n", $titulo, $nombre);
}

$function = new ReflectionFunction('titulo');

echo $function->invokeArgs(array('Sr', 'Pedro'));
?>

El resultado del ejemplo sería:

Dr. Pedro

Ejemplo #2 Ejemplo de ReflectionFunction::invokeArgs() con argumentos por referencia

<?php
function obtener_condiciones_falsas(array $condiciones, array &$condiciones_falsas)
{
    foreach ($condiciones as $condicion) {
        if (!$condicion) {
            $condiciones_falsas[] = $condicion;
        }
    }
}

$ref_a_funcion     = new ReflectionFunction('obtener_condiciones_falsas');

$condiciones        = array(true, false, -1, 0, 1);
$condiciones_falsas = array();

$ref_a_funcion->invokeArgs(array($condiciones, &$condiciones_falsas));

var_dump($condiciones_falsas);
?>

El resultado del ejemplo sería:

array(2) {
  [0]=>
  bool(false)
  [1]=>
  int(0)
}

Notas

Nota:

Si la función tiene argumentos que necesitan ser referencias, éstos deben ser referencias en la lista de argumentos pasados.

Ver también

  • ReflectionFunction::invoke() - Invoca una función
  • ReflectionFunctionAbstract::getNumberOfParameters() - Obtiene el número total de parámetros
  • __invoke()
  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros


Comprueba si una función está desactivada

  • « ReflectionFunction::invokeArgs
  • ReflectionFunction::__toString »
  • PHP Manual
  • ReflectionFunction
  • Comprueba si una función está desactivada

ReflectionFunction::isDisabled

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunction::isDisabled — Comprueba si una función está desactivada

Descripción

public ReflectionFunction::isDisabled ( ) : bool

Comprueba si una función está desactivada, mediante la directiva disable_functions.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si está desactivadao, o false en caso contrario.

Ver también

  • ReflectionFunctionAbstract::isUserDefined() - Comprueba si es una función definida por un usuario
  • directiva disable_functions


Convertir a string

  • « ReflectionFunction::isDisabled
  • ReflectionFunctionAbstract »
  • PHP Manual
  • ReflectionFunction
  • Convertir a string

ReflectionFunction::__toString

(PHP 5, PHP 7)

ReflectionFunction::__toString — Convertir a string

Descripción

public ReflectionFunction::__toString ( ) : string

Convierte a string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una salida similar a la de ReflectionFunction::export().

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunction::__toString()

<?php
function título($título, $nombre)
{
    return sprintf("%s. %s\r\n", $título, $nombre);
}

echo new ReflectionFunction('título');
?>

El resultado del ejemplo sería algo similar a:

Function [ <user> function title ] {
  @@ Command line code 2 - 5

  - Parameters [2] {
    Parameter #0 [ <required> $título ]
    Parameter #1 [ <required> $nombre ]
  }
}

Ver también

  • ReflectionFunction::export() - Exporta una función
  • ReflectionClass::clone()
  • __toString()


Clase ReflectionFunctionAbstract

(PHP 5 >= 5.2.0, PHP 7)

Introducción

Clase padre de ReflectionFunction. Lea su descripción para conocer más detalles.

Sinopsis de la Clase

ReflectionFunctionAbstract implements Reflector {
/* Propiedades */
public $name ;
/* Métodos */
final private __clone ( ) : void
public getClosureScopeClass ( ) : ReflectionClass
public getClosureThis ( ) : object
public getDocComment ( ) : string
public getEndLine ( ) : int
public getExtension ( ) : ReflectionExtension
public getExtensionName ( ) : string
public getFileName ( ) : string
public getName ( ) : string
public getNamespaceName ( ) : string
public getNumberOfParameters ( ) : int
public getNumberOfRequiredParameters ( ) : int
public getParameters ( ) : array
public getReturnType ( ) : ReflectionType|null
public getShortName ( ) : string
public getStartLine ( ) : int
public getStaticVariables ( ) : array
public hasReturnType ( ) : bool
public inNamespace ( ) : bool
public isClosure ( ) : bool
public isDeprecated ( ) : bool
public isGenerator ( ) : bool
public isInternal ( ) : bool
public isUserDefined ( ) : bool
public isVariadic ( ) : bool
public returnsReference ( ) : bool
abstract public __toString ( ) : void
}

Propiedades

name

Nombre de la función. De sólo lectura, lanza una ReflectionException en el intento de escribir.

Tabla de contenidos

  • ReflectionFunctionAbstract::__clone — Clona una función
  • ReflectionFunctionAbstract::getClosureScopeClass — Devuelve el ámbito asociado al cierre
  • ReflectionFunctionAbstract::getClosureThis — Devuelve una función anónima que apunta a esta función
  • ReflectionFunctionAbstract::getDocComment — Obtiene comentarios de documentación
  • ReflectionFunctionAbstract::getEndLine — Obtiene número de linea final
  • ReflectionFunctionAbstract::getExtension — Obtiene información sobre la extensión
  • ReflectionFunctionAbstract::getExtensionName — Obtiene el nombre de la extensión
  • ReflectionFunctionAbstract::getFileName — Obtiene el nombre del fichero
  • ReflectionFunctionAbstract::getName — Obtiene el nombre de la función
  • ReflectionFunctionAbstract::getNamespaceName — Obtiene el nombre del espacio de nombres
  • ReflectionFunctionAbstract::getNumberOfParameters — Obtiene el número total de parámetros
  • ReflectionFunctionAbstract::getNumberOfRequiredParameters — Obtiene el número de parámetros obligatorios
  • ReflectionFunctionAbstract::getParameters — Obtiene los parámetros
  • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
  • ReflectionFunctionAbstract::getShortName — Obtiene el nombre abreviado de la función
  • ReflectionFunctionAbstract::getStartLine — Obtiene el número de la línea de inicio
  • ReflectionFunctionAbstract::getStaticVariables — Obtiene las variable estáticas
  • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
  • ReflectionFunctionAbstract::inNamespace — Comprueba si pertenece a un espacio de nombres
  • ReflectionFunctionAbstract::isClosure — Comprobar si es un cierre
  • ReflectionFunctionAbstract::isDeprecated — Comprueba si está obsoleta
  • ReflectionFunctionAbstract::isGenerator — Devuelve si la función es un generador
  • ReflectionFunctionAbstract::isInternal — Comprueba si la función es interna
  • ReflectionFunctionAbstract::isUserDefined — Comprueba si es una función definida por un usuario
  • ReflectionFunctionAbstract::isVariadic — Comprueba si la función es varíadica
  • ReflectionFunctionAbstract::returnsReference — Comprueba si devuelve una referencia
  • ReflectionFunctionAbstract::__toString — Convertir a texto


Clona una función

  • « ReflectionFunctionAbstract
  • ReflectionFunctionAbstract::getClosureScopeClass »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Clona una función

ReflectionFunctionAbstract::__clone

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::__clone — Clona una función

Descripción

final private ReflectionFunctionAbstract::__clone ( ) : void

Clona una función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Clonación de objetos


Devuelve el ámbito asociado al cierre

  • « ReflectionFunctionAbstract::__clone
  • ReflectionFunctionAbstract::getClosureThis »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Devuelve el ámbito asociado al cierre

ReflectionFunctionAbstract::getClosureScopeClass

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunctionAbstract::getClosureScopeClass — Devuelve el ámbito asociado al cierre

Descripción

public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la clase en caso de éxito o null en caso de fallo.


Devuelve una función anónima que apunta a esta función

  • « ReflectionFunctionAbstract::getClosureScopeClass
  • ReflectionFunctionAbstract::getDocComment »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Devuelve una función anónima que apunta a esta función

ReflectionFunctionAbstract::getClosureThis

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunctionAbstract::getClosureThis — Devuelve una función anónima que apunta a esta función

Descripción

public ReflectionFunctionAbstract::getClosureThis ( ) : object

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un puntero a $this. En caso de error, devuelve null.


Obtiene comentarios de documentación

  • « ReflectionFunctionAbstract::getClosureThis
  • ReflectionFunctionAbstract::getEndLine »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene comentarios de documentación

ReflectionFunctionAbstract::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionFunctionAbstract::getDocComment — Obtiene comentarios de documentación

Descripción

public ReflectionFunctionAbstract::getDocComment ( ) : string

Devuelve los comentarios de documentación de una función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Si existieran, comentarios de documentación. En caso contrario, false.

Ver también

  • ReflectionFunctionAbstract::getStartLine() - Obtiene el número de la línea de inicio


Obtiene número de linea final

  • « ReflectionFunctionAbstract::getDocComment
  • ReflectionFunctionAbstract::getExtension »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene número de linea final

ReflectionFunctionAbstract::getEndLine

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getEndLine — Obtiene número de linea final

Descripción

public ReflectionFunctionAbstract::getEndLine ( ) : int

Devuelve el número de linea final.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El número de la línea final de la función definida por el usuario, o false si fuera desconocido.

Ver también

  • ReflectionFunctionAbstract::getStartLine() - Obtiene el número de la línea de inicio


Obtiene información sobre la extensión

  • « ReflectionFunctionAbstract::getEndLine
  • ReflectionFunctionAbstract::getExtensionName »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene información sobre la extensión

ReflectionFunctionAbstract::getExtension

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getExtension — Obtiene información sobre la extensión

Descripción

public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension

Devuelve información de la extensión a la que pertenece la función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Información de la extensión, en forma de objeto ReflectionExtension.

Ver también

  • ReflectionFunctionAbstract::getExtensionName() - Obtiene el nombre de la extensión


Obtiene el nombre de la extensión

  • « ReflectionFunctionAbstract::getExtension
  • ReflectionFunctionAbstract::getFileName »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el nombre de la extensión

ReflectionFunctionAbstract::getExtensionName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getExtensionName — Obtiene el nombre de la extensión

Descripción

public ReflectionFunctionAbstract::getExtensionName ( ) : string

Devuelve el nombre de la extensión.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre de la extensión.

Ver también

  • ReflectionFunctionAbstract::getExtension() - Obtiene información sobre la extensión


Obtiene el nombre del fichero

  • « ReflectionFunctionAbstract::getExtensionName
  • ReflectionFunctionAbstract::getName »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el nombre del fichero

ReflectionFunctionAbstract::getFileName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getFileName — Obtiene el nombre del fichero

Descripción

public ReflectionFunctionAbstract::getFileName ( ) : string

Obtiene el nombre de fichero que contiene una función definida por el usuario.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre del fichero.

Ver también

  • ReflectionFunctionAbstract::getNamespaceName() - Obtiene el nombre del espacio de nombres


Obtiene el nombre de la función

  • « ReflectionFunctionAbstract::getFileName
  • ReflectionFunctionAbstract::getNamespaceName »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el nombre de la función

ReflectionFunctionAbstract::getName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getName — Obtiene el nombre de la función

Descripción

public ReflectionFunctionAbstract::getName ( ) : string

Devuelve el nombre de la función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre de la función.

Ver también

  • ReflectionFunctionAbstract::getExtensionName() - Obtiene el nombre de la extensión
  • ReflectionFunctionAbstract::isUserDefined() - Comprueba si es una función definida por un usuario


Obtiene el nombre del espacio de nombres

  • « ReflectionFunctionAbstract::getName
  • ReflectionFunctionAbstract::getNumberOfParameters »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el nombre del espacio de nombres

ReflectionFunctionAbstract::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNamespaceName — Obtiene el nombre del espacio de nombres

Descripción

public ReflectionFunctionAbstract::getNamespaceName ( ) : string

Devuelve el nombre del espacio de nombres en el que está definida la clase.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre del espacio de nombres.

Ver también

  • ReflectionFunctionAbstract::getFileName() - Obtiene el nombre del fichero
  • espacios de nombres


Obtiene el número total de parámetros

  • « ReflectionFunctionAbstract::getNamespaceName
  • ReflectionFunctionAbstract::getNumberOfRequiredParameters »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el número total de parámetros

ReflectionFunctionAbstract::getNumberOfParameters

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNumberOfParameters — Obtiene el número total de parámetros

Descripción

public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int

Devuelve el número total de parámetros definidos en una función, ya sean opcionales u obligatorios.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Número de parámetros.

Ver también

  • ReflectionFunctionAbstract::getNumberOfRequiredParameters() - Obtiene el número de parámetros obligatorios
  • func_num_args() - Devuelve el número de argumentos pasados a la función


Obtiene el número de parámetros obligatorios

  • « ReflectionFunctionAbstract::getNumberOfParameters
  • ReflectionFunctionAbstract::getParameters »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el número de parámetros obligatorios

ReflectionFunctionAbstract::getNumberOfRequiredParameters

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNumberOfRequiredParameters — Obtiene el número de parámetros obligatorios

Descripción

public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int

Devuelve el número de parámetros obligatorios definidos en una función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Número de parámetros obligatorios.

Ver también

  • ReflectionFunctionAbstract::getNumberOfParameters() - Obtiene el número total de parámetros


Obtiene los parámetros

  • « ReflectionFunctionAbstract::getNumberOfRequiredParameters
  • ReflectionFunctionAbstract::getReturnType »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene los parámetros

ReflectionFunctionAbstract::getParameters

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getParameters — Obtiene los parámetros

Descripción

public ReflectionFunctionAbstract::getParameters ( ) : array

Devuelve los parámetros en forma de array de ReflectionParameter.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Parámetros, en forma de objetos ReflectionParameter.

Ver también

  • ReflectionFunctionAbstract::getNumberOfParameters() - Obtiene el número total de parámetros
  • func_get_args() - Devuelve un array que se compone de una lista de argumentos de función


Gets the specified return type of a function

  • « ReflectionFunctionAbstract::getParameters
  • ReflectionFunctionAbstract::getShortName »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Gets the specified return type of a function

ReflectionFunctionAbstract::getReturnType

(PHP 7)

ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function

Descripción

public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null

Gets the specified return type of a reflected function.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a ReflectionType object if a return type is specified, null otherwise.

Ejemplos

Ejemplo #1 ReflectionFunctionAbstract::getReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
echo $reflection1->getReturnType();

El resultado del ejemplo sería:

int

Ejemplo #2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->getReturnType());

El resultado del ejemplo sería:

null

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

Ver también

  • ReflectionFunctionAbstract::hasReturnType() - Checks if the function has a specified return type
  • ReflectionType::__toString() - To string


Obtiene el nombre abreviado de la función

  • « ReflectionFunctionAbstract::getReturnType
  • ReflectionFunctionAbstract::getStartLine »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el nombre abreviado de la función

ReflectionFunctionAbstract::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getShortName — Obtiene el nombre abreviado de la función

Descripción

public ReflectionFunctionAbstract::getShortName ( ) : string

Devuelve el nombre abreviado de la función (sin la parte del espacio de nombres).

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre abreviado de la función.

Ver también

  • ReflectionFunctionAbstract::getNamespaceName() - Obtiene el nombre del espacio de nombres
  • espcios de nombres


Obtiene el número de la línea de inicio

  • « ReflectionFunctionAbstract::getShortName
  • ReflectionFunctionAbstract::getStaticVariables »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene el número de la línea de inicio

ReflectionFunctionAbstract::getStartLine

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getStartLine — Obtiene el número de la línea de inicio

Descripción

public ReflectionFunctionAbstract::getStartLine ( ) : int

Devuelve el número de la línea de inicio de esta función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Número de la línea de inicio.

Ver también

  • ReflectionFunctionAbstract::getEndLine() - Obtiene número de linea final


Obtiene las variable estáticas

  • « ReflectionFunctionAbstract::getStartLine
  • ReflectionFunctionAbstract::hasReturnType »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Obtiene las variable estáticas

ReflectionFunctionAbstract::getStaticVariables

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getStaticVariables — Obtiene las variable estáticas

Descripción

public ReflectionFunctionAbstract::getStaticVariables ( ) : array

Devuelve las variables estáticas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

array de variables estáticas.

Ver también

  • ReflectionFunctionAbstract::getParameters() - Obtiene los parámetros


Checks if the function has a specified return type

  • « ReflectionFunctionAbstract::getStaticVariables
  • ReflectionFunctionAbstract::inNamespace »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Checks if the function has a specified return type

ReflectionFunctionAbstract::hasReturnType

(PHP 7)

ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type

Descripción

public ReflectionFunctionAbstract::hasReturnType ( ) : bool

Checks whether the reflected function has a return type specified.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns true if the function is a specified return type, otherwise false.

Ejemplos

Ejemplo #1 ReflectionFunctionAbstract::hasReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
var_dump($reflection1->hasReturnType());

El resultado del ejemplo sería:

bool(true)

Ejemplo #2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->hasReturnType());

El resultado del ejemplo sería:

bool(false)

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

Ver también

  • ReflectionFunctionAbstract::getReturnType() - Gets the specified return type of a function


Comprueba si pertenece a un espacio de nombres

  • « ReflectionFunctionAbstract::hasReturnType
  • ReflectionFunctionAbstract::isClosure »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si pertenece a un espacio de nombres

ReflectionFunctionAbstract::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::inNamespace — Comprueba si pertenece a un espacio de nombres

Descripción

public ReflectionFunctionAbstract::inNamespace ( ) : bool

Comprueba si la función está definida o no en un espacio de nombres.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si está en un espacio de nombres, o si no false

Ver también

  • ReflectionFunctionAbstract::getNamespaceName() - Obtiene el nombre del espacio de nombres
  • espacios de nombres


Comprobar si es un cierre

  • « ReflectionFunctionAbstract::inNamespace
  • ReflectionFunctionAbstract::isDeprecated »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprobar si es un cierre

ReflectionFunctionAbstract::isClosure

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::isClosure — Comprobar si es un cierre

Descripción

public ReflectionFunctionAbstract::isClosure ( ) : bool

Comprueba si la función reflejada es un objeto Closure.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la función es una Closure, false si no.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunctionAbstract::isClosure()

<?php
// No cierre
$función1 = 'str_replace';
$$reflejo1 = new ReflectionFunction($función1);
var_dump($reflejo1->isClosure());

// Cierre
$función2 = function () {};
$reflejo2 = new ReflectionFunction($función2);
var_dump($reflejo2->isClosure());
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionFunctionAbstract::isGenerator() - Devuelve si la función es un generador


Comprueba si está obsoleta

  • « ReflectionFunctionAbstract::isClosure
  • ReflectionFunctionAbstract::isGenerator »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si está obsoleta

ReflectionFunctionAbstract::isDeprecated

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isDeprecated — Comprueba si está obsoleta

Descripción

public ReflectionFunctionAbstract::isDeprecated ( ) : bool

Comprueba si la función está o no obsoleta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si está obsoleta, o si no false

Ejemplos

Ejemplo #1 Ejemplo de ReflectionFunctionAbstract::isDeprecated()

<?php
$rf = new ReflectionFunction('ereg');
var_dump($rf->isDeprecated());
?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • ReflectionFunctionAbstract::getDocComment() - Obtiene comentarios de documentación


Devuelve si la función es un generador

  • « ReflectionFunctionAbstract::isDeprecated
  • ReflectionFunctionAbstract::isInternal »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Devuelve si la función es un generador

ReflectionFunctionAbstract::isGenerator

(PHP 5 >= 5.5.0, PHP 7)

ReflectionFunctionAbstract::isGenerator — Devuelve si la función es un generador

Descripción

public ReflectionFunctionAbstract::isGenerator ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la función es un generador, false si no lo es, o null en caso de error.


Comprueba si la función es interna

  • « ReflectionFunctionAbstract::isGenerator
  • ReflectionFunctionAbstract::isUserDefined »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si la función es interna

ReflectionFunctionAbstract::isInternal

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isInternal — Comprueba si la función es interna

Descripción

public ReflectionFunctionAbstract::isInternal ( ) : bool

Comprueba si la función es interna, en contraposición a las funciones definidas por el usuario.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si es interna, o si no false

Ver también

  • ReflectionFunctionAbstract::isUserDefined() - Comprueba si es una función definida por un usuario


Comprueba si es una función definida por un usuario

  • « ReflectionFunctionAbstract::isInternal
  • ReflectionFunctionAbstract::isVariadic »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si es una función definida por un usuario

ReflectionFunctionAbstract::isUserDefined

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isUserDefined — Comprueba si es una función definida por un usuario

Descripción

public ReflectionFunctionAbstract::isUserDefined ( ) : bool

Comprueba si una función está definida por un usuario, en contraposición a las funciones internas.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si está definida por el usuario, y en cualquier otro caso false.

Ver también

  • ReflectionFunctionAbstract::isInternal() - Comprueba si la función es interna


Comprueba si la función es varíadica

  • « ReflectionFunctionAbstract::isUserDefined
  • ReflectionFunctionAbstract::returnsReference »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si la función es varíadica

ReflectionFunctionAbstract::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionFunctionAbstract::isVariadic — Comprueba si la función es varíadica

Descripción

public ReflectionFunctionAbstract::isVariadic ( ) : bool

Comprueba si la función es varíadica.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si la función es varíadica, false en caso contrario.


Comprueba si devuelve una referencia

  • « ReflectionFunctionAbstract::isVariadic
  • ReflectionFunctionAbstract::__toString »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Comprueba si devuelve una referencia

ReflectionFunctionAbstract::returnsReference

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::returnsReference — Comprueba si devuelve una referencia

Descripción

public ReflectionFunctionAbstract::returnsReference ( ) : bool

Comprueba si la función devuelve o no una referencia.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la función devuelve una referencia, o si no false

Ver también

  • ReflectionFunctionAbstract::isClosure() - Comprobar si es un cierre


Convertir a texto

  • « ReflectionFunctionAbstract::returnsReference
  • ReflectionMethod »
  • PHP Manual
  • ReflectionFunctionAbstract
  • Convertir a texto

ReflectionFunctionAbstract::__toString

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::__toString — Convertir a texto

Descripción

abstract public ReflectionFunctionAbstract::__toString ( ) : void

Convierte a texto.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Texto.

Ver también

  • ReflectionClass::clone()
  • __toString()


La clase ReflectionMethod

(PHP 5, PHP 7)

Introducción

La clase ReflectionMethod muestra información sobre un método.

Sinopsis de la Clase

ReflectionMethod extends ReflectionFunctionAbstract implements Reflector {
/* Constantes */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
const integer IS_ABSTRACT = 2 ;
const integer IS_FINAL = 4 ;
/* Propiedades */
public $name ;
public $class ;
/* Métodos */
public __construct ( mixed $class , string $name )
public static export ( string $class , string $name , bool $return = false ) : string
public getClosure ( object $object ) : Closure
public getDeclaringClass ( ) : ReflectionClass
public getModifiers ( ) : int
public getPrototype ( ) : ReflectionMethod
public invoke ( object $object , mixed $... = ? ) : mixed
public invokeArgs ( object $object , array $args ) : mixed
public isAbstract ( ) : bool
public isConstructor ( ) : bool
public isDestructor ( ) : bool
public isFinal ( ) : bool
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public isStatic ( ) : bool
public setAccessible ( bool $accessible ) : void
public __toString ( ) : string
/* Métodos heredados */
final private ReflectionFunctionAbstract::__clone ( ) : void
public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass
public ReflectionFunctionAbstract::getClosureThis ( ) : object
public ReflectionFunctionAbstract::getDocComment ( ) : string
public ReflectionFunctionAbstract::getEndLine ( ) : int
public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension
public ReflectionFunctionAbstract::getExtensionName ( ) : string
public ReflectionFunctionAbstract::getFileName ( ) : string
public ReflectionFunctionAbstract::getName ( ) : string
public ReflectionFunctionAbstract::getNamespaceName ( ) : string
public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int
public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int
public ReflectionFunctionAbstract::getParameters ( ) : array
public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null
public ReflectionFunctionAbstract::getShortName ( ) : string
public ReflectionFunctionAbstract::getStartLine ( ) : int
public ReflectionFunctionAbstract::getStaticVariables ( ) : array
public ReflectionFunctionAbstract::hasReturnType ( ) : bool
public ReflectionFunctionAbstract::inNamespace ( ) : bool
public ReflectionFunctionAbstract::isClosure ( ) : bool
public ReflectionFunctionAbstract::isDeprecated ( ) : bool
public ReflectionFunctionAbstract::isGenerator ( ) : bool
public ReflectionFunctionAbstract::isInternal ( ) : bool
public ReflectionFunctionAbstract::isUserDefined ( ) : bool
public ReflectionFunctionAbstract::isVariadic ( ) : bool
public ReflectionFunctionAbstract::returnsReference ( ) : bool
abstract public ReflectionFunctionAbstract::__toString ( ) : void
}

Propiedades

name

Nombre del método

class

Nombre de la clase

Constantes predefinidas

Modificadores ReflectionMethod

ReflectionMethod::IS_STATIC

Indica que el método es estático.

ReflectionMethod::IS_PUBLIC

Indica que el método es público.

ReflectionMethod::IS_PROTECTED

Indica que el método está protegido.

ReflectionMethod::IS_PRIVATE

Indica que el método es privado.

ReflectionMethod::IS_ABSTRACT

Indicates that the method is abstract.

ReflectionMethod::IS_FINAL

Indica que este método es final.

Tabla de contenidos

  • ReflectionMethod::__construct — Construye un objeto ReflectionMethod
  • ReflectionMethod::export — Exporta un objeto de tipo ReflectionMethod
  • ReflectionMethod::getClosure — Devuelve un cierre creado dinámicamente para este método
  • ReflectionMethod::getDeclaringClass — Obtiene la clase en la que se ha declarado el método
  • ReflectionMethod::getModifiers — Obtiene los modificadores del método
  • ReflectionMethod::getPrototype — Obtiene el prototipo del método (si lo hubiera)
  • ReflectionMethod::invoke — Invoca un método
  • ReflectionMethod::invokeArgs — Invoca un método con argumentos
  • ReflectionMethod::isAbstract — Comprueba si el método es abstracto
  • ReflectionMethod::isConstructor — Comprueba si el método es un constructor
  • ReflectionMethod::isDestructor — Comprueba si el método es un destructor
  • ReflectionMethod::isFinal — Comprueba si el método es final
  • ReflectionMethod::isPrivate — Comprueba si el método es privado
  • ReflectionMethod::isProtected — Comprueba si el método está protegido
  • ReflectionMethod::isPublic — Comprueba si el método es público
  • ReflectionMethod::isStatic — Comprueba si el método es estático
  • ReflectionMethod::setAccessible — Asigna la accesibilidad del método
  • ReflectionMethod::__toString — Devuelve la representación en forma de texto de este objeto


Construye un objeto ReflectionMethod

  • « ReflectionMethod
  • ReflectionMethod::export »
  • PHP Manual
  • ReflectionMethod
  • Construye un objeto ReflectionMethod

ReflectionMethod::__construct

(PHP 5, PHP 7)

ReflectionMethod::__construct — Construye un objeto ReflectionMethod

Descripción

public ReflectionMethod::__construct ( mixed $class , string $name )
public ReflectionMethod::__construct ( string $class_method )

Construye un nuevo objeto de tipo ReflectionMethod.

Parámetros

class

Nombre de clase u objeto (instancia de la clase) a la que pertenece el método.

name

Nombre del método.

class_method

Nombre de la clase y nombre del método delimitados por ::.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lnaza ReflectionException si no existiera el método.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::__construct()

<?php
class Contador
{
    private static $c = 0;

    /**
     * Incrementar contador
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */
    final public static function incrementar()
    {
        return ++self::$c;
    }
}

// Crea una instancia de la clase ReflectionMethod
$metodo = new ReflectionMethod('Contador', 'incrementar');

// Muestra información básica
printf(
    "===> El método %s%s%s%s%s%s%s '%s' (que es %s)\n" .
    "     declarado en %s\n" .
    "     líneas %d a %d\n" .
    "     con los modificadores %d[%s]\n",
        $metodo->isInternal() ? 'interno' : 'definido por el usuario',
        $metodo->isAbstract() ? ' abstract' : '',
        $metodo->isFinal() ? ' final' : '',
        $metodo->isPublic() ? ' public' : '',
        $metodo->isPrivate() ? ' private' : '',
        $metodo->isProtected() ? ' protected' : '',
        $metodo->isStatic() ? ' static' : '',
        $metodo->getName(),
        $metodo->isConstructor() ? 'un constructor' : 'un método regular',
        $metodo->getFileName(),
        $metodo->getStartLine(),
        $metodo->getEndline(),
        $metodo->getModifiers(),
        implode(' ', Reflection::getModifierNames($metodo->getModifiers()))
);

// Mostrar comentarios de documentación
printf("---> Documentación:\n %s\n", var_export($metodo->getDocComment(), 1));

// Si existieran, mostrar variables estáticas
if ($statics= $metodo->getStaticVariables()) {
    printf("---> Variables estáticas: %s\n", var_export($statics, 1));
}

// Invocación del método
printf("---> Resultado de la invocación: ");
var_dump($metodo->invoke(NULL));
?>

El resultado del ejemplo sería algo similar a:

===> El método definido por el usuario final public static 'incrementar' (que es un método regular)
     declared in /Users/philip/cvs/phpdoc/test.php
     líneas 14 a 17
     con los modificadores 261[final public static]
---> Documentación:
 '/**
     * Incrementar contador
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */'
---> Resultado de la invocación: int(1)

Ver también

  • ReflectionMethod::export() - Exporta un objeto de tipo ReflectionMethod
  • Constructores


Exporta un objeto de tipo ReflectionMethod

  • « ReflectionMethod::__construct
  • ReflectionMethod::getClosure »
  • PHP Manual
  • ReflectionMethod
  • Exporta un objeto de tipo ReflectionMethod

ReflectionMethod::export

(PHP 5, PHP 7)

ReflectionMethod::export — Exporta un objeto de tipo ReflectionMethod

Descripción

public static ReflectionMethod::export ( string $class , string $name , bool $return = false ) : string

Exportar un ReflectionMethod.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

class

Nombre de la clase.

name

Nombre del método.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ver también

  • ReflectionMethod::__construct() - Construye un objeto ReflectionMethod
  • ReflectionMethod::__toString() - Devuelve la representación en forma de texto de este objeto


Devuelve un cierre creado dinámicamente para este método

  • « ReflectionMethod::export
  • ReflectionMethod::getDeclaringClass »
  • PHP Manual
  • ReflectionMethod
  • Devuelve un cierre creado dinámicamente para este método

ReflectionMethod::getClosure

(PHP 5 >= 5.4.0, PHP 7)

ReflectionMethod::getClosure — Devuelve un cierre creado dinámicamente para este método

Descripción

public ReflectionMethod::getClosure ( object $object ) : Closure

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

object

No permitido en métodos estáticos. Obligatorio para el resto de métodos.

Valores devueltos

Devuelve un objeto Closure. En caso de error, devuelve null.


Obtiene la clase en la que se ha declarado el método

  • « ReflectionMethod::getClosure
  • ReflectionMethod::getModifiers »
  • PHP Manual
  • ReflectionMethod
  • Obtiene la clase en la que se ha declarado el método

ReflectionMethod::getDeclaringClass

(PHP 5, PHP 7)

ReflectionMethod::getDeclaringClass — Obtiene la clase en la que se ha declarado el método

Descripción

public ReflectionMethod::getDeclaringClass ( ) : ReflectionClass

Devuelve la clase en la que se ha declarado el método.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Objeto ReflectionClass de la clase a la que pertenece el método reflexionado.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::getDeclaringClass()

<?php
class HelloWorld {

    protected function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod(new HelloWorld(), 'sayHelloTo');
var_dump($reflectionMethod->getDeclaringClass());
?>

El resultado del ejemplo sería:

object(ReflectionClass)#2 (1) {
  ["name"]=>
  string(10) "HolaMundo"
}

Ver también

  • ReflectionMethod::isAbstract() - Comprueba si el método es abstracto


Obtiene los modificadores del método

  • « ReflectionMethod::getDeclaringClass
  • ReflectionMethod::getPrototype »
  • PHP Manual
  • ReflectionMethod
  • Obtiene los modificadores del método

ReflectionMethod::getModifiers

(PHP 5, PHP 7)

ReflectionMethod::getModifiers — Obtiene los modificadores del método

Descripción

public ReflectionMethod::getModifiers ( ) : int

Devuelve un campo de bits de los modificadores de acceso para este método.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Representación numérica de los modificadores enumerados a continuación. El significado de estos modificadores se describe en las constantes predefinidas.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::getModifiers()

<?php
class Prueba
{
    final public static function foo()
    {
        return;
    }
    public function bar()
    {
        return;
    }
}

$foo = new ReflectionMethod('Prueba', 'foo');

echo "Modificadores del método foo():\n";
echo $foo->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($foo->getModifiers())) . "\n";

$bar = new ReflectionMethod('Prueba', 'bar');

echo "Modificadores del método bar():\n";
echo $bar->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($bar->getModifiers()));
?>

El resultado del ejemplo sería algo similar a:

Modificadores del método foo():
261
final public static
Modificadores del método bar():
65792
public

Ver también

  • Reflection::getModifierNames() - Obtener nombres de modificadores


Obtiene el prototipo del método (si lo hubiera)

  • « ReflectionMethod::getModifiers
  • ReflectionMethod::invoke »
  • PHP Manual
  • ReflectionMethod
  • Obtiene el prototipo del método (si lo hubiera)

ReflectionMethod::getPrototype

(PHP 5 >= 5.1.2, PHP 7)

ReflectionMethod::getPrototype — Obtiene el prototipo del método (si lo hubiera)

Descripción

public ReflectionMethod::getPrototype ( ) : ReflectionMethod

Devuelve el prototipo del método.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve una instancia de tipo ReflectionMethod del prototipo del método.

Errores/Excepciones

Lanza ReflectionException si el método no tuviera un prototipo.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::getPrototype()

<?php
class Hola {

    public function saludarA($nombre) {
        return 'Hola ' . $nombre;
    }

}
class HolaMundo extends Hola {

    public function saludarA($nombre) {
        return 'Hola Mundo: ' . $nombre;
    }

}

$metodoReflexionado = new ReflectionMethod('HolaMundo', 'saludarA');
var_dump($metodoReflexionado->getPrototype());
?>

El resultado del ejemplo sería:

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(10) "saludarA"
  ["class"]=>
  string(5) "Hola"
}

Ver también

  • ReflectionMethod::getModifiers() - Obtiene los modificadores del método


Invoca un método

  • « ReflectionMethod::getPrototype
  • ReflectionMethod::invokeArgs »
  • PHP Manual
  • ReflectionMethod
  • Invoca un método

ReflectionMethod::invoke

(PHP 5, PHP 7)

ReflectionMethod::invoke — Invoca un método

Descripción

public ReflectionMethod::invoke ( object $object , mixed $... = ? ) : mixed

Invoca al método reflejado.

Parámetros

object

Objeto al que pertenece el método invocado. En métodos estáticos, se podrá introducir null en este parámetro.

...

Cero o más parámetros para pasar a este método. Acepta un número variable de parámetros, que se pasarán al método.

Valores devueltos

Devuelve el resultado del método.

Errores/Excepciones

Lanza ReflectionException si el parámetro object no contiene una instancia de la clase en la que se declaró este método.

Lanza ReflectionException si fallara la invocación al método.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::invoke()

<?php
class HolaMundo {

    public function saludarA($nombre) {
        return 'Hola ' . $nombre;
    }

}

$metodoReflexionado = new ReflectionMethod('HolaMundo', 'saludarA');
echo $metodoReflexionado->invoke(new HolaMundo(), 'Miguel');
?>

El resultado del ejemplo sería:

Hola Miguel

Notas

Nota:

Si la función tiene argumentos que necesitan ser referencias, éstos deben ser referencias en la lista de argumentos pasados.

Ver también

  • ReflectionMethod::invokeArgs() - Invoca un método con argumentos
  • __invoke()
  • call_user_func() - Llamar a una llamada de retorno dada por el primer parámetro


Invoca un método con argumentos

  • « ReflectionMethod::invoke
  • ReflectionMethod::isAbstract »
  • PHP Manual
  • ReflectionMethod
  • Invoca un método con argumentos

ReflectionMethod::invokeArgs

(PHP 5 >= 5.1.2, PHP 7)

ReflectionMethod::invokeArgs — Invoca un método con argumentos

Descripción

public ReflectionMethod::invokeArgs ( object $object , array $args ) : mixed

Invoca el método reflejado y pasa sus argumentos como array.

Parámetros

object

Objeto en el que se invoca al método. En caso de métodos estáticos, se podrá introducir null en este parámetro.

args

Argumentos que se pasan a la función, en un array.

Valores devueltos

Devuelve el resultado del método.

Errores/Excepciones

Lanza ReflectionException si el parámetro object no contiene una instancia de la clase en la que está declarado este método.

Lanza ReflectionException si falla la invocación al método.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::invokeArgs()

<?php
class HolaMundo {

    public function saludarA($nombre) {
        return 'Hola ' . $nombre;
    }

}

$metodoReflexionado = new ReflectionMethod('HolaMundo', 'saludarA');
echo $metodoReflexionado->invokeArgs(new HolaMundo(), array('Miguel'));
?>

El resultado del ejemplo sería:

Hola Miguel

Notas

Nota:

Si la función tiene argumentos que necesitan ser referencias, éstos deben ser referencias en la lista de argumentos pasados.

Ver también

  • ReflectionMethod::invoke() - Invoca un método
  • __invoke()
  • call_user_func_array() - Llamar a una llamada de retorno con un array de parámetros


Comprueba si el método es abstracto

  • « ReflectionMethod::invokeArgs
  • ReflectionMethod::isConstructor »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es abstracto

ReflectionMethod::isAbstract

(PHP 5, PHP 7)

ReflectionMethod::isAbstract — Comprueba si el método es abstracto

Descripción

public ReflectionMethod::isAbstract ( ) : bool

Comprueba si el método es abstracto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es abstracto, o si no false

Ver también

  • ReflectionMethod::getDeclaringClass() - Obtiene la clase en la que se ha declarado el método


Comprueba si el método es un constructor

  • « ReflectionMethod::isAbstract
  • ReflectionMethod::isDestructor »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es un constructor

ReflectionMethod::isConstructor

(PHP 5, PHP 7)

ReflectionMethod::isConstructor — Comprueba si el método es un constructor

Descripción

public ReflectionMethod::isConstructor ( ) : bool

Comprueba si el método es un constructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es un constructor, o si no false

Ver también

  • ReflectionMethod::__construct() - Construye un objeto ReflectionMethod
  • ReflectionMethod::isAbstract() - Comprueba si el método es abstracto
  • ReflectionMethod::isDestructor() - Comprueba si el método es un destructor


Comprueba si el método es un destructor

  • « ReflectionMethod::isConstructor
  • ReflectionMethod::isFinal »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es un destructor

ReflectionMethod::isDestructor

(PHP 5, PHP 7)

ReflectionMethod::isDestructor — Comprueba si el método es un destructor

Descripción

public ReflectionMethod::isDestructor ( ) : bool

Comprueba si el método es un destructor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es un destructor, o si no false

Ver también

  • ReflectionMethod::isConstructor() - Comprueba si el método es un constructor


Comprueba si el método es final

  • « ReflectionMethod::isDestructor
  • ReflectionMethod::isPrivate »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es final

ReflectionMethod::isFinal

(PHP 5, PHP 7)

ReflectionMethod::isFinal — Comprueba si el método es final

Descripción

public ReflectionMethod::isFinal ( ) : bool

Comprueba si el método es final.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es final, o si no false

Ver también

  • ReflectionMethod::isStatic() - Comprueba si el método es estático


Comprueba si el método es privado

  • « ReflectionMethod::isFinal
  • ReflectionMethod::isProtected »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es privado

ReflectionMethod::isPrivate

(PHP 5, PHP 7)

ReflectionMethod::isPrivate — Comprueba si el método es privado

Descripción

public ReflectionMethod::isPrivate ( ) : bool

Comprueba si el método es privado.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es privado, o si no false

Ver también

  • ReflectionMethod::isPublic() - Comprueba si el método es público


Comprueba si el método está protegido

  • « ReflectionMethod::isPrivate
  • ReflectionMethod::isPublic »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método está protegido

ReflectionMethod::isProtected

(PHP 5, PHP 7)

ReflectionMethod::isProtected — Comprueba si el método está protegido

Descripción

public ReflectionMethod::isProtected ( ) : bool

Comprueba si el método está protegido.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método está protegido, o si no false

Ver también

  • ReflectionMethod::isPrivate() - Comprueba si el método es privado


Comprueba si el método es público

  • « ReflectionMethod::isProtected
  • ReflectionMethod::isStatic »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es público

ReflectionMethod::isPublic

(PHP 5, PHP 7)

ReflectionMethod::isPublic — Comprueba si el método es público

Descripción

public ReflectionMethod::isPublic ( ) : bool

Comprueba si el método es público.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es público, o si no false

Ver también

  • ReflectionMethod::isPrivate() - Comprueba si el método es privado


Comprueba si el método es estático

  • « ReflectionMethod::isPublic
  • ReflectionMethod::setAccessible »
  • PHP Manual
  • ReflectionMethod
  • Comprueba si el método es estático

ReflectionMethod::isStatic

(PHP 5, PHP 7)

ReflectionMethod::isStatic — Comprueba si el método es estático

Descripción

public ReflectionMethod::isStatic ( ) : bool

Comprueba si el método es estático.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el método es estático, o si no false

Ver también

  • ReflectionMethod::isFinal() - Comprueba si el método es final


Asigna la accesibilidad del método

  • « ReflectionMethod::isStatic
  • ReflectionMethod::__toString »
  • PHP Manual
  • ReflectionMethod
  • Asigna la accesibilidad del método

ReflectionMethod::setAccessible

(PHP 5 >= 5.3.2, PHP 7)

ReflectionMethod::setAccessible — Asigna la accesibilidad del método

Descripción

public ReflectionMethod::setAccessible ( bool $accessible ) : void

Marca un método como accesible. Por ejemplo, podría hacer que los métodos protegidos o privados fueran invocados.

Parámetros

accessible

true para permitir que sea accesible, o false.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ReflectionMethod::isPrivate() - Comprueba si el método es privado
  • ReflectionMethod::isProtected() - Comprueba si el método está protegido


Devuelve la representación en forma de texto de este objeto

  • « ReflectionMethod::setAccessible
  • ReflectionNamedType »
  • PHP Manual
  • ReflectionMethod
  • Devuelve la representación en forma de texto de este objeto

ReflectionMethod::__toString

(PHP 5, PHP 7)

ReflectionMethod::__toString — Devuelve la representación en forma de texto de este objeto

Descripción

public ReflectionMethod::__toString ( ) : string

Devuelve la representación en forma de texto de este objeto.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Representación en forma de texto de esta instancia de ReflectionMethod.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionMethod::__toString()

<?php
class HolaMundo {

    public function saludarA($nombre) {
        return 'Hola ' . $nombre;
    }

}

$metodoReflexionado = new ReflectionMethod('HolaMundo', 'saludarA');
echo $metodoReflexionado;
?>

El resultado del ejemplo sería:

Method [ <user> public method saludarA ] {
  @@ /Users/chuso/Downloads/dropme.php 4 - 6

  - Parameters [1] {
    Parameter #0 [ <required> $nombre ]
  }
}

Ver también

  • ReflectionMethod::export() - Exporta un objeto de tipo ReflectionMethod
  • __toString()


The ReflectionNamedType class

(PHP 7 >= 7.1.0)

Introducción

Sinopsis de la Clase

ReflectionNamedType extends ReflectionType {
/* Métodos */
public getName ( ) : string
public isBuiltin ( ) : bool
/* Métodos heredados */
public ReflectionType::allowsNull ( ) : bool
public ReflectionType::__toString ( ) : string
}

Tabla de contenidos

  • ReflectionNamedType::getName — Get the text of the type hint
  • ReflectionNamedType::isBuiltin — Checks if it is a built-in type


Get the text of the type hint

  • « ReflectionNamedType
  • ReflectionNamedType::isBuiltin »
  • PHP Manual
  • ReflectionNamedType
  • Get the text of the type hint

ReflectionNamedType::getName

(PHP 7 >= 7.1.0)

ReflectionNamedType::getName — Get the text of the type hint

Descripción

public ReflectionNamedType::getName ( ) : string

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the text of the type hint.

Ver también

  • ReflectionType::__toString() - To string


Checks if it is a built-in type

  • « ReflectionNamedType::getName
  • ReflectionObject »
  • PHP Manual
  • ReflectionNamedType
  • Checks if it is a built-in type

ReflectionNamedType::isBuiltin

(PHP 7)

ReflectionNamedType::isBuiltin — Checks if it is a built-in type

Descripción

public ReflectionNamedType::isBuiltin ( ) : bool

Checks if the type is a built-in type in PHP.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if it's a built-in type, otherwise false

Ejemplos

Ejemplo #1 ReflectionNamedType::isBuiltin() example

<?php
class SomeClass {}

function someFunction(string $param, SomeClass $param2, StdClass $param3) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->getType()->isBuiltin());
var_dump($reflectionParams[1]->getType()->isBuiltin());
var_dump($reflectionParams[2]->getType()->isBuiltin());

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)

Note that the ReflectionNamedType::isBuiltin() method does not distinguish between internal and custom classes. To make this distinction, the ReflectionClass::isInternal() method should be used on the returned class name.

Ver también

  • ReflectionType::allowsNull() - Checks if null is allowed
  • ReflectionType::__toString() - To string
  • ReflectionClass::isInternal() - Comprueba si una clase está definida internamente por una extensión o por el núcleo
  • ReflectionParameter::getType() - Gets a parameter's type


Clase ReflectionObject

(PHP 5, PHP 7)

Introducción

La clase ReflectionObject reporta información sobre un object.

Sinopsis de la Clase

ReflectionObject extends ReflectionClass implements Reflector {
/* Constantaes heredadas constants */
const integer ReflectionClass::IS_IMPLICIT_ABSTRACT = 16 ;
const integer ReflectionClass::IS_EXPLICIT_ABSTRACT = 32 ;
const integer ReflectionClass::IS_FINAL = 64 ;
/* Propiedades */
public $name ;
/* Métodos */
public __construct ( object $argument )
public static export ( string $argument , bool $return = ? ) : string
/* Métodos heredados */
public ReflectionClass::__construct ( mixed $argument )
public static ReflectionClass::export ( mixed $argument , bool $return = false ) : string
public ReflectionClass::getConstant ( string $name ) : mixed
public ReflectionClass::getConstants ( int|null $filter = null ) : array
public ReflectionClass::getConstructor ( ) : ReflectionMethod
public ReflectionClass::getDefaultProperties ( ) : array
public ReflectionClass::getDocComment ( ) : string
public ReflectionClass::getEndLine ( ) : int
public ReflectionClass::getExtension ( ) : ReflectionExtension
public ReflectionClass::getExtensionName ( ) : string
public ReflectionClass::getFileName ( ) : string
public ReflectionClass::getInterfaceNames ( ) : array
public ReflectionClass::getInterfaces ( ) : array
public ReflectionClass::getMethod ( string $name ) : ReflectionMethod
public ReflectionClass::getMethods ( int $filter = ? ) : array
public ReflectionClass::getModifiers ( ) : int
public ReflectionClass::getName ( ) : string
public ReflectionClass::getNamespaceName ( ) : string
public ReflectionClass::getParentClass ( ) : object
public ReflectionClass::getProperties ( int $filter = ? ) : array
public ReflectionClass::getProperty ( string $name ) : ReflectionProperty
public ReflectionClass::getReflectionConstant ( string $name ) : ReflectionClassConstant|false
public ReflectionClass::getReflectionConstants ( int|null $filter = null ) : array
public ReflectionClass::getShortName ( ) : string
public ReflectionClass::getStartLine ( ) : int
public ReflectionClass::getStaticProperties ( ) : array
public ReflectionClass::getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed
public ReflectionClass::getTraitAliases ( ) : array
public ReflectionClass::getTraitNames ( ) : array
public ReflectionClass::getTraits ( ) : array
public ReflectionClass::hasConstant ( string $name ) : bool
public ReflectionClass::hasMethod ( string $name ) : bool
public ReflectionClass::hasProperty ( string $name ) : bool
public ReflectionClass::implementsInterface ( string $interface ) : bool
public ReflectionClass::inNamespace ( ) : bool
public ReflectionClass::isAbstract ( ) : bool
public ReflectionClass::isAnonymous ( ) : bool
public ReflectionClass::isCloneable ( ) : bool
public ReflectionClass::isFinal ( ) : bool
public ReflectionClass::isInstance ( object $object ) : bool
public ReflectionClass::isInstantiable ( ) : bool
public ReflectionClass::isInterface ( ) : bool
public ReflectionClass::isInternal ( ) : bool
public ReflectionClass::isIterable ( ) : bool
public ReflectionClass::isIterateable ( ) : bool
public ReflectionClass::isSubclassOf ( string $class ) : bool
public ReflectionClass::isTrait ( ) : bool
public ReflectionClass::isUserDefined ( ) : bool
public ReflectionClass::newInstance ( mixed $args , mixed $... = ? ) : object
public ReflectionClass::newInstanceArgs ( array $args = ? ) : object
public ReflectionClass::newInstanceWithoutConstructor ( ) : object
public ReflectionClass::setStaticPropertyValue ( string $name , string $value ) : void
public ReflectionClass::__toString ( ) : string
}

Propiedades

name

Nombre de la clase del objeto. De sólo lectura, lanza una ReflectionException en el intento de escribir .

Tabla de contenidos

  • ReflectionObject::__construct — Construye un ReflectionObject
  • ReflectionObject::export — Exportación


Construye un ReflectionObject

  • « ReflectionObject
  • ReflectionObject::export »
  • PHP Manual
  • ReflectionObject
  • Construye un ReflectionObject

ReflectionObject::__construct

(PHP 5, PHP 7)

ReflectionObject::__construct — Construye un ReflectionObject

Descripción

public ReflectionObject::__construct ( object $argument )

Construye un ReflectionObject.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

argument

Una instancia del objeto.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ReflectionObject::export() - Exportación
  • Constructores


Exportación

  • « ReflectionObject::__construct
  • ReflectionParameter »
  • PHP Manual
  • ReflectionObject
  • Exportación

ReflectionObject::export

(PHP 5, PHP 7)

ReflectionObject::export — Exportación

Descripción

public static ReflectionObject::export ( string $argument , bool $return = ? ) : string

Exportaciones a la reflexión.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

argument

La reflexión a exportar.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Si el parámetro return es seteado a true, la exportación se devolverá como un string, de lo contrario se retornará null.

Ver también

  • ReflectionObject::__construct() - Construye un ReflectionObject


La clase ReflectionParameter

(PHP 5, PHP 7)

Introducción

La clase ReflectionParameter recupera información sobre los parámetros de la función o del método.

Para hacer la introspección a los parámetros de la función, primero se crea una instancia de ReflectionFunction o de ReflectionMethod, y entonces se utiliza su método ReflectionFunctionAbstract::getParameters() para obtener un array de los parámetros.

Sinopsis de la Clase

ReflectionParameter implements Reflector {
/* Propiedades */
public $name ;
/* Métodos */
public allowsNull ( ) : bool
public canBePassedByValue ( ) : bool
final private __clone ( ) : void
public __construct ( callable $function , mixed $parameter )
public static export ( string $function , string $parameter , bool $return = ? ) : string
public getClass ( ) : ReflectionClass
public getDeclaringClass ( ) : ReflectionClass
public getDeclaringFunction ( ) : ReflectionFunctionAbstract
public getDefaultValue ( ) : mixed
public getDefaultValueConstantName ( ) : string
public getName ( ) : string
public getPosition ( ) : int
public getType ( ) : ReflectionType|null
public hasType ( ) : bool
public isArray ( ) : bool
public isCallable ( ) : bool
public isDefaultValueAvailable ( ) : bool
public isDefaultValueConstant ( ) : bool
public isOptional ( ) : bool
public isPassedByReference ( ) : bool
public isVariadic ( ) : bool
public __toString ( ) : string
}

Propiedades

name

Nombre de el parámetro. De sólo lectura, lanza una ReflectionException en el intento de escribir.

Tabla de contenidos

  • ReflectionParameter::allowsNull — Comprueba si null es permitido
  • ReflectionParameter::canBePassedByValue — Devuelve si este parámetro de puede pasar por valor
  • ReflectionParameter::__clone — Clon
  • ReflectionParameter::__construct — Construct
  • ReflectionParameter::export — Exportar
  • ReflectionParameter::getClass — Obtener la clase con declaraciones de tipos
  • ReflectionParameter::getDeclaringClass — Obtiene declaración de la clase
  • ReflectionParameter::getDeclaringFunction — Obtiene declaración de función
  • ReflectionParameter::getDefaultValue — Obtiene el valor del parámetro por defecto
  • ReflectionParameter::getDefaultValueConstantName — Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null
  • ReflectionParameter::getName — Obtener el nombre del parámetro
  • ReflectionParameter::getPosition — Obtiene la posición del parámetro
  • ReflectionParameter::getType — Gets a parameter's type
  • ReflectionParameter::hasType — Checks if parameter has a type
  • ReflectionParameter::isArray — Comprueba si el parámetro espera un array
  • ReflectionParameter::isCallable — Devuelve si el parámetro DEBE ser de tipo callable
  • ReflectionParameter::isDefaultValueAvailable — Comprueba si el valor por defecto está disponible
  • ReflectionParameter::isDefaultValueConstant — Devuelve si el valor predeterminado de este parámetro es constante
  • ReflectionParameter::isOptional — Comprueba si es opcional
  • ReflectionParameter::isPassedByReference — Comprueba si es pasado por referencia
  • ReflectionParameter::isVariadic — Comprueba si el parámetro es varíadico
  • ReflectionParameter::__toString — A string


Comprueba si null es permitido

  • « ReflectionParameter
  • ReflectionParameter::canBePassedByValue »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si null es permitido

ReflectionParameter::allowsNull

(PHP 5, PHP 7)

ReflectionParameter::allowsNull — Comprueba si null es permitido

Descripción

public ReflectionParameter::allowsNull ( ) : bool

Comprueba si el parámetro permite null.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si null es permitido, en caso contrario false

Ver también

  • ReflectionParameter::isOptional() - Comprueba si es opcional


Devuelve si este parámetro de puede pasar por valor

  • « ReflectionParameter::allowsNull
  • ReflectionParameter::__clone »
  • PHP Manual
  • ReflectionParameter
  • Devuelve si este parámetro de puede pasar por valor

ReflectionParameter::canBePassedByValue

(PHP 5 >= 5.4.0, PHP 7)

ReflectionParameter::canBePassedByValue — Devuelve si este parámetro de puede pasar por valor

Descripción

public ReflectionParameter::canBePassedByValue ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el parámetro se puede pasar por valor, de lo contrario false. Retorna null en caso de error.


Clon

  • « ReflectionParameter::canBePassedByValue
  • ReflectionParameter::__construct »
  • PHP Manual
  • ReflectionParameter
  • Clon

ReflectionParameter::__clone

(PHP 5, PHP 7)

ReflectionParameter::__clone — Clon

Descripción

final private ReflectionParameter::__clone ( ) : void

Clones.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • ReflectionParameter::toString()
  • Clonación de Objetos


Construct

  • « ReflectionParameter::__clone
  • ReflectionParameter::export »
  • PHP Manual
  • ReflectionParameter
  • Construct

ReflectionParameter::__construct

(PHP 5, PHP 7)

ReflectionParameter::__construct — Construct

Descripción

public ReflectionParameter::__construct ( callable $function , mixed $parameter )

Construye una instancia ReflectionParameter.

Parámetros

function

La función a reflejar parámetros.

parameter

O bien un int especificando la posición del parámetro (empezando con cero), o un nombre de parámetro como string.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Usando la clase ReflectionParameter

<?php
function foo($a, $b, $c) { }
function bar(Exception $a, &$b, $c) { }
function baz(ReflectionFunction $a, $b = 1, $c = null) { }
function abc() { }

$reflect = new ReflectionFunction('foo');

echo $reflect;

foreach ($reflect->getParameters() as $i => $param) {
    printf(
        "-- Parameter #%d: %s {\n".
        "   Class: %s\n".
        "   Allows NULL: %s\n".
        "   Passed to by reference: %s\n".
        "   Is optional?: %s\n".
        "}\n",
        $i, // $param->getPosition() can be used from PHP 5.2.3
        $param->getName(),
        var_export($param->getClass(), 1),
        var_export($param->allowsNull(), 1),
        var_export($param->isPassedByReference(), 1),
        $param->isOptional() ? 'yes' : 'no'
    );
}
?>

El resultado del ejemplo sería algo similar a:

Function [ <user> function foo ] {
  @@ /Users/philip/cvs/phpdoc/a 2 - 2

  - Parameters [3] {
    Parameter #0 [ <required> $a ]
    Parameter #1 [ <required> $b ]
    Parameter #2 [ <required> $c ]
  }
}
-- Parameter #0: a {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}
-- Parameter #1: b {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}
-- Parameter #2: c {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}

Ver también

  • ReflectionFunctionAbstract::getParameters() - Obtiene los parámetros
  • ReflectionFunction::__construct() - Contruye un objeto de tipo ReflectionFunction
  • ReflectionMethod::__construct() - Construye un objeto ReflectionMethod
  • Constructors


Exportar

  • « ReflectionParameter::__construct
  • ReflectionParameter::getClass »
  • PHP Manual
  • ReflectionParameter
  • Exportar

ReflectionParameter::export

(PHP 5, PHP 7)

ReflectionParameter::export — Exportar

Descripción

public static ReflectionParameter::export ( string $function , string $parameter , bool $return = ? ) : string

Exportar.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

function

El nombre de la función.

parameter

El nombre del parámetro.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

La reflexión exportada.

Ver también

  • ReflectionParameter::toString()


Obtener la clase con declaraciones de tipos

  • « ReflectionParameter::export
  • ReflectionParameter::getDeclaringClass »
  • PHP Manual
  • ReflectionParameter
  • Obtener la clase con declaraciones de tipos

ReflectionParameter::getClass

(PHP 5, PHP 7)

ReflectionParameter::getClass — Obtener la clase con declaraciones de tipos

Descripción

public ReflectionParameter::getClass ( ) : ReflectionClass

Obtiene la clase con declaraciones de tipos para el parámetro como un objeto ReflectionClass.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto ReflectionClass.

Ejemplos

Ejemplo #1 Utilizar la clase ReflectionParameter

<?php
function foo(Exception $a) { }

$functionReflection = new ReflectionFunction('foo');
$parameters = $functionReflection->getParameters();
$aParameter = $parameters[0];

echo $aParameter->getClass()->name;
?>

El resultado del ejemplo sería:

Exception

Ver también

  • ReflectionParameter::getDeclaringClass() - Obtiene declaración de la clase


Obtiene declaración de la clase

  • « ReflectionParameter::getClass
  • ReflectionParameter::getDeclaringFunction »
  • PHP Manual
  • ReflectionParameter
  • Obtiene declaración de la clase

ReflectionParameter::getDeclaringClass

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getDeclaringClass — Obtiene declaración de la clase

Descripción

public ReflectionParameter::getDeclaringClass ( ) : ReflectionClass

Obtiene la declaración de la clase.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto ReflectionClass.

Ejemplos

Ejemplo #1 Obtener la clase que declaró el método

<?php
class Foo
{
    public function bar(\DateTime $datetime)
    {
    }
}

class Baz extends Foo
{
}

$param = new \ReflectionParameter(['Baz', 'bar'], 0);

var_dump($param->getDeclaringClass());

El resultado del ejemplo sería:

object(ReflectionClass)#2 (1) {
  ["name"]=>
  string(3) "Foo"
}

Ver también

  • ReflectionParameter::getClass() - Obtener la clase con declaraciones de tipos


Obtiene declaración de función

  • « ReflectionParameter::getDeclaringClass
  • ReflectionParameter::getDefaultValue »
  • PHP Manual
  • ReflectionParameter
  • Obtiene declaración de función

ReflectionParameter::getDeclaringFunction

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getDeclaringFunction — Obtiene declaración de función

Descripción

public ReflectionParameter::getDeclaringFunction ( ) : ReflectionFunctionAbstract

Obtiene declaración de la función.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un objeto ReflectionFunction.

Ver también

  • ReflectionParameter::getDeclaringClass() - Obtiene declaración de la clase


Obtiene el valor del parámetro por defecto

  • « ReflectionParameter::getDeclaringFunction
  • ReflectionParameter::getDefaultValueConstantName »
  • PHP Manual
  • ReflectionParameter
  • Obtiene el valor del parámetro por defecto

ReflectionParameter::getDefaultValue

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::getDefaultValue — Obtiene el valor del parámetro por defecto

Descripción

public ReflectionParameter::getDefaultValue ( ) : mixed

Obtiene el valor por defecto del parámetro de una función definida por el usuario o en el método. Si el parámetro no es opcional una ReflectionException será lanzada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El valor de los parámetros por defecto.

Ejemplos

Ejemplo #1 Obtención de los valores por defecto de los parámetros de la función

<?php
function foo($test, $bar = 'baz')
{
    echo $test . $bar;
}

$function = new ReflectionFunction('foo');

foreach ($function->getParameters() as $param) {
    echo 'Nombre: ' . $param->getName() . PHP_EOL;
    if ($param->isOptional()) {
        echo 'Valor por defecto: ' . $param->getDefaultValue() . PHP_EOL;
    }
    echo PHP_EOL;
}
?>

El resultado del ejemplo sería:

Nombre: test

Nombre: bar
Valor por defecto: baz

Notas

Nota:

Debido a detalles de implementación, no es posible obtener el valor por omisión de una función o método de clases incorporadas. intentar hacer esto una ReflectionException será lanzada.

Ver también

  • ReflectionParameter::isOptional() - Comprueba si es opcional
  • ReflectionParameter::isDefaultValueAvailable() - Comprueba si el valor por defecto está disponible
  • ReflectionParameter::getDefaultValueConstantName() - Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null
  • ReflectionParameter::isPassedByReference() - Comprueba si es pasado por referencia


Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null

  • « ReflectionParameter::getDefaultValue
  • ReflectionParameter::getName »
  • PHP Manual
  • ReflectionParameter
  • Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null

ReflectionParameter::getDefaultValueConstantName

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::getDefaultValueConstantName — Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null

Descripción

public ReflectionParameter::getDefaultValueConstantName ( ) : string

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string en caso de éxito o null en caso de fallo.


Obtener el nombre del parámetro

  • « ReflectionParameter::getDefaultValueConstantName
  • ReflectionParameter::getPosition »
  • PHP Manual
  • ReflectionParameter
  • Obtener el nombre del parámetro

ReflectionParameter::getName

(PHP 5, PHP 7)

ReflectionParameter::getName — Obtener el nombre del parámetro

Descripción

public ReflectionParameter::getName ( ) : string

Obtener el nombre de el parámetro.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El nombre del parámetro reflejado.

Ver también

  • ReflectionParameter::getValue()


Obtiene la posición del parámetro

  • « ReflectionParameter::getName
  • ReflectionParameter::getType »
  • PHP Manual
  • ReflectionParameter
  • Obtiene la posición del parámetro

ReflectionParameter::getPosition

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getPosition — Obtiene la posición del parámetro

Descripción

public ReflectionParameter::getPosition ( ) : int

Obtiene la posición de el parámetro.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La posición de el parámetro, de izquierda a derecha, comenzando en la posición #0.

Ver también

  • ReflectionParameter::getName() - Obtener el nombre del parámetro


Gets a parameter's type

  • « ReflectionParameter::getPosition
  • ReflectionParameter::hasType »
  • PHP Manual
  • ReflectionParameter
  • Gets a parameter's type

ReflectionParameter::getType

(PHP 7)

ReflectionParameter::getType — Gets a parameter's type

Descripción

public ReflectionParameter::getType ( ) : ReflectionType|null

Gets the associated type of a parameter.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a ReflectionType object if a parameter type is specified, null otherwise.

Ejemplos

Ejemplo #1 ReflectionParameter::getType() Usage as of PHP 7.1.0

As of PHP 7.1.0, ReflectionType::__toString() is deprecated, and ReflectionParameter::getType() may return an instance of ReflectionNamedType. To get the name of the parameter type, ReflectionNamedType() is available in this case.

<?php
function someFunction(int $param, $param2) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();
$reflectionType1 = $reflectionParams[0]->getType();
$reflectionType2 = $reflectionParams[1]->getType();

assert($reflectionType1 instanceof ReflectionNamedType);
echo $reflectionType1->getName(), PHP_EOL;
var_dump($reflectionType2);
?>

El resultado del ejemplo sería:

int
NULL

Ejemplo #2 ReflectionParameter::getType() Usage before PHP 7.1.0

<?php
function someFunction(int $param, $param2) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();
$reflectionType1 = $reflectionParams[0]->getType();
$reflectionType2 = $reflectionParams[1]->getType();

echo $reflectionType1, PHP_EOL;
var_dump($reflectionType2);
?>

Salida del ejemplo anterior en PHP 7.0:

int
NULL

Ver también

  • ReflectionParameter::hasType() - Checks if parameter has a type
  • ReflectionType::__toString() - To string


Checks if parameter has a type

  • « ReflectionParameter::getType
  • ReflectionParameter::isArray »
  • PHP Manual
  • ReflectionParameter
  • Checks if parameter has a type

ReflectionParameter::hasType

(PHP 7)

ReflectionParameter::hasType — Checks if parameter has a type

Descripción

public ReflectionParameter::hasType ( ) : bool

Checks if the parameter has a type associated with it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if a type is specified, false otherwise.

Ejemplos

Ejemplo #1 ReflectionParameter::hasType() example

<?php
function someFunction(string $param, $param2 = null) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->hasType());
var_dump($reflectionParams[1]->hasType());

El resultado del ejemplo sería algo similar a:

bool(true)
bool(false)

Ver también

  • ReflectionParameter::getType() - Gets a parameter's type


Comprueba si el parámetro espera un array

  • « ReflectionParameter::hasType
  • ReflectionParameter::isCallable »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si el parámetro espera un array

ReflectionParameter::isArray

(PHP 5 >= 5.1.2, PHP 7)

ReflectionParameter::isArray — Comprueba si el parámetro espera un array

Descripción

public ReflectionParameter::isArray ( ) : bool

Comprueba si el parámetro espera un array.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si un array es esperado, en caso contrario false.

Ver también

  • ReflectionParameter::isOptional() - Comprueba si es opcional


Devuelve si el parámetro DEBE ser de tipo callable

  • « ReflectionParameter::isArray
  • ReflectionParameter::isDefaultValueAvailable »
  • PHP Manual
  • ReflectionParameter
  • Devuelve si el parámetro DEBE ser de tipo callable

ReflectionParameter::isCallable

(PHP 5 >= 5.4.0, PHP 7)

ReflectionParameter::isCallable — Devuelve si el parámetro DEBE ser de tipo callable

Descripción

public ReflectionParameter::isCallable ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el parámetro es callable, false si no, o null en caso de error.


Comprueba si el valor por defecto está disponible

  • « ReflectionParameter::isCallable
  • ReflectionParameter::isDefaultValueConstant »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si el valor por defecto está disponible

ReflectionParameter::isDefaultValueAvailable

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isDefaultValueAvailable — Comprueba si el valor por defecto está disponible

Descripción

public ReflectionParameter::isDefaultValueAvailable ( ) : bool

Comprueba si el valor por defecto para el parámetro está disponible.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el valor por defecto está disponible, en caso contrario false

Ver también

  • ReflectionParameter::getDefaultValue() - Obtiene el valor del parámetro por defecto
  • ReflectionParameter::isDefaultValueConstant() - Devuelve si el valor predeterminado de este parámetro es constante
  • ReflectionParameter::getName() - Obtener el nombre del parámetro


Devuelve si el valor predeterminado de este parámetro es constante

  • « ReflectionParameter::isDefaultValueAvailable
  • ReflectionParameter::isOptional »
  • PHP Manual
  • ReflectionParameter
  • Devuelve si el valor predeterminado de este parámetro es constante

ReflectionParameter::isDefaultValueConstant

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::isDefaultValueConstant — Devuelve si el valor predeterminado de este parámetro es constante

Descripción

public ReflectionParameter::isDefaultValueConstant ( ) : bool

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el valor predeterminado es constante, false si no lo es, o null en caso de error.


Comprueba si es opcional

  • « ReflectionParameter::isDefaultValueConstant
  • ReflectionParameter::isPassedByReference »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si es opcional

ReflectionParameter::isOptional

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isOptional — Comprueba si es opcional

Descripción

public ReflectionParameter::isOptional ( ) : bool

Comprueba si el parámetro es opcional.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el parámetro es opcional, en caso contrario false

Ver también

  • ReflectionParameter::getName() - Obtener el nombre del parámetro


Comprueba si es pasado por referencia

  • « ReflectionParameter::isOptional
  • ReflectionParameter::isVariadic »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si es pasado por referencia

ReflectionParameter::isPassedByReference

(PHP 5, PHP 7)

ReflectionParameter::isPassedByReference — Comprueba si es pasado por referencia

Descripción

public ReflectionParameter::isPassedByReference ( ) : bool

Comprueba si el parámetro es pasado por referencia.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el parámetro es pasado por referencia, en caso contrario false

Ver también

  • ReflectionParameter::getName() - Obtener el nombre del parámetro


Comprueba si el parámetro es varíadico

  • « ReflectionParameter::isPassedByReference
  • ReflectionParameter::__toString »
  • PHP Manual
  • ReflectionParameter
  • Comprueba si el parámetro es varíadico

ReflectionParameter::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionParameter::isVariadic — Comprueba si el parámetro es varíadico

Descripción

public ReflectionParameter::isVariadic ( ) : bool

Comprueba si el parámetro fue declarado como un parámetro variádico.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el parámetro es varíadico, o false en caso contrario.


A string

  • « ReflectionParameter::isVariadic
  • ReflectionProperty »
  • PHP Manual
  • ReflectionParameter
  • A string

ReflectionParameter::__toString

(PHP 5, PHP 7)

ReflectionParameter::__toString — A string

Descripción

public ReflectionParameter::__toString ( ) : string

A string.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • ReflectionParameter::export() - Exportar
  • __toString()


Clase ReflectionProperty

(PHP 5, PHP 7)

Introducción

La clase ReflectionProperty muestra información sobre las propiedades de una clase.

Sinopsis de la Clase

ReflectionProperty implements Reflector {
/* Constantes */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
/* Propiedades */
public $name ;
public $class ;
/* Métodos */
final private __clone ( ) : void
public __construct ( mixed $class , string $name )
public static export ( mixed $class , string $name , bool $return = ? ) : string
public getDeclaringClass ( ) : ReflectionClass
public getDefaultValue ( ) : mixed
public getDocComment ( ) : string
public getModifiers ( ) : int
public getName ( ) : string
public getType ( ) : ReflectionType|null
public getValue ( object $object = ? ) : mixed
public hasDefaultValue ( ) : bool
public hasType ( ) : bool
public isDefault ( ) : bool
public isInitialized ( object|null $object = null ) : bool
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public isStatic ( ) : bool
public setAccessible ( bool $accessible ) : void
public setValue ( object $object , mixed $value ) : void
public __toString ( ) : string
}

Propiedades

name

Nombre de la propiedad. De sólo lectura, lanza una ReflectionException en un intento de escribir.

class

Nombre de la clase donde se define la propiedad. De sólo lectura, lanza una ReflectionException en un intento de escribir.

Constantes predefinidas

Modificadores ReflectionProperty

ReflectionProperty::IS_STATIC

Indica las propiedades static.

ReflectionProperty::IS_PUBLIC

Indica las propiedades public.

ReflectionProperty::IS_PROTECTED

Indica las propiedades protected.

ReflectionProperty::IS_PRIVATE

Indica las propiedades private.

Tabla de contenidos

  • ReflectionProperty::__clone — Clonar
  • ReflectionProperty::__construct — Construir un objeto ReflectionProperty
  • ReflectionProperty::export — Exportar
  • ReflectionProperty::getDeclaringClass — Obtiene la clase en la que se declaró
  • ReflectionProperty::getDefaultValue — Returns the default value declared for a property
  • ReflectionProperty::getDocComment — Obtiene los comentarios de documentación de una propiedad
  • ReflectionProperty::getModifiers — Obtiene los modificadores
  • ReflectionProperty::getName — Obtiene el nombre de la propiedad
  • ReflectionProperty::getType — Gets a property's type
  • ReflectionProperty::getValue — Obtiene el valor
  • ReflectionProperty::hasDefaultValue — Checks if property has a default value declared
  • ReflectionProperty::hasType — Checks if property has a type
  • ReflectionProperty::isDefault — Comprueba si una propiedad es predeterminada
  • ReflectionProperty::isInitialized — Checks whether a property is initialized
  • ReflectionProperty::isPrivate — Comprueba si una propiedad es privada
  • ReflectionProperty::isProtected — Comprueba si la propiedad es protegida
  • ReflectionProperty::isPublic — Comprueba si la propiedad es pública
  • ReflectionProperty::isStatic — Comprueba si la propiedad es estática
  • ReflectionProperty::setAccessible — Hace accesible una propiedad
  • ReflectionProperty::setValue — Establece el valor de la propiedad
  • ReflectionProperty::__toString — Convertir a texto


Clonar

  • « ReflectionProperty
  • ReflectionProperty::__construct »
  • PHP Manual
  • ReflectionProperty
  • Clonar

ReflectionProperty::__clone

(PHP 5, PHP 7)

ReflectionProperty::__clone — Clonar

Descripción

final private ReflectionProperty::__clone ( ) : void

Clonar.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • ReflectionProperty::export() - Exportar
  • Clonación de objetos


Construir un objeto ReflectionProperty

  • « ReflectionProperty::__clone
  • ReflectionProperty::export »
  • PHP Manual
  • ReflectionProperty
  • Construir un objeto ReflectionProperty

ReflectionProperty::__construct

(PHP 5, PHP 7)

ReflectionProperty::__construct — Construir un objeto ReflectionProperty

Descripción

public ReflectionProperty::__construct ( mixed $class , string $name )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

class

El nombre de la clase que contiene la propiedad.

name

El nombre de la propiedad a reflexionar.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Si se tratara de consultar o modificar propiedades privadas o protegidas de la clase, se lanzará una excepción.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionProperty::__construct()

<?php
class Str
{
    public $longitud = 5;
}

// Crear una instancia de la clase ReflectionProperty
$prop = new ReflectionProperty('Str', 'longitud');

// Mostrar información básica
printf(
    "===> La propiedad %s%s%s%s '%s' (que está %s)\n" .
    "     con los modificadores %s\n",
        $prop->isPublic() ? ' pública' : '',
        $prop->isPrivate() ? ' privada' : '',
        $prop->isProtected() ? ' protegida' : '',
        $prop->isStatic() ? ' estática' : '',
        $prop->getName(),
        $prop->isDefault() ? 'declarada en tiempo de compilación' : 'creada en tiempo de ejecución',
        var_export(Reflection::getModifierNames($prop->getModifiers()), 1)
);

// Crear una instancia de Str
$obj= new Texto();

// Obtener el valor actual
printf("---> Valor: ");
var_dump($prop->getValue($obj));

// Cambiar valor
$prop->setValue($obj, 10);
printf("---> Al establecer como valor 10, su nuevo valor es: ");
var_dump($prop->getValue($obj));

// Volcar objeto
var_dump($obj);
?>

El resultado del ejemplo sería algo similar a:

===> La propiedad  pública 'longitud' (que está declarada en tiempo de compilación)
     con los modificadores array (
  0 => 'public',
)
---> Valor: int(5)
---> Al establecer como valor 10, su nuevo valor es: int(10)
object(Str)#2 (1) {
  ["longitud"]=>
  int(10)
}

Ejemplo #2 Obtener el valor de propiedades privadas y protegidas con ReflectionProperty

<?php

class Foo {
    public $x = 1;
    protected $y = 2;
    private $z = 3;
}

$obj = new Foo;

$prop = new ReflectionProperty('Foo', 'y');
$prop->setAccessible(true); /* Desde PHP 5.3.0 */
var_dump($prop->getValue($obj)); // int(2)

$prop = new ReflectionProperty('Foo', 'z');
$prop->setAccessible(true); /* Desde PHP 5.3.0 */
var_dump($prop->getValue($obj)); // int(2)

?>

El resultado del ejemplo sería algo similar a:

int(2)
int(3)

Ver también

  • ReflectionProperty::getName() - Obtiene el nombre de la propiedad
  • Constructores


Exportar

  • « ReflectionProperty::__construct
  • ReflectionProperty::getDeclaringClass »
  • PHP Manual
  • ReflectionProperty
  • Exportar

ReflectionProperty::export

(PHP 5, PHP 7)

ReflectionProperty::export — Exportar

Descripción

public static ReflectionProperty::export ( mixed $class , string $name , bool $return = ? ) : string

Exporta una reflexión.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

argument

La reflexión a exportar.

name

Nombre de la propiedad.

return

Configurarlo a true devolverá la exportación, a diferencia de emitirla. Configurarlo a false (el valor por defecto) hará lo contrario.

Valores devueltos

Ver también

  • ReflectionProperty::toString()


Obtiene la clase en la que se declaró

  • « ReflectionProperty::export
  • ReflectionProperty::getDefaultValue »
  • PHP Manual
  • ReflectionProperty
  • Obtiene la clase en la que se declaró

ReflectionProperty::getDeclaringClass

(PHP 5, PHP 7)

ReflectionProperty::getDeclaringClass — Obtiene la clase en la que se declaró

Descripción

public ReflectionProperty::getDeclaringClass ( ) : ReflectionClass

Devuelve la clase en la que se declaró.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Objeto de tipo ReflectionClass.

Ver también

  • ReflectionProperty::getName() - Obtiene el nombre de la propiedad


Returns the default value declared for a property

  • « ReflectionProperty::getDeclaringClass
  • ReflectionProperty::getDocComment »
  • PHP Manual
  • ReflectionProperty
  • Returns the default value declared for a property

ReflectionProperty::getDefaultValue

(PHP 8)

ReflectionProperty::getDefaultValue — Returns the default value declared for a property

Descripción

public ReflectionProperty::getDefaultValue ( ) : mixed

Gets the implicit or explicitly declared default value for a property.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The default value if the property has any default value (including null). If there is no default value, then null is returned. It is not possible to differentiate between a null default value and an unitialized typed property. Use ReflectionClass::hasDefaultValue() to detect the difference.

Ejemplos

Ejemplo #1 ReflectionClass::getDefaultValue() example

<?php
class Foo {
    public $bar = 1;
    public ?int $baz;
    public int $boing = 0;
}

$ro = new ReflectionClass(Foo::class);
var_dump($ro->getProperty('bar')->getDefaultValue());
var_dump($ro->getProperty('baz')->getDefaultValue());
var_dump($ro->getProperty('boing')->getDefaultValue());
?>

El resultado del ejemplo sería:

int(1)
NULL
int(0)

Ver también

  • ReflectionProperty::hasDefaultValue() - Checks if property has a default value declared


Obtiene los comentarios de documentación de una propiedad

  • « ReflectionProperty::getDefaultValue
  • ReflectionProperty::getModifiers »
  • PHP Manual
  • ReflectionProperty
  • Obtiene los comentarios de documentación de una propiedad

ReflectionProperty::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionProperty::getDocComment — Obtiene los comentarios de documentación de una propiedad

Descripción

public ReflectionProperty::getDocComment ( ) : string

Obtiene los comentarios de documentación de una propiedad.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Los comentarios de documentación de una propiedad.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionProperty::getDocComment()

<?php
class Str
{
    /**
     * @var int  La longitud del string
     */
    public $length = 5;
}

$prop = new ReflectionProperty('Str', 'length');

var_dump($prop->getDocComment());

?>

El resultado del ejemplo sería algo similar a:

string(51) "/**
     * @var int  La longitud del string
     */"

Ver también

  • ReflectionProperty::getModifiers() - Obtiene los modificadores
  • ReflectionProperty::getName() - Obtiene el nombre de la propiedad
  • ReflectionProperty::getValue() - Obtiene el valor


Obtiene los modificadores

  • « ReflectionProperty::getDocComment
  • ReflectionProperty::getName »
  • PHP Manual
  • ReflectionProperty
  • Obtiene los modificadores

ReflectionProperty::getModifiers

(PHP 5, PHP 7)

ReflectionProperty::getModifiers — Obtiene los modificadores

Descripción

public ReflectionProperty::getModifiers ( ) : int

Devuelve los modificadores de la propiedad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Representación numérica de los modificadores.

Ver también

  • ReflectionProperty::isPrivate() - Comprueba si una propiedad es privada
  • Reflection::getModifierNames() - Obtener nombres de modificadores


Obtiene el nombre de la propiedad

  • « ReflectionProperty::getModifiers
  • ReflectionProperty::getType »
  • PHP Manual
  • ReflectionProperty
  • Obtiene el nombre de la propiedad

ReflectionProperty::getName

(PHP 5, PHP 7)

ReflectionProperty::getName — Obtiene el nombre de la propiedad

Descripción

public ReflectionProperty::getName ( ) : string

Devuelve el nombre de la propiedad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Nombre de la propiedad.

Ver también

  • ReflectionProperty::getValue() - Obtiene el valor


Gets a property's type

  • « ReflectionProperty::getName
  • ReflectionProperty::getValue »
  • PHP Manual
  • ReflectionProperty
  • Gets a property's type

ReflectionProperty::getType

(PHP 7 >= 7.4.0)

ReflectionProperty::getType — Gets a property's type

Descripción

public ReflectionProperty::getType ( ) : ReflectionType|null

Gets the associated type of a property.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a ReflectionType if the property has a type, and null otherwise.

Ejemplos

Ejemplo #1 ReflectionProperty::getType() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
echo $rp->getType()->getName();
?>

El resultado del ejemplo sería:

string

Ver también

  • ReflectionProperty::hasType() - Checks if property has a type
  • ReflectionProperty::isInitialized() - Checks whether a property is initialized


Obtiene el valor

  • « ReflectionProperty::getType
  • ReflectionProperty::hasDefaultValue »
  • PHP Manual
  • ReflectionProperty
  • Obtiene el valor

ReflectionProperty::getValue

(PHP 5, PHP 7)

ReflectionProperty::getValue — Obtiene el valor

Descripción

public ReflectionProperty::getValue ( object $object = ? ) : mixed

Obtiene el valor de la propiedad.

Parámetros

object

Si la propiedad no fuera estática, se deberá adjuntar un objeto del que obtener la propiedad. Si se deseara obtener las propiedades predeterminadas sin proporcionar ningún objeto, utilice en su lugar ReflectionClass::getDefaultProperties().

Valores devueltos

Valor que contiene la propiedad.

Errores/Excepciones

Lanza ReflectionException si la propiedad no fuera accesible. Una propiedad protegida o privada puede hacerse accesible mediante ReflectionProperty::setAccessible().

Ejemplos

Ejemplo #1 Ejemplo de ReflectionProperty::getValue()

<?php
class Foo {
    public static $staticProperty = 'foobar';

    public $property = 'barfoo';
    protected $privateProperty = 'foofoo';
}

$reflectionClass = new ReflectionClass('Foo');

var_dump($reflectionClass->getProperty('staticProperty')->getValue());
var_dump($reflectionClass->getProperty('property')->getValue(new Foo));

$reflectionProperty = $reflectionClass->getProperty('privateProperty');
$reflectionProperty->setAccessible(true);
var_dump($reflectionProperty->getValue(new Foo));
?>

El resultado del ejemplo sería:

string(6) "foobar"
string(6) "barfoo"
string(6) "foofoo"

Ver también

  • ReflectionProperty::setValue() - Establece el valor de la propiedad
  • ReflectionProperty::setAccessible() - Hace accesible una propiedad
  • ReflectionClass::getDefaultProperties() - Obtener propiedades predeterminadas
  • ReflectionClass::getStaticPropertyValue() - Obtiene el valor de una propiedad estática


Checks if property has a default value declared

  • « ReflectionProperty::getValue
  • ReflectionProperty::hasType »
  • PHP Manual
  • ReflectionProperty
  • Checks if property has a default value declared

ReflectionProperty::hasDefaultValue

(PHP 8)

ReflectionProperty::hasDefaultValue — Checks if property has a default value declared

Descripción

public ReflectionProperty::hasDefaultValue ( ) : bool

Checks whether the property was declared with a default value, including an implicit null default value. Only returns false for typed properties without default value (or dynamic properties).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

If the property has any default value (including null) true is returned; if the property is typed without a default value declared or is a dynamic property, false is returned.

Ejemplos

Ejemplo #1 ReflectionClass::hasDefaultValue() example

<?php
class Foo {
    public $bar;
    public ?int $baz;
    public ?int $foo = null;
    public int $boing;

    public function __construct()
    {
        $this->ping = '';
    }
}

$ro = new ReflectionObject(new Foo());
var_dump($ro->getProperty('bar')->hasDefaultValue());
var_dump($ro->getProperty('baz')->hasDefaultValue());
var_dump($ro->getProperty('foo')->hasDefaultValue());
var_dump($ro->getProperty('boing')->hasDefaultValue());
var_dump($ro->getProperty('ping')->hasDefaultValue()); // Dynamic property
var_dump($ro->getProperty('pong')->hasDefaultValue()); // Not defined property
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Fatal error: Uncaught ReflectionException: Property Foo::$pong does not exist in example.php

Ver también

  • ReflectionProperty::getDefaultValue() - Returns the default value declared for a property


Checks if property has a type

  • « ReflectionProperty::hasDefaultValue
  • ReflectionProperty::isDefault »
  • PHP Manual
  • ReflectionProperty
  • Checks if property has a type

ReflectionProperty::hasType

(PHP 7 >= 7.4.0)

ReflectionProperty::hasType — Checks if property has a type

Descripción

public ReflectionProperty::hasType ( ) : bool

Checks if the property has a type associated with it.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if a type is specified, false otherwise.

Ejemplos

Ejemplo #1 ReflectionProperty::hasType() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
var_dump($rp->hasType());
?>

El resultado del ejemplo sería:

bool(true)

Ver también

  • ReflectionProperty::getType() - Gets a property's type
  • ReflectionProperty::isInitialized() - Checks whether a property is initialized


Comprueba si una propiedad es predeterminada

  • « ReflectionProperty::hasType
  • ReflectionProperty::isInitialized »
  • PHP Manual
  • ReflectionProperty
  • Comprueba si una propiedad es predeterminada

ReflectionProperty::isDefault

(PHP 5, PHP 7)

ReflectionProperty::isDefault — Comprueba si una propiedad es predeterminada

Descripción

public ReflectionProperty::isDefault ( ) : bool

Comprueba si la propiedad se declaró durante la compilación o si se declaró dinámicamente durante la ejecución.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la propiedad se declaró en tiempo de compilación, o false si se creó en tiempo de ejecución.

Ejemplos

Ejemplo #1 Ejemplo de ReflectionClass::isDefault()

<?php
class Foo {
    public $bar;
}

$o = new Foo();
$o->bar = 42;
$o->baz = 42;

$ro = new ReflectionObject($o);
var_dump($ro->getProperty('bar')->isDefault());
var_dump($ro->getProperty('baz')->isDefault());
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

Ver también

  • ReflectionProperty::getValue() - Obtiene el valor


Checks whether a property is initialized

  • « ReflectionProperty::isDefault
  • ReflectionProperty::isPrivate »
  • PHP Manual
  • ReflectionProperty
  • Checks whether a property is initialized

ReflectionProperty::isInitialized

(PHP 7 >= 7.4.0)

ReflectionProperty::isInitialized — Checks whether a property is initialized

Descripción

public ReflectionProperty::isInitialized ( object|null $object = null ) : bool

Checks whether a property is initialized.

Parámetros

object

If the property is non-static an object must be provided to fetch the property from.

Valores devueltos

Returns false for typed properties prior to initialization, and for properties that have been explicitly unset(). For all other properties true will be returned.

Errores/Excepciones

Throws a ReflectionException if the property is inaccessible. You can make a protected or private property accessible using ReflectionProperty::setAccessible().

Historial de cambios

Versión | Descripción
8.0.0 | object is nullable now.

Ejemplos

Ejemplo #1 ReflectionProperty::isInitialized() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
$user = new User;
var_dump($rp->isInitialized($user));
$user->name = 'Nikita';
var_dump($rp->isInitialized($user));
?>

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionProperty::hasType() - Checks if property has a type


Comprueba si una propiedad es privada

  • « ReflectionProperty::isInitialized
  • ReflectionProperty::isProtected »
  • PHP Manual
  • ReflectionProperty
  • Comprueba si una propiedad es privada

ReflectionProperty::isPrivate

(PHP 5, PHP 7)

ReflectionProperty::isPrivate — Comprueba si una propiedad es privada

Descripción

public ReflectionProperty::isPrivate ( ) : bool

Comprueba si una propiedad es privada.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la propiedad es privada, o false en caso contrario.

Ver también

  • ReflectionProperty::isPublic() - Comprueba si la propiedad es pública
  • ReflectionProperty::isProtected() - Comprueba si la propiedad es protegida
  • ReflectionProperty::isStatic() - Comprueba si la propiedad es estática


Comprueba si la propiedad es protegida

  • « ReflectionProperty::isPrivate
  • ReflectionProperty::isPublic »
  • PHP Manual
  • ReflectionProperty
  • Comprueba si la propiedad es protegida

ReflectionProperty::isProtected

(PHP 5, PHP 7)

ReflectionProperty::isProtected — Comprueba si la propiedad es protegida

Descripción

public ReflectionProperty::isProtected ( ) : bool

Comprueba si la propiedad es protegida.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la propiedad está protegida, o false en caso contrario.

Ver también

  • ReflectionProperty::isPublic() - Comprueba si la propiedad es pública
  • ReflectionProperty::isPrivate() - Comprueba si una propiedad es privada
  • ReflectionProperty::isStatic() - Comprueba si la propiedad es estática


Comprueba si la propiedad es pública

  • « ReflectionProperty::isProtected
  • ReflectionProperty::isStatic »
  • PHP Manual
  • ReflectionProperty
  • Comprueba si la propiedad es pública

ReflectionProperty::isPublic

(PHP 5, PHP 7)

ReflectionProperty::isPublic — Comprueba si la propiedad es pública

Descripción

public ReflectionProperty::isPublic ( ) : bool

Comprueba si la propiedad es pública.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la propiedad es pública, o false en caso contrario.

Ver también

  • ReflectionProperty::isProtected() - Comprueba si la propiedad es protegida
  • ReflectionProperty::isPrivate() - Comprueba si una propiedad es privada
  • ReflectionProperty::isStatic() - Comprueba si la propiedad es estática


Comprueba si la propiedad es estática

  • « ReflectionProperty::isPublic
  • ReflectionProperty::setAccessible »
  • PHP Manual
  • ReflectionProperty
  • Comprueba si la propiedad es estática

ReflectionProperty::isStatic

(PHP 5, PHP 7)

ReflectionProperty::isStatic — Comprueba si la propiedad es estática

Descripción

public ReflectionProperty::isStatic ( ) : bool

Comprueba si la propiedad es estática.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si la propiedad es estática, o false en caso contrario.

Ver también

  • ReflectionProperty::isPublic() - Comprueba si la propiedad es pública
  • ReflectionProperty::isProtected() - Comprueba si la propiedad es protegida
  • ReflectionProperty::isPrivate() - Comprueba si una propiedad es privada


Hace accesible una propiedad

  • « ReflectionProperty::isStatic
  • ReflectionProperty::setValue »
  • PHP Manual
  • ReflectionProperty
  • Hace accesible una propiedad

ReflectionProperty::setAccessible

(PHP 5 >= 5.3.0, PHP 7)

ReflectionProperty::setAccessible — Hace accesible una propiedad

Descripción

public ReflectionProperty::setAccessible ( bool $accessible ) : void

Hace accesible una propiedad. Por ejemplo, podrá hacer que las propiedades protegidas o privadas sean accesibles.

Parámetros

accessible

true para permitir su acceso, o false.

Valores devueltos

No devuelve ningún valor.

Ver también

  • ReflectionProperty::isPrivate() - Comprueba si una propiedad es privada
  • ReflectionProperty::isProtected() - Comprueba si la propiedad es protegida


Establece el valor de la propiedad

  • « ReflectionProperty::setAccessible
  • ReflectionProperty::__toString »
  • PHP Manual
  • ReflectionProperty
  • Establece el valor de la propiedad

ReflectionProperty::setValue

(PHP 5, PHP 7)

ReflectionProperty::setValue — Establece el valor de la propiedad

Descripción

public ReflectionProperty::setValue ( object $object , mixed $value ) : void
public ReflectionProperty::setValue ( mixed $value ) : void

Establece (cambia) el valor de la propiedad.

Parámetros

object

Si la propiedad no fuera estática, se deberá proporcionar un objeto sobre el que se cambiará la propiedad. Si la propiedad fuera estática, se omite este parámetro y sólo será necesario completar el value.

value

El nuevo valor.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Lanza ReflectionException si la propiedad no fuera accesible. Si la propiedad fuera de tipo protegido o privado, podrá hacerse accesible mediante ReflectionProperty::setAccessible().

Ejemplos

Ejemplo #1 Ejemplo de ReflectionProperty::setValue()

<?php
class Foo {
    public static $staticProperty;

    public $property;
    protected $privateProperty;
}

$reflectionClass = new ReflectionClass('Foo');

$reflectionClass->getProperty('staticProperty')->setValue('foo');
var_dump(Foo::$staticProperty);

$foo = new Foo;

$reflectionClass->getProperty('property')->setValue($foo, 'bar');
var_dump($foo->property);

$reflectionProperty = $reflectionClass->getProperty('privateProperty');
$reflectionProperty->setAccessible(true);
$reflectionProperty->setValue($foo, 'foobar');
var_dump($reflectionProperty->getValue($foo));
?>

El resultado del ejemplo sería:

string(3) "foo"
string(3) "bar"
string(6) "foobar"

Ver también

  • ReflectionProperty::getValue() - Obtiene el valor
  • ReflectionProperty::setAccessible() - Hace accesible una propiedad
  • ReflectionClass::setStaticPropertyValue() - Establece el valor de una propiedad estática


Convertir a texto

  • « ReflectionProperty::setValue
  • ReflectionType »
  • PHP Manual
  • ReflectionProperty
  • Convertir a texto

ReflectionProperty::__toString

(PHP 5, PHP 7)

ReflectionProperty::__toString — Convertir a texto

Descripción

public ReflectionProperty::__toString ( ) : string

Convierte a texto.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • __toString()


The ReflectionType class

(PHP 7)

Introducción

The ReflectionType class reports information about a function's return type.

Sinopsis de la Clase

abstract ReflectionType {
/* Métodos */
public allowsNull ( ) : bool
public __toString ( ) : string
}

Historial de cambios

Versión | Descripción
8.0.0 | ReflectionType has become abstract and ReflectionType::isBuiltin() has been moved to ReflectionNamedType::isBuiltin().

Tabla de contenidos

  • ReflectionType::allowsNull — Checks if null is allowed
  • ReflectionType::__toString — To string


Checks if null is allowed

  • « ReflectionType
  • ReflectionType::__toString »
  • PHP Manual
  • ReflectionType
  • Checks if null is allowed

ReflectionType::allowsNull

(PHP 7)

ReflectionType::allowsNull — Checks if null is allowed

Descripción

public ReflectionType::allowsNull ( ) : bool

Checks whether the parameter allows null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true if null is allowed, otherwise false

Ejemplos

Ejemplo #1 ReflectionType::allowsNull() example

<?php
function someFunction(string $param, StdClass $param2 = null) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->getType()->allowsNull());
var_dump($reflectionParams[1]->getType()->allowsNull());

El resultado del ejemplo sería:

bool(false)
bool(true)

Ver también

  • ReflectionNamedType::isBuiltin() - Checks if it is a built-in type
  • ReflectionType::__toString() - To string
  • ReflectionParameter::getType() - Gets a parameter's type


To string

  • « ReflectionType::allowsNull
  • ReflectionUnionType »
  • PHP Manual
  • ReflectionType
  • To string

ReflectionType::__toString

(PHP 7)

ReflectionType::__toString — To string

Advertencia

Esta función ha sido declarada OBSOLETA a partir de PHP 7.1.0. Su uso está totalmente desaconsejado.

Descripción

public ReflectionType::__toString ( ) : string

Gets the parameter type name.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the type of the parameter.

Ejemplos

Ejemplo #1 ReflectionType::__toString() example

<?php
function someFunction(string $param) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParam = $reflectionFunc->getParameters()[0];

echo $reflectionParam->getType();

El resultado del ejemplo sería algo similar a:

string

Historial de cambios

Versión | Descripción
7.1.0 | ReflectionType::__toString() has been deprecated.

Ver también

  • ReflectionNamedType::getName() - Get the text of the type hint
  • ReflectionNamedType::isBuiltin() - Checks if it is a built-in type
  • ReflectionType::allowsNull() - Checks if null is allowed
  • ReflectionUnionType::getTypes() - Returns the types included in the union type
  • ReflectionParameter::getType() - Gets a parameter's type


The ReflectionUnionType class

(PHP 8)

Introducción

Sinopsis de la Clase

ReflectionUnionType extends ReflectionType {
/* Métodos */
public getTypes ( ) : array
/* Métodos heredados */
public ReflectionType::allowsNull ( ) : bool
public ReflectionType::__toString ( ) : string
}

Tabla de contenidos

  • ReflectionUnionType::getTypes — Returns the types included in the union type


Returns the types included in the union type

  • « ReflectionUnionType
  • ReflectionGenerator »
  • PHP Manual
  • ReflectionUnionType
  • Returns the types included in the union type

ReflectionUnionType::getTypes

(PHP 8)

ReflectionUnionType::getTypes — Returns the types included in the union type

Descripción

public ReflectionUnionType::getTypes ( ) : array

Returns the reflections of types included in the union type.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

An array of ReflectionType objects.

Ejemplos

Ejemplo #1 ReflectionUnionType::getTypes() example

<?php
function someFunction(int|float $number) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParam = $reflectionFunc->getParameters()[0];

var_dump($reflectionParam->getType()->getTypes());

El resultado del ejemplo sería algo similar a:

array(2) {
    [0] =>
    class ReflectionNamedType#4(0) {
    }
    [1] =>
    class ReflectionNamedType#5(0) {
    }
}

Ver también

  • ReflectionType::allowsNull() - Checks if null is allowed
  • ReflectionParameter::getType() - Gets a parameter's type


The ReflectionGenerator class

(PHP 7)

Introducción

The ReflectionGenerator class reports information about a generator.

Sinopsis de la Clase

ReflectionGenerator {
/* Métodos */
public __construct ( Generator $generator )
public getExecutingFile ( ) : string
public getExecutingGenerator ( ) : Generator
public getExecutingLine ( ) : int
public getFunction ( ) : ReflectionFunctionAbstract
public getThis ( ) : object|null
public getTrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ) : array
}

Tabla de contenidos

  • ReflectionGenerator::__construct — Constructs a ReflectionGenerator object
  • ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator
  • ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object
  • ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator
  • ReflectionGenerator::getFunction — Gets the function name of the generator
  • ReflectionGenerator::getThis — Gets the $this value of the generator
  • ReflectionGenerator::getTrace — Gets the trace of the executing generator


Constructs a ReflectionGenerator object

  • « ReflectionGenerator
  • ReflectionGenerator::getExecutingFile »
  • PHP Manual
  • ReflectionGenerator
  • Constructs a ReflectionGenerator object

ReflectionGenerator::__construct

(PHP 7)

ReflectionGenerator::__construct — Constructs a ReflectionGenerator object

Descripción

public ReflectionGenerator::__construct ( Generator $generator )

Constructs a ReflectionGenerator object.

Parámetros

generator

A generator object.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 ReflectionGenerator::__construct() example

<?php

function gen()
{
    yield 1;
}

$gen = gen();

$reflectionGen = new ReflectionGenerator($gen);

echo <<< output
{$reflectionGen->getFunction()->name}
Line: {$reflectionGen->getExecutingLine()}
File: {$reflectionGen->getExecutingFile()}
output;

El resultado del ejemplo sería algo similar a:

gen
Line: 5
File: /path/to/file/example.php

Ver también

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the file name of the currently executing generator

  • « ReflectionGenerator::__construct
  • ReflectionGenerator::getExecutingGenerator »
  • PHP Manual
  • ReflectionGenerator
  • Gets the file name of the currently executing generator

ReflectionGenerator::getExecutingFile

(PHP 7)

ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator

Descripción

public ReflectionGenerator::getExecutingFile ( ) : string

Get the full path and file name of the currently executing generator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the full path and file name of the currently executing generator.

Ejemplos

Ejemplo #1 ReflectionGenerator::getExecutingFile() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

echo "File: {$reflectionGen->getExecutingFile()}";

El resultado del ejemplo sería algo similar a:

File: /path/to/file/example.php

Ver también

  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingGenerator() - Gets the executing Generator object


Gets the executing Generator object

  • « ReflectionGenerator::getExecutingFile
  • ReflectionGenerator::getExecutingLine »
  • PHP Manual
  • ReflectionGenerator
  • Gets the executing Generator object

ReflectionGenerator::getExecutingGenerator

(PHP 7)

ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object

Descripción

public ReflectionGenerator::getExecutingGenerator ( ) : Generator

Get the executing Generator object

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the currently executing Generator object.

Ejemplos

Ejemplo #1 ReflectionGenerator::getExecutingGenerator() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

$gen2 = $reflectionGen->getExecutingGenerator();

var_dump($gen2 === $gen);
var_dump($gen2->current());

El resultado del ejemplo sería algo similar a:

bool(true)
int(1);

Ver también

  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the currently executing line of the generator

  • « ReflectionGenerator::getExecutingGenerator
  • ReflectionGenerator::getFunction »
  • PHP Manual
  • ReflectionGenerator
  • Gets the currently executing line of the generator

ReflectionGenerator::getExecutingLine

(PHP 7)

ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator

Descripción

public ReflectionGenerator::getExecutingLine ( ) : int

Get the currently executing line number of the generator.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the line number of the currently executing statement in the generator.

Ejemplos

Ejemplo #1 ReflectionGenerator::getExecutingLine() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

echo "Line: {$reflectionGen->getExecutingLine()}";

El resultado del ejemplo sería algo similar a:

Line: 7

Ver también

  • ReflectionGenerator::getExecutingGenerator() - Gets the executing Generator object
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the function name of the generator

  • « ReflectionGenerator::getExecutingLine
  • ReflectionGenerator::getThis »
  • PHP Manual
  • ReflectionGenerator
  • Gets the function name of the generator

ReflectionGenerator::getFunction

(PHP 7)

ReflectionGenerator::getFunction — Gets the function name of the generator

Descripción

public ReflectionGenerator::getFunction ( ) : ReflectionFunctionAbstract

Enables the function name of the generator to be obtained by returning a class derived from ReflectionFunctionAbstract.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a ReflectionFunctionAbstract class. This will be ReflectionFunction for functions, or ReflectionMethod for methods.

Ejemplos

Ejemplo #1 ReflectionGenerator::getFunction() example

<?php

function gen()
{
    yield 1;
}

$gen = gen();

$reflectionGen = new ReflectionGenerator($gen);

var_dump($reflectionGen->getFunction());

El resultado del ejemplo sería algo similar a:

object(ReflectionFunction)#3 (1) {
  ["name"]=>
  string(3) "gen"
}

Ver también

  • ReflectionGenerator::getThis() - Gets the $this value of the generator
  • ReflectionGenerator::getTrace() - Gets the trace of the executing generator


Gets the $this value of the generator

  • « ReflectionGenerator::getFunction
  • ReflectionGenerator::getTrace »
  • PHP Manual
  • ReflectionGenerator
  • Gets the $this value of the generator

ReflectionGenerator::getThis

(PHP 7)

ReflectionGenerator::getThis — Gets the $this value of the generator

Descripción

public ReflectionGenerator::getThis ( ) : object|null

Get the $this value that the generator has access to.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the $this value, or null if the generator was not created in a class context.

Ejemplos

Ejemplo #1 ReflectionGenerator::getThis() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

var_dump($reflectionGen->getThis());

El resultado del ejemplo sería algo similar a:

object(GenExample)#3 (0) {
}

Ver también

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getTrace() - Gets the trace of the executing generator


Gets the trace of the executing generator

  • « ReflectionGenerator::getThis
  • ReflectionReference »
  • PHP Manual
  • ReflectionGenerator
  • Gets the trace of the executing generator

ReflectionGenerator::getTrace

(PHP 7)

ReflectionGenerator::getTrace — Gets the trace of the executing generator

Descripción

public ReflectionGenerator::getTrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ) : array

Get the trace of the currently executing generator.

Parámetros

options

The value of options can be any of the following flags.

Available options
Option | Description
DEBUG_BACKTRACE_PROVIDE_OBJECT | Default.
DEBUG_BACKTRACE_IGNORE_ARGS | Don't include the argument information for functions in the stack trace.

Valores devueltos

Returns the trace of the currently executing generator.

Ejemplos

Ejemplo #1 ReflectionGenerator::getTrace() example

<?php
function foo() {
    yield 1;
}

function bar()
{
    yield from foo();
}

function baz()
{
    yield from bar();
}

$gen = baz();
$gen->valid(); // start the generator

var_dump((new ReflectionGenerator($gen))->getTrace());

El resultado del ejemplo sería algo similar a:

array(2) {
  [0]=>
  array(4) {
    ["file"]=>
    string(18) "example.php"
    ["line"]=>
    int(8)
    ["function"]=>
    string(3) "foo"
    ["args"]=>
    array(0) {
    }
  }
  [1]=>
  array(4) {
    ["file"]=>
    string(18) "example.php"
    ["line"]=>
    int(12)
    ["function"]=>
    string(3) "bar"
    ["args"]=>
    array(0) {
    }
  }
}

Ver también

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getThis() - Gets the $this value of the generator


The ReflectionReference class

(PHP 7 >= 7.4.0)

Introducción

The ReflectionReference class provides information about a reference.

Sinopsis de la Clase

final ReflectionReference {
/* Métodos */
public static fromArrayElement ( array $array , int|string $key ) : ReflectionReference|null
public getId ( ) : string
}

Tabla de contenidos

  • ReflectionReference::fromArrayElement — Create a ReflectionReference from an array element
  • ReflectionReference::getId — Get unique ID of a reference


Create a ReflectionReference from an array element

  • « ReflectionReference
  • ReflectionReference::getId »
  • PHP Manual
  • ReflectionReference
  • Create a ReflectionReference from an array element

ReflectionReference::fromArrayElement

(PHP 7 >= 7.4.0)

ReflectionReference::fromArrayElement — Create a ReflectionReference from an array element

Descripción

public static ReflectionReference::fromArrayElement ( array $array , int|string $key ) : ReflectionReference|null

Creates a ReflectionReference from an array element.

Parámetros

array

The array which contains the potential reference.

key

The key; either an int or a string.

Valores devueltos

Returns a ReflectionReference instance if $array[$key] is a reference, or null otherwise.

Errores/Excepciones

If array is not an array, or key is not an int or string, a TypeError is thrown. If $array[$key] does not exist, a ReflectionException is thrown.


Get unique ID of a reference

  • « ReflectionReference::fromArrayElement
  • Reflector »
  • PHP Manual
  • ReflectionReference
  • Get unique ID of a reference

ReflectionReference::getId

(PHP 7 >= 7.4.0)

ReflectionReference::getId — Get unique ID of a reference

Descripción

public ReflectionReference::getId ( ) : string

Returns an ID which is unique for the reference for the lifetime of that reference. This ID can be used to compare references for equality, or to maintain a map of known references.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns a string of unspecified format.

Ejemplos

Ejemplo #1 Basic ReflectionReference::getId() usage

<?php
$val1 = 'foo';
$val2 = 'bar';
$arr = [&$val1, &$val2, &$val1];

$rr1 = ReflectionReference::fromArrayElement($arr, 0);
$rr2 = ReflectionReference::fromArrayElement($arr, 1);
$rr3 = ReflectionReference::fromArrayElement($arr, 2);

var_dump($rr1->getId() === $rr2->getId());
var_dump($rr1->getId() === $rr3->getId());
?>

El resultado del ejemplo sería:

bool(false)
bool(true)


La interfaz Reflector

(PHP 5, PHP 7)

Introducción

Reflector es una interfaz que implementan todas las clases exportables de Reflection.

Sinopsis de la Clase

Reflector {
/* Métodos */
public static export ( ) : string
public __toString ( ) : string
}

Tabla de contenidos

  • Reflector::export — Exportar
  • Reflector::__toString — Convertir a String


Exportar

  • « Reflector
  • Reflector::__toString »
  • PHP Manual
  • Reflector
  • Exportar

Reflector::export

(PHP 5, PHP 7)

Reflector::export — Exportar

Descripción

public static Reflector::export ( ) : string

Exporta.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • Reflection::__toString()


Convertir a String

  • « Reflector::export
  • ReflectionException »
  • PHP Manual
  • Reflector
  • Convertir a String

Reflector::__toString

(PHP 5, PHP 7)

Reflector::__toString — Convertir a String

Descripción

public Reflector::__toString ( ) : string

Convierte a String.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ver también

  • ReflectionProperty::export() - Exportar
  • __toString()


La clase ReflectionException

(PHP 5, PHP 7)

Introducción

La clase ReflectionException.

Sinopsis de la Clase

ReflectionException extends Exception {
/* Propiedades */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Manejo de variables

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de manejo de variables
    • boolval — Obtener el valor booleano de una variable
    • debug_zval_dump — Vuelca a la salida una cadena con la representación de un valor interno de zend
    • doubleval — Alias de floatval
    • empty — Determina si una variable está vacía
    • floatval — Obtener el valor flotante de una variable
    • get_defined_vars — Devuelve una matriz con todas las variables definidas
    • get_resource_id — Returns an integer identifier for the given resource
    • get_resource_type — Devuelve el tipo de recurso
    • gettype — Obtener el tipo de una variable
    • intval — Obtiene el valor entero de una variable
    • is_array — Comprueba si una variable es un array
    • is_bool — Comprueba si una variable es de tipo booleano
    • is_callable — Verificar que los contenidos de una variable puedan ser llamados como una función
    • is_countable — Verifica que el contenido de una variable es un valor contable
    • is_double — Alias de is_float
    • is_float — Comprueba si el tipo de una variable es float
    • is_int — Comprueba si el tipo de una variable es integer
    • is_integer — Alias de is_int
    • is_iterable — Verifica que el contenido de una variable es un valor iterable
    • is_long — Alias de is_int
    • is_null — Comprueba si una variable es null
    • is_numeric — Comprueba si una variable es un número o un string numérico
    • is_object — Comprueba si una variable es un objeto
    • is_real — Alias de is_float
    • is_resource — Comprueba si una variable es un recurso
    • is_scalar — Comprueba si una variable es escalar
    • is_string — Comprueba si una variable es de tipo string
    • isset — Determina si una variable está definida y no es null
    • print_r — Imprime información legible para humanos sobre una variable
    • serialize — Genera una representación apta para el almacenamiento de un valor
    • settype — Establece el tipo de una variable
    • strval — Obtiene el valor de cadena de una variable
    • unserialize — Crea un valor PHP a partir de una representación almacenada
    • unset — Destruye una variable especificada
    • var_dump — Muestra información sobre una variable
    • var_export — Imprime o devuelve una representación string de una variable analizable


Introducción

Para obtener información sobre cómo funcionan las variables, vea la entrada Variables dentro de la sección Referencia del lenguaje del manual.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de variables
Nombre | Por defecto | Cambiable | Historial de cambios
unserialize_callback_func | null | PHP_INI_ALL |
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

unserialize_callback_func string

La función de llamada de retorno especificada será llamada cuando unserialize() intente usar una clase no definida. Una advertencia aparecerá si la llamada de retorno especificada no está definida o si la función de llamada de retorno falla al intentar definir la clase faltante.

Vea también unserialize() y Autoloading Objects.


  • « Tipos de recursos
  • Funciones de manejo de variables »
  • PHP Manual
  • Manejo de variables
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de manejo de variables

Tabla de contenidos

  • boolval — Obtener el valor booleano de una variable
  • debug_zval_dump — Vuelca a la salida una cadena con la representación de un valor interno de zend
  • doubleval — Alias de floatval
  • empty — Determina si una variable está vacía
  • floatval — Obtener el valor flotante de una variable
  • get_defined_vars — Devuelve una matriz con todas las variables definidas
  • get_resource_id — Returns an integer identifier for the given resource
  • get_resource_type — Devuelve el tipo de recurso
  • gettype — Obtener el tipo de una variable
  • intval — Obtiene el valor entero de una variable
  • is_array — Comprueba si una variable es un array
  • is_bool — Comprueba si una variable es de tipo booleano
  • is_callable — Verificar que los contenidos de una variable puedan ser llamados como una función
  • is_countable — Verifica que el contenido de una variable es un valor contable
  • is_double — Alias de is_float
  • is_float — Comprueba si el tipo de una variable es float
  • is_int — Comprueba si el tipo de una variable es integer
  • is_integer — Alias de is_int
  • is_iterable — Verifica que el contenido de una variable es un valor iterable
  • is_long — Alias de is_int
  • is_null — Comprueba si una variable es null
  • is_numeric — Comprueba si una variable es un número o un string numérico
  • is_object — Comprueba si una variable es un objeto
  • is_real — Alias de is_float
  • is_resource — Comprueba si una variable es un recurso
  • is_scalar — Comprueba si una variable es escalar
  • is_string — Comprueba si una variable es de tipo string
  • isset — Determina si una variable está definida y no es null
  • print_r — Imprime información legible para humanos sobre una variable
  • serialize — Genera una representación apta para el almacenamiento de un valor
  • settype — Establece el tipo de una variable
  • strval — Obtiene el valor de cadena de una variable
  • unserialize — Crea un valor PHP a partir de una representación almacenada
  • unset — Destruye una variable especificada
  • var_dump — Muestra información sobre una variable
  • var_export — Imprime o devuelve una representación string de una variable analizable


Obtener el valor booleano de una variable

  • « Funciones de manejo de variables
  • debug_zval_dump »
  • PHP Manual
  • Funciones de manejo de variables
  • Obtener el valor booleano de una variable

boolval

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

boolval — Obtener el valor booleano de una variable

Descripción

boolval ( mixed $var ) : bool

Devuelve el valor boolean de var.

Parámetros

var

El valor escalar a convertir a un boolean.

Valores devueltos

El valor boolean de var.

Ejemplos

Ejemplo #1 Ejemplos de boolval()

<?php
echo '0:        '.(boolval(0) ? 'true' : 'false')."\n";
echo '42:       '.(boolval(42) ? 'true' : 'false')."\n";
echo '0.0:      '.(boolval(0.0) ? 'true' : 'false')."\n";
echo '4.2:      '.(boolval(4.2) ? 'true' : 'false')."\n";
echo '"":       '.(boolval("") ? 'true' : 'false')."\n";
echo '"string": '.(boolval("string") ? 'true' : 'false')."\n";
echo '"0":      '.(boolval("0") ? 'true' : 'false')."\n";
echo '"1":      '.(boolval("1") ? 'true' : 'false')."\n";
echo '[1, 2]:   '.(boolval([1, 2]) ? 'true' : 'false')."\n";
echo '[]:       '.(boolval([]) ? 'true' : 'false')."\n";
echo 'stdClass: '.(boolval(new stdClass) ? 'true' : 'false')."\n";
?>

El resultado del ejemplo sería:

0:        false
42:       true
0.0:      false
4.2:      true
"":       false
"string": true
"0":      false
"1":      true
[1, 2]:   true
[]:       false
stdClass: true

Ver también

  • floatval() - Obtener el valor flotante de una variable
  • intval() - Obtiene el valor entero de una variable
  • strval() - Obtiene el valor de cadena de una variable
  • settype() - Establece el tipo de una variable
  • is_bool() - Comprueba si una variable es de tipo booleano
  • Manipulación de tipos


Vuelca a la salida una cadena con la representación de un valor interno de zend

  • « boolval
  • doubleval »
  • PHP Manual
  • Funciones de manejo de variables
  • Vuelca a la salida una cadena con la representación de un valor interno de zend

debug_zval_dump

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

debug_zval_dump — Vuelca a la salida una cadena con la representación de un valor interno de zend

Descripción

debug_zval_dump ( mixed $variable , mixed $... = ? ) : void

Volcar a la salida una cadena con la representación de un valor interno de zend.

Parámetros

variable

La variable a ser evaluada

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo debug_zval_dump()

<?php
$var1 = 'Hola Mundo';
$var2 = '';

$var2 =& $var1;

debug_zval_dump(&$var1);
?>

El resultado del ejemplo sería:

&string(11) "Hola Mundo" refcount(3)

Nota: Cuidado con refcount

El valor refcount devuelto por esta función no es evidente en determinadas circunstancias. Por ejemplo, un desarrollador puede esperar que el ejemplo anterior indique un refcount de 2. La tercera referencia se crea cuando se realiza la llamada a debug_zval_dump().

Este comportamiento se agrava aún más cuando una variable no se pasa a debug_zval_dump() por referencia. Para ilustrar esto, considere una versión ligeramente modificada del ejemplo anterior:

<?php
$var1 = 'Hola Mundo';
$var2 = '';

$var2 =& $var1;

debug_zval_dump($var1); // esta vez, no pasada por referencia
?>

El resultado del ejemplo sería:

string(11) "Hola Mundo" refcount(1)

Por qué refcount(1)? Porque una copia de $var1 es realizada, cuando se llama a la función.

Esta función se hace aún más confusa cuando una variable con un refcount de 1 es pasada (por copia/valor):

<?php
$var1 = 'Hola Mundo';

debug_zval_dump($var1);
?>

El resultado del ejemplo sería:

string(11) "Hola Mundo" refcount(2)

Un refcount de 2, aquí, no es extremedamente evidente. Especialmente teniendo en cuenta los ejemplos anteriores. ¿Qué ha ocurrido?

Cuando una variable tiene una sola referencia (como ocurría con $var1 antes de que fuera utilizada como un argumento para debug_zval_dump()), el motor de PHP optimiza la manera en que se pasa a una función. Internamente, PHP trata $var1 como una referencia (en esa refcount se incrementa para el ámbito de esa función), con la salvedad de que si la referencia pasa a ser aprobada por escrito y, una copia es realizada, pero sólo en el momento de la escritura. Esto se conoce como "copiar al escribir."

Así que, si debug_zval_dump() pasa a escribir en su único parámetro (y no lo hace), es entonces cuando se haría una copia. Hasta entonces, el parámetro sigue siendo una referencia, haciendo que refcount sea incrementado a 2 en el ámbito de la función llamada.

Ver también

  • var_dump() - Muestra información sobre una variable
  • debug_backtrace() - Genera un rastreo
  • Explicación de las Referencias
  • » Explicación de las Referencias (por Derick Rethans)


Alias de floatval

  • « debug_zval_dump
  • empty »
  • PHP Manual
  • Funciones de manejo de variables
  • Alias de floatval

doubleval

(PHP 4, PHP 5, PHP 7, PHP 8)

doubleval — Alias de floatval()

Descripción

Esta función es un alias de: floatval().


Determina si una variable está vacía

  • « doubleval
  • floatval »
  • PHP Manual
  • Funciones de manejo de variables
  • Determina si una variable está vacía

empty

(PHP 4, PHP 5, PHP 7, PHP 8)

empty — Determina si una variable está vacía

Descripción

empty ( mixed $var ) : bool

Determina si una variable es considerada vacía. Una variable se considera vacía si no existe o si su valor es igual a false. empty() no genera una advertencia si la variable no existe.

Parámetros

var

La variable que se comprueba

Nota:

Antes de PHP 5.5, empty() sólo soportaba variables; cualquier otra cosa provocaría un error del intérprete. En otras palabras, lo siguiente no funcionaría: empty(trim($nombre)). En su lugar, utilice trim($nombre) == false.

No se genera una advertencia si la variable no existe. Esto significa que empty() es esencialmente el equivalente conciso de !isset($var) || $var == false.

Valores devueltos

Devuelve false si var existe y tiene un valor no vacío, distinto de cero. De otro modo devuelve true.

Los siguientes valores son considerados como vacíos:

  • "" (una cadena vacía)
  • 0 (0 como un integer)
  • 0.0 (0 como un float)
  • "0" (0 como un string)
  • null
  • false
  • array() (un array vacío)

Historial de cambios

Versión | Descripción
5.5.0 | empty() ahora soporta expresiones, en vez de únicamente variables.
5.4.0 | Verificación de índices no numéricos de strings devuelve true.

Ejemplos

Ejemplo #1 Una simple comparación empty() / isset()

<?php
$var = 0;

// Se evalúa a true ya que $var está vacia
if (empty($var)) {
    echo '$var es o bien 0, vacía, o no se encuentra definida en absoluto';
}

// Se evalúa como true ya que $var está definida
if (isset($var)) {
    echo '$var está definida a pesar que está vacía';
}
?>

Ejemplo #2 empty() en índices de string

PHP 5.4 cambia como empty() se comporta cuando se pasan índices de string.

<?php
$expected_array_got_string = 'somestring';
var_dump(empty($expected_array_got_string['some_key']));
var_dump(empty($expected_array_got_string[0]));
var_dump(empty($expected_array_got_string['0']));
var_dump(empty($expected_array_got_string[0.5]));
var_dump(empty($expected_array_got_string['0.5']));
var_dump(empty($expected_array_got_string['0 Mostel']));
?>

Salida del ejemplo anterior en PHP 5.3:

bool(false)
bool(false)
bool(false)
bool(false)
bool(false)
bool(false)

Salida del ejemplo anterior en PHP 5.4:

bool(true)
bool(false)
bool(false)
bool(false)
bool(true)
bool(true)

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Nota:

Cuando se utiliza empty() sobre las propiedades de objetos inaccesibles, el método sobrecargado __isset() será llamado, si se declara.

Ver también

  • isset() - Determina si una variable está definida y no es null
  • __isset()
  • unset() - Destruye una variable especificada
  • array_key_exists() - Verifica si el índice o clave dada existe en el array
  • count() - Cuenta todos los elementos de un array o algo de un objeto
  • strlen() - Obtiene la longitud de un string
  • Las tablas de comparación de tipos


Obtener el valor flotante de una variable

  • « empty
  • get_defined_vars »
  • PHP Manual
  • Funciones de manejo de variables
  • Obtener el valor flotante de una variable

floatval

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

floatval — Obtener el valor flotante de una variable

Descripción

floatval ( mixed $var ) : float

Obtiene el valor valor float de var.

Parámetros

var

Puede ser cualquier tipo escalar. No se puede utilizar floatval() en objetos, si es usado emitirá un error de nivel E_NOTICE y devolverá 1.

Valores devueltos

El valor flotante de la variable dada. Arrays vacios devolverán 0, arrays no vacios devolverán 1.

Las cadenas generalmente devolverán 0, aunque esto depende de los primeros caracteres de la cadena. Las reglas comunes de conversión a flotante se aplican en cualquier caso.

Ejemplos

Ejemplo #1 Ejemplo de floatval()

<?php
 $var = '122.34343El';
 $valor_float_de_var = floatval($var);
 echo $valor_float_de_var; // 122.34343
 ?>

Ejemplo #2 Ejemplo de floatval() con caracteres a la izquierda no numéricos

<?php
$var = 'El122.34343';
$float_value_of_var = floatval($var);
echo $float_value_of_var; // 0
?>

Ver también

  • boolval() - Obtener el valor booleano de una variable
  • intval() - Obtiene el valor entero de una variable
  • strval() - Obtiene el valor de cadena de una variable
  • settype() - Establece el tipo de una variable
  • Conversión de Tipos


Devuelve una matriz con todas las variables definidas

  • « floatval
  • get_resource_id »
  • PHP Manual
  • Funciones de manejo de variables
  • Devuelve una matriz con todas las variables definidas

get_defined_vars

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

get_defined_vars — Devuelve una matriz con todas las variables definidas

Descripción

get_defined_vars ( ) : array

Esta función devuelve una matriz multidimensional que contiene una lista de todas las variables definidas, ya sean variables de entorno, de servidor o definidas por el usuario, en el ámbito que get_defined_vars() es llamado.

Valores devueltos

Una matriz multidimensional con todas las variables.

Ejemplos

Ejemplo #1 Ejemplo de get_defined_vars()

<?php
$b = array(1, 1, 2, 3, 5, 8);

$arr = get_defined_vars();

// imprime $b
print_r($arr["b"]);

/* imprime ruta de acceso al intérprete de PHP (si es usado como CGI)
 * e.g. /usr/local/bin/php */
echo $arr["_"];

// imprime los parámetros de la linea de comandos, si existen
print_r($arr["argv"]);

// imprime todas las variables del servidor
print_r($arr["_SERVER"]);

// imprime todas las claves disponibles para las matrices de variables
print_r(array_keys(get_defined_vars()));
?>

Ver también

  • isset() - Determina si una variable está definida y no es null
  • get_defined_functions() - Devuelve un array de todas las funciones definidas
  • get_defined_constants() - Devuelve un array asociativo con los nombres de todas las constantes y sus valores


Returns an integer identifier for the given resource

  • « get_defined_vars
  • get_resource_type »
  • PHP Manual
  • Funciones de manejo de variables
  • Returns an integer identifier for the given resource

get_resource_id

(PHP 8)

get_resource_id — Returns an integer identifier for the given resource

Descripción

get_resource_id ( resource $res ) : int

This function provides a type-safe way for generating the integer identifier for a resource.

Parámetros

res

The evaluated resource handle.

Valores devueltos

The int identifier for the given res.

This function is essentially an int cast of res to make it easier to retrieve the resource ID.

Ejemplos

Ejemplo #1 get_resource_id() example

<?php
$handle = fopen('./storage/logs/lumen.log', 'rt');

echo (int) $handle . "\n\n";

echo get_resource_id($handle);

?>

El resultado del ejemplo sería:

698

698

Ver también

  • get_resource_type() - Devuelve el tipo de recurso


Devuelve el tipo de recurso

  • « get_resource_id
  • gettype »
  • PHP Manual
  • Funciones de manejo de variables
  • Devuelve el tipo de recurso

get_resource_type

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

get_resource_type — Devuelve el tipo de recurso

Descripción

get_resource_type ( resource $handle ) : string

Esta función obtiene el tipo del recurso dado.

Parámetros

handle

El gestor de recurso evaluado.

Valores devueltos

Si el dado handle es un recurso esta función devolverá una cadena que representa su tipo. Si el tipo no es identificado por esta función, el valor de retorno será la cadena Unknown.

Está función devolverá false y generará un error si handle no es un resource.

Ejemplos

Ejemplo #1 Ejemplo deget_resource_type()

<?php
// imprime: mysql link
$c = mysql_connect();
echo get_resource_type($c) . "\n";

// imprime: stream
$fp = fopen("foo", "w");
echo get_resource_type($fp) . "\n";

// imprime: domxml document
$doc = new_xmldoc("1.0");
echo get_resource_type($doc->doc) . "\n";
?>


Obtener el tipo de una variable

  • « get_resource_type
  • intval »
  • PHP Manual
  • Funciones de manejo de variables
  • Obtener el tipo de una variable

gettype

(PHP 4, PHP 5, PHP 7, PHP 8)

gettype — Obtener el tipo de una variable

Descripción

gettype ( mixed $var ) : string

Devuelve el tipo de la variable PHP var. Para la comprobación de tipos, utilice las funciones is_*.

Parámetros

var

La variable de la cual queremos comprobar su tipo.

Valores devueltos

Los valores posibles para la cadena devuelta son:

  • "boolean"
  • "integer"
  • "double" (por razones históricas "double" es devuelto en caso de que un valor sea de tipo float, y no simplemente "float")
  • "string"
  • "array"
  • "object"
  • "resource"
  • "NULL"
  • "unknown type"

Ejemplos

Ejemplo #1 Ejemplo de gettype()

<?php

$data = array(1, 1., NULL, new stdClass, 'foo');

foreach ($data as $value) {
    echo gettype($value), "\n";
}

?>

El resultado del ejemplo sería algo similar a:

integer
double
NULL
object
string

Ver también

  • settype() - Establece el tipo de una variable
  • get_class() - Devuelve el nombre de la clase de un objeto
  • is_array() - Comprueba si una variable es un array
  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_callable() - Verificar que los contenidos de una variable puedan ser llamados como una función
  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_null() - Comprueba si una variable es null
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_object() - Comprueba si una variable es un objeto
  • is_resource() - Comprueba si una variable es un recurso
  • is_scalar() - Comprueba si una variable es escalar
  • is_string() - Comprueba si una variable es de tipo string
  • function_exists() - Devuelve true si la función dada ha sido definida
  • method_exists() - Comprueba si existe un método de una clase


Obtiene el valor entero de una variable

  • « gettype
  • is_array »
  • PHP Manual
  • Funciones de manejo de variables
  • Obtiene el valor entero de una variable

intval

(PHP 4, PHP 5, PHP 7, PHP 8)

intval — Obtiene el valor entero de una variable

Descripción

intval ( mixed $var , int $base = 10 ) : int

Devuelve el valor integer de una var, con la especificada base para la conversión (por defecto es base 10). No debería ser usado en objetos, si es usado emitirá un error de nivel E_NOTICE y devolverá 1.

Parámetros

var

El valor escalar a convertir a un entero

base

La base para la conversión

Nota:

Si base es 0, la base usada estará determinada por el formato de var:

  • si el string incuye el prefijo "0x" (o "0X"), la base se tomará como 16 (hex); si no,
  • si el string comienza con "0", la base se tomará como 8 (octal); si no,
  • la base se toma como 10 (decimal).

Valores devueltos

El valor entero de var en caso de éxito, o 0 en caso de error. Arrays vacíos devuelven 0, arrays no vacíos devuelven 1.

El valor máximo depende del sistema. Los sistemas de 32 bits tienen un rango máximo para un entero con signo que va desde -2147483648 a 2147483647. Así, por ejemplo, en tal sistema, intval('1000000000000') devolverá 2147483647. El valor máximo para un entero con signo en sistemas de 64 bits es 9223372036854775807.

Las cadenas muy probablemente devolverán 0, aunque esto depende de los carácteres del extremo izquierdo de la cadena. Aplican las reglas comunes para moldeado de enteros.

Ejemplos

Ejemplo #1 Ejemplos de intval()

Los siguientes ejemplos se basan en un sistema de 32 bits.

<?php
echo intval(42);                      // 42
echo intval(4.2);                     // 4
echo intval('42');                    // 42
echo intval('+42');                   // 42
echo intval('-42');                   // -42
echo intval(042);                     // 34
echo intval('042');                   // 42
echo intval(1e10);                    // 1410065408
echo intval('1e10');                  // 1
echo intval(0x1A);                    // 26
echo intval(42000000);                // 42000000
echo intval(420000000000000000000);   // 0
echo intval('420000000000000000000'); // 2147483647
echo intval(42, 8);                   // 42
echo intval('42', 8);                 // 34
echo intval(array());                 // 0
echo intval(array('foo', 'bar'));     // 1
?>

Notas

Nota:

El parámetro base no tiene ningún efecto a menos que el parámetro var sea una cadena.

Historial de cambios

Versión | Descripción
5.1.0 | Lanza E_NOTICE y devuelve 1, cuando se pasa un objecto a var.

Ver también

  • boolval() - Obtener el valor booleano de una variable
  • floatval() - Obtener el valor flotante de una variable
  • strval() - Obtiene el valor de cadena de una variable
  • settype() - Establece el tipo de una variable
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • Manipulación de tipos
  • Funciones matemáticas de precisión arbitraria de BCMath


Comprueba si una variable es un array

  • « intval
  • is_bool »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es un array

is_array

(PHP 4, PHP 5, PHP 7, PHP 8)

is_array — Comprueba si una variable es un array

Descripción

is_array ( mixed $var ) : bool

Comprueba si la variable es un array.

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es un array, o de lo contrario false.

Ejemplos

Ejemplo #1 Comprobar que la variable es un array

<?php
$si = array('esto', 'es', 'un array');

echo is_array($si) ? 'Array' : 'No es un array';
echo "\n";

$no = 'esto es un string';

echo is_array($no) ? 'Array' : 'No es un array';
?>

El resultado del ejemplo sería:

Array
No es un array

Ver también

  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_string() - Comprueba si una variable es de tipo string
  • is_object() - Comprueba si una variable es un objeto


Comprueba si una variable es de tipo booleano

  • « is_array
  • is_callable »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es de tipo booleano

is_bool

(PHP 4, PHP 5, PHP 7, PHP 8)

is_bool — Comprueba si una variable es de tipo booleano

Descripción

is_bool ( mixed $var ) : bool

Obtiene si la variable dada es un booleano.

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es un boolean, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplos de is_bool()

<?php
$a = false;
$b = 0;

// Ya que $a es un booleano, devolverá true
if (is_bool($a) === true) {
    echo "Sí, este es un booleano";
}

// Ya que $b no es un booleano, devolverá false
if (is_bool($b) === false) {
    echo "No, este no es un booleano";
}
?>

Ver también

  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_string() - Comprueba si una variable es de tipo string
  • is_object() - Comprueba si una variable es un objeto
  • is_array() - Comprueba si una variable es un array


Verificar que los contenidos de una variable puedan ser llamados como una función

  • « is_bool
  • is_countable »
  • PHP Manual
  • Funciones de manejo de variables
  • Verificar que los contenidos de una variable puedan ser llamados como una función

is_callable

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

is_callable — Verificar que los contenidos de una variable puedan ser llamados como una función

Descripción

is_callable ( mixed $var , bool $syntax_only = false , string &$callable_name = ? ) : bool

Verifica que los contenidos de una variable puedan ser llamados como una función. Esto permite revisar que los contenidos de una variable contengan el nombre de una función válida, o que un array contenga un objeto adecuadamente codificado y un nombre de función.

Parámetros

var

El valor a revisar

solo_sintaxis

Si es true la función solo verifica que nombre pueda ser una función o un método. Solo rechazará variables simples que no sean cadenas, o un array que no tenga una estructura válida para ser usado como llamada de retorno. Se espera que las matrices válidas tengan solo 2 entradas, la primera de las cuales es un objeto o una cadena, y la segunda una cadena.

callable_name

Recibe el "nombre que puede ser llamado". En el ejemplo siguiente aquél es "algunaClase:algunMetodo". Tenga en cuenta, sin embargo, que a pesar de la implicación de que algunaClase::algunMetodo() es un método estático que puede ser llamado, este no es el caso.

Valores devueltos

Devuelve true si var puede ser llamado, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de is_callable()

<?php
//  Cómo chequear una variable para ver si puede ser llamada
//  como una función.

//
//  Variable simple que contiene una función
//

function algunaFuncion()
{
}

$variableFuncion = 'algunaFuncion';

var_dump(is_callable($variableFuncion, false, $nombre_a_llamar));  // bool(true)

echo $nombre_a_llamar, "\n";  // algunaFuncion

//
//  Array que contiene un método
//

class algunaClase {

  function algunMetodo()
  {
  }

}

$unObjeto = new algunaClase();

$variableMetodo = array($unObjeto, 'algunMetodo');

var_dump(is_callable($variableMetodo, true, $nombre_a_llamar));  //  bool(true)

echo $nombre_a_llamar, "\n";  //  algunaClase::algunMetodo

?>

Ejemplo #2 Función is_callable() y constructores

A partir de PHP 5.3.0 la función is_callable() reporta constructores como que no se pueden llamar. Esto afecta el estilo de los constructores de PHP 5 (__construct) así también el estilo de los constructors de PHP 4 (por ejemplo metodos con el mismo nombre de la clase). Anteriormente, ambos casos han sido considerados como llamables.

<?php

class Foo
{
    public function __construct() {}
    public function foo() {}
}

var_dump(
    is_callable(array('Foo', '__construct')),
    is_callable(array('Foo', 'foo'))
);

El resultado del ejemplo sería:

bool(false)
bool(false)

Ver también

  • function_exists() - Devuelve true si la función dada ha sido definida
  • method_exists() - Comprueba si existe un método de una clase


Verifica que el contenido de una variable es un valor contable

  • « is_callable
  • is_double »
  • PHP Manual
  • Funciones de manejo de variables
  • Verifica que el contenido de una variable es un valor contable

is_countable

(PHP 7 >= 7.3.0, PHP 8)

is_countable — Verifica que el contenido de una variable es un valor contable

Descripción

is_countable ( mixed $var ) : bool

Verifica que el contenido de una variable es un array o un objeto implementando Countable

Parámetros

var

El valor a comprobar

Valores devueltos

Devuelve true si var es contable, false en caso contrario.

Historial de cambios

Versión | Descripción
7.3.0 | is_countable() ha sido añadido.

Ejemplos

Ejemplo #1 ejemplos de is_countable()

<?php
var_dump(is_countable([1, 2, 3])); // bool(true)
var_dump(is_countable(new ArrayIterator(['foo', 'bar', 'baz']))); // bool(true)
var_dump(is_countable(new ArrayIterator())); // bool(true)
var_dump(is_countable(new stdClass())); // bool(false)

Ver también

  • is_array() - Comprueba si una variable es un array
  • is_object() - Comprueba si una variable es un objeto
  • is_iterable() - Verifica que el contenido de una variable es un valor iterable
  • is_bool() - Comprueba si una variable es de tipo booleano


Alias de is_float

  • « is_countable
  • is_float »
  • PHP Manual
  • Funciones de manejo de variables
  • Alias de is_float

is_double

(PHP 4, PHP 5, PHP 7, PHP 8)

is_double — Alias de is_float()

Descripción

Esta función es un alias de: is_float().


Comprueba si el tipo de una variable es float

  • « is_double
  • is_int »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si el tipo de una variable es float

is_float

(PHP 4, PHP 5, PHP 7, PHP 8)

is_float — Comprueba si el tipo de una variable es float

Descripción

is_float ( mixed $var ) : bool

Comprueba si el tipo de variable dado es float.

Nota:

Para comprobar si una variable es un número o un string numérico (por ejemplo, un formulario de entrada, que es siempre un string), debe utilizar is_numeric().

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es de tipo float, o false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de is_float()

var_dump(is_float(27.25));
var_dump(is_float('abc'));
var_dump(is_float(23));
var_dump(is_float(23.5));
var_dump(is_float(1e7));  //Notación Científica
var_dump(is_float(true));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)
bool(false)
bool(true)
bool(true)
bool(false)

Ver también

  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_string() - Comprueba si una variable es de tipo string
  • is_array() - Comprueba si una variable es un array
  • is_object() - Comprueba si una variable es un objeto


Comprueba si el tipo de una variable es integer

  • « is_float
  • is_integer »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si el tipo de una variable es integer

is_int

(PHP 4, PHP 5, PHP 7, PHP 8)

is_int — Comprueba si el tipo de una variable es integer

Descripción

is_int ( mixed $var ) : bool

Comprueba si el tipo de variable dado es integer.

Nota:

Para comprobar si una variable es un número o un string numérico (por ejemplo, un formulario de entrada, que es siempre un string), debe utilizar is_numeric().

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es de tipo integer, o false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de is_int()

<?php
$values = array(23, "23", 23.5, "23.5", null, true, false);
foreach ($values as $value) {
    echo "is_int(";
    var_export($value);
    echo ") = ";
    var_dump(is_int($value));
}
?>

El resultado del ejemplo sería:

is_int(23) = bool(true)
is_int('23') = bool(false)
is_int(23.5) = bool(false)
is_int('23.5') = bool(false)
is_int(NULL) = bool(false)
is_int(true) = bool(false)
is_int(false) = bool(false)

Ver también

  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_float() - Comprueba si el tipo de una variable es float
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_string() - Comprueba si una variable es de tipo string
  • is_array() - Comprueba si una variable es un array
  • is_object() - Comprueba si una variable es un objeto


Alias de is_int

  • « is_int
  • is_iterable »
  • PHP Manual
  • Funciones de manejo de variables
  • Alias de is_int

is_integer

(PHP 4, PHP 5, PHP 7, PHP 8)

is_integer — Alias de is_int()

Descripción

Esta función es un alias de: is_int().


Verifica que el contenido de una variable es un valor iterable

  • « is_integer
  • is_long »
  • PHP Manual
  • Funciones de manejo de variables
  • Verifica que el contenido de una variable es un valor iterable

is_iterable

(PHP 7 >= 7.1.0, PHP 8)

is_iterable — Verifica que el contenido de una variable es un valor iterable

Descripción

is_iterable ( mixed $var ) : bool

Verifica que el contenido de una variable es aceptado por el pseudo-tipo iterable, p.e. que es o bien un array o un objeto implementando Traversable

Parámetros

var

El valor a comprobar

Valores devueltos

Devuelve true si var es iterable, false en caso contrario.

Ejemplos

Ejemplo #1 ejemplos de is_iterable()

<?php

var_dump(is_iterable([1, 2, 3]));  // bool(true)
var_dump(is_iterable(new ArrayIterator([1, 2, 3])));  // bool(true)
var_dump(is_iterable((function () { yield 1; })()));  // bool(true)
var_dump(is_iterable(1));  // bool(false)
var_dump(is_iterable(new stdClass()));  // bool(false)

?>

Ver también

  • is_array() - Comprueba si una variable es un array


Alias de is_int

  • « is_iterable
  • is_null »
  • PHP Manual
  • Funciones de manejo de variables
  • Alias de is_int

is_long

(PHP 4, PHP 5, PHP 7, PHP 8)

is_long — Alias de is_int()

Descripción

Esta función es un alias de: is_int().


Comprueba si una variable es null

  • « is_long
  • is_numeric »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es null

is_null

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

is_null — Comprueba si una variable es null

Descripción

is_null ( mixed $var ) : bool

Comprueba si la variable dada es null.

Parámetros

var

La variable a ser evaluada

Valores devueltos

Devuelve true si var es null, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo is_null()

<?php

error_reporting(E_ALL);

$foo = NULL;
var_dump(is_null($inexistent), is_null($foo));

?>
Aviso: Variable indefinida: inexistente en ...
bool(true)
bool(true)

Ver también

  • El tipo null
  • isset() - Determina si una variable está definida y no es null
  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_string() - Comprueba si una variable es de tipo string
  • is_object() - Comprueba si una variable es un objeto
  • is_array() - Comprueba si una variable es un array


Comprueba si una variable es un número o un string numérico

  • « is_null
  • is_object »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es un número o un string numérico

is_numeric

(PHP 4, PHP 5, PHP 7, PHP 8)

is_numeric — Comprueba si una variable es un número o un string numérico

Descripción

is_numeric ( mixed $value ) : bool

Comprueba si la variable dada es numérica o string numérico.

Parámetros

value

La variable a evaluar.

Valores devueltos

Devuelve true si var es un número o una cadena numérica, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplos de is_numeric()

<?php
$tests = array(
    "42",
    1337,
    0x539,
    02471,
    0b10100111001,
    1337e0,
    "0x539",
    "02471",
    "0b10100111001",
    "1337e0",
    "not numeric",
    array(),
    9.1,
    null
);

foreach ($tests as $element) {
    if (is_numeric($element)) {
        echo var_export($element, true) . " es numérico", PHP_EOL;
    } else {
        echo var_export($element, true) . " NO es numérico", PHP_EOL;
    }
}
?>

El resultado del ejemplo sería:

'42' is numérico
1337 is numérico
1337 is numérico
1337 is numérico
1337 is numérico
1337.0 is numérico
'0x539' NO es numérico
'02471' is numérico
'0b10100111001' NO es numérico
'1337e0' is numérico
'not numeric' NO es numérico
array (
) NO es numérico
9.1 is numérico
NULL NO es numérico

Ver también

  • String numérico
  • ctype_digit() - Chequear posibles caracteres numéricos
  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_null() - Comprueba si una variable es null
  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_string() - Comprueba si una variable es de tipo string
  • is_object() - Comprueba si una variable es un objeto
  • is_array() - Comprueba si una variable es un array


Comprueba si una variable es un objeto

  • « is_numeric
  • is_real »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es un objeto

is_object

(PHP 4, PHP 5, PHP 7, PHP 8)

is_object — Comprueba si una variable es un objeto

Descripción

is_object ( mixed $var ) : bool

Comprueba si la variable dada es un objeto.

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es un object, o false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo is_object()

<?php
// Declarar una simple función para devolver un
// array de nuestro objeto
function get_students($obj)
{
    if(!is_object($obj)) {
        return false;
    }

    return $obj->students;
}

// Declara una nueva instancia de clase y rellena
// algunos valores
$obj = new stdClass();
$obj->students = array('Kalle', 'Ross', 'Felipe');

var_dump(get_students(null));
var_dump(get_students($obj));
?>

Historial de cambios

Versión | Descripción
7.2.0 | is_object() ahora devuelve true para objetos no seriados sin una definición de clase (clase de __PHP_Incomplete_Class). Anteriormente false era devuelto.

Ver también

  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_float() - Comprueba si el tipo de una variable es float
  • is_string() - Comprueba si una variable es de tipo string
  • is_array() - Comprueba si una variable es un array


Alias de is_float

  • « is_object
  • is_resource »
  • PHP Manual
  • Funciones de manejo de variables
  • Alias de is_float

is_real

(PHP 4, PHP 5, PHP 7, PHP 8)

is_real — Alias de is_float()

Descripción

Esta función es un alias de: is_float().


Comprueba si una variable es un recurso

  • « is_real
  • is_scalar »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es un recurso

is_resource

(PHP 4, PHP 5, PHP 7, PHP 8)

is_resource — Comprueba si una variable es un recurso

Descripción

is_resource ( mixed $var ) : bool

Comprueba si la variable es un recurso.

Parámetros

var

La variable que se evalúa.

Valores devueltos

Devuelve true si var es un resource, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo de is_resource()

<?php

$db_link = @mysql_connect('localhost', 'mysql_user', 'mysql_pass');
if (!is_resource($db_link)) {
    die('No pudo realizarse la conexión : ' . mysql_error());
}

?>

Ver también

  • La documentación del tipo recurso
  • get_resource_type() - Devuelve el tipo de recurso


Comprueba si una variable es escalar

  • « is_resource
  • is_string »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es escalar

is_scalar

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

is_scalar — Comprueba si una variable es escalar

Descripción

is_scalar ( mixed $var ) : bool

Obtiene si la variable dada es escalar.

Las variables escalares son aquellas que contienen un integer, float, string o boolean. Tipos array, object y resource no son escalares.

Nota:

is_scalar() no tiene en cuenta resource como escalares ya que los recursos son tipos de datos abstractos que actualmente se basan en enteros. No debe confiar en este detalle de implementación, ya que puede cambiar.

Nota:

is_scalar() no considera que NULL sea escalar.

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es escalar, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo is_scalar()

<?php
function show_var($var)
{
    if (is_scalar($var)) {
        echo $var;
    } else {
        var_dump($var);
    }
}
$pi = 3.1416;
$proteinas = array("hemoglobina", "citocromo c oxidasa", "ferredoxin");

show_var($pi);
show_var($proteinas)

?>

El resultado del ejemplo sería:

3.1416
array(3) {
  [0]=>
  string(10) "hemoglobina"
  [1]=>
  string(20) "citocromo c oxidasa"
  [2]=>
  string(10) "ferredoxin"
}

Ver también

  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_numeric() - Comprueba si una variable es un número o un string numérico
  • is_real() - Alias de is_float
  • is_string() - Comprueba si una variable es de tipo string
  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_object() - Comprueba si una variable es un objeto
  • is_array() - Comprueba si una variable es un array


Comprueba si una variable es de tipo string

  • « is_scalar
  • isset »
  • PHP Manual
  • Funciones de manejo de variables
  • Comprueba si una variable es de tipo string

is_string

(PHP 4, PHP 5, PHP 7, PHP 8)

is_string — Comprueba si una variable es de tipo string

Descripción

is_string ( mixed $var ) : bool

Obtiene si la variable dada es de tipo string.

Parámetros

var

La variable a ser evaluada.

Valores devueltos

Devuelve true si var es de tipo string, false de lo contrario.

Ejemplos

Ejemplo #1 Ejemplo is_string()

<?php
$values = array(false, true, null, 'abc', '23', 23, '23.5', 23.5, '', ' ', '0', 0);
foreach ($values as $value) {
    echo "is_string(";
    var_export($value);
    echo ") = ";
    echo var_dump(is_string($value));
}
?>

El resultado del ejemplo sería:

is_string(false) = bool(false)
is_string(true) = bool(false)
is_string(NULL) = bool(false)
is_string('abc') = bool(true)
is_string('23') = bool(true)
is_string(23) = bool(false)
is_string('23.5') = bool(true)
is_string(23.5) = bool(false)
is_string('') = bool(true)
is_string(' ') = bool(true)
is_string('0') = bool(true)
is_string(0) = bool(false)

Ver también

  • is_float() - Comprueba si el tipo de una variable es float
  • is_int() - Comprueba si el tipo de una variable es integer
  • is_bool() - Comprueba si una variable es de tipo booleano
  • is_object() - Comprueba si una variable es un objeto
  • is_array() - Comprueba si una variable es un array


Determina si una variable está definida y no es null

  • « is_string
  • print_r »
  • PHP Manual
  • Funciones de manejo de variables
  • Determina si una variable está definida y no es null

isset

(PHP 4, PHP 5, PHP 7, PHP 8)

isset — Determina si una variable está definida y no es null

Descripción

isset ( mixed $var , mixed $... = ? ) : bool

Determina si una variable está definida y no es null.

Si una variable ha sido removida con unset(), esta ya no estará definida. isset() devolverá false si prueba una variable que ha sido definida como null. También tenga en cuenta que un byte null ("\0") no es equivalente a la constante null de PHP.

Si son pasados varios parámetros, entonces isset() devolverá true únicamente si todos los parámetros están definidos. La evaluación se realiza de izquierda a derecha y se detiene tan pronto como se encuentre una variable no definida.

Parámetros

var

La variable a ser evaluada.

...

Otra variable...

Valores devueltos

Devuelve true si var existe y tiene un valor distinto de null, false de lo contrario.

Historial de cambios

Versión | Descripción
5.4.0 | Comprobación de indices no numéricos de strings ahora retorna false.

Ejemplos

Ejemplo #1 Ejemplos isset()

<?php

$var = '';

// Esto evaluará a TRUE así que el texto se imprimirá.
if (isset($var)) {
    echo "Esta variable está definida, así que se imprimirá";
}

// En los siguientes ejemplo usaremos var_dump para imprimir
// el valor devuelto por isset().

$a = "prueba";
$b = "otraprueba";

var_dump(isset($a));      // TRUE
var_dump(isset($a, $b)); // TRUE

unset ($a);

var_dump(isset($a));     // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));   // FALSE

?>

También trabaja con elementos en matrices:

<?php

$a = array ('test' => 1, 'hello' => NULL, 'pie' => array('a' => 'apple'));

var_dump(isset($a['test']));            // TRUE
var_dump(isset($a['foo']));             // FALSE
var_dump(isset($a['hello']));           // FALSE

// La clave 'helo' es igual a NULL así que no se considera definida
// Si desea comprobar los valores NULL clave, intente:
var_dump(array_key_exists('hello', $a)); // TRUE

// Comprobando valores de arrays con más profunidad
var_dump(isset($a['pie']['a']));        // TRUE
var_dump(isset($a['pie']['b']));        // FALSE
var_dump(isset($a['cake']['a']['b']));  // FALSE

?>

Notas

Advertencia

isset() sólo trabaja con variables, ya que pasar cualquier otra cosa dará como resultado un error de intérprete. Para comprobar si se han definidoconstantes use la función defined().

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Nota:

Cuando se utiliza isset() sobre las propiedades de objetos inaccesibles, el método sobrecargado __isset() será llamado, si se declara.

Ejemplo #2 isset() en indices de String

PHP 5.4 cambia ahora el comportamiendo de isset() cuando son pasados indices de string.

<?php
$expected_array_got_string = 'somestring';
var_dump(isset($expected_array_got_string['some_key']));
var_dump(isset($expected_array_got_string[0]));
var_dump(isset($expected_array_got_string['0']));
var_dump(isset($expected_array_got_string[0.5]));
var_dump(isset($expected_array_got_string['0.5']));
var_dump(isset($expected_array_got_string['0 Mostel']));
?>

Salida del ejemplo anterior en PHP 5.3:

bool(true)
bool(true)
bool(true)
bool(true)
bool(true)
bool(true)

Salida del ejemplo anterior en PHP 5.4:

bool(false)
bool(true)
bool(true)
bool(true)
bool(false)
bool(false)

Ver también

  • empty() - Determina si una variable está vacía
  • __isset()
  • unset() - Destruye una variable especificada
  • defined() - Comprueba si existe una constante con nombre dada
  • las tablas de comparación de tipos
  • array_key_exists() - Verifica si el índice o clave dada existe en el array
  • is_null() - Comprueba si una variable es null
  • el operador @ de control de errores


Imprime información legible para humanos sobre una variable

  • « isset
  • serialize »
  • PHP Manual
  • Funciones de manejo de variables
  • Imprime información legible para humanos sobre una variable

print_r

(PHP 4, PHP 5, PHP 7, PHP 8)

print_r — Imprime información legible para humanos sobre una variable

Descripción

print_r ( mixed $expression , bool $return = false ) : mixed

print_r() muestra información sobre una variable en una forma que es legible por humanos.

print_r(), var_dump() y var_export() mostrarán también propiedades protegidas y privadas de objetos. Miembros de la clase estática no se mostrarán.

Parámetros

expresión

La expresión a ser impresa.

return

Si desea capturar la salida de print_r(), use el parámetro return. Cuando el parámetro es establecido a true, print_r() devolverá la información en lugar de imprimirla.

Valores devueltos

Si se le da string, integer o float, el valor en sí mismo será impreso. Si le dan un array, los valores serán presentados en un formato que muestra las claves y los elementos. Una notación similar se utiliza para objects.

Cuando el parámetro return es true, esta función devolverá un string. De lo contrario, devolverá true.

Notas

Nota:

Cuando el parámetro return se usa, esta función utiliza el almacenamiento en búfer de salida interno, por lo que no puede usarse dentro de una función de llamada de retorno ob_start().

Ejemplos

Ejemplo #1 Ejemplo print_r()

<pre>
<?php
$a = array ('a' => 'manzana', 'b' => 'banana', 'c' => array ('x', 'y', 'z'));
print_r ($a);
?>
</pre>

El resultado del ejemplo sería:

<pre>
Array
(
    [a] => manzana
    [b] => banana
    [c] => Array
        (
            [0] => x
            [1] => y
            [2] => z
        )
)
</pre>

Ejemplo #2 Ejemplo del parámetro devolver

<?php
$b = array ('m' => 'mono', 'foo' => 'bar', 'x' => array ('x', 'y', 'z'));
$resultados = print_r($b, true); // $resultados contiene ahora la salida de print_r
?>

Ver también

  • ob_start() - Activa el almacenamiento en búfer de la salida
  • var_dump() - Muestra información sobre una variable
  • var_export() - Imprime o devuelve una representación string de una variable analizable


Genera una representación apta para el almacenamiento de un valor

  • « print_r
  • settype »
  • PHP Manual
  • Funciones de manejo de variables
  • Genera una representación apta para el almacenamiento de un valor

serialize

(PHP 4, PHP 5, PHP 7, PHP 8)

serialize — Genera una representación apta para el almacenamiento de un valor

Descripción

serialize ( mixed $value ) : string

Genera una representación almacenable de un valor.

Esto es útil para el almacenamiento de valores en PHP sin perder su tipo y estructura.

Para recuperar el valor PHP a partir de la cadena seriada, utilice unserialize().

Parámetros

value

El valor a ser serializado. serialize() maneja todos los tipos, excepto el tipo resource. Puede incluso usar serialize() sobre arrays que contienen referencias a ellos mismos. Las referencias circulares encontradas en el array/objeto que procede a serializar también serán almacenadas. Cualquier otra referencia se perderá.

Cuando se trata de objetos, PHP intentará llamar a la función miembro __sleep() antes de la serialización. Esto permite que el objeto efectúe limpiezas de último minuto, etc. antes de ser serializado. Del mismo modo, cuando el objeto es recuperado usando unserialize(), la función miembro __wakeup() es llamada.

Nota:

Los miembros privados del objeto tienen el nombre de la clase al comienzo de su nombre; los miembros protegidos tienen un '*' al comienzo de su nombre. estos valores antepuestos tienen bytes nulos a ambos lados.

Valores devueltos

Devuelve una cadena que contiene una representación de flujo de bytes del value que puede ser almacenada en cualquier parte.

Observe que esto es una cadena binaria que puede incluir bytes nulos, y necesita ser almacenada y manipulada como tal. Por ejemplo, la salida de serialize() debe ser generalmente almacenada en un campo de tipo BLOB en la base de datos, en vez de en campos de tipo CHAR o TEXT.

Ejemplos

Ejemplo #1 Ejemplo serialize()

<?php
// $datos_sesion contiene un array multi-dimensional con
// información del usuario actual. Usamos serialize() para
// almacenarla en una base de datos al final de la petición.

$con  = odbc_connect("bd_web", "php", "gallina");
$sent = odbc_prepare($con,
      "UPDATE sesiones SET datos = ? WHERE id = ?");
$datos_sql = array (serialize($datos_sesion), $_SERVER['PHP_AUTH_USER']);

if (!odbc_execute($sent, &$datos_sql)) {
    $sent = odbc_prepare($con,
     "INSERT INTO sesiones (id, datos) VALUES(?, ?)");
    if (!odbc_execute($sent, &$datos_sql)) {
        /* Algo ha fallado.. */
    }
}
?>

Notas

Nota:

Tenga en cuenta que muchos objetos integrados de PHP no se pueden serializar. Sin embargo, aquellos con esta habilidad o implementan la interfaz Serializable o los métodos mágicos __sleep() y __wakeup(). Si una clase interna no cumple cualquiera de esos requisitos, estas seguramente no puedan ser serializadas.

Hay algunas excepciones históricas a la regla anterior, donde algunos objetos internos podrían ser serializados sin implementar la interfaz o la exposición de los métodos. En particular, la clase ArrayObject anterior a PHP 5.2.0.

Advertencia

Cuando serialize() serializa los objetos, la barra inicial no está incluido en el nombre de clase de las clases de espacios de nombres para una máxima compatibilidad.

Ver también

  • unserialize() - Crea un valor PHP a partir de una representación almacenada
  • var_export() - Imprime o devuelve una representación string de una variable analizable
  • json_encode() - Retorna la representación JSON del valor dado
  • Serialización de Objetos
  • __sleep()
  • __wakeup()


Establece el tipo de una variable

  • « serialize
  • strval »
  • PHP Manual
  • Funciones de manejo de variables
  • Establece el tipo de una variable

settype

(PHP 4, PHP 5, PHP 7, PHP 8)

settype — Establece el tipo de una variable

Descripción

settype ( mixed &$var , string $type ) : bool

Establece el tipo de la variable var a tipo.

Parámetros

var

La variable a ser convertida.

tipo

Los posibles valores de tipo son:

  • "boolean" o "bool"
  • "integer" o "int"
  • "float" o "double"
  • "string"
  • "array"
  • "object"
  • "null"

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo settype()

<?php
$foo = "5bar"; // cadena
$bar = true;   // booleano

settype($foo, "integer"); // $foo es ahora 5   (entero)
settype($bar, "string");  // $bar es ahora "1" (cadena)
?>

Notas

Nota:

El máximo valor para "int" es PHP_INT_MAX.

Ver también

  • gettype() - Obtener el tipo de una variable
  • type-casting
  • type-juggling


Obtiene el valor de cadena de una variable

  • « settype
  • unserialize »
  • PHP Manual
  • Funciones de manejo de variables
  • Obtiene el valor de cadena de una variable

strval

(PHP 4, PHP 5, PHP 7, PHP 8)

strval — Obtiene el valor de cadena de una variable

Descripción

strval ( mixed $var ) : string

Obtener el valor de la cadena de una variable. Vea la documentación sobre el tipo de dato string para obtener más información sobre la conversión a cadena.

Esta función no realiza ninguna de formato en el valor devuelto. Si está buscando una manera de dar formato a un valor numérico como una cadena, por favor consulte las funciones sprintf() o number_format().

Parámetros

var

La variable que se está convirtiendo en un string.

var puede ser cualquier tipo escalar o un objeto que implemente el método __toString(). No puede usar strval() en arrays u objetos que no implementen el método __toString().

Valores devueltos

El valor string de var.

Ejemplos

Ejemplo #1 strval() usando el método mágico __toString() de PHP 5

<?php
class StrValTest
{
    public function __toString()
    {
        return __CLASS__;
    }
}

// Imprime 'StrValTest'
echo strval(new StrValTest);
?>

Ver también

  • boolval() - Obtener el valor booleano de una variable
  • floatval() - Obtener el valor flotante de una variable
  • intval() - Obtiene el valor entero de una variable
  • settype() - Establece el tipo de una variable
  • sprintf() - Devuelve un string formateado
  • number_format() - Formatear un número con los millares agrupados
  • Manipulación de Tipos
  • __toString()


Crea un valor PHP a partir de una representación almacenada

  • « strval
  • unset »
  • PHP Manual
  • Funciones de manejo de variables
  • Crea un valor PHP a partir de una representación almacenada

unserialize

(PHP 4, PHP 5, PHP 7, PHP 8)

unserialize — Crea un valor PHP a partir de una representación almacenada

Descripción

unserialize ( string $str , array $options = ? ) : mixed

unserialize() toma una única variable serializada y la vuelve a convertir a un valor de PHP.

Advertencia

No pases valores no confiables proporcionados por el usuario a unserialize() con independencia del valor dado en options a allowed_classes. La deserialización puede resultar en que el código sea cargado y ejecutado debido a la instanciación y autocarga de objetos, y un usuario malicioso podría ser capaz de explotar este comportamiento. Utiliza un formato de intercambio de datos estándar y seguro como JSON (mediante json_decode() y json_encode()) si necesitas pasar datos serializados al usuario.

Si necesitas deserializar datos almacenados externamente, considera utilizar hash_hmac() para verificarlos. Asegúrate de que los datos no son modificados por nadie excepto por ti.

Parámetros

str

El string serializado.

Si la variable que está siendo convertida de vuelta es un objeto, PHP intentará llamar la función miembro __wakeup() si existe) automáticamente luego de haber recontruido satisfactoriamente el objeto.

Nota: Directiva unserialize_callback_func

Es posible establecer una función-llamada de retorno la cual será llamada si una clase no definida debería ser instanciada durante el proceso de revertir la seriación(para prevenir que se reciba un object incompleto "__PHP_Incomplete_Class".) Use su php.ini, ini_set() o .htaccess para definir unserialize_callback_func. Cada vez que una clase no definida deba ser instanciada, esta función será llamada. Para deshabilitar esta característica simplemente asigne un valor vacío a este parámetro.

options

Cualquier opción para unserialize(), dada como un array asociativo.

Opciones válidas
Nombre | Tipo | Descripción
allowed_classes | mixed | Puede ser un array de nombres de clases que deben ser aceptadas, false para no aceptar clases, o true para aceptar todas las clases. Si esta opción se define y unserialize() encuentra un objeto de una clase que no se acepta, el objeto será instanciado como __PHP_Incomplete_Class en su lugar. La omisión de esta opción es lo mismo que definirla como true: PHP intentará instanciar objetos de cualquier clase.

Valores devueltos

El valor convertido es retornado, y puede ser un boolean, integer, float, string, array u object.

En caso de que el string pasado no pueda ser procesado para revertir la serialización, se devuelve false y un error de tipo E_NOTICE es generado.

Historial de cambios

Versión | Descripción
7.1.0 | El elemento allowed_classes de options) es ahora estrictamente tipado, es decir: si cualquier cosa distinta de un array o un boolean es proporcionada, unserialize() retornará false y lanzará un E_WARNING.
7.0.0 | Se añadió el parámetro options.
5.6.0 | Manipular los datos serializados reemplazando C: con O: para forzar la instanciación de objetos sin llamar al constructor ahora fallará.

Ejemplos

Ejemplo #1 Ejemplo de unserialize()

<?php
// Aquí usamos unserialize() para cargar los datos de sesión
// provenientes del string seleccionado desde la base de datos en el
// array $datos_sesion. Este ejemplo complementa aquel descrito con serialize().

$con  = odbc_connect("bd_web", "php", "gallina");
$sent = odbc_prepare($con, "SELECT datos FROM sesiones WHERE id = ?");
$datos_sql = array($_SERVER['PHP_AUTH_USER']);

if (!odbc_execute($sent, &$datos_sql) || !odbc_fetch_into($sent, &$tmp)) {
    // si la ejecución del comando o la recuperación de datos falla,
    // inicializar una matriz vacía
    $datos_sesion = array();
} else {
    // ahora deberíamos tener los datos serializados en $tmp[0].
    $datos_sesion = unserialize($tmp[0]);
    if (!is_array($datos_sesion)) {
        // algo ha fallado, inicializar un array vacío
        $datos_sesion = array();
    }
}
?>

Ejemplo #2 Ejemplo de unserialize_callback_func

<?php
$objeto_seriado='O:1:"a":1:{s:5:"valor";s:3:"100";}';

ini_set('unserialize_callback_func', 'mi_llamada_de_retorno'); // defina su callback_function

function mi_llamada_de_retorno($nombre_clase)
{
    // tan solo incluya un fichero que contenga su definición de clase
    // recibe $nombre_clase para determinar qué definición de clase requiere
}
?>

Notas

Advertencia

false es devuelto tanto en el caso de un error como cuando se convierte el valor seriado false. Es posible atrapar este caso especial comparando str con serialize(false) o atrapando el error E_NOTICE generado.

Ver también

  • json_encode() - Retorna la representación JSON del valor dado
  • json_decode() - Decodifica un string de JSON
  • hash_hmac() - Genera un valor cifrado mediante una clave especificada usando el método HMAC
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • Autocarga de clases
  • unserialize_callback_func
  • __wakeup()


Destruye una variable especificada

  • « unserialize
  • var_dump »
  • PHP Manual
  • Funciones de manejo de variables
  • Destruye una variable especificada

unset

(PHP 4, PHP 5, PHP 7, PHP 8)

unset — Destruye una variable especificada

Descripción

unset ( mixed $var , mixed $... = ? ) : void

unset() destruye las variables especificadas.

El comportamiento de unset() dentro de una función puede variar dependiendo de qué tipo de variable que se está tratando de destruir.

Si una variable global es unset() dentro de una función, solo la variable local es destruida. La variable en el entorno de la llamada mantendrá el mismo valor anterior a la llamada a unset().

<?php
function destruir_foo()
{
    global $foo;
    unset($foo);
}

$foo = 'bar';
destruir_foo();
echo $foo;
?>

El resultado del ejemplo sería:

bar

Si desea aplicar unset() a una variable global dentro de una función, puede usar la matriz $GLOBALS para hacerlo:

<?php
function foo()
{
    unset($GLOBALS['bar']);
}

$bar = "algo";
foo();
?>

Si una variable que se pasa POR REFERENCIA es unset() dentro de una función, sólo la variable local es destruida. La variable en el entorno de la llamada mantendrá el mismo valor anterior a la llamada a unset()

<?php
function foo(&$bar)
{
    unset($bar);
    $bar = "blah";
}

$bar = 'algo';
echo "$bar\n";

foo($bar);
echo "$bar\n";
?>

El resultado del ejemplo sería:

algo
algo

Si una variable estática es unset() dentro de una función, unset() destruye la variable únicamente en el contexto del resto de una función. Las llamadas siguientes recuperarán el valor previo de una variable.

<?php
function foo()
{
    static $bar;
    $bar++;
    echo "Antes de unset: $bar, ";
    unset($bar);
    $bar = 23;
    echo "Después de unset: $bar\n";
}

foo();
foo();
foo();
?>

El resultado del ejemplo sería:

Antes de unset: 1, después de unset: 23
Antes de unset: 2, después de unset: 23
Antes de unset: 3, después de unset: 23

Parámetros

var

La variable a ser destruida.

...

Otra variable...

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de unset()

<?php
// destruir una sola variable
unset($foo);

// destruir un solo elemento de una matriz
unset($bar['quux']);

// destruir más de una variable
unset($foo1, $foo2, $foo3);
?>

Ejemplo #2 Usando el forzado a (unset)

El forzado a (unset) a menudo se confunde con la función unset(). El forzado (unset) sólo sirve como una conversión de tipo NULL. Esto no altera la variable que se está forzando.

<?php
$name = 'Felipe';

var_dump((unset) $name);
var_dump($name);
?>

El resultado del ejemplo sería:

NULL
string(6) "Felipe"

Notas

Nota: Puesto que esto es una construcción del lenguaje y no una función, no puede ser llamada usando funciones variables.

Nota:

Es posible remover incluso propiedades de objetos visibles en el contexto actual.

Nota:

No es posible remover $this dentro de un método de objeto a partir de PHP 5.

Nota:

Cuando se utiliza unset() sobre las propiedades de objetos inaccesibles, el método de sobrecarga __unset() será llamado, si se declara.

Ver también

  • isset() - Determina si una variable está definida y no es null
  • empty() - Determina si una variable está vacía
  • __unset()
  • array_splice() - Elimina una porción del array y la reemplaza con otra cosa


Muestra información sobre una variable

  • « unset
  • var_export »
  • PHP Manual
  • Funciones de manejo de variables
  • Muestra información sobre una variable

var_dump

(PHP 4, PHP 5, PHP 7, PHP 8)

var_dump — Muestra información sobre una variable

Descripción

var_dump ( mixed $expression , mixed $... = ? ) : void

Esta función muestra información estructurada sobre una o más expresiones incluyendo su tipo y valor. Las matrices y los objetos son explorados recursivamente con valores sangrados para mostrar su estructura.

En PHP 5 todas las propiedades públicas, privadas y protegidas de los objetos serán devueltas en la salida.

Sugerencia

Como con todo lo que genera un resultado directamente en el navegador, se pueden utilizar las funciones de control de salida para capturar el resultado de esta función y guardarlo, por ejemplo, en un string.

Parámetros

expresion

La variable que desea vacíar la información.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo var_dump()

<?php
$a = array(1, 2, array("a", "b", "c"));
var_dump($a);
?>

El resultado del ejemplo sería:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  array(3) {
    [0]=>
    string(1) "a"
    [1]=>
    string(1) "b"
    [2]=>
    string(1) "c"
  }
}
<?php

$b = 3.1;
$c = true;
var_dump($b, $c);

?>

El resultado del ejemplo sería:

float(3.1)
bool(true)

Ver también

  • print_r() - Imprime información legible para humanos sobre una variable
  • debug_zval_dump() - Vuelca a la salida una cadena con la representación de un valor interno de zend
  • var_export() - Imprime o devuelve una representación string de una variable analizable


Imprime o devuelve una representación string de una variable analizable

  • « var_dump
  • Servicios web »
  • PHP Manual
  • Funciones de manejo de variables
  • Imprime o devuelve una representación string de una variable analizable

var_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

var_export — Imprime o devuelve una representación string de una variable analizable

Descripción

var_export ( mixed $expression , bool $return = false ) : mixed

var_export() obtiene información estructurada sobre la variable dada. Es similar a la función var_dump() con una excepción: la representación devuelta es código PHP válido.

Parámetros

expression

La variable que desea exportar.

return

Si es usada y se define como true, var_export() devolverá la representación de la variable en lugar de imprimirla.

Valores devueltos

Devuelve la representación de la variable cuando el parámetro return es utilizado y evaluado como true. En caso contrario, esta función devolverá null.

Notas

Nota:

Cuando el parámetro return se usa, esta función utiliza el almacenamiento en búfer de salida interno, por lo que no puede usarse dentro de una función de llamada de retorno ob_start().

Historial de cambios

Versión | Descripción
5.1.0 | Posibilidad de exportar las clases y los arrays que contienen las clases utilizando el método mágico __set_state.

Ejemplos

Ejemplo #1 Ejemplos de var_export()

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_export($a);
?>

El resultado del ejemplo sería:

array (
  0 => 1,
  1 => 2,
  2 =>
  array (
    0 => 'a',
    1 => 'b',
    2 => 'c',
  ),
)
<?php

$b = 3.1;
$v = var_export($b, true);
echo $v;

?>

El resultado del ejemplo sería:

3.1

Ejemplo #2 Exportación de clases a partir de PHP 5.1.0

<?php
class A { public $var; }
$a = new A;
$a->var = 5;
var_export($a);
?>

El resultado del ejemplo sería:

A::__set_state(array(
   'var' => 5,
))

Ejemplo #3 Uso de __set_state (a partir de PHP 5.1.0)

<?php
class A
{
    public $var1;
    public $var2;

    public static function __set_state($una_matriz)
    {
        $obj = new A;
        $obj->var1 = $una_matriz['var1'];
        $obj->var2 = $una_matriz['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);
?>

El resultado del ejemplo sería:

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

Notas

Nota:

Las variables de tipo resource no pueden ser exportadas por esta función.

Nota:

var_export() no maneja referencias circulares ya que sería prácticamente imposible generar código PHP interpretable en tal caso. Si desea trabajar con la representación completa de una matriz u objeto, use serialize().

Advertencia

Cuando var_export() exporta objectos, la barra diagonal no se incluye en el nombre de clases que pertencen a un namespace para mantener compatibilidad.

Ver también

  • print_r() - Imprime información legible para humanos sobre una variable
  • serialize() - Genera una representación apta para el almacenamiento de un valor
  • var_dump() - Muestra información sobre una variable


Servicios web

  • OAuth
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de OAuth
    • OAuth — La clase OAuth
    • OAuthProvider — Clase OAuthProvider
    • OAuthException — Clase OAuthException
  • SOAP
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de SOAP
    • SoapClient — La clase SoapClient
    • SoapServer — La clase SoapServer
    • SoapFault — La clase SoapFault
    • SoapHeader — La clase SoapHeader
    • SoapParam — La clase SoapParam
    • SoapVar — La clase SoapVar
  • Yar — Yet Another RPC Framework
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Yar_Server — La clase Yar_Server
    • Yar_Client — La clase Yar_Client
    • Yar_Concurrent_Client — La clase Yar_Concurrent_Client
    • Yar_Server_Exception — La clase Yar_Server_Exception
    • Yar_Client_Exception — La clase Yar_Client_Exception
  • XML-RPC
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Funciones de XML-RPC


OAuth

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • FireEagle
  • Funciones de OAuth
    • oauth_get_sbs — Genera una cadena de firma base
    • oauth_urlencode — Códifica una URI a RFC 3986
  • OAuth — La clase OAuth
    • OAuth::__construct — Crea un nuevo objeto OAuth
    • OAuth::__destruct — El destructor
    • OAuth::disableDebug — Desactiva la depuración detallada
    • OAuth::disableRedirects — Desactiva las redirecciones
    • OAuth::disableSSLChecks — Desactiva la verificación SSL
    • OAuth::enableDebug — Activa la depuración detallada
    • OAuth::enableRedirects — Activa las re-direcciones
    • OAuth::enableSSLChecks — Activa la verificación SSL
    • OAuth::fetch — Obtiene un recurso protegido por OAuth
    • OAuth::generateSignature — Generar una firma
    • OAuth::getAccessToken — Obtiene el token de acceso
    • OAuth::getCAPath — Obtiene la información CA
    • OAuth::getLastResponse — Obtiene la última respuesta
    • OAuth::getLastResponseHeaders — Obtener encabezados de la última respuesta
    • OAuth::getLastResponseInfo — Obtiene la información HTTP sobre la última respuesta
    • OAuth::getRequestHeader — Generar un string de firma de cabecera OAuth
    • OAuth::getRequestToken — Obtiene un token de petición
    • OAuth::setAuthType — Establece el tipo de autorización
    • OAuth::setCAPath — Establece la ruta a CA y su información
    • OAuth::setNonce — Configura el nonce para las solicitudes posteriores
    • OAuth::setRequestEngine — El propósito de setRequestEngine
    • OAuth::setRSACertificate — establece el certificado RSA
    • OAuth::setSSLChecks — Ajustar controles específicos de SSL para las solicitudes
    • OAuth::setTimestamp — Establece el timestamp
    • OAuth::setToken — Establece el token y el secreto
    • OAuth::setVersion — Configura la versión OAuth
  • OAuthProvider — Clase OAuthProvider
    • OAuthProvider::addRequiredParameter — Agregar parámetros necesarios
    • OAuthProvider::callconsumerHandler — Llama al callback consumerNonceHandler
    • OAuthProvider::callTimestampNonceHandler — Llama al callback timestampNonceHandler
    • OAuthProvider::calltokenHandler — Llama al callback tokenNonceHandler
    • OAuthProvider::checkOAuthRequest — Revisa una petición OAuth
    • OAuthProvider::__construct — Construye un nuevo objeto OAuthProvider
    • OAuthProvider::consumerHandler — Establece el manejador callback consumerHandler
    • OAuthProvider::generateToken — Genera un token aleatorio
    • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint — Establece isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter — Remueve un parámetro requerido
    • OAuthProvider::reportProblem — Reportar un problema
    • OAuthProvider::setParam — Establece un parámetro
    • OAuthProvider::setRequestTokenPath — Establece la ruta de petición del token
    • OAuthProvider::timestampNonceHandler — Establece el callback timestampNonceHandler
    • OAuthProvider::tokenHandler — Establece el manejador callback de tokenHandler
  • OAuthException — Clase OAuthException


Introducción

Esta extensión provee un cliente y un servicio OAuth. OAuth es un protocolo de autorización basado en HTTP el cual permite a las aplicaciones garantizar el acceso a datos sin tener alojado un nombre de usuario y contraseña.


Requerimientos

PECL/oauth requiere PHP 5.1 o superior, ext/hash y ext/pcre.

PECL/oauth puede requerir opcionalmente libcurl si se selecciona en el momento de compilación. Si se configura con libcurl, debe ser compilado con soporte HTTPS.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pear.php.net/package/oauth


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

La mayoría de estas constantes involucran problemas, los cuales son descritos en la documentación oficial de OAuth » Problem Reporting. Note sin embargo, que estos nombres de constantes son específicos para PHP, aunque el nombre sea similar.

OAUTH_SIG_METHOD_RSASHA1 (string)
Método de firma OAuth RSA-SHA1.
OAUTH_SIG_METHOD_HMACSHA1 (string)

Método de firma OAuth HMAC-SHA1.

OAUTH_SIG_METHOD_HMACSHA256 (string)
Método de firma OAuth HMAC-SHA256 signature method.
OAUTH_AUTH_TYPE_AUTHORIZATION (string)

Esta constante representa los parámetros OAuth en la cabecera de Authorization.

OAUTH_AUTH_TYPE_NONE (string)

Esta constante indica una petición NoAuth OAuth.

OAUTH_AUTH_TYPE_URI (string)

Esta constante representa los parámetros OAuth en la URI de petición.

OAUTH_AUTH_TYPE_FORM (string)

Esta constante representa los parámetros OAuth como una parte del cuerpo HTTP POST.

OAUTH_HTTP_METHOD_GET (string)

Usa el método GET para la petición OAuth.

OAUTH_HTTP_METHOD_POST (string)

Usa el método POST para la petición OAuth.

OAUTH_HTTP_METHOD_PUT (string)

Usa el método PUT para la petición OAuth.

OAUTH_HTTP_METHOD_HEAD (string)

Usa el método HEAD para la petición OAuth.

OAUTH_HTTP_METHOD_DELETE (string)
Usa el método DELETE para la petición OAuth.
OAUTH_REQENGINE_STREAMS (integer)
Utiliza el método OAuth::setRequestEngine() para definir el motor de PHP streams, en lugar de OAUTH_REQENGINE_CURL para Curl.
OAUTH_REQENGINE_CURL (integer)
Utiliza el método OAuth::setRequestEngine() para definir el motor de Curl, en lugar de OAUTH_REQENGINE_STREAMS para PHP streams.
OAUTH_OK (integer)
La vida es bella.
OAUTH_BAD_NONCE (integer)
El valor oauth_nonce que fue usado en una anterior petición, y no se puede utilizar ahora.
OAUTH_BAD_TIMESTAMP (integer)
El valor oauth_timestamp que no fue aceptado por el proveedor de servicio. En este caso, la respuesta deberá estar también contenida en el parámetro oauth_acceptable_timestamps.
OAUTH_CONSUMER_KEY_UNKNOWN (integer)
oauth_consumer_key es temporalmehte inaceptable para el proveedor de servicio. Por ejemplo, el proveedor de servicio se ha sobrecargado.
OAUTH_CONSUMER_KEY_REFUSED (integer)
La clave de cliente ha sido rechazada.
OAUTH_INVALID_SIGNATURE (integer)
La firma oauth_signature es inválida, no coincide la firma del cliente con la del proveedor.
OAUTH_TOKEN_USED (integer)
El oauth_token ha sido consumido. No se puede utilizar más debido a que ya había sido usada en la/s petición/peticiones anterior/es.
OAUTH_TOKEN_EXPIRED (integer)
El oauth_token ha expirado.
OAUTH_TOKEN_REVOKED (integer)
El oauth_token ha sido revocado, y no será aceptado nunca más.
OAUTH_TOKEN_REJECTED (integer)
El oauth_token no fue aceptado por el proveedor de servicio. La razón es desconocida, pero puede deberse a que el token nunca fue usado, ya había sido consumido, ya había expirado, y/o olvidado por el proveedor de servicio.
OAUTH_VERIFIER_INVALID (integer)
El oauth_verifier es incorrecto.
OAUTH_PARAMETER_ABSENT (integer)
Un parámetro no fue recibido. En ese caso, la respuesta debe también contener el parámetro oauth_parameters_absent.
OAUTH_SIGNATURE_METHOD_REJECTED (integer)
El método oauth_signature_method no fue aceptado por el proveedor de servicio.


  • « Constantes predefinidas
  • FireEagle »
  • PHP Manual
  • OAuth
  • Ejemplos

Ejemplos

Tabla de contenidos

  • FireEagle


FireEagle

<?php
$req_url = 'https://fireeagle.yahooapis.com/oauth/request_token';
$authurl = 'https://fireeagle.yahoo.net/oauth/authorize';
$acc_url = 'https://fireeagle.yahooapis.com/oauth/access_token';
$api_url = 'https://fireeagle.yahooapis.com/api/0.1';
$conskey = 'your_consumer_key';
$conssec = 'your_consumer_secret';

session_start();

// En state=1 la siguiente solicitud debe incluir un oauth_token.
// Si no vuelve a 0 (cero)
if(!isset($_GET['oauth_token']) && $_SESSION['state']==1) $_SESSION['state'] = 0;
try {
  $oauth = new OAuth($conskey,$conssec,OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_URI);
  $oauth->enableDebug();
  if(!isset($_GET['oauth_token']) && !$_SESSION['state']) {
    $request_token_info = $oauth->getRequestToken($req_url);
    $_SESSION['secret'] = $request_token_info['oauth_token_secret'];
    $_SESSION['state'] = 1;
    header('Location: '.$authurl.'?oauth_token='.$request_token_info['oauth_token']);
    exit;
  } else if($_SESSION['state']==1) {
    $oauth->setToken($_GET['oauth_token'],$_SESSION['secret']);
    $access_token_info = $oauth->getAccessToken($acc_url);
    $_SESSION['state'] = 2;
    $_SESSION['token'] = $access_token_info['oauth_token'];
    $_SESSION['secret'] = $access_token_info['oauth_token_secret'];
  }
  $oauth->setToken($_SESSION['token'],$_SESSION['secret']);
  $oauth->fetch("$api_url/user.json");
  $json = json_decode($oauth->getLastResponse());
  print_r($json);
} catch(OAuthException $E) {
  print_r($E);
}
?>


Funciones de OAuth

Tabla de contenidos

  • oauth_get_sbs — Genera una cadena de firma base
  • oauth_urlencode — Códifica una URI a RFC 3986


Genera una cadena de firma base

  • « Funciones de OAuth
  • oauth_urlencode »
  • PHP Manual
  • Funciones de OAuth
  • Genera una cadena de firma base

oauth_get_sbs

(PECL OAuth >=0.99.7)

oauth_get_sbs — Genera una cadena de firma base

Descripción

oauth_get_sbs ( string $http_method , string $uri , array $request_parameters = ? ) : string

Genera un string de firma base con PECL/OAuth.

Parámetros

http_method

El método HTTP.

uri

La URI a códificar.

request_parameters

Array de parámetros de petición.

Valores devueltos

Devuelve el string de firma base.


Códifica una URI a RFC 3986

  • « oauth_get_sbs
  • OAuth »
  • PHP Manual
  • Funciones de OAuth
  • Códifica una URI a RFC 3986

oauth_urlencode

(PECL OAuth >=0.99.2)

oauth_urlencode — Códifica una URI a RFC 3986

Descripción

oauth_urlencode ( string $uri ) : string

Códifica una URI a » RFC 3986.

Parámetros

uri

URI a codificar.

Valores devueltos

Returns an » RFC 3986 encoded string.


La clase OAuth

(PECL OAuth >= 0.99.1)

Introducción

La extensión OAuth provee una interfaz simple para interactuar con proveedores de datos usando la especificación HTTP OAuth para proteger los recursos privados.

Sinopsis de la Clase

OAuth {
/* Propiedades */
public $debug ;
public $sslChecks ;
public $debugInfo ;
/* Métodos */
public __construct ( string $consumer_key , string $consumer_secret , string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 , int $auth_type = 0 )
public __destruct ( ) : void
public disableDebug ( ) : bool
public disableRedirects ( ) : bool
public disableSSLChecks ( ) : bool
public enableDebug ( ) : bool
public enableRedirects ( ) : bool
public enableSSLChecks ( ) : bool
public fetch ( string $protected_resource_url , array $extra_parameters = ? , string $http_method = ? , array $http_headers = ? ) : mixed
public generateSignature ( string $http_method , string $url , mixed $extra_parameters = ? ) : string
public getAccessToken ( string $access_token_url , string $auth_session_handle = ? , string $verifier_token = ? , string $http_method = ? ) : array
public getCAPath ( ) : array
public getLastResponse ( ) : string
public getLastResponseHeaders ( ) : string
public getLastResponseInfo ( ) : array
public getRequestHeader ( string $http_method , string $url , mixed $extra_parameters = ? ) : string
public getRequestToken ( string $request_token_url , string $callback_url = ? , string $http_method = ? ) : array
public setAuthType ( int $auth_type ) : bool
public setCAPath ( string $ca_path = ? , string $ca_info = ? ) : mixed
public setNonce ( string $nonce ) : mixed
public setRequestEngine ( int $reqengine ) : void
public setRSACertificate ( string $cert ) : mixed
public setSSLChecks ( int $sslcheck ) : bool
public setTimestamp ( string $timestamp ) : mixed
public setToken ( string $token , string $token_secret ) : bool
public setVersion ( string $version ) : bool
}

Propiedades

debug

sslChecks

debugInfo

Tabla de contenidos

  • OAuth::__construct — Crea un nuevo objeto OAuth
  • OAuth::__destruct — El destructor
  • OAuth::disableDebug — Desactiva la depuración detallada
  • OAuth::disableRedirects — Desactiva las redirecciones
  • OAuth::disableSSLChecks — Desactiva la verificación SSL
  • OAuth::enableDebug — Activa la depuración detallada
  • OAuth::enableRedirects — Activa las re-direcciones
  • OAuth::enableSSLChecks — Activa la verificación SSL
  • OAuth::fetch — Obtiene un recurso protegido por OAuth
  • OAuth::generateSignature — Generar una firma
  • OAuth::getAccessToken — Obtiene el token de acceso
  • OAuth::getCAPath — Obtiene la información CA
  • OAuth::getLastResponse — Obtiene la última respuesta
  • OAuth::getLastResponseHeaders — Obtener encabezados de la última respuesta
  • OAuth::getLastResponseInfo — Obtiene la información HTTP sobre la última respuesta
  • OAuth::getRequestHeader — Generar un string de firma de cabecera OAuth
  • OAuth::getRequestToken — Obtiene un token de petición
  • OAuth::setAuthType — Establece el tipo de autorización
  • OAuth::setCAPath — Establece la ruta a CA y su información
  • OAuth::setNonce — Configura el nonce para las solicitudes posteriores
  • OAuth::setRequestEngine — El propósito de setRequestEngine
  • OAuth::setRSACertificate — establece el certificado RSA
  • OAuth::setSSLChecks — Ajustar controles específicos de SSL para las solicitudes
  • OAuth::setTimestamp — Establece el timestamp
  • OAuth::setToken — Establece el token y el secreto
  • OAuth::setVersion — Configura la versión OAuth


Crea un nuevo objeto OAuth

  • « OAuth
  • OAuth::__destruct »
  • PHP Manual
  • OAuth
  • Crea un nuevo objeto OAuth

OAuth::__construct

(PECL OAuth >= 0.99.1)

OAuth::__construct — Crea un nuevo objeto OAuth

Descripción

public OAuth::__construct ( string $consumer_key , string $consumer_secret , string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 , int $auth_type = 0 )

Crea un nuevo objeto OAuth

Parámetros

consumer_key

La clave de lectura proporcionada por el proveedor de servicios.

consumer_secret

El secreto de lectura proporcionada por el proveedor de servicios.

signature_method

Este parámetro es opcional define cual método usar, por omisión es OAUTH_SIG_METHOD_HMACSHA1 (HMAC-SHA1).

auth_type

Este parámetro es opcional define como pasar los parámetros OAuth al lector, por omisión es OAUTH_AUTH_TYPE_AUTHORIZATION (en la cabecerá Authorization).


El destructor

  • « OAuth::__construct
  • OAuth::disableDebug »
  • PHP Manual
  • OAuth
  • El destructor

OAuth::__destruct

(PECL OAuth >= 0.99.9)

OAuth::__destruct — El destructor

Descripción

public OAuth::__destruct ( ) : void

El destructor.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ver también

  • OAuth::__construct() - Crea un nuevo objeto OAuth


Desactiva la depuración detallada

  • « OAuth::__destruct
  • OAuth::disableRedirects »
  • PHP Manual
  • OAuth
  • Desactiva la depuración detallada

OAuth::disableDebug

(PECL OAuth >= 0.99.3)

OAuth::disableDebug — Desactiva la depuración detallada

Descripción

public OAuth::disableDebug ( ) : bool

Desactiva la solicitud de información detallada (desactivado por omisión). Alternativamente, la propiedad debug puede ser establecida al valor false para desactivar el depurador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Historial de cambios

Versión | Descripción
0.99.8 | La propiedad debug fue agregada.

Ver también

  • OAuth::enableDebug() - Activa la depuración detallada


Desactiva las redirecciones

  • « OAuth::disableDebug
  • OAuth::disableSSLChecks »
  • PHP Manual
  • OAuth
  • Desactiva las redirecciones

OAuth::disableRedirects

(PECL OAuth >= 0.99.9)

OAuth::disableRedirects — Desactiva las redirecciones

Descripción

public OAuth::disableRedirects ( ) : bool

Desactiva las redirecciones automáticas, permitiendo que la petición sea manualmente redirigida.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Ver también

  • OAuth::enableRedirects() - Activa las re-direcciones


Desactiva la verificación SSL

  • « OAuth::disableRedirects
  • OAuth::enableDebug »
  • PHP Manual
  • OAuth
  • Desactiva la verificación SSL

OAuth::disableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::disableSSLChecks — Desactiva la verificación SSL

Descripción

public OAuth::disableSSLChecks ( ) : bool

Desactiva la verificación del certificado y servidor SSL, esto no se recomiendo para entornos en producción. Alternativamente, el miembro sslChecks puede ser puesto false para desactivar la revisión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Historial de cambios

Versión | Descripción
0.99.8 | El miembro sslChecks fue agregado

Ver también

  • OAuth::enableSSLChecks() - Activa la verificación SSL


Activa la depuración detallada

  • « OAuth::disableSSLChecks
  • OAuth::enableRedirects »
  • PHP Manual
  • OAuth
  • Activa la depuración detallada

OAuth::enableDebug

(PECL OAuth >= 0.99.3)

OAuth::enableDebug — Activa la depuración detallada

Descripción

public OAuth::enableDebug ( ) : bool

Activa la solititud de información detallada útil para depurar, la información de depuración es almacenada en el miembro debugInfo. Alternativamente, el miembro debug puede ser establecido a un valor no-false para activar el depurador.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Historial de cambios

Versión | Descripción
0.99.8 | Los miembros debug y debugInfo fueron agregados.

Ver también

  • OAuth::disableDebug() - Desactiva la depuración detallada


Activa las re-direcciones

  • « OAuth::enableDebug
  • OAuth::enableSSLChecks »
  • PHP Manual
  • OAuth
  • Activa las re-direcciones

OAuth::enableRedirects

(PECL OAuth >= 0.99.9)

OAuth::enableRedirects — Activa las re-direcciones

Descripción

public OAuth::enableRedirects ( ) : bool

Sigue y firma las re-direcciones automáticamente, el cual está en activado por omisión.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Ver también

  • OAuth::disableRedirects() - Desactiva las redirecciones


Activa la verificación SSL

  • « OAuth::enableRedirects
  • OAuth::fetch »
  • PHP Manual
  • OAuth
  • Activa la verificación SSL

OAuth::enableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::enableSSLChecks — Activa la verificación SSL

Descripción

public OAuth::enableSSLChecks ( ) : bool

Activa la verificación del certificado y servidor SSL (activado por omisión). Alternativamente, el miembro sslChecks puede ser puesto a un valor distinto a false para desactivar la revisión.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true

Historial de cambios

Versión | Descripción
0.99.8 | El miembro sslChecks fue agregado

Ver también

  • OAuth::disableSSLChecks() - Desactiva la verificación SSL


Obtiene un recurso protegido por OAuth

  • « OAuth::enableSSLChecks
  • OAuth::generateSignature »
  • PHP Manual
  • OAuth
  • Obtiene un recurso protegido por OAuth

OAuth::fetch

(PECL OAuth >= 0.99.1)

OAuth::fetch — Obtiene un recurso protegido por OAuth

Descripción

public OAuth::fetch ( string $protected_resource_url , array $extra_parameters = ? , string $http_method = ? , array $http_headers = ? ) : mixed

Obtiene un recurso.

Parámetros

protected_resource_url

URL del recurso OAuth protegio.

extra_parameters

Parámetros adicionales para enviar con la petición del recurso.

http_method

Una de las OAUTH_HTTP_METHOD_* constantes OAUTH, which includes GET, POST, PUT, HEAD, or DELETE.

HEAD (OAUTH_HTTP_METHOD_HEAD) can be useful for discovering information prior to the request (if OAuth credentials are in the Authorization header).

http_headers

Encabezados cliente HTTP (como por ejemplo User-Agent, Accept, etc.)

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.
0.99.5 | El parámetro http_method fue agregado
0.99.8 | El parámetro http_headers fue agregado

Ejemplos

Ejemplo #1 Ejemplo de OAuth::fetch()

<?php
try {
    $oauth = new OAuth("consumer_key","consumer_secret",OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_AUTHORIZATION);
    $oauth->setToken("access_token","access_token_secret");

    $oauth->fetch("http://photos.example.net/photo?file=vacation.jpg");

    $response_info = $oauth->getLastResponseInfo();
    header("Content-Type: {$response_info["content_type"]}");
    echo $oauth->getLastResponse();
} catch(OAuthException $E) {
    echo "Excepción atrapada!\n";
    echo "Respuesta: ". $E->lastResponse . "\n";
}
?>

Ver también

  • OAuth::getLastResponse() - Obtiene la última respuesta
  • OAuth::getLastResponseInfo() - Obtiene la información HTTP sobre la última respuesta
  • OAuth::setToken() - Establece el token y el secreto


Generar una firma

  • « OAuth::fetch
  • OAuth::getAccessToken »
  • PHP Manual
  • OAuth
  • Generar una firma

OAuth::generateSignature

(No hay información de versión disponible, podría estar únicamente en Git)

OAuth::generateSignature — Generar una firma

Descripción

public OAuth::generateSignature ( string $http_method , string $url , mixed $extra_parameters = ? ) : string

Generar una firma basada en el método HTTP final, URL y un string/array de parámetros.

Parámetros

http_method

Método HTTP para la solicitud

url

URL de solicitud

extra_parameters

String o array de parámetros adicionales.

Valores devueltos

Un string que contiene la firma generada o false en caso de error


Obtiene el token de acceso

  • « OAuth::generateSignature
  • OAuth::getCAPath »
  • PHP Manual
  • OAuth
  • Obtiene el token de acceso

OAuth::getAccessToken

(PECL OAuth >= 0.99.1)

OAuth::getAccessToken — Obtiene el token de acceso

Descripción

public OAuth::getAccessToken ( string $access_token_url , string $auth_session_handle = ? , string $verifier_token = ? , string $http_method = ? ) : array

Obtiene un token de acceso, secreto y cualquier parámetro de respuesta adicional del proveedor de servicio.

Parámetros

access_token_url

URL al token de acceso de la API.

auth_session_handle

El manejador de autorización de sesión, este parámetro no existe en la especificación OAuth 1.0 pero puede ser implementada por muchos proveedores. » Visite ScalableOAuth para más información.

verifier_token

Para los proveedores de servicio que soportan 1.0a, Un parámetro verifier_token debe ser pasado mientras se solicita el token de acceso. Si el parámetro verifier_token está presente en $_GET o $_POST es pasado automáticamente y el solicitante ya no necesita especificar el verifier_token (usualmente el token de acceso es intercambiado en la URL del oauth_callback). » Visite ScalableOAuth para más información.

http_method

Método HTTP a usar, por ejemplo GET o POST.

Valores devueltos

Devuelve un array que contiene las respuestas OAuth analizadas al tener éxito o false al fallar.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.
0.99.9 | El parámetro verifier_token fue agregado

Ejemplos

Ejemplo #1 Ejemplo de OAuth::getAccessToken()

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $oauth->setToken($request_token,$request_token_secret);
    $access_token_info = $oauth->getAccessToken("https://example.com/oauth/access_token");
    if(!empty($access_token_info)) {
        print_r($access_token_info);
    } else {
        print "Falló obteniendo el token de acceso, la respuesta fue: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Respuesta: ". $E->lastResponse . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

Ver también

  • OAuth::getLastResponse() - Obtiene la última respuesta
  • OAuth::getLastResponseInfo() - Obtiene la información HTTP sobre la última respuesta
  • OAuth::setToken() - Establece el token y el secreto


Obtiene la información CA

  • « OAuth::getAccessToken
  • OAuth::getLastResponse »
  • PHP Manual
  • OAuth
  • Obtiene la información CA

OAuth::getCAPath

(PECL OAuth >= 0.99.8)

OAuth::getCAPath — Obtiene la información CA

Descripción

public OAuth::getCAPath ( ) : array

Obtiene la información del certificado de Autoridad, el cual incluye los ca_path y ca_info establecidos por OAuth::setCaPath().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array con información del Certificado de Autoridad, específicamente como claves ca_path y ca_info dentro del array asociativo devuelto.

Ver también

  • OAuth::setCAPath() - Establece la ruta a CA y su información
  • OAuth::getLastResponseInfo() - Obtiene la información HTTP sobre la última respuesta


Obtiene la última respuesta

  • « OAuth::getCAPath
  • OAuth::getLastResponseHeaders »
  • PHP Manual
  • OAuth
  • Obtiene la última respuesta

OAuth::getLastResponse

(PECL OAuth >= 0.99.1)

OAuth::getLastResponse — Obtiene la última respuesta

Descripción

public OAuth::getLastResponse ( ) : string

Obtiene la respuesta original de la más reciente petición.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve la cadena conteniendo la última respuesta.

Ver también

  • OAuth::getLastResponseInfo() - Obtiene la información HTTP sobre la última respuesta
  • OAuth::fetch() - Obtiene un recurso protegido por OAuth


Obtener encabezados de la última respuesta

  • « OAuth::getLastResponse
  • OAuth::getLastResponseInfo »
  • PHP Manual
  • OAuth
  • Obtener encabezados de la última respuesta

OAuth::getLastResponseHeaders

(No hay información de versión disponible, podría estar únicamente en Git)

OAuth::getLastResponseHeaders — Obtener encabezados de la última respuesta

Descripción

public OAuth::getLastResponseHeaders ( ) : string

Obtiene los encabezados de la última respuesta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un string que contiene los encabezados de la última respuesta o false en caso de error


Obtiene la información HTTP sobre la última respuesta

  • « OAuth::getLastResponseHeaders
  • OAuth::getRequestHeader »
  • PHP Manual
  • OAuth
  • Obtiene la información HTTP sobre la última respuesta

OAuth::getLastResponseInfo

(PECL OAuth >= 0.99.1)

OAuth::getLastResponseInfo — Obtiene la información HTTP sobre la última respuesta

Descripción

public OAuth::getLastResponseInfo ( ) : array

Obtiene la información HTTP sobre la última respuesta.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un array conteniendo la información de respuesta de la última petición. Constantes de curl_getinfo() pueden ser usadas.

Ver también

  • OAuth::fetch() - Obtiene un recurso protegido por OAuth
  • OAuth::getLastResponse() - Obtiene la última respuesta


Generar un string de firma de cabecera OAuth

  • « OAuth::getLastResponseInfo
  • OAuth::getRequestToken »
  • PHP Manual
  • OAuth
  • Generar un string de firma de cabecera OAuth

OAuth::getRequestHeader

(No hay información de versión disponible, podría estar únicamente en Git)

OAuth::getRequestHeader — Generar un string de firma de cabecera OAuth

Descripción

public OAuth::getRequestHeader ( string $http_method , string $url , mixed $extra_parameters = ? ) : string

Generar un string de firma de cabecera OAuth basada en el método HTTP final, el URL y los parámetros de string/array

Parámetros

http_method

Método HTTP para la petición.

url

URL para la petición.

extra_parameters

String o array de parámetros adicionales.

Valores devueltos

Un string que contiene la cabecera solicitada generada o false en caso de error


Obtiene un token de petición

  • « OAuth::getRequestHeader
  • OAuth::setAuthType »
  • PHP Manual
  • OAuth
  • Obtiene un token de petición

OAuth::getRequestToken

(PECL OAuth >= 0.99.1)

OAuth::getRequestToken — Obtiene un token de petición

Descripción

public OAuth::getRequestToken ( string $request_token_url , string $callback_url = ? , string $http_method = ? ) : array

Obtiene un token de petición, secreto y cualquier parámetro adicional de respuesta del proveedor de servicio.

Parámetros

request_token_url

URL al token de solicitud de la API.

callback_url

URL del callback OAuth. Si callback_url es pasado y es un valor vacío, este es puesto a "oob" para satisfacer las exigencias de OAuth 2009.1 advisory.

http_method

Método HTTP a usar, por ejemplo GET o POST.

Valores devueltos

Devuelve un array conteniendo las respuestas OAuth analizadas al tener éxitoo false al fallar.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.
0.99.9 | El parámetro callback_url fue agregado

Ejemplos

Ejemplo #1 Ejemplo de OAuth::getRequestToken()

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $request_token_info = $oauth->getRequestToken("https://example.com/oauth/request_token");
    if(!empty($request_token_info)) {
        print_r($request_token_info);
    } else {
        print "Falló obteniendo el token de petición, la respuesta fue: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Respuesta: ". $E->lastResponse . "\n";
}
?>

El resultado del ejemplo sería algo similar a:

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

Ver también

  • OAuth::getLastResponse() - Obtiene la última respuesta
  • OAuth::getLastResponseInfo() - Obtiene la información HTTP sobre la última respuesta


Establece el tipo de autorización

  • « OAuth::getRequestToken
  • OAuth::setCAPath »
  • PHP Manual
  • OAuth
  • Establece el tipo de autorización

OAuth::setAuthType

(PECL OAuth >= 0.99.1)

OAuth::setAuthType — Establece el tipo de autorización

Descripción

public OAuth::setAuthType ( int $auth_type ) : bool

Establece donde un parámetro OAuthdebería ser pasado.

Parámetros

auth_type

auth_type puede ser una de las siguientes banderas (in orden descendente de preferencia según OAuth 1.0 sección 5.2):

OAUTH_AUTH_TYPE_AUTHORIZATION
Pasa los parámetros OAuth en la cabecera de Authorization HTTP.
OAUTH_AUTH_TYPE_FORM
Anexa los parámetros OAuth al cuerpo de petición HTTP POST.
OAUTH_AUTH_TYPE_URI
Anexa los parámetros OAuth a la URI de petición.
OAUTH_AUTH_TYPE_NONE
Ninguno.

Valores devueltos

Devuelve true si el parámetro es correctamente establecido, de otra manera false (Ejemplo, si un inválido parámetro auth_type es pasado.)

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.


Establece la ruta a CA y su información

  • « OAuth::setAuthType
  • OAuth::setNonce »
  • PHP Manual
  • OAuth
  • Establece la ruta a CA y su información

OAuth::setCAPath

(PECL OAuth >= 0.99.8)

OAuth::setCAPath — Establece la ruta a CA y su información

Descripción

public OAuth::setCAPath ( string $ca_path = ? , string $ca_info = ? ) : mixed

Establece el Certificado de Autoridad (CA), tanto la ruta como la información.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

ca_path

La ruta CA a ser establecida.

ca_info

La ruta de información CA a ser establecido.

Valores devueltos

Devuelve true al tener éxitos, o false si tanto ca_path o ca_info son considerados como inválidos.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.

Ver también

  • OAuth::getCaPath() - Obtiene la información CA


Configura el nonce para las solicitudes posteriores

  • « OAuth::setCAPath
  • OAuth::setRequestEngine »
  • PHP Manual
  • OAuth
  • Configura el nonce para las solicitudes posteriores

OAuth::setNonce

(PECL OAuth >= 0.99.1)

OAuth::setNonce — Configura el nonce para las solicitudes posteriores

Descripción

public OAuth::setNonce ( string $nonce ) : mixed

Establece el nonce para todas las solicitudes posteriores.

Parámetros

nonce

El valor para oauth_nonce.

Valores devueltos

Devuelve true si tiene éxito, o false si nonce es considerado como inválido.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.

Ver también

  • OAuth::setToken() - Establece el token y el secreto
  • OAuth::setAuthType() - Establece el tipo de autorización
  • OAuth::setVersion() - Configura la versión OAuth


El propósito de setRequestEngine

  • « OAuth::setNonce
  • OAuth::setRSACertificate »
  • PHP Manual
  • OAuth
  • El propósito de setRequestEngine

OAuth::setRequestEngine

(PECL OAuth >= 1.0.0)

OAuth::setRequestEngine — El propósito de setRequestEngine

Descripción

public OAuth::setRequestEngine ( int $reqengine ) : void

Establece el motor de peticiones, que estará enviando las peticiones HTTP.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

reqengine

El motor de peticiones deseado. Poner a OAUTH_REQENGINE_STREAMS para usar el Stream PHP, o OAUTH_REQENGINE_CURL para usar Curl.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Emite una excepción OAuthException si un motor de peticiones inválido es escogido.

Ejemplos

Ejemplo #1 Ejemplo de OAuth::setRequestEngine()

<?php
$consumer = new OAuth();

$consumer->setRequestEngine(OAUTH_REQENGINE_STREAMS);
?>

Ver también

  • Curl
  • PHP streams
  • OAuthException


establece el certificado RSA

  • « OAuth::setRequestEngine
  • OAuth::setSSLChecks »
  • PHP Manual
  • OAuth
  • establece el certificado RSA

OAuth::setRSACertificate

(PECL OAuth >= 1.0.0)

OAuth::setRSACertificate — establece el certificado RSA

Descripción

public OAuth::setRSACertificate ( string $cert ) : mixed

Establece el certificado RSA.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

cert

El certificado RSA.

Valores devueltos

Devuelve true si tiene éxito, o false al fallar (Ejemplo, el certificado RSA no se pudo procesar.)

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.

Ejemplos

Ejemplo #1 Ejemplo de OAuth::setRsaCertificate()

<?php
$consume = new OAuth('1234', '', OAUTH_SIG_METHOD_RSASHA1);

$consume->setRSACertificate(file_get_contents('test.pem'));
?>

Ver también

  • OAuth::setCaPath() - Establece la ruta a CA y su información


Ajustar controles específicos de SSL para las solicitudes

  • « OAuth::setRSACertificate
  • OAuth::setTimestamp »
  • PHP Manual
  • OAuth
  • Ajustar controles específicos de SSL para las solicitudes

OAuth::setSSLChecks

(No hay información de versión disponible, podría estar únicamente en Git)

OAuth::setSSLChecks — Ajustar controles específicos de SSL para las solicitudes

Descripción

public OAuth::setSSLChecks ( int $sslcheck ) : bool

Ajusta controles específicos de SSL para las solicitudes.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

sslcheck

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece el timestamp

  • « OAuth::setSSLChecks
  • OAuth::setToken »
  • PHP Manual
  • OAuth
  • Establece el timestamp

OAuth::setTimestamp

(PECL OAuth >= 1.0.0)

OAuth::setTimestamp — Establece el timestamp

Descripción

public OAuth::setTimestamp ( string $timestamp ) : mixed

Establece el timestamp de OAuth para las subsecuentes peticiones.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

timestamp

El timestamp.

Valores devueltos

Devuelve true, a menos que timestamp sea inválido, en cuyo caso false será devuelto.

Historial de cambios

Versión | Descripción
1.0.0 | Antes devolvía null en caso de falla, en lugar de false.

Ver también

  • OAuth::setNonce() - Configura el nonce para las solicitudes posteriores


Establece el token y el secreto

  • « OAuth::setTimestamp
  • OAuth::setVersion »
  • PHP Manual
  • OAuth
  • Establece el token y el secreto

OAuth::setToken

(PECL OAuth >= 0.99.1)

OAuth::setToken — Establece el token y el secreto

Descripción

public OAuth::setToken ( string $token , string $token_secret ) : bool

Establece el token y el secreto para las subsecuentes peticiones.

Parámetros

token

El token OAuth.

token_secret

El secreto OAuth.

Valores devueltos

true

Ejemplos

Ejemplo #1 Ejemplo OAuth::setToken()

<?php
$oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
$oauth->setToken("token","token-secret");
?>


Configura la versión OAuth

  • « OAuth::setToken
  • OAuthProvider »
  • PHP Manual
  • OAuth
  • Configura la versión OAuth

OAuth::setVersion

(PECL OAuth >= 0.99.1)

OAuth::setVersion — Configura la versión OAuth

Descripción

public OAuth::setVersion ( string $version ) : bool

Establece la versión OAuth para las subsecuentes peticiones

Parámetros

version

Versión OAuth, el valor por omisión es siempre "1.0"

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Clase OAuthProvider

(PECL OAuth >= 1.0.0)

Introducción

Administra una clase OAuthProvider.

Vea también el tutorial externo llamado » Escribiendo un proveedor de servicios OAuth, Que tiene un enfoque práctico a la prestación de este servicio. También hay » Ejemplos de proveedor OAuth en la fuente de la extensión Oauth.

Sinopsis de la Clase

OAuthProvider {
/* Methods */
final public addRequiredParameter ( string $req_params ) : bool
public callconsumerHandler ( ) : void
public callTimestampNonceHandler ( ) : void
public calltokenHandler ( ) : void
public checkOAuthRequest ( string $uri = ? , string $method = ? ) : void
public __construct ( array $params_array = ? )
public consumerHandler ( callable $callback_function ) : void
final public static generateToken ( int $size , bool $strong = false ) : string
public is2LeggedEndpoint ( mixed $params_array ) : void
public isRequestTokenEndpoint ( bool $will_issue_request_token ) : void
final public removeRequiredParameter ( string $req_params ) : bool
final public static reportProblem ( string $oauthexception , bool $send_headers = true ) : string
final public setParam ( string $param_key , mixed $param_val = ? ) : bool
final public setRequestTokenPath ( string $path ) : bool
public timestampNonceHandler ( callable $callback_function ) : void
public tokenHandler ( callable $callback_function ) : void
}

Tabla de contenidos

  • OAuthProvider::addRequiredParameter — Agregar parámetros necesarios
  • OAuthProvider::callconsumerHandler — Llama al callback consumerNonceHandler
  • OAuthProvider::callTimestampNonceHandler — Llama al callback timestampNonceHandler
  • OAuthProvider::calltokenHandler — Llama al callback tokenNonceHandler
  • OAuthProvider::checkOAuthRequest — Revisa una petición OAuth
  • OAuthProvider::__construct — Construye un nuevo objeto OAuthProvider
  • OAuthProvider::consumerHandler — Establece el manejador callback consumerHandler
  • OAuthProvider::generateToken — Genera un token aleatorio
  • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
  • OAuthProvider::isRequestTokenEndpoint — Establece isRequestTokenEndpoint
  • OAuthProvider::removeRequiredParameter — Remueve un parámetro requerido
  • OAuthProvider::reportProblem — Reportar un problema
  • OAuthProvider::setParam — Establece un parámetro
  • OAuthProvider::setRequestTokenPath — Establece la ruta de petición del token
  • OAuthProvider::timestampNonceHandler — Establece el callback timestampNonceHandler
  • OAuthProvider::tokenHandler — Establece el manejador callback de tokenHandler


Agregar parámetros necesarios

  • « OAuthProvider
  • OAuthProvider::callconsumerHandler »
  • PHP Manual
  • OAuthProvider
  • Agregar parámetros necesarios

OAuthProvider::addRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::addRequiredParameter — Agregar parámetros necesarios

Descripción

final public OAuthProvider::addRequiredParameter ( string $req_params ) : bool

Agregar parámetros requeridos por el proveedor OAuth.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

req_params

Los parámetros requeridos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OAuthProvider::removeRequiredParameter() - Remueve un parámetro requerido


Llama al callback consumerNonceHandler

  • « OAuthProvider::addRequiredParameter
  • OAuthProvider::callTimestampNonceHandler »
  • PHP Manual
  • OAuthProvider
  • Llama al callback consumerNonceHandler

OAuthProvider::callconsumerHandler

(No hay información de versión disponible, podría estar únicamente en Git)

OAuthProvider::callconsumerHandler — Llama al callback consumerNonceHandler

Descripción

public OAuthProvider::callconsumerHandler ( ) : void

Llama al callback del manejador del consumidor registrado, la cual es establecida con OAuthProvider::consumerHandler().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Muestra un error E_ERROR level si la llamada de retorno no puede ser llamada, o no se especificó.

Ver también

  • OAuthProvider::consumerHandler() - Establece el manejador callback consumerHandler


Llama al callback timestampNonceHandler

  • « OAuthProvider::callconsumerHandler
  • OAuthProvider::calltokenHandler »
  • PHP Manual
  • OAuthProvider
  • Llama al callback timestampNonceHandler

OAuthProvider::callTimestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::callTimestampNonceHandler — Llama al callback timestampNonceHandler

Descripción

public OAuthProvider::callTimestampNonceHandler ( ) : void

Llama a la función callback del timestamp registrado, que fue establecido con OAuthProvider::timestampNonceHandler().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Muestra un error E_ERROR level si la llamada de retorno no puede ser llamada, o no se especificó.

Ver también

  • OAuthProvider::timestampNonceHandler() - Establece el callback timestampNonceHandler


Llama al callback tokenNonceHandler

  • « OAuthProvider::callTimestampNonceHandler
  • OAuthProvider::checkOAuthRequest »
  • PHP Manual
  • OAuthProvider
  • Llama al callback tokenNonceHandler

OAuthProvider::calltokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::calltokenHandler — Llama al callback tokenNonceHandler

Descripción

public OAuthProvider::calltokenHandler ( ) : void

Llama a la función callback del token registrado, que fue establecido con OAuthProvider::tokenHandler().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Muestra un error E_ERROR level si la llamada de retorno no puede ser llamada, o no se especificó.

Ver también

  • OAuthProvider::tokenHandler() - Establece el manejador callback de tokenHandler


Revisa una petición OAuth

  • « OAuthProvider::calltokenHandler
  • OAuthProvider::__construct »
  • PHP Manual
  • OAuthProvider
  • Revisa una petición OAuth

OAuthProvider::checkOAuthRequest

(PECL OAuth >= 1.0.0)

OAuthProvider::checkOAuthRequest — Revisa una petición OAuth

Descripción

public OAuthProvider::checkOAuthRequest ( string $uri = ? , string $method = ? ) : void

Revisa una petición OAuth.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

uri

La URI opcional, o punto final.

method

El métodoHTTP. opcionalmente pasar una de las OAUTH_HTTP_METHOD_* Constantes OAuth.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

Emite un error E_ERROR si el método HTTP no puede ser detectado.

Ver también

  • OAuthProvider::reportProblem() - Reportar un problema


Construye un nuevo objeto OAuthProvider

  • « OAuthProvider::checkOAuthRequest
  • OAuthProvider::consumerHandler »
  • PHP Manual
  • OAuthProvider
  • Construye un nuevo objeto OAuthProvider

OAuthProvider::__construct

(PECL OAuth >= 1.0.0)

OAuthProvider::__construct — Construye un nuevo objeto OAuthProvider

Descripción

public OAuthProvider::__construct ( array $params_array = ? )

Inicia un nuevo object OAuthProvider .

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

params_array

La configuración de estos parámetros opcionales se limita al CLI SAPI.

Valores devueltos

Un object OAuthProvider .

Ejemplos

Ejemplo #1 Ejemplo de OAuthProvider::__construct()

<?php
try {

    $op = new OAuthProvider();

    // Usa funciones callback definidas por el usuario
    $op->consumerHandler(array($this, 'lookupConsumer'));
    $op->timestampNonceHandler(array($this, 'timestampNonceChecker'));
    $op->tokenHandler(array($this, 'myTokenHandler'));

    // Ignora el parámetro foo_uri
    $op->setParam('foo_uri', NULL);

    // No es necesario el token para este punto final
    $op->setRequestTokenPath('/v1/oauth/request_token');

    $op->checkOAuthRequest();

} catch (OAuthException $e) {

    echo OAuthProvider::reportProblem($e);
}
?>

Ver también

  • OAuthProvider::setParam() - Establece un parámetro


Establece el manejador callback consumerHandler

  • « OAuthProvider::__construct
  • OAuthProvider::generateToken »
  • PHP Manual
  • OAuthProvider
  • Establece el manejador callback consumerHandler

OAuthProvider::consumerHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::consumerHandler — Establece el manejador callback consumerHandler

Descripción

public OAuthProvider::consumerHandler ( callable $callback_function ) : void

Establece el manejador callback, que más tarde será llamado con OAuthProvider::callConsumerHandler().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

callback_function

El nombre de la función callable.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo del callback OAuthProvider::consumerHandler()

<?php
function lookupConsumer($provider) {

    if ($provider->consumer_key === 'unknown') {
        return OAUTH_CONSUMER_KEY_UNKNOWN;
    } else if($provider->consumer_key == 'blacklisted' || $provider->consumer_key === 'throttled') {
        return OAUTH_CONSUMER_KEY_REFUSED;
    }

    $provider->consumer_secret = "the_consumers_secret";

    return OAUTH_OK;
}
?>

Ver también

  • OAuthProvider::callConsumerHandler() - Llama al callback consumerNonceHandler


Genera un token aleatorio

  • « OAuthProvider::consumerHandler
  • OAuthProvider::is2LeggedEndpoint »
  • PHP Manual
  • OAuthProvider
  • Genera un token aleatorio

OAuthProvider::generateToken

(PECL OAuth >= 1.0.0)

OAuthProvider::generateToken — Genera un token aleatorio

Descripción

final public static OAuthProvider::generateToken ( int $size , bool $strong = false ) : string

Genera una string de bytes pseudo-aleatorios.

Parámetros

size

La longitud The desired token length, in terms of bytes.

strong

Establecer a true significa que /dev/random será usada para la entropía, de lo contrario /dev/urandom será usado. Este parámetro es ignorado en Windows.

Valores devueltos

El token generado, como un string de bytes.

Errores/Excepciones

Si el parámetro strong es true, entonces un error E_WARNING será emitido cuando la implementación rand() sea usada para rellenar los restantes bytes aleatorios (Ejemplo, cuando no suficientes datos aleatorios fueron encontrados, inicialmente).

Ejemplos

Ejemplo #1 Ejemplo de OAuthProvider::generateToken()

<?php
$p = new OAuthProvider();

$t = $p->generateToken(4);

echo strlen($t),  PHP_EOL;
echo bin2hex($t), PHP_EOL;

?>

El resultado del ejemplo sería algo similar a:

4
b6a82c27

Notas

Nota:

Cuando no suficientes datos aleatorios están disponibles para el sistema, esta función llenará los restantes bytes aleatorios usando la implementación interna de PHP rand().

Ver también

  • openssl_random_pseudo_bytes() - Genera una cadena de bytes pseudo-aleatoria
  • mcrypt_create_iv() - Crea un vector de inicialización (IV) desde una fuente aleatoria


is2LeggedEndpoint

  • « OAuthProvider::generateToken
  • OAuthProvider::isRequestTokenEndpoint »
  • PHP Manual
  • OAuthProvider
  • is2LeggedEndpoint

OAuthProvider::is2LeggedEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint

Descripción

public OAuthProvider::is2LeggedEndpoint ( mixed $params_array ) : void

El flujo de 2-piernas, o la suscripción de petición. No requiere token.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

params_array

Valores devueltos

An OAuthProvider object.

Ejemplos

Ejemplo #1 Ejemplo de OAuthProvider::is2LeggedEndpoint()

<?php

$provider = new OAuthProvider();

$provider->is2LeggedEndpoint(true);

?>

Ver también

  • OAuthProvider::__construct() - Construye un nuevo objeto OAuthProvider


Establece isRequestTokenEndpoint

  • « OAuthProvider::is2LeggedEndpoint
  • OAuthProvider::removeRequiredParameter »
  • PHP Manual
  • OAuthProvider
  • Establece isRequestTokenEndpoint

OAuthProvider::isRequestTokenEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::isRequestTokenEndpoint — Establece isRequestTokenEndpoint

Descripción

public OAuthProvider::isRequestTokenEndpoint ( bool $will_issue_request_token ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

will_issue_request_token

Establece si emitirá o no una emisión de petición de token, determinando si OAuthProvider::tokenHandler() necesita ser llamado.

Valores devueltos

No devuelve ningún valor.

Ver también

  • OAuthProvider::setRequestTokenPath() - Establece la ruta de petición del token
  • OAuthProvider::reportProblem() - Reportar un problema


Remueve un parámetro requerido

  • « OAuthProvider::isRequestTokenEndpoint
  • OAuthProvider::reportProblem »
  • PHP Manual
  • OAuthProvider
  • Remueve un parámetro requerido

OAuthProvider::removeRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::removeRequiredParameter — Remueve un parámetro requerido

Descripción

final public OAuthProvider::removeRequiredParameter ( string $req_params ) : bool

Remueve un parámetro requerido.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

req_params

El parámetro requerido a ser removido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OAuthProvider::setParam() - Establece un parámetro
  • OAuthProvider::addRequiredParameter() - Agregar parámetros necesarios


Reportar un problema

  • « OAuthProvider::removeRequiredParameter
  • OAuthProvider::setParam »
  • PHP Manual
  • OAuthProvider
  • Reportar un problema

OAuthProvider::reportProblem

(PECL OAuth >= 1.0.0)

OAuthProvider::reportProblem — Reportar un problema

Descripción

final public static OAuthProvider::reportProblem ( string $oauthexception , bool $send_headers = true ) : string

Sucede en un problema como OAuthException, con posibles problemas listados en la sección OAuth constants.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

oauthexception

La OAuthException.

Valores devueltos

No devuelve ningún valor.

Ver también

  • OAuthProvider::checkOAuthRequest() - Revisa una petición OAuth
  • OAuthProvider::isRequestTokenEndpoint() - Establece isRequestTokenEndpoint


Establece un parámetro

  • « OAuthProvider::reportProblem
  • OAuthProvider::setRequestTokenPath »
  • PHP Manual
  • OAuthProvider
  • Establece un parámetro

OAuthProvider::setParam

(PECL OAuth >= 1.0.0)

OAuthProvider::setParam — Establece un parámetro

Descripción

final public OAuthProvider::setParam ( string $param_key , mixed $param_val = ? ) : bool

Establece un parámetro.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

param_key

La clave del parámetro.

param_val

El valor opcional del parámetro.

Para excluir un parámetro de la verificación de firmas, colocar este valor a null.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • OAuthProvider::addRequiredParameter() - Agregar parámetros necesarios


Establece la ruta de petición del token

  • « OAuthProvider::setParam
  • OAuthProvider::timestampNonceHandler »
  • PHP Manual
  • OAuthProvider
  • Establece la ruta de petición del token

OAuthProvider::setRequestTokenPath

(PECL OAuth >= 1.0.0)

OAuthProvider::setRequestTokenPath — Establece la ruta de petición del token

Descripción

final public OAuthProvider::setRequestTokenPath ( string $path ) : bool

Establece la ruta de petición del token.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

path

La ruta.

Valores devueltos

true

Ver también

  • OAuthProvider::tokenHandler() - Establece el manejador callback de tokenHandler


Establece el callback timestampNonceHandler

  • « OAuthProvider::setRequestTokenPath
  • OAuthProvider::tokenHandler »
  • PHP Manual
  • OAuthProvider
  • Establece el callback timestampNonceHandler

OAuthProvider::timestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::timestampNonceHandler — Establece el callback timestampNonceHandler

Descripción

public OAuthProvider::timestampNonceHandler ( callable $callback_function ) : void

Establece el manejador callback timestamp nonce, el cual será llamado luego con OAuthProvider::callTimestampNonceHandler(). Errores relacionados con timestamp/nonce son lanzados a este callback.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

callback_function

El nombre de la función callable.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de OAuthProvider::timestampNonceHandler()

<?php
function timestampNonceChecker($provider) {

    if ($provider->nonce === 'bad') {
        return OAUTH_BAD_NONCE;
    } elseif ($provider->timestamp == '0') {
        return OAUTH_BAD_TIMESTAMP;
    }

    return OAUTH_OK;
}
?>

Ver también

  • OAuthProvider::callTimestampNonceHandler() - Llama al callback timestampNonceHandler


Establece el manejador callback de tokenHandler

  • « OAuthProvider::timestampNonceHandler
  • OAuthException »
  • PHP Manual
  • OAuthProvider
  • Establece el manejador callback de tokenHandler

OAuthProvider::tokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::tokenHandler — Establece el manejador callback de tokenHandler

Descripción

public OAuthProvider::tokenHandler ( callable $callback_function ) : void

Establece el token del callback, que será llamado después con OAuthProvider::callTokenHandler().

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

callback_function

El nombre de la función callable.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo del callback OAuthProvider::tokenHandler()

<?php
function tokenHandler($provider) {

    if ($provider->token === 'rejected') {
        return OAUTH_TOKEN_REJECTED;
    } elseif ($provider->token === 'revoked') {
        return OAUTH_TOKEN_REVOKED;
    }

    $provider->token_secret = "the_tokens_secret";
    return OAUTH_OK;
}
?>

Ver también

  • OAuthProvider::callTokenHandler() - Llama al callback tokenNonceHandler


Clase OAuthException

(PECL OAuth >= 0.99.1)

Introducción

Esta excepción es lanzada cuando un error excepcional durante el uso de la extensión OAuth y contiene información útil de depuración.

Sinopsis de la Clase

OAuthException extends Exception {
/* Propiedades */
public $lastResponse ;
public $debugInfo ;
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

lastResponse

La respuesta de la excepción ocurrida, si la hubiera

debugInfo


SOAP

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de SOAP
    • is_soap_fault — Comprueba si una llamada SOAP ha fallado
    • use_soap_error_handler — Establecer si se desea utilizar el manejador de errores de SOAP
  • SoapClient — La clase SoapClient
    • SoapClient::__call — Llama a una función de SOAP (obsoleto)
    • SoapClient::__construct — Constructor de SoapClient
    • SoapClient::__doRequest — Realiza una petición SOAP
    • SoapClient::__getCookies — Get list of cookies
    • SoapClient::__getFunctions — Devuelve una lista de todas las funciones SOAP disponibles
    • SoapClient::__getLastRequest — Devuelve la última petición SOAP
    • SoapClient::__getLastRequestHeaders — Devuelve los encabezados SOAP de la última petición
    • SoapClient::__getLastResponse — Devuelve la última respuesta SOAP
    • SoapClient::__getLastResponseHeaders — Devuelve los encabezados SOAP de la última respuesta
    • SoapClient::__getTypes — Devuelve una lista de los tipos SOAP
    • SoapClient::__setCookie — El propósito de __setCookie
    • SoapClient::__setLocation — Define la localización del servicio Web a utilizar
    • SoapClient::__setSoapHeaders — Define los encabezados SOAP para las subsiguentes llamadas
    • SoapClient::__soapCall — Llama a una función SOAP
  • SoapServer — La clase SoapServer
    • SoapServer::addFunction — Añade una o más funciones al controlador de peticiones SOAP
    • SoapServer::addSoapHeader — Añade un encabezado SOAP a la respuesta
    • SoapServer::__construct — Constructor de SoapServer
    • SoapServer::fault — SoapServer indica que ocurrió un fallo
    • SoapServer::getFunctions — Devuelve una lista de las funciones definidas
    • SoapServer::handle — Controla la petición SOAP
    • SoapServer::setClass — Define la clase que controla las peticiones SOAP
    • SoapServer::setObject — Define el objecto que será usado para controlar las peticiones SOAP
    • SoapServer::setPersistence — Establece el modo de persistencia de SoapServer
  • SoapFault — La clase SoapFault
    • SoapFault::__construct — Constructor de SoapFault
    • SoapFault::__toString — Obtiene una representación en formato cadena de SoapFault
  • SoapHeader — La clase SoapHeader
    • SoapHeader::__construct — Constructor de SoapHeader
  • SoapParam — La clase SoapParam
    • SoapParam::__construct — Constructor de SoapParam
  • SoapVar — La clase SoapVar
    • SoapVar::__construct — Constructor de SoapVar


Introducción

La extensión SOAP se puede utilizar para escribir servidores y clientes SOAP. Admite los subconjuntos de especificaciones » SOAP 1.1, » SOAP 1.2 y » WSDL 1.1.


Requerimientos

Esta extensión requiere la extensión libxml de PHP. Esto significa que también es necesario pasar la opción --enable-libxml, aunque esto se realiza implícitamente debido a que libxml está habilitada de forma predeterminada.


  • « Requerimientos
  • Configuración en tiempo de ejecución »
  • PHP Manual
  • Instalación/Configuración
  • Instalación

Instalación

Para habilitar el soporte de SOAP, se ha de configurar PHP con --enable-soap.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de SOAP
Nombre | Por defecto | Cambiable | Historial de cambios
soap.wsdl_cache_enabled | 1 | PHP_INI_ALL |
soap.wsdl_cache_dir | /tmp | PHP_INI_ALL |
soap.wsdl_cache_ttl | 86400 | PHP_INI_ALL |
soap.wsdl_cache | 1 | PHP_INI_ALL |
soap.wsdl_cache_limit | 5 | PHP_INI_ALL |

He aquí una breve explicación de las directivas de configuración.

soap.wsdl_cache_enabled integer

Activa o desactiva la función de almacenamiento en caché de WSDL.

soap.wsdl_cache_dir string

Define el nombre del directorio donde la extensión SOAP guardará los ficheros en caché.

soap.wsdl_cache_ttl integer

Define el número de segundos (tiempo de vida) por los que los ficheros en caché serán usados en lugar de los originales.

soap.wsdl_cache integer

Si la opción soap.wsdl_cache_enabled está activada, este ajuste determina el tipo de almacenamiento en caché. Puede ser cualquiera de estos tipos: WSDL_CACHE_NONE (0), WSDL_CACHE_DISK (1), WSDL_CACHE_MEMORY (2) o WSDL_CACHE_BOTH (3). También puede definirse usando el array options del constructor de SoapClient o de SoapServer.

soap.wsdl_cache_limit integer

Número máximo de ficheros WSDL almacenados en caché de memoria. Si se añaden más ficheros a una caché de memoria llena, se eliminarán los ficheros más antiguos de la misma.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

SOAP constants
Constant | Value | Description
SOAP_1_1 (integer) | 1 |
SOAP_1_2 (integer) | 2 |
SOAP_PERSISTENCE_SESSION (integer) | 1 |
SOAP_PERSISTENCE_REQUEST (integer) | 2 |
SOAP_FUNCTIONS_ALL (integer) | 999 |
SOAP_ENCODED (integer) | 1 |
SOAP_LITERAL (integer) | 2 |
SOAP_RPC (integer) | 1 |
SOAP_DOCUMENT (integer) | 2 |
SOAP_ACTOR_NEXT (integer) | 1 |
SOAP_ACTOR_NONE (integer) | 2 |
SOAP_ACTOR_UNLIMATERECEIVER (integer) | 3 |
SOAP_COMPRESSION_ACCEPT (integer) | 32 |
SOAP_COMPRESSION_GZIP (integer) | 0 |
SOAP_COMPRESSION_DEFLATE (integer) | 16 |
SOAP_AUTHENTICATION_BASIC (integer) | 0 |
SOAP_AUTHENTICATION_DIGEST (integer) | 1 |
SOAP_SSL_METHOD_TLS (integer) | 0 | Desde PHP 5.5.0.
SOAP_SSL_METHOD_SSLv2 (integer) | 1 | Desde PHP 5.5.0.
SOAP_SSL_METHOD_SSLv3 (integer) | 2 | Desde PHP 5.5.0.
SOAP_SSL_METHOD_SSLv23 (integer) | 3 | Desde PHP 5.5.0.
UNKNOWN_TYPE (integer) | 999998 |
XSD_STRING (integer) | 101 |
XSD_BOOLEAN (integer) | 102 |
XSD_DECIMAL (integer) | 103 |
XSD_FLOAT (integer) | 104 |
XSD_DOUBLE (integer) | 105 |
XSD_DURATION (integer) | 106 |
XSD_DATETIME (integer) | 107 |
XSD_TIME (integer) | 108 |
XSD_DATE (integer) | 109 |
XSD_GYEARMONTH (integer) | 110 |
XSD_GYEAR (integer) | 111 |
XSD_GMONTHDAY (integer) | 112 |
XSD_GDAY (integer) | 113 |
XSD_GMONTH (integer) | 114 |
XSD_HEXBINARY (integer) | 115 |
XSD_BASE64BINARY (integer) | 116 |
XSD_ANYURI (integer) | 117 |
XSD_QNAME (integer) | 118 |
XSD_NOTATION (integer) | 119 |
XSD_NORMALIZEDSTRING (integer) | 120 |
XSD_TOKEN (integer) | 121 |
XSD_LANGUAGE (integer) | 122 |
XSD_NMTOKEN (integer) | 123 |
XSD_NAME (integer) | 124 |
XSD_NCNAME (integer) | 125 |
XSD_ID (integer) | 126 |
XSD_IDREF (integer) | 127 |
XSD_IDREFS (integer) | 128 |
XSD_ENTITY (integer) | 129 |
XSD_ENTITIES (integer) | 130 |
XSD_INTEGER (integer) | 131 |
XSD_NONPOSITIVEINTEGER (integer) | 132 |
XSD_NEGATIVEINTEGER (integer) | 133 |
XSD_LONG (integer) | 134 |
XSD_INT (integer) | 135 |
XSD_SHORT (integer) | 136 |
XSD_BYTE (integer) | 137 |
XSD_NONNEGATIVEINTEGER (integer) | 138 |
XSD_UNSIGNEDLONG (integer) | 139 |
XSD_UNSIGNEDINT (integer) | 140 |
XSD_UNSIGNEDSHORT (integer) | 141 |
XSD_UNSIGNEDBYTE (integer) | 142 |
XSD_POSITIVEINTEGER (integer) | 143 |
XSD_NMTOKENS (integer) | 144 |
XSD_ANYTYPE (integer) | 145 |
XSD_ANYXML (integer) | 147 |
APACHE_MAP (integer) | 200 |
SOAP_ENC_OBJECT (integer) | 301 |
SOAP_ENC_ARRAY (integer) | 300 |
XSD_1999_TIMEINSTANT (integer) | 401 |
XSD_NAMESPACE (integer) | http://www.w3.org/2001/XMLSchema |
XSD_1999_NAMESPACE (integer) | http://www.w3.org/1999/XMLSchema |
SOAP_SINGLE_ELEMENT_ARRAYS (integer) | 1 |
SOAP_WAIT_ONE_WAY_CALLS (integer) | 2 |
SOAP_USE_XSI_ARRAY_TYPE (integer) | 4 |
WSDL_CACHE_NONE (integer) | 0 |
WSDL_CACHE_DISK (integer) | 1 |
WSDL_CACHE_MEMORY (integer) | 2 |
WSDL_CACHE_BOTH (integer) | 3 |


Funciones de SOAP

Tabla de contenidos

  • is_soap_fault — Comprueba si una llamada SOAP ha fallado
  • use_soap_error_handler — Establecer si se desea utilizar el manejador de errores de SOAP


Comprueba si una llamada SOAP ha fallado

  • « Funciones de SOAP
  • use_soap_error_handler »
  • PHP Manual
  • Funciones de SOAP
  • Comprueba si una llamada SOAP ha fallado

is_soap_fault

(PHP 5, PHP 7, PHP 8)

is_soap_fault — Comprueba si una llamada SOAP ha fallado

Descripción

is_soap_fault ( mixed $object ) : bool

Esta función es útil para comprobar si la llamada SOAP ha fallado, pero sin usar excepciones. Para usarse, cree el objecto SoapClient con la opción exceptions definida a cero o false. En este caso, el método SOAP devolverá un objecto especial SoapFault el qual encapsula los datos del fallo (faultcode, faultstring, faultactor and faultdetails).

Si exceptions no está definido la llamada SOAP lanzará una excepción al producirse un error. is_soap_fault() comprueba si un parametro dado es un objecto SoapFault.

Parámetros

object

El objecto a comprobar.

Valores devueltos

Devolverá true si se produce un error y false en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de is_soap_fault()

<?php
$client = new SoapClient("some.wsdl", array('exceptions' => 0));
$result = $client->SomeFunction();
if (is_soap_fault($result)) {
    trigger_error("SOAP Fault: (faultcode: {$result->faultcode}, faultstring: {$result->faultstring})", E_USER_ERROR);
}
?>

Ejemplo #2 El método estándar de SOAP para el informe de errores con las excepciones

<?php
try {
    $client = new SoapClient("some.wsdl");
    $result = $client->SomeFunction(/* ... */);
} catch (SoapFault $fault) {
    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}
?>

Ver también

  • SoapClient::SoapClient()
  • SoapFault::SoapFault()


Establecer si se desea utilizar el manejador de errores de SOAP

  • « is_soap_fault
  • SoapClient »
  • PHP Manual
  • Funciones de SOAP
  • Establecer si se desea utilizar el manejador de errores de SOAP

use_soap_error_handler

(PHP 5, PHP 7, PHP 8)

use_soap_error_handler — Establecer si se desea utilizar el manejador de errores de SOAP

Descripción

use_soap_error_handler ( bool $handler = true ) : bool

Esta función establece si utilizar o no el manejador de errores de SOAP en el servidor de SOAP. Devolverá el valor anterior. Si está definido a true, los datos de los errores en una aplicación SoapServer serán enviados a los clientes como un mensaje de fallo SOAP. Si es false, el manejador de errores PHP será usado. Lo predeterminado es enviar el error al cliente como un mensaje de fallo de SOAP.

Parámetros

handler

Establecerlo a true para enviar información de los errores al cliente.

Valores devueltos

Devuelve el valor original

Ver también

  • set_error_handler() - Establecer una función de gestión de errores definida por el usuario
  • set_exception_handler() - Establece una función de gestión de excepciones definida por el usuario


La clase SoapClient

(PHP 5, PHP 7, PHP 8)

Introducción

La clase SoapClient proporciona un cliente para servidores » SOAP 1.1, » SOAP 1.2. Puede ser usada en modo WSDL o modo no-WSDL.

Sinopsis de la Clase

SoapClient {
/* Métodos */
public __call ( string $function_name , array $arguments ) : mixed
public __construct ( mixed $wsdl , array $options = ? )
public __doRequest ( string $request , string $location , string $action , int $version , int $one_way = 0 ) : string
public __getCookies ( ) : array
public __getFunctions ( ) : array
public __getLastRequest ( ) : string
public __getLastRequestHeaders ( ) : string
public __getLastResponse ( ) : string
public __getLastResponseHeaders ( ) : string
public __getTypes ( ) : array
public __setCookie ( string $name , string $value = ? ) : void
public __setLocation ( string $new_location = ? ) : string
public __setSoapHeaders ( mixed $soapheaders = ? ) : bool
public __soapCall ( string $function_name , array $arguments , array $options = ? , mixed $input_headers = ? , array &$output_headers = ? ) : mixed
}

Tabla de contenidos

  • SoapClient::__call — Llama a una función de SOAP (obsoleto)
  • SoapClient::__construct — Constructor de SoapClient
  • SoapClient::__doRequest — Realiza una petición SOAP
  • SoapClient::__getCookies — Get list of cookies
  • SoapClient::__getFunctions — Devuelve una lista de todas las funciones SOAP disponibles
  • SoapClient::__getLastRequest — Devuelve la última petición SOAP
  • SoapClient::__getLastRequestHeaders — Devuelve los encabezados SOAP de la última petición
  • SoapClient::__getLastResponse — Devuelve la última respuesta SOAP
  • SoapClient::__getLastResponseHeaders — Devuelve los encabezados SOAP de la última respuesta
  • SoapClient::__getTypes — Devuelve una lista de los tipos SOAP
  • SoapClient::__setCookie — El propósito de __setCookie
  • SoapClient::__setLocation — Define la localización del servicio Web a utilizar
  • SoapClient::__setSoapHeaders — Define los encabezados SOAP para las subsiguentes llamadas
  • SoapClient::__soapCall — Llama a una función SOAP


Llama a una función de SOAP (obsoleto)

  • « SoapClient
  • SoapClient::__construct »
  • PHP Manual
  • SoapClient
  • Llama a una función de SOAP (obsoleto)

SoapClient::__call

(PHP 5, PHP 7, PHP 8)

SoapClient::__call — Llama a una función de SOAP (obsoleto)

Descripción

public SoapClient::__call ( string $function_name , array $arguments ) : mixed

Llamar a este método directamente está obsoleto. Normalmente, las funciones de SOAP pueden ser invocadas como métodos del objeto SoapClient; en situaciones donde esto no es posible o son necesarias opciones adicionales, use SoapClient::__soapCall().


Constructor de SoapClient

  • « SoapClient::__call
  • SoapClient::__doRequest »
  • PHP Manual
  • SoapClient
  • Constructor de SoapClient

SoapClient::__construct

(PHP 5, PHP 7, PHP 8)

SoapClient::__construct — Constructor de SoapClient

Descripción

public SoapClient::__construct ( mixed $wsdl , array $options = ? )

Esta función es un alias de: SoapClient::SoapClient()


Realiza una petición SOAP

  • « SoapClient::__construct
  • SoapClient::__getCookies »
  • PHP Manual
  • SoapClient
  • Realiza una petición SOAP

SoapClient::__doRequest

(PHP 5, PHP 7, PHP 8)

SoapClient::__doRequest — Realiza una petición SOAP

Descripción

public SoapClient::__doRequest ( string $request , string $location , string $action , int $version , int $one_way = 0 ) : string

Realiza una petición SOAP vía HTTP.

Este método puede ser sobreescrito en subclases para implementar diferentes capas de transporte, realizar procesos XML adiciones u otros propósitos.

Parámetros

request

La petición XML SOAP.

location

La URL donde realizar la petición.

action

La acción SOAP.

version

La versión de SOAP.

one_way

Si one_way está defindo a 1, este método no devolverá nada. Use esta opción cuando no se espera una respuesta.

Valores devueltos

La respuesta XML SOAP response.

Historial de cambios

Versión | Descripción
5.1.3 | Se añadió el parámetro one_way.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__doRequest()

<?php
function Add($x,$y) {
  return $x+$y;
}

class LocalSoapClient extends SoapClient {

  function __construct($wsdl, $options) {
    parent::__construct($wsdl, $options);
    $this->server = new SoapServer($wsdl, $options);
    $this->server->addFunction('Add');
  }

  function __doRequest($request, $location, $action, $version, $one_way = 0) {
    ob_start();
    $this->server->handle($request);
    $response = ob_get_contents();
    ob_end_clean();
    return $response;
  }

}

$x = new LocalSoapClient(NULL,array('location'=>'test://',
                                   'uri'=>'http://testuri.org'));
var_dump($x->Add(3,4));
?>


Get list of cookies

  • « SoapClient::__doRequest
  • SoapClient::__getFunctions »
  • PHP Manual
  • SoapClient
  • Get list of cookies

SoapClient::__getCookies

(PHP 5 >= 5.4.30, PHP 7, PHP 8)

SoapClient::__getCookies — Get list of cookies

Descripción

public SoapClient::__getCookies ( ) : array

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Devuelve una lista de todas las funciones SOAP disponibles

  • « SoapClient::__getCookies
  • SoapClient::__getLastRequest »
  • PHP Manual
  • SoapClient
  • Devuelve una lista de todas las funciones SOAP disponibles

SoapClient::__getFunctions

(PHP 5, PHP 7, PHP 8)

SoapClient::__getFunctions — Devuelve una lista de todas las funciones SOAP disponibles

Descripción

public SoapClient::__getFunctions ( ) : array

Devuelve un array de las funciones descritas en el WSDL del servicio web.

Nota:

Esta función funciona sólo en modo WSDL.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El array de las funciones prototipo de SOAP, que detallan el tipo retornado, el nombre de la función y los parámetros y sus tipos.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getFunctions()

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getFunctions());
?>

El resultado del ejemplo sería:

array(26) {
  [0]=>
  string(70) "ProductInfo KeywordSearchRequest(KeywordRequest $KeywordSearchRequest)"
  [1]=>
  string(79) "ProductInfo TextStreamSearchRequest(TextStreamRequest $TextStreamSearchRequest)"
  [2]=>
  string(64) "ProductInfo PowerSearchRequest(PowerRequest $PowerSearchRequest)"
...
  [23]=>
  string(107) "ShoppingCart RemoveShoppingCartItemsRequest(RemoveShoppingCartItemsRequest $RemoveShoppingCartItemsRequest)"
  [24]=>
  string(107) "ShoppingCart ModifyShoppingCartItemsRequest(ModifyShoppingCartItemsRequest $ModifyShoppingCartItemsRequest)"
  [25]=>
  string(118) "GetTransactionDetailsResponse GetTransactionDetailsRequest(GetTransactionDetailsRequest $GetTransactionDetailsRequest)"
}

Ver también

  • SoapClient::SoapClient()


Devuelve la última petición SOAP

  • « SoapClient::__getFunctions
  • SoapClient::__getLastRequestHeaders »
  • PHP Manual
  • SoapClient
  • Devuelve la última petición SOAP

SoapClient::__getLastRequest

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastRequest — Devuelve la última petición SOAP

Descripción

public SoapClient::__getLastRequest ( ) : string

Devuelve el XML enviado en la última petición SOAP.

Nota:

Este método solo funciona si el objecto SoapClient fue creado con la opción trace establecida a true.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La última petición SOAP, como cadena XML.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getLastRequest()

<?php
$client = new SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST:\n" . $client->__getLastRequest() . "\n";
?>

Ver también

  • SoapClient::__getLastRequestHeaders() - Devuelve los encabezados SOAP de la última petición
  • SoapClient::__getLastResponse() - Devuelve la última respuesta SOAP
  • SoapClient::__getLastResponseHeaders() - Devuelve los encabezados SOAP de la última respuesta


Devuelve los encabezados SOAP de la última petición

  • « SoapClient::__getLastRequest
  • SoapClient::__getLastResponse »
  • PHP Manual
  • SoapClient
  • Devuelve los encabezados SOAP de la última petición

SoapClient::__getLastRequestHeaders

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastRequestHeaders — Devuelve los encabezados SOAP de la última petición

Descripción

public SoapClient::__getLastRequestHeaders ( ) : string

Devuelve los encabezados SOAP de la última petición.

Nota:

Esta función solo funciona si el objecto SoapClient fue creado con la opción trace establecida como true.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La última petición de los encabezados SOAP.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getLastRequestHeaders()

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST HEADERS:\n" . $client->__getLastRequestHeaders() . "\n";
?>

Ver también

  • SoapClient::__getLastResponseHeaders() - Devuelve los encabezados SOAP de la última respuesta
  • SoapClient::__getLastRequest() - Devuelve la última petición SOAP
  • SoapClient::__getLastResponse() - Devuelve la última respuesta SOAP


Devuelve la última respuesta SOAP

  • « SoapClient::__getLastRequestHeaders
  • SoapClient::__getLastResponseHeaders »
  • PHP Manual
  • SoapClient
  • Devuelve la última respuesta SOAP

SoapClient::__getLastResponse

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastResponse — Devuelve la última respuesta SOAP

Descripción

public SoapClient::__getLastResponse ( ) : string

Devuelve el XML recibido en la última respuesta SOAP.

Nota:

Esta función solo funciona si el objecto SoapClient fue creado con la opción trace establecida como true.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La última respuesta SOAP, como cadena XML.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getLastResponse()

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "Response:\n" . $client->__getLastResponse() . "\n";
?>

Ver también

  • SoapClient::__getLastResponseHeaders() - Devuelve los encabezados SOAP de la última respuesta
  • SoapClient::__getLastRequest() - Devuelve la última petición SOAP
  • SoapClient::__getLastRequestHeaders() - Devuelve los encabezados SOAP de la última petición


Devuelve los encabezados SOAP de la última respuesta

  • « SoapClient::__getLastResponse
  • SoapClient::__getTypes »
  • PHP Manual
  • SoapClient
  • Devuelve los encabezados SOAP de la última respuesta

SoapClient::__getLastResponseHeaders

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastResponseHeaders — Devuelve los encabezados SOAP de la última respuesta

Descripción

public SoapClient::__getLastResponseHeaders ( ) : string

Devuelve los encabezados SOAP de la última respuesta

Nota:

Esta función solo funciona si el objecto SoapClient fue creado con la opción trace establecida como true.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La última respuesta de los encabezados SOAP.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getLastResponse()

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "RESPONSE HEADERS:\n" . $client->__getLastResponseHeaders() . "\n";
?>

Ver también

  • SoapClient::__getLastRequestHeaders() - Devuelve los encabezados SOAP de la última petición
  • SoapClient::__getLastRequest() - Devuelve la última petición SOAP
  • SoapClient::__getLastResponse() - Devuelve la última respuesta SOAP


Devuelve una lista de los tipos SOAP

  • « SoapClient::__getLastResponseHeaders
  • SoapClient::__setCookie »
  • PHP Manual
  • SoapClient
  • Devuelve una lista de los tipos SOAP

SoapClient::__getTypes

(PHP 5, PHP 7, PHP 8)

SoapClient::__getTypes — Devuelve una lista de los tipos SOAP

Descripción

public SoapClient::__getTypes ( ) : array

Devuelve un array de los tipos descritos en el WSDL para el servicio web.

Nota:

Esta función funciona sólo en modo WSDL.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de los tipos SOAP, detallando todas las estructuras y los tipos.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__getTypes()

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getTypes());
?>

El resultado del ejemplo sería:

array(88) {
  [0]=>
  string(30) "ProductLine ProductLineArray[]"
  [1]=>
  string(85) "struct ProductLine {
 string Mode;
 string RelevanceRank;
 ProductInfo ProductInfo;
}"
  [2]=>
  string(105) "struct ProductInfo {
 string TotalResults;
 string TotalPages;
 string ListName;
 DetailsArray Details;
}"
...
  [85]=>
  string(32) "ShortSummary ShortSummaryArray[]"
  [86]=>
  string(121) "struct GetTransactionDetailsRequest {
 string tag;
 string devtag;
 string key;
 OrderIdArray OrderIds;
 string locale;
}"
  [87]=>
  string(75) "struct GetTransactionDetailsResponse {
 ShortSummaryArray ShortSummaries;
}"
}

Ver también

  • SoapClient::SoapClient()


El propósito de __setCookie

  • « SoapClient::__getTypes
  • SoapClient::__setLocation »
  • PHP Manual
  • SoapClient
  • El propósito de __setCookie

SoapClient::__setCookie

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

SoapClient::__setCookie — El propósito de __setCookie

Descripción

public SoapClient::__setCookie ( string $name , string $value = ? ) : void

Define una cookie a ser enviada conjunto con la peticiones SOAP.

Nota:

Al llamar este método afectará a todas las siguentes llamadas a los métodos SoapClient.

Parámetros

name

El nombre de la cookie.

value

El valor de la cookie. Si no se especifica, la cookie será eliminada.

Valores devueltos

No devuelve ningún valor.


Define la localización del servicio Web a utilizar

  • « SoapClient::__setCookie
  • SoapClient::__setSoapHeaders »
  • PHP Manual
  • SoapClient
  • Define la localización del servicio Web a utilizar

SoapClient::__setLocation

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

SoapClient::__setLocation — Define la localización del servicio Web a utilizar

Descripción

public SoapClient::__setLocation ( string $new_location = ? ) : string

Define la URL de conexión que será usada por las siguientes peticiones SOAP. Esto es equivalente a especificar la opción location cuando se construye el SoapClient.

Nota:

Llamar este método es opcional. El SoapClient utiliza la URL de conexión desde el fichero WSDL por defecto.

Parámetros

new_location

La nueva URL de conexión.

Valores devueltos

La anterior URL de conexión.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__setLocation()

<?php
$client = new SoapClient('http://example.com/webservice.php?wsdl');

$client->__setLocation('http://www.somethirdparty.com');

$old_location = $client->__setLocation(); // Desactiva la opción location

echo $old_location;

?>

El resultado del ejemplo sería algo similar a:

http://www.somethirdparty.com

Ver también

  • SoapClient::SoapClient()


Define los encabezados SOAP para las subsiguentes llamadas

  • « SoapClient::__setLocation
  • SoapClient::__soapCall »
  • PHP Manual
  • SoapClient
  • Define los encabezados SOAP para las subsiguentes llamadas

SoapClient::__setSoapHeaders

(PHP 5 >= 5.0.5, PHP 7, PHP 8)

SoapClient::__setSoapHeaders — Define los encabezados SOAP para las subsiguentes llamadas

Descripción

public SoapClient::__setSoapHeaders ( mixed $soapheaders = ? ) : bool

Define los encabezados a enviar en las peticiones SOAP.

Nota:

Llamar este método reemplazará cualquier valor previo.

Parámetros

soapheaders

Encabezados a definir. Puede ser un objecto SoapHeader o un array de objectos SoapHeader. Si no se especifica o se define a null, los encabezados serán eliminados.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__setSoapHeaders()

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$header = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hola mundo');

$client->__setSoapHeaders($header);

$client->__soapCall("echoVoid", null);
?>

Ejemplo #2 Definir múltiples encabezados

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$headers = array();

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hola mundo');

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hola mundo otra vez');

$client->__setSoapHeaders($headers);

$client->__soapCall("echoVoid", null);
?>


Llama a una función SOAP

  • « SoapClient::__setSoapHeaders
  • SoapServer »
  • PHP Manual
  • SoapClient
  • Llama a una función SOAP

SoapClient::__soapCall

(PHP 5, PHP 7, PHP 8)

SoapClient::__soapCall — Llama a una función SOAP

Descripción

public SoapClient::__soapCall ( string $function_name , array $arguments , array $options = ? , mixed $input_headers = ? , array &$output_headers = ? ) : mixed

Esta es una función de bajo nivel del API que se utiliza para hacer llamadas SOAP. Usualmente, en modo WSDL, las funciones soap pueden llamarse como métodos del objecto SoapClient. Este método es útil en módo no-WSDL cuando no se conoce la soapaction, la uri es diferente de la por defecto o cuando se envian y/o reciben encabezados SOAP.

Cuando se produce un error, llamar a una función SOAP puede causar a PHP lanzar una excepción o revolver el objecto SoapFault si las excepciones están desactivadas. Para comprobar si la llamada a la función falló capturar las excepciones SoapFault, comprobar el resultado con is_soap_fault().

Parámetros

function_name

Nombre de la función SOAP a llamar.

arguments

Un array de argumentos a pasar a la función. Puede ser bien un array ordenado o asociativo. Tenga en cuenta que la mayoría de los servidores SOAP requieren que los nombres de parámetros sean proveídos, en cuyo caso ha de ser un array asociativo.

options

Un array asociativo de opciones a pasar al cliente.

La opción location es la URL del servicio Web remoto.

La opción uri es el destino del espacio de nombres del servicio SOAP.

La opción soapaction es la acción a llamar.

input_headers

Un array de encabezados a ser enviados con la petición SOAP.

output_headers

Si se proporciona, este array se llenará con los encabezados de la respuesta SOAP.

Valores devueltos

Las funciones SOAP quizá devuelven uno, o múltiples valores. Si solo un valor es devuelto por la función SOAP, el valor retornado de __soapCall será un valor siemple (p.e.j. un integer, un string, etc). Si múltiples valores son retornados, __soapCall devolverá un array asociativo de los nombrados parámetros de salida.

En caso de error, si el objecto SoapClient fue construido con la opción exceptions establecida a false, devolverá un objeto SoapFault.

Ejemplos

Ejemplo #1 Ejemplo de SoapClient::__soapCall()

<?php

$client = new SoapClient("some.wsdl");
$client->SomeFunction($a, $b, $c);

$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c), NULL,
                    new SoapHeader(), $output_headers);

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->SomeFunction($a, $b, $c);
$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c),
                    array('soapaction' => 'some_action',
                          'uri'        => 'some_uri'));
?>

Ver también

  • SoapClient::SoapClient()
  • SoapParam::SoapParam()
  • SoapVar::SoapVar()
  • SoapHeader::SoapHeader()
  • SoapFault::SoapFault()
  • is_soap_fault() - Comprueba si una llamada SOAP ha fallado


La clase SoapServer

(PHP 5, PHP 7, PHP 8)

Introducción

La clase SoapServer proporciona un servidor para los protocolos » SOAP 1.1 y » SOAP 1.2. Se puede usar con o sin servicio de descripción WSDL.

Sinopsis de la Clase

SoapServer {
/* Métodos */
public addFunction ( mixed $functions ) : void
public addSoapHeader ( SoapHeader $object ) : void
public __construct ( mixed $wsdl , array $options = ? )
public fault ( string $code , string $string , string $actor = ? , string $details = ? , string $name = ? ) : void
public getFunctions ( ) : array
public handle ( string $soap_request = ? ) : void
public setClass ( string $class_name , mixed $... = ? ) : void
public setObject ( object $object ) : void
public setPersistence ( int $mode ) : void
}

Tabla de contenidos

  • SoapServer::addFunction — Añade una o más funciones al controlador de peticiones SOAP
  • SoapServer::addSoapHeader — Añade un encabezado SOAP a la respuesta
  • SoapServer::__construct — Constructor de SoapServer
  • SoapServer::fault — SoapServer indica que ocurrió un fallo
  • SoapServer::getFunctions — Devuelve una lista de las funciones definidas
  • SoapServer::handle — Controla la petición SOAP
  • SoapServer::setClass — Define la clase que controla las peticiones SOAP
  • SoapServer::setObject — Define el objecto que será usado para controlar las peticiones SOAP
  • SoapServer::setPersistence — Establece el modo de persistencia de SoapServer


Añade una o más funciones al controlador de peticiones SOAP

  • « SoapServer
  • SoapServer::addSoapHeader »
  • PHP Manual
  • SoapServer
  • Añade una o más funciones al controlador de peticiones SOAP

SoapServer::addFunction

(PHP 5, PHP 7, PHP 8)

SoapServer::addFunction — Añade una o más funciones al controlador de peticiones SOAP

Descripción

public SoapServer::addFunction ( mixed $functions ) : void

Exporta una o más funciones para clientes remotos

Parámetros

functions

Para exportar una función, pasa el nombre de la función en su parámetro como cadena.

Para exportar varias funciones, pasa un array con el nombre de las funciones.

Para exportar todas las funciones, pasa la constante especial SOAP_FUNCTIONS_ALL.

Nota:

Las functions deben recibir todos los argumentos de entrada en el mismo orden que fueron definidos en el fichero WSDL (no deberían recibir ningún parámetro de salida como argumento) y devolver uno o más valores. Para devolver varios valores deben devolver un array con los nombrados parámetros de salida.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplos de SoapServer::addFunction()

<?php

function echoString($inputString)
{
    return $inputString;
}

$server->addFunction("echoString");

function echoTwoStrings($inputString1, $inputString2)
{
    return array("outputString1" => $inputString1,
                 "outputString2" => $inputString2);
}
$server->addFunction(array("echoString", "echoTwoStrings"));

$server->addFunction(SOAP_FUNCTIONS_ALL);

?>

Ver también

  • SoapServer::SoapServer()
  • SoapServer::setClass() - Define la clase que controla las peticiones SOAP


Añade un encabezado SOAP a la respuesta

  • « SoapServer::addFunction
  • SoapServer::__construct »
  • PHP Manual
  • SoapServer
  • Añade un encabezado SOAP a la respuesta

SoapServer::addSoapHeader

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SoapServer::addSoapHeader — Añade un encabezado SOAP a la respuesta

Descripción

public SoapServer::addSoapHeader ( SoapHeader $object ) : void

Añade un encabezado SOAP a ser devuelto en la respuesta de la petición actual.

Parámetros

object

El encabezado a ser devuelto.

Valores devueltos

No devuelve ningún valor.


Constructor de SoapServer

  • « SoapServer::addSoapHeader
  • SoapServer::fault »
  • PHP Manual
  • SoapServer
  • Constructor de SoapServer

SoapServer::__construct

(PHP 5, PHP 7, PHP 8)

SoapServer::__construct — Constructor de SoapServer

Descripción

public SoapServer::__construct ( mixed $wsdl , array $options = ? )

Esta función es un alias de: SoapServer::SoapServer()


SoapServer indica que ocurrió un fallo

  • « SoapServer::__construct
  • SoapServer::getFunctions »
  • PHP Manual
  • SoapServer
  • SoapServer indica que ocurrió un fallo

SoapServer::fault

(PHP 5, PHP 7, PHP 8)

SoapServer::fault — SoapServer indica que ocurrió un fallo

Descripción

public SoapServer::fault ( string $code , string $string , string $actor = ? , string $details = ? , string $name = ? ) : void

Envía una respuesta al cliente de la petición actual indicando que ocurrió un error.

Nota:

Solo puede ser llamado cuando se está procesando la petición.

Parámetros

code

El código de error a devolver

string

Una breve descripción del fallo

actor

Una cadena identificando el actor qeu causó el fallo.

details

Más información acerca del fallo

name

Nombre del fallo. Puede ser usado para selecionar un nombre desde el fichero WSDL.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SoapFault::SoapFault()


Devuelve una lista de las funciones definidas

  • « SoapServer::fault
  • SoapServer::handle »
  • PHP Manual
  • SoapServer
  • Devuelve una lista de las funciones definidas

SoapServer::getFunctions

(PHP 5, PHP 7, PHP 8)

SoapServer::getFunctions — Devuelve una lista de las funciones definidas

Descripción

public SoapServer::getFunctions ( ) : array

Devuelve una lista de las funciones definidas en el objecto SoapServer. Este método devuelve la lista de todas las funciones añadidas por SoapServer::addFunction() o SoapServer::setClass().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Un array de las funciones definidas.

Ejemplos

Ejemplo #1 Ejemplo de SoapServer::getFunctions()

<?php
$server = new SoapServer(NULL, array("uri" => "http://test-uri"));
$server->addFunction(SOAP_FUNCTIONS_ALL);
if ($_SERVER["REQUEST_METHOD"] == "POST") {
  $server->handle();
} else {
  echo "Este servidor SOAP puede manejar las siguientes funciones: ";
  $functions = $server->getFunctions();
  foreach($functions as $func) {
    echo $func . "\n";
  }
}
?>

Ver también

  • SoapServer::SoapServer()
  • SoapServer::addFunction() - Añade una o más funciones al controlador de peticiones SOAP
  • SoapServer::setClass() - Define la clase que controla las peticiones SOAP


Controla la petición SOAP

  • « SoapServer::getFunctions
  • SoapServer::setClass »
  • PHP Manual
  • SoapServer
  • Controla la petición SOAP

SoapServer::handle

(PHP 5, PHP 7, PHP 8)

SoapServer::handle — Controla la petición SOAP

Descripción

public SoapServer::handle ( string $soap_request = ? ) : void

Procesa una petición SOAP, llama a las funciones necesarias y envía una respuesta.

Parámetros

soap_request

La petición SOAP. Si se omite este argumento, se asume que la petición está en los datos POST de la petición HTTP.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SoapServer::handle()

<?php
function test($x)
{
    return $x;
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

Ver también

  • SoapServer::SoapServer()


Define la clase que controla las peticiones SOAP

  • « SoapServer::handle
  • SoapServer::setObject »
  • PHP Manual
  • SoapServer
  • Define la clase que controla las peticiones SOAP

SoapServer::setClass

(PHP 5, PHP 7, PHP 8)

SoapServer::setClass — Define la clase que controla las peticiones SOAP

Descripción

public SoapServer::setClass ( string $class_name , mixed $... = ? ) : void

Exporta todos los métodos de una clase específica.

El objecto puede ser persistente durante un determinado período de sesiones PHP con el método SoapServer::setPersistence().

Parámetros

class_name

Nombre de la clase exportada.

...

Estos parámetros opcionales serán pasados al constructor de la clase por defecto durante la creación del objeto.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SoapServer::SoapServer()
  • SoapServer::addFunction() - Añade una o más funciones al controlador de peticiones SOAP
  • SoapServer::setPersistence() - Establece el modo de persistencia de SoapServer


Define el objecto que será usado para controlar las peticiones SOAP

  • « SoapServer::setClass
  • SoapServer::setPersistence »
  • PHP Manual
  • SoapServer
  • Define el objecto que será usado para controlar las peticiones SOAP

SoapServer::setObject

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

SoapServer::setObject — Define el objecto que será usado para controlar las peticiones SOAP

Descripción

public SoapServer::setObject ( object $object ) : void

Define un objecto específico como controlador para las peticiones SOAP, en lugar de solo una clase como en SoapServer::setClass().

Parámetros

object

El objecto a controlar las peticiones.

Valores devueltos

No devuelve ningún valor.

Ver también

  • SoapServer::setClass() - Define la clase que controla las peticiones SOAP


Establece el modo de persistencia de SoapServer

  • « SoapServer::setObject
  • SoapFault »
  • PHP Manual
  • SoapServer
  • Establece el modo de persistencia de SoapServer

SoapServer::setPersistence

(PHP 5, PHP 7, PHP 8)

SoapServer::setPersistence — Establece el modo de persistencia de SoapServer

Descripción

public SoapServer::setPersistence ( int $mode ) : void

Esta función permite cambiar el estado de persistencia de un objeto SoapServer entre peticiones. Esta función permite guardar datos entre peticiones usando sesiones de PHP. Este método solamente tiene efecto en un SoapServer después de exportar funciones utilizando SoapServer::setClass().

Nota:

La persistencia de SOAP_PERSISTENCE_SESSION solamente hace persistentes a los objetos de la clase dad, no los datos estáticos de la clase. En este caso, use $this->bar en lugar de self::$bar.

Nota:

SOAP_PERSISTENCE_SESSION serializa datos en el objeto de clase entre peticiones. Para poder adecuadamente utilizar recursos (p.ej. PDO), deberían usarse los métodos mágicos __wakeup() y __sleep().

Parámetros

mode

Una de las constantes SOAP_PERSISTENCE_XXX.

SOAP_PERSISTENCE_REQUEST - Los datos de SoapServer no persisten entre peticiones. Este es el comportamiento predeterminado de cualquier objeto SoapServer después de llamar a setClass.

SOAP_PERSISTENCE_SESSION - Los datos de SoapServer persisten entre peticiones. Esto se lleva a cabo serializando los datos de la clase SoapServer en $_SESSION['_nombre_sesión_falso'], ya que session_start() debe invocarse antes de establecer este modo de persistencia.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de SoapServer::setPersistence()

<?php
 class MyFirstPersistentSoapServer {
     private $resource; // (Tal como PDO, mysqli, etc..)
     public $mivar1;
     public $mivar2;

     public function __construct() {
         $this->__wakeup(); // Estamos llamando nuestro wakeup para manejar nuestro recurso
     }

     public function __wakeup() {
         $this->resource = CodeToStartOurResourceUp();
     }

     public function __sleep() {
         // Nos aseguramos de omitir $resource aquí, por lo que nuestro datos de sesión persisten
         // Un fallo resultará en el fallo durante la deserialilzación de datos
         // en la próxima petición; por lo tanto, nuestro SoapObject no sería persistente entre peticiones.
         return array('mivar1','mivar2');
     }
 }

 try {
     session_start();
     $server = new SoapServer(null, array('uri' => $_SERVER['REQUEST_URI']));
     $server->setClass('MyFirstPersistentSoapServer');
     // setPersistence DEBE invocarse después de setClass, debido a que el comportamiento
     // de setClass establece SESSION_PERSISTENCE_REQUEST tras promulgar el método.
     $server->setPersistence(SOAP_PERSISTENCE_SESSION);
     $server->handle();
 } catch(SoapFault $e) {
     error_log("SOAP ERROR: ". $e->getMessage());
 }
?>

Ver también

  • SoapServer::setClass() - Define la clase que controla las peticiones SOAP


La clase SoapFault

(PHP 5, PHP 7, PHP 8)

Introducción

Representa SOAP fault.

Sinopsis de la Clase

SoapFault extends Exception {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos */
__construct ( string $faultcode , string $faultstring , string $faultactor = ? , string $detail = ? , string $faultname = ? , string $headerfault = ? )
public __toString ( ) : string
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Tabla de contenidos

  • SoapFault::__construct — Constructor de SoapFault
  • SoapFault::__toString — Obtiene una representación en formato cadena de SoapFault


Constructor de SoapFault

  • « SoapFault
  • SoapFault::__toString »
  • PHP Manual
  • SoapFault
  • Constructor de SoapFault

SoapFault::__construct

(PHP 5, PHP 7, PHP 8)

SoapFault::__construct — Constructor de SoapFault

Descripción

SoapFault::__construct ( string $faultcode , string $faultstring , string $faultactor = ? , string $detail = ? , string $faultname = ? , string $headerfault = ? )

Esta función es un alias de: SoapFault::SoapFault()


Obtiene una representación en formato cadena de SoapFault

  • « SoapFault::__construct
  • SoapHeader »
  • PHP Manual
  • SoapFault
  • Obtiene una representación en formato cadena de SoapFault

SoapFault::__toString

(PHP 5, PHP 7, PHP 8)

SoapFault::__toString — Obtiene una representación en formato cadena de SoapFault

Descripción

public SoapFault::__toString ( ) : string

Devuelve una representación en formato cadena de SoapFault.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Una cadena describiendo el SoapFault.


La clase SoapHeader

(PHP 5, PHP 7, PHP 8)

Introducción

Representa un SOAP header.

Sinopsis de la Clase

SoapHeader {
/* Métodos */
__construct ( string $namespace , string $name , mixed $data = ? , bool $mustunderstand = ? , string $actor = ? )
}

Tabla de contenidos

  • SoapHeader::__construct — Constructor de SoapHeader


Constructor de SoapHeader

  • « SoapHeader
  • SoapParam »
  • PHP Manual
  • SoapHeader
  • Constructor de SoapHeader

SoapHeader::__construct

(PHP 5, PHP 7, PHP 8)

SoapHeader::__construct — Constructor de SoapHeader

Descripción

SoapHeader::__construct ( string $namespace , string $name , mixed $data = ? , bool $mustunderstand = ? , string $actor = ? )

Esta función es un alias de: SoapHeader::SoapHeader()


La clase SoapParam

(PHP 5, PHP 7, PHP 8)

Introducción

Representa el parametro para una llamada a SOAP.

Sinopsis de la Clase

SoapParam {
/* Métodos */
__construct ( mixed $data , string $name )
}

Tabla de contenidos

  • SoapParam::__construct — Constructor de SoapParam


Constructor de SoapParam

  • « SoapParam
  • SoapVar »
  • PHP Manual
  • SoapParam
  • Constructor de SoapParam

SoapParam::__construct

(PHP 5, PHP 7, PHP 8)

SoapParam::__construct — Constructor de SoapParam

Descripción

SoapParam::__construct ( mixed $data , string $name )

Esta función es un alias de: SoapParam::SoapParam()


La clase SoapVar

(PHP 5, PHP 7, PHP 8)

Introducción

Una clase representando una variable u objecto para usar con los servicios SOAP.

Sinopsis de la Clase

SoapVar {
/* Métodos */
__construct ( mixed $data , string $encoding , string $type_name = ? , string $type_namespace = ? , string $node_name = ? , string $node_namespace = ? )
}

Tabla de contenidos

  • SoapVar::__construct — Constructor de SoapVar


Constructor de SoapVar

  • « SoapVar
  • Yar »
  • PHP Manual
  • SoapVar
  • Constructor de SoapVar

SoapVar::__construct

(PHP 5, PHP 7, PHP 8)

SoapVar::__construct — Constructor de SoapVar

Descripción

SoapVar::__construct ( mixed $data , string $encoding , string $type_name = ? , string $type_namespace = ? , string $node_name = ? , string $node_namespace = ? )

Esta función es un alias de: SoapVar::SoapVar()


Yet Another RPC Framework

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • Yar_Server — La clase Yar_Server
    • Yar_Server::__construct — Registrar un servidor
    • Yar_Server::handle — Iniciar un servidor RPC
  • Yar_Client — La clase Yar_Client
    • Yar_Client::__call — Llamar a un servicio
    • Yar_Client::__construct — Crear un cliente
    • Yar_Client::setOpt — Establecer los contextos de una llamada
  • Yar_Concurrent_Client — La clase Yar_Concurrent_Client
    • Yar_Concurrent_Client::call — Registrar una llamada concurrente
    • Yar_Concurrent_Client::loop — Enviar todas las llamadas
    • Yar_Concurrent_Client::reset — Limpiar todas las llamadas registradas
  • Yar_Server_Exception — La clase Yar_Server_Exception
    • Yar_Server_Exception::getType — Recuperar el tipo de excepción
  • Yar_Client_Exception — La clase Yar_Client_Exception
    • Yar_Client_Exception::getType — El propósito de getType


Introducción

Yar es un «framework» de RPC que pretende simplificar y facilitar la manera en que se comunican las aplicaciones de PHP entre ellas. Tiene la capacidad de llamar concurrentemente a varios servicios remotos.


Requerimientos

Para emplear msgpack como empaquetador, es necesario compilar Yar con ./configure --enable-msgpack


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/yar.

Actualmente, no hay ninguna DLL disponible para esta extensión PECL. Véase también la sección Compilación en Windows .


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Yar Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
yar.packager | php | PHP_INI_SYSTEM |
yar.debug | Off | PHP_INI_ALL |
yar.connect_timeout | 1000 | PHP_INI_ALL |
yar.timeout | 5000 | PHP_INI_ALL |
yar.expose_info | On | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

yar.packager string

Podría ser php, json, y msgpack (requiere construcción con soporte para msgpack)

yar.debug string

yar.connect_timeout integer

Tiempo de espera en ms

yar.timeout integer

Tiempo de espera en ms

yar.expose_info bool

Si exponer la información del servicio (al acceder al servidor mediante GET)


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

YAR_VERSION (string)
YAR_CLIENT_PROTOCOL_HTTP (integer)
YAR_OPT_PACKAGER (integer)
YAR_OPT_TIMEOUT (integer)
YAR_OPT_CONNECT_TIMEOUT (integer)
YAR_OPT_HEADER (array)
Desde 2.0.4
YAR_PACKAGER_PHP (string)
YAR_PACKAGER_JSON (string)
YAR_ERR_OKEY (integer)
YAR_ERR_OUTPUT (integer)
YAR_ERR_TRANSPORT (integer)
YAR_ERR_REQUEST (integer)
YAR_ERR_PROTOCOL (integer)
YAR_ERR_PACKAGER (integer)
YAR_ERR_EXCEPTION (integer)


Ejemplos

Ejemplo #1 Ejemplo de servidor de Yar

<?php

/* Se asume que a esta página se puede acceder mediante http://example.com/operator.php */

class Operator {

    /**
     * Add two operands
     * @param interge
     * @return interge
     */
    public function add($a, $b) {
        return $this->_add($a, $b);
    }

    /**
     * Sub
     */
    public function sub($a, $b) {
        return $a - $b;
    }

    /**
     * Mul
     */
    public function mul($a, $b) {
        return $a * $b;
    }

    /**
     * Protected methods will not be exposed
     * @param interge
     * @return interge
     */
    protected function _add($a, $b) {
        return $a + $b;
    }
}

$servidor = new Yar_Server(new Operator());
$servidor->handle();
?>

Ejemplo #2 Acceder al servidor desde el navegador (petición GET)

El resultado del ejemplo sería algo similar a:

Información del servidor de Yar

Ejemplo #3 Ejemplo de cliente de Yar

<?php
$cliente = new yar_client("http://example.com/operator.php");

/* llamar directamente */
var_dump($cliente->add(1, 2));

/* llamar mediante el método 'call' */
var_dump($cliente->call("add", array(3, 2)));

/* __add no puede ser llamado */
var_dump($cliente->_add(1, 2));
?>

El resultado del ejemplo sería algo similar a:

int(3)
int(5)
PHP Fatal error:  Uncaught exception 'Yar_Server_Exception' with message 'call to api Operator::_add() failed' in *

Ejemplo #4 Ejemplo de cliente concurrente de Yar

<?php
function callback($ret, $callinfo) {
    echo $callinfo['method'] , " result: ", $ret , "\n";
}

/* registrar las llamadas asíncronas a servicios remotos */
Yar_Concurrent_Client::call("http://example.com/operator.php", "add", array(1, 2), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "sub", array(2, 1), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "mul", array(2, 2), "callback");

/* enviar todas las peticiones y esperar una respuesta */
Yar_Concurrent_Client::loop();
?>

El resultado del ejemplo sería algo similar a:

mul result: 4
sub result: 1
add result: 3


La clase Yar_Server

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

Yar_Server {
/* Propiedades */
protected $_executor ;
/* Métodos */
final public __construct ( Object $obj )
public handle ( ) : bool
}

Propiedades

_executor

Tabla de contenidos

  • Yar_Server::__construct — Registrar un servidor
  • Yar_Server::handle — Iniciar un servidor RPC


Registrar un servidor

  • « Yar_Server
  • Yar_Server::handle »
  • PHP Manual
  • Yar_Server
  • Registrar un servidor

Yar_Server::__construct

(PECL yar >= 1.0.0)

Yar_Server::__construct — Registrar un servidor

Descripción

final public Yar_Server::__construct ( Object $obj )

Configurar un Servidor Yar HTTP RPC. Todos los métodos públicos de $obj serán registrados como un servicio RPC.

Parámetros

obj

Un objeto, todos sus métodos publicos serán registrados como servicioes RPC.

Valores devueltos

Una instancia de Yar_Server.

Ejemplos

Ejemplo #1 Ejemplo de Yar_Server::__construct()

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
         return "some_method";
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Server::handle() - Iniciar un servidor RPC
    •


Iniciar un servidor RPC

  • « Yar_Server::__construct
  • Yar_Client »
  • PHP Manual
  • Yar_Server
  • Iniciar un servidor RPC

Yar_Server::handle

(PECL yar >= 1.0.0)

Yar_Server::handle — Iniciar un servidor RPC

Descripción

public Yar_Server::handle ( ) : bool

Inicia un servidor de HTTP de RPC listo para aceptar peticiones RPC.

Nota:

Las llamadas RPC usuales serán emitidas como peticiones POST de HTTP. Si se emite una petición GET de HTTP al URI, se imprimierá en la página la información del servicio (la sección comentada anteriormente).

Parámetros

Esta función no tiene parámetros.

Valores devueltos

boolean

Ejemplos

Ejemplo #1 Ejemplo de Yar_Server::handle()

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Server::__construct() - Registrar un servidor
    •


La clase Yar_Client

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

Yar_Client {
/* Propiedades */
protected $_protocol ;
protected $_uri ;
protected $_options ;
protected $_running ;
/* Métodos */
public __call ( string $method , array $parameters ) : void
final public __construct ( string $url , array $options = ? )
public setOpt ( int $name , mixed $value ) : Yar_Client
}

Propiedades

_protocol

_uri

_options

_running

Tabla de contenidos

  • Yar_Client::__call — Llamar a un servicio
  • Yar_Client::__construct — Crear un cliente
  • Yar_Client::setOpt — Establecer los contextos de una llamada


Llamar a un servicio

  • « Yar_Client
  • Yar_Client::__construct »
  • PHP Manual
  • Yar_Client
  • Llamar a un servicio

Yar_Client::__call

(PECL yar >= 1.0.0)

Yar_Client::__call — Llamar a un servicio

Descripción

public Yar_Client::__call ( string $method , array $parameters ) : void

Emite una llamada a un método RPC remoto.

Parámetros

method

Nombre del método RPC remono.

parameters

Parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yar_Client::__call()

<?php

$cliente = new Yar_Client("http://host/api/");

/* llamar al servicio remoto */
$resultado = $cliente->some_method("parameter");
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Client::setOpt() - Establecer los contextos de una llamada
    •


Crear un cliente

  • « Yar_Client::__call
  • Yar_Client::setOpt »
  • PHP Manual
  • Yar_Client
  • Crear un cliente

Yar_Client::__construct

(PECL yar >= 1.0.0)

Yar_Client::__construct — Crear un cliente

Descripción

final public Yar_Client::__construct ( string $url , array $options = ? )

Crea un Yar_Client hacia un Yar_Server.

Parámetros

url

El URL del servidor de Yar.

Valores devueltos

Una instancia de Yar_Client.

Ejemplos

Ejemplo #1 Ejemplo de Yar_Client::__construct()

<?php
$cliente = new Yar_Client("http://host/api/");
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Client::__call() - Llamar a un servicio
    •

  • Yar_Client::setOpt() - Establecer los contextos de una llamada
    •


Establecer los contextos de una llamada

  • « Yar_Client::__construct
  • Yar_Concurrent_Client »
  • PHP Manual
  • Yar_Client
  • Establecer los contextos de una llamada

Yar_Client::setOpt

(PECL yar >= 1.0.0)

Yar_Client::setOpt — Establecer los contextos de una llamada

Descripción

public Yar_Client::setOpt ( int $name , mixed $value ) : Yar_Client

Parámetros

name

El nombre puede ser: YAR_OPT_PACKAGER, YAR_OPT_PERSISTENT (Necesita soporte en el servidor), YAR_OPT_TIMEOUT, YAR_OPT_CONNECT_TIMEOUT YAR_OPT_HEADER (Desde 2.0.4)

value

Valores devueltos

Devuelve $this en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de Yar_Client::setOpt()

<?php

$cliente = new Yar_Client("http://host/api/");

//Establecer el tiempo de espera a 1s
$cliente->SetOpt(YAR_OPT_CONNECT_TIMEOUT, 1000);

//Establecer el empaquetador a JSON
$cliente->SetOpt(YAR_OPT_PACKAGER, "json");

//Establecer cabeceras personalizadas
$client->SetOpt(YAR_OPT_HEADER, array("hr1: val1", "hd2: val2"));

/* llamar al servicio remoto */
$result = $cliente->some_method("parameter");
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Client::__call() - Llamar a un servicio
    •


La clase Yar_Concurrent_Client

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

Yar_Concurrent_Client {
/* Propiedades */
static $_callstack ;
static $_callback ;
static $_error_callback ;
/* Métodos */
public static call ( string $uri , string $method , array $parameters = ? , callable $callback = ? , callable $error_callback = ? , array $options = ? ) : int
public static loop ( callable $callback = ? , callable $error_callback = ? ) : bool
public static reset ( ) : boolean
}

Propiedades

_callstack

_callback

_error_callback

Tabla de contenidos

  • Yar_Concurrent_Client::call — Registrar una llamada concurrente
  • Yar_Concurrent_Client::loop — Enviar todas las llamadas
  • Yar_Concurrent_Client::reset — Limpiar todas las llamadas registradas


Registrar una llamada concurrente

  • « Yar_Concurrent_Client
  • Yar_Concurrent_Client::loop »
  • PHP Manual
  • Yar_Concurrent_Client
  • Registrar una llamada concurrente

Yar_Concurrent_Client::call

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::call — Registrar una llamada concurrente

Descripción

public static Yar_Concurrent_Client::call ( string $uri , string $method , array $parameters = ? , callable $callback = ? , callable $error_callback = ? , array $options = ? ) : int

Registra una llamada RPC, aunque no la envía inmediatamente. Se enviará al llamar a Yar_Concurrent_Client::loop()

Parámetros

uri

El URI del servidor de RPC (http, tcp)

method

El nombre del servicio (es decir, el nombre del método)

parameters

Parámetros

callback

Una retrollamada a una función, la cual será invocada mientras se devuelve la respuesta.

Valores devueltos

Un ID único que se puede utilizar para identificar la llamada que es.

Ejemplos

Ejemplo #1 Ejemplo de Yar_Concurrent_Client::call()

<?php
function callback($retval, $callinfo) {
     var_dump($retval);
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // si no se especifica la retrollamada,
                                                                               // se usará la retrollamada en bucle
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //este servidor acepta empaquetadores json
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //tiempo de espera personalizado

//Las peticiones aún no se han enviado
?>

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Concurrent_Client::loop() - Enviar todas las llamadas
    •

  • Yar_Concurrent_Client::reset() - Limpiar todas las llamadas registradas
    •

  • Yar_Server::__construct() - Registrar un servidor
    •

  • Yar_Server::handle() - Iniciar un servidor RPC
    •


Enviar todas las llamadas

  • « Yar_Concurrent_Client::call
  • Yar_Concurrent_Client::reset »
  • PHP Manual
  • Yar_Concurrent_Client
  • Enviar todas las llamadas

Yar_Concurrent_Client::loop

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::loop — Enviar todas las llamadas

Descripción

public static Yar_Concurrent_Client::loop ( callable $callback = ? , callable $error_callback = ? ) : bool

Envía todas las llamadas RPC remotas registradas.

Parámetros

callback

Si se establece esta retrollamada, Yar la invocará después de haber enviado todas las llamadas y antes de cualquier respuesta, con un $callinfo NULL.

Entonces, si un usuario no especifica la retrollamada al registrar una llamada concurretne, esta retrollamada se utilizará para manejar la resupesta, o si no, se utilizará la retrollamada especificada durante el registro.

error_callback

Si se establece esta retrollamada, Yar la invocará cuando suceda un error.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yar_Concurrent_Client::loop()

<?php
function callback($retval, $callinfo) {
     if ($callinfo == NULL) {
        echo "Now, all requests are sent, and no any response available\n";
     } else {
        echo "This is a remote call response, the method name is", $callinfo["method"],
             ". calling sequence is " , $callinfo["sequence"] , "\n";
        var_dump($retval);
     }
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // if the callback is not specificed,
                                                                               // callback in loop will be used
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //this server accept json packager
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //custom timeout

Yar_Concurrent_Client::loop("callback", "error_callback"); //send the requests,
                                                           //the error_callback is optional
?>

El resultado del ejemplo sería algo similar a:

Now, all requests are sent, and no any response available
This is a remote call response, the method name issome_method. calling sequence is 4
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 1
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 2
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 3
string(11) "some_method"

Ver también

  • Yar_Concurrent_Client::call() - Registrar una llamada concurrente
  • Yar_Concurrent_Client::reset() - Limpiar todas las llamadas registradas
  • Yar_Server::__construct() - Registrar un servidor
  • Yar_Server::handle() - Iniciar un servidor RPC


Limpiar todas las llamadas registradas

  • « Yar_Concurrent_Client::loop
  • Yar_Server_Exception »
  • PHP Manual
  • Yar_Concurrent_Client
  • Limpiar todas las llamadas registradas

Yar_Concurrent_Client::reset

(PECL yar >= 1.2.4)

Yar_Concurrent_Client::reset — Limpiar todas las llamadas registradas

Descripción

public static Yar_Concurrent_Client::reset ( ) : boolean

Limpia todas las llamadas registradas

Parámetros

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yar_Concurrent_Client::reset()

El resultado del ejemplo sería algo similar a:

Ver también

  • Yar_Concurrent_Client::call() - Registrar una llamada concurrente
    •

  • Yar_Concurrent_Client::loop() - Enviar todas las llamadas
    •

  • Yar_Server::__construct() - Registrar un servidor
    •

  • Yar_Server::handle() - Iniciar un servidor RPC
    •


La clase Yar_Server_Exception

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Si un servicio lanza excepciones, se lanzará una Yar_Server_Exception en el lado del cliente.

Sinopsis de la Clase

Yar_Server_Exception extends Exception {
/* Propiedades */
protected $_type ;
/* Métodos */
public getType ( ) : string
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

message

code

file

line

_type

Tabla de contenidos

  • Yar_Server_Exception::getType — Recuperar el tipo de excepción


Recuperar el tipo de excepción

  • « Yar_Server_Exception
  • Yar_Client_Exception »
  • PHP Manual
  • Yar_Server_Exception
  • Recuperar el tipo de excepción

Yar_Server_Exception::getType

(PECL yar >= 1.0.0)

Yar_Server_Exception::getType — Recuperar el tipo de excepción

Descripción

public Yar_Server_Exception::getType ( ) : string

Obtener el tipo original de la excepción lanzada por el servidor

Parámetros

Esta función no tiene parámetros.

Valores devueltos

string

Ejemplos

Ejemplo #1 Ejemplo de Yar_Server_Exception::getType()

//Server.php
<?php
class Custom_Exception extends Exception {};

class API {
    public function throw_exception($name) {
        throw new Custom_Exception($name);
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

//Client.php
<?php
$client = new Yar_Client("http://host/api.php");

try {
    $client->throw_exception("client");
} catch (Yar_Server_Exception $e) {
    var_dump($e->getType());
    var_dump($e->getMessage());
}

El resultado del ejemplo sería algo similar a:

string(16) "Custom_Exception"
string(6) "client"

Ver también


La clase Yar_Client_Exception

(No hay información de versión disponible, podría estar únicamente en Git)

Introducción

Sinopsis de la Clase

Yar_Client_Exception extends Exception {
/* Propiedades */
/* Métodos */
public getType ( ) : void
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

message

code

file

line

Tabla de contenidos

  • Yar_Client_Exception::getType — El propósito de getType


El propósito de getType

  • « Yar_Client_Exception
  • XML-RPC »
  • PHP Manual
  • Yar_Client_Exception
  • El propósito de getType

Yar_Client_Exception::getType

(PECL yar >= 1.0.0)

Yar_Client_Exception::getType — El propósito de getType

Descripción

public Yar_Client_Exception::getType ( ) : void

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Ejemplos

Ejemplo #1 Ejemplo de Yar_Client_Exception::getType()

<?php

/* ... */

?>

El resultado del ejemplo sería algo similar a:

...

Ver también


XML-RPC

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Funciones de XML-RPC
    • xmlrpc_decode_request — Decodifica el XML en los tipos de PHP nativos
    • xmlrpc_decode — Decodifica el XML en los tipos de PHP nativos
    • xmlrpc_encode_request — Genera XML para el requerimiento de un método
    • xmlrpc_encode — Genera XML para un valor PHP
    • xmlrpc_get_type — Obtiene el tipo del xmlrpc para un valor PHP
    • xmlrpc_is_fault — Determina si el valor de un arreglo representa una falla del XMLRPC
    • xmlrpc_parse_method_descriptions — Decodifica el XML en una lista de las descripciones del método
    • xmlrpc_server_add_introspection_data — Agrega una documentación introspectiva
    • xmlrpc_server_call_method — Analiza los requerimientos del XML y las llamadas de los métodos
    • xmlrpc_server_create — Crea un servidor xmlrpc
    • xmlrpc_server_destroy — Destruye los recursos del servidor
    • xmlrpc_server_register_introspection_callback — Registra una función PHP para generar la documentación
    • xmlrpc_server_register_method — Registra una función PHP para que el recurso del método coincida con method_name
    • xmlrpc_set_type — Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP


Introducción

Estas funciones se pueden usar para escribir servidores y clientes XML-RPC. Se puede encontrar más información acerca de XML-RPC en » http://www.xmlrpc.com/, y más documentación sobre esta extensión y sus funciones en » http://xmlrpc-epi.sourceforge.net/.

Advertencia

Esta extensión es EXPERIMENTAL. Esto significa que el comportamiento de esta extensión, los nombres de sus funciones y todo lo documentado sobre esta extensión, puede cambiar en una futura edición de PHP sin previo aviso. El uso de esta extensión queda bajo su propia responsabilidad.


Instalación

El XML-RPC soportado en PHP no está activado por defecto. Se necesita usar la opción configuración de --with-xmlrpc[=DIR] cuando es compilado el PHP para activar el soporte a XML-RPC support.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Ésta extensión define un recurso de servicio de XML-RPC devuelto por xmlrpc_server_create().


  • « Tipos de recursos
  • Funciones de XML-RPC »
  • PHP Manual
  • XML-RPC
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Funciones de XML-RPC

Tabla de contenidos

  • xmlrpc_decode_request — Decodifica el XML en los tipos de PHP nativos
  • xmlrpc_decode — Decodifica el XML en los tipos de PHP nativos
  • xmlrpc_encode_request — Genera XML para el requerimiento de un método
  • xmlrpc_encode — Genera XML para un valor PHP
  • xmlrpc_get_type — Obtiene el tipo del xmlrpc para un valor PHP
  • xmlrpc_is_fault — Determina si el valor de un arreglo representa una falla del XMLRPC
  • xmlrpc_parse_method_descriptions — Decodifica el XML en una lista de las descripciones del método
  • xmlrpc_server_add_introspection_data — Agrega una documentación introspectiva
  • xmlrpc_server_call_method — Analiza los requerimientos del XML y las llamadas de los métodos
  • xmlrpc_server_create — Crea un servidor xmlrpc
  • xmlrpc_server_destroy — Destruye los recursos del servidor
  • xmlrpc_server_register_introspection_callback — Registra una función PHP para generar la documentación
  • xmlrpc_server_register_method — Registra una función PHP para que el recurso del método coincida con method_name
  • xmlrpc_set_type — Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP


Decodifica el XML en los tipos de PHP nativos

  • « Funciones de XML-RPC
  • xmlrpc_decode »
  • PHP Manual
  • Funciones de XML-RPC
  • Decodifica el XML en los tipos de PHP nativos

xmlrpc_decode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode_request — Decodifica el XML en los tipos de PHP nativos

Descripción

xmlrpc_decode_request ( string $xml , string &$method , string $encoding = ? ) : mixed
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Decodifica el XML en los tipos de PHP nativos

  • « xmlrpc_decode_request
  • xmlrpc_encode_request »
  • PHP Manual
  • Funciones de XML-RPC
  • Decodifica el XML en los tipos de PHP nativos

xmlrpc_decode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode — Decodifica el XML en los tipos de PHP nativos

Descripción

xmlrpc_decode ( string $xml , string $encoding = "iso-8859-1" ) : mixed
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

xml

La respuesta XML devuelta por el método XMLRPC.

encoding

Entrada de codificación que admite iconv.

Valores devueltos

Devuelve o un arreglo, o un entero, o una cadena, o un booleano conforme a la respuesta devuelta por el método XMLRPC.

Ejemplos

Ver el ejemplo de xmlrpc_encode_request().

Ver también

  • xmlrpc_encode_request() - Genera XML para el requerimiento de un método
  • xmlrpc_is_fault() - Determina si el valor de un arreglo representa una falla del XMLRPC


Genera XML para el requerimiento de un método

  • « xmlrpc_decode
  • xmlrpc_encode »
  • PHP Manual
  • Funciones de XML-RPC
  • Genera XML para el requerimiento de un método

xmlrpc_encode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode_request — Genera XML para el requerimiento de un método

Descripción

xmlrpc_encode_request ( string $method , mixed $params , array $output_options = ? ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

method

El nombre del método a llamar.

params

Los parámetros de los métodos compatibles con la firma del método.

output_options

Las opciones de salida de un arreglo especifico pueden contener (por defecto valores que son enfatizados):

  • output_type: php, xml

  • verbosity: no_white_space, newlines_only, pretty

  • escaping: cdata, non-ascii, non-print, markup (may be a string with one value or an array with multiple values)

  • version: simple, xmlrpc, soap 1.1, auto

  • encoding: iso-8859-1, other character set supported by iconv

Valores devueltos

Devuelve una cadena conteniendo la representación del XML del requerimiento.

Ejemplos

Ejemplo #1 Ejmeplo de las funciones de clietes de XMLRPC

<?php
$request = xmlrpc_encode_request("method", array(1, 2, 3));
$context = stream_context_create(array('http' => array(
    'method' => "POST",
    'header' => "Content-Type: text/xml",
    'content' => $request
)));
$file = file_get_contents("http://www.example.com/xmlrpc", false, $context);
$response = xmlrpc_decode($file);
if ($response && xmlrpc_is_fault($response)) {
    trigger_error("xmlrpc: $response[faultString] ($response[faultCode])");
} else {
    print_r($response);
}
?>

Ver también

  • stream_context_create() - Crear un contexto de flujo
  • file_get_contents() - Transmite un fichero completo a una cadena
  • xmlrpc_decode() - Decodifica el XML en los tipos de PHP nativos


Genera XML para un valor PHP

  • « xmlrpc_encode_request
  • xmlrpc_get_type »
  • PHP Manual
  • Funciones de XML-RPC
  • Genera XML para un valor PHP

xmlrpc_encode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode — Genera XML para un valor PHP

Descripción

xmlrpc_encode ( mixed $value ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Obtiene el tipo del xmlrpc para un valor PHP

  • « xmlrpc_encode
  • xmlrpc_is_fault »
  • PHP Manual
  • Funciones de XML-RPC
  • Obtiene el tipo del xmlrpc para un valor PHP

xmlrpc_get_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_get_type — Obtiene el tipo del xmlrpc para un valor PHP

Descripción

xmlrpc_get_type ( mixed $value ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Ésta función es específicamente útil para la base64 y las cadenas fecha-hora.

Parámetros

value

valor de PHP

Valores devueltos

Devuelve el tipo de XML-RPC.

Ejemplos

Ejemplo #1 Ejemplo de tipo de XML-RPC

<?php
echo xmlrpc_get_type(null) . "\n"; // base64
echo xmlrpc_get_type(false) . "\n"; // boolean
echo xmlrpc_get_type(1) . "\n"; // int
echo xmlrpc_get_type(1.0) . "\n"; // double
echo xmlrpc_get_type("") . "\n"; // string
echo xmlrpc_get_type(array()) . "\n"; // array
echo xmlrpc_get_type(new stdClass) . "\n"; // array
echo xmlrpc_get_type(STDIN) . "\n"; // int
?>

Ver también

  • xmlrpc_set_type() - Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP


Determina si el valor de un arreglo representa una falla del XMLRPC

  • « xmlrpc_get_type
  • xmlrpc_parse_method_descriptions »
  • PHP Manual
  • Funciones de XML-RPC
  • Determina si el valor de un arreglo representa una falla del XMLRPC

xmlrpc_is_fault

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

xmlrpc_is_fault — Determina si el valor de un arreglo representa una falla del XMLRPC

Descripción

xmlrpc_is_fault ( array $arg ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

arg

El arreglo devuelto por xmlrpc_decode().

Valores devueltos

Devuelve true si emabargo si el argumento significa fallo retorna, false. La descripción de la falla o falta está disponible en $arg["faultString"], fault el código está en $arg["faultCode"].

Ejemplos

Ver ejemplo dexmlrpc_encode_request().

Ver también

  • xmlrpc_decode() - Decodifica el XML en los tipos de PHP nativos


Decodifica el XML en una lista de las descripciones del método

  • « xmlrpc_is_fault
  • xmlrpc_server_add_introspection_data »
  • PHP Manual
  • Funciones de XML-RPC
  • Decodifica el XML en una lista de las descripciones del método

xmlrpc_parse_method_descriptions

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_parse_method_descriptions — Decodifica el XML en una lista de las descripciones del método

Descripción

xmlrpc_parse_method_descriptions ( string $xml ) : array
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Agrega una documentación introspectiva

  • « xmlrpc_parse_method_descriptions
  • xmlrpc_server_call_method »
  • PHP Manual
  • Funciones de XML-RPC
  • Agrega una documentación introspectiva

xmlrpc_server_add_introspection_data

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_add_introspection_data — Agrega una documentación introspectiva

Descripción

xmlrpc_server_add_introspection_data ( resource $server , array $desc ) : int
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Analiza los requerimientos del XML y las llamadas de los métodos

  • « xmlrpc_server_add_introspection_data
  • xmlrpc_server_create »
  • PHP Manual
  • Funciones de XML-RPC
  • Analiza los requerimientos del XML y las llamadas de los métodos

xmlrpc_server_call_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_call_method — Analiza los requerimientos del XML y las llamadas de los métodos

Descripción

xmlrpc_server_call_method ( resource $server , string $xml , mixed $user_data , array $output_options = ? ) : string
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Crea un servidor xmlrpc

  • « xmlrpc_server_call_method
  • xmlrpc_server_destroy »
  • PHP Manual
  • Funciones de XML-RPC
  • Crea un servidor xmlrpc

xmlrpc_server_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_create — Crea un servidor xmlrpc

Descripción

xmlrpc_server_create ( ) : resource
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Destruye los recursos del servidor

  • « xmlrpc_server_create
  • xmlrpc_server_register_introspection_callback »
  • PHP Manual
  • Funciones de XML-RPC
  • Destruye los recursos del servidor

xmlrpc_server_destroy

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_destroy — Destruye los recursos del servidor

Descripción

xmlrpc_server_destroy ( resource $server ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Registra una función PHP para generar la documentación

  • « xmlrpc_server_destroy
  • xmlrpc_server_register_method »
  • PHP Manual
  • Funciones de XML-RPC
  • Registra una función PHP para generar la documentación

xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_introspection_callback — Registra una función PHP para generar la documentación

Descripción

xmlrpc_server_register_introspection_callback ( resource $server , string $function ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Registra una función PHP para que el recurso del método coincida con method_name

  • « xmlrpc_server_register_introspection_callback
  • xmlrpc_set_type »
  • PHP Manual
  • Funciones de XML-RPC
  • Registra una función PHP para que el recurso del método coincida con method_name

xmlrpc_server_register_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_method — Registra una función PHP para que el recurso del método coincida con method_name

Descripción

xmlrpc_server_register_method ( resource $server , string $method_name , string $function ) : bool
Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.


Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP

  • « xmlrpc_server_register_method
  • Extensiones específicas de Windows »
  • PHP Manual
  • Funciones de XML-RPC
  • Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP

xmlrpc_set_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_set_type — Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP

Descripción

xmlrpc_set_type ( string &$value , string $type ) : bool

Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP.

Advertencia

Esta función ha sido declarada EXPERIMENTAL. Su funcionamiento, nombre y la documentación que le acompaña puede cambiar sin previo aviso en futuras versiones de PHP. Utilícela bajo su propia responsabilidad.

Parámetros

value

Value to set the type

type

'base64' or 'datetime'

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. If successful, value is converted to an object.

Ejemplos

Ejemplo #1 A xmlrpc_set_type() example

<?php

$params = date("Ymd\TH:i:s", time());
xmlrpc_set_type($params, 'datetime');
echo xmlrpc_encode($params);

?>

El resultado del ejemplo sería algo similar a:

<?xml version="1.0" encoding="utf-8"?>
<params>
<param>
 <value>
  <dateTime.iso8601>20090322T23:43:03</dateTime.iso8601>
 </value>
</param>
</params>

Errores/Excepciones

Issues E_WARNING with type unsupported by XMLRPC.


Extensiones específicas de Windows

  • COM — COM y .Net (Windows)
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Errores y manejo de errores
    • Ejemplos
    • COM — La clase COM
    • DOTNET — La clase DOTNET
    • VARIANT — La clase VARIANT
    • COMPersistHelper — La clase COMPersistHelper
    • com_exception — La clase com_exception
    • Funciones de COM
  • win32service
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones win32service


COM y .Net (Windows)

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Errores y manejo de errores
  • Ejemplos
    • For Each
    • Arrays y propiedades estilo array de COM
  • COM — La clase COM
  • DOTNET — La clase DOTNET
  • VARIANT — La clase VARIANT
  • COMPersistHelper — La clase COMPersistHelper
    • COMPersistHelper::__construct — Construct a COMPersistHelper object
    • COMPersistHelper::GetCurFileName — Get current filename
    • COMPersistHelper::GetMaxStreamSize — Get maximum stream size
    • COMPersistHelper::InitNew — Initialize object to default state
    • COMPersistHelper::LoadFromFile — Load object from file
    • COMPersistHelper::LoadFromStream — Load object from stream
    • COMPersistHelper::SaveToFile — Save object to file
    • COMPersistHelper::SaveToStream — Save object to stream
  • com_exception — La clase com_exception
  • Funciones de COM
    • com_create_guid — Generar un identificador único globalmente (GUID)
    • com_event_sink — Conectar eventos de un objeto COM a un objeto PHP
    • com_get_active_object — Devuelve un gestor a una instancia de un objeto COM ya en ejecución
    • com_load_typelib — Carga una biblioteca de tipos
    • com_message_pump — Procesar mensajes COM, durmiendo hata timeoutms milisegundos
    • com_print_typeinfo — Imprime una definición de clase de PHP para una interfaz despachable
    • variant_abs — Devuelve el valor absoluto de una variante
    • variant_add — "Suma" dos variantes y devuelve el resultado
    • variant_and — Realiza una operación AND a nivel de bits entre dos variantes
    • variant_cast — Convertir una variante en un nuevo objeto variante de otro tipo
    • variant_cat — Concatena dos valores de variantes y devuelve el resultado
    • variant_cmp — Compara dos variantes
    • variant_date_from_timestamp — Devuelve una representación de variante de fecha de una fecha Unix
    • variant_date_to_timestamp — Convierte un valor de una variante de fecha/hora en una fecha Unix
    • variant_div — Devuelve el resultado de dividir dos variantes
    • variant_eqv — Realiza una equivalencia a nivel de bits en dos variantes
    • variant_fix — Devuelve la parte entera de una variante
    • variant_get_type — Devuelve el tipo de un objeto variante
    • variant_idiv — Convierte variantes a enteros y después devuelve el resultado dividiéndolos
    • variant_imp — Realiza una implicación a nivel de bits de dos variantes
    • variant_int — Devuelve la parte entera de una variante
    • variant_mod — Divide dos variantes y devuelve sólo el resto
    • variant_mul — Multiplica los valores de dos variantes
    • variant_neg — Realiza una negación lógica de una variante
    • variant_not — Realiza una negación NOT a nivel de bits en una variante
    • variant_or — Realiza una disyunción lógica de dos variantes
    • variant_pow — Devuelve el resultado de realizar la exponenciación con dos variantes
    • variant_round — Redondea una variante al número de lugares decimales especificado
    • variant_set_type — Convierte una variante en otro tipo "in situ"
    • variant_set — Asigna un nuevo valor para un objeto variante
    • variant_sub — Resta el valor de la variante derecha del valor de la varienta izquierda
    • variant_xor — Realiza una exclución lógica de dos variantes


Introducción

COM es un acrónimo de Component Object Model (Modelo de Objetos de Componentes); es una capa orientada a objetos (y servicios asociados) sobre DCE RPC (un estándar abierto) y define una convención de llamada común que habilita al código escrito en cualquier lenguaje para llamar e interoperar con código escrito en cualquier otro lenguaje (siempre que esos lenguajes sean concernientes a COM). El código no sólo puede ser escrito en cualquier lenguaje, sino que incluso no necesita ser parte del mismo ejecutable; el código se puede cargar desde una DLL, encontrarse en otro proceso en ejecución en la misma máquina, o, con DCOM (COM Distribuido), encontrarse en otro proceso en ejecución en una máquina remota, todo sin que el código necesite conocer dónde reside un componente.

Existe un subconjunto de COM, conocido como OLE Automation, que comprende un conjunto de interfaces COM que permiten la vinculación flexible de objetos COM, por lo que pueden ser examinados internamente y llamados en tiempo de ejecución sin tener conocimiento de cómo funcionan los objetos en tiempo de compilación. La extensión COM de PHP utiliza las interfaces de OLE Automation para permitir crear y llamar objetos compatibles desde los scripts. Técnicamente hablando, esta extensión debería llamarse la "Extensión de OLE Automation para PHP", ya que no todos los objetos COM son compatibles con OLE.

Ahora, ¿por qué usar COM? COM es una de las principales formas de casar aplicaciones y componentes en la plataforma Windows; al usar COM, se puede lanzar Microsoft Word, rellenar una plantilla de documento y guardar el resultado como un documento de Word y enviarlo a un visitante de su página web. También se puede usar COM para realizar tareas administrativas en su red y configurar IIS; estos son lo usos más comunes; se puede hacer mucho más con COM.

Además, se admite la instanciación y creación de ensamblados .Net usando la capa de interoperabilidad de COM proporcionada por Microsoft.


Requerimientos

Las funciones de COM únicamente están disponibles para la versión de Windows de PHP.

El soporte para .Net support requiere PHP 5 y .Net runtime.


Instalación

A partir de PHP 5.3.15 / 5.4.5, esta extensión requiere php_com_dotnet.dll para habilitarla dentro de php.ini para poder usar estas funciones. Las versiones anteriores de PHP habilitaban estas extensiones de manera predeterminada.

Usted tienen la responsabilidada de instalar el soporte para los diversos objetos COM que tenga intención de usar (como MS Word); no incluimos ni podemos incluir todos estos con PHP.


Configuración en tiempo de ejecución

El comportamiento de estas funciones se ve afectado por la configuración de php.ini.

Opciones de configuración de COM
Nombre | Por defecto | Cambiable | Historial de cambios
com.allow_dcom | "0" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.5.
com.autoregister_typelib | "0" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP 4. Disponible desde PHP 4.1.0.
com.autoregister_verbose | "0" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP 4. Disponible desde PHP 4.1.0.
com.autoregister_casesensitive | "1" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP 4. Disponible desde PHP 4.1.0.
com.code_page | "" | PHP_INI_ALL | Disponible desde PHP 5.0.0.
com.typelib_file | "" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.5.
Para más detalles y definiciones de los modos de PHP_INI_*, vea Dónde se puede realizar un ajuste de configuración.

He aquí una breve explicación de las directivas de configuración.

com.allow_dcom

Cuando está activada, PHP será capaz de operar como un cliente D-COM (COM Distribuido) y permitirá al script de PHP instanciar objetos COM en un servidor remoto.

com.autoregister_typelib

Cuando está activada, PHP intentará registrar constantes desde la biblioteca de tipos de objetos que instancia, si esos objetos implementan las interfaces requeridas para obtener esa información. La sensibilidad a mayúsculas-minúsculas de las constantes que registra está controlada por la directiva de configuración .

com.autoregister_verbose

Cuando está activada, cualquier problema al cargar una biblioteca de tipos durante la instanciación de un objeto será notificada usando el mecanismo de errores de PHP. Por defecto está desactivada, no emitiendo así ninguna indicación de si hubo un error buscando o cargando una biblioteca de tipos.

com.autoregister_casesensitive

Cuando está activada (predeterminado), las constantes encontradas en las bibliotecas de tipos autocargadas serán registradas con sensibilidad a mayúsculas-minúsculas. Véase com_load_typelib() para más detalles.

com.code_page

Controla la página de código predeterminada del conjunto de caracters a usar cuando se pasan cadenas hacia y desde objetos COM. Si está establecid a una cadena vacía, PHP asumirá CP_ACP, que es la página de código ANSI predeterminada del sistema.

Si el texto de sus scripts está codificado usando un conjunto de caracteres/codificación diferente por omision, establecer esta directiva le ahorrará de tener que pasar la página de código como parámetro al constructor de la clase COM. Por favor, observe que al usar esta directiva (como cualquier otra directiva de configuración de PHP), su script de PHP se convierte en menos portable; debería usar el parámetro del constructor de COM siempre que sea posible.

Nota: Esta directiva de configuración se introdujo con PHP 5.

com.typelib_file

Cuando está establecida debería contener la ruta al fichero que contiene una lista de bibliotecas de tipos que deberían ser cargadas al inicio. Cada línea del fichero será tratada como el nombre de una biblioteca de tipos y será cargada como si se llamara a com_load_typelib(). Las constantes serán registradas de forma persistente, por lo que la biblioteca únicamente necesita ser cargada una vez. Si un nombre de una biblioteca de tipos termina con la cadena #cis o #case_insensitive, las constantes de esa biblioteca serán registradas de manera insensible a mayúsculas-minúsculas.


Tipos de recursos

Esta extension define una referencia a un componente COM devuelto por la obsoleta com_load() (esta función no existe en PHP 5; en su lugar use la clase COM).


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes COM
Constante | Valor | Descripción | Observaciones
CLSCTX_INPROC_SERVER (integer) | 1 | El código que crea y administra objetos de esta clase es una DLL que se ejecuta en el mismo proceso que el llamador a la función especificando el contexto de la clase. |
CLSCTX_INPROC_HANDLER (integer) | 2 | El código que administra objetos de esta clase es un gestor "en-proceso". Es una DLL que se ejecuta en el proceso cliente e implementa estructuras del lado del cliente de esta clase cuando a las instancias de la clase se acceden de forma remota. |
CLSCTX_LOCAL_SERVER (integer) | 4 | El código EXE que crea y administra objetos de esta clase se ejecuta en la misma máquina, pero se carga en un espacio de proceso distinto. |
CLSCTX_REMOTE_SERVER (integer) | 16 | Un contexto remoto. El código que crea y administra objetos de esta clase se ejecuta en un ordenador diferente. |
CLSCTX_SERVER (integer) | 21 | Indica código de servidor, si es "en-proceso", local, o remoto. Esta definición usa el operador OR con CLSCTX_INPROC_SERVER, CLSCTX_LOCAL_SERVER, y CLSCTX_REMOTE_SERVER. |
CLSCTX_ALL (integer) | 23 | Indica todos los contextos de clase. Esta definición usa el operador OR con CLSCTX_INPROC_HANDLER y CLSCTX_SERVER. |
VT_NULL (integer) | 1 | Referencia a un puntero NULL. |
VT_EMPTY (integer) | 0 | Una propiedad con un indicador de tipo VT_EMPTY no tiene información asociada a ella; es decir, el tamaño del valor es cero. |
VT_UI1 (integer) | 17 | Integer sin signo de 1 byte. |
VT_I2 (integer) | 2 | Dos bytes que representan un integer con signo de 2 bytes. |
VT_I4 (integer) | 3 | Valor de tipo integer con signo de 4 bytes. |
VT_R4 (integer) | 4 | Valor de coma flotante IEEE de 32 bits. |
VT_R8 (integer) | 5 | Valor de coma flotante IEEE de 64 bits. |
VT_BOOL (integer) | 11 | Valor boolean. |
VT_ERROR (integer) | 10 | Código de error; contienen el código de estado asociado con el error. |
VT_CY (integer) | 6 | Integer de complemento a dos de 8 bytes (escalado por 10,000). |
VT_DATE (integer) | 7 | Un número de coma flotante de 64 bits que representa el número de días (no segundos) desde el 31 de diciembre de 1899. Por ejemplo, January 1, 1900, es 2.0, January 2, 1900, es 3.0, y así sucesivamente). Se almacena con la misma representación que VT_R8. |
VT_BSTR (integer) | 8 | Puntero a una cadena Unicode finalizada en null. |
VT_DECIMAL (integer) | 14 | Una estructura decimal. |
VT_UNKNOWN (integer) | 13 | Un puntero a un objeto que implementa al interfaz IUnknown. |
VT_DISPATCH (integer) | 9 | Se especificó un puntero a un puntero a un objeto. |
VT_VARIANT (integer) | 12 | Un indicador de tipo seguido del valor correspondiente. VT_VARIANT sólo se puede usar con VT_BYREF. |
VT_I1 (integer) | 16 | Integer con signo de 1 byte. |
VT_UI2 (integer) | 18 | Integer sin signo de 2 bytes. |
VT_UI4 (integer) | 19 | Integer sin signo de 4 bytes. |
VT_INT (integer) | 22 | Valor integer con signo de 4 bytes (equivalente a VT_I4). |
VT_UINT (integer) | 23 | Valor integer sin signo de 4 bytes (equivalente a VT_UI4). |
VT_ARRAY (integer) | 8192 | Si el indicador de tipo se combina con VT_ARRAY mediante un operador OR, el valor es un puntero a un SAFEARRAY. VT_ARRAY puede usar OR con los siguientes tipos de datos: VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_INT, VT_UINT, VT_R4, VT_R8, VT_BOOL, VT_DECIMAL, VT_ERROR, VT_CY, VT_DATE, VT_BSTR, VT_DISPATCH, VT_UNKNOWN y VT_VARIANT. |
VT_BYREF (integer) | 16384 | Si el indicador de tipo se combina con VT_BYREF mediante un operador OR, el valor es una referencia. Los tipos de referencias son interpretados como una referencia a datos, similar al tipo de referencia en C++. |
CP_ACP (integer) | 0 | Por defecto la página de código de ANSI. |
CP_MACCP (integer) | 2 | Página de código de Macintosh. |
CP_OEMCP (integer) | 1 | Por defecto la página de código de OEM. |
CP_UTF7 (integer) | 65000 | Unicode (UTF-7). |
CP_UTF8 (integer) | 65001 | Unicode (UTF-8). |
CP_SYMBOL (integer) | 42 | Traducciones de SYMBOL. |
CP_THREAD_ACP (integer) | 3 | Página de código de ANSI del hilo actual |
VARCMP_LT (integer) | 0 | El bstr izquierdo es menor que el bstr derecho. |
VARCMP_EQ (integer) | 1 | Los dos parámetros son iguales. |
VARCMP_GT (integer) | 2 | El bstr izquierdo es mayor que el bstr derecho. |
VARCMP_NULL (integer) | 3 | Ambas expresiones son NULL. |
NORM_IGNORECASE (integer) | 1 | Ignorar la sensibilidad a mayúsculas-minúsculas. |
NORM_IGNORENONSPACE (integer) | 2 | Ignorar los caracters que no son espacios. |
NORM_IGNORESYMBOLS (integer) | 4 | Ignorar los símbolos. |
NORM_IGNOREWIDTH (integer) | 131072 | Ignorar el ancho de cadena. |
NORM_IGNOREKANATYPE (integer) | 65536 | Ignorar el tipo Kana. |
NORM_IGNOREKASHIDA (integer) | 262144 | Ignorar caractares kashida árabes. | La disponibilidad depende de la biblioteca subyacente.
DISP_E_DIVBYZERO (integer) | -2147352558 | Un error devuelto que indica un error de división por cero. |
DISP_E_OVERFLOW (integer) | -2147352566 | Un error que indica que un valor no puede ser coaccionado a su representación esperada. |
MK_E_UNAVAILABLE (integer) | -2147221021 | Código de estado COM de iMoniker, devuelto en errores donde la llamada a la función falló a causa de no estar disponible. |


Errores y manejo de errores

Excepciones (PHP 5)

Esta extensión lanzará instancias de la clase com_exception siempre que haya un error potencialmente fatal notificado por COM. Todas las excepciones de COM tienen una propiedad code bien definida que se corresponde con el valor devuelto HRESULT de diferentes operaciones COM. Puede usar este código para tomar decisiones programáticas de cómo manejar la excepción.


Ejemplos

Tabla de contenidos

  • For Each
  • Arrays y propiedades estilo array de COM


For Each

Desde PHP 5 se puede usar la sentencia foreach propia de PHP para iterar sobre el contenido de un COM/OLE IEnumVariant estándar. En términos entendibles, esto significa que se puede usar foreach en lugares donde se podría usar For Each en código VB/ASP.

Ejemplo #1 For Each en ASP

<%
Set domainObject = GetObject("WinNT://Domain")
For Each obj in domainObject
  Response.Write obj.Name & "<br />"
Next
%>

Ejemplo #2 while() ... Next() en PHP 4

<?php
$domainObject = new COM("WinNT://Domain");
while ($obj = $domainObject->Next()) {
   echo $obj->Name . "<br />";
}
?>

Ejemplo #3 foreach en PHP 5

<?php
$domainObject = new COM("WinNT://Domain");
foreach ($domainObject as $obj) {
   echo $obj->Name . "<br />";
}
?>


Arrays y propiedades estilo array de COM

Muchos objetos COM exponen sus propiedades como arrays, o usan el acceso estilo array. En PHP 4 se puede usar la sintaxis de array de PHP para leer/escribir tales propiedades, pero únicamente se permite una sola dimensión. Si se quiere leer una propiedad multidimensional, en su lugar se podría hacer el acceso a la propiedad dentro de una llamada a una función, cada parámetro representando cada dimensión del acceso al array, pero no hay forma de escribir tal propiedad.

PHP 5 introduce la siguiente característica nueva para hacerle la vida más fácil:

  • Acceder a arrays multidimensionales, o propiedades COM que requieren múltiples parámetros usando la sintaxis de array de PHP. También se puede escribir o establecer propiedades usando esta técnica.

  • Iterar SafeArrays (arrays "verdaderos") usando la estructura de control foreach. Esto funciona ya que SafeArrays incluye información sobre su tamaño. Si una propiedad estilo array implementa IEnumVariant, también se puede usar foreach para esa property; eche un vistazo a For Each para más información sobre este tema.


La clase COM

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

Descripción

La clase COM permite crear una instancia de un objeto COM compatible con OLE y llamar sus métodos y aceder sus propiedades.

$obj = new COM("Application.ID")

Métodos

COM::__construct ( string $module_name , mixed $server_name = ? , int $codepage = ? , string $typelib = ? )

Constructor de la clase COM. Los parámetros tienen los siguientes significados:

module_name
Puede ser un ProgID, Class ID o Moniker que tenga el nombre del componente a cargar. Un ProgID tipicamente es el nombre de la aplicación o DLL seguido por un punto, seguido del nombre del objeto, ej.: Word.Application. Un Class ID es el UUID que identifica unívocamente una clase dada. Un Moniker es una forma especial de denominación, similar en concepto a un esquema URL, que identifica un recurso y especifica como debería ser cargado. Como ejemplo, se puede cargar Word y obtener un objeto representando un documento de word especificando el camino completo al documento de word como el nombre del módulo, o puede usar LDAP: como un moniker para usar la interfaz ADSI a LDAP.
server_name
El nombre de un servidor DCOM en donde el componente debería ser cargado y ejecutado. Si es null el objeto es ejecutado usando el predeterminado para la aplicación. Lo predeterminado típicamente es ejecutarlo sobre la máquina local, aunque el administrador puede configurar la aplicación para ejecutarlo en una máquina diferente. Si se especifica un valor distinto de null para el servidor, PHP se reusará a cargar el objeto a no ser que la opción de configuración sea true.

Si server_name es un array, este debería contener los siguientes elementos (distinguiendo mayúsculas de minúsculas!). Note que son todos opcionales (aunque se necesita especificar Username y Password juntos); si se omite el elemento Server, será usado el servidor predeterminado (como se menciona más arriba), y la creación de la instancia del objeto no será afectada por la directiva .

Nombre de servidor DCOM
server_name clave | Tipo | Descripción
Server | string | Nombre del servidor.
Username | string | El nombre de usuario para conectarse.
Password | string | La clave para Username.
Flags | integer | Una o más de las siguientes constantes, unidas por un OR lógico: CLSCTX_INPROC_SERVER, CLSCTX_INPROC_HANDLER, CLSCTX_LOCAL_SERVER, CLSCTX_REMOTE_SERVER, CLSCTX_SERVER y CLSCTX_ALL. El valor predeterminado si no se especifica aquí es CLSCTX_SERVER si tambien se omitió Server, o CLSCTX_REMOTE_SERVER si se especificó un servidor. Se debe consultar la documentación de Microsoft para CoCreateInstance para más información sobre el significado de estas constantes; típicamente nunca suelen usarse.

codepage
Especifica la página de código que es usada para convertir las cadenas a cadenas unicode y viceversa. La conversión es aplicada cuando una cadena PHP es pasada como parámetro o devuelta desde un método de este objeto COM. La página de código es pegajosa en PHP 5, lo que significa que se propaga a objetos y variantes devueltos por el objeto. Los posibles valores son CP_ACP (Usando la página de código ANSI predeterminada - si este parámetro se omite es lo predeterminado), CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP (usando la página de código/localización establecida para el hilo de ejecución actual), CP_UTF7 y CP_UTF8. Tambien puede usar el número de una página de código; consulte la documentación de Microsoft para más detalles sobre los códigos de páginas y sus valores numéricos.

Métodos sobrecargados

El objeto devuelto es un objeto sobrecargado, lo que significa que PHP no ve ningún método fijo como lo hace con las clases regulares; en su lugar, cualquier acceso de propiedad o método son pasados a través de COM.

Comenzando con PHP 5, PHP automáticamente detectará métodos que acepten parámetros por referencia, y automáticamente convertirá las variables regulares de PHP a una forma que pueden ser pasadas por referencia. Esto significa que puede llamar los métodos muy naturalmente; no hay necesidad de ningún esfuerzo extra en su código.

En PHP 4, para pasar parámetros por referencia necesita crear una instancia de la clase VARIANT para envolver los parámetros byref.

Pseudo Métodos

En versiones de PHP anteriores a 5, un número no muy agradables de trucos significaba que los siguientes nombres de métodos no sean pasados a través de COM y fueran directamente controlados por PHP. PHP 5 elimina todo esto; lea los detalles a continuación para determinar como corregir su código. Estos nombres de métodos mágicos son insensible a las mayusculas.

COM::AddRef ( ) : void

Agrega artificialmente una referencia de contador al objeto COM.

Advertencia

No debería tener necesidad de usar este método. Existe como un complemento lógico al método Release() a continuación.

COM::Release ( ) : void

Remueve artificialmente una referencia de contador al objeto COM.

Advertencia

No debería tener necesidad de usar este método. Su existencia en PHP es un error diseñado para evitar un error que mantiene objetos COM ejecutandose por más tiempo que el debido.

Pseudo Métodos para iterar

Estos pseudo métodos solo estan disponibles si com_isenum() devuelve true, en cuyo caso, esconden cualquier método con los mismos nombres que podrían ser proporcionados por el objeto COM. Estos métodos han sido eliminados en PHP 5, y debería usar For Each en su lugar.

COM::All ( ) : variant

Devuelve un variant que representa un SafeArray con 10 elementos; cada elementos será un variant vacío o null. Esta función Returns a variant representing a SafeArray that has 10 elements; each element will be an empty/null variant. This function was supposed to return an array containing all the elements from the iterator, but was never completed. Do not use.

COM::Next ( ) : variant

Devuelve un variant representando el siguiente elemento disponible en el iterador, o false cuando no hay más elementos.

COM::Prev ( ) : variant

Devuelve un variant representando el elemento anterior disponible en el iterador, o false cuando no hay más elementos.

COM::Reset ( ) : void

Retrocede el iterador hasta el principio.

Ejemplos COM

Ejemplo #1 Ejemplo COM (1)

<?php
// Iniciando word
$word = new COM("word.application") or die("No se puede crear la instancia de Word");
echo "Word cargado, versión {$word->Version}\n";

//traerlo al frente
$word->Visible = 1;

//abrir un documento vacío
$word->Documents->Add();

//hacer algunas cosas raras
$word->Selection->TypeText("Esto es una prueba...");
$word->Documents[1]->SaveAs("Prueba inutil.doc");

//cerrando word
$word->Quit();

//liberando el objeto
$word = null;
?>

Ejemplo #2 Ejemplo COM (2)

<?php

$conn = new COM("ADODB.Connection") or die("No se puede iniciar ADO");
$conn->Open("Provider=SQLOLEDB; Data Source=localhost;
Initial Catalog=database; User ID=user; Password=password");

$rs = $conn->Execute("SELECT * FROM sometable");    // Registros

$num_columns = $rs->Fields->Count();
echo $num_columns . "\n";

for ($i=0; $i < $num_columns; $i++) {
    $fld[$i] = $rs->Fields($i);
}

$rowcount = 0;
while (!$rs->EOF) {
    for ($i=0; $i < $num_columns; $i++) {
        echo $fld[$i]->value . "\t";
    }
    echo "\n";
    $rowcount++;            // incrementa rowcount
    $rs->MoveNext();
}

$rs->Close();
$conn->Close();

$rs = null;
$conn = null;

?>


La clase DOTNET

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

Descripción

La clase DOTNET le permite instanciar una clase desde un ensamble .Net y poder llamar sus métodos y acceder a sus propiedades.

$obj = new DOTNET("assembly", "classname")

Métodos

DOTNET::__construct ( string $assembly_name , string $class_name , int $codepage = ? )

Constructor de la clase DOTNET. El parámetro assembly_name especifica cual ensamble debería ser cargado, y class_name especifica cual clase instanciar en ese ensamble. Opcionalmente puede especificar un parámetro codepage para usar transformaciones de cadena unicode; vea la clase COM para más detalles en las páginas de código.

El objeto devuelto es un objeto sobrecargado, lo que significa que PHP no ve ningún método fijo como lo hace con las clases regulares; en su lugar, cualquier método o propiedad que accede se pasa por medio del COM y de allí a DOTNET. En otras palabras, el objeto .Net es mapeado a través de la capa de interoperabilidad COM provista por el runtime de .Net.

Una vez se ha creado un objeto DOTNET, PHP lo trata idénticamente como cualquier otro objeto COM; se aplican todas las mismas reglas.

Ejemplo #1 Ejemplo DOTNET

<?php
 $stack = new DOTNET("mscorlib", "System.Collections.Stack");
 $stack->Push(".Net");
 $stack->Push("Hello ");
 echo $stack->Pop() . $stack->Pop();
?>

Nota:

Necesita instalar el runtime de .Net en su servidor web para tomar las ventajas de esta característica.


La clase VARIANT

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

Descripción

La clase VARIANT es un equivalente de COM para el PHP zval; es una estructura que puede contener un valor con un rango de diferentes tipos posibles. La clase VARIANT suministrada por la extensión COM, permite tener un mayor control sobre el modo en que PHP pasa los valores hacia y desde COM.

$vVar = new VARIANT($var)

Métodos

VARIANT::VARIANT ( mixed $value = ? , int $type = ? , int $codepage = ? )

constructor de clase VARIANT. Parámetros:

value
valor inicial. si se omite, o se le da valor null se creará un objeto vacío VT_EMPTY.
type
especifica el tipo de objeto VARIANT contenido. Los valores posibles son una de las constantes VT_XXX Constantes predefinidas. En versiones PHP anteriores a PHP 5, se puede forzar a PHP para que pase un objeto VARIANT por referencia, combinando VT_BYREF con el operador OR y el parámetro type. En PHP 5, este hack no está soportado; en lugar de eso, PHP 5 puede detectar los parámetros pasados por referencia automáticamente; ni siquiera es necesario pasarlos como objetos VARIANT. Consultar la biblioteca MSDN para información adicional sobre el tipo VARIANT.
codepage
especifica la página de códigos que se utilizará para convertir los strings a unicode. Ver el parámetro del mismo nombre en la clase COM para más información.

Las versiones PHP anteriores a PHP 5 definen un número de propiedades virtuales (no documentadas) para las instancias de la clase VARIANT; estas propiedades han sido eliminadas en PHP 5 en favor de una sintaxis más natural; estas diferencias se ilustran mejor con el siguiente ejemplo:

Ejemplo #1 Ejemplo de una clase VARIANT, utilizada en PHP 4.x

<?php
$v = new VARIANT(42);
print "El tipo es " . $v->type . "<br/>";
print "El valor es " . $v->value . "<br/>";
?>

Ejemplo #2 Ejemplo de una clase VARIANT, utilizada en PHP 5

<?php
$v = new VARIANT(42);
print "El tipo es " . variant_get_type($v) . "<br/>";
print "El valor es " . $v . "<br/>";
?>

La razón para este cambio es que, internamente, la extensión COM ve a las clases VARIANT, COM y DOTNET como la misma cosa, y la filosofía de diseño para estas clases es que todos los accesos a las propiedades y los miembros se transmiten a través de COM sin ninguna interferencia. La nueva sintaxis es más natural y requiere menos esfuerzo, y muchas de las propiedades virtuales eliminadas ya no tienen sentido en un contexto PHP.

Nota:

PHP 5 toma una aproximación mucho más simple en la gestión de VARIANTs; cuando se devuelve un valor o se carga una propiedad VARIANT, ésta se convierte en un valor PHP únicamente cuando hay un mapeo directo entre los tipos de tal forma que no se pierda información. En todos los otros casos, el resultado es devuelto como una instancia de la clase VARIANT. Se puede forzar a PHP para convertir o evaluar la clase VARIANT como un tipo nativo PHP utilizando un operador para clasificarla explícitamente, o implícitamente como un string con la función print. Es posible utilizar el amplio rango de funciones VARIANT para realizar operaciones aritméticas en VARIANTS sin forzar una conversión o arriesgarse a una pérdida de información.

Ver también la función variant_get_type().


La clase COMPersistHelper

(PHP 5, PHP 7, PHP 8)

Introducción

COMPersistHelper mejora la interoperabilidad de COM y PHP con respecto a la directiva php.ini open_basedir, y stream recursos.

Sinopsis de la Clase

final COMPersistHelper {
/* Métodos */
public __construct ( variant|null $variant = null )
public GetCurFileName ( ) : string|false
public GetMaxStreamSize ( ) : int
public InitNew ( ) : bool
public LoadFromFile ( string $filename , int $flags = 0 ) : bool
public LoadFromStream ( resource $stream ) : bool
public SaveToFile ( string|null $filename , bool $remember = true ) : bool
public SaveToStream ( resource $stream ) : bool
}

Tabla de contenidos

  • COMPersistHelper::__construct — Construct a COMPersistHelper object
  • COMPersistHelper::GetCurFileName — Get current filename
  • COMPersistHelper::GetMaxStreamSize — Get maximum stream size
  • COMPersistHelper::InitNew — Initialize object to default state
  • COMPersistHelper::LoadFromFile — Load object from file
  • COMPersistHelper::LoadFromStream — Load object from stream
  • COMPersistHelper::SaveToFile — Save object to file
  • COMPersistHelper::SaveToStream — Save object to stream


Construct a COMPersistHelper object

  • « COMPersistHelper
  • COMPersistHelper::GetCurFileName »
  • PHP Manual
  • COMPersistHelper
  • Construct a COMPersistHelper object

COMPersistHelper::__construct

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::__construct — Construct a COMPersistHelper object

Descripción

public COMPersistHelper::__construct ( variant|null $variant = null )

Constructs a persistence helper object, usually associated with a variant.

Parámetros

variant
A COM object which implements IDispatch. To be able to successfully call any of COMPersistHelper's methods, the object has to implement IPersistFile, IPersistStream and/or IPersistStreamInit. Passing null as variant is only useful if the object is to be loaded from a stream by calling COMPersistHelper::LoadFromStream().


Get current filename

  • « COMPersistHelper::__construct
  • COMPersistHelper::GetMaxStreamSize »
  • PHP Manual
  • COMPersistHelper
  • Get current filename

COMPersistHelper::GetCurFileName

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::GetCurFileName — Get current filename

Descripción

public COMPersistHelper::GetCurFileName ( ) : string|false

Retrieves the current name of the file associated with the object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the current name of the file associated with the object.

Errores/Excepciones

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::GetCurFile() method failed.


Get maximum stream size

  • « COMPersistHelper::GetCurFileName
  • COMPersistHelper::InitNew »
  • PHP Manual
  • COMPersistHelper
  • Get maximum stream size

COMPersistHelper::GetMaxStreamSize

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::GetMaxStreamSize — Get maximum stream size

Descripción

public COMPersistHelper::GetMaxStreamSize ( ) : int

Retrieves the size of the stream (in bytes) needed to save the object.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the size of the stream (in bytes) needed to save the object.

Errores/Excepciones

A com_exception is thrown if the associated object does neither implement the COM interface IPersistStream nor IPersistStreamInit, or when calling the IPersistStream::GetSizeMax() method failed.


Initialize object to default state

  • « COMPersistHelper::GetMaxStreamSize
  • COMPersistHelper::LoadFromFile »
  • PHP Manual
  • COMPersistHelper
  • Initialize object to default state

COMPersistHelper::InitNew

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::InitNew — Initialize object to default state

Descripción

public COMPersistHelper::InitNew ( ) : bool

Initializes an object to a default state.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

A com_exception is thrown if the associated object does not implement the COM interface IPersistStreamInit, or when calling its IPersistStreamInit::Init() method failed.


Load object from file

  • « COMPersistHelper::InitNew
  • COMPersistHelper::LoadFromStream »
  • PHP Manual
  • COMPersistHelper
  • Load object from file

COMPersistHelper::LoadFromFile

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::LoadFromFile — Load object from file

Descripción

public COMPersistHelper::LoadFromFile ( string $filename , int $flags = 0 ) : bool

Opens the specified file and initializes an object from the file contents.

Parámetros

filename
The name of the file from which to load the object.
flags
The access mode to be used when opening the file. Possible values are taken from the » STGM enumeration. The method can treat this value as a suggestion, adding more restrictive permissions if necessary. If flags is 0, the implementation is supposed to open the file using whatever default permissions are used when a user opens the file.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::Load() method failed.


Load object from stream

  • « COMPersistHelper::LoadFromFile
  • COMPersistHelper::SaveToFile »
  • PHP Manual
  • COMPersistHelper
  • Load object from stream

COMPersistHelper::LoadFromStream

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::LoadFromStream — Load object from stream

Descripción

public COMPersistHelper::LoadFromStream ( resource $stream ) : bool

Initializes an object from the stream where it was saved previously.

Parámetros

stream
The stream recurso from which to load the object.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

A com_exception is thrown if the associated object does not implement the COM interface IPersistStream, or when calling the IPersistStream::Load() method failed.


Save object to file

  • « COMPersistHelper::LoadFromStream
  • COMPersistHelper::SaveToStream »
  • PHP Manual
  • COMPersistHelper
  • Save object to file

COMPersistHelper::SaveToFile

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::SaveToFile — Save object to file

Descripción

public COMPersistHelper::SaveToFile ( string|null $filename , bool $remember = true ) : bool

Saves a copy of the object to the specified file.

Parámetros

filename
The name of the file to which to save the object.
remember
Indicates whether the filename parameter is to be used as the current working file. If true, filename becomes the current file and the object is supposed to clear its dirty flag after the save. If false, this save operation is a "Save A Copy As ..." operation. In this case, the current file is unchanged and the object is not supposed to clear its dirty flag.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::Save() method failed.

Ejemplos

Ejemplo #1 Basic COMPersistHelper::saveToFile() Usage

<?php
$word = new COM('Word.Application');
$doc = $word->Documents->Add();
$ph = new COMPersistHelper($doc);
$ph->SaveToFile('C:\\Users\\cmb\\Documents\\my.docx');
$word->Quit();
?>


Save object to stream

  • « COMPersistHelper::SaveToFile
  • com_exception »
  • PHP Manual
  • COMPersistHelper
  • Save object to stream

COMPersistHelper::SaveToStream

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::SaveToStream — Save object to stream

Descripción

public COMPersistHelper::SaveToStream ( resource $stream ) : bool

Saves an object to the specified stream.

Parámetros

stream
The stream recurso to which to save the object.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

A com_exception is thrown if the associated object does neither implement the COM interface IPersistStream nor IPersistStreamInit, or when calling the IPersistStream::Save() method failed.


La clase com_exception

(PHP 5, PHP 7, PHP 8)

Introducción

Sinopsis de la Clase

com_exception extends Exception implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Funciones de COM

Ver también

Para más información sobre COM lea la » Especificación COM. Puede encontrar alguna información adicional útil en nuestra FAQ de PHP y COM. Si está pensando usar aplicaciones de MS Office en el lado del servidor, debería leer la información aquí: » Considerations for Server-Side Automation of Office.

Tabla de contenidos

  • com_create_guid — Generar un identificador único globalmente (GUID)
  • com_event_sink — Conectar eventos de un objeto COM a un objeto PHP
  • com_get_active_object — Devuelve un gestor a una instancia de un objeto COM ya en ejecución
  • com_load_typelib — Carga una biblioteca de tipos
  • com_message_pump — Procesar mensajes COM, durmiendo hata timeoutms milisegundos
  • com_print_typeinfo — Imprime una definición de clase de PHP para una interfaz despachable
  • variant_abs — Devuelve el valor absoluto de una variante
  • variant_add — "Suma" dos variantes y devuelve el resultado
  • variant_and — Realiza una operación AND a nivel de bits entre dos variantes
  • variant_cast — Convertir una variante en un nuevo objeto variante de otro tipo
  • variant_cat — Concatena dos valores de variantes y devuelve el resultado
  • variant_cmp — Compara dos variantes
  • variant_date_from_timestamp — Devuelve una representación de variante de fecha de una fecha Unix
  • variant_date_to_timestamp — Convierte un valor de una variante de fecha/hora en una fecha Unix
  • variant_div — Devuelve el resultado de dividir dos variantes
  • variant_eqv — Realiza una equivalencia a nivel de bits en dos variantes
  • variant_fix — Devuelve la parte entera de una variante
  • variant_get_type — Devuelve el tipo de un objeto variante
  • variant_idiv — Convierte variantes a enteros y después devuelve el resultado dividiéndolos
  • variant_imp — Realiza una implicación a nivel de bits de dos variantes
  • variant_int — Devuelve la parte entera de una variante
  • variant_mod — Divide dos variantes y devuelve sólo el resto
  • variant_mul — Multiplica los valores de dos variantes
  • variant_neg — Realiza una negación lógica de una variante
  • variant_not — Realiza una negación NOT a nivel de bits en una variante
  • variant_or — Realiza una disyunción lógica de dos variantes
  • variant_pow — Devuelve el resultado de realizar la exponenciación con dos variantes
  • variant_round — Redondea una variante al número de lugares decimales especificado
  • variant_set_type — Convierte una variante en otro tipo "in situ"
  • variant_set — Asigna un nuevo valor para un objeto variante
  • variant_sub — Resta el valor de la variante derecha del valor de la varienta izquierda
  • variant_xor — Realiza una exclución lógica de dos variantes


Generar un identificador único globalmente (GUID)

  • « Funciones de COM
  • com_event_sink »
  • PHP Manual
  • Funciones de COM
  • Generar un identificador único globalmente (GUID)

com_create_guid

(PHP 5, PHP 7, PHP 8)

com_create_guid — Generar un identificador único globalmente (GUID)

Descripción

com_create_guid ( ) : string

Genera un identificador único globalmente (GUID: Globally Unique Identifier).

Un GUID es generado de la misma manera que el DCE UUID, excepto que la convención de Microsoft encierra un GUID entre llaves.

Valores devueltos

Devuelve el GUID como cadena.

Ver también

  • uuid_create() en la extensión uuid de PECL


Conectar eventos de un objeto COM a un objeto PHP

  • « com_create_guid
  • com_get_active_object »
  • PHP Manual
  • Funciones de COM
  • Conectar eventos de un objeto COM a un objeto PHP

com_event_sink

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_event_sink — Conectar eventos de un objeto COM a un objeto PHP

Descripción

com_event_sink ( variant $comobject , object $sinkobject , mixed $sinkinterface = ? ) : bool

Ordena a COM que eventos generados por comobject sean absorbidos por el objeto PHP sinkobject.

Tenga cuidado en cómo use esta característica; si está haciendo algo similar al ejemplo de abajo, no tiene sentido ejecutarla en un contexto de servidor web.

Parámetros

comobject

sinkobject

sinkobject debería ser una instancia de una clase con métodos nombrados después de aquellos de la dispinterfaz deseada; se puede usar com_print_typeinfo() para ayudar a generar una clase plantilla para este propósito.

sinkinterface

PHP intentará usar el tipo de dispinterfaz predeterminado especificado por la biblioteca de tipos asociada con comobject, pero se puede sobrescribir esta opción estableciendo sinkinterface al nombre de la dispinterfaz que se desea usar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de absorción de un evento COM

<?php
class IEEventSinker {
    var $terminated = false;

   function ProgressChange($progress, $progressmax) {
      echo "Download progress: $progress / $progressmax\n";
    }

    function DocumentComplete(&$dom, $url) {
      echo "Document $url complete\n";
    }

    function OnQuit() {
      echo "Quit!\n";
      $this->terminated = true;
    }
}
$ie = new COM("InternetExplorer.Application");
// note that you don't need the & for PHP 5!
$sink = new IEEventSinker();
com_event_sink($ie, $sink, "DWebBrowserEvents2");
$ie->Visible = true;
$ie->Navigate("http://www.example.org");
while(!$sink->terminated) {
  com_message_pump(4000);
}
$ie = null;
?>

Ver también

  • com_print_typeinfo() - Imprime una definición de clase de PHP para una interfaz despachable
  • com_message_pump() - Procesar mensajes COM, durmiendo hata timeoutms milisegundos


Devuelve un gestor a una instancia de un objeto COM ya en ejecución

  • « com_event_sink
  • com_load_typelib »
  • PHP Manual
  • Funciones de COM
  • Devuelve un gestor a una instancia de un objeto COM ya en ejecución

com_get_active_object

(PHP 5, PHP 7, PHP 8)

com_get_active_object — Devuelve un gestor a una instancia de un objeto COM ya en ejecución

Descripción

com_get_active_object ( string $progid , int $code_page = ? ) : variant

com_get_active_object() es similar a crear una nueva instancia de un objeto COM, excepto que sólo devolverá un objeto a su script si el objeto ya está en ejecución. Las aplicaciones OLE usan algo conocido como la "Tabla de Objetos en Ejecución" para permitir a las famosas aplicaciones que se lancen solo una vez; esta función expone la función de la biblioteca COM, GetActiveObject(), para obtener un gestor sobre una instancia en ejecución.

Parámetros

progid

progid puede ser el ProgID o el CLSID del objeto al que se quiere acceder (por ejemplo Word.Application).

code_page

Actúa exactamente de la misma forma que lo hace la clase COM.

Valores devueltos

Si el objeto solicitado está ejecutándose será devuelto a su script al igual que otro objeto COM.

Errores/Excepciones

Existen diversas razones para que esta función pueda fallar, la más común siendo que el objeto no está ejecutándose aún. En esta situación, el código de error de excepción será MK_E_UNAVAILABLE; se puede usar el método getCode del objeto excepción para comprobar el código de excepción.

Notas

Advertencia

Usar com_get_active_object() en un contexto de servidor web no es siempre una idea inteligente. La mayoría de las aplicaciones COM/OLE no están diseñadas para tratar más de un cliente al mismo tiempo, incluso (¡o especialmente!) Microsoft Office. Debería leer » Consideraciones para la Automatización del Lado del Servidor de Office para más información sobre los temas generales involucrados.


Carga una biblioteca de tipos

  • « com_get_active_object
  • com_message_pump »
  • PHP Manual
  • Funciones de COM
  • Carga una biblioteca de tipos

com_load_typelib

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

com_load_typelib — Carga una biblioteca de tipos

Descripción

com_load_typelib ( string $typelib_name , bool $case_insensitive = true ) : bool

Carga una biblioteca de tipos y registra sus constantes en la máquina, como si fueran definidas usando define().

Observe que es más efectivo usar el ajuste de configuración para pre-cargar y registrar las constantes, aunque no es tan flexible.

Si se ha activado , PHP intenrá registrar automáticamente las constantes asociadas con un objeto COM cuando se instancie. Esto depende de las interfaces proporcionadas por el propio objeto COM, y no siempre puede ser posible.

Parámetros

typelib_name

typelib_name puede ser uno de los siguientes:

  • El nombre de fichero de un fichero .tlb o el módulo ejecutable que contiente la biblioteca de tipos.

  • El GUID de la biblioteca de tipos, seguido de su número de versión, por ejemplo {00000200-0000-0010-8000-00AA006D2EA4},2,0.

  • El nombre de la biblioteca de tipos, p.ej. Microsoft OLE DB ActiveX Data Objects 1.0 Library.

PHP intentará resolver la biblioteca de tipos en este orden, mientras que el proceso se hace más costoso a medida que se baja por la lista; buscar la biblioteca de tipos por nombre se trata físicamente enumerando el registro hasta que se encuentre una coincidencia.

case_insensitive

case_insensitive se comporta de la misma manera que el parámetro con el mismo nombre de la función define().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Procesar mensajes COM, durmiendo hata timeoutms milisegundos

  • « com_load_typelib
  • com_print_typeinfo »
  • PHP Manual
  • Funciones de COM
  • Procesar mensajes COM, durmiendo hata timeoutms milisegundos

com_message_pump

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_message_pump — Procesar mensajes COM, durmiendo hata timeoutms milisegundos

Descripción

com_message_pump ( int $timeoutms = 0 ) : bool

Esta función duerme hasta timeoutms milisegundos, o hasta que llegue un mensaje a la cola.

El propósito de esta función es guiar las llamadas COM entre departamentos y tratar varios temas de sincronización. Permite a su script esperar de manera eficiente a eventos que van a ser desencadenados, mientras que todavía trata otros evetntos o ejecuta otro código en segundo plano. Debería usarla en un bucle, como se demostró en el ejemplo de la función com_event_sink(), hasta que finalice usando objetos COM de límite de eventos.

Parámetros

timeoutms

El tiempo límite, en milisegundos.

Si no se especifica un valor para timeoutms, se asumirá 0. Un valor de 0 significa que no se realizará ninguna espera; si hay mensajes pendientes serán despachados cuanto antes; si no hay mensajes pendientes, la función devolverá false immediatamente sin dormir.

Valores devueltos

Si un mensaje o mensajes llegan antes del tiempo límite, serán despachados y la función devolverá true. Si se agota el tiempo límite y no se procesaron mensajes, el valor devuelto será false.


Imprime una definición de clase de PHP para una interfaz despachable

  • « com_message_pump
  • variant_abs »
  • PHP Manual
  • Funciones de COM
  • Imprime una definición de clase de PHP para una interfaz despachable

com_print_typeinfo

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_print_typeinfo — Imprime una definición de clase de PHP para una interfaz despachable

Descripción

com_print_typeinfo ( object $comobject , string $dispinterface = ? , bool $wantsink = false ) : bool

El propósito de esta función es ayudar a generar una clase esqueleto para usarla como absorción de eventos. También se puede usar para generar una copia de cualquier objeto COM, siempre que soporte lo suficiente las interfaces de introspección, y que usted sepa el nombre de la interfaz que quiere mostrar.

Parámetros

comobject

comobject debería ser una instancia de un objeto COM, o el nombre de una biblioteca de tipos (que será resuelta según el conjunto de reglas de com_load_typelib()).

dispinterface

El nombre de una interfaz descendiente de IDispatch que se quiere mostrar.

wantsink

Si se establece a true, en su lugar se mostrará la interfaz de absorción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • com_event_sink() - Conectar eventos de un objeto COM a un objeto PHP
  • com_load_typelib() - Carga una biblioteca de tipos


Devuelve el valor absoluto de una variante

  • « com_print_typeinfo
  • variant_add »
  • PHP Manual
  • Funciones de COM
  • Devuelve el valor absoluto de una variante

variant_abs

(PHP 5, PHP 7, PHP 8)

variant_abs — Devuelve el valor absoluto de una variante

Descripción

variant_abs ( mixed $val ) : mixed

Devuelve el valor absoluto de una variante.

Parámetros

val

La variante.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el valor absoluto de val.

Ver también

  • abs() - Valor absoluto


"Suma" dos variantes y devuelve el resultado

  • « variant_abs
  • variant_and »
  • PHP Manual
  • Funciones de COM
  • "Suma" dos variantes y devuelve el resultado

variant_add

(PHP 5, PHP 7, PHP 8)

variant_add — "Suma" dos variantes y devuelve el resultado

Descripción

variant_add ( mixed $left , mixed $right ) : mixed

Suma left a right usando las siguientes reglas (tomadas de la biblioteca MSDN), que se corresponden a aquellas de Visual Basic:

Reglas de Adición de Variantes
Si | Entonces
Ambas expresiones son de tipo cadena | Concatenación
Una expresión es de tipo cadena y la otra un carácter | Adición
Una expresión es numérica y la otra es una cadena | Adición
Ambas expresiones son numéricas | Adición
Alguna expresión es NULL | Se devuelve NULL
Ambas expresiones están vacías | Se devuelve un subtipo integer

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el resultado.

Ver también

  • variant_sub() - Resta el valor de la variante derecha del valor de la varienta izquierda


Realiza una operación AND a nivel de bits entre dos variantes

  • « variant_add
  • variant_cast »
  • PHP Manual
  • Funciones de COM
  • Realiza una operación AND a nivel de bits entre dos variantes

variant_and

(PHP 5, PHP 7, PHP 8)

variant_and — Realiza una operación AND a nivel de bits entre dos variantes

Descripción

variant_and ( mixed $left , mixed $right ) : mixed

Realiza una operación AND a nivel de bits. Observer que esto difiere ligeramente de una operación AND normal.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de Aplicar AND a Variantes
Si left es | Si right es | entonces el resultado es
true | true | true
true | false | false
true | null | null
false | true | false
false | false | false
false | null | false
null | true | null
null | false | false
null | null | null

Ver también

  • variant_or() - Realiza una disyunción lógica de dos variantes


Convertir una variante en un nuevo objeto variante de otro tipo

  • « variant_and
  • variant_cat »
  • PHP Manual
  • Funciones de COM
  • Convertir una variante en un nuevo objeto variante de otro tipo

variant_cast

(PHP 5, PHP 7, PHP 8)

variant_cast — Convertir una variante en un nuevo objeto variante de otro tipo

Descripción

variant_cast ( variant $variant , int $type ) : variant

Esta función hace una copia de variant y realiza una operación de conversión de variante para forzar a la copia a tener el tipo dado por type.

Esta función envuelve VariantChangeType() de la biblioteca COM; consulte MSDN para más información.

Parámetros

variant

La variante.

type

type debería ser una de las constantes VT_XXX.

Valores devueltos

Devuelve una variante VT_DATE.

Ver también

  • variant_set_type() - Convierte una variante en otro tipo "in situ"


Concatena dos valores de variantes y devuelve el resultado

  • « variant_cast
  • variant_cmp »
  • PHP Manual
  • Funciones de COM
  • Concatena dos valores de variantes y devuelve el resultado

variant_cat

(PHP 5, PHP 7, PHP 8)

variant_cat — Concatena dos valores de variantes y devuelve el resultado

Descripción

variant_cat ( mixed $left , mixed $right ) : mixed

Concatena left con right y devuelve el resultado.

Esta función es en teoría equivalente a $left . $right.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el resultado de la concatenación.

Ver también

  • Operadores para strings para el operador de concatenación de cadenas


Compara dos variantes

  • « variant_cat
  • variant_date_from_timestamp »
  • PHP Manual
  • Funciones de COM
  • Compara dos variantes

variant_cmp

(PHP 5, PHP 7, PHP 8)

variant_cmp — Compara dos variantes

Descripción

variant_cmp ( mixed $left , mixed $right , int $lcid = ? , int $flags = ? ) : int

Compara left con right.

Esta fucnión sólo comparará valores escalares, no arrays o registros de variantes.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

lcid

Un Identificador Regional válido a usar cuando se comparan cadenas (esto afecta a la compaginación de cadenas).

flags

flags puede ser uno o más de los siguientes valores usando OR entre ellos, y afecta a la comparación de cadenas:

Banderas de Comparación de Variantes
valor | significado
NORM_IGNORECASE | Comparara de forma insensible a mayúsculas-minúsculas
NORM_IGNORENONSPACE | Ignorar caracteres que no son de espacio
NORM_IGNORESYMBOLS | Ignorar símbolos
NORM_IGNOREWIDTH | Ignorar el ancho de cadena
NORM_IGNOREKANATYPE | Ignorar el tipo Kana
NORM_IGNOREKASHIDA | Ignorar caracteras kashida arábigos

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve un valor de los siguientes:

Resultados de la Comparación de Variantes
valor | significado
VARCMP_LT | left es menor que right
VARCMP_EQ | left es igual que right
VARCMP_GT | left es mayor que right
VARCMP_NULL | left o, right o ambos son null


Devuelve una representación de variante de fecha de una fecha Unix

  • « variant_cmp
  • variant_date_to_timestamp »
  • PHP Manual
  • Funciones de COM
  • Devuelve una representación de variante de fecha de una fecha Unix

variant_date_from_timestamp

(PHP 5, PHP 7, PHP 8)

variant_date_from_timestamp — Devuelve una representación de variante de fecha de una fecha Unix

Descripción

variant_date_from_timestamp ( int $timestamp ) : variant

Convierte timestamp desde un valor de fecha unix a una variante de tipo VT_DATE. Permite la interpolación más sencilla entre las partes unix de PHP y COM.

Parámetros

timestamp

Una fecha unix.

Valores devueltos

Devuelve una variante VT_DATE.

Ver también

  • variant_date_to_timestamp() - Convierte un valor de una variante de fecha/hora en una fecha Unix
  • mktime() - Obtener la marca de tiempo Unix de una fecha
  • time() - Devuelve la fecha Unix actual


Convierte un valor de una variante de fecha/hora en una fecha Unix

  • « variant_date_from_timestamp
  • variant_div »
  • PHP Manual
  • Funciones de COM
  • Convierte un valor de una variante de fecha/hora en una fecha Unix

variant_date_to_timestamp

(PHP 5, PHP 7, PHP 8)

variant_date_to_timestamp — Convierte un valor de una variante de fecha/hora en una fecha Unix

Descripción

variant_date_to_timestamp ( variant $variant ) : int

Convierte variant desde un valor VT_DATE (o similar) a una fecha Unix. Permite la interoperabilidad más sencilla entre las partes Unix de PHP y COM.

Parámetros

variant

La variante.

Valores devueltos

Devuelve una fecha unix.

Ver también

  • variant_date_from_timestamp() - Devuelve una representación de variante de fecha de una fecha Unix
  • date() - Dar formato a la fecha/hora local
  • strftime() - Formatea una fecha/hora local según una configuración local


Devuelve el resultado de dividir dos variantes

  • « variant_date_to_timestamp
  • variant_eqv »
  • PHP Manual
  • Funciones de COM
  • Devuelve el resultado de dividir dos variantes

variant_div

(PHP 5, PHP 7, PHP 8)

variant_div — Devuelve el resultado de dividir dos variantes

Descripción

variant_div ( mixed $left , mixed $right ) : mixed

Divide left entre right y devuelve el resultado.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de División de Variantes
Si | Entonces
Ambas expresiones son de tipo cadena, fecha, carácter, booleano | Se devuelve un valor de tipo double
Una expresión es una cadena y la otra un carácter | División y se devuelve un valor de tipo double
Una expresión es numérica y la otra es una cadena | División y se devuelve un valor de tipo double
Ambas expresiones son numéricas | División y se devuelve un valor de tipo double
Alguna de las expresiones es NULL | Se devuelve NULL
right está vacía y left es cualquier otra cosa menos vacía | Se lanza una com_exception con código DISP_E_DIVBYZERO
left está vacía y right es cualquier otra cosa menos vacía | Se devuelve 0 de tipo double
Ambas expresiones están vacías | Se lanza una com_exception con código DISP_E_OVERFLOW

Ver también

  • variant_idiv() - Convierte variantes a enteros y después devuelve el resultado dividiéndolos


Realiza una equivalencia a nivel de bits en dos variantes

  • « variant_div
  • variant_fix »
  • PHP Manual
  • Funciones de COM
  • Realiza una equivalencia a nivel de bits en dos variantes

variant_eqv

(PHP 5, PHP 7, PHP 8)

variant_eqv — Realiza una equivalencia a nivel de bits en dos variantes

Descripción

variant_eqv ( mixed $left , mixed $right ) : mixed

Realiza una equivalencia a nivel de bits en dos variantes.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Si cada bit de left es igual al bit correspondiente de right se devuelve true, si no se devuelve false.


Devuelve la parte entera de una variante

  • « variant_eqv
  • variant_get_type »
  • PHP Manual
  • Funciones de COM
  • Devuelve la parte entera de una variante

variant_fix

(PHP 5, PHP 7, PHP 8)

variant_fix — Devuelve la parte entera de una variante

Descripción

variant_fix ( mixed $variant ) : mixed

Obtiene la parte entera de una variante.

Parámetros

variant

La variante.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Si variant es negativo, se devuelve el primer entero negativo mayor o igual que la variante, de otro modo se devuelve la parte entera del valor de variant.

Notas

Advertencia

Esta documentación está basada en la documentación de MSDN; parece que esta función o es la misma que variant_int(), o existe un error en la documentación de MSDN.

Ver también

  • variant_int() - Devuelve la parte entera de una variante
  • variant_round() - Redondea una variante al número de lugares decimales especificado
  • floor() - Redondear fracciones hacia abajo
  • ceil() - Redondear fracciones hacia arriba
  • round() - Redondea un float


Devuelve el tipo de un objeto variante

  • « variant_fix
  • variant_idiv »
  • PHP Manual
  • Funciones de COM
  • Devuelve el tipo de un objeto variante

variant_get_type

(PHP 5, PHP 7, PHP 8)

variant_get_type — Devuelve el tipo de un objeto variante

Descripción

variant_get_type ( variant $variant ) : int

Devuelve el tipo de un objeto variante.

Parámetros

variant

El objeto variante.

Valores devueltos

Esta función devuelve un valor de tipo integer que indica el tipo de variant, que puede ser una instancia de las clases COM, DOTNET o VARIANT. El valor devuelto puede ser comparado con una de las constantes VT_XXX.

El valor devuelto para objetos COM y DOTNET será normalmente VT_DISPATCH; la única razón de que esta función funcione con estas clases es que COM y DOTNET son descendientes de VARIANT.

En versiones de PHP anteriores a 5 se podría obtener esta información ÚNICAMENTE desde instancias de la clase VARIANT, leyendo una propiedad type falsa. Véase la clase VARIANT para más información sobre esto.


Convierte variantes a enteros y después devuelve el resultado dividiéndolos

  • « variant_get_type
  • variant_imp »
  • PHP Manual
  • Funciones de COM
  • Convierte variantes a enteros y después devuelve el resultado dividiéndolos

variant_idiv

(PHP 5, PHP 7, PHP 8)

variant_idiv — Convierte variantes a enteros y después devuelve el resultado dividiéndolos

Descripción

variant_idiv ( mixed $left , mixed $right ) : mixed

Convierte left y right a valores de tipo integer, y después realiza la división entera.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de División Entera de Variantes
Si | Entonces
Ambas expresiones son de tipo cadena, fecha, carácter, booleano | División y se devuelve un entero
Una expresión es de tipo cadena y la otra un carácter | División
Una expresión es numérica y la otra es una cadena | División
Ambas expresiones son numéricas | División
Alguna de las expresiones es NULL | Se devuelve NULL
Ambas expresiones están vacías | Se lanza una com_exception con código DISP_E_DIVBYZERO

Ver también

  • variant_div() - Devuelve el resultado de dividir dos variantes


Realiza una implicación a nivel de bits de dos variantes

  • « variant_idiv
  • variant_int »
  • PHP Manual
  • Funciones de COM
  • Realiza una implicación a nivel de bits de dos variantes

variant_imp

(PHP 5, PHP 7, PHP 8)

variant_imp — Realiza una implicación a nivel de bits de dos variantes

Descripción

variant_imp ( mixed $left , mixed $right ) : mixed

Realiza una operación de implicación a nivel de bits.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Tabla de Implicación de Variantes
Si left es | Si right es | entonces el resultado es
true | true | true
true | false | true
true | null | true
false | true | true
false | false | true
false | null | true
null | true | true
null | false | null
null | null | null


Devuelve la parte entera de una variante

  • « variant_imp
  • variant_mod »
  • PHP Manual
  • Funciones de COM
  • Devuelve la parte entera de una variante

variant_int

(PHP 5, PHP 7, PHP 8)

variant_int — Devuelve la parte entera de una variante

Descripción

variant_int ( mixed $variant ) : mixed

Obtiene la parte entera de una variante.

Parámetros

variant

La variante.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Si variant es negativo, se devuelve el primer entero negativo mayor o igual a la variante, de otro modo se devuelve la parte entera del valor de variant.

Ver también

  • variant_fix() - Devuelve la parte entera de una variante
  • variant_round() - Redondea una variante al número de lugares decimales especificado
  • floor() - Redondear fracciones hacia abajo
  • ceil() - Redondear fracciones hacia arriba
  • round() - Redondea un float


Divide dos variantes y devuelve sólo el resto

  • « variant_int
  • variant_mul »
  • PHP Manual
  • Funciones de COM
  • Divide dos variantes y devuelve sólo el resto

variant_mod

(PHP 5, PHP 7, PHP 8)

variant_mod — Divide dos variantes y devuelve sólo el resto

Descripción

variant_mod ( mixed $left , mixed $right ) : mixed

Divide left entre right y devuelve el resto.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el resto de la división.

Ver también

  • variant_div() - Devuelve el resultado de dividir dos variantes
  • variant_idiv() - Convierte variantes a enteros y después devuelve el resultado dividiéndolos


Multiplica los valores de dos variantes

  • « variant_mod
  • variant_neg »
  • PHP Manual
  • Funciones de COM
  • Multiplica los valores de dos variantes

variant_mul

(PHP 5, PHP 7, PHP 8)

variant_mul — Multiplica los valores de dos variantes

Descripción

variant_mul ( mixed $left , mixed $right ) : mixed

Multiplica left por right.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Los valores booleanos son convertidos a -1 para false y 0 para true.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de Multiplicación de Variantes
Si | Entonces
Ambas expresiones son de tipo cadena, fecha, carácter, boolean | Multiplicación
Una expresión es de tipo cadena y la otra un carácter | Multiplicación
Una expresión es numérica y la otra una cadena | Multiplicación
Ambas expresiones son numéricas | Multiplicación
Alguna de las expresiones es NULL | Se devuelve NULL
Ambas expresiones están vacías | Se devuelve una cadena vacía

Ver también

  • variant_div() - Devuelve el resultado de dividir dos variantes
  • variant_idiv() - Convierte variantes a enteros y después devuelve el resultado dividiéndolos


Realiza una negación lógica de una variante

  • « variant_mul
  • variant_not »
  • PHP Manual
  • Funciones de COM
  • Realiza una negación lógica de una variante

variant_neg

(PHP 5, PHP 7, PHP 8)

variant_neg — Realiza una negación lógica de una variante

Descripción

variant_neg ( mixed $variant ) : mixed

Realiza una negación lógica de variant.

Parámetros

variant

La variante.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el resultado de la negación lógica.


Realiza una negación NOT a nivel de bits en una variante

  • « variant_neg
  • variant_or »
  • PHP Manual
  • Funciones de COM
  • Realiza una negación NOT a nivel de bits en una variante

variant_not

(PHP 5, PHP 7, PHP 8)

variant_not — Realiza una negación NOT a nivel de bits en una variante

Descripción

variant_not ( mixed $variant ) : mixed

Realiza una negación NOT a nivel de bits en variant y devuelve el resultado.

Parámetros

variant

La variante.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve la negación NOT a nivel de bits. Si variant es null, el resultado también será null.


Realiza una disyunción lógica de dos variantes

  • « variant_not
  • variant_pow »
  • PHP Manual
  • Funciones de COM
  • Realiza una disyunción lógica de dos variantes

variant_or

(PHP 5, PHP 7, PHP 8)

variant_or — Realiza una disyunción lógica de dos variantes

Descripción

variant_or ( mixed $left , mixed $right ) : mixed

Realiza una operación OR a nivel de bits. Observer que esto difiere ligeramente de una operación OR normal.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas del uso de OR de Variantes
Si left es | Si right es | entonces el resultado es
true | true | true
true | false | true
true | null | true
false | true | true
false | false | false
false | null | null
null | true | true
null | false | null
null | null | null

Ver también

  • variant_and() - Realiza una operación AND a nivel de bits entre dos variantes
  • variant_xor() - Realiza una exclución lógica de dos variantes


Devuelve el resultado de realizar la exponenciación con dos variantes

  • « variant_or
  • variant_round »
  • PHP Manual
  • Funciones de COM
  • Devuelve el resultado de realizar la exponenciación con dos variantes

variant_pow

(PHP 5, PHP 7, PHP 8)

variant_pow — Devuelve el resultado de realizar la exponenciación con dos variantes

Descripción

variant_pow ( mixed $left , mixed $right ) : mixed

Devuelve el resultado de left a la potencia de right.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el resultado de left a la potencia right.

Ver también

  • pow() - Expresión exponencial


Redondea una variante al número de lugares decimales especificado

  • « variant_pow
  • variant_set_type »
  • PHP Manual
  • Funciones de COM
  • Redondea una variante al número de lugares decimales especificado

variant_round

(PHP 5, PHP 7, PHP 8)

variant_round — Redondea una variante al número de lugares decimales especificado

Descripción

variant_round ( mixed $variant , int $decimals ) : mixed

Devuelve el valor de variant redondeado a decimals lugares decimales.

Parámetros

variant

La variante.

decimals

Número de luguras decimales.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Devuelve el valor redondeado.

Ver también

  • round() - Redondea un float


Convierte una variante en otro tipo "in situ"

  • « variant_round
  • variant_set »
  • PHP Manual
  • Funciones de COM
  • Convierte una variante en otro tipo "in situ"

variant_set_type

(PHP 5, PHP 7, PHP 8)

variant_set_type — Convierte una variante en otro tipo "in situ"

Descripción

variant_set_type ( variant $variant , int $type ) : void

Esta función es similar a variant_cast() excepto que la variante es modificada "in situ"; no se crea una nueva variante. Los parámetros para esta función tienen significados idénticos para aquellos de variant_cast().

Parámetros

variant

La variante.

type

Valores devueltos

No devuelve ningún valor.

Ver también

  • variant_cast() - Convertir una variante en un nuevo objeto variante de otro tipo


Asigna un nuevo valor para un objeto variante

  • « variant_set_type
  • variant_sub »
  • PHP Manual
  • Funciones de COM
  • Asigna un nuevo valor para un objeto variante

variant_set

(PHP 5, PHP 7, PHP 8)

variant_set — Asigna un nuevo valor para un objeto variante

Descripción

variant_set ( variant $variant , mixed $value ) : void

Convierte value a una variante y lo asigna al objeto variant; no se crean un nuevo objeto variante, y el valor antiguo de variant es liberado.

Parámetros

variant

La variante.

value

Valores devueltos

No devuelve ningún valor.


Resta el valor de la variante derecha del valor de la varienta izquierda

  • « variant_set
  • variant_xor »
  • PHP Manual
  • Funciones de COM
  • Resta el valor de la variante derecha del valor de la varienta izquierda

variant_sub

(PHP 5, PHP 7, PHP 8)

variant_sub — Resta el valor de la variante derecha del valor de la varienta izquierda

Descripción

variant_sub ( mixed $left , mixed $right ) : mixed

Resta right de left.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de Sustracción de Variantes
Si | Entonces
Ambas expresiones son de tipo cadena | Resta
Una expresión es de tipo cadena y la otra un carácter | Resta
Una expresión es numérica y la otra una cadena | Resta
Ambas expresiones son numéricas | Resta
Alguna de las expresiones es NULL | Se devuelve NULL
Ambas expresiones están vacías | Se devuelve una cadena vacía

Ver también

  • variant_add() - "Suma" dos variantes y devuelve el resultado


Realiza una exclución lógica de dos variantes

  • « variant_sub
  • win32service »
  • PHP Manual
  • Funciones de COM
  • Realiza una exclución lógica de dos variantes

variant_xor

(PHP 5, PHP 7, PHP 8)

variant_xor — Realiza una exclución lógica de dos variantes

Descripción

variant_xor ( mixed $left , mixed $right ) : mixed

Realiza una exclución lógica.

Parámetros

left

El operando izquierdo.

right

El operando derecho.

Nota:

Al igual que con todas las funciones aritméticas variantes, los parámetros de esta función pueden ser tanto un tipo nativo de PHP (integer, string, de punto flotante, boolean o null), o una instancia de una clase COM, VARIANT o DOTNET. Los tipos nativos de PHP serán convertidos en variantes usando las mismas reglas tal como se encuentran en el constructor para la clase VARIANT. Los objetos COM y DOTNET tomarán el valor de sus propiedades predeterminadas adoptadas y lo utilizarán como el valor variante.

Las funciones aritméticas variantes son wrappers alrededor de las funciones con nombres similares en la librería COM; para más información sobre estas funciones, consulte la librería MSDN. Las funciones de PHP tienen nombres ligeramente diferentes; por ejemplo, variant_add() en PHP corresponde a VarAdd() en la documentación MSDN.

Valores devueltos

Reglas de Exclusión de Variantes
Si left es | Si right es | entonces el resultado es
true | true | false
true | false | true
false | true | true
false | false | false
null | null | null

Ver también

  • variant_or() - Realiza una disyunción lógica de dos variantes
  • variant_and() - Realiza una operación AND a nivel de bits entre dos variantes


win32service

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
    • Máscara de Bits de Tipo Servicio de Win32Service
    • Constantes de Estado de Servicio de Win32Service
    • Constantes de Mensajes de Control de Servicio de Win32Service
    • Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service
    • Constantes de Tipo Inicio de Servicio de Win32Service
    • Constantes de Control de Errores de Servicio de Win32Service
    • Constantes de Banderas de Servicio de Win32Service
    • Códigos de Error de Win32
    • Clases base de prioridad Win32
  • Ejemplos
  • Funciones win32service
    • win32_continue_service — Reanuda un servicio pausado
    • win32_create_service — Crea una nueva entrada de servicio en la base de datos del ACS
    • win32_delete_service — Borra una entrada de servicio de la base de datos del ACS
    • win32_get_last_control_message — Devuelve el último mensaje de control que fue enviado a este servicio
    • win32_pause_service — Pausa un servicio
    • win32_query_service_status — Pregunta sobre el estado de un servicio
    • win32_send_custom_control — Enviar un control personalizado al servicio
    • win32_set_service_exit_code — Define o devuelve el código de salida para el servicio en curso
    • win32_set_service_exit_mode — Define o devuelve el modo de salida para el servicio en curso
    • win32_set_service_status — Actualiza el estado del servicio
    • win32_start_service_ctrl_dispatcher — Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
    • win32_start_service — Inicia un servicio
    • win32_stop_service — Detiene un servicio


Introducción

La extensión win32service es una extensión específica de Windows que permite a PHP comunicarse con el Administrador de Control de Servicios para iniciar, detener, registrar y dejar de registrar servicios, e incluso permite a los scripts de PHP ejecutarse como un servicio.


Requerimientos

Windows NT, Windows 2000, Windows XP o Windows Server 2003. Cualquier versión de Windows derivada de Windows NT debería ser compatible.


Instalación

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/win32service


Constantes predefinidas

Tabla de contenidos

  • Máscara de Bits de Tipo Servicio de Win32Service
  • Constantes de Estado de Servicio de Win32Service
  • Constantes de Mensajes de Control de Servicio de Win32Service
  • Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service
  • Constantes de Tipo Inicio de Servicio de Win32Service
  • Constantes de Control de Errores de Servicio de Win32Service
  • Constantes de Banderas de Servicio de Win32Service
  • Códigos de Error de Win32
  • Clases base de prioridad Win32

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.


Máscara de Bits de Tipo Servicio de Win32Service

  • « Constantes predefinidas
  • Constantes de Estado de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Máscara de Bits de Tipo Servicio de Win32Service
Máscara de Bits de Tipo Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_WIN32_OWN_PROCESS | 0x00000010 | El servicio se ejecuta en su propio proceso.
WIN32_SERVICE_INTERACTIVE_PROCESS | 0x00000100 | El servicio puede interactuar con el escritorio. Esta opción no está disponible en Windows Vista o posterior.
WIN32_SERVICE_WIN32_OWN_PROCESS_INTERACTIVE | 0x00000110 | El servicio se ejecuta en su propio procso y puede interactuar con el escritorio. Esta opción no está disponible en Windows Vista o posterior.


Constantes de Estado de Servicio de Win32Service

  • « Máscara de Bits de Tipo Servicio de Win32Service
  • Constantes de Mensajes de Control de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Constantes de Estado de Servicio de Win32Service
Constantes de Estado de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_CONTINUE_PENDING | 0x00000005 | La continuación del servicio está pendiente.
WIN32_SERVICE_PAUSE_PENDING | 0x00000006 | La pausa del servicio está pendiente.
WIN32_SERVICE_PAUSED | 0x00000007 | El servicio está pausado.
WIN32_SERVICE_RUNNING | 0x00000004 | El servicio está en ejecución.
WIN32_SERVICE_START_PENDING | 0x00000002 | El servicio está iniciado.
WIN32_SERVICE_STOP_PENDING | 0x00000003 | El servicio está detenido.
WIN32_SERVICE_STOPPED | 0x00000001 | El servicio no está en ejecución.


Constantes de Mensajes de Control de Servicio de Win32Service

  • « Constantes de Estado de Servicio de Win32Service
  • Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Constantes de Mensajes de Control de Servicio de Win32Service
Constantes de Mensajes de Control de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_CONTROL_CONTINUE | 0x00000003 | Notifica a un servicio pausado que debería reanudarse.
WIN32_SERVICE_CONTROL_INTERROGATE | 0x00000004 | Notifica a un servicio que debería informar de su información de estado al administrador de control de servicios.
WIN32_SERVICE_CONTROL_PAUSE | 0x00000002 | Notifica a un servicio que debería pausarse.
WIN32_SERVICE_CONTROL_PRESHUTDOWN | 0x0000000F | Notifica a un servicio que el sistema se apagará. Un servicio que maneja esta notificación bloquea el apagado del systema hasta que el servicio se detenga o el intervalo de tiempo límite de pre-apagado expira. Este valor no está soportado por Windows Server 2003 y Windows XP/2000.
WIN32_SERVICE_CONTROL_SHUTDOWN | 0x00000005 | Notifica a un servicio que el sistema se está apagando, por lo que el servicio puede realizar tareas de limpieza. Si un servicio acepta este código de cotrol, debe detenerse después de realizar sus tareas de limpieza. Después de que el SCM envíe este código de control, no se enviarán otros códigos de control al servicio.
WIN32_SERVICE_CONTROL_STOP | 0x00000001 | Notifica a un servicio que debería detenerse.


Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service

  • « Constantes de Mensajes de Control de Servicio de Win32Service
  • Constantes de Tipo Inicio de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service
Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_ACCEPT_PAUSE_CONTINUE | 0x00000002 | El servicio puede ser pausado y continuado. Este código de control permite al servicio recibir notificaciones WIN32_SERVICE_CONTROL_PAUSE y WIN32_SERVICE_CONTROL_CONTINUE.
WIN32_SERVICE_ACCEPT_PRESHUTDOWN | 0x00000100 | El servicio puede realizar tareas de pre-apagado. Este código de control habilita al servicio a recibir notificaciones WIN32_SERVICE_CONTROL_PRESHUTDOWN. Este valor no está soportado por Windows Server 2003 y Windows XP/2000.
WIN32_SERVICE_ACCEPT_SHUTDOWN | 0x00000004 | El servicio es notificado cuando sucede el apagado del systema. Este código de control permite al servicio recibir notificaciones WIN32_SERVICE_CONTROL_SHUTDOWN.
WIN32_SERVICE_ACCEPT_STOP | 0x00000001 | El servicio puede ser detenido. Este código de control permite al servicio recibir notificaciones WIN32_SERVICE_CONTROL_STOP.


Constantes de Tipo Inicio de Servicio de Win32Service

  • « Máscaras de Bits Aceptadas de Mensajes de Control de Servicio de Win32Service
  • Constantes de Control de Errores de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Constantes de Tipo Inicio de Servicio de Win32Service
Constantes de Tipo Inicio de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_AUTO_START | 0x00000002 | Un servicio iniciado automáticamente por el administrador de control de servicios durante el inicio del sistema.
WIN32_SERVICE_DEMAND_START | 0x00000003 | Un servicio iniciado por el administrador de control de servicios cuando un proceso llama a la función StartService.
WIN32_SERVICE_DISABLED | 0x00000004 | Un servicio que no puede ser iniciado. Intentar iniciar el servicio resulta en el código de error WIN32_ERROR_SERVICE_DISABLED.


Constantes de Control de Errores de Servicio de Win32Service

  • « Constantes de Tipo Inicio de Servicio de Win32Service
  • Constantes de Banderas de Servicio de Win32Service »
  • PHP Manual
  • Constantes predefinidas
  • Constantes de Control de Errores de Servicio de Win32Service
Constantes de Control de Errores de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_ERROR_IGNORE | 0x00000000 | El programa de inicio ignora el error y continua la operación de inicio.
WIN32_SERVICE_ERROR_NORMAL | 0x00000001 | El programa de inicio registra el error en el registro de sucesos pero continua la operación de inicio.


Constantes de Banderas de Servicio de Win32Service

  • « Constantes de Control de Errores de Servicio de Win32Service
  • Códigos de Error de Win32 »
  • PHP Manual
  • Constantes predefinidas
  • Constantes de Banderas de Servicio de Win32Service
Constantes de Banderas de Servicio de Win32Service
Constante | Valor | Descripción
WIN32_SERVICE_RUNS_IN_SYSTEM_PROCESS | 0x00000001 | El servicio de ejecuta en un proceso de sistema que siempre debe estar ejecutándose.


Códigos de Error de Win32

  • « Constantes de Banderas de Servicio de Win32Service
  • Clases base de prioridad Win32 »
  • PHP Manual
  • Constantes predefinidas
  • Códigos de Error de Win32
Códigos de Error de Win32
Constante | Valor | Descripción
WIN32_ERROR_ACCESS_DENIED | 0x00000005 | El gestor a la base de datos de SCM no tiene los derechos de acceso apropiados.
WIN32_ERROR_CIRCULAR_DEPENDENCY | 0x00000423 | Se especificó una dependencia de servicio circular.
WIN32_ERROR_DATABASE_DOES_NOT_EXIST | 0x00000429 | La base de datos especificada no existe.
WIN32_ERROR_DEPENDENT_SERVICES_RUNNING | 0x0000041B | El servicio no puede ser detenido porque otros servicios en ejecución dependen de él.
WIN32_ERROR_DUPLICATE_SERVICE_NAME | 0x00000436 | El nombre mostrado ya existe en la base de datos del administrador de control de servicios como nombre de servicio o como otro nombre mostrado.
WIN32_ERROR_FAILED_SERVICE_CONTROLLER_CONNECT | 0x00000427 | El error es devuelto si el programa está siendo ejecutado como aplicación de consola en vez de como servicio. Si el programa será ejecutado como aplicación de consola para propósitos de depuración, estructúrelo de tal manera que el código específico de servicio no sea llamado.
WIN32_ERROR_INSUFFICIENT_BUFFER | 0x0000007A | El buffer es demasiado pequeño para la estructura de estado del servicio. No se escribió nada a la estructura.
WIN32_ERROR_INVALID_DATA | 0x0000000D | La estructura de estado del servicio especificado no es válida.
WIN32_ERROR_INVALID_HANDLE | 0x00000006 | El gestor a la base de datos del administrador de control de servicios especificada no es válida.
WIN32_ERROR_INVALID_LEVEL | 0x0000007C | El parámetro InfoLevel contiene un valor no soportado.
WIN32_ERROR_INVALID_NAME | 0x0000007B | El nombre del servicio especificado no es válido.
WIN32_ERROR_INVALID_PARAMETER | 0x00000057 | Se especificó un parámetro no válido.
WIN32_ERROR_INVALID_SERVICE_ACCOUNT | 0x00000421 | El nombre de cuenta de usuario especificado en el parámero user no existe. Véase win32-create_service().
WIN32_ERROR_INVALID_SERVICE_CONTROL | 0x0000041C | El código de control solicitado no es válido, o es inaceptable para el servicio.
WIN32_ERROR_PATH_NOT_FOUND | 0x00000003 | No se pudo encontrar el fichero binario del servicio.
WIN32_ERROR_SERVICE_ALREADY_RUNNING | 0x00000420 | Ya se está ejecutando una instancia del servicio.
WIN32_ERROR_SERVICE_CANNOT_ACCEPT_CTRL | 0x00000425 | El código de control solicitado no puede ser enviado al servicio porque el estado del servicio es WIN32_SERVICE_STOPPED, WIN32_SERVICE_START_PENDING, o WIN32_SERVICE_STOP_PENDING.
WIN32_ERROR_SERVICE_DATABASE_LOCKED | 0x0000041F | La base de datos está bloqueada.
WIN32_ERROR_SERVICE_DEPENDENCY_DELETED | 0x00000433 | El servicio depende de un servicio que no existe o que ha sido marcado para su eleminación.
WIN32_ERROR_SERVICE_DEPENDENCY_FAIL | 0x0000042C | El servicio depende de otro servicio que falló al iniciarse.
WIN32_ERROR_SERVICE_DISABLED | 0x00000422 | El servicio ha sido deshabilitado.
WIN32_ERROR_SERVICE_DOES_NOT_EXIST | 0x00000424 | El servicio especificado no existe como servicio instalado.
WIN32_ERROR_SERVICE_EXISTS | 0x00000431 | El servicio especificado ya existe en esta base de datos.
WIN32_ERROR_SERVICE_LOGON_FAILED | 0x0000042D | El servicio no se inició debeido a un fallo de identificación. Este error sucede si el servicio está configurado para ejecutarse bajo una cuenta que no tiene el derecho "Log on as a service".
WIN32_ERROR_SERVICE_MARKED_FOR_DELETE | 0x00000430 | El servicio especificado ya ha sido marcado para su eliminación.
WIN32_ERROR_SERVICE_NO_THREAD | 0x0000041E | No se pudo crear un hilo para el servicio.
WIN32_ERROR_SERVICE_NOT_ACTIVE | 0x00000426 | El servicio no ha sido iniciado.
WIN32_ERROR_SERVICE_REQUEST_TIMEOUT | 0x0000041D | El proceso para el servicio se inició, pero no llamó a StartServiceCtrlDispatcher, o el hilo que llamó a StartServiceCtrlDispatcher puede estar bloqueado en una función de gestor de control.
WIN32_ERROR_SHUTDOWN_IN_PROGRESS | 0x0000045B | El sistema se está apagando; esta función no puede ser llamada.
WIN32_NO_ERROR | 0x00000000 | Sin error.


Clases base de prioridad Win32

  • « Códigos de Error de Win32
  • Ejemplos »
  • PHP Manual
  • Constantes predefinidas
  • Clases base de prioridad Win32
Clases base de prioridad Win32
Constante | Valor | Descripción
WIN32_ABOVE_NORMAL_PRIORITY_CLASS | 0x00008000 | Procesos que tienen una prioridad superior a WIN32_NORMAL_PRIORITY_CLASS pero inferior a WIN32_HIGH_PRIORITY_CLASS.
WIN32_BELOW_NORMAL_PRIORITY_CLASS | 0x00004000 | Procesos que tienen una prioridad superior a WIN32_IDLE_PRIORITY_CLASS pero inferior a WIN32_NORMAL_PRIORITY_CLASS.
WIN32_HIGH_PRIORITY_CLASS | 0x00000080 | Procesos que realizan tareas de tiempo crítico que deben ser ejecutadas inmediatamente. Los hilos de procesos anticipan a los hilos normales o procesos inactivos. Un ejemplo es la lista de procesos, que debe responder rápidamente cuando es llamado por el usuario, sin importar la carga del sistema operativo. Tenga mucho cuidado cuando use clases de procesos de alta prioridad, debido aque puede requerir un alto consumo de CPU disponible todo el tiempo.
WIN32_IDLE_PRIORITY_CLASS | 0x00000040 | Procesos cuyos hilos de ejecución corren sólo cuando el sistema está inactivo. Los hilo del proceso son antepuestos por los hilos de cualquier otro proceso corriendo en una clase de prioridad superior. Un ejemplo es el Protector de Pantallas. La clase de prioridad inactiva es heredado por sus procesos derivados.
WIN32_NORMAL_PRIORITY_CLASS | 0x00000020 | Procesos sin necesidad de establecer prioridades especiales.
WIN32_REALTIME_PRIORITY_CLASS | 0x00000100 | Procesos que tienen la mayor prioridad posible. Los hilos del proceso se anteponen a los hilos de todas los otros procesos, incluyendo los procesos del sistema operativo para realizar tareas importantes. Por ejemplo, un proceso en tiempo real que ejecuta por más que un breve intervalo puede causar que el cache del disco no se vacíe o provoque que el ratón no responda.


Ejemplos

Ejemplo #1 Registrar un script de PHP para ejecutarlo como un servicio

<?php
win32_create_service(array(
    'service'     => 'dummyphp',                                          # el nombre de su servicio
    'display'     => 'ejemplo de servicio PHP',                           # descripción abreviada
    'description' => 'Este es un servicio de Windows creado usando PHP.', # descripción larga
    'params'      => '"' . __FILE__ . '"  run',                           # ruta del script y parámetros
));
?>

Ejemplo #2 Dejar de registrar un servicio

<?php
win32_delete_service('dummyphp');
?>

Ejemplo #3 Ejecutar como un servicio

<?php
if ($argv[1] == 'run') {
  win32_start_service_ctrl_dispatcher('dummyphp');

  while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
    # hacer su trabajo aquí.
    # intente no tomar más de 30 segundos antes de ejecutar de nuevo
    # el bucle
  }
}
?>


Funciones win32service

Tabla de contenidos

  • win32_continue_service — Reanuda un servicio pausado
  • win32_create_service — Crea una nueva entrada de servicio en la base de datos del ACS
  • win32_delete_service — Borra una entrada de servicio de la base de datos del ACS
  • win32_get_last_control_message — Devuelve el último mensaje de control que fue enviado a este servicio
  • win32_pause_service — Pausa un servicio
  • win32_query_service_status — Pregunta sobre el estado de un servicio
  • win32_send_custom_control — Enviar un control personalizado al servicio
  • win32_set_service_exit_code — Define o devuelve el código de salida para el servicio en curso
  • win32_set_service_exit_mode — Define o devuelve el modo de salida para el servicio en curso
  • win32_set_service_status — Actualiza el estado del servicio
  • win32_start_service_ctrl_dispatcher — Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
  • win32_start_service — Inicia un servicio
  • win32_stop_service — Detiene un servicio


Reanuda un servicio pausado

  • « Funciones win32service
  • win32_create_service »
  • PHP Manual
  • Funciones win32service
  • Reanuda un servicio pausado

win32_continue_service

(PECL win32service >=0.1.0)

win32_continue_service — Reanuda un servicio pausado

Descripción

win32_continue_service ( string $servicename , string $machine = ? ) : int

Reanua un servicio pausado nominado. Se necesitan privilegios administrativos.

Parámetros

servicename

El nombre corto del servicio.

machine

Nombre opcional de la máquina. Si se omite, se usa el nombre de la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ver también

  • win32_start_service() - Inicia un servicio
  • Códigos de Error Win32


Crea una nueva entrada de servicio en la base de datos del ACS

  • « win32_continue_service
  • win32_delete_service »
  • PHP Manual
  • Funciones win32service
  • Crea una nueva entrada de servicio en la base de datos del ACS

win32_create_service

(PECL win32service >=0.1.0)

win32_create_service — Crea una nueva entrada de servicio en la base de datos del ACS

Descripción

win32_create_service ( array $details , string $machine = ? ) : mixed

Parámetros

details

Una matriz con los detalles del servicio:

service

El nombre corto del servicio. Éste es el nombre que se debe usar para controlar el servicio utilizando el comando net. El servicio debe ser único (dos servicios no pueden compartir el mismo nombre), y lo ideal sería evitar que el nombre contenga espacios.

display

El nombre para mostrar del servicio. Éste es el nombre que se verá en la Aplicación de Servicios.

description

La descripción larga del servicio. Ésta es la descripción que verá en el Services Applet.

user

El nombre de la cuenta de usuario bajo la cuál se quiere ejecutar el servicio. Si se omite, el servicio se ejecutará como la cuenta LocalSystem. Si se especifica el nombre de usuario, también se debe proporcionar una contraseña.

password

La contraseña que se corresponde con user.

path

La ruta completa de módulo ejecutable que será lanzado cuando el servicio es iniciado. Si se omite, se usará la ruta del proceso de PHP actual.

params

Parámetros de línea de comandos a pasar al servicio cuando se inicia. Si quiere ejecutar un script de PHP como un servicio, el primer parámetro debería ser la ruta completa del script de PHP que intenta ejecutar. Si el nombre del script o la ruta contiene espacios encierre la ruta completa del script PHP con ".

load_order

Controla el orden de carga. Ésto aún no está completamente soportado.

svc_type

Establece el tipo de servicio. Si se omite, el valor por defecto es WIN32_SERVICE_WIN32_OWN_PROCESS. No cambie esto a menos que sepa lo que está haciendo.

start_type

Especifica cómo debería iniciarse el servicio. Por defecto es WIN32_SERVICE_AUTO_START lo que significa que el servicio será lanzado cuando se encienda la máquina.

error_control

Informa al ACS qué debería hacer cuando detecta un problema con el servicio. Por defecto es WIN32_SERVER_ERROR_IGNORE. El cambio de este valor no está aún soportado completamente.

delayed_start

Si delayed_start está establecido a true, informará al SCM que este servicio debería ser iniciado después que otros servicios con autoinicio, más una pequeña demora.

Cualquier servicio puede ser marcado como un servicio con autoinicio demorado; sin embargo este ajuste no tiene efecto a menos que el parámetro start_type del servicio sea WIN32_SERVICE_AUTO_START.

Este ajuste sólo es aplicable en Windows Vista y Windows Server 2008 o superior.

base_priority

Para reducir el impacto en el uso del procesador, puede ser necesario para establecer una prioridad base más baja de lo normal.

base_priority puede establecerse a una de las constantes definidas en Clases de Prioridad Base de Win32.

machine

El nombre opcional de la máquina en la que quiere crear el servicio. Si se omite, se usará la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de win32_create_service()

Crear un servicio con el nombre abreviado 'dummyphp'.

<?php
$x = win32_create_service(array(
    'service'     => 'dummyphp',                                          # el nombre de su servicio
    'display'     => 'ejemplo de servicio PHP',                           # descripción abreviada
    'description' => 'Este es un servicio de Windows creado usando PHP.', # descripción larga
    'params'      => '"' . __FILE__ . '"  run',                           # ruta del script y parámetros
));
debug_zval_dump($x);
?>

Ver también

  • win32_delete_service() - Borra una entrada de servicio de la base de datos del ACS
  • Clases de Prioridad Base de Win32
  • Códigos de Error de Win32


Borra una entrada de servicio de la base de datos del ACS

  • « win32_create_service
  • win32_get_last_control_message »
  • PHP Manual
  • Funciones win32service
  • Borra una entrada de servicio de la base de datos del ACS

win32_delete_service

(PECL win32service >=0.1.0)

win32_delete_service — Borra una entrada de servicio de la base de datos del ACS

Descripción

win32_delete_service ( string $servicename , string $machine = ? ) : mixed

Intenta borrar un servicio de la base de datos del ACS. Se necesitan privilegios adminstrativos para que esto suceda.

Esta función en realidad marca el servicio para su eliminación. Si otro proceso (tal como la Aplicación de Servicios) está abierto, el borrado será aplazado hasta que tales aplicaciones se cierren. Si un servicio es marcado para su eliminación, más intentos de borrarlo fallarán, y los intentos de crear un nuevo servicio con ese nombre también fallarán.

Parámetros

servicename

El nombre corto del servicio.

machine

El nombre opcional de la máquina. Si se omite, será usada la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de win32_delete_service()

Borra el servicio dummyphp.

<?php
win32_delete_service('dummyphp');
?>

Ver también

  • win32_create_service() - Crea una nueva entrada de servicio en la base de datos del ACS
  • Códigos de Error de Win32


Devuelve el último mensaje de control que fue enviado a este servicio

  • « win32_delete_service
  • win32_pause_service »
  • PHP Manual
  • Funciones win32service
  • Devuelve el último mensaje de control que fue enviado a este servicio

win32_get_last_control_message

(PECL win32service >=0.1.0)

win32_get_last_control_message — Devuelve el último mensaje de control que fue enviado a este servicio

Descripción

win32_get_last_control_message ( ) : int

Devuelve el código de control que fue el último enviado a este proceso de servicio. Cuando se ejecuta como un servicio lo debería comprobar periódicamente para determinar si su servicio necesita detenerse.

Valores devueltos

Devuelve una constante de control que puede ser una de las Constantes de Mensajes de Control de Servicio de Win32Service: WIN32_SERVICE_CONTROL_CONTINUE, WIN32_SERVICE_CONTROL_INTERROGATE, WIN32_SERVICE_CONTROL_PAUSE, WIN32_SERVICE_CONTROL_PRESHUTDOWN, WIN32_SERVICE_CONTROL_SHUTDOWN, WIN32_SERVICE_CONTROL_STOP.

Ver también

  • win32_start_service_ctrl_dispatcher() - Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
  • Constantes de Mensajes de Control de Servicio de Win32Service


Pausa un servicio

  • « win32_get_last_control_message
  • win32_query_service_status »
  • PHP Manual
  • Funciones win32service
  • Pausa un servicio

win32_pause_service

(PECL win32service >=0.1.0)

win32_pause_service — Pausa un servicio

Descripción

win32_pause_service ( string $servicename , string $machine = ? ) : int

Pausa un servicio nominado. Se necesitan privilegios administrativos.

Parámetros

servicename

El nombre corto del servicio.

machine

Nombre opcional de la máquina. Si se omite, se usa el nombre de la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ver también

  • win32_start_service() - Inicia un servicio
  • Códigos de Error Win32


Pregunta sobre el estado de un servicio

  • « win32_pause_service
  • win32_send_custom_control »
  • PHP Manual
  • Funciones win32service
  • Pregunta sobre el estado de un servicio

win32_query_service_status

(PECL win32service >=0.1.0)

win32_query_service_status — Pregunta sobre el estado de un servicio

Descripción

win32_query_service_status ( string $servicename , string $machine = ? ) : mixed

Pregunta sobre el estado actual de un servicio, devolviendo una matriz de información.

Parámetros

servicename

El nombre corto del servicio.

machine

El nombre opcional de la máquina. Si se omite, será usada la máquina local.

Valores devueltos

Devuelve una matriz que consiste en la sigiente información sobre , false si hay un problema con los parámetros o Código de error Win32 en caso de error.

ServiceType

El dwServiceType. Véase Máscaras de Bits de Tipo Servicio de Win32Service.

CurrentState

El dwCurrentState. Véase Constantes de Estado de Servicio de Win32Service.

ControlsAccepted

Qué controles de servicio son aceptados por el servicio. Véase Máscaras de Bits Aceptadas de Mensajes de Control de Servicios de Win32Service.

Win32ExitCode

Si se sale del servicio, el código de retorno del proceso.

ServiceSpecificExitCode

Si se sale del servicio con una condición de error, el código específico de servicio que es registrado en el registro de eventos es visible aquí.

CheckPoint

Si el servicio se apaga, mantiene el número del punto de control actual. Ésto es usado por el ACS como un tipo de pulso para detectar un proceso de servicio estancado. El valor del punto de control se interpreta mejor junto con el valor WaitHint.

WaitHint

Si el servicio se apaga se establecerá WaitHint a un valor del punto de control que indicará 100% de finalización. Esto se puede usar para implementar un indicador de progreso.

ProcessId

El indentificador de proceso de Windows. Si es 0, el proceso no se está ejecutando.

ServiceFlags

El dwServiceFlags. Véase Constantes de Banderas de Servicio de Win32Service.

Ver también

  • Constantes Predefinidas de Win32Service


Enviar un control personalizado al servicio

  • « win32_query_service_status
  • win32_set_service_exit_code »
  • PHP Manual
  • Funciones win32service
  • Enviar un control personalizado al servicio

win32_send_custom_control

(PECL win32service >=0.4.0)

win32_send_custom_control — Enviar un control personalizado al servicio

Descripción

win32_send_custom_control ( string $servicename , int $control , string $machine = ? ) : int

Véase » Microsoft ControlService function para más detalles

Parámetros

servicename

El nombre corto del servicio.

control

El valor del contorno personalizado entre 128 y 255.

machine

Nombre de la máquina opcional. Si se omite, se utiliza la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Errores/Excepciones

Si el valor de control no está entre 128 y 255, esta función emite un error de nivel E_ERROR.

Ver también

  • win32_start_service() - Inicia un servicio
  • win32_stop_service() - Detiene un servicio
  • win32_pause_service() - Pausa un servicio
  • win32_continue_service() - Reanuda un servicio pausado
  • Win32 Error Codes


Define o devuelve el código de salida para el servicio en curso

  • « win32_send_custom_control
  • win32_set_service_exit_mode »
  • PHP Manual
  • Funciones win32service
  • Define o devuelve el código de salida para el servicio en curso

win32_set_service_exit_code

(PECL win32service >=0.4.0)

win32_set_service_exit_code — Define o devuelve el código de salida para el servicio en curso

Descripción

win32_set_service_exit_code ( int $exitCode = 1 ) : int

Cambia o devuelve el código de salida. El código de salida se utiliza sólo si el modo de salida no es ágil. Si el valor no es cero, la configuración de recuperación se puede utilizar después de el fallo de servicio. Véase » Microsoft system error codes para más detalles

Precaución

Esta función sólo funciona en el SAPI "cli". En otro SAPI esta función está desactivada.

Parámetros

exitCode

El código de retorno usado en la salida.

Valores devueltos

Devuelve el código de salida actual o antiguo.

Errores/Excepciones

Si el SAPI no es "cli", esta función emite un error de nivel E_ERROR.

Ver también

  • win32_start_service_ctrl_dispatcher() - Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
  • win32_set_service_status() - Actualiza el estado del servicio
  • win32_set_service_exit_mode() - Define o devuelve el modo de salida para el servicio en curso


Define o devuelve el modo de salida para el servicio en curso

  • « win32_set_service_exit_code
  • win32_set_service_status »
  • PHP Manual
  • Funciones win32service
  • Define o devuelve el modo de salida para el servicio en curso

win32_set_service_exit_mode

(PECL win32service >=0.4.0)

win32_set_service_exit_mode — Define o devuelve el modo de salida para el servicio en curso

Descripción

win32_set_service_exit_mode ( bool $gracefulMode = true ) : bool

Si se proporciona el parámetro gracefulMode, se cambia el modo de salida. Cuando el modo de salida no es ágil, el código de salida utilizado puede ser configurado con la función win32_set_service_exit_code().

Precaución

Esta función sólo funciona en el SAPI "cli". En otro SAPI esta función está desactivada.

Parámetros

gracefulMode

true para salir con agilidad. false para la salida con error.

Valores devueltos

Devuelve el modo de salida actual o antiguo.

Errores/Excepciones

Si el SAPI no es "cli", esta función emite un error de nivel E_ERROR.

Ver también

  • win32_start_service_ctrl_dispatcher() - Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
  • win32_set_service_status() - Actualiza el estado del servicio
  • win32_set_service_exit_code() - Define o devuelve el código de salida para el servicio en curso


Actualiza el estado del servicio

  • « win32_set_service_exit_mode
  • win32_start_service_ctrl_dispatcher »
  • PHP Manual
  • Funciones win32service
  • Actualiza el estado del servicio

win32_set_service_status

(PECL win32service >=0.1.0)

win32_set_service_status — Actualiza el estado del servicio

Descripción

win32_set_service_status ( int $status , int $checkpoint = 0 ) : bool

Informa al ACS del estado actual de un servicio que se está ejecutado. Esta llamada sólo es válida para un proceso de servicio que se esté ejecutando.

Parámetros

status

El código de estado de servicio, uno de los siguientes: WIN32_SERVICE_RUNNING, WIN32_SERVICE_STOPPED, WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING, WIN32_SERVICE_PAUSE_PENDING, WIN32_SERVICE_PAUSED.

checkpoint

El valor del punto de control del servicio aumenta periódicamente para notificar su progreso durante una operación prolongada de inicio, parada, pausa o continuación. Por ejemplo, el servicio debería aumentar este valor al completar cada paso de su inicialización cuando se inicia.

checkpoint sólo es válido cuando status es WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING o WIN32_SERVICE_PAUSE_PENDING.

Valores devueltos

Devuelve true en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ver también

  • win32_start_service_ctrl_dispatcher() - Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
  • Constantes de Estado de Servicio de Win32Service


Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado

  • « win32_set_service_status
  • win32_start_service »
  • PHP Manual
  • Funciones win32service
  • Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado

win32_start_service_ctrl_dispatcher

(PECL win32service >=0.1.0)

win32_start_service_ctrl_dispatcher — Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado

Descripción

win32_start_service_ctrl_dispatcher ( string $name ) : mixed

Cuando de lanza mediante el Administrador de Control de Servicios, se requiere un porceso de servicio para "registralo" con él para establecer la supervisión del servicio y las características de comunicación. Esta función lleva a cabo el registro produciendo un hilo para manejar la comunicación a bajo nivel con el adminstrador de control de servicios.

Una vez iniciado, el proceso de servicio debería hacer 2 cosas. La primera es llamar al Administrador de Control de Servicios que esté ejecutando el servicio. Esto se lleva a cabo llamando a win32_set_service_status() con la constante WIN32_SERVICE_RUNNING. Si necesita realizar algún proceso prolongado antes de que el servicio esté realmente ejecutándose, puede usar la constante WIN32_SERVICE_START_PENDING. Lo segundo es continuar registrando con el administrador de control de servicios por lo que puede determinar si debería finalizarse. Esto se lleva a cabo llamando periódicamente a win32_get_last_control_message() y manteniendo el código devuelto de manera apropiada.

Parámetros

name

El nombre corto del servicio, como se registró mediante win32_create_service().

Valores devueltos

Devuelve true en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ejemplos

Ejemplo #1 Un ejemplo de win32_start_service_ctrl_dispatcher()

Comprobar si el servicio se está ejecutando bajo el ACS.

<?php
if (!win32_start_service_ctrl_dispatcher('dummyphp')) {
  die("Probablemente no esté ejecutándome bajo el administrador de control de servicios");
}

win32_set_service_status(WIN32_SERVICE_START_PENDING);

// Algún proceso prolongado para levantar este servicio y ejecutar.

win32_set_service_status(WIN32_SERVICE_RUNNING);

while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
  # hacer su trabajo aquí, intentando no tomar más de 30 segundos
  # antes de ejecutar de nuevo el bucle
}
?>

Ver también

  • win32_set_service_status() - Actualiza el estado del servicio
  • win32_get_last_control_message() - Devuelve el último mensaje de control que fue enviado a este servicio
  • Códigos de Error de Win32


Inicia un servicio

  • « win32_start_service_ctrl_dispatcher
  • win32_stop_service »
  • PHP Manual
  • Funciones win32service
  • Inicia un servicio

win32_start_service

(PECL win32service >=0.1.0)

win32_start_service — Inicia un servicio

Descripción

win32_start_service ( string $servicename , string $machine = ? ) : int

Intenta iniciar un servicio con nombre. Normalmente requiere privilegios administrativos.

Parámetros

servicename

El nombre corto del servicio.

machine

El nombre opcional de la máquina. Si se omite, será usada la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ver también

  • win32_stop_service() - Detiene un servicio
  • Códigos de Error de Win32


Detiene un servicio

  • « win32_start_service
  • Manipulación de XML »
  • PHP Manual
  • Funciones win32service
  • Detiene un servicio

win32_stop_service

(PECL win32service >=0.1.0)

win32_stop_service — Detiene un servicio

Descripción

win32_stop_service ( string $servicename , string $machine = ? ) : int

Detiene un servicio con nombre. Requiere privilegios administrativos.

Parámetros

servicename

El nombre corto del servicio.

machine

El nombre opcional de la máquina. Si se omite, se usa la máquina local.

Valores devueltos

Devuelve WIN32_NO_ERROR en caso de éxito, false si hay un problema con los parámetros o Código de error Win32 en caso de error.

Ver también

  • win32_start_service() - Inicia un servicio
  • Códigos de Error de Win32


Manipulación de XML

  • DOM — Modelo de Objetos de Documento
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • DOMAttr — La clase DOMAttr
    • DOMCdataSection — La clase DOMCdataSection
    • DOMCharacterData — La clase DOMCharacterData
    • DOMComment — Clase DOMComment
    • DOMDocument — Clase DOMDocument
    • DOMDocumentFragment — La clase DOMDocumentFragment
    • DOMDocumentType — La clase DOMDocumentType
    • DOMElement — La clase DOMElement
    • DOMEntity — La clase DOMEntity
    • DOMEntityReference — La clase DOMEntityReference
    • DOMException — La clase DOMException
    • DOMImplementation — La clase DOMImplementation
    • DOMNamedNodeMap — La clase DOMNamedNodeMap
    • DOMNode — La clase DOMNode
    • DOMNodeList — La clase DOMNodeList
    • DOMNotation — La clase DOMNotation
    • DOMProcessingInstruction — La clase DOMProcessingInstruction
    • DOMText — La clase DOMText
    • DOMXPath — La clase DOMXPath
    • Funciones de DOM
  • libxml
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • libXMLError — La clase libXMLError
    • Funciones de libxml
  • SimpleXML
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • SimpleXMLElement — Clase SimpleXMLElement
    • SimpleXMLIterator — La clase SimpleXMLIterator
    • Funciones de SimpleXML
  • WDDX
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • Funciones de WDDX
  • XMLDiff — Diferencias y fusión de documentos XML
    • Introducción
    • Instalación/Configuración
    • XMLDiff\Base — La clase XMLDiff\Base
    • XMLDiff\DOM — La clase XMLDiff\DOM
    • XMLDiff\Memory — La clase XMLDiff\Memory
    • XMLDiff\File — La clase XMLDiff\File
  • Analizador XML
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Manejadores de eventos
    • Case Folding
    • Error Codes
    • Codificación de caracteres
    • Ejemplos
    • Funciones del Intérprete XML
  • XMLReader
    • Introducción
    • Instalación/Configuración
    • XMLReader — The XMLReader class
  • XMLWriter
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • XMLWriter — La clase XMLWriter
  • XSL
    • Introducción
    • Instalación/Configuración
    • Constantes predefinidas
    • Ejemplos
    • XSLTProcessor — Clase XSLTProcessor


Modelo de Objetos de Documento

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
  • DOMAttr — La clase DOMAttr
    • DOMAttr::__construct — Crea un nuevo objeto DOMAttr
    • DOMAttr::isId — Verifica si un atributo es un ID definido.
  • DOMCdataSection — La clase DOMCdataSection
    • DOMCdataSection::__construct — Construye un nuevo objeto DOMCdataSection
  • DOMCharacterData — La clase DOMCharacterData
    • DOMCharacterData::appendData — Añade el string de caracteres al final de los datos de carácter del nodo.
    • DOMCharacterData::deleteData — Eliminar una serie de caracteres del nodo
    • DOMCharacterData::insertData — Inserta un string en la posición de 16-bit especificada
    • DOMCharacterData::replaceData — Reemplaza un substring dentro de un nodo DOMCharacterData
    • DOMCharacterData::substringData — Extrae una serie de datos del nodo
  • DOMComment — Clase DOMComment
    • DOMComment::__construct — Crea un nuevo objeto DOMComment
  • DOMDocument — Clase DOMDocument
    • DOMDocument::__construct — Crea un nuevo objeto DOMDocument
    • DOMDocument::createAttribute — Crear nuevo attribute
    • DOMDocument::createAttributeNS — Crea un nuevo nodo atributo con un namespace asociado.
    • DOMDocument::createCDATASection — Crea un nuevo nodo cdata
    • DOMDocument::createComment — Crea un nuevo nodo de comentario
    • DOMDocument::createDocumentFragment — Crea un nuevo fragmento de documento
    • DOMDocument::createElement — Crea un nuevo nodo elemento
    • DOMDocument::createElementNS — Crea un nuevo nodo elemento con el nombre de espacio asociado
    • DOMDocument::createEntityReference — Create new entity reference node
    • DOMDocument::createProcessingInstruction — Crea un nuevo nodo PI
    • DOMDocument::createTextNode — Crea un nuevo nodo de texto
    • DOMDocument::getElementById — Busca un elemento con cierto id
    • DOMDocument::getElementsByTagName — Busca todos los elementos con el nombre de etiqueta local dado
    • DOMDocument::getElementsByTagNameNS — Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.
    • DOMDocument::importNode — Importa un nodo dentro del documento actual
    • DOMDocument::load — Cargar un documento XML de un archivo.
    • DOMDocument::loadHTML — Cargar HTML de una cadena
    • DOMDocument::loadHTMLFile — Cargar HTML desde un fichero
    • DOMDocument::loadXML — Cargar XML desde una cadena
    • DOMDocument::normalizeDocument — Normaliza el documento
    • DOMDocument::registerNodeClass — Registra una clase extendida usada para crear tipos de nodos base
    • DOMDocument::relaxNGValidate — Realiza una validación relaxNG del documento
    • DOMDocument::relaxNGValidateSource — Realiza una validación relaxNG del documento
    • DOMDocument::save — Copia el árbol XML interno a un archivo
    • DOMDocument::saveHTML — Copia el documento interno a una cadena usando el formato HTML
    • DOMDocument::saveHTMLFile — Copia el documento interno a un fichero usando el formato HTML
    • DOMDocument::saveXML — Copia el arbol XML interno a un string
    • DOMDocument::schemaValidate — Valida un documento basado en un esquema
    • DOMDocument::schemaValidateSource — Valida un documento basado en un esquema
    • DOMDocument::validate — Valida el documento basado en su DTD
    • DOMDocument::xinclude — Sustituye XIncludes en un objeto DOMDocument
  • DOMDocumentFragment — La clase DOMDocumentFragment
    • DOMDocumentFragment::appendXML — Añade información XML sin formato
  • DOMDocumentType — La clase DOMDocumentType
  • DOMElement — La clase DOMElement
    • DOMElement::__construct — Crea un nuevo objeto DOMElement
    • DOMElement::getAttribute — Devuelve el valor de un atributo
    • DOMElement::getAttributeNode — Devuelve el nodo de un atributo
    • DOMElement::getAttributeNodeNS — Devuelve el nodo de un atributo
    • DOMElement::getAttributeNS — Devuelve el valor de un atributo
    • DOMElement::getElementsByTagName — Obtiene los elementos por nombre de etiqueta
    • DOMElement::getElementsByTagNameNS — Obtener los elementos por la URI del espacio de nombres y el nombre local
    • DOMElement::hasAttribute — Comprueba si existe un atributo
    • DOMElement::hasAttributeNS — Comprueba si un atributo existe
    • DOMElement::removeAttribute — Elimina un atributo
    • DOMElement::removeAttributeNode — Elimina un atributo
    • DOMElement::removeAttributeNS — Elimina un atributo
    • DOMElement::setAttribute — Añade un nuevo atributo
    • DOMElement::setAttributeNode — Añade un nuevo nodo de atributo al elemento
    • DOMElement::setAttributeNodeNS — Aña de un nuevo nodo de atributo al elemento
    • DOMElement::setAttributeNS — Añade un nuevo atributo
    • DOMElement::setIdAttribute — Declara el atributo especificado por su nombre como de tipo ID
    • DOMElement::setIdAttributeNode — Declara el atributo especificado por su nodo como de tipo ID
    • DOMElement::setIdAttributeNS — Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID
  • DOMEntity — La clase DOMEntity
  • DOMEntityReference — La clase DOMEntityReference
    • DOMEntityReference::__construct — Crea un nuevo objeto DOMEntityReference
  • DOMException — La clase DOMException
  • DOMImplementation — La clase DOMImplementation
    • DOMImplementation::__construct — Crea un nuevo objeto DOMImplementation
    • DOMImplementation::createDocument — Crea un objeto DOMDocument del tipo especificado con su elemento documento
    • DOMImplementation::createDocumentType — Crear un objeto DOMDocumentType vacío
    • DOMImplementation::hasFeature — Comprueba si la implementación de DOM implementa una característica específica
  • DOMNamedNodeMap — La clase DOMNamedNodeMap
    • DOMNamedNodeMap::count — Get number of nodes in the map
    • DOMNamedNodeMap::getNamedItem — Recupera un nodo especificado por su nombre
    • DOMNamedNodeMap::getNamedItemNS — Recupera un nodo especificado por el nombre local y la URI del espacio de nombres
    • DOMNamedNodeMap::item — Recupera un nodo especificado por su índice
  • DOMNode — La clase DOMNode
    • DOMNode::appendChild — Añade un nuevo hijo al final de los hijos
    • DOMNode::C14N — Canonizar nodos a una cadena
    • DOMNode::C14NFile — Canonizar nodos a un fichero
    • DOMNode::cloneNode — Clona un nodo
    • DOMNode::getLineNo — Obtener el número de línea de un nodo
    • DOMNode::getNodePath — Obtener un XPath de un nodo
    • DOMNode::hasAttributes — Comprueba si un nodo tiene atributos
    • DOMNode::hasChildNodes — Comprueba si el nodo tiene hijos
    • DOMNode::insertBefore — Añade un nuevo hijo antes del nodo de referencia
    • DOMNode::isDefaultNamespace — Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado
    • DOMNode::isSameNode — Indica si dos nodos son el mismo nodo
    • DOMNode::isSupported — Comprueba si una característica está soportada para la versión especificada
    • DOMNode::lookupNamespaceUri — Obtiene la URI del espacio de nombres del nodo basado en el prefijo
    • DOMNode::lookupPrefix — Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres
    • DOMNode::normalize — Normaliza el nodo
    • DOMNode::removeChild — Elimina un hijo de la lista de hijos.
    • DOMNode::replaceChild — Reemplaza un hijo
  • DOMNodeList — La clase DOMNodeList
    • DOMNodeList::count — Obtiene el número de nodos en la lista
    • DOMNodeList::item — Recupera un nodo especificado por un índice
  • DOMNotation — La clase DOMNotation
  • DOMProcessingInstruction — La clase DOMProcessingInstruction
    • DOMProcessingInstruction::__construct — Crea un nuevo objeto DOMProcessingInstruction
  • DOMText — La clase DOMText
    • DOMText::__construct — Crea un nuevo objeto DOMText
    • DOMText::isElementContentWhitespace — Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento
    • DOMText::isWhitespaceInElementContent — Indica si este nodo de texto contiene espacios en blanco
    • DOMText::splitText — Rompe este nodo en dos nodos en el índice especificado
  • DOMXPath — La clase DOMXPath
    • DOMXPath::__construct — Crea un nuevo objeto DOMXPath
    • DOMXPath::evaluate — Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible
    • DOMXPath::query — Evalúa la expresión XPath dada
    • DOMXPath::registerNamespace — Registra el espacio de nombres con el objeto DOMXPath
    • DOMXPath::registerPhpFunctions — Registra funciones de PHP como funciones XPath
  • Funciones de DOM
    • dom_import_simplexml — Obtiene un objeto DOMElement desde un objeto SimpleXMLElement


Introducción

La extension DOM (siglas en inglés de Document Object Model) permite manipular documentos XML mediante la API DOM con PHP.

Nota:

The DOM extension uses UTF-8 encoding. Use utf8_encode() and utf8_decode() to work with texts in ISO-8859-1 encoding or iconv for other encodings.


Instalación

Esta extensión está habilitada de forma predeterminada. Se puede deshabilitar empleando la siguiente opción durante la compilación: --disable-dom


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

Constantes XML
Constante | Valor | Descripción
XML_ELEMENT_NODE (integer) | 1 | Nodo es un DOMElement
XML_ATTRIBUTE_NODE (integer) | 2 | Nodo es un DOMAttr
XML_TEXT_NODE (integer) | 3 | Nodo es un DOMText
XML_CDATA_SECTION_NODE (integer) | 4 | Nodo es un DOMCharacterData
XML_ENTITY_REF_NODE (integer) | 5 | Nodo es un DOMEntityReference
XML_ENTITY_NODE (integer) | 6 | Nodo es un DOMEntity
XML_PI_NODE (integer) | 7 | Nodo es un DOMProcessingInstruction
XML_COMMENT_NODE (integer) | 8 | Nodo es un DOMComment
XML_DOCUMENT_NODE (integer) | 9 | Nodo es un DOMDocument
XML_DOCUMENT_TYPE_NODE (integer) | 10 | Nodo es un DOMDocumentType
XML_DOCUMENT_FRAG_NODE (integer) | 11 | Nodo es un DOMDocumentFragment
XML_NOTATION_NODE (integer) | 12 | Nodo es un DOMNotation
XML_HTML_DOCUMENT_NODE (integer) | 13 |
XML_DTD_NODE (integer) | 14 |
XML_ELEMENT_DECL_NODE (integer) | 15 |
XML_ATTRIBUTE_DECL_NODE (integer) | 16 |
XML_ENTITY_DECL_NODE (integer) | 17 |
XML_NAMESPACE_DECL_NODE (integer) | 18 |
XML_ATTRIBUTE_CDATA (integer) | 1 |
XML_ATTRIBUTE_ID (integer) | 2 |
XML_ATTRIBUTE_IDREF (integer) | 3 |
XML_ATTRIBUTE_IDREFS (integer) | 4 |
XML_ATTRIBUTE_ENTITY (integer) | 5 |
XML_ATTRIBUTE_NMTOKEN (integer) | 7 |
XML_ATTRIBUTE_NMTOKENS (integer) | 8 |
XML_ATTRIBUTE_ENUMERATION (integer) | 9 |
XML_ATTRIBUTE_NOTATION (integer) | 10 |
DOMException constantes
Constante | Valor | Descripción
DOM_PHP_ERR (integer) | 0 | El código de Error no forma parte de la especificación DOM. Significado para errores PHP.
DOM_INDEX_SIZE_ERR (integer) | 1 | Si el índice o el tamaño es negativo, o mayor que el valor permitido.
DOMSTRING_SIZE_ERR (integer) | 2 | Si el rango especificado de texto no cabe en un DOMString.
DOM_HIERARCHY_REQUEST_ERR (integer) | 3 | Si un nodo es insertado en un lugar al que no pertenece
DOM_WRONG_DOCUMENT_ERR (integer) | 4 | Si un nodo es usado en un documento diferente al que lo creó.
DOM_INVALID_CHARACTER_ERR (integer) | 5 | Si un carácter ilegal o inválido es especificado, como en un nombre.
DOM_NO_DATA_ALLOWED_ERR (integer) | 6 | Si la data es especificada para un nodo que no la soporta.
DOM_NO_MODIFICATION_ALLOWED_ERR (integer) | 7 | Si se intenta modificar un objeto donde las modificaciones no están permitidas.
DOM_NOT_FOUND_ERR (integer) | 8 | Si se intenta referenciar un nodo en un contexto en el que no existe.
DOM_NOT_SUPPORTED_ERR (integer) | 9 | Si la implementación no soporta el tipo de objeto u operación solicitado.
DOM_INUSE_ATTRIBUTE_ERR (integer) | 10 | Si se intenta agregar un atributo que esta siendo usado en otro lugar.
DOM_INVALID_STATE_ERR (integer) | 11 | Si se intenta utilizar un objeto que no es o ha dejado de ser usable.
DOM_SYNTAX_ERR (integer) | 12 | Si una cadena ilegal o inválida es especificada.
DOM_INVALID_MODIFICATION_ERR (integer) | 13 | Si se intenta modificar el tipo de dato del objeto subyacente.
DOM_NAMESPACE_ERR (integer) | 14 | Si se intenta crear o modificar un objeto de una manera que es incorrecta con respecto a su espacio de nombre (namespace).
DOM_INVALID_ACCESS_ERR (integer) | 15 | Si un parámetro u operación no es soportado por el objeto subyacente.
DOM_VALIDATION_ERR (integer) | 16 | Si la llamada a un método como insertBefore o removeChild invalidará el Nodo con respecto a la "validez parcial", esta excepción sera lanzada y la operación no se realizará.


Ejemplos

Muchos ejemplos en esta referencia requieren un fichero XML. Utilizaremos book.xml que contiene lo siguiente:

Ejemplo #1 book.xml

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
 "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
]>
<book id="listing">
 <title>Mis listas</title>
 <chapter id="books">
  <title>Mis libros</title>
  <para>
   <informaltable>
    <tgroup cols="4">
     <thead>
      <row>
       <entry>Título</entry>
       <entry>Autor</entry>
       <entry>Idioma</entry>
       <entry>ISBN</entry>
      </row>
     </thead>
     <tbody>
      <row>
       <entry>The Grapes of Wrath</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>0140186409</entry>
      </row>
      <row>
       <entry>The Pearl</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>014017737X</entry>
      </row>
      <row>
       <entry>Samarcande</entry>
       <entry>Amine Maalouf</entry>
       <entry>fr</entry>
       <entry>2253051209</entry>
      </row>
      <!-- TODO: Tengo muchos libros pendientes de añadir.. -->
     </tbody>
    </tgroup>
   </informaltable>
  </para>
 </chapter>
</book>


La clase DOMAttr

(PHP 5, PHP 7)

Introducción

DOMAttr representa un atributo en el objeto DOMElement.

Sinopsis de la Clase

DOMAttr extends DOMNode {
/* Propiedades */
public readonly string $name ;
public readonly DOMElement $ownerElement ;
public readonly bool $schemaTypeInfo ;
public readonly bool $specified ;
public string $value ;
/* Propiedades heredadas */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public __construct ( string $name , string $value = ? )
public isId ( ) : bool
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

name

El nombre del atributo.

ownerElement

El elemento que contiene el atributo.

schemaTypeInfo

Aún no implementado, siempre es null

specified

Aún no implementado, siempre es null

value

El valor del atributo.

Ver también

  • » Especificación W3C de Attr

Tabla de contenidos

  • DOMAttr::__construct — Crea un nuevo objeto DOMAttr
  • DOMAttr::isId — Verifica si un atributo es un ID definido.


Crea un nuevo objeto DOMAttr

  • « DOMAttr
  • DOMAttr::isId »
  • PHP Manual
  • DOMAttr
  • Crea un nuevo objeto DOMAttr

DOMAttr::__construct

(PHP 5, PHP 7)

DOMAttr::__construct — Crea un nuevo objeto DOMAttr

Descripción

public DOMAttr::__construct ( string $name , string $value = ? )

Crea un nuevo objeto DOMAttr. Este objeto es de sólo lectura. Puede ser anexado a un documento, pero no se le podrán anexar nodos adicionales a este hasta que sea asociado con un documento. Para crear un nodo modificable utilice DOMDocument::createAttribute.

Parámetros

name

El nombre de etiqueta del atributo.

value

El valor de atributo.

Ejemplos

Ejemplo #1 Creación de un nuevo objeto DOMAttr

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$attr = $element->setAttributeNode(new DOMAttr('attr', 'attrvalue'));
echo $dom->saveXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<root attr="attrvalue" />

Ver también

  • DOMDocument::createAttribute() - Crear nuevo attribute


Verifica si un atributo es un ID definido.

  • « DOMAttr::__construct
  • DOMCdataSection »
  • PHP Manual
  • DOMAttr
  • Verifica si un atributo es un ID definido.

DOMAttr::isId

(PHP 5, PHP 7)

DOMAttr::isId — Verifica si un atributo es un ID definido.

Descripción

public DOMAttr::isId ( ) : bool

Esta función verifica si el atributo es un ID definido.

De acuerdo al estándar DOM esto requiere una DTD que defina que el atributo ID sea de tipo ID. Necesitará validar su documento con DOMDocument::validate o DOMDocument::validateOnParse antes de utilizar esta función.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DOMAttr::isId()

<?php

$doc = new DomDocument;

// Necesitaremos validar nuestro documento antes de referir el id
$doc->validateOnParse = true;
$doc->Load('book.xml');

// Devolvemos el atributo llamado id del elemento chapter
$attr = $doc->getElementsByTagName('chapter')->item(0)->getAttributeNode('id');

var_dump($attr->isId()); // bool(true)

?>


La clase DOMCdataSection

(PHP 5, PHP 7)

Introducción

DOMCdataSection hereda de DOMText para la representación textural de constructores CData.

Sinopsis de la Clase

DOMCdataSection extends DOMText {
/* Propiedades heredadas */
readonly public string $wholeText ;
public string $data ;
public readonly int $length ;
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public __construct ( string $value )
/* Métodos heredados */
public DOMText::isElementContentWhitespace ( ) : bool
public DOMText::isWhitespaceInElementContent ( ) : bool
public DOMText::splitText ( int $offset ) : DOMText
public DOMCharacterData::appendData ( string $data ) : void
public DOMCharacterData::deleteData ( int $offset , int $count ) : void
public DOMCharacterData::insertData ( int $offset , string $data ) : void
public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : void
public DOMCharacterData::substringData ( int $offset , int $count ) : string
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Tabla de contenidos

  • DOMCdataSection::__construct — Construye un nuevo objeto DOMCdataSection


Construye un nuevo objeto DOMCdataSection

  • « DOMCdataSection
  • DOMCharacterData »
  • PHP Manual
  • DOMCdataSection
  • Construye un nuevo objeto DOMCdataSection

DOMCdataSection::__construct

(PHP 5, PHP 7)

DOMCdataSection::__construct — Construye un nuevo objeto DOMCdataSection

Descripción

public DOMCdataSection::__construct ( string $value )

Construye un nuevo nodo CDATA. Funciona igual que la clase DOMText.

Parámetros

value

El valor del nodo CDATA. Si no se proporciona, se crea un nodo CDATA vacío.

Ejemplos

Ejemplo #1 Crear un nuevo objeto DOMCdataSection

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$elemento = $dom->appendChild(new DOMElement('root'));
$texto = $elemento->appendChild(new DOMCdataSection('root value'));
echo $dom->saveXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<root><![CDATA[root value]]></root>

Ver también

  • DOMText::__construct() - Crea un nuevo objeto DOMText
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


La clase DOMCharacterData

(PHP 5, PHP 7)

Introducción

Representa nodos con datos de caracteres. Ningún nodo corresponde directamente a esta clase pero otros nodos pueden heredar de ella.

Sinopsis de la Clase

DOMCharacterData extends DOMNode {
/* Propiedades */
public string $data ;
public readonly int $length ;
/* Propiedades heredadas */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public appendData ( string $data ) : void
public deleteData ( int $offset , int $count ) : void
public insertData ( int $offset , string $data ) : void
public replaceData ( int $offset , int $count , string $data ) : void
public substringData ( int $offset , int $count ) : string
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

data

El contenido del nodo.

length

La longitud del contenido.

Ver también

  • » Especificacion W3C specificatión de CharacterData

Tabla de contenidos

  • DOMCharacterData::appendData — Añade el string de caracteres al final de los datos de carácter del nodo.
  • DOMCharacterData::deleteData — Eliminar una serie de caracteres del nodo
  • DOMCharacterData::insertData — Inserta un string en la posición de 16-bit especificada
  • DOMCharacterData::replaceData — Reemplaza un substring dentro de un nodo DOMCharacterData
  • DOMCharacterData::substringData — Extrae una serie de datos del nodo


Añade el string de caracteres al final de los datos de carácter del nodo.

  • « DOMCharacterData
  • DOMCharacterData::deleteData »
  • PHP Manual
  • DOMCharacterData
  • Añade el string de caracteres al final de los datos de carácter del nodo.

DOMCharacterData::appendData

(PHP 5, PHP 7)

DOMCharacterData::appendData — Añade el string de caracteres al final de los datos de carácter del nodo.

Descripción

public DOMCharacterData::appendData ( string $data ) : void

Añade el string data hasta el final de los datos de carácter del nodo.

Parámetros

data

El string de caracteres a añadir.

Valores devueltos

No devuelve ningún valor.

Ver también

  • DOMCharacterData::deleteData() - Eliminar una serie de caracteres del nodo
  • DOMCharacterData::insertData() - Inserta un string en la posición de 16-bit especificada
  • DOMCharacterData::replaceData() - Reemplaza un substring dentro de un nodo DOMCharacterData
  • DOMCharacterData::substringData() - Extrae una serie de datos del nodo


Eliminar una serie de caracteres del nodo

  • « DOMCharacterData::appendData
  • DOMCharacterData::insertData »
  • PHP Manual
  • DOMCharacterData
  • Eliminar una serie de caracteres del nodo

DOMCharacterData::deleteData

(PHP 5, PHP 7)

DOMCharacterData::deleteData — Eliminar una serie de caracteres del nodo

Descripción

public DOMCharacterData::deleteData ( int $offset , int $count ) : void

Elimina count caracteres comenzando desde la posición offset.

Parámetros

offset

El índice desde el cual se comenzará a remover.

count

La cantidad de caracteres a eliminar. Si la suma de offset y count excede la longitud, entonces todos los caracteres al final de la data son eliminados.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_INDEX_SIZE_ERR

Lanzada si offset es negativo o mayor que el número de unidades de 16-bit en la data, o si count es negativo.

Ver también

  • DOMCharacterData::appendData() - Añade el string de caracteres al final de los datos de carácter del nodo.
  • DOMCharacterData::insertData() - Inserta un string en la posición de 16-bit especificada
  • DOMCharacterData::replaceData() - Reemplaza un substring dentro de un nodo DOMCharacterData
  • DOMCharacterData::substringData() - Extrae una serie de datos del nodo


Inserta un string en la posición de 16-bit especificada

  • « DOMCharacterData::deleteData
  • DOMCharacterData::replaceData »
  • PHP Manual
  • DOMCharacterData
  • Inserta un string en la posición de 16-bit especificada

DOMCharacterData::insertData

(PHP 5, PHP 7)

DOMCharacterData::insertData — Inserta un string en la posición de 16-bit especificada

Descripción

public DOMCharacterData::insertData ( int $offset , string $data ) : void

Inserta el string data en la posición offset.

Parámetros

offset

La posición en la cual se insertará.

data

El string a insertar.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_INDEX_SIZE_ERR

Lanzado si offset es negativo o mayor que el número de unidades de 16-bit en la data.

Ver también

  • DOMCharacterData::appendData() - Añade el string de caracteres al final de los datos de carácter del nodo.
  • DOMCharacterData::deleteData() - Eliminar una serie de caracteres del nodo
  • DOMCharacterData::replaceData() - Reemplaza un substring dentro de un nodo DOMCharacterData
  • DOMCharacterData::substringData() - Extrae una serie de datos del nodo


Reemplaza un substring dentro de un nodo DOMCharacterData

  • « DOMCharacterData::insertData
  • DOMCharacterData::substringData »
  • PHP Manual
  • DOMCharacterData
  • Reemplaza un substring dentro de un nodo DOMCharacterData

DOMCharacterData::replaceData

(PHP 5, PHP 7)

DOMCharacterData::replaceData — Reemplaza un substring dentro de un nodo DOMCharacterData

Descripción

public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : void

Reemplaza count caracteres comenzando en la posicion offset con data.

Parámetros

offset

La posición inicial a partir de la cual se iniciara el reemplazo.

count

El número de carácteres a reemplazar. Si la suma de offset y count excede la longitud, entonces todos los carácteres al final de la data son reemplazados.

data

El string con el cual el rango debe ser reemplazado.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_INDEX_SIZE_ERR

Lanzado si offset es negativo o mayor que el número de unidades de 16-bit en la data, o si count es negativo.

Ver también

  • DOMCharacterData::appendData() - Añade el string de caracteres al final de los datos de carácter del nodo.
  • DOMCharacterData::deleteData() - Eliminar una serie de caracteres del nodo
  • DOMCharacterData::insertData() - Inserta un string en la posición de 16-bit especificada
  • DOMCharacterData::substringData() - Extrae una serie de datos del nodo


Extrae una serie de datos del nodo

  • « DOMCharacterData::replaceData
  • DOMComment »
  • PHP Manual
  • DOMCharacterData
  • Extrae una serie de datos del nodo

DOMCharacterData::substringData

(PHP 5, PHP 7)

DOMCharacterData::substringData — Extrae una serie de datos del nodo

Descripción

public DOMCharacterData::substringData ( int $offset , int $count ) : string

Devuelve el substring especificado.

Parámetros

offset

Posición de inicio del substring a extraer.

count

El número de carácteres a extraer.

Valores devueltos

El substring especificado. Si la suma de offset y count excede la longitud, entonces todas las unidades de 16-bit hasta el final de la cadena son devueltas.

Errores/Excepciones

DOM_INDEX_SIZE_ERR

Lanzado si offset es negativo o mayor que el numero de unidades de 16-bit en la data, o si count es negativo.

Ver también

  • DOMCharacterData::appendData() - Añade el string de caracteres al final de los datos de carácter del nodo.
  • DOMCharacterData::deleteData() - Eliminar una serie de caracteres del nodo
  • DOMCharacterData::insertData() - Inserta un string en la posición de 16-bit especificada
  • DOMCharacterData::replaceData() - Reemplaza un substring dentro de un nodo DOMCharacterData


Clase DOMComment

(PHP 5, PHP 7)

Introducción

Representa nodos comentario, caracteres delimitados por <!-- y -->.

Sinopsis de la Clase

DOMComment extends DOMCharacterData {
/* Propiedades heredadas */
public string $data ;
public readonly int $length ;
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public __construct ( string $value = ? )
/* Métodos heredados */
public DOMCharacterData::appendData ( string $data ) : void
public DOMCharacterData::deleteData ( int $offset , int $count ) : void
public DOMCharacterData::insertData ( int $offset , string $data ) : void
public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : void
public DOMCharacterData::substringData ( int $offset , int $count ) : string
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Ver también

  • » Especificación W3C de Comment

Tabla de contenidos

  • DOMComment::__construct — Crea un nuevo objeto DOMComment


Crea un nuevo objeto DOMComment

  • « DOMComment
  • DOMDocument »
  • PHP Manual
  • DOMComment
  • Crea un nuevo objeto DOMComment

DOMComment::__construct

(PHP 5, PHP 7)

DOMComment::__construct — Crea un nuevo objeto DOMComment

Descripción

public DOMComment::__construct ( string $value = ? )

Crea un nuevo objeto DOMComment . Este objeto es de solo lectura. Puede ser anexado a un documento, pero nodos adicionales no pueden ser anexados a este nodo hasta tando no haya sido asociado con un documento. Para crear un nodo modificable utilice DOMDocument::createComment.

Parámetros

value

El valor del comentario.

Ejemplos

Ejemplo #1 Creando un nuevo DOMComment

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$comment = $element->appendChild(new DOMComment('root comment'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root><!--root comment--></root> */

?>

Ver también

  • DOMDocument::createComment() - Crea un nuevo nodo de comentario


Clase DOMDocument

(PHP 5, PHP 7)

Introducción

Representa un documento HTML o XML en su totalidad; sirve como raíz del árbol de documento.

Sinopsis de la Clase

DOMDocument extends DOMNode {
/* Propiedades */
readonly public string $actualEncoding ;
readonly public DOMConfiguration $config ;
readonly public DOMDocumentType $doctype ;
readonly public DOMElement $documentElement ;
public string $documentURI ;
public string $encoding ;
public bool $formatOutput ;
readonly public DOMImplementation $implementation ;
public bool $preserveWhiteSpace = true ;
public bool $recover ;
public bool $resolveExternals ;
public bool $standalone ;
public bool $strictErrorChecking = true ;
public bool $substituteEntities ;
public bool $validateOnParse = false ;
public string $version ;
readonly public string $xmlEncoding ;
public bool $xmlStandalone ;
public string $xmlVersion ;
/* Métodos */
public __construct ( string $version = ? , string $encoding = ? )
public createAttribute ( string $name ) : DOMAttr
public createAttributeNS ( string $namespaceURI , string $qualifiedName ) : DOMAttr
public createCDATASection ( string $data ) : DOMCDATASection
public createComment ( string $data ) : DOMComment
public createDocumentFragment ( ) : DOMDocumentFragment
public createElement ( string $name , string $value = ? ) : DOMElement
public createElementNS ( string $namespaceURI , string $qualifiedName , string $value = ? ) : DOMElement
public createEntityReference ( string $name ) : DOMEntityReference
public createProcessingInstruction ( string $target , string $data = ? ) : DOMProcessingInstruction
public createTextNode ( string $content ) : DOMText
public getElementById ( string $elementId ) : DOMElement
public getElementsByTagName ( string $name ) : DOMNodeList
public getElementsByTagNameNS ( string $namespaceURI , string $localName ) : DOMNodeList
public importNode ( DOMNode $importedNode , bool $deep = false ) : DOMNode
public load ( string $filename , int $options = 0 ) : mixed
public loadHTML ( string $source , int $options = 0 ) : bool
public loadHTMLFile ( string $filename , int $options = 0 ) : bool
public loadXML ( string $source , int $options = 0 ) : mixed
public normalizeDocument ( ) : void
public registerNodeClass ( string $baseclass , string $extendedclass ) : bool
public relaxNGValidate ( string $filename ) : bool
public relaxNGValidateSource ( string $source ) : bool
public save ( string $filename , int $options = 0 ) : int
public saveHTML ( DOMNode $node = NULL ) : string
public saveHTMLFile ( string $filename ) : int
public saveXML ( DOMNode $node = ? , int $options = 0 ) : string
public schemaValidate ( string $filename , int $flags = 0 ) : bool
public schemaValidateSource ( string $source , int $flags = ? ) : bool
public validate ( ) : bool
public xinclude ( int $options = 0 ) : int
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

actualEncoding

Obsoleto. Codificación actual del documento, es el equivalente de solo lectura de encoding.

config

Obsoleto. Configuración utilizada cuando DOMDocument::normalizeDocument() es invocado.

doctype

La declaración de tipo de documento asociada con este documento.

documentElement

Este es un atributo de conveniencia que permite acceso directo al nodo hijo que es el elemento documento del documento.

documentURI

La ubicación del documento o null si es indefinida.

encoding

Codificación del documento, como ha sido especificada en la declaración XML. Este atributo no está presente en la especificación DOM Nivel 3, pero es la única manera de manipular la codificación de un documento XML en esta implementación.

formatOutput

Da formato a la salida con identación y espacios extra.

implementation

El objeto DOMImplementation que maneja este documento.

preserveWhiteSpace

No remover espacios en blanco redundantes. Predeterminado a true.

recover

Proprietario. Activa el modo de recuperación. Ejemplo: intentar analizar documentos mal formados. Este atributo no es parte de la especificación DOM y es especifica para libxml.

resolveExternals

Asigne true para cargar entidades externas a una declaración doctype. Es útil para incluir entidades de caracteres en su documento XML.

standalone

Obsoleto. Si este documento es o no independiente, tal como ha sido especificado por la declaración XML, corresponde a xmlStandalone.

strictErrorChecking

Lanzar DOMException en caso de errores. Predeterminado a true.

substituteEntities

Proprietario.Si se substituyen o no las entidades. Este atributo no forma parte de la especificación DOM y es específico para libxml.

validateOnParse

Cargar y validar contra la DTD. Predeterminado a false.

version

Obsoleto. Versión de XML, corresponde a xmlVersion.

xmlEncoding

Un atributo que forma parte de la declaración XML y especifica la codificación de este documento. Es null cuando no ha sido especificado o se desconoce, como cuando el documento fue creado en memoria.

xmlStandalone

Un atributo que forma parte de la declaración XML y especifica cuando este documento es independiente. Es false cuando no ha sido especificado.

xmlVersion

Un atributo que forma parte de la declaracion XML y especifica el número de versión de este documento. Si no hay declaración y este documento soporta la característica "XML" el valor es "1.0".

Notas

Nota:

La extensión DOM utiliza la codificación UTF-8. Use utf8_encode() y utf8_decode() para trabajar con textos con codificación ISO-8859-1 o Iconv para otras codificaciones.

Ver también

  • » Especificación W3C para Document

Tabla de contenidos

  • DOMDocument::__construct — Crea un nuevo objeto DOMDocument
  • DOMDocument::createAttribute — Crear nuevo attribute
  • DOMDocument::createAttributeNS — Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection — Crea un nuevo nodo cdata
  • DOMDocument::createComment — Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment — Crea un nuevo fragmento de documento
  • DOMDocument::createElement — Crea un nuevo nodo elemento
  • DOMDocument::createElementNS — Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference — Create new entity reference node
  • DOMDocument::createProcessingInstruction — Crea un nuevo nodo PI
  • DOMDocument::createTextNode — Crea un nuevo nodo de texto
  • DOMDocument::getElementById — Busca un elemento con cierto id
  • DOMDocument::getElementsByTagName — Busca todos los elementos con el nombre de etiqueta local dado
  • DOMDocument::getElementsByTagNameNS — Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.
  • DOMDocument::importNode — Importa un nodo dentro del documento actual
  • DOMDocument::load — Cargar un documento XML de un archivo.
  • DOMDocument::loadHTML — Cargar HTML de una cadena
  • DOMDocument::loadHTMLFile — Cargar HTML desde un fichero
  • DOMDocument::loadXML — Cargar XML desde una cadena
  • DOMDocument::normalizeDocument — Normaliza el documento
  • DOMDocument::registerNodeClass — Registra una clase extendida usada para crear tipos de nodos base
  • DOMDocument::relaxNGValidate — Realiza una validación relaxNG del documento
  • DOMDocument::relaxNGValidateSource — Realiza una validación relaxNG del documento
  • DOMDocument::save — Copia el árbol XML interno a un archivo
  • DOMDocument::saveHTML — Copia el documento interno a una cadena usando el formato HTML
  • DOMDocument::saveHTMLFile — Copia el documento interno a un fichero usando el formato HTML
  • DOMDocument::saveXML — Copia el arbol XML interno a un string
  • DOMDocument::schemaValidate — Valida un documento basado en un esquema
  • DOMDocument::schemaValidateSource — Valida un documento basado en un esquema
  • DOMDocument::validate — Valida el documento basado en su DTD
  • DOMDocument::xinclude — Sustituye XIncludes en un objeto DOMDocument


Crea un nuevo objeto DOMDocument

  • « DOMDocument
  • DOMDocument::createAttribute »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo objeto DOMDocument

DOMDocument::__construct

(PHP 5, PHP 7)

DOMDocument::__construct — Crea un nuevo objeto DOMDocument

Descripción

public DOMDocument::__construct ( string $version = ? , string $encoding = ? )

Crea un nuevo objeto DOMDocument .

Parámetros

version

El numero de versión del documento como parte de la declaración XML.

encoding

La codificación del documento como parte de la declaración XML.

Ejemplos

Ejemplo #1 Creando un nuevo DOMDocument

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');

echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?> */

?>

Ver también

  • DOMImplementation::createDocument() - Crea un objeto DOMDocument del tipo especificado con su elemento documento


Crear nuevo attribute

  • « DOMDocument::__construct
  • DOMDocument::createAttributeNS »
  • PHP Manual
  • DOMDocument
  • Crear nuevo attribute

DOMDocument::createAttribute

(PHP 5, PHP 7)

DOMDocument::createAttribute — Crear nuevo attribute

Descripción

public DOMDocument::createAttribute ( string $name ) : DOMAttr

Esta función crea una nueva instancia de la clase DOMAttr. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

name

El nombre del atributo.

Valores devueltos

El nuevo DOMAttr o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado si name contiene un carácter inválido.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo atributo con un namespace asociado.

  • « DOMDocument::createAttribute
  • DOMDocument::createCDATASection »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo atributo con un namespace asociado.

DOMDocument::createAttributeNS

(PHP 5, PHP 7)

DOMDocument::createAttributeNS — Crea un nuevo nodo atributo con un namespace asociado.

Descripción

public DOMDocument::createAttributeNS ( string $namespaceURI , string $qualifiedName ) : DOMAttr

Esta función crea una nueva instancia de la clase DOMAttr. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

namespaceURI

El URI del namespace.

qualifiedName

El nombre de etiqueta y prefijo del atributo, como prefix:tagname.

Valores devueltos

El nuevo DOMAttr o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado siqualifiedName contiene un carácter inválido.

DOM_NAMESPACE_ERR

Lanzado si qualifiedName es un nombre calificado mal formado , o si qualifiedName tiene un prefijo y namespaceURI es null.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo cdata

  • « DOMDocument::createAttributeNS
  • DOMDocument::createComment »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo cdata

DOMDocument::createCDATASection

(PHP 5, PHP 7)

DOMDocument::createCDATASection — Crea un nuevo nodo cdata

Descripción

public DOMDocument::createCDATASection ( string $data ) : DOMCDATASection

Esta función crea una nueva instancia de la clase DOMCDATASection. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

data

El contenido del cdata.

Valores devueltos

El nuevo DOMCDATASection o false si ha ocurrido un error.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo de comentario

  • « DOMDocument::createCDATASection
  • DOMDocument::createDocumentFragment »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo de comentario

DOMDocument::createComment

(PHP 5, PHP 7)

DOMDocument::createComment — Crea un nuevo nodo de comentario

Descripción

public DOMDocument::createComment ( string $data ) : DOMComment

Esta función crea una nueva instancia de la clase DOMComment. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

data

El contenido del comentario.

Valores devueltos

El nuevo DOMComment o false si ha ocurrido un error.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo fragmento de documento

  • « DOMDocument::createComment
  • DOMDocument::createElement »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo fragmento de documento

DOMDocument::createDocumentFragment

(PHP 5, PHP 7)

DOMDocument::createDocumentFragment — Crea un nuevo fragmento de documento

Descripción

public DOMDocument::createDocumentFragment ( ) : DOMDocumentFragment

Esta función crea una nueva instancia de la clase DOMDocumentFragment. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Valores devueltos

El nuevo DOMDocumentFragment o false si ha ocurrido un error.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo elemento

  • « DOMDocument::createDocumentFragment
  • DOMDocument::createElementNS »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo elemento

DOMDocument::createElement

(PHP 5, PHP 7)

DOMDocument::createElement — Crea un nuevo nodo elemento

Descripción

public DOMDocument::createElement ( string $name , string $value = ? ) : DOMElement

Esta función crea una nueva instancia de la clase DOMElement. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

name

El nombre de etiqueta del elemento.

value

El valor del elemento. De manera predeterminada se creará un elemento vacio. El valor también puede ser asignado más tarde con DOMElement::$nodeValue.

El valor es usado al pie de la letra, excepto que las referencias de entidad < y > se escaparán. Tenga en cuenta que & tiene que ser escapado manualmente; de lo contrario, se tomará como inicio de una referencia de entidad. Además " no sera escapado.

Valores devueltos

Devuelve una nueva instanca de la clase DOMElement o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado si name contiene un carácter inválido.

Ejemplos

Ejemplo #1 Crear un nuevo elemento e insertarlo como raíz

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElement('test', 'This is the root element!');

// Insertamos el nuevo elemento como raíz (hijo del documento)
$dom->appendChild($element);

echo $dom->saveXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<test>This is the root element!</test>

Ejemplo #2 Pasando texto que contiene un & sin escapar como valor

<?php
$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->createElement('foo', 'me & you');
$dom->appendChild($element);
echo $dom->saveXML();
?>

El resultado del ejemplo sería algo similar a:

Warning: DOMDocument::createElement(): unterminated entity reference             you in /in/BjTCg on line 4
<?xml version="1.0" encoding="utf-8"?>
<foo/>

Notas

Nota:

El parámetro value no será escapado. Utilice DOMDocument::createTextNode() para crear un nodo de texto con soporte para escape de carácteres.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo elemento con el nombre de espacio asociado

  • « DOMDocument::createElement
  • DOMDocument::createEntityReference »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo elemento con el nombre de espacio asociado

DOMDocument::createElementNS

(PHP 5, PHP 7)

DOMDocument::createElementNS — Crea un nuevo nodo elemento con el nombre de espacio asociado

Descripción

public DOMDocument::createElementNS ( string $namespaceURI , string $qualifiedName , string $value = ? ) : DOMElement

Esta función crea un nuevo nodo elemento con el nombre de espacio asociado. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

namespaceURI

El URI del nombre de espacio.

qualifiedName

Elo nombre cualificado del elemento, como prefix:tagname.

value

El valor del elemento. De manera predeterminada se creará un elemento vacio. El valor también puede ser asignado más tarde con DOMElement::$nodeValue.

Valores devueltos

El nuevo DOMElement o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado si qualifiedName contiene un carácter inválido.

DOM_NAMESPACE_ERR

Lanzado si qualifiedName es un nombre cualificado mal formado.

Ejemplos

Ejemplo #1 Crear un nuevo elemento e insertarlo como raíz

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElementNS('http://www.example.com/XFoo', 'xfoo:test', 'This is the root element!');

// Insertamos el nuevo elemento como raíz (hijo del documento)
$dom->appendChild($element);

echo $dom->saveXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<xfoo:test xmlns:xfoo="http://www.example.com/XFoo">This is the root element!</xfoo:test>

Ejemplo #2 Un ejemplo de prefijo de nombre de espacio

<?php
$doc  = new DOMDocument('1.0', 'utf-8');
$doc->formatOutput = true;
$root = $doc->createElementNS('http://www.w3.org/2005/Atom', 'element');
$doc->appendChild($root);
$root->setAttributeNS('http://www.w3.org/2000/xmlns/' ,'xmlns:g', 'http://base.google.com/ns/1.0');
$item = $doc->createElementNS('http://base.google.com/ns/1.0', 'g:item_type', 'house');
$root->appendChild($item);

echo $doc->saveXML(), "\n";

echo $item->namespaceURI, "\n"; // Outputs: http://base.google.com/ns/1.0
echo $item->prefix, "\n";       // Outputs: g
echo $item->localName, "\n";    // Outputs: item_type
?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<element xmlns="http://www.w3.org/2005/Atom" xmlns:g="http://base.google.com/ns/1.0">
  <g:item_type>house</g:item_type>
</element>

http://base.google.com/ns/1.0
g
item_type

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Create new entity reference node

  • « DOMDocument::createElementNS
  • DOMDocument::createProcessingInstruction »
  • PHP Manual
  • DOMDocument
  • Create new entity reference node

DOMDocument::createEntityReference

(PHP 5, PHP 7)

DOMDocument::createEntityReference — Create new entity reference node

Descripción

public DOMDocument::createEntityReference ( string $name ) : DOMEntityReference

Esta función crea una nueva instancia de la clase DOMEntityReference. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

name

El contenido de la entidad referencia, p.ej. la entidad referencia menos los carácteres & inicial y el ; final.

Valores devueltos

El nuevo DOMEntityReference o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado si name contiene un carácter inválido.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo PI

  • « DOMDocument::createEntityReference
  • DOMDocument::createTextNode »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo PI

DOMDocument::createProcessingInstruction

(PHP 5, PHP 7)

DOMDocument::createProcessingInstruction — Crea un nuevo nodo PI

Descripción

public DOMDocument::createProcessingInstruction ( string $target , string $data = ? ) : DOMProcessingInstruction

Esta función crea una nueva instancia de la clase DOMProcessingInstruction. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

target

El objetivo de la instrucción de procesamiento.

data

El contenido de la instrucción de procesamiento.

Valores devueltos

El nuevo DOMProcessingInstruction o false si ha ocurrido un error.

Errores/Excepciones

DOM_INVALID_CHARACTER_ERR

Lanzado si target contiene un carácter inválido.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Crea un nuevo nodo de texto

  • « DOMDocument::createProcessingInstruction
  • DOMDocument::getElementById »
  • PHP Manual
  • DOMDocument
  • Crea un nuevo nodo de texto

DOMDocument::createTextNode

(PHP 5, PHP 7)

DOMDocument::createTextNode — Crea un nuevo nodo de texto

Descripción

public DOMDocument::createTextNode ( string $content ) : DOMText

Esta función crea una nueva instancia de la clase DOMText. Este nodo no se mostrará en el documento a no ser que sea insertado con (p.e.j.) DOMNode::appendChild().

Parámetros

content

El contenido del texto.

Valores devueltos

El nuevo DOMText o false si ha ocurrido un error.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMDocument::createAttribute() - Crear nuevo attribute
  • DOMDocument::createAttributeNS() - Crea un nuevo nodo atributo con un namespace asociado.
  • DOMDocument::createCDATASection() - Crea un nuevo nodo cdata
  • DOMDocument::createComment() - Crea un nuevo nodo de comentario
  • DOMDocument::createDocumentFragment() - Crea un nuevo fragmento de documento
  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI


Busca un elemento con cierto id

  • « DOMDocument::createTextNode
  • DOMDocument::getElementsByTagName »
  • PHP Manual
  • DOMDocument
  • Busca un elemento con cierto id

DOMDocument::getElementById

(PHP 5, PHP 7)

DOMDocument::getElementById — Busca un elemento con cierto id

Descripción

public DOMDocument::getElementById ( string $elementId ) : DOMElement

Esta función es similar a DOMDocument::getElementsByTagNamepero busca un elemento con el id dado.

Para que esta función trabaje, necesitará asignar algunos atributos ID con DOMElement::setIdAttribute o un DTD que defina un atributo de tipo ID. En el último caso necesitará validar el documento con DOMDocument::validate o DOMDocument::$validateOnParse antes de utilizar esta función.

Parámetros

elementId

El valor de id único para un elemento.

Valores devueltos

Devuelve el DOMElement o null si el elemento no ha sido encontrado.

Ejemplos

Ejemplo #1 Ejemplo de DOMDocument::getElementById()

Los siguientes ejemplos usan book.xml, cuyo contenido es el siguiente:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE books [
  <!ELEMENT books   (book+)>
  <!ELEMENT book    (title, author+, xhtml:blurb?)>
  <!ELEMENT title   (#PCDATA)>
  <!ELEMENT blurb   (#PCDATA)>
  <!ELEMENT author  (#PCDATA)>
  <!ATTLIST books   xmlns        CDATA  #IMPLIED>
  <!ATTLIST books   xmlns:xhtml  CDATA  #IMPLIED>
  <!ATTLIST book    id           ID     #IMPLIED>
  <!ATTLIST author  email        CDATA  #IMPLIED>
]>
<?xml-stylesheet type="text/xsl" href="style.xsl"?>
<books xmlns="http://books.php/" xmlns:xhtml="http://www.w3.org/1999/xhtml">
  <book id="php-basics">
    <title>PHP Basics</title>
    <author email="jim.smith@basics.php">Jim Smith</author>
    <author email="jane.smith@basics.php">Jane Smith</author>
    <xhtml:blurb><![CDATA[
<p><em>PHP Basics</em> provides an introduction to PHP.</p>
]]></xhtml:blurb>
  </book>
  <book id="php-advanced">
    <title>PHP Advanced Programming</title>
    <author email="jon.doe@advanced.php">Jon Doe</author>
  </book>
</books>
<?php

$doc = new DomDocument;

// Necesitamos validar nuestro documento antes de referirnos al id
$doc->validateOnParse = true;
$doc->Load('book.xml');

echo "The element whose id is 'php-basics' is: " . $doc->getElementById('php-basics')->tagName . "\n";

?>

El resultado del ejemplo sería:

The element whose id is 'php-basics' is: book

Ver también

  • DOMDocument::getElementsByTagName() - Busca todos los elementos con el nombre de etiqueta local dado


Busca todos los elementos con el nombre de etiqueta local dado

  • « DOMDocument::getElementById
  • DOMDocument::getElementsByTagNameNS »
  • PHP Manual
  • DOMDocument
  • Busca todos los elementos con el nombre de etiqueta local dado

DOMDocument::getElementsByTagName

(PHP 5, PHP 7)

DOMDocument::getElementsByTagName — Busca todos los elementos con el nombre de etiqueta local dado

Descripción

public DOMDocument::getElementsByTagName ( string $name ) : DOMNodeList

Esta función devuelve una nueva instancia de la clase DOMNodeList que contiene los elementos con el nombre de etiqueta local buscado.

Parámetros

name

El nombre local (sin namespace) de la etiqueta con el cual se hará comparación. El valor especial * coincindirá con todas las etiquetas.

Valores devueltos

Un nuevo objeto DOMNodeList que contiene todos los elementos coincidentes.

Ejemplos

Ejemplo #1 Ejemplo de uso básico

<?php
$xml = <<< XML
<?xml version="1.0" encoding="utf-8"?>
<books>
 <book>Patrones de Arquitectura de Aplicaciones Empresariales</book>
 <book>Patrones de diseño: elementos de diseño de software reutilizable</book>
 <book>Código limpio</book>
</books>
XML;

$dom = new DOMDocument;
$dom->loadXML($xml);
$books = $dom->getElementsByTagName('book');
foreach ($books as $book) {
    echo $book->nodeValue, PHP_EOL;
}
?>

El resultado del ejemplo sería:

Patrones de Arquitectura de Aplicaciones Empresariales
Patrones de diseño: elementos de diseño de software reutilizable
Código limpio

Ver también

  • DOMDocument::getElementsByTagNameNS() - Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.


Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.

  • « DOMDocument::getElementsByTagName
  • DOMDocument::importNode »
  • PHP Manual
  • DOMDocument
  • Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.

DOMDocument::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMDocument::getElementsByTagNameNS — Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.

Descripción

public DOMDocument::getElementsByTagNameNS ( string $namespaceURI , string $localName ) : DOMNodeList

Devuelve un DOMNodeList de todos los elementos con el nombre local dado y el URI del espacio de nombre.

Parámetros

namespaceURI

El URI del espacio de nombre de los elementos en los que se buscara. El valor especial * coincide con todos los espacios de nombre.

localName

El nombre local de los elementos buscados. El valor especial * coincide con todos los nombres locales.

Valores devueltos

Un nuevo objeto DOMNodeList que contiene todos los elementos coincidentes.

Ejemplos

Ejemplo #1 Obtener todos los elementos XInclude

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
<title>Books of the other guy..</title>
<para>
 <xi:include href="book.xml">
  <xi:fallback>
   <error>xinclude: book.xml not found</error>
  </xi:fallback>
 </xi:include>
 <include>
  This is another namespace
 </include>
</para>
</chapter>
EOD;
$dom = new DOMDocument;

// load the XML string defined above
$dom->loadXML($xml);

foreach ($dom->getElementsByTagNameNS('http://www.w3.org/2001/XInclude', '*') as $element) {
    echo 'local name: ', $element->localName, ', prefix: ', $element->prefix, "\n";
}
?>

El resultado del ejemplo sería:

local name: include, prefix: xi
local name: fallback, prefix: xi

Ver también

  • DOMDocument::getElementsByTagName() - Busca todos los elementos con el nombre de etiqueta local dado


Importa un nodo dentro del documento actual

  • « DOMDocument::getElementsByTagNameNS
  • DOMDocument::load »
  • PHP Manual
  • DOMDocument
  • Importa un nodo dentro del documento actual

DOMDocument::importNode

(PHP 5, PHP 7)

DOMDocument::importNode — Importa un nodo dentro del documento actual

Descripción

public DOMDocument::importNode ( DOMNode $importedNode , bool $deep = false ) : DOMNode

Esta función devuelve una copia del nodo a importar y le asocia con el documento actual.

Parámetros

importedNode

El nodo que desea importar

deep

Si se establece en true, este método importará de forma recursiva el subárbol bajo el importedNode.

Nota:

Para copiar los atributos de los nodos deep debe establecerse a true

Valores devueltos

El nodo copiado o false, si no puede ser copiado.

Errores/Excepciones

DOMException es lanzado si el nodo no puede ser importado.

Ejemplos

Ejemplo #1 DOMDocument::importNode() ejemplo

Copiando nodos entre documentos.

<?php

$orgdoc = new DOMDocument;
$orgdoc->loadXML("<root><element><child>text in child</child></element></root>");

// El nodo que se quiere importar al nuevo documento
$node = $orgdoc->getElementsByTagName("element")->item(0);

// Crear un nuevo documento
$newdoc = new DOMDocument;
$newdoc->formatOutput = true;

// Agregar marcado
$newdoc->loadXML("<root><someelement>text in some element</someelement></root>");

echo "The 'new document' before copying nodes into it:\n";
echo $newdoc->saveXML();

// Importar el nodo y todos sus hijos al documento
$node = $newdoc->importNode($node, true);
// y entonces anexarlo a el nodo "<root>"
$newdoc->documentElement->appendChild($node);

echo "\nThe 'new document' after copying the nodes into it:\n";
echo $newdoc->saveXML();
?>

El resultado del ejemplo sería:

The 'new document' before copying nodes into it:
<?xml version="1.0"?>
<root>
  <someelement>text in some element</someelement>
</root>

The 'new document' after copying the nodes into it:
<?xml version="1.0"?>
<root>
  <someelement>text in some element</someelement>
  <element>
    <child>text in child</child>
  </element>
</root>


Cargar un documento XML de un archivo.

  • « DOMDocument::importNode
  • DOMDocument::loadHTML »
  • PHP Manual
  • DOMDocument
  • Cargar un documento XML de un archivo.

DOMDocument::load

(PHP 5, PHP 7)

DOMDocument::load — Cargar un documento XML de un archivo.

Descripción

public DOMDocument::load ( string $filename , int $options = 0 ) : mixed

Carga un documento XML de un archivo.

Advertencia

Rutas tipo Unix con barras inclinadas hacia a delante, pueden causar una degradacion significativa de rendimiento en sistemas Windows, si es el caso, asegúrese de llamar realpath().

Parámetros

filename

La ruta al documento XML.

options

Bitwise OR de las constantes de opción libxml.constants.html.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si se llama estáticamente, devuelve un DOMDocument o false en caso de error.

Errores/Excepciones

Si una cadena vacia es pasada como el filename o se pasa el nombre de un archivo vacío, se generará una advertencia. Esta advertencia no es generada por libxml y no puede ser manejada utilizando las funciones de manejo de erro de libxml.

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Ejemplos

Ejemplo #1 Creando un Documento

<?php
$doc = new DOMDocument();
$doc->load('book.xml');
echo $doc->saveXML();
?>

Ver también

  • DOMDocument::loadXML() - Cargar XML desde una cadena
  • DOMDocument::save() - Copia el árbol XML interno a un archivo
  • DOMDocument::saveXML() - Copia el arbol XML interno a un string


Cargar HTML de una cadena

  • « DOMDocument::load
  • DOMDocument::loadHTMLFile »
  • PHP Manual
  • DOMDocument
  • Cargar HTML de una cadena

DOMDocument::loadHTML

(PHP 5, PHP 7)

DOMDocument::loadHTML — Cargar HTML de una cadena

Descripción

public DOMDocument::loadHTML ( string $source , int $options = 0 ) : bool

Esta función procesa el HTML contenido en la cadena source. De manera distinta a cargar XML, HTML no tiene que estar bien formado para cargarse. Esta función también puede llamarse estáticamente para cargar y crear un objeto DOMDocument. La invocación estática puede utilizarse aún cuando ninguna propiedad de DOMDocument haya sido establecida antes de la lectura.

Parámetros

source

La cadena HTML.

options

Desde PHP 5.4.0 y Libxml 2.6.0, se puede usar el parámetro options para especificar parámetros de Libxml adicionales.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si es llamada de manera estática devuelve un objeto DOMDocument o false en caso de error.

Errores/Excepciones

Si una cadena vacía es pasada como el source o se pasa el nombre de un archivo vacío, se generará una advertencia. Esta advertencia no es generada por libxml y no puede ser manejada utilizando las funciones de manejo de errores de libxml.

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Aunque el HTML malformado debería cargar con éxito, esta función puede generar errores E_WARNING al encontrarse con marcado erróneo. Se pueden usar las funciones de manejo de errores de libxml para manejar estos errores.

Ejemplos

Ejemplo #1 Creando un Documento

<?php
$doc = new DOMDocument();
$doc->loadHTML("<html><body>Test<br></body></html>");
echo $doc->saveHTML();
?>

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámero options.

Ver también

  • DOMDocument::loadHTMLFile() - Cargar HTML desde un fichero
  • DOMDocument::saveHTML() - Copia el documento interno a una cadena usando el formato HTML
  • DOMDocument::saveHTMLFile() - Copia el documento interno a un fichero usando el formato HTML


Cargar HTML desde un fichero

  • « DOMDocument::loadHTML
  • DOMDocument::loadXML »
  • PHP Manual
  • DOMDocument
  • Cargar HTML desde un fichero

DOMDocument::loadHTMLFile

(PHP 5, PHP 7)

DOMDocument::loadHTMLFile — Cargar HTML desde un fichero

Descripción

public DOMDocument::loadHTMLFile ( string $filename , int $options = 0 ) : bool

Esta función analiza el documento HTML del fichero llamado filename. A diferencia de cargar XML, HTML no tiene que estar bien formado para cargarse.

Parámetros

filename

La ruta al fichero HTML.

options

Desde PHP 5.4.0 y Libxml 2.6.0, se puede usar el parámetro options para especificar parámetros de Libxml adicionales.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si se llama estáticamente, devuelve un DOMDocument o false en caso de error.

Errores/Excepciones

Si se pasa una cadena vacía a filename o se nombra un fichero vacío, se generará una advertencia. Esta advertencia no es generada por libxml y no se puede tratar usando funciones de manejo de errores de libxml.

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Aunque el HTML malformado debería cargar con éxito, esta función puede generar errores E_WARNING al encontrarse con marcado erróneo. Se pueden usar las funciones de manejo de errores de libxml para manejar estos errores.

Ejemplos

Ejemplo #1 Crear un Documento

<?php
$doc = new DOMDocument();
$doc->loadHTMLFile("filename.html");
echo $doc->saveHTML();
?>

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámero options.

Ver también

  • DOMDocument::loadHTML() - Cargar HTML de una cadena
  • DOMDocument::saveHTML() - Copia el documento interno a una cadena usando el formato HTML
  • DOMDocument::saveHTMLFile() - Copia el documento interno a un fichero usando el formato HTML


Cargar XML desde una cadena

  • « DOMDocument::loadHTMLFile
  • DOMDocument::normalizeDocument »
  • PHP Manual
  • DOMDocument
  • Cargar XML desde una cadena

DOMDocument::loadXML

(PHP 5, PHP 7)

DOMDocument::loadXML — Cargar XML desde una cadena

Descripción

public DOMDocument::loadXML ( string $source , int $options = 0 ) : mixed

Carga un documento XML desde una cadena.

Parámetros

source

La cadena que contiene el XML.

options

Operador a nivel de bits OR de las constantes de opciones libxml.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si se llama estáticamente, devuelve un DOMDocument o false en caso de error.

Errores/Excepciones

Si se pasa una cadena vacía a source, se generará una advertencia. Esta advertencia no es generada por libxml y no puede ser tratada usando funciones de manejo de errores de libxml.

Ejemplos

Ejemplo #1 Crear un Documento

<?php
$doc = new DOMDocument();
$doc->loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Ejemplo #2 Invocación estática de loadXML

<?php
$doc = DOMDocument::loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Ver también

  • DOMDocument::load() - Cargar un documento XML de un archivo.
  • DOMDocument::save() - Copia el árbol XML interno a un archivo
  • DOMDocument::saveXML() - Copia el arbol XML interno a un string


Normaliza el documento

  • « DOMDocument::loadXML
  • DOMDocument::registerNodeClass »
  • PHP Manual
  • DOMDocument
  • Normaliza el documento

DOMDocument::normalizeDocument

(PHP 5, PHP 7)

DOMDocument::normalizeDocument — Normaliza el documento

Descripción

public DOMDocument::normalizeDocument ( ) : void

Este método actúa como si guardara y después cargara el documento, poniendo el el documento en una forma "normal".

Valores devueltos

No devuelve ningún valor.

Ver también

  • » La Especificación DOM
  • DOMNode::normalize() - Normaliza el nodo


Registra una clase extendida usada para crear tipos de nodos base

  • « DOMDocument::normalizeDocument
  • DOMDocument::relaxNGValidate »
  • PHP Manual
  • DOMDocument
  • Registra una clase extendida usada para crear tipos de nodos base

DOMDocument::registerNodeClass

(PHP 5 >= 5.2.0, PHP 7)

DOMDocument::registerNodeClass — Registra una clase extendida usada para crear tipos de nodos base

Descripción

public DOMDocument::registerNodeClass ( string $baseclass , string $extendedclass ) : bool

Este método permite registrar su propia clase DOM extendida para usarla después por la extensión DOM de PHP.

Este método no es parte del estándar DOM.

Parámetros

baseclass

La clase DOM que se quiere extender. Se puede encontrar una lista de estas clases en el capítulo introducción.

extendedclass

El nombre de la clase extendida. Si se proporciona null, cualquier clase registrada previamente que extienda baseclass será eliminada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.2.2 | Antes de 5.2.2, una extendedclass previamente registrada teniá que ser desregistrada antes de poder registrar una nueva clase que extendiese a la misma baseclass.

Ejemplos

Ejemplo #1 Añadir un nuevo método a DOMElement para facilitar su código

<?php

class myElement extends DOMElement {
   function appendElement($name) {
      return $this->appendChild(new myElement($name));
   }
}

class myDocument extends DOMDocument {
   function setRoot($name) {
      return $this->appendChild(new myElement($name));
   }
}

$doc = new myDocument();
$doc->registerNodeClass('DOMElement', 'myElement');

// A partir de ahora, ¡ añadir un elemento a otro sólo cuesta una llamada al método !
$root = $doc->setRoot('root');
$child = $root->appendElement('child');
$child->setAttribute('foo', 'bar');

echo $doc->saveXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0"?>
<root><child foo="bar"/></root>

Ejemplo #2 Recuperar elementos como clase personalizada

<?php
class myElement extends DOMElement {
    public function __toString() {
        return $this->nodeValue;
    }
}

$doc = new DOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");
$doc->registerNodeClass("DOMElement", "myElement");

$element = $doc->getElementsByTagName("child")->item(0);
var_dump(get_class($element));

// Y tomar ventaja del método __toString ...
echo $element;
?>

El resultado del ejemplo sería:

string(9) "myElement"
text in child

Ejemplo #3 Recuperar un propio documento

Al instanciar un DOMDocument personalizado, la propiedad ownerDocument se referirá a la clase instanciada, lo que significa que no hay necesidad (y de hecho no es posible) de usar DOMDocument::registerNodeClass() con DOMDocument

<?php
class myDOMDocument extends DOMDocument {
}

class myOtherDOMDocument extends DOMDocument {
}

// Crear myDOMDocument con algo de XML
$doc = new myDOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");

$child = $doc->getElementsByTagName("child")->item(0);

// El actual propietario del nodo es myDOMDocument
var_dump(get_class($child->ownerDocument));

// Importar un nodo desde myDOMDocument
$newdoc = new myOtherDOMDocument;
$child = $newdoc->importNode($child);

// El propietario del nodo ha cambiado a myOtherDOMDocument
var_dump(get_class($child->ownerDocument));
?>

El resultado del ejemplo sería:

string(13) "myDOMDocument"
string(18) "myOtherDOMDocument"


Realiza una validación relaxNG del documento

  • « DOMDocument::registerNodeClass
  • DOMDocument::relaxNGValidateSource »
  • PHP Manual
  • DOMDocument
  • Realiza una validación relaxNG del documento

DOMDocument::relaxNGValidate

(PHP 5, PHP 7)

DOMDocument::relaxNGValidate — Realiza una validación relaxNG del documento

Descripción

public DOMDocument::relaxNGValidate ( string $filename ) : bool

Realiza una validación » relaxNG del documento basándose en el esquema RNG dado.

Parámetros

filename

El fichero RNG.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMDocument::relaxNGValidateSource() - Realiza una validación relaxNG del documento
  • DOMDocument::schemaValidate() - Valida un documento basado en un esquema
  • DOMDocument::schemaValidateSource() - Valida un documento basado en un esquema
  • DOMDocument::validate() - Valida el documento basado en su DTD


Realiza una validación relaxNG del documento

  • « DOMDocument::relaxNGValidate
  • DOMDocument::save »
  • PHP Manual
  • DOMDocument
  • Realiza una validación relaxNG del documento

DOMDocument::relaxNGValidateSource

(PHP 5, PHP 7)

DOMDocument::relaxNGValidateSource — Realiza una validación relaxNG del documento

Descripción

public DOMDocument::relaxNGValidateSource ( string $source ) : bool

Realiza una validación » relaxNG del documento basándose en la fuente RNG dada.

Parámetros

source

Una cadena que contiene el esquema RNG.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMDocument::relaxNGValidate() - Realiza una validación relaxNG del documento
  • DOMDocument::schemaValidate() - Valida un documento basado en un esquema
  • DOMDocument::schemaValidateSource() - Valida un documento basado en un esquema
  • DOMDocument::validate() - Valida el documento basado en su DTD


Copia el árbol XML interno a un archivo

  • « DOMDocument::relaxNGValidateSource
  • DOMDocument::saveHTML »
  • PHP Manual
  • DOMDocument
  • Copia el árbol XML interno a un archivo

DOMDocument::save

(PHP 5, PHP 7)

DOMDocument::save — Copia el árbol XML interno a un archivo

Descripción

public DOMDocument::save ( string $filename , int $options = 0 ) : int

Crea un documento XML desde la representación DOM. Esta función normalmente se llama después de construir un nuevo documento desde ceros, como en el ejemplo de abajo.

Parámetros

filename

La ruta al documento XML guardado.

options

Opciones Adicionales. Actualmente sólo está soportada LIBXML_NOEMPTYTAG.

Valores devueltos

Devuelve el número de bytes escritos o false si ocurrió un error.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro options

Ejemplos

Ejemplo #1 Guardar un árbol DOM en un fichero

<?php

$doc = new DOMDocument('1.0');
// queremos una impresión buena
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('Este es el título');
$text = $title->appendChild($text);

echo 'Escrito: ' . $doc->save("/tmp/test.xml") . ' bytes'; // Escrito: 72 bytes

?>

Ver también

  • DOMDocument::saveXML() - Copia el arbol XML interno a un string
  • DOMDocument::load() - Cargar un documento XML de un archivo.
  • DOMDocument::loadXML() - Cargar XML desde una cadena


Copia el documento interno a una cadena usando el formato HTML

  • « DOMDocument::save
  • DOMDocument::saveHTMLFile »
  • PHP Manual
  • DOMDocument
  • Copia el documento interno a una cadena usando el formato HTML

DOMDocument::saveHTML

(PHP 5, PHP 7)

DOMDocument::saveHTML — Copia el documento interno a una cadena usando el formato HTML

Descripción

public DOMDocument::saveHTML ( DOMNode $node = NULL ) : string

Crea un documento HTML desde la representación DOM. Esta función normalmente se llama después de construir un nuevo documento desde cero, como en el ejemplo de abajo.

Parámetros

node

Parámetro opcional que devuelve una parte del documento.

Valores devueltos

Devuelve el HTML, o false si ocurrió un error.

Historial de cambios

Versión | Descripción
5.3.6 | El parámetro node fue añadido.

Ejemplos

Ejemplo #1 Salvar un árbol HTML en una cadena

<?php

$doc = new DOMDocument('1.0');

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('Este es el título');
$text = $title->appendChild($text);

echo $doc->saveHTML();

?>

Ver también

  • DOMDocument::saveHTMLFile() - Copia el documento interno a un fichero usando el formato HTML
  • DOMDocument::loadHTML() - Cargar HTML de una cadena
  • DOMDocument::loadHTMLFile() - Cargar HTML desde un fichero


Copia el documento interno a un fichero usando el formato HTML

  • « DOMDocument::saveHTML
  • DOMDocument::saveXML »
  • PHP Manual
  • DOMDocument
  • Copia el documento interno a un fichero usando el formato HTML

DOMDocument::saveHTMLFile

(PHP 5, PHP 7)

DOMDocument::saveHTMLFile — Copia el documento interno a un fichero usando el formato HTML

Descripción

public DOMDocument::saveHTMLFile ( string $filename ) : int

Crea un documento HTML desde la representación DOM. Esta función normalmente se llama después de construir un nuevo documento desde cero, como en el ejemplo de abajo.

Parámetros

filename

La ruta al documento HTML guardado.

Valores devueltos

Devuelve el número de bytes escritos o false si ocurrió un error.

Ejemplos

Ejemplo #1 Guardar un árbol HTML en un archivo

<?php

$doc = new DOMDocument('1.0');
// queremos una impresión buena
$doc->formatOutput = true;

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('Este es el título');
$text = $title->appendChild($text);

echo 'EScrito: ' . $doc->saveHTMLFile("/tmp/test.html") . ' bytes'; // Escrito: 129 bytes

?>

Ver también

  • DOMDocument::saveHTML() - Copia el documento interno a una cadena usando el formato HTML
  • DOMDocument::loadHTML() - Cargar HTML de una cadena
  • DOMDocument::loadHTMLFile() - Cargar HTML desde un fichero


Copia el arbol XML interno a un string

  • « DOMDocument::saveHTMLFile
  • DOMDocument::schemaValidate »
  • PHP Manual
  • DOMDocument
  • Copia el arbol XML interno a un string

DOMDocument::saveXML

(PHP 5, PHP 7)

DOMDocument::saveXML — Copia el arbol XML interno a un string

Descripción

public DOMDocument::saveXML ( DOMNode $node = ? , int $options = 0 ) : string

Crea un documento XML desde la representación DOM. Esta función normalmente se llama después de construir un nuevo documento desde cero, como en el ejemplo de abajo.

Parámetros

node

Use este parámetro para imprimir sólo un nodo especifico sin la declaración XML en vez del documento completo.

options

Opciones Adicionales. Actualmente sólo está soportada LIBXML_NOEMPTYTAG.

Valores devueltos

Devuelve el XML, o false en caso de error.

Errores/Excepciones

DOM_WRONG_DOCUMENT_ERR

Lanzado si node es de otro documento.

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro options

Ejemplos

Ejemplo #1 Guardar un árbol DOM en un string

<?php

$doc = new DOMDocument('1.0');
// queremos una impresión buena
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('Este es el título');
$text = $title->appendChild($text);

echo "Guardando todo el documento:\n";
echo $doc->saveXML() . "\n";

echo "Guardando sólo la parte del título:\n";
echo $doc->saveXML($title);

?>

El resultado del ejemplo sería:

Guardando todo el documento:
<?xml version="1.0"?>
<book>
  <title>Este es el título</title>
</book>

Guardando sólo la parte del título:
<title>Este es el título</title>

Ver también

  • DOMDocument::save() - Copia el árbol XML interno a un archivo
  • DOMDocument::load() - Cargar un documento XML de un archivo.
  • DOMDocument::loadXML() - Cargar XML desde una cadena


Valida un documento basado en un esquema

  • « DOMDocument::saveXML
  • DOMDocument::schemaValidateSource »
  • PHP Manual
  • DOMDocument
  • Valida un documento basado en un esquema

DOMDocument::schemaValidate

(PHP 5, PHP 7)

DOMDocument::schemaValidate — Valida un documento basado en un esquema

Descripción

public DOMDocument::schemaValidate ( string $filename , int $flags = 0 ) : bool

Valida un documento basado en el fichero de esquema dado.

Parámetros

filename

La ruta al esquema.

flags

Una máscara de bits de banderas de validación de esquemas de Libxml. Actualmente el único valor admitido es LIBXML_SCHEMA_CREATE. Disponible desde PHP 5.5.2 y Libxml 2.6.14.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.2 | Se añadió el parámetro flags

Ver también

  • DOMDocument::schemaValidateSource() - Valida un documento basado en un esquema
  • DOMDocument::relaxNGValidate() - Realiza una validación relaxNG del documento
  • DOMDocument::relaxNGValidateSource() - Realiza una validación relaxNG del documento
  • DOMDocument::validate() - Valida el documento basado en su DTD


Valida un documento basado en un esquema

  • « DOMDocument::schemaValidate
  • DOMDocument::validate »
  • PHP Manual
  • DOMDocument
  • Valida un documento basado en un esquema

DOMDocument::schemaValidateSource

(PHP 5, PHP 7)

DOMDocument::schemaValidateSource — Valida un documento basado en un esquema

Descripción

public DOMDocument::schemaValidateSource ( string $source , int $flags = ? ) : bool

Valida un documento basado en un esquema definido en la cadena dada.

Parámetros

source

Una cadena que contiene el esquema.

flags

Una máscara de bits de banderas de validación de esquemas de Libxml. Actualmente el único valor admitido es LIBXML_SCHEMA_CREATE. Disponible desde PHP 5.5.2 y Libxml 2.6.14.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
5.5.2 | Se añadió el parámetro flags

Ver también

  • DOMDocument::schemaValidate() - Valida un documento basado en un esquema
  • DOMDocument::relaxNGValidate() - Realiza una validación relaxNG del documento
  • DOMDocument::relaxNGValidateSource() - Realiza una validación relaxNG del documento
  • DOMDocument::validate() - Valida el documento basado en su DTD


Valida el documento basado en su DTD

  • « DOMDocument::schemaValidateSource
  • DOMDocument::xinclude »
  • PHP Manual
  • DOMDocument
  • Valida el documento basado en su DTD

DOMDocument::validate

(PHP 5, PHP 7)

DOMDocument::validate — Valida el documento basado en su DTD

Descripción

public DOMDocument::validate ( ) : bool

Valida el documento basado en su DTD.

También se puede usar la propiedad validateOnParse de DOMDocument para realizar la validación de DTD.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si el documento no tiene el DTD adjunto, este método devolverá false.

Ejemplos

Ejemplo #1 Ejemplo de validación de DTD

<?php
$dom = new DOMDocument;
$dom->load('book.xml');
if ($dom->validate()) {
    echo "¡Este documento es válido!\n";
}
?>

También se puede validar un fichero XML mientras se carga:

<?php
$dom = new DOMDocument;
$dom->validateOnParse = true;
$dom->load('book.xml');
?>

Ver también

  • DOMDocument::schemaValidate() - Valida un documento basado en un esquema
  • DOMDocument::schemaValidateSource() - Valida un documento basado en un esquema
  • DOMDocument::relaxNGValidate() - Realiza una validación relaxNG del documento
  • DOMDocument::relaxNGValidateSource() - Realiza una validación relaxNG del documento


Sustituye XIncludes en un objeto DOMDocument

  • « DOMDocument::validate
  • DOMDocumentFragment »
  • PHP Manual
  • DOMDocument
  • Sustituye XIncludes en un objeto DOMDocument

DOMDocument::xinclude

(PHP 5, PHP 7)

DOMDocument::xinclude — Sustituye XIncludes en un objeto DOMDocument

Descripción

public DOMDocument::xinclude ( int $options = 0 ) : int

Este método sustituye » XIncludes en un objeto DOMDocument.

Nota:

Debido a que libxml2 resuelve automáticamente entidades, este método producirá resultados inesperados si el fichero XML incluido tiene un DTD adjunto.

Parámetros

options

Parámetros de libxml. Disponible desde PHP 5.1.0 y Libxml 2.6.7.

Valores devueltos

Devuelve el número de XIncludes del documento, -1 si falló algún proceso, o false si no hubo sustituciones.

Ejemplos

Ejemplo #1 Ejemplo de DOMDocument::xinclude()

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
 <title>Books of the other guy..</title>
 <para>
  <xi:include href="book.xml">
   <xi:fallback>
    <error>xinclude: book.xml not found</error>
   </xi:fallback>
  </xi:include>
 </para>
</chapter>
EOD;

$dom = new DOMDocument;

// vamos a tener una impresión buena
$dom->preserveWhiteSpace = false;
$dom->formatOutput = true;

// cargar la cadena XML definida arriba
$dom->loadXML($xml);

// sustituir xincludes
$dom->xinclude();

echo $dom->saveXML();

?>

El resultado del ejemplo sería algo similar a:

<?xml version="1.0"?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
  <title>Books of the other guy..</title>
  <para>
    <row xml:base="/home/didou/book.xml">
       <entry>The Grapes of Wrath</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>0140186409</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>The Pearl</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>014017737X</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>Samarcande</entry>
       <entry>Amine Maalouf</entry>
       <entry>fr</entry>
       <entry>2253051209</entry>
      </row>
  </para>
</chapter>


La clase DOMDocumentFragment

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMDocumentFragment extends DOMNode {
/* Propiedades */
/* Propiedades heredadas */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public appendXML ( string $data ) : bool
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Tabla de contenidos

  • DOMDocumentFragment::appendXML — Añade información XML sin formato


Añade información XML sin formato

  • « DOMDocumentFragment
  • DOMDocumentType »
  • PHP Manual
  • DOMDocumentFragment
  • Añade información XML sin formato

DOMDocumentFragment::appendXML

(PHP 5 >= 5.1.0, PHP 7)

DOMDocumentFragment::appendXML — Añade información XML sin formato

Descripción

public DOMDocumentFragment::appendXML ( string $data ) : bool

Añade información XML sin formato a un DOMDocumentFragment.

Este método no es parte del estándar DOM. Fue creado como enfoque más sencillo para añadir un DocumentFragment de XML a un DOMDocument.

Si quiere mantener los estándares, tendrá que crear un DOMDocument temporal con una raíz cualquiera y después ir a través de los nodos hijo de la raíz de su información XML para añadirlos.

Parámetros

data

XML a añadir.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Añadir información XML a su documento

<?php
$doc = new DOMDocument();
$doc->loadXML("<root/>");
$f = $doc->createDocumentFragment();
$f->appendXML("<foo>text</foo><bar>text2</bar>");
$doc->documentElement->appendChild($f);
echo $doc->saveXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0"?>
<root><foo>text</foo><bar>text2</bar></root>


La clase DOMDocumentType

(PHP 5, PHP 7)

Introducción

Cada DOMDocument tiene un atributo doctype cuyo valor es null o un objeto DOMDocumentType.

Sinopsis de la Clase

DOMDocumentType extends DOMNode {
/* Propiedades */
readonly public string $publicId ;
readonly public string $systemId ;
readonly public string $name ;
readonly public DOMNamedNodeMap $entities ;
readonly public DOMNamedNodeMap $notations ;
readonly public string $internalSubset ;
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

publicId

El identificador público del subconjunto externo.

systemId

El identificador de sistema del subconjunto externo. Puede ser o no una URI absoluta.

name

El nombre del DTD; es decir, el nombre que siguie inmediatemante a la palabra clave DOCTYPE.

entities

Un objeto DOMNamedNodeMap que contiene las entidades generales, externas e internas, declaradas en el DTD.

notations

Un objeto DOMNamedNodeMap que contiene las notaciones declaradas en el DTD.

internalSubset

El subconjunto interno como cadena, o null si no hay ninguno. No contiene los corchetes delimitadores.


La clase DOMElement

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMElement extends DOMNode {
/* Propiedades */
readonly public bool $schemaTypeInfo ;
readonly public string $tagName ;
/* Métodos */
public __construct ( string $name , string $value = ? , string $namespaceURI = ? )
public getAttribute ( string $name ) : string
public getAttributeNode ( string $name ) : DOMAttr
public getAttributeNodeNS ( string $namespaceURI , string $localName ) : DOMAttr
public getAttributeNS ( string $namespaceURI , string $localName ) : string
public getElementsByTagName ( string $name ) : DOMNodeList
public getElementsByTagNameNS ( string $namespaceURI , string $localName ) : DOMNodeList
public hasAttribute ( string $name ) : bool
public hasAttributeNS ( string $namespaceURI , string $localName ) : bool
public removeAttribute ( string $name ) : bool
public removeAttributeNode ( DOMAttr $oldnode ) : bool
public removeAttributeNS ( string $namespaceURI , string $localName ) : bool
public setAttribute ( string $name , string $value ) : DOMAttr
public setAttributeNode ( DOMAttr $attr ) : DOMAttr
public setAttributeNodeNS ( DOMAttr $attr ) : DOMAttr
public setAttributeNS ( string $namespaceURI , string $qualifiedName , string $value ) : void
public setIdAttribute ( string $name , bool $isId ) : void
public setIdAttributeNode ( DOMAttr $attr , bool $isId ) : void
public setIdAttributeNS ( string $namespaceURI , string $localName , bool $isId ) : void
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

schemaTypeInfo

Aún no implementado, siempre devuelve null

tagName

El nombre del elemento

Notas

Nota:

La extensión DOM utiliza la codificación UTF-8. Use utf8_encode() y utf8_decode() para trabajar con textos con codificación ISO-8859-1 o Iconv para otras codificaciones.

Tabla de contenidos

  • DOMElement::__construct — Crea un nuevo objeto DOMElement
  • DOMElement::getAttribute — Devuelve el valor de un atributo
  • DOMElement::getAttributeNode — Devuelve el nodo de un atributo
  • DOMElement::getAttributeNodeNS — Devuelve el nodo de un atributo
  • DOMElement::getAttributeNS — Devuelve el valor de un atributo
  • DOMElement::getElementsByTagName — Obtiene los elementos por nombre de etiqueta
  • DOMElement::getElementsByTagNameNS — Obtener los elementos por la URI del espacio de nombres y el nombre local
  • DOMElement::hasAttribute — Comprueba si existe un atributo
  • DOMElement::hasAttributeNS — Comprueba si un atributo existe
  • DOMElement::removeAttribute — Elimina un atributo
  • DOMElement::removeAttributeNode — Elimina un atributo
  • DOMElement::removeAttributeNS — Elimina un atributo
  • DOMElement::setAttribute — Añade un nuevo atributo
  • DOMElement::setAttributeNode — Añade un nuevo nodo de atributo al elemento
  • DOMElement::setAttributeNodeNS — Aña de un nuevo nodo de atributo al elemento
  • DOMElement::setAttributeNS — Añade un nuevo atributo
  • DOMElement::setIdAttribute — Declara el atributo especificado por su nombre como de tipo ID
  • DOMElement::setIdAttributeNode — Declara el atributo especificado por su nodo como de tipo ID
  • DOMElement::setIdAttributeNS — Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID


Crea un nuevo objeto DOMElement

  • « DOMElement
  • DOMElement::getAttribute »
  • PHP Manual
  • DOMElement
  • Crea un nuevo objeto DOMElement

DOMElement::__construct

(PHP 5, PHP 7)

DOMElement::__construct — Crea un nuevo objeto DOMElement

Descripción

public DOMElement::__construct ( string $name , string $value = ? , string $namespaceURI = ? )

Crea un nuevo objeto DOMElement. Este objeto es de sólo lectura. Puede ser añadido a un documento, pero no se pueden añadir nodos adicionales a este nodo hasta que el nodo esté asociado con un documento. Para crear un nodo modificable, use DOMDocument::createElement o DOMDocument::createElementNS.

Parámetros

name

El nombre de la etiqueta del elemento. Cuando también se pasa en namespaceURI, el nombre del elemento puede tomar un prefijo para asociarlo con la URI.

value

El valor del elemento.

namespaceURI

Una URI del espacio de nombres para crear el elemento dentro de un espacio de nombres especificado.

Ejemplos

Ejemplo #1 Crear un nuevo objeto DOMElement

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$element_ns = new DOMElement('pr:node1', 'thisvalue', 'http://xyz');
$element->appendChild($element_ns);
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?>
<root><pr:node1 xmlns:pr="http://xyz">thisvalue</pr:node1></root> */

?>

Ver también

  • DOMDocument::createElement() - Crea un nuevo nodo elemento
  • DOMDocument::createElementNS() - Crea un nuevo nodo elemento con el nombre de espacio asociado


Devuelve el valor de un atributo

  • « DOMElement::__construct
  • DOMElement::getAttributeNode »
  • PHP Manual
  • DOMElement
  • Devuelve el valor de un atributo

DOMElement::getAttribute

(PHP 5, PHP 7)

DOMElement::getAttribute — Devuelve el valor de un atributo

Descripción

public DOMElement::getAttribute ( string $name ) : string

Obtiene el valor del atributo de nombre name para el nodo actual.

Parámetros

name

El nombre del atributo.

Valores devueltos

El valor del atributo, o una cadena vacía si no se encuentra un atributo con el nombre dado por name.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::setAttribute() - Añade un nuevo atributo
  • DOMElement::removeAttribute() - Elimina un atributo


Devuelve el nodo de un atributo

  • « DOMElement::getAttribute
  • DOMElement::getAttributeNodeNS »
  • PHP Manual
  • DOMElement
  • Devuelve el nodo de un atributo

DOMElement::getAttributeNode

(PHP 5, PHP 7)

DOMElement::getAttributeNode — Devuelve el nodo de un atributo

Descripción

public DOMElement::getAttributeNode ( string $name ) : DOMAttr

Devuelve el nodo del atributo con nombre name para el elemento actual.

Parámetros

name

El nombre del atributo.

Valores devueltos

El nodo de atributos. Observe que para los atributos de las declaraciones del espacio de nombres XML (xmlns y xmlns:*) una instancia de DOMNameSpaceNode es devuelta en vez de una instancia de DOMAttr.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::setAttributeNode() - Añade un nuevo nodo de atributo al elemento
  • DOMElement::removeAttributeNode() - Elimina un atributo


Devuelve el nodo de un atributo

  • « DOMElement::getAttributeNode
  • DOMElement::getAttributeNS »
  • PHP Manual
  • DOMElement
  • Devuelve el nodo de un atributo

DOMElement::getAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNodeNS — Devuelve el nodo de un atributo

Descripción

public DOMElement::getAttributeNodeNS ( string $namespaceURI , string $localName ) : DOMAttr

Devuelve el nodo del atributo en el espacio de nombres namespaceURI con el nombre local localName para el nodo actual.

Parámetros

namespaceURI

La URI del espacio de nombres.

localName

El nombre local.

Valores devueltos

El nodo de atributos. Observe que para los atributos de las declaraciones del espacio de nombres XML (xmlns y xmlns:*) una instancia de DOMNameSpaceNode es devuelta en vez de una instancia de DOMAttr.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::setAttributeNodeNS() - Aña de un nuevo nodo de atributo al elemento
  • DOMElement::removeAttributeNode() - Elimina un atributo


Devuelve el valor de un atributo

  • « DOMElement::getAttributeNodeNS
  • DOMElement::getElementsByTagName »
  • PHP Manual
  • DOMElement
  • Devuelve el valor de un atributo

DOMElement::getAttributeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNS — Devuelve el valor de un atributo

Descripción

public DOMElement::getAttributeNS ( string $namespaceURI , string $localName ) : string

Obtiene el valor del atributo en el espacio de nombres namespaceURI con el nombre local localName para el nodo actual.

Parámetros

namespaceURI

La URI del espacio de nombres.

localName

El nombre local.

Valores devueltos

El valor del atributo, o una cadena vacía si no se ecuentra el atributo con los localName y namespaceURI dados.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::setAttributeNS() - Añade un nuevo atributo
  • DOMElement::removeAttributeNS() - Elimina un atributo


Obtiene los elementos por nombre de etiqueta

  • « DOMElement::getAttributeNS
  • DOMElement::getElementsByTagNameNS »
  • PHP Manual
  • DOMElement
  • Obtiene los elementos por nombre de etiqueta

DOMElement::getElementsByTagName

(PHP 5, PHP 7)

DOMElement::getElementsByTagName — Obtiene los elementos por nombre de etiqueta

Descripción

public DOMElement::getElementsByTagName ( string $name ) : DOMNodeList

Esta función devuelve una nueva instancia de la clase DOMNodeList con todos los elementos descendientes con un nombre de etiqueta dado por name, en el orden en que fueron encontrados en un recorrido preorden de este elemento árbol.

Parámetros

name

El nombre de la etiqueta. Use * para devolver todos los elementos dentro del elemento árbol.

Valores devueltos

Esta función devuelve una nueva instancia de la clase DOMNodeList con todos los elementos coincidentes.

Ver también

  • DOMElement::getElementsByTagNameNS() - Obtener los elementos por la URI del espacio de nombres y el nombre local


Obtener los elementos por la URI del espacio de nombres y el nombre local

  • « DOMElement::getElementsByTagName
  • DOMElement::hasAttribute »
  • PHP Manual
  • DOMElement
  • Obtener los elementos por la URI del espacio de nombres y el nombre local

DOMElement::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMElement::getElementsByTagNameNS — Obtener los elementos por la URI del espacio de nombres y el nombre local

Descripción

public DOMElement::getElementsByTagNameNS ( string $namespaceURI , string $localName ) : DOMNodeList

Esta función trae todos los elementos descendientes con unos localName y namespaceURI dados.

Parámetros

namespaceURI

La URI del espacio de nombres.

localName

EL nombre local. Use * para devolver todos los elementos dentro del elemento árbol.

Valores devueltos

Esta función devuelve una nueva instancia de la clase DOMNodeList con todos los elementos coincidentes en el orden en que fueron encontrados en un recorriendo en preorden este elemento árbol.

Ver también

  • DOMElement::getElementsByTagName() - Obtiene los elementos por nombre de etiqueta


Comprueba si existe un atributo

  • « DOMElement::getElementsByTagNameNS
  • DOMElement::hasAttributeNS »
  • PHP Manual
  • DOMElement
  • Comprueba si existe un atributo

DOMElement::hasAttribute

(PHP 5, PHP 7)

DOMElement::hasAttribute — Comprueba si existe un atributo

Descripción

public DOMElement::hasAttribute ( string $name ) : bool

Indica si un atributo llamado name existe como miembro del elemento.

Parámetros

name

El nombre del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::getAttribute() - Devuelve el valor de un atributo
  • DOMElement::setAttribute() - Añade un nuevo atributo
  • DOMElement::removeAttribute() - Elimina un atributo


Comprueba si un atributo existe

  • « DOMElement::hasAttribute
  • DOMElement::removeAttribute »
  • PHP Manual
  • DOMElement
  • Comprueba si un atributo existe

DOMElement::hasAttributeNS

(PHP 5, PHP 7)

DOMElement::hasAttributeNS — Comprueba si un atributo existe

Descripción

public DOMElement::hasAttributeNS ( string $namespaceURI , string $localName ) : bool

Indica si un atributo en el espacio de nombres namespaceURI llamado localName existe como miembro del elemento.

Parámetros

namespaceURI

La URI del espacio de nombres.

localName

El nombre local.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::getAttributeNS() - Devuelve el valor de un atributo
  • DOMElement::setAttributeNS() - Añade un nuevo atributo
  • DOMElement::removeAttributeNS() - Elimina un atributo


Elimina un atributo

  • « DOMElement::hasAttributeNS
  • DOMElement::removeAttributeNode »
  • PHP Manual
  • DOMElement
  • Elimina un atributo

DOMElement::removeAttribute

(PHP 5, PHP 7)

DOMElement::removeAttribute — Elimina un atributo

Descripción

public DOMElement::removeAttribute ( string $name ) : bool

Elimina el atributo llamado name del elemento.

Parámetros

name

El nombre del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::getAttribute() - Devuelve el valor de un atributo
  • DOMElement::setAttribute() - Añade un nuevo atributo


Elimina un atributo

  • « DOMElement::removeAttribute
  • DOMElement::removeAttributeNS »
  • PHP Manual
  • DOMElement
  • Elimina un atributo

DOMElement::removeAttributeNode

(PHP 5, PHP 7)

DOMElement::removeAttributeNode — Elimina un atributo

Descripción

public DOMElement::removeAttributeNode ( DOMAttr $oldnode ) : bool

Elimina el atributo oldnode del elemento.

Parámetros

oldnode

El nodo atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NOT_FOUND_ERROR

Lanzado si oldnode no es un atributo del elemento.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::getAttributeNode() - Devuelve el nodo de un atributo
  • DOMElement::setAttributeNode() - Añade un nuevo nodo de atributo al elemento


Elimina un atributo

  • « DOMElement::removeAttributeNode
  • DOMElement::setAttribute »
  • PHP Manual
  • DOMElement
  • Elimina un atributo

DOMElement::removeAttributeNS

(PHP 5, PHP 7)

DOMElement::removeAttributeNS — Elimina un atributo

Descripción

public DOMElement::removeAttributeNS ( string $namespaceURI , string $localName ) : bool

Elimina el atributo localName en el espacio de nombre namespaceURI de el elemento.

Parámetros

namespaceURI

La URI del espacio de nombres.

localName

El nombre local.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::getAttributeNS() - Devuelve el valor de un atributo
  • DOMElement::setAttributeNS() - Añade un nuevo atributo


Añade un nuevo atributo

  • « DOMElement::removeAttributeNS
  • DOMElement::setAttributeNode »
  • PHP Manual
  • DOMElement
  • Añade un nuevo atributo

DOMElement::setAttribute

(PHP 5, PHP 7)

DOMElement::setAttribute — Añade un nuevo atributo

Descripción

public DOMElement::setAttribute ( string $name , string $value ) : DOMAttr

Establece un atributo con nombre name al valor dado. Si el atributo no existe, se creará.

Parámetros

name

El nombre del atributo.

value

El valor del atributo.

Valores devueltos

El nuevo objeto DOMAttr o false si ocurrió un error.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

Ejemplos

Ejemplo #1 Establecer un atributo

<?php
$doc = new DOMDocument("1.0");
$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);
$newnode->setAttribute("align", "left");
?>

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::getAttribute() - Devuelve el valor de un atributo
  • DOMElement::removeAttribute() - Elimina un atributo


Añade un nuevo nodo de atributo al elemento

  • « DOMElement::setAttribute
  • DOMElement::setAttributeNodeNS »
  • PHP Manual
  • DOMElement
  • Añade un nuevo nodo de atributo al elemento

DOMElement::setAttributeNode

(PHP 5, PHP 7)

DOMElement::setAttributeNode — Añade un nuevo nodo de atributo al elemento

Descripción

public DOMElement::setAttributeNode ( DOMAttr $attr ) : DOMAttr

Añade el nuevo nodo de atributo dado por attr al elemento.

Parámetros

attr

El nodo de atributo.

Valores devueltos

Devuelve el nodo antiguo si el atributo ha sido reemplazado o null.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

Ver también

  • DOMElement::hasAttribute() - Comprueba si existe un atributo
  • DOMElement::getAttributeNode() - Devuelve el nodo de un atributo
  • DOMElement::removeAttributeNode() - Elimina un atributo


Aña de un nuevo nodo de atributo al elemento

  • « DOMElement::setAttributeNode
  • DOMElement::setAttributeNS »
  • PHP Manual
  • DOMElement
  • Aña de un nuevo nodo de atributo al elemento

DOMElement::setAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNodeNS — Aña de un nuevo nodo de atributo al elemento

Descripción

public DOMElement::setAttributeNodeNS ( DOMAttr $attr ) : DOMAttr

Añade el nuevo nodo atributo attr al elemento.

Parámetros

attr

El nodo atributo.

Valores devueltos

Devuelve el antiguo nodo si el atributo ya sido reemplazado.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::getAttributeNodeNS() - Devuelve el nodo de un atributo
  • DOMElement::removeAttributeNode() - Elimina un atributo


Añade un nuevo atributo

  • « DOMElement::setAttributeNodeNS
  • DOMElement::setIdAttribute »
  • PHP Manual
  • DOMElement
  • Añade un nuevo atributo

DOMElement::setAttributeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNS — Añade un nuevo atributo

Descripción

public DOMElement::setAttributeNS ( string $namespaceURI , string $qualifiedName , string $value ) : void

Establece un atributo con el espacio de nombres namespaceURI y el nombre name al valor dado. Si el atributo no existe, se creará.

Parámetros

namespaceURI

La URI del espacio de nombres.

qualifiedName

El nombre cualificado del atributo, como prefijo:nombre_etiqueta.

value

El valor del atributo.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NAMESPACE_ERR

Lanzado si qualifiedName es un nombre cualificado malformado, o si qualifiedName tienen un prefijo y namespaceURI es null.

Ver también

  • DOMElement::hasAttributeNS() - Comprueba si un atributo existe
  • DOMElement::getAttributeNS() - Devuelve el valor de un atributo
  • DOMElement::removeAttributeNS() - Elimina un atributo


Declara el atributo especificado por su nombre como de tipo ID

  • « DOMElement::setAttributeNS
  • DOMElement::setIdAttributeNode »
  • PHP Manual
  • DOMElement
  • Declara el atributo especificado por su nombre como de tipo ID

DOMElement::setIdAttribute

(PHP 5, PHP 7)

DOMElement::setIdAttribute — Declara el atributo especificado por su nombre como de tipo ID

Descripción

public DOMElement::setIdAttribute ( string $name , bool $isId ) : void

Declara el atributo name como de tipo ID.

Parámetros

name

El nombre del atributo.

isId

Establecer a true si se quiere que name sea de tipo ID, false si no.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NOT_FOUND

Lanzado si name no es un atributo de este elemento.

Ver también

  • DOMDocument::getElementById() - Busca un elemento con cierto id
  • DOMElement::setIdAttributeNode() - Declara el atributo especificado por su nodo como de tipo ID
  • DOMElement::setIdAttributeNS() - Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID


Declara el atributo especificado por su nodo como de tipo ID

  • « DOMElement::setIdAttribute
  • DOMElement::setIdAttributeNS »
  • PHP Manual
  • DOMElement
  • Declara el atributo especificado por su nodo como de tipo ID

DOMElement::setIdAttributeNode

(PHP 5, PHP 7)

DOMElement::setIdAttributeNode — Declara el atributo especificado por su nodo como de tipo ID

Descripción

public DOMElement::setIdAttributeNode ( DOMAttr $attr , bool $isId ) : void

Declara el atributo especificado por attr como de tipo ID.

Parámetros

attr

El nodo atributo.

isId

Establecer a true si se quiere que name sea de tipo ID, false si no.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NOT_FOUND

Lanzado si name no es un atributo de este elemento.

Ver también

  • DOMDocument::getElementById() - Busca un elemento con cierto id
  • DOMElement::setIdAttribute() - Declara el atributo especificado por su nombre como de tipo ID
  • DOMElement::setIdAttributeNS() - Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID


Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID

  • « DOMElement::setIdAttributeNode
  • DOMEntity »
  • PHP Manual
  • DOMElement
  • Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID

DOMElement::setIdAttributeNS

(PHP 5, PHP 7)

DOMElement::setIdAttributeNS — Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID

Descripción

public DOMElement::setIdAttributeNS ( string $namespaceURI , string $localName , bool $isId ) : void

Declara el atributo especificado por localName y namespaceURI como de tipo ID.

Parámetros

namespaceURI

La URI del espacio de nombres del atributo.

localName

El nombre local del atributo, como prefijo:nombre_etiqueta.

isId

Establecer a true si se quiere que name sea de tipo ID, false si no.

Valores devueltos

No devuelve ningún valor.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NOT_FOUND

Lanzado si name no es un atributo de este elemento.

Ver también

  • DOMDocument::getElementById() - Busca un elemento con cierto id
  • DOMElement::setIdAttribute() - Declara el atributo especificado por su nombre como de tipo ID
  • DOMElement::setIdAttributeNode() - Declara el atributo especificado por su nodo como de tipo ID


La clase DOMEntity

(PHP 5, PHP 7)

Introducción

Esta interfaz representa una entidad conocida, analizada o sin analizar, de un documento XML.

Sinopsis de la Clase

DOMEntity extends DOMNode {
/* Propiedades */
readonly public string $publicId ;
readonly public string $systemId ;
readonly public string $notationName ;
public string $actualEncoding ;
readonly public string $encoding ;
readonly public string $version ;
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

publicId

El identificador público asociado con la entidad si se especifica, y si no null.

systemId

El identificador de sistema asociado con la entidad si se especifica, y si no null. Puede ser o no una URI absoluta.

notationName

Para entidades no analizadas, el nombre de la notación de la entidad. Para entidades analizadas es null.

actualEncoding

Un atributo que especifica la codificación usada para esta entidad en el momento de analizar, cuando es una entidad analizada externa. Es null si es una entidad de un subconjunto interno o si es desconocida.

encoding

Un atributo que especifica, como parte de la declaración de texto, la codificación de esta entirdad, cuando es una entidad analizada externa. Si no, es null.

version

Un atributo que especifica, como parte de la declaración de texto, el número de versión de esta entidad, cuando es una entidad analizada externa. Si no, es null.


La clase DOMEntityReference

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMEntityReference extends DOMNode {
/* Propiedades */
/* Métodos */
public __construct ( string $name )
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Tabla de contenidos

  • DOMEntityReference::__construct — Crea un nuevo objeto DOMEntityReference


Crea un nuevo objeto DOMEntityReference

  • « DOMEntityReference
  • DOMException »
  • PHP Manual
  • DOMEntityReference
  • Crea un nuevo objeto DOMEntityReference

DOMEntityReference::__construct

(PHP 5, PHP 7)

DOMEntityReference::__construct — Crea un nuevo objeto DOMEntityReference

Descripción

public DOMEntityReference::__construct ( string $name )

Crea un nuevo objeto DOMEntityReference.

Parámetros

name

El nombre de la referencia de entidad.

Ejemplos

Ejemplo #1 Crear un nuevo objeto DOMEntityReference

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$elemento = $dom->appendChild(new DOMElement('root'));
$entidad = $elemento->appendChild(new DOMEntityReference('nbsp'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?><root></root> */

?>

Ver también

  • DOMDocument::createEntityReference() - Create new entity reference node


La clase DOMException

(PHP 5, PHP 7)

Introducción

Las operaciones DOM lanzan excepciones bajo circunstancias particulares, esto es, cuando es imposible de realizar una operación por razones lógicas.

Véase también Excepciones.

Sinopsis de la Clase

DOMException extends Exception {
/* Propiedades */
readonly public int $code ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Propiedades

code

Un integer que indica el tipo de error generado


La clase DOMImplementation

(PHP 5, PHP 7)

Introducción

La interfaz DOMImplementation proporciona varios métodos para realizar operaciones que son independientes de cualquier instancia en particular del modelo de objetos del documento.

Sinopsis de la Clase

DOMImplementation {
/* Propiedades */
/* Métodos */
__construct ( )
public createDocument ( string $namespaceURI = null , string $qualifiedName = null , DOMDocumentType $doctype = null ) : DOMDocument
public createDocumentType ( string $qualifiedName = null , string $publicId = null , string $systemId = null ) : DOMDocumentType
public hasFeature ( string $feature , string $version ) : bool
}

Tabla de contenidos

  • DOMImplementation::__construct — Crea un nuevo objeto DOMImplementation
  • DOMImplementation::createDocument — Crea un objeto DOMDocument del tipo especificado con su elemento documento
  • DOMImplementation::createDocumentType — Crear un objeto DOMDocumentType vacío
  • DOMImplementation::hasFeature — Comprueba si la implementación de DOM implementa una característica específica


Crea un nuevo objeto DOMImplementation

  • « DOMImplementation
  • DOMImplementation::createDocument »
  • PHP Manual
  • DOMImplementation
  • Crea un nuevo objeto DOMImplementation

DOMImplementation::__construct

(PHP 5, PHP 7)

DOMImplementation::__construct — Crea un nuevo objeto DOMImplementation

Descripción

DOMImplementation::__construct ( )

Crea un nuevo objeto DOMImplementation.


Crea un objeto DOMDocument del tipo especificado con su elemento documento

  • « DOMImplementation::__construct
  • DOMImplementation::createDocumentType »
  • PHP Manual
  • DOMImplementation
  • Crea un objeto DOMDocument del tipo especificado con su elemento documento

DOMImplementation::createDocument

(PHP 5, PHP 7)

DOMImplementation::createDocument — Crea un objeto DOMDocument del tipo especificado con su elemento documento

Descripción

public DOMImplementation::createDocument ( string $namespaceURI = null , string $qualifiedName = null , DOMDocumentType $doctype = null ) : DOMDocument

Crea un objeto DOMDocument del tipo especificado con su elemento documento.

Parámetros

namespaceURI

La URI del espacio de nombres del elemento documento a crear.

qualifiedName

El nombre cualificado del elemento documento a crear.

doctype

El tipo de documento a crear o null.

Valores devueltos

Un nuevo objeto DOMDocument. Si namespaceURI, qualifiedName, y doctype son null, el DOMDocument devuelto está vacío sin elemento documento

Errores/Excepciones

DOM_WRONG_DOCUMENT_ERR

Lanzado si doctype ya ha sido usado con un documento diferente o fue creado desde una implementación diferente.

DOM_NAMESPACE_ERR

Lanzado si hay un error con el espacio de nombres, como determina namespaceURI y qualifiedName.

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Ver también

  • DOMDocument::__construct() - Crea un nuevo objeto DOMDocument
  • DOMImplementation::createDocumentType() - Crear un objeto DOMDocumentType vacío


Crear un objeto DOMDocumentType vacío

  • « DOMImplementation::createDocument
  • DOMImplementation::hasFeature »
  • PHP Manual
  • DOMImplementation
  • Crear un objeto DOMDocumentType vacío

DOMImplementation::createDocumentType

(PHP 5, PHP 7)

DOMImplementation::createDocumentType — Crear un objeto DOMDocumentType vacío

Descripción

public DOMImplementation::createDocumentType ( string $qualifiedName = null , string $publicId = null , string $systemId = null ) : DOMDocumentType

Crea un objeto DOMDocumentType vacío. Las declaraciones de entidades y las notaciones no están disponibles. Las expansiones de referencias de entidades y la adición de atributos por defecto no ocurren.

Parámetros

qualifiedName

El nombre cualificado del tipo de documente a crear.

publicId

El identificador público del subconjunto externo.

systemId

El identificador de sistema del subconjunto externo.

Valores devueltos

Un nuevo nodo DOMDocumentType con su ownerDocument establecido a null.

Errores/Excepciones

DOM_NAMESPACE_ERR

Se produce si hay un error con el espacio de nombres, como determina qualifiedName.

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Ejemplos

Ejemplo #1 Crear un documento con un DTD adjunto

<?php

// Crear una instancia de la clase DOMImplementation
$imp = new DOMImplementation;

// Crear una instancia de DOMDocumentType
$dtd = $imp->createDocumentType('graph', '', 'graph.dtd');

// Crear una instancia de DOMDocument
$dom = $imp->createDocument("", "", $dtd);

// Establecer otras propiedades
$dom->encoding = 'UTF-8';
$dom->standalone = false;

// Crear un elemento vacío
$element = $dom->createElement('graph');

// Añadir el elemento
$dom->appendChild($element);

// Retrieve and print the document
echo $dom->saveXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE graph SYSTEM "graph.dtd">
<graph/>

Ver también

  • DOMImplementation::createDocument() - Crea un objeto DOMDocument del tipo especificado con su elemento documento


Comprueba si la implementación de DOM implementa una característica específica

  • « DOMImplementation::createDocumentType
  • DOMNamedNodeMap »
  • PHP Manual
  • DOMImplementation
  • Comprueba si la implementación de DOM implementa una característica específica

DOMImplementation::hasFeature

(PHP 5, PHP 7)

DOMImplementation::hasFeature — Comprueba si la implementación de DOM implementa una característica específica

Descripción

public DOMImplementation::hasFeature ( string $feature , string $version ) : bool

Comprueba si la implementación de DOM implementa una característica específica dada por feature.

Se puede encontrar una lista de todas las características en la sección » Conformance de la especificación DOM.

Parámetros

feature

La característica a comprobar.

version

El número de versión de feature a comprobar. En el nivel 2 puede ser 2.0 o 1.0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Ejemplos

Ejemplo #1 Comprobar su Implementación DOM

<?php

$features = array(
  'Core'           => 'Core module',
  'XML'            => 'XML module',
  'HTML'           => 'HTML module',
  'Views'          => 'Views module',
  'Stylesheets'    => 'Style Sheets module',
  'CSS'            => 'CSS module',
  'CSS2'           => 'CSS2 module',
  'Events'         => 'Events module',
  'UIEvents'       => 'User interface Events module',
  'MouseEvents'    => 'Mouse Events module',
  'MutationEvents' => 'Mutation Events module',
  'HTMLEvents'     => 'HTML Events module',
  'Range'          => 'Range module',
  'Traversal'      => 'Traversal module'
);

foreach ($features as $clave => $nombre) {
  if (DOMImplementation::hasFeature($clave, '2.0')) {
    echo "Tiene la característica $nombre\n";
  } else {
    echo "Falta la característica $nombre\n";
  }
}

?>

Ver también

  • DOMNode::isSupported() - Comprueba si una característica está soportada para la versión especificada


La clase DOMNamedNodeMap

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMNamedNodeMap implements Traversable {
/* Propiedades */
readonly public int $length ;
/* Métodos */
public count ( ) : int|false
getNamedItem ( string $name ) : DOMNode
getNamedItemNS ( string $namespaceURI , string $localName ) : DOMNode
item ( int $index ) : DOMNode
}

Propiedades

length

El número de nodos del mapa. El rango de los índice del nodo hijo válido es de 0 a length - 1 inclusive.

Tabla de contenidos

  • DOMNamedNodeMap::count — Get number of nodes in the map
  • DOMNamedNodeMap::getNamedItem — Recupera un nodo especificado por su nombre
  • DOMNamedNodeMap::getNamedItemNS — Recupera un nodo especificado por el nombre local y la URI del espacio de nombres
  • DOMNamedNodeMap::item — Recupera un nodo especificado por su índice


Get number of nodes in the map

  • « DOMNamedNodeMap
  • DOMNamedNodeMap::getNamedItem »
  • PHP Manual
  • DOMNamedNodeMap
  • Get number of nodes in the map

DOMNamedNodeMap::count

(PHP 7 >= 7.2.0)

DOMNamedNodeMap::count — Get number of nodes in the map

Descripción

public DOMNamedNodeMap::count ( ) : int|false

Gets the number of nodes in the map.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the number of nodes in the map, which is identical to the length property.


Recupera un nodo especificado por su nombre

  • « DOMNamedNodeMap::count
  • DOMNamedNodeMap::getNamedItemNS »
  • PHP Manual
  • DOMNamedNodeMap
  • Recupera un nodo especificado por su nombre

DOMNamedNodeMap::getNamedItem

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItem — Recupera un nodo especificado por su nombre

Descripción

DOMNamedNodeMap::getNamedItem ( string $name ) : DOMNode

Recupera un nodo especificado por su nodeName.

Parámetros

name

El nodeName del nodo a recuperar.

Valores devueltos

Un nodo (de cualquier tipo) con el nodeName especificado, o null si no se encuentra ningún nodo.

Ver también

  • DOMNamedNodeMap::getNamedItemNS() - Recupera un nodo especificado por el nombre local y la URI del espacio de nombres


Recupera un nodo especificado por el nombre local y la URI del espacio de nombres

  • « DOMNamedNodeMap::getNamedItem
  • DOMNamedNodeMap::item »
  • PHP Manual
  • DOMNamedNodeMap
  • Recupera un nodo especificado por el nombre local y la URI del espacio de nombres

DOMNamedNodeMap::getNamedItemNS

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItemNS — Recupera un nodo especificado por el nombre local y la URI del espacio de nombres

Descripción

DOMNamedNodeMap::getNamedItemNS ( string $namespaceURI , string $localName ) : DOMNode

Recupera un nodo especificado por localName y namespaceURI.

Parámetros

namespaceURI

La URI del espacio de nombres del nodo a recuperar.

localName

El nombre local del nodo a recuperar.

Valores devueltos

Un nodo (de cualquier tipo) con el nombre local y la URI del espacio de nombres especificados, o null si no se encuentra ningún nodo.

Ver también

  • DOMNamedNodeMap::getNamedItem() - Recupera un nodo especificado por su nombre


Recupera un nodo especificado por su índice

  • « DOMNamedNodeMap::getNamedItemNS
  • DOMNode »
  • PHP Manual
  • DOMNamedNodeMap
  • Recupera un nodo especificado por su índice

DOMNamedNodeMap::item

(PHP 5, PHP 7)

DOMNamedNodeMap::item — Recupera un nodo especificado por su índice

Descripción

DOMNamedNodeMap::item ( int $index ) : DOMNode

Recupera un nodo especificado por index dentro del objeto DOMNamedNodeMap.

Parámetros

index

Índice dentro de este mapa.

Valores devueltos

El nodo en la posición marcada por index en el mapa, o null si no es un índice válido (mayor o igual que el número de nodos de este mapa).


La clase DOMNode

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMNode {
/* Propiedades */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Métodos */
public appendChild ( DOMNode $newnode ) : DOMNode
public C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public cloneNode ( bool $deep = ? ) : DOMNode
public getLineNo ( ) : int
public getNodePath ( ) : string
public hasAttributes ( ) : bool
public hasChildNodes ( ) : bool
public insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public isDefaultNamespace ( string $namespaceURI ) : bool
public isSameNode ( DOMNode $node ) : bool
public isSupported ( string $feature , string $version ) : bool
public lookupNamespaceUri ( string $prefix ) : string
public lookupPrefix ( string $namespaceURI ) : string
public normalize ( ) : void
public removeChild ( DOMNode $oldnode ) : DOMNode
public replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

nodeName

Devuelve el nombre más exacto del tipo de nodo actual

nodeValue

El valor de este nodo, dependiendo de su tipo. A diferencia de al especificación del W3C, el valor de los nodos DOMElement es igual a DOMNode::textContent en lugar de null.

nodeType

Obtiene el tipo del nodo. Una de las constantes XML_xxx_NODE predefinidas

parentNode

El padre de este nodo. Si no existe tal nodo, devuelve null.

childNodes

Un objeto DOMNodeList que contiene todos los hijos de este nodo. Si no existieran hijos, es un objeto DOMNodeList vacío.

firstChild

El primer hijo de este nodo. Si no existiera tal nodo devuelve null.

lastChild

El último hijo de este nodo. Si no existiera tal nodo devuelve null.

previousSibling

El nodo que precede inmediatamente a este ndo. Si no existiera tal nodo devuelve null.

nextSibling

El siguiente nodo inmediato a este nodo. Si no existiera tal nodo devuelve null.

attributes

Un objeto DOMNamedNodeMap que contiene los atributos de este nodo (si es un objeto DOMElement), o de lo contrario null.

ownerDocument

El objeto DOMDocument asociado con este nodo.

namespaceURI

El URI del espacio de nombres de este nodo, o null si no está especificado.

prefix

El prefijo del espacio de nombres de este nodo, o null si no está especificado.

localName

Devuelve la parte local del nombre cualificado de este nodo.

baseURI

El URI base absoluto de este nodo o null si la implementación no pudo obtener un URI absoluto.

textContent

El contenido de texto de este nodo y sus descendientes.

Notas

Nota:

La extensión DOM utiliza la codificación UTF-8. Use utf8_encode() y utf8_decode() para trabajar con textos con codificación ISO-8859-1 o Iconv para otras codificaciones.

Historial de cambios

Versión | Descripción
5.6.1 | La propiedad textContent ahora es escribible (anteriormente era de solo lectura).

Ver también

  • » Especificaión de Nodo del W3C

Tabla de contenidos

  • DOMNode::appendChild — Añade un nuevo hijo al final de los hijos
  • DOMNode::C14N — Canonizar nodos a una cadena
  • DOMNode::C14NFile — Canonizar nodos a un fichero
  • DOMNode::cloneNode — Clona un nodo
  • DOMNode::getLineNo — Obtener el número de línea de un nodo
  • DOMNode::getNodePath — Obtener un XPath de un nodo
  • DOMNode::hasAttributes — Comprueba si un nodo tiene atributos
  • DOMNode::hasChildNodes — Comprueba si el nodo tiene hijos
  • DOMNode::insertBefore — Añade un nuevo hijo antes del nodo de referencia
  • DOMNode::isDefaultNamespace — Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado
  • DOMNode::isSameNode — Indica si dos nodos son el mismo nodo
  • DOMNode::isSupported — Comprueba si una característica está soportada para la versión especificada
  • DOMNode::lookupNamespaceUri — Obtiene la URI del espacio de nombres del nodo basado en el prefijo
  • DOMNode::lookupPrefix — Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres
  • DOMNode::normalize — Normaliza el nodo
  • DOMNode::removeChild — Elimina un hijo de la lista de hijos.
  • DOMNode::replaceChild — Reemplaza un hijo


Añade un nuevo hijo al final de los hijos

  • « DOMNode
  • DOMNode::C14N »
  • PHP Manual
  • DOMNode
  • Añade un nuevo hijo al final de los hijos

DOMNode::appendChild

(PHP 5, PHP 7)

DOMNode::appendChild — Añade un nuevo hijo al final de los hijos

Descripción

public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode

Esta función agrega un hijo a una lista existente de hijos o crea una nueva lista de hijos. El hijo se puede crear con, p.ej., DOMDocument::createElement(), DOMDocument::createTextNode() etc. o simplemente usando cualquier otro nodo.

Parámetros

newnode

El hijo añadido.

Valores devueltos

El nodo añadido.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si este nodo es de sólo lectura o si el padre previo del nodo a ser insertado es de sólo lectura.

DOM_HIERARCHY_REQUEST_ERR

Lanzado si este nodo es de un tipo de no permite hijos del tipo del nodo newnode, o si el nodo a añadir es uno de los progenitores del nodo o si es el nodo en sí.

DOM_WRONG_DOCUMENT_ERR

Lanzado si newnode fue creado desde un documento diferente del que creó este nodo.

Ejemplos

El siguiente ejemplo añadirá un nuevo nodo elemento a un nuevo documento.

Ejemplo #1 Añadiendo un hijo

<?php

$doc = new DOMDocument;

$nodo = $doc->createElement("para");
$nuevo_nodo = $doc->appendChild($nodo);

echo $doc->saveXML();
?>

Ejemplo #2 Hijos anidados

<?php

$doc = new DOMDocument;

$headNode = $doc->createElement("head");
$doc->appendChild($headNode);

$titleNode = $doc->createElement("title");
$headNode->appendChild($titleNode);

echo $doc->saveXML();
?>

Ver también

  • DOMNode::insertBefore() - Añade un nuevo hijo antes del nodo de referencia
  • DOMNode::removeChild() - Elimina un hijo de la lista de hijos.
  • DOMNode::replaceChild() - Reemplaza un hijo


Canonizar nodos a una cadena

  • « DOMNode::appendChild
  • DOMNode::C14NFile »
  • PHP Manual
  • DOMNode
  • Canonizar nodos a una cadena

DOMNode::C14N

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14N — Canonizar nodos a una cadena

Descripción

public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string

Canoniza nodos a una cadena

Parámetros

exclusive

Habilita el análisis exclusivo de los nodos que coincidan únicamente con el xpath o los prefijos de nombres de espacio proporcionados.

with_comments

Conservar los comentarios en la salida.

xpath

Un array de xpaths por los que filtrar los nodos.

ns_prefixes

Un array de prefijos de nombres de espacio por los que filtrar los nodos.

Valores devueltos

Devuelve los nodos canonizados como cadenas o false en caso de error

Ver también

  • DOMNode::C14NFile() - Canonizar nodos a un fichero


Canonizar nodos a un fichero

  • « DOMNode::C14N
  • DOMNode::cloneNode »
  • PHP Manual
  • DOMNode
  • Canonizar nodos a un fichero

DOMNode::C14NFile

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14NFile — Canonizar nodos a un fichero

Descripción

public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int

Canoniza nodos a un fichero

Parámetros

uri

La ruta en la que escribir la salida.

exclusive

Habilita el análisis exclusivo de los nodos que coincidan únicamente con el xpath o los prefijos de nombres de espacio proporcionados.

with_comments

Conservar los comentarios en la salida.

xpath

Un array de xpaths por los que filtrar los nodos.

ns_prefixes

Un array de prefijos de nombres de espacio por los que filtrar los nodos.

Valores devueltos

El número de bytes escritos o false en caso de error

Ver también

  • DOMNode::C14N() - Canonizar nodos a una cadena


Clona un nodo

  • « DOMNode::C14NFile
  • DOMNode::getLineNo »
  • PHP Manual
  • DOMNode
  • Clona un nodo

DOMNode::cloneNode

(PHP 5, PHP 7)

DOMNode::cloneNode — Clona un nodo

Descripción

public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode

Crea una copia del nodo.

Parámetros

deep

Indica si copiar todos los nodos descendientes. Este parámetro es false de manera predeterminada.

Valores devueltos

El nodo clonado.


Obtener el número de línea de un nodo

  • « DOMNode::cloneNode
  • DOMNode::getNodePath »
  • PHP Manual
  • DOMNode
  • Obtener el número de línea de un nodo

DOMNode::getLineNo

(PHP 5 >= 5.3.0, PHP 7)

DOMNode::getLineNo — Obtener el número de línea de un nodo

Descripción

public DOMNode::getLineNo ( ) : int

Obtiene el número de línea donde está definido el nodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Siempre devuelve el número de línea donde está definido el nodo.

Ejemplos

Ejemplo #1 Ejemplo de DOMNode::getLineNo()

<?php
// XML dump for below example
$xml = <<<XML
<?xml version="1.0" encoding="utf-8"?>
<root>
    <node />
</root>
XML;

// Crear una nueva instancia de DOMDocument
$dom = new DOMDocument;

// Cargar el XML
$dom->loadXML($xml);

// Imprimir la línea donde el elemento 'node' fue definido
printf('La etiqueta <node> está definida en la línea %d', $dom->getElementsByTagName('node')->item(0)->getLineNo());
?>

El resultado del ejemplo sería:

La etiqueta <node> está definida en la línea 3


Obtener un XPath de un nodo

  • « DOMNode::getLineNo
  • DOMNode::hasAttributes »
  • PHP Manual
  • DOMNode
  • Obtener un XPath de un nodo

DOMNode::getNodePath

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::getNodePath — Obtener un XPath de un nodo

Descripción

public DOMNode::getNodePath ( ) : string

Obtiene una ruta de ubicación XPath del nodo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un string que contiene el XPath, o null en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de DOMNode::getNodePath()

<?php
// Crear una nueva instancia de DOMDocument
$dom = new DOMDocument;

// Cargar el XML
$dom->loadXML('
<frutas>
 <manzanas>
  <manzana>braeburn</manzana>
  <manzana>granny smith</manzana>
 </manzanas>
 <peras>
  <pera>conference</pera>
 </peras>
</frutas>
');

// Imprimir el XPath para cada elemento
foreach ($dom->getElementsByTagName('*') as $nodo) {
    echo $nodo->getNodePath() . "\n";
}
?>

El resultado del ejemplo sería:

/frutas
/frutas/manzanas
/frutas/manzanas/manzana[1]
/frutas/manzanas/manzana[2]
/frutas/peras
/frutas/peras/pera

Ver también

  • DOMXPath


Comprueba si un nodo tiene atributos

  • « DOMNode::getNodePath
  • DOMNode::hasChildNodes »
  • PHP Manual
  • DOMNode
  • Comprueba si un nodo tiene atributos

DOMNode::hasAttributes

(PHP 5, PHP 7)

DOMNode::hasAttributes — Comprueba si un nodo tiene atributos

Descripción

public DOMNode::hasAttributes ( ) : bool

Este método comprueba si el nodo tiene atributos. El nodo comprobado tiene que ser un XML_ELEMENT_NODE.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMNode::hasChildNodes() - Comprueba si el nodo tiene hijos


Comprueba si el nodo tiene hijos

  • « DOMNode::hasAttributes
  • DOMNode::insertBefore »
  • PHP Manual
  • DOMNode
  • Comprueba si el nodo tiene hijos

DOMNode::hasChildNodes

(PHP 5, PHP 7)

DOMNode::hasChildNodes — Comprueba si el nodo tiene hijos

Descripción

public DOMNode::hasChildNodes ( ) : bool

Esta función comprueba si el nodo tiene hijos.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMNode::hasAttributes() - Comprueba si un nodo tiene atributos


Añade un nuevo hijo antes del nodo de referencia

  • « DOMNode::hasChildNodes
  • DOMNode::isDefaultNamespace »
  • PHP Manual
  • DOMNode
  • Añade un nuevo hijo antes del nodo de referencia

DOMNode::insertBefore

(PHP 5, PHP 7)

DOMNode::insertBefore — Añade un nuevo hijo antes del nodo de referencia

Descripción

public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode

Esta función inserta un nuevo nodo justo antes que el nodo de referencia. Si planea hacer modificaciones posteriores al hijo añadido debe usar el nodo devuelto.

Parámetros

newnode

El nuevo nodo.

refnode

El nodo de referencia. Si no se proporciona, newnode es añadido al hijo.

Valores devueltos

El nodo insertado.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si este nodo es de sólo lectura o si el padre previo del nodo que va a ser insertado es de sólo lectura.

DOM_HIERARCHY_REQUEST_ERR

Lanzado si este nodo es de un tipo de no permite hijos del tipo del nodo newnode, o si el nodo a añadir es uno de los progenitores del nodo o si es el nodo en sí.

DOM_WRONG_DOCUMENT_ERR

Lanzado si newnode fue creado desde un documento diferente del que creó este nodo.

DOM_NOT_FOUND

Lanzado si refnode no es un hijo de este nodo.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos


Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado

  • « DOMNode::insertBefore
  • DOMNode::isSameNode »
  • PHP Manual
  • DOMNode
  • Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado

DOMNode::isDefaultNamespace

(PHP 5, PHP 7)

DOMNode::isDefaultNamespace — Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado

Descripción

public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool

Indica si namespaceURI es el espacio de nombres especificado.

Parámetros

namespaceURI

La URI del espacio de nombres a buscar.

Valores devueltos

Devuelve true si namespaceURI es el espacio de nombres predeterminado, false si no.


Indica si dos nodos son el mismo nodo

  • « DOMNode::isDefaultNamespace
  • DOMNode::isSupported »
  • PHP Manual
  • DOMNode
  • Indica si dos nodos son el mismo nodo

DOMNode::isSameNode

(PHP 5, PHP 7)

DOMNode::isSameNode — Indica si dos nodos son el mismo nodo

Descripción

public DOMNode::isSameNode ( DOMNode $node ) : bool

Esta función indica si dos nodos son el mismo nodo. La comparación no está basada en el contenido

Parámetros

node

El nodo comparado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Comprueba si una característica está soportada para la versión especificada

  • « DOMNode::isSameNode
  • DOMNode::lookupNamespaceUri »
  • PHP Manual
  • DOMNode
  • Comprueba si una característica está soportada para la versión especificada

DOMNode::isSupported

(PHP 5, PHP 7)

DOMNode::isSupported — Comprueba si una característica está soportada para la versión especificada

Descripción

public DOMNode::isSupported ( string $feature , string $version ) : bool

Comprueba si la característica solicitada dada por feature está soportada para la versión especificada dada por version.

Parámetros

feature

La característica a comprobar. Véase el ejemplo de DOMImplementation::hasFeature() para una lista de características.

version

El número de versión de feature a comprobar.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • DOMImplementation::hasFeature() - Comprueba si la implementación de DOM implementa una característica específica


Obtiene la URI del espacio de nombres del nodo basado en el prefijo

  • « DOMNode::isSupported
  • DOMNode::lookupPrefix »
  • PHP Manual
  • DOMNode
  • Obtiene la URI del espacio de nombres del nodo basado en el prefijo

DOMNode::lookupNamespaceUri

(PHP 5, PHP 7)

DOMNode::lookupNamespaceUri — Obtiene la URI del espacio de nombres del nodo basado en el prefijo

Descripción

public DOMNode::lookupNamespaceUri ( string $prefix ) : string

Obtiene la URI del espacio de nombres del nodo basado en prefix.

Parámetros

prefix

El prefijo del espacio de nombres.

Valores devueltos

La URI del espacio de nombres del nodo.

Ver también

  • DOMNode::lookupPrefix() - Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres


Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres

  • « DOMNode::lookupNamespaceUri
  • DOMNode::normalize »
  • PHP Manual
  • DOMNode
  • Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres

DOMNode::lookupPrefix

(PHP 5, PHP 7)

DOMNode::lookupPrefix — Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres

Descripción

public DOMNode::lookupPrefix ( string $namespaceURI ) : string

Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres.

Parámetros

namespaceURI

La URI del espacio de nombres.

Valores devueltos

El prefijo del espacio de nombres.

Ver también

  • DOMNode::lookupNamespaceUri() - Obtiene la URI del espacio de nombres del nodo basado en el prefijo


Normaliza el nodo

  • « DOMNode::lookupPrefix
  • DOMNode::removeChild »
  • PHP Manual
  • DOMNode
  • Normaliza el nodo

DOMNode::normalize

(PHP 5, PHP 7)

DOMNode::normalize — Normaliza el nodo

Descripción

public DOMNode::normalize ( ) : void

Elimina nodos de texto vacíos y une nodos de texto adyacentes en este nodo y todos sus hijos.

Valores devueltos

No devuelve ningún valor.

Ver también

  • » La Especificación DOM
  • DOMDocument::normalizeDocument() - Normaliza el documento


Elimina un hijo de la lista de hijos.

  • « DOMNode::normalize
  • DOMNode::replaceChild »
  • PHP Manual
  • DOMNode
  • Elimina un hijo de la lista de hijos.

DOMNode::removeChild

(PHP 5, PHP 7)

DOMNode::removeChild — Elimina un hijo de la lista de hijos.

Descripción

public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode

Esta función elimina un hijo de la lista de hijos.

Parámetros

oldnode

El hijo eliminado.

Valores devueltos

Si el hijo ha podido ser eliminado la función devuelve el hijo antiguo.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanzado si el nodo es de sólo lectura.

DOM_NOT_FOUND

Lanzado si oldnode no es un hijo de este nodo.

Ejemplos

El siguiente ejemplo eliminará el elemento chapter de nuestro documento XML.

Ejemplo #1 Eliminar un hijo

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$book = $doc->documentElement;

// recuperamos el capítulo y lo eliminamos del libro
$chapter = $book->getElementsByTagName('chapter')->item(0);
$oldchapter = $book->removeChild($chapter);

echo $doc->saveXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
          "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<book id="listing">
 <title>My lists</title>

</book>

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMNode::replaceChild() - Reemplaza un hijo


Reemplaza un hijo

  • « DOMNode::removeChild
  • DOMNodeList »
  • PHP Manual
  • DOMNode
  • Reemplaza un hijo

DOMNode::replaceChild

(PHP 5, PHP 7)

DOMNode::replaceChild — Reemplaza un hijo

Descripción

public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode

Esta función reemplaza el hijo oldnode con es nuevo nodo newnode proporcionado. Si el nuevo nodo ya es un hijo no será añadido una segunda vez. Si el reemplazo tiene éxito se devuelve el nodo antiguo.

Parámetros

newnode

El nuevo nodo. Debe ser un miembro del documento objetivo, es decir, creado con uno de los métodos DOMDocument->createXXX() o importado al documento por DOMDocument::importNode.

oldnode

El nodo antiguo.

Valores devueltos

El nodo antiguo o false si ocurrió un error.

Errores/Excepciones

DOM_NO_MODIFICATION_ALLOWED_ERR

Lanazado si este nodo es de sólo lectura o si el padre anterior del nodo al que va a ser insertado es de sólo lectura.

DOM_HIERARCHY_REQUEST_ERR

Lanzado si el nodo es de un tipo que no permite hijos del tipo del nodo newnode, o si el nodo a colocar es uno de los progenitores de este nodo o es este nodo en sí.

DOM_WRONG_DOCUMENT_ERR

Lanzado si newnode fue creado desde un documento diferente que el que creó este nodo.

DOM_NOT_FOUND

Lanzado si oldnode no es un hijo de este nodo.

Ver también

  • DOMNode::appendChild() - Añade un nuevo hijo al final de los hijos
  • DOMNode::removeChild() - Elimina un hijo de la lista de hijos.


La clase DOMNodeList

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMNodeList implements Traversable {
/* Propiedades */
readonly public int $length ;
/* Métodos */
public count ( ) : int
item ( int $index ) : DOMNode
}

Propiedades

length

El número de nodos de la lista. El rango de índices válidos de nodo hijo es de 0 a length - 1, ambos inclusive.

Ver también

  • » Especificación W3C de NodeList

Tabla de contenidos

  • DOMNodeList::count — Obtiene el número de nodos en la lista
  • DOMNodeList::item — Recupera un nodo especificado por un índice


Obtiene el número de nodos en la lista

  • « DOMNodeList
  • DOMNodeList::item »
  • PHP Manual
  • DOMNodeList
  • Obtiene el número de nodos en la lista

DOMNodeList::count

(PHP 7 >= 7.2.0)

DOMNodeList::count — Obtiene el número de nodos en la lista

Descripción

public DOMNodeList::count ( ) : int

Obtiene el número de nodos de la lista.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el número de nodos de la lista, que es idéntica a la propiedad length.


Recupera un nodo especificado por un índice

  • « DOMNodeList::count
  • DOMNotation »
  • PHP Manual
  • DOMNodeList
  • Recupera un nodo especificado por un índice

DOMNodeList::item

(PHP 5, PHP 7)

DOMNodeList::item — Recupera un nodo especificado por un índice

Descripción

DOMNodeList::item ( int $index ) : DOMNode

Recupera un nodo especificado por index dentro del objeto DOMNodeList.

Sugerencia

Si necesita conocer el número de nodos de la colección, use la propiedad length del objeto DOMNodeList.

Parámetros

index

Índice del nodo de la colección.

Valores devueltos

El nodo en la posición marcada por index del objeto DOMNodeList, o null si no es un índice válido.

Ejemplos

Ejemplo #1 Atravesar todas las entradas de una tabla

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$items = $doc->getElementsByTagName('entry');

for ($i = 0; $i < $items->length; $i++) {
    echo $items->item($i)->nodeValue . "\n";
}

?>

De manera alternativa, se puede usar foreach, que es una manera mucho más conveniente:

<?php

foreach ($items as $item) {
    echo $item->nodeValue . "\n";
}

?>

El resultado del ejemplo sería:

Title
Author
Language
ISBN
The Grapes of Wrath
John Steinbeck
en
0140186409
The Pearl
John Steinbeck
en
014017737X
Samarcande
Amine Maalouf
fr
2253051209


La clase DOMNotation

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMNotation extends DOMNode {
/* Propiedades */
readonly public string $publicId ;
readonly public string $systemId ;
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

publicId

systemId


La clase DOMProcessingInstruction

(PHP 5, PHP 7)

Sinopsis de la Clase

DOMProcessingInstruction extends DOMNode {
/* Propiedades */
readonly public string $target ;
public string $data ;
/* Métodos */
public __construct ( string $name , string $value = ? )
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

target

data

Tabla de contenidos

  • DOMProcessingInstruction::__construct — Crea un nuevo objeto DOMProcessingInstruction


Crea un nuevo objeto DOMProcessingInstruction

  • « DOMProcessingInstruction
  • DOMText »
  • PHP Manual
  • DOMProcessingInstruction
  • Crea un nuevo objeto DOMProcessingInstruction

DOMProcessingInstruction::__construct

(PHP 5, PHP 7)

DOMProcessingInstruction::__construct — Crea un nuevo objeto DOMProcessingInstruction

Descripción

public DOMProcessingInstruction::__construct ( string $name , string $value = ? )

Crea un nuevo objeto DOMProcessingInstruction. Este objeto es de sólo lectura. Se puede añadir a un documento, pero no se pueden añadir nodos adicionales a este nodo hata que el nodo esté asociado con un documento. Para crear un nodo modificable, use DOMDocument::createProcessingInstruction.

Parámetros

name

El nombre de la etiqueta de la instrucción en proceso.

value

El valor de la intrucción en proceso.

Ejemplos

Ejemplo #1 Crear un nuevo objeto DOMProcessingInstruction

<?php

$dom = new DOMDocument('1.0', 'UTF-8');
$html = $dom->appendChild(new DOMElement('html'));
$body = $html->appendChild(new DOMElement('body'));
$pinode = new DOMProcessingInstruction('php', 'echo "Hola Mundo"; ');
$body->appendChild($pinode);
echo $dom->saveXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0" encoding="UTF-8"?>
<html><body><?php echo "Hola Mundo"; ?></body></html>

Ver también

  • DOMDocument::createProcessingInstruction() - Crea un nuevo nodo PI


La clase DOMText

(PHP 5, PHP 7)

Introducción

La clase DOMText hereda de DOMCharacterData y representa el contenido textual de un objeto DOMElement o DOMAttr.

Sinopsis de la Clase

DOMText extends DOMCharacterData {
/* Propiedades */
readonly public string $wholeText ;
/* Métodos */
public __construct ( string $value = ? )
public isElementContentWhitespace ( ) : bool
public isWhitespaceInElementContent ( ) : bool
public splitText ( int $offset ) : DOMText
/* Métodos heredados */
public DOMNode::appendChild ( DOMNode $newnode ) : DOMNode
public DOMNode::C14N ( bool $exclusive = ? , bool $with_comments = ? , array $xpath = ? , array $ns_prefixes = ? ) : string
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $with_comments = false , array $xpath = ? , array $ns_prefixes = ? ) : int
public DOMNode::cloneNode ( bool $deep = ? ) : DOMNode
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $newnode , DOMNode $refnode = ? ) : DOMNode
public DOMNode::isDefaultNamespace ( string $namespaceURI ) : bool
public DOMNode::isSameNode ( DOMNode $node ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespaceURI ) : string
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $oldnode ) : DOMNode
public DOMNode::replaceChild ( DOMNode $newnode , DOMNode $oldnode ) : DOMNode
}

Propiedades

wholeText

Mantiene todo el texto de los nodos Text adyacentes de forma lógica (sin estar separados por Element, Comment o Processing Instruction).

Tabla de contenidos

  • DOMText::__construct — Crea un nuevo objeto DOMText
  • DOMText::isElementContentWhitespace — Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento
  • DOMText::isWhitespaceInElementContent — Indica si este nodo de texto contiene espacios en blanco
  • DOMText::splitText — Rompe este nodo en dos nodos en el índice especificado


Crea un nuevo objeto DOMText

  • « DOMText
  • DOMText::isElementContentWhitespace »
  • PHP Manual
  • DOMText
  • Crea un nuevo objeto DOMText

DOMText::__construct

(PHP 5, PHP 7)

DOMText::__construct — Crea un nuevo objeto DOMText

Descripción

public DOMText::__construct ( string $value = ? )

Crea un nuevo objeto DOMText.

Parámetros

value

El valor del nodo de texto. Si no se proporciona, se crea un nodo de texto vacío.

Ejemplos

Ejemplo #1 Crear un nuevo objeto DOMText

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$text = $element->appendChild(new DOMText('root value'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?><root>root value</root> */

?>

Ver también

  • DOMDocument::createTextNode() - Crea un nuevo nodo de texto


Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento

  • « DOMText::__construct
  • DOMText::isWhitespaceInElementContent »
  • PHP Manual
  • DOMText
  • Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento

DOMText::isElementContentWhitespace

(No hay información de versión disponible, podría estar únicamente en Git)

DOMText::isElementContentWhitespace — Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento

Descripción

public DOMText::isElementContentWhitespace ( ) : bool

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Indica si este nodo de texto contiene espacios en blanco

  • « DOMText::isElementContentWhitespace
  • DOMText::splitText »
  • PHP Manual
  • DOMText
  • Indica si este nodo de texto contiene espacios en blanco

DOMText::isWhitespaceInElementContent

(PHP 5, PHP 7)

DOMText::isWhitespaceInElementContent — Indica si este nodo de texto contiene espacios en blanco

Descripción

public DOMText::isWhitespaceInElementContent ( ) : bool

Indica si este nodo de texto contiene únicamente espacios en blanco o si está vacío. El nodo de texto está determinado a contener espacios en blanco en el contenido del elemento durante la carga del documento.

Valores devueltos

Devuelve true si el nodo contiene cero o más carecteres espacio en blanco y nada más. De lo contrario deveulve false.


Rompe este nodo en dos nodos en el índice especificado

  • « DOMText::isWhitespaceInElementContent
  • DOMXPath »
  • PHP Manual
  • DOMText
  • Rompe este nodo en dos nodos en el índice especificado

DOMText::splitText

(PHP 5, PHP 7)

DOMText::splitText — Rompe este nodo en dos nodos en el índice especificado

Descripción

public DOMText::splitText ( int $offset ) : DOMText

Rompe este nodo en dos nodos en el índice especificado por offset, manteniéndolos en el árbol como hermanos.

Después de la separación, este nodo contendrá todos el contenido hata offset. Si el nodo original tenía un nodo padre, el nuevo nodo se inserta como el hermano siguiente del nodo original. Cuando offset es igual a la longitud de este nodo, el nuevo nodo no tendrá información.

Parámetros

offset

El índice en el que se hace la separación, comenzando en 0.

Valores devueltos

El nuevo nodo del mismo tipo, que contiene todo el contenido desde y después de offset.


La clase DOMXPath

(PHP 5, PHP 7)

Introducción

Soporta XPath 1.0

Sinopsis de la Clase

DOMXPath {
/* Propiedades */
public DOMDocument $document ;
/* Métodos */
public __construct ( DOMDocument $doc )
public evaluate ( string $expression , DOMNode $contextnode = ? , bool $registerNodeNS = true ) : mixed
public query ( string $expression , DOMNode $contextnode = ? , bool $registerNodeNS = true ) : DOMNodeList
public registerNamespace ( string $prefix , string $namespaceURI ) : bool
public registerPhpFunctions ( mixed $restrict = ? ) : void
}

Propiedades

document

Tabla de contenidos

  • DOMXPath::__construct — Crea un nuevo objeto DOMXPath
  • DOMXPath::evaluate — Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible
  • DOMXPath::query — Evalúa la expresión XPath dada
  • DOMXPath::registerNamespace — Registra el espacio de nombres con el objeto DOMXPath
  • DOMXPath::registerPhpFunctions — Registra funciones de PHP como funciones XPath


Crea un nuevo objeto DOMXPath

  • « DOMXPath
  • DOMXPath::evaluate »
  • PHP Manual
  • DOMXPath
  • Crea un nuevo objeto DOMXPath

DOMXPath::__construct

(PHP 5, PHP 7)

DOMXPath::__construct — Crea un nuevo objeto DOMXPath

Descripción

public DOMXPath::__construct ( DOMDocument $doc )

Crea un nuevo objeto DOMXPath.

Parámetros

doc

El objeto DOMDocument asociado con el objeto DOMXPath.


Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible

  • « DOMXPath::__construct
  • DOMXPath::query »
  • PHP Manual
  • DOMXPath
  • Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible

DOMXPath::evaluate

(PHP 5 >= 5.1.0, PHP 7)

DOMXPath::evaluate — Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible

Descripción

public DOMXPath::evaluate ( string $expression , DOMNode $contextnode = ? , bool $registerNodeNS = true ) : mixed

Ejecuta la expresión XPath dada por expression y devuelve un resultado escrito si es posible.

Parámetros

expression

La expresión XPath a ejecutar.

contextnode

El parámetro opcional contextnode se puede especificar para hacer consultas XPath relativas. Por omisión, las consultas son relativas al elemento raíz.

registerNodeNS

El parámetro opcional registerNodeNS puede ser especificado para deshabilitar el registro automático del nodo de contexto.

Valores devueltos

Devuelve un resultado escrito si es posible o un objeto DOMNodeList que contiene todos los nodos coincidentes con la expresión XPath dada por expression.

Si el parámetro expression está malformado o el parámetro contextnode es inválido, DOMXPath::evaluate() devuelve false.

Historial de cambios

Versión | Descripción
5.3.3 | Se añadió el parámetro registerNodeNS.

Ejemplos

Ejemplo #1 Obtener el número de todos los libros en inglés

<?php

$doc = new DOMDocument;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// nuestra consulta es relativa al nodo tbody
$consulta = 'count(row/entry[. = "en"])';

$entradas = $xpath->evaluate($consulta, $tbody);
echo "Hay $entradas libros en inglés\n";

?>

El resultado del ejemplo sería:

Hay 2 libros en inglés

Ver también

  • DOMXPath::query() - Evalúa la expresión XPath dada


Evalúa la expresión XPath dada

  • « DOMXPath::evaluate
  • DOMXPath::registerNamespace »
  • PHP Manual
  • DOMXPath
  • Evalúa la expresión XPath dada

DOMXPath::query

(PHP 5, PHP 7)

DOMXPath::query — Evalúa la expresión XPath dada

Descripción

public DOMXPath::query ( string $expression , DOMNode $contextnode = ? , bool $registerNodeNS = true ) : DOMNodeList

Ejecuta la expresión XPath dada por expression.

Parámetros

expression

La expresión XPath a ejecutar.

contextnode

El parámetro opcional contextnode se puede especificar para hacer consultas XPath relativas. Por omisión, las consultas son relativas al elemento raíz.

registerNodeNS

El parámetro opcional registerNodeNS puede ser especificado para deshabilitar el registro automático del nodo de contexto.

Valores devueltos

Devuelve un objeto DOMNodeList que contiene todos los nodos coincidentes con la expresión XPath dada por expression. Cualquier expresión que no devuelva nodos devolverá un objeto DOMNodeList vacío.

Si el parámetro expression está malformado o el parámetro contextnode es inválido, DOMXPath::query() devuelve false.

Historial de cambios

Versión | Descripción
5.3.3 | Se añadió el parámetro registerNodeNS.

Ejemplos

Ejemplo #1 Obtener todos los libros en inglés

<?php

$doc = new DOMDocument;

// No queremos molestar con espacios en blanco
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Empezamos desde el elemento root
$consulta = '//book/chapter/para/informaltable/tgroup/tbody/row/entry[. = "en"]';

$entradas = $xpath->query($consulta);

foreach ($entradas as $entrada) {
    echo "Se encotró {$entrada->previousSibling->previousSibling->nodeValue}," .
         " por {$entrada->previousSibling->nodeValue}\n";
}
?>

El resultado del ejemplo sería:

Se encontró The Grapes of Wrath, por John Steinbeck
Se encontró The Pearl, por John Steinbeck

También podemos usar el parámetro contextnode para acortar nuestra expresión:

<?php

$doc = new DOMDocument;
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// nuestra consulta es relativa al nodo tbody
$consulta = 'row/entry[. = "en"]';

$entradas = $xpath->query($consulta, $tbody);

foreach ($entradas as $entrada) {
    echo "Se encontró {$entrada->previousSibling->previousSibling->nodeValue}," .
         " por {$entrada->previousSibling->nodeValue}\n";
}
?>

Ver también

  • DOMXPath::evaluate() - Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible


Registra el espacio de nombres con el objeto DOMXPath

  • « DOMXPath::query
  • DOMXPath::registerPhpFunctions »
  • PHP Manual
  • DOMXPath
  • Registra el espacio de nombres con el objeto DOMXPath

DOMXPath::registerNamespace

(PHP 5, PHP 7)

DOMXPath::registerNamespace — Registra el espacio de nombres con el objeto DOMXPath

Descripción

public DOMXPath::registerNamespace ( string $prefix , string $namespaceURI ) : bool

Registra namespaceURI y prefix con el objeto DOMXPath.

Parámetros

prefix

El prefijo.

namespaceURI

La URI del espacio de nombres.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Registra funciones de PHP como funciones XPath

  • « DOMXPath::registerNamespace
  • Funciones de DOM »
  • PHP Manual
  • DOMXPath
  • Registra funciones de PHP como funciones XPath

DOMXPath::registerPhpFunctions

(PHP 5 >= 5.3.0, PHP 7)

DOMXPath::registerPhpFunctions — Registra funciones de PHP como funciones XPath

Descripción

public DOMXPath::registerPhpFunctions ( mixed $restrict = ? ) : void

Este método habilita la capacidad de usar funciones de PHP dentro de expresiones XPath.

Parámetros

restrict

Use este parámetro para permitir solamente que ciertas funciones sean llamadas desde XPath.

Este parámetro puede ser un string (un nombre de función) o un array de nombres de funciones.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Los siguientes ejemplos usan book.xml que contiene lo siguiente:

Ejemplo #1 book.xml

<?xml version="1.0" encoding="UTF-8"?>
<books>
 <book>
  <title>PHP Basics</title>
  <author>Jim Smith</author>
  <author>Jane Smith</author>
 </book>
 <book>
  <title>PHP Secrets</title>
  <author>Jenny Smythe</author>
 </book>
 <book>
  <title>XML basics</title>
  <author>Joe Black</author>
 </book>
</books>

Ejemplo #2 DOMXPath::registerPHPFunctions() con php:functionString

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Registrar el espacio de nombres php: namespace (requerido)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Registrar funciones de PHP (sin restricciones)
$xpath->registerPHPFunctions();

// Llamar a la función substr en el título del libro
$nodos = $xpath->query('//book[php:functionString("substr", title, 0, 3) = "PHP"]');

echo "Se encontró {$nodos->length} libros que empiezan con 'PHP':\n";
foreach ($nodos as $nodo) {
    $title  = $nodo->getElementsByTagName("title")->item(0)->nodeValue;
    $author = $nodo->getElementsByTagName("author")->item(0)->nodeValue;
    echo "$title por $author\n";
}

?>

El resultado del ejemplo sería algo similar a:

Se encontró 2 libros que empiezan con 'PHP':
PHP Basics por Jim Smith
PHP Secrets por Jenny Smythe

Ejemplo #3 DOMXPath::registerPHPFunctions() con php:function

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Registrar el espacio de nombres php: namespace (requerido)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Registrar funciones de PHP (sólo has_multiple)
$xpath->registerPHPFunctions("has_multiple");

function has_multiple($nodos) {
    // Return true if more than one author
    return count($nodos) > 1;
}
// Filtrar libros con múltiples autores
$libros = $xpath->query('//book[php:function("has_multiple", author)]');

echo "Libros con múltiples autores:\n";
foreach ($libros as $libro) {
    echo $libro->getElementsByTagName("title")->item(0)->nodeValue . "\n";
}

?>

El resultado del ejemplo sería algo similar a:

Libros con múltiples autores:
PHP Basics

Ver también

  • DOMXPath::registerNamespace() - Registra el espacio de nombres con el objeto DOMXPath
  • DOMXPath::query() - Evalúa la expresión XPath dada
  • DOMXPath::evaluate() - Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible


Funciones de DOM

Tabla de contenidos

  • dom_import_simplexml — Obtiene un objeto DOMElement desde un objeto SimpleXMLElement


Obtiene un objeto DOMElement desde un objeto SimpleXMLElement

  • « Funciones de DOM
  • libxml »
  • PHP Manual
  • Funciones de DOM
  • Obtiene un objeto DOMElement desde un objeto SimpleXMLElement

dom_import_simplexml

(PHP 5, PHP 7)

dom_import_simplexml — Obtiene un objeto DOMElement desde un objeto SimpleXMLElement

Descripción

dom_import_simplexml ( SimpleXMLElement $node ) : DOMElement

Esta función toma el nodo node de la clase SimpleXML y lo convierte en un nodod DOMElement. Este nuevo objeto se puede usar como un nodo DOMElement nativo.

Parámetros

node

El nodo SimpleXMLElement.

Valores devueltos

El nodo DOMElement añdido o false si ocurrió un error.

Ejemplos

Ejemplo #1 Importar SimpleXML a DOM con dom_import_simplexml()

<?php

$sxe = simplexml_load_string('<books><book><title>blah</title></book></books>');

if ($sxe === false) {
    echo 'Error al analizar el documento';
    exit;
}

$dom_sxe = dom_import_simplexml($sxe);
if (!$dom_sxe) {
    echo 'Error al convertir a XML';
    exit;
}

$dom = new DOMDocument('1.0');
$dom_sxe = $dom->importNode($dom_sxe, true);
$dom_sxe = $dom->appendChild($dom_sxe);

echo $dom->saveXML();

?>

Ver también

  • simplexml_import_dom() - Obtiene un objeto SimpleXMLElement de un nodo DOM


libxml

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • libXMLError — La clase libXMLError
  • Funciones de libxml
    • libxml_clear_errors — Limpia el buffer de errores de libxml
    • libxml_disable_entity_loader — Deshabilita la capacidad de cargar entidades externas
    • libxml_get_errors — Recupera un array de errores
    • libxml_get_last_error — Recupera el último error de libxml
    • libxml_set_external_entity_loader — Cambia el cargador externo por defecto de entidades
    • libxml_set_streams_context — Configura el contexto de flujo para el próximo documento libxml cargado o escrito
    • libxml_use_internal_errors — Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario


Introducción

Estas funciones/constantes están disponibles a partir de PHP 5.1.0. Las siguientes extensiones del núcleo dependen de esta extensión libxml: DOM, libxml, SimpleXML, SOAP, WDDX, XSL, XML, XMLReader, XMLRPC y XMLWriter.


  • « Instalación/Configuración
  • Instalación »
  • PHP Manual
  • Instalación/Configuración
  • Requerimientos

Requerimientos

Esta estensión requiere » libxml >= 2.6.0.


Instalación

La extensión libxml está habilitada por defecto, aún asi es posible deshabilitarla con la directiva --disable-libxml.

La directiva --with-libxml-dir opcional es utilizada para especificar la ubicación de libxml dentro del sistema en el que PHP está siendo compilado, de lo contrario solo las ubicaciones por defecto son escaneadas. El proceso configure chequea por libxml (específicamente, xml2-config) en el siguiente orden:

  1. La ubicación ([DIR]) especificada con --with-libxml-dir ([DIR]=/bin/xml2-config)

  2. /usr/local/bin/xml2-config

  3. /usr/bin/xml2-config

Si configure no puede encontrar xml2-config en el directorio especificado por --with-libxml-dir, entonces continuará y comprobará las ubicaciones por defecto.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

LIBXML_COMPACT (integer)
Activa la optimización de asignación de nodos pequeños. Esto puede acelerar la aplicación sin la necesidad de cambiar el código.

Nota:

Solo disponible en Libxml >= 2.6.21

LIBXML_DTDATTR (integer)
Atributos DTD por defecto
LIBXML_DTDLOAD (integer)
Carga el subconjunto externo
LIBXML_DTDVALID (integer)
Valida con el DTD
LIBXML_HTML_NOIMPLIED (integer)
Establece el indicador HTML_PARSE_NOIMPLIED flag, el cual desactiva la adición automática de elementos html/body... implicados.

Nota:

Solamente disponible en Libxml >= 2.7.7 (a partir de PHP >= 5.4.0)

LIBXML_HTML_NODEFDTD (integer)
Establece el indicador HTML_PARSE_NODEFDTD, el cual previente que se añada un tipo de documento predeterminado cuando no se encuentra uno.

Nota:

Solamente disponible en Libxml >= 2.7.8 (a partir de PHP >= 5.4.0)

LIBXML_NOBLANKS (integer)
Elimina nodos en blanco
LIBXML_NOCDATA (integer)
Combina CDATA como nodos de texto
LIBXML_NOEMPTYTAG (integer)
Expande etiquetas vacías (por ej. de <br/> a <br></br>)

Nota:

Esta opción está actualmente disponible solo en las funciones DOMDocument::save y DOMDocument::saveXML.

LIBXML_NOENT (integer)
Sustituye entidades
LIBXML_NOERROR (integer)
Suprime reportes de errores
LIBXML_NONET (integer)
Deshabilita el acceso a red cuando se cargan documentos
LIBXML_NOWARNING (integer)
Suprime reportes de advertencias
LIBXML_NOXMLDECL (integer)
Omite la declaración XML cuando se guarda un documento

Nota:

Solo disponible en Libxml >= 2.6.21

LIBXML_NSCLEAN (integer)
Eliminar declaraciones de nombre de espacios redundantes
LIBXML_PARSEHUGE (integer)
Establece la bandera XML_PARSE_HUGE, que hace más flexible cualquier límite hardcode del analizador. Esto afecta a los límites tales como la profundidad máxima de un documento o la recursión de entidades, así como los límites de tamaño de los nodos de texto.

Nota:

Solamente está disponible en Libxml >= 2.7.0 (a partir de PHP >= 5.3.2 y PHP >= 5.2.12)

LIBXML_PEDANTIC (integer)
Establece el indicador XML_PARSE_PEDANTIC, el cual habilita el informe de errores pedante.

Nota:

Disponible a partir de PHP >= 5.4.0

LIBXML_XINCLUDE (integer)
Implementa la sustitución XInclude
LIBXML_ERR_ERROR (integer)
Un error recuperable
LIBXML_ERR_FATAL (integer)
Un error fatal
LIBXML_ERR_NONE (integer)
Sin errores
LIBXML_ERR_WARNING (integer)
Una simple advertencia
LIBXML_VERSION (integer)
La versión de libxml, como 20605 o 20617
LIBXML_DOTTED_VERSION (string)
La versión de libxml, como 2.6.5 o 2.6.17
LIBXML_SCHEMA_CREATE (integer)
Crear nodos de valor predeterminado/fijo durante la validación del esquema XSD

Nota:

Solamente disponible en Libxml >= 2.6.14 (a partir de PHP >= 5.5.2)


La clase libXMLError

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Introducción

Contiene diversa información sobre los errores lanzados por libxml. Los códigos de error son descritos en la » documentación de la API xmlError oficial.

Sinopsis de la Clase

libXMLError {
/* Propiedades */
public int $level ;
public int $code ;
public int $column ;
public string $message ;
public string $file ;
public int $line ;
}

Propiedades

level

La gravedad del error (una de las siguientes constantes: LIBXML_ERR_WARNING, LIBXML_ERR_ERROR o LIBXML_ERR_FATAL)

code

El código del error.

column

La columna donde ocurrió el error.

Nota:

Esta propiedad no está completamente implementada en libxml y por tanto a menudo devuelve 0.

message

El mensaje del error, si es que hay.

file

El nombre del fichero, o vacio si el XML fue cargado desde una cadena.

line

La línea en la que ocurrió el error.


Funciones de libxml

Tabla de contenidos

  • libxml_clear_errors — Limpia el buffer de errores de libxml
  • libxml_disable_entity_loader — Deshabilita la capacidad de cargar entidades externas
  • libxml_get_errors — Recupera un array de errores
  • libxml_get_last_error — Recupera el último error de libxml
  • libxml_set_external_entity_loader — Cambia el cargador externo por defecto de entidades
  • libxml_set_streams_context — Configura el contexto de flujo para el próximo documento libxml cargado o escrito
  • libxml_use_internal_errors — Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario


Limpia el buffer de errores de libxml

  • « Funciones de libxml
  • libxml_disable_entity_loader »
  • PHP Manual
  • Funciones de libxml
  • Limpia el buffer de errores de libxml

libxml_clear_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_clear_errors — Limpia el buffer de errores de libxml

Descripción

libxml_clear_errors ( ) : void

libxml_clear_errors() limpia el buffer de errores de libxml.

Valores devueltos

No devuelve ningún valor.

Ver también

  • libxml_get_errors() - Recupera un array de errores
  • libxml_get_last_error() - Recupera el último error de libxml


Deshabilita la capacidad de cargar entidades externas

  • « libxml_clear_errors
  • libxml_get_errors »
  • PHP Manual
  • Funciones de libxml
  • Deshabilita la capacidad de cargar entidades externas

libxml_disable_entity_loader

(PHP 5 >= 5.2.11, PHP 7, PHP 8)

libxml_disable_entity_loader — Deshabilita la capacidad de cargar entidades externas

Descripción

libxml_disable_entity_loader ( bool $disable = true ) : bool

Habilita/deshabilita la capacidad de cargar entidades externas.

Parámetros

disable

Deshabilita (true) o habilita (false) extensiones libxml (tal como DOM, XMLWriter y XMLReader) para cargar entidades externas.

Valores devueltos

Devuelve el valor anterior.

Ver también

  • libxml_use_internal_errors() - Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario
  • La constante LIBXML_NONET


Recupera un array de errores

  • « libxml_disable_entity_loader
  • libxml_get_last_error »
  • PHP Manual
  • Funciones de libxml
  • Recupera un array de errores

libxml_get_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_get_errors — Recupera un array de errores

Descripción

libxml_get_errors ( ) : array

Recupera un array de errores.

Valores devueltos

Recupera un array con objetos de tipo LibXMLError si hay errores en el buffer, o un array vacío en caso contrario.

Ejemplos

Ejemplo #1 Ejemplo de libxml_get_errors()

Este ejemplo demuestra cómo contruir un gestor de errores libxml simple.

<?php

libxml_use_internal_errors(true);

$xmlstr = <<< XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <titles>PHP: Detrás del analizador sintáctico</title>
 </movie>
</movies>
XML;

$doc = simplexml_load_string($xmlstr);
$xml = explode("\n", $xmlstr);

if (!$doc) {
    $errors = libxml_get_errors();

    foreach ($errors as $error) {
        echo display_xml_error($error, $xml);
    }

    libxml_clear_errors();
}

function display_xml_error($error, $xml)
{
    $return  = $xml[$error->line - 1] . "\n";
    $return .= str_repeat('-', $error->column) . "^\n";

    switch ($error->level) {
        case LIBXML_ERR_WARNING:
            $return .= "Warning $error->code: ";
            break;
         case LIBXML_ERR_ERROR:
            $return .= "Error $error->code: ";
            break;
        case LIBXML_ERR_FATAL:
            $return .= "Fatal Error $error->code: ";
            break;
    }

    $return .= trim($error->message) .
               "\n  Line: $error->line" .
               "\n  Column: $error->column";

    if ($error->file) {
        $return .= "\n  File: $error->file";
    }

    return "$return\n\n--------------------------------------------\n\n";
}

?>

El resultado del ejemplo sería:

  <titles>PHP: Detrás del analizador sintáctico</title>
----------------------------------------------^
Fatal Error 76: Opening and ending tag mismatch: titles line 4 and title
  Line: 4
  Column: 46

--------------------------------------------

Ver también

  • libxml_get_last_error() - Recupera el último error de libxml
  • libxml_clear_errors() - Limpia el buffer de errores de libxml


Recupera el último error de libxml

  • « libxml_get_errors
  • libxml_set_external_entity_loader »
  • PHP Manual
  • Funciones de libxml
  • Recupera el último error de libxml

libxml_get_last_error

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_get_last_error — Recupera el último error de libxml

Descripción

libxml_get_last_error ( ) : LibXMLError

Recupera el último error de libxml.

Valores devueltos

Devuelve un objeto de tipo LibXMLError si hay algún error en el buffer, o false en caso contrario.

Ver también

  • libxml_get_errors() - Recupera un array de errores
  • libxml_clear_errors() - Limpia el buffer de errores de libxml


Cambia el cargador externo por defecto de entidades

  • « libxml_get_last_error
  • libxml_set_streams_context »
  • PHP Manual
  • Funciones de libxml
  • Cambia el cargador externo por defecto de entidades

libxml_set_external_entity_loader

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

libxml_set_external_entity_loader — Cambia el cargador externo por defecto de entidades

Descripción

libxml_set_external_entity_loader ( callable $resolver_function ) : bool

Cambia el cargador externo por defecto de entidades.

Parámetros

resolver_function

Un callable que acepte tres argumentos. Dos strings: una id pública y una id de sistema, y un contexto (un array con cuatro elementos) como tercer argumento. Este callback debe devolver un resource, una cadena a partir de la cual s epueda abrir un resource, o null.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de libxml_set_external_entity_loader()

<?php
$xml = <<<XML
<!DOCTYPE foo PUBLIC "-//FOO/BAR" "http://example.com/foobar">
<foo>bar</foo>
XML;

$dtd = <<<DTD
<!ELEMENT foo (#PCDATA)>
DTD;

libxml_set_external_entity_loader(
    function ($public, $system, $context) use($dtd) {
        var_dump($public);
        var_dump($system);
        var_dump($context);
        $f = fopen("php://temp", "r+");
        fwrite($f, $dtd);
        rewind($f);
        return $f;
    }
);

$dd = new DOMDocument;
$r  = $dd->loadXML($xml);

var_dump($dd->validate());
?>

El resultado del ejemplo sería:

string(10) "-//FOO/BAR"
string(25) "http://example.com/foobar"
array(4) {
    ["directory"]    => NULL
    ["intSubName"]   => NULL
    ["extSubURI"]    => NULL
    ["extSubSystem"] => NULL
}
bool(true)

Ver también

  • libxml_disable_entity_loader() - Deshabilita la capacidad de cargar entidades externas


Configura el contexto de flujo para el próximo documento libxml cargado o escrito

  • « libxml_set_external_entity_loader
  • libxml_use_internal_errors »
  • PHP Manual
  • Funciones de libxml
  • Configura el contexto de flujo para el próximo documento libxml cargado o escrito

libxml_set_streams_context

(PHP 5, PHP 7, PHP 8)

libxml_set_streams_context — Configura el contexto de flujo para el próximo documento libxml cargado o escrito

Descripción

libxml_set_streams_context ( resource $streams_context ) : void

Configura el contexto de flujo para el próximo documento libxml cargado o escrito.

Parámetros

streams_context

El contexto de flujo de tipo resource (creado con la función stream_context_create())

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Ejemplo de libxml_set_streams_context()

<?php

$opts = array(
    'http' => array(
        'user_agent' => 'PHP libxml agent',
    )
);

$context = stream_context_create($opts);
libxml_set_streams_context($context);

// peticiona un archivo a través de HTTP
$doc = DOMDocument::load('http://www.example.com/file.xml');

?>

Ver también

  • stream_context_create() - Crear un contexto de flujo


Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario

  • « libxml_set_streams_context
  • SimpleXML »
  • PHP Manual
  • Funciones de libxml
  • Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario

libxml_use_internal_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_use_internal_errors — Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario

Descripción

libxml_use_internal_errors ( bool $use_errors = false ) : bool

libxml_use_internal_errors() permite deshabilitar errores libxml estándares y habilitar el manejo de errores del usuario.

Parámetros

use_errors

Habilita (true) o deshabilita (false) el manejo de errores por parte del usuario. La deshabilitación también borrará cualquier error libxml existente.

Valores devueltos

Esta función devuelve el valor anterior de use_errors.

Ejemplos

Ejemplo #1 Ejemplo de libxml_use_internal_errors()

Este ejemplo demuestra el uso básico de los errores libxml y el valor devuelto por esta función.

<?php

// habilita el manejo de errores del usuario
var_dump(libxml_use_internal_errors(true));

// carga el documento
$doc = new DOMDocument;

if (!$doc->load('file.xml')) {
    foreach (libxml_get_errors() as $error) {
        // Aquí se manejan los errores
    }

    libxml_clear_errors();
}

?>

El resultado del ejemplo sería:

bool(false)

Ver también

  • libxml_clear_errors() - Limpia el buffer de errores de libxml
  • libxml_get_errors() - Recupera un array de errores


SimpleXML

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Uso básico de SimpleXML
    • Tratar con los errores XML
  • SimpleXMLElement — Clase SimpleXMLElement
    • SimpleXMLElement::addAttribute — Añade un atributo al elemento SimpleXML
    • SimpleXMLElement::addChild — Añade un elemento hijo al nodo XML
    • SimpleXMLElement::asXML — Retorna un string XML correcto basado en un elemento SimpleXML
    • SimpleXMLElement::attributes — Identifica el atributo de un elemento
    • SimpleXMLElement::children — Encuentra los hijos del nodo dado
    • SimpleXMLElement::__construct — Crea un nuevo objeto SimpleXMLElement
    • SimpleXMLElement::count — Cuenta los hijos de un elemento
    • SimpleXMLElement::getDocNamespaces — Devuelve los espacios de nombre declarados en el documento
    • SimpleXMLElement::getName — Retorna el nombre del elemento XML
    • SimpleXMLElement::getNamespaces — Devuelve los espacios de nombre usados en el documento
    • SimpleXMLElement::registerXPathNamespace — Crea un contexto prefijo/ns para la siguiente petición XPath
    • SimpleXMLElement::saveXML — Alias de SimpleXMLElement::asXML
    • SimpleXMLElement::__toString — Returns the string content
    • SimpleXMLElement::xpath — Ejecuta una petición XPath sobre los datos XML
  • SimpleXMLIterator — La clase SimpleXMLIterator
    • SimpleXMLIterator::current — Devuelve el elemento actual
    • SimpleXMLIterator::getChildren — Devuelve los sub elementos de el elemento actual
    • SimpleXMLIterator::hasChildren — Comprueba si el elemento actual tiene sub elementos
    • SimpleXMLIterator::key — Devuelve la clave actual
    • SimpleXMLIterator::next — Mueve al siguiente elemento
    • SimpleXMLIterator::rewind — Rebobina hasta el primer elemento
    • SimpleXMLIterator::valid — Comprueba si el elemento actual es válido
  • Funciones de SimpleXML
    • simplexml_import_dom — Obtiene un objeto SimpleXMLElement de un nodo DOM
    • simplexml_load_file — Interpreta un fichero XML en un objeto
    • simplexml_load_string — Interpreta un string de XML en un objeto


Introducción

La extensión SimpleXML proporciona un conjunto de herramientas muy simple y fácil de usar para convertir XML a un objeto que pueda ser procesado con selectores de propiedades normales e iteradores de arrays.


Requerimientos

Esta extensión requiere la extensión libxml de PHP. Esto significa que también es necesario pasar la opción --enable-libxml, aunque esto se realiza implícitamente debido a que libxml está habilitada de forma predeterminada.

La extensión SimpleXML requiere PHP 5.


Instalación

Esta extensión está habilitada de forma predeterminada. Se puede deshabilitar empleando la siguiente opción durante la compilación: --disable-simplexml

Nota: Para versiones anteriores a PHP 5.1.2, es necesario usar --enable-simplexml para activar esta extensión.


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • SimpleXML
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Uso básico de SimpleXML »
  • PHP Manual
  • SimpleXML
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Uso básico de SimpleXML
  • Tratar con los errores XML


Uso básico de SimpleXML

Muchos ejemplos en esta referencia requieren un string XML. En vez de repetir este string en cada ejemplo, se ha puesto en un fichero que se incluye en cada ejemplo. Este fichero se muestra en la siguiente sección de ejemplo. Alternativamente, puede crearse un documento XML y leerlo con simplexml_load_file().

Ejemplo #1 El fichero ejemplo.php a incluir con el string XML

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<peliculas>
 <pelicula>
  <titulo>PHP: Tras el Analilzador</titulo>
  <personajes>
   <personaje>
    <nombre>Srta. Programadora</nombre>
    <actor>Onlivia Actora</actor>
   </personaje>
   <personaje>
    <nombre>Sr. Programador</nombre>
    <actor>El Act&#211;r</actor>
   </personaje>
  </personajes>
  <argumento>
   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje de script? Lo descubrirás en esta intrigante y temible parodia
   de un documental.
  </argumento>
  <grandes-frases>
   <frase>PHP soluciona todos los problemas web</frase>
  </grandes-frases>
  <puntuacion tipo="votos">7</puntuacion>
  <puntuacion tipo="estrellas">5</puntuacion>
 </pelicula>
</peliculas>
XML;
?>

La simplicidad de SimpleXML se ve claramente cuando se extrae un string o un número de un documento XMl básico.

Ejemplo #2 Obtener <argumento>

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

echo $peliculas->pelicula[0]->argumento;
?>

El resultado del ejemplo sería:

   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje de script? Lo descubrirás en esta intrigante y temible parodia
   de un documental.

El acceso a elementos dentro de un documento XML que contiene caracteres no permitidos por la convención de nombres de PHP (p.ej., el guión) puede realizarse encapsulando el nombre del elemento dentro de un par de llaves y comillas simples.

Ejemplo #3 Obtener <frase>

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

echo $peliculas->pelicula->{'grandes-frases'}->frase;
?>

El resultado del ejemplo sería:

PHP soluciona todos los problemas web

Ejemplo #4 Acceder a elementos no únicos en SimpleXML

Cuando existen múltiples instancias de un elemento como hijos de un único elemento padre, se aplican las técnicas normales de iteración.

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

/* Para cada <personaje>, se muestra cada <nombre>. */
foreach ($peliculas->pelicula->personajes->personaje as $personaje) {
   echo $personaje->nombre, ' interpretado por ', $personaje->actor, PHP_EOL;
}

?>

El resultado del ejemplo sería:

Srta. Programadora interpretado por Onlivia Actora
Sr. Programador interpretado por El ActÓr

Nota:

Las propiedades ($peliculas->pelicula en el ejemplo anterior) no son arrays. Son objetos iterables y accesibles.

Ejemplo #5 Utilizar atributos

Hasta aquí, únicamente se ha cubierto el trabajo de leer nombres de elementos y sus valores. SimpleXML puede también acceder a los atributos de los elementos. Para acceder a ellos, se realiza como si fuesen elementos de un array.

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

/* Acceder a los nodos <puntuacion> de la primera película.
 * Mostrar la escala de puntuación también. */
foreach ($peliculas->pelicula[0]->puntuacion as $puntuacion) {
    switch((string) $puntuacion['tipo']) { // Obtener los atributos como índices del elemento
    case 'votos':
        echo $puntuacion, ' votos positivos';
        break;
    case 'estrellas':
        echo $puntuacion, ' estrellas';
        break;
    }
}
?>

El resultado del ejemplo sería:

7 votos positivos5 estrellas

Ejemplo #6 Comparar elementos y atributos con texto

Para comparar un elemento o atributo con un string o pasarlo a una función que requiera un string, debe realizarse una conversión a string empleando (string). De lo contrario, PHP trata al elemento como un objeto.

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

if ((string) $peliculas->pelicula->titulo == 'PHP: Tras el Analilzador') {
    print 'Mi película favorita.';
}

echo htmlentities((string) $peliculas->pelicula->titulo);
?>

El resultado del ejemplo sería:

Mi película favorita.PHP: Tras el Analilzador

Ejemplo #7 Comparar dos elementos

Dos SimpleXMLElements son considerados distintos incluso cuando ambos apuntan al mismo elemento desde PHP 5.2.0.

<?php
include 'ejemplo.php';

$pelicula1 = new SimpleXMLElement($xmlstr);
$pelicula2 = new SimpleXMLElement($xmlstr);
var_dump($pelicula1 == $pelicula2); // falso desde PHP 5.2.0
?>

El resultado del ejemplo sería:

bool(false)

Ejemplo #8 Utilizar XPath

SimpleXML incorpora soporte para XPath. Para encontrar todos los elementos <personaje>:

<?php
include 'ejemplo.php';

$peliculas = new SimpleXMLElement($xmlstr);

foreach ($peliculas->xpath('//personaje') as $personaje) {
    echo $personaje->nombre . ' interpretado por ' . $personaje->actor, PHP_EOL;
}
?>

'//' actúa como un comodín. Para especificar una ruta absoluta, hay que omitir una de las dos barras.

El resultado del ejemplo sería:

Srta. Programadora interpretado por Onlivia Actora
Sr. Programador interpretado por El ActÓr

Ejemplo #9 Establecer valores

Los datos en SimpleXML no tienen que ser constantes. El objeto permite que se manipulen todos sus elementos.

<?php
include 'ejemplo.php';
$peliculas = new SimpleXMLElement($xmlstr);

$peliculas->pelicula[0]->personajes->personaje[0]->nombre = 'Srta. Programadora';

echo $peliculas->asXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0" standalone="yes"?>
<peliculas>
 <pelicula>
  <titulo>PHP: Tras el Analilzador</titulo>
  <personajes>
   <personaje>
    <nombre>Srta. Programadora</nombre>
    <actor>Onlivia Actora</actor>
   </personaje>
   <personaje>
    <nombre>Sr. Programador</nombre>
    <actor>El Act&#xD3;r</actor>
   </personaje>
  </personajes>
  <argumento>
   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje de script? Lo descubrirás en esta intrigante y temible parodia
   de un documental.
  </argumento>
  <grandes-frases>
   <frase>PHP soluciona todos los problemas web</frase>
  </grandes-frases>
  <puntuacion tipo="votos">7</puntuacion>
  <puntuacion tipo="estrellas">5</puntuacion>
 </pelicula>
</peliculas>
+

Ejemplo #10 Añadir elementos y atributos

Desde PHP 5.1.3, SimpleXML tiene la capacidad de añadir fácilmente hijos y atributos.

<?php
include 'ejemplo.php';
$peliculas = new SimpleXMLElement($xmlstr);

$personaje = $peliculas->pelicula[0]->personajes->addChild('personaje');
$personaje->addChild('nombre', 'Sr. Analizador');
$personaje->addChild('actor', 'John Doe');

$puntuacion = $peliculas->pelicula[0]->addChild('puntuacion', 'Todos los públicos');
$puntuacion->addAttribute('tipo', 'clasificacion');

echo $peliculas->asXML();
?>

El resultado del ejemplo sería:

<?xml version="1.0" standalone="yes"?>
<peliculas>
 <pelicula>
  <titulo>PHP: Tras el Analizador</titulo>
  <personajes>
   <personaje>
    <nombre>Srta. Programadora</nombre>
    <actor>Onlivia Actora</actor>
   </personaje>
   <personaje>
    <nombre>Sr. Programador</nombre>
    <actor>El Actor</actor>
   </personaje>
  <personaje><nombre>Sr. Analizador</nombre><actor>John Doe</actor></personaje></personajes>
  <argumento>
   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje de script? Lo descubrirás en esta intrigante y temible parodia
   de un documental.
  </argumento>
  <grandes-frases>
   <frase>PHP soluciona todos los problemas web</frase>
  </grandes-frases>
  <puntuacion tipo="votos">7</puntuacion>
  <puntuacion tipo="estrellas">5</puntuacion>
  <puntuacion tipo="clasificacion">Todos los públicos</puntuacion>
 </pelicula>
</peliculas>

Ejemplo #11 Interoperatibilidad con DOM

PHP tiene un mecanismo para convertir nodos XML entre los formatos SimpleXML y DOM. Este ejemplo muestra cómo cambiar un elemento DOM a SimpleXML.

<?php
$dom = new DOMDocument;
$dom->loadXML('<libros><libro><titulo>bla</titulo></libro></libros>');
if (!$dom) {
    echo 'Error al analizar el documento');
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->libro[0]->titulo;
?>

El resultado del ejemplo sería:

bla


Tratar con los errores XML

Tratar con los errores XML cuando se cargan documentos es una tarea muy sencilla. Utilizando la funcionalidad de libxml es posible suprimir todos los errores XML cuando se carga un documento para luego recorrerlos.

El objeto libXMLError, retornado por libxml_get_errors(), contiene varias propiedades, incluyendo el mensaje, línea y columna (posición) del error.

Ejemplo #1 Cargar un string XML erróneo

<?php
libxml_use_internal_errors(true);
$sxe = simplexml_load_string("<?xml version='1.0'><roto><xml></roto>");
if ($sxe === false) {
    echo "Error cargando XML\n";
    foreach(libxml_get_errors() as $error) {
        echo "\t", $error->message;
    }
}
?>

El resultado del ejemplo sería:

Error cargando XML
    Blank needed here
    parsing XML declaration: '?>' expected
    Opening and ending tag mismatch: xml line 1 and broken
    Premature end of data in tag broken line 1

Ver también

  • libxml_use_internal_errors()
  • libxml_get_errors()
  • libXMLError


Clase SimpleXMLElement

(PHP 5, PHP 7, PHP 8)

Introducción

Representa un elemento en un documento XML.

Sinopsis de la Clase

SimpleXMLElement {
/* Métodos */
final public __construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )
public addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void
public addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement
public asXML ( string $filename = ? ) : mixed
public attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement
public children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement
public count ( ) : int
public getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array
public getName ( ) : string
public getNamespaces ( bool $recursive = false ) : array
public registerXPathNamespace ( string $prefix , string $ns ) : bool
public __toString ( ) : string
public xpath ( string $path ) : array
}

Tabla de contenidos

  • SimpleXMLElement::addAttribute — Añade un atributo al elemento SimpleXML
  • SimpleXMLElement::addChild — Añade un elemento hijo al nodo XML
  • SimpleXMLElement::asXML — Retorna un string XML correcto basado en un elemento SimpleXML
  • SimpleXMLElement::attributes — Identifica el atributo de un elemento
  • SimpleXMLElement::children — Encuentra los hijos del nodo dado
  • SimpleXMLElement::__construct — Crea un nuevo objeto SimpleXMLElement
  • SimpleXMLElement::count — Cuenta los hijos de un elemento
  • SimpleXMLElement::getDocNamespaces — Devuelve los espacios de nombre declarados en el documento
  • SimpleXMLElement::getName — Retorna el nombre del elemento XML
  • SimpleXMLElement::getNamespaces — Devuelve los espacios de nombre usados en el documento
  • SimpleXMLElement::registerXPathNamespace — Crea un contexto prefijo/ns para la siguiente petición XPath
  • SimpleXMLElement::saveXML — Alias de SimpleXMLElement::asXML
  • SimpleXMLElement::__toString — Returns the string content
  • SimpleXMLElement::xpath — Ejecuta una petición XPath sobre los datos XML


Añade un atributo al elemento SimpleXML

  • « SimpleXMLElement
  • SimpleXMLElement::addChild »
  • PHP Manual
  • SimpleXMLElement
  • Añade un atributo al elemento SimpleXML

SimpleXMLElement::addAttribute

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::addAttribute — Añade un atributo al elemento SimpleXML

Descripción

public SimpleXMLElement::addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void

Añade un atributo al elemento SimpleXML.

Parámetros

name

El nombre del atributo a añadir.

value

El valor del atributo.

namespace

Si se especifica, indica el espacio de nombres al que pertenece el atributo.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Nota:

Los ejemplos enumerados podrían incluir example.php, que hace referencia al string XML encontrado en el primer ejemplo de la guía de uso básico.

Ejemplo #1 Añadir atributos e hijos a un elemento SimpleXML

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('tipo', 'documental');

$pelicula = $sxe->addChild('pelicula');
$pelicula->addChild('titulo', 'PHP2: Más historias del Parser');
$pelicula->addChild('argumento', 'Todo sobre la gente que lo hace funcionar.');

$personajes = $pelicula->addChild('personajes');
$personaje  = $personajes->addChild('personaje');
$personaje->addChild('nombre', 'Sr. Parser');
$personaje->addChild('actor', 'John Doe');

$puntuacion = $pelicula->addChild('puntuacion', '5');
$puntuacion->addAttribute('tipo', 'estrellas');

echo $sxe->asXML();

?>

El resultado del ejemplo sería algo similar a:

<?xml version="1.0" standalone="yes"?>
<peliculas tipo="documental">
 <pelicula>
  <titulo>PHP: Tras el Parser</titulo>
  <personajes>
   <personaje>
    <nombre>Srta. Programadora</nombre>
    <actor>Onlivia Actora</actor>
   </personaje>
   <personaje>
    <nombre>Sr. Programador</nombre>
    <actor>El Actor</actor>
   </personaje>
  </personajes>
  <argumento>
   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje interpretado? Lo descubrirás en esta intrigante y temible parodia
   de un documental.
  </argumento>
  <grandes-lineas>
   <linea>PHP soluciona todos los problemas web</linea>
  </grandes-lineas>
  <puntuacion tipo="pulgares">7</puntuacion>
  <puntuacion tipo="estrellas">5</puntuacion>
 </pelicula>
 <pelicula>
  <titulo>PHP2: Más historias del Parser</titulo>
  <argumento>Todo sobre la gente que lo hace funcionar.</argumento>
  <personajes>
   <personaje>
    <nombre>Sr. Parser</nombre>
    <actor>John Doe</actor>
   </personaje>
  </personajes>
  <puntuacion tipo="estrellas">5</puntuacion>
 </pelicula>
</peliculas>

Ver también

  • SimpleXMLElement::addChild() - Añade un elemento hijo al nodo XML
  • Uso básico de SimpleXML


Añade un elemento hijo al nodo XML

  • « SimpleXMLElement::addAttribute
  • SimpleXMLElement::asXML »
  • PHP Manual
  • SimpleXMLElement
  • Añade un elemento hijo al nodo XML

SimpleXMLElement::addChild

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::addChild — Añade un elemento hijo al nodo XML

Descripción

public SimpleXMLElement::addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement

Añade un elemento hijo al nodo y retorna un SimpleXMLElement del hijo.

Parámetros

name

Nombre del elemento hijo a añadir.

value

Si se especifica, valor del elemento hijo.

namespace

Si se especifica, el namespace al que pertenece el elemento hijo.

Valores devueltos

El método addChild retorna un objeto SimpleXMLElement representando el hijo añadido al nodo XML.

Ejemplos

Nota:

Los ejemplos listados quizá incluyen example.php, que hacen referencia a la cadena XML encontrada en el primer ejemplo de la guía de uso básico.

Ejemplo #1 Añade atributos e hijos a un elemento SimpleXML

<?php
include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('tipo', 'documental');

$pelicula = $sxe->addChild('pelicula');
$pelicula->addChild('titulo', 'PHP2: Más historias sobre Parser');
$pelicula->addChild('argumento', 'Todo sobre las personas que hacen que funcione.');

$personajes = $pelicula->addChild('personajes');
$personaje  = $personajes->addChild('personaje');
$personaje->addChild('nombre', 'Sr. Parser');
$personaje->addChild('actor', 'John Doe');

$puntuacion = $pelicula->addChild('puntuacion', '5');
$puntuacion->addAttribute('tipo', 'estrellas');

echo $sxe->asXML();

?>

El resultado del ejemplo sería algo similar a:

<?xml version="1.0" standalone="yes"?>
<peliculas tipo="documental">
 <pelicula>
  <titulo>PHP: Tras el Parser</titulo>
  <personajes>
   <personaje>
    <nombre>Srta. Programadora</nombre>
    <actor>Onlivia Actora</actor>
   </personaje>
   <personaje>
    <nombre>Sr. Programador</nombre>
    <actor>El Actor</actor>
   </personaje>
  </personajes>
  <argumento>
   Así que, este lenguaje. Es como, un lenguaje de programación. ¿O es un
   lenguaje interpretado? Lo descubrirás en esta intrigante y temible parodia
   de un documental.
  </argumento>
  <grandes-lineas>
   <linea>PHP soluciona todos los problemas web</linea>
  </grandes-lineas>
  <puntuacion tipo="pulgares">7</puntuacion>
  <puntuacion tipo="estrellas">5</puntuacion>
 </pelicula>
 <pelicula>
  <titulo>PHP2: Más historias del Parser</titulo>
  <argumento>Todo sobre la gente que lo hace funcionar.</argumento>
  <personajes>
   <personaje>
    <nombre>Sr. Parser</nombre>
    <actor>John Doe</actor>
   </personaje>
  </personajes>
  <puntuacion type="estrellas">5</puntuacion>
 </pelicula>
</peliculas>

Ver también

  • SimpleXMLElement::addAttribute() - Añade un atributo al elemento SimpleXML
  • Uso básico de SimpleXML


Retorna un string XML correcto basado en un elemento SimpleXML

  • « SimpleXMLElement::addChild
  • SimpleXMLElement::attributes »
  • PHP Manual
  • SimpleXMLElement
  • Retorna un string XML correcto basado en un elemento SimpleXML

SimpleXMLElement::asXML

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::asXML — Retorna un string XML correcto basado en un elemento SimpleXML

Descripción

public SimpleXMLElement::asXML ( string $filename = ? ) : mixed

El método asXML formatea los datos del objeto padre en XML versión 1.0.

Parámetros

filename

Si se especifica, la función escribe los datos al fichero en vez de retornarlo.

Valores devueltos

Si no se especifica filename, esta función retorna un string si no hay errores y false si lo hay. Si se especifica el parámetro, retorna true si el fichero se escribió correctamente y false en caso contrario.

Ejemplos

Ejemplo #1 Retornar XML

<?php
$string = <<<XML
<a>
 <b>
  <c>texto</c>
  <c>cosas</c>
 </b>
 <d>
  <c>codigo</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

echo $xml->asXML();

?>

El resultado del ejemplo sería:

<?xml version="1.0"?>
<a>
 <b>
  <c>texto</c>
  <c>cosas</c>
 </b>
 <d>
  <c>codigo</c>
 </d>
</a>

asXML también trabaja con resultados Xpath:

Ejemplo #2 Usando asXML() en resultados SimpleXMLElement::xpath()

<?php
// Continuación del ejemplo XML anterior.

/* Buscar <a><b><c> */
$resultado = $xml->xpath('/a/b/c');

foreach ($result as $node) {
    echo $node->asXML();
}
?>

El resultado del ejemplo sería:

<c>texto</c><c>cosas</c>

Ver también

  • SimpleXMLElement::__toString() - Returns the string content
  • Uso básico de SimpleXML


Identifica el atributo de un elemento

  • « SimpleXMLElement::asXML
  • SimpleXMLElement::children »
  • PHP Manual
  • SimpleXMLElement
  • Identifica el atributo de un elemento

SimpleXMLElement::attributes

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::attributes — Identifica el atributo de un elemento

Descripción

public SimpleXMLElement::attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement

Esta función provee de los atributos y valores definidos dentro de una etiqueta XML.

Nota: SimpleXML ha desarrollado una regla para el añadido de propiedades iterativas a la mayoría de métodos. No pueden ser examinados usando var_dump() ni con cualquier otra función que examine objetos.

Parámetros

ns

Un namespace opcional para los atributos recuperados

is_prefix

Por defecto false

Valores devueltos

Devuelve un objeto SimpleXMLElement que puede ser iterado a través de los atributos en la etiqueta.

Devuelve null si se invoca sobre un objeto SimpleXMLElement que ya representa un atributo y no una etiqueta.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro opcional is_prefix.

Ejemplos

Ejemplo #1 Interpreta un string XML

<?php
$string = <<<XML
<a>
 <prueba nombre="uno" juego="solitario">1</prueba>
</a>
XML;

$xml = simplexml_load_string($string);
foreach($xml->prueba[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

El resultado del ejemplo sería:

nombre="uno"
juego="solitario"

Ver también

  • Uso básico de SimpleXML


Encuentra los hijos del nodo dado

  • « SimpleXMLElement::attributes
  • SimpleXMLElement::__construct »
  • PHP Manual
  • SimpleXMLElement
  • Encuentra los hijos del nodo dado

SimpleXMLElement::children

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::children — Encuentra los hijos del nodo dado

Descripción

public SimpleXMLElement::children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement

Este método encuentra el hijo de un elemento. El resultado cumple las reglas normales de iteración.

Nota: SimpleXML ha desarrollado una regla para el añadido de propiedades iterativas a la mayoría de métodos. No pueden ser examinados usando var_dump() ni con cualquier otra función que examine objetos.

Parámetros

ns

Un nombre de espacio XML.

is_prefix

Si is_prefix es true, ns será considerado como un prefijo. Si es false ns será considerado como un espacio de nombres URL.

Valores devueltos

Devuelve un elemento SimpleXMLElement, tanto si el nodo tiene hijos o no.

Historial de cambios

Versión | Descripción
5.2.0 | Se añade el parámetro opcional is_prefix.

Ejemplos

Ejemplo #1 Recorre el pseudo-array children()

<?php
$xml = new SimpleXMLElement(
'<persona>
 <hijo rol="hijo">
  <hijo rol="hija"/>
 </hijo>
 <hijo rol="hija">
  <hijo rol="hijo">
   <hijo rol="hijo"/>
  </hijo>
 </hijo>
</persona>');

foreach ($xml->children() as $segunda_gen) {
    echo 'La persona engendra un/a ' . $segunda_gen['role'];

    foreach ($second_gen->children() as $tercera_gen) {
        echo ' quien engendra un/a ' . $tercera_gen['role'] . ';';

        foreach ($tercera_gen->children() as $cuarta_gen) {
            echo ' y ese/a ' . $tercera_gen['role'] .
                ' engendra un/a ' . $cuarta_gen['role'];
        }
    }
}
?>

El resultado del ejemplo sería:

La persona engendra un/a hijo quien engendra un/a hija; La persona engendra
un/a hija quien engendra a un/a hijo; y ese/a hijo engendra un/a hijo

Ejemplo #2 Usando espacio de nombres

<?php
$xml = '<example xmlns:foo="my.foo.urn">
  <foo:a>Apple</foo:a>
  <foo:b>Banana</foo:b>
  <c>Cherry</c>
</example>';

$sxe = new SimpleXMLElement($xml);

$kids = $sxe->children('foo');
var_dump(count($kids));

$kids = $sxe->children('foo', TRUE);
var_dump(count($kids));

$kids = $sxe->children('my.foo.urn');
var_dump(count($kids));

$kids = $sxe->children('my.foo.urn', TRUE);
var_dump(count($kids));

$kids = $sxe->children();
var_dump(count($kids));
?>
int(0)
int(2)
int(2)
int(0)
int(1)

Notas

SimpleXMLElement::children() devuleve un nodo de objeto no impotando si el nodo actuali tiene un hijo o no. Use SimpleXMLElement::count() en el valor retornado para comprobar si hay algún hijo. Como en PHP 5.3.0, SimpleXMLElement::count() puede usarse en su lugar.

Ver también

  • SimpleXMLElement::count() - Cuenta los hijos de un elemento
  • count() - Cuenta todos los elementos de un array o algo de un objeto


Crea un nuevo objeto SimpleXMLElement

  • « SimpleXMLElement::children
  • SimpleXMLElement::count »
  • PHP Manual
  • SimpleXMLElement
  • Crea un nuevo objeto SimpleXMLElement

SimpleXMLElement::__construct

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::__construct — Crea un nuevo objeto SimpleXMLElement

Descripción

final public SimpleXMLElement::__construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )

Crea un nuevo objeto SimpleXMLElement.

Parámetros

data

Un string XML correcto o la ruta o URL a un documento XML si data_is_url es true.

options

Se utiliza opcionalmente para especificar parámetros adicionales de Libxml, que afectan a la lectura de los documentos XML. Las opciones que afectan a la salida de los documentos XML (p.e. LIBXML_NOEMPTYTAG) son silenciosamente ignoradas.

Nota:

Puede ser necesario pasar LIBXML_PARSEHUGE para poder procesar XML profundamente anidados o nodos de texto muy grandes.

data_is_url

Por defecto, data_is_url es false. Usar true para precisar que data es una ruta o URL a un documento XML en vez de un string de datos.

ns

Prefijo de espacio de nombres o URI.

is_prefix

true si ns es un prefijo, false si es una URI; por omisión, false.

Valores devueltos

Retorna un objeto SimpleXMLElement representando data.

Errores/Excepciones

Produce un mensaje de error E_WARNING por cada error encontrado en los datos XML y adicionalmente lanza una Exception si no se han podido analizar correctamente los datos XML.

Sugerencia

Debe usarse libxml_use_internal_errors() para eliminar todos los errores XML y libxml_get_errors() para iterar sobre ellos después.

Historial de cambios

Versión | Descripción
5.2.0 | Añadidos los parámetros ns y is_prefix.
5.1.2 | Añadidos los parámetros options y data_is_url.

Ejemplos

Nota:

Los ejemplos listados quizá incluyen example.php, que hacen referencia a la cadena XML encontrada en el primer ejemplo de la guía de uso básico.

Ejemplo #1 Crea un objeto SimpleXMLElement

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
echo $sxe->pelicula[0]->titulo;

?>

El resultado del ejemplo sería:

PHP: Tras el Parser

Ejemplo #2 Crea un objeto SimpleXMLElement a partir de una URL

<?php

$sxe = new SimpleXMLElement('http://example.org/document.xml', NULL, TRUE);
echo $sxe->asXML();

?>

Ver también

  • Uso básico de SimpleXML
  • simplexml_load_string() - Interpreta un string de XML en un objeto
  • simplexml_load_file() - Interpreta un fichero XML en un objeto
  • Tratar con los errores XML
  • libxml_use_internal_errors() - Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario


Cuenta los hijos de un elemento

  • « SimpleXMLElement::__construct
  • SimpleXMLElement::getDocNamespaces »
  • PHP Manual
  • SimpleXMLElement
  • Cuenta los hijos de un elemento

SimpleXMLElement::count

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SimpleXMLElement::count — Cuenta los hijos de un elemento

Descripción

public SimpleXMLElement::count ( ) : int

Este método cuenta el número de hijos de un elemento.

Valores devueltos

Devuelve el número de elementos de un elemento.

Ejemplos

Ejemplo #1 Cuenta el número de hijos

<?php
$xml = <<<EOF
<people>
 <person name="Persona 1">
  <child/>
  <child/>
  <child/>
 </person>
 <person name="Persona 2">
  <child/>
  <child/>
  <child/>
  <child/>
  <child/>
 </person>
</people>
EOF;

$elem = new SimpleXMLElement($xml);

foreach ($elem as $person) {
    printf("%s tiene %d hijos.\n", $person['name'], $person->count());
}
?>

El resultado del ejemplo sería:

Persona 1 tiene 3 hijos.
Persona 2 tiene 5 hijos.

Ver también

  • SimpleXMLElement::children() - Encuentra los hijos del nodo dado


Devuelve los espacios de nombre declarados en el documento

  • « SimpleXMLElement::count
  • SimpleXMLElement::getName »
  • PHP Manual
  • SimpleXMLElement
  • Devuelve los espacios de nombre declarados en el documento

SimpleXMLElement::getDocNamespaces

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

SimpleXMLElement::getDocNamespaces — Devuelve los espacios de nombre declarados en el documento

Descripción

public SimpleXMLElement::getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array

Devuelve los espacios de nombres declarados en el documento

Parámetros

recursive

Si se especifica, devuelve todos los espacios de nombre declarados en los nodos padre e hijos. De lo contrario, devuelve únicamente el espacio de nombre declarado en el nodo raíz.

from_root

Permite comprobar recursivamente espacios de nombre bajo un nodo hijo en lugar de desde la raíz del documento XML.

Valores devueltos

El método getDocNamespaces devuelve un array de nombres de espacios de nombre con sus URIs asociadas.

Ejemplos

Ejemplo #1 Obtener los espacios de nombres del documento

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<gente xmlns:p="http://example.org/ns">
    <p:persona id="1">John Doe</p:persona>
    <p:persona id="2">Susie Q. Public</p:persona>
</gente>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces();
var_dump($namespaces);

?>

El resultado del ejemplo sería:

array(1) {
   ["p"]=>
   string(21) "http://example.org/ns"
}

Ejemplo #2 Trabajando con múltiples espacios de nombre

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<gente xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:persona t:id="1">John Doe</p:persona>
    <p:persona t:id="2" a:direccion="Calle 123" xmlns:a="http://example.org/addr">
        Susie Q. Public
    </p:person>
</gente>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces(TRUE);
var_dump($namespaces);

?>

El resultado del ejemplo sería:

array(3) {
  ["p"]=>
  string(21) "http://example.org/ns"
  ["t"]=>
  string(23) "http://example.org/test"
  ["a"]=>
  string(23) "http://example.org/addr"
}

Historial de cambios

Versión | Descripción
5.4.0 | Se añadió el parámetro from_root.

Ver también

  • SimpleXMLElement::getNamespaces() - Devuelve los espacios de nombre usados en el documento
  • SimpleXMLElement::registerXPathNamespace() - Crea un contexto prefijo/ns para la siguiente petición XPath


Retorna el nombre del elemento XML

  • « SimpleXMLElement::getDocNamespaces
  • SimpleXMLElement::getNamespaces »
  • PHP Manual
  • SimpleXMLElement
  • Retorna el nombre del elemento XML

SimpleXMLElement::getName

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::getName — Retorna el nombre del elemento XML

Descripción

public SimpleXMLElement::getName ( ) : string

Retorna el nombre del elemento XML.

Valores devueltos

El método getName retorna como string el nombre de la etiqueta XML referenciada por el objeto SimpleXMLElement.

Ejemplos

Nota:

Los ejemplos listados quizá incluyen example.php, que hacen referencia a la cadena XML encontrada en el primer ejemplo de la guía de uso básico.

Ejemplo #1 Retornar el nombre del elemento XML

<?php

include 'example.php';
$sxe = new SimpleXMLElement($xmlstr);

echo $sxe->getName() . "\n";

foreach ($sxe->children() as $hijo)
{
    echo $hijo->getName() . "\n";
}

?>

El resultado del ejemplo sería:

peliculas
pelicula


Devuelve los espacios de nombre usados en el documento

  • « SimpleXMLElement::getName
  • SimpleXMLElement::registerXPathNamespace »
  • PHP Manual
  • SimpleXMLElement
  • Devuelve los espacios de nombre usados en el documento

SimpleXMLElement::getNamespaces

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

SimpleXMLElement::getNamespaces — Devuelve los espacios de nombre usados en el documento

Descripción

public SimpleXMLElement::getNamespaces ( bool $recursive = false ) : array

Devuelve los espacios de nombre usados en el documento

Parámetros

recursive

Si se especifica, devuelve todos los espacios de nombre usados en los nodos padre e hijos. De lo contrario, devuelve sólo los espacios de nombre usados en el nodo raíz.

Valores devueltos

El método getNamespaces devuelve un array de nombres de espacios de nombre con sus URIs asociadas.

Ejemplos

Ejemplo #1 Obtener el nombre de espacio del documento en uso

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<gente xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:persona id="1">John Doe</p:persona>
    <p:persona id="2">Susie Q. Public</p:persona>
</gente>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getNamespaces(true);
var_dump($namespaces);

?>

El resultado del ejemplo sería:

array(1) {
  ["p"]=>
  string(21) "http://example.org/ns"
}

Ver también

  • SimpleXMLElement::getDocNamespaces() - Devuelve los espacios de nombre declarados en el documento
  • SimpleXMLElement::registerXPathNamespace() - Crea un contexto prefijo/ns para la siguiente petición XPath


Crea un contexto prefijo/ns para la siguiente petición XPath

  • « SimpleXMLElement::getNamespaces
  • SimpleXMLElement::saveXML »
  • PHP Manual
  • SimpleXMLElement
  • Crea un contexto prefijo/ns para la siguiente petición XPath

SimpleXMLElement::registerXPathNamespace

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

SimpleXMLElement::registerXPathNamespace — Crea un contexto prefijo/ns para la siguiente petición XPath

Descripción

public SimpleXMLElement::registerXPathNamespace ( string $prefix , string $ns ) : bool

Crea un contexto de prefijo/ns para la siguiente petición XPath. En particular, ésto es útil si el proveedor del documento XML proporcionado altera los prefijos del namespace. registerXPathNamespace creará un prefijo para el namespace asociado, permitiendo el acceso a los nodos en ese namespace sin necesidad de cambiar el código para tener en cuenta los nuevos prefijos dictados por el proveedor.

Parámetros

prefix

El prefijo del namespace a usar en la petición XPath para el namespace dado en ns.

ns

El namespace a usar para la petición XPath. Debe coincidir con un namespace en uso por el documento XML o la petición XPath usando prefix no retornará ningún resultado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Estableciendo un prefijo para el namespace a usar en una petición XPath

<?php

$xml = <<<EOD
<book xmlns:chap="http://example.org/titulo-capitulo">
    <title>My Book</title>
    <chapter id="1">
        <chap:titulo>Chapter 1</chap:titulo>
        <para>Donec velit. Nullam eget tellus vitae tortor gravida scelerisque.
            In orci lorem, cursus imperdiet, ultricies non, hendrerit et, orci.
            Nulla facilisi. Nullam velit nisl, laoreet id, condimentum ut,
            ultricies id, mauris.</para>
    </chapter>
    <chapter id="2">
        <chap:titulo>Chapter 2</chap:titulo>
        <para>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin
            gravida. Phasellus tincidunt massa vel urna. Proin adipiscing quam
            vitae odio. Sed dictum. Ut tincidunt lorem ac lorem. Duis eros
            tellus, pharetra id, faucibus eu, dapibus dictum, odio.</para>
    </chapter>
</book>
EOD;

$sxe = new SimpleXMLElement($xml);

$sxe->registerXPathNamespace('c', 'http://example.org/titulo-capitulo');
$resultado = $sxe->xpath('//c:titulo');

foreach ($resultado as $titulo) {
  echo $titulo . "\n";
}

?>

El resultado del ejemplo sería:

Chapter 1
Chapter 2

Notar como el documento XML mostrado en el ejemplo establece un namespace con un prefijo de chap. En el caso de que este documento (u otro como este) hubiera usado un prefijo de c, como este ha cambiado, la petición XPath no retornará los resultados adecuados y la petición requerirá modificación. Usando registerXPathNamespace evita futuras modificaciones de la petición incluso si el proveedor cambia el prefijo del namespace.

Ver también

  • SimpleXMLElement::xpath() - Ejecuta una petición XPath sobre los datos XML
  • SimpleXMLElement::getDocNamespaces() - Devuelve los espacios de nombre declarados en el documento
  • SimpleXMLElement::getNamespaces() - Devuelve los espacios de nombre usados en el documento


Alias de SimpleXMLElement::asXML

  • « SimpleXMLElement::registerXPathNamespace
  • SimpleXMLElement::__toString »
  • PHP Manual
  • SimpleXMLElement
  • Alias de SimpleXMLElement::asXML

SimpleXMLElement::saveXML

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

SimpleXMLElement::saveXML — Alias de SimpleXMLElement::asXML()

Descripción

Este método es un alias de: SimpleXMLElement::asXML()


Returns the string content

  • « SimpleXMLElement::saveXML
  • SimpleXMLElement::xpath »
  • PHP Manual
  • SimpleXMLElement
  • Returns the string content

SimpleXMLElement::__toString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SimpleXMLElement::__toString — Returns the string content

Descripción

public SimpleXMLElement::__toString ( ) : string

Returns text content that is directly in this element. Does not return text content that is inside this element's children.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the string content on success or an empty string on failure.

Ejemplos

Ejemplo #1 Get string content

<?php
$xml = new SimpleXMLElement('<a>1 <b>2 </b>3</a>');
echo $xml;
?>

El resultado del ejemplo sería:

1 3

Ver también

  • SimpleXMLElement::asXML() - Retorna un string XML correcto basado en un elemento SimpleXML


Ejecuta una petición XPath sobre los datos XML

  • « SimpleXMLElement::__toString
  • SimpleXMLIterator »
  • PHP Manual
  • SimpleXMLElement
  • Ejecuta una petición XPath sobre los datos XML

SimpleXMLElement::xpath

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::xpath — Ejecuta una petición XPath sobre los datos XML

Descripción

public SimpleXMLElement::xpath ( string $path ) : array

El método xpath busca el nodo SimpleXML para los hijos que cumplan la path XPath.

Parámetros

path

Una ruta XPath

Valores devueltos

Retorna un array de objetos SimpleXMLElement o false en caso de error.

Ejemplos

Ejemplo #1 Xpath

<?php
$string = <<<XML
<a>
 <b>
  <c>texto</c>
  <c>cosas</c>
 </b>
 <d>
  <c>código</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

/* Busca <a><b><c> */
$resultado = $xml->xpath('/a/b/c');

while(list( , $nodo) = each($resultado)) {
    echo '/a/b/c: ',$nodo,"\n";
}

/* Rutas relativas también funcionan... */
$resultado = $xml->xpath('b/c');

while(list( , $nodo) = each($resultado)) {
    echo 'b/c: ',$nodo,"\n";
}
?>

El resultado del ejemplo sería:

/a/b/c: texto
/a/b/c: cosas
b/c: texto
b/c: cosas

Notar que los dos resultados son iguales.

Ver también

  • SimpleXMLElement::registerXPathNamespace() - Crea un contexto prefijo/ns para la siguiente petición XPath
  • SimpleXMLElement::getDocNamespaces() - Devuelve los espacios de nombre declarados en el documento
  • SimpleXMLElement::getNamespaces() - Devuelve los espacios de nombre usados en el documento
  • Uso básico de SimpleXML


La clase SimpleXMLIterator

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

Introducción

El clase SimpleXMLIterator proporciona una iteración recursiva sobre todos los nodos de un objeto SimpleXMLElement.

Sinopsis de la Clase

SimpleXMLIterator extends SimpleXMLElement implements RecursiveIterator , Countable {
/* Métodos */
public current ( ) : mixed
public getChildren ( ) : SimpleXMLIterator
public hasChildren ( ) : bool
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* Métodos heredados */
final public SimpleXMLElement::__construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )
public SimpleXMLElement::addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void
public SimpleXMLElement::addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement
public SimpleXMLElement::asXML ( string $filename = ? ) : mixed
public SimpleXMLElement::attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement
public SimpleXMLElement::children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement
public SimpleXMLElement::count ( ) : int
public SimpleXMLElement::getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array
public SimpleXMLElement::getName ( ) : string
public SimpleXMLElement::getNamespaces ( bool $recursive = false ) : array
public SimpleXMLElement::registerXPathNamespace ( string $prefix , string $ns ) : bool
public SimpleXMLElement::__toString ( ) : string
public SimpleXMLElement::xpath ( string $path ) : array
}

Tabla de contenidos

  • SimpleXMLIterator::current — Devuelve el elemento actual
  • SimpleXMLIterator::getChildren — Devuelve los sub elementos de el elemento actual
  • SimpleXMLIterator::hasChildren — Comprueba si el elemento actual tiene sub elementos
  • SimpleXMLIterator::key — Devuelve la clave actual
  • SimpleXMLIterator::next — Mueve al siguiente elemento
  • SimpleXMLIterator::rewind — Rebobina hasta el primer elemento
  • SimpleXMLIterator::valid — Comprueba si el elemento actual es válido


Devuelve el elemento actual

  • « SimpleXMLIterator
  • SimpleXMLIterator::getChildren »
  • PHP Manual
  • SimpleXMLIterator
  • Devuelve el elemento actual

SimpleXMLIterator::current

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::current — Devuelve el elemento actual

Descripción

public SimpleXMLIterator::current ( ) : mixed

Este método devuelve el elemento actual como un objeto SimpleXMLIterator o null.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el elemento actual como un objeto SimpleXMLIterator o null en caso de error.

Ejemplos

Ejemplo #1 Devuelve el elemento actual

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP básico</book><book>XML básico</book></books>');
var_dump($xmlIterator->current());

$xmlIterator->rewind(); // reiniciar al primer elemento
var_dump($xmlIterator->current());
?>

El resultado del ejemplo sería:

NULL
object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "PHP básico"
}

Ver también

  • SimpleXMLIterator::key() - Devuelve la clave actual
  • SimpleXMLIterator::next() - Mueve al siguiente elemento
  • SimpleXMLIterator::rewind() - Rebobina hasta el primer elemento
  • SimpleXMLIterator::valid() - Comprueba si el elemento actual es válido
  • SimpleXMLElement


Devuelve los sub elementos de el elemento actual

  • « SimpleXMLIterator::current
  • SimpleXMLIterator::hasChildren »
  • PHP Manual
  • SimpleXMLIterator
  • Devuelve los sub elementos de el elemento actual

SimpleXMLIterator::getChildren

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::getChildren — Devuelve los sub elementos de el elemento actual

Descripción

public SimpleXMLIterator::getChildren ( ) : SimpleXMLIterator

Este método devuelve un objeto SimpleXMLIterator que contiene sub elementos de el elemento SimpleXMLIterator actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve un objeto SimpleXMLIterator que contiene los sub elementos de el elemento actual.

Ejemplos

Ejemplo #1 Devuelve los sub elementos de el elemento actual

<?php
$xml = <<<XML
<books>
    <book>
        <title>PHP Básico</title>
        <author>Jim Smith</author>
    </book>
    <book>XML básico</book>
</books>
XML;

$xmlIterator = new SimpleXMLIterator($xml);
for( $xmlIterator->rewind(); $xmlIterator->valid(); $xmlIterator->next() ) {
    foreach($xmlIterator->getChildren() as $name => $data) {
    echo "El $name es '$data' de la clase " . get_class($data) . "\n";
    }
}
?>

El resultado del ejemplo sería:

El título es 'PHP Básico' de la clase SimpleXMLIterator
El autor es 'Jim Smith' de la clase SimpleXMLIterator


Comprueba si el elemento actual tiene sub elementos

  • « SimpleXMLIterator::getChildren
  • SimpleXMLIterator::key »
  • PHP Manual
  • SimpleXMLIterator
  • Comprueba si el elemento actual tiene sub elementos

SimpleXMLIterator::hasChildren

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::hasChildren — Comprueba si el elemento actual tiene sub elementos

Descripción

public SimpleXMLIterator::hasChildren ( ) : bool

Este método comprueba si el elemento SimpleXMLIterator actual tiene sub elementos.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

true si el elemento actual tiene sub elementos, en caso contrario false

Ejemplos

Ejemplo #1 Comprobar si el elemento actual tiene sub elementos

<?php
$xml = <<<XML
<books>
    <book>
        <title>PHP Básico</title>
        <author>Jim Smith</author>
    </book>
    <book>XML básico</book>
</books>
XML;

$xmlIterator = new SimpleXMLIterator( $xml );
for( $xmlIterator->rewind(); $xmlIterator->valid(); $xmlIterator->next() ) {
    if($xmlIterator->hasChildren()) {
        var_dump($xmlIterator->current());
    }
}
?>

El resultado del ejemplo sería:

object(SimpleXMLIterator)#2 (2) {
  ["title"]=>
  string(10) "PHP Básico"
  ["author"]=>
  string(9) "Jim Smith"
}


Devuelve la clave actual

  • « SimpleXMLIterator::hasChildren
  • SimpleXMLIterator::next »
  • PHP Manual
  • SimpleXMLIterator
  • Devuelve la clave actual

SimpleXMLIterator::key

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::key — Devuelve la clave actual

Descripción

public SimpleXMLIterator::key ( ) : mixed

Este método obtiene el nombre de la etiqueta XML del elemento actual.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre de la etiqueta XML del elemento referenciado por el objeto SimpleXMLIterator actual o false

Ejemplos

Ejemplo #1 Obtener la clave actual de etiquetas XML

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP básico</book><book>XML básico</book></books>');

echo var_dump($xmlIterator->key());
$xmlIterator->rewind(); // rebobinar hasta el primer elemento
echo var_dump($xmlIterator->key());

?>

El resultado del ejemplo sería:

bool(false)
string(4) "book"


Mueve al siguiente elemento

  • « SimpleXMLIterator::key
  • SimpleXMLIterator::rewind »
  • PHP Manual
  • SimpleXMLIterator
  • Mueve al siguiente elemento

SimpleXMLIterator::next

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::next — Mueve al siguiente elemento

Descripción

public SimpleXMLIterator::next ( ) : void

Este método mueve el SimpleXMLIterator a el siguiente elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Mover a el siguiente elemento

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP Básico</book><book>XML básico</book></books>');
$xmlIterator->rewind(); // rebobinar hasta el primer elemento
$xmlIterator->next();

var_dump($xmlIterator->current());
?>

El resultado del ejemplo sería:

object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "XML básico"
}


Rebobina hasta el primer elemento

  • « SimpleXMLIterator::next
  • SimpleXMLIterator::valid »
  • PHP Manual
  • SimpleXMLIterator
  • Rebobina hasta el primer elemento

SimpleXMLIterator::rewind

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::rewind — Rebobina hasta el primer elemento

Descripción

public SimpleXMLIterator::rewind ( ) : void

Este método rebobina el SimpleXMLIterator a el primer elemento.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Rebobinar hasta el primer elemento

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP Básico</book><book>XML Básico</book></books>');
$xmlIterator->rewind();

var_dump($xmlIterator->current());
?>

El resultado del ejemplo sería:

object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "PHP Básico"
}


Comprueba si el elemento actual es válido

  • « SimpleXMLIterator::rewind
  • Funciones de SimpleXML »
  • PHP Manual
  • SimpleXMLIterator
  • Comprueba si el elemento actual es válido

SimpleXMLIterator::valid

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::valid — Comprueba si el elemento actual es válido

Descripción

public SimpleXMLIterator::valid ( ) : bool

Este mñetodo comprueba si el elemento actual es válido después de llamar a SimpleXMLIterator::rewind() o SimpleXMLIterator::next().

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve true si el elemento actual es válido, en caso contrario false

Ejemplos

Ejemplo #1 Comprobar si el elemento actual es válido

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>SQL Básico</book></books>');

$xmlIterator->rewind(); // rebobinar hasta el primer elemento
echo var_dump($xmlIterator->valid()); // bool(true)

$xmlIterator->next(); // avanzar al siguiente elemento
echo var_dump($xmlIterator->valid()); // bool(false) porque sólo hay un elemento
?>


Funciones de SimpleXML

Tabla de contenidos

  • simplexml_import_dom — Obtiene un objeto SimpleXMLElement de un nodo DOM
  • simplexml_load_file — Interpreta un fichero XML en un objeto
  • simplexml_load_string — Interpreta un string de XML en un objeto


Obtiene un objeto SimpleXMLElement de un nodo DOM

  • « Funciones de SimpleXML
  • simplexml_load_file »
  • PHP Manual
  • Funciones de SimpleXML
  • Obtiene un objeto SimpleXMLElement de un nodo DOM

simplexml_import_dom

(PHP 5, PHP 7, PHP 8)

simplexml_import_dom — Obtiene un objeto SimpleXMLElement de un nodo DOM

Descripción

simplexml_import_dom ( DOMNode $node , string $class_name = "SimpleXMLElement" ) : SimpleXMLElement

Esta función toma un nodo de un documento DOM y lo convierte en un nodo SimpleXML. Este nuevo objeto puede ser usado como un elemento SimpleXML nativo.

Parámetros

node

Un nodo del elemento DOM

class_name

Este parámetro opcional debe usarse cuando se necesite que simplexml_import_dom() retorne un objeto de la clase indicada. Esa clase debe extender de la clase SimpleXMLElement.

Valores devueltos

Devuelve un SimpleXMLElement o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Ejemplos

Ejemplo #1 Importando desde DOM

<?php
$dom = new DOMDocument;
$dom->loadXML('<libros><libro><titulo>blah</titulo></libro></libros>');
if (!$dom) {
    echo 'Error analizando el documento';
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->libro[0]->titulo;
?>

El resultado del ejemplo sería:

blah

Ver también

  • dom_import_simplexml() - Obtiene un objeto DOMElement desde un objeto SimpleXMLElement
  • Uso básico de SimpleXML


Interpreta un fichero XML en un objeto

  • « simplexml_import_dom
  • simplexml_load_string »
  • PHP Manual
  • Funciones de SimpleXML
  • Interpreta un fichero XML en un objeto

simplexml_load_file

(PHP 5, PHP 7, PHP 8)

simplexml_load_file — Interpreta un fichero XML en un objeto

Descripción

simplexml_load_file ( string $filename , string $class_name = "SimpleXMLElement" , int $options = 0 , string $ns = "" , bool $is_prefix = false ) : SimpleXMLElement

Convierte el documento correcto XML del fichero dado en un objeto.

Parámetros

filename

Ruta al fichero XML

Nota:

Libxml 2 no escapa la URI, así que si es necesario pasar, por ejemplo b&c, como parámetro a de la URI, hay que llamar a simplexml_load_file(rawurlencode('http://example.com/?a=' . urlencode('b&c'))). Desde PHP 5.1.0 no es necesario hacer esto porque PHP lo hará automáticamente.

class_name

Este parámetro opcional puede ser usado cuando se necesita que simplexml_load_file() retorne un objeto de la clase especificada. Esa clase debe extender de la clase SimpleXMLElement.

options

Desde PHP 5.1.0 y Libxml 2.6.0 puede usarse options para especificar parámetros Libxml adicionales.

ns

El prefijo del espacio de nombres o un URI.

is_prefix

true si ns es un prefijo, false si es un URI; por defecto es false.

Valores devueltos

Devuelve un object de tipo SimpleXMLElement cuyas propiedades contienen los datos del documento XML, o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Errores/Excepciones

Produce un mensaje de error E_WARNING para cada error encontrado en los datos XML.

Sugerencia

Usar libxml_use_internal_errors() para suprimir todos los errores XML y libxml_get_errors() para iterar sobre cada uno de ellos posteriormente.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro opcional is_prefix.

Ejemplos

Ejemplo #1 Interpreta un documento XML

<?php
// El fichero test.xml contiene un documento XML con un elemento raíz y, al
// menos, un elemento /[raiz]/titulo.

if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    print_r($xml);
} else {
    exit('Error abriendo test.xml.');
}
?>

Este script mostrará, si no hay errores:

SimpleXMLElement Object
(
  [titulo] => Título ejemplo
  ...
)

En este punto, se puede seguir recorriendo usando $xml->titulo y cualquier otro elemento.

Ver también

  • simplexml_load_string() - Interpreta un string de XML en un objeto
  • SimpleXMLElement::__construct() - Crea un nuevo objeto SimpleXMLElement
  • Tratar con los errores XML
  • libxml_use_internal_errors() - Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario
  • Uso básico de SimpleXML


Interpreta un string de XML en un objeto

  • « simplexml_load_file
  • WDDX »
  • PHP Manual
  • Funciones de SimpleXML
  • Interpreta un string de XML en un objeto

simplexml_load_string

(PHP 5, PHP 7, PHP 8)

simplexml_load_string — Interpreta un string de XML en un objeto

Descripción

simplexml_load_string ( string $data , string $class_name = "SimpleXMLElement" , int $options = 0 , string $ns = "" , bool $is_prefix = false ) : SimpleXMLElement

Toma un string XML correcto y lo retorna como objeto.

Parámetros

data

Un string XML correcto

class_name

Este parámetro opcional puede ser usado cuando se necesita que simplexml_load_file() retorne un objeto de la clase especificada. Esa clase debe extender de la clase SimpleXMLElement.

options

Desde PHP 5.1.0 y Libxml 2.6.0 puede usarse options para especificar parámetros Libxml adicionales.

ns

El prefijo del espacio de nombres o un URI.

is_prefix

true si ns es un prefijo, false si es un URI; por defecto es false.

Valores devueltos

Devuelve un object de tipo SimpleXMLElement cuyas propiedades contienen los datos del documento XML, o false en caso de error.

Advertencia

Esta función puede devolver el valor booleano false, pero también puede devolver un valor no booleano que se evalúa como false. Por favor lea la sección sobre Booleanos para más información. Use el operador === para comprobar el valor devuelto por esta función.

Errores/Excepciones

Produce un mensaje de error E_WARNING para cada error encontrado en los datos XML.

Sugerencia

Usar libxml_use_internal_errors() para suprimir todos los errores XML y libxml_get_errors() para iterar sobre cada uno de ellos posteriormente.

Historial de cambios

Versión | Descripción
5.2.0 | Se añadió el parámetro opcional is_prefix.

Ejemplos

Ejemplo #1 Interpreta un string XML

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
 <title>¿Cuarenta qué?</title>
 <from>Joe</from>
 <to>Jane</to>
 <body>
  Sé que esa es la respuesta pero, ¿cuál es la pregunta?
 </body>
</document>
XML;

$xml = simplexml_load_string($string);

print_r($xml);
?>

El resultado del ejemplo sería:

SimpleXMLElement Object
(
  [titulo] => ¿Cuarenta qué?
  [de] => Joe
  [para] => Jane
  [mensaje] => Sé que esa es la respuesta pero, ¿cuál es la pregunta?
)

En este punto, se puede usar $xml->mensaje y similares.

Ver también

  • simplexml_load_file() - Interpreta un fichero XML en un objeto
  • SimpleXMLElement::__construct() - Crea un nuevo objeto SimpleXMLElement
  • Tratar con los errores XML
  • libxml_use_internal_errors() - Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario
  • Uso básico de SimpleXML


WDDX

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ejemplos de wddx
  • Funciones de WDDX
    • wddx_add_vars — Agrega variables a un paquete WDDX con un ID específico
    • wddx_deserialize — Deserializa un packet WDDX
    • wddx_packet_end — Finaliza un paquete WDDX con un ID específico
    • wddx_packet_start — Inicia un nuevo paquete WDDX con una estructura a dentro
    • wddx_serialize_value — Serializa una simple valor dentro de un paquete WDDX
    • wddx_serialize_vars — Serializa variables en un paquete WDDX


  • « WDDX
  • Instalación/Configuración »
  • PHP Manual
  • WDDX
  • Introducción

Introducción

Estas funciones están previstas para trabajar con » WDDX.


Requerimientos

Esta extensión requiere la extensión libxml de PHP. Esto significa que también es necesario pasar la opción --enable-libxml, aunque esto se realiza implícitamente debido a que libxml está habilitada de forma predeterminada.

A fin de utilizar WDDX, se necesita instalar la librería expat (la cual viene con Apache 1.3.7 o superior).


Instalación

Despúes de instalar la librería requerida expat, compile PHP con --enable-wddx, y use --with-libexpat-dir para expat.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


  • « Configuración en tiempo de ejecución
  • Constantes predefinidas »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión define un identificador de paquete WDDX devuelto por wddx_packet_start().


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • WDDX
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


  • « Constantes predefinidas
  • Ejemplos de wddx »
  • PHP Manual
  • WDDX
  • Ejemplos

Ejemplos

Tabla de contenidos

  • Ejemplos de wddx


Ejemplos de wddx

Todas las funciones que serializan variables utilizan el primer elemento de un array para determinar si el array ha sido serializado en una estructura o un array. Si el primer elemento tiene una cadena como llave, entonces es serializado como estructura, de lo contrario, en un array.

Ejemplo #1 Serializando un simple valor con WDDX

<?php
echo wddx_serialize_value("PHP to WDDX packet example", "PHP packet");
?>

Este ejemplo producirá:

<wddxPacket version='1.0'><header comment='PHP packet'/><data>
<string>PHP to WDDX packet example</string></data></wddxPacket>

Ejemplo #2 Usando paquetes incrementales con WDDX

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* Suppose $cities came from database */
$cities = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "cities");

$packet = wddx_packet_end($packet_id);
echo $packet;
?>

Este ejemplo producirá:

<wddxPacket version='1.0'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='cities'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

Nota:

Si se desea serializar caracteres distintos al ASCII se debe convertir los datos a UTF-8 primero (ver utf8_encode() e iconv()).


Funciones de WDDX

Tabla de contenidos

  • wddx_add_vars — Agrega variables a un paquete WDDX con un ID específico
  • wddx_deserialize — Deserializa un packet WDDX
  • wddx_packet_end — Finaliza un paquete WDDX con un ID específico
  • wddx_packet_start — Inicia un nuevo paquete WDDX con una estructura a dentro
  • wddx_serialize_value — Serializa una simple valor dentro de un paquete WDDX
  • wddx_serialize_vars — Serializa variables en un paquete WDDX


Agrega variables a un paquete WDDX con un ID específico

  • « Funciones de WDDX
  • wddx_deserialize »
  • PHP Manual
  • Funciones de WDDX
  • Agrega variables a un paquete WDDX con un ID específico

wddx_add_vars

(PHP 4, PHP 5, PHP 7)

wddx_add_vars — Agrega variables a un paquete WDDX con un ID específico

Advertencia

This function was REMOVED in PHP 7.4.0.

Descripción

wddx_add_vars ( resource $packet_id , mixed $var_name , mixed $... = ? ) : bool

Serializa las variables pasadas y agrega el resultado al paquete determinado.

Parámetros

Esta función toma un número variable de parámetros.

packet_id

Un paquete WDDX, devuelto por wddx_packet_start().

var_name

Pude ser una cadena, una variable o un array conteniendo una cadena, una variable u otro array, etc.

...

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Deserializa un packet WDDX

  • « wddx_add_vars
  • wddx_packet_end »
  • PHP Manual
  • Funciones de WDDX
  • Deserializa un packet WDDX

wddx_deserialize

(PHP 4, PHP 5, PHP 7)

wddx_deserialize — Deserializa un packet WDDX

Descripción

wddx_deserialize ( string $packet ) : mixed

Deserializa un packet WDDX.

Parámetros

packet

Un paquete WDDX, como un string o cadena.

Valores devueltos

Devuelve un valor deserializado que puede ser una cadena, un número o un array. Note que las estructuras son deserializadas en arrays asociativos.


Finaliza un paquete WDDX con un ID específico

  • « wddx_deserialize
  • wddx_packet_start »
  • PHP Manual
  • Funciones de WDDX
  • Finaliza un paquete WDDX con un ID específico

wddx_packet_end

(PHP 4, PHP 5, PHP 7)

wddx_packet_end — Finaliza un paquete WDDX con un ID específico

Advertencia

This function was REMOVED in PHP 7.4.0.

Descripción

wddx_packet_end ( resource $packet_id ) : string

Finaliza y devuelve el paquete WDDX.

Parámetros

packet_id

Un paquete WDDX, devuelto por wddx_packet_start().

Valores devueltos

Devuelve la cadena que contiene el paquete WDDX.


Inicia un nuevo paquete WDDX con una estructura a dentro

  • « wddx_packet_end
  • wddx_serialize_value »
  • PHP Manual
  • Funciones de WDDX
  • Inicia un nuevo paquete WDDX con una estructura a dentro

wddx_packet_start

(PHP 4, PHP 5, PHP 7)

wddx_packet_start — Inicia un nuevo paquete WDDX con una estructura a dentro

Advertencia

This function was REMOVED in PHP 7.4.0.

Descripción

wddx_packet_start ( string $comment = ? ) : resource

Inicia un nuevo paquete WDDX para adición incremental de variables. Crea una definición de estructura automáticamente dentro del paquete para almacenar variables.

Parámetros

comment

Una cadena de comentario opcional.

Valores devueltos

Devuelve un ID de paquete para usar en funciones posteriores, o false en caso de error.


Serializa una simple valor dentro de un paquete WDDX

  • « wddx_packet_start
  • wddx_serialize_vars »
  • PHP Manual
  • Funciones de WDDX
  • Serializa una simple valor dentro de un paquete WDDX

wddx_serialize_value

(PHP 4, PHP 5, PHP 7)

wddx_serialize_value — Serializa una simple valor dentro de un paquete WDDX

Advertencia

This function was REMOVED in PHP 7.4.0.

Descripción

wddx_serialize_value ( mixed $var , string $comment = ? ) : string

Crea un paquete WDDX a partir de un simple valor.

Parámetros

var

El valor que será serializado

comment

Una cadena opcional de comentario que aparecerá en la cabecera del paquete.

Valores devueltos

Devuelve el paquete WDDX, o false en caso de error.


Serializa variables en un paquete WDDX

  • « wddx_serialize_value
  • XMLDiff »
  • PHP Manual
  • Funciones de WDDX
  • Serializa variables en un paquete WDDX

wddx_serialize_vars

(PHP 4, PHP 5, PHP 7)

wddx_serialize_vars — Serializa variables en un paquete WDDX

Advertencia

This function was REMOVED in PHP 7.4.0.

Descripción

wddx_serialize_vars ( mixed $var_name , mixed $... = ? ) : string

Crea un paquete WDDX con una estructura que contiene la representación serializada de las variables pasadas.

Parámetros

Esta función toma un número variables de parámetros.

var_name

Pude ser una cadena, una variable o un array conteniendo una cadena, una variable u otro array, etc.

...

Valores devueltos

Devuelve el paquete WDDX, o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo wddx_serialize_vars()

<?php
$a = 1;
$b = 5.5;
$c = array("blue", "orange", "violet");
$d = "colors";

$clvars = array("c", "d");
echo wddx_serialize_vars("a", "b", $clvars);
?>

El resultado del ejemplo sería:

<wddxPacket version='1.0'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>blue</string><string>orange</string><string>violet</string></array></var>
<var name='d'><string>colors</string></var></struct></data></wddxPacket>


Diferencias y fusión de documentos XML

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • XMLDiff\Base — La clase XMLDiff\Base
    • XMLDiff\Base::__construct — Constructor
    • XMLDiff\Base::diff — Produce diferencias de dos documentos XML
    • XMLDiff\Base::merge — Produce un nuevo documento XML basado en diferencias
  • XMLDiff\DOM — La clase XMLDiff\DOM
    • XMLDiff\DOM::diff — Diferencia dos objetos DOMDocument
    • XMLDiff\DOM::merge — Produce DOMDocument unido
  • XMLDiff\Memory — La clase XMLDiff\Memory
    • XMLDiff\Memory::diff — Diferenciar dos documentos XML
    • XMLDiff\Memory::merge — Produce un documento XML unido
  • XMLDiff\File — La clase XMLDiff\File
    • XMLDiff\File::diff — Diferencia dos archivos XML
    • XMLDiff\File::merge — Produce un documento XML unido


Introducción

Esta extensión es capaz de calcular las diferencias de dos documentos XML y luego aplicarlas en el documento de origen. El diff es un documento XML que contiene en sus nodos, en formato legible por humanos, las instruciones para copiar/insertar/eliminar. Objetos del tipo DOMDocument, ficheros locales y strings en memoria pueden ser procesados.


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • XMLDiff
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


Requerimientos

libdiffmark - la versión 0.10 se incluye con la extensión. Si diffmark está disponible en los paquetes del sistema, su uso es altamente recomendado.

Extensión libxml

Extensión DOM


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/xmldiff.

Un DLL para esta extensión PECL se encuentra disponible en » http://windows.php.net/downloads/pecl/releases/xmldiff/.


La clase XMLDiff\Base

(PECL xmldiff >= 0.8.0)

Introducción

Clase abstracta, base para todas las clases de comparación en la extensión.

Sinopsis de la Clase

XMLDiff\Base {
/* Métodos */
public __construct ( string $nsname )
abstract public diff ( mixed $from , mixed $to ) : mixed
abstract public merge ( mixed $src , mixed $diff ) : mixed
}

Tabla de contenidos

  • XMLDiff\Base::__construct — Constructor
  • XMLDiff\Base::diff — Produce diferencias de dos documentos XML
  • XMLDiff\Base::merge — Produce un nuevo documento XML basado en diferencias


Constructor

  • « XMLDiff\Base
  • XMLDiff\Base::diff »
  • PHP Manual
  • XMLDiff\Base
  • Constructor

XMLDiff\Base::__construct

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::__construct — Constructor

Descripción

public XMLDiff\Base::__construct ( string $nsname )

Constructor base para todas las clases de trabajadores en la extensión Xmldiff.

Parámetros

nsname

Nombre del espacio de nombres personalizado para el documento de diferencias. El espacio de nombres por defecto es http://www.locus.cz/diffmark y eso es suficiente para evitar conflictos de nombres. Usa este parámetro si quieres cambiarlo por alguna razón.

Valores devueltos


Produce diferencias de dos documentos XML

  • « XMLDiff\Base::__construct
  • XMLDiff\Base::merge »
  • PHP Manual
  • XMLDiff\Base
  • Produce diferencias de dos documentos XML

XMLDiff\Base::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::diff — Produce diferencias de dos documentos XML

Descripción

abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed

Método abstracto diferencial para ser aplicado por las clases hereditarias.

El propósito básico de este método es producir diferencias entre dos documentos. El orden paramétrico importa y producirá diferentes resultados.

Parámetros

from

Documento fuente XML.

to

Documento XML de destino.

Valores devueltos

Depende de la implementación.


Produce un nuevo documento XML basado en diferencias

  • « XMLDiff\Base::diff
  • XMLDiff\DOM »
  • PHP Manual
  • XMLDiff\Base
  • Produce un nuevo documento XML basado en diferencias

XMLDiff\Base::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::merge — Produce un nuevo documento XML basado en diferencias

Descripción

abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed

Método de fusión abstracta para ser implementado por las clases hereditarias.

Básicamente el propósito del método es producir un nuevo documento XML basado en la información diferencial.

Parámetros

src

Documento fuente XML.

diff

Documento producido por el método diferencial.

Valores devueltos

Depende de la implementación.


La clase XMLDiff\DOM

(PECL xmldiff >= 0.8.0)

Introducción

Sinopsis de la Clase

XMLDiff\DOM extends XMLDiff\Base {
/* Métodos */
public diff ( DOMDocument $from , DOMDocument $to ) : DOMDocument
public merge ( DOMDocument $src , DOMDocument $diff ) : DOMDocument
/* Métodos heredados */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Tabla de contenidos

  • XMLDiff\DOM::diff — Diferencia dos objetos DOMDocument
  • XMLDiff\DOM::merge — Produce DOMDocument unido


Diferencia dos objetos DOMDocument

  • « XMLDiff\DOM
  • XMLDiff\DOM::merge »
  • PHP Manual
  • XMLDiff\DOM
  • Diferencia dos objetos DOMDocument

XMLDiff\DOM::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::diff — Diferencia dos objetos DOMDocument

Descripción

public XMLDiff\DOM::diff ( DOMDocument $from , DOMDocument $to ) : DOMDocument

Diferencia dos instancias de DOMDocument y produce la nueva que contiene la información de la diferencia.

Parámetros

from

Fuente del objeto DOMDocument.

to

Objeto de destino DOMDocument.

Valores devueltos

DOMDocument con la información de diferencia o NULL.


Produce DOMDocument unido

  • « XMLDiff\DOM::diff
  • XMLDiff\Memory »
  • PHP Manual
  • XMLDiff\DOM
  • Produce DOMDocument unido

XMLDiff\DOM::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::merge — Produce DOMDocument unido

Descripción

public XMLDiff\DOM::merge ( DOMDocument $src , DOMDocument $diff ) : DOMDocument

Crear un nuevo DOMDocument basado en las diferencias.

Parámetros

src

Objeto fuente DOMDocument.

diff

Objeto DOMDocument que contiene la información de diferencias.

Valores devueltos

DOMDocument unido o NULL.


La clase XMLDiff\Memory

(PECL xmldiff >= 0.8.0)

Introducción

Sinopsis de la Clase

XMLDiff\Memory extends XMLDiff\Base {
/* Métodos */
public diff ( string $from , string $to ) : string
public merge ( string $src , string $diff ) : string
/* Métodos heredados */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Tabla de contenidos

  • XMLDiff\Memory::diff — Diferenciar dos documentos XML
  • XMLDiff\Memory::merge — Produce un documento XML unido


Diferenciar dos documentos XML

  • « XMLDiff\Memory
  • XMLDiff\Memory::merge »
  • PHP Manual
  • XMLDiff\Memory
  • Diferenciar dos documentos XML

XMLDiff\Memory::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::diff — Diferenciar dos documentos XML

Descripción

public XMLDiff\Memory::diff ( string $from , string $to ) : string

Diferenciar dos string que contienen documentos XML y producir la información diferencial.

Parámetros

from

Documento fuente XML.

to

Documento XML de destino.

Valores devueltos

String con el documento XML que contiene la información del diferencia o NULL.


Produce un documento XML unido

  • « XMLDiff\Memory::diff
  • XMLDiff\File »
  • PHP Manual
  • XMLDiff\Memory
  • Produce un documento XML unido

XMLDiff\Memory::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::merge — Produce un documento XML unido

Descripción

public XMLDiff\Memory::merge ( string $src , string $diff ) : string

Crear un nuevo documento XML basado en diferencias y documento fuente.

Parámetros

src

Documento fuente XML.

diff

Documento XML que contiene información de diferencias.

Valores devueltos

String con el nuevo documento XML o NULL.


La clase XMLDiff\File

(PECL xmldiff >= 0.8.0)

Introducción

Sinopsis de la Clase

XMLDiff\File extends XMLDiff\Base {
/* Métodos */
public diff ( string $from , string $to ) : string
public merge ( string $src , string $diff ) : string
/* Métodos heredados */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Tabla de contenidos

  • XMLDiff\File::diff — Diferencia dos archivos XML
  • XMLDiff\File::merge — Produce un documento XML unido


Diferencia dos archivos XML

  • « XMLDiff\File
  • XMLDiff\File::merge »
  • PHP Manual
  • XMLDiff\File
  • Diferencia dos archivos XML

XMLDiff\File::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\File::diff — Diferencia dos archivos XML

Descripción

public XMLDiff\File::diff ( string $from , string $to ) : string

Diferencia dos archivos XML locales y produce un string con la información de diferenciación.

Parámetros

from

Path to the source document.

to

Ruta al documento fuente.

Valores devueltos

String con el documento XML que contiene la información diferencial o NULL.


Produce un documento XML unido

  • « XMLDiff\File::diff
  • Analizador XML »
  • PHP Manual
  • XMLDiff\File
  • Produce un documento XML unido

XMLDiff\File::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\File::merge — Produce un documento XML unido

Descripción

public XMLDiff\File::merge ( string $src , string $diff ) : string

Crea un nuevo documento XML basado en diferencias y documento fuente.

Parámetros

src

Ruta al documento XML de origen.

diff

Ruta al documento XML con la información de diferencia.

Valores devueltos

String con el nuevo documento XML o NULL.


Analizador XML

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Manejadores de eventos
  • Case Folding
  • Error Codes
  • Codificación de caracteres
  • Ejemplos
    • Ejemplo de estructura de XML
    • Ejemplo de asignación de etiquetas XML
    • Ejemplo de entidades XML externas
  • Funciones del Intérprete XML
    • utf8_decode — Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1
    • utf8_encode — Codifica un string ISO-8859-1 a UTF-8
    • xml_error_string — Obtiene la cadena de un error dado en un intérprete XML
    • xml_get_current_byte_index — Obtiene la indexación del byte actual en un intérprete XML
    • xml_get_current_column_number — Obtiene el número de columna actual para un intérprete XML
    • xml_get_current_line_number — Obtiene el número de línea actual para un intérprete XML
    • xml_get_error_code — Obtiene un código de error en un intérprete XML
    • xml_parse_into_struct — Interpreta datos XML en una estructura de array
    • xml_parse — Inicia un intérprete sobre un documento XML
    • xml_parser_create_ns — Crea un analizador XML con soporte para espacios de nombres
    • xml_parser_create — Crea un intérprete XML
    • xml_parser_free — Liberar una analizador XML
    • xml_parser_get_option — Obtiene el valor de las opciones de un intérprete XML
    • xml_parser_set_option — Configura las opciones en un intérprete XML
    • xml_set_character_data_handler — Configura el manejador de los datos de caracteres
    • xml_set_default_handler — Configura el manejador predeterminado
    • xml_set_element_handler — Configura los manejadores para los elementos de inicio y final
    • xml_set_end_namespace_decl_handler — Configura el manejador de declaración de final del namespace
    • xml_set_external_entity_ref_handler — Configura el manejador de referencia a entidades externas
    • xml_set_notation_decl_handler — Configura el manejador de declaraciones de notación
    • xml_set_object — Usa un intérprete XML Parser dentro de un objeto
    • xml_set_processing_instruction_handler — Configura el manejador de instrucciones de proceso (PI)
    • xml_set_start_namespace_decl_handler — Configura el manejador de declaración de inicio del namespace
    • xml_set_unparsed_entity_decl_handler — Configura el manejador de declaración de entidades no analizadas


Introducción

XML (eXtensible Markup Language) es un formato de datos para el intercambio en la web de documentos estructurados. Es un estándar definido por el World Wide Web consortium (W3C). Se puede encontrar más información sobre XML y tecnologías relacionadas en » http://www.w3.org/XML/.

Esta extensión de PHP implementa el soporte para expat de James Clark en PHP. Este conjunto de herramientas permite analizar, pero no validar, documentos XML. Es compatible con tres codificaciones de caracteres fuente, también proporcionadas por PHP: US-ASCII, ISO-8859-1 y UTF-8. No está soportada UTF-16.

Esta extensión permite crear analizadores XML y luego definir gestores para los diferentes eventos XML. Cada analizador XML también tiene algunos parámetros que se pueden ajustar.


Requerimientos

Esta extensión requiere la extensión libxml de PHP. Esto significa que también es necesario pasar la opción --enable-libxml, aunque esto se realiza implícitamente debido a que libxml está habilitada de forma predeterminada.

Esta extensión usa una capa de compatibilidad expat por defecto. También puede usarse expat,el cual puede encontrarse en » http://www.jclark.com/xml/expat.html. El Makefile que viene con expat no construye una libreria por defecto, puede utilizar esta regla para hacerlo:

libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
Se puede encontrar un paquete RPM de expat en » http://sourceforge.net/projects/expat/.


Instalación

Esta extensión está habilitada de forma predeterminada. Se puede deshabilitar empleando la siguiente opción durante la compilación: --disable-xml

Estas funciones estan activadas por defecto, usando la libreria incluida de expat. Se puede desactivar el soporte XML con --disable-xml. Si se compila PHP como un módulo para Apache 1.3.9 o superior, PHP automaticamente usará la libreria incluida de expat desde Apache. Para no usar la libreria incluida de expat se configura PHP con --with-expat-dir=DIR, donde DIR apunta al directorio base de instalación de expat expat.

La versión de PHP para Windows tiene soporte nativo para esta extensión. No se requiere cargar extensiones adicionales para utilizar estas funciones.


Tipos de recursos

El recurso xml tal y como lo devuelve xml_parser_create() y xml_parser_create_ns() hace referencia a una instancia de intérprete xml para ser usado con las funciones provistas por esta extensión.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)
XML_SAX_IMPL (string)
Guarda el método de implementación de SAX. Puede ser libxml o expat .


Manejadores de eventos

Los manejadores XML de eventos definidos son:

Manejadores XML soportados
Función PHP para configurar el manejador | Descripción del evento
xml_set_element_handler() | Los eventos de elemento se producen cada vez que el intérprete XML encuentra etiquetas de inicio o de final. Hay manejadores separados para etiquetas de inicio y final.
xml_set_character_data_handler() | Por definición los datos de caracteres es todo el contenido no marcado de los documentos XML, incluidos los espacios en blanco entre etiquetas. Tenga en cuenta que el intérprete XML no añade o elimina ningún espacio en blanco, eso depende de la aplicación (usted) decidir si el espacio en blanco es significativo.
xml_set_processing_instruction_handler() | Los programadores de PHP ya deberían estar familiarizados con las instrucciones de procesado (PI). <?php ?> es una instrucción de procesado, donde php se denomina "PI destino". El manejo de ellos es específico para cada aplicación, excepto los PI destinos que empiecen con "XML", ya que estan reservados.
xml_set_default_handler() | Lo que no va a otro manejador va al manejador predeterminado. En el controlador predeterminado se obtendran cosas como el XML y las declaraciones de tipo de documento.
xml_set_unparsed_entity_decl_handler() | Este manejador será llamado para la declaración de una entidad no analizada (NDATA).
xml_set_notation_decl_handler() | Este manejador es llamado para la declaración de una notación.
xml_set_external_entity_ref_handler() | Este manejador es llamado cuando el intérprete XML encuentra una referencia a una entidad general externa analizada. Por ejemplo puede ser una referencia a un fichero o una URL. Ver el ejemplo de entidad externa para una demostración.
xml_set_start_namespace_decl_handler() | Este manejador es llamado al principio de una declaración de namespace.
xml_set_end_namespace_decl_handler() | Este manejador es llamado al fin de un espacio de una declaración de namespace. Tenga en cuenta que este evento NO es bajo LibXML.


Case Folding

Las funciones manejadoras de elementos pueden obtener sus nombres de elementos "case-folded". Case folding se define como "un proceso aplicado a una secuencia de caracteres", en el cual aquellos que son identificados como no-mayúsculas son reemplazados por sus equivalentes en mayúsculas". En otras palabras, cuando se trata de XML, case folding simplemente significa poner en mayúsculas.

Por defecto, todos los nombres de elementos que son pasados al manejador de funciones son pasados a mayúsculas. Este comportamiento puede ser consultado y controlado por el intérprete XML mediante las funciones xml_parser_get_option() y xml_parser_set_option() respectivamente.


Error Codes

Las siguientes constantes se definen para códigos de error XML (como los que devuelve xml_parse ()):

  • XML_ERROR_NONE
  • XML_ERROR_NO_MEMORY
  • XML_ERROR_SYNTAX
  • XML_ERROR_NO_ELEMENTS
  • XML_ERROR_INVALID_TOKEN
  • XML_ERROR_UNCLOSED_TOKEN
  • XML_ERROR_PARTIAL_CHAR
  • XML_ERROR_TAG_MISMATCH
  • XML_ERROR_DUPLICATE_ATTRIBUTE
  • XML_ERROR_JUNK_AFTER_DOC_ELEMENT
  • XML_ERROR_PARAM_ENTITY_REF
  • XML_ERROR_UNDEFINED_ENTITY
  • XML_ERROR_RECURSIVE_ENTITY_REF
  • XML_ERROR_ASYNC_ENTITY
  • XML_ERROR_BAD_CHAR_REF
  • XML_ERROR_BINARY_ENTITY_REF
  • XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
  • XML_ERROR_MISPLACED_XML_PI
  • XML_ERROR_UNKNOWN_ENCODING
  • XML_ERROR_INCORRECT_ENCODING
  • XML_ERROR_UNCLOSED_CDATA_SECTION
  • XML_ERROR_EXTERNAL_ENTITY_HANDLING


Codificación de caracteres

La extensión de PHP XML es compatible con el conjunto de caracteres » Unicode a través de diferentes codificaciones de caracteres. Hay dos tipos de codificaciones de caracteres: la codificación fuente y la codificación de destino. La representación interna de PHP del documento está siempre codificada con UTF-8.

La codificación fuente se hace cuando un documento XML es analizado. Una vez creado un intérprete XML, la codificación fuente puede ser especificada (esta codificación no puede ser cambiada más adelante en la vida del intérprete XML). Las codificaciones fuente soportadas son ISO-8859-1, US-ASCII y UTF-8. Las dos primeras son codificaciones de un solo byte, lo cual significa que cada caracter se representa por un solo byte. UTF-8 puede codificar caracteres compuestos por un número variable de bits (hasta 21) de uno a cuatro bytes. La codificación fuente por defecto usada por PHP es ISO-8859-1.

La codificación de destino se hace cuando PHP pasa datos al controlador XML de funciones. Cuando un intérprete XML se ha creado, la codificación de destino se establece igual que la que tenga la codificación fuente, pero esta puede ser cambiada en cualquier punto. La codificación de destino afectará a los caracteres de los datos como también a los nombres de etiquetas y las intrucciones de procesamiento de destino.

Si el intérprete XML encuentra caracteres fuera de rango que su codificación fuente es capaz de representar, devolverá un error.

Si PHP encuentra caracteres en el documento XML analizado que no pueden ser representados en la codificación de destino escogida, los caracteres problemáticos seran "degradados". Actualmente esto significa que tales caracteres seran reemplazados por un signo de interrogación.


Ejemplos

Tabla de contenidos

  • Ejemplo de estructura de XML
  • Ejemplo de asignación de etiquetas XML
  • Ejemplo de entidades XML externas


Ejemplo de estructura de XML

Este primer ejemplo muestra la estructura de los elementos en un documento con indentación.

Ejemplo #1 Mostrar la estructura de elementos XML

<?php
$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs)
{
    global $depth;

    if (!isset($depth[$parser])) {
        $depth[$parser] = 0;
    }

    for ($i = 0; $i < $depth[$parser]; $i++) {
        echo "  ";
    }
    echo "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name)
{
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>


Ejemplo de asignación de etiquetas XML

Ejemplo #1 Asignar XML a HTML

Este ejemplo asigna las etiquetas en un documento XML directamente a etiquetas HTML. Los elementos que no sean encontrados en el "map array" son ignorados. Por supuesto, este ejemplo solo funcionará con un tipo específico de documento XML.

<?php
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "<$map_array[$name]>";
    }
}

function endElement($parser, $name)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "</$map_array[$name]>";
    }
}

function characterData($parser, $data)
{
    echo $data;
}

$xml_parser = xml_parser_create();
// use case-folding so we are sure to find the tag in $map_array
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>


Ejemplo de entidades XML externas

Este ejemplo resalta el código XML. Muestra como usar un gestor de referencia de entidades externas para incluir y analizar otros documentos, así como cuantos PIs pueden ser procesados, y una manera de determinar "confianza" para PIs que contienen código.

Los documentos XML que pueden ser usados para este ejemplo se pueden encontrar debajo del código del ejemplo (xmltest.xml y xmltest2.xml.)

Ejemplo #1 Ejemplo de entidades XML externas

<?php
$file = "xmltest.xml";

function trustedFile($file)
{
    // only trust local files owned by ourselves
    if (!preg_match("@^([a-z]+)\:\/\/@i", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs)
{
    echo "&lt;<font color=\"#0000cc\">$name</font>";
    if (count($attribs)) {
        foreach ($attribs as $k => $v) {
            echo " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    echo "&gt;";
}

function endElement($parser, $name)
{
    echo "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data)
{
    echo "<b>$data</b>";
}

function PIHandler($parser, $target, $data)
{
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // If the parsed document is "trusted", we say it is safe
            // to execute PHP code inside it.  If not, display the code
            // instead.
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Untrusted PHP code: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data)
{
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("Could not open entity %s at %s\n", $openEntityNames,
                   $systemId);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML error: %s at line %d while parsing entity %s\n",
                       xml_error_string(xml_get_error_code($parser)),
                       xml_get_current_line_number($parser), $openEntityNames);
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file)
{
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser, "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("could not open XML input");
}

echo "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d\n",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
echo "</pre>";
echo "parse complete\n";
xml_parser_free($xml_parser);

?>

Ejemplo #2 xmltest.xml

<?xml version='1.0'?>
<!DOCTYPE chapter SYSTEM "/just/a/test.dtd" [
<!ENTITY plainEntity "FOO entity">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
 <TITLE>Title &plainEntity;</TITLE>
 <para>
  <informaltable>
   <tgroup cols="3">
    <tbody>
     <row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
     <row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
 &systemEntity;
 <section id="about">
  <title>About this Document</title>
  <para>
   <!-- this is a comment -->
   <?php echo 'Hi!  This is PHP version ' . phpversion(); ?>
  </para>
 </section>
</chapter>

Este fichero se incluye desde xmltest.xml:

Ejemplo #3 xmltest2.xml

<?xml version="1.0"?>
<!DOCTYPE foo [
<!ENTITY testEnt "test entity">
]>
<foo>
   <element attrib="value"/>
   &testEnt;
   <?php echo "This is some more PHP code being executed."; ?>
</foo>


Funciones del Intérprete XML

Tabla de contenidos

  • utf8_decode — Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1
  • utf8_encode — Codifica un string ISO-8859-1 a UTF-8
  • xml_error_string — Obtiene la cadena de un error dado en un intérprete XML
  • xml_get_current_byte_index — Obtiene la indexación del byte actual en un intérprete XML
  • xml_get_current_column_number — Obtiene el número de columna actual para un intérprete XML
  • xml_get_current_line_number — Obtiene el número de línea actual para un intérprete XML
  • xml_get_error_code — Obtiene un código de error en un intérprete XML
  • xml_parse_into_struct — Interpreta datos XML en una estructura de array
  • xml_parse — Inicia un intérprete sobre un documento XML
  • xml_parser_create_ns — Crea un analizador XML con soporte para espacios de nombres
  • xml_parser_create — Crea un intérprete XML
  • xml_parser_free — Liberar una analizador XML
  • xml_parser_get_option — Obtiene el valor de las opciones de un intérprete XML
  • xml_parser_set_option — Configura las opciones en un intérprete XML
  • xml_set_character_data_handler — Configura el manejador de los datos de caracteres
  • xml_set_default_handler — Configura el manejador predeterminado
  • xml_set_element_handler — Configura los manejadores para los elementos de inicio y final
  • xml_set_end_namespace_decl_handler — Configura el manejador de declaración de final del namespace
  • xml_set_external_entity_ref_handler — Configura el manejador de referencia a entidades externas
  • xml_set_notation_decl_handler — Configura el manejador de declaraciones de notación
  • xml_set_object — Usa un intérprete XML Parser dentro de un objeto
  • xml_set_processing_instruction_handler — Configura el manejador de instrucciones de proceso (PI)
  • xml_set_start_namespace_decl_handler — Configura el manejador de declaración de inicio del namespace
  • xml_set_unparsed_entity_decl_handler — Configura el manejador de declaración de entidades no analizadas


Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1

  • « Funciones del Intérprete XML
  • utf8_encode »
  • PHP Manual
  • Funciones del Intérprete XML
  • Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1

utf8_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

utf8_decode — Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1

Descripción

utf8_decode ( string $data ) : string

Ésta función decodifica los data, asumidos a ser codificados por UTF-8, a ISO-8859-1.

Parámetros

data

Una cadena codificada UTF-8.

Valores devueltos

Devuelve la traducción ISO-8859-1 de los data.

Ver también

  • utf8_encode() - Codifica un string ISO-8859-1 a UTF-8 (contiene una explicación de la codificación UTF-8)


Codifica un string ISO-8859-1 a UTF-8

  • « utf8_decode
  • xml_error_string »
  • PHP Manual
  • Funciones del Intérprete XML
  • Codifica un string ISO-8859-1 a UTF-8

utf8_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

utf8_encode — Codifica un string ISO-8859-1 a UTF-8

Descripción

utf8_encode ( string $data ) : string

Ésta función codifica el string data a UTF-8, y devuelve una versión codificada. UTF-8 es un mecanismo estándar usado por Unicode para la codificación de los valores de caracteres anchos en un flujo de bytes. UTF-8 es transparente para caracteres ASCII puros, está autosincronizada (lo que significa que un programa puede averiguar dónde empiezan los caracteres del flujo de bytes) y puede usarse con funciones de comparación de string normal para ordenar, etc. PHP codifica los caracteres UTF-8 en hasta cuatro bytes, así:

Codificación UTF-8
bytes | bits | representation
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb
Cada b representa un bit que se puede usar para almacenar los datos de los caracteres.

Parámetros

data

Un string ISO-8859-1.

Valores devueltos

Devuelve la traducción UTF-8 de data.

Ver también

  • utf8_decode() - Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1


Obtiene la cadena de un error dado en un intérprete XML

  • « utf8_encode
  • xml_get_current_byte_index »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene la cadena de un error dado en un intérprete XML

xml_error_string

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_error_string — Obtiene la cadena de un error dado en un intérprete XML

Descripción

xml_error_string ( int $code ) : string

Obtiene la cadena asociada a un error code dado en un intérprete XML.

Parámetros

code

Código de error como el obtenido desde xml_get_error_code().

Valores devueltos

Devuelve un string con una descripción textual del error code, o false si no se ha encontrado una descripción asociada a ese código de error.

Ver también

  • xml_get_error_code() - Obtiene un código de error en un intérprete XML


Obtiene la indexación del byte actual en un intérprete XML

  • « xml_error_string
  • xml_get_current_column_number »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene la indexación del byte actual en un intérprete XML

xml_get_current_byte_index

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_byte_index — Obtiene la indexación del byte actual en un intérprete XML

Descripción

xml_get_current_byte_index ( resource $parser ) : int

Obtiene la indexación del byte actual en un intérprete XML dado.

Parámetros

parser

Identificador del recurso del intérprete XML sobre el que se va a obtener la indexación del byte actual.

Valores devueltos

Devuelve cual es la indexación del byte en el que se haya actualmente el intérprete en el buffer de datos (empieza siendo 0), o devuelve false si parser no se refiere a un intérprete válido.

Notas

Advertencia

Esta función devuelve la indexación de bytes de acuerdo a la codificación de texto UTF-8 texto sin tener en cuenta si la entrada está en otra codificación.

Ver también

  • xml_get_current_column_number() - Obtiene el número de columna actual para un intérprete XML
  • xml_get_current_line_number() - Obtiene el número de línea actual para un intérprete XML


Obtiene el número de columna actual para un intérprete XML

  • « xml_get_current_byte_index
  • xml_get_current_line_number »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene el número de columna actual para un intérprete XML

xml_get_current_column_number

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_column_number — Obtiene el número de columna actual para un intérprete XML

Descripción

xml_get_current_column_number ( resource $parser ) : int

Obtiene el número de columna actual para el intérprete XML dado.

Parámetros

parser

Identificador del recurso del intérprete XML sobre el que se va a obtener el número de columna.

Valores devueltos

Devuelve el número de columna en la línea actual (como la dada de xml_get_current_line_number()) en la que se haya el intérprete en el buffer de datos, o devuelve false si parser no se refiere a un intérprete válido.

Ver también

  • xml_get_current_byte_index() - Obtiene la indexación del byte actual en un intérprete XML
  • xml_get_current_line_number() - Obtiene el número de línea actual para un intérprete XML


Obtiene el número de línea actual para un intérprete XML

  • « xml_get_current_column_number
  • xml_get_error_code »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene el número de línea actual para un intérprete XML

xml_get_current_line_number

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_line_number — Obtiene el número de línea actual para un intérprete XML

Descripción

xml_get_current_line_number ( resource $parser ) : int

Obtiene el número de línea actual para el intérprete XML dado.

Parámetros

parser

Identificador del recurso del intérprete XML sobre el que se va a obtener el número de línea.

Valores devueltos

Devuelve el número de línea en el que se haya el intérprete actualmente en el buffer de datos, o devuelve false si parser no se refiere a un intérprete válido.

Ver también

  • xml_get_current_column_number() - Obtiene el número de columna actual para un intérprete XML
  • xml_get_current_byte_index() - Obtiene la indexación del byte actual en un intérprete XML


Obtiene un código de error en un intérprete XML

  • « xml_get_current_line_number
  • xml_parse_into_struct »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene un código de error en un intérprete XML

xml_get_error_code

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_error_code — Obtiene un código de error en un intérprete XML

Descripción

xml_get_error_code ( resource $parser ) : int

Obtiene un código de error dado en un intérprete XML.

Parámetros

parser

Identificador del recurso del intérprete XML sobre el que se va a obtener el valor de la opción.

Valores devueltos

Esta función devuelve false si parser no se refiere a un intérprete válido, si no devuelve un error de la lista: error codes section.

Ver también

  • xml_error_string() - Obtiene la cadena de un error dado en un intérprete XML


Interpreta datos XML en una estructura de array

  • « xml_get_error_code
  • xml_parse »
  • PHP Manual
  • Funciones del Intérprete XML
  • Interpreta datos XML en una estructura de array

xml_parse_into_struct

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parse_into_struct — Interpreta datos XML en una estructura de array

Descripción

xml_parse_into_struct ( resource $parser , string $data , array &$values , array &$index = ? ) : int

Esta función interpreta una cadena XML en dos estructuras paralelas de array, una (index) que contiene punteros a la ubicación de los valores adecuados en el array values. Estos dos últimos parámetros deben ser pasados por referencia.

Parámetros

parser

Una referencia para el interprete de XML.

data

Una cadena que contiene los datos XML.

values

Un array que contiene los valores de los datos XML.

index

Un array que contiene apuntadores hacia la ubicación de los valores apropiados en $values.

Valores devueltos

xml_parse_into_struct() retorna 0 cuando falla y 1 si es exitoso. Esto no es lo mismo que false y true, tener cuidado con operadores tales como ===.

Ejemplos

A continuación se muestra un ejemplo que ilustra la estructura interna de los arrays que se generan por la función. Se usa una etiqueta simple note incrustada dentro de una etiqueta para y entonces esto se interpreta y se muestran las estructuras generadas:

Ejemplo #1 Ejemplo de xml_parse_into_struct()

<?php
$simple = "<para><note>Nota Simple</note></para>";
$p = xml_parser_create();
xml_parse_into_struct($p, $simple, $vals, $index);
xml_parser_free($p);
echo "Index array\n";
print_r($index);
echo "\nVals array\n";
print_r($vals);
?>

Cuando se ejecuta este código, la salida será:

Index array
Array
(
    [PARA] => Array
        (
            [0] => 0
            [1] => 2
        )

    [NOTE] => Array
        (
            [0] => 1
        )

)

Vals array
Array
(
    [0] => Array
        (
            [tag] => PARA
            [type] => open
            [level] => 1
        )

    [1] => Array
        (
            [tag] => NOTE
            [type] => complete
            [level] => 2
            [value] => simple note
        )

    [2] => Array
        (
            [tag] => PARA
            [type] => close
            [level] => 1
        )

)

El análisis por eventos (basado en la biblioteca expat) puede ser más complicado cuando se tiene un documento XML que es complejo. Esta función no produce un objeto de estilo DOM, pero genera estructuras susceptibles de ser transversionadas en forma de árbol. Por lo tanto, se pueden crear objetos que representan los datos en el archivo XML con facilidad. Considere el siguiente archivo XML que representa una pequeña base de datos con información de aminoácidos:

Ejemplo #2 moldb.xml - pequeña base de datos de información molecular

<?xml version="1.0"?>
<moldb>

  <molecule>
      <name>Alanine</name>
      <symbol>ala</symbol>
      <code>A</code>
      <type>hydrophobic</type>
  </molecule>

  <molecule>
      <name>Lysine</name>
      <symbol>lys</symbol>
      <code>K</code>
      <type>charged</type>
  </molecule>

</moldb>
Y algo de código para interpretar el documento y generar los objetos adecuados:

Ejemplo #3 parsemoldb.php - interpreta moldb.xml dentro de un array de objetos moleculares

<?php

class AminoAcid {
    var $name;  // nombre aa
    var $symbol;    // símbolo de tres letras
    var $code;  // código de una letra
    var $type;  // hidrofóbico, cargado or neutral

    function AminoAcid ($aa)
    {
        foreach ($aa as $k=>$v)
            $this->$k = $aa[$k];
    }
}

function readDatabase($filename)
{
    // read the XML database of aminoacids
    $data = implode("", file($filename));
    $parser = xml_parser_create();
    xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
    xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, 1);
    xml_parse_into_struct($parser, $data, $values, $tags);
    xml_parser_free($parser);

    // repetir a través de las extructuras
    foreach ($tags as $key=>$val) {
        if ($key == "molecule") {
            $molranges = $val;
            // cada par contiguo de netradas de array son los
            // rangos altos y bajos para cada definición de molécula
            for ($i=0; $i < count($molranges); $i+=2) {
                $offset = $molranges[$i] + 1;
                $len = $molranges[$i + 1] - $offset;
                $tdb[] = parseMol(array_slice($values, $offset, $len));
            }
        } else {
            continue;
        }
    }
    return $tdb;
}

function parseMol($mvalues)
{
    for ($i=0; $i < count($mvalues); $i++) {
        $mol[$mvalues[$i]["tag"]] = $mvalues[$i]["value"];
    }
    return new AminoAcid($mol);
}

$db = readDatabase("moldb.xml");
echo "** Database of AminoAcid objects:\n";
print_r($db);

?>
Después de ejecutar parsemoldb.php, la variable $db contiene un array de objetos de AminoAcid y la salida del script confirma que:
** Base de datos de objetos AminoÁcidos:
Array
(
    [0] => Objeto aminoácido
        (
            [name] => Alanine
            [symbol] => ala
            [code] => A
            [type] => hydrophobic
        )

    [1] => Objeto aminoácido
        (
            [name] => Lysine
            [symbol] => lys
            [code] => K
            [type] => charged
        )

)


Inicia un intérprete sobre un documento XML

  • « xml_parse_into_struct
  • xml_parser_create_ns »
  • PHP Manual
  • Funciones del Intérprete XML
  • Inicia un intérprete sobre un documento XML

xml_parse

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parse — Inicia un intérprete sobre un documento XML

Descripción

xml_parse ( resource $parser , string $data , bool $is_final = false ) : int

xml_parse() analiza un documento XML. Los manejadores para los eventos configurados son llamados tantas veces como sea necesario.

Parámetros

parser

Identificador del recurso del intérprete XML que se va a usar.

data

Conjunto de información que se analizará. Un documento puede ser analizado por trozos llamando varias veces con nuevos trozos a xml_parse(), siempre que se establezca el parámetro is_final y sea true cuando el último dato sea analizado.

is_final

Si existe y es true, data es el último fragmento de datos enviados en este intérprete.

Valores devueltos

Devuelve 1 si el análisis se realiza con éxito o 0 en caso de error.

Para análisis fallidos, se puede recuperar información del error con
  xml_get_error_code(),
  xml_error_string(),
  xml_get_current_line_number(),
  xml_get_current_column_number() and
  xml_get_current_byte_index().

Nota:

Los errores de entidades son reportados al final de los datos, solo si is_final existe y es true.


Crea un analizador XML con soporte para espacios de nombres

  • « xml_parse
  • xml_parser_create »
  • PHP Manual
  • Funciones del Intérprete XML
  • Crea un analizador XML con soporte para espacios de nombres

xml_parser_create_ns

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_parser_create_ns — Crea un analizador XML con soporte para espacios de nombres

Descripción

xml_parser_create_ns ( string $encoding = ? , string $separator = ":" ) : resource

xml_parser_create_ns() crea un nuevo analizador XML con soporte para espacios de nombres XML y devuelve un gestor de recurso que hace referencia al mismo, para poder utilizarlo con las demás funciones de XML.

Parámetros

encoding

El parámetro opcional encoding especifica la codificación de caracteres para la entrada y salida en PHP4. A partir de PHP5, la codificación de entrada es detectada automáticamente, así que el parámetro encoding especifica sólo la codificación de salida. En PHP 4, la codificación de salida predeterminada es la misma que la del juego de caracteres de la entrada. En PHP 5.0.0 y 5.0.1, el juego de caracteres predeterminado es ISO-8859-1, mientras que en PHP 5.0.2 y posterior es UTF-8. Las codificaciones soportadas son ISO-8859-1, UTF-8 y US-ASCII.

separator

Con un analizador que tiene en cuenta los espacios de nombres, los parámetros de etiquetas pasados a las diferentes funciones gestoras consistirán en el espacio de nombres y el nombre de la etiqueta separado por el string especificado en separator.

Valores devueltos

Devuelve un gestor de recurso para el nuevo analizador XML.

Ver también

  • xml_parser_create() - Crea un intérprete XML
  • xml_parser_free() - Liberar una analizador XML


Crea un intérprete XML

  • « xml_parser_create_ns
  • xml_parser_free »
  • PHP Manual
  • Funciones del Intérprete XML
  • Crea un intérprete XML

xml_parser_create

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_create — Crea un intérprete XML

Descripción

xml_parser_create ( string $encoding = ? ) : resource

xml_parser_create() crea un nuevo intérprete XML y devuelve un identificador del recurso al que hace referencia, para ser usado por otras funciones XML.

Parámetros

encoding

El parámetro opcional encoding especifica la codificación de caracteres para entrada y salida en PHP4. A partir de PHP5, la codificación de entrada se detecta automaticamente, así que el parámetro encoding especifica solo la codificación de salida. En PHP 4, la codificación por defecto de salida es la misma que la del juego de caracteres de la entrada. Si se le pasa una cadena vacia, el intérprete intenta identificar cual es la codificación del documento mirando los 3 o 4 primeros bytes. En PHP 5.0.0 y 5.0.1, el juego de caracteres por defecto es ISO-8859-1, mientras que en PHP 5.0.2 y superior es UTF-8. Las codificaciones soportadas son ISO-8859-1, UTF-8 y US-ASCII.

Valores devueltos

Devuelve un identificador del recurso para el nuevo intérprete XML.

Ver también

  • xml_parser_create_ns() - Crea un analizador XML con soporte para espacios de nombres
  • xml_parser_free() - Liberar una analizador XML


Liberar una analizador XML

  • « xml_parser_create
  • xml_parser_get_option »
  • PHP Manual
  • Funciones del Intérprete XML
  • Liberar una analizador XML

xml_parser_free

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_free — Liberar una analizador XML

Descripción

xml_parser_free ( resource $parser ) : bool

Liberar el parser XML dado.

Parámetros

parser
Una referencia a el analizador a liberar.

Valores devueltos

Ésta función devuelve false si parser no refiere a un analizador valido, o sino lo libera al analizador y devuelve true.


Obtiene el valor de las opciones de un intérprete XML

  • « xml_parser_free
  • xml_parser_set_option »
  • PHP Manual
  • Funciones del Intérprete XML
  • Obtiene el valor de las opciones de un intérprete XML

xml_parser_get_option

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_get_option — Obtiene el valor de las opciones de un intérprete XML

Descripción

xml_parser_get_option ( resource $parser , int $option ) : mixed

Obtiene el valor de una opción de un intérprete XML.

Parámetros

parser
Identificador del recurso del intéprete XML sobre el que se va a obtener el valor de la opción.
option
Indica cual es la opción para ir a buscar. Estan disponibles XML_OPTION_CASE_FOLDING y XML_OPTION_TARGET_ENCODING. Para su descripción ver xml_parser_set_option() .

Valores devueltos

Devuelve el valor de la opción. Puede devolver false si: parser no se refiere a un intérprete válido o si option no es válido, también generará un E_WARNING en ambos casos.


Configura las opciones en un intérprete XML

  • « xml_parser_get_option
  • xml_set_character_data_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura las opciones en un intérprete XML

xml_parser_set_option

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_set_option — Configura las opciones en un intérprete XML

Descripción

xml_parser_set_option ( resource $parser , int $option , mixed $value ) : bool

Configura una opción en un intérprete XML.

Parámetros

parser

Identificador del recurso del intérprete XML sobre el que se va a configurar el valor de la opción.

option

Cual es la opción para configurar. Véase más abajo.

Estan disponibles las siguientes opciones:

Opciones del intérprete XML
Option constant | Data type | Description
XML_OPTION_CASE_FOLDING | integer | Controla si case-folding está activada para este intérprete XML. Por defecto activado.
XML_OPTION_SKIP_TAGSTART | integer | Especifica el número de caracteres que seran omitidos al principio del nombre de una etiqueta.
XML_OPTION_SKIP_WHITE | integer | Especifica si hay que omitir los valores que consistan en espacios en blanco.
XML_OPTION_TARGET_ENCODING | string | Configura cual será el target encoding (codificación de caracteres de salida) para usar en este intérprete XML. Por defecto se establece la misma codificación de la fuente fuente usada por xml_parser_create(). Las codificaciones de destino soportadas son ISO-8859-1, US-ASCII y UTF-8.

value

El nuevo valor para la opción.

Valores devueltos

Devuelve true si se ha establecido el nuevo valor para la opción. Puede devolver false si: parser no se refiere a un intérprete válido, o si la opción no se ha podido configurar.


Configura el manejador de los datos de caracteres

  • « xml_parser_set_option
  • xml_set_default_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de los datos de caracteres

xml_set_character_data_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_character_data_handler — Configura el manejador de los datos de caracteres

Descripción

xml_set_character_data_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador de los datos de caracteres para el intérprete XML parser.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador de datos de caracteres.

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar dos parámetros:

handler ( resource $parser , string $data )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
data
El segundo parámetro, data, contiene los datos de caracteres como un string.

El manejador de datos de caracteres es llamado para cada pieza de un texto en el documento XML. Puede ser llamado multiples veces dentro de cada fragmento (por ejemplo, para strings que no son ASCII).

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Configura el manejador predeterminado

  • « xml_set_character_data_handler
  • xml_set_element_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador predeterminado

xml_set_default_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_default_handler — Configura el manejador predeterminado

Descripción

xml_set_default_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador predeterminado para el intérprete XML parser.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador predeterminado.

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar dos parámetros:

handler ( resource $parser , string $data )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
data
El segundo parámetro, data, contiene los datos de carateres. Esto puede ser la declaración XML, las declaraciones DOCTYPE, entidades u otros datos para los cuales no exista otro manejador.

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Configura los manejadores para los elementos de inicio y final

  • « xml_set_default_handler
  • xml_set_end_namespace_decl_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura los manejadores para los elementos de inicio y final

xml_set_element_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_element_handler — Configura los manejadores para los elementos de inicio y final

Descripción

xml_set_element_handler ( resource $parser , callable $start_element_handler , callable $end_element_handler ) : bool

Configura las funciones de los manejadores de elementos. start_element_handler y end_element_handler son strings que contienen los nombres de funciones que deben existir cuando xml_parse() sea llamado por parser.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se van a configurar las funciones del manejador de elementos de inicio y final.

start_element_handler

La función llamada mediante start_element_handler debe aceptar tres parámetros:

start_element_handler ( resource $parser , string $name , array $attribs )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
name
El segundo parámetro, name, contiene el nombre del elemento por el cual el manejador es llamado. Si case-folding está activado para este intérprete, el elemento name estará en letras mayúsculas.
attribs
El tercer parámetroattribs, contiene un array asociativo con los atributos del elemento (si hay alguno). Las claves de este array son los nombres de atributo, los valores son los valores de los atributos. Los nombres de los atributos están en mayúsculas case-folded siguiendo el mismo criterio que los nombres de los elementos. Los valores de los atributos no sufren las consecuencias de case-folding. El orden original de los atributos puede ser recuperado recorriendo attribs de manera normal, usando each(). La primera clave en el array es el primer atributo, y así sucesivamente.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

end_element_handler

La función llamada mediante end_element_handler debe aceptar dos parámetros:

end_element_handler ( resource $parser , string $name )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
name
El segundo parámetro, name, contiene el nombre del elemento por el cual el manejador es llamado. Si case-folding está activado para este intérprete, el elemento name estará en letras mayúsculas.

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Configura el manejador de declaración de final del namespace

  • « xml_set_element_handler
  • xml_set_external_entity_ref_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de declaración de final del namespace

xml_set_end_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_set_end_namespace_decl_handler — Configura el manejador de declaración de final del namespace

Descripción

xml_set_end_namespace_decl_handler ( resource $parser , callable $handler ) : bool

Configura un manejador para ser llamado cuando se salga del alcance de una declaración de namespace. Se llamará por cada declaración de namespace, después del manejador de etiqueta final del elemento en el cual el namespace fue declarado.

Parámetros

parser

Identificador del recurso del intérprete XML.

handler

handler es una cadena que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar dos parámetros, y deberia devolver un número entero. Si el valor devuelto desde el manejador es false (lo cual ocurrirá si no se devulve un valor), el intérprete XML detendrá el analizado y xml_get_error_code() devolverá XML_ERROR_EXTERNAL_ENTITY_HANDLING.

handler ( resource $parser , string $prefix )
parser
El primer parámetro, parser, es una referencia al intérprete XML que llama al manejador.
prefix
El prefijo es una cadena que se utiliza para hacer referencia al namespace dentro de un objeto XML.

Si la función del manejador se configura como una cadena vacía, o false, el manejador en cuestión es deshabilitado.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Notas

Nota:

Este evento no es soportado bajo LibXML.

Ver también

  • xml_set_start_namespace_decl_handler() - Configura el manejador de declaración de inicio del namespace


Configura el manejador de referencia a entidades externas

  • « xml_set_end_namespace_decl_handler
  • xml_set_notation_decl_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de referencia a entidades externas

xml_set_external_entity_ref_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_external_entity_ref_handler — Configura el manejador de referencia a entidades externas

Descripción

xml_set_external_entity_ref_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador de referencia a entidades externas para el intérprete XML parser.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador de referencia a entidades externas

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar cinco parámetros, y deberia devolver un número entero. Si el valor devuelto desde el manejador es false (lo cual ocurrirá si no se devulve un valor), el intérprete XML detendrá el analizado y xml_get_error_code() devolverá XML_ERROR_EXTERNAL_ENTITY_HANDLING.

handler ( resource $parser , string $open_entity_names , string $base , string $system_id , string $public_id )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
open_entity_names
El segundo parámetro, open_entity_names, es una lista separada por espacios de los nombres de las entidades que estan abiertas para el análisis de esta entidad (incluyendo el nombre de la entidad referenciada).
base
Esta es la base para resolver el identificador de sistema (system_id) de la declaración de notación. Actualmente este parámetro siempre se establecerá como una cadena vacia.
system_id
El cuarto parámetro, system_id, es el identificador de sistema tal como se especifica en la declaración de entidad.
public_id
El quinto parámetro, public_id, es el identificador público tal como se especifica en la declaración de entidad, o una cadena vacia si no se habia especificado; en el identificador público el espacio en blanco se habrá normalizado como lo requerido mediante las especificaciones XML.

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Configura el manejador de declaraciones de notación

  • « xml_set_external_entity_ref_handler
  • xml_set_object »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de declaraciones de notación

xml_set_notation_decl_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_notation_decl_handler — Configura el manejador de declaraciones de notación

Descripción

xml_set_notation_decl_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador de declaraciones de notación (NOTATION) para el intérprete XML parser.

Una declaración de notación es parte del DTD del documento y tiene el siguiente formato:

<!NOTATION <parameter>name</parameter>
      { <parameter>systemId</parameter> | <parameter>publicId</parameter>?>
Para la definición de declaraciones de notación ver » sección 4.7 de las especificaciones XML 1.0 .

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador de declaración de notación.

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar cinco parámetros:

handler ( resource $parser , string $notation_name , string $base , string $system_id , string $public_id )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
notation_name
Esto es el name de la notación, como se describió arriba en el formato de notación.
base
Esta es la base para resolver el identificador de sistema (system_id) de la declaración de notación. Actualmente este parámetro siempre se establecerá como una cadena vacia.
system_id
Identificador de sistema de la declaración de notación externa.
public_id
Identificador público de la declaración de notación externa.

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Usa un intérprete XML Parser dentro de un objeto

  • « xml_set_notation_decl_handler
  • xml_set_processing_instruction_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Usa un intérprete XML Parser dentro de un objeto

xml_set_object

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_object — Usa un intérprete XML Parser dentro de un objeto

Descripción

xml_set_object ( resource $parser , object &$object ) : bool

Esta función permite usar parser dentro de object. Todas las funciones de retorno se podrian establecer con xml_set_element_handler(), etc y asumirlas como métodos de object.

Parámetros

parser

Identificador del recurso del intérprete XML para usar dentro del objeto.

object

El objeto donde usar el intérprete XML.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo xml_set_object()

<?php
class xml  {
    var $parser;

    function xml()
    {
        $this->parser = xml_parser_create();

        xml_set_object($this->parser, $this);
        xml_set_element_handler($this->parser, "tag_open", "tag_close");
        xml_set_character_data_handler($this->parser, "cdata");
    }

    function parse($data)
    {
        xml_parse($this->parser, $data);
    }

    function tag_open($parser, $tag, $attributes)
    {
        var_dump($parser, $tag, $attributes);
    }

    function cdata($parser, $cdata)
    {
        var_dump($parser, $cdata);
    }

    function tag_close($parser, $tag)
    {
        var_dump($parser, $tag);
    }

} // end of class xml

$xml_parser = new xml();
$xml_parser->parse("<A ID='hallo'>PHP</A>");
?>


Configura el manejador de instrucciones de proceso (PI)

  • « xml_set_object
  • xml_set_start_namespace_decl_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de instrucciones de proceso (PI)

xml_set_processing_instruction_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_processing_instruction_handler — Configura el manejador de instrucciones de proceso (PI)

Descripción

xml_set_processing_instruction_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador de instrucciones de proceso para el intérprete XML. parser.

Una instrucción de proceso tiene el siguiente formato:

<?
target data
?>
Se puede poner código PHP dentro de esa etiqueta, pero ser consciente de una limitación: en un XML PI, la etiqueta de cierre PI tag (?>) no puede ser entrecomillada, por lo que esta secuencia de caracteres no deberia aparecer en el código PHP embebido con PIs en documentos XML. Si esto sucede, el resto del código PHP, así como la etiqueta de cierre de PI "real", serán tratados como datos de caracteres.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador de instrucción de proceso.

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar tres parámetros:

handler ( resource $parser , string $target , string $data )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
target
El segundo parámetro, target, contiene el PI destino.
data
El tercer parámetro, data, contiene los datos del PI

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Configura el manejador de declaración de inicio del namespace

  • « xml_set_processing_instruction_handler
  • xml_set_unparsed_entity_decl_handler »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de declaración de inicio del namespace

xml_set_start_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_set_start_namespace_decl_handler — Configura el manejador de declaración de inicio del namespace

Descripción

xml_set_start_namespace_decl_handler ( resource $parser , callable $handler ) : bool

Configura un manejador para ser llamado cuando un namespace es declarado. La declaración de namespace ocurre dentro de las etiquetas de inicio. Sin embargo, el manejador inicial de declaración del namespace es llamado antes del manejador de etiqueta inicial para cada namespace declarado en esa etiqueta de inicio.

Parámetros

parser

Identificador del recurso del intérprete XML.

handler

handler es una cadena que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar tres parámetros, y deberia devolver un número entero. Si el valor devuelto desde el manejador es false (lo cual ocurrirá si no se devulve un valor), el intérprete XML detendrá el analizado y xml_get_error_code() devolverá XML_ERROR_EXTERNAL_ENTITY_HANDLING.

handler ( resource $parser , string $prefix , string $uri )
parser
El primer parámetro, parser, es una referencia al intérprete XML que llama al manejador.
prefix
El prefijo es una cadena que se utiliza para hacer referencia al namespace dentro de un objeto XML.
uri
Identificador de Recurso Uniforme (URI, por sus siglas en inglés) del namespace.

Si una función del manejador se configura como una cadena vacía, o false, el manejador en cuestión es deshabilitado.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • xml_set_end_namespace_decl_handler() - Configura el manejador de declaración de final del namespace


Configura el manejador de declaración de entidades no analizadas

  • « xml_set_start_namespace_decl_handler
  • XMLReader »
  • PHP Manual
  • Funciones del Intérprete XML
  • Configura el manejador de declaración de entidades no analizadas

xml_set_unparsed_entity_decl_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_unparsed_entity_decl_handler — Configura el manejador de declaración de entidades no analizadas

Descripción

xml_set_unparsed_entity_decl_handler ( resource $parser , callable $handler ) : bool

Configura la función del manejador de declaración de entidades no analizadas para el intérprete XML parser.

El handler será llamado si el intérprete XML encuentra una declaración de entidad externa con una declaración NDATA, como la siguiente:

<!ENTITY <parameter>name</parameter> {<parameter>publicId</parameter> | <parameter>systemId</parameter>}
        NDATA <parameter>notationName</parameter>

Para la definición de notación de NDATA ver » sección 4.2.2 de las especificaciones XML 1.0.

Parámetros

parser

Identificador del recurso del intérprete XML para el que se va a configurar la función del manejador de declaración de entidades no analizadas.

handler

handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada mediante handler debe aceptar seis parámetros:

handler ( resource $parser , string $entity_name , string $base , string $system_id , string $public_id , string $notation_name )
parser
El primer parámetro, parser, hace referencia al intérprete XML que llama al manejador.
entity_name
El nombre de la entidad que está a punto de definirse.
base
Esta es la base para resolver el identificador de sistema (system_id) de la declaración de notación. Actualmente este parámetro siempre se establecerá como una cadena vacia.
system_id
Identificador de sistema de la declaración de notación externa.
public_id
Identificador público de la declaración de notación externa.
notation_name
Nombre de la notación de esta entidad (ver xml_set_notation_decl_handler()).

Si la función del manejador se configura como una cadena vacia, o false, el manejador en cuestión se deshabilita.

Nota: En lugar del nombre de una función, se puede asignar un array que contenga la referencia a un objeto o el nombre de un método.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


XMLReader

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • XMLReader — The XMLReader class
    • XMLReader::close — Cierra la entrada del XMLReader
    • XMLReader::expand — Devuelve una copia del actual nodo como un objeto DOM
    • XMLReader::getAttribute — Obtiener el valor del atributo nombrado
    • XMLReader::getAttributeNo — Obtiene el valor de un atributo por el indice
    • XMLReader::getAttributeNs — Obtiene el valor de un atributo por su nombre local y URI
    • XMLReader::getParserProperty — Indica si la porpiedad especificada ha sido establecida
    • XMLReader::isValid — Indica si el documento analizado es válido
    • XMLReader::lookupNamespace — Busca el namespace para un prefijo
    • XMLReader::moveToAttribute — Mueve el cursor a un atributo nombrado
    • XMLReader::moveToAttributeNo — Mueve el cursor a un atributo por su índice
    • XMLReader::moveToAttributeNs — Mover el cursor a un atributo dado
    • XMLReader::moveToElement — Posiciona el cursor en el eleménto padre del actual atributo
    • XMLReader::moveToFirstAttribute — Posiciona el cursor en el primer atributo
    • XMLReader::moveToNextAttribute — Posiciona el cursor en el siguiente atributo
    • XMLReader::next — Mueve el cursor al siguiente nodo saltandose todos los subárboles
    • XMLReader::open — Establece el URI conteniendo el XML a analizar
    • XMLReader::read — Se mueve al siguiente nodo en el documento
    • XMLReader::readInnerXML — Recupera el XML del actual nodo
    • XMLReader::readOuterXML — Recupera el XML del actual nodo, incluyendo él mismo
    • XMLReader::readString — Lee el contenido del nodo actual como string
    • XMLReader::setParserProperty — Establecer las opciones del analizador
    • XMLReader::setRelaxNGSchema — Establece el nomb re del archivo o el URI para un esquema RelaxNG
    • XMLReader::setRelaxNGSchemaSource — Establece los datos contenidos en un esquema RelaxNG
    • XMLReader::setSchema — Valida el documento en contra del XSD
    • XMLReader::XML — Establece el contenido del XML a analizar


Introducción

La extensión XMLReader es un analizador de XML. El lector actúa como un cursor yendo hacia delante en el flujo del documento y deteniéndose en cada nodo del camino.

Codificación

Es importante observar que, internamente, libxml usa la codificación UTF-8, y por lo tanto, la codificación de los contenidos recuperados estará siempre en la codificación UTF-8.


Instalación

La extensión XMLReader inicialmente era una extensión PECL para PHP 5. Posteriormente se movió al código fuente de PHP a partir de PHP 5.1.0, y se habilitó de forma predeterminada a partir de PHP 5.1.2.

Esta extensión está habilitada de forma predeterminada. Se puede deshabilitar empleando la siguiente opción durante la compilación: --disable-xmlreader


  • « Configuración en tiempo de ejecución
  • XMLReader »
  • PHP Manual
  • Instalación/Configuración
  • Tipos de recursos

Tipos de recursos

Esta extensión no tiene ningún tipo de recurso definido.


The XMLReader class

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Introducción

La extensión XMLReader es un analizador de XML. El lector actúa como un cursor yendo hacia adelante en la corriente del documento y deteniéndose en cada nodo del camino.

Sinopsis de la Clase

XMLReader {
/* Constantes */
const int NONE = 0 ;
const int ELEMENT = 1 ;
const int ATTRIBUTE = 2 ;
const int TEXT = 3 ;
const int CDATA = 4 ;
const int ENTITY_REF = 5 ;
const int ENTITY = 6 ;
const int PI = 7 ;
const int COMMENT = 8 ;
const int DOC = 9 ;
const int DOC_TYPE = 10 ;
const int DOC_FRAGMENT = 11 ;
const int NOTATION = 12 ;
const int WHITESPACE = 13 ;
const int SIGNIFICANT_WHITESPACE = 14 ;
const int END_ELEMENT = 15 ;
const int END_ENTITY = 16 ;
const int XML_DECLARATION = 17 ;
const int LOADDTD = 1 ;
const int DEFAULTATTRS = 2 ;
const int VALIDATE = 3 ;
const int SUBST_ENTITIES = 4 ;
/* Propiedades */
public readonly int $attributeCount ;
public readonly string $baseURI ;
public readonly int $depth ;
public readonly bool $hasAttributes ;
public readonly bool $hasValue ;
public readonly bool $isDefault ;
public readonly bool $isEmptyElement ;
public readonly string $localName ;
public readonly string $name ;
public readonly string $namespaceURI ;
public readonly int $nodeType ;
public readonly string $prefix ;
public readonly string $value ;
public readonly string $xmlLang ;
/* Métodos */
public close ( ) : bool
public expand ( DOMNode $basenode = ? ) : DOMNode
public getAttribute ( string $name ) : string
public getAttributeNo ( int $index ) : string
public getAttributeNs ( string $localName , string $namespaceURI ) : string
public getParserProperty ( int $property ) : bool
public isValid ( ) : bool
public lookupNamespace ( string $prefix ) : bool
public moveToAttribute ( string $name ) : bool
public moveToAttributeNo ( int $index ) : bool
public moveToAttributeNs ( string $localName , string $namespaceURI ) : bool
public moveToElement ( ) : bool
public moveToFirstAttribute ( ) : bool
public moveToNextAttribute ( ) : bool
public next ( string $localname = ? ) : bool
public open ( string $URI , string $encoding = ? , int $options = 0 ) : bool
public read ( ) : bool
public readInnerXML ( ) : string
public readOuterXML ( ) : string
public readString ( ) : string
public setParserProperty ( int $property , bool $value ) : bool
public setRelaxNGSchema ( string $filename ) : bool
public setRelaxNGSchemaSource ( string $source ) : bool
public setSchema ( string $filename ) : bool
public xml ( string $source , string $encoding = ? , int $options = 0 ) : bool
}

Propiedades

attributeCount

El número de atributos en el nodo

baseURI

La base URI del nodo

depth

La profundidad del nodo en el árbol, empezando en 0

hasAttributes

Indica si el nodo tiene atributos

hasValue

Indica si el nodo tiene un valor de texto

isDefault

Indica si el atributo está por defecto del DTD

isEmptyElement

Indica si el nodo es un elemento vacio de etiqueta

localName

El nombre local del nodo

name

El nombre calificado del nodo

namespaceURI

El URI del namespace asociado con el nodo

nodeType

El tipo de nodo para el nodo

prefix

El prefijo del namespace asociado con el nodo

value

El valor de texto del nodo

xmlLang

El xml: El lang scope el cual el nodo reside

Constantes predefinidas

XMLReader Node Types

XMLReader::NONE

Sin tipo de nodo

XMLReader::ELEMENT

Empieza el eleménto

XMLReader::ATTRIBUTE

El atributo del nodo

XMLReader::TEXT

El nodo de texto

XMLReader::CDATA

El CDATA del nodo

XMLReader::ENTITY_REF

La entidad de refencia del nodo

XMLReader::ENTITY

La entidad de declaración del nodo

XMLReader::PI

La instrucción de proceso del nodo

XMLReader::COMMENT

El comentario del nodo

XMLReader::DOC

El documento del nodo

XMLReader::DOC_TYPE

El tipo de documento del nodo

XMLReader::DOC_FRAGMENT

El fragmento del documento del nodo

XMLReader::NOTATION

La notación del nodo

XMLReader::WHITESPACE

El espacio en blanco del nodo

XMLReader::SIGNIFICANT_WHITESPACE

El espacio en blanco significante del nodo

XMLReader::END_ELEMENT

El fin del eleménto

XMLReader::END_ENTITY

La entidad final

XMLReader::XML_DECLARATION

La declaración XML del nodo

XMLReader Parser Options

XMLReader::LOADDTD

Carga el DTD pero no lo valida

XMLReader::DEFAULTATTRS

Carga el DTD y los atributos por defecto pero no los valida

XMLReader::VALIDATE

Carga el DTD y valida el analizado en blanco

XMLReader::SUBST_ENTITIES

Substituye las entidades y expande las referencias

Tabla de contenidos

  • XMLReader::close — Cierra la entrada del XMLReader
  • XMLReader::expand — Devuelve una copia del actual nodo como un objeto DOM
  • XMLReader::getAttribute — Obtiener el valor del atributo nombrado
  • XMLReader::getAttributeNo — Obtiene el valor de un atributo por el indice
  • XMLReader::getAttributeNs — Obtiene el valor de un atributo por su nombre local y URI
  • XMLReader::getParserProperty — Indica si la porpiedad especificada ha sido establecida
  • XMLReader::isValid — Indica si el documento analizado es válido
  • XMLReader::lookupNamespace — Busca el namespace para un prefijo
  • XMLReader::moveToAttribute — Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNo — Mueve el cursor a un atributo por su índice
  • XMLReader::moveToAttributeNs — Mover el cursor a un atributo dado
  • XMLReader::moveToElement — Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToFirstAttribute — Posiciona el cursor en el primer atributo
  • XMLReader::moveToNextAttribute — Posiciona el cursor en el siguiente atributo
  • XMLReader::next — Mueve el cursor al siguiente nodo saltandose todos los subárboles
  • XMLReader::open — Establece el URI conteniendo el XML a analizar
  • XMLReader::read — Se mueve al siguiente nodo en el documento
  • XMLReader::readInnerXML — Recupera el XML del actual nodo
  • XMLReader::readOuterXML — Recupera el XML del actual nodo, incluyendo él mismo
  • XMLReader::readString — Lee el contenido del nodo actual como string
  • XMLReader::setParserProperty — Establecer las opciones del analizador
  • XMLReader::setRelaxNGSchema — Establece el nomb re del archivo o el URI para un esquema RelaxNG
  • XMLReader::setRelaxNGSchemaSource — Establece los datos contenidos en un esquema RelaxNG
  • XMLReader::setSchema — Valida el documento en contra del XSD
  • XMLReader::XML — Establece el contenido del XML a analizar


Cierra la entrada del XMLReader

  • « XMLReader
  • XMLReader::expand »
  • PHP Manual
  • XMLReader
  • Cierra la entrada del XMLReader

XMLReader::close

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::close — Cierra la entrada del XMLReader

Descripción

public XMLReader::close ( ) : bool

Cierra la entrada del objeto XMLReader que es actualmente análizado.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::open() - Establece el URI conteniendo el XML a analizar
  • XMLReader::xml() - Establece el contenido del XML a analizar


Devuelve una copia del actual nodo como un objeto DOM

  • « XMLReader::close
  • XMLReader::getAttribute »
  • PHP Manual
  • XMLReader
  • Devuelve una copia del actual nodo como un objeto DOM

XMLReader::expand

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::expand — Devuelve una copia del actual nodo como un objeto DOM

Descripción

public XMLReader::expand ( DOMNode $basenode = ? ) : DOMNode

Éste metodo copia el nodo actual y devuelve el apropiado objeto DOM.

Valores devueltos

El resultante DOMNode o false en caso de error.


Obtiener el valor del atributo nombrado

  • « XMLReader::expand
  • XMLReader::getAttributeNo »
  • PHP Manual
  • XMLReader
  • Obtiener el valor del atributo nombrado

XMLReader::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttribute — Obtiener el valor del atributo nombrado

Descripción

public XMLReader::getAttribute ( string $name ) : string

Devuelve el valor del atributo nombrado o null si el atributo no existe o no está posicionado en un eleménto del nodo.

Parámetros

name

El nombre del atributo.

Valores devueltos

El valor del atributo, o null si no se encuetra un atributo con el nombre dado por name o no está posicionado en un nodo de elemento.

Historial de cambios

Versión | Descripción
5.1.3 | Devuelve null si no se encuentra ningún atributo. Antes, devolvía una cadena de texto vacía.

Ver también

  • XMLReader::getAttributeNo() - Obtiene el valor de un atributo por el indice
  • XMLReader::getAttributeNs() - Obtiene el valor de un atributo por su nombre local y URI


Obtiene el valor de un atributo por el indice

  • « XMLReader::getAttribute
  • XMLReader::getAttributeNs »
  • PHP Manual
  • XMLReader
  • Obtiene el valor de un atributo por el indice

XMLReader::getAttributeNo

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttributeNo — Obtiene el valor de un atributo por el indice

Descripción

public XMLReader::getAttributeNo ( int $index ) : string

Devuelve el valor de un atributo basado en su posición o una cadena vacia si el atributo no existe o no está posicionado en un eleménto del nodo.

Parámetros

index

La posición del atributo.

Valores devueltos

El valor del atributo, o una cadena vacia si el atributo no existe en el index o no está posicionado en el eleménto.

Ver también

  • XMLReader::getAttribute() - Obtiener el valor del atributo nombrado
  • XMLReader::getAttributeNs() - Obtiene el valor de un atributo por su nombre local y URI


Obtiene el valor de un atributo por su nombre local y URI

  • « XMLReader::getAttributeNo
  • XMLReader::getParserProperty »
  • PHP Manual
  • XMLReader
  • Obtiene el valor de un atributo por su nombre local y URI

XMLReader::getAttributeNs

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttributeNs — Obtiene el valor de un atributo por su nombre local y URI

Descripción

public XMLReader::getAttributeNs ( string $localName , string $namespaceURI ) : string

Devuelve el valor de un atributo por su nombre y URI del namespace o una cadena vacia si el atributo no existe o no está posicionado en el eleménto.

Parámetros

localName

El nombre local.

namespaceURI

El URI del namespace.

Valores devueltos

El valor del atributo, o una cadena vacia si ningun atributo con el localName dado y el namespaceURI es encontrado o no está posicionado en el eleménto.

Ver también

  • XMLReader::getAttribute() - Obtiener el valor del atributo nombrado
  • XMLReader::getAttributeNo() - Obtiene el valor de un atributo por el indice


Indica si la porpiedad especificada ha sido establecida

  • « XMLReader::getAttributeNs
  • XMLReader::isValid »
  • PHP Manual
  • XMLReader
  • Indica si la porpiedad especificada ha sido establecida

XMLReader::getParserProperty

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getParserProperty — Indica si la porpiedad especificada ha sido establecida

Descripción

public XMLReader::getParserProperty ( int $property ) : bool

Indica si la porpiedad especificada ha sido establecida.

Parámetros

property

Una de las constantes analizadoras de opción.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::setParserProperty() - Establecer las opciones del analizador


Indica si el documento analizado es válido

  • « XMLReader::getParserProperty
  • XMLReader::lookupNamespace »
  • PHP Manual
  • XMLReader
  • Indica si el documento analizado es válido

XMLReader::isValid

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::isValid — Indica si el documento analizado es válido

Descripción

public XMLReader::isValid ( ) : bool

Devuelve un booleano indicando si el documento siendo analizado es actualmente válido.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Validando el XML

<?php
$xml = XMLReader::open('test.xml');

// Debe estar habilitada la opción del analizador para
// que este método funcione correctamente
$xml->setParserProperty(XMLReader::VALIDATE, true);

var_dump($xml->isValid());
?>

Notas

Nota: Esto comprueba el nodo actual, no el documento completo.

Ver también

  • XMLReader::setParserProperty() - Establecer las opciones del analizador
  • XMLReader::setRelaxNGSchema() - Establece el nomb re del archivo o el URI para un esquema RelaxNG
  • XMLReader::setRelaxNGSchemaSource() - Establece los datos contenidos en un esquema RelaxNG
  • XMLReader::setSchema() - Valida el documento en contra del XSD


Busca el namespace para un prefijo

  • « XMLReader::isValid
  • XMLReader::moveToAttribute »
  • PHP Manual
  • XMLReader
  • Busca el namespace para un prefijo

XMLReader::lookupNamespace

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::lookupNamespace — Busca el namespace para un prefijo

Descripción

public XMLReader::lookupNamespace ( string $prefix ) : bool

Busca el ámbito del namespace para un prefijo dado.

Parámetros

prefix

La cadena conteniendo el prefijo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Mueve el cursor a un atributo nombrado

  • « XMLReader::lookupNamespace
  • XMLReader::moveToAttributeNo »
  • PHP Manual
  • XMLReader
  • Mueve el cursor a un atributo nombrado

XMLReader::moveToAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttribute — Mueve el cursor a un atributo nombrado

Descripción

public XMLReader::moveToAttribute ( string $name ) : bool

Posciciona el cursor a un atributo nombrado.

Parámetros

name

El nombre del atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttributeNo() - Mueve el cursor a un atributo por su índice
  • XMLReader::moveToAttributeNs() - Mover el cursor a un atributo dado
  • XMLReader::moveToFirstAttribute() - Posiciona el cursor en el primer atributo


Mueve el cursor a un atributo por su índice

  • « XMLReader::moveToAttribute
  • XMLReader::moveToAttributeNs »
  • PHP Manual
  • XMLReader
  • Mueve el cursor a un atributo por su índice

XMLReader::moveToAttributeNo

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttributeNo — Mueve el cursor a un atributo por su índice

Descripción

public XMLReader::moveToAttributeNo ( int $index ) : bool

Coloca el cursor en el atributo en función de su posición.

Parámetros

index

La posición de el atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNs() - Mover el cursor a un atributo dado
  • XMLReader::moveToFirstAttribute() - Posiciona el cursor en el primer atributo


Mover el cursor a un atributo dado

  • « XMLReader::moveToAttributeNo
  • XMLReader::moveToElement »
  • PHP Manual
  • XMLReader
  • Mover el cursor a un atributo dado

XMLReader::moveToAttributeNs

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttributeNs — Mover el cursor a un atributo dado

Descripción

public XMLReader::moveToAttributeNs ( string $localName , string $namespaceURI ) : bool

Posiciona el cursor en el atributo dado en el espacio de nombres especificado.

Parámetros

localName

El nombre local.

namespaceURI

El URI namespace.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNo() - Mueve el cursor a un atributo por su índice
  • XMLReader::moveToFirstAttribute() - Posiciona el cursor en el primer atributo


Posiciona el cursor en el eleménto padre del actual atributo

  • « XMLReader::moveToAttributeNs
  • XMLReader::moveToFirstAttribute »
  • PHP Manual
  • XMLReader
  • Posiciona el cursor en el eleménto padre del actual atributo

XMLReader::moveToElement

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToElement — Posiciona el cursor en el eleménto padre del actual atributo

Descripción

public XMLReader::moveToElement ( ) : bool

Posiciona el cursor en el eleménto padre del actual atributo.

Valores devueltos

Devuelve true si es satisfactorio y false si falla o no está posicionado en el atributo cuando éste método es llamado.

Ver también

  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNo() - Mueve el cursor a un atributo por su índice
  • XMLReader::moveToAttributeNs() - Mover el cursor a un atributo dado
  • XMLReader::moveToFirstAttribute() - Posiciona el cursor en el primer atributo


Posiciona el cursor en el primer atributo

  • « XMLReader::moveToElement
  • XMLReader::moveToNextAttribute »
  • PHP Manual
  • XMLReader
  • Posiciona el cursor en el primer atributo

XMLReader::moveToFirstAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToFirstAttribute — Posiciona el cursor en el primer atributo

Descripción

public XMLReader::moveToFirstAttribute ( ) : bool

Mueve el cursor al primer atributo.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNo() - Mueve el cursor a un atributo por su índice
  • XMLReader::moveToAttributeNs() - Mover el cursor a un atributo dado
  • XMLReader::moveToNextAttribute() - Posiciona el cursor en el siguiente atributo


Posiciona el cursor en el siguiente atributo

  • « XMLReader::moveToFirstAttribute
  • XMLReader::next »
  • PHP Manual
  • XMLReader
  • Posiciona el cursor en el siguiente atributo

XMLReader::moveToNextAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToNextAttribute — Posiciona el cursor en el siguiente atributo

Descripción

public XMLReader::moveToNextAttribute ( ) : bool

Posiciona el cursor en el siguiente atributo si se encuentra en un atributo o lo mueve al primer atributo si se encuentrae un eleménto.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::moveToAttributeNo() - Mueve el cursor a un atributo por su índice
  • XMLReader::moveToAttributeNs() - Mover el cursor a un atributo dado
  • XMLReader::moveToFirstAttribute() - Posiciona el cursor en el primer atributo


Mueve el cursor al siguiente nodo saltandose todos los subárboles

  • « XMLReader::moveToNextAttribute
  • XMLReader::open »
  • PHP Manual
  • XMLReader
  • Mueve el cursor al siguiente nodo saltandose todos los subárboles

XMLReader::next

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::next — Mueve el cursor al siguiente nodo saltandose todos los subárboles

Descripción

public XMLReader::next ( string $localname = ? ) : bool

Posiciona el cursor al siguiente nodo saltandose todos los subárboles.

Parámetros

localname

El nodo del siguiente nodoa mover el cursor.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToNextAttribute() - Posiciona el cursor en el siguiente atributo
  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado


Establece el URI conteniendo el XML a analizar

  • « XMLReader::next
  • XMLReader::read »
  • PHP Manual
  • XMLReader
  • Establece el URI conteniendo el XML a analizar

XMLReader::open

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::open — Establece el URI conteniendo el XML a analizar

Descripción

public XMLReader::open ( string $URI , string $encoding = ? , int $options = 0 ) : bool

Establece el URI que contiene el XML a ser analizado.

Parámetros

URI

El URI señalado para el documento.

encoding

El documento codificado o null.

options

Una mascara de bit de las contantes de LIBXML_*.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si es llamado de forma estática, devuelve un XMLReader o false en caso de error.

Errores/Excepciones

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Historial de cambios

Versión | Descripción
5.2.0 | encoding y options fueron agregadas.

Ver también

  • XMLReader::xml() - Establece el contenido del XML a analizar
  • XMLReader::close() - Cierra la entrada del XMLReader


Se mueve al siguiente nodo en el documento

  • « XMLReader::open
  • XMLReader::readInnerXML »
  • PHP Manual
  • XMLReader
  • Se mueve al siguiente nodo en el documento

XMLReader::read

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::read — Se mueve al siguiente nodo en el documento

Descripción

public XMLReader::read ( ) : bool

Mueve el cursor al siguiente nodo en el documento.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::moveToElement() - Posiciona el cursor en el eleménto padre del actual atributo
  • XMLReader::moveToAttribute() - Mueve el cursor a un atributo nombrado
  • XMLReader::next() - Mueve el cursor al siguiente nodo saltandose todos los subárboles


Recupera el XML del actual nodo

  • « XMLReader::read
  • XMLReader::readOuterXML »
  • PHP Manual
  • XMLReader
  • Recupera el XML del actual nodo

XMLReader::readInnerXML

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readInnerXML — Recupera el XML del actual nodo

Descripción

public XMLReader::readInnerXML ( ) : string

Lee el contenido del actual nodo, incluyendo notas pequeñas y marcado.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Returns the contents of the current node as a string. Empty string on failure.

Notas

Precaución

Esta función sólo esta disponible cuando PHP ha sido compilado con libxml 20620 o superior.

Ver también

  • XMLReader::readString() - Lee el contenido del nodo actual como string
  • XMLReader::readOuterXML() - Recupera el XML del actual nodo, incluyendo él mismo
  • XMLReader::expand() - Devuelve una copia del actual nodo como un objeto DOM


Recupera el XML del actual nodo, incluyendo él mismo

  • « XMLReader::readInnerXML
  • XMLReader::readString »
  • PHP Manual
  • XMLReader
  • Recupera el XML del actual nodo, incluyendo él mismo

XMLReader::readOuterXML

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readOuterXML — Recupera el XML del actual nodo, incluyendo él mismo

Descripción

public XMLReader::readOuterXML ( ) : string

Lee el contenido del actual nodo, incluyendo el nodo mismo.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el contenido del actual nodo, incluyendo el de él mismo, como una cadena. Cadena vacía en fallo.

Notas

Precaución

Esta función sólo esta disponible cuando PHP ha sido compilado con libxml 20620 o superior.

Ver también

  • XMLReader::readString() - Lee el contenido del nodo actual como string
  • XMLReader::readInnerXML() - Recupera el XML del actual nodo
  • XMLReader::expand() - Devuelve una copia del actual nodo como un objeto DOM


Lee el contenido del nodo actual como string

  • « XMLReader::readOuterXML
  • XMLReader::setParserProperty »
  • PHP Manual
  • XMLReader
  • Lee el contenido del nodo actual como string

XMLReader::readString

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readString — Lee el contenido del nodo actual como string

Descripción

public XMLReader::readString ( ) : string

Lee el contenido del nodo actual como string.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el contenido del nodo actual como cadena. En caso de error devuelve una cadena vacía.

Notas

Precaución

Esta función sólo esta disponible cuando PHP ha sido compilado con libxml 20620 o superior.

Ver también

  • XMLReader::readOuterXML() - Recupera el XML del actual nodo, incluyendo él mismo
  • XMLReader::readInnerXML() - Recupera el XML del actual nodo
  • XMLReader::expand() - Devuelve una copia del actual nodo como un objeto DOM


Establecer las opciones del analizador

  • « XMLReader::readString
  • XMLReader::setRelaxNGSchema »
  • PHP Manual
  • XMLReader
  • Establecer las opciones del analizador

XMLReader::setParserProperty

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setParserProperty — Establecer las opciones del analizador

Descripción

public XMLReader::setParserProperty ( int $property , bool $value ) : bool

Establece las opciones del analizador. Las opciones deben ser establecidas después de
llamar a XMLReader::open() o
a XMLReader::xml(), y antes
de la primera llamada a XMLReader::read().

Parámetros

property

Una de las constantes de opción del analizador.

value

Si se establece a true la opción será habilitada, de otra manera será deshabilitada.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.


Establece el nomb re del archivo o el URI para un esquema RelaxNG

  • « XMLReader::setParserProperty
  • XMLReader::setRelaxNGSchemaSource »
  • PHP Manual
  • XMLReader
  • Establece el nomb re del archivo o el URI para un esquema RelaxNG

XMLReader::setRelaxNGSchema

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setRelaxNGSchema — Establece el nomb re del archivo o el URI para un esquema RelaxNG

Descripción

public XMLReader::setRelaxNGSchema ( string $filename ) : bool

Establece el nomb re del archivo o el URI para un esquema RelaxNG a usar para validación.

Parámetros

filename

El nombre del archivo o apuntador URI a un esquema RelaxNG.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::setRelaxNGSchemaSource() - Establece los datos contenidos en un esquema RelaxNG
  • XMLReader::setSchema() - Valida el documento en contra del XSD
  • XMLReader::isValid() - Indica si el documento analizado es válido


Establece los datos contenidos en un esquema RelaxNG

  • « XMLReader::setRelaxNGSchema
  • XMLReader::setSchema »
  • PHP Manual
  • XMLReader
  • Establece los datos contenidos en un esquema RelaxNG

XMLReader::setRelaxNGSchemaSource

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setRelaxNGSchemaSource — Establece los datos contenidos en un esquema RelaxNG

Descripción

public XMLReader::setRelaxNGSchemaSource ( string $source ) : bool

Establece los datos contenidos en un esquema RelaxNG a usar para validación.

Parámetros

source

SCadena que contiene el esquema RelaxNG.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XMLReader::setRelaxNGSchema() - Establece el nomb re del archivo o el URI para un esquema RelaxNG
  • XMLReader::setSchema() - Valida el documento en contra del XSD
  • XMLReader::isValid() - Indica si el documento analizado es válido


Valida el documento en contra del XSD

  • « XMLReader::setRelaxNGSchemaSource
  • XMLReader::XML »
  • PHP Manual
  • XMLReader
  • Valida el documento en contra del XSD

XMLReader::setSchema

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::setSchema — Valida el documento en contra del XSD

Descripción

public XMLReader::setSchema ( string $filename ) : bool

Usa el esquema W3C XSD para validar el documento como es procesado. La activación solo es posible antes de la primera lectura o Read().

Parámetros

filename

El nombre del archivo del esquema XSD.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Errores/Excepciones

Las cuestiones E_WARNING si la libxml fue construida sin el esquema de soporte, el esquema contiene errores si el XMLReader::read() ya ha sido llamado.

Notas

Precaución

Esta función sólo esta disponible cuando PHP ha sido compilado con libxml 20620 o superior.

Ver también

  • XMLReader::setRelaxNGSchema() - Establece el nomb re del archivo o el URI para un esquema RelaxNG
  • XMLReader::setRelaxNGSchemaSource() - Establece los datos contenidos en un esquema RelaxNG
  • XMLReader::isValid() - Indica si el documento analizado es válido


Establece el contenido del XML a analizar

  • « XMLReader::setSchema
  • XMLWriter »
  • PHP Manual
  • XMLReader
  • Establece el contenido del XML a analizar

XMLReader::XML

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::XML — Establece el contenido del XML a analizar

Descripción

public XMLReader::xml ( string $source , string $encoding = ? , int $options = 0 ) : bool

Establece el contenido del XML a analizar.

Parámetros

source

La cadena que contiene el XML a ser analizado.

encoding

La codificación del documento o null.

options

Una mascara bit de la constante LIBXML_*.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error. Si es llamado de forma estática, devuelve un XMLReader o false en caso de error.

Errores/Excepciones

Este método puede ser llamado de forma estática, pero lanzará un error E_STRICT.

Historial de cambios

Versión | Descripción
5.2.0 | encoding ay options fueron agregados.

Ver también

  • XMLReader::open() - Establece el URI conteniendo el XML a analizar
  • XMLReader::close() - Cierra la entrada del XMLReader


XMLWriter

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Crear un simple documento XML
    • Trabajar con espacios de nombres XML
    • Trabajando con el OO API
  • XMLWriter — La clase XMLWriter
    • XMLWriter::endAttribute — End attribute
    • XMLWriter::endCdata — End current CDATA
    • XMLWriter::endComment — Create end comment
    • XMLWriter::endDocument — End current document
    • XMLWriter::endDtd — End current DTD
    • XMLWriter::endDtdAttlist — End current DTD AttList
    • XMLWriter::endDtdElement — End current DTD element
    • XMLWriter::endDtdEntity — End current DTD Entity
    • XMLWriter::endElement — End current element
    • XMLWriter::endPi — End current PI
    • XMLWriter::flush — Flush current buffer
    • XMLWriter::fullEndElement — End current element
    • XMLWriter::openMemory — Create new xmlwriter using memory for string output
    • XMLWriter::openUri — Create new xmlwriter using source uri for output
    • XMLWriter::outputMemory — Returns current buffer
    • XMLWriter::setIndent — Toggle indentation on/off
    • XMLWriter::setIndentString — Set string used for indenting
    • XMLWriter::startAttribute — Create start attribute
    • XMLWriter::startAttributeNs — Create start namespaced attribute
    • XMLWriter::startCdata — Create start CDATA tag
    • XMLWriter::startComment — Create start comment
    • XMLWriter::startDocument — Create document tag
    • XMLWriter::startDtd — Create start DTD tag
    • XMLWriter::startDtdAttlist — Create start DTD AttList
    • XMLWriter::startDtdElement — Create start DTD element
    • XMLWriter::startDtdEntity — Create start DTD Entity
    • XMLWriter::startElement — Create start element tag
    • XMLWriter::startElementNs — Create start namespaced element tag
    • XMLWriter::startPi — Create start PI tag
    • XMLWriter::text — Write text
    • XMLWriter::writeAttribute — Write full attribute
    • XMLWriter::writeAttributeNs — Write full namespaced attribute
    • XMLWriter::writeCdata — Write full CDATA tag
    • XMLWriter::writeComment — Write full comment tag
    • XMLWriter::writeDtd — Write full DTD tag
    • XMLWriter::writeDtdAttlist — Write full DTD AttList tag
    • XMLWriter::writeDtdElement — Write full DTD element tag
    • XMLWriter::writeDtdEntity — Write full DTD Entity tag
    • XMLWriter::writeElement — Write full element tag
    • XMLWriter::writeElementNs — Write full namespaced element tag
    • XMLWriter::writePi — Writes a PI
    • XMLWriter::writeRaw — Write a raw XML text


Introducción

Esta es la extensión XMLWriter. Envuelve a la API xmlWriter de libxml.

Esta extensión representa un escritor que provee medios no almacenados en caché de sólo avance para la generación de flujos o ficheros con datos XML.

Esta extensión se puede usar con el estilo orientado a objetos o con el procedimental. Cada método documentado describe la llamada procedimental alternativa.


Instalación

La extensión XMLWriter inicialmente era una extensión PECL para PHP 5. Posteriormente se añadió al código fuente de PHP a partir de PHP 5.1.2. Esta extensión está habilitada de forma predeterminada.

Esta extensión está habilitada de forma predeterminada. Se puede deshabilitar empleando la siguiente opción durante la compilación: --disable-xmlwriter


Tipos de recursos

Hay un recurso usado por la versión procedimental de la extensión XMLWriter: el devuelto por xmlwriter_open_memory() o xmlwriter_open_uri().


  • « Tipos de recursos
  • Ejemplos »
  • PHP Manual
  • XMLWriter
  • Constantes predefinidas

Constantes predefinidas

Esta extensión no tiene ninguna constante definida.


Ejemplos

Tabla de contenidos

  • Crear un simple documento XML
  • Trabajar con espacios de nombres XML
  • Trabajando con el OO API


Crear un simple documento XML

Este ejemplo muestra cómo utilizar XMLWriter para crear un documento XML en memoria.

Ejemplo #1 Crear un simple documento XML

<?php

$xw = xmlwriter_open_memory();
xmlwriter_set_indent($xw, 1);
$res = xmlwriter_set_indent_string($xw, ' ');

xmlwriter_start_document($xw, '1.0', 'UTF-8');

// A first element
xmlwriter_start_element($xw, 'tag1');

// Attribute 'att1' for element 'tag1'
xmlwriter_start_attribute($xw, 'att1');
xmlwriter_text($xw, 'valueofatt1');
xmlwriter_end_attribute($xw);

xmlwriter_write_comment($xw, 'this is a comment.');

// Start a child element
xmlwriter_start_element($xw, 'tag11');
xmlwriter_text($xw, 'This is a sample text, ä');
xmlwriter_end_element($xw); // tag11

xmlwriter_end_element($xw); // tag1

// CDATA
xmlwriter_start_element($xw, 'testc');
xmlwriter_write_cdata($xw, "This is cdata content");
xmlwriter_end_element($xw); // testc

xmlwriter_start_element($xw, 'testc');
xmlwriter_start_cdata($xw);
xmlwriter_text($xw, "test cdata2");
xmlwriter_end_cdata($xw);
xmlwriter_end_element($xw); // testc

// A processing instruction
xmlwriter_start_pi($xw, 'php');
xmlwriter_text($xw, '$foo=2;echo $foo;');
xmlwriter_end_pi($xw);

xmlwriter_end_document($xw);

echo xmlwriter_output_memory($xw);

El resultado del ejemplo sería:

<?xml version="1.0" encoding="UTF-8"?>
<tag1 att1="valueofatt1">
 <!--this is a comment.-->
 <tag11>This is a sample text, ä</tag11>
</tag1>
<testc><![CDATA[This is cdata content]]></testc>
<testc><![CDATA[test cdata2]]></testc>
<?php $foo=2;echo $foo;?>


Trabajar con espacios de nombres XML

Este ejemplo muestra cómo crear elementos XML con espacio de nombres.

Ejemplo #1 Trabajar con espacios de nombres XML

<?php

$xw = xmlwriter_open_memory();
xmlwriter_set_indent($xw, 1);
$res = xmlwriter_set_indent_string($xw, ' ');

xmlwriter_start_document($xw, '1.0', 'UTF-8');
// A first element
xmlwriter_start_element_ns($xw,'prefix', 'books', 'uri');
xmlwriter_start_attribute($xw, 'isbn');

xmlwriter_start_attribute_ns($xw, 'prefix', 'isbn', 'uri');
xmlwriter_end_attribute($xw);

xmlwriter_end_attribute($xw);

xmlwriter_text($xw, 'book1');
xmlwriter_end_element($xw);

xmlwriter_end_document($xw);

echo xmlwriter_output_memory($xw);

El resultado del ejemplo sería:

<?xml version="1.0" encoding="UTF-8"?>
<prefix:books isbn="" prefix:isbn="" xmlns:prefix="uri">book1</prefix:books>


Trabajando con el OO API

Este ejemplo muestra cómo trabajar con la API orientada a objetos de XMLWriter.

Ejemplo #1 Trabajando con el OO API

<?php

$xw = new XMLWriter();
$xw->openMemory();
$xw->startDocument("1.0");
$xw->startElement("book");
$xw->text("example");
$xw->endElement();
$xw->endDocument();
echo $xw->outputMemory();

El resultado del ejemplo sería:

<?xml version="1.0"?>
<book>example</book>


La clase XMLWriter

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

Introducción

Sinopsis de la Clase

XMLWriter {
/* Métodos */
public endAttribute ( ) : bool
public endCdata ( ) : bool
public endComment ( ) : bool
public endDocument ( ) : bool
public endDtd ( ) : bool
public endDtdAttlist ( ) : bool
public endDtdElement ( ) : bool
public endDtdEntity ( ) : bool
public endElement ( ) : bool
public endPi ( ) : bool
public flush ( bool $empty = true ) : string|int
public fullEndElement ( ) : bool
public openMemory ( ) : bool
public openUri ( string $uri ) : bool
public outputMemory ( bool $flush = true ) : string
public setIndent ( bool $enable ) : bool
public setIndentString ( string $indentation ) : bool
public startAttribute ( string $name ) : bool
public startAttributeNs ( string|null $prefix , string $name , string|null $namespace ) : bool
public startCdata ( ) : bool
public startComment ( ) : bool
public startDocument ( string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool
public startDtd ( string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool
public startDtdAttlist ( string $name ) : bool
public startDtdElement ( string $qualifiedName ) : bool
public startDtdEntity ( string $name , bool $isParam ) : bool
public startElement ( string $name ) : bool
public startElementNs ( string|null $prefix , string $name , string|null $namespace ) : bool
public startPi ( string $target ) : bool
public text ( string $content ) : bool
public writeAttribute ( string $name , string $value ) : bool
public writeAttributeNs ( string|null $prefix , string $name , string|null $namespace , string $value ) : bool
public writeCdata ( string $content ) : bool
public writeComment ( string $content ) : bool
public writeDtd ( string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool
public writeDtdAttlist ( string $name , string $content ) : bool
public writeDtdElement ( string $name , string $content ) : bool
public writeDtdEntity ( string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool
public writeElement ( string $name , string|null $content = null ) : bool
public writeElementNs ( string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool
public writePi ( string $target , string $content ) : bool
public writeRaw ( string $content ) : bool
}

Tabla de contenidos

  • XMLWriter::endAttribute — End attribute
  • XMLWriter::endCdata — End current CDATA
  • XMLWriter::endComment — Create end comment
  • XMLWriter::endDocument — End current document
  • XMLWriter::endDtd — End current DTD
  • XMLWriter::endDtdAttlist — End current DTD AttList
  • XMLWriter::endDtdElement — End current DTD element
  • XMLWriter::endDtdEntity — End current DTD Entity
  • XMLWriter::endElement — End current element
  • XMLWriter::endPi — End current PI
  • XMLWriter::flush — Flush current buffer
  • XMLWriter::fullEndElement — End current element
  • XMLWriter::openMemory — Create new xmlwriter using memory for string output
  • XMLWriter::openUri — Create new xmlwriter using source uri for output
  • XMLWriter::outputMemory — Returns current buffer
  • XMLWriter::setIndent — Toggle indentation on/off
  • XMLWriter::setIndentString — Set string used for indenting
  • XMLWriter::startAttribute — Create start attribute
  • XMLWriter::startAttributeNs — Create start namespaced attribute
  • XMLWriter::startCdata — Create start CDATA tag
  • XMLWriter::startComment — Create start comment
  • XMLWriter::startDocument — Create document tag
  • XMLWriter::startDtd — Create start DTD tag
  • XMLWriter::startDtdAttlist — Create start DTD AttList
  • XMLWriter::startDtdElement — Create start DTD element
  • XMLWriter::startDtdEntity — Create start DTD Entity
  • XMLWriter::startElement — Create start element tag
  • XMLWriter::startElementNs — Create start namespaced element tag
  • XMLWriter::startPi — Create start PI tag
  • XMLWriter::text — Write text
  • XMLWriter::writeAttribute — Write full attribute
  • XMLWriter::writeAttributeNs — Write full namespaced attribute
  • XMLWriter::writeCdata — Write full CDATA tag
  • XMLWriter::writeComment — Write full comment tag
  • XMLWriter::writeDtd — Write full DTD tag
  • XMLWriter::writeDtdAttlist — Write full DTD AttList tag
  • XMLWriter::writeDtdElement — Write full DTD element tag
  • XMLWriter::writeDtdEntity — Write full DTD Entity tag
  • XMLWriter::writeElement — Write full element tag
  • XMLWriter::writeElementNs — Write full namespaced element tag
  • XMLWriter::writePi — Writes a PI
  • XMLWriter::writeRaw — Write a raw XML text


End attribute

  • « XMLWriter
  • XMLWriter::endCdata »
  • PHP Manual
  • XMLWriter
  • End attribute

XMLWriter::endAttribute

xmlwriter_end_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endAttribute -- xmlwriter_end_attribute — End attribute

Descripción

Estilo orientado a objetos

public XMLWriter::endAttribute ( ) : bool

Estilo por procedimientos

xmlwriter_end_attribute ( XMLWriter $writer ) : bool

Ends the current attribute.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


End current CDATA

  • « XMLWriter::endAttribute
  • XMLWriter::endComment »
  • PHP Manual
  • XMLWriter
  • End current CDATA

XMLWriter::endCdata

xmlwriter_end_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endCdata -- xmlwriter_end_cdata — End current CDATA

Descripción

Estilo orientado a objetos

public XMLWriter::endCdata ( ) : bool

Estilo por procedimientos

xmlwriter_end_cdata ( XMLWriter $writer ) : bool

Ends the current CDATA section.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startCdata() - Create start CDATA tag
  • XMLWriter::writeCdata() - Write full CDATA tag


Create end comment

  • « XMLWriter::endCdata
  • XMLWriter::endDocument »
  • PHP Manual
  • XMLWriter
  • Create end comment

XMLWriter::endComment

xmlwriter_end_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::endComment -- xmlwriter_end_comment — Create end comment

Descripción

Estilo orientado a objetos

public XMLWriter::endComment ( ) : bool

Estilo por procedimientos

xmlwriter_end_comment ( XMLWriter $writer ) : bool

Ends the current comment.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startComment() - Create start comment
  • XMLWriter::writeComment() - Write full comment tag


End current document

  • « XMLWriter::endComment
  • XMLWriter::endDtd »
  • PHP Manual
  • XMLWriter
  • End current document

XMLWriter::endDocument

xmlwriter_end_document

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDocument -- xmlwriter_end_document — End current document

Descripción

Estilo orientado a objetos

public XMLWriter::endDocument ( ) : bool

Estilo por procedimientos

xmlwriter_end_document ( XMLWriter $writer ) : bool

Ends the current document.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDocument() - Create document tag


End current DTD

  • « XMLWriter::endDocument
  • XMLWriter::endDtdAttlist »
  • PHP Manual
  • XMLWriter
  • End current DTD

XMLWriter::endDtd

xmlwriter_end_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtd -- xmlwriter_end_dtd — End current DTD

Descripción

Estilo orientado a objetos

public XMLWriter::endDtd ( ) : bool

Estilo por procedimientos

xmlwriter_end_dtd ( XMLWriter $writer ) : bool

Ends the DTD of the document.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtd() - Create start DTD tag
  • XMLWriter::writeDtd() - Write full DTD tag


End current DTD AttList

  • « XMLWriter::endDtd
  • XMLWriter::endDtdElement »
  • PHP Manual
  • XMLWriter
  • End current DTD AttList

XMLWriter::endDtdAttlist

xmlwriter_end_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdAttlist -- xmlwriter_end_dtd_attlist — End current DTD AttList

Descripción

Estilo orientado a objetos

public XMLWriter::endDtdAttlist ( ) : bool

Estilo por procedimientos

xmlwriter_end_dtd_attlist ( XMLWriter $writer ) : bool

Ends the current DTD attribute list.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtdAttlist() - Create start DTD AttList
  • XMLWriter::writeDtdAttlist() - Write full DTD AttList tag


End current DTD element

  • « XMLWriter::endDtdAttlist
  • XMLWriter::endDtdEntity »
  • PHP Manual
  • XMLWriter
  • End current DTD element

XMLWriter::endDtdElement

xmlwriter_end_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdElement -- xmlwriter_end_dtd_element — End current DTD element

Descripción

Estilo orientado a objetos

public XMLWriter::endDtdElement ( ) : bool

Estilo por procedimientos

xmlwriter_end_dtd_element ( XMLWriter $writer ) : bool

Ends the current DTD element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtdElement() - Create start DTD element
  • XMLWriter::writeDtdElement() - Write full DTD element tag


End current DTD Entity

  • « XMLWriter::endDtdElement
  • XMLWriter::endElement »
  • PHP Manual
  • XMLWriter
  • End current DTD Entity

XMLWriter::endDtdEntity

xmlwriter_end_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdEntity -- xmlwriter_end_dtd_entity — End current DTD Entity

Descripción

Estilo orientado a objetos

public XMLWriter::endDtdEntity ( ) : bool

Estilo por procedimientos

xmlwriter_end_dtd_entity ( XMLWriter $writer ) : bool

Ends the current DTD entity.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtdEntity() - Create start DTD Entity
  • XMLWriter::writeDtdEntity() - Write full DTD Entity tag


End current element

  • « XMLWriter::endDtdEntity
  • XMLWriter::endPi »
  • PHP Manual
  • XMLWriter
  • End current element

XMLWriter::endElement

xmlwriter_end_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endElement -- xmlwriter_end_element — End current element

Descripción

Estilo orientado a objetos

public XMLWriter::endElement ( ) : bool

Estilo por procedimientos

xmlwriter_end_element ( XMLWriter $writer ) : bool

Ends the current element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startElement() - Create start element tag
  • XMLWriter::writeElement() - Write full element tag


End current PI

  • « XMLWriter::endElement
  • XMLWriter::flush »
  • PHP Manual
  • XMLWriter
  • End current PI

XMLWriter::endPi

xmlwriter_end_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endPi -- xmlwriter_end_pi — End current PI

Descripción

Estilo orientado a objetos

public XMLWriter::endPi ( ) : bool

Estilo por procedimientos

xmlwriter_end_pi ( XMLWriter $writer ) : bool

Ends the current processing instruction.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startPi() - Create start PI tag
  • XMLWriter::writePi() - Writes a PI


Flush current buffer

  • « XMLWriter::endPi
  • XMLWriter::fullEndElement »
  • PHP Manual
  • XMLWriter
  • Flush current buffer

XMLWriter::flush

xmlwriter_flush

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::flush -- xmlwriter_flush — Flush current buffer

Descripción

Estilo orientado a objetos

public XMLWriter::flush ( bool $empty = true ) : string|int

Estilo por procedimientos

xmlwriter_flush ( XMLWriter $writer , bool $empty = true ) : string|int

Flushes the current buffer.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

empty

Whether to empty the buffer or not. Default is true.

Valores devueltos

If you opened the writer in memory, this function returns the generated XML buffer, Else, if using URI, this function will write the buffer and return the number of written bytes.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.
8.0.0 | This function can no longer return false.


End current element

  • « XMLWriter::flush
  • XMLWriter::openMemory »
  • PHP Manual
  • XMLWriter
  • End current element

XMLWriter::fullEndElement

xmlwriter_full_end_element

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL xmlwriter >= 2.0.4)

XMLWriter::fullEndElement -- xmlwriter_full_end_element — End current element

Descripción

Estilo orientado a objetos

public XMLWriter::fullEndElement ( ) : bool

Estilo por procedimientos

xmlwriter_full_end_element ( XMLWriter $writer ) : bool

End the current xml element. Writes an end tag even if the element is empty.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endElement() - End current element


Create new xmlwriter using memory for string output

  • « XMLWriter::fullEndElement
  • XMLWriter::openUri »
  • PHP Manual
  • XMLWriter
  • Create new xmlwriter using memory for string output

XMLWriter::openMemory

xmlwriter_open_memory

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::openMemory -- xmlwriter_open_memory — Create new xmlwriter using memory for string output

Descripción

Estilo orientado a objetos

public XMLWriter::openMemory ( ) : bool

Estilo por procedimientos

xmlwriter_open_memory ( ) : XMLWriter|false

Creates a new XMLWriter using memory for string output.

Parámetros

Valores devueltos

Estilo orientado a objetos: Devuelve true en caso de éxito o false en caso de error.

Estilo por procedimientos: Returns a new XMLWriter for later use with the xmlwriter functions on success, o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | This function returns now an XMLWriter instance on success. Previouly, a recurso has been returned in this case.

Ver también

  • XMLWriter::openUri() - Create new xmlwriter using source uri for output


Create new xmlwriter using source uri for output

  • « XMLWriter::openMemory
  • XMLWriter::outputMemory »
  • PHP Manual
  • XMLWriter
  • Create new xmlwriter using source uri for output

XMLWriter::openUri

xmlwriter_open_uri

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::openUri -- xmlwriter_open_uri — Create new xmlwriter using source uri for output

Descripción

Estilo orientado a objetos

public XMLWriter::openUri ( string $uri ) : bool

Estilo por procedimientos

xmlwriter_open_uri ( string $uri ) : XMLWriter|false

Creates a new XMLWriter using uri for the output.

Parámetros

uri

The URI of the resource for the output.

Valores devueltos

Estilo orientado a objetos: Devuelve true en caso de éxito o false en caso de error.

Estilo por procedimientos: Returns a new XMLWriter instance for later use with the xmlwriter functions on success, o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | This function returns now an XMLWriter instance on success. Previouly, a recurso has been returned in this case.

Ejemplos

Ejemplo #1 Direct output of XML

It is possible to directly output XML by using the php://output stream wrapper.

<?php
$out =new XMLWriter();
$out->openURI('php://output');
?>

Notas

Nota:

On Windows, files opened with this function are locked until the writer is released.

Ver también

  • XMLWriter::openMemory() - Create new xmlwriter using memory for string output


Returns current buffer

  • « XMLWriter::openUri
  • XMLWriter::setIndent »
  • PHP Manual
  • XMLWriter
  • Returns current buffer

XMLWriter::outputMemory

xmlwriter_output_memory

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::outputMemory -- xmlwriter_output_memory — Returns current buffer

Descripción

Estilo orientado a objetos

public XMLWriter::outputMemory ( bool $flush = true ) : string

Estilo por procedimientos

xmlwriter_output_memory ( XMLWriter $writer , bool $flush = true ) : string

Returns the current buffer.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

flush

Whether to flush the output buffer or not. Default is true.

Valores devueltos

Returns the current buffer as a string.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::flush() - Flush current buffer


Toggle indentation on/off

  • « XMLWriter::outputMemory
  • XMLWriter::setIndentString »
  • PHP Manual
  • XMLWriter
  • Toggle indentation on/off

XMLWriter::setIndent

xmlwriter_set_indent

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndent -- xmlwriter_set_indent — Toggle indentation on/off

Descripción

Estilo orientado a objetos

public XMLWriter::setIndent ( bool $enable ) : bool

Estilo por procedimientos

xmlwriter_set_indent ( XMLWriter $writer , bool $enable ) : bool

Toggles indentation on or off.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

enable

Whether indentation is enabled.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ejemplos

Ejemplo #1 XMLWriter::setIndent() and mixed Content

Enabling indentation is not suitable for mixed content, because the indent string is also inserted before inline elements.

<?php
$writer = new XMLWriter();
$writer->openMemory();
$writer->setIndent(2);
$writer->startDocument();
$writer->startElement('p');
$writer->text('before');
$writer->writeElement('a', 'element');
$writer->text('after');
$writer->endElement();
$writer->endDocument();
echo $writer->outputMemory();
?>

El resultado del ejemplo sería:

<?xml version="1.0"?>
<p>before <a>element</a>
after</p>

Notas

Nota:

The indent is reset when an xmlwriter is opened.

Ver también

  • XMLWriter::setIndentString() - Set string used for indenting


Set string used for indenting

  • « XMLWriter::setIndent
  • XMLWriter::startAttribute »
  • PHP Manual
  • XMLWriter
  • Set string used for indenting

XMLWriter::setIndentString

xmlwriter_set_indent_string

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndentString -- xmlwriter_set_indent_string — Set string used for indenting

Descripción

Estilo orientado a objetos

public XMLWriter::setIndentString ( string $indentation ) : bool

Estilo por procedimientos

xmlwriter_set_indent_string ( XMLWriter $writer , string $indentation ) : bool

Sets the string which will be used to indent each element/attribute of the resulting xml.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

indentation

The indentation string.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Notas

Nota:

The indent is reset when an xmlwriter is opened.

Ver también

  • XMLWriter::setIndent() - Toggle indentation on/off


Create start attribute

  • « XMLWriter::setIndentString
  • XMLWriter::startAttributeNs »
  • PHP Manual
  • XMLWriter
  • Create start attribute

XMLWriter::startAttribute

xmlwriter_start_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttribute -- xmlwriter_start_attribute — Create start attribute

Descripción

Estilo orientado a objetos

public XMLWriter::startAttribute ( string $name ) : bool

Estilo por procedimientos

xmlwriter_start_attribute ( XMLWriter $writer , string $name ) : bool

Starts an attribute.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The attribute name.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ejemplos

Ejemplo #1 Basic XMLWriter::startAttribute() Usage

<?php
$writer = new XMLWriter;
$writer->openURI('php://output');
$writer->startDocument('1.0', 'UTF-8');?>
$writer->startElement('element');
$writer->startAttribute('attribute');
$writer->text('value');
$writer->endAttribute();
$writer->endElement();
$writer->endDocument();

El resultado del ejemplo sería algo similar a:

<?xml version="1.0" encoding="UTF-8"?>
<element attribute="value"/>

Ver también

  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


Create start namespaced attribute

  • « XMLWriter::startAttribute
  • XMLWriter::startCdata »
  • PHP Manual
  • XMLWriter
  • Create start namespaced attribute

XMLWriter::startAttributeNs

xmlwriter_start_attribute_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttributeNs -- xmlwriter_start_attribute_ns — Create start namespaced attribute

Descripción

Estilo orientado a objetos

public XMLWriter::startAttributeNs ( string|null $prefix , string $name , string|null $namespace ) : bool

Estilo por procedimientos

xmlwriter_start_attribute_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace ) : bool

Starts a namespaced attribute.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

prefix

The namespace prefix.

name

The attribute name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.
8.0.0 | prefix is nullable now.

Ver también

  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::endAttribute() - End attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


Create start CDATA tag

  • « XMLWriter::startAttributeNs
  • XMLWriter::startComment »
  • PHP Manual
  • XMLWriter
  • Create start CDATA tag

XMLWriter::startCdata

xmlwriter_start_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startCdata -- xmlwriter_start_cdata — Create start CDATA tag

Descripción

Estilo orientado a objetos

public XMLWriter::startCdata ( ) : bool

Estilo por procedimientos

xmlwriter_start_cdata ( XMLWriter $writer ) : bool

Starts a CDATA.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endCdata() - End current CDATA
  • XMLWriter::writeCdata() - Write full CDATA tag


Create start comment

  • « XMLWriter::startCdata
  • XMLWriter::startDocument »
  • PHP Manual
  • XMLWriter
  • Create start comment

XMLWriter::startComment

xmlwriter_start_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::startComment -- xmlwriter_start_comment — Create start comment

Descripción

Estilo orientado a objetos

public XMLWriter::startComment ( ) : bool

Estilo por procedimientos

xmlwriter_start_comment ( XMLWriter $writer ) : bool

Starts a comment.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endComment() - Create end comment
  • XMLWriter::writeComment() - Write full comment tag


Create document tag

  • « XMLWriter::startComment
  • XMLWriter::startDtd »
  • PHP Manual
  • XMLWriter
  • Create document tag

XMLWriter::startDocument

xmlwriter_start_document

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDocument -- xmlwriter_start_document — Create document tag

Descripción

Estilo orientado a objetos

public XMLWriter::startDocument ( string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool

Estilo por procedimientos

xmlwriter_start_document ( XMLWriter $writer , string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool

Starts a document.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

version

The version number of the document as part of the XML declaration.

encoding

The encoding of the document as part of the XML declaration.

standalone

yes or no.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endDocument() - End current document


Create start DTD tag

  • « XMLWriter::startDocument
  • XMLWriter::startDtdAttlist »
  • PHP Manual
  • XMLWriter
  • Create start DTD tag

XMLWriter::startDtd

xmlwriter_start_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtd -- xmlwriter_start_dtd — Create start DTD tag

Descripción

Estilo orientado a objetos

public XMLWriter::startDtd ( string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool

Estilo por procedimientos

xmlwriter_start_dtd ( XMLWriter $writer , string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool

Starts a DTD.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

qualifiedName

The qualified name of the document type to create.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endDtd() - End current DTD
  • XMLWriter::writeDtd() - Write full DTD tag


Create start DTD AttList

  • « XMLWriter::startDtd
  • XMLWriter::startDtdElement »
  • PHP Manual
  • XMLWriter
  • Create start DTD AttList

XMLWriter::startDtdAttlist

xmlwriter_start_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdAttlist -- xmlwriter_start_dtd_attlist — Create start DTD AttList

Descripción

Estilo orientado a objetos

public XMLWriter::startDtdAttlist ( string $name ) : bool

Estilo por procedimientos

xmlwriter_start_dtd_attlist ( XMLWriter $writer , string $name ) : bool

Starts a DTD attribute list.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The attribute list name.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endDtdAttlist() - End current DTD AttList
  • XMLWriter::writeDtdAttlist() - Write full DTD AttList tag


Create start DTD element

  • « XMLWriter::startDtdAttlist
  • XMLWriter::startDtdEntity »
  • PHP Manual
  • XMLWriter
  • Create start DTD element

XMLWriter::startDtdElement

xmlwriter_start_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdElement -- xmlwriter_start_dtd_element — Create start DTD element

Descripción

Estilo orientado a objetos

public XMLWriter::startDtdElement ( string $qualifiedName ) : bool

Estilo por procedimientos

xmlwriter_start_dtd_element ( XMLWriter $writer , string $qualifiedName ) : bool

Starts a DTD element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

qualifiedName

The qualified name of the document type to create.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endDtdElement() - End current DTD element
  • XMLWriter::writeDtdElement() - Write full DTD element tag


Create start DTD Entity

  • « XMLWriter::startDtdElement
  • XMLWriter::startElement »
  • PHP Manual
  • XMLWriter
  • Create start DTD Entity

XMLWriter::startDtdEntity

xmlwriter_start_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdEntity -- xmlwriter_start_dtd_entity — Create start DTD Entity

Descripción

Estilo orientado a objetos

public XMLWriter::startDtdEntity ( string $name , bool $isParam ) : bool

Estilo por procedimientos

xmlwriter_start_dtd_entity ( XMLWriter $writer , string $name , bool $isParam ) : bool

Starts a DTD entity.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The name of the entity.

isParam

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endDtdEntity() - End current DTD Entity
  • XMLWriter::writeDtdEntity() - Write full DTD Entity tag


Create start element tag

  • « XMLWriter::startDtdEntity
  • XMLWriter::startElementNs »
  • PHP Manual
  • XMLWriter
  • Create start element tag

XMLWriter::startElement

xmlwriter_start_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startElement -- xmlwriter_start_element — Create start element tag

Descripción

Estilo orientado a objetos

public XMLWriter::startElement ( string $name ) : bool

Estilo por procedimientos

xmlwriter_start_element ( XMLWriter $writer , string $name ) : bool

Starts an element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The element name.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElement() - Write full element tag


Create start namespaced element tag

  • « XMLWriter::startElement
  • XMLWriter::startPi »
  • PHP Manual
  • XMLWriter
  • Create start namespaced element tag

XMLWriter::startElementNs

xmlwriter_start_element_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startElementNs -- xmlwriter_start_element_ns — Create start namespaced element tag

Descripción

Estilo orientado a objetos

public XMLWriter::startElementNs ( string|null $prefix , string $name , string|null $namespace ) : bool

Estilo por procedimientos

xmlwriter_start_element_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace ) : bool

Starts a namespaced element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The element name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElementNs() - Write full namespaced element tag


Create start PI tag

  • « XMLWriter::startElementNs
  • XMLWriter::text »
  • PHP Manual
  • XMLWriter
  • Create start PI tag

XMLWriter::startPi

xmlwriter_start_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startPi -- xmlwriter_start_pi — Create start PI tag

Descripción

Estilo orientado a objetos

public XMLWriter::startPi ( string $target ) : bool

Estilo por procedimientos

xmlwriter_start_pi ( XMLWriter $writer , string $target ) : bool

Starts a processing instruction tag.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

target

The target of the processing instruction.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::endPi() - End current PI
  • XMLWriter::writePi() - Writes a PI


Write text

  • « XMLWriter::startPi
  • XMLWriter::writeAttribute »
  • PHP Manual
  • XMLWriter
  • Write text

XMLWriter::text

xmlwriter_text

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::text -- xmlwriter_text — Write text

Descripción

Estilo orientado a objetos

public XMLWriter::text ( string $content ) : bool

Estilo por procedimientos

xmlwriter_text ( XMLWriter $writer , string $content ) : bool

Writes a text.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

content

The contents of the text. The characters <, >, & and " are written as entity references (i.e. &lt;, &gt;, &amp; and &quot;, respectively). All other characters including ' are written literally. To write the special XML characters literally, or to write literal entity references, xmlwriter_write_raw() has to be used.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.


Write full attribute

  • « XMLWriter::text
  • XMLWriter::writeAttributeNs »
  • PHP Manual
  • XMLWriter
  • Write full attribute

XMLWriter::writeAttribute

xmlwriter_write_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttribute -- xmlwriter_write_attribute — Write full attribute

Descripción

Estilo orientado a objetos

public XMLWriter::writeAttribute ( string $name , string $value ) : bool

Estilo por procedimientos

xmlwriter_write_attribute ( XMLWriter $writer , string $name , string $value ) : bool

Writes a full attribute.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The name of the attribute.

value

The value of the attribute.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ejemplos

Ejemplo #1 Intermixing Sub-elements and Attributes

If writing sub-elements and attributes is intermixed, any attempt to write attributes after the first sub-element will fail and return false.

<?php
$xml = new XMLWriter();
$xml->openMemory();

$xml->startElement('element');
$xml->writeAttribute('attr1', '0');
$xml->writeElement('subelem', '0');
var_dump($xml->writeAttribute('attr2', '0'));
$xml->endElement();

echo $xml->flush();
?>

El resultado del ejemplo sería:

bool(false)
<element attr1="0"><subelem>0</subelem></element>

Ver también

  • XMLWriter::writeAttributeNs() - Write full namespaced attribute
  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute


Write full namespaced attribute

  • « XMLWriter::writeAttribute
  • XMLWriter::writeCdata »
  • PHP Manual
  • XMLWriter
  • Write full namespaced attribute

XMLWriter::writeAttributeNs

xmlwriter_write_attribute_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttributeNs -- xmlwriter_write_attribute_ns — Write full namespaced attribute

Descripción

Estilo orientado a objetos

public XMLWriter::writeAttributeNs ( string|null $prefix , string $name , string|null $namespace , string $value ) : bool

Estilo por procedimientos

xmlwriter_write_attribute_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace , string $value ) : bool

Writes a full namespaced attribute.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The attribute name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

value

The attribute value.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute


Write full CDATA tag

  • « XMLWriter::writeAttributeNs
  • XMLWriter::writeComment »
  • PHP Manual
  • XMLWriter
  • Write full CDATA tag

XMLWriter::writeCdata

xmlwriter_write_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeCdata -- xmlwriter_write_cdata — Write full CDATA tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeCdata ( string $content ) : bool

Estilo por procedimientos

xmlwriter_write_cdata ( XMLWriter $writer , string $content ) : bool

Writes a full CDATA.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

content

The contents of the CDATA.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ejemplos

Ejemplo #1 Basic xmlwriter_write_cdata() Usage

<?php
// set up the document
$xml = new XmlWriter();
$xml->openMemory();
$xml->setIndent(true);
$xml->startDocument('1.0', 'UTF-8');
$xml->startElement('mydoc');
$xml->startElement('myele');

// CData output
$xml->startElement('mycdataelement');
$xml->writeCData("text for inclusion as CData");
$xml->endElement();

// end the document and output
$xml->endElement();
$xml->endElement();
echo $xml->outputMemory(true);
?>

El resultado del ejemplo sería:

<mydoc>
 <myele>
  <mycdataelement><![CDATA[text for inclusion as CData]?]></mycdataelement>
 </myele>
</mydoc>

Ver también

  • XMLWriter::startCdata() - Create start CDATA tag
  • XMLWriter::endCdata() - End current CDATA


Write full comment tag

  • « XMLWriter::writeCdata
  • XMLWriter::writeDtd »
  • PHP Manual
  • XMLWriter
  • Write full comment tag

XMLWriter::writeComment

xmlwriter_write_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeComment -- xmlwriter_write_comment — Write full comment tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeComment ( string $content ) : bool

Estilo por procedimientos

xmlwriter_write_comment ( XMLWriter $writer , string $content ) : bool

Writes a full comment.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

content

The contents of the comment.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startComment() - Create start comment
  • XMLWriter::endComment() - Create end comment


Write full DTD tag

  • « XMLWriter::writeComment
  • XMLWriter::writeDtdAttlist »
  • PHP Manual
  • XMLWriter
  • Write full DTD tag

XMLWriter::writeDtd

xmlwriter_write_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtd -- xmlwriter_write_dtd — Write full DTD tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeDtd ( string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool

Estilo por procedimientos

xmlwriter_write_dtd ( XMLWriter $writer , string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool

Writes a full DTD.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The DTD name.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

content

The content of the DTD.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtd() - Create start DTD tag
  • XMLWriter::endDtd() - End current DTD


Write full DTD AttList tag

  • « XMLWriter::writeDtd
  • XMLWriter::writeDtdElement »
  • PHP Manual
  • XMLWriter
  • Write full DTD AttList tag

XMLWriter::writeDtdAttlist

xmlwriter_write_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdAttlist -- xmlwriter_write_dtd_attlist — Write full DTD AttList tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeDtdAttlist ( string $name , string $content ) : bool

Estilo por procedimientos

xmlwriter_write_dtd_attlist ( XMLWriter $writer , string $name , string $content ) : bool

Writes a DTD attribute list.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The name of the DTD attribute list.

content

The content of the DTD attribute list.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtdAttlist() - Create start DTD AttList
  • XMLWriter::endDtdAttlist() - End current DTD AttList


Write full DTD element tag

  • « XMLWriter::writeDtdAttlist
  • XMLWriter::writeDtdEntity »
  • PHP Manual
  • XMLWriter
  • Write full DTD element tag

XMLWriter::writeDtdElement

xmlwriter_write_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdElement -- xmlwriter_write_dtd_element — Write full DTD element tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeDtdElement ( string $name , string $content ) : bool

Estilo por procedimientos

xmlwriter_write_dtd_element ( XMLWriter $writer , string $name , string $content ) : bool

Writes a full DTD element.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The name of the DTD element.

content

The content of the element.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startDtdElement() - Create start DTD element
  • XMLWriter::endDtdElement() - End current DTD element


Write full DTD Entity tag

  • « XMLWriter::writeDtdElement
  • XMLWriter::writeElement »
  • PHP Manual
  • XMLWriter
  • Write full DTD Entity tag

XMLWriter::writeDtdEntity

xmlwriter_write_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdEntity -- xmlwriter_write_dtd_entity — Write full DTD Entity tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeDtdEntity ( string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool

Estilo por procedimientos

xmlwriter_write_dtd_entity ( XMLWriter $writer , string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool

Writes a full DTD entity.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The name of the entity.

content

The content of the entity.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.
8.0.0 | publicId, systemId and notationData are nullable now.

Ver también

  • XMLWriter::startDtdEntity() - Create start DTD Entity
  • XMLWriter::endDtdEntity() - End current DTD Entity


Write full element tag

  • « XMLWriter::writeDtdEntity
  • XMLWriter::writeElementNs »
  • PHP Manual
  • XMLWriter
  • Write full element tag

XMLWriter::writeElement

xmlwriter_write_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElement -- xmlwriter_write_element — Write full element tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeElement ( string $name , string|null $content = null ) : bool

Estilo por procedimientos

xmlwriter_write_element ( XMLWriter $writer , string $name , string|null $content = null ) : bool

Writes a full element tag.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

name

The element name.

content

The element contents.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startElement() - Create start element tag
  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElementNs() - Write full namespaced element tag


Write full namespaced element tag

  • « XMLWriter::writeElement
  • XMLWriter::writePi »
  • PHP Manual
  • XMLWriter
  • Write full namespaced element tag

XMLWriter::writeElementNs

xmlwriter_write_element_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElementNs -- xmlwriter_write_element_ns — Write full namespaced element tag

Descripción

Estilo orientado a objetos

public XMLWriter::writeElementNs ( string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool

Estilo por procedimientos

xmlwriter_write_element_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool

Writes a full namespaced element tag.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The element name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

content

The element contents.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startElementNs() - Create start namespaced element tag
  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElement() - Write full element tag


Writes a PI

  • « XMLWriter::writeElementNs
  • XMLWriter::writeRaw »
  • PHP Manual
  • XMLWriter
  • Writes a PI

XMLWriter::writePi

xmlwriter_write_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writePi -- xmlwriter_write_pi — Writes a PI

Descripción

Estilo orientado a objetos

public XMLWriter::writePi ( string $target , string $content ) : bool

Estilo por procedimientos

xmlwriter_write_pi ( XMLWriter $writer , string $target , string $content ) : bool

Writes a processing instruction.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

target

The target of the processing instruction.

content

The content of the processing instruction.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::startPi() - Create start PI tag
  • XMLWriter::endPi() - End current PI


Write a raw XML text

  • « XMLWriter::writePi
  • XSL »
  • PHP Manual
  • XMLWriter
  • Write a raw XML text

XMLWriter::writeRaw

xmlwriter_write_raw

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL xmlwriter >= 2.0.4)

XMLWriter::writeRaw -- xmlwriter_write_raw — Write a raw XML text

Descripción

Estilo orientado a objetos

public XMLWriter::writeRaw ( string $content ) : bool

Estilo por procedimientos

xmlwriter_write_raw ( XMLWriter $writer , string $content ) : bool

Writes a raw xml text.

Parámetros

xmlwriter

Sólo para llamadas por procedimientos. El resource XMLWriter que está siendo modificado. Este recurso proviene de una llamada a xmlwriter_open_uri() o xmlwriter_open_memory().

content

The text string to write.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Historial de cambios

Versión | Descripción
8.0.0 | writer expects an XMLWriter instance now; previously, a resource was expected.

Ver también

  • XMLWriter::text() - Write text


XSL

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
    • Configuración en tiempo de ejecución
    • Tipos de recursos
  • Constantes predefinidas
  • Ejemplos
    • Ficheros collection.xml y collection.xsl de ejemplo
    • Manejo de errores con las funciones de manejo de errores de libxml
  • XSLTProcessor — Clase XSLTProcessor
    • XSLTProcessor::__construct — Crea un nuevo objeto XSLTProcessor
    • XSLTProcessor::getParameter — Obtiene el valor de un parámetro
    • XSLTProcessor::getSecurityPrefs — Obtiene las preferencias de seguridad
    • XSLTProcessor::hasExsltSupport — Determina si PHP tiene soporte para EXSLT
    • XSLTProcessor::importStylesheet — Importa una hoja de estilos
    • XSLTProcessor::registerPHPFunctions — Activa la capacidad de usar funciones PHP como funciones XSLT
    • XSLTProcessor::removeParameter — Elimina un parámetro
    • XSLTProcessor::setParameter — Establece el valor para uno o varios parámetros
    • XSLTProcessor::setProfiling — Establece el fichero de salida para la información resultado del proceso
    • XSLTProcessor::setSecurityPrefs — Establece las preferencias de seguridad
    • XSLTProcessor::transformToDoc — Transforma en un DOMDocument
    • XSLTProcessor::transformToUri — Transformar a URI
    • XSLTProcessor::transformToXml — Transforma a XML


Introducción

La extensión XSL implementa el estándar XSL, realizando » transformaciones XSLT usando la » biblioteca libxslt


Requerimientos

Esta extensión requiere la extensión libxml de PHP. Esto significa que también es necesario pasar la opción --enable-libxml, aunque esto se realiza implícitamente debido a que libxml está habilitada de forma predeterminada.

Esta extensión usa libxslt disponible en » http://xmlsoft.org/XSLT/. Se requiere una versión de libxslt 1.1.0 o superior.


Instalación

PHP 5 incluye la extensión XSL por defecto y puede ser activada añadiendo el argumento --with-xsl[=DIR] en la línea de configuración. DIR es el directorio de instalación de libxslt.


Constantes predefinidas

Estas constantes están definidas por esta extensión y estarán disponibles sólo cuando la extensión haya sido compilada con PHP, o bien sea cargada dinámicamente en ejecución.

XSL_CLONE_AUTO (integer)
XSL_CLONE_NEVER (integer)
XSL_CLONE_ALWAYS (integer)
LIBXSLT_VERSION (integer)
versión libxslt como 10117. Disponible a partir de PHP 5.1.2.
LIBXSLT_DOTTED_VERSION (string)
versión de libxslt como la 1.1.17. Disponible a partir de PHP 5.1.2.
LIBEXSLT_VERSION (integer)
versión de libexslt como la 813. Disponible a partir de PHP 5.1.2.
LIBEXSLT_DOTTED_VERSION (string)
versión de libexslt como la 1.1.17. Disponible a partir de PHP 5.1.2.
XSL_SECPREF_NONE (integer)
Desactivar todas las restricciones de seguridad.
XSL_SECPREF_READ_FILE (integer)
Deshabilita la lectura de archivos.
XSL_SECPREF_WRITE_FILE (integer)
Deshabilita la escritura de archivos.
XSL_SECPREF_CREATE_DIRECTORY (integer)
No permite crear directorios.
XSL_SECPREF_READ_NETWORK (integer)
No permite leer los archivos de la red.
XSL_SECPREF_WRITE_NETWORK (integer)
Deshabilita la escritura de archivos de red.
XSL_SECPREF_DEFAULT (integer)
Deshabilita todo acceso de escritura, es decir, una máscara de bits de XSL_SECPREF_WRITE_NETWORK | XSL_SECPREF_CREATE_DIRECTORY | XSL_SECPREF_WRITE_FILE.


Ejemplos

Tabla de contenidos

  • Ficheros collection.xml y collection.xsl de ejemplo
  • Manejo de errores con las funciones de manejo de errores de libxml


Ficheros collection.xml y collection.xsl de ejemplo

Muchos ejemplos en esta referencia requieren tanto un fichero XML como un XSL. Se usará collection.xml y collection.xsl que contienen el siguiente código:

Ejemplo #1 collection.xml

<collection>
 <cd>
  <title>Fight for your mind</title>
  <artist>Ben Harper</artist>
  <year>1995</year>
 </cd>
 <cd>
  <title>Electric Ladyland</title>
  <artist>Jimi Hendrix</artist>
  <year>1997</year>
 </cd>
</collection>

Ejemplo #2 collection.xsl

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:param name="owner" select="'Nicolas Eliaszewicz'"/>
 <xsl:output method="html" encoding="iso-8859-1" indent="no"/>
 <xsl:template match="collection">
  Hey! Welcome to <xsl:value-of select="$owner"/>'s sweet CD collection!
  <xsl:apply-templates/>
 </xsl:template>
 <xsl:template match="cd">
  <h1><xsl:value-of select="title"/></h1>
  <h2>by <xsl:value-of select="artist"/> - <xsl:value-of select="year"/></h2>
  <hr />
 </xsl:template>
</xsl:stylesheet>


Manejo de errores con las funciones de manejo de errores de libxml

libxml ofrece una serie de funciones para el manejo de errores, que pueden ser empleadas para capturar y tratar los errores en el procesamiento de XSLT.

Ejemplo #1 fruits.xml

Un archivo XML válido.

<fruits>
 <fruit>Apple</fruit>
 <fruit>Banana</fruit>
 <fruit>Cherry</fruit>
</fruits>

Ejemplo #2 fruits.xsl

Contiene una expresión selectiva no válida.

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:output method="html" encoding="utf-8" indent="no"/>
 <xsl:template match="fruits">
  <ul>
   <xsl:apply-templates/>
  </ul>
 </xsl:template>
 <xsl:template match="fruit">
  <li><xsl:value-of select="THIS IS A DELIBERATE ERROR!"/></li>
 </xsl:template>
</xsl:stylesheet>

Ejemplo #3 Errores de compaginación e impresión

El siguiente ejemplo captura y muestra los errores de libxml que se producen al llamar a XSLTProcessor::importStyleSheet() on una hoja de estilo que contiene un error.

<?php

$xmldoc = new DOMDocument();
$xsldoc = new DOMDocument();
$xsl = new XSLTProcessor();

$xmldoc->loadXML('fruits.xml');
$xsldoc->loadXML('fruits.xsl');

libxml_use_internal_errors(true);
$result = $xsl->importStyleSheet($xsldoc);
if (!$result) {
    foreach (libxml_get_errors() as $error) {
        echo "Libxml error: {$error->message}\n";
    }
}
libxml_use_internal_errors(false);

if ($result) {
    echo $xsl->transformToXML($xmldoc);
}

?>

El resultado del ejemplo sería algo similar a:

Libxml error: Invalid expression

Libxml error: compilation error: file fruits.xsl line 9 element value-of
Libxml error: xsl:value-of : could not compile select expression 'THIS IS A DELIBERATE ERROR!'


Clase XSLTProcessor

(PHP 5, PHP 7, PHP 8)

Introducción

Sinopsis de la Clase

XSLTProcessor {
/* Métodos */
getParameter ( string $namespaceURI , string $localName ) : string
public getSecurityPrefs ( ) : int
hasExsltSupport ( ) : bool
public importStylesheet ( object $stylesheet ) : bool
registerPHPFunctions ( mixed $restrict = ? ) : void
removeParameter ( string $namespaceURI , string $localName ) : bool
setParameter ( string $namespace , string $name , string $value ) : bool
setProfiling ( string $filename ) : bool
public setSecurityPrefs ( int $securityPrefs ) : int
transformToDoc ( DOMNode $doc ) : DOMDocument
transformToURI ( DOMDocument $doc , string $uri ) : int
transformToXml ( object $doc ) : string
}

Tabla de contenidos

  • XSLTProcessor::__construct — Crea un nuevo objeto XSLTProcessor
  • XSLTProcessor::getParameter — Obtiene el valor de un parámetro
  • XSLTProcessor::getSecurityPrefs — Obtiene las preferencias de seguridad
  • XSLTProcessor::hasExsltSupport — Determina si PHP tiene soporte para EXSLT
  • XSLTProcessor::importStylesheet — Importa una hoja de estilos
  • XSLTProcessor::registerPHPFunctions — Activa la capacidad de usar funciones PHP como funciones XSLT
  • XSLTProcessor::removeParameter — Elimina un parámetro
  • XSLTProcessor::setParameter — Establece el valor para uno o varios parámetros
  • XSLTProcessor::setProfiling — Establece el fichero de salida para la información resultado del proceso
  • XSLTProcessor::setSecurityPrefs — Establece las preferencias de seguridad
  • XSLTProcessor::transformToDoc — Transforma en un DOMDocument
  • XSLTProcessor::transformToUri — Transformar a URI
  • XSLTProcessor::transformToXml — Transforma a XML


Crea un nuevo objeto XSLTProcessor

  • « XSLTProcessor
  • XSLTProcessor::getParameter »
  • PHP Manual
  • XSLTProcessor
  • Crea un nuevo objeto XSLTProcessor

XSLTProcessor::__construct

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::__construct — Crea un nuevo objeto XSLTProcessor

Descripción

XSLTProcessor::__construct ( )

Crea un nuevo objeto XSLTProcessor.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Creando un XSLTProcessor

<?php

$xsldoc = new DOMDocument();
$xsldoc->load($xsl_filename);

$xmldoc = new DOMDocument();
$xmldoc->load($xml_filename);

$xsl = new XSLTProcessor();
$xsl->importStyleSheet($xsldoc);
echo $xsl->transformToXML($xmldoc);

?>


Obtiene el valor de un parámetro

  • « XSLTProcessor::__construct
  • XSLTProcessor::getSecurityPrefs »
  • PHP Manual
  • XSLTProcessor
  • Obtiene el valor de un parámetro

XSLTProcessor::getParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::getParameter — Obtiene el valor de un parámetro

Descripción

XSLTProcessor::getParameter ( string $namespaceURI , string $localName ) : string

Obtiene un parámetro si ha sido previamente establecido por XSLTProcessor::setParameter().

Parámetros

namespaceURI

La URI del namespace del parámetro XSLT.

localName

El nombre local del parámetro XSLT.

Valores devueltos

El valor del parámetro (como un string), o false si no está definido.

Ver también

  • XSLTProcessor::setParameter() - Establece el valor para uno o varios parámetros
  • XSLTProcessor::removeParameter() - Elimina un parámetro


Obtiene las preferencias de seguridad

  • « XSLTProcessor::getParameter
  • XSLTProcessor::hasExsltSupport »
  • PHP Manual
  • XSLTProcessor
  • Obtiene las preferencias de seguridad

XSLTProcessor::getSecurityPrefs

(PHP >= 5.4.0, PHP 7, PHP 8)

XSLTProcessor::getSecurityPrefs — Obtiene las preferencias de seguridad

Descripción

public XSLTProcessor::getSecurityPrefs ( ) : int

Obtiene las preferencias de seguridad.

Parámetros

Esta función no tiene parámetros.

Valores devueltos

A bitmask consisting of XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK.


Determina si PHP tiene soporte para EXSLT

  • « XSLTProcessor::getSecurityPrefs
  • XSLTProcessor::importStylesheet »
  • PHP Manual
  • XSLTProcessor
  • Determina si PHP tiene soporte para EXSLT

XSLTProcessor::hasExsltSupport

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

XSLTProcessor::hasExsltSupport — Determina si PHP tiene soporte para EXSLT

Descripción

XSLTProcessor::hasExsltSupport ( ) : bool

Este método determina si PHP se compiló con la » librería EXSLT.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Comprobando si tiene EXSLT

<?php

$proc = new XSLTProcessor;
if (!$proc->hasExsltSupport()) {
    die('EXSLT no disponible');
}

// aquí las líneas de código con EXSLT..

?>


Importa una hoja de estilos

  • « XSLTProcessor::hasExsltSupport
  • XSLTProcessor::registerPHPFunctions »
  • PHP Manual
  • XSLTProcessor
  • Importa una hoja de estilos

XSLTProcessor::importStylesheet

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::importStylesheet — Importa una hoja de estilos

Descripción

public XSLTProcessor::importStylesheet ( object $stylesheet ) : bool

Este método importa la hoja de estilos a XSLTProcessor para realizar transformaciones.

Parámetros

stylesheet

La hoja de estilos importada como objeto DOMDocument o SimpleXMLElement.

Valores devueltos

No devuelve ningún valor.

Historial de cambios

Versión | Descripción
5.2.8 | Acepta SimpleXMLElement de nuevo; no funcionaba desde PHP 5.2.6.


Activa la capacidad de usar funciones PHP como funciones XSLT

  • « XSLTProcessor::importStylesheet
  • XSLTProcessor::removeParameter »
  • PHP Manual
  • XSLTProcessor
  • Activa la capacidad de usar funciones PHP como funciones XSLT

XSLTProcessor::registerPHPFunctions

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

XSLTProcessor::registerPHPFunctions — Activa la capacidad de usar funciones PHP como funciones XSLT

Descripción

XSLTProcessor::registerPHPFunctions ( mixed $restrict = ? ) : void

Este método activa la capacidad de usar funciones PHP como funciones XSLT dentro de las hojas de estilo XSL.

Parámetros

restrict

Usar este parámetro para acceder únicamente a ciertas funciones a ser llamadas desde XSLT.

Este parámetro puede ser tanto un string (nombre de la función) como un array de funciones.

Valores devueltos

No devuelve ningún valor.

Ejemplos

Ejemplo #1 Sencilla llamada a una función de PHP desde una hoja de estilos

<?php
$xml = <<<EOB
<allusers>
 <user>
  <uid>bob</uid>
 </user>
 <user>
  <uid>joe</uid>
 </user>
</allusers>
EOB;
$xsl = <<<EOB
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0"
     xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
     xmlns:php="http://php.net/xsl">
<xsl:output method="html" encoding="utf-8" indent="yes"/>
 <xsl:template match="allusers">
  <html><body>
    <h2>Users</h2>
    <table>
    <xsl:for-each select="user">
      <tr><td>
        <xsl:value-of
             select="php:function('ucfirst',string(uid))"/>
      </td></tr>
    </xsl:for-each>
    </table>
  </body></html>
 </xsl:template>
</xsl:stylesheet>
EOB;
$xmldoc = DOMDocument::loadXML($xml);
$xsldoc = DOMDocument::loadXML($xsl);

$proc = new XSLTProcessor();
$proc->registerPHPFunctions();
$proc->importStyleSheet($xsldoc);
echo $proc->transformToXML($xmldoc);
?>

Historial de cambios

Versión | Descripción
5.1.0 | Se añadió el parámetro restrict.


Elimina un parámetro

  • « XSLTProcessor::registerPHPFunctions
  • XSLTProcessor::setParameter »
  • PHP Manual
  • XSLTProcessor
  • Elimina un parámetro

XSLTProcessor::removeParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::removeParameter — Elimina un parámetro

Descripción

XSLTProcessor::removeParameter ( string $namespaceURI , string $localName ) : bool

Elimina un parámetro, si ya existía. Esto hará que el procesador use el valor por defecto para el parámetro como está especificado en la hoja de estilos.

Parámetros

namespaceURI

La URI del namespace para el parámetro XSLT.

localName

Nombre local del parámetro XSLT.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ver también

  • XSLTProcessor::setParameter() - Establece el valor para uno o varios parámetros
  • XSLTProcessor::getParameter() - Obtiene el valor de un parámetro


Establece el valor para uno o varios parámetros

  • « XSLTProcessor::removeParameter
  • XSLTProcessor::setProfiling »
  • PHP Manual
  • XSLTProcessor
  • Establece el valor para uno o varios parámetros

XSLTProcessor::setParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::setParameter — Establece el valor para uno o varios parámetros

Descripción

XSLTProcessor::setParameter ( string $namespace , string $name , string $value ) : bool
XSLTProcessor::setParameter ( string $namespace , array $options ) : bool

Establece el valor para uno o más parámetros a ser usado en las siguientes transformaciones con XSLTProcessor. Si el parámetro no existe en la hoja de estilos, será ignorado.

Parámetros

namespace

La URI para el namespace del parámetro XSLT.

name

Nombre local del parámetro XSLT.

value

Nuevo valor para el parámetro XSLT.

options

Un array de parejas nombre => valor. Esta sintaxis está disponible desde PHP 5.1.0.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Changing the owner before the transformation

<?php

$collections = array(
    'Marc Rutkowski' => 'marc',
    'Olivier Parmentier' => 'olivier'
);

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configuración del procesador
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // asociamos las reglas xsl

foreach ($collections as $name => $file) {
    // Cargamos el XML origen
    $xml = new DOMDocument;
    $xml->load('collection_' . $file . '.xml');

    $proc->setParameter('', 'owner', $name);
    $proc->transformToURI($xml, 'file:///tmp/' . $file . '.html');
}

?>

Ver también

  • XSLTProcessor::getParameter() - Obtiene el valor de un parámetro
  • XSLTProcessor::removeParameter() - Elimina un parámetro


Establece el fichero de salida para la información resultado del proceso

  • « XSLTProcessor::setParameter
  • XSLTProcessor::setSecurityPrefs »
  • PHP Manual
  • XSLTProcessor
  • Establece el fichero de salida para la información resultado del proceso

XSLTProcessor::setProfiling

(PHP >= 5.3.0, PHP 7, PHP 8)

XSLTProcessor::setProfiling — Establece el fichero de salida para la información resultado del proceso

Descripción

XSLTProcessor::setProfiling ( string $filename ) : bool

Establece el nombre del fichero de salida para la información generada del propio procesado de la hoja de estilos.

Parámetros

filename

Ruta al fichero donde volcar la información.

Valores devueltos

Devuelve true en caso de éxito o false en caso de error.

Ejemplos

Ejemplo #1 Ejemplo de salida de información

<?php
// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configuración del procesador
$proc = new XSLTProcessor;
$proc->setProfiling('profiling.txt');
$proc->importStyleSheet($xsl); // adjunta las reglas xsl

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);
?>

Este código generará la siguiente información en el fichero profiling.txt:

number               match                name      mode  Calls Tot 100us Avg

    0                   cd                                    2      3      1
    1           collection                                    1      1      1

                         Total                                3      4


Establece las preferencias de seguridad

  • « XSLTProcessor::setProfiling
  • XSLTProcessor::transformToDoc »
  • PHP Manual
  • XSLTProcessor
  • Establece las preferencias de seguridad

XSLTProcessor::setSecurityPrefs

(PHP >= 5.4.0, PHP 7, PHP 8)

XSLTProcessor::setSecurityPrefs — Establece las preferencias de seguridad

Descripción

public XSLTProcessor::setSecurityPrefs ( int $securityPrefs ) : int

Establece las preferencias de seguridad.

Parámetros

securityPrefs

Las nuevas preferencias de seguridad. Las siguientes constantes pueden ser ORed: XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK. Alternativamente, XSL_SECPREF_NONE o se puede pasar XSL_SECPREF_DEFAULT.

Valores devueltos

Devuelve las antiguas preferencias de seguridad.


Transforma en un DOMDocument

  • « XSLTProcessor::setSecurityPrefs
  • XSLTProcessor::transformToUri »
  • PHP Manual
  • XSLTProcessor
  • Transforma en un DOMDocument

XSLTProcessor::transformToDoc

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToDoc — Transforma en un DOMDocument

Descripción

XSLTProcessor::transformToDoc ( DOMNode $doc ) : DOMDocument

Transforma el nodo origen en un DOMDocument aplicando las hojas de estilo dadas por el método XSLTProcessor::importStylesheet().

Parámetros

doc

El nodo a transformar.

Valores devueltos

El DOMDocument resultante o false en caso de error.

Ejemplos

Ejemplo #1 Transformando en un DOMDocument

<?php

// Carga del fichero origen XML
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configuración del procesador
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // adjunta las reglas xsl

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);

?>

El resultado del ejemplo sería:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

Ver también

  • XSLTProcessor::transformToUri() - Transformar a URI
  • XSLTProcessor::transformToXml() - Transforma a XML


Transformar a URI

  • « XSLTProcessor::transformToDoc
  • XSLTProcessor::transformToXml »
  • PHP Manual
  • XSLTProcessor
  • Transformar a URI

XSLTProcessor::transformToUri

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToUri — Transformar a URI

Descripción

XSLTProcessor::transformToURI ( DOMDocument $doc , string $uri ) : int

Transforma el nodo origen a una URI aplicando la hoja de estilos dada por el metodo XSLTProcessor::importStylesheet().

Parámetros

doc

El documento a transformar.

uri

Devuelve la ubicación URI para la transformación.

Valores devueltos

Retorna el número de bytes escritos o false en caso de error.

Ejemplos

Ejemplo #1 Transformando a un fichero HTML

<?php

// Carga el fichero XML origen
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configura el procesador
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // adjunta las reglas xsl

$proc->transformToURI($xml, 'file:///tmp/out.html');

?>

Ver también

  • XSLTProcessor::transformToDoc() - Transforma en un DOMDocument
  • XSLTProcessor::transformToXml() - Transforma a XML


Transforma a XML

  • « XSLTProcessor::transformToUri
  • Extensiones de GUI »
  • PHP Manual
  • XSLTProcessor
  • Transforma a XML

XSLTProcessor::transformToXml

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToXml — Transforma a XML

Descripción

XSLTProcessor::transformToXml ( object $doc ) : string

Transforma el nodo origen a un string aplicando la hoja de estilos dada por el método xsltprocessor::importStylesheet().

Parámetros

doc

El objeto DOMDocument o SimpleXMLElement para ser transformado.

Valores devueltos

Resultado de la transformación a string o false en caso de error.

Ejemplos

Ejemplo #1 Transformando a un string

<?php

// Carga el fichero XML origen
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configura el procesador
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // adjunta las reglas XSL

echo $proc->transformToXML($xml);

?>

El resultado del ejemplo sería:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

<h1>Fight for your mind</h1><h2>by Ben Harper - 1995</h2><hr>
<h1>Electric Ladyland</h1><h2>by Jimi Hendrix - 1997</h2><hr>

Ver también

  • XSLTProcessor::transformToDoc() - Transforma en un DOMDocument
  • XSLTProcessor::transformToUri() - Transformar a URI


Extensiones de GUI

  • UI
    • Introducción
    • Instalación/Configuración
    • UI\Point — Represents a position (x,y)
    • UI\Size — Represents dimenstions (width, height)
    • UI\Window — Window
    • UI\Control — Control
    • UI\Menu — Menu
    • UI\MenuItem — Menu Item
    • UI\Area — Area
    • UI\Executor — Execution Scheduler
    • UI\Controls\Tab — Tab Control
    • UI\Controls\Check — Check Control
    • UI\Controls\Button — Button Control
    • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\Label — Label Control
    • UI\Controls\Entry — Entry Control
    • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\Spin — Spin Control
    • UI\Controls\Slider — Slider Control
    • UI\Controls\Progress — Progress Control
    • UI\Controls\Separator — Control Separator
    • UI\Controls\Combo — Combo Control
    • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\Radio — Radio Control
    • UI\Controls\Picker — Picker Control
    • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Box — Control Box (Arrangement)
    • UI\Draw\Pen — Draw Pen
    • UI\Draw\Path — Draw Path
    • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Color — Color Representation
    • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Brush — Brushes
    • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI Funciones
    • UI\Draw\Text\Font\Weight — Font Weight Settings
    • UI\Draw\Text\Font\Italic — Italic Font Settings
    • UI\Draw\Text\Font\Stretch — Font Stretch Settings
    • UI\Draw\Line\Cap — Line Cap Settings
    • UI\Draw\Line\Join — Line Join Settings
    • UI\Key — Key Identifiers
    • UI\Exception\InvalidArgumentException — InvalidArgumentException
    • UI\Exception\RuntimeException — RuntimeException


UI

  • Introducción
  • Instalación/Configuración
    • Requerimientos
    • Instalación
  • UI\Point — Represents a position (x,y)
    • UI\Point::at — Tamaño de coerción
    • UI\Point::__construct — Construye un nuevo punto
    • UI\Point::getX — Recupera X
    • UI\Point::getY — Recupera Y
    • UI\Point::setX — Establece X
    • UI\Point::setY — Establece Y
  • UI\Size — Represents dimenstions (width, height)
    • UI\Size::__construct — Construye un nuevo tamaño
    • UI\Size::getHeight — Recupera la altura
    • UI\Size::getWidth — Recupera el ancho
    • UI\Size::of — Punto de coerción
    • UI\Size::setHeight — Establece la altura
    • UI\Size::setWidth — Establece el ancho
  • UI\Window — Window
    • UI\Window::add — Añade un control
    • UI\Window::__construct — Construye una nueva ventana
    • UI\Window::error — Mostrar cuadro de error
    • UI\Window::getSize — Obtiene el tamaño de la ventana
    • UI\Window::getTitle — Obtiene el título
    • UI\Window::hasBorders — Detección del Borde
    • UI\Window::hasMargin — Detección de Margen
    • UI\Window::isFullScreen — Detección de pantalla completa
    • UI\Window::msg — Mostrar Cuadro de Mensajes
    • UI\Window::onClosing — Cierre de la devolución de llamada
    • UI\Window::open — Abrir Diálogo
    • UI\Window::save — Guarda Diálogo
    • UI\Window::setBorders — Uso de Bordes
    • UI\Window::setFullScreen — Uso de la pantalla completa
    • UI\Window::setMargin — Uso del Margen
    • UI\Window::setSize — Establece Tamaño
    • UI\Window::setTitle — Título de la Vetana
  • UI\Control — Control
    • UI\Control::destroy — Destroy Control
    • UI\Control::disable — Disable Control
    • UI\Control::enable — Enable Control
    • UI\Control::getParent — Get Parent Control
    • UI\Control::getTopLevel — Get Top Level
    • UI\Control::hide — Hide Control
    • UI\Control::isEnabled — Determine if Control is enabled
    • UI\Control::isVisible — Determine if Control is visible
    • UI\Control::setParent — Set Parent Control
    • UI\Control::show — Control Show
  • UI\Menu — Menu
    • UI\Menu::append — Añade elemento de menú
    • UI\Menu::appendAbout — Añade elemento de menú Acerca de
    • UI\Menu::appendCheck — Añade un elemento de menú comprobable
    • UI\Menu::appendPreferences — Añade elemento de menú de preferencias
    • UI\Menu::appendQuit — Añade elemento de menú salir
    • UI\Menu::appendSeparator — Añade separador de elementos del menú
    • UI\Menu::__construct — Construye un nuevo menú
  • UI\MenuItem — Menu Item
    • UI\MenuItem::disable — Desactiva elemento del menú
    • UI\MenuItem::enable — Activa elemento de menú
    • UI\MenuItem::isChecked — Detecta Marcado
    • UI\MenuItem::onClick — Llamada de retorno On Click
    • UI\MenuItem::setChecked — Establece marcado
  • UI\Area — Area
    • UI\Area::onDraw — Draw Callback
    • UI\Area::onKey — Key Callback
    • UI\Area::onMouse — Mouse Callback
    • UI\Area::redraw — Redraw Area
    • UI\Area::scrollTo — Area Scroll
    • UI\Area::setSize — Set Size
  • UI\Executor — Execution Scheduler
    • UI\Executor::__construct — Construct a new Executor
    • UI\Executor::kill — Stop Executor
    • UI\Executor::onExecute — Execution Callback
    • UI\Executor::setInterval — Interval Manipulation
  • UI\Controls\Tab — Tab Control
    • UI\Controls\Tab::append — Append Page
    • UI\Controls\Tab::delete — Delete Page
    • UI\Controls\Tab::hasMargin — Margin Detection
    • UI\Controls\Tab::insertAt — Insert Page
    • UI\Controls\Tab::pages — Page Count
    • UI\Controls\Tab::setMargin — Set Margin
  • UI\Controls\Check — Check Control
    • UI\Controls\Check::__construct — Construct a new Check
    • UI\Controls\Check::getText — Get Text
    • UI\Controls\Check::isChecked — Checked Detection
    • UI\Controls\Check::onToggle — Toggle Callback
    • UI\Controls\Check::setChecked — Set Checked
    • UI\Controls\Check::setText — Set Text
  • UI\Controls\Button — Button Control
    • UI\Controls\Button::__construct — Construct a new Button
    • UI\Controls\Button::getText — Get Text
    • UI\Controls\Button::onClick — Click Handler
    • UI\Controls\Button::setText — Set Text
  • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\ColorButton::getColor — Get Color
    • UI\Controls\ColorButton::onChange — Change Handler
    • UI\Controls\ColorButton::setColor — Set Color
  • UI\Controls\Label — Label Control
    • UI\Controls\Label::__construct — Construct a new Label
    • UI\Controls\Label::getText — Get Text
    • UI\Controls\Label::setText — Set Text
  • UI\Controls\Entry — Entry Control
    • UI\Controls\Entry::__construct — Construct a new Entry
    • UI\Controls\Entry::getText — Get Text
    • UI\Controls\Entry::isReadOnly — Detect Read Only
    • UI\Controls\Entry::onChange — Change Handler
    • UI\Controls\Entry::setReadOnly — Set Read Only
    • UI\Controls\Entry::setText — Set Text
  • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\MultilineEntry::append — Append Text
    • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
    • UI\Controls\MultilineEntry::getText — Get Text
    • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
    • UI\Controls\MultilineEntry::onChange — Change Handler
    • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
    • UI\Controls\MultilineEntry::setText — Set Text
  • UI\Controls\Spin — Spin Control
    • UI\Controls\Spin::__construct — Construct a new Spin
    • UI\Controls\Spin::getValue — Get Value
    • UI\Controls\Spin::onChange — Change Handler
    • UI\Controls\Spin::setValue — Set Value
  • UI\Controls\Slider — Slider Control
    • UI\Controls\Slider::__construct — Construct a new Slider
    • UI\Controls\Slider::getValue — Get Value
    • UI\Controls\Slider::onChange — Change Handler
    • UI\Controls\Slider::setValue — Set Value
  • UI\Controls\Progress — Progress Control
    • UI\Controls\Progress::getValue — Get Value
    • UI\Controls\Progress::setValue — Set Value
  • UI\Controls\Separator — Control Separator
    • UI\Controls\Separator::__construct — Construct a new Separator
  • UI\Controls\Combo — Combo Control
    • UI\Controls\Combo::append — Append Option
    • UI\Controls\Combo::getSelected — Get Selected Option
    • UI\Controls\Combo::onSelected — Selected Handler
    • UI\Controls\Combo::setSelected — Set Selected Option
  • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\EditableCombo::append — Append Option
    • UI\Controls\EditableCombo::getText — Get Text
    • UI\Controls\EditableCombo::onChange — Change Handler
    • UI\Controls\EditableCombo::setText — Set Text
  • UI\Controls\Radio — Radio Control
    • UI\Controls\Radio::append — Append Option
    • UI\Controls\Radio::getSelected — Get Selected Option
    • UI\Controls\Radio::onSelected — Selected Handler
    • UI\Controls\Radio::setSelected — Set Selected Option
  • UI\Controls\Picker — Picker Control
    • UI\Controls\Picker::__construct — Construct a new Picker
  • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Form::append — Append Control
    • UI\Controls\Form::delete — Delete Control
    • UI\Controls\Form::isPadded — Padding Detection
    • UI\Controls\Form::setPadded — Set Padding
  • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Grid::append — Append Control
    • UI\Controls\Grid::isPadded — Padding Detection
    • UI\Controls\Grid::setPadded — Set Padding
  • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Group::append — Append Control
    • UI\Controls\Group::__construct — Construct a new Group
    • UI\Controls\Group::getTitle — Get Title
    • UI\Controls\Group::hasMargin — Margin Detection
    • UI\Controls\Group::setMargin — Set Margin
    • UI\Controls\Group::setTitle — Set Title
  • UI\Controls\Box — Control Box (Arrangement)
    • UI\Controls\Box::append — Append Control
    • UI\Controls\Box::__construct — Construct a new Box
    • UI\Controls\Box::delete — Delete Control
    • UI\Controls\Box::getOrientation — Get Orientation
    • UI\Controls\Box::isPadded — Padding Detection
    • UI\Controls\Box::setPadded — Set Padding
  • UI\Draw\Pen — Draw Pen
    • UI\Draw\Pen::clip — Clip a Path
    • UI\Draw\Pen::fill — Llena una ruta
    • UI\Draw\Pen::restore — Restaura
    • UI\Draw\Pen::save — Guarda
    • UI\Draw\Pen::stroke — Traza una ruta
    • UI\Draw\Pen::transform — Transformación de la matriz
    • UI\Draw\Pen::write — Dibuja el texto en el punto
  • UI\Draw\Path — Draw Path
    • UI\Draw\Path::addRectangle — Dibuja un rectángulo
    • UI\Draw\Path::arcTo — Dibuja un arco
    • UI\Draw\Path::bezierTo — Draw Bezier Curve
    • UI\Draw\Path::closeFigure — Cerrar Figura
    • UI\Draw\Path::__construct — Construye una nueva ruta
    • UI\Draw\Path::end — Finalizar Ruta
    • UI\Draw\Path::lineTo — Dibuja una línea
    • UI\Draw\Path::newFigure — Dibuja figura
    • UI\Draw\Path::newFigureWithArc — Dibuja figura con arco
  • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Matrix::invert — Invertir matriz
    • UI\Draw\Matrix::isInvertible — Detección de invertido
    • UI\Draw\Matrix::multiply — Multiplica la matriz
    • UI\Draw\Matrix::rotate — Rota la matriz
    • UI\Draw\Matrix::scale — Escala la Matriz
    • UI\Draw\Matrix::skew — Inclina la Matriz
    • UI\Draw\Matrix::translate — Traduce la matriz
  • UI\Draw\Color — Color Representation
    • UI\Draw\Color::__construct — Construye un nuevo color
    • UI\Draw\Color::getChannel — Manipulación de color
    • UI\Draw\Color::setChannel — Manipulación de color
  • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Stroke::__construct — Construye un nuevo trazo
    • UI\Draw\Stroke::getCap — Get Line Cap
    • UI\Draw\Stroke::getJoin — Obtiene la unión de línea
    • UI\Draw\Stroke::getMiterLimit — Obtiene el límite de inglete
    • UI\Draw\Stroke::getThickness — Obtiene el grosor
    • UI\Draw\Stroke::setCap — Set Line Cap
    • UI\Draw\Stroke::setJoin — Establece la línea de unión
    • UI\Draw\Stroke::setMiterLimit — Establece el límite de ingletes
    • UI\Draw\Stroke::setThickness — Establece el grosor
  • UI\Draw\Brush — Brushes
    • UI\Draw\Brush::__construct — Construct a new Brush
    • UI\Draw\Brush::getColor — Get Color
    • UI\Draw\Brush::setColor — Set Color
  • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop — Stop Manipulation
  • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient
  • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient
  • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Layout::__construct — Construir un nuevo diseño de texto
    • UI\Draw\Text\Layout::setColor — Establece el color
    • UI\Draw\Text\Layout::setWidth — Establece el ancho
  • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font::__construct — Construye una nueva fuente
    • UI\Draw\Text\Font::getAscent — Métricas de la fuente
    • UI\Draw\Text\Font::getDescent — Métricas de la fuente
    • UI\Draw\Text\Font::getLeading — Métricas de la fuente
    • UI\Draw\Text\Font::getUnderlinePosition — Métricas de la fuente
    • UI\Draw\Text\Font::getUnderlineThickness — Métricas de la fuente
  • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
    • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection
  • UI Funciones
    • UI\Draw\Text\Font\fontFamilies — Recuperar las familias de fuentes
    • UI\quit — Quit UI Loop
    • UI\run — Enter UI Loop
  • UI\Draw\Text\Font\Weight — Font Weight Settings
  • UI\Draw\Text\Font\Italic — Italic Font Settings
  • UI\Draw\Text\Font\Stretch — Font Stretch Settings
  • UI\Draw\Line\Cap — Line Cap Settings
  • UI\Draw\Line\Join — Line Join Settings
  • UI\Key — Key Identifiers
  • UI\Exception\InvalidArgumentException — InvalidArgumentException
  • UI\Exception\RuntimeException — RuntimeException


Introducción

This extension wraps libui to provide an OO API for the cross platform development of native look-and-feel user interfaces .


  • « Introducción
  • Requerimientos »
  • PHP Manual
  • UI
  • Instalación/Configuración

Instalación/Configuración

Tabla de contenidos

  • Requerimientos
  • Instalación


Requerimientos

Installation requires the libui library, and PHP 7 or newer.

This extension requires the » libui library version 0.1.0 or higher to be installed. See the libui documentation for a list of prerequisites.


Instalación

Esta extensión » PECL no se distribuye con PHP.

Se puede encontrar información para la instalación de esta extensión PECL en el capítulo del manual titulado Instalación de extensiones PECL. Se puede encontrar información adicional, tal como nuevos lanzamientos, descargas, ficheros fuente, información de mantenimiento, y un CHANGELOG, aquí: » https://pecl.php.net/package/ui.

Los binarios de Windows (ficheros DLL) para esta extensión de PECL están disponibles en el sitio web de PECL.


Represents a position (x,y)

(UI 0.9.9)

Introducción

Points are used throughout UI to represent co-ordinates on a screen, control, or area.

Sinopsis de la Clase

final UI\Point {
/* Propiedades */
public $x ;
public $y ;
/* Constructor */
public __construct ( float $x , float $y )
/* Métodos */
public static at ( float $point ) : UI\Point
public static at ( UI\Size $size ) : UI\Point
public getX ( ) : float
public getY ( ) : float
public setX ( float $point )
public setY ( float $point )
}

Propiedades

x

Holds the X co-ordinate, can be read/written directly

y

Holds the Y co-ordinate, can be read/written directly

Tabla de contenidos

  • UI\Point::at — Tamaño de coerción
  • UI\Point::__construct — Construye un nuevo punto
  • UI\Point::getX — Recupera X
  • UI\Point::getY — Recupera Y
  • UI\Point::setX — Establece X
  • UI\Point::setY — Establece Y


Tamaño de coerción

  • « UI\Point
  • UI\Point::__construct »
  • PHP Manual
  • UI\Point
  • Tamaño de coerción

UI\Point::at

(UI 1.0.2)

UI\Point::at — Tamaño de coerción

Descripción

public static UI\Point::at ( float $point ) : UI\Point
public static UI\Point::at ( UI\Size $size ) : UI\Point

Devolverá un objeto de punto UI donde x y y son iguales a los suministrados, ya sea en forma flotante o de tamaño UI.

Parámetros

point

El valor de x y y

size

El tamaño a convertir

Valores devueltos

El punto resultante


Construye un nuevo punto

  • « UI\Point::at
  • UI\Point::getX »
  • PHP Manual
  • UI\Point
  • Construye un nuevo punto

UI\Point::__construct

(UI 0.9.9)

UI\Point::__construct — Construye un nuevo punto

Descripción

public UI\Point::__construct ( float $x , float $y )

Construye un nuevo punto usando nuevas coordenadas

Parámetros

x

La nueva coordenada X

y

La nueva coordenada Y


Recupera X

  • « UI\Point::__construct
  • UI\Point::getY »
  • PHP Manual
  • UI\Point
  • Recupera X

UI\Point::getX

(UI 0.9.9)

UI\Point::getX — Recupera X

Descripción

public UI\Point::getX ( ) : float

Recupera la coordenada X

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La coordenada X actual


Recupera Y

  • « UI\Point::getX
  • UI\Point::setX »
  • PHP Manual
  • UI\Point
  • Recupera Y

UI\Point::getY

(UI 0.9.9)

UI\Point::getY — Recupera Y

Descripción

public UI\Point::getY ( ) : float

Recupera la coordenada Y

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La coordenada Y actual


Establece X

  • « UI\Point::getY
  • UI\Point::setY »
  • PHP Manual
  • UI\Point
  • Establece X

UI\Point::setX

(UI 0.9.9)

UI\Point::setX — Establece X

Descripción

public UI\Point::setX ( float $point )

Establece la coordenada X

Parámetros

point

La nueva coordenada X

Valores devueltos


Establece Y

  • « UI\Point::setX
  • UI\Size »
  • PHP Manual
  • UI\Point
  • Establece Y

UI\Point::setY

(UI 0.9.9)

UI\Point::setY — Establece Y

Descripción

public UI\Point::setY ( float $point )

Establece la coordenada Y

Parámetros

point

La nueva coordenada Y

Valores devueltos


Represents dimenstions (width, height)

(UI 0.9.9)

Introducción

Sizes are used throughout UI to represent the size of a screen, control, or area.

Sinopsis de la Clase

final UI\Size {
/* Propiedades */
public $width ;
public $height ;
/* Constructor */
public __construct ( float $width , float $height )
/* Métodos */
public getHeight ( ) : float
public getWidth ( ) : float
public static of ( float $size ) : UI\Size
public static of ( UI\Point $point ) : UI\Size
public setHeight ( float $size )
public setWidth ( float $size )
}

Propiedades

width

Holds the width, can be read/written directly

height

Holds the height, can be read/written directly

Tabla de contenidos

  • UI\Size::__construct — Construye un nuevo tamaño
  • UI\Size::getHeight — Recupera la altura
  • UI\Size::getWidth — Recupera el ancho
  • UI\Size::of — Punto de coerción
  • UI\Size::setHeight — Establece la altura
  • UI\Size::setWidth — Establece el ancho


Construye un nuevo tamaño

  • « UI\Size
  • UI\Size::getHeight »
  • PHP Manual
  • UI\Size
  • Construye un nuevo tamaño

UI\Size::__construct

(UI 0.9.9)

UI\Size::__construct — Construye un nuevo tamaño

Descripción

public UI\Size::__construct ( float $width , float $height )

Construye un nuevo tamaño usando un nuevo ancho y alto

Parámetros

width

El nuevo ancho

height

El nuevo alto


Recupera la altura

  • « UI\Size::__construct
  • UI\Size::getWidth »
  • PHP Manual
  • UI\Size
  • Recupera la altura

UI\Size::getHeight

(UI 0.9.9)

UI\Size::getHeight — Recupera la altura

Descripción

public UI\Size::getHeight ( ) : float

Recupera la altura

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La altura actual


Recupera el ancho

  • « UI\Size::getHeight
  • UI\Size::of »
  • PHP Manual
  • UI\Size
  • Recupera el ancho

UI\Size::getWidth

(UI 0.9.9)

UI\Size::getWidth — Recupera el ancho

Descripción

public UI\Size::getWidth ( ) : float

Recupera el ancho

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El ancho actual


Punto de coerción

  • « UI\Size::getWidth
  • UI\Size::setHeight »
  • PHP Manual
  • UI\Size
  • Punto de coerción

UI\Size::of

(UI 1.0.2)

UI\Size::of — Punto de coerción

Descripción

public static UI\Size::of ( float $size ) : UI\Size
public static UI\Size::of ( UI\Point $point ) : UI\Size

Devolverá un objeto de tamaño UI en el que el ancho y la altura son iguales a los suministrados, ya sea en forma flotante o en forma de UI.

Parámetros

size

El valor de la anchura y la altura

point

El punto a convertir

Valores devueltos

El tamaño resultante


Establece la altura

  • « UI\Size::of
  • UI\Size::setWidth »
  • PHP Manual
  • UI\Size
  • Establece la altura

UI\Size::setHeight

(UI 0.9.9)

UI\Size::setHeight — Establece la altura

Descripción

public UI\Size::setHeight ( float $size )

Establece una nueva altura

Parámetros

size

La nueva altura

Valores devueltos


Establece el ancho

  • « UI\Size::setHeight
  • UI\Window »
  • PHP Manual
  • UI\Size
  • Establece el ancho

UI\Size::setWidth

(UI 0.9.9)

UI\Size::setWidth — Establece el ancho

Descripción

public UI\Size::setWidth ( float $size )

Establece un nuevo ancho

Parámetros

size

El nuevo ancho

Valores devueltos


Window

(UI 0.9.9)

Introducción

Represents a UI Window

Sinopsis de la Clase

UI\Window extends UI\Control {
/* Propiedades */
protected $controls ;
/* Constructor */
public __construct ( string $title , Size $size , bool $menu = false )
/* Métodos */
public add ( UI\Control $control )
public error ( string $title , string $msg )
public getSize ( ) : UI\Size
public getTitle ( ) : string
public hasBorders ( ) : bool
public hasMargin ( ) : bool
public isFullScreen ( ) : bool
public msg ( string $title , string $msg )
protected onClosing ( ) : int
public open ( ) : string
public save ( ) : string
public setBorders ( bool $borders )
public setFullScreen ( bool $full )
public setMargin ( bool $margin )
public setSize ( UI\Size $size )
public setTitle ( string $title )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Propiedades

controls

Contains controls, should not be manipulated directly

Tabla de contenidos

  • UI\Window::add — Añade un control
  • UI\Window::__construct — Construye una nueva ventana
  • UI\Window::error — Mostrar cuadro de error
  • UI\Window::getSize — Obtiene el tamaño de la ventana
  • UI\Window::getTitle — Obtiene el título
  • UI\Window::hasBorders — Detección del Borde
  • UI\Window::hasMargin — Detección de Margen
  • UI\Window::isFullScreen — Detección de pantalla completa
  • UI\Window::msg — Mostrar Cuadro de Mensajes
  • UI\Window::onClosing — Cierre de la devolución de llamada
  • UI\Window::open — Abrir Diálogo
  • UI\Window::save — Guarda Diálogo
  • UI\Window::setBorders — Uso de Bordes
  • UI\Window::setFullScreen — Uso de la pantalla completa
  • UI\Window::setMargin — Uso del Margen
  • UI\Window::setSize — Establece Tamaño
  • UI\Window::setTitle — Título de la Vetana


Añade un control

  • « UI\Window
  • UI\Window::__construct »
  • PHP Manual
  • UI\Window
  • Añade un control

UI\Window::add

(UI 0.9.9)

UI\Window::add — Añade un control

Descripción

public UI\Window::add ( UI\Control $control )

Añadirá un control a esta ventana

Parámetros

control

El control a añadir

Valores devueltos


Construye una nueva ventana

  • « UI\Window::add
  • UI\Window::error »
  • PHP Manual
  • UI\Window
  • Construye una nueva ventana

UI\Window::__construct

(UI 0.9.9)

UI\Window::__construct — Construye una nueva ventana

Descripción

public UI\Window::__construct ( string $title , Size $size , bool $menu = false )

Construirá una nueva ventana

Parámetros

title

El título de la Ventana

size

El tamaño de la Ventana

menu

Interruptor del menú


Mostrar cuadro de error

  • « UI\Window::__construct
  • UI\Window::getSize »
  • PHP Manual
  • UI\Window
  • Mostrar cuadro de error

UI\Window::error

(UI 0.9.9)

UI\Window::error — Mostrar cuadro de error

Descripción

public UI\Window::error ( string $title , string $msg )

Mostrará un cuadro de error

Parámetros

title

El título del cuadro de error

msg

El mensaje para el cuadro de error


Obtiene el tamaño de la ventana

  • « UI\Window::error
  • UI\Window::getTitle »
  • PHP Manual
  • UI\Window
  • Obtiene el tamaño de la ventana

UI\Window::getSize

(UI 0.9.9)

UI\Window::getSize — Obtiene el tamaño de la ventana

Descripción

public UI\Window::getSize ( ) : UI\Size

Devolverá el tamaño de esta ventana

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Obtiene el título

  • « UI\Window::getSize
  • UI\Window::hasBorders »
  • PHP Manual
  • UI\Window
  • Obtiene el título

UI\Window::getTitle

(UI 0.9.9)

UI\Window::getTitle — Obtiene el título

Descripción

public UI\Window::getTitle ( ) : string

Recuperará el título de esta Ventana

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Detección del Borde

  • « UI\Window::getTitle
  • UI\Window::hasMargin »
  • PHP Manual
  • UI\Window
  • Detección del Borde

UI\Window::hasBorders

(UI 0.9.9)

UI\Window::hasBorders — Detección del Borde

Descripción

public UI\Window::hasBorders ( ) : bool

Detectará si se usan bordes en esta ventana

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Detección de Margen

  • « UI\Window::hasBorders
  • UI\Window::isFullScreen »
  • PHP Manual
  • UI\Window
  • Detección de Margen

UI\Window::hasMargin

(UI 0.9.9)

UI\Window::hasMargin — Detección de Margen

Descripción

public UI\Window::hasMargin ( ) : bool

Detectará si se usan márgenes en esta ventana

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Detección de pantalla completa

  • « UI\Window::hasMargin
  • UI\Window::msg »
  • PHP Manual
  • UI\Window
  • Detección de pantalla completa

UI\Window::isFullScreen

(UI 0.9.9)

UI\Window::isFullScreen — Detección de pantalla completa

Descripción

public UI\Window::isFullScreen ( ) : bool

Detectará si esta ventana se utiliza toda la pantalla

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Mostrar Cuadro de Mensajes

  • « UI\Window::isFullScreen
  • UI\Window::onClosing »
  • PHP Manual
  • UI\Window
  • Mostrar Cuadro de Mensajes

UI\Window::msg

(UI 0.9.9)

UI\Window::msg — Mostrar Cuadro de Mensajes

Descripción

public UI\Window::msg ( string $title , string $msg )

Mostrará un cuadro de mensajes

Parámetros

title

El título del cuadro de mensajes

msg

El mensaje


Cierre de la devolución de llamada

  • « UI\Window::msg
  • UI\Window::open »
  • PHP Manual
  • UI\Window
  • Cierre de la devolución de llamada

UI\Window::onClosing

(UI 0.9.9)

UI\Window::onClosing — Cierre de la devolución de llamada

Descripción

protected UI\Window::onClosing ( ) : int

Debería destruir con agilidad esta ventana

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Abrir Diálogo

  • « UI\Window::onClosing
  • UI\Window::save »
  • PHP Manual
  • UI\Window
  • Abrir Diálogo

UI\Window::open

(UI 0.9.9)

UI\Window::open — Abrir Diálogo

Descripción

public UI\Window::open ( ) : string

Mostrará un diálogo de archivo abierto

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del archivo seleccionado para su apertura


Guarda Diálogo

  • « UI\Window::open
  • UI\Window::setBorders »
  • PHP Manual
  • UI\Window
  • Guarda Diálogo

UI\Window::save

(UI 0.9.9)

UI\Window::save — Guarda Diálogo

Descripción

public UI\Window::save ( ) : string

Mostrará un diálogo a guardar

Parámetros

Esta función no tiene parámetros.

Valores devueltos

Devuelve el nombre del archivo seleccionado para ser guardado


Uso de Bordes

  • « UI\Window::save
  • UI\Window::setFullScreen »
  • PHP Manual
  • UI\Window
  • Uso de Bordes

UI\Window::setBorders

(UI 0.9.9)

UI\Window::setBorders — Uso de Bordes

Descripción

public UI\Window::setBorders ( bool $borders )

Habilitará o deshabilitará el uso de los bordes en esta ventana

Parámetros

borders


Uso de la pantalla completa

  • « UI\Window::setBorders
  • UI\Window::setMargin »
  • PHP Manual
  • UI\Window
  • Uso de la pantalla completa

UI\Window::setFullScreen

(UI 0.9.9)

UI\Window::setFullScreen — Uso de la pantalla completa

Descripción

public UI\Window::setFullScreen ( bool $full )

Activará o desactivará el uso de la pantalla completa para esta ventana

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

full


Uso del Margen

  • « UI\Window::setFullScreen
  • UI\Window::setSize »
  • PHP Manual
  • UI\Window
  • Uso del Margen

UI\Window::setMargin

(UI 0.9.9)

UI\Window::setMargin — Uso del Margen

Descripción

public UI\Window::setMargin ( bool $margin )

Habilitará o deshabilitará el uso de los márgenes para esta Ventana

Parámetros

margin


Establece Tamaño

  • « UI\Window::setMargin
  • UI\Window::setTitle »
  • PHP Manual
  • UI\Window
  • Establece Tamaño

UI\Window::setSize

(UI 0.9.9)

UI\Window::setSize — Establece Tamaño

Descripción

public UI\Window::setSize ( UI\Size $size )

Establecerá el tamaño de esta ventana

Parámetros

size

Valores devueltos


Título de la Vetana

  • « UI\Window::setSize
  • UI\Control »
  • PHP Manual
  • UI\Window
  • Título de la Vetana

UI\Window::setTitle

(UI 0.9.9)

UI\Window::setTitle — Título de la Vetana

Descripción

public UI\Window::setTitle ( string $title )

Pondrá el título de esta ventana

Parámetros

title

El nuevo título


Control

(UI 0.9.9)

Introducción

This is the closed base class for all UI Controls.

Sinopsis de la Clase

final UI\Control {
/* Métodos */
public destroy ( )
public disable ( )
public enable ( )
public getParent ( ) : UI\Control
public getTopLevel ( ) : int
public hide ( )
public isEnabled ( ) : bool
public isVisible ( ) : bool
public setParent ( UI\Control $parent )
public show ( )
}

Tabla de contenidos

  • UI\Control::destroy — Destroy Control
  • UI\Control::disable — Disable Control
  • UI\Control::enable — Enable Control
  • UI\Control::getParent — Get Parent Control
  • UI\Control::getTopLevel — Get Top Level
  • UI\Control::hide — Hide Control
  • UI\Control::isEnabled — Determine if Control is enabled
  • UI\Control::isVisible — Determine if Control is visible
  • UI\Control::setParent — Set Parent Control
  • UI\Control::show — Control Show


Destroy Control

  • « UI\Control
  • UI\Control::disable »
  • PHP Manual
  • UI\Control
  • Destroy Control

UI\Control::destroy

(UI 0.9.9)

UI\Control::destroy — Destroy Control

Descripción

public UI\Control::destroy ( )

Shall destroy this Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Disable Control

  • « UI\Control::destroy
  • UI\Control::enable »
  • PHP Manual
  • UI\Control
  • Disable Control

UI\Control::disable

(UI 0.9.9)

UI\Control::disable — Disable Control

Descripción

public UI\Control::disable ( )

Shall disable this Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Enable Control

  • « UI\Control::disable
  • UI\Control::getParent »
  • PHP Manual
  • UI\Control
  • Enable Control

UI\Control::enable

(UI 0.9.9)

UI\Control::enable — Enable Control

Descripción

public UI\Control::enable ( )

Shall enable this Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get Parent Control

  • « UI\Control::enable
  • UI\Control::getTopLevel »
  • PHP Manual
  • UI\Control
  • Get Parent Control

UI\Control::getParent

(UI 0.9.9)

UI\Control::getParent — Get Parent Control

Descripción

public UI\Control::getParent ( ) : UI\Control

Shall return the parent Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Get Top Level

  • « UI\Control::getParent
  • UI\Control::hide »
  • PHP Manual
  • UI\Control
  • Get Top Level

UI\Control::getTopLevel

(UI 0.9.9)

UI\Control::getTopLevel — Get Top Level

Descripción

public UI\Control::getTopLevel ( ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Hide Control

  • « UI\Control::getTopLevel
  • UI\Control::isEnabled »
  • PHP Manual
  • UI\Control
  • Hide Control

UI\Control::hide

(UI 0.9.9)

UI\Control::hide — Hide Control

Descripción

public UI\Control::hide ( )

Shall hide this Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Determine if Control is enabled

  • « UI\Control::hide
  • UI\Control::isVisible »
  • PHP Manual
  • UI\Control
  • Determine if Control is enabled

UI\Control::isEnabled

(UI 0.9.9)

UI\Control::isEnabled — Determine if Control is enabled

Descripción

public UI\Control::isEnabled ( ) : bool

Shall detect if this Control is enabled

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Determine if Control is visible

  • « UI\Control::isEnabled
  • UI\Control::setParent »
  • PHP Manual
  • UI\Control
  • Determine if Control is visible

UI\Control::isVisible

(UI 0.9.9)

UI\Control::isVisible — Determine if Control is visible

Descripción

public UI\Control::isVisible ( ) : bool

Shall detect if this Control is visible

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Set Parent Control

  • « UI\Control::isVisible
  • UI\Control::show »
  • PHP Manual
  • UI\Control
  • Set Parent Control

UI\Control::setParent

(UI 0.9.9)

UI\Control::setParent — Set Parent Control

Descripción

public UI\Control::setParent ( UI\Control $parent )

Shall set the parent Control of this Control

Parámetros

parent

The parent Control

Valores devueltos


Control Show

  • « UI\Control::setParent
  • UI\Menu »
  • PHP Manual
  • UI\Control
  • Control Show

UI\Control::show

(UI 0.9.9)

UI\Control::show — Control Show

Descripción

public UI\Control::show ( )

Shall show this Control

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Menu

(UI 0.9.9)

Introducción

Menus must be constructed before the first Window, and can be shown on any Window

Sinopsis de la Clase

UI\Menu {
/* Constructor */
public __construct ( string $name )
/* Métodos */
public append ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem
public appendAbout ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendCheck ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem
public appendPreferences ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendQuit ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendSeparator ( )
}

Tabla de contenidos

  • UI\Menu::append — Añade elemento de menú
  • UI\Menu::appendAbout — Añade elemento de menú Acerca de
  • UI\Menu::appendCheck — Añade un elemento de menú comprobable
  • UI\Menu::appendPreferences — Añade elemento de menú de preferencias
  • UI\Menu::appendQuit — Añade elemento de menú salir
  • UI\Menu::appendSeparator — Añade separador de elementos del menú
  • UI\Menu::__construct — Construye un nuevo menú


Añade elemento de menú

  • « UI\Menu
  • UI\Menu::appendAbout »
  • PHP Manual
  • UI\Menu
  • Añade elemento de menú

UI\Menu::append

(UI 0.9.9)

UI\Menu::append — Añade elemento de menú

Descripción

public UI\Menu::append ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem

Añadirá un nuevo elemento del menú

Parámetros

name

El nombre (texto) del nuevo elemento

type

El tipo para el nuevo elemento

Valores devueltos

Un objeto construido del tipo dado


Añade elemento de menú Acerca de

  • « UI\Menu::append
  • UI\Menu::appendCheck »
  • PHP Manual
  • UI\Menu
  • Añade elemento de menú Acerca de

UI\Menu::appendAbout

(UI 0.9.9)

UI\Menu::appendAbout — Añade elemento de menú Acerca de

Descripción

public UI\Menu::appendAbout ( string $type = UI\MenuItem::class ) : UI\MenuItem

Se añadirá un elemento del menú Acerca de

Parámetros

type

El tipo para el nuevo elemento

Valores devueltos

Un elemento del menú Acerca de construido del tipo dado


Añade un elemento de menú comprobable

  • « UI\Menu::appendAbout
  • UI\Menu::appendPreferences »
  • PHP Manual
  • UI\Menu
  • Añade un elemento de menú comprobable

UI\Menu::appendCheck

(UI 0.9.9)

UI\Menu::appendCheck — Añade un elemento de menú comprobable

Descripción

public UI\Menu::appendCheck ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem

Se añadirá un elemento del menú comprobable

Parámetros

name

El nombre (texto) del nuevo elemento

type

El tipo para el nuevo elemento

Valores devueltos

Un elemento de menú construido y comprobable del tipo dado


Añade elemento de menú de preferencias

  • « UI\Menu::appendCheck
  • UI\Menu::appendQuit »
  • PHP Manual
  • UI\Menu
  • Añade elemento de menú de preferencias

UI\Menu::appendPreferences

(UI 0.9.9)

UI\Menu::appendPreferences — Añade elemento de menú de preferencias

Descripción

public UI\Menu::appendPreferences ( string $type = UI\MenuItem::class ) : UI\MenuItem

Se añadirá un elemento del menú de Preferencias

Parámetros

type

El tipo para el nuevo elemento

Valores devueltos

Un elemento de menú de Preferencias construido del tipo dado


Añade elemento de menú salir

  • « UI\Menu::appendPreferences
  • UI\Menu::appendSeparator »
  • PHP Manual
  • UI\Menu
  • Añade elemento de menú salir

UI\Menu::appendQuit

(UI 0.9.9)

UI\Menu::appendQuit — Añade elemento de menú salir

Descripción

public UI\Menu::appendQuit ( string $type = UI\MenuItem::class ) : UI\MenuItem

Se añadirá un elemento del menú de salida

Parámetros

type

El tipo para el nuevo elemento

Valores devueltos

Un elemento del menú de salida construido del tipo dado


Añade separador de elementos del menú

  • « UI\Menu::appendQuit
  • UI\Menu::__construct »
  • PHP Manual
  • UI\Menu
  • Añade separador de elementos del menú

UI\Menu::appendSeparator

(UI 0.9.9)

UI\Menu::appendSeparator — Añade separador de elementos del menú

Descripción

public UI\Menu::appendSeparator ( )

Se añadirá un separador

Parámetros

Esta función no tiene parámetros.


Construye un nuevo menú

  • « UI\Menu::appendSeparator
  • UI\MenuItem »
  • PHP Manual
  • UI\Menu
  • Construye un nuevo menú

UI\Menu::__construct

(UI 0.9.9)

UI\Menu::__construct — Construye un nuevo menú

Descripción

public UI\Menu::__construct ( string $name )

Construirá un nuevo menú

Parámetros

name

El nombre (texto) del menú


Menu Item

(UI 0.9.9)

Introducción

Menu Items should only be created by the Menu

Sinopsis de la Clase

UI\MenuItem {
/* Métodos */
public disable ( )
public enable ( )
public isChecked ( ) : bool
protected onClick ( )
public setChecked ( bool $checked )
}

Tabla de contenidos

  • UI\MenuItem::disable — Desactiva elemento del menú
  • UI\MenuItem::enable — Activa elemento de menú
  • UI\MenuItem::isChecked — Detecta Marcado
  • UI\MenuItem::onClick — Llamada de retorno On Click
  • UI\MenuItem::setChecked — Establece marcado


Desactiva elemento del menú

  • « UI\MenuItem
  • UI\MenuItem::enable »
  • PHP Manual
  • UI\MenuItem
  • Desactiva elemento del menú

UI\MenuItem::disable

(UI 0.9.9)

UI\MenuItem::disable — Desactiva elemento del menú

Descripción

public UI\MenuItem::disable ( )

Desactivará este elemento del menú

Parámetros

Esta función no tiene parámetros.


Activa elemento de menú

  • « UI\MenuItem::disable
  • UI\MenuItem::isChecked »
  • PHP Manual
  • UI\MenuItem
  • Activa elemento de menú

UI\MenuItem::enable

(UI 0.9.9)

UI\MenuItem::enable — Activa elemento de menú

Descripción

public UI\MenuItem::enable ( )

Activará este elemento del menú

Parámetros

Esta función no tiene parámetros.


Detecta Marcado

  • « UI\MenuItem::enable
  • UI\MenuItem::onClick »
  • PHP Manual
  • UI\MenuItem
  • Detecta Marcado

UI\MenuItem::isChecked

(UI 0.9.9)

UI\MenuItem::isChecked — Detecta Marcado

Descripción

public UI\MenuItem::isChecked ( ) : bool

Detecta si este elemento del menú está marcado

Parámetros

Esta función no tiene parámetros.


Llamada de retorno On Click

  • « UI\MenuItem::isChecked
  • UI\MenuItem::setChecked »
  • PHP Manual
  • UI\MenuItem
  • Llamada de retorno On Click

UI\MenuItem::onClick

(UI 0.9.9)

UI\MenuItem::onClick — Llamada de retorno On Click

Descripción

protected UI\MenuItem::onClick ( )

Se ejecutará cuando se haga clic en este elemento del menú

Parámetros

Esta función no tiene parámetros.


Establece marcado

  • « UI\MenuItem::onClick
  • UI\Area »
  • PHP Manual
  • UI\MenuItem
  • Establece marcado

UI\MenuItem::setChecked

(UI 0.9.9)

UI\MenuItem::setChecked — Establece marcado

Descripción

public UI\MenuItem::setChecked ( bool $checked )

Establecerá el estado marcado de este elemento del menú

Parámetros

checked

El nuevo estado


Area

(UI 0.9.9)

Introducción

An Area represents a canvas which can be used to draw, and respond to mouse and key events.

Sinopsis de la Clase

UI\Area extends UI\Control {
/* Constants */
const int Ctrl ;
const int Alt ;
const int Shift ;
const int Super ;
const int Down ;
const int Up ;
/* Métodos */
protected onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )
protected onKey ( string $key , int $ext , int $flags )
protected onMouse ( UI\Point $areaPoint , UI\Size $areaSize , int $flags )
public redraw ( )
public scrollTo ( UI\Point $point , UI\Size $size )
public setSize ( UI\Size $size )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Area::Ctrl

Shall be set in the modifiers passed to key and mouse events when the CTRL key is active

UI\Area::Alt

Shall be set in the modifiers passed to key and mouse events when the ALT key is active

UI\Area::Shift

Shall be set in the modifiers passed to key and mouse events when the SHIFT key is active

UI\Area::Super

UI\Area::Down

Shall be set in the modifiers passed to key and mouse events

UI\Area::Up

Shall be set in the modifiers passed to key and mouse events

Tabla de contenidos

  • UI\Area::onDraw — Draw Callback
  • UI\Area::onKey — Key Callback
  • UI\Area::onMouse — Mouse Callback
  • UI\Area::redraw — Redraw Area
  • UI\Area::scrollTo — Area Scroll
  • UI\Area::setSize — Set Size


Draw Callback

  • « UI\Area
  • UI\Area::onKey »
  • PHP Manual
  • UI\Area
  • Draw Callback

UI\Area::onDraw

(UI 0.9.9)

UI\Area::onDraw — Draw Callback

Descripción

protected UI\Area::onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )

Shall be invoked when this Area requires redrawing

Parámetros

pen

A Pen suitable for drawing in this Area

areaSize

The size of the Area

clipPoint

The clip point of the Area

clipSize

The clip size of the Area


Key Callback

  • « UI\Area::onDraw
  • UI\Area::onMouse »
  • PHP Manual
  • UI\Area
  • Key Callback

UI\Area::onKey

(UI 0.9.9)

UI\Area::onKey — Key Callback

Descripción

protected UI\Area::onKey ( string $key , int $ext , int $flags )

Shall be executed on key events

Parámetros

key

The key pressed

ext

The extended key pressed

flags

Event modifiers

Valores devueltos


Mouse Callback

  • « UI\Area::onKey
  • UI\Area::redraw »
  • PHP Manual
  • UI\Area
  • Mouse Callback

UI\Area::onMouse

(UI 0.9.9)

UI\Area::onMouse — Mouse Callback

Descripción

protected UI\Area::onMouse ( UI\Point $areaPoint , UI\Size $areaSize , int $flags )

Shall be executed on mouse events

Parámetros

areaPoint

The co-ordinates of the event

areaSize

The size of the area of the event

flags

Event modifiers


Redraw Area

  • « UI\Area::onMouse
  • UI\Area::scrollTo »
  • PHP Manual
  • UI\Area
  • Redraw Area

UI\Area::redraw

(UI 0.9.9)

UI\Area::redraw — Redraw Area

Descripción

public UI\Area::redraw ( )

Requests that this Area is redrawn

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Area Scroll

  • « UI\Area::redraw
  • UI\Area::setSize »
  • PHP Manual
  • UI\Area
  • Area Scroll

UI\Area::scrollTo

(UI 0.9.9)

UI\Area::scrollTo — Area Scroll

Descripción

public UI\Area::scrollTo ( UI\Point $point , UI\Size $size )

Scroll this Area

Parámetros

point

The point to scroll to

size

The size of the scroll pane


Set Size

  • « UI\Area::scrollTo
  • UI\Executor »
  • PHP Manual
  • UI\Area
  • Set Size

UI\Area::setSize

(UI 0.9.9)

UI\Area::setSize — Set Size

Descripción

public UI\Area::setSize ( UI\Size $size )

Sets the size of this Area

Parámetros

size

The new size


Execution Scheduler

(UI 2.0.0)

Introducción

This facility schedules repetitive execution of a callback, useful for animations and other such activities.

Sinopsis de la Clase

abstract UI\Executor {
/* Constructor */
public __construct ( )
public __construct ( int $microseconds )
public __construct ( int $seconds , int $microseconds )
/* Métodos */
public kill ( ) : void
abstract protected onExecute ( ) : void
public setInterval ( int $microseconds ) : bool
public setInterval ( int $seconds , int $microseconds ) : bool
}

Tabla de contenidos

  • UI\Executor::__construct — Construct a new Executor
  • UI\Executor::kill — Stop Executor
  • UI\Executor::onExecute — Execution Callback
  • UI\Executor::setInterval — Interval Manipulation


Construct a new Executor

  • « UI\Executor
  • UI\Executor::kill »
  • PHP Manual
  • UI\Executor
  • Construct a new Executor

UI\Executor::__construct

(UI 2.0.0)

UI\Executor::__construct — Construct a new Executor

Descripción

public UI\Executor::__construct ( )
public UI\Executor::__construct ( int $microseconds )
public UI\Executor::__construct ( int $seconds , int $microseconds )

Shall construct an executor with the given interval, will not start executing until main loop is entered

Parámetros

seconds

Seconds between executions

microseconds

Microseconds between executions


Stop Executor

  • « UI\Executor::__construct
  • UI\Executor::onExecute »
  • PHP Manual
  • UI\Executor
  • Stop Executor

UI\Executor::kill

(UI 2.0.0)

UI\Executor::kill — Stop Executor

Descripción

public UI\Executor::kill ( ) : void

Shall stop an executor, the executor cannot be restarted

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Execution Callback

  • « UI\Executor::kill
  • UI\Executor::setInterval »
  • PHP Manual
  • UI\Executor
  • Execution Callback

UI\Executor::onExecute

(UI 2.0.0)

UI\Executor::onExecute — Execution Callback

Descripción

abstract protected UI\Executor::onExecute ( ) : void

Shall be repetitively queued for execution in the main thread

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Interval Manipulation

  • « UI\Executor::onExecute
  • UI\Controls\Tab »
  • PHP Manual
  • UI\Executor
  • Interval Manipulation

UI\Executor::setInterval

(UI 2.0.0)

UI\Executor::setInterval — Interval Manipulation

Descripción

public UI\Executor::setInterval ( int $microseconds ) : bool
public UI\Executor::setInterval ( int $seconds , int $microseconds ) : bool

Shall set the new interval. An interval of 0 will pause the executor until a new interval has been set

Parámetros

seconds

microseconds

Valores devueltos

Indication of success


Tab Control

(UI 0.9.9)

Introducción

A Tab can contain many pages of Controls, each with a title, each selectable by the user.

Sinopsis de la Clase

UI\Controls\Tab extends UI\Control {
/* Propiedades */
protected $controls ;
/* Métodos */
public append ( string $name , UI\Control $control ) : int
public delete ( int $index ) : bool
public hasMargin ( int $page ) : bool
public insertAt ( string $name , int $page , UI\Control $control )
public pages ( ) : int
public setMargin ( int $page , bool $margin )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Propiedades

controls

Contains controls, should not be manipulated directly

Tabla de contenidos

  • UI\Controls\Tab::append — Append Page
  • UI\Controls\Tab::delete — Delete Page
  • UI\Controls\Tab::hasMargin — Margin Detection
  • UI\Controls\Tab::insertAt — Insert Page
  • UI\Controls\Tab::pages — Page Count
  • UI\Controls\Tab::setMargin — Set Margin


Append Page

  • « UI\Controls\Tab
  • UI\Controls\Tab::delete »
  • PHP Manual
  • UI\Controls\Tab
  • Append Page

UI\Controls\Tab::append

(UI 0.9.9)

UI\Controls\Tab::append — Append Page

Descripción

public UI\Controls\Tab::append ( string $name , UI\Control $control ) : int

Append a new page to this Tab

Parámetros

name

The name for the new page

control

The control for the new page

Valores devueltos

Shall return the index of the appended control, may be 0


Delete Page

  • « UI\Controls\Tab::append
  • UI\Controls\Tab::hasMargin »
  • PHP Manual
  • UI\Controls\Tab
  • Delete Page

UI\Controls\Tab::delete

(UI 0.9.9)

UI\Controls\Tab::delete — Delete Page

Descripción

public UI\Controls\Tab::delete ( int $index ) : bool

Shall remove the selected page from this Tab

Parámetros

index

The index of the page to remove

Valores devueltos

Indication of success


Margin Detection

  • « UI\Controls\Tab::delete
  • UI\Controls\Tab::insertAt »
  • PHP Manual
  • UI\Controls\Tab
  • Margin Detection

UI\Controls\Tab::hasMargin

(UI 0.9.9)

UI\Controls\Tab::hasMargin — Margin Detection

Descripción

public UI\Controls\Tab::hasMargin ( int $page ) : bool

Shall detect if the given page has a margin.

Parámetros

page

The index of the page

Valores devueltos


Insert Page

  • « UI\Controls\Tab::hasMargin
  • UI\Controls\Tab::pages »
  • PHP Manual
  • UI\Controls\Tab
  • Insert Page

UI\Controls\Tab::insertAt

(UI 0.9.9)

UI\Controls\Tab::insertAt — Insert Page

Descripción

public UI\Controls\Tab::insertAt ( string $name , int $page , UI\Control $control )

Shall insert a new page into this Tab

Parámetros

name

The name for the new page

page

The index to perform the insertion before

control

The control for the new page


Page Count

  • « UI\Controls\Tab::insertAt
  • UI\Controls\Tab::setMargin »
  • PHP Manual
  • UI\Controls\Tab
  • Page Count

UI\Controls\Tab::pages

(UI 0.9.9)

UI\Controls\Tab::pages — Page Count

Descripción

public UI\Controls\Tab::pages ( ) : int

Shall return the number of pages in this Tab

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The number of pages in this Tab


Set Margin

  • « UI\Controls\Tab::pages
  • UI\Controls\Check »
  • PHP Manual
  • UI\Controls\Tab
  • Set Margin

UI\Controls\Tab::setMargin

(UI 0.9.9)

UI\Controls\Tab::setMargin — Set Margin

Descripción

public UI\Controls\Tab::setMargin ( int $page , bool $margin )

Shall enable or disable margins on the selected page

Parámetros

page

The page to select

margin

Margin switch


Check Control

(UI 0.9.9)

Introducción

A Check is a labelled checkable box

Sinopsis de la Clase

UI\Controls\Check extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Métodos */
public getText ( ) : string
public isChecked ( ) : bool
protected onToggle ( )
public setChecked ( bool $checked )
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Check::__construct — Construct a new Check
  • UI\Controls\Check::getText — Get Text
  • UI\Controls\Check::isChecked — Checked Detection
  • UI\Controls\Check::onToggle — Toggle Callback
  • UI\Controls\Check::setChecked — Set Checked
  • UI\Controls\Check::setText — Set Text


Construct a new Check

  • « UI\Controls\Check
  • UI\Controls\Check::getText »
  • PHP Manual
  • UI\Controls\Check
  • Construct a new Check

UI\Controls\Check::__construct

(UI 0.9.9)

UI\Controls\Check::__construct — Construct a new Check

Descripción

public UI\Controls\Check::__construct ( string $text )

Shall construct a new Check

Parámetros

text

The text (label) for the Check box


Get Text

  • « UI\Controls\Check::__construct
  • UI\Controls\Check::isChecked »
  • PHP Manual
  • UI\Controls\Check
  • Get Text

UI\Controls\Check::getText

(UI 0.9.9)

UI\Controls\Check::getText — Get Text

Descripción

public UI\Controls\Check::getText ( ) : string

Shall return the text (label) for this Check

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current text (label)


Checked Detection

  • « UI\Controls\Check::getText
  • UI\Controls\Check::onToggle »
  • PHP Manual
  • UI\Controls\Check
  • Checked Detection

UI\Controls\Check::isChecked

(UI 0.9.9)

UI\Controls\Check::isChecked — Checked Detection

Descripción

public UI\Controls\Check::isChecked ( ) : bool

Shall detect the status of this Check

Parámetros

Esta función no tiene parámetros.


Toggle Callback

  • « UI\Controls\Check::isChecked
  • UI\Controls\Check::setChecked »
  • PHP Manual
  • UI\Controls\Check
  • Toggle Callback

UI\Controls\Check::onToggle

(UI 0.9.9)

UI\Controls\Check::onToggle — Toggle Callback

Descripción

protected UI\Controls\Check::onToggle ( )

Shall be executed when the status of this Check is changed

Parámetros

Esta función no tiene parámetros.


Set Checked

  • « UI\Controls\Check::onToggle
  • UI\Controls\Check::setText »
  • PHP Manual
  • UI\Controls\Check
  • Set Checked

UI\Controls\Check::setChecked

(UI 0.9.9)

UI\Controls\Check::setChecked — Set Checked

Descripción

public UI\Controls\Check::setChecked ( bool $checked )

Shall change the status of this Check

Parámetros

checked

The new status


Set Text

  • « UI\Controls\Check::setChecked
  • UI\Controls\Button »
  • PHP Manual
  • UI\Controls\Check
  • Set Text

UI\Controls\Check::setText

(UI 0.9.9)

UI\Controls\Check::setText — Set Text

Descripción

public UI\Controls\Check::setText ( string $text )

Shall set the text (label) for this Check

Parámetros

text

The new text (label)


Button Control

(UI 0.9.9)

Introducción

Represents a labelled clickable button

Sinopsis de la Clase

UI\Controls\Button extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Métodos */
public getText ( ) : string
protected onClick ( )
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Button::__construct — Construct a new Button
  • UI\Controls\Button::getText — Get Text
  • UI\Controls\Button::onClick — Click Handler
  • UI\Controls\Button::setText — Set Text


Construct a new Button

  • « UI\Controls\Button
  • UI\Controls\Button::getText »
  • PHP Manual
  • UI\Controls\Button
  • Construct a new Button

UI\Controls\Button::__construct

(UI 0.9.9)

UI\Controls\Button::__construct — Construct a new Button

Descripción

public UI\Controls\Button::__construct ( string $text )

Shall construct a new Button

Parámetros

text

The text (label) for this Button


Get Text

  • « UI\Controls\Button::__construct
  • UI\Controls\Button::onClick »
  • PHP Manual
  • UI\Controls\Button
  • Get Text

UI\Controls\Button::getText

(UI 0.9.9)

UI\Controls\Button::getText — Get Text

Descripción

public UI\Controls\Button::getText ( ) : string

Shall retrieve the text (label) for this Button

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current text (label)


Click Handler

  • « UI\Controls\Button::getText
  • UI\Controls\Button::setText »
  • PHP Manual
  • UI\Controls\Button
  • Click Handler

UI\Controls\Button::onClick

(UI 0.9.9)

UI\Controls\Button::onClick — Click Handler

Descripción

protected UI\Controls\Button::onClick ( )

Shall be executed when this Button is clicked

Parámetros

Esta función no tiene parámetros.


Set Text

  • « UI\Controls\Button::onClick
  • UI\Controls\ColorButton »
  • PHP Manual
  • UI\Controls\Button
  • Set Text

UI\Controls\Button::setText

(UI 0.9.9)

UI\Controls\Button::setText — Set Text

Descripción

public UI\Controls\Button::setText ( string $text )

Shall set the text (label) for this Button

Parámetros

text

The new text (label)


ColorButton Control

(UI 0.9.9)

Introducción

A Color Button is a button which displays a color picker when clicked

Sinopsis de la Clase

UI\Controls\ColorButton extends UI\Control {
/* Métodos */
public getColor ( ) : UI\Color
protected onChange ( )
public setColor ( UI\Draw\Color $color )
public setColor ( int $color )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\ColorButton::getColor — Get Color
  • UI\Controls\ColorButton::onChange — Change Handler
  • UI\Controls\ColorButton::setColor — Set Color


Get Color

  • « UI\Controls\ColorButton
  • UI\Controls\ColorButton::onChange »
  • PHP Manual
  • UI\Controls\ColorButton
  • Get Color

UI\Controls\ColorButton::getColor

(UI 0.9.9)

UI\Controls\ColorButton::getColor — Get Color

Descripción

public UI\Controls\ColorButton::getColor ( ) : UI\Color

Shall retrieve the currently selected Color

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Change Handler

  • « UI\Controls\ColorButton::getColor
  • UI\Controls\ColorButton::setColor »
  • PHP Manual
  • UI\Controls\ColorButton
  • Change Handler

UI\Controls\ColorButton::onChange

(UI 0.9.9)

UI\Controls\ColorButton::onChange — Change Handler

Descripción

protected UI\Controls\ColorButton::onChange ( )

Shall be executed when the selected Color is changed

Parámetros

Esta función no tiene parámetros.


Set Color

  • « UI\Controls\ColorButton::onChange
  • UI\Controls\Label »
  • PHP Manual
  • UI\Controls\ColorButton
  • Set Color

UI\Controls\ColorButton::setColor

(UI 0.9.9)

UI\Controls\ColorButton::setColor — Set Color

Descripción

public UI\Controls\ColorButton::setColor ( UI\Draw\Color $color )
public UI\Controls\ColorButton::setColor ( int $color )

Shall set the currently selected Color

Parámetros

color

The new color


Label Control

(UI 0.9.9)

Introducción

A Label is a single line of text, meant to identify, for the user, some element of the interface.

Sinopsis de la Clase

UI\Controls\Label extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Métodos */
public getText ( ) : string
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Label::__construct — Construct a new Label
  • UI\Controls\Label::getText — Get Text
  • UI\Controls\Label::setText — Set Text


Construct a new Label

  • « UI\Controls\Label
  • UI\Controls\Label::getText »
  • PHP Manual
  • UI\Controls\Label
  • Construct a new Label

UI\Controls\Label::__construct

(UI 0.9.9)

UI\Controls\Label::__construct — Construct a new Label

Descripción

public UI\Controls\Label::__construct ( string $text )

Shall construct a new Label

Parámetros

text

The text for this label


Get Text

  • « UI\Controls\Label::__construct
  • UI\Controls\Label::setText »
  • PHP Manual
  • UI\Controls\Label
  • Get Text

UI\Controls\Label::getText

(UI 0.9.9)

UI\Controls\Label::getText — Get Text

Descripción

public UI\Controls\Label::getText ( ) : string

Shall return the current text for this Label

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Set Text

  • « UI\Controls\Label::getText
  • UI\Controls\Entry »
  • PHP Manual
  • UI\Controls\Label
  • Set Text

UI\Controls\Label::setText

(UI 0.9.9)

UI\Controls\Label::setText — Set Text

Descripción

public UI\Controls\Label::setText ( string $text )

Shall set the text for this Label

Parámetros

text

The new text


Entry Control

(UI 0.9.9)

Introducción

An Entry is a text entry control, suitable for entering plain text, passwords, or search terms.

Sinopsis de la Clase

UI\Controls\Entry extends UI\Control {
/* Constants */
const int Normal ;
const int Password ;
const int Search ;
/* Constructor */
public __construct ( int $type = UI\Controls\Entry::Normal )
/* Métodos */
public getText ( ) : string
public isReadOnly ( ) : bool
protected onChange ( )
public setReadOnly ( bool $readOnly )
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Controls\Entry::Normal

A normal single line entry

UI\Controls\Entry::Password

A password entry

UI\Controls\Entry::Search

A search entry

Tabla de contenidos

  • UI\Controls\Entry::__construct — Construct a new Entry
  • UI\Controls\Entry::getText — Get Text
  • UI\Controls\Entry::isReadOnly — Detect Read Only
  • UI\Controls\Entry::onChange — Change Handler
  • UI\Controls\Entry::setReadOnly — Set Read Only
  • UI\Controls\Entry::setText — Set Text


Construct a new Entry

  • « UI\Controls\Entry
  • UI\Controls\Entry::getText »
  • PHP Manual
  • UI\Controls\Entry
  • Construct a new Entry

UI\Controls\Entry::__construct

(UI 0.9.9)

UI\Controls\Entry::__construct — Construct a new Entry

Descripción

public UI\Controls\Entry::__construct ( int $type = UI\Controls\Entry::Normal )

Construct a new entry of the given type

Parámetros

type

Entry::Normal, Entry::Password, or Entry::Search


Get Text

  • « UI\Controls\Entry::__construct
  • UI\Controls\Entry::isReadOnly »
  • PHP Manual
  • UI\Controls\Entry
  • Get Text

UI\Controls\Entry::getText

(UI 0.9.9)

UI\Controls\Entry::getText — Get Text

Descripción

public UI\Controls\Entry::getText ( ) : string

Shall return the current text from this Entry

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current text


Detect Read Only

  • « UI\Controls\Entry::getText
  • UI\Controls\Entry::onChange »
  • PHP Manual
  • UI\Controls\Entry
  • Detect Read Only

UI\Controls\Entry::isReadOnly

(UI 0.9.9)

UI\Controls\Entry::isReadOnly — Detect Read Only

Descripción

public UI\Controls\Entry::isReadOnly ( ) : bool

Shall detect if this Entry is read only

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Change Handler

  • « UI\Controls\Entry::isReadOnly
  • UI\Controls\Entry::setReadOnly »
  • PHP Manual
  • UI\Controls\Entry
  • Change Handler

UI\Controls\Entry::onChange

(UI 0.9.9)

UI\Controls\Entry::onChange — Change Handler

Descripción

protected UI\Controls\Entry::onChange ( )

Shall be executed when the text in this Entry changes

Parámetros

Esta función no tiene parámetros.


Set Read Only

  • « UI\Controls\Entry::onChange
  • UI\Controls\Entry::setText »
  • PHP Manual
  • UI\Controls\Entry
  • Set Read Only

UI\Controls\Entry::setReadOnly

(UI 0.9.9)

UI\Controls\Entry::setReadOnly — Set Read Only

Descripción

public UI\Controls\Entry::setReadOnly ( bool $readOnly )

Shall enable or disable read only for this Entry

Parámetros

readOnly


Set Text

  • « UI\Controls\Entry::setReadOnly
  • UI\Controls\MultilineEntry »
  • PHP Manual
  • UI\Controls\Entry
  • Set Text

UI\Controls\Entry::setText

(UI 0.9.9)

UI\Controls\Entry::setText — Set Text

Descripción

public UI\Controls\Entry::setText ( string $text )

Shall set the text for this Entry

Parámetros

text

The new text


MultilineEntry Control

(UI 0.9.9)

Introducción

A Multiline Entry is a text entry control able to hold multiple lines of text, with or without wrapping.

Sinopsis de la Clase

UI\Controls\MultilineEntry extends UI\Control {
/* Constants */
const int Wrap ;
const int NoWrap ;
/* Constructor */
public __construct ( int $type = ? )
/* Métodos */
public append ( string $text )
public getText ( ) : string
public isReadOnly ( ) : bool
protected onChange ( )
public setReadOnly ( bool $readOnly )
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Controls\MultilineEntry::Wrap

Allow lines to wrap

UI\Controls\MultilineEntry::NoWrap

Do not allow lines to wrap

Tabla de contenidos

  • UI\Controls\MultilineEntry::append — Append Text
  • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
  • UI\Controls\MultilineEntry::getText — Get Text
  • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
  • UI\Controls\MultilineEntry::onChange — Change Handler
  • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
  • UI\Controls\MultilineEntry::setText — Set Text


Append Text

  • « UI\Controls\MultilineEntry
  • UI\Controls\MultilineEntry::__construct »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Append Text

UI\Controls\MultilineEntry::append

(UI 0.9.9)

UI\Controls\MultilineEntry::append — Append Text

Descripción

public UI\Controls\MultilineEntry::append ( string $text )

Shall append the given text to the text in this Multiline Entry

Parámetros

text

The text to append


Construct a new Multiline Entry

  • « UI\Controls\MultilineEntry::append
  • UI\Controls\MultilineEntry::getText »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Construct a new Multiline Entry

UI\Controls\MultilineEntry::__construct

(UI 0.9.9)

UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry

Descripción

public UI\Controls\MultilineEntry::__construct ( int $type = ? )

Shall construct a new Multiline Entry of the given type

Parámetros

type

MultilineEntry::Wrap or MultilineEntry::NoWrap


Get Text

  • « UI\Controls\MultilineEntry::__construct
  • UI\Controls\MultilineEntry::isReadOnly »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Get Text

UI\Controls\MultilineEntry::getText

(UI 0.9.9)

UI\Controls\MultilineEntry::getText — Get Text

Descripción

public UI\Controls\MultilineEntry::getText ( ) : string

Shall return the text in this Multiline Entry

Parámetros

Esta función no tiene parámetros.


Read Only Detection

  • « UI\Controls\MultilineEntry::getText
  • UI\Controls\MultilineEntry::onChange »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Read Only Detection

UI\Controls\MultilineEntry::isReadOnly

(UI 0.9.9)

UI\Controls\MultilineEntry::isReadOnly — Read Only Detection

Descripción

public UI\Controls\MultilineEntry::isReadOnly ( ) : bool

Shall detect if this Multiline Entry is read only

Parámetros

Esta función no tiene parámetros.


Change Handler

  • « UI\Controls\MultilineEntry::isReadOnly
  • UI\Controls\MultilineEntry::setReadOnly »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Change Handler

UI\Controls\MultilineEntry::onChange

(UI 0.9.9)

UI\Controls\MultilineEntry::onChange — Change Handler

Descripción

protected UI\Controls\MultilineEntry::onChange ( )

Shall be executed when the text in this Multiline Entry is changed

Parámetros

Esta función no tiene parámetros.


Set Read Only

  • « UI\Controls\MultilineEntry::onChange
  • UI\Controls\MultilineEntry::setText »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Set Read Only

UI\Controls\MultilineEntry::setReadOnly

(UI 0.9.9)

UI\Controls\MultilineEntry::setReadOnly — Set Read Only

Descripción

public UI\Controls\MultilineEntry::setReadOnly ( bool $readOnly )

Shall enable or disable read only on this Multiline Entry

Parámetros

readOnly


Set Text

  • « UI\Controls\MultilineEntry::setReadOnly
  • UI\Controls\Spin »
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Set Text

UI\Controls\MultilineEntry::setText

(UI 0.9.9)

UI\Controls\MultilineEntry::setText — Set Text

Descripción

public UI\Controls\MultilineEntry::setText ( string $text )

Shall set the text in this Multiline Entry

Parámetros

text

The new text


Spin Control

(UI 0.9.9)

Introducción

A Spin box is a text box with an up-down control which changes the integer value in the box, within a defined range

Sinopsis de la Clase

UI\Controls\Spin extends UI\Control {
/* Constructor */
public __construct ( int $min , int $max )
/* Métodos */
public getValue ( ) : int
protected onChange ( )
public setValue ( int $value )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Spin::__construct — Construct a new Spin
  • UI\Controls\Spin::getValue — Get Value
  • UI\Controls\Spin::onChange — Change Handler
  • UI\Controls\Spin::setValue — Set Value


Construct a new Spin

  • « UI\Controls\Spin
  • UI\Controls\Spin::getValue »
  • PHP Manual
  • UI\Controls\Spin
  • Construct a new Spin

UI\Controls\Spin::__construct

(UI 0.9.9)

UI\Controls\Spin::__construct — Construct a new Spin

Descripción

public UI\Controls\Spin::__construct ( int $min , int $max )

Constructs a new Spin with the given range

Parámetros

min

The minimum value allowed

max

The maximum value allowed


Get Value

  • « UI\Controls\Spin::__construct
  • UI\Controls\Spin::onChange »
  • PHP Manual
  • UI\Controls\Spin
  • Get Value

UI\Controls\Spin::getValue

(UI 0.9.9)

UI\Controls\Spin::getValue — Get Value

Descripción

public UI\Controls\Spin::getValue ( ) : int

Get the value in this Spin

Parámetros

Esta función no tiene parámetros.


Change Handler

  • « UI\Controls\Spin::getValue
  • UI\Controls\Spin::setValue »
  • PHP Manual
  • UI\Controls\Spin
  • Change Handler

UI\Controls\Spin::onChange

(UI 0.9.9)

UI\Controls\Spin::onChange — Change Handler

Descripción

protected UI\Controls\Spin::onChange ( )

Shall be executed when the value in this Spin changes

Parámetros

Esta función no tiene parámetros.


Set Value

  • « UI\Controls\Spin::onChange
  • UI\Controls\Slider »
  • PHP Manual
  • UI\Controls\Spin
  • Set Value

UI\Controls\Spin::setValue

(UI 0.9.9)

UI\Controls\Spin::setValue — Set Value

Descripción

public UI\Controls\Spin::setValue ( int $value )

Set the value in this Spin

Parámetros

value

The new value


Slider Control

(UI 0.9.9)

Introducción

A Slider is a control which represents a range, and a current value in the range. The sliding element of the control (sometimes called the "thumb") reflects the value, and can be adjusted within the range.

Sinopsis de la Clase

UI\Controls\Slider extends UI\Control {
/* Constructor */
public __construct ( int $min , int $max )
/* Métodos */
public getValue ( ) : int
protected onChange ( )
public setValue ( int $value )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Slider::__construct — Construct a new Slider
  • UI\Controls\Slider::getValue — Get Value
  • UI\Controls\Slider::onChange — Change Handler
  • UI\Controls\Slider::setValue — Set Value


Construct a new Slider

  • « UI\Controls\Slider
  • UI\Controls\Slider::getValue »
  • PHP Manual
  • UI\Controls\Slider
  • Construct a new Slider

UI\Controls\Slider::__construct

(UI 0.9.9)

UI\Controls\Slider::__construct — Construct a new Slider

Descripción

public UI\Controls\Slider::__construct ( int $min , int $max )

Construct a new Slider with the given range

Parámetros

min

The minimum allowed value

max

The maximum allowed value


Get Value

  • « UI\Controls\Slider::__construct
  • UI\Controls\Slider::onChange »
  • PHP Manual
  • UI\Controls\Slider
  • Get Value

UI\Controls\Slider::getValue

(UI 0.9.9)

UI\Controls\Slider::getValue — Get Value

Descripción

public UI\Controls\Slider::getValue ( ) : int

Get the value from this Slider

Parámetros

Esta función no tiene parámetros.


Change Handler

  • « UI\Controls\Slider::getValue
  • UI\Controls\Slider::setValue »
  • PHP Manual
  • UI\Controls\Slider
  • Change Handler

UI\Controls\Slider::onChange

(UI 0.9.9)

UI\Controls\Slider::onChange — Change Handler

Descripción

protected UI\Controls\Slider::onChange ( )

Shall be executed when the value of this Slider changes

Parámetros

Esta función no tiene parámetros.


Set Value

  • « UI\Controls\Slider::onChange
  • UI\Controls\Progress »
  • PHP Manual
  • UI\Controls\Slider
  • Set Value

UI\Controls\Slider::setValue

(UI 0.9.9)

UI\Controls\Slider::setValue — Set Value

Descripción

public UI\Controls\Slider::setValue ( int $value )

Shall set the value for this Slider

Parámetros

value

The new value


Progress Control

(UI 0.9.9)

Introducción

A Progress control is a familiar Progress bar: It represents progress as a percentage, with a possible range of 0 to 100 (inclusive).

Sinopsis de la Clase

UI\Controls\Progress extends UI\Control {
/* Métodos */
public getValue ( ) : int
public setValue ( int $value )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Progress::getValue — Get Value
  • UI\Controls\Progress::setValue — Set Value


Get Value

  • « UI\Controls\Progress
  • UI\Controls\Progress::setValue »
  • PHP Manual
  • UI\Controls\Progress
  • Get Value

UI\Controls\Progress::getValue

(UI 0.9.9)

UI\Controls\Progress::getValue — Get Value

Descripción

public UI\Controls\Progress::getValue ( ) : int

Shall retrieve the current value of this Progress bar

Parámetros

Esta función no tiene parámetros.


Set Value

  • « UI\Controls\Progress::getValue
  • UI\Controls\Separator »
  • PHP Manual
  • UI\Controls\Progress
  • Set Value

UI\Controls\Progress::setValue

(UI 0.9.9)

UI\Controls\Progress::setValue — Set Value

Descripción

public UI\Controls\Progress::setValue ( int $value )

Shall set the value for this Progress bar

Parámetros

value

An integer between 0 and 100 (inclusive)


Control Separator

(UI 0.9.9)

Introducción

A Separator represents a control separator, it has no other function.

Sinopsis de la Clase

UI\Controls\Separator extends UI\Control {
/* Constants */
const int Horizontal ;
const int Vertical ;
/* Constructor */
public __construct ( int $type = UI\Controls\Separator::Horizontal )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Controls\Separator::Horizontal

A Horizontal Separator

UI\Controls\Separator::Vertical

A Vertical Separator

Tabla de contenidos

  • UI\Controls\Separator::__construct — Construct a new Separator


Construct a new Separator

  • « UI\Controls\Separator
  • UI\Controls\Combo »
  • PHP Manual
  • UI\Controls\Separator
  • Construct a new Separator

UI\Controls\Separator::__construct

(UI 0.9.9)

UI\Controls\Separator::__construct — Construct a new Separator

Descripción

public UI\Controls\Separator::__construct ( int $type = UI\Controls\Separator::Horizontal )

Shall construct a new Separator of the given type

Parámetros

type

Separator::Horizonal or Separator::Vertical


Combo Control

(UI 0.9.9)

Introducción

A Combo control represents a list of options, like the familiar select HTML element.

Sinopsis de la Clase

UI\Controls\Combo extends UI\Control {
/* Métodos */
public append ( string $text )
public getSelected ( ) : int
protected onSelected ( )
public setSelected ( int $index )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Combo::append — Append Option
  • UI\Controls\Combo::getSelected — Get Selected Option
  • UI\Controls\Combo::onSelected — Selected Handler
  • UI\Controls\Combo::setSelected — Set Selected Option


Append Option

  • « UI\Controls\Combo
  • UI\Controls\Combo::getSelected »
  • PHP Manual
  • UI\Controls\Combo
  • Append Option

UI\Controls\Combo::append

(UI 0.9.9)

UI\Controls\Combo::append — Append Option

Descripción

public UI\Controls\Combo::append ( string $text )

Append an option to this Combo

Parámetros

text

The text for the new option


Get Selected Option

  • « UI\Controls\Combo::append
  • UI\Controls\Combo::onSelected »
  • PHP Manual
  • UI\Controls\Combo
  • Get Selected Option

UI\Controls\Combo::getSelected

(UI 0.9.9)

UI\Controls\Combo::getSelected — Get Selected Option

Descripción

public UI\Controls\Combo::getSelected ( ) : int

Shall retrieve the index of the option selected in this Combo

Parámetros

Esta función no tiene parámetros.


Selected Handler

  • « UI\Controls\Combo::getSelected
  • UI\Controls\Combo::setSelected »
  • PHP Manual
  • UI\Controls\Combo
  • Selected Handler

UI\Controls\Combo::onSelected

(UI 0.9.9)

UI\Controls\Combo::onSelected — Selected Handler

Descripción

protected UI\Controls\Combo::onSelected ( )

Shall be executed when an option is selected in this Combo

Parámetros

Esta función no tiene parámetros.


Set Selected Option

  • « UI\Controls\Combo::onSelected
  • UI\Controls\EditableCombo »
  • PHP Manual
  • UI\Controls\Combo
  • Set Selected Option

UI\Controls\Combo::setSelected

(UI 0.9.9)

UI\Controls\Combo::setSelected — Set Selected Option

Descripción

public UI\Controls\Combo::setSelected ( int $index )

Shall set the currently selected option in this Combo

Parámetros

index

The index of the option to select


EdiableCombo Control

(UI 0.9.9)

Introducción

An Editable Combo is a Combo which allows the user to enter custom options

Sinopsis de la Clase

UI\Controls\EditableCombo extends UI\Control {
/* Métodos */
public append ( string $text )
public getText ( ) : string
protected onChange ( )
public setText ( string $text )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\EditableCombo::append — Append Option
  • UI\Controls\EditableCombo::getText — Get Text
  • UI\Controls\EditableCombo::onChange — Change Handler
  • UI\Controls\EditableCombo::setText — Set Text


Append Option

  • « UI\Controls\EditableCombo
  • UI\Controls\EditableCombo::getText »
  • PHP Manual
  • UI\Controls\EditableCombo
  • Append Option

UI\Controls\EditableCombo::append

(UI 0.9.9)

UI\Controls\EditableCombo::append — Append Option

Descripción

public UI\Controls\EditableCombo::append ( string $text )

Shall append a new option to this Editable Combo

Parámetros

text

The text for the new option


Get Text

  • « UI\Controls\EditableCombo::append
  • UI\Controls\EditableCombo::onChange »
  • PHP Manual
  • UI\Controls\EditableCombo
  • Get Text

UI\Controls\EditableCombo::getText

(UI 0.9.9)

UI\Controls\EditableCombo::getText — Get Text

Descripción

public UI\Controls\EditableCombo::getText ( ) : string

Get the value of the currently selected option in this Editable Combo

Parámetros

Esta función no tiene parámetros.


Change Handler

  • « UI\Controls\EditableCombo::getText
  • UI\Controls\EditableCombo::setText »
  • PHP Manual
  • UI\Controls\EditableCombo
  • Change Handler

UI\Controls\EditableCombo::onChange

(UI 0.9.9)

UI\Controls\EditableCombo::onChange — Change Handler

Descripción

protected UI\Controls\EditableCombo::onChange ( )

Shall be executed when the value of this Editable Combobox changes

Parámetros

Esta función no tiene parámetros.


Set Text

  • « UI\Controls\EditableCombo::onChange
  • UI\Controls\Radio »
  • PHP Manual
  • UI\Controls\EditableCombo
  • Set Text

UI\Controls\EditableCombo::setText

(UI 0.9.9)

UI\Controls\EditableCombo::setText — Set Text

Descripción

public UI\Controls\EditableCombo::setText ( string $text )

Shall set the text of the currently selected option in this Editable Combo

Parámetros

text

The new text


Radio Control

(UI 0.9.9)

Introducción

A Radio is similar to the radio input type familiar from HTML

Sinopsis de la Clase

UI\Controls\Radio extends UI\Control {
/* Métodos */
public append ( string $text )
public getSelected ( ) : int
protected onSelected ( )
public setSelected ( int $index )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Tabla de contenidos

  • UI\Controls\Radio::append — Append Option
  • UI\Controls\Radio::getSelected — Get Selected Option
  • UI\Controls\Radio::onSelected — Selected Handler
  • UI\Controls\Radio::setSelected — Set Selected Option


Append Option

  • « UI\Controls\Radio
  • UI\Controls\Radio::getSelected »
  • PHP Manual
  • UI\Controls\Radio
  • Append Option

UI\Controls\Radio::append

(UI 0.9.9)

UI\Controls\Radio::append — Append Option

Descripción

public UI\Controls\Radio::append ( string $text )

Shall append a new option to this Radio

Parámetros

text

The text (label) for the option


Get Selected Option

  • « UI\Controls\Radio::append
  • UI\Controls\Radio::onSelected »
  • PHP Manual
  • UI\Controls\Radio
  • Get Selected Option

UI\Controls\Radio::getSelected

(UI 0.9.9)

UI\Controls\Radio::getSelected — Get Selected Option

Descripción

public UI\Controls\Radio::getSelected ( ) : int

Shall retrieve the index of the currently selected option in this Radio

Parámetros

Esta función no tiene parámetros.


Selected Handler

  • « UI\Controls\Radio::getSelected
  • UI\Controls\Radio::setSelected »
  • PHP Manual
  • UI\Controls\Radio
  • Selected Handler

UI\Controls\Radio::onSelected

(UI 0.9.9)

UI\Controls\Radio::onSelected — Selected Handler

Descripción

protected UI\Controls\Radio::onSelected ( )

Shall be executed when the option selected in this Radio changes

Parámetros

Esta función no tiene parámetros.


Set Selected Option

  • « UI\Controls\Radio::onSelected
  • UI\Controls\Picker »
  • PHP Manual
  • UI\Controls\Radio
  • Set Selected Option

UI\Controls\Radio::setSelected

(UI 0.9.9)

UI\Controls\Radio::setSelected — Set Selected Option

Descripción

public UI\Controls\Radio::setSelected ( int $index )

Shall set the currently selected option in this Radio

Parámetros

index

The index of the option to select


Picker Control

(UI 0.9.9)

Introducción

A Picker represents a button which when clicked presents a native Date/Time/DateTime Picker interface to the user.

Sinopsis de la Clase

UI\Controls\Picker extends UI\Control {
/* Constants */
const int Date ;
const int Time ;
const int DateTime ;
/* Constructor */
public __construct ( int $type = UI\Controls\Picker::Date )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Controls\Picker::Date

A Date Picker

UI\Controls\Picker::Time

A Time Picker

UI\Controls\Picker::DateTime

A Date and Time Picker

Tabla de contenidos

  • UI\Controls\Picker::__construct — Construct a new Picker


Construct a new Picker

  • « UI\Controls\Picker
  • UI\Controls\Form »
  • PHP Manual
  • UI\Controls\Picker
  • Construct a new Picker

UI\Controls\Picker::__construct

(UI 0.9.9)

UI\Controls\Picker::__construct — Construct a new Picker

Descripción

public UI\Controls\Picker::__construct ( int $type = UI\Controls\Picker::Date )

Construct a new Picker of the given type

Parámetros

type

Picker::Date, Picker::Time, or Picker::DateTime


Control Form (Arrangement)

(UI 0.9.9)

Introducción

A Form is a control which allows the arrangement of other controls into a familiar layout (the form).

Sinopsis de la Clase

UI\Controls\Form extends UI\Control {
/* Propiedades */
protected $controls ;
/* Métodos */
public append ( string $label , UI\Control $control , bool $stretchy = false ) : int
public delete ( int $index ) : bool
public isPadded ( ) : bool
public setPadded ( bool $padded )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Propiedades

controls

Contains controls, should not be manipulated directly

Tabla de contenidos

  • UI\Controls\Form::append — Append Control
  • UI\Controls\Form::delete — Delete Control
  • UI\Controls\Form::isPadded — Padding Detection
  • UI\Controls\Form::setPadded — Set Padding


Append Control

  • « UI\Controls\Form
  • UI\Controls\Form::delete »
  • PHP Manual
  • UI\Controls\Form
  • Append Control

UI\Controls\Form::append

(UI 0.9.9)

UI\Controls\Form::append — Append Control

Descripción

public UI\Controls\Form::append ( string $label , UI\Control $control , bool $stretchy = false ) : int

Shall append the control to the form, and set the label

Parámetros

label

The text for the label

control

A control

stretchy

Should be set true to stretch the control

Valores devueltos

Shall return the index of the appended control, may be 0


Delete Control

  • « UI\Controls\Form::append
  • UI\Controls\Form::isPadded »
  • PHP Manual
  • UI\Controls\Form
  • Delete Control

UI\Controls\Form::delete

(UI 0.9.9)

UI\Controls\Form::delete — Delete Control

Descripción

public UI\Controls\Form::delete ( int $index ) : bool

Shall delete the control at the given index in this Form

Parámetros

index

The index of the control to remove

Valores devueltos

Indication of succcess


Padding Detection

  • « UI\Controls\Form::delete
  • UI\Controls\Form::setPadded »
  • PHP Manual
  • UI\Controls\Form
  • Padding Detection

UI\Controls\Form::isPadded

(UI 0.9.9)

UI\Controls\Form::isPadded — Padding Detection

Descripción

public UI\Controls\Form::isPadded ( ) : bool

Shall detect if padding is enabled on this Form

Parámetros

Esta función no tiene parámetros.


Set Padding

  • « UI\Controls\Form::isPadded
  • UI\Controls\Grid »
  • PHP Manual
  • UI\Controls\Form
  • Set Padding

UI\Controls\Form::setPadded

(UI 0.9.9)

UI\Controls\Form::setPadded — Set Padding

Descripción

public UI\Controls\Form::setPadded ( bool $padded )

Shall enable or disable padding on this Form

Parámetros

padded


Control Grid (Arrangement)

(UI 0.9.9)

Introducción

A Grid is a control which is allows the arrangement of children into a grid

Sinopsis de la Clase

UI\Controls\Grid extends UI\Control {
/* Constants */
const int Fill ;
const int Start ;
const int Center ;
const int End ;
const int Leading ;
const int Top ;
const int Trailing ;
const int Bottom ;
/* Propiedades */
protected $controls ;
/* Métodos */
public append ( UI\Control $control , int $left , int $top , int $xspan , int $yspan , bool $hexpand , int $halign , bool $vexpand , int $valign )
public isPadded ( ) : bool
public setPadded ( bool $padding )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Constantes predefinidas

UI\Controls\Grid::Fill

UI\Controls\Grid::Start

UI\Controls\Grid::Center

UI\Controls\Grid::End

UI\Controls\Grid::Leading

UI\Controls\Grid::Top

UI\Controls\Grid::Trailing

UI\Controls\Grid::Bottom

Propiedades

controls

Contains controls, should not be manipulated directly

Tabla de contenidos

  • UI\Controls\Grid::append — Append Control
  • UI\Controls\Grid::isPadded — Padding Detection
  • UI\Controls\Grid::setPadded — Set Padding


Append Control

  • « UI\Controls\Grid
  • UI\Controls\Grid::isPadded »
  • PHP Manual
  • UI\Controls\Grid
  • Append Control

UI\Controls\Grid::append

(UI 0.9.9)

UI\Controls\Grid::append — Append Control

Descripción

public UI\Controls\Grid::append ( UI\Control $control , int $left , int $top , int $xspan , int $yspan , bool $hexpand , int $halign , bool $vexpand , int $valign )

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

control

The Control to append

left

top

xspan

yspan

hexpand

halign

vexpand

valign

Valores devueltos


Padding Detection

  • « UI\Controls\Grid::append
  • UI\Controls\Grid::setPadded »
  • PHP Manual
  • UI\Controls\Grid
  • Padding Detection

UI\Controls\Grid::isPadded

(UI 0.9.9)

UI\Controls\Grid::isPadded — Padding Detection

Descripción

public UI\Controls\Grid::isPadded ( ) : bool

Shall detect if padding is enabled on this Grid

Parámetros

Esta función no tiene parámetros.


Set Padding

  • « UI\Controls\Grid::isPadded
  • UI\Controls\Group »
  • PHP Manual
  • UI\Controls\Grid
  • Set Padding

UI\Controls\Grid::setPadded

(UI 0.9.9)

UI\Controls\Grid::setPadded — Set Padding

Descripción

public UI\Controls\Grid::setPadded ( bool $padding )

Shall enable or disable padding for this Grid

Parámetros

padding


Control Group (Arrangement)

(UI 0.9.9)

Introducción

A Group is a titled container for child controls

Sinopsis de la Clase

UI\Controls\Group extends UI\Control {
/* Propiedades */
protected $controls ;
/* Constructor */
public __construct ( string $title )
/* Métodos */
public append ( UI\Control $control )
public getTitle ( ) : string
public hasMargin ( ) : bool
public setMargin ( bool $margin )
public setTitle ( string $title )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Propiedades

controls

Contains controls, should not be manipulated directly

Tabla de contenidos

  • UI\Controls\Group::append — Append Control
  • UI\Controls\Group::__construct — Construct a new Group
  • UI\Controls\Group::getTitle — Get Title
  • UI\Controls\Group::hasMargin — Margin Detection
  • UI\Controls\Group::setMargin — Set Margin
  • UI\Controls\Group::setTitle — Set Title


Append Control

  • « UI\Controls\Group
  • UI\Controls\Group::__construct »
  • PHP Manual
  • UI\Controls\Group
  • Append Control

UI\Controls\Group::append

(No hay información de versión disponible, podría estar únicamente en Git)

UI\Controls\Group::append — Append Control

Descripción

public UI\Controls\Group::append ( UI\Control $control )

Shall append a control to this Group

Parámetros

control

The control to append


Construct a new Group

  • « UI\Controls\Group::append
  • UI\Controls\Group::getTitle »
  • PHP Manual
  • UI\Controls\Group
  • Construct a new Group

UI\Controls\Group::__construct

(UI 0.9.9)

UI\Controls\Group::__construct — Construct a new Group

Descripción

public UI\Controls\Group::__construct ( string $title )

Shall construct a new Group with the given title

Parámetros

title

The text for the title label


Get Title

  • « UI\Controls\Group::__construct
  • UI\Controls\Group::hasMargin »
  • PHP Manual
  • UI\Controls\Group
  • Get Title

UI\Controls\Group::getTitle

(UI 0.9.9)

UI\Controls\Group::getTitle — Get Title

Descripción

public UI\Controls\Group::getTitle ( ) : string

Shall return the current title for this Group

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current title


Margin Detection

  • « UI\Controls\Group::getTitle
  • UI\Controls\Group::setMargin »
  • PHP Manual
  • UI\Controls\Group
  • Margin Detection

UI\Controls\Group::hasMargin

(UI 0.9.9)

UI\Controls\Group::hasMargin — Margin Detection

Descripción

public UI\Controls\Group::hasMargin ( ) : bool

Shall detect if this Group has a margin

Parámetros

Esta función no tiene parámetros.


Set Margin

  • « UI\Controls\Group::hasMargin
  • UI\Controls\Group::setTitle »
  • PHP Manual
  • UI\Controls\Group
  • Set Margin

UI\Controls\Group::setMargin

(UI 0.9.9)

UI\Controls\Group::setMargin — Set Margin

Descripción

public UI\Controls\Group::setMargin ( bool $margin )

Shall enable or disable margins for this Group

Parámetros

margin


Set Title

  • « UI\Controls\Group::setMargin
  • UI\Controls\Box »
  • PHP Manual
  • UI\Controls\Group
  • Set Title

UI\Controls\Group::setTitle

(UI 0.9.9)

UI\Controls\Group::setTitle — Set Title

Descripción

public UI\Controls\Group::setTitle ( string $title )

Shall set the title for this Group

Parámetros

title

The text for the new title


Control Box (Arrangement)

(UI 0.9.9)

Introducción

A Box allows the arrangement of other controls

Sinopsis de la Clase

UI\Controls\Box extends UI\Control {
/* Constants */
const int Vertical ;
const int Horizontal ;
/* Propiedades */
protected $controls ;
/* Constructor */
public __construct ( int $orientation = UI\Controls\Box::Horizontal )
/* Métodos */
public append ( Control $control , bool $stretchy = false ) : int
public delete ( int $index ) : bool
public getOrientation ( ) : int
public isPadded ( ) : bool
public setPadded ( bool $padded )
/* Métodos heredados */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Propiedades

controls

Contains controls, should not be manipulated directly

Constantes predefinidas

UI\Controls\Box::Vertical

UI\Controls\Box::Horizontal

Tabla de contenidos

  • UI\Controls\Box::append — Append Control
  • UI\Controls\Box::__construct — Construct a new Box
  • UI\Controls\Box::delete — Delete Control
  • UI\Controls\Box::getOrientation — Get Orientation
  • UI\Controls\Box::isPadded — Padding Detection
  • UI\Controls\Box::setPadded — Set Padding


Append Control

  • « UI\Controls\Box
  • UI\Controls\Box::__construct »
  • PHP Manual
  • UI\Controls\Box
  • Append Control

UI\Controls\Box::append

(UI 0.9.9)

UI\Controls\Box::append — Append Control

Descripción

public UI\Controls\Box::append ( Control $control , bool $stretchy = false ) : int

Shall append the given control to this Box

Parámetros

control

The control to append

stretchy

Set true to stretch the control

Valores devueltos

Shall return the index of the appended control, may be 0


Construct a new Box

  • « UI\Controls\Box::append
  • UI\Controls\Box::delete »
  • PHP Manual
  • UI\Controls\Box
  • Construct a new Box

UI\Controls\Box::__construct

(UI 0.9.9)

UI\Controls\Box::__construct — Construct a new Box

Descripción

public UI\Controls\Box::__construct ( int $orientation = UI\Controls\Box::Horizontal )

Shall construct a new box

Parámetros

orientation

Box::Horizontal or Box::Vertical


Delete Control

  • « UI\Controls\Box::__construct
  • UI\Controls\Box::getOrientation »
  • PHP Manual
  • UI\Controls\Box
  • Delete Control

UI\Controls\Box::delete

(UI 0.9.9)

UI\Controls\Box::delete — Delete Control

Descripción

public UI\Controls\Box::delete ( int $index ) : bool

Shall delete the control at the given index from this Box

Parámetros

index

The index of the control to delete

Valores devueltos

Indication of success


Get Orientation

  • « UI\Controls\Box::delete
  • UI\Controls\Box::isPadded »
  • PHP Manual
  • UI\Controls\Box
  • Get Orientation

UI\Controls\Box::getOrientation

(UI 0.9.9)

UI\Controls\Box::getOrientation — Get Orientation

Descripción

public UI\Controls\Box::getOrientation ( ) : int

Shall retrieve the orientation of this Box

Parámetros

Esta función no tiene parámetros.


Padding Detection

  • « UI\Controls\Box::getOrientation
  • UI\Controls\Box::setPadded »
  • PHP Manual
  • UI\Controls\Box
  • Padding Detection

UI\Controls\Box::isPadded

(UI 0.9.9)

UI\Controls\Box::isPadded — Padding Detection

Descripción

public UI\Controls\Box::isPadded ( ) : bool

Shall detect if padding is enabled on this Box

Parámetros

Esta función no tiene parámetros.


Set Padding

  • « UI\Controls\Box::isPadded
  • UI\Draw\Pen »
  • PHP Manual
  • UI\Controls\Box
  • Set Padding

UI\Controls\Box::setPadded

(UI 0.9.9)

UI\Controls\Box::setPadded — Set Padding

Descripción

public UI\Controls\Box::setPadded ( bool $padded )

Shall enable or disable padding on this Box

Parámetros

padded


Draw Pen

(UI 0.9.9)

Introducción

The Pen is passed to the Area Draw event handler, it is used for clipping, filling, stroking, and writing to Draw Paths.

Sinopsis de la Clase

final UI\Draw\Pen {
/* Métodos */
public clip ( UI\Draw\Path $path )
public fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public fill ( UI\Draw\Path $path , int $with )
public restore ( )
public save ( )
public stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , int $with , UI\Draw\Stroke $stroke )
public transform ( UI\Draw\Matrix $matrix )
public write ( UI\Point $point , UI\Draw\Text\Layout $layout )
}

Tabla de contenidos

  • UI\Draw\Pen::clip — Clip a Path
  • UI\Draw\Pen::fill — Llena una ruta
  • UI\Draw\Pen::restore — Restaura
  • UI\Draw\Pen::save — Guarda
  • UI\Draw\Pen::stroke — Traza una ruta
  • UI\Draw\Pen::transform — Transformación de la matriz
  • UI\Draw\Pen::write — Dibuja el texto en el punto


Clip a Path

  • « UI\Draw\Pen
  • UI\Draw\Pen::fill »
  • PHP Manual
  • UI\Draw\Pen
  • Clip a Path

UI\Draw\Pen::clip

(UI 0.9.9)

UI\Draw\Pen::clip — Clip a Path

Descripción

public UI\Draw\Pen::clip ( UI\Draw\Path $path )

Shall clip the given Path

Parámetros

path

The path to clip


Llena una ruta

  • « UI\Draw\Pen::clip
  • UI\Draw\Pen::restore »
  • PHP Manual
  • UI\Draw\Pen
  • Llena una ruta

UI\Draw\Pen::fill

(UI 0.9.9)

UI\Draw\Pen::fill — Llena una ruta

Descripción

public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , int $with )

Llenará la ruta dada

Parámetros

path

La ruta a llenar

with

El color o el pincel para rellenar


Restaura

  • « UI\Draw\Pen::fill
  • UI\Draw\Pen::save »
  • PHP Manual
  • UI\Draw\Pen
  • Restaura

UI\Draw\Pen::restore

(UI 0.9.9)

UI\Draw\Pen::restore — Restaura

Descripción

public UI\Draw\Pen::restore ( )

Restaurará un bolígrafo previamente guardado

Parámetros

Esta función no tiene parámetros.


Guarda

  • « UI\Draw\Pen::restore
  • UI\Draw\Pen::stroke »
  • PHP Manual
  • UI\Draw\Pen
  • Guarda

UI\Draw\Pen::save

(UI 0.9.9)

UI\Draw\Pen::save — Guarda

Descripción

public UI\Draw\Pen::save ( )

Guardará el bolígrafo

Parámetros

Esta función no tiene parámetros.


Traza una ruta

  • « UI\Draw\Pen::save
  • UI\Draw\Pen::transform »
  • PHP Manual
  • UI\Draw\Pen
  • Traza una ruta

UI\Draw\Pen::stroke

(UI 0.9.9)

UI\Draw\Pen::stroke — Traza una ruta

Descripción

public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , int $with , UI\Draw\Stroke $stroke )

Trazará la ruta dada

Parámetros

path

La ruta del trazo

with

El color o el pincel con el que trazar

stroke

La configuración del trazo


Transformación de la matriz

  • « UI\Draw\Pen::stroke
  • UI\Draw\Pen::write »
  • PHP Manual
  • UI\Draw\Pen
  • Transformación de la matriz

UI\Draw\Pen::transform

(UI 0.9.9)

UI\Draw\Pen::transform — Transformación de la matriz

Descripción

public UI\Draw\Pen::transform ( UI\Draw\Matrix $matrix )

Realizará la transformación de la matriz

Parámetros

matrix

La matriz a usar


Dibuja el texto en el punto

  • « UI\Draw\Pen::transform
  • UI\Draw\Path »
  • PHP Manual
  • UI\Draw\Pen
  • Dibuja el texto en el punto

UI\Draw\Pen::write

(UI 0.9.9)

UI\Draw\Pen::write — Dibuja el texto en el punto

Descripción

public UI\Draw\Pen::write ( UI\Point $point , UI\Draw\Text\Layout $layout )

Dibujará la disposición del texto en el punto dado

Parámetros

point

El punto a realizar el dibujo

layout

La disposición del texto a dibujar


Draw Path

(UI 0.9.9)

Introducción

A Draw Path guides a Draw Pen, telling the Pen where to draw on an Area.

Sinopsis de la Clase

UI\Draw\Path {
/* Constants */
const int Winding ;
const int Alternate ;
/* Constructor */
public __construct ( int $mode = UI\Draw\Path::Winding )
/* Métodos */
public addRectangle ( UI\Point $point , UI\Size $size )
public arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public closeFigure ( )
public end ( )
public lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public newFigure ( UI\Point $point )
public newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
}

Constantes predefinidas

UI\Draw\Path::Winding

This is the default draw path mode

UI\Draw\Path::Alternate

This is the alternate draw path mode

Tabla de contenidos

  • UI\Draw\Path::addRectangle — Dibuja un rectángulo
  • UI\Draw\Path::arcTo — Dibuja un arco
  • UI\Draw\Path::bezierTo — Draw Bezier Curve
  • UI\Draw\Path::closeFigure — Cerrar Figura
  • UI\Draw\Path::__construct — Construye una nueva ruta
  • UI\Draw\Path::end — Finalizar Ruta
  • UI\Draw\Path::lineTo — Dibuja una línea
  • UI\Draw\Path::newFigure — Dibuja figura
  • UI\Draw\Path::newFigureWithArc — Dibuja figura con arco


Dibuja un rectángulo

  • « UI\Draw\Path
  • UI\Draw\Path::arcTo »
  • PHP Manual
  • UI\Draw\Path
  • Dibuja un rectángulo

UI\Draw\Path::addRectangle

(UI 0.9.9)

UI\Draw\Path::addRectangle — Dibuja un rectángulo

Descripción

public UI\Draw\Path::addRectangle ( UI\Point $point , UI\Size $size )

Trazará la ruta de un rectángulo del tamaño dado, en el punto dado

Parámetros

point

El punto de partida de la forma

size

El tamaño del rectángulo


Dibuja un arco

  • « UI\Draw\Path::addRectangle
  • UI\Draw\Path::bezierTo »
  • PHP Manual
  • UI\Draw\Path
  • Dibuja un arco

UI\Draw\Path::arcTo

(UI 0.9.9)

UI\Draw\Path::arcTo — Dibuja un arco

Descripción

public UI\Draw\Path::arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Trazará la ruta para un arco

Parámetros

point

El punto de partida del mapeo

radius

El radio del arco

angle

El ángulo del arco

sweep

El alcance del arco

negative

Valores devueltos


Draw Bezier Curve

  • « UI\Draw\Path::arcTo
  • UI\Draw\Path::closeFigure »
  • PHP Manual
  • UI\Draw\Path
  • Draw Bezier Curve

UI\Draw\Path::bezierTo

(UI 0.9.9)

UI\Draw\Path::bezierTo — Draw Bezier Curve

Descripción

public UI\Draw\Path::bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall draw a bezier curve

Parámetros

point

The point at which to begin mapping

radius

The radius of the curve

angle

The angle of the curve

sweep

The sweep of the curve

negative


Cerrar Figura

  • « UI\Draw\Path::bezierTo
  • UI\Draw\Path::__construct »
  • PHP Manual
  • UI\Draw\Path
  • Cerrar Figura

UI\Draw\Path::closeFigure

(UI 0.9.9)

UI\Draw\Path::closeFigure — Cerrar Figura

Descripción

public UI\Draw\Path::closeFigure ( )

Cerrará la figura actual

Parámetros

Esta función no tiene parámetros.


Construye una nueva ruta

  • « UI\Draw\Path::closeFigure
  • UI\Draw\Path::end »
  • PHP Manual
  • UI\Draw\Path
  • Construye una nueva ruta

UI\Draw\Path::__construct

(UI 0.9.9)

UI\Draw\Path::__construct — Construye una nueva ruta

Descripción

public UI\Draw\Path::__construct ( int $mode = UI\Draw\Path::Winding )

Construirá una nueva ruta en el modo dado

Parámetros

mode

Path::Winding o Path::Alternate


Finalizar Ruta

  • « UI\Draw\Path::__construct
  • UI\Draw\Path::lineTo »
  • PHP Manual
  • UI\Draw\Path
  • Finalizar Ruta

UI\Draw\Path::end

(UI 0.9.9)

UI\Draw\Path::end — Finalizar Ruta

Descripción

public UI\Draw\Path::end ( )

Finalizará esta ruta

Parámetros

Esta función no tiene parámetros.


Dibuja una línea

  • « UI\Draw\Path::end
  • UI\Draw\Path::newFigure »
  • PHP Manual
  • UI\Draw\Path
  • Dibuja una línea

UI\Draw\Path::lineTo

(UI 0.9.9)

UI\Draw\Path::lineTo — Dibuja una línea

Descripción

public UI\Draw\Path::lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Trazará la ruta para una línea

Parámetros

point

El punto de partida del mapeo

radius

angle

sweep

negative

Valores devueltos


Dibuja figura

  • « UI\Draw\Path::lineTo
  • UI\Draw\Path::newFigureWithArc »
  • PHP Manual
  • UI\Draw\Path
  • Dibuja figura

UI\Draw\Path::newFigure

(UI 0.9.9)

UI\Draw\Path::newFigure — Dibuja figura

Descripción

public UI\Draw\Path::newFigure ( UI\Point $point )

Trazará una nueva figura en el punto dado

Parámetros

point

El punto de partida del mapeo


Dibuja figura con arco

  • « UI\Draw\Path::newFigure
  • UI\Draw\Matrix »
  • PHP Manual
  • UI\Draw\Path
  • Dibuja figura con arco

UI\Draw\Path::newFigureWithArc

(UI 0.9.9)

UI\Draw\Path::newFigureWithArc — Dibuja figura con arco

Descripción

public UI\Draw\Path::newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Parámetros

point

radius

angle

sweep

negative

Valores devueltos


Draw Matrix

(UI 0.9.9)

Introducción

Sinopsis de la Clase

UI\Draw\Matrix {
/* Métodos */
public invert ( )
public isInvertible ( ) : bool
public multiply ( UI\Draw\Matrix $matrix ) : UI\Draw\Matrix
public rotate ( UI\Point $point , float $amount )
public scale ( UI\Point $center , UI\Point $point )
public skew ( UI\Point $point , UI\Point $amount )
public translate ( UI\Point $point )
}

Tabla de contenidos

  • UI\Draw\Matrix::invert — Invertir matriz
  • UI\Draw\Matrix::isInvertible — Detección de invertido
  • UI\Draw\Matrix::multiply — Multiplica la matriz
  • UI\Draw\Matrix::rotate — Rota la matriz
  • UI\Draw\Matrix::scale — Escala la Matriz
  • UI\Draw\Matrix::skew — Inclina la Matriz
  • UI\Draw\Matrix::translate — Traduce la matriz


Invertir matriz

  • « UI\Draw\Matrix
  • UI\Draw\Matrix::isInvertible »
  • PHP Manual
  • UI\Draw\Matrix
  • Invertir matriz

UI\Draw\Matrix::invert

(UI 0.9.9)

UI\Draw\Matrix::invert — Invertir matriz

Descripción

public UI\Draw\Matrix::invert ( )

Invertirá esta matriz

Parámetros

Esta función no tiene parámetros.


Detección de invertido

  • « UI\Draw\Matrix::invert
  • UI\Draw\Matrix::multiply »
  • PHP Manual
  • UI\Draw\Matrix
  • Detección de invertido

UI\Draw\Matrix::isInvertible

(UI 0.9.9)

UI\Draw\Matrix::isInvertible — Detección de invertido

Descripción

public UI\Draw\Matrix::isInvertible ( ) : bool

Detectará si esta Matriz puede ser invertida

Parámetros

Esta función no tiene parámetros.


Multiplica la matriz

  • « UI\Draw\Matrix::isInvertible
  • UI\Draw\Matrix::rotate »
  • PHP Manual
  • UI\Draw\Matrix
  • Multiplica la matriz

UI\Draw\Matrix::multiply

(UI 0.9.9)

UI\Draw\Matrix::multiply — Multiplica la matriz

Descripción

public UI\Draw\Matrix::multiply ( UI\Draw\Matrix $matrix ) : UI\Draw\Matrix

Multiplicará esta matriz con la matriz dada

Parámetros

Esta función no tiene parámetros.

Valores devueltos

La nueva matriz


Rota la matriz

  • « UI\Draw\Matrix::multiply
  • UI\Draw\Matrix::scale »
  • PHP Manual
  • UI\Draw\Matrix
  • Rota la matriz

UI\Draw\Matrix::rotate

(UI 0.9.9)

UI\Draw\Matrix::rotate — Rota la matriz

Descripción

public UI\Draw\Matrix::rotate ( UI\Point $point , float $amount )

Rotar esta Matriz

Parámetros

point

amount


Escala la Matriz

  • « UI\Draw\Matrix::rotate
  • UI\Draw\Matrix::skew »
  • PHP Manual
  • UI\Draw\Matrix
  • Escala la Matriz

UI\Draw\Matrix::scale

(UI 0.9.9)

UI\Draw\Matrix::scale — Escala la Matriz

Descripción

public UI\Draw\Matrix::scale ( UI\Point $center , UI\Point $point )

Escalará esta Matriz

Parámetros

center

point


Inclina la Matriz

  • « UI\Draw\Matrix::scale
  • UI\Draw\Matrix::translate »
  • PHP Manual
  • UI\Draw\Matrix
  • Inclina la Matriz

UI\Draw\Matrix::skew

(UI 0.9.9)

UI\Draw\Matrix::skew — Inclina la Matriz

Descripción

public UI\Draw\Matrix::skew ( UI\Point $point , UI\Point $amount )

Inclinará esta Matriz

Parámetros

point

amount


Traduce la matriz

  • « UI\Draw\Matrix::skew
  • UI\Draw\Color »
  • PHP Manual
  • UI\Draw\Matrix
  • Traduce la matriz

UI\Draw\Matrix::translate

(UI 0.9.9)

UI\Draw\Matrix::translate — Traduce la matriz

Descripción

public UI\Draw\Matrix::translate ( UI\Point $point )

Traducirá esta Matriz

Parámetros

point


Color Representation

(UI 0.9.9)

Introducción

Represents RGBA colours, individual channels are accessible via public properties.

Sinopsis de la Clase

UI\Draw\Color {
/* Constants */
const int Red ;
const int Green ;
const int Blue ;
const int Alpha ;
/* Propiedades */
public $r ;
public $g ;
public $b ;
public $a ;
/* Constructor */
public __construct ( UI\Draw\Color $color = ? )
public __construct ( int $color = ? )
/* Métodos */
public getChannel ( int $channel ) : float
public setChannel ( int $channel , float $value ) : void
}

Propiedades

r

Provides access to the red channel

g

Provides access to the green channel

b

Provides access to the blue channel

a

Provides access to the alpha channel

Constantes predefinidas

UI\Draw\Color::Red

Identifies the red channel

UI\Draw\Color::Green

Identifies the green channel

UI\Draw\Color::Blue

Identifies the blue channel

UI\Draw\Color::Alpha

Identifies the alpha channel

Tabla de contenidos

  • UI\Draw\Color::__construct — Construye un nuevo color
  • UI\Draw\Color::getChannel — Manipulación de color
  • UI\Draw\Color::setChannel — Manipulación de color


Construye un nuevo color

  • « UI\Draw\Color
  • UI\Draw\Color::getChannel »
  • PHP Manual
  • UI\Draw\Color
  • Construye un nuevo color

UI\Draw\Color::__construct

(UI 0.9.9)

UI\Draw\Color::__construct — Construye un nuevo color

Descripción

public UI\Draw\Color::__construct ( UI\Draw\Color $color = ? )
public UI\Draw\Color::__construct ( int $color = ? )

Construirá un nuevo color

Parámetros

color

Puede ser UI\Draw\Color o RRGGBBAA


Manipulación de color

  • « UI\Draw\Color::__construct
  • UI\Draw\Color::setChannel »
  • PHP Manual
  • UI\Draw\Color
  • Manipulación de color

UI\Draw\Color::getChannel

(UI 0.9.9)

UI\Draw\Color::getChannel — Manipulación de color

Descripción

public UI\Draw\Color::getChannel ( int $channel ) : float

Recuperará el valor de un canal

Parámetros

channel

La identidad del canal constante

Valores devueltos

El valor actual del canal solicitado


Manipulación de color

  • « UI\Draw\Color::getChannel
  • UI\Draw\Stroke »
  • PHP Manual
  • UI\Draw\Color
  • Manipulación de color

UI\Draw\Color::setChannel

(UI 0.9.9)

UI\Draw\Color::setChannel — Manipulación de color

Descripción

public UI\Draw\Color::setChannel ( int $channel , float $value ) : void

Pondrá el canal seleccionado en el valor dado

Parámetros

channel

La identidad del canal constante

value

El nuevo valor para el canal seleccionado

Valores devueltos


Draw Stroke

(UI 0.9.9)

Introducción

Holds the configuration for the Pen to perform a stroke

Sinopsis de la Clase

UI\Draw\Stroke {
/* Constructor */
public __construct ( int $cap = UI\Draw\Line\Cap::Flat , int $join = UI\Draw\Line\Join::Miter , float $thickness = 1 , float $miterLimit = 10 )
/* Métodos */
public getCap ( ) : int
public getJoin ( ) : int
public getMiterLimit ( ) : float
public getThickness ( ) : float
public setCap ( int $cap )
public setJoin ( int $join )
public setMiterLimit ( float $limit )
public setThickness ( float $thickness )
}

Tabla de contenidos

  • UI\Draw\Stroke::__construct — Construye un nuevo trazo
  • UI\Draw\Stroke::getCap — Get Line Cap
  • UI\Draw\Stroke::getJoin — Obtiene la unión de línea
  • UI\Draw\Stroke::getMiterLimit — Obtiene el límite de inglete
  • UI\Draw\Stroke::getThickness — Obtiene el grosor
  • UI\Draw\Stroke::setCap — Set Line Cap
  • UI\Draw\Stroke::setJoin — Establece la línea de unión
  • UI\Draw\Stroke::setMiterLimit — Establece el límite de ingletes
  • UI\Draw\Stroke::setThickness — Establece el grosor


Construye un nuevo trazo

  • « UI\Draw\Stroke
  • UI\Draw\Stroke::getCap »
  • PHP Manual
  • UI\Draw\Stroke
  • Construye un nuevo trazo

UI\Draw\Stroke::__construct

(UI 0.9.9)

UI\Draw\Stroke::__construct — Construye un nuevo trazo

Descripción

public UI\Draw\Stroke::__construct ( int $cap = UI\Draw\Line\Cap::Flat , int $join = UI\Draw\Line\Join::Miter , float $thickness = 1 , float $miterLimit = 10 )

Construirá un nuevo trazo

Parámetros

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, o UI\Draw\Line\Cap::Square

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, o UI\Draw\Line\Join::Bevel

thickness

El grosor del trazo

miterLimit

Límite de inglete (el valor por defecto es válido para todas las plataformas)


Get Line Cap

  • « UI\Draw\Stroke::__construct
  • UI\Draw\Stroke::getJoin »
  • PHP Manual
  • UI\Draw\Stroke
  • Get Line Cap

UI\Draw\Stroke::getCap

(UI 0.9.9)

UI\Draw\Stroke::getCap — Get Line Cap

Descripción

public UI\Draw\Stroke::getCap ( ) : int

Shall retrieve the line cap setting of this Stroke

Parámetros

Esta función no tiene parámetros.

Valores devueltos

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square


Obtiene la unión de línea

  • « UI\Draw\Stroke::getCap
  • UI\Draw\Stroke::getMiterLimit »
  • PHP Manual
  • UI\Draw\Stroke
  • Obtiene la unión de línea

UI\Draw\Stroke::getJoin

(UI 0.9.9)

UI\Draw\Stroke::getJoin — Obtiene la unión de línea

Descripción

public UI\Draw\Stroke::getJoin ( ) : int

Recuperaremos el ajuste de la línea de unión de este trazo

Parámetros

Esta función no tiene parámetros.

Valores devueltos

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, o UI\Draw\Line\Join::Bevel


Obtiene el límite de inglete

  • « UI\Draw\Stroke::getJoin
  • UI\Draw\Stroke::getThickness »
  • PHP Manual
  • UI\Draw\Stroke
  • Obtiene el límite de inglete

UI\Draw\Stroke::getMiterLimit

(UI 0.9.9)

UI\Draw\Stroke::getMiterLimit — Obtiene el límite de inglete

Descripción

public UI\Draw\Stroke::getMiterLimit ( ) : float

Recuperará el límite de ingletes de este trazo

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El actual límite de ingletes


Obtiene el grosor

  • « UI\Draw\Stroke::getMiterLimit
  • UI\Draw\Stroke::setCap »
  • PHP Manual
  • UI\Draw\Stroke
  • Obtiene el grosor

UI\Draw\Stroke::getThickness

(UI 0.9.9)

UI\Draw\Stroke::getThickness — Obtiene el grosor

Descripción

public UI\Draw\Stroke::getThickness ( ) : float

Recuperará el grosor de este trazo

Parámetros

Esta función no tiene parámetros.

Valores devueltos

El grosor actual


Set Line Cap

  • « UI\Draw\Stroke::getThickness
  • UI\Draw\Stroke::setJoin »
  • PHP Manual
  • UI\Draw\Stroke
  • Set Line Cap

UI\Draw\Stroke::setCap

(UI 0.9.9)

UI\Draw\Stroke::setCap — Set Line Cap

Descripción

public UI\Draw\Stroke::setCap ( int $cap )

Shall set the line cap setting for this Stroke

Parámetros

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square


Establece la línea de unión

  • « UI\Draw\Stroke::setCap
  • UI\Draw\Stroke::setMiterLimit »
  • PHP Manual
  • UI\Draw\Stroke
  • Establece la línea de unión

UI\Draw\Stroke::setJoin

(UI 0.9.9)

UI\Draw\Stroke::setJoin — Establece la línea de unión

Descripción

public UI\Draw\Stroke::setJoin ( int $join )

Establecerá la línea de unión para este trazo

Parámetros

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, o UI\Draw\Line\Join::Bevel

Valores devueltos


Establece el límite de ingletes

  • « UI\Draw\Stroke::setJoin
  • UI\Draw\Stroke::setThickness »
  • PHP Manual
  • UI\Draw\Stroke
  • Establece el límite de ingletes

UI\Draw\Stroke::setMiterLimit

(UI 0.9.9)

UI\Draw\Stroke::setMiterLimit — Establece el límite de ingletes

Descripción

public UI\Draw\Stroke::setMiterLimit ( float $limit )

Establece el límite de ingletes para este trazo

Parámetros

limit

El nuevo límite


Establece el grosor

  • « UI\Draw\Stroke::setMiterLimit
  • UI\Draw\Brush »
  • PHP Manual
  • UI\Draw\Stroke
  • Establece el grosor

UI\Draw\Stroke::setThickness

(UI 0.9.9)

UI\Draw\Stroke::setThickness — Establece el grosor

Descripción

public UI\Draw\Stroke::setThickness ( float $thickness )

Establecerá el grosor de este trazo

Parámetros

thickness

El nuevo grosor


Brushes

(UI 0.9.9)

Introducción

Represents a solid color brush

Sinopsis de la Clase

UI\Draw\Brush {
/* Constructor */
public __construct ( UI\Draw\Color $color )
public __construct ( int $color )
/* Métodos */
public getColor ( ) : UI\Draw\Color
public setColor ( UI\Draw\Color $color ) : void
public setColor ( int $color ) : void
}

Tabla de contenidos

  • UI\Draw\Brush::__construct — Construct a new Brush
  • UI\Draw\Brush::getColor — Get Color
  • UI\Draw\Brush::setColor — Set Color


Construct a new Brush

  • « UI\Draw\Brush
  • UI\Draw\Brush::getColor »
  • PHP Manual
  • UI\Draw\Brush
  • Construct a new Brush

UI\Draw\Brush::__construct

(UI 0.9.9)

UI\Draw\Brush::__construct — Construct a new Brush

Descripción

public UI\Draw\Brush::__construct ( UI\Draw\Color $color )
public UI\Draw\Brush::__construct ( int $color )

Shall construct a solid brush using the given color

Parámetros

color

Can be a UI\Draw\Color or RRGGBBAA


Get Color

  • « UI\Draw\Brush::__construct
  • UI\Draw\Brush::setColor »
  • PHP Manual
  • UI\Draw\Brush
  • Get Color

UI\Draw\Brush::getColor

(UI 0.9.9)

UI\Draw\Brush::getColor — Get Color

Descripción

public UI\Draw\Brush::getColor ( ) : UI\Draw\Color

Shall return a UI\Draw\Color for this brush

Parámetros

Esta función no tiene parámetros.

Valores devueltos

The current color of the brush


Set Color

  • « UI\Draw\Brush::getColor
  • UI\Draw\Brush\Gradient »
  • PHP Manual
  • UI\Draw\Brush
  • Set Color

UI\Draw\Brush::setColor

(UI 0.9.9)

UI\Draw\Brush::setColor — Set Color

Descripción

public UI\Draw\Brush::setColor ( UI\Draw\Color $color ) : void
public UI\Draw\Brush::setColor ( int $color ) : void

Shall set the color of this brush to the color provided

Parámetros

color

Can be a UI\Draw\Color or RRGGBBAA

Valores devueltos


Gradient Brushes

(UI 2.0.0)

Introducción

Abstract for gradient brushes

Sinopsis de la Clase

abstract UI\Draw\Brush\Gradient extends UI\Draw\Brush {
/* Métodos */
public addStop ( float $position , UI\Draw\Color $color ) : int
public addStop ( float $position , int $color ) : int
public delStop ( int $index ) : int
public setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public setStop ( int $index , float $position , int $color ) : bool
/* Métodos heredados */
public UI\Draw\Brush::getColor ( ) : UI\Draw\Color
public UI\Draw\Brush::setColor ( UI\Draw\Color $color ) : void
public UI\Draw\Brush::setColor ( int $color ) : void
}

Tabla de contenidos

  • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::setStop — Stop Manipulation


Stop Manipulation

  • « UI\Draw\Brush\Gradient
  • UI\Draw\Brush\Gradient::delStop »
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::addStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::addStop — Stop Manipulation

Descripción

public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int

Shall at a stop of the given color at the given position

Parámetros

position

The position for the new stop

color

The color for the new stop, may be UI\Draw\Color or RRGGBBAA

Valores devueltos

Total number of stops


Stop Manipulation

  • « UI\Draw\Brush\Gradient::addStop
  • UI\Draw\Brush\Gradient::setStop »
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::delStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::delStop — Stop Manipulation

Descripción

public UI\Draw\Brush\Gradient::delStop ( int $index ) : int

Advertencia

Esta función no está documentada actualmente, solamente se encuentra disponible la lista de parámetros.

Parámetros

index

Valores devueltos

Total number of stops


Stop Manipulation

  • « UI\Draw\Brush\Gradient::delStop
  • UI\Draw\Brush\LinearGradient »
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::setStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::setStop — Stop Manipulation

Descripción

public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool

Parámetros

index

The index of the stop to set

position

The position for the stop

color

The color for the stop, may be UI\Draw\Color or RRGGBBAA

Valores devueltos

Indication of success


Linear Gradient

(UI 2.0.0)

Introducción

Sinopsis de la Clase

UI\Draw\Brush\LinearGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $end )
/* Métodos heredados */
public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int
public UI\Draw\Brush\Gradient::delStop ( int $index ) : int
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool
}

Tabla de contenidos

  • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient


Construct a Linear Gradient

  • « UI\Draw\Brush\LinearGradient
  • UI\Draw\Brush\RadialGradient »
  • PHP Manual
  • UI\Draw\Brush\LinearGradient
  • Construct a Linear Gradient

UI\Draw\Brush\LinearGradient::__construct

(UI 2.0.0)

UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient

Descripción

public UI\Draw\Brush\LinearGradient::__construct ( UI\Point $start , UI\Point $end )

Shall construct a new linear gradient

Parámetros

start

end


Radial Gradient

(UI 2.0.0)

Introducción

Sinopsis de la Clase

UI\Draw\Brush\RadialGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $outer , float $radius )
/* Métodos heredados */
public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int
public UI\Draw\Brush\Gradient::delStop ( int $index ) : int
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool
}

Tabla de contenidos

  • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient


Construct a new Radial Gradient

  • « UI\Draw\Brush\RadialGradient
  • UI\Draw\Text\Layout »
  • PHP Manual
  • UI\Draw\Brush\RadialGradient
  • Construct a new Radial Gradient

UI\Draw\Brush\RadialGradient::__construct

(UI 2.0.0)

UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient

Descripción

public UI\Draw\Brush\RadialGradient::__construct ( UI\Point $start , UI\Point $outer , float $radius )

Shall construct a new radial gradient

Parámetros

start

outer

radius


Represents Text Layout

(UI 0.9.9)

Introducción

A Text Layout represents the layout of text which will be drawn by the Pen

Sinopsis de la Clase

UI\Draw\Text\Layout {
/* Constructor */
public __construct ( string $text , UI\Draw\Text\Font $font , float $width )
/* Métodos */
public setColor ( UI\Draw\Color $color , int $start = 0 , int $end = ? )
public setColor ( int $color , int $start = 0 , int $end = ? )
public setWidth ( float $width )
}

Tabla de contenidos

  • UI\Draw\Text\Layout::__construct — Construir un nuevo diseño de texto
  • UI\Draw\Text\Layout::setColor — Establece el color
  • UI\Draw\Text\Layout::setWidth — Establece el ancho


Construir un nuevo diseño de texto

  • « UI\Draw\Text\Layout
  • UI\Draw\Text\Layout::setColor »
  • PHP Manual
  • UI\Draw\Text\Layout
  • Construir un nuevo diseño de texto

UI\Draw\Text\Layout::__construct

(UI 0.9.9)

UI\Draw\Text\Layout::__construct — Construir un nuevo diseño de texto

Descripción

public UI\Draw\Text\Layout::__construct ( string $text , UI\Draw\Text\Font $font , float $width )

Construirá un nuevo diseño de texto

Parámetros

text

El texto para el diseño

font

El tipo de letra a utilizar para escribir

width

El ancho del diseño


Establece el color

  • « UI\Draw\Text\Layout::__construct
  • UI\Draw\Text\Layout::setWidth »
  • PHP Manual
  • UI\Draw\Text\Layout
  • Establece el color

UI\Draw\Text\Layout::setColor

(UI 0.9.9)

UI\Draw\Text\Layout::setColor — Establece el color

Descripción

public UI\Draw\Text\Layout::setColor ( UI\Draw\Color $color , int $start = 0 , int $end = ? )
public UI\Draw\Text\Layout::setColor ( int $color , int $start = 0 , int $end = ? )

Establecerá el color para todo o un rango del texto en el diseño

Parámetros

color

El color a usar

start

El carácter inicial

end

El carácter final, por defecto el final del string


Establece el ancho

  • « UI\Draw\Text\Layout::setColor
  • UI\Draw\Text\Font »
  • PHP Manual
  • UI\Draw\Text\Layout
  • Establece el ancho

UI\Draw\Text\Layout::setWidth

(UI 0.9.9)

UI\Draw\Text\Layout::setWidth — Establece el ancho

Descripción

public UI\Draw\Text\Layout::setWidth ( float $width )

Establecerá el ancho del diseño del texto

Parámetros

width

El nuevo ancho


Represents a Font

(UI 0.9.9)

Introducción

Loads a described font

Sinopsis de la Clase

UI\Draw\Text\Font {
/* Constructor */
public __construct ( UI\Draw\Text\Font\Descriptor $descriptor )
/* Métodos */
public getAscent ( ) : float
public getDescent ( ) : float
public getLeading ( ) : float
public getUnderlinePosition ( ) : float
public getUnderlineThickness ( ) : float
}

Tabla de contenidos

  • UI\Draw\Text\Font::__construct — Construye una nueva fuente
  • UI\Draw\Text\Font::getAscent — Métricas de la fuente
  • UI\Draw\Text\Font::getDescent — Métricas de la fuente
  • UI\Draw\Text\Font::getLeading — Métricas de la fuente
  • UI\Draw\Text\Font::getUnderlinePosition — Métricas de la fuente
  • UI\Draw\Text\Font::getUnderlineThickness — Métricas de la fuente


Construye una nueva fuente

  • « UI\Draw\Text\Font
  • UI\Draw\Text\Font::getAscent »
  • PHP Manual
  • UI\Draw\Text\Font
  • Construye una nueva fuente

UI\Draw\Text\Font::__construct

(UI 0.9.9)

UI\Draw\Text\Font::__construct — Construye una nueva fuente

Descripción

public UI\Draw\Text\Font::__construct ( UI\Draw\Text\Font\Descriptor $descriptor )

Construirá una nueva fuente usando el descriptor dado

Parámetros

descriptor

El descriptor de la fuente


Métricas de la fuente

  • « UI\Draw\Text\Font::__construct
  • UI\Draw\Text\Font::getDescent »
  • PHP Manual
  • UI\Draw\Text\Font
  • Métricas de la fuente

UI\Draw\Text\Font::getAscent

(UI 1.0.3)

UI\Draw\Text\Font::getAscent — Métricas de la fuente

Descripción

public UI\Draw\Text\Font::getAscent ( ) : float

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Métricas de la fuente

  • « UI\Draw\Text\Font::getAscent
  • UI\Draw\Text\Font::getLeading »
  • PHP Manual
  • UI\Draw\Text\Font
  • Métricas de la fuente

UI\Draw\Text\Font::getDescent

(UI 1.0.3)

UI\Draw\Text\Font::getDescent — Métricas de la fuente

Descripción

public UI\Draw\Text\Font::getDescent ( ) : float

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Métricas de la fuente

  • « UI\Draw\Text\Font::getDescent
  • UI\Draw\Text\Font::getUnderlinePosition »
  • PHP Manual
  • UI\Draw\Text\Font
  • Métricas de la fuente

UI\Draw\Text\Font::getLeading

(UI 1.0.3)

UI\Draw\Text\Font::getLeading — Métricas de la fuente

Descripción

public UI\Draw\Text\Font::getLeading ( ) : float

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Métricas de la fuente

  • « UI\Draw\Text\Font::getLeading
  • UI\Draw\Text\Font::getUnderlineThickness »
  • PHP Manual
  • UI\Draw\Text\Font
  • Métricas de la fuente

UI\Draw\Text\Font::getUnderlinePosition

(UI 1.0.3)

UI\Draw\Text\Font::getUnderlinePosition — Métricas de la fuente

Descripción

public UI\Draw\Text\Font::getUnderlinePosition ( ) : float

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Métricas de la fuente

  • « UI\Draw\Text\Font::getUnderlinePosition
  • UI\Draw\Text\Font\Descriptor »
  • PHP Manual
  • UI\Draw\Text\Font
  • Métricas de la fuente

UI\Draw\Text\Font::getUnderlineThickness

(UI 1.0.3)

UI\Draw\Text\Font::getUnderlineThickness — Métricas de la fuente

Descripción

public UI\Draw\Text\Font::getUnderlineThickness ( ) : float

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Font Descriptor

(UI 0.9.9)

Introducción

Describes a font

Sinopsis de la Clase

UI\Draw\Text\Font\Descriptor {
/* Constructor */
public __construct ( string $family , float $size , int $weight = UI\Draw\Text\Font\Weight::Normal , int $italic = UI\Draw\Text\Font\Italic::Normal , int $stretch = UI\Draw\Text\Font\Stretch::Normal )
/* Métodos */
public getFamily ( ) : string
public getItalic ( ) : int
public getSize ( ) : float
public getStretch ( ) : int
public getWeight ( ) : int
}

Tabla de contenidos

  • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
  • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
  • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
  • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
  • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
  • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection


Construct a new Font Descriptor

  • « UI\Draw\Text\Font\Descriptor
  • UI\Draw\Text\Font\Descriptor::getFamily »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Construct a new Font Descriptor

UI\Draw\Text\Font\Descriptor::__construct

(UI 0.9.9)

UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor

Descripción

public UI\Draw\Text\Font\Descriptor::__construct ( string $family , float $size , int $weight = UI\Draw\Text\Font\Weight::Normal , int $italic = UI\Draw\Text\Font\Italic::Normal , int $stretch = UI\Draw\Text\Font\Stretch::Normal )

Shall construct a new Font Descriptor

Parámetros

family

The name of a valid family of fonts

size

The preferred size

weight

UI\Draw\Text\Font\Weight constant

italic

UI\Draw\Text\Font\Italic constant

stretch

UI\Draw\Text\Font\Stretch constant


Get Font Family

  • « UI\Draw\Text\Font\Descriptor::__construct
  • UI\Draw\Text\Font\Descriptor::getItalic »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Get Font Family

UI\Draw\Text\Font\Descriptor::getFamily

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family

Descripción

public UI\Draw\Text\Font\Descriptor::getFamily ( ) : string

Shall return the requested font family

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Style Detection

  • « UI\Draw\Text\Font\Descriptor::getFamily
  • UI\Draw\Text\Font\Descriptor::getSize »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Style Detection

UI\Draw\Text\Font\Descriptor::getItalic

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getItalic — Style Detection

Descripción

public UI\Draw\Text\Font\Descriptor::getItalic ( ) : int

Shall return constant setting

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Size Detection

  • « UI\Draw\Text\Font\Descriptor::getItalic
  • UI\Draw\Text\Font\Descriptor::getStretch »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Size Detection

UI\Draw\Text\Font\Descriptor::getSize

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getSize — Size Detection

Descripción

public UI\Draw\Text\Font\Descriptor::getSize ( ) : float

Shall return the requested size

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Style Detection

  • « UI\Draw\Text\Font\Descriptor::getSize
  • UI\Draw\Text\Font\Descriptor::getWeight »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Style Detection

UI\Draw\Text\Font\Descriptor::getStretch

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getStretch — Style Detection

Descripción

public UI\Draw\Text\Font\Descriptor::getStretch ( ) : int

Shall return requested stretch

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Weight Detection

  • « UI\Draw\Text\Font\Descriptor::getStretch
  • UI Funciones »
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Weight Detection

UI\Draw\Text\Font\Descriptor::getWeight

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection

Descripción

public UI\Draw\Text\Font\Descriptor::getWeight ( ) : int

Shall return requested weight

Parámetros

Esta función no tiene parámetros.

Valores devueltos


UI Funciones

Tabla de contenidos

  • UI\Draw\Text\Font\fontFamilies — Recuperar las familias de fuentes
  • UI\quit — Quit UI Loop
  • UI\run — Enter UI Loop


Recuperar las familias de fuentes

  • « UI Funciones
  • UI\quit »
  • PHP Manual
  • UI Funciones
  • Recuperar las familias de fuentes

UI\Draw\Text\Font\fontFamilies

(UI 0.9.9)

UI\Draw\Text\Font\fontFamilies — Recuperar las familias de fuentes

Descripción

UI\Draw\Text\Font\fontFamilies ( ) : array

Devuelve un array con las familas de fuentes válidas para el sistema actual

Parámetros

Esta función no tiene parámetros.


Quit UI Loop

  • « UI\Draw\Text\Font\fontFamilies
  • UI\run »
  • PHP Manual
  • UI Funciones
  • Quit UI Loop

UI\quit

(UI 2.0.0)

UI\quit — Quit UI Loop

Descripción

UI\quit ( ) : void

Shall cause the main loop to be exited

Parámetros

Esta función no tiene parámetros.

Valores devueltos


Enter UI Loop

  • « UI\quit
  • UI\Draw\Text\Font\Weight »
  • PHP Manual
  • UI Funciones
  • Enter UI Loop

UI\run

(UI 2.0.0)

UI\run — Enter UI Loop

Descripción

UI\run ( int $flags = ? ) : void

Shall cause PHP to enter into the main loop, by default control will not be returned to the caller

Parámetros

flags

Set UI\Loop to return control, and UI\Wait to return control after waiting

Valores devueltos


Font Weight Settings

(UI 0.9.9)

Introducción

Sinopsis de la Clase

final UI\Draw\Text\Font\Weight {
/* Constants */
const int Thin ;
const int UltraLight ;
const int Light ;
const int Book ;
const int Normal ;
const int Medium ;
const int SemiBold ;
const int Bold ;
const int UltraBold ;
const int Heavy ;
const int UltraHeavy ;
}


Italic Font Settings

(UI 0.9.9)

Introducción

Sinopsis de la Clase

final UI\Draw\Text\Font\Italic {
/* Constants */
const int Normal = 0 ;
const int Oblique = 1 ;
const int Italic = 2 ;
}


Font Stretch Settings

(UI 0.9.9)

Introducción

Sinopsis de la Clase

final UI\Draw\Text\Font\Stretch {
/* Constants */
const int UltraCondensed = 0 ;
const int ExtraCondensed = 1 ;
const int Condensed = 2 ;
const int SemiCondensed = 3 ;
const int Normal = 4 ;
const int SemiExpanded = 5 ;
const int Expanded = 6 ;
const int ExtraExpanded = 7 ;
const int UltraExpanded = 8 ;
}


Line Cap Settings

(UI 0.9.9)

Introducción

Sinopsis de la Clase

final UI\Draw\Line\Cap {
/* Constants */
const int Flat ;
const int Round ;
const int Square ;
}


Line Join Settings

(UI 0.9.9)

Introducción

Sinopsis de la Clase

final UI\Draw\Line\Join {
/* Constants */
const int Miter ;
const int Round ;
const int Bevel ;
}


Key Identifiers

(UI 1.0.0)

Introducción

Sinopsis de la Clase

final UI\Key {
/* Constants */
const int Escape ;
const int Insert ;
const int Delete ;
const int Home ;
const int End ;
const int PageUp ;
const int PageDown ;
const int Up ;
const int Down ;
const int Left ;
const int Right ;
const int F1 ;
const int F2 ;
const int F3 ;
const int F4 ;
const int F5 ;
const int F6 ;
const int F7 ;
const int F8 ;
const int F9 ;
const int F10 ;
const int F11 ;
const int F12 ;
const int N0 ;
const int N1 ;
const int N2 ;
const int N3 ;
const int N4 ;
const int N5 ;
const int N6 ;
const int N7 ;
const int N8 ;
const int N9 ;
const int NDot ;
const int NEnter ;
const int NAdd ;
const int NSubtract ;
const int NMultiply ;
const int NDivide ;
}


InvalidArgumentException

(UI 1.0.3)

Introducción

Sinopsis de la Clase

UI\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


RuntimeException

(UI 1.0.3)

Introducción

Sinopsis de la Clase

UI\Exception\RuntimeException extends RuntimeException implements Throwable {
/* Propiedades heredadas */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Métodos heredados */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


FAQ: Preguntas frequentes

  • Información general
  • Listas de correos
  • Consiguiendo PHP
  • Problemas con bases de datos
  • Instalación
  • Problemas de Compilación
  • Utilizar PHP
  • Hash de Contraseñas — Hash de contraseñas seguro
  • PHP y HTML
  • PHP y COM
  • Preguntas Varias


Información general

Esta sección contiene las preguntas más generales sobre PHP: Qué es y qué hace.

  1. ¿Qué es PHP?
  2. ¿Qué significa PHP?
  3. ¿Cuál es la relación entre las versiones?
  4. ¿Puedo usar varias versiones de PHP al mismo tiempo?
  5. ¡Creo que he encontrado un error! ¿A quién debo informar?
¿Qué es PHP?

Según el prefacio del manual:

PHP es un lenguaje de «scripting» que puede ser embebido en HTML. Gran parte de su sintaxis se toma prestada de C, Java y Perl con un par de características específicas propias de PHP. El objetivo del lenguaje es permitir a los desarrolladores web escribir con rapidez páginas generadas dinámicamente.

¿Qué significa PHP?

PHP significa PHP: Hypertext Preprocessor. Esto confunde a mucha gente porque la primera palabra del acrónimo es el acrónimo mismo. Este tipo de acrónimo se denomina 'acrónimo recursivo'. Para más información, los curiosos pueden visitar » El Diccionario de Informática On-Line Gratuito ó la » entrada de acrónimo recursivo en Wikipedia (ambos en inglés).

¿Cuál es la relación entre las versiones?

PHP/FI 2.0 es una versión de PHP antigua y sin soporte. PHP 3 es el sucesor de PHP/FI 2.0 y es mucho mejor. PHP 7 es la generación actual de PHP, la cual emplea el Motor Zend 3 que, entre otras cosas, ofrece muchas características adicionales de POO.

¿Puedo usar varias versiones de PHP al mismo tiempo?

Sí. Vea el fichero INSTALL que se incluye en la distribución del código fuente de PHP.

¡Creo que he encontrado un error! ¿A quién debo informar?

Debería ir a la Base de datos de errores de PHP y asegurarse de que no se trate de un error ya descubierto. Si no lo encuentra en la Base de datos, use el formulario de notificación para informar del error. Es importante que utilice la Base de datos de errores en vez de solamente enviar un correo electrónico a una de las listas de correo, ya que así al error se le asignará un número de seguimiento, pudiendo volver luego y comprobar el estado de dicho error. La Base de datos de errores de PHP se encuentra en » https://bugs.php.net/.


Listas de correos

Esta sección contiene preguntas acerca de cómo ponerse en contacto con la comunidad de PHP. La mejor forma es a través de las listas de correos.

  1. ¿Existen listas de correos de PHP?
  2. ¿Existen otras comunidades?
  3. ¿Puedo crear mi propia lista de correos de PHP?
  4. ¡Ayuda! ¡Aparentemente no puedo iniciar/cancelar suscripciones en una de las listas de correos!
  5. ¿Existe un archivo de las listas de correos en alguna parte?
  6. ¿Qué puedo preguntar en la lista de correos?
  7. ¿Qué información debo incluir cuando envío mensajes a las listas de correos?
¿Existen listas de correos de PHP?

¡Por supuesto! Hay listas de correos para diferentes asuntos. Las listas de correos más comunes de la comunidad se pueden encontrar en nuestra página de » Listas de correos.

La lista de correos más general es php-general. Para suscribirse, envíe un correo electrónico en blanco a » php-general-subscribe@lists.php.net. Para anular su suscripción, envíe un correo electrónico en blanco a » php-general-unsubscribe@lists.php.net.

También puede iniciar y cancelar suscripciones usando la interfaz web de nuestra página » Listas de correos. También se incluyen instrucciones para darse de baja al final de cada mensaje de las listas de correos.

¿Existen otras comunidades?

Hay un sinnúmero de comunidades de PHP alrededor del mundo, y tenemos vínculos con algunos de estos recursos (asi como información sobre cómo averiguar más) en nuestra página de » Soporte.

¿Puedo crear mi propia lista de correos de PHP?

¡Absolutamente! De hecho, no sólo lo permitimos libremente, lo apoyamos! Ayudando a otros compartiendo su conocimiento y experiencia sobre PHP ayuda a fomentar el crecimiento y desarrollo de la comunidad mundial de PHP y del lenguaje en sí.

¡Ayuda! ¡Aparentemente no puedo iniciar/cancelar suscripciones en una de las listas de correos!

Si tiene problemas con la suscripción o la baja de una suscripción en una lista de correos, puede ser porque el software de la lista de correos no entiende la correcta dirección de e-mail a utilizar. Si su dirección es joeblow@example.com, y está intentando suscribirse a php-general, puede enviar su solicitud de suscripción a php-general-subscribe-joeblow=example.com@lists.php.net, o su solicitud de baja a php-general-unsubscribe-joeblow=example.com@lists.php.net. Use direcciones similares para otras listas de correos.

La causa más común por la que la gente tiene problemas a la hora de darse de baja de nuestras listas de correos se debe al reenvío de correos. Por ejemplo, si su e-mail es danbrown@example.com, pero se suscribió a la lista de correos con el redireccionador php-lists@example.com y reenvía eso a danbrown@example.com, intentar dar de baja a danbrown@example.com no funcionará, ya que esa dirección no existe en nuestros sistemas. En cambio, necesitará dar de baja la dirección de la que haya sido enviado el correo de suscripción - en este caso, php-lists@example.com.

¿Existe un archivo de las listas de correos en alguna parte?

Si, encontrará vínculos a algunos sitios que mantienen archivos en la sección » Listas de correos. También encontrará decenas de Sitios que archivan y/o sindican el contenido de nuestra lista de correos usando su Motor de Búsqueda de Internet favorito y buscando "archivos de la lista de correos de php".

Todos los artículos de las listas de correos son también archivados como noticias. Puede acceder al servidor de noticias en » news://news.php.net/ con un cliente de este servicio. También existe una interfaz web experimental para el servidor de noticias en » http://news.php.net/

¿Qué puedo preguntar en la lista de correos?

Dado que PHP está creciendo más y más cada día, el tráfico en la lista de correos php-general se ha incrementado, yendo de 75 a 200 o más mensajes por día. Debido a esto, es del interés de todos que sólo use la lista como último recurso, una vez haya probado todos los demás caminos.

Antes de enviar su consulta a la lista por favor eche un vistazo a esta FAQ y al manual para ver si puede encontrar ayuda en tales sitios. Si no encuentra nada, pruebe con los archivos de las listas de correos (vea más arriba). Si tiene problemas con la instalación o configuración de PHP, por favor lea en su totalidad la documentación incluida y los documentos README. Si todavía no puede encontrar información alguna que le ayude, es más que bienvenido para usar la lista de correos apropiada.

Para asegurarse de que reciba las mejores respuestas (y recudir la probabilidad de frustrar a sus compañeros), por favor tenga en cuenta enviar la pregunta a la lista correspondiente. Por ejemplo, si está teniendo dificultades instalando PHP, debería enviar su consulta a la lista de correos php-install. Una advertencia: algunas listas tienen nombres similares y usos totalmente diferentes; una consulta respecto scripts PHP en Windows debería ser dirigida a la lista de usuarios de PHP en Windows, no a la lista del Funcionamiento Interno de Windows.

Antes de consultar, puede que sea de su interés leer el artículo » Cómo formular preguntas inteligentemente, ya que es una buena idea para todos.

¿Qué información debo incluir cuando envío mensajes a las listas de correos?

Mensajes como "¡No logro que PHP funcione! ¡Ayúdenme! ¿Qué está mal?" son absolutamente inútiles para todos. Si está sufriendo dificultades con la ejecución y configuración de PHP debe incluir el sistema operativo que está usando, la versión de PHP que está tratando de utilizar, de qué forma adquirió el software (pre-compilada, Git, RPM, etc.), qué ha hecho hasta el momento, y el mensaje de error exacto o el resultado actual.

Esto se aplica también para cualquier otro problema: debe incluir una explicación de qué ha hecho, qué está tratando de hacer, y algún mensaje de error encontrado en el proceso. Si tiene problemas con su código fuente, debería incluir la parte del código que no funciona, indicando en que línea se encuentra el error mediante un comentario apropiadamente situado. ¡No incluya más código del necesario! Eso hace al mensaje difícil de leer, y mayoría puede simplemente ignorarlo por esta razón. Si no está seguro de cuánta información debería ser incluida, envie lo que crea de relevancia significativa a su problema actual, y preparese para dar más datos sobre su solicitud.

Otro punto importante a tener en mente es hacer un resumen de su problema en el asunto del mensaje. Un asunto como "AYUUDAAAA!!!" o "¿Cuál es el problema aquí?" será ignorado por la mayoría de los lectores.

Y por último, es recomendable que lea el artículo » Cómo formular preguntas inteligentemente, debido a que será de gran ayuda para todos, especialmente para Ud. mismo.


Consiguiendo PHP

Esta sección contiene detalles sobre las ubicaciones de descarga de PHP, y asuntos específicos a diferentes sistemas operativos.

  1. ¿Donde puedo conseguir PHP?
  2. ¿Hay versiones binarias pre-compiladas disponibles?
  3. ¿Donde consigo las bibliotecas requeridas para compilar algunas de las extensiones opcionales de PHP?
  4. ¿Cómo hago para que esas bibliotecas funcionen?
  5. He conseguido la última versión del código fuente de PHP desde el repositorio Git en mi máquina Windows, ¿Qué necesito para su compilación?
  6. ¿Dónde consigo el Archivo de Capacidades del Explorador?
  7. ¿Que significa thread safety cuando se descarga PHP?
¿Donde puedo conseguir PHP?

Se puede descargar PHP desde cualquier miembro de la red de Sitios de PHP. Estos se pueden encontrar en » https://www.php.net/. También puede utilizar Git anónimo para conseguir la última versión del código fuente. Para mayor información, visite » https://www.php.net/git.php.

¿Hay versiones binarias pre-compiladas disponibles?

Nosotros solo distribuímos binarios pre-compilados para sistemas Windows, debido a que no tenemos la capacidad de compilar PHP para cada plataforma popular Linux/Unix con todas las combinaciones de extensiones. También tenga en cuenta que muchas distribuciones Linux actualmente vienen con PHP integrado. Los binarios para Windows pueden ser descargados desde nuestra página de » Descargas. Para binarios de Linux, por favor visite el sitio de su distribución.

¿Donde consigo las bibliotecas requeridas para compilar algunas de las extensiones opcionales de PHP?

Nota: Aquellas marcadas con * no son seguras a nivel de hilos; no se recomienda su uso en entornos multihilo.

  • » LDAP (Unix).
  • » LDAP (Unix/Win) : Directorio de Mozilla (LDAP) SDK
  • » free LDAP server.
  • » Berkeley DB2 (Unix/Win) : http://www.sleepycat.com/.
  • » SNMP* (Unix): .
  • » GD (Unix/Win).
  • » mSQL* (Unix).
  • » PostgreSQL (Unix).
  • » IMAP* (Win/Unix).
  • » Sybase-CT* (Linux, libc5) : Disponible localmente.
  • » FreeType (libttf):.
  • » ZLib (Unix/Win32).
  • » expat XML parser (Unix/Win32).
  • » PDFLib.
  • » mcrypt.
  • » mhash.
  • » t1lib.
  • » dmalloc.
  • » aspell.
  • » readline.

¿Cómo hago para que esas bibliotecas funcionen?

Necesitará seguir las instrucciones provistas en la biblioteca. Algunas de estas bibliotecas son detectadas automáticamente cuando ejecuta el script 'configure' de PHP (tal como la biblioteca GD), y otras tendran que ser habilitadas usando opciones '--with-EXTENSION' con 'configure'. Ejecute 'configure --help' para una lista de estas opciones.

He conseguido la última versión del código fuente de PHP desde el repositorio Git en mi máquina Windows, ¿Qué necesito para su compilación?

Véase al wiki de PHP para las últimas instrucciones: » Instrucciones de construcción paso a paso

¿Dónde consigo el Archivo de Capacidades del Explorador?

Se puede encontrar el archivo browscap.ini en » http://browscap.org/.

¿Que significa thread safety cuando se descarga PHP?

Thread Safety significa que el binario puede funcionar en un servidor multi-hilo como por ejemplo bajo Apache 2 para windows.Thread Safety funciona creando una copia local de almacenamiento para cada hilo, de manera que los datos no colisionarán con otros hilos.

Entonces ¿que necesito? Si se elige ejecutar PHP como binario CGI, entonces no se necesita thread safety, por que el binario es invocado en cada petición. Para servidores multi-hilo, como IIS5 y IIS6 se debe utilizar la versión threaded de PHP.


Problemas con bases de datos

Esta sección contiene preguntas comunes sobre la relación entre PHP y bases de datos. Sí, PHP puede acceder a prácticamente cualquier base de datos disponible hoy en día.

  1. He escuchado que es posible acceder a Microsoft SQL Server desde PHP. ¿Cómo?
  2. ¿Puedo acceder a bases de datos Microsoft Access?
  3. ¿Por qué el uso de la extensión MySQL (ext/mysql), que he utilizado durante más de 10 años, está desaconsejado? ¿Está obsoleta? ¿Qué utilizo en su lugar? ¿Cómo puedo migrar?
  4. ¿Porqué recibo un error que luce algo así: "Warning: 0 is not a MySQL result index in <archivo> on line <x>" o "Warning: Supplied argument is not a valid MySQL result resource in <archivo> on line <x>"?
He escuchado que es posible acceder a Microsoft SQL Server desde PHP. ¿Cómo?

En máquinas Unix se puede usar PDO_ODBC o la API ODBC Unificada.

En máquinas Windows se puede usar PDO_SQLSRV o SQLSRV.

Consulte también la respuesta de la siguiente pregunta.

¿Puedo acceder a bases de datos Microsoft Access?

Si. Usted ya dispone de todas las herramientas necesarias si está corriendo enteramente bajo Windows 9x/Me, o NT/2000, en donde es posible utilizar ODBC y los controladores ODBC para bases de datos Microsoft Access.

Si está corriendo PHP en una máquina Unix y desea comunicarse con MS Access en Windows, necesitará controladores ODBC para Unix. » OpenLink Software tiene controladores ODBC basados en Unix que tienen esa capacidad.

Otra alternativa consiste en usar un servidor SQL que tenga controladores ODBC Windows y usarlo para almacenar los datos, a los cuales puede acceder desde Microsoft Access (usando ODBC) y PHP (usando los controladores incorporados), o usar un formato de archivo intermedio que Access y PHP entiendan, como archivos planos o bases de datos dBase. Sobre este punto, Tim Hayes de OpenLink Software escribe:

Usar otra base de datos como intermediario no es una buena idea, cuando es posible usar ODBC desde PHP directamente a su base de datos, es decir, con los controladores de OpenLink. Si realmente necesita usar un formato de archivo intermedio, OpenLink ha lanzado ahora Virtuoso (un motor de bases de datos virtual) para NT, Linux y otras plataformas Unix. Por favor visite nuestro » sitio web para una descarga gratuita.

Una opción que ha sido probada con éxito es usar MySQL y sus controladores MyODBC en Windows y sincronizar las bases de datos. Steve Lawrence escribe:

  • Instale MySQL en su plataforma de acuerdo a las instrucciones de MySQL. La última versión disponible se encuentra en » http://www.mysql.com/. No se requiere ninguna configuración especial, exceptuando al momento de configurar una base de datos, y al configurar la cuenta de usuario, debe poner % en el campo de host, o el nombre del host del equipo Windows desde el que desea acceder a MySQL. Anote su nombre de servidor, nombre de usuario y contraseña.
  • Descargue el controlador MyODBC para Windows desde el sitio de MySQL. Instálelo en su equipo Windows. Es posible probar su operación con las utilidades incluidas con este programa.
  • Cree un usuario o dsn de sistema en su administrador de ODBC, ubicado en el panel de control. Cree un nombre dsn, ingrese su nombre de host, nombre de usuario, contraseña, puerto, etc. para su base de datos MySQL configurada en el paso 1.
  • Instale Access usando la instalación completa, esto asegura que tenga las elementos adicionales apropiados... por lo menos requerirá el soporte ODBC y el gestor de tablas enlazadas.
  • ¡Ahora la parte divertida! Cree una nueva base de datos Access. En la ventana de tabla use el clic derecho y seleccione Enlazar Tablas, o bajo la opción del menú de archivo, seleccione Obtener Datos Externos y luego Enlazar Tablas. Cuando el cuadro de navegación de archivos aparezca, seleccione archivos de tipo: ODBC. Seleccione dsn de Sistema y el nombre de su dsn creado en el paso 3. Seleccione la tabla a enlazar, presione Aceptar, y ¡listo! ¡Ahora es posible abrir la tabla y agregar/eliminar/editar datos en su servidor MySQL! También es posible construir consultas, importar/exportar tablas a MySQL, construir formularios y reportes, etc.

Consejos y Trucos:

  • Es posible construir sus tablas en Access y exportarlas a MySQL, y luego enlazarlas de vuelta. Esto facilita la rápida creación de tablas.
  • Cuando se crean tablas en Access, es necesario tener una clave primaria definida para tener acceso de escritura a la tabla en Access. Asegúrese de crear una clave primaria en MySQL antes de enlazar en Access.
  • Si modifica una tabla en MySQL, es necesario re-enlazarla en Access. Diríjase a Herramientas>Adiciones>Gestor de Tablas Enlazadas, vaya a su DSN ODBC, y seleccione la tabla a re-enlazar desde allí. También es posible transladar su fuente dsn allí, simplemente active el cuadro de verificación "siempre preguntar por una ubicación nueva" antes de presionar Aceptar.

¿Por qué el uso de la extensión MySQL (ext/mysql), que he utilizado durante más de 10 años, está desaconsejado? ¿Está obsoleta? ¿Qué utilizo en su lugar? ¿Cómo puedo migrar?

Existen tres extensiones de MySQL, como está descrito en la sección Elegir una API de MySQL. No se debe usar la API antigua, está obsoletea a partir de PHP 5.5.0 y ha sido movida a PECL a paritr de PHP 7.0.0. Se recomienda encarecidamente escribir todo el código nuevo con mysqli o PDO_MySQL.

La migración de los scripts no está disponible por el momento, aunque la API mysqli API contiene tanto una API procedimental como una API POO, siendo la versión procedimental similar a ext/mysql.

No es posible mezclar extensiones. Así, por ejemplo, pasar una conexión mysqli a PDO_MySQL o ext/mysql no funcionará.

¿Porqué recibo un error que luce algo así: "Warning: 0 is not a MySQL result index in <archivo> on line <x>" o "Warning: Supplied argument is not a valid MySQL result resource in <archivo> on line <x>"?

Está intentando usar un identificador de resultado que es 0. El 0 indica que su consulta falló por alguna razón. Necesita verificar errores después de enviar una consulta y antes de que intente usar el identificador de resultado devuelto. La manera apropiada de hacerlo es con un código similar al siguiente:

<?php

$resultado = mysql_query("SELECT * FROM tablas_priv");
if (!$resultado) {
    echo mysql_error();
    exit;
}
?>
o
<?php

$resultado = mysql_query("SELECT * FROM tablas_priv")
    or die("Consulta fallida: " . mysql_error());
?>


Instalación

Esta sección contiene preguntas comunes sobre la forma de instalar PHP. Este está disponible para casi cualquier SO y casi cualquier servidor web.

Para instalar PHP, siga las instrucciones de Instalación y configuración.

  1. ¿Por qué no debe utilizarse Apache2 con un MPM con hilos en un entorno de producción?
  2. Unix/Windows: ¿Donde debería ubicarse mi fichero php.ini?
  3. Unix: He instalado PHP, pero con cada documento que cargo, obtengo el mensaje 'Document Contains No Data'. ¿Qué está pasando?
  4. Unix: He instalado PHP usando paquetes RPM, pero Apache no procesa los las páginas de PHP. ¿Qué está pasando?
  5. Unix: Le he aplicado a Apache el parche de extensiones de FrontPage, y de pronto PHP dejó de funcionar. ¿Acaso PHP es incompatible con las extensiones de FrontPage para Apache?
  6. Unix/Windows: He inslatado PHP, pero cuando intento acceder a ficheros de script de PHP a través de mi navegador obtengo la pantalla en blanco.
  7. Unix/Windows: He instalado PHP, pero cuando intento acceder a un fichero de script de PHP a través de mi navegador, obtengo un error 500 del servidor.
  8. Algunos sistemas operativos: He instalado PHP sin errores, pero cuando intento iniciar Apache, obtengo errores de Símbolos no definidos: [mybox:user /src/php5] root# apachectl configtest apachectl: /usr/local/apache/bin/httpd Undefined symbols: _compress _uncompress
  9. Windows: He instalado PHP, pero cuando intento acceder a un fichero de script de PHP a través de mi navegador, obtengo el error: cgi error: The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
  10. Windows: He seguido todas las instrucciones, pero todavía no puedo hacer que PHP e IIS funcionen juntos.
  11. Cuando ejecuto PHP como CGI con IIS, PWS, OmniHTTPD o Xitami, obtengo el siguiente error: Security Alert! PHP CGI cannot be accessed directly..
  12. ¿Cómo sé si mi php.ini se ha encontrado y se está leyendo? Parece como si no lo fuera, ya que los cambios que realizo no se implementan.
  13. ¿Cómo agrego mi directorio de PHP a PATH en Windows?
  14. ¿Cómo hago que el fichero php.ini esté disponible para PHP en Windows?
  15. ¿Es posible usar la negociación de contenidos de Apache (opción MultiViews) con PHP?
  16. ¿PHP se limita a procesar únicamente métodos de peticiones GET y POST?
¿Por qué no debe utilizarse Apache2 con un MPM con hilos en un entorno de producción?

PHP es el «pegamento» utilizado para desarrollar buenas aplicaciones web uniendo docenas de bibliotecas de terceros y haciéndolas que parezcan una entidad coherente a través de una interfaz de lenguaje intuitiva y fácil de aprender. La flexibilidad y la potencia de PHP residen en la estabilidad y robustez de la plataforma subyacente. Requiere la combinación de un SO, de un servidor web y de bibliotecas de terceros, todos correctamente funcionando. Cuando cualquiera de ellos deja de funcionar, PHP necesita identificar los problemas y corregirlos rápidamente. Cuando el marco de trabajo subyacente se hace más complejo al no tener hilos de ejecución completamente independientes, segementos de memoria completamente independientes y un fuerte entorno de pruebas por cada petición a cubrir, se introducirán más debilidades en el sistema de PHP.

Si desea utilizar un MPM con hilos, considere una configuración de FastCGI donde PHP se ejecute en su propio espacio de memoria.

Unix/Windows: ¿Donde debería ubicarse mi fichero php.ini?

Por defecto, en Unix debería estar en /usr/local/lib, lo que es <install-path>/lib. Para cambiar esta ruta durante la compilación se ha de usar la bandera --with-config-file-path. Se debería establecer a algo como por ejemplo:

--with-config-file-path=/etc
Luego se debería copiar el fichero php.ini-development de la distribución a /etc/php.ini y editarlo para realizar cualquier cambio necesario.

--with-config-file-scan-dir=PATH

En Windows, la ruta predeterminada para el fichero php.ini es el directorio Windows. Si se utiliza el servidor web Apache, php.ini se busca primero en el directorio de instalación de Apache, p. ej. en C:\Archivos de programa\Apache Group\Apache. De esta forma se pueden tener distintos ficheros php.ini para diferentes versiones de Apache en la misma máquina.

Véase también el capítulo sobre el fichero de configuración.

Unix: He instalado PHP, pero con cada documento que cargo, obtengo el mensaje 'Document Contains No Data'. ¿Qué está pasando?

Esto probablemente signifique que PHP esté teniendo algún tipo de problema y esté realizando un volcado de memoria. Revise el registro de errores del servidor para ver si este es el caso, y después intente reproducir el problema con una pequeña prueba. Si sabe cómo usar 'gdb', le será de gran ayuda al poder proporcionar la traza de la pila con el informe de errores para que los desarrolladores puedan precisar el origen del problema. Si está utilizando PHP como un módulo de Apache, intente algo así:

  • Detener los procesos httpd

  • gdb httpd

  • Detener los procesos httpd

  • > run -X -f /ruta/al/httpd.conf

  • Luego obtenga el URL que causa el problema con su explorador

  • > run -X -f /ruta/al/httpd.conf

  • Si resulta en un volcado de memoria, gdb debería informárselo al instante

  • escriba: bt

  • Debería incluir la traza en su informe de errores, el cual debe ser enviado a » https://bugs.php.net/

Si su script utiliza las funciones de expresiones regulares (preg_match() y similares), debería asegurarse de que PHP y Apache se compilaron con los mismos paquetes de expresiones regulares. Esto debería ocurrir automáticamente con PHP y Apache 1.3.x

Unix: He instalado PHP usando paquetes RPM, pero Apache no procesa los las páginas de PHP. ¿Qué está pasando?

Asumiendo que instaló tanto Apache como PHP desde paquetes RPM, necesita descomentar o agregar algunas o todas de las siguientes líneas en su fichero httpd.conf:

# Extra Modules
AddModule mod_php.c
AddModule mod_perl.c

# Extra Modules
LoadModule php_module         modules/mod_php.so
LoadModule php5_module        modules/libphp5.so
LoadModule perl_module        modules/libperl.so
Y agregar:
AddType application/x-httpd-php .php
a las propiedades globales, o a las propiedades del VirtualDomain que desee que tenga añadido el soporte para PHP.

Unix: Le he aplicado a Apache el parche de extensiones de FrontPage, y de pronto PHP dejó de funcionar. ¿Acaso PHP es incompatible con las extensiones de FrontPage para Apache?

No, PHP funciona bien con las extensiones de FrontPage. El problema radica en que dicho parche modifica varias estructuras de Apache de las que depende PHP. La recompilación de PHP (con 'make clean ; make') tras la aplicación del parche debería resolver el problema.

Unix/Windows: He inslatado PHP, pero cuando intento acceder a ficheros de script de PHP a través de mi navegador obtengo la pantalla en blanco.

Ejecute 'ver código fuente' en el navegador web y probablemente encontrará que puede ver el código fuente de su script de PHP. Esto significa que el servidor web no envió el script a PHP para interpretarlo. Algo está mal en la configuración del servidor: vuelva a comprobarla con respecto a las instrucciones de instalación de PHP.

Unix/Windows: He instalado PHP, pero cuando intento acceder a un fichero de script de PHP a través de mi navegador, obtengo un error 500 del servidor.

Algo falló cuando el servidor intentó ejecutar PHP. Para obtener un mensaje de error detallado desde la línea de comandos, vaya al directorio que tiene el ejecutable de PHP (php.exe en Windows) y ejecute php -i. Si PHP tiene problemas al ejecutarse, el correspondiente error será mostrado en pantalla proporcionando una pista sobre lo que debe hacer a continuación. Si obtiene una pantalla completa de código HTML (la salida de la función phpinfo()) es porque PHP está funcionando, y su problema puede estar relacionado con la configuración del servidor, la cual debería de volver a revisar.

Algunos sistemas operativos: He instalado PHP sin errores, pero cuando intento iniciar Apache, obtengo errores de Símbolos no definidos:
[mybox:user /src/php5] root# apachectl configtest
      apachectl: /usr/local/apache/bin/httpd Undefined symbols:
      _compress
      _uncompress

Esto, en realidad, no tiene nada que ver con PHP, sino con las bibliotecas cliente de MySQL. Algunas necesitan --with-zlib, otras no. Esto también se trata en las Preguntas frecuentes de MySQL.

Windows: He instalado PHP, pero cuando intento acceder a un fichero de script de PHP a través de mi navegador, obtengo el error:
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:

Este mensaje de error significa que PHP no pudo imprimir nada. Para obtener un mensaje de error detallado desde la línea de comandos, vaya al directorio que contiene el ejecutable de PHP (php.exe en Windows) y ejecute php -i. Si PHP tiene problemas al ejecutarse, el correspondiente error será mostrado en pantalla proporcionando una pista sobre lo que debe hacer a continuación. Si obtiene una pantalla completa de código HTML (la salida de la función phpinfo()) es porque PHP está funcionando.

Una vez que PHP esté funcionando desde la línea de comandos, intente acceder nuevamente al script a través de su navegador. Si continúa fallando, podría ser por una de las siguientes razones:

  • Los permisos de fichero en el script de PHP, php.exe, php5ts.dll, php.ini o cualquier extensión de PHP que esté intentando cargar, son tales que el usuario de internet anónimo ISUR_<machinename> no puede acceder a ellos.
  • El fichero de script no existe (o quizá no se ubique en donde usted cree que está en relación a su directorio raíz web). Observe que para IIS se puede manejar este error señalando la casilla 'comprobar si el fichero existe' al configurar la correspondencia de scripts en el Administrador de Servicios de Internet. Si un fichero de script no existe, el servidor devolverá un error HTTP 404 en su lugar. IIS también brinda el beneficio adicional de encargarse de cualquier autenticación requerida de forma automática basándose en lospermisos NTLanMan de su fichero de script.
Windows: He seguido todas las instrucciones, pero todavía no puedo hacer que PHP e IIS funcionen juntos.

Asegúrese de que todo usuario que necesite ejecutar un script de PHP tenga los permisos para ejecutar php.exe. IIS utiliza un usuario anónimo que se añade en el momento de su instalación. Este usuario necesita permisos para php.exe. Además, cualquier usuario autenticado necesitará permisos para poder ejecutar php.exe. Asimismo, es necesario indicarle a IIS4 que PHP es un motor de script. Le podría interesar leer también estas preguntas frecuentes.

Cuando ejecuto PHP como CGI con IIS, PWS, OmniHTTPD o Xitami, obtengo el siguiente error: Security Alert! PHP CGI cannot be accessed directly..

La directiva cgi.force_redirect debe establecerse a 0. Por defecto es 1, por lo que debe asegurarse de que no esté comentada (con un ;). Como todas las directivas, se configura en php.ini

Debido a que su valor predeterminado es 1, es crítico asegurarse al 100% de estar leyendo el fichero php.ini correcto. Lea estas preguntas frecuentes para más detalles.

¿Cómo sé si mi php.ini se ha encontrado y se está leyendo? Parece como si no lo fuera, ya que los cambios que realizo no se implementan.

Para asegurarse de que PHP está leyendo su php.ini, realice una llamada a phpinfo(). Cerca de la parte superior, habrá una lista llamada Configuration File (php.ini). Allí figurará dónde está buscando PHP el php.ini y si está siendo leído o no. Si existe solo un directorio en PATH, entonces PHP no está leyéndolo, por lo que debería colocar su php.ini en tal directorio. Si php.ini está incluido dentro de PATH, es que se está leyendo.

Si php.ini está siendo leído y PHP se está ejecutando como un módulo, deberá reiniciar su servidor web tras aplicar los cambios a php.ini

Véase también php_ini_loaded_file().

¿Cómo agrego mi directorio de PHP a PATH en Windows?

En Windows 7, XP, Vista, 2008, 2012 y siguientes:

  • Vaya a Panel de Control y abra el icono Sistema (Inicio ? Panel de control)

  • Vaya a la pestaña Avanzado

  • Haga clic en el botón 'Variables de Entorno'

  • Revise la parte de 'Variables de Sistema'

  • Encuentre la entrada Path (seguramente tendrá que desplazarse para encontrarla)

  • Haga doble clic en la entrada Path

  • Ingrese su directorio de PHP al final de todo, con un ';' antes (p.ej., ;C:\php)

  • Presione OK

En Windows 98/Me necesita editar el fichero autoexec.bat:

  • Abra el Bloc de Notas (Inicio ? Ejecutar y escriba notepad)

  • Abra el fichero C:\autoexec.bat

  • Localice la línea con PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;..... y agregue: ;C:\php al final de la misma

  • Guarde el fichero y reinicie la máquina

Nota: Asegúrese de reiniciar tras seguir los pasos anteriores para garantizar que se apliquen los cambios a PATH.

El manual de PHP solía promover el copiado de ficheros dentro del directorio de sistema de Windows. Esto es porque este directorio (C:\Windows, C:\WINNT, etc.) está por defecto en el PATH del sistema. La copia de ficheros dentro del directorio de sistema de Windows hace tiempo que ya no se utiliza ya que puede causar problemas.

¿Cómo hago que el fichero php.ini esté disponible para PHP en Windows?

Hay varias formas de hacerlo. Si está usando Apache, lea las instrucciones específicas de instalación (Apache 1, Apache 2), o de lo contrario, debe configurar la variable de entorno PHPRC:

En Windows:

  • Vaya a Panel de Control y abra el icono Sistema (Inicio ? Configuración ? Panel de Control ? Sistema, o directamente Inicio ? Panel de Control ? Sistema)

  • Vaya a la pestaña Avanzado

  • Haga clic en el botón 'Variables de Entorno'

  • Revise el panel de 'Variables de Sistema'

  • Haga clic en 'Nuevo' e ingrese 'PHPRC' como nombre de variable, y el directorio donde se encuentra php.ini como el valor de la variable (p.ej., C:\php)

  • Presione OK y reinicie la máquina

En Windows 98/Me necesita editar el fichero autoexec.bat:

  • Abra el Bloc de Notas (Inicio ? Ejecutar y escriba notepad)

  • Abra el fichero C:\autoexec.bat

  • Agregue una nueva línea al final del fichero: set PHPRC=C:\php (reemplace C:\php con el directorio donde se encuentre php.ini). Por favor, observe que la ruta no puede contener espacios. Por ejemplo, si instaló PHP en C:\Archivos de programa\PHP, debería ingresar C:\ARCHIV~1\PHP en su lugar.

  • Guarde el fichero y reinicie la máquina

¿Es posible usar la negociación de contenidos de Apache (opción MultiViews) con PHP?

Si los enlaces a ficheros de PHP incluyen la extensión, todo funciona perfectamente. Estas preguntas frecuentes son solo para aquellos casos en los que los enlaces a ficheros de PHP no incluyen la extensión y se desea utilizar la negociación de contenidos para elegir ficheros de PHP sin extensión desde un URL. En este caso, reemplace la línea AddType application/x-httpd-php .php con:

AddHandler php5-script php
AddType text/html php
Esta solución no funciona para Apache 1 ya que el módulo de PHP no capta php-script.

¿PHP se limita a procesar únicamente métodos de peticiones GET y POST?

No. Es posible manejar cualquier método de peticiones, por, ej., CONNECT. El estado de respuesta apropiado puede ser enviado con header(). Si solo se van a manejar los métodos GET y POST, esto se puede lograr con la siguiente configuración de Apache:

<LimitExcept GET POST>
Deny from all
</LimitExcept>


Problemas de Compilación

Esta sección reune la mayoría de errores que ocurren al momento de compilar.

  1. Tengo la última versión de PHP usando el servicio anónimo Git, pero no hay un script de configuración.
  2. Tengo problemas configurando PHP para que trabaje con Apache. Dice que no puede encontrar el httpd.h, pero esta justo donde digo que esta!
  3. Mientras se configura PHP (./configure), se devuelve un error similar al siguiente: checking lex output file root... ./configure: lex: command not found configure: error: cannot find output from lex; giving up
  4. Cuando intento iniciar Apache, obtengo el siguiente mensaje: fatal: relocation error: file /path/to/libphp4.so: symbol ap_block_alarms: referenced symbol not found
  5. Cuando ejecuto la configuración, dice que no puede encontrar los archivos o librerías para GD, gdbm, o algún otro paquete!
  6. Cuando se esta compilando el archivo language-parser.tab.c, da errores así yytname undeclared.
  7. Cuando ejecuto make, parece que se ejecuta bien, pero luego falla cuando intenta enlazar la aplicación final quejandose de que faltan algunos archivos.
  8. Cuando se enlaza PHP, se queja del número de referencias indefenidas.
  9. No puedo encontrar la manera de compilar PHP con Apache 1.3.
  10. He seguido todos los pasos para instalar la versión del módulo de Apache en Unix, y cuando mis scripts de PHP aparecen se me pregunta por guardar el archivo.
  11. Dice que use: --activate-module=src/modules/php4/libphp4.a, pero ese archivo no existe, asi que lo cambie a --activate-module=src/modules/php4/libmodphp4.a y no funciona!? que esta pasando?
  12. Cuando intento compilar Apache con PHP como un módulo estatico usando --activate-module=src/modules/php4/libphp4.a me dice que mi compilador no es compatible con ANSI.
  13. Cuando intento compilar PHP usando --with-apxs obtengo mensajes de error extraños.
  14. Durante el make, obtengo errores sobre microtime, y muchas cosas de RUSAGE_.
  15. Cuando compilo PHP con MySQL, la configuración se ejecuta bien, pero durante el make obtengo un error similar al siguiente: ext/mysql/libmysqlclient/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysqlclient/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp', ¿Qué esta mal?
  16. Si deseo actualizar mi PHP. ¿Donde puedo encontrar la línea ./configure que fue usada para compilar mi instalación actual de PHP?
  17. Cuando compilo PHP con la librería GD, también da errores raros de compilación o segfaults en la ejecución.
  18. Cuando compilo PHP parece que recibo errores al azar, como si se colgara. Estoy usando Solaris si eso importa.
Tengo la última versión de PHP usando el servicio anónimo Git, pero no hay un script de configuración.

Se tiene que tener el paquete autoconf de GNU instalado y así se podrá generar el script de configuración desde configure.in. Solo se ejecuta ./buildconf en el directorio de nivel superior después de obtener los fuentes desde el servidor Git. (También, a menos que se ejecute configure con la opción --enable-maintainer-mode, el script de configuración no se recompilará automaticamente cuando el archivo configure.in es actualizado, así que debe de asegurarse que se hace manualmente cuando se note que configure.in haya cambiado. Un sintoma de esto es encontrar cosas como @VARIABLE@ en el archivo Makefile después de configurar o ejecutar config.status).

Tengo problemas configurando PHP para que trabaje con Apache. Dice que no puede encontrar el httpd.h, pero esta justo donde digo que esta!

Se necesita decirle al script configure/setup de apache la ubicación del nivel superior del árbol origen. Esto significa que se debe especificar --with-apache=/path/to/apache y no --with-apache=/path/to/apache/src.

Mientras se configura PHP (./configure), se devuelve un error similar al siguiente:

checking lex output file root... ./configure: lex: command not found
configure: error: cannot find output from lex; giving up

Se debe asegurar de leer cuidadosamente las instrucciones installation y notar que se necesita flex y bison instalados para compilar PHP. Dependiendo de la configuración, se necesitará instalar bison y flex desde el paquete de origen, como un RPM

Cuando intento iniciar Apache, obtengo el siguiente mensaje:

fatal: relocation error: file /path/to/libphp4.so:
symbol ap_block_alarms: referenced symbol not found

Este error usualmente se da cuando un programa del núcleo de Apache se compila como una librería DS0 para uso compartido. Se debe reconfigurar apache, asegurándose de usar al menos una de los siguientes flags:

--enable-shared=max --enable-rule=SHARED_CORE

Para mas información, leer el archivo de nivel superior de Apache INSTALL o las páginas del manual de Apache » DSO manual.

Cuando ejecuto la configuración, dice que no puede encontrar los archivos o librerías para GD, gdbm, o algún otro paquete!

Se puede configurar el script para que busque los archivos de encabezados y librerías en ubicaciones no estándar para especificar flags adicionales para ser pasados al preprocesador y compilador C, como:

    CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
Si se esta usando una variante de csh como login shell (por qué?), debería de ser:
    env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure

Cuando se esta compilando el archivo language-parser.tab.c, da errores así yytname undeclared.

Se debe actualizar la versión de Bison. Se puede encontrar la ultima versión en » http://www.gnu.org/software/bison/bison.html.

Cuando ejecuto make, parece que se ejecuta bien, pero luego falla cuando intenta enlazar la aplicación final quejandose de que faltan algunos archivos.

Algunas versiones antiguas de make no colocan correctamente las versiones compiladas de archivos y funciones de directorio en el mismo directorio. Se debe intentar ejecutar las funciones cp *.o y entonces re-ejecutar make para ver si eso ayuda. Si no lo hace, realmente se debería actualizar a la versión más reciente de GNU Make.

Cuando se enlaza PHP, se queja del número de referencias indefenidas.

Hay que mirar la linea del enlace y asegurarse de que todas las librerías apropiadas han sido incluidas al final. Las mas comunes que podrían estar perdidas son las '-ldl' y librerías requeridas como soporte por cualquier base de datos que se haya incluido.

Algunas personas han reportado que han tenido que adicionar '-ldl' inmediatamente seguido por libphp4.a cuando enlazan con Apache.

No puedo encontrar la manera de compilar PHP con Apache 1.3.

Esto es muy fácil actualmente. Siga cuidadosamente estos pasos:

  • Obtener la ultima distribución de Apache 1.3 desde » http://httpd.apache.org/download.cgi.
  • Descomprimir el archivo en alguna parte, por ejemplo /usr/local/src/apache-1.3.
  • Compilar PHP para la primera ejecución ./configure --with-apache=/<path>/apache-1.3 (sustituir <path> por la ruta actual del directorio de apache-1.3).
  • Escribir make seguido por make install para compilar PHP y copiar los archivos necesarios al árbol de la distribución de Apache.
  • Cambiar los directorios en el directorio /<path>/apache-1.3/src y editar el archivo de Configuration. Adicionar al archivo: AddModule modules/php4/libphp4.a.
  • Escribir: ./configure seguido por make.
  • Se debería tener ahora un httpd binario con PHP habilitado!

Nota:Se puede usar también el nuevo script ./configure. Ver las instrucciones en el archivo README.configure el cual es parte de la distribución de Apache. También se puede hechar una mirada al archivo INSTALL en la distribución de PHP.

He seguido todos los pasos para instalar la versión del módulo de Apache en Unix, y cuando mis scripts de PHP aparecen se me pregunta por guardar el archivo.

Esto significa que el módulo de PHP no esta siendo invocado por alguna razón. Hay tres cosas que chequear antes de pedir ayuda:

  • Asegurarse que el binario del httpd que se esta ejecutando es el nuevo binario httpd que se acaba de hacer. Para ver esto, se debe intentar ejecutar: /path/to/binary/httpd -l Si no se ve mod_php4.c listado, entonces no se esta ejecutando el binario correcto. Hay que encontrarlo e instalar el binario correcto.
  • Asegurarse de que es agregado el Mime Type correcto en uno de los archivos de Apache .conf. Debería de ser: AddType application/x-httpd-php .php También asegurarse que esta línea AddType no esta oculta dentro de un bloque de <Virtualhost> o uno de <Directory> el cual podría evitar que se aplique en el lugar donde se prueba el script.
  • Por último, el lugar por defecto de los archivos de configuración de Apache cambio entre Apache 1.2 y Apache 1.3. Se debería chequear que el archivo de configuración al cual se le agrega la línea AddType esta siendo leído actualmente. Se puede poner un error de sintaxis obvio dentro del archivo httpd.conf o algún otro cambio que pueda decir si el archivo esta siendo leído de forma correcta.

Dice que use: --activate-module=src/modules/php4/libphp4.a, pero ese archivo no existe, asi que lo cambie a --activate-module=src/modules/php4/libmodphp4.a y no funciona!? que esta pasando?

Hay que tener en cuenta que el archivo libphp4.a no se supone que exista. El proceso de apache sera creado!.

Cuando intento compilar Apache con PHP como un módulo estatico usando --activate-module=src/modules/php4/libphp4.a me dice que mi compilador no es compatible con ANSI.

Este es un mensaje de error equivocado de Apache que ha sido corregido en las versiones mas recientes.

Cuando intento compilar PHP usando --with-apxs obtengo mensajes de error extraños.

Hay 3 cosas que chequear aqui. Primero, por alguna razón cuando Apache compila el script de Perl apxs, algunas veces termina compilandose sin el compilador apropiado y sin los flags correspondientes. Hay que encontrar el script apxs (intentar con el comando which apxs), algunas veces se encuentra en /usr/local/apache/bin/apxs o /usr/sbin/apxs. Abrirlo y revisar las líneas similares a estas:

my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl
Si esto es lo que se ve, se ha encontrado el problema. Podrían contener espacios u otros valores incorrectos, como 'q()'. Hay que cambiar esas linas para que digan:
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';                   # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);              # substituted via Makefile.tmpl
El segundo problema posible podría ser un caso único en Red Hat 6.1 y 6.2. El script apxs de Red Hat esta malo. Hay que ver esta línea:
my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install
Si se ve como la línea anterior, hay que cambiarla por:
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install
Por último, si se reconfigura/reinstala Apache, hay que agregar un make clean al proceso después de ./configure y antes de make.

Durante el make, obtengo errores sobre microtime, y muchas cosas de RUSAGE_.

Durante la parte de la instalación de make, si se encuentran problemas que se vean similares a esto:

microtime.c: In function `php_if_getrusage':
microtime.c:94: storage size of `usg' isn't known
microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
microtime.c:97: (Each undeclared identifier is reported only once
microtime.c:97: for each function it appears in.)
microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
make[3]: *** [microtime.lo] Error 1
make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/master/php-4.0.1/ext'
make: *** [all-recursive] Error 1

Significa que el sistema esta mal. Se necesita corregir los archivos /usr/include instalando el paquete glibc-devel que coincida con tu glibc. Esto no tiene nada que ver con PHP. Para comprobar esto, hay que hacer esta simple prueba:

$ cat >test.c <<X
#include <sys/resource.h>
X
$ gcc -E test.c >/dev/null
Si esto produce errores, se sabrá que los archivos incluidos están mal.

Cuando compilo PHP con MySQL, la configuración se ejecuta bien, pero durante el make obtengo un error similar al siguiente: ext/mysql/libmysqlclient/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysqlclient/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp', ¿Qué esta mal?

Primero, es importante darse cuenta que esto es un Warning y no un error fatal. Debido a que esto es la última salida vista durante el make, podría verse como un error fatal pero no lo es. Por supuesto, si se ha puesto el compilador a que pare en los Warnings, lo hará. También hay que tener en mente que el soporte por MySQL es habilitado por defecto.

Nota:

Como en PHP 4.3.2, se verá el siguiente texto después de que se complete la compilación (make):

Build complete.
(Es seguro hacer caso omiso de las advertencias sobre tempnam y tmpnam).

Si deseo actualizar mi PHP. ¿Donde puedo encontrar la línea ./configure que fue usada para compilar mi instalación actual de PHP?

Si se mira el archivo config.nice, en el árbol origen de la instalación actual de PHP o, si esto no esta disponible, simplemente se debe ejecutar un script con

<?php phpinfo(); ?>
Al inicio de la salida se mostrará la línea ./configure que fue usada para compilar la instalación de PHP.

Cuando compilo PHP con la librería GD, también da errores raros de compilación o segfaults en la ejecución.

Hay que asegurar que la librería GD y PHP estan enlazados contra las mismas librerías dependientes (ej: libpng).

Cuando compilo PHP parece que recibo errores al azar, como si se colgara. Estoy usando Solaris si eso importa.

Usando utilidades no-GNU mientras se compila PHP podría causar problemas. Hay que asegurarse de usar herramientas GNU para estar seguros que la compilación de PHP funcionará. Por ejemplo, en Solaris, usando el SunOS BSD-compatible o versiones de Solaris de sed no funcionará, pero usando las versiones GNU o Sun POSIX (xpg4) de sed hará que funcione. Enlaces: » GNU sed, » GNU flex, y » GNU bison.


Utilizar PHP

Esta sección reúne varios errores comunes a los que se puede enfrentar mientras se escriben scripts de PHP.

  1. No puedo recordar el orden de los parámetros de las funciones de PHP, ¿son aleatorios?
  2. Me gustaría escribir un script genérico en PHP que pueda manejar datos provenientes de cualquier formulario. ¿Cómo puedo saber qué variables del método POST están disponibles?
  3. Necesito convertir todas las comillas simples (') en barras invertidas seguidas de comillas simples (\'). ¿Cómo puedo hacer esto con expresiones regulares? También me gustaría convertir " en \" y \ en \\.
  4. Cuando hago lo siguiente, la salida se muestra en el orden equivocado: <?php function mi_función($argumento) { echo $argumento + 10; } $variable = 10; echo "mi_función($variable) = " . mi_función($variable); ?> ¿Qué está pasando?
  5. ¡Eh!, ¿qué les pasa a mis nuevas líneas? <pre> <?php echo "Esto debería ser la primer línea."; ?> <?php echo "Esto debería mostrarse después de la línea anterior."; ?> </pre>
  6. Recibo el mensaje 'Warning: Cannot send session cookie - headers already sent...' o 'Cannot add header information - headers already sent...'.
  7. Necesito acceder directamente a información de las cabeceras de una petición. ¿Cómo puedo hacerlo?
  8. Cuando intento usar la autenticación con IIS obtengo el mensaje 'No Input file specified'.
  9. Windows: No puedo acceder a ficheros compartidos en otra computadora usando IIS
  10. ¿Cómo se supone que mezclo XML y PHP? ¡A este no le gustan mis etiquetas <?xml!
  11. ¿Dónde puedo encontrar un listado completo de las variables disponibles de PHP?
  12. ¿Cómo puedo generar ficheros PDF sin usar bibliotecas no gratuitas o comerciales como PDFLib? Me gustaría algo que sea gratis y no requiera bibliotecas de PDF externas.
  13. Estoy intentando acceder a una de las variables estándar de CGI (como $DOCUMENT_ROOT o $HTTP_REFERER) en una función definida por el usuario, y parece que no puede encontrarla. ¿Qué está mal?
  14. Algunas directivas de PHP pueden también tomar una abreviatura de valores de bytes, en lugar de solo valores de bytes integer. ¿Cuáles son todas las opciones de abreviaturas de bytes disponibles?
  15. Windows: Mis conexiones caducan al utilizar localhost, mientras que "127.0.0.1" funciona.
No puedo recordar el orden de los parámetros de las funciones de PHP, ¿son aleatorios?

PHP es un pegamento que une cientos de bibliotecas externas y esto, a veces, lo complica. Por eso, una simple regla de oro es la siguiente:

Los parámetros de las funciones de Array están ordenados como "aguja, pajar", mientras que sucede lo contrario con las funciones de String, esto es, "pajar, aguja".

Me gustaría escribir un script genérico en PHP que pueda manejar datos provenientes de cualquier formulario. ¿Cómo puedo saber qué variables del método POST están disponibles?

PHP ofrece muchas variables predefinidas, como la variable superglobal $_POST. Se puede recorrer la variable $_POST, ya que es un array asociativo con todos los valores provenientes de POST. Por ejemplo, vamos a recorrerla simplemente con foreach, comprobar los valores vacíos, empty(), y mostrarlos todos.

<?php
$vacío = $post = array();
foreach ($_POST as $nombre_variable => $nombre_valor) {
    if (empty($nombre_valor)) {
        $vacío[$nombre_variable] = $nombre_valor;
    } else {
        $post[$nombre_variable] = $nombre_valor;
    }
}

print "<pre>";
if (empty($vacío)) {
    print "Ninguno de los valores de POST esta vacío, se envió:\n";
    var_dump($post);
} else {
    print "Tenemos " . count($vacío) . " valores vacíos\n";
    print "Registrados:\n"; var_dump($post);
    print "Vacíos:\n";  var_dump($vacío);
    exit;
}
?>

Necesito convertir todas las comillas simples (') en barras invertidas seguidas de comillas simples (\'). ¿Cómo puedo hacer esto con expresiones regulares? También me gustaría convertir " en \" y \ en \\.

Asumiendo que esto es para una base de datos, utilice el mecanismo de escape que viene con esta. Por ejemplo, emplee la función mysql_real_escape_string() con MYSQL y pg_escape_string() con PostgreSQL. Existen también las funciones genéricas addslashes() y stripslashes(), las cuales son más comunes en código PHP antiguo.

Nota: Sobre de la directiva: magic_quotes_gpc

La directiva de PHP magic_quotes_gpc tiene por defecto el valor on. Básicamente ejecuta addslashes() en los datos obtenidos por GET, POST, y COOKIE. Se puede usar stripslashes() para quitarlos.

Cuando hago lo siguiente, la salida se muestra en el orden equivocado:
<?php
function mi_función($argumento)
{
    echo $argumento + 10;
}
$variable = 10;
echo "mi_función($variable) = " . mi_función($variable);
?>
¿Qué está pasando?

Para poder usar los resultados de funciones en una expresión (como la concatenación con otras cadenas del ejemplo anterior), es necesario devolver el valor con return; no utilzar echo.

¡Eh!, ¿qué les pasa a mis nuevas líneas?
<pre>
<?php echo "Esto debería ser la primer línea."; ?>
<?php echo "Esto debería mostrarse después de la línea anterior."; ?>
</pre>

En PHP, la terminación de un bloque de código se realiza bien con "?>" o con "?>\n" (donde \n significa una nueva línea). Con el ejemplo anterior, las sentencias de 'echo' estarán en una línea debido a que PHP omite las nuevas líneas después del final de un bloque. Esto significa que es necesario agregar una nueva línea extra después de cada bloque de código PHP para poder imprimir una nueva línea.

¿Por qué PHP hace esto? Porque cuando se formatea HTML normal, esto hace la vida más fácil ya que normalmente no se desea esa nueva línea, pero se tendrían que crear líneas extremadamente largas o, de lo contrario, hacer el código fuente de la pagina ilegible para obtener tal efecto.

Recibo el mensaje 'Warning: Cannot send session cookie - headers already sent...' o 'Cannot add header information - headers already sent...'.

Las funciones header(), setcookie(), y las funciones de sesión necesitan agregar cabeceras al flujo de salida, pero las cabeceras solo pueden enviarse antes de cualquier otro contenido. No puede haber ninguna salida antes de usar esas funciones, salidas como HTML. La función headers_sent() comprobará si un script ya ha enviado las cabeceras. Véase también las funciones de control de salida.

Necesito acceder directamente a información de las cabeceras de una petición. ¿Cómo puedo hacerlo?

La función getallheaders() lo hará si se está ejecutando PHP como un módulo de Apache. El siguiente trozo de código mostrará todas las cabeceras de la petición:

<?php
$cabeceras = getallheaders();
foreach ($cabeceras as $nombre => $contenido) {
    echo "headers[$nombre] = $contenido<br />\n";
}
?>

Véae también
apache_lookup_uri(),
apache_response_headers(), y
fsockopen()

Cuando intento usar la autenticación con IIS obtengo el mensaje 'No Input file specified'.

El modelo de seguridad de IIS es el culpable en este caso. Es un problema común a todos los programas CGI que se ejecutan bajo IIS. Una solución es crear un fichero de HTML plano (no analizado por PHP) como la página de entrada en un directorio autenticado. Se debe utilizar entonces una etiqueta META para redirigir a la página de PHP, o tener un enlace a dicha página. PHP reconocerá así la autenticación correctamente. Con el módulo ISAPI, esto no es un problema. Esto no debería afectar a otros servidores web NT. Para más información, véase: » http://support.microsoft.com/kb/q160422/ y la sección del manual sobre Autenticación HTTP .

Windows: No puedo acceder a ficheros compartidos en otra computadora usando IIS

Ha de cambiar Ir a los Servicios de Información de Internet. Localice su fichero PHP y vaya a sus propiedades. Luego vaya a la pestaña Seguridad de Archivos, Editar -< Acceso anónimo y control de autenticación.

Se puede corregir el problema ya sea desmarcando Acceso anónimo y dejando Autenticación integrada de Windows marcado, o marcando Acceso anónimo y editando el usuario, que ya no tendría que tener derecho de acceso.

¿Cómo se supone que mezclo XML y PHP? ¡A este no le gustan mis etiquetas <?xml!

Con el fin de integrar directamente <?xml en código de PHP, se han de desactivar las etiquetas abreviadas estableciendo la directiva de PHP short_open_tags a 0. Esta directiva no se puede establecer con ini_set(). Independientemente de que short_open_tags esté activada o no, se puede hacer algo como: <?php echo '<?xml'; ?>. El valor predeterminado de esta directiva es On.

¿Dónde puedo encontrar un listado completo de las variables disponibles de PHP?

Lea la página del manual sobre variables predefinidas, que incluye un listado parcial de variables predefinidas disponibles para su script. Se pude ver un listado completo de las variables disponibles (y mucha mas información) llamando a la función phpinfo(). Asegúrese de leer la sección del manual sobre variables desde fuentes externas a PHP, la cual describe escenarios comunes para variables externas, como desde un formulario HTML, una cookie, y un URL.

Nota: register_globals: Observación importante

Desde PHP 4.2.0, el valor por defecto de la directiva register_globals es off. La comunidad de PHP desaconseja el uso de esta directiva y sugiere el uso de otras formas como superglobals.

¿Cómo puedo generar ficheros PDF sin usar bibliotecas no gratuitas o comerciales como PDFLib? Me gustaría algo que sea gratis y no requiera bibliotecas de PDF externas.

Hay algunas alternativas escritas en PHP como » FPDF y » TCPDF.

Estoy intentando acceder a una de las variables estándar de CGI (como $DOCUMENT_ROOT o $HTTP_REFERER) en una función definida por el usuario, y parece que no puede encontrarla. ¿Qué está mal?

Utilice $_SERVER['DOCUMENT_ROOT'] y $_SERVER['HTTP_REFERER'] en su lugar.

Algunas directivas de PHP pueden también tomar una abreviatura de valores de bytes, en lugar de solo valores de bytes integer. ¿Cuáles son todas las opciones de abreviaturas de bytes disponibles?

Las opciones disponibles son K (para Kilobytes), M (para Megabytes) y G (para Gigabytes; disponible desde PHP 5.1.0). Ninguna considera las mayúsculas/minúsculas. Cualquier otra cosa asume bytes. 1M es igual a un Megabyte o 1048576 bytes. 1K es igual a un Kilobyte o 1024 bytes. Estas notaciones abreviadas pueden utlizarse en php.ini y en la función ini_set(). Observe que el valor numérico se moldea a integer; por ejemplo, 0.5M es interpretado como 0.

Nota: kilobyte contra kibibyte

La notación de PHP describe que un kilobyte equivale a 1024 bytes, mientras que el estándar IEC considera que debe ser un kibibyte. Resumiendo: k y K = 1024 bytes.

Windows: Mis conexiones caducan al utilizar localhost, mientras que "127.0.0.1" funciona.

Antes de PHP 5.3.4, existía un error en el código de resolución de red dentro de PHP que ocasionaba que localhost fallase en todas las situaciones relacionadas con flujos si IPv6 estaba habilitado. Para solucionar este problema se puede usar tanto "127.0.0.1" como deshabilitar la resolución de IPv6 en el fichero hosts.


Hash de contraseñas seguro

Esta sección explica las razones que justifican el uso de funciones hash para proteger las contraseñas. También se explica cómo hacerlo de un modo efectivo.

  1. ¿Por qué debo usar hash en las contraseñas de los usuarios de mi aplicación?
  2. ¿Por qué las funciones hash más comunes como md5 y sha1 no son adecuadas para las contraseñas?
  3. ¿Qué hash debo aplicar a mis contraseñas, si las funciones hash más comunes no son adecuadas?
  4. ¿Qué es una sal (salt)?
  5. ¿Cómo almaceno mis sales?
¿Por qué debo usar hash en las contraseñas de los usuarios de mi aplicación?

El hash de contraseñas es una de las consideraciones de seguridad más elementales que se deben llevar a la práctica al diseñar una aplicación que acepte contraseñas de los usuarios. Sin hashing, cualquier contraseña que se almacene en la base de datos de la aplicación podrá ser robada si la base de datos se ve comprometida, con lo que inmediatamente no sólo estaría comprometida la aplicación, sino también las cuentas de otros servicios de nuestros usuarios, siempre y cuando no utilicen contraseñas distintas.

Si aplicamos un algoritmo hash a las contraseñas antes de almacenarlas en la base de datos, dificultamos al atacante el determinar la contraseña original, pese a que en un futuro podrá comparar el hash resultante con la contraseña original.

Sin embargo, es importante tener en cuenta que el hecho de aplicar hash a las contraseñas sólo protege de que se vean comprometidas las contraseñas almacenadas, pero no las protege necesariamente de ser interceptadas por un código malicioso inyectado en la propia aplicación.

¿Por qué las funciones hash más comunes como md5() y sha1() no son adecuadas para las contraseñas?

Los algoritmos hash como MD5, SHA1 o SHA256 están diseñados para ser muy rápidos y eficientes. Con las técnicas y equipos modernos, es algo trivial extraer por fuerza bruta la salida de estos algoritmos, para determinar los datos de entrada originales.

Dada la velocidad con que los ordenadores actuales pueden "invertir" estos algoritmos hash, muchos profesionales de la seguridad recomiendan encarecidamente no utilizarlas como funciones hash para contraseñas.

¿Qué hash debo aplicar a mis contraseñas, si las funciones hash más comunes no son adecuadas?

Al aplicar un algoritmo hash, los dos factores más importantes son el coste computacional y la sal. Cuanto más cueste aplicar un algoritmo hash, más costará analizar su salida por fuerza bruta.

PHP 5.5 proporciona una API de hash de contraseñas nativa que maneja cuidadosamente el empleo de hash y la verificación de contraseñas de una manera segura. También hay una » biblioteca de compatibilidad de PHP pura disponible para PHP 5.3.7 y posterior.

Otra opción es la función crypt(), la cual tiene soporte para varios algoritmos hash en PHP 5.3 y posterior. Al emplear esta función, se garantiza que el algoritmo que se seleccione esté disponible, debido a que PHP contiene implementaciones nativas de cada algoritomo soportado, en caso de que el sistema no tenga soporte para uno o más de estos algoritmos.

El algoritmo recomendado para el empleo de contraseñas con hash es Blowfish, que es también el predeterminado de la API de hash de contraseñas, que, aunque es significativamente más caro computacionalmente que MD5 o SHA1, sigue siendo escalable.

Observar que si se emplea crypt() para verificar una contraseña, será necesario tomar precauciones para evitar ataques de temporización utilizando una comparación de string de tiempo constantes. Ni los operadores == y === de PHP ni strcmp() llevan a cabo una comparación de string de tiempo constante. Debido a que password_verify() hará esto de forma automática, se recomienda el empleo de la API de hash de contraseñas nativa siempre que sea posible.

¿Qué es una sal (salt)?

Una sal criptográfica es un dato que se utiliza durante el proceso de hash para eliminar la posibilidad de que el resultado pueda buscarse a partir de una lista de pares precalculados de hash y sus entradas originales, conocidas como tablas rainbow.

Es decir, una sal es un pequeño dato añadido que hace que los hash sean significantemente más difíciles de crackear. Existe un gran número de servicios online que ofrecen grandes listas de códigos hash precalculados, junto con sus datos de entrada originales. El uso de una sal hace muy difícil o imposible encontrar el hash resultante en cualquiera de estas listas.

password_hash() creará una sal aleatoria si no se proporciona una, siendo esta generalmente la estrategia más sencilla y segura.

¿Cómo almaceno mis sales?

Al utilizar password_hash() o crypt(), el valor devuelto incluye la sal como parte del hash generado. Este valor debería almacenarse tal cual en la base de datos, ya que incluye información sobre la función hash que se empleó y así proporcionarla directamente a password_verify() o crypt() al verificar contraseñas.

El siguiente diagrama muestra el formato de un valor devuelto por crypt() o password_hash(). Como se puede observar, son autocontenidos, con toda la información del algoritmo y la sal requerida para futuras verificaciones de contraseñas.

Los componentes del valor devuelto por password_hash y crypt: en orden, el algoritmo elegido, las opciones del algoritmo, la sal utilizada, y la contraseña con hash.


PHP y HTML

PHP y HTML interactúan mucho: PHP puede generar HTML, y HTML puede pasar información a PHP. Antes de leer esta sección, es importante que aprenda cómo obtener variables desde fuentes externas. La página del manual sobre este tema incluye muchos ejemplos también.

  1. ¿Qué codificación/decodificación es necesaria al pasar un valor a través de un formulario/URL?
  2. Estoy intentando usar una etiqueta <input type="image">, pero las variables $foo.x y $foo.y no están disponibles. $_GET['foo.x'] tampoco existe. ¿Dónde están?
  3. ¿Cómo creo arrays en un <form> de HTML?
  4. ¿Cómo obtengo todos los resultados de una etiqueta de selección múltiple en HTML?
  5. ¿Cómo puedo pasar una variable de Javascript a PHP?
¿Qué codificación/decodificación es necesaria al pasar un valor a través de un formulario/URL?

Existen varios escenarios en los que la codificación es importante. Asumiendo que se tiene un valor $datos de tipo string, el cual contiene la cadena que desea pasar sin codificar, existen los escenarios relevantes:

  • Interpretación de HTML. Para especificar una cadena aleatoria, es necesario incluirla entre comillas dobles, y aplicar htmlspecialchars() sobre el valor completo.

  • URL: Un URL consta de varias partes. Si los datos han de ser interpretados como un elemento, es necesario codificarlo con urlencode().

Ejemplo #1 Un elemento oculto de un formulario HTML

<?php
    echo '<input type="hidden" value="' . htmlspecialchars($datos) . '" />'."\n";
?>

Nota: No es correcto aplicar urlencode() sobre $datos, ya que es responsabilidad de los navegadores codificar los datos. Todos los navegadores populares lo realizan correctamente. Observe que esto ocurrirá independientemente del método (es decir, GET o POST). Aunque solo se observará esto en el caso de una petición GET, ya que las peticiones POST normalmente están ocultas.

Ejemplo #2 Datos a editar por el usuario

<?php
    echo "<textarea name='misdatos'>\n";
    echo htmlspecialchars($datos)."\n";
    echo "</textarea>";
?>

Nota: Los datos son mostrados en el navegador como se esperaba, ya que el navegador interpretará los símbolos HTML escapados. Durante el envío, ya sea mediante GET o POST, los datos serán codificados por el navegador para su transferencia, y serán decodificados directamente por PHP. Por lo tanto, no será necesario realizar ninguna codificación/decodificación, todo es manejado automáticamente.

Ejemplo #3 En un URL

<?php
    echo '<a href="' . htmlspecialchars("/siguientepagina.php?etapa=23&datos=" .
        urlencode($datos)) . '">'."\n";
?>

Nota: De hecho, se está imitando una petición GET de HTML, por lo que no es necesario aplicar urlencode() manualmente a los datos.

Nota: Es necesario usar htmlspecialchars() sobre el URL completo, ya que el URL se da como un valor de un atributo HTML. En este caso, el navegador primero reemplazará los caracteres HTML especiales por los caracteres correctos del valor, y luego pasará el URL. PHP entenderá el URL correctamente, ya que ya se utilizó urlencode() sobre los datos. Se observará que el caracter & en el URL es reemplazado por &amp;. Aunque la mayoría de navegadores entenderán el carácter si se olvida esto, no siempre es posible que ocurra. Así que, incluso si un URL no es dinámico, es necesario usar htmlspecialchars() sobre el URL.

Estoy intentando usar una etiqueta <input type="image">, pero las variables $foo.x y $foo.y no están disponibles. $_GET['foo.x'] tampoco existe. ¿Dónde están?

Cuando se envía un formulario, es posible usar una imagen en lugar del botón de envío estándar con una etiqueta como esta:

<input type="image" src="imagen.gif" name="foo" />
Cuando un usuario pulsa sobre la imagen, el formulario al que pertenece será transmitido al servidor con dos variables adicionales: foo.x y foo.y.

Dado que foo.x y foo.y habrían representado nombres de variable inválidos en PHP, éstas son convertidas automáticamente a foo_x y foo_y. Es decir, los puntos son reemplazados con caracteres de subrayado. Por lo tanto, es posible acceder a estas variables como cualquier otra descrita en la sección sobre la recuperación de variables desde fuentes externas. Por ejemplo, $_GET['foo_x'].

Nota:

Los espacios en nombres de variables de petición son convertidos a caracteres de subrayado.

¿Cómo creo arrays en un <form> de HTML?

Para hacer que el resultado de <form> sea enviado como un array a un script de PHP, se deben nombrar los elementos <input>, <select> o <textarea> de esta forma:

<input name="MiArray[]" />
<input name="MiArray[]" />
<input name="MiArray[]" />
<input name="MiArray[]" />
Observe los corchetes después del nombre de la variable; ellos son los que la convierten en un array. Es posible agrupar los elementos en diferentes arrays asignando el mismo nombre a elementos diferentes:
<input name="MiArray[]" />
<input name="MiArray[]" />
<input name="MiOtroArray[]" />
<input name="MiOtroArray[]" />
Esto produce dos array, MiArray y MiOtroArray, que son enviados al script PHP. También es posible asignar claves específicas a los arrays:
<input name="OtroArray[]" />
<input name="OtroArray[]" />
<input name="OtroArray[email]" />
<input name="OtroArray[telefono]" />
El array OtroArray ahora tendrá las claves 0, 1, email y telefono.

Nota:

La especificación de claves de arrays es opcional en HTML. Si no se especifican las claves, el array será rellenado en el orden en que aparecen los elementos en el formulario. Nuestro primer ejemplo contendrá las claves 0, 1, 2 y 3.

Véase también Funciones de arrays y Variables desde fuentes externas.

¿Cómo obtengo todos los resultados de una etiqueta de selección múltiple en HTML?

La etiqueta de selección múltiple en una construcción HTML permite a los usuarios elegir varios elementos de una lista. Estos elementos son pasados entonces al gestor de la acción del formulario. El problema es que todos son pasados con el mismo nombre de control. Es decir,

<select name="var" multiple="yes">
Cada opción elegida llegará al gestor de la acción como:
      var=opcion1
      var=opcion2
      var=opcion3
Cada opción sobrescribirá el contenido de la variable $var anterior. La solución es usar la característica "array desde un elemento de formulario" de PHP. Debería usarse la siguiente forma:
<select name="var[]" multiple="yes">
Esto le indica a PHP que debe tratar $var como un array y que cada asignación de un valor a var[] añade un elemento al array. El primer elemento se convierte en $var[0], el siguiente en $var[1], etc. La función count() puede usarse para determinar cuántas opciones fueron seleccionadas, y la función sort() puede usarse para ordenar el array de opciones si fuera necesario.

Observe que si se está usando JavaScript, los caracteres [] en el nombre del elemento podrían causar problemas al intentar referirse al elemento por su nombre. Use el ID numérico del elemento del formulario en su lugar, o encierre el nombre de la variable entre comillas simples y úselo como índice del array de elementos, por ejemplo:

      variable = document.forms[0].elements['var[]'];

¿Cómo puedo pasar una variable de Javascript a PHP?

Ya que Javascript es una tecnología (usualmente) del lado del cliente, y PHP es (usualmente) una tecnología del lado del servidor, y dado que HTTP es un protocolo "sin estados", los dos lenguajes no pueden compartir variables directamente.

Sin embargo, es posible pasar variables entre los dos. Una forma de hacerlo es generar código Javascript con PHP, y hacer que el navegador se refresque a sí mismo, volviendo a pasar variables específicas al script de PHP. El ejemplo de abajo muestra precisamente cómo hacer esto; permite que el código de PHP capture el alto y el ancho de la pantalla, algo que normalmente sólo es posible en el lado del cliente.

Ejemplo #4 Generación de Javascript con PHP

<?php
if (isset($_GET['ancho']) AND isset($_GET['alto'])) {
  // imprimir las variables de geometría
  echo "El ancho de la pantalla es: ". $_GET['ancho'] ."<br />\n";
  echo "El alto de la pantalla es: ". $_GET['alto'] ."<br />\n";
} else {
  // pasar las variables de geometría
  // (preservar la cadena de consulta original
  //   -- las variables post deberán ser manejadas de otra forma)

  echo "<script language='javascript'>\n";
  echo "  location.href=\"${_SERVER['SCRIPT_NAME']}?${_SERVER['QUERY_STRING']}"
            . "&ancho=\" + screen.width + \"&alto=\" + screen.height;\n";
  echo "</script>\n";
  exit();
}
?>


PHP y COM

PHP puede ser usado para acceder a objetos COM y DCOM en plataformas Win32.

  1. He compilado un DLL para calcular algo. ¿Hay alguna forma de ejecutar ese DLL bajo PHP?
  2. ¿Qué quiere decir 'Unsupported variant type: xxxx (0xxxxx)'?
  3. ¿Es posible manipular objetos visuales en PHP?
  4. ¿Puedo almacenar un objeto COM en una sesión?
  5. ¿Cómo puedo atrapar errores de COM?
  6. ¿Puedo generar archivos DLL desde scripts PHP como puedo en Perl?
  7. ¿Qué quiere decir 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'?
  8. ¿Cómo puedo ejecutar un objeto COM desde un servidor remoto?
  9. Recibo 'DCOM is disabled in C:\ruta...\nombre_script.php on line 6', ¿qué puedo hacer?
  10. ¿Es posible leer/manipular un objeto ActiveX en una página con PHP?
  11. ¿Es posible obtener una instancia en ejecución de un componente?
  12. ¿Hay una forma de manejar un evento enviado desde un objeto COM?
  13. Estoy teniendo problemas al intentar invocar un método de un objeto COM el cual expone más de una interfaz. ¿Qué puedo hacer?
  14. Así que PHP funciona con COM, ¿qué hay de COM+?
  15. Si PHP puede manipular objetos COM, ¿podemos imaginar el uso de MTS para manejar recursos de componentes, en conjunto con PHP?
He compilado un DLL para calcular algo. ¿Hay alguna forma de ejecutar ese DLL bajo PHP?

Si se trata de un DLL simple no hay forma aun de ejecutarlo desde PHP. Si el archivo DLL contiene un servidor COM es posible que pueda acceder a él si implementa la interfaz IDispatch.

¿Qué quiere decir 'Unsupported variant type: xxxx (0xxxxx)'?

Existen docenas de tipos VARIANT y combinaciones de ellos. La mayoría de ellos son soportados pero algunos aun deben ser implementados. Las matrices no están completamente soportadas. Solo las matrices unidimensionales de índice pueden ser pasadas entre PHP y COM. Si encuentra otros tipos que no sean soportados, por favor repórtelos como un bug (si aun no han sido reportados) y ofrezca tanta información como tenga disponible.

¿Es posible manipular objetos visuales en PHP?

En general es posible, pero ya que PHP es usado frecuentemente como un lenguaje de scripting web, corre en el contexto de servidores web, por lo que objetos visuales nunca aparecerán en el escritorio de los servidores. Si usa PHP para una aplicación de scripting, p.ej. en conjunto con PHP-GTK, no hay limitaciones al acceder y manipular objetos visuales a través de COM.

¿Puedo almacenar un objeto COM en una sesión?

No, no puede. Las instancias COM son tratadas como recursos y por lo tanto sólo están disponibles en el contexto de un script único.

¿Cómo puedo atrapar errores de COM?

La extensión COM lanza excepciones com_exception, las cuales puede atrapar y luego inspeccionar el miembro code para determinar el siguiente paso.

¿Puedo generar archivos DLL desde scripts PHP como puedo en Perl?

No, desafortunadamente no existe una herramienta de ese tipo disponible para PHP.

¿Qué quiere decir 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'?

Este error puede tener varias razones:

  • el valor CLSID es incorrecto
  • el archivo DLL solicitado no existe
  • el componente solicitado no implementa la interfaz IDispatch

¿Cómo puedo ejecutar un objeto COM desde un servidor remoto?

Exactamente como ejecuta objetos locales. Tan solo debe pasar la IP de la máquina remota como segundo parámetro al constructor COM.

Asegúrese de que ha definido com.allow_dcom =true en su php.ini.

Recibo 'DCOM is disabled in C:\ruta...\nombre_script.php on line 6', ¿qué puedo hacer?

Edite su archivo php.ini y defina com.allow_dcom =true.

¿Es posible leer/manipular un objeto ActiveX en una página con PHP?

Esto no tiene nada que ver con PHP. Los objetos ActiveX son cargados en el lado del cliente si son solicitados por el documento HTML. No hay relación con el script PHP y por lo tanto no hay una interacción directa posible con el lado del servidor.

¿Es posible obtener una instancia en ejecución de un componente?

Esto es posible con la ayuda de monikers. Si desea obtener múltiples referencias a la misma instancia de word, puede crear esa instancia como se muestra:

<?php
$word = new COM("C:\docs\word.doc");
?>

Esto creará una nueva instancia si no hay una instancia en ejecución disponible, o devolverá un gestor a la instancia en ejecución, si existe.

¿Hay una forma de manejar un evento enviado desde un objeto COM?

Puede definir el receptor de un evento y asociarlo usando com_event_sink(). Es posible usar com_print_typeinfo() para que PHP genere un esqueleto para la clase receptora del evento.

Estoy teniendo problemas al intentar invocar un método de un objeto COM el cual expone más de una interfaz. ¿Qué puedo hacer?

La respuesta es tan simple como poco satisfactoria. No estamos seguros pero parece que no es posible hacer nada. Si alguien tiene información específica al respecto, por favor » infórmenos :)

Así que PHP funciona con COM, ¿qué hay de COM+?

COM+ extiende COM mediante un marco para administrar componentes a través de MTS y MSMQ pero no hay nada especial que PHP deba soportar para usar tales componentes.

Si PHP puede manipular objetos COM, ¿podemos imaginar el uso de MTS para manejar recursos de componentes, en conjunto con PHP?

PHP por sí mismo no maneja transacciones aun. Por lo tanto si un error ocurre no se inicia un proceso rollback. Si usa componentes que soporten transacciones tendrá que implementar la gestión de transacciones usted mismo.


Preguntas Varias

Puede que existan algunas preguntas que no podemos colocar en otras categorías. Este es el lugar en donde puede encontrarlas.

  1. ¿Cómo puedo manipular los manuales comprimidos mediante bz2 en Windows?
¿Cómo puedo manipular los manuales comprimidos mediante bz2 en Windows?

Si no cuenta con una herramienta de archivación que pueda manejar archivos bz2, » descargue la herramienta de línea de comandos de RedHat (por favor refiérase a la inforamción presentada más adelante).

Si no desea usar una herramienta de línea de comandos, puede probar herramientas gratuitas como » Stuffit Expander, » UltimateZip, » 7-Zip, o » Quick Zip. Si dispone de herramientas como » WinRAR o » Power Archiver, puede descomprimir fácilmente archivos bz2 con ellas. Si usa Total Commander (anteriormente Windows Commander), un módulo adicional para ese programa se encuentra disponible de forma gratuita desde el sitio de » Total Commander.

La herramienta bzip2 de línea de comandos por Redhat:

Los usuarios de Win2k Sp2 deben obtener la versión más reciente, 1.0.2, todos los demás usuarios de Windows deben obtener la versión 1.00. Después de la descarga, renombre el ejecutable a bzip2.exe. Para mayor conveniencia, colóquelo en un directorio que sea parte de sus rutas predeterminadas, p.ej. C:\Windows, en donde C representa la unidad en donde se encuentra su instalación de Windows.

Nota: lang representa su lenguaje, y x el formato deseado, p.ej: pdf. Para descomprimir el archivo php_manual_lang.x.bz2 siga las siguientes instrucciones:

  • abra una ventana con el intérprete de comandos
  • cambie de directorio hacia la carpeta en donde almacenó el archivo php_manual_lang.x.bz2 descargado
  • invoque bzip2 -d php_manual_lang.x.bz2, extrayendo de este modo php_manual_lang.x en la misma carpeta

En caso de que haya descargado el archivo php_manual_lang.tar.bz2 con varios archivos html en su interior, el procedimiento es el mismo. La única diferencia es que recibe un archivo php_manual_lang.tar. Se conoce que el formato tar es tratado por la mayoría de archivadores en Windows, como por ejemplo » WinZip.


Apéndices

  • Historia de PHP y Proyectos Relacionados
    • Historia de PHP
    • Historia de los proyectos relacionados con PHP
    • Libros sobre PHP
    • Publicaciones sobre PHP
  • Migración de PHP 7.4.x a PHP 8.0.x
    • Nuevas características
    • Cambios incompatibles hacia atrás
    • Características obsoletas
    • Other Changes
  • Migración de PHP 7.3.x a PHP 7.4.x
    • New Features
    • Nuevas clases e interfaces
    • Nuevas funciones
    • Nuevas constantes globales
    • Backward Incompatible Changes
    • Características obsoletas
    • Extensiones eliminadas
    • Other Changes
    • Windows Support
  • Migración de PHP 7.2.x a PHP 7.3.x
    • Nuevas características
    • Nuevas funciones
    • Nuevas constantes globales
    • Cambios incompatibles con el pasado
    • Características obsoletas
    • Other Changes
    • Soporte de Windows
  • Migración de PHP 7.1.x a PHP 7.2.x
    • New features
    • Nuevas funciones
    • Nuevas constantes globales
    • Cambios incompatibles hacia atrás
    • Características obsoletas en PHP 7.2.x
    • Otros cambios
  • Migración de PHP 7.0.x a PHP 7.1.x
    • Nuevas características
    • Nuevas funciones
    • Nuevas constantes globales
    • Cambios retroincompatibles
    • Características obsoletas en PHP 7.1.x
    • Changed functions
    • Otros cambios
    • Soporte para Windows
  • Migración de PHP 5.6.x a PHP 7.0.x
    • Cambios retroincompatibles
    • Nuevas características
    • Características obsoletas en PHP 7.0.x
    • Funciones cambiadas
    • Nuevas funciones
    • Nuevas clases e interfaces
    • Nuevas constantes globales
    • Cambios en los Módulos SAPI
    • Extensiones y SAPI eliminadas
    • Otros cambios
  • Migración de PHP 5.5.x a PHP 5.6.x
    • Cambios retroincompatibles
    • Características nuevas
    • Características obsoletas en PHP 5.6.x
    • Cambios en funciones
    • Nuevas funciones
    • Cambios de OpenSSL en PHP 5.6.x
    • Otros cambios en extensiones
    • Nuevas constantes globales
  • Depuración en PHP
    • Sobre la depuración en PHP
  • Opciones de configuración
    • Listado de opciones de configuración del núcleo
  • Directivas de php.ini
    • Listado de directivas de php.ini
    • Lista de secciones de php.ini
    • Descripción de las directivas del núcleo de php.ini
  • Categorización de Extensiones
    • Alfabética
    • Incorporación
    • Estado
  • Listado de funciones alias
  • Lista de palabras reservadas
    • Lista de palabras reservadas
    • Clases predefinidas
    • Constantes predefinidas
    • Listado de otras palabras reservadas
  • Lista de Tipos de Recurso
  • Lista de filtros disponibles
    • Filtros de String
    • Filtros de conversión
    • Filtros de compresión
    • Filtros de encriptación
  • Lista de Transportes de Sockets Soportados
    • Dominio de Internet: TCP, UDP, SSL, y TLS
    • Dominio Unix: Unix y UDG
  • Tablas de comparación de tipos de PHP
  • Lista de componentes léxicos del analizador
  • Guía de entorno de usuario para nombres
    • Global Namespace
    • Reglas
    • Tips
  • Acerca del manual
    • Formatos
    • Acerca de los comentarios de usuarios
    • Como interpretar la definición de una función (prototipo)
    • Versiones de PHP documentadas en este manual
    • Cómo encontrar más información sobre PHP
    • Cómo ayudar a mejorar la documentación
    • Cómo generamos los formatos
    • Traducciones
  • Creative Commons Attribution 3.0
  • Listado de índices
    • Listado de Funciones y Métodos
    • Listado de ejemplos
  • Registro de cambios


Historia de PHP y Proyectos Relacionados

Tabla de contenidos

  • Historia de PHP
  • Historia de los proyectos relacionados con PHP
  • Libros sobre PHP
  • Publicaciones sobre PHP

PHP ha recorrido un largo camino desde su nacimiento a mediados de los 90. Desde sus humildes comienzos hasta ser uno de los más importantes lenguajes de programación web, la evolución de PHP es un cuento de hadas para "geeks". Pero ojo, un crecimiento explosivo como tal no era una tarea fácil. Aquellos de ustedes que estén interesados en ver brevemente cómo PHP creció hasta convertirse en lo que es hoy, lean. Si le gustaría tocar una pieza de la historia de Internet, puede encontrar versiones antiguas de PHP en el » Museo de PHP.


Historia de PHP

PHP Tools, FI, Equipo de Construcción, y PHP/FI

PHP tal y como se conoce hoy en día es en realidad el sucesor de un producto llamado PHP/FI. Creado en 1994 por Rasmus Lerdorf, la primera encarnación de PHP era un conjunto simple de ficheros binarios Common Gateway Interface (CGI) escritos en el lenguaje de programación C. Originalmente utilizado para rastrear visitas de su currículum online, llamó al conjunto de scripts "Personal Home Page Tools", más frecuentemente referenciado como "PHP Tools". Con el paso del tiempo se quiso más funcionalidad, y Rasmus reescribió PHP Tools, produciendo una implementación más grande y rica. Este nuevo modelo fue capaz de interaccionar con bases de datos, y mucho más, proporcionando un entorno de trabajo sobre cuyos usuarios podían desarrollar aplicaciones web dinámicas sencillas tales como libros de visitas. En junio de 1995, Rasmus » publicó el código fuente de PHP Tools, lo que permitió a los desarrolladores usarlo como considerasen apropiado. Esto también permitió -y animó- a los usuarios a proporcionar soluciones a los errores del código, y generalmente a mejorarlo.

En septiembre de ese mismo año, Rasmus amplió PHP y -por un corto periodo de tiempo- abandonó el nombre de PHP. Ahora, refiriéndose a las herramientas como FI (abreviatura de "Forms Interpreter"), la nueva implementación incluía algunas de las funciones básicas de PHP tal y como la conocemos hoy. Tenía variables como las de Perl, interpretación automática de variables de formulario y sintaxis incrustada HTML. La sintaxis por sí misma era similar a la de Perl, aunque mucho más limitada, simple y algo inconsistente. De hecho, para embeber el código en un fichero HTML, los desarrolladores tenían que usar comentarios de HTML. Aunque este método no era completamente bien recibido, FI continuó gozando de expansión y aceptación como una herramienta CGI --- pero todavía no completamente como lenguaje. Sin embargo, esto comenzó a cambiar al mes siguiente; en octubre de 1995 Rasmus publicó una versión nueva del código. Recordando el nombre PHP, ahora era llamado (resumidamente) "Personal Home Page Construction Kit," y fue la primera versión que presumía de ser, en aquel momento, considerada como una interfaz de scripts avanzada. El lenguaje fue deliberadamente diseñado para asemejarse a C en estructura, haciéndolo una adopción sencilla para desarrolladores familiarizados con C, Perl, y lenguajes similares. Habiendo sido así bastante limitado a sistemas UNIX y compatibles con POSIX, el potencial para una implementación de Windows NT estaba siendo explorada.

El código fue completamente rehecho de nuevo, y en abril de 1996, combinando los nombres de versiones anteriores, Rasmus introdujo PHP/FI. Esta implementación de segunda generación comenzó realmente a desarrollar PHP desde un conjunto de herramientas dentro de un lenguaje de programación de derecho propio. Incluía soporte interno para DBM, mSQL, y bases de datos Postgres95, cookies, soporte para funciones definidas por el usuario, y mucho más. Ese mes de junio, PHP/FI brindó una versión 2.0. Sin embargo, un interesante hecho sobre esto, es que sólo había una única versión completa de PHP 2.0. Cuando finalmente pasó de la versión beta en noviembre de 1997, el motor de análisis subyacente ya estaba siendo reescrito por completo.

Aunque vivió una corta vida de desarrollo, continuó gozando de un crecimiento de popularidad en el aún joven mundo del desarrollo. En 1997 y 1998, PHP/FI tenía un culto de varios miles de usuarios en todo el mundo. Una encuesta de Netcraft en mayo de 1998 indicó que cerca de 60,000 dominios reportaron que tenían cabeceras que contenían "PHP", indicando en efecto que el servidor host lo tenía instalado. Este número se correspondía con aproximadamente el 1% de todos los dominios de Internet del momento. A pesar de estas impresionantes cifras, la maduración de PHP/FI estaba condenada por limitaciones; mientras habían varios contribuidores menores, aún era desarrollado principalmente por un individuo.

Ejemplo #1 Ejemplo de Código PHP/FI

<!--include /text/header.html-->

<!--getenv HTTP_USER_AGENT-->
<!--ifsubstr $exec_result Mozilla-->
  Hey, ¡está usando Netscape!<p>
<!--endif-->

<!--sql database select * from table where user='$username'-->
<!--ifless $numentries 1-->
  Lo siento, esta entrada no existe<p>
<!--endif exit-->
  Bienvenido <!--$user-->!<p>
  Le quedan <!--$index:0--> créditos en su cuenta.<p>

<!--include /text/footer.html-->

PHP 3

PHP 3.0 fue la primera versión que más se parecía al PHP que existe hoy. Encontrando todavía PHP/FI 2.0 ineficiente y falto de las características que necesitaban para impulsar una aplicación de comercio electrónico que estaban desarrollando para un proyecto de universidad, Andi Gutmans y Zeev Suraski, de Tel Aviv, Israel, comenzaron otra nueva versión del analizador subyacente en 1997. Proponiendo Rasmus online, discutieron varios aspectos de la implementación actual y su redesarrollo de PHP. En un esfuerzon para mejorar el motor y comenzar a construir sobre la base de usuario de PHP/FI existente, Andi, Rasmus y Zeev decidieron colaborar en el desarrollo de un nuevo e independiente lenguaje de programación. Este lenguaje completamente nuevo fue publicado bajo un nuevo nombre, que eliminó la implicación del uso limitado personal que el nombre PHP/FI tenía. Fue renombrado simplemente como 'PHP', con el significado de un acrónimo recursivo - PHP: Hypertext Preprocessor.

Una de las mejores características de PHP 3.0 era su gran extensibilidad. Además de proveer a los usuarios finales de una interfaz madura para múltiplies bases de datos, protocolos, y APIs, la sencillez de ampliar el lenguaje mismo atrajo a docenas de desarrolladores que presentaron variedad de módulos. Podría decirse que esta fue la clave para el tremendo éxito de PHP 3.0. Otras características clave introducidas en PHP 3.0 incluían el soporte para programación orientada a objetos y una sintaxis de lenguaje mucho más potente y consistente.

En junio de 1998, con muchos nuevos desarrolladores de todo el mundo unidos al esfuerzon, PHP 3.0 fue anunciado por el nuevo Equipo de Desarrollo de PHP como el sucesor oficial de PHP/FI 2.0. El desarrollo activo de PHP/FI 2.0, que estaba casi parado desde noviembre del año anterior, fue oficialmente finalizado. Después de aproximadamente nueve meses de pruebas públicas, cuando el anuncio de la versión oficial de PHP 3.0 vino, ya estaba instalado en más de 70,000 dominios de todo el mundo, y ya no estaba limitado a sistemas operativos compatibles con POSIX. Una relativamente pequeña parte de de los dominios que tenían instalado PHP estaban albergados en servidores que ejecutaban Windows 95, 98, y NT, y Macintosh. En este punto, PHP 3.0 estaba instalado en aproximadamente el 10% de los servidores web de Internet.

PHP 4

En el invierno de 1998, poco después del lanzamiento oficial de PHP 3.0, Andi Gutmans y Zeev Suraski comenzaron a trabajar en una nueva versión del núcleo de PHP. Los objetivos de diseño fueron mejorar la ejecución de aplicaciones complejas y mejorar la modularidad del código base de PHP. Estas aplicaciones se hicieron posibles por las nuevas características de PHP 3.0 y el apoyo de una gran variedad de bases de datos y APIs de terceros, pero PHP 3.0 no estaba diseñado para un mantenimiento tan complejo de aplicaciones eficientemente.

El nuevo motor, apodado 'Motor Zend' (proviene de sus nombres de pila, Zeev y Andi), alcanzó estos objetivos de diseño satisfactoriamente, y se introdujo por primera vez a mediados de 1999. PHP 4.0, basado en este motor, y asociado con un gran rango de nuevas características adicionales, fue oficialmente publicado en Mayo del 2000, casi dos años después que su predecesor. Además de la mejora de rendimiento de esta versión, PHP 4.0 incluía otras características clave como el soporte para la mayoría de los servidores Web, sesiones HTTP, buffers de salida, formas más seguras de controlar las entradas de usuario y muchas nuevas construcciones de lenguaje.

PHP 5

PHP 5 fué lanzado en Julio del 2004 después de un largo desarrollo y varios pre-releases. Está básicamente impulsado por su núcleo, Zend Engine 2.0 que contiene un nuevo modelo de objectos y docenas de nuevas opciones.

El equipo de desarrollo de PHP incluye docenas de desarrolladores, así como docenas de otras personas trabajando en proyectos relacionados y de soporte para PHP, como PEAR, PECL, y documentación, y una infraestructura en red subyacente de más de cien servidores web individuales en seis de los siete continentes del mundo. Aunque es solo una estimación basada en estadísticas de años ateriores, es seguro suponer que PHP ahora está instalado en diez o quizá cien millones de dominios en todo el mundo.


Historia de los proyectos relacionados con PHP

PEAR

» PEAR, la extensión de PHP y repositorio de aplicaciones (originalmente, extensión de PHP y repositorio add-on) es la base de clases para PHP y en un futuro seguramente será la forma de distribuir extensiones PHP entre desarrolladores.

PEAR nació de las discusiones mantenidas en el PHP Developers' Meeting (PDM) transcurrido en Enero de 2000 en Tel Aviv. Fue creado por Stig S. Bakken, y lo dedicó a su primogénita, Malin Bakken.

Hasta principios de 2000, PEAR fue creciendo hasta ser un gran y significativo proyecto con un gran número de programadores trabajando en la implementación común, funcionalidad reutilizable para el beneficio de toda la comunidad PHP. PEAR hoy incluye una gran variedad de clases de infraestructura para acceso a bases de datos, caché de contenido, cálculos matemáticos, comercio electrónico y mucho más.

Más información sobre PEAR se puede encontrar en » el manual.

Garantía de calidad de PHP

La » Iniciativa para la Garantía de Calidad de PHP se configuró en el verano de 2000 en respuesta a los que criticaban que las versiones de PHP se liberaban sin que fueran comprobadas suficientemente para entornos de producción. El equipo ahora consiste en un grupo central de desarrolladores con un buen entendimiento del código base de PHP. Estos desarrolladores están mucho tiempo localizando y solucionando problemas con PHP. Además, hay muchos miembros de otros equipos que testean y prueban estas soluciones usando una gran variedad de plataformas.

PHP-GTK

» PHP-GTK es la solución PHP para escribir las aplicaciones GUI del lado del cliente. Andrei Zmievski nos recuerda la planificación y la creación del proceso de PHP-GTK:

Programar GUI siempre ha estado entre mis intereses, y he encontrado que Gtk+ es una herramienta muy buena, salvo que programar con ella en C es algo tedioso. Tras presenciar las implementaciones de PyGtk y GTK-Perl, decidí ver si PHP se podría hacer con la interfaz Gtk+, incluso mínimamente. En Agosto de 2000 empecé a tener más tiempo libre, con lo que comencé a experimentar. Mi principal guía fue la implementación PyGtk con características completas bastante buenas y con un buen interfaz orientado a objetos. James Henstridge, el autor de PyGtk, proveyó mucha ayuda adicional durante esos estados iniciales.

Escribir las interfaces de todas las funciones Gtk+ estaba fuera de cuestión, por lo que mantuve la idea de generador de código, similar a cómo PyGtk lo hizo. El generador de código es un programa PHP que lee un conjunto de ficheros .defs que contienen las clases Gtk+, constantes e información de métodos y genera código C que interactúa PHP con ellos. Lo que no se puede generar automáticamente puede escribirse a mano en ficheros .overrides.

Trabajar en el generador de código y la infraestructura llevó algo de tiempo, porque pude dedicar poco tiempo a PHP-GTK durante el otoño de 2000. Después mostré PHP-GTK a Frank Kromann, que se interesó y empezó a ayudarme con el trabajo del generador de código y con la implementación para Win32. Cuando escribimos el primer programa Hola Mundo y funcionó, fue extremadamente excitante. Llevó un par de meses más llevar el proyecto a una condición presentable y la versión inicial se liberó el 1 de Marzo de 2001. La historia rápidamente llegó a SlashDot.

Dándome cuenta que PHP-GTK podría extenderse, configuré listas de correo separadas y repositorios CVS para ello, así como el sitio web gtk.php.net con la ayuda de Colin Viebrock. La documentación también tenía que hacerse y James Moore se únio al proyecto para ayudar en esto.

Desde su lanzamiento PHP-GTK fue ganando popularidad. Tenemos nuestro propio equipo de documentación, el manual sigue mejorando, la gente ha comenzado a escribir extensiones para PHP-GTK, y con ello más y mejores aplicaciones.


Libros sobre PHP

Según crecía PHP, empezó a ser reconocido como una popular plataforma de desarrollo web. Una de las más interesantes formas de ver esta tendencia fué observando los libros de PHP que han ido publicando a lo largo de los años.

Por lo que nosotros sabemos, el primer libro dedicado a PHP fue 'PHP - tvorba interaktivních internetových aplikací' (PHP - Creando aplicaciones interactivas en internet) - un libro checo publicado en 1999, cuyo autor fue Jirka Koseksiendo. Al mes siguiente le siguió un libro alemán cuyos autores fueron Egon Schmid, Christian Cartus y Richard Blume. El primer libro en Inglés sobre PHP se publicó poco después, y fue 'Core PHP Programming' de Leon Atkinson. Los dos libros cubrían PHP 3.0.

Mientras estos libros fueron los primeros de su tipo - fueron seguidos por un gran número de libros de una multitud de autores y editores. ¡Existen más 400 libros en inglés, 100 libros en alemán, y más de 50 libros en francés o español! Además, se pueden encontrar libros sobre PHP en la mayoría de las demás lenguas, incluyendo coreano, japonés y hebreo.

Evidentemente, este gran número de libros, escritos por diferentes autores, publicados por muchos editores, y su disponibilidad en tantas lenguas - son un fuerte testimonio del éxito mundial de PHP.


Publicaciones sobre PHP

Por lo que sabemos, el primer artículo sobre PHP en una revista impresa se publicó en la version checa de Computerworld en la primavera de 1998, y cubría PHP 3.0. Como con los libros, fue el primero en una serie de muchos artículos publicados sobre PHP en varias revistas importantes.

Artículos sobre PHP han aparecido en Dr. Dobbs, Linux Enterprise, Linux Magazine y muchas otras. Artículos sobre migración de aplicaciones basadas en PHP bajo Windows ¡han aparecido incluso en el MSDN de Microsoft!


Migración de PHP 7.4.x a PHP 8.0.x

Tabla de contenidos

  • Nuevas características
  • Cambios incompatibles hacia atrás
  • Características obsoletas
  • Other Changes

Esta nueva versión mayor trae consigo una serie de nuevas características y algunas incompatibilidades que debe ser probado antes de cambiar las versiones de PHP en los entornos de producción.

Véanse también las guías de migración para versiones de PHP 7.0.x, 7.1.x, 7.2.x, 7.3.x. 7.4.x.


Nuevas características

PHP Core

Argumentos nombrados

Se ha añadido soporte para losArgumentos nombrados.

Atributos

Se ha añadido soporte para los Atributos.

Constructor Property Promotion

Support for constructor property promotion (declaring properties in the constructor signature) has been added.

Union Types

Support for union types has been added.

Match Expression

Support for match expressions has been added.

Nullsafe Operator

Support for the nullsafe operator (?->) has been added.

Other new Features

  • The WeakMap class has been added.

  • The ValueError class has been added.

  • Any number of function parameters may now be replaced by a variadic argument, as long as the types are compatible. For example, the following code is now allowed:

    <?php
    class A {
         public function     method(int $many, string $parameters, $here) {}
    }
    class     B extends A {
         public function     method(...$everything) {}
    }
    ?>

  • static (as in "late static binding") can now be used as a return type:

    <?php
    class Test {
         public function     create(): static {
              return new static();
         }
    }
    ?>

  • It is now possible to fetch the class name of an object using $object::class. The result is the same as get_class($object).

  • new and instanceof can now be used with arbitrary expressions, using new (expression)(...$args) and $obj instanceof (expression).

  • Some consistency fixes to variable syntax have been applied, for example writing Foo::BAR::$baz is now allowed.

  • Added Stringable interface, which is automatically implemented if a class defines a __toString() method.

  • Traits can now define abstract private methods. Such methods must be implemented by the class using the trait.

  • throw can now be used as an expression. That allows usages like:

    <?php
    $fn     = fn() => throw new Exception('Exception in arrow function');
    $user = $session->user ?? throw new Exception('Must have user');

  • An optional trailing comma is now allowed in parameter lists.

    <?php
    function functionWithLongSignature(
            Type1 $parameter1,
            Type2 $parameter2, // <-- This comma is now allowed.
    ) {
    }

  • It is now possible to write catch (Exception) to catch an exception without storing it in a variable.

  • Support for mixed type has been added.

  • Private methods declared on a parent class no longer enforce any inheritance rules on the methods of a child class (with the exception of final private constructors). The following example illustrates which restrictions have been removed:

    <?php
    class ParentClass {
        private function     method1() {}
        private function     method2() {}
        private static function     method3() {}
            // Throws a warning, as "final" no longer has an effect:
            private final function method4() {}
    }
    class     ChildClass extends ParentClass {
            // All of the following are now allowed, even though the modifiers aren't
        // the same as for the private methods in the parent class.
            public abstract function method1() {}
        public static function     method2() {}
        public function     method3() {}
        public function     method4() {}
    }
    ?>

  • get_resource_id() has been added, which returns the same value as (int) $resource. It provides the same functionality under a clearer API.

Date and Time

  • DateTime::createFromInterface() and DateTimeImmutable::createFromInterface() have been added.

  • The DateTime format specifier p has been added, which is the same as P but returns Z rather than +00:00 for UTC.

DOM

DOMParentNode and DOMChildNode with new traversal and manipulation APIs have been added.

Filter

FILTER_VALIDATE_BOOL has been added as an alias for FILTER_VALIDATE_BOOLEAN. The new name is preferred, as it uses the canonical type name.

Enchant

enchant_dict_add(), enchant_dict_is_added(), and LIBENCHANT_VERSION have been added.

FPM

Added a new option pm.status_listen that allows getting the status from different endpoint (e.g. port or UDS file) which is useful for getting the status when all children are busy with serving long running requests.

Hash

HashContext objects can now be serialized.

Internationalization Functions

The IntlDateFormatter::RELATIVE_FULL,
IntlDateFormatter::RELATIVE_LONG,
IntlDateFormatter::RELATIVE_MEDIUM, and
IntlDateFormatter::RELATIVE_SHORT
constants have been added.

LDAP

ldap_count_references() has been added, which returns the number of reference messages in a search result.

OPcache

If the opcache.record_warnings ini setting is enabled, OPcache will record compile-time warnings and replay them on the next include, even if it is served from cache.

OpenSSL

Added Cryptographic Message Syntax (CMS) (» RFC 5652) support composed of functions for encryption, decryption, signing, verifying and reading. The API is similar to the API for PKCS #7 functions with an addition of new encoding constants: OPENSSL_ENCODING_DER, OPENSSL_ENCODING_SMIME and OPENSSL_ENCODING_PEM:

  • openssl_cms_encrypt() encrypts the message in the file with the certificates and outputs the result to the supplied file.
  • openssl_cms_decrypt() that decrypts the S/MIME message in the file and outputs the results to the supplied file.
  • openssl_cms_read() that exports the CMS file to an array of PEM certificates.
  • openssl_cms_sign() that signs the MIME message in the file with a cert and key and output the result to the supplied file.
  • openssl_cms_verify() that verifies that the data block is intact, the signer is who they say they are, and returns the certs of the signers.

Regular Expressions (Perl-Compatible)

preg_last_error_msg() has been added, which returns a human-readable message for the last PCRE error. It complements preg_last_error(), which returns an integer enum value instead.

Reflection

  • The following methods can now return information about default values of parameters of internal functions:

    • ReflectionParameter::isDefaultValueAvailable()
    • ReflectionParameter::getDefaultValue()
    • ReflectionParameter::isDefaultValueConstant()
    • ReflectionParameter::getDefaultValueConstantName()

SQLite3

SQLite3::setAuthorizer() and respective class constants have been added to set a userland callback that will be used to authorize or not an action on the database.

Standard Library

  • str_contains(), str_starts_with() and str_ends_with() have been added, which check whether haystack contains, starts with or ends with needle, respectively.

  • fdiv() has been added, which performs a floating-point division under IEEE 754 semantics. Division by zero is considered well-defined and will return one of Inf, -Inf or NaN.

  • get_debug_type() has been added, which returns a type useful for error messages. Unlike gettype(), it uses canonical type names, returns class names for objects, and indicates the resource type for resources.

  • printf() and friends now support the %h and %H format specifiers. These are the same as %g and %G, but always use "." as the decimal separator, rather than determining it through the LC_NUMERIC locale.

  • printf() and friends now support using "*" as width or precision, in which case the width/precision is passed as an argument to printf. This also allows using precision -1 with %g, %G, %h and %H. For example, the following code can be used to reproduce PHP's default floating point formatting:

    <?php
    printf    ("%.*H", (int) ini_get("precision"), $float);
    printf("%.*H", (int) ini_get("serialize_precision"), $float);
    ?>

  • proc_open() now supports pseudo-terminal (PTY) descriptors. The following attaches stdin, stdout and stderr to the same PTY:

    <?php
    $proc     = proc_open($command, [['pty'], ['pty'], ['pty']], $pipes);
    ?>

  • proc_open() now supports socket pair descriptors. The following attaches a distinct socket pair to stdin, stdout and stderr:

    <?php
    $proc     = proc_open($command, [['socket'], ['socket'], ['socket']], $pipes);
    ?>

    Unlike pipes, sockets do not suffer from blocking I/O issues on Windows. However, not all programs may work correctly with stdio sockets.

  • Sorting functions are now stable, which means that equal-comparing elements will retain their original order.

  • array_diff(), array_intersect() and their variations can now be used with a single array as argument. This means that usages like the following are now possible:

    <?php
    // OK even if $excludes is empty:
    array_diff($array, ...$excludes);
    // OK even if $arrays only contains a single array:
    array_intersect(...$arrays);
    ?>

  • The flag parameter of ob_implicit_flush() was changed to accept a bool rather than an int.

Tokenizer

PhpToken adds an object-based interface to the tokenizer. It provides a more uniform and ergonomic representation, while being more memory efficient and faster.

Zip

  • The Zip extension has been updated to version 1.19.1.

  • New ZipArchive::setMtimeName() and ZipArchive::setMtimeIndex() to set the modification time of an entry.

  • New ZipArchive::registerProgressCallback() to provide updates during archive close.

  • New ZipArchive::registerCancelCallback() to allow cancellation during archive close.

  • New ZipArchive::replaceFile() to replace an entry content.

  • New ZipArchive::isCompressionMethodSupported() to check optional compression features.

  • New ZipArchive::isEncryptionMethodSupported() to check optional encryption features.

  • The ZipArchive::lastId property to get the index value of the last added entry has been added.

  • Errors can now be checked after an archive has been closed using the
ZipArchive::status and
ZipArchive::statusSys properties, or the
ZipArchive::getStatusString() method.

  • The 'remove_path' option of ZipArchive::addGlob() and ZipArchive::addPattern() is now treated as an arbitrary string prefix (for consistency with the 'add_path' option), whereas formerly it was treated as a directory name.

  • Optional compression / encryption features are now listed in phpinfo.


Cambios incompatibles hacia atrás

PHP Core

String to Number Comparison

Non-strict comparisons between numbers and non-numeric strings now work by casting the number to string and comparing the strings. Comparisons between numbers and numeric strings continue to work as before. Notably, this means that 0 == "not-a-number" is considered false now.

Comparison | Before | After
0 == "0" | true | true
0 == "0.0" | true | true
0 == "foo" | true | false
0 == "" | true | false
42 == " 42" | true | true
42 == "42foo" | true | false

Other incompatible Changes

  • match is now a reserved keyword.

  • Assertion failures now throw by default. If the old behavior is desired, assert.exception=0 can be set in the INI settings.

  • Methods with the same name as the class are no longer interpreted as constructors. The __construct() method should be used instead.

  • The ability to call non-static methods statically has been removed. Thus is_callable() will fail when checking for a non-static method with a classname (must check with an object instance).

  • The (real) and (unset) casts have been removed.

  • The track_errors ini directive has been removed. This means that php_errormsg is no longer available. The error_get_last() function may be used instead.

  • The ability to define case-insensitive constants has been removed. The third argument to define() may no longer be true.

  • The ability to specify an autoloader using an __autoload() function has been removed. spl_autoload_register() should be used instead.

  • The errcontext argument will no longer be passed to custom error handlers set with set_error_handler().

  • create_function() has been removed. Anonymous functions may be used instead.

  • each() has been removed. foreach or ArrayIterator should be used instead.

  • The ability to unbind this from closures that were created from a method, using Closure::fromCallable() or ReflectionMethod::getClosure(), has been removed.

  • The ability to unbind this from proper closures that contain uses of this has also been removed.

  • The ability to use array_key_exists() with objects has been removed. isset() or property_exists() may be used instead.

  • The behavior of array_key_exists() regarding the type of the key parameter has been made consistent with isset() and normal array access. All key types now use the usual coercions and array/object keys throw a TypeError.

  • Any array that has a number n as its first numeric key will use n+1 for its next implicit key, even if n is negative.

  • The default error_reporting level is now E_ALL. Previously it excluded E_NOTICE and E_DEPRECATED.

  • display_startup_errors is now enabled by default.

  • Using parent inside a class that has no parent will now result in a fatal compile-time error.

  • The @ operator will no longer silence fatal errors (E_ERROR, E_CORE_ERROR, E_COMPILE_ERROR, E_USER_ERROR, E_RECOVERABLE_ERROR, E_PARSE). Error handlers that expect error_reporting to be 0 when @ is used, should be adjusted to use a mask check instead:

    <?php
    // Replace
    function my_error_handler($err_no, $err_msg, $filename, $linenum) {
        if (    error_reporting() == 0) {
            return;     // Silenced
            }
            // ...
    }

    // With
    function my_error_handler($err_no, $err_msg, $filename, $linenum) {
        if (!(    error_reporting() & $err_no)) {
            return;     // Silenced
            }
            // ...
    }
    ?>

    Additionally, care should be taken that error messages are not displayed in production environments, which can result in information leaks. Please ensure that display_errors=Off is used in conjunction with error logging.

  • #[ is no longer interpreted as the start of a comment, as this syntax is now used for attributes.

  • Inheritance errors due to incompatible method signatures (LSP violations) will now always generate a fatal error. Previously a warning was generated in some cases.

  • The precedence of the concatenation operator has changed relative to bitshifts and addition as well as subtraction.

    <?php
    echo "Sum: " . $a + $b;
    // was previously interpreted as:
    echo ("Sum: " . $a) + $b;
    // is now interpreted as:
    echo "Sum:" . ($a + $b);
    ?>

  • Arguments with a default value that resolves to null at runtime will no longer implicitly mark the argument type as nullable. Either an explicit nullable type, or an explicit null default value has to be used instead.

    <?php
    // Replace
    function test(int $arg = CONST_RESOLVING_TO_NULL) {}
    // With
    function test(?int $arg = CONST_RESOLVING_TO_NULL) {}
    // Or
    function test(int $arg = null) {}
    ?>

  • A number of warnings have been converted into Error exceptions:

    • Attempting to write to a property of a non-object. Previously this implicitly created an stdClass object for null, false and empty strings.
    • Attempting to append an element to an array for which the PHP_INT_MAX key is already used.
    • Attempting to use an invalid type (array or object) as an array key or string offset.
    • Attempting to write to an array index of a scalar value.
    • Attempting to unpack a non-array/Traversable.
    • Attempting to access unqualified constants which are undefined. Previously, unqualified constant accesses resulted in a warning and were interpreted as strings.

    A number of notices have been converted into warnings:

    • Attempting to read an undefined variable.
    • Attempting to read an undefined property.
    • Attempting to read an undefined array key.
    • Attempting to read a property of a non-object.
    • Attempting to access an array index of a non-array.
    • Attempting to convert an array to string.
    • Attempting to use a resource as an array key.
    • Attempting to use null, a boolean, or a float as a string offset.
    • Attempting to read an out-of-bounds string offset.
    • Attempting to assign an empty string to a string offset.

  • Attempting to assign multiple bytes to a string offset will now emit a warning.

  • Unexpected characters in source files (such as NUL bytes outside of strings) will now result in a ParseError exception instead of a compile warning.

  • Uncaught exceptions now go through "clean shutdown", which means that destructors will be called after an uncaught exception.

  • The compile time fatal error "Only variables can be passed by reference" has been delayed until runtime, and converted into an "Argument cannot be passed by reference" Error exception.

  • Some "Only variables should be passed by reference" notices have been converted to "Argument cannot be passed by reference" exception.

  • The generated name for anonymous classes has changed. It will now include the name of the first parent or interface:

    <?php
    new class extends ParentClass {};
    // -> ParentClass@anonymous
    new class implements FirstInterface, SecondInterface {};
    // -> FirstInterface@anonymous
    new class {};
    // -> class@anonymous
    ?>

    The name shown above is still followed by a NUL byte and a unique suffix.

  • Non-absolute trait method references in trait alias adaptations are now required to be unambiguous:

    <?php
    class X {
        use     T1, T2 {
                func as otherFunc;
        }
        function     func() {}
    }
    ?>

    If both T1::func() and T2::func() exist, this code was previously silently accepted, and func was assumed to refer to T1::func. Now it will generate a fatal error instead, and either T1::func or T2::func needs to be written explicitly.

  • The signature of abstract methods defined in traits is now checked against the implementing class method:

    <?php
    trait MyTrait {
        abstract private function     neededByTrait(): string;
    }

    class     MyClass {
        use     MyTrait;

            // Error, because of return type mismatch.
            private function neededByTrait(): int { return 42; }
    }
    ?>

  • Disabled functions are now treated exactly like non-existent functions. Calling a disabled function will report it as unknown, and redefining a disabled function is now possible.

  • data:// stream wrappers are no longer writable, which matches the documented behavior.

  • The arithmetic and bitwise operators +, -, *, /, **, %, <<, >>, &, |, ^, ~, ++, -- will now consistently throw a TypeError when one of the operands is an array, recurso or non-overloaded object. The only exception to this is the array + array merge operation, which remains supported.

  • Float to string casting will now always behave locale-independently.

    <?php
    setlocale    (LC_ALL, "de_DE");
    $f = 3.14;
    echo     $f, "\n";
    // Previously: 3,14
    // Now:        3.14
    ?>

    See printf(), number_format() and NumberFormatter() for ways to customize number formatting.

  • Support for deprecated curly braces for offset access has been removed.

    <?php
    // Instead of:
    $array{0};
    $array{"key"};
    // Write:
    $array[0];
    $array["key"];
    ?>

  • Applying the final modifier on a private method will now produce a warning unless that method is the constructor.

  • If an object constructor exit()s, the object destructor will no longer be called. This matches the behavior when the constructor throws.

  • Namespaced names can no longer contain whitespace: While Foo\Bar will be recognized as a namespaced name, Foo \ Bar will not. Conversely, reserved keywords are now permitted as namespace segments, which may also change the interpretation of code: new\x is now the same as constant('new\x'), not new \x().

  • Nested ternaries now require explicit parentheses.

  • debug_backtrace() and Exception::getTrace() will no longer provide references to arguments. It will not be possible to change function arguments through the backtrace.

  • Numeric string handling has been altered to be more intuitive and less error-prone. Trailing whitespace is now allowed in numeric strings for consistency with how leading whitespace is treated. This mostly affects:

    • The is_numeric() function
    • String-to-string comparisons
    • Type declarations
    • Increment and decrement operations

    The concept of a "leading-numeric string" has been mostly dropped; the cases where this remains exist in order to ease migration. Strings which emitted an E_NOTICE "A non well-formed numeric value encountered" will now emit an E_WARNING "A non-numeric value encountered" and all strings which emitted an E_WARNING "A non-numeric value encountered" will now throw a TypeError. This mostly affects:

    • Arithmetic operations
    • Bitwise operations

    This E_WARNING to TypeError change also affects the E_WARNING "Illegal string offset 'string'" for illegal string offsets. The behavior of explicit casts to int/float from strings has not been changed.

  • Magic Methods will now have their arguments and return types checked if they have them declared. The signatures should match the following list:

    • __call(string $name, array $arguments): mixed
    • __callStatic(string $name, array $arguments): mixed
    • __clone(): void
    • __debugInfo(): ?array
    • __get(string $name): mixed
    • __invoke(mixed $arguments): mixed
    • __isset(string $name): bool
    • __serialize(): array
    • __set(string $name, mixed $value): void
    • __set_state(array $properties): object
    • __sleep(): array
    • __unserialize(array $data): void
    • __unset(string $name): void
    • __wakeup(): void

  • call_user_func_array() array keys will now be interpreted as parameter names, instead of being silently ignored.

  • Declaring a function called assert() inside a namespace is no longer allowed, and issues E_COMPILE_ERROR. The assert() function is subject to special handling by the engine, which may lead to inconsistent behavior when defining a namespaced function with the same name.

Resource to Object Migration

Several recursos have been migrated to objects. Return value checks using is_resource() should be replaced with checks for false.

  • curl_init() will now return a CurlHandle object rather than a recurso. The curl_close() function no longer has an effect, instead the CurlHandle instance is automatically destroyed if it is no longer referenced.

  • curl_multi_init() will now return a CurlMultiHandle object rather than a recurso. The curl_multi_close() function no longer has an effect, instead the CurlMultiHandle instance is automatically destroyed if it is no longer referenced.

  • curl_share_init() will now return a CurlShareHandle object rather than a recurso. The curl_share_close() function no longer has an effect, instead the CurlShareHandle instance is automatically destroyed if it is no longer referenced.

  • enchant_broker_init() will now return an EnchantBroker object rather than a recurso.

  • enchant_broker_request_dict() and enchant_broker_request_pwl_dict() will now return an EnchantDictionary object rather than a recurso.

  • The GD extension now uses GdImage objects as the underlying data structure for images, rather than recursos. The imagedestroy() function no longer has an effect; instead the GdImage instance is automatically destroyed if it is no longer referenced.

  • openssl_x509_read() and openssl_csr_sign() will now return an OpenSSLCertificate object rather than a recurso. The openssl_x509_free() function is deprecated and no longer has an effect, instead the OpenSSLCertificate instance is automatically destroyed if it is no longer referenced.

  • openssl_csr_new() will now return an OpenSSLCertificateSigningRequest object rather than a recurso.

  • openssl_pkey_new() will now return an OpenSSLAsymmetricKey object rather than a recurso. The openssl_pkey_free() function is deprecated and no longer has an effect, instead the OpenSSLAsymmetricKey instance is automatically destroyed if it is no longer referenced.

  • shmop_open() will now return a Shmop object rather than a recurso. The shmop_close() function no longer has an effect, and is deprecated; instead the Shmop instance is automatically destroyed if it is no longer referenced.

  • socket_create(), socket_create_listen(), socket_accept(), socket_import_stream(), socket_addrinfo_connect(), socket_addrinfo_bind(), and socket_wsaprotocol_info_import() will now return a Socket object rather than a recurso. socket_addrinfo_lookup() will now return an array of AddressInfo objects rather than recursos.

  • msg_get_queue() will now return an SysvMessageQueue object rather than a recurso.

  • sem_get() will now return an SysvSemaphore object rather than a recurso.

  • shm_attach() will now return an SysvSharedMemory object rather than a recurso.

  • xml_parser_create() and xml_parser_create_ns() will now return an XMLParser object rather than a recurso. The xml_parser_free() function no longer has an effect, instead the XMLParser instance is automatically destroyed if it is no longer referenced.

  • The XMLWriter functions now accept and return, respectively, XMLWriter objects instead of recursos.

  • inflate_init() will now return an InflateContext object rather than a recurso.

  • deflate_init() will now return a DeflateContext object rather than a recurso.

COM and .Net (Windows)

The ability to import case-insensitive constants from type libraries has been removed. The second argument to com_load_typelib() may no longer be false; com.autoregister_casesensitive may no longer be disabled; case-insensitive markers in com.typelib_file are ignored.

CURL

CURLOPT_POSTFIELDS no longer accepts objects as arrays. To interpret an object as an array, perform an explicit (array) cast. The same applies to other options accepting arrays as well.

Date and Time

mktime() and gmmktime() now require at least one argument. time() can be used to get the current timestamp.

DOM

Unimplemented classes from the DOM extension that had no behavior and contained test data have been removed. These classes have also been removed in the latest version of the DOM standard:

  • DOMNameList
  • DomImplementationList
  • DOMConfiguration
  • DomError
  • DomErrorHandler
  • DOMImplementationSource
  • DOMLocator
  • DOMUserDataHandler
  • DOMTypeInfo

Enchant

  • enchant_broker_list_dicts(), enchant_broker_describe() and enchant_dict_suggest() will now return an empty array instead of null.

Exif

read_exif_data() has been removed; exif_read_data() should be used instead.

Filter

  • The FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED flags for the FILTER_VALIDATE_URL filter have been removed. The scheme and host are (and have been) always required.

  • The INPUT_REQUEST and INPUT_SESSION source for filter_input() etc. have been removed. These were never implemented and their use always generated a warning.

GD

  • The deprecated functions image2wbmp() has been removed.

  • The deprecated functions png2wbmp() and jpeg2wbmp() have been removed.

  • The default mode parameter of imagecropauto() no longer accepts -1. IMG_CROP_DEFAULT should be used instead.

  • On Windows, php_gd2.dll has been renamed to php_gd.dll.

GMP

gmp_random() has been removed. One of gmp_random_range() or gmp_random_bits() should be used instead.

Iconv

iconv implementations which do not properly set errno in case of errors are no longer supported.

IMAP

  • The unused default_host argument of imap_headerinfo() has been removed.

  • The imap_header() function which is an alias of imap_headerinfo() has been removed.

Internationalization Functions

  • The deprecated constant INTL_IDNA_VARIANT_2003 has been removed.

  • The deprecated Normalizer::NONE constant has been removed.

LDAP

  • The deprecated functions ldap_sort(),
ldap_control_paged_result() and
ldap_control_paged_result_response() have been removed.

  • The interface of ldap_set_rebind_proc() has changed; the callback parameter does not accept empty strings anymore; null should be used instead.

MBString

  • The mbstring.func_overload directive has been removed. The related MB_OVERLOAD_MAIL, MB_OVERLOAD_STRING, and MB_OVERLOAD_REGEX constants have also been removed. Finally, the "func_overload" and "func_overload_list" entries in mb_get_info() have been removed.

  • mb_parse_str() can no longer be used without specifying a result array.

  • A number of deprecated mbregex aliases have been removed. See the following list for which functions should be used instead:

    • mbregex_encoding() ? mb_regex_encoding()
    • mbereg() ? mb_ereg()
    • mberegi() ? mb_eregi()
    • mbereg_replace() ? mb_ereg_replace()
    • mberegi_replace() ? mb_eregi_replace()
    • mbsplit() ? mb_split()
    • mbereg_match() ? mb_ereg_match()
    • mbereg_search() ? mb_ereg_search()
    • mbereg_search_pos() ? mb_ereg_search_pos()
    • mbereg_search_regs() ? mb_ereg_search_regs()
    • mbereg_search_init() ? mb_ereg_search_init()
    • mbereg_search_getregs() ? mb_ereg_search_getregs()
    • mbereg_search_getpos() ? mb_ereg_search_getpos()
    • mbereg_search_setpos() ? mb_ereg_search_setpos()

  • The e modifier for mb_ereg_replace() has been removed. mb_ereg_replace_callback() should be used instead.

  • A non-string pattern argument to mb_ereg_replace() will now be interpreted as a string instead of an ASCII codepoint. The previous behavior may be restored with an explicit call to chr().

  • The needle argument for mb_strpos(),
mb_strrpos(), mb_stripos(),
mb_strripos(), mb_strstr(),
mb_stristr(), mb_strrchr() and
mb_strrichr() can now be empty.

  • The is_hex parameter, which was not used internally, has been removed from mb_decode_numericentity().

  • The legacy behavior of passing the encoding as the third argument instead of an offset for the mb_strrpos() function has been removed; an explicit 0 offset with the encoding should be provided as the fourth argument instead.

  • The ISO_8859-* character encoding aliases have been replaced by ISO8859-* aliases for better interoperability with the iconv extension. The mbregex ISO 8859 aliases with underscores (ISO_8859_* and ISO8859_*) have also been removed.

  • mb_ereg() and mb_eregi() will now return boolean true on a successful match. Previously they returned integer 1 if matches was not passed, or max(1, strlen($matches[0])) if matches was passed.

OCI8

  • The OCI-Lob class is now called OCILob, and the OCI-Collection class is now called OCICollection for name compliance enforced by PHP 8 arginfo type annotation tooling.

  • Several alias functions have been marked as deprecated.

  • oci_internal_debug() and its alias ociinternaldebug() have been removed.

ODBC

  • odbc_connect() no longer reuses connections.

  • The unused flags parameter of odbc_exec() has been removed.

OpenSSL

  • openssl_seal() and openssl_open() now require method to be passed, as the previous default of "RC4" is considered insecure.

Regular Expressions (Perl-Compatible)

When passing invalid escape sequences they are no longer interpreted as literals. This behavior previously required the X modifier – which is now ignored.

PHP Data Objects

  • The default error handling mode has been changed from "silent" to "exceptions". See Errors and error handling for details.

  • The signatures of some PDO methods have changed:

    • PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs)
    • PDOStatement::setFetchMode(int $mode, mixed ...$args)

PDO ODBC

The php.ini directive pdo_odbc.db2_instance_name has been removed.

PDO MySQL

PDO::inTransaction() now reports the actual transaction state of the connection, rather than an approximation maintained by PDO. If a query that is subject to "implicit commit" is executed, PDO::inTransaction() will subsequently return false, as a transaction is no longer active.

PostgreSQL

  • The deprecated pg_connect() syntax using multiple parameters instead of a connection string is no longer supported.

  • The deprecated pg_lo_import() and pg_lo_export() signature that passes the connection as the last argument is no longer supported. The connection should be passed as first argument instead.

  • pg_fetch_all() will now return an empty array instead of false for result sets with zero rows.

Phar

Metadata associated with a phar will no longer be automatically unserialized, to fix potential security vulnerabilities due to object instantiation, autoloading, etc.

Reflection

  • The method signatures

    • ReflectionClass::newInstance($args)
    • ReflectionFunction::invoke($args)
    • ReflectionMethod::invoke($object, $args)

    have been changed to:

    • ReflectionClass::newInstance(...$args)
    • ReflectionFunction::invoke(...$args)
    • ReflectionMethod::invoke($object, ...$args)

    Code that must be compatible with both PHP 7 and PHP 8 can use the following signatures to be compatible with both versions:

    • ReflectionClass::newInstance($arg = null, ...$args)
    • ReflectionFunction::invoke($arg = null, ...$args)
    • ReflectionMethod::invoke($object, $arg = null, ...$args)

  • The ReflectionType::__toString() method will now return a complete debug representation of the type, and is no longer deprecated. In particular the result will include a nullability indicator for nullable types. The format of the return value is not stable and may change between PHP versions.

  • Reflection export() methods have been removed. Instead reflection objects can be cast to string.

  • ReflectionMethod::isConstructor() and
ReflectionMethod::isDestructor() now also return true for
__construct() and
__destruct() methods of interfaces.
Previously, this would only be true for methods of classes and traits.

  • ReflectionType::isBuiltin() method has been moved to ReflectionNamedType. ReflectionUnionType does not have it.

Sockets

  • The deprecated AI_IDN_ALLOW_UNASSIGNED and AI_IDN_USE_STD3_ASCII_RULES flags for socket_addrinfo_lookup() have been removed.

Standard PHP Library (SPL)

  • SplFileObject::fgetss() has been removed.

  • SplFileObject::seek() now always seeks to the beginning of the line. Previously, positions =1 sought to the beginning of the next line.

  • SplHeap::compare() now specifies a method signature. Inheriting classes implementing this method will now have to use a compatible method signature.

  • SplDoublyLinkedList::push(), SplDoublyLinkedList::unshift() and SplQueue::enqueue() now return void instead of true.

  • spl_autoload_register() will now always throw a TypeError on invalid arguments, therefore the second argument do_throw is ignored and a notice will be emitted if it is set to false.

  • SplFixedArray is now an IteratorAggregate and not an Iterator. SplFixedArray::rewind(), SplFixedArray::current(), SplFixedArray::key(), SplFixedArray::next(), and SplFixedArray::valid() have been removed. In their place, SplFixedArray::getIterator() has been added. Any code which uses explicit iteration over SplFixedArray must now obtain an Iterator through SplFixedArray::getIterator(). This means that SplFixedArray is now safe to use in nested loops.

Standard Library

  • assert() will no longer evaluate string arguments, instead they will be treated like any other argument. assert($a == $b) should be used instead of assert('$a == $b'). The assert.quiet_eval ini directive and the ASSERT_QUIET_EVAL constant have also been removed, as they would no longer have any effect.

  • parse_str() can no longer be used without specifying a result array.

  • The string.strip_tags filter has been removed.

  • The needle argument of strpos(), strrpos(), stripos(), strripos(), strstr(), strchr(), strrchr(), and stristr() will now always be interpreted as a string. Previously non-string needles were interpreted as an ASCII code point. An explicit call to chr() can be used to restore the previous behavior.

  • The needle argument for strpos(),
strrpos(), stripos(), strripos(),
strstr(), stristr() and strrchr() can
now be empty.

  • The length argument for substr(), substr_count(), substr_compare(), and iconv_substr() can now be null. null values will behave as if no length argument was provided and will therefore return the remainder of the string instead of an empty string.

  • The length argument for array_splice() can now be null. null values will behave identically to omitting the argument, thus removing everything from the offset to the end of the array.

  • The args argument of vsprintf(), vfprintf(), and vprintf() must now be an array. Previously any type was accepted.

  • The 'salt' option of password_hash() is no longer supported. If the 'salt' option is used a warning is generated, the provided salt is ignored, and a generated salt is used instead.

  • The quotemeta() function will now return an empty string if an empty string was passed. Previously false was returned.

  • The following functions have been removed:

    • hebrevc()
    • convert_cyr_string()
    • money_format()
    • ezmlm_hash()
    • restore_include_path()
    • get_magic_quotes_gpc()
    • get_magic_quotes_runtime()
    • fgetss()

  • FILTER_SANITIZE_MAGIC_QUOTES has been removed.

  • Calling implode() with parameters in a reverse order ($pieces, $glue) is no longer supported.

  • parse_url() will now distinguish absent and empty queries and fragments:

    • http://example.com/foo ? query = null, fragment = null
    • http://example.com/foo? ? query = "", fragment = null
    • http://example.com/foo# ? query = null, fragment = ""
    • http://example.com/foo?# ? query = "", fragment = ""
    Previously all cases resulted in query and fragment being null.

  • var_dump() and debug_zval_dump() will now print floating-point numbers using serialize_precision rather than precision. In a default configuration, this means that floating-point numbers are now printed with full accuracy by these debugging functions.

  • If the array returned by __sleep() contains non-existing properties, these are now silently ignored. Previously, such properties would have been serialized as if they had the value null.

  • The default locale on startup is now always "C". No locales are inherited from the environment by default. Previously, LC_ALL was set to "C", while LC_CTYPE was inherited from the environment. However, some functions did not respect the inherited locale without an explicit setlocale() call. An explicit setlocale() call is now always required if a locale component should be changed from the default.

  • The deprecated DES fallback in crypt() has been removed. If an unknown salt format is passed to crypt(), the function will fail with *0 instead of falling back to a weak DES hash now.

  • Specifying out of range rounds for SHA256/SHA512 crypt() will now fail with *0 instead of clamping to the closest limit. This matches glibc behavior.

  • The result of sorting functions may have changed, if the array contains elements that compare as equal.

  • Any functions accepting callbacks that are not explicitly specified to accept parameters by reference will now warn if a callback with reference parameters is used. Examples include array_filter() and array_reduce(). This was already the case for most, but not all, functions previously.

  • The HTTP stream wrapper as used by functions like file_get_contents() now advertises HTTP/1.1 rather than HTTP/1.0 by default. This does not change the behavior of the client, but may cause servers to respond differently. To retain the old behavior, set the 'protocol_version' stream context option, e.g.

    <?php
    $ctx     = stream_context_create(['http' => ['protocol_version' => '1.0']]);
    echo     file_get_contents('http://example.org', false, $ctx);
    ?>

  • Calling crypt() without an explicit salt is no longer supported. If you would like to produce a strong hash with an auto-generated salt, use password_hash() instead.

  • substr(), mb_substr(), iconv_substr() and grapheme_substr() now consistently clamp out-of-bounds offsets to the string boundary. Previously, false was returned instead of the empty string in some cases.

  • On Windows, the program execution functions (proc_open(), exec(), popen() etc.) using the shell, now consistently execute %comspec% /s /c "$commandline", which has the same effect as executing $commandline (without additional quotes).

Sysvsem

  • The auto_release parameter of sem_get() was changed to accept bool values rather than int.

Tidy

  • The use_include_path parameter, which was not used internally, has been removed from tidy_repair_string().

  • tidy::repairString() and tidy::repairFile() became static methods.

Tokenizer

  • T_COMMENT tokens will no longer include a trailing newline. The newline will instead be part of a following T_WHITESPACE token. It should be noted that T_COMMENT is not always followed by whitespace, it may also be followed by T_CLOSE_TAG or end-of-file.

  • Namespaced names are now represented using the T_NAME_QUALIFIED (Foo\Bar), T_NAME_FULLY_QUALIFIED (\Foo\Bar) and T_NAME_RELATIVE (namespace\Foo\Bar) tokens. T_NS_SEPARATOR is only used for standalone namespace separators, and only syntactially valid in conjunction with group use declarations.

XMLReader

XMLReader::open() and XMLReader::xml() are now static methods. They can still be called as instance methods, but inheriting classes need to declare them as static if they override these methods.

XML-RPC

The XML-RPC extension has been moved to PECL and is no longer part of the PHP distribution.

Zip

ZipArchive::OPSYS_Z_CPM has been removed (this name was a typo). Use ZipArchive::OPSYS_CPM instead.

Zlib

  • gzgetss() has been removed.

  • zlib.output_compression is no longer automatically disabled for Content-Type: image/*.

Windows PHP Test Packs

The test runner has been renamed from run-test.php to run-tests.php, to match its name in php-src.


Características obsoletas

Núcleo PHP

  • If a parameter with a default value is followed by a required parameter, the default value has no effect. This is deprecated as of PHP 8.0.0 and can generally be resolved by dropping the default value, without a change in functionality:

    <?php
    function test($a = [], $b) {} // Before
    function test($a, $b) {}      // After
    ?>

    One exception to this rule are parameters of the form Type $param = null, where the null default makes the type implicitly nullable. This usage remains allowed, but it is recommended to use an explicit nullable type instead:

    <?php
    function test(A $a = null, $b) {} // Still allowed
    function test(?A $a, $b) {}       // Recommended
    ?>

  • Calling get_defined_functions() with exclude_disabled explicitly set to false is deprecated and no longer has an effect. get_defined_functions() will never include disabled functions.

Enchant

  • enchant_broker_set_dict_path() and enchant_broker_get_dict_path() are deprecated, because that functionality is neither available in libenchant < 1.5 nor in libenchant-2.

  • enchant_dict_add_to_personal() is deprecated; use enchant_dict_add() instead.

  • enchant_dict_is_in_session() is deprecated; use enchant_dict_is_added() instead.

  • enchant_broker_free() and enchant_broker_free_dict() are deprecated; unset the object instead.

  • The ENCHANT_MYSPELL and ENCHANT_ISPELL constants are deprecated.

LibXML

libxml_disable_entity_loader() has been deprecated. As libxml 2.9.0 is now required, external entity loading is guaranteed to be disabled by default, and this function is no longer needed to protect against XXE attacks.

PGSQL / PDO PGSQL

  • The constant PGSQL_LIBPQ_VERSION_STR now has the same value as PGSQL_LIBPQ_VERSION, and thus is deprecated.

  • Function aliases in the pgsql extension have been deprecated. See the following list for which functions should be used instead:

    • pg_errormessage() ? pg_last_error()
    • pg_numrows() ? pg_num_rows()
    • pg_numfields() ? pg_num_fields()
    • pg_cmdtuples() ? pg_affected_rows()
    • pg_fieldname() ? pg_field_name()
    • pg_fieldsize() ? pg_field_size()
    • pg_fieldtype() ? pg_field_type()
    • pg_fieldnum() ? pg_field_num()
    • pg_result() ? pg_fetch_result()
    • pg_fieldprtlen() ? pg_field_prtlen()
    • pg_fieldisnull() ? pg_field_is_null()
    • pg_freeresult() ? pg_free_result()
    • pg_getlastoid() ? pg_last_oid()
    • pg_locreate() ? pg_lo_create()
    • pg_lounlink() ? pg_lo_unlink()
    • pg_loopen() ? pg_lo_open()
    • pg_loclose() ? pg_lo_close()
    • pg_loread() ? pg_lo_read()
    • pg_lowrite() ? pg_lo_write()
    • pg_loreadall() ? pg_lo_read_all()
    • pg_loimport() ? pg_lo_import()
    • pg_loexport() ? pg_lo_export()
    • pg_setclientencoding() ? pg_set_client_encoding()
    • pg_clientencoding() -> pg_client_encoding()

Standard Library

  • Sort comparison functions that return true or false will now throw a deprecation warning, and should be replaced with an implementation that returns an integer less than, equal to, or greater than zero.

    <?php
    // Replace
    usort($array, fn($a, $b) => $a > $b);
    // With
    usort($array, fn($a, $b) => $a <=> $b);
    ?>

Zip

  • Using an empty file as ZipArchive is deprecated. Libzip 1.6.0 does not accept empty files as valid zip archives any longer. The existing workaround will be removed in the next version.

  • The procedural API of Zip is deprecated. Use ZipArchive instead. Iteration over all entries can be accomplished using ZipArchive::statIndex() and a for loop:

    <?php
    // iterate using the procedural API
    assert(is_resource($zip));
    while (    $entry = zip_read($zip)) {
        echo     zip_entry_name($entry);
    }

    // iterate using the object-oriented API
    assert($zip instanceof ZipArchive);
    for (    $i = 0; $entry = $zip->statIndex($i); $i++) {
        echo     $entry['name'];
    }
    ?>

Reflection

  • ReflectionFunction::isDisabled() is deprecated, as it is no longer possible to create a ReflectionFunction for a disabled function. This method now always returns false.

  • ReflectionParameter::getClass(),
ReflectionParameter::isArray(), and
ReflectionParameter::isCallable() are deprecated.
ReflectionParameter::getType() and the
ReflectionType APIs should be used instead.


Other Changes

Changes in SAPI Modules

Apache2Handler

The PHP module has been renamed from php7_module to php_module.

Changed Functions

Reflection

ReflectionClass::getConstants() and ReflectionClass::getReflectionConstants() results can be now filtered via a new parameter filter. Three new constants were added to be used with it:

  • ReflectionClassConstant::IS_PUBLIC
  • ReflectionClassConstant::IS_PROTECTED
  • ReflectionClassConstant::IS_PRIVATE

Zip

  • The ZipArchive::addGlob() and ZipArchive::addPattern() methods accept more values in the options array argument:

    • flags
    • comp_method
    • comp_flags
    • env_method
    • enc_password

  • ZipArchive::addEmptyDir(), ZipArchive::addFile() and ZipArchive::addFromString() methods have a new flags argument. This allows managing name encoding (ZipArchive::FL_ENC_*) and entry replacement (ZipArchive::FL_OVERWRITE).

  • ZipArchive::extractTo() now restores the file modification time.

Other Changes to Extensions

CURL

  • The CURL extension now requires at least libcurl 7.29.0.

  • The deprecated parameter version of curl_version() has been removed.

Date and Time

DatePeriod now implements IteratorAggregate (instead of Traversable).

DOM

DOMNamedNodeMap and DOMNodeList now implement IteratorAggregate (instead of Traversable).

Intl

IntlBreakIterator and ResourceBundle now implement IteratorAggregate (instead of Traversable).

Enchant

The enchant extension now uses libenchant-2 by default when available. libenchant version 1 is still supported but is deprecated and could be removed in the future.

GD

  • The num_points parameter of imagepolygon(), imageopenpolygon() and imagefilledpolygon() is now optional, i.e. these functions may be called with either 3 or 4 arguments. If the argument is omitted, it is calculated as count($points)/2.

  • The function imagegetinterpolation() to get the current interpolation method has been added.

JSON

The JSON extension cannot be disabled anymore and is always an integral part of any PHP build, similar to the date extension.

MBString

The Unicode data tables have been updated to version 13.0.0.

PDO

PDOStatement now implements IteratorAggregate (instead of Traversable).

LibXML

The minimum required libxml version is now 2.9.0. This means that external entity loading is now guaranteed to be disabled by default, and no extra steps need to be taken to protect against XXE attacks.

MySQLi / PDO MySQL

  • When mysqlnd is not used (which is the default and recommended option), the minimum supported libmysqlclient version is now 5.5.

  • mysqli_result now implements IteratorAggregate (instead of Traversable).

PGSQL / PDO PGSQL

The PGSQL and PDO PGSQL extensions now require at least libpq 9.1.

Readline

Calling readline_completion_function() before the interactive prompt starts (e.g. in auto_prepend_file) will now override the default interactive prompt completion function. Previously, readline_completion_function() only worked when called after starting the interactive prompt.

SimpleXML

SimpleXMLElement now implements RecursiveIterator and absorbed the functionality of SimpleXMLIterator. SimpleXMLIterator is an empty extension of SimpleXMLElement.

Changes to INI File Handling

  • com.dotnet_version is a new INI directive to choose the version of the .NET framework to use for dotnet objects.

  • zend.exception_string_param_max_len is a new INI directive to set the maximum string length in an argument of a stringified stack strace.

EBCDIC

EBCDIC targets are no longer supported, though it's unlikely that they were still working in the first place.

Performance

  • A Just-In-Time (JIT) compiler has been added to the opcache extension.

  • array_slice() on an array without gaps will no longer scan the whole array to find the start offset. This may significantly reduce the runtime of the function with large offsets and small lengths.

  • strtolower() now uses a SIMD implementation when using the "C" LC_CTYPE locale (which is the default).


Migración de PHP 7.3.x a PHP 7.4.x

Tabla de contenidos

  • New Features
  • Nuevas clases e interfaces
  • Nuevas funciones
  • Nuevas constantes globales
  • Backward Incompatible Changes
  • Características obsoletas
  • Extensiones eliminadas
  • Other Changes
  • Windows Support

Esta nueva versión menor trae consigo una serie de nuevas características y algunas incompatibilidades que debe ser probado antes de cambiar las versiones de PHP en los entornos de producción.

Véanse también las guías de migración para versiones de PHP 7.0.x, 7.1.x, 7.2.x y 7.3.x.


New Features

PHP Core

Typed properties

Class properties now support type declarations.

<?php
class User {
    public int $id;
    public string $name;
}
?>
The above example will enforce that $user->id can only be assigned int values and $user->name can only be assigned string values.

Arrow functions

Arrow functions provide a shorthand syntax for defining functions with implicit by-value scope binding.

<?php
$factor = 10;
$nums = array_map(fn($n) => $n * $factor, [1, 2, 3, 4]);
// $nums = array(10, 20, 30, 40);
?>

Limited return type covariance and argument type contravariance

The following code will now work:

<?php
class A {}
class B extends A {}

class Producer {
    public function method(): A {}
}
class ChildProducer extends Producer {
    public function method(): B {}
}
?>
Full variance support is only available if autoloading is used. Inside a single file only non-cyclic type references are possible, because all classes need to be available before they are referenced.

Null coalescing assignment operator

<?php
$array['key'] ??= computeDefault();
// is roughly equivalent to
if (!isset($array['key'])) {
    $array['key'] = computeDefault();
}
?>

Unpacking inside arrays

<?php
$parts = ['apple', 'pear'];
$fruits = ['banana', 'orange', ...$parts, 'watermelon'];
// ['banana', 'orange', 'apple', 'pear', 'watermelon'];
?>

Numeric literal separator

Numeric literals can contain underscores between digits.

<?php
6.674_083e-11; // float
299_792_458;   // decimal
0xCAFE_F00D;   // hexadecimal
0b0101_1111;   // binary
?>

Weak references

Weak references allow the programmer to retain a reference to an object that does not prevent the object from being destroyed.

Allow exceptions from __toString()

Throwing exceptions from __toString() is now permitted. Previously this resulted in a fatal error. Existing recoverable fatal errors in string conversions have been converted to Error exceptions.

CURL

CURLFile now supports stream wrappers in addition to plain file names, if the extension has been built against libcurl >= 7.56.0.

Filter

The FILTER_VALIDATE_FLOAT filter now supports the min_range and max_range options, with the same semantics as FILTER_VALIDATE_INT.

FFI

FFI is a new extension, which provides a simple way to call native functions, access native variables, and create/access data structures defined in C libraries.

GD

Added the IMG_FILTER_SCATTER image filter to apply a scatter filter to images.

Hash

Added crc32c hash using Castagnoli's polynomial. This CRC32 variant is used by storage systems, such as iSCSI, SCTP, Btrfs and ext4.

Multibyte String

Added the mb_str_split() function, which provides the same functionality as str_split(), but operating on code points rather than bytes.

OPcache

Support for preloading code has been added.

Regular Expressions (Perl-Compatible)

The preg_replace_callback() and preg_replace_callback_array() functions now accept an additional flags argument, with support for the PREG_OFFSET_CAPTURE and PREG_UNMATCHED_AS_NULL flags. This influences the format of the matches array passed to to the callback function.

PDO

The username and password can now be specified as part of the PDO DSN for the mysql, mssql, sybase, dblib, firebird and oci drivers. Previously this was only supported by the pgsql driver. If a username/password is specified both in the constructor and the DSN, the constructor takes precedence.

It is now possible to escape question marks in SQL queries to avoid them being interpreted as parameter placeholders. Writing ?? allows sending a single question mark to the database and e.g. use the PostgreSQL JSON key exists (?) operator.

PDO_OCI

PDOStatement::getColumnMeta() is now available.

PDO_SQLite

PDOStatement::getAttribute(PDO::SQLITE_ATTR_READONLY_STATEMENT) allows checking whether the statement is read-only, i.e. if it doesn't modify the database.

PDO::setAttribute(PDO::SQLITE_ATTR_EXTENDED_RESULT_CODES, true) enables the use of SQLite3 extended result codes in PDO::errorInfo() and PDOStatement::errorInfo().

SQLite3

Added SQLite3::lastExtendedErrorCode() to fetch the last extended result code.

Added SQLite3::enableExtendedResultCodes($enable = true), which will make SQLite3::lastErrorCode() return extended result codes.

Standard

strip_tags() with array of tag names

strip_tags() now also accepts an array of allowed tags: instead of strip_tags($str, '<a><p>') you can now write strip_tags($str, ['a', 'p']).

Custom object serialization

A new mechanism for custom object serialization has been added, which uses two new magic methods: __serialize and __unserialize.

<?php
// Returns array containing all the necessary state of the object.
public function __serialize(): array;

// Restores the object state from the given data array.
public function __unserialize(array $data): void;
?>
The new serialization mechanism supersedes the Serializable interface, which will be deprecated in the future.

Array merge functions without arguments

array_merge() and array_merge_recursive() may now be called without any arguments, in which case they will return an empty array. This is useful in conjunction with the spread operator, e.g. array_merge(...$arrays).

proc_open() function

proc_open() now accepts an array instead of a string for the command. In this case the process will be opened directly (without going through a shell) and PHP will take care of any necessary argument escaping.

<?php
proc_open(['php', '-r', 'echo "Hello World\n";'], $descriptors, $pipes);
?>

proc_open() now supports redirect and null descriptors.

<?php
// Like 2>&1 on the shell
proc_open($cmd, [1 => ['pipe', 'w'], 2 => ['redirect', 1]], $pipes);
// Like 2>/dev/null or 2>nul on the shell
proc_open($cmd, [1 => ['pipe', 'w'], 2 => ['null']], $pipes);
?>

argon2i(d) without libargon

password_hash() now has the argon2i and argon2id implementations from the sodium extension when PHP is built without libargon.


  • « New Features
  • Nuevas funciones »
  • PHP Manual
  • Migración de PHP 7.3.x a PHP 7.4.x
  • Nuevas clases e interfaces

Nuevas clases e interfaces

Reflection

  • ReflectionReference


Nuevas funciones

Núcleo PHP

  • get_mangled_object_vars()
  • password_algos()
  • sapi_windows_set_ctrl_handler()

GD

  • imagecreatefromtga()

OpenSSL

  • openssl_x509_verify()

Process Control

  • pcntl_unshare()

SQLite3

  • SQLite3::backup()
  • SQLite3Stmt::getSQL()


Nuevas constantes globales

Núcleo PHP

  • PHP_WINDOWS_EVENT_CTRL_C
  • PHP_WINDOWS_EVENT_CTRL_BREAK

Multibyte String

  • MB_ONIGURUMA_VERSION

Sockets

Añadidas las siguientes opciones de sockets específicas de FreeBSD:

  • SO_LABEL
  • SO_PEERLABEL
  • SO_LISTENQLIMIT
  • SO_LISTENQLEN
  • SO_USER_COOKIE

Tidy

  • TIDY_TAG_ARTICLE
  • TIDY_TAG_ASIDE
  • TIDY_TAG_AUDIO
  • TIDY_TAG_BDI
  • TIDY_TAG_CANVAS
  • TIDY_TAG_COMMAND
  • TIDY_TAG_DATALIST
  • TIDY_TAG_DETAILS
  • TIDY_TAG_DIALOG
  • TIDY_TAG_FIGCAPTION
  • TIDY_TAG_FIGURE
  • TIDY_TAG_FOOTER
  • TIDY_TAG_HEADER
  • TIDY_TAG_HGROUP
  • TIDY_TAG_MAIN
  • TIDY_TAG_MARK
  • TIDY_TAG_MENUITEM
  • TIDY_TAG_METER
  • TIDY_TAG_NAV
  • TIDY_TAG_OUTPUT
  • TIDY_TAG_PROGRESS
  • TIDY_TAG_SECTION
  • TIDY_TAG_SOURCE
  • TIDY_TAG_SUMMARY
  • TIDY_TAG_TEMPLATE
  • TIDY_TAG_TIME
  • TIDY_TAG_TRACK
  • TIDY_TAG_VIDEO


Backward Incompatible Changes

PHP Core

Array-style access of non-arrays

Trying to use values of type null, bool, int, float or resource as an array (such as $null["key"]) will now generate a notice.

get_declared_classes() function

The get_declared_classes() function no longer returns anonymous classes that have not been instantiated yet.

fn keyword

fn is now a reserved keyword. In particular, it can no longer be used as a function or class name. It can still be used as a method or class constant name.

<?php tag at end of file

<?php at the end of the file (without trailing newline) will now be interpreted as an opening PHP tag. Previously it was interpreted either as a short opening tag followed by literal php and resulted in a syntax error (with short_open_tag=1) or was interpreted as a literal <?php string (with short_open_tag=0).

Stream wrappers

When using include/require on a stream, streamWrapper::stream_set_option() will be invoked with the STREAM_OPTION_READ_BUFFER option. Custom stream wrapper implementations may need to implement the streamWrapper::stream_set_option() method to avoid a warning (always returning false is a sufficient implementation).

Serialization

The o serialization format has been removed. As it is never produced by PHP, this may only break unserialization of manually crafted strings.

Password algorithm constants

Password hashing algorithm identifiers are now nullable strings rather than integers.

  • PASSWORD_DEFAULT was int 1; now is null
  • PASSWORD_BCRYPT was int 1; now is string '2y'
  • PASSWORD_ARGON2I was int 2; now is string 'argon2i'
  • PASSWORD_ARGON2ID was int 3; now is string 'argon2id'

Applications correctly using the constants PASSWORD_DEFAULT, PASSWORD_BCRYPT, PASSWORD_ARGON2I, and PASSWORD_ARGON2ID will continue to function correctly.

htmlentities() function

htmlentities() will now raise a notice (instead of a strict standards warning) if it is used with an encoding for which only basic entity substitution is supported, in which case it is equivalent to htmlspecialchars().

fread() and fwrite() function

fread() and fwrite() will now return false if the operation failed. Previously an empty string or 0 was returned. EAGAIN/EWOULDBLOCK are not considered failures.

These functions now also raise a notice on failure, such as when trying to write to a read-only file resource.

BCMath Arbitrary Precision Mathematics

BCMath functions will now warn if a non well-formed number is passed, such as "32foo". The argument will be interpreted as zero, as before.

CURL

Attempting to serialize a CURLFile class will now generate an exception. Previously the exception was only thrown on unserialization.

Using CURLPIPE_HTTP1 is deprecated, and is no longer supported as of cURL 7.62.0.

The $version parameter of curl_version() is deprecated. If any value not equal to the default CURLVERSION_NOW is passed, a warning is raised and the parameter is ignored.

Date and Time

Calling var_dump() or similar on a DateTime or DateTimeImmutable instance will no longer leave behind accessible properties on the object.

Comparison of DateInterval objects (using ==, <, and so on) will now generate a warning and always return false. Previously all DateInterval objects were considered equal, unless they had properties.

Intl

The default parameter value of idn_to_ascii() and idn_to_utf8() is now INTL_IDNA_VARIANT_UTS46 instead of the deprecated INTL_IDNA_VARIANT_2003.

MySQLi

The embedded server functionality has been removed. It was broken since at least PHP 7.0.

The undocumented mysqli::$stat property has been removed in favor of mysqli::stat().

OpenSSL

The openssl_random_pseudo_bytes() function will now throw an exception in error situations, similar to random_bytes(). In particular, an Error is thrown if the number of requested bytes is less than or equal to zero, and an Exception is thrown if sufficient randomness cannot be gathered. The $crypto_strong output argument is guaranteed to always be true if the function does not throw, so explicitly checking it is not necessary.

Regular Expressions (Perl-Compatible)

When PREG_UNMATCHED_AS_NULL mode is used, trailing unmatched capturing groups will now also be set to null (or [null, -1] if offset capture is enabled). This means that the size of the $matches will always be the same.

PHP Data Objects

Attempting to serialize a PDO or PDOStatement instance will now generate an Exception rather than a PDOException, consistent with other internal classes which do not support serialization.

Reflection

Reflection objects will now generate an exception if an attempt is made to serialize them. Serialization for reflection objects was never supported and resulted in corrupted reflection objects. It has been explicitly prohibited now.

Standard PHP Library (SPL)

Calling get_object_vars() on an ArrayObject instance will now always return the properties of the ArrayObject itself (or a subclass). Previously it returned the values of the wrapped array/object unless the ArrayObject::STD_PROP_LIST flag was specified.

Other affected operations are:

  • ReflectionObject::getProperties()
  • reset(), current(), etc. Use Iterator methods instead.
  • Potentially others working on object properties as a list, e.g. array_walk().

(array) casts are not affected. They will continue to return either the wrapped array, or the ArrayObject properties, depending on whether the ArrayObject::STD_PROP_LIST flag is used.

SplPriorityQueue::setExtractFlags() will throw an exception if zero is passed. Previously this would generate a recoverable fatal error on the next extraction operation.

ArrayObject, ArrayIterator, SplDoublyLinkedList and SplObjectStorage now support the __serialize() and __unserialize() mechanism in addition to the Serializable interface. This means that serialization payloads created on older PHP versions can still be unserialized, but new payloads created by PHP 7.4 will not be understood by older versions.

Tokenizer

token_get_all() will now emit a T_BAD_CHARACTER token for unexpected characters instead of leaving behind holes in the token stream.

Incoming Cookies

As of PHP 7.4.11, the names of incoming cookies are no longer url-decoded for security reasons.


Características obsoletas

Núcleo PHP

Operadores ternarios anidados sin paréntesis explícitos

Las operaciones ternarias anidadas deben utilizar explícitamente paréntesis para dictar el orden de las operaciones. Anteriormente, cuando se usaba sin paréntesis, la asociatividad izquierda no resultaría en el comportamiento esperado en la mayoría de los casos.

<?php
1 ? 2 : 3 ? 4 : 5;   // obsoleto
(1 ? 2 : 3) ? 4 : 5; // ok
1 ? 2 : (3 ? 4 : 5); // ok
?>

Acceso al desplazamiento de Array y string usando llaves

La sintaxis de acceso de desplazamiento en array y string con llaves es obsoleto. Use $var[$idx] en vez de $var{$idx}.

La llamada (real) y la función is_real()

La llamada (real) es obsoleta, use (float) en su lugar.

La función is_real() es también obsoleta, use is_float() en su lugar.

Desencadenando $this cuando $this es usado

Desencadenando $this de un cierre no estático que use $this es obsoleto.

palabra clave parent sin clase de padre

Usar parent dentro de una clase sin un padre es obsoleto, y lanzará un error de compilación en el futuro. Actualmente sólo se generará un error si/cuando el padre es accedido en tiempo de ejecución.

Opción INI allow_url_include

La directiva ini allow_url_include es obsoleta. Habilitar esta generará un aviso de depreciación en el arranque.

Caracteres inválidos en las funciones de conversión de base

Pasar caracteres inválidos a base_convert(), bindec(), octdec() y hexdec() generará ahora un aviso de depreciación. El resultado se seguirá calculando como si los caracteres inválidos no existieran. Liderando y siguiendo el espacio blanco, así como prefijos de tipo 0x (dependiendo de la base) siguen estando permitidos.

Usar array_key_exists() en objetos

Usar array_key_exists() en objetos es obsoleto. En lugar de eso, debe usar isset() o property_exists().

Funciones de comillas mágicas

Las funciones get_magic_quotes_gpc() y get_magic_quotes_runtime() son obsoletas. Estas siempre devolverán false.

función hebrevc()

La función hebrevc() es obsoleta. Esta puede ser reemplazada con nl2br(hebrev($str)) o, preferiblemente, el uso del soporte RTL de Unicode.

función convert_cyr_string()

La función convert_cyr_string() es obsoleta.
Esta puede ser reemplazada con mb_convert_string(),
iconv() o UConverter.

función money_format()

La función money_format() es obsoleta. Esta puede ser reemplazada con la funcionalidad intl NumberFormatter.

función ezmlm_hash()

La función ezmlm_hash() es obsoleta.

función restore_include_path()

La función restore_include_path() es obsoleta. Esta puede ser reemplazada con ini_restore('include_path').

Implode con el orden de los parámetros históricos

Pasar parámetros a implode() en orden inverso es obsoleto, use implode($glue, $parts) en vez de implode($parts, $glue).

COM

La importación de bibliotecas de tipos con registro constante que no distingue entre mayúsculas y y minúsculas es obsoleto.

Filter

FILTER_SANITIZE_MAGIC_QUOTES es obsoleto, use FILTER_SANITIZE_ADD_SLASHES en su lugar.

Multibyte String

Pasar un patrón sin string a mb_ereg_replace() es obsoleto. Actualmente, los patrones sin string se interpretan como puntos de código ASCII. En PHP 8, el patrón será interpretado como un string en su lugar.

Pasar la codificación como tercer parámetro a mb_strrpos() es obsoleto. En su lugar, pasar un offset de 0, y codificar como cuarto parámetro.

Protocolo ligero de acceso a directorios

ldap_control_paged_result_response() y ldap_control_paged_result() son obsoletas. Los controles de paginación pueden ser enviados junto con ldap_search() en su lugar.

Reflection

Llamar a ReflectionType::__toString() ahora generará un aviso de depreciación. Este método ha sido desaprobado en favor de ReflectionNamedType::getName() en la documentación desde PHP 7.1, pero no lanzó un aviso de depreciación por razones técnicas.

Los métodos export() en todas las clases Reflection están obsoletos. Contruir un objeto Reflection y convertir este a string en su lugar:

<?php
// ReflectionClass::export(Foo::class, false) is:
echo new ReflectionClass(Foo::class), "\n";

// $str = ReflectionClass::export(Foo::class, true) is:
$str = (string) new ReflectionClass(Foo::class);
?>

Socket

Las flags AI_IDN_ALLOW_UNASSIGNED y AI_IDN_USE_STD3_ASCII_RULES para socket_addrinfo_lookup() sob obsoletas, debido a una depreciación ascendente en el glibc.


Extensiones eliminadas

Estas extensiones han sido trasladadas a PECL y ya no forman parte de la distribución de PHP. Las versiones del paquete PECL de estas extensiones se crearán según a demanda de los usuarios.

  • Firebird/Interbase - el acceso a una base de datos basada en InterBase y/o Firebird sigue siendo con el driver PDO Firebird.
  • Recode
  • WDDX


Other Changes

Performance Improvements

PHP Core

A specialized VM opcode for the array_key_exists() function has been added, which improves performance of this function if it can be statically resolved. In namespaced code, this may require writing \array_key_exists() or explicitly importing the function.

Regular Expressions (Perl-Compatible)

When preg_match() in UTF-8 mode ("u" modifier) is repeatedly called on the same string (but possibly different offsets), it will only be checked for UTF-8 validity once.

Changes to INI File Handling

zend.exception_ignore_args is a new INI directive for including or excluding arguments from stack traces generated from exceptions.

opcache.preload_user is a new INI directive for specifying the user account under which preloading code is execute if it would otherwise be run as root (which is not allowed for security reasons).

Migration to pkg-config

A number of extensions have been migrated to exclusively use pkg-config for the detection of library dependencies. Generally, this means that instead of using --with-foo-dir=DIR or similar only --with-foo is used. Custom library paths can be specified either by adding additional directories to PKG_CONFIG_PATH or by explicitly specifying compilation options through FOO_CFLAGS and FOO_LIBS.

The following extensions and SAPIs are affected:

  • CURL:
    • --with-curl no longer accepts a directory.
  • Enchant:
    • --with-enchant no longer accepts a directory.
  • FPM:
    • --with-fpm-systemd now uses only pkg-config for libsystem checks. The libsystemd minimum required version is 209.
  • GD:
    • --with-gd becomes --enable-gd (whether to enable the extension at all) and --with-external-gd (to opt into using an external libgd, rather than the bundled one).
    • --with-png-dir has been removed. libpng is required.
    • --with-zlib-dir has been removed. zlib is required.
    • --with-freetype-dir becomes --with-freetype
    • --with-jpeg-dir becomes --with-jpeg
    • --with-webp-dir becomes --with-webp
    • --with-xpm-dir becomes --with-xpm
  • IMAP:
    • --with-kerberos-systemd no longer accepts a directory.
  • Intl:
    • --with-icu-dir has been removed. If --enable-intl is passed, then libicu is always required.
  • LDAP:
    • --with-ldap-sasl no longer accepts a directory.
  • Libxml:
    • --with-libxml-dir has been removed.
    • --enable-libxml becomes --with-libxml.
    • --with-libexpat-dir has been renamed to --with-expat and no longer accepts a directory.
  • Litespeed:
    • --with-litespeed becomes --enable-litespeed.
  • Mbstring:
    • --with-onig has been removed. Unless --disable-mbregex has been passed, libonig is required.
  • ODBC:
    • --with-iodbc no longer accepts a directory.
    • --with-unixODBC without a directory now uses pkg-config (preferred). Directory is still accepted for old versions without libodbc.pc.
  • OpenSSL:
    • --with-openssl no longer accepts a directory.
  • PCRE:
    • --with-pcre-regex has been removed. Instead --with-external-pcre is provided to opt into using an external PCRE library, rather than the bundled one.
  • PDO_SQLite:
    • --with-pdo-sqlite no longer accepts a directory.
  • Readline:
    • --with-libedit no longer accepts a directory.
  • Sodium:
    • --with-sodium no longer accepts a directory.
  • SQLite3:
    • --with-sqlite3 no longer accepts a directory.
  • XSL:
    • --with-xsl no longer accepts a directory.
  • Zip:
    • --with-libzip has been removed.
    • --enable-zip becomes --with-zip.

CSV escaping

fputcsv(),
fgetcsv(),
SplFileObject::fputcsv(),
SplFileObject::fgetcsv(), and
SplFileObject::setCsvControl()
now accept an empty string as $escape argument,
which disables the proprietary PHP escaping mechanism.

The behavior of str_getcsv() has been adjusted accordingly (formerly, an empty string was identical to using the default).

SplFileObject::getCsvControl() now may also return an empty string for the third array element, accordingly.

Data Filtering

The filter extension no longer exposes --with-pcre-dir for Unix builds and can now reliably be built as shared when using ./configure

GD

The behavior of imagecropauto() in the bundled libgd has been synced with that of system libgd:

  • IMG_CROP_DEFAULT is no longer falling back to IMG_CROP_SIDES
  • Threshold-cropping now uses the algorithm of system libgd

The default $mode parameter of imagecropauto() has been changed to IMG_CROP_DEFAULT; passing -1 is now deprecated.

imagescale() now supports aspect ratio preserving scaling to a fixed height by passing -1 as $new_width.

HASH Message Digest Framework

The hash extension cannot be disabled anymore and is always an integral part of any PHP build, similar to the date extension.

Intl

The intl extension now requires at least ICU 50.1.

ResourceBundle now implements Countable.

Lightweight Directory Access Protocol

Support for nsldap and umich_ldap has been removed.

Libxml

All libxml-based extensions now require libxml 2.7.6 or newer.

Multibyte String

The oniguruma library is no longer bundled with PHP, instead libonig needs to be available on the system. Alternatively --disable-mbregex can be used to disable the mbregex component.

OPcache

The --disable-opcache-file and --enable-opcache-file configure options have been removed in favor of the opcache.file_cache INI directive.

Password Hashing

The password_hash() and functions now accept nullable string and int for $algo argument.

PEAR

Installation of PEAR (including PECL) is no longer enabled by default. It can be explicitly enabled using --with-pear. This option is deprecated and may be removed in the future.

Reflection

The numeric values of the modifier constants (IS_ABSTRACT, IS_DEPRECATED, IS_EXPLICIT_ABSTRACT, IS_FINAL, IS_IMPLICIT_ABSTRACT, IS_PRIVATE, IS_PROTECTED, IS_PUBLIC, and IS_STATIC) on the ReflectionClass, ReflectionFunction, ReflectionMethod, ReflectionObject, and ReflectionProperty classes have changed.

SimpleXML

SimpleXMLElement now implements Countable.

SQLite3

The bundled libsqlite has been removed. To build the SQLite3 extension a system libsqlite3 = 3.7.4 is now required. To build the PDO_SQLite extension a system libsqlite3 = 3.5.0 is now required.

Serialization and unserialization of SQLite3, SQLite3Stmt and SQLite3Result is now explicitly forbidden. Formerly, serialization of instances of these classes was possible, but unserialization yielded unusable objects.

The @param notation can now also be used to denote SQL query parameters.

Zip

The bundled libzip library has been removed. A system libzip >= 0.11 is now necessary to build the zip extension.


Windows Support

configure flags

configure ahora considera a los conjuntos adicionales como CFLAGS y LDFLAGS variables de entorno.

Manejo de CTRL

CTRL+C y CTRL+BREAK en la consola pueden ser capturados mediante la configuración de una función de manejo con sapi_windows_set_ctrl_handler().

proc_open() en Windows se puede pasar una opción "create_process_group". Se requiere si el proceso del hijo se supone que maneja eventos CTRL.

OPcache

OPcache ahora soporta un número arbitrario de cachés separados por usuario a través de la directiva INI opcache.cache_id. Todos los procesos con el mismo ID de caché y el usuario comparten una instancia OPcache.

stat

La implementación de la estadística se ha refactorizado.

  • Un número inode An inode number se entregado y se basa en el índice de archivos NTFS.
  • El número del dispositivo se basa ahora en el número de serie del volumen.

Obsérvese que ambos valores se derivan del sistema y se proporcionan tal cual en los sistemas de 64 bits. En sistemas de 32 bits, estos valores podrían desbordar el entero de 32 bits en PHP, así que son falsos.

libsqlite3

libsqlite3 ya no está compilada estáticamente en php_sqlite3.dll y php_pdo_sqlite.dll, pero más bien disponible como libsqlite3.dll. Consulte las instrucciones de instalación para SQLite3 y PDO_SQLITE, respectivamente.


Migración de PHP 7.2.x a PHP 7.3.x

Tabla de contenidos

  • Nuevas características
  • Nuevas funciones
  • Nuevas constantes globales
  • Cambios incompatibles con el pasado
  • Características obsoletas
  • Other Changes
  • Soporte de Windows

Esta nueva versión menor trae consigo una serie de nuevas características y unas pocas incompatibilidades que se deben probar antes de cambiar las versiones de PHP en entornos de producción.

Véanse también las guías de migración para versiones de PHP 7.0.x, 7.1.x y 7.2.x.


Nuevas características

PHP Core

Sintaxis Heredoc y Nowdoc más flexible

Ya no es necesario que el marcador de cierre de los string de documento vaya seguido de un punto y coma o línea nueva. Además, el marcador de cierre puede ser sangrado, en en cuyo caso la indentación se quitará de todas las líneas del string de documento.

La Desestructuración de Arrays soporta las Asignaciones de Referencia

La desestructuración de arrays ahora soporta asignaciones de referencia utilizando la sintaxis [&$a, [$b, &$c]] = $d. Lo mismo se soporta también para list().

Operador Instanceof acepta literales

instanceof ahora permite los literales como el primer operando, en en cuyo caso el resultado es siempre false.

Excepción del error de compilación en lugar de algunos errores de compilación

Una nueva excepción CompileError ha sido añadida, de la cual hereda ParseError. Un pequeño número de errores de compilación lanzarán ahora CompileError en vez de generar un error fatal. Actualmente esto sólo afecta a los errores de compilación que pueden ser lanzados por token_get_all() en modo TOKEN_PARSE, pero más errores pueden ser convertidos en el futuro.

Se permite el uso de comas en las llamadas

Ahora se permiten las comas en las llamadas a funciones y métodos.

Soporte de Argon2id

El argumento de configuración--with-password-argon2[=dir] ahora proporciona soporte tanto para los hashes de Argon2i como de Argon2id en las fuynciones password_hash(), password_verify(), password_get_info(), y password_needs_rehash(). Las contraseñas pueden ser descifradas y verificadas usando la constante PASSWORD_ARGON2ID. El soporte tanto para Argon2i como para Argon2id en las funciones password_*() ahora requiere que PHP esté enlazado con la biblioteca de referencia libargon2 = 20161029.

FastCGI Process Manager

Se han añadido nuevas opciones para personalizar el registro de FPM:

log_limit
Esta opción global puede utilizarse para establecer el límite de registro para la línea que permite registrar mensajes de más de 1024 caracteres sin envoltura. También arregla varios problemas de envoltura.
log_buffering
Esta opción global permite un registro experimental sin buffer extra.
decorate_workers_output
Esta opción de pool permite deshabilitar la decoración de salida para la salida de los trabajadores cuando se habilita catch_workers_output.

Funciones matemáticas de BC

bcscale() ahora también puede ser usado como getter para recuperar la escala actual en uso.

Protocolo ligero de acceso a directorios

El soporte completo para los controles de LDAP se ha añadido a las funciones de consulta LDAP y

  • Un parámetro $serverctrls para enviar controles al
servidor en ldap_add(),
ldap_mod_replace(), ldap_mod_add(),
ldap_mod_del(), ldap_rename(),
ldap_compare(), ldap_delete(),
ldap_modify_batch(),
ldap_search(), ldap_list() y
ldap_read() ha sido añadido.
  • El parámetro de salida $serverctrls para obtener los controles del servidor en ldap_parse_result() ha sido añadido.
  • Soporte para LDAP_OPT_SERVER_CONTROLS y LDAP_OPT_CLIENT_CONTROLS en ldap_get_option() y ldap_set_option() ha sido arreglado.

Funciones de string multibyte

Soporte completo de mapeo y plegado de casos

Se ha añadido soporte al mapeo completo y el plegado de casos. A diferencia del mapeo simple, el mapeo completo de los casos puede cambiar la longitud del string. Por ejemplo:

<?php
mb_strtoupper("Straße");
// Produces STRAßE en PHP 7.2
// Produces STRASSE en PHP 7.3
?>
Los diferentes modos de mapeo y plegado están disponibles a través de mb_convert_case():
  • MB_CASE_LOWER (usado por mb_strtolower())
  • MB_CASE_UPPER (usado por mb_strtoupper())
  • MB_CASE_TITLE
  • MB_CASE_FOLD
  • MB_CASE_LOWER_SIMPLE
  • MB_CASE_UPPER_SIMPLE
  • MB_CASE_TITLE_SIMPLE
  • MB_CASE_FOLD_SIMPLE (utilizado en operaciones que no tienen en cuenta los casos)
Sólo se realiza un mapeo de casos completo incondicional y agnóstico del lenguaje.

Las operaciones de string insensible a los casos que utilizan el plegado de casos

Las operaciones de string insensible a las mayúsculas y minúsculas utilizan ahora el plegado de mayúsculas en lugar del mapeo de mayúsculas y minúsculas durante las comparaciones. Esto significa que más caracteres serán considerado (caso insensible) igual ahora.

MB_CASE_TITLE realiza la conversión de casos de título

mb_convert_case() con MB_CASE_TITLE ahora realiza una conversión de título-caso basado en Cased y CaseIgnorable propiedades derivadas de Unicode. En particular, esto también mejora el manejo de comillas y apóstrofes.

Soporte Unicode 11

La tabla de datos Multibyte String ha sido actualizado para Unicode 11.

Soporte de string largos

Las Funciones Multibyte String ahora soportan correctamente strings de más de 2GB.

Mejoras en el rendimiento

Funcionamiento de la extensión Multibyte String extension ha mejorado significativamente en todos los aspectos. Las mayores mejoras son en las funciones de conversión de casos.

Soporte de capturas nombradas

Las funciones mb_ereg_* ahora soportan capturas nombradas. Las funciones de coincidencia como mb_ereg() ahora retornarán capturas nombradas usando su número de grupo como su nombre, de forma similar a la PCRE:

<?php
mb_ereg('(?<word>\w+)', '?', $matches);
// => [0 => "?", 1 => "?", "word" => "?"];
?>
Adicionalmente, mb_ereg_replace() ahora soporta la notación \k<> y \k'' para referirse a las capturas nombradas en el string de reemplazo:
<?php
mb_ereg_replace('\s*(?<word>\w+)\s*', "_\k<word>_\k'word'_", ' foo ');
// => "_foo_foo_"
?>
\k<> y \k'' también puede utilizarse para referencias numeradas, que también funciona con números de grupo mayores de 9.

Readline

Soporte para las opciones completion_append_character y completion_suppress_append ha sido añadido para readline_info(). Estas opciones sólo están disponibles si PHP está vinculado con libreadline (más que con libedit).


Nuevas funciones

Núcleo PHP

  • array_key_first()
  • array_key_last()
  • gc_status()
  • hrtime()
  • is_countable()
  • net_get_interfaces()

Gestor del proceso FastCGI

  • fpm_get_status()

Fecha y hora

  • DateTime::createFromImmutable()

Precisión múltiple de GNU

  • gmp_binomial()
  • gmp_kronecker()
  • gmp_lcm()
  • gmp_perfect_power()

Funciones de internacionalización

  • Normalizer::getRawDecomposition()
  • normalizer_get_raw_decomposition()
  • Spoofchecker::setRestrictionLevel()

Protocolo ligero de acceso a directorios

  • ldap_add_ext()
  • ldap_bind_ext()
  • ldap_delete_ext()
  • ldap_exop_refresh()
  • ldap_mod_add_ext()
  • ldap_mod_replace_ext()
  • ldap_mod_del_ext()
  • ldap_rename_ext()

OpenSSL

  • openssl_pkey_derive()

Sockets

  • socket_wsaprotocol_info_export()
  • socket_wsaprotocol_info_import()
  • socket_wsaprotocol_info_release()


Nuevas constantes globales

Núcleo PHP

  • PASSWORD_ARGON2ID

Biblioteca URL del cliente

  • CURLAUTH_BEARER
  • CURLAUTH_GSSAPI
  • CURLE_WEIRD_SERVER_REPLY
  • CURLINFO_APPCONNECT_TIME_T
  • CURLINFO_CONNECT_TIME_T
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD_T
  • CURLINFO_CONTENT_LENGTH_UPLOAD_T
  • CURLINFO_FILETIME_T
  • CURLINFO_HTTP_VERSION
  • CURLINFO_NAMELOOKUP_TIME_T
  • CURLINFO_PRETRANSFER_TIME_T
  • CURLINFO_PROTOCOL
  • CURLINFO_PROXY_SSL_VERIFYRESULT
  • CURLINFO_REDIRECT_TIME_T
  • CURLINFO_SCHEME
  • CURLINFO_SIZE_DOWNLOAD_T
  • CURLINFO_SIZE_UPLOAD_T
  • CURLINFO_SPEED_DOWNLOAD_T
  • CURLINFO_SPEED_UPLOAD_T
  • CURLINFO_STARTTRANSFER_TIME_T
  • CURLINFO_TOTAL_TIME_T
  • CURL_LOCK_DATA_CONNECT
  • CURL_LOCK_DATA_PSL
  • CURL_MAX_READ_SIZE
  • CURLOPT_ABSTRACT_UNIX_SOCKET
  • CURLOPT_DISALLOW_USERNAME_IN_URL
  • CURLOPT_DNS_SHUFFLE_ADDRESSES
  • CURLOPT_HAPPY_EYEBALLS_TIMEOUT_MS
  • CURLOPT_HAPROXYPROTOCOL
  • CURLOPT_KEEP_SENDING_ON_ERROR
  • CURLOPT_PRE_PROXY
  • CURLOPT_PROXY_CAINFO
  • CURLOPT_PROXY_CAPATH
  • CURLOPT_PROXY_CRLFILE
  • CURLOPT_PROXY_KEYPASSWD
  • CURLOPT_PROXY_PINNEDPUBLICKEY
  • CURLOPT_PROXY_SSLCERT
  • CURLOPT_PROXY_SSLCERTTYPE
  • CURLOPT_PROXY_SSL_CIPHER_LIST
  • CURLOPT_PROXY_SSLKEY
  • CURLOPT_PROXY_SSLKEYTYPE
  • CURLOPT_PROXY_SSL_OPTIONS
  • CURLOPT_PROXY_SSL_VERIFYHOST
  • CURLOPT_PROXY_SSL_VERIFYPEER
  • CURLOPT_PROXY_SSLVERSION
  • CURLOPT_PROXY_TLS13_CIPHERS
  • CURLOPT_PROXY_TLSAUTH_PASSWORD
  • CURLOPT_PROXY_TLSAUTH_TYPE
  • CURLOPT_PROXY_TLSAUTH_USERNAME
  • CURLOPT_REQUEST_TARGET
  • CURLOPT_SOCKS5_AUTH
  • CURLOPT_SSH_COMPRESSION
  • CURLOPT_SUPPRESS_CONNECT_HEADERS
  • CURLOPT_TIMEVALUE_LARGE
  • CURLOPT_TLS13_CIPHERS
  • CURLPROXY_HTTPS
  • CURLSSH_AUTH_GSSAPI
  • CURL_SSLVERSION_MAX_DEFAULT
  • CURL_SSLVERSION_MAX_NONE
  • CURL_SSLVERSION_MAX_TLSv1_0
  • CURL_SSLVERSION_MAX_TLSv1_1
  • CURL_SSLVERSION_MAX_TLSv1_2
  • CURL_SSLVERSION_MAX_TLSv1_3
  • CURL_SSLVERSION_TLSv1_3
  • CURL_VERSION_ALTSVC (as of PHP 7.3.6)
  • CURL_VERSION_ASYNCHDNS
  • CURL_VERSION_BROTLI
  • CURL_VERSION_CONV
  • CURL_VERSION_CURLDEBUG (as of PHP 7.3.6)
  • CURL_VERSION_DEBUG
  • CURL_VERSION_GSSAPI
  • CURL_VERSION_GSSNEGOTIATE
  • CURL_VERSION_HTTPS_PROXY
  • CURL_VERSION_IDN
  • CURL_VERSION_LARGEFILE
  • CURL_VERSION_MULTI_SSL
  • CURL_VERSION_NTLM
  • CURL_VERSION_NTLM_WB
  • CURL_VERSION_PSL (as of PHP 7.3.6)
  • CURL_VERSION_SPNEGO
  • CURL_VERSION_SSPI
  • CURL_VERSION_TLSAUTH_SRP

Filtrado de datos

  • FILTER_SANITIZE_ADD_SLASHES

Notación de objetos en JavaScript

  • JSON_THROW_ON_ERROR

Protocolo ligero de acceso a directorios

  • LDAP_CONTROL_ASSERT
  • LDAP_CONTROL_MANAGEDSAIT
  • LDAP_CONTROL_PROXY_AUTHZ
  • LDAP_CONTROL_SUBENTRIES
  • LDAP_CONTROL_VALUESRETURNFILTER
  • LDAP_CONTROL_PRE_READ
  • LDAP_CONTROL_POST_READ
  • LDAP_CONTROL_SORTREQUEST
  • LDAP_CONTROL_SORTRESPONSE
  • LDAP_CONTROL_PAGEDRESULTS
  • LDAP_CONTROL_AUTHZID_REQUEST
  • LDAP_CONTROL_AUTHZID_RESPONSE
  • LDAP_CONTROL_SYNC
  • LDAP_CONTROL_SYNC_STATE
  • LDAP_CONTROL_SYNC_DONE
  • LDAP_CONTROL_DONTUSECOPY
  • LDAP_CONTROL_PASSWORDPOLICYREQUEST
  • LDAP_CONTROL_PASSWORDPOLICYRESPONSE
  • LDAP_CONTROL_X_INCREMENTAL_VALUES
  • LDAP_CONTROL_X_DOMAIN_SCOPE
  • LDAP_CONTROL_X_PERMISSIVE_MODIFY
  • LDAP_CONTROL_X_SEARCH_OPTIONS
  • LDAP_CONTROL_X_TREE_DELETE
  • LDAP_CONTROL_X_EXTENDED_DN
  • LDAP_CONTROL_VLVREQUEST
  • LDAP_CONTROL_VLVRESPONSE

String Multibyte

  • MB_CASE_FOLD
  • MB_CASE_LOWER_SIMPLE
  • MB_CASE_UPPER_SIMPLE
  • MB_CASE_TITLE_SIMPLE
  • MB_CASE_FOLD_SIMPLE

OpenSSL

  • STREAM_CRYPTO_PROTO_SSLv3
  • STREAM_CRYPTO_PROTO_TLSv1_0
  • STREAM_CRYPTO_PROTO_TLSv1_1
  • STREAM_CRYPTO_PROTO_TLSv1_2

PostgreSQL

  • PGSQL_DIAG_SCHEMA_NAME
  • PGSQL_DIAG_TABLE_NAME
  • PGSQL_DIAG_COLUMN_NAME
  • PGSQL_DIAG_DATATYPE_NAME
  • PGSQL_DIAG_CONSTRAINT_NAME
  • PGSQL_DIAG_SEVERITY_NONLOCALIZED


Cambios incompatibles con el pasado

Núcleo PHP

Interpretación de la etiqueta final Heredoc/Nowdoc

Debido a la introducción de la sintaxis flexible heredoc/nowdoc, los documentos string que contienen la etiqueta final dentro de su cuerpo pueden causar errores de sintaxis o cambios de la interpretación. Por ejemplo en:

<?php
$str = <<<FOO
abcdefg
   FOO
FOO;
?>
la aparición de FOO con sangría, previamente no tenía ningún significado especial. Ahora se interpretará como el final de la cadena heredoc y el siguiente FOO; provocará un error de sintaxis. Este problema siempre se puede resolver eligiendo una etiqueta final que no aparezca dentro del contenido de la cadena.

Continuar problemas del modificador de adventencias

Declaraciones de continue dirigidas a switch las estructuras de flujo de control ahora generarán una advertencia. En php la declaración continue es equivalente atargeting switch is equivalent to break, mientras estas se comportan como continue 2 en otros lenguajes.

<?php
while ($foo) {
    switch ($bar) {
      case "baz":
         continue;
         // Warning: "continue" el modificador equivale a
         //          "break". ¿Te referías a usar "continue 2"?
   }
}
?>

Interpretación estricta de las claves Integer en String ArrayAccess

Acceos de array de tipo $obj["123"], donde $obj implementa ArrayAccess y "123" es un integer string literal ya no dará como resultado una conversión implícita a integer, p.e., $obj->offsetGet("123") se llamará en lugar de $obj->offsetGet(123). Esto coincide para el comportamiento existente para los no literales. El comportamiento de arrays no se ve afectado de ninguna manera, ellos continuan explícitamente convirtiendo claves de string integrales a enteros.

Propiedades estáticas ya no separadas por asignación de referencia

En PHP, las propiedades estáticas se comparten entre las clases heredadas, a menos que la propiedad estática se invalide explícitamente en una clase secundaria. Sin embargo, debido a un macanismo de implementación fue posible separar las propiedades estáticas asignando una referencia. Esta laguna ha sido arreglada.

<?php
class Test {
    public static $x = 0;
}
class Test2 extends Test { }

Test2::$x = &$x;
$x = 1;

var_dump(Test::$x, Test2::$x);
// Previously: int(0), int(1)
// Now:        int(1), int(1)
?>

Referencias devueltas por Array y accesos a la propiedad se desenvuelven inmediatamente

Referencias devueltas por array y accesos a la propiedad se desenvuelven ahora como parte del acceso. Esto significa que ya no es posible modificar la referencia entre el acceso y el uso del valor de acceso:

<?php
$arr = [1];
$ref =& $arr[0];
var_dump($arr[0] + ($arr[0] = 2));
// Previously: int(4), Now: int(3)
?>
Esto hace que el comportamientos de las referencias y no referencias sea consistente. Por favor note que la lectura y escritura de un valor dentro de una sola expresión permanece como un comportamiento indefinido y puede cambiar de nuevo en el futuro.

Argumento Unpacking de Traversables con claves no enteras ya no se permiten

Argumento unpacking dejó de funcionar con Traversables con las claves no enteras. El siguiente código funcionó en PHP 5.6-7.2 por accidente.

<?php
function foo(...$args) {
    var_dump($args);
}
function gen() {
    yield 1.23 => 123;
}
foo(...gen());
?>

Varios

La utilidad ext_skel ha sido completamente rediseñada con nuevas opciones y algunas opciones antiguas eliminadas. Ahora está escrito en PHP y no tiene dependencias externas.

Soporte para el BeOS ha sido retirado.

Excepciones lanzadas debido a la conversión automática de advertencias a excepciones en modo EH_THROW (e.j. algunas excepciones DateTime) ya no ocupan el estado error_get_last(). Como tal, ahora funcionan de la misma manera que las excepciones lanzadas manualmente.

TypeError ahora informa de tipos erróneos como int y bool en lugar de integer y boolean, respectivamente.

Variables no definidas pasadas a compact() será ahora reportado como un aviso.

getimagesize() y funciones relacionadas ahora reportan el tipo mime de las imágenes BMP como image/bmp en lugar de image/x-ms-bmp, ya que el primero ha sido registrado en la IANA (véase » RFC 7903).

stream_socket_get_name() devolverá ahora las direcciones IPv6 envueltas entre paréntesis. Por ejemplo "[::1]:1337" será devuelto en lugar de "::1:1337".

BCMath Matemáticas de Precisión Arbitraria

Todas las advertencias lanzadas por las funciones BCMath son ahora usadas por el manejo de errores de PHP. Anteriormente algunas advertencias han sido escritas directamente a stderr.

bcmul() y bcpow() ahora devuelven los números con la escala solicitada. Anteriormente, los números devueltos pueden haber omitido los ceros decimales.

IMAP, POP3 y NNTP

Los inicio de sesión rsh/ssh están desactivados por defecto. Use imap.enable_insecure_rsh si quiere habilitarlos. Tenga en cuenta que la biblioteca IMAP no filtra los nombres de los buzones antes de pasarlos al comando rsh/ssh, pasando así datos no confiables a esta función con rsh/ssh habilitado es inseguro.

Multibyte String

Debido al soporte añadido a las capturas nombradas, mb_ereg_*() los patrones que utilizan las capturas nombradas se comportarán de forma diferente. En particular las capturas nombradas formarán parte de las coincidencias y mb_ereg_replace() interpretará sintaxis adicional. Véase Capturas Nombradas para más información.

Extensión mejorada de MySQL

Las declaraciones preparadas ahora reportan correctamente los segundos fraccionarios para DATETIME, TIME y TIMESTAMP columnas con especificador de decimales (e.j. TIMESTAMP(6) cuando se usan microsegundos). Anteriormente, la parte de los segundos fraccionarios fue simplemente omitida de los valores devueltos.

Funciones MySQL (PDO_MYSQL)

Las declaraciones preparadas ahora reportan correctamente los segundos fraccionarios para DATETIME, TIME y TIMESTAMP columnas con especificador de decimales (e.j. TIMESTAMP(6) cuando se usa microsegundos). Anteriormente, la parte de los segundos fraccionarios fue simplemente omitida de los valores devueltos. Por favor tenga en cuenta que esto sólo afecta a la utilización de PDO_MYSQL con los preparados emulados apagados (e.j. usando la funcionalidad de la preparación nativa). Las declaraciones que utilizan conexiones que tienen PDO::ATTR_EMULATE_PREPARES=true (que es el valor por defecto) no se vieron afectados por el fallo arreglado y ya han obtenido los valores de segundos fraccionarios adecuados al motor.

Reflection

La exportación Reflection a string utiliza ahora int y bool en lugar de integer y boolean, respectivamente.

Biblioteca estándar de PHP (SPL)

Si un autocargador SPL lanza una excepción, los siguientes autocargadores no serán ejecutados. Anteriormente todos los autocargadores eran ejecutados y las excepciones estaban encadenadas.

SimpleXML

Las operaciones matemáticas con objetos SimpleXML tratarán ahora el texto como un integer o float, lo que sea más apropieado. Anteriormente los valores se trataban como integers incondicionalmente.


Características obsoletas

Núcleo PHP

Constantes insensibles a mayúsculas y minúsculas

La declaración de constantes insensibles a las mayúsculas y minúsculas ha quedado obsoleta. Pasando true como el tercer argumento a define() generará ahora una advertencia de deprecación. El uso de constantes insensibles a las mayúsculas y minúsculas con un caso que

Namespaced assert()

Declarando una función llamada assert() dentro de un espacio de nombres es obsoleto. La función assert() está sujeta a un manejo especial por parte del motor, lo que puede dar lugar a un comportamiento inconsistente al definir una función con el mismo nombre.

Buscando Strings en una aguja sin string

Pasar una aguja sin string a las funciones de búsqueda de string es obsoleto. En el futuro la aguja será interpretada como un string en lugar de un punto de código ASCII. Dependiendo del comportamiento deseado, debe lanzar la aguja explícitamente al string o realizar un llamado explícito a chr(). Las siguientes funciones se ven afectadas:

  • strpos()
  • strrpos()
  • stripos()
  • strripos()
  • strstr()
  • strchr()
  • strrchr()
  • stristr()

Strip-Tags Streaming

La función fgetss() y el filtro stream string.strip_tags son obsoletos. Esto también afecta al método SplFileObject::fgetss() y la función gzgetss().

Filtrado de datos

El uso explícito de las constantes FILTER_FLAG_SCHEME_REQUIRED y FILTER_FLAG_HOST_REQUIRED es ahora obsoleto; ambos están implícitos para FILTER_VALIDATE_URL de todos modos.

Procesamiento de imágenes y GD

image2wbmp() ha quedado obsoleta.

Funciones de internacionalización

El uso de la forma Normalizer::NONE lanza una advertencia de obsoleto, si PHP es enlazado con ICU = 56.

Multibyte String

El siguiente alias indocumentado mbereg_*() ha sido desaprobado. Use las correspondientes variantes mb_ereg_*() en su lugar.

  • mbregex_encoding()
  • mbereg()
  • mberegi()
  • mbereg_replace()
  • mberegi_replace()
  • mbsplit()
  • mbereg_match()
  • mbereg_search()
  • mbereg_search_pos()
  • mbereg_search_regs()
  • mbereg_search_init()
  • mbereg_search_getregs()
  • mbereg_search_getpos()
  • mbereg_search_setpos()

Funciones ODBC y DB2 (PDO_ODBC)

La configuración ini pdo_odbc.db2_instance_name ha sido formalmente desaprobada. Está obsoleto en la documentación a partir de PHP 5.1.1.


Other Changes

PHP Core

Set(raw)cookie accepts $option Argument

setcookie() and setrawcookie() now also support the following signature:

setcookie ( string $name , string $value = "" , array $options = [] ) : bool
where $options is an associative array which may have any of the keys "expires", "path", "domain", "secure", "httponly" and "samesite".

New Syslog ini Directives

The following ini Directives have been added to customize logging, if error_log is set to syslog:

syslog.facility
Specifies what type of program is logging the message.
syslog.filter
Specifies the filter type to filter the logged messages. There are three supported filter types - all, no-ctrl and ascii.
syslog.ident
Specifies the ident string which is prepended to every message.

Garbage Collection

The cyclic GC has been enhanced, which may result in considerable performance improvements.

Miscellaneous

var_export() now exports stdClass objects as an array cast to an object ((object) array( ... )), rather than using the nonexistent method stdClass::__setState().

debug_zval_dump() was changed to display recursive arrays and objects in the same way as var_dump(). Now, it doesn't display them twice.

array_push() and array_unshift() can now also be called with a single argument, which is particularly convenient wrt. the spread operator.

Interactive PHP Debugger

The unused constants PHPDBG_FILE, PHPDBG_METHOD, PHPDBG_LINENO and PHPDBG_FUNC have been removed.

FastCGI Process Manager

The getallheaders() function is now also available.

Client URL Library

libcurl = 7.15.5 is now required.

Data Filtering

FILTER_VALIDATE_FLOAT now also supports a thousand option, which defines the set of allowed thousand separator chars. The default ("',.") is fully backward compatible with former PHP versions.

FILTER_SANITIZE_ADD_SLASHES has been added as an alias of the magic_quotes filter (FILTER_SANITIZE_MAGIC_QUOTES). The magic_quotes filter is subject to removal in future versions of PHP.

FTP

The default transfer mode has been changed to binary.

Internationalization Functions

Normalizer::NONE is deprecated, when PHP is linked with ICU = 56.

Introduced Normalizer::FORM_KC_CF as Normalizer::normalize() argument for NFKC_Casefold normalization; available when linked with ICU = 56.

JavaScript Object Notation

A new flag has been added, JSON_THROW_ON_ERROR, which can be used with json_decode() or json_encode() and causes these functions to throw the new JsonException upon an error, instead of setting the global error state that is retrieved with json_last_error() and json_last_error_msg(). JSON_PARTIAL_OUTPUT_ON_ERROR takes precedence over JSON_THROW_ON_ERROR.

Multibyte String

The configuration option --with-libmbfl is no longer available.

ODBC (Unified)

Support for ODBCRouter and Birdstep including the birdstep.max_links ini directive has been removed.

OPcache

The opcache.inherited_hack ini directive has been removed. The value has already been ignored since PHP 5.3.0.

OpenSSL

The min_proto_version and max_proto_version ssl stream options as well as related constants for possible TLS protocol values have been added.

Regular Expressions (Perl-Compatible)

The PCRE extension has been upgraded to PCRE2, which may cause minor behavioral changes (for instance, character ranges in classes are now more strictly interpreted), and augments the existing regular expression syntax.

preg_quote() now also escapes the '#' character.

Microsoft SQL Server and Sybase Functions (PDO_DBLIB)

The attribute PDO::DBLIB_ATTR_SKIP_EMPTY_ROWSETS to enable automatic skipping of empty rowsets has been added.

The PDO::DBLIB_ATTR_TDS_VERSION attribute which exposes the TDS version has been added.

DATETIME2 columns are now treated like DATETIME columns.

SQLite Functions (PDO_SQLITE)

SQLite3 databases can now be opened in read-only mode by setting the new PDO::SQLITE_ATTR_OPEN_FLAGS attribute to PDO::SQLITE_OPEN_READONLY.

Session Handling

session_set_cookie_params() now also supports the following signature:

session_set_cookie_params ( array $options ) : bool
where $options is an associative array which may have any of the keys "lifetime", "path", "domain", "secure", "httponly" and "samesite". Accordingly, the return value of session_get_cookie_params() now also has an element with the key "samesite". Furthermore, the new session.cookie_samesite ini option to set the default of the SameSite directive for cookies has been added. It defaults to "" (empty string), so no SameSite directive is set. Can be set to "Lax" or "Strict", which sets the respective SameSite directive.

Tidy

Building against » tidyp is now also supported transparently. Since tidyp offers no API to get the release date, tidy_get_release() and tidy::getRelease() return 'unknown' in this case.

XML Parser

The return value of the xml_set_external_entity_ref_handler() callback is no longer ignored if the extension has been built against libxml. Formerly, the return value has been ignored, and parsing did never stop.

Zip

Building against the bundled libzip is discouraged, but still possible by adding --without-libzip to the configuration.

Zlib Compression

The zlib/level context option for the compress.zlib wrapper to facilitate setting the desired compression level has been added.


Soporte de Windows

Núcleo PHP

Más eliminación de archivos conforme con POSIX

Los descriptores de archivos son abiertos en modo compartido lectura/escritura/borrado por defecto. Esto mapea efectivamente la semántica de POSIX y permite eliminar los archivos con manejador en uso. No es 100% igual, algunas diferencias de plataforma todavía persisten. Después de la eliminación, la entrada del nombre del archivo es bloqueada, hasta que todos los manejadores abiertos estén cerrados.


Migración de PHP 7.1.x a PHP 7.2.x

Tabla de contenidos

  • New features
  • Nuevas funciones
  • Nuevas constantes globales
  • Cambios incompatibles hacia atrás
  • Características obsoletas en PHP 7.2.x
  • Otros cambios

Esta versión menor viene con varias características nuevas y algunas incompatibilidades que deberían ser probadas antes de cambiar de versión de PHP en entornos de producción.

Véanse también las guías de migración para versiones de PHP 7.0.x y 7.1.x.


New features

New object type

A new type, object, has been introduced that can be used for (contravariant) parameter typing and (covariant) return typing of any objects.

<?php

function test(object $obj) : object
{
    return new SplQueue();
}

test(new StdClass());

Extension loading by name

Shared extensions no longer require their file extension (.so for Unix or .dll for Windows) to be specified. This is enabled in the php.ini file, as well as in the dl() function.

Abstract method overriding

Abstract methods can now be overridden when an abstract class extends another abstract class.

<?php

abstract class A
{
    abstract function test(string $s);
}
abstract class B extends A
{
    // overridden - still maintaining contravariance for parameters and covariance for return
    abstract function test($s) : int;
}

Sodium is now a core extension

The modern Sodium cryptography library has now become a core extension in PHP.

For a complete function reference, see the Sodium chapter.

Password hashing with Argon2

Argon2 has been added to the password hashing API, where the following constants have been exposed:

  • PASSWORD_ARGON2I
  • PASSWORD_ARGON2_DEFAULT_MEMORY_COST
  • PASSWORD_ARGON2_DEFAULT_TIME_COST
  • PASSWORD_ARGON2_DEFAULT_THREADS

Extended string types for PDO

PDO's string type has been extended to support the national character type when emulating prepares. This has been done with the following constants:

  • PDO::PARAM_STR_NATL
  • PDO::PARAM_STR_CHAR
  • PDO::ATTR_DEFAULT_STR_PARAM

These constants are utilised by bitwise OR'ing them with PDO::PARAM_STR:

<?php

$db->quote('über', PDO::PARAM_STR | PDO::PARAM_STR_NATL);

Additional emulated prepares debugging information for PDO

The PDOStatement::debugDumpParams() method has been updated to include the SQL being sent to the DB, where the full, raw query (including the replaced placeholders with their bounded values) will be shown. This has been added to aid with debugging emulated prepares (and so it will only be available when emulated prepares are turned on).

Support for extended operations in LDAP

Support for EXOP has been added to the LDAP extension. This has been done by exposing the following functions and constants:

  • ldap_parse_exop()
  • ldap_exop()
  • ldap_exop_passwd()
  • ldap_exop_whoami()
  • LDAP_EXOP_START_TLS
  • LDAP_EXOP_MODIFY_PASSWD
  • LDAP_EXOP_REFRESH
  • LDAP_EXOP_WHO_AM_I
  • LDAP_EXOP_TURN

Address Information additions to the Sockets extension

The sockets extension now has the ability to lookup address information, as well as connect to it, bind to it, and explain it. The following four functions have been added for this:

  • socket_addrinfo_lookup()
  • socket_addrinfo_connect()
  • socket_addrinfo_bind()
  • socket_addrinfo_explain()

Parameter type widening

Parameter types from overridden methods and from interface implementations may now be omitted. This is still in compliance with LSP, since parameters types are contravariant.

<?php

interface A
{
    public function Test(array $input);
}

class B implements A
{
    public function Test($input){} // type omitted for $input
}

Allow a trailing comma for grouped namespaces

A trailing comma can now be added to the group-use syntax introduced in PHP 7.0.

<?php

use Foo\Bar\{
    Foo,
    Bar,
    Baz,
};

proc_nice() support on Windows

The proc_nice() function is now supported on Windows.

pack() and unpack() endian support

The pack() and unpack() functions now support float and double in both little and big endian.

Enhancements to the EXIF extension

The EXIF extension has been updated to support a much larger range of formats. This means that their format specific tags are now properly translated when parsing images with the exif_read_data() function. The following new formats are now supported:

  • Samsung
  • DJI
  • Panasonic
  • Sony
  • Pentax
  • Minolta
  • Sigma/Foveon
  • AGFA
  • Kyocera
  • Ricoh
  • Epson

The EXIF functions exif_read_data() and exif_thumbnail() now support passing streams as their first argument.

New features in PCRE

  • The J modifier for setting PCRE_DUPNAMES has been added.

SQLite3 allows writing BLOBs

SQLite3::openBlob() now allows to open BLOB fields in write mode; formerly only read mode was supported.

Oracle OCI8 Transparent Application Failover Callbacks

Support for Oracle Database Transparent Application Failover (TAF) callbacks has been added. TAF allows PHP OCI8 applications to automatically reconnect to a preconfigured database when a connection is broken. The new TAF callback support allows PHP applications to monitor and control reconnection during failover.

Enhancements to the ZIP extension

Read and write support for encrypted archives has been added (requires libzip 1.2.0).

The ZipArchive class now implements the Countable interface.

The zip:// stream now accepts a 'password' context option.


Nuevas funciones

Núcleo PHP

  • stream_isatty()
  • sapi_windows_vt100_support()

SPL

  • spl_object_id()

DOM

  • DomNodeList::count()
  • DOMNamedNodeMap::count()

FTP

  • ftp_append()

GD

  • imagesetclip()
  • imagegetclip()
  • imageopenpolygon()
  • imageresolution()
  • imagecreatefrombmp()
  • imagebmp()

Hash

  • hash_hmac_algos()

LDAP

  • ldap_parse_exop()
  • ldap_exop()
  • ldap_exop_passwd()
  • ldap_exop_whoami()

String Multibyte

  • mb_chr()
  • mb_ord()
  • mb_scrub()

Oracle OCI8

  • oci_register_taf_callback()
  • oci_unregister_taf_callback()

Sockets

  • socket_addrinfo_lookup()
  • socket_addrinfo_connect()
  • socket_addrinfo_bind()
  • socket_addrinfo_explain()

Sodium

  • sodium_add()
  • sodium_bin2hex()
  • sodium_compare()
  • sodium_crypto_aead_aes256gcm_decrypt()
  • sodium_crypto_aead_aes256gcm_encrypt()
  • sodium_crypto_aead_aes256gcm_is_available()
  • sodium_crypto_aead_aes256gcm_keygen()
  • sodium_crypto_aead_chacha20poly1305_decrypt()
  • sodium_crypto_aead_chacha20poly1305_encrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen()
  • sodium_crypto_aead_chacha20poly1305_keygen()
  • sodium_crypto_auth_keygen()
  • sodium_crypto_auth_verify()
  • sodium_crypto_auth()
  • sodium_crypto_box_keypair_from_secretkey_and_publickey()
  • sodium_crypto_box_keypair()
  • sodium_crypto_box_open()
  • sodium_crypto_box_publickey_from_secretkey()
  • sodium_crypto_box_publickey()
  • sodium_crypto_box_seal_open()
  • sodium_crypto_box_seal()
  • sodium_crypto_box_secretkey()
  • sodium_crypto_box_seed_keypair()
  • sodium_crypto_box()
  • sodium_crypto_generichash_final()
  • sodium_crypto_generichash_init()
  • sodium_crypto_generichash_keygen()
  • sodium_crypto_generichash_update()
  • sodium_crypto_generichash()
  • sodium_crypto_kdf_derive_from_key()
  • sodium_crypto_kdf_keygen()
  • sodium_crypto_kx_client_session_keys()
  • sodium_crypto_kx_keypair()
  • sodium_crypto_kx_publickey()
  • sodium_crypto_kx_secretkey()
  • sodium_crypto_kx_seed_keypair()
  • sodium_crypto_kx_server_session_keys()
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify()
  • sodium_crypto_pwhash_scryptsalsa208sha256_str()
  • sodium_crypto_pwhash_scryptsalsa208sha256()
  • sodium_crypto_pwhash_str_verify()
  • sodium_crypto_pwhash_str()
  • sodium_crypto_pwhash()
  • sodium_crypto_scalarmult_base()
  • sodium_crypto_scalarmult()
  • sodium_crypto_secretbox_keygen()
  • sodium_crypto_secretbox_open()
  • sodium_crypto_secretbox()
  • sodium_crypto_shorthash_keygen()
  • sodium_crypto_shorthash()
  • sodium_crypto_sign_detached()
  • sodium_crypto_sign_ed25519_pk_to_curve25519()
  • sodium_crypto_sign_ed25519_sk_to_curve25519()
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey()
  • sodium_crypto_sign_keypair()
  • sodium_crypto_sign_open()
  • sodium_crypto_sign_publickey_from_secretkey()
  • sodium_crypto_sign_publickey()
  • sodium_crypto_sign_secretkey()
  • sodium_crypto_sign_seed_keypair()
  • sodium_crypto_sign_verify_detached()
  • sodium_crypto_sign()
  • sodium_crypto_stream_keygen()
  • sodium_crypto_stream_xor()
  • sodium_crypto_stream()
  • sodium_hex2bin()
  • sodium_increment()
  • sodium_memcmp()
  • sodium_memzero()
  • sodium_pad()
  • sodium_unpad()

ZIP

  • ZipArchive::count()
  • ZipArchive::setEncryptionName()
  • ZipArchive::setEncryptionIndex()


Nuevas constantes globales

Núcleo de PHP

  • PHP_FLOAT_DIG
  • PHP_FLOAT_EPSILON
  • PHP_FLOAT_MIN
  • PHP_FLOAT_MAX
  • PHP_OS_FAMILY

Información de fichero

  • FILEINFO_EXTENSION

JSON

  • JSON_INVALID_UTF8_IGNORE
  • JSON_INVALID_UTF8_SUBSTITUTE

GD

  • IMG_EFFECT_MULTIPLY
  • IMG_BMP

LDAP

  • LDAP_EXOP_START_TLS
  • LDAP_EXOP_MODIFY_PASSWD
  • LDAP_EXOP_REFRESH
  • LDAP_EXOP_WHO_AM_I
  • LDAP_EXOP_TURN

'Hash' de contraseñas

  • PASSWORD_ARGON2I
  • PASSWORD_ARGON2_DEFAULT_MEMORY_COST
  • PASSWORD_ARGON2_DEFAULT_TIME_COST
  • PASSWORD_ARGON2_DEFAULT_THREADS

PCRE

  • PREG_UNMATCHED_AS_NULL

PDO

  • PDO::PARAM_STR_NATL
  • PDO::PARAM_STR_CHAR
  • PDO::ATTR_DEFAULT_STR_PARAM

Sodium

  • SODIUM_LIBRARY_VERSION
  • SODIUM_LIBRARY_MAJOR_VERSION
  • SODIUM_LIBRARY_MINOR_VERSION
  • SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES
  • SODIUM_CRYPTO_AUTH_BYTES
  • SODIUM_CRYPTO_AUTH_KEYBYTES
  • SODIUM_CRYPTO_BOX_SEALBYTES
  • SODIUM_CRYPTO_BOX_SECRETKEYBYTES
  • SODIUM_CRYPTO_BOX_PUBLICKEYBYTES
  • SODIUM_CRYPTO_BOX_KEYPAIRBYTES
  • SODIUM_CRYPTO_BOX_MACBYTES
  • SODIUM_CRYPTO_BOX_NONCEBYTES
  • SODIUM_CRYPTO_BOX_SEEDBYTES
  • SODIUM_CRYPTO_KDF_BYTES_MIN
  • SODIUM_CRYPTO_KDF_BYTES_MAX
  • SODIUM_CRYPTO_KDF_CONTEXTBYTES
  • SODIUM_CRYPTO_KDF_KEYBYTES
  • SODIUM_CRYPTO_KX_SEEDBYTES
  • SODIUM_CRYPTO_KX_SESSIONKEYBYTES
  • SODIUM_CRYPTO_KX_PUBLICKEYBYTES
  • SODIUM_CRYPTO_KX_SECRETKEYBYTES
  • SODIUM_CRYPTO_KX_KEYPAIRBYTES
  • SODIUM_CRYPTO_GENERICHASH_BYTES
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MIN
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MAX
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13
  • SODIUM_CRYPTO_PWHASH_ALG_DEFAULT
  • SODIUM_CRYPTO_PWHASH_SALTBYTES
  • SODIUM_CRYPTO_PWHASH_STRPREFIX
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE
  • SODIUM_CRYPTO_SCALARMULT_BYTES
  • SODIUM_CRYPTO_SCALARMULT_SCALARBYTES
  • SODIUM_CRYPTO_SHORTHASH_BYTES
  • SODIUM_CRYPTO_SHORTHASH_KEYBYTES
  • SODIUM_CRYPTO_SECRETBOX_KEYBYTES
  • SODIUM_CRYPTO_SECRETBOX_MACBYTES
  • SODIUM_CRYPTO_SECRETBOX_NONCEBYTES
  • SODIUM_CRYPTO_SIGN_BYTES
  • SODIUM_CRYPTO_SIGN_SEEDBYTES
  • SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES
  • SODIUM_CRYPTO_SIGN_SECRETKEYBYTES
  • SODIUM_CRYPTO_SIGN_KEYPAIRBYTES
  • SODIUM_CRYPTO_STREAM_NONCEBYTES
  • SODIUM_CRYPTO_STREAM_KEYBYTES

Zip

  • ZipArchive::EM_NONE
  • ZipArchive::EM_AES_128
  • ZipArchive::EM_AES_192
  • ZipArchive::EM_AES_256


Cambios incompatibles hacia atrás

Evitar que number_format() devuelva el cero negativo

Anteriormente, era posible que la función number_format() devolviera -0. Aunque esto es perfectamente válido de acuerdo con la especificación de punto flotante IEEE 754, esta peculiaridad no era deseable para mostrar los números formateados en una forma legible para los humanos.

<?php

var_dump(number_format(-0.01)); // now outputs string(1) "0" instead of string(2) "-0"

Convertir las claves numéricas de objetos y arrays

Las claves numéricas ahora se manejan mejor cuando se hacen arrays de objetos y objetos en arrays (ya sea de un modo explícito o por settype()).

Esto significa que las claves de números integer (o números integer en string) de los array que están siendo lanzados a los objetos son ahora accesibles:

<?php

// array to object
$arr = [0 => 1];
$obj = (object)$arr;
var_dump(
    $obj,
    $obj->{'0'}, // ahora accesible
    $obj->{0} // ahora accesible
);

El resultado del ejemplo sería:

object(stdClass)#1 (1) {
  ["0"]=>    // la clave string ahora, en lugar de la clave de los números integer
  int(1)
}
int(1)
int(1)

Y las claves de números enteros (o string de números enteros) de los objetos que están siendo lanzados a los array son ahora accesibles:

<?php

// object to array
$obj = new class {
    public function __construct()
    {
        $this->{0} = 1;
    }
};
$arr = (array)$obj;
var_dump(
    $arr,
    $arr[0], // ahora accesible
    $arr['0'] // ahora accesible
);

El resultado del ejemplo sería:

array(1) {
  [0]=>    // clave integer ahora, en lugar de la clave de string
  int(1)
}
int(1)
int(1)

No se permite pasar null a get_class()

Anteriormente, pasar null a la función get_class() daría a conocer el nombre de la clase adjunta. Este comportamiento ya ha sido eliminado, donde se emitirá un E_WARNING en su lugar. Para lograr el mismo comportamiento que antes, el argumento debe ser simplemente omitido.

Advertencia al contar los tipos no contables

Una advertencia E_WARNING se emitirá ahora cuando se intente contar (count()) tipos no contables (esto incluye la función alias sizeof()).

<?php

var_dump(
    count(null), // NULL si no es contable
    count(1), // integers no son contables
    count('abc'), // strings no son contables
    count(new stdclass), // objetos que no implementen la interfaz Countable no son contables
    count([1,2]) // arrays son contables
);

El resultado del ejemplo sería:

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d
int(0)
int(1)
int(1)
int(1)
int(2)

Mover ext/hash de los recursos a los objetos

Como parte de la migración a largo plazo lejos de los recursos, la extensión Hash se ha actualizado para utilizar objetos en lugar de recursos. El cambio debería ser perfecto para los desarrolladores de PHP, excepto cuando is_resource() ha hecho comprobaciones (que necesitará ser actualizado a is_object() en su lugar).

Mejorar los valores por omisión de SSL/TLS

Se han hecho los siguientes cambios a los valores predeterminados:

  • tls:// ahora por omisión a TLSv1.0 o TLSv1.1 o TLSv1.2
  • ssl:// un alias de tls://
  • Las constantes STREAM_CRYPTO_METHOD_TLS_* por omisión a TLSv1.0 o TLSv1.1 + TLSv1.2, en lugar de sólo TLSv1.0

gettype() devolviendo valores en recursos cerrados

Anteriormente, usar gettype() en un recurso cerrado devolvería un string de "unknown type". Ahora, un string de "resource (closed)" es devuelto.

is_object() y __PHP_Incomplete_Class

Anteriormente, usar is_object() en la clase __PHP_Incomplete_Class devolvería false. Ahora, true será devuelto.

Promover el nivel de error de las constantes no definidas

Las referencias no cualificadas a constantes no definidas generarán ahora una advertencia E_WARNING (en vez de una E_NOTICE). En la próxima versión principal de PHP, generarán excepciones Error.

Soporte de Windows

Las versiones mínimas oficialmente soportadas de Windows son ahora Windows 7/Server 2008 R2.

Comprobación de los valores de propiedad predeterminados de los rasgos (traits)

Las comprobaciones de compatibilidad de los valores de propiedad de los rasgos por omisión ya no se realizarán.

object para los nombres de las clases

El nombre object fue previamente reservado en PHP 7.0. Esto ahora se ha reservado con fuerza, prohibiendo su uso como nombre de clase, rasgo o nombre de interfaz.

Soporte de NetWare

El soporte para NetWare ha sido eliminado.

array_unique() con SORT_STRING

Mientras que array_unique() con SORT_STRING antes copiaba el array y eliminaba los elementos no únicos (sin empaquetar el array después), ahora se construye un nuevo array añadiendo los elementos únicos. Esto puede dar lugar a diferentes índices numéricos.

Cambios con floats en la función bcmod()

La función bcmod() ya no trunca números fraccionarios a números enteros. Como tal, su comportamiento ahora sigue fmod(), en lugar del operador %. Por ejemplo bcmod('4', '3.5') ahora devuelve 0.5 en lugar de 1.

Funciones de hash y hash no criptográficas

Las funciones hash_hmac(), hash_hmac_file(), hash_pbkdf2(), y hash_init() (con HASH_HMAC) ya no aceptan los no criptográficos hashes.

Opciones de la función json_decode()

La opción de la función json_decode(), JSON_OBJECT_AS_ARRAY, es ahora usada si el segundo parámetro (asociativo) es null. Anteriormente, JSON_OBJECT_AS_ARRAY siempre fue ignorado.

Salida de rand() y mt_rand()

secuencias generadas por rand() y mt_rand() para una semilla específica puede diferir de PHP 7.1 en máquinas de 64 bits (debido a la fijación de un error de sesgo de módulo en la aplicación).

La eliminación de la configuración ini sql.safe_mode

La configuración ini sql.safe_mode ha sido eliminada.

Cambios a las funciones date_parse() y date_parse_from_format()

El elemento zone de el array devuelto por las funciones date_parse() y date_parse_from_format() ahora representan segundos en vez de minutos, y su signo está invertido. Por ejemplo -120 es ahora 7200.


Características obsoletas en PHP 7.2.x

Cadenas sin entrecomillar

Las cadenas sin entrecomillar que sean constantes globales inexistentes se convierten en cadenas de ellas mismas. Este comportamiento solía emitir una E_NOTICE, pero a partir de ahora emitirá una E_WARNING. En la siguiente versión mayor de PHP, se lanzará una excepción Error en su lugar.

<?php

var_dump(INEXISTENTE);

/* Output:
Warning: Use of undefined constant INEXISTENTE - assumed 'INEXISTENTE' (this will throw an Error in a future version of PHP) in %s on line %d
string(11) "INEXISTENTE"
*/

png2wbmp() and jpeg2wbmp()

Las funciones png2wbmp() y jpeg2wbmp() de la extensión GD se han marcado como obsoletas y serán borradas en la siguiente versión mayor de PHP.

Variante INTL_IDNA_VARIANT_2003

La extensión Intl ha marcado como obsoleta la variante INTL_IDNA_VARIANT_2003, que es actualmente usada como el valor por defecto de idn_to_ascii() y idn_to_utf8(). PHP 7.4 cambiará estos valores por defecto a INTL_IDNA_VARIANT_UTS46, y en la siguiente versión mayor de PHP borrará la variante INTL_IDNA_VARIANT_2003.

__autoload() method

The __autoload() method has been deprecated because it is inferior to spl_autoload_register() (due to it not being able to chain autoloaders), and there is no interoperability between the two autoloading styles.

Directiva ini track_errors y variable $php_errormsg

Cuando la directiva ini track_errors está activada, una variable $php_errormsg es creada en el ámbito local cuando ocurre un error no fatal. Dado que el método preferido de obtener ese tipo de información de errores es usando error_get_last(), esta característica ha sido marcada como obsoleta.

Función create_function()

Debido a los problemas de seguridad de esta función (siendo una envoltura de eval()), esta antigua función ha sido marcada como obsoleta. La alternativa preferida es usar funciones anónimas.

Directiva ini mbstring.func_overload

Debido a los problemas de interoperabilidad de funciones basadas en cadenas usadas en entornos con esta directiva activada, ha sido marcada como obsoleta.

Forzado a (unset)

Forzar cualquier expresión a este tipo siempre resulta en null, por lo que este tipo de forzado superfluo ha sido marcado como obsoleto.

parse_str() sin segundo argumento

Sin un segundo argumento para parse_str(), los parámetros de una cadena de consulta son establecidos en el ámbito local. Debido a los problemas de seguridad de ello, el uso de parse_str() sin un segundo parámetro ha sido marcado como obsoleto. Esta función siempre debe ser usada con dos argumentos, ya que el segundo argumento provoca que la cadena de consulta sea interpretada a un array.

Función gmp_random()

Esta función genera un número aleatorio dentro de rango que es calculado por un método no expuesto y dependiente de la plataforma. Por ello, esta función ha sido ahora marcado como obsoleto. El método preferido de generar un número aleatorio usando la extensión GMP extension es usando gmp_random_bits() y gmp_random_range().

Función each()

Esta función es mucho más lenta iterando que un foreach normal, y causa problemas de implementación con algunos cambios del lenguaje. Ha sido por tanto marcada como obsoleta.

assert() con una cadena como argumento

Usar assert() con una cadena como argumento requería que la cadena fuera eval()uada. Debido al potencial para ejecución remota de código, el uso de assert() con una cadena como argumento ha sido marcado como obsoleto en favor del uso de expresiones booleanas.

Argumento $errcontext de manejadores de errores

El argumento $errcontext contiene todas las variables locales del ámbito donde ocurrió el error. Debido a su poco uso, y los problemas que causa con optimizaciones internas, ha sido marcado como obsoleto. En su lugar, se debe usar un depurador para obtener información sobre las variables del ámbito local del lugar del error.

Función read_exif_data()

El alias read_exif_data() ha sido marcado como obsoleto. La función exif_read_data() debe ser usada en su lugar.


Otros cambios

El movimiento de utf8_encode() y utf8_decode()

Las funciones utf8_encode() y utf8_decode() se han movido ahora a la extensión estándar como funciones de string, mientras que antes la extensión XML era necesaria para que estuvieran disponibles.

Cambios a las funciones mail() y mb_sendmail()

El parámetro $additional_headers de mail() y mb_sendmail() ahora aceptan un array en vez de un string.

Soporte de LMDB

La extensión DBA ahora tiene soporte para LMDB.

Cambios en el sistema de compilación de PHP

  • Unix: Ahora se requiere Autoconf 2.64 o superior para compilar PHP.
  • Unix: el argumento de configuración --with-pdo-oci ya no necesita el número de versión del Cliente Instantáneo de Oracle.
  • Unix: el argumento de configuración --enable-gd-native-ttf ha sido eliminado. Esto no se usaba desde PHP 5.5.0.
  • Windows: el argumento de configuración --with-config-profile ha sido añadido. Esto puede ser usado para guardar configuraciones específicas, como el fichero mágico config.nice.bat.

Cambios a GD

  • imageantialias() está ahora también disponible si se compila con un sistema libgd.
  • imagegd() almacena las imágenes en color verdadero como imágenes en color verdadero. Anteriormente, eran convertidos en paleta.

Se movió MCrypt a PECL

La extensión MCrypt ha sido ahora movida fuera del núcleo a PECL. Dado que la libería mcrypt no ha recibido actualizaciones desde 2007, su uso es muy desaconsejado. En su lugar, o bien la extensión OpenSSL o Sodium pueden ser usadas.

session_module_name()

Pasar "user" la función session_module_name() ahora arroja un error de tipo E_RECOVERABLE_ERROR. Anteriormente, esto ha sido silenciosamente ignorado.


Migración de PHP 7.0.x a PHP 7.1.x

Tabla de contenidos

  • Nuevas características
  • Nuevas funciones
  • Nuevas constantes globales
  • Cambios retroincompatibles
  • Características obsoletas en PHP 7.1.x
  • Changed functions
  • Otros cambios
  • Soporte para Windows

Esta nueva versión menor viene con varias características nuevas y unas pocas incompatibilidades que deberían ser probadas antes de cambiar de versión de PHP en entornos de producción.

Véanse también las guías de migración para versiones de PHP 7.0.x.


Nuevas características

Tipos 'nullable'

Las declaraciones de tipos para parámetros y valores de retorno ahora se pueden marcar como «nullable» prefijando el nombre del tipo con un signo de cierre de interrogación. Esto significa que, así como el tipo especificado, se puede pasar null como un argumento, o ser devuelto como un valor, respectivamente.

<?php

function testReturn(): ?string
{
    return 'elePHPant';
}

var_dump(testReturn());

function testReturn(): ?string
{
    return null;
}

var_dump(testReturn());

function test(?string $name)
{
    var_dump($name);
}

test('elePHPant');
test(null);
test();

El resultado del ejemplo sería:

string(10) "elePHPant"
NULL
string(10) "elePHPant"
NULL
Uncaught Error: Too few arguments to function test(), 0 passed in...

Funciones 'void'

Se ha introducido un tipo de retorno, void. Las funciones declaradas con 'void' como su tipo de retorno deben o bien omitir su sentencia 'return' totalmente, o utilizar una sentencia 'return' vacía. null no es un valor de retorno válido para una función 'void'.

<?php
function intercambiar(&$izquierdo, &$derecho) : void
{
    if ($izquierdo === $derecho) {
        return;
    }

    $tmp = $izquierdo;
    $izquierdo = $derecho;
    $derecho = $tmp;
}

$a = 1;
$b = 2;
var_dump(intercambiar($a, $b), $a, $b);

El resultado del ejemplo sería:

null
int(2)
int(1)

El uso del valor de retorno de una función 'void' simplemente se evalúa a null, sin emitir advertencias. Las razón de esto es porque las advertencias implicarían el uso de funciones genéricas de orden mayor.

Desestructuración de arrays simétricos

La sintaxis abreviada de array ([]) se puede usar ahora para desestructurar arrays para asignaciones (incluyendo dentro de foreach) como alternativa a la sintaxis list() existente, la cual aún se admite.

<?php
$datos = [
    [1, 'Tom'],
    [2, 'Fred'],
];

// Estilo de list()
list($id1, $nombre1) = $datos[0];

// Estilo de []
[$id1, $list] = $datos[0];

// Estilo de list()
foreach ($datos as list($id, $nombre)) {
    // aquí va la lógica con $id y $nombre
}

// Estilo de []
foreach ($datos as [$id, $nombre]) {
    // aquí va la lógica con $id y $nombre
}

Visibilidad de las constantes de clase

Se ha añadido soporte para especificar la visibilidad de constantes de clase.

<?php
class ConstDemo
{
    const PUBLIC_CONST_A = 1;
    public const PUBLIC_CONST_B = 2;
    protected const PROTECTED_CONST = 3;
    private const PRIVATE_CONST = 4;
}

El seudotipo iterable

Se ha introducido un nuevo seudotipo (similar a callable) llamado iterable. Se puede utilizar en parámetros y tipos de retorno, donde acepta tanto arrays u objetos que implementen la interfaz Traversable. Con respecto a la subtipificación, los tipos de parámetros de clases hijas podrían ampliar una declaración de la madre de array o Traversable a iterable. Con los tipos de retorno, las clases hijas podrían reducir un tipo de retorno de la madre de iterable a array o un objeto que implemente Traversable.

<?php
function iterator(iterable $iter)
{
    foreach ($iter as $val) {
        //
    }
}

Manejo de multicaptura de excepciones

Ahora se pueden especificar múltiples excepciones por bloque catch con el carácter tubería (|). Esto es útil para cuando diferentes excepciones de diferentes jerarquías de clases son manejadas como la misma.

<?php
try {
    // algo de código
} catch (FirstException | SecondException $e) {
    // manejar la primera y segunda excepción
}

Soporte para claves en list()

Ahora se pueden especificar claves en list(), o en su nueva sintaxis abreviada []. Esto habilita la desestructuración de arrays con claves no enteras o no secuenciales.

<?php
$datos = [
    ["id" => 1, "nombre" => 'Tom'],
    ["id" => 2, "nombre" => 'Fred'],
];

// Estilo de list()
list("id" => $id1, "nombre" => $nombre1) = $datos[0];

// Estilo de []
["id" => $id1, "nombre" => $nombre1] = $datos[0];

// Estilo de list()
foreach ($datos as list("id" => $id, "nombre" => $nombre)) {
    // aquí va la lógica con $id y $nombre
}

// Estilo de []
foreach ($datos as ["id" => $id, "nombre" => $nombre]) {
    // aquí va la lógica con $id y $nombre
}

Soporte para índices negativos de cadenas

Se ha añadido soporte para índices negativos de cadenas a las funciones de manipulación de cadenas que acepten índices, así como a la indexación de cadenas con [] o {}. En tales casos, un índice negativo se interpreta como un índice desde el final de la cadena.

<?php
var_dump("abcdef"[-2]);
var_dump(strpos("aabbcc", "b", -3));

El resultado del ejemplo sería:

string (1) "e"
int(3)

Los índices negativos de cadenas y arrays ahora tambíen se admiten en la sintaxis del paso de una variable dentro de cadenas.

<?php
$string = 'bar';
echo "The last character of '$string' is '$string[-1]'.\n";
?>

El resultado del ejemplo sería:

The last character of 'bar' is 'r'.

Soporte para AEAD en ext/openssl

Se ha añadido soporte para AEAD (modos GCM y CCM) ampliando las funciones openssl_encrypt() y openssl_decrypt() con parámetros adicionales.

Conversión de 'callables' Closure con Closure::fromCallable()

Se ha introducido un nuevo método estático a la clase Closure para poder convertir de forma sencilla callables a objetos Closure.

<?php
class Test
{
    public function exposeFunction()
    {
        return Closure::fromCallable([$this, 'privateFunction']);
    }

    private function privateFunction($param)
    {
        var_dump($param);
    }
}

$privFunc = (new Test)->exposeFunction();
$privFunc('some value');

El resultado del ejemplo sería:

string(10) "some value"

Manejo de señales asíncronas

Se ha introducido una nueva función llamada pcntl_async_signals() para habilitar el manejo de señales asíncronas sin el empleo de «ticks» (lo cual introduce mucha sobrecarga).

<?php
pcntl_async_signals(true); // turn on async signals

pcntl_signal(SIGHUP,  function($sig) {
    echo "SIGHUP\n";
});

posix_kill(posix_getpid(), SIGHUP);

El resultado del ejemplo sería:

SIGHUP

Soporte para 'push' del servidor HTTP/2 en ext/curl

Se ha añadido soporte para 'push' del servidor a la extensión CURL (requiere la versión 7.46 y superior). Esto se puede aprovechar a través de la función curl_multi_setopt() con la nueva constante CURLMOPT_PUSHFUNCTION. Las constantes CURL_PUSH_OK y CURL_PUSH_DENY también han sido añadidas, por lo que la ejecución de la retrollamada 'push' del servidor pueda ser aprobada o denegada.


Nuevas funciones

Núcleo de PHP

  • sapi_windows_cp_get()
  • sapi_windows_cp_set()
  • sapi_windows_cp_conv()
  • sapi_windows_cp_is_utf8()

Closure

  • Closure::fromCallable()

CURL

  • curl_multi_errno()
  • curl_share_errno()
  • curl_share_strerror()

OpenSSL

  • openssl_get_curve_names()

Session

  • session_create_id()
  • session_gc()

SPL

  • is_iterable()

PCNTL

  • pcntl_async_signals()
  • pcntl_signal_get_handler()


Nuevas constantes globales

Constantes predefinidas del núcleo

  • PHP_FD_SETSIZE

CURL

  • CURLMOPT_PUSHFUNCTION
  • CURL_PUSH_OK
  • CURL_PUSH_DENY

Filtro de datos

  • FILTER_FLAG_EMAIL_UNICODE

Procesamiento de imágenes y GD

  • IMAGETYPE_WEBP

JSON

  • JSON_UNESCAPED_LINE_TERMINATORS

LDAP

  • LDAP_OPT_X_SASL_NOCANON
  • LDAP_OPT_X_SASL_USERNAME
  • LDAP_OPT_X_TLS_CACERTDIR
  • LDAP_OPT_X_TLS_CACERTFILE
  • LDAP_OPT_X_TLS_CERTFILE
  • LDAP_OPT_X_TLS_CIPHER_SUITE
  • LDAP_OPT_X_TLS_KEYFILE
  • LDAP_OPT_X_TLS_RANDOM_FILE
  • LDAP_OPT_X_TLS_CRLCHECK
  • LDAP_OPT_X_TLS_CRL_NONE
  • LDAP_OPT_X_TLS_CRL_PEER
  • LDAP_OPT_X_TLS_CRL_ALL
  • LDAP_OPT_X_TLS_DHFILE
  • LDAP_OPT_X_TLS_CRLFILE
  • LDAP_OPT_X_TLS_PROTOCOL_MIN
  • LDAP_OPT_X_TLS_PROTOCOL_SSL2
  • LDAP_OPT_X_TLS_PROTOCOL_SSL3
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_0
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_1
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
  • LDAP_OPT_X_TLS_PACKAGE
  • LDAP_OPT_X_KEEPALIVE_IDLE
  • LDAP_OPT_X_KEEPALIVE_PROBES
  • LDAP_OPT_X_KEEPALIVE_INTERVAL

PostgreSQL

  • PGSQL_NOTICE_LAST
  • PGSQL_NOTICE_ALL
  • PGSQL_NOTICE_CLEAR

SPL

  • MT_RAND_PHP


Cambios retroincompatibles

Lanzamiento de una excepción al pasar muy pocos argumentos a una función

Anteriormente se emitía una advertencia al invocar funciones definidas por el usuario con muy pocos argumentos. Ahora, esta advertencia ha sido promovida a una excepción de tipo Error. Este cambio solamente se aplica a funciones definidas por el usuario, no a funciones internas. Por ejemplo:

<?php
function test($param){}
test();

El resultado del ejemplo sería algo similar a:

Fatal error: Uncaught ArgumentCountError: Too few arguments to function test(), 0 passed in %s on line %d and exactly 1 expected in %s:%d

Prohibición de llamadas dinámicas a funciones de introspección de alcance

Se han prohibido las llamadas dinámicas a ciertas funciones (de la forma $func() o array_map('extract', ...), etc.). Estas funciones bien inspeccionan o modifican otro ámbito, presentando así un comportamiento ambiguo y poco fiable. Las funciones son las siguientes:

  • assert() - con una cadena como primer argumento
  • compact()
  • extract()
  • func_get_args()
  • func_get_arg()
  • func_num_args()
  • get_defined_vars()
  • mb_parse_str() - con un argumento
  • parse_str() - con un argumento
<?php
(function () {
    $func = 'func_num_args';
    $func();
})();

El resultado del ejemplo sería:

Warning: Cannot call func_num_args() dynamically in %s on line %d

Nombres de clases, interfaces o rasgos no válidos

Los siguientes nombres no se pueden usar como nombres de clases, interfaces o rasgos:

  • void
  • iterable

Las conversiones de cadenas numéricas ahora respetan la notación científica

Las operaciones y conversiones de enteros en cadenas de numéricas ahora respetan la notación científica. Esto también incluye la operación 'cast' a (int) y l as siguientes funciones: intval() (donde la base es 10), settype(), decbin(), decoct(), y dechex().

Correcciones al algoritmo mt_rand()

mt_rand() ahora utilizará predeterminadamente la versión corregida del algoritmo Mersenne Twister. Si se confiaba en la salida determinista de mt_srand(), la constante MT_RAND_PHP con la capacidad de preservar la implementación antigua (incorrecta) mediante un segundo parámetro opcional adicional a mt_srand().

rand() es un alias de mt_rand() y srand() de mt_srand()

rand() y srand() ahora son alias de mt_rand() y mt_srand(), respectivamente. Esto significa que la salida de las siguientes funciones ha cambiado: rand(), shuffle(), str_shuffle(), y array_rand().

Rechazar el caracter de control de borrado ASCII en identificadores

El caracter de control de borrado ASCII (0x7F) ya no se puede usar en identificadores que no estén entrecomillados.

error_log cambia con el valor syslog

Si el ajuste ini de error_log se establece a syslog, los niveles de error de PHP se corresponden con los niveles de error de syslog. Esto ofrece un mayor diferenciación en los registros de errores, al contrario que el enfoque anterior, donde todos los errores eran registrados con el nivel 'notice' solamente.

No invocar a destructores en objetos incompletos

Ahora, los destructores nunca son invocados en objetos que lanzan una excepción durante la ejecución de su constructor. En versiones anteriores, este comportamiento dependía de si al objeto se le hacía referencia fuera del constructor (p.ej., mediante el rastreo de una excepción).

Manejo de call_user_func() de argumentos de referencia

call_user_func() ahora generará siempre una advertencia al llamar a funciones que esperan referencias como argumentos. Anteriormente esto dependía de si la llamada era totalmente cualificada.

Además, call_user_func() y call_user_func_array() ya no abortarán la llamada a la función es este caso. La advertencia de "expected reference" (se esperaba una referencia) será emitida, aunque la llamada procederá como siempre.

El operador de índice vacío ya no se admite más para cadenas

La aplicación del operador de índice vacío a una cadena (p.ej. $str[] = $x) lanza un error fatal en lugar de convertirla a un array silenciosamente.

Directivas ini eliminadas

Las siguientes directivas ini han sido eliminadas:

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

Cambio en la ordenación de arrays cuando los elementos son creados automáticamente durante asignaciones por referencia

El orden de los elementos de un array ha cambiado cuando estos elementos han sido creados automáticamente mediante una asignación por referencia. Por ejemplo:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

Salida del ejemplo anterior en PHP 7.0:

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

Salida del ejemplo anterior en PHP 7.1:

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

Ordenación de elementos iguales

El algoritmo de ordenación interno se ha mejorado, lo que podría resultar en una ordenación diferente de los elementos que se comparan como iguales.

Nota:

No confíe en el orden de elementos que se comparan como iguales; podría cambiar en cualquier momento.

Mensaje de error para los errores E_RECOVERABLE

El mensaje de error para errores E_RECOVERABLE ha cambiado de "Catchable fatal error" a "Recoverable fatal error".

Parámetro $options de unserialize()

El elemento allowed_classes del parámetro $options de unserialize() ahora está estrictamente tipificado, es decir, si se da un valor distinto a un array o un boolean, unserialize() devuelve false y emite un E_WARNING.

DateTime constructor incorporates microseconds

DateTime y DateTimeImmutable ahora incorporan adecuadamente microsegundos al ser construidos desde el momento actual, ya sea explícitamente o con una cadena relativa(p.ej., "first day of next month"). Esto significa que la simple comparación de dos instancias recién creadas ahora probablemente devuelva false en lugar de true:

<?php
new DateTime() == new DateTime();
?>

Conversión de errores fatales a excepciones Error

En la extensión Date, los datos de serialización inválidos para las clases DateTime o DatePeriod, o el fallo de inicialización de una zona horaria desde datos serializados, ahora lanzarán una excepción Error desde los métodos __wakeup() o __set_state(), en lugar de resultar en un error fatal.

En la extensión DBA, las funciones que modifican datos (como dba_insert()) ahora lanzarán una excepción Error en lugar de emitir un error fatal capturable si la clave no contiene exactamente dos elementos.

En la extensión DOM, un esquema inválido o contextos de validación RelaxNG ahora lanzarán una excepción Error en lugar de resultar en un error fatal. De manera similar, el intento de registrar una clase nodo que no extienda la clase base apropiada, o el intento de leer una propiedad inválida o escribir en una propiedad de solo lectura, también lanzará una excepción Error.

En la extensión IMAP, las direcciones de correo electrónica mayores de 16385 bytes lanzarán una excepción Error en lugar de resultar en un error fatal.

En la extensión Intl, el fallo al invocar al constructor padre en una clase que extiende Collator antes de invocar a los métodos padres ahora lanzará una excepción Error en lugar de resultar en un error fatal recuperable. También, clonar un objeto Transliterator ahora lanzará una excepción Error en caso de fallo al clonar el transliterador interno en lugar de resultar en un error fatal.

En la extensión LDAP, proporcionar un tipo de modificación desconocido a ldap_batch_modify() ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión bstring, las funciones mb_ereg() y mb_eregi() ahora lanzarán una excepción ParseError si se proporciona una expresión de PHP inválida y se emplea la opción 'e'.

En la extensión Mcrypt, las funciones mcrypt_encrypt() y mcrypt_decrypt() ahora lanzarán una excepción Error en lugar de resultar en un error fatal si mcrypt no puede ser inicializado.

En la extensión mysqli, el intento de leer una propiedad inválidad o escribir en una propiedad de solo lectura ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión Reflection, el fallo al recuperar un objeto de reflexión o recuperar una propiedad de un objeto ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión Session, los manejadores de sesiones propios que no devuelvan cadenas para los ID de sesción ahora lanzarán una excepción Error en lugar de resultar en un error fatal cuando una función sea invocada y deba generar un ID de sesión.

En la extensión SimpleXML, la creación de un atributo sin nombre o duplicado ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión SPL, el intento de clonar un objeto SplDirectory ahora lanzará una excepción Error en lugar de resultar en un error fatal. De forma simiarl, invocar a ArrayIterator::append() cuando se recorre un objeto también lanzará una excepción Error.

En la extensión estándar, la función assert(), al proporcionarle un argumento de cadena a su primer parámetro, ahora lanzará una excepción ParseError en lugar de resultar en un error fatal capturable si el código de PHP no es válido. De forma similar, invocar a forward_static_call() fuera del ámbito de una clase ahora también lanzará una excepción Error.

En la extensión Tidy, la creación manual de un objeto tidyNode ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión WDDX, una referencia circular al serializar ahora lanzará una excepción Error en lugar de resultar en un error fatal.

En la extensión XML-RPC, una referencia circular al serializar ahora lanzará una instancia de una excepción Error en lugar de resultar en un error fatal.

En la extensión Zip, el método ZipArchive::addGlob() ahora lanzará una excepción Error en lugar de resultar en un error fatal si el soporte para 'glob' no está disponible.

Las variables vinculadas léxicamente no pueden reutilizar nombres

Las variables vinculadas a un cierre mediante el constructor use no pueden utilizar el mismo nombre que cualquier superglobals, $this, o cualquier parámetro. Por ejemplo, todas estas definiciones de funciones resultarán en error fatal:

<?php
$f = function () use ($_SERVER) {};
$f = function () use ($this) {};
$f = function ($param) use ($param) {};

Cambio del tipo del parámetro de long2ip()

long2ip()() ahora espera un int en vez de un string.

Codificación y decodificación de JSON

El ajuste ini serialize_precision ahora controla la precisión de serialización al codificar 'doubles'.

La decodificación de una clave vacía ahora resulta en un nombre de propiedad vacío, en lugar de _empty_ como nombre de propiedad.

<?php
var_dump(json_decode(json_encode(['' => 1])));

El resultado del ejemplo sería algo similar a:

object(stdClass)#1 (1) {
  [""]=>
  int(1)
}

Al proporcionar la bandera JSON_UNESCAPED_UNICODE a json_encode(), las secuencias U+2028 y U+2029 ahora son escapadas.

Cambios en la semántica de los parámetros de mb_ereg() y mb_eregi()

El tercer parámetro de las funciones mb_ereg() y mb_eregi() (regs) ahora será establecido a un array vacío si no hubieron coincidencias. Anteriormente, el parametro era modificado.

Eliminación del soporte para el flujo sslv2

El flujo sslv2 se ha eliminado de OpenSSL.


Características obsoletas en PHP 7.1.x

ext/mcrypt

La extensión mcrypt fue declarada «abandonware» hace casi una década, y también era bastante compleja de utilizar. Por tanto, está obsoleta en favor de OpenSSL, y será eliminada del núcleo y puesta en PECL en PHP 7.2.

Opción 'eval' para mb_ereg_replace() y mb_eregi_replace()

El modificador de patrón e está obsoleto para las funciones mb_ereg_replace() y mb_eregi_replace().


Changed functions

PHP Core

  • getopt() tiene un tercer parámetro opcional que expone el índice del siguiente elemento de la lista de vectores de argumentos a procesar. Esto se hace mediante un parámetro por referencia.
  • getenv() ya no requiere su parámetro. Si se omite, serán devueltas las variables de entorno actuales como un array asociativo.
  • get_headers() ahora tiene un parámetro adicional a habilitar para el pase de contextos de flujo personalizados.
  • output_reset_rewrite_vars() ya no reinica variables de reescritura de URL de sesión.
  • parse_url() es ahora más restrictivo y da soporte a RFC3986.
  • unpack() ahora acepta un tercer parámetro opcional para especificar el índice desde el ue iniciar el desempaquetamiento.

File System

  • file_get_contents() ahora acepta un índice de búsqueda negativo si el flujo es buscable.
  • tempnam() ahora emite un aviso al recurrir al directorio temp del sistema.

JSON

  • json_encode() ahora acepta una nueva opción, JSON_UNESCAPED_LINE_TERMINATORS, para inhabilitar el escape de los caracteres U+2028 y U+2029 al proporcionar JSON_UNESCAPED_UNICODE.

Multibyte String

  • mb_ereg() ahora rechaza secuencias de bytes ilegales.
  • mb_ereg_replace() ahora rechaza secuencias de bytes ilegales.

PDO

  • PDO::lastInsertId() ahora desencadenará un error para PostgreSQL cuando nextval no ha sido llamado para la sesión actual (la conexión de postgres).

PostgreSQL

  • pg_last_notice() ahora acepta un parámetro opcional para especificar una operación. Esto se puede hacer con una de las siguientes constantes nuevas: PGSQL_NOTICE_LAST, PGSQL_NOTICE_ALL, o PGSQL_NOTICE_CLEAR.
  • pg_fetch_all() ahora acepta un segundo parámetro opcional para especificar el tipo de resultado (similar al tercer parámetro de pg_fetch_array()).
  • pg_select() ahora acepta un cuarto parámetro opcional para especificar el tipo de resultado (similar al tercer parámetro de pg_fetch_array()).


Otros cambios

Avisos y advertencias sobre aritmética con cadenas no inválidas

Se han introducido nuevos errores E_WARNING y E_NOTICE al forzar cadenas no válidas usando operadores que esperan número (+ - * / ** % << >> | & ^) o sus equivalentes de asignación. Se emite un E_NOTICE cuando la cadena comienza con un valor numérico pero contiene al final caracteres no numéricos, y se emite un E_WARNING cuando la cadena no contiene ningún valor numérico.

<?php
'1b' + 'algo';

El resultado del ejemplo sería:

Notice: A non well formed numeric value encountered in %s on line %d
Warning: A non-numeric value encountered in %s on line %d

Advertencia de desbordamiento de secuencia de escape octal

Anteriormente, las secuencias de escape de cadenas octales de tres octetos desbordaban silenciosamente. Ahora, siguen desbordando, pero se emite un E_WARNING.

<?php
var_dump("\500");

El resultado del ejemplo sería:

Warning: Octal escape sequence overflow \500 is greater than \377 in %s on line %d
string(1) "@"

Reparación de inconsistencias en $this

Pese a que $this está considerada un variable especial en PHP, carece de comprobaciones apropiadas para asegurarse de que no se usó como un nombre de variable o fue reasignada. Ahora, esto se ha rectificado para asegurarse de que $this no puede ser una variable definida por el usuario, reasignada a un valor diferente, o globalizada.

Generación de ID de sesión sin 'hash'

Los ID de sesión ya no utilzarán 'hash' en su generación. Este cambio provoca la eliminación de los cuatro siguientes ajustes ini:

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

Y la adición de los dos siguientes ajustes ini:

  • session.sid_length - define la longitud del ID de sesión, siendo 32 caracteres la predeterminada por retrocompatibilidad
  • session.sid_bits_per_character - define el número de bits a almacenar por carácter (esto es, aumenta el rango de caracteres que se pueden utilizar en el ID de sesión), siendo 4 el predeterminado por retrocompatibilidad

Cambios en el manejo del fichero INI

precision

Si el valor se establece a -1, se usará el modo dtoa 0. El valor predeterminado aún es 14.

serialize_precision

Si el valor se establece a -1, se usará el modo dtoa 0. Ahora se usa el valor -1 como predeterminado.

gd.jpeg_ignore_warning

El valor predeterminado de este ajuste de php.ini ha cambiado a 1, por lo que las advertencias predeterminadas de libjpeg son ignoradas.

opcache.enable_cli

El valor predeterminado para este ajuste php.ini ha cambiado a 1 (habilitado) en PHP 7.1.2.

Generación de ID de sesión con un CSPRNG solamente

Los ID de sesión ahora solamente serán generados con un CSPRNG.

Mensajes TypeError más informativos cuando se permite null

Las excepciones TypeError para comprobaciones de tipo arg_info ahora proporcionan mensajes de error más informativos. Si el tipo de parámetro o el tipo devuelto acepta null (ya sea teniente un valor predeterminado de null o siendo un tipo «nullable»), el mensaje de error ahora mencionará esto con un mensaje "must be ... or null" o "must ... or be null."


Soporte para Windows

readline

A la extensión readline se le da soporte a través de la » biblioteca WinEditLine. De esta manera, también se le da soporte al «shell» interactivo CLI (php.exe -a).


Migración de PHP 5.6.x a PHP 7.0.x

Tabla de contenidos

  • Cambios retroincompatibles
  • Nuevas características
  • Características obsoletas en PHP 7.0.x
  • Funciones cambiadas
  • Nuevas funciones
  • Nuevas clases e interfaces
  • Nuevas constantes globales
  • Cambios en los Módulos SAPI
  • Extensiones y SAPI eliminadas
  • Otros cambios

Aunque PHP 7.0 es una nueva versión mayor, se ha realizado mucho esfuerzo para hacer la migración lo más sencilla posible. Esta versión se centra principalmente en la eliminación de la funcionalidad obsoleta de versiones anteriores y en la mejora de la consistencia del lenguaje.

Existen unas pocas incompatibilidades y nuevas características que deberían considerarse, debiendo así de probar el antes de cambiar de versión de PHP en entornos de producción.


Cambios retroincompatibles

Cambios en el manejo de errores y excepciones

Muchos errores fatales y errores fatales recuperables han sido convertidos en excepciones en PHP 7. Estas excepciones de error heredan de la clase Error, la cual implementa en sí la interfaz Throwable, (la interfaz base que heredan todas las excepciones).

Esto significa que los manejadores de errores personalizados podrían no desencadenarse debido a que podrían lanzarse excepciones en su lugar (causando nuevos errores fatales para excepciones Error no capturadas).

Se puede encontrar una descripción más completa de cómo operan los errores en PHP 7 en la página de errores de PHP 7. Esta guía de migración simplemente enumerará los cambios que afectan a la retrocompatiblidad.

Ya no se garantiza que set_exception_handler() reciba objetos Exception

El código que implemente un manejador de excepciones registrado con set_exception_handler() empleando una declaración de tipo de Exception causará un error fatal cuando sea lance un objeto Error.

Si el manejador necesita funcionar tanto en PHP 5 como en PHP 7, se debería eliminar la declaración de tipo del manejador, mientras que el código que sea migrado para que funcione exclusivamente en PHP 7 puede simplemente reemplazar la declaración de tipo Exception con Throwable en su lugar.

<?php
// Código de la era de PHP 5 que no funcionará.
function handler(Exception $e) { ... }
set_exception_handler('handler');

// Compatible con PHP 5 y 7.
function handler($e) { ... }

// Solo PHP 7.
function handler(Throwable $e) { ... }
?>

Los constructores internos siempre lanzan excepciones en caso de fallo

Previamente, algunas clases internas devolvían null o un objeto inutilizable cuando el constructor fallaba. Ahora, todas las clases internas lanzan una Exception en tal caso, de la misma forma que las clases de usuario ya deben de hacerlo.

Los errores de análisis lanzan un objeto ParseError

Los errores de análisis ahora lanzan un objeto ParseError. El manejo de errores para eval() ahora debería incluir un bloque catch que permita manejar dicho error.

Cambios en la severidad de avisos E_STRICT

Todos los avisos de E_STRICT han sido reclasificados a otros niveles. Se mantiene la consntante E_STRICT, por lo que llamadas como error_reporting(E_ALL|E_STRICT) no ocasionarán ningún error.

Cambios en la severidad de avisos de E_STRICT
Situación | Nuevo nivel/comportamiento
Indexación mediante un recurso | E_NOTICE
Métodos estáticos abstractos | Aviso eliminado, no genera un error
'Redefinición' de un constructor | Aviso eliminado, no genera un error
Discordancia de la signatura durante la herencia | E_WARNING
Misma propiedad (compatible) en dos rasgos empleados | Aviso eliminado, no genera un error
Acceso a una propiedad estática de forma no estática | E_NOTICE
Solamente las variables deberían ser asignadas por referencia | E_NOTICE
Solamente las variables deberían ser pasadas por referencia | E_NOTICE
Llamada a métodos no estáticos de forma estática | E_DEPRECATED

Cambios en el manejo de variables

PHP 7 ahora emplea un árbol sintáctico abstracto al analizar ficheros. Esto ha permitido muchas mejoras en el lenguaje que antes eran imposibles debido a las limitaciones del analizador empleado en versiones previas de PHP, aunque ha resultado en la eliminación de unos pocos casos especiales por razones de consistencia, dando así lugar a roturas de retrocompatibilidad. Dichos casos están detallados a continuación.

Cambios en el manejo de variables, propiedades y métodos indirectos

El acceso indirecto a variables, propiedades y métodos ahora se evalúa estrictamente de izquierda a derecha, en contraste a la mezcla anterior de casos especiales. La tabla de abajo muestra los cambios en el orden de evaluación.

Antigua y nueva evaluación de expresiones indirectas
Expresión | Interpretación de PHP 5 | Interpretación de PHP 7
$$foo['bar']['baz'] | ${$foo['bar']['baz']} | ($$foo)['bar']['baz']
$foo->$bar['baz'] | $foo->{$bar['baz']} | ($foo->$bar)['baz']
$foo->$bar['baz']() | $foo->{$bar['baz']}() | ($foo->$bar)['baz']()
Foo::$bar['baz']() | Foo::{$bar['baz']}() | (Foo::$bar)['baz']()

El código que emplee el orden antiguo de evaluación de derecha a izquierda debe ser rescrito para utilizar explícitamente el orden de evaluación con llaves (véase la columna de en medio de arriba). Esto hará al código compatible con PHP 7.x y retrocompatible con PHP 5.x.

Cambios al manejo de list()

list() ya no asigna variables en orden inverso

list() ahora asigna valores a variables en el orden en el que estas se definen, en vez de en orden inverso. En general, esto solamente afecta al caso donde list() se emplea junto con el operador de array [], como se muestra a continuación:

<?php
list($a[], $a[], $a[]) = [1, 2, 3];
var_dump($a);
?>

Salida del ejemplo anterior en PHP 5:

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}

Salida del ejemplo anterior en PHP 7:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

En general, se recomienda no depender del orden en el que ocurren las asignaciones de list(), ya que este es un detalle de implementación que podría cambiar en el futuro.

Se han eliminado las asignaciones vacías de list()

Las construcciones de list() ya no pueden estar vacías. Lo siguiente ya no es válido:

<?php
list() = $a;
list(,,) = $a;
list($x, list(), $y) = $a;
?>
list() no puede desempaquetar strings

list() ya no puede desempaquetar variables de tipo string. Debería usarse str_split() en su lugar.

Cambio en el ordenamiento de arrays cuando los elementos se crean automáticamente durante las asignaciones por referencia

El orden de los elementos de un array ha cambiado cuando dichos elementos han sido creados automáticamente haciendo referencia a ellos en una asignación por referencia. Por ejemplo:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

Salida del ejemplo anterior en PHP 5:

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

Salida del ejemplo anterior en PHP 7:

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

global solamente acepta variables simples

Ya no se pueden utilizar variables variables con la palabra reservada global. Se puede emplear la sintaxis de llaves para emular el comportamiento anterior si fuera necesario:

<?php
function f() {
    // Válido solamente en PHP 5.
    global $$foo->bar;

    // Válido en PHP 5 y 7.
    global ${$foo->bar};
}
?>

Como principio general, se desaconseja el uso de global con algo que no sea una simple variable.

Los paréntesis alrededor de argumentos de una función ya no afectan al comportamiento

En PHP 5, el uso de paréntesis redundantes alrededor de un argumento de una función podía silenciar advertencias del estándar estricto cuando el argumento de dicha función era pasado por referencia. Estas advertencias ahora se emiten siempre.

<?php
function obtenerArray() {
    return [1, 2, 3];
}

function arrayAlCuadrado(array &$a) {
    foreach ($a as &$v) {
        $v **= 2;
    }
}

// Genera una advertencia en PHP 7.
arrayAlCuadrado((obtenerArray()));
?>

El resultado del ejemplo sería:

Notice: Only variables should be passed by reference in /tmp/test.php on line 13

Cambios en foreach

Se han realizado cambios menores en el comportamiento de la estructura de control foreach, principalmente alrededor del manejo del puntero de arrays interno y la modificación del array en su recorrido.

foreach ya no cambia el puntero de arrays interno

Antes de PHP 7, el puntero de arrays interno era modificado mientras el array se recorría con foreach. Este ya no es el caso, como se muestra en el siguiente ejemplo:

<?php
$array = [0, 1, 2];
foreach ($array as &$val) {
    var_dump(current($array));
}
?>

Salida del ejemplo anterior en PHP 5:

int(1)
int(2)
bool(false)

Salida del ejemplo anterior en PHP 7:

int(0)
int(0)
int(0)

La iteración de foreach por valor opera sobre una copia del array

Al utilizar el modo predeterminado de iteración por valor, foreach ahora opera sobre una copia del array a recorrer en lugar del array en sí. Esto significa que los cambios realizados a un array durante una iteración no afectarán a los valores que se recorren.

Se ha mejorado el comportamiento de la iteración de foreach por referencia

Cuando se itera por referencia, foreach ahora realizará un trabajo mejor realizando un seguimiento de los cambios hechos en el array durante la iteración. Por ejemplo, al añadir valores a un array mientras se recorre dará como resultado también el recorrido de los valores añadidos:

<?php
$array = [0];
foreach ($array as &$val) {
    var_dump($val);
    $array[1] = 1;
}
?>

Salida del ejemplo anterior en PHP 5:

int(0)

Salida del ejemplo anterior en PHP 7:

int(0)
int(1)

Iteración de objetos no Traversables

Recorrer un objeto no Traversable ahora tendrá el mismo comportamiento que recorrer arrays por referencia. Esto resulta en que la mejora del comportamiento al modificar un array durante la iteración se aplique también cuando se añaden propiedades a o se eleminan de un objeto.

Cambios en el manejo del tipo integer

Literales de octal inválidos

Previamente, los literales de octal que contenían números inválidos eran truncados silenciosamente (0128 era tomado como 012). Ahora, un literal de octal inválido causará un error de análisis.

Desplazamientos negativos de bits

Los desplazamientos de bit mediante números negativos ahora lanzan un ArithmeticError:

<?php
var_dump(1 >> -1);
?>

Salida del ejemplo anterior en PHP 5:

int(0)

Salida del ejemplo anterior en PHP 7:

Fatal error: Uncaught ArithmeticError: Bit shift by negative number in /tmp/test.php:2
Stack trace:
#0 {main}
  thrown in /tmp/test.php on line 2

Desplazamientos de bits fuera de rango

Los desplazamientos de bits (en cualquier dirección) fuera del ancho de bit de un integer siempre resultarán en 0. Anteriormente, el comportamiento de dichos desplazamientos dependía de la arquitectura.

Cambios en la División por Cero

Anteriormente, cuando se empleaba 0 como divisor de los operadores de división (/) o módulo (%), se emitía un error de tipo E_WARNING y se devolvía false. Ahora, el operador de división devuelve un valor de tipo float así como +INF, -INF, o NAN tal como se especifica en el IEEE 754. El error E_WARNING del operador de módulo ha sido eliminado, lanzando ahora una excepción DivisionByZeroError.

<?php
var_dump(3/0);
var_dump(0/0);
var_dump(0%0);
?>

Salida del ejemplo anterior en PHP 5:

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

Salida del ejemplo anterior en PHP 7:

Warning: Division by zero in %s on line %d
float(INF)

Warning: Division by zero in %s on line %d
float(NAN)

PHP Fatal error:  Uncaught DivisionByZeroError: Modulo by zero in %s line %d

Cambios en el manejo del tipo string

Un string hexadecimal ya no se considera numérico

Los string que contienen números hexadecimales ya no se consideran numéricos. Por ejemplo:

<?php
var_dump("0x123" == "291");
var_dump(is_numeric("0x123"));
var_dump("0xe" + "0x1");
var_dump(substr("foo", "0x1"));
?>

Salida del ejemplo anterior en PHP 5:

bool(true)
bool(true)
int(15)
string(2) "oo"

Salida del ejemplo anterior en PHP 7:

bool(false)
bool(false)
int(0)

Notice: A non well formed numeric value encountered in /tmp/test.php on line 5
string(3) "foo"

Se puede emplear filter_var() para comprobar si un string contiene un numero hexadecimal, y también para convertir un string de dicho tipo en un integer:

<?php
$str = "0xffff";
$int = filter_var($str, FILTER_VALIDATE_INT, FILTER_FLAG_ALLOW_HEX);
if (false === $int) {
    throw new Exception("¡Número entero inválido!");
}
var_dump($int); // int(65535)
?>

\u{ puede ocasionar errores

Debido a la incorporación de la nueva sintaxis de escape de puntos de código de Unicode, los string que contienen un literal \u{ seguido de una secuencia inválida causarán un error fatal. Para evitarlo, se debería escapar la barra inicial.

Funciones eliminadas

call_user_method() y call_user_method_array()

Estas funciones estaban obsoletas en PHP 4.1.0 en favor de call_user_func() y call_user_func_array(). Se podría también considerar el uso de funciones variables y/o el operador ....

Todas las funciones ereg*

Se han eliminado todas las funciones de ereg. Se recomienda PCRE como alternativa.

Alias de mcrypt

Se ha eliminado la función obsoleta mcrypt_generic_end() en favor de mcrypt_generic_deinit().

También se han eliminado las funciones obsoletas mcrypt_ecb(),
mcrypt_cbc(), mcrypt_cfb() y
mcrypt_ofb() en favor del
uso de mcrypt_decrypt() con la constante
MCRYPT_MODE_* apropiada.

Todas las funciones de ext/mysql

Se han eliminado todas las funciones de ext/mysql. Para más detalles sobre elegir una API de MySQL diferente, Véase Elegir una API de MySQL.

Todas las funciones ext/mssql

Se han eliminado todas las funciones de ext/mssql.

  • PDO_SQLSRV
  • PDO_ODBC
  • SQLSRV
  • ODBC Unidficada API

Alias de intl

Se han eliminado los alias obsoletos datefmt_set_timezone_id() y
IntlDateFormatter::setTimeZoneID()
en favor de datefmt_set_timezone() y
IntlDateFormatter::setTimeZone(), respectivamente.

set_magic_quotes_runtime()

Se ha eliminado set_magic_quotes_runtime(), junto con su alias magic_quotes_runtime(). Estaban obsoletos en PHP 5.3.0, y de hecho se quedaron sin funcionalidad con la eliminación de las comillas mágicas en PHP 5.4.0.

set_socket_blocking()

Se ha eliminado el alias obsoleto set_socket_blocking() en favor de stream_set_blocking().

dl() en PHP-FPM

dl() ya no se puede utilizar en PHP-FPM. Permanece funcional en CLI y en SAPI embebidas.

Funciones de Type1 de GD

Se ha eliminado el soporte para fuentes Type1 de PostScript de la extensión GD, resultado en la eliminación de las siguientes funciones:

  • imagepsbbox()
  • imagepsencodefont()
  • imagepsextendfont()
  • imagepsfreefont()
  • imagepsloadfont()
  • imagepsslantfont()
  • imagepstext()

Se recomienda utilizar fuentes TrueType y sus asociadas en su lugar.

Directivas INI eliminadas

Características eliminadas

Las siguientes directivas INI han sido eliminadas, así como sus características asociadas:

  • always_populate_raw_post_data
  • asp_tags

xsl.security_prefs

Ha sido eliminada la directiva xsl.security_prefs. En su lugar, debería llamarse al método XsltProcessor::setSecurityPrefs() para controlar las preferencias de seguridad en función de cada procesador.

Otros cambios retroincompatibles

No se pueden asignar nuevos objetos por referencia

El resultado de la sentencia new ya no se puede asignar a una variable por referencia:

<?php
class C {}
$c =& new C;
?>

Salida del ejemplo anterior en PHP 5:

Deprecated: Assigning the return value of new by reference is deprecated in /tmp/test.php on line 3

Salida del ejemplo anterior en PHP 7:

Parse error: syntax error, unexpected 'new' (T_NEW) in /tmp/test.php on line 3

Nombres de clase, interfaz y rasgo inválidos

Los siguientes nombres no se pueden emplear para nombrar a clases, interfaces o rasgos:

  • bool
  • int
  • float
  • string
  • null
  • true
  • false

Tampoco deberían utilizarse los siguientes nombres. Aunque no generan un error en PHP 7.0, están reservados para un uso futuro, por lo que deberían considerarse obsoletos.

  • resource
  • object
  • mixed
  • numeric

Eliminación de las etiquetas ASP y de script de PHP

Se ha eliminado el soporte para usar etiquetas ASP y de script para delimitar código de PHP. Las etiquetas afectadas son:

Etiquetas ASP y de script eliminadas
Etiqueta de apertura | Etiqueta de cierre
<% | %>
<%= | %>
<script language="php"> | </script>

Eliminación de llamadas desde contextos incompatibles

Ya obsoletas en PHP 5.6, las llamadas estáticas realizadas a un método no estático con un contexto incompatible resultarán ahora en la tenencia del método llamado de una variable $this indefinida y en la emisión de una advertencia de obsolescencia.

<?php
class A {
    public function prueba() { var_dump($this); }
}

// Nota: NO extiende a A
class B {
    public function llamadaAMétodoNoEstáticoDeA() { A::prueba(); }
}

(new B)->llamadaAMétodoNoEstáticoDeA();
?>

Salida del ejemplo anterior en PHP 5.6:

Deprecated: Non-static method A::prueba() should not be called statically, assuming $this from incompatible context in /tmp/test.php on line 8
object(B)#1 (0) {
}

Salida del ejemplo anterior en PHP 7:

Deprecated: Non-static method A::prueba() should not be called statically in /tmp/test.php on line 8

Notice: Undefined variable: this in /tmp/test.php on line 3
NULL

yield ahora es un operador asociativo derecho

El constructor yield ya no requiere paréntesis, ya que ha pasado a ser un operador asociativo derecho con precedencia entre print y =>. Esto puede resultar en un cambio de comportamiento:

<?php
echo yield -1;
// Anteriormente era interpretado como
echo (yield) - 1;
// Y ahora es intrepretado como
echo yield (-1);

yield $foo or die;
// Anteriormente era interpretado como
yield ($foo or die);
// Y ahora es intrepretado como
(yield $foo) or die;
?>

Los paréntesis se pueden emplear para desambiguar estos casos.

Las funciones no pueden tener varios parámetros con el mismo nombre

Ya no es posible definir dos o más parámetros de función con el mismo nombre. Por ejemplo, el siguiente método generará un error E_COMPILE_ERROR:

<?php
function foo($a, $b, $sin_usar, $sin_usar) {
    //
}
?>

Las funciones que inspeccionan argumentos informan del valor del parámetro actual

func_get_arg(), func_get_args(), debug_backtrace() y las excepciones de información de rastreo ya no informarán del valor original que fue pasado a un paramétro, en su lugar proporcionarán el valor actual (el cual podría haber sido modificado).

<?php
function foo($x) {
    $x++;
    var_dump(func_get_arg(0));
}
foo(1);?>

Salida del ejemplo anterior en PHP 5:

1

Salida del ejemplo anterior en PHP 7:

2

Las sentencias switch no pueden tener varios bloques default

Ya no es posible definir dos o más bloques default en una sentencia switch. Por ejemplo, la siguiente senetencia switch generará un error E_COMPILE_ERROR:

<?php
switch (1) {
    default:
    break;
    default:
    break;
}
?>

Eliminación de $HTTP_RAW_POST_DATA

$HTTP_RAW_POST_DATA ya no está disponible. Debería usarse el flujo php://input en su lugar.

Eliminación de los comentarios # en ficheros INI

Se ha eliminado el soporte para los comentarios prefijados con # en los ficheros INI. Se debe emplear en su lugar ; (punto y coma). Este cambio se aplica a php.ini, así como a ficheros manejados por parse_ini_file() y parse_ini_string().

JSON extension replaced with JSOND

Se ha reemplazado la extensión JSON por JSOND ocasionando tres roturas de RC (retocompatibilidad). La primera, un número no puede finalizar con un punto decimal (esto es, 34. debe cambiarse para que sea o 34.0 o 34). La segunda, al utilizar notación científica, el exponente e no debe seguir inmediatamente a un punto decimal (esto es, 3.e3 se debe cambiar para que sea o 3.0e3 o 3e3). Finalmente, una cadena vacía ya no se considera un JSON válido.

Fallo de funciones internas en un desbordamiento

Anteriormente, las funciones internas truncaban de forma silenciosa números producidos desde coacciones de tipo float a integer cuando el float era demasiado grande de representar como un integer. Ahora, se emitirá un E_WARNING y se devolverá null.

Reparaciones en los valores de devolución de gestores de sesión personalizados

Cualquier función declarada implementada por gestores de sesión personalizados que devuelvan o false o -1 serán errores fatales. Si desde estas funciones se devuelve cualquier valor distinto de un booleano, -1, o 0, fallarán y se emitirá un E_WARNING.

Sort order of equal elements

El algoritmo de ordenación interno ha sido mejorado, lo cual puede resultar en un orden diferente de elementos, que se comparan como iguales, que antes.

Nota:

No dependa del orden de los elementos que se comparan como iguales; podría cambiar en cualquier momento.


Nuevas características

Declaraciones de tipo escalar

Las declaraciones de tipo escalar son de dos tipos: coercitivo (por defecto) y estricto. Ahora se pueden forzar los siguientes tipos para parámetros (tanto coercitiva como estrictamente): cadenas de caracteres (string), números enteros (int), números decimales (float), y booleanos (bool). Estos se añaden a los tipos introducidos en PHP 5: nombres de clases, interfaces, arrays y callables.

<?php
// Modo coercitivo
function sumaDeEnteros(int ...$enteros)
{
    return array_sum($enteros);
}

var_dump(sumaDeEnteros(2, '3', 4.1));

El resultado del ejemplo sería:

int(9)

Para habilitar el modo estricto se debe colocar una simple directiva declare al inicio del fichero. Esto siginfica que la rigurosidad de la tipificación de escalares se configura en función de cada fichero. Esta directiva no solamente afecta a las declaraciones de tipo de parámetros, sino también al tipo de devolución de una función (véanse las declaraciones de tipo de devolución), a funciones internas de PHP, y a funciones de extensiones cargadas.

Se puede encontrar la documentación completa y ejemplos de las declaraciones de tipo escalar en la referencia de declaraciones de tipo.

Declaraciones de tipo de devolución

PHP 7 añade soporte para declaraciones de tipo de devolución. Similarmente a las declaraciones de tipo de argumento, las declaraciones de tipo de devolución especifican el tipo del valor que será devuelto por una función. Están disponibles los mismos tipos tanto para las declaraciones de tipo de devolución como para las declaraciones de tipo de argumento.

<?php

function sumarArrays(array ...$arrays): array
{
    return array_map(function(array $array): int {
        return array_sum($array);
    }, $arrays);
}

print_r(sumarArrays([1,2,3], [4,5,6], [7,8,9]));

El resultado del ejemplo sería:

Array
(
    [0] => 6
    [1] => 15
    [2] => 24
)

Se puede encontrar la documentación completa y ejemplos de las declaraciones de tipo de devolución en la referencia de las declaraciones de tipo de devolución.

Operador de fusión de null

El operador de fusión de null (??) se ha añadido como aliciente sintáctico para el caso común de la necesidad de utilizar un operador ternario junto con isset(). Devuelve su primer operando si existe y no es null; de lo contrario devuelve su segundo operando.

<?php
// Obntener el valor de $_GET['usuario'] y devolver 'nadie'
// si no existe.
$nombre_usuario = $_GET['usuario'] ?? 'nadie';
// Esto equivale a:
$nombre_usuario = isset($_GET['usuario']) ? $_GET['usuario'] : 'nadie';

// La fusión se puede encadenar: esto devolverá el primer
// valor definido de $_GET['usuario'], $_POST['usuario'],
// y 'nadie'.
$nombre_usuario = $_GET['usuario'] ?? $_POST['usuario'] ?? 'nadie';
?>

El operador nave espacial

El operador nave espacial se emplea para comparar dos expresiones. Devuelve -1, 0 o 1 cuando $a es respectivamente menor, igual, o mayor que $b. Las comparaciones se realizan según las reglas de comparación de tipos usuales de PHP.

<?php
// Números enteros
echo 1 <=> 1; // 0
echo 1 <=> 2; // -1
echo 2 <=> 1; // 1

// Numeros decimales
echo 1.5 <=> 1.5; // 0
echo 1.5 <=> 2.5; // -1
echo 2.5 <=> 1.5; // 1

// Cadenas de caracteres
echo "a" <=> "a"; // 0
echo "a" <=> "b"; // -1
echo "b" <=> "a"; // 1
?>

Arrays constantes con define()

Ahora se pueden definir constantes de array con define(). En PHP 5.6, solamente se podían definir con const.

<?php
define('ANIMALES', [
    'perro',
    'gato',
    'pájaro'
]);

echo ANIMALES[1]; // imprime "gato"
?>

Clases anónimas

Se ha añadido soporte para clases anónimas mediante new clase. Estas se pueden utilizar en lugar de definiciones de clases completas para objetos desechables:

<?php
interface Logger {
    public function log(string $msg);
}

class Application {
    private $logger;

    public function getLogger(): Logger {
         return $this->logger;
    }

    public function setLogger(Logger $logger) {
         $this->logger = $logger;
    }
}

$app = new Application;
$app->setLogger(new class implements Logger {
    public function log(string $msg) {
        echo $msg;
    }
});

var_dump($app->getLogger());
?>

El resultado del ejemplo sería:

object(class@anonymous)#2 (0) {
}

La documentación completa se puede encontrar en la referencia de clases anónimas.

Sintaxis de escape de puntos de códigos de Unicode

Esta sintaxis toma un punto de código de Unicode en forma hexadecimal, e imprime ese punto de código en UTF-8 a un string con entrecomillado doble o a un heredoc. Se acepta cualquier punto de código válido, siendo los ceros iniciales opcionales.

echo "\u{aa}";
echo "\u{0000aa}";
echo "\u{9999}";

El resultado del ejemplo sería:

ª
ª (lo mismo que antes pero con ceros iniciales opcinales)
?

Closure::call()

Closure::call() es una manera más eficiente y abreviada de vincular temporalmente un ámbito de objeto a un cierre e invocarlo.

<?php
class A {private $x = 1;}

// Código anterior a PHP 7
$getX = function() {return $this->x;};
$getXCB = $getX->bindTo(new A, 'A'); // cierre intermedio
echo $getXCB();

// Código de PHP 7+
$getX = function() {return $this->x;};
echo $getX->call(new A);

El resultado del ejemplo sería:

1
1

Filtros para unserialize()

Esta característica busca el proporcionar una mejor seguridad al deserializar objetos en datos no fiables. Previene de posibles inyecciones de código al capacitar al desarrollador a crear listas blancas de clases que deden ser deserializadas.

<?php

// convertir todos los objetos a un objeto __PHP_Incomplete_Class
$data = unserialize($foo, ["allowed_classes" => false]);

// convertir todos los objetos a un objeto __PHP_Incomplete_Class excepto a los de MiClase y MiClase2
$data = unserialize($foo, ["allowed_classes" => ["MiClase", "MiClase2"]]);

// comportamiento predeterminado (lo mismo que omitir el segundo argumento) que acepta todas las clases
$data = unserialize($foo, ["allowed_classes" => true]);

IntlChar

La nueva clase IntlChar busca exponer funcionalidad adicional de ICU. La clase en sí define varios métodos estáticos y constantes que se pueden emplear para manipular caracteres Unicode.

<?php

printf('%x', IntlChar::CODEPOINT_MAX);
echo IntlChar::charName('@');
var_dump(IntlChar::ispunct('!'));

El resultado del ejemplo sería:

10ffff
COMMERCIAL AT
bool(true)

Para utilizar esta clase debe estar instalada la extensión Intl.

Previsiones

Las previsiones son una mejora retrocompatible con la antigua función assert(). Con ellas se pueden realizar afirmaciones sin coste en código de producción, proporcionando la capacidad de lanzar excepciones personalizadas cuando la afirmación falla.

Mientras que la API antigua se siguie manteniendo por compatibilidad, assert() ahora es un constructor de lenguaje, permitiendo que el primer parámetro sea una expresión en lugar de solamente un string a evaluar o un valor de tipo boolean a probar.

<?php
ini_set('assert.exception', 1);

class ErrorPersonalizado extends AssertionError {}

assert(false, new ErrorPersonalizado('Un mensaje de error'));
?>

El resultado del ejemplo sería:

Fatal error: Uncaught ErrorPersonalizado: Un mensaje de error

Se pueden encontrar los detalles completos de esta característica, incluyendo cómo configurarla tanto en entornos de desarrollo como de producción, en la sección de previsiones de la referencia de assert().

Declaraciones de use en grupo

Las clases, funciones y constantes que se importen desde el mismo namespace ahora pueden ser agrupadas en una única sentencia use.

<?php
// Código anterior a PHP 7
use un\espacioDeNombres\ClaseA;
use un\espacioDeNombres\ClaseB;
use un\espacioDeNombres\ClaseC as C;

use function un\espacioDeNombres\fn_a;
use function un\espacioDeNombres\fn_b;
use function un\espacioDeNombres\fn_c;

use const un\espacioDeNombres\ConstA;
use const un\espacioDeNombres\ConstB;
use const un\espacioDeNombres\ConstC;

// código de PHP 7+
use un\espacioDeNombres\{ClaseA, ClaseB, ClaseC as C};
use function un\espacioDeNombres\{fn_a, fn_b, fn_c};
use const un\espacioDeNombres\{ConstA, ConstB, ConstC};
?>

Expresiones 'return' en generadores

Esta característica se basa en la funcionalidad de los generadores introducida en PHP 5.5. Habilita a la sentencia return para utilizarla dentro de un generador para que pueda devolver una expresión final (la devolución por referencia no está permitida). Este valor se puede obtener empleando el nuevo método Generator::getReturn(), el cual solamente se puede utilizar una vez que el generador ha finalizado de producir valores.

<?php

$gen = (function() {
    yield 1;
    yield 2;

    return 3;
})();

foreach ($gen as $val) {
    echo $val, PHP_EOL;
}

echo $gen->getReturn(), PHP_EOL;

El resultado del ejemplo sería:

1
2
3

La capacidad de devolver explícitamente un valor final desde un generador (quizá desde una forma de computación de corutina) es útil debido a que puede ser específicamente manejado por el código del cliente que ejecuta el generador. Esto es mucho más simple que forzar al código del cliente a comprobar primero si el valor final se ha generado y luego, si es asi, manejar dicho valor específicamente.

Delegación de generadores

Los generadores ahora pueden delegar a otro generador, objeto Traversable o array de forma automática, sin la necesidad de escribir «clichés» en el generador más externo con la construcción yield from.

<?php
function gen()
{
    yield 1;
    yield 2;
    yield from gen2();
}

function gen2()
{
    yield 3;
    yield 4;
}

foreach (gen() as $val)
{
    echo $val, PHP_EOL;
}
?>

El resultado del ejemplo sería:

1
2
3
4

División entera con intdiv()

La nueva función intdiv() realiza una división entera de sus operandos y la devuelve.

<?php
var_dump(intdiv(10, 3));
?>

El resultado del ejemplo sería:

int(3)

Opciones de sesión

session_start() ahora acepta un array de opciones que sobrescriben las directivas de configuración de sesiones establecidas normalmente en php.ini.

Estas opciones también se han ampliado para admitir session.lazy_write, la cual está activada de forma predeterminada y causa que PHP solamente sobrescriba cualquier fichero de sesión si los datos de sesión han cambiado, y read_and_close, la cual es una opción que se puede pasar solo a session_start() para indicar que los datos de sesión deberían ser leídos y luego la sesión debería ser cerrada inmediatamente sin cambios.

Por ejemplo, para establecer session.cache_limiter a private e inmediatamente cerrar la sesión después de leerla:

<?php
session_start([
    'cache_limiter' => 'private',
    'read_and_close' => true,
]);
?>

preg_replace_callback_array()

Con la nueva función preg_replace_callback_array(), el código escrito es más claro al emplear la función preg_replace_callback(). Antes de PHP 7, las retrollamadas que necesitaban ser ejecutadas por cada expresión regular requerían que la función de retrollamda fuera contaminada con muchas ramificaciones.

Ahora, las retrollamadas se pueden registrar para cada expresión regular usando un array asociativo, donde la clave es una expresión regular y el valor es una retrollamada.

Funciones de CSPRNG

Se han añadido dos nuevas funciones para generar números enteros y cadenas de caractéres criptográficamente seguros de una forma multiplataforma: random_bytes() y random_int().

list() siempre desempaqueta objetos que implementen ArrayAccess

Anteriormente, no se garantizaba que list() operase correctamente con objetos que implementasen ArrayAccess. Esto ha sido arreglado.

Otras características

  • Se ha añadido el acceso a miembros de clase al clonar, p.ej. (clone $foo)->bar().


Características obsoletas en PHP 7.0.x

Constructores al estilo de PHP4

Los constructores al estilo de PHP4 (métodos que tienen el mismo nombre que la clase donde están definidos) están obsoletos y serán eliminados en el futuro. PHP 7 emitirá un error E_DEPRECATED si un constructor de PHP 4 es el único definido dentro de una clase. Las clases que implementen un método __construct() no se ven afectadas.

<?php
class foo {
    function foo() {
        echo 'Soy el constructor';
    }
}
?>

El resultado del ejemplo sería:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; foo has a deprecated constructor in example.php on line 3

Llamadas estáticas a métodos no estáticos

Una llamada estática a un método que no esté declarado como static está obsoleta y podría ser eliminada en el futuro.

<?php
class foo {
    function bar() {
        echo '¡No soy estático!';
    }
}

foo::bar();
?>

El resultado del ejemplo sería:

Deprecated: Non-static method foo::bar() should not be called statically in - on line 8
¡No soy estático!

Opción 'salt' de password_hash()

La opción 'salt' de la función password_hash() está obsoleta para prevenir a los desarrolladores de generar sus propias sales (usualmente inseguras). La función en sí genera una sal criptográficamente segura cuando el desarrollador no proprorciona ninguna. Por tanto, no debería ser necesaria la generación de sales personalizadas.

Opción de contexto SSL capture_session_meta

La opción de contexto SSL capture_session_meta ha sido declarada obsoleta. Los metadatos de SSL ahora están disponibles a través de la función stream_get_meta_data().

Obsolescencias de LDAP

La siguiente función está obsoleta:

  • ldap_sort()


Funciones cambiadas

Núcleo de PHP

  • debug_zval_dump() ahora imprime "int" en lugar de "long", y "float" en lugar de "double"
  • dirname() ahora toma opcionalmente un segundo parámetro, depth, para obtener el nombre del directorio de depth niveles hasta el directorio actual.
  • getrusage() ahora tiene soporte para Windows.
  • Las funciones mktime() y gmmktime() ya no aceptan el parámetro is_dst.
  • La función preg_replace() ya no admite "\e" (PREG_REPLACE_EVAL). Debería usarse en su lugar preg_replace_callback().
  • La función setlocale() ya no acepta que category sea un string. Se deberían utilizar en su lugar las constantes LC_*.
  • Las funciones exec(), system() y passthru() ahora poseen protección del byte NULL.
  • shmop_open() ahora devuelve un recurso en lugar de un entero, el cual ha de ser pasado a shmop_size(), shmop_write(), shmop_read(), shmop_close() y shmop_delete().
  • substr() y iconv_substr() ahora devuelven una cadena vacía si el número de caracteres de la cadena de entrada es el mismo que el del parámetro 'start'.
  • xml_set_object() ahora requiere que se destruya ('unset') $parser al finalizar para evitar fugas de memoria.


Nuevas funciones

Closure

  • Closure::call()

CSPRNG

  • random_bytes()
  • random_int()

Manejo y registro de errores

  • error_clear_last()

Generator

  • Generator::getReturn()

Precisión múltiple de GNU

  • gmp_random_seed()

Math

  • intdiv()

PCRE

  • preg_replace_callback_array()

Opciones/Info de PHP

  • gc_mem_caches()
  • get_resources()

POSIX

  • posix_setrlimit()

Reflection

  • ReflectionParameter::getType()
  • ReflectionParameter::hasType()
  • ReflectionFunctionAbstract::getReturnType()
  • ReflectionFunctionAbstract::hasReturnType()

Zip

  • ZipArchive::setCompressionIndex()
  • ZipArchive::setCompressionName()

Compresión Zlib

  • inflate_add()
  • deflate_add()
  • inflate_init()
  • deflate_init()


Nuevas clases e interfaces

Intl

  • IntlChar

Reflection

  • ReflectionGenerator
  • ReflectionType

Manejo de sesiónes

  • SessionUpdateTimestampHandlerInterface

Jerarquía de excepciones

  • Throwable
  • Error
  • TypeError
  • ParseError
  • AssertionError
  • ArithmeticError
  • DivisionByZeroError


Nuevas constantes globales

Constantes predefinidas principales

  • PHP_INT_MIN

GD

  • IMG_WEBP (a partir de PHP 7.0.10)

JSON

  • JSON_ERROR_INVALID_PROPERTY_NAME
  • JSON_ERROR_UTF16

LibXML

  • LIBXML_BIGLINES

PCRE

  • PREG_JIT_STACKLIMIT_ERROR

POSIX

  • POSIX_RLIMIT_AS
  • POSIX_RLIMIT_CORE
  • POSIX_RLIMIT_CPU
  • POSIX_RLIMIT_DATA
  • POSIX_RLIMIT_FSIZE
  • POSIX_RLIMIT_LOCKS
  • POSIX_RLIMIT_MEMLOCK
  • POSIX_RLIMIT_MSGQUEUE
  • POSIX_RLIMIT_NICE
  • POSIX_RLIMIT_NOFILE
  • POSIX_RLIMIT_NPROC
  • POSIX_RLIMIT_RSS
  • POSIX_RLIMIT_RTPRIO
  • POSIX_RLIMIT_RTTIME
  • POSIX_RLIMIT_SIGPENDING
  • POSIX_RLIMIT_STACK
  • POSIX_RLIMIT_INFINITY

Zlib

  • ZLIB_ENCODING_RAW
  • ZLIB_ENCODING_DEFLATE
  • ZLIB_ENCODING_GZIP
  • ZLIB_FILTERED
  • ZLIB_HUFFMAN_ONLY
  • ZLIB_FIXED
  • ZLIB_RLE
  • ZLIB_DEFAULT_STRATEGY
  • ZLIB_BLOCK
  • ZLIB_FINISH
  • ZLIB_FULL_FLUSH
  • ZLIB_NO_FLUSH
  • ZLIB_PARTIAL_FLUSH
  • ZLIB_SYNC_FLUSH


Cambios en los Módulos SAPI

FPM

Los puertos de listen no cualificados ahora escuchan tanto en IPv4 como en IPv6

En PHP 5, una directiva listen con un único número de puerto escucha en todas las interfaces, pero solamente en IPv4. PHP 7 ahora acepta peticiones realizadas mediante IPv4 y IPv6.

Esto no afecta a las directivas que incluyen direcciones IP específicas; estas continúan escuchando solamente a dichas direcciones y protocolos.


Extensiones y SAPI eliminadas

Extensiones eliminadas

  • ereg
  • mssql
  • mysql
  • sybase_ct

SAPI eliminadas

  • aolserver
  • apache
  • apache_hooks
  • apache2filter
  • caudium
  • continuity
  • isapi
  • milter
  • nsapi
  • phttpd
  • pi3web
  • roxen
  • thttpd
  • tux
  • webjames


Otros cambios

Relajación en las restricciones de palabras reservadas

Ahora están permitidas las palabras reservadas globalmente como nombres de propiedades, de constantes y de métodos dentro de clases, interfaces y rasgos. Esto reduce la superficie de roturas de retrocompatibilidad cuando se introducen nuevas palabras reservadas, y evita las restricciones de nombres en las API.

Esto es particularmente útil al crear DSL internas con interfaces fluidas:

<?php
// 'new', 'private', y 'for' no se podían utilzar antes
Proyecto::new('Nombre del proyecto')->private()->for('propósito')->with('nombre de usuario');
?>

La única limitación es que la palabra reservada class no se puede usar aún como nombre de constante, de lo contrario entraría en conflicto con la sintaxis de resolución del nombre de la clase (NombreClase::class).

Eliminación de la advertencia de date.timezone

Anteriormente, se emitía una advertencia si el ajuste INI date.timezone no estaba establecido antes de utilizar cualquier función basada en fecha u hora. Ahora, esta advertencia ha sido eliminada (siendo aún UTC el valor predeterminado de date.timezone).


Migración de PHP 5.5.x a PHP 5.6.x

Tabla de contenidos

  • Cambios retroincompatibles
  • Características nuevas
  • Características obsoletas en PHP 5.6.x
  • Cambios en funciones
  • Nuevas funciones
  • Cambios de OpenSSL en PHP 5.6.x
  • Otros cambios en extensiones
  • Nuevas constantes globales

La mayoria de las mejoras de PHP 5.6.x no tienen impacto en el código existente. Hay varias incompatibilidades y nuevas características que deberían ser consideradas, ya que el código debería probarse antes de cambiar de versión de PHP en ambientes de producción.


Cambios retroincompatibles

Aunque la mayoría del código existente de PHP 5 debería funcionar sin cambios, se ha de tomar nota de algunos cambios retroincompatibles:

Las claves de un array no serán sobrescritas al definir un array como propiedad de una clase mediante un literal de array

Anteriormente, los array declarados como propiedades de clase que mezclaban claves explícita e implícitamente podían tener elementos de array sobrescritos de manera silenciosa si una clave explícita era la misma que una clave implícita secuencial. Por ejemplo:

<?php
class C {
    const UNO = 1;
    public $array = [
        self::UNO => 'foo',
        'bar',
        'quux',
    ];
}

var_dump((new C)->array);
?>

Salida del ejemplo anterior en PHP 5.5:

array(2) {
  [0]=>
  string(3) "bar"
  [1]=>
  string(4) "quux"
}

Salida del ejemplo anterior en PHP 5.6:

array(3) {
  [1]=>
  string(3) "foo"
  [2]=>
  string(3) "bar"
  [3]=>
  string(4) "quux"
}

Rigurosidad de json_decode()

json_decode() ahora siempre rechaza las variantes que no estén en minúsculas de los literales true, false y null de JSON, según la especificación de JSON, y establece json_last_error() en consecuencia. Anteriormente, json_decode() aceptaba entradas que consistían únicamente en uno de estos valores en mayúsculas o mezclando también minúsculas.

Este cambio solamente afectará a los casos donde hubiera sido pasado JSON no válido a json_decode(): una entrada JSON válida no se verá afectada y continuará siendo interpretada normalmente.

Las envolturas de flujos ahora verifican de manera predeterminada los certificados del par y los nombres de host al usar SSL/TLS

Todos los flujos encriptados de clientes ahora habilitan la verificación del par por omisión. De manera predeterminada se usará el paquete de CA predeterminado de OpenSSL para verificar el certificado del par. En la mayoría de los casos no será necesario realizar ningún cambio para comunicarse con servidores que posean certificados SSL válidos, ya que los distribuidores generalmente configuran OpenSSL para que emplee paquetes de CA bien conocidos.

El paquete de CA podría ser sobrescrito globalmente estableciendo la opción de configuración openssl.cafile u openssl.capath, o en función de cada petición, usando las opciones de contexto cafile o capath.

Aunque no se recomienda en general, es posible deshabilitar la verificación del certificado del par para una petición estableciendo la opción de contexto verify_peer a false, y para deshabilitar la validación del nombre del par estableciendo a false la opción de contexto verify_peer_name.

Los recursos GMP ahora son objetos

Los recursos GMP ahora son objetos. La API funcional implementada en la extensión GMP no ha cambiado, por lo que el código debería ejecutarse sin modificaciones, a menos que se revise en busca de un recurso explícitamente empleando is_resource() o similar.

Las funciones de Mcrypt ahora requieren claves e IV válidos

mcrypt_encrypt(), mcrypt_decrypt(), mcrypt_cbc(), mcrypt_cfb(), mcrypt_ecb(), mcrypt_generic() y mcrypt_ofb() ya no aceptan claves o IV con tamaños incorrectos, por lo que los modos de cifrado de bloques que requieran algún IV fallarán si no se proporciona uno.

Subidas de ficheros de cURL

Las subidas empleando la sintaxis @file ahora requieren que CURLOPT_SAFE_UPLOAD sea establecido a false. Debería utilizarse CURLFile en su lugar.


Características nuevas

Expresiones constantes

Ahora es posible proporcionar una expresión escalar que involucre literales numéricos y de string y/o constantes en contextos donde PHP anteriormente demandaba un valor estático, tal como una constante, una declaración de una propiedad o argumentos de funciones predeterminados.

<?php
const UNO = 1;
const DOS = UNO * 2;

class C {
    const TRES = DOS + 1;
    const UN_TERCIO = UNO / self::TRES;
    const SENTENCE = 'El valor de TRES es '.self::TRES;

    public function f($a = UNO + self::TRES) {
        return $a;
    }
}

echo (new C)->f()."\n";
echo C::SENTENCE;
?>

El resultado del ejemplo sería:

4
El valor de TRES es 3

Ahora también es posible definir un array constante utilizando la palabra reservada const:

<?php
const ARR = ['a', 'b'];

echo ARR[0];
?>

El resultado del ejemplo sería:

a

Funciones variádicas mediante ...

Las funciones variádicas ahora se pueden implementar usando el operador ..., en lugar de depender de func_get_args().

<?php
function f($requerido, $opcional = null, ...$parámetros) {
    // $parámetros es un array que contiene los argumentos restantes.
    printf('$requerido: %d; $opcional: %d; número de parámetros: %d'."\n",
           $requerido, $opcional, count($parámetros));
}

f(1);
f(1, 2);
f(1, 2, 3);
f(1, 2, 3, 4);
f(1, 2, 3, 4, 5);
?>

El resultado del ejemplo sería:

$requerido: 1; $opcional: 0; número de parámetros: 0
$requerido: 1; $opcional: 2; número de parámetros: 0
$requerido: 1; $opcional: 2; número de parámetros: 1
$requerido: 1; $opcional: 2; número de parámetros: 2
$requerido: 1; $opcional: 2; número de parámetros: 3

Desempaquetar argumentos mediante ...

Los array y los objetos Traversable se pueden desempaquetar a listas de argumentos al invocar a funciones empleando el operador .... A esto también se le conoce como el operador 'splat' en otros lenguajes como Ruby.

<?php
function sumar($a, $b, $c) {
    return $a + $b + $c;
}

$operadores = [2, 3];
echo sumar(1, ...$operadores);
?>

El resultado del ejemplo sería:

6

Exponenciación mediante **

Se a añadido un operador asociativo derecho, **, para realizar la exponenciación, junto con un operador de asignación abreviado, **=.

<?php
printf("2 ** 3 ==      %d\n", 2 ** 3);
printf("2 ** 3 ** 2 == %d\n", 2 ** 3 ** 2);

$a = 2;
$a **= 3;
printf("a ==           %d\n", $a);
?>

El resultado del ejemplo sería:

2 ** 3 ==      8
2 ** 3 ** 2 == 512
a ==           8

use function y use const

El operador use se ha ampliado para admitir funciones de importación y constantes además de clases. Esto se lleva a cabo mediante los contructores use function y use const, respectivamente.

<?php
namespace Espacio\De\Nombres {
    const FOO = 42;
    function f() { echo __FUNCTION__."\n"; }
}

namespace {
    use const Espacio\De\Nombres\FOO;
    use function Espacio\De\Nombres\f;

    echo FOO."\n";
    f();
}
?>

El resultado del ejemplo sería:

42
Espacio\De\Nombres\f

phpdbg

PHP ahora incluye un depurador interactivo llamado phpdbg, implementado como un módulo de SAPI. Para más información, visite la » documentación de phpdbg.

Codificación de caracteres predeterminada

default_charset ahora se emplea como conjunto de caracteres predeterminado para las funciones htmlentities(), html_entity_decode() y htmlspecialchars(). Observe que si los ajustes de codificación iconv y mbstring (ahora obsoletos) están establecidos, tomarán precedencia sobre default_charset para las funciones de iconv y mbstring, respectivamente.

El valor predeterminado para este ajuste es UTF-8.

php://input es reutilizable

php://input ahora podría se reabierto y leído tantas veces como sea necesario. Este trabajo también ha resultado en una mayor reducción de la cantidad de memoria necesaria para tratar con datos POST.

Subidas de ficheros grandes

Ahora se admiten subidas de ficheros de más de 2 gigabytes.

GMP soporta la sobrecarga de operadores

Los objetos GMP ahora soportan la sobrecarga de operadores y la conversión a tipos escalares. Esto permite código más expresivo empleando GMP:

<?php
$a = gmp_init(42);
$b = gmp_init(17);

if (version_compare(PHP_VERSION, '5.6', '<')) {
    echo gmp_intval(gmp_add($a, $b)), PHP_EOL;
    echo gmp_intval(gmp_add($a, 17)), PHP_EOL;
    echo gmp_intval(gmp_add(42, $b)), PHP_EOL;
} else {
    echo $a + $b, PHP_EOL;
    echo $a + 17, PHP_EOL;
    echo 42 + $b, PHP_EOL;
}
?>

El resultado del ejemplo sería:

59
59
59

hash_equals() para comparar string con seguridad contra ataques de temporización

Se ha añadido la función hash_equals() para comparar dos string en tiempo constante. Esto debería emplearse para mitigar los ataques de temporización; por ejemplo, al probar los hash de contraseñas de crypt() (asumiendo que no se puede usar password_hash() y password_verify(), que no son susceptibles a ataques de temporización).

<?php
$previsto   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correcto   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrecto = crypt('1234',  '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($previsto, $correcto));
var_dump(hash_equals($previsto, $incorrecto));
?>

El resultado del ejemplo sería:

bool(true)
bool(false)

__debugInfo()

El método mágico __debugInfo() se ha añadido para permitir a los objetos cambiar las propiedades y los valores que se muestran cuando el objeto se imprime al utilizar var_dump().

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

El resultado del ejemplo sería:

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}

Algoritmo de hash gost-crypto

Se ha añadido el algoritmo de hash gost-crypto. Implementa la función de hash GOST usando las tablas S-box de CryptoPro, como se especifica en la » RFC 4357, sección 11.2.

Mejoras en SSL/TLS

Se han realizado un amplio rango de mejoras al soporte para SSL/TLS en PHP 5.6. Estas incluyen la habilitación de la verificación del par por omisión, el soporte para la comparación de huellas digitales de certificados, la mitigación de ataques de renegociación TLS, y muchas opciones de contexto SSL nuevas para permitir un mayor control de grano fino en ajustes de protocolos y verificaciones al emplear flujos encriptados.

Estos cambios están descritos con más detalle en la sección Cambios de OpenSSL en PHP 5.6.x de esta guía de migración.

Soporte para pgsql asíncrono

La extensión pgsql ahora admite conexiones y consultas asíncronas, habilitando así un comportamiento de no bloqueo al interactuar con bases de datos de PostgreSQL. Las conexiones asíncronas podrían esteblecerse mediante la constante PGSQL_CONNECT_ASYNC, y se podrían emplear las nuevas funciones pg_connect_poll(), pg_socket(), pg_consume_input() y pg_flush() para manejar conexiones y consultas asíncronas.


Características obsoletas en PHP 5.6.x

Llamadas desde un contexto incompatible

Los métodos llamados desde un contexto incompatible ahora están obsoletos, generando errores E_DEPRECATED en lugar de E_STRICT cuando son invocados. El soporte para dichas llamadas será eliminado en una futura versión de PHP.

Un ejemplo de tales llamadas es:

<?php
class A {
    function f() { echo get_class($this); }
}

class B {
    function f() { A::f(); }
}

(new B)->f();
?>

El resultado del ejemplo sería:

Deprecated: Non-static method A::f() should not be called statically, assuming $this from incompatible context in - on line 7
B

$HTTP_RAW_POST_DATA y always_populate_raw_post_data

always_populate_raw_post_data ahora generará un error E_DEPRECATED cuando se rellene $HTTP_RAW_POST_DATA. El código nuevo debería utilizar php://input en lugar de $HTTP_RAW_POST_DATA, el cual será eliminado en una futura versión. Se puede activar este nuevo comportamiento (en el cual $HTTP_RAW_POST_DATA nunca está definido y por tanto no se generará un error E_DEPRECATED) estableciendo always_populate_raw_post_data a -1.

Ajustes de codificación de iconv y mbstring

Las opciones de configuración de iconv y mbstring relacionadas con la codificación están obsoletas en favor de default_charset. Las opciones obsoletas son:

  • iconv.input_encoding
  • iconv.output_encoding
  • iconv.internal_encoding
  • mbstring.http_input
  • mbstring.http_output
  • mbstring.internal_encoding


Cambios en funciones

Núcleo de PHP

  • crypt() ahora emitirá un error E_NOTICE si se omite el parámetro salt.
  • substr_compare() ahora aceptará 0 para su parámetro length.
  • unserialize() ahora fallará si se proporcionan datos serializados que hayan sido manipulados para intentar instanciar un objeto sin llamar a su constructor.

cURL

  • Las subidas empleando la sintaxis @file ahora únicamente están soportadas si la opción CURLOPT_SAFE_UPLOAD está establecida a false. Debería utilizarse en su lugar CURLFile.

Mcrypt

  • El valor predeterminado del parámetro source de mcrypt_create_iv() ahora es MCRYPT_DEV_URANDOM en vez de MCRYPT_DEV_RANDOM.

OpenSSL

  • stream_socket_enable_crypto() ahora permite que el parámetro crypto_type sea opcional si el contexto SSL del flujo incluye la nueva opción crypto_type.

PostgreSQL

  • pg_insert(), pg_select(), pg_update() y pg_delete() ya no son experimentales.
  • pg_send_execute(),
pg_send_prepare(), pg_send_query()
y pg_send_query_params() ya no bloquearán hasta
que termine la escritura de la consulta si el flujo de socket subyacente para
la conexión a la base de datos está establecido al modo de no bloqueo.

Reflection

  • ReflectionClass::newInstanceWithoutConstructor() ahora permite que se instancien clases internas no finales.

XMLReader

  • XMLReader::getAttributeNs() y XMLReader::getAttributeNo() ahora devuelven null si no se pudo encontrar el atributo, al igual que XMLReader::getAttribute().


Nuevas funciones

Fecha y Hora

  • DateTimeImmutable::createFromMutable()

GMP

  • gmp_root()
  • gmp_rootrem()

Hash

  • hash_equals()

LDAP

  • ldap_escape()
  • ldap_modify_batch()

MySQLi

  • mysqli_get_links_stats()

OCI8

  • oci_get_implicit_resultset()

OpenSSL

  • openssl_get_cert_locations()
  • openssl_x509_fingerprint()
  • openssl_spki_new()
  • openssl_spki_verify()
  • openssl_spki_export_challenge()
  • openssl_spki_export()

PostgreSQL

  • pg_connect_poll()
  • pg_consume_input()
  • pg_flush()
  • pg_socket()

PDO_PGSQL

  • PDO::pgsqlGetNotify()
  • PDO::pgsqlGetPid()

Session

  • session_abort()
  • session_reset()

Zip

  • ZipArchive::setPassword()


Cambios de OpenSSL en PHP 5.6.x

Las envolturas de flujos ahora verifican los certificados del par y los nombres de host por omisión al utilizar SSL/TLS

Todos los flujos encriptados de clientes ahora habilitan la verificación del par por omisión. De manera predeterminada se usará el paquete de CA predeterminado de OpenSSL para verificar el certificado del par. En la mayoría de los casos no será necesario realizar ningún cambio para comunicarse con servidores que posean certificados SSL válidos, ya que los distribuidores generalmente configuran OpenSSL para que emplee paquetes de CA bien conocidos.

El paquete de CA podría ser sobrescrito globalmente estableciendo la opción de configuración openssl.cafile u openssl.capath, o en función de cada petición, usando las opciones de contexto cafile o capath.

Aunque no se recomienda en general, es posible deshabilitar la verificación del certificado del par para una petición estableciendo la opción de contexto verify_peer a false, y para deshabilitar la validación del nombre del par estableciendo a false la opción de contexto verify_peer_name.

Huellas digitales de certificados

Se ha añadido soporte para extraer y verificar huellas digitales de certificados. Se ha añadido openssl_x509_fingerprint() para extraer una huella digital de un certificado X.509, y se han añadido dos opciones de contexto de flujo SSL: capture_peer_cert para capturar el certificado X.509 del par, y peer_fingerprint para confirmar que el certificado del par debería coincidir con la huella digital dada.

Cifradores predeterminados actualizados

Los cifradores predeterminados empleados por PHP han sido actualizados a una lista más segura basada en las » recomendaciones de cifradores de Mozilla, con dos exclusiones adicionales: cifradores Diffie-Hellman anónimos, y RC4.

Se puede acceder a la lista mediante la nueva constante OPENSSL_DEFAULT_STREAM_CIPHERS, y se puede sobrescribir (como en versiones anteriores de PHP) estableciendo la opción de contexto ciphers.

Compresión deshabilitada de forma predeterminada

La compresión SSL/TLS ha sido deshabilitada de forma predeterminada para mitigar el ataque CRIME. PHP 5.4.13 añadió la opción de contexto disable_compression para poder deshabilitar la compresión: ahora está establecida a true (es decir, la compresión está deshabilitada) de forma predeterminada.

Permitir que los servidores prefieran su orden de cifradores

Se ha añadido la opción de contexto honor_cipher_order de SSL para que los servidores de flujos encriptados mitiguen las vulnerabilidades BEAST prefiriendo los cifradores del servidor a los del cliente.

Acceder al cifrador y protocolo negociados

Ahora se puede acceder al protocolo y cifrador que eran negociados para un flujo encriptado mediante stream_get_meta_data() o stream_context_get_options() cuando la opción de contexto capture_session_meta de SSL está establecida a true.

<?php
$ctx = stream_context_create(['ssl' => [
    'capture_session_meta' => TRUE
]]);

$html = file_get_contents('https://google.com/', FALSE, $ctx);
$meta = stream_context_get_options($ctx)['ssl']['session_meta'];
var_dump($meta);
?>

El resultado del ejemplo sería:

array(4) {
  ["protocol"]=>
  string(5) "TLSv1"
  ["cipher_name"]=>
  string(20) "ECDHE-RSA-AES128-SHA"
  ["cipher_bits"]=>
  int(128)
  ["cipher_version"]=>
  string(11) "TLSv1/SSLv3"
}

Nuevas opciones para secreto hacia adelante perfecto en servidores de flujos encriptados

Los flujos de clientes encriptados ya admiten secreto hacia adelante perfecto (PFS por sus siglas en inglés), ya que está generalmente controlado por el servidor. Los flujos encriptados de servidores de PHP emplean certificados capaces del secreto hacia adelante perfecto no necesitan tomar ninguna acción adicional para habilitar PFS; sin embargo, se han añadido varias opciones de contexto de SSL para permitir un mayor control sobre PFS y tratar con cualquier problema de compatibilidad que pudiera surgir.

ecdh_curve

Esta opción permite la selección de una curva específica a emplear con cifradores ECDH. Si no se especifca, se empleará prime256v1.

dh_param

Una ruta a un fichero que contiene parámetros para el intercambio de claves Diffie-Hellman, tal como el creado por el siguiente comando:

openssl dhparam -out /path/to/my/certs/dh-2048.pem 2048
single_dh_use

Si se establece a true, se creará un nuevo par de claves cuando se emplean parámetros Diffie-Hellman, mejorando así el secreto hacia adelante.

single_ecdh_use

Si se establece a true, se generará siempre un nuevo par de claves cuando se negocian cifradores ECDH. Esto mejora el secreto hacia adelante.

Selección de la versión de SSL/TLS

Ahora es posible seleccionar versiones específicas de SSL y TLS mediante la opción de contexto crypto_method de SSL o estableciendo un transporte esepecífico al crear una envoltura de flujos (por ejemplo, llamando a stream_socket_client() o stream_socket_server()).

La opción de contexto crypto_method de SSL acepta una máscara de bit que enumere los protocolos que están permitidos, como lo hace crypto_type de stream_socket_enable_crypto().

Versiones de protocolo seleccionadas y opciones correspondientes
Protocolo/s | Indicador del cliente | Indicador del servidor | Transporte
Cualquier versión de TLS o SSL | STREAM_CRYPTO_METHOD_ANY_CLIENT | STREAM_CRYPTO_METHOD_ANY_SERVER | ssl://
Cualquier versión de TLS | STREAM_CRYPTO_METHOD_TLS_CLIENT | STREAM_CRYPTO_METHOD_TLS_SERVER | tls://
TLS 1.0 | STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_0_SERVER | tlsv1.0://
TLS 1.1 | STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_1_SERVER | tlsv1.1://
TLS 1.2 | STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_2_SERVER | tlsv1.2://
SSL 3 | STREAM_CRYPTO_METHOD_SSLv3_CLIENT | STREAM_CRYPTO_METHOD_SSLv3_SERVER | sslv3://
<?php

// Requerir TLS 1.0 o superior al emplear file_get_contents():
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLS_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Requerir TLS 1.1 o 1.2:
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT |
                           STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Conectar usando el transoporte de socket de flujo tlsv1.2:// .
$sock = stream_socket_client('tlsv1.2://google.com:443/');

?>

Se ha añadido openssl_get_cert_locations()

Se ha añadido la función openssl_get_cert_locations(): devuelve las ubicaciones predeterminadas en las cuales PHP buscará paquetes de CA.

<?php
var_dump(openssl_get_cert_locations());
?>

El resultado del ejemplo sería:

array(8) {
  ["default_cert_file"]=>
  string(21) "/etc/pki/tls/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/etc/pki/tls/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/etc/pki/tls/private"
  ["default_default_cert_area"]=>
  string(12) "/etc/pki/tls"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}

Soporte para SPKI

Se ha añadido soporte para generar, extraer y verificar claves públicas firmadas y retos (SPKAC por sus siglas en inglés). Se han añadido openssl_spki_new(), openssl_spki_verify(), openssl_spki_export_challenge(), y openssl_spki_export() para crear, verificar y exportar claves públicas PEM y retos asociados de SPKAC generadas desde un elemento KeyGen de HTML5.

openssl_spki_new

Genera una nueva SPKAC usando una clave privada, un string con un reto y un algoritmo de hash.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
?>

El resultado del ejemplo sería:

SPKAC=MIIBXjCByDCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA3L0IfUijj7+A8CPC8EmhcdNoe5fUAog7OrBdhn7EkxFButUp40P7+LiYiygYG1TmoI/a5EgsLU3s9twEz3hmgY9mYIqb/rb+SF8qlD/K6KVyUORC7Wlz1Df4L8O3DuRGzx6/+3jIW6cPBpfgH1sVuYS1vDBsP/gMMIxwTsKJ4P0CAwEAARYkYjViMzYxMTktNjY5YS00ZDljLWEyYzctMGZjNGFhMjVlMmE2MA0GCSqGSIb3DQEBAwUAA4GBAF7hu0ifzmjonhAak2FhhBRsKFDzXdKIkrWxVNe8e0bZzMrWOxFM/rqBgeH3/gtOUDRS5Fnzyq425UsTYbjfiKzxGeCYCQJb1KJ2V5Ij/mIJHZr53WYEXHQTNMGR8RPm7IxwVXVSHIgAfXsXZ9IXNbFbcaLRiSTr9/N4U+MXUWL7
openssl_spki_verify

Verifica la SPKAC provista.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
var_dump(openssl_spki_verify($spkac));
?>
openssl_spki_export_challenge

Exporta retos asociados desde la SPKAC provista.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge($spkac):
echo $challenge;
?>

El resultado del ejemplo sería:

challenge string
openssl_spki_export

Exporta la clave pública RSA con formato PEM desde la SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
echo openssl_spki_export($spkac);
?>

El resultado del ejemplo sería:

-----BEGIN PUBLIC KEY-----
MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDcvQh9SKOPv4DwI8LwSaFx02h7
l9QCiDs6sF2GfsSTEUG61SnjQ/v4uJiLKBgbVOagj9rkSCwtTez23ATPeGaBj2Zg
ipv+tv5IXyqUP8ropXJQ5ELtbXPUN/gvw7cO5EbPHr/7eMhbpw8Gl+AfWxW5hLW8
MGw/+AwwjHBOwong/QIDAQAB
-----END PUBLIC KEY-----


Otros cambios en extensiones

cURL

Se han eliminado varias constantes marcadas como obsoletas en la biblioteca cURL:

  • CURLOPT_CLOSEPOLICY
  • CURLCLOSEPOLICY_CALLBACK
  • CURLCLOSEPOLICY_LEAST_RECENTLY_USED
  • CURLCLOSEPOLICY_LEAST_TRAFFIC
  • CURLCLOSEPOLICY_OLDEST
  • CURLCLOSEPOLICY_SLOWEST

OCI8

  • Se ha añadido soporte para conjuntos de resultados implícitos para Oracle Database 12c mediante la nueva función oci_get_implicit_resultset().
  • El empleo de oci_execute($s, OCI_NO_AUTO_COMMIT) para una SELECT ya no inicia innecesariamente un ROLLBACK interno durante el cierre de la conexión.
  • Se han añadido las sondas DTrace controladas por la opción de configuración --enable-dtrace.
  • oci_internal_debug() ahora es una instrucción no-op.
  • Ha cambiado el formato de salida de phpinfo() para OCI8.

Zip

Se ha añadido una opción de configuración, --with-libzip, para emplear un sistema de instalación de libzip. Se requiere la versión 0.11 de libzip, y se recomienda la 0.11.2 o posterior.

MySQLi

Se ha añadido una nueva opción, mysqli.rollback_on_cached_plink, para revertir conexiones que han sido puestas de nuevo en la provisión de conexiones persistentes.


Nuevas constantes globales

GD

  • IMG_WEBP (a partir de PHP 5.6.25)

LDAP

  • LDAP_ESCAPE_DN
  • LDAP_ESCAPE_FILTER

OpenSSL

  • OPENSSL_DEFAULT_STREAM_CIPHERS
  • STREAM_CRYPTO_METHOD_ANY_CLIENT
  • STREAM_CRYPTO_METHOD_ANY_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_0_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_1_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_2_SERVER

PostgreSQL

  • PGSQL_CONNECT_ASYNC
  • PGSQL_CONNECTION_AUTH_OK
  • PGSQL_CONNECTION_AWAITING_RESPONSE
  • PGSQL_CONNECTION_MADE
  • PGSQL_CONNECTION_SETENV
  • PGSQL_CONNECTION_SSL_STARTUP
  • PGSQL_CONNECTION_STARTED
  • PGSQL_DML_ESCAPE
  • PGSQL_POLLING_ACTIVE
  • PGSQL_POLLING_FAILED
  • PGSQL_POLLING_OK
  • PGSQL_POLLING_READING
  • PGSQL_POLLING_WRITING


  • « Nuevas constantes globales
  • Sobre la depuración en PHP »
  • PHP Manual
  • Apéndices
  • Depuración en PHP

Depuración en PHP

Tabla de contenidos

  • Sobre la depuración en PHP


Sobre la depuración en PHP

PHP 5.6 viene con el depurador interactivo phpdbg. Las versiones de PHP anteriores a la 5.6 no cuentan con una herramienta de depuración interna, sin embargo. Aún así, se puede utilizar uno de los depuradores externos. El » IDE Zend incluye un depurador y existen también algunas extensiones de depuración gratuitas como DBG en » http://www.php-debugger.com/dbg/, el » Depurador Avanzado de PHP (APD, por sus siglas en Inglés) o » Xdebug.


  • « Sobre la depuración en PHP
  • Listado de opciones de configuración del núcleo »
  • PHP Manual
  • Apéndices
  • Opciones de configuración

Opciones de configuración

Tabla de contenidos

  • Listado de opciones de configuración del núcleo


Listado de opciones de configuración del núcleo

A continuación se muestra una lista de parte de las opciones de configuración usadas por el script configure de PHP cuando se compila en entornos como UNIX. La mayoría de las opciones de configuración se enumeran en su ubicación correspondiente de las páginas de referencia de cada extensión, no aquí. Para una lista actualizada y completa de las opciones de configuración, ejecute ./configure --help en el directorio origen de PHP después de ejecutar autoconf (véase también el capítulo de Instalación). Podría ser interesante también consultar la documentación de » GNU configure para mayor información en otras opciones de configure como --prefix=PREFIJO.

Nota:

Estas opciones se utilizan únicamente durante la compilación. Si desea alterar la configuración en tiempo de ejecución de PHP, por favor vea el capítulo sobre Configuración en tiempo de ejecución.

  • Misceláneo
  • Comportamiento de PHP
  • Servidor

Opciones de configuración en PHP

Otras opciones

--enable-debug

Compilar con símbolos de depuración.

--with-layout=TYPE

Establece la forma de presentar los ficheros instalados. El tipo es PHP (predeterminado) o GNU.

--with-pear=DIR

Instalar PEAR en DIR (valor predeterminado PREFIJO/lib/php).

--without-pear

No instalar PEAR.

--enable-sigchild

Habilitar el propio manejador SIGCHLD de PHP.

--disable-rpath

Deshabilitar el paso de rutas adicionales de búsqueda de bibliotecas en tiempo de ejecución.

--enable-libgcc

Habilitar explícitamente el enlazado con libgcc.

--enable-php-streams

Incluir flujos de PHP experimentales. ¡No se use a menos que este probando el código!.

--with-zlib-dir[=DIR]

Definir la localización del directorio de instalación de zlib.

--with-tsrm-pthreads

Usar hilos de POSIX (predeterminado).

--enable-shared[=PKGS]

Construir bibliotecas compartidas [predeterminado=yes].

--enable-static[=PKGS]

Construir bibliotecas estáticas [predeterminado=yes].

--enable-fast-install[=PKGS]

Optimizar para una instalación rápida [predeterminado=yes].

--with-gnu-ld

Asumir que el compilador de C usa ld de GNU [predeterminado=no].

--disable-libtool-lock

Evitar bloqueos (podría romper construcciones en paralelo).

--with-pic

Intentar usar solo objetos PIC/no PIC [predeterminado=use both].

--enable-memory-limit

Compilar con soporte de límite de memoria. (No disponible desde PHP 5.2.1: siempre está habilitado).

--disable-url-fopen-wrapper

Deshabilitar la envoltura de fopen que considera URL que permita el acceso a ficheros mediante HTTP o FTP. (No disponible desde PHP 5.2.5)

--enable-versioning

Exportar solo los símbolos requeridos. Véase INSTALL para más información.

Opciones de PHP

--enable-maintainer-mode

Habilita las reglas y dependencias de Make, que no son útiles (y en ocasiones son confusas) para el usuario habitual.

--with-config-file-path=PATH

Establece la ruta a seguir para php.ini, el valor por defecto es /PREFIX/lib.

--enable-safe-mode

Habilita safe mode por defecto.

Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

--with-exec-dir[=DIR]

Solo permite ejecutables en DIR cuando safe mode está por defecto a /usr/local/php/bin.

Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

--enable-magic-quotes

Habilita magic quotes por defecto.

Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

--disable-short-tags

Deshabilita la forma corta de la etiqueta de inicio php <? por defecto.

--enable-zend-multibyte

Habilita código multibyte en el analizador y el escáner de lenguaje PHP para ser ejecutado. Cuando PHP se compila con esta opción, también habilita la directiva encoding en el constructor declare.

Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0 y ELIMINADA a partir de PHP 5.4.0.

--with-libdir

Especifica el directorio en el que están las librerías para compilar PHP en un sistema Unix. Para sistemas de 64 bits, es necesario especificar este argumento para poder usar el directorio lib64: --with-libdir=lib64.

Opciones SAPI

La siguiente lista contiene los SAPI&s disponibles ( Server Application Programming Interface) para PHP.

--with-aolserver=DIR

Especifica la ruta donde está AOLserver.

--with-apxs[=FILE]

Crea un módulo compartido de Apache. FILE es la ruta opcional de la herramienta Apache apxs, por defecto a apxs. Asegúrese de especificar la versión de apxs que está instalada en su sistema y NO la que está en los fuentes de Apache.

--with-apache[=DIR]

Crea un módulo estático de Apache. DIR es el directorio de Apache, por defecto es /usr/local/apache.

--with-mod_charset

Habilita la tranferencia de tablas para mod_charset (Apache en Ruso).

--with-apxs2[=FILE]

Crea un módulo compartido de Apache 2.0. FILE es la ruta opcional a la herramienta apxs, por defecto a apxs.

--with-caudium=DIR

Crea PHP como un módulo Pike para ser usado con Caudium. DIR es el directorio del servidor Caudium, con el valor por defecto /usr/local/caudium/server.

--disable-cli

Deshabilita la versión CLI de PHP (esto fuerza--without-pear). Para mayor información, vea la sección acerca de Usando PHP desde la línea de comando.

--enable-phpdbg

Habilitar el soporte para el módulo SAPI de depuración interactiva phpdbg en PHP 5.6.x o superior.

--enable-embed[=TYPE]

Habilita la creación de la librería SAPI. TYPE es shared o static, el valor por defecto es shared.

--with-isapi=DIR

Crea PHP como un módulo ISAPI para ser usado con Zeus.

--with-nsapi=DIR

Especifica la ruta para el servidor web instalado Netscape/iPlanet/SunONE.

--with-phttpd=DIR

No hay información disponible.

--with-pi3web=DIR

Crea PHP como un módulo para ser usado con Pi3Web.

--with-roxen=DIR

Crea PHP como un módulo Pike. DIR es el directorio base de Roxen, normalmente /usr/local/roxen/server.

--enable-roxen-zts

Crea el modulo Roxen usando Zend Thread Safety..

--with-servlet[=DIR]

Incluye soporte para servlet. DIR es el directorio base de instalación de JSDK. Este SAPI requiere que la extensión de java sea creada como un dl compartido.

--with-thttpd=SRCDIR

Crea PHP como un modulo thttpd.

--with-tux=MODULEDIR

Crea PHP como un módulo TUX (solo Linux).

--with-webjames=SRCDIR

Crea PHP como un módulo WebJames (solo RISC OS).

--disable-cgi

Desabilita la versión CGI de la construcción de PHP.

Desde PHP 5.3.0 este argumento habilita FastCGI mientras que anteriormente se tenía que activar usando --enable-fastcgi.

--enable-force-cgi-redirect

Habilita el chequeo de seguridad para redirecciones internas del servidor. Debe usar esta opción si esta ejecutando la versión CGI con Apache.

Desde PHP 5.3.0 este argumento está habilitado por defecto y ya no existe. Para deshabilitarlo se debe definir la directiva ini cgi.force_redirect a 0.

--enable-discard-path

Si esta opción está habilitada, el binario CGI de PHP puede, de manera segura, ser puesto fuera de la trayectoria web y los usuarios no podrán evitar la seguridad de .htaccess.

Desde PHP 5.3.0 este argumento está deshabilitado por defecto y ya no existe. Para activar esta opción la directiva ini cgi.discard_path debe estar definida como 1.

--enable-fastcgi

Si esta opción está activada, el modulo CGI será construido también con soporte para FastCGI.

Desde PHP 5.3.0 este argumento ya no existe y debe ser habilitado usando --enable-cgi en su lugar.

--disable-path-info-check

Si esta opción esta deshabilitada, las rutas, tales como /info.php/test?a=b fallarán. Para mas información vea el » Manual de Apache.

A partir de PHP 5.3.0 este argumento está activado por defecto y ya no existe. Para desactivar esta característica la directiva ini cgi.fix_pathinfo debe establecerse a 0.


Directivas de php.ini

Tabla de contenidos

  • Listado de directivas de php.ini
  • Lista de secciones de php.ini
  • Descripción de las directivas del núcleo de php.ini


Listado de directivas de php.ini

Este listado incluye las directivas de php.ini que se pueden establecer para la configuración de PHP.

La columna "Cambiable" muestra los modos que determinan cuándo y dónde una directiva puede ser establecida. Véase la sección Valores de modo cambiable para sus definiciones.

Opciones de configuración
Nombre | Por defecto | Cambiable | Historial de cambios
allow_url_fopen | "1" | PHP_INI_SYSTEM |
allow_url_include | "0" | PHP_INI_SYSTEM | Obsoleta desde desde PHP 5.2.0.
arg_separator.input | "&" | PHP_INI_PERDIR |
arg_separator.output | "&" | PHP_INI_ALL |
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
auto_append_file | NULL | PHP_INI_PERDIR |
auto_detect_line_endings | "0" | PHP_INI_ALL |
auto_globals_jit | "1" | PHP_INI_PERDIR | Disponible desde PHP 5.0.0.
auto_prepend_file | NULL | PHP_INI_PERDIR |
browscap | NULL | PHP_INI_SYSTEM |
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM |
cgi.discard_path | "0" | PHP_INI_SYSTEM |
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM |
cgi.force_redirect | "1" | PHP_INI_SYSTEM |
cgi.nph | "0" | PHP_INI_ALL |
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM |
cgi.rfc2616_headers | "0" | PHP_INI_ALL |
child_terminate | "0" | PHP_INI_ALL |
default_charset | "UTF-8" | PHP_INI_ALL | Predeterminado a "UTF-8".
default_mimetype | "text/html" | PHP_INI_ALL |
default_socket_timeout | "60" | PHP_INI_ALL |
disable_classes | "" | php.ini only |
disable_functions | "" | php.ini only |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL | Disponible desde PHP 4.0.3.
docref_ext | "" | PHP_INI_ALL |
docref_root | "" | PHP_INI_ALL |
doc_root | NULL | PHP_INI_SYSTEM |
enable_dl | "1" | PHP_INI_SYSTEM | Esta característica obsoleta será eliminada con certeza en el futuro.
enable_post_data_reading | On | PHP_INI_PERDIR |
engine | "1" | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
error_prepend_string | NULL | PHP_INI_ALL |
error_reporting | NULL | PHP_INI_ALL |
exit_on_timeout | "" | PHP_INI_ALL | Disponible desde PHP 5.3.0
expose_php | "1" | php.ini only |
extension | NULL | php.ini only |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
fastcgi.impersonate | "0" | PHP_INI_SYSTEM |
fastcgi.logging | "1" | PHP_INI_SYSTEM |
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde PHP 4.2.0.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | Disponible desde PHP 4.0.6.
fbsql.batchSize | "1000" | PHP_INI_SYSTEM |
fbsql.batchsize | "1000" | PHP_INI_ALL |
fbsql.default_database | "" | PHP_INI_SYSTEM |
fbsql.default_database_password | "" | PHP_INI_SYSTEM |
fbsql.default_host | NULL | PHP_INI_SYSTEM |
fbsql.default_password | "" | PHP_INI_SYSTEM |
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM |
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM |
fbsql.max_connections | "128" | PHP_INI_SYSTEM |
fbsql.max_links | "128" | PHP_INI_SYSTEM |
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM |
fbsql.max_results | "128" | PHP_INI_SYSTEM |
fbsql.show_timestamp_decimals | "0" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.5.
file_uploads | "1" | PHP_INI_SYSTEM |
from | "" | PHP_INI_ALL |
hard_timeout | "2" | PHP_INI_SYSTEM | Available since PHP 7.1.0.
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL |
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Disponible desde ibm_db2 1.8.0.
ignore_repeated_errors | "0" | PHP_INI_ALL |
ignore_repeated_source | "0" | PHP_INI_ALL |
ignore_user_abort | "0" | PHP_INI_ALL |
implicit_flush | "0" | PHP_INI_ALL |
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Disponible desde ingres 1.4.0
ingres.auto | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Disponible desde ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Disponible desde ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Disponible desde ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
last_modified | "0" | PHP_INI_ALL |
intl.default_locale | "" | PHP_INI_ALL |
intl.error_level | "0" | PHP_INI_ALL |
intl.use_exceptions | "0" | PHP_INI_ALL |
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Disponible desde ingres 1.4.0
ingres.auto | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Disponible desde ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Disponible desde ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Disponible desde ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Disponible desde ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Disponible desde ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Disponible desde ingres 2.0.0.
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL |
mail.add_x_header | "0" | PHP_INI_PERDIR |
mail.force_extra_parameters | NULL | php.ini only |
mail.log | "" | PHP_INI_PERDIR |
max_execution_time | "30" | PHP_INI_ALL |
max_input_nesting_level | "64" | PHP_INI_PERDIR |
max_input_vars | 1000 | PHP_INI_PERDIR | Disponible desde PHP 5.3.9.
max_input_time | "-1" | PHP_INI_PERDIR |
memory_limit | "128M" | PHP_INI_ALL |
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Eliminado en 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Añadido en 1.2.10, antes de 1.3.0 el valor predeterminado era 60.
mongo.long_as_object | o | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Antes de la versión 1.5.0, el valor predeterminado era 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Añadido en 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | Disponible desde PHP 4.3.0.
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | Disponible desde PHP 4.0.1.
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | PHP_INI_SYSTEM en PHP <= 4.3.2. Disponible desde PHP 4.3.0.
mysqli.allow_local_infile | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.2.4.
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
mysqli.max_links | "-1" | PHP_INI_SYSTEM | Disponible desde PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_host | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | Disponible desde PHP 5.0.0.
mysqli.reconnect | "0" | PHP_INI_SYSTEM | Disponible desde PHP 4.3.5.
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | Disponible desde PHP 5.6.0.
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Disponible desde 1.0.0
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |
opcache.enable | "1" | PHP_INI_ALL |
opcache.enable_cli | "0" | PHP_INI_SYSTEM | Entre PHP 7.1.2 y 7.1.6 inclusive, el valor predetermindao era "1"
opcache.memory_consumption | "128" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "64"
opcache.interned_strings_buffer | "8" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "4"
opcache.max_accelerated_files | "10000" | PHP_INI_SYSTEM | Antes de PHP 7.0.0 el valor predeterminado era "2000"
opcache.max_wasted_percentage | "5" | PHP_INI_SYSTEM |
opcache.use_cwd | "1" | PHP_INI_SYSTEM |
opcache.validate_timestamps | "1" | PHP_INI_ALL |
opcache.revalidate_freq | "2" | PHP_INI_ALL |
opcache.revalidate_path | "0" | PHP_INI_ALL |
opcache.save_comments | "1" | PHP_INI_SYSTEM |
opcache.load_comments | "1" | PHP_INI_ALL | Eliminado en PHP 7.0.0.
opcache.fast_shutdown | "0" | PHP_INI_SYSTEM | Eliminado en PHP 7.2.0.
opcache.enable_file_override | "0" | PHP_INI_SYSTEM |
opcache.optimization_level | "0x7FFFBFFF" | PHP_INI_SYSTEM | Cambiado desde 0xFFFFFFFF en PHP 5.6.18
opcache.inherited_hack | "1" | PHP_INI_SYSTEM | Eliminado en PHP 7.3.0.
opcache.dups_fix | "0" | PHP_INI_ALL |
opcache.blacklist_filename | "" | PHP_INI_SYSTEM |
opcache.max_file_size | "0" | PHP_INI_SYSTEM |
opcache.consistency_checks | "0" | PHP_INI_ALL |
opcache.force_restart_timeout | "180" | PHP_INI_SYSTEM |
opcache.error_log | "" | PHP_INI_SYSTEM |
opcache.log_verbosity_level | "1" | PHP_INI_SYSTEM |
opcache.preferred_memory_model | "" | PHP_INI_SYSTEM |
opcache.protect_memory | "0" | PHP_INI_SYSTEM |
opcache.mmap_base | null | PHP_INI_SYSTEM |
opcache.restrict_api | "" | PHP_INI_SYSTEM |
opcache.file_update_protection | "2" | PHP_INI_ALL |
opcache.huge_code_pages | "0" | PHP_INI_SYSTEM |
opcache.lockfile_path | "/tmp" | PHP_INI_SYSTEM |
opcache.opt_debug_level | "0" | PHP_INI_SYSTEM |
opcache.file_cache | NULL | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_only | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_consistency_checks | "1" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.0
opcache.file_cache_fallback | "1" | PHP_INI_SYSTEM | Solo Windows. Disponible a partir de PHP 7.0.0
opcache.validate_permission | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.14
opcache.validate_root | "0" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.0.14
opcache.preload | "" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.4.0
opcache.preload_user | "" | PHP_INI_SYSTEM | Disponible a partir de PHP 7.4.0
open_basedir | NULL | PHP_INI_ALL |
oracle.allow_persistent | "-1" | PHP_INI_ALL |
oracle.max_links | "-1" | PHP_INI_ALL |
oracle.max_persistent | "-1" | PHP_INI_ALL |
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR |
post_max_size | "8M" | PHP_INI_PERDIR |
precision | "14" | PHP_INI_ALL |
realpath_cache_size | "16K" | PHP_INI_SYSTEM |
realpath_cache_ttl | "120" | PHP_INI_SYSTEM |
register_argc_argv | "1" | PHP_INI_PERDIR |
report_memleaks | "1" | PHP_INI_ALL |
report_zend_debug | "1" | PHP_INI_ALL |
request_order | "" | PHP_INI_PERDIR |
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | "/usr/sbin/sendmail -t -i" | PHP_INI_SYSTEM |
serialize_precision | "-1" | PHP_INI_ALL | Hasta PHP 7.1.0, el valor predeterminado era 17.
short_open_tag | "1" | PHP_INI_PERDIR |
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL |
sql.safe_mode | "0" | PHP_INI_SYSTEM |
syslog.facility | "LOG_USER" | PHP_INI_SYSTEM | Disponible desde PHP 7.3.0.
syslog.filter | "no-ctrl" | PHP_INI_ALL | Disponible desde PHP 7.3.0.
syslog.ident | "php" | PHP_INI_SYSTEM | Disponible desde PHP 7.3.0.
sys_temp_dir | "" | PHP_INI_SYSTEM |
track_errors | "0" | PHP_INI_ALL | Obsoleta desde PHP 7.2.0.
unserialize_callback_func | NULL | PHP_INI_ALL | Disponible desde PHP 4.2.0.
uploadprogress.file.filename_template | "/tmp/upt_%s.txt" | PHP_INI_ALL |
upload_max_filesize | "2M" | PHP_INI_PERDIR |
max_file_uploads | 20 | PHP_INI_SYSTEM |
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL |
user_agent | NULL | PHP_INI_ALL |
user_dir | NULL | PHP_INI_SYSTEM |
user_ini.cache_ttl | "300" | PHP_INI_SYSTEM |
user_ini.filename | ".user.ini" | PHP_INI_SYSTEM |
uopz.disable | "0" | PHP_INI_SYSTEM | Available as of uopz 5.0.2
uopz.exit | "0" | PHP_INI_SYSTEM | Available as of uopz 6.0.1
uopz.overloads | "1" | PHP_INI_SYSTEM | Available as of uopz 2.0.2. Removed as of uopz 5.0.0.
variables_order | "EGPCS" | PHP_INI_PERDIR |
vld.active | "0" | PHP_INI_SYSTEM |
vld.execute | "1" | PHP_INI_SYSTEM | Disponible desde vld 0.8.0.
vld.skip_append | "0" | PHP_INI_SYSTEM | Disponible desde vld 0.8.0.
vld.skip_prepend | "0" | PHP_INI_SYSTEM | Disponible desde vld 0.8.0.
windows.show_crt_warning | "0" | PHP_INI_ALL |
xbithack | "0" | PHP_INI_ALL |
xmlrpc_errors | "0" | PHP_INI_SYSTEM |
xmlrpc_error_number | "0" | PHP_INI_ALL |
yaz.keepalive | "120" | PHP_INI_ALL |
yaz.log_mask | NULL | PHP_INI_ALL | Disponible desde yaz 1.0.3.
zend.assertions | "1" | PHP_INI_ALL |
zend.detect_unicode | "1" | PHP_INI_ALL |
zend.enable_gc | "1" | PHP_INI_ALL |
zend.multibyte | "0" | PHP_INI_PERDIR |
zend.script_encoding | NULL | PHP_INI_ALL |
zend.signal_check | "0" | PHP_INI_SYSTEM |
zend_extension | NULL | Solamente en php.ini |


Lista de secciones de php.ini

Esta lista incluye las secciones de php.ini que se pueden establecer para configurar los ajustes de PHP según cada servidor o ruta. Estas secciones son opcionales.

Estas secciones no afectan directamente a PHP. Se utilizan para agrupar otras directivas de php.ini y hacerlas funcionar para un servidor o ruta determinados.

Estas secciones solo se utilizan en modo CGI/FastCGI y no pueden configurar directivas de extensión ni de zend_extension.

Secciones
Nombre | Cambiable | Historial de cambios
[HOST=] | PHP_INI_SYSTEM | Añadida en PHP 5.3.0.
[PATH=] | PHP_INI_SYSTEM | Añadida en PHP 5.3.0.

He aquí una breve explicación de las directivas de configuración.

[HOST=<host>]

Esta sección permite definir un conjunto de directivas de php.ini que afectarán solamente al servidor designado.

Ejemplo #1 Activar la notificación completa de errores por pantalla para el dominio dev.

[HOST=dev.site.com]
error_reporting = E_ALL
display_errors = On

[PATH=<path>]

Esta sección permite definir un conjunto de directivas de php.ini que tomarán efecto al ejecutar un script en la ruta designada.

Ejemplo #2 Añadir un script de seguridad para aréas protegidas

[PATH=/home/site/public/secure]
auto_prepend_file=security.php


Descripción de las directivas del núcleo de php.ini

Esta lista incluye las directivas del núcleo de php.ini que se pueden establecer para la configuración de PHP. Las directivas manejadas por extensiones están enumeradas y detalladas en las respectivas páginas de la documentación de cada extensión. La información sobre las directivas de sesión, por ejemplo, se puede encontrar en la página de sesiones.

Nota:

Las opciones predeterminadas enumeradas aquí se usan cuando php.ini no está cargado; los valores para el php.ini de producción y desarrollo podrían variar.

Opciones del lenguaje

Opciones del lenguaje y configuración variada
Nombre | Por defecto | Cambiable | Historial de cambios
short_open_tag | "1" | PHP_INI_PERDIR |
asp_tags | "0" | PHP_INI_PERDIR | Eliminada in PHP 7.0.0.
precision | "14" | PHP_INI_ALL |
serialize_precision | "-1" | PHP_INI_ALL | Hasta PHP 5.3.5, el valor predeterminado era 100. Antes de PHP 7.1.0, el valor predeterminado era 17.
y2k_compliance | "1" | PHP_INI_ALL | Eliminado en PHP 5.4.0.
allow_call_time_pass_reference | "1" | PHP_INI_PERDIR | Eliminada en PHP 5.4.0.
disable_functions | "" | Sólo en PHP_INI_SYSTEM |
disable_classes | "" | Sólo en php.ini |
exit_on_timeout | "" | INI_ALL | Disponible desde PHP 5.3.0.
expose_php | "1" | Sólo en php.ini |
hard_timeout | "2" | PHP_INI_SYSTEM | Disponible desde PHP 7.1.0.
zend.exception_ignore_args | "0" | PHP_INI_ALL | Disponible desde PHP 7.4.0
zend.multibyte | "0" | PHP_INI_ALL | Disponible desde PHP 5.4.0
zend.script_encoding | NULL | PHP_INI_ALL | Disponible desde PHP 5.4.0
zend.detect-unicode | NULL | PHP_INI_ALL | Disponible desde PHP 5.4.0
zend.signal_check | "0" | PHP_INI_SYSTEM | Disponible desde PHP 5.4.0
zend.assertions | "1" | PHP_INI_ALL con restricciones | Disponible desde PHP 7.0.0.
detect_unicode | "1" | PHP_INI_ALL | Disponible desde PHP 5.1.0. Renombrada a zend.detect-unicode desde PHP 5.4.0.

He aquí una breve explicación de las directivas de configuración.

short_open_tag boolean

Indica a PHP si debería permitirse la forma abreviada de las etiquetas de apertura de PHP (<? ?>). Si se quiere utilizar PHP junto con XML, se puede desactivar esta opción para poder usar <?xml ?> en línea. Si no, puede imprimirse con PHP, por ejemplo: <?php echo '<?xml version="1.0"?>'; ?>. Además, si está desactivada, se debe usar siempre la forma no abreviada de la etiqueta de apertura de PHP (<?php ?>).

Nota:

Esta directiva también afecta a la abreviatura <?= en versiones anteriores a PHP 5.4.0, la cual es lo mismo que <? echo. El uso de esta abreviatura requería que short_open_tag estuviese activada. Desde PHP 5.4.0, <?= siempre está disponible.

asp_tags boolean
Activa el uso de las etiquetas estilo ASP (<% %>) además de las normales (<?php ?>). Esto incluye la abreviatura de variable-valor <%= $valor %>. Para más información, véase Salir de HTML.

Registro de cambios para asp_tags
Versión | Descripción
7.0.0 | Eliminada de PHP.

precision integer
El número de dígitos significativos que se muestran en números de punto flotante. -1 significa que se utilizará el algoritmo mejorado para redondear dichos números.
serialize_precision integer
El número de dígitos significativos almacenados durante la serialización de números de punto flotante. -1 significa que se utilizará el algoritmo mejorado para redondear dichos números.
y2k_compliance boolean
Asegura la compatibilidad con el año 2000 (causará problemas con navegadores no compatibles)
allow_call_time_pass_reference boolean

Sirve para avisar cuándo los argumentos son pasados por referencia al llamar a una función. El método recomendado para especificar los argumentos que deberían parsarse por referencia es en la declaración de la función. Se anima a probar y desactivar esta opción para asegurarse de que los scripts funcionen adecuadamente también en futuras versiones del lenguaje (si está característica está desactivada, se mostrará una advertencia cada vez que se utilice).

El paso de argumentos por referencia en el momento de llamar a una función quedó obsoleto por razones de limpieza en el código. Una función puede modificar sus argumentos de una manera no documentada si no declaró que dichos argumentos deberían ser pasados por referencia. Para evitar efectos secundarios, es mejor especificar qué argumentos son pasados por referencia solamente en la declaración de la función.

Véase también Explicación de las referencias.

Registro de cambios de allow_call_time_pass_reference
Versión | Descripción
5.4.0 | Eliminada de PHP.
5.3.0 | Emite un error de nivel E_DEPRECATED.
5.0.0 | Obsoleta, y genera un error de nivel E_COMPILE_WARNING.

expose_php boolean

Expone al mundo que PHP está instalado en el servidor, lo que incluye la versión de PHP en la cabecera HTTP (p.ej., X-Powered-By: PHP/5.3.7). Antes de PHP 5.5.0, los GUIDs del logotipo de PHP también eran expuestos, por lo que al añadirlos a la URL de un script de PHP, se mostraba el logotipo correspondiente (p.ej., » https://www.php.net/?=PHPE9568F34-D428-11d2-A769-00AA001ACF42). Esto también afectaba a la salida de phpinfo(), ya que cuando estaba desactivada, no se mostraban el logotipo de PHP y la información de los créditos.

Nota:

Desde PHP 5.5.0, estos GUIDs y la función php_logo_guid() han sido eliminados de PHP, y los GUIDs han sido reemplazados en su lugar con URIs de datos. Por lo tanto, ya no funciona el acceso al logotipo de PHP mediante la adición del GUID a la URL. Similarmente, desactivar expose_php no afectará a la visualización del logotipo de PHP en phpinfo().

Véase también php_logo_guid() y phpcredits().

disable_functions string

Esta directiva permite desactivar ciertas funciones por razones de seguridad. Requiere una lista con los nombres de las funciones delimitados por comas.

Solamente las funciones internas pueden ser desactivadas usando esta directiva. Las funciones definidas por el usuario no se ven afectadas.

Esta directiva debe ser establecida en el fichero php.ini. Por ejemplo, no puede establecerse en httpd.conf.

disable_classes string
Esta directiva permite desactivar ciertas clases por razones de seguridad. Requiere una lista con los nombres de las clases delimitados por comas. Esta directiva debe ser establecida en el fichero php.ini. Por ejemplo, no puede establecerse en httpd.conf.
zend.assertions integer
Cuando se establece a 1, se generará y se ejecutará código de afirmaciones (modo desarrollo). Si se establece a 0, el código de afirmaciones se generará aunque será saltado (no ejecutado) durante la ejecución. Cuando se establece a -1, el código de afirmaciones no se generará, haciendo que las afirmaciones tengan un coste de cero (modo producción).

Nota:

Si un proceso se inicia en modo de producción, zend.assertions no podrá ser cambiado durante la ejecución, ya que no se generó el código para las afirmaciones.

Si un proceso se inicia en modo desarrollo, zend.assertions no podrá ser establecido a -1 durante la ejecución.

hard_timeout int

zend.exception_ignore_args bool

Excluye argumentos del stack trace generados a partir de excepciones.

zend.multibyte bool

Permite analizar los ficheros fuentes con codificación multibyte. Se requiere habilitar zend.multibyte para utilizar codificaciones de caracteres como SJIS, BIG5, etc que contienen caracteres especiales en datos de cadenas multibyte. Las codificaciones compatibles con ISO-8859-1 como UTF-8, EUC, etc no requieren esta opción.

Enabling zend.multibyte requires the mbstring extension to be available.

zend.script_encoding string

Este valor será usado a menos que una directiva declare(encoding=...) aparezca al principio del script. Cuando se emplea una codificación incompatible con ISO-8859-1, se deben utilizar zend.multibyte y zend.script_encoding.

Los string literales se transliterarán de zend.script_enconding a mbstring.internal_encoding, como si mb_convert_encoding() hubiera sido llamada.

zend.detect_unicode boolean

Comprobar la marca BOM (Byte Order Mark) y verificar si el fichero contiene caracteres multibyte válidos. Esta detección se realiza antes de procesar __halt_compiler(). Disponible solamente en modo Zend Multibyte.

zend.signal_check boolean

Para verficar gestores de señales reemplazados en el apagado.

exit_on_timeout boolean

Esta es una directiva mod_php-only de Apache1 que fuerza a un subproceso de Apache a salir si expiró el tiempo de ejecución de PHP. Este tiempo de espera provoca una llamada interna a longjmp() en Apache1, que puede dejar algunas extensiones en un estado de incoherencia. Al terminar el proceso, será limpiado cualquier bloqueo pendiente o la memoria.

Límite de recursos

Límite de recursos
Nombre | Por defecto | Cambiable | Historial de cambios
memory_limit | "128M" | PHP_INI_ALL | "8M" antes de PHP 5.2.0, "16M" en PHP 5.2.0

He aquí una breve explicación de las directivas de configuración.

memory_limit integer

Establece el máximo de memoria en bytes que un script puede consumir. Ayuda a prevenir que scripts mal programados consuman toda la memoria disponible en el servidor. Observe que para no tener límite de memoria, se ha de establecer esta directiva a -1.

En versiones anteriores a PHP 5.2.1, esta directiva tenía que estar habilitada en tiempo de compilación usando --enable-memory-limit en la línea de configuración. Esta bandera en tiempo de compilación también se requería para definir las funciones memory_get_usage() y memory_get_peak_usage() en versiones anteriores a PHP 5.2.1.

Cuando se usa un integer, el valor del mismo es medido en bytes. También se puede usar la notación reducida, tal como se describe en esta FAQ.

Véase también: max_execution_time.

Ajuste del rendimiento

Ajuste del rendimiento
Nombre | Por defecto | Cambiable | Historial de cambios
realpath_cache_size | "16K" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.0.
realpath_cache_ttl | "120" | PHP_INI_SYSTEM | Disponible desde PHP 5.1.0.

He aquí una breve explicación de las directivas de configuración.

realpath_cache_size integer

Determina el tamaño de la caché de realpath que va a ser usada por PHP. Este valor debe ser incrementado en sistemas donde PHP abra muchos ficheros, para reflejar la cantidad de operaciones realizadas con ficheros.

El tamaño representa el número total de bytes de los strings de rutas almacenadas, más el tamaño de los datos asociados con la entrada de la caché. Esto significa que para poder almacenar rutas mayores en la caché, el tamaño de esta debe ser mayor. Este valor no controla directamente el número de rutas distintas que pueden ser almacenadas en caché.

El tamaño requerido para los datos de entrada de la caché depende del sistema.

realpath_cache_ttl integer

Tiempo (en segundos) durante el cual almacenar en caché información de realpath para un determinado fichero o directorio. Para sistemas que raramente cambian ficheros, considere incrementar este valor.

Manejo de datos

Opciones de configuración de manejo de datos
Nombre | Por defecto | Cambiable | Historial de cambios
arg_separator.output | "&" | PHP_INI_ALL |
arg_separator.input | "&" | PHP_INI_PERDIR |
variables_order | "EGPCS" | PHP_INI_PERDIR | PHP_INI_ALL en PHP <= 5.0.5.
request_order | "" | PHP_INI_PERDIR | Disponible desde PHP 5.3.0
auto_globals_jit | "1" | PHP_INI_PERDIR |
register_argc_argv | "1" | PHP_INI_PERDIR |
register_long_arrays | "1" | PHP_INI_PERDIR | Obsoleta en PHP 5.3.0. Eliminada en PHP 5.4.0.
enable_post_data_reading | "1" | PHP_INI_PERDIR | Disponible desde PHP 5.4.0
post_max_size | "8M" | PHP_INI_PERDIR |
auto_prepend_file | NULL | PHP_INI_PERDIR |
auto_append_file | NULL | PHP_INI_PERDIR |
default_mimetype | "text/html" | PHP_INI_ALL |
default_charset | "UTF-8" | PHP_INI_ALL | Se predetermina a "UTF-8" desde PHP >= 5.6.0, vacío para PHP < 5.6.0.
always_populate_raw_post_data | "0" | PHP_INI_PERDIR | Eliminada en PHP 7.0.0.

He aquí una breve explicación de las directivas de configuración.

arg_separator.output string

El separador usado en PHP para distinguir argumentos en las URLs generadas.

arg_separator.input string

Lista de separadores empleados por PHP para convertir datos de URLs en variables.

Nota:

Cada carácter de esta directiva es considerado un separador.

variables_order string

Establece el orden de interpretación de variables EGPCS (Entorno, Get, Post, Cookie, y Servidor). Por ejemplo, si variables_order es "SP", PHP creará las superglobals $_SERVER y $_POST, pero no creará $_ENV, $_GET, y $_COOKIE. Si se establece a "", las variables superglobals no estarán disponibles.

Advertencia

En ambas SAPIs, CGI y FastCGI, $_SERVER también es rellenada con los valores de entorno; S siempre es equivalente a ES independientemente de la posición de E en esta directiva.

Nota:

El contenido y el orden de $_REQUEST también se ve afectado por esta directiva.

request_order string

Esta directiva describe el orden en que PHP registra las variables GET, POST y Cookie en el array _REQUEST. El registro se hace de izquierda a derecha; los nuevos valores reemplazan los valores más antiguos.

Si esta directiva no está definida, variables_order se usa para el contenido de $_REQUEST.

Observe que la distribución predeterminada de los ficheros php.ini no contienen 'C' para cookies, por motivos de seguridad.

auto_globals_jit boolean

Cuando está activada, las variables SERVER y EVN son creadas la primera vez que se necesitan ("Just In Time") en lugar de hacerlo cuando el script se inicia. Si estas variables no son usadas en un script, el tener esta directiva activada resultará en una mejora del rendimiento.

Advertencia

El uso de las variables SERVER y ENV se comprueba durante el tiempo de compilación, por lo que utilizarlas a través de, por ejemplo, variables variables no causará su inicialización.

register_argc_argv boolean
Indica a PHP si debe declarar las variables argv y argc (que pueden que contengan la información de GET). Véase también la línea de comandos.
register_long_arrays boolean
Indica a PHP si registrar o no las obsoletas variables predefinidas del tipo $HTTP_*_VARS. Cuando esté activada (predeterminado), las variables largas predefinidas de PHP, como $HTTP_GET_VARS, estarán definidas. Si no se utilizan, se recomienda desactivarlas por razones de rendimiento. En su lugar, use los arrays superglobales, como $_GET. Esta directiva empezó a estar disponible en PHP 5.0.0.
Advertencia

Esta característica ha sido declarada OBSOLETA desde PHP 5.3.0. Su uso está totalmente desaconsejado.

enable_post_data_reading boolean
Al deshabilitar esta opción hace que $_POST y $_FILES no sean rellenados. La única manera de leer datos de POST será a través de la envoltura de flujo php://input. Esto puede ser útil en peticiones de proxys o para procesar los datos de POST de una manera efeciente en cuestión de memoria.
post_max_size integer
Define el tamaño máximo de datos de POST permitidos. Esta opción también afecta a la subida de ficheros. Para subir ficheros grandes, este valor debe ser mayor que upload_max_filesize. Por norma general, memory_limit debe ser mayor que post_max_size. Cuando se usa un integer, el valor del mismo es medido en bytes. También se puede usar la notación reducida, tal como se describe en esta FAQ. Si el tamaño de los datos de POST es mayor que post_max_size, las superglobales $_POST y $_FILES estarán vacías. Esto se puede rastrear de varias maneras, por ejemplo, pasando la variable $_GET al script que procesa los datos, esto es, <form action="edit.php?procesado=1">, y luego comprobar si la variable $_GET['procesado'] existe.

Nota:

PHP acepta abreviaturas para valores de byte, incluyendo K (kilo), M (mega) y G (giga). PHP hará las conversión automaticamente si utiliza cualesquiera de estas abreviaturas. Tenga cuidado de no execeder el límite de los enteros con signo de 32 bits (si está usando veriones de 32 bits), puesto que hará que el script falle.

Registro de cambios para post_max_size
Versión | Descripción
5.3.4 | post_max_size = 0 no deshabilitará el límite cuando el tipo de contenido sea application/x-www-form-urlencoded o no esté registrado en PHP.
5.3.2 , 5.2.12 | Permitir un tamaño de post ilimitado estableciendo post_max_size a 0.

auto_prepend_file string

Especifica el nombre del fichero que será analizado automáticamente antes del fichero principal. El fichero es incluido como si fuera llamado con la función require, por lo que se usa include_path.

El valor especial none desactiva esta directiva.

auto_append_file string

Especifica el nombre del fichero que será analizado automaticamente después del fichero principal. El fichero es incluido como si fuera llamado con la función require, por que se utiliza include_path.

El valor especial none desactiva el esta directiva.

Nota: Si el script finaliza con exit(), está funcionalidad no será llevada a cabo.

default_mimetype string

Por defecto, PHP generará un tipo de medio empleando la cabecera Content-Type. Para deshabilitarlo, simplemente se ha de establecer a vacía.

El tipo de medio predeterminado interno de PHP está establecido a text/html.

default_charset string

A partir de PHP 5.6, "UTF-8" es el valor predeterminado empleándose su valor como la codificación de caracterse predeterminada para htmlentities(), html_entity_decode() y htmlspecialchars() si se omite el parámetro encoding. El valor de default_charset también se empleará para establecer el conjunto de caracteres predeterminado para las funciones de iconv si las opciones de configuración iconv.input_encoding, iconv.output_encoding y iconv.internal_encoding están desestablecidas, y para las funciones de mbstring si las opciones de configuración mbstring.http_input mbstring.http_output mbstring.internal_encoding están desestablecidas.

Todas las versiones de PHP utilizarán este valor como el conjunto de caracteres dentro de la cabecera Content-Type predeterminada enviada por PHP si la cabecera no ha sido sobrescrita por una llamada a header().

No se recomienda establecer default_charset a un valor vacío.

input_encoding string

Disponible desde PHP 5.6.0. Este ajuste se usa para módulos multibyte comos mbstring e iconv. El valor predeterminado es vacío.

output_encoding string

Disponible desde PHP 5.6.0. Este ajuste se usa para módulos multibyte comos mbstring e iconv. El valor predeterminado es vacío.

internal_encoding string

Disponible desde PHP 5.6.0. Este ajuste se usa para módulos multibyte comos mbstring e iconv. El valor predeterminado es vacío. Si está vacío, se usará default_charset.

always_populate_raw_post_data mixed
Advertencia

Esta característica fue declarada OBSOLETA en PHP 5.6.0 y ELILMINADA a partir de PHP 7.0.0.

Si se establece a true, PHP rellenará siempre $HTTP_RAW_POST_DATA que contiene los datos POST sin tratar. De lo contrario, la variable se rellena solamente cuando el tipo MIME de los datos es irreconocible.

El método preferido para acceder a los datos POST sin tratar es php://input, ya que $HTTP_RAW_POST_DATA está obsoleta a partir de PHP 5.6.0. Al establecer always_populate_raw_post_data a -1 se optará por el nuevo comportamiento que será implementado en una futura versión de, donde $HTTP_RAW_POST_DATA nunca está definida.

Independientemente del ajuste, $HTTP_RAW_POST_DATA no está disponible con enctype="multipart/form-data".

Véase también: magic_quotes_gpc, magic_quotes_runtime, y magic_quotes_sybase.

Rutas y directorios

Opciones de configuración de rutas y directorios
Nombre | Por defecto | Cambiable | Historial de cambios
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
open_basedir | NULL | PHP_INI_ALL | PHP_INI_SYSTEM en PHP < 5.3.0
doc_root | NULL | PHP_INI_SYSTEM |
user_dir | NULL | PHP_INI_SYSTEM |
user_ini.cache_ttl | "300" | PHP_INI_SYSTEM |
user_ini.filename | ".user.ini" | PHP_INI_SYSTEM |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
extension | NULL | Solamente en php.ini |
zend_extension | NULL | Solamente en php.ini |
zend_extension_debug | NULL | Solamente en php.ini | Disponible antes de PHP 5.3.0.
zend_extension_debug_ts | NULL | Solamente en php.ini | Disponible antes de PHP 5.3.0.
zend_extension_ts | NULL | Solamente en php.ini | Disponible antes de PHP 5.3.0.
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM | Disponible desde PHP 5.2.0.
cgi.discard_path | "0" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM | PHP_INI_ALL antes de PHP 5.2.1.
cgi.force_redirect | "1" | PHP_INI_SYSTEM | PHP_INI_ALL antes de PHP 5.2.1.
cgi.nph | "0" | PHP_INI_SYSTEM | Disponible desde PHP 5.3.0.
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM | PHP_INI_ALL antes de PHP 5.2.1.
cgi.rfc2616_headers | "0" | PHP_INI_ALL |
fastcgi.impersonate | "0" | PHP_INI_SYSTEM | PHP_INI_ALL antes de PHP 5.2.1.
fastcgi.logging | "1" | PHP_INI_SYSTEM | PHP_INI_ALL antes de PHP 5.2.1.

He aquí una breve explicación de las directivas de configuración.

include_path string

Especifica la lista de directorios donde las funciones require, include, fopen(), file(), readfile() y file_get_contents() buscarán ficheros. El formato es como la variable de entorno PATH del sistema: una lista de directorios separados por dos puntos en Unix o separados por punto y coma en Windows.

PHP considera cada entrada de la ruta de inclusión por separado cuando está buscando ficheros a incluir. Primero buscará en la primera ruta, y si no lo encuentra ahí, buscará en la siguiente, hasta que encuentre el fichero incluido, o devuelva una advertencia o un error. Se puede modificar o establecer una ruta de incluición propia en tiempo de ejecucción usando set_include_path().

Ejemplo #1 include_path en Unix

include_path=".:/php/includes"

Ejemplo #2 include_path en Windows

include_path=".;c:\php\includes"

El uso de . en la ruta de inclusión permite el uso de inclusiones relativas, ya que significa el directorio actual. Sin embargo, es más eficiente usar explícitamente include './fichero' que hacer que PHP compruebe siempre el directorio actual para cada inclusión.

Nota:

Las variables ENV también son accesibles en ficheros .ini. Por lo tanto, es posible hacer referencia al directorio raíz utilizando ${LOGIN} y ${USER}.

Las variables de entorno podrían variar entre APIs de servidores, ya que sus entornos pueden ser diferentes.

Ejemplo #3 include_path en Unix usando la variable de entorno ${USER}

include_path = ".:${USER}/pear/php"

open_basedir string

El límite de los ficheros a los que PHP puede acceder en el árbol de directorios especificado, incluyendo el fichero en sí. Esta directiva NO se ve afectada si el Modo Seguro está activado (On) o desactivado (Off).

Cuando un script intenta acceder al sistema de ficheros, por ejemplo, usando include, o fopen(), se comprueba la ubicación del fichero. Cuando el fichero está fuera del árbol de directorio especificado, PHP rechazará acceder a él. Todos los enlaces simbólicos se resuelven, por lo que no es posible evitar esta restricción con un enlace simbólico. Si el fichero no existe, el enlace simbólico no podría ser resuelto, por lo que el nombre de fichero se compara con (uno resuelto) open_basedir.

open_basedir puede afectar no sólo a las funciones del sistema de ficheros; por ejemplo, si MySQL está configurado para usar los controladores de mysqlnd, LOAD DATA INFILE se verá afectado por open_basedir. Mucha de la funcionalidad ampliada de PHP usa open_basedir de esta manera.

El valor especial . indica que el directorio de trabajo del script será usado como directorio base. Esto es, sin embargo, un poco peligroso, ya que el directorio de trabajo del script puede ser fácilmente cambiado con la función chdir().

En httpd.conf, se puede desactivar open_basedir (p.ej. para algunos servidores virtuales) de la misma manera que cualquier otra directiva de configuración con "php_admin_value open_basedir none".

Bajo Windows, los directorios se han de separar con punto y coma. En cualquier otro sistema, se ha de hacer con dos puntos. Como módulo de Apache, las rutas de open_basedir de los directorios superiores se heredan automáticamente.

La restricción especificada en open_basedir es un nombre de directorio desde PHP 5.2.16 y 5.3.4. Las versiones anteriores lo usaban como un prefijo. Esto quiere decir que "open_basedir = /dir/incl" también tiene acceso a "/dir/include" y "/dir/incls, si existen. Cuando se quiera restringir el acceso solamente a un directorio específico, se ha de finalizar con una barra. Por ejemplo: open_basedir = /dir/incl/

El valor predeterminado permite abrir cualquier fichero.

Nota:

A partir de PHP 5.3.0, open_basedir puede usarse en tiempo de ejecución. Esto significa que si open_basedir está establecido como /www/ en php.ini, un script puede reforzar la configuración a /www/tmp/ en tiempo de ejecución con ini_set(). Cuando se enumeran varios directorios, se puede usar la constante PATH_SEPARATOR como separador, independientemente del sistema operativo.

doc_root string

El "directorio raíz" de PHP en el servidor. Solamente usada si no está vacía. Si PHP no se compiló con FORCE_REDIRECT, debería establecerse doc_root si se está usando PHP como CGI bajo cualquier tipo de servidor (que no sea IIS). La alternativa es usar la configuación de cgi.force_redirect de más abajo.

user_ini.cache_ttl int

user_ini.filename string

user_dir string

El nombre base del directorio usado en un directorio principal de usuario para ficheros PHP, por ejemplo public_html .

extension_dir string

En qué directorio debería buscar PHP extensiones que se pueden cargar dinámicamente. Véase también: enable_dl, y dl().

extension string

Qué extensiones se cargarán dinámicamente cuando se inicie PHP.

zend_extension string

El nombre de la extensión Zend cargable dinámicamente (por ejemplo XDebug) cuando se inicie PHP.

zend_extension_debug string

Variante de zend_extension para extensiones compiladas con información de depuración antes de PHP 5.3.0.

zend_extension_debug_ts string

Variante de zend_extension para extensiones compiladas con información de depuración y subprocesamiento seguro antes de PHP 5.3.0.

zend_extension_ts string

Variante de zend_extension para extensiones compiladas con subprocesamiento seguro antes de PHP 5.3.0.

cgi.check_shebang_line boolean

Controla si PHP en modo CGI comprueba líneas que empiezan por #! (shebang) en el inicio del script que se está ejecutando. Esta línea podría ser necesaria si el script admite su ejecución tanto como un script independiente como mediante el modo CGI de PHP. El modo CGI de PHP omite esta línea e ignora su contenido si esta directiva si está activada.

cgi.discard_path boolean

Si está habilitado, el binario de CGI de PHP puede ser colocado sin riesgo fuera del árbol web, no siendo posible así eludir la seguridad de .htaccess.

cgi.fix_pathinfo boolean

Proporciona soporte real de PATH_INFO / PATH_TRANSLATED para CGI. El comportamiento anterior de PHP era establecer PATH_TRANSLATED a SCRIPT_FILENAME, por lo que no comprendía lo que era PATH_INFO. Para más información sobre PATH_INFO, véanse las especificaciones de CGI. Si se establece el valor de esta directiva a 1, el modo CGI de PHP corregirá sus rutas conforme a las especificaciones. Si se establece a cero, funcionará como anteriormente. Esta directiva está activada de forma predeterminada. Debería corregir sus scripts para que utilicen SCRIPT_FILENAME en lugar de PATH_TRANSLATED.

cgi.force_redirect boolean

cgi.force_redirect es necesario para proporcionar seguridad al ejecutar PHP como CGI bajo la mayoría de servidores web. Si no se define, PHP activa esta directiva de forma predeterminada. Puede desactivarla bajo su propia responsabilidad.

Nota:

Para usuarios de Windows: Al usar IIS, esta ocpción debe estar desactivada. Para OmniHTTPD o Xitami se aplica lo mismo.

cgi.nph boolean

Si cgi.nph está habilitado, forzará a que cgi siempre envíe Status: 200 en cada petidión.

cgi.redirect_status_env string

Si cgi.force_redirect está activada, y no se están usando servidores web Apache o Netscape (iPlanet), podría ser necesario establecer el nombre de una variable de entorno que PHP buscará para saber que se puede continuar con la ejecucción.

Nota:

Establecer esta variable podría causar problemas de seguridad, no la cambie a no ser que sepa lo que está haciendo.

cgi.rfc2616_headers int

Le indica a PHP qué tipo de encabezados usar cuando envía el código de respuesta HTTP. Si está establecida a 0, PHP envía una cabecera "Status:" » RFC 3875 la cual es admitida por Apache y otros servidores web. Cuando esta opción está establecida a 1, PHP enviará encabezados compatibles con la » RFC 2616.

Si esta opción está habiltada, y está ejecutándose PHP en un entorno CGI (p.ej. PHP-FPM) no se deberían usar las cabeceras de respuesta de estado HTTP estilo estándar RFC 2616, se debería usar en su lugar sus equivalentes RFC 3875, p.ej., en lugar de header("HTTP/1.0 404 Not found"); se debería usar header("Status: 404 Not Found");

Déjelo establecido a 0 a menos que sepa lo que está haciendo.

fastcgi.impersonate string

FastCGI bajo IIS (en SO basados en WINNT) admite la capacidad de imitar tokens de seguridad del cliente que llama. Esto permite a IIS definir el contexto de seguridad en el que la petición se ejecuta. mod_fastgci bajo Apache actualmente no admite esta característica (17/03/2002). Establézcalo a 1 si usa IIS. El valor predeterminado es cero.

fastcgi.logging boolean

Activa la identificación de la SAPI cuando se usa FastCGI. El valor predeterminado es habilitar la identificación.

Subida de ficheros

Opciones de configuración de subida de ficheros
Nombre | Por defecto | Cambiable | Historial de cambios
file_uploads | "1" | PHP_INI_SYSTEM | PHP_INI_ALL en PHP <= 4.2.3. Disponible desde PHP 4.0.3.
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
max_input_nesting_level | 64 | PHP_INI_PERDIR | Disponible desde PHP 5.3.9.
max_input_vars | 1000 | PHP_INI_PERDIR | Disponible desde PHP 5.3.9.
upload_max_filesize | "2M" | PHP_INI_PERDIR | PHP_INI_ALL en PHP <= 4.2.3.
max_file_uploads | 20 | PHP_INI_SYSTEM | Disponible desde PHP 5.2.12.

He aquí una breve explicación de las directivas de configuración.

file_uploads boolean

Si permitir o no la subida de ficheros mediante HTTP. Véanse también las directivas upload_max_filesize, upload_tmp_dir, y post_max_size.

upload_tmp_dir string

El directorio temporal usado para almacenar ficheros durante el proceso de subida. Es necesario tener permisos de escritura para el usuario que está ejecutando PHP. Si no está especificado, PHP usará el predeterminado del sistema.

Si el directorio especificado no tiene permisos de escritura, PHP recurrirá al directorio temporal predeterminado del sistema. Si la directiva open_basedir está activada, al directorio predeterminado del sistema se le ha de permitir la subida de ficheros para que funcione.

upload_max_filesize integer

El tamaño máximo de un fichero subido.

Cuando se usa un integer, el valor del mismo es medido en bytes. También se puede usar la notación reducida, tal como se describe en esta FAQ.
max_file_uploads integer

El número máximo de ficheros a subir permitidos de forma simultánea. A partir de PHP 5.3.4, los campos de subida de ficheros dejados en blanco en el momento del envío no cuentan en este límite.

Configuración de SQL en general

Opciones de configuración de SQL en general
Nombre | Por defecto | Cambiable | Historial de cambios
sql.safe_mode | "0" | PHP_INI_SYSTEM |

He aquí una breve explicación de las directivas de configuración.

sql.safe_mode boolean

Si está activado, las funciones de conexión a bases de datos que especifiquen valores predeterminados emplearán dichos valores en lugar cualquier argumento proporcionado por el usuario. Para los detalles de los valores predeterminados, veáse la documentación de las funciones de conexión relevantes.

Específico de Windows

Opciones de configuración específicas de Windows
Nombre | Por defecto | Cambiable | Historial de cambios
windows.show_crt_warning | "0" | PHP_INI_ALL | Disponibe desde PHP 5.4.0.

He aquí una breve explicación de las directivas de configuración.

windows_show_crt_warning boolean

Esta directiva muestra las advertencias CRT de Windows cuando está establecida. Estas advertencias eran mostradas de forma predeterminada hasta PHP 5.4.0.


Categorización de Extensiones

Tabla de contenidos

  • Alfabética
  • Incorporación
  • Estado

Este apéndice categoriza más de 150 extensiones documentadas en el manual de PHP de acuerdo a varios criterios.


Alfabética

  • Apache
  • APCu
  • Arrays
  • BC Math
  • Bzip2
  • Calendario
  • Classkit
  • Clases/Objetos
  • COM
  • CSPRNG
  • Ctype
  • CUBRID
  • cURL
  • Fecha/Hora
  • DBA
  • dBase
  • DB++
  • Direct IO
  • Directorios
  • DOM
  • Data Structures
  • Eio
  • Enchant
  • Manejo de errores
  • Ev
  • Event
  • Ejecución de programas
  • Exif
  • Expect
  • FANN
  • FANN
  • FrontBase
  • FDF
  • Fileinfo
  • filePro
  • Sistema de Ficheros
  • Filter
  • FastCGI Process Manager
  • FTP
  • Manejo de Funciones
  • Gearman
  • Gender
  • GeoIP
  • Gettext
  • Gmagick
  • GMP
  • GnuPG
  • Hash
  • HRTime
  • Firebird/InterBase
  • IBM DB2
  • iconv
  • GD
  • ImageMagick
  • IMAP
  • Opciones/Info de PHP
  • Ingres
  • Inotify
  • intl
  • JSON
  • LDAP
  • libxml
  • Lua
  • LZF
  • Mail
  • Mailparse
  • Math
  • Cadenas de caracteres multibyte
  • Mcrypt
  • Memcache
  • Memcached
  • Memtrack
  • Mhash
  • Misc.
  • Mongo
  • MongoDB\BSON
  • MongoDB\Controlador
  • mqseries
  • MySQL (Original)
  • MySQLi
  • Mysqlnd
  • mysqlnd_memcache
  • mysqlnd_ms
  • mysqlnd_mux
  • mysqlnd_qc
  • mysqlnd_uh
  • Ncurses
  • Network
  • OAuth
  • OCI8
  • OPcache
  • OpenAL
  • OpenSSL
  • Control de la salida
  • Paradox
  • Parle
  • Hash de contraseñas
  • PCNTL
  • PCRE
  • PDO
  • CUBRID (PDO)
  • MS SQL Server (PDO)
  • Firebird (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • Oracle (PDO)
  • ODBC y DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)
  • MS SQL Server (PDO)
  • PostgreSQL
  • Phar
  • POSIX
  • Proctitle
  • PS
  • Pspell
  • pthreads
  • Quickhash
  • Radius
  • Rar
  • Readline
  • Recode
  • Reflection
  • Expresiones Regulares de POSIX
  • RRD
  • ScoutAPM
  • Seaslog
  • Semaphore
  • Sesiones
  • Memoria compartida
  • SimpleXML
  • SNMP
  • SOAP
  • Sockets
  • Sodium
  • Solr
  • Sphinx
  • SPL
  • SQLite3
  • SQLSRV
  • ssdeep
  • SSH2
  • Estadísticas
  • Stomp
  • Flujos
  • Strings
  • SVM
  • SVN
  • Swoole
  • Sync
  • Taint
  • TCP
  • Tidy
  • Tokenizer
  • tokyo_tyrant
  • Trader
  • UI
  • ODBC
  • uopz
  • URLs
  • V8js
  • Manejo de variables
  • Varnish
  • WDDX
  • Weakref
  • win32service
  • WinCache
  • wkhtmltox
  • xattr
  • xdiff
  • Xhprof
  • Analizador XML
  • XMLDiff
  • XMLReader
  • XML-RPC
  • XMLWriter
  • XSL
  • Yaconf
  • Yaf
  • Yaml
  • Yar
  • YAZ
  • Zip
  • Zlib
  • Mensajería de 0MQ
  • ZooKeeper


Incorporación

Extensiones del núcleo

No son extensiones realmente. Son parte del núcleo de PHP y no pueden omitirse en un binario de PHP con opciones de compilación.

  • Arrays

  • Clases/Objetos

  • CSPRNG

  • Fecha/Hora

  • Directorios

  • Manejo de errores

  • Ejecución de programas

  • Sistema de Ficheros

  • Filter

  • Manejo de Funciones

  • Hash

  • Opciones/Info de PHP

  • Mail

  • Math

  • Misc.

  • Network

  • Control de la salida

  • Hash de contraseñas

  • Phar

  • Reflection

  • Expresiones Regulares de POSIX

  • Sesiones

  • SPL

  • Flujos

  • Strings

  • Tokenizer

  • URLs

  • Manejo de variables

Bundled

Extensiones incorporadas en PHP.

  • Apache

  • BC Math

  • Calendario

  • COM

  • Ctype

  • DBA

  • Exif

  • Fileinfo

  • FTP

  • iconv

  • GD

  • intl

  • JSON

  • Cadenas de caracteres multibyte

  • OPcache

  • PCNTL

  • PCRE

  • PDO

  • POSIX

  • Semaphore

  • Memoria compartida

  • Sockets

  • SQLite3

  • XML-RPC

  • Zlib

Extensiones externas

Estas extensiones vienen con PHP, pero para poder compilarlas, se requieren bibliotecas externas.

  • Bzip2

  • cURL

  • dBase

  • DOM

  • Enchant

  • FrontBase

  • Gettext

  • GMP

  • Firebird/InterBase

  • IMAP

  • LDAP

  • libxml

  • Mcrypt

  • Mhash

  • MySQL (Original)

  • MySQLi

  • Mysqlnd

  • OCI8

  • OpenSSL

  • MS SQL Server (PDO)

  • Firebird (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC y DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • PostgreSQL

  • Pspell

  • Readline

  • Recode

  • SimpleXML

  • SNMP

  • SOAP

  • Sodium

  • Tidy

  • ODBC

  • WDDX

  • Analizador XML

  • XMLReader

  • XMLWriter

  • XSL

  • Zip

Extensiones PECL

Estas extensiones están disponibles desde » PECL. Seguramente requieren bibliotecas externas. Existen más extensiones PECL pero no están documentadas aún en el manual.

  • Classkit

  • CUBRID

  • DB++

  • Direct IO

  • Eio

  • Ev

  • Event

  • Expect

  • FDF

  • filePro

  • Gearman

  • Gender

  • GeoIP

  • Gmagick

  • GnuPG

  • IBM DB2

  • ImageMagick

  • Ingres

  • Inotify

  • Lua

  • LuaSandbox

  • LZF

  • Mailparse

  • Memcache

  • Memcached

  • Memtrack

  • Mongo

  • mqseries

  • mysqlnd_memcache

  • mysqlnd_ms

  • mysqlnd_mux

  • mysqlnd_qc

  • mysqlnd_uh

  • Ncurses

  • OAuth

  • OpenAL

  • Paradox

  • CUBRID (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MS SQL Server (PDO)

  • Proctitle

  • PS

  • pthreads

  • Quickhash

  • Radius

  • Rar

  • RRD

  • runkit

  • ScoutAPM

  • Seaslog

  • Solr

  • Sphinx

  • SQLSRV

  • ssdeep

  • SSH2

  • Estadísticas

  • Stomp

  • Swoole

  • SVM

  • SVN

  • Taint

  • TCP

  • tokyo_tyrant

  • Trader

  • V8js

  • Varnish

  • Weakref

  • win32service

  • WinCache

  • xattr

  • xdiff

  • Xhprof

  • Yaf

  • Yaml

  • YAZ

  • ZooKeeper


Estado

Esta sección lista las extensiones que no son recomendables para su uso en producción - son demasiado "viejas" (obsoletas) o "nuevas" (experimentales).

Extensiones obsoletas

Estas extensiones han sido marcadas como obsoletas, por lo general han sido reemplazadas por otras extensiones.

  • Memtrack

Extensiones experimentales

El comportamiento de estas extensiones - incluyendo los nombres de sus funciones y cualquier otra cosa documentada sobre estas extensiones - puede cambiar sin previo aviso en una futura versión de PHP. Use estas extensiones bajo su propio riesgo.

  • DB++

  • Hash

  • ImageMagick

  • Ncurses

  • Paradox

  • MS SQL Server (PDO)

  • Firebird (PDO)

  • Oracle (PDO)

  • PS

  • XML-RPC


Listado de funciones alias

Hay unas cuantas funciones en PHP que puede llamar con más de un nombre. En algunos de los casos no hay ningún nombre preferido de entre los múltiples nombres, is_int() e is_integer() son un buen ejemplo. Sin embargo hay funciones que cambiaron de nombre a causa de una limpieza del API o alguna otra razón y los nombres antiguos solo se preservan como alias para mantener la compatibilidad con versiones anteriores. Suele ser mala idea usar este tipo de alias, ya que pueden quedar obsoletos o que cambien de nombre, y hacer imposible la portabilidad del script. Esta lista se facilita para ayudar a las personas que quieren actualizar su código antiguo a una nueva sintaxis.

Alias
Alias | Función maestra | Extensión
_ | gettext() | Gettext
chop | rtrim() | Sintaxis base
close | closedir() | Sintaxis base
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
die | exit() | Funciones misceláneas
diskfreespace | disk_free_space() | Sistema de ficheros
doubleval | floatval() | Sintaxis base
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | Sintaxis base
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | Multi-bytes Strings
i18n_discover_encoding | mb_detect_encoding() | Multi-bytes Strings
i18n_http_input | mb_http_input() | Multi-bytes Strings
i18n_http_output | mb_http_output() | Multi-bytes Strings
i18n_internal_encoding | mb_internal_encoding() | Multi-bytes Strings
i18n_ja_jp_hantozen | mb_convert_kana() | Multi-bytes Strings
i18n_mime_header_decode | mb_decode_mimeheader() | Multi-bytes Strings
i18n_mime_header_encode | mb_encode_mimeheader() | Multi-bytes Strings
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | Sintaxis base
is_double | is_float() | Sintaxis base
is_integer | is_int() | Sintaxis base
is_long | is_int() | Sintaxis base
is_real | is_float() | Sintaxis base
is_writeable | is_writable() | Sintaxis base
join | implode() | Sintaxis base
key_exists | array_key_exists() | Sintaxis base
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | Sintaxis base
mbstrcut | mb_strcut() | Multi-bytes Strings
mbstrlen | mb_strlen() | Multi-bytes Strings
mbstrpos | mb_strpos() | Multi-bytes Strings
mbstrrpos | mb_strrpos() | Multi-bytes Strings
mbsubstr | mb_substr() | Multi-bytes Strings
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
ociassignelem | OCI-Collection::assignElem | OCI8
ocibindbyname | oci_bind_by_name() | OCI8
ocicancel | oci_cancel() | OCI8
ocicloselob | OCI-Lob::close | OCI8
ocicollappend | OCI-Collection::append | OCI8
ocicollassign | OCI-Collection::assign | OCI8
ocicollmax | OCI-Collection::max | OCI8
ocicollsize | OCI-Collection::size | OCI8
ocicolltrim | OCI-Collection::trim | OCI8
ocicolumnisnull | oci_field_is_null() | OCI8
ocicolumnname | oci_field_name() | OCI8
ocicolumnprecision | oci_field_precision() | OCI8
ocicolumnscale | oci_field_scale() | OCI8
ocicolumnsize | oci_field_size() | OCI8
ocicolumntype | oci_field_type() | OCI8
ocicolumntyperaw | oci_field_type_raw() | OCI8
ocicommit | oci_commit() | OCI8
ocidefinebyname | oci_define_by_name() | OCI8
ocierror | oci_error() | OCI8
ociexecute | oci_execute() | OCI8
ocifetch | oci_fetch() | OCI8
ocifetchinto | oci_fetch_array(), oci_fetch_row(), oci_fetch_assoc(), oci_fetch_object() | OCI8
ocifetchstatement | oci_fetch_all() | OCI8
ocifreecollection | OCI-Collection::free | OCI8
ocifreecursor | oci_free_statement() | OCI8
ocifreedesc | oci_free_descriptor() | OCI8
ocifreestatement | oci_free_statement() | OCI8
ocigetelem | OCI-Collection::getElem | OCI8
ociinternaldebug | oci_internal_debug() | OCI8
ociloadlob | OCI-Lob::load | OCI8
ocilogon | oci_connect() | OCI8
ocinewcollection | oci_new_collection() | OCI8
ocinewcursor | oci_new_cursor() | OCI8
ocinewdescriptor | oci_new_descriptor() | OCI8
ocinlogon | oci_new_connect() | OCI8
ocinumcols | oci_num_fields() | OCI8
ociparse | oci_parse() | OCI8
ocipasswordchange | oci_password_change() | OCI8
ociplogon | oci_pconnect() | OCI8
ociresult | oci_result() | OCI8
ocirollback | oci_rollback() | OCI8
ocisavelob | OCI-Lob::save | OCI8
ocisavelobfile | OCI-Lob::import | OCI8
ociserverversion | oci_server_version() | OCI8
ocisetprefetch | oci_set_prefetch() | OCI8
ocistatementtype | oci_statement_type() | OCI8
ociwritelobtofile | OCI-Lob::export | OCI8
ociwritetemporarylob | OCI-Lob::writeTemporary | OCI8
odbc_do | odbc_exec() | ODBC
odbc_field_precision | odbc_field_len() | ODBC
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | Sintaxis base
recode | recode_string() | Recode
show_source | highlight_file() | Sintaxis base
sizeof | count() | Sintaxis base
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | Sintaxis base
xptr_new_context | xpath_new_context() |


Lista de palabras reservadas

Tabla de contenidos

  • Lista de palabras reservadas
  • Clases predefinidas
  • Constantes predefinidas
  • Listado de otras palabras reservadas

A continuación se muestra un listado de los identificadores predefinidos en PHP. Ninguno de estos identificadores se puede usar como identificador en scripts a menos que se indique los contrario. Estas listas incluyen tanto palabras reservadas como variables predefinidas, constantes y nombres de clases. Estas listas no son ni exhaustivas ni completas.


Lista de palabras reservadas

Estas palabras tienen un significado especial en PHP. Algunas representan cosas que se parecen a funciones, otras se parecen a constantes, etc.; pero no lo son en realidad: son constructores del lenguaje. No se puede usar ninguna de las siguientes palabras como constantes, nombres de clases, nombres de funciones o métodos. Se pueden usar como nombres de variables, pero podría dar lugar a confusiones.

A partir de PHP 7.0.0, estas palabras reservadas están permitidas como nombres de propiedades, de constantes y de métodos de clases, interfaces y rasgos, excepto que class no puede utilizarse como nombre de constante.

Palabras reservadas de PHP
__halt_compiler() | abstract | and | array() | as
break | callable (a partir de PHP 5.4) | case | catch | class
clone | const | continue | declare | default
die() | do | echo | else | elseif
empty() | enddeclare | endfor | endforeach | endif
endswitch | endwhile | eval() | exit() | extends
final | finally (a partir de PHP 5.5) | fn (as of PHP 7.4) | for | foreach
function | global | goto (a partir de PHP 5.3) | if | implements
include | include_once | instanceof | insteadof (a partir de PHP 5.4) | interface
isset() | list() | match (a partir de PHP 8.0) | namespace (a partir de PHP 5.3) | new
or | print | private | protected | public
require | require_once | return | static | switch
throw | trait (a partir de PHP 5.4) | try | unset() | use
var | while | xor | yield (a partir de PHP 5.5) | yield from (a partir de PHP 7.0)
Constantes en tiempo de compilación
__CLASS__ | __DIR__ (a partir de PHP 5.3) | __FILE__ | __FUNCTION__ | __LINE__ | __METHOD__
__NAMESPACE__ (a partir de PHP 5.3) | __TRAIT__ (a partir de PHP 5.4) |  |  |  |


Clases predefinidas

Esta sección enumera las clases predefinidas estándar. Varias extensiones definen otras clases, las cuales se describen en sus respectivas secciones.

Clases definidas estándar

Estas clases están definidas en el conjunto estándar de funciones que se incluyen en la compilación de PHP.

Directory
Creada por dir().
stdClass
Creada en la conversión al tipo object.
__PHP_Incomplete_Class
Posiblemente creada por unserialize().

Clases predefinidas a partir de PHP 5

Estas clases predefinidas adicionales se introdujeron en PHP 5.0.0.

Exception
ErrorException
Disponible desde PHP 5.1.0.
php_user_filter

Closure

La clase final predefinida Closure fue introducida en PHP 5.3.0. Se usa para representar funciones anónimas.

Para más información, véase la página de su clase.

Generator

La clase final predefinida Generator fue introducida en PHP 5.5.0. Se usa para representar generadores.

Para más información, véase la página de su clase.

Interfaces y clases predefinidas a partir de PHP 7

Estas interfaces y clases predefinidas adicionales se han introducido en PHP 7.0.0.

ArithmeticError
AssertionError
DivisionByZeroError
Error
Throwable
ParseError
TypeError

Clases especiales

Los siguientes identificadores no se pueden usar como nombres de clase, dado que tienen un propósito especial.

self
Clase actual.
static
Clase actual en tiempo de ejecución.
parent
Clase madre.


Constantes predefinidas

Constantes predefinidas del núcleo

Estas constantes están definidas por el núcleo de PHP. Este incluye PHP, el motor Zend, y los módulos SAPI.

PHP_VERSION (string)
La versión actual de PHP en notación "mayor.menor.edición[extra]".
PHP_MAJOR_VERSION (integer)
La versión "mayor" actual de PHP como valor integer (p.ej., int(5) en la versión "5.2.7-extra"). Disponible desde PHP 5.2.7.
PHP_MINOR_VERSION (integer)
La versión "menor" actual de PHP como valor integer (p.ej, int(2) en la versión "5.2.7-extra"). Disponible desde PHP 5.2.7.
PHP_RELEASE_VERSION (integer)
La versión de "publicación" (release) actual de PHP como valor integer (p.ej., int(7) en la versión "5.2.7-extra"). Disponible desde PHP 5.2.7.
PHP_VERSION_ID (integer)
La versión de PHP actual como valor integer, útil para comparar versiones (p.ej., int(50207) para la versión "5.2.7-extra"). Disponible desde PHP 5.2.7.
PHP_EXTRA_VERSION (string)
La versión "extra" actual de PHP, en forma de string (p.ej., '-extra' para la versión "5.2.7-extra"). Se usa a menudo por los distribuidores para indicar la versión de un paquete. Disponible desde PHP 5.2.7.
PHP_ZTS (integer)
Disponible desde PHP 5.2.7.
PHP_DEBUG (integer)
Disponible desde PHP 5.2.7.
PHP_MAXPATHLEN (integer)
La longitud máxima de los nombres de ficheros (incluyendo directorios) admitida por la compilación de PHP. Disponible desde PHP 5.3.0.
PHP_OS (string)
El sistema operativo para el que se construyó PHP.
PHP_OS_FAMILY (string)
La familia de sistemas operativos para la que se construyó PHP. Puede se 'Windows', 'BSD', 'OSX', 'Solaris', 'Linux' or 'Unknown'. Disponible desde PHP 7.2.0.
PHP_SAPI (string)
La API del servidor de la compilación de PHP. Ver también php_sapi_name().
PHP_EOL (string)
El símbolo 'Fin De Línea' correcto de la plataforma en uso. Disponible desde PHP 5.0.2
PHP_INT_MAX (integer)
El número entero más grande admitido en esta compilación de PHP. Normalmente int(2147483647). Disponible desde PHP 5.0.5
PHP_INT_MIN (integer)
El número entero más pequeño admitido en esta compilación de PHP. Normalmente int(-2147483648) en sistemas de 32 bits y int(-9223372036854775808) en sistemas de 64 bits. Disponible desde PHP 7.0.0. Usualmente, PHP_INT_MIN === ~PHP_INT_MAX.
PHP_INT_SIZE (integer)
El tamaño de un número entero en bytes en esta compilación de PHP. Disponible desde PHP 5.0.5
PHP_FLOAT_DIG (integer)
Número de dígitos decimales que se pueden redondear en un float y revertirlos si pédida de precisión. Disponible a partir de PHP 7.2.0.
PHP_FLOAT_EPSILON (float)
El menor número positivo representable x, tal que x + 1.0 != 1.0. Disponible a partir de PHP 7.2.0.
PHP_FLOAT_MIN (float)
El menor número de punto flotante representable. Disponible a partir de PHP 7.2.0.
PHP_FLOAT_MAX (float)
El mayor número de punto flotante representable. Disponible a partir de PHP 7.2.0.
DEFAULT_INCLUDE_PATH (string)
PEAR_INSTALL_DIR (string)
PEAR_EXTENSION_DIR (string)
PHP_EXTENSION_DIR (string)
PHP_PREFIX (string)
El valor de "--prefix" usado en la configuración.
PHP_BINDIR (string)
Especifica dónde se instalaron los binarios.
PHP_BINARY (string)
Especifica la ruta de los binarios de PHP durante la ejecución del script. Disponible desde PHP 5.4.
PHP_MANDIR (string)
Especifica dónde están instalados los manuales. Disponible desde PHP 5.3.7.
PHP_LIBDIR (string)
PHP_DATADIR (string)
PHP_SYSCONFDIR (string)
PHP_LOCALSTATEDIR (string)
PHP_CONFIG_FILE_PATH (string)
PHP_CONFIG_FILE_SCAN_DIR (string)
PHP_SHLIB_SUFFIX (string)
Sufijo de las bibliotecas compartidas de la plataforma de compilación, como "so" (mayoría de plataformas Unix) o "dll" (Windows).
PHP_FD_SETSIZE (string)
El número máximo de descriptores de ficheros para seleccionar llamadas al sistema. Disponble a partir de PHP 7.1.0.
E_ERROR (integer)
Constante de informe de error
E_WARNING (integer)
E_PARSE (integer)
E_NOTICE (integer)
E_CORE_ERROR (integer)
E_CORE_WARNING (integer)
E_COMPILE_ERROR (integer)
E_COMPILE_WARNING (integer)
E_USER_ERROR (integer)
E_USER_WARNING (integer)
E_USER_NOTICE (integer)
E_DEPRECATED (integer)
Disponible desde PHP 5.3.0
E_USER_DEPRECATED (integer)
Disponible desde PHP 5.3.0
E_ALL (integer)
E_STRICT (integer)
__COMPILER_HALT_OFFSET__ (integer)
Disponible desde PHP 5.1.0
true (boolean)
Ver también Booleanos.
false (boolean)
Ver también Booleanos.
null (null)
Ver también Null.

Ver también: Constantes mágicas.

Constantes predefinidas estándar

Todas las constantes de extensiones del núcleo están definidas en PHP de manera predeterminada.


Listado de otras palabras reservadas

Las siguientes palabras no se pueden utilizar para dar nombre a una clase, interfaz o rasgo, y están también prohibidas emplearlas en espacios de nombres.

Palabras reservadas
int (a partir de PHP 7) | float (a partir de PHP 7) | bool (a partir de PHP 7) | string (a partir de PHP 7)
true (a partir de PHP 7) | false (a partir de PHP 7) | null (a partir de PHP 7) | void (a partir de PHP 7.1)
iterable (a partir de PHP 7.1) | object (a partir de PHP 7.2)

Las palabras de la siguiente lista han estado ligeramente reservadas. Aunque todavía se puden emplear como nombres de clases interfaces y rasgos, (así como en espacio de nombres), su uso está totalmente desaconsejado debido a que podrían ser utilizadas en versiones futuras de PHP.

Palabras ligeramente reservadas
resource (as of PHP 7) mixed (as of PHP 7) numeric (as of PHP 7)


Lista de Tipos de Recurso

La siguiente es una lista de las funciones que crean, usan o destruyen recursos PHP. La función is_resource() se puede usar para determinar si una variable es un recurso, y get_resource_type() devolverá el tipo de recurso que es.

Tipos de recursos
Nombre del tipo de recurso | Creado por | Usado por | Destruido por | Definición
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Fichero bzip2
cubrid connection | cubrid_connect() cubrid_connect_with_url() | cubrid_col_get() cubrid_col_size() cubrid_commit() cubrid_drop() cubrid_execute() cubrid_get_autocommit() cubrid_get_charset() cubrid_get_class_name() cubrid_get_db_parameter() cubrid_get_server_info() cubrid_get() cubrid_insert_id() cubrid_is_instance() cubrid_lob_export() cubrid_lob_get() cubrid_lob_send() cubrid_lock_read() cubrid_lock_write() cubrid_prepare() cubrid_put() cubrid_rollback() cubrid_schema() cubrid_seq_drop() cubrid_seq_insert() cubrid_seq_put() cubrid_set_add() cubrid_set_autocommit() cubrid_set_db_parameter() cubrid_set_drop() cubrid_affected_rows() cubrid_client_encoding() cubrid_errno() cubrid_error() cubrid_list_dbs() cubrid_ping() cubrid_query() cubrid_real_escape_string() | cubrid_close() cubrid_disconnect() | Conexión a una base de datos de CUBRID
persistent cubrid connection | cubrid_pconnect() cubrid_pconnect_with_url() | cubrid_col_get() cubrid_col_size() cubrid_commit() cubrid_drop() cubrid_execute() cubrid_get_autocommit() cubrid_get_charset() cubrid_get_class_name() cubrid_get_db_parameter() cubrid_get_server_info() cubrid_get() cubrid_insert_id() cubrid_is_instance() cubrid_lob_export() cubrid_lob_get() cubrid_lob_send() cubrid_lock_read() cubrid_lock_write() cubrid_prepare() cubrid_put() cubrid_rollback() cubrid_schema() cubrid_seq_drop() cubrid_seq_insert() cubrid_seq_put() cubrid_set_add() cubrid_set_autocommit() cubrid_set_db_parameter() cubrid_set_drop() cubrid_affected_rows() cubrid_client_encoding() cubrid_errno() cubrid_error() cubrid_list_dbs() cubrid_ping() cubrid_query() cubrid_real_escape_string() cubrid_lob2_new() | Conexión persistente a una base de datos de CUBRID
cubrid request | cubrid_prepare() cubrid_execute() cubrid_query() cubrid_unbuffered_query() | cubrid_bind() cubrid_column_names() cubrid_column_types() cubrid_current_oid() cubrid_execute() cubrid_free_result() cubrid_get_query_timeout() cubrid_move_cursor() cubrid_next_result() cubrid_num_cols() cubrid_num_rows() cubrid_set_query_timeout() cubrid_data_seek() cubrid_fetch_array() cubrid_fetch_assoc() cubrid_fetch_field() cubrid_fetch_lengths() cubrid_fetch_object() cubrid_fetch_row() cubrid_field_flags() cubrid_field_len() cubrid_field_name() cubrid_field_seek() cubrid_field_table() cubrid_field_type() cubrid_num_fields() cubrid_result() cubrid_lob2_bind() | cubrid_close_prepare() cubrid_close_request() | Solicitud de CUBRID
cubrid lob | cubrid_lob_get() | cubrid_lob_export() cubrid_lob_send() cubrid_lob_size() | cubrid_lob_close() | Nadie
cubrid lob2 | cubrid_lob2_new() cubrid_fetch() cubrid_fetch_row() cubrid_fetch_array() cubrid_fetch_assoc() cubrid_fetch_object() | cubrid_lob2_export() cubrid_lob2_import() cubrid_lob2_read() cubrid_lob2_write() cubrid_lob2_tell() cubrid_lob2_tell64() cubrid_lob2_seek() cubrid_lob2_seek64() cubrid_lob2_size() cubrid_lob2_size64() | cubrid_lob2_close() | Nadie
curl | curl_copy_handle(), curl_init() | curl_copy_handle(), curl_errno(), curl_error(), curl_exec(), curl_getinfo(), curl_setopt() | curl_close() | Sesión de curl
dba | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | Enlace a una base de datos DBA
dba persistent | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | Nadie | Enlace persistente a una base de datos DBA
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Enlace a una base de datos Dbase
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx connection
dbx_result_object | dbx_query() | Nadie | Resultado dbx
xpath context
xpath object
fbsql link | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_blob_size(), fbsql_clob_size(), fbsql_commit(), fbsql_change_user(), fbsql_create_blob(), fbsql_create_db(), fbsql_create_clob(), fbsql_data_seek(), fbsql_database_password(), fbsql_database(), fbsql_db_query(), fbsql_db_status(), fbsql_drop_db(), fbsql_errno(), fbsql_error(), fbsql_get_autostart_info(), fbsql_hostname(), fbsql_insert_id(), fbsql_list_dbs(), fbsql_password(), fbsql_read_blob(), fbsql_read_clob(), fbsql_rollback(), fbsql_select_db(), fbsql_set_password(), fbsql_set_transaction(), fbsql_start_db(), fbsql_stop_db(), fbsql_username() | fbsql_close() | Enlace a una base de datos fbsql
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | Nadie | Enlace persistente a una base de datos fbsql
fbsql result | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | Resultado de fbsql
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | Fichero FDF
ftp | ftp_connect(), ftp_ssl_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site(), ftp_alloc(), ftp_chmod(), ftp_exec(), ftp_get_option(), ftp_nb_continue(), ftp_nb_fget(), ftp_nb_fput(), ftp_nb_get(), ftp_nb_put(), ftp_raw(), ftp_set_option() | ftp_close() | Flujo FTP
gd | imagecreate(), imagecreatefromgd(), imagecreatefromgd2(), imagecreatefromgd2part(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatefromxbm(), imagecreatefromxpm(), imagecreatetruecolor(), imagerotate() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagerotate(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness(), image2wbmp(), imagealphablending(), imageantialias(), imagecolorallocatealpha(), imagecolorclosesthwb(), imagecolordeallocate(), imagecolormatch(), imagefilter(), imagefttext(), imagegd(), imagegd2(), imageistruecolor(), imagelayereffect(), imagepalettecopy(), imagesavealpha(), imagesetstyle(), imagexbm() | imagedestroy() | Imagen GD
gd font | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | Nadie | Tipo de letra para GD
gd PS encoding
gd PS font | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | Tipo de letra PS para GD
GMP integer | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | Nadie | Número GMP
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | Enlace a un servidor IMAP, POP3
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | Enlace a un base de datos ingresII
ingres persistent | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | Nadie | Enlace persistente a una base de datos ingresII
interbase blob
interbase link | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Enlace a una base de datos Interbase
interbase link persistent | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | Nadie | Enlace persistente a una base de datos Interbase
interbase query | ibase_prepare() | ibase_execute() | ibase_free_query() | Consulta de Interbase
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Resultado de Interbase
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Transacción de Interbase
ldap link | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | Conexión de ldap
ldap result | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | Resultado de búsqueda de ldap
ldap result entry
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch agent
mnogosearch result
msql link | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | Enlace a una base de datos mSQL
msql link persistent | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | Nadie | Enlace persistente a mSQL
msql query | msql_db_query(), msql_list_dbs(), msql_list_fields(), msql_list_tables(), msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_field_seek(), msql_field_table(), msql_field_flags(), msql_field_len(), msql_field_name(), msql_field_type(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | Resultado de mSQL
mssql link | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Enlace a una base de datos Microsoft SQL Server
mssql link persistent | mssql_pconnect() | mssql_query(), mssql_select_db() | Nadie | Enlace persistente a Microsoft SQL Server
mssql result | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Rasultado de Microsoft SQL Server
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | Enlace a una base de datos MySQL
mysql link persistent | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | Nadie | Enlace persistente a una base de datos MySQL
mysql result | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_processes(), mysql_list_tables(), mysql_query(), mysql_unbuffered_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | Resultado de MySQL
oci8 collection | oci_new_collection() | OCI-Collection::append(), OCI-Collection::assign(), OCI-Collection::assignElem(), OCI-Collection::getElem(), OCI-Collection::max(), OCI-Collection::size(), OCI-Collection::trim() | OCI-Collection::free() | Colección de Oracle
oci8 connection | oci_connect(), oci_pconnect(), oci_new_connect() | oci_commit(), oci_error(), oci_new_cursor(), oci_parse(), oci_password_change(), oci_rollback(), oci_server_version(), oci_set_action(), oci_set_client_identifier(), oci_set_client_info(), oci_set_module_name() | oci_close() | Conexiión a base de datos de Oracle
oci8 lob | oci_new_descriptor() | OCI-Lob::append(), OCI-Lob::close(), OCI-Lob::eof(), OCI-Lob::erase(), OCI-Lob::export(), OCI-Lob::flush(), OCI-Lob::getBuffering(), OCI-Lob::import(), OCI-Lob::load(), OCI-Lob::read(), OCI-Lob::rewind(), OCI-Lob::save(), OCI-Lob::saveFile(), OCI-Lob::seek(), OCI-Lob::setBuffering(), OCI-Lob::size(), OCI-Lob::tell(), OCI-Lob::truncate(), OCI-Lob::write(), OCI-Lob::writeTemporary(), OCI-Lob::writeToFile(), oci_lob_copy(), oci_lob_is_equal() | OCI-Lob::free() | Objetos grandes de Oracle
oci8 statement | oci_parse(), oci_new_cursor() | oci_bind_array_by_name(), oci_bind_by_name(), oci_cancel(), oci_define_by_name(), oci_error() oci_execute(), oci_fetch_all(), oci_fetch_array(), oci_fetch_assoc(), oci_fetch_object(), oci_fetch_row(), oci_fetch(), oci_field_is_null(), oci_field_name(), oci_field_precision(), oci_field_scale(), oci_field_size(), oci_field_type_raw(), oci_field_type(), oci_num_fields(), oci_num_rows(), oci_result(), oci_set_prefetch(), oci_statement_type() | oci_free_statement() | Cursor de Oracle
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | Enlace a una base de datos ODBC
odbc link persistent | odbc_pconnect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | Nadie | Enlace persistente a una base de datos ODBC
odbc result | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | Resultado de ODBC
birdstep link
birdstep result
OpenSSL key | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | Clave OpenSSL
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Clave pública
pdf document | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_add_thumbnail(), pdf_arcn(), pdf_begin_pattern(), pdf_begin_template(), pdf_end_pattern(), pdf_end_template(), pdf_initgraphics(), pdf_makespotcolor(), pdf_set_info(), pdf_setcolor(), pdf_setmatrix(), pdf_open_memory_image() | pdf_close(), pdf_delete() | Documento PDF
pdf image | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | Imagen en un fichero PDF
pdf object
pdf outline
pgsql large object | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | Objeto Grande de PostgreSQL
pgsql link | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | Enlace a una base de datos PostgreSQL
pgsql link persistent | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | Nadie | Enlace persistente a una base de datos PostgreSQL
pgsql result | pg_execute(), pg_query(), pg_query_params(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | Resultado de PostgreSQL
pgsql string
printer
printer brush
printer font
printer pen
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | Nadie | Diccionario pspell
pspell config | pspell_config_create() | pspell_new_config() | Nadie | Configuración de pspell
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close() | Manejo de bloques de memoria compartida (a partir de PHP 7.0.0)
sockets file descriptor set | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
sockets i/o vector
stream | opendir() | readdir(), rewinddir() | closedir() | Gestor de directorio
stream | fopen(), tmpfile() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | Gestor de fichero
stream | popen(), fsockopen(), pfsockopen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Gestor de proceso
socket | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Gestor de socket
sybase-db link | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | Enlace a una base de datos Sybase usando la biblioteca DB
sybase-db link persistent | sybase_pconnect() | sybase_query(), sybase_select_db() | Nadie | Enlace persistente a una base de datos Sybase usando la biblioteca DB
sybase-db result | sybase_query(), sybase_unbuffered_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Resultado de Sybase usando la biblioteca DB
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | Enlace a una base de datos Sybase usando la biblioteca CT
sybase-ct link persistent | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | Nadie | Enlace persistente a una base de datos Sybase usando la biblioteca CT
sybase-ct result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Resultado de Sybase usando la biblioteca CT
sysvsem | sem_get() | sem_acquire() | sem_release() | Semáforo de System V
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | Memoria compartida de System V
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | Paquete WDDX
xml | xml_parser_create(), xml_parser_create_ns(), | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | Analizador sintáctico XML
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | Fichero comprimido gz
zlib.deflate | deflate_init() | deflate_add() | Ninguna() | contexto de desinflación incremental
zlib.inflate | inflate_init() | inflate_add() | Ninguna() | contexto de inflación incremental


Lista de filtros disponibles

Tabla de contenidos

  • Filtros de String
  • Filtros de conversión
  • Filtros de compresión
  • Filtros de encriptación

La siguiente es una lista de unos cuantos filtros de secuencia integrados que puede usar con stream_filter_append(). Su versión de PHP puede tener más filtros (o menos) que aquellos que aparecen aquí.

Vale la pena anotar una ligera asimetría entre stream_filter_append() y stream_filter_prepend(). Cada secuencia en PHP contiene un pequeño búfer de lectura en donde almacena los bloques de datos recibidos desde el sistema de archivos u otro recurso para procesar los datos de la forma más eficiente. Tan pronto como los datos son tomados del recurso y colocados en el búfer interno de la secuencia, éstos son procesados inmediatamente a través de cualquier filtro adjunto sin importar que la aplicación PHP esté lista para los datos o no. Si los datos están en el búfer de lectura cuando un filtro es añadido al final, los datos serán procesados inmediatamente a través del filtro haciendo parecer que el proceso fuera transparente. Sin embargo, si los datos están en el búfer de lectura cuando un filtro es adjuntado al comienzo, los datos NO serán procesados a través del filtro. En su lugar esperará a que el siguiente bloque de datos sea recuperado del recurso.

Para una lista de filtros instalados en su versión de PHP, use stream_get_filters().


Filtros de String

Cada uno de estos filtros hace precisamente lo que su nombre implica y corresponden al comportamiento de una función de manejo de strings php incorporada. Para obtener más información sobre un filtro determinado, consulte la página del manual de la función correspondiente.

string.rot13

El uso de este filtro es equivalente a procesar todos los datos de la secuencia a través de la función str_rot13().

Ejemplo #1 string.rot13

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.rot13');
fwrite($fp, "Esto es una prueba.\n");
/* Salida:  Guvf vf n grfg.   */
?>

string.toupper

El uso de este filtro es equivalente a procesar todos los datos de la secuencia a través de la función strtoupper().

Ejemplo #2 string.toupper

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.toupper');
fwrite($fp, "Esto es una prueba.\n");
/* Salida:  ESTO ES UNA PRUEBA.   */
?>

string.tolower

El uso de este filtro es equivalente a procesar todos los datos de la secuencia a través de la función strtolower().

Ejemplo #3 string.tolower

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.tolower');
fwrite($fp, "Esto es una prueba.\n");
/* Salida:  esto es una prueba.   */
?>

string.strip_tags

El uso de este filtro es equivalente a procesar todos los datos de la secuencia a través de la función strip_tags(). Acepta parámetros en una de dos formas: Ya sea como un string que contiene una lista de etiquetas similares a el segundo parámetro de la función strip_tags(), o como un array de nombres de etiqueta.

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.2.0. Su uso está totalmente desaconsejado.

Ejemplo #4 string.strip_tags

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, "<b><i><u>");
fwrite($fp, "<b>texto en negrita</b> ampliado a un <h1>título de nivel 1</h1>\n");
fclose($fp);
/* Imprime:  <b>texto en negrita</b> ampliado a un título de nivel 1   */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, array('b','i','u'));
fwrite($fp, "<b>texto en negrita</b> ampliado a un <h1>título de nivel 1</h1>\n");
fclose($fp);
/* Imprime:  <b>texto en negrita</b> ampliado a un título de nivel 1   */
?>


Filtros de conversión

Como los filtros string.*, los filtros convert.* realiza acciones similares a sus nombres. Para obtener más información sobre un filtro determinado, consulte la página del manual de la función correspondiente.

convert.base64-encode y convert.base64-decode

El uso de estos filtros equivale a procesar todos los datos de la secuencia a través de las funciones base64_encode() y base64_decode() respectivamente. convert.base64-encode soporta parámetros dados como un array asociativo. Si el parámetro line-length se da, la salida de base64 se dividirá en trozos de line-length caracteres cada uno. Si el parámetro line-break-chars se da, cada porción será delimitada por los caracteres dados. Estos parámetros le dan el mismo efecto que el uso de base64_encode() con chunk_split().

Ejemplo #1 convert.base64-encode & convert.base64-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode');
fwrite($fp, "Esto es una prueba.\n");
fclose($fp);
/* Outputs:  VGhpcyBpcyBhIHRlc3QuCg==  */

$param = array('line-length' => 8, 'line-break-chars' => "\r\n");
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode', STREAM_FILTER_WRITE, $param);
fwrite($fp, "Esto es una prueba.\n");
fclose($fp);
/* Outputs:  VGhpcyBp
          :  cyBhIHRl
          :  c3QuCg==  */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-decode');
fwrite($fp, "VGhpcyBpcyBhIHRlc3QuCg==");
fclose($fp);
/* Salida:  Esto es una prueba.  */
?>

convert.quoted-printable-encode y convert.quoted-printable-decode

El uso de la versión decodificada de este filtro equivale a procesar todo el flujo de datos a través de las funciones quoted_printable_decode(). No existe una función equivalente a convert.quoted-printable-encode. convert.quoted-printable-encode soporta parámetros dados como un array asociativo. Además de los parámetros soportados por convert.base64-encode, convert.quoted-printable-encode también soporta argumentos booleanos binary y force-encode-first. convert.base64-decode sólo soporta los parámetros line-break-chars como un tipo sugerido para quitar la carga útil codificada.

Ejemplo #2 convert.quoted-printable-encode & convert.quoted-printable-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-encode');
fwrite($fp, "Esto es una prueba.\n");
/* Outputs:  =Esto es una prueba.=0A  */
?>

convert.iconv.*

Los filtros convert.iconv.* están disponibles, si el soporte iconv está habilitado, y su uso es equivalente a procesar todos los datos de la secuencia con iconv(). Estos filtros no soportan parámetros, sino que esperan que la entrada y codificaciones de salida que se darán como parte del nombre del filtro, es decir, ya sea como convert.iconv.<input-encoding>.<output-encoding> o convert.iconv.<input-encoding>/<output-encoding> (ambas notaciones son semánticamente equivalentes).

Ejemplo #3 convert.iconv.*

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.iconv.utf-16le.utf-8');
fwrite($fp, "T\0h\0i\0s\0 \0i\0s\0 \0a\0 \0t\0e\0s\0t\0.\0\n\0");
fclose($fp);
/* Salida: Esto es una prueba. */
?>


Filtros de compresión

Mientras que los Envoltorios de compresión proporcionan una forma de crear ficheros gzip y bz2 compatibles con el sistema de archivos local, no proporcionan un medio para la compresión generalizada sobre los flujos de la red, ni proporcionan un medio para comenzar con un flujo no comprimido y la transición a uno comprimido. Para ello, se puede aplicar un filtro de compresión a cualquier recurso de flujo en cualquier momento.

Nota: Los filtros de compresión no generan cabeceras y avances utilizadas por las utilidades de línea de comando como gzip. Sólo comprimen y descomprimen las porciones de carga útil de los flujos de datos comprimidos.

zlib.deflate y zlib.inflate

zlib.deflate (compresión) y zlib.inflate (descompresión) son implementaciones de los métodos de compresión descritos en » RFC 1951. Los filtros deflate toma hasta tres parámetros pasados como un array asociativo. level describe la intensidad de compresión (1-9). Números más grandes producen, por lo general, resultados más pequeños, al costo de tiempo de procesamiento adicional. Dos niveles de compresión especiales existen también: 0 (para no-compresión), y -1 (el valor predeterminado de zlib -- actualmente 6). window es el registro en base-2 del tamaño de ventana del circuito cerrado de compresión. Valores más altos (de hasta 15 -- 32768 bytes) producen mejor compresión al costo de más memoria, mientras valores más bajos (alrededor de 9 -- 512 bytes) producen una compresión inferior en un espacio de memoria más pequeño. El tamaño de window es actualmente 15. memory es una escala que indica cuánta memoria debería ser reservada. Los valores válidos están en el rango de 1 (reserva mínima) a 9 (reserva máxima). Esta reserva de memoria afecta únicamente la repidez y no tiene impacto en el tamaño del resultado generado.

Nota: Debido a que el nivel de compresión es el parámetro más comúnmente usado, puede ser alternativamente proporcionado como un valor entero simple (en lugar de un elemento de array).

Los filtros de compresión zlib.* están disponibles con PHP desde la versión 5.1.0 si el soporte de zlib se encuentra habilitado. También están disponibles como una característica portada de vuelta en la versión 5.0.x, instalando el paquete » zlib_filter desde » PECL.

Ejemplo #1 zlib.deflate y zlib.inflate

<?php
$params = array('level' => 6, 'window' => 15, 'memory' => 9);

$texto_original = "Esto es una prueba.\nEsto es solo una prueba.\nEsta no es una cadena importante.\n";
echo "El texto original tiene " . strlen($texto_original) . " caracteres.\n";

$da = fopen('test.deflated', 'w');
stream_filter_append($da, 'zlib.deflate', STREAM_FILTER_WRITE, $params);
fwrite($da, $texto_original);
fclose($da);

echo "El archivo comprimido tiene " . filesize('test.deflated') . " bytes.\n";
echo "El texto original era:\n";
/* Use readfile y zlib.inflate para descomprimir al vuelo */
readfile('php://filter/zlib.inflate/resource=test.deflated');

/* Genera la salida:

El texto original tiene 79 caracteres.
El archivo comprimido tiene 59 bytes.
El texto original era:
Esto es una prueba.
Esto es solo una prueba.
Esta no es una cadena importante.

 */
?>

Ejemplo #2 zlib.deflate simple

<?php
$texto_original = "Esto es una prueba.\nEsto es solo una prueba.\nEsta no es una cadena importante.\n";
echo "El texto original tiene " . strlen($texto_original) . " caracteres.\n";

$da = fopen('test.deflated', 'w');
/* Aqui "6" indica el nivel 6 de compresion */
stream_filter_append($da, 'zlib.deflate', STREAM_FILTER_WRITE, 6);
fwrite($da, $texto_original);
fclose($da);

echo "El archivo comprimido tiene " . filesize('test.deflated') . " bytes.\n";

/* Genera la salida:

El texto original tiene 79 caracteres.
El archivo comprimido tiene 53 bytes.

 */
?>

bzip2.compress y bzip2.decompress

bzip2.compress y bzip2.decompress funcionan de la misma forma que los filtros zlib descritos anteriormente. El filtro bzip2.compress acepta hasta dos parámetros dados como elementos de una matriz asociativa: blocks es un valor entero desde 1 hasta 9 que indica el número de bloques de 100kbytes de memoria a reservar para el espacio de trabajo. work es también un valor entero que va desde 0 a 250, e indica cuánto esfuerzo debe invertirse para expandir usando el método de compresión normal antes de caer en un método más lento pero más confiable. Modificar este parámetro afecta únicamente la rapidez de compresién. Ni el tamaño de la salida comprimida ni el uso de memoria se modifican por este valor. Un factor de trabajo de 0 le indica a la biblioteca bzip que debe usar el valor interno predeterminado. El filtro bzip2.decompress sólo acepta un parámetro, el cual puede ser pasado como un valor booleano ordinario, o como el elemento small de una matriz asociativa. small, cuando se define a un valor true, le indica a la biblioteca bzip de realice una descompresión con una cantidad de memoria mínima, al costo de la rapidez.

Las filtros de compresión bzip2.* se encuentran disponibles con PHP desde la versión 5.1.0 si el soporte de bz2 se encuentra habilitado. También se encuentran disponibles como una característica portada hacia atrás en la versión 5.0.x, instalando el paquete » bz2_filter desde » PECL.

Ejemplo #3 bzip2.compress y bzip2.decompress

<?php
$param = array('blocks' => 9, 'work' => 0);

echo "El archivo original tiene " . filesize('LICENSE') . " bytes.\n";

$da = fopen('LICENSE.compressed', 'w');
stream_filter_append($da, 'bzip2.compress', STREAM_FILTER_WRITE, $param);
fwrite($da, file_get_contents('LICENSE'));
fclose($da);

echo "El archivo comprimido tiene " . filesize('LICENSE.compressed') . " bytes.\n";

/* Genera la salida:

El archivo original tiene 3288 bytes.
El archivo comprimido tiene 1488 bytes.

 */
?>


Filtros de encriptación

Los filtros de cifrado son especialmente útiles para el cifrado de archivos y flujos.

mcrypt.* y mdecrypt.*

Advertencia

Esta característica ha sido declarada OBSOLETA a partir de PHP 7.0.1. Su uso está totalmente desaconsejado.

mcrypt.* y mdecrypt.* ofrecen encripción y desencripción simétrica usando libmcrypt. Ambos conjuntos de filtros soportan los mismos algoritmos disponibles a la extensión mcrypt en la forma de mcrypt.ciphername, en donde ciphername es el nombre del cifrado que debe ser pasado a mcrypt_module_open(). Los siguientes cinco parámetros se encuentran disponibles también:

parámetros del filtro mcrypt
Parámetro | ¿Requerido? | Por omisión | Valores de ejemplo
mode | Optional | cbc | cbc, cfb, ecb, nofb, ofb, stream
algorithms_dir | Optional | ini_get('mcrypt.algorithms_dir') | Ubicación de los módulos de los algoritmos
modes_dir | Optional | ini_get('mcrypt.modes_dir') | Ubicación de los módulos de los modos
iv | Required | N/A | Típicamente 8, 16, o 32 bytes de datos binarios. Depende del cifrado
key | Required | N/A | Típicamente 8, 16, o 32 bytes de datos binarios. Depende del cifrado

Ejemplo #1 Encriptar/Desencriptar con Blowfish

<?php
//$key que se supone que ha sido generado previamente
$iv_size = mcrypt_get_iv_size(MCRYPT_BLOWFISH, MCRYPT_MODE_CBC);
$iv = mcrypt_create_iv($iv_size, MCRYPT_DEV_URANDOM);
$fp = fopen('encrypted-file.enc', 'wb');
fwrite($fp, $iv);
$opts = array('mode'=>'cbc','iv'=>$iv, 'key'=>$key);
stream_filter_append($fp, 'mcrypt.blowfish', STREAM_FILTER_WRITE, $opts);
fwrite($fp, 'message to encrypt');
fclose($fp);

//desencriptar...
$fp = fopen('encrypted-file.enc', 'rb');
$iv = fread($fp, $iv_size = mcrypt_get_iv_size(MCRYPT_BLOWFISH, MCRYPT_MODE_CBC));
$opts = array('mode'=>'cbc','iv'=>$iv, 'key'=>$key)
stream_filter_append($fp, 'mdecrypt.blowfish', STREAM_FILTER_READ, $opts);
$data = rtrim(stream_get_contents($fp));//trims off null padding
fclose($fp);
echo $data;
?>

Ejemplo #2 Encriptar el archivo usando AES-128 CBC con SHA256 HMAC en PHP 5.5+

<?php
AES_CBC::encryptFile($password, "plaintext.txt", "encrypted.enc");
AES_CBC::decryptFile($password, "encrypted.enc", "decrypted.txt");

class AES_CBC
{
   protected static $KEY_SIZES = array('AES-128'=>16,'AES-192'=>24,'AES-256'=>32);
   protected static function key_size() { return self::$KEY_SIZES['AES-128']; } //default AES-128
   public static function encryptFile($password, $input_stream, $aes_filename){
      $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_128, MCRYPT_MODE_CBC);
      $fin = fopen($input_stream, "rb");
      $fc = fopen($aes_filename, "wb+");
      if (!empty($fin) && !empty($fc)) {
         fwrite($fc, str_repeat("_", 32) );//marcador de posición, SHA256 HMAC irá aquí más tarde
         fwrite($fc, $hmac_salt = mcrypt_create_iv($iv_size, MCRYPT_DEV_URANDOM));
         fwrite($fc, $esalt = mcrypt_create_iv($iv_size, MCRYPT_DEV_URANDOM));
         fwrite($fc, $iv = mcrypt_create_iv($iv_size, MCRYPT_DEV_URANDOM));
         $ekey = hash_pbkdf2("sha256", $password, $esalt, $it=1000, self::key_size(), $raw=true);
         $opts = array('mode'=>'cbc', 'iv'=>$iv, 'key'=>$ekey);
         stream_filter_append($fc, 'mcrypt.rijndael-128', STREAM_FILTER_WRITE, $opts);
         $infilesize = 0;
         while (!feof($fin)) {
            $block = fread($fin, 8192);
            $infilesize+=strlen($block);
            fwrite($fc, $block);
         }
         $block_size = mcrypt_get_block_size(MCRYPT_RIJNDAEL_128, MCRYPT_MODE_CBC);
         $padding = $block_size - ($infilesize % $block_size);//$padding es un número del 1 al 16
         fwrite($fc, str_repeat(chr($padding), $padding) );//realizar el relleno de PKCS7
         fclose($fin);
         fclose($fc);
         $hmac_raw = self::calculate_hmac_after_32bytes($password, $hmac_salt, $aes_filename);
         $fc = fopen($aes_filename, "rb+");
         fwrite($fc, $hmac_raw);//sobrescribir el marcador de posición
         fclose($fc);
      }
   }
   public static function decryptFile($password, $aes_filename, $out_stream) {
      $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_128, MCRYPT_MODE_CBC);
      $hmac_raw = file_get_contents($aes_filename, false, NULL,  0, 32);
      $hmac_salt = file_get_contents($aes_filename, false, NULL, 32, $iv_size);
      $hmac_calc = self::calculate_hmac_after_32bytes($password, $hmac_salt, $aes_filename);
      $fc = fopen($aes_filename, "rb");
      $fout = fopen($out_stream, 'wb');
      if (!empty($fout) && !empty($fc) && self::hash_equals($hmac_raw,$hmac_calc)) {
         fread($fc, 32+$iv_size);//skip sha256 hmac and salt
         $esalt = fread($fc, $iv_size);
         $iv    = fread($fc, $iv_size);
         $ekey = hash_pbkdf2("sha256", $password, $esalt, $it=1000, self::key_size(), $raw=true);
         $opts = array('mode'=>'cbc', 'iv'=>$iv, 'key'=>$ekey);
         stream_filter_append($fc, 'mdecrypt.rijndael-128', STREAM_FILTER_READ, $opts);
         while (!feof($fc)) {
            $block = fread($fc, 8192);
            if (feof($fc)) {
               $padding = ord($block[strlen($block) - 1]);//asume el relleno del PKCS7
               $block = substr($block, 0, 0-$padding);
            }
            fwrite($fout, $block);
         }
         fclose($fout);
         fclose($fc);
      }
   }
   private static function hash_equals($str1, $str2) {
      if(strlen($str1) == strlen($str2)) {
         $res = $str1 ^ $str2;
         for($ret=0,$i = strlen($res) - 1; $i >= 0; $i--) $ret |= ord($res[$i]);
         return !$ret;
      }
      return false;
   }
   private static function calculate_hmac_after_32bytes($password, $hsalt, $filename) {
      static $init=0;
      $init or $init = stream_filter_register("user-filter.skipfirst32bytes", "FileSkip32Bytes");
      $stream = 'php://filter/read=user-filter.skipfirst32bytes/resource=' . $filename;
      $hkey = hash_pbkdf2("sha256", $password, $hsalt, $iterations=1000, 24, $raw=true);
      return hash_hmac_file('sha256', $stream, $hkey, $raw=true);
   }
}
class FileSkip32Bytes extends php_user_filter
{
   private $skipped=0;
   function filter($in, $out, &$consumed, $closing)  {
      while ($bucket = stream_bucket_make_writeable($in)) {
         $outlen = $bucket->datalen;
         if ($this->skipped<32){
            $outlen = min($bucket->datalen,32-$this->skipped);
            $bucket->data = substr($bucket->data, $outlen);
            $bucket->datalen = $bucket->datalen-$outlen;
            $this->skipped+=$outlen;
         }
         $consumed += $outlen;
         stream_bucket_append($out, $bucket);
      }
      return PSFS_PASS_ON;
   }
}
class AES_128_CBC extends AES_CBC {
   protected static function key_size() { return self::$KEY_SIZES['AES-128']; }
}
class AES_192_CBC extends AES_CBC {
   protected static function key_size() { return self::$KEY_SIZES['AES-192']; }
}
class AES_256_CBC extends AES_CBC {
   protected static function key_size() { return self::$KEY_SIZES['AES-256']; }
}


Lista de Transportes de Sockets Soportados

Tabla de contenidos

  • Dominio de Internet: TCP, UDP, SSL, y TLS
  • Dominio Unix: Unix y UDG

La siguiente es una lista de los varios transportes de socket estilo URL que PHP tiene integrados para su uso con funciones de sockets basados en secuencias, tales como fsockopen(), y stream_socket_client(). Estos transportes no se aplican a la Extensión de Sockets.

Para una lista de transportes instalados con su versión de PHP use stream_get_transports().


Dominio de Internet: TCP, UDP, SSL, y TLS

PHP 4, PHP 5. ssl:// y tls:// a partir de PHP 4.3.0, sslv2:// y sslv3:// a partir de PHP 5.0.2

Nota: Si no se especifica un transporte, se asumirá tcp://

  • 127.0.0.1
  • fe80::1
  • www.example.com
  • tcp://127.0.0.1
  • tcp://fe80::1
  • tcp://www.example.com
  • udp://www.example.com
  • ssl://www.example.com
  • sslv2://www.example.com
  • sslv3://www.example.com
  • tls://www.example.com

Los sockets del Dominio de Internet esperan un número de puerto junto con una dirección de destino. En el caso de fsockopen(), éste es especificado en un segundo parámetro y por lo tanto no tiene impacto sobre el formato de la URL de transporte. Sin embargo, en el caso de stream_socket_client() y funciones relacionadas, así como ocurre con URLs tradicionales, el número de puerto se especifica como un sufijo del URL de transporte delimitado con el signo dos puntos.

  • tcp://127.0.0.1:80
  • tcp://[fe80::1]:80
  • tcp://www.example.com:80

Nota: Direcciones IPv6 numéricas con números de puerto
En el segundo ejemplo anterior, mientras que los ejemplos IPv4 y con nombre de dominio fueron modificados solo ligeramente con la adición de sus dos puntos y número de puerto, la dirección IPv6 es rodeada por corchetes cuadrados: [fe80::1]. Esto es para poder distinguir entre los dos puntos usados en una dirección IPv6 y aquellos usados para delimitar el número de puerto.

Los transportes ssl:// y tls:// (disponibles únicamente cuando se compila el soporte para openssl con PHP) son extensiones del transporte tcp:// el cual incluye encripción SSL. A partir de PHP 4.3.0 el soporte OpenSSL debe ser compilado estáticamente con PHP, a partir de PHP 5.0.0 puede ser compilado como módulo o estáticamente.

ssl:// intentará negociar una conexión SSL V2 o SSL V3 dependiendo de las capacidades y preferencias del host remoto. sslv2:// y sslv3:// seleccionarán el protocolo SSL V2 o SSL V3 explícitamente.


Dominio Unix: Unix y UDG

unix:// y udg:// (udg:// a partir de PHP 5).

  • unix:///tmp/misock
  • udg:///tmp/misock

unix:// provee acceso a una conexión secuencial de sockets en el dominio Unix. udg:// provee un transporte alternativo a un socket del dominio Unix, usando el protocolo de datagramas de usuario.

Los sockets de dominio Unix, a diferencia de los sockets del dominio de Internet, no esperan un número de puerto. En el caso de fsockopen(), el parámetro num_puerto debe ser definido como 0.


Tablas de comparación de tipos de PHP

Las siguientes tablas demuestran el comportamiento de los tipos de PHP y los operadores de comparación, tanto para comparaciones flexibles como estrictas. Este suplemento está relacionado también con la sección del manual sobre manipulación de tipos. La inspiración proviene de varios comentarios de usuarios y del trabajo realizado en » BlueShoes.

Antes de usar estas tablas, es importante entender los tipos y sus significados. Por ejemplo, "42" es un string mientras que 42 es un integer. false es un boolean mientras "false" es un string.

Nota:

Los formularios HTML no pasan enteros, reales, o booleanos; solo pasan cadenas. Para saber si una cadena es numérica, se puede usar is_numeric().

Nota:

Hacer un simple if ($x) mientras que $x no esté definido, generará un error de nivel E_NOTICE. En lugar de esto, considere el uso de empty() o isset(), y/o inicialice sus variables.

Nota:

Algunas representaciones numéricas pueden resultar en un valor representado por la constante NAN. Cualquier comparación flexible o estricta de este valor con cualquier otro valor, incluyendo a sí mismo, excepto true, tendrá un resultado false, (esto es, NAN != NAN y NAN !== NAN). Algunos ejemplos de operaciones que producen NAN son sqrt(-1), asin(2), y acosh(0).

Comparaciones de $x con funciones PHP
Expresión | gettype() | empty() | is_null() | isset() | boolean : if($x)
$x = ""; | string | true | false | true | false
$x = null; | NULL | true | true | false | false
var $x; | NULL | true | true | false | false
$x no está definido | NULL | true | true | false | false
$x = array(); | array | true | false | true | false
$x = array('a', 'b'); | array | false | false | true | true
$x = false; | boolean | true | false | true | false
$x = true; | boolean | false | false | true | true
$x = 1; | integer | false | false | true | true
$x = 42; | integer | false | false | true | true
$x = 0; | integer | true | false | true | false
$x = -1; | integer | false | false | true | true
$x = "1"; | string | false | false | true | true
$x = "0"; | string | true | false | true | false
$x = "-1"; | string | false | false | true | true
$x = "php"; | string | false | false | true | true
$x = "true"; | string | false | false | true | true
$x = "false"; | string | false | false | true | true

Comparaciones flexibles con ==
 | true | false | 1 | 0 | -1 | "1" | "0" | "-1" | null | array() | "php" | ""
true | true | false | true | false | true | true | false | true | false | false | true | false
false | false | true | false | true | false | false | true | false | true | true | false | true
1 | true | false | true | false | false | true | false | false | false | false | false | false
0 | false | true | false | true | false | false | true | false | true | false | true | true
-1 | true | false | false | false | true | false | false | true | false | false | false | false
"1" | true | false | true | false | false | true | false | false | false | false | false | false
"0" | false | true | false | true | false | false | true | false | false | false | false | false
"-1" | true | false | false | false | true | false | false | true | false | false | false | false
null | false | true | false | true | false | false | false | false | true | true | false | true
array() | false | true | false | false | false | false | false | false | true | true | false | false
"php" | true | false | false | true | false | false | false | false | false | false | true | false
"" | false | true | false | true | false | false | false | false | true | false | false | true

Comparaciones estrictas con ===
 | true | false | 1 | 0 | -1 | "1" | "0" | "-1" | null | array() | "php" | ""
true | true | false | false | false | false | false | false | false | false | false | false | false
false | false | true | false | false | false | false | false | false | false | false | false | false
1 | false | false | true | false | false | false | false | false | false | false | false | false
0 | false | false | false | true | false | false | false | false | false | false | false | false
-1 | false | false | false | false | true | false | false | false | false | false | false | false
"1" | false | false | false | false | false | true | false | false | false | false | false | false
"0" | false | false | false | false | false | false | true | false | false | false | false | false
"-1" | false | false | false | false | false | false | false | true | false | false | false | false
null | false | false | false | false | false | false | false | false | true | false | false | false
array() | false | false | false | false | false | false | false | false | false | true | false | false
"php" | false | false | false | false | false | false | false | false | false | false | true | false
"" | false | false | false | false | false | false | false | false | false | false | false | true


Lista de componentes léxicos del analizador

Algunas partes del lenguaje PHP son representadas internamente por tipos como T_SR. PHP produce identificadores como este a la hora de analizar errores, como "Parse error: unexpected T_SR, expecting ',' or ';' in script.php on line 10." ("Error de análisis: T_SR inesperado, se esperaba ',' o ';' en script.php en la línea 10.")

Se supone que uno debería saber lo qué significa T_SR. Para todo aquél que no lo sepa, se muestra una tabla con dichos identificadores, la sintaxis de PHP y referencias al apartado apropiado del manual.

Nota: Uso de las constantes T_*

Todos los componentes léxicos (o tokens) enumerados abajo también están definidos como constantes de PHP. Sus valores son automáticamente generados basándose en la infraestructura del analizador subyacente de PHP. Esto significa que el valor concreto de un componenete léxico puede cambiar entre dos versiones de PHP. Por ejemplo, la constante T_FILE es 365 en PHP 5.3, mientras que el mismo valor se refiere ahora a T_TRAIT en PHP 5.4, y el valor de T_FILE es 369. Esto sigifica que el código no debería nunca depender directamente de los valores originales de las constantes T_* tomadas de la versión X.Y.Z de PHP, para proporcionar cierta compatibildad entre múltiples versiones PHP. En su lugar, el código debería utilizar valores personalizados (usando números grandes como 10000) y una estrategia apropiada que funcione tanto con las versiones de PHP como con los valores de las constantes T_*.

Componente léxico
Elemento | Sintaxis | Referencia
T_ABSTRACT | abstract | Abstracción de clases (disponible desde PHP 5.0.0)
T_AND_EQUAL | &= | operadores de asignación
T_ARRAY | array() | array(), sintaxis de array
T_ARRAY_CAST | (array) | conversión de tipos
T_AS | as | foreach
T_BAD_CHARACTER |  | todo lo que haya por debajo de ASCII 32 excepto \t (0x09), \n (0x0a) y \r (0x0d)
T_BOOLEAN_AND | && | operadores lógios
T_BOOLEAN_OR | || | operadores lógicos
T_BOOL_CAST | (bool) o (boolean) | conversión de tipos
T_BREAK | break | break
T_CALLABLE | callable | callable
T_CASE | case | switch
T_CATCH | catch | Excepciones (disponible desde PHP 5.0.0)
T_CHARACTER |  | ya no se utiliza
T_CLASS | class | clases y objetos
T_CLASS_C | __CLASS__ | constantes mágicas
T_CLONE | clone | clases y objetos
T_CLOSE_TAG | ?> o %> | salir de HTML
T_COMMENT | // o #, y /* */ | comentarios
T_CONCAT_EQUAL | .= | operadores de asignación
T_CONST | const | constantes
T_CONSTANT_ENCAPSED_STRING | "foo" o 'bar' | sintaxis de string
T_CONTINUE | continue | continue
T_CURLY_OPEN | {$ | sintaxis compleja
T_DEC | -- | operadores de incremento/decremento
T_DECLARE | declare | declare
T_DEFAULT | default | switch
T_DIR | __DIR__ | constantes mágicas (disponible desde PHP 5.3.0)
T_DIV_EQUAL | /= | operadores de asignación
T_DNUMBER | 0.12, etc. | números de punto flotante
T_DOC_COMMENT | /** */ | comentarios tipo PHPDoc
T_DO | do | do..while
T_DOLLAR_OPEN_CURLY_BRACES | ${ | sintaxis compleja
T_DOUBLE_ARROW | => | sintaxis de array
T_DOUBLE_CAST | (real), (double) o (float) | conversión de tipos
T_DOUBLE_COLON | :: | véase T_PAAMAYIM_NEKUDOTAYIM más abajo
T_ECHO | echo | echo
T_ELLIPSIS | ... | argumentos de función (disponible desde PHP 5.6.0)
T_ELSE | else | else
T_ELSEIF | elseif | elseif
T_EMPTY | empty | empty()
T_ENCAPSED_AND_WHITESPACE | " $a" | parte constante de un string con variables
T_ENDDECLARE | enddeclare | declare, sintaxis alternativa
T_ENDFOR | endfor | for, sintaxis alternativa
T_ENDFOREACH | endforeach | foreach, sintaxis alternativa
T_ENDIF | endif | if, sintaxis alternativa
T_ENDSWITCH | endswitch | switch, sintaxis alternativa
T_ENDWHILE | endwhile | while, sintaxis alternativa
T_END_HEREDOC |  | sintaxis de heredoc
T_EVAL | eval() | eval()
T_EXIT | exit o die | exit(), die()
T_EXTENDS | extends | extends, clases y objetos
T_FILE | __FILE__ | constantes mágicas
T_FINAL | final | Palabra clave Final
T_FINALLY | finally | Excepciones (disponible desde PHP 5.5.0)
T_FOR | for | for
T_FOREACH | foreach | foreach
T_FUNCTION | function o cfunction | funciones
T_FUNC_C | __FUNCTION__ | constantes mágicas
T_GLOBAL | global | ámbito de las variables
T_GOTO | goto | (disponible desde PHP 5.3.0)
T_HALT_COMPILER | __halt_compiler() | __halt_compiler (disponible desde PHP 5.1.0)
T_IF | if | if
T_IMPLEMENTS | implements | Interfaces de objetos
T_INC | ++ | operadores de incremento/decremento
T_INCLUDE | include() | include
T_INCLUDE_ONCE | include_once() | include_once
T_INLINE_HTML |  | texto fuera de PHP
T_INSTANCEOF | instanceof | operadores de tipo
T_INSTEADOF | insteadof | Rasgos (Traits) (disponible desde PHP 5.4.0)
T_INT_CAST | (int) o (integer) | conversión de tipos
T_INTERFACE | interface | Interfaces de objetos
T_ISSET | isset() | isset()
T_IS_EQUAL | == | operadores de comparación
T_IS_GREATER_OR_EQUAL | >= | operadores de comparación
T_IS_IDENTICAL | === | operadores de comparación
T_IS_NOT_EQUAL | != o <> | operadores de comparación
T_IS_NOT_IDENTICAL | !== | operadores de comparación
T_IS_SMALLER_OR_EQUAL | <= | operadores de comparación
T_SPACESHIP | <=> | operadores de comparación (disponible desde PHP 7.0.0)
T_LINE | __LINE__ | constantes mágicas
T_LIST | list() | list()
T_LNUMBER | 123, 012, 0x1ac, etc. | números enteros
T_LOGICAL_AND | and | operadores lógicos
T_LOGICAL_OR | or | operadores lógicos
T_LOGICAL_XOR | xor | operadores lógicos
T_METHOD_C | __METHOD__ | constantes mágicas
T_MINUS_EQUAL | -= | operadores de asignación
T_MOD_EQUAL | %= | operadores de asignación
T_MUL_EQUAL | *= | operadores de asignación
T_NAMESPACE | namespace | espacios de nombres (disponible desde PHP 5.3.0)
T_NS_C | __NAMESPACE__ | espacios de nombres (disponible desde PHP 5.3.0)
T_NS_SEPARATOR | \ | espacios de nombres (disponible desde PHP 5.3.0)
T_NEW | new | clases y objectos
T_NUM_STRING | "$a[0]" | array de índice numérico dentro de un string
T_OBJECT_CAST | (object) | conversión de tipos
T_OBJECT_OPERATOR | -> | clases y objetos
T_OPEN_TAG | <?php, <? o <% | salir de HTML
T_OPEN_TAG_WITH_ECHO | <?= o <%= | salir de HTML
T_OR_EQUAL | |= | operadores de asignación
T_PAAMAYIM_NEKUDOTAYIM | :: | ::. También se define como T_DOUBLE_COLON.
T_PLUS_EQUAL | += | operadores de asignación
T_POW | ** | operadores aritméticos (disponible desde PHP 5.6.0)
T_POW_EQUAL | **= | operadores de asignación (disponible desde PHP 5.6.0)
T_PRINT | print() | print
T_PRIVATE | private | clases y objetos
T_PUBLIC | public | clases y objetos
T_PROTECTED | protected | clases y objetos
T_REQUIRE | require() | require
T_REQUIRE_ONCE | require_once() | require_once
T_RETURN | return | valores de retorno
T_SL | << | operadores a nivel de bits
T_SL_EQUAL | <<= | operadores de asignación
T_SR | >> | operadores a nivel de bits
T_SR_EQUAL | >>= | operadores de asignación
T_START_HEREDOC | <<< | sintaxis de heredoc
T_STATIC | static | ámbito de las variables
T_STRING | parent, self, etc. | se comparan identificadores, p.ej. palabras clave como parent y self, nombres de funciones, nombres de clases y más. Véase también T_CONSTANT_ENCAPSED_STRING.
T_STRING_CAST | (string) | conversión de tipos
T_STRING_VARNAME | "${a | sintaxis compleja
T_SWITCH | switch | switch
T_THROW | throw | Excepciones
T_TRAIT | trait | Rasgos (Traits) (disponible desde PHP 5.4.0)
T_TRAIT_C | __TRAIT__ | __TRAIT__ (disponible desde PHP 5.4.0)
T_TRY | try | Excepciones
T_UNSET | unset() | unset()
T_UNSET_CAST | (unset) | conversión de tipos
T_USE | use | espacios de nombres (disponible desde PHP 5.3.0; reservada desde PHP 4.0.0)
T_VAR | var | clases y objetos
T_VARIABLE | $foo | variables
T_WHILE | while | while, do..while
T_WHITESPACE | \t \r\n |
T_XOR_EQUAL | ^= | operadores de asignación
T_YIELD | yield | generadores (disponible desde PHP 5.5.0)

Véase también token_name().


Guía de entorno de usuario para nombres

Tabla de contenidos

  • Global Namespace
  • Reglas
  • Tips

La siguiente es una guía para saber cómo elegir el mejor nombre para los identificadores del código del entorno del usuario PHP. Cuando se eligen nombres para cualquier código que crea símbolos en el global namespace, es importante tener en cuenta los siguientes lineamientos para evitar que en futuras versiones de PHP estos choquen con los símbolos elegidos.


Global Namespace

Aquí hay una visión general de las construcciones de código que van al espacio de nombres global:

  • funciones

  • clases

  • interfaces

  • constantes (no constanstes de clase)

  • variables definidas fuera de funciones/métodos


Reglas

La siguiente lista muestra un resumen de los derechos que se reserva el proyecto PHP para sí mismo, cuando elige los nombres para los nuevos identificadores internos. La guía definitiva son los » ESTÁNDARES DE CODIFICACION oficiales:

  • PHP es el propietario de el namespace de nivel superior, pero trata de encontrar una descripción decente de nombres y evitar así futuros choques.

  • Los nombres de función usan guion bajo entre palabras, mientras que los nombres de las clases usan las reglas camelCase o PascalCase.

  • PHP antepondrá a cualquier símbolo global de una extensión el nombre de de la extensión. (En el pasado, han habido numerosas excepciones a esta regla). Ejemplos:

    • curl_close()

    • mysql_query()

    • PREG_SPLIT_DELIM_CAPTURE

    • new DOMDocument()

    • strpos() (ejemplo de un error del pasado)

    • new SplFileObject()

  • Iteradores y Excepciones son como siempre, simplemente postfijados con "Iterator" y Exception." Ejemplos:

    • ArrayIterator

    • LogicException

  • PHP se reserva todos los simbolos que comienzan con __ como magicos. Es recomendado que no se creen simbolos que comiencen con __ en PHP a menos que se quiera usar una funcionalidad magica documentada. Ejemplos:

    • __get()

    • __autoload()


Tips

Con el fin de escribir código que funcione en el futuro, se recomienda no colocar muchas variables, funciones o clases en el espacio de nombres global. Esto prevendrá de conflictos de nombres con código de terceros así como con posibles adiciones futuras al lenguaje.

Una manera común de evitar conflictos con nombres de funciones y clases es añadirlos a su propio espacio de nombres dedicado.

<?php

namespace MiProyecto;

function mi_función() {
    return true;
}

\MiProyecto\mi_función();

Esto todavía necesita que se mantenga la cuenta de los espacios de nombres ya utilizados, pero una vez que se decido el espacio de nombres que se va a usar se pueden añadir todas las funciones y clases e él sin tener que pensar más en conflictos.

Es una buena práctica limitar el número de variables añadidas al ámbito global para evitar conflictos de nombres con código de terceros.

Nota: Ámbito de variables

Debido a las reglas de ámbito de PHP, las variables definidas dentro de funciones y métodos no están en el ámbito global y, por tanto, no pueden crear conflictos con otras variables definidas en el ámbito global.


Acerca del manual

Tabla de contenidos

  • Formatos
  • Acerca de los comentarios de usuarios
  • Como interpretar la definición de una función (prototipo)
  • Versiones de PHP documentadas en este manual
  • Cómo encontrar más información sobre PHP
  • Cómo ayudar a mejorar la documentación
  • Cómo generamos los formatos
  • Traducciones


Formatos

El manual de PHP se encuentra disponible en diferentes formatos. Estos formatos se pueden dividir en dos grupos: formato accesible online y ficheros descargables.

Nota:

Algunas editoriales han publicado versiones impresas de este manual. No podemos recomendar ninguna de ellas, ya que suelen quedarse obsoletas rápidamente.

El manual puede ser leído online en » sitio web de PHP.net y en numerosos mirrors. Para un mejor funcionamiento, debería utilizar el mirror más cercano. La versión online del manual PHP tiene dos hojas de estilos CSS CSS, una para web y la otra para imprimir.

La ventaja del manual online sobre la mayoría de formatos offline es que contiene los comentarios/notas de usuarios y los » enlaces URL que pueden ser usados para llegar rápidamente hasta las partes deseadas del manual. Y obviamente, la desventaja es que se requiere estár online para ver este manual.

Existen varios formatos offline. El más apropiado para cada usuario depende del sistema operativo que use y de sus preferencias a la hora de leer. La información sobre como el manual es generado en tantos formatos diferentes se puede obtener en la sección de este apéndice titulada 'Cómo generamos los diferentes formatos' sección de su apéndice.

El formato más accesible desde diferentes plataformas es la versión HTML. Este manual se ofrece como un único fichero en HTML o como un paquete que contiene un fichero HTML por cada sección (colección de varios cientos de ficheros). Se proporcionan estas versiones de forma comprimida, por tanto, se require una utilidad para obtener los ficheros desde el archivo comprimido.

Para plataformas Windows, la versión Windows HTML Help Workshop mejora la versión del manual en HTML, al poder usar la aplicación Windows HTML Help Workshop. Esta versión proporciona: búsqueda completa de texto, índice completo y favoritos. Muchos entornos de desarrollo para PHP incorporan esta versión de la documentación para proporcionar un acceso fácil . También hay visores CHM disponibles para Linux. Dale un vistazo a » xCHM o » GnoCHM.

También está disponible la » versión extendida de CHM , la cual se actualiza menos frecuentemente, pero proporciona otras muchas opciones. Solamente funciona con Microsoft Windows debido a la tecnología utilizada para crear estas páginas de ayuda.


Acerca de los comentarios de usuarios

Los comentarios de los usuarios juegan un papel muy importante en el desarrollo de este manual. Permitir a los lectores del manual contribuir con ejemplos y aclaraciones desde su navegador, hace que podamos mejorar el manual. Y mientras los comentarios no formen parte del manual, podrán ser consultados online y también en algunos de los soportes offline.

Nota:

Los comentarios de los usuarios no son moderados antes de ser publicados online, así que la calidad de lo escrito como los ejemplos o incluso la veracidad de lo expuesto en el comentario no podrá ser garantizada. (Tampoco hay ninguna garantía de la calidad o exactitud del texto del manual).

Nota:

Por propósito de la cobertura de la licencia, los comentarios contribuidos por los usuarios son considerados partes del manual PHP, y tienen el mismo tipo de licencia que la documentación (por el momento Creative Commons Attribution) Para más información vea la página Copyright del Manual


Como interpretar la definición de una función (prototipo)

Cada función en el manual está documentada para obtener una referencia rápida. Si sabemos como leer e interpretar el manual será mucho más fácil aprender PHP. En lugar de confiar en ejemplos o copiar y pegar, todo el mundo debería saber como interpretar una definición de funciones (prototipos). Empecemos:

Nota: Prerrequisitos: Comprensión básica de los diferentes tipos

Aunque PHP es un lenguaje de programación relajado (en lo referente a los tipos de variables/valores), es importante entender, básicamente, estos diferentes tipos, ya que son importantes.

Las definiciones de funciones nos dicen que tipo de valores son valores de retorno. Usemos la definición de la función strlen() en nuestro primer ejemplo:

strlen

(PHP 4, PHP 5)
strlen -- Obtiene longitud de un string

Descripción
int strlen ( string $string )

Devuelve longitud de un string

Explicación de la definición de una función
Parte | Descripción
strlen | El nombre de la función.
(PHP 4, PHP 5) | strlen() está disponible en todas las versiones de PHP 4, PHP 5
int | Tipo de valor devuelto por esta función, en este caso un entero (ejemplo: la longitud de un string se mide en números).
( string $string ) | El primer (sólo para este caso) parámetro o argumento para esta función se llama string, y es de tipo string.

Podríamos escribir la definición de esta función de un modo genérico:

      tipo de retorno    nombre función    ( tipo de parámetro   nombre parámetro )

Muchas funciones tiene múltiples parametros, por ejemplo in_array(). Su prototipo sería:

      boleano in_array ( mixto $aguja, array $pajar [, boleano $estricto = FALSE])

¿Qué significa? in_array() devuelve un valor booleano, true si termina con éxito (Si la aguja fue encontrada en el pajar) o false en caso de error (si la aguja no fue encontrada en el pajar). El primer parámetro se llama aguja y puede ser de muchos tipos, así que lo llamamos "mixto". Este mixtoaguja (que es lo que estamos buscando) bien puede ser un valor escalar (string, integer, o float), o un array. El pajar (el array en el que buscamos) es el segundo parámetro. El tercero es un parámetro opcional y lo llamamos estricto. Todos los parámetros opcionales están entre [ paréntesis ]. El manual muestra que el parámetro estricto es por defecto booleano false. Vea la página del manual de cada función para informarse de cómo funcionan.

Además, el símbolo & (et) antepuesto a un parámetro de función permite que dicho parámetro sea pasado por referencia, como se muestra abajo:

       int preg_match ( string $pattern , string $subject [, array &$matches
      [, int $flags = 0 [, int $offset = 0 ]]] )

En este ejemplo se puede ver que el tercer parámetro opcional &$matches será pasado por referencia.

También hay funciones con información PHP mucho más compleja. Toma html_entity_decode() como ejemplo:

(PHP 4 >= 4.3.0, PHP 5)

Esto significa que esta función solo está disponible desde la versión PHP 4.3.0.


Versiones de PHP documentadas en este manual

Este manual contiene información sobre anteriores, actuales y futuras versiones de PHP. Cambios en el comportamiento están documentados como notas, changelogs y texto en las páginas del manual. La versión más antigua documentada es PHP 5.0.0.

Cuando existe documentación sobre la última versión (no lanzada) en desarrollo de PHP, será etiquetada como "disponible en Git" o "versión de desarrollo". Y si bien estos cambios se deben planificar, en casos raros pueden cambiar.

Todo el desarrollo se lleva a cabo en Git y puede ser corroborado como se describe en la página » acceso anónimo a Git.

Y para aclarar, el manual se referirá a lanzamientos generales, secundarios y específicos PHP. Tomemos PHP 5.3.1 como ejemplo, entonces el 5 hace referencia a la versión general, el 3 a la secundaria, y el 1 es el lanzamiento específico. Normalmente PHP sólo añade nuevas características a los lanzamientos generales y secundarios, y corrige bugs en los específicos. Sin embargo, Esta convención no siempre es cierta.

También tome en cuenta que el manual de PHP está escrito en presente, no en futuro, incluso para documentar características que todavía no están disponibles. La razón de esto es que el manual puede superar la prueba del tiempo, por lo que no requiere de tediosas actualizaciones gramáticas con cada lanzamiento.

Muchas veces el manual de PHP muestra "valores por defecto" para las directivas PHP. Estos valores están basados en cómo actúa PHP sin un archivo de configuración php.ini, y por tanto pueden diferir de los valores encontrados en los archivos php.ini-development y php.ini-production distribuidos. también hacen referencia a la última versión de PHP, aunque las entradas de changelog hacen mención de valores antiguos. Vea el Apéndice de directivas PHP para detalles con respecto a estos valores y sus cambios.


Cómo encontrar más información sobre PHP

Este manual no pretende dar prácticas de programación en general. Si es su primera vez o es un principiante, seguramente encontrará difícil aprender como programar con PHP usando solamente este manual. Busque mejor un libro orientado a principiantes.

Hay un gran número de listas de correo activas para discutir cualquier aspecto relacionado con la programación con PHP. Si se queda bloqueado con un problema, puede usar estas listas para obtener ayuda. Para ver las opciones de soporte, incluidas listas de correo, ver » página de soporte de PHP.net.


Cómo ayudar a mejorar la documentación

Hay tres formas en la que todo el mundo puede ayudar a mejorar esta documentación.

Si hay un error en el manual, en cualquier idioma, por favor infórmenos usando el sistema de informe de errores » https://bugs.php.net/. Clasifique el error como "Documentation Problem". Cualquier problema relacionado con la documentación, incluyendo manuales en diferentes formatos, deben ser enviados como bug.

Nota:

Por favor, no abusar del sistema de informes de errores mandando peticiones de ayuda. En su lugar, utilice las listas de correos y recursos mencionados anteriormente. » soporte de PHP.

Contribuyendo con comentarios, se pueden dar ejemplos, advertencias y aclaraciones para otros lectores. Pero por favor no utilice el sistema de informe de errores, utilice el sistema de comentarios. Para más información, vea la sección titulada 'Acerca de comentarios de los usuarios'.

También es posible enviar pull requests al » repositorio de documentación espejo en Github.

El manual de PHP es traducido a muchos otros idiomas. Si sabe inglés y otro idioma extranjero puede ayudar a mejorar el manual de PHP trabajando con el equipo de traducción. Para más información de como empezar una nueva traducción o ayudar con la traducción, por favor lea » http://doc.php.net/tutorial/.

El proyecto de la documentación de PHP también tiene un canal de IRC donde muchos de los autores se reúnen. Pase por #php.doc o irc.efnet.org y podremos discutir formas de mejorar la documentación de PHP.


Cómo generamos los formatos

Este manual está escrito en XML usando » DocBook XML DTD, y » PhD (El render [D]ocBook basado en[PH]P ) para el mantenimiento y formato.

Usamos XML como base, para generar diferentes formatos, centralizando un solo código fuente para todos los diferentes formatos del manual. Utilizamos la herramienta » PhD para crear las páginas del manual online. También usamos » Microsoft HTML Help Workshop para generar el formato de ayuda Windows HTML y por supuesto usamos PHP para crear algunas conversiones adicionales y formateado.

El manual de PHP es generado en varios idiomas y formatos, ver » https://www.php.net/docs.php para más información. El código fuente XML puede ser descargado desde Git y visualizado en » https://github.com/php/doc-en".


Traducciones

El manual de PHP no solamente está disponible en diferentes formatos, tambien se encuentra en diferentes idiomas. El manual es escrito primero en inglés y luego grupos de traductores de todo el mundo se encargan de mantener la traducción a su idioma sincronizada con la versión inglesa. Si la traducción de algún apartado del manual no ha sido realizada todavía por el equipo de traductores, este aparecerá en inglés hasta que sea traducido.

Las personas involucradas en las traducciones, utilizan el código fuente en XML disponible en » https://github.com/php/doc-en" y lo traducen a su idioma. No utilizan las versiones generadas (como HTML o texto plano) Es el sistema de generación de formatos el que se encarga de producirlos a partir de XML a formatos de lectura legibles por humanos.

Nota:

Si le interesa ayudar o participar en la traducción de la documentación a su idioma, póngase en contacto con el equipo de traducción/documentación apuntándose a la lista de correo phpdoc. Mande un mensaje vacio a » phpdoc-subscribe@lists.php.net. La dirección de la esta lista de correo es phpdoc@lists.php.net. Explique que está interesado en traducir el manual a un idioma y nos pondremos en contacto con usted. Le mandaremos información para que pueda empezar una nueva traducción o para que pase a formar parte del equipo de traducción de su idioma, si este ya existe.

Por el momento el idioma está disponible, parcialmente o no, en 10 idiomas.

Puede ser descargado desde: » https://www.php.net/docs.php.


Creative Commons Attribution 3.0

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions

  1. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.
  2. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(f) below, which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined above) for the purposes of this License.
  3. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.
  4. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.
  5. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography, topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not otherwise considered a literary or artistic work.
  6. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.
  7. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.
  8. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

  1. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
  2. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
  3. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
  4. to Distribute and Publicly Perform Adaptations.

  5. For the avoidance of doubt:

    1. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License;
    2. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor waives the exclusive right to collect such royalties for any exercise by You of the rights granted under this License; and,
    3. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via that society, from any exercise by You of the rights granted under this License.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved.

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

  1. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License. This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(b), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable, remove from the Adaptation any credit as required by Section 4(b), as requested.
  2. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute, publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with Section 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The credit required by this Section 4 (b) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.
  3. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer

UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. Termination.

  1. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
  2. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous

  1. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
  2. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
  3. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
  4. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent
  5. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
  6. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the license of any rights under applicable law.


  • « Creative Commons Attribution 3.0
  • Listado de Funciones y Métodos »
  • PHP Manual
  • Apéndices
  • Listado de índices

Listado de índices

Tabla de contenidos

  • Listado de Funciones y Métodos
  • Listado de ejemplos


Listado de Funciones y Métodos

Lista todas las funciones y métodos del manual

a b c d e f g h i j k l m n o p q r s t u v w x y z _

  • a
    • abs - Valor absoluto
    • acos - Arco coseno
    • acosh - Arco coseno hiperbólico
    • addcslashes - Escapa una cadena al estilo de C
    • addslashes - Escapa un string con barras invertidas
    • apache_child_terminate - Finaliza un proceso de Apache después de esta llamada
    • apache_getenv - Obtiene una variable del entorno subprocess_env de Apache
    • apache_get_modules - Obtiene una lista de los módulos cargados en el servidor Apache
    • apache_get_version - Obtiene la versión del servidor Apache
    • apache_lookup_uri - Realiza una petición parcial por la URI especificada y devuelve toda la información sobre ella
    • apache_note - Obtiene y establece las notas de petición de apache
    • apache_request_headers - Obtiene todas las cabeceras HTTP
    • apache_response_headers - Obtiene todas las cabeceras HTTP de respuesta
    • apache_setenv - Establece una variable subprocess_env de Apache
    • APCUIterator::current - Obtener el elemento actual
    • APCUIterator::getTotalCount - Obtiene el conteo total
    • APCUIterator::getTotalHits - Obtener resultados totales de la memoria caché
    • APCUIterator::getTotalSize - Obtiene el tamaño total del caché
    • APCUIterator::key - Obtiene la clave del iterador
    • APCUIterator::next - Mueve el puntero al siguiente elemento
    • APCUIterator::rewind - Rebobina el iterador
    • APCUIterator::valid - Comprueba si la posición actual es válida
    • APCUIterator::__construct - Construye un objeto iterador APCUIterator
    • apcu_add - Cache a new variable in the data store
    • apcu_cache_info - Recupera la información almacenada en la memoria APCu
    • apcu_cas - Actualiza un valor antiguo con un nuevo valor
    • apcu_clear_cache - Limpia el caché del APCu
    • apcu_dec - Disminuir un número almacenado
    • apcu_delete - Elimina una variable almacenada en caché
    • apcu_enabled - Si el APCu es utilizable en el entorno actual
    • apcu_entry - Atomically fetch or generate a cache entry
    • apcu_exists - Checks if entry exists
    • apcu_fetch - Fetch a stored variable from the cache
    • apcu_inc - Increase a stored number
    • apcu_key_info - Get detailed information about the cache key
    • apcu_sma_info - Retrieves APCu Shared Memory Allocation information
    • apcu_store - Cache a variable in the data store
    • AppendIterator::append - Añade un iterador
    • AppendIterator::current - Obtiene el valor actual
    • AppendIterator::getArrayIterator - Obtiene el getArrayIterator
    • AppendIterator::getInnerIterator - Obtiene el iterador interno
    • AppendIterator::getIteratorIndex - Obtiene un índice de iteradores
    • AppendIterator::key - Obtiene la clave actual
    • AppendIterator::next - Desplazarse al siguiente elemento
    • AppendIterator::rewind - Rebobina el iterador
    • AppendIterator::valid - Comprueba la validación del elemento actual
    • AppendIterator::__construct - Construye un AppendIterator
    • array - Crea un array
    • ArrayAccess::offsetExists - Comprobar si existe un índice
    • ArrayAccess::offsetGet - Offset para recuperar
    • ArrayAccess::offsetSet - Asignar un valor al índice esepecificado
    • ArrayAccess::offsetUnset - Destruye un offset
    • ArrayIterator::append - Añade un elemento
    • ArrayIterator::asort - Ordena array por sus valores
    • ArrayIterator::count - Cuenta elementos
    • ArrayIterator::current - Devuelve la entrada actual del array
    • ArrayIterator::getArrayCopy - Obtener copia de un array
    • ArrayIterator::getFlags - Obtener opciones
    • ArrayIterator::key - Devuelve la clave actual del array
    • ArrayIterator::ksort - Ordena un array por sus claves
    • ArrayIterator::natcasesort - Ordena un array de forma natural, sensible a mayúsculas
    • ArrayIterator::natsort - Ordena un array de forma natural
    • ArrayIterator::next - Desplaza a la siguiente entrada
    • ArrayIterator::offsetExists - Compruebar si el índice existe
    • ArrayIterator::offsetGet - Obtener el valor de un índice
    • ArrayIterator::offsetSet - Establece el valor para un índice
    • ArrayIterator::offsetUnset - Destruye el valor de un índice
    • ArrayIterator::rewind - Rebobinar array al inicio
    • ArrayIterator::seek - Buscar la posición
    • ArrayIterator::serialize - Serializar
    • ArrayIterator::setFlags - Definir opciones de comportamiento
    • ArrayIterator::uasort - Ordenado definido por el usuario
    • ArrayIterator::uksort - Ordenado definido por el usuario
    • ArrayIterator::unserialize - Deserializar
    • ArrayIterator::valid - Comprueba si un array contiene más entradas
    • ArrayIterator::__construct - Construye un ArrayIterator
    • ArrayObject::append - Añade un valor
    • ArrayObject::asort - Ordena las entradas por valor
    • ArrayObject::count - Obtener el número de propiedades públicas en la clase ArrayObject
    • ArrayObject::exchangeArray - Intercambia el array por otro
    • ArrayObject::getArrayCopy - Crea una copia de la clase ArrayObject
    • ArrayObject::getFlags - Obtiene las flags de comportamiento
    • ArrayObject::getIterator - Crear un nuevo iterador desde una instancia ArrayObject
    • ArrayObject::getIteratorClass - Obtiene el nombre de clase iterador para ArrayObject
    • ArrayObject::ksort - Ordena las entradas por clave
    • ArrayObject::natcasesort - Ordena un array usando un algoritmo orden natural
    • ArrayObject::natsort - Ordena entradas usando un algoritmo de orden natural
    • ArrayObject::offsetExists - Devuelve si el índice solicitado existe
    • ArrayObject::offsetGet - Devuelve el valor del índice especificado
    • ArrayObject::offsetSet - Establece el valor en el índice especificado
    • ArrayObject::offsetUnset - Destruye el valor para el índice especificado
    • ArrayObject::serialize - Serializar un ArrayObject
    • ArrayObject::setFlags - Establece las flags de comportamiento
    • ArrayObject::setIteratorClass - Establece el nombre de clase iterador para ArrayObject
    • ArrayObject::uasort - Ordena las entradas con una función de comparación definida por el usuario y mantiene asociación de claves
    • ArrayObject::uksort - Ordena las entradas por clave usando una función de comparación definida por el usuario
    • ArrayObject::unserialize - Deserializar el objeto ArrayObject
    • ArrayObject::__construct - Construir un nuevo objeto Array
    • array_change_key_case - Cambia a mayúsculas o minúsculas todas las claves en un array
    • array_chunk - Divide un array en fragmentos
    • array_column - Devuelve los valores de una sola columna del array de entrada
    • array_combine - Crea un nuevo array, usando una matriz para las claves y otra para sus valores
    • array_count_values - Cuenta todos los valores de un array
    • array_diff - Calcula la diferencia entre arrays
    • array_diff_assoc - Calcula la diferencia entre arrays con un chequeo adicional de índices
    • array_diff_key - Calcula la diferencia entre arrays empleando las claves para la comparación
    • array_diff_uassoc - Calcula la diferencia entre arrays con un chequeo adicional de índices que se realiza por una función de devolución de llamada suministrada por el usuario
    • array_diff_ukey - Calcula la diferencia entre arrays usando una función de devolución de llamada en las keys para comparación
    • array_fill - Llena un array con valores
    • array_fill_keys - Llena un array con valores, especificando las keys
    • array_filter - Filtra elementos de un array usando una función de devolución de llamada
    • array_flip - Intercambia todas las claves de un array con sus valores asociados
    • array_intersect - Calcula la intersección de arrays
    • array_intersect_assoc - Calcula la intersección de arrays con un chequeo adicional de índices
    • array_intersect_key - Calcula la intersección de arrays usando sus claves para la comparación
    • array_intersect_uassoc - Calcula la intersección de arrays con una comprobación adicional de índices, los cuales se comparan con una función de retrollamada
    • array_intersect_ukey - Calcula la intersección de arrays usando una función de devolución de llamada en las claves para la comparación
    • array_keys - Devuelve todas las claves de un array o un subconjunto de claves de un array
    • array_key_exists - Verifica si el índice o clave dada existe en el array
    • array_key_first - Obtiene la primera clave de un array
    • array_key_last - Obtiene la última clave de un array
    • array_map - Aplica la retrollamada a los elementos de los arrays dados
    • array_merge - Combina dos o más arrays
    • array_merge_recursive - Une dos o más arrays recursivamente
    • array_multisort - Ordena varios arrays, o arrays multidimensionales
    • array_pad - Rellena un array a la longitud especificada con un valor
    • array_pop - Extrae el último elemento del final del array
    • array_product - Calcula el producto de los valores de un array
    • array_push - Inserta uno o más elementos al final de un array
    • array_rand - Seleccionar una o más claves aleatorias de un array
    • array_reduce - Reduce iterativamente un array a un solo valor usando una función llamada de retorno
    • array_replace - Reemplaza los elementos del array original con elementos de array adicionales
    • array_replace_recursive - Reemplaza los elementos de los arrays pasados al primer array de forma recursiva
    • array_reverse - Devuelve un array con los elementos en orden inverso
    • array_search - Busca un valor determinado en un array y devuelve la primera clave correspondiente en caso de éxito
    • array_shift - Quita un elemento del principio del array
    • array_slice - Extraer una parte de un array
    • array_splice - Elimina una porción del array y la reemplaza con otra cosa
    • array_sum - Calcular la suma de los valores de un array
    • array_udiff - Computa la diferencia entre arrays, usando una llamada de retorno para la comparación de datos
    • array_udiff_assoc - Computa la diferencia entre arrays con una comprobación de indices adicional, compara la información mediante una función de llamada de retorno
    • array_udiff_uassoc - Computa la diferencia entre arrays con una verificación de índices adicional, compara la información y los índices mediante una función de llamada de retorno
    • array_uintersect - Computa una intersección de arrays, compara la información mediante una función de llamada de retorno
    • array_uintersect_assoc - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información mediante una función de retrollamada
    • array_uintersect_uassoc - Calcula la intersección de arrays con una comprobación de índices adicional, compara la información y los índices mediante funciones de retrollamada por separado
    • array_unique - Elimina valores duplicados de un array
    • array_unshift - Añadir al inicio de un array uno a más elementos
    • array_values - Devuelve todos los valores de un array
    • array_walk - Aplicar una función proporcionada por el usuario a cada miembro de un array
    • array_walk_recursive - Aplicar una función de usuario recursivamente a cada miembro de un array
    • arsort - Ordena un array en orden inverso y mantiene la asociación de índices
    • Aserción - Verifica si la aserción es false
    • asin - Arco seno
    • asinh - Arco seno hiperbólico
    • asort - Ordena un array y mantiene la asociación de índices
    • assert_options - Establecer/obtener valores de las directivas relacionadas con las aserciones
    • atan - Arco tangente
    • atan2 - Arco tangente de dos variables
    • atanh - Arco tangente hiperbólica
  • b
    • base64_decode - Decodifica datos codificados con MIME base64
    • base64_encode - Codifica datos con MIME base64
    • basename - Devuelve el último componente de nombre de una ruta
    • base_convert - Convertir un número entre bases arbitrarias
    • bcadd - Añade dos números de precisión arbitrária
    • bccomp - Compara dos números de precisión arbitraria
    • bcdiv - Divide dos números de precisión arbitraria
    • bcmod - Obtiene el módulo de un número de precisión arbitraria
    • bcmul - Multiplica dos números de precisión arbitraria
    • bcpow - Elevar un número de precisión arbitraria a otro
    • bcpowmod - Eleva un número de precisión arbitraria a otro, reducido por un módulo especificado
    • bcscale - Establece los parametros de scale por defecto para todas las funciones matemáticas de bc
    • bcsqrt - Obtiene la raiz cuadrada de un número de precisión arbitraria
    • bcsub - Resta un número de precisión arbitraria de otro
    • bin2hex - Convierte datos binarios en su representación hexadecimal
    • bindec - Binario a decimal
    • bindtextdomain - Establece la ruta del dominio
    • bind_textdomain_codeset - Especifica el juego de caracteres en que los mensajes del catálogo del dominio serán devueltos
    • boolval - Obtener el valor booleano de una variable
    • bson_decode - Decodifica un objecto BSON a un array PHP
    • bson_encode - Serializa una variable PHP a un string BSON
    • bzclose - Cierra un fichero bzip2
    • bzcompress - Comprime una cadena en datos codificados en bzip2
    • bzdecompress - Descomprime datos codificados con bzip2
    • bzerrno - Devuelve el número de erro de bzip2
    • bzerror - Devuelve el número de error y la cadena del error de bzip2 en un array
    • bzerrstr - Devuelve una cadena de error de bzip2
    • bzflush - Fuerza la escritura de todos los datos del búfer
    • bzopen - Abre un fichero comprimido con bzip2
    • bzread - Lectura segura de ficheros bzip2
    • bzwrite - Escribe en un fichero bzip2 de forma segura binariamente
  • c
    • CachingIterator::count - El número de elementos en el iterador
    • CachingIterator::current - Devuelve el elemento actual
    • CachingIterator::getCache - Recuperar el contenido de la caché
    • CachingIterator::getFlags - Obtener las banderas utilizadas
    • CachingIterator::getInnerIterator - Devuelve el iterador interno
    • CachingIterator::hasNext - Comprueba que el iterador interno tenga un elemento siguiente válido
    • CachingIterator::key - Devuelve la clave del elemento actual
    • CachingIterator::next - Desplaza el iterador adelante
    • CachingIterator::offsetExists - Comprobar existencia de un índice
    • CachingIterator::offsetGet - El propósito offsetGet
    • CachingIterator::offsetSet - El propósito offsetSet
    • CachingIterator::offsetUnset - El propósito offsetUnset
    • CachingIterator::rewind - Rebobina el iterador
    • CachingIterator::setFlags - El propósito de setFlags
    • CachingIterator::valid - Comprueba que el elemento actual sea válido
    • CachingIterator::__construct - Construir un nuevo objeto CachingIterator para el iterador
    • CachingIterator::__toString - Devolver la representación en formato cadena del elemento actual
    • CallbackFilterIterator::accept - Llama la llamada de retorno con el valor actual, la clave actual y el iterador interior como argumentos
    • CallbackFilterIterator::__construct - Crear un iterador filtrado desde otro iterador
    • call_user_func - Llamar a una llamada de retorno dada por el primer parámetro
    • call_user_func_array - Llamar a una llamada de retorno con un array de parámetros
    • cal_days_in_month - Devolver el número de días de un mes para un año y un calendario dados
    • cal_from_jd - Convierte de una Fecha Juliana a un calendario soportado
    • cal_info - Devuelve información sobre un calendario en particular
    • cal_to_jd - Convertir un calendario soportado a la Fecha Juliana
    • ceil - Redondear fracciones hacia arriba
    • chdir - Cambia de directorio
    • checkdate - Validar una fecha gregoriana
    • checkdnsrr - Comprueba registros DNS correspondientes a un nombre de host de Internet dado o dirección IP
    • chgrp - Cambia el grupo del archivo
    • chmod - Cambia el modo de un fichero
    • chop - Alias de rtrim
    • chown - Cambia el propietario del fichero
    • chr - Devuelve un caracter específico
    • chroot - Cambia el directorio raíz
    • chunk_split - Divide una cadena en trozos más pequeños
    • classkit_import - Importar nuevas definiciones de métodos de clase desde un archivo
    • classkit_method_add - Añade dinámicamente un nuevo método una clase dada
    • classkit_method_copy - Copia un método de una clase a otra
    • classkit_method_redefine - Cambia dinámicamente el código del método dado
    • classkit_method_remove - Elimina dinámicamente el método dado
    • classkit_method_rename - Cambia dinámicamente el nombre del método dado
    • class_alias - Crea un alias para una clase
    • class_exists - Verifica si la clase ha sido definida
    • class_implements - Devuelve las interfaces que son implementadas por la clase o interfaz dadas
    • class_parents - Devuelve las clases padre de la clase dada.
    • class_uses - Devolver los "traits" usados por la clase dada
    • clearstatcache - Limpia la caché de estado de un archivo
    • cli_get_process_title - Returns the current process title
    • cli_set_process_title - Sets the process title
    • closedir - Cierra un gestor de directorio
    • closelog - Cerrar conexión al log del sistema
    • Closure::bind - Duplicar un cierre con un objeto vinculado y ámbito de clase especificados
    • Closure::bindTo - Duplicar el cierre con un objeto vinculado y ámbito de clase nuevos
    • Closure::call - Vincula y llama al cierre
    • Closure::fromCallable - Convierte un 'callable' en un cierre
    • Closure::__construct - Constructor que anula la instanciación
    • Collator::asort - Ordenar un array manteniendo la relación de índices
    • Collator::compare - Comparar dos cadenas Unicode
    • Collator::create - Crear un cotejador
    • Collator::getAttribute - Obtener el valor de un atributo de cotejo
    • Collator::getErrorCode - Obtener el último código de error del cotejeador
    • Collator::getErrorMessage - Obtener el texto del último código de error del cotejador
    • Collator::getLocale - Obtener el nombre de la configuración regional del cotejador
    • Collator::getSortKey - Obtener la clave de ordenación de una cadena
    • Collator::getStrength - Obtener la fuerza de cotejo actual
    • Collator::setAttribute - Establecer el atributo de cotejo
    • Collator::setStrength - Establecer la fuerza (strength) de un cotejo
    • Collator::sort - Ordenar un array usando cotejador especificado
    • Collator::sortWithSortKeys - Ordenar un array usando el cotejador y las claves de ordenación especificados
    • Collator::__construct - Crear un objeto Collator
    • Collectable::isGarbage - Determinar si un objeto ha sido marcado como basura
    • Collectable::setGarbage - Marcar un objeto como basura
    • CommonMark\CQL::__construct - Constructor CQL
    • CommonMark\CQL::__invoke - CQL Execution
    • CommonMark\Interfaces\IVisitable::accept - Visitation
    • CommonMark\Interfaces\IVisitor::enter - Visitation
    • CommonMark\Interfaces\IVisitor::leave - Visitation
    • CommonMark\Node::accept - Visitation
    • CommonMark\Node::appendChild - Manipulación AST
    • CommonMark\Node::insertAfter - Manipulación AST
    • CommonMark\Node::insertBefore - Manipulación AST
    • CommonMark\Node::prependChild - Manipulación AST
    • CommonMark\Node::replace - Manipulación AST
    • CommonMark\Node::unlink - Manipulación AST
    • CommonMark\Node\BulletList::__construct - Construcción BulletList
    • CommonMark\Node\CodeBlock::__construct - Constructor CodeBlock
    • CommonMark\Node\Heading::__construct - Constructor Heading
    • CommonMark\Node\Image::__construct - Constructor Image
    • CommonMark\Node\Link::__construct - Constructor Link
    • CommonMark\Node\OrderedList::__construct - Constructor OrderedList
    • CommonMark\Node\Text::__construct - Constructor Text
    • CommonMark\Parse - Parsing
    • CommonMark\Parser::finish - Parsing
    • CommonMark\Parser::parse - Parsing
    • CommonMark\Parser::__construct - Constructor Parser
    • CommonMark\Render - Rendering
    • CommonMark\Render\HTML - Rendering
    • CommonMark\Render\Latex - Rendering
    • CommonMark\Render\Man - Rendering
    • CommonMark\Render\XML - Rendering
    • compact - Crear un array que contiene variables y sus valores
    • COMPersistHelper::GetCurFileName - Get current filename
    • COMPersistHelper::GetMaxStreamSize - Get maximum stream size
    • COMPersistHelper::InitNew - Initialize object to default state
    • COMPersistHelper::LoadFromFile - Load object from file
    • COMPersistHelper::LoadFromStream - Load object from stream
    • COMPersistHelper::SaveToFile - Save object to file
    • COMPersistHelper::SaveToStream - Save object to stream
    • COMPersistHelper::__construct - Construct a COMPersistHelper object
    • Componere\Abstract\Definition::addInterface - Añadir Interface
    • Componere\Abstract\Definition::addMethod - Añadir método
    • Componere\Abstract\Definition::addTrait - Añadir rasgo
    • Componere\Abstract\Definition::getReflector - Reflection
    • Componere\cast - Moldeado
    • Componere\cast_by_ref - Moldeado
    • Componere\Definition::addConstant - Añade constante
    • Componere\Definition::addProperty - Añade propiedad
    • Componere\Definition::getClosure - Obtener Cierre
    • Componere\Definition::getClosures - Obtener Cierres
    • Componere\Definition::isRegistered - Detección del estado
    • Componere\Definition::register - Registro
    • Componere\Definition::__construct - Constructor Definition
    • Componere\Method::getReflector - Reflection
    • Componere\Method::setPrivate - Modificación de la accesibilidad
    • Componere\Method::setProtected - Modificación de la accesibilidad
    • Componere\Method::setStatic - Modificación de la accesibilidad
    • Componere\Method::__construct - Constructor Method
    • Componere\Patch::apply - Aplicación
    • Componere\Patch::derive - Derivación del parche
    • Componere\Patch::getClosure - Obtener Cierre
    • Componere\Patch::getClosures - Obtener Cierres
    • Componere\Patch::isApplied - Detección del estado
    • Componere\Patch::revert - Reversión
    • Componere\Patch::__construct - Constructor Patch
    • Componere\Value::hasDefault - Interacción de Value
    • Componere\Value::isPrivate - Detección de accesibilidad
    • Componere\Value::isProtected - Detección de accesibilidad
    • Componere\Value::isStatic - Detección de accesibilidad
    • Componere\Value::setPrivate - Modificación de la accesibilidad
    • Componere\Value::setProtected - Modificación de la accesibilidad
    • Componere\Value::setStatic - Modificación de la accesibilidad
    • Componere\Value::__construct - Constructor Value
    • com_create_guid - Generar un identificador único globalmente (GUID)
    • com_event_sink - Conectar eventos de un objeto COM a un objeto PHP
    • com_get_active_object - Devuelve un gestor a una instancia de un objeto COM ya en ejecución
    • com_load_typelib - Carga una biblioteca de tipos
    • com_message_pump - Procesar mensajes COM, durmiendo hata timeoutms milisegundos
    • com_print_typeinfo - Imprime una definición de clase de PHP para una interfaz despachable
    • Cond::broadcast - Broadcast a Condition
    • Cond::create - Create a Condition
    • Cond::destroy - Destroy a Condition
    • Cond::signal - Signal a Condition
    • Cond::wait - Wait for Condition
    • connection_aborted - Verifica si el cliente se desconectó
    • connection_status - Devuelve el campo de bits de status de conexión
    • constant - Devuelve el valor de una constante
    • Contexto parámetros - Listado de parámetros de contexto
    • convert_cyr_string - Convierte de un juego de caracteres cirílico a otro juego de caracteres cirílico
    • convert_uudecode - Descodifica una cadena codificada mediante uuencode
    • convert_uuencode - Codificar mediante uuencode una cadena
    • copy - Copia un fichero
    • cos - Coseno
    • cosh - Coseno hiperbólico
    • count - Cuenta todos los elementos de un array o algo de un objeto
    • Countable::count - Cuenta los elementos de un objeto
    • count_chars - Devuelve información sobre los caracteres usados en una cadena
    • crc32 - Calcula el polinomio crc32 de una cadena
    • create_function - Crear una función anónima (estilo lambda)
    • crypt - Hash de cadenas de un sólo sentido
    • ctype_alnum - Chequear posibles caracteres alfanuméricos
    • ctype_alpha - Chequear posibles caracteres alfabéticos
    • ctype_cntrl - Chequear posibles caracteres de control
    • ctype_digit - Chequear posibles caracteres numéricos
    • ctype_graph - Chequear posibles caracteres imprimibles, con excepción de los espacios
    • ctype_lower - Chequear posibles caracteres en minúscula
    • ctype_print - Chequear posibles caracteres imprimibles
    • ctype_punct - Chequear posibles caracteres imprimibles que no son ni espacios en blanco ni caracteres alfanuméricos
    • ctype_space - Chequear posibles caracteres de espacio en blanco
    • ctype_upper - Chequear posibles caracteres en mayúscula
    • ctype_xdigit - Chequear posibles caracteres que representen un dígito hexadecimal
    • cubrid_affected_rows - Devolver el número de filas afectadas por la última sentencia SQL
    • cubrid_bind - Vincular variables para una sentencia preparada como parámetros
    • cubrid_client_encoding - Devuelve el actual conjunto de caracteres de la conexión a CUBRID
    • cubrid_close - Cerrar la conexión de CUBRID
    • cubrid_close_prepare - Cerrar el gestor de solicitud
    • cubrid_close_request - Cerrar el gestor de solicitud
    • cubrid_column_names - Obtener los nombres de las columnas del resultado
    • cubrid_column_types - Obtener los tipos de columnas del resultado
    • cubrid_col_get - Obtener el contenido de la columna del tipo de colecctión usando OID
    • cubrid_col_size - Obtener el número de elementos de la columna del tipo de colección usando OID
    • cubrid_commit - Consigna una transacción
    • cubrid_connect - Abrir una conexión al servidor CUBRID
    • cubrid_connect_with_url - Establecer el entorno para la conexión al servidor de CUBRID
    • cubrid_current_oid - Obtener el OID de la posición del cursor actual
    • cubrid_data_seek - Mueve el puntero interno de la fila del resultado CUBRID
    • cubrid_db_name - Obtener el nombre de la base de datos desde los resultados de cubrid_list_dbs
    • cubrid_disconnect - Cerrar una conexión a una base de datos
    • cubrid_drop - Borrar una instancia usando OID
    • cubrid_errno - Devuelve el valor numérico del mensaje de error de la operación de CUBRID previa
    • cubrid_error - Se usa para obtener el mensaje de error
    • cubrid_error_code - Obtener el código de error de la llamada a una función más reciente
    • cubrid_error_code_facility - Obtener el código de error del dispositivo
    • cubrid_error_msg - Obtener el último mensaje de error de la llamada a la función más reciente
    • cubrid_execute - Ejecutar una sentencia SQL preparada
    • cubrid_fetch - Obtener la siguiente fila de un conjunto de resultados
    • cubrid_fetch_array - Extrae una fila como array asociativo, numérico o ambos
    • cubrid_fetch_assoc - Devuelve un array asociativo que se corresponde con la fila obtenida
    • cubrid_fetch_field - Devuelve un objeto con ciertas propiedades
    • cubrid_fetch_lengths - Devuelve una matriz con las longitudes de los valores de cada campo de la fila actual
    • cubrid_fetch_object - Devuelve un objeto con los nombres de las columnas
    • cubrid_fetch_row - Devuelve un array numérico con los valores de la fila actual
    • cubrid_field_flags - Devuelve una cadena con las banderas del índice del campo dado
    • cubrid_field_len - Devuelve la longitud máxima del campo especificado
    • cubrid_field_name - Devuelve el nombre del índice del campo especificado
    • cubrid_field_seek - Mueve el cursor del conjunto de resultados al índece del campo especificado
    • cubrid_field_table - Devuelve el nombre de la tabla del campo especificado
    • cubrid_field_type - Devuelve el tipo de columna que se corresponde con el índice del campo dado
    • cubrid_free_result - Liberar la memoria ocupada por los datos del resultado
    • cubrid_get - Obtener una columna usando OID
    • cubrid_get_autocommit - Devuelve el modo auto-commit de la conexión
    • cubrid_get_charset - Devolver el conjunto de caracteres de la conexión CUBRID actual
    • cubrid_get_class_name - Obtener el nombre de la clase usando OID
    • cubrid_get_client_info - Devolver la versión de la biblioteca cliente
    • cubrid_get_db_parameter - Devuelve los parámetros de la base de datos CUBRID
    • cubrid_get_query_timeout - Obtener el valor del tiempo de espera de consulta de la petición
    • cubrid_get_server_info - Devolver la versión del servidor CUBRID
    • cubrid_insert_id - Devuelve el ID generado por la última columna actualizada AUTO_INCREMENT
    • cubrid_is_instance - Comprobar si existe la instancia apuntada por OID
    • cubrid_list_dbs - Devuelve una matriz con la lista de todas las bases de datos Cubrid existentes
    • cubrid_load_from_glo - Leer información de una instancia GLO y guardarla en un fichero
    • cubrid_lob2_bind - Vincula un objeto LOB o un string como un objeto LOB a una sentencia preparada como parámetros
    • cubrid_lob2_close - Cierra un objeto LOB
    • cubrid_lob2_export - Exporta un objeto LOB a un fichero
    • cubrid_lob2_import - Importa datos BLOB/CLOB desde un fichero
    • cubrid_lob2_new - Crea un objeto LOB
    • cubrid_lob2_read - Lee desde datos BLOB/CLOB
    • cubrid_lob2_seek - Mover el cursor de un objeto LOB
    • cubrid_lob2_seek64 - Mover el cursor de un objeto LOB
    • cubrid_lob2_size - Obtiene el tamaño de un objeto LOB
    • cubrid_lob2_size64 - Obtiene el tamaño de un objeto LOB
    • cubrid_lob2_tell - Indica la posición del cursor de un objeto LOB
    • cubrid_lob2_tell64 - Indica la posición del cursor de un objeto LOB
    • cubrid_lob2_write - Escribe en un objeto LOB
    • cubrid_lob_close - Cerrar información BLOB/CLOB
    • cubrid_lob_export - Exportar datos BLOB/CLOB a un fichero
    • cubrid_lob_get - Obtener información BLOB/CLOB
    • cubrid_lob_send - Leer información BLOB/CLOB y enviarla directamente al navegador
    • cubrid_lob_size - Obtener el tamaño de datos BLOB/CLOB
    • cubrid_lock_read - Establecer un bloqueo de lectura sobre el OID dado
    • cubrid_lock_write - Establecer un bloqueo de escritura para el OID dado
    • cubrid_move_cursor - Mover el cursor en el resultado
    • cubrid_new_glo - Crear una instancia glo
    • cubrid_next_result - Obtiene el resultado de la siguiente consulta cuando se ejecutan multiples sentencias SQL
    • cubrid_num_cols - Devolver el número de columnas del conjunto de resultados
    • cubrid_num_fields - Devuelve el número de columnas del conjunto de resultados
    • cubrid_num_rows - Obtener el número de filas del conjunto de resultados
    • cubrid_pconnect - Abrir una conexión persistente a un servidor CUBRID
    • cubrid_pconnect_with_url - Abrir una conexión persistente al servidor CUBRID
    • cubrid_ping - Hacer ping en una conexión al servidor o reconectar si no hay conexión
    • cubrid_prepare - Preparar una sentencia SQL para su ejecución
    • cubrid_put - Actualizar un atributo usando OID
    • cubrid_query - Enviar una consulta CUBRID
    • cubrid_real_escape_string - Escapar caracteres especiales en una cadena para usarla en una sentencia SQL
    • cubrid_result - Devuelve el valor de un campo específico de una fila específica
    • cubrid_rollback - Retroceder una transacción
    • cubrid_save_to_glo - Guardar el fichero solicitado en una instancia GLO
    • cubrid_schema - Obtener la información del esquema solicitado
    • cubrid_send_glo - Leer información de un glo y enviarla a la salida estándar
    • cubrid_seq_drop - Borrar un elemento de una columna tipo secuencia usando OID
    • cubrid_seq_insert - Insertar un elemento en una columna tipo secuencia usando OID
    • cubrid_seq_put - Actualizar el valor del elemento de la columna de tipo secuencia usando OID
    • cubrid_set_add - Insertar un único elemento en la columna del tipo de conjunto usando OID
    • cubrid_set_autocommit - Establece el modo de confirmación automática de la conexión
    • cubrid_set_db_parameter - Configura los parámetros de la base de datos CUBRID
    • cubrid_set_drop - Borrar un elemento de la columna del tipo de conjunto usando OID
    • cubrid_set_query_timeout - Establecer el tiempo de espera de la ejecución de consultas
    • cubrid_unbuffered_query - Realiza una consulta sin traer los resultados a memoria
    • cubrid_version - Obtener la versión del módulo de PHP de CUBRID
    • CURLFile::getFilename - Recupera el nombre de un fichero
    • CURLFile::getMimeType - Recupera el tipo MIME
    • CURLFile::getPostFilename - Recupera el nombre de fichero para POST
    • CURLFile::setMimeType - Configura el tipo MIME
    • CURLFile::setPostFilename - Establecer el nombre de fichero para POST
    • CURLFile::__construct - Crear un objeto CURLFile
    • curl_close - Cierra una sesión cURL
    • curl_copy_handle - Copia el recurso cURL junto con todas sus preferencias
    • curl_errno - Devuelve el último número de error
    • curl_error - Devuelve una cadena que contiene el último error de la sesión actual
    • curl_escape - Función URL que codifica el string dado
    • curl_exec - Establece una sesión cURL
    • curl_getinfo - Obtener información sobre una transferencia específica
    • curl_init - Inicia sesión cURL
    • curl_multi_add_handle - Añade un recurso cURL a un grupo de recursos cURL
    • curl_multi_close - Cierra un grupo de recursos cURL
    • curl_multi_errno - Devuelve el último número de error de cURL múltiple
    • curl_multi_exec - Ejecuta las sub-conexiones del recurso cURL actual
    • curl_multi_getcontent - Devuelve el contenido del recurso cURL si CURLOPT_RETURNTRANSFER está activado
    • curl_multi_info_read - Obtiene información de las transferencias en curso
    • curl_multi_init - Devuelve un nuevo multi recurso cURL
    • curl_multi_remove_handle - Elimina un multi recurso de un conjunto de recursos cURL
    • curl_multi_select - Espera actividad en cualquier conexión en curl_multi
    • curl_multi_setopt - Configura una opción para el multi gestor cURL
    • curl_multi_strerror - Devuelve un string con la descripción del código de error
    • curl_pause - Pausa y reanuda una conexión
    • curl_reset - Reinicializa todas las opciones de un gestor de sesión libcurl
    • curl_setopt - Configura una opción para una transferencia cURL
    • curl_setopt_array - Configura múltiples opciones para una transferencia cURL
    • curl_share_close - Cierra un gestor cURL compartido
    • curl_share_errno - Devuelve el último número del error compartido cURL
    • curl_share_init - Inicializar un gestor cURL compartido
    • curl_share_setopt - Configura una opción para un manejador cURL compartido
    • curl_share_strerror - Devuelve string con la descripción del codigo de error dado
    • curl_strerror - Devuelve un string que describe el código de error dado
    • curl_unescape - Descodifica un string codificado de URL
    • curl_version - Obtiene la información de la versión de cURL
    • current - Devuelve el elemento actual en un array
  • d
    • data:// - Data (RFC 2397)
    • date - Dar formato a la fecha/hora local
    • DateInterval::createFromDateString - Establece un objeto DateInterval desde las partes relativas de una cadena
    • DateInterval::format - Formatea el intervalo
    • DateInterval::__construct - Crea un nuevo objeto DateInterval
    • DatePeriod::getDateInterval - Obtener el intervalo
    • DatePeriod::getEndDate - Obtener la fecha final
    • DatePeriod::getRecurrences - Gets the number of recurrences
    • DatePeriod::getStartDate - Obtener la fecha inicial
    • DatePeriod::__construct - Crea un nuevo objeto DatePeriod
    • DateTime::add - Añade una cantidad de días, meses, años, horas, minutos y segundos a un objeto DateTime
    • DateTime::createFromFormat - Analiza una cadena con un instante según un formato especificado
    • DateTime::createFromImmutable - Returns new DateTime object encapsulating the given DateTimeImmutable object
    • DateTime::createFromInterface - Returns new DateTime object encapsulating the given DateTimeInterface object
    • DateTime::diff - Devuelve la diferencia entre dos objetos DateTime
    • DateTime::format - Devuelve la fecha formateada según el formato dado
    • DateTime::getLastErrors - Devuelve las advertencias y los errores
    • DateTime::getOffset - Devuelve el índice de la zona horaria
    • DateTime::getTimestamp - Obtiene la marca de tiempo Unix
    • DateTime::getTimezone - Develve la zona horaria relativa al objeto DateTime dado
    • DateTime::modify - Altera la marca temporal
    • DateTime::setDate - Establece la fecha
    • DateTime::setISODate - Establece la fecha ISO
    • DateTime::setTime - Establece la hora
    • DateTime::setTimestamp - Establece la fecha y la hora basándose en una marca temporal de Unix
    • DateTime::setTimezone - Establece la zona horaria para el objeto DateTime
    • DateTime::sub - Sustrae una cantidad de días, meses, años, horas, minutos y segundos de un objeto DateTime
    • DateTime::__construct - Devuelve un nuevo objeto DateTime
    • DateTime::__set_state - El gestor __set_state
    • DateTime::__wakeup - El gestor __wakeup
    • DateTimeImmutable::add - Añade una cantidad de días, meses, años, horas, minutos y segundos
    • DateTimeImmutable::createFromFormat - Devuelve un nuevo objeto DateTimeImmutable formateado según el formato especificado
    • DateTimeImmutable::createFromInterface - Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
    • DateTimeImmutable::createFromMutable - Devuelve un nuevo objeto DateTimeImmutable que encapsula el objeto DateTime dado
    • DateTimeImmutable::getLastErrors - Devuelve las advertencias y errores
    • DateTimeImmutable::modify - Crea un nuevo objeto con la marca de tiempo modificada
    • DateTimeImmutable::setDate - Establece la fecha
    • DateTimeImmutable::setISODate - Establece la fecha ISO
    • DateTimeImmutable::setTime - Establece la hora
    • DateTimeImmutable::setTimestamp - Establece la fecha y hora basadas en una marca de tiempo Unix
    • DateTimeImmutable::setTimezone - Establece la zona horaria
    • DateTimeImmutable::sub - Sustrae una cantidad de días, meses, años, horas, minutos y segundos
    • DateTimeImmutable::__construct - Devuelve un nuevo objeto DateTimeImmutable
    • DateTimeImmutable::__set_state - El gestor __set_state
    • DateTimeZone::getLocation - Devuelve la información de la ubicación para una zona horaria
    • DateTimeZone::getName - Devuelve el nombre de la zona horaria
    • DateTimeZone::getOffset - Devuelve el índice de la zona horaria de GMT
    • DateTimeZone::getTransitions - Devuelve todas las transiciones para una zona horaria
    • DateTimeZone::listAbbreviations - Devuelve una matriz asociativa que contiene el horario de verano (dst), el índice y el nombre de la zona horaria
    • DateTimeZone::listIdentifiers - Devuelve un array indexado numéricamente que contiene todos los identificadores de zonas horarias definidos
    • DateTimeZone::__construct - Crea un nuevo objeto DateTimeZone
    • date_add - Alias de DateTime::add
    • date_create - Alias de DateTime::__construct
    • date_create_from_format - Alias de DateTime::createFromFormat
    • date_create_immutable - Alias de DateTimeImmutable::__construct
    • date_create_immutable_from_format - Alias de DateTimeImmutable::createFromFormat
    • date_date_set - Alias de DateTime::setDate
    • date_default_timezone_get - Obtiene la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
    • date_default_timezone_set - Establece la zona horaria predeterminada usada por todas las funciones de fecha/hora en un script
    • date_diff - Alias de DateTime::diff
    • date_format - Alias de DateTime::format
    • date_get_last_errors - Alias de DateTime::getLastErrors
    • date_interval_create_from_date_string - Alias de DateInterval::createFromDateString
    • date_interval_format - Alias de DateInterval::format
    • date_isodate_set - Alias de DateTime::setISODate
    • date_modify - Alias de DateTime::modify
    • date_offset_get - Alias de DateTime::getOffset
    • date_parse - Devuelve un array asociativo con información detallada acerca de una fecha dada
    • date_parse_from_format - Obtiene información de una fecha dada formateada de acuerdo al formato especificado
    • date_sub - Alias de DateTime::sub
    • date_sunrise - Devuelve la hora de la salida del sol de un día y ubicación dados
    • date_sunset - Devuelve la hora de la puesta de sol de un día y ubicación dados
    • date_sun_info - Devuelve una matriz con información sobre la puesta/salida del sol y el comienzo/final del crepúsculo
    • date_timestamp_get - Alias de DateTime::getTimestamp
    • date_timestamp_set - Alias de DateTime::setTimestamp
    • date_timezone_get - Alias de DateTime::getTimezone
    • date_timezone_set - Alias de DateTime::setTimezone
    • date_time_set - Alias de DateTime::setTime
    • db2_autocommit - Devuelve o establece el estado de AUTOCOMMIT en una conexión de bases de datos
    • db2_bind_param - Vincula una variable PHP a un parámetro de una sentencia SQL
    • db2_client_info - Devuelve un objeto cuyas propiedades describen cliente de una base de datos DB2
    • db2_close - Cierra una conexión a base de datos
    • db2_columns - Devuelve los campos de una tabla y sus metadatos asociados.
    • db2_column_privileges - Obtiene la lista de columnas y permisos asociados a una tabla
    • db2_commit - Confirmar una transacción
    • db2_connect - Devolver una conexión a la base de datos
    • db2_conn_error - Devolver una cadena que contenga el valor SQLSTATE devuelto por el último intento de conexión.
    • db2_conn_errormsg - Devolver el último mensaje de error de la conexión y su valor SQLCODE
    • db2_cursor_type - Determinar el tipo de cursor utilizado en una consulta
    • db2_escape_string - Escapar ciertos caracteres especiales
    • db2_exec - Ejecutar directamente una sentencia SQL
    • db2_execute - Ejecutar una sentencia SQL preparada
    • db2_fetch_array - Devolver un arreglo, indexado por la posición de las columnas, que represanta una fila de un bloque de resultados
    • db2_fetch_assoc - Devolver un arreglo, indexado por el nombre de las columnas, representando una fila del bloque de resultados
    • db2_fetch_both - Devolver un arreglo, indexado por el nombre y por la posición de la columna, representando una fila de un bloque de resultados
    • db2_fetch_object - Devolver un objeto con atributos que representan a las columnas de una fila extraida
    • db2_fetch_row - Establecer el apuntador de los resultados hacia la siguiente fila o a la fila solicitada
    • db2_field_display_size - Devolver el número máximo de bytes requeridos para mostrar una columna
    • db2_field_name - Devolver el nombre de la columna indicada del resultado
    • db2_field_num - Devolver la posición de la columna indicada en un resultado
    • db2_field_precision - Devolver la precisión de la columna indicada en el resultado
    • db2_field_scale - Devolver la escala de la columna indicada en el resultado
    • db2_field_type - Devolver el tipo de dato de la columna indicada en un resultado
    • db2_field_width - Devolver el tamaño del valor contenido en la columna indicada
    • db2_foreign_keys - Devolver un resultado que contenga las llaves foraneas de una tabla
    • db2_free_result - Liberar los recursos asociados con un resultado
    • db2_free_stmt - Liberar un recurso indicado
    • db2_get_option - Devolver el valor de la opción correpondiente a una conexión o sentencia
    • db2_last_insert_id - Devolver el ID autogenerado el la última sentencia INSERT ejecutada correctamente en la conexión
    • db2_lob_read - Obtener un segmento, de tamaño definido por el usuario, de un archivo LOB
    • db2_next_result - Solicitar el siguiente resultado de un procedimiento almacendo
    • db2_num_fields - Devolver el número de campos que contiene un resultado
    • db2_num_rows - Devolver el número de filas afectadas por una sentencia SQL
    • db2_pclose - Cerrar una conexión persistente a la base de datos
    • db2_pconnect - Devolver una conexión persistente a la base de datos
    • db2_prepare - Prepara un comando SQL para su ejecución
    • db2_primary_keys - Devolver un resultado con las llaves primarias de una tabla
    • db2_procedures - Devolver un resultado con los procedimientos almacenados registrados en la base de datos
    • db2_procedure_columns - Devolver un resultado con los parámetros de los procedimientos almacenados
    • db2_result - Devolver una columna específica del resultado
    • db2_rollback - Cancelar una transacción
    • db2_server_info - Returns an object with properties that describe the DB2 database server
    • db2_set_option - Set options for connection or statement resources
    • db2_special_columns - Returns a result set listing the unique row identifier columns for a table
    • db2_statistics - Returns a result set listing the index and statistics for a table
    • db2_stmt_error - Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg - Returns a string containing the last SQL statement error message
    • db2_tables - Returns a result set listing the tables and associated metadata in a database
    • db2_table_privileges - Returns a result set listing the tables and associated privileges in a database
    • dbase_add_record - Añade un registro a una base de datos
    • dbase_close - Cierra una base de datos
    • dbase_create - Crea una base de datos
    • dbase_delete_record - Borra un registro de una base de datos
    • dbase_get_header_info - Obtiene la información de cabecera de una base de datos
    • dbase_get_record - Obtiene un registro de una base de datos como una matriz indexada
    • dbase_get_record_with_names - Obtiene un registro de una base de datos como una matriz asociativa
    • dbase_numfields - Obtiene el número de campos de una base de datos
    • dbase_numrecords - Obtener el número de registros de una base de datos
    • dbase_open - Abre una base de datos
    • dbase_pack - Empaquetar una base de datos
    • dbase_replace_record - Reemplaza un registro en una base de datos
    • dba_close - Cerrar una base de datos DBA
    • dba_delete - Elimina una entrada DBA especificada por clave
    • dba_exists - Verificar si la clave existe
    • dba_fetch - Recuperar datos especificados por clave
    • dba_firstkey - Recuperar la primera clave
    • dba_handlers - Listar todos los gestores disponibles
    • dba_insert - Insertar entrada
    • dba_key_split - Separa una clave en representación de cadena en representación de array
    • dba_list - Listar todos los archivos de base de datos abiertos
    • dba_nextkey - Recuperar la siguiente clave
    • dba_open - Abrir una base de datos
    • dba_optimize - Optimizar base de datos
    • dba_popen - Abrir una base de datos de forma persistente
    • dba_replace - Reemplazar o insertar una entrada
    • dba_sync - Sincronizar base de datos
    • dbplus_add - Añade una tupla a una relación
    • dbplus_aql - Realizar una consulta AQL
    • dbplus_chdir - Obtener/Estabecer el directorio virtual actual de la base de datos
    • dbplus_close - Cierra una relación
    • dbplus_curr - Get current tuple from relation
    • dbplus_errcode - Obtener la cadena de error de un código de error dado o del último error
    • dbplus_errno - Obtener el código de error de la última operación
    • dbplus_find - Establecer una restricción en una relación
    • dbplus_first - Obtener la primera tupla de una relación
    • dbplus_flush - Vuelca todos los cambios hechos en una relación
    • dbplus_freealllocks - Liberar todos los bloqueos mantenidos por este cliente
    • dbplus_freelock - Libera el bloqueo de escritura en una tupla
    • dbplus_freerlocks - Liberar todos los bloqueos de una relación dada
    • dbplus_getlock - Obtener un bloqueo de escritura en una tupla
    • dbplus_getunique - Obtener un único número de identificación para una relación
    • dbplus_info - Obtener información sobre una relación
    • dbplus_last - Obtener la última tupla de una relación
    • dbplus_lockrel - Solictar un bloqueo de escritura en una relación
    • dbplus_next - Obtener la siguiente tupla de una relación
    • dbplus_open - Abre un archivo de relación
    • dbplus_prev - Obtener la tupla previa de una relación
    • dbplus_rchperm - Cambiar los permisos de una relación
    • dbplus_rcreate - Crea una nueva relación de DB++
    • dbplus_rcrtexact - Crea una copia exacta pero vacía de una relación incluyendo los índices
    • dbplus_rcrtlike - Crea una copia vacía de una relación con los índeces predeterminados
    • dbplus_resolve - Resuelve la información del host de la relación
    • dbplus_restorepos - Restablece la posición
    • dbplus_rkeys - Especificar una nueva clave primaria para un relaición
    • dbplus_ropen - Abrir un archivo local de relación
    • dbplus_rquery - Realizar una consulta AQL local (en bruto)
    • dbplus_rrename - Renombrar una relación
    • dbplus_rsecindex - Crear un nuevo índice secundario para una relación
    • dbplus_runlink - Eliminar una relación del sistema de archivos
    • dbplus_rzap - Eliminar todas las tuplas de una relación
    • dbplus_savepos - Guardar la posición
    • dbplus_setindex - Establecer el índice
    • dbplus_setindexbynumber - Establecer el índice por número
    • dbplus_sql - Realiza una consulta SQL
    • dbplus_tcl - Ejecutar código TCL en el lado del servidor
    • dbplus_tremove - Eliminar una tupla y devolver la nueva tupla actual
    • dbplus_undo - Deshacer
    • dbplus_undoprepare - Preparara deshacer
    • dbplus_unlockrel - Liberar un bloqueo de escritura en una relación
    • dbplus_unselect - Eliminar una restricción de una relación
    • dbplus_update - Actualizar la tupla especificada en la relación
    • dbplus_xlockrel - Solicitar un bloqueo exclusivo de una relación
    • dbplus_xunlockrel - Liberar un bloqueo exclusivo en una relación
    • dcgettext - Sobrescribe el dominio de la búsqueda única del mensaje
    • dcngettext - Versión plural de dcgettext
    • debug_backtrace - Genera un rastreo
    • debug_print_backtrace - Muestra un rastreo
    • debug_zval_dump - Vuelca a la salida una cadena con la representación de un valor interno de zend
    • decbin - Decimal a binario
    • dechex - Decimal a hexadecimal
    • decoct - Decimal a octal
    • define - Define una constante con nombre
    • defined - Comprueba si existe una constante con nombre dada
    • deflate_add - Incrementally deflate data
    • deflate_init - Initialize an incremental deflate context
    • deg2rad - Convierte el número en grados a su equivalente en radianes
    • delete - Véase unlink o unset
    • dgettext - Sobrescribe el dominio actual
    • die - Equivalente a exit
    • dio_close - Cierra el descriptor de fichero fd
    • dio_fcntl - Lleva a cabo la función fcntl de la biblioteca C en el fichero fd
    • dio_open - Abre (crea si fuera necesario) un fichero a un nivel más bajo que el permitido por flujos de entrada y salida de las bibliotecas en C
    • dio_read - Leer bytes de un descriptor de fichero
    • dio_seek - Salta a una posición del descriptor de fichero desde donde proceda
    • dio_stat - Consulta información de estado del descriptor de fichero fd
    • dio_tcsetattr - Establece los atributos terminales y la tasa de baudios del puerto serie
    • dio_truncate - Trunca un descriptor de fichero fd a un determinado número de bytes
    • dio_write - Escribe datos en el descriptor de fichero con un truncado opcional
    • dir - Devuelve una instancia de la clase Directory
    • Directory::close - Cierra un gestor de directorio
    • Directory::read - Lee una entrada desde el controlador de directorio
    • Directory::rewind - Rebobina el manejador de directorio
    • DirectoryIterator::current - Devuelve el elemento actual del DirectoryIterator
    • DirectoryIterator::getATime - Obtener el último acceso del elemento actual DirectoryIterator
    • DirectoryIterator::getBasename - Obtener el nombre base del elemento actual DirectoryIterator
    • DirectoryIterator::getCTime - Obtiene el cambio de tiempo del inodo para el elemento actual DirectoryIterator
    • DirectoryIterator::getExtension - Obtiene la extensión de un fichero
    • DirectoryIterator::getFilename - Devuelve el nombre del fichero del elemento actual DirectoryIterator
    • DirectoryIterator::getGroup - Obtiene el grupo para el elemento actual DirectoryIterator
    • DirectoryIterator::getInode - Obtiene el inodo para el elemento actual DirectoryIterator
    • DirectoryIterator::getMTime - Obtiene la última modificación para el elemento actual DirectoryIterator
    • DirectoryIterator::getOwner - Obtiene el dueño del elemento actual DirectoryIterator
    • DirectoryIterator::getPath - Obtiene la ruta del elemento iterador actual sin nombre de fichero
    • DirectoryIterator::getPathname - Devuelve la ruta y nombre de fichero del elemento actual DirectoryIterator
    • DirectoryIterator::getPerms - Obtiene los permisos del elemento actual DirectoryIterator
    • DirectoryIterator::getSize - obtiene el tamaño de el elemento actual DirectoryIterator
    • DirectoryIterator::getType - Determina el tipo del elemento actual DirectoryIterator
    • DirectoryIterator::isDir - Determina si el elemento actual DirectoryIterator es un directorio
    • DirectoryIterator::isDot - Determina si el elemento actual DirectoryIterator es '.' o '..'
    • DirectoryIterator::isExecutable - Determina si el emento actual DirectoryIterator es ejecutable
    • DirectoryIterator::isFile - Determina si el elemento actual DirectoryIterator es un fichero
    • DirectoryIterator::isLink - Determina si el elemento actual DirectoryIterator es un enlace simbólico
    • DirectoryIterator::isReadable - Determina si el elemento actual DirectoryIterator puede ser leído
    • DirectoryIterator::isWritable - Determina si el elemento actual DirectoryIterator se puede escribir
    • DirectoryIterator::key - Devuelve la clave del elemento actual DirectoryIterator
    • DirectoryIterator::next - Avanza al siguiente elemento DirectoryIterator
    • DirectoryIterator::rewind - Robobina DirectoryIterator hasta volver al inicio
    • DirectoryIterator::seek - Mueve el apuntador interno del elemento DirectoryIterator
    • DirectoryIterator::valid - Comprueba si la actual posición de DirectoryIterator es un fichero válido
    • DirectoryIterator::__construct - Construye un iterador nuevo directorio de una ruta
    • DirectoryIterator::__toString - Obtiene el nombre del fichero como un string
    • dirname - Devuelve la ruta de un directorio padre
    • diskfreespace - Alias de disk_free_space
    • disk_free_space - Devuelve el espacio disponible de un sistema de archivos o partición de disco
    • disk_total_space - Devuelve el tamaño total de un sistema de archivos o partición de disco
    • dl - Carga una extensión de PHP durante la ejecución
    • dngettext - Versión plural de dgettext
    • dns_check_record - Alias de checkdnsrr
    • dns_get_mx - Alias de getmxrr
    • dns_get_record - Fetch DNS Resource Records associated with a hostname
    • DOMAttr::isId - Verifica si un atributo es un ID definido.
    • DOMAttr::__construct - Crea un nuevo objeto DOMAttr
    • DOMCdataSection::__construct - Construye un nuevo objeto DOMCdataSection
    • DOMCharacterData::appendData - Añade el string de caracteres al final de los datos de carácter del nodo.
    • DOMCharacterData::deleteData - Eliminar una serie de caracteres del nodo
    • DOMCharacterData::insertData - Inserta un string en la posición de 16-bit especificada
    • DOMCharacterData::replaceData - Reemplaza un substring dentro de un nodo DOMCharacterData
    • DOMCharacterData::substringData - Extrae una serie de datos del nodo
    • DOMComment::__construct - Crea un nuevo objeto DOMComment
    • DOMDocument::createAttribute - Crear nuevo attribute
    • DOMDocument::createAttributeNS - Crea un nuevo nodo atributo con un namespace asociado.
    • DOMDocument::createCDATASection - Crea un nuevo nodo cdata
    • DOMDocument::createComment - Crea un nuevo nodo de comentario
    • DOMDocument::createDocumentFragment - Crea un nuevo fragmento de documento
    • DOMDocument::createElement - Crea un nuevo nodo elemento
    • DOMDocument::createElementNS - Crea un nuevo nodo elemento con el nombre de espacio asociado
    • DOMDocument::createEntityReference - Create new entity reference node
    • DOMDocument::createProcessingInstruction - Crea un nuevo nodo PI
    • DOMDocument::createTextNode - Crea un nuevo nodo de texto
    • DOMDocument::getElementById - Busca un elemento con cierto id
    • DOMDocument::getElementsByTagName - Busca todos los elementos con el nombre de etiqueta local dado
    • DOMDocument::getElementsByTagNameNS - Busca todos los elementos con el nombre de etiqueta dado en el espacio de nombre especificado.
    • DOMDocument::importNode - Importa un nodo dentro del documento actual
    • DOMDocument::load - Cargar un documento XML de un archivo.
    • DOMDocument::loadHTML - Cargar HTML de una cadena
    • DOMDocument::loadHTMLFile - Cargar HTML desde un fichero
    • DOMDocument::loadXML - Cargar XML desde una cadena
    • DOMDocument::normalizeDocument - Normaliza el documento
    • DOMDocument::registerNodeClass - Registra una clase extendida usada para crear tipos de nodos base
    • DOMDocument::relaxNGValidate - Realiza una validación relaxNG del documento
    • DOMDocument::relaxNGValidateSource - Realiza una validación relaxNG del documento
    • DOMDocument::save - Copia el árbol XML interno a un archivo
    • DOMDocument::saveHTML - Copia el documento interno a una cadena usando el formato HTML
    • DOMDocument::saveHTMLFile - Copia el documento interno a un fichero usando el formato HTML
    • DOMDocument::saveXML - Copia el arbol XML interno a un string
    • DOMDocument::schemaValidate - Valida un documento basado en un esquema
    • DOMDocument::schemaValidateSource - Valida un documento basado en un esquema
    • DOMDocument::validate - Valida el documento basado en su DTD
    • DOMDocument::xinclude - Sustituye XIncludes en un objeto DOMDocument
    • DOMDocument::__construct - Crea un nuevo objeto DOMDocument
    • DOMDocumentFragment::appendXML - Añade información XML sin formato
    • DOMElement::getAttribute - Devuelve el valor de un atributo
    • DOMElement::getAttributeNode - Devuelve el nodo de un atributo
    • DOMElement::getAttributeNodeNS - Devuelve el nodo de un atributo
    • DOMElement::getAttributeNS - Devuelve el valor de un atributo
    • DOMElement::getElementsByTagName - Obtiene los elementos por nombre de etiqueta
    • DOMElement::getElementsByTagNameNS - Obtener los elementos por la URI del espacio de nombres y el nombre local
    • DOMElement::hasAttribute - Comprueba si existe un atributo
    • DOMElement::hasAttributeNS - Comprueba si un atributo existe
    • DOMElement::removeAttribute - Elimina un atributo
    • DOMElement::removeAttributeNode - Elimina un atributo
    • DOMElement::removeAttributeNS - Elimina un atributo
    • DOMElement::setAttribute - Añade un nuevo atributo
    • DOMElement::setAttributeNode - Añade un nuevo nodo de atributo al elemento
    • DOMElement::setAttributeNodeNS - Aña de un nuevo nodo de atributo al elemento
    • DOMElement::setAttributeNS - Añade un nuevo atributo
    • DOMElement::setIdAttribute - Declara el atributo especificado por su nombre como de tipo ID
    • DOMElement::setIdAttributeNode - Declara el atributo especificado por su nodo como de tipo ID
    • DOMElement::setIdAttributeNS - Declara el atributo especificado por su nombre local y su URI del espacio de nombres como de tipo ID
    • DOMElement::__construct - Crea un nuevo objeto DOMElement
    • DOMEntityReference::__construct - Crea un nuevo objeto DOMEntityReference
    • DOMImplementation::createDocument - Crea un objeto DOMDocument del tipo especificado con su elemento documento
    • DOMImplementation::createDocumentType - Crear un objeto DOMDocumentType vacío
    • DOMImplementation::hasFeature - Comprueba si la implementación de DOM implementa una característica específica
    • DOMImplementation::__construct - Crea un nuevo objeto DOMImplementation
    • DOMNamedNodeMap::count - Get number of nodes in the map
    • DOMNamedNodeMap::getNamedItem - Recupera un nodo especificado por su nombre
    • DOMNamedNodeMap::getNamedItemNS - Recupera un nodo especificado por el nombre local y la URI del espacio de nombres
    • DOMNamedNodeMap::item - Recupera un nodo especificado por su índice
    • DOMNode::appendChild - Añade un nuevo hijo al final de los hijos
    • DOMNode::C14N - Canonizar nodos a una cadena
    • DOMNode::C14NFile - Canonizar nodos a un fichero
    • DOMNode::cloneNode - Clona un nodo
    • DOMNode::getLineNo - Obtener el número de línea de un nodo
    • DOMNode::getNodePath - Obtener un XPath de un nodo
    • DOMNode::hasAttributes - Comprueba si un nodo tiene atributos
    • DOMNode::hasChildNodes - Comprueba si el nodo tiene hijos
    • DOMNode::insertBefore - Añade un nuevo hijo antes del nodo de referencia
    • DOMNode::isDefaultNamespace - Comprueba si la URI del espacio de nombres especificada es el espacio de nombres predeterminado
    • DOMNode::isSameNode - Indica si dos nodos son el mismo nodo
    • DOMNode::isSupported - Comprueba si una característica está soportada para la versión especificada
    • DOMNode::lookupNamespaceUri - Obtiene la URI del espacio de nombres del nodo basado en el prefijo
    • DOMNode::lookupPrefix - Obtiene el prefijo del espacio de nombres del nodo basándoes en la URI del espacio de nombres
    • DOMNode::normalize - Normaliza el nodo
    • DOMNode::removeChild - Elimina un hijo de la lista de hijos.
    • DOMNode::replaceChild - Reemplaza un hijo
    • DOMNodeList::count - Obtiene el número de nodos en la lista
    • DOMNodeList::item - Recupera un nodo especificado por un índice
    • DOMProcessingInstruction::__construct - Crea un nuevo objeto DOMProcessingInstruction
    • DOMText::isElementContentWhitespace - Devuelve si este nodo de texto contiene espacios en blanco en el contenido del elemento
    • DOMText::isWhitespaceInElementContent - Indica si este nodo de texto contiene espacios en blanco
    • DOMText::splitText - Rompe este nodo en dos nodos en el índice especificado
    • DOMText::__construct - Crea un nuevo objeto DOMText
    • DOMXPath::evaluate - Evalúa la expresión XPath dada y devuelve un resultado escrito si es posible
    • DOMXPath::query - Evalúa la expresión XPath dada
    • DOMXPath::registerNamespace - Registra el espacio de nombres con el objeto DOMXPath
    • DOMXPath::registerPhpFunctions - Registra funciones de PHP como funciones XPath
    • DOMXPath::__construct - Crea un nuevo objeto DOMXPath
    • dom_import_simplexml - Obtiene un objeto DOMElement desde un objeto SimpleXMLElement
    • doubleval - Alias de floatval
    • DSN de PDO_CUBRID - Conectar con bases de datos de CUBRID
    • DSN de PDO_IBM - Conectarse a bases de datos de IBM
    • DSN de PDO_INFORMIX - Conectarse a bases de datos de Informix
    • DSN de PDO_OCI - Conectar a bases de datos de Oracle
    • DSN de PDO_ODBC - Conectarse a bases de datos de ODBC o de DB2
    • DSN de PDO_SQLSRV - Conectar a bases de datos de MS SQL Server y de SQL Azure
    • Ds\Collection::clear - Removes all values
    • Ds\Collection::copy - Returns a shallow copy of the collection
    • Ds\Collection::isEmpty - Returns whether the collection is empty
    • Ds\Collection::toArray - Converts the collection to an array
    • Ds\Deque::allocate - Allocates enough memory for a required capacity
    • Ds\Deque::apply - Updates all values by applying a callback function to each value
    • Ds\Deque::capacity - Returns the current capacity
    • Ds\Deque::clear - Removes all values from the deque
    • Ds\Deque::contains - Determines if the deque contains given values
    • Ds\Deque::copy - Returns a shallow copy of the deque
    • Ds\Deque::count - Returns the number of values in the collection
    • Ds\Deque::filter - Creates a new deque using a callable to determine which values to include
    • Ds\Deque::find - Attempts to find a value's index
    • Ds\Deque::first - Returns the first value in the deque
    • Ds\Deque::get - Returns the value at a given index
    • Ds\Deque::insert - Inserts values at a given index
    • Ds\Deque::isEmpty - Returns whether the deque is empty
    • Ds\Deque::join - Joins all values together as a string
    • Ds\Deque::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Deque::last - Returns the last value
    • Ds\Deque::map - Returns the result of applying a callback to each value
    • Ds\Deque::merge - Returns the result of adding all given values to the deque
    • Ds\Deque::pop - Removes and returns the last value
    • Ds\Deque::push - Adds values to the end of the deque
    • Ds\Deque::reduce - Reduces the deque to a single value using a callback function
    • Ds\Deque::remove - Removes and returns a value by index
    • Ds\Deque::reverse - Reverses the deque in-place
    • Ds\Deque::reversed - Returns a reversed copy
    • Ds\Deque::rotate - Rotates the deque by a given number of rotations
    • Ds\Deque::set - Updates a value at a given index
    • Ds\Deque::shift - Removes and returns the first value
    • Ds\Deque::slice - Returns a sub-deque of a given range
    • Ds\Deque::sort - Sorts the deque in-place
    • Ds\Deque::sorted - Returns a sorted copy
    • Ds\Deque::sum - Returns the sum of all values in the deque
    • Ds\Deque::toArray - Converts the deque to an array
    • Ds\Deque::unshift - Adds values to the front of the deque
    • Ds\Deque::__construct - Creates a new instance
    • Ds\Hashable::equals - Determines whether an object is equal to the current instance
    • Ds\Hashable::hash - Returns a scalar value to be used as a hash value
    • Ds\Map::allocate - Allocates enough memory for a required capacity
    • Ds\Map::apply - Updates all values by applying a callback function to each value
    • Ds\Map::capacity - Returns the current capacity
    • Ds\Map::clear - Removes all values
    • Ds\Map::copy - Returns a shallow copy of the map
    • Ds\Map::count - Returns the number of values in the map
    • Ds\Map::diff - Creates a new map using keys that aren't in another map
    • Ds\Map::filter - Creates a new map using a callable to determine which pairs to include
    • Ds\Map::first - Returns the first pair in the map
    • Ds\Map::get - Returns the value for a given key
    • Ds\Map::hasKey - Determines whether the map contains a given key
    • Ds\Map::hasValue - Determines whether the map contains a given value
    • Ds\Map::intersect - Creates a new map by intersecting keys with another map
    • Ds\Map::isEmpty - Returns whether the map is empty
    • Ds\Map::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Map::keys - Returns a set of the map's keys
    • Ds\Map::ksort - Sorts the map in-place by key
    • Ds\Map::ksorted - Returns a copy, sorted by key
    • Ds\Map::last - Returns the last pair of the map
    • Ds\Map::map - Returns the result of applying a callback to each value
    • Ds\Map::merge - Returns the result of adding all given associations
    • Ds\Map::pairs - Returns a sequence containing all the pairs of the map
    • Ds\Map::put - Associates a key with a value
    • Ds\Map::putAll - Associates all key-value pairs of a traversable object or array
    • Ds\Map::reduce - Reduces the map to a single value using a callback function
    • Ds\Map::remove - Removes and returns a value by key
    • Ds\Map::reverse - Reverses the map in-place
    • Ds\Map::reversed - Returns a reversed copy
    • Ds\Map::skip - Returns the pair at a given positional index
    • Ds\Map::slice - Returns a subset of the map defined by a starting index and length
    • Ds\Map::sort - Sorts the map in-place by value
    • Ds\Map::sorted - Returns a copy, sorted by value
    • Ds\Map::sum - Returns the sum of all values in the map
    • Ds\Map::toArray - Converts the map to an array
    • Ds\Map::union - Creates a new map using values from the current instance and another map
    • Ds\Map::values - Returns a sequence of the map's values
    • Ds\Map::xor - Creates a new map using keys of either the current instance or of another map, but not of both
    • Ds\Map::__construct - Creates a new instance
    • Ds\Pair::clear - Removes all values
    • Ds\Pair::copy - Returns a shallow copy of the pair
    • Ds\Pair::isEmpty - Returns whether the pair is empty
    • Ds\Pair::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Pair::toArray - Converts the pair to an array
    • Ds\Pair::__construct - Creates a new instance
    • Ds\PriorityQueue::allocate - Allocates enough memory for a required capacity
    • Ds\PriorityQueue::capacity - Returns the current capacity
    • Ds\PriorityQueue::clear - Removes all values
    • Ds\PriorityQueue::copy - Returns a shallow copy of the queue
    • Ds\PriorityQueue::count - Returns the number of values in the queue
    • Ds\PriorityQueue::isEmpty - Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\PriorityQueue::peek - Returns the value at the front of the queue
    • Ds\PriorityQueue::pop - Removes and returns the value with the highest priority
    • Ds\PriorityQueue::push - Pushes values into the queue
    • Ds\PriorityQueue::toArray - Converts the queue to an array
    • Ds\PriorityQueue::__construct - Creates a new instance
    • Ds\Queue::allocate - Allocates enough memory for a required capacity
    • Ds\Queue::capacity - Returns the current capacity
    • Ds\Queue::clear - Removes all values
    • Ds\Queue::copy - Returns a shallow copy of the queue
    • Ds\Queue::count - Returns the number of values in the queue
    • Ds\Queue::isEmpty - Returns whether the queue is empty
    • Ds\Queue::jsonSerialize - Regresa una representacion que puede ser convertida a JSON
    • Ds\Queue::peek - Returns the value at the front of the queue
    • Ds\Queue::pop - Removes and returns the value at the front of the queue
    • Ds\Queue::push - Añade un elemento a la cola
    • Ds\Queue::toArray - Convierte la cola en un array
    • Ds\Queue::__construct - Creates a new instance
    • Ds\Sequence::allocate - Allocates enough memory for a required capacity
    • Ds\Sequence::apply - Updates all values by applying a callback function to each value
    • Ds\Sequence::capacity - Returns the current capacity
    • Ds\Sequence::contains - Determines if the sequence contains given values
    • Ds\Sequence::filter - Creates a new sequence using a callable to determine which values to include
    • Ds\Sequence::find - Attempts to find a value's index
    • Ds\Sequence::first - Returns the first value in the sequence
    • Ds\Sequence::get - Returns the value at a given index
    • Ds\Sequence::insert - Inserts values at a given index
    • Ds\Sequence::join - Joins all values together as a string
    • Ds\Sequence::last - Returns the last value
    • Ds\Sequence::map - Returns the result of applying a callback to each value
    • Ds\Sequence::merge - Returns the result of adding all given values to the sequence
    • Ds\Sequence::pop - Removes and returns the last value
    • Ds\Sequence::push - Adds values to the end of the sequence
    • Ds\Sequence::reduce - Reduces the sequence to a single value using a callback function
    • Ds\Sequence::remove - Removes and returns a value by index
    • Ds\Sequence::reverse - Reverses the sequence in-place
    • Ds\Sequence::reversed - Returns a reversed copy
    • Ds\Sequence::rotate - Rotates the sequence by a given number of rotations
    • Ds\Sequence::set - Updates a value at a given index
    • Ds\Sequence::shift - Removes and returns the first value
    • Ds\Sequence::slice - Returns a sub-sequence of a given range
    • Ds\Sequence::sort - Sorts the sequence in-place
    • Ds\Sequence::sorted - Returns a sorted copy
    • Ds\Sequence::sum - Returns the sum of all values in the sequence
    • Ds\Sequence::unshift - Adds values to the front of the sequence
    • Ds\Set::add - Adds values to the set
    • Ds\Set::allocate - Allocates enough memory for a required capacity
    • Ds\Set::capacity - Returns the current capacity
    • Ds\Set::clear - Removes all values
    • Ds\Set::contains - Determines if the set contains all values
    • Ds\Set::copy - Returns a shallow copy of the set
    • Ds\Set::count - Returns the number of values in the set
    • Ds\Set::diff - Creates a new set using values that aren't in another set
    • Ds\Set::filter - Creates a new set using a callable to determine which values to include
    • Ds\Set::first - Returns the first value in the set
    • Ds\Set::get - Returns the value at a given index
    • Ds\Set::intersect - Creates a new set by intersecting values with another set
    • Ds\Set::isEmpty - Returns whether the set is empty
    • Ds\Set::join - Joins all values together as a string
    • Ds\Set::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Set::last - Returns the last value in the set
    • Ds\Set::merge - Returns the result of adding all given values to the set
    • Ds\Set::reduce - Reduces the set to a single value using a callback function
    • Ds\Set::remove - Removes all given values from the set
    • Ds\Set::reverse - Reverses the set in-place
    • Ds\Set::reversed - Returns a reversed copy
    • Ds\Set::slice - Returns a sub-set of a given range
    • Ds\Set::sort - Sorts the set in-place
    • Ds\Set::sorted - Returns a sorted copy
    • Ds\Set::sum - Returns the sum of all values in the set
    • Ds\Set::toArray - Converts the set to an array
    • Ds\Set::union - Creates a new set using values from the current instance and another set
    • Ds\Set::xor - Creates a new set using values in either the current instance or in another set, but not in both
    • Ds\Set::__construct - Creates a new instance
    • Ds\Stack::allocate - Allocates enough memory for a required capacity
    • Ds\Stack::capacity - Returns the current capacity
    • Ds\Stack::clear - Removes all values
    • Ds\Stack::copy - Returns a shallow copy of the stack
    • Ds\Stack::count - Returns the number of values in the stack
    • Ds\Stack::isEmpty - Returns whether the stack is empty
    • Ds\Stack::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Stack::peek - Returns the value at the top of the stack
    • Ds\Stack::pop - Removes and returns the value at the top of the stack
    • Ds\Stack::push - Pushes values onto the stack
    • Ds\Stack::toArray - Converts the stack to an array
    • Ds\Stack::__construct - Creates a new instance
    • Ds\Vector::allocate - Allocates enough memory for a required capacity
    • Ds\Vector::apply - Updates all values by applying a callback function to each value
    • Ds\Vector::capacity - Returns the current capacity
    • Ds\Vector::clear - Removes all values
    • Ds\Vector::contains - Determines if the vector contains given values
    • Ds\Vector::copy - Returns a shallow copy of the vector
    • Ds\Vector::count - Returns the number of values in the collection
    • Ds\Vector::filter - Creates a new vector using a callable to determine which values to include
    • Ds\Vector::find - Attempts to find a value's index
    • Ds\Vector::first - Returns the first value in the vector
    • Ds\Vector::get - Returns the value at a given index
    • Ds\Vector::insert - Inserts values at a given index
    • Ds\Vector::isEmpty - Returns whether the vector is empty
    • Ds\Vector::join - Joins all values together as a string
    • Ds\Vector::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Vector::last - Returns the last value
    • Ds\Vector::map - Returns the result of applying a callback to each value
    • Ds\Vector::merge - Returns the result of adding all given values to the vector
    • Ds\Vector::pop - Removes and returns the last value
    • Ds\Vector::push - Adds values to the end of the vector
    • Ds\Vector::reduce - Reduces the vector to a single value using a callback function
    • Ds\Vector::remove - Removes and returns a value by index
    • Ds\Vector::reverse - Reverses the vector in-place
    • Ds\Vector::reversed - Returns a reversed copy
    • Ds\Vector::rotate - Rotates the vector by a given number of rotations
    • Ds\Vector::set - Updates a value at a given index
    • Ds\Vector::shift - Removes and returns the first value
    • Ds\Vector::slice - Returns a sub-vector of a given range
    • Ds\Vector::sort - Sorts the vector in-place
    • Ds\Vector::sorted - Returns a sorted copy
    • Ds\Vector::sum - Returns the sum of all values in the vector
    • Ds\Vector::toArray - Converts the vector to an array
    • Ds\Vector::unshift - Adds values to the front of the vector
    • Ds\Vector::__construct - Creates a new instance
  • e
    • each - Devolver el par clave/valor actual de un array y avanzar el cursor del array
    • easter_date - Obtener la fecha Unix para la medianoche de Pascua de un año dado
    • easter_days - Obtener el número de días despúes del 21 de marzo en el cuál cae Pascua para un año dado
    • echo - Muestra una o más cadenas
    • eio_busy - Incrementar artificialmente la carga. Podría ser útil en pruebas, evaluaciones comparativas
    • eio_cancel - Cancelar una petición
    • eio_chmod - Cambiar los permisos de fichero/directorio
    • eio_chown - Cambiar los permisos de un fichero/directorio
    • eio_close - Cerrar un fichero
    • eio_custom - Ejecutar una petición personalizada como cualquier otra llamada eio_*
    • eio_dup2 - Duplicar un descriptor de fichero
    • eio_event_loop - Monitorizar libeio hasta que todas las peticiones sean procesadas
    • eio_fallocate - Permitir al llamador manipular directamente el espacio de disco asignado a un fichero
    • eio_fchmod - Cambiar los permisos de un fichero
    • eio_fchown - Cambiar el propietario del fichero
    • eio_fdatasync - Sincronizar el estado de ficheros que están en memoria con un dispositivo de almacenamiento
    • eio_fstat - Obtener el estado de un fichero
    • eio_fstatvfs - Obtener las estadísticas del sistema de ficheros
    • eio_fsync - Sincronizar el estado de un fichero en memoria con un dispositivo de almacenamiento
    • eio_ftruncate - Truncar un fichero
    • eio_futime - Cambiar los momentos de último y acceso y modificación de un fichero
    • eio_get_event_stream - Obtiene un flujo que representa una variable usada en comnunicaciones internas con libeio
    • eio_get_last_error - Devuelve un string que describe el último error asociado con un recurso de petición
    • eio_grp - Crear un grupo de peticiones
    • eio_grp_add - Añadir una petición al grupo de peticiones
    • eio_grp_cancel - Cancelar un grupo de peticiones
    • eio_grp_limit - Establecer el límite de un grupo
    • eio_init - (Re-)inicializa Eio
    • eio_link - Crear un enlace duro par un fichero
    • eio_lstat - Obtener el estado de un fichero
    • eio_mkdir - Crear un directorio
    • eio_mknod - Crear un fichero especial u ordinario
    • eio_nop - No hace nada, sólo recorre el ciclo de peticiones entero
    • eio_npending - Devolver el número de peticiones, excepto las no manejadas
    • eio_nready - Devolver el número de peticiones aún no tratadas
    • eio_nreqs - Devuelve el número de peticiones a ser procesadas
    • eio_nthreads - Devuelve el número de hilos actualmente en uso
    • eio_open - Abrir un fichero
    • eio_poll - Puede ser llamada siempre que existan peticiones pendientes que necesitan ser finalizadas
    • eio_read - Leer de un descriptor de fichero en un índice dado
    • eio_readahead - Perform file readahead into page cache
    • eio_readdir - Leer un directorio al completo
    • eio_readlink - Leer el valor de un enlace simbólico
    • eio_realpath - Obtener el nombre de ruta absoluto canonizado
    • eio_rename - Cambiar el nombre o la ubicación de un fichero
    • eio_rmdir - Eliminar un directorio
    • eio_seek - Reposiciona el índice del fichero abierto asociado con el argumento fd al argumento offset según la directiva whence
    • eio_sendfile - Transferir información entre descriptores de ficheros
    • eio_set_max_idle - Establecer el número máximo de hilos parados
    • eio_set_max_parallel - Esteblecer el máximo de hilos paralelos
    • eio_set_max_poll_reqs - Establecer el máximo número de peticiones procesadas en una monitorización
    • eio_set_max_poll_time - Establecer el tiempo máximo de monitorización
    • eio_set_min_parallel - Esteblecer el número de hilos paralelos mínimo
    • eio_stat - Obtener el estado de un fichero
    • eio_statvfs - Obtener las estadísticas del sistema de ficheros
    • eio_symlink - Crear un enlace simbólico
    • eio_sync - Consignar el caché de buffer cache al disco
    • eio_syncfs - Realizar una llamada al sistema de syncfs de Linux si está disponible
    • eio_sync_file_range - Sincornizar un segmento de fichero con el disco
    • eio_truncate - Truncar un fichero
    • eio_unlink - Borrar un nombre y posiblemente el fichero al que se refiere
    • eio_utime - Cambiar los momentos de último y acceso y modificación de un fichero
    • eio_write - Escribir en un fichero
    • empty - Determina si una variable está vacía
    • EmptyIterator::current - El método current()
    • EmptyIterator::key - El método key()
    • EmptyIterator::next - El método next()
    • EmptyIterator::rewind - El método rewind()
    • EmptyIterator::valid - El método valid()
    • enchant_broker_describe - Enumera los proveedores de Enchant
    • enchant_broker_dict_exists - Si existe o no un diccionario. Usando una etiqueta no vacía
    • enchant_broker_free - Liberar el recurso de agente y sus diccionarios
    • enchant_broker_free_dict - Liberar un recurso de diccionario
    • enchant_broker_get_dict_path - Obtener la ruta del directorio para un 'backend' dado
    • enchant_broker_get_error - Devuelve el último error del agente
    • enchant_broker_init - Crear un nuevo objeto agente capaz de hacer peticiones
    • enchant_broker_list_dicts - Devuelve una lista de los diccionarios disponibles
    • enchant_broker_request_dict - Crear un diccionario usanto una etiqueta
    • enchant_broker_request_pwl_dict - Crea un diccionario usando un fichero PWL
    • enchant_broker_set_dict_path - Establecer la ruta del directorio para un 'backend' dado
    • enchant_broker_set_ordering - Declara una preferencia de diccionarios a usar para el lenguaje
    • enchant_dict_add - Add a word to personal word list
    • enchant_dict_add_to_personal - Añadir una palabra a una lista personal de palabras
    • enchant_dict_add_to_session - Añadir una palabra a esta sesión ortográfica
    • enchant_dict_check - Comprobar si una palabra está correctamente escrita o no
    • enchant_dict_describe - Describe un diccionario individual
    • enchant_dict_get_error - Devuelve el último error de la sesión ortográfica actual
    • enchant_dict_is_added - Whether or not 'word' exists in this spelling-session
    • enchant_dict_is_in_session - Si existe o no una palabra en esta sesión ortográfica
    • enchant_dict_quick_check - Verifica si la palabra está correctamente escrita y proporciona sugerencias
    • enchant_dict_store_replacement - Añadir una corrección a una palabra
    • enchant_dict_suggest - Devolverá una lista de valores si no se reúnen esas pre-condiciones
    • end - Establece el puntero interno de un array a su último elemento
    • ereg - Comparación de una expresión regular
    • eregi - Comparación de una expresión regular de forma insensible a mayúsculas-minúsculas
    • eregi_replace - Sustituye una expresión regular de forma insensible a mayúsculas-minúsculas
    • ereg_replace - Sustituye una expresión regular
    • Error::getCode - Obtener el código de error
    • Error::getFile - Obtener el fichero en el que ocurrío el error
    • Error::getLine - Obtener la línea en la que ocurrió el error
    • Error::getMessage - Obtener el mensaje de error
    • Error::getPrevious - Devuelve el objeto Throwable anterior
    • Error::getTrace - Obtener la traza de la pila
    • Error::getTraceAsString - Obtener la traza de la pila como un string
    • Error::__clone - Clonar el error
    • Error::__construct - Construir el objeto error
    • Error::__toString - Representación de string del error
    • ErrorException::getSeverity - Obtiene la severidad de la excepción
    • ErrorException::__construct - Constructor de la excepción
    • error_clear_last - Limpiar el error más reciente
    • error_get_last - Obtener el último error que ocurrió
    • error_log - Enviar un mensaje de error a las rutinas de manejo de errores definidas
    • error_reporting - Establece cuáles errores de PHP son notificados
    • escapeshellarg - Escapar una cadena a ser usada como argumento del intérprete de comandos
    • escapeshellcmd - Escapar meta-caracteres del intérprete de comandos
    • Ev::backend - Devuelve un entero que describe el back-end utilizado por libev
    • Ev::depth - Devuelve la profundidad de la recursividad
    • Ev::embeddableBackends - Returns the set of backends that are embeddable in other event loops
    • Ev::feedSignal - Feed a signal event info Ev
    • Ev::feedSignalEvent - Feed signal event into the default loop
    • Ev::iteration - Return the number of times the default event loop has polled for new events
    • Ev::now - Returns the time when the last iteration of the default event loop has started
    • Ev::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
    • Ev::recommendedBackends - Returns a bit mask of recommended backends for current platform
    • Ev::resume - Resume previously suspended default event loop
    • Ev::run - Begin checking for events and calling callbacks for the default loop
    • Ev::sleep - Block the process for the given number of seconds
    • Ev::stop - Stops the default event loop
    • Ev::supportedBackends - Returns the set of backends supported by current libev configuration
    • Ev::suspend - Suspend the default event loop
    • Ev::time - Returns the current time in fractional seconds since the epoch
    • Ev::verify - Performs internal consistency checks(for debugging)
    • eval - Evaluar una cadena como código de PHP
    • EvCheck::createStopped - Create instance of a stopped EvCheck watcher
    • EvCheck::__construct - Constructs the EvCheck watcher object
    • EvChild::createStopped - Create instance of a stopped EvCheck watcher
    • EvChild::set - Configures the watcher
    • EvChild::__construct - Constructs the EvChild watcher object
    • EvEmbed::createStopped - Create stopped EvEmbed watcher object
    • EvEmbed::set - Configures the watcher
    • EvEmbed::sweep - Realizar un único barrido sin bloqueos sobre el bucle embebido
    • EvEmbed::__construct - Constructs the EvEmbed object
    • Event::add - Makes event pending
    • Event::addSignal - Makes signal event pending
    • Event::addTimer - Makes timer event pending
    • Event::del - Makes event non-pending
    • Event::delSignal - Makes signal event non-pending
    • Event::delTimer - Makes timer event non-pending
    • Event::free - Make event non-pending and free resources allocated for this event
    • Event::getSupportedMethods - Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending - Detects whether event is pending or scheduled
    • Event::set - Re-configures event
    • Event::setPriority - Set event priority
    • Event::setTimer - Re-configures timer event
    • Event::signal - Constructs signal event object
    • Event::timer - Constructs timer event object
    • Event::__construct - Constructs Event object
    • EventBase::dispatch - Despacha eventos pendientes
    • EventBase::exit - Detiene el envío de los eventos
    • EventBase::free - Free resources allocated for this event base
    • EventBase::getFeatures - Devuelve una máscara de bits de funcionalidades soportadas
    • EventBase::getMethod - Devuelve el método de evento utilizado
    • EventBase::getTimeOfDayCached - Devuelve el tiempo del evento base actual
    • EventBase::gotExit - Verifica si se ha indicado al bucle del evento de salir
    • EventBase::gotStop - Verifica si se ha indicado al bucle del evento de salir
    • EventBase::loop - Despacha eventos pendientes
    • EventBase::priorityInit - Define el número de prioridades por evento base
    • EventBase::reInit - Reinicializa el evento base (después de un 'fork')
    • EventBase::stop - Solicita a event_base que detenga la emisión de eventos
    • EventBase::__construct - Construye un objeto EventBase
    • EventBuffer::add - Añade datos al final de un buffer de eventos
    • EventBuffer::addBuffer - Mueve todos los datos de un buffer a la instancia actual de EventBuffer
    • EventBuffer::appendFrom - Mueve el número de bytes especificados desde un buffer fuente, al final del buffer actual
    • EventBuffer::copyout - Copia un número específico de bytes del principio del buffer
    • EventBuffer::drain - Elimina un número específico de bytes del principio del buffer sin copiarlo a ningún lugar
    • EventBuffer::enableLocking - Descripción
    • EventBuffer::expand - Reserva espacio en el buffer
    • EventBuffer::freeze - Evita que las llamadas puedan modificar un buffer de eventos
    • EventBuffer::lock - Bloquea un buffer
    • EventBuffer::prepend - Prepend data to the front of the buffer
    • EventBuffer::prependBuffer - Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup - Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read - Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom - Read data from a file onto the end of the buffer
    • EventBuffer::readLine - Extracts a line from the front of the buffer
    • EventBuffer::search - Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol - Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr - Substracts a portion of the buffer data
    • EventBuffer::unfreeze - Re-enable calls that modify an event buffer
    • EventBuffer::unlock - Releases lock acquired by EventBuffer::lock
    • EventBuffer::write - Write contents of the buffer to a file or socket
    • EventBuffer::__construct - Construye el objeto EventBuffer
    • EventBufferEvent::close - Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect - Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost - Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::createPair - Creates two buffer events connected to each other
    • EventBufferEvent::disable - Disable events read, write, or both on a buffer event
    • EventBufferEvent::enable - Enable events read, write, or both on a buffer event
    • EventBufferEvent::free - Free a buffer event
    • EventBufferEvent::getDnsErrorString - Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled - Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput - Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput - Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read - Read buffer's data
    • EventBufferEvent::readBuffer - Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks - Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority - Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts - Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark - Adjusts read and/or write watermarks
    • EventBufferEvent::sslError - Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter - Crea un nuevo evento búfer SSL búfer para enviar sus datos a otro evento búfer
    • EventBufferEvent::sslGetCipherInfo - Returns a textual description of the cipher
    • EventBufferEvent::sslGetCipherName - Returns the current cipher name of the SSL connection
    • EventBufferEvent::sslGetCipherVersion - Returns version of cipher used by current SSL connection
    • EventBufferEvent::sslGetProtocol - Returns the name of the protocol used for current SSL connection
    • EventBufferEvent::sslRenegotiate - Tells a bufferevent to begin SSL renegotiation
    • EventBufferEvent::sslSocket - Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write - Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer - Adds contents of the entire buffer to a buffer event's output buffer
    • EventBufferEvent::__construct - Constructs EventBufferEvent object
    • EventConfig::avoidMethod - Tells libevent to avoid specific event method
    • EventConfig::requireFeatures - Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval - Prevents priority inversion
    • EventConfig::__construct - Constructs EventConfig object
    • EventDnsBase::addNameserverIp - Adds a nameserver to the DNS base
    • EventDnsBase::addSearch - Adds a domain to the list of search domains
    • EventDnsBase::clearSearch - Removes all current search suffixes
    • EventDnsBase::countNameservers - Gets the number of configured nameservers
    • EventDnsBase::loadHosts - Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf - Scans the resolv.conf-formatted file
    • EventDnsBase::setOption - Set the value of a configuration option
    • EventDnsBase::setSearchNdots - Set the 'ndots' parameter for searches
    • EventDnsBase::__construct - Constructs EventDnsBase object
    • EventHttp::accept - Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias - Adds a server alias to the HTTP server object
    • EventHttp::bind - Binds an HTTP server on the specified address and port
    • EventHttp::removeServerAlias - Removes server alias
    • EventHttp::setAllowedMethods - Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback - Sets a callback for specified URI
    • EventHttp::setDefaultCallback - Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize - Sets maximum request body size
    • EventHttp::setMaxHeadersSize - Sets maximum HTTP header size
    • EventHttp::setTimeout - Sets the timeout for an HTTP request
    • EventHttp::__construct - Constructs EventHttp object(the HTTP server)
    • EventHttpConnection::getBase - Returns event base associated with the connection
    • EventHttpConnection::getPeer - Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest - Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback - Set callback for connection close
    • EventHttpConnection::setLocalAddress - Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort - Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize - Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize - Sets maximum header size
    • EventHttpConnection::setRetries - Sets the retry limit for the connection
    • EventHttpConnection::setTimeout - Sets the timeout for the connection
    • EventHttpConnection::__construct - Constructs EventHttpConnection object
    • EventHttpRequest::addHeader - Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel - Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders - Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection - Closes associated HTTP connection
    • EventHttpRequest::findHeader - Finds the value belonging a header
    • EventHttpRequest::free - Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent - Returns EventBufferEvent object
    • EventHttpRequest::getCommand - Returns the request command(method)
    • EventHttpRequest::getConnection - Returns EventHttpConnection object
    • EventHttpRequest::getHost - Returns the request host
    • EventHttpRequest::getInputBuffer - Returns the input buffer
    • EventHttpRequest::getInputHeaders - Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer - Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders - Returns associative array of the output headers
    • EventHttpRequest::getResponseCode - Returns the response code
    • EventHttpRequest::getUri - Returns the request URI
    • EventHttpRequest::removeHeader - Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError - Send an HTML error message to the client
    • EventHttpRequest::sendReply - Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk - Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd - Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart - Initiate a chunked reply
    • EventHttpRequest::__construct - Constructs EventHttpRequest object
    • EventListener::disable - Disables an event connect listener object
    • EventListener::enable - Enables an event connect listener object
    • EventListener::getBase - Returns event base associated with the event listener
    • EventListener::getSocketName - Retreives the current address to which the listener's socket is bound
    • EventListener::setCallback - The setCallback purpose
    • EventListener::setErrorCallback - Set event listener's error callback
    • EventListener::__construct - Creates new connection listener associated with an event base
    • EventSslContext::__construct - Constructs an OpenSSL context for use with Event classes
    • EventUtil::getLastSocketErrno - Returns the most recent socket error number
    • EventUtil::getLastSocketError - Returns the most recent socket error
    • EventUtil::getSocketFd - Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName - Retreives the current address to which the socket is bound
    • EventUtil::setSocketOption - Sets socket options
    • EventUtil::sslRandPoll - Generates entropy by means of OpenSSL's RAND_poll()
    • EventUtil::__construct - The abstract constructor
    • EvFork::createStopped - Creates a stopped instance of EvFork watcher class
    • EvFork::__construct - Constructs the EvFork watcher object
    • EvIdle::createStopped - Creates instance of a stopped EvIdle watcher object
    • EvIdle::__construct - Constructs the EvIdle watcher object
    • EvIo::createStopped - Create stopped EvIo watcher object
    • EvIo::set - Configures the watcher
    • EvIo::__construct - Constructs EvIo watcher object
    • EvLoop::backend - Returns an integer describing the backend used by libev
    • EvLoop::check - Creates EvCheck object associated with the current event loop instance
    • EvLoop::child - Creates EvChild object associated with the current event loop
    • EvLoop::defaultLoop - Returns or creates the default event loop
    • EvLoop::embed - Creates an instance of EvEmbed watcher associated with the current EvLoop object
    • EvLoop::fork - Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle - Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending - Invoke all pending watchers while resetting their pending state
    • EvLoop::io - Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork - Must be called after a fork
    • EvLoop::now - Returns the current "event loop time"
    • EvLoop::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
    • EvLoop::periodic - Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare - Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume - Resume previously suspended default event loop
    • EvLoop::run - Begin checking for events and calling callbacks for the loop
    • EvLoop::signal - Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat - Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop - Stops the event loop
    • EvLoop::suspend - Suspend the loop
    • EvLoop::timer - Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify - Performs internal consistency checks(for debugging)
    • EvLoop::__construct - Constructs the event loop object
    • EvPeriodic::again - Simply stops and restarts the periodic watcher again
    • EvPeriodic::at - Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::createStopped - Create a stopped EvPeriodic watcher
    • EvPeriodic::set - Configures the watcher
    • EvPeriodic::__construct - Constructs EvPeriodic watcher object
    • EvPrepare::createStopped - Crea una instancia detenida del watcher (testigo) EvPrepare
    • EvPrepare::__construct - Construye un objeto observador de EvPrepare
    • EvSignal::createStopped - Create stopped EvSignal watcher object
    • EvSignal::set - Configura el testigo
    • EvSignal::__construct - Construye el objeto observador EvSignal
    • EvStat::attr - Returns the values most recently detected by Ev
    • EvStat::createStopped - Create a stopped EvStat watcher object
    • EvStat::prev - Returns the previous set of values returned by EvStat::attr
    • EvStat::set - Configures the watcher
    • EvStat::stat - Initiates the stat call
    • EvStat::__construct - Constructs EvStat watcher object
    • EvTimer::again - Restarts the timer watcher
    • EvTimer::createStopped - Creates EvTimer stopped watcher object
    • EvTimer::set - Configures the watcher
    • EvTimer::__construct - Constructs an EvTimer watcher object
    • EvWatcher::clear - Clear watcher pending status
    • EvWatcher::feed - Feeds the given revents set into the event loop
    • EvWatcher::getLoop - Returns the loop responsible for the watcher
    • EvWatcher::invoke - Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive - Configures whether to keep the loop from returning
    • EvWatcher::setCallback - Sets new callback for the watcher
    • EvWatcher::start - Starts the watcher
    • EvWatcher::stop - Stops the watcher
    • EvWatcher::__construct - Abstract constructor of a watcher object
    • Exception::getCode - Obtiene el código de una excepción
    • Exception::getFile - Obtiene el fichero en el que se creó la excepción
    • Exception::getLine - Obtiene la línea en el que se creó la excepción
    • Exception::getMessage - Obtiene el mensaje de Excepción
    • Exception::getPrevious - Devuelve la excepción anterior
    • Exception::getTrace - Obtiene la traza de la pila
    • Exception::getTraceAsString - Obtiene la traza de la pila como una cadena de caracteres
    • Exception::__clone - Clona la excepción
    • Exception::__construct - Constructor de la excepción
    • Exception::__toString - Representación de la excepción en formato cadena
    • exec - Ejecutar un programa externo
    • exif_imagetype - Determinar el tipo de una imagen
    • exif_read_data - Lee las cabeceras EXIF desde un JPEG o un TIFF
    • exif_tagname - Obtener el nombre de la cabecera de un índice
    • exif_thumbnail - Recuperar la miniatura embebida de una imagen TIFF o JPEG
    • exit - Imprime un mensaje y termina el script actual
    • exp - Calcula la exponencial de e
    • expect:// - Flujos de Interacción de Procesos
    • expect_expectl - Espera a que la salida de un proceso coincida con un patrón, se supere un determinado periodo de tiempo, o se alcance un EOF
    • expect_popen - Ejecuta comandos por la shell Bourne, y abre el flujo PTY al proceso
    • explode - Divide un string en varios string
    • expm1 - Devuelve exp(numero)-1, calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
    • extension_loaded - Encontrar si una extensión está cargada
    • extract - Importar variables a la tabla de símbolos actual desde un array
    • ezmlm_hash - Calcula el valor hash que necesita EZMLM
  • f
    • FANNConnection::getFromNeuron - Devuelve las posiciones de la neurona inicial
    • FANNConnection::getToNeuron - Devuelve las posiciones de la neurona terminal
    • FANNConnection::getWeight - Devuelve el peso de la conexión
    • FANNConnection::setWeight - Establece el peso de la conexión
    • FANNConnection::__construct - El constructor de la conexión
    • fann_cascadetrain_on_data - Entrena un conjunto de datos completo, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
    • fann_cascadetrain_on_file - Entre un conjunto de datos completo desde un fichero, por un período de tiempo utilizando el algoritmo de entrenamiento Cascade2
    • fann_clear_scaling_params - Limpia los parámetros de escala
    • fann_copy - Crea una copia de una estructura fann
    • fann_create_from_file - Construye una red neuronal de retropropagación desde un fichero de configuración
    • fann_create_shortcut - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
    • fann_create_shortcut_array - Crea una red neuronal de retropropagación estándar que no está completamente conectada y que posee conexiones de atajo
    • fann_create_sparse - Crea una red neuronal de retropropagación estándar que no está conectada completamente
    • fann_create_sparse_array - Crea una red neuronal de retropropagación estándar que no está completamente conectada empleando un array con tamaños de capas
    • fann_create_standard - Crea una red neuronal de retropropagación estándar completamente conectada
    • fann_create_standard_array - Crea una red neuronal de retropropagación estándar completamente conectada empleando un array con tamaños de capas
    • fann_create_train - Crea una estructura de datos de entrenamiento vacía
    • fann_create_train_from_callback - Crea una estructura de datos de entrenamiento desde una función proporcionada por el usuario
    • fann_descale_input - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
    • fann_descale_output - Escalar datos en un vector de entrada después de obtenerlo de una RNA basada en parámetros previamente calculados
    • fann_descale_train - Descalar datos de entrada y salida basados en parámetros previamente calculados
    • fann_destroy - Destruye la red por completo y libera adecuadamente toda la memoria asociada
    • fann_destroy_train - Destruye los datos de entrenamiento
    • fann_duplicate_train_data - Devuelve una copia exacta de uno datos de entrenamiento de fann
    • fann_get_activation_function - Devuelve la función de activación
    • fann_get_activation_steepness - Devuelve la pendiente de activación para el número de neurona y de capa proporcionados
    • fann_get_bias_array - Obtener el número de tendencias de cada capa de una red
    • fann_get_bit_fail - El número de bit fallidos
    • fann_get_bit_fail_limit - Devuelve el límite de fallo de bit empleado durante un entrenamiento
    • fann_get_cascade_activation_functions - Devuelve las funciones de activación en cascada
    • fann_get_cascade_activation_functions_count - Devuelve el número de funciones de activación en cascada
    • fann_get_cascade_activation_steepnesses - Devuelve las pendientes de activación en cascada
    • fann_get_cascade_activation_steepnesses_count - El número de pendientes de activación
    • fann_get_cascade_candidate_change_fraction - Devuelve la fracción de cambio de candidatas en cascada
    • fann_get_cascade_candidate_limit - Devuelve el límite de candidatas
    • fann_get_cascade_candidate_stagnation_epochs - Devuelve el número de épocas de estancamiento de candidatas en cascada
    • fann_get_cascade_max_cand_epochs - Devuelve el máximo de épocas de candidatas
    • fann_get_cascade_max_out_epochs - Devuelve el máximo de épocas de salida
    • fann_get_cascade_min_cand_epochs - Devuelve el mínimo de épocas de candidatas
    • fann_get_cascade_min_out_epochs - Devuelve el mínimo de épocas de salida
    • fann_get_cascade_num_candidates - Devuelve el número de candidatas empleadas durante un entrenamiento
    • fann_get_cascade_num_candidate_groups - Devuelve el número de grupos de candidatas
    • fann_get_cascade_output_change_fraction - Devuelve la fracción de cambio de salida en cascada
    • fann_get_cascade_output_stagnation_epochs - Devuelve el número de épocas de estancamiento de salida en cascada
    • fann_get_cascade_weight_multiplier - Devuelve el multiplicador de peso
    • fann_get_connection_array - Obtener las conexiones de la red
    • fann_get_connection_rate - Obtener el índice de conexión empleado al crear la red
    • fann_get_errno - Devuelve el número del último error
    • fann_get_errstr - Devuelve el string de último error
    • fann_get_layer_array - Obtener el número de neuronas de cada capa de la red
    • fann_get_learning_momentum - Devuelve el momento del aprendizaje
    • fann_get_learning_rate - Devuelve el índice de aprendizaje
    • fann_get_MSE - Lee el error cuadrático medio de la red
    • fann_get_network_type - Obtener el tipo de una red neuronal
    • fann_get_num_input - Obtener el número de neuronas de entrada
    • fann_get_num_layers - Obtener el número de capas de la red neuronal
    • fann_get_num_output - Obtener el número de neuronas de salida
    • fann_get_quickprop_decay - Devuelve la decadencia, que es un factor por el que los pesos deberían decrementar en cada iteración durante un entrenamiento quickprop
    • fann_get_quickprop_mu - Devuelve el factor mu
    • fann_get_rprop_decrease_factor - Devuelve el factor de disminución empleado durante un entrenamiento RPROP
    • fann_get_rprop_delta_max - Devuelve el tamaño de paso máximo
    • fann_get_rprop_delta_min - Devuelve el tamaño de paso mínimo
    • fann_get_rprop_delta_zero - Devuelve el tamaño de paso inicial
    • fann_get_rprop_increase_factor - Devuelve el factor de aumento empleado durante un entrenamiento RPROP
    • fann_get_sarprop_step_error_shift - Devuelve el desplazamiento del error de paso de sarprop
    • fann_get_sarprop_step_error_threshold_factor - Devuelve el factor de umbral del error de paso de sarprop
    • fann_get_sarprop_temperature - Devuelve la temperatura de sarprop
    • fann_get_sarprop_weight_decay_shift - Devuelve el desplazamiento de decadencia del peso de sarprop
    • fann_get_total_connections - Obtener el número total de conexiones de la red completa
    • fann_get_total_neurons - Obtener el número total de neuronas de la red completa
    • fann_get_training_algorithm - Devuelve el algoritmo de entrenamiento
    • fann_get_train_error_function - Devuelve la función de error empleada durante un entrenamiento
    • fann_get_train_stop_function - Devuelve la función de parada empleada durante el entrenamiento
    • fann_init_weights - Inicializar los pesos empleando el algoritmo de Widrow + Nguyen
    • fann_length_train_data - Devuelve el número de patrones de entrenamiento de los datos de entrenamiento
    • fann_merge_train_data - Funde los datos de entrenamiento
    • fann_num_input_train_data - Devuelve el número de entradas de cada patrón de entrenamiento de los datos de entrenamiento
    • fann_num_output_train_data - Devuelve el número de salidas de cada patrón de entrenamiento de los datos de entrenamiento
    • fann_print_error - Imprime el string de error
    • fann_randomize_weights - Dar a cada conexión un peso aleatorio entre min_weight y max_weight
    • fann_read_train_from_file - Lee un fichero que almacena datos de entrenamiento
    • fann_reset_errno - Reinicia el número del último error
    • fann_reset_errstr - Reinicia el string del último error
    • fann_reset_MSE - Reinicia el error cuadrático medio de la red
    • fann_run - Ejecutará la entrada a través de la red neuronal
    • fann_save - Guarda la red completa a un fichero de configuración
    • fann_save_train - Guarda la estructura de entrenamiento en un fichero
    • fann_scale_input - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
    • fann_scale_input_train_data - Escala las entradas de los datos de entrenamiento al rango especificado
    • fann_scale_output - Escalar datos en un vector de entrada antes de alimentarlo a una RNA basada en parámetros previamente calculados
    • fann_scale_output_train_data - Escala las salidas de los datos de entrenamiento al rango especificado
    • fann_scale_train - Escalar datos de entrada y salida basados en parámetros previamente calculados
    • fann_scale_train_data - Escala la entradas y salidas de los datos de entrenamiento al rango especificado
    • fann_set_activation_function - Establece la función de activación para la neurona y capa proporcionadas
    • fann_set_activation_function_hidden - Establece la función de activación para todas las capas ocultas
    • fann_set_activation_function_layer - Establece la función de activación para todas las neuronas de la capa proporcionada
    • fann_set_activation_function_output - Establece la función de activación para la capa de salida
    • fann_set_activation_steepness - Establece la pendiente de activación el número de neurona y capa proporcionados
    • fann_set_activation_steepness_hidden - Establece la pendiente de la activación para todas las neuronas de todas las capas ocultas
    • fann_set_activation_steepness_layer - Establece la pendiente de activación para todas las neuronas del número de capa proporcionada
    • fann_set_activation_steepness_output - Establece la pendiente de activación de la capa de salida
    • fann_set_bit_fail_limit - Establece el límite de fallo de bit empleado durante un entrenamiento
    • fann_set_callback - Establece la función de retrollamada a emplear durante el entrenamiento
    • fann_set_cascade_activation_functions - Establece el array de funciones de activación de candidatas en cascada
    • fann_set_cascade_activation_steepnesses - Establece el array de pendientes de activación de candidatas en cascada
    • fann_set_cascade_candidate_change_fraction - Establece la fracción de cambio de candidatas en cascada
    • fann_set_cascade_candidate_limit - Establece el límite de candidatas
    • fann_set_cascade_candidate_stagnation_epochs - Establece el número de épocas de estancamiento de candidatas en cascada
    • fann_set_cascade_max_cand_epochs - Establece el máximo de épocas de candidatas
    • fann_set_cascade_max_out_epochs - Establece el máximo de épocas de salida
    • fann_set_cascade_min_cand_epochs - Establece el mínimo de épocas de candidatas
    • fann_set_cascade_min_out_epochs - Establece el mínimo de épocas de salida
    • fann_set_cascade_num_candidate_groups - Establece el número de grupos de candidatas
    • fann_set_cascade_output_change_fraction - Establece la fracción de cambio de salida en cascada
    • fann_set_cascade_output_stagnation_epochs - Establece el número de épocas de estancamiento de salida en cascada
    • fann_set_cascade_weight_multiplier - Establece el multiplicador de peso
    • fann_set_error_log - Establece dónde registrar los errores
    • fann_set_input_scaling_params - Calcular los parámetros de escala de entrada para un uso futuro basados en datos de entrenamiento
    • fann_set_learning_momentum - Establece el momento del aprendizaje
    • fann_set_learning_rate - Establece el índice de aprendizaje
    • fann_set_output_scaling_params - Calcular los parámetros de escala de salida para un uso futuro basados en datos de entrenamiento
    • fann_set_quickprop_decay - Establece el factor de decadencia de quickprop
    • fann_set_quickprop_mu - Establece el factor mu de quickprop
    • fann_set_rprop_decrease_factor - Establece el factor de disminución empleado durante un entrenamiento RPROP
    • fann_set_rprop_delta_max - Establece el tamaño de paso máximo
    • fann_set_rprop_delta_min - Establece el tamaño de paso mínimo
    • fann_set_rprop_delta_zero - Establece el tamaño de paso inicial
    • fann_set_rprop_increase_factor - Establece el factor de aumento empleado durante un entrenamiento RPROP
    • fann_set_sarprop_step_error_shift - Establece el desplazamiento del error de paso de sarprop
    • fann_set_sarprop_step_error_threshold_factor - Establece el factor de umbral del error de paso de sarprop
    • fann_set_sarprop_temperature - Establece la temperatura de sarprop
    • fann_set_sarprop_weight_decay_shift - Establece el desplazamiento de decadencia del peso de sarprop
    • fann_set_scaling_params - Calcular los parámetros de escala de entrada y salida para un uso futuro basados en datos de entrenamiento
    • fann_set_training_algorithm - Establece el algoritmo de entrenamiento
    • fann_set_train_error_function - Establecer la función de error empleada durante un entrenamiento
    • fann_set_train_stop_function - Establece la función de parada empleada durante el entrenamiento
    • fann_set_weight - Establecer una conexión de la red
    • fann_set_weight_array - Establecer las conexiones de la red
    • fann_shuffle_train_data - Mezcla los datos de entrenamiento, aleatorizando el orden
    • fann_subset_train_data - Devuelve una copia de un subconjunto de los datos de entrenamiento
    • fann_test - Probar con un conjunto de entradas, y un conjunto de salidas deseadas
    • fann_test_data - Prueba un conjunto de datos de entrenamiento y calcula el ECM de dichos datos
    • fann_train - Entrenar una iteración con un conjunto de entradas y un conjunto de salidas deseadas
    • fann_train_epoch - Entrenar una época con un conjunto de datos de entrenamiento
    • fann_train_on_data - Entrena un conjunto de datos completo por un período de tiempo
    • fann_train_on_file - Entrena un conjunto de datos completo leído desde un fichero, por un período de tiempo
    • fastcgi_finish_request - Flushes all response data to the client
    • fbird_add_user - Alias de ibase_add_user
    • fbird_affected_rows - Alias de ibase_affected_rows
    • fbird_backup - Alias de ibase_backup
    • fbird_blob_add - Alias de ibase_blob_add
    • fbird_blob_cancel - Cancel creating blob
    • fbird_blob_close - Alias de ibase_blob_close
    • fbird_blob_create - Alias de ibase_blob_create
    • fbird_blob_echo - Alias de ibase_blob_echo
    • fbird_blob_get - Alias de ibase_blob_get
    • fbird_blob_import - Alias de ibase_blob_import
    • fbird_blob_info - Alias de ibase_blob_info
    • fbird_blob_open - Alias de ibase_blob_open
    • fbird_close - Alias de ibase_close
    • fbird_commit - Alias de ibase_commit
    • fbird_commit_ret - Alias de ibase_commit_ret
    • fbird_connect - Alias de ibase_connect
    • fbird_db_info - Alias de ibase_db_info
    • fbird_delete_user - Alias de ibase_delete_user
    • fbird_drop_db - Alias de ibase_drop_db
    • fbird_errcode - Alias de ibase_errcode
    • fbird_errmsg - Alias de ibase_errmsg
    • fbird_execute - Alias de ibase_execute
    • fbird_fetch_assoc - Alias de ibase_fetch_assoc
    • fbird_fetch_object - Alias de ibase_fetch_object
    • fbird_fetch_row - Alias de ibase_fetch_row
    • fbird_field_info - Alias de ibase_field_info
    • fbird_free_event_handler - Alias de ibase_free_event_handler
    • fbird_free_query - Alias de ibase_free_query
    • fbird_free_result - Alias de ibase_free_result
    • fbird_gen_id - Alias de ibase_gen_id
    • fbird_maintain_db - Alias de ibase_maintain_db
    • fbird_modify_user - Alias de ibase_modify_user
    • fbird_name_result - Alias de ibase_name_result
    • fbird_num_fields - Alias de ibase_num_fields
    • fbird_num_params - Alias de ibase_num_params
    • fbird_param_info - Alias de ibase_param_info
    • fbird_pconnect - Alias de ibase_pconnect
    • fbird_prepare - Alias de ibase_prepare
    • fbird_query - Alias de ibase_query
    • fbird_restore - Alias de ibase_restore
    • fbird_rollback - Alias de ibase_rollback
    • fbird_rollback_ret - Alias de ibase_rollback_ret
    • fbird_server_info - Alias de ibase_server_info
    • fbird_service_attach - Alias de ibase_service_attach
    • fbird_service_detach - Alias de ibase_service_detach
    • fbird_set_event_handler - Alias de ibase_set_event_handler
    • fbird_trans - Alias de ibase_trans
    • fbird_wait_event - Alias de ibase_wait_event
    • fbsql_affected_rows - Obtiene el numero de filas afectadas en la anterior operación de FrontBase
    • fbsql_autocommit - Activa o desactiva el autocommit
    • fbsql_blob_size - Obtiene el tamaño de un BLOB
    • fbsql_change_user - Cambia el usuario logueado en la conexión activa
    • fbsql_clob_size - Obtiene el tamaño de un CLOB
    • fbsql_close - Cierra la conexión FrontBase
    • fbsql_commit - Ejecuta un commit de la transacción sobre la base de datos
    • fbsql_connect - Abre una conexión a un servidor FrontBase
    • fbsql_create_blob - Crea un BLOB
    • fbsql_create_clob - Crea un CLOB
    • fbsql_create_db - Crea una base de datos FrontBase
    • fbsql_database - Obtiene o especifica la base de datos usada por la conexión
    • fbsql_database_password - Asigna o recupera el password de una base de datos FrontBase
    • fbsql_data_seek - Mueve el puntero interno de resultado
    • fbsql_db_query - Ejecuta una consulta a FrontBase
    • fbsql_db_status - Obtiene el estado de una base de datos dada
    • fbsql_drop_db - Elimina (drop) una base de datos FrontBase
    • fbsql_errno - Devuelve el número de error de la última operación
    • fbsql_error - Devuelve el mensaje de error de la última operación
    • fbsql_fetch_array - Obtiene una fila de resultados como array asociativo, array numérico, o ambos
    • fbsql_fetch_assoc - Obtiene una fila de resultados como array asociativo
    • fbsql_fetch_field - Obtiene información de columnas de un resultado y la devuelve como objeto
    • fbsql_fetch_lengths - Obtiene la longitud de cada salida en un resultado
    • fbsql_fetch_object - Obtiene una fila de resultados como objeto
    • fbsql_fetch_row - Obtiene una fila de resultados como array enumerado
    • fbsql_field_flags - Obtiene los flags de un campo especificado en un resultado
    • fbsql_field_len - Devuleve la longitud de un campo especificado
    • fbsql_field_name - Obtiene el nombre de un campo especificado en un resultado
    • fbsql_field_seek - Mueve el puntero interno de resultado al campo con la posición especificada
    • fbsql_field_table - Obtiene el nombre de la tabla donde se encuentra el campo especificado
    • fbsql_field_type - Obtiene el tipo de campo especificado en un resultado
    • fbsql_free_result - Libera la memoria de resultados
    • fbsql_get_autostart_info - Descripción
    • fbsql_hostname - Obtiene o establece el nombre host de una conexión
    • fbsql_insert_id - Obtiene el valor id generado por la anterior operación INSERT
    • fbsql_list_dbs - Lista las bases de datos disponibles en un servidor FrontBase
    • fbsql_list_fields - Lista los campos de un resultado de FrontBase
    • fbsql_list_tables - Lista las tablas de una base de datos FrontBase
    • fbsql_next_result - Mover el puntero del resultado interno por el resultado de al lado
    • fbsql_num_fields - Obtener el número de campos del resultado
    • fbsql_num_rows - Obtener el número de filas del resultado
    • fbsql_password - Obtiene o asigna el password usado en una conexión
    • fbsql_pconnect - Abrir una conexión persistente a un servidor FrontBase
    • fbsql_query - Realiza una consulta FrontBase
    • fbsql_read_blob - Lee un BLOB de la base de datos
    • fbsql_read_clob - Lee un CLOB de la base de datos
    • fbsql_result - Obtiene los datos de resultado
    • fbsql_rollback - Retrocede una transacción a la base de datos
    • fbsql_rows_fetched - Obtiene el número de filas afectadas por la última consulta
    • fbsql_select_db - Selecciona una base de datos FrontBase
    • fbsql_set_characterset - Cambia el juego de caracteres de entrada/salida
    • fbsql_set_lob_mode - Asigna el modo de recuperación LOB para un set de resultados FrontBase
    • fbsql_set_password - Cambia la contraseña para el usuario especificado
    • fbsql_set_transaction - Asigna el bloqueo y aislamiento de la transacción
    • fbsql_start_db - Inicia una base de datos en un servidor local o remoto
    • fbsql_stop_db - Detiene una base de datos en un servidor local o remoto
    • fbsql_tablename - Alias de fbsql_table_name
    • fbsql_table_name - Obtiene el nombre de una tabla
    • fbsql_username - Obtiene o asigna el nombre de usuario de la conexión
    • fbsql_warnings - Activa o desactiva los warnings de FrontBase
    • fclose - Cierra un puntero a un archivo abierto
    • fdf_add_doc_javascript - Añadir código javascript al documento FDF
    • fdf_add_template - Añadir una plantilla al documento FDF
    • fdf_close - Cierra un documento FDF
    • fdf_create - Crear un nuevo documento FDF
    • fdf_enum_values - Invocar una función definida por el usuario por cada dato del documento
    • fdf_errno - Devuelve el código de error de la última operación sobre fdf
    • fdf_error - Consultar la descripción de un código de error FDF
    • fdf_get_ap - Consultar la publicación de un campo
    • fdf_get_attachment - Extraer un fichero subido por FDF
    • fdf_get_encoding - Consultar el valor de la clave /Encoding
    • fdf_get_file - Obtener el valor de la clave /F
    • fdf_get_flags - Consultar banderas de un campo
    • fdf_get_opt - Consultar un valor del array de opciones de un campo
    • fdf_get_status - Obtener el valor de la clave /STATUS
    • fdf_get_value - Obtener el valor de un campo
    • fdf_get_version - Consulta el número de versión de la API o de un fichero FDF
    • fdf_header - Establecer cabeceras de salida específicas de FDF
    • fdf_next_field_name - Obtener el siguiente nombre de campo
    • fdf_open - Abrir un documento FDF
    • fdf_open_string - Consulta un documento FDF a partir de un string
    • fdf_remove_item - Asignar contenedor para el formulario
    • fdf_save - Guardar un documento FDF
    • fdf_save_string - Devuelve el documento FDF en forma de string
    • fdf_set_ap - Establecer la apariencia de un campo
    • fdf_set_encoding - Asignar codificación de caracteres de FDF
    • fdf_set_file - Establecer el documento PDF en donde desplegar datos FDF
    • fdf_set_flags - Establecer banderas de un campo
    • fdf_set_javascript_action - Añadir una acción javascript a un campo
    • fdf_set_on_import_javascript - Añadir código javascript para ejecutar cuando Acrobat abra el FDF
    • fdf_set_opt - Establecer una opción sobre un campo
    • fdf_set_status - Establecer el valor de la clave /STATUS
    • fdf_set_submit_form_action - Asignar acción a un campo de formulario al enviarse
    • fdf_set_target_frame - Definir contenedor en el que mostrar el formulario
    • fdf_set_value - Establecer el valor de un campo
    • fdf_set_version - Asignar número de versión a un fichero FDF
    • fdiv - Divides two numbers, according to IEEE 754
    • feof - Comprueba si el puntero a un archivo está al final del archivo
    • FFI::addr - Creates an unmanaged pointer to C data
    • FFI::alignof - Gets the alignment
    • FFI::arrayType - Dynamically constructs a new C array type
    • FFI::cast - Performs a C type cast
    • FFI::cdef - Creates a new FFI object
    • FFI::free - Releases an unmanaged data structure
    • FFI::isNull - Checks whether a FFI\CData is a null pointer
    • FFI::load - Loads C declarations from a C header file
    • FFI::memcmp - Compares memory areas
    • FFI::memcpy - Copies one memory area to another
    • FFI::memset - Fills a memory area
    • FFI::new - Creates a C data structure
    • FFI::scope - Instantiates an FFI object with C declarations parsed during preloading
    • FFI::sizeof - Gets the size of C data or types
    • FFI::string - Creates a PHP string from a memory area
    • FFI::type - Creates an FFI\CType object from a C declaration
    • FFI::typeof - Gets the FFI\CType of FFI\CData
    • fflush - Vuelca la salida a un archivo
    • fgetc - Obtiene un carácter de un puntero a un archivo
    • fgetcsv - Obtiene una línea de un puntero a un fichero y la analiza en busca de campos CSV
    • fgets - Obtiene una línea desde el puntero a un fichero
    • fgetss - Obtiene un línea desde un puntero a un archivo y elimina las etiquetas HTML
    • file - Transfiere un fichero completo a un array
    • file:// - Acceso al sistema de ficheros local
    • fileatime - Obtiene el momento del último acceso a un archivo
    • filectime - Obtiene el momento del último cambio del i-nodo de un archivo
    • filegroup - Obtiene el grupo de un archivo
    • fileinode - Obtiene el i-nodo del archivo
    • filemtime - Obtiene el momento de la última modificación de un archivo
    • fileowner - Obtiene el propietario de un archivo
    • fileperms - Obtiene los permisos de un fichero
    • filepro - Lee y verifica el mapa del fichero
    • filepro_fieldcount - Encuentra cuantos campos hay en una base de datos filePro
    • filepro_fieldname - Obtiene el nombre de un campo
    • filepro_fieldtype - Obtiene el tipo de campo
    • filepro_fieldwidth - Obtiene el ancho de un campo
    • filepro_retrieve - Obtiene datos de una base de datos filePro
    • filepro_rowcount - Averigüa cuantas filas hay en una base de datos filePro
    • filesize - Obtiene el tamaño de un fichero
    • FilesystemIterator::current - El fichero actual
    • FilesystemIterator::getFlags - Obtiene el manejo de flags
    • FilesystemIterator::key - Recupera la clave del fichero actual
    • FilesystemIterator::next - Moverse al siguiente fichero
    • FilesystemIterator::rewind - Rebobina hasta volver al inicio
    • FilesystemIterator::setFlags - Establece las flags de manejo
    • FilesystemIterator::__construct - Construye un nuevo iterador filesystem
    • filetype - Obtiene el tipo de fichero
    • file_exists - Comprueba si existe un fichero o directorio
    • file_get_contents - Transmite un fichero completo a una cadena
    • file_put_contents - Escribir datos en un fichero
    • FilterIterator::accept - Comprueba si el elemento actual del iterador es aceptable
    • FilterIterator::current - Obtiene el valor del elemento actual
    • FilterIterator::getInnerIterator - Obtiene el iterador interno
    • FilterIterator::key - Obtiene la clave actual
    • FilterIterator::next - Mueve el iterador a la siguiente posición
    • FilterIterator::rewind - Rebobina el iterador
    • FilterIterator::valid - Comprueba si el elemento actual es válido
    • FilterIterator::__construct - Construye un filterIterator
    • filter_has_var - Comprueba si existe una variable de un tipo concreto existe
    • filter_id - Indica el ID del nombre de filtro que se indique
    • filter_input - Toma una variable externa concreta por su nombre y opcionalmente la filtra
    • filter_input_array - Obtiene variables externas y opcionalmente las filtra
    • filter_list - Devuelve una lista de todos los filtros soportados
    • filter_var - Filtra una variable con el filtro que se indique
    • filter_var_array - Retorna múltiple variables y opcionalmente las filtra
    • finfo::buffer - Alias de finfo_buffer()
    • finfo::file - Alias de finfo_file()
    • finfo::set_flags - Alias de finfo_set_flags()
    • finfo::__construct - Alias de finfo_open
    • finfo_close - Cierra el recurso fileinfo
    • finfo_open - Crea un nuevo recurso fileinfo
    • floatval - Obtener el valor flotante de una variable
    • flock - Bloqueo de ficheros recomendado y portable
    • floor - Redondear fracciones hacia abajo
    • flush - Vaciar el búfer de salida del sistema
    • fmod - Devuelve el resto en punto flotante (módulo) de la división de los argumentos
    • fnmatch - Compara un nombre de fichero con un patrón
    • fopen - Abre un fichero o un URL
    • forward_static_call - Llamar a un método estático
    • forward_static_call_array - Llamar a un método estático y pasar los argumentos como matriz
    • fpassthru - Escribe toda la información restante de un puntero a un archivo
    • fprintf - Escribir una cadena con formato a una secuencia
    • fputcsv - Dar formato CSV a una línea y escribirla en un puntero a un fichero
    • fputs - Alias de fwrite
    • fread - Lectura de un fichero en modo binario seguro
    • frenchtojd - Convierte una fecha del Calendario Republicano Francés a una fecha Juliana
    • fscanf - Analiza la entrada desde un archivo de acuerdo a un formato
    • fseek - Busca sobre un puntero a un fichero
    • fsockopen - Abre una conexión vía sockets a Internet o a un dominio Unix
    • fstat - Obtiene información acerca de un archivo usando un puntero al archivo abierto
    • ftell - Devuelve la posición de lectura/escritura actual del puntero a un fichero
    • ftok - Convertir un nombre de ruta y un identificador de proyecto a una clave IPC de System V
    • ftp:// - Acceso a URLs por FTP(s)
    • ftp_alloc - Reserva espacio para que un archivo sea cargado
    • ftp_append - Append the contents of a file to another file on the FTP server
    • ftp_cdup - Vuelve al directorio padre
    • ftp_chdir - Cambia el directorio actual en un servidor FTP
    • ftp_chmod - Establecer permisos en un archivo via FTP
    • ftp_close - Cierra una conexión FTP
    • ftp_connect - Abre una conexión FTP
    • ftp_delete - Elimina un archivo en el servidor FTP
    • ftp_exec - Solicita la ejecución de un comando en el servidor FTP
    • ftp_fget - Descarga un archivo desde el servidor FTP y lo guarda en un archivo abierto
    • ftp_fput - Carga un archivo abierto en el servidor FTP
    • ftp_get - Descarga un archivo desde el servidor FTP
    • ftp_get_option - Recupera varios comportamientos de tiempo de ejecución de la secuencia FTP actual
    • ftp_login - Inicia sesión en una conexión FTP
    • ftp_mdtm - Devuelve el tiempo de la última modificación del archivo dado
    • ftp_mkdir - Crea un directorio
    • ftp_mlsd - Returns a list of files in the given directory
    • ftp_nb_continue - Continúa recuperando/enviando un archivo (modo no-bloqueo)
    • ftp_nb_fget - Recupera un archivo desde el servidor FTP y lo escribe en un archivo abierto (modo no-bloqueo)
    • ftp_nb_fput - Almacena un archivo desde un archivo abierto en el servidor FTP (modo no-bloqueo)
    • ftp_nb_get - Recupera un archivo desde el servidor FTP y lo escribe en un archivo local (modo no-bloqueo)
    • ftp_nb_put - Almacena un archivo en el servidor FTP (modo no-bloqueo)
    • ftp_nlist - Devuelve una lista de los archivos que se encuentran en el directorio especificado
    • ftp_pasv - Activa o desactiva el modo pasivo
    • ftp_put - Carga un archivo al servidor FTP
    • ftp_pwd - Devuelve el nombre del directorio actual
    • ftp_quit - Alias de ftp_close
    • ftp_raw - Envía un comando arbitrario a un servidor FTP
    • ftp_rawlist - Devuelve una lista detallada de archivos en el directorio especificado
    • ftp_rename - Renombra un archivo o un directorio en el servidor FTP
    • ftp_rmdir - Elimina un directorio
    • ftp_set_option - Establecer varias opciones FTP de tiempo de ejecución
    • ftp_site - Envía un comando SITE al servidor
    • ftp_size - Devuelve el tamaño del archivo dado
    • ftp_ssl_connect - Abre una conexión segura SSL-FTP
    • ftp_systype - Devuelve el identificador del tipo de sistema del servidor FTP remoto
    • ftruncate - Trunca un archivo a una longitud dada
    • function_exists - Devuelve true si la función dada ha sido definida
    • func_get_arg - Devuelve un elemento de una lista de argumentos
    • func_get_args - Devuelve un array que se compone de una lista de argumentos de función
    • func_num_args - Devuelve el número de argumentos pasados a la función
    • fwrite - Escritura de un archivo en modo binario seguro
  • g
    • gc_collect_cycles - Fuerza la recolección de los ciclos de basura existentes
    • gc_disable - Desactiva el recolector de referencia circular
    • gc_enable - Activa el colector de referencia circular
    • gc_enabled - Devuelve el estado del colector de referencia circular
    • gc_mem_caches - Reclaims memory used by the Zend Engine memory manager
    • gc_status - Gets information about the garbage collector
    • gd_info - Reunir información acerca de la biblioteca GD instalada actualmente
    • GearmanClient::addOptions - Añade opciones al cliente
    • GearmanClient::addServer - Añade un servidor de trabajos al cliente
    • GearmanClient::addServers - Añade una lista de servidores de trabajos al cliente
    • GearmanClient::addTask - Añade una tarea para ser ejecutada en paralelo
    • GearmanClient::addTaskBackground - Ejecuta una tarea en segundo plano para ser ejecutada en paralelo
    • GearmanClient::addTaskHigh - Añade una tarea de alta prioridad para ser ejecutada en paralelo
    • GearmanClient::addTaskHighBackground - Añade una tarea de alta prioridad ejecutada en segundo plano y en paralelo
    • GearmanClient::addTaskLow - Añade una tarea de baja prioridad para ejecutar en paralelo
    • GearmanClient::addTaskLowBackground - Añade una tarea de baja prioridad en segundo plano para ser ejecutada en paralelo
    • GearmanClient::addTaskStatus - Añade una tarea para obtener el estado
    • GearmanClient::clearCallbacks - Elimina todas las funciones de retorno de llamada
    • GearmanClient::clone - Crea una copia de un objeto GearmanClient
    • GearmanClient::context - Obtiene el contexto de la aplicación
    • GearmanClient::data - Retorna los datos de aplicación (obsoleto)
    • GearmanClient::do - Ejecuta una sola tarea y retorna el resultado [obsoleto]
    • GearmanClient::doBackground - Ejecuta una tarea en segundo plano
    • GearmanClient::doHigh - Ejecuta una tarea de prioridad alta
    • GearmanClient::doHighBackground - Ejecuta una tarea de alta prioridad en segundo plano
    • GearmanClient::doJobHandle - Obtiene el manejador de trabajo para la tarea en ejecución
    • GearmanClient::doLow - Ejecuta una tarea de baja prioridad
    • GearmanClient::doLowBackground - Ejecuta una tarea de prioridad baja en segundo plano
    • GearmanClient::doNormal - Ejecutar una única tarea y devolver un resultado
    • GearmanClient::doStatus - Obtiene el estado de la tarea en ejecución
    • GearmanClient::echo - Envía datos a todos los servidores de trabajo para ver si retornan [obsoleto]
    • GearmanClient::error - Retorna un string con el último error encontrado
    • GearmanClient::getErrno - Obtiene un valor errno
    • GearmanClient::jobStatus - Obtiene el estado de un trabajo en segundo plano
    • GearmanClient::ping - Envar datos a todos los servidores de trabajo para ver si los repiten
    • GearmanClient::removeOptions - Elimina opciones del cliente
    • GearmanClient::returnCode - Obtiene el último código de retorno de Gearman
    • GearmanClient::runTasks - Ejecuta una lista de tareas en paralelo
    • GearmanClient::setClientCallback - Función de llamada de retorno cuando hay un paquete de datos para una tarea (obsoleto)
    • GearmanClient::setCompleteCallback - Especifica una función a ser llamada cuando se complete una tarea
    • GearmanClient::setContext - Establece el contexto de la aplicación
    • GearmanClient::setCreatedCallback - Establece una llamada de retornopara cuando se encola una tarea
    • GearmanClient::setData - Establece los datos de aplicación (obsoleto)
    • GearmanClient::setDataCallback - Función de llamada de retorno para cuando hay un paquete de datos para la tarea
    • GearmanClient::setExceptionCallback - Establece una llamada de retorno para excepciones del trabajador
    • GearmanClient::setFailCallback - Establece una llamada de retorno para cuando falla un trabajo
    • GearmanClient::setOptions - Establece opciones del cliente
    • GearmanClient::setStatusCallback - Establece una llamada de retorno para obtener el estado de una tarea
    • GearmanClient::setTimeout - Establece el tiempo máximo de inactividad para actividad de entrada/salida en el socket
    • GearmanClient::setWarningCallback - Establece una llamada de retorno para los warnings del trabajador
    • GearmanClient::setWorkloadCallback - Establece una llamada de retorno para aceptar actualizaciones incrementales de datos
    • GearmanClient::timeout - Obtiene el tiempo máximo de inactividad de entrada/salida para el socket
    • GearmanClient::wait - Wait for I/O activity on all connections in a client
    • GearmanClient::__construct - Crea una instancia de GearmanClient
    • GearmanJob::complete - Envía el resultado y el estado completo (obsoleto)
    • GearmanJob::data - Envía datos para un trabajo en ejecución (obsoleto)
    • GearmanJob::exception - Envía una excepción para un trabajo en ejecución (obsoleto)
    • GearmanJob::fail - Envía el estado de fallo (obsoleto)
    • GearmanJob::functionName - Retorna el nombre de la función
    • GearmanJob::handle - Retorna el manejador para el trabajo
    • GearmanJob::returnCode - Obtiene el último código de retorno
    • GearmanJob::sendComplete - Envía el resultado y el estado completado
    • GearmanJob::sendData - Envía datos para un trabajo en ejecución
    • GearmanJob::sendException - Envía una excepción para un trabajo en ejecución
    • GearmanJob::sendFail - Envía el estado de fallo
    • GearmanJob::sendStatus - Envía el estado
    • GearmanJob::sendWarning - Envía una advertencia
    • GearmanJob::setReturn - Establece el valor de retorno
    • GearmanJob::status - Envía el estado (obsoleto)
    • GearmanJob::unique - Obtiene el identificador único
    • GearmanJob::warning - Envía un aviso (obsoleto)
    • GearmanJob::workload - Obtiene la carga de trabajo
    • GearmanJob::workloadSize - Obtiene el tamaño de la carga de trabajo
    • GearmanJob::__construct - Crea una instancia de GearmanJob
    • GearmanTask::create - Crea una tarea (obsoleto)
    • GearmanTask::data - Obtiene los datos retornados para una tarea
    • GearmanTask::dataSize - Obtiene el tamaño de la información retornada
    • GearmanTask::function - Obtiene el nombre de la función asociada (obsoleto)
    • GearmanTask::functionName - Retorna el nombre de la función asociada
    • GearmanTask::isKnown - Determina si la tarea es conocida
    • GearmanTask::isRunning - Comprueba si la tarea está siendo ejecutada
    • GearmanTask::jobHandle - Retorna el manejador del trabajo
    • GearmanTask::recvData - Guarda un trabajo o los datos resultantes de una tarea en un buffer
    • GearmanTask::returnCode - Retorna el último código de error
    • GearmanTask::sendData - Envía datos a una tarea (obsoleto)
    • GearmanTask::sendWorkload - Envía datos a una tarea
    • GearmanTask::taskDenominator - Obtiene el denominador del porcentaje de tarea completada
    • GearmanTask::taskNumerator - Retorna el numerador del tanto por ciento completado de la tarea, expresado como una fracción
    • GearmanTask::unique - Obtiene el identificador único de una tarea
    • GearmanTask::uuid - Obtiene el identificador único de una tarea (obsoleto)
    • GearmanTask::__construct - Crea una instancia de GearmanTask
    • GearmanWorker::addFunction - Registra y añade una función de retorno
    • GearmanWorker::addOptions - Añade opciones al trabajador
    • GearmanWorker::addServer - Añade un servidor de trabajo
    • GearmanWorker::addServers - Añade servidores de trabajo
    • GearmanWorker::clone - Crea una copia del trabajador
    • GearmanWorker::echo - Comprueba la respuesta de un servidor de trabajo
    • GearmanWorker::error - Retorna el último error que ha ocurrido
    • GearmanWorker::getErrno - Obtiene el código de error
    • GearmanWorker::options - Retorna las opciones del trabajador
    • GearmanWorker::register - Registra una función en el servidor de trabajo
    • GearmanWorker::removeOptions - Elimina las opciones del trabajador
    • GearmanWorker::returnCode - Obtiene el último código de retorno de Gearman
    • GearmanWorker::setId - Asigna un identificador al trabajador de tal forma que pueda ser rastreado cuando se solicite a gearmand la lista de los trabajadores disponibles
    • GearmanWorker::setOptions - Establece las opciones del trabajador
    • GearmanWorker::setTimeout - Establece un tiempo de espera máximo para actividad de entrada/salida del socket
    • GearmanWorker::timeout - Retorna el tiempo máximo de espera para actividad de entrada/salida del socket
    • GearmanWorker::unregister - Elimina el registro del nombre de una función en los servidores de trabajo
    • GearmanWorker::unregisterAll - Elimina el registro de todas los nombres de funciones en los servidores de trabajo
    • GearmanWorker::wait - Espera cualquier actividad de uno de los servidores de trabajo
    • GearmanWorker::work - Espera y realiza un trabajo
    • GearmanWorker::__construct - Crea una instancia GearmanWorker
    • Gender\Gender::connect - Conecta con un diccionario de nombres externo
    • Gender\Gender::country - Obtener la representación textual de un país
    • Gender\Gender::get - Obtener el género de un nombre
    • Gender\Gender::isNick - Comprueba si name0 es un alias de name1
    • Gender\Gender::similarNames - Obtener nombres similares
    • Gender\Gender::__construct - Construye un objeto Gender
    • Generator::current - Obtener el valor producido
    • Generator::getReturn - Obtener el valor devuelto de un generador
    • Generator::key - Obtener la clave generada
    • Generator::next - Continua la ejecución del generador
    • Generator::rewind - Rebobina el iterador
    • Generator::send - Enviar un valor al generador
    • Generator::throw - Lanzar una excepción dentro generador
    • Generator::valid - Verificar si el iterador ha sido cerrado
    • Generator::__wakeup - Serialize callback
    • geoip_asnum_by_name - Obtiene los Números de sistemas autónomos (ASN)
    • geoip_continent_code_by_name - Obtiene la abreviación de dos letras del continente
    • geoip_country_code3_by_name - Obtiene la abreviación de tres letras del país
    • geoip_country_code_by_name - Obtiene la abreviación de dos letras del país
    • geoip_country_name_by_name - Obtiene el nombre del país completo
    • geoip_database_info - Obtener información de la base de datos GeoIP
    • geoip_db_avail - Determina si la base de datos GeoIP está disponible
    • geoip_db_filename - Devuelve el nombre del fichero correspondiente a la base de datos de GeoIP
    • geoip_db_get_all_info - Devuelve información detallada sobre todos los tipos de bases de datos GeoIP
    • geoip_domain_by_name - Obtener el nombre de dominio de segundo nivel
    • geoip_id_by_name - Obtiene el tipo de conexión a Internet
    • geoip_isp_by_name - Obtiene el nombre del proveedor de servicios de Internet (ISP)
    • geoip_netspeedcell_by_name - Obtener la velocidad de la conexión a Internet
    • geoip_org_by_name - Consultar nombre de la organización
    • geoip_record_by_name - Devuelve información detallada de la Ciudad encontrada en la base de datos de GeoIP
    • geoip_region_by_name - Consultar el código de país y de región
    • geoip_region_name_by_code - Devuelve, a partir de una combinación de código de país y de región, el nombre de región
    • geoip_setup_custom_directory - Establecer un directorio personalizado para la base de datos de GeoIP
    • geoip_time_zone_by_country_and_region - Devuelve, a partir de una combinación de país y región, la zona horaria
    • getallheaders - Recupera todas las cabeceras de petición HTTP
    • getcwd - Obtiene el directorio actual en donde se esta trabajando
    • getdate - Obtener información de la fecha/hora
    • getenv - Obtiene el valor de una variable de entorno
    • gethostbyaddr - Obtener el nombre del host de Internet correspondiente a una dirección IP dada
    • gethostbyname - Obtener la dirección IPv4 que corresponde a un nombre de host de Internet dado
    • gethostbynamel - Obtener una lista de direcciones IPv4 que corresponde a un nombre de host de Internet dado
    • gethostname - Obtiene el nombre de host
    • getimagesize - Obtener el tamaño de una imagen
    • getimagesizefromstring - Obtener el tamaño de una imagen desde una cadena
    • getlastmod - Obtiene la hora de la última modificación de la página
    • getmxrr - Obtener los registros MX correspondientes a un nombre de host de Internet
    • getmygid - Obtener el GID del dueño del script PHP
    • getmyinode - Obtiene el inode del script actual
    • getmypid - Obtiene el ID del proceso PHP
    • getmyuid - Obtiene el UID del dueño del script PHP
    • getopt - Obtiene las opciones de la lista de argumentos de la línea de comandos
    • getprotobyname - Obtener el número de protocolo asociado con el nombre de protocolo
    • getprotobynumber - Obtiene el nombre de protocolo asociado con un número de protocolo
    • getrandmax - Mostrar el mayor valor aleatorio posible
    • getrusage - Obtiene el uso de los recursos actuales
    • getservbyname - Obtener el número de puerto asociado con un servicio y protocolo de Internet
    • getservbyport - Obtener el servicio de Internet que corresponde con el puerto y protocolo
    • gettext - Consultar un mensaje en el dominio actual
    • gettimeofday - Obtener la hora actual
    • gettype - Obtener el tipo de una variable
    • get_browser - Indica de lo que es capaz el navegador del usuario
    • get_called_class - El nombre de la clase enlazada estáticamente en tiempo de ejecución ("Late State Binding")
    • get_cfg_var - Obtiene el valor de una opción de configuración de PHP
    • get_class - Devuelve el nombre de la clase de un objeto
    • get_class_methods - Obtiene los nombres de los métodos de una clase
    • get_class_vars - Obtener las propiedades predeterminadas de una clase
    • get_current_user - Obtiene el nombre del propietario del script PHP actual
    • get_declared_classes - Devuelve una matriz con los nombres de las clases definidas
    • get_declared_interfaces - Devuelve un array con todas las interfaces declaradas
    • get_declared_traits - Devuelve un array de todos los traits declarados
    • get_defined_constants - Devuelve un array asociativo con los nombres de todas las constantes y sus valores
    • get_defined_functions - Devuelve un array de todas las funciones definidas
    • get_defined_vars - Devuelve una matriz con todas las variables definidas
    • get_extension_funcs - Devuelve una matriz con los nombres de funciones de un módulo
    • get_headers - Recupera todas las cabeceras enviadas por el servidor en respuesta a una petición HTTP
    • get_html_translation_table - Devuelve la tabla de traducción utilizada por htmlspecialchars y htmlentities
    • get_included_files - Devuelve un array con los nombres de los archivos incluidos o requeridos
    • get_include_path - Obtiene la opción de configuración include_path actual
    • get_loaded_extensions - Devuelve un array con los nombres de todos los módulos compilados y cargados
    • get_magic_quotes_gpc - Obtiene el valor actual de configuración de magic_quotes_gpc
    • get_magic_quotes_runtime - Obtiene el valor de configuración activo actual de magic_quotes_runtime
    • get_meta_tags - Extrae todo el contenido de atributos de etiquetas meta de un archivo y devuelve un array
    • get_object_vars - Obtiene las propiedades del objeto dado
    • get_parent_class - Recupera el nombre de la clase padre de un objeto o clase
    • get_required_files - Alias de get_included_files
    • get_resources - Returns active resources
    • get_resource_id - Returns an integer identifier for the given resource
    • get_resource_type - Devuelve el tipo de recurso
    • glob - Buscar coincidencias de nombres de ruta con un patrón
    • glob:// - Encuentra las rutas que coincidan con el patrón
    • GlobIterator::count - Obtiene el número de directorios y ficheros
    • GlobIterator::__construct - Construye un directorio usando glob
    • Gmagick::addimage - Añade una nueva imagen a la lista de imágenes del objeto Gmagick
    • Gmagick::addnoiseimage - Añade ruido aleatorio a la imagen
    • Gmagick::annotateimage - Anota una imagen con texto
    • Gmagick::blurimage - Añade un filtro de borrosidad a la imagen
    • Gmagick::borderimage - Rodea la imagen con un borde
    • Gmagick::charcoalimage - Simula un dibujo a carboncillo
    • Gmagick::chopimage - Elimina una región de una imagen y la recorta
    • Gmagick::clear - Limpia todos los recursos asociados con el objeto Gmagick
    • Gmagick::commentimage - Añade un comentario a una imagen
    • Gmagick::compositeimage - Compone una imagen en otra
    • Gmagick::cropimage - Extrae una región de la imagen
    • Gmagick::cropthumbnailimage - Crea una miniatura recortada
    • Gmagick::current - Devuelve la refencia al objeto Gmagick acutal
    • Gmagick::cyclecolormapimage - Desplaza un mapa de color de una imagen
    • Gmagick::deconstructimages - Devuelve ciertas diferencias de píxeles entre imágenes
    • Gmagick::despeckleimage - Reduce el ruido granular de una imagen
    • Gmagick::destroy - Destruye un objeto Gmagick
    • Gmagick::drawimage - Renderiza el objeto GmagickDraw en la imagen actual
    • Gmagick::edgeimage - Mejora los bordes dentro de una imagen
    • Gmagick::embossimage - Devuelve una imagen en escala de grises con un efecto tridimensional
    • Gmagick::enhanceimage - Mejora la calidad de una imagen con ruido
    • Gmagick::equalizeimage - Ecualiza el histograma de la imagen
    • Gmagick::flipimage - Crea una imagen espejo vertical
    • Gmagick::flopimage - Crea una imagen espejo horizontal
    • Gmagick::frameimage - Añade un borde tridimensional simulado
    • Gmagick::gammaimage - Corrección gamma de una imagen
    • Gmagick::getcopyright - Devuelve el copyright de la API GraphicsMagick como una cadena
    • Gmagick::getfilename - El nombre de archivo asociado a una secuencia de imágenes
    • Gmagick::getimagebackgroundcolor - Devuelve el color de fondo de la imagen
    • Gmagick::getimageblueprimary - Devuelve el punto primario azul de la cromaticidad
    • Gmagick::getimagebordercolor - Devuelve el color del borde de la imagen
    • Gmagick::getimagechanneldepth - Obtiene la profundidad de un canal de imagen en particular
    • Gmagick::getimagecolors - Devuelve el color del índice del mapa de color especificado
    • Gmagick::getimagecolorspace - Obtiene el espacio de colores de la imagen
    • Gmagick::getimagecompose - Devuelve el operador de composición asociado a la imagen
    • Gmagick::getimagedelay - Obetiene el retraso de la imagen
    • Gmagick::getimagedepth - Obtiene la profundidad de la imagen
    • Gmagick::getimagedispose - Obtiene el método de disposición de la imagen
    • Gmagick::getimageextrema - Obtiene los extremos de la imagen
    • Gmagick::getimagefilename - Devuelve el nombre de archivo de una imagen en particular de una secuencia
    • Gmagick::getimageformat - Devuelve el formato de una imagen en particular de una secuencia
    • Gmagick::getimagegamma - Obtiene el valor gamma de la imagen
    • Gmagick::getimagegreenprimary - Devuelve el punto primario verde de la cromaticidad
    • Gmagick::getimageheight - Devuelve el alto de la imagen
    • Gmagick::getimagehistogram - Obtiene el histograma de la imagen
    • Gmagick::getimageindex - Obtiene el índice de la imagen activa actual
    • Gmagick::getimageinterlacescheme - Obtiene la combinación de entrelazado de la imagen
    • Gmagick::getimageiterations - Obtiene las iteraciones de la imagen
    • Gmagick::getimagematte - Comprobar si la imagen tiene un canal mate
    • Gmagick::getimagemattecolor - Devuelve el color mate de la imagen
    • Gmagick::getimageprofile - Devuelve el perfil nominado de la imagen
    • Gmagick::getimageredprimary - Devuelve el punto primario rojo de la cromaticidad
    • Gmagick::getimagerenderingintent - Obtiene la propuesta de renderización de la imagen
    • Gmagick::getimageresolution - Obtiene la resolución X e Y de la imagen
    • Gmagick::getimagescene - Obtiene la escena de la imagen
    • Gmagick::getimagesignature - Genera un resumen de un mensaje SHA-256
    • Gmagick::getimagetype - Obtiene el tipo de imagen potencial.
    • Gmagick::getimageunits - Obtiene las unidades de resolución de la imagen
    • Gmagick::getimagewhitepoint - Devuelve el punto blanco de la cromaticidad
    • Gmagick::getimagewidth - Devuelve el ancho de la imagen
    • Gmagick::getpackagename - Devuelve el nombre del paquete de GraphicsMagick
    • Gmagick::getquantumdepth - Obtiene la profundidad de la cuantía de Gmagick como una cadena
    • Gmagick::getreleasedate - Devuelve la fecha de distribución de GraphicsMagick como una cadena
    • Gmagick::getsamplingfactors - Obtiene el factor de muestreo horizontal y vertical
    • Gmagick::getsize - Devuelve el tamaño asociado con el objeto Gmagick
    • Gmagick::getversion - Devuelve la versión de la API GraphicsMagick
    • Gmagick::hasnextimage - Comprueba si el objeto tiene más imágenes
    • Gmagick::haspreviousimage - Verifica si el objeto tiene una imagen previa
    • Gmagick::implodeimage - Crea una nueva imagen como una copia
    • Gmagick::labelimage - Añade una etiqueta a una imagen
    • Gmagick::levelimage - Ajusta los niveles de la imagen
    • Gmagick::magnifyimage - Escala una imagen x2 proporcionalmente
    • Gmagick::mapimage - Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
    • Gmagick::medianfilterimage - Aplica un filtro digital
    • Gmagick::minifyimage - Escala una imagen proporcionalmente a la mitad de su tamaño
    • Gmagick::modulateimage - Controla el brillo, la saturación y el tono
    • Gmagick::motionblurimage - Simula borrosidad en movimiento
    • Gmagick::newimage - Crea una nueva imagen
    • Gmagick::nextimage - Moverse a la siguiente imagen
    • Gmagick::normalizeimage - Mejora el contraste de una imagen a color
    • Gmagick::oilpaintimage - Simula una pintura al óleo
    • Gmagick::previousimage - Moverse a la imagen previa del objeto
    • Gmagick::profileimage - Añade o elimina un perfil de una imagen
    • Gmagick::quantizeimage - Analiza los colores dentro de una imagen de referencia
    • Gmagick::quantizeimages - Analiza los colores dentro de una secuencia de imágenes
    • Gmagick::queryfontmetrics - Devuelve una matriz que representa las métricas de la fuente
    • Gmagick::queryfonts - Devuelve las fuentes configuradas
    • Gmagick::queryformats - Devuelve los formatos admitidos por Gmagick
    • Gmagick::radialblurimage - Hace borrosa de forma radial una imagen
    • Gmagick::raiseimage - Crea un efecto de botón en 3D simulado
    • Gmagick::read - Lee una imagen desde un nombre de archivo
    • Gmagick::readimage - Lee una imagen desde un nombre de archivo
    • Gmagick::readimageblob - Lee una imagen desde una cadena binaria
    • Gmagick::readimagefile - Lee una imagen desde un descriptor de archivo abierto
    • Gmagick::reducenoiseimage - Suaviza los contornos de una imagen
    • Gmagick::removeimage - Elimina una imagen de la lista de imágenes
    • Gmagick::removeimageprofile - Elimina el perfil nombrado de la imagen y lo devuelve
    • Gmagick::resampleimage - Re-muestrea la imagen a la resolución deseada
    • Gmagick::resizeimage - Escala una imagen
    • Gmagick::rollimage - Compensa una imagen
    • Gmagick::rotateimage - Rota una imagen
    • Gmagick::scaleimage - Escala el tamaño de una imagen
    • Gmagick::separateimagechannel - Separa un canal de la imagen
    • Gmagick::setCompressionQuality - Establece la calidad de compresión predeterminada del objeto
    • Gmagick::setfilename - Establece el nombre de archivo antes de que se lea o escriba una imagen
    • Gmagick::setimagebackgroundcolor - Establece el color de fondo de la imagen
    • Gmagick::setimageblueprimary - Establece el punto primario azul de la cromaticidad de la imagen
    • Gmagick::setimagebordercolor - Establece el color de borde de la imagen
    • Gmagick::setimagechanneldepth - Establece la profundidad de una canal de imagen en particular
    • Gmagick::setimagecolorspace - Establece el espacio de color de una imagen
    • Gmagick::setimagecompose - Establece el operador de composción de una imagen
    • Gmagick::setimagedelay - Establece el retardo de una imagen
    • Gmagick::setimagedepth - Establece la profundidad de una imagen
    • Gmagick::setimagedispose - Establece el método de disposición de una imagen
    • Gmagick::setimagefilename - Establece el nombre de archivo de una imagen en particular en una secuencia
    • Gmagick::setimageformat - Establece el formato de una imagen en particular
    • Gmagick::setimagegamma - Establece el valor gamma de la imagen
    • Gmagick::setimagegreenprimary - Establece el punto primario verde de la cromaticidad de la imagen
    • Gmagick::setimageindex - Establece la posición del iterador en la lista de imágenes especificada con el parámetro index
    • Gmagick::setimageinterlacescheme - Establece la combinación de entrelazado de la imagen
    • Gmagick::setimageiterations - Establece las iteraciones de la imagen
    • Gmagick::setimageprofile - Añade un perfil nombrado al objeto Gmagick
    • Gmagick::setimageredprimary - Establece el punto primario rojo de la cromaticidad de la imagen
    • Gmagick::setimagerenderingintent - Establece el propósito de renderización de la imagen
    • Gmagick::setimageresolution - Establece la resolución de la imagen
    • Gmagick::setimagescene - Establece la escena de la imagen
    • Gmagick::setimagetype - Establece el tipo de imagen
    • Gmagick::setimageunits - Establece las unidades de resolución de la imagen
    • Gmagick::setimagewhitepoint - Establece el punto blanco de cromaticidad de la imagen
    • Gmagick::setsamplingfactors - Establece los factores de muestreo de la imagen
    • Gmagick::setsize - Establece el tamaño del objeto Gmagick
    • Gmagick::shearimage - Crea un paralelogramo
    • Gmagick::solarizeimage - Aplica un efecto de solarización a la imagen
    • Gmagick::spreadimage - Despalza aleatoriamente cada píxel en un bloque
    • Gmagick::stripimage - Elimina todos los perfiles y comentarios de una imagen
    • Gmagick::swirlimage - Arremolina los píxeles desde el centro de la imagen
    • Gmagick::thumbnailimage - Cambia el tamaño de una imagen
    • Gmagick::trimimage - Elimina los extremos de la imagen
    • Gmagick::write - Alias de Gmagick::writeimage
    • Gmagick::writeimage - Escribe una imagen al nombre de archivo especificado
    • Gmagick::__construct - El constructor Gmagick
    • GmagickDraw::annotate - Dibuja texto en la imagen
    • GmagickDraw::arc - Dibuja un arco
    • GmagickDraw::bezier - Dibuja una curva Bézier
    • GmagickDraw::ellipse - Dibuja una elipse en la imagen
    • GmagickDraw::getfillcolor - Devuelve el color de relleno
    • GmagickDraw::getfillopacity - Devuelve la opacidad usada cuando se dibuja
    • GmagickDraw::getfont - Devuelve el tipo de letra
    • GmagickDraw::getfontsize - Devuelve el tamaño de punto de la fuente
    • GmagickDraw::getfontstyle - Devuelve el estilo de fuente
    • GmagickDraw::getfontweight - Devuelve el peso de la fuente
    • GmagickDraw::getstrokecolor - Devuelve el color usado para contornear perfiles de objetos
    • GmagickDraw::getstrokeopacity - Devuelve la opacidad de los perfiles del objeto contorneado
    • GmagickDraw::getstrokewidth - Devuelve el ancho del contorno usado para dibular perfiles del objeto
    • GmagickDraw::gettextdecoration - Devuelve la decoración del texto
    • GmagickDraw::gettextencoding - Devuelve el conjunto de codificación usado para anotaciones de texto
    • GmagickDraw::line - Dibuja una línea en la imagen
    • GmagickDraw::point - Dibuja un punto
    • GmagickDraw::polygon - Dibuja un polígono
    • GmagickDraw::polyline - Dibuja una polilínea
    • GmagickDraw::rectangle - Dibuja un rectángulo
    • GmagickDraw::rotate - Aplica la rotación especificada al espacio de coordenadas actual
    • GmagickDraw::roundrectangle - Dibuja un rectángulo redondeado
    • GmagickDraw::scale - Ajusta el factor de escala
    • GmagickDraw::setfillcolor - Establece el color de relleno a usar cuando se dibujan objetos rellenos
    • GmagickDraw::setfillopacity - Establece la opacidad del relleno
    • GmagickDraw::setfont - Establece la fuente especificada completamente a usar cuando se anota texto
    • GmagickDraw::setfontsize - Establece el tamaño de punto de la fuente a usar cuando se anota texto
    • GmagickDraw::setfontstyle - Establece el estilo de fuente a usar cuando se anota texto
    • GmagickDraw::setfontweight - Establece el peso de la fuente
    • GmagickDraw::setstrokecolor - Establece el color usado para contornear los perfiles del objeto
    • GmagickDraw::setstrokeopacity - Especifica la opacidad del los perfiles del objeto contorneado
    • GmagickDraw::setstrokewidth - Establece el ancho del contorno usado para dibujar los perfiles del objeto.
    • GmagickDraw::settextdecoration - Especifica una decoración
    • GmagickDraw::settextencoding - Especifica el conjunto de codificación del texto
    • GmagickPixel::getcolor - Devuelve el color
    • GmagickPixel::getcolorcount - Devuelve la cuenta de color asociada a este color
    • GmagickPixel::getcolorvalue - Obtiene el valor normalizado del canal de color proporcionado
    • GmagickPixel::setcolor - Establece el color
    • GmagickPixel::setcolorvalue - Establece el valor normalizado de uno de los canales
    • GmagickPixel::__construct - El constructor GmagickPixel
    • gmdate - Formatea una fecha/hora GMT/UTC
    • gmmktime - Obtener la marca temporal de Unix para una fecha GMT
    • gmp_abs - Valor absoluto
    • gmp_add - Agrega números
    • gmp_and - AND a nivel de bit
    • gmp_binomial - Calculates binomial coefficient
    • gmp_clrbit - Limpia un bit
    • gmp_cmp - Compara los números
    • gmp_com - Calcula uno de los complementos
    • gmp_div - Alias de gmp_div_q
    • gmp_divexact - División exacta de números
    • gmp_div_q - Divide los números
    • gmp_div_qr - Divide los números y obtiene el cociente y resto
    • gmp_div_r - El resto de la división de los números
    • gmp_export - Exportar a un string binario
    • gmp_fact - Factorial
    • gmp_gcd - Calcula el máximo común divisor
    • gmp_gcdext - Calcula el máximo común divisor y multiplicadores
    • gmp_hamdist - Distancia Hamming
    • gmp_import - Importar de un string binario
    • gmp_init - Crea un número GMP
    • gmp_intval - Convertir un número GMP a entero
    • gmp_invert - Inverso del modulo
    • gmp_jacobi - Símbolo Jacobi
    • gmp_kronecker - Kronecker symbol
    • gmp_lcm - Calculate LCM
    • gmp_legendre - Símbolo Legendre
    • gmp_mod - Modulo de operación
    • gmp_mul - Multiplicación de números
    • gmp_neg - Número negativo
    • gmp_nextprime - Encuentra el siguiente número primo
    • gmp_or - Nivel de bit OR
    • gmp_perfect_power - Perfect power check
    • gmp_perfect_square - Comprueba el cuadrado perfecto
    • gmp_popcount - Cuenta la población
    • gmp_pow - Aumenta el número a la potencia
    • gmp_powm - Eleva un número a la potencia con modulo
    • gmp_prob_prime - Revisa si el número es "probablemente primo"
    • gmp_random - Numero al azar
    • gmp_random_bits - Un número aleatorio
    • gmp_random_range - Un número aleatorio
    • gmp_random_seed - Establece la semilla RNG
    • gmp_root - Tomar la parte entera de una raíz enésima
    • gmp_rootrem - Tomar la parte entera y el resto de una raíz enésima
    • gmp_scan0 - Escanear para 0
    • gmp_scan1 - Escanear para 1
    • gmp_setbit - Establece el bit
    • gmp_sign - El símbolo del número
    • gmp_sqrt - Calcula la raíz cuadrada
    • gmp_sqrtrem - Raíz cuadrada con resto
    • gmp_strval - Convierte un número GMP a cadena
    • gmp_sub - Resta los números
    • gmp_testbit - Prueba si un bit es establecido
    • gmp_xor - Nivel de bit XOR
    • gmstrftime - Formatear una fecha/hora GMT/UTC según la configuración local
    • gnupg_adddecryptkey - Añade una llave para desencriptar
    • gnupg_addencryptkey - Añade una llave para encriptar
    • gnupg_addsignkey - Añade una llave para firmar
    • gnupg_cleardecryptkeys - Elimina todas las llaves establecidas anteriormente para desencriptar
    • gnupg_clearencryptkeys - Elimina todas las llaves establecidas anteriormente paraencriptar
    • gnupg_clearsignkeys - Elimina todas las llaves establecidas anteriormente para firmar
    • gnupg_decrypt - Desencripta un texto dado
    • gnupg_decryptverify - Desencripta y verifica un texto dado
    • gnupg_encrypt - Encripta el texto dado
    • gnupg_encryptsign - Encripta y firma un texto dado
    • gnupg_export - Exporta una llave
    • gnupg_geterror - Retorna el texto de error si una función falla
    • gnupg_getprotocol - Retorna el protocolo activo actualmente para todas las operaciones
    • gnupg_import - Importa una llave
    • gnupg_init - Inicializa una conexión
    • gnupg_keyinfo - Retorna un array con información sobre todas las llaves que coinciden con un patrón dado
    • gnupg_setarmor - Activa o desactiva la salida blindada
    • gnupg_seterrormode - Fija el modo para error_reporting
    • gnupg_setsignmode - Fija el modo para firmar
    • gnupg_sign - Firma un texto dado
    • gnupg_verify - Verifica un texto firmado
    • grapheme_extract - Función para extraer una secuencia de un clúster de grafemas predeterminados desde un buffer de texto, que puede estar codificado en UTF-8
    • grapheme_stripos - Buscar la posición (en unidades de grafema) de la primera coincidencia de una cadena insensible a mayúsculas-minúsculas
    • grapheme_stristr - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" insensible a mayúsculas-minúsculas hasta el final de "pajar"
    • grapheme_strlen - Obtener la longitud de un string en unidades de grafema
    • grapheme_strpos - Buscar la posición (en unidades de grafema) de la primera ocurrencia de una cadena
    • grapheme_strripos - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena insensible a mayúsculas-minúsculas
    • grapheme_strrpos - Buscar la posición (en unidades de grafema) de la última coincidencia de una cadena
    • grapheme_strstr - Devolver parte de la cadena "pajar" desde la primera coincidencia de la cadena "aguja" hasta el final de "pajar"
    • grapheme_substr - Devolver parte de una cadena
    • gregoriantojd - Convierte una fecha Gregoriana en Fecha Juliana
    • gzclose - Cierra el apuntador de un archivo gz abierto
    • gzcompress - Comprime una cadena
    • gzdecode - Decodifica una cadena comprimida con gzip
    • gzdeflate - Comprime una cadena
    • gzencode - Crea una cadena comprimida con gzip
    • gzeof - Prueba de apuntador para EOF de archivo gz
    • gzfile - Lee un archivo gz completo en una matriz
    • gzgetc - Obtiene el caracter donde está el apuntador al archivo gz
    • gzgets - Obtiene la línea del apuntador al archivo
    • gzgetss - Obtiene la línea del apuntador al archivo gz y retira las etiquetas HTML
    • gzinflate - Descomprime una cadena comprimida
    • gzopen - Abre un archivo gz
    • gzpassthru - Muestra todos los datos restantes a partir del apuntador al achivo gz
    • gzputs - Alias de gzwrite
    • gzread - Lectura de archivo gz segura a nivel binario
    • gzrewind - Reinicia la posición del apuntador a un archivo gz
    • gzseek - Ubica el apuntador a un archivo gz
    • gztell - Indica la posición de lectura/escritura del apuntador al archivo gz
    • gzuncompress - Descomprime una cadena comprimida
    • gzwrite - Escritura en un archivo gz, segura a nivel binario
  • h
    • hash - Generar un valor hash (resumen de mensaje)
    • hash_algos - Devuelve una lista con los algoritmos de cifrado soportados
    • hash_copy - Copia un recurso de contexto de cifrado
    • hash_equals - Comparación de strings segura contra ataques de temporización
    • hash_file - Generar un valor hash usando el contenido de un fichero dado
    • hash_final - Finaliza un contexto incremental y devuelve el resultado cifrado
    • hash_hkdf - Generate a HKDF key derivation of a supplied key input
    • hash_hmac - Genera un valor cifrado mediante una clave especificada usando el método HMAC
    • hash_hmac_algos - Return a list of registered hashing algorithms suitable for hash_hmac
    • hash_hmac_file - Genera un valor cifrado mediante una clave especificada usando el método HMAC y el contenido de un fichero dado
    • hash_init - Iniciar un contexto de hashing incremental
    • hash_pbkdf2 - Genera una derivación de clave PBKDF2 de una contraseña proporcionada
    • hash_update - Pega más datos en un contexto incremental de cifrado activo
    • hash_update_file - Inyecta datos en un contexto de cifrado activo desde un fichero
    • hash_update_stream - Pega datos en un contexto de cifrado activo desde un flujo de datos abierto
    • header - Enviar encabezado sin formato HTTP
    • headers_list - Devuelve una lista de encabezados de respuesta enviados (o listos para enviar)
    • headers_sent - Comprueba si o donde han enviado cabeceras
    • header_register_callback - Llamar a una función de cabecera
    • header_remove - Elimina encabezados previamente establecidos
    • hebrev - Convierte texto hebreo lógico a texto visual
    • hebrevc - Convertir texto de hebreo lógico a texto visual con conversión de línea nueva
    • hex2bin - Decodifica una cadena binaria codificada hexadecimalmente
    • hexdec - Hexadecimal a decimal
    • highlight_file - Remarcado de la sintaxis de un fichero
    • highlight_string - Remarcado de sintaxis de una cadena
    • hrtime - Get the system's high resolution time
    • HRTime\PerformanceCounter::getFrequency - La frecuencia del cronómetro en pulsos por segundo
    • HRTime\PerformanceCounter::getTicks - Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince - Ticks elapsed since the given value
    • HRTime\StopWatch::getElapsedTicks - Get elapsed ticks for all intervals
    • HRTime\StopWatch::getElapsedTime - Obtener el tiempo transcurrido para todos los intervalos
    • HRTime\StopWatch::getLastElapsedTicks - Get elapsed ticks for the last interval
    • HRTime\StopWatch::getLastElapsedTime - Obtener el tiempo transcurrido para el último intervalo
    • HRTime\StopWatch::isRunning - Whether the measurement is running
    • HRTime\StopWatch::start - Start time measurement
    • HRTime\StopWatch::stop - Stop time measurement
    • htmlentities - Convierte todos los caracteres aplicables a entidades HTML
    • htmlspecialchars - Convierte caracteres especiales en entidades HTML
    • htmlspecialchars_decode - Convierte entidades HTML especiales de nuevo en caracteres
    • html_entity_decode - Convierte todas las entidades HTML a sus caracteres correspondientes
    • http:// - Acceso a URLS en HTTP(s)
    • http_build_query - Generar una cadena de consulta codificada estilo URL
    • http_response_code - Obtener u establecer el código de respuesta HTTP
    • hypot - Calcula la longitud de la hipotenusa de un triángulo de ángulo recto
  • i
    • ibase_add_user - Añade un usuario a una base de datos segura
    • ibase_affected_rows - Devuelve el número de columnas afectadas por la última consulta
    • ibase_backup - Inicia la tarea de copia de seguridad en el administrador de servicios y devuelve el control inmediatamente
    • ibase_blob_add - Añade datos a un nuevo blob
    • ibase_blob_cancel - Cancela la creación de un blob
    • ibase_blob_close - Cierra un blob
    • ibase_blob_create - Crea un nuevo blob al que añadir datos
    • ibase_blob_echo - Imprime el contenido de un blob
    • ibase_blob_get - Consulta un determinado número de bytes de un blob
    • ibase_blob_import - Crea un blob, copia un fichero en él, y lo cierra
    • ibase_blob_info - Devuelve el tamaño de un blob y otra información útil
    • ibase_blob_open - Abre un blob para su consulta
    • ibase_close - Cerrar una conexión con una base de datos InterBase
    • ibase_commit - Lleva a cabo una transacción
    • ibase_commit_ret - Lleva a cabo una transacción sin cerrarla
    • ibase_connect - Abrir una conexión a una base de datos
    • ibase_db_info - Consulta estadísticas de una base de datos
    • ibase_delete_user - Elimina un usuario de una base de datos segura
    • ibase_drop_db - Elimina una base de datos
    • ibase_errcode - Devuelve un código de error
    • ibase_errmsg - Devuelve un mensaje de error
    • ibase_execute - Ejecutar una consulta previamente preparada
    • ibase_fetch_assoc - Extra una fila en forma de array asociativo de una consulta
    • ibase_fetch_object - Consulta un objeto de una base de datos InterBase
    • ibase_fetch_row - Recuperar una fila desde una base de datos InterBase
    • ibase_field_info - Consulta información sobre un determinado campo
    • ibase_free_event_handler - Cancela un manejador de eventos ya registrado
    • ibase_free_query - Liberar la memoria reservada por una consulta preparada
    • ibase_free_result - Liberar un conjunto de resultados
    • ibase_gen_id - Incrementa el generador de nombres y devuelve su nuevo valor
    • ibase_maintain_db - Lleva a cabo una tarea de mantenimiento en el servidor de bases de datos
    • ibase_modify_user - Modifica un usuario en una base de datos segura
    • ibase_name_result - Asigna un nombre a un juego de resultados
    • ibase_num_fields - Consulta el número de campos de un resultado
    • ibase_num_params - Devuelve el número de parámetros de una sentencia preparada
    • ibase_param_info - Devuelve información sobre un parámetro de una sentencia preparada
    • ibase_pconnect - Abrir una conexión persistente con una base de datos InterBase
    • ibase_prepare - Preparar una consulta para su asociación con parámetros de sustitución y ejecución posterior
    • ibase_query - Ejecutar una consulta en una base de datos InterBase
    • ibase_restore - Inicia una tarea de restauración en el administrador de servicios y devuelve el control inmediatamente
    • ibase_rollback - Deshace una transacción
    • ibase_rollback_ret - Deshace una transacción sin cerrarla
    • ibase_server_info - Solicita información sobre un servidor de bases de datos
    • ibase_service_attach - Conecta al administrador de servicios
    • ibase_service_detach - Desconecta del administrador de servicios
    • ibase_set_event_handler - Registra una función manejadora de un determinado evento
    • ibase_trans - Comienza una transacción
    • ibase_wait_event - Espera a que la base de datos emita un determinado evento
    • iconv - Convierte un string a la codificación de caracteres indicada
    • iconv_get_encoding - Recupera variables de configuración interna de la extensión iconv
    • iconv_mime_decode - Decodifica un campo de la cabecera MIME
    • iconv_mime_decode_headers - Decodifica varios campos de cabeceras MIME en la misma llamada
    • iconv_mime_encode - Compone un campo de cabecera MIME
    • iconv_set_encoding - Establece las opciones para la conversión de codificación de caracteres
    • iconv_strlen - Retorna el número de caracteres de un string
    • iconv_strpos - Encuentra la posición de la primera aparición de una aguja en un pajar
    • iconv_strrpos - Busca la última aparición de un string
    • iconv_substr - Elimina parte del string
    • idate - Formatea una fecha/hora local como un entero
    • idn_to_ascii - Convierte un nombre de dominio a formato IDNA ASCII
    • idn_to_utf8 - Convierte un nombre de dominio de IDNA ASCII a Unicode
    • ignore_user_abort - Establecer si la desconexión de un cliente debería abortar la ejecución del script
    • image2wbmp - Exportar la imagen al navegador o a un fichero
    • imageaffine - Devuelve la imagen que contiene la imagen origen transformada afín, usando un área de recorte opcional
    • imageaffinematrixconcat - Concatena dos matrices (como al hacer muchas opciones de una vez)
    • imageaffinematrixget - Devuelve la imagen que contiene la imagen fuente transformada afín, usando un área de recorte opcional
    • imagealphablending - Establece el modo de mezcla para una imagen
    • imageantialias - Permitir o no el uso de funciones antialias
    • imagearc - Dibujar un arco
    • imagebmp - Output a BMP image to browser or file
    • imagechar - Dibujar un carácter horizontalmente
    • imagecharup - Dibujar un carácter verticalmente
    • imagecolorallocate - Asigna un color para una imagen
    • imagecolorallocatealpha - Asignar un color para una imagen
    • imagecolorat - Obtener el índice del color de un píxel
    • imagecolorclosest - Obtener el índice del color más próximo al color especificado
    • imagecolorclosestalpha - Obtener el índice del color más próximo al color + alpha especificado
    • imagecolorclosesthwb - Obtener el índice del color que tiene el tono, blancura y negrura
    • imagecolordeallocate - Desasignar un color de una imagen
    • imagecolorexact - Obtener el índice del color especificado
    • imagecolorexactalpha - Obtener el índice del color + alpha especificado
    • imagecolormatch - Hacer que los colores de la versión de la paleta de una imagen coincidan más estrechamente con la versión de color verdadero
    • imagecolorresolve - Obtener el índice del color especificado o su alternativa más próxima posible
    • imagecolorresolvealpha - Obtener el índice del color + alpha especificado o su alternativa más próxima posible
    • imagecolorset - Establecer el color para el índice de paleta especificada
    • imagecolorsforindex - Obtener los colores de un índice
    • imagecolorstotal - Averiguar el número de colores de la paleta de una imagen
    • imagecolortransparent - Definir un color como transparente
    • imageconvolution - Aplicar una matriz de convolución de 3x3, usando coeficiente e índice
    • imagecopy - Copiar parte de una imagen
    • imagecopymerge - Copiar y fusionar parte de una imagen
    • imagecopymergegray - Copiar y fusionar parte de una imagen con escala de grises
    • imagecopyresampled - Copia y cambia el tamaño de parte de una imagen redimensionándola
    • imagecopyresized - Copia y cambia el tamaño de parte de una imagen
    • imagecreate - Crea una nueva imagen basada en paleta
    • imagecreatefrombmp - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromgd - Crear una imagen nueva desde un fichero GD o un URL
    • imagecreatefromgd2 - Crear una imagen nueva desde un fichero GD2 o un URL
    • imagecreatefromgd2part - Crear una nueva imagen desde una parte dada de un fichero GD2 o un URL
    • imagecreatefromgif - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromjpeg - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefrompng - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromstring - Crear una imagen nueva desde el flujo de imagen de la cadena
    • imagecreatefromwbmp - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromwebp - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromxbm - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatefromxpm - Crea una nueva imagen a partir de un fichero o de una URL
    • imagecreatetruecolor - Crear una nueva imagen de color verdadero
    • imagecrop - Recorta una imagen usando las coordenadas, el tamaño, x, y, ancho y alto dados
    • imagecropauto - Recorta una imagen automáticamente usando uno de los modos disponibles
    • imagedashedline - Dibujar una línea discontinua
    • imagedestroy - Destruir una imagen
    • imageellipse - Dibujar una elipse
    • imagefill - Rellenar
    • imagefilledarc - Dibujar un arco parcial y rellenarlo
    • imagefilledellipse - Dibujar una elipse con relleno
    • imagefilledpolygon - Dibujar un polígono con relleno
    • imagefilledrectangle - Dibujar un rectángulo con relleno
    • imagefilltoborder - Rellenar con un color específico
    • imagefilter - Aplica un filtro a una imagen
    • imageflip - Flips an image using a given mode
    • imagefontheight - Obtener el alto de la fuente
    • imagefontwidth - Obtener el ancho de la fuente
    • imageftbbox - Devolver la caja circundante de un texto usando fuentes mediante FreeType 2
    • imagefttext - Escribir texto en la imagen usando fuentes mediante FreeType 2
    • imagegammacorrect - Aplicar una corrección gamma a la imagen GD
    • imagegd - Imprime una imagen GD2 a un navegador o archivo
    • imagegd2 - Imprime una imagen GD2 a un navegador o fichero
    • imagegetclip - Get the clipping rectangle
    • imagegetinterpolation - Get the interpolation method
    • imagegif - Exportar la imagen al navegador o a un fichero
    • imagegrabscreen - Capturar la pantalla completa
    • imagegrabwindow - Capturar una ventana
    • imageinterlace - Habilitar o deshabilitar en entrelazamiento
    • imageistruecolor - Averiguar si una imagen es de color verdadero
    • imagejpeg - Exportar la imagen al navegador o a un fichero
    • imagelayereffect - Establecer la bandera de mezcla alfa para usar los efectos de capa
    • imageline - Dibujar una línea
    • imageloadfont - Cargar una nueva fuente
    • imageopenpolygon - Draws an open polygon
    • imagepalettecopy - Copiar la paleta de una imagen a otra
    • imagepalettetotruecolor - Convierte una imagen basada en paleta a color verdadero
    • imagepng - Imprimir una imagen PNG al navegador o a un archivo
    • imagepolygon - Dibujar un polígono
    • imagerectangle - Dibuja un rectángulo
    • imageresolution - Get or set the resolution of the image
    • imagerotate - Rotar una imagen con un ángulo dado
    • imagesavealpha - Establecer la bandera para guardar la información completa del canal alfa (como oposición a la transparencia de un simple color) cuando se guardan imágenes PNG
    • imagescale - Redimensiona una imagen usando un nuevo ancho y alto
    • imagesetbrush - Establecer la imagen de pincel para el dibujo de líneas
    • imagesetclip - Set the clipping rectangle
    • imagesetinterpolation - Establecer el método de interpolación
    • imagesetpixel - Establecer un simple píxel
    • imagesetstyle - Establecer el estilo para el dibujo de líneas
    • imagesetthickness - Establecer el grosor para el dibujo de líneas
    • imagesettile - Establecer la imagen de tesela para rellenos
    • imagestring - Dibujar una cadena horizontalmente
    • imagestringup - Dibujar una cadena verticalmente
    • imagesx - Obtener el ancho de una imagen
    • imagesy - Obtener el alto de una imagen
    • imagetruecolortopalette - Convertir una imagen de color verdadero en una imagen de paleta
    • imagettfbbox - Devuelve la caja circundante de un texto usando fuentes TrueType
    • imagettftext - Escribir texto en la imagen usando fuentes TrueType
    • imagetypes - Devolver los tipos de imagen soportados por la versión actual de PHP
    • imagewbmp - Exportar la imagen al navegador o a un fichero
    • imagewebp - Imprimir una imagen WebP al navegador o fichero
    • imagexbm - Imprimir una imagen XBM en el navegador o en un fichero
    • image_type_to_extension - Obtiene la extensión de un tipo de imagen
    • image_type_to_mime_type - Obtiene el tipo Mime de un tipo de imagen devuelto por getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
    • Imagick::adaptiveBlurImage - Añade un filtro de borrosidad adaptativo a la imagen
    • Imagick::adaptiveResizeImage - Redimensiona una imagen adaptativamente con información dependiente de la triangulación
    • Imagick::adaptiveSharpenImage - Afila la imagen adaptativamente
    • Imagick::adaptiveThresholdImage - Selecciona un umbral para cada píxel basado en un rango de intensidad
    • Imagick::addImage - Añade una nueva imagen a la lista de imágenes del objeto Imagick
    • Imagick::addNoiseImage - Añade ruido aleatorio a la imagen
    • Imagick::affineTransformImage - Transforma una imagen
    • Imagick::animateImages - Anima una imagen o imágenes
    • Imagick::annotateImage - Anota una imagen con texto
    • Imagick::appendImages - Añade un conjunto de imágenes
    • Imagick::autoLevelImage - Description
    • Imagick::averageImages - Calcula la media de un conjunto de imágenes
    • Imagick::blackThresholdImage - Fuerza a todos los píxeles bajo un umbral a ser negros
    • Imagick::blueShiftImage - Description
    • Imagick::blurImage - Añade un filtro de borrosidad a la imagen
    • Imagick::borderImage - Rodea la imagen con un borde
    • Imagick::brightnessContrastImage - Description
    • Imagick::charcoalImage - Simula un dibujo a carboncillo
    • Imagick::chopImage - Borra una región de una imagen y la recorta
    • Imagick::clampImage - Description
    • Imagick::clear - Borra todos los recursos asociados con un objeto Imagick
    • Imagick::clipImage - Recorta a lo largo del primer trazado desde un perfil 8BIM
    • Imagick::clipImagePath - Description
    • Imagick::clipPathImage - Recorta a lo largo de trazados nominados desde un perfil 8BIM
    • Imagick::clone - Hace una copia exacta de un objeto Imagick
    • Imagick::clutImage - Reemplaza los colores de una imagen
    • Imagick::coalesceImages - Compone un conjunto de imágenes
    • Imagick::colorFloodfillImage - Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::colorizeImage - Mezcla el color de relleno con la imagen
    • Imagick::colorMatrixImage - Description
    • Imagick::combineImages - Combina una o más imágenes en una sóla imagen
    • Imagick::commentImage - Añade un comentario a la imagen
    • Imagick::compareImageChannels - Devuelve la diferencia entre una o más imágenes
    • Imagick::compareImageLayers - Devuelve la región circundante máxima entre imágenes
    • Imagick::compareImages - Compara una imagen con otra reconstruida
    • Imagick::compositeImage - Compone una imagen en otra
    • Imagick::contrastImage - Cambia el contraste de una imagen
    • Imagick::contrastStretchImage - Mejora el contraste de una imagen en color
    • Imagick::convolveImage - Aplica una semilla de convolución a medida a la imagen
    • Imagick::count - Get the number of images
    • Imagick::cropImage - Extrae una región de la imagen
    • Imagick::cropThumbnailImage - Crea una miniatura recortada
    • Imagick::current - Devuelve una referencia del objeto Imagick actual
    • Imagick::cycleColormapImage - Desplaza el mapa de colores de una imagen
    • Imagick::decipherImage - Descifra una imagen
    • Imagick::deconstructImages - Devuelve ciertas diferencias de píxeles entre imágenes
    • Imagick::deleteImageArtifact - Borra un artefacto de imagen
    • Imagick::deleteImageProperty - Description
    • Imagick::deskewImage - Elimina la torción de la imagen
    • Imagick::despeckleImage - Reduce el ruido granular de una imagen
    • Imagick::destroy - Destruye un objeto Imagick
    • Imagick::displayImage - Muestra una imagen
    • Imagick::displayImages - Muestra una imagen o una secuencia de imágenes
    • Imagick::distortImage - Deforma una imagen utilizando varios métodos de distorsión
    • Imagick::drawImage - Renderiza el objeto ImagickDraw a la imagen actual
    • Imagick::edgeImage - Mejora los bordes de la imagen
    • Imagick::embossImage - Devuelve una imagen en escala de grises con un efecto tridimensional
    • Imagick::encipherImage - Cifra una imagen
    • Imagick::enhanceImage - Mejora la calidad de una imagen con ruido
    • Imagick::equalizeImage - Ecualiza el histograma de la imagen
    • Imagick::evaluateImage - Aplica una expresión a una imagen
    • Imagick::exportImagePixels - Exporta píxeles de imagen en bruto
    • Imagick::extentImage - Establecer el tamaño de la imagen
    • Imagick::filter - Description
    • Imagick::flattenImages - Fusiona una secuencia de imágenes
    • Imagick::flipImage - Crea una imagen espejo vertical
    • Imagick::floodFillPaintImage - Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::flopImage - Crea una imagen espejo horizontal
    • Imagick::forwardFourierTransformImage - Description
    • Imagick::frameImage - Añade un borde tridimensional simulado
    • Imagick::functionImage - Aplica una función a la imagen
    • Imagick::fxImage - Evalúa una expresión por cada píxel de la imagen
    • Imagick::gammaImage - Corrección gamma de una imagen
    • Imagick::gaussianBlurImage - Hace borrosa una imagen
    • Imagick::getColorspace - Obtiene el espacio de color
    • Imagick::getCompression - Obtiene el tipo de compresión del objeto
    • Imagick::getCompressionQuality - Obtiene la calidad de compresión del objeto
    • Imagick::getCopyright - Devuelve el copyright de la API ImageMagick como una cadena
    • Imagick::getFilename - El nombre de archivo asociado a una secuencia de imágenes
    • Imagick::getFont - Obtiene la fuente
    • Imagick::getFormat - Devuelve el formato de un objeto Imagick
    • Imagick::getGravity - Obtiene la gravedad
    • Imagick::getHomeURL - Devuelve la URL de inicio de ImageMagick
    • Imagick::getImage - Devuelve un nuevo objeto Imagick
    • Imagick::getImageAlphaChannel - Obtiene el canal alfa de una imagen
    • Imagick::getImageArtifact - Obtener el artefacto de imagen
    • Imagick::getImageAttribute - Description
    • Imagick::getImageBackgroundColor - Devuelve el color de fondo de la imagen
    • Imagick::getImageBlob - Devuelve la secuencia de imágenes como un valor de tipo blob
    • Imagick::getImageBluePrimary - Devuelve el punto primario azul de la cromaticidad
    • Imagick::getImageBorderColor - Devuelve el color del borde de la imagen
    • Imagick::getImageChannelDepth - Obtiene la profundidad de un canal de imagen en particular
    • Imagick::getImageChannelDistortion - Compara los canales de imagen de una imagen con una imagen reconstruida
    • Imagick::getImageChannelDistortions - Obtiene las distorsiones del canal
    • Imagick::getImageChannelExtrema - Obtiene los extremos de uno o más canales de imagen
    • Imagick::getImageChannelKurtosis - Obtiene la curtosis y la asimetría estadística de un canal específico
    • Imagick::getImageChannelMean - Obtiene la media y la desviación estándar
    • Imagick::getImageChannelRange - Obtiene el rango del canal
    • Imagick::getImageChannelStatistics - Devuelve las estadísticas de cada canal de la imagen
    • Imagick::getImageClipMask - Obtiene la máscara de recorte de la imagen
    • Imagick::getImageColormapColor - Devuelve el color del índice del mapa de colores especficado
    • Imagick::getImageColors - Obtiene el número de colores únicos de la imagen
    • Imagick::getImageColorspace - Obtiene el espacio de color de la imagen
    • Imagick::getImageCompose - Devuelve el operador de composición asociado a la imagen
    • Imagick::getImageCompression - Obtiene el tipo de compresión de la imagen actual
    • Imagick::getImageCompressionQuality - Obtiene la calidad de compresión de la imagen actual
    • Imagick::getImageDelay - Obtiene el retraso de la imagen
    • Imagick::getImageDepth - Obtiene la profundidad de la imagen
    • Imagick::getImageDispose - Obtiene el método de disposición de la imagen
    • Imagick::getImageDistortion - Compara una imagen con una imagen reconstruida
    • Imagick::getImageExtrema - Obtiene los extremos de la imagen
    • Imagick::getImageFilename - Devuelve el nombre de archivo de una imagen en particular de una secuencia
    • Imagick::getImageFormat - Devuelve el formato de una imagen en particular de una secuencia
    • Imagick::getImageGamma - Obtiene el valor gamma de la imagen
    • Imagick::getImageGeometry - Obtiene el ancho y el alto como un array asociativo
    • Imagick::getImageGravity - Obtiene la gravedad de la imagen
    • Imagick::getImageGreenPrimary - Devuelve el punto primario verde de la cromaticidad
    • Imagick::getImageHeight - Devuelve el alto de la imagen
    • Imagick::getImageHistogram - Obtiene el histograma de la imagen
    • Imagick::getImageIndex - Obtiene el índice de la imagen activa actual
    • Imagick::getImageInterlaceScheme - Obtiene la combinación de entrelazado de la imagen
    • Imagick::getImageInterpolateMethod - Devuelve el método de interpolación
    • Imagick::getImageIterations - Obtiene las iteraciones de la imagen
    • Imagick::getImageLength - Devuelve la longitud de la imagen en bytes
    • Imagick::getImageMatte - Devuelve si la imagen tiene un canal mate
    • Imagick::getImageMatteColor - Devuelve el color mate de la imagen
    • Imagick::getImageMimeType - Description
    • Imagick::getImageOrientation - Obtiene la orientación de la imagen
    • Imagick::getImagePage - Devuelve la geometría de la página
    • Imagick::getImagePixelColor - Devuelve el color del píxel especificado
    • Imagick::getImageProfile - Devuelve el perfil nominado de la imagen
    • Imagick::getImageProfiles - Devuelve los perfiles de la imagen
    • Imagick::getImageProperties - Devuelve las propiedades de la imagen
    • Imagick::getImageProperty - Devuelve la propiedad nominada de la imagen
    • Imagick::getImageRedPrimary - Devuelve el punto primario rojo de la cromaticidad
    • Imagick::getImageRegion - Extrae una región de la imagen
    • Imagick::getImageRenderingIntent - Obtiene el propósito de renderización de la imagen
    • Imagick::getImageResolution - Obtiene la resolución X e Y de la imagen
    • Imagick::getImagesBlob - Devuelve todas las secuencias de imágenes como un blob
    • Imagick::getImageScene - Obtiene la escena de la imagen
    • Imagick::getImageSignature - Genera un resumen de un mensaje SHA-256
    • Imagick::getImageSize - Devuelve la longitud de la imagen en bytes
    • Imagick::getImageTicksPerSecond - Obtiene los pulsos por segundo de la imagen
    • Imagick::getImageTotalInkDensity - Obtiene la densidad de tinta total de la imagen
    • Imagick::getImageType - Obtiene el tipo de imagen potencial
    • Imagick::getImageUnits - Obtiene las unidades de resolución de la imagen
    • Imagick::getImageVirtualPixelMethod - Devuelve el método de píxel virtual
    • Imagick::getImageWhitePoint - Devuelve el punto blanco de la cromaticidad
    • Imagick::getImageWidth - Devuelve el ancho de la imagen
    • Imagick::getInterlaceScheme - Obtiene la combinación de entrelazado de un objeto
    • Imagick::getIteratorIndex - Obtiene el índice de la imagen activa actual
    • Imagick::getNumberImages - Devuelve el número de imágenes del objeto
    • Imagick::getOption - Devuelve un valor asociado con la clave especificada
    • Imagick::getPackageName - Devuelve el nombre del paquete de ImageMagick
    • Imagick::getPage - Devuelve la geometría de la página
    • Imagick::getPixelIterator - Devuelve un objeto MagickPixelIterator
    • Imagick::getPixelRegionIterator - Obtinene un objeto ImagickPixelIterator de una sección de imagen
    • Imagick::getPointSize - Obtiene el tamaño de punto
    • Imagick::getQuantum - Description
    • Imagick::getQuantumDepth - Obtiene la profundidad de la cuantía
    • Imagick::getQuantumRange - Devuelve el rango de cuantía de Imagick
    • Imagick::getRegistry - Description
    • Imagick::getReleaseDate - Devuelve la fecha de distribución de ImageMagick
    • Imagick::getResource - Devuelve el uso de memoria del recurso especificado
    • Imagick::getResourceLimit - Devuelve el límite del recurso especificado
    • Imagick::getSamplingFactors - Obtiene el factor de muestreo horizontal y vertical
    • Imagick::getSize - Devuelve el tamaño asociado con el objeto Imagick
    • Imagick::getSizeOffset - Devuelve el índice de tamaño
    • Imagick::getVersion - Devuelve la versión de la API ImageMagick
    • Imagick::haldClutImage - Reemplaza los colores de la imagen
    • Imagick::hasNextImage - Comprueba si el objeto tiene más imágenes
    • Imagick::hasPreviousImage - Verifica si el objeto tiene una imagen previa
    • Imagick::identifyFormat - Description
    • Imagick::identifyImage - Identifica una imagen y obtiene sus atributos
    • Imagick::implodeImage - Crea una nueva imagen como una copia
    • Imagick::importImagePixels - Importa los píxeles de una imagen
    • Imagick::inverseFourierTransformImage - Description
    • Imagick::labelImage - Añade una etiqueta a una imagen
    • Imagick::levelImage - Ajusta los niveles de la imagen
    • Imagick::linearStretchImage - Estrecha con saturación la intensidad de la imagen
    • Imagick::liquidRescaleImage - Anima una imagen o imágenes
    • Imagick::listRegistry - Description
    • Imagick::magnifyImage - Escala una imagen x2 proporcionalmente
    • Imagick::mapImage - Reemplaza los colores de una imagen con el color más cercano de una imagen de referencia
    • Imagick::matteFloodfillImage - Cambia el valor de transparencia de un color
    • Imagick::medianFilterImage - Aplica un filtro digital
    • Imagick::mergeImageLayers - Fusiona las capas de una imagen
    • Imagick::minifyImage - Escala una imagen proporcionalmente a la mitad de su tamaño
    • Imagick::modulateImage - Controla el brillo, la saturación y el tono
    • Imagick::montageImage - Crea una imagen compuesta
    • Imagick::morphImages - Metamorfosea un conjunto de imágenes
    • Imagick::morphology - Description
    • Imagick::mosaicImages - Forma un mosaico de imágenes
    • Imagick::motionBlurImage - Simula borrosidad en movimiento
    • Imagick::negateImage - Invierte los colores en la imagen de referencia
    • Imagick::newImage - Crea una nueva imagen
    • Imagick::newPseudoImage - Crea una nueva imagen
    • Imagick::nextImage - Se mueve a la siguiente imagen
    • Imagick::normalizeImage - Mejora el contraste de una imagen a color
    • Imagick::oilPaintImage - Simula una pintura al óleo
    • Imagick::opaquePaintImage - Cambia el color de cualquier píxel que coincida con el objetivo
    • Imagick::optimizeImageLayers - Elimina porciones repetidas de imágenes para optimizarlas
    • Imagick::orderedPosterizeImage - Realiza un entramado ordenado
    • Imagick::paintFloodfillImage - Cambia el valor del color de cualquier píxel que coincida con el objetivo
    • Imagick::paintOpaqueImage - Cambia cualquier píxel que coincida con el color
    • Imagick::paintTransparentImage - Cambia cualquier píxel que coincida con el color definido para el relleno
    • Imagick::pingImage - Trae los atributos básicos de una imagen
    • Imagick::pingImageBlob - Traer los atributos rápidamente
    • Imagick::pingImageFile - Obtener los atrbutos básicos de la imagen de una manera liviana
    • Imagick::polaroidImage - Simula una fotografía Polaroid
    • Imagick::posterizeImage - Reduce la imagen a un número limitado de niveles de color
    • Imagick::previewImages - Precisa rápidamente los parámetros apropiados para el procesamiento de la imagen
    • Imagick::previousImage - Se mueve a la imagen previa del objeto
    • Imagick::profileImage - Añade o elimina un perfil de una imagen
    • Imagick::quantizeImage - Analiza los colores dentro de una imagen de referencia
    • Imagick::quantizeImages - Analiza los colores dentro de una secuencia de imágenes
    • Imagick::queryFontMetrics - Devuelve una matriz que representa las métricas de la fuente
    • Imagick::queryFonts - Devuelve las fuentes configuradas
    • Imagick::queryFormats - Devuelve los formatos soportados por Imagick
    • Imagick::radialBlurImage - Hace borrosa de forma radial una imagen
    • Imagick::raiseImage - Crea un efecto de botón en 3D simulado
    • Imagick::randomThresholdImage - Crea una imagen de alto contraste y dos colores
    • Imagick::readImage - Lee una imagen desde un nombre de fichero
    • Imagick::readImageBlob - Lee una imagen desde un string binario
    • Imagick::readImageFile - Lee una imagen desde un gestor de fichero abierto
    • Imagick::readimages - Description
    • Imagick::recolorImage - Re-colorea una imagen
    • Imagick::reduceNoiseImage - Suaviza los contornos de una imagen
    • Imagick::remapImage - Re-mapea los colores de una imagen
    • Imagick::removeImage - Quita una imagen de la lista de imágenes
    • Imagick::removeImageProfile - Elimina el perfil nominado de la imagen y lo devuelve
    • Imagick::render - Renderiza todos los comandos de dibujo precedentes
    • Imagick::resampleImage - Remuestrea la imagen a la resolución deseada
    • Imagick::resetImagePage - Reinicia una página de imagen
    • Imagick::resizeImage - Escala una imagen
    • Imagick::rollImage - Compensa una imagen
    • Imagick::rotateImage - Rota una imagen
    • Imagick::rotationalBlurImage - Description
    • Imagick::roundCorners - Redondea las esquinas de una imagen
    • Imagick::sampleImage - Escala una imagen con un muestreo de píxeles
    • Imagick::scaleImage - Escala el tamaño de una imagen
    • Imagick::segmentImage - Segmenta una imagen
    • Imagick::selectiveBlurImage - Description
    • Imagick::separateImageChannel - Separa un canal de la imagen
    • Imagick::sepiaToneImage - Pone una imagen en tono sepia
    • Imagick::setBackgroundColor - Establece el color de fondo por omisión del objeto
    • Imagick::setColorspace - Establecer el espacio de color
    • Imagick::setCompression - Establece el tipo de compresión predeterminado del objeto
    • Imagick::setCompressionQuality - Establece la calidad de compresión predeterminda del objeto
    • Imagick::setFilename - Establece el nombre de archivo antes de que se lea o escriba una imagen
    • Imagick::setFirstIterator - Establece el iterador Imagick para la primera imagen
    • Imagick::setFont - Establece el tipo de letra
    • Imagick::setFormat - Establece el formato del objeto Imagick
    • Imagick::setGravity - Establece la gravedad
    • Imagick::setImage - Reemplaza una imagen en el objeto
    • Imagick::setImageAlphaChannel - Establece el canal alfa de la imagen
    • Imagick::setImageArtifact - Establecer un artefacto de imagen
    • Imagick::setImageAttribute - Description
    • Imagick::setImageBackgroundColor - Establece el color de fondo de la imagen
    • Imagick::setImageBias - Establece el sesgo de la imagen para cualquier método que convolucione una imagen
    • Imagick::setImageBiasQuantum - Description
    • Imagick::setImageBluePrimary - Establece el punto primario azul de la cromaticidad de la imagen
    • Imagick::setImageBorderColor - Establece el color de borde de la imagen
    • Imagick::setImageChannelDepth - Establece la profundidad de una canal de imagen en particular
    • Imagick::setImageClipMask - Establece la máscara de recorte de una imagen
    • Imagick::setImageColormapColor - Establece el color de un índice de mapa de color especificado
    • Imagick::setImageColorspace - Establece el espacio de color de una imagen
    • Imagick::setImageCompose - Establece el operador de composción de una imagen
    • Imagick::setImageCompression - Establece la compresión de una imagen
    • Imagick::setImageCompressionQuality - Establece la calidad de compresión de una imagen
    • Imagick::setImageDelay - Establece el retardo de una imagen
    • Imagick::setImageDepth - Establece la profundidad de una imagen
    • Imagick::setImageDispose - Establece el método de disposición de una imagen
    • Imagick::setImageExtent - Establece el tamaño de una imagen
    • Imagick::setImageFilename - Establece el nombre de archivo de una imagen en particular
    • Imagick::setImageFormat - Establece el formato de una imagen en particular
    • Imagick::setImageGamma - Establece el valor gamma de la imagen
    • Imagick::setImageGravity - Establece la gravedad de la imagen
    • Imagick::setImageGreenPrimary - Establece el punto primario verde de la cromaticidad de la imagen
    • Imagick::setImageIndex - Establece la posición del iterador
    • Imagick::setImageInterlaceScheme - Establece la compresión de la imagen
    • Imagick::setImageInterpolateMethod - Establece el método de interpolación de píxeles
    • Imagick::setImageIterations - Establece las iteraciones de una imagen
    • Imagick::setImageMatte - Establece el canal mate de la imagen
    • Imagick::setImageMatteColor - Establece el color mate de la imagen
    • Imagick::setImageOpacity - Establece el nivel de opacidad de la imagen
    • Imagick::setImageOrientation - Establece la orientación de la imagen
    • Imagick::setImagePage - Establece la geometría de la página de la imagen
    • Imagick::setImageProfile - Añade un perfil nominado al objeto Imagick
    • Imagick::setImageProperty - Establece una propiedad de la imagen
    • Imagick::setImageRedPrimary - Establece el punto primario rojo de la cromaticidad de la imagen
    • Imagick::setImageRenderingIntent - Establece el propósito de renderización de la imagen
    • Imagick::setImageResolution - Establece la resolución de la imagen
    • Imagick::setImageScene - Establece la escena de la imagen
    • Imagick::setImageTicksPerSecond - Establece los ticks por segundo de la imagen
    • Imagick::setImageType - Establece el tipo de imagen
    • Imagick::setImageUnits - Establece las unidades de resolución de la imagen
    • Imagick::setImageVirtualPixelMethod - Establece el método de píxel virtual de la imagen
    • Imagick::setImageWhitePoint - Establece el punto blanco de cromaticidad de la imagen
    • Imagick::setInterlaceScheme - Establece la compresión de la imagen
    • Imagick::setIteratorIndex - Establece la posición del iterador
    • Imagick::setLastIterator - Establece el iterador de Imagick a la última imagen
    • Imagick::setOption - Establece una opción
    • Imagick::setPage - Establece la geometría de página del objeto Imagick
    • Imagick::setPointSize - Establece el tamaño del punto
    • Imagick::setProgressMonitor - Description
    • Imagick::setRegistry - Description
    • Imagick::setResolution - Establece la resolución de la imagen
    • Imagick::setResourceLimit - Establece el límite de un recurso en particular en megabytes
    • Imagick::setSamplingFactors - Establece los factores de muestreo de la imagen
    • Imagick::setSize - Establece el tamaño del objeto Imagick
    • Imagick::setSizeOffset - Establece el tamaño y el índice del objeto Imagick
    • Imagick::setType - Establece el atributo tipo de imagen
    • Imagick::shadeImage - Crea un efecto en 3D
    • Imagick::shadowImage - Simula una sombra de imagen
    • Imagick::sharpenImage - Afila una imagen
    • Imagick::shaveImage - Recorta píxeles de los extremos de la imagen
    • Imagick::shearImage - Crea un paralelogramo
    • Imagick::sigmoidalContrastImage - Ajusta el contraste de una imagen
    • Imagick::sketchImage - Simula el bosquejo de un lapiz
    • Imagick::smushImages - Description
    • Imagick::solarizeImage - Aplica un efecto de solarización a la imagen
    • Imagick::sparseColorImage - Interpola colores
    • Imagick::spliceImage - Une un color sólido en la imagen
    • Imagick::spreadImage - Despalza aleatoriamente cada píxel en un bloque
    • Imagick::statisticImage - Description
    • Imagick::steganoImage - Oculta una marca de agua digital dentro de la imagen
    • Imagick::stereoImage - Compone dos imágenes
    • Imagick::stripImage - Elimina todos los perfiles y comentarios de una imagen
    • Imagick::subImageMatch - Description
    • Imagick::swirlImage - Arremolina los píxeles desde el centro de la imagen
    • Imagick::textureImage - Reviste repetidamente la textura de la imagen
    • Imagick::thresholdImage - Cambia el valor de píexeles individuales basdos en un umbral
    • Imagick::thumbnailImage - Cambia el tamaño de una imagen
    • Imagick::tintImage - Aplica un vector de color a cada píxel en la imagen
    • Imagick::transformImage - Método conveniente para establecer el tamaño del recorte y la geometría de la imagen
    • Imagick::transformImageColorspace - Transforma una imagen a un nuevo espacio de color
    • Imagick::transparentPaintImage - Pinta píxeles transparentes
    • Imagick::transposeImage - Crea una imagen espejo vertical
    • Imagick::transverseImage - Crea una imagen espejo horizontal
    • Imagick::trimImage - Elimina los extremos de la imagen
    • Imagick::uniqueImageColors - Desecha todos los colores de los píxeles excepto uno
    • Imagick::unsharpMaskImage - Afila una imagen
    • Imagick::valid - Comprueba si el elemento actual es válido
    • Imagick::vignetteImage - Añade un filtro de viñeta a la imagen
    • Imagick::waveImage - Aplica un filtro de onda a la imagen
    • Imagick::whiteThresholdImage - Fuerza a todos los píxeles por encima del umbral a ser blancos
    • Imagick::writeImage - Escribe una imagen al nombre de fichero especificado
    • Imagick::writeImageFile - Escribe una imagen a un gestor de archivo
    • Imagick::writeImages - Escribe una imagen o secuencia de imágenes
    • Imagick::writeImagesFile - Escribe fotogramas al gestor de archivo
    • Imagick::__construct - El constructor Imagick
    • Imagick::__toString - Devuelve la imagen como un string
    • ImagickDraw::affine - Ajusta la matriz de transformación afín actual
    • ImagickDraw::annotation - Dibuja texto en la imagen
    • ImagickDraw::arc - Dibuja un arco
    • ImagickDraw::bezier - Dibuja una curva de Bézier
    • ImagickDraw::circle - Dibuja un círculo
    • ImagickDraw::clear - Borra el objeto ImagickDraw
    • ImagickDraw::clone - Hace una copia exacta del objeto ImagickDraw especificado
    • ImagickDraw::color - Dibuja color en una imagen
    • ImagickDraw::comment - Añade un comentario
    • ImagickDraw::composite - Compone una imagen dentro de la imagen actual
    • ImagickDraw::destroy - Libera todos los recursos asociados
    • ImagickDraw::ellipse - Dibuja una elipse en la imagen
    • ImagickDraw::getClipPath - Obtiene el ID del trazado de recorte actual
    • ImagickDraw::getClipRule - Devuelve la regla de relleno de un polígono actual
    • ImagickDraw::getClipUnits - Devuelve la interpretación de unidades del trazado de recorte
    • ImagickDraw::getFillColor - Devuelve el color de relleno
    • ImagickDraw::getFillOpacity - Devuelve la opacidad usada cuando se dibuja
    • ImagickDraw::getFillRule - Devuelve la regla de relleno
    • ImagickDraw::getFont - Devuelve la fuente
    • ImagickDraw::getFontFamily - Devuelve la familia de la fuente
    • ImagickDraw::getFontSize - Devuelve el tamaño de punto de la fuente
    • ImagickDraw::getFontStretch - Description
    • ImagickDraw::getFontStyle - Devuelve el estilo de fuente
    • ImagickDraw::getFontWeight - Devuelve el peso de la fuente
    • ImagickDraw::getGravity - Devuelve la gravedad de emplazamiento del texto
    • ImagickDraw::getStrokeAntialias - Devuelve la configuración de antialias de contorno actual
    • ImagickDraw::getStrokeColor - Devuelve el color usado por los perfiles de objetos contorneados
    • ImagickDraw::getStrokeDashArray - Devuelve un array que representa el patrón de rayas y huecos usado por trazados contorneados
    • ImagickDraw::getStrokeDashOffset - Devuelve el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
    • ImagickDraw::getStrokeLineCap - Devuelve la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
    • ImagickDraw::getStrokeLineJoin - Devuelve la forma que se va a usar en la esquinas de los trazados cuando están contorneados
    • ImagickDraw::getStrokeMiterLimit - Devuelve el límite del inglete del contorno
    • ImagickDraw::getStrokeOpacity - Devuelve la opacidad del perfil de objetos contorneados
    • ImagickDraw::getStrokeWidth - Devuelve al ancho del contorno usado para dibujar contornos de objetos
    • ImagickDraw::getTextAlignment - Devuelve la alineación del texto
    • ImagickDraw::getTextAntialias - Devuelve la configuración de antialias del texto actual
    • ImagickDraw::getTextDecoration - Devuelve la decoración del texto
    • ImagickDraw::getTextEncoding - Devuelve la codificación usada para anotaciones de texto
    • ImagickDraw::getTextInterlineSpacing - Description
    • ImagickDraw::getTextInterwordSpacing - Description
    • ImagickDraw::getTextKerning - Description
    • ImagickDraw::getTextUnderColor - Devuelve el color debajo del texto
    • ImagickDraw::getVectorGraphics - Devuelve una cadena que contiene gráficos vectoriales
    • ImagickDraw::line - Dibuja una línea
    • ImagickDraw::matte - Pinta sobre el canal de opacidad de la imagen
    • ImagickDraw::pathClose - Añade un elemento de trazado al trazado actual
    • ImagickDraw::pathCurveToAbsolute - Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute - Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierRelative - Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute - Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative - Dibuja una curva Bézier cuadrática
    • ImagickDraw::pathCurveToRelative - Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToSmoothAbsolute - Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathCurveToSmoothRelative - Dibuja una curva cúbica de Bézier
    • ImagickDraw::pathEllipticArcAbsolute - Dibuja un arco elíptico
    • ImagickDraw::pathEllipticArcRelative - Dibuja un arco elíptico
    • ImagickDraw::pathFinish - Finaliza el trazado actual
    • ImagickDraw::pathLineToAbsolute - Dibuja un trazado de línea
    • ImagickDraw::pathLineToHorizontalAbsolute - Dibuja un trazado de línea horizontal
    • ImagickDraw::pathLineToHorizontalRelative - Dibuja una línea horizontal
    • ImagickDraw::pathLineToRelative - Dibuja un trazado de línea
    • ImagickDraw::pathLineToVerticalAbsolute - Dibuja un línea vertical
    • ImagickDraw::pathLineToVerticalRelative - Dibuja un trazado de línea vertical
    • ImagickDraw::pathMoveToAbsolute - Inicia un nuevo sub-trazado
    • ImagickDraw::pathMoveToRelative - Inicia un nuevo sub-trazado
    • ImagickDraw::pathStart - Declara el inicio de una lista de dibujo de trazados
    • ImagickDraw::point - Dibuja un punto
    • ImagickDraw::polygon - Dibuja un polígono
    • ImagickDraw::polyline - Dibuja una poli-línea
    • ImagickDraw::pop - Destruye el objeto ImagickDraw actual de la pila, y lo devuelve al objeto ImagickDraw previamente metido
    • ImagickDraw::popClipPath - Finaliza una definición de un trazado de recorte
    • ImagickDraw::popDefs - Finaliza una lista de definiciones
    • ImagickDraw::popPattern - Finaliza una definición de patrón
    • ImagickDraw::push - Clona el objeto ImagickDraw actual y lo mete en la pila
    • ImagickDraw::pushClipPath - Inicia la definición de un trazado de recorte
    • ImagickDraw::pushDefs - Indica que los siguientes comandos crean elementos con nombre para un procesamiento previo
    • ImagickDraw::pushPattern - Indica que los comandos subsiguientes hasta un comando ImagickDraw::opPattern() comprenden la definición de un patrón nominado
    • ImagickDraw::rectangle - Dibuja un rectángulo
    • ImagickDraw::render - Renderiza todos los comandos de dibujo precedentes en la imagen
    • ImagickDraw::resetVectorGraphics - Description
    • ImagickDraw::rotate - Aplica la rotación especificada al espacio de coordenadas actual
    • ImagickDraw::roundRectangle - Dibuja un rectángulo redondeado
    • ImagickDraw::scale - Ajusta el factor de escala
    • ImagickDraw::setClipPath - Asocia un trazado de recorte nominado con la imagen
    • ImagickDraw::setClipRule - Establece la regla de relleno de polígonos a usar por el trazado de recorte
    • ImagickDraw::setClipUnits - Establece la interpretación de las unidades de un trazado de recorte
    • ImagickDraw::setFillAlpha - Establece la opacidad a usar cuando se dibuja utilizando el color de relleno o la textura de relleno
    • ImagickDraw::setFillColor - Establece el color de relleno que se va a usar para dibujar objetos rellenos
    • ImagickDraw::setFillOpacity - Establece la opacidad para usarla cuando se dibuja utilizando el color de relleno o la textura de relleno
    • ImagickDraw::setFillPatternURL - Establece la URL a usar como un patrón de relleno para objetos rellenos
    • ImagickDraw::setFillRule - Establece la regla de relleno a usar mientras se dibujan polígonos
    • ImagickDraw::setFont - Establece la fuente especificada completamente para usarla cuando se escribe texto
    • ImagickDraw::setFontFamily - Establece la familia de fuentes para usarla cuando se escribe texto
    • ImagickDraw::setFontSize - Establece el tamaño de punto de la fuente para usarlo cuando se escribe texto
    • ImagickDraw::setFontStretch - Establece el estiramiento de la fuente para usarla cuando se escribe texto
    • ImagickDraw::setFontStyle - Establece el estilo de fuente para usarlo cuando se escribe texto
    • ImagickDraw::setFontWeight - Establece el peso de fuente
    • ImagickDraw::setGravity - Establece la gravedad de ubicación del texto
    • ImagickDraw::setResolution - Description
    • ImagickDraw::setStrokeAlpha - Especifica la opacidad de los perfiles de los objetos contorneados
    • ImagickDraw::setStrokeAntialias - Controla si los perfiles contorneados tiene antialias
    • ImagickDraw::setStrokeColor - Establece el color usado por los perfiles de objetos contorneados
    • ImagickDraw::setStrokeDashArray - Especifica el patrón de rayas y huecos usado por los trazados de contorno
    • ImagickDraw::setStrokeDashOffset - Especifica el índice dentro del patrón de discontinuidad para iniciar la discontinuidad
    • ImagickDraw::setStrokeLineCap - Especifica la forma que se va a usar al final de los subtrazados abiertos cuando están contorneados
    • ImagickDraw::setStrokeLineJoin - Especifica la forma que se va a usar en la esquinas de los trazados cuando están contorneados
    • ImagickDraw::setStrokeMiterLimit - Especifica el límite del inglete
    • ImagickDraw::setStrokeOpacity - Especifica la opacidad de los perfiles de los objetos contorneados
    • ImagickDraw::setStrokePatternURL - Establece el patrón usado para los perfiles de objetos contorneados
    • ImagickDraw::setStrokeWidth - Establece el ancho del contorno a usar para dibujar perfiles de objetos
    • ImagickDraw::setTextAlignment - Especifica una alineación de texto
    • ImagickDraw::setTextAntialias - Controla si el texto tiene antialias
    • ImagickDraw::setTextDecoration - Especifica una decoración
    • ImagickDraw::setTextEncoding - Especifica el conjunto de codificación del texto
    • ImagickDraw::setTextInterlineSpacing - Description
    • ImagickDraw::setTextInterwordSpacing - Description
    • ImagickDraw::setTextKerning - Description
    • ImagickDraw::setTextUnderColor - Especifica el color de un rectángulo de fondo
    • ImagickDraw::setVectorGraphics - Establece los gráficos vectoriales
    • ImagickDraw::setViewbox - Establece el tamaño de todos los lienzos
    • ImagickDraw::skewX - Tuerce el sistema de coordenadas actual en la dirección horizontal
    • ImagickDraw::skewY - Tuerce el sistema de coordenadas actual en la dirección vertical
    • ImagickDraw::translate - Aplica una traslación del sistema de coordenadas actual
    • ImagickDraw::__construct - El constructor ImagickDraw
    • ImagickKernel::addKernel - Description
    • ImagickKernel::addUnityKernel - Description
    • ImagickKernel::fromBuiltIn - Description
    • ImagickKernel::fromMatrix - Description
    • ImagickKernel::getMatrix - Description
    • ImagickKernel::scale - Description
    • ImagickKernel::separate - Description
    • ImagickPixel::clear - Borra los recursos asociados con este objeto
    • ImagickPixel::destroy - Desasigna los recursos asociados con este objeto
    • ImagickPixel::getColor - Devuelve el color
    • ImagickPixel::getColorAsString - Devuelve el color como string
    • ImagickPixel::getColorCount - Devuelve la cuenta de color asociada a este
    • ImagickPixel::getColorQuantum - Description
    • ImagickPixel::getColorValue - Obtiene el valor normalizado del canal de color proporcionado
    • ImagickPixel::getColorValueQuantum - Description
    • ImagickPixel::getHSL - Devuelve el color HSL normalizado del objeto ImagickPixel
    • ImagickPixel::getIndex - Description
    • ImagickPixel::isPixelSimilar - Comprobar la distancia entre este color y otro
    • ImagickPixel::isPixelSimilarQuantum - Description
    • ImagickPixel::isSimilar - Comprobar la distancia entre este color y otro
    • ImagickPixel::setColor - Establece el color
    • ImagickPixel::setColorCount - Description
    • ImagickPixel::setColorValue - Establece el valor normalizado de uno de los canales
    • ImagickPixel::setColorValueQuantum - Description
    • ImagickPixel::setHSL - Establece el color HSL normalizado
    • ImagickPixel::setIndex - Description
    • ImagickPixel::__construct - El constructor ImagickPixel
    • ImagickPixelIterator::clear - Borra los recursos asociados con un objeto PixelIterator
    • ImagickPixelIterator::destroy - Desasigna los recursos asociacdos con un objeto PixelIterator
    • ImagickPixelIterator::getCurrentIteratorRow - Devuelve la fila actual de objetos ImagickPixel
    • ImagickPixelIterator::getIteratorRow - Devuelve la fila actual del iterador de píxel
    • ImagickPixelIterator::getNextIteratorRow - Devuelve la fila siguiente del iterador de píxel
    • ImagickPixelIterator::getPreviousIteratorRow - Devuelve la fila previa
    • ImagickPixelIterator::newPixelIterator - Devuelve un nuevo iterador de píxel
    • ImagickPixelIterator::newPixelRegionIterator - Devuelve un nuevo iterador de píxel
    • ImagickPixelIterator::resetIterator - Reinicia el iterador de píxel
    • ImagickPixelIterator::setIteratorFirstRow - Establece el iterador de píxel a la primera fila de píxeles
    • ImagickPixelIterator::setIteratorLastRow - Establece el iterador de píxel a la última fila de píxeles
    • ImagickPixelIterator::setIteratorRow - Establecer la fila del iterador de píxel
    • ImagickPixelIterator::syncIterator - Sincornizar el iterador de píxel
    • ImagickPixelIterator::__construct - El constructor ImagickPixelIterator
    • imap_8bit - Convertir una cadena 8bit a una cadena quoted-printable
    • imap_alerts - Devuelve todos los mensajes de alerte de IMAP que han sucedido
    • imap_append - Añadir un mensaje de cadena a un buzón especificado
    • imap_base64 - Decodificar un texto cifrado con BASE64
    • imap_binary - Convertir una cadena 8bit a una cadena base64
    • imap_body - Leer el cuerpo del mensaje
    • imap_bodystruct - Leer la estructura de una sección del cuerpo especificado de un mensaje especificado
    • imap_check - Comprobar el buzón actual
    • imap_clearflag_full - Limpia las banderas de mensajes
    • imap_close - Cerrar una secuencia IMAP
    • imap_create - Alias de imap_createmailbox
    • imap_createmailbox - Crear un nuevo buzón de correo
    • imap_delete - Marcar un mensaje para su borrado del buzón actual
    • imap_deletemailbox - Elimina un buzón
    • imap_errors - Devuelve todos los errores de IMAP que han ocurrido
    • imap_expunge - Borra todos los mensajes marcados para eliminación
    • imap_fetchbody - Traer una sección en particular del cuerpo del mensaje
    • imap_fetchheader - Devolver la cabecera de un mensaje
    • imap_fetchmime - Obtener las cabeceras MIME para una sección en particular del mensaje
    • imap_fetchstructure - Leer la estructura de un mensaje en particular
    • imap_fetchtext - Alias de imap_body
    • imap_fetch_overview - Leer una visión general de la información de las cabeceras del mensaje dado
    • imap_gc - Limpia la caché de IMAP
    • imap_getacl - Obtiene el ACL para un buzón dado
    • imap_getmailboxes - Leer la lista de buzones, devolviendo información detallada de cada uno
    • imap_getsubscribed - Listar todos los buzones suscritos
    • imap_get_quota - Obtener la cuota de ajustes por usuario, y las estadísticas de uso por buzón
    • imap_get_quotaroot - Obtener la cuota de ajustes por usuario
    • imap_header - Alias de imap_headerinfo
    • imap_headerinfo - Leer la cabecera del mensaje
    • imap_headers - Devuelve las cabeceras de todos los mensajes de un buzón
    • imap_last_error - Obtiene el último error de IMAP que ocurrió durante esta petición de página
    • imap_list - Leer la lista de buzones
    • imap_listmailbox - Alias de imap_list
    • imap_listscan - Devuelve la lista de buzones que coinciden con el texto dado
    • imap_listsubscribed - Alias de imap_lsub
    • imap_lsub - Listar todos los buzones suscritos
    • imap_mail - Enviar un mensaje de correo electrónico
    • imap_mailboxmsginfo - Obtener información sobre el buzón actual
    • imap_mail_compose - Crear un mensaje MIME basado en las secciones sobre y cuerpo
    • imap_mail_copy - Copiar los mensajes especificados a un buzón
    • imap_mail_move - Mover los mensajes especificados a un buzón
    • imap_mime_header_decode - Decodificar los elementos de la cabecera MIME
    • imap_msgno - Obtiene el número de secuencia de mensaje para el UID dado
    • imap_mutf7_to_utf8 - Decode a modified UTF-7 string to UTF-8
    • imap_num_msg - Obtiene el número de mensajes del buzón actual
    • imap_num_recent - Obtiene el número de mensajes recientes en el buzón actual
    • imap_open - Abrir un flujo IMAP a un buzón
    • imap_ping - Comprobar si el flujo de IMAP está aún activo
    • imap_qprint - Convertir una cadena imprimible entrecomillada a una cadena de 8 bits
    • imap_rename - Alias de imap_renamemailbox
    • imap_renamemailbox - Renombrar un buzón antiguo a un buzón nuevo
    • imap_reopen - Reabrir un flujo IMAP hacia un nuevo buzón
    • imap_rfc822_parse_adrlist - Analiza una cadena de dirección
    • imap_rfc822_parse_headers - Analizar cabeceras de correo desde una cadena
    • imap_rfc822_write_address - Devuelve una dirección de correo correctamente formateada dados el buzón, host e información personal
    • imap_savebody - Guardar una sección del cuerpo específica en un fichero
    • imap_scan - Alias de imap_listscan
    • imap_scanmailbox - Alias de imap_listscan
    • imap_search - Esta función devuelve un array de mensajes que coinciden con el criterio de búsqueda dado
    • imap_setacl - Establece el ACL para el buzón dado
    • imap_setflag_full - Establece banderas en mensajes
    • imap_set_quota - Establece una cuota para un buzón dado
    • imap_sort - Obtiene y ordena mensajes
    • imap_status - Devuelve la información de estado de un buzón
    • imap_subscribe - Suscribirse a un buzón
    • imap_thread - Devuelve un árbol de mensajes hilados
    • imap_timeout - Establece o obtiene el tiempo de espera de imap
    • imap_uid - Esta función devuelve el UID del número de secuencia del mensaje dado
    • imap_undelete - Desmarcar el mensaje que está marcado para borrar
    • imap_unsubscribe - Cancelar la inscripción de un buzón
    • imap_utf7_decode - Decodifica una cadena codificada con UTF-7 modificado
    • imap_utf7_encode - Convierte una cadena ISO-8859-1 a un texto UTF-7 modifiicado
    • imap_utf8 - Convierte texto codificado MIME en UTF-8
    • imap_utf8_to_mutf7 - Encode a UTF-8 string to modified UTF-7
    • implode - Une elementos de un array en un string
    • inet_ntop - Convertir una dirección de internet empaquetada en una representación legible por humanos
    • inet_pton - Convertir una dirección IP legible por humanos a su representación in_addr empaquetada
    • InfiniteIterator::next - Mueve el iterador interno hacía adelante o se rebobina
    • InfiniteIterator::__construct - Construye un InfiniteIterator
    • inflate_add - Incrementally inflate encoded data
    • inflate_get_read_len - Get number of bytes read so far
    • inflate_get_status - Get decompression status
    • inflate_init - Initialize an incremental inflate context
    • ingres_autocommit - Activa o desactiva la autoconsigna
    • ingres_autocommit_state - Comprueba si la conexión usa la autoconsigna
    • ingres_charset - Devuelve el conjunto de caracteres de la instalación
    • ingres_close - Cierra una conexión a una base de datos de Ingres
    • ingres_commit - Consigna una trasacción
    • ingres_connect - Abre una conexión a una base de datos de Ingres
    • ingres_cursor - Obtiene el nombre de un cursor de un recurso de resultados dado
    • ingres_errno - Obtiene el número del último error generado de Ingres
    • ingres_error - Obtener un mensaje de error coherente del último error generado
    • ingres_errsqlstate - Obtiene el código del último error SQLSTATE generado
    • ingres_escape_string - Escapa caracteres especiales para usuarlos en una consulta
    • ingres_execute - Ejecuta una consulta preparada
    • ingres_fetch_array - Obtiene una fila de resultados en un array
    • ingres_fetch_assoc - Obtienen una fila de resultados en un array asociativo
    • ingres_fetch_object - Obtiene una fila de resultados en un objeto
    • ingres_fetch_proc_return - Obtiene el valor de retorno de una llamada a un procedimiento
    • ingres_fetch_row - Obtiene una fila de resultados en un array enumerado
    • ingres_field_length - Obtiene la longitud de un campo
    • ingres_field_name - Obtiene el nombre de un campo de un resultado de una consulta
    • ingres_field_nullable - Comprueba si un campo puede contener valores null
    • ingres_field_precision - Obtiene la precisión de un campo
    • ingres_field_scale - Obtiene la escala de un campo
    • ingres_field_type - Obtiene el tipo de un campo de un resultado de una consulta
    • ingres_free_result - Libera los recursos asociados a un identificador de resultados
    • ingres_next_error - Obtiene el siguiente error de Ingres
    • ingres_num_fields - Obtiene el número de campos devueltos por la última consulta
    • ingres_num_rows - Obtener el número de filas afectadas o devueltas por una consulta
    • ingres_pconnect - Abre una conexión persistente a una base de datos de Ingres
    • ingres_prepare - Prepara una consulta para su ejecución posterior
    • ingres_query - Envía una consulta SQL a Ingres
    • ingres_result_seek - Establece la posición de una fila antes de obtener datos
    • ingres_rollback - Revierte una transacción
    • ingres_set_environment - Establece las características de entorno que controlan las opciones de salida
    • ingres_unbuffered_query - Envía una consulta SQL no almacenada en búfer a Ingres
    • ini_alter - Alias de ini_set
    • ini_get - Devuelve el valor de una directiva de configuración
    • ini_get_all - Obtiene todas las opciones de configuración
    • ini_restore - Restablece el valor de una opción de configuración
    • ini_set - Establece el valor de una directiva de configuración
    • inotify_add_watch - Añade un seguimiento a una instancia inotify inicializada
    • inotify_init - Inicializa una instancia inotify
    • inotify_queue_len - Devuelve un número superior a cero si hay eventos pendientes
    • inotify_read - Lee eventos de una instancia inotify
    • inotify_rm_watch - Elimina un seguimiento existente de una instancia inotify
    • intdiv - División entera
    • interface_exists - Comprueba si una interfaz ha sido definida
    • IntlBreakIterator::createCharacterInstance - Crear un iterador de ruptura para los límites de secuencias de caracters combinados
    • IntlBreakIterator::createCodePointInstance - Crear un iterador de ruptura para los límites de puntos de código
    • IntlBreakIterator::createLineInstance - Crear un iterador de ruptura para las lógicamente posibles saltos de línea
    • IntlBreakIterator::createSentenceInstance - Crear un iterador de ruptura para rupturas de sentencias
    • IntlBreakIterator::createTitleInstance - Crear un iterador de ruptura para rupturas de marcos de título
    • IntlBreakIterator::createWordInstance - Crear un iterador de ruptura para ruptura de palabras
    • IntlBreakIterator::current - Obtiene el índice de la posición actual
    • IntlBreakIterator::first - Coloca la posición al primer caracter en el texto
    • IntlBreakIterator::following - Avanza el iterador al primer límite siguiendo un offset específico
    • IntlBreakIterator::getErrorCode - Obtener el código del último error del objeto
    • IntlBreakIterator::getErrorMessage - Obtener el último mensaje de error del objeto
    • IntlBreakIterator::getLocale - Obtiene el locale asociado al objeto
    • IntlBreakIterator::getPartsIterator - Crear un iterador para fragmentos de navegación entre límites
    • IntlBreakIterator::getText - Obtiene el texto que está siendo escaneado
    • IntlBreakIterator::isBoundary - Indicar si un índice es un índice de límites
    • IntlBreakIterator::last - Establecer la posición del iterador al índice tras el último carácter
    • IntlBreakIterator::next - Avanzar el iterador al siguiente límite
    • IntlBreakIterator::preceding - Establecer la posición del iterador al primer límite antes de un índice
    • IntlBreakIterator::previous - Establecer la posición del iterador al límite inmediatamente anterior al actual
    • IntlBreakIterator::setText - Establecer el texto a escanear
    • IntlBreakIterator::__construct - Constructor privado para denegar la instanciación
    • IntlCalendar::add - Añadir una candidad (con signo) de tiempo al campo
    • IntlCalendar::after - Indica si el instante de este objeto es posterior al del proporcionado
    • IntlCalendar::before - Indica si el instante de este objeto es anterior al del proporcionado
    • IntlCalendar::clear - Limpiar uno o todos los campos
    • IntlCalendar::createInstance - Crear un nuevo IntlCalendar
    • IntlCalendar::equals - Comparar el instante de dos objetos IntlCalendar
    • IntlCalendar::fieldDifference - Calcular la diferencia entre el instante dado y el de este objeto
    • IntlCalendar::fromDateTime - Crear un IntlCalendar desde un objeto DateTime o tring
    • IntlCalendar::get - Obtiene el valor de un campo
    • IntlCalendar::getActualMaximum - El valor máximo de un campo, considerando el instante actual del objeto
    • IntlCalendar::getActualMinimum - El valor mínimo de un campo, considerando el instante actual del objeto
    • IntlCalendar::getAvailableLocales - Obtener un array con las zonas para las que existen datos
    • IntlCalendar::getDayOfWeekType - Inidcar si un día es un día de entresemana, del fin de semana o un día de transición entre ambos
    • IntlCalendar::getErrorCode - Obtener el código de error del objeto
    • IntlCalendar::getErrorMessage - Obtener el últime mensaje de error del objeto
    • IntlCalendar::getFirstDayOfWeek - Obtener el primer día de la semana de la región del calendario
    • IntlCalendar::getGreatestMinimum - Obtener el valor mínimo local más grande de un campo
    • IntlCalendar::getKeywordValuesForLocale - Obtener un conjunto de valores de palabras clave de zonas
    • IntlCalendar::getLeastMaximum - Obtener el máximo local más pequeño de un campo
    • IntlCalendar::getLocale - Obtener la configuración regional asociada al objeto
    • IntlCalendar::getMaximum - Obtener el valor máximo global de un campo
    • IntlCalendar::getMinimalDaysInFirstWeek - Obtener el número mínimo de días que puede tener la primera semana de un año o mes
    • IntlCalendar::getMinimum - Obtener el valor mínimo de un campo
    • IntlCalendar::getNow - Obtener el número que representa el instante actual
    • IntlCalendar::getRepeatedWallTimeOption - Obtener el comportamiento para tratar horas repetidas
    • IntlCalendar::getSkippedWallTimeOption - Obtener el comportamiento para tratar horas omitidas
    • IntlCalendar::getTime - Obtiene el tiempo representado por el objeto
    • IntlCalendar::getTimeZone - Obtener la zona horaria del objeto
    • IntlCalendar::getType - Obtener el tipo de calendario
    • IntlCalendar::getWeekendTransition - Obtener el instante del día en la que comienza o termina el fin de semana
    • IntlCalendar::inDaylightTime - Indicar si el instante del objeto está en el horario de verano
    • IntlCalendar::isEquivalentTo - Indicar si otro calendario es igual pero para un instante diferente
    • IntlCalendar::isLenient - Indicar si la interpretación de una fecha/hora está en modo tolerante
    • IntlCalendar::isSet - Determina si un campo está definido
    • IntlCalendar::isWeekend - Determina si una cierta fecha es fin de semana
    • IntlCalendar::roll - Añadir un valor a un campo si acarrear más campos significativos
    • IntlCalendar::set - Establecer un campo de instante o varios campos en común de una vez
    • IntlCalendar::setFirstDayOfWeek - Establecer el día en el que se estima que empieza la semana
    • IntlCalendar::setLenient - Establecer si la interpretación de la fecha/hora es tolerante
    • IntlCalendar::setMinimalDaysInFirstWeek - Establecer el número de días mínimo que puede tener la primera semana de un año o mes
    • IntlCalendar::setRepeatedWallTimeOption - Establecer el comportamiento para tratar horas repetidas en transiciones negativas de índices de zonas horarias
    • IntlCalendar::setSkippedWallTimeOption - Establecer el comportamiento para tratar horas omitidas en transiciones positivas de índices de zonas horarias
    • IntlCalendar::setTime - Establecer el momento del calendario en milisegundos desde la época
    • IntlCalendar::setTimeZone - Establecer la zona horaria usada por este calendario
    • IntlCalendar::toDateTime - Convertir un objeto IntlCalendar a un objeto DateTime
    • IntlCalendar::__construct - Constructor privado para no permitir la creación de instancias
    • IntlChar::charAge - Obtener la «edad» del punto de código
    • IntlChar::charDigitValue - Obtener el valor del dígito decimal de un carácter de dígito decimal
    • IntlChar::charDirection - Obtener el valor de la categoría bidireccional de un punto de código
    • IntlChar::charFromName - Buscar un carácter Unicode por su nombre y devolver su valor de punto de código
    • IntlChar::charMirror - Obtener el carácter de «imagen reflejada» de un punto de código
    • IntlChar::charName - Obtener el nombre de un carácter Unicode
    • IntlChar::charType - Obtener el valor de la categoría general de un punto de código
    • IntlChar::chr - Devolver el carácter Unicode mediante su valor de punto de código
    • IntlChar::digit - Obtener el valor del dígito decimal de un punto de código para una base dada
    • IntlChar::enumCharNames - Enumerar todos los caracteres de Unicode con asignación dentro de un rango
    • IntlChar::enumCharTypes - Enumerar todos los puntos de código con sus categorías generales de Unicode
    • IntlChar::foldCase - Realiza un «plegamiento» de un punto de código
    • IntlChar::forDigit - Obtener la representación de un carácter para un dígito y base dados
    • IntlChar::getBidiPairedBracket - Obtener la pareja del carácter parentético de un punto de código
    • IntlChar::getBlockCode - Obtener el bloque de asignación de Unicode que contiene a un punto de código
    • IntlChar::getCombiningClass - Obtener la clase de combinación de un punto de cógido
    • IntlChar::getFC_NFKC_Closure - Obtener la propiedad FC_NFKC_Closure de un punto de código
    • IntlChar::getIntPropertyMaxValue - Obtener el valor máximo de una propiedad de Unicode
    • IntlChar::getIntPropertyMinValue - Obtener el valor mínimo de una propiedad de Unicode
    • IntlChar::getIntPropertyValue - Obtener el valor de una propiedad de Unicode para un punto de código
    • IntlChar::getNumericValue - Obtener el valor numérico de un punto de código de Unicode
    • IntlChar::getPropertyEnum - Obtener el valor de la constante de una propiedad para un nombre de propiedad dado
    • IntlChar::getPropertyName - Obtener el nombre Unicode de una propiedad
    • IntlChar::getPropertyValueEnum - Obtener el valor de una propiedad para un nombre de valor dado
    • IntlChar::getPropertyValueName - Obtener el nombre Unicode para un valor de una propiedad
    • IntlChar::getUnicodeVersion - Obtener la versión de Unicode
    • IntlChar::hasBinaryProperty - Comprobar una propiedad de Unicode binaria para un punto de código
    • IntlChar::isalnum - Comporbar si un punto de código es un carácter alfanumérico
    • IntlChar::isalpha - Comprobar si un punto de código es un caracter de letra
    • IntlChar::isbase - Comprobar si un punto de código es un carácter base
    • IntlChar::isblank - Comprobar si un punto de código es un carácter «en blanco» o de «espacio horizontal»
    • IntlChar::iscntrl - Comprobar si un punto de código es un carácter de control
    • IntlChar::isdefined - Comprobar si un punto de código está definido
    • IntlChar::isdigit - Comprobar si un punto de código es un carácter de dígito
    • IntlChar::isgraph - Comprobar si un punto de código es un caráter gráfico
    • IntlChar::isIDIgnorable - Comprobar si un punto de código es un carácter ignorable
    • IntlChar::isIDPart - Comprobar si un punto de código es permisible en un identificador
    • IntlChar::isIDStart - Comprobar si un punto de código es permisible como el primer carácter de un identificador
    • IntlChar::isISOControl - Comprobar si un punto de código es un código de control de ISO
    • IntlChar::isJavaIDPart - Comprobar si un punto de código es permisible en un identificador de Java
    • IntlChar::isJavaIDStart - Comprobar si un punto de código es permisible como el primer carácter de un identificador de Java
    • IntlChar::isJavaSpaceChar - Comprobar si un punto de código es un carácter de espacio según Java
    • IntlChar::islower - Comprobar si un punto de código es una letra minúscula
    • IntlChar::isMirrored - Comprobar si un punto de código posee la propiedad Bidi_Mirrored
    • IntlChar::isprint - Comprobar si un punto de código es un carácter imprimible
    • IntlChar::ispunct - Comprobar si un punto de código es un carácter de puntuación
    • IntlChar::isspace - Comprobar si un punto de código es un carácter de espacio
    • IntlChar::istitle - Comprobar si un punto de código es una letra titular
    • IntlChar::isUAlphabetic - Comprobar si un punto de código tiene la propiedad de Unicode Alphabetic
    • IntlChar::isULowercase - Comprobar si un punto de código tiene la propiedad de Unicode Lowercase
    • IntlChar::isupper - Comprobar si un punto de código tiene la categoría general "Lu" (letra mayúscula)
    • IntlChar::isUUppercase - Comprobar si un punto de código tiene la propiedad de Unicode Uppercase
    • IntlChar::isUWhiteSpace - Comprobar si un punto de código tiene la propiedad de Unicode White_Space
    • IntlChar::isWhitespace - Comprobar si un punto de código es un carácter de espacio en blanco según ICU
    • IntlChar::isxdigit - Comprobar si el punto de código es un dígito hexadecimal
    • IntlChar::ord - Devolver el valor del punto de código de Unicode de un carácter
    • IntlChar::tolower - Convertir a minúsculas un carácter Unicode
    • IntlChar::totitle - Convertir un carácter Unicode a letra titular
    • IntlChar::toupper - Convertir a mayúsculas un carácter Unicode
    • IntlCodePointBreakIterator::getLastCodePoint - Obtener el último punto de código ignorado después de que el iterdor avance o retroceda
    • IntlDateFormatter::create - Crear un formateador de fechas
    • IntlDateFormatter::format - Formatear el valor fecha/hora como una cadena
    • IntlDateFormatter::formatObject - Formatea un objeto
    • IntlDateFormatter::getCalendar - Obtener el tipo de calendario usado por el objeto IntlDateFormatter
    • IntlDateFormatter::getCalendarObject - Obtener una copia del objeto calendario del formateador
    • IntlDateFormatter::getDateType - Obtener el tipo de fecha usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::getErrorCode - Obtener el código del error de la última operación
    • IntlDateFormatter::getErrorMessage - Obtener el texto del error de la última operación
    • IntlDateFormatter::getLocale - Obtener la configuración regional usada por un formateador
    • IntlDateFormatter::getPattern - Obtener el patrón utilizado por un formateador de IntlDateFormatter
    • IntlDateFormatter::getTimeType - Obtener el tipo de hora usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::getTimeZone - Obtener la zona horaria del formateador
    • IntlDateFormatter::getTimeZoneId - Obtener el ID de la zona horario usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::isLenient - Obtener la tolerancia usada por un formateador de IntlDateFormatter
    • IntlDateFormatter::localtime - Convertir una cadena en un valor de marca de tiempo basado en un campo
    • IntlDateFormatter::parse - Convertir una cadena en un valor de marca de tiempo
    • IntlDateFormatter::setCalendar - Establecer el tipo de calendario usado por el formateador
    • IntlDateFormatter::setLenient - Establecer la tolerancia del analizador
    • IntlDateFormatter::setPattern - Establecer el patrón utilizado por el formateador de IntlDateFormatter
    • IntlDateFormatter::setTimeZone - Establece la zona horaria del formateador
    • IntlIterator::current - Obtiene el elemento actual
    • IntlIterator::key - Obtiene la clave actual
    • IntlIterator::next - Adelanta hasta el siguiente elemento
    • IntlIterator::rewind - Mueve el iterador al primer elemento
    • IntlIterator::valid - Comprueba si la posición actual es válida
    • IntlPartsIterator::getBreakIterator - Obtener un IntlBreakIterator respaldando este iterador de partes
    • IntlRuleBasedBreakIterator::getBinaryRules - Obtener la forma binaria de las reglas compiladas
    • IntlRuleBasedBreakIterator::getRules - Obtener el conjunto de reglas empleado para crear este objeto
    • IntlRuleBasedBreakIterator::getRuleStatus - Obtener el mayor valor de estado de las reglas de ruptura que determinaron la posición de ruptura actual
    • IntlRuleBasedBreakIterator::getRuleStatusVec - Obtener los valores de estado de las reglas de ruptura que determinaron la posición de ruptura acutal
    • IntlRuleBasedBreakIterator::__construct - Crear un iterador desde un conjunto de reglas
    • IntlTimeZone::countEquivalentIDs - Obtener el número de ID del grupo de equivalencias que incluye el ID dado
    • IntlTimeZone::createDefault - Crear una nueva copia de la zona horaria predeterminada para este host
    • IntlTimeZone::createEnumeration - Obtener una enumeración de ID de zonas horarias asociados al país o índice dado
    • IntlTimeZone::createTimeZone - Crear un objeto de zona horaria para el ID dado
    • IntlTimeZone::createTimeZoneIDEnumeration - Get an enumeration over system time zone IDs with the given filter conditions
    • IntlTimeZone::fromDateTimeZone - Crear un objeto de zona horaria desde DateTimeZone
    • IntlTimeZone::getCanonicalID - Obtener el ID canónico de la zona horaria del sistema o el ID normalizado de la zona horaria personalizada para el ID de zona horaria dado
    • IntlTimeZone::getDisplayName - Obtener un nombre de esta zona horaria apto para la presentación al usuario
    • IntlTimeZone::getDSTSavings - Obtener la cantidad de tiempo a añadir a la hora local estándar para obtener la hora local actual
    • IntlTimeZone::getEquivalentID - Obtener un ID del grupo de equivalencias que incluya el ID dado
    • IntlTimeZone::getErrorCode - Obtener el último código de error del objeto
    • IntlTimeZone::getErrorMessage - Obtener el último mensaje de error del objeto
    • IntlTimeZone::getGMT - Crear una zona horaria GMT (UTC)
    • IntlTimeZone::getID - Obtener el ID de la zona horaria
    • IntlTimeZone::getIDForWindowsID - Translate a Windows timezone into a system timezone
    • IntlTimeZone::getOffset - Obtener la zona horaria sin tratar y el índice GMT para el momento dado
    • IntlTimeZone::getRawOffset - Obtener el índice GMT sin tratar (antes de tomar en cuenta el horario de verano)
    • IntlTimeZone::getRegion - Get the region code associated with the given system time zone ID
    • IntlTimeZone::getTZDataVersion - Obtener la versión de los datos de zonas horarias actualmente usada por ICU
    • IntlTimeZone::getUnknown - Get the "unknown" time zone
    • IntlTimeZone::getWindowsID - Translate a system timezone into a Windows timezone
    • IntlTimeZone::hasSameRules - Comprobar si esta zona horaria tiene las mismas reglas e índices que otra
    • IntlTimeZone::toDateTimeZone - Convertir a un objeto DateTimeZone
    • IntlTimeZone::useDaylightTime - Comprobar si esta zona horaria utiliza el horario de verano
    • intl_error_name - Obtiene un nombre simbólico a partir de un código de error dado
    • intl_get_error_code - Obtiene el último código de error
    • intl_get_error_message - Obtener una descripción del último error
    • intl_is_failure - Comprueba si el código de error dado indica un fallo
    • intval - Obtiene el valor entero de una variable
    • in_array - Comprueba si un valor existe en un array
    • ip2long - Convierte una cadena que contiene una dirección con puntos del Protocolo de Internet (IPv4) en una dirección apropiada
    • iptcembed - Incluir información IPTC binaria en una imagen JPEG
    • iptcparse - Conviertir un bloque IPTC binario en simples etiquetas
    • isset - Determina si una variable está definida y no es null
    • is_a - Comprueba si un objeto es de una clase o tiene esta clase como una de sus madres
    • is_array - Comprueba si una variable es un array
    • is_bool - Comprueba si una variable es de tipo booleano
    • is_callable - Verificar que los contenidos de una variable puedan ser llamados como una función
    • is_countable - Verifica que el contenido de una variable es un valor contable
    • is_dir - Indica si el nombre de archivo es un directorio
    • is_double - Alias de is_float
    • is_executable - Indica si el nombre de archivo es ejecutable
    • is_file - Indica si el nombre de fichero es un fichero normal
    • is_finite - Encuentra si un valor es un número finito legal
    • is_float - Comprueba si el tipo de una variable es float
    • is_infinite - Encuentra si un valor es infinito
    • is_int - Comprueba si el tipo de una variable es integer
    • is_integer - Alias de is_int
    • is_iterable - Verifica que el contenido de una variable es un valor iterable
    • is_link - Indica si el nombre de archivo es un enlace simbólico
    • is_long - Alias de is_int
    • is_nan - Encuentra si un valor no es un número
    • is_null - Comprueba si una variable es null
    • is_numeric - Comprueba si una variable es un número o un string numérico
    • is_object - Comprueba si una variable es un objeto
    • is_readable - Indica si un fichero existe y es legible
    • is_real - Alias de is_float
    • is_resource - Comprueba si una variable es un recurso
    • is_scalar - Comprueba si una variable es escalar
    • is_soap_fault - Comprueba si una llamada SOAP ha fallado
    • is_string - Comprueba si una variable es de tipo string
    • is_subclass_of - Comprueba si el objeto tiene esta clase como uno de sus padres o si la implementa
    • is_tainted - Comprobar si un string está corrompido
    • is_uploaded_file - Indica si el archivo fue subido mediante HTTP POST
    • is_writable - Indica si un archivo existe y es escribible
    • is_writeable - Alias de is_writable
    • Iterator::current - Devuelve el elemento actual
    • Iterator::key - Devuelve la clave del elemento actual
    • Iterator::next - Avanza al siguiente elemento
    • Iterator::rewind - Rebobine la Iterator al primer elemento
    • Iterator::valid - Comprueba si la posición actual es válido
    • IteratorAggregate::getIterator - Recuperar un Iterator externo
    • IteratorIterator::current - Obtener el valor actual
    • IteratorIterator::getInnerIterator - Obtener el iterador interno
    • IteratorIterator::key - Obtener la clave del elemento actual
    • IteratorIterator::next - Avanzar al siguiente elemento
    • IteratorIterator::rewind - Rebobinar al primer elemento
    • IteratorIterator::valid - Comprobar si el iterador es válido
    • IteratorIterator::__construct - Crear un iterador de cualquier cosa que se pueda recorrer
    • iterator_apply - Llamar a una función para cada elemento de un iterador
    • iterator_count - Contar los elementos de un iterador
    • iterator_to_array - Copiar el iterador a un array
  • j
    • jddayofweek - Devuelve el día de la semana
    • jdmonthname - Devuelve el nombre de un mes
    • jdtofrench - Convierte una Fecha Juliana al Calendario Republicano Francés
    • jdtogregorian - Convierte una Fecha Juliana en una fecha Gregoriana
    • jdtojewish - Convierte una Fecha Juliana a una fecha del Calendario Judío
    • jdtojulian - Convierte una Fecha Juliana a una fecha del Calendario Juliano
    • jdtounix - Convierte una Fecha Juliana a una fecha Unix
    • jewishtojd - Convierte una fecha del Calendario Judío a una Fecha Juliana
    • join - Alias de implode
    • jpeg2wbmp - Convertir un archiov de imagen JPEG a un archivo de imagen WBMP
    • JsonSerializable::jsonSerialize - Especifica los datos que deberían serializarse para JSON
    • json_decode - Decodifica un string de JSON
    • json_encode - Retorna la representación JSON del valor dado
    • json_last_error - Devuelve el último error ocurrido
    • json_last_error_msg - Devuelve el string con el error de la última llamada a json_encode() o a json_decode()
    • juliantojd - Convierte una fecha del Calendario Juliano a una Fecha Juliana
  • k
    • key - Obtiene una clave de un array
    • key_exists - Alias de array_key_exists
    • krsort - Ordena un array por clave en orden inverso
    • ksort - Ordena un array por clave
  • l
    • lcfirst - Pasa a minúscula el primer caracter de un string
    • lcg_value - Generador lineal congruente combinado
    • lchgrp - Cambia el grupo de un enlace simbólico
    • lchown - Cambia el propietario de un enlace simbólico
    • ldap_8859_to_t61 - Traducir caracteres 8859 a caracteres t61
    • ldap_add - Agregar entradas al directorio de LDAP
    • ldap_add_ext - Add entries to LDAP directory
    • ldap_bind - Realiza la autenticación con un servidor LDAP
    • ldap_bind_ext - Bind to LDAP directory
    • ldap_close - Alias de ldap_unbind
    • ldap_compare - Comparar el valor del atributo encontrado en la entrada que se especificó con un DN
    • ldap_connect - Abre una conexión a un servidor LDAP
    • ldap_control_paged_result - Enviar el control de paginación LDAP
    • ldap_control_paged_result_response - Recuperar la cookie de paginación LDAP
    • ldap_count_entries - Contar el número de entradas en una búsqueda
    • ldap_delete - Eliminar una entrada de un directorio
    • ldap_delete_ext - Delete an entry from a directory
    • ldap_dn2ufn - Convertir un DN a un formato de nombramiento amigable al usuario
    • ldap_err2str - Convertir un número de error de LDAP a una cadena con un mensaje de error
    • ldap_errno - Devuelve el número de error LDAP del último comando LDAP
    • ldap_error - Devuelve el mensaje de error de LDAP del último comando LDAP
    • ldap_escape - Escapa una cadena de texto para su uso en un filtro LDAP o DN
    • ldap_exop - Performs an extended operation
    • ldap_exop_passwd - PASSWD extended operation helper
    • ldap_exop_refresh - Refresh extended operation helper
    • ldap_exop_whoami - WHOAMI extended operation helper
    • ldap_explode_dn - Divide un DN en sus partes componentes
    • ldap_first_attribute - Devolver el primer atributo
    • ldap_first_entry - Devolver el primer resultado de identificación
    • ldap_first_reference - Devolver la primera referencia
    • ldap_free_result - Liberar la memoria de resultado
    • ldap_get_attributes - Obtener atributos de una entrada de búsqueda de resultados
    • ldap_get_dn - Get the DN of a result entry
    • ldap_get_entries - Obtener todas las entradas de los resultados
    • ldap_get_option - Obtener el valor actual para la opción dada
    • ldap_get_values - Obtener todos los valores de una entrada de resultados
    • ldap_get_values_len - Obtener todos los valores binarios desde una entrada de resultados
    • ldap_list - Búsqueda de un solo nivel
    • ldap_modify - Modificar una entrada de LDAP
    • ldap_modify_batch - Batch and execute modifications on an LDAP entry
    • ldap_mod_add - Agregar valores de atributo a los atributos actuales
    • ldap_mod_add_ext - Add attribute values to current attributes
    • ldap_mod_del - Borrar valores de atributo de los atributos actuales
    • ldap_mod_del_ext - Delete attribute values from current attributes
    • ldap_mod_replace - Reemplazar valores de atributos con valores nuevos
    • ldap_mod_replace_ext - Replace attribute values with new ones
    • ldap_next_attribute - Obtener el siguiente atributo en un resultado
    • ldap_next_entry - Obtener el siguiente resultado de entrada
    • ldap_next_reference - Obtener la siguiente referencia
    • ldap_parse_exop - Parse result object from an LDAP extended operation
    • ldap_parse_reference - Extraer información de la entrada de referencia
    • ldap_parse_result - Extraer información del resultado
    • ldap_read - Leer una entrada
    • ldap_rename - Modificar el nombre de una entrada
    • ldap_rename_ext - Modify the name of an entry
    • ldap_sasl_bind - Unirse a un directorio LDAP utilizando SASL
    • ldap_search - Buscar el árbol LDAP
    • ldap_set_option - Establecer el valor de la opción proporcionada
    • ldap_set_rebind_proc - Establece una función de devolución de llamada para realizar revinculaciones en el rastreo referencial
    • ldap_sort - Clasificar entradas de resultados de LDAP en el lado del cliente
    • ldap_start_tls - Inciar TLS
    • ldap_t61_to_8859 - Traduce del conjunto de caracteres t61 al conjunto de caracteres 8859
    • ldap_unbind - Desenlazar de directorio LDAP
    • levenshtein - Cálculo de la distancia Levenshtein entre dos strings
    • libxml_clear_errors - Limpia el buffer de errores de libxml
    • libxml_disable_entity_loader - Deshabilita la capacidad de cargar entidades externas
    • libxml_get_errors - Recupera un array de errores
    • libxml_get_last_error - Recupera el último error de libxml
    • libxml_set_external_entity_loader - Cambia el cargador externo por defecto de entidades
    • libxml_set_streams_context - Configura el contexto de flujo para el próximo documento libxml cargado o escrito
    • libxml_use_internal_errors - Deshabilita errores libxml y permite al usuario extraer información de errores según sea necesario
    • LimitIterator::current - Obtiene el elemento actual
    • LimitIterator::getInnerIterator - Obtiene el iterador interno
    • LimitIterator::getPosition - Devuelve la posición actual
    • LimitIterator::key - Obtiene la clave actual
    • LimitIterator::next - Mueve el iterador a la siguiente posición
    • LimitIterator::rewind - Rebobina el iterador a un punto específicado
    • LimitIterator::seek - Mueve el apuntador interno a la posición dada
    • LimitIterator::valid - Comprobar si el elemento actual es válido
    • LimitIterator::__construct - Construye un LimitIterator
    • link - Crea un enlace duro
    • linkinfo - Obtiene información acerca de un enlace
    • list - Asignar variables como si fueran un array
    • Locale::acceptFromHttp - Intentar encontrar la mejor configuración regional basada en la cabecera "Accept-Language" de HTTP
    • Locale::canonicalize - Canonizar el string de configuración regional
    • Locale::composeLocale - Devolver un ID regional correctamente ordenado y delimitado
    • Locale::filterMatches - Comprobar si unfiltro de etiquetas de lenguaje coincide con una configuración regional
    • Locale::getAllVariants - Obtener las variantes de la configuración regional de entrada
    • Locale::getDefault - Obtener el valor de la configuración regional predeterminada del identificador global 'default_locale' de INTL
    • Locale::getDisplayLanguage - Devolver un nombre manifiesto debidamente localizado del lenguaje de la configuración regional de entrada
    • Locale::getDisplayName - Devolver un nombre manifiesto debidamente localizado de la configuración regional de entrada
    • Locale::getDisplayRegion - Devolver un nombre manifiesto debidamente localizado de la región de la configuración regional de entrada
    • Locale::getDisplayScript - Devolver un nombre manifiesto debidamente localizado de la escritura de la configuración regional de entrada
    • Locale::getDisplayVariant - Devolver un nombre manifiesto debidamente localizado de las variantes de la configuración regional de entrada
    • Locale::getKeywords - Obtener las palabras clave de la configuración regional de entrada
    • Locale::getPrimaryLanguage - Obtener el lenguaje principal de la configuración regional de entrada
    • Locale::getRegion - Obtener la región de la configuración local de entrada
    • Locale::getScript - Obtener la escritura de la configuración regional de entrada
    • Locale::lookup - Busca en la lista de etiquetas de lenguaje la mejor coincidencia para el lenguaje
    • Locale::parseLocale - Devolver un array de claves-valores de los elementos de las subetiquetas del ID regional
    • Locale::setDefault - Establecer la configuración regional predeterminada en tiempo de ejecución
    • localeconv - Obtener información sobre el formato numérico
    • localtime - Obtiene fecha y hora local
    • log - Logaritmo natural
    • log1p - Devuelve log(1 + numero), calculado de tal forma que no pierde precisión incluso cuando el valor del numero se aproxima a cero.
    • log10 - Logaritmo en base 10
    • log_cmd_delete - Función de retrollamada al borrar documentos
    • log_cmd_insert - Función de retrollamada al insertar documentos
    • log_cmd_update - Función de retrollamada al actualizar documentos
    • log_getmore - Función de retrollamada al obtener el próximo lote del cursor
    • log_killcursor - Función de retrollamada al ejecutar operaciones KILLCURSOR
    • log_reply - Función de retrollamada al leer una réplica de MongoDB
    • log_write_batch - Función de retrollamada al escribir lotes
    • long2ip - Convierte una dirección de red (IPv4) en una cadena de texto en formato con puntos estándar de internet
    • lstat - Da información acerca de un archivo o enlace simbólico
    • ltrim - Retira espacios en blanco (u otros caracteres) del inicio de un string
    • Lua::assign - Asigna una variable de PHP a Lua
    • Lua::call - Llama funciones de Lua
    • Lua::eval - Evalúa una cadena de texto como código Lua
    • Lua::getVersion - Obtiene la versión
    • Lua::include - Analiza un fichero script Lua
    • Lua::registerCallback - Registra una función PHP en Lua
    • Lua::__construct - Constructor de Lua
    • LuaClosure::__invoke - Invoke luaclosure
    • LuaSandbox::callFunction - Call a function in a Lua global variable
    • LuaSandbox::disableProfiler - Disable the profiler
    • LuaSandbox::enableProfiler - Enable the profiler.
    • LuaSandbox::getCPUUsage - Fetch the current CPU time usage of the Lua environment
    • LuaSandbox::getMemoryUsage - Fetch the current memory usage of the Lua environment
    • LuaSandbox::getPeakMemoryUsage - Fetch the peak memory usage of the Lua environment
    • LuaSandbox::getProfilerFunctionReport - Fetch profiler data
    • LuaSandbox::getVersionInfo - Return the versions of LuaSandbox and Lua
    • LuaSandbox::loadBinary - Load a precompiled binary chunk into the Lua environment
    • LuaSandbox::loadString - Load Lua code into the Lua environment
    • LuaSandbox::pauseUsageTimer - Pause the CPU usage timer
    • LuaSandbox::registerLibrary - Register a set of PHP functions as a Lua library
    • LuaSandbox::setCPULimit - Set the CPU time limit for the Lua environment
    • LuaSandbox::setMemoryLimit - Set the memory limit for the Lua environment
    • LuaSandbox::unpauseUsageTimer - Unpause the timer paused by LuaSandbox::pauseUsageTimer
    • LuaSandbox::wrapPhpFunction - Wrap a PHP callable in a LuaSandboxFunction
    • LuaSandboxFunction::call - Call a Lua function
    • LuaSandboxFunction::dump - Dump the function as a binary blob
    • LuaSandboxFunction::__construct - Unused
    • lzf_compress - Compresión LZF
    • lzf_decompress - Descompresión LZF
    • lzf_optimized_for - Determina para qué fue optimizada la extensión LZF
  • m
    • mail - Enviar correo
    • mailparse_determine_best_xfer_encoding - Obtiene la mejor forma de codificar
    • mailparse_msg_create - Crea un recurso de correo mime
    • mailparse_msg_extract_part - Extrae/decodifica una sección de mensaje
    • mailparse_msg_extract_part_file - Extrae/decodifica una sección de mensaje
    • mailparse_msg_extract_whole_part_file - Extrae una sección del mensaje incluyendo cabeceras sin descodificar la transferencia codificada
    • mailparse_msg_free - Libera un recurso MIME
    • mailparse_msg_get_part - Devuelve un gestor sobre una sección dada en un mensaje mime
    • mailparse_msg_get_part_data - Devuelve una matriz asociativa de información sobre el mensaje
    • mailparse_msg_get_structure - Devuelve una matriz de nombres de sección mime en el mensaje dado
    • mailparse_msg_parse - Procesar datos incrementalmente sobre un búfer
    • mailparse_msg_parse_file - Procesa un archivo
    • mailparse_rfc822_parse_addresses - Procesa direcciones compatibles con RFC 822
    • mailparse_stream_encode - Secuencia datos desde un apuntador de archivo, codifica y escribe a fp_destino
    • mailparse_uudecode_all - Procesa los datos desde un apuntador a archivo y extrae cada archivo embebido con codificación uu
    • main - Función main falsa
    • max - Encontrar el valor más alto
    • mb_check_encoding - Comprueba si el string es válido para a la codificación especificada
    • mb_chr - Get a specific character
    • mb_convert_case - Realiza una conversión a mayúsculas/minúsculas de un string
    • mb_convert_encoding - Convierte una codificación de caracteres
    • mb_convert_kana - Convierte un "kana" a otro ("zen-kaku", "han-kaku" y más)
    • mb_convert_variables - Convierte códigos de caracteres a variable/s
    • mb_decode_mimeheader - Decodifica un string en el campo de cabecera MIME
    • mb_decode_numericentity - Decodifica referencias a string numéricas de HTML en caracteres
    • mb_detect_encoding - Detecta la codificación de caracteres
    • mb_detect_order - Establece/obtiene el orden de detección de codificaciones de caracteres
    • mb_encode_mimeheader - Codifica un string para la cabecera MIME
    • mb_encode_numericentity - Convierte caracteres a referencias de string numéricas de HTML
    • mb_encoding_aliases - Obtiene los alias de un tipo de codificación conocido
    • mb_ereg - Comparación de expresiones regulares con soporte multibyte
    • mb_eregi - Comparación de expresiones regulares ignorando mayúsculas/minúsculas con soporte multibyte
    • mb_eregi_replace - Reemplaza una expresión regular con soporte multibyte ignorando mayúsculas/minúsculas
    • mb_ereg_match - Compararción de expresiones regulares para strings multibyte
    • mb_ereg_replace - Reemplaza una expresión regular con soporte multibyte
    • mb_ereg_replace_callback - Realiza una búsqueda y sustitución de una expresión regular con soporte multibyte usando una llamada de retorno
    • mb_ereg_search - Comparación de expresiones regulares multibyte para un string multibyte predefinido
    • mb_ereg_search_getpos - Devuelve la posición de inicio para la siguiente comparación de una expresión regular
    • mb_ereg_search_getregs - Recupera el resultado de la última comparación de expresión regular multibyte
    • mb_ereg_search_init - Configura el string y la expresión regular para una comparación de expresiones regulares multibyte
    • mb_ereg_search_pos - Devuelve la posición y la longitud de una parte coincidente de la expresión regular multibyte para un string multibyte predefinido
    • mb_ereg_search_regs - Devuelve la parte coincidente de una expresión regular multibyte
    • mb_ereg_search_setpos - Establece el punto de inicio de la siguiente comparación de una expresión regular
    • mb_get_info - Obtiene la configuración interna de mbstring
    • mb_http_input - Detecta la codificación de caracteres de entrada HTTP
    • mb_http_output - Establece/obtiene la codificación de caracteres de salida HTTP
    • mb_internal_encoding - Establece/obtiene la codificación de caracteres interna
    • mb_language - Establece/obtiene el idioma actual
    • mb_list_encodings - Devuelve un array con todos los tipos de codificaciones admitidas
    • mb_ord - Get code point of character
    • mb_output_handler - Función de llamada de retorno que convierte la codificación de caracteres en búfer de salida
    • mb_parse_str - Analiza datos GET/POST/COOKIE y establece varialbes globales
    • mb_preferred_mime_name - Obtener un string del conjunto de caracteres del MIME
    • mb_regex_encoding - Establecer/obtener la codificación de caracteres para expresiones regulares multibyte
    • mb_regex_set_options - Establece/obtiene las opciones predeterminadas para las funciones mbregex
    • mb_scrub - Description
    • mb_send_mail - Envía un correo codificado
    • mb_split - Divide cadenas de caracteres multibyte usando una expresión regular
    • mb_strcut - Obtener parte de un string
    • mb_strimwidth - Obtiene un string truncado con el ancho especificado
    • mb_stripos - Busca la posición de la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_stristr - Busca la primera ocurrencia de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_strlen - Obtiene la longitud de una cadena de caracteres
    • mb_strpos - Busca la posición de la primera ocurrencia de un string en otro string
    • mb_strrchr - Busca la última ocurrencia de un carácter de un string dentro de otro
    • mb_strrichr - Busca la última ocurrencia de un carácter de un string dentro de otro, insensible a mayúsculas/minúsculas
    • mb_strripos - Busca la posicion de la última ocurrencia de un string dentro de otro string, insensible a mayúsculas/minúsculas
    • mb_strrpos - Busca la posicion de la última ocurrencia de un string en otro string
    • mb_strstr - Busca la primera ocurrencia de un string dentro de otro
    • mb_strtolower - Convierte una cadena de caracteres a minúsculas
    • mb_strtoupper - Convierte un string en mayúsculas
    • mb_strwidth - Devuelve el ancho de un string
    • mb_str_split - Given a multibyte string, return an array of its characters
    • mb_substitute_character - Establece/obtiene un carácter de sustitución
    • mb_substr - Obtiene parte de una cadena de caracteres
    • mb_substr_count - Cuenta el número de ocurrencias de un substring
    • mcrypt_cbc - Encripta/decripta datos en modo CBC
    • mcrypt_cfb - Encripta/decripta datos en modo CFB
    • mcrypt_create_iv - Crea un vector de inicialización (IV) desde una fuente aleatoria
    • mcrypt_decrypt - Desencripta texto cifrado con los parámetros dados
    • mcrypt_ecb - Obsoleto: Encripta/decripta datos en modo ECB
    • mcrypt_encrypt - Cifra texto plano con los parámetros dados
    • mcrypt_enc_get_algorithms_name - Devuelve el nombre del algoritmo abierto
    • mcrypt_enc_get_block_size - Devuelve el tamaño del bloque del algoritmo abierto
    • mcrypt_enc_get_iv_size - Devuelve el tamaño del IV del algoritmo abierto
    • mcrypt_enc_get_key_size - Devuelve el tamaño de clave máximo soportado por el modo abierto
    • mcrypt_enc_get_modes_name - Devuelve el nombre del modo abierto
    • mcrypt_enc_get_supported_key_sizes - Devuelve un array con los tamaños de clave soportados por el algoritmo abierto
    • mcrypt_enc_is_block_algorithm - Chequea si el algoritmo del modo abierto es un algoritmo por bloques
    • mcrypt_enc_is_block_algorithm_mode - Chequea si el cifrado del modo abierto trabaja sobre bloques
    • mcrypt_enc_is_block_mode - Chequea si el modo abierto retorna bloques
    • mcrypt_enc_self_test - Ejecuta una prueba automática sobre el módulo abierto
    • mcrypt_generic - Esta función encripta datos
    • mcrypt_generic_deinit - Esta función deinicializa un módulo de cifrado
    • mcrypt_generic_end - Esta función termina el cifrado
    • mcrypt_generic_init - Esta función inicializa todos los buffers requeridos para el cifrado
    • mcrypt_get_block_size - Toma el tamaño del bloque del cifrador especificado
    • mcrypt_get_cipher_name - Toma el nombre del cifrador especificado
    • mcrypt_get_iv_size - Devuelve el tamaño del IV perteneciente a una combinación cifrador/modo específica
    • mcrypt_get_key_size - Toma el tamaño de clave del cifrador especificado
    • mcrypt_list_algorithms - Obtiene un array con todos los cifradores soportados
    • mcrypt_list_modes - Obtiene un array con todos los modos soportados
    • mcrypt_module_close - Cierra el módulo mcrypt
    • mcrypt_module_get_algo_block_size - Devuelve el tamaño de bloque del algoritmo especificado
    • mcrypt_module_get_algo_key_size - Devuelve el tamaño de clave máximo soportado por el modo abierto
    • mcrypt_module_get_supported_key_sizes - Devuelve un array con los tamaños de clave soportados del algoritmo abierto
    • mcrypt_module_is_block_algorithm - Esta función chequea si el algoritmo especificado es un algoritmo por bloques
    • mcrypt_module_is_block_algorithm_mode - Devuelve si el módulo especificado es un algoritmo por bloques o no
    • mcrypt_module_is_block_mode - Devuelve si el modo especificado retorna bloques o no
    • mcrypt_module_open - Abre el módulo del algoritmo y el modo a ser utilizados
    • mcrypt_module_self_test - Esta función ejecuta una prueba automática sobre el módulo especificado
    • mcrypt_ofb - Encripta/desencripta datos en modo OFB
    • md5 - Calcula el 'hash' md5 de un string
    • md5_file - Calcula el resumen criptográfico md5 de un archivo dado
    • mdecrypt_generic - Desencripta datos
    • Memcache::add - Añadir un valor en el servidor
    • Memcache::addServer - Añadir servidor memcache al grupo de conexiones
    • Memcache::close - Cierra la conexión al servidor memcached
    • Memcache::connect - Abre una conexión al servidor memcached
    • Memcache::decrement - Decrementa numéricamente un valor
    • Memcache::delete - Elimina un valor del servidor
    • Memcache::flush - Limpia todos los valores existentes en el servidor
    • Memcache::get - Obtener valor del servidor
    • Memcache::getExtendedStats - Obtener estadísticas de todos los servidores en el grupo
    • Memcache::getServerStatus - Devuelve el estado del servidor
    • Memcache::getStats - Obtiene estadísticas del servidor
    • Memcache::getVersion - Devuelve la versión del servidor
    • Memcache::increment - Incrementa numéricamente un valor
    • Memcache::pconnect - Abre una conexión persistente a memcached
    • Memcache::replace - Reemplaza el valor de un valor existente
    • Memcache::set - Guarda datos en el servidor
    • Memcache::setCompressThreshold - Activa compresión automática de valores con datos largos
    • Memcache::setServerParams - Cambia parámetros del servidor y estado en tiempo de ejecucción
    • Memcached::add - Añade un ítem asociado a una nueva clave
    • Memcached::addByKey - Añade un ítem asociado a una nueva clave en un servidor específico
    • Memcached::addServer - Añade un servidor a la provisión de servidores
    • Memcached::addServers - Añadir varios servidores a la agrupación de servidores
    • Memcached::append - Añadir datos a un ítem existente
    • Memcached::appendByKey - Añadir datos a un ítem existente en un servidor específico
    • Memcached::cas - Comparar e intercambiar un ítem
    • Memcached::casByKey - Comparar e intercambiar un ítem en un servidor específico
    • Memcached::decrement - Decrementar un valor numérico de un ítem
    • Memcached::decrementByKey - Decrementar un valor numérico de un ítem almacenado en un servidor específico
    • Memcached::delete - Eliminar un ítem
    • Memcached::deleteByKey - Eliminar un ítem de un servidor específico
    • Memcached::deleteMulti - Eliminar varios ítems
    • Memcached::deleteMultiByKey - Eliminar varios ítems de un servidor específico
    • Memcached::fetch - Obtener el siguiente resultado
    • Memcached::fetchAll - Obtener todos los resultados restantes
    • Memcached::flush - Invalidar todos los ítems de la caché
    • Memcached::get - Obtener un ítem
    • Memcached::getAllKeys - Obtiene las claves almacenadas en todos los servidores
    • Memcached::getByKey - Obtiene un ítem de un servidor específico
    • Memcached::getDelayed - Obtener varios ítems
    • Memcached::getDelayedByKey - Solicitar varios ítems de un servidor específico
    • Memcached::getMulti - Obtener varios ítems
    • Memcached::getMultiByKey - Recuperar varios ítems de un servidor específico
    • Memcached::getOption - Obtener el valor de una opción de Memcached
    • Memcached::getResultCode - Devuelve el código resultante de la última operación
    • Memcached::getResultMessage - Devolver un mensaje que describe el resultado de la última operación
    • Memcached::getServerByKey - Hacer corresponder una clave con un servidor
    • Memcached::getServerList - Obtener la lista de servidores de la agrupación
    • Memcached::getStats - Obtener las estadísticas de la agrupación de servidores
    • Memcached::getVersion - Obtener la información de la versión de la agrupación de servidores
    • Memcached::increment - Incrementar un valor numérico de un ítem
    • Memcached::incrementByKey - Incrementar un valor numérico de un ítem, almacenado en un servidor específico
    • Memcached::isPersistent - Comprueba si se está utilizando una conexión persistente a memcache
    • Memcached::isPristine - Comprobar si la instancia se creó recientemente
    • Memcached::prepend - Anteponer datos a un ítem existente
    • Memcached::prependByKey - Anteponer datos a un ítem existente en un servidor específico
    • Memcached::quit - Cierra cualquier conexión abierta
    • Memcached::replace - Reemplaza un ítem asociado a una clave existente
    • Memcached::replaceByKey - Reemplazar un ítem bajo una clave existente en un servidor específico
    • Memcached::resetServerList - Limpia todos los servidores de la lista de servidores
    • Memcached::set - Guardar un ítem
    • Memcached::setByKey - Guardar un ítem en un servidor específico
    • Memcached::setMulti - Almacenar varios ítems
    • Memcached::setMultiByKey - Almacena varios ítems en un servidor específico
    • Memcached::setOption - Establecer una opción de Memcached
    • Memcached::setOptions - Establecer opciones de Memcached
    • Memcached::setSaslAuthData - Establecer las credenciales para la autenticación
    • Memcached::touch - Establecer una nueva expiración para un ítem
    • Memcached::touchByKey - Establecer una nueva expiración para un ítem de un servidor específico
    • Memcached::__construct - Crear una instancia de Memcached
    • memcache_debug - Activa/desactiva debug output
    • memory_get_peak_usage - Devuelve el máximo de memoria asignada por PHP
    • memory_get_usage - Devuelve la cantidad de memoria asignada a PHP
    • MessageFormatter::create - Construir un nuevo Formateador de Mensajes
    • MessageFormatter::format - Dar formato al mensaje
    • MessageFormatter::formatMessage - Formateo rápido de un mensaje
    • MessageFormatter::getErrorCode - Obtener el código de error de la última operación
    • MessageFormatter::getErrorMessage - Obtener el texto del error de la última operación
    • MessageFormatter::getLocale - Obtener la configuración regional desde la que se creó el formateador
    • MessageFormatter::getPattern - Obtener el patrón usado por el formateador
    • MessageFormatter::parse - Procesar la cadena de entrada según un patrón
    • MessageFormatter::parseMessage - Procesar rápidamente una cadena de entrada
    • MessageFormatter::setPattern - Establecer el patrón usado por el formateador
    • metaphone - Calcula la clave metaphone de un string
    • method_exists - Comprueba si existe un método de una clase
    • mhash - Calcula el hash
    • mhash_count - Toma el mayor ID de hash disponible
    • mhash_get_block_size - Toma el tamaño de bloque del algoritmo hash especificado
    • mhash_get_hash_name - Toma el nombre del algoritmo hash especificado
    • mhash_keygen_s2k - Genera una clave
    • microtime - Devuelve la fecha Unix actual con microsegundos
    • mime_content_type - Detecta el MIME Content-type para un fichero
    • min - Encontrar el valor más bajo
    • mkdir - Crea un directorio
    • mktime - Obtener la marca de tiempo Unix de una fecha
    • money_format - Da formato a un número como un string de moneda
    • Mongo::connectUtil - Conecta con un servidor de bases de datos
    • Mongo::getPoolSize - Obtener el tamaño de las agrupaciones de conexiones
    • Mongo::getSlave - Devuelve la dirección usada por las lecturas de slaveOkay
    • Mongo::getSlaveOkay - Obtiene el valor de slaveOkay de esta conexión
    • Mongo::poolDebug - Devuelve información sobre todas las agrupaciones de conexiones
    • Mongo::setPoolSize - Establecer el tamaño para futuras agrupaciones de conexiones
    • Mongo::setSlaveOkay - Cambia el valor de slaveOkay para esta conexión
    • Mongo::switchSlave - Elije un nuevo secundario para lecturas slaveOkay
    • Mongo::__construct - El propósito de __construct
    • MongoBinData::__construct - Crea un nuevo objeto de datos binarios
    • MongoBinData::__toString - Representación en forma de string de este objeto de datos binarios
    • MongoClient::close - Cierra esta conexión
    • MongoClient::connect - Conecta a un servidor de bases de datos
    • MongoClient::dropDB - Elimina una base de datos [obsoleto]
    • MongoClient::getConnections - Devuelve información sobre todas las conexiones abiertas
    • MongoClient::getHosts - Actualiza el estado de todos los hosts asociados
    • MongoClient::getReadPreference - Obtener la preferencia de lectura para esta conexión
    • MongoClient::getWriteConcern - Obteenr el asunto de escritura para esta conexión
    • MongoClient::killCursor - Elimina un cursor específico del servidor
    • MongoClient::listDBs - Enumera todas las bases de datos disponibles
    • MongoClient::selectCollection - Obtiene una colección de bases de datos
    • MongoClient::selectDB - Obtiene una base de datos
    • MongoClient::setReadPreference - Establece la preferencia de lectura para esta conexión
    • MongoClient::setWriteConcern - Establecer el asunto de escritura para esta conexión
    • MongoClient::__construct - Crea un nuevo objeto de conexión a base de datos
    • MongoClient::__get - Obtiene una base de datos
    • MongoClient::__toString - Representación de cadena de esta conexión
    • MongoCode::__construct - Crea un nuevo objeto de código
    • MongoCode::__toString - Devuelve este código en forma de texto
    • MongoCollection::aggregate - Realiza una acumulación usando el framework de acumulación
    • MongoCollection::aggregateCursor - Ejecutar un comando de tubería acumulador y recuperar los resultados mediante un cursor
    • MongoCollection::batchInsert - Inserta múltiples documentos en esta colección
    • MongoCollection::count - Cuenta el número de documentos de esta colección
    • MongoCollection::createDBRef - Crea una referencia a una base de datos
    • MongoCollection::createIndex - Crea un índice en el campo o campos especificados, si aún no existen
    • MongoCollection::deleteIndex - Elimina un índice de esta colección
    • MongoCollection::deleteIndexes - Elimina todos los índices de esta colección
    • MongoCollection::distinct - Recupera una lista de valores distintos para una clave dada a través de una colección
    • MongoCollection::drop - Borra esta colección
    • MongoCollection::ensureIndex - Crea un índice en el campo o campos especificados, si aún no existen
    • MongoCollection::find - Consulta esta colección, devolviendo un objeto MongoCursor para el conjunto de resultados
    • MongoCollection::findAndModify - Actualizar un documento y devolverlo
    • MongoCollection::findOne - Realiza una consulta a esta colección, devolviendo sólo un elemento
    • MongoCollection::getDBRef - Captura el documento al que apunta una referencia de base de datos
    • MongoCollection::getIndexInfo - Devuelve información sobre los índices de esta colección
    • MongoCollection::getName - Devuelve el nombre de esta colección
    • MongoCollection::getReadPreference - Obtener la preferencia de lectura psrs esta colección
    • MongoCollection::getSlaveOkay - Consulta el valor de slaveOkay de esta colección
    • MongoCollection::getWriteConcern - Obtener el asunto de escritura para esta colección
    • MongoCollection::group - Lleva a cabo una operación similar al comando GROUP BY de SQL
    • MongoCollection::insert - Inserta un documento en la colección
    • MongoCollection::parallelCollectionScan - Devuelve un array con cursores para recorrer una colección completa en paralelo
    • MongoCollection::remove - Eliminar registros de esta colección
    • MongoCollection::save - Guarda un documento en esta colección
    • MongoCollection::setReadPreference - Establecer la preferencia de lectura para esta colección
    • MongoCollection::setSlaveOkay - Cambia el valor de slaveOkay de esta colección
    • MongoCollection::setWriteConcern - Establecer el asunto de escritura para esta base de datos
    • MongoCollection::toIndexString - Convierte claves especificando un índice para su string de identificación
    • MongoCollection::update - Actualizar registros basándose en los criterios proporcionados
    • MongoCollection::validate - Valida esta colección
    • MongoCollection::__construct - Crea una nueva colección
    • MongoCollection::__get - Obtiene una colección
    • MongoCollection::__toString - Representación en forma de string de esta colección
    • MongoCommandCursor::batchSize - Limita el número de elementos devueltos en un lote
    • MongoCommandCursor::createFromDocument - Crear un nuevo cursor de comando desde un documento de cursor existente
    • MongoCommandCursor::current - Devuelve el elemento actual
    • MongoCommandCursor::dead - Comprueba si hay resultados que aún no han sido enviados desde la base de datos
    • MongoCommandCursor::getReadPreference - Obtener la preferencia de lectura para este comando
    • MongoCommandCursor::info - Obtiene información sobre la creación e iteración del cursor
    • MongoCommandCursor::key - Devuelve el _id del resultado acutal
    • MongoCommandCursor::next - Avanza el cursor al siguiente resultado
    • MongoCommandCursor::rewind - Ejecuta el comando y reinicia el cursor al comienzo del conjunto de resultados
    • MongoCommandCursor::setReadPreference - Establecer la preferencia de lectura para este comando
    • MongoCommandCursor::timeout - Establece el tiempo de espera del lado del cliente para este comando
    • MongoCommandCursor::valid - Comprueba si el cursor está leyendo un resultado válido
    • MongoCommandCursor::__construct - Crear un nuevo cursor de comando
    • MongoCursor::addOption - Añade un par clave/valor de alto nivel a una consulta
    • MongoCursor::awaitData - Establece si el cursor esperará un momento a que un cursor de seguimiento devuelva más datos
    • MongoCursor::batchSize - Limita el número de elementos devueltos en un lote
    • MongoCursor::count - Cuenta el número de resultados de esta consulta
    • MongoCursor::current - Devuelve el elemento actual
    • MongoCursor::dead - Comprueba si hay resultados que no han sido enviados aún de la base de datos
    • MongoCursor::doQuery - Ejecutar un sentencia
    • MongoCursor::explain - Devuelve una explicación de la consulta, útil para la optimización y depuración
    • MongoCursor::fields - Establece los campos para una consulta
    • MongoCursor::getNext - Avanza el cursor al siguiente resultado y devuelve dicho resultado
    • MongoCursor::getReadPreference - Obtener la preferencia de lectura para esta consulta
    • MongoCursor::hasNext - Comprueba si existe algún elemento más en este cursor
    • MongoCursor::hint - Da a la base de datos un indicio sobre la consulta
    • MongoCursor::immortal - Establece si este cursor expirará
    • MongoCursor::info - Obtiene la información sobre la creación e iteración del cursor
    • MongoCursor::key - Devuelve el _id del resultado actual, o su índice dentro del conjunto de resultados
    • MongoCursor::limit - Limita el número de resultados devueltos
    • MongoCursor::maxTimeMS - Establece un tiempo límite en el lado del cliente para esta consulta
    • MongoCursor::next - Avanza el cursor al siguiente resultado, y devuelve dicho resultado
    • MongoCursor::partial - Si esta consulta debería obtener resultados parciales de mongos si un trozo ha caído
    • MongoCursor::reset - Limpia el cursor
    • MongoCursor::rewind - Devuelve el cursor al inicio del conjunto de resultados
    • MongoCursor::setFlag - Establece banderas arbitrarias en caso de que no haya métodos disponibles para una bandera específica
    • MongoCursor::setReadPreference - Establece la preferencia de lectura para esta consulta
    • MongoCursor::skip - Omite un número de resultados
    • MongoCursor::slaveOkay - Establece si esta consulta puede realizarse en un secundario [obsoleto]
    • MongoCursor::snapshot - Usar el modo 'snapshot' para la consulta
    • MongoCursor::sort - Ordena los resultados por el campo que se indique
    • MongoCursor::tailable - Establece si este cursor se dejará abierto después de obtener los últimos resultados
    • MongoCursor::timeout - Establece un tiempo de espera en el lado del cliente para esta consulta
    • MongoCursor::valid - Comprueba si el cursor está leyendo un resultado válido
    • MongoCursor::__construct - Crea un nuevo cursor
    • MongoCursorException::getHost - El nombre de host del servidor que encontró el error
    • MongoCursorInterface::batchSize - Limita el número de elementos devueltos en un lote
    • MongoCursorInterface::dead - Comprueba si existen resultados que aún no han sido enviados desde la base de datos
    • MongoCursorInterface::getReadPreference - Obtener la preferencia de lectura para esta consulta
    • MongoCursorInterface::info - Obtiene información sobre la creación e iteración del cursor
    • MongoCursorInterface::setReadPreference - Establecer la preferencia de lectura para esta consulta
    • MongoCursorInterface::timeout - Establece un tiempo de espera en el lado del cliente para esta consulta
    • MongoDate::toDateTime - Devuelve un objeto DateTime que representa esta fecha
    • MongoDate::__construct - Crea una nueva fecha
    • MongoDate::__toString - Devuelve una representación en forma de texto de esta fecha
    • MongoDB::authenticate - Iniciar sesión en esta base de datos
    • MongoDB::command - Ejecuta una orden de base de datos
    • MongoDB::createCollection - Crea una colección
    • MongoDB::createDBRef - Crea una referencia a base de datos
    • MongoDB::drop - Borra esta base de datos
    • MongoDB::dropCollection - Borra una colección [obsoleto]
    • MongoDB::execute - Ejecuta código JavaScript en el servidor de bases de datos [obsoleto]
    • MongoDB::forceError - Crea un error de base de datos
    • MongoDB::getCollectionInfo - Devuelve información sobre las colecciones de esta base de datos
    • MongoDB::getCollectionNames - Obtiene un array con los nombres de todas las colecciones de esta base de datos
    • MongoDB::getDBRef - Captura el documento que está siendo apuntado por una referencia de base de datos
    • MongoDB::getGridFS - Obtiene un objeto para trabajar con ficheros almacenados en esta base de datos
    • MongoDB::getProfilingLevel - Obtiene el nivel de perfilado (profiling) de la base de datos
    • MongoDB::getReadPreference - Obtener la preferencia de lectura para esta base de datos
    • MongoDB::getSlaveOkay - Devuelve el valor de slaveOkay de esta base de datos
    • MongoDB::getWriteConcern - Obtener el asunto de escritura para esta base de datos
    • MongoDB::lastError - Comprueba si hubo un error en la última operación de base de datos llevada a cabo
    • MongoDB::listCollections - Obtiene un array de objetos MongoCollection para todas las colecciones de esta base de datos
    • MongoDB::prevError - Comprueba el último error emitido durante una operación de base de datos
    • MongoDB::repair - Repara y compacta esta base de datos
    • MongoDB::resetError - Limpia cualquier error de la base de datos que se haya apuntado
    • MongoDB::selectCollection - Obtiene una colección
    • MongoDB::setProfilingLevel - Establece el nivel de perfilado (profiling) de la base de datos
    • MongoDB::setReadPreference - Establece la preferencia de lectura para esta base de datos
    • MongoDB::setSlaveOkay - Cambiar el valor de slaveOkay de esta base de datos
    • MongoDB::setWriteConcern - Establecer el asunto de escritura para esta base de datos
    • MongoDB::__construct - Crea una nueva base de datos
    • MongoDB::__get - Obtiene una colección
    • MongoDB::__toString - Nombre de esta base de datos
    • MongoDBRef::create - Crea una nueva referencia de base de datos
    • MongoDBRef::get - Captura el objeto al que apunta la referencia
    • MongoDBRef::isRef - Comprueba si un array es una referencia en la base de datos
    • MongoDB\BSON\Binary::getData - Returns the Binary's data
    • MongoDB\BSON\Binary::getType - Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize - Serialize a Binary
    • MongoDB\BSON\Binary::unserialize - Unserialize a Binary
    • MongoDB\BSON\Binary::__construct - Construct a new Binary
    • MongoDB\BSON\Binary::__toString - Returns the Binary's data
    • MongoDB\BSON\BinaryInterface::getData - Returns the BinaryInterface's data
    • MongoDB\BSON\BinaryInterface::getType - Returns the BinaryInterface's type
    • MongoDB\BSON\BinaryInterface::__toString - Returns the BinaryInterface's data
    • MongoDB\BSON\Decimal128::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize - Serialize a Decimal128
    • MongoDB\BSON\Decimal128::unserialize - Unserialize a Decimal128
    • MongoDB\BSON\Decimal128::__construct - Construct a new Decimal128
    • MongoDB\BSON\Decimal128::__toString - Returns the string representation of this Decimal128
    • MongoDB\BSON\Decimal128Interface::__toString - Returns the string representation of this Decimal128Interface
    • MongoDB\BSON\fromJSON - Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP - Returns the BSON representation of a PHP value
    • MongoDB\BSON\Javascript::getCode - Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope - Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize - Serialize a Javascript
    • MongoDB\BSON\Javascript::unserialize - Unserialize a Javascript
    • MongoDB\BSON\Javascript::__construct - Construct a new Javascript
    • MongoDB\BSON\Javascript::__toString - Returns the Javascript's code
    • MongoDB\BSON\JavascriptInterface::getCode - Returns the JavascriptInterface's code
    • MongoDB\BSON\JavascriptInterface::getScope - Returns the JavascriptInterface's scope document
    • MongoDB\BSON\JavascriptInterface::__toString - Returns the JavascriptInterface's code
    • MongoDB\BSON\MaxKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize - Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize - Unserialize a MaxKey
    • MongoDB\BSON\MaxKey::__construct - Construct a new MaxKey
    • MongoDB\BSON\MinKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize - Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize - Unserialize a MinKey
    • MongoDB\BSON\MinKey::__construct - Construct a new MinKey
    • MongoDB\BSON\ObjectId::getTimestamp - Returns the timestamp component of this ObjectId
    • MongoDB\BSON\ObjectId::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectId::serialize - Serialize an ObjectId
    • MongoDB\BSON\ObjectId::unserialize - Unserialize an ObjectId
    • MongoDB\BSON\ObjectId::__construct - Construct a new ObjectId
    • MongoDB\BSON\ObjectId::__toString - Returns the hexidecimal representation of this ObjectId
    • MongoDB\BSON\ObjectIdInterface::getTimestamp - Returns the timestamp component of this ObjectIdInterface
    • MongoDB\BSON\ObjectIdInterface::__toString - Returns the hexidecimal representation of this ObjectIdInterface
    • MongoDB\BSON\Regex::getFlags - Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern - Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize - Serialize a Regex
    • MongoDB\BSON\Regex::unserialize - Unserialize a Regex
    • MongoDB\BSON\Regex::__construct - Construct a new Regex
    • MongoDB\BSON\Regex::__toString - Returns the string representation of this Regex
    • MongoDB\BSON\RegexInterface::getFlags - Returns the RegexInterface's flags
    • MongoDB\BSON\RegexInterface::getPattern - Returns the RegexInterface's pattern
    • MongoDB\BSON\RegexInterface::__toString - Returns the string representation of this RegexInterface
    • MongoDB\BSON\Serializable::bsonSerialize - Provides an array or document to serialize as BSON
    • MongoDB\BSON\Timestamp::getIncrement - Returns the increment component of this Timestamp
    • MongoDB\BSON\Timestamp::getTimestamp - Returns the timestamp component of this Timestamp
    • MongoDB\BSON\Timestamp::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize - Serialize a Timestamp
    • MongoDB\BSON\Timestamp::unserialize - Unserialize a Timestamp
    • MongoDB\BSON\Timestamp::__construct - Construct a new Timestamp
    • MongoDB\BSON\Timestamp::__toString - Returns the string representation of this Timestamp
    • MongoDB\BSON\TimestampInterface::getIncrement - Returns the increment component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::getTimestamp - Returns the timestamp component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::__toString - Returns the string representation of this TimestampInterface
    • MongoDB\BSON\toCanonicalExtendedJSON - Returns the Canonical Extended JSON representation of a BSON value
    • MongoDB\BSON\toJSON - Returns the Legacy Extended JSON representation of a BSON value
    • MongoDB\BSON\toPHP - Returns the PHP representation of a BSON value
    • MongoDB\BSON\toRelaxedExtendedJSON - Returns the Relaxed Extended JSON representation of a BSON value
    • MongoDB\BSON\Unserializable::bsonUnserialize - Constructs the object from a BSON array or document
    • MongoDB\BSON\UTCDateTime::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize - Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime - Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize - Unserialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::__construct - Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString - Returns the string representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTimeInterface::toDateTime - Returns the DateTime representation of this UTCDateTimeInterface
    • MongoDB\BSON\UTCDateTimeInterface::__toString - Returns the string representation of this UTCDateTimeInterface
    • MongoDB\Driver\BulkWrite::count - Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete - Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert - Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update - Add an update operation to the bulk
    • MongoDB\Driver\BulkWrite::__construct - Create a new BulkWrite
    • MongoDB\Driver\Command::__construct - Create a new Command
    • MongoDB\Driver\Cursor::current - Returns the current element
    • MongoDB\Driver\Cursor::getId - Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer - Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead - Checks if the cursor is exhausted or may have additional results
    • MongoDB\Driver\Cursor::key - Returns the current result's index within the cursor
    • MongoDB\Driver\Cursor::next - Advances the cursor to the next result
    • MongoDB\Driver\Cursor::rewind - Rewind the cursor to the first result
    • MongoDB\Driver\Cursor::setTypeMap - Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray - Returns an array containing all results for this cursor
    • MongoDB\Driver\Cursor::valid - Checks if the current position in the cursor is valid
    • MongoDB\Driver\Cursor::__construct - Create a new Cursor (not used)
    • MongoDB\Driver\CursorId::serialize - Serialize a CursorId
    • MongoDB\Driver\CursorId::unserialize - Unserialize a CursorId
    • MongoDB\Driver\CursorId::__construct - Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::__toString - String representation of the cursor ID
    • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel - Returns whether an error label is associated with an exception
    • MongoDB\Driver\Exception\WriteException::getWriteResult - Returns the WriteResult for the failed write operation
    • MongoDB\Driver\Manager::createClientEncryption - Create a new ClientEncryption object
    • MongoDB\Driver\Manager::executeBulkWrite - Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand - Execute a database command
    • MongoDB\Driver\Manager::executeQuery - Execute a database query
    • MongoDB\Driver\Manager::executeReadCommand - Execute a database command that reads
    • MongoDB\Driver\Manager::executeReadWriteCommand - Execute a database command that reads and writes
    • MongoDB\Driver\Manager::executeWriteCommand - Execute a database command that writes
    • MongoDB\Driver\Manager::getReadConcern - Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference - Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers - Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern - Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer - Select a server matching a read preference
    • MongoDB\Driver\Manager::startSession - Start a new client session for use with this client
    • MongoDB\Driver\Manager::__construct - Create new MongoDB Manager
    • MongoDB\Driver\Query::__construct - Create a new Query
    • MongoDB\Driver\ReadConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::getLevel - Returns the ReadConcern's "level" option
    • MongoDB\Driver\ReadConcern::isDefault - Checks if this is the default read concern
    • MongoDB\Driver\ReadConcern::serialize - Serialize a ReadConcern
    • MongoDB\Driver\ReadConcern::unserialize - Unserialize a ReadConcern
    • MongoDB\Driver\ReadConcern::__construct - Create a new ReadConcern
    • MongoDB\Driver\ReadPreference::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::getHedge - Returns the ReadPreference's "hedge" option
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds - Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode - Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getModeString - Returns the ReadPreference's "mode" option as a string
    • MongoDB\Driver\ReadPreference::getTagSets - Returns the ReadPreference's "tagSets" option
    • MongoDB\Driver\ReadPreference::serialize - Serialize a ReadPreference
    • MongoDB\Driver\ReadPreference::unserialize - Unserialize a ReadPreference
    • MongoDB\Driver\ReadPreference::__construct - Create a new ReadPreference
    • MongoDB\Driver\Server::executeBulkWrite - Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand - Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery - Execute a database query on this server
    • MongoDB\Driver\Server::executeReadCommand - Execute a database command that reads on this server
    • MongoDB\Driver\Server::executeReadWriteCommand - Execute a database command that reads and writes on this server
    • MongoDB\Driver\Server::executeWriteCommand - Execute a database command that writes on this server
    • MongoDB\Driver\Server::getHost - Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo - Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency - Returns the latency of this server
    • MongoDB\Driver\Server::getPort - Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags - Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType - Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter - Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden - Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive - Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary - Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary - Checks if this server is a secondary member of a replica set
    • MongoDB\Driver\Server::__construct - Create a new Server (not used)
    • MongoDB\Driver\WriteConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::getJournal - Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW - Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout - Returns the WriteConcern's "wtimeout" option
    • MongoDB\Driver\WriteConcern::isDefault - Checks if this is the default write concern
    • MongoDB\Driver\WriteConcern::serialize - Serialize a WriteConcern
    • MongoDB\Driver\WriteConcern::unserialize - Unserialize a WriteConcern
    • MongoDB\Driver\WriteConcern::__construct - Create a new WriteConcern
    • MongoDB\Driver\WriteConcernError::getCode - Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo - Returns metadata document for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage - Returns the WriteConcernError's error message
    • MongoDB\Driver\WriteError::getCode - Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex - Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo - Returns metadata document for the WriteError
    • MongoDB\Driver\WriteError::getMessage - Returns the WriteError's error message
    • MongoDB\Driver\WriteResult::getDeletedCount - Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount - Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount - Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount - Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer - Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount - Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds - Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError - Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors - Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged - Returns whether the write was acknowledged
    • MongoDeleteBatch::__construct - Descripción
    • MongoGridFS::delete - Elimina un fichero y sus trozos de la base de datos
    • MongoGridFS::drop - Da de baja una colección de ficheros y de bloques
    • MongoGridFS::find - Selecciona ficheros
    • MongoGridFS::findOne - Devuelve el fichero que cumpla las condiciones
    • MongoGridFS::get - Obtiene un fichero de la base de datos
    • MongoGridFS::put - Almacena un fichero en la base de datos
    • MongoGridFS::remove - Eliminar ficheros y sus trozos de la base de datos
    • MongoGridFS::storeBytes - Almacena un string de bytes en la base de datos
    • MongoGridFS::storeFile - Almacena un fichero en la base de datos
    • MongoGridFS::storeUpload - Almacena un fichero subido en la base de datos
    • MongoGridFS::__construct - Crea una nueva colección de ficheros
    • MongoGridFSCursor::current - Devuelve el fichero actual
    • MongoGridFSCursor::getNext - Devuelve el siguiente fichero al que apunta este cursor, y avanza el cursor
    • MongoGridFSCursor::key - Devuelve el nombre de fichero del resultado actual
    • MongoGridFSCursor::__construct - Crea un nuevo cursor
    • MongoGridFSFile::getBytes - Devuelve el contenido de este fichero en forma de string de bytes
    • MongoGridFSFile::getFilename - Devuelve el nombre de este fichero
    • MongoGridFSFile::getResource - Devuelve un recurso que puede usarse para leer el fichero almacenado
    • MongoGridFSFile::getSize - Devuelve el tamaño de este fichero
    • MongoGridFSFile::write - Escribe este fichero en disco
    • MongoGridfsFile::__construct - Crea un nuevo fichero GridFS
    • MongoId::getHostname - Obtiene el nombre de host que se usa para el id de esta máquina
    • MongoId::getInc - Obtiene el valor incremental usado para crear este id
    • MongoId::getPID - Obtiene el ID del proceso
    • MongoId::getTimestamp - Devuelve el número de segundos desde la fecha de referencia con el que se creó este id
    • MongoId::isValid - Comprobar si un valor es un ObjectId válido
    • MongoId::__construct - Crea un nuevo id
    • MongoId::__set_state - Crea un objeto MongoId trivial
    • MongoId::__toString - Devuelve la representación hexadecimal de este id
    • MongoInsertBatch::__construct - Descripción
    • MongoInt32::__construct - Crea un nuevo entero de 32 bits
    • MongoInt32::__toString - Devuelve al representación en forma de string de este entero de 32 bits
    • MongoInt64::__construct - Crea un nuevo entero de 64 bits
    • MongoInt64::__toString - Devuelve la representación en forma de texto de este entero de 64 bits
    • MongoLog::getCallback - Obtiene la función de retrollamada establecida anteriormente
    • MongoLog::getLevel - Obtiene el nivel o niveles que están siendo registrados
    • MongoLog::getModule - Devuelve el módulo o módulos que se están registrando actualmente
    • MongoLog::setCallback - Establece una función de retrollamada para ser invocada por eventos
    • MongoLog::setLevel - Establece el nivel o niveles a registrar
    • MongoLog::setModule - Establece el módulo o módulos a registrar
    • MongoPool::getSize - Devuelve el tamaño actual de un agrupamiento de conexiones
    • MongoPool::info - Devuelve información sobre todos los agrupamientos de conexiones
    • MongoPool::setSize - Establece el tamaño de los nuevos agrupamientos de conexiones
    • MongoRegex::__construct - Crea una nueva expresión regular
    • MongoRegex::__toString - Representación en forma de texto de esta expresión regular
    • MongoResultException::getDocument - Recupera el documento resultante completo
    • MongoTimestamp::__construct - Crea una nueva marca temporal
    • MongoTimestamp::__toString - Devuelve la representación en forma de texto de este timestamp
    • MongoUpdateBatch::__construct - Descripción
    • MongoWriteBatch::add - Añade una operación de escritura a un lote
    • MongoWriteBatch::execute - Ejecuta un lote de operaciones de escritura
    • MongoWriteBatch::__construct - Crea un nuevo lote de operaciones de escritura
    • MongoWriteConcernException::getDocument - Obtener el documento del error
    • move_uploaded_file - Mueve un archivo subido a una nueva ubicación
    • mqseries_back - MQSeries MQBACK
    • mqseries_begin - MQseries MQBEGIN
    • mqseries_close - MQSeries MQCLOSE
    • mqseries_cmit - MQSeries MQCMIT
    • mqseries_conn - MQSeries MQCONN
    • mqseries_connx - MQSeries MQCONNX
    • mqseries_disc - MQSeries MQDISC
    • mqseries_get - MQSeries MQGET
    • mqseries_inq - MQSeries MQINQ
    • mqseries_open - MQSeries MQOPEN
    • mqseries_put - MQSeries MQPUT
    • mqseries_put1 - MQSeries MQPUT1
    • mqseries_set - MQSeries MQSET
    • mqseries_strerror - Returns the error message corresponding to a result code (MQRC)
    • msg_get_queue - Crear o adjuntar a una cola de mensajes
    • msg_queue_exists - Verificar si una cola de mensajes existe
    • msg_receive - Recibir un mensaje de la cola de mensajes
    • msg_remove_queue - Destruir una cola de mensajes
    • msg_send - Eviar un mensaje a una cola de mensajes
    • msg_set_queue - Establecer información en la estructura de datos de la cola de mensajes
    • msg_stat_queue - Devuelve información desde la estructura de datos de la cola de mensajes
    • mt_getrandmax - Mostrar el mayor valor aleatorio posible
    • mt_rand - Genera un mejor número entero aleatorio
    • mt_srand - Genera el mejor número aleatorio a partir de una semilla
    • MultipleIterator::attachIterator - Adjunta información al iterador
    • MultipleIterator::containsIterator - Comprueba si un iterador está adjunto
    • MultipleIterator::countIterators - Obtiene el número de instancias de iteradores adjuntos
    • MultipleIterator::current - Obtiene las instancias registradas del iterador
    • MultipleIterator::detachIterator - Desasocia un iterador
    • MultipleIterator::getFlags - Obtiene información de las flags
    • MultipleIterator::key - Obtiene las instancias registradas del iterador
    • MultipleIterator::next - Mueve todas las instancias de iterador adjuntadas hacía la siguiente
    • MultipleIterator::rewind - Rebobina todas las instancias de iterador adjuntadas
    • MultipleIterator::setFlags - Establece las flags
    • MultipleIterator::valid - Comprueba la validez de los subiteradores
    • MultipleIterator::__construct - Construye un nuevo MultipleIterator
    • Mutex::create - Create a Mutex
    • Mutex::destroy - Destroy Mutex
    • Mutex::lock - Acquire Mutex
    • Mutex::trylock - Attempt to Acquire Mutex
    • Mutex::unlock - Release Mutex
    • mysqli::$affected_rows - Obtiene el número de filas afectadas en la última operación MySQL
    • mysqli::$connect_errno - Devuelve el código de error de la última llamada
    • mysqli::$connect_error - Devuelve una cadena con la descripción del último error de conexión
    • mysqli::$errno - Devuelve el código del error de la última función llamada
    • mysqli::$error - Devuelve una cadena que describe el último error
    • mysqli::$error_list - Devuelve una lista de errores desde el último comando ejecutado
    • mysqli::$field_count - Devuelve el número de columnas para la consulta más reciente
    • mysqli::$host_info - Devuelve una cadena que representa el tipo de conexión usada
    • mysqli::$info - Obtiene la información de la última consulta ejecutada
    • mysqli::$insert_id - Devuelve el id autogenerado que se utilizó en la última consulta
    • mysqli::$protocol_version - Devuelve la versión del protocolo MySQL utilizada
    • mysqli::$server_info - Devuelve la versión del servidor MySQL
    • mysqli::$server_version - Devuelve la versión del servidor MySQL como un valor entero
    • mysqli::$sqlstate - Devuelve el error SQLSTATE de la operación de MySQL previa
    • mysqli::$thread_id - Deveulve el ID del hilo de la conexión actual
    • mysqli::$warning_count - Devuelve el número de mensajes de advertencia de la última consulta para un enlace dado
    • mysqli::autocommit - Activa o desactiva las modificaciones de la base de datos autoconsignadas
    • mysqli::begin_transaction - Inicia una transacción
    • mysqli::change_user - Cambia el usuario de la conexión de bases de datos especificada
    • mysqli::character_set_name - Devuelve el juego de caracteres predeterminado para la conexión a la base de datos
    • mysqli::close - Cierra una conexión previamente abierta a una base de datos
    • mysqli::commit - Consigna la transacción actual
    • mysqli::debug - Realiza operaciones de depuración
    • mysqli::dump_debug_info - Volcado de información de depuración en el registro
    • mysqli::get_charset - Devuelve un objeto que contiene el conjunto de caracteres
    • mysqli::get_client_info - Obtiene información de la biblioteca cliente de MySQL
    • mysqli::get_connection_stats - Devuelve estadísticas sobre la conexión del cliente
    • mysqli::get_warnings - Obtiene el resultado de SHOW WARNINGS
    • mysqli::init - Inicializa y devuelve un recurso para utilizarlo con mysqli_real_connect()
    • mysqli::kill - Pide al servidor poner fin a un hilo de MySQL
    • mysqli::more_results - Comprueba si hay más resultados de una multi consulta
    • mysqli::multi_query - Realiza una consulta a la base de datos
    • mysqli::next_result - Prepara el siguiente resultado de multi_query
    • mysqli::options - Establecer opciones
    • mysqli::ping - Comprueba la conexión al servidor, o trata de reconectar si se perdió la conexión
    • mysqli::poll - Almacena en caché conexiones
    • mysqli::prepare - Prepara una sentencia SQL para su ejecución
    • mysqli::query - Realiza una consulta a la base de datos
    • mysqli::real_connect - Abre una conexión a un servidor mysql
    • mysqli::real_escape_string - Escapa los caracteres especiales de una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
    • mysqli::real_query - Ejecuta una consulta SQL
    • mysqli::reap_async_query - Obtener el resultado de una consulta asincrónica
    • mysqli::refresh - Refresca
    • mysqli::release_savepoint - Elimina el punto salvado con nombre del conjunto de puntos salvados de la transacción actual
    • mysqli::rollback - Revierte la transacción actual
    • mysqli::savepoint - Define el nombre de un punto de salvaguarda de la transacción
    • mysqli::select_db - Selecciona la base de datos por defecto para realizar las consultas
    • mysqli::set_charset - Establece el conjunto de caracteres predeterminado del cliente
    • mysqli::set_opt - Alias de mysqli_options
    • mysqli::ssl_set - Usada para establece conexiones seguras usando SSL
    • mysqli::stat - Obtiene el estado actual del sistema
    • mysqli::stmt_init - Inicializa una sentencia y devuelve un objeto para usarlo con mysqli_stmt_prepare
    • mysqli::store_result - Transfiere un conjunto de resultados de la última consulta
    • mysqli::thread_safe - Devuelve si la seguridad a nivel de hilos está dada o no
    • mysqli::use_result - Inicia la recuperación de un conjunto de resultados
    • mysqli::__construct - Abre una nueva conexión al servidor de MySQL
    • mysqli_connect - Alias de mysqli::__construct
    • mysqli_driver::$report_mode - Habilita o desabilita las funciones internas de notificación
    • mysqli_driver::embedded_server_end - Detener el servidor incrustado
    • mysqli_driver::embedded_server_start - Inicializa e inicia el servidor embebido
    • mysqli_escape_string - Alias de mysqli_real_escape_string
    • mysqli_execute - Alias para mysqli_stmt_execute
    • mysqli_get_client_stats - Returns client per-process statistics
    • mysqli_get_client_version - Devuelve la versión clientes de MySQL como valor de tipo integer
    • mysqli_get_links_stats - Devolver información sobre enlaces abiertos y almacenados en caché
    • mysqli_report - Alias de mysqli_driver->report_mode
    • mysqli_result::$current_field - Obtener posición del campo actual de un puntero a un resultado
    • mysqli_result::$field_count - Obtiene el número de campos de un resultado
    • mysqli_result::$lengths - Retorna los largos de las columnas de la fila actual en el resultset
    • mysqli_result::$num_rows - Obtiene el número de filas de un resultado
    • mysqli_result::data_seek - Ajustar el puntero de resultado a una fila arbitraria del resultado
    • mysqli_result::fetch_all - Obtener todas las filas en un array asociativo, numérico, o en ambos
    • mysqli_result::fetch_array - Obtiene una fila de resultados como un array asociativo, numérico, o ambos
    • mysqli_result::fetch_assoc - Obtener una fila de resultado como un array asociativo
    • mysqli_result::fetch_field - Retorna el próximo campo del resultset
    • mysqli_result::fetch_fields - Devuelve un array de objetos que representan los campos de un conjunto de resultados
    • mysqli_result::fetch_field_direct - Obtener los metadatos de un único campo
    • mysqli_result::fetch_object - Devuelve la fila actual de un conjunto de resultados como un objeto
    • mysqli_result::fetch_row - Obtener una fila de resultados como un array enumerado
    • mysqli_result::field_seek - Establecer el puntero del resultado al índice del campo especificado
    • mysqli_result::free - Libera la memoria asociada a un resultado
    • mysqli_stmt::$affected_rows - Devuelve el número total de filas cambiadas, borradas, o insertadas por la última sentencia ejecutada
    • mysqli_stmt::$errno - Devuelve el código de error de la llamada de la sentencia más reciente
    • mysqli_stmt::$error - Devuelve una descripción en forma de string del último error de una sentencia
    • mysqli_stmt::$error_list - Devuelve una lista de errores de la última sentencia ejecutada
    • mysqli_stmt::$field_count - Devuelve el número de campos de la sentencia dada
    • mysqli_stmt::$insert_id - Obtener el ID generado en la operación INSERT anterior
    • mysqli_stmt::$num_rows - Devuelve el número de filas de un conjunto de resultados de una sentencia
    • mysqli_stmt::$param_count - Devuelve el número de parámetros de la sentencia dada
    • mysqli_stmt::$sqlstate - Devuelve el error SQLSTATE de la operación de sentencia previa
    • mysqli_stmt::attr_get - Se utiliza para obtener el valor actual de un atributo de la sentencia
    • mysqli_stmt::attr_set - Se utiliza para modificar el comportamiento de una sentencia preparada
    • mysqli_stmt::bind_param - Agrega variables a una sentencia preparada como parámetros
    • mysqli_stmt::bind_result - Vincula variables a una sentencia preparada para el almacenamiento de resultados
    • mysqli_stmt::close - Cierra una sentencia preparada
    • mysqli_stmt::data_seek - Busca una fila arbitraria en un conjunto de resultados de una sentencia
    • mysqli_stmt::execute - Ejecuta una consulta preparada
    • mysqli_stmt::fetch - Obtiene los resultados de una sentencia preparadas en las variables vinculadas
    • mysqli_stmt::free_result - Libera la memoria de los resultados almacenados del gestor de sentencia dado
    • mysqli_stmt::get_result - Obtiene un conjunto de resultados de una sentencia preparada
    • mysqli_stmt::get_warnings - Obtener los resultados de SHOW WARNINGS
    • mysqli_stmt::more_results - Comprobar si existen más resultados de una consulta de consultas múltiples
    • mysqli_stmt::next_result - Lee el siguiente resultado de una consulta múltiple
    • mysqli_stmt::prepare - Preparar una sentencia SQL para su ejecución
    • mysqli_stmt::reset - Reinicia una sentencia preparada
    • mysqli_stmt::result_metadata - Devuelve los metadatos del conjunto de resultados de una sentencia preparada
    • mysqli_stmt::send_long_data - Enviar datos en bloques
    • mysqli_stmt::store_result - Transfiere un conjunto de resultados desde una sentencia preparada
    • mysqli_stmt::__construct - Construye un nuevo objeto mysqli_stmt
    • mysqli_warning::next - El propósito next
    • MysqlndUhConnection::changeUser - Cambia el usuario de la conexión de la base de datos de mysqlnd especificada
    • MysqlndUhConnection::charsetName - Devuelve el conjunto de caracters predeterminado de la conexión de la base de datos
    • MysqlndUhConnection::close - Cierra una conexión a una base de datos abierta previamente
    • MysqlndUhConnection::connect - Abre una nueva conexión al servidor MySQL
    • MysqlndUhConnection::endPSession - Finaliza una conexión persistente
    • MysqlndUhConnection::escapeString - Escapa los caracteres especiales en una cadena para usarla en una sentencia SQL, tomando en cuenta el conjunto de caracteres actual de la conexión
    • MysqlndUhConnection::getAffectedRows - Obtiene el número de filas afectadas en una operación de MySQL anterior
    • MysqlndUhConnection::getErrorNumber - Devuelve el código de error de la llamada más reciente a una función
    • MysqlndUhConnection::getErrorString - Devuelve una descripción del último error
    • MysqlndUhConnection::getFieldCount - Devuelve el número de columnas de la consulta más reciente
    • MysqlndUhConnection::getHostInformation - Devuelve una representación de tipo string del tipo de conexión usada
    • MysqlndUhConnection::getLastInsertId - Devuelve el id autogenerado en la última consulta
    • MysqlndUhConnection::getLastMessage - Recupera información sobre la consulta ejecutadamás recientemente
    • MysqlndUhConnection::getProtocolInformation - Devuelve la versión del protocolo de MySQL usado
    • MysqlndUhConnection::getServerInformation - Devuelve la versión del servidor MySQL
    • MysqlndUhConnection::getServerStatistics - Obtiene el estado actual del sistema
    • MysqlndUhConnection::getServerVersion - Devuelve la versión del servidor MySQL en forma de entero
    • MysqlndUhConnection::getSqlstate - Devuelve el error SQLSTATE de la operación anterior de MySQL
    • MysqlndUhConnection::getStatistics - Devuelve estadísticas sobre la conexión cliente
    • MysqlndUhConnection::getThreadId - Devuelve el ID del hilo de la conexión en uso
    • MysqlndUhConnection::getWarningCount - Devuelve el número de advertencias de la última consulta para el enlace dado
    • MysqlndUhConnection::init - Iniciliza una conexión de mysqlnd
    • MysqlndUhConnection::killConnection - Pregunta al servidor para matar un subproceso de MySQL
    • MysqlndUhConnection::listFields - Enumera los campos de una tabla de MySQL
    • MysqlndUhConnection::listMethod - Envoltura para comandos de listas desordenadas
    • MysqlndUhConnection::moreResults - Comprueba si existen más resultados de consultas en una multiconsulta
    • MysqlndUhConnection::nextResult - Prepara el siguiente resultado de multi_query
    • MysqlndUhConnection::ping - Comprueba una conexión al servidor, o intenta reconectar si la conexión ha caído
    • MysqlndUhConnection::query - Realiza una consulta en la base de datos
    • MysqlndUhConnection::queryReadResultsetHeader - Lee una cabecera del conjunto de resultados
    • MysqlndUhConnection::reapQuery - Obtiene el resultado de una consulta asicrónica
    • MysqlndUhConnection::refreshServer - Vacía o reinicia las tablas y las cachés
    • MysqlndUhConnection::restartPSession - Reinicializa una conexión persistente a mysqlnd
    • MysqlndUhConnection::selectDb - Selecciona la base de datos predeterminada para su consulta
    • MysqlndUhConnection::sendClose - Envía un comando de cierre a MySQL
    • MysqlndUhConnection::sendQuery - Envía una consulta a MySQL
    • MysqlndUhConnection::serverDumpDebugInformation - Vierte la información de depuración en el registro para el servidor MySQL
    • MysqlndUhConnection::setAutocommit - Activa o desactiva la autoconsigna de las modificaciones de la base de datos
    • MysqlndUhConnection::setCharset - Establece el conjunto de caracteres predeterminado del cliente
    • MysqlndUhConnection::setClientOption - Establece una opción del cliente
    • MysqlndUhConnection::setServerOption - Establece una opción del servidor
    • MysqlndUhConnection::shutdownServer - The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand - Envía un comando COM_* básico
    • MysqlndUhConnection::simpleCommandHandleResponse - Procesa una respuesta para un comando COM_* básico enviado al cliente
    • MysqlndUhConnection::sslSet - Usado para establecer conexiones seguras con SSL
    • MysqlndUhConnection::stmtInit - Iniciliza una sentencia y devuelve un recurso para usarlo con mysqli_statement::prepare
    • MysqlndUhConnection::storeResult - Transfiere un conjunto de resultados de la última consulta
    • MysqlndUhConnection::txCommit - Consigna la transacción en uso
    • MysqlndUhConnection::txRollback - Revierte la transacción en uso
    • MysqlndUhConnection::useResult - Inicia una recuperación de un conjunto de resultados
    • MysqlndUhConnection::__construct - The __construct purpose
    • MysqlndUhPreparedStatement::execute - Ejecuta una consulta preparada
    • MysqlndUhPreparedStatement::prepare - Prepara una sentencia SQL para su ejecución
    • MysqlndUhPreparedStatement::__construct - The __construct purpose
    • mysqlnd_memcache_get_config - Devuelve información acerca de la configuración del complemento
    • mysqlnd_memcache_set - Asociar una conexión de MySQL con una conexión de Memcache
    • mysqlnd_ms_dump_servers - Devuelve una lista con los servidores actualmente configurados
    • mysqlnd_ms_fabric_select_global - Cambiar al servidor de fragmentación global para una tabla dada
    • mysqlnd_ms_fabric_select_shard - Cambiar a los fragmentos
    • mysqlnd_ms_get_last_gtid - Devuelve el último ID de transacciones global
    • mysqlnd_ms_get_last_used_connection - Devuelve un array que describe la última conexión usada
    • mysqlnd_ms_get_stats - Devuelve la distribución consultas y las estadísticas de conexión
    • mysqlnd_ms_match_wild - Comprueba si el nombre de una tabla coincide con un patrón comodín
    • mysqlnd_ms_query_is_select - Comprueba si se envía la conslta al servidor maestro, al esclavo, o al último servidor MySQL usado
    • mysqlnd_ms_set_qos - Establece la calidad de servicio necesaria de un clúster
    • mysqlnd_ms_set_user_pick_server - Establece una llamada de retorno para la división de lectura/escritura definida por el usuario
    • mysqlnd_ms_xa_begin - Inicia una transacción distribuida/XA entre servidores de MySQL
    • mysqlnd_ms_xa_commit - Consigna una transacción distribuida/XA entre servidores de MySQL
    • mysqlnd_ms_xa_gc - Recolecta basura de transacciones XA no finalizadas después de algún error del servidor
    • mysqlnd_ms_xa_rollback - Revierte una transacción distribuida/XA entre servidores de MySQL
    • mysqlnd_qc_clear_cache - Vacía todo el contenido de la caché
    • mysqlnd_qc_get_available_handlers - Devuelve una lista de los gestores de almacenamiento disponibles
    • mysqlnd_qc_get_cache_info - Devuelve información sobre el gestor en uso, el número de entradas de la caché y sobre las entradas de la caché, si está disponible
    • mysqlnd_qc_get_core_stats - Estadísticas recopiladas por el núcleo de la caché de consultas
    • mysqlnd_qc_get_normalized_query_trace_log - Devuelve un registro de rastreo de consultas normalizadas para cada consulta inspeccionada por la caché de consultas
    • mysqlnd_qc_get_query_trace_log - Devuelve información de rastreo para cada consulta inspeccionada por la caché de consultas
    • mysqlnd_qc_set_cache_condition - Establece las condiciones para el almacenamiento en caché automático
    • mysqlnd_qc_set_is_select - Instala una llamada de retorno que decide si una sentencia es almacenada en caché
    • mysqlnd_qc_set_storage_handler - Cambia el gestor de almacenamiento en uso
    • mysqlnd_qc_set_user_handlers - Establece las funciones de llamada de retorno para un gestor de almacenamiento procedimental definido por el usuario
    • mysqlnd_uh_convert_to_mysqlnd - Convierte un gestor de conexión de MySQL a uno de mysqlnd
    • mysqlnd_uh_set_connection_proxy - Instala un proxy para las conexiones de mysqlnd
    • mysqlnd_uh_set_statement_proxy - Instala un proxy para sentencias de mysqlnd
    • mysql_affected_rows - Obtiene el número de filas afectadas en la anterior operación de MySQL
    • mysql_client_encoding - Devuelve el nombre del conjunto de caracteres
    • mysql_close - Cerrar una conexión de MySQL
    • mysql_connect - Abre una conexión al servidor MySQL
    • mysql_create_db - Crea una base de datos MySQL
    • mysql_data_seek - Mueve el puntero de resultados interno
    • mysql_db_name - Recupera el nombre de la base de datos desde una llamada a mysql_list_dbs
    • mysql_db_query - Selecciona una base de datos y ejecuta una consulta sobre la misma
    • mysql_drop_db - Elimina (DROP) una base de datos MySQL
    • mysql_errno - Devuelve el valor numérico del mensaje de error de la última operación MySQL
    • mysql_error - Devuelve el texto del mensaje de error de la operación MySQL anterior
    • mysql_escape_string - Escapa una cadena para ser usada en mysql_query
    • mysql_fetch_array - Recupera una fila de resultados como un array asociativo, un array numérico o como ambos
    • mysql_fetch_assoc - Recupera una fila de resultados como un array asociativo
    • mysql_fetch_field - Obtiene la información de una columna de un resultado y la devuelve como un objeto
    • mysql_fetch_lengths - Obtiene la longitud de cada salida en un resultado
    • mysql_fetch_object - Recupera una fila de resultados como un objeto
    • mysql_fetch_row - Obtiene una fila de resultados como un array numérico
    • mysql_field_flags - Obtiene las banderas asociadas al campo especificado de un resultado
    • mysql_field_len - Devuelve la longitud del campo especificado
    • mysql_field_name - Obtiene el nombre del campo especificado de un resultado
    • mysql_field_seek - Establece el puntero del resultado en un índice de campo específicado
    • mysql_field_table - Obtiene el nombre de la tabla en la que está el campo especificado
    • mysql_field_type - Obtiene el tipo del campo especificado de un resultado
    • mysql_free_result - Libera la memoria del resultado
    • mysql_get_client_info - Obtiene información del cliente MySQL
    • mysql_get_host_info - Obtener información del anfitrión de MySQL
    • mysql_get_proto_info - Obtener información del protocolo MySQL
    • mysql_get_server_info - Obtiene información del servidor MySQL
    • mysql_info - Obtiene información sobre la consulta más reciente
    • mysql_insert_id - Obtiene el ID generado en la última consulta
    • mysql_list_dbs - Lista las bases de datos disponibles en un servidor MySQL
    • mysql_list_fields - Lista los campos de una tabla de MySQL
    • mysql_list_processes - Lista los procesos de MySQL
    • mysql_list_tables - Enumerar las tablas de una base de datos MySQL
    • mysql_num_fields - Obtiene el número de campos de un resultado
    • mysql_num_rows - Obtener el número de filas de un conjunto de resultados
    • mysql_pconnect - Abre una conexión persistente a un servidor MySQL
    • mysql_ping - Efectuar un chequeo de respuesta (ping) sobre una conexión al servidor o reconectarse si no hay conexión
    • mysql_query - Enviar una consulta MySQL
    • mysql_real_escape_string - Escapa caracteres especiales en una cadena para su uso en una sentencia SQL
    • mysql_result - Obtener datos de resultado
    • mysql_select_db - Seleccionar una base de datos MySQL
    • mysql_set_charset - Establece el conjunto de caracteres del cliente
    • mysql_stat - Obtiene el estado actual del sistema
    • mysql_tablename - Obtiene el nombre de la tabla de un campo
    • mysql_thread_id - Devuelve el ID del hilo actual
    • mysql_unbuffered_query - Envía una consulta SQL a MySQL, sin recuperar ni almacenar en búfer las filas de resultados
  • n
    • natcasesort - Ordenar un array usando un algoritmo de "orden natural" insensible a mayúsculas-minúsculas
    • natsort - Ordena un array usando un algoritmo de "orden natural"
    • ncurses_addch - Agregar un caracter en la posición actual y avanzar el cursor
    • ncurses_addchnstr - Agregar cadena con atributos y longitud especificada en la posición actual
    • ncurses_addchstr - Agregar una cadena con atributos en la posición actual
    • ncurses_addnstr - Agregar una cadena con la longitud especificada en la posición actual
    • ncurses_addstr - Imprimir texto en la posición actual
    • ncurses_assume_default_colors - Definir colores predeterminados para el color 0
    • ncurses_attroff - Deshabilitar los atributos dados
    • ncurses_attron - Habilitar los atributos dados
    • ncurses_attrset - Establecer los atributos dados
    • ncurses_baudrate - Devuelve la tasa de baudios de la terminal
    • ncurses_beep - Producir un beep en la terminal
    • ncurses_bkgd - Establecer la propiedad de segundo plano para la pantalla de la terminal
    • ncurses_bkgdset - Controla el segundo plano de la pantalla
    • ncurses_border - Dibujar un borde alrededor de la pantalla usando caracteres con atributos
    • ncurses_bottom_panel - Mueve un panel visible al fondo de la pila
    • ncurses_can_change_color - Comprobar si las definiciones de color del terminal se pueden cambiar
    • ncurses_cbreak - Desactivar el búfer de entrada
    • ncurses_clear - Limpiar la pantalla
    • ncurses_clrtobot - Limpiar la pantalla desde la posición actual al final
    • ncurses_clrtoeol - Limpiar la pantalla desde la posición actual al final de la línea
    • ncurses_color_content - Obtiene los componentes RGB de un color
    • ncurses_color_set - Establecer los colores de primer plano y fondo activos
    • ncurses_curs_set - Establecer el estado del cursor
    • ncurses_define_key - Definir un código de tecla
    • ncurses_def_prog_mode - Guarda los modos de terminal (programa)
    • ncurses_def_shell_mode - Guarda los modos de terminal (intérprete de comandos)
    • ncurses_delay_output - Retrasar la salida en la terminal usando caracteres de relleno
    • ncurses_delch - Eliminar un caracter en la posición actual, mover el resto de la línea hacia la izquierda
    • ncurses_deleteln - Eliminar una línea en la posición actual, mover el resto de la pantalla hacia arriba
    • ncurses_delwin - Eliminar una ventana ncurses
    • ncurses_del_panel - Remover un panel de la pila y eliminarlo (pero no la ventana asociada)
    • ncurses_doupdate - Escribir todas las actualizaciones preparadas sobre la terminal
    • ncurses_echo - Activar la repetición de entrada del teclado
    • ncurses_echochar - Salida de un caracter sencillo, incluyendo actualización
    • ncurses_end - Dejar de usar ncurses, limpiar la pantalla
    • ncurses_erase - Limpiar pantalla de terminal
    • ncurses_erasechar - Devuelve el caracter de borrado actual
    • ncurses_filter - Definir LINES para iniscr() y newterm() a 1
    • ncurses_flash - Relampaguear la pantalla de terminal (campana visual)
    • ncurses_flushinp - Volcar el búfer de entrada de teclado
    • ncurses_getch - Leer un caracter desde el teclado
    • ncurses_getmaxyx - Devuelve el tamaño de una ventana
    • ncurses_getmouse - Lee los eventos del ratón
    • ncurses_getyx - Devuelve la posición de cursor actual para una ventana
    • ncurses_halfdelay - Colocar la terminal en modo de medio retraso
    • ncurses_has_colors - Comprueba si el terminal tiene capacidades de color
    • ncurses_has_ic - Chequear por el soporte de inserción y borrado
    • ncurses_has_il - Chequea el soporte de inserción y borrado
    • ncurses_has_key - Chequear por la presencia de una tecla de función en el teclado de la terminal
    • ncurses_hide_panel - Remover un panel de la pila, haciéndolo invisible
    • ncurses_hline - Dibujar una línea horizontal en la posición actual usando un caracter con atributos, y de máximo n caracteres de largo
    • ncurses_inch - Obtener el caracter y los atributos de la posición actual
    • ncurses_init - Inicializar ncurses
    • ncurses_init_color - Definir un color de termimal
    • ncurses_init_pair - Definir una pareja de colores
    • ncurses_insch - Insertar un caracter, moviendo el resto de la línea, incluyendo el caracter en la posición actual
    • ncurses_insdelln - Insertar líneas antes de la línea actual, desplazando hacia abajo (los números negativos eliminan líneas y desplazan hacia arriba)
    • ncurses_insertln - Insertar una línea, mover el resto de la pantalla hacia abajo
    • ncurses_insstr - Insertar cadena en la posición actual, moviendo el resto de la línea hacia la derecha
    • ncurses_instr - Lee una cadena desde la pantalla de terminal
    • ncurses_isendwin - Ncurses está en modo endwin, se puede realizar una salida normal por pantalla
    • ncurses_keyok - Habilitar o deshabilitar un código de tecla
    • ncurses_keypad - Activa o desactiva el teclado numérico
    • ncurses_killchar - Devuelve el caracter de eliminación de línea actual
    • ncurses_longname - Devuelve la descripción de la terminal
    • ncurses_meta - Habilita/deshabilita la meta-información de 8-bits de tecla
    • ncurses_mouseinterval - Establecer el tiempo de espera para clics de botón del mouse
    • ncurses_mousemask - Establece las opciones del ratón
    • ncurses_mouse_trafo - Transforma coordenadas
    • ncurses_move - Mover la posición de salida
    • ncurses_move_panel - Mueve un panel de modo que su esquina superior izquierda se encuentre en [comienzo_x, comienzo_y]
    • ncurses_mvaddch - Mover la posición actual y agregar un caracter
    • ncurses_mvaddchnstr - Mover la posición y agregar una cadena con atributos con la longitud especificada
    • ncurses_mvaddchstr - Mover la posición y agregar una cadena con atributos
    • ncurses_mvaddnstr - Mover la posición y agregar una cadena con la longitud especificada
    • ncurses_mvaddstr - Mover la posición y agregar una cadena
    • ncurses_mvcur - Mover el cursor inmediatamente
    • ncurses_mvdelch - Mover la posición y eliminar un caracter, desplazar el resto de la línea hacia la izquierda
    • ncurses_mvgetch - Mover la posición y obtener el caracter en la nueva posición
    • ncurses_mvhline - Establecer una nueva posición y dibujar una línea horizontal usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_mvinch - Mover la posición y obtener el caracter con atributos en la nueva posición
    • ncurses_mvvline - Establecer una nueva posición y dibujar una línea vertical usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_mvwaddstr - Añadir una cadena en una posicón nueva de la ventana
    • ncurses_napms - Dormir
    • ncurses_newpad - Crea un nuevo pad (ventana)
    • ncurses_newwin - Crear una nueva ventana
    • ncurses_new_panel - Crear un nuevo panel y asociarlo con una ventana
    • ncurses_nl - Traducir línea nueva y retorno de carro / alimentación de línea
    • ncurses_nocbreak - Cambiar la terminal a modo normal (cooked)
    • ncurses_noecho - Desactivar la repetición de entrada del teclado
    • ncurses_nonl - No traducir línea nueva y retorno de carro / alimentación de línea
    • ncurses_noqiflush - No realizar volcados en caracteres de señales
    • ncurses_noraw - Salir del modo puro en la terminal
    • ncurses_pair_content - Obtiene los colores de primer plano y fondo de una pareja de colores
    • ncurses_panel_above - Devuelve el panel encima del panel indicado
    • ncurses_panel_below - Devuelve el panel por debajo del panel indicado
    • ncurses_panel_window - Devuelve la ventana asociada con el panel
    • ncurses_pnoutrefresh - Copia una región desde un pad a la pantalla virtual
    • ncurses_prefresh - Copia una región desde un pad a la pantalla virtual
    • ncurses_putp - Aplicar la información de márgenes a la cadena e imprimirla
    • ncurses_qiflush - Producir volcado en caracteres de señales
    • ncurses_raw - Colocar la terminal en modo puro
    • ncurses_refresh - Refrescar la pantalla
    • ncurses_replace_panel - Reemplaza la ventana asociada con el panel
    • ncurses_resetty - Restablece el estado guardado de la terminal
    • ncurses_reset_prog_mode - Restablece el modo de programa guardado por def_prog_mode
    • ncurses_reset_shell_mode - Restablece el modo de intérprete de comandos guardado por def_shell_mode
    • ncurses_savetty - Guarda el estado de la terminal
    • ncurses_scrl - Desplazar el contenido de la ventana hacia arriba o abajo sin cambiar la posición actual
    • ncurses_scr_dump - Vuelca el contenido de la pantalla en un archivo
    • ncurses_scr_init - Inicializar la pantalla desde un volcado en un archivo
    • ncurses_scr_restore - Recuperar la pantalla desde un volcado en un archivo
    • ncurses_scr_set - Heredar la pantalla de un volcado en un archivo
    • ncurses_show_panel - Coloca un panel invisible al comienzo de la pila, haciéndola visible
    • ncurses_slk_attr - Devuelve el atributo de la etiqueta suave de teclado
    • ncurses_slk_attroff - Deshabilitar los atributos dados para las etiquetas suaves de teclado
    • ncurses_slk_attron - Habilitar los atributos dados para las etiquetas suaves de funciones de teclado
    • ncurses_slk_attrset - Definir los atributos dados para las etiquetas suaves de funciones de teclado
    • ncurses_slk_clear - Limpia las etiquetas suaves de la pantalla
    • ncurses_slk_color - Establece el color para las etiquetas suaves de teclado
    • ncurses_slk_init - Inicializa las funciones de tecla de etiquetación suave
    • ncurses_slk_noutrefresh - Copia las etiquetas suaves de teclado a la pantalla virtual
    • ncurses_slk_refresh - Copia las etiquetas suaves de teclado a la pantalla
    • ncurses_slk_restore - Recupera las etiquetas suaves de teclado
    • ncurses_slk_set - Establece las etiquetas de teclado
    • ncurses_slk_touch - Obliga a que se produzca salida cuando se ejecute ncurses_slk_noutrefresh
    • ncurses_standend - Dejar de usar el atributo 'standout'
    • ncurses_standout - Comenzar a usar el atributo 'standout'
    • ncurses_start_color - Inicializa la funcionalidad de color
    • ncurses_termattrs - Devuelve un valor OR lógico de todas las banderas de atributos soportados por la terminal
    • ncurses_termname - Devuelve el nombre (corto) de la terminal
    • ncurses_timeout - Establecer el tiempo de espera para secuencias especiales de teclas
    • ncurses_top_panel - Mueve un panel visible al tope de la pila
    • ncurses_typeahead - Especificar un descriptor de archivo diferente para el chequeo de escritura siguiente
    • ncurses_ungetch - Colocar un caracter de vuelta en la secuencia de entrada
    • ncurses_ungetmouse - Coloca un evento de mouse en la cola
    • ncurses_update_panels - Refresca la pantalla virtual, para reflejar las relaciones entre los paneles en la pila
    • ncurses_use_default_colors - Asignar los colores predeterminados de la terminal al id de color -1
    • ncurses_use_env - Controlar el uso de información del entorno sobre el tamaño de la terminal
    • ncurses_use_extended_names - Controlar el uso de nombres extendidos en descripciones de información de terminal
    • ncurses_vidattr - Desplegar la cadena en la terminal con el atributo de modo de video
    • ncurses_vline - Dibujar una línea vertical en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres
    • ncurses_waddch - Agrega un caracter en la posición actual de una ventana y avanza el cursor
    • ncurses_waddstr - Imprime un texto en la posición actual de una ventana
    • ncurses_wattroff - Deshabilita los atributos para una ventana
    • ncurses_wattron - Habilita los atributos para una ventana
    • ncurses_wattrset - Establecer los atributos para una ventana
    • ncurses_wborder - Dibuja un borde alrededor de la ventana usando caracteres con atributos
    • ncurses_wclear - Limpia la ventana
    • ncurses_wcolor_set - Establece parejas de colores en la ventana
    • ncurses_werase - Eliminar los contenidos de la ventana
    • ncurses_wgetch - Lee un caracter desde el teclado (en la ventana)
    • ncurses_whline - Dibuja una línea horizontal en una ventana en la posición actual usando un caracter con atributos y un largo máximo de n caracteres
    • ncurses_wmouse_trafo - Transforma coordenadas de ventana/stdscr
    • ncurses_wmove - Mueve la posición de salida de la ventana
    • ncurses_wnoutrefresh - Copia la ventana a la pantalla virtual
    • ncurses_wrefresh - Refrescar la ventana en la pantalla de terminal
    • ncurses_wstandend - Finaliza el modo standout para una ventana
    • ncurses_wstandout - Ingresar a modo standout en una ventana
    • ncurses_wvline - Dibuja una línea vertical en una ventana en la posición actual usando un caracter con atributos y una longitud máxima de n caracteres
    • next - Avanza el puntero interno de un array
    • ngettext - Versión plural de gettext
    • nl2br - Inserta saltos de línea HTML antes de todas las nuevas líneas de un string
    • nl_langinfo - Consulta información sobre el idioma y la configuración regional
    • NoRewindIterator::current - Obtener el valor actual
    • NoRewindIterator::getInnerIterator - Obtiene el iterador interno
    • NoRewindIterator::key - Obtiene la clave actual
    • NoRewindIterator::next - Avanza al siguiente elemento
    • NoRewindIterator::rewind - Evita la operación de rebobinado en el iterador interno
    • NoRewindIterator::valid - Valida el iterador
    • NoRewindIterator::__construct - Construye un NoRewindIterator
    • Normalizer::getRawDecomposition - Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
    • Normalizer::isNormalized - Comprobar si la cadena proporcionada ya está en la forma de normalización especificada.
    • Normalizer::normalize - Normaliza la entrada provista y devuelve la cadena normalizada
    • NumberFormatter::create - Crear un formateador de números
    • NumberFormatter::format - Dar formato a un número
    • NumberFormatter::formatCurrency - Dar formato a un valor monetario
    • NumberFormatter::getAttribute - Obtener un atributo
    • NumberFormatter::getErrorCode - Obtener el último código de error del formateador
    • NumberFormatter::getErrorMessage - Obtener el último mensaje de error del formateador
    • NumberFormatter::getLocale - Obtener la configuración regional de un formateador
    • NumberFormatter::getPattern - Obtener el patrón del formateador
    • NumberFormatter::getSymbol - Obtener el valor de un símbolo
    • NumberFormatter::getTextAttribute - Obtiene un atributo de texto
    • NumberFormatter::parse - Analiza un número
    • NumberFormatter::parseCurrency - Procesa un número monetario
    • NumberFormatter::setAttribute - Establecer un atributo
    • NumberFormatter::setPattern - Establecer el patrón de un formateador
    • NumberFormatter::setSymbol - Establecer un valor de símbolo
    • NumberFormatter::setTextAttribute - Set a text attribute
    • number_format - Formatear un número con los millares agrupados
  • o
    • OAuth::disableDebug - Desactiva la depuración detallada
    • OAuth::disableRedirects - Desactiva las redirecciones
    • OAuth::disableSSLChecks - Desactiva la verificación SSL
    • OAuth::enableDebug - Activa la depuración detallada
    • OAuth::enableRedirects - Activa las re-direcciones
    • OAuth::enableSSLChecks - Activa la verificación SSL
    • OAuth::fetch - Obtiene un recurso protegido por OAuth
    • OAuth::generateSignature - Generar una firma
    • OAuth::getAccessToken - Obtiene el token de acceso
    • OAuth::getCAPath - Obtiene la información CA
    • OAuth::getLastResponse - Obtiene la última respuesta
    • OAuth::getLastResponseHeaders - Obtener encabezados de la última respuesta
    • OAuth::getLastResponseInfo - Obtiene la información HTTP sobre la última respuesta
    • OAuth::getRequestHeader - Generar un string de firma de cabecera OAuth
    • OAuth::getRequestToken - Obtiene un token de petición
    • OAuth::setAuthType - Establece el tipo de autorización
    • OAuth::setCAPath - Establece la ruta a CA y su información
    • OAuth::setNonce - Configura el nonce para las solicitudes posteriores
    • OAuth::setRequestEngine - El propósito de setRequestEngine
    • OAuth::setRSACertificate - establece el certificado RSA
    • OAuth::setSSLChecks - Ajustar controles específicos de SSL para las solicitudes
    • OAuth::setTimestamp - Establece el timestamp
    • OAuth::setToken - Establece el token y el secreto
    • OAuth::setVersion - Configura la versión OAuth
    • OAuth::__construct - Crea un nuevo objeto OAuth
    • OAuth::__destruct - El destructor
    • OAuthProvider::addRequiredParameter - Agregar parámetros necesarios
    • OAuthProvider::callconsumerHandler - Llama al callback consumerNonceHandler
    • OAuthProvider::callTimestampNonceHandler - Llama al callback timestampNonceHandler
    • OAuthProvider::calltokenHandler - Llama al callback tokenNonceHandler
    • OAuthProvider::checkOAuthRequest - Revisa una petición OAuth
    • OAuthProvider::consumerHandler - Establece el manejador callback consumerHandler
    • OAuthProvider::generateToken - Genera un token aleatorio
    • OAuthProvider::is2LeggedEndpoint - is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint - Establece isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter - Remueve un parámetro requerido
    • OAuthProvider::reportProblem - Reportar un problema
    • OAuthProvider::setParam - Establece un parámetro
    • OAuthProvider::setRequestTokenPath - Establece la ruta de petición del token
    • OAuthProvider::timestampNonceHandler - Establece el callback timestampNonceHandler
    • OAuthProvider::tokenHandler - Establece el manejador callback de tokenHandler
    • OAuthProvider::__construct - Construye un nuevo objeto OAuthProvider
    • oauth_get_sbs - Genera una cadena de firma base
    • oauth_urlencode - Códifica una URI a RFC 3986
    • ob_clean - Limpiar (eliminar) el búfer de salida
    • ob_end_clean - Limpiar (eliminar) el búfer de salida y deshabilitar el almacenamiento en el mismo
    • ob_end_flush - Volcar (enviar) el búfer de salida y deshabilitar el almacenamiento en el mismo
    • ob_flush - Vaciar (enviar) el búfer de salida
    • ob_get_clean - Obtiene el contenido del búfer actual y elimina el búfer de salida actual
    • ob_get_contents - Devolver el contenido del búfer de salida
    • ob_get_flush - Volcar el búfer de salida, devolverlo como una cadena de caracteres y deshabilitar el almacenamiento en el búfer de salida
    • ob_get_length - Devolver la longitud del búfer de salida
    • ob_get_level - Devolver el nivel de anidamiento del mecanismo de almacenamiento en el búfer de salida
    • ob_get_status - Obtener el estado de los búferes de salida
    • ob_gzhandler - Función de llamada de retorno de ob_start para comprimir el búfer de salida con gzip
    • ob_iconv_handler - Convierte la codificación de caracteres al manejador del buffer de salida
    • ob_implicit_flush - Habilitar/deshabilitar el volcado implícito
    • ob_list_handlers - Enumerar todos los gestores de salida en uso
    • ob_start - Activa el almacenamiento en búfer de la salida
    • ob_tidyhandler - Función callback de ob_start para reparar el buffer
    • OCI-Collection::append - Añade un elemento a la colección
    • OCI-Collection::assign - Asigna un valor a la colección desde otra colección existente
    • OCI-Collection::assignElem - Asigna un valor a un elemento de la colección
    • OCI-Collection::free - Libera los recursos asociados con el objeto colección
    • OCI-Collection::getElem - Devuelve el valor de un elemento
    • OCI-Collection::max - Devuelve el número máximo de elementos de la colección
    • OCI-Collection::size - Devuelve el tamaño de la colección
    • OCI-Collection::trim - Elimina elementos del final de la colección
    • OCI-Lob::append - Añade datos a un objeto grande (LOB) desde otro
    • OCI-Lob::close - Cierra un descriptor de LOB
    • OCI-Lob::eof - Comprueba la marca de final de fichero en un descriptor de objetos grandes
    • OCI-Lob::erase - Borra la porción especificada de los datos internos de un LOB
    • OCI-Lob::export - Exporta el contenido de un LOB a un fichero
    • OCI-Lob::flush - Vacía/escribe el búfer de un LOB al servidor
    • OCI-Lob::free - Libera los recursos asociados con el descriptor del LOB
    • OCI-Lob::getBuffering - Devuelve el estado actual del uso del búfer para un objeto grande
    • OCI-Lob::import - Importa datos de un fichero a un LOB
    • OCI-Lob::load - Devuelve el contenido de un objeto grande
    • OCI-Lob::read - Lee parte del objeto grande
    • OCI-Lob::rewind - Mueve el puntero interno al comienzo de un objeto grande
    • OCI-Lob::save - Guarda datos en un objeto grande
    • OCI-Lob::saveFile - Alias de OCI-Lob::import
    • OCI-Lob::seek - Ubica el puntero interno de un objeto grande
    • OCI-Lob::setBuffering - Cambia el estado actual del uso del búfer para objetos grandes
    • OCI-Lob::size - Devuelve el tamaño de un objeto grande
    • OCI-Lob::tell - Devuelve la posición actual del puntero interno de un objeto grande
    • OCI-Lob::truncate - Trunca un objeto grande
    • OCI-Lob::write - Escribe datos en un objeto grande
    • OCI-Lob::writeTemporary - Escribe un objeto grande temporal
    • OCI-Lob::writeToFile - Alias de OCI-Lob::export
    • ocibindbyname - Alias de oci_bind_by_name
    • ocicancel - Alias de oci_cancel
    • ocicloselob - Alias de OCI-Lob::close
    • ocicollappend - Alias de OCI-Collection::append
    • ocicollassign - Alias de OCI-Collection::assign
    • ocicollassignelem - Alias de OCI-Collection::assignElem
    • ocicollgetelem - Alias de OCI-Collection::getElem
    • ocicollmax - Alias de OCI-Collection::max
    • ocicollsize - Alias de OCI-Collection::size
    • ocicolltrim - Alias de OCI-Collection::trim
    • ocicolumnisnull - Alias de oci_field_is_null
    • ocicolumnname - Alias de oci_field_name
    • ocicolumnprecision - Alias de oci_field_precision
    • ocicolumnscale - Alias de oci_field_scale
    • ocicolumnsize - Alias de oci_field_size
    • ocicolumntype - Alias de oci_field_type
    • ocicolumntyperaw - Alias de oci_field_type_raw
    • ocicommit - Alias de oci_commit
    • ocidefinebyname - Alias de oci_define_by_name
    • ocierror - Alias de oci_error
    • ociexecute - Alias de oci_execute
    • ocifetch - Alias de oci_fetch
    • ocifetchinto - Variante obsoleta de oci_fetch_array, oci_fetch_object, oci_fetch_assoc y oci_fetch_row
    • ocifetchstatement - Alias de oci_fetch_all
    • ocifreecollection - Alias de OCI-Collection::free
    • ocifreecursor - Alias de oci_free_statement
    • ocifreedesc - Alias de OCI-Lob::free
    • ocifreestatement - Alias de oci_free_statement
    • ociinternaldebug - Alias de oci_internal_debug
    • ociloadlob - Alias de OCI-Lob::load
    • ocilogoff - Alias de oci_close
    • ocilogon - Alias de oci_connect
    • ocinewcollection - Alias de oci_new_collection
    • ocinewcursor - Alias de oci_new_cursor
    • ocinewdescriptor - Alias de oci_new_descriptor
    • ocinlogon - Alias de oci_new_connect
    • ocinumcols - Alias de oci_num_fields
    • ociparse - Alias de oci_parse
    • ociplogon - Alias de oci_pconnect
    • ociresult - Alias de oci_result
    • ocirollback - Alias de oci_rollback
    • ocirowcount - Alias de oci_num_rows
    • ocisavelob - Alias de OCI-Lob::save
    • ocisavelobfile - Alias de OCI-Lob::import
    • ociserverversion - Alias de oci_server_version
    • ocisetprefetch - Alias de oci_set_prefetch
    • ocistatementtype - Alias de oci_statement_type
    • ociwritelobtofile - Alias de OCI-Lob::export
    • ociwritetemporarylob - Alias de OCI-Lob::writeTemporary
    • oci_bind_array_by_name - Vincula un array de PHP con un parámetro de un array de Oracle PL/SQL
    • oci_bind_by_name - Vincula una variable de PHP a un parámetro de sustitución de Oracle
    • oci_cancel - Cancela la lectura del cursor
    • oci_client_version - Devuelve la versión de la biblioteca cliente de Oracle
    • oci_close - Cierra una conexión a Oracle
    • oci_commit - Consigna la transacción pendiente de la base de datos
    • oci_connect - Conecta a una base de datos de Oracle
    • oci_define_by_name - Asocia una variable de PHP con una columna para la obtención de consultas
    • oci_error - Devuelve el último error encontrado
    • oci_execute - Ejecuta una sentencia
    • oci_fetch - Coloca la siguiente fila de una consulta en los búferes internos
    • oci_fetch_all - Obtiene múltiples filas de una consulta y las ubica en un array bidimiensional
    • oci_fetch_array - Devuelve la siguiente fila de una consulta como un array asociativo o numérico
    • oci_fetch_assoc - Devuelve la siguiente fila de una consulta como un array asociativo
    • oci_fetch_object - Devuelve la siguiente fila de una consulta como un objeto
    • oci_fetch_row - Devuelve la siguiente fila de una consulta como un array numérico
    • oci_field_is_null - Comprueba si un campo de la fila actualmente obtenida es null
    • oci_field_name - Devuelve el nombre de un campo de una sentencia
    • oci_field_precision - Indica la precisión de un campo
    • oci_field_scale - Indica la escala de un campo
    • oci_field_size - Devuelve el tamaño de un campo
    • oci_field_type - Devuelve el nombre del tipo de datos de un campo
    • oci_field_type_raw - Indica el tipo de datos sin tratar de Oracle de un campo
    • oci_free_descriptor - Libera un descriptor
    • oci_free_statement - Libera todos los recursos asociados con una sentencia o cursor
    • oci_get_implicit_resultset - Devuelve el siguiente recurso de sentencia hija desde un recurso de sentencia padre que posee Conjuntos de resultados implícitos de Oracle Database 12c
    • oci_internal_debug - Enables or disables internal debug output
    • oci_lob_copy - Copia objetos grandes
    • oci_lob_is_equal - Compara dos localizadores LOB/FILE
    • oci_new_collection - Asigna un nuevo objeto colección
    • oci_new_connect - Conectar al servidor de Oracle usando una conexión única
    • oci_new_cursor - Asigna y devuelve un nuevo cursor (gestor de sentencia)
    • oci_new_descriptor - Inicializa un nuevo descriptor LOB o FILE vacío
    • oci_num_fields - Devuelve el número de columnas del resultado de una sentencia
    • oci_num_rows - Devuelve el número de filas afectadas durante la ejecución de una sentencia
    • oci_parse - Prepara una sentencia de Oracle para su ejecución
    • oci_password_change - Cambia la contraseña de un usuario de Oracle
    • oci_pconnect - Conectar a una base de datos de Oracle usando una conexión persistente
    • oci_register_taf_callback - Registrar una función de retrollamada definida por el usuario para TAF de Oracle Database
    • oci_result - Devuelve el valor de un campo de la fila obtenida
    • oci_rollback - Revierte la transacción pendiente de la base de datos
    • oci_server_version - Devuelve la versión de Oracle Database
    • oci_set_action - Establece el nombre de una acción
    • oci_set_call_timeout - Sets a millisecond timeout for database calls
    • oci_set_client_identifier - Establece el identificador del cliente
    • oci_set_client_info - Establece la información del cliente
    • oci_set_db_operation - Sets the database operation
    • oci_set_edition - Establece la edición de la base de datos
    • oci_set_module_name - Establece el nombre de un módulo
    • oci_set_prefetch - Establece el número de filas a precargar mediante consultas
    • oci_statement_type - Devuelve el tipo de una sentencia
    • oci_unregister_taf_callback - Unregister a user-defined callback function for Oracle Database TAF
    • octdec - Octal a decimal
    • odbc_autocommit - Activa el comportamiento automático de envío
    • odbc_binmode - Manejo de información de columna binaria
    • odbc_close - Cerrar una conexión ODBC
    • odbc_close_all - Cerrar todas las conexiones ODBC
    • odbc_columnprivileges - Lista las columnas y los privilegios asociados para la tabla dada
    • odbc_columns - Lista los nombres de columnas de la tabla especificada
    • odbc_commit - Envía una transacción ODBC
    • odbc_connect - Conectar a una fuente de datos
    • odbc_cursor - Obtener el nombre del cursor
    • odbc_data_source - Devuelve información sobre una conexión actual
    • odbc_do - Alias de odbc_exec
    • odbc_error - Obtener el último código de error
    • odbc_errormsg - Obtener el último mensaje de error
    • odbc_exec - Preparar y ejecutar una sentencia SQL
    • odbc_execute - Ejecutar una declaración preparada
    • odbc_fetch_array - Obtener una fila de resultados como una matriz asociativa
    • odbc_fetch_into - Traer una fila de resultados en una matriz
    • odbc_fetch_object - Obtener una fila de resultados como un objeto
    • odbc_fetch_row - Traer una fila
    • odbc_field_len - Obtener la longitud (precisión) de un campo
    • odbc_field_name - Obtener el nombre de una columna
    • odbc_field_num - Devolver el número de columna
    • odbc_field_precision - Alias de odbc_field_len
    • odbc_field_scale - Obtener la escala de un campo
    • odbc_field_type - Tipo de datos de un campo
    • odbc_foreignkeys - Recupera información de una lista de claves extranjeras
    • odbc_free_result - Liberar los recursos asociados con un resultado
    • odbc_gettypeinfo - Recupera información sobre los tipos de datos soportados por la fuente de datos
    • odbc_longreadlen - Manejo de columnas LONG
    • odbc_next_result - Verifica si están disponibles múltiples resultados
    • odbc_num_fields - Número de columnas de un resultado
    • odbc_num_rows - Número de filas de un resultado
    • odbc_pconnect - Abrir una conexión persistente a una base de datos
    • odbc_prepare - Prepara una declaración para su ejecución
    • odbc_primarykeys - Obtiene las claves primarias de una tabla
    • odbc_procedurecolumns - Recuperar información sobre los parámetros a procedimientos
    • odbc_procedures - Obtener la lista de procedimientos almacenados en una fuente de datos específica
    • odbc_result - Obtener información de resultado
    • odbc_result_all - Imprimir el resultado como una tabla HTML
    • odbc_rollback - Revertir una transacción
    • odbc_setoption - Ajustar la configuración de ODBC
    • odbc_specialcolumns - Recupera columnas especiales
    • odbc_statistics - Recuperar las estadísticas de un tabla
    • odbc_tableprivileges - Lista las tablas y los privilegios asociados con cada tabla
    • odbc_tables - Obtener la lista de los nombres de las tablas almacenados en una fuente de datos específica
    • ogg:// - Flujos de audio
    • opcache_compile_file - Compiles and caches a PHP script without executing it
    • opcache_get_configuration - Get configuration information about the cache
    • opcache_get_status - Get status information about the cache
    • opcache_invalidate - Invalidates a cached script
    • opcache_is_script_cached - Tells whether a script is cached in OPCache
    • opcache_reset - Resets the contents of the opcode cache
    • Opciones de contexto de HTTP - Listado de opciones de contexto de HTTP
    • Opciones de contexto de MongoDB - Listado de opciones de contexto de MongoDB
    • Opciones de contexto de sockets - Listado de opciones de contexto de sockets
    • Opciones de contexto para CURL - Listado de opciones de contexto para CURL
    • Opciones de contexto para FTP - Listado de opciones de contexto para FTP
    • Opciones de contexto para SSL - Listado de opciones de contexto para SSL
    • Opciones de contexto Phar - Listado de opciones de contexto Phar
    • Opciones del contexto zip - Listado de opciones del contexto zip
    • openal_buffer_create - Genera un buffer OpenAL
    • openal_buffer_data - Carga un buffer con datos
    • openal_buffer_destroy - Destruye un buffer OpenAL
    • openal_buffer_get - Recupera una propiedad del buffer OpenAL
    • openal_buffer_loadwav - Carga un archivo .wav dentro de un buffer
    • openal_context_create - Crea un contexto de procesamiento de audio
    • openal_context_current - Crea el corriente contexto especificado
    • openal_context_destroy - Destruye un contexto
    • openal_context_process - Procesa un contexto especificado
    • openal_context_suspend - Suspende el contexto especificado
    • openal_device_close - Cierra un dispositivo OpenAL
    • openal_device_open - Inicia la capa de audio del OpenAL
    • openal_listener_get - Devuelve una propiedad de oyente
    • openal_listener_set - Establece una propiedad de oyente
    • openal_source_create - Genera una fuente de recursos
    • openal_source_destroy - Destruye una fuente de recursos
    • openal_source_get - Recupera una propiedad de una fuente del OpenAL
    • openal_source_pause - Pausa la fuente
    • openal_source_play - Empieza la reproducción de la fuente
    • openal_source_rewind - Rebobina la fuente
    • openal_source_set - Establece la propiedad de la fuente
    • openal_source_stop - Detiene la reproducción de la fuente
    • openal_stream - Empieza la salida de una fuente
    • opendir - Abre un gestor de directorio
    • openlog - Open connection to system logger
    • openssl_cipher_iv_length - Obtener la longitud del iv de cipher
    • openssl_cms_decrypt - Decrypt a CMS message
    • openssl_cms_encrypt - Encrypt a CMS message
    • openssl_cms_read - Export the CMS file to an array of PEM certificates
    • openssl_cms_sign - Sign a file
    • openssl_cms_verify - Verify a CMS signature
    • openssl_csr_export - Exporta una CSR como una cadena
    • openssl_csr_export_to_file - Exporta una CSR a un archivo
    • openssl_csr_get_public_key - Devuelve la clave púbilca de un CERT
    • openssl_csr_get_subject - Devuelve el sujeto de un CERT
    • openssl_csr_new - Genera una CSR
    • openssl_csr_sign - Firmar una CSR con otro certificado (o autofirmar) y generar un certificado
    • openssl_decrypt - Desencripta datos
    • openssl_dh_compute_key - Computa el secreto compartido para un valor público de una clave DH remota y una clave DH local
    • openssl_digest - Computa un método de resumen
    • openssl_encrypt - Cifra datos
    • openssl_error_string - Devolver un mensaje de error openSSL
    • openssl_free_key - Liberar el recurso de clave
    • openssl_get_cert_locations - Obtener las ubicaciones de certificados disponibles
    • openssl_get_cipher_methods - Obtiene los métodos de cifrado disponibles
    • openssl_get_curve_names - Gets list of available curve names for ECC
    • openssl_get_md_methods - Obtener los métodos de resumen disponibles
    • openssl_get_privatekey - Alias de openssl_pkey_get_private
    • openssl_get_publickey - Alias de openssl_pkey_get_public
    • openssl_open - Abre información sellada
    • openssl_pbkdf2 - Genera un string PKCS5 v2 PBKDF2, predeterminado a SHA-1
    • openssl_pkcs7_decrypt - Desencripta un mensaje S/MIME encriptado
    • openssl_pkcs7_encrypt - Encriptar un mensaje S/MIME
    • openssl_pkcs7_read - Export the PKCS7 file to an array of PEM certificates
    • openssl_pkcs7_sign - Firma un mensaje S/MIME
    • openssl_pkcs7_verify - Verifica la firma de un mensaje S/MIME firmado
    • openssl_pkcs12_export - Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12 a una variable
    • openssl_pkcs12_export_to_file - Exporta un Archivo de Almacén de Certificado Compatible con PKCS#12
    • openssl_pkcs12_read - Convierte un Almacén de Certificado PKCS#12 a una matriz
    • openssl_pkey_derive - Computes shared secret for public value of remote and local DH or ECDH key
    • openssl_pkey_export - Obtiene una representación de una clave exportable a una cadena
    • openssl_pkey_export_to_file - Obtiene una representación de una clave exportable a un archivo
    • openssl_pkey_free - Libera una clave privada
    • openssl_pkey_get_details - Devuelve una matriz con los detalles de la clave
    • openssl_pkey_get_private - Obtener una clave privada
    • openssl_pkey_get_public - Extrae la clave pública del certificado y la prepara para usarla
    • openssl_pkey_new - Genera una clave privada nueva
    • openssl_private_decrypt - Desencripta información con la clave privada
    • openssl_private_encrypt - Encripta información con la clave privada
    • openssl_public_decrypt - Desencripta información con la clave pública
    • openssl_public_encrypt - Encripta información con una clave pública
    • openssl_random_pseudo_bytes - Genera una cadena de bytes pseudo-aleatoria
    • openssl_seal - Sellar (encriptar) información
    • openssl_sign - Genera una firma
    • openssl_spki_export - Exports a valid PEM formatted public key signed public key and challenge
    • openssl_spki_export_challenge - Exporta el desafío asociados con una clave pública y desafío firmados
    • openssl_spki_new - Generate a new signed public key and challenge
    • openssl_spki_verify - Verifies a signed public key and challenge
    • openssl_verify - Verificar una firma
    • openssl_x509_checkpurpose - Verifica si un certificado se puede usar para un propósito en particular
    • openssl_x509_check_private_key - Comprueba si una clave privada se corresponde a un certificado
    • openssl_x509_export - Exporta un certificado como una cadena
    • openssl_x509_export_to_file - Exporta un certificado a un archivo
    • openssl_x509_fingerprint - Calculates the fingerprint, or digest, of a given X.509 certificate
    • openssl_x509_free - Liberar un recurso de certificado
    • openssl_x509_parse - Analiza un certificado X509 y devuelve la información como un matriz
    • openssl_x509_read - Analiza un certificado X.509 y devuelve un identificador de recurso para él
    • openssl_x509_verify - Verifies digital signature of x509 certificate against a public key
    • ord - Convierte el primer byte de un string a un valor entre 0 y 255
    • OuterIterator::getInnerIterator - Devuelve el iterador interno de la entrada actual
    • output_add_rewrite_var - Añadir valores al mecanismo de reescritura de URLs
    • output_reset_rewrite_vars - Restablecer los valores del mecanismo de reescritura de URLs
  • p
    • pack - Empaqueta información a una cadena binaria
    • parallel\bootstrap - Bootstrapping
    • parallel\Channel::close - Closing
    • parallel\Channel::make - Access
    • parallel\Channel::open - Access
    • parallel\Channel::recv - Sharing
    • parallel\Channel::send - Sharing
    • parallel\Channel::__construct - Channel Construction
    • parallel\Events::addChannel - Targets
    • parallel\Events::addFuture - Targets
    • parallel\Events::poll - Polling
    • parallel\Events::remove - Targets
    • parallel\Events::setBlocking - Behaviour
    • parallel\Events::setInput - Input
    • parallel\Events::setTimeout - Behaviour
    • parallel\Events\Input::add - Inputs
    • parallel\Events\Input::clear - Inputs
    • parallel\Events\Input::remove - Inputs
    • parallel\Future::cancel - Cancellation
    • parallel\Future::cancelled - State Detection
    • parallel\Future::done - State Detection
    • parallel\Future::value - Resolution
    • parallel\run - Execution
    • parallel\Runtime::close - Runtime Graceful Join
    • parallel\Runtime::kill - Runtime Join
    • parallel\Runtime::run - Execution
    • parallel\Runtime::__construct - Runtime Construction
    • parallel\Sync::get - Access
    • parallel\Sync::notify - Synchronization
    • parallel\Sync::set - Access
    • parallel\Sync::wait - Synchronization
    • parallel\Sync::__construct - Construction
    • parallel\Sync::__invoke - Synchronization
    • ParentIterator::accept - Determina aceptabilidad
    • ParentIterator::getChildren - Devuelve los iteradores hijo contenidos en un ParentIterator
    • ParentIterator::hasChildren - Comprueba si los iteradores internos del elemento actual tiene un hijos
    • ParentIterator::next - Mueve el iterador a la siguiente posición
    • ParentIterator::rewind - Rebobina el iterador
    • ParentIterator::__construct - Construye un ParentIterator
    • Parle\Lexer::advance - Process next lexer rule
    • Parle\Lexer::build - Finalize the lexer rule set
    • Parle\Lexer::callout - Define token callback
    • Parle\Lexer::consume - Pass the data for processing
    • Parle\Lexer::dump - Dump the state machine
    • Parle\Lexer::getToken - Retrieve the current token
    • Parle\Lexer::insertMacro - Insert regex macro
    • Parle\Lexer::push - Add a lexer rule
    • Parle\Lexer::reset - Reset lexer
    • Parle\Parser::advance - Process next parser rule
    • Parle\Parser::build - Finalize the grammar rules
    • Parle\Parser::consume - Consume the data for processing
    • Parle\Parser::dump - Dump the grammar
    • Parle\Parser::errorInfo - Retrieve the error information
    • Parle\Parser::left - Declare a token with left-associativity
    • Parle\Parser::nonassoc - Declare a token with no associativity
    • Parle\Parser::precedence - Declare a precedence rule
    • Parle\Parser::push - Add a grammar rule
    • Parle\Parser::reset - Reset parser state
    • Parle\Parser::right - Declare a token with right-associativity
    • Parle\Parser::sigil - Retrieve a matching part of a rule
    • Parle\Parser::token - Declare a token
    • Parle\Parser::tokenId - Get token id
    • Parle\Parser::trace - Trace the parser operation
    • Parle\Parser::validate - Validate input
    • Parle\RLexer::advance - Process next lexer rule
    • Parle\RLexer::build - Finalize the lexer rule set
    • Parle\RLexer::callout - Define token callback
    • Parle\RLexer::consume - Pass the data for processing
    • Parle\RLexer::dump - Dump the state machine
    • Parle\RLexer::getToken - Retrieve the current token
    • Parle\RLexer::insertMacro - Insert regex macro
    • Parle\RLexer::push - Add a lexer rule
    • Parle\RLexer::pushState - Push a new start state
    • Parle\RLexer::reset - Reset lexer
    • Parle\RParser::advance - Process next parser rule
    • Parle\RParser::build - Finalize the grammar rules
    • Parle\RParser::consume - Consume the data for processing
    • Parle\RParser::dump - Dump the grammar
    • Parle\RParser::errorInfo - Retrieve the error information
    • Parle\RParser::left - Declare a token with left-associativity
    • Parle\RParser::nonassoc - Declare a token with no associativity
    • Parle\RParser::precedence - Declare a precedence rule
    • Parle\RParser::push - Add a grammar rule
    • Parle\RParser::reset - Reset parser state
    • Parle\RParser::right - Declare a token with right-associativity
    • Parle\RParser::sigil - Retrieve a matching part of a rule
    • Parle\RParser::token - Declare a token
    • Parle\RParser::tokenId - Get token id
    • Parle\RParser::trace - Trace the parser operation
    • Parle\RParser::validate - Validate input
    • Parle\Stack::pop - Pop an item from the stack
    • Parle\Stack::push - Push an item into the stack
    • parse_ini_file - Analiza un fichero de configuración
    • parse_ini_string - Analiza una cadena de configuración
    • parse_str - Convierte el string en variables
    • parse_url - Analiza un URL y devuelve sus componentes
    • passthru - Ejecuta un programa externo y muestra la salida en bruto
    • password_algos - Get available password hashing algorithm IDs
    • password_get_info - Devuelve información sobre el hash proporcionado
    • password_hash - Crea un hash de contraseña
    • password_needs_rehash - Comprueba si el hash facilitado coincide con las opciones proporcionadas
    • password_verify - Comprueba que la contraseña coincida con un hash
    • pathinfo - Devuelve información acerca de la ruta de un fichero
    • pclose - Cierra un proceso de un puntero a un fichero
    • pcntl_alarm - Set an alarm clock for delivery of a signal
    • pcntl_async_signals - Enable/disable asynchronous signal handling or return the old setting
    • pcntl_errno - Alias de pcntl_get_last_error
    • pcntl_exec - Executes specified program in current process space
    • pcntl_fork - Forks the currently running process
    • pcntl_getpriority - Get the priority of any process
    • pcntl_get_last_error - Retrieve the error number set by the last pcntl function which failed
    • pcntl_setpriority - Change the priority of any process
    • pcntl_signal - Installs a signal handler
    • pcntl_signal_dispatch - Calls signal handlers for pending signals
    • pcntl_signal_get_handler - Get the current handler for specified signal
    • pcntl_sigprocmask - Sets and retrieves blocked signals
    • pcntl_sigtimedwait - Waits for signals, with a timeout
    • pcntl_sigwaitinfo - Waits for signals
    • pcntl_strerror - Retrieve the system error message associated with the given errno
    • pcntl_wait - Waits on or returns the status of a forked child
    • pcntl_waitpid - Waits on or returns the status of a forked child
    • pcntl_wexitstatus - Returns the return code of a terminated child
    • pcntl_wifexited - Checks if status code represents a normal exit
    • pcntl_wifsignaled - Checks whether the status code represents a termination due to a signal
    • pcntl_wifstopped - Checks whether the child process is currently stopped
    • pcntl_wstopsig - Returns the signal which caused the child to stop
    • pcntl_wtermsig - Returns the signal which caused the child to terminate
    • PDO::beginTransaction - Inicia una transacción
    • PDO::commit - Consigna una transacción
    • PDO::cubrid_schema - Obtiene la información del esquema solicitada
    • PDO::errorCode - Obtiene un SQLSTATE asociado con la última operación en el manejador de la base de datos
    • PDO::errorInfo - Obtiene información extendida del error asociado con la última operación del manejador de la base de datos
    • PDO::exec - Ejecuta una sentencia SQL y devuelve el número de filas afectadas
    • PDO::getAttribute - Devuelve un atributo de la conexión a la base de datos
    • PDO::getAvailableDrivers - Devuelve un array con los controladores de PDO disponibles
    • PDO::inTransaction - Comprueba si una transacción está activa
    • PDO::lastInsertId - Devuelve el ID de la última fila o secuencia insertada
    • PDO::pgsqlCopyFromArray - Copiar datos de un array de PHP a una tabla
    • PDO::pgsqlCopyFromFile - Copiar datos de un fichero a una tabla
    • PDO::pgsqlCopyToArray - Copiar datos de una tabla de una base de datos a un array de PHP
    • PDO::pgsqlCopyToFile - Copiar datos desde una tabla a un fichero
    • PDO::pgsqlGetNotify - Obtener una notificación asíncrona
    • PDO::pgsqlGetPid - Obtener el PID del servidor
    • PDO::pgsqlLOBCreate - Crear un nuevo objeto grande
    • PDO::pgsqlLOBOpen - Abrir un flujo de un objeto grande existente
    • PDO::pgsqlLOBUnlink - Eliminar un objeto grande
    • PDO::prepare - Prepara una sentencia para su ejecución y devuelve un objeto sentencia
    • PDO::query - Ejecuta una sentencia SQL, devolviendo un conjunto de resultados como un objeto PDOStatement
    • PDO::quote - Entrecomilla una cadena de caracteres para usarla en una consulta
    • PDO::rollBack - Revierte una transacción
    • PDO::setAttribute - Establece un atributo
    • PDO::sqliteCreateAggregate - Registra una función acumuladora definida por el usuario para usarla en sentencias SQL
    • PDO::sqliteCreateCollation - Registra una función definida por el usuario para emplearla como función de cotejo en sentencias SQL
    • PDO::sqliteCreateFunction - Registra una función definida por el usuario para utilizarla en sentencias SQL
    • PDO::__construct - Crea una instancia de PDO que representa una conexión a una base de datos
    • PDOStatement::bindColumn - Vincula una columna a una variable de PHP
    • PDOStatement::bindParam - Vincula un parámetro al nombre de variable especificado
    • PDOStatement::bindValue - Vincula un valor a un parámetro
    • PDOStatement::closeCursor - Cierra un cursor, habilitando a la sentencia para que sea ejecutada otra vez
    • PDOStatement::columnCount - Devuelve el número de columnas de un conjunto de resultados
    • PDOStatement::debugDumpParams - Vuelca un comando preparado de SQL
    • PDOStatement::errorCode - Obtiene el SQLSTATE asociado con la última operación del gestor de sentencia
    • PDOStatement::errorInfo - Obtiene información ampliada del error asociado con la última operación del gestor de sentencia
    • PDOStatement::execute - Ejecuta una sentencia preparada
    • PDOStatement::fetch - Obtiene la siguiente fila de un conjunto de resultados
    • PDOStatement::fetchAll - Devuelve un array que contiene todas las filas del conjunto de resultados
    • PDOStatement::fetchColumn - Devuelve una única columna de la siguiente fila de un conjunto de resultados
    • PDOStatement::fetchObject - Obtiene la siguiente fila y la devuelve como un objeto
    • PDOStatement::getAttribute - Recupera un atributo de sentencia
    • PDOStatement::getColumnMeta - Devuelve metadatos de una columna de un conjunto de resultados
    • PDOStatement::nextRowset - Avanza hasta el siguiente conjunto de filas de un gestor de sentencia multiconjunto de filas
    • PDOStatement::rowCount - Devuelve el número de filas afectadas por la última sentencia SQL
    • PDOStatement::setAttribute - Establece un atributo de sentencia
    • PDOStatement::setFetchMode - Establece el modo de obtención para esta sentencia
    • PDO_DBLIB DSN - Conectarse a bases de datos de Microsoft SQL Server y Sybase
    • PDO_FIREBIRD DSN - Conectarse a bases de datos de Firebird
    • PDO_MYSQL DSN - Conectarse a bases de datos de MySQL
    • PDO_PGSQL DSN - Conectarse a bases de datos de PostgreSQL
    • PDO_SQLITE DSN - Conectar a las bases de datos de SQLite
    • pfsockopen - Abre Internet persistente o conexión de socket de dominio Unix
    • pg_affected_rows - Devuelve el número de registros afectados (filas)
    • pg_cancel_query - Cancelar una consulta asíncrona
    • pg_client_encoding - Obtiene la codificación del cliente
    • pg_close - Cierra una conexión PostgreSQL
    • pg_connect - Abre una conexión a PostgreSQL
    • pg_connection_busy - Permite saber si la conexión esta ocupada o no
    • pg_connection_reset - Restablece conexión (reconectar)
    • pg_connection_status - Obtener estado de la conexión
    • pg_connect_poll - Verifica el estado de un intento de conexión asíncrono en curso de PostgreSQL
    • pg_consume_input - Reads input on the connection
    • pg_convert - Conviertir valores de un array asociativo en valores adecuados para sentencias SQL
    • pg_copy_from - Insertar registros dentro de una tabla desde un array
    • pg_copy_to - Copiar una tabla a un array
    • pg_dbname - Obtiene el nombre de la base de datos
    • pg_delete - Borra registros
    • pg_end_copy - Sincronizar con PostgreSQL
    • pg_escape_bytea - Escapar un string para insertarlo en un campo bytea
    • pg_escape_identifier - Escape a identifier for insertion into a text field
    • pg_escape_literal - Escape a literal for insertion into a text field
    • pg_escape_string - Escape a string for query
    • pg_execute - Envía una solicitud para ejecutar una setencia preparada con parámetros dados, y espera el resultado
    • pg_fetch_all - Obtiene todas las filas de un resultado como un array
    • pg_fetch_all_columns - Fetches all rows in a particular result column as an array
    • pg_fetch_array - Fetch a row as an array
    • pg_fetch_assoc - Fetch a row as an associative array
    • pg_fetch_object - Fetch a row as an object
    • pg_fetch_result - Returns values from a result resource
    • pg_fetch_row - Get a row as an enumerated array
    • pg_field_is_null - Test if a field is SQL NULL
    • pg_field_name - Returns the name of a field
    • pg_field_num - Returns the field number of the named field
    • pg_field_prtlen - Returns the printed length
    • pg_field_size - Returns the internal storage size of the named field
    • pg_field_table - Returns the name or oid of the tables field
    • pg_field_type - Devuelve el nombre de tipo para el número de campo correspondiente
    • pg_field_type_oid - Returns the type ID (OID) for the corresponding field number
    • pg_flush - Flush outbound query data on the connection
    • pg_free_result - Free result memory
    • pg_get_notify - Gets SQL NOTIFY message
    • pg_get_pid - Obtiene la ID del proceso del backend
    • pg_get_result - Get asynchronous query result
    • pg_host - Devuelve el nombre de host asociado a la conexión
    • pg_insert - Insert array into table
    • pg_last_error - Obtiene una cadena con el último mensaje de error de la conexión
    • pg_last_notice - Devuelve el último aviso del servidor PostgreSQL
    • pg_last_oid - Returns the last row's OID
    • pg_lo_close - Close a large object
    • pg_lo_create - Create a large object
    • pg_lo_export - Export a large object to file
    • pg_lo_import - Import a large object from file
    • pg_lo_open - Open a large object
    • pg_lo_read - Read a large object
    • pg_lo_read_all - Reads an entire large object and send straight to browser
    • pg_lo_seek - Seeks position within a large object
    • pg_lo_tell - Returns current seek position a of large object
    • pg_lo_truncate - Truncates a large object
    • pg_lo_unlink - Delete a large object
    • pg_lo_write - Write to a large object
    • pg_meta_data - Get meta data for table
    • pg_num_fields - Returns the number of fields in a result
    • pg_num_rows - Returns the number of rows in a result
    • pg_options - Obtener las opciones asociadas con la conexión
    • pg_parameter_status - Looks up a current parameter setting of the server
    • pg_pconnect - Abre una conexión persistente a PostgreSQL
    • pg_ping - Ping a conexión de base de datos
    • pg_port - Devuelve el número de puerto asociado con la conexión
    • pg_prepare - Envía una solicitud para crear una sentencia preparada con los parámetros dados, y espera que se complete
    • pg_put_line - Send a NULL-terminated string to PostgreSQL backend
    • pg_query - Ejecutar una consulta
    • pg_query_params - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
    • pg_result_error - Get error message associated with result
    • pg_result_error_field - Returns an individual field of an error report
    • pg_result_seek - Set internal row offset in result resource
    • pg_result_status - Get status of query result
    • pg_select - Select records
    • pg_send_execute - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
    • pg_send_prepare - Envía una solicitud para crear una instrucción preparada con los parámetros dados, sin esperar la finalización
    • pg_send_query - Sends asynchronous query
    • pg_send_query_params - Submits a command and separate parameters to the server without waiting for the result(s)
    • pg_set_client_encoding - Set the client encoding
    • pg_set_error_verbosity - Determines the verbosity of messages returned by pg_last_error and pg_result_error
    • pg_socket - Obtener un identificador de sólo lectura en el socket subyacente a una conexión de PostgreSQL
    • pg_trace - Enable tracing a PostgreSQL connection
    • pg_transaction_status - Devuelve el estado actual de la transaccion del servidor
    • pg_tty - Devolver el nombre TTY asociado con la conexión
    • pg_unescape_bytea - Unescape binary for bytea type
    • pg_untrace - Desactivar el rastreo de una conexión de PostgreSQL
    • pg_update - Actualizar tabla
    • pg_version - Devuelve un array con el cliente, protocolo y versión del servidor (si está disponible)
    • phar:// - Archivo PHP
    • Phar::addEmptyDir - Añadir un directorio vacío al archvo phar
    • Phar::addFile - Añadir un fichero desde el sistema de ficheros al archivo phar
    • Phar::addFromString - Añadir un fichero desde un string al archivo phar
    • Phar::apiVersion - Devolver la versión de la API
    • Phar::buildFromDirectory - Construir un archivo phar desde los ficheros de un directorio
    • Phar::buildFromIterator - Construir un archivo phar desde un iterador
    • Phar::canCompress - Devuelve si la extensión phar soporta la compresión usando zlib o bzip2
    • Phar::canWrite - Devolver si la extensión phar soporta la escritura y creación de archivos phar
    • Phar::compress - Comprimir el archivo Phar entero usando la compresión Gzip o Bzip2
    • Phar::compressFiles - Comprime todos los ficheros del archivo Phar actual
    • Phar::convertToData - Convertir un archivo phar en un fichero tar o zip no ejecutable
    • Phar::convertToExecutable - Convertir un archivo phar en otro formato de archivo phar ejecutable
    • Phar::copy - Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
    • Phar::count - Devuelve el número de entradas (ficheros) en el archivo Phar
    • Phar::createDefaultStub - Crear una rutina de interoperabilidad específica del formato de fichero phar
    • Phar::decompress - Descomprimir un archivo Phar entero
    • Phar::decompressFiles - Descomprimir todos los ficheros del archivo Phar actual
    • Phar::delete - Borrar un fichero dentro de un archivo phar
    • Phar::delMetadata - Eliminar la metainformación global del phar
    • Phar::extractTo - Extraer el contenido de un archivo phar a un directorio
    • Phar::getAlias - Get the alias for Phar
    • Phar::getMetadata - Devolver la metainformación de un archivo phar
    • Phar::getModified - Devolver si el phar fue modificado
    • Phar::getPath - Get the real path to the Phar archive on disk
    • Phar::getSignature - Devolver la firma MD5/SHA1/SHA256/SHA512/OpenSSL de un archivo Phar
    • Phar::getStub - Devolver el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
    • Phar::getSupportedCompression - Devolver un array de los algoritmos de compresión soportados
    • Phar::getSupportedSignatures - Devolver un array con los tipos de firmas soportados
    • Phar::getVersion - Devolver información de la versión del archivo Phar
    • Phar::hasMetadata - Devolver si el phar tiene metainformación global
    • Phar::interceptFileFuncs - Ordenar a phar interceptar fopen, file_get_contents, opendir, y todas las funciones relacionadas con estadísticas
    • Phar::isBuffering - Determinar si las operaciones de escritura de Phar está siendo almacenadas en buffer, o están siendo volcadas directamente al disco
    • Phar::isCompressed - Devuelve Phar::GZ oPHAR::BZ2 si el archivo phar entero está comprimido (.tar.gz/tar.bz, etc.)
    • Phar::isFileFormat - Devolver true si el archivo phar está basado en el formato de fichero tar/phar/zip dependiendo del parámetro
    • Phar::isValidPharFilename - Devolver si el nombre de fichero dado es un nombre de fichero phar válido
    • Phar::isWritable - Devolver si el archivo phar se puede modificar
    • Phar::loadPhar - Cargar cualquier archivo phar con un alias
    • Phar::mapPhar - Leer el fichero (un phar) que está en ejecución y registrar su manifiesto
    • Phar::mount - Montar un fichero o ruta externos en una ubicación virtual dentro de un archivo phar
    • Phar::mungServer - Definir una lista de hasta 4 variables $_SERVER que debería ser modificadas para la ejecución
    • Phar::offsetExists - Determina si un fichero existe en un phar
    • Phar::offsetGet - Obtener un objeto de la clase PharFileInfo para un fichero específico
    • Phar::offsetSet - Establecer el contenido de un fichero interno a aquel de un fichero externo
    • Phar::offsetUnset - Eliminar un fichero de un phar
    • Phar::running - Devolover la ruta completa del disco o el URL completo de phar del archivo Phar que está en ejecución
    • Phar::setAlias - Establecer el alias para un archivo Phar
    • Phar::setDefaultStub - Establecer el cargador o la rutina de interoperabilidad de un archivo Phar al cargador predeterminado
    • Phar::setMetadata - Establecer la metainformación de un archivo phar
    • Phar::setSignatureAlgorithm - Establecer el algoritmo de firma para un phar y aplicarlo
    • Phar::setStub - Establecer el cargador de PHP o la rutina de interoperabilidad de un archivo Phar
    • Phar::startBuffering - Iniciar las operaciones de escritura en buffer de Phar, no modifica el objeto Phar del disco
    • Phar::stopBuffering - Detener las peticiones de escritura en buffer del archivo Phar, y guardar los cambios en disco
    • Phar::unlinkArchive - Elimiar completamente un archivo phar del disco y de la memoria
    • Phar::webPhar - mapPhar para archivos phar basados en web. Controlador principal para aplicaciones web
    • Phar::__construct - Construir un objeto de archivo Phar
    • PharData::addEmptyDir - Añadir un directorio vacío al archivo tar/zip
    • PharData::addFile - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
    • PharData::addFromString - Añadir un fichero desde el sistema de ficheros al archivo tar/zip
    • PharData::buildFromDirectory - Construir un archivo tar/zip desde los ficheros de un directorio
    • PharData::buildFromIterator - Construir un archivo tar o zip desde un iterador
    • PharData::compress - Comprimir el archivo tar/zip entero usando la compresión Gzip o Bzip2
    • PharData::compressFiles - Comprime todos los ficheros del archivo tar/zip actual
    • PharData::convertToData - Convertir un archivo phar en un fichero tar o zip no ejecutable
    • PharData::convertToExecutable - Convertir un archivo tar/zip no ejecutable en un archivo phar ejecutable
    • PharData::copy - Copiar un fichero interno de un archivo phar a otro fichero nuevo dentro del phar
    • PharData::decompress - Descomprimir un archivo Phar entero
    • PharData::decompressFiles - Descomprimir todos los ficheros del archivo zip actual
    • PharData::delete - Borrar un fichero dentro de un archivo tar/zip
    • PharData::delMetadata - Eliminar la metainformación global de un archivo zip
    • PharData::extractTo - Extraer el contenido de un archivo tar/zip a un directorio
    • PharData::isWritable - Devolver si el archivo tar/zip se puede modificar
    • PharData::offsetSet - Establecer el contenido de un fichero dentro de un tar/zip a aquel de un fichero o cadena externos
    • PharData::offsetUnset - Eliminar un ficerho de un archivo tar/zip
    • PharData::setAlias - función sin sentido (Phar::setAlias no es válido para PharData)
    • PharData::setDefaultStub - función sin sentido (Phar::setStub no es válido para PharData)
    • PharData::setStub - función sin sentido (Phar::setStub no es válido para PharData)
    • PharData::__construct - Construir un objeto de archivo tar o zip no ejecutable
    • PharException - La clase PharException ofrece una excepción de clase específica de phar para bloques try/catch
    • PharFileInfo::chmod - Esteblecer los bits de permiso específicos del fichero
    • PharFileInfo::compress - Comprimir la entrada del Phar actual con la compresión zlib o bzip2
    • PharFileInfo::decompress - Descomprimir la entrada Phar actual dentro del phar
    • PharFileInfo::delMetadata - Eliminar la metainformación de una entrada
    • PharFileInfo::getCompressedSize - Devolver el tamaño real de un fichero (con compresión) dentro de un archivo Phar
    • PharFileInfo::getContent - Get the complete file contents of the entry
    • PharFileInfo::getCRC32 - Devolver el códido CRC32 o lanzar una exepción si la CRC no ha sido verificado
    • PharFileInfo::getMetadata - Devolver la metainformación específica de un fichero almacenada con un fichero
    • PharFileInfo::getPharFlags - Devolver las banderas de una entrada de fichero
    • PharFileInfo::hasMetadata - Devolver la metainformación de una entrada
    • PharFileInfo::isCompressed - Devolver si la entrada está comprimida
    • PharFileInfo::isCRCChecked - Devolver si la entrada de fichero tiene su CRC verificada
    • PharFileInfo::setMetadata - Establecer la metainformación específica de un fichero almacenda con un fichero
    • PharFileInfo::__construct - Construir un objeto de entrada Phar
    • php:// - Acceso a distintos flujos de E/S
    • phpcredits - Imprime los créditos de PHP
    • phpdbg_break_file - Inserts a breakpoint at a line in a file
    • phpdbg_break_function - Inserts a breakpoint at entry to a function
    • phpdbg_break_method - Inserts a breakpoint at entry to a method
    • phpdbg_break_next - Inserts a breakpoint at the next opcode
    • phpdbg_clear - Clears all breakpoints
    • phpdbg_color - Sets the color of certain elements
    • phpdbg_end_oplog - Descripción
    • phpdbg_exec - Attempts to set the execution context
    • phpdbg_get_executable - Descripción
    • phpdbg_prompt - Sets the command prompt
    • phpdbg_start_oplog - Descripción
    • phpinfo - Muestra información sobre la configuración de PHP
    • phpversion - Obtiene la versión de PHP
    • php_ini_loaded_file - Recupera la ruta de acceso al archivo php.ini cargado
    • php_ini_scanned_files - Devuelve una lista de ficheros .ini procesados del directorio adicional ini
    • php_sapi_name - Devuelve el tipo de interfaz que hay entre PHP y el servidor
    • php_strip_whitespace - Devuelve el código fuente sin los comentarios y espacios blancos
    • php_uname - Devuelve información sobre el sistema operativo en que se está ejecutando PHP
    • php_user_filter::filter - Llamado cuando se aplica un filtro
    • php_user_filter::onClose - Llamado cuando se cierra el filtro
    • php_user_filter::onCreate - Llamado cuando se crea el filtro
    • pht\AtomicInteger::dec - Decrements the atomic integer's value by one
    • pht\AtomicInteger::get - Gets the atomic integer's value
    • pht\AtomicInteger::inc - Increments the atomic integer's value by one
    • pht\AtomicInteger::lock - Acquires the atomic integer's mutex lock
    • pht\AtomicInteger::set - Sets the atomic integer's value
    • pht\AtomicInteger::unlock - Releases the atomic integer's mutex lock
    • pht\AtomicInteger::__construct - AtomicInteger creation
    • pht\HashTable::lock - Acquires the hash table's mutex lock
    • pht\HashTable::size - Gets the size of the hash table
    • pht\HashTable::unlock - Releases the hash table's mutex lock
    • pht\Queue::front - Returns the first value from a queue
    • pht\Queue::lock - Acquires the queue's mutex lock
    • pht\Queue::pop - Pops a value off of the front of a queue
    • pht\Queue::push - Pushes a value to the end of a queue
    • pht\Queue::size - Gets the size of the queue
    • pht\Queue::unlock - Releases the queue's mutex lock
    • pht\Runnable::run - The entry point of a threaded class
    • pht\Thread::addClassTask - Class threading
    • pht\Thread::addFileTask - File threading
    • pht\Thread::addFunctionTask - Function threading
    • pht\Thread::join - Joins a thread
    • pht\Thread::start - Starts the new thread
    • pht\Thread::taskCount - Gets a thread's task count
    • pht\Threaded::lock - Acquires the mutex lock
    • pht\Threaded::unlock - Releases the mutex lock
    • pht\Vector::deleteAt - Deletes a value in the vector
    • pht\Vector::insertAt - Inserts a value into the vector
    • pht\Vector::lock - Acquires the vector's mutex lock
    • pht\Vector::pop - Pops a value to the vector
    • pht\Vector::push - Pushes a value to the vector
    • pht\Vector::resize - Resizes a vector
    • pht\Vector::shift - Shifts a value from the vector
    • pht\Vector::size - Gets the size of the vector
    • pht\Vector::unlock - Releases the vector's mutex lock
    • pht\Vector::unshift - Unshifts a value to the vector front
    • pht\Vector::updateAt - Updates a value in the vector
    • pht\Vector::__construct - Vector creation
    • pi - Obtener valor de pi
    • png2wbmp - Convertir un archivo de imagen PNG a un archivo de imagen WBMP
    • Pool::collect - Collect references to completed tasks
    • Pool::resize - Resize the Pool
    • Pool::shutdown - Shutdown all workers
    • Pool::submit - Submits an object for execution
    • Pool::submitTo - Submits a task to a specific worker for execution
    • Pool::__construct - Creates a new Pool of Workers
    • popen - Abre un proceso de un puntero a un fichero
    • pos - Alias de current
    • posix_access - Determinar la accesibilidad de un archivo
    • posix_ctermid - Obtener el nombre de la ruta del terminal controlador
    • posix_errno - Alias de posix_get_last_error
    • posix_getcwd - Nombre de la ruta del directorio actual
    • posix_getegid - Devuelve el ID efectivo de grupo del proceso actual
    • posix_geteuid - Devolver el ID efectivo de usuario del proceso actual
    • posix_getgid - Devuelve el ID real de grupo del proceso actual
    • posix_getgrgid - Devolver información sobre un grupo mediante un id de grupo
    • posix_getgrnam - Devolver información sobre un grupo mediante su nombre
    • posix_getgroups - Devolver el conjunto de grupos del proceso actual
    • posix_getlogin - Devuelve el nombre del inicio de sesión
    • posix_getpgid - Obtener el id del grupo de procesos para un control de trabajo
    • posix_getpgrp - Devolver el identificador de grupo de proceso actual
    • posix_getpid - Devolver el identificador del proceso actual
    • posix_getppid - Devolver el identificador del proceso padre
    • posix_getpwnam - Devolver información sobre un usuario mediante su nombre de usuario
    • posix_getpwuid - Devolver información sobre un usuario mediante su id de usuario
    • posix_getrlimit - Devolver información sobre los límites de recursos del sistema
    • posix_getsid - Obtener el sid actual del proceos
    • posix_getuid - Devolver el ID real de usuario del proceso actual
    • posix_get_last_error - Recuperar el número de error establecido por la última función posix que ha fallado
    • posix_initgroups - Calcular la lista de acceso al grupo
    • posix_isatty - Determinar si un descriptor de fichero es un terminal interactiva
    • posix_kill - Enviar una señal a un proceso
    • posix_mkfifo - Crear un archivo especial fifo (un pipe con nombre)
    • posix_mknod - Crear un fichero especial u ordinario (POSIX.1)
    • posix_setegid - Establecer el GID efectivo del proceso actual
    • posix_seteuid - Establecer el UID efectivo del proceso actual
    • posix_setgid - Establecer el GID de proceso actual
    • posix_setpgid - Establecer el id de grupo de procesos para el control de trabajo
    • posix_setrlimit - Establecer los límites de recursos del sistema
    • posix_setsid - Hacer del proceso actual un líder de sesión
    • posix_setuid - Establecer el UID del proceso actual
    • posix_strerror - Recuperar el mensaje de error del sistema asociado con el errno dado
    • posix_times - Obtener los tiempos de procesos
    • posix_ttyname - Determinar el nombre del dispositivo terminal
    • posix_uname - Obtener el nombre del sistema
    • pow - Expresión exponencial
    • preg_filter - Realiza una búsqueda y sustitución de una expresión regular
    • preg_grep - Devuelve entradas de matriz que coinciden con el patrón
    • preg_last_error - Devuelve el código de error de la última ejecución de expresión regular de PCRE
    • preg_last_error_msg - Returns the error message of the last PCRE regex execution
    • preg_match - Realiza una comparación con una expresión regular
    • preg_match_all - Realiza una comparación global de una expresión regular
    • preg_quote - Escapar caracteres en una expresión regular
    • preg_replace - Realiza una búsqueda y sustitución de una expresión regular
    • preg_replace_callback - Realiza una búsqueda y sustitución de una expresión regular usando una llamada de retorno
    • preg_replace_callback_array - Realizar una búsqueda y sustitución de expresión regular con retrollamadas
    • preg_split - Divide un string mediante una expresión regular
    • prev - Rebobina el puntero interno del array
    • print - Mostrar una cadena
    • printf - Imprimir una cadena con formato
    • print_r - Imprime información legible para humanos sobre una variable
    • proc_close - Cierra un proceso abierto mediante proc_open y devuelve el códido de salida de tal proceso
    • proc_get_status - Obtiene información sobre un proceso abierto por proc_open
    • proc_nice - Modificar la prioridad del proceso actual
    • proc_open - Ejecuta un comando y abre un puntero de fichero para entrada/salida
    • proc_terminate - Mata un proceso abierto mediante proc_open
    • property_exists - Comprueba si el objeto o la clase tienen una propiedad
    • pspell_add_to_personal - Añadir una palabra a la lista personal de palabras
    • pspell_add_to_session - Añadir la palabra a la lista de palabras en la sesión actual
    • pspell_check - Verificar una palabra
    • pspell_clear_session - Limpia la sesión actual
    • pspell_config_create - Crear una configuración usada para abrir un diccionario
    • pspell_config_data_dir - Ubicación de los ficheros de información de lenguaje
    • pspell_config_dict_dir - Ubicación de la lista principal de palabras
    • pspell_config_ignore - Ignorar palabras con menos de N caracteres
    • pspell_config_mode - Cambiar el modo de número de sugerencias devueltas
    • pspell_config_personal - Establecer un fichero que contiene una lista personal de palabras
    • pspell_config_repl - Establecer un fichero que contiene pares de sustitución
    • pspell_config_runtogether - Considerar las palabras unidas como compuestos válidos
    • pspell_config_save_repl - Deterinar si se guarda una lista de pares de sustitución junto con la lista de palabras
    • pspell_new - Cargar un nuevo diccionario
    • pspell_new_config - Cargar un nuevo diccionario con ajustes basados en una configuración dada
    • pspell_new_personal - Cargar un nuevo diccionario con una lista personal de palabras
    • pspell_save_wordlist - Guardar la lista de palabras personal a un fichero
    • pspell_store_replacement - Almacenar un par de sustitución de una palabra
    • pspell_suggest - Sugerir ortografías de una palabra
    • ps_add_bookmark - Añadir un marcapáginas a la página actual
    • ps_add_launchlink - Añadir un vínculo que lance un fichero
    • ps_add_locallink - Añadir un vínculo hacia una página del mismo documento
    • ps_add_note - Añadir una nota a la página actual
    • ps_add_pdflink - Añadir un vínculo hacia una página de un segundo documento PDF
    • ps_add_weblink - Añadir un vínculo hacia una ubicación web
    • ps_arc - Dibujar un arco en el sentido contrario a las agujas del reloj
    • ps_arcn - Dibujar un arco en el sentido de las agujas del reloj
    • ps_begin_page - Empezar una nueva página
    • ps_begin_pattern - Iniciar un nuevo patrón
    • ps_begin_template - Iniciar una nueva plantilla
    • ps_circle - Dibujar un círculo
    • ps_clip - Realizar un recorte utilizando el trazado actual
    • ps_close - Cerrar un documento PostScript
    • ps_closepath - Cerrar un trazado
    • ps_closepath_stroke - Cerrar y contornear un trazado
    • ps_close_image - Cerrar una imagen y liberar memoria
    • ps_continue_text - Continuar el texto en la siguiente línea
    • ps_curveto - Dibujar una curva
    • ps_delete - Borrar todos los recursos de un documento PostScript
    • ps_end_page - Finalizar una página
    • ps_end_pattern - Finalizar un patrón
    • ps_end_template - Finalizar una plantilla
    • ps_fill - Rellenar el trazado actual
    • ps_fill_stroke - Rellenar y contornear el trazado actual
    • ps_findfont - Cargar una fuente
    • ps_get_buffer - Obtener el buffer completo que contiene la información generada de PS
    • ps_get_parameter - Obtener ciertos parámetros
    • ps_get_value - Obtener ciertos valores
    • ps_hyphenate - Particionar silábicamente una palabra
    • ps_include_file - Leer un fichero externo con código PostScript sin tratar
    • ps_lineto - Dibujar una línea
    • ps_makespotcolor - Crear un color directo
    • ps_moveto - Establecer el punto actual
    • ps_new - Crear un nuevo objeto de documento PostScript
    • ps_open_file - Abrir un fichero para su impresión
    • ps_open_image - Leer una imagen para su colocación posterior
    • ps_open_image_file - Abre una imagen desde un fichero
    • ps_open_memory_image - Tomar una imagen de GD y devolverla como una imagen para colcarla en un documento PS
    • ps_place_image - Colocar una imágen en la página
    • ps_rect - Dibujar un rectángulo
    • ps_restore - Restaurar un contexto previamente guardado
    • ps_rotate - Establecer el factor de rotación
    • ps_save - Guardar el contexto actual
    • ps_scale - Estalecer el factor de escala
    • ps_setcolor - Establecer el color actual
    • ps_setdash - Establecer la apariencia de una línea discontinua
    • ps_setflat - Establecer la planicidad
    • ps_setfont - Establecer la fuente a usar para la siguiente impresión
    • ps_setgray - Establecer el valor de gris
    • ps_setlinecap - Establecer la apariencia de los extremos de línea
    • ps_setlinejoin - Establecer cómo están unidas las líneas conectadas
    • ps_setlinewidth - Establecer el ancho de una línea
    • ps_setmiterlimit - Establecer el límite del inglete
    • ps_setoverprintmode - Establecer el modo de sobreimpresión
    • ps_setpolydash - Establecer la apariencia de una línea discontinua
    • ps_set_border_color - Establecer el color del borde de las anotaciones
    • ps_set_border_dash - Establece la longitud de las rayas del borde de las anotaciones
    • ps_set_border_style - Establecer el estilo del borde de las anotaciones
    • ps_set_info - Establecer los campos de información del documento
    • ps_set_parameter - Establecer ciertos parámetros
    • ps_set_text_pos - Establecer la posición de la salida de texto
    • ps_set_value - Establecer ciertos valores
    • ps_shading - Crear un sombreado para su uso posterior
    • ps_shading_pattern - Crear un patrón basado en un sombreado
    • ps_shfill - Rellenar un área con un sombreado
    • ps_show - Imprimir texto
    • ps_show2 - Imprimir texto en la posición actual
    • ps_show_boxed - Imprimir texto en una caja
    • ps_show_xy - Imprimir texto en una posición dada
    • ps_show_xy2 - Imprimir texto en una posición
    • ps_stringwidth - Obtener el ancho de una cadena
    • ps_string_geometry - Establecer la geometría de una cadena de caracteres
    • ps_stroke - Dibujar el trazado actual
    • ps_symbol - Imprimir un glifo
    • ps_symbol_name - Obtener el nombre de un glifo
    • ps_symbol_width - Obtener el ancho de un glifo
    • ps_translate - Establecer una traslación
    • putenv - Establece el valor de una variable de entorno
    • px_close - Cerrar una base de datos paradox
    • px_create_fp - Crear una nueva base de datos paradox
    • px_date2string - Convierte una fecha en una cadena.
    • px_delete - Eliminar los recursos de la base de datos paradox
    • px_delete_record - Eliminar los registros de base de datos paradox
    • px_get_field - Devuelve la especificación de un solo campo
    • px_get_info - Devuelve una gran cantidad de información sobre un archivo paradox
    • px_get_parameter - Obtener un parámetro
    • px_get_record - Devuelve registro de base de datos paradox
    • px_get_schema - Devuelve la definición de la base de datos (schema)
    • px_get_value - Obtener un valor
    • px_insert_record - Inserta registro en base de datos paradox
    • px_new - Crear un nuevo objeto paradox
    • px_numfields - Devuelve el número de campos en una base de datos
    • px_numrecords - Devuelve el número de registros en una base de datos
    • px_open_fp - Abrir base de datos paradox
    • px_put_record - Almacenar registro en la base de datos paradox
    • px_retrieve_record - Devolver registro de base de datos paradox
    • px_set_blob_file - Establecer el archivo desde donde los blobs se van a leer
    • px_set_parameter - Establecer un parámetro
    • px_set_tablename - Establecer el nombre de una tabla (obsoleto)
    • px_set_targetencoding - Establecer la codificación de los campos de caracteres (obsoleto)
    • px_set_value - Establecer un valor
    • px_timestamp2string - Convertir la fecha y la hora en una cadena.
    • px_update_record - Actualizar el registro en la base de datos paradox
  • q
    • QuickHashIntHash::add - Este método añade una nueva entrada al hash
    • QuickHashIntHash::delete - Este método elimina una entrada de un hash
    • QuickHashIntHash::exists - Este método comprueba si la clave es parte del hash
    • QuickHashIntHash::get - Este método recupera un valor a partir del hash por su clave
    • QuickHashIntHash::getSize - Devuelve el número de elementos de un hash
    • QuickHashIntHash::loadFromFile - Este método de fabricación crea un hash desde un fichero
    • QuickHashIntHash::loadFromString - Este método de fabricación crea un hash dedsde una cadena de caracteres
    • QuickHashIntHash::saveToFile - Este método almacena un hash en memoria en disco
    • QuickHashIntHash::saveToString - Este método devuelve una versión serializada del hash
    • QuickHashIntHash::set - Este método actualiza una entrada del hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashIntHash::update - Este método actualiza una entrada del hash con un nuevo valor
    • QuickHashIntHash::__construct - Crea un nuevo objeto QuickHashIntHash
    • QuickHashIntSet::add - Este método añade una nuevas entrada al conjunto
    • QuickHashIntSet::delete - Este método elimina una entrada de un conjunto
    • QuickHashIntSet::exists - Este método comprueba si una clave es parte de un conjunto
    • QuickHashIntSet::getSize - Devuelve el número de elementos del conjunto
    • QuickHashIntSet::loadFromFile - Este método de fabricación crear un conjunto desde un fichero
    • QuickHashIntSet::loadFromString - Este método de fabricación crea un conjunto desde una cadena de caracteres
    • QuickHashIntSet::saveToFile - Este método almacena un conjunto que está en la memoria en el disco
    • QuickHashIntSet::saveToString - Este método devuelve una versión serializada del conjunto
    • QuickHashIntSet::__construct - Crea un nuevo objeto QuickHashIntSet
    • QuickHashIntStringHash::add - Este método añade una nueva entrada a un hash
    • QuickHashIntStringHash::delete - Este método elimina una entrada del hash
    • QuickHashIntStringHash::exists - Este método comprueba si una clave es parte de un hash
    • QuickHashIntStringHash::get - Este método recupera un valor de un hash mediante su clave
    • QuickHashIntStringHash::getSize - Devuelve el número de elementos de un hash
    • QuickHashIntStringHash::loadFromFile - Este método de fabricación crea un hash desde un fichero
    • QuickHashIntStringHash::loadFromString - Este método de fabricación crea un hash desde una cadena de caracteres
    • QuickHashIntStringHash::saveToFile - Este método almacena un hash que esté en memoria en el disco
    • QuickHashIntStringHash::saveToString - Este método devuelve una versión serializada del hash
    • QuickHashIntStringHash::set - Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashIntStringHash::update - Este método actualiza una entrada de un hash con un nuevo valor
    • QuickHashIntStringHash::__construct - Crea un nuevo objeto QuickHashIntStringHash
    • QuickHashStringIntHash::add - Este método añade una nueva entrada a un hash
    • QuickHashStringIntHash::delete - Este método elimina una entrada del hash
    • QuickHashStringIntHash::exists - Este método comprueba si una clave es parte de un hash
    • QuickHashStringIntHash::get - Este método recupera un valor de un hash mediante su clave
    • QuickHashStringIntHash::getSize - Devuelve el número de elementos de un hash
    • QuickHashStringIntHash::loadFromFile - Este método de fabricación crea un hash desde un fichero
    • QuickHashStringIntHash::loadFromString - Este método de fabricación crea un hash desde una cadena de caracteres
    • QuickHashStringIntHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString - Este método devuelve una versión serializada del hash
    • QuickHashStringIntHash::set - Este método actualiza una entrada de un hash con un nuevo valor, o añade una nueva si la entrada no existe
    • QuickHashStringIntHash::update - Este método actualiza una entrada de un hash con un nuevo valor
    • QuickHashStringIntHash::__construct - Crea un nuevo objeto QuickHashStringIntHash
    • quoted_printable_decode - Convierte un string quoted-printable en un string de 8 bits
    • quoted_printable_encode - Convierte un string de 8 bits en un string quoted-printable
    • quotemeta - Escapa meta caracteres
  • r
    • rad2deg - Convierte el número en radianes a su equivalente en grados
    • radius_acct_open - Crea un manejador Radius para el conteo
    • radius_add_server - Adds a server
    • radius_auth_open - Crea un identificador de Radius para la autenticación
    • radius_close - Libera todos los recursos
    • radius_config - Causes the library to read the given configuration file
    • radius_create_request - Create accounting or authentication request
    • radius_cvt_addr - Converts raw data to IP-Address
    • radius_cvt_int - Converts raw data to integer
    • radius_cvt_string - Converts raw data to string
    • radius_demangle - Demangles data
    • radius_demangle_mppe_key - Derives mppe-keys from mangled data
    • radius_get_attr - Extracts an attribute
    • radius_get_tagged_attr_data - Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag - Extracts the tag from a tagged attribute
    • radius_get_vendor_attr - Extracts a vendor specific attribute
    • radius_put_addr - Attaches an IP address attribute
    • radius_put_attr - Attaches a binary attribute
    • radius_put_int - Attaches an integer attribute
    • radius_put_string - Attaches a string attribute
    • radius_put_vendor_addr - Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr - Attaches a vendor specific binary attribute
    • radius_put_vendor_int - Attaches a vendor specific integer attribute
    • radius_put_vendor_string - Attaches a vendor specific string attribute
    • radius_request_authenticator - Returns the request authenticator
    • radius_salt_encrypt_attr - Salt-encrypts a value
    • radius_send_request - Sends the request and waits for a reply
    • radius_server_secret - Returns the shared secret
    • radius_strerror - Devuelve un mensaje de error
    • rand - Genera un número entero aleatorio
    • random_bytes - Genera bytes seudoaleatorios criptográficamente seguros
    • random_int - Genera números enteros seudoaleatorios criptográficamente seguros
    • range - Crear un array que contiene un rango de elementos
    • rar:// - RAR
    • RarArchive::close - Cerrar archivo RAR y liberar todos los recursos
    • RarArchive::getComment - Obtener comentarios de texto desde el archivo RAR
    • RarArchive::getEntries - Obtener la lista completa de entradas del archivo RAR
    • RarArchive::getEntry - Obtener el objeto entrada desde el archivo RAR
    • RarArchive::isBroken - Comprobar si un archivo está dañado (incompleto)
    • RarArchive::isSolid - Comprueba si el archivo RAR es sólido
    • RarArchive::open - Abre un archivo RAR
    • RarArchive::setAllowBroken - Determina si la apertura de archivos dañados se permite
    • RarArchive::__toString - Obtener representación de texto
    • RarEntry::extract - Extraer entrada del archivo
    • RarEntry::getAttr - Obtener los atributos de la entrada
    • RarEntry::getCrc - Obtener el CRC de la entrada
    • RarEntry::getFileTime - Devolver entrada última fecha de modificación
    • RarEntry::getHostOs - Obtener sistema operativo anfitrión del archivo de entrada
    • RarEntry::getMethod - Obtener método pack de la entrada
    • RarEntry::getName - Obtener el nombre de la entrada
    • RarEntry::getPackedSize - Obtiene el tamaño empaquetado de la entrada
    • RarEntry::getStream - Obtener manejador de archivo para entrada
    • RarEntry::getUnpackedSize - Obtener el tamaño descomprimido de la entrada
    • RarEntry::getVersion - Obtener la versión mínima del programa RAR requerida para desempaquetar la entrada
    • RarEntry::isDirectory - Comprobar si una entrada representa un directorio
    • RarEntry::isEncrypted - Comprobar si una entrada está cifrada
    • RarEntry::__toString - Obtener texto representación de entrada
    • RarException::isUsingExceptions - Comprobar si el manejador de errores con excepciones está en uso
    • RarException::setUsingExceptions - Activar y desactivar el manejador de errores con excepciones
    • rar_wrapper_cache_stats - Caché de aciertos y errores del URL wrapper
    • rawurldecode - Decodificar cadenas codificadas estilo URL
    • rawurlencode - Codificar estilo URL de acuerdo al RFC 3986
    • readdir - Lee una entrada desde un gestor de directorio
    • readfile - Realizar la salida de un fichero
    • readgzfile - Muestra un archivo gz
    • readline - Lee una línea
    • readline_add_history - Agrega una línea a la historia
    • readline_callback_handler_install - Inicializa la interfaz de llamada de readline y la terminal, imprime el mensaje y retorna inmediatamente
    • readline_callback_handler_remove - Elimina una interfaz de llamada anteriormente agregada y retaura la configuración de terminal
    • readline_callback_read_char - Lee un carácter e informa a la interfaz de llamada de readline cuando una línea es recibida
    • readline_clear_history - Limpia el historial
    • readline_completion_function - Registra una función de autocompletado
    • readline_info - Obtiene/Modifica variables internas a readline
    • readline_list_history - Obtener el historial
    • readline_on_new_line - Informar a readline que el cursor se ha movido a una nueva línea
    • readline_read_history - Lee el historial
    • readline_redisplay - Redibuja la vista
    • readline_write_history - Escribe el historial
    • readlink - Devuelve el objetivo de un enlace simbólico
    • read_exif_data - Alias de exif_read_data
    • realpath - Devuelve el nombre de la ruta absoluta canonizado
    • realpath_cache_get - Obtiene las entradas de la caché de la ruta real
    • realpath_cache_size - Obtiene el tamaño de la caché de la ruta real
    • recode - Alias de recode_string
    • recode_file - Recodificar de fichero a fichero según la petición de recoficación
    • recode_string - Recodifica un string según una petición de recodificación
    • RecursiveArrayIterator::getChildren - Devuelve un iterador para la entrada actual si este es un array o un object
    • RecursiveArrayIterator::hasChildren - Devuelve si la entrada actual es un array o un objeto
    • RecursiveCachingIterator::getChildren - Devuelve los iteradores internos hijos como un RecursiveCachingIterator
    • RecursiveCachingIterator::hasChildren - Comprueba si el elemento actual de un iterador interno tiene hijos
    • RecursiveCachingIterator::__construct - Construct
    • RecursiveCallbackFilterIterator::getChildren - D3evuelve los iteradores internos hijos contenidos en un RecursiveCallbackFilterIterator
    • RecursiveCallbackFilterIterator::hasChildren - Comprueba si los iteradores internos del elemento actual tiene hijos
    • RecursiveCallbackFilterIterator::__construct - Crear un RecursiveCallbackFilterIterator desde un RecursiveIterator
    • RecursiveDirectoryIterator::getChildren - Devuelve un iterador de la entrada actual si se trata de un directorio
    • RecursiveDirectoryIterator::getSubPath - Obtiene sub ruta
    • RecursiveDirectoryIterator::getSubPathname - Obtiene la sub ruta y nombre
    • RecursiveDirectoryIterator::hasChildren - Devuelve si la entrada actual es un directorio y no '.' o '..'
    • RecursiveDirectoryIterator::key - Devuelve la ruta y nombre de fichero del directorio
    • RecursiveDirectoryIterator::next - Mover a la siguiente entrada
    • RecursiveDirectoryIterator::rewind - Rebobina el directorio hasta el inicio
    • RecursiveDirectoryIterator::__construct - Construye un RecursiveDirectoryIterator
    • RecursiveFilterIterator::getChildren - Devuelve los hijos del iterador interno contenidos en un RecursiveFilterIterator
    • RecursiveFilterIterator::hasChildren - Comprueba si el elemento actual del iterador interno tiene hijos
    • RecursiveFilterIterator::__construct - Crear un RecursiveFilterIterator a partir de un RecursiveIterator
    • RecursiveIterator::getChildren - Devuelve un iterador para la entrada actual
    • RecursiveIterator::hasChildren - Retorna si un iterador puede ser creado para la entrada actual
    • RecursiveIteratorIterator::beginChildren - Inicio del hijo
    • RecursiveIteratorIterator::beginIteration - Inicio de la iteración
    • RecursiveIteratorIterator::callGetChildren - Obtener hijo
    • RecursiveIteratorIterator::callHasChildren - Comprueba si tiene hijos
    • RecursiveIteratorIterator::current - Acceder al valor del elemento actual
    • RecursiveIteratorIterator::endChildren - Final de los hijos
    • RecursiveIteratorIterator::endIteration - Final de la iteración
    • RecursiveIteratorIterator::getDepth - Obtener la profundidad actual de la iteración recursiva
    • RecursiveIteratorIterator::getInnerIterator - Obtener el iterador interno
    • RecursiveIteratorIterator::getMaxDepth - Obtener el máximo de profundidad
    • RecursiveIteratorIterator::getSubIterator - El subiterador activo actual
    • RecursiveIteratorIterator::key - Acceder a la clave actual
    • RecursiveIteratorIterator::next - Moverse al siguiente elemento
    • RecursiveIteratorIterator::nextElement - Siguiente elemento
    • RecursiveIteratorIterator::rewind - Rebobina el iterador al primer elemento al nivel superior del iterador interno
    • RecursiveIteratorIterator::setMaxDepth - Establecer el máximo de profundidad
    • RecursiveIteratorIterator::valid - Comprueba si la posición actual es válida
    • RecursiveIteratorIterator::__construct - Construir un objeto RecursiveIteratorIterator
    • RecursiveRegexIterator::getChildren - Devuelve un iterador para la entrada actual
    • RecursiveRegexIterator::hasChildren - Retorna si un iterador puede ser obtenido de la entrada actual
    • RecursiveRegexIterator::__construct - Crea un nuevo RecursiveRegexIterator
    • RecursiveTreeIterator::beginChildren - Inicio de los hijos
    • RecursiveTreeIterator::beginIteration - Inicio de la iteración
    • RecursiveTreeIterator::callGetChildren - Obtener los hijos
    • RecursiveTreeIterator::callHasChildren - Comprobar si tiene hijos
    • RecursiveTreeIterator::current - Obtener el elemento actual
    • RecursiveTreeIterator::endChildren - Final de los hijos
    • RecursiveTreeIterator::endIteration - Fin de la iteración
    • RecursiveTreeIterator::getEntry - obtener la entrada actual
    • RecursiveTreeIterator::getPostfix - Obtiener el postfijo
    • RecursiveTreeIterator::getPrefix - Obtener el prefijo
    • RecursiveTreeIterator::key - Obtiene la clave de el elemento actual
    • RecursiveTreeIterator::next - Mover al siguiente elemento
    • RecursiveTreeIterator::nextElement - Comprueba si hay un siguiente elemento
    • RecursiveTreeIterator::rewind - Rebobina el iterador
    • RecursiveTreeIterator::setPostfix - Set postfix
    • RecursiveTreeIterator::setPrefixPart - Establece la parte de el prefijo
    • RecursiveTreeIterator::valid - Comprueba la validez
    • RecursiveTreeIterator::__construct - Construye un nuevo RecursiveTreeIterator
    • Reflection::export - Exportar
    • Reflection::getModifierNames - Obtener nombres de modificadores
    • ReflectionClass::export - Exporta una clase
    • ReflectionClass::getConstant - Obtener una constante definida
    • ReflectionClass::getConstants - Obtener constantes
    • ReflectionClass::getConstructor - Obtiene el constructor de una clase
    • ReflectionClass::getDefaultProperties - Obtener propiedades predeterminadas
    • ReflectionClass::getDocComment - Obtener los comentarios de documentación
    • ReflectionClass::getEndLine - Consultar línea final
    • ReflectionClass::getExtension - Obtiene un objeto ReflectionExtension para la extensión que definió la clase
    • ReflectionClass::getExtensionName - Obtiene el nombre de la extensión que definió una clase
    • ReflectionClass::getFileName - Obtiene el nombre de fichero en el que está definida la clase
    • ReflectionClass::getInterfaceNames - Obtiene nombres de las interfaces
    • ReflectionClass::getInterfaces - Obtiene las interfaces
    • ReflectionClass::getMethod - Obtiene un objeto ReflectionMethod para un método de una clase
    • ReflectionClass::getMethods - Obtiene un array de métodos
    • ReflectionClass::getModifiers - Obtiene los modificadores de clase
    • ReflectionClass::getName - Obtiene el nombre de la clase
    • ReflectionClass::getNamespaceName - Obtiene el nombre del espacio de nombres
    • ReflectionClass::getParentClass - Obtiene la clase padre
    • ReflectionClass::getProperties - Obtiene las propiedades
    • ReflectionClass::getProperty - Obtiene un objeto ReflectionProperty para una propiedad de una clase
    • ReflectionClass::getReflectionConstant - Gets a ReflectionClassConstant for a class's constant
    • ReflectionClass::getReflectionConstants - Gets class constants
    • ReflectionClass::getShortName - Obtiene el nombre abreviado
    • ReflectionClass::getStartLine - Obtiene el número de linea de inicio
    • ReflectionClass::getStaticProperties - Obtiene las propiedades estáticas
    • ReflectionClass::getStaticPropertyValue - Obtiene el valor de una propiedad estática
    • ReflectionClass::getTraitAliases - Obtiene un array con los alias usados con los traits
    • ReflectionClass::getTraitNames - Devuelve un array con los nombres de los traits usados por esta clase
    • ReflectionClass::getTraits - Obtiene un array con los traits que utiliza esta clase
    • ReflectionClass::hasConstant - Comprueba si una constante está o no definida
    • ReflectionClass::hasMethod - Comprueba si un método está o no definido
    • ReflectionClass::hasProperty - Comprueba si una propiedad está o no definida
    • ReflectionClass::implementsInterface - Comprueba si se implementa una determinada interfaz
    • ReflectionClass::inNamespace - Comprueba si pertenece a un determinado espacio de nombres
    • ReflectionClass::isAbstract - Comprueba si la clase es abstracta
    • ReflectionClass::isAnonymous - Checks if class is anonymous
    • ReflectionClass::isCloneable - Comprueba si la clase es o no clonable
    • ReflectionClass::isFinal - Comprueba si la clase inal
    • ReflectionClass::isInstance - Comprueba si un objeto es instancia de la clase
    • ReflectionClass::isInstantiable - Comprueba si una clase es instanciable
    • ReflectionClass::isInterface - Comprueba una la clase es una interfaz
    • ReflectionClass::isInternal - Comprueba si una clase está definida internamente por una extensión o por el núcleo
    • ReflectionClass::isIterable - Check whether this class is iterable
    • ReflectionClass::isIterateable - Comprueba si es iterable
    • ReflectionClass::isSubclassOf - Comprueba si es una subclase
    • ReflectionClass::isTrait - Comprueba si es un trait
    • ReflectionClass::isUserDefined - Comprueba si es una clase definida por el usuario
    • ReflectionClass::newInstance - Crea una nueva instancia de clase a partir de la lista de parámetros dados
    • ReflectionClass::newInstanceArgs - Crea una nueva instancia de clase a partir de los argumentos dados
    • ReflectionClass::newInstanceWithoutConstructor - Crea una nueva clase sin invocar al constructor
    • ReflectionClass::setStaticPropertyValue - Establece el valor de una propiedad estática
    • ReflectionClass::__construct - Construye un objeto de tipo ReflectionClass
    • ReflectionClass::__toString - Devuelve la representación en forma de string del objeto ReflectionClass
    • ReflectionClassConstant::export - Export
    • ReflectionClassConstant::getDeclaringClass - Gets declaring class
    • ReflectionClassConstant::getDocComment - Gets doc comments
    • ReflectionClassConstant::getModifiers - Gets the class constant modifiers
    • ReflectionClassConstant::getName - Get name of the constant
    • ReflectionClassConstant::getValue - Gets value
    • ReflectionClassConstant::isPrivate - Checks if class constant is private
    • ReflectionClassConstant::isProtected - Checks if class constant is protected
    • ReflectionClassConstant::isPublic - Checks if class constant is public
    • ReflectionClassConstant::__construct - Constructs a ReflectionClassConstant
    • ReflectionClassConstant::__toString - Returns the string representation of the ReflectionClassConstant object
    • ReflectionExtension::export - Exportar
    • ReflectionExtension::getClasses - Obtiene clases
    • ReflectionExtension::getClassNames - Obtiene nombres de las clases
    • ReflectionExtension::getConstants - Obtiene las constantes
    • ReflectionExtension::getDependencies - Obtiene las dependencias
    • ReflectionExtension::getFunctions - Obtiene las funciones de una extensión
    • ReflectionExtension::getINIEntries - Obtiene las entradas INI de la extensión
    • ReflectionExtension::getName - Obtiene el nombre de la extensión
    • ReflectionExtension::getVersion - Obtiene la versión de una extensión
    • ReflectionExtension::info - Imprime información sobre la extensión
    • ReflectionExtension::isPersistent - Indica si la extensión es persistente
    • ReflectionExtension::isTemporary - Indica si la extensión es temporal
    • ReflectionExtension::__clone - Clonar
    • ReflectionExtension::__construct - Constructor de los objetos ReflectionExtension
    • ReflectionExtension::__toString - Convertir a string
    • ReflectionFunction::export - Exporta una función
    • ReflectionFunction::getClosure - Genera dinámicamente una función anónima de esta función
    • ReflectionFunction::invoke - Invoca una función
    • ReflectionFunction::invokeArgs - Invoca a la función con argumentos
    • ReflectionFunction::isDisabled - Comprueba si una función está desactivada
    • ReflectionFunction::__construct - Contruye un objeto de tipo ReflectionFunction
    • ReflectionFunction::__toString - Convertir a string
    • ReflectionFunctionAbstract::getClosureScopeClass - Devuelve el ámbito asociado al cierre
    • ReflectionFunctionAbstract::getClosureThis - Devuelve una función anónima que apunta a esta función
    • ReflectionFunctionAbstract::getDocComment - Obtiene comentarios de documentación
    • ReflectionFunctionAbstract::getEndLine - Obtiene número de linea final
    • ReflectionFunctionAbstract::getExtension - Obtiene información sobre la extensión
    • ReflectionFunctionAbstract::getExtensionName - Obtiene el nombre de la extensión
    • ReflectionFunctionAbstract::getFileName - Obtiene el nombre del fichero
    • ReflectionFunctionAbstract::getName - Obtiene el nombre de la función
    • ReflectionFunctionAbstract::getNamespaceName - Obtiene el nombre del espacio de nombres
    • ReflectionFunctionAbstract::getNumberOfParameters - Obtiene el número total de parámetros
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters - Obtiene el número de parámetros obligatorios
    • ReflectionFunctionAbstract::getParameters - Obtiene los parámetros
    • ReflectionFunctionAbstract::getReturnType - Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName - Obtiene el nombre abreviado de la función
    • ReflectionFunctionAbstract::getStartLine - Obtiene el número de la línea de inicio
    • ReflectionFunctionAbstract::getStaticVariables - Obtiene las variable estáticas
    • ReflectionFunctionAbstract::hasReturnType - Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace - Comprueba si pertenece a un espacio de nombres
    • ReflectionFunctionAbstract::isClosure - Comprobar si es un cierre
    • ReflectionFunctionAbstract::isDeprecated - Comprueba si está obsoleta
    • ReflectionFunctionAbstract::isGenerator - Devuelve si la función es un generador
    • ReflectionFunctionAbstract::isInternal - Comprueba si la función es interna
    • ReflectionFunctionAbstract::isUserDefined - Comprueba si es una función definida por un usuario
    • ReflectionFunctionAbstract::isVariadic - Comprueba si la función es varíadica
    • ReflectionFunctionAbstract::returnsReference - Comprueba si devuelve una referencia
    • ReflectionFunctionAbstract::__clone - Clona una función
    • ReflectionFunctionAbstract::__toString - Convertir a texto
    • ReflectionGenerator::getExecutingFile - Gets the file name of the currently executing generator
    • ReflectionGenerator::getExecutingGenerator - Gets the executing Generator object
    • ReflectionGenerator::getExecutingLine - Gets the currently executing line of the generator
    • ReflectionGenerator::getFunction - Gets the function name of the generator
    • ReflectionGenerator::getThis - Gets the $this value of the generator
    • ReflectionGenerator::getTrace - Gets the trace of the executing generator
    • ReflectionGenerator::__construct - Constructs a ReflectionGenerator object
    • ReflectionMethod::export - Exporta un objeto de tipo ReflectionMethod
    • ReflectionMethod::getClosure - Devuelve un cierre creado dinámicamente para este método
    • ReflectionMethod::getDeclaringClass - Obtiene la clase en la que se ha declarado el método
    • ReflectionMethod::getModifiers - Obtiene los modificadores del método
    • ReflectionMethod::getPrototype - Obtiene el prototipo del método (si lo hubiera)
    • ReflectionMethod::invoke - Invoca un método
    • ReflectionMethod::invokeArgs - Invoca un método con argumentos
    • ReflectionMethod::isAbstract - Comprueba si el método es abstracto
    • ReflectionMethod::isConstructor - Comprueba si el método es un constructor
    • ReflectionMethod::isDestructor - Comprueba si el método es un destructor
    • ReflectionMethod::isFinal - Comprueba si el método es final
    • ReflectionMethod::isPrivate - Comprueba si el método es privado
    • ReflectionMethod::isProtected - Comprueba si el método está protegido
    • ReflectionMethod::isPublic - Comprueba si el método es público
    • ReflectionMethod::isStatic - Comprueba si el método es estático
    • ReflectionMethod::setAccessible - Asigna la accesibilidad del método
    • ReflectionMethod::__construct - Construye un objeto ReflectionMethod
    • ReflectionMethod::__toString - Devuelve la representación en forma de texto de este objeto
    • ReflectionNamedType::getName - Get the text of the type hint
    • ReflectionNamedType::isBuiltin - Checks if it is a built-in type
    • ReflectionObject::export - Exportación
    • ReflectionObject::__construct - Construye un ReflectionObject
    • ReflectionParameter::allowsNull - Comprueba si null es permitido
    • ReflectionParameter::canBePassedByValue - Devuelve si este parámetro de puede pasar por valor
    • ReflectionParameter::export - Exportar
    • ReflectionParameter::getClass - Obtener la clase con declaraciones de tipos
    • ReflectionParameter::getDeclaringClass - Obtiene declaración de la clase
    • ReflectionParameter::getDeclaringFunction - Obtiene declaración de función
    • ReflectionParameter::getDefaultValue - Obtiene el valor del parámetro por defecto
    • ReflectionParameter::getDefaultValueConstantName - Devuelve el nombre de la consntante del valor predeterminado si el valor predeterminado es constante o null
    • ReflectionParameter::getName - Obtener el nombre del parámetro
    • ReflectionParameter::getPosition - Obtiene la posición del parámetro
    • ReflectionParameter::getType - Gets a parameter's type
    • ReflectionParameter::hasType - Checks if parameter has a type
    • ReflectionParameter::isArray - Comprueba si el parámetro espera un array
    • ReflectionParameter::isCallable - Devuelve si el parámetro DEBE ser de tipo callable
    • ReflectionParameter::isDefaultValueAvailable - Comprueba si el valor por defecto está disponible
    • ReflectionParameter::isDefaultValueConstant - Devuelve si el valor predeterminado de este parámetro es constante
    • ReflectionParameter::isOptional - Comprueba si es opcional
    • ReflectionParameter::isPassedByReference - Comprueba si es pasado por referencia
    • ReflectionParameter::isVariadic - Comprueba si el parámetro es varíadico
    • ReflectionParameter::__clone - Clon
    • ReflectionParameter::__construct - Construct
    • ReflectionParameter::__toString - A string
    • ReflectionProperty::export - Exportar
    • ReflectionProperty::getDeclaringClass - Obtiene la clase en la que se declaró
    • ReflectionProperty::getDefaultValue - Returns the default value declared for a property
    • ReflectionProperty::getDocComment - Obtiene los comentarios de documentación de una propiedad
    • ReflectionProperty::getModifiers - Obtiene los modificadores
    • ReflectionProperty::getName - Obtiene el nombre de la propiedad
    • ReflectionProperty::getType - Gets a property's type
    • ReflectionProperty::getValue - Obtiene el valor
    • ReflectionProperty::hasDefaultValue - Checks if property has a default value declared
    • ReflectionProperty::hasType - Checks if property has a type
    • ReflectionProperty::isDefault - Comprueba si una propiedad es predeterminada
    • ReflectionProperty::isInitialized - Checks whether a property is initialized
    • ReflectionProperty::isPrivate - Comprueba si una propiedad es privada
    • ReflectionProperty::isProtected - Comprueba si la propiedad es protegida
    • ReflectionProperty::isPublic - Comprueba si la propiedad es pública
    • ReflectionProperty::isStatic - Comprueba si la propiedad es estática
    • ReflectionProperty::setAccessible - Hace accesible una propiedad
    • ReflectionProperty::setValue - Establece el valor de la propiedad
    • ReflectionProperty::__clone - Clonar
    • ReflectionProperty::__construct - Construir un objeto ReflectionProperty
    • ReflectionProperty::__toString - Convertir a texto
    • ReflectionReference::fromArrayElement - Create a ReflectionReference from an array element
    • ReflectionReference::getId - Get unique ID of a reference
    • ReflectionType::allowsNull - Checks if null is allowed
    • ReflectionType::__toString - To string
    • ReflectionUnionType::getTypes - Returns the types included in the union type
    • ReflectionZendExtension::export - Exportar
    • ReflectionZendExtension::getAuthor - Consultar autor
    • ReflectionZendExtension::getCopyright - Consultar los derechos de copia
    • ReflectionZendExtension::getName - Obtiene el nombre
    • ReflectionZendExtension::getURL - Obtiene la URL
    • ReflectionZendExtension::getVersion - Obtiene la versión
    • ReflectionZendExtension::__clone - Clon de controlador
    • ReflectionZendExtension::__construct - Constructor
    • ReflectionZendExtension::__toString - Convierte a texto
    • Reflector::export - Exportar
    • Reflector::__toString - Convertir a String
    • RegexIterator::accept - Obtener el estado de aceptación
    • RegexIterator::getFlags - Obtener flags
    • RegexIterator::getMode - Devuelve el modo de operación
    • RegexIterator::getPregFlags - Devuelve las flags de expresión regular
    • RegexIterator::getRegex - Devuelve la expresión regular actual
    • RegexIterator::setFlags - Establece las flags
    • RegexIterator::setMode - Establece el modo de operación
    • RegexIterator::setPregFlags - Establece las flags de expresión regular
    • RegexIterator::__construct - Crea un nuevo RegexIterator
    • register_shutdown_function - Registrar una función para que sea ejecutada al cierre
    • register_tick_function - Registrar una función para que sea ejecutada en cada tick
    • rename - Renombra un fichero o directorio
    • reset - Establece el puntero interno de un array a su primer elemento
    • ResourceBundle::count - Obtener el número de elementos de un paquete
    • ResourceBundle::create - Crear un paquete de recursos
    • ResourceBundle::get - Obtener datos de un paquete
    • ResourceBundle::getErrorCode - Obtener el códido del último error del paquete
    • ResourceBundle::getErrorMessage - Obtener el mensaje del último error del paquete
    • ResourceBundle::getLocales - Obtener las configuraciones regionales soportadas
    • restore_error_handler - Recupera la función de gestión de errores previa
    • restore_exception_handler - Restaura la función de gestión de excepciones previamente definida
    • restore_include_path - Restablece el valor de la opción de configuración include_path
    • rewind - Rebobina la posición de un puntero a un archivo
    • rewinddir - Regresar el gestor de directorio
    • rmdir - Elimina un directorio
    • round - Redondea un float
    • rpmaddtag - Add tag retrieved in query
    • rpmdbinfo - Get information from installed RPM
    • rpmdbsearch - Search RPM packages
    • rpminfo - Get information from a RPM file
    • rpmvercmp - RPM version comparison
    • RRDCreator::addArchive - Añade RRA - archivo de valores de datos para cada fuente de datos
    • RRDCreator::addDataSource - Añade definición de origen de datos para la base de datos RRD
    • RRDCreator::save - Guarda la base de datos RRD en un archivo
    • RRDCreator::__construct - Crea una nueva instancia RRDCreator
    • rrdc_disconnect - Close any outstanding connection to rrd caching daemon
    • RRDGraph::save - Guarda el resultado de la consulta en la imagen
    • RRDGraph::saveVerbose - Guarda la consulta de la bases de datos RRD en la imagen y devuelve la información detallada acerca de gráfico generado.
    • RRDGraph::setOptions - Establece las opciones para la exportación gráfica rrd
    • RRDGraph::__construct - Crea una nueva instancia RRDGraph
    • RRDUpdater::update - Actualiza el archivo de base de datos RRD
    • RRDUpdater::__construct - Crea una nueva instancia RRDUpdater
    • rrd_create - Crea un archivo de base de datos rrd
    • rrd_error - Obtener el último mensaje de error
    • rrd_fetch - Recuperar los datos de gráfico como un array
    • rrd_first - Obtiene la marca de tiempo UNIX de la primera muestra desde el archivo rrd
    • rrd_graph - Crea la imagen de un conjunto de datos
    • rrd_info - Obtiene información sobre el archivo rrd
    • rrd_last - Obtiene la marca de tiempo UNIX de la última muestra
    • rrd_lastupdate - Obtiene información sobre los últimos datos actualizados
    • rrd_restore - Restaura el archivo RRD desde el XML dump
    • rrd_tune - Cambia algunas opciones de cabecera del archivo de base de datos RRD database
    • rrd_update - Actualizar la base de datos RRD
    • rrd_version - Obtiene información acerca de la biblioteca subyacente rrdtool
    • rrd_xport - Exporta la información acerca de la base de datos RRD
    • rsort - Ordena un array en orden inverso
    • rtrim - Retira los espacios en blanco (u otros caracteres) del final de un string
    • runkit7_object_id - Return the integer object handle for given object
    • runkit7_zval_inspect - Returns information about the passed in value with data types, reference counts, etc
    • runkit_constant_add - Similar a define(), excepto que también permite definir en definiciones de clase
    • runkit_constant_redefine - Redefinir una constante ya definida
    • runkit_constant_remove - Eliminar/Borrar una constante ya definida
    • runkit_function_add - Añadir una nueva función, similar a create_function
    • runkit_function_copy - Copiar una función a un nombre de función nuevo
    • runkit_function_redefine - Reemplazar una definición de función con una nueva implementación
    • runkit_function_remove - Eliminar una definición de función
    • runkit_function_rename - Cambiar el nombre de una función
    • runkit_import - Procesar un archivo PHP importando definiciones de funciones y clases, sobrescribiendo cuando sea apropiado
    • runkit_method_add - Añadir dinámicamente un nuevo método a una clase dada
    • runkit_method_copy - Copia un método de una clase a otra
    • runkit_method_redefine - Cambiar dinámicamente el código del método dado
    • runkit_method_remove - Eliminar dinámicamente el método dado
    • runkit_method_rename - Cambiar dinámicamente el nombre del método dado
    • runkit_superglobals - Devolver el array indexado numéricamente de las superglobales registradas
  • s
    • sapi_windows_cp_conv - Convert string from one codepage to another
    • sapi_windows_cp_get - Get current codepage
    • sapi_windows_cp_is_utf8 - Indicates whether the codepage is UTF-8 compatible
    • sapi_windows_cp_set - Set process codepage
    • sapi_windows_generate_ctrl_event - Send a CTRL event to another process
    • sapi_windows_set_ctrl_handler - Set or remove a CTRL event handler
    • sapi_windows_vt100_support - Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
    • scandir - Enumera los ficheros y directorios ubicados en la ruta especificada
    • scoutapm_get_calls - Returns a list of instrumented calls that have occurred
    • scoutapm_list_instrumented_functions - List functions scoutapm will instrument.
    • SeasLog::alert - Record alert log information
    • SeasLog::analyzerCount - Get log count by level, log_path and key_word
    • SeasLog::analyzerDetail - Get log detail by level, log_path, key_word, start, limit, order
    • SeasLog::closeLoggerStream - Manually release stream flow from logger
    • SeasLog::critical - Record critical log information
    • SeasLog::debug - Record debug log information
    • SeasLog::emergency - Record emergency log information
    • SeasLog::error - Record error log information
    • SeasLog::flushBuffer - Flush logs buffer, dump to appender file, or send to remote api with tcp/udp
    • SeasLog::getBasePath - Get SeasLog base path.
    • SeasLog::getBuffer - Get the logs buffer in memory as array
    • SeasLog::getBufferEnabled - Determin if buffer enabled
    • SeasLog::getDatetimeFormat - Get SeasLog datetime format style
    • SeasLog::getLastLogger - Get SeasLog last logger path
    • SeasLog::getRequestID - Get SeasLog request_id differentiated requests
    • SeasLog::getRequestVariable - Get SeasLog request variable
    • SeasLog::info - Record info log information
    • SeasLog::log - The Common Record Log Function
    • SeasLog::notice - Record notice log information
    • SeasLog::setBasePath - Set SeasLog base path
    • SeasLog::setDatetimeFormat - Set SeasLog datetime format style
    • SeasLog::setLogger - Set SeasLog logger name
    • SeasLog::setRequestID - Set SeasLog request_id differentiated requests
    • SeasLog::setRequestVariable - Manually set SeasLog request variable
    • SeasLog::warning - Record warning log information
    • SeasLog::__construct - Description
    • SeasLog::__destruct - Description
    • seaslog_get_author - Get SeasLog author.
    • seaslog_get_version - Get SeasLog version.
    • SeekableIterator::seek - Mueve la posición del apuntador interno
    • sem_acquire - Adquirir un semáforo
    • sem_get - Obtener el id de un semáforo
    • sem_release - Liberar un semáforo
    • sem_remove - Eliminar un semáforo
    • Serializable::serialize - Representación en formato cadena de un objeto
    • Serializable::unserialize - Construye el objeto
    • serialize - Genera una representación apta para el almacenamiento de un valor
    • SessionHandler::close - Cerrar la sesión
    • SessionHandler::create_sid - Devuelve un nuevo ID de sesión
    • SessionHandler::destroy - Destruir una sesión
    • SessionHandler::gc - Eliminar las sesiones antiguas
    • SessionHandler::open - Inicializar una sesión
    • SessionHandler::read - Leer información de la sesión
    • SessionHandler::write - Escribir información de sesión
    • SessionHandlerInterface::close - Cerrar la sesión
    • SessionHandlerInterface::destroy - Destruir una sesión
    • SessionHandlerInterface::gc - Limpieza de sesiones antiguas
    • SessionHandlerInterface::open - Inicializar una sesión
    • SessionHandlerInterface::read - Leer información de sesión
    • SessionHandlerInterface::write - Escribir información de sesión
    • SessionIdInterface::create_sid - Create session ID
    • SessionUpdateTimestampHandlerInterface::updateTimestamp - Update timestamp
    • SessionUpdateTimestampHandlerInterface::validateId - Validate ID
    • session_abort - Desecha los cambios en el array de sesión y finaliza la sesión
    • session_cache_expire - Devuelve la caducidad de la caché actual
    • session_cache_limiter - Obtener y/o establecer el limitador de caché actual
    • session_commit - Alias de session_write_close
    • session_create_id - Crear un nuevo ID de sesión
    • session_decode - Decodifica la información de sesión desde una cadena de sesión codificada
    • session_destroy - Destruye toda la información registrada de una sesión
    • session_encode - Codifica los datos de la sesión actual como un string codificado de sesión
    • session_gc - Realizar una recolección de basura de datos de sesión
    • session_get_cookie_params - Obtener los parámetros de la cookie de sesión
    • session_id - Obtener y/o establecer el id de sesión actual
    • session_is_registered - Averiguar si una variable global está registrada en una sesión
    • session_module_name - Obtiene y/o establece el módulo de sesión actual
    • session_name - Obtener y/o establecer el nombre de la sesión actual
    • session_regenerate_id - Actualiza el id de sesión actual con uno generado más reciente
    • session_register_shutdown - Función de cierre de sesiones
    • session_reset - Reinicializar el array de sesión con los valores originales
    • session_save_path - Obtener y/o establecer la ruta de almacenamiento de la sesión actual
    • session_set_cookie_params - Establecer los parámetros de la cookie de sesión
    • session_set_save_handler - Establece funciones de almacenamiento de sesiones a nivel de usuario
    • session_start - Iniciar una nueva sesión o reanudar la existente
    • session_status - Devuelve el estado de la sesión actual
    • session_unregister - Deja de registrar una variable global de la sesión actual
    • session_unset - Libera todas las variables de sesión
    • session_write_close - Escribir información de sesión y finalizar la sesión
    • setcookie - Enviar una cookie
    • setlocale - Establecer la información del localismo
    • setproctitle - Establecer el título de proceso
    • setrawcookie - Enviar una cookie sin codificar su valor
    • setthreadtitle - Set the thread title
    • settype - Establece el tipo de una variable
    • set_error_handler - Establecer una función de gestión de errores definida por el usuario
    • set_exception_handler - Establece una función de gestión de excepciones definida por el usuario
    • set_file_buffer - Alias de stream_set_write_buffer
    • set_include_path - Establece la opción de configuración include_path
    • set_time_limit - Limita el tiempo máximo de ejecución
    • sha1 - Calcula el 'hash' sha1 de un string
    • sha1_file - Calcula el hash sha1 de un archivo
    • shell_exec - Ejecutar un comando mediante el intérprete de comandos y devolver la salida completa como una cadena
    • shmop_close - Cerrar un segmento de memoria compartida
    • shmop_delete - Borrar segmento de memoria compartida
    • shmop_open - Crea o abre un segmento de memoria compartida
    • shmop_read - Leer datos desde un segmento de memoria compartida
    • shmop_size - Obtiene el tamaño de un segmento de memoria compartida
    • shmop_write - Escribir datos en un segmento de memoria compartida
    • shm_attach - Crea o abre un segmento de memoria compartida
    • shm_detach - Desconectarse del segmento de memoria compartida
    • shm_get_var - Devuelve una variable desde la memoria compartida
    • shm_has_var - Verificar si existe una entrada específica
    • shm_put_var - Inserta o actualiza una variable en la memoria compartida
    • shm_remove - Elimina la memoria compartida de sistemas Unix
    • shm_remove_var - Eliminar una variable de la memoria compartida
    • show_source - Alias de highlight_file
    • shuffle - Mezcla un array
    • similar_text - Calcula la similitud entre dos strings
    • SimpleXMLElement::addAttribute - Añade un atributo al elemento SimpleXML
    • SimpleXMLElement::addChild - Añade un elemento hijo al nodo XML
    • SimpleXMLElement::asXML - Retorna un string XML correcto basado en un elemento SimpleXML
    • SimpleXMLElement::attributes - Identifica el atributo de un elemento
    • SimpleXMLElement::children - Encuentra los hijos del nodo dado
    • SimpleXMLElement::count - Cuenta los hijos de un elemento
    • SimpleXMLElement::getDocNamespaces - Devuelve los espacios de nombre declarados en el documento
    • SimpleXMLElement::getName - Retorna el nombre del elemento XML
    • SimpleXMLElement::getNamespaces - Devuelve los espacios de nombre usados en el documento
    • SimpleXMLElement::registerXPathNamespace - Crea un contexto prefijo/ns para la siguiente petición XPath
    • SimpleXMLElement::saveXML - Alias de SimpleXMLElement::asXML
    • SimpleXMLElement::xpath - Ejecuta una petición XPath sobre los datos XML
    • SimpleXMLElement::__construct - Crea un nuevo objeto SimpleXMLElement
    • SimpleXMLElement::__toString - Returns the string content
    • SimpleXMLIterator::current - Devuelve el elemento actual
    • SimpleXMLIterator::getChildren - Devuelve los sub elementos de el elemento actual
    • SimpleXMLIterator::hasChildren - Comprueba si el elemento actual tiene sub elementos
    • SimpleXMLIterator::key - Devuelve la clave actual
    • SimpleXMLIterator::next - Mueve al siguiente elemento
    • SimpleXMLIterator::rewind - Rebobina hasta el primer elemento
    • SimpleXMLIterator::valid - Comprueba si el elemento actual es válido
    • simplexml_import_dom - Obtiene un objeto SimpleXMLElement de un nodo DOM
    • simplexml_load_file - Interpreta un fichero XML en un objeto
    • simplexml_load_string - Interpreta un string de XML en un objeto
    • sin - Seno
    • sinh - Seno hiperbólico
    • sizeof - Alias de count
    • sleep - Retrasar la ejecución
    • snmp2_get - Fetch an SNMP object
    • snmp2_getnext - Fetch the SNMP object which follows the given object id
    • snmp2_real_walk - Return all objects including their respective object ID within the specified one
    • snmp2_set - Set the value of an SNMP object
    • snmp2_walk - Fetch all the SNMP objects from an agent
    • snmp3_get - Fetch an SNMP object
    • snmp3_getnext - Fetch the SNMP object which follows the given object id
    • snmp3_real_walk - Return all objects including their respective object ID within the specified one
    • snmp3_set - Set the value of an SNMP object
    • snmp3_walk - Fetch all the SNMP objects from an agent
    • SNMP::close - Cerrar sesión SNMP
    • SNMP::get - Fetch an SNMP object
    • SNMP::getErrno - Get last error code
    • SNMP::getError - Obtiene el último mensaje de error
    • SNMP::getnext - Fetch an SNMP object which follows the given object id
    • SNMP::set - Set the value of an SNMP object
    • SNMP::setSecurity - Configures security-related SNMPv3 session parameters
    • SNMP::walk - Fetch SNMP object subtree
    • SNMP::__construct - Creates SNMP instance representing session to remote SNMP agent
    • snmpget - Fetch an SNMP object
    • snmpgetnext - Fetch the SNMP object which follows the given object id
    • snmprealwalk - Return all objects including their respective object ID within the specified one
    • snmpset - Set the value of an SNMP object
    • snmpwalk - Fetch all the SNMP objects from an agent
    • snmpwalkoid - Query for a tree of information about a network entity
    • snmp_get_quick_print - Fetches the current value of the NET-SNMP library's quick_print setting
    • snmp_get_valueretrieval - Return the method how the SNMP values will be returned
    • snmp_read_mib - Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print - Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print - Set the OID output format
    • snmp_set_oid_output_format - Set the OID output format
    • snmp_set_quick_print - Set the value of enable within the NET-SNMP library
    • snmp_set_valueretrieval - Specify the method how the SNMP values will be returned
    • SoapClient::__call - Llama a una función de SOAP (obsoleto)
    • SoapClient::__construct - Constructor de SoapClient
    • SoapClient::__doRequest - Realiza una petición SOAP
    • SoapClient::__getCookies - Get list of cookies
    • SoapClient::__getFunctions - Devuelve una lista de todas las funciones SOAP disponibles
    • SoapClient::__getLastRequest - Devuelve la última petición SOAP
    • SoapClient::__getLastRequestHeaders - Devuelve los encabezados SOAP de la última petición
    • SoapClient::__getLastResponse - Devuelve la última respuesta SOAP
    • SoapClient::__getLastResponseHeaders - Devuelve los encabezados SOAP de la última respuesta
    • SoapClient::__getTypes - Devuelve una lista de los tipos SOAP
    • SoapClient::__setCookie - El propósito de __setCookie
    • SoapClient::__setLocation - Define la localización del servicio Web a utilizar
    • SoapClient::__setSoapHeaders - Define los encabezados SOAP para las subsiguentes llamadas
    • SoapClient::__soapCall - Llama a una función SOAP
    • SoapFault::__construct - Constructor de SoapFault
    • SoapFault::__toString - Obtiene una representación en formato cadena de SoapFault
    • SoapHeader::__construct - Constructor de SoapHeader
    • SoapParam::__construct - Constructor de SoapParam
    • SoapServer::addFunction - Añade una o más funciones al controlador de peticiones SOAP
    • SoapServer::addSoapHeader - Añade un encabezado SOAP a la respuesta
    • SoapServer::fault - SoapServer indica que ocurrió un fallo
    • SoapServer::getFunctions - Devuelve una lista de las funciones definidas
    • SoapServer::handle - Controla la petición SOAP
    • SoapServer::setClass - Define la clase que controla las peticiones SOAP
    • SoapServer::setObject - Define el objecto que será usado para controlar las peticiones SOAP
    • SoapServer::setPersistence - Establece el modo de persistencia de SoapServer
    • SoapServer::__construct - Constructor de SoapServer
    • SoapVar::__construct - Constructor de SoapVar
    • socket_accept - Acepta una conexión de un socket
    • socket_addrinfo_bind - Create and bind to a socket from a given addrinfo
    • socket_addrinfo_connect - Create and connect to a socket from a given addrinfo
    • socket_addrinfo_explain - Get information about addrinfo
    • socket_addrinfo_lookup - Get array with contents of getaddrinfo about the given hostname
    • socket_bind - Vincula un nombre a un socket
    • socket_clear_error - Limpia el error del socket o el último código de error
    • socket_close - Cierra un recurso socket
    • socket_cmsg_space - Calcular el tamaño del búfer de mensajes
    • socket_connect - Inicia una conexión sobre un socket
    • socket_create - Crear un socket (extremo de comunicación)
    • socket_create_listen - Abre un socket en un puerto para aceptar conexiones
    • socket_create_pair - Crea un par de sockets indistinguibles y los almacena en una matriz
    • socket_export_stream - Export a socket into a stream that encapsulates a socket
    • socket_getopt - Alias de socket_get_option
    • socket_getpeername - Pregunta a la parte remota del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
    • socket_getsockname - Preguntar a la parte local del socket dado que puede resultar en un host/puerto o en una ruta de sistema de archivos Unix, dependiendo de su tipo
    • socket_get_option - Obtiene las opciones de socket para el socket
    • socket_get_status - Alias de stream_get_meta_data
    • socket_import_stream - Importar un flujo a stream
    • socket_last_error - Devuelve el último error sobre un socket
    • socket_listen - Escucha una conexión sobre un socket
    • socket_read - Lee un máximo de longitud de bytes desde un socket
    • socket_recv - Recibe información desde un socket conectado
    • socket_recvfrom - Recibe información desde un socket que esté o no orientado a conexión
    • socket_recvmsg - Leer un mensaje
    • socket_select - Ejecuta la llamada a select() del sistema sobre las matrices de sockets dadas con un tiempo límite especificado
    • socket_send - Envía información a un socket conectado
    • socket_sendmsg - Enviar un mensaje
    • socket_sendto - Envía un mensaje a un socket, ya esté conectado o no
    • socket_setopt - Alias de socket_set_option
    • socket_set_block - Establece el modo de bloqueo de un recurso socket
    • socket_set_blocking - Alias de stream_set_blocking
    • socket_set_nonblock - Establece el modo de no-bloqueo para el descriptor de archivo fd
    • socket_set_option - Establece las opciones de socket para el socket
    • socket_set_timeout - Alias de stream_set_timeout
    • socket_shutdown - Cierra un socket para dejar de recibir, enviar, o ambos
    • socket_strerror - Devuelve una cadena que describe un error de socket
    • socket_write - Escribir en un socket
    • socket_wsaprotocol_info_export - Exports the WSAPROTOCOL_INFO Structure
    • socket_wsaprotocol_info_import - Imports a Socket from another Process
    • socket_wsaprotocol_info_release - Releases an exported WSAPROTOCOL_INFO Structure
    • sodium_add - Add large numbers
    • sodium_base642bin - Description
    • sodium_bin2base64 - Description
    • sodium_bin2hex - Encode to hexadecimal
    • sodium_compare - Compare large numbers
    • sodium_crypto_aead_aes256gcm_decrypt - Decrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_encrypt - Encrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_is_available - Check if hardware supports AES256-GCM
    • sodium_crypto_aead_aes256gcm_keygen - Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_decrypt - Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_encrypt - Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_decrypt - Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_ietf_encrypt - Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_keygen - Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_keygen - Get random bytes for key
    • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt - Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt - Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_keygen - Description
    • sodium_crypto_auth - Compute a tag for the message
    • sodium_crypto_auth_keygen - Get random bytes for key
    • sodium_crypto_auth_verify - Verifies that the tag is valid for the message
    • sodium_crypto_box - Encrypt a message
    • sodium_crypto_box_keypair - Randomly generate a secret key and a corresponding public key
    • sodium_crypto_box_keypair_from_secretkey_and_publickey - Description
    • sodium_crypto_box_open - Verify and decrypt a ciphertext
    • sodium_crypto_box_publickey - Description
    • sodium_crypto_box_publickey_from_secretkey - Description
    • sodium_crypto_box_seal - Encrypt a message
    • sodium_crypto_box_seal_open - Decrypt the ciphertext
    • sodium_crypto_box_secretkey - Description
    • sodium_crypto_box_seed_keypair - Deterministically derive the key pair from a single key
    • sodium_crypto_generichash - Get a hash of the message
    • sodium_crypto_generichash_final - Complete the hash
    • sodium_crypto_generichash_init - Initialize a hash
    • sodium_crypto_generichash_keygen - Get random bytes for key
    • sodium_crypto_generichash_update - Add message to a hash
    • sodium_crypto_kdf_derive_from_key - Derive a subkey
    • sodium_crypto_kdf_keygen - Get random bytes for key
    • sodium_crypto_kx_client_session_keys - Description
    • sodium_crypto_kx_keypair - Creates a new sodium keypair
    • sodium_crypto_kx_publickey - Description
    • sodium_crypto_kx_secretkey - Description
    • sodium_crypto_kx_seed_keypair - Description
    • sodium_crypto_kx_server_session_keys - Description
    • sodium_crypto_pwhash - Derive a key from a password
    • sodium_crypto_pwhash_scryptsalsa208sha256 - Derives a key from a password
    • sodium_crypto_pwhash_scryptsalsa208sha256_str - Get an ASCII encoded hash
    • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify - Verify that the password is a valid password verification string
    • sodium_crypto_pwhash_str - Get an ASCII-encoded hash
    • sodium_crypto_pwhash_str_needs_rehash - Description
    • sodium_crypto_pwhash_str_verify - Verifies that a password matches a hash
    • sodium_crypto_scalarmult - Compute a shared secret given a user's secret key and another user's public key
    • sodium_crypto_scalarmult_base - Alias de sodium_crypto_box_publickey_from_secretkey
    • sodium_crypto_secretbox - Encrypt a message
    • sodium_crypto_secretbox_keygen - Get random bytes for key
    • sodium_crypto_secretbox_open - Verify and decrypt a ciphertext
    • sodium_crypto_secretstream_xchacha20poly1305_init_pull - Description
    • sodium_crypto_secretstream_xchacha20poly1305_init_push - Description
    • sodium_crypto_secretstream_xchacha20poly1305_keygen - Description
    • sodium_crypto_secretstream_xchacha20poly1305_pull - Description
    • sodium_crypto_secretstream_xchacha20poly1305_push - Description
    • sodium_crypto_secretstream_xchacha20poly1305_rekey - Description
    • sodium_crypto_shorthash - Compute a fixed-size fingerprint for the message
    • sodium_crypto_shorthash_keygen - Get random bytes for key
    • sodium_crypto_sign - Sign a message
    • sodium_crypto_sign_detached - Sign the message
    • sodium_crypto_sign_ed25519_pk_to_curve25519 - Convert an Ed25519 public key to a Curve25519 public key
    • sodium_crypto_sign_ed25519_sk_to_curve25519 - Convert an Ed25519 secret key to a Curve25519 secret key
    • sodium_crypto_sign_keypair - Randomly generate a secret key and a corresponding public key
    • sodium_crypto_sign_keypair_from_secretkey_and_publickey - Description
    • sodium_crypto_sign_open - Check that the signed message has a valid signature
    • sodium_crypto_sign_publickey - Description
    • sodium_crypto_sign_publickey_from_secretkey - Extract the public key from the secret key
    • sodium_crypto_sign_secretkey - Description
    • sodium_crypto_sign_seed_keypair - Deterministically derive the key pair from a single key
    • sodium_crypto_sign_verify_detached - Verify signature for the message
    • sodium_crypto_stream - Generate a deterministic sequence of bytes from a seed
    • sodium_crypto_stream_keygen - Get random bytes for key
    • sodium_crypto_stream_xor - Encrypt a message
    • sodium_hex2bin - Decodes a hexadecimally encoded binary string
    • sodium_increment - Increment large number
    • sodium_memcmp - Test for equality in constant-time
    • sodium_memzero - Overwrite buf with zeros
    • sodium_pad - Add padding data
    • sodium_unpad - Remove padding data
    • SolrClient::addDocument - Añade un documento al índice
    • SolrClient::addDocuments - Añade una colección de instancias de SolrInputDocument al índice
    • SolrClient::commit - Finaliza todas las añadiduras/eliminaciones hechas al índice
    • SolrClient::deleteById - Eliminar por Id
    • SolrClient::deleteByIds - Elimina mediante Ids
    • SolrClient::deleteByQueries - Elimina todos los documentos que coincidan con cualquiera de las consultas
    • SolrClient::deleteByQuery - Elimina todos los documentos que coincidan con la consulta dada
    • SolrClient::getById - Get Document By Id. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getByIds - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getDebug - Devuelve la información de depuración para el último intento de conexión
    • SolrClient::getOptions - Devuelve las opciones de cliente establecidas internamente
    • SolrClient::optimize - Defragmenta el índice
    • SolrClient::ping - Comprueba si el servidor Solr está todavía activo
    • SolrClient::query - Envía una consulta al servidor
    • SolrClient::request - Envía una petición de actualización sin formato
    • SolrClient::rollback - Revierte todos los añadidos/eliminados hechos en el índice desde el último envío
    • SolrClient::setResponseWriter - Establece el autor de la respuesta usado para preparar la respuesta de Solr
    • SolrClient::setServlet - Cambia el servlet especificado a un nuevo valor
    • SolrClient::system - Obtener información del Servidor Solr
    • SolrClient::threads - Verifica el estado de los hilos
    • SolrClient::__construct - Constructor para el objeto SolrClient
    • SolrClient::__destruct - Destructor para SolrClient
    • SolrClientException::getInternalInfo - Devuelve información interna de donde se lanzó la excepción
    • SolrCollapseFunction::getField - Returns the field that is being collapsed on
    • SolrCollapseFunction::getHint - Returns collapse hint
    • SolrCollapseFunction::getMax - Returns max parameter
    • SolrCollapseFunction::getMin - Returns min parameter
    • SolrCollapseFunction::getNullPolicy - Returns null policy
    • SolrCollapseFunction::getSize - Returns size parameter
    • SolrCollapseFunction::setField - Sets the field to collapse on
    • SolrCollapseFunction::setHint - Sets collapse hint
    • SolrCollapseFunction::setMax - Selects the group heads by the max value of a numeric field or function query
    • SolrCollapseFunction::setMin - Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy - Sets the NULL Policy
    • SolrCollapseFunction::setSize - Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::__construct - Constructor
    • SolrCollapseFunction::__toString - Returns a string representing the constructed collapse function
    • SolrDisMaxQuery::addBigramPhraseField - Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery - Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField - Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField - Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField - Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField - Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::removeBigramPhraseField - Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery - Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField - Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField - Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField - Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField - Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop - Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction - Sets a Boost Function (bf parameter)
    • SolrDisMaxQuery::setBoostQuery - Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch - Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields - Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop - Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt - Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop - Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker - Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields - Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop - Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields - Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser - Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser - Switch QueryParser to be EDisMax
    • SolrDisMaxQuery::__construct - Class Constructor
    • SolrDocument::addField - añade un campo al documento
    • SolrDocument::clear - Borra todos los campos del documento
    • SolrDocument::current - Recupera el campo actual
    • SolrDocument::deleteField - Elimina un campo del documento
    • SolrDocument::fieldExists - Comprueba si existe un campo en el documento
    • SolrDocument::getChildDocuments - Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrDocument::getField - Recupera un campo según su nombre
    • SolrDocument::getFieldCount - Devuelve el número de campos de este documento
    • SolrDocument::getFieldNames - Devuelve una matriz con los nombres de campos del documento
    • SolrDocument::getInputDocument - Devuelve un SolrInputDocument equivalente al objeto
    • SolrDocument::hasChildDocuments - Checks whether the document has any child documents
    • SolrDocument::key - Recupera la clave actual
    • SolrDocument::merge - Fusiona la fuente con el objeto SolrDocument actual
    • SolrDocument::next - Mueve el puntero interno al siguiente campo
    • SolrDocument::offsetExists - Comprueba si existe un campo en particular
    • SolrDocument::offsetGet - Recupera un campo
    • SolrDocument::offsetSet - Añade un campo al documento
    • SolrDocument::offsetUnset - Elimina un campo
    • SolrDocument::reset - Este es un alias de SolrDocument::clear()
    • SolrDocument::rewind - Reinicia el puntero interno al principio
    • SolrDocument::serialize - Usado para serialización personalizada
    • SolrDocument::sort - Ordena los campos del documento
    • SolrDocument::toArray - Devuelve una matriz como representación de un documento
    • SolrDocument::unserialize - Serialización personalizada de objetos SolrDocument
    • SolrDocument::valid - Comprueba si la posición actual del puntero interno es aún válida
    • SolrDocument::__clone - Crea una copia de un objeto SolrDocument
    • SolrDocument::__construct - Constructor
    • SolrDocument::__destruct - Destructor
    • SolrDocument::__get - Acceder al campo como una propiedad
    • SolrDocument::__isset - Comprueba si existe un campo
    • SolrDocument::__set - Añade otro campo al documento
    • SolrDocument::__unset - Elimina un campo del documento
    • SolrDocumentField::__construct - Constructor
    • SolrDocumentField::__destruct - Destructor
    • SolrException::getInternalInfo - Devuelve información interna de donde se lanzó la excepción
    • SolrGenericResponse::__construct - Constructor
    • SolrGenericResponse::__destruct - Destructor
    • SolrIllegalArgumentException::getInternalInfo - Devuelve información interna de donde se lanzó la excepción
    • SolrIllegalOperationException::getInternalInfo - Devuelve información interna de donde se lanzó la excepción
    • SolrInputDocument::addChildDocument - Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments - Adds an array of child documents
    • SolrInputDocument::addField - Añade un campo al documento
    • SolrInputDocument::clear - Restablece el documento de entrada
    • SolrInputDocument::deleteField - Elimina un campo del documento
    • SolrInputDocument::fieldExists - Comprueba si existe un campo
    • SolrInputDocument::getBoost - Recupera el valor boost actual del documento
    • SolrInputDocument::getChildDocuments - Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrInputDocument::getField - Recupera un campo por su nombre
    • SolrInputDocument::getFieldBoost - Recupera el valor boost de un campo en particular
    • SolrInputDocument::getFieldCount - Devuelve el número de campos del documento
    • SolrInputDocument::getFieldNames - Devuelve una matriz que contiene todos los campos del documento
    • SolrInputDocument::hasChildDocuments - Returns true if the document has any child documents
    • SolrInputDocument::merge - Fusiona un documento con otro
    • SolrInputDocument::reset - Este es un alias de SolrInputDocument::clear
    • SolrInputDocument::setBoost - Establece el valor boost de este documento
    • SolrInputDocument::setFieldBoost - Establece el valor boost de tiempo del índice de un campo
    • SolrInputDocument::sort - Ordena los campos dentro de un documento
    • SolrInputDocument::toArray - Devuelve una matriz como representación del documento de entrada
    • SolrInputDocument::__clone - Crea una copia de un objeto SolrDocument
    • SolrInputDocument::__construct - Constructor
    • SolrInputDocument::__destruct - Destructor
    • SolrModifiableParams::__construct - Constructor
    • SolrModifiableParams::__destruct - Destructor
    • SolrObject::getPropertyNames - Devuelve una matriz de todos los nombres de las propiedades
    • SolrObject::offsetExists - Comprueba si la propiedad existe
    • SolrObject::offsetGet - Usado para recuperar una propiedad
    • SolrObject::offsetSet - Establece el valor de una propiedad
    • SolrObject::offsetUnset - Desestablece el valor de la propiedad
    • SolrObject::__construct - Crea un objeto Solr
    • SolrObject::__destruct - Destructor
    • SolrParams::add - Esto es un alias de SolrParams::addParam
    • SolrParams::addParam - Añade un parámetro al objeto
    • SolrParams::get - Este es una alias de SolrParams::getParam
    • SolrParams::getParam - Devuelve el valor de un parámetro
    • SolrParams::getParams - Devuelve una matriz de parámetros URL no codificados
    • SolrParams::getPreparedParams - Devuelve una matriz de parámetros URL codificados
    • SolrParams::serialize - Usado para serialización personalizada
    • SolrParams::set - Un alas de SolrParams::setParam
    • SolrParams::setParam - Establece el parámetro al valor especificado
    • SolrParams::toString - Devuelve todos los parámetros de los pares nombre-valor del objeto
    • SolrParams::unserialize - Usado para serialización personalizada
    • SolrPingResponse::getResponse - Devuelve la respuesta del servidor
    • SolrPingResponse::__construct - Constructor
    • SolrPingResponse::__destruct - Destructor
    • SolrQuery::addExpandFilterQuery - Overrides main filter query, determines which documents to include in the main group
    • SolrQuery::addExpandSortField - Orders the documents within the expanded groups (expand.sort parameter)
    • SolrQuery::addFacetDateField - Mapea a facet.date
    • SolrQuery::addFacetDateOther - Añade otro parámetro facet.date.other
    • SolrQuery::addFacetField - Añade otro campo a la faceta
    • SolrQuery::addFacetQuery - Añade una consulta de faceta
    • SolrQuery::addField - Especifica qué campos devolver en el resultado
    • SolrQuery::addFilterQuery - Especifica una consulta de filtro
    • SolrQuery::addGroupField - Add a field to be used to group results
    • SolrQuery::addGroupFunction - Allows grouping results based on the unique values of a function query (group.func parameter)
    • SolrQuery::addGroupQuery - Allows grouping of documents that match the given query
    • SolrQuery::addGroupSortField - Add a group sort field (group.sort parameter)
    • SolrQuery::addHighlightField - Mapea a hl.fl
    • SolrQuery::addMltField - Establece un campo para usarlo para similitud
    • SolrQuery::addMltQueryField - Mapea a mlt.qf
    • SolrQuery::addSortField - Usado para controlar cómo deberían ordenarse los resultados
    • SolrQuery::addStatsFacet - Recupera una devolución de subresultados para valores dentro de la faceta dada
    • SolrQuery::addStatsField - Mapea al parámetro stats.field
    • SolrQuery::collapse - Collapses the result set to a single document per group
    • SolrQuery::getExpand - Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries - Returns the expand filter queries
    • SolrQuery::getExpandQuery - Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows - Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields - Returns an array of fields
    • SolrQuery::getFacet - Devuelve el valor del parámetro facet
    • SolrQuery::getFacetDateEnd - Devuelve el valor del parámetro facet.date.end
    • SolrQuery::getFacetDateFields - Devuelve todos los campos de facet.date
    • SolrQuery::getFacetDateGap - Devuelve el valor del parámetro facet.date.gap
    • SolrQuery::getFacetDateHardEnd - Devuelve el valor del parámetro facet.date.hardend
    • SolrQuery::getFacetDateOther - Devuelve el valor del parámetro facet.date.other
    • SolrQuery::getFacetDateStart - Devuelve el límite inferior del primer rango de datos para todas las facetas de fecha de este campo
    • SolrQuery::getFacetFields - Devuelve todos los campos facet
    • SolrQuery::getFacetLimit - Devuelve el número máximo de restricciones que deberían ser devueltas por los campos facet
    • SolrQuery::getFacetMethod - Devuelve el valor del parámetro facet.method
    • SolrQuery::getFacetMinCount - Devuelve el mínimo de facetas que deberían ser incluidas en la respuesta
    • SolrQuery::getFacetMissing - Devuelve el estado acutual del parámetro facet.missing
    • SolrQuery::getFacetOffset - Devuelve un índice dentro de la lista de restricciones para ser usado en paginación
    • SolrQuery::getFacetPrefix - Devuelve el prefijo de faceta
    • SolrQuery::getFacetQueries - Devuelve todas las consultas de facetas
    • SolrQuery::getFacetSort - Devuelve el tipo de ordenación de la faceta
    • SolrQuery::getFields - Devuelve la lista de campos que serán devueltos en la respuesta
    • SolrQuery::getFilterQueries - Devuelve una matriz de consultas de filtro
    • SolrQuery::getGroup - Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent - Returns group cache percent value
    • SolrQuery::getGroupFacet - Returns the group.facet parameter value
    • SolrQuery::getGroupFields - Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat - Returns the group.format value
    • SolrQuery::getGroupFunctions - Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit - Returns the group.limit value
    • SolrQuery::getGroupMain - Returns the group.main value
    • SolrQuery::getGroupNGroups - Returns the group.ngroups value
    • SolrQuery::getGroupOffset - Returns the group.offset value
    • SolrQuery::getGroupQueries - Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields - Returns the group.sort value
    • SolrQuery::getGroupTruncate - Returns the group.truncate value
    • SolrQuery::getHighlight - Devuelve el estado del parámtero hl
    • SolrQuery::getHighlightAlternateField - Devuelve el campo remarcado para usarlo como copia de seguridad o como predeterminado
    • SolrQuery::getHighlightFields - Devuelve todos los campos que Solr debería generar para remarcación de trozos
    • SolrQuery::getHighlightFormatter - Devuelve el formateador de la salida remarcada
    • SolrQuery::getHighlightFragmenter - Devuelve el generador de trozos de texto para el texto remarcado
    • SolrQuery::getHighlightFragsize - Devuelve el número de caracteres de fragmentos a considerar para remarcación
    • SolrQuery::getHighlightHighlightMultiTerm - Devuelve si habilitar o no la remarcación de consultas range/wildcard/fuzzy/prefix
    • SolrQuery::getHighlightMaxAlternateFieldLength - Devuelve el número máximo de caracteres del campo a devolver
    • SolrQuery::getHighlightMaxAnalyzedChars - Devuelve el número máximo de caracteres de un documento para buscar trozos adecuados
    • SolrQuery::getHighlightMergeContiguous - Devuelve si colapsar o no fragmentos contiguos en un único fragmento
    • SolrQuery::getHighlightRegexMaxAnalyzedChars - Devuelve el número máximo de caracteres de un campo cuando se usa el fragmentador de expresiones regulares
    • SolrQuery::getHighlightRegexPattern - Devuelve la expresión regular para la fragmentación
    • SolrQuery::getHighlightRegexSlop - Devuelve el factor de desviación del tamaño de fragmento ideal
    • SolrQuery::getHighlightRequireFieldMatch - Devuelve si un campo será remarcado solamente si la consulta coincide con este campo en particular
    • SolrQuery::getHighlightSimplePost - Devuelve el texto que aparece después de un término remarcado
    • SolrQuery::getHighlightSimplePre - Devuelve el texto que aparece antes de un término remarcado
    • SolrQuery::getHighlightSnippets - Devuelve el número máximo de trozos remarcados a generar por campo
    • SolrQuery::getHighlightUsePhraseHighlighter - Devuelve el estado del parámetro hl.usePhraseHighlighter
    • SolrQuery::getMlt - Devuelve si los resultados MoreLikeThis deberían o no ser habilitados
    • SolrQuery::getMltBoost - Devuelve si la consulta será impulsada (boost) o no mediante la relevancia del térmido de interés
    • SolrQuery::getMltCount - Devuelve el número de documentos similares a devolver para cada resultado
    • SolrQuery::getMltFields - Devuelve todos los campos a usar para similitud
    • SolrQuery::getMltMaxNumQueryTerms - Devuelve el número máximo de términos de consultas que serán incluidos en cualquier consulta generada
    • SolrQuery::getMltMaxNumTokens - Devuelve el número máximo de tokens a analizar en cada campo del documento que no esté almacenado con soporte TermVector
    • SolrQuery::getMltMaxWordLength - Devuelve la longitud máxima de palabra de las palabras que serán ignoradas
    • SolrQuery::getMltMinDocFrequency - Devuelve el umbral de frecuencia en el que las palabras que no ocurran en por lo menos tantos documentos como este serán ignoradas
    • SolrQuery::getMltMinTermFrequency - Devuelve la frecuencia bajo la cual los términos serán ignorados en el documento fuente
    • SolrQuery::getMltMinWordLength - Devuelve la longitud máxima de palabra bajo la cual las palabras serán ignoradas
    • SolrQuery::getMltQueryFields - Devuelve los campos de consultas y sus boosts
    • SolrQuery::getQuery - Devuelve la consulta principal
    • SolrQuery::getRows - Devuelve el número máximo de documentos
    • SolrQuery::getSortFields - Devuelve todos los campos de ordenación
    • SolrQuery::getStart - Devuelve el índice del conjunto de resultados completo
    • SolrQuery::getStats - Devuelve si están habilitadas o no las estadísticas
    • SolrQuery::getStatsFacets - Devuelve todas las estadísticas de las facetas que fueron establecidas
    • SolrQuery::getStatsFields - Devuelve todas las estadísticas de los campos
    • SolrQuery::getTerms - Devuelve si está habilitado o no TermsComponent
    • SolrQuery::getTermsField - Devuelve el campo desde el cuál los términos son recuperados
    • SolrQuery::getTermsIncludeLowerBound - Devuelve si incluir o no el límite inferior en el conjunto de resultados
    • SolrQuery::getTermsIncludeUpperBound - Devuelve si incluir o no el término de límite superior en el conjunto de resultados
    • SolrQuery::getTermsLimit - Devuelve el número máximo de términos que debería devolver Solr
    • SolrQuery::getTermsLowerBound - Devuelve el término en el que comenzar
    • SolrQuery::getTermsMaxCount - Devuelve la frecuencia de documento máxima
    • SolrQuery::getTermsMinCount - Devuelve la frecuencia de documento mínima a devolver para ser incluido
    • SolrQuery::getTermsPrefix - Devuelve el prefijo del término
    • SolrQuery::getTermsReturnRaw - Si devolver o no caracteres en bruto
    • SolrQuery::getTermsSort - Devuelve un entero indicando cómo son ordenados los términos
    • SolrQuery::getTermsUpperBound - Devuelve el término en donde parar
    • SolrQuery::getTimeAllowed - Devuelve el tiempo en milisegundos permitido para que la consulta finalice
    • SolrQuery::removeExpandFilterQuery - Removes an expand filter query
    • SolrQuery::removeExpandSortField - Removes an expand sort field from the expand.sort parameter
    • SolrQuery::removeFacetDateField - Elimina uno de los campos de faceta de fecha
    • SolrQuery::removeFacetDateOther - Elimina uno de los parámetros facet.date.other
    • SolrQuery::removeFacetField - Elimina uno de los parámetros facet.date
    • SolrQuery::removeFacetQuery - Elimina uno de los parámetros facet.query
    • SolrQuery::removeField - Elimina un campo de la lista de campos
    • SolrQuery::removeFilterQuery - Elimina una consulta de filtro
    • SolrQuery::removeHighlightField - Elimina uno de los campos usados para remarcación
    • SolrQuery::removeMltField - Elimina uno de los campos moreLikeThis
    • SolrQuery::removeMltQueryField - Elimina uno de los campos de consulta moreLikeThis
    • SolrQuery::removeSortField - Elimina uno de los campos de ordenación
    • SolrQuery::removeStatsFacet - Elimina uno de los parámetros stats.facet
    • SolrQuery::removeStatsField - Elimina uno de los parámetros stats.field
    • SolrQuery::setEchoHandler - Conmuta el parámetro echoHandler
    • SolrQuery::setEchoParams - Determina qué tipo de parámetros incluir en la respuesta
    • SolrQuery::setExpand - Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery - Sets the expand.q parameter
    • SolrQuery::setExpandRows - Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther - Establece el parámetro de consulta común explainOther
    • SolrQuery::setFacet - Mapea al parámetro facet. Habilita o deshabilta las facetas
    • SolrQuery::setFacetDateEnd - Mapea a facet.date.end
    • SolrQuery::setFacetDateGap - Mapea a facet.date.gap
    • SolrQuery::setFacetDateHardEnd - Mapea a facet.date.hardend
    • SolrQuery::setFacetDateStart - Mapea a facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency - Establece la frecuencia de documento mínima usada para determinar la cuenta de términos
    • SolrQuery::setFacetLimit - Mapea a facet.limit
    • SolrQuery::setFacetMethod - Especifica el tipo de algoritmo a usar cuando se hace una faceta a un campo
    • SolrQuery::setFacetMinCount - Mapea a facet.mincount
    • SolrQuery::setFacetMissing - Mapea a facet.missing
    • SolrQuery::setFacetOffset - Establece el índice de la lista de restricciones para tener en cuenta la paginación
    • SolrQuery::setFacetPrefix - Especifica un prefijo de cadena con el que limitar los términos a los que hacer una faceta
    • SolrQuery::setFacetSort - Determina el orden de las restricciones de campos de faceta
    • SolrQuery::setGroup - Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent - Enables caching for result grouping
    • SolrQuery::setGroupFacet - Sets group.facet parameter
    • SolrQuery::setGroupFormat - Sets the group format, result structure (group.format parameter)
    • SolrQuery::setGroupLimit - Specifies the number of results to return for each group. The server default value is 1
    • SolrQuery::setGroupMain - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
    • SolrQuery::setGroupNGroups - If true, Solr includes the number of groups that have matched the query in the results
    • SolrQuery::setGroupOffset - Sets the group.offset parameter
    • SolrQuery::setGroupTruncate - If true, facet counts are based on the most relevant document of each group matching the query
    • SolrQuery::setHighlight - Habilita o deshabilita la remarcación
    • SolrQuery::setHighlightAlternateField - Especifica el campo de copia de seguridad a usar
    • SolrQuery::setHighlightFormatter - Especifica un formateador para la salida remarcada
    • SolrQuery::setHighlightFragmenter - Establece el generador de trozos de código para texto remarcado
    • SolrQuery::setHighlightFragsize - El tamaño de los fragmentos a considerara para remarcación
    • SolrQuery::setHighlightHighlightMultiTerm - Usa SpanScorer para remarcar términos de frases
    • SolrQuery::setHighlightMaxAlternateFieldLength - Establece el número máximo de caracteres del campo a devolver
    • SolrQuery::setHighlightMaxAnalyzedChars - Especifica el número de caracteres de un documento para buscar trozos apropiados
    • SolrQuery::setHighlightMergeContiguous - Si colapsar o no fragmentos contiguos en un único fragmento
    • SolrQuery::setHighlightRegexMaxAnalyzedChars - Especifica el número máximo de caracteres a analizar
    • SolrQuery::setHighlightRegexPattern - Especifica la expresión regular para la fragmentación
    • SolrQuery::setHighlightRegexSlop - Establece el factor por el cual el fragmentador de expresiones regulares puede desviarse del tamaño de fragmento ideal
    • SolrQuery::setHighlightRequireFieldMatch - Requerir la coincicencia de campos durante el remarcado
    • SolrQuery::setHighlightSimplePost - Establece el texto que aparece antes de un término remarcado
    • SolrQuery::setHighlightSimplePre - Establece el texto que aparece antes de un término remarcado
    • SolrQuery::setHighlightSnippets - Establece el número máximo de trozos remarcados para generar por campo
    • SolrQuery::setHighlightUsePhraseHighlighter - Si remarcar o no términos de frases sólo cuando aparecen en la frase de consulta
    • SolrQuery::setMlt - Habilita o deshabilita moreLikeThis
    • SolrQuery::setMltBoost - Establecer si la consulta será impulsada (boost) por la relevancia del término de interés
    • SolrQuery::setMltCount - Establece el número de documentos similares a devolver en cada resultado
    • SolrQuery::setMltMaxNumQueryTerms - Establece el número máximo de términos de consulta incluidos
    • SolrQuery::setMltMaxNumTokens - Especifica el número máximo de tokens a analizar
    • SolrQuery::setMltMaxWordLength - Establece la longitud de palabra máxima
    • SolrQuery::setMltMinDocFrequency - Establece la frecuencia de mltMinDoc
    • SolrQuery::setMltMinTermFrequency - Establece la frecuencia bajo la cual los términos serán ignorados en los documentos fuente
    • SolrQuery::setMltMinWordLength - Establece la longitud de palabra mínima
    • SolrQuery::setOmitHeader - Excluye la cabecera de los resultados devueltos
    • SolrQuery::setQuery - Establece la consulta de búsqueda
    • SolrQuery::setRows - Especifica el número máximo de filas a devolver en el resultado
    • SolrQuery::setShowDebugInfo - Bandera para mostrar información de depuración
    • SolrQuery::setStart - Especifica el número de filas que se van a saltar
    • SolrQuery::setStats - Habilita o deshablita el componente de estadísticas
    • SolrQuery::setTerms - Habilita o deshablita TermsComponent
    • SolrQuery::setTermsField - Establece el nombre del campo del que obtener los términos
    • SolrQuery::setTermsIncludeLowerBound - Incluir el término de límite inferior en el conjunto de resultados
    • SolrQuery::setTermsIncludeUpperBound - Incluir el término de límite superior en el conjunto de resultados
    • SolrQuery::setTermsLimit - Establece el número máximo de términos a devolver
    • SolrQuery::setTermsLowerBound - Especifica el término de donde empezar
    • SolrQuery::setTermsMaxCount - Establece la frecuencia máxima de documentos
    • SolrQuery::setTermsMinCount - Establece la frecuencia mínima de documentos
    • SolrQuery::setTermsPrefix - Restringe las coincidencias de términos que comienzan con el prefijo
    • SolrQuery::setTermsReturnRaw - Devuelve los caracteres en bruto del término indexado
    • SolrQuery::setTermsSort - Especifica cómo ordenar los términos devueltos
    • SolrQuery::setTermsUpperBound - Establece el término en el que parar
    • SolrQuery::setTimeAllowed - El tiempo permitido para que la búsqueda finalice
    • SolrQuery::__construct - Constructor
    • SolrQuery::__destruct - Destructor
    • SolrQueryResponse::__construct - Constructor
    • SolrQueryResponse::__destruct - Destructor
    • SolrResponse::getDigestedResponse - Devuelve la respueste XML como información de PHP serializada
    • SolrResponse::getHttpStatus - Devuelve el estado HTTP de la respuesta
    • SolrResponse::getHttpStatusMessage - Devuelve más detalles del estado HTTP
    • SolrResponse::getRawRequest - Devuelve la respuesta en bruto enviada al servidor Solr
    • SolrResponse::getRawRequestHeaders - Devuelve las cabeceras de respuesta sin tratar enviadas al servidor Solr
    • SolrResponse::getRawResponse - Devuelve la respuesta sin tratar del servidor
    • SolrResponse::getRawResponseHeaders - Devuelve las cabeceras de respuesta sin tratar del servidor
    • SolrResponse::getRequestUrl - Devuelve la URL completa a la que se envió la respuesta
    • SolrResponse::getResponse - Devuelve un objeto SolrObject que representa la respuesta XML del servidor
    • SolrResponse::setParseMode - Establece el modo de análisis
    • SolrResponse::success - ¿Tuvo éxito la petición?
    • SolrServerException::getInternalInfo - Devuelve información interna de dónde fue lanzada la excepción
    • SolrUpdateResponse::__construct - Constructor
    • SolrUpdateResponse::__destruct - Destructor
    • SolrUtils::digestXmlResponse - Convierte una cadena de respuesta XML a un objeto SolrObject
    • SolrUtils::escapeQueryChars - Escapa un string de consulta lucene
    • SolrUtils::getSolrVersion - Devuelve la versión actual de la extensión Solr
    • SolrUtils::queryPhrase - Prepara una frase desde una cadena lucene sin escapar
    • solr_get_version - Devuelve la versión actual de la extensión Apache Solr
    • sort - Ordena un array
    • soundex - Calcula la clave soundex de un string
    • SphinxClient::addQuery - Add query to multi-query batch
    • SphinxClient::buildExcerpts - Build text snippets
    • SphinxClient::buildKeywords - Extraer las palabras clave de una consulta
    • SphinxClient::close - Cierra conexión persistente previamente abierta
    • SphinxClient::escapeString - Escapa caracteres especiales
    • SphinxClient::getLastError - Obtener el último mensaje de error
    • SphinxClient::getLastWarning - Obtener la última advertencia
    • SphinxClient::open - Abre una conexión persistente con el servidor
    • SphinxClient::query - Execute search query
    • SphinxClient::resetFilters - Clear all filters
    • SphinxClient::resetGroupBy - Clear all group-by settings
    • SphinxClient::runQueries - Ejecutar un lote de consultas de búsqueda
    • SphinxClient::setArrayResult - Change the format of result set array
    • SphinxClient::setConnectTimeout - Establecer el tiempo de conexión
    • SphinxClient::setFieldWeights - Set field weights
    • SphinxClient::setFilter - Add new integer values set filter
    • SphinxClient::setFilterFloatRange - Add new float range filter
    • SphinxClient::setFilterRange - Add new integer range filter
    • SphinxClient::setGeoAnchor - Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy - Set grouping attribute
    • SphinxClient::setGroupDistinct - Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange - Set a range of accepted document IDs
    • SphinxClient::setIndexWeights - Set per-index weights
    • SphinxClient::setLimits - Set offset and limit of the result set
    • SphinxClient::setMatchMode - Set full-text query matching mode
    • SphinxClient::setMaxQueryTime - Establecer el tiempo máximo de consulta
    • SphinxClient::setOverride - Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode - Set ranking mode
    • SphinxClient::setRetries - Set retry count and delay
    • SphinxClient::setSelect - Set select clause
    • SphinxClient::setServer - Set searchd host and port
    • SphinxClient::setSortMode - Set matches sorting mode
    • SphinxClient::status - Queries searchd status
    • SphinxClient::updateAttributes - Actualiza los atributos del documento
    • SphinxClient::__construct - Crea un nuevo objeto SphinxClient
    • SplDoublyLinkedList::add - Añadir/insertar un nuevo valor en el índice especificado
    • SplDoublyLinkedList::bottom - Examinar el nodo del comienzo de la lista doblemente enlazada
    • SplDoublyLinkedList::count - Cuenta el número de elementos de la lista doblemente enlazada
    • SplDoublyLinkedList::current - Devuelve la entrada actual del array
    • SplDoublyLinkedList::getIteratorMode - Devuelve el modo de iteración
    • SplDoublyLinkedList::isEmpty - Comprueba si la lista doblemente enlazada está vacía
    • SplDoublyLinkedList::key - Devuelve el índice del nodo actual
    • SplDoublyLinkedList::next - Avanza a la siguiente entrada
    • SplDoublyLinkedList::offsetExists - Devuelve si el índice solicitado existe
    • SplDoublyLinkedList::offsetGet - Devuelve el valor del índice específicado
    • SplDoublyLinkedList::offsetSet - Establece el valor del índice específicado
    • SplDoublyLinkedList::offsetUnset - Borra el valor de el índice específicado
    • SplDoublyLinkedList::pop - Extrae un nodo del final de la lista doblementa enlazada
    • SplDoublyLinkedList::prev - Retrocede a la entrada anterior
    • SplDoublyLinkedList::push - Inserta un elemento al final de la lista doblemente enlazada
    • SplDoublyLinkedList::rewind - Rebobina el iterador hasta el inicio
    • SplDoublyLinkedList::serialize - Serializa el almacenamiento
    • SplDoublyLinkedList::setIteratorMode - Establece el modo de iteración
    • SplDoublyLinkedList::shift - Quita un nodo del inicio de la lista doblemente enlazada
    • SplDoublyLinkedList::top - Examina el nodo del final de la lista doblemente enlazada
    • SplDoublyLinkedList::unserialize - Deserializa el almacenamiento
    • SplDoublyLinkedList::unshift - Antepone un elemento a la lista doblemente enlazada
    • SplDoublyLinkedList::valid - Comprueba si la lista doblemente enlazada contiene más nodos
    • SplDoublyLinkedList::__construct - Construye una nueva lista doblemente enlazada
    • SplFileInfo::getATime - Obtiene la hora del último acceso al fichero
    • SplFileInfo::getBasename - Obtiene el nombre base del fichero
    • SplFileInfo::getCTime - Obtiene el i-nodo de el cambio de tiempo
    • SplFileInfo::getExtension - Obtiene la extensión del fichero
    • SplFileInfo::getFileInfo - Obtiene un objeto SplFileInfo para el fichero
    • SplFileInfo::getFilename - Obtiene el nombre del fichero
    • SplFileInfo::getGroup - Obtiene el grupo de el fichero
    • SplFileInfo::getInode - Obtiene el i-nodo de el fichero
    • SplFileInfo::getLinkTarget - Obtiene el destino de un enlace del sistema de ficheros
    • SplFileInfo::getMTime - Obtiene la fecha de la última modificación
    • SplFileInfo::getOwner - Obtiene el dueño de el fichero
    • SplFileInfo::getPath - Obtiene la ruta sin el nombre de fichero
    • SplFileInfo::getPathInfo - Obtiene un objeto SplFileInfo para la ruta
    • SplFileInfo::getPathname - Obtiene la ruta de un fichero
    • SplFileInfo::getPerms - Obtiene los permisos del fichero
    • SplFileInfo::getRealPath - Obtiene la ruta absoluta al fichero
    • SplFileInfo::getSize - Obtiene el tamaño de el fichero
    • SplFileInfo::getType - Obtiene el tipo del fichero
    • SplFileInfo::isDir - Dice si el fichero es un directorio
    • SplFileInfo::isExecutable - Comprueba si el fichero es ejecutable
    • SplFileInfo::isFile - Dice is el objeto hace referencia a un fichero normal
    • SplFileInfo::isLink - Comprueba si el fichero es un link
    • SplFileInfo::isReadable - Comprueba si el fichero se puede leer
    • SplFileInfo::isWritable - Comprueba si se puede escribir en el fichero
    • SplFileInfo::openFile - Obtiene un objeto SplFileObject para el fichero
    • SplFileInfo::setFileClass - Establece la clase empleada con SplFileInfo::openFile
    • SplFileInfo::setInfoClass - Establece la clase empleada con SplFileInfo::getFileInfo y SplFileInfo::getPathInfo
    • SplFileInfo::__construct - Construir un objeto nuevo SplFileInfo
    • SplFileInfo::__toString - Devuelve la ruta de el fichero como un string
    • SplFileObject::current - Recupera la línea actual del fichero
    • SplFileObject::eof - Comprueba si es el final del fichero
    • SplFileObject::fflush - Vuelca el resultado en el fichero
    • SplFileObject::fgetc - Obtiene un caracter del fichero
    • SplFileObject::fgetcsv - Obtiene la línea del archivo y analiza como campos CSV
    • SplFileObject::fgets - Obtener la línea de el fichero
    • SplFileObject::fgetss - Obtiene la línea de el fichero y elimina etiquetas HTML
    • SplFileObject::flock - Bloqueo de ficheros portable
    • SplFileObject::fpassthru - Imprimir todos los datos restantes en un apuntador de fichero
    • SplFileObject::fputcsv - Escribir un array de campos como una línea CSV
    • SplFileObject::fread - Leer un fichero
    • SplFileObject::fscanf - Analiza la entrada de un fichero de acuerdo a un formato
    • SplFileObject::fseek - Busca una posiciónn
    • SplFileObject::fstat - Obtiene información de el fichero
    • SplFileObject::ftell - Devuelve la posición del fichero actual
    • SplFileObject::ftruncate - Trunca el archivo a una longitud dada
    • SplFileObject::fwrite - Escribe en el fichero
    • SplFileObject::getChildren - Ningún propósito
    • SplFileObject::getCsvControl - Obtiene el carácter delimitador, el circundante y de escape para campos CSV
    • SplFileObject::getCurrentLine - Alias de SplFileObject::fgets
    • SplFileObject::getFlags - Obtener las flags de SplFileObject
    • SplFileObject::getMaxLineLen - Obtener la longitud máxima de línea
    • SplFileObject::hasChildren - SplFileObject no tiene hijos
    • SplFileObject::key - Obtiene el número de línea
    • SplFileObject::next - Leer la siguiente línea
    • SplFileObject::rewind - Rebobina el fichero hasta la primera línea
    • SplFileObject::seek - Mueve el apuntador interno a la línea específicada
    • SplFileObject::setCsvControl - Establece el carácter delimitador, el circundante y el de escape para campos CSV
    • SplFileObject::setFlags - Establece flags para el SplFileObject
    • SplFileObject::setMaxLineLen - Establecer la longitud máxima de una línea
    • SplFileObject::valid - Comprueba si el final del finchero ha sido alcanzado
    • SplFileObject::__construct - Construye un nuevo objeto de fichero
    • SplFileObject::__toString - Alias de SplFileObject::fgets
    • SplFixedArray::count - Devuelve el tamaño del array
    • SplFixedArray::current - Devuelve la entrada del array actual
    • SplFixedArray::fromArray - Importa un array PHP en una instancia SplFixedArray
    • SplFixedArray::getSize - Obtiene el tamaño de el array
    • SplFixedArray::key - Devuelve los índices del array actual
    • SplFixedArray::next - Mover a la siguiente entrada
    • SplFixedArray::offsetExists - Devuelve si el índice solicitado existe
    • SplFixedArray::offsetGet - Devuelve el valor en el índice específicado
    • SplFixedArray::offsetSet - Establece un nuevo valor para el índice específicado
    • SplFixedArray::offsetUnset - Destruye el valor en el índice específicado
    • SplFixedArray::rewind - Rebobina el iterador hasta el inicio
    • SplFixedArray::setSize - Cambiar el tamaño de un array
    • SplFixedArray::toArray - Devuelve un array PHP de un array fijo
    • SplFixedArray::valid - Comprueba si el array contiene más elementos
    • SplFixedArray::__construct - Construye un nuevo array fijo
    • SplFixedArray::__wakeup - Reinicializar el array después de ser deserializado
    • SplHeap::compare - Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba
    • SplHeap::count - Cuenta el número de elementos en el montón
    • SplHeap::current - Devuelve el nodo actual señalado por el iterador
    • SplHeap::extract - Extrae un nodo de la parte superior del montón
    • SplHeap::insert - Inserta un elemento en el montón
    • SplHeap::isCorrupted - Tells if the heap is in a corrupted state
    • SplHeap::isEmpty - Comprueba si el montón actual está vacío
    • SplHeap::key - Devuelve el índice de el nodo actual
    • SplHeap::next - Avanzar al siguiente nodo
    • SplHeap::recoverFromCorruption - Recuperarse de un estado dañado y permitir un mayor número de acciones en el montón
    • SplHeap::rewind - Rebobina el iterador al comienzo
    • SplHeap::top - Observar el nodo desde el comienzo del montón
    • SplHeap::valid - Comprueba si el montón contiene más nodos
    • SplHeap::__construct - Construye un nuevo heap vacío
    • split - Divide una cadena en una matriz mediante una expresión regular
    • spliti - Divide una cadena en una matriz mediante una expresión regular insensible a mayúsculas-minúsculas
    • SplMaxHeap::compare - Compara elementos con el fin de colocarlos correctamente en el montón en la parte de arriba
    • SplMinHeap::compare - Comparar elementos con el fin de colocarlos correctamente en el montón em la parte de arriba
    • SplObjectStorage::addAll - Agrega todos los objetos de otro almacenamiento
    • SplObjectStorage::attach - Agrega un objeto en el almacenamiento
    • SplObjectStorage::contains - Comprueba si el almacenamiento contiene un objeto específico
    • SplObjectStorage::count - Devuelve el número de objetos en el almacenamiento
    • SplObjectStorage::current - Devuelve la entrada actual de almacenamiento
    • SplObjectStorage::detach - Quita un object de el almacenamiento
    • SplObjectStorage::getHash - Calcular un identificador único (hash) para los objetos contenidos
    • SplObjectStorage::getInfo - Devuelve los datos asociados con la entrada del iterador actual
    • SplObjectStorage::key - Devuelve el índice en el que se encuentra el iterador actualmente
    • SplObjectStorage::next - Mover a la siguiente entrada
    • SplObjectStorage::offsetExists - Comprueba si un objeto existe en el almacenamiento
    • SplObjectStorage::offsetGet - Devuelve los datos asociados con un object
    • SplObjectStorage::offsetSet - Asocia datos a un objeto en el almacenamiento
    • SplObjectStorage::offsetUnset - Quita un objeto de el almacenamiento
    • SplObjectStorage::removeAll - Remover objetos contenidos en otro almacenamiento de el almacenamiento actual
    • SplObjectStorage::removeAllExcept - Remover objetos excepto los contenidos en otro almacenamiento del almacenamiento actual
    • SplObjectStorage::rewind - Rebobina el iterador a el primer elemento de el almacenamiento
    • SplObjectStorage::serialize - Serializa el almacenamiento
    • SplObjectStorage::setInfo - Establece los datos asociados con el iterador de la entrada actual
    • SplObjectStorage::unserialize - Deserializa un almacenamiento desde su representación string
    • SplObjectStorage::valid - Comprobar si la entrada actual del iterador es válida
    • SplObserver::update - Recibe actualizaciones de sujeto
    • SplPriorityQueue::compare - Comparar las prioridades con el fin de colocar los elementos correctamente en el montón, mientras que tamizar arriba
    • SplPriorityQueue::count - Cuenta el número de elementos en la cola
    • SplPriorityQueue::current - Volver nodo actual que apunta el iterador
    • SplPriorityQueue::extract - Extrae un nodo de la parte superior del montículo y desplaza hacia arriba
    • SplPriorityQueue::getExtractFlags - Get the flags of extraction
    • SplPriorityQueue::insert - Inserta un elemento en la cola en la parte de arriba
    • SplPriorityQueue::isCorrupted - Tells if the priority queue is in a corrupted state
    • SplPriorityQueue::isEmpty - Comprueba si la cola está vacía
    • SplPriorityQueue::key - Devuelve el índice del nodo actual
    • SplPriorityQueue::next - Pasar a la siguiente nodo
    • SplPriorityQueue::recoverFromCorruption - Recuperar desde la condición corrupta y permitir acciones más en la cola
    • SplPriorityQueue::rewind - Rebobinar iterador de vuelta al inicio (no-op)
    • SplPriorityQueue::setExtractFlags - Establece el modo de extracción
    • SplPriorityQueue::top - Mira en el nodo de la parte superior de la cola
    • SplPriorityQueue::valid - Comprobar si la cola contiene más nodos
    • SplPriorityQueue::__construct - Construye una nueva cola vacía
    • SplQueue::dequeue - Quita un nodo de la cola
    • SplQueue::enqueue - Añade un elemento a la cola
    • SplQueue::setIteratorMode - Establece el modo de iteración
    • SplQueue::__construct - Construye una nueva cola implementada usando una lista doblemente enlazada
    • SplStack::setIteratorMode - Establece el modo de iteración
    • SplStack::__construct - Construye una nueva pila implementada mediante una lista doblemente enlazada
    • SplSubject::attach - Adjuntar un SplObserver
    • SplSubject::detach - Separa un observador
    • SplSubject::notify - Notificar un observador
    • SplTempFileObject::__construct - Construir un nuevo objeto de fichero temporal
    • spl_autoload - Implementación predeterminada para __autoload()
    • spl_autoload_call - Probar todos las funciones registradas __autoload() para cargar la clase solicitada
    • spl_autoload_extensions - Registrar y devolver las extensiones de ficheros predeterminadas para spl_autoload
    • spl_autoload_functions - Devolver todas las funciones __autoload() registradas
    • spl_autoload_register - Registrar las funciones dadas como implementación de __autoload()
    • spl_autoload_unregister - Desregistrar una función dada como implementación de __autoload()
    • spl_classes - Devuelve las clases SPL disponibles
    • spl_object_hash - Devuelve el id del hash del objeto dado
    • spl_object_id - Return the integer object handle for given object
    • Spoofchecker::areConfusable - Comprobar si un texto dado contiene carateres que pueden ser confusos
    • Spoofchecker::isSuspicious - Comprobar si un texto dad contiene caracteres sospechosos
    • Spoofchecker::setAllowedLocales - Las configuraciones regionales a usar cuando se ejecutan las comprobaciones
    • Spoofchecker::setChecks - Establecer las comprobaciones a ejecutar
    • Spoofchecker::__construct - Constructor
    • sprintf - Devuelve un string formateado
    • SQLite3::backup - Backup one database to another database
    • SQLite3::busyTimeout - Establecer el gestor de conexión ocupado
    • SQLite3::changes - Devolver el número de filas de la base de datos que fueron cambiadas (o insertadas, o eliminadas) por la sentencia SQL más reciente
    • SQLite3::close - Cerrar la conexión a la base de datos
    • SQLite3::createAggregate - Registrar una función de PHP para usarla como una función totalizadora de SQL
    • SQLite3::createCollation - Registra una función PHP para ser utilizada como una función SQL de ordenación específica
    • SQLite3::createFunction - Registrar una función de PHP para usarla como una función escalar de SQL
    • SQLite3::enableExceptions - Enable throwing exceptions
    • SQLite3::escapeString - Devolver una cadena que ha sido debidamente escapada
    • SQLite3::exec - Ejecutar una consulta que no devuelve resultados en una base de datos dada
    • SQLite3::lastErrorCode - Devolver el código numérico del resultado de la petición SQLite que falló más recientemente
    • SQLite3::lastErrorMsg - Devolver texto en inglés describiendo la petición SQLite que falló más recientemente
    • SQLite3::lastInsertRowID - Devolver el ID de la fila de la sentencia INSERT más reciente realizada en la base de datos
    • SQLite3::loadExtension - Intentar cargar una biblioteca de extensiones de SQLite
    • SQLite3::open - Abrir una base de datos SQLite
    • SQLite3::openBlob - Opens a stream resource to read a BLOB
    • SQLite3::prepare - Preparar una sentencia SQL para su ejecución
    • SQLite3::query - Ejecutar una consulta SQL
    • SQLite3::querySingle - Ejecutar una consulta y devolver un único resultado
    • SQLite3::setAuthorizer - Configures a callback to be used as an authorizer to limit what a statement can do
    • SQLite3::version - Devolver la versión de la biblioteca SQLite3 como una constante de cadena y como un número
    • SQLite3::__construct - Instanciar un objeto de la clase SQLite3 y abrir una base de datos de SQLite 3
    • SQLite3Result::columnName - Devolver el nombre de la columna n-ésima
    • SQLite3Result::columnType - Devolver el tipo de la columna n-ésima
    • SQLite3Result::fetchArray - Obtener una fila de resultados en forma de un array asociativo o indexado o ambos
    • SQLite3Result::finalize - Cerrar el conjunto de resultados
    • SQLite3Result::numColumns - Devolver el número de columnas del conjunto de resultados
    • SQLite3Result::reset - Reiniciar el conjunto de resultados a la primera fila
    • SQLite3Stmt::bindParam - Vincular un parámetro a una variable de sentencia
    • SQLite3Stmt::bindValue - Vincular el valor de un parámetro a una variable de sentencia
    • SQLite3Stmt::clear - Limpiar todos los parámetros vinculados actuales
    • SQLite3Stmt::close - Cerrar una sentencia preparada
    • SQLite3Stmt::execute - Ejecutar una sentencia preparada y devuolver un objeto de conjunto de resultados
    • SQLite3Stmt::getSQL - Get the SQL of the statement
    • SQLite3Stmt::paramCount - Devolver el número de parámetros dentro de la sentencia preparada
    • SQLite3Stmt::readOnly - Returns whether a statement is definitely read only
    • SQLite3Stmt::reset - Reiniciar la sentencia preparada
    • sqlsrv_begin_transaction - Inicia una transacción de base de datos
    • sqlsrv_cancel - Cancela una sentencia de base de datos
    • sqlsrv_client_info - Devuelve información sobre el cliente y la conexión especificada
    • sqlsrv_close - Cierra una conexión abierta y libera los recursos asociados a la conexión
    • sqlsrv_commit - Consolida una transacción que se inició con sqlsrv_begin_transaction
    • sqlsrv_configure - Cambia la configuración de los drivers del gestionador de errores y de log
    • sqlsrv_connect - Abre una conexión a una base de datos Microsoft SQL Server
    • sqlsrv_errors - Devuelve información de errores y alertas (warnings) de la última operación SQLSRV realizada
    • sqlsrv_execute - Ejecuta una sentencia preparada con sqlsrv_prepare
    • sqlsrv_fetch - Hace que esté disponible para ser leída la siguiente fila del conjunto de resultado
    • sqlsrv_fetch_array - Devuelve una fila como un array
    • sqlsrv_fetch_object - Devuelve la siguiente fila de datos de un conjunto resultado como un objeto
    • sqlsrv_field_metadata - Obtiene la metadata de los campos de una consulta preparada por sqlsrv_prepare o sqlsrv_query
    • sqlsrv_free_stmt - Frees all resources for the specified statement
    • sqlsrv_get_config - Returns the value of the specified configuration setting
    • sqlsrv_get_field - Gets field data from the currently selected row
    • sqlsrv_has_rows - Indicates whether the specified statement has rows
    • sqlsrv_next_result - Makes the next result of the specified statement active
    • sqlsrv_num_fields - Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows - Retrieves the number of rows in a result set
    • sqlsrv_prepare - Prepares a query for execution
    • sqlsrv_query - Prepares and executes a query
    • sqlsrv_rollback - Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data - Sends data from parameter streams to the server
    • sqlsrv_server_info - Returns information about the server
    • sql_regcase - Produce una expresión regular para la comparación insensible a mayúscuas-minúsculas
    • sqrt - Raíz cuadrada
    • srand - Genera un número aleatorio a partir de una semilla
    • sscanf - Interpreta un string de entrada de acuerdo con un formato
    • ssdeep_fuzzy_compare - Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash - Create a fuzzy hash from a string
    • ssdeep_fuzzy_hash_filename - Create a fuzzy hash from a file
    • ssh2:// - Secure Shell 2
    • ssh2_auth_agent - Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file - Authenticate using a public hostkey
    • ssh2_auth_none - Authenticate as "none"
    • ssh2_auth_password - Authenticate over SSH using a plain password
    • ssh2_auth_pubkey_file - Authenticate using a public key
    • ssh2_connect - Conecta a un servidor SSH
    • ssh2_disconnect - Close a connection to a remote SSH server
    • ssh2_exec - Execute a command on a remote server
    • ssh2_fetch_stream - Fetch an extended data stream
    • ssh2_fingerprint - Retrieve fingerprint of remote server
    • ssh2_forward_accept - Accept a connection created by a listener
    • ssh2_forward_listen - Bind a port on the remote server and listen for connections
    • ssh2_methods_negotiated - Return list of negotiated methods
    • ssh2_poll - Poll the channels/listeners/streams for events
    • ssh2_publickey_add - Add an authorized publickey
    • ssh2_publickey_init - Initialize Publickey subsystem
    • ssh2_publickey_list - List currently authorized publickeys
    • ssh2_publickey_remove - Remove an authorized publickey
    • ssh2_scp_recv - Solicita un fichero mediante SCP
    • ssh2_scp_send - Envía un fichero mediante SCP
    • ssh2_sftp - Inicializar el subsistema SFTP
    • ssh2_sftp_chmod - Changes file mode
    • ssh2_sftp_lstat - Stat a symbolic link
    • ssh2_sftp_mkdir - Create a directory
    • ssh2_sftp_readlink - Return the target of a symbolic link
    • ssh2_sftp_realpath - Resolve the realpath of a provided path string
    • ssh2_sftp_rename - Rename a remote file
    • ssh2_sftp_rmdir - Remove a directory
    • ssh2_sftp_stat - Stat a file on a remote filesystem
    • ssh2_sftp_symlink - Create a symlink
    • ssh2_sftp_unlink - Delete a file
    • ssh2_shell - Request an interactive shell
    • ssh2_tunnel - Open a tunnel through a remote server
    • stat - Da información acerca de un fichero
    • stats_absolute_deviation - Devuelve la desviación media de una matriz de valores
    • stats_cdf_beta - Calcula un parámetro de la distribución beta según los valores dados a los otros
    • stats_cdf_binomial - Calcula un parámetro de la distribución binomial según los valores dados a los otros
    • stats_cdf_cauchy - No documentada
    • stats_cdf_chisquare - Calcula un parámetro de la distribución ji-cuadrado según los valores dados a los otros
    • stats_cdf_exponential - No documentada
    • stats_cdf_f - Calcula un parámetro de la distribución F según los valores dados a los otros
    • stats_cdf_gamma - Calcula un parámetro de la distribución gamma según los valores dados a los otros
    • stats_cdf_laplace - No documentada
    • stats_cdf_logistic - No documentada
    • stats_cdf_negative_binomial - Calcula un parámetro de la distribución binomial negativa según los valores dados a los otros
    • stats_cdf_noncentral_chisquare - Calcula un parámetro de la distribución ji-cuadrado no central según los valores dados a los otros
    • stats_cdf_noncentral_f - Calcula un parámetro de la distribución F no central según los valores dados a los otros
    • stats_cdf_noncentral_t - Calculates any one parameter of the non-central t-distribution give values for the others
    • stats_cdf_normal - Calculates any one parameter of the normal distribution given values for the others
    • stats_cdf_poisson - Calcula un parámetro de la distribución de Poisson según los valores dados a los otros
    • stats_cdf_t - Calcula un parámetro de la distribución T según los valores dados a los otros
    • stats_cdf_uniform - No documentada
    • stats_cdf_weibull - No documentada
    • stats_covariance - Computa la covarianza de dos conjuntos de datos
    • stats_dens_beta - No documentada
    • stats_dens_cauchy - No documentada
    • stats_dens_chisquare - No documentada
    • stats_dens_exponential - No documentada
    • stats_dens_f - Descripción
    • stats_dens_gamma - No documentada
    • stats_dens_laplace - No documentada
    • stats_dens_logistic - No documentada
    • stats_dens_normal - No documentada
    • stats_dens_pmf_binomial - No documentada
    • stats_dens_pmf_hypergeometric - Descripción
    • stats_dens_pmf_negative_binomial - Probability mass function of the negative binomial distribution
    • stats_dens_pmf_poisson - No documentada
    • stats_dens_t - No documentada
    • stats_dens_uniform - Probability density function of the uniform distribution
    • stats_dens_weibull - No documentada
    • stats_harmonic_mean - Devuelve la media armónica de una matriz de valores
    • stats_kurtosis - Computa la curtosis de la información de la matriz
    • stats_rand_gen_beta - Genera una desviación aleatoria beta
    • stats_rand_gen_chisquare - Genera una desviación aleatorio desde una distribución ji-cuadrado con "df" grados de libertad de variable aleatoria
    • stats_rand_gen_exponential - Genera una desviación aleatoria sencilla desde una distribución exponencial con media "av"
    • stats_rand_gen_f - Genera una desviación aleatoria
    • stats_rand_gen_funiform - Genera números de coma flotante uniformes entretes low (exclusive) y high (exclusive)
    • stats_rand_gen_gamma - Genera desviaciones aleatorias desde una distribución gamma
    • stats_rand_gen_ibinomial - Genera una desviación sencilla desde una distribución binomial cuyo número de pruebas es "n" (n >= 0) y cuya probabilidad de un suceso en cada prueba es "pp" ([0;1]). Método : algoritmo BTPE
    • stats_rand_gen_ibinomial_negative - Generates una desviación aleatoria sencilla desde una distribución binomial negativa. Argumentos : n - el número de pruebas de la distribución binomial negativa desde la cuál se va a generar una desviación aleatoria (n > 0), p - la probabilidad de un suceso (0 < p < 1))
    • stats_rand_gen_int - Genera enteros aleatorios entre 1 y 2147483562
    • stats_rand_gen_ipoisson - Genera una desviación aleatoria sencilla desde una distribución Poisson con media "mu" (mu >= 0.0)
    • stats_rand_gen_iuniform - Genera enteros uniformemente distribuidos entre LOW (inclusive) y HIGH (inclusive)
    • stats_rand_gen_noncentral_chisquare - Generates a random deviate from the non-central chi-square distribution
    • stats_rand_gen_noncentral_f - Genera una desviación aleatoria desde una distribución F no central (ratio de varianza) con "dfn" grados de libertad en el numerador y "dfd" grados de libertad en el denominador, y parámetro no central "xnonc". Método : genera directamente el ratio de la desviación ji-cuadrado de numerador no central hasta la variación ji-cuadrado de denominador central
    • stats_rand_gen_noncentral_t - Genera una desviación aleatoria sencilla desde una distribución T no central
    • stats_rand_gen_normal - Genera una desviación aleatoria sencilla desde una distribución normal con media av, y desviación estándar sd (sd >= 0). Método : Renombra SNORM desde TOMS ya que está ligeramente modificado por BWB para usar RANF en lugar de SUNIF
    • stats_rand_gen_t - Genera una desviación aleatoria sencilla desde una distribución T
    • stats_rand_get_seeds - No documentada
    • stats_rand_phrase_to_seeds - Generar dos semillas para el generador de números aleatorios RGN
    • stats_rand_ranf - Devuelve un número de coma flotante desde una distribución uniforme sobre 0 - 1 (los extremos de este intervalo no son devueltos) usando el generador actual
    • stats_rand_setall - No documentada
    • stats_skew - Computa la oblicuidad de los datos de una matriz
    • stats_standard_deviation - Devuelve la desviación estándar
    • stats_stat_binomial_coef - No documentada
    • stats_stat_correlation - No documentada
    • stats_stat_factorial - Returns the factorial of an integer
    • stats_stat_independent_t - No documentada
    • stats_stat_innerproduct - Descripción
    • stats_stat_paired_t - No documentada
    • stats_stat_percentile - No documentada
    • stats_stat_powersum - No documentada
    • stats_variance - Devuelve la varianza de población
    • Stomp::abort - Deshacer una transacción en curso
    • Stomp::ack - Confirmar la recepción y el consumo de un mensaje
    • Stomp::begin - Iniciar una transacción
    • Stomp::commit - Validar una transacción en curso
    • Stomp::error - Obtiene el último error stomp
    • Stomp::getReadTimeout - Obtener la lectura del tiempo de espera de la solicitud
    • Stomp::getSessionId - Obtiene el identificador de sesión actual stomp
    • Stomp::hasFrame - Indica si existe o no una trama lista para leer
    • Stomp::readFrame - Leer la siguiente trama
    • Stomp::send - Envía un mensaje
    • Stomp::setReadTimeout - Establecer el tiempo de espera de lectura
    • Stomp::subscribe - Registrarse para escuchar a un destino dado
    • Stomp::unsubscribe - Dar de baja una suscripción existente
    • Stomp::__construct - Abre una conexión
    • Stomp::__destruct - Cierra una conexión stomp
    • StompException::getDetails - Obtener detalles de la excepción
    • StompFrame::__construct - Constructor
    • stomp_connect_error - Devuelve una cadena descripción de el último error al conectar
    • stomp_version - Obtiene la versión actual de la extensión stomp
    • strcasecmp - Comparación de string segura a nivel binario e insensible a mayúsculas y minúsculas
    • strchr - Alias de strstr
    • strcmp - Comparación de string segura a nivel binario
    • strcoll - Comparación de cadenas basada en la localidad
    • strcspn - Averiguar la longitud del segmento inicial que no coincida con una máscara
    • streamWrapper::dir_closedir - Cerrar un gestor de directorio
    • streamWrapper::dir_opendir - Abrir un gestor de directorio
    • streamWrapper::dir_readdir - Leer una entrada desde el gestor de directorio
    • streamWrapper::dir_rewinddir - Rebobina el gestor de directorio
    • streamWrapper::mkdir - Crear un directorio
    • streamWrapper::rename - Renombra un archivo o directorio
    • streamWrapper::rmdir - Elimina un directorio
    • streamWrapper::stream_cast - Recuperar el recurso subyacente
    • streamWrapper::stream_close - Cerrar un recurso
    • streamWrapper::stream_eof - Comprueba si un puntero a un archivo está en el final del archivo (EOF)
    • streamWrapper::stream_flush - Vuelca la salida
    • streamWrapper::stream_lock - Bloqueo de archivos asesorado
    • streamWrapper::stream_metadata - Cambiar las opciones del flujo
    • streamWrapper::stream_open - Abre un archivo o una URL
    • streamWrapper::stream_read - Leer un flujo
    • streamWrapper::stream_seek - Busca la ubicación específica en un flujo
    • streamWrapper::stream_set_option - Cambiar las opciones del flujo
    • streamWrapper::stream_stat - Recuperar información sobre un recurso de archivo
    • streamWrapper::stream_tell - Recuperar la posición actual de un flujo
    • streamWrapper::stream_truncate - Truncar un flujo
    • streamWrapper::stream_write - Escribir en un flujo
    • streamWrapper::unlink - Borrar un archivo
    • streamWrapper::url_stat - Recuperar información sobre un archivo
    • streamWrapper::__construct - Construye una nueva envoltura de flujo
    • streamWrapper::__destruct - Destruye una envoltura de flujo existente
    • stream_bucket_append - Añade un recipiente a una cadena de recipientes
    • stream_bucket_make_writeable - Devuelve un objeto recipiente desde una cadena de recipientes para operarar con él
    • stream_bucket_new - Crear un nuevo recipiente para usarlo en el flujo actual
    • stream_bucket_prepend - Añade un recipiente al principio de una cadena de recipientes
    • stream_context_create - Crear un contexto de flujo
    • stream_context_get_default - Recuperar el contexto de flujo predeterminado
    • stream_context_get_options - Recuperar las opciones para un flujo/envoltura/contexto
    • stream_context_get_params - Recuperar los parámetros de un contexto
    • stream_context_set_default - Establecer el contexto de flujo predeterminado
    • stream_context_set_option - Establece una opción para un flujo/envoltura/contexto
    • stream_context_set_params - Establecer parámetros para un flujo/envoltura/contexto
    • stream_copy_to_stream - Copia información desde un flujo a otro
    • stream_filter_append - Enlaza un filtro a un flujo
    • stream_filter_prepend - Adjunta un filtro a un flujo
    • stream_filter_register - Registrar un filtro de flujo definido por el usuario
    • stream_filter_remove - Elimina un filtro de un flujo
    • stream_get_contents - Transfiere el resto de un flujo a una cadena
    • stream_get_filters - Recuperar la lista de los filtros registrados
    • stream_get_line - Obtiene una línea del recurso de flujo hasta un delimitador dado
    • stream_get_meta_data - Recuperar meta-información o de cabecera de punteros a flujos/archivo
    • stream_get_transports - Recuperar la lista de transportes de socket registrados
    • stream_get_wrappers - Recupera la lista de los flujos registrados
    • stream_isatty - Check if a stream is a TTY
    • stream_is_local - Comprueba si un flujo es un flujo local
    • stream_notification_callback - Una función de retrollamada para el parámetro de contexto de notificación
    • stream_register_wrapper - Alias de stream_wrapper_register
    • stream_resolve_include_path - Resuelve el nombre de archivo en la ruta incluida
    • stream_select - Ejecuta el equivalente de la llamada al sistema select() sobre las matrices de flujos dadas con un tiempo de espera especificado por tv_sec y tv_usec
    • stream_set_blocking - Establecer el modo bloqueo/no-bloqueo en un flujo
    • stream_set_chunk_size - Establecer el tamaño de trozo de flujo
    • stream_set_read_buffer - Establece el búfer de lectura de archivos en el flujo dado
    • stream_set_timeout - Establecer un perido de tiempo de espera en un flujo
    • stream_set_write_buffer - Establece el búfer para escritura de ficheros en el flujo dado
    • stream_socket_accept - Acepta una conexión sobre un socket creado por stream_socket_server
    • stream_socket_client - Abrir una conexión de socket de dominio de Internet o Unix
    • stream_socket_enable_crypto - Activa/desactiva la encriptación en un socket ya conectado
    • stream_socket_get_name - Recuperar el nombre de los sockets locales o remotos
    • stream_socket_pair - Crea un pareja de flujos de socket conectados e indistinguibles
    • stream_socket_recvfrom - Recibir información de un socket, conectado o no
    • stream_socket_sendto - Envía un mensaje a un socket, ya esté conectado o no
    • stream_socket_server - Crear un socket de servidor de dominio de Internet o de Unix
    • stream_socket_shutdown - Cerrar una conexión full-duplex
    • stream_supports_lock - Indica si el flujo soporta bloqueo
    • stream_wrapper_register - Registra una envoltura de URL implementada como una clase de PHP
    • stream_wrapper_restore - Restablece una envoltura incluida que se dejó de registrar previamente
    • stream_wrapper_unregister - Deja de registrar una envoltura de URL
    • strftime - Formatea una fecha/hora local según una configuración local
    • stripcslashes - Desmarca la cadena marcada con addcslashes
    • stripos - Encuentra la posición de la primera aparición de un substring en un string sin considerar mayúsculas ni minúsculas
    • stripslashes - Quita las barras de un string con comillas escapadas
    • strip_tags - Retira las etiquetas HTML y PHP de un string
    • stristr - strstr insensible a mayúsculas y minúsculas
    • strlen - Obtiene la longitud de un string
    • strnatcasecmp - Comparación de strings, insensible a mayúsculas y minúsculas, utilizando un algoritmo de "orden natural"
    • strnatcmp - Comparación de strings utilizando un algoritmo de "orden natural"
    • strncasecmp - Comparación de los primeros n caracteres de cadenas, segura con material binario e insensible a mayúsculas y minúsculas
    • strncmp - Comparación segura a nivel binario de los primeros n caracteres entre strings
    • strpbrk - Buscar una cadena por cualquiera de los elementos de un conjunto de caracteres
    • strpos - Encuentra la posición de la primera ocurrencia de un substring en un string
    • strptime - Analiza una fecha/hora generada con strftime
    • strrchr - Encuentra la última aparición de un caracter en un string
    • strrev - Invierte una string
    • strripos - Encuentra la posición de la última aparición de un substring insensible a mayúsculas y minúsculas en un string
    • strrpos - Encuentra la posición de la última aparición de un substring en un string
    • strspn - Averigua la longitud del segmento inicial de un string que consista únicamente en caracteres contenidos dentro de una máscara dada
    • strstr - Encuentra la primera aparición de un string
    • strtok - Tokeniza string
    • strtolower - Convierte un string a minúsculas
    • strtotime - Convierte una descripción de fecha/hora textual en Inglés a una fecha Unix
    • strtoupper - Convierte un string a mayúsculas
    • strtr - Convierte caracteres o reemplaza substrings
    • strval - Obtiene el valor de cadena de una variable
    • str_contains - Determine if a string contains a given substring
    • str_ends_with - Checks if a string ends with a given substring
    • str_getcsv - Convierte un string con formato CSV a un array
    • str_ireplace - Versión insensible a mayúsculas y minúsculas de str_replace
    • str_pad - Rellena un string hasta una longitud determinada con otro string
    • str_repeat - Repite un string
    • str_replace - Reemplaza todas las apariciones del string buscado con el string de reemplazo
    • str_rot13 - Realizar la transformación rot13 sobre una cadena
    • str_shuffle - Reordena aleatoriamente una cadena
    • str_split - Convierte un string en un array
    • str_starts_with - Checks if a string starts with a given substring
    • str_word_count - Devuelve información sobre las palabras utilizadas en un string
    • substr - Devuelve parte de una cadena
    • substr_compare - Comparación segura a nivel binario de dos o más strings desde un índice hasta una longitud de caracteres dada
    • substr_count - Cuenta el número de apariciones del substring
    • substr_replace - Reemplaza el texto dentro de una porción de un string
    • SVM::crossvalidate - Test training params on subsets of the training data
    • SVM::getOptions - Return the current training parameters
    • SVM::setOptions - Set training parameters
    • SVM::train - Create a SVMModel based on training data
    • SVM::__construct - Construir un nuevo objeto SVM
    • SVMModel::checkProbabilityModel - Returns true if the model has probability information
    • SVMModel::getLabels - Get the labels the model was trained on
    • SVMModel::getNrClass - Returns the number of classes the model was trained with
    • SVMModel::getSvmType - Get the SVM type the model was trained with
    • SVMModel::getSvrProbability - Get the sigma value for regression types
    • SVMModel::load - Cargar un modelo SVM guardado
    • SVMModel::predict - Predict a value for previously unseen data
    • SVMModel::predict_probability - Return class probabilities for previous unseen data
    • SVMModel::save - Guardar un modelo en un archivo
    • SVMModel::__construct - Construct a new SVMModel
    • svn_add - Programa la adición de un artículo en un directorio de trabajo
    • svn_auth_get_parameter - Recupera un parámetros de autenticación
    • svn_auth_set_parameter - Establece un parámetro de autenticación
    • svn_blame - Obtiene las acusaciones SVN de un archivo
    • svn_cat - Devuelve el contenido de un fichero en un repositorio
    • svn_checkout - Descarga una copia de trabajo desde el repositorio
    • svn_cleanup - Limpieza recursiva del directorio de trabajo, finalizando operaciones no completadas y eliminado bloqueos
    • svn_client_version - Devuelve la versión de las librerias del cliente SVN
    • svn_commit - Envía los cambios desde el directorio local de trabajo al repositorio
    • svn_delete - Elimina ítems de una copia de trabajo o repositorio
    • svn_diff - Compara dos rutas de acceso recursivamente
    • svn_export - Exporta el contenido de un directorio SVN
    • svn_fs_abort_txn - Cancelar una transacción, devuelve true si todo está bien, false de lo contrario
    • svn_fs_apply_text - Crea y devuelve una secuencia que se utilizará para reemplazar
    • svn_fs_begin_txn2 - Crear una nueva transacción
    • svn_fs_change_node_prop - Retorna verdadero si todo está ok, falso en caso contrario
    • svn_fs_check_path - Determina que tipo de elemento está apuntado por una ruta de acceso determinada, en un repositorio fsroot
    • svn_fs_contents_changed - Devuelve verdadero si el contenido es diferente, falso en caso contrario
    • svn_fs_copy - Copia un fichero o un directorio, devuelve true en caso de éxito, de lo contrario devuelve false
    • svn_fs_delete - Elimina un fichero o directorio, devuelve true en caso de éxito, en caso contrario devuele false
    • svn_fs_dir_entries - Enumera los directorios que hay bajo una ruta de acceso determinada; devuelve un array con los nombres de los directorios
    • svn_fs_file_contents - Devuelve un flujo de acceso al contenido de un fichero para una versión del sistema de ficheros dada
    • svn_fs_file_length - Devuelve la longitud de un fichero para una versión dada de sistema de ficheros
    • svn_fs_is_dir - Devuelve true si la ruta apunta a un directorio, false en caso contrario
    • svn_fs_is_file - Devuelve true si la ruta apunta a un fichero, falso en caso contrario
    • svn_fs_make_dir - Crea un nuevo directorio vacío, devuelve true en caso de éxito, en caso contrario devuelve false
    • svn_fs_make_file - Crea un nuevo fichero vacío, devuelve true en caso de éxito, false en caso contrario
    • svn_fs_node_created_rev - Devuelve la revisión en la que la ruta de acceso bajo fsroot fue creado
    • svn_fs_node_prop - Devuelve el valor de una propiedad de un nodo
    • svn_fs_props_changed - Devuelve verdadero si las propiedades son diferentes, falso en caso contrario
    • svn_fs_revision_prop - Recupera el valor de una propiedad con determinado nombre
    • svn_fs_revision_root - Obtiene un gestor en una versión específica del repositorio 'root'
    • svn_fs_txn_root - Crea y retorna una transacción 'root'
    • svn_fs_youngest_rev - Devuelve el número de la revisión más reciente del sistema de ficheros
    • svn_import - Importa una ruta de acceso sin versión, dentro de un repositorio
    • svn_log - Devuelve el log histórico de mensajes de un repositorio URL
    • svn_ls - Devuelve una lista del contenido del directorio en el repositorio URL, opcionalmente el número de revisión
    • svn_mkdir - Crea un directorio en la copia de trabajo actual o repositorio
    • svn_repos_create - Crea un nuevo repositorio de subversión
    • svn_repos_fs - Obtiene un gestor del sistema de ficheros para un repositorio
    • svn_repos_fs_begin_txn_for_commit - Crea una nueva transacción
    • svn_repos_fs_commit_txn - Consolida una transacción y devuelve la nueva revisión
    • svn_repos_hotcopy - Realiza una copia en caliente del repositorio en pathrepospath; y lo copia en destpath
    • svn_repos_open - Abre una cerradura compartida en un repositorio
    • svn_repos_recover - Ejecuta los procesos de recuperación en el repositorio localizado en un path determinado
    • svn_revert - Deshace los cambios en la copia de trabajo
    • svn_status - Devuelve el estado de la copia de trabajo de los ficheros y directorios
    • svn_update - Actualiza la copia de trabajo
    • Swoole\Async::dnsLookup - Async and non-blocking hostname to IP lookup.
    • Swoole\Async::read - Read file stream asynchronously.
    • Swoole\Async::readFile - Read a file asynchronously.
    • Swoole\Async::set - Update the async I/O options.
    • Swoole\Async::write - Write data to a file stream asynchronously.
    • Swoole\Async::writeFile - Description
    • Swoole\Atomic::add - Add a number to the value to the atomic object.
    • Swoole\Atomic::cmpset - Compare and set the value of the atomic object.
    • Swoole\Atomic::get - Get the current value of the atomic object.
    • Swoole\Atomic::set - Set a new value to the atomic object.
    • Swoole\Atomic::sub - Subtract a number to the value of the atomic object.
    • Swoole\Atomic::__construct - Construct a swoole atomic object.
    • Swoole\Buffer::append - Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
    • Swoole\Buffer::clear - Reset the memory buffer.
    • Swoole\Buffer::expand - Expand the size of memory buffer.
    • Swoole\Buffer::read - Read data from the memory buffer based on offset and length.
    • Swoole\Buffer::recycle - Release the memory to OS which is not used by the memory buffer.
    • Swoole\Buffer::substr - Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
    • Swoole\Buffer::write - Write data to the memory buffer. The memory allocated for the buffer will not be changed.
    • Swoole\Buffer::__construct - Fixed size memory blocks allocation.
    • Swoole\Buffer::__destruct - Destruct the Swoole memory buffer.
    • Swoole\Buffer::__toString - Get the string value of the memory buffer.
    • Swoole\Channel::pop - Read and pop data from swoole channel.
    • Swoole\Channel::push - Write and push data into Swoole channel.
    • Swoole\Channel::stats - Get stats of swoole channel.
    • Swoole\Channel::__construct - Construct a Swoole Channel
    • Swoole\Channel::__destruct - Destruct a Swoole channel.
    • Swoole\Client::close - Close the connection established.
    • Swoole\Client::connect - Connect to the remote TCP or UDP port.
    • Swoole\Client::getpeername - Get the remote socket name of the connection.
    • Swoole\Client::getsockname - Get the local socket name of the connection.
    • Swoole\Client::isConnected - Check if the connection is established.
    • Swoole\Client::on - Add callback functions triggered by events.
    • Swoole\Client::pause - Pause receiving data.
    • Swoole\Client::pipe - Redirect the data to another file descriptor.
    • Swoole\Client::recv - Receive data from the remote socket.
    • Swoole\Client::resume - Resume receiving data.
    • Swoole\Client::send - Send data to the remote TCP socket.
    • Swoole\Client::sendfile - Send file to the remote TCP socket.
    • Swoole\Client::sendto - Send data to the remote UDP address.
    • Swoole\Client::set - Set the Swoole client parameters before the connection is established.
    • Swoole\Client::sleep - Remove the TCP client from system event loop.
    • Swoole\Client::wakeup - Add the TCP client back into the system event loop.
    • Swoole\Client::__construct - Create Swoole sync or async TCP/UDP client, with or without SSL.
    • Swoole\Client::__destruct - Destruct the Swoole client.
    • Swoole\Connection\Iterator::count - Count connections.
    • Swoole\Connection\Iterator::current - Return current connection entry.
    • Swoole\Connection\Iterator::key - Return key of the current connection.
    • Swoole\Connection\Iterator::next - Move to the next connection.
    • Swoole\Connection\Iterator::offsetExists - Check if offet exists.
    • Swoole\Connection\Iterator::offsetGet - Offset to retrieve.
    • Swoole\Connection\Iterator::offsetSet - Assign a Connection to the specified offset.
    • Swoole\Connection\Iterator::offsetUnset - Unset an offset.
    • Swoole\Connection\Iterator::rewind - Rewinds iterator
    • Swoole\Connection\Iterator::valid - Check if current position is valid.
    • Swoole\Coroutine::call_user_func - Call a callback given by the first parameter
    • Swoole\Coroutine::call_user_func_array - Call a callback with an array of parameters
    • Swoole\Coroutine::cli_wait - Description
    • Swoole\Coroutine::create - Description
    • Swoole\Coroutine::getuid - Description
    • Swoole\Coroutine::resume - Description
    • Swoole\Coroutine::suspend - Description
    • Swoole\Coroutine\Client::close - Description
    • Swoole\Coroutine\Client::connect - Description
    • Swoole\Coroutine\Client::getpeername - Description
    • Swoole\Coroutine\Client::getsockname - Description
    • Swoole\Coroutine\Client::isConnected - Description
    • Swoole\Coroutine\Client::recv - Description
    • Swoole\Coroutine\Client::send - Description
    • Swoole\Coroutine\Client::sendfile - Description
    • Swoole\Coroutine\Client::sendto - Description
    • Swoole\Coroutine\Client::set - Description
    • Swoole\Coroutine\Client::__construct - Description
    • Swoole\Coroutine\Client::__destruct - Description
    • Swoole\Coroutine\Http\Client::addFile - Description
    • Swoole\Coroutine\Http\Client::close - Description
    • Swoole\Coroutine\Http\Client::execute - Description
    • Swoole\Coroutine\Http\Client::get - Description
    • Swoole\Coroutine\Http\Client::getDefer - Description
    • Swoole\Coroutine\Http\Client::isConnected - Description
    • Swoole\Coroutine\Http\Client::post - Description
    • Swoole\Coroutine\Http\Client::recv - Description
    • Swoole\Coroutine\Http\Client::set - Description
    • Swoole\Coroutine\Http\Client::setCookies - Description
    • Swoole\Coroutine\Http\Client::setData - Description
    • Swoole\Coroutine\Http\Client::setDefer - Description
    • Swoole\Coroutine\Http\Client::setHeaders - Description
    • Swoole\Coroutine\Http\Client::setMethod - Description
    • Swoole\Coroutine\Http\Client::__construct - Description
    • Swoole\Coroutine\Http\Client::__destruct - Description
    • Swoole\Coroutine\MySQL::close - Description
    • Swoole\Coroutine\MySQL::connect - Description
    • Swoole\Coroutine\MySQL::getDefer - Description
    • Swoole\Coroutine\MySQL::query - Description
    • Swoole\Coroutine\MySQL::recv - Description
    • Swoole\Coroutine\MySQL::setDefer - Description
    • Swoole\Coroutine\MySQL::__construct - Description
    • Swoole\Coroutine\MySQL::__destruct - Description
    • Swoole\Event::add - Add new callback functions of a socket into the EventLoop.
    • Swoole\Event::defer - Add a callback function to the next event loop.
    • Swoole\Event::del - Remove all event callback functions of a socket.
    • Swoole\Event::exit - Exit the eventloop, only available at client side.
    • Swoole\Event::set - Update the event callback functions of a socket.
    • Swoole\Event::wait - Description
    • Swoole\Event::write - Write data to the socket.
    • Swoole\Http\Client::addFile - Add a file to the post form.
    • Swoole\Http\Client::close - Close the http connection.
    • Swoole\Http\Client::download - Download a file from the remote server.
    • Swoole\Http\Client::execute - Send the HTTP request after setting the parameters.
    • Swoole\Http\Client::get - Send GET http request to the remote server.
    • Swoole\Http\Client::isConnected - Check if the HTTP connection is connected.
    • Swoole\Http\Client::on - Register callback function by event name.
    • Swoole\Http\Client::post - Send POST http request to the remote server.
    • Swoole\Http\Client::push - Push data to websocket client.
    • Swoole\Http\Client::set - Update the HTTP client paramters.
    • Swoole\Http\Client::setCookies - Set the http request cookies.
    • Swoole\Http\Client::setData - Set the HTTP request body data.
    • Swoole\Http\Client::setHeaders - Set the HTTP request headers.
    • Swoole\Http\Client::setMethod - Set the HTTP request method.
    • Swoole\Http\Client::upgrade - Upgrade to websocket protocol.
    • Swoole\Http\Client::__construct - Construct the async HTTP client.
    • Swoole\Http\Client::__destruct - Destruct the HTTP client.
    • Swoole\Http\Request::rawcontent - Get the raw HTTP POST body.
    • Swoole\Http\Request::__destruct - Destruct the HTTP request.
    • Swoole\Http\Response::cookie - Set the cookies of the HTTP response.
    • Swoole\Http\Response::end - Send data for the HTTP request and finish the response.
    • Swoole\Http\Response::gzip - Enable the gzip of response content.
    • Swoole\Http\Response::header - Set the HTTP response headers.
    • Swoole\Http\Response::initHeader - Init the HTTP response header.
    • Swoole\Http\Response::rawcookie - Set the raw cookies to the HTTP response.
    • Swoole\Http\Response::sendfile - Send file through the HTTP response.
    • Swoole\Http\Response::status - Set the status code of the HTTP response.
    • Swoole\Http\Response::write - Append HTTP body content to the HTTP response.
    • Swoole\Http\Response::__destruct - Destruct the HTTP response.
    • Swoole\Http\Server::on - Bind callback function to HTTP server by event name.
    • Swoole\Http\Server::start - Start the swoole http server.
    • Swoole\Lock::lock - Try to acquire the lock. It will block if the lock is not available.
    • Swoole\Lock::lock_read - Lock a read-write lock for reading.
    • Swoole\Lock::trylock - Try to acquire the lock and return straight away even the lock is not available.
    • Swoole\Lock::trylock_read - Try to lock a read-write lock for reading and return straight away even the lock is not available.
    • Swoole\Lock::unlock - Release the lock.
    • Swoole\Lock::__construct - Construct a memory lock.
    • Swoole\Lock::__destruct - Destory a Swoole memory lock.
    • Swoole\Mmap::open - Map a file into memory and return the stream resource which can be used by PHP stream operations.
    • Swoole\MySQL::close - Close the async MySQL connection.
    • Swoole\MySQL::connect - Connect to the remote MySQL server.
    • Swoole\MySQL::getBuffer - Description
    • Swoole\MySQL::on - Register callback function based on event name.
    • Swoole\MySQL::query - Run the SQL query.
    • Swoole\MySQL::__construct - Construct an async MySQL client.
    • Swoole\MySQL::__destruct - Destory the async MySQL client.
    • Swoole\Process::alarm - High precision timer which triggers signal with fixed interval.
    • Swoole\Process::close - Close the pipe to the child process.
    • Swoole\Process::daemon - Change the process to be a daemon process.
    • Swoole\Process::exec - Execute system commands.
    • Swoole\Process::exit - Stop the child processes.
    • Swoole\Process::freeQueue - Destroy the message queue created by swoole_process::useQueue.
    • Swoole\Process::kill - Send signal to the child process.
    • Swoole\Process::name - Set name of the process.
    • Swoole\Process::pop - Read and pop data from the message queue.
    • Swoole\Process::push - Write and push data into the message queue.
    • Swoole\Process::read - Read data sending to the process.
    • Swoole\Process::signal - Send signal to the child processes.
    • Swoole\Process::start - Start the process.
    • Swoole\Process::statQueue - Get the stats of the message queue used as the communication method between processes.
    • Swoole\Process::useQueue - Create a message queue as the communication method between the parent process and child processes.
    • Swoole\Process::wait - Wait for the events of child processes.
    • Swoole\Process::write - Write data into the pipe and communicate with the parent process or child processes.
    • Swoole\Process::__construct - Construct a process.
    • Swoole\Process::__destruct - Destory the process.
    • Swoole\Redis\Server::format - Description
    • Swoole\Redis\Server::setHandler - Description
    • Swoole\Redis\Server::start - Description
    • Swoole\Serialize::pack - Serialize the data.
    • Swoole\Serialize::unpack - Unserialize the data.
    • Swoole\Server::addlistener - Add a new listener to the server.
    • Swoole\Server::addProcess - Add a user defined swoole_process to the server.
    • Swoole\Server::after - Trigger a callback function after a period of time.
    • Swoole\Server::bind - Bind the connection to a user defined user ID.
    • Swoole\Server::clearTimer - Stop and destory a timer.
    • Swoole\Server::close - Close a connection to the client.
    • Swoole\Server::confirm - Check status of the connection.
    • Swoole\Server::connection_info - Get the connection info by file description.
    • Swoole\Server::connection_list - Get all of the established connections.
    • Swoole\Server::defer - Delay execution of the callback function at the end of current EventLoop.
    • Swoole\Server::exist - Check if the connection is existed.
    • Swoole\Server::finish - Used in task process for sending result to the worker process when the task is finished.
    • Swoole\Server::getClientInfo - Get the connection info by file description.
    • Swoole\Server::getClientList - Get all of the established connections.
    • Swoole\Server::getLastError - Get the error code of the most recent error.
    • Swoole\Server::heartbeat - Check all the connections on the server.
    • Swoole\Server::listen - Listen on the given IP and port, socket type.
    • Swoole\Server::on - Register a callback function by event name.
    • Swoole\Server::pause - Stop receiving data from the connection.
    • Swoole\Server::protect - Set the connection to be protected mode.
    • Swoole\Server::reload - Restart all the worker process.
    • Swoole\Server::resume - Start receving data from the connection.
    • Swoole\Server::send - Send data to the client.
    • Swoole\Server::sendfile - Send file to the connection.
    • Swoole\Server::sendMessage - Send message to worker processes by ID.
    • Swoole\Server::sendto - Send data to the remote UDP address.
    • Swoole\Server::sendwait - Send data to the remote socket in the blocking way.
    • Swoole\Server::set - Set the runtime settings of the swoole server.
    • Swoole\Server::shutdown - Shutdown the master server process, this function can be called in worker processes.
    • Swoole\Server::start - Start the Swoole server.
    • Swoole\Server::stats - Get the stats of the Swoole server.
    • Swoole\Server::stop - Stop the Swoole server.
    • Swoole\Server::task - Send data to the task worker processes.
    • Swoole\Server::taskwait - Send data to the task worker processes in blocking way.
    • Swoole\Server::taskWaitMulti - Execute multiple tasks concurrently.
    • Swoole\Server::tick - Repeats a given function at every given time-interval.
    • Swoole\Server::__construct - Construct a Swoole server.
    • Swoole\Server\Port::on - Register callback functions by event.
    • Swoole\Server\Port::set - Set protocol of the server port.
    • Swoole\Server\Port::__construct - Construct a server port
    • Swoole\Server\Port::__destruct - Destory server port
    • Swoole\Table::column - Set the data type and size of the columns.
    • Swoole\Table::count - Count the rows in the table, or count all the elements in the table if $mode = 1.
    • Swoole\Table::create - Create the swoole memory table.
    • Swoole\Table::current - Get the current row.
    • Swoole\Table::decr - Decrement the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::del - Delete a row in the Swoole table by $row_key.
    • Swoole\Table::destroy - Destroy the Swoole table.
    • Swoole\Table::exist - Check if a row is existed by $row_key.
    • Swoole\Table::get - Get the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::incr - Increment the value by $row_key and $column_key.
    • Swoole\Table::key - Get the key of current row.
    • Swoole\Table::next - Iterator the next row.
    • Swoole\Table::rewind - Rewind the iterator.
    • Swoole\Table::set - Update a row of the table by $row_key.
    • Swoole\Table::valid - Check current if the current row is valid.
    • Swoole\Table::__construct - Construct a Swoole memory table with fixed size.
    • Swoole\Timer::after - Trigger a callback function after a period of time.
    • Swoole\Timer::clear - Delete a timer by timer ID.
    • Swoole\Timer::exists - Check if a timer is existed.
    • Swoole\Timer::tick - Repeats a given function at every given time-interval.
    • Swoole\WebSocket\Server::exist - Check if the file descriptor exists.
    • Swoole\WebSocket\Server::on - Register event callback function
    • Swoole\WebSocket\Server::pack - Get a pack of binary data to send in a single frame.
    • Swoole\WebSocket\Server::push - Push data to the remote client.
    • Swoole\WebSocket\Server::unpack - Unpack the binary data received from the client.
    • swoole_async_dns_lookup - Async and non-blocking hostname to IP lookup
    • swoole_async_read - Read file stream asynchronously
    • swoole_async_readfile - Read a file asynchronously
    • swoole_async_set - Update the async I/O options
    • swoole_async_write - Write data to a file stream asynchronously
    • swoole_async_writefile - Write data to a file asynchronously
    • swoole_client_select - Get the file description which are ready to read/write or error
    • swoole_cpu_num - Get the number of CPU
    • swoole_errno - Get the error code of the latest system call
    • swoole_event_add - Add new callback functions of a socket into the EventLoop
    • swoole_event_defer - Add callback function to the next event loop
    • swoole_event_del - Remove all event callback functions of a socket
    • swoole_event_exit - Exit the eventloop, only available at the client side
    • swoole_event_set - Update the event callback functions of a socket
    • swoole_event_wait - Start the event loop
    • swoole_event_write - Write data to a socket
    • swoole_get_local_ip - Get the IPv4 IP addresses of each NIC on the machine
    • swoole_last_error - Get the lastest error message
    • swoole_load_module - Load a swoole extension
    • swoole_select - Select the file descriptions which are ready to read/write or error in the eventloop
    • swoole_set_process_name - Set the process name
    • swoole_strerror - Convert the Errno into error messages
    • swoole_timer_after - Trigger a one time callback function in the future
    • swoole_timer_exists - Check if a timer callback function is existed
    • swoole_timer_tick - Trigger a timer tick callback function by time interval
    • swoole_version - Get the version of Swoole
    • symlink - Crea un enlace simbólico
    • SyncEvent::fire - Fires/sets the event
    • SyncEvent::reset - Resets a manual event
    • SyncEvent::wait - Waits for the event to be fired/set
    • SyncEvent::__construct - Constructs a new SyncEvent object
    • SyncMutex::lock - Waits for an exclusive lock
    • SyncMutex::unlock - Unlocks the mutex
    • SyncMutex::__construct - Constructs a new SyncMutex object
    • SyncReaderWriter::readlock - Waits for a read lock
    • SyncReaderWriter::readunlock - Releases a read lock
    • SyncReaderWriter::writelock - Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock - Releases a write lock
    • SyncReaderWriter::__construct - Constructs a new SyncReaderWriter object
    • SyncSemaphore::lock - Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock - Increases the count of the semaphore
    • SyncSemaphore::__construct - Constructs a new SyncSemaphore object
    • SyncSharedMemory::first - Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read - Copy data from named shared memory
    • SyncSharedMemory::size - Returns the size of the named shared memory
    • SyncSharedMemory::write - Copy data to named shared memory
    • SyncSharedMemory::__construct - Constructs a new SyncSharedMemory object
    • syslog - Genera un mensaje log de sistema
    • system - Ejecutar un programa externo y mostrar su salida
    • sys_getloadavg - Obtiene la carga media del sistema
    • sys_get_temp_dir - Devuelve la ruta del directorio para archivos temporales
  • t
    • taint - Corrompe un string
    • tan - Tangente
    • tanh - Tangente hiperbólica
    • tcpwrap_check - Realiza una comprobación tcpwrap
    • tempnam - Crea un fichero con un nombre de fichero único
    • textdomain - Establece el dominio actual
    • Thread::detach - Ejecución
    • Thread::getCreatorId - Identificación
    • Thread::getCurrentThread - Identificación
    • Thread::getCurrentThreadId - Identification
    • Thread::getThreadId - Identification
    • Thread::globally - Execution
    • Thread::isJoined - State Detection
    • Thread::isStarted - State Detection
    • Thread::join - Synchronization
    • Thread::kill - Ejecución
    • Thread::start - Execution
    • Threaded::chunk - Manipulation
    • Threaded::count - Manipulation
    • Threaded::extend - Runtime Manipulation
    • Threaded::from - Creation
    • Threaded::getTerminationInfo - Error Detection
    • Threaded::isRunning - State Detection
    • Threaded::isTerminated - State Detection
    • Threaded::isWaiting - State Detection
    • Threaded::lock - Synchronization
    • Threaded::merge - Manipulation
    • Threaded::notify - Synchronization
    • Threaded::notifyOne - Synchronization
    • Threaded::pop - Manipulation
    • Threaded::run - Execution
    • Threaded::shift - Manipulation
    • Threaded::synchronized - Synchronization
    • Threaded::unlock - Synchronization
    • Threaded::wait - Synchronization
    • Throwable::getCode - Obtener el código de la excepción
    • Throwable::getFile - Obtiene el fichero en el que se creó el objeto
    • Throwable::getLine - Obtiene la línea en la que el objeto fue instanciado
    • Throwable::getMessage - Obtiene el mensaje
    • Throwable::getPrevious - Devuelve el objeto Throwable previo
    • Throwable::getTrace - Obtener la traza de la pila
    • Throwable::getTraceAsString - Obtener la traza de la pila como un string
    • Throwable::__toString - Obtiene un representación de string del objeto lanzado
    • tidy::$errorBuffer - Devuelve advertencias y errores que ocurrieron al analizar el documento especificado
    • tidy::body - Devuelve un objeto tidyNode empezando con la etiqueta <body>
    • tidy::cleanRepair - Ejecuta una operación de limpieza y reparación de las etiquetas HTML
    • tidy::diagnose - Ejecuta un diagnóstico sobre documento analizado y reparado
    • tidy::getConfig - Obtiene la configuración actual de Tidy
    • tidy::getHtmlVer - Obtiene la versión detectada de HTML en un documento especificado
    • tidy::getOpt - Devuelve el valor de la opción de configuración especificada para el documento tidy
    • tidy::getOptDoc - Devuelve la documentación correspondiente a un nombre de opción dado
    • tidy::getRelease - Obtiene la fecha de lanzamiento (versión) de la librería Tidy
    • tidy::getStatus - Obtiene el status de un documento especificado
    • tidy::head - Devuelve un objeto tidyNode empezando con la etiqueta <head>
    • tidy::html - Devuelve un objeto tidyNode empezando con la etiqueta <html>
    • tidy::isXhtml - Indica si el documento es XHTML
    • tidy::isXml - Indica si el documento es XML (no HTML/XHTML)
    • tidy::parseFile - Analiza las etiquetas de un fichero o URI
    • tidy::parseString - Analiza un documento almacenado en una cadena
    • tidy::repairFile - Repara un archivo y lo devuelve como una cadena
    • tidy::repairString - Repara una cadena HTML usando un archivo de configuración opcional
    • tidy::root - Devuelve un objeto tidyNode que representa la raíz del árbol analizado por tidy
    • tidy::__construct - Construye un nuevo objeto tidy
    • tidyNode::getParent - Devuelve el nodo padre del nodo actual
    • tidyNode::hasChildren - Indica si un nodo tiene hijos
    • tidyNode::hasSiblings - Indica si un nodo tiene hermanos
    • tidyNode::isAsp - Comprueba si el nodo es ASP
    • tidyNode::isComment - Comprueba el nodo actual es un comentario
    • tidyNode::isHtml - Comprueba si el nodo es parte de un documento HTML
    • tidyNode::isJste - Comprueba si el nodo es JSTE
    • tidyNode::isPhp - Comprueba si el nodo es PHP
    • tidyNode::isText - Comprueba si un nodo representa un texto (no HTML)
    • tidyNode::__construct - Private constructor to disallow direct instantiation
    • tidy_access_count - Devuelve el número de alertas de accesibilidad Tidy encontradas en un documento dado
    • tidy_config_count - Devuelve el número de errores de configuración Tidy encontrados en un documento dado
    • tidy_error_count - Devuelve el número de errores Tidy encontrados en un documento dado
    • tidy_get_output - Devuelve una cadena que contiene las etiquetas analizadas por Tidy
    • tidy_warning_count - Devuelve el número de alertas encontradas en un documendo dado
    • time - Devuelve la fecha Unix actual
    • timezone_abbreviations_list - Alias de DateTimeZone::listAbbreviations
    • timezone_identifiers_list - Alias de DateTimeZone::listIdentifiers
    • timezone_location_get - Alias de DateTimeZone::getLocation
    • timezone_name_from_abbr - Devuelve el nombre de la zona horaria desde su abreviatura
    • timezone_name_get - Alias de DateTimeZone::getName
    • timezone_offset_get - Alias de DateTimeZone::getOffset
    • timezone_open - Alias de DateTimeZone::__construct
    • timezone_transitions_get - Alias de DateTimeZone::getTransitions
    • timezone_version_get - Obtiene la versión de la base de datos timezonedb
    • time_nanosleep - Retrasar por un número de segundos y nanosegundos
    • time_sleep_until - Hacer que el script duerma hasta el momento especificado
    • tmpfile - Crea un archivo temporal
    • token_get_all - Divide la fuente dada en tokens PHP
    • token_name - Obtiene el nombre simbólico de un token PHP dado
    • TokyoTyrant::add - Adds to a numeric key
    • TokyoTyrant::connect - Connect to a database
    • TokyoTyrant::connectUri - Connects to a database
    • TokyoTyrant::copy - Copies the database
    • TokyoTyrant::ext - Execute a remote script
    • TokyoTyrant::fwmKeys - Returns the forward matching keys
    • TokyoTyrant::get - The get purpose
    • TokyoTyrant::getIterator - Get an iterator
    • TokyoTyrant::num - Number of records in the database
    • TokyoTyrant::out - Removes records
    • TokyoTyrant::put - Puts values
    • TokyoTyrant::putCat - Concatenates to a record
    • TokyoTyrant::putKeep - Puts a record
    • TokyoTyrant::putNr - Puts value
    • TokyoTyrant::putShl - Concatenates to a record
    • TokyoTyrant::restore - Restore the database
    • TokyoTyrant::setMaster - Set the replication master
    • TokyoTyrant::size - Returns the size of the value
    • TokyoTyrant::stat - Get statistics
    • TokyoTyrant::sync - Synchronize the database
    • TokyoTyrant::tune - Tunes connection values
    • TokyoTyrant::vanish - Empties the database
    • TokyoTyrant::__construct - Construct a new TokyoTyrant object
    • TokyoTyrantIterator::current - Get the current value
    • TokyoTyrantIterator::key - Returns the current key
    • TokyoTyrantIterator::next - Move to next key
    • TokyoTyrantIterator::rewind - Rewinds the iterator
    • TokyoTyrantIterator::valid - Rewinds the iterator
    • TokyoTyrantIterator::__construct - Construct an iterator
    • TokyoTyrantQuery::addCond - Adds a condition to the query
    • TokyoTyrantQuery::count - Counts records
    • TokyoTyrantQuery::current - Returns the current element
    • TokyoTyrantQuery::hint - Get the hint string of the query
    • TokyoTyrantQuery::key - Returns the current key
    • TokyoTyrantQuery::metaSearch - Retrieve records with multiple queries
    • TokyoTyrantQuery::next - Moves the iterator to next entry
    • TokyoTyrantQuery::out - Removes records based on query
    • TokyoTyrantQuery::rewind - Rewinds the iterator
    • TokyoTyrantQuery::search - Searches records
    • TokyoTyrantQuery::setLimit - Limit results
    • TokyoTyrantQuery::setOrder - Orders results
    • TokyoTyrantQuery::valid - Checks the validity of current item
    • TokyoTyrantQuery::__construct - Construct a new query
    • TokyoTyrantTable::add - Adds a record
    • TokyoTyrantTable::genUid - Generate unique id
    • TokyoTyrantTable::get - Get a row
    • TokyoTyrantTable::getIterator - Get an iterator
    • TokyoTyrantTable::getQuery - Get a query object
    • TokyoTyrantTable::out - Remove records
    • TokyoTyrantTable::put - Store a row
    • TokyoTyrantTable::putCat - Concatenates to a row
    • TokyoTyrantTable::putKeep - Put a new record
    • TokyoTyrantTable::putNr - Puts value
    • TokyoTyrantTable::putShl - Concatenates to a record
    • TokyoTyrantTable::setIndex - Sets index
    • touch - Establece el momento de acceso y modificación de un archivo
    • trader_acos - Arcocoseno trigonométrico de vectores
    • trader_ad - Línea A/D Chaikin
    • trader_add - Suma aritmética de vectores
    • trader_adosc - Oscilador A/D Chaikin
    • trader_adx - Índice de movimiento direccional medio
    • trader_adxr - Tasación del índice de movimiento direccional medio
    • trader_apo - Oscilador de precio absoluto
    • trader_aroon - Aroon
    • trader_aroonosc - Oscilador Aroon
    • trader_asin - Arcoseno trigonométrico de vectores
    • trader_atan - Arcotangente trigonométrica de vectores
    • trader_atr - Rango verdadero medio
    • trader_avgprice - Precio medio
    • trader_bbands - Bandas de Bollinger
    • trader_beta - Beta
    • trader_bop - Equilibrio de poder
    • trader_cci - Índice de Canal de Comodidad
    • trader_cdl2crows - Dos Cuervos
    • trader_cdl3blackcrows - Tres Cuervos Negros
    • trader_cdl3inside - Tres Velas Interiores Alcistas/Bajistas
    • trader_cdl3linestrike - Triple Golpe
    • trader_cdl3outside - Tres Velas Exteriores Alcistas/Bajistas
    • trader_cdl3starsinsouth - Tres Estrellas en el Sur
    • trader_cdl3whitesoldiers - Tres Soldados Blancos Avanzando
    • trader_cdlabandonedbaby - Bebé Abandonado
    • trader_cdladvanceblock - Avance en Bloque
    • trader_cdlbelthold - Belt-hold
    • trader_cdlbreakaway - Escape
    • trader_cdlclosingmarubozu - Vela Cerrada Marubozu
    • trader_cdlconcealbabyswall - Pequeña Golondrina Escondida
    • trader_cdlcounterattack - Contraataque
    • trader_cdldarkcloudcover - Cubierta de Nube Oscura
    • trader_cdldoji - Doji
    • trader_cdldojistar - Estrella Doji
    • trader_cdldragonflydoji - Doji Libélula
    • trader_cdlengulfing - Patrón envolvente
    • trader_cdleveningdojistar - Estrella Vespertina Doji
    • trader_cdleveningstar - Estrella de Atardecer
    • trader_cdlgapsidesidewhite - Velas blancas paralelas de hueco alcista/bajista
    • trader_cdlgravestonedoji - Doji Lápida
    • trader_cdlhammer - Martillo
    • trader_cdlhangingman - Hombre Colgado
    • trader_cdlharami - Patrón Harami
    • trader_cdlharamicross - Patrón Cruz Harami
    • trader_cdlhighwave - Vela de Onda Alta
    • trader_cdlhikkake - Patrón Hikkake
    • trader_cdlhikkakemod - Patrón Hikkake Modificado
    • trader_cdlhomingpigeon - Paloma Mensajera
    • trader_cdlidentical3crows - Tres Cuervos Idénticos
    • trader_cdlinneck - Patrón Formación en el cuello
    • trader_cdlinvertedhammer - Martilllo Invertido
    • trader_cdlkicking - Patada
    • trader_cdlkickingbylength - Patada - alza/baja determinada por el marubozu más largo
    • trader_cdlladderbottom - Suelo de escalera
    • trader_cdllongleggeddoji - Doji Zancudo
    • trader_cdllongline - Vela de Línea Larga
    • trader_cdlmarubozu - Marubozu
    • trader_cdlmatchinglow - Mínimos coincidentes
    • trader_cdlmathold - Mat Hold
    • trader_cdlmorningdojistar - Lucero del Alba Doji
    • trader_cdlmorningstar - Lucero del Alba
    • trader_cdlonneck - Patrón Sobre el cuello
    • trader_cdlpiercing - Patrón penetrante
    • trader_cdlrickshawman - Calesero
    • trader_cdlrisefall3methods - Triple Formación Alcista/Bajista
    • trader_cdlseparatinglines - Lineas Separadas
    • trader_cdlshootingstar - Estrella Fugaz
    • trader_cdlshortline - Vela de Línea Corta
    • trader_cdlspinningtop - Peonza
    • trader_cdlstalledpattern - Patrón Añejo
    • trader_cdlsticksandwich - Bocadillo
    • trader_cdltakuri - Takuri (Libélula Doji con sombra muy larga)
    • trader_cdltasukigap - Hueco Tasuki
    • trader_cdlthrusting - Patrón de empuje
    • trader_cdltristar - Patrón de tres estrellas
    • trader_cdlunique3river - Tres ríos únicos
    • trader_cdlupsidegap2crows - Dos Cuervos tras un Huevo al Alza
    • trader_cdlxsidegap3methods - Métodos de Tres Huevos al Alza/Baja
    • trader_ceil - Redondeo hacia arriba de vectores
    • trader_cmo - Oscilador de momento de Chande
    • trader_correl - Coeficiente de correlación de Pearson (r)
    • trader_cos - Coseno trigonométrico de vectores
    • trader_cosh - Coseno hiperbólico de un vector
    • trader_dema - Media móvil exponencial doble
    • trader_div - División aritmética de vectores
    • trader_dx - Índice de movimiento direccional
    • trader_ema - Media móvil exponencial
    • trader_errno - Obtener el código de error
    • trader_exp - Exponencial aritmética de vectores
    • trader_floor - Redondeo hacia abajo de vectores
    • trader_get_compat - Obtiene el modo de compatibilidad
    • trader_get_unstable_period - Obtiene el periodo inestable
    • trader_ht_dcperiod - Transformación de Hilbert - Período de ciclo dominante
    • trader_ht_dcphase - Transformación de Hilbert - Fase de ciclo dominante
    • trader_ht_phasor - Transformación de Hilbert - Componentes de un fasor
    • trader_ht_sine - Transformación de Hilbert - Sinusoide
    • trader_ht_trendline - Transformación de Hilbert - Línea de tendencia instantánea
    • trader_ht_trendmode - Transformación de Hilbert - Tendencia vs Modo de ciclo
    • trader_kama - Media móvil adaptativa de Kaufman
    • trader_linearreg - Regresión lineal
    • trader_linearreg_angle - Ángulo de regresión lineal
    • trader_linearreg_intercept - Intercepción de regresión lineal
    • trader_linearreg_slope - Pendiente de regresión lineal
    • trader_ln - Logaritmo natural de vectores
    • trader_log10 - Logaritmo en base 10 de vectores
    • trader_ma - Media móvil
    • trader_macd - Convergencia/divergencia de la media móvil
    • trader_macdext - MACD con tipo MA controlable
    • trader_macdfix - Convergencia/divergencia fija 12/26 de la media móvil
    • trader_mama - Media móvil adaptativa MESA
    • trader_mavp - Media móvil con periodo variable
    • trader_max - Valor mayor sobre un periodo especificado
    • trader_maxindex - Índice del valor mayor sobre un periodo especificado
    • trader_medprice - Precio medio
    • trader_mfi - Índice de flujo de dinero
    • trader_midpoint - Punto medio sobre un periodo
    • trader_midprice - Precio de punto medio sobre un periodo
    • trader_min - Valor más bajo sobre un periodo especificado
    • trader_minindex - Índice del valor más bajo sobre un periodo especificado
    • trader_minmax - Valores más altos y bajos sobre un periodo especificado
    • trader_minmaxindex - Índices de los valores más bajos y altos sobre un periodo especificado
    • trader_minus_di - Indicador direccional menos
    • trader_minus_dm - Movimiento direccional menos
    • trader_mom - Momentum
    • trader_mult - Multiplicación aritmética de vectores
    • trader_natr - Rango verdadero de la media normalizada
    • trader_obv - Volumen sobre balance
    • trader_plus_di - Indicador direccional más
    • trader_plus_dm - Movimiento direccional más
    • trader_ppo - Oscilador de precio porcentual
    • trader_roc - Ritmo de cambio : ((precio/precioAnterior)-1)*100
    • trader_rocp - Porcentaje del ritmo de cabio: (precio-precioAnterior)/precioAnterior
    • trader_rocr - Ratio del ritmo de cambio: (precio/precioAnterior)
    • trader_rocr100 - Ratio del ritmo de cambio en escala 100: (precio/precioAnterior)*100
    • trader_rsi - Índice de fuerza relativa
    • trader_sar - Sistema parabólico
    • trader_sarext - Sistema parabólico - Extendido
    • trader_set_compat - Establece el modo de compatibilidad
    • trader_set_unstable_period - Establece el periodo inestable
    • trader_sin - Seno trigonométrico de vectores
    • trader_sinh - Seno hiperbólico de vectores
    • trader_sma - Media móvil simple
    • trader_sqrt - Raíz cuadrada de vectores
    • trader_stddev - Desviación estándar
    • trader_stoch - Estocástico
    • trader_stochf - Estocástico rápido
    • trader_stochrsi - Índice de fuerza relativa estocástica
    • trader_sub - Sustracción artimética de vectores
    • trader_sum - Sumatorio
    • trader_t3 - Media móvil exponencial triple (T3)
    • trader_tan - Tangente trigonométrica de vectores
    • trader_tanh - Tangente hiperbólica trigonométrica de vectores
    • trader_tema - Media móvil exponencial triple
    • trader_trange - Rango verdadero
    • trader_trima - Media móvil triangular
    • trader_trix - Ritmo de cambio de 1 día (RDC) de una MME suave triple
    • trader_tsf - Previsión de series de tiempo
    • trader_typprice - Precio típico
    • trader_ultosc - Oscilador final
    • trader_var - Varianza
    • trader_wclprice - Precio de cierre ponderado
    • trader_willr - %R de Williams
    • trader_wma - Media móvil ponderada
    • trait_exists - Comprobar si el trait existe
    • Transliterator::create - Crear un transliterador
    • Transliterator::createFromRules - Crear un transliterador desdes normas
    • Transliterator::createInverse - Cerar una transliteración inversa
    • Transliterator::getErrorCode - Obtener el código del último error
    • Transliterator::getErrorMessage - Obtener el mensaje del último error
    • Transliterator::listIDs - Obtener los IDs de los transliterardores
    • Transliterator::transliterate - Transliterar una cadena
    • Transliterator::__construct - Constructor privado para denegar la instanciación
    • trigger_error - Generar un mensaje de error/advertencia/aviso de nivel de usuario
    • trim - Elimina espacio en blanco (u otro tipo de caracteres) del inicio y el final de la cadena
  • u
    • uasort - Ordena un array con una función de comparación definida por el usuario y mantiene la asociación de índices
    • ucfirst - Convierte el primer caracter de una cadena a mayúsculas
    • UConverter::convert - Convertir un string de un juego de caracteres a otro
    • UConverter::fromUCallback - Función de retrollamada "from" predeterminada
    • UConverter::getAliases - Obtener los alias del nombre dado
    • UConverter::getAvailable - Obtener los nombres canónicos de los convertidores disponibles
    • UConverter::getDestinationEncoding - Obtener la codificación de destino
    • UConverter::getDestinationType - Obtener el tipo del convertidor de destino
    • UConverter::getErrorCode - Obtener el código del último error del objeto
    • UConverter::getErrorMessage - Obtener el último mensaje de error del objeto
    • UConverter::getSourceEncoding - Obtener la codificación de origen
    • UConverter::getSourceType - Obtener el tipo de convertidor de origen
    • UConverter::getStandards - Obtener los estándares asociados a los nombres de los convertidores
    • UConverter::getSubstChars - Obtener los caracteres de sustitución
    • UConverter::reasonText - Obtener la representación de string de la razón de la retrollamada
    • UConverter::setDestinationEncoding - Establecer la codificación destino
    • UConverter::setSourceEncoding - Establecer la codificación origen
    • UConverter::setSubstChars - Establecer los caracteres de sustitución
    • UConverter::toUCallback - Función de retrollamada "to" predeterminada
    • UConverter::transcode - Convertir un string de un juego de caracteres a otro
    • UConverter::__construct - Crea un objeto UConverter
    • ucwords - Convierte a mayúsculas el primer caracter de cada palabra de una cadena
    • UI\Area::onDraw - Draw Callback
    • UI\Area::onKey - Key Callback
    • UI\Area::onMouse - Mouse Callback
    • UI\Area::redraw - Redraw Area
    • UI\Area::scrollTo - Area Scroll
    • UI\Area::setSize - Set Size
    • UI\Control::destroy - Destroy Control
    • UI\Control::disable - Disable Control
    • UI\Control::enable - Enable Control
    • UI\Control::getParent - Get Parent Control
    • UI\Control::getTopLevel - Get Top Level
    • UI\Control::hide - Hide Control
    • UI\Control::isEnabled - Determine if Control is enabled
    • UI\Control::isVisible - Determine if Control is visible
    • UI\Control::setParent - Set Parent Control
    • UI\Control::show - Control Show
    • UI\Controls\Box::append - Append Control
    • UI\Controls\Box::delete - Delete Control
    • UI\Controls\Box::getOrientation - Get Orientation
    • UI\Controls\Box::isPadded - Padding Detection
    • UI\Controls\Box::setPadded - Set Padding
    • UI\Controls\Box::__construct - Construct a new Box
    • UI\Controls\Button::getText - Get Text
    • UI\Controls\Button::onClick - Click Handler
    • UI\Controls\Button::setText - Set Text
    • UI\Controls\Button::__construct - Construct a new Button
    • UI\Controls\Check::getText - Get Text
    • UI\Controls\Check::isChecked - Checked Detection
    • UI\Controls\Check::onToggle - Toggle Callback
    • UI\Controls\Check::setChecked - Set Checked
    • UI\Controls\Check::setText - Set Text
    • UI\Controls\Check::__construct - Construct a new Check
    • UI\Controls\ColorButton::getColor - Get Color
    • UI\Controls\ColorButton::onChange - Change Handler
    • UI\Controls\ColorButton::setColor - Set Color
    • UI\Controls\Combo::append - Append Option
    • UI\Controls\Combo::getSelected - Get Selected Option
    • UI\Controls\Combo::onSelected - Selected Handler
    • UI\Controls\Combo::setSelected - Set Selected Option
    • UI\Controls\EditableCombo::append - Append Option
    • UI\Controls\EditableCombo::getText - Get Text
    • UI\Controls\EditableCombo::onChange - Change Handler
    • UI\Controls\EditableCombo::setText - Set Text
    • UI\Controls\Entry::getText - Get Text
    • UI\Controls\Entry::isReadOnly - Detect Read Only
    • UI\Controls\Entry::onChange - Change Handler
    • UI\Controls\Entry::setReadOnly - Set Read Only
    • UI\Controls\Entry::setText - Set Text
    • UI\Controls\Entry::__construct - Construct a new Entry
    • UI\Controls\Form::append - Append Control
    • UI\Controls\Form::delete - Delete Control
    • UI\Controls\Form::isPadded - Padding Detection
    • UI\Controls\Form::setPadded - Set Padding
    • UI\Controls\Grid::append - Append Control
    • UI\Controls\Grid::isPadded - Padding Detection
    • UI\Controls\Grid::setPadded - Set Padding
    • UI\Controls\Group::append - Append Control
    • UI\Controls\Group::getTitle - Get Title
    • UI\Controls\Group::hasMargin - Margin Detection
    • UI\Controls\Group::setMargin - Set Margin
    • UI\Controls\Group::setTitle - Set Title
    • UI\Controls\Group::__construct - Construct a new Group
    • UI\Controls\Label::getText - Get Text
    • UI\Controls\Label::setText - Set Text
    • UI\Controls\Label::__construct - Construct a new Label
    • UI\Controls\MultilineEntry::append - Append Text
    • UI\Controls\MultilineEntry::getText - Get Text
    • UI\Controls\MultilineEntry::isReadOnly - Read Only Detection
    • UI\Controls\MultilineEntry::onChange - Change Handler
    • UI\Controls\MultilineEntry::setReadOnly - Set Read Only
    • UI\Controls\MultilineEntry::setText - Set Text
    • UI\Controls\MultilineEntry::__construct - Construct a new Multiline Entry
    • UI\Controls\Picker::__construct - Construct a new Picker
    • UI\Controls\Progress::getValue - Get Value
    • UI\Controls\Progress::setValue - Set Value
    • UI\Controls\Radio::append - Append Option
    • UI\Controls\Radio::getSelected - Get Selected Option
    • UI\Controls\Radio::onSelected - Selected Handler
    • UI\Controls\Radio::setSelected - Set Selected Option
    • UI\Controls\Separator::__construct - Construct a new Separator
    • UI\Controls\Slider::getValue - Get Value
    • UI\Controls\Slider::onChange - Change Handler
    • UI\Controls\Slider::setValue - Set Value
    • UI\Controls\Slider::__construct - Construct a new Slider
    • UI\Controls\Spin::getValue - Get Value
    • UI\Controls\Spin::onChange - Change Handler
    • UI\Controls\Spin::setValue - Set Value
    • UI\Controls\Spin::__construct - Construct a new Spin
    • UI\Controls\Tab::append - Append Page
    • UI\Controls\Tab::delete - Delete Page
    • UI\Controls\Tab::hasMargin - Margin Detection
    • UI\Controls\Tab::insertAt - Insert Page
    • UI\Controls\Tab::pages - Page Count
    • UI\Controls\Tab::setMargin - Set Margin
    • UI\Draw\Brush::getColor - Get Color
    • UI\Draw\Brush::setColor - Set Color
    • UI\Draw\Brush::__construct - Construct a new Brush
    • UI\Draw\Brush\Gradient::addStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop - Stop Manipulation
    • UI\Draw\Brush\LinearGradient::__construct - Construct a Linear Gradient
    • UI\Draw\Brush\RadialGradient::__construct - Construct a new Radial Gradient
    • UI\Draw\Color::getChannel - Manipulación de color
    • UI\Draw\Color::setChannel - Manipulación de color
    • UI\Draw\Color::__construct - Construye un nuevo color
    • UI\Draw\Matrix::invert - Invertir matriz
    • UI\Draw\Matrix::isInvertible - Detección de invertido
    • UI\Draw\Matrix::multiply - Multiplica la matriz
    • UI\Draw\Matrix::rotate - Rota la matriz
    • UI\Draw\Matrix::scale - Escala la Matriz
    • UI\Draw\Matrix::skew - Inclina la Matriz
    • UI\Draw\Matrix::translate - Traduce la matriz
    • UI\Draw\Path::addRectangle - Dibuja un rectángulo
    • UI\Draw\Path::arcTo - Dibuja un arco
    • UI\Draw\Path::bezierTo - Draw Bezier Curve
    • UI\Draw\Path::closeFigure - Cerrar Figura
    • UI\Draw\Path::end - Finalizar Ruta
    • UI\Draw\Path::lineTo - Dibuja una línea
    • UI\Draw\Path::newFigure - Dibuja figura
    • UI\Draw\Path::newFigureWithArc - Dibuja figura con arco
    • UI\Draw\Path::__construct - Construye una nueva ruta
    • UI\Draw\Pen::clip - Clip a Path
    • UI\Draw\Pen::fill - Llena una ruta
    • UI\Draw\Pen::restore - Restaura
    • UI\Draw\Pen::save - Guarda
    • UI\Draw\Pen::stroke - Traza una ruta
    • UI\Draw\Pen::transform - Transformación de la matriz
    • UI\Draw\Pen::write - Dibuja el texto en el punto
    • UI\Draw\Stroke::getCap - Get Line Cap
    • UI\Draw\Stroke::getJoin - Obtiene la unión de línea
    • UI\Draw\Stroke::getMiterLimit - Obtiene el límite de inglete
    • UI\Draw\Stroke::getThickness - Obtiene el grosor
    • UI\Draw\Stroke::setCap - Set Line Cap
    • UI\Draw\Stroke::setJoin - Establece la línea de unión
    • UI\Draw\Stroke::setMiterLimit - Establece el límite de ingletes
    • UI\Draw\Stroke::setThickness - Establece el grosor
    • UI\Draw\Stroke::__construct - Construye un nuevo trazo
    • UI\Draw\Text\Font::getAscent - Métricas de la fuente
    • UI\Draw\Text\Font::getDescent - Métricas de la fuente
    • UI\Draw\Text\Font::getLeading - Métricas de la fuente
    • UI\Draw\Text\Font::getUnderlinePosition - Métricas de la fuente
    • UI\Draw\Text\Font::getUnderlineThickness - Métricas de la fuente
    • UI\Draw\Text\Font::__construct - Construye una nueva fuente
    • UI\Draw\Text\Font\Descriptor::getFamily - Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic - Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize - Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch - Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight - Weight Detection
    • UI\Draw\Text\Font\Descriptor::__construct - Construct a new Font Descriptor
    • UI\Draw\Text\Font\fontFamilies - Recuperar las familias de fuentes
    • UI\Draw\Text\Layout::setColor - Establece el color
    • UI\Draw\Text\Layout::setWidth - Establece el ancho
    • UI\Draw\Text\Layout::__construct - Construir un nuevo diseño de texto
    • UI\Executor::kill - Stop Executor
    • UI\Executor::onExecute - Execution Callback
    • UI\Executor::setInterval - Interval Manipulation
    • UI\Executor::__construct - Construct a new Executor
    • UI\Menu::append - Añade elemento de menú
    • UI\Menu::appendAbout - Añade elemento de menú Acerca de
    • UI\Menu::appendCheck - Añade un elemento de menú comprobable
    • UI\Menu::appendPreferences - Añade elemento de menú de preferencias
    • UI\Menu::appendQuit - Añade elemento de menú salir
    • UI\Menu::appendSeparator - Añade separador de elementos del menú
    • UI\Menu::__construct - Construye un nuevo menú
    • UI\MenuItem::disable - Desactiva elemento del menú
    • UI\MenuItem::enable - Activa elemento de menú
    • UI\MenuItem::isChecked - Detecta Marcado
    • UI\MenuItem::onClick - Llamada de retorno On Click
    • UI\MenuItem::setChecked - Establece marcado
    • UI\Point::at - Tamaño de coerción
    • UI\Point::getX - Recupera X
    • UI\Point::getY - Recupera Y
    • UI\Point::setX - Establece X
    • UI\Point::setY - Establece Y
    • UI\Point::__construct - Construye un nuevo punto
    • UI\quit - Quit UI Loop
    • UI\run - Enter UI Loop
    • UI\Size::getHeight - Recupera la altura
    • UI\Size::getWidth - Recupera el ancho
    • UI\Size::of - Punto de coerción
    • UI\Size::setHeight - Establece la altura
    • UI\Size::setWidth - Establece el ancho
    • UI\Size::__construct - Construye un nuevo tamaño
    • UI\Window::add - Añade un control
    • UI\Window::error - Mostrar cuadro de error
    • UI\Window::getSize - Obtiene el tamaño de la ventana
    • UI\Window::getTitle - Obtiene el título
    • UI\Window::hasBorders - Detección del Borde
    • UI\Window::hasMargin - Detección de Margen
    • UI\Window::isFullScreen - Detección de pantalla completa
    • UI\Window::msg - Mostrar Cuadro de Mensajes
    • UI\Window::onClosing - Cierre de la devolución de llamada
    • UI\Window::open - Abrir Diálogo
    • UI\Window::save - Guarda Diálogo
    • UI\Window::setBorders - Uso de Bordes
    • UI\Window::setFullScreen - Uso de la pantalla completa
    • UI\Window::setMargin - Uso del Margen
    • UI\Window::setSize - Establece Tamaño
    • UI\Window::setTitle - Título de la Vetana
    • UI\Window::__construct - Construye una nueva ventana
    • uksort - Ordena un array según sus claves usando una función de comparación definida por el usuario
    • umask - Cambia la máscara de usuario actual
    • uniqid - Generar un ID único
    • unixtojd - Convertir una fecha Unix en una Fecha Juliana
    • unlink - Borra un fichero
    • unpack - Desempaqueta datos de una cadena binaria
    • unregister_tick_function - Dejar de registrar una función para su ejecución en cada tick
    • unserialize - Crea un valor PHP a partir de una representación almacenada
    • unset - Destruye una variable especificada
    • untaint - Sanea un string
    • uopz_add_function - Adds non-existent function or method
    • uopz_allow_exit - Allows control over disabled exit opcode
    • uopz_backup - Backup a function
    • uopz_compose - Compose a class
    • uopz_copy - Copy a function
    • uopz_delete - Delete a function
    • uopz_del_function - Deletes previously added function or method
    • uopz_extend - Extend a class at runtime
    • uopz_flags - Get or set flags on function or class
    • uopz_function - Creates a function at runtime
    • uopz_get_exit_status - Retrieve the last set exit status
    • uopz_get_hook - Gets previously set hook on function or method
    • uopz_get_mock - Get the current mock for a class
    • uopz_get_property - Gets value of class or instance property
    • uopz_get_return - Gets a previous set return value for a function
    • uopz_get_static - Gets the static variables from function or method scope
    • uopz_implement - Implements an interface at runtime
    • uopz_overload - Overload a VM opcode
    • uopz_redefine - Redefine a constant
    • uopz_rename - Rename a function at runtime
    • uopz_restore - Restore a previously backed up function
    • uopz_set_hook - Sets hook to execute when entering a function or method
    • uopz_set_mock - Use mock instead of class for new objects
    • uopz_set_property - Sets value of existing class or instance property
    • uopz_set_return - Provide a return value for an existing function
    • uopz_set_static - Sets the static variables in function or method scope
    • uopz_undefine - Undefine a constant
    • uopz_unset_hook - Removes previously set hook on function or method
    • uopz_unset_mock - Unset previously set mock
    • uopz_unset_return - Unsets a previously set return value for a function
    • urldecode - Decodifica una cadena cifrada como URL
    • urlencode - Codifica como URL una cadena
    • user_error - Alias de trigger_error
    • use_soap_error_handler - Establecer si se desea utilizar el manejador de errores de SOAP
    • usleep - Retrasar la ejecución en microsegundos
    • usort - Ordena un array según sus valores usando una función de comparación definida por el usuario
    • utf8_decode - Convierte una cadena con los caracteres codificados ISO-8859-1 con UTF-8 a un sencillo byte ISO-8859-1
    • utf8_encode - Codifica un string ISO-8859-1 a UTF-8
  • v
    • V8Js::executeString - Execute a string as Javascript code
    • V8Js::getExtensions - Devolver un array de extensiones registradas
    • V8Js::getPendingException - Return pending uncaught Javascript exception
    • V8Js::registerExtension - Register Javascript extensions for V8Js
    • V8Js::__construct - Construct a new V8Js object
    • V8JsException::getJsFileName - El propósito getJsFileName
    • V8JsException::getJsLineNumber - El propósito getJsLineNumber
    • V8JsException::getJsSourceLine - El propósito getJsSourceLine
    • V8JsException::getJsTrace - El propósito getJsTrace
    • variant_abs - Devuelve el valor absoluto de una variante
    • variant_add - "Suma" dos variantes y devuelve el resultado
    • variant_and - Realiza una operación AND a nivel de bits entre dos variantes
    • variant_cast - Convertir una variante en un nuevo objeto variante de otro tipo
    • variant_cat - Concatena dos valores de variantes y devuelve el resultado
    • variant_cmp - Compara dos variantes
    • variant_date_from_timestamp - Devuelve una representación de variante de fecha de una fecha Unix
    • variant_date_to_timestamp - Convierte un valor de una variante de fecha/hora en una fecha Unix
    • variant_div - Devuelve el resultado de dividir dos variantes
    • variant_eqv - Realiza una equivalencia a nivel de bits en dos variantes
    • variant_fix - Devuelve la parte entera de una variante
    • variant_get_type - Devuelve el tipo de un objeto variante
    • variant_idiv - Convierte variantes a enteros y después devuelve el resultado dividiéndolos
    • variant_imp - Realiza una implicación a nivel de bits de dos variantes
    • variant_int - Devuelve la parte entera de una variante
    • variant_mod - Divide dos variantes y devuelve sólo el resto
    • variant_mul - Multiplica los valores de dos variantes
    • variant_neg - Realiza una negación lógica de una variante
    • variant_not - Realiza una negación NOT a nivel de bits en una variante
    • variant_or - Realiza una disyunción lógica de dos variantes
    • variant_pow - Devuelve el resultado de realizar la exponenciación con dos variantes
    • variant_round - Redondea una variante al número de lugares decimales especificado
    • variant_set - Asigna un nuevo valor para un objeto variante
    • variant_set_type - Convierte una variante en otro tipo "in situ"
    • variant_sub - Resta el valor de la variante derecha del valor de la varienta izquierda
    • variant_xor - Realiza una exclución lógica de dos variantes
    • VarnishAdmin::auth - Autentificar en una instancia de varnish
    • VarnishAdmin::ban - Prohibe URLs usando una expresión VCL
    • VarnishAdmin::banUrl - Prohibe una URL usando una expresión VCL
    • VarnishAdmin::clearPanic - Limpia mensajes de pánico de la instancia varnish
    • VarnishAdmin::connect - Conectarse a una interfaz de administración de instancias de varnish
    • VarnishAdmin::disconnect - Desconecta interfaz de administración de la instancia de varnish
    • VarnishAdmin::getPanic - Obtener el último mensaje de pánico en una instancia varnish
    • VarnishAdmin::getParams - Busca los parámetros de configuración de la instancia varnish actual
    • VarnishAdmin::isRunning - Comprueba si el proceso varnish esclavo está actualmente en marcha
    • VarnishAdmin::setCompat - Establece el parámetro de configuración de la clase compacta
    • VarnishAdmin::setHost - Establece el parámetro de configuración del host de la clase
    • VarnishAdmin::setIdent - Establece el parámetro de configuración de la identificación de la clase
    • VarnishAdmin::setParam - Establece los parámetros de configuración en la instancia varnish actual
    • VarnishAdmin::setPort - Establece el parámetro de configuración del puerto de clase
    • VarnishAdmin::setSecret - Establece los parámetros secretos de configuración de la clase
    • VarnishAdmin::setTimeout - Configura el parámetro de tiempo de espera de la clase
    • VarnishAdmin::start - Iniciar el proceso de varnish
    • VarnishAdmin::stop - Detener el proceso de varnish
    • VarnishAdmin::__construct - VarnishAdmin constructor
    • VarnishLog::getLine - Obtiene la siguiente línea de registro
    • VarnishLog::getTagName - Obtener la etiqueta de registro representada por su índice
    • VarnishLog::__construct - Constructor de Varnishlog
    • VarnishStat::getSnapshot - Obtener la instantánea actual de las estadísticas de instancia varnish
    • VarnishStat::__construct - Constructor VarnishStat
    • var_dump - Muestra información sobre una variable
    • var_export - Imprime o devuelve una representación string de una variable analizable
    • version_compare - Compara dos números de versiones estandarizados de PHP
    • vfprintf - Escribe un string con formato en un flujo
    • virtual - Realiza una sub-petición de Apache
    • vprintf - Muestra una cadena con formato
    • vsprintf - Devuelve una cadena con formato
    • Vtiful\Kernel\Excel::addSheet - Vtiful\Kernel\Excel addSheet
    • Vtiful\Kernel\Excel::autoFilter - Vtiful\Kernel\Excel autoFilter
    • Vtiful\Kernel\Excel::constMemory - Vtiful\Kernel\Excel constMemory
    • Vtiful\Kernel\Excel::data - Vtiful\Kernel\Excel data
    • Vtiful\Kernel\Excel::fileName - Vtiful\Kernel\Excel fileName
    • Vtiful\Kernel\Excel::getHandle - Vtiful\Kernel\Excel getHandle
    • Vtiful\Kernel\Excel::header - Vtiful\Kernel\Excel header
    • Vtiful\Kernel\Excel::insertFormula - Vtiful\Kernel\Excel insertFormula
    • Vtiful\Kernel\Excel::insertImage - Vtiful\Kernel\Excel insertImage
    • Vtiful\Kernel\Excel::insertText - Vtiful\Kernel\Excel insertText
    • Vtiful\Kernel\Excel::mergeCells - Vtiful\Kernel\Excel mergeCells
    • Vtiful\Kernel\Excel::output - Vtiful\Kernel\Excel output
    • Vtiful\Kernel\Excel::setColumn - Vtiful\Kernel\Excel setColumn
    • Vtiful\Kernel\Excel::setRow - Vtiful\Kernel\Excel setRow
    • Vtiful\Kernel\Excel::__construct - Vtiful\Kernel\Excel constructor
    • Vtiful\Kernel\Format::align - Vtiful\Kernel\Format align
    • Vtiful\Kernel\Format::bold - Vtiful\Kernel\Format bold
    • Vtiful\Kernel\Format::italic - Vtiful\Kernel\Format italic
    • Vtiful\Kernel\Format::underline - Vtiful\Kernel\Format underline
  • w
    • wddx_add_vars - Agrega variables a un paquete WDDX con un ID específico
    • wddx_deserialize - Deserializa un packet WDDX
    • wddx_packet_end - Finaliza un paquete WDDX con un ID específico
    • wddx_packet_start - Inicia un nuevo paquete WDDX con una estructura a dentro
    • wddx_serialize_value - Serializa una simple valor dentro de un paquete WDDX
    • wddx_serialize_vars - Serializa variables en un paquete WDDX
    • WeakMap::count - Cuenta el número de entradas vivas de un mapa
    • WeakMap::current - Devuelve el valor actual de la iteración
    • WeakMap::key - Devuelve la clave actual de la iteración
    • WeakMap::next - Avanza al siguiente elemento del mapa
    • WeakMap::offsetExists - Comprueba si un cierto objeto está en un mapa
    • WeakMap::offsetGet - Devuelve el valor apuntado por un cierto objeto
    • WeakMap::offsetSet - Actualiza el mapa con un nuevo par clave-valor
    • WeakMap::offsetUnset - Elimina una entrada del mapa
    • WeakMap::rewind - Sitúa el iterador al comienzo del mapa
    • WeakMap::valid - Devuelve si el iterador aún está sobre un elemento válido de un mapa
    • WeakMap::__construct - Construye un nuevo mapa
    • Weakref::acquire - Adquiere una referencia fuerte de un objeto
    • Weakref::get - Devuelve el objeto apuntado por una referencia débil
    • Weakref::release - Libera una referencia previmente adquirida
    • Weakref::valid - Comprueba si el objeto referenciado aún existe
    • Weakref::__construct - Construye una nueva referencia débil
    • WeakReference::create - Crea una nueva referencia débil
    • WeakReference::get - Obtiene un objeto débilmente referenciado
    • WeakReference::__construct - Constructor que no permite la instanciación
    • win32_continue_service - Reanuda un servicio pausado
    • win32_create_service - Crea una nueva entrada de servicio en la base de datos del ACS
    • win32_delete_service - Borra una entrada de servicio de la base de datos del ACS
    • win32_get_last_control_message - Devuelve el último mensaje de control que fue enviado a este servicio
    • win32_pause_service - Pausa un servicio
    • win32_query_service_status - Pregunta sobre el estado de un servicio
    • win32_send_custom_control - Enviar un control personalizado al servicio
    • win32_set_service_exit_code - Define o devuelve el código de salida para el servicio en curso
    • win32_set_service_exit_mode - Define o devuelve el modo de salida para el servicio en curso
    • win32_set_service_status - Actualiza el estado del servicio
    • win32_start_service - Inicia un servicio
    • win32_start_service_ctrl_dispatcher - Registra el script con el ACS, por lo que puede actuar como el servicio con el nombre dado
    • win32_stop_service - Detiene un servicio
    • wincache_fcache_fileinfo - Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo - Recupera información sobre el uso de memoria caché de ficheros
    • wincache_lock - Obtiene un bloqueo exclusivo en una clave dada
    • wincache_ocache_fileinfo - Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo - Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed - Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo - Retrieves information about resolve file path cache
    • wincache_rplist_meminfo - Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info - Retrieves information about files cached in the session cache
    • wincache_scache_meminfo - Recupera información sobre el uso de memoria caché de sesión
    • wincache_ucache_add - Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas - Compara la variable con el valor antiguo y le asigna un nuevo valor a este
    • wincache_ucache_clear - Elimina todo el contenido de la caché del usuario
    • wincache_ucache_dec - Disminuye el valor asociado a la clave
    • wincache_ucache_delete - Elimina las variables de la memoria caché del usuario
    • wincache_ucache_exists - Comprueba si una variable existe en la caché del usuario
    • wincache_ucache_get - Obtiene una variable almacenada en la caché del usuario
    • wincache_ucache_inc - Incrementa el valor asociado a la clave
    • wincache_ucache_info - Recupera información sobre los datos almacenados en la caché del usuario
    • wincache_ucache_meminfo - Recupera información sobre el uso de memoria caché de usuario
    • wincache_ucache_set - Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock - Libera un bloqueo exclusivo sobre una clave dada
    • wkhtmltox\Image\Converter::convert - Realiza la conversión de la imagen
    • wkhtmltox\Image\Converter::getVersion - Determina la versión del convertidor
    • wkhtmltox\Image\Converter::__construct - Create a new Image converter
    • wkhtmltox\PDF\Converter::add - Añade un objeto para su conversión
    • wkhtmltox\PDF\Converter::convert - Realiza la conversión a PDF
    • wkhtmltox\PDF\Converter::getVersion - Determina la versión del convertidor
    • wkhtmltox\PDF\Converter::__construct - Create a new PDF converter
    • wkhtmltox\PDF\Object::__construct - Create a new PDF Object
    • wordwrap - Ajusta un string hasta un número dado de caracteres
    • Worker::collect - Collect references to completed tasks
    • Worker::getStacked - Gets the remaining stack size
    • Worker::isShutdown - State Detection
    • Worker::isWorking - State Detection
    • Worker::shutdown - Shutdown the worker
    • Worker::stack - Stacking work
    • Worker::unstack - Unstacking work
  • x
    • xattr_get - Obtener un atributo extendido
    • xattr_list - Obtener una lista de atributos extendidos
    • xattr_remove - Elimina un atributo extendido
    • xattr_set - Establece un atributo extendido
    • xattr_supported - Comprueba si soporta los atributos extendidos del sistema de archivos
    • xdiff_file_bdiff - Realiza una diferencia binaria de dos archivos
    • xdiff_file_bdiff_size - Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
    • xdiff_file_bpatch - Parchea un archivo con una diferencia binaria
    • xdiff_file_diff - Hacer un diff unificado de dos archivos
    • xdiff_file_diff_binary - Alias de xdiff_file_bdiff
    • xdiff_file_merge3 - Une 3 archivos en uno
    • xdiff_file_patch - Parchea un archivo con un diff unificado
    • xdiff_file_patch_binary - Alias de xdiff_file_bpatch
    • xdiff_file_rabdiff - Hacer una diferencia binaria de dos archivos utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
    • xdiff_string_bdiff - Hacer una diferencia binaria de dos cadenas
    • xdiff_string_bdiff_size - Lee el tamaño de un archivo creado tras aplicar una diferencia binaria
    • xdiff_string_bpatch - Parchear una cadena con una diferencia binaria
    • xdiff_string_diff - Hacer un diff unificado de dos strings
    • xdiff_string_diff_binary - Alias de xdiff_string_bdiff
    • xdiff_string_merge3 - Unir tres cadenas en una
    • xdiff_string_patch - Parchear una cadena con un diff unificado
    • xdiff_string_patch_binary - Alias de xdiff_string_bpatch
    • xdiff_string_rabdiff - Hacer una diferencia binaria de dos cadenas utilizando el algoritmo polinomial de huella digital (fingerprinting) de Rabin
    • xhprof_disable - Detiene el perfilador xhprof
    • xhprof_enable - Inicia perfil xhprof
    • xhprof_sample_disable - Detiene la muestra del perfilador xhprof
    • xhprof_sample_enable - Iniciar el analisis de XHProf en modo de muestreo
    • XMLDiff\Base::diff - Produce diferencias de dos documentos XML
    • XMLDiff\Base::merge - Produce un nuevo documento XML basado en diferencias
    • XMLDiff\Base::__construct - Constructor
    • XMLDiff\DOM::diff - Diferencia dos objetos DOMDocument
    • XMLDiff\DOM::merge - Produce DOMDocument unido
    • XMLDiff\File::diff - Diferencia dos archivos XML
    • XMLDiff\File::merge - Produce un documento XML unido
    • XMLDiff\Memory::diff - Diferenciar dos documentos XML
    • XMLDiff\Memory::merge - Produce un documento XML unido
    • XMLReader::close - Cierra la entrada del XMLReader
    • XMLReader::expand - Devuelve una copia del actual nodo como un objeto DOM
    • XMLReader::getAttribute - Obtiener el valor del atributo nombrado
    • XMLReader::getAttributeNo - Obtiene el valor de un atributo por el indice
    • XMLReader::getAttributeNs - Obtiene el valor de un atributo por su nombre local y URI
    • XMLReader::getParserProperty - Indica si la porpiedad especificada ha sido establecida
    • XMLReader::isValid - Indica si el documento analizado es válido
    • XMLReader::lookupNamespace - Busca el namespace para un prefijo
    • XMLReader::moveToAttribute - Mueve el cursor a un atributo nombrado
    • XMLReader::moveToAttributeNo - Mueve el cursor a un atributo por su índice
    • XMLReader::moveToAttributeNs - Mover el cursor a un atributo dado
    • XMLReader::moveToElement - Posiciona el cursor en el eleménto padre del actual atributo
    • XMLReader::moveToFirstAttribute - Posiciona el cursor en el primer atributo
    • XMLReader::moveToNextAttribute - Posiciona el cursor en el siguiente atributo
    • XMLReader::next - Mueve el cursor al siguiente nodo saltandose todos los subárboles
    • XMLReader::open - Establece el URI conteniendo el XML a analizar
    • XMLReader::read - Se mueve al siguiente nodo en el documento
    • XMLReader::readInnerXML - Recupera el XML del actual nodo
    • XMLReader::readOuterXML - Recupera el XML del actual nodo, incluyendo él mismo
    • XMLReader::readString - Lee el contenido del nodo actual como string
    • XMLReader::setParserProperty - Establecer las opciones del analizador
    • XMLReader::setRelaxNGSchema - Establece el nomb re del archivo o el URI para un esquema RelaxNG
    • XMLReader::setRelaxNGSchemaSource - Establece los datos contenidos en un esquema RelaxNG
    • XMLReader::setSchema - Valida el documento en contra del XSD
    • XMLReader::XML - Establece el contenido del XML a analizar
    • xmlrpc_decode - Decodifica el XML en los tipos de PHP nativos
    • xmlrpc_decode_request - Decodifica el XML en los tipos de PHP nativos
    • xmlrpc_encode - Genera XML para un valor PHP
    • xmlrpc_encode_request - Genera XML para el requerimiento de un método
    • xmlrpc_get_type - Obtiene el tipo del xmlrpc para un valor PHP
    • xmlrpc_is_fault - Determina si el valor de un arreglo representa una falla del XMLRPC
    • xmlrpc_parse_method_descriptions - Decodifica el XML en una lista de las descripciones del método
    • xmlrpc_server_add_introspection_data - Agrega una documentación introspectiva
    • xmlrpc_server_call_method - Analiza los requerimientos del XML y las llamadas de los métodos
    • xmlrpc_server_create - Crea un servidor xmlrpc
    • xmlrpc_server_destroy - Destruye los recursos del servidor
    • xmlrpc_server_register_introspection_callback - Registra una función PHP para generar la documentación
    • xmlrpc_server_register_method - Registra una función PHP para que el recurso del método coincida con method_name
    • xmlrpc_set_type - Establece el tipo del xmlrpc, base64 o fecha-hora, para un valor de cadena PHP
    • XMLWriter::endAttribute - End attribute
    • XMLWriter::endCdata - End current CDATA
    • XMLWriter::endComment - Create end comment
    • XMLWriter::endDocument - End current document
    • XMLWriter::endDtd - End current DTD
    • XMLWriter::endDtdAttlist - End current DTD AttList
    • XMLWriter::endDtdElement - End current DTD element
    • XMLWriter::endDtdEntity - End current DTD Entity
    • XMLWriter::endElement - End current element
    • XMLWriter::endPi - End current PI
    • XMLWriter::flush - Flush current buffer
    • XMLWriter::fullEndElement - End current element
    • XMLWriter::openMemory - Create new xmlwriter using memory for string output
    • XMLWriter::openUri - Create new xmlwriter using source uri for output
    • XMLWriter::outputMemory - Returns current buffer
    • XMLWriter::setIndent - Toggle indentation on/off
    • XMLWriter::setIndentString - Set string used for indenting
    • XMLWriter::startAttribute - Create start attribute
    • XMLWriter::startAttributeNs - Create start namespaced attribute
    • XMLWriter::startCdata - Create start CDATA tag
    • XMLWriter::startComment - Create start comment
    • XMLWriter::startDocument - Create document tag
    • XMLWriter::startDtd - Create start DTD tag
    • XMLWriter::startDtdAttlist - Create start DTD AttList
    • XMLWriter::startDtdElement - Create start DTD element
    • XMLWriter::startDtdEntity - Create start DTD Entity
    • XMLWriter::startElement - Create start element tag
    • XMLWriter::startElementNs - Create start namespaced element tag
    • XMLWriter::startPi - Create start PI tag
    • XMLWriter::text - Write text
    • XMLWriter::writeAttribute - Write full attribute
    • XMLWriter::writeAttributeNs - Write full namespaced attribute
    • XMLWriter::writeCdata - Write full CDATA tag
    • XMLWriter::writeComment - Write full comment tag
    • XMLWriter::writeDtd - Write full DTD tag
    • XMLWriter::writeDtdAttlist - Write full DTD AttList tag
    • XMLWriter::writeDtdElement - Write full DTD element tag
    • XMLWriter::writeDtdEntity - Write full DTD Entity tag
    • XMLWriter::writeElement - Write full element tag
    • XMLWriter::writeElementNs - Write full namespaced element tag
    • XMLWriter::writePi - Writes a PI
    • XMLWriter::writeRaw - Write a raw XML text
    • xml_error_string - Obtiene la cadena de un error dado en un intérprete XML
    • xml_get_current_byte_index - Obtiene la indexación del byte actual en un intérprete XML
    • xml_get_current_column_number - Obtiene el número de columna actual para un intérprete XML
    • xml_get_current_line_number - Obtiene el número de línea actual para un intérprete XML
    • xml_get_error_code - Obtiene un código de error en un intérprete XML
    • xml_parse - Inicia un intérprete sobre un documento XML
    • xml_parser_create - Crea un intérprete XML
    • xml_parser_create_ns - Crea un analizador XML con soporte para espacios de nombres
    • xml_parser_free - Liberar una analizador XML
    • xml_parser_get_option - Obtiene el valor de las opciones de un intérprete XML
    • xml_parser_set_option - Configura las opciones en un intérprete XML
    • xml_parse_into_struct - Interpreta datos XML en una estructura de array
    • xml_set_character_data_handler - Configura el manejador de los datos de caracteres
    • xml_set_default_handler - Configura el manejador predeterminado
    • xml_set_element_handler - Configura los manejadores para los elementos de inicio y final
    • xml_set_end_namespace_decl_handler - Configura el manejador de declaración de final del namespace
    • xml_set_external_entity_ref_handler - Configura el manejador de referencia a entidades externas
    • xml_set_notation_decl_handler - Configura el manejador de declaraciones de notación
    • xml_set_object - Usa un intérprete XML Parser dentro de un objeto
    • xml_set_processing_instruction_handler - Configura el manejador de instrucciones de proceso (PI)
    • xml_set_start_namespace_decl_handler - Configura el manejador de declaración de inicio del namespace
    • xml_set_unparsed_entity_decl_handler - Configura el manejador de declaración de entidades no analizadas
    • XSLTProcessor::getParameter - Obtiene el valor de un parámetro
    • XSLTProcessor::getSecurityPrefs - Obtiene las preferencias de seguridad
    • XSLTProcessor::hasExsltSupport - Determina si PHP tiene soporte para EXSLT
    • XSLTProcessor::importStylesheet - Importa una hoja de estilos
    • XSLTProcessor::registerPHPFunctions - Activa la capacidad de usar funciones PHP como funciones XSLT
    • XSLTProcessor::removeParameter - Elimina un parámetro
    • XSLTProcessor::setParameter - Establece el valor para uno o varios parámetros
    • XSLTProcessor::setProfiling - Establece el fichero de salida para la información resultado del proceso
    • XSLTProcessor::setSecurityPrefs - Establece las preferencias de seguridad
    • XSLTProcessor::transformToDoc - Transforma en un DOMDocument
    • XSLTProcessor::transformToUri - Transformar a URI
    • XSLTProcessor::transformToXml - Transforma a XML
    • XSLTProcessor::__construct - Crea un nuevo objeto XSLTProcessor
  • y
    • Yac::add - Guardar en caché
    • Yac::delete - Eliminar los artículos de la memoria caché
    • Yac::dump - Volcar cache
    • Yac::flush - Limpiar el caché
    • Yac::get - Recuperar los valores de caché
    • Yac::info - Estado del caché
    • Yac::set - Guardar en el caché
    • Yac::__construct - Constructor
    • Yac::__get - Getter
    • Yac::__set - Setter
    • Yaconf::get - Recuperar un elemento
    • Yaconf::has - Determinar si un elemento existe
    • Yaf_Action_Abstract::execute - Punto de entrada de una acción
    • Yaf_Action_Abstract::getController - Recupera el objeto controlador
    • Yaf_Action_Abstract::getControllerName - Obtener el nombre del controlador
    • Yaf_Application::app - Recuperar una instancia de la clase Application
    • Yaf_Application::bootstrap - Llamar al arranque
    • Yaf_Application::clearLastError - Limpiar la información del último error
    • Yaf_Application::environ - Recuperar el entorno
    • Yaf_Application::execute - Ejecutar una llamada de retorno
    • Yaf_Application::getAppDirectory - Obtener el directorio de la aplicación
    • Yaf_Application::getConfig - Recuperar la instancia de configuración
    • Yaf_Application::getDispatcher - Obtener la instancia de la clase Yaf_Dispatcher
    • Yaf_Application::getLastErrorMsg - Obtener el mensaje del último error ocurrido
    • Yaf_Application::getLastErrorNo - Pbetner el código del último error ocurrido
    • Yaf_Application::getModules - Obtener los nombres de los modulos definidos
    • Yaf_Application::run - Iniciar una instancia de la clase Yaf_Application
    • Yaf_Application::setAppDirectory - Cambiar el directorio de la aplicación
    • Yaf_Application::__construct - El constructor de la clase Yaf_Application
    • Yaf_Application::__destruct - El propósito de __destruct
    • Yaf_Config_Abstract::get - Consultor
    • Yaf_Config_Abstract::readonly - Buscar si una configuración es de sólo lectura
    • Yaf_Config_Abstract::set - Modificador
    • Yaf_Config_Abstract::toArray - Convertir en un array
    • Yaf_Config_Ini::count - Contar todos los elementos en Yaf_Config.ini
    • Yaf_Config_Ini::current - Recuperar el valor actual
    • Yaf_Config_Ini::key - Buscar la clave del elemento actual
    • Yaf_Config_Ini::next - Avanzar el puntero interno
    • Yaf_Config_Ini::offsetExists - El propósito de offsetExists
    • Yaf_Config_Ini::offsetGet - El propósito de offsetGet
    • Yaf_Config_Ini::offsetSet - El propósito de offsetSet
    • Yaf_Config_Ini::offsetUnset - El propósito de offsetUnset
    • Yaf_Config_Ini::readonly - El propósito de readonly
    • Yaf_Config_Ini::rewind - El propósito de rewind
    • Yaf_Config_Ini::toArray - Devuelve la configuración como un array PHP
    • Yaf_Config_Ini::valid - El propósito de valid
    • Yaf_Config_Ini::__construct - Constructor de Yaf_Config_Ini
    • Yaf_Config_Ini::__get - Recuperar un elemento
    • Yaf_Config_Ini::__isset - Determinar si existe una clave
    • Yaf_Config_Ini::__set - El propósito de __set
    • Yaf_Config_Simple::count - El propósito de count
    • Yaf_Config_Simple::current - El propósito de current
    • Yaf_Config_Simple::key - El propósito de key
    • Yaf_Config_Simple::next - El propósito de next
    • Yaf_Config_Simple::offsetExists - El propósito de offsetExists
    • Yaf_Config_Simple::offsetGet - El propósito de offsetGet
    • Yaf_Config_Simple::offsetSet - El propósito de offsetSet
    • Yaf_Config_Simple::offsetUnset - El propósito de offsetUnset
    • Yaf_Config_Simple::readonly - El propósito de readonly
    • Yaf_Config_Simple::rewind - El propósito de rewind
    • Yaf_Config_Simple::toArray - Devuelve un array de PHP
    • Yaf_Config_Simple::valid - El propósito de valid
    • Yaf_Config_Simple::__construct - El propósito de __construct
    • Yaf_Config_Simple::__get - El propósito de __get
    • Yaf_Config_Simple::__isset - El propósito de __isset
    • Yaf_Config_Simple::__set - El propósito de __set
    • Yaf_Controller_Abstract::display - El propósito de display
    • Yaf_Controller_Abstract::forward - Avanza a la siguiente acción
    • Yaf_Controller_Abstract::getInvokeArg - El propósito de getInvokeArg
    • Yaf_Controller_Abstract::getInvokeArgs - El propósito de getInvokeArgs
    • Yaf_Controller_Abstract::getModuleName - Obtiene el nombre del módulo
    • Yaf_Controller_Abstract::getName - Obtener el nombre propio
    • Yaf_Controller_Abstract::getRequest - Recupera el objeto petición actual
    • Yaf_Controller_Abstract::getResponse - Recupera el objeto respuesta actual
    • Yaf_Controller_Abstract::getView - Recupera el motor de vistas
    • Yaf_Controller_Abstract::getViewpath - El propósito de getViewpath
    • Yaf_Controller_Abstract::init - Inicializador del controlador
    • Yaf_Controller_Abstract::initView - El propósito de initView
    • Yaf_Controller_Abstract::redirect - Redirige a un URL
    • Yaf_Controller_Abstract::render - Interpreta una plantilla de vista
    • Yaf_Controller_Abstract::setViewpath - El propósito de setViewpath
    • Yaf_Controller_Abstract::__construct - Constructor de Yaf_Controller_Abstract
    • Yaf_Dispatcher::autoRender - Activa/desactiva la autointerpretación
    • Yaf_Dispatcher::catchException - Activar/desactivar la captura de excepciones
    • Yaf_Dispatcher::disableView - Deshabilita la interpretación de vistas
    • Yaf_Dispatcher::dispatch - Despachar una petición
    • Yaf_Dispatcher::enableView - Habilita la interpretación de vistas
    • Yaf_Dispatcher::flushInstantly - Activa/desactiva el vaciado instantáneo
    • Yaf_Dispatcher::getApplication - Recupera la aplicación
    • Yaf_Dispatcher::getDefaultAction - Recupera el nombre de la acción por defecto
    • Yaf_Dispatcher::getDefaultController - Recupera el nombre del controlador predeterminado
    • Yaf_Dispatcher::getDefaultModule - Recupera el nombre del módulo por defecto
    • Yaf_Dispatcher::getInstance - Recupeara la instancia despachadora
    • Yaf_Dispatcher::getRequest - Recupera la instancia de petición
    • Yaf_Dispatcher::getRouter - Recuperar la instancia de envío
    • Yaf_Dispatcher::initView - Inicializa una vista y la devuelve
    • Yaf_Dispatcher::registerPlugin - Registra un complemento
    • Yaf_Dispatcher::returnResponse - El propósito de returnResponse
    • Yaf_Dispatcher::setDefaultAction - Cambia el nombre de la acción predeterminada
    • Yaf_Dispatcher::setDefaultController - Cambia el nombre del controlador predeterminado
    • Yaf_Dispatcher::setDefaultModule - Cambia el nombre del módulo predeterminado
    • Yaf_Dispatcher::setErrorHandler - Establece el gestor de errores
    • Yaf_Dispatcher::setRequest - El propósito de setRequest
    • Yaf_Dispatcher::setView - Establecer un motor de vistas personalizado
    • Yaf_Dispatcher::throwException - Activa/desactiva el lanzamiento de excepciones
    • Yaf_Dispatcher::__construct - Constructor de la clase Yaf_Dispatcher
    • Yaf_Exception::getPrevious - El propósito de getPrevious
    • Yaf_Exception::__construct - El propósito de __construct
    • Yaf_Loader::autoload - El propósito de autoload
    • Yaf_Loader::clearLocalNamespace - El propósito de clearLocalNamespace
    • Yaf_Loader::getInstance - El propósito de getInstance
    • Yaf_Loader::getLibraryPath - Obtener la ruta de la biblioteca
    • Yaf_Loader::getLocalNamespace - Recupera toda la información de un espacio de nombre
    • Yaf_Loader::getNamespacePath - Recupera la ruta de un espacio de nombres registrado
    • Yaf_Loader::import - El propósito de import
    • Yaf_Loader::isLocalName - El propósito de isLocalName
    • Yaf_Loader::registerLocalNamespace - Registra un prefijo de clase local
    • Yaf_Loader::registerNamespace - Registra un espacio de nombre con ruta de búsqueda
    • Yaf_Loader::setLibraryPath - Cmabiar la ruta de la biblioteca
    • Yaf_Loader::__construct - El propósito de __construct
    • Yaf_Plugin_Abstract::dispatchLoopShutdown - El propósito de dispatchLoopShutdown
    • Yaf_Plugin_Abstract::dispatchLoopStartup - Enganchar antes del bucle de envío
    • Yaf_Plugin_Abstract::postDispatch - El propósito de postDispatch
    • Yaf_Plugin_Abstract::preDispatch - El propósito de preDispatch
    • Yaf_Plugin_Abstract::preResponse - El propósito de preResponse
    • Yaf_Plugin_Abstract::routerShutdown - El propósito de routerShutdown
    • Yaf_Plugin_Abstract::routerStartup - Enganche deEl propósito de routerStartup
    • Yaf_Registry::del - Elimina un elemento del registro
    • Yaf_Registry::get - Recupera un elemento del registro
    • Yaf_Registry::has - Comprueba si existe un elemento
    • Yaf_Registry::set - Añade un elemento al registro
    • Yaf_Registry::__construct - Yaf_Registry implementa «singleton»
    • Yaf_Request_Abstract::clearParams - Eliminar todos los parámetros
    • Yaf_Request_Abstract::getActionName - El propósito de getActionName
    • Yaf_Request_Abstract::getBaseUri - El propósito de getBaseUri
    • Yaf_Request_Abstract::getControllerName - El propósito de getControllerName
    • Yaf_Request_Abstract::getEnv - Recupera la variable ENV
    • Yaf_Request_Abstract::getException - El propósito de getException
    • Yaf_Request_Abstract::getLanguage - Recupera el lenguaje preferido del cliente
    • Yaf_Request_Abstract::getMethod - Recupera el método de solicitud
    • Yaf_Request_Abstract::getModuleName - El propósito de getModuleName
    • Yaf_Request_Abstract::getParam - Recupera el parámetro de llamada
    • Yaf_Request_Abstract::getParams - Recupera todos los parámetros de llamada
    • Yaf_Request_Abstract::getRequestUri - El propósito de getRequestUri
    • Yaf_Request_Abstract::getServer - Recupera la variable SERVER
    • Yaf_Request_Abstract::isCli - Determina si la solicitud es una solicitud CLI
    • Yaf_Request_Abstract::isDispatched - Determina si la solicitud es enviada
    • Yaf_Request_Abstract::isGet - Determina si la solicitud es una solicitud GET
    • Yaf_Request_Abstract::isHead - Determina si la solicitud es una solicitud HEAD
    • Yaf_Request_Abstract::isOptions - Determina si la solicitud es una solicitud de OPCIONES
    • Yaf_Request_Abstract::isPost - Determina si la solicitud es una solicitud POST
    • Yaf_Request_Abstract::isPut - Determina si la solicitud es una solicitud PUT
    • Yaf_Request_Abstract::isRouted - Determina si la solicitud ha sido enrutada
    • Yaf_Request_Abstract::isXmlHttpRequest - Determina si la solicitud es una solicitud AJAX
    • Yaf_Request_Abstract::setActionName - Establece el nombre de la acción
    • Yaf_Request_Abstract::setBaseUri - Establecer el URI base
    • Yaf_Request_Abstract::setControllerName - El propósito de setControllerName
    • Yaf_Request_Abstract::setDispatched - El propósito de setDispatched
    • Yaf_Request_Abstract::setModuleName - El propósito de setModuleName
    • Yaf_Request_Abstract::setParam - El propósito de setParam
    • Yaf_Request_Abstract::setRequestUri - El propósito de setRequestUri
    • Yaf_Request_Abstract::setRouted - El propósito de setRouted
    • Yaf_Request_Http::get - Recupera una variable del cliente
    • Yaf_Request_Http::getCookie - Recupera una varible de Cookie
    • Yaf_Request_Http::getFiles - El propósito de getFiles
    • Yaf_Request_Http::getPost - Recupera una variable de POST
    • Yaf_Request_Http::getQuery - Obtiene un parámetro de una consulta
    • Yaf_Request_Http::getRaw - Recupera el cuerpo de la solicitud de raw
    • Yaf_Request_Http::getRequest - El propósito de getRequest
    • Yaf_Request_Http::isXmlHttpRequest - Determina si la solicitud es una solicitud de Ajax
    • Yaf_Request_Http::__construct - Constructor de Yaf_Request_Http
    • Yaf_Request_Simple::get - El propósito de get
    • Yaf_Request_Simple::getCookie - El propósito de getCookie
    • Yaf_Request_Simple::getFiles - El propósito de getFiles
    • Yaf_Request_Simple::getPost - El propósito de getPost
    • Yaf_Request_Simple::getQuery - El propósito de getQuery
    • Yaf_Request_Simple::getRequest - El propósito de getRequest
    • Yaf_Request_Simple::isXmlHttpRequest - Determina si la solicitud es una solicitud AJAX
    • Yaf_Request_Simple::__construct - Constructor de Yaf_Request_Simple
    • Yaf_Response_Abstract::appendBody - Añadir contenido al cuerpo de respuesta
    • Yaf_Response_Abstract::clearBody - Descarta todo el cuerpo de respuesta existente
    • Yaf_Response_Abstract::clearHeaders - Descarta todas las cabeceras establecidas
    • Yaf_Response_Abstract::getBody - Recupera un contenido existente
    • Yaf_Response_Abstract::getHeader - El propósito de getHeader
    • Yaf_Response_Abstract::prependBody - El propósito de prependBody
    • Yaf_Response_Abstract::response - Envía una respuesta
    • Yaf_Response_Abstract::setAllHeaders - El propósito de setAllHeaders
    • Yaf_Response_Abstract::setBody - Establece el contenido de una respuesta
    • Yaf_Response_Abstract::setHeader - Establece cabecera de respuesta
    • Yaf_Response_Abstract::setRedirect - El propósito de setRedirect
    • Yaf_Response_Abstract::__construct - El propósito de __construct
    • Yaf_Response_Abstract::__destruct - El propósito de __destruct
    • Yaf_Response_Abstract::__toString - Recupera todo el cuerpo como un string
    • Yaf_Router::addConfig - Añadir rutas definidas en configuración al Enrutador
    • Yaf_Router::addRoute - Añadir una nueva ruta al Enrutador
    • Yaf_Router::getCurrentRoute - Obtener el nombre de la ruta efectiva
    • Yaf_Router::getRoute - Recupera una ruta por su nombre
    • Yaf_Router::getRoutes - Recupera las rutas registradas
    • Yaf_Router::route - El propósito de route
    • Yaf_Router::__construct - El constructor de Yaf_Router
    • Yaf_Route_Interface::assemble - Ensamblar una petición
    • Yaf_Route_Interface::route - Enruta una petición
    • Yaf_Route_Map::assemble - Ensamblar un URL
    • Yaf_Route_Map::route - El propósito de route
    • Yaf_Route_Map::__construct - El propósito de __construct
    • Yaf_Route_Regex::assemble - Ensamblar un URL
    • Yaf_Route_Regex::route - El propósito de route
    • Yaf_Route_Regex::__construct - Constructor de Yaf_Route_Regex
    • Yaf_Route_Rewrite::assemble - Ensamblar un URL
    • Yaf_Route_Rewrite::route - El propósito de route
    • Yaf_Route_Rewrite::__construct - Constructor de Yaf_Route_Rewrite
    • Yaf_Route_Simple::assemble - Ensamblar un URL
    • Yaf_Route_Simple::route - Enviar una petición
    • Yaf_Route_Simple::__construct - El constructor de la clase Yaf_Route_Simple
    • Yaf_Route_Static::assemble - Ensamblar un URL
    • Yaf_Route_Static::match - El propósito de match
    • Yaf_Route_Static::route - Enviar una petición
    • Yaf_Route_Supervar::assemble - Ensamblar un URL
    • Yaf_Route_Supervar::route - El propósito de route
    • Yaf_Route_Supervar::__construct - El propósito de __construct
    • Yaf_Session::count - El propósito de count
    • Yaf_Session::current - El propósito de current
    • Yaf_Session::del - El propósito de del
    • Yaf_Session::getInstance - El propósito de getInstance
    • Yaf_Session::has - El propósito de has
    • Yaf_Session::key - El propósito de key
    • Yaf_Session::next - El propósito de next
    • Yaf_Session::offsetExists - El propósito de offsetExists
    • Yaf_Session::offsetGet - El propósito de offsetGet
    • Yaf_Session::offsetSet - El propósito de offsetSet
    • Yaf_Session::offsetUnset - El propósito de offsetUnset
    • Yaf_Session::rewind - El propósito de rewind
    • Yaf_Session::start - El propósito de start
    • Yaf_Session::valid - El propósito de valid
    • Yaf_Session::__construct - Constructor de Yaf_Session
    • Yaf_Session::__get - El propósito de __get
    • Yaf_Session::__isset - El propósito de __isset
    • Yaf_Session::__set - El propósito de __set
    • Yaf_Session::__unset - El propósito de __unset
    • Yaf_View_Interface::assign - Asignar valores al motor de Vistas
    • Yaf_View_Interface::display - Interpretar e imprimir una plantilla
    • Yaf_View_Interface::getScriptPath - El propósito de getScriptPath
    • Yaf_View_Interface::render - Interpretar una plantilla
    • Yaf_View_Interface::setScriptPath - El propósito de setScriptPath
    • Yaf_View_Simple::assign - Asignar valores
    • Yaf_View_Simple::assignRef - El propósito de assignRef
    • Yaf_View_Simple::clear - Limpiar valores asignados
    • Yaf_View_Simple::display - Interpretar y mostrar
    • Yaf_View_Simple::eval - Interpreta una plantilla
    • Yaf_View_Simple::getScriptPath - Obtiene el directorio de plantillas
    • Yaf_View_Simple::render - Interpreta una plantilla
    • Yaf_View_Simple::setScriptPath - Establece el directorio de plantillas
    • Yaf_View_Simple::__construct - El constructor de Yaf_View_Simple
    • Yaf_View_Simple::__get - Recupera una variable asignada
    • Yaf_View_Simple::__isset - El propósito de __isset
    • Yaf_View_Simple::__set - Establece el valor para el motor
    • yaml_emit - Devuelve la representación de un valor YAML
    • yaml_emit_file - Enviar la representación YAML de un valor a un fichero
    • yaml_parse - Analiza una secuencia de texto en formato YAML
    • yaml_parse_file - Analiza una secuencia de texto en formato YAML desde un fichero
    • yaml_parse_url - Analiza una secuencia de texto Yaml desde una URL
    • Yar_Client::setOpt - Establecer los contextos de una llamada
    • Yar_Client::__call - Llamar a un servicio
    • Yar_Client::__construct - Crear un cliente
    • Yar_Client_Exception::getType - El propósito de getType
    • Yar_Concurrent_Client::call - Registrar una llamada concurrente
    • Yar_Concurrent_Client::loop - Enviar todas las llamadas
    • Yar_Concurrent_Client::reset - Limpiar todas las llamadas registradas
    • Yar_Server::handle - Iniciar un servidor RPC
    • Yar_Server::__construct - Registrar un servidor
    • Yar_Server_Exception::getType - Recuperar el tipo de excepción
    • yaz_addinfo - Devuelve un error adicional de información
    • yaz_ccl_conf - Configura el analizador CCL
    • yaz_ccl_parse - Inviocar el analizador Invoke CCL
    • yaz_close - Close YAZ connection
    • yaz_connect - Prepara una conexión a un servidor Z39.50
    • yaz_database - Especifica las bases de datos dentro de una sesión
    • yaz_element - Especifica el nombre del elemento establecido para recuperar
    • yaz_errno - Devuelve el número de error
    • yaz_error - Devuelve la descripción del error
    • yaz_es - Prepara para una solicitud de servicio extendido
    • yaz_es_result - Resulados de Servicios Extendidos de Inspección
    • yaz_get_option - Devuelve el valor de opción para la conexión
    • yaz_hits - Devuelve el número de éxitos de la última búsqueda
    • yaz_itemorder - Prepara para la solicitud Z39.50 Item Order con el paquete ILL-Request
    • yaz_present - Se prepara para la recuperación (Z39.50 presente)
    • yaz_range - Específica un rango de registros a recuperar
    • yaz_record - Devuelve un registro
    • yaz_scan - Prepara para un escaneo YAZ
    • yaz_scan_result - Devuelve el resultado de un escaneado
    • yaz_schema - Especifica el esquema para la recuperación
    • yaz_search - Prepara una búsqueda
    • yaz_set_option - Configura una o más opciones de la conexión
    • yaz_sort - Configura los criterios de búsqueda
    • yaz_syntax - Especifica la sintaxis de registro preferida para la recuperación
    • yaz_wait - Espera que las peticiones Z39.50 se completeten
  • z
    • zend_thread_id - Devuelve un identificador único del thread actual
    • zend_version - Obtiene la versión del motor Zend actual
    • ZipArchive::addEmptyDir - Añadir un nuevo directorio
    • ZipArchive::addFile - Añade un fichero al archivo ZIP para la ruta dada
    • ZipArchive::addFromString - Añadir un fichero al archivo ZIP usando su contenido
    • ZipArchive::addGlob - Añadir ficheros de un directorio mediante un patrón glob
    • ZipArchive::addPattern - Añade ficheros de un directorio a partir de un patrón PCRE
    • ZipArchive::close - Cierra el fichero activo (abierto o el nuevo creado)
    • ZipArchive::count - Cuenta el número de archivos en el archivo
    • ZipArchive::deleteIndex - Elimina una entrada en el archivo usando su índice
    • ZipArchive::deleteName - Elimina una entrada en el archivo por su nombre
    • ZipArchive::extractTo - Extraer el contenido del archivo
    • ZipArchive::getArchiveComment - Devuelve el comentario del archivo ZIP
    • ZipArchive::getCommentIndex - Devuelve el comentario de una entrada usando la entrada díndice
    • ZipArchive::getCommentName - Devuelve el comentario de una entrada usando el nombre de la entrada
    • ZipArchive::getExternalAttributesIndex - Obtener los atributos externos de una entrada definida por su índice
    • ZipArchive::getExternalAttributesName - Obtener los atributos externos de una entrada definida por su nombre
    • ZipArchive::getFromIndex - Devuelve el contenido de la entrada usando su índice
    • ZipArchive::getFromName - Devuelve el contenido de la entrada utilizando su nombre
    • ZipArchive::getNameIndex - Devuelve el nombre de una entrada utilizando su índice
    • ZipArchive::getStatusString - Devuelve mensajes de: estado de error, de sistema y/o mensajes de zip
    • ZipArchive::getStream - Obtener un manejador de fichero para la entrada definido por su nombre (sólo lectura)
    • ZipArchive::isCompressionMethodSupported - Check if a compression method is supported by libzip
    • ZipArchive::isEncryptionMethodSupported - Check if a encryption method is supported by libzip
    • ZipArchive::locateName - Devuelve el índice de la entrada en el archivo
    • ZipArchive::open - Abrir un fichero de archivo en formato ZIP
    • ZipArchive::registerCancelCallback - Registrar una llamada para permitir la cancelación durante el cierre del archivo
    • ZipArchive::registerProgressCallback - Registra una llamada para proporcionar actualizaciones durante el cierre del archivo
    • ZipArchive::renameIndex - Renombra una entrada definida por su índice
    • ZipArchive::renameName - Renombra una entrada definida por su nombre
    • ZipArchive::replaceFile - Reemplaza fichero en el archivo ZIP con una ruta determinada
    • ZipArchive::setArchiveComment - Establece el comentario de un archivo ZIP
    • ZipArchive::setCommentIndex - Establece el comentario de una entrada definido por su índice
    • ZipArchive::setCommentName - Establece el comentario de una entrada definido por su nombre
    • ZipArchive::setCompressionIndex - Establecer el método de compresión de una entrada definida por su índice
    • ZipArchive::setCompressionName - Establecer el método de compresión de una entrada definida por su nombre
    • ZipArchive::setEncryptionIndex - Establece el método de cifrado de una entrada definida por su índice
    • ZipArchive::setEncryptionName - Establece el método de cifrado de una entrada definida por su nombre
    • ZipArchive::setExternalAttributesIndex - Establece los atributos externos de una entrada definida por su índice
    • ZipArchive::setExternalAttributesName - Establece los atributos externos de una entrada definida por su nombre
    • ZipArchive::setMtimeIndex - Establece el tiempo de modificación de una entrada definido por su índice
    • ZipArchive::setMtimeName - Establece la hora de modificación de una entrada definida por su nombre
    • ZipArchive::setPassword - Establece la contraseña para el archivo activo
    • ZipArchive::statIndex - Obtiene los detalles de una entrada definida por su índice
    • ZipArchive::statName - Obtener los detalles de una entrada definida por su nombre
    • ZipArchive::unchangeAll - Deshacer todos los cambios hechos en el archivo
    • ZipArchive::unchangeArchive - Revertir todos los cambios globales hechos en el archivo
    • ZipArchive::unchangeIndex - Revertir todos los cambios hechos a una entrada en el índice dado
    • ZipArchive::unchangeName - Deshace todos los cambios realizados a una entrada con un nombre dado
    • zip_close - Cierra un fichero ZIP
    • zip_entry_close - Cierra la entrada a un directorio
    • zip_entry_compressedsize - Obtiene el tamaño comprimido de una entrada de directorio
    • zip_entry_compressionmethod - Devuelve el método de compresión de una entrada de directorio
    • zip_entry_filesize - Devuelve el tamaño del fichero actual de una entrada de directorio
    • zip_entry_name - Devuelve el nombre de la entrada de un directorio
    • zip_entry_open - Abrir una entrada de directorio para lectura
    • zip_entry_read - Leer desde una entrada de directorio abierta
    • zip_open - Abre un fichero ZIP
    • zip_read - Leer la siguiente entrada en el fichero ZIP
    • zlib:// - Flujos de compresión
    • zlib_decode - Descomprime datos codificados en craw/gzip/zlib
    • zlib_encode - Comprime datos con la codificación especificada
    • zlib_get_coding_type - Retorna el tipo de codificación utilizada para hacer la compresión
    • ZMQ::__construct - El constructor de ZMQ
    • ZMQContext::getOpt - Obtener la opción de contexto
    • ZMQContext::getSocket - Crear un nuevo socket
    • ZMQContext::isPersistent - Indicar si el contexto es persistente
    • ZMQContext::setOpt - Establecer una opción de socket
    • ZMQContext::__construct - Construir un nuevo objeto ZMQContext
    • ZMQDevice::getIdleTimeout - Obtener el tiempo de espera de inactividad
    • ZMQDevice::getTimerTimeout - Obtener el tiempo de espera del temporizador
    • ZMQDevice::run - Ejecutar el nuevo dispositivo
    • ZMQDevice::setIdleCallback - Establecer la función de retrollamada de inactividad
    • ZMQDevice::setIdleTimeout - Establecer el tiempo de espera para la inactividad
    • ZMQDevice::setTimerCallback - Establecer la función de retrollamada del temporizador
    • ZMQDevice::setTimerTimeout - Establecer el tiempo de espera del temporizador
    • ZMQDevice::__construct - Construir un nuevo dispositivo
    • ZMQPoll::add - Añadir un elemento al conjunto de sondeo
    • ZMQPoll::clear - Limpiar el conjunto de sondeo
    • ZMQPoll::count - Contar los elementos del conjunto de sondeo
    • ZMQPoll::getLastErrors - Obtener los errores del sondeo
    • ZMQPoll::poll - Sondear los elementos
    • ZMQPoll::remove - Eliminar un elemento del conjunto de sondeo
    • ZMQSocket::bind - Vincular el socket
    • ZMQSocket::connect - Contectar el socket
    • ZMQSocket::disconnect - Desconectar un socket
    • ZMQSocket::getEndpoints - Obtener una lista de los extremos
    • ZMQSocket::getPersistentId - Obtener el ID de persistencia
    • ZMQSocket::getSocketType - Obtener el tipo de socket
    • ZMQSocket::getSockOpt - Obtener la opción de un socket
    • ZMQSocket::isPersistent - Comprobrar si un socket es persistente
    • ZMQSocket::recv - Recibir un mensaje
    • ZMQSocket::recvMulti - Recibir un mensaje multiparte
    • ZMQSocket::send - Enviar un mensaje
    • ZMQSocket::sendmulti - Enviar un mensaje multiparte
    • ZMQSocket::setSockOpt - Establecer una opción de socket
    • ZMQSocket::unbind - Desvincular el socket
    • ZMQSocket::__construct - Construir un nuevo ZMQSocket
    • Zookeeper::addAuth - Specify application credentials
    • Zookeeper::close - Close the zookeeper handle and free up any resources
    • Zookeeper::connect - Create a handle to used communicate with zookeeper
    • Zookeeper::create - Create a node synchronously
    • Zookeeper::delete - Delete a node in zookeeper synchronously
    • Zookeeper::exists - Checks the existence of a node in zookeeper synchronously
    • Zookeeper::get - Gets the data associated with a node synchronously
    • Zookeeper::getAcl - Gets the acl associated with a node synchronously
    • Zookeeper::getChildren - Lists the children of a node synchronously
    • Zookeeper::getClientId - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getConfig - Get instance of ZookeeperConfig
    • Zookeeper::getRecvTimeout - Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
    • Zookeeper::getState - Get the state of the zookeeper connection
    • Zookeeper::isRecoverable - Checks if the current zookeeper connection state can be recovered
    • Zookeeper::set - Sets the data associated with a node
    • Zookeeper::setAcl - Sets the acl associated with a node synchronously
    • Zookeeper::setDebugLevel - Sets the debugging level for the library
    • Zookeeper::setDeterministicConnOrder - Enable/disable quorum endpoint order randomization
    • Zookeeper::setLogStream - Sets the stream to be used by the library for logging
    • Zookeeper::setWatcher - Set a watcher function
    • Zookeeper::__construct - Create a handle to used communicate with zookeeper
    • ZookeeperConfig::add - Add servers to the ensemble
    • ZookeeperConfig::get - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
    • ZookeeperConfig::remove - Remove servers from the ensemble
    • ZookeeperConfig::set - Change ZK cluster ensemble membership and roles of ensemble peers
    • zookeeper_dispatch - Calls callbacks for pending operations
  • _
    • __autoload - Intenta cargar una clase sin definir
    • __halt_compiler - Detiene la ejecución del compilador


Listado de ejemplos

Lista todos los ejemplos del manual

  • Example#0 - Un ejemplo introductorio
  • Example#1 - Nuestro primer script de PHP: hola.php
  • Example#2 - Obtener la información del sistema desde PHP
  • Example#3 - Imprimir una variable (elemento de array)
  • Example#4 - Ejemplo usando estructuras de control y funciones
  • Example#5 - Mezcla de los modos HTML y PHP
  • Example#6 - Un formulario HTML sencillo
  • Example#7 - Mostrar información de nuestro formulario
  • Example#8 - Instrucciones de instalación (Versión de módulo compartido de Apache) para PHP
  • Example#9 - Instrucciones de instalación (Instalación de módulo estático para Apache) para PHP
  • Example#10 - Comandos de ejemplo para reiniciar Apache
  • Example#11 -
  • Example#12 -
  • Example#13 -
  • Example#14 -
  • Example#15 -
  • Example#16 -
  • Example#17 -
  • Example#18 -
  • Example#19 -
  • Example#20 -
  • Example#21 -
  • Example#22 -
  • Example#23 -
  • Example#24 - Extracto de lighttpd.conf
  • Example#25 - Lanzando oyentes FastCGI
  • Example#26 - Conexión a instancias de php-fastcgi remotas
  • Example#27 -
  • Example#28 -
  • Example#29 - Ejemplo de instalación de paquete de OpenBSD
  • Example#30 - Ejemplo de Instalación en Debian con Apache 2
  • Example#31 - Deteniendo e iniciando Apache una vez que PHP está instalado
  • Example#32 - Métodos para listar paquetes relacionados con PHP 5
  • Example#33 - Instalar PHP con MySQL, cURL
  • Example#34 - Configuración recomendada de WinCache
  • Example#35 - Configuración recomendada de WinCache
  • Example#36 - Linea de órdenes para configurar IIS y PHP
  • Example#37 - PHP 5 paquete de estructura
  • Example#38 - Configuración CGI y FastCGI en php.ini
  • Example#39 - Configuración de la extensión FastCGI para manejar las solicitudes de PHP
  • Example#40 - Configuración del fichero de los permisos de acceso
  • Example#41 - Configuración FastCGI y reciclaje PHP
  • Example#42 - Configuración de los ajustes de tiempo de espera FastCGI
  • Example#43 - Cambiar la ubicación del fichero php.ini
  • Example#44 - CGI y FastCGI en la configuración php.ini
  • Example#45 - >Creación del proceso del grupo IIS FastCGI
  • Example#46 - Creación de mapas manejador de peticiones PHP
  • Example#47 - La determinación de la cuenta utilizada como IIS identidad anónima
  • Example#48 - Configuración de archivo de los permisos de acceso
  • Example#49 - Establecer index.php como un documento predeterminado en IIS
  • Example#50 - Configuración de PHP FastCGI y el reciclaje
  • Example#51 - Configuración de los ajustes de tiempo de espera FastCGI
  • Example#52 - Cambiar la ubicación del fichero php.ini
  • Example#53 - PHP como módulo de Apache 1.3.x
  • Example#54 - PHP y Apache 1.3.x como CGI
  • Example#55 - PHP and Apache 2.x como controlador
  • Example#56 -
  • Example#57 - PHP y Apache 2.x como CGI
  • Example#58 - Configurar Apache para ejecutar PHP como FastCGI
  • Example#59 - Configuracion de Sambar ISAPI
  • Example#60 - Habilitar la extensión Bzip2 para PHP-Windows
  • Example#61 - Registro de cambios
  • Example#62 - Pasando variables de entorno y ajustando las configuraciones de PHP por grupos
  • Example#63 - Establecer ajustes PHP en nginx.conf
  • Example#64 - llamada a phpinfo
  • Example#65 - Variables de entorno de php.ini
  • Example#66 - Ejemplo de php.ini
  • Example#67 - Ejemplo de configuración de Apache
  • Example#68 - Salida avanzada usando condiciones
  • Example#69 - Etiquetas de apertura y de cierre de PHP
  • Example#70 - Literales de números enteros
  • Example#71 - Desbordamiento de enteros en sistemas de 32 bit
  • Example#72 - Desbordamiento de enteros en sistemas de 64 bit
  • Example#73 - Ejemplo no válido
  • Example#74 - Ejemplo de entrecomillado de string en Heredoc
  • Example#75 - Ejemplo de Heredoc en argumentos
  • Example#76 - Usar Heredoc para inicializar valores estáticos
  • Example#77 - Emplear comillas dobles en Heredoc
  • Example#78 - Ejemplo de entrecomillado de string de Nowdoc
  • Example#79 - Ejemplo de datos estáticos
  • Example#80 - Ejemplo de sintaxis simple
  • Example#81 - Algunos ejemplos de string
  • Example#82 - Diferencias entre PHP 5.3 y PHP 5.4
  • Example#83 - Un array simple
  • Example#84 - Ejemplo de amoldamiento de tipo y sobrescritura
  • Example#85 - Claves mixtas integer y string
  • Example#86 - Arrays indexados sin clave
  • Example#87 - Claves no en todos los elementos
  • Example#88 - Acceso a elementos de un array
  • Example#89 - Hacer referencia al resultado array de funciones
  • Example#90 - Uso de array()
  • Example#91 - Colección
  • Example#92 - Cambiando elemento en el bucle
  • Example#93 - Índice con base 1
  • Example#94 - Llenado de un array
  • Example#95 - Ordenado de un array
  • Example#96 - Arrays recursivos y multi-dimensionales
  • Example#97 - Ejemplo de de tipo de parámetro iterable
  • Example#98 - Ejemplo de valor predeterminado de un parámetro iterable
  • Example#99 - Ejemplo de tipo de retorno iterable
  • Example#100 - Ejemplo de tipo de retorno de generadro iterable
  • Example#101 - Ejemplo de varianza del tipo iterable
  • Example#102 - Ejemplos de funciones de llamadas de retorno
  • Example#103 - Ejemplo de retrollamada utilizando un cierre
  • Example#104 -
  • Example#105 - Basic class type declaration
  • Example#106 - Basic interface type declaration
  • Example#107 - Basic return type declaration
  • Example#108 - Returning an object
  • Example#109 - Nullable argument type declaration
  • Example#110 - Nullable return type declaration
  • Example#111 - Old way to make arguments nullable
  • Example#112 - Strict typing for arguments values
  • Example#113 - Coercive typing for argument values
  • Example#114 - Strict typing for return values
  • Example#115 - Example of types being coerced into a type part of the union
  • Example#116 - Typed pass-by-reference Parameters
  • Example#117 - Catching TypeError
  • Example#118 - Valores predeterminados en variables sin inicializar
  • Example#119 - Uso de global
  • Example#120 - Uso de $GLOBALS en lugar de global
  • Example#121 - Ejemplo que demuestra las superglobales y el ámbito
  • Example#122 - Ejemplo que demuestra la necesidad de variables estáticas
  • Example#123 - Ejemplo del uso de variables estáticas
  • Example#124 - Variables estáticas con funciones recursivas
  • Example#125 - Declaración de variables estáticas
  • Example#126 - Ejemplo de propiedad variable
  • Example#127 - Un formulario HTML sencillo
  • Example#128 - Acceso a datos de un formulario HTML sencillo con POST
  • Example#129 - Old methods of accessing user input
  • Example#130 - Variables de formulario más complejas
  • Example#131 - Un ejemplo de setcookie
  • Example#132 - Nombres de constantes correctos e incorrectos
  • Example#133 - Definición de constantes
  • Example#134 - Definición de constantes usando el la palabra reservada const
  • Example#135 - Asociatividad
  • Example#136 - Orden de evaluación no definido
  • Example#137 - +, - y . tienen la misma precedencia
  • Example#138 - Asignación por referencia
  • Example#139 - Operaciones AND, OR y XOR bit a bit sobre integers
  • Example#140 - Operaciones XOR bit a bit sobre strings
  • Example#141 - Desplazamiento de bits sobre integers
  • Example#142 - Comparación boolean/null
  • Example#143 - Transcripción de la comparación estándar de arrays
  • Example#144 - Asignación de un valor predeterminado
  • Example#145 - Comportamiento Ternario poco obvio
  • Example#146 - Operaciones aritméticas sobre variables de caracteres
  • Example#147 - Los operadores lógicos ilustrados
  • Example#148 - Comparando arrays
  • Example#149 - Utilizando instanceof con clases
  • Example#150 - Utilizando instanceof con clases heredadas
  • Example#151 - Utilizando instanceof para verificar si un objeto no es una instancia de una clase
  • Example#152 - Utilizando instanceof para la clase
  • Example#153 - Utilizando instanceof con otras variables
  • Example#154 - Usar instanceof para comprobar otras variables
  • Example#155 - Evitando búsquedas del nombre de clase y errores fatales con instanceof en PHP 5.0
  • Example#156 - Estructura switch
  • Example#157 - Estrutura switch permite el uso de strings
  • Example#158 - Structure of a match expression
  • Example#159 - Example of an unhandled match expression
  • Example#160 - Using a generalized match expressions to branch on integer ranges
  • Example#161 - Using a generalized match expressions to branch on string content
  • Example#162 - Ejemplo de uso del tick
  • Example#163 - Ejemplo de uso de ticks
  • Example#164 - Declarando un encoding para el script
  • Example#165 - Ejemplo básico de include
  • Example#166 - Incluyendo dentro de funciones
  • Example#167 - include por medio de HTTP
  • Example#168 - Comparando el valor de retorno de include
  • Example#169 - include y la sentencia return
  • Example#170 - Usando buffering de salida para incluir un archivo PHP dentro de una cadena
  • Example#171 - Ejemplo de goto
  • Example#172 - Ejemplo de goto en un bucle
  • Example#173 - Esto no funcionará
  • Example#174 - Seudocódigo para demostrar el uso de funciones
  • Example#175 - Funciones condicionales
  • Example#176 - Funciones dentro de funciones
  • Example#177 - Funciones recursivas
  • Example#178 - Pasar arrays a funciones
  • Example#179 - Paso de parámetros de una función por referencia
  • Example#180 - Uso de parámetros predeterminados en funciones
  • Example#181 - Usar tipos no escalares como valores predeterminados
  • Example#182 - Uso incorrecto de argumentos predeterminados en una función
  • Example#183 - Uso correcto de argumentos predeterminados en una función
  • Example#184 -
  • Example#185 - Declaración básica de tipo clase
  • Example#186 - Declaración básica de tipo interfaz
  • Example#187 - Tipos de parámetros pasados por referencia
  • Example#188 - Declaración de tipo nulo
  • Example#189 - Tipificación estricta
  • Example#190 - Tipificación débil
  • Example#191 - Capturar la excepción TypeError
  • Example#192 - Usando ... para acceder a argumentos variables
  • Example#193 - Usar ... para proporcionar argumentos
  • Example#194 - Argumentos variables de declaración de tipo
  • Example#195 - Acceder a argumentos variables en PHP 5.5 y anteriores
  • Example#196 - Named argument syntax
  • Example#197 - Positional arguments versus named arguments
  • Example#198 - Same example as above with a different order of parameters
  • Example#199 - Combining named arguments with positional arguments
  • Example#200 - Error exception when passing the same parameter multiple times
  • Example#201 - Empleo de return
  • Example#202 - Devolver un array para obtener múltiples valores
  • Example#203 - Devolver una referencia desde una función
  • Example#204 - Declaración básica de tipo de devolución
  • Example#205 - El modo estricto en acción
  • Example#206 - Devolver un objeto
  • Example#207 - Declaración de tipo de retorno anulable (a partir de PHP 7.1.0)
  • Example#208 - Ejemplo de función variable
  • Example#209 - Ejemplo de método variable
  • Example#210 - Ejemplo de método variable con propiedades estáticas
  • Example#211 - Llamables complejos
  • Example#212 - Ejemplo de función anónima
  • Example#213 - Ejemplo de asignación de variable de una función anónima
  • Example#214 - Heredar variables de un ámbito padre
  • Example#215 - Cierres y ámbito
  • Example#216 - Vinculación automática de $this
  • Example#217 - Intentar usar $this dentro de una función anónima estática
  • Example#218 - Intentar vincular un objeto a una función anónima estática
  • Example#219 - Las funciones de flecha capturan las variables por valor automáticamente
  • Example#220 - Las funciones de flecha capturan variables por valor automáticamente, incluso cuando están anidadas
  • Example#221 - Ejemplos de funciones de flecha
  • Example#222 - Los valores del alcance exterior no pueden ser modificados por las funciones de flecha
  • Example#223 - Definición de una clase sencilla
  • Example#224 - Algunos ejemplos de la pseudovariable $this
  • Example#225 - Creación de una instancia
  • Example#226 - Asignación de objetos
  • Example#227 - Creación de nuevos objetos
  • Example#228 - Acceder a un mimebro de un objeto recién creado
  • Example#229 - Acceso a propiedad contra llamada a método
  • Example#230 - Llamar a una función anónima almacenada en una propiedad
  • Example#231 - Herencia de clases sencilla
  • Example#232 - Compatible child methods
  • Example#233 - Fatal error when a child method removes a parameter
  • Example#234 - Fatal error when a child method makes an optional parameter mandatory
  • Example#235 - Error when using named arguments and parameters were renamed in a child class
  • Example#236 - Resolución de nombres de clases
  • Example#237 - Missing class name resolution
  • Example#238 - Object name resolution
  • Example#239 - Nullsafe Operator
  • Example#240 - Declaración de propiedades
  • Example#241 - Ejemplo del uso de nowdoc para inicializar una propiedad
  • Example#242 - Definición y uso de una constante
  • Example#243 - Ejemplo de datos estáticos
  • Example#244 - Ejemplo de ::class en espacio de nombres
  • Example#245 - Ejemplo de expresión constante
  • Example#246 - Modificadores de visibilidad de constantes de clase
  • Example#247 - Ejemplo de autocarga
  • Example#248 - Otro ejemplo de autocarga
  • Example#249 - Autocarga con manejo de excepciones para 5.3.0+
  • Example#250 - Autocarga con manejo de excepciones para 5.3.0+: Excepción personalizada ausente
  • Example#251 - Utilización de nuevos constructores unificados
  • Example#252 - Using constructor arguments
  • Example#253 - Using constructor property promotion
  • Example#254 - Using static creation methods
  • Example#255 - Ejemplo de Destructor
  • Example#256 - Declaración de propiedades
  • Example#257 - Declaración de métodos
  • Example#258 - Declaración de constantes a partir de PHP 7.1.0
  • Example#259 - Accediendo a miembros private del mismo tipo de objeto
  • Example#260 - Ejemplo de herencia
  • Example#261 - :: desde el exterior de la definición de la clase
  • Example#262 - :: desde el interior de la definición de la clase
  • Example#263 - Invocando a un método parent
  • Example#264 - Ejemplo de método estático
  • Example#265 - Ejemplo de propiedad estática
  • Example#266 - Ejemplo de clase abstracta
  • Example#267 - Ejemplo de clase abstracta
  • Example#268 - Ejemplo de interfaz
  • Example#269 - Interfaces extensibles
  • Example#270 - Herencia múltiple de interfaces
  • Example#271 - Interfaces con constantes
  • Example#272 - Ejemplo de rasgo
  • Example#273 - Ejemplo de Orden de Precedencia
  • Example#274 - Ejemplo de Orden de Precedencia #2
  • Example#275 - Uso de varios rasgos
  • Example#276 - Resolución de Conflictos
  • Example#277 - Modificar la Visibilidad de un Método
  • Example#278 - Traits compuestos de traits
  • Example#279 - Expresar Resquisitos con Métodos Abstractos
  • Example#280 - Variables estáticas
  • Example#281 - Métodos Estáticos
  • Example#282 - Definir Propiedades
  • Example#283 - Resolución de Conflictos
  • Example#284 - Sobrecarga de propiedades mediante los métodos __get(), __set(), __isset() y __unset()
  • Example#285 - Sobrecarga de métodos mediante los métodos __call() and __callStatic()
  • Example#286 - Iteración simple de un objeto
  • Example#287 - Iteración de un objeto implementando Iterator
  • Example#288 - Iteración de un objeto implementando IteratorAggregate
  • Example#289 - Sleep y wakeup
  • Example#290 - Ejemplo simple
  • Example#291 - Uso de __invoke()
  • Example#292 - Uso de __set_state() (desde PHP 5.1.0)
  • Example#293 - Utilizar __debugInfo()
  • Example#294 - Ejemplo de métodos Final
  • Example#295 - Ejemplo de clase Final
  • Example#296 - Clonación de un objeto
  • Example#297 - Acceder a un miembre del objeto recién clonado
  • Example#298 - Ejemplo de comparación de objetos en PHP 5
  • Example#299 - Uso de self::
  • Example#300 - Uso básico de static::
  • Example#301 - Uso de static:: en un contexto no estático
  • Example#302 - Llamadas que propagan y que no propagan la información de llamada
  • Example#303 - Referencias y Objetos
  • Example#304 - Ejemplo de sintaxis de espacios de nombres
  • Example#305 - Declarar un único espacio de nombres
  • Example#306 - Declarar un único espacio de nombres
  • Example#307 - Declarar un único espacio de nombres con jerarquía
  • Example#308 - Declarar varios espacios de nombres, sintaxis de combinación simple
  • Example#309 - Declarar varios espacios de nombres, sintaxis de llaves
  • Example#310 - Declarar múltiples espacios de nombres y código que no es de espacio de nombres
  • Example#311 - Declarar varios espacios de nombres y código que no es de espacio de nombres
  • Example#312 - Acceder a clases, funciones y constantes globales desde un espacio de nombres
  • Example#313 - Acceder dinámicamente a elementos
  • Example#314 - Acceder dinámicamente a elementos de un espacio de nombres
  • Example#315 - Ejemplo de __NAMESPACE__, código de espacio de nombres
  • Example#316 - Ejemplo de __NAMESPACE__, código global
  • Example#317 - Empleo de __NAMESPACE__ para la construcción dinámica de nombres
  • Example#318 - El operador namespace, dentro de un espacio de nombres
  • Example#319 - El operador namespace, en código global
  • Example#320 - Importar/apodar con el operador use
  • Example#321 - Importar/apodar con el operador use, varias sentencias use combinadas
  • Example#322 - La importación y los nombres dinámicos
  • Example#323 - La importación y los nombres completamente cualificados
  • Example#324 - Regla de importación ilegal
  • Example#325 - Usar la especificación de espacio global
  • Example#326 - Acceder a clases globales dentro de un espacio de nombres
  • Example#327 - Recurrir a funciones/constantes globales dentro de un espacio de nombres
  • Example#328 - Las resoluciones de nombres ilustradas
  • Example#329 - Acceder a clases globales fuera de un espacio de nombres
  • Example#330 - Acceder a clases globales fuera de un espacio de nombres
  • Example#331 - Acceder a clases internas en espacios de nombres
  • Example#332 - Acceder a clases, funciones o constantes internas en un espacio de nombres
  • Example#333 - Nombres completamente cualificados
  • Example#334 - Nombres cualificados
  • Example#335 - Nombres de clases no cualificados
  • Example#336 - Nombres de funciones o constantes no cualificados
  • Example#337 - Peligros de usar nombres de espacios de nombres dentro de una cadena entre comillas dobles
  • Example#338 - Constantes no definidas
  • Example#339 - Constantes no definidas
  • Example#340 - La clase Exception Interna
  • Example#341 - Extender la clase Exception (PHP 5.3.0+)
  • Example#342 - Lanzar una Excepción
  • Example#343 - Manejo de excepciones con un bloque finally
  • Example#344 - Excepciones anidadas
  • Example#345 - Implementando range como generador
  • Example#346 - Ejemplo sencillo de facilitar valores con yield
  • Example#347 - Facilitar un par clave-valor
  • Example#348 - Yielding nulls
  • Example#349 - Facilitar valores por referencia
  • Example#350 - yield from con iterator_to_array
  • Example#351 - Uso básico de yield from
  • Example#352 - yield from y valores devueltos
  • Example#353 - Implementing optional methods of an interface with Attributes
  • Example#354 - Attribute Syntax
  • Example#355 - Reading Attributes using Reflection API
  • Example#356 - Reading Specific Attributes using Reflection API
  • Example#357 - Using target specification to restrict where attributes can be used
  • Example#358 - Simple Attribute Class
  • Example#359 - Using IS_REPEATABLE to allow attribute on a declaration multiple times
  • Example#360 - Usar referencias con variables no definidas
  • Example#361 - Refenciar variables globales dentro de funciones
  • Example#362 - Referencias y la sentencia foreach
  • Example#363 - Ejemplo de $GLOBALS
  • Example#364 - Ejemplo de $_SERVER
  • Example#365 - Ejemplo de $_GET
  • Example#366 - Ejemplo de $_POST
  • Example#367 - Ejemplo de $_ENV
  • Example#368 - Ejemplo de $_COOKIE
  • Example#369 - Ejemplo de $php_errormsg
  • Example#370 - Ejemplo de $http_response_header
  • Example#371 - Ejemplo de $argc
  • Example#372 - Ejemplo de $argv
  • Example#373 - Ejemplo de Exception::getMessage
  • Example#374 - Ejemplo de Exception::getPrevious
  • Example#375 - Ejemplo de Exception::getCode
  • Example#376 - Ejemplo de Exception::getFile
  • Example#377 - Ejemplo de Exception::getLine
  • Example#378 - Ejemplo de Exception::getTrace
  • Example#379 - Ejemplo de Exception::getTraceAsString
  • Example#380 - Ejemplo de Exception::__toString
  • Example#381 - Utilizar set_error_handler para convertir mensajes de error en objetos ErrorException.
  • Example#382 - Ejemplo de ErrorException::getSeverity
  • Example#383 - Ejemplo de Error::getMessage
  • Example#384 - Ejemplo de Error::getPrevious
  • Example#385 - Ejemplo de Error::getCode
  • Example#386 - Ejemplo de Error::getFile
  • Example#387 - Ejemplo de Error::getLine
  • Example#388 - Ejemplo de Error::getTrace
  • Example#389 - Ejemplo de Error::getTraceAsString
  • Example#390 - Ejemplo de Error::__toString
  • Example#391 - Uso básico
  • Example#392 - Uso básico
  • Example#393 - Uso básico
  • Example#394 - Ejemplo de ArrayAccess::offsetExists
  • Example#395 - Uso básico
  • Example#396 - Ejemplo de Closure::bind
  • Example#397 - Ejemplo de Closure::bindTo
  • Example#398 - Ejemplo de Closure::call
  • Example#399 - Ejemplo de Generator::getReturn
  • Example#400 - Ejemplo de Generator::key
  • Example#401 - Empleo de Generator::send para inyectar valores
  • Example#402 - Lanzar una ecepión dentro de un generador
  • Example#403 - Uso básico de WeakReference
  • Example#404 - Ejemplo de uso básico de bindto
  • Example#405 - Obtener una página y enviar datos POST
  • Example#406 - Ignorar las redirecciones, aunque obtener las cabeceras y el contenido
  • Example#407 - Obtener una página y enviar datos POST
  • Example#408 - Ejemplo de uso básico password
  • Example#409 - Detectar la URL en la que se finaliza tras las redirecciones
  • Example#410 - php://temp/maxmemory
  • Example#411 - php://filter/resource=<flujo a filtrar>
  • Example#412 - php://filter/read=<lista de filtros a aplicar a la cadena de lectura>
  • Example#413 - php://filter/write=<lista de filtros a aplicar a la cadena de escritura>
  • Example#414 - php://memory y php://temp no son reutilizables
  • Example#415 - Mostrar contenidos de data://
  • Example#416 - Obtener el Tipo de Medio
  • Example#417 - Uso básico
  • Example#418 - Abriendo un flujo a partir de una conexión activa
  • Example#419 - ¡La variable $session debe permanecer disponible!
  • Example#420 - Recorriendo un archivo RAR
  • Example#421 - Abriendo un fichero encriptado (encriptación de cabeceras)
  • Example#422 - Un control pobre puede llevar a ....
  • Example#423 - ... Un ataque al sistema de archivos
  • Example#424 - Comprobación más segura del nombre de archivo
  • Example#425 - Comprobación más segura del nombre de archivo
  • Example#426 - Script vulnerable a bytes nulos
  • Example#427 - Validando correctamente la entrada
  • Example#428 - Campo de contraseña con hash
  • Example#429 - Contraseña con hash utilizando crypt
  • Example#430 - Dividir el conjunto de resultados en páginas ... y crear superusuarios (PostgreSQL)
  • Example#431 - Enumerar artículos ... y algunas contraseñas (cualquier servidor de bases de datos)
  • Example#432 - Desde restablecer una contraseña ... hasta obtener más privilegios (cualquier servidor de bases de datos)
  • Example#433 - Atacar el sistema operativo que hospeda la base de datos (Servidor MSSQL)
  • Example#434 - Una forma más segura de componer una consulta para paginación
  • Example#435 - Atacando variables con una página HTML personalizada
  • Example#436 - Explotando variables comunes de depuración
  • Example#437 - Buscando variables peligrosas con E_ALL
  • Example#438 - Uso Peligroso de Variables
  • Example#439 - Ocultando PHP como si fuera otro lenguaje
  • Example#440 - Utilizar tipos desconocidos para extensiones de PHP
  • Example#441 - Utilizar tipos HTML para extensiones de PHP
  • Example#442 - Ejemplo de autenticación HTTP 'Basic'
  • Example#443 - Ejemplo de autenticación HTTP 'Digest'
  • Example#444 - Ejemplo de autenticación HTTP forzando un nuevo usuario/contraseña
  • Example#445 - Un formulario simple de búsqueda con XForms
  • Example#446 - Empleo de un Xform para rellenar $_POST
  • Example#447 - Formulario para la subida de ficheros
  • Example#448 - Validación de la subida de ficheros
  • Example#449 - Subir un array de ficheros
  • Example#450 - Subida de varios ficheros
  • Example#451 - Guardar ficheros PUT de HTTP
  • Example#452 - Obtener el título de una página remota
  • Example#453 - Almacenar datos en un servidor remoto
  • Example#454 - Ejemplo que muestra las diferencias respecto a la SAPI CGI:
  • Example#455 -
  • Example#456 - Muestra los módulos PHP y Zend incorporados (y habilitados)
  • Example#457 - Obteniendo un error sintáctico usando comillas dobles
  • Example#458 - Usando comillas simples para prevenir la sustitución de variables de la consola
  • Example#459 - Usando las opciones -B, -R y -E para contar el número de líneas de un proyecto.
  • Example#460 - Al usar -v obtenemos el nombre de la SAPI y la versión de PHP y Zend
  • Example#461 - Ejemplo de --ini
  • Example#462 - Uso básico de --rf
  • Example#463 - Ejemplo de --rc
  • Example#464 - Ejemplo de --re
  • Example#465 - Ejemplo de --ri
  • Example#466 - Ejecutando un script PHP como un script de consola
  • Example#467 - Script destinado a ejecutarse desde la línea de comandos (script.php)
  • Example#468 - Fichero por lotes para ejecutar un script PHP en línea de comandos (script.bat)
  • Example#469 - Ejecutando código desde la consola interactiva
  • Example#470 - Autocompletado con el tabulador
  • Example#471 - Estableciendo configuraciones de php.ini en la shell interactiva
  • Example#472 - Iniciando el servidor web
  • Example#473 - Iniciando con una raíz de documentos específica
  • Example#474 - Utilizando un Script enrutador
  • Example#475 - Revisión del uso de la CLI del servidor web
  • Example#476 - Manejando tipos de ficheros no soportados
  • Example#477 - Accediendo a la CLI del servidor web desde máquinas remotas
  • Example#478 - Creación de un nuevo contenedor zval
  • Example#479 - Mostrar información de zval
  • Example#480 - Incremento de refcount de un zval
  • Example#481 - Decremento de refcount de zval
  • Example#482 - Crear un zval de tipo array
  • Example#483 - Añadir un elemento existente a un array
  • Example#484 - Eliminar un elemento de un array
  • Example#485 - Añadir el propio array como elemento de sí mismo
  • Example#486 - Eliminar $a
  • Example#487 - Ejemplo de uso de memoria
  • Example#488 - Influencia en rendimiento de Recolector de Basuras
  • Example#489 - Ejecutando el script anterior
  • Example#490 - Recompilando PHP para habilitar el análisis del Recolector de Basuras
  • Example#491 - Estadísticas de Recolección de Basuras
  • Example#492 - all_probes.d para monitorizar todos los Sondeos Estáticos en PHP con DTrace
  • Example#493 - all_probes.stp para monitorizar todas los Sondeos Estáticos de PHP con SystemTap
  • Example#494 - A apcu_add example
  • Example#495 - Un ejemplo de apcu_cache_info
  • Example#496 - Ejemplo de apcu_cas
  • Example#497 - Ejemplo de apcu_dec
  • Example#498 - Un ejemplo deapcu_delete
  • Example#499 - An apcu_entry example
  • Example#500 - apcu_exists example
  • Example#501 - A apcu_fetch example
  • Example#502 - apcu_inc example
  • Example#503 - A apcu_key_info example
  • Example#504 - A apcu_sma_info example
  • Example#505 - A apcu_store example
  • Example#506 - Un ejemplo de APCUIterator::__construct
  • Example#507 - Usar el manejo de errores en un script
  • Example#508 - Ejemplo de debug_backtrace
  • Example#509 - Ejemplo de debug_print_backtrace
  • Example#510 - Un ejemplo de error_clear_last
  • Example#511 - Un ejemplo de error_get_last
  • Example#512 - Ejemplos de error_log
  • Example#513 - Ejemplos de error_reporting
  • Example#514 - Ejemplo de restore_error_handler
  • Example#515 - Ejemplo de restore_exception_handler
  • Example#516 - Manejo de errores con set_error_handler y trigger_error
  • Example#517 - Ejemplo de set_exception_handler
  • Example#518 - Ejemplo de trigger_error
  • Example#519 - Calling a function from shared library
  • Example#520 - Calling a function, returning a structure through an argument
  • Example#521 - Accessing existing C variables
  • Example#522 - Creating and Modifying C variables
  • Example#523 - Working with C arrays
  • Example#524 - Working with C enums
  • Example#525 -
  • Example#526 -
  • Example#527 - Crear una matriz grande en una función
  • Example#528 - Ejemplo de control de la salida
  • Example#529 - Ejemplo de ob_end_clean
  • Example#530 - Ejemplo de ob_end_flush
  • Example#531 - Un ejemplo sencillo de ob_get_clean
  • Example#532 - Un ejemplo sencillo de ob_get_contents
  • Example#533 - Ejemplo de ob_get_flush
  • Example#534 - Un ejemplo sencillo de ob_get_length
  • Example#535 - Ejemplo de ob_gzhandler
  • Example#536 - Ejemplo de ob_list_handlers
  • Example#537 - Ejemplo de una función de llamada de retorno definida por el usuario
  • Example#538 - Crear un búfer de salida imborrable de forma compatible con PHP 5.3 y 5.4
  • Example#539 - Ejemplo de output_add_rewrite_var
  • Example#540 - Ejemplo de output_reset_rewrite_vars
  • Example#541 - Ejemplo de assert_options
  • Example#542 - Handle a failed assertion with a custom handler
  • Example#543 - Using a custom handler to print a description
  • Example#544 - Expectations without a custom exception
  • Example#545 - Expectations with a custom exception
  • Example#546 - cli_get_process_title example
  • Example#547 - cli_set_process_title example
  • Example#548 - Ejemplos de dl
  • Example#549 - Ejemplo de extension_loaded
  • Example#550 - Ejemplo de gc_enabled
  • Example#551 - gc_status Usage
  • Example#552 - get_current_user ejemplo
  • Example#553 - Ejemplo de get_defined_constants
  • Example#554 - Imprime las funciones XML
  • Example#555 - Ejemplo de get_include_path
  • Example#556 - Ejemplo de get_included_files
  • Example#557 - get_loaded_extensions
  • Example#558 - get_magic_quotes_runtime ejemplo
  • Example#559 - Unfiltered get_resources
  • Example#560 - Filtered get_resources
  • Example#561 - Ejemplo de getenv
  • Example#562 - Ejemplo de getlastmod
  • Example#563 - Ejemplo de getopt: Lo básico
  • Example#564 - Ejemplo de getopt: Introducir opciones long
  • Example#565 - Ejemplo de getopt: Pasar varias opciones como una
  • Example#566 - getrusage ejemplo
  • Example#567 - ini_get_all ejemplos
  • Example#568 - Disabling details
  • Example#569 - Unos cuantos ejemplos de la función ini_get
  • Example#570 - ini_restore ejemplo
  • Example#571 - Establece una opción ini
  • Example#572 - A memory_get_usage ejemplo
  • Example#573 - php_ini_loaded_file ejemplo
  • Example#574 - Un ejemplo simple para enumerar los archivos ini devueltos
  • Example#575 - Ejemplo de php_sapi_name
  • Example#576 - Algúnos ejemplos de php_uname
  • Example#577 - Algunos ejemplos de las constantes relacionadas al SO
  • Example#578 - Imprimir los créditos generales
  • Example#579 - Imprimir los desarrolladores principales y el grupo de documentación
  • Example#580 - Imprimir todos los créditos
  • Example#581 - Ejemplo de phpinfo
  • Example#582 - phpversion Ejemplo básico
  • Example#583 - PHP_VERSION_ID Ejemplo y uso
  • Example#584 - Definición de una variable de entorno
  • Example#585 - Ejemplo de restore_include_path
  • Example#586 - Ejemplo de set_include_path
  • Example#587 - Añadir a la ruta de inclusión
  • Example#588 - sys_get_temp_dir example
  • Example#589 - Ejemplos de version_compare
  • Example#590 - Ejemplo de zend_thread_id
  • Example#591 - Ejemplo de zend_version
  • Example#592 - Superglobales personalizadas con runkit.superglobal=_FOO,_BAR en php.ini
  • Example#593 - Un ejemplo de runkit_function_add
  • Example#594 - Un ejemplo de runkit_function_copy
  • Example#595 - Un ejemplo de runkit_function_redefine
  • Example#596 - Ejemplo de runkit_import
  • Example#597 - Ejemplo de runkit_method_add
  • Example#598 - Ejemplo de runkit_method_copy
  • Example#599 - Ejemplo de runkit_method_redefine
  • Example#600 - Ejemplo de runkit_method_remove
  • Example#601 - Ejemplo derunkit_method_rename
  • Example#602 - Basic uopz_add_function Usage
  • Example#603 - uopz_allow_exit example
  • Example#604 - uopz_backup example
  • Example#605 - uopz_compose example
  • Example#606 - uopz_copy example
  • Example#607 - Basic uopz_del_function Usage
  • Example#608 - uopz_delete example
  • Example#609 - uopz_delete class example
  • Example#610 - uopz_extend example
  • Example#611 - uopz_flags example
  • Example#612 - "Unfinalize" a Class
  • Example#613 - uopz_function example
  • Example#614 - uopz_function class example
  • Example#615 - uopz_get_exit_status example
  • Example#616 - Basic uopz_get_hook Usage
  • Example#617 - uopz_get_mock example
  • Example#618 - Basic uopz_get_property Usage
  • Example#619 - uopz_get_return example
  • Example#620 - Basic uopz_get_static Usage
  • Example#621 - uopz_implement example
  • Example#622 - uopz_overload example
  • Example#623 - uopz_redefine example
  • Example#624 - uopz_rename example
  • Example#625 - uopz_rename class example
  • Example#626 - uopz_restore example
  • Example#627 - Basic uopz_set_hook Usage
  • Example#628 - uopz_set_mock example
  • Example#629 - uopz_set_mock example
  • Example#630 - uopz_set_mock and static members
  • Example#631 - Basic uopz_set_property Usage
  • Example#632 - uopz_set_return example
  • Example#633 - uopz_set_return example
  • Example#634 - uopz_set_return class example
  • Example#635 - Basic uopz_set_static Usage
  • Example#636 - uopz_undefine example
  • Example#637 - Basic uopz_unset_hook Usage
  • Example#638 - uopz_unset_mock example
  • Example#639 - uopz_unset_return example
  • Example#640 - Ejemplo de uso de Weakref
  • Example#641 - Ejemplo de uso de WeakRef
  • Example#642 - Ejemplo de Weakref::acquire
  • Example#643 - Ejemplo de acquire/release anidados
  • Example#644 - Ejemplo de Weakref::__construct
  • Example#645 - Ejemplo de Weakref::release
  • Example#646 - Ejemplo de uso de Weakmap
  • Example#647 - Ejemplo de wincache.ignorelist
  • Example#648 - Authentication configuration for wincache.php
  • Example#649 - Enabling WinCache session handler
  • Example#650 - Enabling WinCache functions reroutes
  • Example#651 - Reroute.ini file content
  • Example#652 - A wincache_fcache_fileinfo example
  • Example#653 - Un ejemplo de wincache_fcache_meminfo
  • Example#654 - Empleo de wincache_lock
  • Example#655 - A wincache_ocache_fileinfo example
  • Example#656 - A wincache_ocache_meminfo example
  • Example#657 - A wincache_refresh_if_changed example
  • Example#658 - A wincache_rplist_fileinfo example
  • Example#659 - A wincache_rplist_meminfo example
  • Example#660 - A wincache_scache_info example
  • Example#661 - Ejemplo de wincache_scache_meminfo
  • Example#662 - wincache_ucache_add with key as a string
  • Example#663 - wincache_ucache_add with key as an array
  • Example#664 - Usando wincache_ucache_cas
  • Example#665 - Usando wincache_ucache_clear
  • Example#666 - Usando wincache_ucache_dec
  • Example#667 - Usando wincache_ucache_delete con key como un string
  • Example#668 - Usingwincache_ucache_delete con key como un array
  • Example#669 - Using wincache_ucache_delete con key como un array donde algunos elementos no se pueden eliminar
  • Example#670 - Usando wincache_ucache_exists
  • Example#671 - wincache_ucache_get con key como un string
  • Example#672 - wincache_ucache_get con key como un array
  • Example#673 - Usando wincache_ucache_inc
  • Example#674 - Usar wincache_ucache_info
  • Example#675 - Ejemplo de wincache_ucache_meminfo
  • Example#676 - wincache_ucache_set with key as a string
  • Example#677 - wincache_ucache_set with key as an array
  • Example#678 - Usar wincache_unlock
  • Example#679 - Ejemplo Xhprof con interfaz gráfica de usuario opcional
  • Example#680 - xhprof_disable ejemplo
  • Example#681 - Ejemplos de xhprof_enable
  • Example#682 - Ejemplo de xhprof_sample_disable
  • Example#683 - Asegúrate de que el artículo se almacene
  • Example#684 - Using CHAP passwords
  • Example#685 - radius_acct_open example
  • Example#686 - radius_add_server example
  • Example#687 - Ejemplo de radius_auth_open
  • Example#688 - radius_create_request example
  • Example#689 - radius_cvt_addr example
  • Example#690 - radius_cvt_int example
  • Example#691 - radius_cvt_string example
  • Example#692 - radius_get_attr example
  • Example#693 - radius_get_tagged_attr_data example
  • Example#694 - radius_get_tagged_attr_tag example
  • Example#695 - radius_get_vendor_attr example
  • Example#696 - radius_put_attr example
  • Example#697 - radius_put_int example
  • Example#698 - radius_put_string example
  • Example#699 - radius_put_vendor_attr example
  • Example#700 - Writing a string with a specified color to the screen
  • Example#701 - Ejemplo de ncurses_getmouse
  • Example#702 - Escribir una cadena con un color especificado en la pantalla
  • Example#703 - Escrivir una cadena con un color especificado en la pantalla
  • Example#704 - Ejemplo de ncurses_mousemask
  • Example#705 - Writing a string with a specified color to the screen
  • Example#706 - Ejemplo de interfaz de llamada readline
  • Example#707 - Ejemplo de readline
  • Example#708 - Pequeño ejemplo de bzip2
  • Example#709 - Comprimiendo datos
  • Example#710 - Descompresión de un String
  • Example#711 - Ejemplo de bzerror
  • Example#712 - Ejemplo de bzopen
  • Example#713 - ejemplo de bzread
  • Example#714 - Ejemplo de bzwrite
  • Example#715 - Utilizar un fichero externo
  • Example#716 - Utilizar un fichero dentro de un archivo phar
  • Example#717 - Convertir un archivo phar, desde phar al formato de fichero tar
  • Example#718 - phar.extract_list usage example
  • Example#719 - Ejemplo de uso de phar.cache_list
  • Example#720 - Un ejemplo de Phar::addEmptyDir
  • Example#721 - Un ejemplo de Phar::addFile
  • Example#722 - Un ejemplo de Phar::addFromString
  • Example#723 - Un ejemplo de Phar::apiVersion
  • Example#724 - Un ejemplo de Phar::buildFromDirectory
  • Example#725 - Un ejemplo de Phar::buildFromIterator con SplFileInfo
  • Example#726 - Un ejemplo de Phar::buildFromIterator con otros iteradores
  • Example#727 - Un ejemplo de Phar::canCompress
  • Example#728 - Un ejemplo de Phar::canWrite
  • Example#729 - Un ejemplo de Phar::compress
  • Example#730 - Un ejemplo de Phar::compressFiles
  • Example#731 - Un ejemplo de Phar::__construct
  • Example#732 - Un ejemplo de Phar::convertToData
  • Example#733 - Un ejemplo de Phar::convertToExecutable
  • Example#734 - Un ejemplo de Phar::copy
  • Example#735 - Phar::count ejemplo
  • Example#736 - Un ejemplo de Phar::createDefaultStub
  • Example#737 - Un ejemplo de Phar::decompress
  • Example#738 - Un ejemplo de Phar::decompressFiles
  • Example#739 - Un ejemplo de Phar::delMetaData
  • Example#740 - Un ejemplo de Phar::delete
  • Example#741 - Un ejemplo de Phar::extractTo
  • Example#742 - Un ejemplo de Phar::getMetadata
  • Example#743 - Un ejemplo de Phar::getStub
  • Example#744 - Un ejemplo de Phar::hasMetadata
  • Example#745 - Un ejemplo de Phar::interceptFileFuncs
  • Example#746 - Un ejemplo de Phar::interceptFileFuncs
  • Example#747 - Un ejemplo de Phar::isBuffering
  • Example#748 - Un ejemplo de Phar::isCompressed
  • Example#749 - Un ejemplo de Phar::loadPhar
  • Example#750 - Un ejemplo de Phar::mapPhar
  • Example#751 - Un ejemplo de Phar::mount
  • Example#752 - Un ejemplo de Phar::mungServer
  • Example#753 - Un ejemplo de Phar::offsetExists
  • Example#754 - Ejemplo de Phar::offsetGet
  • Example#755 - Un ejemplo de Phar::offsetSet
  • Example#756 - Un ejemplo de Phar::offsetUnset
  • Example#757 - Un ejemplo de Phar::running
  • Example#758 - Un ejemplo de Phar::setAlias
  • Example#759 - Un ejemplo de Phar::setDefaultStub
  • Example#760 - Un ejemplo de Phar::setMetadata
  • Example#761 - Un ejemplo de Phar::setStub
  • Example#762 - Un ejemplo de Phar::startBuffering
  • Example#763 - Un ejemplo de Phar::stopBuffering
  • Example#764 - Un ejemplo de Phar::unlinkArchive
  • Example#765 - Un ejemplo de Phar::webPhar
  • Example#766 - Un ejemplo de PharData::addEmptyDir
  • Example#767 - Un ejemplo de PharData::addFile
  • Example#768 - Un ejemplo de PharData::addFromString
  • Example#769 - Un ejemplo de PharData::buildFromDirectory
  • Example#770 - Un ejemplo de PharData::buildFromIterator con SplFileInfo
  • Example#771 - Un ejemplo de PharData::buildFromIterator con otros iteradores
  • Example#772 - Un ejemplo de PharData::compress
  • Example#773 - Un ejemplo de PharData::compressFiles
  • Example#774 - Un ejemplo de PharData::__construct
  • Example#775 - Un ejemplo de PharData::convertToData
  • Example#776 - Un ejemplo de PharData::convertToExecutable
  • Example#777 - Un ejemplo de Phar::copy
  • Example#778 - Un ejemplo de PharData::decompress
  • Example#779 - Un ejemplo de PharData::decompressFiles
  • Example#780 - Un ejemplo de PharData::delMetaData
  • Example#781 - Un ejemplo de PharData::delete
  • Example#782 - Un ejemplo de PharData::extractTo
  • Example#783 - Un ejemplo de PharData::offsetSet
  • Example#784 - Un ejemplo de PharData::offsetUnset
  • Example#785 - Un ejemplo de Phar::setMetadata
  • Example#786 - Un ejemplo de PharFileInfo::chmod
  • Example#787 - Un ejemplo de PharFileInfo::compress
  • Example#788 - Un ejemplo de PharFileInfo::__construct
  • Example#789 - Un ejemplo de PharFileInfo::decompress
  • Example#790 - Un ejemplo de PharFileInfo::delMetaData
  • Example#791 - Un ejemplo de PharFileInfo::getCRC32
  • Example#792 - Un ejemplo de PharFileInfo::getCompressedSize
  • Example#793 - Un ejemplo de PharFileInfo::getMetadata
  • Example#794 - Un ejemplo de PharFileInfo::getPharFlags
  • Example#795 - Un ejemplo de PharFileInfo::isCRCChecked
  • Example#796 - Un ejemplo de PharFileInfo::isCompressed
  • Example#797 - Un ejemplo de PharFileInfo::setMetadata
  • Example#798 - Instalación Rar
  • Example#799 - Descompresión "al vuelo"
  • Example#800 - Ejemplo de sistema de extracción de archivos Rar
  • Example#801 - Estilo orientado a objetos
  • Example#802 - Estilo por procedimientos
  • Example#803 - Estilo orientado a objetos
  • Example#804 - Estilo por procedimientos
  • Example#805 - Estilo orientado a objetos
  • Example#806 - Estilo por procedimientos
  • Example#807 - Estilo orientado a objetos
  • Example#808 - Estilo por procedimientos
  • Example#809 - Estilo orientado a objetos
  • Example#810 - Estilo por procedimientos
  • Example#811 - Estilo orientado a objetos
  • Example#812 - Estilo por procedimientos
  • Example#813 - Estilo orientado a objetos
  • Example#814 - Estilo por procedimientos
  • Example#815 - Volume Callback
  • Example#816 - Estilo orientado a objetos
  • Example#817 - Estilo por procedimientos
  • Example#818 - Ejemplo de RarArchive::__toString
  • Example#819 - Ejemplo de RarEntry::extract
  • Example#820 - ¿Cómo extraer todos los archivos en archivo?:
  • Example#821 - Ejemplo de RarEntry::getAttr
  • Example#822 - Ejemplo de RarEntry::getHostOs (version >= 2.0.0)
  • Example#823 - RarEntry::getHostOs example (version <= 1.0.0)
  • Example#824 - Ejemplo de RarEntry::getMethod
  • Example#825 - Ejemplo de RarEntry::getName
  • Example#826 - Ejemplo de RarEntry::getPackedSize
  • Example#827 - Ejemplo de RarEntry::getStream
  • Example#828 - Ejemplo de RarEntry::getUnpackedSize
  • Example#829 - Ejemplo de RarEntry::getVersion
  • Example#830 - Ejemplo de RarException::isUsingExceptions
  • Example#831 - Ejemplo de RarException::setUsingExceptions
  • Example#832 - Crear un fichero Zip
  • Example#833 - Volcar la información del archivo y listarlos
  • Example#834 - Usando contenedor Zip, leer meta info de OpenOffice
  • Example#835 - Ejemplo del uso de Zip
  • Example#836 - Crea un nuevo directorio en un archivo
  • Example#837 - Abrir y extraer
  • Example#838 - Añade una entrada al nuevo fichero
  • Example#839 - Añade un fichero en un directorio dentro de un archivo
  • Example#840 - Ejemplo con ZipArchive::addGlob
  • Example#841 - Ejemplo con ZipArchive::addPattern
  • Example#842 - Elimina el fichero desde el archivo usando su índice
  • Example#843 - Eliminado un fichero y un directorio desde un archivo, usando nombres
  • Example#844 - Extraer todas las entradas
  • Example#845 - Extraer dos entradas
  • Example#846 - Vuelca el comentario del archivo
  • Example#847 - Vuelca el comentario de la entrada
  • Example#848 - Vuelca el comentario de la entrada
  • Example#849 - Extraer todas las entradas con permisos Unix
  • Example#850 - Obtener el contenido del fichero
  • Example#851 - Obtener el contenido de los ficheros
  • Example#852 - Convierte una imagen desde una entrada de fichero zip
  • Example#853 - Ejemplo de ZipArchive::getNameIndex
  • Example#854 - Obtiene los contenidos de entrada con fread y lo almacena
  • Example#855 - Lo mismo como el ejemplo anterior pero con fopen y el envoltorio de flujo de zip
  • Example#856 - El flujo de envoltorio y la imagen, también pueden ser utilizados con la función xml
  • Example#857 - Crear un archivo y luego utilizarlo con ZipArchive::locateName
  • Example#858 - Abrir y extraer
  • Example#859 - Crear un fichero
  • Example#860 - Crear un fichero temporal
  • Example#861 - Archive a file
  • Example#862 - Archive a file
  • Example#863 - Renombra una entrada
  • Example#864 - Renombra una entrada
  • Example#865 - Abrir y reemplazar
  • Example#866 - Crear un archivo y establecer un comentario
  • Example#867 - Abrir un archivo y establecer un comentario para una entrada
  • Example#868 - Abrir un archivo y establecer un comentario para una entrada
  • Example#869 - Añadir ficheros con diferentes métodos de compresión a un archivo
  • Example#870 - Añadir ficheros con diferentes métodos de compresión a un archivo
  • Example#871 - Añadir fichero y establecer el método de compresión
  • Example#872 - Archivar y encriptar un archivo
  • Example#873 - Archivar un fichero, con sus permisos Unix
  • Example#874 - Archivar un fichero
  • Example#875 - Archivar un fichero
  • Example#876 - Volcar la información estadística de una entrada
  • Example#877 - Volcar la información estadística de una entrada
  • Example#878 - Pequeño Ejemplo de Zlib
  • Example#879 - Trabajando con la API de compresión y descompresión increemental desde PHP 7.0.0
  • Example#880 - Ejemplo de gzclose
  • Example#881 - Ejemplo de gzcompress
  • Example#882 - Ejemplo de gzdeflate
  • Example#883 - Creando un archivo gzip
  • Example#884 - Ejemplo de gzeof
  • Example#885 - Ejemplo de gzfile
  • Example#886 - Ejemplo de gzgetc
  • Example#887 - Ejemplo de gzgets
  • Example#888 - Ejemplo de gzgetss
  • Example#889 - Ejemplo de gzinflate
  • Example#890 - Ejemplo de gzopen
  • Example#891 - Ejemplo de gzpassthru
  • Example#892 - Ejemplo de gzread
  • Example#893 - Ejamplo de gzseek
  • Example#894 - Ejemplo de gzuncompress
  • Example#895 - Ejemplo de gzwrite
  • Example#896 - Ejemplo de zlib_encode
  • Example#897 - Ejemplo de random_bytes
  • Example#898 - Ejmplo de random_int
  • Example#899 - hash_algos ejemplo
  • Example#900 - Ejemplo de hash_copy
  • Example#901 - Ejemplo
  • Example#902 - Usando hash_file
  • Example#903 - Ejemplo de hash_final
  • Example#904 - hash_hkdf example
  • Example#905 - hash_hmac_algos example
  • Example#906 - Ejemplo de hash_hmac_file
  • Example#907 - hash_hmac example
  • Example#908 - Ejemplo de hashing incremental
  • Example#909 - Ejemplo de uso básico de hash_pbkdf2
  • Example#910 - Ejemplo de hash_update_stream
  • Example#911 - Un ejemplo de hash
  • Example#912 - Calcular unos 'hashes' Tiger anteriores a PHP 5.4 con PHP 5.4 y superior
  • Example#913 - Cifrar un valor de entrada con AES con una clave de 256 bits bajo 2.4.x y superiores en modo CBC
  • Example#914 - Ejemplo de mcrypt_create_iv
  • Example#915 - Ejemplo de mcrypt_enc_get_algorithms_name
  • Example#916 - Ejemplo de mcrypt_enc_get_modes_name
  • Example#917 - Ejemplo de mcrypt_enc_get_supported_key_sizes
  • Example#918 - Ejemplo de mcrypt_encrypt
  • Example#919 - Ejemplo de mcrypt_get_block_size
  • Example#920 - Ejemplo de mcrypt_get_cipher_name
  • Example#921 - Ejemplo de mcrypt_get_iv_size
  • Example#922 - Ejemplo de mcrypt_get_key_size
  • Example#923 - Ejemplo de mcrypt_list_algorithms
  • Example#924 - Ejemplo de mcrypt_list_modes
  • Example#925 - Ejemplo de mcrypt_module_open
  • Example#926 - Utilizando mcrypt_module_open en el proceso de cifrado
  • Example#927 - Ejemplo de mcrypt_module_self_test
  • Example#928 - Ejemplo de mdecrypt_generic
  • Example#929 - Calcula el MD5 y el hmac, y lo imprime como hexadecimal
  • Example#930 - Atravesando todos los hash
  • Example#931 - Ejemplo de mhash_get_block_size
  • Example#932 - Ejemplo de mhash_get_hash_name
  • Example#933 - Ejemplo de openssl_cipher_iv_length
  • Example#934 - Crear un certificado autofirmado
  • Example#935 - Ejemplo de openssl_csr_sign - firmar una CSR (cómo implementar su propia AC)
  • Example#936 - Ejemplo de openssl_error_string
  • Example#937 - Ejemplo de openssl_get_cert_locations
  • Example#938 - Ejemplo de openssl_get_cipher_methods
  • Example#939 - openssl_get_curve_names example
  • Example#940 - Ejemplo de openssl_get_md_methods
  • Example#941 - Ejemplo de openssl_open
  • Example#942 - Ejemplo de openssl_pkcs12_read
  • Example#943 - Ejemplo de openssl_pkcs7_decrypt
  • Example#944 - Ejemplo de openssl_pkcs7_encrypt
  • Example#945 - Ejemplo de openssl_pkcs7_sign
  • Example#946 - openssl_pkey_derive example
  • Example#947 - Ejemplo de openssl_random_pseudo_bytes
  • Example#948 - Ejemplo de openssl_seal
  • Example#949 - Ejemplo de openssl_sign
  • Example#950 - Ejemplo de openssl_sign
  • Example#951 - Ejemplo de openssl_spki_export_challenge
  • Example#952 - Ejemplo de openssl_spki_export_challenge desde <keygen>
  • Example#953 - openssl_spki_export example
  • Example#954 - openssl_spki_export example from <keygen>
  • Example#955 - openssl_spki_new example
  • Example#956 - openssl_spki_verify example
  • Example#957 - openssl_spki_verify example from <keygen>
  • Example#958 - Ejemplo de openssl_verify
  • Example#959 - openssl_verify example
  • Example#960 - openssl_x509_verify example
  • Example#961 - Basic password usage
  • Example#962 - Ejemplo de password_hash
  • Example#963 - Ejemplo de password_hash estableciendo el coste manualmente
  • Example#964 - Ejemplo de password_hash estableciendo la sal manualmente
  • Example#965 - Ejemplo de password_hash buscando un buen coste
  • Example#966 - Empleo de password_needs_rehash
  • Example#967 - Ejemplo de password_verify
  • Example#968 - sodium_crypto_kx_keypair usage
  • Example#969 - password_hash example
  • Example#970 - password_hash example
  • Example#971 - Ejemplo de DBA
  • Example#972 - Atravesar una base de datos
  • Example#973 - Ejemplo de dba_handlers
  • Example#974 - Conexiones sin DSN
  • Example#975 - Ejemplo de odbc_execute y odbc_prepare
  • Example#976 - Ejemplos de odbc_fetch_into
  • Example#977 - odbc_next_result
  • Example#978 - Ejemplo de odbc_execute y odbc_prepare
  • Example#979 - Ejemplos de odbc_result
  • Example#980 - Ejemplos de odbc_setoption
  • Example#981 - Uso de PDO::ATTR_DRIVER_NAME
  • Example#982 - Conectarse a MySQL
  • Example#983 - Manejo de errores de conexión
  • Example#984 - Cerrar una conexión
  • Example#985 - Conexiones persistentes
  • Example#986 - Ejecución de un lote en una transacción
  • Example#987 - Inserciones repetidas utilizando sentencias preparadas
  • Example#988 - Inserciones repetidas utilizando sentencias preparadas
  • Example#989 - Obtener datos empleando sentencias preparadas
  • Example#990 - Llamar a un procedimiento almacenado con un parámetro de salida
  • Example#991 - Llamar a un procedimiento almacenado con un parámetro de entrada/salida
  • Example#992 - Uso inválido de un marcador de posición
  • Example#993 - Crear una instancia de PDO y establecer el modo de error
  • Example#994 - Crear una instancia de PDO y establecer el modo de error desde el constructor
  • Example#995 - Mostrar una imagen desde una base de datos
  • Example#996 - Insertar una imagen en una base de datos
  • Example#997 - Insertar una imagen en una base de datos: Oracle
  • Example#998 - Revertir una transacción
  • Example#999 - Consignar una transacción básica
  • Example#1000 - Consignar una transacción DDL
  • Example#1001 - Crear una instancia PDO a través de una invocación al controlador
  • Example#1002 - Crear una instancia PDO a través de una invocación a la URI
  • Example#1003 - Crear una instancia de PDO usando un alias
  • Example#1004 - Recuperación de un código SQLSTATE
  • Example#1005 - Muestra los campos de errorInfo() para una conexión PDO_ODBC a una base de datos DB2
  • Example#1006 - Ejecutando una sentencia DELETE
  • Example#1007 - Obtiene los atributos de la conexión a la base de datos
  • Example#1008 - Un ejemplo de PDO::getAvailableDrivers
  • Example#1009 - Prepara una sentencia SQL con parámetros de sustitución nombrados
  • Example#1010 - Prepara una sentencia SQL con parámetros de signos de interrogación
  • Example#1011 - Demostración de PDO::query
  • Example#1012 - Entrecomillar una cadena de caracteres normal
  • Example#1013 - Entrecomillar una cadena peligrosa
  • Example#1014 - Entrecomillar una cadena compleja
  • Example#1015 - Revertir una transacción
  • Example#1016 - Vincular la salida de un conjunto de resultados a variables de PHP
  • Example#1017 - Ejecutar una sentencia preparada con parámetros de sustitución con nombre
  • Example#1018 - Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación
  • Example#1019 - Llamar a un procedimiento almacenado con un parámetro INOUT
  • Example#1020 - Ejecutar una sentencia preparada con parámetros de sustitución con nombre
  • Example#1021 - Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación
  • Example#1022 - Un ejemplo de PDOStatement::closeCursor
  • Example#1023 - Contar columnas
  • Example#1024 - Ejemplo de PDOStatement::debugDumpParams con parámetros con nombre
  • Example#1025 - Ejemplo de PDOStatement::debugDumpParams con parámetros sin nombre
  • Example#1026 - Recuperar un código SQLSTATE
  • Example#1027 - Mostrar los campos de errorInfo() para una conexión PDO_ODBC a una base de datos de DB2
  • Example#1028 - Ejecutar una sentencia preparada con una variable y valor vinculados
  • Example#1029 - Ejecutar una sentencia preparada con un array de valores de inserción (parámetros con nombre)
  • Example#1030 - Ejecutar una sentencia preparada con un array de valores de inserción (parámetros de sustitución)
  • Example#1031 - Ejecutar una sentencia preparada con parámetros de sustitución de signos de interrogación
  • Example#1032 - Ejecutar una sentencia preparada usando un array para la cláusula IN
  • Example#1033 - Obtención de filas usando diferentes tipos de obtención
  • Example#1034 - Obtener filas con un cursor desplazable
  • Example#1035 - Orden de construcción
  • Example#1036 - Obtener todas las filas restantes de un conjunto de resultados
  • Example#1037 - Obtener todos los valores de una única columna de un conjunto de resultados
  • Example#1038 - Agrupar todos los valores según una única columna
  • Example#1039 - Instanciar una clase para cada resultado
  • Example#1040 - Invocar a una función por cada resultado
  • Example#1041 - Devolver la primera columna de la siguiente fila
  • Example#1042 - Recuperar metadatos de una columna
  • Example#1043 - Obtener múltiples conjuntos de filas devueltas por un procedimiento almacenado
  • Example#1044 - Devolver el número de filas eliminadas
  • Example#1045 - Contar las filas devueltas por una sentencia SELECT
  • Example#1046 - Establece el modo de obtención
  • Example#1047 - Insertar LOBs en CUBRID PDO
  • Example#1048 - Obtener LOBs en CUBRID PDO
  • Example#1049 - Insertar un conjunto en CUBRID PDO con el tipo de datos predeterminado.
  • Example#1050 - Especificar un tipo de datos al insertar un conjunto en CUBRID PDO
  • Example#1051 - Ejemplos de DSN de PDO_CUBRID
  • Example#1052 - Un ejemplo de PDO::cubrid_schema
  • Example#1053 - PDO_DBLIB DSN examples
  • Example#1054 - Ejemplo de DSN de PDO_FIREBIRD DSN con ruta
  • Example#1055 - Ejemplo de DSN de PDO_FIREBIRD DSN con puerto y ruta
  • Example#1056 - Ejemplo de DSN de PDO_FIREBIRD con localhost y ruta hacia empleado.fdb en un sistema Debian
  • Example#1057 - Ejemplo de DSN de PDO_IBM DSN usando db2cli.ini
  • Example#1058 - Ejemplo de DSN de PDO_IBM usando una cadena de conexión
  • Example#1059 - Ejemplo de DSN de PDO_INFORMIX usando odbc.ini
  • Example#1060 - Ejemplo de DSN de PDO_INFORMIX usando una cadena de conexión
  • Example#1061 - Forzar consultas para que sean guardadas en el búfer en mysql
  • Example#1062 - Establecer el juego de caracteres de la conexión a UTF-8, antes de PHP 5.3.6
  • Example#1063 - ejemplos PDO_MYSQL DSN
  • Example#1064 - Ejemplos de DSN de PDO_SQLSRV
  • Example#1065 - Ejemplos del DSN de PDO_OCI
  • Example#1066 - Ejemplo de DSN de PDO_ODBC (administrador de controladores de ODBC)
  • Example#1067 - Ejemplo de DSN de PDO_ODBC (conexión no catalogada de IBM DB2)
  • Example#1068 - Ejemplo de DSN de PDO_ODBC (conexión no catalogada de Microsoft Access)
  • Example#1069 - Ejemplos de DSN de PDO_PGSQL
  • Example#1070 - Un ejemplo de PDO::pgsqlLOBCreate
  • Example#1071 - Un ejemplo de PDO::pgsqlLOBOpen
  • Example#1072 - Un ejemplo de PDO::pgsqlLOBUnlink
  • Example#1073 - Ejemplos de PDO_SQLITE DSN
  • Example#1074 - Ejemplo de función acumuladora max_length
  • Example#1075 - Ejemplo de PDO::sqliteCreateCollation
  • Example#1076 - Ejemplo de PDO::sqliteCreateFunction
  • Example#1077 - Ejemplo de Recuperación de Datos
  • Example#1078 - Ejemplo de Inserción de Datos
  • Example#1079 - Ejemplo de cubrid_bind
  • Example#1080 - Ejemplo de BLOB/CLOB de cubrid_bind
  • Example#1081 - Ejemplo de BLOB/CLOB de cubrid_bind
  • Example#1082 - Ejemplo de cubrid_close_prepare
  • Example#1083 - Ejemplo de cubrid_close_request
  • Example#1084 - Ejemplo de cubrid_col_get
  • Example#1085 - Ejemplo de cubrid_col_size
  • Example#1086 - Ejemplo de cubrid_column_names
  • Example#1087 - Ejemplo de cubrid_column_types
  • Example#1088 - Ejemplo de cubrid_commit
  • Example#1089 - Ejemplo de cubrid_connect_with_url, url sin propiedades
  • Example#1090 - Ejemplo de cubrid_connect_with_url, url con propiedades
  • Example#1091 - Ejemplo de cubrid_connect
  • Example#1092 - Ejemplo de cubrid_current_oid
  • Example#1093 - Ejemplo de cubrid_disconnect
  • Example#1094 - Ejemplo de cubrid_drop
  • Example#1095 - Ejemplo de cubrid_error_code_facility
  • Example#1096 - Ejemplo de cubrid_error_code
  • Example#1097 - Ejemplo de cubrid_error_msg
  • Example#1098 - Ejemplo de cubrid_execute
  • Example#1099 - Ejemplo de cubrid_fetch
  • Example#1100 - Ejemplo de cubrid_free_result
  • Example#1101 - Ejemplo de cubrid_get_charset
  • Example#1102 - Ejemplo de cubrid_get_class_name
  • Example#1103 - Ejemplo de cubrid_get_client_info
  • Example#1104 - Ejemplo de cubrid_get_db_parameter
  • Example#1105 - Ejemplo de cubrid_get_query_timeout
  • Example#1106 - Ejemplo de cubrid_get_server_info
  • Example#1107 - Ejemplo de cubrid_get
  • Example#1108 - Ejemplo de cubrid_insert_id
  • Example#1109 - Ejemplo de cubrid_is_instance
  • Example#1110 - Ejemplo de cubrid_lob_close
  • Example#1111 - Ejemplo de cubrid_lob_export
  • Example#1112 - Ejemplo de cubrid_lob_get
  • Example#1113 - Ejemplo de cubrid_lob_send
  • Example#1114 - Ejemplo de cubrid_lob_size
  • Example#1115 - Ejemplo de cubrid_lob2_bind
  • Example#1116 - Ejemplo de cubrid_lob2_export
  • Example#1117 - Ejemplo de cubrid_lob2_export
  • Example#1118 - Ejemplo 1 de cubrid_lob2_read
  • Example#1119 - Ejemplo 2 cubrid_lob2_read
  • Example#1120 - Ejemplo de cubrid_lob2_seek64
  • Example#1121 - Ejemplo de cubrid_lob2_seek
  • Example#1122 - Ejemplo 1 de cubrid_lob2_write
  • Example#1123 - Ejemplo 2 de cubrid_lob2_write
  • Example#1124 - Ejemplo de cubrid_lock_read
  • Example#1125 - Ejemplo de cubrid_lock_write
  • Example#1126 - Ejemplo de cubrid_move_cursor
  • Example#1127 - cubrid_next_result ejemplo
  • Example#1128 - Ejemplo de cubrid_num_cols
  • Example#1129 - Ejemplo de cubrid_num_rows
  • Example#1130 - Ejemplo de url de cubrid_pconnect_with_url sin propiedades
  • Example#1131 - Ejemplo de url de cubrid_pconnect_with_url con propiedades
  • Example#1132 - Ejemplo de cubrid_pconnect
  • Example#1133 - Ejemplo de cubrid_prepare
  • Example#1134 - Ejemplo de cubrid_put
  • Example#1135 - Ejemplo de cubrid_rollback
  • Example#1136 - Ejemplo de cubrid_schema
  • Example#1137 - Ejemplo de cubrid_seq_drop
  • Example#1138 - Ejemplo de cubrid_seq_insert
  • Example#1139 - Ejemplo de cubrid_seq_put
  • Example#1140 - Ejemplo de cubrid_set_add
  • Example#1141 - Ejemplo de cubrid_get_db_parameter
  • Example#1142 - Ejemplo de cubrid_set_drop
  • Example#1143 - Ejemplo de cubrid_version
  • Example#1144 - Ejemplo de cubrid_affected_rows
  • Example#1145 - Ejemplo de cubrid_client_encoding
  • Example#1146 - Ejemplo de cubrid_close
  • Example#1147 - Ejemplo de cubrid_data_seek
  • Example#1148 - Ejemplo de cubrid_db_name
  • Example#1149 - Ejemplo de cubrid_errno
  • Example#1150 - Ejemplo de cubrid_error
  • Example#1151 - Ejemplo de cubrid_fetch_array
  • Example#1152 - Ejemplo de cubrid_fetch_assoc
  • Example#1153 - Ejemplo de cubrid_fetch_field
  • Example#1154 - Ejemplo de cubrid_fetch_lengths
  • Example#1155 - Ejemplo de cubrid_fetch_object
  • Example#1156 - Ejemplo de cubrid_fetch_row
  • Example#1157 - Ejemplo de cubrid_field_flags
  • Example#1158 - Ejemplo de cubrid_field_len
  • Example#1159 - Ejemplo de cubrid_field_name
  • Example#1160 - Ejemplo de cubrid_field_seek
  • Example#1161 - Ejemplo de cubrid_field_table
  • Example#1162 - Ejemplo de cubrid_field_type
  • Example#1163 - Ejemplo de cubrid_list_dbs
  • Example#1164 - Ejemplo de cubrid_num_fields
  • Example#1165 - Ejemplo de cubrid_ping
  • Example#1166 - Consulta No Válida
  • Example#1167 - Consulta Válida
  • Example#1168 - Ejemplo de cubrid_real_escape_string
  • Example#1169 - Ejemplo de cubrid_result
  • Example#1170 - Ejemplo de cubrid_unbuffered_query
  • Example#1171 - Ejemplo de cubrid_load_from_glo
  • Example#1172 - Ejemplo de cubrid_new_glo
  • Example#1173 - Ejemplo de cubrid_save_to_glo
  • Example#1174 - Ejemplo de cubrid_send_glo
  • Example#1175 - Insertar un registro en una base de datos dBase
  • Example#1176 - Cerrar un archivo de base de datos de dBase
  • Example#1177 - Crear un archivo de base de datos dBase
  • Example#1178 - Mostrar la información de cabecera de un archivo de base de datos dBase
  • Example#1179 - Listar todos los miembros registrados en la base de datos
  • Example#1180 - Ejemplo de dbase_numfields
  • Example#1181 - Recorrer todos los registros de la base de datos
  • Example#1182 - Abrir un archivo de base de datos de dBase
  • Example#1183 - Vaciar una base de datos dBase
  • Example#1184 - Actualizar un registro en la base de datos
  • Example#1185 - Ejemplo de ibase_blob_get
  • Example#1186 - Ejemplo de ibase_blob_import
  • Example#1187 - Ejemplo de ibase_connect
  • Example#1188 - Ejemplo de ibase_execute
  • Example#1189 - Ejemplo de ibase_fetch_object
  • Example#1190 - Ejemplo de ibase_field_info
  • Example#1191 - Ejemplo de ibase_name_result
  • Example#1192 - Ejemplo de ibase_num_fields
  • Example#1193 - Ejemplo de ibase_query
  • Example#1194 - Ejemplo de ibase_set_event_handler
  • Example#1195 - Ejemplo de fbsql_close
  • Example#1196 - Ejemplo de fbsql_connect
  • Example#1197 - Ejemplo de fbsql_create_blob
  • Example#1198 - fbsql_create_clob example
  • Example#1199 - Ejemplo de fbsql_create_db.
  • Example#1200 - fbsql_data_seek example
  • Example#1201 - Ejemplo de fbsql_database_password
  • Example#1202 - Ejemplo de fbsql_errno
  • Example#1203 - Ejemplo de fbsql_error
  • Example#1204 - Ejemplo de fbsql_fetch_array
  • Example#1205 - fbsql_fetch_assoc example
  • Example#1206 - Ejemplo de fbsql_fetch_field
  • Example#1207 - Ejemplo de fbsql_fetch_object
  • Example#1208 - Ejemplo de fbsql_field_name
  • Example#1209 - Ejemplo de fbsql_field_type
  • Example#1210 - Ejemplo de fbsql_list_dbs
  • Example#1211 - fbsql_list_fields example
  • Example#1212 - fbsql_next_result ejemplo
  • Example#1213 - Ejemplo de fbsql_num_rows
  • Example#1214 - Ejemplo fbsql_query
  • Example#1215 - Ejemplo fbsql_query
  • Example#1216 - Ejemplo de fbsql_read_blob
  • Example#1217 - Ejemplo de fbsql_read_clob
  • Example#1218 - Ejemplo de fbsql_table_name
  • Example#1219 - Consultando el valor de AUTOCOMMIT de una conexión
  • Example#1220 - Asignando el valor de AUTOCOMMIT en una conexión
  • Example#1221 - Vinculando variables PHP a sentencias preparadas
  • Example#1222 - Llamada a procedimientos almacenados con parámetros de Entrada y Salida
  • Example#1223 - Insertando un objeto extenso binario (BLOB) directamente desde un fichero
  • Example#1224 - Ejemplo de db2_client_info
  • Example#1225 - Cierre de una conexión
  • Example#1226 - Extrayendo el valor SQLSTATE de un intento de conexión fallido
  • Example#1227 - Extrayendo el mensaje de error devuelto por un intento de conexión fallido
  • Example#1228 - Creando una conexión catalogada
  • Example#1229 - Creando una conexión no catalogada
  • Example#1230 - Creando una conexión con confirmaciones automáticas de transacciones deshabilitadas
  • Example#1231 - Optimizando en i5/OS
  • Example#1232 - Usando contexto de confianza
  • Example#1233 - Ejemplo de db2_escape_string
  • Example#1234 - Creando una tabla con db2_exec
  • Example#1235 - Ejecutando una sentencia SELECT con cursor de tipo SCROLLABLE
  • Example#1236 - Devolviendo datos XML como resultado
  • Example#1237 - Ejecutando un JOIN con datos XML
  • Example#1238 - Devolviendo datos SQL como parte de un documento XML extenso
  • Example#1239 - Preparando y ejecutando una sentencia SQL con marcadores de parámetros
  • Example#1240 - Llamando a un procedimiento almacenado con un parámetro OUT
  • Example#1241 - Devolviendo datos XML como resultado SQL
  • Example#1242 - Ejecutando un "JOIN" con datos XML
  • Example#1243 - Devolviendo datos SQL como parte un documento XML más extenso
  • Example#1244 - Iterando a través de un cursor de no-recorrido (sólo hacia adelante)
  • Example#1245 - Extrayendo filas específicas con db2_fetch_array con un cursor de recorrido
  • Example#1246 - Iterando a través de un cursor de no-recorrido (sólo hacia adelante)
  • Example#1247 - Extrayendo filas específicas con db2_fetch_assoc a partir de un cursor de recorrido
  • Example#1248 - Iterando a través de un cursor de no-recorrido (sólo hacia adelante)
  • Example#1249 - Extrayendo filas específicas con db2_fetch_both a partir de un cursor de recorrido
  • Example#1250 - Ejemplo de db2_fetch_object
  • Example#1251 - Iterando a través de un bloque de resultados
  • Example#1252 - Alternativas recomendadas para db2_fetch_row/db2_result en i5/OS
  • Example#1253 - Estableciendo y extrayendo parámetros a través de una conexión
  • Example#1254 - Ejemplo de db2_last_insert_id
  • Example#1255 - Iterando a través de diferentes tipos de datos
  • Example#1256 - Llamando a un procedimiento almacenado que devuelve múltiples resultados
  • Example#1257 - Extrayendo el número de campos de un resultado
  • Example#1258 - Cerrando una conexión persistente
  • Example#1259 - Ejemplo de db2_pconnect
  • Example#1260 - Utilizando contexto de confianza
  • Example#1261 - Preparando y ejecutando un comando SQL con marcadores de parámetros.
  • Example#1262 - Ejemplo de db2_result
  • Example#1263 - Cancelando una sentencia DELETE
  • Example#1264 - A db2_server_info example
  • Example#1265 - Setting one parameter with a connection resource
  • Example#1266 - Setting multiple parameters with a connection resource
  • Example#1267 - Setting multiple parameters with an invalid key
  • Example#1268 - Setting multiple parameters with an invalid value
  • Example#1269 - Setting multiple parameters with a connection resource and the wrong type
  • Example#1270 - Setting multiple parameters with the wrong resource
  • Example#1271 - Putting it all together
  • Example#1272 - i5/OS cursors are read-only
  • Example#1273 - Ejemplo de uso de PassEnv para Ingres
  • Example#1274 - Simple Ingres Example
  • Example#1275 - ingres_charset - Obtener el conjunto de caracteres de la instalación
  • Example#1276 - Abrir una conexión a un base de datos de Ingres
  • Example#1277 - Obtener el nombre del cursor para un recurso de consultas
  • Example#1278 - Obtener el númeor del último error generado de Ingres
  • Example#1279 - Obtener un mensaje del último error generado
  • Example#1280 - Obtener el código del último error SQLSTATE generado
  • Example#1281 - Escape special characters for use in a query
  • Example#1282 - Obtener una fila de resultados en un array
  • Example#1283 - Obtener una fila en un array asociativo
  • Example#1284 - Obtener una fila en un objeto
  • Example#1285 - Obtener el valor de retorno de una llamada a un procedimiento
  • Example#1286 - Obttener una fila de resultados en un array enumerado
  • Example#1287 - Liberar un recurso de resultados
  • Example#1288 - Enviar un simple select
  • Example#1289 - Pasar parámetros de consulta a ingres_query
  • Example#1290 - Insertar datos BLOB con tipos de parámetros
  • Example#1291 - Posicionar el cursor a la 3ª fila
  • Example#1292 - Establecer el formato de fecha a ISO4
  • Example#1293 - Set timezone to HONG-KONG
  • Example#1294 - Ejecutar un SELECT sencillo no almacenado en búfer
  • Example#1295 - Passing query parameters to ingres_unbuffered_query
  • Example#1296 - Insertar datos BLOB con tipos de parámetros
  • Example#1297 -
  • Example#1298 -
  • Example#1299 -
  • Example#1300 -
  • Example#1301 -
  • Example#1302 -
  • Example#1303 -
  • Example#1304 -
  • Example#1305 -
  • Example#1306 -
  • Example#1307 -
  • Example#1308 -
  • Example#1309 -
  • Example#1310 -
  • Example#1311 -
  • Example#1312 - Preferencias de lectura de URI de coneción con sintaxis de cadena de consulta
  • Example#1313 - Establecer las preferencias de lectura con sintaxis de array para conjuntos de etiquetas
  • Example#1314 - Pasar un WriteConcern a una operación de escritura
  • Example#1315 - WriteConcerns en cadena de conexión
  • Example#1316 - MongoDB::setWriteConcern y MongoCollection::setWriteConcern
  • Example#1317 - Asunto de escritura no reconocido, seguido de una escritura reconocida
  • Example#1318 - Escrituras reconocidas
  • Example#1319 - Escritura reconocida por la mayoría
  • Example#1320 - Escritura reconocida y esctrita en el diario
  • Example#1321 - Conectar a una instancia de MongoDB con encriptación SSL
  • Example#1322 - Conectar a una instancia de MongoDB con encriptación SSL, verificando que es quien se espera
  • Example#1323 - Conectar a una instancia de MongoDB que requiera certificados cliente
  • Example#1324 - Autenticación con certificados X.509
  • Example#1325 - Autenticación en la base de datos "admin"
  • Example#1326 - Autenticación en bases de datos normales
  • Example#1327 - Lista de semillas de ReplicaSet
  • Example#1328 - Duplicación errónea de un nombre de un conjunto de réplica
  • Example#1329 - Uso correcto de dos nombres de conjuntos de réplica
  • Example#1330 -
  • Example#1331 -
  • Example#1332 -
  • Example#1333 -
  • Example#1334 -
  • Example#1335 -
  • Example#1336 - Herencia de las preferencias de lectura del nivel de la base de datos hacia el cursor
  • Example#1337 -
  • Example#1338 -
  • Example#1339 -
  • Example#1340 -
  • Example#1341 -
  • Example#1342 -
  • Example#1343 -
  • Example#1344 - Uso básido de MongoClient
  • Example#1345 - Ejemplo de MongoClient::close
  • Example#1346 - Ejemplo de conjunto de réplica con MongoClient::__construct
  • Example#1347 - Conectarse a un socket de dominio
  • Example#1348 - Ejemplo de autenticación con MongoClient::__construct
  • Example#1349 - Ejemplo de preferencia de lectura con MongoClient::__construct
  • Example#1350 - Ejemplo de opciones de MongoClient::__construct
  • Example#1351 - Ejemplo de preferencia de lectura de MongoClient::__construct
  • Example#1352 - Ejemplo de MongoClient::getConnections
  • Example#1353 - Ejemplo de valor devuelto por MongoClient::getReadPreference
  • Example#1354 - Ejemplo del valor devuelto por MongoClient::getWriteConcern
  • Example#1355 - Ejemplo de MongoClient::killCursor
  • Example#1356 - Ejemplo de MongoClient::listDBs
  • Example#1357 - Ejemplo de MongoClient::selectCollection
  • Example#1358 - Ejemplo de sintaxis de array de conjunto de etiquetas con MongoClient::setReadPreference
  • Example#1359 - Ejemplo de MongoClient::setWriteConcern
  • Example#1360 - Seleccionar una base de datos
  • Example#1361 - Ejemplo de MongoDB::command con "distinct"
  • Example#1362 - Ejemplo de MongoDB::command con "distinct"
  • Example#1363 - Ejemplo de MongoDB::command con MapReduce
  • Example#1364 - Ejemplo de MongoDB::command con "geoNear"
  • Example#1365 - Ejemplo de MongoDB::createCollection para colección de tamaño fijo
  • Example#1366 - Ejemplo de MongoDB::createDBRef
  • Example#1367 - Ejemplo de MongoDB::createDBRef
  • Example#1368 - Ejemplo de MongoDB::drop
  • Example#1369 - Ejemplo sencillo de MongoDB::execute
  • Example#1370 - Ejemplo de parámetros en MongoDB::execute
  • Example#1371 - Ejemplo de ámbito
  • Example#1372 - Ejemplo de MongoDB::getCollectionInfo
  • Example#1373 - Ejemplo de MongoDB::getCollectionNames
  • Example#1374 - Ejemplo de MongoDB::getDBRef
  • Example#1375 - Ejemplo de MongoDB::getGridFS
  • Example#1376 - Ejemplo de valor devuelto de MongoDB::getReadPreference
  • Example#1377 - Ejemplo del valor devuelto por MongoDB::getWriteConcern
  • Example#1378 - Ejemplo de error null de MongoDB::lastError
  • Example#1379 - Ejemplo de error de clave duplicada con MongoDB::lastError
  • Example#1380 - Ejemplo de MongoDB::listCollections
  • Example#1381 - Ejemplo de MongoDB::repair
  • Example#1382 - Ejemplo de sintaxis de array de conjunto de etiquetas con MongoDB::setReadPreference
  • Example#1383 - Ejemplo de MongoDB::setWriteConcern
  • Example#1384 - Ejemplo de MongoCollection::aggregate
  • Example#1385 - Ejemplo de MongoCollection::aggregate
  • Example#1386 - Ejemplo de MongoCollection::aggregate
  • Example#1387 - MongoCollection::aggregate con opciones de comandos
  • Example#1388 - Ejemplo de MongoCollection::aggregateCursor
  • Example#1389 - Ejemplo de MongoCollection::aggregateCursor con un tamaño inicial de lote diferente
  • Example#1390 - Ejemplo de MongoCollection::batchInsert
  • Example#1391 - Ejemplo de MongoCollection::batchInsert ignorando errores
  • Example#1392 - Ejemplo de MongoCollection::count
  • Example#1393 - Ejemplo de MongoCollection::createDBRef
  • Example#1394 - Ejemplo de MongoCollection::ensureIndex
  • Example#1395 - Indexación geoespacial
  • Example#1396 - Ejemplo de eliminación de duplicados
  • Example#1397 - Ejemplo de MongoCollection::deleteIndex
  • Example#1398 - Ejemplo de MongoCollection::deleteIndexes
  • Example#1399 - Ejemplo de MongoCollection::distinct
  • Example#1400 - Ejemplo de MongoCollection::distinct sobre un documento embebido
  • Example#1401 - MongoCollection::drop example
  • Example#1402 - Ejemplo de MongoCollection::ensureIndex
  • Example#1403 - Indexación geoespacial
  • Example#1404 - Ejemplo de eliminación de duplicados
  • Example#1405 - Ejemplo de MongoCollection::find
  • Example#1406 - Ejemplo de MongoCollection::find
  • Example#1407 - Ejemplo de MongoCollection::find usando $where
  • Example#1408 - Ejemplo de MongoCollection::find usando $in
  • Example#1409 - Obtener resultados en forma de array
  • Example#1410 - Ejemplo de MongoCollection::findAndModify
  • Example#1411 - Manejo de errores de MongoCollection::findAndModify
  • Example#1412 - Ejemplo de MongoCollection::findOne buscando por id.
  • Example#1413 - Ejemplo de MongoCollection::findOne a partir de una condición.
  • Example#1414 - Ejemplo de MongoCollection::getDBRef
  • Example#1415 - Ejemplo de MongoCollection::getIndexInfo
  • Example#1416 - Ejemplo de MongoCollection::getName
  • Example#1417 - Ejemplo de valor devueto por MongoCollection::getReadPreference
  • Example#1418 - Ejemplo del valor devuelto por MongoCollection::getWriteConcern
  • Example#1419 - Ejemplo de MongoCollection::group
  • Example#1420 - Ejemplo de MongoCollection::group
  • Example#1421 - Pasar una función a keys
  • Example#1422 - Ejemplo de MongoCollection::insert con _id
  • Example#1423 - Ejemplo de escritura aceptada con MongoCollection::insert
  • Example#1424 - Ejmplo de MongoCollection::parallelCollectionScan
  • Example#1425 - Ejemplo de MongoCollection::remove con justOne
  • Example#1426 - Ejemplo de MongoCollection::save
  • Example#1427 - Ejemplo de sintaxis de array de conjunto de etiquetas con MongoCollection::setReadPreference
  • Example#1428 - Ejemplo de MongoDB::setWriteConcern
  • Example#1429 - Ejemplo de MongoCollection::toIndexString
  • Example#1430 - Ejemplo de MongoCollection::__toString
  • Example#1431 - MongoCollection::update
  • Example#1432 - Ejemplos de MongoCollection::update con upsert
  • Example#1433 - Ejemplo de múltiples MongoCollection::update
  • Example#1434 - Uso básico de MongoCursor
  • Example#1435 - Iterar sobre MongoCursor
  • Example#1436 - Añadir opciones a MongoCursor
  • Example#1437 - Ejemplo para añadir un comentario con MongoCursor::addOption
  • Example#1438 - Ejemplo de MongoCursor::addOption
  • Example#1439 - Ejemplo de MongoCursor::awaitData
  • Example#1440 - MongoCursor::batchSize y combinaciones con MongoCursor::limit
  • Example#1441 - Ejemplo de MongoCursor::count
  • Example#1442 - Ejemplo de MongoCursor::doQuery
  • Example#1443 - Ejemplo de MongoCursor::explain
  • Example#1444 - Ejemplo de valor devuelto de MongoCursor::getReadPreference
  • Example#1445 - Ejemplo de MongoCursor::info
  • Example#1446 - Ejemplo de MongoCursor::maxTimeMS
  • Example#1447 - Ejemplo de MongoCursor::setFlag
  • Example#1448 - Ejemplo de sintaxis de array de conjunto de etiquetas con MongoCursor::setReadPreference
  • Example#1449 - Ejemplo de MongoCursor::slaveOkay
  • Example#1450 - Ejemplo de MongoCursor::sort
  • Example#1451 - Ejemplo de MongoCursor::tailable
  • Example#1452 - Ejemplo de MongoCursor::timeout
  • Example#1453 - Añadir opciones a MongoCommandCursor
  • Example#1454 - MongoCommandCursor::batchSize
  • Example#1455 - Ejemplo de MongoCommandCursor
  • Example#1456 - MongoCommandCursor::createFromDocument
  • Example#1457 - Ejemplo de valor devuelto por MongoCommandCursor::getReadPreference
  • Example#1458 - Ejemplo de MongoCommandCursor::info
  • Example#1459 - MongoCommandCursor::rewind
  • Example#1460 - Ejemplo de sintaxis de array de conjunto de etiquetas de MongoCommandCursor::setReadPreference
  • Example#1461 - Ejemplo de MongoCommandCursor::timeout
  • Example#1462 - MongoId::__construct example
  • Example#1463 - Ejemplo con parámetros
  • Example#1464 - Ejemplo de MongoId::__toString
  • Example#1465 - Ejemplo de MongoCode::__construct
  • Example#1466 - Usando MongoCode con $where
  • Example#1467 - Ejemplo de MongoCode::__toString
  • Example#1468 - Almacenar datos con MongoDate
  • Example#1469 - Ejemplo de MongoDate::__construct
  • Example#1470 - Ejemplo de MongoDate::toDateTime
  • Example#1471 - Patrón de una expresión regular
  • Example#1472 - Ejemplo de MongoRegex::__construct
  • Example#1473 - Ejemplo de MongoRegex::__toString
  • Example#1474 -
  • Example#1475 - Vincular documentos
  • Example#1476 - Crear vínculos MongoDBRef
  • Example#1477 - Ejemplo de MongoDBRef::create
  • Example#1478 - Ejemplo de MongoCollection::createDBRef
  • Example#1479 - Ejemplo de MongoGridFS::findOne
  • Example#1480 - MongoGridFS::storeBytes com metadatos adicionales
  • Example#1481 - MongoGridFS::storeFile con metadatos adicionales
  • Example#1482 - Ejemplo de forumulario HTML con MongoGridFS::storeUpload
  • Example#1483 - Ejemplo de MongoGridFSFile::getBytes
  • Example#1484 - Ejemplo de MongoGridFSFile::getResource
  • Example#1485 - Ejemplo de MongoGridFSFile::write
  • Example#1486 - Ejemplo de MongoWriteBatch
  • Example#1487 - Ejemplo de MongoWriteBatch::add
  • Example#1488 - Ejemplo de MongoWriteBatch::add
  • Example#1489 - Ejemplo de MongoWriteBatch::add
  • Example#1490 - Ejemplo de MongoWriteBatch::add
  • Example#1491 - Ejemplo de MongoWriteBatch::add
  • Example#1492 - Ejemplo de MongoWriteBatch::add
  • Example#1493 - Ejemplo de MongoLog::setCallback
  • Example#1494 - Cambiar el tamaño de un agrupamiento
  • Example#1495 - Ejemplo de Mongo::setPoolSize
  • Example#1496 - Cambiar el tamaño de la agrupación
  • Example#1497 - Ejemplo de Mongo::setPoolSize
  • Example#1498 - Ejemplo de MongoResultException::getDocument
  • Example#1499 - Capturar una MongoDuplicateKeyException
  • Example#1500 - Capturar una MongoProtocolException
  • Example#1501 - MongoDB\Driver\Manager::__construct basic example
  • Example#1502 - MongoDB\Driver\Manager::__construct basic examples
  • Example#1503 - MongoDB\Driver\Manager::executeBulkWrite example
  • Example#1504 - MongoDB\Driver\Manager::executeCommand with a command returning a single result document
  • Example#1505 - MongoDB\Driver\Manager::executeCommand with a command returning a cursor
  • Example#1506 - Limiting execution time for a command
  • Example#1507 - MongoDB\Driver\Manager::executeQuery example
  • Example#1508 - Limiting execution time for a query
  • Example#1509 - MongoDB\Driver\Manager::getReadConcern example
  • Example#1510 - MongoDB\Driver\Manager::getReadPreference example
  • Example#1511 - MongoDB\Driver\Manager::getServers example
  • Example#1512 - MongoDB\Driver\Manager::getWriteConcern example
  • Example#1513 - Composing MongoDB\Driver\Command to provide a helper to create collections
  • Example#1514 - MongoDB\Driver\Command::__construct example
  • Example#1515 - MongoDB\Driver\Command::__construct example
  • Example#1516 - MongoDB\Driver\Query::__construct example
  • Example#1517 - Mixed write operations are grouped by type
  • Example#1518 - Ordered write operations causing an error
  • Example#1519 - MongoDB\Driver\BulkWrite::__construct example
  • Example#1520 - MongoDB\Driver\BulkWrite::count example
  • Example#1521 - MongoDB\Driver\BulkWrite::delete example
  • Example#1522 - MongoDB\Driver\BulkWrite::insert example
  • Example#1523 - MongoDB\Driver\BulkWrite::update example
  • Example#1524 - MongoDB\Driver\WriteConcern::bsonSerialize with majority write concern
  • Example#1525 - MongoDB\Driver\WriteConcern::bsonSerialize with wtimeout and journal
  • Example#1526 - MongoDB\Driver\WriteConcern::__construct example
  • Example#1527 - MongoDB\Driver\WriteConcern::getJournal example
  • Example#1528 - MongoDB\Driver\WriteConcern::getW example
  • Example#1529 - MongoDB\Driver\WriteConcern::getWtimeout example
  • Example#1530 - MongoDB\Driver\WriteConcern::isDefault example
  • Example#1531 - MongoDB\Driver\ReadPreference::bsonSerialize with primary read preference
  • Example#1532 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and tag sets
  • Example#1533 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and max staleness
  • Example#1534 - MongoDB\Driver\ReadPreference::__construct example
  • Example#1535 - MongoDB\Driver\ReadPreference::getMaxStalenessSeconds example
  • Example#1536 - MongoDB\Driver\ReadPreference::getMode example
  • Example#1537 - MongoDB\Driver\ReadPreference::getModeString example
  • Example#1538 - MongoDB\Driver\ReadPreference::getTagSets example
  • Example#1539 - MongoDB\Driver\ReadConcern::bsonSerialize with empty read concern
  • Example#1540 - MongoDB\Driver\ReadConcern::bsonSerialize with local read concern
  • Example#1541 - MongoDB\Driver\ReadConcern::__construct example
  • Example#1542 - MongoDB\Driver\ReadConcern::getLevel example
  • Example#1543 - MongoDB\Driver\ReadConcern::isDefault example
  • Example#1544 - Reading a result set
  • Example#1545 - Reading a result set for a tailable cursor
  • Example#1546 - MongoDB\Driver\Cursor::getId example
  • Example#1547 - MongoDB\Driver\Cursor::getServer example
  • Example#1548 - MongoDB\Driver\Cursor::isDead example
  • Example#1549 - MongoDB\Driver\Cursor::setTypeMap example
  • Example#1550 - MongoDB\Driver\Cursor::toArray example
  • Example#1551 - MongoDB\Driver\CursorId::__toString example
  • Example#1552 - MongoDB\Driver\Server::getHost example
  • Example#1553 - MongoDB\Driver\Server::getInfo example
  • Example#1554 - MongoDB\Driver\Server::getLatency example
  • Example#1555 - MongoDB\Driver\Server::getPort example
  • Example#1556 - MongoDB\Driver\WriteConcernError::getCode example
  • Example#1557 - MongoDB\Driver\WriteConcernError::getInfo example
  • Example#1558 - MongoDB\Driver\WriteConcernError::getMessage example
  • Example#1559 - MongoDB\Driver\WriteError::getCode example
  • Example#1560 - MongoDB\Driver\WriteError::getIndex example
  • Example#1561 - MongoDB\Driver\WriteError::getMessage example
  • Example#1562 - MongoDB\Driver\WriteResult::getDeletedCount example
  • Example#1563 - MongoDB\Driver\WriteResult::getInsertedCount example
  • Example#1564 - MongoDB\Driver\WriteResult::getMatchedCount example
  • Example#1565 - MongoDB\Driver\WriteResult::getModifiedCount example
  • Example#1566 - MongoDB\Driver\WriteResult::getServer example
  • Example#1567 - MongoDB\Driver\WriteResult::getUpsertedCount example
  • Example#1568 - MongoDB\Driver\WriteResult::getUpsertedIds example
  • Example#1569 - MongoDB\Driver\WriteResult::getWriteConcernError example
  • Example#1570 - MongoDB\Driver\WriteResult::getWriteErrors with a single error
  • Example#1571 - MongoDB\Driver\WriteResult::getWriteErrors with multiple errors
  • Example#1572 - MongoDB\Driver\WriteResult::isAcknowledged with acknowledged write concern
  • Example#1573 - MongoDB\Driver\WriteResult::isAcknowledged with unacknowledged write concern
  • Example#1574 - MongoDB\BSON\fromJSON example
  • Example#1575 - MongoDB\BSON\fromPHP example
  • Example#1576 - MongoDB\BSON\toCanonicalExtendedJSON example
  • Example#1577 - MongoDB\BSON\toJSON example
  • Example#1578 - MongoDB\BSON\toPHP example
  • Example#1579 - MongoDB\BSON\toRelaxedExtendedJSON example
  • Example#1580 - MongoDB\BSON\Binary::__construct example
  • Example#1581 - MongoDB\BSON\Binary::getData example
  • Example#1582 - MongoDB\BSON\Binary::getType example
  • Example#1583 - MongoDB\BSON\Binary::__toString example
  • Example#1584 - MongoDB\BSON\Decimal128::__construct example
  • Example#1585 - MongoDB\BSON\Decimal128::__toString example
  • Example#1586 - MongoDB\BSON\Javascript::__construct example
  • Example#1587 - MongoDB\BSON\Javascript::getCode example
  • Example#1588 - MongoDB\BSON\Javascript::getScope example
  • Example#1589 - MongoDB\BSON\Javascript::__toString example
  • Example#1590 - MongoDB\BSON\MaxKey::__construct example
  • Example#1591 - MongoDB\BSON\MinKey::__construct example
  • Example#1592 - MongoDB\BSON\ObjectId::__construct example
  • Example#1593 - MongoDB\BSON\ObjectId::getTimestamp example
  • Example#1594 - MongoDB\BSON\ObjectId::__toString example
  • Example#1595 - MongoDB\BSON\Regex::__construct example
  • Example#1596 - MongoDB\BSON\Regex::getFlags example
  • Example#1597 - MongoDB\BSON\Regex::getPattern example
  • Example#1598 - MongoDB\BSON\Regex::__toString example
  • Example#1599 - MongoDB\BSON\Timestamp::__construct example
  • Example#1600 - MongoDB\BSON\Timestamp::__toString example
  • Example#1601 - MongoDB\BSON\UTCDateTime::__construct example
  • Example#1602 - MongoDB\BSON\UTCDatetime::toDateTime example
  • Example#1603 - MongoDB\BSON\UTCDateTime::__toString example
  • Example#1604 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for root document
  • Example#1605 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for root document
  • Example#1606 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for document field
  • Example#1607 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for document field
  • Example#1608 - MongoDB\BSON\Unserializable::bsonUnserialize example
  • Example#1609 - MongoDB\Driver\Exception\WriteException::getWriteResult example
  • Example#1610 - Comparación de las tres API de MySQL
  • Example#1611 - Comandos de configuración para usar mysqlnd o libmysqlclient
  • Example#1612 - Ejemplo de consulta no almacenada en buffer: mysqli
  • Example#1613 - Ejemplo de consulta no almacenada en buffer: pdo_mysql
  • Example#1614 - Ejemplo de consulta no almacenada en buffer: mysql
  • Example#1615 - Problemas al establecer el conjunto de caracteres con SQL
  • Example#1616 - Ejemplo para establecer el conjunto de caracteres: mysqli
  • Example#1617 - Ejemplo para establecer el conjunto de caracteres: pdo_mysql
  • Example#1618 - Ejemplo para establecer el conjunto de caracteres: mysql
  • Example#1619 - Migración sencilla desde la antigua extensión mysql
  • Example#1620 - Interfaz orientada a objetos y procedimental
  • Example#1621 - Estilo de codificación malo
  • Example#1622 - Significado especial de localhost
  • Example#1623 - Configuración predeterminada
  • Example#1624 - Conectando a MySQL
  • Example#1625 - Navegación a través de resultados almacenados en buffer
  • Example#1626 - Navegación a través de resultados no almacenados en buffer
  • Example#1627 - El protocolo de texto devuelve cadenas de manera predeterminado
  • Example#1628 - Tipos de datos nativos con mysqlnd y la opción de conexión
  • Example#1629 - Primera etapa: prepación
  • Example#1630 - Segunda etapa: vincular y ejecutar
  • Example#1631 - INSERT preparada una vez, ejecutada múltiples veces
  • Example#1632 - Menos viajes de ida y vuelta usando SQL multi-INSERT
  • Example#1633 - Tipos de datos nativos
  • Example#1634 - Vinculación de variables de salida
  • Example#1635 - Usar mysqli_result para obtener los resultados
  • Example#1636 - Conjunto de resultados almacenado en buffer para la lectura flexible
  • Example#1637 - Llamar a un procedimiento almacenado
  • Example#1638 - Usar variables de sesión
  • Example#1639 - Obtener los resultados de procedimientos almacenados
  • Example#1640 - Procedimientos Almacenados y Sentencias Preparadas
  • Example#1641 - Procedimientos Almacenados y Sentencias Preparadas usando la API de vinculación
  • Example#1642 - Sentencias múltiples
  • Example#1643 - Inyección SQL
  • Example#1644 - Establecer el modo de autoconsignación con SQL y a través de la API
  • Example#1645 - Consignación y reinicio
  • Example#1646 - Acceder a los metadatos de un conjunto de resultados
  • Example#1647 - Metadatos de sentencias preparadas
  • Example#1648 - Ejemplo resumen de la extensión MySQLi
  • Example#1649 - Ejemplo de $mysqli->affected_rows
  • Example#1650 - Ejemplo de mysqli::autocommit
  • Example#1651 - Ejemplo de $mysqli->begin_transaction
  • Example#1652 - Ejemplo del método mysqli::change_user
  • Example#1653 - Ejemplo de mysqli::character_set_name
  • Example#1654 - Ejemplo de mysqli::commit
  • Example#1655 - $mysqli->connect_errno example
  • Example#1656 - Ejemplo de $mysqli->connect_error
  • Example#1657 - Ejemplo de mysqli::__construct
  • Example#1658 - Generando un fichero de prueba (traza)
  • Example#1659 - Ejemplo de $mysqli->errno
  • Example#1660 - Ejemplo de $mysqli->error_list
  • Example#1661 - Ejemplo de $mysqli->error
  • Example#1662 - Ejemplo de $mysqli->field_count
  • Example#1663 - mysqli::get_charset example
  • Example#1664 - mysqli_get_client_info
  • Example#1665 - mysqli_get_client_version
  • Example#1666 - Un ejemplo de mysqli_get_connection_stats
  • Example#1667 - Ejemplo de $mysqli->host_info
  • Example#1668 - Ejemplo de $mysqli->protocol_version
  • Example#1669 - Ejemplo de $mysqli->server_info
  • Example#1670 - Ejemplo de $mysqli->server_version
  • Example#1671 - Ejemplo de $mysqli->info
  • Example#1672 - Ejemplo de $mysqli->insert_id
  • Example#1673 - Ejemplo de mysqli::kill
  • Example#1674 - Ejemplo de mysqli::multi_query
  • Example#1675 - Ejemplo de mysqli::ping
  • Example#1676 - Un ejemplo de mysqli_poll
  • Example#1677 - Ejemplo de mysqli::prepare
  • Example#1678 - Ejemplo de mysqli::query
  • Example#1679 - Ejemplo de mysqli::real_connect
  • Example#1680 - Ejemplo de mysqli::real_escape_string
  • Example#1681 - Ejemplo de mysqli::rollback
  • Example#1682 - Ejemplo de mysqli::select_db
  • Example#1683 - Ejemplo de mysqli::set_charset
  • Example#1684 - Ejemplo de $mysqli->sqlstate
  • Example#1685 - Ejemplo de mysqli::stat
  • Example#1686 - Ejemplo $mysqli->thread_id
  • Example#1687 - Ejemplo de mysqli::use_result
  • Example#1688 - Ejemplo de $mysqli->warning_count
  • Example#1689 - Estilo orientado a objetos
  • Example#1690 - Estilo por procedimientos
  • Example#1691 - Estilo orientado a objetos
  • Example#1692 - Estilo por procedimientos
  • Example#1693 - Estilo orientado a objetos
  • Example#1694 - Estilo por procedimientos
  • Example#1695 - Estilo orientado a objetos
  • Example#1696 - Estilo por procedimientos
  • Example#1697 - Estilo orientado a objetos
  • Example#1698 - Estilo por procedimientos
  • Example#1699 - Estilo orientado a objetos
  • Example#1700 - Estilo por procedimientos
  • Example#1701 - Estilo orientado a objetos
  • Example#1702 - Estilo por procedimientos
  • Example#1703 - Estilo orientado a objetos
  • Example#1704 - Estilo por procedimientos
  • Example#1705 - Estilo orientado a objetos
  • Example#1706 - Estilo por procedimientos
  • Example#1707 - Estilo orientado a objetos
  • Example#1708 - Estilo por procedimientos
  • Example#1709 - Estilo orientado a objetos
  • Example#1710 - Estilo por procedimientos
  • Example#1711 - Estilo orientado a objetos
  • Example#1712 - Estilo por procedimientos
  • Example#1713 - Estilo orientado a objetos
  • Example#1714 - Estilo por procedimientos
  • Example#1715 - Estilo orientado a objetos
  • Example#1716 - Estilo por procedimientos
  • Example#1717 - Estilo orientado a objetos
  • Example#1718 - Estilo orientado a objetos
  • Example#1719 - Estilo por procedimientos
  • Example#1720 - Estilo orientado a objetos
  • Example#1721 - Estilo por procedimientos
  • Example#1722 - Estilo orientado a objetos
  • Example#1723 - Estilo por procedimientos
  • Example#1724 - Estilo orientado a objetos
  • Example#1725 - Estilo por procedimientos
  • Example#1726 - Estilo orientado a objetos
  • Example#1727 - Estilo por procedimientos
  • Example#1728 - Estilo orientado a objetos
  • Example#1729 - Estilo por procedimientos
  • Example#1730 - Un ejemplo de mysqli_result comparando el uso de iterator
  • Example#1731 - Estilo orientado a objetos
  • Example#1732 - Estilo por procedimientos
  • Example#1733 - Estilo orientado a objetos
  • Example#1734 - Estilo por procedimientos
  • Example#1735 - Estilo orientado a objetos
  • Example#1736 - Estilo por procedimientos
  • Example#1737 - Estilo orientado a objetos
  • Example#1738 - Estilo por procedimientos
  • Example#1739 - Estilo orientado a objetos
  • Example#1740 - Estilo por procedimientos
  • Example#1741 - Estilo orientado a objetos
  • Example#1742 - Estilo por procedimientos
  • Example#1743 - Estilo orientado a objetos
  • Example#1744 - Estilo por procedimientos
  • Example#1745 - Estilo orientado a objetos
  • Example#1746 - Estilo por procedimientos
  • Example#1747 - Estilo orientado a objetos
  • Example#1748 - Estilo por procedimientos
  • Example#1749 - Estilo orientado a objetos
  • Example#1750 - Estilo por procedimientos
  • Example#1751 - Ejemplo de mysqli_connect
  • Example#1752 - A mysqli_get_client_stats example
  • Example#1753 - Ejemplo general de la extensión MySQL
  • Example#1754 - Ejemplo de mysql_affected_rows
  • Example#1755 - Ejemplo de mysql_affected_rows al utilizar transacciones
  • Example#1756 - Ejemplo de mysql_client_encoding
  • Example#1757 - Ejemplo de mysql_close
  • Example#1758 - Ejemplo de mysql_connect
  • Example#1759 - Ejemplo de mysql_connect usando la sintaxis nombre_anfitrión:puerto
  • Example#1760 - Ejemplo de mysql_connect usando la sintaxis ":/rota/al/socket"
  • Example#1761 - Ejemplo alternativo de mysql_create_db
  • Example#1762 - Ejemplo de mysql_data_seek
  • Example#1763 - Ejemplo de mysql_db_name
  • Example#1764 - Ejemplo alternativo de mysql_db_query
  • Example#1765 - Ejemplo alternativo de mysql_drop_db
  • Example#1766 - Ejemplo de mysql_errno
  • Example#1767 - Ejemplo de mysql_error
  • Example#1768 - Ejemplo de mysql_escape_string
  • Example#1769 - Consulta con nombres de campos duplicados con alias
  • Example#1770 - mysql_fetch_array con MYSQL_NUM
  • Example#1771 - mysql_fetch_array con MYSQL_ASSOC
  • Example#1772 - mysql_fetch_array con MYSQL_BOTH
  • Example#1773 - Un ejemplo desarrolado de mysql_fetch_assoc
  • Example#1774 - Ejemplo de mysql_fetch_field
  • Example#1775 - Un ejemplo de mysql_fetch_lengths
  • Example#1776 - Ejemplo de mysql_fetch_object
  • Example#1777 - Ejemplo de mysql_fetch_object
  • Example#1778 - Recuperar una fila con mysql_fetch_row
  • Example#1779 - Un ejemplo de mysql_field_flags
  • Example#1780 - Ejemplo de mysql_field_len
  • Example#1781 - Ejemplo de mysql_field_name
  • Example#1782 - Un ejemplo de mysql_field_table
  • Example#1783 - Ejemplo de mysql_field_type
  • Example#1784 - Un ejemplo de mysql_free_result
  • Example#1785 - Ejemplo de mysql_get_client_info
  • Example#1786 - Ejemplo de mysql_get_host_info
  • Example#1787 - Ejemplo de mysql_get_proto_info
  • Example#1788 - Ejemplo de mysql_get_server_info
  • Example#1789 - Sentencias MySQL Relevantes
  • Example#1790 - Ejemplo de mysql_insert_id
  • Example#1791 - Ejemplo de mysql_list_dbs
  • Example#1792 - Alternativa para la obsoleta mysql_list_fields
  • Example#1793 - Ejemplo de mysql_list_processes
  • Example#1794 - Ejemplo alternativo de mysql_list_tables
  • Example#1795 - Un ejemplo de mysql_num_fields
  • Example#1796 - Ejemplo de mysql_num_rows
  • Example#1797 - Un ejemplo de mysql_ping
  • Example#1798 - Consulta inválida
  • Example#1799 - Consulta válida
  • Example#1800 - Ejemplo sencillo de mysql_real_escape_string
  • Example#1801 - mysql_real_escape_string requiere una conexión
  • Example#1802 - Un ejemplo de ataque de inyección de SQL
  • Example#1803 - Ejemplo de mysql_result
  • Example#1804 - Ejemplo mysql_select_db
  • Example#1805 - Ejemplo de mysql_stat
  • Example#1806 - Ejemplo alternativo de mysql_stat
  • Example#1807 - Ejemplo de mysql_tablename
  • Example#1808 - Ejemplo de mysql_thread_id
  • Example#1809 - Habilitar el complemento (php.ini)
  • Example#1810 - Fichero de configuración mínima específico del complemento (mysqlnd_ms_plugin.ini)
  • Example#1811 - Configuración mínima recomendada específica del complemento (mysqlnd_ms_plugin.ini)
  • Example#1812 - Usar un servidor como maestro y esclavo (¡solamente para pruebas!)
  • Example#1813 - Fichero de configuración específico del complemento (mysqlnd_ms_plugin.ini)
  • Example#1814 - Abrir una conexión con equilibrado de carga
  • Example#1815 - Ejecutar sentencias
  • Example#1816 - Configuración del complemento con un esclavo y un maestro
  • Example#1817 - Problema: estado de conexión y variables SQL de usuario
  • Example#1818 - Configuración del complemento con un esclavo y un maestro
  • Example#1819 - Sugerencias SQL para evitar el intercambio de conexión
  • Example#1820 - Enfrentarse a la demora de replicación
  • Example#1821 - Creación de una tabla en un esclavo
  • Example#1822 - Configuración del complemento con un esclavo y un maestro
  • Example#1823 - Usar sugerencias SQL para transacciones
  • Example#1824 - Equilibrado de carga considerando transacciones: el ajuste trx_stickiness
  • Example#1825 - Consideración de transacciones
  • Example#1826 - Patrón general para transacciones XA
  • Example#1827 - Las transacciones locales y globales son mutuamente exclusivas
  • Example#1828 - Almacenamiento del estado del coordinador de transacciones
  • Example#1829 - Consistencia de sesión: lectura de sus escrituras
  • Example#1830 - Solicitud de consistencia de sesión
  • Example#1831 - Edad máxima/demora del esclavo
  • Example#1832 - Limitar la demora del esclavo
  • Example#1833 - La tolerancia a fallos no está establecida
  • Example#1834 - No hay esclavos dentro del límite de tiempo
  • Example#1835 - Crear una tabla contador en el maestro
  • Example#1836 - Configuración del complemento: SQL para la inyección del GTID en el lado del cliente
  • Example#1837 - Inyección transparente del ID de transacciones global
  • Example#1838 - Configuración del complemento: SQL para obtener el GTID
  • Example#1839 - Obtener el GTID después de la ejecución
  • Example#1840 - Configuración del complemento: comprobar un GTID en particular
  • Example#1841 - Nivel de servicio de consistencia de sesión y GTID combinados
  • Example#1842 - Configuración de complemento: usar la característica del GTID interna de MySQL 5.6.5-m8
  • Example#1843 - Resumen: calidad del servicio para solicitar la lectura de sus escrituras
  • Example#1844 - Configuración del complemento: sin entradas especiales para la caché
  • Example#1845 - Almacenar en caché una petición a un servidor
  • Example#1846 - Lectura de sus escrituras y almacenamiento en la caché combinados
  • Example#1847 - Tolerancia a fallos manual, opcional automática
  • Example#1848 - Tolerancia a fallos manual
  • Example#1849 - Clúster de grupos de nodos
  • Example#1850 - Particionamiento manual usando sugerencias SQL
  • Example#1851 - Configuración del complemento: hosts de Fabric en lugar de servidores MySQL
  • Example#1852 - Particionameinto manual usando sugerencias SQL
  • Example#1853 - Provocar un error de conexión
  • Example#1854 - Error de conexión en la ejecución de una consulta
  • Example#1855 - Provocar un error de conexión
  • Example#1856 - Tolerancia a fallos más básica
  • Example#1857 - Provocar un error transitorio
  • Example#1858 - Bucle de reintentos del error transitorio
  • Example#1859 - Habilitar el complemento (php.ini)
  • Example#1860 - Configuración básica del complemento (mysqlnd_ms_plugin.ini) para la Replicación de MySQL
  • Example#1861 - Múltiples primarios - multimaestro (php.ini)
  • Example#1862 - Copia primaria con múltiples primarios y particionamiento
  • Example#1863 - Múltiples primarios - multimaestro (php.ini)
  • Example#1864 - Clúster de actualización en cualquier sitio sincrónico
  • Example#1865 - Patrón general para transacciones XA
  • Example#1866 - Convertir un array de PHP (hash) al formato JSON
  • Example#1867 - Ejemplo del uso de nombres de sección
  • Example#1868 - Lista de esclavos anónimos
  • Example#1869 - Lista de maestros usando nombres simbólicos
  • Example#1870 - Palabras clave para configurar un servidor
  • Example#1871 - El nuevo filtro roundrobin, funcionalidad antigua
  • Example#1872 - El filtro user reemplaza a mysqlnd_ms_set_user_pick_server
  • Example#1873 - Mensaje de error común en caso de problemas con el fichero de configuración (hasta la versión 1.5.0)
  • Example#1874 - Validación mejorada del fichero de configuración desde 1.5.0
  • Example#1875 - Error posiblemente más preciso debido a mysqlnd_ms.force_config_usage=1
  • Example#1876 - Configuración mínima del complemento para usar con MySQL Fabric
  • Example#1877 - Tiempo de espera opcional para la comunicación con Fabric
  • Example#1878 - Advertencias sobre la violación de límites de transacciones
  • Example#1879 - Secuencia de filtros inválida
  • Example#1880 - Equilibrado de carga aleatorio con el filtro random
  • Example#1881 - Equilibrado de carga "aleatoria una vez" con el filtro random
  • Example#1882 - Error de referencia
  • Example#1883 - Asignar weight para el equilibrado de carga
  • Example#1884 - Filtro roundrobin
  • Example#1885 - Establecer una llamada de retorno
  • Example#1886 - Utilizar una llamada de retorno
  • Example#1887 - Devolver maestros y esclavos aleatorios
  • Example#1888 - Particionamiento manual
  • Example#1889 - Límite global de la demora de los esclavos
  • Example#1890 - Tolerancia a fallos opcional en el maestro al fallar una conexión a un esclavo
  • Example#1891 - Nueva sintaxis desde 1.4.0
  • Example#1892 - Deshabilitar las conexiones retardadas
  • Example#1893 - Escapado de cadenas de texto sobre un gestor de conexiones retardadas
  • Example#1894 - master_on_write para lecturas consistentes
  • Example#1895 - Utilizar el maestro para ejecutar transacciones
  • Example#1896 - Sin tolerancia a fallos automáticia, inconveniente al manejar errores
  • Example#1897 - Bucle de reintentos para errores transitorios
  • Example#1898 - Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL
  • Example#1899 - Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL
  • Example#1900 - Definición SQL para la tabla de transacciones de almacenamiento de estado de MySQL
  • Example#1901 - Ejemplo del uso de nombres de sección
  • Example#1902 - Sintaxis de lista
  • Example#1903 - Comprobar la actividad del complemento en un modelo de desarrollo sin hilos
  • Example#1904 - Registrar las estadístcias durante el cierre
  • Example#1905 - Ejemplo demostrando el uso de constantes de mysqlnd_ms
  • Example#1906 - Ejemplo de mysqlnd_ms_dump_servers
  • Example#1907 - Ejemplo de mysqlnd_ms_get_last_gtid
  • Example#1908 - Ejemplo de mysqlnd_ms_get_last_used_connection
  • Example#1909 - Ejemplo de mysqlnd_ms_get_stats
  • Example#1910 - Ejemplo de mysqlnd_ms_match_wild
  • Example#1911 - Ejemplo de mysqlnd_ms_query_is_select
  • Example#1912 - Ejemplo de mysqlnd_ms_set_qos
  • Example#1913 - Ejemplo de mysqlnd_ms_set_user_pick_server
  • Example#1914 - Habilitar el complemento (php.ini)
  • Example#1915 - Usar la sugerencia SQL MYSQLND_QC_ENABLE_SWITCH
  • Example#1916 - Usar la sugerencia SQL MYSQLND_QC_DISABLE_SWITCH
  • Example#1917 - Ejemplo que muestra qué tipos de sentencias no son almacenadas en la caché
  • Example#1918 - Habilitar el almacenamiento en caché de todas las sentencias usando el ajuste ini mysqlnd_qc.cache_no_table
  • Example#1919 - Establecer el TTL con el ajuste ini mysqlnd_qc.ttl
  • Example#1920 - Establecer el TTL con sugerencias SQL
  • Example#1921 - Establecer una llamada de retorno con mysqlnd_qc_set_is_select
  • Example#1922 - Habilitar el mecanismo de defensa de cierre
  • Example#1923 - Recopilar un rastreo de consulta
  • Example#1924 - Establecer la profundidad de la búsqueda de rastros con el ajuste ini mysqlnd_qc.query_trace_bt_depth
  • Example#1925 - Recopilar datos de estadísticas con el ajuste ini mysqlnd_qc.time_statistics
  • Example#1926 - Ejemplo del uso de mysqlnd_qc_get_cache_info
  • Example#1927 - Ejemplo del uso de mysqlnd_qc_get_normalized_query_trace_log
  • Example#1928 - Utilizar un gestor de almacenamiento definido por el usuario
  • Example#1929 - Usar constantes de sugerencias SQL
  • Example#1930 - Ejemplo del uso de mysqlnd_qc_set_cache_condition
  • Example#1931 - Ejemplo de mysqlnd_qc_get_available_handlers
  • Example#1932 - Ejemplo de mysqlnd_qc_get_cache_info
  • Example#1933 - Ejemplo de mysqlnd_qc_get_core_stats
  • Example#1934 - Ejemplo de mysqlnd_qc_get_normalized_query_trace_log
  • Example#1935 - Ejemplo de mysqlnd_qc_get_query_trace_log
  • Example#1936 - Ejemplo de mysqlnd_qc_set_cache_condition
  • Example#1937 - Ejemplo de mysqlnd_qc_set_is_select
  • Example#1938 - Ejemplo de mysqlnd_qc_set_storage_handler
  • Example#1939 - Habilitar el complemento (php.ini)
  • Example#1940 - Pseudocódigo: qué hace la clase interna
  • Example#1941 - Instalar un proxy
  • Example#1942 - Registro del proxy, mysqlnd_uh.enable=1
  • Example#1943 - La instalación del proxy deshabilitada
  • Example#1944 - Proxy de conexión
  • Example#1945 - Proxy de sentencia preparada
  • Example#1946 - Monitorización básica
  • Example#1947 - Ejemplo de MysqlndUhConnection::changeUser
  • Example#1948 - Ejemplo de MysqlndUhConnection::charsetName
  • Example#1949 - Ejemplo de MysqlndUhConnection::close
  • Example#1950 - Ejemplo de MysqlndUhConnection::connect
  • Example#1951 - Ejemplo de MysqlndUhConnection::endPSession
  • Example#1952 - Ejemplo de MysqlndUhConnection::escapeString
  • Example#1953 - Ejemplo de MysqlndUhConnection::getAffectedRows
  • Example#1954 - Ejemplo de MysqlndUhConnection::getErrorNumber
  • Example#1955 - Ejemplo de MysqlndUhConnection::getErrorString
  • Example#1956 - Ejemplo de MysqlndUhConnection::getFieldCount
  • Example#1957 - Ejemplo de MysqlndUhConnection::getHostInformation
  • Example#1958 - Ejemplo de MysqlndUhConnection::getLastInsertId
  • Example#1959 - Ejemplo de MysqlndUhConnection::getLastMessage
  • Example#1960 - Ejemplo de MysqlndUhConnection::getProtocolInformation
  • Example#1961 - Ejemplo de MysqlndUhConnection::getServerInformation
  • Example#1962 - Ejemplo de MysqlndUhConnection::getServerStatistics
  • Example#1963 - Ejemplo de MysqlndUhConnection::getServerVersion
  • Example#1964 - Ejemplo de MysqlndUhConnection::getSqlstate
  • Example#1965 - Ejemplo de MysqlndUhConnection::getStatistics
  • Example#1966 - Ejemplo de MysqlndUhConnection::getThreadId
  • Example#1967 - Ejemplo de MysqlndUhConnection::getWarningCount
  • Example#1968 - Ejemplo de MysqlndUhConnection::init
  • Example#1969 - Ejemplo de MysqlndUhConnection::kill
  • Example#1970 - Ejemplo de MysqlndUhConnection::listFields
  • Example#1971 - Ejemplo de MysqlndUhConnection::listMethod
  • Example#1972 - Ejemplo de MysqlndUhConnection::moreResults
  • Example#1973 - Ejemplo de MysqlndUhConnection::nextResult
  • Example#1974 - Ejemplo de MysqlndUhConnection::ping
  • Example#1975 - Ejemplo de MysqlndUhConnection::query
  • Example#1976 - Ejemplo de MysqlndUhConnection::queryReadResultsetHeader
  • Example#1977 - Ejemplo de MysqlndUhConnection::reapQuery
  • Example#1978 - Ejemplo de MysqlndUhConnection::refreshServer
  • Example#1979 - Ejemplo de MysqlndUhConnection::restartPSession
  • Example#1980 - Ejemplo de MysqlndUhConnection::selectDb
  • Example#1981 - Ejemplo de MysqlndUhConnection::sendClose
  • Example#1982 - Ejemplo de MysqlndUhConnection::sendQuery
  • Example#1983 - Ejemplo de MysqlndUhConnection::serverDumpDebugInformation
  • Example#1984 - Ejemplo de MysqlndUhConnection::setAutocommit
  • Example#1985 - Ejemplo de MysqlndUhConnection::setCharset
  • Example#1986 - Ejemplo de MysqlndUhConnection::setClientOption
  • Example#1987 - Ejemplo de MysqlndUhConnection::setServerOption
  • Example#1988 - Ejemplo de MysqlndUhConnection::simpleCommand
  • Example#1989 - Ejemplo de MysqlndUhConnection::simpleCommandHandleResponse
  • Example#1990 - Ejemplo de MysqlndUhConnection::sslSet
  • Example#1991 - Ejemplo de MysqlndUhConnection::stmtInit
  • Example#1992 - Ejemplo de MysqlndUhConnection::storeResult
  • Example#1993 - Ejemplo de MysqlndUhConnection::txCommit
  • Example#1994 - Ejemplo de MysqlndUhConnection::txRollback
  • Example#1995 - Ejemplo de MysqlndUhConnection::useResult
  • Example#1996 - Ejemplo de MysqlndUhPreparedStatement::execute
  • Example#1997 - Ejemplo de MysqlndUhPreparedStatement::prepare
  • Example#1998 - Ejemplo de mysqlnd_uh_convert_to_mysqlnd
  • Example#1999 - Ejemplo de mysqlnd_uh_set_connection_proxy
  • Example#2000 - Habilitar el complemento (php.ini)
  • Example#2001 - Tabla SQL empleada para la Guía rápida
  • Example#2002 - Ejemplo básico
  • Example#2003 - Ejemplo de mysqlnd_memcache_get_config
  • Example#2004 - Ejemplo de mysqlnd_memcache_set con var_dump como una retrollama de depuración simple.
  • Example#2005 - Consulta básica
  • Example#2006 - Inserción con variables vinculadas
  • Example#2007 - Vincular la cláusula WHERE a una consulta
  • Example#2008 - Insertar datos en una columna CLOB
  • Example#2009 - Usar una función almacenada de PL/SQL
  • Example#2010 - Utilizar un procedimiento almacenado de PL/SQL
  • Example#2011 - Llamar a una función de PL/SQL que devuelve un REF CURSOR
  • Example#2012 -
  • Example#2013 - user_oci8_probes.d para rasrear todos los Sondeos estáticos de OCI8 para PHP al nivel de usuario con DTrace
  • Example#2014 - Ejemplo de oci_bind_array_by_name
  • Example#2015 - Insertar datos con oci_bind_by_name
  • Example#2016 - Vincular una vez para múltiples ejecuciones
  • Example#2017 - Vinculación con un bucle foreach
  • Example#2018 - Vinculación en una cláusula WHERE
  • Example#2019 - Vinculación con una cláusula LIKE
  • Example#2020 - Vinculación con REGEXP_LIKE
  • Example#2021 - Vinculación de múltiples valores en una cláusula IN
  • Example#2022 - Vinculación de un ROWID devuelto por una consulta
  • Example#2023 - Vinculación de un ROWID sobre INSERT
  • Example#2024 - Vinculación para una función almacenada de PL/SQL
  • Example#2025 - Vinculación de parámetros para un procedimiento almacenado de PL/SQL
  • Example#2026 - Vinculación de una columna CLOB
  • Example#2027 - Vincular un BOOLEAN de PL/SQL
  • Example#2028 - Ejemplo de oci_client_version
  • Example#2029 - Cerrar una conexión
  • Example#2030 - Las conexiones a bases de datos no se cierran hasta que todas las referencias sean cerradas
  • Example#2031 - Cerrar una conexión abierta más de una vez
  • Example#2032 - Las conexsiones se cierran cuando las variables salen de su ámbito
  • Example#2033 - Ejemplo de oci_commit
  • Example#2034 - Uso básico de oci_connect utilizando la sintaxis de Easy Connect
  • Example#2035 - Uso básico de oci_connect utilizando un nombre de Network Connect
  • Example#2036 - oci_connect con un conjunto de caracteres explícito
  • Example#2037 - Usar múltiples llamadas a oci_connect
  • Example#2038 - Ejemplo de oci_define_by_name
  • Example#2039 - oci_define_by_name con nombres de columna sensibles al uso de mayúsculas/minúsculas
  • Example#2040 - oci_define_by_name con columnas de tipo LOB
  • Example#2041 - oci_define_by_name con un tipo explícito
  • Example#2042 - Mostrar el mensaje de error de Oracle después de un error de conexión
  • Example#2043 - Mostrar el mensaje de error de Oracle después de un error de análisis
  • Example#2044 - Mostrar el mensaje de error de Oracle, la sentencia problemática, y la posición del problema en un error de ejecución
  • Example#2045 - oci_execute para consultas
  • Example#2046 - Ejemplo de oci_execute sin especificar un modo
  • Example#2047 - Ejemplo de oci_execute con OCI_NO_AUTO_COMMIT
  • Example#2048 - Ejemplo de oci_execute con diferentes modos de consolidación
  • Example#2049 - Ejemplo de oci_execute con OCI_DESCRIBE_ONLY
  • Example#2050 - Ejemplo de oci_fetch_all
  • Example#2051 - Ejemplo de oci_fetch_all con OCI_FETCHSTATEMENT_BY_ROW
  • Example#2052 - oci_fetch_all con OCI_NUM
  • Example#2053 - oci_fetch_array con OCI_BOTH
  • Example#2054 - oci_fetch_array con OCI_NUM
  • Example#2055 - oci_fetch_array con OCI_ASSOC
  • Example#2056 - oci_fetch_array con OCI_RETURN_NULLS
  • Example#2057 - oci_fetch_array con OCI_RETURN_LOBS
  • Example#2058 - oci_fetch_array con nombres de columna sensibles al uso de mayúsculas/minúsculas
  • Example#2059 - oci_fetch_array con columnas que tienen nombres duplicados
  • Example#2060 - oci_fetch_array con columnas DATE
  • Example#2061 - oci_fetch_array con REF CURSOR
  • Example#2062 - Paginación con oci_fetch_array usando una consulta como LIMIT
  • Example#2063 - oci_fetch_array con Conjuntos de Resultados Implícitos de Oracle Database 12c
  • Example#2064 - Ejemplo de oci_fetch_assoc
  • Example#2065 - Ejemplo de oci_fetch_object
  • Example#2066 - oci_fetch_object con nombres de columnas sensibles al uso de mayúsculas/minúsculas
  • Example#2067 - oci_fetch_object con LOBs
  • Example#2068 - Ejemplo de oci_fetch_row
  • Example#2069 - oci_fetch con variables definidas
  • Example#2070 - oci_fetch con oci_result
  • Example#2071 - Ejemplo de oci_field_name
  • Example#2072 - Ejemplo de oci_field_name
  • Example#2073 - Ejemplo de oci_field_precision
  • Example#2074 - oci_field_scale Example
  • Example#2075 - Ejemplo de oci_field_size
  • Example#2076 - oci_field_type_raw Example
  • Example#2077 - Ejemplo de oci_field_type
  • Example#2078 - Obtener Conjuntos de resultados implícitos en un blucle
  • Example#2079 - Obtener gestores de sentencias hijas individualemente
  • Example#2080 - Establecer explícitamente la Cuenta de precarga
  • Example#2081 - Ejemplo de Conjunto de resultados implícitos sin usar oci_get_implicit_resultset
  • Example#2082 - Ejemplo de oci_new_connect
  • Example#2083 - Vincular un REF CURSOR en una llamada a un procedimiento almacenado de Oracle
  • Example#2084 - Ejemplo de oci_new_descriptor
  • Example#2085 - Ejemplo de oci_new_descriptor
  • Example#2086 - Ejemplo de oci_num_fields
  • Example#2087 - Ejemplo de oci_num_rows
  • Example#2088 - Ejemplo de oci_parse para sentencias SQL
  • Example#2089 - Ejemplo de oci_parse para sentencias PL/SQL
  • Example#2090 - Ejemplo de oci_password_change cambiando la contraseña de un usuario ya conectado
  • Example#2091 - Ejemplo de oci_password_change conectando y cambiando la contraseña en un solo paso
  • Example#2092 - Ejemplo básico de oci_pconnect usando la sintaxis de Easy Connect
  • Example#2093 - oci_fetch con oci_result
  • Example#2094 - Ejemplo de oci_rollback
  • Example#2095 - Ejemplo de reversión a un SAVEPOINT
  • Example#2096 - Ejemplo de oci_server_version
  • Example#2097 - Establecer la acción
  • Example#2098 - Setting the timeout
  • Example#2099 - Establecer el identificador del cliente para el usuario de la aplicación
  • Example#2100 - Establecer la información del cliente
  • Example#2101 - Setting the DBOP
  • Example#2102 - Dos scripts pueden usar diferentes versiones de myfunc() a la vez
  • Example#2103 - Establecer el nombre del módulo
  • Example#2104 - Cambiar el valor de precarga predeterminado para una consulta
  • Example#2105 - Cambiar la precarga predeterminada para la obtención de un REF CURSOR
  • Example#2106 - Establecer el valor de precarga cuando se vuelve a pasar un REF CURSOR a Oracle
  • Example#2107 - Ejemplo de oci_statement_type
  • Example#2108 - Creación de una base de datos Paradox con dos campos
  • Example#2109 - Convierte una fecha en el archivo paradox en un formato legible por humanos
  • Example#2110 - Establece los campos fecha/hora en una base de datos paradox a la fecha/hora actual
  • Example#2111 - Abrir una base de datos Paradox
  • Example#2112 - Abrir una base de datos Paradox
  • Example#2113 - Conversión de una fecha y hora paradox en un formato legible por humanos
  • Example#2114 - Ejemplo resumido de la extensión PostgreSQL
  • Example#2115 - Ejemplo de pg_affected_rows
  • Example#2116 - Ejemplo de pg_cancel_query
  • Example#2117 - Ejemplo de pg_client_encoding
  • Example#2118 - Ejemplo de pg_close
  • Example#2119 - Usando pg_connect
  • Example#2120 - Ejemplo de pg_connection_busy
  • Example#2121 - Ejemplo de pg_connection_reset
  • Example#2122 - Ejemplo de pg_connection_status
  • Example#2123 - Ejemplo de pg_convert
  • Example#2124 - Ejemplo de la función pg_copy_from
  • Example#2125 - Ejemplo de pg_copy_to
  • Example#2126 - Ejemplo de pg_dbname
  • Example#2127 - Ejemplo de la función pg_delete
  • Example#2128 - pg_end_copy example
  • Example#2129 - Ejemplo de pg_escape_bytea
  • Example#2130 - pg_escape_identifier example
  • Example#2131 - pg_escape_literal example
  • Example#2132 - pg_escape_string example
  • Example#2133 - Usando pg_execute
  • Example#2134 - pg_fetch_all_columns example
  • Example#2135 - PostgreSQL fetch all
  • Example#2136 - pg_fetch_array example
  • Example#2137 - pg_fetch_assoc example
  • Example#2138 - pg_fetch_object example
  • Example#2139 - pg_fetch_result example
  • Example#2140 - pg_fetch_row example
  • Example#2141 - pg_field_is_null example
  • Example#2142 - Getting information about fields
  • Example#2143 - Getting information about fields
  • Example#2144 - Getting information about fields
  • Example#2145 - Getting information about fields
  • Example#2146 - Getting table information about a field
  • Example#2147 - Getting information about fields
  • Example#2148 - Obtención de información sobre los campos
  • Example#2149 - pg_free_result example
  • Example#2150 - PostgreSQL NOTIFY message
  • Example#2151 - PostgreSQL backend PID
  • Example#2152 - pg_get_result example
  • Example#2153 - Ejemplo de pg_host
  • Example#2154 - pg_insert example
  • Example#2155 - Ejemplo depg_last_error
  • Example#2156 - Ejemplo de pg_last_notice
  • Example#2157 - pg_last_oid example
  • Example#2158 - pg_lo_close example
  • Example#2159 - pg_lo_create example
  • Example#2160 - pg_lo_export example
  • Example#2161 - pg_lo_import example
  • Example#2162 - pg_lo_open example
  • Example#2163 - pg_lo_read_all example
  • Example#2164 - pg_lo_read example
  • Example#2165 - pg_lo_seek example
  • Example#2166 - pg_lo_tell example
  • Example#2167 - pg_lo_truncate example
  • Example#2168 - pg_lo_unlink example
  • Example#2169 - pg_lo_write example
  • Example#2170 - Getting table metadata
  • Example#2171 - pg_num_fields example
  • Example#2172 - pg_num_rows example
  • Example#2173 - Ejemplo de pg_options
  • Example#2174 - pg_parameter_status example
  • Example#2175 - Usando pg_pconnect
  • Example#2176 - Ejemplo de pg_ping
  • Example#2177 - Ejemplo de pg_port
  • Example#2178 - Usando pg_prepare
  • Example#2179 - pg_put_line example
  • Example#2180 - Using pg_query_params
  • Example#2181 - Ejemplo de pg_query
  • Example#2182 - Uso de pg_query con varias sentencias
  • Example#2183 - pg_result_error_field example
  • Example#2184 - pg_result_error example
  • Example#2185 - pg_result_seek example
  • Example#2186 - pg_result_status example
  • Example#2187 - pg_select example
  • Example#2188 - Using pg_send_execute
  • Example#2189 - Utilizando pg_send_prepare
  • Example#2190 - Using pg_send_query_params
  • Example#2191 - pg_send_query example
  • Example#2192 - pg_set_client_encoding example
  • Example#2193 - pg_set_error_verbosity example
  • Example#2194 - pg_trace example
  • Example#2195 - Ejemplo de pg_transaction_status
  • Example#2196 - Ejemplo de pg_tty
  • Example#2197 - pg_unescape_bytea example
  • Example#2198 - Ejemplo de pg_untrace
  • Example#2199 - Ejemplo de pg_update
  • Example#2200 - Ejemplo de pg_version
  • Example#2201 - Backup an existing database
  • Example#2202 - Ejemplo de SQLite3::changes
  • Example#2203 - Ejemplo de SQLite3::close
  • Example#2204 - Ejemplo de SQLite3::__construct
  • Example#2205 - SQLite3::createCollation
  • Example#2206 - Ejemplo de SQLite3::createFunction
  • Example#2207 - SQLite3::enableExceptions example
  • Example#2208 - Ejemplo de SQLite3::exec
  • Example#2209 - Ejemplo de SQLite3::loadExtension
  • Example#2210 - Ejemplo de SQLite3::open
  • Example#2211 - SQLite3::openBlob example
  • Example#2212 - Incrementally writing a BLOB
  • Example#2213 - Ejemplo de SQLite3::prepare
  • Example#2214 - Ejemplo de SQLite3::query
  • Example#2215 - Ejemplo de SQLite3::querySingle
  • Example#2216 - SQLite3::setAuthorizer example
  • Example#2217 - Ejemplo de SQLite3::version
  • Example#2218 - Ejemplo de SQLite3Stmt::bindValue
  • Example#2219 - Inspecting the expanded SQL
  • Example#2220 - Ejemplo de sqlsrv_begin_transaction
  • Example#2221 - Ejemplo de sqlsrv_cancel
  • Example#2222 - Ejemplo de sqlsrv_client_info
  • Example#2223 - Ejemplo de sqlsrv_close
  • Example#2224 - Ejemplo de sqlsrv_commit
  • Example#2225 - Conectar utilizando autenticación Windows.
  • Example#2226 - Conectar especificando nombre de usuario y contraseña.
  • Example#2227 - Conectar a un puerto específico.
  • Example#2228 - ejemplo de functionname
  • Example#2229 - ejemplo de sqlsrv_execute
  • Example#2230 - Devolver un array asociativo.
  • Example#2231 - Devolver un array numérico.
  • Example#2232 - Ejemplo con sqlsrv_fetch_object
  • Example#2233 - Ejemplo con sqlsrv_fetch
  • Example#2234 - Ejemplo con sqlsrv_field_metadata
  • Example#2235 - sqlsrv_free_stmt example
  • Example#2236 - sqlsrv_get_field example
  • Example#2237 - sqlsrv_has_rows example
  • Example#2238 - sqlsrv_next_result example
  • Example#2239 - sqlsrv_num_fields example
  • Example#2240 - sqlsrv_num_rows example
  • Example#2241 - sqlsrv_prepare example
  • Example#2242 - sqlsrv_query example
  • Example#2243 - sqlsrv_rollback example
  • Example#2244 - sqlsrv_rows_affected example
  • Example#2245 - sqlsrv_send_stream_data example
  • Example#2246 - sqlsrv_server_info example
  • Example#2247 - Putting and getting a key-value pair
  • Example#2248 - TokyoTyrant::add example
  • Example#2249 - TokyoTyrant::connect example
  • Example#2250 - TokyoTyrant::connectUri example
  • Example#2251 - TokyoTyrant::copy example
  • Example#2252 - TokyoTyrant::ext example
  • Example#2253 - TokyoTyrant::fwmKeys example
  • Example#2254 - TokyoTyrant::get example
  • Example#2255 - TokyoTyrant::getIterator example
  • Example#2256 - TokyoTyrant::num example
  • Example#2257 - TokyoTyrant::out example
  • Example#2258 - TokyoTyrant::put example
  • Example#2259 - TokyoTyrant::putCat example
  • Example#2260 - tokyotyrant::putKeep example
  • Example#2261 - TokyoTyrant::putNr example
  • Example#2262 - TokyoTyrant::putShl example
  • Example#2263 - TokyoTyrant::setMaster example
  • Example#2264 - TokyoTyrant::size example
  • Example#2265 - TokyoTyrant::stat example
  • Example#2266 - TokyoTyrant::vanish example
  • Example#2267 - TokyoTyrantTable::genUid example
  • Example#2268 - TokyoTyrantTable::get example
  • Example#2269 - TokyoTyrantTable::getIterator example
  • Example#2270 - TokyoTyrantTable::getQuery example
  • Example#2271 - TokyoTyrantTable::out example
  • Example#2272 - TokyoTyrantTable::put example
  • Example#2273 - TokyoTyrantTable::putCat example
  • Example#2274 - TokyoTyrantTable::putKeep example
  • Example#2275 - TokyoTyrantQuery::addCond example
  • Example#2276 - TokyoTyrantQuery::__construct example
  • Example#2277 - TokyoTyrantQuery::count example
  • Example#2278 - TokyoTyrantQuery iterator example
  • Example#2279 - TokyoTyrantQuery::hint example
  • Example#2280 - TokyoTyrantQuery iterator example
  • Example#2281 - TokyoTyrantQuery::metaSearch example
  • Example#2282 - TokyoTyrantQuery iterator example
  • Example#2283 - TokyoTyrantQuery::out example
  • Example#2284 - TokyoTyrantQuery iterator example
  • Example#2285 - TokyoTyrantQuery::search example
  • Example#2286 - TokyoTyrantQuery iterator example
  • Example#2287 - TokyoTyrantIterator::__construct example
  • Example#2288 - Ejemplo de cal_days_in_month
  • Example#2289 - Ejemplo de cal_from_jd
  • Example#2290 - Ejemplo de cal_info
  • Example#2291 - Ejemplo de easter_date
  • Example#2292 - Ejemplo de easter_days
  • Example#2293 - Funciones de calendario
  • Example#2294 - Ejemplo de jdtojewish
  • Example#2295 - DateTime::add/sub, añadir intervalos que cubren el tiempo transcurrido
  • Example#2296 - DateTime::modify y strtotime, aumentar o disminuir valores de componentes individuales
  • Example#2297 - Añadir o restar horas puede sobrepasar o subpasar fechas
  • Example#2298 - Ejemplo de DateTime::add
  • Example#2299 - Más ejemplos de DateTime::add
  • Example#2300 - Cuidado al añadir meses
  • Example#2301 - Ejemplo de DateTime::__construct
  • Example#2302 - Complejidades de DateTime::__construct
  • Example#2303 - Ejemplo de DateTime::createFromFormat
  • Example#2304 - Complejidades de DateTime::createFromFormat
  • Example#2305 - Cadena de formato con caracteres literales
  • Example#2306 - Creating a mutable date time object
  • Example#2307 - Creating a mutable date time object
  • Example#2308 - Ejemplo de DateTime::getLastErrors
  • Example#2309 - Ejemplo de DateTime::modify
  • Example#2310 - Cuidado al añadir o sustraer meses
  • Example#2311 - Ejemplo de DateTime::setDate
  • Example#2312 - Los valores que exceden rangos son añadidos a sus valores padre
  • Example#2313 - Ejemplo de DateTime::setISODate
  • Example#2314 - Los valores que execen rangos son añadidos a sus valores padre
  • Example#2315 - Buscar el mes en el que se encuentra una semana
  • Example#2316 - Ejemplo de DateTime::setTime
  • Example#2317 - Los valores que exceden rangos son añadidos a sus valores padre
  • Example#2318 - Ejemplo de DateTime::setTimestamp
  • Example#2319 - Alternativa de DateTime::setTimestamp en PHP 5.2
  • Example#2320 - Ejemplo de DateTime::setTimeZone
  • Example#2321 - Ejemplo de DateTime::sub
  • Example#2322 - Más ejemplos de DateTime::sub
  • Example#2323 - Cuidado al sustraer meses
  • Example#2324 - Creating an immutable date time object
  • Example#2325 - Crear un objeto de fecha y hora inmutable
  • Example#2326 - Ejemplo de DateTime::diff
  • Example#2327 - Comparación de objetos DateTime
  • Example#2328 - Ejemplo de DateTime::format
  • Example#2329 - Ejemplo de DateTime::getOffset
  • Example#2330 - Ejemplo de DateTime::getTimestamp
  • Example#2331 - Ejemplo de DateTime::getTimezone
  • Example#2332 - Atrapar errores cuando se instancia un DateTimeZone
  • Example#2333 - Ejemplo de DateTimeZone::getLocation
  • Example#2334 - Ejemplo de DateTimeZone::getOffset
  • Example#2335 - Un ejemplo de timezone_transitions_get
  • Example#2336 - Un ejemplo de timezone_abbreviations_list
  • Example#2337 - Un ejemplo de timezone_identifiers_list
  • Example#2338 - Ejemplo de DateInterval
  • Example#2339 - Analizar intervalos de fechas válidos
  • Example#2340 - Ejemplo de DateInterval
  • Example#2341 - DateInterval y excesos
  • Example#2342 - DateInterval y DateTime::diff con los modificadores %a y %d
  • Example#2343 - Ejemplo de DatePeriod
  • Example#2344 - Ejemplo de DatePeriod con DatePeriod::EXCLUDE_START_DATE
  • Example#2345 - Ejemplo de DatePeriod::getDateInterval
  • Example#2346 - Ejemplo de DatePeriod::getEndDate
  • Example#2347 - DatePeriod::getEndDate sin una fecha final
  • Example#2348 - Ejemplo de DatePeriod::getStartDate
  • Example#2349 - Ejemplo de checkdate
  • Example#2350 - Obtener la zona horaria por defecto
  • Example#2351 - Obtener la abreviatura de una zona horaria
  • Example#2352 - Obtener la zona horaria por defecto
  • Example#2353 - Ejemplo de date_parse_from_format
  • Example#2354 - Un ejemplo de date_parse
  • Example#2355 - date_parse con formatos relativos
  • Example#2356 - Un ejemplo de date_sun_info
  • Example#2357 - Ejemplo de date_sunrise
  • Example#2358 - Ejemplo de date_sunset
  • Example#2359 - Ejemplo de date
  • Example#2360 - Escapar caracteres en date
  • Example#2361 - Ejemplo de date y mktime
  • Example#2362 - date Formatting
  • Example#2363 - Ejemplo de getdate
  • Example#2364 - Ejemplo de gettimeofday
  • Example#2365 - Ejemplo de gmdate
  • Example#2366 - Ejemplo básico de gmmktime
  • Example#2367 - Ejemplo de gmstrftime
  • Example#2368 - Ejemplo de idate
  • Example#2369 - Ejemplo de localtime
  • Example#2370 - Ejecución de un script de cronometraje con microtime
  • Example#2371 - Ejecución de un script de cronometraje en PHP 5
  • Example#2372 - microtime y REQUEST_TIME_FLOAT (desde PHP 5.4.0)
  • Example#2373 - Ejemplo básico de mktime
  • Example#2374 - Ejemplo de mktime
  • Example#2375 - El último día del mes
  • Example#2376 - Ejemplos de localismos con strftime
  • Example#2377 - Ejemplo de número de semana del ISO 8601:1988
  • Example#2378 - Ejemplo multiplataforma compatible del modificador %e
  • Example#2379 - Mostrar todos los formatos conocidos y desconocidos.
  • Example#2380 - Ejemplo de strptime
  • Example#2381 - Un ejemplo de strtotime
  • Example#2382 - Comprobar si falla
  • Example#2383 - Ejemplo de time
  • Example#2384 - Un ejemplo de timezone_name_from_abbr
  • Example#2385 - Obtener la versión de timezonedb
  • Example#2386 - Medir la ejecución de varios bloques de código y obtener el total
  • Example#2387 - Cerrando un descriptor de fichero
  • Example#2388 - Bloqueando y desbloqueando
  • Example#2389 - Abrir un descriptor de fichero
  • Example#2390 - Posicionamiento de un fichero
  • Example#2391 - Asignando la tasa de baudios del puerto serie
  • Example#2392 - chdir ejemplo
  • Example#2393 - Ejemplo de chroot
  • Example#2394 - closedir ejemplo
  • Example#2395 - Ejemplo de dir
  • Example#2396 - getcwd ejemplo
  • Example#2397 - opendir ejemplo
  • Example#2398 - Listar todas las entradas de un directorio
  • Example#2399 - Listar todas las entradas del directorio actual y descartar . y ..
  • Example#2400 - Un simple ejemplo de scandir
  • Example#2401 - Ejemplo de finfo_buffer
  • Example#2402 - Un ejemplo de finfo_file
  • Example#2403 - Estilo orientado a objetos
  • Example#2404 - Estilo por procedimientos
  • Example#2405 - Ejemplo mime_content_type
  • Example#2406 - Ejemplo de basename
  • Example#2407 - Cambiar el grupo de un archivo
  • Example#2408 - Uso sencillo de chown
  • Example#2409 - Ejemplo de clearstatcache
  • Example#2410 - Ejemplo de copy
  • Example#2411 - Ejemplo de dirname
  • Example#2412 - Ejemplo de disk_free_space
  • Example#2413 - Ejemplo de disk_total_space
  • Example#2414 - Un ejemplo sencillo de fclose
  • Example#2415 - Manejar tiempos de espera con feof
  • Example#2416 - Ejemplo de feof con un puntero a un archivo no válido
  • Example#2417 - Ejemplo de escritura de un archivo usando fflush
  • Example#2418 - Un ejemplo de fgetc
  • Example#2419 - Leer e imprimir el contenido completo de un fichero CSV
  • Example#2420 - Leer un fichero línea a línea
  • Example#2421 - Leer un archivo PHP línea a línea
  • Example#2422 - Comprobar si existe un fichero
  • Example#2423 - Obtiene y muestra el código fuente de la página de inicio de un sitio web
  • Example#2424 - Buscar dentro de include_path
  • Example#2425 - Leer una sección de un fichero
  • Example#2426 - Usar contextos de flujo
  • Example#2427 - Ejemplo sencillo de uso
  • Example#2428 - Usar banderas
  • Example#2429 - Ejemplo de file
  • Example#2430 - Ejemplo de fileatime
  • Example#2431 - Un ejemplo de filectime
  • Example#2432 - Encontrar el grupo de un archivo
  • Example#2433 - Comparar el i-nodo de un archivo con el archivo actual
  • Example#2434 - Ejemplo de filemtime
  • Example#2435 - Encontrar el propietario de un archivo
  • Example#2436 - Muestra los permisos como un valor octal
  • Example#2437 - Muestra los permisos completos
  • Example#2438 - Ejemplo de filesize
  • Example#2439 - Ejemplo de filetype
  • Example#2440 - Ejemplo de flock
  • Example#2441 - flock usando la opción LOCK_NB
  • Example#2442 - Comprobar un adjetivo con un patrón comodín tipo shell
  • Example#2443 - Ejemplos de fopen
  • Example#2444 - Usar fpassthru con archivos binarios
  • Example#2445 - Ejemplo de fputcsv
  • Example#2446 - Un ejemplo sencillo de fread
  • Example#2447 - Ejemplo de lectura binaria de fread
  • Example#2448 - Ejemplos de lectura remota con fread
  • Example#2449 - Ejemplo de fscanf
  • Example#2450 - Contenido de usuarios.txt
  • Example#2451 - Ejemplo de fseek
  • Example#2452 - Ejemplo de fstat
  • Example#2453 - Ejemplo de ftell
  • Example#2454 - Ejemplo de truncar un archivo
  • Example#2455 - Un ejemplo sencillo de fwrite
  • Example#2456 - Manera conveniente de cómo glob puede remplazar a opendir y similares.
  • Example#2457 - Ejemplo de is_dir
  • Example#2458 - Ejemplo de is_executable
  • Example#2459 - Ejemplo de is_file
  • Example#2460 - Crear y confirmar si un archivo es un enlace simbólico
  • Example#2461 - Ejemplo de is_readable
  • Example#2462 - Ejemplo de is_uploaded_file
  • Example#2463 - Ejemplo de is_writable
  • Example#2464 - Cambiar el grupo de un enlace simbólico
  • Example#2465 - Cambiar el propietario de un enlace simbólico
  • Example#2466 - Crear un simple enlace duro
  • Example#2467 - Ejmeplo de linkinfo
  • Example#2468 - Comparación de stat y lstat
  • Example#2469 - Ejmplo de mkdir
  • Example#2470 - mkdir usando el parámetro recursive
  • Example#2471 - Subida de múltiples archivos
  • Example#2472 - Contenido de ejemplo.ini
  • Example#2473 - Ejemplo de parse_ini_file
  • Example#2474 - parse_ini_file analizando un fichero de php.ini
  • Example#2475 - Ejemplo de pathinfo
  • Example#2476 - Ejemplo de pathinfo mostrando las diferencias entre null y no utilizar extensión
  • Example#2477 - Ejemplo de pathinfo para un fichero que comienza con punto
  • Example#2478 - Ejemplo de pclose
  • Example#2479 - Ejemplo de popen
  • Example#2480 - Ejemplo de popen
  • Example#2481 - Forzar un descarga empleando readfile
  • Example#2482 - Ejemplo de readlink
  • Example#2483 - Ejemplo de realpath_cache_get
  • Example#2484 - Ejemplo de realpath_cache_size
  • Example#2485 - Ejemplo de realpath
  • Example#2486 - realpath en Windows
  • Example#2487 - Ejemplo con rename
  • Example#2488 - Ejemplo de sobrescritura con rewind
  • Example#2489 - Ejemplo de rmdir
  • Example#2490 - Ejemplo de stat
  • Example#2491 - Usar la información de stat junto con touch
  • Example#2492 - Crear un enlace simbólico
  • Example#2493 - Ejemplo de tempnam
  • Example#2494 - Ejemplo de tmpfile
  • Example#2495 - Ejemplo de touch
  • Example#2496 - touch usando el parámetro time
  • Example#2497 - Ejemplo de umask
  • Example#2498 - Uso básico de unlink
  • Example#2499 - Ejemplo de uso de inotify
  • Example#2500 - Ejemplo de setproctitle
  • Example#2501 - setthreadtitle ejemplo
  • Example#2502 - Comprueba si el administrador del sistema firmó el archivo
  • Example#2503 - Imprime los nombres de todos los atributos extendidos del archivo
  • Example#2504 - Elimina todos los atributos extendidos de un archivo
  • Example#2505 - Establece atributos extendidos en archivo .wav
  • Example#2506 - Ejemplo de xattr_supported
  • Example#2507 - Ejemplo de xdiff_file_bdiff_size
  • Example#2508 - Ejemplo de xdiff_file_bdiff
  • Example#2509 - xdiff_file_bpatch example
  • Example#2510 - Ejemplo de xdiff_file_diff_binary
  • Example#2511 - Ejemplo de xdiff_file_diff
  • Example#2512 - Ejemplo de xdiff_file_merge3
  • Example#2513 - Ejemplo de xdiff_file_patch_binary
  • Example#2514 - Ejemplo de xdiff_file_patch
  • Example#2515 - Ejemplo de parche invertido
  • Example#2516 - Ejemplo de xdiff_file_rabdiff
  • Example#2517 - Ejemplo de xdiff_string_bdiff_size
  • Example#2518 - Ejemplo de xdiff_string_diff
  • Example#2519 - Ejemplo de xdiff_string_patch
  • Example#2520 - Ejemplos de Uso de Enchant
  • Example#2521 - Listar los entornos proporcionados por el agente dado
  • Example#2522 - Un ejemplo de enchant_broker_dict_exists
  • Example#2523 - Listar todos los diccionarios disponibles para un agente
  • Example#2524 - Un ejemplo de enchant_broker_request_dict
  • Example#2525 - Añadir una palabra a un PWL
  • Example#2526 - Adding a word to a PWL
  • Example#2527 - Un ejemplo de enchant_dict_describe
  • Example#2528 - Un ejemplo de enchant_dict_quick_check
  • Example#2529 - Un ejemplo de enchant_dict_suggest
  • Example#2530 - Ejemplo de uso.
  • Example#2531 - Uso de Gender\Gender::country
  • Example#2532 - Ejemplo de bindtextdomain
  • Example#2533 - gettext-check
  • Example#2534 - Ejemplo de ngettext
  • Example#2535 - Ejemplo de iconv_get_encoding
  • Example#2536 - Ejemplo de iconv_mime_decode_headers
  • Example#2537 - Ejemplo de la función iconv_mime_decode
  • Example#2538 - Ejemplo de iconv_mime_encode
  • Example#2539 - Ejemplo de iconv_set_encoding
  • Example#2540 - Ejemplo de iconv
  • Example#2541 - Ejemplo de ob_iconv_handler
  • Example#2542 - Ejemplo usando la API procedimental
  • Example#2543 - Ejemplo usando la API orientada a objetos
  • Example#2544 - Reglas de FRENCH_COLLATION
  • Example#2545 - Reglas de ALTERNATE_HANDLING
  • Example#2546 - Reglas de CASE_FIRST
  • Example#2547 - Reglas de CASE_LEVEL
  • Example#2548 - Ejemplo de collator_asort
  • Example#2549 - Ejemplo de collator_compare
  • Example#2550 - Ejemplo de Collator::__construct
  • Example#2551 - Ejemplo de collator_create
  • Example#2552 - Ejemplo de collator_get_attribute
  • Example#2553 - Ejemplo collator_get_error_code
  • Example#2554 - Ejemplo de collator_get_error_message
  • Example#2555 - Ejemplo collator_get_locale
  • Example#2556 - Ejemplo de collator_get_sort_key
  • Example#2557 - Ejemplo de collator_get_strength
  • Example#2558 - Ejemplo de collator_set_attribute
  • Example#2559 - Ejemplo de collator_set_strength
  • Example#2560 - Ejemplo de collator_sort_with_sort_keys
  • Example#2561 - Ejemplo de collator_sort
  • Example#2562 - Ejemplo de numfmt_create
  • Example#2563 - Ejemplo de NumberFormatter::create
  • Example#2564 - Ejemplo de numfmt_format_currency
  • Example#2565 - Ejemplo orientado a objetos
  • Example#2566 - Ejemplo de numfmt_format
  • Example#2567 - Ejemplo orientado a objetos
  • Example#2568 - Ejemplo de numfmt_get_attribute
  • Example#2569 - Ejemplo orientado a objetos
  • Example#2570 - Ejemplo de numfmt_get_error_code
  • Example#2571 - Ejemplo orientado a objetos
  • Example#2572 - Ejemplo de numfmt_get_error_message
  • Example#2573 - Ejemplo orientado a objetos
  • Example#2574 - Ejemplo de numfmt_get_locale
  • Example#2575 - Ejemplo de numfmt_get_pattern
  • Example#2576 - OO example
  • Example#2577 - Ejemplo de numfmt_get_symbol
  • Example#2578 - OO example
  • Example#2579 - Ejemplo de numfmt_get_text_attribute
  • Example#2580 - OO example
  • Example#2581 - Ejemplo de numfmt_parse_currency
  • Example#2582 - OO example
  • Example#2583 - Ejemplo de numfmt_parse
  • Example#2584 - Ejemplo O.O.
  • Example#2585 - Ejemplo de numfmt_set_attribute
  • Example#2586 - OO example
  • Example#2587 - Ejemplo de numfmt_set_pattern
  • Example#2588 - OO example
  • Example#2589 - Ejemplo de numfmt_set_symbol
  • Example#2590 - OO example
  • Example#2591 - Ejemplo de numfmt_set_text_attribute
  • Example#2592 - OO example
  • Example#2593 - Ejemplo de locale_accept_from_http
  • Example#2594 - Ejemplo orientado a objetos
  • Example#2595 - Ejemplo de locale_compose
  • Example#2596 - Ejemplo orientado a objetos
  • Example#2597 - Ejemplo de locale_filter_matches
  • Example#2598 - Ejemplo orientado a objetos
  • Example#2599 - Ejepmplo de locale_get_all_variants
  • Example#2600 - Ejemplo orientado a objetos
  • Example#2601 - Ejemplo de locale_get_default
  • Example#2602 - Ejemplo orientado a objetos
  • Example#2603 - Ejemplo de locale_get_display_language
  • Example#2604 - Ejemplo orientado a objetos
  • Example#2605 - Ejemplo de locale_get_display_name
  • Example#2606 - Ejemplo orientado a objetos
  • Example#2607 - Ejemplo de locale_get_display_region
  • Example#2608 - Ejemplo orientado a objetos
  • Example#2609 - Ejemplo de locale_get_display_script
  • Example#2610 - Ejemplo orientado a objetos
  • Example#2611 - Ejemplo de locale_get_display_variant
  • Example#2612 - Ejemplo orientado a objetos
  • Example#2613 - Ejemplo de locale_get_keywords
  • Example#2614 - Ejemplo orientado a objetos
  • Example#2615 - Ejemplo de locale_get_primary_language
  • Example#2616 - Ejemplo orientado a objetos
  • Example#2617 - Ejemplo de locale_get_region
  • Example#2618 - Ejemplo orientado a objetos
  • Example#2619 - Ejemplo de locale_get_script
  • Example#2620 - Ejemplo orientado a objetos
  • Example#2621 - Ejemplo de locale_lookup
  • Example#2622 - Ejemplo orientado a objetos
  • Example#2623 - Ejemplo locale_parse
  • Example#2624 - Ejemplo orientado a objetos
  • Example#2625 - Ejemplo de locale_set_default
  • Example#2626 - Ejemplo orientado a objetos
  • Example#2627 - Normalizer::getRawDecomposition example
  • Example#2628 - Ejemplo de normalizer_is_normalized
  • Example#2629 - Ejemplo orientado a objetos
  • Example#2630 - Ejemplo de normalizer_normalize
  • Example#2631 - Ejemplo Orientado a Objetos
  • Example#2632 - Ejemplo de msgfmt_create
  • Example#2633 - Ejemplo orientado a objetos
  • Example#2634 - Ejemplo de msgfmt_format_message
  • Example#2635 - Ejemplo orientado a objetos
  • Example#2636 - Ejemplo de msgfmt_format
  • Example#2637 - Ejemplo orientado a objetos
  • Example#2638 - Ejemplo de msgfmt_get_error_code
  • Example#2639 - Ejemplo orientado a objetos
  • Example#2640 - Ejemplo de msgfmt_get_error_message
  • Example#2641 - Ejemplo orientado a objetos
  • Example#2642 - Ejemplo de msgfmt_get_locale
  • Example#2643 - Ejemplo orientado a objetos
  • Example#2644 - Ejemplo de msgfmt_get_pattern
  • Example#2645 - Ejemplo orientado a objetos
  • Example#2646 - Ejemplo de msgfmt_parse_message
  • Example#2647 - Ejemplo orientado a objetos
  • Example#2648 - Ejemplo de msgfmt_parse
  • Example#2649 - Ejemplo orientado a objetos
  • Example#2650 - Ejemplo de msgfmt_set_pattern
  • Example#2651 - Ejemplo orientado a objetos
  • Example#2652 - IntlCalendar::add
  • Example#2653 - IntlCalendar::after
  • Example#2654 - Ejemplod de IntlCalendar::clear
  • Example#2655 - IntlCalendar::createInstance
  • Example#2656 - IntlCalendar::equals
  • Example#2657 - IntlCalendar::fieldDifference
  • Example#2658 - IntlCalendar::fromDateTime
  • Example#2659 - IntlCalendar::get
  • Example#2660 - IntlCalendar::getActualMaximum
  • Example#2661 - IntlCalendar::getAvailableLocales()
  • Example#2662 - IntlCalendar::getDayOfWeekType
  • Example#2663 - IntlCalendar::getErrorCode y IntlCalendar::getErrorMessage
  • Example#2664 - IntlCalendar::getErrorMessage
  • Example#2665 - IntlCalendar::getFirstDayOfWeek
  • Example#2666 - IntlCalendar::getKeyworkValuesForLocale
  • Example#2667 - Ejemplos de máximos
  • Example#2668 - IntlCalendar::getLocale
  • Example#2669 - IntlCalendar::getMinimalDaysInFirstWeek
  • Example#2670 - IntlCalendar::getNow
  • Example#2671 - IntlCalendar::getRepeatedWallTimeOption
  • Example#2672 - IntlCalendar::getSkippedWallTimeOption
  • Example#2673 - IntlCalendar::getTime
  • Example#2674 - IntlCalendar::getTimeZone
  • Example#2675 - IntlCalendar::getType
  • Example#2676 - IntlCalendar::inDaylightTime
  • Example#2677 - IntlCalendar::isEquivalentTo
  • Example#2678 - IntlCalendar::isLenient
  • Example#2679 - IntlCalendar::isWeekend
  • Example#2680 - IntlCalendar::roll
  • Example#2681 - IntlCalendar::set
  • Example#2682 - IntlCalendar::setFirstDayOfWeek
  • Example#2683 - IntlCalendar::setTime
  • Example#2684 - IntlCalendar::setTimeZone
  • Example#2685 - IntlCalendar::toDateTime
  • Example#2686 - Ejemplo de datefmt_create
  • Example#2687 - Ejemplo orientado a objetos
  • Example#2688 - Ejemplo de datefmt_format
  • Example#2689 - Ejemplo orientado a objetos
  • Example#2690 - Con un objeto IntlCalendar
  • Example#2691 - Ejemplos de IntlDateFormatter::formatObject
  • Example#2692 - Ejemlo de datefmt_get_calendar
  • Example#2693 - Ejemplo orientado a objetos
  • Example#2694 - Ejemlo de datefmt_get_datetype
  • Example#2695 - Ejemplo orientado a objetos
  • Example#2696 - Ejemplo de datefmt_get_error_code
  • Example#2697 - Ejemplo orientado a objetos
  • Example#2698 - Ejemplo de datefmt_get_error_message
  • Example#2699 - Ejemplo orientado a objetos
  • Example#2700 - Ejemplo de datefmt_get_locale
  • Example#2701 - Ejemplo orientado a objetos
  • Example#2702 - Ejemplo de datefmt_get_pattern
  • Example#2703 - Ejemplo orientado a objetos
  • Example#2704 - Ejemplo de datefmt_get_timetype
  • Example#2705 - Ejemplo orientado a objetos
  • Example#2706 - Ejemplo de datefmt_get_timezone_id
  • Example#2707 - Ejemplo orientado a objetos
  • Example#2708 - Ejemplo IntlDateFormatter::getCalendarObject
  • Example#2709 - Ejemplos de IntlDateFormatter::getTimeZone
  • Example#2710 - Ejmplo de datefmt_is_lenient
  • Example#2711 - Ejemplo orientado a objetos
  • Example#2712 - Ejemplo de datefmt_localtime
  • Example#2713 - Ejemplo orientado a objetos
  • Example#2714 - Ejemplo orientado a objetos
  • Example#2715 - Ejemplo de datefmt_parse
  • Example#2716 - Ejemplo de datefmt_set_calendar
  • Example#2717 - Ejemplo orientado a objetos
  • Example#2718 - Ejemplo con el argumento IntlCalendar
  • Example#2719 - Ejemplo de datefmt_set_lenient
  • Example#2720 - Ejemplo orientado a objetos
  • Example#2721 - Ejemplo de datefmt_set_pattern
  • Example#2722 - Ejemplo orientado a objetos
  • Example#2723 - Ejemplos de IntlDateFormatter::setTimeZone
  • Example#2724 - Ejemplo de resourcebundle_count
  • Example#2725 - Ejemplo orientado a objetos
  • Example#2726 - Ejemplo de resourcebundle_create
  • Example#2727 - Ejemplo de ResourceBundle::create
  • Example#2728 - Ejemplo de resourcebundle_get_error_code
  • Example#2729 - Ejemplo orientado a objetos
  • Example#2730 - Ejemplo de resourcebundle_get_error_message
  • Example#2731 - Ejemplo orientado a objetos
  • Example#2732 - Ejemplo de resourcebundle_get
  • Example#2733 - Ejemplo orientado a objetos
  • Example#2734 - Ejemplo de resourcebundle_locales
  • Example#2735 - Ejemplo orientado a objetos
  • Example#2736 - Converting escaped UTF-16 code units
  • Example#2737 - Ejemplo de grapheme_extract
  • Example#2738 - Ejemplo de grapheme_stripos
  • Example#2739 - Ejemplo de grapheme_stristr
  • Example#2740 - Ejemplo de grapheme_strlen
  • Example#2741 - Ejemplo de grapheme_strpos
  • Example#2742 - Ejemplo de grapheme_strripos
  • Example#2743 - Ejemplo de grapheme_strrpos
  • Example#2744 - Ejemplo de grapheme_strstr
  • Example#2745 - Ejemplo de grapheme_substr
  • Example#2746 - Ejemplo de idn_to_ascii
  • Example#2747 - Ejemplo de idn_to_utf8
  • Example#2748 - Probar diferentes puntos de código
  • Example#2749 - Probar diferentes puntos de código
  • Example#2750 - Probar diferentes puntos de código
  • Example#2751 - Probar diferentes puntos de código
  • Example#2752 - Probar diferentes puntos de código
  • Example#2753 - Probar diferentes puntos de código
  • Example#2754 - Probar diferentes puntos de código
  • Example#2755 - Probar diferentes puntos de código
  • Example#2756 - Probar diferentes puntos de código
  • Example#2757 - Enumeración de un rango de muestra de puntos de código
  • Example#2758 - Enumeración de un rango de muestra de puntos de código
  • Example#2759 - Probar diferentes puntos de código
  • Example#2760 - Probar diferentes puntos de código
  • Example#2761 - Probar diferentes puntos de código
  • Example#2762 - Probar diferentes puntos de código
  • Example#2763 - Probar diferentes puntos de código
  • Example#2764 - Probar diferentes propiedades
  • Example#2765 - Probar diferentes propiedades
  • Example#2766 - Probar diferentes propiedades
  • Example#2767 - Probar diferentes puntos de código
  • Example#2768 - Probar diferentes propiedades
  • Example#2769 - Probar diferentes propiedades
  • Example#2770 - Probar diferentes propiedades
  • Example#2771 - Probar diferentes propiedades
  • Example#2772 - Probar diferentes propiedades
  • Example#2773 - Probar diferentes propiedades
  • Example#2774 - Probar diferentes puntos de código
  • Example#2775 - Probar diferentes puntos de código
  • Example#2776 - Probar diferentes puntos de código
  • Example#2777 - Probar diferentes puntos de código
  • Example#2778 - Probar diferentes puntos de código
  • Example#2779 - Probar diferentes puntos de código
  • Example#2780 - Probar diferentes puntos de código
  • Example#2781 - Probar diferentes puntos de código
  • Example#2782 - Probar diferentes puntos de código
  • Example#2783 - Probar diferentes puntos de código
  • Example#2784 - Probar diferentes puntos de código
  • Example#2785 - Probar diferentes puntos de código
  • Example#2786 - Probar diferentes puntos de código
  • Example#2787 - Probar diferentes puntos de código
  • Example#2788 - Probar diferentes puntos de código
  • Example#2789 - Probar diferentes puntos de código
  • Example#2790 - Probar diferentes puntos de código
  • Example#2791 - Probar diferentes puntos de código
  • Example#2792 - Probar diferentes puntos de código
  • Example#2793 - Probar diferentes puntos de código
  • Example#2794 - Probar diferentes puntos de código
  • Example#2795 - Probar diferentes puntos de código
  • Example#2796 - Probar diferentes puntos de código
  • Example#2797 - Probar diferentes puntos de código
  • Example#2798 - Probar diferentes puntos de código
  • Example#2799 - Probar diferentes puntos de código
  • Example#2800 - Probar diferentes puntos de código
  • Example#2801 - Probar diferentes puntos de código
  • Example#2802 - Probar diferentes puntos de código
  • Example#2803 - Probar diferentes puntos de código
  • Example#2804 - Probar diferentes puntos de código
  • Example#2805 - Probar diferentes puntos de código
  • Example#2806 - intl_error_name ejemplo
  • Example#2807 - intl_get_error_code ejemplo
  • Example#2808 - intl_get_error_message ejemplo
  • Example#2809 - intl_is_failure ejemplo
  • Example#2810 - Ejemplos de ajustes de php.ini
  • Example#2811 - Ajustes de php.ini para usuarios de EUC-JP
  • Example#2812 - Ajustes de php.ini para usuarios de SJIS
  • Example#2813 - Desactivar la conversión de caracteres de la entrada HTTP en php.ini
  • Example#2814 - Ejemplo de configuración de php.ini
  • Example#2815 - Ejemplo de script
  • Example#2816 - Ejemplo de mb_convert_case
  • Example#2817 - Ejemplo de mb_convert_case con texto no latino en UTF-8
  • Example#2818 - Ejemplo de mb_convert_encoding
  • Example#2819 - Ejemplo de mb_convert_kana
  • Example#2820 - Ejemplo de mb_convert_variables
  • Example#2821 - Ejemplo de convmap
  • Example#2822 - Ejemplo de convmap escapando cadenas de JavaScript
  • Example#2823 - Ejemplo de mb_detect_encoding
  • Example#2824 - Ejemplo de mb_detect_order
  • Example#2825 - Ejemplo mostrando un orden de detección inútil
  • Example#2826 - Ejemplo de mb_encode_mimeheader
  • Example#2827 - Ejemplo de convmap
  • Example#2828 - Ejemplo de mb_encode_numericentity
  • Example#2829 - Ejemplo de mb_encoding_aliases
  • Example#2830 - Ejemplo de mb_ereg_replace_callback
  • Example#2831 - mb_ereg_replace_callback usando una función anónima admitida en PHP 5.3.0 o posterior
  • Example#2832 - Ejemplo de mb_internal_encoding
  • Example#2833 - Ejemplo de mb_list_encodings
  • Example#2834 - Ejemplo de mb_output_handler
  • Example#2835 - Ejemplo de mb_preferred_mime_name
  • Example#2836 - Ejemplo de mb_strimwidth
  • Example#2837 - Ejemplo de mb_strtolower
  • Example#2838 - Ejemplo de mb_strtolower con texto no latino
  • Example#2839 - Ejemplo de mb_strtoupper
  • Example#2840 - Ejemplo de mb_strtoupper con texto UTF-8 no latino
  • Example#2841 - Ejemplo de mb_substitute_character
  • Example#2842 - Ejemplo de mb_substr_count
  • Example#2843 - pspell_add_to_personal
  • Example#2844 - Ejemplo de pspell_check
  • Example#2845 - Ejemplo de pspell_add_to_personal
  • Example#2846 - pspell_config_create
  • Example#2847 - pspell_config_ignore
  • Example#2848 - Ejemplo de pspell_config_mode
  • Example#2849 - pspell_config_personal
  • Example#2850 - pspell_config_repl
  • Example#2851 - pspell_config_runtogether
  • Example#2852 - pspell_new_config
  • Example#2853 - pspell_new_personal
  • Example#2854 - pspell_new
  • Example#2855 - pspell_add_to_personal
  • Example#2856 - pspell_store_replacement
  • Example#2857 - Ejemplo de pspell_suggest
  • Example#2858 - Ejemplo básico de recode_file
  • Example#2859 - Ejemplo básico de recode_string
  • Example#2860 - Ejemplo de exif_imagetype
  • Example#2861 - Ejemplo de exif_read_data
  • Example#2862 - Ejemplo exif_tagname
  • Example#2863 - Ejemplo de exif_thumbnail
  • Example#2864 - Creación de un PNG con PHP
  • Example#2865 - Añadir marcas de agua a imágenes usando canales alfa
  • Example#2866 - Usar imagecopymerge para crear una marca de agua translúcida
  • Example#2867 - Empleo de gd_info
  • Example#2868 - getimagesize y tipos MIME
  • Example#2869 - Ejemplo degetimagesize
  • Example#2870 - getimagesize (URL)
  • Example#2871 - getimagesize() devolviendo IPTC
  • Example#2872 - Ejemplo de getimagesizefromstring
  • Example#2873 - Ejemplo de image_type_to_extension
  • Example#2874 - Ejemplo de image_type_to_mime_type
  • Example#2875 - Ejemplo de image2wbmp
  • Example#2876 - Ejemplo de uso de imagealphablending
  • Example#2877 - Una comparación de dos líneas, una con antialias activado
  • Example#2878 - Dibujar un círculo con imagearc
  • Example#2879 - Saving a BMP file
  • Example#2880 - Ejemplo de imagechar
  • Example#2881 - Ejemplo de imagecharup
  • Example#2882 - Ejemplo de imagecolorallocate
  • Example#2883 - Ejemplo usando imagecolorallocatealpha
  • Example#2884 - Acceder a los distintos valores RGB
  • Example#2885 - Valores RGB legibles para humanos usando imagecolorsforindex
  • Example#2886 - Buscar un conjunto de colores en una imagen
  • Example#2887 - Buscar un conjunto de colores en una imagen
  • Example#2888 - Ejemplo usando imagecolorclosesthwb
  • Example#2889 - Usar imagecolordeallocate
  • Example#2890 - Obtener colores del logotipo de GD
  • Example#2891 - Obtener colores del logotipo de GD
  • Example#2892 - Ejemplo de imagecolormatch
  • Example#2893 - Usar imagecoloresolve para obtener colores de una imagen
  • Example#2894 - Usar imagecoloresolvealpha para obtener colores de una imagen
  • Example#2895 - Ejemplo de imagecolorset
  • Example#2896 - Ejemplo de imagecolorsforindex
  • Example#2897 - Obtener el número total de colores de una imagen usando imagecolorstotal
  • Example#2898 - Ejemplo de imagecolortransparent
  • Example#2899 - Poner en relieve el logotipo de PHP.net
  • Example#2900 - Borrosidad gaussiana
  • Example#2901 - Recortar el logotipo de PHP.net
  • Example#2902 - Fusionar dos copias del logotipo de PHP.net con 75% de transparencia
  • Example#2903 - Uso de imagecopymergegray
  • Example#2904 - Ejemplo sencillo
  • Example#2905 - Redimensionar una imagen proporcionalmente
  • Example#2906 - Cambiar el tamaño de una imagen
  • Example#2907 - Crear un nuevo flujo de imagen GD e imprimir una imagen.
  • Example#2908 - Convert an BMP image to a PNG image using imagecreatefrombmp
  • Example#2909 - Ejemplo de imagecreatefromgd2
  • Example#2910 - Ejemplo de imagecreatefromgd2part
  • Example#2911 - Ejemplo de imagecreatefromgd
  • Example#2912 - Ejemplo de manejar un error durante la carga de un GIF
  • Example#2913 - Ejemplo de manejar un error durante la carga de un JPEG
  • Example#2914 - Ejemplo de manejar un error durante la carga de un PNG
  • Example#2915 - Ejemplo de imagecreatefromstring
  • Example#2916 - Ejemplo de manejar un error durante la carga de un WBMP
  • Example#2917 - Convertir una image WebP a una imagen jpeg usando imagecreatefromwebp
  • Example#2918 - Convertir una imagen XBM en una imagen png usando imagecreatefromxbm
  • Example#2919 - Crear una instancia de imagen usando imagecreatefromxpm
  • Example#2920 - Crear un nuevo flujo a una imagen GD e imprimir una imagen.
  • Example#2921 - Ejemplo de imagedashedline
  • Example#2922 - Alternativa a imagedashedline
  • Example#2923 - Ejemplo de uso de imagedestroy
  • Example#2924 - Ejemplo de imageellipse
  • Example#2925 - Ejemplo de imagefill
  • Example#2926 - Crear una gráfico de tarta en 3D
  • Example#2927 - Ejemplo de imagefilledellipse
  • Example#2928 - Ejemplo de imagefilledpolygon
  • Example#2929 - Uso de imagefilledrectangle
  • Example#2930 - Rellenar una elipse con un color
  • Example#2931 - Ejemplo de escala de grises con imagefilter
  • Example#2932 - Ejemplo de brillo con imagefilter
  • Example#2933 - Ejemplo de coloración con imagefilter
  • Example#2934 - Ejemplo de inversión de color con imagefilter
  • Example#2935 - Ejemplo de pixelación con imagefilter
  • Example#2936 - Voltea una imagen verticalmente
  • Example#2937 - Voltea la imagen horizontalmente
  • Example#2938 - Usar imagefontheight con fuentes incorporadas
  • Example#2939 - Usar imagefontheight junto con imageloadfont
  • Example#2940 - Usar imagefontwidth con fuentes incorporadas
  • Example#2941 - Usar imagefontwidth junto con imageloadfont
  • Example#2942 - Ejemplo de imageftbbox
  • Example#2943 - Ejemplo de imagefttext
  • Example#2944 - Uso de imagegammacorrect
  • Example#2945 - Imprimir una imagen GD2
  • Example#2946 - Guardar una imagen GD2
  • Example#2947 - Imprimir una imagen GD
  • Example#2948 - Saving a GD image
  • Example#2949 - imagegetclip example
  • Example#2950 - Imprimir una imagen usando imagegif
  • Example#2951 - Convertir una imagen PNG en GIF usando imagegif
  • Example#2952 - Ejemplo de imagegrabscreen
  • Example#2953 - Ejemplo de imagegrabwindow
  • Example#2954 - Activar el entrelazamiento usando imageinterlace
  • Example#2955 - Simple detección de instancias de imagen de color verdadero usando imageistruecolor
  • Example#2956 - Imprimir una imagen JPEG
  • Example#2957 - Guardar una imagen JPEG
  • Example#2958 - Imprimir la imagen al 75% de calidad
  • Example#2959 - Ejemplo de imagelayereffect
  • Example#2960 - Dibujar una línea gruesa
  • Example#2961 - Ejemplo de uso de imageloadfont
  • Example#2962 - imageopenpolygon example
  • Example#2963 - Ejemplo de imagepalettecopy
  • Example#2964 - Convertir cualquier recurso de imagaen a color verdadero
  • Example#2965 - Ejemplo de imagepolygon
  • Example#2966 - Ejemplo sencillo de imagerectangle
  • Example#2967 - Setting and getting the resolution of an image
  • Example#2968 - Rotar una imagen 180 grados
  • Example#2969 - Ejemplo de imagesavealpha
  • Example#2970 - Ejemplo de imagesetbrush
  • Example#2971 - Ejemplo de imagesetinterpolation
  • Example#2972 - Ejemplo de imagesetpixel
  • Example#2973 - Ejemplo de imagesetstyle
  • Example#2974 - Ejemplo de imagesetthickness
  • Example#2975 - Ejemplo de imagesettile
  • Example#2976 - Ejemplo de imagestring
  • Example#2977 - Ejemplo de imagestringup
  • Example#2978 - Usar imagesx
  • Example#2979 - Usar imagesy
  • Example#2980 - Convertir una imagen de color verdadero en una imagen de paleta
  • Example#2981 - Ejemplo de imagettfbbox
  • Example#2982 - Ejemplo de imagettftext
  • Example#2983 - Comprobar el soporte para PNG
  • Example#2984 - Imprimir una imagen WBMP
  • Example#2985 - Guardar una imagen WBMP
  • Example#2986 - Imprimir la imagen con un primer plano diferente
  • Example#2987 - Guardar un fichero WebP
  • Example#2988 - Guardar un fichero XBM
  • Example#2989 - Guardar un fichero XBM con un color de primer plano diferente
  • Example#2990 - Incluir información IPTC a un JPEG
  • Example#2991 - iptcparse() usado junto con getimagesize
  • Example#2992 - Ejemplo de jpeg2wbmp
  • Example#2993 - Ejmplo de png2wbmp
  • Example#2994 - Ejemplo de Gmagick
  • Example#2995 - Ejemplo de Gmagick::despeckleimage
  • Example#2996 - Gmagick::setCompressionQuality
  • Example#2997 - Crear una miniatura con Imagick
  • Example#2998 - Hacer una miniatura de todos los archivos JPG de un directorio
  • Example#2999 - Crear un reflejo de una imagen
  • Example#3000 - Rellenar un texto con un gradiente
  • Example#3001 - Leer una imágen GIF y redimensionar todos los fotogramas
  • Example#3002 - Crear un logo de PHP
  • Example#3003 - Usar Imagick::adaptiveBlurImage:
  • Example#3004 - Usar Imagick::adaptiveResizeImage
  • Example#3005 - Un ejemplo de Imagick::adaptiveSharpenImage
  • Example#3006 - Imagick::adaptiveThresholdImage
  • Example#3007 - Imagick::addNoiseImage
  • Example#3008 - Imagick::affineTransformImage
  • Example#3009 - Usar Imagick::annotateImage:
  • Example#3010 - Ejemplo de Imagick::appendImages
  • Example#3011 - Imagick::autoLevelImage
  • Example#3012 - Imagick::blackThresholdImage
  • Example#3013 - Imagick::blueShiftImage
  • Example#3014 - Usar Imagick::blurImage:
  • Example#3015 - Imagick::borderImage
  • Example#3016 - Imagick::brightnessContrastImage
  • Example#3017 - Imagick::charcoalImage
  • Example#3018 - Usar Imagick::chopImage:
  • Example#3019 - Clonación de un objeto Imagick en diferentes versiones de imagick
  • Example#3020 - Usar Imagick::clutImage:
  • Example#3021 - Imagick::colorizeImage
  • Example#3022 - Imagick::colorMatrixImage
  • Example#3023 - Usar Imagick::commentImage:
  • Example#3024 - Usar Imagick::compareImageLayers
  • Example#3025 - Uso de Imagick::compareImages:
  • Example#3026 - Empleo de Imagick::compositeImage:
  • Example#3027 - Imagick::contrastImage
  • Example#3028 - Imagick::convolveImage
  • Example#3029 - Imagick::cropImage
  • Example#3030 - Imagick::deskewImage
  • Example#3031 - Imagick::despeckleImage
  • Example#3032 - Usar Imagick::distortImage:
  • Example#3033 - Imagick::edgeImage
  • Example#3034 - Imagick::embossImage
  • Example#3035 - Imagick::enhanceImage
  • Example#3036 - Imagick::equalizeImage
  • Example#3037 - Usando Imagick::evaluateImage
  • Example#3038 - Usar Imagick::exportImagePixels
  • Example#3039 - Imagick::filter
  • Example#3040 - Imagick::flipImage
  • Example#3041 - Ejemplo de Imagick::floodfillPaintImage
  • Example#3042 - Imagick::flopImage
  • Example#3043 - Imagick::forwardFourierTransformImage
  • Example#3044 - Imagick::frameImage
  • Example#3045 - Crear un degradado sinusoide
  • Example#3046 - Crear un degradado desde el polinomio (4x^2 - 4x + 1)
  • Example#3047 - Crear un degradao complejo a partir del polinomio (4x^2 - 4x^2 + 1) modulado por un degradao sinusoide
  • Example#3048 - Imagick::fxImage
  • Example#3049 - Imagick::gammaImage
  • Example#3050 - Imagick::gaussianBlurImage
  • Example#3051 - Imagick::getImageGeometry
  • Example#3052 - Generates Imagick::getImageHistogram
  • Example#3053 - Usar Imagick::getImageLength:
  • Example#3054 - Usar Imagick::getImageProperties:
  • Example#3055 - Usando Imagick::getImageProperty:
  • Example#3056 - Usar Imagick::getIteratorIndex:
  • Example#3057 - Imagick::getPixelIterator
  • Example#3058 - Ejemplo de Imagick::getPixelRegionIterator
  • Example#3059 - Imagick::haldClutImage
  • Example#3060 - Imagick::identifyFormat
  • Example#3061 - Ejemplo de formato resultante
  • Example#3062 - Imagick::implodeImage
  • Example#3063 - Ejemplo deImagick::importImagePixels
  • Example#3064 - Imagick::levelImage
  • Example#3065 - Imagick::linearStretchImage
  • Example#3066 - Imagick::magnifyImage
  • Example#3067 - Imagick::medianFilterImage
  • Example#3068 - Imagick::mergeImageLayers
  • Example#3069 - Imagick::modulateImage
  • Example#3070 - Convolve Imagick::morphology
  • Example#3071 - Correlate Imagick::morphology
  • Example#3072 - Erode Imagick::morphology
  • Example#3073 - Erode Intensity Imagick::morphology
  • Example#3074 - Dilate Imagick::morphology
  • Example#3075 - Dilate intensity Imagick::morphology
  • Example#3076 - Distance with Chebyshev kernel Imagick::morphology
  • Example#3077 - Distance with Manhattan kernel Imagick::morphology
  • Example#3078 - Distance with ocatagonal kernel Imagick::morphology
  • Example#3079 - Distance with Euclidean kernel Imagick::morphology
  • Example#3080 - Edge Imagick::morphology
  • Example#3081 - Open Imagick::morphology
  • Example#3082 - Open intensity Imagick::morphology
  • Example#3083 - Close Imagick::morphology
  • Example#3084 - Close Intensity Imagick::morphology
  • Example#3085 - Smooth Imagick::morphology
  • Example#3086 - Edge in Imagick::morphology
  • Example#3087 - Edge out Imagick::morphology
  • Example#3088 - The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology
  • Example#3089 - The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology
  • Example#3090 - Hit and Miss Imagick::morphology
  • Example#3091 - Thinning Imagick::morphology
  • Example#3092 - Thicken Imagick::morphology
  • Example#3093 - Thick to generate a convex hull Imagick::morphology
  • Example#3094 - Iterative morphology Imagick::morphology
  • Example#3095 - Helper functon to get an image silhouette Imagick::morphology
  • Example#3096 - Imagick::motionBlurImage
  • Example#3097 - Imagick::negateImage
  • Example#3098 - Usar Imagick::newImage:
  • Example#3099 - Imagick::newPseudoImage
  • Example#3100 - Imagick::normalizeImage
  • Example#3101 - Imagick::oilPaintImage
  • Example#3102 - Usar Imagick::optimizeImageLayers
  • Example#3103 - Imagick::orderedPosterizeImage
  • Example#3104 - Usar Imagick::pingImageBlob
  • Example#3105 - Usar Imagick::pingImageFile
  • Example#3106 - Un ejemplo de Imagick::polaroidImage
  • Example#3107 - Imagick::posterizeImage
  • Example#3108 - Imagick::quantizeImage
  • Example#3109 - Usar Imagick::queryFontMetrics:
  • Example#3110 - Imagick::queryFonts
  • Example#3111 - Imagick::queryFormats
  • Example#3112 - Imagick::radialBlurImage
  • Example#3113 - Imagick::raiseImage
  • Example#3114 - Imagick::randomThresholdImage
  • Example#3115 - Imagick::readImageBlob
  • Example#3116 - Imagick::recolorImage
  • Example#3117 - Imagick::reduceNoiseImage
  • Example#3118 - Imagick::resampleImage
  • Example#3119 - Imagick::resizeImage
  • Example#3120 - Imagick::rollImage
  • Example#3121 - Imagick::rotateImage
  • Example#3122 - Imagick::rotationalBlurImage
  • Example#3123 - Usar Imagick::roundCorners:
  • Example#3124 - Imagick::scaleImage
  • Example#3125 - Imagick::segmentImage
  • Example#3126 - Imagick::selectiveBlurImage
  • Example#3127 - Imagick::separateImageChannel
  • Example#3128 - Imagick::sepiaToneImage
  • Example#3129 - Imagick::setCompressionQuality
  • Example#3130 - Un ejemplo de Imagick::setFont
  • Example#3131 - Un ejemplo de Imagick::setImage
  • Example#3132 - Imagick::setImageArtifact
  • Example#3133 - Imagick::setImageBias
  • Example#3134 - Imagick::setImageClipMask
  • Example#3135 - Imagick::setImageCompressionQuality
  • Example#3136 - Modificar un GIF animado con Imagick::setImageDelay
  • Example#3137 - Uso básido ce Imagick::setImageIterations
  • Example#3138 - Un ejemplo de Imagick::setImageOpacity
  • Example#3139 - Imagick::setImageOrientation
  • Example#3140 - Usar Imagick::setImageProperty:
  • Example#3141 - Imagick::setImageResolution
  • Example#3142 - Modificar un GIF animado con Imagick::setImageTicksPerSecond
  • Example#3143 - Usar Imagick::setIteratorIndex:
  • Example#3144 - Attempt to reach '$extent' sizeImagick::setOption
  • Example#3145 - Imagick::setOption
  • Example#3146 - Imagick::setOption
  • Example#3147 - Un ejemplo de Imagick::setPointSize
  • Example#3148 - Imagick::setProgressMonitor
  • Example#3149 - Imagick::setSamplingFactors
  • Example#3150 - Imagick::shadeImage
  • Example#3151 - Imagick::shadowImage
  • Example#3152 - Imagick::sharpenImage
  • Example#3153 - Imagick::shaveImage
  • Example#3154 - Imagick::shearImage
  • Example#3155 - Crear una imagen degradada usando Imagick::sigmoidalContrastImage apta para mezclar dos imágenes suavemente, con la mezcla definida por $contraste y el $punto_medio
  • Example#3156 - Imagick::sketchImage
  • Example#3157 - Imagick::smushImages
  • Example#3158 - Imagick::solarizeImage
  • Example#3159 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3160 - SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage
  • Example#3161 - SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage
  • Example#3162 - SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage
  • Example#3163 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3164 - createGradientImage is used by other examples. Imagick::sparseColorImage
  • Example#3165 - Imagick::spliceImage
  • Example#3166 - Imagick::spreadImage
  • Example#3167 - Imagick::statisticImage
  • Example#3168 - Imagick::subImageMatch
  • Example#3169 - Imagick::swirlImage
  • Example#3170 - Imagick::textureImage
  • Example#3171 - Imagick::thresholdImage
  • Example#3172 - Imagick::thumbnailImage
  • Example#3173 - Imagick::tintImage
  • Example#3174 - Usar Imagick::transformImage:
  • Example#3175 - Ejemplo de Imagick::transformImageColorspace
  • Example#3176 - Imagick::transformImageColorspace
  • Example#3177 - Imagick::transparentPaintImage
  • Example#3178 - Imagick::transposeImage
  • Example#3179 - Imagick::transverseImage
  • Example#3180 - Usar Imagick::trimImage:
  • Example#3181 - Imagick::uniqueImageColors
  • Example#3182 - Imagick::unsharpMaskImage
  • Example#3183 - Imagick::vignetteImage
  • Example#3184 - WaveImage can be quite slow Imagick::waveImage
  • Example#3185 - Imagick::whiteThresholdImage
  • Example#3186 - ImagickDraw::affine
  • Example#3187 - ImagickDraw::arc
  • Example#3188 - ImagickDraw::bezier
  • Example#3189 - ImagickDraw::circle
  • Example#3190 - ImagickDraw::composite
  • Example#3191 - ImagickDraw::ellipse
  • Example#3192 - ImagickDraw::line
  • Example#3193 - ImagickDraw::matte
  • Example#3194 - ImagickDraw::pathCurveToQuadraticBezierAbsolute
  • Example#3195 - ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
  • Example#3196 - ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
  • Example#3197 - ImagickDraw::pathStart
  • Example#3198 - ImagickDraw::point
  • Example#3199 - ImagickDraw::polygon
  • Example#3200 - ImagickDraw::polyline
  • Example#3201 - ImagickDraw::popDefs
  • Example#3202 - ImagickDraw::push
  • Example#3203 - ImagickDraw::pushPattern
  • Example#3204 - ImagickDraw::rectangle
  • Example#3205 - ImagickDraw::rotate
  • Example#3206 - ImagickDraw::roundRectangle
  • Example#3207 - ImagickDraw::scale
  • Example#3208 - ImagickDraw::setClipPath
  • Example#3209 - ImagickDraw::setClipRule
  • Example#3210 - ImagickDraw::setClipUnits
  • Example#3211 - ImagickDraw::setFillAlpha
  • Example#3212 - ImagickDraw::setFillColor
  • Example#3213 - ImagickDraw::setFillOpacity
  • Example#3214 - ImagickDraw::setFillRule
  • Example#3215 - ImagickDraw::setFont
  • Example#3216 - ImagickDraw::setFontFamily
  • Example#3217 - ImagickDraw::setFontSize
  • Example#3218 - ImagickDraw::setFontStretch
  • Example#3219 - ImagickDraw::setFontStyle
  • Example#3220 - ImagickDraw::setFontWeight
  • Example#3221 - ImagickDraw::setGravity
  • Example#3222 - ImagickDraw::setStrokeAlpha
  • Example#3223 - ImagickDraw::setStrokeAntialias
  • Example#3224 - ImagickDraw::setStrokeColor
  • Example#3225 - ImagickDraw::setStrokeDashArray
  • Example#3226 - ImagickDraw::setStrokeDashOffset
  • Example#3227 - ImagickDraw::setStrokeLineCap
  • Example#3228 - ImagickDraw::setStrokeLineJoin
  • Example#3229 - ImagickDraw::setStrokeMiterLimit
  • Example#3230 - ImagickDraw::setStrokeOpacity
  • Example#3231 - ImagickDraw::setStrokeWidth
  • Example#3232 - ImagickDraw::setTextAlignment
  • Example#3233 - ImagickDraw::setTextAntialias
  • Example#3234 - ImagickDraw::setTextDecoration
  • Example#3235 - ImagickDraw::setTextUnderColor
  • Example#3236 - ImagickDraw::setVectorGraphics
  • Example#3237 - ImagickDraw::setViewBox
  • Example#3238 - ImagickDraw::skewX
  • Example#3239 - ImagickDraw::skewY
  • Example#3240 - ImagickDraw::translate
  • Example#3241 - ImagickPixel::construct
  • Example#3242 - Uso básico de Imagick::getColor
  • Example#3243 - Uso básico de Imagick::getColorAsString
  • Example#3244 - getColorCount de ImagickPixel
  • Example#3245 - Uso básico de Imagick::getColorValue
  • Example#3246 - ImagickPixel::getColorValueQuantum
  • Example#3247 - Uso básico de Imagick::getHSL
  • Example#3248 - ImagickPixel::isSimilar
  • Example#3249 - ImagickPixel::setColor
  • Example#3250 - Uso básico de Imagick::setColorValue
  • Example#3251 - ImagickPixel::setColorValueQuantum
  • Example#3252 - Usar ImagickPixel::setHSL para modificar un color
  • Example#3253 - ImagickPixelIterator::clear
  • Example#3254 - ImagickPixelIterator::construct
  • Example#3255 - ImagickPixelIterator::getNextIteratorRow
  • Example#3256 - ImagickPixelIterator::resetIterator
  • Example#3257 - ImagickPixelIterator::setIteratorRow
  • Example#3258 - ImagickKernel::addKernel
  • Example#3259 - ImagickKernel::addUnityKernel
  • Example#3260 - ImagickKernel::addUnityKernel
  • Example#3261 - ImagickKernel::fromBuiltin
  • Example#3262 - ImagickKernel::fromMatrix
  • Example#3263 - ImagickKernel::getMatrix
  • Example#3264 - ImagickKernel::scale
  • Example#3265 - ImagickKernel::separate
  • Example#3266 - Ejemplo de imap_append
  • Example#3267 - Ejemplo de imap_check
  • Example#3268 - Ejemplo de imap_createmailbox
  • Example#3269 - Ejemplo de imap_delete
  • Example#3270 - Ejemplo de imap_fetch_overview
  • Example#3271 - Ejemplo de imap_gc
  • Example#3272 - Ejemplo de imap_get_quota
  • Example#3273 - Ejemplo de imap_get_quota 4.3 o superiro
  • Example#3274 - Ejemplo de imap_get_quotaroot
  • Example#3275 - Ejemplo de imap_getacl
  • Example#3276 - Ejemplo de imap_getmailboxes
  • Example#3277 - Ejemplo de imap_list
  • Example#3278 - Ejemplo de imap_mail_compose
  • Example#3279 - Ejemplo de imap_mailboxmsginfo
  • Example#3280 - Ejemplo de imap_mime_header_decode
  • Example#3281 - Diferentes usos de imap_open
  • Example#3282 - Ejemplo de imap_open
  • Example#3283 - Ejemplo de imap_ping
  • Example#3284 - Ejemplo de imap_reopen
  • Example#3285 - Ejemplo de imap_rfc822_parse_adrlist
  • Example#3286 - Ejemplo de imap_rfc822_write_address
  • Example#3287 - imap_search example
  • Example#3288 - Ejemplo de imap_set_quota
  • Example#3289 - Ejemplo de imap_setflag_full
  • Example#3290 - Ejemplo de imap_status
  • Example#3291 - Ejemplo de imap_thread
  • Example#3292 - Ejemplo de imap_timeout
  • Example#3293 - Calcular el hash de un usuario suscriptor.
  • Example#3294 - Enviar un correo.
  • Example#3295 - Enviar un correo con cabeceras extra.
  • Example#3296 - Enviar un correo con parámetros de línea de comando adicionales.
  • Example#3297 - Envío de un correo HTML
  • Example#3298 - Ejemplo de mailparse_determine_best_xfer_encoding
  • Example#3299 - Ejemplo de mailparse_rfc822_parse_addresses
  • Example#3300 - Ejemplo de mailparse_stream_encode
  • Example#3301 - Ejemplo de mailparse_uudecode_all
  • Example#3302 - Ejemplo bcadd
  • Example#3303 - Ejemplobccomp
  • Example#3304 - Ejemplo bcdiv
  • Example#3305 - Ejemplo bcmod
  • Example#3306 - Ejemplo bcmul
  • Example#3307 - Ejemplo bcpow
  • Example#3308 - Ejemplo de escalado de bcpow
  • Example#3309 - Ejemplo bcscale
  • Example#3310 - Ejemplo bcsqrt
  • Example#3311 - Ejemplo bcsub
  • Example#3312 - Función factorial usando GMP
  • Example#3313 - Ejemplo de gmp_abs
  • Example#3314 - Ejemplo de gmp_add
  • Example#3315 - Ejemplo de gmp_and
  • Example#3316 - Ejemplo de gmp_clrbit
  • Example#3317 - gmp_cmp example
  • Example#3318 - Ejemplo de gmp_com
  • Example#3319 - Ejemplo de gmp_div_q
  • Example#3320 - División de números GMP
  • Example#3321 - gmp_div_r example
  • Example#3322 - Ejemplo degmp_divexact
  • Example#3323 - Ejemplo de gmp_export
  • Example#3324 - Ejemplo degmp_fact
  • Example#3325 - Ejemplo degmp_gcd
  • Example#3326 - Resolver ecuaciones de diofántica lineal
  • Example#3327 - Ejemplo degmp_hamdist
  • Example#3328 - Ejemplo de gmp_import
  • Example#3329 - Creación de un número GMP
  • Example#3330 - Ejemplo de gmp_intval
  • Example#3331 - Ejemplo de gmp_invert
  • Example#3332 - Ejemplo de gmp_jacobi
  • Example#3333 - Ejemplo de gmp_legendre
  • Example#3334 - Ejemplo de gmp_mod
  • Example#3335 - Ejemplo degmp_mul
  • Example#3336 - Ejemplo degmp_neg
  • Example#3337 - Ejemplo de gmp_nextprime
  • Example#3338 - Ejemplo de gmp_or
  • Example#3339 - Ejemplo de gmp_perfect_square
  • Example#3340 - Ejemplo de gmp_popcount
  • Example#3341 - Ejemplo de gmp_pow
  • Example#3342 - gmp_powm example
  • Example#3343 - Ejemplo de gmp_prob_prime
  • Example#3344 - Ejemplo de gmp_random_bits
  • Example#3345 - Ejemplo de gmp_random_range
  • Example#3346 - Ejemplo de gmp_random_seed
  • Example#3347 - Ejemplo de gmp_random
  • Example#3348 - Ejemplo de gmp_scan0
  • Example#3349 - Ejemplo de gmp_scan1
  • Example#3350 - Ejemplo de gmp_setbit - índice 0
  • Example#3351 - Ejemplo de gmp_setbit - índice 1
  • Example#3352 - Ejemplo de gmp_setbit - limpiar un bit
  • Example#3353 - Ejemplo de gmp_sign
  • Example#3354 - Ejemplo de gmp_sqrt
  • Example#3355 - Ejemplo degmp_sqrtrem
  • Example#3356 - Converting a GMP number to a string
  • Example#3357 - Ejemplo de gmp_sub
  • Example#3358 - Ejemplo degmp_testbit
  • Example#3359 - Ejemplo degmp_xor
  • Example#3360 - Ejemplo de abs
  • Example#3361 - Ejemplo de base_convert
  • Example#3362 - Ejemplo de bindec
  • Example#3363 - bindec interpreta las entradas como enteros sin signo
  • Example#3364 - Ejemplo de ceil
  • Example#3365 - Ejemplo de cos
  • Example#3366 - Ejemplo de decbin
  • Example#3367 - Ejemplo dechex
  • Example#3368 - Ejemplo de dechex con números enteros grandes
  • Example#3369 - Ejemplo de decoct
  • Example#3370 - Ejemplo de deg2rad
  • Example#3371 - Ejemplo de exp
  • Example#3372 - Using fdiv
  • Example#3373 - Ejemplo de floor
  • Example#3374 - Uso de fmod
  • Example#3375 - Ejemplo de hexdec
  • Example#3376 - Ejemplo de intdiv
  • Example#3377 - Ejemplo de is_nan
  • Example#3378 - Ejemplos de uso de max
  • Example#3379 - Ejemplos de uso de min
  • Example#3380 - Calcular un número de coma flotante aleatorio
  • Example#3381 - Ejemplo de mt_rand
  • Example#3382 - Ejemplo de mt_srand
  • Example#3383 - Ejemplo de octdec
  • Example#3384 - Ejemplo de pi
  • Example#3385 - Algunos ejemplos de pow
  • Example#3386 - Ejemplo de rad2deg
  • Example#3387 - Ejemplo de rand
  • Example#3388 - Ejemplos de round
  • Example#3389 - Ejemplos de mode
  • Example#3390 - Ejemplos de mode con precisión
  • Example#3391 - Ejemplo de sin
  • Example#3392 - Ejemplo de sqrt
  • Example#3393 - Ejemplo de srand
  • Example#3394 - Ejemplo de tan
  • Example#3395 - Evaluar un documento FDF
  • Example#3396 - Añadiendo código JavaScript a un FDF
  • Example#3397 - Poblar un documento PDF
  • Example#3398 - Guardando un fichero subido por FDF
  • Example#3399 - Detección de todos los nombres de campo en un FDF
  • Example#3400 - Accediendo a los datos de un formulario
  • Example#3401 - Acceso a datos de formulario
  • Example#3402 - Salvando un FDF como string
  • Example#3403 - Paso de datos FDF a un segundo formulario
  • Example#3404 - Ejemplo de firma (clearsign) gnupg mediante funciones
  • Example#3405 - Ejemplo de firma gnupg (clearsign) mediante orientación a objetos
  • Example#3406 - keylistiterator
  • Example#3407 - Ejemplo de gnupg_adddecryptkey mediante funciones
  • Example#3408 - Ejemplo de gnupg_adddecryptkey mediante OO
  • Example#3409 - Ejemplo de gnupg_addencryptkey mediante funciones
  • Example#3410 - Ejemplo de gnupg_addencryptkey mediante OO
  • Example#3411 - Ejemplo de gnupg_addsignkey mediante funciones
  • Example#3412 - Ejemplo de gnupg_addsignkey mediante OO
  • Example#3413 - Ejemplo de gnupg_cleardecryptkeys mediante funciones
  • Example#3414 - Ejemplo de gnupg_cleardecryptkeys mediante OO
  • Example#3415 - Ejemplo de gnupg_clearencryptkeys mediante funciones
  • Example#3416 - Ejemplo de gnupg_clearencryptkeys mediante OO
  • Example#3417 - Ejemplo de gnupg_clearsignkeys mediante funciones
  • Example#3418 - Ejemplo de gnupg_clearsignkeys mediante OO
  • Example#3419 - Ejemplo de gnupg_decrypt mediante funciones
  • Example#3420 - Ejemplo de gnupg_encrypt mediante OO
  • Example#3421 - Ejemplo de gnupg_decryptverify mediante funciones
  • Example#3422 - Ejemplo de gnupg_decryptverify mediante OO
  • Example#3423 - Ejemplo de gnupg_encrypt mediante funciones
  • Example#3424 - Ejemplo de gnupg_encrypt mediante OO
  • Example#3425 - Ejemplo de gnupg_encryptsign mediante funciones
  • Example#3426 - Ejemplo de gnupg_encryptsign mediante OO
  • Example#3427 - Ejemplo de gnupg_export mediante funciones
  • Example#3428 - Ejemplo de gnupg_export mediante OO
  • Example#3429 - Ejemplo de gnupg_geterror mediante funciones
  • Example#3430 - Ejemplo de gnupg_geterror mediante OO
  • Example#3431 - Ejemplo de gnupg_getprotocol mediante funciones
  • Example#3432 - Ejemplo de gnupg_getprotocol mediante
  • Example#3433 - Ejemplo de gnupg_import mediante funciones
  • Example#3434 - Ejemplo de gnupg_import mediante OO
  • Example#3435 - Ejemplo de gnupg_init mediante funciones
  • Example#3436 - Ejemplo del inicializador gnupg mediante OO
  • Example#3437 - Ejemplo de gnupg_keyinfo mediante funciones
  • Example#3438 - Ejemplo de gnupg_keyinfo mediante OO
  • Example#3439 - Ejemplo de gnupg_setarmor mediante funciones
  • Example#3440 - Ejemplo de gnupg_setarmor mediante OO
  • Example#3441 - Pejemplo de gnupg_seterrormode mediante funciones
  • Example#3442 - Ejemplo de gnupg_seterrormode mediante OO
  • Example#3443 - Ejemplo de gnupg_setsignmode mediante funciones
  • Example#3444 - Ejemplo de gnupg_setsignmode mediante OO
  • Example#3445 - Ejemplo de gnupg_sign mediante funciones
  • Example#3446 - Ejemplo de gnupg_sign mediante OO
  • Example#3447 - Ejemplo de gnupg_verify mediante funciones
  • Example#3448 - Ejemplo de gnupg_verify mediante OO
  • Example#3449 - Crear y usar un patrón
  • Example#3450 - Crear y utilizar una plantilla
  • Example#3451 - Particionar silábicamente un texto
  • Example#3452 - Dibujar un rectángulo
  • Example#3453 - Crear y utilizar un color directo
  • Example#3454 - Rotación del sistema de coordenadas
  • Example#3455 - Colocar texto en una posición dada
  • Example#3456 - Dibujar una línea discontinua
  • Example#3457 - Traslación del sistema de coordenadas
  • Example#3458 - A rpmdbinfo example
  • Example#3459 - Searching for the package owning a file
  • Example#3460 - A rpminfo example
  • Example#3461 - ejemplo
  • Example#3462 - ejemplo
  • Example#3463 - ejemplo
  • Example#3464 - ejemplo
  • Example#3465 - ejemplo
  • Example#3466 - ejemplo
  • Example#3467 - ejemplo
  • Example#3468 - ejemplo
  • Example#3469 - ejemplo
  • Example#3470 - ejemplo
  • Example#3471 - ejemplo
  • Example#3472 - ejemplo
  • Example#3473 - ejemplo
  • Example#3474 - ejemplo
  • Example#3475 - ejemplo
  • Example#3476 - ejemplo
  • Example#3477 - ejemplo
  • Example#3478 - ejemplo
  • Example#3479 - ejemplo
  • Example#3480 - Incorrect requests
  • Example#3481 - Llamar a una petición desde una llamada de retorno de petición
  • Example#3482 - Llamar a una petición desde una llamada de retorno de petición
  • Example#3483 - Usar eio con libevent
  • Example#3484 - Cancelar una petición
  • Example#3485 - Llamar a eio_chmod
  • Example#3486 - Realizar una petición personalizada
  • Example#3487 - Agrupar peticiones
  • Example#3488 - Emplear eio con la extensión libevent
  • Example#3489 - Emplear eio con la extensión event
  • Example#3490 - Ejemplo de eio_cancel
  • Example#3491 - Ejemplo de eio_custom
  • Example#3492 - Ejemplo de eio_event_loop
  • Example#3493 - Ejemplo de eio_lstat
  • Example#3494 - Usar eio con libevent
  • Example#3495 - Agrupar peticiones
  • Example#3496 - Ejemplo de eio_grp
  • Example#3497 - Ejemplo de eio_link
  • Example#3498 - Ejemplo de eio_lstat
  • Example#3499 - Ejemplo de eio_mkdir
  • Example#3500 - Ejemplo de eio_mknod
  • Example#3501 - Ejepmlo de eio_nreqs
  • Example#3502 - Ejemplo de eio_open
  • Example#3503 - Ejemplo de eio_poll
  • Example#3504 - Ejemplo de eio_read
  • Example#3505 - eio_readdir example
  • Example#3506 - Ejemplo de eio_readlink
  • Example#3507 - Ejemplo deeio_realpath
  • Example#3508 - Ejemplo de eio_rename
  • Example#3509 - Ejemplo de eio_rmdir
  • Example#3510 - Ejemplo de eio_stat
  • Example#3511 - Ejemplo de eio_statvfs
  • Example#3512 - eio_symlink example
  • Example#3513 - Simple timers
  • Example#3514 - Periodic timer. Tick each 10.5 seconds
  • Example#3515 - Periodic timer. Use reschedule callback
  • Example#3516 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3517 - Wait until STDIN is readable
  • Example#3518 - Use some async I/O to access a socket
  • Example#3519 - Embedding one loop into another
  • Example#3520 - Embedding loop created with kqueue backend into the default loop
  • Example#3521 - Handle SIGTERM signal
  • Example#3522 - Monitor changes of /var/log/messages
  • Example#3523 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3524 - Process status changes
  • Example#3525 - Using reschedule callback
  • Example#3526 - Embedding loop created with kqueue backend into the default loop
  • Example#3527 - Embedding one loop into another
  • Example#3528 - Embedding loop created with kqueue backend into the default loop
  • Example#3529 - Embedding loop created with kqueue backend into the default loop
  • Example#3530 - Periodic timer. Use reschedule callback
  • Example#3531 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3532 - Hourly watcher
  • Example#3533 - Manejar la señal SIGTERM
  • Example#3534 - Monitor changes of /var/log/messages
  • Example#3535 - Monitor changes of /var/log/messages
  • Example#3536 - Simple timers
  • Example#3537 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3538 - Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.
  • Example#3539 - Ejemplo de uso de Expect
  • Example#3540 - Otro ejemplo de uso de Expect
  • Example#3541 - Ejemplo de expect_expectl
  • Example#3542 - Ejemplo de expect_popen
  • Example#3543 - Process Control Example
  • Example#3544 - pcntl_fork example
  • Example#3545 - pcntl_signal_dispatch example
  • Example#3546 - pcntl_signal_get_handler example
  • Example#3547 - pcntl_signal example
  • Example#3548 - pcntl_sigprocmask example
  • Example#3549 - pcntl_sigwaitinfo example
  • Example#3550 - Ejemplo de posix_access
  • Example#3551 - Ejemplo de posix_ctermid
  • Example#3552 - Ejemplo de posix_get_last_error
  • Example#3553 - Ejemplo de posix_getcwd
  • Example#3554 - Ejemplo de posix_getegid
  • Example#3555 - Ejemplo de posix_geteuid
  • Example#3556 - Ejemplo de posix_getgid
  • Example#3557 - Ejemplo de uso deposix_getgrgid
  • Example#3558 - Ejemplo de uso de posix_getgrnam
  • Example#3559 - Ejemplo de uso de posix_getgroups
  • Example#3560 - Ejemplo de uso de posix_getlogin
  • Example#3561 - Ejemplo de uso de posix_getpgid
  • Example#3562 - Ejemplo de uso de posix_getpid
  • Example#3563 - Ejemplo de uso de posix_getppid
  • Example#3564 - Ejemplo de uso de posix_getpwnam
  • Example#3565 - Ejemplo de uso de posix_getpwuid
  • Example#3566 - Ejemplo de uso de posix_getrlimit
  • Example#3567 - Ejemplo de uso de posix_getsid
  • Example#3568 - Ejemplo de uso de posix_getuid
  • Example#3569 - Un ejemplo de posix_mknod
  • Example#3570 - Ejemplo de posix_setegid
  • Example#3571 - Ejemplo de posix_setgid
  • Example#3572 - Ejemplo de posix_setuid
  • Example#3573 - Ejemplo de posix_strerror
  • Example#3574 - Ejemplo de uso de posix_times
  • Example#3575 - Ejemplo de uso de posix_uname
  • Example#3576 - Ejemplo de escapeshellarg
  • Example#3577 - Ejemplo de escapeshellcmd
  • Example#3578 - Un ejemplo de exec
  • Example#3579 - Ejemplo de proc_open
  • Example#3580 - Un ejemplo de shell_exec
  • Example#3581 - Ejemplo de system
  • Example#3582 - Example showing Future as return value
  • Example#3583 - Example showing Future as synchronization point
  • Example#3584 - Fetch a chunk of the property table
  • Example#3585 - Counting the properties of an object
  • Example#3586 - Runtime inheritance
  • Example#3587 - Thread safe objects from closures
  • Example#3588 - Detecting fatal errors in Threads
  • Example#3589 - Detect the state of the referenced object
  • Example#3590 - Detect the state of the referenced object
  • Example#3591 - Detect the state of the referenced object
  • Example#3592 - Locking Object Properties
  • Example#3593 - Merging into the property table of a threaded object
  • Example#3594 - Notifications and Waiting
  • Example#3595 - Notifications and Waiting
  • Example#3596 - Popping the last item from the property table of a threaded object
  • Example#3597 - Shifting the first item from the property table of a threaded object
  • Example#3598 - Synchronizing
  • Example#3599 - Locking the property table of a threaded object
  • Example#3600 - Notifications and Waiting
  • Example#3601 - Devuelve la identificación del hilo o proceso que el hilo referenciado creó.
  • Example#3602 - Devuelve el hilo que se está ejecutando
  • Example#3603 - Return the identity of the currently executing Thread
  • Example#3604 - Return the identity of the referenced Thread
  • Example#3605 - Execute in the global scope
  • Example#3606 - Detect the state of the referenced Thread
  • Example#3607 - Tell if the referenced Thread was started
  • Example#3608 - Join with the referenced Thread
  • Example#3609 - Termina el hilo referenciado
  • Example#3610 - Starting Threads
  • Example#3611 - A basic example of Worker::collect
  • Example#3612 - A basic example of Worker::getStacked
  • Example#3613 - Detect the state of a worker
  • Example#3614 - Detect the state of a Worker
  • Example#3615 - Shutdown the referenced worker
  • Example#3616 - Stacking a task for execution onto a worker
  • Example#3617 - Removing objects from the stack of Workers
  • Example#3618 - Ejemplo de método protegido: los métodos protegidos solamente pueden ser ejecutados por un Thread a la vez.
  • Example#3619 - Ejemplo de método privado: los métodos privados solamente pueden ser ejecutados por el objeto Threaded durante su ejecución
  • Example#3620 - A basic example of Pool::collect
  • Example#3621 - Creating Pools
  • Example#3622 - Shutting down a pool
  • Example#3623 - Submitting Tasks
  • Example#3624 - Submitting tasks to a specific worker
  • Example#3625 - Mutex Creation and Destruction
  • Example#3626 - Mutex Creation and Destruction
  • Example#3627 - Mutex Locking and Unlocking
  • Example#3628 - Mutex Locking and Unlocking
  • Example#3629 - Mutex Locking and Unlocking
  • Example#3630 - Condition Broadcasting
  • Example#3631 - Condition Creation and Destruction
  • Example#3632 - Condition Creation and Destruction
  • Example#3633 - Condition Signalling
  • Example#3634 - Waiting for Conditions
  • Example#3635 - Adding a new class task to a thread
  • Example#3636 - Adding a new file task to a thread
  • Example#3637 - Adding a new function task to a thread
  • Example#3638 - Joining a thread
  • Example#3639 - Starting a new thread
  • Example#3640 - Getting the task count of a thread
  • Example#3641 - Locking a hash table's mutex lock
  • Example#3642 - Getting a hash table's size
  • Example#3643 - Locking a hash table's mutex lock
  • Example#3644 - Creating a new vector
  • Example#3645 - Deleting values in a vector
  • Example#3646 - Inserting a value into a vector
  • Example#3647 - Locking a vector's mutex lock
  • Example#3648 - Popping a value from a vector
  • Example#3649 - Pushing values to a vector
  • Example#3650 - Resizing a vector
  • Example#3651 - Shifting a value from a vector
  • Example#3652 - Getting a vector's size
  • Example#3653 - Locking a vector's mutex lock
  • Example#3654 - Unshifting a value to the front of a vector
  • Example#3655 - Updating a value in a vector
  • Example#3656 - Retrieving the front value of a queue
  • Example#3657 - Retrieving the front value in a loop (bad example - don't do this)
  • Example#3658 - Retrieving the front value in a loop (good example)
  • Example#3659 - Locking a queue's mutex lock
  • Example#3660 - Popping a value from a queue
  • Example#3661 - Pushing a value to a queue
  • Example#3662 - Getting a queue's size
  • Example#3663 - Locking a queue's mutex lock
  • Example#3664 - Creating a new atomic integer
  • Example#3665 - Decrementing an atomic integer's value
  • Example#3666 - Getting an atomic integer's value
  • Example#3667 - Incrementing an atomic integer's value
  • Example#3668 - Grouping together an atomic integer's operations (requiring a mutex lock)
  • Example#3669 - Setting an atomic integer's value
  • Example#3670 - Grouping together an atomic integer's operations (requiring a mutex lock)
  • Example#3671 -
  • Example#3672 - Resumen de las operaciones con Memoria Compartida
  • Example#3673 - Cerrando segmento de memoria compartida
  • Example#3674 - Borrando segmento de memoria compartida
  • Example#3675 - Crear un nuevo segmento de memoria compartida
  • Example#3676 - Lectura de un segmento de memoria compartida
  • Example#3677 - Obtención del tamaño de un segmento de memoria compartida
  • Example#3678 - Escribiendo en un segmento de memoria compartida
  • Example#3679 - SyncMutex::__construct named mutex with lock timeout example
  • Example#3680 - SyncMutex::__construct unnamed mutex example
  • Example#3681 - SyncMutex::lock example
  • Example#3682 - SyncMutex::unlock example
  • Example#3683 - SyncSemaphore::__construct example
  • Example#3684 - SyncSemaphore::lock example
  • Example#3685 - SyncSemaphore::unlock example
  • Example#3686 - SyncEvent::__construct example
  • Example#3687 - SyncEvent::fire example
  • Example#3688 - SyncEvent::reset example
  • Example#3689 - SyncEvent::wait example
  • Example#3690 - SyncReaderWriter::__construct example
  • Example#3691 - SyncReaderWriter::readlock example
  • Example#3692 - SyncReaderWriter::readunlock example
  • Example#3693 - SyncReaderWriter::writelock example
  • Example#3694 - SyncReaderWriter::writeunlock example
  • Example#3695 - SyncSharedMemory::__construct example
  • Example#3696 - SyncSharedMemory::first example
  • Example#3697 - SyncSharedMemory::__construct example
  • Example#3698 - SyncSharedMemory::size example
  • Example#3699 - SyncSharedMemory::write example
  • Example#3700 - Un ejemplo de geoip_asnum_by_name
  • Example#3701 - Un ejemplo de geoip_continent_code_by_name
  • Example#3702 - Ejemplo de geoip_country_code_by_name
  • Example#3703 - Ejemplo de geoip_country_code3_by_name
  • Example#3704 - Ejemplo de geoip_country_name_by_name
  • Example#3705 - Ejemplo de geoip_database_info
  • Example#3706 - Un ejemplo de geoip_db_avail
  • Example#3707 - Ejemplo de geoip_db_filename
  • Example#3708 - Ejemplo de geoip_db_get_all_info
  • Example#3709 - Ejemplo de geoip_db_get_all_info
  • Example#3710 - Un ejemplo de geoip_domain_by_name
  • Example#3711 - Ejemplo de geoip_id_by_name
  • Example#3712 - Ejemplo de geoip_isp_by_name
  • Example#3713 - Un ejemplo de geoip_netspeedcell_by_name
  • Example#3714 - Ejemplo de geoip_org_by_name
  • Example#3715 - Ejemplo de geoip_record_by_name
  • Example#3716 - Ejemplo de geoip_region_by_name
  • Example#3717 - Ejemplo de geoip_region_name_by_code usando código de región para EEUU/Cánada
  • Example#3718 - Ejemplo de geoip_region_name_by_code usando códigos FIPS
  • Example#3719 - Un ejemplo de geoip_setup_custom_directory
  • Example#3720 - Ejemplo de geoip_time_zone_by_country_and_region usando códigos de región de EEUU/Canadá
  • Example#3721 - Ejemplo de geoip_time_zone_by_country_and_region usando códigos FIPS
  • Example#3722 - Fichero xor.data
  • Example#3723 - Entrenamiento sencillo
  • Example#3724 - Prueba sencilla
  • Example#3725 - Ejemplo de fann_create_train_from_callback
  • Example#3726 - Ejemplo de fann_read_train_from_file
  • Example#3727 - Ejemplo de JsonSerializable::jsonSerialize devolviendo un array
  • Example#3728 - Ejemplo de JsonSerializable::jsonSerialize devolviendo un array asociativo
  • Example#3729 - Ejemplo de JsonSerializable::jsonSerialize devolviento un integer
  • Example#3730 - Ejemplo de JsonSerializable::jsonSerialize devolviendo un string
  • Example#3731 - Ejemplos de json_decode
  • Example#3732 - Acceder a propiedades de objeto no válidas
  • Example#3733 - Errores comunes al usar json_decode
  • Example#3734 - Errores con depth
  • Example#3735 - json_decode de enteros grandes
  • Example#3736 - Un ejemplo de json_encode
  • Example#3737 - Un ejemplo de json_encode mostrando algunas de las opciones en acción
  • Example#3738 - Ejemplo de la opción JSON_NUMERIC_CHECK
  • Example#3739 - Ejemplo de array secuencial contra array no secuencial
  • Example#3740 - Ejemplo de la opción JSON_PRESERVE_ZERO_FRACTION
  • Example#3741 - Ejemplo de json_last_error
  • Example#3742 - json_last_error en json_encode
  • Example#3743 - Ejemplo de Lua::assign
  • Example#3744 - Ejemplo de la función Lua::call
  • Example#3745 - Ejemplo de la función Lua::eval
  • Example#3746 - Ejemplo de Lua::registerCallback
  • Example#3747 - Ejemplo de LuaClosure::__invoke
  • Example#3748 - Execute some Lua code
  • Example#3749 - Calling a Lua function
  • Example#3750 - Profiling Lua code
  • Example#3751 - Loading code into Lua
  • Example#3752 - Manipulating the usage timer
  • Example#3753 - Registering PHP functions to call from Lua
  • Example#3754 - Calling a Lua function
  • Example#3755 - Calling a Lua function
  • Example#3756 - Ejemplo de constant
  • Example#3757 - Definir Constantes
  • Example#3758 - Comprobar constantes
  • Example#3759 - Ejemplo de eval - fusión de texto sencillo
  • Example#3760 - Ejemplo de exit
  • Example#3761 - Ejemplo de status de exit
  • Example#3762 - Las funciones Shutdown y los destructores se ejecutan igualmente
  • Example#3763 - Listar toda la información sobre el navegador del usuario
  • Example#3764 - Un Ejemplo de __halt_compiler
  • Example#3765 - Ejemplo de highlight_string
  • Example#3766 - hrtime usage
  • Example#3767 - Un ejemplo ignore_user_abort
  • Example#3768 - Ejemplo de pack
  • Example#3769 - Ejemplo de php_strip_whitespace
  • Example#3770 - Basic sapi_windows_generate_ctrl_event Usage
  • Example#3771 - Basic sapi_windows_set_ctrl_handler Usage
  • Example#3772 - sapi_windows_vt100_support default state
  • Example#3773 - sapi_windows_vt100_support changing state
  • Example#3774 - Example usage of VT100 support enabled
  • Example#3775 - Ejemplo de sleep
  • Example#3776 - Ejemplo de sys_getloadavg
  • Example#3777 - Ejemplo de time_nanosleep
  • Example#3778 - Un ejemplo de time_sleep_until
  • Example#3779 - Ejemplo de uniqid
  • Example#3780 - Ejemplo de unpack
  • Example#3781 - Ejemplo de unpack con un repetidor
  • Example#3782 - Ejemplo unpack con claves sin nombre
  • Example#3783 - Ejemplo de usleep
  • Example#3784 - Get and set base path
  • Example#3785 - Get and set logger
  • Example#3786 - Fast write log
  • Example#3787 - Fast count some type of log count value
  • Example#3788 - Acquisit some type of log list
  • Example#3789 - seaslog_get_author example
  • Example#3790 - seaslog_get_version example
  • Example#3791 - SeasLog::alert example
  • Example#3792 - SeasLog::analyzerCount example
  • Example#3793 - SeasLog::analyzerDetail example
  • Example#3794 - SeasLog::closeLoggerStream example
  • Example#3795 - SeasLog::__construct example
  • Example#3796 - SeasLog::critical example
  • Example#3797 - SeasLog::debug example
  • Example#3798 - SeasLog::__destruct example
  • Example#3799 - SeasLog::emergency example
  • Example#3800 - SeasLog::error example
  • Example#3801 - SeasLog::flushBuffer example
  • Example#3802 - SeasLog::getBasePath example
  • Example#3803 - SeasLog::getBuffer example
  • Example#3804 - SeasLog::getBufferEnabled example
  • Example#3805 - SeasLog::getDatetimeFormat example
  • Example#3806 - SeasLog::getLastLogger example
  • Example#3807 - SeasLog::getRequestID example
  • Example#3808 - SeasLog::getRequestVariable example
  • Example#3809 - SeasLog::info example
  • Example#3810 - SeasLog::log example
  • Example#3811 - SeasLog::notice example
  • Example#3812 - SeasLog::setBasePath example
  • Example#3813 - SeasLog::setDatetimeFormat example
  • Example#3814 - SeasLog::setLogger example
  • Example#3815 - SeasLog::setRequestID example
  • Example#3816 - SeasLog::setRequestVariable example
  • Example#3817 - SeasLog::warning example
  • Example#3818 - Ejemplo de SplDoublyLinkedList::__construct
  • Example#3819 - Ejemplo de SplStack::__construct
  • Example#3820 - Ejemplo de SplQueue::__construct
  • Example#3821 - Manejo eficiente de las tareas con SplQueue
  • Example#3822 - Ejemplo de uso SplFixedArray
  • Example#3823 - Ejemplo de SplFixedArray::__construct
  • Example#3824 - Ejemplo de SplFixedArray::count
  • Example#3825 - Ejemplo de SplFixedArray::fromArray
  • Example#3826 - Ejemplo de SplFixedArray::getSize
  • Example#3827 - Ejemplo de SplFixedArray::setSize
  • Example#3828 - Ejemplo de SplFixedArray::toArray
  • Example#3829 - SplObjectStorage como un conjunto
  • Example#3830 - SplObjectStorage como un mapa
  • Example#3831 - Ejemplo de SplObjectStorage::addAll
  • Example#3832 - Ejemplo de SplObjectStorage::attach
  • Example#3833 - Ejemplo de SplObjectStorage::contains
  • Example#3834 - Ejemplo de SplObjectStorage::count
  • Example#3835 - Ejemplo de SplObjectStorage::current
  • Example#3836 - Ejemplo de SplObjectStorage::detach
  • Example#3837 - Ejemplo de SplObjectStorage::getHash
  • Example#3838 - Ejemplo de SplObjectStorage::getInfo
  • Example#3839 - Ejemplo de SplObjectStorage::key
  • Example#3840 - Ejemplo de SplObjectStorage::next
  • Example#3841 - Ejemplo de SplObjectStorage::offsetExists
  • Example#3842 - Ejemplo de SplObjectStorage::offsetGet
  • Example#3843 - Ejemplo de SplObjectStorage::offsetSet
  • Example#3844 - Ejemplo de SplObjectStorage::offsetUnset
  • Example#3845 - Ejemplo de SplObjectStorage::removeAll
  • Example#3846 - Ejemplo de SplObjectStorage::removeAllExcept
  • Example#3847 - Ejemplo de SplObjectStorage::rewind
  • Example#3848 - Ejemplo de SplObjectStorage::serialize
  • Example#3849 - Ejemplo de SplObjectStorage::setInfo
  • Example#3850 - Ejemplo de SplObjectStorage::unserialize
  • Example#3851 - Ejemplo de SplObjectStorage::valid
  • Example#3852 - Ejemplo de AppendIterator::append
  • Example#3853 - Recorriendo AppendIterator con foreach
  • Example#3854 - Recorriendo AppendIterator con la API de AppendIterator
  • Example#3855 - Ejemplo de AppendIterator::getInnerIterator
  • Example#3856 - Ejemplo básico de AppendIterator.getIteratorIndex
  • Example#3857 - Ejemplo básico de AppendIterator::key
  • Example#3858 - Ejemplo de ArrayIterator::current
  • Example#3859 - Ejemplo de ArrayIterator::key
  • Example#3860 - Ejemplo de ArrayIterator::next
  • Example#3861 - Ejemplo de ArrayIterator::rewind
  • Example#3862 - Ejemplo de ArrayIterator::valid
  • Example#3863 - Ejemplo de CachingIterator::getCache.
  • Example#3864 - Argumentos disponibles de la llamada de retorno
  • Example#3865 - Ejemplos básicos de llamada de retorno
  • Example#3866 - Un DirectoryIterator::__construct ejemplo
  • Example#3867 - Ejemplo de DirectoryIterator::current
  • Example#3868 - Ejemplo de DirectoryIterator::getATime
  • Example#3869 - Ejemplo de DirectoryIterator::getBasename
  • Example#3870 - DirectoryIterator::getCTime example
  • Example#3871 - Ejemplo de DirectoryIterator::getExtension
  • Example#3872 -
  • Example#3873 - Ejemplo de DirectoryIterator::getFilename
  • Example#3874 - Ejemplo de DirectoryIterator::getGroup
  • Example#3875 - Ejemplo de DirectoryIterator::getInode
  • Example#3876 - Ejemplo de DirectoryIterator::getMTime
  • Example#3877 - Ejemplo de DirectoryIterator::getOwner
  • Example#3878 - Ejemplo de DirectoryIterator::getPath
  • Example#3879 - Ejemplo de DirectoryIterator::getPathname
  • Example#3880 - Ejemplo de DirectoryIterator::getPerms
  • Example#3881 - Ejemplo de DirectoryIterator::getSize
  • Example#3882 - Ejemplo de DirectoryIterator::getType
  • Example#3883 - Ejemplo de DirectoryIterator::isDir
  • Example#3884 - Ejemplo de DirectoryIterator::isDot
  • Example#3885 - Ejemplo de DirectoryIterator::isExecutable
  • Example#3886 - Ejemplo de DirectoryIterator::isFile
  • Example#3887 - Ejemplo de DirectoryIterator::isLink
  • Example#3888 - Ejemplo de DirectoryIterator::isReadable
  • Example#3889 - Ejemplo de DirectoryIterator::isWritable
  • Example#3890 - Ejemplo de DirectoryIterator::key
  • Example#3891 - Ejemplo de DirectoryIterator::next
  • Example#3892 - Ejemplo de DirectoryIterator::rewind
  • Example#3893 - Ejemplo de DirectoryIterator::seek
  • Example#3894 - Ejemplo de DirectoryIterator::__toString
  • Example#3895 - Ejemplo de DirectoryIterator::valid
  • Example#3896 - Ejemplo de FilesystemIterator::__construct
  • Example#3897 - Ejemplo de FilesystemIterator::current
  • Example#3898 - Ejemplo de FilesystemIterator::key
  • Example#3899 - Ejemplo de FilesystemIterator::next
  • Example#3900 - Ejemplo de FilesystemIterator::rewind
  • Example#3901 - Ejemplo de FilesystemIterator::key
  • Example#3902 - Ejemplo de FilterIterator::accept
  • Example#3903 - Ejemplo de GlobIterator
  • Example#3904 - Ejemplo de GlobIterator::count
  • Example#3905 - Ejemplo de InfiniteIterator::__construct
  • Example#3906 - Ejemplo de uso de LimitIterator
  • Example#3907 - Ejemplo de LimitIterator::__construct
  • Example#3908 - Ejemplo de LimitIterator::getPosition
  • Example#3909 - Iterar un MultipleIterator
  • Example#3910 - Ejemplo de NoRewindIterator::__construct
  • Example#3911 - Ejemplo de NoRewindIterator::rewind
  • Example#3912 - Ejemplo de RecursiveArrayIterator::getChildren
  • Example#3913 - Ejemplo de RecursiveArrayIterator::hasChildren
  • Example#3914 - Argumentos disponibles de la llamada de retorno
  • Example#3915 - Ejemplo básico de llamada de retorno recursiva
  • Example#3916 - Uso básico de RecursiveCallbackFilterIterator::hasChildren
  • Example#3917 - Ejemplo de RecursiveDirectoryIterator
  • Example#3918 - Ejemplo de getSubPath
  • Example#3919 - Ejemplo de getSubPathname
  • Example#3920 - Ejemplo básico de RecursiveFilterIterator
  • Example#3921 - Ejemplo de RecursiveFilterIterator
  • Example#3922 - Iterar un RecursiveIteratorIterator
  • Example#3923 - Ejemplo de RecursiveRegexIterator::__construct
  • Example#3924 - Ejemplo de RecursiveRegexIterator::getChildren
  • Example#3925 - Ejemplo de RecursiveRegexIterator::hasChildren
  • Example#3926 - RegexIterator::accept example
  • Example#3927 - Ejemplo de RegexIterator::__construct
  • Example#3928 - Ejemplo de RegexIterator::getFlags
  • Example#3929 - Ejemplo de RegexIterator::getMode
  • Example#3930 - Ejemplo de RegexIterator::getPregFlags
  • Example#3931 - Ejemplo de RegexIterator::setFlags
  • Example#3932 - Ejemplo de RegexIterator::setMode
  • Example#3933 - Ejemplo de RegexIterator::setPregFlags
  • Example#3934 - Ejemplo de Countable::count
  • Example#3935 - Uso básico
  • Example#3936 - Ejemplo de SeekableIterator::seek
  • Example#3937 - Ejemplo de class_implements
  • Example#3938 - Ejemplo de class_parents
  • Example#3939 - Ejemplo de class_uses
  • Example#3940 - Ejemplo de iterator_apply
  • Example#3941 - Ejemplo de iterator_count
  • Example#3942 - iterator_count modifica la posición
  • Example#3943 - iterator_count en bucles foreach
  • Example#3944 - Ejemplo de iterator_to_array
  • Example#3945 - spl_autoload_register como sustituto de una función __autoload
  • Example#3946 - Ejemplo de spl_autoload_register donde la clase no es cargada
  • Example#3947 - Ejemplo de spl_classes
  • Example#3948 - Ejemplo de spl_object_hash
  • Example#3949 - A spl_object_id example
  • Example#3950 - SplFileInfo::__construct ejemplo
  • Example#3951 - SplFileInfo::getBasenameejemplo
  • Example#3952 - Ejemplo de SplFileInfo::getCTime
  • Example#3953 - SplFileInfo::getExtension ejemplo
  • Example#3954 -
  • Example#3955 - SplFileInfo::getFilename ejemplo
  • Example#3956 - Ejemplo de SplFileInfo::getGroup
  • Example#3957 - Ejemplo de SplFileInfo::getLinkTarget
  • Example#3958 - Ejemplo de SplFileInfo::getOwner
  • Example#3959 - Ejemplo de SplFileInfo::getPath
  • Example#3960 - Ejemplo de SplFileInfo::getPathInfo
  • Example#3961 - Ejemplo de SplFileInfo::getPathname
  • Example#3962 - Ejemplo de SplFileInfo::getPerms
  • Example#3963 - Ejemplo de SplFileInfo::getRealPath
  • Example#3964 - Ejemplo de SplFileInfo::getType
  • Example#3965 - Ejemplo de SplFileInfo::isDir
  • Example#3966 - Ejemplo de SplFileInfo::isExecutable
  • Example#3967 - Ejemplo de SplFileInfo::isFile
  • Example#3968 - Ejemplo de SplFileInfo::isLink
  • Example#3969 - Ejemplo de SplFileInfo::isReadable
  • Example#3970 - Ejemplo de SplFileInfo::openFile
  • Example#3971 - Ejemplo de SplFileInfo::setFileClass
  • Example#3972 - Ejemplo de SplFileInfo::setFileClass
  • Example#3973 - Ejemplo de SplFileInfo::__toString
  • Example#3974 - Ejemplo de SplFileObject::__construct
  • Example#3975 - Ejemplo de SplFileObject::current
  • Example#3976 - Ejemplo de SplFileObject::eof
  • Example#3977 - Ejemplo de SplFileObject::fflush
  • Example#3978 - Ejemplo de SplFileObject::fgetc
  • Example#3979 - Ejemplo de SplFileObject::fgetcsv
  • Example#3980 - Ejemplo de SplFileObject::READ_CSV
  • Example#3981 - Ejemplo de SplFileObject::fgets
  • Example#3982 - Ejemplo de SplFileObject::fgetss
  • Example#3983 - Ejemplo de SplFileObject::flock
  • Example#3984 - Ejemplo de SplFileObject::fpassthru
  • Example#3985 - Ejemplo de SplFileObject::fputcsv
  • Example#3986 - Ejemplo de SplFileObject::fread
  • Example#3987 - Ejemplo de SplFileObject::fscanf
  • Example#3988 - Ejemplo de SplFileObject::fseek
  • Example#3989 - Ejemplo de SplFileObject::fstat
  • Example#3990 - Ejemplo de SplFileObject::ftell
  • Example#3991 - Ejemplo de SplFileObject::ftruncate
  • Example#3992 - Ejemplo de SplFileObject::fwrite
  • Example#3993 - Ejemplo de SplFileObject::getCsvControl
  • Example#3994 - Ejemplo de SplFileObject::getFlags
  • Example#3995 - Ejemplo de SplFileObject::getMaxLineLen
  • Example#3996 - Ejemplo de SplFileObject::key
  • Example#3997 - SplFileObject::key ejemplo con SplFileObject::setMaxLineLen
  • Example#3998 - Ejemplo de SplFileObject::next
  • Example#3999 - Ejemplo de SplFileObject::rewind
  • Example#4000 - Ejemplo de SplFileObject::seek
  • Example#4001 - Ejemplo de SplFileObject::setCsvControl
  • Example#4002 - Ejemplo de SplFileObject::setFlags
  • Example#4003 - Ejemplo de SplFileObject::setMaxLineLen
  • Example#4004 - Ejemplo de SplFileObject::valid
  • Example#4005 - Ejemplo de SplTempFileObject
  • Example#4006 - Ejemplo de ArrayObject::append
  • Example#4007 - ArrayObject::asort example
  • Example#4008 - Ejemplo de ArrayObject::__construct
  • Example#4009 - Ejemplo de ArrayObject::count
  • Example#4010 - ArrayObject::exchangeArray example
  • Example#4011 - ArrayObject::getArrayCopy example
  • Example#4012 - Ejemplo de ArrayObject::getFlags
  • Example#4013 - Ejemplo de ArrayObject::getIterator
  • Example#4014 - ArrayObject::getIteratorClass example
  • Example#4015 - Ejemplo de ArrayObject::ksort
  • Example#4016 - Ejemplo de ArrayObject::natcasesort
  • Example#4017 - Ejemplo de ArrayObject::natsort
  • Example#4018 - Ejemplo de ArrayObject::offsetExists
  • Example#4019 - Ejemplo de ArrayObject::offsetGet
  • Example#4020 - Ejemplo de ArrayObject::offsetSet
  • Example#4021 - Ejemplo de ArrayObject::offsetUnset
  • Example#4022 - Ejemplo de ArrayObject::serialize
  • Example#4023 - Ejemplo de ArrayObject::setFlags
  • Example#4024 - Ejemplo de ArrayObject::setIteratorClass
  • Example#4025 - Ejemplo de ArrayObject::uasort
  • Example#4026 - Ejemplo de ArrayObject::uksort
  • Example#4027 - Usar file_get_contents para recuperar información desde múltiples fuentes
  • Example#4028 - Hacer una petición POST a un servidor https
  • Example#4029 - Escribir información en un archivo compirmido
  • Example#4030 - Un Flujo para leer/escribir variables globales
  • Example#4031 - Listar los ficheros de archivos tar
  • Example#4032 - Ejemplos de stream_bucket_prepend
  • Example#4033 - Usar stream_context_create
  • Example#4034 - Usar stream_context_get_default
  • Example#4035 - Ejemplo de stream_context_get_options
  • Example#4036 - Ejemplo de stream_context_get_params
  • Example#4037 - Ejemplo de stream_context_set_default
  • Example#4038 - Un ejemplo de stream_copy_to_stream
  • Example#4039 - Controlar dónde son aplicados los filtros
  • Example#4040 - Filtro para poner en mayúsculas caracteres en el flujo foo-bar.txt
  • Example#4041 - Registrar una clase de filtro genérica para comparar múltiples nombres de filtro.
  • Example#4042 - Refiltrar dináminamente un flujo
  • Example#4043 - Ejemplo de stream_get_contents
  • Example#4044 - Usar stream_get_filters
  • Example#4045 - Ejemplo de stream_get_meta_data
  • Example#4046 - Usar stream_get_transports
  • Example#4047 - Ejemplo de stream_get_wrappers
  • Example#4048 - Comprobar la existencia de una envoltura de flujo
  • Example#4049 - Ejemplo de stream_is_local
  • Example#4050 - stream_isatty example
  • Example#4051 - Ejemplo de stream_notification_callback
  • Example#4052 - Barra de progreso sencilla para la descarga por parte del cliente por línea de comandos
  • Example#4053 - Ejemplo de stream_resolve_include_path
  • Example#4054 - Ejemplo de stream_select
  • Example#4055 - Ejemplo de stream_set_timeout
  • Example#4056 - Ejemplo de stream_set_write_buffer
  • Example#4057 - Ejemplo de stream_socket_client
  • Example#4058 - Usar una conexión UDP
  • Example#4059 - Ejemplo de stream_socket_enable_crypto
  • Example#4060 - Un ejemplo de stream_socket_pair
  • Example#4061 - Ejemplo de stream_socket_recvfrom
  • Example#4062 - Ejemplo de stream_socket_sendto
  • Example#4063 - Usar sockets de servidor de TCP
  • Example#4064 - Usar sockets de servidor de UDP
  • Example#4065 - Un ejemplo de stream_socket_shutdown
  • Example#4066 - Cómo registrar una envoltura de flujo
  • Example#4067 - Uso Básico Tidy
  • Example#4068 - Ejemplo de tidy::getBody
  • Example#4069 - Ejemplo de tidy::cleanrepair
  • Example#4070 - Ejemplo de tidy::__construct
  • Example#4071 - Ejemplo de tidy::diagnose
  • Example#4072 - Ejemplo de tidy_get_error_buffer
  • Example#4073 - Ejemplo de tidy::getConfig
  • Example#4074 - Ejemplo de tidy_getopt
  • Example#4075 - Imprimir todas las opciones, junto con su documentación y sus valores por omisión
  • Example#4076 - Ejemplo de tidy::getStatus
  • Example#4077 - Ejemplo de tidy::head
  • Example#4078 - Ejemplo de tidy::html
  • Example#4079 - Ejemplo de tidy::parseFile
  • Example#4080 - Ejemplo de tidy::parseString
  • Example#4081 - Ejemplo de tidy::repairFile
  • Example#4082 - Ejemplo de tidy::repairString
  • Example#4083 - tidy::root ejemplo
  • Example#4084 - Ejemplo de tidyNode::hasChildren
  • Example#4085 - Ejemplo de tidyNode::hasChildren
  • Example#4086 - Ejemplo de tidyNode::hasSiblings
  • Example#4087 - Extraer el código ASP embebido en un documento HTML
  • Example#4088 - Extraer los comentarios de un documento HTML
  • Example#4089 - Extraer el código HTML de un documento HTML
  • Example#4090 - Extrer el código JSTE de un documento HTML
  • Example#4091 - Extraer el código PHP embebido en un documento HTML
  • Example#4092 - Extraer el texto de un documento HTML
  • Example#4093 - Ejemplo de ob_tidyhandler
  • Example#4094 - Ejemplo de la función tidy_access_count
  • Example#4095 - Ejemplo de la función tidy_config_count
  • Example#4096 - Ejemplo de la función tidy_error_count
  • Example#4097 - Ejemplo de la función tidy_get_output
  • Example#4098 - Ejemplo de la función tidy_warning_count
  • Example#4099 - Quitar comentarios con el tokenizer
  • Example#4100 - token_get_all ejemplos
  • Example#4101 - token_name ejemplo
  • Example#4102 - Ejemplo de base64_decode
  • Example#4103 - Ejemplo de base64_encode
  • Example#4104 - Ejemplo de get_headers
  • Example#4105 - get_headers using HEAD example
  • Example#4106 - Lo que procesa get_meta_tags
  • Example#4107 - Lo que devuelve get_meta_tags
  • Example#4108 - Uso simple de http_build_query
  • Example#4109 - http_build_query con elementos indexados numéricamente.
  • Example#4110 - con arrays complejos http_build_query
  • Example#4111 - Uso de http_build_query con un objeto
  • Example#4112 - Un ejemplo de parse_url
  • Example#4113 - Un ejemplo de parse_url con el esquema ausente
  • Example#4114 - Ejemplo de rawurldecode
  • Example#4115 - Inclusión de una contraseña en una URL FTP
  • Example#4116 - Ejemplo 2 de rawurlencode
  • Example#4117 - Ejemplo de urldecode
  • Example#4118 - Ejemplo de urlencode
  • Example#4119 - Ejemplo de urlencode y ejemplo de htmlentities
  • Example#4120 - Básica ejecución Javascript
  • Example#4121 - Yaml Example
  • Example#4122 - Ejemplo de análisis de callback
  • Example#4123 - Ejemplo de emisión de callback
  • Example#4124 - Ejemplo de yaml_emit
  • Example#4125 - Ejemplo de yaml_parse
  • Example#4126 - Distribución clásica del directorio Application
  • Example#4127 - Entrada
  • Example#4128 - Regla de sobrescritura
  • Example#4129 - Configuración de la aplicación
  • Example#4130 - Controlador predeterminado
  • Example#4131 - Plantilla de vistas predeterminada
  • Example#4132 - Ejecutar la aplicación
  • Example#4133 - Un ejemplo de array de PHP
  • Example#4134 - Un ejemplo de un fichero ini
  • Example#4135 - Un ejemplo de A Bootstrap
  • Example#4136 - Ejemplo de Yaf_Application::bootstrap
  • Example#4137 - Ejemplo de Yaf_Application::clearLastError
  • Example#4138 - A ini config file example
  • Example#4139 - Ejemplo de Yaf_Application::__construct
  • Example#4140 - Ejemplo de Yaf_Application::__construct
  • Example#4141 - Ejemplo de Yaf_Application::environ
  • Example#4142 - Ejemplo de Yaf_Application::execute
  • Example#4143 - Ejemplo de Yaf_Application::getConfig
  • Example#4144 - Ejemplo de Yaf_Application::getDispatcher
  • Example#4145 - Ejemplo de Yaf_Application::getLastErrorMsg
  • Example#4146 - Ejemplo de Yaf_Application::getLastErrorNo
  • Example#4147 - Ejemplo de Yaf_Application::getModules
  • Example#4148 - Ejemplo de arranque
  • Example#4149 - Ejemplo de Yaf_Dispatcher::autoRender
  • Example#4150 - Ejemplo de Yaf_Dispatcher::catchException
  • Example#4151 - Yaf_Dispatcher::registerPluginexample
  • Example#4152 - Ejemplo de un motor de Vistas personalizado
  • Example#4153 - Ejemplo de Yaf_Dispatcher::setView
  • Example#4154 - Ejemplo de Yaf_Dispatcher::throwexception
  • Example#4155 - Ejemplo de Yaf_Dispatcher::throwexception
  • Example#4156 - Ejemplo de Yaf_Config_Ini
  • Example#4157 - Definir una acción en un fichero aparte
  • Example#4158 - Dummy_action.php
  • Example#4159 - Ejemplo de Yaf_Controller_Abstract::forward
  • Example#4160 - Ejemplo de Yaf_Action_Abstract::execute
  • Example#4161 - Ejemplo de Yaf_Action_Abstract::execute
  • Example#4162 - Ejemplo de Yaf_View_Simple::assign
  • Example#4163 - Ejemplo de template
  • Example#4164 - Ejemplo de Yaf_View_Simple::assignRef
  • Example#4165 - Ejemplo de template
  • Example#4166 - Ejemplo de Yaf_View_Simple::clear
  • Example#4167 - Ejemplo de Yaf_View_Simple::__constructor
  • Example#4168 - Ejemplo de Yaf_View_Simple::__set
  • Example#4169 - Ejemplo de configuración
  • Example#4170 - Registrar el espacio de nombres local
  • Example#4171 - Load class example
  • Example#4172 - Ejemplo de carga de una clase en el espacio de nombres
  • Example#4173 - Ejemplo de carga de clase MVC
  • Example#4174 - Distinciones de clases MVC
  • Example#4175 - Ejemplo de carga MVC
  • Example#4176 - Ejemplo de Yaf_Loader::registerNamespace
  • Example#4177 - Ejemplo de Yaf_Loader::registerLocalNamespace
  • Example#4178 - Ejemplo de Yaf_Loader::registerNamespace
  • Example#4179 - Plugin example
  • Example#4180 - Ejemplo de Yaf_Plugin_Abstract::routerShutdown
  • Example#4181 - Ejemplo de Yaf_Response_Abstract::appendBody
  • Example#4182 - Ejemplo de Yaf_Response_Abstract::getBody
  • Example#4183 - Ejemplo de Yaf_Response_Abstract::prependBody
  • Example#4184 - Ejemplo de Yaf_Response_Abstract::response
  • Example#4185 - Ejemplo de Yaf_Response_Abstract::setBody
  • Example#4186 - Ejemplo de Yaf_Route_Map::assemble
  • Example#4187 - Ejemplo de Yaf_Route_Map
  • Example#4188 - Ejemplo de Yaf_Route_Map
  • Example#4189 - Yaf_Route_Mapexample
  • Example#4190 - Ejemplo de Yaf_Route_Regex::assemble
  • Example#4191 - Ejemplo de Yaf_Route_Regex
  • Example#4192 - Ejemplo de Yaf_Route_Regex(como en 2.3.0)
  • Example#4193 - Ejemplo de Yaf_Route_Regex y el nombre de la zona de captura (a partir de 2.3.0)
  • Example#4194 - Ejemplo de Yaf_Route_Regex
  • Example#4195 - Ejemplo de Yaf_Route_Rewrite::assemble
  • Example#4196 - Ejemplo de Yaf_Route_Rewrite
  • Example#4197 - Ejemplo de Yaf_Route_Rewrite
  • Example#4198 - Ejemplo de Yaf_Route_Rewrite (como en 2.3.0)
  • Example#4199 - Regla de reescritura para Apache
  • Example#4200 - Regla de reescritura para Apache
  • Example#4201 - Regla de reescritura para Lighttpd
  • Example#4202 - Regla de reescritura para Nginx
  • Example#4203 - Ejemplo de Yaf_Route_Static (ruta predeterminada)
  • Example#4204 - Ejemplo de application.ini
  • Example#4205 - Ejemplo de Yaf_Dispatcher::autoConfig
  • Example#4206 - Ejemplo de Yaf_Dispatcher::autoRender
  • Example#4207 - Registrar algunas rutas en el Arranque
  • Example#4208 - Complemento Dummy.php (bajo application.directory/plugins)
  • Example#4209 - Ejemplo de Yaf_Route_Simple::assemble
  • Example#4210 - Ejemplo de Yaf_Route_Simple::route
  • Example#4211 - Ejemplo de Yaf_Route_Simple::route
  • Example#4212 - Ejemplo de Yaf_Route_Static::assemble
  • Example#4213 - Ejemplo de Yaf_Route_Static::route
  • Example#4214 - Ejemplo de Yaf_Route_Supervar::assemble
  • Example#4215 - Ejemplo de Yaf_Route_Supervar
  • Example#4216 - INI example
  • Example#4217 - Ejemplo de secciones INI
  • Example#4218 - Ejemplo de INI
  • Example#4219 - Ejemplo de taint
  • Example#4220 - Vector
  • Example#4221 - Map
  • Example#4222 - Ds\Collection::clear example
  • Example#4223 - Ds\Collection::copy example
  • Example#4224 - Ds\Collection::isEmpty example
  • Example#4225 - Ds\Collection::toArray example
  • Example#4226 - Ds\Hashable::hash example
  • Example#4227 - Ds\Sequence::allocate example
  • Example#4228 - Ds\Sequence::apply example
  • Example#4229 - Ds\Sequence::capacity example
  • Example#4230 - Ds\Sequence::contains example
  • Example#4231 - Ds\Sequence::filter example using callback function
  • Example#4232 - Ds\Sequence::filter example without a callback function
  • Example#4233 - Ds\Sequence::find example
  • Example#4234 - Ds\Sequence::first example
  • Example#4235 - Ds\Sequence::get example
  • Example#4236 - Ds\Sequence::get example using array syntax
  • Example#4237 - Ds\Sequence::insert example
  • Example#4238 - Ds\Sequence::join example using a separator string
  • Example#4239 - Ds\Sequence::join example without a separator string
  • Example#4240 - Ds\Sequence::last example
  • Example#4241 - Ds\Sequence::map example
  • Example#4242 - Ds\Sequence::merge example
  • Example#4243 - Ds\Sequence::pop example
  • Example#4244 - Ds\Sequence::push example
  • Example#4245 - Ds\Sequence::reduce with initial value example
  • Example#4246 - Ds\Sequence::reduce without an initial value example
  • Example#4247 - Ds\Sequence::remove example
  • Example#4248 - Ds\Sequence::reverse example
  • Example#4249 - Ds\Sequence::reversed example
  • Example#4250 - Ds\Sequence::rotate example
  • Example#4251 - Ds\Sequence::set example
  • Example#4252 - Ds\Sequence::set example using array syntax
  • Example#4253 - Ds\Sequence::shift example
  • Example#4254 - Ds\Sequence::slice example
  • Example#4255 - Ds\Sequence::sort example
  • Example#4256 - Ds\Sequence::sort example using a comparator
  • Example#4257 - Ds\Sequence::sorted example
  • Example#4258 - Ds\Sequence::sorted example using a comparator
  • Example#4259 - Ds\Sequence::sum integer example
  • Example#4260 - Ds\Sequence::sum float example
  • Example#4261 - Ds\Sequence::unshift example
  • Example#4262 - Ds\Vector::allocate example
  • Example#4263 - Ds\Vector::apply example
  • Example#4264 - Ds\Vector::capacity example
  • Example#4265 - Ds\Vector::clear example
  • Example#4266 - Ds\Vector::__construct example
  • Example#4267 - Ds\Vector::contains example
  • Example#4268 - Ds\Vector::copy example
  • Example#4269 - Ds\Vector::filter example using callback function
  • Example#4270 - Ds\Vector::filter example without a callback function
  • Example#4271 - Ds\Vector::find example
  • Example#4272 - Ds\Vector::first example
  • Example#4273 - Ds\Vector::get example
  • Example#4274 - Ds\Vector::get example using array syntax
  • Example#4275 - Ds\Vector::insert example
  • Example#4276 - Ds\Vector::isEmpty example
  • Example#4277 - Ds\Vector::join example using a separator string
  • Example#4278 - Ds\Vector::join example without a separator string
  • Example#4279 - Ds\Vector::last example
  • Example#4280 - Ds\Vector::map example
  • Example#4281 - Ds\Vector::merge example
  • Example#4282 - Ds\Vector::pop example
  • Example#4283 - Ds\Vector::push example
  • Example#4284 - Ds\Vector::reduce with initial value example
  • Example#4285 - Ds\Vector::reduce without an initial value example
  • Example#4286 - Ds\Vector::remove example
  • Example#4287 - Ds\Vector::reverse example
  • Example#4288 - Ds\Vector::reversed example
  • Example#4289 - Ds\Vector::rotate example
  • Example#4290 - Ds\Vector::set example
  • Example#4291 - Ds\Vector::set example using array syntax
  • Example#4292 - Ds\Vector::shift example
  • Example#4293 - Ds\Vector::slice example
  • Example#4294 - Ds\Vector::sort example
  • Example#4295 - Ds\Vector::sort example using a comparator
  • Example#4296 - Ds\Vector::sorted example
  • Example#4297 - Ds\Vector::sorted example using a comparator
  • Example#4298 - Ds\Vector::sum integer example
  • Example#4299 - Ds\Vector::sum float example
  • Example#4300 - Ds\Vector::toArray example
  • Example#4301 - Ds\Vector::unshift example
  • Example#4302 - Ds\Deque::allocate example
  • Example#4303 - Ds\Deque::apply example
  • Example#4304 - Ds\Deque::capacity example
  • Example#4305 - Ds\Deque::clear example
  • Example#4306 - Ds\Deque::__construct example
  • Example#4307 - Ds\Deque::contains example
  • Example#4308 - Ds\Deque::copy example
  • Example#4309 - Ds\Deque::filter example using callback function
  • Example#4310 - Ds\Deque::filter example without a callback function
  • Example#4311 - Ds\Deque::find example
  • Example#4312 - Ds\Deque::first example
  • Example#4313 - Ds\Deque::get example
  • Example#4314 - Ds\Deque::get example using array syntax
  • Example#4315 - Ds\Deque::insert example
  • Example#4316 - Ds\Deque::isEmpty example
  • Example#4317 - Ds\Deque::join example using a separator string
  • Example#4318 - Ds\Deque::join example without a separator string
  • Example#4319 - Ds\Deque::last example
  • Example#4320 - Ds\Deque::map example
  • Example#4321 - Ds\Deque::merge example
  • Example#4322 - Ds\Deque::pop example
  • Example#4323 - Ds\Deque::push example
  • Example#4324 - Ds\Deque::reduce with initial value example
  • Example#4325 - Ds\Deque::reduce without an initial value example
  • Example#4326 - Ds\Deque::remove example
  • Example#4327 - Ds\Deque::reverse example
  • Example#4328 - Ds\Deque::reversed example
  • Example#4329 - Ds\Deque::rotate example
  • Example#4330 - Ds\Deque::set example
  • Example#4331 - Ds\Deque::set example using array syntax
  • Example#4332 - Ds\Deque::shift example
  • Example#4333 - Ds\Deque::slice example
  • Example#4334 - Ds\Deque::sort example
  • Example#4335 - Ds\Deque::sort example using a comparator
  • Example#4336 - Ds\Deque::sorted example
  • Example#4337 - Ds\Deque::sorted example using a comparator
  • Example#4338 - Ds\Deque::sum integer example
  • Example#4339 - Ds\Deque::sum float example
  • Example#4340 - Ds\Deque::toArray example
  • Example#4341 - Ds\Deque::unshift example
  • Example#4342 - Ds\Map::allocate example
  • Example#4343 - Ds\Map::apply example
  • Example#4344 - Ds\Map::capacity example
  • Example#4345 - Ds\Map::clear example
  • Example#4346 - Ds\Map::__construct example
  • Example#4347 - Ds\Map::copy example
  • Example#4348 - Ds\Map::diff example
  • Example#4349 - Ds\Map::filter example using callback function
  • Example#4350 - Ds\Map::filter example without a callback function
  • Example#4351 - Ds\Map::first example
  • Example#4352 - Ds\Map::get example
  • Example#4353 - Ds\Map::get example using array syntax
  • Example#4354 - Ds\Map::hasKey example
  • Example#4355 - Ds\Map::hasValue example
  • Example#4356 - Ds\Map::intersect example
  • Example#4357 - Ds\Map::isEmpty example
  • Example#4358 - Ds\Map::keys example
  • Example#4359 - Ds\Map::ksort example
  • Example#4360 - Ds\Map::ksort example using a comparator
  • Example#4361 - Ds\Map::ksorted example
  • Example#4362 - Ds\Map::ksorted example using a comparator
  • Example#4363 - Ds\Map::last example
  • Example#4364 - Ds\Map::map example
  • Example#4365 - Ds\Map::merge example
  • Example#4366 - Ds\Map::pairs example
  • Example#4367 - Ds\Map::put example
  • Example#4368 - Ds\Map::put example using objects as keys
  • Example#4369 - Ds\Map::putAll example
  • Example#4370 - Ds\Map::reduce with initial value example
  • Example#4371 - Ds\Map::reduce without an initial value example
  • Example#4372 - Ds\Map::remove example
  • Example#4373 - Ds\Map::reverse example
  • Example#4374 - Ds\Map::reversed example
  • Example#4375 - Ds\Map::skip example
  • Example#4376 - Ds\Map::slice example
  • Example#4377 - Ds\Map::sort example
  • Example#4378 - Ds\Map::sort example using a comparator
  • Example#4379 - Ds\Map::sort example
  • Example#4380 - Ds\Map::sort example using a comparator
  • Example#4381 - Ds\Map::sum integer example
  • Example#4382 - Ds\Map::sum float example
  • Example#4383 - Ds\Map::toArray example
  • Example#4384 - Ds\Map::union example
  • Example#4385 - Ds\Map::values example
  • Example#4386 - Ds\Map::xor example
  • Example#4387 - Ds\Pair::clear example
  • Example#4388 - Ds\Pair::copy example
  • Example#4389 - Ds\Pair::isEmpty example
  • Example#4390 - Ds\Pair::toArray example
  • Example#4391 - Ds\Set::add example using integers
  • Example#4392 - Ds\Set::add example using objects
  • Example#4393 - Ds\Set::allocate example
  • Example#4394 - Ds\Set::capacity example
  • Example#4395 - Ds\Set::clear example
  • Example#4396 - Ds\Set::__construct example
  • Example#4397 - Ds\Set::contains example
  • Example#4398 - Ds\Set::copy example
  • Example#4399 - Ds\Set::diff example
  • Example#4400 - Ds\Set::filter example using callback function
  • Example#4401 - Ds\Set::filter example without a callback function
  • Example#4402 - Ds\Set::first example
  • Example#4403 - Ds\Set::get example
  • Example#4404 - Ds\Set::get example using array syntax
  • Example#4405 - Ds\Set::intersect example
  • Example#4406 - Ds\Set::isEmpty example
  • Example#4407 - Ds\Set::join example using a separator string
  • Example#4408 - Ds\Set::join example without a separator string
  • Example#4409 - Ds\Set::last example
  • Example#4410 - Ds\Set::merge example
  • Example#4411 - Ds\Set::reduce with initial value example
  • Example#4412 - Ds\Set::reduce without an initial value example
  • Example#4413 - Ds\Set::remove example
  • Example#4414 - Ds\Set::reverse example
  • Example#4415 - Ds\Set::reversed example
  • Example#4416 - Ds\Set::slice example
  • Example#4417 - Ds\Set::sort example
  • Example#4418 - Ds\Set::sort example using a comparator
  • Example#4419 - Ds\Set::sorted example
  • Example#4420 - Ds\Set::sorted example using a comparator
  • Example#4421 - Ds\Set::sum integer example
  • Example#4422 - Ds\Set::sum float example
  • Example#4423 - Ds\Set::toArray example
  • Example#4424 - Ds\Set::union example
  • Example#4425 - Ds\Set::xor example
  • Example#4426 - Ds\Stack::clear example
  • Example#4427 - Ds\Stack::__construct example
  • Example#4428 - Ds\Stack::copy example
  • Example#4429 - Ds\Stack::isEmpty example
  • Example#4430 - Ds\Stack::peek example
  • Example#4431 - Ds\Stack::pop example
  • Example#4432 - Ds\Stack::push example
  • Example#4433 - Ds\Stack::toArray example
  • Example#4434 - Ds\Queue::allocate example
  • Example#4435 - Ds\Queue::capacity example
  • Example#4436 - Ds\Queue::clear example
  • Example#4437 - Ds\Queue::__construct example
  • Example#4438 - Ds\Queue::copy example
  • Example#4439 - Ds\Queue::isEmpty example
  • Example#4440 - Ds\Queue::peek example
  • Example#4441 - Ds\Queue::pop example
  • Example#4442 - Ejemplo de Ds\Queue::push
  • Example#4443 - Ejemplo de Ds\Queue::toArray
  • Example#4444 - Ds\PriorityQueue::allocate example
  • Example#4445 - Ds\PriorityQueue::capacity example
  • Example#4446 - Ds\PriorityQueue::clear example
  • Example#4447 - Ds\PriorityQueue::__construct example
  • Example#4448 - Ds\PriorityQueue::copy example
  • Example#4449 - Ds\PriorityQueue::isEmpty example
  • Example#4450 - Ds\PriorityQueue::peek example
  • Example#4451 - Ds\PriorityQueue::pop example
  • Example#4452 - Ds\PriorityQueue::push example
  • Example#4453 - Ds\PriorityQueue::toArray example
  • Example#4454 - Uso del módulo cURL de PHP para capturar página principal de example.com
  • Example#4455 - Inicializar una nueva sesión CURL y capturar una página web
  • Example#4456 - Copiar un recurso cURL
  • Example#4457 - curl_errno ejemplo
  • Example#4458 - Ejemplo de curl_error
  • Example#4459 - Ejemplo con curl_escape
  • Example#4460 - Capturar una página web
  • Example#4461 - Ejemplo de curl_getinfo
  • Example#4462 - Ejemplo de curl_getinfo con el parámetro opt
  • Example#4463 - Inicia una nueva sesión cURL y captura una página web
  • Example#4464 - curl_multi_add_handle example
  • Example#4465 - curl_multi_close example
  • Example#4466 - curl_multi_exec example
  • Example#4467 - Un ejemplo de curl_multi_info_read
  • Example#4468 - curl_multi_init example
  • Example#4469 - Ejemplo con curl_multi_strerror
  • Example#4470 - Ejemplo con curl_reset
  • Example#4471 - Iniciando una nueva sesión cURL y capturando una página web
  • Example#4472 - O nuestra implementación de curl_setopt_array
  • Example#4473 - Inicializar una nueva sesión de cURL y obtener una página web
  • Example#4474 - Subir un fichero (obsoleto a partir de PHP 5.5.0)
  • Example#4475 - Ejemplo con curl_share_setopt
  • Example#4476 - Ejemplo con curl_share_init
  • Example#4477 - Ejemplo de curl_share_setopt
  • Example#4478 - Ejemplo de curl_errno
  • Example#4479 - Ejemplo de curl_escape
  • Example#4480 - ejemplo de curl_version
  • Example#4481 - Ejemplo con CURLFile::__construct
  • Example#4482 - Simple HTTP client
  • Example#4483 - HTTP client using asynchronous DNS resolver
  • Example#4484 - Echo server
  • Example#4485 - SSL echo server
  • Example#4486 - Signal handler
  • Example#4487 - Use libevent's loop to process requests of `eio' extension
  • Example#4488 - Miscellaneous
  • Example#4489 - Simple HTTP server
  • Example#4490 - Simple HTTPS server
  • Example#4491 - OpenSSL connection
  • Example#4492 - EventHttpConnection::makeRequest example
  • Example#4493 - Connection listener based on a UNIX domain socket
  • Example#4494 - Simple SMTP server
  • Example#4495 - Handling SIGTERM signal
  • Example#4496 - Event::addSignal example
  • Example#4497 - Event::addTimer example
  • Example#4498 - Ejemplo con EventBase::getFeatures
  • Example#4499 - Ejemplo con EventBase::getMethod
  • Example#4500 - EventBuffer::search example
  • Example#4501 - EventBufferEvent::connect example
  • Example#4502 - Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console
  • Example#4503 - EventBufferEvent::connectHost example
  • Example#4504 - Buffer event's read callback
  • Example#4505 - EventBufferEvent::getOutput example
  • Example#4506 - EventBufferEvent::sslError example
  • Example#4507 - Simple SMTP server
  • Example#4508 - EventConfig::avoidMethod example
  • Example#4509 - EventConfig::__construct example
  • Example#4510 - EventConfig::requireFeatures example
  • Example#4511 - EventHttp::accept example
  • Example#4512 - EventHttp::addServerAlias example
  • Example#4513 - EventHttp::bind example
  • Example#4514 - Simple HTTP server
  • Example#4515 - EventHttp::setCallback example
  • Example#4516 - EventHttp::setDefaultCallback example
  • Example#4517 - EventHttpConnection::makeRequest example
  • Example#4518 - EventHttpConnection::setCloseCallback example
  • Example#4519 - EventHttpRequest::__construct example
  • Example#4520 - EventHttpRequest::sendError example
  • Example#4521 - EventListener::__construct example
  • Example#4522 - EventSslContext::__construct example
  • Example#4523 - Ejemplo FTP
  • Example#4524 - Ejemplo de ftp_alloc
  • Example#4525 - Ejemplo de ftp_cdup
  • Example#4526 - Ejemplo de ftp_chdir
  • Example#4527 - Ejemplo de ftp_chmod
  • Example#4528 - Ejemplo de ftp_close
  • Example#4529 - Ejemplo de ftp_connect
  • Example#4530 - Ejemplo de ftp_delete
  • Example#4531 - Ejemplo de ftp_exec
  • Example#4532 - Ejemplo de ftp_fget
  • Example#4533 - Ejemplo de ftp_fput
  • Example#4534 - Ejemplo de ftp_get_option
  • Example#4535 - Ejemplo de ftp_get
  • Example#4536 - Ejemplo de ftp_login
  • Example#4537 - Ejemplo de ftp_mdtm
  • Example#4538 - Ejemplo de ftp_mkdir
  • Example#4539 - ftp_mlsd example
  • Example#4540 - Ejemplo de ftp_nb_continue
  • Example#4541 - Ejemplo de ftp_nb_fget
  • Example#4542 - Ejemplo de ftp_nb_fput
  • Example#4543 - Ejemplo de ftp_nb_get
  • Example#4544 - Reanudar una descarga con ftp_nb_get
  • Example#4545 - Reanudar una descarga en la posición 100 a un nuevo archivo con ftp_nb_get
  • Example#4546 - Ejemplo de ftp_nb_put
  • Example#4547 - Reanudación de un proceso de carga con ftp_nb_put
  • Example#4548 - Ejemplo de ftp_nlist
  • Example#4549 - Ejemplo de ftp_pasv
  • Example#4550 - Ejemplo de ftp_put
  • Example#4551 - Ejemplo de ftp_pwd
  • Example#4552 - Uso de ftp_raw para iniciar sesión en un servidor FTP de forma manual.
  • Example#4553 - Ejemplo de ftp_rawlist
  • Example#4554 - Ejemplo de ftp_rename
  • Example#4555 - Ejemplo de ftp_rmdir
  • Example#4556 - Ejemplo de ftp_set_option
  • Example#4557 - Envío de un comando SITE a un servidor FTP
  • Example#4558 - Ejemplo de ftp_size
  • Example#4559 - Ejemplo de ftp_ssl_connect
  • Example#4560 - Ejemplo de ftp_systype
  • Example#4561 - Cliente y trabajador básicos en Gearman
  • Example#4562 - Cliente y trabajador básicos en Gearman, trabajo en segundo plano
  • Example#4563 - Cliente y trabajador básicos, enviando tareas
  • Example#4564 - Añadir dos servidores de trabajos
  • Example#4565 - Añade dos servidores de trabajos
  • Example#4566 - Envío básico de dos tareas
  • Example#4567 - Envío básico de dos tareas pasando contexto de la aplicación
  • Example#4568 - Dos tareas, una en segundo plano y la otra no
  • Example#4569 - Una tarea de prioridad alta junto con dos tareas de prioridad normal
  • Example#4570 - Una tarea de baja prioridad junto con dos tareas de prioridad normal
  • Example#4571 - Monitor para el estado de finalización de múltiples tareas en segundo plano
  • Example#4572 - Envío de un trabajo con retorno inmediato
  • Example#4573 - Envío de un trabajo y obtención del estado incremental
  • Example#4574 - Envío y monitorización de un trabajo en segundo plano
  • Example#4575 - Envío de un trabajo sencillo con retorno inmediato
  • Example#4576 - Enviar un trabajo y recuperar el estado incremental
  • Example#4577 - Obtiene el estado de un trabajo en ejecución de larga duración
  • Example#4578 - Monitorización del estado de un trabajo ejecutandose en segundo plano
  • Example#4579 - Sencillo trabajador que usa los datos de contexto de aplicación
  • Example#4580 - Añade servidores Gearman alternativos
  • Example#4581 - Añade dos servidores de trabajo
  • Example#4582 - Ejemplo de GearmanWorker::setId
  • Example#4583 - Un trabajador sencillo con un tiempo de espera de 5 segundos
  • Example#4584 - Running worker in non-blocking mode
  • Example#4585 - GearmanWorker::work example
  • Example#4586 - Testing support for paged result control
  • Example#4587 - Ejemplo de búsqueda LDAP
  • Example#4588 - Ejemplo completo con enlace autenticado
  • Example#4589 - Ejemplo de autenticación
  • Example#4590 - Ejemplo de autenticación anónima
  • Example#4591 - Ejemplo completo de revisión de contraseña
  • Example#4592 - Ejemplo de conexión a un servidor LDAP.
  • Example#4593 - Ejemplo de conexión segura a un servidor LDAP.
  • Example#4594 - Paginación LDAP
  • Example#4595 - Paginación LDAP
  • Example#4596 - Ejemplo de ldap-count-entries
  • Example#4597 - Enumerando todos los mensajes de error de LDAP
  • Example#4598 - Generación y captura de un error
  • Example#4599 - PASSWD extended operation
  • Example#4600 - Whoami extended operation
  • Example#4601 - Mostrar la lista de atributos mantenida por una entrada de directorio en particular
  • Example#4602 - Revisar la versión del protocolo
  • Example#4603 - Listar todos los valores del atributo "correo" para una entrada de directorio
  • Example#4604 - Producir una lista de todas las unidades organizacionales de una organización
  • Example#4605 - Add a telephone number to a contact
  • Example#4606 - Rename a user
  • Example#4607 - Add two e-mail addresses to a user
  • Example#4608 - Change a user's password
  • Example#4609 - Change a user's password (Active Directory)
  • Example#4610 - Ejemplo de ldap_parse_result
  • Example#4611 - Búsqueda LDAP
  • Example#4612 - Establecer la versión del protocolo
  • Example#4613 - Establecer controles del servidor
  • Example#4614 - Clasificador de LDAP
  • Example#4615 - Ejemplos de la extensión memcache extension
  • Example#4616 - Usando el gestor de sesiones de memcache
  • Example#4617 - Ejemplo Memcache::add
  • Example#4618 - Ejemplo Memcache::addServer
  • Example#4619 - Ejemplo Memcache::close
  • Example#4620 - Memcache::connect example
  • Example#4621 - Ejemplo Memcache::decrement
  • Example#4622 - Ejemplo de Memcache::delete
  • Example#4623 - Ejemplo de Memcache::flush
  • Example#4624 - Ejemplo de Memcache::get
  • Example#4625 - Ejemplo de Memcache::getExtendedStats
  • Example#4626 - Ejemplo de Memcache::getServerStatus
  • Example#4627 - Ejemplo de Memcache::getVersion
  • Example#4628 - Ejemplo de Memcache::increment
  • Example#4629 - Ejemplo de Memcache::pconnect
  • Example#4630 - Ejemplo de Memcache::replace
  • Example#4631 - Ejemplo de Memcache::set
  • Example#4632 - Ejemplo de Memcache::set
  • Example#4633 - Ejemplo de Memcache::setCompressThreshold
  • Example#4634 - Ejemplo de Memcache::setServerParams
  • Example#4635 - Ejemplo retrollamada de resultados
  • Example#4636 - Ejemplo de lectura de retrollamada
  • Example#4637 - Ejemplo de Memcached::addServer
  • Example#4638 - Ejemplo de Memcached::addServers
  • Example#4639 - Ejemplo de Memcached::append
  • Example#4640 - Ejemplo de Memcached::cas
  • Example#4641 - Crear un objeto Memcached
  • Example#4642 - Ejemplo de Memcached::decrement
  • Example#4643 - Ejemplo de Memcached::delete
  • Example#4644 - Ejemplo de Memcached::fetch
  • Example#4645 - Ejemplo de Memcached::getDelayed
  • Example#4646 - Ejemplo de Memcached::flush
  • Example#4647 - Ejemplo 1 Memcached::get
  • Example#4648 - Otro ejemplo de Memcached::get
  • Example#4649 - Ejemplo de Memcached::getDelayed
  • Example#4650 - Ejemplo de Memcached::getMulti
  • Example#4651 - Ejemplo de Memcached::GET_PRESERVE_ORDER
  • Example#4652 - Obtener opciones de Memcached
  • Example#4653 - Ejemplo de Memcached::getResultCode
  • Example#4654 - Ejemplo de Memcached::getResultMessage
  • Example#4655 - Ejemplo de Memcached::getServerByKey
  • Example#4656 - Ejemplo de Memcached::getServerList
  • Example#4657 - Ejemplo de Memcached::getStats
  • Example#4658 - Ejemplo de Memcached::getVersion
  • Example#4659 - Ejemplo de Memcached::increment
  • Example#4660 - Ejemplo de Memcached::prepend
  • Example#4661 - Ejemplo de Memcached::set
  • Example#4662 - Ejemplo de Memcached::setByKey
  • Example#4663 - Ejemplo de Memcached::setMulti
  • Example#4664 - Establecer una opción de Memcached
  • Example#4665 - Establecer opciones de Memcached
  • Example#4666 - mqseries_back example
  • Example#4667 - mqseries_begin example
  • Example#4668 - mqseries_close example
  • Example#4669 - mqseries_cmit example
  • Example#4670 - mqseries_conn example
  • Example#4671 - mqseries_connx example
  • Example#4672 - mqseries_connx example using SSL connection & OCSP Responder URL
  • Example#4673 - mqseries_disc example
  • Example#4674 - mqseries_get example
  • Example#4675 - mqseries_inq example
  • Example#4676 - mqseries_open example
  • Example#4677 - mqseries_put example
  • Example#4678 - mqseries_strerror example
  • Example#4679 - Using dns_get_record
  • Example#4680 - Using dns_get_record and DNS_ANY
  • Example#4681 - Ejemplo de fsockopen
  • Example#4682 - Utilización de una conexión UDP
  • Example#4683 - Un ejemplo sencillo de gethostbyaddr
  • Example#4684 - Ejemplo simple de gethostbyname
  • Example#4685 - Ejemplo de gethostbynamel
  • Example#4686 - Un ejemplo simple de gethostname
  • Example#4687 - Ejemplo de getprotobyname
  • Example#4688 - Ejemplo de getservbyname
  • Example#4689 - header_register_callback example
  • Example#4690 - Eliminar un encabezado específico.
  • Example#4691 - Eliminar todos los encabezados previamente establecidos.
  • Example#4692 - Diálogo de descarga
  • Example#4693 - Directivas caché
  • Example#4694 - Ejemplos usando headers_list
  • Example#4695 - Ejemplos usando headers_sent
  • Example#4696 - Empleo de http_response_code en un entorno de servidor web
  • Example#4697 - Empleo de http_response_code en un entorno CLI
  • Example#4698 - Ejemplo de inet_ntop
  • Example#4699 - Ejemplo de inet_pton
  • Example#4700 - Ejemplo de ip2long
  • Example#4701 - Desplegar una dirección IP
  • Example#4702 - Ejemplo de envío con setcookie
  • Example#4703 - Ejemplo de eliminación con setcookie
  • Example#4704 - setcookie y los arrays
  • Example#4705 - Uso de syslog
  • Example#4706 - Procedimiento de utilización de rrd
  • Example#4707 - Procedimiento de utilización de OOP rrd
  • Example#4708 - Ejemplo de RRDGraph::setOptions
  • Example#4709 - Establecer varias opciones de color
  • Example#4710 - Ejemplos de RRDUpdater::update
  • Example#4711 - Fetch instrumented calls
  • Example#4712 - Fetch the list of functions scoutapm will instrument
  • Example#4713 - snmp_get_quick_print example
  • Example#4714 - Using snmp_get_valueretrieval
  • Example#4715 - Using snmp_read_mib
  • Example#4716 - Using snmp_set_enum_print
  • Example#4717 - Using snmprealwalk
  • Example#4718 - Using snmp_set_quick_print
  • Example#4719 - Using snmp_set_valueretrieval
  • Example#4720 - Using snmp2_get
  • Example#4721 - Using snmp2_get_next
  • Example#4722 - Using snmp2_real_walk
  • Example#4723 - Using snmp2_set
  • Example#4724 - Using snmp2_set for setting BITS SNMP object id
  • Example#4725 - snmp2_walk Example
  • Example#4726 - Using snmp3_get
  • Example#4727 - Using snmp3_getnext
  • Example#4728 - Using snmp3_real_walk
  • Example#4729 - Using snmp3_set
  • Example#4730 - Using snmp3_set for setting BITS SNMP object id
  • Example#4731 - snmp3_walk Example
  • Example#4732 - Using snmpget
  • Example#4733 - Using snmpgetnext
  • Example#4734 - Using snmprealwalk
  • Example#4735 - Using snmpset
  • Example#4736 - Using snmpset for setting BITS SNMP object id
  • Example#4737 - snmpwalk Example
  • Example#4738 - snmpwalkoid Example
  • Example#4739 - Ejemplo de SNMP::close
  • Example#4740 - Fetching sysLocation
  • Example#4741 - Single SNMP object
  • Example#4742 - Multiple SNMP objects
  • Example#4743 - Ejemplo de SNMP::getErrno
  • Example#4744 - Ejemplo de SNMP::getError
  • Example#4745 - Single SNMP object
  • Example#4746 - Miltiple SNMP objects
  • Example#4747 - Set single SNMP object id
  • Example#4748 - Set multiple values using single SNMP::set call
  • Example#4749 - Using SNMP::set for setting BITS SNMP object id
  • Example#4750 - SNMP::setSecurity example
  • Example#4751 - SNMP::walk example
  • Example#4752 - suffixAsKey example
  • Example#4753 - Ejemplo de socket: Servidor TCP/IP sencillo
  • Example#4754 - Ejemplo de socket: Cliente TCP/IP sencillo
  • Example#4755 - Usar socket_bind para establecer la dirección de origen
  • Example#4756 - Ejemplo de socket_create_pair
  • Example#4757 - Ejemplo IPC de socket_create_pair
  • Example#4758 - Ejemplo de socket_get_option
  • Example#4759 - Ejemplo de socket_import_stream
  • Example#4760 - Un ejemplo de socket_last_error
  • Example#4761 - Un ejemplo de socket_recv
  • Example#4762 - Un ejemplo de socket_recvfrom
  • Example#4763 - Usar null con socket_select
  • Example#4764 - Comprender el resultado de socket_select
  • Example#4765 - Un ejemplo de socket_select
  • Example#4766 - Ejemplo de socket_sendto
  • Example#4767 - Un ejemplo de socket_set_block
  • Example#4768 - Un ejemplo de socket_set_nonblock
  • Example#4769 - Un ejemplo de socket_set_option
  • Example#4770 - Ejemplo de socket_strerror
  • Example#4771 - Authenticating with a ssh agent
  • Example#4772 - Authentication using a public hostkey
  • Example#4773 - Retrieving a list of authentication methods
  • Example#4774 - Authenticating with a password
  • Example#4775 - Authentication using a public key
  • Example#4776 - ssh2_connect
  • Example#4777 - Executing a command
  • Example#4778 - Opening a shell and retrieving the stderr stream associated with it
  • Example#4779 - Checking the fingerprint against a known value
  • Example#4780 - Determining what methods were negotiated
  • Example#4781 - Adding a publickey with ssh2_publickey_add
  • Example#4782 - Listing authorized keys with ssh2_publickey_list
  • Example#4783 - Descargar un fichero mediante SCP
  • Example#4784 - Cargar un fichero via SCP
  • Example#4785 - Changing the mode of a file on a remote server
  • Example#4786 - Stating a symbolic link via SFTP
  • Example#4787 - Creating a directory on a remote server
  • Example#4788 - Reading a symbolic link
  • Example#4789 - Resolving a pathname
  • Example#4790 - Renaming a file via sftp
  • Example#4791 - Removing a directory on a remote server
  • Example#4792 - Stating a file via SFTP
  • Example#4793 - Creating a symbolic link
  • Example#4794 - Deleting a file
  • Example#4795 - Abrir un fichero a través de SFTP
  • Example#4796 - Requesting an interactive shell
  • Example#4797 - Opening a tunnel to an arbitrary host
  • Example#4798 - Estilo orientado a objetos
  • Example#4799 - Estilo por procedimientos
  • Example#4800 - Ejemplo de stomp_connect_error
  • Example#4801 - Ejemplo de stomp_version
  • Example#4802 - Estilo orientado a objetos
  • Example#4803 - Estilo por procedimientos
  • Example#4804 - Estilo orientado a objetos
  • Example#4805 - Estilo por procedimientos
  • Example#4806 - Estilo orientado a objetos
  • Example#4807 - Estilo por procedimientos
  • Example#4808 - Estilo orientado a objetos
  • Example#4809 - Estilo por procedimientos
  • Example#4810 - Estilo orientado a objetos
  • Example#4811 - Estilo por procedimientos
  • Example#4812 - Estilo orientado a objetos
  • Example#4813 - Estilo por procedimientos
  • Example#4814 - Estilo orientado a objetos
  • Example#4815 - Estilo procedural
  • Example#4816 - Estilo orientado a objetos
  • Example#4817 - Estilo por procedimientos
  • Example#4818 - Estilo orientado a objetos
  • Example#4819 - Estilo por procedimientos
  • Example#4820 - Train from array
  • Example#4821 - Train from a file
  • Example#4822 - Ejemplo de svn_add
  • Example#4823 - Ejemplo de autenticación por omisión
  • Example#4824 - Ejemplo de svn_blame
  • Example#4825 - Ejemplo básico
  • Example#4826 - Ejemplo básico
  • Example#4827 - Ejemplo básico
  • Example#4828 - Ejemplo básico
  • Example#4829 - Ejemplo básico
  • Example#4830 - Ejemplo básico
  • Example#4831 - Comparando dos revisiones de una ruta de acceso a repositorio
  • Example#4832 - Comparativa portable de dos ficheros locales
  • Example#4833 - Ejemplo de svn_export
  • Example#4834 - Ejemplo básico
  • Example#4835 - svn_log example
  • Example#4836 - svn_ls example
  • Example#4837 - Ejemplo básico
  • Example#4838 - Ejemplo básico
  • Example#4839 - Denegar todas las conexiones desde localhost
  • Example#4840 - Prohibición de una URL
  • Example#4841 - Obtención de una instantánea de las estadísticas
  • Example#4842 - Lectura del log de varnish en la memoria compartida
  • Example#4843 - ejemplo de VarnishAdmin::__construct
  • Example#4844 - Busqueda Paralela usando YAZ
  • Example#4845 - Configuración del CCL
  • Example#4846 - Análisis CCL
  • Example#4847 - Actualizar registro
  • Example#4848 - Array para registro GRS-1
  • Example#4849 - Trabajar con MARCXML
  • Example#4850 - función PHP que escanea títulos
  • Example#4851 - Query Examples
  • Example#4852 - Criterios de Ordenación
  • Example#4853 - Un ejemplo de ZMQContext
  • Example#4854 - Un ejemplo de ZMQContext
  • Example#4855 - Un ejemplo de ZMQContext
  • Example#4856 - Un ejemplo de ZMQSocket
  • Example#4857 - Un ejemplo de send/recv
  • Example#4858 - Un ejemplo de ZMQPoll
  • Example#4859 - zookeeper_dispatch example #1
  • Example#4860 - zookeeper_dispatch example #2
  • Example#4861 - Zookeeper::addAuth example
  • Example#4862 - Zookeeper::create example
  • Example#4863 - Zookeeper::delete example
  • Example#4864 - Zookeeper::exists example
  • Example#4865 - Zookeeper::get example
  • Example#4866 - Zookeeper::get stat example
  • Example#4867 - Zookeeper::getAcl example
  • Example#4868 - Zookeeper::getChildren example
  • Example#4869 - Zookeeper::set example
  • Example#4870 - Zookeeper::setAcl example
  • Example#4871 - Zookeeper::setDebugLevel example
  • Example#4872 - ZookeeperConfig::add example
  • Example#4873 - ZookeeperConfig::get example
  • Example#4874 - ZookeeperConfig::remove example
  • Example#4875 - ZookeeperConfig::set example
  • Example#4876 - Ejemplo de solr_get_version
  • Example#4877 - Contenido del archivo BootStrap
  • Example#4878 - Añadir un documento al índice
  • Example#4879 - Fusionar un documento con otro documento
  • Example#4880 - Buscar documentos - respuestas de SolrObject
  • Example#4881 - Buscar documentos - respuestas de SolrDocument
  • Example#4882 - Ejemplo sencillo de TermsComponent - básico
  • Example#4883 - Ejemplo sencillo de TermsComponent - usar un prefijo
  • Example#4884 - Ejemplo sencillo de TermsComponent - especificar una frecuencia mínima
  • Example#4885 - Ejemplo sencillo de Facet
  • Example#4886 - Ejemplo sencillo de Facet - con sobrescritura de campo opcional para mincount
  • Example#4887 - Ejemplo de fecha de faceta
  • Example#4888 - Conectar a un Servidor con SSL Habilitado
  • Example#4889 - Colapsar un SolrQuery
  • Example#4890 - Ejemplo de conseguir el tiempo real Solr(RTG) SolrClient::getById
  • Example#4891 - SolrInputDocument::addChildDocument example
  • Example#4892 - SolrInputDocument::addChildDocuments example
  • Example#4893 - Ejemplo de SolrDocument::toArray
  • Example#4894 - Ejemplo de SolrObject::__construct
  • Example#4895 - Ejemplo de SolrObject::offsetUnset
  • Example#4896 - Ejemplo de SolrClient::addDocument
  • Example#4897 - Ejemplo 2 de SolrClient::addDocument
  • Example#4898 - Ejemplo de SolrClient::addDocuments
  • Example#4899 - Ejemplo de SolrClient::__construct
  • Example#4900 - Ejemplo de SolrQuery::deleteByQuery
  • Example#4901 - SolrClient::getById example
  • Example#4902 - SolrClient::getByIds example
  • Example#4903 - Ejemplo de SolrClient::ping
  • Example#4904 - Ejemplo de SolrClient::query
  • Example#4905 - Ejemplo de SolrClient::request
  • Example#4906 - Ejemplo de SolrClient::setResponseWriter
  • Example#4907 - Ejemplo de SolrParams::setParam
  • Example#4908 - Ejemplo de SolrQuery::addFacetField
  • Example#4909 - Ejemplo de SolrQuery::addFacetField
  • Example#4910 - Ejemplo de SolrQuery::addFilterQuery
  • Example#4911 - SolrQuery::addGroupSortField example
  • Example#4912 - SolrQuery::collapse example
  • Example#4913 - SolrQuery::setExpand example
  • Example#4914 - SolrDisMaxQuery::addBigramPhraseField example
  • Example#4915 - SolrDisMaxQuery::addBoostQuery example
  • Example#4916 - SolrDisMaxQuery::addPhraseField example
  • Example#4917 - SolrDisMaxQuery::addQueryField example
  • Example#4918 - SolrDisMaxQuery::addTrigramPhraseField example
  • Example#4919 - SolrDisMaxQuery::addUserField example
  • Example#4920 - SolrDisMaxQuery::__construct example
  • Example#4921 - SolrDisMaxQuery::removeBigramPhraseField example
  • Example#4922 - SolrDisMaxQuery::removeBoostQuery example
  • Example#4923 - SolrDisMaxQuery::removePhraseField example
  • Example#4924 - SolrDisMaxQuery::removeQueryField example
  • Example#4925 - SolrDisMaxQuery::removeTrigramPhraseField example
  • Example#4926 - SolrDisMaxQuery::removeUserField example
  • Example#4927 - SolrDisMaxQuery::setBigramPhraseFields example
  • Example#4928 - SolrDisMaxQuery::setBigramPhraseSlop example
  • Example#4929 - SolrDisMaxQuery::setBoostFunction example
  • Example#4930 - SolrDisMaxQuery::setBoostQuery example
  • Example#4931 - SolrDisMaxQuery::setMinimumMatch example
  • Example#4932 - SolrDisMaxQuery::setPhraseFields example
  • Example#4933 - SolrDisMaxQuery::setPhraseSlop example
  • Example#4934 - SolrDisMaxQuery::setQueryAlt example
  • Example#4935 - SolrDisMaxQuery::setQueryPhraseSlop example
  • Example#4936 - SolrDisMaxQuery::setTieBreaker example
  • Example#4937 - SolrDisMaxQuery::setTrigramPhraseFields example
  • Example#4938 - SolrDisMaxQuery::setTrigramPhraseSlop example
  • Example#4939 - SolrDisMaxQuery::setUserFields example
  • Example#4940 - SolrDisMaxQuery::useDisMaxQueryParser example
  • Example#4941 - SolrDisMaxQuery::useEDisMaxQueryParser example
  • Example#4942 - SolrCollapseFunction::__construct example
  • Example#4943 - SolrCollapseFunction::setHint example
  • Example#4944 - SolrCollapseFunction::setMax example
  • Example#4945 - Ejemplo de uso básico
  • Example#4946 - Desactivar el intérprete de PHP en un directorio utilizando .htaccess
  • Example#4947 - Ejemplo de apache_get_modules
  • Example#4948 - Ejemplo de apache_get_version
  • Example#4949 - Ejemplo de apache_getenv
  • Example#4950 - apache_lookup_uri example
  • Example#4951 - Paso de información entre PHP y Perl
  • Example#4952 - Registro de valores en access.log
  • Example#4953 - Ejemplo de apache_request_headers
  • Example#4954 - Ejemplo de apache_response_headers
  • Example#4955 - Estableciendo una variable de entorno de Apache usando apache_setenv
  • Example#4956 - Ejemplo de getallheaders
  • Example#4957 - Registrar una variable con $_SESSION.
  • Example#4958 - Desregistrar una variable con $_SESSION
  • Example#4959 - Contar el número de peticiones de un sólo usuario
  • Example#4960 - Ejemplo de información
  • Example#4961 - Ejemplo de session_cache_expire
  • Example#4962 - Ejemplo de session_cache_limiter
  • Example#4963 - Ejemplo de session_create_id con session_regenerate_id
  • Example#4964 - Destruir una sesión con $_SESSION
  • Example#4965 - Ejemplo de session_gc para administradores de tareas como cron
  • Example#4966 - Ejemplo de session_gc para un script accesible al usuario
  • Example#4967 - Ejemplo de session_name
  • Example#4968 - Un ejemplo de session_regenerate_id
  • Example#4969 - Gestor de seseiones personalizado: véase el código completo en la sinopsis de SessionHandlerInterface.
  • Example#4970 - Gestor de almacenamiento de sesiones personalizado usando objetos
  • Example#4971 - pagina1.php
  • Example#4972 - pagina2.php
  • Example#4973 - Sobrescribir el tiempo de vida de la cookie
  • Example#4974 - Leer la sesión y cerrarla
  • Example#4975 - Usar SessionHandler para añadir encriptación a los gestores de almacenamiento internos de PHP.
  • Example#4976 - Ejemplo usando SessionHandlerInterface
  • Example#4977 - Tokenize comma separated integer list
  • Example#4978 - Tokenize assign statement
  • Example#4979 - Simple calculator
  • Example#4980 - Parse words out from a sentence
  • Example#4981 - Ejemplos de patrones válidos
  • Example#4982 - Ejemplos de patrones no válidos
  • Example#4983 - Ejemplo comparando preg_filter con preg_replace
  • Example#4984 - Ejemplo de preg_grep
  • Example#4985 - preg_last_error_msg example
  • Example#4986 - Ejemplo de preg_last_error
  • Example#4987 - Obtener todos los números de teléfono de algún texto.
  • Example#4988 - Buscar coincidencias de etiquetas HTML (codicioso)
  • Example#4989 - Usar sub-patrones nominados
  • Example#4990 - Busca la cadena de texto "php"
  • Example#4991 - Busca la palabra "web"
  • Example#4992 - Obtener el nombre de dominio de una URL
  • Example#4993 - Usar sub-patrones nominados
  • Example#4994 - Ejemplo de preg_quote
  • Example#4995 - Poner en cursiva una palabra dentro de un texto
  • Example#4996 - Ejemplo de preg_replace_callback_array
  • Example#4997 - preg_replace_callback y función anónima
  • Example#4998 - Ejemplo de preg_replace_callback
  • Example#4999 - preg_replace_callback usando una estructura recursiva para manejar el código BB encapsulado
  • Example#5000 - Usar retroreferencias seguidas de literales numéricos
  • Example#5001 - Emplear arrays indexados con preg_replace
  • Example#5002 - Sustituir varios valores
  • Example#5003 - Quitar los espacios en blanco
  • Example#5004 - Usar el parámetro count
  • Example#5005 - Ejemplo de preg_split : Obtener las partes de un string de búsqueda
  • Example#5006 - Dividir un string en sus caracteres constituyentes
  • Example#5007 - Dividir un string mediante coincidencias y sus índices
  • Example#5008 - Ejemplos de Expresiones Regulares
  • Example#5009 - Ejemplo de ereg_replace
  • Example#5010 - Ejemplo de ereg_replace
  • Example#5011 - Sustituye URLs por vínculos
  • Example#5012 - Ejemplo de ereg
  • Example#5013 - Destaca los resultados buscados
  • Example#5014 - Ejemplo de eregi
  • Example#5015 - Ejemplo de split
  • Example#5016 - Ejemplo de split
  • Example#5017 - Ejemplo de spliti
  • Example#5018 - Ejemplo de sql_regcase
  • Example#5019 - Ejemplo de addcslashes
  • Example#5020 - Un ejemplo de addslashes
  • Example#5021 - chr Ejemplo
  • Example#5022 - Ejemplo de chunk_split
  • Example#5023 - Ejemplo de convert_uudecode
  • Example#5024 - Ejemplo de convert_uuencode
  • Example#5025 - count_chars example
  • Example#5026 - Mostrar una suma de verificación crc32
  • Example#5027 - crypt examples
  • Example#5028 - Using crypt with htpasswd
  • Example#5029 - Using crypt with different hash types
  • Example#5030 - Ejemplos de echo
  • Example#5031 - Ejemplo de explode
  • Example#5032 - Ejemplos de la devolución de explode
  • Example#5033 - Ejemplos del parámetro limit
  • Example#5034 - fprintf: enteros con relleno de ceros
  • Example#5035 - fprintf: dando formato a valores monetarios
  • Example#5036 - Ejemplo de tabla de traducción
  • Example#5037 - Ejemplo de hex2bin
  • Example#5038 - Decodificación de entidades HTML
  • Example#5039 - Un ejemplo de htmlentities
  • Example#5040 - Uso de ENT_IGNORE
  • Example#5041 - Un ejemplo de htmlspecialchars_decode
  • Example#5042 - Ejemplo de htmlspecialchars
  • Example#5043 - Ejemplo de implode
  • Example#5044 - Ejemplo de lcfirst
  • Example#5045 - Ejemplo de levenshtein
  • Example#5046 - Ejemplo de localeconv
  • Example#5047 - Ejemplo de uso de ltrim
  • Example#5048 - Ejemplo de uso de md5_file
  • Example#5049 - Ejemplo de md5
  • Example#5050 - Ejemplo básico de metaphone
  • Example#5051 - Utilizando el parámetro phonemes
  • Example#5052 - Ejemplos de money_format
  • Example#5053 - Usar nl2br
  • Example#5054 - Generar marcado HTML válido utilizando el parámetro is_xhtml
  • Example#5055 - Varios separadores de nueva línea
  • Example#5056 - Ejemplo de number_format
  • Example#5057 - Ejemplo de ord
  • Example#5058 - Examinar los bytes individuales de un string UTF-8
  • Example#5059 - Utilizando parse_str
  • Example#5060 - Ejemplos de print
  • Example#5061 - Ejemplo de uso de rtrim
  • Example#5062 - Ejemplos de setlocale
  • Example#5063 - Ejemplos para Windows de setlocale
  • Example#5064 - Ejemplo de sha1_file
  • Example#5065 - Ejemplo de sha1
  • Example#5066 - Ejemplos de soundex
  • Example#5067 - Intercambio de argumentos
  • Example#5068 - Intercambio de argumentos
  • Example#5069 - Intercambio de argumentos
  • Example#5070 - Intercambio de argumentos
  • Example#5071 - Especificar un carácter de relleno
  • Example#5072 - Especificador de posición con otros especificadores
  • Example#5073 - printf: ejemplos varios
  • Example#5074 - printf: especificadores de string
  • Example#5075 - sprintf: valores de tipo integer rellenados con ceros
  • Example#5076 - sprintf: formato de moneda
  • Example#5077 - sprintf: notación científica
  • Example#5078 - Ejemplo de sscanf
  • Example#5079 - sscanf - using optional parameters
  • Example#5080 - Using the empty string ''
  • Example#5081 - Showing case-sensitivity
  • Example#5082 - Using the empty string ''
  • Example#5083 - Showing case-sensitivity
  • Example#5084 - Ejemplo de str_ireplace
  • Example#5085 - Ejemplo de str_pad
  • Example#5086 - Ejemplo de str_repeat
  • Example#5087 - Ejemplos básicos de str_replace
  • Example#5088 - Ejemplos de trampas potenciales con str_replace
  • Example#5089 - Ejemplo de str_rot13
  • Example#5090 - Ejemplo de str_shuffle
  • Example#5091 - Ejemplos de uso de str_split
  • Example#5092 - Using the empty string ''
  • Example#5093 - Showing case-sensitivity
  • Example#5094 - Ejemplo de str_word_count
  • Example#5095 - Ejemplo de strcasecmp
  • Example#5096 - Ejemplo de strcmp
  • Example#5097 - Ejemplo de strcspn
  • Example#5098 - Ejemplo de strip_tags
  • Example#5099 - Ejemplos de stripos
  • Example#5100 - Un ejemplo de stripslashes
  • Example#5101 - Utilizando stripslashes en un array
  • Example#5102 - Ejemplo de stristr
  • Example#5103 - Probando si un string se encuentra o no
  • Example#5104 - Utilizando un needle no "string"
  • Example#5105 - Un ejemplo destrlen
  • Example#5106 - Ejemplo de strpbrk
  • Example#5107 - Usando ===
  • Example#5108 - Usando !==
  • Example#5109 - Uso de offset
  • Example#5110 - Ejemplo de strrchr
  • Example#5111 - Invertir una cadena con strrev
  • Example#5112 - Un ejemplo simple de strripos
  • Example#5113 - Verificando si hay una aguja en el pajar
  • Example#5114 - Buscando con desplazamientos
  • Example#5115 - Ejemplo de strspn
  • Example#5116 - Ejemplo de strstr
  • Example#5117 - Ejemplo de strtok
  • Example#5118 - Comportamiento anterior de strtok
  • Example#5119 - Comportamiento nuevo de strtok
  • Example#5120 - Ejemplo de strtolower
  • Example#5121 - Ejemplo de strtoupper
  • Example#5122 - Ejemplo de strtr
  • Example#5123 - Ejemplo de strtr con dos argumentos
  • Example#5124 - Comparación del comportamiento de strtr
  • Example#5125 - Un ejemplo de substr_compare
  • Example#5126 - Ejemplo de substr_count
  • Example#5127 - Ejemplo desubstr_replace
  • Example#5128 - Usando substr_replace para reemplazar múltiples strings de una vez
  • Example#5129 - Usando un start negativo
  • Example#5130 - Usando un length negativo
  • Example#5131 - Uso básico de substr
  • Example#5132 - Comportamiento de casting de substr
  • Example#5133 -
  • Example#5134 - Ejemplo de uso de trim
  • Example#5135 - Uso de trim en valores de un array
  • Example#5136 - Ejemplo de ucfirst
  • Example#5137 - Ejemplo de ucwords
  • Example#5138 - Ejemplo de ucwords con delimitadores personalizados
  • Example#5139 - vfprintf: números extendidos con ceros
  • Example#5140 - vprintf: zero-padded integers
  • Example#5141 - vsprintf: zero-padded integers
  • Example#5142 - Ejemplo de wordwrap
  • Example#5143 - Ejemplo de wordwrap
  • Example#5144 - Ejemplo de wordwrap
  • Example#5145 - Ejemplo de array_change_key_case
  • Example#5146 - Ejemplo de array_chunk
  • Example#5147 - Obtener la columna de nombres del conjunto de resultados
  • Example#5148 - Obtener la columna de apellidos del conjunto de resultados, indexada por la columna "id"
  • Example#5149 - Obtener la columna de nombres de usuarios de la propiedad pública "nombre_usuario" de un objeto
  • Example#5150 - Obtener la columna de nombres de la propiedad privada "nombre" de un objeto empleando el método mágico __get.
  • Example#5151 - Ejemplo simple de array_combine
  • Example#5152 - Ejemplo de array_count_values
  • Example#5153 - Ejemplo de array_diff_assoc
  • Example#5154 - Ejemplo de array_diff_assoc
  • Example#5155 - Ejemplo de array_diff_key
  • Example#5156 - Ejemplo de array_diff_uassoc
  • Example#5157 - Ejemplo de array_diff_ukey
  • Example#5158 - Ejemplo de array_diff
  • Example#5159 - Ejemplo de array_fill_keys
  • Example#5160 - Ejemplo de array_fill
  • Example#5161 - Ejemplo de array_filter
  • Example#5162 - array_filter sin callback
  • Example#5163 - array_filter con flag
  • Example#5164 - Ejemplo de array_flip
  • Example#5165 - Ejemplo de array_flip : collision
  • Example#5166 - Ejemplo de array_intersect_assoc
  • Example#5167 - Ejemplo de array_intersect_key
  • Example#5168 - Ejemplo de array_intersect_uassoc
  • Example#5169 - Ejemplo de array_intersect_ukey
  • Example#5170 - Ejemplo de array_intersect
  • Example#5171 - Ejemplo de array_key_exists
  • Example#5172 - array_key_exists vs isset
  • Example#5173 - Uso básico de array_key_first
  • Example#5174 - Ejemplo de array_keys
  • Example#5175 - Ejemplo de array_map
  • Example#5176 - array_map usando una función lambda (desde PHP 5.3.0)
  • Example#5177 - array_map - usando más arrays
  • Example#5178 - Crear un array de arrays
  • Example#5179 - array_map - con claves de tipo string
  • Example#5180 - Ejemplo de array_merge_recursive
  • Example#5181 - Ejemplo de array_merge
  • Example#5182 - Ejemplo de sencillo de array_merge
  • Example#5183 - array_merge con tipos que no son array
  • Example#5184 - Ordenar varios arrays
  • Example#5185 - Ordenar un array multidimensional
  • Example#5186 - Ordenar resultados de una base de datos
  • Example#5187 - Ordenación sin considerar mayúsculas/minúsculas
  • Example#5188 - Ejemplo de array_pad
  • Example#5189 - Ejemplo de array_pop
  • Example#5190 - Ejemplo de array_product
  • Example#5191 - Ejemplo de array_push
  • Example#5192 - Ejemplo de array_rand
  • Example#5193 - Ejemplo de array_reduce
  • Example#5194 - Ejemplo de array_replace_recursive
  • Example#5195 - array_replace_recursive y comportamiento recursivo
  • Example#5196 - Ejemplo de array_replace
  • Example#5197 - Ejemplo de array_reverse
  • Example#5198 - Ejemplo de array_search
  • Example#5199 - Ejemplo de array_shift
  • Example#5200 - Ejemplos de array_slice
  • Example#5201 - Ejemplos de array_splice
  • Example#5202 - Ejemplos de array_splice
  • Example#5203 - Ejemplos de array_sum
  • Example#5204 - Ejemplo de array_udiff_assoc
  • Example#5205 - Ejemplo de array_udiff_uassoc
  • Example#5206 - Ejemplo de array_udiff usando objetos de stdClass
  • Example#5207 - Ejemplo de array_udiff usando objetos de DateTime
  • Example#5208 - Ejemplo de array_uintersect_assoc
  • Example#5209 - Ejemplo de array_uintersect_uassoc
  • Example#5210 - Ejemplo de array_uintersect
  • Example#5211 - Ejemplo de array_unique
  • Example#5212 - array_unique y tipos
  • Example#5213 - Ejemplo de array_unshift
  • Example#5214 - Ejemplo de array_values
  • Example#5215 - Ejemplo de array_walk_recursive
  • Example#5216 - Ejemplo de array_walk
  • Example#5217 - Ejemplo de array
  • Example#5218 - Array con índice automático
  • Example#5219 - array con índice de base 1
  • Example#5220 - Accessing an array inside double quotes
  • Example#5221 - Ejemplo de arsort
  • Example#5222 - Ejemplo de la función asort
  • Example#5223 - Ejemplo de compact
  • Example#5224 - Ejemplo de count
  • Example#5225 - Ejemplo de count recursivo
  • Example#5226 - Ejemplo de uso de current y similares
  • Example#5227 - Ejemplo de each
  • Example#5228 - Atravesar un array con each
  • Example#5229 - Ejemplo de end
  • Example#5230 - Ejemplo de extract
  • Example#5231 - Ejemplo de in_array
  • Example#5232 - Ejemplo de in_array en modo estricto
  • Example#5233 - in_array con un array como aguja
  • Example#5234 - Ejemplo de key
  • Example#5235 - Ejemplo de krsort
  • Example#5236 - Ejemplo de ksort
  • Example#5237 - Ejemplos de list
  • Example#5238 - Un ejemplo del uso de list
  • Example#5239 - Empleo de list anidados
  • Example#5240 - Uso de list con índices de array
  • Example#5241 - list y orden de definiciones de índices
  • Example#5242 - Ejemplo de natcasesort
  • Example#5243 - Ejemplos de natsort demostrando su uso básico
  • Example#5244 - Ejemplos de natsort demostrando trampas potenciales
  • Example#5245 - Ejemplo del uso de next y similares
  • Example#5246 - Ejemplo de uso de prev and friends
  • Example#5247 - Ejemplos de range
  • Example#5248 - Ejemplo de reset
  • Example#5249 - Ejemplo de rsort
  • Example#5250 - Ejemplo de shuffle
  • Example#5251 - Ejemplo de sort
  • Example#5252 - Ejemplo de sort usando la ordenación insensible a mayúsculas/minúsculas natural
  • Example#5253 - Ejemplo básico de uasort
  • Example#5254 - Ejemplo de uksort
  • Example#5255 - Ejemplo de usort
  • Example#5256 - Ejemplo de usort usando un array multidimensional
  • Example#5257 - Ejemplo de usort usando una función miembro de un objeto
  • Example#5258 - Ejemplo de usort usando un cierre para ordenar un array multidimensional
  • Example#5259 - classes.inc
  • Example#5260 - test_script.php
  • Example#5261 - Ejemplo de class_alias
  • Example#5262 - Ejemplo de class_exists
  • Example#5263 - Ejemplo del parámetro autoload
  • Example#5264 - Usar get_called_class
  • Example#5265 - Ejemplo de get_class_methods
  • Example#5266 - Ejemplo de get_class_vars
  • Example#5267 - get_class_vars y comportamiento de ámbito
  • Example#5268 - Usar get_class
  • Example#5269 - Usar get_class en superclass
  • Example#5270 - Ejemplo de get_declared_classes
  • Example#5271 - Ejemplo de get_declared_interfaces
  • Example#5272 - Uso de get_object_vars
  • Example#5273 - Usar get_parent_class
  • Example#5274 - Ejemplo de interface_exists
  • Example#5275 - Ejemplo de is_a
  • Example#5276 - Usar el operador instanceof en PHP 5
  • Example#5277 - Ejemplo de is_subclass_of
  • Example#5278 - Ejemplo de is_subclass_of usando una interfaz
  • Example#5279 - Ejemplo de method_exists
  • Example#5280 - Ejemplo de method_exists estático
  • Example#5281 - Un ejemplo de property_exists
  • Example#5282 - Ejemplo de classkit_import
  • Example#5283 - Ejemplo de classkit_method_add
  • Example#5284 - Ejemplo de classkit_method_copy
  • Example#5285 - Ejemplo de classkit_method_redefine
  • Example#5286 - Ejemplo de classkit_method_remove
  • Example#5287 - Ejemplo de classkit_method_rename
  • Example#5288 - Un ejemplo de ctype_alnum (usando la localización predeterminada)
  • Example#5289 - Un ejemplo de ctype_alpha (usando la localización predeterminada)
  • Example#5290 - Un ejemplo de ctype_cntrl
  • Example#5291 - Un ejemplo de ctype_digit
  • Example#5292 - Un ejemplo de ctype_digit comparando strings con integers
  • Example#5293 - Un ejemplo de ctype_graph
  • Example#5294 - Un ejemplo de ctype_lower (usando la localidad predeterminada)
  • Example#5295 - Un ejemplo de ctype_print
  • Example#5296 - Un ejemplo de ctype_punct
  • Example#5297 - Un ejemplo de ctype_space
  • Example#5298 - Un ejemplo de ctype_upper (usando la localidad predeterminada)
  • Example#5299 - Un ejemplo de ctype_xdigit
  • Example#5300 - Configuring the default filter to act like htmlspecialchars
  • Example#5301 - Configurar el filtro predeterminado para que actúe como htmlspecialchars
  • Example#5302 - Validación de direcciones de correo con filter_var
  • Example#5303 - Validación de direcciones IP con filter_var
  • Example#5304 - Pasando opciones a filter_var
  • Example#5305 - Saneando y validando direcciones de correo
  • Example#5306 - Configuración de un filtro por omisión
  • Example#5307 - Un ejemplo con filter_input_array
  • Example#5308 - Un ejemplo de filter_input
  • Example#5309 - Ejemplo de filter_list
  • Example#5310 - Ejemplo de filter_var_array
  • Example#5311 - Un ejemplo de filter_var
  • Example#5312 - Ejemplo de call_user_func_array
  • Example#5313 - call_user_func_array usando un nombre de espacio de nombres
  • Example#5314 - Usar una función lambda
  • Example#5315 - Ejemplo de call_user_func y referencias
  • Example#5316 - Ejemplo de call_user_func
  • Example#5317 - call_user_func usando un nombre de espacios de nombres
  • Example#5318 - Usar un método de clase con call_user_func
  • Example#5319 - Usar una función lambda con call_user_func
  • Example#5320 - Crear una función anónima con create_function
  • Example#5321 - Hacer una función de proceso general con create_function
  • Example#5322 - Usar funciones anónimas como funciones de llamada de retorno
  • Example#5323 - Ejemplo de forward_static_call_array
  • Example#5324 - Ejemplo de forward_static_call
  • Example#5325 - Ejemplo de func_get_arg
  • Example#5326 - Ejemplo de func_get_arg antes y después de PHP 5.3
  • Example#5327 - func_get_arg ejemplo de argumentos byref (pasa un objeto como referencia) y byval (pasa un objeto como valor)
  • Example#5328 - Ejemplo de func_get_args
  • Example#5329 - Ejemplo de func_get_args antes y después de PHP 5.3
  • Example#5330 - func_get_args ejemplo de argumentos byref (pasa un objeto como referencia) y byval (pasa un objeto como valor)
  • Example#5331 - Ejemplo de func_num_args
  • Example#5332 - Ejemplo de func_num_args antes y después de PHP 5.3
  • Example#5333 - Ejemplo de function_exists
  • Example#5334 - Ejemplo de get_defined_functions
  • Example#5335 - Ejemplo de register_shutdown_function
  • Example#5336 - Ejemplo de register_tick_function
  • Example#5337 - Ejemplo de Quickhash
  • Example#5338 - Ejemplo de Quickhash con ArrayAccess
  • Example#5339 - Ejemplo de Quickhash con Iterator
  • Example#5340 - Ejemplo de valores de tipo string de Quickhash
  • Example#5341 - Ejemplo de QuickHashIntSet::add
  • Example#5342 - Ejemplo de QuickHashIntSet::__construct
  • Example#5343 - Ejemplo de QuickHashIntSet::delete
  • Example#5344 - Ejempl0 de QuickHashIntSet::exists
  • Example#5345 - Ejemplo de QuickHashIntSet::getSize
  • Example#5346 - Ejemplo de QuickHashIntSet::loadFromFile
  • Example#5347 - Ejemplo de QuickHashIntSet::loadFromString
  • Example#5348 - Ejemplo de QuickHashIntSet::saveToFile
  • Example#5349 - Ejemplo de QuickHashIntSet::saveToString
  • Example#5350 - Ejemplo de QuickHashIntHash::add
  • Example#5351 - Ejemplo de QuickHashIntHash::__construct
  • Example#5352 - Ejemplo de QuickHashIntHash::delete
  • Example#5353 - Ejemplo de QuickHashIntHash::exists
  • Example#5354 - Ejemplo de QuickHashIntHash::get
  • Example#5355 - Ejemplo de QuickHashIntHash::getSize
  • Example#5356 - Formato de fichero de IntHash de QuickHash
  • Example#5357 - Formato de fichero de IntHash de QuickHash
  • Example#5358 - Ejemplo de QuickHashIntHash::loadFromFile
  • Example#5359 - Ejemplo de QuickHashIntHash::loadFromString
  • Example#5360 - Ejemplo de QuickHashIntHash::saveToFile
  • Example#5361 - Ejemplo de QuickHashIntHash::saveToString
  • Example#5362 - Ejemplo de QuickHashIntHash::set
  • Example#5363 - Ejemplo de QuickHashIntHash::update
  • Example#5364 - Ejemplo de QuickHashStringIntHash::add
  • Example#5365 - Ejemplo de QuickHashStringIntHash::__construct
  • Example#5366 - Ejemplo de QuickHashStringIntHash::delete
  • Example#5367 - Ejemplo de QuickHashStringIntHash::get
  • Example#5368 - Ejemplo de QuickHashStringIntHash::getSize
  • Example#5369 - Formato de fichero de StringIntHash de QuickHash
  • Example#5370 - Formato de fichero de StringIntHash de QuickHash
  • Example#5371 - Ejemplo de QuickHashStringIntHash::loadFromFile
  • Example#5372 - Ejemplo de QuickHashStringIntHash::loadFromString
  • Example#5373 - Ejemplo de QuickHashStringIntHash::saveToFile
  • Example#5374 - Ejemplo de QuickHashStringIntHash::saveToString
  • Example#5375 - Ejemplo de QuickHashStringIntHash::set
  • Example#5376 - Ejemplo de QuickHashStringIntHash::update
  • Example#5377 - Ejemplo de QuickHashIntStringHash::add
  • Example#5378 - Ejemplo de QuickHashIntStringHash::__construct
  • Example#5379 - Ejemplo de QuickHashIntStringHash::delete
  • Example#5380 - Ejemplo de QuickHashIntStringHash::get
  • Example#5381 - Ejemplo de QuickHashIntStringHash::getSize
  • Example#5382 - Formato de fichero de IntString de QuickHash
  • Example#5383 - Formato de fichero de IntString de QuickHash
  • Example#5384 - Ejemplo de QuickHashIntStringHash::loadFromFile
  • Example#5385 - Ejemplo de QuickHashIntStringHash::loadFromString
  • Example#5386 - Ejemplo de QuickHashIntStringHash::saveToFile
  • Example#5387 - Ejemplo de QuickHashIntStringHash::saveToString
  • Example#5388 - Ejemplo de QuickHashIntStringHash::set
  • Example#5389 - Ejemplo de QuickHashIntStringHash::update
  • Example#5390 - Ejemplo de Reflection desde Shell (un terminal)
  • Example#5391 - Extendiendo las clases incorporadas
  • Example#5392 - Funcionamiento básico de ReflectionClass
  • Example#5393 - Uso básico de ReflectionClass::export
  • Example#5394 - Uso básico de ReflectionClass::getConstructor
  • Example#5395 - Ejemplo de ReflectionClass::getDefaultProperties
  • Example#5396 - Ejemplo de ReflectionClass::getDocComment
  • Example#5397 - Ejemplo de ReflectionClass::getEndLine
  • Example#5398 - Uso básico de ReflectionClass::getExtension
  • Example#5399 - Uso básico de ReflectionClass::getExtensionName
  • Example#5400 - Ejemplo de ReflectionClass::getInterfaceNames
  • Example#5401 - Ejemplo de ReflectionClass::getInterfaces
  • Example#5402 - Uso básico de ReflectionClass::getMethod
  • Example#5403 - Uso básico de ReflectionClass::getMethods
  • Example#5404 - Filtrar los resultados de ReflectionClass::getMethods
  • Example#5405 - Ejemplo de ReflectionClass::getName
  • Example#5406 - Ejemplo de ReflectionClass::getNamespaceName
  • Example#5407 - Ejemplo de filtrado con ReflectionClass::getProperties
  • Example#5408 - Uso básico de ReflectionClass::getProperty
  • Example#5409 - Basic ReflectionClass::getReflectionConstants example
  • Example#5410 - Ejemplo de ReflectionClass::getShortName
  • Example#5411 - Uso básico de ReflectionClass::getStaticPropertyValue
  • Example#5412 - Ejemplo de ReflectionClass::hasConstant
  • Example#5413 - Ejemplo de ReflectionClass::hasMethod
  • Example#5414 - Ejemplo de ReflectionClass::hasProperty
  • Example#5415 - Ejemplo de ReflectionClass::inNamespace
  • Example#5416 - Ejemplo de ReflectionClass::isAbstract
  • Example#5417 - ReflectionClass::isAnonymous example
  • Example#5418 - Uso básico de ReflectionClass::isCloneable
  • Example#5419 - Ejemplo de ReflectionClass::isFinal
  • Example#5420 - Ejemplo relacionado con ReflectionClass::isInstance
  • Example#5421 - Ejemplo de ReflectionClass::isInstantiable
  • Example#5422 - Uso básico de ReflectionClass::isInterface
  • Example#5423 - Uso básico de ReflectionClass::isInternal
  • Example#5424 - Basic ReflectionClass::isIterable Usage
  • Example#5425 - Ejemplo de ReflectionClass::isIterateable
  • Example#5426 - Uso básico de ReflectionClass::newInstanceArgs
  • Example#5427 - Ejemplo de ReflectionClass::__toString
  • Example#5428 - Ejemplo de ReflectionExtension
  • Example#5429 - Ejemplo de ReflectionExtension::getClasses
  • Example#5430 - Ejemplo de ReflectionExtension::getClassNames
  • Example#5431 - Ejemplo de ReflectionExtension::getConstants
  • Example#5432 - Ejemplo de ReflectionExtension::getDependencies
  • Example#5433 - Ejemplo de ReflectionExtension::getFunctions
  • Example#5434 - Ejemplo de ReflectionExtension::getINIEntries
  • Example#5435 - Ejemplo de ReflectionExtension::getName
  • Example#5436 - Ejemplo de ReflectionExtension::getVersion
  • Example#5437 - Ejemplo de ReflectionExtension::info
  • Example#5438 - Ejemplo de ReflectionFunction::__construct
  • Example#5439 - Ejemplo de ReflectionFunction::invoke example
  • Example#5440 - Ejemplo de ReflectionFunction::invokeArgs
  • Example#5441 - Ejemplo de ReflectionFunction::invokeArgs con argumentos por referencia
  • Example#5442 - Ejemplo de ReflectionFunction::__toString
  • Example#5443 - ReflectionFunctionAbstract::getReturnType example
  • Example#5444 - Usage on built-in functions
  • Example#5445 - ReflectionFunctionAbstract::hasReturnType example
  • Example#5446 - Usage on built-in functions
  • Example#5447 - Ejemplo de ReflectionFunctionAbstract::isClosure
  • Example#5448 - Ejemplo de ReflectionFunctionAbstract::isDeprecated
  • Example#5449 - Ejemplo de ReflectionMethod::__construct
  • Example#5450 - Ejemplo de ReflectionMethod::getDeclaringClass
  • Example#5451 - Ejemplo de ReflectionMethod::getModifiers
  • Example#5452 - Ejemplo de ReflectionMethod::getPrototype
  • Example#5453 - Ejemplo de ReflectionMethod::invoke
  • Example#5454 - Ejemplo de ReflectionMethod::invokeArgs
  • Example#5455 - Ejemplo de ReflectionMethod::__toString
  • Example#5456 - ReflectionNamedType::isBuiltin example
  • Example#5457 - Usando la clase ReflectionParameter
  • Example#5458 - Utilizar la clase ReflectionParameter
  • Example#5459 - Obtener la clase que declaró el método
  • Example#5460 - Obtención de los valores por defecto de los parámetros de la función
  • Example#5461 - ReflectionParameter::getType Usage as of PHP 7.1.0
  • Example#5462 - ReflectionParameter::getType Usage before PHP 7.1.0
  • Example#5463 - ReflectionParameter::hasType example
  • Example#5464 - Ejemplo de ReflectionProperty::__construct
  • Example#5465 - Obtener el valor de propiedades privadas y protegidas con ReflectionProperty
  • Example#5466 - ReflectionClass::getDefaultValue example
  • Example#5467 - Ejemplo de ReflectionProperty::getDocComment
  • Example#5468 - ReflectionProperty::getType example
  • Example#5469 - Ejemplo de ReflectionProperty::getValue
  • Example#5470 - ReflectionClass::hasDefaultValue example
  • Example#5471 - ReflectionProperty::hasType example
  • Example#5472 - Ejemplo de ReflectionClass::isDefault
  • Example#5473 - ReflectionProperty::isInitialized example
  • Example#5474 - Ejemplo de ReflectionProperty::setValue
  • Example#5475 - ReflectionType::allowsNull example
  • Example#5476 - ReflectionType::__toString example
  • Example#5477 - ReflectionUnionType::getTypes example
  • Example#5478 - ReflectionGenerator::__construct example
  • Example#5479 - ReflectionGenerator::getExecutingFile example
  • Example#5480 - ReflectionGenerator::getExecutingGenerator example
  • Example#5481 - ReflectionGenerator::getExecutingLine example
  • Example#5482 - ReflectionGenerator::getFunction example
  • Example#5483 - ReflectionGenerator::getThis example
  • Example#5484 - ReflectionGenerator::getTrace example
  • Example#5485 - Basic ReflectionReference::getId usage
  • Example#5486 - Ejemplos de boolval
  • Example#5487 - Ejemplo debug_zval_dump
  • Example#5488 -
  • Example#5489 -
  • Example#5490 - Una simple comparación empty / isset
  • Example#5491 - empty en índices de string
  • Example#5492 - Ejemplo de floatval
  • Example#5493 - Ejemplo de floatval con caracteres a la izquierda no numéricos
  • Example#5494 - Ejemplo de get_defined_vars
  • Example#5495 - get_resource_id example
  • Example#5496 - Ejemplo deget_resource_type
  • Example#5497 - Ejemplo de gettype
  • Example#5498 - Ejemplos de intval
  • Example#5499 - Comprobar que la variable es un array
  • Example#5500 - Ejemplos de is_bool
  • Example#5501 - Ejemplo de is_callable
  • Example#5502 - Función is_callable y constructores
  • Example#5503 - ejemplos de is_countable
  • Example#5504 - Ejemplo de is_float
  • Example#5505 - Ejemplo de is_int
  • Example#5506 - ejemplos de is_iterable
  • Example#5507 - Ejemplo is_null
  • Example#5508 - Ejemplos de is_numeric
  • Example#5509 - Ejemplo is_object
  • Example#5510 - Ejemplo de is_resource
  • Example#5511 - Ejemplo is_scalar
  • Example#5512 - Ejemplo is_string
  • Example#5513 - Ejemplos isset
  • Example#5514 - isset en indices de String
  • Example#5515 - Ejemplo print_r
  • Example#5516 - Ejemplo del parámetro devolver
  • Example#5517 - Ejemplo serialize
  • Example#5518 - Ejemplo settype
  • Example#5519 - strval usando el método mágico __toString() de PHP 5
  • Example#5520 - Ejemplo de unserialize
  • Example#5521 - Ejemplo de unserialize_callback_func
  • Example#5522 - Ejemplo de unset
  • Example#5523 - Usando el forzado a (unset)
  • Example#5524 - Ejemplo var_dump
  • Example#5525 - Ejemplos de var_export
  • Example#5526 - Exportación de clases a partir de PHP 5.1.0
  • Example#5527 - Uso de __set_state (a partir de PHP 5.1.0)
  • Example#5528 -
  • Example#5529 - Ejemplo de OAuth::fetch
  • Example#5530 - Ejemplo de OAuth::getAccessToken
  • Example#5531 - Ejemplo de OAuth::getRequestToken
  • Example#5532 - Ejemplo de OAuth::setRequestEngine
  • Example#5533 - Ejemplo de OAuth::setRsaCertificate
  • Example#5534 - Ejemplo OAuth::setToken
  • Example#5535 - Ejemplo de OAuthProvider::__construct
  • Example#5536 - Ejemplo del callback OAuthProvider::consumerHandler
  • Example#5537 - Ejemplo de OAuthProvider::generateToken
  • Example#5538 - Ejemplo de OAuthProvider::is2LeggedEndpoint
  • Example#5539 - Ejemplo de OAuthProvider::timestampNonceHandler
  • Example#5540 - Ejemplo del callback OAuthProvider::tokenHandler
  • Example#5541 - Ejemplo de is_soap_fault
  • Example#5542 - El método estándar de SOAP para el informe de errores con las excepciones
  • Example#5543 - Ejemplo de SoapClient::__doRequest
  • Example#5544 - Ejemplo de SoapClient::__getFunctions
  • Example#5545 - Ejemplo de SoapClient::__getLastRequest()
  • Example#5546 - Ejemplo de SoapClient::__getLastRequestHeaders()
  • Example#5547 - Ejemplo de SoapClient::__getLastResponse()
  • Example#5548 - Ejemplo de SoapClient::__getLastResponse()
  • Example#5549 - Ejemplo de SoapClient::__getTypes
  • Example#5550 - Ejemplo de SoapClient::__setLocation
  • Example#5551 - Ejemplo de SoapClient::__setSoapHeaders
  • Example#5552 - Definir múltiples encabezados
  • Example#5553 - Ejemplo de SoapClient::__soapCall
  • Example#5554 - Ejemplos de SoapServer::addFunction
  • Example#5555 - Ejemplo de SoapServer::getFunctions
  • Example#5556 - Ejemplo de SoapServer::handle
  • Example#5557 - Ejemplo de SoapServer::setPersistence
  • Example#5558 - Ejemplo de servidor de Yar
  • Example#5559 - Acceder al servidor desde el navegador (petición GET)
  • Example#5560 - Ejemplo de cliente de Yar
  • Example#5561 - Ejemplo de cliente concurrente de Yar
  • Example#5562 - Ejemplo de Yar_Server::__construct
  • Example#5563 - Ejemplo de Yar_Server::handle
  • Example#5564 - Ejemplo de Yar_Client::__call
  • Example#5565 - Ejemplo de Yar_Client::__construct
  • Example#5566 - Ejemplo de Yar_Client::setOpt
  • Example#5567 - Ejemplo de Yar_Concurrent_Client::call
  • Example#5568 - Ejemplo de Yar_Concurrent_Client::loop
  • Example#5569 - Ejemplo de Yar_Concurrent_Client::reset
  • Example#5570 - Ejemplo de Yar_Server_Exception::getType
  • Example#5571 - Ejemplo de Yar_Client_Exception::getType
  • Example#5572 - Ejmeplo de las funciones de clietes de XMLRPC
  • Example#5573 - Ejemplo de tipo de XML-RPC
  • Example#5574 - A xmlrpc_set_type example
  • Example#5575 - For Each en ASP
  • Example#5576 - while() ... Next() en PHP 4
  • Example#5577 - foreach en PHP 5
  • Example#5578 - Ejemplo COM (1)
  • Example#5579 - Ejemplo COM (2)
  • Example#5580 - Ejemplo DOTNET
  • Example#5581 - Ejemplo de una clase VARIANT, utilizada en PHP 4.x
  • Example#5582 - Ejemplo de una clase VARIANT, utilizada en PHP 5
  • Example#5583 - Basic COMPersistHelper::saveToFile Usage
  • Example#5584 - Ejemplo de absorción de un evento COM
  • Example#5585 - Registrar un script de PHP para ejecutarlo como un servicio
  • Example#5586 - Dejar de registrar un servicio
  • Example#5587 - Ejecutar como un servicio
  • Example#5588 - Un ejemplo de win32_create_service
  • Example#5589 - Un ejemplo de win32_delete_service
  • Example#5590 - Un ejemplo de win32_start_service_ctrl_dispatcher
  • Example#5591 - book.xml
  • Example#5592 - Creación de un nuevo objeto DOMAttr
  • Example#5593 - Ejemplo de DOMAttr::isId()
  • Example#5594 - Crear un nuevo objeto DOMCdataSection
  • Example#5595 - Creando un nuevo DOMComment
  • Example#5596 - Creando un nuevo DOMDocument
  • Example#5597 - Crear un nuevo elemento e insertarlo como raíz
  • Example#5598 - Pasando texto que contiene un & sin escapar como valor
  • Example#5599 - Crear un nuevo elemento e insertarlo como raíz
  • Example#5600 - Un ejemplo de prefijo de nombre de espacio
  • Example#5601 - Ejemplo de DOMDocument::getElementById()
  • Example#5602 - Ejemplo de uso básico
  • Example#5603 - Obtener todos los elementos XInclude
  • Example#5604 - DOMDocument::importNode ejemplo
  • Example#5605 - Creando un Documento
  • Example#5606 - Creando un Documento
  • Example#5607 - Crear un Documento
  • Example#5608 - Crear un Documento
  • Example#5609 - Invocación estática de loadXML
  • Example#5610 - Añadir un nuevo método a DOMElement para facilitar su código
  • Example#5611 - Recuperar elementos como clase personalizada
  • Example#5612 - Recuperar un propio documento
  • Example#5613 - Guardar un árbol DOM en un fichero
  • Example#5614 - Salvar un árbol HTML en una cadena
  • Example#5615 - Guardar un árbol HTML en un archivo
  • Example#5616 - Guardar un árbol DOM en un string
  • Example#5617 - Ejemplo de validación de DTD
  • Example#5618 - Ejemplo de DOMDocument::xinclude()
  • Example#5619 - Añadir información XML a su documento
  • Example#5620 - Crear un nuevo objeto DOMElement
  • Example#5621 - Establecer un atributo
  • Example#5622 - Crear un nuevo objeto DOMEntityReference
  • Example#5623 - Crear un documento con un DTD adjunto
  • Example#5624 - Comprobar su Implementación DOM
  • Example#5625 - Añadiendo un hijo
  • Example#5626 - Hijos anidados
  • Example#5627 - Ejemplo de DOMNode::getLineNo
  • Example#5628 - Ejemplo de DOMNode::getNodePath
  • Example#5629 - Eliminar un hijo
  • Example#5630 - Atravesar todas las entradas de una tabla
  • Example#5631 - Crear un nuevo objeto DOMProcessingInstruction
  • Example#5632 - Crear un nuevo objeto DOMText
  • Example#5633 - Obtener el número de todos los libros en inglés
  • Example#5634 - Obtener todos los libros en inglés
  • Example#5635 - book.xml
  • Example#5636 - DOMXPath::registerPHPFunctions con php:functionString
  • Example#5637 - DOMXPath::registerPHPFunctions con php:function
  • Example#5638 - Importar SimpleXML a DOM con dom_import_simplexml
  • Example#5639 - Ejemplo de libxml_get_errors
  • Example#5640 - Ejemplo de libxml_set_external_entity_loader
  • Example#5641 - Ejemplo de libxml_set_streams_context
  • Example#5642 - Ejemplo de libxml_use_internal_errors
  • Example#5643 - El fichero ejemplo.php a incluir con el string XML
  • Example#5644 - Obtener <argumento>
  • Example#5645 - Obtener <frase>
  • Example#5646 - Acceder a elementos no únicos en SimpleXML
  • Example#5647 - Utilizar atributos
  • Example#5648 - Comparar elementos y atributos con texto
  • Example#5649 - Comparar dos elementos
  • Example#5650 - Utilizar XPath
  • Example#5651 - Establecer valores
  • Example#5652 - Añadir elementos y atributos
  • Example#5653 - Interoperatibilidad con DOM
  • Example#5654 - Cargar un string XML erróneo
  • Example#5655 - Añadir atributos e hijos a un elemento SimpleXML
  • Example#5656 - Añade atributos e hijos a un elemento SimpleXML
  • Example#5657 - Retornar XML
  • Example#5658 - Usando asXML() en resultados SimpleXMLElement::xpath
  • Example#5659 - Interpreta un string XML
  • Example#5660 - Recorre el pseudo-array children()
  • Example#5661 - Usando espacio de nombres
  • Example#5662 - Crea un objeto SimpleXMLElement
  • Example#5663 - Crea un objeto SimpleXMLElement a partir de una URL
  • Example#5664 - Cuenta el número de hijos
  • Example#5665 - Obtener los espacios de nombres del documento
  • Example#5666 - Trabajando con múltiples espacios de nombre
  • Example#5667 - Retornar el nombre del elemento XML
  • Example#5668 - Obtener el nombre de espacio del documento en uso
  • Example#5669 - Estableciendo un prefijo para el namespace a usar en una petición XPath
  • Example#5670 - Get string content
  • Example#5671 - Xpath
  • Example#5672 - Devuelve el elemento actual
  • Example#5673 - Devuelve los sub elementos de el elemento actual
  • Example#5674 - Comprobar si el elemento actual tiene sub elementos
  • Example#5675 - Obtener la clave actual de etiquetas XML
  • Example#5676 - Mover a el siguiente elemento
  • Example#5677 - Rebobinar hasta el primer elemento
  • Example#5678 - Comprobar si el elemento actual es válido
  • Example#5679 - Importando desde DOM
  • Example#5680 - Interpreta un documento XML
  • Example#5681 - Interpreta un string XML
  • Example#5682 - Serializando un simple valor con WDDX
  • Example#5683 - Usando paquetes incrementales con WDDX
  • Example#5684 - Ejemplo wddx_serialize_vars
  • Example#5685 - Mostrar la estructura de elementos XML
  • Example#5686 - Asignar XML a HTML
  • Example#5687 - Ejemplo de entidades XML externas
  • Example#5688 - xmltest.xml
  • Example#5689 - xmltest2.xml
  • Example#5690 - Ejemplo de xml_parse_into_struct
  • Example#5691 - moldb.xml - pequeña base de datos de información molecular
  • Example#5692 - parsemoldb.php - interpreta moldb.xml dentro de un array de objetos moleculares
  • Example#5693 - Ejemplo xml_set_object
  • Example#5694 - Validando el XML
  • Example#5695 - Crear un simple documento XML
  • Example#5696 - Trabajar con espacios de nombres XML
  • Example#5697 - Trabajando con el OO API
  • Example#5698 - Direct output of XML
  • Example#5699 - XMLWriter::setIndent and mixed Content
  • Example#5700 - Basic XMLWriter::startAttribute Usage
  • Example#5701 - Intermixing Sub-elements and Attributes
  • Example#5702 - Basic xmlwriter_write_cdata Usage
  • Example#5703 - collection.xml
  • Example#5704 - collection.xsl
  • Example#5705 - fruits.xml
  • Example#5706 - fruits.xsl
  • Example#5707 - Errores de compaginación e impresión
  • Example#5708 - Creando un XSLTProcessor
  • Example#5709 - Comprobando si tiene EXSLT
  • Example#5710 - Sencilla llamada a una función de PHP desde una hoja de estilos
  • Example#5711 - Changing the owner before the transformation
  • Example#5712 - Ejemplo de salida de información
  • Example#5713 - Transformando en un DOMDocument
  • Example#5714 - Transformando a un fichero HTML
  • Example#5715 - Transformando a un string
  • Example#5716 - Un elemento oculto de un formulario HTML
  • Example#5717 - Datos a editar por el usuario
  • Example#5718 - En un URL
  • Example#5719 - Generación de Javascript con PHP
  • Example#5720 - Ejemplo de Código PHP/FI
  • Example#5721 - Activar la notificación completa de errores por pantalla para el dominio dev.
  • Example#5722 - Añadir un script de seguridad para aréas protegidas
  • Example#5723 - include_path en Unix
  • Example#5724 - include_path en Windows
  • Example#5725 - include_path en Unix usando la variable de entorno ${USER}
  • Example#5726 - string.rot13
  • Example#5727 - string.toupper
  • Example#5728 - string.tolower
  • Example#5729 - string.strip_tags
  • Example#5730 - convert.base64-encode & convert.base64-decode
  • Example#5731 - convert.quoted-printable-encode & convert.quoted-printable-decode
  • Example#5732 - convert.iconv.*
  • Example#5733 - zlib.deflate y zlib.inflate
  • Example#5734 - zlib.deflate simple
  • Example#5735 - bzip2.compress y bzip2.decompress
  • Example#5736 - Encriptar/Desencriptar con Blowfish
  • Example#5737 - Encriptar el archivo usando AES-128 CBC con SHA256 HMAC en PHP 5.5+


Registro de cambios

A las funciones de las extensiones incluidas se han realizado los siguientes cambios.

Version | Function | Description
PHP 7.0.15, PHP 7.1.1 | get_defined_functions | Se ha añadido el parámetro exclude_disabled.
PHP 5.3.19 | imagecreatefromxpm | imagecreatefromxpm está disponible en Windows.
8.0.0 / 1.18.0 | ZipArchive::getStatusString | Este método puede ser llamado en un archivo cerrado.
8.0.0 | curl_init | url es ahora nullable.
curl_init | En caso de éxito, esta función devuelve una instancia CurlHandle ahora; anteriormente, se devolvía un resource.
deflate_add | context expects a DeflateContext instance now; previously, a resource was expected.
deflate_init | On success, this function returns a DeflateContext instance now; previously, a resource was returned.
enchant_dict_add | dictionary expects an EnchantDictionary instance now; previoulsy, a recurso was expected.
enchant_dict_is_added | dictionary expects an EnchantDictionary instance now; previoulsy, a recurso was expected.
gmp_binomial | This function no longer returns false on failure.
inflate_add | context expects an InflateContext instance now; previously, a resource was expected.
inflate_get_read_len | context expects an InflateContext instance now; previously, a resource was expected.
inflate_get_status | context expects an InflateContext instance now; previously, a resource was expected.
inflate_init | On success, this function returns an InflateContext instance now; previously, a resource was returned.
ldap_add_ext | controls is nullable now; previously, it defaulted to [].
ldap_bind_ext | controls is nullable now; previously, it defaulted to [].
ldap_delete_ext | controls is nullable now; previously, it defaulted to [].
ldap_exop_passwd | controls is nullable now; previously, it defaulted to [].
ldap_modify_batch | controls is nullable now; previously, it defaulted to [].
ldap_mod_add_ext | controls is nullable now; previously, it defaulted to [].
ldap_mod_del_ext | controls is nullable now; previously, it defaulted to [].
ldap_mod_replace_ext | controls is nullable now; previously, it defaulted to [].
ldap_rename_ext | controls is nullable now; previously, it defaulted to [].
mb_chr | encoding is nullable now.
mb_ord | encoding is nullable now.
mb_scrub | encoding is nullable now.
mb_str_split | encoding is nullable now.
mb_str_split | This function no longer returns false on failure.
openssl_spki_new | private_key accepts an OpenSSLAsymmetricKey instance now; previously, a recurso of type OpenSSL key was accepted.
openssl_x509_fingerprint | certificate accepts an OpenSSLCertificate instance now; previously, a recurso of type OpenSSL X.509 was accepted.
openssl_x509_verify | public_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a recurso of type OpenSSL key or OpenSSL X.509 was accepted.
openssl_x509_verify | certificate accepts an OpenSSLCertificate instance now; previously, a recurso of type OpenSSL X.509 was accepted.
socket_addrinfo_bind | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_bind | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_addrinfo_connect | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_addrinfo_connect | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_explain | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_lookup | service is nullable now.
socket_addrinfo_lookup | On success, this function returns a array of AddressInfo instances now; previously, an array of resources was returned.
socket_export_stream | socket is a Socket instance now; previously, it was a resource.
socket_wsaprotocol_info_export | socket is a Socket instance now; previously, it was a resource.
socket_wsaprotocol_info_import | On success, this function returns a Socket instance now; previously, a resource was returned.
ReflectionClass::getConstants | Se añadió el parámetro filter.
ReflectionClass::getReflectionConstants | filter has been added.
ReflectionProperty::isInitialized | object is nullable now.
XMLWriter::endAttribute | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endCdata | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endComment | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endDocument | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endDtd | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endDtdAttlist | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endDtdElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endDtdEntity | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::endPi | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::flush | This function can no longer return false.
XMLWriter::flush | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::fullEndElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::openMemory | This function returns now an XMLWriter instance on success. Previouly, a recurso has been returned in this case.
XMLWriter::openUri | This function returns now an XMLWriter instance on success. Previouly, a recurso has been returned in this case.
XMLWriter::outputMemory | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::setIndent | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::setIndentString | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startAttribute | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startAttributeNs | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startAttributeNs | prefix is nullable now.
XMLWriter::startCdata | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startComment | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startDocument | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startDtd | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startDtdAttlist | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startDtdElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startDtdEntity | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startElementNs | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::startPi | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::text | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeAttribute | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeAttributeNs | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeCdata | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeComment | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeDtd | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeDtdAttlist | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeDtdElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeDtdEntity | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeDtdEntity | publicId, systemId and notationData are nullable now.
XMLWriter::writeElement | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeElementNs | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writePi | writer expects an XMLWriter instance now; previously, a resource was expected.
XMLWriter::writeRaw | writer expects an XMLWriter instance now; previously, a resource was expected.
7.4.0 | get_magic_quotes_gpc | Esta función ha quedado en desuso.
get_magic_quotes_runtime | Esta función es obsoleta.
implode | Pasar el parámetro glue después de el parámetro pieces (es decir, sin utilizar el orden documentado de los parámetros) es obsoleto.
SplFileObject::fgetcsv | El parámetro escape ahora también acepta un string vacío para desactivar el mecanismo de escape propio.
SplFileObject::fwrite | La función ahora devuelve false en vez de cero en caso de error.
SplFileObject::getCsvControl | El carácter de escape puede ser ahora un string vacío.
SplFileObject::setCsvControl | El parámetro escape ahora acepta un string vacío para desactivar el mecanismo de escape.
7.3.0 | apache_request_headers | Esta función se hizo disponible en el SAPI de FPM.
array_unshift | Esta función ahora puede ser llamada con un solo parámetro. Anteriormente, se requerían al menos dos parámetros.
curl_getinfo | Introdujo CURLINFO_CONTENT_LENGTH_DOWNLOAD_T, CURLINFO_CONTENT_LENGTH_UPLOAD_T, CURLINFO_HTTP_VERSION, CURLINFO_PROTOCOL, CURLINFO_PROXY_SSL_VERIFYRESULT, CURLINFO_SCHEME, CURLINFO_SIZE_DOWNLOAD_T, CURLINFO_SIZE_UPLOAD_T, CURLINFO_SPEED_DOWNLOAD_T, CURLINFO_SPEED_UPLOAD_T, CURLINFO_APPCONNECT_TIME_T, CURLINFO_CONNECT_TIME_T, CURLINFO_FILETIME_T, CURLINFO_NAMELOOKUP_TIME_T, CURLINFO_PRETRANSFER_TIME_T, CURLINFO_REDIRECT_TIME_T, CURLINFO_STARTTRANSFER_TIME_T, CURLINFO_TOTAL_TIME_T.
getallheaders | Esta función se hizo disponible en el SAPI de FPM.
is_countable | is_countable ha sido añadido.
json_encode | JSON_THROW_ON_ERROR Se añadió a flags.
setcookie | Una alternativa que soporta un array options ha sido añadida. Esta alternativa soporta también la configuración del atributo de la cookie de SameSite.
setrawcookie | Una alternativa que soporta un array options ha sido añadida. Esta alternativa soporta también la configuración del atributo de la cookie de SameSite.
7.3 | ldap_exop | Support for serverctrls added
ldap_exop_passwd | Support for controls added
ldap_modify_batch | Support for controls added
ldap_mod_add_ext | Support for controls added
ldap_mod_del_ext | Support for controls added
ldap_mod_replace_ext | Support for controls added
ldap_rename_ext | Support for controls added
ldap_search | Se añadión soporte para serverctrls
7.2.19, 7.3.6 | SplFileObject::__toString | Cambiado de un alias de SplFileObject::current a un alias de SplFileObject::fgets.
7.2.0 | array_unique | Si el parámetro sort_flags es SORT_STRING, el array anterior ha sido copiado y se han eliminado los elementos no únicos (sin empaquetar el array posteriormente), pero ahora se construye un nuevo array añadiendo los elementos únicos. Esto puede dar lugar a diferentes índices numéricos.
count | count generará una advertencia si se pasan tipos contables no válido al parámetro array_or_countable.
date_parse_from_format | El elemento de zone devuelto representa ahora segundos en lugar de minutos, y su signo está invertido. Por ejemplo -120 es ahora 7200.
hash_init | Uso de funciones de hash no criptográficas (adler32, crc32, crc32b, fnv132, fnv1a32, fnv164, fnv1a64, joaat) con HASH_HMAC ha sido deshabilitado.
hash_init | Devuelve HashContext en lugar de recurso.
is_object | is_object ahora devuelve true para objetos no seriados sin una definición de clase (clase de __PHP_Incomplete_Class). Anteriormente false era devuelto.
json_encode | JSON_INVALID_UTF8_IGNORE, and JSON_INVALID_UTF8_SUBSTITUTE Se añadieron a flags.
mail | El parámetro additional_headers ahora también acepta array.
session_abort | El tipo de retorno de esta función es bool ahora. Anteriormente, ha sido void.
SQLite3::openBlob | The flags parameter has been added, allowing to write BLOBs; formerly only reading was supported.
7.1.0 | array_rand | El algoritmo de aleatorización interno se ha cambiado para usar el generador de números aleatorios Mersenne Twister en lugar de la función libc rand.
file_get_contents | Se añadió soporte para valores negativos de offset.
get_headers | El parámetro context fue agregado.
iconv_strpos | Añadido soporte para offsets negativos.
json_encode | JSON_UNESCAPED_LINE_TERMINATORS Se añadió a flags.
json_encode | serialize_precision se utiliza en lugar de precision al codificar 'doubles'.
mb_ereg_replace | El modificador e está ahora obsoleto.
mb_eregi_replace | El modificador e está ahora obsoleto.
output_reset_rewrite_vars | Antes de PHP 7.1.0, la variables reescritas por output_add_rewrite_var utilizaban el mismo buffer de salida del módulo de sesión trans sid. Desde PHP 7.1.0, se usa un buffer de salida dedicado y output_reset_rewrite_vars solo elimina las variables reescritas definidas por output_add_rewrite_var.
pcntl_signal | As of PHP 7.1.0 the handler callback is given a second argument containing the siginfo of the specific signal. This data is only supplied if the operating system has the siginfo_t structure. If the OS does not implement siginfo_t NULL is supplied.
pcntl_signal_get_handler | pcntl_signal_get_handler has been added.
pg_fetch_all | El parametro result_type fue agregado.
pg_last_notice | El parameto option fue agregado.
pg_select | The result_type parameter was added.
unserialize | El elemento allowed_classes de options) es ahora estrictamente tipado, es decir: si cualquier cosa distinta de un array o un boolean es proporcionada, unserialize retornará false y lanzará un E_WARNING.
ReflectionType::__toString | ReflectionType::__toString has been deprecated.
7.0.16, 7.1.2 | dns_get_record | Added support for CAA record type.
fopen | Se añadió la opción 'e'.
7.0.11 | iconv_substr | Si la longitud de caracteres de str es igual a offset, devolverá un string vacío. Antes de ésta versión, un false era devuelto en éste caso.
7.0.7 | curl_setopt | Se introdujeron CURL_HTTP_VERSION_2, CURL_HTTP_VERSION_2_PRIOR_KNOWLEDGE, CURL_HTTP_VERSION_2TLS, CURL_REDIR_POST_301, CURL_REDIR_POST_302, CURL_REDIR_POST_303, CURL_REDIR_POST_ALL, CURL_VERSION_KERBEROS5, CURL_VERSION_PSL, CURL_VERSION_UNIX_SOCKETS, CURLAUTH_NEGOTIATE, CURLAUTH_NTLM_WB, CURLFTP_CREATE_DIR, CURLFTP_CREATE_DIR_NONE, CURLFTP_CREATE_DIR_RETRY, CURLHEADER_SEPARATE, CURLHEADER_UNIFIED, CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE, CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE, CURLMOPT_MAX_HOST_CONNECTIONS, CURLMOPT_MAX_PIPELINE_LENGTH, CURLMOPT_MAX_TOTAL_CONNECTIONS, CURLOPT_CONNECT_TO, CURLOPT_DEFAULT_PROTOCOL, CURLOPT_DNS_INTERFACE, CURLOPT_DNS_LOCAL_IP4, CURLOPT_DNS_LOCAL_IP6, CURLOPT_EXPECT_100_TIMEOUT_MS, CURLOPT_HEADEROPT, CURLOPT_LOGIN_OPTIONS, CURLOPT_PATH_AS_IS, CURLOPT_PINNEDPUBLICKEY, CURLOPT_PIPEWAIT, CURLOPT_PROXY_SERVICE_NAME, CURLOPT_PROXYHEADER, CURLOPT_SASL_IR, CURLOPT_SERVICE_NAME, CURLOPT_SSL_ENABLE_ALPN, CURLOPT_SSL_ENABLE_NPN, CURLOPT_SSL_FALSESTART, CURLOPT_SSL_VERIFYSTATUS, CURLOPT_STREAM_WEIGHT, CURLOPT_TCP_FASTOPEN, CURLOPT_TFTP_NO_OPTIONS, CURLOPT_UNIX_SOCKET_PATH, CURLOPT_XOAUTH2_BEARER, CURLPROTO_SMB, CURLPROTO_SMBS, CURLPROXY_HTTP_1_0, CURLSSH_AUTH_AGENT y CURLSSLOPT_NO_REVOKE.
7.0.0 | array_column | Se añadió la capacidad de que el parámetro input sea un array de objetos.
Aserción | assert is now a language construct and not a function. assertion can now be an expression. The second parameter is now interpreted either as an exception (if a Throwable object is given), or as the description supported from PHP 5.4.8 onwards.
curl_setopt | Se ha eliminado el soporte para inhabilitar la opción CURLOPT_SAFE_UPLOAD. Todas las subidas de ficheros de curl deben emplear CURLFile.
current | array ahora siempre se pasa por el valor. Antes de esta versión, se pasaba por referencia si era posible, y por el valor de lo contrario.
define | Están permitidos valores array.
dirname | Añadido el parámetro opcional levels.
dl | dl está deshabilitado en PHP-FPM.
getrusage | Esta función ahora está soportada en Windows
gmmktime | El parámetro is_dst ha sido eliminado.
key | array ahora siempre se pasa por el valor. Antes de esta versión, se pasaba por referencia si era posible, y por el valor de lo contrario.
list | Los strings ya no pueden ser desempaquetados.
list | Las expresiones de list ya no pueden estar completamente vacías.
list | El orden en el que se realizan las operaciones de asignación ha cambiado.
mktime | El parámetro is_dst ha sido eliminado.
ob_start | En caso de utilizar ob_start dentro de una retrollamada del búfer de salida, esta función ya no emitirá un E_ERROR, si no un E_RECOVERABLE_ERROR, permitiendo a los manejadores de errores propios capturar tales errores.
preg_replace | Se ha eliminado el soporte para el modificador /e. Emplee preg_replace_callback en su lugar.
session_start | Se añadió el parámetro options.
set_exception_handler | Cambiado el tipo de parámetro pasado a exception_handler de Exception a Throwable
setlocale | Se ha eliminado el soporte para el parámetro category pasado como string. En esta versión, solamente se pueden utilizar las constantes LC_*.
shmop_close | El tipo de shmid ha sido cambiado de int a resource.
shmop_delete | El tipo de shmid ha sido cambiado de int a resource.
shmop_open | El tipo devuelto de shmop_open ha sido cambiado de int a resource.
shmop_read | El tipo de shmid ha sido cambiado de int a resource.
shmop_size | El tipo de shmid ha sido cambiado de int a resource.
shmop_write | El tipo de shmid ha sido cambiado de int a resource.
substr | Si la longitud de caracteres de string es igual a start, se devolverá una cadena vacía. Antes de esta versión, en este caso se devolvía false.
unserialize | Se añadió el parámetro options.
5.6.25, 7.0.10 | SplFileObject::getCsvControl | Se añadió el carácter de escape al array devuelto.
5.6.16 | mysqli::real_connect | Se añadió la bandera MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT para el Controlador Nativo de MySQL
5.6.12 | gd_info | Se añadió WebP Support.
5.6.5 | crypt | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.6 devolvía incorrectamente un hash DES.
5.6.3 | pack | Se añadieron los códigos "q", "Q", "J" y "P" para habilitar el trabajo con número de 64 bit.
5.6.1 | sem_acquire | Se añadió el parámetro $nowait.
5.6.0 | array_fill | num ahora puede ser cero. Anteriormente, se requería que num fuera maoyor que cero.
array_filter | Se añadió el parámetro opcional flag y las constantes ARRAY_FILTER_USE_KEY y ARRAY_FILTER_USE_BOTH
crypt | Se emite una advertencia de seguridad E_NOTICE si se omite salt.
curl_setopt | CURLOPT_SAFE_UPLOAD ahore es true de forma predeterminada.
curl_setopt | Se eliminó CURLOPT_CLOSEPOLICY y sus valores asociados.
hash_algos | Se añadió soprte para gost-crypto. Este implementa la función de hash GOST empleando las tablas CryptoPro S-box como está especificado en la RFC 4357, sección 11.2.
html_entity_decode | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
htmlentities | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
htmlspecialchars | El valor predeterminado para el parámetro encoding se cambió para que fuera el valor de la opción de configuración default_charset.
json_decode | Ya no se aceptan variantes que no estén en minúsculas de los literales true, false y null como entradas válidas, por lo que se generarán advertencias.
mb_regex_encoding | La codificación predeterminada se cambió a UTF-8. Anteriormente era EUC-JP.
mcrypt_create_iv | MCRYPT_DEV_URANDOM ahora es el valor predetermniado de source.
mcrypt_decrypt | Tamaños incorrectos en key y iv ya no son admitidos. mcrypt_decrypt emitirá una advertencia y devolverá false si los datos de entrada son incorrectos. Anteriormente la clave y el IV eran rellenados con bytes '\0' hasta el siguiente tamaño válido.
mcrypt_encrypt | Tamaños incorrectos en key y iv ya no son admitidos. mcrypt_encrypt emitirá una advertencia y devolverá false si los datos de entrada son incorrectos. Anteriormente la clave y el IV eran rellenados con bytes '\0' hasta el siguiente tamaño válido.
pg_connect | El soporte para la constante PGSQL_CONNECT_ASYNC se ha añadido con el parametro connect_type.
pg_convert | Ya no es experimental. Se admiten los tipos de datos boolean/NULL. Los tipos de datos desconocidos/no soportados son escapados sin validación. Se podría emplear pg_convert con cualquier tipo de dato.
pg_delete | Ya no es experimental. Se añadió la constante PGSQL_DML_ESCAPE, se admiten los tipos de datos true/false y null.
pg_insert | Unless PGSQL_DML_STRING is passed, the function now returns the connection resource instead of true on success.
pg_insert | No longer experimental. Added PGSQL_DML_ESCAPE constant, true/false and null data type support.
pg_lo_seek | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
pg_lo_tell | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
pg_lo_truncate | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
pg_meta_data | No longer experimental. Added "is enum" as default attribute. extended flag is added.
pg_select | No longer experimental. Added PGSQL_DML_ESCAPE constant, true/false and null data type support.
pg_update | Ya no es experimental. Se ha añadido la constante PGSQL_DML_ESCAPE, true/false y null son los tipo de datos soportados.
stream_socket_enable_crypto | crypto_type ahora es opcional.
unserialize | Manipular los datos serializados reemplazando C: con O: para forzar la instanciación de objetos sin llamar al constructor ahora fallará.
ReflectionClass::newInstanceWithoutConstructor | Ahora todas las clases internas pueden ser instanciadas, excepto aquellas declaradas final.
5.5.22, 5.6.6 | flock | Se añadió soporte para el parámetro wouldblock en Windows.
SplFileObject::flock | Añadido soporte para el parámetro wouldblock en Windows.
5.5.21, 5.6.5 | SplFileObject::fputcsv | Se añadió el parámetro escape.
5.5.21 | crypt | Cuando se da la cadena de fallo "*0" como salt, ahora se devuelve "*1" por consistencia con otras implementaciones de crypt. Antes de esta versión, PHP 5.5 (y ramificaciones anteriores) devolvía incorrectamente un hash DES.
5.5.19/5.6.3 | imagescale | Se ha arreglado el cálculo de la altura si new_height era negativo o se omitía; antes de estas versiones, la proporción de aspecto no se mantenía correctamente.
5.5.11 | substr_compare | length ahora puede ser 0.
5.5.10 | DateTimeZone::__construct | El parámetro timezone acepta valores de índice.
5.5.8 | DatePeriod::__construct | El tipo de end se cambió a DateTimeInterface. Anteriormente era DateTime.
5.5.4 | fputcsv | Se añadió el parámetro escape_char
5.5.3/5.4.19 | pg_delete | La inyección SQL directa a table_name y la inyección SQL indirecta a identificadores son fijasinjection.
pg_insert | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
pg_select | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
pg_update | La inyección directa SQL a table_name y la inyección indirecta SQL a los indetificadores a sido arreglada.
5.5.2 | DOMDocument::schemaValidate | Se añadió el parámetro flags
DOMDocument::schemaValidateSource | Se añadió el parámetro flags
5.5.1 | hex2bin | Se emite una advertencia si el string de entrada es un string hexadecimal no válido.
pg_unescape_bytea | A warning is thrown if the input string is invalid.
session_set_save_handler | Se añadió el parámetro opcional create_sid.
5.5.0/PECL 3.0.0 | IntlDateFormatter::create | Se permite un objeto IntlCalendar para calendar. Los objetos de tipo IntlTimeZone y DateTimeZone están permitidos para timezone. Los identificadores de zonas horarias válidos (incluyendo string vacíos) ya no están permitidos para timezone. Si se proporciona null a timezone, el identificador de la zona horaria dado por date_default_timezone_get se usará en lugar del predeterminado de ICU.
IntlDateFormatter::format | Se añadió el soporta para proporcionar objetos IntlCalendar al parámetro value.
IntlDateFormatter::setCalendar | Ahora es posible pasar un objeto IntlCalendar.
5.5.0 | DatePeriod::__construct | start se cambió a DateTimeImmutable. Anteriormente era DateTime.
curl_getinfo | Introdujo CURLINFO_RESPONSE_CODE, CURLINFO_HTTP_CONNECTCODE, CURLINFO_HTTPAUTH_AVAIL, CURLINFO_PROXYAUTH_AVAIL, CURLINFO_OS_ERRNO, CURLINFO_NUM_CONNECTS, CURLINFO_SSL_ENGINES, CURLINFO_COOKIELIST, CURLINFO_FTP_ENTRY_PATH, CURLINFO_APPCONNECT_TIME, CURLINFO_CONDITION_UNMET, CURLINFO_RTSP_CLIENT_CSEQ, CURLINFO_RTSP_CSEQ_RECV, CURLINFO_RTSP_SERVER_CSEQ y CURLINFO_RTSP_SESSION_ID.
curl_setopt | Se introdujo CURLOPT_SHARE.
curl_setopt | Se añadió el recurso cURL como el primer parámetro de la llamada de retorno CURLOPT_PROGRESSFUNCTION.
empty | empty ahora soporta expresiones, en vez de únicamente variables.
imagerotate | Esta función ahora se ve afectada por el método de interpolación establecido por la función imagesetinterpolation.
iterator_to_array | iterator_to_array da soporte a tipos de claves diferentes a integer y string cuando el parámetro use_keys está habilitado.
mysql_connect | Esta función generará un error de nivel E_DEPRECATED.
mysql_db_name | La función mysql_list_dbs es obsoleta, por lo que emite un error de nivel E_DEPRECATED.
mysql_pconnect | Esta función generará un error de nivel E_DEPRECATED.
mysql_tablename | La función mysql_tablename es obsoleta, por lo que emite un error de nivel E_DEPRECATED.
pack | Se añadió el código "Z" con funcionalidad equivalente a "a" por compatibilidad con Perl.
phpinfo | Los GUIDs de logos fueron reemplazados con URIs de datos, por lo que desactivar ahora expose_php no tiene efecto sobre el resutaldo de phpinfo(). Los créditos ahora también han sido embebidos en la salida misma en vez mediante enlaces.
preg_replace | El modificador /e está obsoleto. Utilice preg_replace_callback en su lugar. Véase la documentación de PREG_REPLACE_EVAL para obtener información adicional sobre riesgos de seguridad.
set_error_handler | error_handler ahora acepta null.
set_exception_handler | Anteriormente, si se pasaba null, esta función devolvía true. Devuelve el manejador anterior desde PHP 5.5.0.
setcookie | Ahora se incluye un atributo Max-Age en la cabecera Set-Cookie enviada al cliente.
setrawcookie | Ahora se incluye un atributo Max-Age en la cabecera Set-Cookie enviada al cliente.
unpack | Cambios realizados para poner esta función en línea con Perl: El código "a" ahora guarda bytes NULL sobrantes de cola. El código "A" ahora elimina todos los espacios en blanco ASCII sobrantes de cola (espacios, tabulaciones, nuevas líneas, retorno de carro, y bytes NULL). Se añadió en código "Z" para cadenas rellenadas con NULL, y elimina los bytes NULL sobrantes de cola.
mysqli::commit | Se añadieron los parámetros flags y name.
mysqli::options | Se añadieron las opciones MYSQLI_SERVER_PUBLIC_KEY y MYSQLI_SERVER_PUBLIC_KEY.
mysqli::rollback | Se añadieron los parámetros flags y name.
5.4.32, 5.5.16 | ucwords | Se añadió el parámetro delimiters.
5.4.8 | Aserción | The description parameter was added. The description is also now provided to a callback function in ASSERT_CALLBACK mode as the fourth argument.
mb_strcut | Pasar NULL al parámetro length extrae todos los bytes hasta el final de string. Antes de esta versión, NULL era tratado de igual modo que 0.
mb_substr | Pasar NULL al parámetro length extrae todos los caracteres hasta el final de string. Antes de esta versión, NULL era tratado de igual modo que 0.
5.4.7 | curl_getinfo | Introdujo CURLINFO_PRIMARY_IP, CURLINFO_PRIMARY_PORT, CURLINFO_LOCAL_IP y CURLINFO_LOCAL_PORT.
parse_url | Arreglado el reconocimiento de host cuando scheme es omitido y está presente un separador de componentes que lo encabeza.
5.4.4 | hex2bin | Se emite una advertencia si la cadena de entrada tiene una longitud impar. En PHP 5.4.0 la cadena era aceptada de forma silenciosa, pero el último byte era truncado.
5.4.0/PECL 2.0.0b1 | idn_to_ascii | Se añadieron los parámetros variant y idna_info; y el soporte para UTS #46.
idn_to_utf8 | Se añadieron los parámetros variant y idna_info; y el soporte para UTS #46.
5.4.0 | DOMDocument::loadHTML | Se añadió el parámero options.
DOMDocument::loadHTMLFile | Se añadió el parámero options.
apache_child_terminate | Esta función está disponible bajo FastCGI. Anteriormente, estaba soportada solo cuando había sido instalado un módulo PHP en Apache.
array_combine | Versiones previas emiten un E_WARNING y devuelven false para arrays vacíos.
array_multisort | Se añadieron SORT_NATURAL y SORT_FLAG_CASE a array1_sort_flags como posibles banderas de ordenación.
date_default_timezone_get | La zona horaria ya no se adivina de la información disponible a través del sistema operativo, la zona horaria adivinada no puede invocarse.
date_default_timezone_get | La variable de entorno TZ ya no se usa para adivinar la zona horaria.
debug_backtrace | Añadido el parámetro opcional limit.
debug_print_backtrace | Añadido el parámetro opcional limit.
empty | Verificación de índices no numéricos de strings devuelve true.
error_reporting | Ahora E_STRICT es parte de E_ALL.
filter_input_array | Se añadió el parámetro add_empty.
filter_var_array | Se añadió el parámetro add_empty.
get_html_translation_table | El valor por defecto para el parámetro encoding se cambió a UTF-8.
get_html_translation_table | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
get_magic_quotes_runtime | Siempre devuelve false debido a que la característica de comillas mágicas ha sido eliminada de PHP.
gzcompress | Se añadió el parámetro encoding.
gzdeflate | Se añadió el parámetro encoding.
gzencode | FORCE_DEFLATE ahora genera una salida que cumple el RFC 1950.
hash | El algoritmo tiger ahora utiliza orden de byte «big-endian». Véase también el ejemplo de más abajo.
hash_algos | Se añade soporte para joaat, fnv132 y para fnv164. Soporte para Salsa10 y Salsa20 fué eliminado.
html_entity_decode | Se añadieron las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
html_entity_decode | La codificación predeterminada se cambió de ISO-8859-1 a UTF-8.
htmlentities | El valor por defecto del parámetro encoding se cambió a UTF-8.
htmlentities | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
htmlspecialchars | El valor predeterminado del parámetro encoding se cambió a UTF-8.
htmlspecialchars | Se añadieron las constantes ENT_SUBSTITUTE, ENT_DISALLOWED, ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
htmlspecialchars_decode | Fueron agregadas las constantes ENT_HTML401, ENT_XML1, ENT_XHTML y ENT_HTML5.
http_build_query | Se agregó el parámetro enc_type.
imagecolorset | Se añadió el parámetro alpha.
imagegd2 | Se añadió soporte para pasar un resource de flujo a to.
imagejpeg | Se añadió soporte para pasar un resource de flujo a to.
imagejpeg | Se deshabilitó el paso de un string vacío a filename para saltar este argumeto.
imagewebp | Se añadió soporte para pasar un resource de flujo a to.
isset | Comprobación de indices no numéricos de strings ahora retorna false.
json_decode | Se añadió el parámetro options.
mb_encode_numericentity | Añadido el parámetro is_hex.
number_format | Esta función ahora admite múltiples bytes en dec_point y thousands_sep. En versiones anteriors solamente se utilizaba el primer byte de cada separador.
ob_start | Un tamaño de segmento de 1 ahora resulta en segmentos de 1 byte que se van a enviar al búfer de salida.
ob_start | El tercer parámetro de ob_start se cambió de un parámetro boolean llamado erase (el cual, si se establecía a false, prevenía al búfer de salida de ser eliminado hasta el final de la ejecución del script) a un parámetro integer llamado flags. Desafortunadamente, esto resulta en una rotura de compatibilidad de la API para código escrito antes de PHP 5.4.0 que use el tercer parámetro. Véase el ejemplo de banderas para saber cómo manejar esto con código que necesite ser compatible con ambas.
openssl_decrypt | raw_output se cambió a options.
openssl_encrypt | raw_output se cambió a options.
preg_match_all | El parámetro matches ahora es opcional.
scandir | Se añadieron las constantes de sorting_order. En versiones anteriores, cualquir valor distinto de cero ocasionaba un ordenamiento descendente. Por lo tanto, para todas las versiones de PHP, use 0 para el orden ascendente, y 1 para el orden descendente. No existía una opción para el comportamiento de SCANDIR_SORT_NONE antes de PHP 5.4.0.
session_set_save_handler | Se añadió SessionHandlerInterface para la implementación de gestores de sesión y SessionHandler para exponer gestores de sesión internos de PHP.
sort | Se añadió el soporte para SORT_NATURAL y SORT_FLAG_CASE como sort_flags
PDOStatement::getColumnMeta | Se añadió el soporte para el controlador PDO_DBLIB
Phar::setStub | Se añadió el parámetro len.
PharData::setStub | Se añadió el parámetro len.
SimpleXMLElement::getDocNamespaces | Se añadió el parámetro from_root.
5.4 | grapheme_substr | Si se proporciona length y es positivo, y el argumento string es más corto que la longitud especificada, se devuelve el resto de la cadena de acuerdo al parámetro start. Anteriormente devolvía false.
5.3.9 | DateTime::createFromFormat | Se añadió el especficador + para format.
dl | dl está deshabilitado en PHP-FPM, aunque se desaconseja.
is_a | Se añadió el parámetro allow_string
is_subclass_of | Se añadió el parámetro allow_string
5.3.7 | crypt | Se añadieron los modos de Blowfish $2x$ y $2y$ para tratar con ataques de bit alto potenciales.
curl_getinfo | Introdujo CURLINFO_REDIRECT_URL.
is_subclass_of | Se añadió el soporte para class_name para trabajar con interfaces
5.3.6 | DateTime::modify | Las sentencias de fecha/hora absolutas ahora toman efecto. Anteriormente, sólo se utilizaban las partes relativas.
DOMDocument::saveHTML | El parámetro node fue añadido.
array_product | El producto de un array vacío ahora es 1, mientras que antes esta función devolvía 0 para un array vacío.
debug_backtrace | Se cambió el parámetro provide_object a options y se añadió la opción adicional DEBUG_BACKTRACE_IGNORE_ARGS.
debug_print_backtrace | Añadido el parámetro opcional options.
preg_match | Devuelve false si offset es mayor que la longitud de subject.
preg_match_all | Devuelve false si offset es mayor que la longitud de subject.
PDO_MYSQL DSN | Antes de la versión 5.3.6, charset era ignorado.
5.3.4 | copy | Se cambió el parámetro context para que realmente tenga efecto. Anteriormente, se ignoraba cualquier context.
get_html_translation_table | Se añadió el parámetro encoding.
mt_rand | Emite un error de nivel E_WARNING y devuelve false si max < min.
rawurlencode | Los caracteres con tilde ya no son condificados al usar rawurlencode con EBCDIC en cadenas.
sleep | Antes de PHP 5.3.4, en Windows, sleep siempre devuelve null cuando el sueño ha sucedido, si tener en cuenta si el sueño fue interrumpido o no.
strip_tags | strip_tags ignora las etiquetas de autocierre de XHTML en allowable_tags.
IntlDateFormatter::format | Se añadió el soporte para proporcionar objetos de la clase DateTime al parámetro value.
mysqli_driver::$report_mode | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.
5.3.3 | DOMXPath::evaluate | Se añadió el parámetro registerNodeNS.
DOMXPath::query | Se añadió el parámetro registerNodeNS.
ldap_sasl_bind | Se añadió soporte en Windows.
openssl_decrypt | Se añadió el parámetro iv.
openssl_encrypt | Se añadió el parámetro iv.
parse_url | Eliminado el E_WARNING que era producido cuando fallaba el análisis de la URL.
5.3.2 (PECL OCI8 1.4) | oci_set_prefetch | Antes de esta versión, rows debe ser >= 1.
5.3.2 | crypt | Agregado el crypt SHA-256 y SHA-512 basado en la implementación de Ulrich Drepper.
crypt | Corregido el comportamiento de Blowfish sobre rondas no válidas para devolver el string "failure" ("*0" or "*1"), en lugar de caer al DES.
flock | Se eliminó la liberación del bloqueo automática al cerrarse el manejador del recurso. La liberación del bloqueo ahora siempre tiene que realizarse manualmente.
gmp_init | La base fue extendidad de 2 a 36, a 2 a 62 y -2 a -36.
gmp_strval | La base fue extendida de 2 a 36, a 2 a 62 y -2 a -36.
imap_append | Se añadió el soporte de INTERNALDATE para imap_append.
imap_open | Se añadió params
SplFileObject::flock | Se eliminó el desbloqueo automático cuando se cierra el manejador de recursos del archivo. El desbloqueo ahora siempre tiene que hacerse manualmente.
5.3.1 | get_defined_constants | Sólo para Windows: las constantes fundamentales se clasifican en Core, previamente mhash.
ibase_query | Si no hay rows afectados, la función ahora devuelve true en caso de éxito, donde anteriormente devolvía 0 (un cero seguido por un espacio en blanco).
rename | rename ahora puede renombrar ficheros a través de controladores de Windows.
5.3.0 (PECL OCI8 1.3.4) | oci_set_prefetch | Antes de esta versión, la precarga estaba limitada al menor valor de rows filas y 1024 * rows bytes. La restricción del tamaño de bytes ahora ha sido eliminada.
5.3.0 | DateTime::__construct | Si time contiene un formato de fecha/hora no válido, se lanzará una excepción. Anteriormente se emitía un error.
DateTime::modify | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.
DateTime::setDate | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.
DateTime::setISODate | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.
DateTime::setTime | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.
DateTime::setTimezone | Se ha cambiado el valor devuelto en caso de éxito de null a DateTime.
DateTimeZone::getTransitions | Se añadieron los parámetros opcionales timestamp_begin y timestamp_end.
DateTimeZone::listIdentifiers | Añadidos los parámteros opcionales what y country.
DirectoryIterator::__construct | Lanza una UnexpectedValueException si path no se puede abrir.
acosh | La función esta disponible en todas las plataformas
array_multisort | Se añadió SORT_LOCALE_STRING a array1_sort_flags como posible bandera de ordenación.
array_reduce | Se cambió el parámetro initial para permitir mixed, anteriormente era integer.
array_search | Al igual que con todas las funciones internas de PHP a partir de la versión 5.3.0, array_search devuelve null si se le pasan parámetros inválidos.
asinh | La función esta disponible en todas las plataformas
atanh | La función esta disponible en todas las plataformas
call_user_func | La interpretación de palabras clave orientadas a objetos como parent y self ha cambiado. Anteriormente al llamarlas usando la sintaxis de dobles dos puntos emitiría una advertencia E_STRICT porque eran interpretadas como estáticas.
call_user_func_array | La interpretación de palabras clave orientadas a objetos como parent y self ha cambiado. Anteriormente al llamarlas usando la sintaxis de dobles dos puntos emitiría una advertencia E_STRICT porque eran interpretadas como estáticas.
checkdnsrr | Esta función está disponible en plataformas Windows.
clearstatcache | Se añadieron los parámetros opcionales clear_realpath_cache y filename.
copy | Se añadió el soporte para el contexto.
crypt | PHP ahora contiene su propia implementación de los algoritmos MD5, DES estándar, DES extendido y Blowfish y los utilizará si el sistema carece de soporte para uno o varios de los algoritmos.
curl_getinfo | Introdujo CURLINFO_CERTINFO.
curl_setopt | Se introdujo CURLOPT_PROGRESSFUNCTION.
date_default_timezone_set | Ahora se lanza un E_WARNING en vez de un E_STRICT.
dl | dl está desactivado en algunos módulos SAPI por problemas de estabilidad. Los únicos modulos SAPI que permiten dl son: CLI, CGI and Embed. En su lugar usar las directivas Directivas de carga de extensiones
error_reporting | Se introdujo E_DEPRECATED y E_USER_DEPRECATED.
exif_imagetype | Se añadió soporte para iconos.
expm1 | Esta función está ahora disponible en todas las plataformas.
fgetcsv | Se añadió el parámetro escape
fnmatch | Esta función ahora está disponible en plataformas Windows.
func_get_arg | Si esta función es llamada desde el ámbito último de un archivo que ha sido incluido mediante una llamada a include o require desde dentro de una función en el archivo de llamada, ahora genera una advertencia y devuelve false.
func_get_arg | Esta función ahora se puede usar en listas de parámetros.
func_get_args | Esta función ahora se puede usar en listas de parámetros.
func_get_args | Si esta función es llamada desde el ámbito último de un archivo que ha sido incluido mediante una llamada a include o require desde dentro de una función en el archivo de llamada, ahora genera una advertencia y devuelve false.
func_num_args | Si esta función es llamada desde el ámbito último de un fichero que ha sido incluido mediante una llamada a include o require desde dentro de una función en el fichero de llamada, ahora genera una advertencia y devuelve -1.
func_num_args | Esta función ahora se puede usar en listas de parámetros.
gd_info | El atributo JPG Support se renombró a JPEG Support.
get_cfg_var | get_cfg_var se fijó para ser capaz de retornar un "array" con las opciones ini.
get_class | El valor predeterminado de object ahora es null, por lo que pasar el valor null a object tiene el mismo resultado que no pasar ningún valor.
get_defined_constants | Constantes fundamentales se clasifican en Core, antes internal. En Windows, las constantes fundamentales se clasifican en mhash.
get_object_vars | Esta función ahora devuelve null si object no es un objeto. Anteriormente devolvía false
getimagesize | Se añadió el soporte para iconos.
getmxrr | Esta función ahora está disponible en plataformas Windows.
getopt | Esta función ya no depende del sistema y funciona también en Windows.
getopt | Añadido soporte para valores opcionales (especificado mediante "::").
getopt | El parámetro longopts está disponible en todos los sistemas.
getopt | Añadido soporte para usar "=" como separador de argumento/valor.
hash_algos | Se añade soporte para md2, ripemd256, ripemd320, salsa10, salsa20, snefru256 y para sha224
htmlentities | Se añadió la constante ENT_IGNORE.
htmlspecialchars | Se añadió la constante ENT_IGNORE.
imagecolorclosesthwb | Está función ahora está disponible en Windows
imagefilter | Se añadió el soporete de pixelación (IMG_FILTER_PIXELATE).
inet_ntop | Esta función ahora está disponible en plataformas Windows.
inet_pton | Esta función ahora está disponible en plataformas Windows.
ini_get | Anteriormente, se devolvía un string si la opción de configuración no existía. Ahora en su lugar se devuelve false.
ini_get_all | Se añadió details.
is_a | Esta función ya no está obsoleta, y por lo tanto ya no lanza advertencias de tipo E_STRICT.
json_decode | Se añadió el parámetro opcional depth. La profundidad de recursividad predeterminada se aumentó de 128 a 512
link | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o superiores).
linkinfo | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o mayores).
log1p | Esta función está disponible en todas las plataformas.
mb_get_info | Está disponible la entrada "http_output_conv_mimetypes".
mcrypt_create_iv | MCRYPT_DEV_RANDOM y MCRYPT_DEV_URANDOM se volvieron disponibles en plataformas Windows.
mcrypt_create_iv | Ya no se requiere invocar primero a srand. Esto ahora se realiza de forma automática.
mktime | mktime ahora lanza un aviso de tipo E_DEPRECATED si se usa el parámetro is_dst.
mysql_db_query | Ésta función ahora lanza ahora un aviso E_DEPRECATED.
mysql_escape_string | Ahora, esta función lanza un aviso E_DEPRECATED.
nl2br | Se agregó el parámetro opcional is_xhtml. Antes de esta versión, siempre se insertaba '<br />'.
openssl_seal | Se añadió el parámetro method.
preg_quote | El carácter - ahora es escapado
property_exists | Esta función comprueba la existencia de una propiedad independientemente de su accesibilidad.
rawurlencode | Ahora sigue el RFC 3986.
readlink | Esta función ahora está disponible en plataformas Windows (Vista, Server 2008 o mayores).
realpath | Antes de esta versión, si en sistemas *BSD el último componente de path no existía, realpath no fallaba. Ahora realpath también falla en este caso.
register_tick_function | Los ticks ahora están soportados en los módulos de servidores web que usan hilos.
round | Se introdujo el parámetro mode.
session_start | Si una sesión falla al iniciarse, se devuelve false. Anteriormente se devolvía true.
setlocale | Está función ahora emite un aviso E_DEPRECATED si se pasa un string al parámetro category en lugar de una de las constantes LC_*.
shm_attach | Esta función ahora devuelve un recurso en vez de un integer.
socket_create_pair | Esta función ya está disponible en las plataformas de Windows.
spl_autoload_register | Se añadio el parámetro prepend.
spl_autoload_register | Se introdujo el soporte para espacios de nombres.
stream_context_create | Se añadió el argumento opcional params.
stream_socket_pair | Esta función ahora está disponible en plataformas Windows.
stristr | Agregado el parámetro opcional before_needle.
strlen | Las versiones anteriores trataban los arrays como el string Array, devolviendo así una longitud de string de 5 y emitiendo un error de nivel E_NOTICE.
strstr | Se añadió el parámetro opcional before_needle.
strtotime | Antes de PHP 5.3.0, formatos de tiempo relativo que se suministran al parámetro time de la función strtotime como this week, previous week, last week, y next week se interpreta como un período de 7 días en relación con la fecha y hora actual, en lugar de un período de semana de Monday a Sunday.
strtotime | Antes de PHP 5.3.0, 24:00 no era un formato válido y strtotime devolvía false.
symlink | Esta función ahora es compatible con las plataformas Windows (Vista, Server 2008 o superior).
time_nanosleep | Esta función ahora está disponible en plataformas Windows.
time_sleep_until | Esta función ahora está disponible en plataformas Windows.
touch | Se hizo posible cambiar el momento de modificación de un directorio bajo Windows.
mysqli::__construct | Se añadió la capacidad de conexiones persistentes.
mysqli::options | Se añadierons las opciones MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, y MYSQLI_OPT_SSL_VERIFY_SERVER_CERT.
mysqli::query | Se agregó la posibilidad de realizar consultas asíncronas.
ReflectionFunction::__construct | ahora name puede representar una función anónima.
SplFileObject::setCsvControl | Añadido el parámetro escape.
SplObjectStorage::attach | Añadido el parámetro data.
5.2.15 | mysqli_driver::$report_mode | El cambio de modo de notificación ahora es por solicitud, en vez de por proceso.
5.2.11 | get_defined_constants | El parámetro categorize ahora funciona correctamente. Anteriormente, el parámetro categorize era interpretado como !is_null($categorize), por lo que cualquier valor distinto de null fuerza a las constantes a ser clasificadas.
5.2.10 | array_rand | El array de claves resultante ya no se mezcla.
array_unique | Se volvió a cambiar el valor predeterminado de sort_flags a SORT_STRING.
curl_setopt | Se introdujo CURLOPT_PROTOCOLS, y CURLOPT_REDIR_PROTOCOLS.
ip2long | Antes de esta versión, ip2long según como devolverá un número válido incluso si el valor no es una dirección con puntos (IPv4) Internet Protocol.
natsort | Las cadenas numéricas rellenadas con ceros (p.ej., '00005') ahora ignoran el relleno de 0.
5.2.9 | array_unique | Se añadió el parámetro opcional sort_flags con el valor predeterminado SORT_REGULAR. Antes de 5.2.9, esta función se usaba para ordenar el array con SORT_STRING internamente.
5.2.8 | XSLTProcessor::importStylesheet | Acepta SimpleXMLElement de nuevo; no funcionaba desde PHP 5.2.6.
5.2.7 | error_log | El valor posible de 4 se añadió a message_type.
round | El funcionamiento interno en round se modificó para adecuarse al estándar C99.
strtotime | En PHP 5 anterior a 5.2.7, las peticiones de una incidencia de un día de la semana dado en un mes donde ese día de la semana era el primer día del mes, añadía incorrectamente una semana a la marca de tiempo devuelta. Esto ha sido corregido en 5.2.7 y versiones posteriores.
5.2.6 | fopen | Se añadieron las opciones 'c' y 'c+'
5.2.5 | addcslashes | Se añadieron las secuencias de escape \v y \f.
debug_backtrace | Se añadió el parámetro opcional provide_object.
imagefilter | Se añadió el soporte de alfa para IMG_FILTER_COLORIZE.
5.2.4 | array_slice | El valor predeterminado del parámetro length se cambió a NULL. Una length NULL ahora indica a la función que use la longitud de array. Antes de esta versión, una length NULL se tomaba como de longitud cero (no se devolvía nada).
checkdnsrr | Se añadió el type TXT.
curl_getinfo | Introdujo CURLINFO_PRIVATE.
curl_setopt | Se introdujo CURLOPT_PRIVATE.
get_loaded_extensions | Fue añadido el parámetro opcional zend_extensions
ldap_first_attribute | ber_identifier ha sido retirado. Este ahora es manejado automáticamente por PHP.
ldap_next_attribute | El parámetro ber_identifier fue removido. Este se maneja ahora automáticamente por PHP.
stream_wrapper_register | Añadido el parámetro flags.
5.2.3 | getimagesize | Los errores de lectura generados por esta función se degradaron desde E_WARNING a E_NOTICE.
htmlentities | Se añadió el parámetro double_encode.
htmlspecialchars | Se añadió el parámetro double_encode.
json_decode | La profundidad de recursividad predeterminada se aumentó de 20 a 128
PDOStatement::getColumnMeta | El campo table
5.2.2 - 5.2.6 | substr | Si el parámetro start indica una posición negativa de truncamiento o más allá, se devolverá false. En otras versiones de PHP obtienen la cadena desde el principio.
5.2.2 | DOMDocument::registerNodeClass | Antes de 5.2.2, una extendedclass previamente registrada teniá que ser desregistrada antes de poder registrar una nueva clase que extendiese a la misma baseclass.
ftp_ssl_connect | La función se ha cambiado para devolver false cuando no se puede utilizar una conexión SSL, en lugar de recurrir a una conexión no-SSL como hacía en versiones anteriores.
phpinfo | Se añadió la información del "Fichero de configuración cargado", mientras que anteriormente solo existía "Ruta del fichero de configuración (php.ini).
preg_match | Los sub-patrones nominados ahora aceptan la sintaxis (?<nombre>) y (?'nombre') así como (?P<nombre>). Las versiones anteriores sólo aceptaban (?P<nombre>).
preg_match_all | Los sub-patrones nominados ahora aceptan la sintaxis (?<nombre>) y (?'nombre') así como (?P<nombre>). Versiones anteriores sólo aceptaban (?P<nombre>).
proc_terminate | Versiones previas usadas para destruir el recurso de un proceso dado.
token_get_all | Los números de línea son devueltos en el elemento 2
5.2.1 | iterator_to_array | Añadido el parámetro use_keys.
json_decode | Se añadió soporte para la decodificación de JSON de tipos básicos.
memory_get_peak_usage | Compilar con --enable-memory-limit ya no es necesario para que esta función exista.
memory_get_usage | Compilar con --enable-memory-limit ya no es necesario para que exista esta función.
mt_srand | La implementación de Mersenne Twister en PHP ahora usa un nuevo algoritmo para la semilla de Richard Wagner. La misma semilla ahora ya no produce la misma secuencia de valores como sucedía en anteriores versiones. No se espera que se vuelva a cambiar de nuevo este comportamiento, aunque, no obstante, se considera inseguro confiar en él.
proc_open | Añadida la opción bypass_shell al parámetro other_options.
realpath | Antes de esta versión, realpath devolvía false si path era un string vacío o null.
5.2.0 | base64_decode | Añadido strict
curl_multi_info_read | msgs_in_queue fue añadido.
error_reporting | Se introdujo E_RECOVERABLE_ERROR.
imagettftext | Ahora es posible especificar una entidad hexadecimal en text.
imap_open | Se añadió n_retries
imap_reopen | Se añadió n_retries
mb_strrpos | Se añadió el parámetro opcional offset.
memory_get_peak_usage | Se añade real_usage.
memory_get_usage | Se añadió real_usage.
openssl_verify | Se añadió el parámetro signature_alg.
pathinfo | Se añadió la constante PATHINFO_FILENAME.
pg_escape_bytea | Se agregó el parámetro connection
session_get_cookie_params | La entrada "httponly" fue añadida en la matriz devuelta.
session_set_cookie_params | Se añadió el parámetro httponly.
set_error_handler | El gestor de errores debe devolver false para rellenar $php_errormsg.
setcookie | Se añadió el parámetro httponly.
setrawcookie | Se añadió el parámetro httponly.
simplexml_load_file | Se añadió el parámetro opcional is_prefix.
simplexml_load_string | Se añadió el parámetro opcional is_prefix.
PDOStatement::execute | Las claves de input_parameters deben coincidir con aquellas declaradas en la sentencia SQL. Antes de PHP 5.2.0 esto se ignoraba silenciosamente.
SimpleXMLElement::attributes | Se añadió el parámetro opcional is_prefix.
SimpleXMLElement::children | Se añade el parámetro opcional is_prefix.
SimpleXMLElement::__construct | Añadidos los parámetros ns y is_prefix.
XMLReader::open | encoding y options fueron agregadas.
XMLReader::XML | encoding ay options fueron agregados.
5.1.3 | DirectoryIterator::__construct | Lanza una RuntimeException si path es una cadena vacía.
curl_getinfo | Introdujo CURLINFO_HEADER_OUT.
get_headers | Esta función usa el contexto de secuencia predeterminado, el cual puede ser definido/modificado con la función stream_context_set_default.
http_build_query | Los corchetes cuadrados son escapados.
imagecolorallocate | Devuelve false si falló la asignación. Anteriormente devolvía -1.
imagecolorallocatealpha | Devuelve false si falló la asignación. Anteriormente devolvía -1.
imagepng | Añadido el parámetro filters.
mb_get_info | Están disponibles las entradas "mail_charset", "mail_header_encoding", y "mail_body_encoding".
SoapClient::__doRequest | Se añadió el parámetro one_way.
XMLReader::getAttribute | Devuelve null si no se encuentra ningún atributo. Antes, devolvía una cadena de texto vacía.
5.1.2 | date_default_timezone_set | La función comenzo a validar el parámetro timezone_identifier.
header | Esta función ahora previene que se pueda enviar más de un encabezado a la vez como protección en contra de ataques de inyección de encabezados.
http_build_query | Se agregó el parámetro arg_separator.
imagepng | Añadido el parámetro quality.
parse_url | Se agregó el parámetro component.
SimpleXMLElement::__construct | Añadidos los parámetros options y data_is_url.
5.1.1 | date | Hay constantes útiles de los formatos estándar de fecha/hora que pueden utilizarse para especificar el parámetro format.
debug_backtrace | Se añadió el object actual como posible elemento devuelto.
gmdate | Hay constantes útiles de formatos de fecha/hora estándar que se pueden usar para especificar el parámetro format.
5.1.0 | DirectoryIterator::__construct | Lanza una RuntimeException en caso de error. Anteriormente lanzaba una Exception.
DOMDocument::save | Se añadió el parámetro options
DOMDocument::saveXML | Se añadió el parámetro options
class_implements | Añadida la opción para pasar el parámetro class como un string. Añadido el parámetro autoload.
class_parents | Añadida la opción para pasar el parámetro class como un string. Añadido el parámetro autoload.
ctype_digit | En versiones anteriores a PHP 5.1.0, esta función devolvía true cuando text era una cadena vacía.
curl_setopt | Se introdujo CURLOPT_AUTOREFERER, CURLOPT_BINARYTRANSFER, CURLOPT_FTPSSLAUTH, CURLOPT_PROXYAUTH, y CURLOPT_TIMECONDITION.
date | El rango válido de una marca de tiempo es típicamente desde Fri, 13 Dec 1901 20:45:54 GMT a Tue, 19 Jan 2038 03:14:07 GMT. (Estas son las fechas que corresponden a los valores mínimo y máximo de un entero con signo de 32 bit). Sin embargo, antes de PHP 5.1.0 este rango estaba limitado desde 01-01-1970 a 19-01-2038 en algunos sistemas (p.ej. Windows).
date | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
date_sunrise | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
date_sunset | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
explode | Se añadió soporte para limit negativo.
fgetcsv | El parámetro length ahora es opcional. El valor predeterminado es 0, significando sin límite de longitud.
file_get_contents | Se añadieron los parámetros offset y maxlen.
file_put_contents | Añadido el soporte para LOCK_EX y la capacidad de pasar un recurso de flujo al parámetro data
get_parent_class | Si se llamaba sin parámetro fuera del objeto, está función devolvía null con una advertencia, pero ahora devuelve false.
gettimeofday | Se añadió el parámetro return_float.
glob | Se añadió GLOB_ERR
gmdate | El rango válido de una marca de tiempo es típicamente desde Fri, 13 Dec 1901 20:45:54 GMT a Tue, 19 Jan 2038 03:14:07 GMT. (Estas son las fechas que corresponden a los valores mínimo y máximo de un entero con signo de 32-bit). Sin embargo, antes de PHP 5.1.0 este rango estaba limitado desde 01-01-1970 a 19-01-2038 en algunos sistemas (p.ej. Windows).
gmmktime | A partir de PHP 5.1.0, el parámetro is_dst se volvió obsoleto. Como resultado, se podría usar en su lugar las nuevas características de manejo de zonas horarias.
idate | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
imagerotate | Se añadió ignore_transparent.
intval | Lanza E_NOTICE y devuelve 1, cuando se pasa un objecto a var.
localtime | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
md5_file | Se modificó la función para usar la API de secuencias. Esto quiere decir que se puede usar con envolturas, como md5_file('http://example.com/..')
mktime | Cuando se hace la llamada sin argumento, mktime lanza un aviso E_STRICT. Use la función time en su lugar.
mktime | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
mktime | El parámetro is_dst se volvió obsoleto. Hacía que la funcion devolviese false si se pruducía un error, en vez de -1. Arreglada la función para que acepte el año, mes y día pasados como cero.
openssl_pkcs7_verify | Se añadió el parámetro content.
preg_replace | Añadido el parámetro count
preg_replace_callback | Se añadió el parámetro count
session_regenerate_id | Añadido el parámetro delete_old_session.
sha1_file | Cambiada la función para utilizar el API de flujo de datos. Esto significa que se puede utilizar con envolturas, como en sha1_file('http://ejemplo.com/..')
str_word_count | Agregado el parámetro charlist
stream_copy_to_stream | Se añadió el parámetro offset
stream_filter_append | Antes de PHP 5.1.0, esta función devolvía true si se tuvo éxito o false en caso de error.
stream_filter_prepend | Antes de PHP 5.1.0, esta función devolvía true en caso de éxito o false en caso de error.
stream_get_contents | Se añadió el parámetro offset.
strftime | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
strtotime | Ahora devuelve false si falla, en vez de -1.
strtotime | Ahora muestra un error E_STRICT y E_NOTICE cuando ocurren errores con zonas horarias.
substr_compare | Se añadió la posibilidad de usar un offset negativo.
substr_count | Los parámetros offset y length fueron agregados
var_export | Posibilidad de exportar las clases y los arrays que contienen las clases utilizando el método mágico __set_state.
XSLTProcessor::registerPHPFunctions | Se añadió el parámetro restrict.
5.0.3 | get_class_vars | get_class_vars devolverá sólo las propiedades que pueden ser accedidas desde el ámbito actual.
is_subclass_of | Es posible especificar también el parámetro object como una cadena (el nombre de la clase)
5.0.2 | array_slice | Se añadió el parámetro opcional preserve_keys.
class_exists | Ya no devuelve true para interfaces definidas. En ese caso se debe usar interface_exists.
get_class_vars | Al llamar a get_class_vars ahora se expondrán todas las propiedades como una matriz, a diferencia del comportamiento anterior donde las propieades protected y private eran prefijadas con bytes nul.
sort | Se añadió SORT_LOCALE_STRING
strtotime | En PHP 5 hasta 5.0.2, "now" y otros momentos relativos son computados erróneamente como la medianoche de hoy. Esto difiere de otras versiones donde es computado como el momento actual.
5.0.1 | get_class_vars | Al llamar a get_class_vars se expondrán todas las propiedades, como cuando se convierte un objeto en una clase.
5.0.0 | curl_setopt | Se introdujo CURLOPT_FTP_USE_EPRT, CURLOPT_NOSIGNAL, CURLOPT_UNRESTRICTED_AUTH, CURLOPT_BUFFERSIZE, CURLOPT_HTTPAUTH, CURLOPT_PROXYPORT, CURLOPT_PROXYTYPE, CURLOPT_SSLCERTTYPE, y CURLOPT_HTTP200ALIASES.
is_a | Esta funcion se volvió obsoleta en favor del operador instanceof. Llamar a esta función resultará en una advertencia de tipo E_STRICT.
opendir | ruta soporta dentro de la URL la envoltura ftp://.
rename | rename ahora también puede emplearse con algunas envolturas de URL. Consulte para un listado de las envolturas que admite rename.
strip_tags | strip_tags ahora es segura a nivel binario.
strrpos | needle puede ser ahora un string de más de un carácter.
strtotime | Los microsegundos comenzaron a estar permitidos, pero son ignorados.


HTML edición de ayuda

  • Sobre Esta Edición
  • Uso de la Edición CHM del Manual de PHP
    • La Barra de Herramientas de la Ayuda HTML
    • El Panel de Navegación
    • Combinaciones de Teclado
  • La Búsqueda de Texto Completo
    • Reglas generales de búsqueda
    • Búsquedas sobre palabras o frases
    • Definición de términos de búsqueda
    • Uso de expresiones anidadas en búsquedas
  • Integración del manual de PHP


Sobre Esta Edición

La Edición de Ayuda HTML Windows del Manual de PHP está dirigida a desarrolladores, quienes desean tener el manual a mano todo el tiempo, y desean leer páginas del manual y notas de usuarios sin tener que esperar a que descargue una página web remota. Esta edición le ofrece el contenido completo del manual más las anotaciones de usuarios, con algunas excelentes características adicionales ofrecidas por la aplicación visora, por los scripts que usamos para generar éste formato y por otros contribuyentes en forma de skins.

Esta distribución del manual de PHP contiene varios archivos, incluyendo el archivo principal del manual, php_manual_en.chm. Puede ver el manual haciendo doble clic sobre éste archivo (tal y como ya lo habrá adivinado). También puede ver un archivo php_manual_en.chw en el directorio, éste es generado la primera vez que usa la pestaña del índice, y contiene un índice con las páginas del manual.

Para aquellos interesados en los detalles técnicos del formato Microsoft HTML Help, » http://www.helpware.net/ constituye un excelente recurso. Para más información, y saber del lugar de Windows HTML Help entre los formatos de ayuda de Microsoft y su historia de servicios, consulte este » artículo de WinWriters.


Uso de la Edición CHM del Manual de PHP

Tabla de contenidos

  • La Barra de Herramientas de la Ayuda HTML
  • El Panel de Navegación
  • Combinaciones de Teclado

Cuando realiza doble-clic sobre un archivo CHM, una ventana del Visor de Ayuda HTML es abierta con tres páneles. En el lado izquierdo de la ventana se encuentra el panel de Navegación. Éste contiene cuatro solapas de navegación: las solapas de Contenido, índice, Búsqueda y Favoritos. En el lado derecho de la ventana se encuentra el panel de Tópico. Éste despliega el tema de ayuda seleccionado, o el tema de ayuda predeterminado en el arranque. Las páginas de ayuda son todas archivos HTML separados, su instalación de Internet Explorer despliega las páginas en el panel de Tópico. El tercer panel es la barra de herramientas, la cual está ubicada por debajo de la barra de título de la ventana de ayuda. Puede ajustar la apariencia horizontal al arrastrar el borde vertical entre el panel de Navegación y el panel de Tópico.

Note que cuando abre el documento CHM por primera vez, puede aparecer con una posición y tamaño extraños. Desde entonces, windows recuerda la posición de la ventana, su tamaño y la solapa abierta por última vez. Toda esta información, incluyendo sus favoritos, es almacenada en un archivo llamado hh.dat. Si mueve su archivo a otro directorio, todas estas preferencias recordadas se perderán (¡incluyendo su lista de favoritos!). Aunque, si reemplaza su archivo CHM por uno nuevo, con el mismo nombre, no será un problema. Los nombres de archivo y valores de ruta son almacenados en hh.dat.


La Barra de Herramientas de la Ayuda HTML

La Barra de Herramientas de la Ayuda HTML contiene los siguientes íconos, cuando se encuentra consultando el Manual de PHP:

  • Esconder/Mostrar - Esconde/muestra el panel de navegación.
  • Ubicar - Ubica un tópico en la solapa de contenidos (en caso de que haya encontrado un tópico a travÉs de la búsqueda, el índice o los favoritos, y quisiera ver en dónde se encuentra en la vista de árbol de la tabla de contenidos).
  • Atrás - Va hacia atrás en el historial.
  • Adelante - Va hacia adelante en el historial.
  • Refrescar - Recarga la página actual.
  • Inicio - Abre la página de inicio del documento CHM.
  • Imprimir - Abre el cuadro de diálogo de impresión.
  • Opciones - Provee una lista con más opciones.
El uso de esta barra de herramientas es realmente sencillo, muchos de los íconos de la barra de herramientas están relacionados fuertemente con sus equivalentes en Internet Explorer.


El Panel de Navegación

El Panel de Navegación contiene cuatro solapas de navegación: las solapas de Contenido, índice, Búsqueda y Favoritos. Éstas proveen mÉtodos diferentes para acceder a un tópico en el archivo de ayuda.

  • La solapa de contenidos revela una tabla de contenidos en forma de árbol, en donde puede navegar al tópico deseado al abrir y cerrar partes del árbol. Puede incluso acceder a las secciones más profundas usando Ésta tabla de contenidos. Si hace clic derecho sobre un item aquí y selecciona "Imprimir...", tendrá la opción de imprimir el tópico seleccionado o el tópico seleccionado junto con todos los sub-temas. Sin embargo, la impresión no es el objetivo inicial de esta versión del manual (la versión PDF es apropiada para su impresión).
  • La solapa de índice lista un gran número de "palabras clave" (en realidad, títulos de páginas del manual). Puede seleccionar una, o comenzar a escribir una palabra clave, ver la lista ajustarse a su entrada, y luego hacer clic sobre un tema, o presionar enter si el tema seleccionado es el que desea consultar.
  • La solapa de búsqueda muestra una de las características más poderosas del Visor de Ayuda HTML, la búsqueda de texto completo (tambiÉn conocida como FTS, por sus siglas en InglÉs). Aquí puede escribir su expresión de búsqueda, conectando palabras opcionalmente con AND/OR/NEAR/NOT. Antes de que haga clic sobre 'Listar temas', tambiÉn puede definir algunas opciones en la parte baja. Luego de que los resultados de búsqueda son desplegados, notará que el texto del manual y los resultados de notas de usuario son separados. Para ordenar ambos tipos, pulse sobre la cabecera de la columna 'Ubicación'. Ahora, desde la lista de resultados de la búsqueda, puede seleccionar un tema, y ver su página. Las palabras que ha buscado son resaltadas en la página.
  • La solapa de favoritos le permite guardar una lista con los temas más usados, para su fácil acceso. Aquí puede ver la lista, agregar un tema a ella, eliminar un tema, o desplegar un item seleccionado. TambiÉn puede especificar su propio título para el favorito, escribiÉndolo en el cuadro 'Tema actual:'. Los títulos de páginas de notas de usuario son precedidos de la cadena 'N:', de modo que pueda distinguirlas de las páginas normales del manual en el listado de favoritos.


Combinaciones de Teclado

Hay varias combinaciones de teclas que puede usar para incrementar su productividad. Muchos usuarios encuentran más cómodo usar Éstas combinaciones de teclado para acceder a los temas, en lugar de hacer uso de clics.

Combinaciones de Teclado Generales del Visor de Ayuda
Para | Presione
Cerrar el Visor de Ayuda | ALT+F4
Mostrar el menú de Opciones | ALT+O
Esconder o mostrar el panel de Navegación | ALT+O, y luego T
Imprimir un tema | ALT+O, y luego P
Moverse al tema anterior | ALT+FLECHA IZQUIERDA
Moverse al tema siguiente (provisto que lo ha visitado anteriormente) | ALT+FLECHA DERECHA
Activar o desactivar el resaltado de búsquedas. | ALT+O, y luego O
Regresar al inicio del archivo de ayuda | ALT+O, y luego H
Cambiar entre el panel de Navegación y el panel de Tópico | F6
Desplazarse a travÉs de todos los enlaces en un tema o a travÉs de todas las opciones en una solapa del panel de Navegación | TAB
Mostrar el menú de contexto (clic derecho) | SHIFT+F10
Combinaciones de Teclado de la Solapa de Contenidos
Para | Presione
Mostrar la solapa de Contenidos | ALT+C
Abrir y cerrar un libro o carpeta | SIGNO MáS y SIGNO MENOS, o FLECHA IZQUIERDA y FLECHA DERECHA
Seleccionar un tema | FLECHA HACIA ABAJO y FLECHA HACIA ARRIBA
Mostrar el tema seleccionado | ENTER
Combinaciones de Teclado de la Solapa de índice
Para | Presione
Mostrar la solapa de índice | ALT+N
Escribir una palabra clave a buscar | ALT+W, y luego escriba la palabra
Seleccionar una palabra clave en la lista | FLECHA HACIA ABAJO y FLECHA HACIA ARRIBA
Mostrar el tema asociado | ENTER o ALT+D
Combinaciones de Teclado de la Solapa de Búsqueda
Para | Presione
Mostrar la solapa de Búsqueda | ALT+S
Escribir una palabra clave a buscar | ALT+W, y luego escriba la palabra
Iniciar una búsqueda | ALT+L
Seleccioner un tema en la lista de resultados | ALT+T, y luego FLECHA HACIA ABAJO y FLECHA HACIA ARRIBA
Mostrar el tema seleccionado | ENTER o ALT+D
Buscar por una palabra clave en la lista de resultados de una búsqueda previa | ALT+U
Buscar por palabras similares a la palabra clave. Por ejemplo para encontrar palabras como "corriendo" y "corre" para la palabra clave "correr" | ALT+M
Buscar sólo a travÉs de los títulos de los temas | ALT+R
Combinaciones de Teclado de la Solapa de Favoritos
Para | Presione
Mostrar la solapa de Favoritos | ALT+I
Agregar el tema mostrado actualmente a la lista de Favoritos | ALT+A
Seleccionar un tema en la lista de Favoritos | ALT+P, y luego FLECHA HACIA ABAJO y FLECHA HACIA ARRIBA
Mostrar el tema seleccionado | ENTER o ALT+D
Eliminar el tema seleccionado de la lista | ALT+R
Combinaciones de Teclado del Panel de Tópico
Para | Presione
Consultar en el índice | Seleccione las palabras que quiere consultar y presione F1
Encontrar en la página | CTRL+F, y luego ajuste las opciones
Refrescar la página | F5


La Búsqueda de Texto Completo

Tabla de contenidos

  • Reglas generales de búsqueda
  • Búsquedas sobre palabras o frases
  • Definición de términos de búsqueda
  • Uso de expresiones anidadas en búsquedas

Esta edición del Manual de PHP incluye una característica avanzada de búsqueda de texto completo ofrecida por la aplicación visora. Esto le permite a los usuarios buscar por cada palabra en el archivo de ayuda para encontrar una coincidencia. Por ejemplo, si un usuario realiza una búsqueda de texto completo sobre la palabra "Apache", cada tópico que contega la palabra "Apache" será listado. La búsqueda de texto completo le permite a un usuario efectuar búsquedas usando expresiones anidadas, booleanas y comodines. Un usuario también puede limitar la búsqueda a resultados previos, coincidencias con palabras similares, o buscar únicamente en títulos de temas.

El uso de la característica de búsqueda es bastante directo. Pulse sobre la solapa de búsqueda, escriba las palabras deseadas y presione ENTER (o pulse sobre "Listar Tópicos"). Entonces recibirá una lista de coincidencias del Manual de PHP (y las notas). Puede usar el botón con una flecha derecha y agregar operadores booleanos a su búsqueda (o puede escribirlos). Como puede ver en los resultados, puede usar las cabeceras de columna (Título, Ubicación y Rango) para ordenar la lista de tópicos. El orden predeterminado es por Rank. También puede ordenar algunos parámetros al final de la ésta solapa.

Las palabras encontradas son resaltadas en la página actual del panel de Tópico por defecto. Puede deshabilitar ésta característica seleccionando el item "Search Highlight Off" en el menú de Opciones. Si está observando un tópico largo, sólo las primeras 500 instancias de una palabra o frase de búsqueda serán resaltadas, debido a una limitación del visor.


Reglas generales de búsqueda

Una búsqueda básica consiste de la palabra o frase que desea encontrar. Puede usar expresiones con comodines, expresiones anidadas, operadores booleanos, coincidencias de palabras similares, una lista de resultados previos, o títulos de temas para refinar su búsqueda.

Las reglas básicas para formular consultas son las siguientes:

  • Las búsquedas no son sensibles a mayúsculas y minúsculas, de modo que puede escribir su búsqueda usando cualquier estilo.
  • Puede realizar búsquedas sobre cualquier combinación de letras (a-z) y números (0-9). No puede realizar búsquedas sobre letras sencillas (a, b, c, etc.) y palabras comunes, como: un, y, como, en, pero, por, para, tener, el, en, eso, no, de, sobre, ella, alla, esto, nosotros, cual, con, usted.
  • Los signos de puntuación como el punto (.), los dos-puntos (:), el punto-y-coma (;), la coma (,), y el guión (-) son ignorados durante una búsqueda.
  • Agrupe los elementos de su búsqueda usando comillas dobles o paréntesis para separar cada elemento. No puede hacer búsquedas sobre signos de comillas.

Nota:

Si está buscando por un nombre de archivo con una extensión, debe agrupar la cadena completa en comillas dobles, ("nombre_archivo.ext"). De otra forma, el punto separará el nombre de archivo en dos términos diferentes. La operación predeterminada entre términos es AND, de modo que creará el equivalente lógico de "nombre_archivo AND ext".


Búsquedas sobre palabras o frases

Puede realizar búsquedas sobre palabras o frases y usar expresiones con comodines. Las expresiones con comodines le permiten buscar por uno o más caracteres usando un signo de interrogación o un asterisco. La siguiente tabla describe los resultados de éstos tipos distintos de búsqueda.

Búsquedas por palabra y frase
Buscar por | Ejemplo | Resultados
Una palabra sencilla | seleccionar | Tópicos que contienen la palabra "seleccionar". (También encontrará sus variaciones gramaticales, como "seleccionador" y "selección".)
Una frase | "nuevo operador" o nuevo operador | Tópicos que contienen la frase literal "nuevo operador" y todas sus variaciones gramaticales. Sin las comillas, la consulta es equivalente a especificar "nuevo AND operador,", lo que encontrará los tópicos que contienen ambas palabras individuales, en lugar de la frase.
Expresiones comodín | esc* o HT?? | Los resultados del primer ejemplo incluyen los tópicos que contengan los términos "ESC", "escapar", "escalabilidad", y demás. El asterisco no puede ser el único caracter en el término. Los resultados para el segundo ejemplo incluyen los tópicos que contengan los términos "HTTP", "HTML" y demás. El signo de interrogación no puede ser el único caracter en el término.

Nota:

Seleccione el campo "Match similar words" para incluir variaciones gramaticales menores de la frase que busca. Esta característica solo ubica variacones de la palabra con sufijos comunes. Por ejemplo, una búsqueda sobre la palabra "add", encontrará "added," pero no encontrará "additive". Esta opción es independiente de otras opciones o sintaxis. Si realiza una búsqueda sólo sobre títulos, las variaciones del títulos serán consideradas. Si usa comillas (o cualquier otro operador de consulta), puede aparecer cualquier variación de la palabra; por ejemplo "stemmed search" también coincidirá con "stemming search".


Definición de términos de búsqueda

Los operadores AND, OR, NOT y NEAR le permiten definir con precisión su búsqueda, creando una relación entre términos de búsqueda. La siguiente tabla le muestra cómo puede mostrar cada uno de estos operadores. Si no se especifica un operador, se usa AND. Por ejemplo, la consulta "servidor cgi seguridad" es equivalente a "servidor AND cgi AND seguridad".

Operadores de búsqueda
Buscar por | Ejemplo | Resultados
Ambos términos en el mismo tópico | http AND apache | Tópicos que contienen las palabras "http" y "apache".
Cualquier término en un tópico | ming OR swflib | Tópicos que contienen ya sea la palabra "ming" o la palabra "swflib", o ambas.
El primer término sin el segundo | xml NOT expat | Tópicos que contienen la palabra "xml", pero no la palabra "expat".
Ambos términos en el mismo tópico, cerca uno del otro | database NEAR security | Tópicos que contienen la palabra "database" a ocho palabras de distancia de la palabra "security".

Nota:

Los caracteres |, &, y ! pueden ser usados también en lugar de OR, AND y NOT respectivamente. Puede que esto no funcione si usa una versión antigua del visor.


Uso de expresiones anidadas en búsquedas

Las expresiones anidadas le permiten crear búsquedas de información complejas. Por ejemplo "html AND ((smtp OR pop3) NEAR mail)" encuentra tópicos que contienen la palabra "html" junto con las palabras "smtp" y "mail" cercanas una de la otra, o que contengan "html" junto con las palabras "pop3" y "mail" cercanas entre sí.

Las reglas básicas para buscar tópicos de ayuda usando expresiones anidadas son las siguientes:

  • Puede usar paréntesis para anidar expresiones al interior de una consulta. Las expresiones entre paréntesis son evaluadas antes del resto de la consulta.
  • Si una consulta no contiene una expresión anidada, ésta es evaluada de izquierda a derecha. Por ejemplo: "mail NOT pop3 OR smtp" encuentra los tópicos que contienen la palabra "mail" sin la palabra "pop3", o tópicos que contienen la palabra "smtp". Por otra parte, "mail NOT (pop3 OR smtp)" encuentra los tópicos que contienen la palabra "mail" sin ninguna de las palabras "pop3" ni "smtp".
  • No puede anidar expresiones con más de cinco niveles de profundidad.


Integración del manual de PHP

Nota:

La información ofrecida aquí está dirigida principalmente a autores de IDEs, o usuarios avanzados que quisieran integrar éste archivo CHM con sus IDEs favoritos u otros componentes de entornos de producción.

Existen varios editores en la actualidad que ofrecen integración con CHM, pero puede que necesite saber algunas cosas sobre los contenidos CHM para integrar satisfactoriamente el manual a su entorno.

El documento CHM es construido usando tablas de estilos XSL a partir de fuentes XML. Este hecho es único actualmente en la familia del Manual de PHP, ya que todas las otras versiones son generadas usando tablas de estilo DSSSL. Esto también quiere decir que pueden surgir algunas diferencias de visualización no intencionales. Un script especial de conversión es ejecutado sobre la salida XSLT, agregando varias características interesantes, y empaquetando el manual con los archivos de preferencias y muestras de skins.

Si nunca ha trabajado con CHMs, puede pensar en ellos como archivos comprimidos con soporte integrado del SO para el acceso a archivos y soporte adicional para búsquedas e índices. Aunque los archivos CHM sólo pueden consultarse usando el Visor de Ayuda HTML, se puede acceder directamente a archivos al interior de documentos CHM usando un prefijo de URL especial, el nombre del archivo CHM y el archivo que desea en el interior. Ya que todo el contenido de la ayuda es almacenado en archivos HTML, puede desplegar páginas del CHM en Internet Explorer.

Asumiendo que usted colocó su archivo php_manual_en.chm en c:\phpmanual, el archivo índice del manual (aquel que ve la primera vez) puede ser consultado con la siguiente URL: mk:@MSITStore:C:\phpmanual\php_manual_en.chm::/_index.html. Aquí, mk:@MSITStore: es el "protocolo" especial, C:\phpmanual\php_manual_en.chm es el documento CHM con su ruta completa. La parte /_index.html es la ruta al archivo índice dentro del CHM y :: es simplemente lo que necesita colocar entre la ruta CHM y ésta ruta de archivo.

Nota:

Todos los archivos se encuentran en el directorio raíz del CHM, a diferencia de versiones previas de CHM que incluían un directorio de lenguaje. Las imágenes, tables de estilos y otros archivos suplementarios tienen nombres que inician con un caracter de subrayado (como ocurre con el índice principal mostrado anteriormente), para evitar colisiones de nombres.

Los nombres de los archivos generados siguen las mismas reglas que el manual en línea, excepto que la extensión es .html y no .php. La más importante es que los archivos de documentación de funciones reciben nombres de la forma function.FUNCNAME.html, en donde FUNCNAME es el nombre de la función, con todos los signos de subrayado convertidos en guiones. Algunos ejemplos son function.echo.html, function.mysql-close.html, function.imagecopy.html.

Usando toda esta información, usted puede mostrar una página del manual para una función solicitada por un usuario. Un ejemplo simple es incluido en la distribución, llamado php_quickref.hta. ésta es una » Aplicación HTML parA demostrar el simple proceso de mostrar una página del manual que hace referencia a una función. La función quickRef() definida allí cumple con esta tarea.

Si se quiere integrar el manual en un IDE sin soporte directo para el manual de PHP (en realidad, la conversión de signos de subrayado en guiones), puede usar el archivo _function.html incluido para acceder a una página de función, Este archivo es simplemente un enrutador, y puede ser parametrizado a través de la URL, como _function.html#mysql_close. Esta página le redireccionará a la página de la función mysql_close (function.mysql-close.html) automáticamente. Puede proveer la ruta completa de este archivo si su IDE soporta la ayuda sensible a contexto, y proveer la cadena especificada por el IDE como el parámetro. Un ejemplo de esto es la integración de UltraEdit 9 (vea la página web de edición).

El índice del manual (asequible a través de la pestaña de índice en el panel de navegación) puede ser usado también para propósitos de integración. Todas las páginas HTML son incluidas en el índice con sus títulos como términos de indexación (incluyendo páginas de descripción de funciones).

Si usted es un desarrollador de aplicaciones de escritorio y quiesiera integrar profundamente el CHM con su programa (como por ejemplo desplegando el árbol de la tabla de contenidos en el cuadro de ayuda de su IDE), puede encontrar más información en » http://www.helpware.net/, así como en otros recursos útiles. El sitio oficial del formato HTML Help se encuentra en » http://www.microsoft.com/download/en/details.aspx?id=21138.